Microsoft.Win32

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Microsoft.Win32 Namespace

Classes

Class | Description
Registry | To be supplied.
RegistryKey | This class is a registry encapsulation. To get an instance of a RegistryKey, use the static member getBaseKey, or use the Registry class's static members.

Enumerations

Enumeration | Description
RegistryHive | [To be supplied.]

Build number 1812.

© 2000 Microsoft Corporation. All rights reserved.


Registry Class

To be supplied.

Object
Registry

[Visual Basic]
NotInheritable Public Class Registry
[C#]
public sealed class Registry
[C++]
public __gc __sealed class Registry
[JScript]
public class Registry

Remarks

[To be supplied.]

Requirements

Namespace: Microsoft.Win32

Assembly: mscorlib.dll

See Also

Registry Members | Microsoft.Win32 Namespace


Registry Members

Public:

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

ClassesRoot | The Windows Registry base key HKEY_CLASSES_ROOT.
CurrentConfig | The Windows Registry base key HKEY_CURRENT_CONFIG.
CurrentUser | The Windows Registry base key HKEY_CURRENT_USER.
DynData | The Windows Registry base key HKEY_DYN_DATA.
LocalMachine | [To be supplied.]
PerformanceData | The Windows Registry base key HKEY_PERFORMANCE_DATA.
Users | The Windows Registry base key HKEY_USERS.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Registry Class | Microsoft.Win32 Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Registry Fields

The fields of the Registry class are listed below. For a complete list of Registry class members, see the Registry Members topic.

Public:

ClassesRoot | The Windows Registry base key HKEY_CLASSES_ROOT.
CurrentConfig | The Windows Registry base key HKEY_CURRENT_CONFIG.
CurrentUser | The Windows Registry base key HKEY_CURRENT_USER.
DynData | The Windows Registry base key HKEY_DYN_DATA.
LocalMachine | [To be supplied.]
PerformanceData | The Windows Registry base key HKEY_PERFORMANCE_DATA.
Users | The Windows Registry base key HKEY_USERS.

See Also

Registry Class | Microsoft.Win32 Namespace


Registry.ClassesRoot

The Windows Registry base key HKEY_CLASSES_ROOT.

[Visual Basic]
Public Shared ReadOnly ClassesRoot As RegistryKey
[C#]
public static readonly RegistryKey ClassesRoot;
[C++]
public: static readonly RegistryKey* ClassesRoot;
[JScript]
public static var ClassesRoot : RegistryKey;

See Also

Registry Class | Registry Members | Microsoft.Win32 Namespace


Registry.CurrentConfig

The Windows Registry base key HKEY_CURRENT_CONFIG.

[Visual Basic]
Public Shared ReadOnly CurrentConfig As RegistryKey
[C#]
public static readonly RegistryKey CurrentConfig;
[C++]
public: static readonly RegistryKey* CurrentConfig;
[JScript]
public static var CurrentConfig : RegistryKey;

See Also

Registry Class | Registry Members | Microsoft.Win32 Namespace


Registry.CurrentUser

The Windows Registry base key HKEY_CURRENT_USER.

[Visual Basic]
Public Shared ReadOnly CurrentUser As RegistryKey
[C#]
public static readonly RegistryKey CurrentUser;
[C++]
public: static readonly RegistryKey* CurrentUser;
[JScript]
public static var CurrentUser : RegistryKey;

See Also

Registry Class | Registry Members | Microsoft.Win32 Namespace


Registry.DynData

The Windows Registry base key HKEY_DYN_DATA.

[Visual Basic]
Public Shared ReadOnly DynData As RegistryKey
[C#]
public static readonly RegistryKey DynData;
[C++]
public: static readonly RegistryKey* DynData;
[JScript]
public static var DynData : RegistryKey;

See Also

Registry Class | Registry Members | Microsoft.Win32 Namespace


Registry.LocalMachine

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly LocalMachine As RegistryKey
[C#]
public static readonly RegistryKey LocalMachine;
[C++]
public: static readonly RegistryKey* LocalMachine;
[JScript]
public static var LocalMachine : RegistryKey;

See Also

Registry Class | Registry Members | Microsoft.Win32 Namespace


Registry.PerformanceData

The Windows Registry base key HKEY_PERFORMANCE_DATA.

[Visual Basic]
Public Shared ReadOnly PerformanceData As RegistryKey
[C#]
public static readonly RegistryKey PerformanceData;
[C++]
public: static readonly RegistryKey* PerformanceData;
[JScript]
public static var PerformanceData : RegistryKey;

See Also

Registry Class | Registry Members | Microsoft.Win32 Namespace


Registry.Users

The Windows Registry base key HKEY_USERS.

[Visual Basic]
Public Shared ReadOnly Users As RegistryKey
[C#]
public static readonly RegistryKey Users;
[C++]
public: static readonly RegistryKey* Users;
[JScript]
public static var Users : RegistryKey;

See Also

Registry Class | Registry Members | Microsoft.Win32 Namespace


RegistryHive Enumeration

[To be supplied.]

[Visual Basic]
Public Enum RegistryHive
[C#]
public enum RegistryHive
[C++]
public enum RegistryHive

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
ClassesRoot | [To be supplied.]
CurrentConfig | [To be supplied.]
CurrentUser | [To be supplied.]
DynData | [To be supplied.]
LocalMachine | [To be supplied.]
PerformanceData | [To be supplied.]
Users | [To be supplied.]

Requirements

Namespace: Microsoft.Win32

Assembly: mscorlib.dll

See Also

Microsoft.Win32 Namespace


RegistryKey Class

This class is a registry encapsulation. To get an instance of a RegistryKey, use the static member getBaseKey, or use the Registry class's static members.

Object
RegistryKey

[Visual Basic]
NotInheritable Public Class RegistryKey
[C#]
public sealed class RegistryKey
[C++]
public __gc __sealed class RegistryKey
[JScript]
public class RegistryKey

Remarks

[To be supplied.]

Requirements

Namespace: Microsoft.Win32

Assembly: mscorlib.dll

Example

[C++]
#import <mscorlib.dll>
using namespace Microsoft::Win32;

void main ()
{
RegistryKey * pRegKey = Registry::LocalMachine;
pRegKey = pRegKey->OpenSubKey(L"HARDWARE\\DESCRIPTION\\System\\CentralProcessor\\0");
Object *pValue = pRegKey->GetValue(L"VendorIdentifier");
Console::WriteLine(L"The central processor of this machine is: {0}.", pValue);
}

See Also

RegistryKey Members | Microsoft.Win32 Namespace


RegistryKey Members

Public:

Properties

Name | Retrieves the name of the key.
SubKeyCount | Retrieves the count of subkeys.
ValueCount | Retrieves the count of values in the key.

Methods

Close | Closes this key and flushes it to disk if the contents have been modified.
CreateSubKey | Creates a new subkey or opens an existing subkey. The string subKey is not case sensitive.
DeleteSubKey | Deletes the specified subkey. To delete child subkeys, use DeleteSubKeyTree. The string subKey is not case sensitive.
DeleteSubKeyTree | Recursively deletes a subkey and any child subkeys. The string subKey is not case sensitive.
DeleteValue | Deletes the specified value from this key. The string subKey is not case sensitive.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubKeyNames | Retrieves an array of strings containing all the subkey names.
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | Overloaded. Retrieves the specified value.
GetValueNames | Retrieves an array of strings containing all the value names.
OpenRemoteBaseKey | Opens a new RegistryKey that represents the requested key on a foreign machine.
OpenSubKey | Overloaded. Retrieves a subkey.
SetValue | Sets the specified value. The string subKey is not case sensitive.
ToString | Retrieves a string representation of this key.

Protected:

Methods

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RegistryKey Class | Microsoft.Win32 Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RegistryKey Properties

The properties of the RegistryKey class are listed below. For a complete list of RegistryKey class members, see the RegistryKey Members topic.

Public:

Name | Retrieves the name of the key.
SubKeyCount | Retrieves the count of subkeys.
ValueCount | Retrieves the count of values in the key.

See Also

RegistryKey Class | Microsoft.Win32 Namespace


RegistryKey.Name

Retrieves the name of the key.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}
[C++]
public: __property String* get_Name();
[JScript]
public function get Name() : String;

See Also

RegistryKey Class | RegistryKey Members | Microsoft.Win32 Namespace


RegistryKey.SubKeyCount

Retrieves the count of subkeys.

[Visual Basic]
Public ReadOnly Property SubKeyCount As Integer
[C#]
public int SubKeyCount {get;}
[C++]
public: __property int get_SubKeyCount();
[JScript]
public function get SubKeyCount() : int;

Exceptions

Exception Type | Condition
SecurityException | If the user does not have read permission for the key.

Remarks

This property finds subkeys only at the base level, and does not recurse to lower levels.

See Also

RegistryKey Class | RegistryKey Members | Microsoft.Win32 Namespace


RegistryKey.ValueCount

Retrieves the count of values in the key.

[Visual Basic]
Public ReadOnly Property ValueCount As Integer
[C#]
public int ValueCount {get;}
[C++]
public: __property int get_ValueCount();
[JScript]
public function get ValueCount() : int;

Exceptions

Exception Type | Condition
SecurityException | If the user does not have read permission for the key.

See Also

RegistryKey Class | RegistryKey Members | Microsoft.Win32 Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RegistryKey Methods

The methods of the RegistryKey class are listed below. For a complete list of RegistryKey class members, see the RegistryKey Members topic.

Public:

Close | Closes this key and flushes it to disk if the contents have been modified.
CreateSubKey | Creates a new subkey or opens an existing subkey. The string subKey is not case sensitive.
DeleteSubKey | Deletes the specified subkey. To delete child subkeys, use DeleteSubKeyTree. The string subKey is not case sensitive.
DeleteSubKeyTree | Recursively deletes a subkey and any child subkeys. The string subKey is not case sensitive.
DeleteValue | Deletes the specified value from this key. The string subKey is not case sensitive.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubKeyNames | Retrieves an array of strings containing all the subkey names.
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | Overloaded. Retrieves the specified value.
GetValueNames | Retrieves an array of strings containing all the value names.
OpenRemoteBaseKey | Opens a new RegistryKey that represents the requested key on a foreign machine.
OpenSubKey | Overloaded. Retrieves a subkey.
SetValue | Sets the specified value. The string subKey is not case sensitive.
ToString | Retrieves a string representation of this key.

Protected:

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RegistryKey Class | Microsoft.Win32 Namespace


RegistryKey.Close

Closes this key and flushes it to disk if the contents have been modified.

[Visual Basic]
Public Sub Close()
[C#]
public void Close();
[C++]
public: void Close();
[JScript]
public function Close();

See Also

RegistryKey Class | RegistryKey Members | Microsoft.Win32 Namespace


RegistryKey.CreateSubKey

Creates a new subkey or opens an existing subkey. The string subKey is not case sensitive.

[Visual Basic]
Public Function CreateSubKey( _
   ByVal subkey As String _
) As RegistryKey
[C#]
public RegistryKey CreateSubKey(
   string subkey
);
[C++]
public: RegistryKey* CreateSubKey(
   String* subkey
);
[JScript]
public function CreateSubKey(
   subkey : String
) : RegistryKey;

Parameters

subkey
Name or path of subkey to create or open.

Return Value

Returns the subkey or null if the operation failed.

Exceptions

Exception Type | Condition
ArgumentNullException | If subkey is null.
SecurityException | if the user does not have RegistryPermission.SetInclude(create, currentKey) or RegistryPermission.SetInclude(open, currentKey) access.

Remarks

The user must have permission at this level and below.

See Also

RegistryKey Class | RegistryKey Members | Microsoft.Win32 Namespace


RegistryKey.DeleteSubKey

Deletes the specified subkey. To delete child subkeys, use DeleteSubKeyTree. The string subKey is not case sensitive.

[Visual Basic]
Public Sub DeleteSubKey( _
   ByVal subkey As String _
)
[C#]
public void DeleteSubKey(
   string subkey
);
[C++]
public: void DeleteSubKey(
   String* subkey
);
[JScript]
public function DeleteSubKey(
   subkey : String
);

Parameters

subkey
Name of the subkey to delete.

Exceptions

Exception Type | Condition
InvalidOperationException | thrown if the subkey has child subkeys.
ArgumentNullException | thrown if the subkey is null.
SecurityException | if the user does not have RegistryPermission.SetInclude(delete, currentKey) access.

Remarks

This function must perform identically in Win95 and NT, so do explicit checking for child subkeys, as this is not illegal in Win95.

See Also

RegistryKey Class | RegistryKey Members | Microsoft.Win32 Namespace


RegistryKey.DeleteSubKeyTree

Recursively deletes a subkey and any child subkeys. The string subKey is not case sensitive.

[Visual Basic]
Public Sub DeleteSubKeyTree( _
   ByVal subkey As String _
)
[C#]
public void DeleteSubKeyTree(
   string subkey
);
[C++]
public: void DeleteSubKeyTree(
   String* subkey
);
[JScript]
public function DeleteSubKeyTree(
   subkey : String
);

Parameters

subkey
Subkey to delete.

Exceptions

Exception Type | Condition
InvalidArgumentException | if deletion of a root hive is attempted.
ArgumentException | if subkey does not match a valid registry subkey.
ArgumentNullException | if subkey is null.
SecurityException | if user does not have RegistryPermission.SetInclude(delete, currentKey) access.

See Also

RegistryKey Class | RegistryKey Members | Microsoft.Win32 Namespace


RegistryKey.DeleteValue

Deletes the specified value from this key. The string subKey is not case sensitive.

[Visual Basic]
Public Sub DeleteValue( _
   ByVal name As String _
)
[C#]
public void DeleteValue(
   string name
);
[C++]
public: void DeleteValue(
   String* name
);
[JScript]
public function DeleteValue(
   name : String
);

Parameters

name
Name of the value to delete.

Exceptions

Exception Type | Condition
ArgumentException | if name is not a valid reference to a value.
SecurityException | if the user does not have RegistryPermission.SetInclude(delete, currentKey) access.

See Also

RegistryKey Class | RegistryKey Members | Microsoft.Win32 Namespace


RegistryKey.Finalize

[To be supplied.]

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

RegistryKey Class | RegistryKey Members | Microsoft.Win32 Namespace


RegistryKey.GetSubKeyNames

Retrieves an array of strings containing all the subkey names.

[Visual Basic]
Public Function GetSubKeyNames() As String ()
[C#]
public string[] GetSubKeyNames();
[C++]
public: String* GetSubKeyNames() [];
[JScript]
public function GetSubKeyNames() : String[];

Return Value

All subkey names.

Exceptions

Exception Type | Condition
SecurityException | The user does not have RegistryPermission.SetInclude(read, currentKey) access.

Remarks

This method does not recursively find names. It only returns the names on the base level it was called from.

See Also

RegistryKey Class | RegistryKey Members | Microsoft.Win32 Namespace


RegistryKey.GetValue

Retrieves the specified value.

Overload List

Retrieves the specified value, and returns defaultValue if the value doesn't exist. The string name is not case sensitive.

[Visual Basic] Overloads Public Function GetValue(String, Object) As Object
[C#] public object GetValue(String, Object);
[C++] public: Object* GetValue(String*, Object);
[JScript] public function GetValue(String, Object) : Object;

Retrieves the specified value, and returns null if the value doesn't exist. The string name is not case sensitive.

[Visual Basic] Overloads Public Function GetValue(String) As Object
[C#] public object GetValue(String);
[C++] public: Object* GetValue(String*);
[JScript] public function GetValue(String) : Object;

See Also

RegistryKey Class | RegistryKey Members | Microsoft.Win32 Namespace


RegistryKey.GetValue (String, Object)

Retrieves the specified value, and returns defaultValue if the value doesn't exist. The string name is not case sensitive.

[Visual Basic]
Overloads Public Function GetValue( _
   ByVal name As String, _
   ByVal defaultValue As Object _
) As Object
[C#]
public object GetValue(
   string name,
   object defaultValue
);
[C++]
public: Object* GetValue(
   String* name,
   Object* defaultValue
);
[JScript]
public function GetValue(
   name : String,
   defaultValue : Object
) : Object;

Parameters

name
Name of value to retrieve.
defaultValue
[To be supplied.]

See Also

RegistryKey Class | RegistryKey Members | Microsoft.Win32 Namespace | RegistryKey.GetValue Overload List


RegistryKey.GetValue (String)

Retrieves the specified value, and returns null if the value doesn't exist. The string name is not case sensitive.

[Visual Basic]
Overloads Public Function GetValue( _
   ByVal name As String _
) As Object
[C#]
public object GetValue(
   string name
);
[C++]
public: Object* GetValue(
   String* name
);
[JScript]
public function GetValue(
   name : String
) : Object;

Parameters

name
Name of the value to retrieve.

Return Value

The data associated with the value. Returns null if the the value doesn't exist.

See Also

RegistryKey Class | RegistryKey Members | Microsoft.Win32 Namespace | RegistryKey.GetValue Overload List


RegistryKey.GetValueNames

Retrieves an array of strings containing all the value names.

[Visual Basic]
Public Function GetValueNames() As String ()
[C#]
public string[] GetValueNames();
[C++]
public: String* GetValueNames() [];
[JScript]
public function GetValueNames() : String[];

Exceptions

Exception Type | Condition
SecurityException | The user does not have RegistryPermission.SetInclude(read, currentKey) access.

See Also

RegistryKey Class | RegistryKey Members | Microsoft.Win32 Namespace


RegistryKey.OpenRemoteBaseKey

Opens a new RegistryKey that represents the requested key on a foreign machine.

[Visual Basic]
Public Shared Function OpenRemoteBaseKey( _
   ByVal hKey As RegistryHive, _
   ByVal machineName As String _
) As RegistryKey
[C#]
public static RegistryKey OpenRemoteBaseKey(
   RegistryHive hKey,
   string machineName
);
[C++]
public: static RegistryKey* OpenRemoteBaseKey(
   RegistryHive hKey,
   String* machineName
);
[JScript]
public static function OpenRemoteBaseKey(
   hKey : RegistryHive,
   machineName : String
) : RegistryKey;

Parameters

hKey
HKEY to open. Provided by Win32.Registry class.
machineName
[To be supplied.]

Return Value

The requested RegistryKey.

Exceptions

Exception Type | Condition
ArgumentException | if hKey is invalid or if machineName is not found.
ArgumentNullException | if machine name is null.
SecurityException | if the user does not have access.

Remarks

The local machine registry is opened if String.Empty is passed as the machine name.

See Also

RegistryKey Class | RegistryKey Members | Microsoft.Win32 Namespace


RegistryKey.OpenSubKey

Retrieves a subkey.

Overload List

Retrieves a subkey. If writable is true, the key will be opened for reading and writing, otherwise, the key will be opened as read-only.

[Visual Basic] Overloads Public Function OpenSubKey(String, Boolean) As RegistryKey
[C#] public RegistryKey OpenSubKey(String, bool);
[C++] public: RegistryKey* OpenSubKey(String*, bool);
[JScript] public function OpenSubKey(String, Boolean) : RegistryKey;

Retrieves a subkey as read-only.

[Visual Basic] Overloads Public Function OpenSubKey(String) As RegistryKey
[C#] public RegistryKey OpenSubKey(String);
[C++] public: RegistryKey* OpenSubKey(String*);
[JScript] public function OpenSubKey(String) : RegistryKey;

See Also

RegistryKey Class | RegistryKey Members | Microsoft.Win32 Namespace


RegistryKey.OpenSubKey (String, Boolean)

Retrieves a subkey. If writable is true, the key will be opened for reading and writing, otherwise, the key will be opened as read-only.

[Visual Basic]
Overloads Public Function OpenSubKey( _
   ByVal name As String, _
   ByVal writable As Boolean _
) As RegistryKey
[C#]
public RegistryKey OpenSubKey(
   string name,
   bool writable
);
[C++]
public: RegistryKey* OpenSubKey(
   String* name,
   bool writable
);
[JScript]
public function OpenSubKey(
   name : String,
   writable : Boolean
) : RegistryKey;

Parameters

name
Name or path of subkey to open.
writable
[To be supplied.]

Return Value

The subkey requested, or NULL if the operation failed.

See Also

RegistryKey Class | RegistryKey Members | Microsoft.Win32 Namespace | RegistryKey.OpenSubKey Overload List


RegistryKey.OpenSubKey (String)

Retrieves a subkey as read-only.

[Visual Basic]
Overloads Public Function OpenSubKey( _
   ByVal name As String _
) As RegistryKey
[C#]
public RegistryKey OpenSubKey(
   string name
);
[C++]
public: RegistryKey* OpenSubKey(
   String* name
);
[JScript]
public function OpenSubKey(
   name : String
) : RegistryKey;

Parameters

name
Name or path of subkey to open.

Return Value

The subkey requested, or NULL if the operation failed.

See Also

RegistryKey Class | RegistryKey Members | Microsoft.Win32 Namespace | RegistryKey.OpenSubKey Overload List


RegistryKey.SetValue

Sets the specified value. The string subKey is not case sensitive.

[Visual Basic]
Public Sub SetValue( _
   ByVal name As String, _
   ByVal value As Object _
)
[C#]
public void SetValue(
   string name,
   object value
);
[C++]
public: void SetValue(
   String* name,
   Object* value
);
[JScript]
public function SetValue(
   name : String,
   value : Object
);

Parameters

name
Name of value to store data in.
value
[To be supplied.]

Return Value

Returns NULL if name is not found.

Exceptions

Exception Type | Condition
SecurityException | The user does not have RegistryPermission.SetInclude(write, currentKey) access.

Remarks

Values allowed in the registry are dword, binary, and string (multi_sz, expanded_sz, and sz).

See Also

RegistryKey Class | RegistryKey Members | Microsoft.Win32 Namespace


RegistryKey.ToString

Retrieves a string representation of this key.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

A string representing the key.

See Also

RegistryKey Class | RegistryKey Members | Microsoft.Win32 Namespace


System

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System Namespace

Classes

Class | Description
AccessException | Represents a failed attempt to access a type member (method, field, etc.).
Activator | The Activator class provides a standard way to create and obtain instances of objects in the NGWS runtime in a late bound way.
AppDomain The NGWS runtime allows multiple applications to run in a single process. Application domains are used to isolate the applications from one another. The AppDomain class provides methods that let NGWS runtime hosts perform the following tasks:
  • Enumerate the assemblies and threads in a domain.
  • Define dynamic assemblies in a domain.
  • Set events assembly loading and domain termination.
  • Load assemblies and types into the domain.
  • Terminate the domain.
AppDomainFlags | Represents assembly binding information that can be added to an AppDomain. The members are used with the GetData and SetData methods to identify the AppDomain data to be used.
AppDomainUnloadedException | Initializes a new instance of the AppDomainUnloadedException.
AppDomainUnloadInProgressException | Initializes a new instance of the AppDomainUnloadInProgressException.
ApplicationException | Represents non-fatal application errors.
ArgumentException | Represents an exception that is thrown when a method is invoked and one of the arguments is not valid.
ArgumentNullException | Represents the exception that is thrown when a null argument passed to a method that does not accept it.
ArgumentOutOfRangeException | Represents an exception that is thrown when the argument is outside the allowed values of the method that is invoked.
ArithmeticException | Represents an exception that is thrown when overflow or underflow occurs.
Array | Provides methods for creating, manipulating, searching, and sorting arrays. This is the base class for all arrays in the system.
ArrayTypeMismatchException | Represents an exception that is thrown when an attempt is made to store an object of the wrong type within an array.
Attribute Custom attributes add user-defined annotations to the metadata. Custom attributes allow an instance of a type to be stored with any element of the metadata. This mechanism can be used to store application specific information at compile time and access it either at runtime or when another tool reads the metadata. While any user-defined type can be used as an attribute it is expected that most attributes will be instances of types whose parent is System.Attribute. The NGWS runtime predefines some attribute types and uses them to control runtime behavior. Some languages predefine attribute types to represent language features not directly represented in the VOS. Users or other tools are welcome to define and use additional attribute types.

All Attributes inherit (directly or indirectly) from System.Attribute. This common base class gives all Attributes a central point in the hierarchy from which they can inherit. Compilers and other development tools use this information to identify which types are Custom Attributes

Just inheriting from System.Attribute gives an attribute certain default behaviors: Allowed on any element, Inheritable, duplicate instances are not allowed.
AttributeUsageAttribute | [To be supplied.]
BadImageFormatException | [To be supplied.]
BitConverter | Converts arrays of unsigned bytes to and from the base data types.
Buffer | Provides access to unmanaged memory.
CallContext This class exposes the API for the users of call context. All methods in CallContext are static and operate upon the call context in the Thread.

NOTE: CallContext is a specialized form of something that behaves like TLS for method calls. However, since the call objects may get serialized and deserialized along the path, it is tough to guarantee identity preservation.
CLSCompliantAttribute This attribute indicates if an element is compliant with the Common language specification or not.

In order to be CLS-compliant, a producer tool must have an option that enables users to produce only CLS-compliant types. Tool vendors may also wish to have an option that enables users to consume only CLS-compliant types, but this is not required for CLS-compliance.

In addition, the runtime SDK will provide a tool that verifies CLS compliance of any compiled library or executable.

The goal of the compiler switch and SDK tool is to give developers some indication of when they use features that are not guaranteed to be supported in all NGWS runtime programming languages.

The CLSCompliantAttribute indicates what assemblies are CLS compliant and what Types and Type members are not CLS Compliant in a compliant assembly.

Note: The CLSCompliantAttribute may not be applied to any member of an Interface or any abstract member of a base type as this would make the classes un-extensible.

There are two ways this custom attribute can be used:

On Assemblies- When applied to an Assembly, this attribute marks an Assembly as being CLS compliant. Unless otherwise noted all types defined in this assembly are assumed to be CLS compliant. Without this attribute, an assembly is considered to be non compliant, all type defined with in it are also considered to be non-compliant.

On Types and Type Members- This attribute may be applied to Types, Methods, Properties, Fields, or Events. It calls out those members of a CLS Compliant Assembly that are not compliant. Any member of CLS Compliant assembly that is not compliant must have a compliant alternative. The CLS compliance checking tools ignore any member that has this attribute. That is, no warning is given for violation in this member. This attribute is inherited by base classes.

For example: compiling code such as:

public int SetValue (unsigned int value);

would generate a CLS compliance warning because the type of value is not in the CLS.

However, if the method was defined as:

[CLSComplaintAttribute (false)] public int SetValue (unsigned int value); public int SetValue (long value);

No compiler warnings/errors would be generated.

This checking gets slightly more complicate when the parameter type is non-primitive type. For example:

public int SetValue (FooType value);

We have to know something about the parameter type (FooType) to know if this method is CLS compliant. We assume that types used in public interfaces but not defined in this compiland are CLS compliant if and only if:

1. The type is defined in an assembly that is marked with the System.CLSCompliantAttribute (true)

The type is not marked with the custom attribute System.CLSCompliantAttribute(false).

See the Common Langauge specification for more details.
Console Provides access to the standard input, standard output, and standard error streams. These streams are represented by Console.In, Console.Out, and Console.Error, respectively. They can be redirected via the SetIn, SetOut, and SetError methods.

The read methods provided by this class read from Console.In. They are provided as an alternative to directly invoking them on Console.In that is a StreamReader.

The write methods provided by this class write to Console.Out. They are provided as an alternative to directly invoking them on Console.Out that is a StreamWriter. Console.Error is also a StreamWriter.
ContextBoundObject | Defines the root type for all context bound types.
ContextMarshalException | Represents an exception that is thrown when the formal type and marshal style of the object are incompatible.
ContextStaticAttribute
Convert Converts base data types to other base data types.

A conversion that results in a loss of precision (narrowing conversion) will not return an exception; however, an exception will be returned if the resultant magnitude is out of range. For example, when a Double is converted to a Single, a loss of precision may occur, but an exception will not be thrown. However, if the Double is too large in magnitude to be represented by a Single, an exception will be thrown.
CoreException | Represents an exception that is thrown by the Runtime.
DBNull | Represents a null value.
Delegate | Represents a delegate, which is a data structure that refers to a static method or to an object instance and an instance method of that object.
DivideByZeroException | Represents an exception that is thrown when an attempt is made to divided by zero.
DuplicateWaitObjectException | Represents an exception that is thrown when for duplicate objects in WaitAll or Wait Any.
Empty | Represents an empty value.
EntryPointNotFoundException | Represents the exception class for class loading failures.
Enum | Provides the base class for enumerations.
Environment | Provides basic access to environment functionality.
EventArgs | The EventArgs is the base class for event data.
Exception | Represents the class that provides information required to handle and process errors.
ExecutionEngineException | Represents an exception that is thrown by the NGWS runtime when an error internal to the Execution Engine occurs.
FieldAccessException | Represents an exception that is thrown when there is a failed attempt to access a field.
FlagsAttribute Custom attribute to indicate that the enum should be treated as a bitfield (or set of flags). An IDE can use this information to provide a richer development experience.

Bitfeilds are allowed to be or'ed together; enum values are not.
FormatException | Represents an exception that is thrown when the format of an argument does not match the contract of its method.
GC | Provides methods for interacting with the memory management system, which performs garbage collection (GC) of objects that are no longer needed.
IndexOutOfRangeException | Represents an exception that is thrown when an attempt is made to access an array outside of its upper or lower bound.
InvalidCastException | Represents an exception that is thrown when an invalid cast occurs.
InvalidOperationException | Represents an exception that is thrown when a method is invoked and, due to the current state of the object involved, the invocation is invalid.
LocalDataStore | [To be supplied.]
LocalDataStoreMgr | [To be supplied.]
LocalDataStoreSlot | [To be supplied.]
LogicalCallContext | Reserved.
MarshalByRefObject | Base class for Remoting objects that need to be marshal by reference. This includes WellKnown SingleCall and WellKnown Singleton WebService objects and Client Activated Objects.
Math | Provides static methods for trigonometric, logarithmic, and other common mathematical functions. Overloaded methods are provided for use with standard base data types.
MethodAccessException | Represents an exception that is thrown when an attempt to access a method fails.
MissingFieldException | Represents an exception that is thrown when there is an attempt to access a nonexistent field.
MissingMemberException | Represents an exception that helps handle versioning problems with DLLs.
MissingMethodException | Represents the exception that is thrown when there is an attempt to access a nonexistent method.
MulticastDelegate Represents a multicast delegate, which is a delegate that can have an invocation list with more than one element. All multicast delegates are derived from this class.

A delegate that inherits directly from Delegate has an invocation list (a linked list of delegates that are to be invoked when the "invoke" method is called) with one element- itself. The Delegate.Combine and Delegate.Remove methods are used to create new invocation lists.
MulticastNotSupportedException | Represents the exception that is thrown when there is an attempt to add multiple callbacks to a non-multicast delegate.
NonSerializedAttribute | [To be supplied.]
NotFiniteNumberException | Represents an exception that helps handle numbers that are not valid.
NotImplementedException | [To be supplied.]
NotSupportedException | Represents the exception that is thrown to indicate that a method is not supported.
NullReferenceException | Represents the exception that is thrown when there is an attempt to dereference a null object reference.
Object | Supports all classes in the NGWS frameworks class hierarchy and provides low-level services to subclasses. This is the ultimate superclass of all classes in NGWS frameworks; it is the root of the type hierarchy.
ObsoleteAttribute | Represents an attribute that is attached to members that are not to be used any longer. Message is some human readable explanation of what to use. Error indicates whether the compiler should treat usage of such a method as an error.
OperatingSystem | Contains information about an operating system version. The information includes major version number, minor version numbers, a build number, a platform identifier, and descriptive text about the operating system.
OutOfMemoryException | Represents the exception that is thrown when there is not enough memory to continue the execution of a program.
OverflowException | Represents the exception that is thrown when an arithmetic operation results in an overflow.
ParamArrayAttribute | [To be supplied.]
Radix | The Radix class provides methods for converting numbers between different counting systems. Counting systems from base 2 (binary) through base 36 are supported.
Random Represents a pseudo-random-number generator, a device that meets certain statistical requirements and produces what is known as a sequence of pseudo-random numbers.

It generates numbers chosen with equal probability from a finite set of numbers. Because a mathematical algorithm is used, the numbers are not completely random but are sufficiently random for practical uses. The random number generation starts from a "seed." If the same seed is used repeatedly, the same series of numbers will be generated unless the seed is time-dependent, thereby producing a different series for each call.
RankException | Represents the exception that is thrown when an array with the wrong number of dimensions is passed to a method.
SerializableAttribute | [To be supplied.]
StackOverflowException | Represents the exception that is thrown when there is a stack overflow violation.
String | Represents a static string of characters.
SystemException | Represents non-fatal, "less severe" errors that may occur.
ThreadStaticAttribute | Provides for type member fields that are relative for the thread. Whenever the static field is accessed on a particular thread it will be unique or relative for that thread only. The static is not shared between threads. If the static field is access on another thread the field will contain a different value, since the field is unique per thread. Null initialization of thread local statics. The member field is marked with a custom attribute ThreadStaticAttribute.
TimeZone | [To be supplied.]
Type | Represents type declarations: class types, interface types, array types, value types, and enumeration types.
TypeInitializationException | Represents the exception thrown when type's class initializer throws an exception.
TypeLoadException | Retrieves messages when type-loading failures occur.
TypeUnloadedException | Represents an exception that is thrown when there is an attempt to access an unloaded class.
UnhandledExceptionEvent | Represents an exception event that was not handled by an application domain.
Value | [To be supplied.]
ValueType | Provides the base class for value types.
Version | Represents the version number for a NGWS runtime assembly.
WeakReference | Supports a weak reference.
WeakReferenceException | Represents an exception that is thrown when an attempt to access an invalid object reference encapsulated by a WeakReference object.

Interfaces

Interface | Description
IAsyncResult |
ICloneable | Supports cloning, which creates a new instance of a type with the same value as an existing instance. Only objects that implement ICloneable can be cloned.
IComparable | Provides functionality to compare objects and to sort arrays and collections.
IConvertible | [To be supplied.]
ICustomFormatter | This interface is implemented by classes that special formatting.
IFormattable | Provides functionality to format the value of an object.
ILogicalThreadAffinative | [To be supplied.]
IServiceObjectProvider | Provides a mechanism for retrieving a service object, which provides a service to other objects. Services are identified using Type objects.

Structures

Structure | Description
ArgIterator | Represents a variable argument list. You can use this class to step through the argument list of a function that takes a variable number of arguments. It is very likely that most compilers will hide the complexity of ArgIterator under language syntax. See the example below. Functions that require variable length argument lists are declared using the ellipsis (...) in the argument list.
Boolean | Represents the Boolean value, which is either true or false.
Byte | Represents an unsigned byte (1-byte uint) value.
Char | Represents a character value.
Currency | OBSOLETE. Use Decimal class intead. Represents a currency value.
DateTime | Represents a date and time value.
Decimal | Represents a decimal value.
Double | Represents a 64-bit, double precision, floating point number.
Guid | Represents a globally unique identifier (GUID). GUIDs can be used wherever a unique identifier is required.
Int16 | Represents a 16-bit signed integer.
Int32 | Represents a 32-bit signed integer.
Int64 | Represents a 64-bit signed integer.
ParamArray | Presents an array-like abstraction over the arguments to a varargs function call. This is a value type.
RuntimeArgumentHandle | To be supplied.
RuntimeFieldHandle | The RuntimeFieldHandle is a handle to the internal metadata representation of a field.
RuntimeMethodHandle | The RuntimeMethodHandle is a handle to the internal metadata representation of a method.
RuntimeTypeHandle | The RuntimeTypeHandle is a handle to the internal metadata representation of a type.
SByte | Represents a 8-bit signed integer .
Single | Represents a four-byte, single precision, floating point number.
TimeSpan | Represents a period of time.
TypedReference | TypedReferences are used to describe objects that contain both a managed pointer to a location and a runtime representation of the type that may be stored at that location. TypedReferences can be used for parameters and local variables. It is a built-in value type.
UInt16 | Represents a 16-bit unsigned integer.
UInt32 | Represents a 32-bit unsigned integer.
UInt64 | Represents an 64-bit unsigned integer integer.
Void | Indicates that a method has the void return type. This class is used in the System.Reflection namespace. Instances of this class cannot be created, and the class has no members.

Delegates

Delegate | Description
AsyncCallback | Delegate for methods that complete asynchronously.
EventHandler | Delegate for Events.
UnhandledExceptionEventHandler | Exception handler for an event that is not handled by an application domain.

Enumerations

Enumeration | Description
AttributeTargets | Specifies all the elements of the VOS to which it is valid to attach the attribute.
PlatformID | Describes the platforms supported by an assembly. These flags are used to bind to an assembly.
TypeCode | [To be supplied.]


AccessException Class

Represents a failed attempt to access a type member (method, field, etc.).

Object
Exception
SystemException
AccessException

[Visual Basic]
Public Class AccessException
   Inherits SystemException
[C#]
public class AccessException : SystemException
[C++]
public __gc class AccessException : public SystemException
[JScript]
public class AccessException extends SystemException

Remarks

AccessException is thrown by the following methods: Invoke of the System.Reflection Namespace classes (see ConstructorInfo, MethodInfo, etc.), GetValue and SetValue of the FieldInfo, DynamicInvoke of the delegate classes (see Delegate).

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

AccessException Members | System Namespace


AccessException Members

Public:

Constructor

AccessException Constructor Overloaded. Initializes a new instance of the AccessException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

AccessException Class | System Namespace


AccessException Constructor

Initializes a new instance of the AccessException class.

Overload List

Initializes a new instance of the AccessException class.

[Visual Basic] Overloads Public Sub New()
[C#] public AccessException();
[C++] public: AccessException();
[JScript] public function AccessException();

Initializes a new instance of the AccessException class with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public AccessException(String);
[C++] public: AccessException(String*);
[JScript] public function AccessException(String);

Initializes a new instance of AccessException with a specified message and indicates the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public AccessException(String, Exception);
[C++] public: AccessException(String*, Exception);
[JScript] public function AccessException(String, Exception);

See Also

AccessException Class | AccessException Members | System Namespace


AccessException Constructor ()

Initializes a new instance of the AccessException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public AccessException();
[C++]
public: AccessException();
[JScript]
public function AccessException();

Remarks

AccessException inherits from the Exception class. This constructor sets the properties of the new AccessException object as follows:

Property | Description
InnerException | null
Message | The message string.

See Also

AccessException Class | AccessException Members | System Namespace | AccessException Constructor Overload List


AccessException Constructor (String)

Initializes a new instance of the AccessException class with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public AccessException(
   string message
);
[C++]
public: AccessException(
   String* message
);
[JScript]
public function AccessException(
   message : String
);

Parameters

message
The message that identifies the reason the exception occurred.

Remarks

AccessException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property | Description
InnerException | null
Message | The empty string.

See Also

AccessException Class | AccessException Members | System Namespace | AccessException Constructor Overload List


AccessException Constructor (String, Exception)

Initializes a new instance of AccessException with a specified message and indicates the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public AccessException(
   string message,
   Exception inner
);
[C++]
public: AccessException(
   String* message,
   Exception* inner
);
[JScript]
public function AccessException(
   message : String,
   inner : Exception
);

Parameters

message
The message that indicates the reason the exception occurred.
inner
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

AccessException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property | Description
InnerException | The inner exception
Message | The message string.

See Also

AccessException Class | AccessException Members | System Namespace | AccessException Constructor Overload List


Activator Class

The Activator class provides a standard way to create and obtain instances of objects in the NGWS Runtime in a late bound way.

Object
Activator

[Visual Basic]
NotInheritable Public Class Activator
[C#]
public sealed class Activator
[C++]
public __gc __sealed class Activator
[JScript]
public class Activator

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

Activator Members | System Namespace


Activator Members

Public:

Constructor

Activator Constructor [To be supplied.]

Methods

CreateInstance | Overloaded. The CreateInstance methods create an instance of the object with full binding support. Variations of the method will allow the activation call site attributes to be passed as an array of objects. The activation can potentially occur remotely. Once the object has been activated remotely the CreateInstance will return.
CreateInstanceFrom | Overloaded. Creates a handle to an object from a particular assembly file and type name.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObject | Overloaded. The Activator.MarshalByRefObject methods provide the ability to obtain a "proxy" to an already running remote object Well Known object. Only when calls are made on the "proxy" will messages be sent remotely.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Activator Class | System Namespace


Activator Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public Activator();
[C++]
public: Activator();
[JScript]
public function Activator();

See Also

Activator Class | Activator Members | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Activator Methods

The methods of the Activator class are listed below. For a complete list of Activator class members, see the Activator Members topic.

Public:

CreateInstance | Overloaded. The CreateInstance methods create an instance of the object with full binding support. Variations of the method will allow the activation call site attributes to be passed as an array of objects. The activation can potentially occur remotely. Once the object has been activated remotely the CreateInstance will return.
CreateInstanceFrom | Overloaded. Creates a handle to an object from a particular assembly file and type name.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObject | Overloaded. The Activator.MarshalByRefObject methods provide the ability to obtain a "proxy" to an already running remote object Well Known object. Only when calls are made on the "proxy" will messages be sent remotely.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Activator Class | System Namespace


Activator.CreateInstance

The CreateInstance methods create an instance of the object with full binding support. Variations of the method will allow the activation call site attributes to be passed as an array of objects. The activation can potentially occur remotely. Once the object has been activated remotely the CreateInstance will return.

Overload List

Creates an instance using the name of the type and the assembly where it exists. This allows types to be created remotely without having to load the type locally. These will return an ObjectHandle that needs to be unwrapped in order to access the real object.

[Visual Basic] Overloads Public Shared Function CreateInstance(String, String) As ObjectHandle
[C#] public static ObjectHandle CreateInstance(String, String);
[C++] public: static ObjectHandle* CreateInstance(String*, String*);
[JScript] public static function CreateInstance(String, String) : ObjectHandle;

Calling this method is equivalent to calling the constructor on the class with no arguments (the default constructor). For example if the Type object represents the String class, calling CreateInstance() is equivalent to invoking the default String constructor. This would fail, however (a MissingMethodException would be thrown) because String does not have a default constructor.

Note: Access restrictions are ignored for fully trusted code. That is, private constructors, methods, fields, and properties can be accessed and invoked via Reflection whenever the code is fully trusted.

[Visual Basic] Overloads Public Shared Function CreateInstance(Type) As Object
[C#] public static object CreateInstance(Type);
[C++] public: static Object* CreateInstance(Type*);
[JScript] public static function CreateInstance(Type) : Object;

Creates an instance of a specified type using the specified constructor. The constructor that is to be invoked must be accessible and provide the most specific match with the specified argument list, under the constraints of the default binder.

[Visual Basic] Overloads Public Shared Function CreateInstance(Type, Object(), Object()) As Object
[C#] public static object CreateInstance(Type, Object[], Object[]);
[C++] public: static Object* CreateInstance(Type*, Object[], Object[]);
[JScript] public static function CreateInstance(Type, Object[], Object[]) : Object;

Creates an instance using the name of the type and the assembly where it exists. This allows types to be created remotely without having to load the type locally. These will return an ObjectHandle that needs to be unwrapped in order to access the real object.

[Visual Basic] Overloads Public Shared Function CreateInstance(String, String, Boolean, BindingFlags, Binder, Object(), CultureInfo, Boolean, Object(), Evidence) As ObjectHandle
[C#] public static ObjectHandle CreateInstance(String, String, bool, BindingFlags, Binder, Object[], CultureInfo, bool, Object[], Evidence);
[C++] public: static ObjectHandle* CreateInstance(String*, String*, bool, BindingFlags, Binder, Object[], CultureInfo, bool, Object[], Evidence);
[JScript] public static function CreateInstance(String, String, Boolean, BindingFlags, Binder, Object[], CultureInfo, Boolean, Object[], Evidence) : ObjectHandle;

Creates an instance using the name of the type and the assembly where it exists. This allows types to be created remotely without having to load the type locally. These will return an ObjectHandle that needs to be unwrapped in order to access the real object.

[Visual Basic] Overloads Public Shared Function CreateInstance(String, String, Boolean, Object()) As ObjectHandle
[C#] public static ObjectHandle CreateInstance(String, String, bool, Object[]);
[C++] public: static ObjectHandle* CreateInstance(String*, String*, bool, Object[]);
[JScript] public static function CreateInstance(String, String, Boolean, Object[]) : ObjectHandle;

Creates a handle to an object using the name of the type and the assembly where it exists. This allows types to be created remotely without having to load the type locally. These will return an ObjectHandle that needs to be unwrapped in order to access the real object.

[Visual Basic] Overloads Public Shared Function CreateInstance(String, String, Boolean) As ObjectHandle
[C#] public static ObjectHandle CreateInstance(String, String, bool);
[C++] public: static ObjectHandle* CreateInstance(String*, String*, bool);
[JScript] public static function CreateInstance(String, String, Boolean) : ObjectHandle;

Creates an instance of a specified type using the specified constructor. The constructor that is to be invoked must be accessible and provide the most specific match with the specified argument list, under the constraints of the default binder.

[Visual Basic] Overloads Public Shared Function CreateInstance(Type, Object()) As Object
[C#] public static object CreateInstance(Type, Object[]);
[C++] public: static Object* CreateInstance(Type*, Object[]);
[JScript] public static function CreateInstance(Type, Object[]) : Object;

Creates an instance of the specified type using the specified constructor. The constructor that is to be invoked must be accessible and provide the most specific match with the specified argument list, under the constraints of the specified binder and binding attributes.

[Visual Basic] Overloads Public Shared Function CreateInstance(Type, BindingFlags, Binder, Object(), CultureInfo) As Object
[C#] public static object CreateInstance(Type, BindingFlags, Binder, Object[], CultureInfo);
[C++] public: static Object* CreateInstance(Type*, BindingFlags, Binder, Object[], CultureInfo);
[JScript] public static function CreateInstance(Type, BindingFlags, Binder, Object[], CultureInfo) : Object;

Creates an instance of the specified type using the specified constructor. The constructor that is to be invoked must be accessible and provide the most specific match with the specified argument list, under the constraints of the specified binder and binding attributes.

[Visual Basic] Overloads Public Shared Function CreateInstance(Type, BindingFlags, Binder, Object(), CultureInfo, Object()) As Object
[C#] public static object CreateInstance(Type, BindingFlags, Binder, Object[], CultureInfo, Object[]);
[C++] public: static Object* CreateInstance(Type*, BindingFlags, Binder, Object[], CultureInfo, Object[]);
[JScript] public static function CreateInstance(Type, BindingFlags, Binder, Object[], CultureInfo, Object[]) : Object;

See Also

Activator Class | Activator Members | System Namespace


Activator.CreateInstance (String, String)

Creates an instance using the name of the type and the assembly where it exists. This allows types to be created remotely without having to load the type locally. These will return an ObjectHandle that needs to be unwrapped in order to access the real object.

[Visual Basic]
Overloads Public Shared Function CreateInstance( _
   ByVal assemblyName As String, _
   ByVal typeName As String _
) As ObjectHandle
[C#]
public static ObjectHandle CreateInstance(
   string assemblyName,
   string typeName
);
[C++]
public: static ObjectHandle* CreateInstance(
   String* assemblyName,
   String* typeName
);
[JScript]
public static function CreateInstance(
   assemblyName : String,
   typeName : String
) : ObjectHandle;

Parameters

assemblyName
The name of the assembly in which this object type resides.
typeName
[To be supplied.]

Return Value

A handle to the requested object.

See Also

Activator Class | Activator Members | System Namespace | Activator.CreateInstance Overload List


Activator.CreateInstance (Type)

Calling this method is equivalent to calling the constructor on the class with no arguments (the default constructor). For example if the Type object represents the String class, calling CreateInstance() is equivalent to invoking the default String constructor. This would fail, however (a MissingMethodException would be thrown) because String does not have a default constructor.

Note: Access restrictions are ignored for fully trusted code. That is, private constructors, methods, fields, and properties can be accessed and invoked via Reflection whenever the code is fully trusted.

[Visual Basic]
Overloads Public Shared Function CreateInstance( _
   ByVal type As Type _
) As Object
[C#]
public static object CreateInstance(
   Type type
);
[C++]
public: static Object* CreateInstance(
   Type* type
);
[JScript]
public static function CreateInstance(
   type : Type
) : Object;

Parameters

type
The Type designator for the class of object you want to create.

Return Value

A reference to the newly created object.

Exceptions

Exception Type | Condition
MissingMethodException | If no default constructor exists for the type.

See Also

Activator Class | Activator Members | System Namespace | Activator.CreateInstance Overload List


Activator.CreateInstance (Type, Object[], Object[])

Creates an instance of a specified type using the specified constructor. The constructor that is to be invoked must be accessible and provide the most specific match with the specified argument list, under the constraints of the default binder.

[Visual Basic]
Overloads Public Shared Function CreateInstance( _
   ByVal type As Type, _
   ByVal args() As Object, _
   ByVal activationAttributes() As Object _
) As Object
[C#]
public static object CreateInstance(
   Type type,
   object[] args,
   object[] activationAttributes
);
[C++]
public: static Object* CreateInstance(
   Type* type,
   Object* args[],
   Object* activationAttributes[]
);
[JScript]
public static function CreateInstance(
   type : Type,
   args : Object[],
   activationAttributes : Object[]
) : Object;

Parameters

type
The Type designator for the desired object.
args
[To be supplied.]
activationAttributes
[To be supplied.]

Return Value

A reference to the newly created object.

Exceptions

Exception Type | Condition
AccessException | The caller does not have sufficient permissions to call this method. An element of args does not meet the contract of the constructor being invoked.
TargetInvocationException | The constructor being called throws an exception.

See Also

Activator Class | Activator Members | System Namespace | Activator.CreateInstance Overload List


Activator.CreateInstance (String, String, Boolean, BindingFlags, Binder, Object[], CultureInfo, Boolean, Object[], Evidence)

Creates an instance using the name of the type and the assembly where it exists. This allows types to be created remotely without having to load the type locally. These will return an ObjectHandle that needs to be unwrapped in order to access the real object.

[Visual Basic]
Overloads Public Shared Function CreateInstance( _
   ByVal assemblyName As String, _
   ByVal typeName As String, _
   ByVal ignoreCase As Boolean, _
   ByVal bindingAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal args() As Object, _
   ByVal culture As CultureInfo, _
   ByVal shared As Boolean, _
   ByVal activationAttributes() As Object, _
   ByVal securityInfo As Evidence _
) As ObjectHandle
[C#]
public static ObjectHandle CreateInstance(
   string assemblyName,
   string typeName,
   bool ignoreCase,
   BindingFlags bindingAttr,
   Binder binder,
   object[] args,
   CultureInfo culture,
   bool shared,
   object[] activationAttributes,
   Evidence securityInfo
);
[C++]
public: static ObjectHandle* CreateInstance(
   String* assemblyName,
   String* typeName,
   bool ignoreCase,
   BindingFlags bindingAttr,
   Binder* binder,
   Object* args[],
   CultureInfo* culture,
   bool shared,
   Object* activationAttributes[],
   Evidence* securityInfo
);
[JScript]
public static function CreateInstance(
   assemblyName : String,
   typeName : String,
   ignoreCase : Boolean,
   bindingAttr : BindingFlags,
   binder : Binder,
   args : Object[],
   culture : CultureInfo,
   shared : Boolean,
   activationAttributes : Object[],
   securityInfo : Evidence
) : ObjectHandle;

Parameters

assemblyName
The name of the assembly in which this object type resides.
typeName
[To be supplied.]
ignoreCase
[To be supplied.]
bindingAttr
[To be supplied.]
binder
[To be supplied.]
args
[To be supplied.]
culture
[To be supplied.]
shared
[To be supplied.]
activationAttributes
[To be supplied.]
securityInfo
[To be supplied.]

Return Value

A handle to the requested object.

See Also

Activator Class | Activator Members | System Namespace | Activator.CreateInstance Overload List


Activator.CreateInstance (String, String, Boolean, Object[])

Creates an instance using the name of the type and the assembly where it exists. This allows types to be created remotely without having to load the type locally. These will return an ObjectHandle that needs to be unwrapped in order to access the real object.

[Visual Basic]
Overloads Public Shared Function CreateInstance( _
   ByVal assemblyname As String, _
   ByVal typeName As String, _
   ByVal shared As Boolean, _
   ByVal activationAttributes() As Object _
) As ObjectHandle
[C#]
public static ObjectHandle CreateInstance(
   string assemblyname,
   string typeName,
   bool shared,
   object[] activationAttributes
);
[C++]
public: static ObjectHandle* CreateInstance(
   String* assemblyname,
   String* typeName,
   bool shared,
   Object* activationAttributes[]
);
[JScript]
public static function CreateInstance(
   assemblyname : String,
   typeName : String,
   shared : Boolean,
   activationAttributes : Object[]
) : ObjectHandle;

Parameters

assemblyname
The name of the assembly in which this object type resides.
typeName
[To be supplied.]
shared
[To be supplied.]
activationAttributes
[To be supplied.]

Return Value

A handle to the requested object.

See Also

Activator Class | Activator Members | System Namespace | Activator.CreateInstance Overload List


Activator.CreateInstance (String, String, Boolean)

Creates a handle to an object using the name of the type and the assembly where it exists. This allows types to be created remotely without having to load the type locally. These will return an ObjectHandle that needs to be unwrapped in order to access the real object.

[Visual Basic]
Overloads Public Shared Function CreateInstance( _
   ByVal assemblyName As String, _
   ByVal typeName As String, _
   ByVal shared As Boolean _
) As ObjectHandle
[C#]
public static ObjectHandle CreateInstance(
   string assemblyName,
   string typeName,
   bool shared
);
[C++]
public: static ObjectHandle* CreateInstance(
   String* assemblyName,
   String* typeName,
   bool shared
);
[JScript]
public static function CreateInstance(
   assemblyName : String,
   typeName : String,
   shared : Boolean
) : ObjectHandle;

Parameters

assemblyName
The name of the assembly in which this object type resides.
typeName
[To be supplied.]
shared
[To be supplied.]

Return Value

A handle to the requested object.

See Also

Activator Class | Activator Members | System Namespace | Activator.CreateInstance Overload List


Activator.CreateInstance (Type, Object[])

Creates an instance of a specified type using the specified constructor. The constructor that is to be invoked must be accessible and provide the most specific match with the specified argument list, under the constraints of the default binder.

[Visual Basic]
Overloads Public Shared Function CreateInstance( _
   ByVal type As Type, _
   ByVal args() As Object _
) As Object
[C#]
public static object CreateInstance(
   Type type,
   object[] args
);
[C++]
public: static Object* CreateInstance(
   Type* type,
   Object* args[]
);
[JScript]
public static function CreateInstance(
   type : Type,
   args : Object[]
) : Object;

Parameters

type
The Type designator for the desired object.
args
[To be supplied.]

Return Value

A reference to the newly created object.

Exceptions

Exception Type | Condition
AccessException | The caller does not have sufficient permissions to call this method. An element of args does not meet the contract of the constructor being invoked.
TargetInvocationException | The constructor being called throws an exception.

See Also

Activator Class | Activator Members | System Namespace | Activator.CreateInstance Overload List


Activator.CreateInstance (Type, BindingFlags, Binder, Object[], CultureInfo)

Creates an instance of the specified type using the specified constructor. The constructor that is to be invoked must be accessible and provide the most specific match with the specified argument list, under the constraints of the specified binder and binding attributes.

[Visual Basic]
Overloads Public Shared Function CreateInstance( _
   ByVal type As Type, _
   ByVal bindingAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal args() As Object, _
   ByVal culture As CultureInfo _
) As Object
[C#]
public static object CreateInstance(
   Type type,
   BindingFlags bindingAttr,
   Binder binder,
   object[] args,
   CultureInfo culture
);
[C++]
public: static Object* CreateInstance(
   Type* type,
   BindingFlags bindingAttr,
   Binder* binder,
   Object* args[],
   CultureInfo* culture
);
[JScript]
public static function CreateInstance(
   type : Type,
   bindingAttr : BindingFlags,
   binder : Binder,
   args : Object[],
   culture : CultureInfo
) : Object;

Parameters

type
The Type designator for the class of object you want to create.
bindingAttr
[To be supplied.]
binder
[To be supplied.]
args
[To be supplied.]
culture
[To be supplied.]

Return Value

A reference to the newly created object.

Exceptions

Exception Type | Condition
AccessException | The caller does not have sufficient permissions to call this method.
TargetInvocationException | The constructor being called throws an exception.

See Also

Activator Class | Activator Members | System Namespace | Activator.CreateInstance Overload List


Activator.CreateInstance (Type, BindingFlags, Binder, Object[], CultureInfo, Object[])

Creates an instance of the specified type using the specified constructor. The constructor that is to be invoked must be accessible and provide the most specific match with the specified argument list, under the constraints of the specified binder and binding attributes.

[Visual Basic]
Overloads Public Shared Function CreateInstance( _
   ByVal type As Type, _
   ByVal bindingAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal args() As Object, _
   ByVal culture As CultureInfo, _
   ByVal activationAttributes() As Object _
) As Object
[C#]
public static object CreateInstance(
   Type type,
   BindingFlags bindingAttr,
   Binder binder,
   object[] args,
   CultureInfo culture,
   object[] activationAttributes
);
[C++]
public: static Object* CreateInstance(
   Type* type,
   BindingFlags bindingAttr,
   Binder* binder,
   Object* args[],
   CultureInfo* culture,
   Object* activationAttributes[]
);
[JScript]
public static function CreateInstance(
   type : Type,
   bindingAttr : BindingFlags,
   binder : Binder,
   args : Object[],
   culture : CultureInfo,
   activationAttributes : Object[]
) : Object;

Parameters

type
The Type designator for the class of object you want to create.
bindingAttr
[To be supplied.]
binder
[To be supplied.]
args
[To be supplied.]
culture
[To be supplied.]
activationAttributes
[To be supplied.]

Return Value

A reference to the newly created object.

Exceptions

Exception Type | Condition
AccessException | The caller does not have sufficient permissions to call this method.
TargetInvocationException | The constructor being called throws an exception.

See Also

Activator Class | Activator Members | System Namespace | Activator.CreateInstance Overload List


Activator.CreateInstanceFrom

Creates a handle to an object from a particular assembly file and type name.

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Shared Function CreateInstanceFrom(String, String, Boolean) As ObjectHandle
[C#] public static ObjectHandle CreateInstanceFrom(String, String, bool);
[C++] public: static ObjectHandle* CreateInstanceFrom(String*, String*, bool);
[JScript] public static function CreateInstanceFrom(String, String, Boolean) : ObjectHandle;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function CreateInstanceFrom(String, String, Boolean, Object()) As ObjectHandle
[C#] public static ObjectHandle CreateInstanceFrom(String, String, bool, Object[]);
[C++] public: static ObjectHandle* CreateInstanceFrom(String*, String*, bool, Object[]);
[JScript] public static function CreateInstanceFrom(String, String, Boolean, Object[]) : ObjectHandle;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function CreateInstanceFrom(String, String, Boolean, BindingFlags, Binder, Object(), CultureInfo, Boolean, Object(), Evidence) As ObjectHandle
[C#] public static ObjectHandle CreateInstanceFrom(String, String, bool, BindingFlags, Binder, Object[], CultureInfo, bool, Object[], Evidence);
[C++] public: static ObjectHandle* CreateInstanceFrom(String*, String*, bool, BindingFlags, Binder, Object[], CultureInfo, bool, Object[], Evidence);
[JScript] public static function CreateInstanceFrom(String, String, Boolean, BindingFlags, Binder, Object[], CultureInfo, Boolean, Object[], Evidence) : ObjectHandle;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function CreateInstanceFrom(String, String) As ObjectHandle
[C#] public static ObjectHandle CreateInstanceFrom(String, String);
[C++] public: static ObjectHandle* CreateInstanceFrom(String*, String*);
[JScript] public static function CreateInstanceFrom(String, String) : ObjectHandle;

See Also

Activator Class | Activator Members | System Namespace


Activator.CreateInstanceFrom (String, String, Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function CreateInstanceFrom( _
   ByVal assemblyFile As String, _
   ByVal typeName As String, _
   ByVal shared As Boolean _
) As ObjectHandle
[C#]
public static ObjectHandle CreateInstanceFrom(
   string assemblyFile,
   string typeName,
   bool shared
);
[C++]
public: static ObjectHandle* CreateInstanceFrom(
   String* assemblyFile,
   String* typeName,
   bool shared
);
[JScript]
public static function CreateInstanceFrom(
   assemblyFile : String,
   typeName : String,
   shared : Boolean
) : ObjectHandle;

Parameters

assemblyFile
[To be supplied.]
typeName
[To be supplied.]
shared
[To be supplied.]

Return Value

A handle to the desired object.

See Also

Activator Class | Activator Members | System Namespace | Activator.CreateInstanceFrom Overload List


Activator.CreateInstanceFrom (String, String, Boolean, Object[])

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function CreateInstanceFrom( _
   ByVal assemblyFile As String, _
   ByVal typeName As String, _
   ByVal shared As Boolean, _
   ByVal activationAttributes() As Object _
) As ObjectHandle
[C#]
public static ObjectHandle CreateInstanceFrom(
   string assemblyFile,
   string typeName,
   bool shared,
   object[] activationAttributes
);
[C++]
public: static ObjectHandle* CreateInstanceFrom(
   String* assemblyFile,
   String* typeName,
   bool shared,
   Object* activationAttributes[]
);
[JScript]
public static function CreateInstanceFrom(
   assemblyFile : String,
   typeName : String,
   shared : Boolean,
   activationAttributes : Object[]
) : ObjectHandle;

Parameters

assemblyFile
[To be supplied.]
typeName
[To be supplied.]
shared
[To be supplied.]
activationAttributes
[To be supplied.]

See Also

Activator Class | Activator Members | System Namespace | Activator.CreateInstanceFrom Overload List


Activator.CreateInstanceFrom (String, String, Boolean, BindingFlags, Binder, Object[], CultureInfo, Boolean, Object[], Evidence)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function CreateInstanceFrom( _
   ByVal assemblyFile As String, _
   ByVal typeName As String, _
   ByVal ignoreCase As Boolean, _
   ByVal bindingAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal args() As Object, _
   ByVal culture As CultureInfo, _
   ByVal shared As Boolean, _
   ByVal activationAttributes() As Object, _
   ByVal securityInfo As Evidence _
) As ObjectHandle
[C#]
public static ObjectHandle CreateInstanceFrom(
   string assemblyFile,
   string typeName,
   bool ignoreCase,
   BindingFlags bindingAttr,
   Binder binder,
   object[] args,
   CultureInfo culture,
   bool shared,
   object[] activationAttributes,
   Evidence securityInfo
);
[C++]
public: static ObjectHandle* CreateInstanceFrom(
   String* assemblyFile,
   String* typeName,
   bool ignoreCase,
   BindingFlags bindingAttr,
   Binder* binder,
   Object* args[],
   CultureInfo* culture,
   bool shared,
   Object* activationAttributes[],
   Evidence* securityInfo
);
[JScript]
public static function CreateInstanceFrom(
   assemblyFile : String,
   typeName : String,
   ignoreCase : Boolean,
   bindingAttr : BindingFlags,
   binder : Binder,
   args : Object[],
   culture : CultureInfo,
   shared : Boolean,
   activationAttributes : Object[],
   securityInfo : Evidence
) : ObjectHandle;

Parameters

assemblyFile
[To be supplied.]
typeName
[To be supplied.]
ignoreCase
[To be supplied.]
bindingAttr
[To be supplied.]
binder
[To be supplied.]
args
[To be supplied.]
culture
[To be supplied.]
shared
[To be supplied.]
activationAttributes
[To be supplied.]
securityInfo
[To be supplied.]

See Also

Activator Class | Activator Members | System Namespace | Activator.CreateInstanceFrom Overload List


Activator.CreateInstanceFrom (String, String)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function CreateInstanceFrom( _
   ByVal assemblyFile As String, _
   ByVal typeName As String _
) As ObjectHandle
[C#]
public static ObjectHandle CreateInstanceFrom(
   string assemblyFile,
   string typeName
);
[C++]
public: static ObjectHandle* CreateInstanceFrom(
   String* assemblyFile,
   String* typeName
);
[JScript]
public static function CreateInstanceFrom(
   assemblyFile : String,
   typeName : String
) : ObjectHandle;

Parameters

assemblyFile
The file containing the desired object's assembly.
typeName
[To be supplied.]

Return Value

A handle to the requested object.

See Also

Activator Class | Activator Members | System Namespace | Activator.CreateInstanceFrom Overload List


Activator.GetObject

The Activator.MarshalByRefObject methods provide the ability to obtain a "proxy" to an already running remote object Well Known object. Only when calls are made on the "proxy" will messages be sent remotely.

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Shared Function GetObject(Type, String, Object) As MarshalByRefObject
[C#] public static MarshalByRefObject GetObject(Type, String, Object);
[C++] public: static MarshalByRefObject* GetObject(Type*, String, Object);
[JScript] public static function GetObject(Type, String, Object) : MarshalByRefObject;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function GetObject(Type, String) As MarshalByRefObject
[C#] public static MarshalByRefObject GetObject(Type, String);
[C++] public: static MarshalByRefObject* GetObject(Type*, String);
[JScript] public static function GetObject(Type, String) : MarshalByRefObject;

See Also

Activator Class | Activator Members | System Namespace


Activator.GetObject (Type, String, Object)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function GetObject( _
   ByVal type As Type, _
   ByVal url As String, _
   ByVal state As Object _
) As MarshalByRefObject
[C#]
public static MarshalByRefObject GetObject(
   Type type,
   string url,
   object state
);
[C++]
public: static MarshalByRefObject* GetObject(
   Type* type,
   String* url,
   Object* state
);
[JScript]
public static function GetObject(
   type : Type,
   url : String,
   state : Object
) : MarshalByRefObject;

Parameters

type
[To be supplied.]
url
[To be supplied.]
state
[To be supplied.]

See Also

Activator Class | Activator Members | System Namespace | Activator.GetObject Overload List


Activator.GetObject (Type, String)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function GetObject( _
   ByVal type As Type, _
   ByVal url As String _
) As MarshalByRefObject
[C#]
public static MarshalByRefObject GetObject(
   Type type,
   string url
);
[C++]
public: static MarshalByRefObject* GetObject(
   Type* type,
   String* url
);
[JScript]
public static function GetObject(
   type : Type,
   url : String
) : MarshalByRefObject;

Parameters

type
[To be supplied.]
url
[To be supplied.]

See Also

Activator Class | Activator Members | System Namespace | Activator.GetObject Overload List


AppDomain Class

The NGWS runtime allows multiple applications to run in a single process. Application domains are used to isolate the applications from one another. The AppDomain class provides methods that let NGWS runtime hosts perform the following tasks:

  • Enumerate the assemblies and threads in a domain.
  • Define dynamic assemblies in a domain.
  • Set events assembly loading and domain termination.
  • Load assemblies and types into the domain.
  • Terminate the domain.

Object
MarshalByRefObject
AppDomain

[Visual Basic]
NotInheritable Public Class AppDomain
   Inherits MarshalByRefObject
   Implements IEvidenceFactory
[C#]
public sealed class AppDomain : MarshalByRefObject,
   IEvidenceFactory
[C++]
public __gc __sealed class AppDomain : public MarshalByRefObject,
   IEvidenceFactory
[JScript]
public class AppDomain extends MarshalByRefObject, IEvidenceFactory

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

AppDomain Members | System Namespace


AppDomain Members

Public:

Properties

BaseDirectory | Read-only. Get the base directory that the assembly resolver uses to probe for assemblies. The BaseDirectory property corresponds to the assembly resolver's APPBASE.
CurrentDomain | Read-only. Gets the current application domain for the current Thread.
Evidence | Read-only. Gets the Evidence associated with this application domain that is used as input to security policy.
FriendlyName | Read-only. Gets the friendly name of this application domain.
RelativeSearchPath | [To be supplied.]
ShadowCopyFiles | Read-only. If ShadowCopyFiles is set all assemblies that are loaded in the application domain are shadow copied, not just a particular one.
SharedSearchPath | Read-only. Get the path relative to the base directory where the assembly resolver should probe for shared assemblies. Shared assemblies are published assemblies. Published assemblies need not be deployed in the same directory structure as the application.
SnapShotID | Read-only. Get the SnapShotID used by the assembly resolver to track what assemblies are loaded in an application domain. The SnapShotID is related to the ShadowCopyFiles property. The host will change the SnapShotID if they wish shadow copying to be started "fresh" for this instance of the application domain rather than reusing the copies that were made before.

Methods

AppendPrivatePath | Appends the specified name of the directory to the private path.
AppendSharedPath | Appends the specified name of the directory to the shared path.
CreateDomain | Overloaded. Creates a new application domain.
CreateInstance | Overloaded. Creates an instance of a specified type defined in the specified assembly file.
CreateInstanceFrom | Overloaded. Overloaded. Creates an instance of a specified type defined in the specified assembly file.
DefineDynamicAssembly | Overloaded. Defines a dynamic assembly in the current application domain.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
ExecuteAssembly | Overloaded. Executes the assembly given its file name.
GetAssemblies | Gets the assemblies that have been loaded into this application domain.
GetCurrentThreadId | [To be supplied.]
GetData | Gets the value stored in the current application domain for the specified data name.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetThreads | Gets the Thread objects representing the threads in the application domain.
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService | [To be supplied.]
Load | Overloaded. Loads an Assembly into this application domain.
SetAppDomainPolicy | Set the security policy for this application domain.
SetData | Sets the value stored in the current application domain for the specified data name.
SetPrincipalPolicy | Set the class of the default principal object to be attached to threads if they attempt to bind to a principal while executing in this application domain.
SetThreadPrincipal | Set the default principal object to be attached to threads if they attempt to bind to a principal while executing in this application domain.
ToString | Gets a string representation of the application domain.
Unload | Overloaded. [To be supplied.]

Events

AssemblyLoad | [To be supplied.]
Stop | [To be supplied.]
UnhandledException | [To be supplied.]
Unload | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Event Hookup:

Methods

AddOnAssemblyLoad | Subscribes to the "assembly load" event. The "assembly load" event is raised when an assembly is loaded into the application domain.
AddOnStop | Subscribes to the "application domain stop" event. This event occurs after an application domain has been unloaded.
AddOnUnhandledException | Subscribes to the "unhandled exception" event.
AddOnUnload | Subscribes to the "application domain unload" event.
RemoveOnAssemblyLoad | Unsubscribes to the "assembly load" event. The "assembly load" event is raised when an assembly is loaded into the application domain.
RemoveOnStop | Unsubscribes to the "application domain stop" event.
RemoveOnUnhandledException | Unsubscribes to the "unhandled exception" event.
RemoveOnUnload | Unsubscribes to the "application domain unload" event.

See Also

AppDomain Class | System Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AppDomain Properties

The properties of the AppDomain class are listed below. For a complete list of AppDomain class members, see the AppDomain Members topic.

Public:

BaseDirectory | Read-only. Get the base directory that the assembly resolver uses to probe for assemblies. The BaseDirectory property corresponds to the assembly resolver's APPBASE.
CurrentDomain | Read-only. Gets the current application domain for the current Thread.
Evidence | Read-only. Gets the Evidence associated with this application domain that is used as input to security policy.
FriendlyName | Read-only. Gets the friendly name of this application domain.
RelativeSearchPath | [To be supplied.]
ShadowCopyFiles | Read-only. If ShadowCopyFiles is set all assemblies that are loaded in the application domain are shadow copied, not just a particular one.
SharedSearchPath | Read-only. Get the path relative to the base directory where the assembly resolver should probe for shared assemblies. Shared assemblies are published assemblies. Published assemblies need not be deployed in the same directory structure as the application.
SnapShotID | Read-only. Get the SnapShotID used by the assembly resolver to track what assemblies are loaded in an application domain. The SnapShotID is related to the ShadowCopyFiles property. The host will change the SnapShotID if they wish shadow copying to be started "fresh" for this instance of the application domain rather than reusing the copies that were made before.

See Also

AppDomain Class | System Namespace


AppDomain.BaseDirectory

Read-only. Get the base directory that the assembly resolver uses to probe for assemblies. The BaseDirectory property corresponds to the assembly resolver's APPBASE.

[Visual Basic]
Public ReadOnly Property BaseDirectory As String
[C#]
public string BaseDirectory {get;}
[C++]
public: __property String* get_BaseDirectory();
[JScript]
public function get BaseDirectory() : String;

Property Value

Get the base directory that the assembly resolver uses to probe for assemblies.

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.CurrentDomain

Read-only. Gets the current application domain for the current Thread.

[Visual Basic]
Public Shared ReadOnly Property CurrentDomain As AppDomain
[C#]
public static AppDomain CurrentDomain {get;}
[C++]
public: __property static AppDomain* get_CurrentDomain();
[JScript]
public static function get CurrentDomain() : AppDomain;

Property Value

Gets the current application domain for the current Thread.

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.Evidence

Read-only. Gets the Evidence associated with this application domain that is used as input to security policy.

[Visual Basic]
Overridable Public ReadOnly Property Evidence As Evidence
[C#]
public Evidence Evidence {virtual get;}
[C++]
public: __property virtual Evidence* get_Evidence();
[JScript]
public function get Evidence() : Evidence;

Property Value

Gets the Evidence associated with this application domain that is used as input to security policy.

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.FriendlyName

Read-only. Gets the friendly name of this application domain.

[Visual Basic]
Public ReadOnly Property FriendlyName As String
[C#]
public string FriendlyName {get;}
[C++]
public: __property String* get_FriendlyName();
[JScript]
public function get FriendlyName() : String;

Property Value

Gets the friendly name of this application domain.

Remarks

The friendly name of an application domain is the name of the assembly file loaded in the application domain. The friendly name is formed by stripping the directory specification from the assembly's codebase. For example, if an assembly with the file name is "c:\MyAppDirectory\MyAssembly.exe" is loaded in an application domain, the friendly name of the application domain will be "MyAssembly.exe".

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.RelativeSearchPath

[To be supplied.]

[Visual Basic]
Public ReadOnly Property RelativeSearchPath As String
[C#]
public string RelativeSearchPath {get;}
[C++]
public: __property String* get_RelativeSearchPath();
[JScript]
public function get RelativeSearchPath() : String;

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.ShadowCopyFiles

Read-only. If ShadowCopyFiles is set all assemblies that are loaded in the application domain are shadow copied, not just a particular one.

[Visual Basic]
Public ReadOnly Property ShadowCopyFiles As Boolean
[C#]
public bool ShadowCopyFiles {get;}
[C++]
public: __property bool get_ShadowCopyFiles();
[JScript]
public function get ShadowCopyFiles() : Boolean;

Property Value

true if all assemblies that are loaded in the application domain are shadow copied, not just a particular one. Otherwise, false.

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.SharedSearchPath

Read-only. Get the path relative to the base directory where the assembly resolver should probe for shared assemblies. Shared assemblies are published assemblies. Published assemblies need not be deployed in the same directory structure as the application.

[Visual Basic]
Public ReadOnly Property SharedSearchPath As String
[C#]
public string SharedSearchPath {get;}
[C++]
public: __property String* get_SharedSearchPath();
[JScript]
public function get SharedSearchPath() : String;

Property Value

Get the path relative to the base directory where the assembly resolver should probe for shared assemblies.

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.SnapShotID

Read-only. Get the SnapShotID used by the assembly resolver to track what assemblies are loaded in an application domain. The SnapShotID is related to the ShadowCopyFiles property. The host will change the SnapShotID if they wish shadow copying to be started "fresh" for this instance of the application domain rather than reusing the copies that were made before.

[Visual Basic]
Public ReadOnly Property SnapShotID As Integer
[C#]
public int SnapShotID {get;}
[C++]
public: __property int get_SnapShotID();
[JScript]
public function get SnapShotID() : int;

Property Value

Get the SnapshotID used by the assembly resolver to track what assemblies are loaded in an application domain.

See Also

AppDomain Class | AppDomain Members | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AppDomain Methods

The methods of the AppDomain class are listed below. For a complete list of AppDomain class members, see the AppDomain Members topic.

Public:

AppendPrivatePath | Appends the specified name of the directory to the private path.
AppendSharedPath | Appends the specified name of the directory to the shared path.
CreateDomain | Overloaded. Creates a new application domain.
CreateInstance | Overloaded. Creates an instance of a specified type defined in the specified assembly file.
CreateInstanceFrom | Overloaded. Overloaded. Creates an instance of a specified type defined in the specified assembly file.
DefineDynamicAssembly | Overloaded. Defines a dynamic assembly in the current application domain.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
ExecuteAssembly | Overloaded. Executes the assembly given its file name.
GetAssemblies | Gets the assemblies that have been loaded into this application domain.
GetCurrentThreadId | [To be supplied.]
GetData | Gets the value stored in the current application domain for the specified data name.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetThreads | Gets the Thread objects representing the threads in the application domain.
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService | [To be supplied.]
Load | Overloaded. Loads an Assembly into this application domain.
SetAppDomainPolicy | Set the security policy for this application domain.
SetData | Sets the value stored in the current application domain for the specified data name.
SetPrincipalPolicy | Set the class of the default principal object to be attached to threads if they attempt to bind to a principal while executing in this application domain.
SetThreadPrincipal | Set the default principal object to be attached to threads if they attempt to bind to a principal while executing in this application domain.
ToString | Gets a string representation of the application domain.
Unload | Overloaded. [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Event Hookup:

AddOnAssemblyLoad | Subscribes to the "assembly load" event. The "assembly load" event is raised when an assembly is loaded into the application domain.
AddOnStop | Subscribes to the "application domain stop" event. This event occurs after an application domain has been unloaded.
AddOnUnhandledException | Subscribes to the "unhandled exception" event.
AddOnUnload | Subscribes to the "application domain unload" event.
RemoveOnAssemblyLoad | Unsubscribes to the "assembly load" event. The "assembly load" event is raised when an assembly is loaded into the application domain.
RemoveOnStop | Unsubscribes to the "application domain stop" event.
RemoveOnUnhandledException | Unsubscribes to the "unhandled exception" event.
RemoveOnUnload | Unsubscribes to the "application domain unload" event.

See Also

AppDomain Class | System Namespace


AppDomain.AddOnAssemblyLoad

Subscribes to the "assembly load" event. The "assembly load" event is raised when an assembly is loaded into the application domain.

[Visual Basic]
Public Sub AddOnAssemblyLoad( _
   ByVal handler As EventHandler _
)
[C#]
public void AddOnAssemblyLoad(
   EventHandler handler
);
[C++]
public: void AddOnAssemblyLoad(
   EventHandler* handler
);
[JScript]
public function AddOnAssemblyLoad(
   handler : EventHandler
);

Parameters

handler
A delegate of type EventHandler to receive the event.

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.AddOnStop

Subscribes to the "application domain stop" event. This event occurs after an application domain has been unloaded.

[Visual Basic]
Public Sub AddOnStop( _
   ByVal handler As EventHandler _
)
[C#]
public void AddOnStop(
   EventHandler handler
);
[C++]
public: void AddOnStop(
   EventHandler* handler
);
[JScript]
public function AddOnStop(
   handler : EventHandler
);

Parameters

handler
A delegate of type EventHandler to receive the event.

Remarks

This method will be removed in a future release. Use the "application domain unloaded" event instead of this event.

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.AddOnUnhandledException

Subscribes to the "unhandled exception" event.

[Visual Basic]
Public Sub AddOnUnhandledException( _
   ByVal handler As UnhandledExceptionEventHandler _
)
[C#]
public void AddOnUnhandledException(
   UnhandledExceptionEventHandler handler
);
[C++]
public: void AddOnUnhandledException(
   UnhandledExceptionEventHandler* handler
);
[JScript]
public function AddOnUnhandledException(
   handler : UnhandledExceptionEventHandler
);

Parameters

handler
A delegate of type EventHandler to receive the event.

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.AddOnUnload

Subscribes to the "application domain unload" event.

[Visual Basic]
Public Sub AddOnUnload( _
   ByVal handler As EventHandler _
)
[C#]
public void AddOnUnload(
   EventHandler handler
);
[C++]
public: void AddOnUnload(
   EventHandler* handler
);
[JScript]
public function AddOnUnload(
   handler : EventHandler
);

Parameters

handler
A delegate of type EventHandler to receive the event.

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.AppendPrivatePath

Appends the specified name of the directory to the private path.

[Visual Basic]
Public Sub AppendPrivatePath( _
   ByVal path As String _
)
[C#]
public void AppendPrivatePath(
   string path
);
[C++]
public: void AppendPrivatePath(
   String* path
);
[JScript]
public function AppendPrivatePath(
   path : String
);

Parameters

path
The name of the directory to be appended to the private path.

Remarks

The private path, or relative search path, is the path relative to the base directory where the assembly resolver probes for private assemblies.

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.AppendSharedPath

Appends the specified name of the directory to the shared path.

[Visual Basic]
Public Sub AppendSharedPath( _
   ByVal path As String _
)
[C#]
public void AppendSharedPath(
   string path
);
[C++]
public: void AppendSharedPath(
   String* path
);
[JScript]
public function AppendSharedPath(
   path : String
);

Parameters

path
The name of the directory to be appended to the shared path.

Remarks

The shared path is the path relative to the base directory where the assembly resolver probes for shared assemblies. Shared assemblies are published assemblies. Published assemblies need not be deployed in the same directory structure as the application.

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.CreateDomain

Creates a new application domain.

Overload List

Creates a new application domain with the given name using, evidence, a set of context policies, and a set of property name/value pairs. The property name/value pairs are stored in the application domain's property bag. The GetData and the SetData methods can be used to respectively get and set the values of the properties.

[Visual Basic] Overloads Public Shared Function CreateDomain(String, Evidence, Object(), IDictionary) As AppDomain
[C#] public static AppDomain CreateDomain(String, Evidence, Object[], IDictionary);
[C++] public: static AppDomain* CreateDomain(String*, Evidence, Object[], IDictionary);
[JScript] public static function CreateDomain(String, Evidence, Object[], IDictionary) : AppDomain;

Creates a new application domain with the given name using the supplied evidence and a set of context policies.

[Visual Basic] Overloads Public Shared Function CreateDomain(String, Evidence, Object()) As AppDomain
[C#] public static AppDomain CreateDomain(String, Evidence, Object[]);
[C++] public: static AppDomain* CreateDomain(String*, Evidence, Object[]);
[JScript] public static function CreateDomain(String, Evidence, Object[]) : AppDomain;

Creates a new application domain with the given name using, evidence, a set of context policies, application base path, relative search path, shared search path, snapshot ID, and a parameter that specifies whether a shadow copy of an assembly is to be loaded in to the application domain.

[Visual Basic] Overloads Public Shared Function CreateDomain(String, Evidence, Object(), String, String, String, Boolean, Long) As AppDomain
[C#] public static AppDomain CreateDomain(String, Evidence, Object[], String, String, String, bool, long);
[C++] public: static AppDomain* CreateDomain(String*, Evidence, Object[], String*, String*, String*, bool, __int64);
[JScript] public static function CreateDomain(String, Evidence, Object[], String, String, String, Boolean, long) : AppDomain;

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.CreateDomain (String, Evidence, Object[], IDictionary)

Creates a new application domain with the given name using, evidence, a set of context policies, and a set of property name/value pairs. The property name/value pairs are stored in the application domain's property bag. The GetData and the SetData methods can be used to respectively get and set the values of the properties.

[Visual Basic]
Overloads Public Shared Function CreateDomain( _
   ByVal friendlyName As String, _
   ByVal securityInfo As Evidence, _
   ByVal policies() As Object, _
   ByVal properties As IDictionary _
) As AppDomain
[C#]
public static AppDomain CreateDomain(
   string friendlyName,
   Evidence securityInfo,
   object[] policies,
   IDictionary properties
);
[C++]
public: static AppDomain* CreateDomain(
   String* friendlyName,
   Evidence* securityInfo,
   Object* policies[],
   IDictionary* properties
);
[JScript]
public static function CreateDomain(
   friendlyName : String,
   securityInfo : Evidence,
   policies : Object[],
   properties : IDictionary
) : AppDomain;

Parameters

friendlyName
The friendly name of the domain. This friendly name can be displayed in user interfaces to identify the domain. See the description of FriendlyName.
securityInfo
An optional array of Evidence objects representing evidence that is mapped through security policy to establish a top-of-stack permission set.
policies
An optional array of context policies to be added to the basic policies of the domain.
properties
A dictionary of property name/value pairs to be stored in the property bag.

Return Value

The newly created application domain.

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.CreateDomain Overload List


AppDomain.CreateDomain (String, Evidence, Object[])

Creates a new application domain with the given name using the supplied evidence and a set of context policies.

[Visual Basic]
Overloads Public Shared Function CreateDomain( _
   ByVal friendlyName As String, _
   ByVal securityInfo As Evidence, _
   ByVal policies() As Object _
) As AppDomain
[C#]
public static AppDomain CreateDomain(
   string friendlyName,
   Evidence securityInfo,
   object[] policies
);
[C++]
public: static AppDomain* CreateDomain(
   String* friendlyName,
   Evidence* securityInfo,
   Object* policies[]
);
[JScript]
public static function CreateDomain(
   friendlyName : String,
   securityInfo : Evidence,
   policies : Object[]
) : AppDomain;

Parameters

friendlyName
The friendly name of the domain. This friendly name can be displayed in user interfaces to identify the domain. See the description of FriendlyName.
securityInfo
An optional array of Evidence objects representing evidence that is mapped through security policy to establish a top-of-stack permission set.
policies
An optional array of context policies to be added to the basic policies of the domain.

Return Value

The newly created application domain.

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.CreateDomain Overload List


AppDomain.CreateDomain (String, Evidence, Object[], String, String, String, Boolean, Int64)

Creates a new application domain with the given name using, evidence, a set of context policies, application base path, relative search path, shared search path, snapshot ID, and a parameter that specifies whether a shadow copy of an assembly is to be loaded in to the application domain.

[Visual Basic]
Overloads Public Shared Function CreateDomain( _
   ByVal friendlyName As String, _
   ByVal securityInfo As Evidence, _
   ByVal policies() As Object, _
   ByVal appBasePath As String, _
   ByVal appRelativeSearchPath As String, _
   ByVal sharedSearchPath As String, _
   ByVal shadowCopyFiles As Boolean, _
   ByVal snapshotID As Long _
) As AppDomain
[C#]
public static AppDomain CreateDomain(
   string friendlyName,
   Evidence securityInfo,
   object[] policies,
   string appBasePath,
   string appRelativeSearchPath,
   string sharedSearchPath,
   bool shadowCopyFiles,
   long snapshotID
);
[C++]
public: static AppDomain* CreateDomain(
   String* friendlyName,
   Evidence* securityInfo,
   Object* policies[],
   String* appBasePath,
   String* appRelativeSearchPath,
   String* sharedSearchPath,
   bool shadowCopyFiles,
   __int64 snapshotID
);
[JScript]
public static function CreateDomain(
   friendlyName : String,
   securityInfo : Evidence,
   policies : Object[],
   appBasePath : String,
   appRelativeSearchPath : String,
   sharedSearchPath : String,
   shadowCopyFiles : Boolean,
   snapshotID : long
) : AppDomain;

Parameters

friendlyName
The friendly name of the domain. This friendly name can be displayed in user interfaces to identify the domain. See the description of FriendlyName.
securityInfo
An optional array of Evidence objects representing evidence that is mapped through security policy to establish a top-of-stack permission set.
policies
An optional array of context policies to be added to the basic policies of the domain.
appBasePath
The base directory that the assembly resolver uses to probe for assemblies. See the description of BaseDirectory.
appRelativeSearchPath
The path relative to the base directory where the assembly resolver should probe for private assemblies. See the description of RelativeSearchPath.
sharedSearchPath
The path relative to the base directory where the assembly resolver should probe for shared assemblies. See the description of SharedSearchPath.
shadowCopyFiles
If true, a shadow copy of an assembly is loaded into this application domain.
snapshotID
The SnapshotID used by the assembly resolver to track what assemblies are loaded in an application domain.

Return Value

The newly created application domain.

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.CreateDomain Overload List


AppDomain.CreateInstance

Creates an instance of a specified type defined in the specified assembly file.

Overload List

Instantiate the specified type defined in the specified assembly.

[Visual Basic] Overloads Public Function CreateInstance(String, String) As ObjectHandle
[C#] public ObjectHandle CreateInstance(String, String);
[C++] public: ObjectHandle* CreateInstance(String*, String*);
[JScript] public function CreateInstance(String, String) : ObjectHandle;

Instantiate the specified type defined in the specified assembly with the supplied arguments to the type constructor, optionally ignoring the case of the assembly name and the type name, using the specified binder and binding flags. Optionally, the loaded assembly can be shared across application domains. A set of activation attributes can be supplied and evidence can be supplied.

[Visual Basic] Overloads Public Function CreateInstance(String, String, Boolean, BindingFlags, Binder, Object(), CultureInfo, Boolean, Object(), Evidence) As ObjectHandle
[C#] public ObjectHandle CreateInstance(String, String, bool, BindingFlags, Binder, Object[], CultureInfo, bool, Object[], Evidence);
[C++] public: ObjectHandle* CreateInstance(String*, String*, bool, BindingFlags, Binder, Object[], CultureInfo, bool, Object[], Evidence);
[JScript] public function CreateInstance(String, String, Boolean, BindingFlags, Binder, Object[], CultureInfo, Boolean, Object[], Evidence) : ObjectHandle;

Instantiate the specified type defined in the specified assembly. Optionally, the loaded assembly can be shared across application domains. A set of activation attributes can be supplied and evidence can be supplied.

[Visual Basic] Overloads Public Function CreateInstance(String, String, Boolean, Object()) As ObjectHandle
[C#] public ObjectHandle CreateInstance(String, String, bool, Object[]);
[C++] public: ObjectHandle* CreateInstance(String*, String*, bool, Object[]);
[JScript] public function CreateInstance(String, String, Boolean, Object[]) : ObjectHandle;

Instantiate the specified type defined in the specified assembly and optionally specifying whether the assembly is to be shared across application domains.

[Visual Basic] Overloads Public Function CreateInstance(String, String, Boolean) As ObjectHandle
[C#] public ObjectHandle CreateInstance(String, String, bool);
[C++] public: ObjectHandle* CreateInstance(String*, String*, bool);
[JScript] public function CreateInstance(String, String, Boolean) : ObjectHandle;

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.CreateInstance (String, String)

Instantiate the specified type defined in the specified assembly.

[Visual Basic]
Overloads Public Function CreateInstance( _
   ByVal assemblyname As String, _
   ByVal typeName As String _
) As ObjectHandle
[C#]
public ObjectHandle CreateInstance(
   string assemblyname,
   string typeName
);
[C++]
public: ObjectHandle* CreateInstance(
   String* assemblyname,
   String* typeName
);
[JScript]
public function CreateInstance(
   assemblyname : String,
   typeName : String
) : ObjectHandle;

Parameters

assemblyname
The display name of the assembly. See the description of AssemblyName for the format of the display name. If a null reference (in Visual Basic Nothing), the executing assembly is assumed.
typeName
The full name of the type.

Return Value

Returns an ObjectHandle object that is a wrapper for the instantiated object. Returns a null reference (Nothing) if the type is not found. ObjectHandle needs to be unwrapped to access the real object.

Exceptions

Exception Type | Condition
ArgumentNullException | if assemblyString is a null reference (Nothing).

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.CreateInstance Overload List


AppDomain.CreateInstance (String, String, Boolean, BindingFlags, Binder, Object[], CultureInfo, Boolean, Object[], Evidence)

Instantiate the specified type defined in the specified assembly with the supplied arguments to the type constructor, optionally ignoring the case of the assembly name and the type name, using the specified binder and binding flags. Optionally, the loaded assembly can be shared across application domains. A set of activation attributes can be supplied and evidence can be supplied.

[Visual Basic]
Overloads Public Function CreateInstance( _
   ByVal assemblyName As String, _
   ByVal typeName As String, _
   ByVal ignoreCase As Boolean, _
   ByVal bindingAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal args() As Object, _
   ByVal culture As CultureInfo, _
   ByVal shared As Boolean, _
   ByVal activationAttributes() As Object, _
   ByVal securityAttributes As Evidence _
) As ObjectHandle
[C#]
public ObjectHandle CreateInstance(
   string assemblyName,
   string typeName,
   bool ignoreCase,
   BindingFlags bindingAttr,
   Binder binder,
   object[] args,
   CultureInfo culture,
   bool shared,
   object[] activationAttributes,
   Evidence securityAttributes
);
[C++]
public: ObjectHandle* CreateInstance(
   String* assemblyName,
   String* typeName,
   bool ignoreCase,
   BindingFlags bindingAttr,
   Binder* binder,
   Object* args[],
   CultureInfo* culture,
   bool shared,
   Object* activationAttributes[],
   Evidence* securityAttributes
);
[JScript]
public function CreateInstance(
   assemblyName : String,
   typeName : String,
   ignoreCase : Boolean,
   bindingAttr : BindingFlags,
   binder : Binder,
   args : Object[],
   culture : CultureInfo,
   shared : Boolean,
   activationAttributes : Object[],
   securityAttributes : Evidence
) : ObjectHandle;

Parameters

assemblyName
The display name of the assembly. See the description of AssemblyName for the format of the display name. If a null reference (in Visual Basic Nothing), the executing assembly is assumed.
typeName
The full name of the Type.
ignoreCase
If true, the case of the supplied names, assemblyName and typeName, is ignored.
bindingAttr
This bit mask affects the way in which the search is conducted. The value is a combination of zero or more bit flags from BindingFlags such as NonPublic. This can be set to 0 to conduct a case-sensitive search for public properties.
binder
An object that enables the binding, coercion of argument types, invocation of members, and retrieval of MemberInfo objects via reflection. If binder is a null reference (Nothing), the default binder is used. See Binder.
args
The arguments to be passed to the constructor. This array or arguments must match in number, order, and type, the parameters of the constructor to be invoked. If the constructor that takes no parameters is desired, args must be an empty array or a a null reference (Nothing) reference.
culture
An instance of CultureInfo used to govern the coercion of types. If this is a null reference (Nothing), the CultureInfo for the current thread is used. (Note that this is necessary to, for example, convert a String that represents 1000 to a Double value, since 1000 is represented differently by different cultures.)
shared
If true, the assembly is loaded in a form where its JIT-compiled code can be reused by multiple application domains (at a slight cost in code quality).
activationAttributes
One or more activation attributes that can participate in the activation. An example of an activation attribute is:
securityAttributes
[To be supplied.]

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.CreateInstance Overload List


AppDomain.CreateInstance (String, String, Boolean, Object[])

Instantiate the specified type defined in the specified assembly. Optionally, the loaded assembly can be shared across application domains. A set of activation attributes can be supplied and evidence can be supplied.

[Visual Basic]
Overloads Public Function CreateInstance( _
   ByVal assemblyname As String, _
   ByVal typeName As String, _
   ByVal shared As Boolean, _
   ByVal activationAttributes() As Object _
) As ObjectHandle
[C#]
public ObjectHandle CreateInstance(
   string assemblyname,
   string typeName,
   bool shared,
   object[] activationAttributes
);
[C++]
public: ObjectHandle* CreateInstance(
   String* assemblyname,
   String* typeName,
   bool shared,
   Object* activationAttributes[]
);
[JScript]
public function CreateInstance(
   assemblyname : String,
   typeName : String,
   shared : Boolean,
   activationAttributes : Object[]
) : ObjectHandle;

Parameters

assemblyname
The display name of the assembly. See the description of System.AssemblyName for the format of the display name. If a null reference (in Visual Basic Nothing), the executing assembly is assumed.
typeName
The full name of the type.
shared
If true, the assembly is loaded in a form where its JIT-compiled code can be reused by multiple application domains (at a slight cost in code quality).
activationAttributes
One or more attributes that can participate in the activation. An example of an activation attribute is: URLAttribute ("http://hostname/vroot/objectname")

Return Value

Returns an ObjectHandle object that is a wrapper for the instantiated object. Returns a null reference (Nothing) if the type is not found. ObjectHandle needs to be unwrapped to access the real object.

Exceptions

Exception Type | Condition
ArgumentNullException | if assemblyString is a null reference (Nothing).

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.CreateInstance Overload List


AppDomain.CreateInstance (String, String, Boolean)

Instantiate the specified type defined in the specified assembly and optionally specifying whether the assembly is to be shared across application domains.

[Visual Basic]
Overloads Public Function CreateInstance( _
   ByVal assemblyname As String, _
   ByVal typeName As String, _
   ByVal shared As Boolean _
) As ObjectHandle
[C#]
public ObjectHandle CreateInstance(
   string assemblyname,
   string typeName,
   bool shared
);
[C++]
public: ObjectHandle* CreateInstance(
   String* assemblyname,
   String* typeName,
   bool shared
);
[JScript]
public function CreateInstance(
   assemblyname : String,
   typeName : String,
   shared : Boolean
) : ObjectHandle;

Parameters

assemblyname
The display name of the assembly. See the description of AssemblyName for the format of the display name. If a null reference (in Visual Basic Nothing), the executing assembly is assumed.
typeName
The full name of the type.
shared
If true, the assembly is loaded in a form where its JIT-compiled code can be reused by multiple application domains (at a slight cost in code quality).

Return Value

Returns an ObjectHandle object that is a wrapper for the instantiated object. Returns a null reference (Nothing) if the type is not found. ObjectHandle needs to be unwrapped to access the real object.

Exceptions

Exception Type | Condition
ArgumentNullException | if assemblyString is a null reference (Nothing).

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.CreateInstance Overload List


AppDomain.CreateInstanceFrom

Overloaded. Creates an instance of a specified type defined in the specified assembly file.

Overload List

Instantiate the specified type defined in the specified assembly file and optionally specifying whether the assembly is to be shared across application domains.

[Visual Basic] Overloads Public Function CreateInstanceFrom(String, String, Boolean) As ObjectHandle
[C#] public ObjectHandle CreateInstanceFrom(String, String, bool);
[C++] public: ObjectHandle* CreateInstanceFrom(String*, String*, bool);
[JScript] public function CreateInstanceFrom(String, String, Boolean) : ObjectHandle;

Instantiate the specified type defined in the specified assembly file.

[Visual Basic] Overloads Public Function CreateInstanceFrom(String, String) As ObjectHandle
[C#] public ObjectHandle CreateInstanceFrom(String, String);
[C++] public: ObjectHandle* CreateInstanceFrom(String*, String*);
[JScript] public function CreateInstanceFrom(String, String) : ObjectHandle;

Instantiate the specified type defined in the specified assembly file. Optionally, the loaded assembly can be shared across application domains. A set of activation attributes can be supplied and evidence can be supplied.

[Visual Basic] Overloads Public Function CreateInstanceFrom(String, String, Boolean, Object()) As ObjectHandle
[C#] public ObjectHandle CreateInstanceFrom(String, String, bool, Object[]);
[C++] public: ObjectHandle* CreateInstanceFrom(String*, String*, bool, Object[]);
[JScript] public function CreateInstanceFrom(String, String, Boolean, Object[]) : ObjectHandle;

Instantiate the specified type defined in the specified assembly file with the supplied arguments to the type constructor, optionally ignoring the case of the assembly name and the type name, using the specified binder and binding flags. Optionally, the loaded assembly can be shared across application domains. A set of activation attributes can be supplied and evidence can be supplied.

[Visual Basic] Overloads Public Function CreateInstanceFrom(String, String, Boolean, BindingFlags, Binder, Object(), CultureInfo, Boolean, Object(), Evidence) As ObjectHandle
[C#] public ObjectHandle CreateInstanceFrom(String, String, bool, BindingFlags, Binder, Object[], CultureInfo, bool, Object[], Evidence);
[C++] public: ObjectHandle* CreateInstanceFrom(String*, String*, bool, BindingFlags, Binder, Object[], CultureInfo, bool, Object[], Evidence);
[JScript] public function CreateInstanceFrom(String, String, Boolean, BindingFlags, Binder, Object[], CultureInfo, Boolean, Object[], Evidence) : ObjectHandle;

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.CreateInstanceFrom (String, String, Boolean)

Instantiate the specified type defined in the specified assembly file and optionally specifying whether the assembly is to be shared across application domains.

[Visual Basic]
Overloads Public Function CreateInstanceFrom( _
   ByVal assemblyFile As String, _
   ByVal typeName As String, _
   ByVal shared As Boolean _
) As ObjectHandle
[C#]
public ObjectHandle CreateInstanceFrom(
   string assemblyFile,
   string typeName,
   bool shared
);
[C++]
public: ObjectHandle* CreateInstanceFrom(
   String* assemblyFile,
   String* typeName,
   bool shared
);
[JScript]
public function CreateInstanceFrom(
   assemblyFile : String,
   typeName : String,
   shared : Boolean
) : ObjectHandle;

Parameters

assemblyFile
The assembly file name.
typeName
The full name of the type.
shared
If true, the assembly is loaded in a form where its JIT-compiled code can be reused by multiple application domains (at a slight cost in code quality).

Return Value

Returns an ObjectHandle object that is a wrapper for the instantiated object. Returns a null reference (in Visual Basic Nothing) if the type is not found. ObjectHandle needs to be unwrapped to access the real object.

Exceptions

Exception Type | Condition
ArgumentNullException | if assemblyFile is a null reference (Nothing).

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.CreateInstanceFrom Overload List


AppDomain.CreateInstanceFrom (String, String)

Instantiate the specified type defined in the specified assembly file.

[Visual Basic]
Overloads Public Function CreateInstanceFrom( _
   ByVal assemblyFile As String, _
   ByVal typeName As String _
) As ObjectHandle
[C#]
public ObjectHandle CreateInstanceFrom(
   string assemblyFile,
   string typeName
);
[C++]
public: ObjectHandle* CreateInstanceFrom(
   String* assemblyFile,
   String* typeName
);
[JScript]
public function CreateInstanceFrom(
   assemblyFile : String,
   typeName : String
) : ObjectHandle;

Parameters

assemblyFile
The assembly file name.
typeName
The full name of the type.

Return Value

Returns an ObjectHandle object that is a wrapper for the instantiated object. Returns a null reference (in Visual Basic Nothing) if the type is not found. ObjectHandle needs to be unwrapped to access the real object.

Exceptions

Exception Type | Condition
ArgumentNullException | if assemblyFile is a null reference (Nothing).

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.CreateInstanceFrom Overload List


AppDomain.CreateInstanceFrom (String, String, Boolean, Object[])

Instantiate the specified type defined in the specified assembly file. Optionally, the loaded assembly can be shared across application domains. A set of activation attributes can be supplied and evidence can be supplied.

[Visual Basic]
Overloads Public Function CreateInstanceFrom( _
   ByVal assemblyFile As String, _
   ByVal typeName As String, _
   ByVal shared As Boolean, _
   ByVal activationAttributes() As Object _
) As ObjectHandle
[C#]
public ObjectHandle CreateInstanceFrom(
   string assemblyFile,
   string typeName,
   bool shared,
   object[] activationAttributes
);
[C++]
public: ObjectHandle* CreateInstanceFrom(
   String* assemblyFile,
   String* typeName,
   bool shared,
   Object* activationAttributes[]
);
[JScript]
public function CreateInstanceFrom(
   assemblyFile : String,
   typeName : String,
   shared : Boolean,
   activationAttributes : Object[]
) : ObjectHandle;

Parameters

assemblyFile
The assembly file name.
typeName
The full name of the type.
shared
If true, the assembly is loaded in a form where its JIT-compiled code can be reused by multiple application domains (at a slight cost in code quality).
activationAttributes
One or more activation attributes that can participate in the activation. An example of an activation attribute is:

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.CreateInstanceFrom Overload List


AppDomain.CreateInstanceFrom (String, String, Boolean, BindingFlags, Binder, Object[], CultureInfo, Boolean, Object[], Evidence)

Instantiate the specified type defined in the specified assembly file with the supplied arguments to the type constructor, optionally ignoring the case of the assembly name and the type name, using the specified binder and binding flags. Optionally, the loaded assembly can be shared across application domains. A set of activation attributes can be supplied and evidence can be supplied.

[Visual Basic]
Overloads Public Function CreateInstanceFrom( _
   ByVal assemblyFile As String, _
   ByVal typeName As String, _
   ByVal ignoreCase As Boolean, _
   ByVal bindingAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal args() As Object, _
   ByVal culture As CultureInfo, _
   ByVal shared As Boolean, _
   ByVal activationAttributes() As Object, _
   ByVal securityAttributes As Evidence _
) As ObjectHandle
[C#]
public ObjectHandle CreateInstanceFrom(
   string assemblyFile,
   string typeName,
   bool ignoreCase,
   BindingFlags bindingAttr,
   Binder binder,
   object[] args,
   CultureInfo culture,
   bool shared,
   object[] activationAttributes,
   Evidence securityAttributes
);
[C++]
public: ObjectHandle* CreateInstanceFrom(
   String* assemblyFile,
   String* typeName,
   bool ignoreCase,
   BindingFlags bindingAttr,
   Binder* binder,
   Object* args[],
   CultureInfo* culture,
   bool shared,
   Object* activationAttributes[],
   Evidence* securityAttributes
);
[JScript]
public function CreateInstanceFrom(
   assemblyFile : String,
   typeName : String,
   ignoreCase : Boolean,
   bindingAttr : BindingFlags,
   binder : Binder,
   args : Object[],
   culture : CultureInfo,
   shared : Boolean,
   activationAttributes : Object[],
   securityAttributes : Evidence
) : ObjectHandle;

Parameters

assemblyFile
The assembly file name.
typeName
The full name of the Type.
ignoreCase
If true, the case of the supplied names, assemblyName and typeName, is ignored.
bindingAttr
This bit mask affects the way in which the search is conducted. The value is a combination of zero or more bit flags from BindingFlags such as NonPublic. This can be set to 0 to conduct a case-sensitive search for public properties.
binder
An object that enables the binding, coercion of argument types, invocation of members, and retrieval of MemberInfo objects via reflection. If binder is a null reference (in Visual Basic Nothing), the default binder is used. See Binder.
args
The arguments to be passed to the constructor. This array or arguments must match in number, order, and type, the parameters of the constructor to be invoked. If the constructor that takes no parameters is desired, args must be an empty array or a a null reference (Nothing) reference.
culture
[To be supplied.]
shared
If true, the assembly is loaded in a form where its JIT-compiled code can be reused by multiple application domains (at a slight cost in code quality).
activationAttributes
One or more activation attributes that can participate in the activation. An example of an activation attribute is:
securityAttributes
[To be supplied.]

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.CreateInstanceFrom Overload List


AppDomain.DefineDynamicAssembly

Defines a dynamic assembly in the current application domain.

Overload List

Defines a dynamic assembly with the given name, given access, the name of the directory for saving the assembly, and the permission requests.

[Visual Basic] Overloads Public Function DefineDynamicAssembly(AssemblyName, AssemblyBuilderAccess, String, PermissionSet, PermissionSet, PermissionSet) As AssemblyBuilder
[C#] public AssemblyBuilder DefineDynamicAssembly(AssemblyName, AssemblyBuilderAccess, String, PermissionSet, PermissionSet, PermissionSet);
[C++] public: AssemblyBuilder* DefineDynamicAssembly(AssemblyName*, AssemblyBuilderAccess, String, PermissionSet, PermissionSet, PermissionSet);
[JScript] public function DefineDynamicAssembly(AssemblyName, AssemblyBuilderAccess, String, PermissionSet, PermissionSet, PermissionSet) : AssemblyBuilder;

Defines a dynamic assembly with the given name, given access, supplied evidence, and the permission requests.

Only fully trusted callers can supply their evidence when defining a dynamic assembly. The runtime will map the evidence through policy to determine the granted permissions. Semi-trusted callers must supply a a null reference (in Visual Basic Nothing) evidence. If evidence is a null reference (Nothing), the runtime copies the permission sets (that is, the current grant and deny sets) from the caller's assembly to the dynamic assembly being defined and marks policy as resolved.

If the dynamic assembly is saved to disk, subsequent loads will get grants based on policies associated with the location where the assembly was saved.

[Visual Basic] Overloads Public Function DefineDynamicAssembly(AssemblyName, AssemblyBuilderAccess, Evidence, PermissionSet, PermissionSet, PermissionSet) As AssemblyBuilder
[C#] public AssemblyBuilder DefineDynamicAssembly(AssemblyName, AssemblyBuilderAccess, Evidence, PermissionSet, PermissionSet, PermissionSet);
[C++] public: AssemblyBuilder* DefineDynamicAssembly(AssemblyName*, AssemblyBuilderAccess, Evidence, PermissionSet, PermissionSet, PermissionSet);
[JScript] public function DefineDynamicAssembly(AssemblyName, AssemblyBuilderAccess, Evidence, PermissionSet, PermissionSet, PermissionSet) : AssemblyBuilder;

Defines a dynamic Assembly with the given name, given access, the name of the directory for saving the Assembly, supplied Evidence, and the permission requests. Optionally, the caller can specify if the creation of modules, types, and members in the dynamic Assembly should be synchronized.

Only fully trusted callers can supply their evidence when defining a dynamic Assembly. The runtime will map the Evidence through policy to determine the granted permissions. Semi-trusted callers must supply a Evidence. If evidence is a null reference (Nothing), the runtime copies the permission sets, i.e., the current grant and deny sets, from the caller's Assembly to the dynamic Assembly being defined and marks policy as resolved.

If the dynamic Assembly is saved to disk, subsequent loads will get grants based on policies associated with the location where the Assembly was saved.

[Visual Basic] Overloads Public Function DefineDynamicAssembly(AssemblyName, AssemblyBuilderAccess, String, Evidence, PermissionSet, PermissionSet, PermissionSet, Boolean) As AssemblyBuilder
[C#] public AssemblyBuilder DefineDynamicAssembly(AssemblyName, AssemblyBuilderAccess, String, Evidence, PermissionSet, PermissionSet, PermissionSet, bool);
[C++] public: AssemblyBuilder* DefineDynamicAssembly(AssemblyName*, AssemblyBuilderAccess, String, Evidence, PermissionSet, PermissionSet, PermissionSet, bool);
[JScript] public function DefineDynamicAssembly(AssemblyName, AssemblyBuilderAccess, String, Evidence, PermissionSet, PermissionSet, PermissionSet, Boolean) : AssemblyBuilder;

Defines a dynamic assembly with the given name, the given access, and the given permission requests.

[Visual Basic] Overloads Public Function DefineDynamicAssembly(AssemblyName, AssemblyBuilderAccess, PermissionSet, PermissionSet, PermissionSet) As AssemblyBuilder
[C#] public AssemblyBuilder DefineDynamicAssembly(AssemblyName, AssemblyBuilderAccess, PermissionSet, PermissionSet, PermissionSet);
[C++] public: AssemblyBuilder* DefineDynamicAssembly(AssemblyName*, AssemblyBuilderAccess, PermissionSet, PermissionSet, PermissionSet);
[JScript] public function DefineDynamicAssembly(AssemblyName, AssemblyBuilderAccess, PermissionSet, PermissionSet, PermissionSet) : AssemblyBuilder;

Defines a dynamic assembly with the given name, given access, the name of the directory for saving the assembly, and the supplied evidence.

Only fully trusted callers can supply their evidence when defining a dynamic assembly. The runtime will map the evidence through policy to determine the granted permissions. Semi-trusted callers must supply a a null reference (Nothing) evidence. If evidence is a null reference (Nothing), the runtime copies the permission sets, i.e., the current grant and deny sets, from the caller's assembly to the dynamic assembly being defined and marks policy as resolved. If the dynamic assembly is saved to disk, subsequent loads will get grants based on policies associated with the location where the assembly was saved.

[Visual Basic] Overloads Public Function DefineDynamicAssembly(AssemblyName, AssemblyBuilderAccess, String, Evidence) As AssemblyBuilder
[C#] public AssemblyBuilder DefineDynamicAssembly(AssemblyName, AssemblyBuilderAccess, String, Evidence);
[C++] public: AssemblyBuilder* DefineDynamicAssembly(AssemblyName*, AssemblyBuilderAccess, String, Evidence);
[JScript] public function DefineDynamicAssembly(AssemblyName, AssemblyBuilderAccess, String, Evidence) : AssemblyBuilder;

Defines a dynamic assembly with the given name and the given access.

[Visual Basic] Overloads Public Function DefineDynamicAssembly(AssemblyName, AssemblyBuilderAccess) As AssemblyBuilder
[C#] public AssemblyBuilder DefineDynamicAssembly(AssemblyName, AssemblyBuilderAccess);
[C++] public: AssemblyBuilder* DefineDynamicAssembly(AssemblyName*, AssemblyBuilderAccess);
[JScript] public function DefineDynamicAssembly(AssemblyName, AssemblyBuilderAccess) : AssemblyBuilder;

Defines a dynamic assembly with the given name, the given access, and the name of the directory for saving the assembly.

[Visual Basic] Overloads Public Function DefineDynamicAssembly(AssemblyName, AssemblyBuilderAccess, String) As AssemblyBuilder
[C#] public AssemblyBuilder DefineDynamicAssembly(AssemblyName, AssemblyBuilderAccess, String);
[C++] public: AssemblyBuilder* DefineDynamicAssembly(AssemblyName*, AssemblyBuilderAccess, String);
[JScript] public function DefineDynamicAssembly(AssemblyName, AssemblyBuilderAccess, String) : AssemblyBuilder;

Defines a dynamic assembly with the given name, given access, the name of the directory for saving the assembly, supplied evidence, and the permission requests.

Only fully trusted callers can supply their evidence when defining a dynamic assembly. The runtime will map the evidence through policy to determine the granted permissions. Semi-trusted callers must supply a a null reference (Nothing) evidence. If evidence is a null reference (Nothing), the runtime copies the permission sets, i.e., the current grant and deny sets, from the caller's assembly to the dynamic assembly being defined and marks policy as resolved.

If the dynamic assembly is saved to disk, subsequent loads will get grants based on policies associated with the location where the assembly was saved.

[Visual Basic] Overloads Public Function DefineDynamicAssembly(AssemblyName, AssemblyBuilderAccess, String, Evidence, PermissionSet, PermissionSet, PermissionSet) As AssemblyBuilder
[C#] public AssemblyBuilder DefineDynamicAssembly(AssemblyName, AssemblyBuilderAccess, String, Evidence, PermissionSet, PermissionSet, PermissionSet);
[C++] public: AssemblyBuilder* DefineDynamicAssembly(AssemblyName*, AssemblyBuilderAccess, String, Evidence, PermissionSet, PermissionSet, PermissionSet);
[JScript] public function DefineDynamicAssembly(AssemblyName, AssemblyBuilderAccess, String, Evidence, PermissionSet, PermissionSet, PermissionSet) : AssemblyBuilder;

Defines a dynamic assembly with the given name, the given access, and the supplied evidence.

Only fully trusted callers can supply evidence when defining a dynamic assembly. The runtime will map the supplied evidence through policy to determine the granted permissions. Semi-trusted callers must supply a a null reference (Nothing) evidence. If evidence is a null reference (Nothing), the runtime copies the permission sets, i.e., the current grant and deny sets, from the caller's assembly to the dynamic assembly being defined and marks policy as resolved. If the dynamic assembly is saved to disk, subsequent loads will get grants based on policies associated with the location where the assembly was saved.

[Visual Basic] Overloads Public Function DefineDynamicAssembly(AssemblyName, AssemblyBuilderAccess, Evidence) As AssemblyBuilder
[C#] public AssemblyBuilder DefineDynamicAssembly(AssemblyName, AssemblyBuilderAccess, Evidence);
[C++] public: AssemblyBuilder* DefineDynamicAssembly(AssemblyName*, AssemblyBuilderAccess, Evidence);
[JScript] public function DefineDynamicAssembly(AssemblyName, AssemblyBuilderAccess, Evidence) : AssemblyBuilder;

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.DefineDynamicAssembly (AssemblyName, AssemblyBuilderAccess, String, PermissionSet, PermissionSet, PermissionSet)

Defines a dynamic assembly with the given name, given access, the name of the directory for saving the assembly, and the permission requests.

[Visual Basic]
Overloads Public Function DefineDynamicAssembly( _
   ByVal name As AssemblyName, _
   ByVal access As AssemblyBuilderAccess, _
   ByVal dir As String, _
   ByVal requiredPermissions As PermissionSet, _
   ByVal optionalPermissions As PermissionSet, _
   ByVal refusedPermissions As PermissionSet _
) As AssemblyBuilder
[C#]
public AssemblyBuilder DefineDynamicAssembly(
   AssemblyName name,
   AssemblyBuilderAccess access,
   string dir,
   PermissionSet requiredPermissions,
   PermissionSet optionalPermissions,
   PermissionSet refusedPermissions
);
[C++]
public: AssemblyBuilder* DefineDynamicAssembly(
   AssemblyName* name,
   AssemblyBuilderAccess access,
   String* dir,
   PermissionSet* requiredPermissions,
   PermissionSet* optionalPermissions,
   PermissionSet* refusedPermissions
);
[JScript]
public function DefineDynamicAssembly(
   name : AssemblyName,
   access : AssemblyBuilderAccess,
   dir : String,
   requiredPermissions : PermissionSet,
   optionalPermissions : PermissionSet,
   refusedPermissions : PermissionSet
) : AssemblyBuilder;

Parameters

name
The unique identity of the dynamic assembly.
access
The mode in which the dynamic assembly will be accessed.
dir
The name of the directory in which the assembly will be saved. If dir is a null reference (in Visual Basic Nothing), the directory defaults to the current directory.
requiredPermissions
The required permission request.
optionalPermissions
The optional permission request.
refusedPermissions
The refused permission request.

Return Value

An AssemblyBuilder object that represents the dynamic assembly created.

Exceptions

Exception Type | Condition
ArgumentNullException | is thrown if name is a null reference (Nothing).

Remarks

You can specify partial signing of the assembly by specifing AssemblyName.Originator. You can specify full signing of the assembly by specifying AssemblyName.Originator and AssemblyName.KeyPair.

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.DefineDynamicAssembly Overload List


AppDomain.DefineDynamicAssembly (AssemblyName, AssemblyBuilderAccess, Evidence, PermissionSet, PermissionSet, PermissionSet)

Defines a dynamic assembly with the given name, given access, supplied evidence, and the permission requests.

Only fully trusted callers can supply their evidence when defining a dynamic assembly. The runtime will map the evidence through policy to determine the granted permissions. Semi-trusted callers must supply a a null reference (in Visual Basic Nothing) evidence. If evidence is a null reference (Nothing), the runtime copies the permission sets (that is, the current grant and deny sets) from the caller's assembly to the dynamic assembly being defined and marks policy as resolved.

If the dynamic assembly is saved to disk, subsequent loads will get grants based on policies associated with the location where the assembly was saved.

[Visual Basic]
Overloads Public Function DefineDynamicAssembly( _
   ByVal name As AssemblyName, _
   ByVal access As AssemblyBuilderAccess, _
   ByVal evidence As Evidence, _
   ByVal requiredPermissions As PermissionSet, _
   ByVal optionalPermissions As PermissionSet, _
   ByVal refusedPermissions As PermissionSet _
) As AssemblyBuilder
[C#]
public AssemblyBuilder DefineDynamicAssembly(
   AssemblyName name,
   AssemblyBuilderAccess access,
   Evidence evidence,
   PermissionSet requiredPermissions,
   PermissionSet optionalPermissions,
   PermissionSet refusedPermissions
);
[C++]
public: AssemblyBuilder* DefineDynamicAssembly(
   AssemblyName* name,
   AssemblyBuilderAccess access,
   Evidence* evidence,
   PermissionSet* requiredPermissions,
   PermissionSet* optionalPermissions,
   PermissionSet* refusedPermissions
);
[JScript]
public function DefineDynamicAssembly(
   name : AssemblyName,
   access : AssemblyBuilderAccess,
   evidence : Evidence,
   requiredPermissions : PermissionSet,
   optionalPermissions : PermissionSet,
   refusedPermissions : PermissionSet
) : AssemblyBuilder;

Parameters

name
The unique identity of the dynamic assembly.
access
The mode in which the dynamic assembly will be accessed.
evidence
The evidence supplied for the dynamic assembly.
requiredPermissions
The required permission request.
optionalPermissions
The optional permission request.
refusedPermissions
The refused permission request.

Return Value

An AssemblyBuilder object that represents the dynamic assembly created.

Exceptions

Exception Type | Condition
ArgumentNullException | is thrown if name is a null reference (Nothing).

Remarks

You can specify partial signing of the assembly by specifing AssemblyName.Originator. You can specify full signing of the assembly by specifying AssemblyName.Originator and AssemblyName.KeyPair.

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.DefineDynamicAssembly Overload List


AppDomain.DefineDynamicAssembly (AssemblyName, AssemblyBuilderAccess, String, Evidence, PermissionSet, PermissionSet, PermissionSet, Boolean)

Defines a dynamic Assembly with the given name, given access, the name of the directory for saving the Assembly, supplied Evidence, and the permission requests. Optionally, the caller can specify if the creation of modules, types, and members in the dynamic Assembly should be synchronized.

Only fully trusted callers can supply their evidence when defining a dynamic Assembly. The runtime will map the Evidence through policy to determine the granted permissions. Semi-trusted callers must supply a Evidence. If evidence is a null reference (in Visual Basic Nothing), the runtime copies the permission sets, i.e., the current grant and deny sets, from the caller's Assembly to the dynamic Assembly being defined and marks policy as resolved.

If the dynamic Assembly is saved to disk, subsequent loads will get grants based on policies associated with the location where the Assembly was saved.

[Visual Basic]
Overloads Public Function DefineDynamicAssembly( _
   ByVal name As AssemblyName, _
   ByVal access As AssemblyBuilderAccess, _
   ByVal dir As String, _
   ByVal evidence As Evidence, _
   ByVal requiredPermissions As PermissionSet, _
   ByVal optionalPermissions As PermissionSet, _
   ByVal refusedPermissions As PermissionSet, _
   ByVal isSynchronized As Boolean _
) As AssemblyBuilder
[C#]
public AssemblyBuilder DefineDynamicAssembly(
   AssemblyName name,
   AssemblyBuilderAccess access,
   string dir,
   Evidence evidence,
   PermissionSet requiredPermissions,
   PermissionSet optionalPermissions,
   PermissionSet refusedPermissions,
   bool isSynchronized
);
[C++]
public: AssemblyBuilder* DefineDynamicAssembly(
   AssemblyName* name,
   AssemblyBuilderAccess access,
   String* dir,
   Evidence* evidence,
   PermissionSet* requiredPermissions,
   PermissionSet* optionalPermissions,
   PermissionSet* refusedPermissions,
   bool isSynchronized
);
[JScript]
public function DefineDynamicAssembly(
   name : AssemblyName,
   access : AssemblyBuilderAccess,
   dir : String,
   evidence : Evidence,
   requiredPermissions : PermissionSet,
   optionalPermissions : PermissionSet,
   refusedPermissions : PermissionSet,
   isSynchronized : Boolean
) : AssemblyBuilder;

Parameters

name
The unique identity of the dynamic Assembly.
access
The mode in which the dynamic Assembly will be accessed.
dir
The name of the directory in which the Assembly will be saved. If dir is a null reference (Nothing), the directory defaults to the current directory.
evidence
The evidence supplied for the dynamic Assembly.
requiredPermissions
The required permission request.
optionalPermissions
The optional permission request.
refusedPermissions
The refused permission request.
isSynchronized
If true, the creation of modules, types, and members in the dynamic Assembly are synchronized.

Return Value

An AssemblyBuilder object that represents the dynamic Assembly created.

Exceptions

Exception Type | Condition
ArgumentNullException | is thrown if name is a null reference (Nothing).

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.DefineDynamicAssembly Overload List


AppDomain.DefineDynamicAssembly (AssemblyName, AssemblyBuilderAccess, PermissionSet, PermissionSet, PermissionSet)

Defines a dynamic assembly with the given name, the given access, and the given permission requests.

[Visual Basic]
Overloads Public Function DefineDynamicAssembly( _
   ByVal name As AssemblyName, _
   ByVal access As AssemblyBuilderAccess, _
   ByVal requiredPermissions As PermissionSet, _
   ByVal optionalPermissions As PermissionSet, _
   ByVal refusedPermissions As PermissionSet _
) As AssemblyBuilder
[C#]
public AssemblyBuilder DefineDynamicAssembly(
   AssemblyName name,
   AssemblyBuilderAccess access,
   PermissionSet requiredPermissions,
   PermissionSet optionalPermissions,
   PermissionSet refusedPermissions
);
[C++]
public: AssemblyBuilder* DefineDynamicAssembly(
   AssemblyName* name,
   AssemblyBuilderAccess access,
   PermissionSet* requiredPermissions,
   PermissionSet* optionalPermissions,
   PermissionSet* refusedPermissions
);
[JScript]
public function DefineDynamicAssembly(
   name : AssemblyName,
   access : AssemblyBuilderAccess,
   requiredPermissions : PermissionSet,
   optionalPermissions : PermissionSet,
   refusedPermissions : PermissionSet
) : AssemblyBuilder;

Parameters

name
The unique identity of the dynamic assembly.
access
The mode in which the dynamic assembly will be accessed.
requiredPermissions
The required permission request.
optionalPermissions
The optional permission request.
refusedPermissions
The refused permission request.

Return Value

An AssemblyBuilder object that represents the dynamic assembly created.

Exceptions

Exception Type | Condition
ArgumentNullException | is thrown if name is a null reference (in Visual Basic Nothing).

Remarks

You can specify partial signing of the assembly by specifing AssemblyName.Originator. You can specify full signing of the assembly by specifying AssemblyName.Originator and AssemblyName.KeyPair.

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.DefineDynamicAssembly Overload List


AppDomain.DefineDynamicAssembly (AssemblyName, AssemblyBuilderAccess, String, Evidence)

Defines a dynamic assembly with the given name, given access, the name of the directory for saving the assembly, and the supplied evidence.

Only fully trusted callers can supply their evidence when defining a dynamic assembly. The runtime will map the evidence through policy to determine the granted permissions. Semi-trusted callers must supply a a null reference (in Visual Basic Nothing) evidence. If evidence is a null reference (Nothing), the runtime copies the permission sets, i.e., the current grant and deny sets, from the caller's assembly to the dynamic assembly being defined and marks policy as resolved. If the dynamic assembly is saved to disk, subsequent loads will get grants based on policies associated with the location where the assembly was saved.

[Visual Basic]
Overloads Public Function DefineDynamicAssembly( _
   ByVal name As AssemblyName, _
   ByVal access As AssemblyBuilderAccess, _
   ByVal dir As String, _
   ByVal evidence As Evidence _
) As AssemblyBuilder
[C#]
public AssemblyBuilder DefineDynamicAssembly(
   AssemblyName name,
   AssemblyBuilderAccess access,
   string dir,
   Evidence evidence
);
[C++]
public: AssemblyBuilder* DefineDynamicAssembly(
   AssemblyName* name,
   AssemblyBuilderAccess access,
   String* dir,
   Evidence* evidence
);
[JScript]
public function DefineDynamicAssembly(
   name : AssemblyName,
   access : AssemblyBuilderAccess,
   dir : String,
   evidence : Evidence
) : AssemblyBuilder;

Parameters

name
The unique identity of the dynamic assembly.
access
The mode in which the dynamic assembly will be accessed.
dir
The name of the directory in which the assembly will be saved. If dir is a null reference (Nothing), the directory defaults to the current directory.
evidence
The evidence supplied for the dynamic assembly.

Return Value

An AssemblyBuilder object that represents the dynamic assembly created.

Exceptions

Exception Type | Condition
ArgumentNullException | is thrown if name is a null reference (Nothing).

Remarks

You can specify partial signing of the assembly by specifing AssemblyName.Originator. You can specify full signing of the assembly by specifying AssemblyName.Originator and AssemblyName.KeyPair.

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.DefineDynamicAssembly Overload List


AppDomain.DefineDynamicAssembly (AssemblyName, AssemblyBuilderAccess)

Defines a dynamic assembly with the given name and the given access.

[Visual Basic]
Overloads Public Function DefineDynamicAssembly( _
   ByVal name As AssemblyName, _
   ByVal access As AssemblyBuilderAccess _
) As AssemblyBuilder
[C#]
public AssemblyBuilder DefineDynamicAssembly(
   AssemblyName name,
   AssemblyBuilderAccess access
);
[C++]
public: AssemblyBuilder* DefineDynamicAssembly(
   AssemblyName* name,
   AssemblyBuilderAccess access
);
[JScript]
public function DefineDynamicAssembly(
   name : AssemblyName,
   access : AssemblyBuilderAccess
) : AssemblyBuilder;

Parameters

name
The unique identity of the dynamic assembly.
access
The mode in which the dynamic assembly will be accessed.

Return Value

An AssemblyBuilder object that represents the dynamic assembly created.

Exceptions

Exception Type | Condition
ArgumentNullException | is thrown if name is a null reference (in Visual Basic Nothing).

Remarks

You can specify partial signing of the assembly by specifing AssemblyName.Originator. You can specify full signing of the assembly by specifying AssemblyName.Originator and AssemblyName.KeyPair.

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.DefineDynamicAssembly Overload List


AppDomain.DefineDynamicAssembly (AssemblyName, AssemblyBuilderAccess, String)

Defines a dynamic assembly with the given name, the given access, and the name of the directory for saving the assembly.

[Visual Basic]
Overloads Public Function DefineDynamicAssembly( _
   ByVal name As AssemblyName, _
   ByVal access As AssemblyBuilderAccess, _
   ByVal dir As String _
) As AssemblyBuilder
[C#]
public AssemblyBuilder DefineDynamicAssembly(
   AssemblyName name,
   AssemblyBuilderAccess access,
   string dir
);
[C++]
public: AssemblyBuilder* DefineDynamicAssembly(
   AssemblyName* name,
   AssemblyBuilderAccess access,
   String* dir
);
[JScript]
public function DefineDynamicAssembly(
   name : AssemblyName,
   access : AssemblyBuilderAccess,
   dir : String
) : AssemblyBuilder;

Parameters

name
The unique identity of the dynamic assembly.
access
The mode in which the dynamic assembly will be accessed.
dir
The name of the directory in which the assembly will be saved. If dir is a null reference (in Visual Basic Nothing), the directory defaults to the current directory.

Return Value

An AssemblyBuilder object that represents the dynamic assembly created.

Exceptions

Exception Type | Condition
ArgumentNullException | is thrown if name is a null reference (Nothing).

Remarks

You can specify partial signing of the assembly by specifing AssemblyName.Originator. You can specify full signing of the assembly by specifying AssemblyName.Originator and AssemblyName.KeyPair.

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.DefineDynamicAssembly Overload List


AppDomain.DefineDynamicAssembly (AssemblyName, AssemblyBuilderAccess, String, Evidence, PermissionSet, PermissionSet, PermissionSet)

Defines a dynamic assembly with the given name, given access, the name of the directory for saving the assembly, supplied evidence, and the permission requests.

Only fully trusted callers can supply their evidence when defining a dynamic assembly. The runtime will map the evidence through policy to determine the granted permissions. Semi-trusted callers must supply a a null reference (in Visual Basic Nothing) evidence. If evidence is a null reference (Nothing), the runtime copies the permission sets, i.e., the current grant and deny sets, from the caller's assembly to the dynamic assembly being defined and marks policy as resolved.

If the dynamic assembly is saved to disk, subsequent loads will get grants based on policies associated with the location where the assembly was saved.

[Visual Basic]
Overloads Public Function DefineDynamicAssembly( _
   ByVal name As AssemblyName, _
   ByVal access As AssemblyBuilderAccess, _
   ByVal dir As String, _
   ByVal evidence As Evidence, _
   ByVal requiredPermissions As PermissionSet, _
   ByVal optionalPermissions As PermissionSet, _
   ByVal refusedPermissions As PermissionSet _
) As AssemblyBuilder
[C#]
public AssemblyBuilder DefineDynamicAssembly(
   AssemblyName name,
   AssemblyBuilderAccess access,
   string dir,
   Evidence evidence,
   PermissionSet requiredPermissions,
   PermissionSet optionalPermissions,
   PermissionSet refusedPermissions
);
[C++]
public: AssemblyBuilder* DefineDynamicAssembly(
   AssemblyName* name,
   AssemblyBuilderAccess access,
   String* dir,
   Evidence* evidence,
   PermissionSet* requiredPermissions,
   PermissionSet* optionalPermissions,
   PermissionSet* refusedPermissions
);
[JScript]
public function DefineDynamicAssembly(
   name : AssemblyName,
   access : AssemblyBuilderAccess,
   dir : String,
   evidence : Evidence,
   requiredPermissions : PermissionSet,
   optionalPermissions : PermissionSet,
   refusedPermissions : PermissionSet
) : AssemblyBuilder;

Parameters

name
The unique identity of the dynamic assembly.
access
The mode in which the dynamic assembly will be accessed.
dir
The name of the directory in which the assembly will be saved. If dir is a null reference (Nothing), the directory defaults to the current directory.
evidence
The evidence supplied for the dynamic assembly.
requiredPermissions
The required permission request.
optionalPermissions
The optional permission request.
refusedPermissions
The refused permission request.

Return Value

An AssemblyBuilder object that represents the dynamic assembly created.

Exceptions

Exception Type | Condition
ArgumentNullException | is thrown if name is a null reference (Nothing).

Remarks

You can specify partial signing of the assembly by specifing AssemblyName.Originator. You can specify full signing of the assembly by specifying AssemblyName.Originator and AssemblyName.KeyPair.

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.DefineDynamicAssembly Overload List


AppDomain.DefineDynamicAssembly (AssemblyName, AssemblyBuilderAccess, Evidence)

Defines a dynamic assembly with the given name, the given access, and the supplied evidence.

Only fully trusted callers can supply evidence when defining a dynamic assembly. The runtime will map the supplied evidence through policy to determine the granted permissions. Semi-trusted callers must supply a a null reference (in Visual Basic Nothing) evidence. If evidence is a null reference (Nothing), the runtime copies the permission sets, i.e., the current grant and deny sets, from the caller's assembly to the dynamic assembly being defined and marks policy as resolved. If the dynamic assembly is saved to disk, subsequent loads will get grants based on policies associated with the location where the assembly was saved.

[Visual Basic]
Overloads Public Function DefineDynamicAssembly( _
   ByVal name As AssemblyName, _
   ByVal access As AssemblyBuilderAccess, _
   ByVal evidence As Evidence _
) As AssemblyBuilder
[C#]
public AssemblyBuilder DefineDynamicAssembly(
   AssemblyName name,
   AssemblyBuilderAccess access,
   Evidence evidence
);
[C++]
public: AssemblyBuilder* DefineDynamicAssembly(
   AssemblyName* name,
   AssemblyBuilderAccess access,
   Evidence* evidence
);
[JScript]
public function DefineDynamicAssembly(
   name : AssemblyName,
   access : AssemblyBuilderAccess,
   evidence : Evidence
) : AssemblyBuilder;

Parameters

name
The unique identity of the dynamic assembly.
access
The mode in which the dynamic assembly will be accessed.
evidence
The evidence supplied for the dynamic assembly.

Return Value

An AssemblyBuilder object that represents the dynamic assembly created.

Exceptions

Exception Type | Condition
ArgumentNullException | is thrown if name is a null reference (Nothing).

Remarks

You can specify partial signing of the assembly by specifing AssemblyName.Originator. You can specify full signing of the assembly by specifying AssemblyName.Originator and AssemblyName.KeyPair.

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.DefineDynamicAssembly Overload List


AppDomain.ExecuteAssembly

Executes the assembly given its file name.

Overload List

Execute the Assembly given its file name and supplied Evidence. The entry point is called with the supplied arguments. Optionally, the Assembly can be shared across application domains.

[Visual Basic] Overloads Public Function ExecuteAssembly(String, Evidence, Boolean, String()) As Integer
[C#] public int ExecuteAssembly(String, Evidence, bool, String[]);
[C++] public: int ExecuteAssembly(String*, Evidence, bool, String*[]);
[JScript] public function ExecuteAssembly(String, Evidence, Boolean, String[]) : int;

Execute the Assembly given its file name and supplied Evidence. Optionally, the Assembly can be shared across application domains.

[Visual Basic] Overloads Public Function ExecuteAssembly(String, Evidence, Boolean) As Integer
[C#] public int ExecuteAssembly(String, Evidence, bool);
[C++] public: int ExecuteAssembly(String*, Evidence, bool);
[JScript] public function ExecuteAssembly(String, Evidence, Boolean) : int;

Execute the Assembly given its file name and supplied evidence.

[Visual Basic] Overloads Public Function ExecuteAssembly(String, Evidence) As Integer
[C#] public int ExecuteAssembly(String, Evidence);
[C++] public: int ExecuteAssembly(String*, Evidence);
[JScript] public function ExecuteAssembly(String, Evidence) : int;

Execute the Assembly given its file name. The method specified in the NGWS runtime header is called.

[Visual Basic] Overloads Public Function ExecuteAssembly(String) As Integer
[C#] public int ExecuteAssembly(String);
[C++] public: int ExecuteAssembly(String*);
[JScript] public function ExecuteAssembly(String) : int;

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.ExecuteAssembly (String, Evidence, Boolean, String[])

Execute the Assembly given its file name and supplied Evidence. The entry point is called with the supplied arguments. Optionally, the Assembly can be shared across application domains.

[Visual Basic]
Overloads Public Function ExecuteAssembly( _
   ByVal fileName As String, _
   ByVal assemblySecurity As Evidence, _
   ByVal shared As Boolean, _
   ByVal args() As String _
) As Integer
[C#]
public int ExecuteAssembly(
   string fileName,
   Evidence assemblySecurity,
   bool shared,
   string[] args
);
[C++]
public: int ExecuteAssembly(
   String* fileName,
   Evidence* assemblySecurity,
   bool shared,
   String* args[]
);
[JScript]
public function ExecuteAssembly(
   fileName : String,
   assemblySecurity : Evidence,
   shared : Boolean,
   args : String[]
) : int;

Parameters

fileName
The name of the file from which the Assembly is to be loaded.
assemblySecurity
The supplied Evidence for the Assembly.
shared
If true, the Assembly is loaded in a form where its JIT-compiled code can be reused by multiple application domains (at a slight cost in code quality).
args
The arguments to the entry point of the Assembly.

Return Value

Returns the value returned by the entry point of the Assembly.

Remarks

The method does not spawn a new process, create a new application domain, or execute the entry point method on a new thread.

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.ExecuteAssembly Overload List


AppDomain.ExecuteAssembly (String, Evidence, Boolean)

Execute the Assembly given its file name and supplied Evidence. Optionally, the Assembly can be shared across application domains.

[Visual Basic]
Overloads Public Function ExecuteAssembly( _
   ByVal fileName As String, _
   ByVal assemblySecurity As Evidence, _
   ByVal shared As Boolean _
) As Integer
[C#]
public int ExecuteAssembly(
   string fileName,
   Evidence assemblySecurity,
   bool shared
);
[C++]
public: int ExecuteAssembly(
   String* fileName,
   Evidence* assemblySecurity,
   bool shared
);
[JScript]
public function ExecuteAssembly(
   fileName : String,
   assemblySecurity : Evidence,
   shared : Boolean
) : int;

Parameters

fileName
The name of the file from which the Assembly is to be loaded.
assemblySecurity
The supplied Evidence for the Assembly.
shared
If true, the Assembly is loaded in a form where its JIT-compiled code can be reused by multiple application domains (at a slight cost in code quality).

Return Value

Returns the value returned by the entry point of the Assembly.

Remarks

The method does not spawn a new process, create a new application domain, or execute the entry point method on a new thread.

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.ExecuteAssembly Overload List


AppDomain.ExecuteAssembly (String, Evidence)

Execute the Assembly given its file name and supplied evidence.

[Visual Basic]
Overloads Public Function ExecuteAssembly( _
   ByVal fileName As String, _
   ByVal assemblySecurity As Evidence _
) As Integer
[C#]
public int ExecuteAssembly(
   string fileName,
   Evidence assemblySecurity
);
[C++]
public: int ExecuteAssembly(
   String* fileName,
   Evidence* assemblySecurity
);
[JScript]
public function ExecuteAssembly(
   fileName : String,
   assemblySecurity : Evidence
) : int;

Parameters

fileName
The name of the file from which the Assembly is to be loaded.
assemblySecurity
The supplied Evidence for the Assembly.

Return Value

Returns the value returned by the entry point of the Assembly.

Remarks

The method does not spawn a new process, create a new application domain, or execute the entry point method on a new thread.

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.ExecuteAssembly Overload List


AppDomain.ExecuteAssembly (String)

Execute the Assembly given its file name. The method specified in the NGWS runtime header is called.

[Visual Basic]
Overloads Public Function ExecuteAssembly( _
   ByVal fileName As String _
) As Integer
[C#]
public int ExecuteAssembly(
   string fileName
);
[C++]
public: int ExecuteAssembly(
   String* fileName
);
[JScript]
public function ExecuteAssembly(
   fileName : String
) : int;

Parameters

fileName
The name of the file from which the Assembly is to be loaded.

Return Value

Returns the value returned by the entry point of the Assembly.

Remarks

The method does not spawn a new process, create a new application domain, or execute the entry point method on a new thread.

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.ExecuteAssembly Overload List


AppDomain.GetAssemblies

Gets the assemblies that have been loaded into this application domain.

[Visual Basic]
Public Function GetAssemblies() As Assembly ()
[C#]
public Assembly[] GetAssemblies();
[C++]
public: Assembly* GetAssemblies() [];
[JScript]
public function GetAssemblies() : Assembly[];

Return Value

An array of assemblies.

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.GetCurrentThreadId

[To be supplied.]

[Visual Basic]
extern Public Shared Function GetCurrentThreadId() As Integer
[C#]
public static extern int GetCurrentThreadId();
[C++]
public: static extern int GetCurrentThreadId();
[JScript]
public static extern function GetCurrentThreadId() : int;

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.GetData

Gets the value stored in the current application domain for the specified data name.

[Visual Basic]
Public Function GetData( _
   ByVal name As String _
) As Object
[C#]
public object GetData(
   string name
);
[C++]
public: Object* GetData(
   String* name
);
[JScript]
public function GetData(
   name : String
) : Object;

Parameters

name
The name of an application domain property.

Return Value

The value of the specified application domain property.

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.GetThreads

Gets the Thread objects representing the threads in the application domain.

[Visual Basic]
Public Function GetThreads() As Thread ()
[C#]
public Thread[] GetThreads();
[C++]
public: Thread* GetThreads() [];
[JScript]
public function GetThreads() : Thread[];

Return Value

An array of Thread objects representing the threads in the application domain

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.InitializeLifetimeService

[To be supplied.]

[Visual Basic]
Overrides Public Function InitializeLifetimeService() As Object
[C#]
public override object InitializeLifetimeService();
[C++]
public: override Object* InitializeLifetimeService();
[JScript]
public override function InitializeLifetimeService() : Object;

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.Load

Loads an Assembly into this application domain.

Overload List

Loads an Assembly given its display name. The Assembly may be shared.

[Visual Basic] Overloads Public Function Load(String, Boolean) As Assembly
[C#] public Assembly Load(String, bool);
[C++] public: Assembly* Load(String*, bool);
[JScript] public function Load(String, Boolean) : Assembly;

Loads the Assembly with a COFF based image containing an emitted Assembly. The raw bytes representing the symbols for the Assembly are also loaded.

[Visual Basic] Overloads Public Function Load(Byte(), Byte()) As Assembly
[C#] public Assembly Load(byte[], byte[]);
[C++] public: Assembly* Load(unsigned char*[], unsigned char*[]);
[JScript] public function Load(Byte[], Byte[]) : Assembly;

Loads the Assembly with a COFF based image containing an emitted Assembly.

[Visual Basic] Overloads Public Function Load(Byte()) As Assembly
[C#] public Assembly Load(byte[]);
[C++] public: Assembly* Load(unsigned char*[]);
[JScript] public function Load(Byte[]) : Assembly;

Loads an Assembly given its AssemblyName and supplied evidence. The Assembly may be shared.

[Visual Basic] Overloads Public Function Load(AssemblyName, Evidence, Boolean) As Assembly
[C#] public Assembly Load(AssemblyName, Evidence, bool);
[C++] public: Assembly* Load(AssemblyName*, Evidence, bool);
[JScript] public function Load(AssemblyName, Evidence, Boolean) : Assembly;

Loads an Assembly given its display name.

[Visual Basic] Overloads Public Function Load(String) As Assembly
[C#] public Assembly Load(String);
[C++] public: Assembly* Load(String*);
[JScript] public function Load(String) : Assembly;

Loads an Assembly given its AssemblyName.

[Visual Basic] Overloads Public Function Load(AssemblyName) As Assembly
[C#] public Assembly Load(AssemblyName);
[C++] public: Assembly* Load(AssemblyName*);
[JScript] public function Load(AssemblyName) : Assembly;

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.Load (String, Boolean)

Loads an Assembly given its display name. The Assembly may be shared.

[Visual Basic]
Overloads Public Function Load( _
   ByVal assemblyString As String, _
   ByVal shared As Boolean _
) As Assembly
[C#]
public Assembly Load(
   string assemblyString,
   bool shared
);
[C++]
public: Assembly* Load(
   String* assemblyString,
   bool shared
);
[JScript]
public function Load(
   assemblyString : String,
   shared : Boolean
) : Assembly;

Parameters

assemblyString
The display name of the Assembly.
shared
If true, the Assembly is loaded in a form where its JIT-compiled code can be reused by multiple application domains (at a slight cost in code quality).

Return Value

The loaded Assembly.

Exceptions

Exception Type | Condition
ArgumentNullException | if assemblyRef is a null reference (in Visual Basic Nothing)

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.Load Overload List


AppDomain.Load (Byte[], Byte[])

Loads the Assembly with a COFF based image containing an emitted Assembly. The raw bytes representing the symbols for the Assembly are also loaded.

[Visual Basic]
Overloads Public Function Load( _
   ByVal rawAssembly() As Byte, _
   ByVal rawSymbolStore() As Byte _
) As Assembly
[C#]
public Assembly Load(
   byte[] rawAssembly,
   byte[] rawSymbolStore
);
[C++]
public: Assembly* Load(
   unsigned char* rawAssembly[],
   unsigned char* rawSymbolStore[]
);
[JScript]
public function Load(
   rawAssembly : Byte[],
   rawSymbolStore : Byte[]
) : Assembly;

Parameters

rawAssembly
[To be supplied.]
rawSymbolStore
[To be supplied.]

Return Value

The loaded Assembly.

Exceptions

Exception Type | Condition
ArgumentNullException | if assemblyRef is a null reference (in Visual Basic Nothing)

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.Load Overload List


AppDomain.Load (Byte[])

Loads the Assembly with a COFF based image containing an emitted Assembly.

[Visual Basic]
Overloads Public Function Load( _
   ByVal rawAssembly() As Byte _
) As Assembly
[C#]
public Assembly Load(
   byte[] rawAssembly
);
[C++]
public: Assembly* Load(
   unsigned char* rawAssembly[]
);
[JScript]
public function Load(
   rawAssembly : Byte[]
) : Assembly;

Parameters

rawAssembly
[To be supplied.]

Return Value

The loaded Assembly.

Exceptions

Exception Type | Condition
ArgumentNullException | if assemblyRef is a null reference (in Visual Basic Nothing)

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.Load Overload List


AppDomain.Load (AssemblyName, Evidence, Boolean)

Loads an Assembly given its AssemblyName and supplied evidence. The Assembly may be shared.

[Visual Basic]
Overloads Public Function Load( _
   ByVal assemblyRef As AssemblyName, _
   ByVal assemblySecurity As Evidence, _
   ByVal shared As Boolean _
) As Assembly
[C#]
public Assembly Load(
   AssemblyName assemblyRef,
   Evidence assemblySecurity,
   bool shared
);
[C++]
public: Assembly* Load(
   AssemblyName* assemblyRef,
   Evidence* assemblySecurity,
   bool shared
);
[JScript]
public function Load(
   assemblyRef : AssemblyName,
   assemblySecurity : Evidence,
   shared : Boolean
) : Assembly;

Parameters

assemblyRef
The AssemblyName that describes the Assembly to be loaded.
assemblySecurity
Evidence for loading the Assembly.
shared
If true, the Assembly is loaded in a form where its JIT-compiled code can be reused by multiple application domains (at a slight cost in code quality).

Return Value

The loaded Assembly.

Exceptions

Exception Type | Condition
ArgumentNullException | if assemblyRef is a null reference (in Visual Basic Nothing)

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.Load Overload List


AppDomain.Load (String)

Loads an Assembly given its display name.

[Visual Basic]
Overloads Public Function Load( _
   ByVal assemblyString As String _
) As Assembly
[C#]
public Assembly Load(
   string assemblyString
);
[C++]
public: Assembly* Load(
   String* assemblyString
);
[JScript]
public function Load(
   assemblyString : String
) : Assembly;

Parameters

assemblyString
[To be supplied.]

Return Value

The loaded Assembly.

Exceptions

Exception Type | Condition
ArgumentNullException | if assemblyRef is a null reference (in Visual Basic Nothing)

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.Load Overload List


AppDomain.Load (AssemblyName)

Loads an Assembly given its AssemblyName.

[Visual Basic]
Overloads Public Function Load( _
   ByVal assemblyRef As AssemblyName _
) As Assembly
[C#]
public Assembly Load(
   AssemblyName assemblyRef
);
[C++]
public: Assembly* Load(
   AssemblyName* assemblyRef
);
[JScript]
public function Load(
   assemblyRef : AssemblyName
) : Assembly;

Parameters

assemblyRef
The AssemblyName that describes the Assembly to be loaded.

Return Value

The loaded Assembly.

Exceptions

Exception Type | Condition
ArgumentNullException | if assemblyRef is a null reference (in Visual Basic Nothing)

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.Load Overload List


AppDomain.RemoveOnAssemblyLoad

Unsubscribes to the "assembly load" event. The "assembly load" event is raised when an assembly is loaded into the application domain.

[Visual Basic]
Public Sub RemoveOnAssemblyLoad( _
   ByVal handler As EventHandler _
)
[C#]
public void RemoveOnAssemblyLoad(
   EventHandler handler
);
[C++]
public: void RemoveOnAssemblyLoad(
   EventHandler* handler
);
[JScript]
public function RemoveOnAssemblyLoad(
   handler : EventHandler
);

Parameters

handler
The delegate that was previously registered.

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.RemoveOnStop

Unsubscribes to the "application domain stop" event.

[Visual Basic]
Public Sub RemoveOnStop( _
   ByVal handler As EventHandler _
)
[C#]
public void RemoveOnStop(
   EventHandler handler
);
[C++]
public: void RemoveOnStop(
   EventHandler* handler
);
[JScript]
public function RemoveOnStop(
   handler : EventHandler
);

Parameters

handler
The delegate that was previously registered.

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.RemoveOnUnhandledException

Unsubscribes to the "unhandled exception" event.

[Visual Basic]
Public Sub RemoveOnUnhandledException( _
   ByVal handler As UnhandledExceptionEventHandler _
)
[C#]
public void RemoveOnUnhandledException(
   UnhandledExceptionEventHandler handler
);
[C++]
public: void RemoveOnUnhandledException(
   UnhandledExceptionEventHandler* handler
);
[JScript]
public function RemoveOnUnhandledException(
   handler : UnhandledExceptionEventHandler
);

Parameters

handler
The delegate that was previously registered.

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.RemoveOnUnload

Unsubscribes to the "application domain unload" event.

[Visual Basic]
Public Sub RemoveOnUnload( _
   ByVal handler As EventHandler _
)
[C#]
public void RemoveOnUnload(
   EventHandler handler
);
[C++]
public: void RemoveOnUnload(
   EventHandler* handler
);
[JScript]
public function RemoveOnUnload(
   handler : EventHandler
);

Parameters

handler
The delegate that was previously registered.

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.SetAppDomainPolicy

Set the security policy for this application domain.

[Visual Basic]
Public Sub SetAppDomainPolicy( _
   ByVal domainPolicy As PolicyLevel _
)
[C#]
public void SetAppDomainPolicy(
   PolicyLevel domainPolicy
);
[C++]
public: void SetAppDomainPolicy(
   PolicyLevel* domainPolicy
);
[JScript]
public function SetAppDomainPolicy(
   domainPolicy : PolicyLevel
);

Parameters

domainPolicy
The policy for the application domain.

Exceptions

Exception Type | Condition
PolicyException | if the principal has been set previously.

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.SetData

Sets the value stored in the current application domain for the specified data name.

[Visual Basic]
Public Sub SetData( _
   ByVal name As String, _
   ByVal data As Object _
)
[C#]
public void SetData(
   string name,
   object data
);
[C++]
public: void SetData(
   String* name,
   Object* data
);
[JScript]
public function SetData(
   name : String,
   data : Object
);

Parameters

name
The name of an application domain property.
data
The value of the application domain property.

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.SetPrincipalPolicy

Set the class of the default principal object to be attached to threads if they attempt to bind to a principal while executing in this application domain.

[Visual Basic]
Public Sub SetPrincipalPolicy( _
   ByVal policy As PrincipalPolicy _
)
[C#]
public void SetPrincipalPolicy(
   PrincipalPolicy policy
);
[C++]
public: void SetPrincipalPolicy(
   PrincipalPolicy policy
);
[JScript]
public function SetPrincipalPolicy(
   policy : PrincipalPolicy
);

Parameters

policy
The class of the principal object to be attached to threads.

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.SetThreadPrincipal

Set the default principal object to be attached to threads if they attempt to bind to a principal while executing in this application domain.

[Visual Basic]
Public Sub SetThreadPrincipal( _
   ByVal principal As IPrincipal _
)
[C#]
public void SetThreadPrincipal(
   IPrincipal principal
);
[C++]
public: void SetThreadPrincipal(
   IPrincipal* principal
);
[JScript]
public function SetThreadPrincipal(
   principal : IPrincipal
);

Parameters

principal
The principal object to be attached to threads.

Exceptions

Exception Type | Condition
PolicyException | if the principal has been set previously.

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.ToString

Gets a string representation of the application domain.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

A string representation of this application domains

Remarks

The string representation specifies the friendly name of the application domains and the list of context policies.

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.Unload

[To be supplied.]

Overload List

Unloads the current domain.

[Visual Basic] Overloads Public Sub Unload()
[C#] public void Unload();
[C++] public: void Unload();
[JScript] public function Unload();

Unloads the specified application domain.

[Visual Basic] Overloads Public Shared Sub Unload(AppDomain)
[C#] public static void Unload(AppDomain);
[C++] public: static void Unload(AppDomain*);
[JScript] public static function Unload(AppDomain);

See Also

AppDomain Class | AppDomain Members | System Namespace


AppDomain.Unload ()

Unloads the current domain.

[Visual Basic]
Overloads Public Sub Unload()
[C#]
public void Unload();
[C++]
public: void Unload();
[JScript]
public function Unload();

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.Unload Overload List


AppDomain.Unload (AppDomain)

Unloads the specified application domain.

[Visual Basic]
Overloads Public Shared Sub Unload( _
   ByVal domain As AppDomain _
)
[C#]
public static void Unload(
   AppDomain domain
);
[C++]
public: static void Unload(
   AppDomain* domain
);
[JScript]
public static function Unload(
   domain : AppDomain
);

Parameters

domain
The application domain to be unloaded.

See Also

AppDomain Class | AppDomain Members | System Namespace | AppDomain.Unload Overload List


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AppDomain Events

The events of the AppDomain class are listed below. For a complete list of AppDomain class members, see the AppDomain Members topic.

Public:

AssemblyLoad | [To be supplied.]
Stop | [To be supplied.]
UnhandledException | [To be supplied.]
Unload | [To be supplied.]

See Also

AppDomain Class | System Namespace


AppDomain AssemblyLoad Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the AssemblyLoad event.

[Visual Basic]
Private Sub AppDomainName_AssemblyLoad( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
private void AppDomainName_AssemblyLoad(
   object sender,
   EventArgs e
);
[C++]
private: void AppDomainName_AssemblyLoad(
   Object* sender,
   EventArgs* e
);
[JScript]
private AppDomainName_AssemblyLoad(
   sender : Object,
   e : EventArgs
);

Parameters

sender
The source of the event.
e
An EventArgs that contains the event data. The following EventArgs properties provide information specific to this event.
Property Description
ExtendedInfo
Holds a reference to an object that manages the event's state.

See Also

AppDomain Class | AppDomain MembersTopic | System Namespace


AppDomain Stop Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the Stop event.

[Visual Basic]
Private Sub AppDomainName_Stop( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
private void AppDomainName_Stop(
   object sender,
   EventArgs e
);
[C++]
private: void AppDomainName_Stop(
   Object* sender,
   EventArgs* e
);
[JScript]
private AppDomainName_Stop(
   sender : Object,
   e : EventArgs
);

Parameters

sender
The source of the event.
e
An EventArgs that contains the event data. The following EventArgs properties provide information specific to this event.
Property Description
ExtendedInfo
Holds a reference to an object that manages the event's state.

See Also

AppDomain Class | AppDomain MembersTopic | System Namespace


AppDomain UnhandledException Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the UnhandledException event.

[Visual Basic]
Private Sub AppDomainName_UnhandledException( _
   ByVal sender As Object, _
   ByVal e As UnhandledExceptionEventArgs _
)
[C#]
private void AppDomainName_UnhandledException(
   object sender,
   UnhandledExceptionEventArgs e
);
[C++]
private: void AppDomainName_UnhandledException(
   Object* sender,
   UnhandledExceptionEventArgs* e
);
[JScript]
private AppDomainName_UnhandledException(
   sender : Object,
   e : UnhandledExceptionEventArgs
);

Parameters

sender
The source of the event.
e
An UnhandledExceptionEventArgs that contains the event data.

See Also

AppDomain Class | AppDomain MembersTopic | System Namespace


AppDomainFlags Class

Represents assembly binding information that can be added to an AppDomain. The members are used with the GetData and SetData methods to identify the AppDomain data to be used.

Object
AppDomainFlags

[Visual Basic]
NotInheritable Public Class AppDomainFlags
[C#]
public sealed class AppDomainFlags
[C++]
public __gc __sealed class AppDomainFlags
[JScript]
public class AppDomainFlags

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

AppDomainFlags Members | System Namespace


AppDomainFlags Members

Public:

Constructor

AppDomainFlags Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

ApplicationBase | Used to get or set the assembly cache manager's APPBASE variable. This is the directory where the assembly cache manager should begin probing for assemblies.
Configuration | Used to get or set the assembly cache manager's CONFIG variable. The value "Retail" is predefined, and would be the configuration provided by the assembly binding services if no specific configuration is requested. Otherwise, the configuration may be set to any string value.
ConfigurationFile | Used to get or set the assembly cache manager's APP_CONFIG_FILE variable. This variable is the name of the configuration file for an application domain. The configuration file describes the search rules and the configuration data for the application domain. The host that creates the application domain is responsible for supplying this data because the meaningful values vary by scenario. For example, the configuration data for ASP+ applications is stored per application, site and machine, while the configuration data for an executable is stored per application, user and machine. Only the host knows the specifics of the configuration data for their particular scenario.
Culture | Used to get or set the locale that an assembly should support. This information is used by the assembly binding services.
PrivateBinPath | Used to get or set the the assembly cache manager's PRIVATE_BINPATH variable. This path is a semi-colon separated list of directories that is combined with the ApplicationBase directory to probe for private assemblies. Private assemblies are deployed in the same directory structure as the application.
PrivateBinPathProbe | Used to get or set the "Application Probing" property of the application domain. If this property is set then the search is restricted to the private bin paths. This means the application directory will not be searched. This does not affect searching the global bin paths or the global assembly cache
Processor | Used to get or set the processors that an assembly should support. In V1, this information is not used by the assembly binding services but is meant for informational use only.
ShadowCopyDirectories | When the ShadowCopyFiles property is set ShowCopyDirs define the directories from which assemblies will be shadow copies. Assemblies found in other directories will not be shadow copied. If this property is not set then the default is to shadow copy the SharedBinPath.
ShadowCopyFiles | Used to get or set the "shadow copy" property of an application domain. If this property is set, the application domain will load a shadow copy of an assembly obtained from the assembly cache manager.
SharedBinPath | Used to get or set the assembly cache manager's SHARED_BINPATH variable. This path is a semi-colon separated list of directories that is combined with the ApplicationBase directory to probe for shared assemblies. Shared assemblies are published assemblies. Published assemblies need not be deployed in the same directory structure as the application.
SnapshotID | Used to get or set the SnapshotID. The SnapshotID is used by the assembly cache manager to track what assemblies are loaded in an application domain.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AppDomainFlags Class | System Namespace


AppDomainFlags Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public AppDomainFlags();
[C++]
public: AppDomainFlags();
[JScript]
public function AppDomainFlags();

See Also

AppDomainFlags Class | AppDomainFlags Members | System Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AppDomainFlags Fields

The fields of the AppDomainFlags class are listed below. For a complete list of AppDomainFlags class members, see the AppDomainFlags Members topic.

Public:

ApplicationBase | Used to get or set the assembly cache manager's APPBASE variable. This is the directory where the assembly cache manager should begin probing for assemblies.
Configuration | Used to get or set the assembly cache manager's CONFIG variable. The value "Retail" is predefined, and would be the configuration provided by the assembly binding services if no specific configuration is requested. Otherwise, the configuration may be set to any string value.
ConfigurationFile | Used to get or set the assembly cache manager's APP_CONFIG_FILE variable. This variable is the name of the configuration file for an application domain. The configuration file describes the search rules and the configuration data for the application domain. The host that creates the application domain is responsible for supplying this data because the meaningful values vary by scenario. For example, the configuration data for ASP+ applications is stored per application, site and machine, while the configuration data for an executable is stored per application, user and machine. Only the host knows the specifics of the configuration data for their particular scenario.
Culture | Used to get or set the locale that an assembly should support. This information is used by the assembly binding services.
PrivateBinPath | Used to get or set the the assembly cache manager's PRIVATE_BINPATH variable. This path is a semi-colon separated list of directories that is combined with the ApplicationBase directory to probe for private assemblies. Private assemblies are deployed in the same directory structure as the application.
PrivateBinPathProbe | Used to get or set the "Application Probing" property of the application domain. If this property is set then the search is restricted to the private bin paths. This means the application directory will not be searched. This does not affect searching the global bin paths or the global assembly cache
Processor | Used to get or set the processors that an assembly should support. In V1, this information is not used by the assembly binding services but is meant for informational use only.
ShadowCopyDirectories | When the ShadowCopyFiles property is set ShowCopyDirs define the directories from which assemblies will be shadow copies. Assemblies found in other directories will not be shadow copied. If this property is not set then the default is to shadow copy the SharedBinPath.
ShadowCopyFiles | Used to get or set the "shadow copy" property of an application domain. If this property is set, the application domain will load a shadow copy of an assembly obtained from the assembly cache manager.
SharedBinPath | Used to get or set the assembly cache manager's SHARED_BINPATH variable. This path is a semi-colon separated list of directories that is combined with the ApplicationBase directory to probe for shared assemblies. Shared assemblies are published assemblies. Published assemblies need not be deployed in the same directory structure as the application.
SnapshotID | Used to get or set the SnapshotID. The SnapshotID is used by the assembly cache manager to track what assemblies are loaded in an application domain.

See Also

AppDomainFlags Class | System Namespace


AppDomainFlags.ApplicationBase

Used to get or set the assembly cache manager's APPBASE variable. This is the directory where the assembly cache manager should begin probing for assemblies.

[Visual Basic]
Public Shared ReadOnly ApplicationBase As String
[C#]
public static readonly string ApplicationBase;
[C++]
public: static readonly String* ApplicationBase;
[JScript]
public static var ApplicationBase : String;

See Also

AppDomainFlags Class | AppDomainFlags Members | System Namespace


AppDomainFlags.Configuration

Used to get or set the assembly cache manager's CONFIG variable. The value "Retail" is predefined, and would be the configuration provided by the assembly binding services if no specific configuration is requested. Otherwise, the configuration may be set to any string value.

[Visual Basic]
Public Shared ReadOnly Configuration As String
[C#]
public static readonly string Configuration;
[C++]
public: static readonly String* Configuration;
[JScript]
public static var Configuration : String;

Remarks

This member will be removed in a future release.

See Also

AppDomainFlags Class | AppDomainFlags Members | System Namespace


AppDomainFlags.ConfigurationFile

Used to get or set the assembly cache manager's APP_CONFIG_FILE variable. This variable is the name of the configuration file for an application domain. The configuration file describes the search rules and the configuration data for the application domain. The host that creates the application domain is responsible for supplying this data because the meaningful values vary by scenario. For example, the configuration data for ASP+ applications is stored per application, site and machine, while the configuration data for an executable is stored per application, user and machine. Only the host knows the specifics of the configuration data for their particular scenario.

[Visual Basic]
Public Shared ReadOnly ConfigurationFile As String
[C#]
public static readonly string ConfigurationFile;
[C++]
public: static readonly String* ConfigurationFile;
[JScript]
public static var ConfigurationFile : String;

See Also

AppDomainFlags Class | AppDomainFlags Members | System Namespace


AppDomainFlags.Culture

Used to get or set the locale that an assembly should support. This information is used by the assembly binding services.

[Visual Basic]
Public Shared ReadOnly Culture As String
[C#]
public static readonly string Culture;
[C++]
public: static readonly String* Culture;
[JScript]
public static var Culture : String;

See Also

AppDomainFlags Class | AppDomainFlags Members | System Namespace


AppDomainFlags.PrivateBinPath

Used to get or set the the assembly cache manager's PRIVATE_BINPATH variable. This path is a semi-colon separated list of directories that is combined with the ApplicationBase directory to probe for private assemblies. Private assemblies are deployed in the same directory structure as the application.

[Visual Basic]
Public Shared ReadOnly PrivateBinPath As String
[C#]
public static readonly string PrivateBinPath;
[C++]
public: static readonly String* PrivateBinPath;
[JScript]
public static var PrivateBinPath : String;

See Also

AppDomainFlags Class | AppDomainFlags Members | System Namespace


AppDomainFlags.PrivateBinPathProbe

Used to get or set the "Application Probing" property of the application domain. If this property is set then the search is restricted to the private bin paths. This means the application directory will not be searched. This does not affect searching the global bin paths or the global assembly cache

[Visual Basic]
Public Shared ReadOnly PrivateBinPathProbe As String
[C#]
public static readonly string PrivateBinPathProbe;
[C++]
public: static readonly String* PrivateBinPathProbe;
[JScript]
public static var PrivateBinPathProbe : String;

See Also

AppDomainFlags Class | AppDomainFlags Members | System Namespace


AppDomainFlags.Processor

Used to get or set the processors that an assembly should support. In V1, this information is not used by the assembly binding services but is meant for informational use only.

[Visual Basic]
Public Shared ReadOnly Processor As String
[C#]
public static readonly string Processor;
[C++]
public: static readonly String* Processor;
[JScript]
public static var Processor : String;

Remarks

This member will be removed in a future release.

See Also

AppDomainFlags Class | AppDomainFlags Members | System Namespace


AppDomainFlags.ShadowCopyDirectories

When the ShadowCopyFiles property is set ShowCopyDirs define the directories from which assemblies will be shadow copies. Assemblies found in other directories will not be shadow copied. If this property is not set then the default is to shadow copy the SharedBinPath.

[Visual Basic]
Public Shared ReadOnly ShadowCopyDirectories As String
[C#]
public static readonly string ShadowCopyDirectories;
[C++]
public: static readonly String* ShadowCopyDirectories;
[JScript]
public static var ShadowCopyDirectories : String;

See Also

AppDomainFlags Class | AppDomainFlags Members | System Namespace


AppDomainFlags.ShadowCopyFiles

Used to get or set the "shadow copy" property of an application domain. If this property is set, the application domain will load a shadow copy of an assembly obtained from the assembly cache manager.

[Visual Basic]
Public Shared ReadOnly ShadowCopyFiles As String
[C#]
public static readonly string ShadowCopyFiles;
[C++]
public: static readonly String* ShadowCopyFiles;
[JScript]
public static var ShadowCopyFiles : String;

See Also

AppDomainFlags Class | AppDomainFlags Members | System Namespace


AppDomainFlags.SharedBinPath

Used to get or set the assembly cache manager's SHARED_BINPATH variable. This path is a semi-colon separated list of directories that is combined with the ApplicationBase directory to probe for shared assemblies. Shared assemblies are published assemblies. Published assemblies need not be deployed in the same directory structure as the application.

[Visual Basic]
Public Shared ReadOnly SharedBinPath As String
[C#]
public static readonly string SharedBinPath;
[C++]
public: static readonly String* SharedBinPath;
[JScript]
public static var SharedBinPath : String;

See Also

AppDomainFlags Class | AppDomainFlags Members | System Namespace


AppDomainFlags.SnapshotID

Used to get or set the SnapshotID. The SnapshotID is used by the assembly cache manager to track what assemblies are loaded in an application domain.

[Visual Basic]
Public Shared ReadOnly SnapshotID As String
[C#]
public static readonly string SnapshotID;
[C++]
public: static readonly String* SnapshotID;
[JScript]
public static var SnapshotID : String;

See Also

AppDomainFlags Class | AppDomainFlags Members | System Namespace


AppDomainUnloadedException Class

Initializes a new instance of the AppDomainUnloadedException.

Object
Exception
SystemException
AppDomainUnloadedException

[Visual Basic]
Public Class AppDomainUnloadedException
   Inherits SystemException
[C#]
public class AppDomainUnloadedException : SystemException
[C++]
public __gc class AppDomainUnloadedException : public
   SystemException
[JScript]
public class AppDomainUnloadedException extends SystemException

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

Example

The AppDomainUnloadedException is an exception class for attempts to access an unloaded AppDomain.

See Also

AppDomainUnloadedException Members | System Namespace


AppDomainUnloadedException Members

Public:

Constructor

AppDomainUnloadedException Constructor Overloaded. Initalizes a new instance of the AppDomainUnloadedException.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

AppDomainUnloadedException Class | System Namespace


AppDomainUnloadedException Constructor

Initalizes a new instance of the AppDomainUnloadedException.

Overload List

Initializes a new instance of the AppDomainUnloadedException with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public AppDomainUnloadedException();
[C++] public: AppDomainUnloadedException();
[JScript] public function AppDomainUnloadedException();

Initializes a new instance of the AppDomainUnloadedException class with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public AppDomainUnloadedException(String);
[C++] public: AppDomainUnloadedException(String*);
[JScript] public function AppDomainUnloadedException(String);

Initializes a new instance of the AppDomainUnloadedException class with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public AppDomainUnloadedException(String, Exception);
[C++] public: AppDomainUnloadedException(String*, Exception);
[JScript] public function AppDomainUnloadedException(String, Exception);

See Also

AppDomainUnloadedException Class | AppDomainUnloadedException Members | System Namespace


AppDomainUnloadedException Constructor ()

Initializes a new instance of the AppDomainUnloadedException with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public AppDomainUnloadedException();
[C++]
public: AppDomainUnloadedException();
[JScript]
public function AppDomainUnloadedException();

Remarks

AppDomainUnloadedException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The empty string.

See Also

AppDomainUnloadedException Class | AppDomainUnloadedException Members | System Namespace | AppDomainUnloadedException Constructor Overload List


AppDomainUnloadedException Constructor (String)

Initializes a new instance of the AppDomainUnloadedException class with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public AppDomainUnloadedException(
   string message
);
[C++]
public: AppDomainUnloadedException(
   String* message
);
[JScript]
public function AppDomainUnloadedException(
   message : String
);

Parameters

message
The message that indicates the reason the exception occurred.

Remarks

AppDomainUnloadedException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | null
Message | The empty string.

See Also

AppDomainUnloadedException Class | AppDomainUnloadedException Members | System Namespace | AppDomainUnloadedException Constructor Overload List


AppDomainUnloadedException Constructor (String, Exception)

Initializes a new instance of the AppDomainUnloadedException class with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public AppDomainUnloadedException(
   string message,
   Exception innerException
);
[C++]
public: AppDomainUnloadedException(
   String* message,
   Exception* innerException
);
[JScript]
public function AppDomainUnloadedException(
   message : String,
   innerException : Exception
);

Parameters

message
The message tha indicates the reason the exception occurred.
innerException
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

AppDomainUnloadedException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | null
Message | The empty string.

See Also

AppDomainUnloadedException Class | AppDomainUnloadedException Members | System Namespace | AppDomainUnloadedException Constructor Overload List


AppDomainUnloadInProgressException Class

Initializes a new instance of the AppDomainUnloadInProgressException.

Object
Exception
SystemException
AppDomainUnloadInProgressException

[Visual Basic]
Public Class AppDomainUnloadInProgressException
   Inherits SystemException
[C#]
public class AppDomainUnloadInProgressException : SystemException
[C++]
public __gc class AppDomainUnloadInProgressException : public
   SystemException
[JScript]
public class AppDomainUnloadInProgressException extends
   SystemException

Remarks

The AppDomainUnloadInProgressException is an exception class for attempts to access an unloaded AppDomain.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

AppDomainUnloadInProgressException Members | System Namespace


AppDomainUnloadInProgressException Members

Public:

Constructor

AppDomainUnloadInProgressException Constructor Overloaded. Initalizes a new instance of the AppDomainUnloadInProgressException.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

AppDomainUnloadInProgressException Class | System Namespace


AppDomainUnloadInProgressException Constructor

Initalizes a new instance of the AppDomainUnloadInProgressException.

Overload List

Initializes a new instance of the AppDomainUnloadInProgressException with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public AppDomainUnloadInProgressException();
[C++] public: AppDomainUnloadInProgressException();
[JScript] public function AppDomainUnloadInProgressException();

Initializes a new instance of the AppDomainUnloadInProgressException class with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public AppDomainUnloadInProgressException(String);
[C++] public: AppDomainUnloadInProgressException(String*);
[JScript] public function AppDomainUnloadInProgressException(String);

Initializes a new instance of the AppDomainUnloadInProgressException class with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public AppDomainUnloadInProgressException(String, Exception);
[C++] public: AppDomainUnloadInProgressException(String*, Exception);
[JScript] public function AppDomainUnloadInProgressException(String, Exception);

See Also

AppDomainUnloadInProgressException Class | AppDomainUnloadInProgressException Members | System Namespace


AppDomainUnloadInProgressException Constructor ()

Initializes a new instance of the AppDomainUnloadInProgressException with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public AppDomainUnloadInProgressException();
[C++]
public: AppDomainUnloadInProgressException();
[JScript]
public function AppDomainUnloadInProgressException();

Remarks

AppDomainUnloadInProgressException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The empty string.

See Also

AppDomainUnloadInProgressException Class | AppDomainUnloadInProgressException Members | System Namespace | AppDomainUnloadInProgressException Constructor Overload List


AppDomainUnloadInProgressException Constructor (String)

Initializes a new instance of the AppDomainUnloadInProgressException class with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public AppDomainUnloadInProgressException(
   string message
);
[C++]
public: AppDomainUnloadInProgressException(
   String* message
);
[JScript]
public function AppDomainUnloadInProgressException(
   message : String
);

Parameters

message
The message that indicates the reason the exception occurred.

Remarks

AppDomainUnloadInProgressException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | null
Message | The message string.

See Also

AppDomainUnloadInProgressException Class | AppDomainUnloadInProgressException Members | System Namespace | AppDomainUnloadInProgressException Constructor Overload List


AppDomainUnloadInProgressException Constructor (String, Exception)

Initializes a new instance of the AppDomainUnloadInProgressException class with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public AppDomainUnloadInProgressException(
   string message,
   Exception innerException
);
[C++]
public: AppDomainUnloadInProgressException(
   String* message,
   Exception* innerException
);
[JScript]
public function AppDomainUnloadInProgressException(
   message : String,
   innerException : Exception
);

Parameters

message
The message that indicates the reason the exception occurred.
innerException
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

AppDomainUnloadInProgressException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | The inner exception reference.
Message | The message string.

See Also

AppDomainUnloadInProgressException Class | AppDomainUnloadInProgressException Members | System Namespace | AppDomainUnloadInProgressException Constructor Overload List


ApplicationException Class

Represents non-fatal application errors.

Object
Exception
ApplicationException

[Visual Basic]
Public Class ApplicationException
   Inherits Exception
[C#]
public class ApplicationException : Exception
[C++]
public __gc class ApplicationException : public Exception
[JScript]
public class ApplicationException extends Exception

Remarks

These exceptions are generated (i.e., thrown) by an application, not the runtime.

Subclass the ApplicationException class if you are designing an application that needs to create its own exceptions. ApplicationException extends the Exception, but doesn't add new functionality.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

ApplicationException Members | System Namespace


ApplicationException Members

Public:

Constructor

ApplicationException Constructor Overloaded. Initializes a new instance of the ApplicationException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

ApplicationException Class | System Namespace


ApplicationException Constructor

Initializes a new instance of the ApplicationException class.

Overload List

Initializes a new instance of the ApplicationException with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public ApplicationException();
[C++] public: ApplicationException();
[JScript] public function ApplicationException();

Initializes a new instance of the ApplicationException class with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public ApplicationException(String);
[C++] public: ApplicationException(String*);
[JScript] public function ApplicationException(String);

Initializes a new instance of the ApplicationException class with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public ApplicationException(String, Exception);
[C++] public: ApplicationException(String*, Exception);
[JScript] public function ApplicationException(String, Exception);

See Also

ApplicationException Class | ApplicationException Members | System Namespace


ApplicationException Constructor ()

Initializes a new instance of the ApplicationException with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ApplicationException();
[C++]
public: ApplicationException();
[JScript]
public function ApplicationException();

Remarks

ApplicationException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The empty string.

See Also

ApplicationException Class | ApplicationException Members | System Namespace | ApplicationException Constructor Overload List


ApplicationException Constructor (String)

Initializes a new instance of the ApplicationException class with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public ApplicationException(
   string message
);
[C++]
public: ApplicationException(
   String* message
);
[JScript]
public function ApplicationException(
   message : String
);

Parameters

message
The message that indicates the reason the exception occurred.

Remarks

ApplicationException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The message string.

See Also

ApplicationException Class | ApplicationException Members | System Namespace | ApplicationException Constructor Overload List


ApplicationException Constructor (String, Exception)

Initializes a new instance of the ApplicationException class with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public ApplicationException(
   string message,
   Exception inner
);
[C++]
public: ApplicationException(
   String* message,
   Exception* inner
);
[JScript]
public function ApplicationException(
   message : String,
   inner : Exception
);

Parameters

message
The message that indicates the reason the exception occurred.
inner
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

ApplicationException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | The inner exception reference.
Message | The message string.

See Also

ApplicationException Class | ApplicationException Members | System Namespace | ApplicationException Constructor Overload List


ArgIterator Structure

Represents a variable argument list. You can use this class to step through the argument list of a function that takes a variable number of arguments. It is very likely that most compilers will hide the complexity of ArgIterator under language syntax. See the example below.

Functions that require variable length argument lists are declared using the ellipsis (...) in the argument list.

Object
ValueType
ArgIterator

[Visual Basic]
Public Structure ArgIterator
[C#]
public struct ArgIterator
[C++]
public __value struct ArgIterator

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

Example

Managed C++:

#import <mscorlib.dll>
#include <crt.h>

int sum(int numElements,...) {
  va_list args;
  va_start(args,
numElements); //Creates a new ArgIterator

  int sum = 0;
  int arg;

  for(int ct=0;ct <
numElements;ct++) {
      arg = va_arg(args,
int); //Calls ArgIterator::GetNextArg()
      Console::WriteLine
(L"Argument {0}: '{1}'", Int32::Box(ct),

Int32::Box(arg));
      sum += arg;
  }
  return sum;
}

int main() {
  int ret = sum(4, 40, 54,
20, 99);
  Console::WriteLine
(L"Sum is: {0}", Int32::Box(ret));
  return 1;
}

See Also

ArgIterator Members | System Namespace


ArgIterator Members

Public:

Constructor

ArgIterator Constructor Overloaded. Initializes a new instance of the ArgIterator class that points at the first argument that is not statically declared.

Methods

End | Invalidates the iterator. Conceptually it moves the the iterator to the end of the list so that the next call to GetNextArg generates an exception.
Equals | This methods have not yet been implemented and throws a NotSupportedException when called.
GetHashCode | This methods have not yet been implemented and throws a NotSupportedException when called.
GetNextArg | Overloaded. Gets the next argument in the list and advances the iterator by one.
GetNextArgType | This method can be used to determine the type of the next argument. It is important to note that the iterator is not advanced to the next argument when this call is made.
GetRemainingCount | Determine the number of arguments remaining in the argument list.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArgIterator Structure | System Namespace


ArgIterator Constructor

Initializes a new instance of the ArgIterator class that points at the first argument that is not statically declared.

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(RuntimeArgumentHandle)
[C#] public ArgIterator(RuntimeArgumentHandle);
[C++] public: ArgIterator(RuntimeArgumentHandle);
[JScript] public function ArgIterator(RuntimeArgumentHandle);

Initializes a new instance of the ArgIterator class that points to the specified argument within the specified argument list. If the function takes a fixed number of required arguments followed by a variable number of optional arguments, this constructor would be used to point to the last fixed argument so that a call to the GetNextArg method would retrieve the first variable argument.

[Visual Basic] Overloads Public Sub New(RuntimeArgumentHandle, Int32*)
[C#] public ArgIterator(RuntimeArgumentHandle, Int32*);
[C++] public: ArgIterator(RuntimeArgumentHandle, Int32*);
[JScript] public function ArgIterator(RuntimeArgumentHandle, Int32*);

See Also

ArgIterator Structure | ArgIterator Members | System Namespace


ArgIterator Constructor (RuntimeArgumentHandle)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal arglist As RuntimeArgumentHandle _
)
[C#]
public ArgIterator(
   RuntimeArgumentHandle arglist
);
[C++]
public: ArgIterator(
   RuntimeArgumentHandle arglist
);
[JScript]
public function ArgIterator(
   arglist : RuntimeArgumentHandle
);

Parameters

arglist
specifies the variable argument list to be processed. It arglist can be obtained by calling the ArgList instruction.

Remarks

The verifer verifies that a valid token is passed to arglist (that is, one returned by the ArgList instruction). Fully trusted code could call this directly, but it is not recommended and could cause internal corruptions in the EE.

See Also

ArgIterator Structure | ArgIterator Members | System Namespace | ArgIterator Constructor Overload List


ArgIterator Constructor (RuntimeArgumentHandle, Int32*)

Initializes a new instance of the ArgIterator class that points to the specified argument within the specified argument list. If the function takes a fixed number of required arguments followed by a variable number of optional arguments, this constructor would be used to point to the last fixed argument so that a call to the GetNextArg method would retrieve the first variable argument.

[Visual Basic]
Overloads Public Sub New( _
   ByVal arglist As RuntimeArgumentHandle, _
   ByVal ptr As Int32* _
)
[C#]
public ArgIterator(
   RuntimeArgumentHandle arglist,
   Int32* ptr
);
[C++]
public: ArgIterator(
   RuntimeArgumentHandle arglist,
   Int32** ptr
);
[JScript]
public function ArgIterator(
   arglist : RuntimeArgumentHandle,
   ptr : Int32*
);

Parameters

arglist
identifies the variable argument list to be processed. This is the value returned by the ArgList instruction.
ptr
a pointer to the argument immediately before the argument to be accessed first.

Remarks

The verifer verifies that a valid token is passed to arglist (that is one returned by the ArgList instruction). Fully trusted code could call this directly, but it is not recommended and could cause internal corruptions in the EE.

See Also

ArgIterator Structure | ArgIterator Members | System Namespace | ArgIterator Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ArgIterator Methods

The methods of the ArgIterator structure are listed below. For a complete list of ArgIterator structure members, see the ArgIterator Members topic.

Public:

End | Invalidates the iterator. Conceptually it moves the the iterator to the end of the list so that the next call to GetNextArg generates an exception.
Equals | This methods have not yet been implemented and throws a NotSupportedException when called.
GetHashCode | This methods have not yet been implemented and throws a NotSupportedException when called.
GetNextArg | Overloaded. Gets the next argument in the list and advances the iterator by one.
GetNextArgType | This method can be used to determine the type of the next argument. It is important to note that the iterator is not advanced to the next argument when this call is made.
GetRemainingCount | Determine the number of arguments remaining in the argument list.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArgIterator Structure | System Namespace


ArgIterator.End

Invalidates the iterator. Conceptually it moves the the iterator to the end of the list so that the next call to GetNextArg generates an exception.

[Visual Basic]
Public Sub End()
[C#]
public void End();
[C++]
public: void End();
[JScript]
public function End();

See Also

ArgIterator Structure | ArgIterator Members | System Namespace


ArgIterator.Equals

This methods have not yet been implemented and throws a NotSupportedException when called.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal o As Object _
) As Boolean
[C#]
public override bool Equals(
   object o
);
[C++]
public: override bool Equals(
   Object* o
);
[JScript]
public override function Equals(
   o : Object
) : Boolean;

Parameters

o
The object to be compared to this instance.

Exceptions

Exception Type | Condition
NotSupportedException | is thrown every time this method is called.

Remarks

This method overrides Equals.

See Also

ArgIterator Structure | ArgIterator Members | System Namespace


ArgIterator.GetHashCode

This methods have not yet been implemented and throws a NotSupportedException when called.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Exceptions

Exception Type | Condition
NotSupportedException | is thrown every time this method is called.

Remarks

This method overrides GetHashCode.

See Also

ArgIterator Structure | ArgIterator Members | System Namespace


ArgIterator.GetNextArg

Gets the next argument in the list and advances the iterator by one.

Overload List

Gets the next argument in the list and advances the iterator by one.

[Visual Basic] Overloads Public Function GetNextArg(RuntimeTypeHandle) As TypedReference
[C#] public TypedReference GetNextArg(RuntimeTypeHandle);
[C++] public: TypedReference GetNextArg(RuntimeTypeHandle);
[JScript] public function GetNextArg(RuntimeTypeHandle) : TypedReference;

[To be supplied.]

[Visual Basic] Overloads Public Function GetNextArg() As TypedReference
[C#] public TypedReference GetNextArg();
[C++] public: TypedReference GetNextArg();
[JScript] public function GetNextArg() : TypedReference;

See Also

ArgIterator Structure | ArgIterator Members | System Namespace


ArgIterator.GetNextArg (RuntimeTypeHandle)

Gets the next argument in the list and advances the iterator by one.

[Visual Basic]
Overloads Public Function GetNextArg( _
   ByVal rth As RuntimeTypeHandle _
) As TypedReference
[C#]
public TypedReference GetNextArg(
   RuntimeTypeHandle rth
);
[C++]
public: TypedReference GetNextArg(
   RuntimeTypeHandle rth
);
[JScript]
public function GetNextArg(
   rth : RuntimeTypeHandle
) : TypedReference;

Parameters

rth
The runtime type handle

See Also

ArgIterator Structure | ArgIterator Members | System Namespace | ArgIterator.GetNextArg Overload List


ArgIterator.GetNextArg ()

[To be supplied.]

[Visual Basic]
Overloads Public Function GetNextArg() As TypedReference
[C#]
public TypedReference GetNextArg();
[C++]
public: TypedReference GetNextArg();
[JScript]
public function GetNextArg() : TypedReference;

Return Value

Returns the next argument as a TypedReference object.

Exceptions

Exception Type | Condition
Exception | is thrown if the call attempts to read beyond the end of the list

Remarks

This method treats the next parameter as though it has the ByRef constraint. ByRef parameters are represented by the TypedReference class.

See Also

ArgIterator Structure | ArgIterator Members | System Namespace | ArgIterator.GetNextArg Overload List


NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ArgIterator.GetNextArgType

This method can be used to determine the type of the next argument. It is important to note that the iterator is not advanced to the next argument when this call is made.

[Visual Basic]
Public Function GetNextArgType() As Integer
[C#]
public int GetNextArgType();
[C++]
public: int GetNextArgType();
[JScript]
public function GetNextArgType() : int;

Return Value

Returns the type of the next argument.

See Also

ArgIterator Structure | ArgIterator Members | System Namespace


NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ArgIterator.GetRemainingCount

Determine the number of arguments remaining in the argument list.

[Visual Basic]
Public Function GetRemainingCount() As Integer
[C#]
public int GetRemainingCount();
[C++]
public: int GetRemainingCount();
[JScript]
public function GetRemainingCount() : int;

Return Value

Returns the number of remaining arguments.

See Also

ArgIterator Structure | ArgIterator Members | System Namespace


ArgumentException Class

Represents an exception that is thrown when a method is invoked and one of the arguments is not valid.

Object
Exception
SystemException
ArgumentException

[Visual Basic]
Public Class ArgumentException
   Inherits SystemException
[C#]
public class ArgumentException : SystemException
[C++]
public __gc class ArgumentException : public SystemException
[JScript]
public class ArgumentException extends SystemException

Remarks

The ArgumentException is the class that is thrown when a method is invoked and one of the arguments passed to the method does not meet the contract of the called method. Ideally, an instance of ArgumentException should carry a meaningful error message describing the invalid argument, as well as the range of expected values for the argument.

The primary subclasses of ArgumentException are ArgumentNullException and ArgumentOutOfRangeException. These subclasses should be used instead of ArgumentException except in the situations that neither are acceptable. For example, exceptions are thrown by:

  • ArgumentNullException when null are passed but the argument is not a valid.
  • ArgumentOutOfRange when the argument that is passed is out of range, such as "46" for the month value when your creating a DateTime.

Note that an InvalidOperationException should be used when the invocation fails, and either the call does not have arguments or the failure has nothing to do with the arguments. For examples when InvalidOperationException are thrown:

  • DictionaryEnumerator.GetNext(), because GetNext() is not a method.
  • GetString, if the resource set has been closed.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

ArgumentException Members | System Namespace


ArgumentException Members

Public:

Constructor

ArgumentException Constructor Overloaded. Initializes a new instance of the ArgumentException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message | Retrieves the message string for this exception or an empty string if no message is set.
ParamName | Retrieves the name of the parameter that caused this exception to be thrown.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

ArgumentException Class | System Namespace


ArgumentException Constructor

Initializes a new instance of the ArgumentException class.

Overload List

Initializes a new instance of the ArgumentException with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public ArgumentException();
[C++] public: ArgumentException();
[JScript] public function ArgumentException();

Initializes a new instance of the ArgumentException class with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public ArgumentException(String);
[C++] public: ArgumentException(String*);
[JScript] public function ArgumentException(String);

Initializes a new instance of the ArgumentException class with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public ArgumentException(String, Exception);
[C++] public: ArgumentException(String*, Exception);
[JScript] public function ArgumentException(String, Exception);

Initializes a new instance of the ArgumentException class with a specified message and parameter name.

[Visual Basic] Overloads Public Sub New(String, String)
[C#] public ArgumentException(String, String);
[C++] public: ArgumentException(String*, String*);
[JScript] public function ArgumentException(String, String);

See Also

ArgumentException Class | ArgumentException Members | System Namespace


ArgumentException Constructor ()

Initializes a new instance of the ArgumentException with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ArgumentException();
[C++]
public: ArgumentException();
[JScript]
public function ArgumentException();

Remarks

This constructor creates an new ArugmentException with its message set to the message.

ArgumentException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The empty string.

See Also

ArgumentException Class | ArgumentException Members | System Namespace | ArgumentException Constructor Overload List


ArgumentException Constructor (String)

Initializes a new instance of the ArgumentException class with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public ArgumentException(
   string message
);
[C++]
public: ArgumentException(
   String* message
);
[JScript]
public function ArgumentException(
   message : String
);

Parameters

message
The message that indicates the reason the exception occurred.

Remarks

This constructor creates an new ArugmentException with its message set to the message.

ArgumentException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The message string.

See Also

ArgumentException Class | ArgumentException Members | System Namespace | ArgumentException Constructor Overload List


ArgumentException Constructor (String, Exception)

Initializes a new instance of the ArgumentException class with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public ArgumentException(
   string message,
   Exception inner
);
[C++]
public: ArgumentException(
   String* message,
   Exception* inner
);
[JScript]
public function ArgumentException(
   message : String,
   inner : Exception
);

Parameters

message
The message that indicates the reason the exception occurred.
inner
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

ArgumentException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | The inner exception reference.
Message | The message string.

See Also

ArgumentException Class | ArgumentException Members | System Namespace | ArgumentException Constructor Overload List


ArgumentException Constructor (String, String)

Initializes a new instance of the ArgumentException class with a specified message and parameter name.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal paramName As String _
)
[C#]
public ArgumentException(
   string message,
   string paramName
);
[C++]
public: ArgumentException(
   String* message,
   String* paramName
);
[JScript]
public function ArgumentException(
   message : String,
   paramName : String
);

Parameters

message
The message that indicates the reason the exception occurred.
paramName
The name of the parameter that caused this exception to be thrown.

Remarks

ArgumentException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
paramName | The parameter name string.
Message | The message string.

See Also

ArgumentException Class | ArgumentException Members | System Namespace | ArgumentException Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ArgumentException Properties

The properties of the ArgumentException class are listed below. For a complete list of ArgumentException class members, see the ArgumentException Members topic.

Public:

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message | Retrieves the message string for this exception or an empty string if no message is set.
ParamName | Retrieves the name of the parameter that caused this exception to be thrown.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

See Also

ArgumentException Class | System Namespace


ArgumentException.Message

Retrieves the message string for this exception or an empty string if no message is set.

[Visual Basic]
Overridable Public ReadOnly Property Message As String
[C#]
public string Message {override get;}
[C++]
public: __property virtual String* get_Message();
[JScript]
public function get Message() : String;

Property Value

Read-only.

Remarks

Overrides Message.This is a message string with a new line character followed by the parameter name. If a parameter name was not specified when the object was constructed, the value consists only of the message string.

See Also

ArgumentException Class | ArgumentException Members | System Namespace


ArgumentException.ParamName

Retrieves the name of the parameter that caused this exception to be thrown.

[Visual Basic]
Overridable Public ReadOnly Property ParamName As String
[C#]
public string ParamName {virtual get;}
[C++]
public: __property virtual String* get_ParamName();
[JScript]
public function get ParamName() : String;

Remarks

Overrides Message.

Every ArgumentException should carry the name of the parameter that causes the exception to be thrown, in addition to a message string that describes the expected values of the parameter.

This is a message string with a new line character followed by the parameter name. If a parameter name was not specified when the object was constructed, the value consists only of the message string.

See Also

ArgumentException Class | ArgumentException Members | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ArgumentException Methods

The methods of the ArgumentException class are listed below. For a complete list of ArgumentException class members, see the ArgumentException Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArgumentException Class | System Namespace


ArgumentException.GetObjectData

Accesses the method that contains the context of the data from the source or destination.

[Visual Basic]
Overrides Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
public: override void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
);
[JScript]
public override function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);

Parameters

info
The serialized object.
context
[To be supplied.]

Return Value

A serialized object is returned as context by StreamingContext.

Remarks

The GetObjectData method accesses StreamingContext to return the value of hte source and/or destination of a given serialized stream. (For more information, see SerializationInfo.)

See Also

ArgumentException Class | ArgumentException Members | System Namespace


ArgumentException.SetObjectData

Sets the object that contains the context of the data from the source or destination.

[Visual Basic]
Overrides Public Sub SetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
public override void SetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
public: override void SetObjectData(
   SerializationInfo* info,
   StreamingContext context
);
[JScript]
public override function SetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);

Parameters

info
An object to hold the data.
context
The data obtained.

Return Value

The value of the object containing the StreamingContext.

Exceptions

Exception Type | Condition
ArgumentNullException | If the object is null.

Remarks

This method sets the StreamingContext to return the value of the object that holds the source and/or destination of a given serialized stream (see SerializationInfo).

See Also

ArgumentException Class | ArgumentException Members | System Namespace


ArgumentNullException Class

Represents the exception that is thrown when a null argument passed to a method that does not accept it.

Object
Exception
SystemException
ArgumentException
ArgumentNullException

[Visual Basic]
Public Class ArgumentNullException
   Inherits ArgumentException
[C#]
public class ArgumentNullException : ArgumentException
[C++]
public __gc class ArgumentNullException : public ArgumentException
[JScript]
public class ArgumentNullException extends ArgumentException

Remarks

ArgumentNullException is thrown when a method is invoked with a null argument and the contract of the method does not allow that argument to be null. Ideally it should carry a meaningful error message describing which argument is invalid and the expected values of that argument.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

ArgumentNullException Members | System Namespace


ArgumentNullException Members

Public:

Constructor

ArgumentNullException Constructor Overloaded. Initializes a new instance of the ArgumentNullException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from ArgumentException) | Retrieves the message string for this exception or an empty string if no message is set.
ParamName (inherited from ArgumentException) | Retrieves the name of the parameter that caused this exception to be thrown.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from ArgumentException) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from ArgumentException) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

ArgumentNullException Class | System Namespace


ArgumentNullException Constructor

Initializes a new instance of the ArgumentNullException class.

Overload List

Initializes a new instance of the ArgumentNullException with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public ArgumentNullException();
[C++] public: ArgumentNullException();
[JScript] public function ArgumentNullException();

Initializes a new instance of the ArgumentNullException class with the name of the parameter that caused this exception to be thrown.

[Visual Basic] Overloads Public Sub New(String)
[C#] public ArgumentNullException(String);
[C++] public: ArgumentNullException(String*);
[JScript] public function ArgumentNullException(String);

Initializes an instance of ArgumentNullException with a specified message and the name of the parameter that caused this exception to be thrown.

[Visual Basic] Overloads Public Sub New(String, String)
[C#] public ArgumentNullException(String, String);
[C++] public: ArgumentNullException(String*, String*);
[JScript] public function ArgumentNullException(String, String);

See Also

ArgumentNullException Class | ArgumentNullException Members | System Namespace


ArgumentNullException Constructor ()

Initializes a new instance of the ArgumentNullException with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ArgumentNullException();
[C++]
public: ArgumentNullException();
[JScript]
public function ArgumentNullException();

Remarks

ArgumentException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The empty string.

See Also

ArgumentNullException Class | ArgumentNullException Members | System Namespace | ArgumentNullException Constructor Overload List


ArgumentNullException Constructor (String)

Initializes a new instance of the ArgumentNullException class with the name of the parameter that caused this exception to be thrown.

[Visual Basic]
Overloads Public Sub New( _
   ByVal parameterName As String _
)
[C#]
public ArgumentNullException(
   string parameterName
);
[C++]
public: ArgumentNullException(
   String* parameterName
);
[JScript]
public function ArgumentNullException(
   parameterName : String
);

Parameters

parameterName
The name of the parameter that was passed a null value.

Remarks

ArgumentException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The empty string.
System.ArgumentException.parameterName | The parameter name string.

See Also

ArgumentNullException Class | ArgumentNullException Members | System Namespace | ArgumentNullException Constructor Overload List


ArgumentNullException Constructor (String, String)

Initializes an instance of ArgumentNullException with a specified message and the name of the parameter that caused this exception to be thrown.

[Visual Basic]
Overloads Public Sub New( _
   ByVal parameterName As String, _
   ByVal message As String _
)
[C#]
public ArgumentNullException(
   string parameterName,
   string message
);
[C++]
public: ArgumentNullException(
   String* parameterName,
   String* message
);
[JScript]
public function ArgumentNullException(
   parameterName : String,
   message : String
);

Parameters

parameterName
The name of the parameter that was passed a null value.
message
The message that indicates the reason the exception occurred.

Remarks

ArgumentException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The message string.
System.ArgumentException.parameterName | The parameter name string.

See Also

ArgumentNullException Class | ArgumentNullException Members | System Namespace | ArgumentNullException Constructor Overload List


ArgumentOutOfRangeException Class

Represents an exception that is thrown when the argument is outside the allowed values of the method that is invoked.

Object
Exception
SystemException
ArgumentException
ArgumentOutOfRangeException

[Visual Basic]
Public Class ArgumentOutOfRangeException
   Inherits ArgumentException
[C#]
public class ArgumentOutOfRangeException : ArgumentException
[C++]
public __gc class ArgumentOutOfRangeException : public
   ArgumentException
[JScript]
public class ArgumentOutOfRangeException extends ArgumentException

Remarks

ArgumentOutOfRangeException is thrown when a method is invoked and one of the arguments passed to that method is outside the expected range values. This is usually the result of an attempt to access an object with an index that is outside the lower and upper bounds or range of indices.

This exception is used extensively by:

  • the TBD and TBD namespaces .
  • the Array class.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

ArgumentOutOfRangeException Members | System Namespace


ArgumentOutOfRangeException Members

Public:

Constructor

ArgumentOutOfRangeException Constructor Overloaded. Initializes a new instance of the ArgumentOutOfRangeException class.

Properties

ActualValue | Retrieves the actual value that caused the exception to be thrown.
HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message | Retrieves the message text for this exception or indicates an empty string if no message is set.
ParamName (inherited from ArgumentException) | Retrieves the name of the parameter that caused this exception to be thrown.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Returns a SerializationInfo object completely populated with all the data needed to serialize the target object.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from ArgumentException) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

ArgumentOutOfRangeException Class | System Namespace


ArgumentOutOfRangeException Constructor

Initializes a new instance of the ArgumentOutOfRangeException class.

Overload List

Initializes a new instance of the ArgumentOutOfRangeException with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public ArgumentOutOfRangeException();
[C++] public: ArgumentOutOfRangeException();
[JScript] public function ArgumentOutOfRangeException();

Initializes a new instance of the ArgumentOutOfRangeException class using the parameter name.

[Visual Basic] Overloads Public Sub New(String)
[C#] public ArgumentOutOfRangeException(String);
[C++] public: ArgumentOutOfRangeException(String*);
[JScript] public function ArgumentOutOfRangeException(String);

Initializes a new instance of the ArgumentOutOfRangeException class with a specified message and a parameter name.

[Visual Basic] Overloads Public Sub New(String, String)
[C#] public ArgumentOutOfRangeException(String, String);
[C++] public: ArgumentOutOfRangeException(String*, String*);
[JScript] public function ArgumentOutOfRangeException(String, String);

Initializes a new instance of the ArgumentOutOfRangeException class with a specified message, a parameter name, and a value of the argument.

[Visual Basic] Overloads Public Sub New(String, Object, String)
[C#] public ArgumentOutOfRangeException(String, Object, String);
[C++] public: ArgumentOutOfRangeException(String*, Object, String*);
[JScript] public function ArgumentOutOfRangeException(String, Object, String);

See Also

ArgumentOutOfRangeException Class | ArgumentOutOfRangeException Members | System Namespace


ArgumentOutOfRangeException Constructor ()

Initializes a new instance of the ArgumentOutOfRangeException with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ArgumentOutOfRangeException();
[C++]
public: ArgumentOutOfRangeException();
[JScript]
public function ArgumentOutOfRangeException();

Remarks

ArgumentException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The empty string.

See Also

ArgumentOutOfRangeException Class | ArgumentOutOfRangeException Members | System Namespace | ArgumentOutOfRangeException Constructor Overload List


ArgumentOutOfRangeException Constructor (String)

Initializes a new instance of the ArgumentOutOfRangeException class using the parameter name.

[Visual Basic]
Overloads Public Sub New( _
   ByVal parameterName As String _
)
[C#]
public ArgumentOutOfRangeException(
   string parameterName
);
[C++]
public: ArgumentOutOfRangeException(
   String* parameterName
);
[JScript]
public function ArgumentOutOfRangeException(
   parameterName : String
);

Parameters

parameterName
The parameter that is out of range. The ParamName property is set to this value.

Remarks

ArgumentOutOfRangeException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The empty string.
ParamName | The parameter name string.

See Also

ArgumentOutOfRangeException Class | ArgumentOutOfRangeException Members | System Namespace | ArgumentOutOfRangeException Constructor Overload List


ArgumentOutOfRangeException Constructor (String, String)

Initializes a new instance of the ArgumentOutOfRangeException class with a specified message and a parameter name.

[Visual Basic]
Overloads Public Sub New( _
   ByVal parameterName As String, _
   ByVal message As String _
)
[C#]
public ArgumentOutOfRangeException(
   string parameterName,
   string message
);
[C++]
public: ArgumentOutOfRangeException(
   String* parameterName,
   String* message
);
[JScript]
public function ArgumentOutOfRangeException(
   parameterName : String,
   message : String
);

Parameters

parameterName
The name of the parameter that is out of range.
message
The message that indicates the reason the exception occurred.

Remarks

ArgumentOutOfRangeException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The message string.
ParamName | The parameter name string.

See Also

ArgumentOutOfRangeException Class | ArgumentOutOfRangeException Members | System Namespace | ArgumentOutOfRangeException Constructor Overload List


ArgumentOutOfRangeException Constructor (String, Object, String)

Initializes a new instance of the ArgumentOutOfRangeException class with a specified message, a parameter name, and a value of the argument.

[Visual Basic]
Overloads Public Sub New( _
   ByVal parameterName As String, _
   ByVal actualValue As Object, _
   ByVal message As String _
)
[C#]
public ArgumentOutOfRangeException(
   string parameterName,
   object actualValue,
   string message
);
[C++]
public: ArgumentOutOfRangeException(
   String* parameterName,
   Object* actualValue,
   String* message
);
[JScript]
public function ArgumentOutOfRangeException(
   parameterName : String,
   actualValue : Object,
   message : String
);

Parameters

parameterName
The name of the parameter that is out of range.
actualValue
The value of the argument that caused this exception.
message
The message that indicates the reason the exception occurred.

Remarks

Note that this constructor is not used within the base class library. The ActualValue property is provided so that developers can avoid the use of printf's when throwing this exception with an appropriate message text.

The actualValue parameter is an invalid value that was passed to the method and causes this exception to be thrown. This value is stored in the ActualValue property and a string representation is appended to the value of the Message property.

ArgumentOutOfRangeException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
ActualValue | actualValue
InnerException | null
Message | The message string.
ParamName | The parameter name string.

See Also

ArgumentOutOfRangeException Class | ArgumentOutOfRangeException Members | System Namespace | ArgumentOutOfRangeException Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ArgumentOutOfRangeException Properties

The properties of the ArgumentOutOfRangeException class are listed below. For a complete list of ArgumentOutOfRangeException class members, see the ArgumentOutOfRangeException Members topic.

Public:

ActualValue | Retrieves the actual value that caused the exception to be thrown.
HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message | Retrieves the message text for this exception or indicates an empty string if no message is set.
ParamName (inherited from ArgumentException) | Retrieves the name of the parameter that caused this exception to be thrown.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

See Also

ArgumentOutOfRangeException Class | System Namespace


ArgumentOutOfRangeException.ActualValue

Retrieves the actual value that caused the exception to be thrown.

[Visual Basic]
Overridable Public ReadOnly Property ActualValue As Object
[C#]
public object ActualValue {virtual get;}
[C++]
public: __property virtual Object* get_ActualValue();
[JScript]
public function get ActualValue() : Object;

Property Value

This property retrieves the actual value that caused the exception to be thrown.

Remarks

The ActualValue prooperty is assigned at the time of construction via ArgumentOutOfRangeException(String parameterName, Object value, String message). If ActualValue is non-null, a string representation is appended to the message text held by Message.

Note that the ActualValue property is not used within the base class library. That is, its value is null on all the ArgumentOutOfRangeException objects thrown by the base class library. It is provided so that developers may avoid the use of printf's when throwing this exception with an appropriate message text.

See Also

ArgumentOutOfRangeException Class | ArgumentOutOfRangeException Members | System Namespace


ArgumentOutOfRangeException.Message

Retrieves the message text for this exception or indicates an empty string if no message is set.

[Visual Basic]
Overridable Public ReadOnly Property Message As String
[C#]
public string Message {override get;}
[C++]
public: __property virtual String* get_Message();
[JScript]
public function get Message() : String;

Property Value

The ActualValue property retrieves the message text for this exception. The value of this property takes one of two forms:

Property Type | Condition
If ActualValue is null | Then it consists of the string passed to the constructor as the message.
If ActualValue is non-null | Then it consists of the string passed to the constructor as the message with "Actual value was " followed by ActualValue:ToString() appended.

Remarks

Overrides Message.

See Also

ArgumentOutOfRangeException Class | ArgumentOutOfRangeException Members | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ArgumentOutOfRangeException Methods

The methods of the ArgumentOutOfRangeException class are listed below. For a complete list of ArgumentOutOfRangeException class members, see the ArgumentOutOfRangeException Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Returns a SerializationInfo object completely populated with all the data needed to serialize the target object.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from ArgumentException) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArgumentOutOfRangeException Class | System Namespace


ArgumentOutOfRangeException.GetObjectData

Returns a SerializationInfo object completely populated with all the data needed to serialize the target object.

[Visual Basic]
Overrides Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
public: override void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
);
[JScript]
public override function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);

Parameters

info
The informtion needed for serialization (see SerializationInfo).
context
[To be supplied.]

Return Value

A SerializationInfo with all the data need to serialize the object

Exceptions

Exception Type | Condition
ArgumentNullException | If it is null.

Remarks

The SerializationInfo object must return data because if it is null, the SerializationInfo will thrown an ArgumentNullException.

See Also

ArgumentOutOfRangeException Class | ArgumentOutOfRangeException Members | System Namespace


ArithmeticException Class

Represents an exception that is thrown when overflow or underflow occurs.

Object
Exception
SystemException
ArithmeticException

[Visual Basic]
Public Class ArithmeticException
   Inherits SystemException
[C#]
public class ArithmeticException : SystemException
[C++]
public __gc class ArithmeticException : public SystemException
[JScript]
public class ArithmeticException extends SystemException

Remarks

The ArithmeticException is an exception class for bad arithmetic conditions. This exception is throw when the arithmetic conditions are not meet, such as a number that greater than or less than the acceptable range of numbers.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

ArithmeticException Members | System Namespace


ArithmeticException Members

Public:

Constructor

ArithmeticException Constructor Overloaded. Initializes a new instance of the ArithmeticException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

ArithmeticException Class | System Namespace


ArithmeticException Constructor

Initializes a new instance of the ArithmeticException class.

Overload List

Initializes a new instance of the ArithmeticException class.

[Visual Basic] Overloads Public Sub New()
[C#] public ArithmeticException();
[C++] public: ArithmeticException();
[JScript] public function ArithmeticException();

Initializes a new instance of the ArithmeticException class with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public ArithmeticException(String);
[C++] public: ArithmeticException(String*);
[JScript] public function ArithmeticException(String);

Initializes a new instance of the ArithmeticException class with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public ArithmeticException(String, Exception);
[C++] public: ArithmeticException(String*, Exception);
[JScript] public function ArithmeticException(String, Exception);

See Also

ArithmeticException Class | ArithmeticException Members | System Namespace


ArithmeticException Constructor ()

Initializes a new instance of the ArithmeticException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ArithmeticException();
[C++]
public: ArithmeticException();
[JScript]
public function ArithmeticException();

Remarks

ArthmeticException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | null
Message | The empty string.

See Also

ArithmeticException Class | ArithmeticException Members | System Namespace | ArithmeticException Constructor Overload List


ArithmeticException Constructor (String)

Initializes a new instance of the ArithmeticException class with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public ArithmeticException(
   string message
);
[C++]
public: ArithmeticException(
   String* message
);
[JScript]
public function ArithmeticException(
   message : String
);

Parameters

message
The message that indicates the reason the exception occurred.

Remarks

ArthmeticException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | null
Message | The message string.

See Also

ArithmeticException Class | ArithmeticException Members | System Namespace | ArithmeticException Constructor Overload List


ArithmeticException Constructor (String, Exception)

Initializes a new instance of the ArithmeticException class with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public ArithmeticException(
   string message,
   Exception inner
);
[C++]
public: ArithmeticException(
   String* message,
   Exception* inner
);
[JScript]
public function ArithmeticException(
   message : String,
   inner : Exception
);

Parameters

message
The message that indicates the reason the exception occurred.
inner
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

ArthmeticException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | The inner exception reference.
Message | The message string.

See Also

ArithmeticException Class | ArithmeticException Members | System Namespace | ArithmeticException Constructor Overload List


Array Class

Provides methods for creating, manipulating, searching, and sorting arrays. This is the base class for all arrays in the system.

Object
Array

[Visual Basic]
Public Class Array
   Implements ICloneable, ICollection, IEnumerable
[C#]
public class Array : ICloneable, ICollection, IEnumerable
[C++]
public __gc class Array : public ICloneable, ICollection,
   IEnumerable
[JScript]
public class Array implements ICloneable, ICollection, IEnumerable

Remarks

An element is a value in the Array. The length of an Array is size of an Array; that is, the number of elements it can contain. The rank of an Array is the number of dimensions in the Array. The lower bound or lowbound of a dimension of an Array is the starting index of that dimension of the Array; a multidimensional Array can have different bounds for each dimension.

Type objects provide information about array type declarations. Array objects with the same array type share the same Type object.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

Array Members | System Namespace


Array Members

Public:

Properties

IsReadOnly | Gets a value indicating whether the Array is read-only.
IsSynchronized | Gets a value indicating whether access to the Array is synchronized (thread-safe).
Length | Gets the total number of elements in all the dimensions of the Array.
Rank | Gets the rank, or number of dimensions, in the Array.
SyncRoot | Gets an object that can be used to synchronize access to the Array.

Methods

AsList | Returns a fixed-size IList that represents the specified Array.
BinarySearch | Overloaded. Searches a one-dimensional Array for a value using a binary search algorithm.
Clear | Sets a range of elements in the Array to 0 or a null reference (in Visual Basic Nothing).
Clone | Creates a deep copy of the Array.
Copy | Overloaded. Copies a section of one Array to another Array, and performs type-downcasting as required.
CopyTo | Copies all the elements of the current Array into the specified Array, starting at the specified destination Array index.
CreateInstance | Overloaded. Initializes a new instance of the Array class.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Returns an IEnumerator for the one-dimensional Array.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLength | Gets the number of elements in the specified dimension of the Array.
GetLowerBound | Gets the lower bound of the specified dimension in the Array.
GetType (inherited from Object) | Gets the Type of the Object.
GetUpperBound | Gets the upper bound of the specified dimension in the Array.
GetValue | Overloaded. Gets the value(s) of the Array element(s) at the specified index(es).
IndexOf | Overloaded. Returns the index of the first occurrence of a value in a one-dimensional Array, or in a portion of it.
Initialize | Initializes every element of the value-type Array, by calling the default constructor of the value class.
LastIndexOf | Overloaded. Returns the index of the last occurrence of a value in a one-dimensional Array, or in a portion of it.
Reverse | Overloaded. Reverses the order of the elements in the specified one-dimensional Array, or in a portion of it.
SetValue | Overloaded. Sets the specified Array element(s) to the specified value.
Sort | Overloaded. Sorts the elements in one-dimensional Array objects.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Constructor

Array Constructor Initializes a new instance of the Array class.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Array Class | System Namespace


Array Constructor

Initializes a new instance of the Array class.

[Visual Basic]
Protected Sub New()
[C#]
protected Array();
[C++]
protected: Array();
[JScript]
protected function Array();

See Also

Array Class | Array Members | System Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Array Properties

The properties of the Array class are listed below. For a complete list of Array class members, see the Array Members topic.

Public:

IsReadOnly | Gets a value indicating whether the Array is read-only.
IsSynchronized | Gets a value indicating whether access to the Array is synchronized (thread-safe).
Length | Gets the total number of elements in all the dimensions of the Array.
Rank | Gets the rank, or number of dimensions, in the Array.
SyncRoot | Gets an object that can be used to synchronize access to the Array.

See Also

Array Class | System Namespace


Array.IsReadOnly

Gets a value indicating whether the Array is read-only.

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {virtual get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;

Property Value

true if the Array is read-only; otherwise, false.

See Also

Array Class | Array Members | System Namespace


Array.IsSynchronized

Gets a value indicating whether access to the Array is synchronized (thread-safe).

[Visual Basic]
Overridable Public ReadOnly Property IsSynchronized As Boolean
[C#]
public bool IsSynchronized {virtual get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;

Property Value

true if access to the Array is synchronized (thread-safe); otherwise, false.

Remarks

SyncRoot returns an object, which can be used to synchronize access to the Array.

See Also

Array Class | Array Members | System Namespace | SyncRoot | Synchronized


Array.Length

Gets the total number of elements in all the dimensions of the Array.

[Visual Basic]
Public ReadOnly Property Length As Integer
[C#]
public int Length {get;}
[C++]
public: __property int get_Length();
[JScript]
public function get Length() : int;

Property Value

The total number of elements in all the dimensions of the Array.

See Also

Array Class | Array Members | System Namespace | GetLength | Rank


Array.Rank

Gets the rank, or number of dimensions, in the Array.

[Visual Basic]
Public ReadOnly Property Rank As Integer
[C#]
public int Rank {get;}
[C++]
public: __property int get_Rank();
[JScript]
public function get Rank() : int;

Property Value

The rank, or number of dimensions, in the Array.

Remarks

Jagged arrays, defined as Type [][]...[], are considered to be arrays of arrays; therefore, calling Rank on a jagged array always returns 1.

See Also

Array Class | Array Members | System Namespace | Length | GetLength


Array.SyncRoot

Gets an object that can be used to synchronize access to the Array.

[Visual Basic]
Overridable Public ReadOnly Property SyncRoot As Object
[C#]
public object SyncRoot {virtual get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;

Property Value

An object that can be used to synchronize access to the Array.

Remarks

The root object for an Array is used when performing synchronized operations on the Array. Instead of synchronizing directly on an Array, program code should always synchronize on the root of the Array. This ensures proper operation of arrays that are derived from other objects; proper synchronization is maintained with other threads that might be simultaneously modifying the Array object.

See Also

Array Class | Array Members | System Namespace | IsSynchronized | Synchronized


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Array Methods

The methods of the Array class are listed below. For a complete list of Array class members, see the Array Members topic.

Public:

AsList | Returns a fixed-size IList that represents the specified Array.
BinarySearch | Overloaded. Searches a one-dimensional Array for a value using a binary search algorithm.
Clear | Sets a range of elements in the Array to 0 or a null reference (in Visual Basic Nothing).
Clone | Creates a deep copy of the Array.
Copy | Overloaded. Copies a section of one Array to another Array, and performs type-downcasting as required.
CopyTo | Copies all the elements of the current Array into the specified Array, starting at the specified destination Array index.
CreateInstance | Overloaded. Initializes a new instance of the Array class.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Returns an IEnumerator for the one-dimensional Array.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLength | Gets the number of elements in the specified dimension of the Array.
GetLowerBound | Gets the lower bound of the specified dimension in the Array.
GetType (inherited from Object) | Gets the Type of the Object.
GetUpperBound | Gets the upper bound of the specified dimension in the Array.
GetValue | Overloaded. Gets the value(s) of the Array element(s) at the specified index(es).
IndexOf | Overloaded. Returns the index of the first occurrence of a value in a one-dimensional Array, or in a portion of it.
Initialize | Initializes every element of the value-type Array, by calling the default constructor of the value class.
LastIndexOf | Overloaded. Returns the index of the last occurrence of a value in a one-dimensional Array, or in a portion of it.
Reverse | Overloaded. Reverses the order of the elements in the specified one-dimensional Array, or in a portion of it.
SetValue | Overloaded. Sets the specified Array element(s) to the specified value.
Sort | Overloaded. Sorts the elements in one-dimensional Array objects.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Array Class | System Namespace


Array.AsList

Returns a fixed-size IList that represents the specified Array.

[Visual Basic]
Public Shared Function AsList( _
   ByVal array As Array _
) As IList
[C#]
public static IList AsList(
   Array array
);
[C++]
public: static IList* AsList(
   Array* array
);
[JScript]
public static function AsList(
   array : Array
) : IList;

Parameters

array
The Array to represent as a fixed-size IList.

Return Value

A fixed-size IList that represents the specified Array.

Remarks

In a fixed-sized list, individual elements can be modified but not added or removed.

The AsList method is the only way to create an IList from an Array.

Casting an array of value type elements into an array of Object elements is not possible in the runtime. Therefore, a value type array must be converted to an object array using the Copy method.

See Also

Array Class | Array Members | System Namespace


Array.BinarySearch

Searches a one-dimensional Array for a value using a binary search algorithm.

Overload List

Searches a one-dimensional Array for a value, using the specified IComparer interface.

[Visual Basic] Overloads Public Shared Function BinarySearch(Array, Object, IComparer) As Integer
[C#] public static int BinarySearch(Array, Object, IComparer);
[C++] public: static int BinarySearch(Array*, Object, IComparer);
[JScript] public static function BinarySearch(Array, Object, IComparer) : int;

Searches a section of a one-dimensional Array for a value, using the specified IComparer interface.

[Visual Basic] Overloads Public Shared Function BinarySearch(Array, Integer, Integer, Object, IComparer) As Integer
[C#] public static int BinarySearch(Array, int, int, Object, IComparer);
[C++] public: static int BinarySearch(Array*, int, int, Object, IComparer);
[JScript] public static function BinarySearch(Array, int, int, Object, IComparer) : int;

Searches a one-dimensional Array for a specific element, using the IComparable interface implemented by each element of the Array and by the specified Object.

[Visual Basic] Overloads Public Shared Function BinarySearch(Array, Object) As Integer
[C#] public static int BinarySearch(Array, Object);
[C++] public: static int BinarySearch(Array*, Object);
[JScript] public static function BinarySearch(Array, Object) : int;

Searches a section of a one-dimensional Array for a value, using the IComparable interface implemented by each element of the Array and by the specified value.

[Visual Basic] Overloads Public Shared Function BinarySearch(Array, Integer, Integer, Object) As Integer
[C#] public static int BinarySearch(Array, int, int, Object);
[C++] public: static int BinarySearch(Array*, int, int, Object);
[JScript] public static function BinarySearch(Array, int, int, Object) : int;

See Also

Array Class | Array Members | System Namespace


Array.BinarySearch (Array, Object, IComparer)

Searches a one-dimensional Array for a value, using the specified IComparer interface.

[Visual Basic]
Overloads Public Shared Function BinarySearch( _
   ByVal array As Array, _
   ByVal value As Object, _
   ByVal comparer As IComparer _
) As Integer
[C#]
public static int BinarySearch(
   Array array,
   object value,
   IComparer comparer
);
[C++]
public: static int BinarySearch(
   Array* array,
   Object* value,
   IComparer* comparer
);
[JScript]
public static function BinarySearch(
   array : Array,
   value : Object,
   comparer : IComparer
) : int;

Parameters

array
The one-dimensional Array to search.
value
The Object to search for.
comparer
The IComparer implementation to use when comparing elements.

-or-

a null reference (in Visual Basic Nothing) to use the IComparable implementation of each element.

Return Value

The index of the value in the Array, if value is found. Otherwise, a negative number, which is the bitwise complement of the index of the first element that is larger than value.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference (Nothing).
RankException | array is multidimensional.
ArgumentException | comparer is a null reference (Nothing), and neither value nor the elements of array implement the IComparable interface. -or- comparer is a null reference (Nothing), and value is not of the same type as the elements of array.

Remarks

If comparer is specified and array is not already sorted according to the sort order defined by comparer, the result may be incorrect.

If comparer is not specified, value and each element of array must implement the IComparable interface, which is used for comparisons. If array is not already sorted according to the IComparable interface, the result may be incorrect.

a null reference (Nothing) can always be compared with any other type; therefore, comparisons with a null reference (Nothing) will not generate an exception. When sorting, a null reference (Nothing) is considered to be less than any other object.

The bitwise complement operator (~) can be applied to a negative result to produce the index of the first element (if any) that is larger than the specified search value.

See Also

Array Class | Array Members | System Namespace | Array.BinarySearch Overload List | IComparer | IComparable | Sort


Array.BinarySearch (Array, Int32, Int32, Object, IComparer)

Searches a section of a one-dimensional Array for a value, using the specified IComparer interface.

[Visual Basic]
Overloads Public Shared Function BinarySearch( _
   ByVal array As Array, _
   ByVal index As Integer, _
   ByVal length As Integer, _
   ByVal value As Object, _
   ByVal comparer As IComparer _
) As Integer
[C#]
public static int BinarySearch(
   Array array,
   int index,
   int length,
   object value,
   IComparer comparer
);
[C++]
public: static int BinarySearch(
   Array* array,
   int index,
   int length,
   Object* value,
   IComparer* comparer
);
[JScript]
public static function BinarySearch(
   array : Array,
   index : int,
   length : int,
   value : Object,
   comparer : IComparer
) : int;

Parameters

array
The one-dimensional Array to search.
index
The starting index of the range to search.
length
The length of the range to search.
value
The Object to search for.
comparer
The IComparer implementation to use when comparing elements.

-or-

a null reference (in Visual Basic Nothing) to use the IComparable implementation of each element.

Return Value

The index of the value in the Array, if value is found. Otherwise, a negative number, which is the bitwise complement of the index of the first element that is larger than value.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference (Nothing).
RankException | array is multidimensional.
ArgumentOutOfRangeException | index is less than the lower bound of array. -or- length is less than zero.
ArgumentException | index and length do not denote a valid range in array. -or- comparer is a null reference (Nothing), and neither value nor the elements of array implement the IComparable interface. -or- comparer is a null reference (Nothing), and value is not of the same type as the elements of array.

Remarks

If comparer is specified and array is not already sorted according to the sort order defined by comparer, the result may be incorrect.

If comparer is not specified, value and each element of array must implement the IComparable interface, which is used for comparisons. If array is not already sorted according to the IComparable interface, the result may be incorrect.

a null reference (Nothing) can always be compared with any other type; therefore, comparisons with a null reference (Nothing) will not generate an exception when using IComparable. When sorting, a null reference (Nothing) is considered to be less than any other object.

The bitwise complement operator (~) can be applied to a negative result to produce the index of the first element (if any) that is larger than the specified search value.

See Also

Array Class | Array Members | System Namespace | Array.BinarySearch Overload List | IComparer | IComparable | Sort


Array.BinarySearch (Array, Object)

Searches a one-dimensional Array for a specific element, using the IComparable interface implemented by each element of the Array and by the specified Object.

[Visual Basic]
Overloads Public Shared Function BinarySearch( _
   ByVal array As Array, _
   ByVal value As Object _
) As Integer
[C#]
public static int BinarySearch(
   Array array,
   object value
);
[C++]
public: static int BinarySearch(
   Array* array,
   Object* value
);
[JScript]
public static function BinarySearch(
   array : Array,
   value : Object
) : int;

Parameters

array
The one-dimensional Array to search.
value
The Object to search for.

Return Value

The index of the value in the Array, if value is found. Otherwise, a negative number, which is the bitwise complement of the index of the first element that is larger than value.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference (in Visual Basic Nothing).
RankException | array is multidimensional.
ArgumentException | Neither value nor the elements of array implement the IComparable interface. -or- value is not of the same type as the elements of array.

Remarks

value and each element of array must implement the IComparable interface, which is used for comparisons.

If array is not already sorted according to the IComparable interface, the result may be incorrect.

a null reference (Nothing) can always be compared with any other type; therefore, comparisons with a null reference (Nothing) will not generate an exception. When sorting, a null reference (Nothing) is considered to be less than any other object.

The bitwise complement operator (~) can be applied to a negative result to produce the index of the first element (if any) that is larger than the specified search value.

See Also

Array Class | Array Members | System Namespace | Array.BinarySearch Overload List | IComparable | Sort


Array.BinarySearch (Array, Int32, Int32, Object)

Searches a section of a one-dimensional Array for a value, using the IComparable interface implemented by each element of the Array and by the specified value.

[Visual Basic]
Overloads Public Shared Function BinarySearch( _
   ByVal array As Array, _
   ByVal index As Integer, _
   ByVal length As Integer, _
   ByVal value As Object _
) As Integer
[C#]
public static int BinarySearch(
   Array array,
   int index,
   int length,
   object value
);
[C++]
public: static int BinarySearch(
   Array* array,
   int index,
   int length,
   Object* value
);
[JScript]
public static function BinarySearch(
   array : Array,
   index : int,
   length : int,
   value : Object
) : int;

Parameters

array
The one-dimensional Array to search.
index
The starting index of the range to search.
length
The length of the range to search.
value
The Object to search for.

Return Value

The index of the value in the Array, if value is found. Otherwise, a negative number, which is the bitwise complement of the index of the first element that is larger than value.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference (in Visual Basic Nothing).
RankException | array is multidimensional.
ArgumentOutOfRangeException | index is less than the lower bound of array. -or- length is less than zero.
ArgumentException | index and length do not denote a valid range in array. -or- Neither value nor the elements of array implement the IComparable interface. -or- value is not of the same type as the elements of array.

Remarks

value and each element of array must implement the IComparable interface, which is used for comparisons.

If array is not already sorted according to the IComparable interface, the result may be incorrect.

a null reference (Nothing) can always be compared with any other type; therefore, comparisons with a null reference (Nothing) will not generate an exception. When sorting, a null reference (Nothing) is considered to be less than any other object.

The bitwise complement operator (~) can be applied to a negative result to produce the index of the first element (if any) that is larger than the specified search value.

See Also

Array Class | Array Members | System Namespace | Array.BinarySearch Overload List | IComparable | Sort


Array.Clear

Sets a range of elements in the Array to 0 or a null reference (in Visual Basic Nothing).

[Visual Basic]
Public Shared Sub Clear( _
   ByVal array As Array, _
   ByVal index As Integer, _
   ByVal length As Integer _
)
[C#]
public static void Clear(
   Array array,
   int index,
   int length
);
[C++]
public: static void Clear(
   Array* array,
   int index,
   int length
);
[JScript]
public static function Clear(
   array : Array,
   index : int,
   length : int
);

Parameters

array
The Array whose elements would be cleared.
index
The starting index of the range of elements to clear.
length
The number of elements to clear.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference (Nothing).
ArgumentOutOfRangeException | index is less than 0. -or- length is less than 0. -or- The sum of index and length is greater than the size of the Array.

Remarks

Reference-type elements are set to a null reference (Nothing). Value-type elements are set to 0.

See Also

Array Class | Array Members | System Namespace


Array.Clone

Creates a deep copy of the Array.

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

Return Value

A deep copy of the Array.

See Also

Array Class | Array Members | System Namespace


Array.Copy

Copies a section of one Array to another Array, and performs type-downcasting as required.

Overload List

Copies a range of elements from a one-dimensional Array starting at the lower bound index, and pastes them into another one-dimensional Array starting at the lower bound index.

[Visual Basic] Overloads Public Shared Sub Copy(Array, Array, Integer)
[C#] public static void Copy(Array, Array, int);
[C++] public: static void Copy(Array*, Array*, int);
[JScript] public static function Copy(Array, Array, int);

Copies a range of elements from a one-dimensional Array starting at the specified source index, and pastes them into another one-dimensional Array starting at the specified destination index.

[Visual Basic] Overloads Public Shared Sub Copy(Array, Integer, Array, Integer, Integer)
[C#] public static void Copy(Array, int, Array, int, int);
[C++] public: static void Copy(Array*, int, Array*, int, int);
[JScript] public static function Copy(Array, int, Array, int, int);

See Also

Array Class | Array Members | System Namespace


Array.Copy (Array, Array, Int32)

Copies a range of elements from a one-dimensional Array starting at the lower bound index, and pastes them into another one-dimensional Array starting at the lower bound index.

[Visual Basic]
Overloads Public Shared Sub Copy( _
   ByVal sourceArray As Array, _
   ByVal destinationArray As Array, _
   ByVal length As Integer _
)
[C#]
public static void Copy(
   Array sourceArray,
   Array destinationArray,
   int length
);
[C++]
public: static void Copy(
   Array* sourceArray,
   Array* destinationArray,
   int length
);
[JScript]
public static function Copy(
   sourceArray : Array,
   destinationArray : Array,
   length : int
);

Parameters

sourceArray
The one-dimensional Array containing the data to copy.
destinationArray
The one-dimensional Array to receive the data.
length
The number of elements to copy.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | sourceArray is a null reference (in Visual Basic Nothing). -or- destinationArray is a null reference (Nothing).
RankException | sourceArray is multidimensional. -or- destinationArray is multidimensional.
ArrayTypeMismatchException | sourceArray and destinationArray are of incompatible types.
InvalidCastException | At least one element in sourceArray could not be cast to destinationArray 's type.
ArgumentOutOfRangeException | length is less than 0. -or- length is greater than the number of elements in sourceArray. -or- length is greater than the number of elements in destinationArray.

Remarks

Both the source array and the destination array must be one-dimensional. The source array can have zero elements.

The arrays may be reference-type arrays or value-type arrays. Type-downcasting is performed, as required.

See Also

Array Class | Array Members | System Namespace | Array.Copy Overload List


Array.Copy (Array, Int32, Array, Int32, Int32)

Copies a range of elements from a one-dimensional Array starting at the specified source index, and pastes them into another one-dimensional Array starting at the specified destination index.

[Visual Basic]
Overloads Public Shared Sub Copy( _
   ByVal sourceArray As Array, _
   ByVal sourceIndex As Integer, _
   ByVal destinationArray As Array, _
   ByVal destinationIndex As Integer, _
   ByVal length As Integer _
)
[C#]
public static void Copy(
   Array sourceArray,
   int sourceIndex,
   Array destinationArray,
   int destinationIndex,
   int length
);
[C++]
public: static void Copy(
   Array* sourceArray,
   int sourceIndex,
   Array* destinationArray,
   int destinationIndex,
   int length
);
[JScript]
public static function Copy(
   sourceArray : Array,
   sourceIndex : int,
   destinationArray : Array,
   destinationIndex : int,
   length : int
);

Parameters

sourceArray
The one-dimensional Array containing the data to copy.
sourceIndex
The starting index in the sourceArray where copying begins.
destinationArray
The one-dimensional Array to receive the data.
destinationIndex
The starting index in the destinationArray where storing begins.
length
The number of elements to copy.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | sourceArray is a null reference (in Visual Basic Nothing). -or- destinationArray is a null reference (Nothing).
RankException | sourceArray is multidimensional. -or- destinationArray is multidimensional.
ArrayTypeMismatchException | sourceArray and destinationArray are of incompatible types.
InvalidCastException | At least one element in sourceArray could not be cast to destinationArray 's type.
ArgumentOutOfRangeException | sourceIndex is less than sourceArray 's lower bound. -or- destinationIndex is less than destinationArray 's lower bound. -or- length is less than 0. -or- The sum of sourceIndex and length is greater than the number of elements in sourceArray. -or- The sum of destinationIndex and length is greater than the number of elements in destinationArray.

Remarks

Both the source array and the destination array must be one-dimensional. The source array can have zero elements.

The arrays may be reference-type arrays or value-type arrays. Type-downcasting is performed, as required.

Note that if this method throws an exception while copying, the elements of destination may be modified only up to the point where the exception occurs.

Supports multidimensional arrays, if their ranks and bounds are identical.

If the source and destination are both arrays of reference types, a shallow copy is performed. (The data members of the elements are not cloned, but rather referenced by the copy.) If the source and the destination are of incompatible types or if they differ by rank, an ArrayTypeMismatchException is thrown. If every element in the source requires a downcast (for example, from a base class to a subclass or from an interface to an object) and at least one element of the source cannot be cast to the corresponding type in the destination, an InvalidCastException is thrown.

If the source is an array of reference types and the destination is an array of value types, each element of source is unboxed and then copied into destination. If the source and the destination are of incompatible types or they differ by rank, an ArrayTypeMismatchException is thrown. If every element in the source requires a downcast and at least one element of the source cannot be cast to the corresponding type in the destination, an InvalidCastException is thrown.

Note that if the destination is an array of value types, the source must be either an array of the same value type, or an array of Object types or interface types implemented by that value type. Otherwise an ArrayTypeMismatchException is thrown because an interface and a value type that aren't directly connected are guaranteed not to be indirectly connected.

If source is an array of value types and destination is an array of reference types, each element of source is boxed and then copied to the reference array. If the source and the destination are of incompatible types or they differ by rank, an ArrayTypeMismatchException is thrown.

Note that if the source is a value type array, the destination can only be the same value type array, or an Object or interface array, where the interface is implemented by that value type. Down casting is not applicable in this situation, so an InvalidCastException will never occur.

If source and destination are both arrays of intrinsic value types, the copy will succeed. If the element types are identical or if the conversion from the source element type to the destination, element type is a widening coercion. An ArrayTypeMismatchException is thrown whenever a narrowing coercion is required. An ArrayTypeMismatchException is also thrown if either the source or the destination arrays are user-defined value types (i.e., non-intrinsic value types). If source and destination are both arrays of Objects, they are copied as described above for arrays of value types. If source is an array of Object and destination is an array of reference (or value) types, the values stored in each Object are retrieved, boxed, if needed, and copied to the destination array. A InvalidCastException is thrown if this assignment is not possible. If source is an array of reference or value types and destination is an array of type Object, an Object is created to hold each value (or reference) in source and is copied into destination.

See Also

Array Class | Array Members | System Namespace | Array.Copy Overload List


Array.CopyTo

Copies all the elements of the current Array into the specified Array, starting at the specified destination Array index.

[Visual Basic]
Overridable Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
[C#]
public virtual void CopyTo(
   Array array,
   int index
);
[C++]
public: virtual void CopyTo(
   Array* array,
   int index
);
[JScript]
public function CopyTo(
   array : Array,
   index : int
);

Parameters

array
The destination Array to copy the current Array 's elements into.
index
The destination Array index to start copying into.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference (in Visual Basic Nothing).

Remarks

This method can be overridden by a derived class.

This method is provided to support the ICollection interface and calls Copy internally. If implementing ICollection is not explicitly required, use Copy to avoid an extra indirection.

See Also

Array Class | Array Members | System Namespace | ICollection | Copy


Array.CreateInstance

Initializes a new instance of the Array class.

Overload List

Creates a three-dimensional Array of the specified Type and dimension lengths, with 0-based indexing.

[Visual Basic] Overloads Public Shared Function CreateInstance(Type, Integer, Integer, Integer) As Array
[C#] public static Array CreateInstance(Type, int, int, int);
[C++] public: static Array* CreateInstance(Type*, int, int, int);
[JScript] public static function CreateInstance(Type, int, int, int) : Array;

Creates a multidimensional Array of the specified Type and dimension lengths, with 0-based indexing.

[Visual Basic] Overloads Public Shared Function CreateInstance(Type, Integer()) As Array
[C#] public static Array CreateInstance(Type, int[]);
[C++] public: static Array* CreateInstance(Type*, int[]);
[JScript] public static function CreateInstance(Type, int[]) : Array;

Creates a multidimensional Array of the specified Type and dimension lengths, with the specified lower bounds.

[Visual Basic] Overloads Public Shared Function CreateInstance(Type, Integer(), Integer()) As Array
[C#] public static Array CreateInstance(Type, int[], int[]);
[C++] public: static Array* CreateInstance(Type*, int[], int[]);
[JScript] public static function CreateInstance(Type, int[], int[]) : Array;

Creates a one-dimensional Array of the specified Type and length, with 0-based indexing.

[Visual Basic] Overloads Public Shared Function CreateInstance(Type, Integer) As Array
[C#] public static Array CreateInstance(Type, int);
[C++] public: static Array* CreateInstance(Type*, int);
[JScript] public static function CreateInstance(Type, int) : Array;

Creates a two-dimensional Array of the specified Type and dimension lengths, with 0-based indexing.

[Visual Basic] Overloads Public Shared Function CreateInstance(Type, Integer, Integer) As Array
[C#] public static Array CreateInstance(Type, int, int);
[C++] public: static Array* CreateInstance(Type*, int, int);
[JScript] public static function CreateInstance(Type, int, int) : Array;

See Also

Array Class | Array Members | System Namespace


Array.CreateInstance (Type, Int32, Int32, Int32)

Creates a three-dimensional Array of the specified Type and dimension lengths, with 0-based indexing.

[Visual Basic]
Overloads Public Shared Function CreateInstance( _
   ByVal elementType As Type, _
   ByVal length1 As Integer, _
   ByVal length2 As Integer, _
   ByVal length3 As Integer _
) As Array
[C#]
public static Array CreateInstance(
   Type elementType,
   int length1,
   int length2,
   int length3
);
[C++]
public: static Array* CreateInstance(
   Type* elementType,
   int length1,
   int length2,
   int length3
);
[JScript]
public static function CreateInstance(
   elementType : Type,
   length1 : int,
   length2 : int,
   length3 : int
) : Array;

Parameters

elementType
The Type of array to create.
length1
The size of the first dimension of the array to create.
length2
The size of the second dimension of the array to create.
length3
The size of the third dimension of the array to create.

Return Value

A new three-dimensional Array of the specified Type and dimension lengths, with 0-based indexing.

Exceptions

Exception Type | Condition
ArgumentNullException | elementType is a null reference (in Visual Basic Nothing).
ArgumentException | elementType is not a valid Type.
ArgumentOutOfRangeException | length1 is less than 0. -or- length2 is less than 0. -or- length3 is less than 0.

Remarks

Reference-type elements are initialized to a null reference (Nothing). Value-type elements are initialized to 0.

See Also

Array Class | Array Members | System Namespace | Array.CreateInstance Overload List


Array.CreateInstance (Type, Int32[])

Creates a multidimensional Array of the specified Type and dimension lengths, with 0-based indexing.

[Visual Basic]
Overloads Public Shared Function CreateInstance( _
   ByVal elementType As Type, _
   ByVal lengths() As Integer _
) As Array
[C#]
public static Array CreateInstance(
   Type elementType,
   int[] lengths
);
[C++]
public: static Array* CreateInstance(
   Type* elementType,
   int* lengths[]
);
[JScript]
public static function CreateInstance(
   elementType : Type,
   lengths : int[]
) : Array;

Parameters

elementType
The Type of array to create.
lengths
An array containing the size of each dimension of the array to create.

Return Value

A new multidimensional Array of the specified Type and dimension lengths, with 0-based indexing.

Exceptions

Exception Type | Condition
ArgumentNullException | elementType is a null reference (in Visual Basic Nothing). -or- lengths is a null reference (Nothing).
ArgumentException | elementType is not a valid Type. -or- lengths contains less than one element.
ArgumentOutOfRangeException | Any value in lengths is less than 0.

Remarks

The number of elements in the lengths array must equal the number of dimensions in the new array. Each element of the lengths array must denote the length of the corresponding dimension in the new array.

Reference-type elements are initialized to a null reference (Nothing). Value-type elements are initialized to 0.

See Also

Array Class | Array Members | System Namespace | Array.CreateInstance Overload List


Array.CreateInstance (Type, Int32[], Int32[])

Creates a multidimensional Array of the specified Type and dimension lengths, with the specified lower bounds.

[Visual Basic]
Overloads Public Shared Function CreateInstance( _
   ByVal elementType As Type, _
   ByVal lengths() As Integer, _
   ByVal lowerBounds() As Integer _
) As Array
[C#]
public static Array CreateInstance(
   Type elementType,
   int[] lengths,
   int[] lowerBounds
);
[C++]
public: static Array* CreateInstance(
   Type* elementType,
   int* lengths[],
   int* lowerBounds[]
);
[JScript]
public static function CreateInstance(
   elementType : Type,
   lengths : int[],
   lowerBounds : int[]
) : Array;

Parameters

elementType
The Type of array to create.
lengths
A one-dimensional array containing the size of each dimension of the array to create.
lowerBounds
A one-dimensional array containing the lower bound (starting index) of each dimension of the array to create.

Return Value

A new multidimensional Array of the specified Type and dimension lengths, with the specified lower bounds.

Exceptions

Exception Type | Condition
ArgumentNullException | elementType is a null reference (in Visual Basic Nothing). -or- lengths is a null reference (Nothing). -or- lowerBounds is a null reference (Nothing).
ArgumentException | elementType is not a valid Type. -or- lengths contains less than one element. -or- lengths and lowerBounds do not contain the same number of elements.
ArgumentOutOfRangeException | Any value in lengths is less than 0.

Remarks

The lengths array and the lowerBounds array must have the same number of elements. The number of elements in the lengths array must equal the number of dimensions in the new array.

Each element of the lengths array must denote the length of the corresponding dimension in the new array.

Each element of the lowerBounds array must denote the lower bound of the corresponding dimension in the new array.

Reference-type elements are initialized to a null reference (Nothing). Value-type elements are initialized to 0.

See Also

Array Class | Array Members | System Namespace | Array.CreateInstance Overload List


Array.CreateInstance (Type, Int32)

Creates a one-dimensional Array of the specified Type and length, with 0-based indexing.

[Visual Basic]
Overloads Public Shared Function CreateInstance( _
   ByVal elementType As Type, _
   ByVal length As Integer _
) As Array
[C#]
public static Array CreateInstance(
   Type elementType,
   int length
);
[C++]
public: static Array* CreateInstance(
   Type* elementType,
   int length
);
[JScript]
public static function CreateInstance(
   elementType : Type,
   length : int
) : Array;

Parameters

elementType
The Type of array to create.
length
The size of the array to create.

Return Value

A new one-dimensional Array of the specified Type and length, with 0-based indexing.

Exceptions

Exception Type | Condition
ArgumentNullException | elementType is a null reference (in Visual Basic Nothing).
ArgumentException | elementType is not a valid Type.
ArgumentOutOfRangeException | length is less than 0.

Remarks

Reference-type elements are initialized to a null reference (Nothing). Value-type elements are initialized to 0.

See Also

Array Class | Array Members | System Namespace | Array.CreateInstance Overload List


Array.CreateInstance (Type, Int32, Int32)

Creates a two-dimensional Array of the specified Type and dimension lengths, with 0-based indexing.

[Visual Basic]
Overloads Public Shared Function CreateInstance( _
   ByVal elementType As Type, _
   ByVal length1 As Integer, _
   ByVal length2 As Integer _
) As Array
[C#]
public static Array CreateInstance(
   Type elementType,
   int length1,
   int length2
);
[C++]
public: static Array* CreateInstance(
   Type* elementType,
   int length1,
   int length2
);
[JScript]
public static function CreateInstance(
   elementType : Type,
   length1 : int,
   length2 : int
) : Array;

Parameters

elementType
The Type of array to create.
length1
The size of the first dimension of the array to create.
length2
The size of the second dimension of the array to create.

Return Value

A new two-dimensional Array of the specified Type and dimension lengths, with 0-based indexing.

Exceptions

Exception Type | Condition
ArgumentNullException | elementType is a null reference (in Visual Basic Nothing).
ArgumentException | elementType is not a valid Type.
ArgumentOutOfRangeException | length1 is less than 0. -or- length2 is less than 0.

Remarks

Reference-type elements are initialized to a null reference (Nothing). Value-type elements are initialized to 0.

See Also

Array Class | Array Members | System Namespace | Array.CreateInstance Overload List


Array.GetEnumerator

Returns an IEnumerator for the one-dimensional Array.

[Visual Basic]
Overridable Public Function GetEnumerator() As IEnumerator
[C#]
public virtual IEnumerator GetEnumerator();
[C++]
public: virtual IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

Return Value

An IEnumerator for the one-dimensional Array.

Exceptions

Exception Type | Condition
NotSupportedException | The Array is multidimensional.

Remarks

This method can be overridden by a derived class.

The enumerator does not have exclusive access to the Array; therefore, any changes made to the Array may cause Current or MoveNext to throw an exception.

Removing objects from the enumerator will remove them from the Array.

See Also

Array Class | Array Members | System Namespace


Array.GetLength

Gets the number of elements in the specified dimension of the Array.

[Visual Basic]
Public Function GetLength( _
   ByVal dimension As Integer _
) As Integer
[C#]
public int GetLength(
   int dimension
);
[C++]
public: int GetLength(
   int dimension
);
[JScript]
public function GetLength(
   dimension : int
) : int;

Parameters

dimension
A zero-based dimension of the Array whose length to determine.

Return Value

The number of elements in the specified dimension.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | dimension is less than zero. -or- dimension is equal to or greater than Rank.

Remarks

For example, GetLength (0) returns the number of elements in the first dimension of the Array.

See Also

Array Class | Array Members | System Namespace | Length | Rank


Array.GetLowerBound

Gets the lower bound of the specified dimension in the Array.

[Visual Basic]
Public Function GetLowerBound( _
   ByVal dimension As Integer _
) As Integer
[C#]
public int GetLowerBound(
   int dimension
);
[C++]
public: int GetLowerBound(
   int dimension
);
[JScript]
public function GetLowerBound(
   dimension : int
) : int;

Parameters

dimension
A zero-based dimension of the Array whose lower bound to determine.

Return Value

The lower bound of the specified dimension in the Array.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | dimension is less than zero. -or- dimension is equal to or greater than Rank.

Remarks

For example, GetLowerBound (0) returns the lower bound for the indexes of the first dimension of the Array, and GetLowerBound (Rank- 1) will return the lower bound of the last dimension of the Array.

See Also

Array Class | Array Members | System Namespace | GetUpperBound | Rank


Array.GetUpperBound

Gets the upper bound of the specified dimension in the Array.

[Visual Basic]
Public Function GetUpperBound( _
   ByVal dimension As Integer _
) As Integer
[C#]
public int GetUpperBound(
   int dimension
);
[C++]
public: int GetUpperBound(
   int dimension
);
[JScript]
public function GetUpperBound(
   dimension : int
) : int;

Parameters

dimension
A zero-based dimension of the Array whose upper bound to determine.

Return Value

The upper bound of the specified dimension in the Array.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | dimension is less than zero. -or- dimension is equal to or greater than Rank.

Remarks

For example, GetUpperBound (0) returns the upper bound for the indices of the first dimension of the Array and GetUpperBound (Rank- 1) returns the upper bound of the last dimension of the Array.

See Also

Array Class | Array Members | System Namespace | GetLowerBound | Rank


Array.GetValue

Gets the value(s) of the Array element(s) at the specified index(es).

Overload List

Gets the value at the specified position in the two-dimensional Array.

[Visual Basic] Overloads Public Function GetValue(Integer, Integer) As Object
[C#] public object GetValue(int, int);
[C++] public: Object* GetValue(int, int);
[JScript] public function GetValue(int, int) : Object;

Gets the value at the specified position in the three-dimensional Array.

[Visual Basic] Overloads Public Function GetValue(Integer, Integer, Integer) As Object
[C#] public object GetValue(int, int, int);
[C++] public: Object* GetValue(int, int, int);
[JScript] public function GetValue(int, int, int) : Object;

Gets the value at the specified position in the multidimensional Array.

[Visual Basic] Overloads Public Function GetValue(Integer()) As Object
[C#] public object GetValue(int[]);
[C++] public: Object* GetValue(int*[]);
[JScript] public function GetValue(int[]) : Object;

Gets the value at the specified position in the one-dimensional Array.

[Visual Basic] Overloads Public Function GetValue(Integer) As Object
[C#] public object GetValue(int);
[C++] public: Object* GetValue(int);
[JScript] public function GetValue(int) : Object;

See Also

Array Class | Array Members | System Namespace


Array.GetValue (Int32, Int32)

Gets the value at the specified position in the two-dimensional Array.

[Visual Basic]
Overloads Public Function GetValue( _
   ByVal index1 As Integer, _
   ByVal index2 As Integer _
) As Object
[C#]
public object GetValue(
   int index1,
   int index2
);
[C++]
public: Object* GetValue(
   int index1,
   int index2
);
[JScript]
public function GetValue(
   index1 : int,
   index2 : int
) : Object;

Parameters

index1
The first-dimension index of the Array element to retrieve.
index2
The second-dimension index of the Array element to retrieve.

Return Value

The value at the specified position in the Array.

Exceptions

Exception Type | Condition
ArgumentException | The Array does not have exactly two dimensions.
IndexOutOfRangeException | index1 or index2 is outside the range of valid indices for the corresponding dimension of the Array.

Remarks

The GetLowerBound and GetUpperBound methods can be used to determine whether any of the indices is out of bounds.

See Also

Array Class | Array Members | System Namespace | Array.GetValue Overload List | GetLowerBound | GetUpperBound | SetValue


Array.GetValue (Int32, Int32, Int32)

Gets the value at the specified position in the three-dimensional Array.

[Visual Basic]
Overloads Public Function GetValue( _
   ByVal index1 As Integer, _
   ByVal index2 As Integer, _
   ByVal index3 As Integer _
) As Object
[C#]
public object GetValue(
   int index1,
   int index2,
   int index3
);
[C++]
public: Object* GetValue(
   int index1,
   int index2,
   int index3
);
[JScript]
public function GetValue(
   index1 : int,
   index2 : int,
   index3 : int
) : Object;

Parameters

index1
The first-dimension index of the Array element to retrieve.
index2
The second-dimension index of the Array element to retrieve.
index3
The third-dimension index of the Array element to retrieve.

Return Value

The value at the specified position in the Array.

Exceptions

Exception Type | Condition
ArgumentException | The Array does not have exactly three dimensions.
IndexOutOfRangeException | index1 or index2 or index3 is outside the range of valid indices for the corresponding dimension of the Array.

Remarks

The GetLowerBound and GetUpperBound methods can be used to determine whether any of the indices is out of bounds.

See Also

Array Class | Array Members | System Namespace | Array.GetValue Overload List | GetLowerBound | GetUpperBound | SetValue


Array.GetValue (Int32[])

Gets the value at the specified position in the multidimensional Array.

[Visual Basic]
Overloads Public Function GetValue( _
   ByVal indices() As Integer _
) As Object
[C#]
public object GetValue(
   int[] indices
);
[C++]
public: Object* GetValue(
   int* indices[]
);
[JScript]
public function GetValue(
   indices : int[]
) : Object;

Parameters

indices
A one-dimensional array of indices specifying the position of the element to retrieve.

Return Value

The value at the specified position in the Array.

Exceptions

Exception Type | Condition
ArgumentNullException | indices is a null reference (in Visual Basic Nothing).
ArgumentException | The number of dimensions in the Array is not equal to the number of elements in indices.
IndexOutOfRangeException | Any element in indices is outside the range of valid indices for the corresponding dimension of the Array.

Remarks

The number of elements in indices must equal the number of dimensions in the Array. All elements in the indices array must collectively denote the position of the desired element in the multidimensional Array.

The GetLowerBound and GetUpperBound methods can be used to determine whether any of the indices is out of bounds.

See Also

Array Class | Array Members | System Namespace | Array.GetValue Overload List | GetLowerBound | GetUpperBound | SetValue


Array.GetValue (Int32)

Gets the value at the specified position in the one-dimensional Array.

[Visual Basic]
Overloads Public Function GetValue( _
   ByVal index As Integer _
) As Object
[C#]
public object GetValue(
   int index
);
[C++]
public: Object* GetValue(
   int index
);
[JScript]
public function GetValue(
   index : int
) : Object;

Parameters

index
The position of the value to retrieve from the Array.

Return Value

The value at the specified position in the one-dimensional Array.

Exceptions

Exception Type | Condition
ArgumentException | The Array does not have exactly one dimension.
IndexOutOfRangeException | index is outside the range of valid indices for the Array.

Remarks

The GetLowerBound and GetUpperBound methods can be used to determine whether the value of index is out of bounds.

See Also

Array Class | Array Members | System Namespace | Array.GetValue Overload List | GetLowerBound | GetUpperBound | SetValue


Array.IndexOf

Returns the index of the first occurrence of a value in a one-dimensional Array, or in a portion of it.

Overload List

Searches the entire one-dimensional Array for a specific value.

[Visual Basic] Overloads Public Shared Function IndexOf(Array, Object) As Integer
[C#] public static int IndexOf(Array, Object);
[C++] public: static int IndexOf(Array*, Object);
[JScript] public static function IndexOf(Array, Object) : int;

Searches the one-dimensional Array for a specific value, starting at the specified index and ending at the last element.

[Visual Basic] Overloads Public Shared Function IndexOf(Array, Object, Integer) As Integer
[C#] public static int IndexOf(Array, Object, int);
[C++] public: static int IndexOf(Array*, Object, int);
[JScript] public static function IndexOf(Array, Object, int) : int;

Searches the one-dimensional Array for a specific value, starting at the specified start index and ending at the element just prior to the specified end index (?).

[Visual Basic] Overloads Public Shared Function IndexOf(Array, Object, Integer, Integer) As Integer
[C#] public static int IndexOf(Array, Object, int, int);
[C++] public: static int IndexOf(Array*, Object, int, int);
[JScript] public static function IndexOf(Array, Object, int, int) : int;

See Also

Array Class | Array Members | System Namespace


Array.IndexOf (Array, Object)

Searches the entire one-dimensional Array for a specific value.

[Visual Basic]
Overloads Public Shared Function IndexOf( _
   ByVal array As Array, _
   ByVal value As Object _
) As Integer
[C#]
public static int IndexOf(
   Array array,
   object value
);
[C++]
public: static int IndexOf(
   Array* array,
   Object* value
);
[JScript]
public static function IndexOf(
   array : Array,
   value : Object
) : int;

Parameters

array
The one-dimensional Array to search.
value
The Object to locate in array.

Return Value

The index of the first occurrence of value in the entire one-dimensional array, or-1 if value does not occur in array.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference (in Visual Basic Nothing).

Remarks

The Array is searched forwards, and the elements are compared to the specified value using the Equals method.

See Also

Array Class | Array Members | System Namespace | Array.IndexOf Overload List | LastIndexOf


Array.IndexOf (Array, Object, Int32)

Searches the one-dimensional Array for a specific value, starting at the specified index and ending at the last element.

[Visual Basic]
Overloads Public Shared Function IndexOf( _
   ByVal array As Array, _
   ByVal value As Object, _
   ByVal startIndex As Integer _
) As Integer
[C#]
public static int IndexOf(
   Array array,
   object value,
   int startIndex
);
[C++]
public: static int IndexOf(
   Array* array,
   Object* value,
   int startIndex
);
[JScript]
public static function IndexOf(
   array : Array,
   value : Object,
   startIndex : int
) : int;

Parameters

array
The one-dimensional Array to search.
value
The Object to locate in array.
startIndex
The starting index of the search.

Return Value

The index of the first occurrence of value in the range startIndex through the last element, or-1 if value does not occur in that range.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference (in Visual Basic Nothing).
ArgumentOutOfRangeException | startIndex is outside the range of valid indices for array.

Remarks

The Array is searched forwards, starting at startIndex and ending at the last element, and the elements are compared to the specified value using the Equals method.

See Also

Array Class | Array Members | System Namespace | Array.IndexOf Overload List | LastIndexOf


Array.IndexOf (Array, Object, Int32, Int32)

Searches the one-dimensional Array for a specific value, starting at the specified start index and ending at the element just prior to the specified end index (?).

[Visual Basic]
Overloads Public Shared Function IndexOf( _
   ByVal array As Array, _
   ByVal value As Object, _
   ByVal startIndex As Integer, _
   ByVal endIndex As Integer _
) As Integer
[C#]
public static int IndexOf(
   Array array,
   object value,
   int startIndex,
   int endIndex
);
[C++]
public: static int IndexOf(
   Array* array,
   Object* value,
   int startIndex,
   int endIndex
);
[JScript]
public static function IndexOf(
   array : Array,
   value : Object,
   startIndex : int,
   endIndex : int
) : int;

Parameters

array
The one-dimensional Array to search.
value
The Object to locate in array.
startIndex
The starting index of the search.
endIndex
The index after (?) the last element of the search range.

Return Value

The index of the first occurrence of value in the range startIndex through endIndex-1 (?), or-1 if value does not occur in that range.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference (in Visual Basic Nothing).
ArgumentOutOfRangeException | startIndex is outside the range of valid indices for array. -or- endIndex is less than startIndex. -or- endIndex is greater than the last valid index of array plus 1 (?).

Remarks

The Array is searched forwards, starting at startIndex and ending at the element just prior to (?) endIndex, and the elements are compared to the specified value using the Equals method.

See Also

Array Class | Array Members | System Namespace | Array.IndexOf Overload List | LastIndexOf


Array.Initialize

Initializes every element of the value-type Array, by calling the default constructor of the value class.

[Visual Basic]
Public Sub Initialize()
[C#]
public void Initialize();
[C++]
public: void Initialize();
[JScript]
public function Initialize();

Return Value

None.

Remarks

This method should not be used on reference-type arrays.

The value-type Array can have any lower bound and any number of dimensions.

See Also

Array Class | Array Members | System Namespace


Array.LastIndexOf

Returns the index of the last occurrence of a value in a one-dimensional Array, or in a portion of it.

Overload List

Determines the index of the last occurrence of a value in the entire one-dimensional Array by searching backwards, starting at the last element and ending at the first element.

[Visual Basic] Overloads Public Shared Function LastIndexOf(Array, Object) As Integer
[C#] public static int LastIndexOf(Array, Object);
[C++] public: static int LastIndexOf(Array*, Object);
[JScript] public static function LastIndexOf(Array, Object) : int;

Determines the index of the last occurrence of a value in the one-dimensional Array by searching backwards, starting at the specified index and ending at the first element.

[Visual Basic] Overloads Public Shared Function LastIndexOf(Array, Object, Integer) As Integer
[C#] public static int LastIndexOf(Array, Object, int);
[C++] public: static int LastIndexOf(Array*, Object, int);
[JScript] public static function LastIndexOf(Array, Object, int) : int;

Determines the index of the last occurrence of a value in the one-dimensional Array by searching backwards, starting and ending at the specified indices.

[Visual Basic] Overloads Public Shared Function LastIndexOf(Array, Object, Integer, Integer) As Integer
[C#] public static int LastIndexOf(Array, Object, int, int);
[C++] public: static int LastIndexOf(Array*, Object, int, int);
[JScript] public static function LastIndexOf(Array, Object, int, int) : int;

See Also

Array Class | Array Members | System Namespace


Array.LastIndexOf (Array, Object)

Determines the index of the last occurrence of a value in the entire one-dimensional Array by searching backwards, starting at the last element and ending at the first element.

[Visual Basic]
Overloads Public Shared Function LastIndexOf( _
   ByVal array As Array, _
   ByVal value As Object _
) As Integer
[C#]
public static int LastIndexOf(
   Array array,
   object value
);
[C++]
public: static int LastIndexOf(
   Array* array,
   Object* value
);
[JScript]
public static function LastIndexOf(
   array : Array,
   value : Object
) : int;

Parameters

array
The one-dimensional Array to search.
value
The Object to locate in array.

Return Value

The index of the last occurrence of value in the entire one-dimensional array, or-1 if value does not occur in array.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference (in Visual Basic Nothing).

Remarks

The Array is searched backwards, and the elements are compared to the specified value using the Equals method.

See Also

Array Class | Array Members | System Namespace | Array.LastIndexOf Overload List | IndexOf


Array.LastIndexOf (Array, Object, Int32)

Determines the index of the last occurrence of a value in the one-dimensional Array by searching backwards, starting at the specified index and ending at the first element.

[Visual Basic]
Overloads Public Shared Function LastIndexOf( _
   ByVal array As Array, _
   ByVal value As Object, _
   ByVal startIndex As Integer _
) As Integer
[C#]
public static int LastIndexOf(
   Array array,
   object value,
   int startIndex
);
[C++]
public: static int LastIndexOf(
   Array* array,
   Object* value,
   int startIndex
);
[JScript]
public static function LastIndexOf(
   array : Array,
   value : Object,
   startIndex : int
) : int;

Parameters

array
The one-dimensional Array to search.
value
The Object to locate in array.
startIndex
The starting index of the backward search.

Return Value

The index of the last occurrence of value in the range 0 through startIndex, or-1 if value does not occur in that range.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference (in Visual Basic Nothing).
ArgumentOutOfRangeException | startIndex is outside the range of valid indices for array.

Remarks

The Array is searched backwards, starting at startIndex and ending at index 0, and the elements are compared to the specified value using the Equals method.

See Also

Array Class | Array Members | System Namespace | Array.LastIndexOf Overload List | IndexOf


Array.LastIndexOf (Array, Object, Int32, Int32)

Determines the index of the last occurrence of a value in the one-dimensional Array by searching backwards, starting and ending at the specified indices.

[Visual Basic]
Overloads Public Shared Function LastIndexOf( _
   ByVal array As Array, _
   ByVal value As Object, _
   ByVal startIndex As Integer, _
   ByVal endIndex As Integer _
) As Integer
[C#]
public static int LastIndexOf(
   Array array,
   object value,
   int startIndex,
   int endIndex
);
[C++]
public: static int LastIndexOf(
   Array* array,
   Object* value,
   int startIndex,
   int endIndex
);
[JScript]
public static function LastIndexOf(
   array : Array,
   value : Object,
   startIndex : int,
   endIndex : int
) : int;

Parameters

array
The one-dimensional Array to search.
value
The Object to locate in array.
startIndex
The starting index of the backward search.
endIndex
The ending index of the backward search.

Return Value

The index of the last occurrence of value in the range endIndex through startIndex, or-1 if value does not occur in that range.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference (in Visual Basic Nothing).
ArgumentOutOfRangeException | startIndex or endIndex is outside the range of valid indices for array. -or- endIndex is greater than startIndex.

Remarks

The Array is searched backwards, starting at startIndex and ending at endIndex, and the elements are compared to the specified value using the Equals method.

See Also

Array Class | Array Members | System Namespace | Array.LastIndexOf Overload List | IndexOf


Array.Reverse

Reverses the order of the elements in the specified one-dimensional Array, or in a portion of it.

Overload List

Reverses the sequence of the elements in a section of the one-dimensional Array.

[Visual Basic] Overloads Public Shared Sub Reverse(Array, Integer, Integer)
[C#] public static void Reverse(Array, int, int);
[C++] public: static void Reverse(Array*, int, int);
[JScript] public static function Reverse(Array, int, int);

Reverses the sequence of the elements in the entire one-dimensional Array.

[Visual Basic] Overloads Public Shared Sub Reverse(Array)
[C#] public static void Reverse(Array);
[C++] public: static void Reverse(Array*);
[JScript] public static function Reverse(Array);

See Also

Array Class | Array Members | System Namespace


Array.Reverse (Array, Int32, Int32)

Reverses the sequence of the elements in a section of the one-dimensional Array.

[Visual Basic]
Overloads Public Shared Sub Reverse( _
   ByVal array As Array, _
   ByVal index As Integer, _
   ByVal length As Integer _
)
[C#]
public static void Reverse(
   Array array,
   int index,
   int length
);
[C++]
public: static void Reverse(
   Array* array,
   int index,
   int length
);
[JScript]
public static function Reverse(
   array : Array,
   index : int,
   length : int
);

Parameters

array
The one-dimensional Array to reverse.
index
The starting index of the section to reverse.
length
The number of elements in the section to reverse.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference (in Visual Basic Nothing).
RankException | array is multidimensional.
ArgumentOutOfRangeException | index is less than the lower bound of array. -or- length is less than zero.
ArgumentException | index and length do not denote a valid range in array.

Remarks

After a call to this method, the element at Array [i], where i is any index within the range, moves to Array [j], where j equals index + index + count- i- 1.

See Also

Array Class | Array Members | System Namespace | Array.Reverse Overload List


Array.Reverse (Array)

Reverses the sequence of the elements in the entire one-dimensional Array.

[Visual Basic]
Overloads Public Shared Sub Reverse( _
   ByVal array As Array _
)
[C#]
public static void Reverse(
   Array array
);
[C++]
public: static void Reverse(
   Array* array
);
[JScript]
public static function Reverse(
   array : Array
);

Parameters

array
The one-dimensional Array to reverse.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference (in Visual Basic Nothing).
RankException | array is multidimensional.

Remarks

After a call to this method, the element at Array [i], where i is any index in the array, moves to Array [j], where j equals the length of the array- i- 1.

See Also

Array Class | Array Members | System Namespace | Array.Reverse Overload List


Array.SetValue

Sets the specified Array element(s) to the specified value.

Overload List

Assigns a value to the element at the specified position in the three-dimensional Array.

[Visual Basic] Overloads Public Sub SetValue(Object, Integer, Integer, Integer)
[C#] public void SetValue(Object, int, int, int);
[C++] public: void SetValue(Object*, int, int, int);
[JScript] public function SetValue(Object, int, int, int);

Assigns a value to the element at the specified position in the multidimensional Array.

[Visual Basic] Overloads Public Sub SetValue(Object, Integer())
[C#] public void SetValue(Object, int[]);
[C++] public: void SetValue(Object*, int[]);
[JScript] public function SetValue(Object, int[]);

Assigns a value to the element at the specified position in the one-dimensional Array.

[Visual Basic] Overloads Public Sub SetValue(Object, Integer)
[C#] public void SetValue(Object, int);
[C++] public: void SetValue(Object*, int);
[JScript] public function SetValue(Object, int);

Assigns a value to the element at the specified position in the two-dimensional Array.

[Visual Basic] Overloads Public Sub SetValue(Object, Integer, Integer)
[C#] public void SetValue(Object, int, int);
[C++] public: void SetValue(Object*, int, int);
[JScript] public function SetValue(Object, int, int);

See Also

Array Class | Array Members | System Namespace


Array.SetValue (Object, Int32, Int32, Int32)

Assigns a value to the element at the specified position in the three-dimensional Array.

[Visual Basic]
Overloads Public Sub SetValue( _
   ByVal value As Object, _
   ByVal index1 As Integer, _
   ByVal index2 As Integer, _
   ByVal index3 As Integer _
)
[C#]
public void SetValue(
   object value,
   int index1,
   int index2,
   int index3
);
[C++]
public: void SetValue(
   Object* value,
   int index1,
   int index2,
   int index3
);
[JScript]
public function SetValue(
   value : Object,
   index1 : int,
   index2 : int,
   index3 : int
);

Parameters

value
The new value for the specified element.
index1
The first-dimension index of the Array element to set.
index2
The second-dimension index of the Array element to set.
index3
The third-dimension index of the Array element to set.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentException | The Array does not have exactly three dimensions. -or- value does not contain a type that can be widened, using the standard widening conversions, to the element type of the Array.
IndexOutOfRangeException | index1 or index2 or index3 is outside the range of valid indices for the corresponding dimension of the Array.

Remarks

The GetLowerBound and GetUpperBound methods can be used to determine whether any of the indices is out of bounds.

See Also

Array Class | Array Members | System Namespace | Array.SetValue Overload List | GetLowerBound | GetUpperBound | GetValue


Array.SetValue (Object, Int32[])

Assigns a value to the element at the specified position in the multidimensional Array.

[Visual Basic]
Overloads Public Sub SetValue( _
   ByVal value As Object, _
   ByVal indices() As Integer _
)
[C#]
public void SetValue(
   object value,
   int[] indices
);
[C++]
public: void SetValue(
   Object* value,
   int* indices[]
);
[JScript]
public function SetValue(
   value : Object,
   indices : int[]
);

Parameters

value
The new value for the specified element.
indices
A one-dimensional array of indices specifying the position of the element to set.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | indices is a null reference (in Visual Basic Nothing).
ArgumentException | The number of dimensions in the Array is not equal to the number of elements in indices.
IndexOutOfRangeException | Any element in indices is outside the range of valid indices for the corresponding dimension of the Array.

Remarks

The number of elements in indices must equal the number of dimensions in the Array. All elements in the indices array must collectively denote the position of the desired element in the multidimensional Array.

The GetLowerBound and GetUpperBound methods can be used to determine whether any of the indices is out of bounds.

See Also

Array Class | Array Members | System Namespace | Array.SetValue Overload List | GetLowerBound | GetUpperBound | GetValue


Array.SetValue (Object, Int32)

Assigns a value to the element at the specified position in the one-dimensional Array.

[Visual Basic]
Overloads Public Sub SetValue( _
   ByVal value As Object, _
   ByVal index As Integer _
)
[C#]
public void SetValue(
   object value,
   int index
);
[C++]
public: void SetValue(
   Object* value,
   int index
);
[JScript]
public function SetValue(
   value : Object,
   index : int
);

Parameters

value
The new value for the specified element.
index
The position of the Array element to set.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentException | The Array does not have exactly one dimension. -or- value does not contain a type that can be widened, using the standard widening conversions, to the element type of the Array.
IndexOutOfRangeException | index is outside the range of valid indices for the Array.

Remarks

The GetLowerBound and GetUpperBound methods can be used to determine whether the value of index is out of bounds.

See Also

Array Class | Array Members | System Namespace | Array.SetValue Overload List | GetLowerBound | GetUpperBound | GetValue


Array.SetValue (Object, Int32, Int32)

Assigns a value to the element at the specified position in the two-dimensional Array.

[Visual Basic]
Overloads Public Sub SetValue( _
   ByVal value As Object, _
   ByVal index1 As Integer, _
   ByVal index2 As Integer _
)
[C#]
public void SetValue(
   object value,
   int index1,
   int index2
);
[C++]
public: void SetValue(
   Object* value,
   int index1,
   int index2
);
[JScript]
public function SetValue(
   value : Object,
   index1 : int,
   index2 : int
);

Parameters

value
The new value for the specified element.
index1
The first-dimension index of the Array element to set.
index2
The second-dimension index of the Array element to set.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentException | The Array does not have exactly two dimensions. -or- value does not contain a type that can be widened, using the standard widening conversions, to the element type of the Array.
IndexOutOfRangeException | index1 or index2 is outside the range of valid indices for the corresponding dimension of the Array.

Remarks

The GetLowerBound and GetUpperBound methods can be used to determine whether any of the indices is out of bounds.

See Also

Array Class | Array Members | System Namespace | Array.SetValue Overload List | GetLowerBound | GetUpperBound | GetValue


Array.Sort

Sorts the elements in one-dimensional Array objects.

Overload List

Sorts a pair of one-dimensional Array objects- one containing the keys and the other containing the corresponding items- based on the keys in the first Array, using the specified IComparer interface.

[Visual Basic] Overloads Public Shared Sub Sort(Array, Array, IComparer)
[C#] public static void Sort(Array, Array, IComparer);
[C++] public: static void Sort(Array*, Array*, IComparer);
[JScript] public static function Sort(Array, Array, IComparer);

Sorts the elements in a section of a one-dimensional Array, using the specified IComparer interface.

[Visual Basic] Overloads Public Shared Sub Sort(Array, Integer, Integer, IComparer)
[C#] public static void Sort(Array, int, int, IComparer);
[C++] public: static void Sort(Array*, int, int, IComparer);
[JScript] public static function Sort(Array, int, int, IComparer);

Sorts a section of a pair of one-dimensional Array objects- one containing the keys and the other containing the corresponding items- based on the keys in the first Array, using the specified IComparer interface.

[Visual Basic] Overloads Public Shared Sub Sort(Array, Array, Integer, Integer, IComparer)
[C#] public static void Sort(Array, Array, int, int, IComparer);
[C++] public: static void Sort(Array*, Array*, int, int, IComparer);
[JScript] public static function Sort(Array, Array, int, int, IComparer);

Sorts the elements in a one-dimensional Array, using the specified IComparer interface.

[Visual Basic] Overloads Public Shared Sub Sort(Array, IComparer)
[C#] public static void Sort(Array, IComparer);
[C++] public: static void Sort(Array*, IComparer);
[JScript] public static function Sort(Array, IComparer);

Sorts a pair of one-dimensional Array objects- one containing the keys and the other containing the corresponding items- based on the keys in the first Array, using the IComparable interface implemented by each key.

[Visual Basic] Overloads Public Shared Sub Sort(Array, Array)
[C#] public static void Sort(Array, Array);
[C++] public: static void Sort(Array*, Array*);
[JScript] public static function Sort(Array, Array);

Sorts the elements in an entire one-dimensional Array, using the IComparable interface implemented by each element of the Array.

[Visual Basic] Overloads Public Shared Sub Sort(Array)
[C#] public static void Sort(Array);
[C++] public: static void Sort(Array*);
[JScript] public static function Sort(Array);

Sorts a section of a pair of one-dimensional Array objects- one containing the keys and the other containing the corresponding items- based on the keys in the first Array, using the IComparable interface implemented by each key.

[Visual Basic] Overloads Public Shared Sub Sort(Array, Array, Integer, Integer)
[C#] public static void Sort(Array, Array, int, int);
[C++] public: static void Sort(Array*, Array*, int, int);
[JScript] public static function Sort(Array, Array, int, int);

Sorts the elements in a section of a one-dimensional Array, using the IComparable interface implemented by each element of the Array.

[Visual Basic] Overloads Public Shared Sub Sort(Array, Integer, Integer)
[C#] public static void Sort(Array, int, int);
[C++] public: static void Sort(Array*, int, int);
[JScript] public static function Sort(Array, int, int);

See Also

Array Class | Array Members | System Namespace


Array.Sort (Array, Array, IComparer)

Sorts a pair of one-dimensional Array objects- one containing the keys and the other containing the corresponding items- based on the keys in the first Array, using the specified IComparer interface.

[Visual Basic]
Overloads Public Shared Sub Sort( _
   ByVal keys As Array, _
   ByVal items As Array, _
   ByVal comparer As IComparer _
)
[C#]
public static void Sort(
   Array keys,
   Array items,
   IComparer comparer
);
[C++]
public: static void Sort(
   Array* keys,
   Array* items,
   IComparer* comparer
);
[JScript]
public static function Sort(
   keys : Array,
   items : Array,
   comparer : IComparer
);

Parameters

keys
The one-dimensional Array containing the keys to sort.
items
The one-dimensional Array containing the items that correspond to each of the keys in the keys Array.

-or-

a null reference (in Visual Basic Nothing) to sort only the keys Array.

comparer
The IComparer implementation to use when comparing elements.

-or-

a null reference (Nothing) to use the IComparable implementation of each element.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | keys is a null reference (Nothing). -or- items is a null reference (Nothing).
RankException | keys is multidimensional. -or- items is multidimensional.
ArgumentException | items is not a null reference (Nothing), and the lower bound of keys does not match the lower bound of items.
InvalidCastException | comparer is a null reference (Nothing), and one or more elements in the keys array does not implement the IComparable interface.

Remarks

Each key in the keys Array has a corresponding item in the items Array. When a key is repositioned during the sorting, the corresponding item in the items Array is similarly repositioned. Therefore, the items Array is sorted according to the arrangement of the corresponding keys in the keys Array.

If comparer is a null reference (Nothing), each key in the keys Array must implement the IComparable interface to be capable of comparisons with every other key.

See Also

Array Class | Array Members | System Namespace | Array.Sort Overload List | IComparer | IComparable | BinarySearch


Array.Sort (Array, Int32, Int32, IComparer)

Sorts the elements in a section of a one-dimensional Array, using the specified IComparer interface.

[Visual Basic]
Overloads Public Shared Sub Sort( _
   ByVal array As Array, _
   ByVal index As Integer, _
   ByVal length As Integer, _
   ByVal comparer As IComparer _
)
[C#]
public static void Sort(
   Array array,
   int index,
   int length,
   IComparer comparer
);
[C++]
public: static void Sort(
   Array* array,
   int index,
   int length,
   IComparer* comparer
);
[JScript]
public static function Sort(
   array : Array,
   index : int,
   length : int,
   comparer : IComparer
);

Parameters

array
The one-dimensional Array to sort.
index
The starting index of the range to sort.
length
The number of elements in the range to sort.
comparer
The IComparer implementation to use when comparing elements.

-or-

a null reference (in Visual Basic Nothing) to use the IComparable implementation of each element.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference (Nothing).
RankException | array is multidimensional.
ArgumentOutOfRangeException | index is less than the lower bound of array. -or- length is less than zero.
ArgumentException | index and length do not denote a valid range in array.
InvalidCastException | comparer is a null reference (Nothing), and one or more elements in array does not implement the IComparable interface.

Remarks

If comparer is a null reference (Nothing), each element within the specified section of array must implement the IComparable interface to be capable of comparisons with every other element in array.

See Also

Array Class | Array Members | System Namespace | Array.Sort Overload List | IComparer | IComparable | BinarySearch


Array.Sort (Array, Array, Int32, Int32, IComparer)

Sorts a section of a pair of one-dimensional Array objects- one containing the keys and the other containing the corresponding items- based on the keys in the first Array, using the specified IComparer interface.

[Visual Basic]
Overloads Public Shared Sub Sort( _
   ByVal keys As Array, _
   ByVal items As Array, _
   ByVal index As Integer, _
   ByVal length As Integer, _
   ByVal comparer As IComparer _
)
[C#]
public static void Sort(
   Array keys,
   Array items,
   int index,
   int length,
   IComparer comparer
);
[C++]
public: static void Sort(
   Array* keys,
   Array* items,
   int index,
   int length,
   IComparer* comparer
);
[JScript]
public static function Sort(
   keys : Array,
   items : Array,
   index : int,
   length : int,
   comparer : IComparer
);

Parameters

keys
The one-dimensional Array containing the keys to sort.
items
The one-dimensional Array containing the items that correspond to each of the keys in the keys Array.

-or-

a null reference (in Visual Basic Nothing) to sort only the keys Array.

index
The starting index of the range to sort.
length
The number of elements in the range to sort.
comparer
The IComparer implementation to use when comparing elements.

-or-

a null reference (Nothing) to use the IComparable implementation of each element.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | keys is a null reference (Nothing).
RankException | keys is multidimensional. -or- items is not a null reference (Nothing) and is multidimensional.
ArgumentOutOfRangeException | index is less than the lower bound of keys. -or- length is less than zero.
ArgumentException | items is not a null reference (Nothing), and the lower bound of keys does not match the lower bound of items. -or- index and length do not denote a valid range in the keys Array. -or- items is not a null reference (Nothing), and index and length do not denote a valid range in the items Array.
InvalidCastException | comparer is a null reference (Nothing), and one or more elements in the keys array does not implement the IComparable interface.

Remarks

Each key in the keys Array has a corresponding item in the items Array. When a key is repositioned during the sorting, the corresponding item in the items Array is similarly repositioned. Therefore, the items Array is sorted according to the arrangement of the corresponding keys in the keys Array.

If comparer is a null reference (Nothing), each key within the specified section of the keys Array must implement the IComparable interface to be capable of comparisons with every other key.

See Also

Array Class | Array Members | System Namespace | Array.Sort Overload List | IComparer | IComparable | BinarySearch


Array.Sort (Array, IComparer)

Sorts the elements in a one-dimensional Array, using the specified IComparer interface.

[Visual Basic]
Overloads Public Shared Sub Sort( _
   ByVal array As Array, _
   ByVal comparer As IComparer _
)
[C#]
public static void Sort(
   Array array,
   IComparer comparer
);
[C++]
public: static void Sort(
   Array* array,
   IComparer* comparer
);
[JScript]
public static function Sort(
   array : Array,
   comparer : IComparer
);

Parameters

array
The one-dimensional Array to sort.
comparer
The IComparer implementation to use when comparing elements.

-or-

a null reference (in Visual Basic Nothing) to use the IComparable implementation of each element.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference (Nothing).
RankException | array is multidimensional.
InvalidCastException | comparer is a null reference (Nothing), and one or more elements in array does not implement the IComparable interface.

Remarks

If comparer is a null reference (Nothing), each element of array must implement the IComparable interface to be capable of comparisons with every other element in array.

See Also

Array Class | Array Members | System Namespace | Array.Sort Overload List | IComparer | IComparable | BinarySearch


Array.Sort (Array, Array)

Sorts a pair of one-dimensional Array objects- one containing the keys and the other containing the corresponding items- based on the keys in the first Array, using the IComparable interface implemented by each key.

[Visual Basic]
Overloads Public Shared Sub Sort( _
   ByVal keys As Array, _
   ByVal items As Array _
)
[C#]
public static void Sort(
   Array keys,
   Array items
);
[C++]
public: static void Sort(
   Array* keys,
   Array* items
);
[JScript]
public static function Sort(
   keys : Array,
   items : Array
);

Parameters

keys
The one-dimensional Array containing the keys to sort.
items
The one-dimensional Array containing the items that correspond to each of the keys in the keys Array.

-or-

a null reference (in Visual Basic Nothing) to sort only the keys Array.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | keys is a null reference (Nothing). -or- items is a null reference (Nothing).
RankException | keys is multidimensional. -or- items is multidimensional.
ArgumentException | items is not a null reference (Nothing), and the lower bound of keys does not match the lower bound of items.

Remarks

Each key in the keys Array has a corresponding item in the items Array. When a key is repositioned during the sorting, the corresponding item in the items Array is similarly repositioned. Therefore, the items Array is sorted according to the arrangement of the corresponding keys in the keys Array.

Each key in the keys Array must implement the IComparable interface to be capable of comparisons with every other key.

See Also

Array Class | Array Members | System Namespace | Array.Sort Overload List | IComparable | BinarySearch


Array.Sort (Array)

Sorts the elements in an entire one-dimensional Array, using the IComparable interface implemented by each element of the Array.

[Visual Basic]
Overloads Public Shared Sub Sort( _
   ByVal array As Array _
)
[C#]
public static void Sort(
   Array array
);
[C++]
public: static void Sort(
   Array* array
);
[JScript]
public static function Sort(
   array : Array
);

Parameters

array
The one-dimensional Array to sort.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference (in Visual Basic Nothing).
RankException | array is multidimensional.

Remarks

Each element of array must implement the IComparable interface to be capable of comparisons with every other element in array.

See Also

Array Class | Array Members | System Namespace | Array.Sort Overload List | IComparable | BinarySearch


Array.Sort (Array, Array, Int32, Int32)

Sorts a section of a pair of one-dimensional Array objects- one containing the keys and the other containing the corresponding items- based on the keys in the first Array, using the IComparable interface implemented by each key.

[Visual Basic]
Overloads Public Shared Sub Sort( _
   ByVal keys As Array, _
   ByVal items As Array, _
   ByVal index As Integer, _
   ByVal length As Integer _
)
[C#]
public static void Sort(
   Array keys,
   Array items,
   int index,
   int length
);
[C++]
public: static void Sort(
   Array* keys,
   Array* items,
   int index,
   int length
);
[JScript]
public static function Sort(
   keys : Array,
   items : Array,
   index : int,
   length : int
);

Parameters

keys
The one-dimensional Array containing the keys to sort.
items
The one-dimensional Array containing the items that correspond to each of the keys in the keys Array.

-or-

a null reference (in Visual Basic Nothing) to sort only the keys Array.

index
The starting index of the range to sort.
length
The number of elements in the range to sort.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | keys is a null reference (Nothing).
RankException | keys is multidimensional. -or- items is not a null reference (Nothing) and is multidimensional.
ArgumentOutOfRangeException | index is less than the lower bound of keys. -or- length is less than zero.
ArgumentException | items is not a null reference (Nothing), and the lower bound of keys does not match the lower bound of items. -or- index and length do not denote a valid range in the keys Array. -or- items is not a null reference (Nothing), and index and length do not denote a valid range in the items Array.

Remarks

Each key in the keys Array has a corresponding item in the items Array. When a key is repositioned during the sorting, the corresponding item in the items Array is similarly repositioned. Therefore, the items Array is sorted according to the arrangement of the corresponding keys in the keys Array.

Each key within the specified section of the keys Array must implement the IComparable interface to be capable of comparisons with every other key.

See Also

Array Class | Array Members | System Namespace | Array.Sort Overload List | IComparable | BinarySearch


Array.Sort (Array, Int32, Int32)

Sorts the elements in a section of a one-dimensional Array, using the IComparable interface implemented by each element of the Array.

[Visual Basic]
Overloads Public Shared Sub Sort( _
   ByVal array As Array, _
   ByVal index As Integer, _
   ByVal length As Integer _
)
[C#]
public static void Sort(
   Array array,
   int index,
   int length
);
[C++]
public: static void Sort(
   Array* array,
   int index,
   int length
);
[JScript]
public static function Sort(
   array : Array,
   index : int,
   length : int
);

Parameters

array
The one-dimensional Array to sort.
index
The starting index of the range to sort.
length
The number of elements in the range to sort.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference (in Visual Basic Nothing).
RankException | array is multidimensional.
ArgumentOutOfRangeException | index is less than the lower bound of array. -or- length is less than zero.
ArgumentException | index and length do not denote a valid range in array.

Remarks

Each element within the specified section of array must implement the IComparable interface to be capable of comparisons with every other element in array.

See Also

Array Class | Array Members | System Namespace | Array.Sort Overload List | IComparable | BinarySearch


ArrayTypeMismatchException Class

Represents an exception that is thrown when an attempt is made to store an object of the wrong type within an array.

Object
Exception
SystemException
ArrayTypeMismatchException

[Visual Basic]
Public Class ArrayTypeMismatchException
   Inherits SystemException
[C#]
public class ArrayTypeMismatchException : SystemException
[C++]
public __gc class ArrayTypeMismatchException : public
   SystemException
[JScript]
public class ArrayTypeMismatchException extends SystemException

Remarks

The ArrayMismatchException is the exception class that is used when an exception is thrown when the arrays are of different primitive types.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

ArrayTypeMismatchException Members | System Namespace


ArrayTypeMismatchException Members

Public:

Constructor

ArrayTypeMismatchException Constructor Overloaded. Initializes a new instance of the ArrayTypeMismatchException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

ArrayTypeMismatchException Class | System Namespace


ArrayTypeMismatchException Constructor

Initializes a new instance of the ArrayTypeMismatchException class.

Overload List

Initializes a new instance of the ArrayTypeMismatchException class with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public ArrayTypeMismatchException();
[C++] public: ArrayTypeMismatchException();
[JScript] public function ArrayTypeMismatchException();

Initializes a new instance of the ArrayTypeMismatchException class with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public ArrayTypeMismatchException(String);
[C++] public: ArrayTypeMismatchException(String*);
[JScript] public function ArrayTypeMismatchException(String);

Initializes a new instance of the ArrayTypeMismatchException class with a specified message and exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public ArrayTypeMismatchException(String, Exception);
[C++] public: ArrayTypeMismatchException(String*, Exception);
[JScript] public function ArrayTypeMismatchException(String, Exception);

See Also

ArrayTypeMismatchException Class | ArrayTypeMismatchException Members | System Namespace


ArrayTypeMismatchException Constructor ()

Initializes a new instance of the ArrayTypeMismatchException class with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ArrayTypeMismatchException();
[C++]
public: ArrayTypeMismatchException();
[JScript]
public function ArrayTypeMismatchException();

Remarks

ArraeyTypeMismatchException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The empty string.

See Also

ArrayTypeMismatchException Class | ArrayTypeMismatchException Members | System Namespace | ArrayTypeMismatchException Constructor Overload List


ArrayTypeMismatchException Constructor (String)

Initializes a new instance of the ArrayTypeMismatchException class with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public ArrayTypeMismatchException(
   string message
);
[C++]
public: ArrayTypeMismatchException(
   String* message
);
[JScript]
public function ArrayTypeMismatchException(
   message : String
);

Parameters

message
The message that indicates the reason the exception occurred.

Remarks

ArrayTypeMismatchException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | null
Message | The message string.

See Also

ArrayTypeMismatchException Class | ArrayTypeMismatchException Members | System Namespace | ArrayTypeMismatchException Constructor Overload List


ArrayTypeMismatchException Constructor (String, Exception)

Initializes a new instance of the ArrayTypeMismatchException class with a specified message and exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public ArrayTypeMismatchException(
   string message,
   Exception inner
);
[C++]
public: ArrayTypeMismatchException(
   String* message,
   Exception* inner
);
[JScript]
public function ArrayTypeMismatchException(
   message : String,
   inner : Exception
);

Parameters

message
[To be supplied.]
inner
[To be supplied.]

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

ArrayTypeMismatchException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | The inner exception reference.
Message | The message string.

See Also

ArrayTypeMismatchException Class | ArrayTypeMismatchException Members | System Namespace | ArrayTypeMismatchException Constructor Overload List


AsyncCallback Delegate

Delegate for methods that complete asynchronously.

[Visual Basic]
Public Delegate Sub AsyncCallback( _
   ByVal ar As IAsyncResult _
)
[C#]
public delegate void AsyncCallback(
   IAsyncResult ar
);
[C++]
public __gc __delegate void AsyncCallback(
   IAsyncResult* ar
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the AsyncCallback delegate declaration.

ar
The IAsyncResult for the async call.

Remarks

The delegate method uses the IAsyncResult to obtain information about the async call.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

System Namespace


Attribute Class

Custom attributes add user-defined annotations to the metadata. Custom attributes allow an instance of a type to be stored with any element of the metadata. This mechanism can be used to store application specific information at compile time and access it either at runtime or when another tool reads the metadata. While any user-defined type can be used as an attribute it is expected that most attributes will be instances of types whose parent is System.Attribute. The NGWS runtime predefines some attribute types and uses them to control runtime behavior. Some languages predefine attribute types to represent language features not directly represented in the VOS. Users or other tools are welcome to define and use additional attribute types.

All Attributes inherit (directly or indirectly) from System.Attribute. This common base class gives all Attributes a central point in the hierarchy from which they can inherit. Compilers and other development tools use this information to identify which types are Custom Attributes

Just inheriting from System.Attribute gives an attribute certain default behaviors: Allowed on any element, Inheritable, duplicate instances are not allowed.

Object
Attribute

[Visual Basic]
Public Class Attribute
[C#]
public class Attribute
[C++]
public __gc class Attribute
[JScript]
public class Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

Attribute Members | System Namespace


Attribute Members

Public:

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCustomAttribute | Overloaded. [To be supplied.]
GetCustomAttributes | Overloaded. Returns an instance of each custom attribute defined on the given attributedElement or an empty array if non-exists. If customAttributeType is a base class or interface this method will return any implementation of subclass of that type. Returns an empty array if non-custom attributes exists on this the given element. Ignores any attributes that don't inherit from System.Attribute. If a type is specified, the array returned must be an array of that type.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsDefined | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Constructor

Attribute Constructor Initializes a new instance of the Attribute class.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Attribute Class | System Namespace


Attribute Constructor

Initializes a new instance of the Attribute class.

[Visual Basic]
Protected Sub New()
[C#]
protected Attribute();
[C++]
protected: Attribute();
[JScript]
protected function Attribute();

Remarks

None

See Also

Attribute Class | Attribute Members | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Attribute Methods

The methods of the Attribute class are listed below. For a complete list of Attribute class members, see the Attribute Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCustomAttribute | Overloaded. [To be supplied.]
GetCustomAttributes | Overloaded. Returns an instance of each custom attribute defined on the given attributedElement or an empty array if non-exists. If customAttributeType is a base class or interface this method will return any implementation of subclass of that type. Returns an empty array if non-custom attributes exists on this the given element. Ignores any attributes that don't inherit from System.Attribute. If a type is specified, the array returned must be an array of that type.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsDefined | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Attribute Class | System Namespace


Attribute.GetCustomAttribute

[To be supplied.]

Overload List

Returns an instance of attributeType or a null reference (in Visual Basic Nothing) if non-exists on the given element.

[Visual Basic] Overloads Public Shared Function GetCustomAttribute(ParameterInfo, Type) As Attribute
[C#] public static Attribute GetCustomAttribute(ParameterInfo, Type);
[C++] public: static Attribute* GetCustomAttribute(ParameterInfo*, Type);
[JScript] public static function GetCustomAttribute(ParameterInfo, Type) : Attribute;

Returns an instance of attributeType or a null reference (Nothing) if non-exists on the given element.

[Visual Basic] Overloads Public Shared Function GetCustomAttribute(MemberInfo, Type) As Attribute
[C#] public static Attribute GetCustomAttribute(MemberInfo, Type);
[C++] public: static Attribute* GetCustomAttribute(MemberInfo*, Type);
[JScript] public static function GetCustomAttribute(MemberInfo, Type) : Attribute;

Returns an instance of attributeType or a null reference (Nothing) if non-exists on the given element.

[Visual Basic] Overloads Public Shared Function GetCustomAttribute(Assembly, Type) As Attribute
[C#] public static Attribute GetCustomAttribute(Assembly, Type);
[C++] public: static Attribute* GetCustomAttribute(Assembly*, Type);
[JScript] public static function GetCustomAttribute(Assembly, Type) : Attribute;

Returns an instance of attributeType or a null reference (Nothing) if non-exists on the given element.

[Visual Basic] Overloads Public Shared Function GetCustomAttribute(Module, Type) As Attribute
[C#] public static Attribute GetCustomAttribute(Module, Type);
[C++] public: static Attribute* GetCustomAttribute(Module*, Type);
[JScript] public static function GetCustomAttribute(Module, Type) : Attribute;

See Also

Attribute Class | Attribute Members | System Namespace


Attribute.GetCustomAttribute (ParameterInfo, Type)

Returns an instance of attributeType or a null reference (in Visual Basic Nothing) if non-exists on the given element.

[Visual Basic]
Overloads Public Shared Function GetCustomAttribute( _
   ByVal element As ParameterInfo, _
   ByVal attributeType As Type _
) As Attribute
[C#]
public static Attribute GetCustomAttribute(
   ParameterInfo element,
   Type attributeType
);
[C++]
public: static Attribute* GetCustomAttribute(
   ParameterInfo* element,
   Type* attributeType
);
[JScript]
public static function GetCustomAttribute(
   element : ParameterInfo,
   attributeType : Type
) : Attribute;

Parameters

element
The parameter to search for the custom attribute on.
attributeType
[To be supplied.]

Return Value

An instance of attributeType that was assigned to this parameter or a null reference (Nothing) if none exists.

Exceptions

Exception Type | Condition
AmbiguousMatchException | If there is more than one attribute of type attributeType defined on this element.

See Also

Attribute Class | Attribute Members | System Namespace | Attribute.GetCustomAttribute Overload List


Attribute.GetCustomAttribute (MemberInfo, Type)

Returns an instance of attributeType or a null reference (in Visual Basic Nothing) if non-exists on the given element.

[Visual Basic]
Overloads Public Shared Function GetCustomAttribute( _
   ByVal element As MemberInfo, _
   ByVal attributeType As Type _
) As Attribute
[C#]
public static Attribute GetCustomAttribute(
   MemberInfo element,
   Type attributeType
);
[C++]
public: static Attribute* GetCustomAttribute(
   MemberInfo* element,
   Type* attributeType
);
[JScript]
public static function GetCustomAttribute(
   element : MemberInfo,
   attributeType : Type
) : Attribute;

Parameters

element
The member to search for the custom attribute on.
attributeType
The type of the attribute to be returned.

Return Value

An instance of attributeType that was assigned to this member or a null reference (Nothing) if none exists.

Exceptions

Exception Type | Condition
AmbiguousMatchException | If there is more than one attribute of type attributeType defined on this element.

See Also

Attribute Class | Attribute Members | System Namespace | Attribute.GetCustomAttribute Overload List


Attribute.GetCustomAttribute (Assembly, Type)

Returns an instance of attributeType or a null reference (in Visual Basic Nothing) if non-exists on the given element.

[Visual Basic]
Overloads Public Shared Function GetCustomAttribute( _
   ByVal element As Assembly, _
   ByVal attributeType As Type _
) As Attribute
[C#]
public static Attribute GetCustomAttribute(
   Assembly element,
   Type attributeType
);
[C++]
public: static Attribute* GetCustomAttribute(
   Assembly* element,
   Type* attributeType
);
[JScript]
public static function GetCustomAttribute(
   element : Assembly,
   attributeType : Type
) : Attribute;

Parameters

element
The assembly to search for the custom attribute on.
attributeType
The type of the attribute to be returned.

Return Value

An instance of attributeType that was assigned to this assembly or a null reference (Nothing) if none exists.

Exceptions

Exception Type | Condition
AmbiguousMatchException | If there is more than one attribute of type attributeType defined on this element.

See Also

Attribute Class | Attribute Members | System Namespace | Attribute.GetCustomAttribute Overload List


Attribute.GetCustomAttribute (Module, Type)

Returns an instance of attributeType or a null reference (in Visual Basic Nothing) if non-exists on the given element.

[Visual Basic]
Overloads Public Shared Function GetCustomAttribute( _
   ByVal element As Module, _
   ByVal attributeType As Type _
) As Attribute
[C#]
public static Attribute GetCustomAttribute(
   Module element,
   Type attributeType
);
[C++]
public: static Attribute* GetCustomAttribute(
   Module* element,
   Type* attributeType
);
[JScript]
public static function GetCustomAttribute(
   element : Module,
   attributeType : Type
) : Attribute;

Parameters

element
The module to search for the custom attribute on.
attributeType
The type of the attribute to be returned.

Return Value

An instance of attributeType that was assigned to this module or a null reference (Nothing) if none exists.

Exceptions

Exception Type | Condition
AmbiguousMatchException | If there is more than one attribute of type attributeType defined on this element.

See Also

Attribute Class | Attribute Members | System Namespace | Attribute.GetCustomAttribute Overload List


Attribute.GetCustomAttributes

Returns an instance of each custom attribute defined on the given attributedElement or an empty array if non-exists. If customAttributeType is a base class or interface this method will return any implementation of subclass of that type. Returns an empty array if non-custom attributes exists on this the given element. Ignores any attributes that don't inherit from System.Attribute. If a type is specified, the array returned must be an array of that type.

Overload List

Returns an array of all the custom attributes of type attributeType defined on this assembly.

[Visual Basic] Overloads Public Shared Function GetCustomAttributes(Assembly, Type) As Attribute ()
[C#] public static Attribute[] GetCustomAttributes(Assembly, Type);
[C++] public: static Attribute* GetCustomAttributes(Assembly*, Type) [];
[JScript] public static function GetCustomAttributes(Assembly, Type) : Attribute[];

Returns an array of all the custom attributes of type attributeType defined on this module.

[Visual Basic] Overloads Public Shared Function GetCustomAttributes(Module, Type) As Attribute ()
[C#] public static Attribute[] GetCustomAttributes(Module, Type);
[C++] public: static Attribute* GetCustomAttributes(Module*, Type) [];
[JScript] public static function GetCustomAttributes(Module, Type) : Attribute[];

Returns an array of all the custom attributes defined on this parameter.

[Visual Basic] Overloads Public Shared Function GetCustomAttributes(ParameterInfo) As Attribute ()
[C#] public static Attribute[] GetCustomAttributes(ParameterInfo);
[C++] public: static Attribute* GetCustomAttributes(ParameterInfo*) [];
[JScript] public static function GetCustomAttributes(ParameterInfo) : Attribute[];

Returns an array of all the custom attributes defined on this assembly.

[Visual Basic] Overloads Public Shared Function GetCustomAttributes(Assembly) As Attribute ()
[C#] public static Attribute[] GetCustomAttributes(Assembly);
[C++] public: static Attribute* GetCustomAttributes(Assembly*) [];
[JScript] public static function GetCustomAttributes(Assembly) : Attribute[];

Returns an array of all the custom attributes defined on this module.

[Visual Basic] Overloads Public Shared Function GetCustomAttributes(Module) As Attribute ()
[C#] public static Attribute[] GetCustomAttributes(Module);
[C++] public: static Attribute* GetCustomAttributes(Module*) [];
[JScript] public static function GetCustomAttributes(Module) : Attribute[];

Returns an array of all the custom attributes of type type defined on this member.

[Visual Basic] Overloads Public Shared Function GetCustomAttributes(MemberInfo, Type) As Attribute ()
[C#] public static Attribute[] GetCustomAttributes(MemberInfo, Type);
[C++] public: static Attribute* GetCustomAttributes(MemberInfo*, Type) [];
[JScript] public static function GetCustomAttributes(MemberInfo, Type) : Attribute[];

Returns an array of all the custom attributes of type attributeType defined on this parameter.

[Visual Basic] Overloads Public Shared Function GetCustomAttributes(ParameterInfo, Type) As Attribute ()
[C#] public static Attribute[] GetCustomAttributes(ParameterInfo, Type);
[C++] public: static Attribute* GetCustomAttributes(ParameterInfo*, Type) [];
[JScript] public static function GetCustomAttributes(ParameterInfo, Type) : Attribute[];

Returns an array of all the custom attributes defined on this member.

[Visual Basic] Overloads Public Shared Function GetCustomAttributes(MemberInfo) As Attribute ()
[C#] public static Attribute[] GetCustomAttributes(MemberInfo);
[C++] public: static Attribute* GetCustomAttributes(MemberInfo*) [];
[JScript] public static function GetCustomAttributes(MemberInfo) : Attribute[];

See Also

Attribute Class | Attribute Members | System Namespace


Attribute.GetCustomAttributes (Assembly, Type)

Returns an array of all the custom attributes of type attributeType defined on this assembly.

[Visual Basic]
Overloads Public Shared Function GetCustomAttributes( _
   ByVal element As Assembly, _
   ByVal attributeType As Type _
) As Attribute ()
[C#]
public static Attribute[] GetCustomAttributes(
   Assembly element,
   Type attributeType
);
[C++]
public: static Attribute* GetCustomAttributes(
   Assembly* element,
   Type* attributeType
) [];
[JScript]
public static function GetCustomAttributes(
   element : Assembly,
   attributeType : Type
) : Attribute[];

Parameters

element
The assembly to search for the custom attribute on.
attributeType
The type of the attribute to be returned

Return Value

Returns an array of all the custom attributes of type attributeType defined on this assembly.

See Also

Attribute Class | Attribute Members | System Namespace | Attribute.GetCustomAttributes Overload List


Attribute.GetCustomAttributes (Module, Type)

Returns an array of all the custom attributes of type attributeType defined on this module.

[Visual Basic]
Overloads Public Shared Function GetCustomAttributes( _
   ByVal element As Module, _
   ByVal attributeType As Type _
) As Attribute ()
[C#]
public static Attribute[] GetCustomAttributes(
   Module element,
   Type attributeType
);
[C++]
public: static Attribute* GetCustomAttributes(
   Module* element,
   Type* attributeType
) [];
[JScript]
public static function GetCustomAttributes(
   element : Module,
   attributeType : Type
) : Attribute[];

Parameters

element
The module to search for the custom attribute on.
attributeType
The type of the attribute to be returned

Return Value

Returns an array of all the custom attributes of type attributeType defined on this module.

See Also

Attribute Class | Attribute Members | System Namespace | Attribute.GetCustomAttributes Overload List


Attribute.GetCustomAttributes (ParameterInfo)

Returns an array of all the custom attributes defined on this parameter.

[Visual Basic]
Overloads Public Shared Function GetCustomAttributes( _
   ByVal element As ParameterInfo _
) As Attribute ()
[C#]
public static Attribute[] GetCustomAttributes(
   ParameterInfo element
);
[C++]
public: static Attribute* GetCustomAttributes(
   ParameterInfo* element
) [];
[JScript]
public static function GetCustomAttributes(
   element : ParameterInfo
) : Attribute[];

Parameters

element
The parameter on which to look for custom attributes.

Return Value

Returns an array of all the custom attributes defined on this parameter.

See Also

Attribute Class | Attribute Members | System Namespace | Attribute.GetCustomAttributes Overload List


Attribute.GetCustomAttributes (Assembly)

Returns an array of all the custom attributes defined on this assembly.

[Visual Basic]
Overloads Public Shared Function GetCustomAttributes( _
   ByVal element As Assembly _
) As Attribute ()
[C#]
public static Attribute[] GetCustomAttributes(
   Assembly element
);
[C++]
public: static Attribute* GetCustomAttributes(
   Assembly* element
) [];
[JScript]
public static function GetCustomAttributes(
   element : Assembly
) : Attribute[];

Parameters

element
The assembly on which to look for custom attributes.

Return Value

Returns an array of all the custom attributes defined on this assembly.

See Also

Attribute Class | Attribute Members | System Namespace | Attribute.GetCustomAttributes Overload List


Attribute.GetCustomAttributes (Module)

Returns an array of all the custom attributes defined on this module.

[Visual Basic]
Overloads Public Shared Function GetCustomAttributes( _
   ByVal element As Module _
) As Attribute ()
[C#]
public static Attribute[] GetCustomAttributes(
   Module element
);
[C++]
public: static Attribute* GetCustomAttributes(
   Module* element
) [];
[JScript]
public static function GetCustomAttributes(
   element : Module
) : Attribute[];

Parameters

element
The module on which to look for custom attributes.

Return Value

Returns an array of all the custom attributes defined on this module.

See Also

Attribute Class | Attribute Members | System Namespace | Attribute.GetCustomAttributes Overload List


Attribute.GetCustomAttributes (MemberInfo, Type)

Returns an array of all the custom attributes of type type defined on this member.

[Visual Basic]
Overloads Public Shared Function GetCustomAttributes( _
   ByVal element As MemberInfo, _
   ByVal type As Type _
) As Attribute ()
[C#]
public static Attribute[] GetCustomAttributes(
   MemberInfo element,
   Type type
);
[C++]
public: static Attribute* GetCustomAttributes(
   MemberInfo* element,
   Type* type
) [];
[JScript]
public static function GetCustomAttributes(
   element : MemberInfo,
   type : Type
) : Attribute[];

Parameters

element
The member to search for the custom attribute on.
type
The type of the attribute to be returned

Return Value

Returns an array of all the custom attributes of type type defined on this member.

See Also

Attribute Class | Attribute Members | System Namespace | Attribute.GetCustomAttributes Overload List


Attribute.GetCustomAttributes (ParameterInfo, Type)

Returns an array of all the custom attributes of type attributeType defined on this parameter.

[Visual Basic]
Overloads Public Shared Function GetCustomAttributes( _
   ByVal element As ParameterInfo, _
   ByVal attributeType As Type _
) As Attribute ()
[C#]
public static Attribute[] GetCustomAttributes(
   ParameterInfo element,
   Type attributeType
);
[C++]
public: static Attribute* GetCustomAttributes(
   ParameterInfo* element,
   Type* attributeType
) [];
[JScript]
public static function GetCustomAttributes(
   element : ParameterInfo,
   attributeType : Type
) : Attribute[];

Parameters

element
The parameter to search for the custom attribute on.
attributeType
The type of the attribute to be returned

Return Value

Returns an array of all the custom attributes of type attributeType defined on this parameter.

See Also

Attribute Class | Attribute Members | System Namespace | Attribute.GetCustomAttributes Overload List


Attribute.GetCustomAttributes (MemberInfo)

Returns an array of all the custom attributes defined on this member.

[Visual Basic]
Overloads Public Shared Function GetCustomAttributes( _
   ByVal element As MemberInfo _
) As Attribute ()
[C#]
public static Attribute[] GetCustomAttributes(
   MemberInfo element
);
[C++]
public: static Attribute* GetCustomAttributes(
   MemberInfo* element
) [];
[JScript]
public static function GetCustomAttributes(
   element : MemberInfo
) : Attribute[];

Parameters

element
The member on which to look for custom attributes.

Return Value

Returns an array of all the custom attributes defined on this member.

See Also

Attribute Class | Attribute Members | System Namespace | Attribute.GetCustomAttributes Overload List


Attribute.IsDefined

[To be supplied.]

Overload List

Returns true if this attribute is defined on the given element (including inherited members)

[Visual Basic] Overloads Public Shared Function IsDefined(MemberInfo, Type) As Boolean
[C#] public static bool IsDefined(MemberInfo, Type);
[C++] public: static bool IsDefined(MemberInfo*, Type);
[JScript] public static function IsDefined(MemberInfo, Type) : Boolean;

Returns true if this attribute is defined on the given element (including inherited members)

[Visual Basic] Overloads Public Shared Function IsDefined(ParameterInfo, Type) As Boolean
[C#] public static bool IsDefined(ParameterInfo, Type);
[C++] public: static bool IsDefined(ParameterInfo*, Type);
[JScript] public static function IsDefined(ParameterInfo, Type) : Boolean;

Returns true if this attribute is defined on the given element (including inherited members)

[Visual Basic] Overloads Public Shared Function IsDefined(Assembly, Type) As Boolean
[C#] public static bool IsDefined(Assembly, Type);
[C++] public: static bool IsDefined(Assembly*, Type);
[JScript] public static function IsDefined(Assembly, Type) : Boolean;

Returns true if this attribute is defined on the given element (including inherited members)

[Visual Basic] Overloads Public Shared Function IsDefined(Module, Type) As Boolean
[C#] public static bool IsDefined(Module, Type);
[C++] public: static bool IsDefined(Module*, Type);
[JScript] public static function IsDefined(Module, Type) : Boolean;

See Also

Attribute Class | Attribute Members | System Namespace


Attribute.IsDefined (MemberInfo, Type)

Returns true if this attribute is defined on the given element (including inherited members)

[Visual Basic]
Overloads Public Shared Function IsDefined( _
   ByVal element As MemberInfo, _
   ByVal attributeType As Type _
) As Boolean
[C#]
public static bool IsDefined(
   MemberInfo element,
   Type attributeType
);
[C++]
public: static bool IsDefined(
   MemberInfo* element,
   Type* attributeType
);
[JScript]
public static function IsDefined(
   element : MemberInfo,
   attributeType : Type
) : Boolean;

Parameters

element
The member to search for the custom attribute on.
attributeType
The type of the attribute to be returned

Return Value

Returns true if this attribute is defined on the given element (including inherited members)

See Also

Attribute Class | Attribute Members | System Namespace | Attribute.IsDefined Overload List


Attribute.IsDefined (ParameterInfo, Type)

Returns true if this attribute is defined on the given element (including inherited members)

[Visual Basic]
Overloads Public Shared Function IsDefined( _
   ByVal element As ParameterInfo, _
   ByVal attributeType As Type _
) As Boolean
[C#]
public static bool IsDefined(
   ParameterInfo element,
   Type attributeType
);
[C++]
public: static bool IsDefined(
   ParameterInfo* element,
   Type* attributeType
);
[JScript]
public static function IsDefined(
   element : ParameterInfo,
   attributeType : Type
) : Boolean;

Parameters

element
The parameter to search for the custom attribute on.
attributeType
The type of the attribute to be returned

Return Value

Returns true if this attribute is defined on the given element (including inherited members)

See Also

Attribute Class | Attribute Members | System Namespace | Attribute.IsDefined Overload List


Attribute.IsDefined (Assembly, Type)

Returns true if this attribute is defined on the given element (including inherited members)

[Visual Basic]
Overloads Public Shared Function IsDefined( _
   ByVal element As Assembly, _
   ByVal attributeType As Type _
) As Boolean
[C#]
public static bool IsDefined(
   Assembly element,
   Type attributeType
);
[C++]
public: static bool IsDefined(
   Assembly* element,
   Type* attributeType
);
[JScript]
public static function IsDefined(
   element : Assembly,
   attributeType : Type
) : Boolean;

Parameters

element
The assembly to search for the custom attribute on.
attributeType
The type of the attribute to be returned

Return Value

Returns true if this attribute is defined on the given element (including inherited members)

See Also

Attribute Class | Attribute Members | System Namespace | Attribute.IsDefined Overload List


Attribute.IsDefined (Module, Type)

Returns true if this attribute is defined on the given element (including inherited members)

[Visual Basic]
Overloads Public Shared Function IsDefined( _
   ByVal element As Module, _
   ByVal attributeType As Type _
) As Boolean
[C#]
public static bool IsDefined(
   Module element,
   Type attributeType
);
[C++]
public: static bool IsDefined(
   Module* element,
   Type* attributeType
);
[JScript]
public static function IsDefined(
   element : Module,
   attributeType : Type
) : Boolean;

Parameters

element
The module to search for the custom attribute on.
attributeType
The type of the attribute to be returned

Return Value

Returns true if this attribute is defined on the given element (including inherited members)

See Also

Attribute Class | Attribute Members | System Namespace | Attribute.IsDefined Overload List


AttributeTargets Enumeration

Specifies all the elements of the VOS to which it is valid to attach the attribute.

[Visual Basic]
Public Enum AttributeTargets
[C#]
public enum AttributeTargets
[C++]
public enum AttributeTargets

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

AttributeTargets enumeration values may be bitwise or'ed together to get the appropriate combination.

do not use this enumeration. It will be removed in the next release.

Members

Member Name | Description
All | Attribute may be applied to any element.
Assembly | Attribute may be applied to an assembly.
Class | Attribute may be applied to a class.
ClassMembers | Attribute applied to only classes, methods, fields, events, and properties.
Constructor | Attribute may be applied to a constructor.
Delegate | Attribute may be applied to a delegate.
Enum | Attribute may be applied to an enumeration.
Event | Attribute may be applied to an event.
Field | Attribute may be applied to a field.
Interface | Attribute may be applied to an interface.
Method | Attribute may be applied to a method.
Module | Attribute may be applied to a module.
Parameter | Attribute may be applied to a parameter.
Property | Attribute may be applied to a property.
ReturnValue | Attribute may be applied to a Return value.
Struct | Attribute may be applied to a value type.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

System Namespace


AttributeUsageAttribute Class

[To be supplied.]

Object
Attribute
AttributeUsageAttribute

[Visual Basic]
NotInheritable Public Class AttributeUsageAttribute
   Inherits Attribute
[C#]
public sealed class AttributeUsageAttribute : Attribute
[C++]
public __gc __sealed class AttributeUsageAttribute : public
   Attribute
[JScript]
public class AttributeUsageAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

AttributeUsageAttribute Members | System Namespace


AttributeUsageAttribute Members

Public:

Constructor

AttributeUsageAttribute Constructor Initializes a new instance of the AttributeUsageAttribute class.

Properties

AllowMultiple | [To be supplied.]
Inherited | [To be supplied.]
ValidOn | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttributeUsageAttribute Class | System Namespace


AttributeUsageAttribute Constructor

Initializes a new instance of the AttributeUsageAttribute class.

[Visual Basic]
Public Sub New( _
   ByVal validOn As AttributeTargets _
)
[C#]
public AttributeUsageAttribute(
   AttributeTargets validOn
);
[C++]
public: AttributeUsageAttribute(
   AttributeTargets validOn
);
[JScript]
public function AttributeUsageAttribute(
   validOn : AttributeTargets
);

Parameters

validOn
[To be supplied.]

See Also

AttributeUsageAttribute Class | AttributeUsageAttribute Members | System Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AttributeUsageAttribute Properties

The properties of the AttributeUsageAttribute class are listed below. For a complete list of AttributeUsageAttribute class members, see the AttributeUsageAttribute Members topic.

Public:

AllowMultiple | [To be supplied.]
Inherited | [To be supplied.]
ValidOn | [To be supplied.]

See Also

AttributeUsageAttribute Class | System Namespace


AttributeUsageAttribute.AllowMultiple

[To be supplied.]

[Visual Basic]
Public Property AllowMultiple As Boolean
[C#]
public bool AllowMultiple {get; set;}
[C++]
public: __property bool get_AllowMultiple();
public: __property void set_AllowMultiple(bool);
[JScript]
public function get AllowMultiple() : Boolean;
public function set AllowMultiple(Boolean);

See Also

AttributeUsageAttribute Class | AttributeUsageAttribute Members | System Namespace


AttributeUsageAttribute.Inherited

[To be supplied.]

[Visual Basic]
Public Property Inherited As Boolean
[C#]
public bool Inherited {get; set;}
[C++]
public: __property bool get_Inherited();
public: __property void set_Inherited(bool);
[JScript]
public function get Inherited() : Boolean;
public function set Inherited(Boolean);

See Also

AttributeUsageAttribute Class | AttributeUsageAttribute Members | System Namespace


AttributeUsageAttribute.ValidOn

[To be supplied.]

[Visual Basic]
Public ReadOnly Property ValidOn As AttributeTargets
[C#]
public AttributeTargets ValidOn {get;}
[C++]
public: __property AttributeTargets get_ValidOn();
[JScript]
public function get ValidOn() : AttributeTargets;

See Also

AttributeUsageAttribute Class | AttributeUsageAttribute Members | System Namespace


BadImageFormatException Class

[To be supplied.]

Object
Exception
SystemException
BadImageFormatException

[Visual Basic]
Public Class BadImageFormatException
   Inherits SystemException
[C#]
public class BadImageFormatException : SystemException
[C++]
public __gc class BadImageFormatException : public SystemException
[JScript]
public class BadImageFormatException extends SystemException

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

BadImageFormatException Members | System Namespace


BadImageFormatException Members

Public:

Constructor

BadImageFormatException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

BadImageFormatException Class | System Namespace


BadImageFormatException Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public BadImageFormatException();
[C++] public: BadImageFormatException();
[JScript] public function BadImageFormatException();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public BadImageFormatException(String);
[C++] public: BadImageFormatException(String*);
[JScript] public function BadImageFormatException(String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public BadImageFormatException(String, Exception);
[C++] public: BadImageFormatException(String*, Exception);
[JScript] public function BadImageFormatException(String, Exception);

See Also

BadImageFormatException Class | BadImageFormatException Members | System Namespace


BadImageFormatException Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public BadImageFormatException();
[C++]
public: BadImageFormatException();
[JScript]
public function BadImageFormatException();

See Also

BadImageFormatException Class | BadImageFormatException Members | System Namespace | BadImageFormatException Constructor Overload List


BadImageFormatException Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public BadImageFormatException(
   string message
);
[C++]
public: BadImageFormatException(
   String* message
);
[JScript]
public function BadImageFormatException(
   message : String
);

Parameters

message
[To be supplied.]

See Also

BadImageFormatException Class | BadImageFormatException Members | System Namespace | BadImageFormatException Constructor Overload List


BadImageFormatException Constructor (String, Exception)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public BadImageFormatException(
   string message,
   Exception inner
);
[C++]
public: BadImageFormatException(
   String* message,
   Exception* inner
);
[JScript]
public function BadImageFormatException(
   message : String,
   inner : Exception
);

Parameters

message
[To be supplied.]
inner
[To be supplied.]

See Also

BadImageFormatException Class | BadImageFormatException Members | System Namespace | BadImageFormatException Constructor Overload List


BitConverter Class

Converts arrays of unsigned bytes to and from the base data types.

Object
BitConverter

[Visual Basic]
NotInheritable Public Class BitConverter
[C#]
public sealed class BitConverter
[C++]
public __gc __sealed class BitConverter
[JScript]
public class BitConverter

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

BitConverter Members | System Namespace


BitConverter Members

Public:

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBytes | Overloaded. Converts a specified type into an array of unsigned bytes.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToBoolean | Converts an array of bytes into a Boolean value.
ToChar | Converts two unsigned bytes into a unicode character value.
ToDouble | Converts eight unsigned bytes beginning at the specified index in the specified array into a double-precision floating point number.
ToInt16 | Converts two unsigned bytes beginning at the specified index in the specified array into a 16-bit signed integer value.
ToInt32 | Converts four bytes beginning at the specified index in the specified array to a 32-bit signed integer value.
ToInt64 | Converts eight bytes beginning at the specified index in the specified array into a 64-bit signed integer value.
ToSingle | Converts four bytes beginning at the specified index in the specified array into a single-precision floating point number.
ToString | Overloaded. [To be supplied.]
ToUInt16 | Converts an array of bytes into a 16-bit unsigned integer.
ToUInt32 | Converts an array of bytes into a 32-bit unsigned integer.
ToUInt64 | Converts an array of bytes into a 64-bit unsigned integer.

Fields

IsLittleEndian This field indicates the "endianess" of the architecture.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BitConverter Class | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

BitConverter Methods

The methods of the BitConverter class are listed below. For a complete list of BitConverter class members, see the BitConverter Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBytes | Overloaded. Converts a specified type into an array of unsigned bytes.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToBoolean | Converts an array of bytes into a Boolean value.
ToChar | Converts two unsigned bytes into a unicode character value.
ToDouble | Converts eight unsigned bytes beginning at the specified index in the specified array into a double-precision floating point number.
ToInt16 | Converts two unsigned bytes beginning at the specified index in the specified array into a 16-bit signed integer value.
ToInt32 | Converts four bytes beginning at the specified index in the specified array to a 32-bit signed integer value.
ToInt64 | Converts eight bytes beginning at the specified index in the specified array into a 64-bit signed integer value.
ToSingle | Converts four bytes beginning at the specified index in the specified array into a single-precision floating point number.
ToString | Overloaded. [To be supplied.]
ToUInt16 | Converts an array of bytes into a 16-bit unsigned integer.
ToUInt32 | Converts an array of bytes into a 32-bit unsigned integer.
ToUInt64 | Converts an array of bytes into a 64-bit unsigned integer.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BitConverter Class | System Namespace


BitConverter.GetBytes

Converts a specified type into an array of unsigned bytes.

Overload List

Converts a 32-bit unsigned integer into an array of bytes with length 4.

[Visual Basic] Overloads Public Shared Function GetBytes(UInt32) As Byte ()
[C#] public static byte[] GetBytes(uint);
[C++] public: static unsigned char* GetBytes(unsigned int) [];
[JScript] public static function GetBytes(UInt32) : Byte[];

Converts a 16-bit unsigned integer into an array of bytes with length 2.

[Visual Basic] Overloads Public Shared Function GetBytes(UInt16) As Byte ()
[C#] public static byte[] GetBytes(ushort);
[C++] public: static unsigned char* GetBytes(unsigned short) [];
[JScript] public static function GetBytes(UInt16) : Byte[];

Converts an 64-bit signed integer into an array of unsigned bytes with length 8.

[Visual Basic] Overloads Public Shared Function GetBytes(Long) As Byte ()
[C#] public static byte[] GetBytes(long);
[C++] public: static unsigned char* GetBytes(__int64) [];
[JScript] public static function GetBytes(long) : Byte[];

Converts a double-precision floating-point number into an array of unsigned bytes with length 8.

[Visual Basic] Overloads Public Shared Function GetBytes(Double) As Byte ()
[C#] public static byte[] GetBytes(double);
[C++] public: static unsigned char* GetBytes(double) [];
[JScript] public static function GetBytes(double) : Byte[];

Converts a single-precision floating-point number into an array of unsigned bytes with length 4.

[Visual Basic] Overloads Public Shared Function GetBytes(Single) As Byte ()
[C#] public static byte[] GetBytes(float);
[C++] public: static unsigned char* GetBytes(float) [];
[JScript] public static function GetBytes(float) : Byte[];

Converts a 64-bit unsigned integer into an array of bytes with length 8.

[Visual Basic] Overloads Public Shared Function GetBytes(UInt64) As Byte ()
[C#] public static byte[] GetBytes(ulong);
[C++] public: static unsigned char* GetBytes(unsigned __int64) [];
[JScript] public static function GetBytes(UInt64) : Byte[];

Converts a 16-bit signed integer into an array of unsigned bytes with length 2.

[Visual Basic] Overloads Public Shared Function GetBytes(Integer) As Byte ()
[C#] public static byte[] GetBytes(short);
[C++] public: static unsigned char* GetBytes(short) [];
[JScript] public static function GetBytes(Int16) : Byte[];

Converts a unicode character into an array of unsigned bytes with length 2.

[Visual Basic] Overloads Public Shared Function GetBytes(Char) As Byte ()
[C#] public static byte[] GetBytes(char);
[C++] public: static unsigned char* GetBytes(__wchar_t) [];
[JScript] public static function GetBytes(Char) : Byte[];

Converts a boolean value into an array of bytes with length one.

[Visual Basic] Overloads Public Shared Function GetBytes(Boolean) As Byte ()
[C#] public static byte[] GetBytes(bool);
[C++] public: static unsigned char* GetBytes(bool) [];
[JScript] public static function GetBytes(Boolean) : Byte[];

Converts a 32-bit signed integer into an array of unsigned bytes with length 4.

[Visual Basic] Overloads Public Shared Function GetBytes(Integer) As Byte ()
[C#] public static byte[] GetBytes(int);
[C++] public: static unsigned char* GetBytes(int) [];
[JScript] public static function GetBytes(int) : Byte[];

See Also

BitConverter Class | BitConverter Members | System Namespace


BitConverter.GetBytes (UInt32)

Converts a 32-bit unsigned integer into an array of bytes with length 4.

[Visual Basic]
Overloads Public Shared Function GetBytes( _
   ByVal value As UInt32 _
) As Byte ()
[C#]
public static byte[] GetBytes(
   uint value
);
[C++]
public: static unsigned char* GetBytes(
   unsigned int value
) [];
[JScript]
public static function GetBytes(
   value : UInt32
) : Byte[];

Parameters

value
The number to be converted.

Return Value

An array of bytes with length 4.

See Also

BitConverter Class | BitConverter Members | System Namespace | BitConverter.GetBytes Overload List


BitConverter.GetBytes (UInt16)

Converts a 16-bit unsigned integer into an array of bytes with length 2.

[Visual Basic]
Overloads Public Shared Function GetBytes( _
   ByVal value As UInt16 _
) As Byte ()
[C#]
public static byte[] GetBytes(
   ushort value
);
[C++]
public: static unsigned char* GetBytes(
   unsigned short value
) [];
[JScript]
public static function GetBytes(
   value : UInt16
) : Byte[];

Parameters

value
The number to be converted.

Return Value

An array of bytes with length 2.

See Also

BitConverter Class | BitConverter Members | System Namespace | BitConverter.GetBytes Overload List


BitConverter.GetBytes (Int64)

Converts an 64-bit signed integer into an array of unsigned bytes with length 8.

[Visual Basic]
Overloads Public Shared Function GetBytes( _
   ByVal value As Long _
) As Byte ()
[C#]
public static byte[] GetBytes(
   long value
);
[C++]
public: static unsigned char* GetBytes(
   __int64 value
) [];
[JScript]
public static function GetBytes(
   value : long
) : Byte[];

Parameters

value
The number to be converted.

Return Value

An array of unsigned bytes with length 8.

See Also

BitConverter Class | BitConverter Members | System Namespace | BitConverter.GetBytes Overload List


BitConverter.GetBytes (Double)

Converts a double-precision floating-point number into an array of unsigned bytes with length 8.

[Visual Basic]
Overloads Public Shared Function GetBytes( _
   ByVal value As Double _
) As Byte ()
[C#]
public static byte[] GetBytes(
   double value
);
[C++]
public: static unsigned char* GetBytes(
   double value
) [];
[JScript]
public static function GetBytes(
   value : double
) : Byte[];

Parameters

value
The number to be converted.

Return Value

An array of unsigned bytes with length 8.

See Also

BitConverter Class | BitConverter Members | System Namespace | BitConverter.GetBytes Overload List


BitConverter.GetBytes (Single)

Converts a single-precision floating-point number into an array of unsigned bytes with length 4.

[Visual Basic]
Overloads Public Shared Function GetBytes( _
   ByVal value As Single _
) As Byte ()
[C#]
public static byte[] GetBytes(
   float value
);
[C++]
public: static unsigned char* GetBytes(
   float value
) [];
[JScript]
public static function GetBytes(
   value : float
) : Byte[];

Parameters

value
The number to be converted.

Return Value

An array of unsigned bytes with length 4.

See Also

BitConverter Class | BitConverter Members | System Namespace | BitConverter.GetBytes Overload List


BitConverter.GetBytes (UInt64)

Converts a 64-bit unsigned integer into an array of bytes with length 8.

[Visual Basic]
Overloads Public Shared Function GetBytes( _
   ByVal value As UInt64 _
) As Byte ()
[C#]
public static byte[] GetBytes(
   ulong value
);
[C++]
public: static unsigned char* GetBytes(
   unsigned __int64 value
) [];
[JScript]
public static function GetBytes(
   value : UInt64
) : Byte[];

Parameters

value
The number to be converted.

Return Value

An array of bytes with length 8.

See Also

BitConverter Class | BitConverter Members | System Namespace | BitConverter.GetBytes Overload List


BitConverter.GetBytes (Int16)

Converts a 16-bit signed integer into an array of unsigned bytes with length 2.

[Visual Basic]
Overloads Public Shared Function GetBytes( _
   ByVal value As Short _
) As Byte ()
[C#]
public static byte[] GetBytes(
   short value
);
[C++]
public: static unsigned char* GetBytes(
   short value
) [];
[JScript]
public static function GetBytes(
   value : Int16
) : Byte[];

Parameters

value
The number to be converted.

Return Value

An array of unsigned bytes with length 2.

See Also

BitConverter Class | BitConverter Members | System Namespace | BitConverter.GetBytes Overload List


BitConverter.GetBytes (Char)

Converts a unicode character into an array of unsigned bytes with length 2.

[Visual Basic]
Overloads Public Shared Function GetBytes( _
   ByVal value As Char _
) As Byte ()
[C#]
public static byte[] GetBytes(
   char value
);
[C++]
public: static unsigned char* GetBytes(
   __wchar_t value
) [];
[JScript]
public static function GetBytes(
   value : Char
) : Byte[];

Parameters

value
The character to be converted.

Return Value

An array of unsigned bytes with length two.

See Also

BitConverter Class | BitConverter Members | System Namespace | BitConverter.GetBytes Overload List


BitConverter.GetBytes (Boolean)

Converts a boolean value into an array of bytes with length one.

[Visual Basic]
Overloads Public Shared Function GetBytes( _
   ByVal value As Boolean _
) As Byte ()
[C#]
public static byte[] GetBytes(
   bool value
);
[C++]
public: static unsigned char* GetBytes(
   bool value
) [];
[JScript]
public static function GetBytes(
   value : Boolean
) : Byte[];

Parameters

value
The value to be converted.

Return Value

An array of bytes with length one.

See Also

BitConverter Class | BitConverter Members | System Namespace | BitConverter.GetBytes Overload List


BitConverter.GetBytes (Int32)

Converts a 32-bit signed integer into an array of unsigned bytes with length 4.

[Visual Basic]
Overloads Public Shared Function GetBytes( _
   ByVal value As Integer _
) As Byte ()
[C#]
public static byte[] GetBytes(
   int value
);
[C++]
public: static unsigned char* GetBytes(
   int value
) [];
[JScript]
public static function GetBytes(
   value : int
) : Byte[];

Parameters

value
The number to be converted.

Return Value

An array of unsigned bytes with length 4.

See Also

BitConverter Class | BitConverter Members | System Namespace | BitConverter.GetBytes Overload List


BitConverter.ToBoolean

Converts an array of bytes into a Boolean value.

[Visual Basic]
Public Shared Function ToBoolean( _
   ByVal value() As Byte, _
   ByVal startIndex As Integer _
) As Boolean
[C#]
public static bool ToBoolean(
   byte[] value,
   int startIndex
);
[C++]
public: static bool ToBoolean(
   unsigned char* value[],
   int startIndex
);
[JScript]
public static function ToBoolean(
   value : Byte[],
   startIndex : int
) : Boolean;

Parameters

value
An array of unsigned bytes.
startIndex
A position within the value at which to begin.

Return Value

true if the unsigned byte value (i.e., the first byte beginning at startIndex) of value is nonzero; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentException | value is a null reference (in Visual Basic Nothing).
ArgumentException | startIndex is less than zero or greater than the length of value.

See Also

BitConverter Class | BitConverter Members | System Namespace


BitConverter.ToChar

Converts two unsigned bytes into a unicode character value.

[Visual Basic]
Public Shared Function ToChar( _
   ByVal value() As Byte, _
   ByVal startIndex As Integer _
) As Char
[C#]
public static char ToChar(
   byte[] value,
   int startIndex
);
[C++]
public: static __wchar_t ToChar(
   unsigned char* value[],
   int startIndex
);
[JScript]
public static function ToChar(
   value : Byte[],
   startIndex : int
) : Char;

Parameters

value
An array of unsigned bytes.
startIndex
A position within value at which to begin.

Return Value

A character formed from two unsigned bytes beginning at startIndex.

Exceptions

Exception Type | Condition
ArgumentException | value is null.
ArgumentException | startIndex is a value that results in invalid access to the array.

See Also

BitConverter Class | BitConverter Members | System Namespace


BitConverter.ToDouble

Converts eight unsigned bytes beginning at the specified index in the specified array into a double-precision floating point number.

[Visual Basic]
Public Shared Function ToDouble( _
   ByVal value() As Byte, _
   ByVal startIndex As Integer _
) As Double
[C#]
public static double ToDouble(
   byte[] value,
   int startIndex
);
[C++]
public: static double ToDouble(
   unsigned char* value[],
   int startIndex
);
[JScript]
public static function ToDouble(
   value : Byte[],
   startIndex : int
) : double;

Parameters

value
An array of unsigned bytes.
startIndex
A position within the value at which to begin.

Return Value

Returns a double precision floating-point numberformed from eight unsigned bytes beginning at startIndex.

Exceptions

Exception Type | Condition
ArgumentException | value is null.
ArgumentException | startIndex is a value that results in invalid access to the array.

See Also

BitConverter Class | BitConverter Members | System Namespace


BitConverter.ToInt16

Converts two unsigned bytes beginning at the specified index in the specified array into a 16-bit signed integer value.

[Visual Basic]
Public Shared Function ToInt16( _
   ByVal value() As Byte, _
   ByVal startIndex As Integer _
) As Short
[C#]
public static short ToInt16(
   byte[] value,
   int startIndex
);
[C++]
public: static short ToInt16(
   unsigned char* value[],
   int startIndex
);
[JScript]
public static function ToInt16(
   value : Byte[],
   startIndex : int
) : Int16;

Parameters

value
An array of unsigned bytes.
startIndex
A position within value at which to begin.

Return Value

Returns a 16-bit signed integer formed from two unsigned bytes beginning at startIndex.

Exceptions

Exception Type | Condition
ArgumentException | value is null.
ArgumentException | startIndex is a value that results in invalid access to the array.

See Also

BitConverter Class | BitConverter Members | System Namespace


BitConverter.ToInt32

Converts four bytes beginning at the specified index in the specified array to a 32-bit signed integer value.

[Visual Basic]
Public Shared Function ToInt32( _
   ByVal value() As Byte, _
   ByVal startIndex As Integer _
) As Integer
[C#]
public static int ToInt32(
   byte[] value,
   int startIndex
);
[C++]
public: static int ToInt32(
   unsigned char* value[],
   int startIndex
);
[JScript]
public static function ToInt32(
   value : Byte[],
   startIndex : int
) : int;

Parameters

value
An array of unsigned bytes.
startIndex
The position within value at which to begin.

Return Value

Returns a 32-bit signed integer formed from four unsigned bytes beginning at startIndex.

Exceptions

Exception Type | Condition
ArgumentException | value is null.
ArgumentException | startIndex is a value that results in invalid access to the array.

See Also

BitConverter Class | BitConverter Members | System Namespace


BitConverter.ToInt64

Converts eight bytes beginning at the specified index in the specified array into a 64-bit signed integer value.

[Visual Basic]
Public Shared Function ToInt64( _
   ByVal value() As Byte, _
   ByVal startIndex As Integer _
) As Long
[C#]
public static long ToInt64(
   byte[] value,
   int startIndex
);
[C++]
public: static __int64 ToInt64(
   unsigned char* value[],
   int startIndex
);
[JScript]
public static function ToInt64(
   value : Byte[],
   startIndex : int
) : long;

Parameters

value
An array of unsigned bytes.
startIndex
The position within value at which to begin.

Return Value

A 64-bit signed integer formed from eight unsigned bytes beginning at startIndex.

Exceptions

Exception Type | Condition
ArgumentException | value is null.
ArgumentException | startIndex is a value that results in invalid access to the array.

See Also

BitConverter Class | BitConverter Members | System Namespace


BitConverter.ToSingle

Converts four bytes beginning at the specified index in the specified array into a single-precision floating point number.

[Visual Basic]
Public Shared Function ToSingle( _
   ByVal value() As Byte, _
   ByVal startIndex As Integer _
) As Single
[C#]
public static float ToSingle(
   byte[] value,
   int startIndex
);
[C++]
public: static float ToSingle(
   unsigned char* value[],
   int startIndex
);
[JScript]
public static function ToSingle(
   value : Byte[],
   startIndex : int
) : float;

Parameters

value
An array of unsigned bytes.
startIndex
A position within the value at which to begin.

Return Value

A single-precision floating point number formed from four unsigned bytes beginning at startIndex.

Exceptions

Exception Type | Condition
ArgumentException | value is null.
ArgumentException | startIndex is a value that results in invalid access to the array.

See Also

BitConverter Class | BitConverter Members | System Namespace


BitConverter.ToString

[To be supplied.]

Overload List

Converts a region of an array of unsigned bytes into a string.

[Visual Basic] Overloads Public Shared Function ToString(Byte(), Integer) As String
[C#] public static string ToString(byte[], int);
[C++] public: static String* ToString(unsigned char*[], int);
[JScript] public static function ToString(Byte[], int) : String;

Converts an array of unsigned bytes into a string.

[Visual Basic] Overloads Public Shared Function ToString(Byte()) As String
[C#] public static string ToString(byte[]);
[C++] public: static String* ToString(unsigned char*[]);
[JScript] public static function ToString(Byte[]) : String;

Converts a specified number of elements of an array of unsigned bytes into a string, starting at a specified location.

[Visual Basic] Overloads Public Shared Function ToString(Byte(), Integer, Integer) As String
[C#] public static string ToString(byte[], int, int);
[C++] public: static String* ToString(unsigned char*[], int, int);
[JScript] public static function ToString(Byte[], int, int) : String;

See Also

BitConverter Class | BitConverter Members | System Namespace


BitConverter.ToString (Byte[], Int32)

Converts a region of an array of unsigned bytes into a string.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value() As Byte, _
   ByVal startIndex As Integer _
) As String
[C#]
public static string ToString(
   byte[] value,
   int startIndex
);
[C++]
public: static String* ToString(
   unsigned char* value[],
   int startIndex
);
[JScript]
public static function ToString(
   value : Byte[],
   startIndex : int
) : String;

Parameters

value
An array of unsigned bytes.
startIndex
The index in value at which to begin.

Return Value

A list of hexadecimal pairs representing the corresponding entries in value beginning at startIndex. The hexadecimal pairs are separated by hyphens (for example, "7F-2C-4A").

Exceptions

Exception Type | Condition
ArgumentException | value is a null reference (in Visual Basic Nothing).
ArgumentException | startIndex is less than zero.

See Also

BitConverter Class | BitConverter Members | System Namespace | BitConverter.ToString Overload List


BitConverter.ToString (Byte[])

Converts an array of unsigned bytes into a string.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value() As Byte _
) As String
[C#]
public static string ToString(
   byte[] value
);
[C++]
public: static String* ToString(
   unsigned char* value[]
);
[JScript]
public static function ToString(
   value : Byte[]
) : String;

Parameters

value
An array of unsigned bytes.

Return Value

A list of hexadecimal pairs representing the corresponding entries of value. The hexadecimal pairs are separated by hyphens (for example, "7F-2C-4A").

Exceptions

Exception Type | Condition
ArgumentException | if value is a null reference (in Visual Basic Nothing).

See Also

BitConverter Class | BitConverter Members | System Namespace | BitConverter.ToString Overload List


BitConverter.ToString (Byte[], Int32, Int32)

Converts a specified number of elements of an array of unsigned bytes into a string, starting at a specified location.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value() As Byte, _
   ByVal startIndex As Integer, _
   ByVal length As Integer _
) As String
[C#]
public static string ToString(
   byte[] value,
   int startIndex,
   int length
);
[C++]
public: static String* ToString(
   unsigned char* value[],
   int startIndex,
   int length
);
[JScript]
public static function ToString(
   value : Byte[],
   startIndex : int,
   length : int
) : String;

Parameters

value
An array of unsigned bytes.
startIndex
The index in the value at which to begin.
length
The number of unsigned bytes to be converted.

Return Value

A list of hexadecimal pairs representing the corresponding entries in value beginning at startIndex and ending at startIndex + length - 1. The hexadecimal pairs are separated by hyphens (for example, "7F-2C-4A").

Exceptions

Exception Type | Condition
ArgumentException | value is a null reference (in Visual Basic Nothing).
ArgumentException | startIndex is less than zero or greater than the length of value.
ArgumentException | Either length is less than zero, or startIndex + length is greater than the length of value

See Also

BitConverter Class | BitConverter Members | System Namespace | BitConverter.ToString Overload List


BitConverter.ToUInt16

Converts an array of bytes into a 16-bit unsigned integer.

[Visual Basic]
Public Shared Function ToUInt16( _
   ByVal value() As Byte, _
   ByVal startIndex As Integer _
) As UInt16
[C#]
public static ushort ToUInt16(
   byte[] value,
   int startIndex
);
[C++]
public: static unsigned short ToUInt16(
   unsigned char* value[],
   int startIndex
);
[JScript]
public static function ToUInt16(
   value : Byte[],
   startIndex : int
) : UInt16;

Parameters

value
The array of bytes.
startIndex
The position within value at which to begin.

Return Value

A 16-bit unsigned integer formed by the two bytes beginning at startIndex.

Exceptions

Exception Type | Condition
ArgumentNullException | if value is null.
ArgumentOutOfRangeException | if startIndex is less than zero or greater than the length of value-2.

See Also

BitConverter Class | BitConverter Members | System Namespace


BitConverter.ToUInt32

Converts an array of bytes into a 32-bit unsigned integer.

[Visual Basic]
Public Shared Function ToUInt32( _
   ByVal value() As Byte, _
   ByVal startIndex As Integer _
) As UInt32
[C#]
public static uint ToUInt32(
   byte[] value,
   int startIndex
);
[C++]
public: static unsigned int ToUInt32(
   unsigned char* value[],
   int startIndex
);
[JScript]
public static function ToUInt32(
   value : Byte[],
   startIndex : int
) : UInt32;

Parameters

value
An array of unsigned bytes.
startIndex
The position within value at which to begin.

Return Value

A 32-bit unsigned integer formed by the four bytes beginning at startIndex.

Exceptions

Exception Type | Condition
ArgumentNullException | if value is null.
ArgumentOutOfRangeException | if startIndex is less than zero or greater than the length of value-4.

See Also

BitConverter Class | BitConverter Members | System Namespace


BitConverter.ToUInt64

Converts an array of bytes into a 64-bit unsigned integer.

[Visual Basic]
Public Shared Function ToUInt64( _
   ByVal value() As Byte, _
   ByVal startIndex As Integer _
) As UInt64
[C#]
public static ulong ToUInt64(
   byte[] value,
   int startIndex
);
[C++]
public: static unsigned __int64 ToUInt64(
   unsigned char* value[],
   int startIndex
);
[JScript]
public static function ToUInt64(
   value : Byte[],
   startIndex : int
) : UInt64;

Parameters

value
An array of unsigned bytes.
startIndex
The position within value at which to begin.

Return Value

A 32-bit unsigned integer formed by the four bytes beginning at startIndex.

Exceptions

Exception Type | Condition
ArgumentNullException | if value is null.
ArgumentOutOfRangeException | if startIndex is less than zero or greater than the length of value-8.

See Also

BitConverter Class | BitConverter Members | System Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

BitConverter Fields

The fields of the BitConverter class are listed below. For a complete list of BitConverter class members, see the BitConverter Members topic.

Public:

IsLittleEndian This field indicates the "endianess" of the architecture.

See Also

BitConverter Class | System Namespace


BitConverter.IsLittleEndian

This field indicates the "endianess" of the architecture.

[Visual Basic]
Public Shared ReadOnly IsLittleEndian As Boolean
[C#]
public static readonly bool IsLittleEndian;
[C++]
public: static readonly bool IsLittleEndian;
[JScript]
public static var IsLittleEndian : Boolean;

Remarks

This value is true if the architecture is little-endian; false if it is big-endian.

Different machine architectures sometimes store data using different byte orders. Big-endian means the most significant byte is on the left end of a word. Little-endian means the most significant byte is on the right end of a word.

See Also

BitConverter Class | BitConverter Members | System Namespace


Boolean Structure

Represents the Boolean value, which is either true or false.

Object
ValueType
Boolean

[Visual Basic]
Public Structure Boolean
   Implements IComparable, IConvertible
[C#]
public struct Boolean : IComparable, IConvertible
[C++]
public __value struct Boolean : public IComparable, IConvertible

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

The Boolean class provides object representation for the primitive type Boolean.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

Boolean Members | System Namespace | Object


Boolean Members

Public:

Methods

CompareTo | Compares this instance of the object to another specified object.
Equals | Determines whether two Boolean objects are equal.
FromString | Converts the "true" and "false" strings to Boolean true and false values, respectively.
GetHashCode | Returns the hash code for this instance of Boolean.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | Retrieves the type code of an object.
Parse | Converts a String to a Boolean.
ToBoolean | Converts a string to a Boolean value.
ToByte | Converts this instance of a Boolean to an unsigned Byte.
ToChar | Converts this instance of a Boolean a Char.
ToDateTime | Converts this instance of a Boolean to a DateTime object.
ToDecimal | Converts this instance of a Boolean to a Decimal format.
ToDouble | Converts this instance of a Boolean as a Double.
ToInt16 | Converts this instance of a Boolean to an Int16.
ToInt32 | Converts this instance of a Boolean value to an Int32.
ToInt64 | Converts this instance of a Boolean to an Int64.
ToSByte | Converts this instance of a Boolean to an SByte.
ToSingle | Converts a Boolean to a Single.
ToString | Overloaded. Converts this instance of Boolean to a String.
ToType | Retrieves the Type for a specified Object.
ToUInt16 | Converts a Boolean to a UInt16.
ToUInt32 | Converts a Boolean to a UInt32.
ToUInt64 | Converts a Boolean to a UInt64.

Fields

Empty | Represents the constant that is the Empty string.
False | Represents the constant that is a false Boolean value.
FalseString | Represents the constant that is the false string.
True | Represents the constant that is a true Boolean value.
TrueString | Represents the constant that is a true string.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Boolean Structure | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Boolean Methods

The methods of the Boolean structure are listed below. For a complete list of Boolean structure members, see the Boolean Members topic.

Public:

CompareTo | Compares this instance of the object to another specified object.
Equals | Determines whether two Boolean objects are equal.
FromString | Converts the "true" and "false" strings to Boolean true and false values, respectively.
GetHashCode | Returns the hash code for this instance of Boolean.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | Retrieves the type code of an object.
Parse | Converts a String to a Boolean.
ToBoolean | Converts a string to a Boolean value.
ToByte | Converts this instance of a Boolean to an unsigned Byte.
ToChar | Converts this instance of a Boolean a Char.
ToDateTime | Converts this instance of a Boolean to a DateTime object.
ToDecimal | Converts this instance of a Boolean to a Decimal format.
ToDouble | Converts this instance of a Boolean as a Double.
ToInt16 | Converts this instance of a Boolean to an Int16.
ToInt32 | Converts this instance of a Boolean value to an Int32.
ToInt64 | Converts this instance of a Boolean to an Int64.
ToSByte | Converts this instance of a Boolean to an SByte.
ToSingle | Converts a Boolean to a Single.
ToString | Overloaded. Converts this instance of Boolean to a String.
ToType | Retrieves the Type for a specified Object.
ToUInt16 | Converts a Boolean to a UInt16.
ToUInt32 | Converts a Boolean to a UInt32.
ToUInt64 | Converts a Boolean to a UInt64.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Boolean Structure | System Namespace


Boolean.CompareTo

Compares this instance of the object to another specified object.

[Visual Basic]
Overridable Public Function CompareTo( _
   ByVal obj As Object _
) As Integer
[C#]
public virtual int CompareTo(
   object obj
);
[C++]
public: virtual int CompareTo(
   Object* obj
);
[JScript]
public function CompareTo(
   obj : Object
) : int;

Parameters

obj
An object to compare with this instance.

Return Value

Value | Condition
A negative integer | If this instance is false and the object is true.
Zero | If this instance and the object have the same value.
A positive integer | If this instance is true and the object is false.
A positive integer | If the object is null. This is a special case.

Exceptions

Exception Type | Condition
ArgumentException | If the object is not a Boolean and is not null.

Remarks

The CompareTo method compares this object to another object and returns an integer that indicates the relationship. For Booleans, false sorts before true.

When comparing two Boolean values, false is considered to be less than true. As a special case, a null reference is considered less than any instance.

The object parameter must be either a Boolean type or a null reference.

See Also

Boolean Structure | Boolean Members | System Namespace | Object


Boolean.Equals

Determines whether two Boolean objects are equal.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The object to compare with this instance.

Return Value

true if the object is a Boolean with the same value as this instance, otherwise false.

Remarks

Overrides Equals.

See Also

Boolean Structure | Boolean Members | System Namespace | Object


Boolean.FromString

Converts the "true" and "false" strings to Boolean true and false values, respectively.

[Visual Basic]
Public Shared Function FromString( _
   ByVal value As String _
) As Boolean
[C#]
public static bool FromString(
   string value
);
[C++]
public: static bool FromString(
   String* value
);
[JScript]
public static function FromString(
   value : String
) : Boolean;

Parameters

value
A string to be converted.

Return Value

A true or false Boolean value.

Exceptions

Exception Type | Condition
ArgumentException | If the string is null.
FormatException | If the string does not match.

Remarks

The FromString method provides a means of changing true and false strings to Boolean values.

The string parameter must provide a case-insensitive match with either "true" or "false". Leading and trailing white space is allowed and ignored.

The return value is a true Boolean value if the value is a case-insensitive match for "true", or a "false" Boolean value if it is a case-insensitive match for "false".

If the return valuedoes not match "true" or "false", then an exception is thrown. It will ignore the case of the text, as well as leading or trailing white space.

See Also

Boolean Structure | Boolean Members | System Namespace


Boolean.GetHashCode

Returns the hash code for this instance of Boolean.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

true if the value of this instance is true, otherwise false.

Remarks

The GetHashCode method is overridden by the Value method.

See Also

Boolean Structure | Boolean Members | System Namespace | True | False


Boolean.GetTypeCode

Retrieves the type code of an object.

[Visual Basic]
Overridable Public Function GetTypeCode() As TypeCode
[C#]
public virtual TypeCode GetTypeCode();
[C++]
public: virtual TypeCode GetTypeCode();
[JScript]
public function GetTypeCode() : TypeCode;

Return Value

A type code.

Remarks

The GetTypeCode method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See the TypeCode enumeration for more information about type codes.)

This method corresponds to GetTypeCode.

See Also

Boolean Structure | Boolean Members | System Namespace | Value


Boolean.Parse

Converts a String to a Boolean.

[Visual Basic]
Public Shared Function Parse( _
   ByVal value As String _
) As Boolean
[C#]
public static bool Parse(
   string value
);
[C++]
public: static bool Parse(
   String* value
);
[JScript]
public static function Parse(
   value : String
) : Boolean;

Parameters

value
The string to be converted.

Return Value

A true or false Boolean value.

Exceptions

Exception Type | Condition
ArgumentException | If the string is null.
FormatException | If the string does not provide a match as described.

Remarks

The Parse method provides a means of converting (parsing) a string into a Boolean.

The return value is true if the string is a case-insensitive match for "true", or false if it is a case-insensitive match for "false". Leading and trailing white space is allowed.

See Also

Boolean Structure | Boolean Members | System Namespace


Boolean.ToBoolean

Converts a string to a Boolean value.

[Visual Basic]
Overridable Public Function ToBoolean() As Boolean
[C#]
public virtual bool ToBoolean();
[C++]
public: virtual bool ToBoolean();
[JScript]
public function ToBoolean() : Boolean;

Return Value

false if the string is zero, otherwise true.

Remarks

The ToBoolean method converts the "true" or "false" Boolean values to the Boolean values of true and false, respectively.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See the TypeCode enumeration for more information about type codes.)

See Also

Boolean Structure | Boolean Members | System Namespace


Boolean.ToByte

Converts this instance of a Boolean to an unsigned Byte.

[Visual Basic]
Overridable Public Function ToByte() As Byte
[C#]
public virtual byte ToByte();
[C++]
public: virtual unsigned char ToByte();
[JScript]
public function ToByte() : Byte;

Return Value

true if it is a byte, otherwise false.

Remarks

The ToByte method returns an 8-bit unsigned Byte whose value is true or false, depending on the value to be converted.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See the TypeCode enumeration for more information about type codes, Convert, and ToByte.)

See Also

Boolean Structure | Boolean Members | System Namespace


Boolean.ToChar

Converts this instance of a Boolean a Char.

[Visual Basic]
Overridable Public Function ToChar() As Char
[C#]
public virtual char ToChar();
[C++]
public: virtual __wchar_t ToChar();
[JScript]
public function ToChar() : Char;

Return Value

A character.

Exceptions

Exception Type | Condition
InvalidCastException | If it doesn't return a character.

Remarks

The ToChar method returns a character value.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See the TypeCode enumeration for more information about type codes, Convert, and ToChar.)

See Also

Boolean Structure | Boolean Members | System Namespace


Boolean.ToDateTime

Converts this instance of a Boolean to a DateTime object.

[Visual Basic]
Overridable Public Function ToDateTime() As DateTime
[C#]
public virtual DateTime ToDateTime();
[C++]
public: virtual DateTime ToDateTime();
[JScript]
public function ToDateTime() : DateTime;

Return Value

A DateTime.

Exceptions

Exception Type | Condition
InvalidCastException | If it doesn't return a DateTime.

Remarks

The ToDateTime method returns a DateTime.

See Also

Boolean Structure | Boolean Members | System Namespace | Convert


Boolean.ToDecimal

Converts this instance of a Boolean to a Decimal format.

[Visual Basic]
Overridable Public Function ToDecimal() As Decimal
[C#]
public virtual Decimal ToDecimal();
[C++]
public: virtual Decimal ToDecimal();
[JScript]
public function ToDecimal() : Decimal;

Return Value

A decimal as a Boolean

Exceptions

Exception Type | Condition
InvalidCastException | If it doesn't return a decimal.

Remarks

The ToDecimal method returns a decimal.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See the TypeCode enumeration for more information about type codes and ToDecimal.)

See Also

Boolean Structure | Boolean Members | System Namespace | Convert


Boolean.ToDouble

Converts this instance of a Boolean as a Double.

[Visual Basic]
Overridable Public Function ToDouble() As Double
[C#]
public virtual double ToDouble();
[C++]
public: virtual double ToDouble();
[JScript]
public function ToDouble() : double;

Return Value

A double as a Boolean.

Exceptions

Exception Type | Condition
InvalidCastException | If it doesn't return a double.

Remarks

The ToBoolean method returns the specified parameter as an 8-byte double precision floating-point number.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See the TypeCode enumeration for more information about type codes and ToBoolean.)

See Also

Boolean Structure | Boolean Members | System Namespace | Convert


Boolean.ToInt16

Converts this instance of a Boolean to an Int16.

[Visual Basic]
Overridable Public Function ToInt16() As Short
[C#]
public virtual short ToInt16();
[C++]
public: virtual short ToInt16();
[JScript]
public function ToInt16() : Int16;

Return Value

An Int16 as a Boolean.

Remarks

The ToInt16 method returns a short.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See the TypeCode enumeration for more information about type codes, Convert, and ToInt16.)

See Also

Boolean Structure | Boolean Members | System Namespace


Boolean.ToInt32

Converts this instance of a Boolean value to an Int32.

[Visual Basic]
Overridable Public Function ToInt32() As Integer
[C#]
public virtual int ToInt32();
[C++]
public: virtual int ToInt32();
[JScript]
public function ToInt32() : int;

Return Value

A value as an Int32.

Remarks

The ToInt32 method returns an int. It returns a 32-bit, 4-byte signed integer with the converted number.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See the TypeCode enumeration for more information about type codes, Convert, and ToInt32.)

See Also

Boolean Structure | Boolean Members | System Namespace


Boolean.ToInt64

Converts this instance of a Boolean to an Int64.

[Visual Basic]
Overridable Public Function ToInt64() As Long
[C#]
public virtual long ToInt64();
[C++]
public: virtual __int64 ToInt64();
[JScript]
public function ToInt64() : long;

Return Value

An Int64 value.

Remarks

The ToInt64 method returns a long. It returns a 64-bit, 8-byte signed integer with the converted number.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See the TypeCode enumeration for more information about type codes, Convert, and ToInt64.)

See Also

Boolean Structure | Boolean Members | System Namespace


Boolean.ToSByte

Converts this instance of a Boolean to an SByte.

[Visual Basic]
Overridable Public Function ToSByte() As SByte
[C#]
public virtual sbyte ToSByte();
[C++]
public: virtual char ToSByte();
[JScript]
public function ToSByte() : SByte;

Return Value

An SByte value.

Remarks

The ToSByte method returns an unsigned byte.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See the TypeCode enumeration for more information about type codes, Convert, and ToSByte.)

See Also

Boolean Structure | Boolean Members | System Namespace


Boolean.ToSingle

Converts a Boolean to a Single.

[Visual Basic]
Overridable Public Function ToSingle() As Single
[C#]
public virtual float ToSingle();
[C++]
public: virtual float ToSingle();
[JScript]
public function ToSingle() : float;

Return Value

A float value

Exceptions

Exception Type | Condition
InvalidCastException | If it doesn't return a float.

Remarks

The ToSingle method returns the specified parameter as a float number.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See the TypeCode enumeration for more information about type codes and Single.)

See Also

Boolean Structure | Boolean Members | System Namespace | Convert


Boolean.ToString

Converts this instance of Boolean to a String.

Overload List

Converts a specified Boolean to a String.

[Visual Basic] Overloads Public Shared Function ToString(Boolean) As String
[C#] public static string ToString(bool);
[C++] public: static String* ToString(bool);
[JScript] public static function ToString(Boolean) : String;

Converts this instance of Boolean to a String.

[Visual Basic] Overloads Overrides Public Function ToString() As String
[C#] public override string ToString();
[C++] public: override String* ToString();
[JScript] public override function ToString() : String;

See Also

Boolean Structure | Boolean Members | System Namespace


Boolean.ToString (Boolean)

Converts a specified Boolean to a String.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As Boolean _
) As String
[C#]
public static string ToString(
   bool value
);
[C++]
public: static String* ToString(
   bool value
);
[JScript]
public static function ToString(
   value : Boolean
) : String;

Parameters

value
A Boolean value to be converted.

Return Value

The string representation of a specified Boolean value.

Remarks

The ToString method converts a Boolean value of this instance to a string and returns the Boolean value for this instance of either FalseString or TrueString.

See Also

Boolean Structure | Boolean Members | System Namespace | Boolean.ToString Overload List | String


Boolean.ToString ()

Converts this instance of Boolean to a String.

[Visual Basic]
Overloads Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

The value of this instance is returned, either FalseString or TrueString.

Remarks

The ToString method converts the Boolean value of this instance to a string and returns the Boolean value of this instance. ToString will override ToString.

See Also

Boolean Structure | Boolean Members | System Namespace | Boolean.ToString Overload List | String


Boolean.ToType

Retrieves the Type for a specified Object.

[Visual Basic]
Overridable Public Function ToType( _
   ByVal type As Type _
) As Object
[C#]
public virtual object ToType(
   Type type
);
[C++]
public: virtual Object* ToType(
   Type* type
);
[JScript]
public function ToType(
   type : Type
) : Object;

Parameters

type
The type.

Return Value

The type of the specified object.

Exceptions

Exception Type | Condition
InvalidCastException | If it doesn't return a type.

Remarks

The ToType method allows a means of reaching the Type class, which provides the functionality of several different services of the runtime, such as accessing the metadata and the System.Reflection. (For information, see System.Object.ToType and DefaultToType).

See Also

Boolean Structure | Boolean Members | System Namespace | IConvertible | Convert


Boolean.ToUInt16

Converts a Boolean to a UInt16.

[Visual Basic]
Overridable Public Function ToUInt16() As UInt16
[C#]
public virtual ushort ToUInt16();
[C++]
public: virtual unsigned short ToUInt16();
[JScript]
public function ToUInt16() : UInt16;

Return Value

A number as a UInt16.

Exceptions

Exception Type | Condition
InvalidCastException | If it doesn't return a UInt16.

Remarks

The ToUInt16 method converts a Boolean value into a UInt16 and returns the Boolean value for this instance. True is converted to one, and false is converted to zero (see ToUInt16 for more information).

See Also

Boolean Structure | Boolean Members | System Namespace | Convert


Boolean.ToUInt32

Converts a Boolean to a UInt32.

[Visual Basic]
Overridable Public Function ToUInt32() As UInt32
[C#]
public virtual uint ToUInt32();
[C++]
public: virtual unsigned int ToUInt32();
[JScript]
public function ToUInt32() : UInt32;

Return Value

A number as a UInt32.

Exceptions

Exception Type | Condition
InvalidCastException | If it doesn't return a UInt32.

Remarks

The ToUInt32 method converts a Boolean value into a UInt32 and returns the Boolean value for this instance. True is converted to one, and false is converted to zero (see ToUInt32 for more information).

See Also

Boolean Structure | Boolean Members | System Namespace | Convert


Boolean.ToUInt64

Converts a Boolean to a UInt64.

[Visual Basic]
Overridable Public Function ToUInt64() As UInt64
[C#]
public virtual ulong ToUInt64();
[C++]
public: virtual unsigned __int64 ToUInt64();
[JScript]
public function ToUInt64() : UInt64;

Return Value

A number as a UInt64.

Exceptions

Exception Type | Condition
InvalidCastException | If it doesn't return a UInt64.

Remarks

The ToUInt64 method converts a Boolean value into a UInt64 and returns the Boolean value for this instance. True is converted to one, and false is converted to zero (see ToUInt64 for more information).

See Also

Boolean Structure | Boolean Members | System Namespace | Convert


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Boolean Fields

The fields of the Boolean structure are listed below. For a complete list of Boolean structure members, see the Boolean Members topic.

Public:

Empty | Represents the constant that is the Empty string.
False | Represents the constant that is a false Boolean value.
FalseString | Represents the constant that is the false string.
True | Represents the constant that is a true Boolean value.
TrueString | Represents the constant that is a true string.

See Also

Boolean Structure | System Namespace


Boolean.Empty

Represents the constant that is the Empty string.

[Visual Basic]
Public Const Empty As Boolean
[C#]
public const bool Empty;
[C++]
public: const bool Empty;
[JScript]
public var Empty : Boolean;

Remarks

Empty is the constant equal to the string representation of the Boolean class value that is false. False is the default empty value.

See Also

Boolean Structure | Boolean Members | System Namespace


Boolean.False

Represents the constant that is a false Boolean value.

[Visual Basic]
Public Const False As Integer
[C#]
public const int False;
[C++]
public: const int False;
[JScript]
public var False : int;

Remarks

The False constructor is equal to the Boolean class value that is zero.

See Also

Boolean Structure | Boolean Members | System Namespace


Boolean.FalseString

Represents the constant that is the false string.

[Visual Basic]
Public Shared ReadOnly FalseString As String
[C#]
public static readonly string FalseString;
[C++]
public: static readonly String* FalseString;
[JScript]
public static var FalseString : String;

Remarks

The FalseString field is equal to the string representation of the Boolean class value that is false.

See Also

Boolean Structure | Boolean Members | System Namespace


Boolean.True

Represents the constant that is a true Boolean value.

[Visual Basic]
Public Const True As Integer
[C#]
public const int True;
[C++]
public: const int True;
[JScript]
public var True : int;

Remarks

The True constructor is equal to the Boolean class value that is one.

See Also

Boolean Structure | Boolean Members | System Namespace


Boolean.TrueString

Represents the constant that is a true string.

[Visual Basic]
Public Shared ReadOnly TrueString As String
[C#]
public static readonly string TrueString;
[C++]
public: static readonly String* TrueString;
[JScript]
public static var TrueString : String;

Remarks

The TrueString field is equal to the string representation of the Boolean class value that is true.

See Also

Boolean Structure | Boolean Members | System Namespace | String


Buffer Class

Provides access to unmanaged memory.

Object
Buffer

[Visual Basic]
NotInheritable Public Class Buffer
[C#]
public sealed class Buffer
[C++]
public __gc __sealed class Buffer
[JScript]
public class Buffer

Remarks

The Buffer class does not require serialization. It copies from one primitive array to another primitive array without respecting types. This calls memove internally.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

Buffer Members | System Namespace


Buffer Members

Public:

Methods

BlockCopy | Copies the bytes from one object to another.
ByteLength | Returns the total number of bytes in this array.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetByte | Retrieves the byte at the specified location in the array.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SetByte | Retrieves the byte at the specified location in the array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Buffer Class | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Buffer Methods

The methods of the Buffer class are listed below. For a complete list of Buffer class members, see the Buffer Members topic.

Public:

BlockCopy | Copies the bytes from one object to another.
ByteLength | Returns the total number of bytes in this array.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetByte | Retrieves the byte at the specified location in the array.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SetByte | Retrieves the byte at the specified location in the array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Buffer Class | System Namespace


Buffer.BlockCopy

Copies the bytes from one object to another.

[Visual Basic]
Public Shared Sub BlockCopy( _
   ByVal src As Array, _
   ByVal srcOffset As Integer, _
   ByVal dst As Array, _
   ByVal dstOffset As Integer, _
   ByVal count As Integer _
)
[C#]
public static void BlockCopy(
   Array src,
   int srcOffset,
   Array dst,
   int dstOffset,
   int count
);
[C++]
public: static void BlockCopy(
   Array* src,
   int srcOffset,
   Array* dst,
   int dstOffset,
   int count
);
[JScript]
public static function BlockCopy(
   src : Array,
   srcOffset : int,
   dst : Array,
   dstOffset : int,
   count : int
);

Parameters

src
The source buffer.
srcOffset
The byte offset in src where to begin reading.
dst
The destination buffer.
dstOffset
The byte offset in dst where to begin writing.
count
The number of bytes to be copied.

Remarks

The bytes in src beginning at the byte offset given by srcOffset are copied to dst beginning at the byte offset given by dstOffset.

See Also

Buffer Class | Buffer Members | System Namespace


Buffer.ByteLength

Returns the total number of bytes in this array.

[Visual Basic]
Public Shared Function ByteLength( _
   ByVal array As Array _
) As Integer
[C#]
public static int ByteLength(
   Array array
);
[C++]
public: static int ByteLength(
   Array* array
);
[JScript]
public static function ByteLength(
   array : Array
) : int;

Parameters

array
The array where the bytes will be counted.

Return Value

The number of bytes in the array.

Exceptions

Exception Type | Condition
ArgumentException | If the array is not a primitive.
ArgumentNullException | If the array is null.

Remarks

The ByteLength method gets a particular byte out of an array. The array must be an array of primitives. It essentially does the following:

return array.length * sizeof(array.UnderlyingElementType)

Example [C#]

[C#]

int [] arr = new int [5] = {0, 1, 2, 3, 4};
Assert (arr.ByteLength == 20);
for (int i = 0; i < arr.ByteLength; i++)
  {
  Console.Write (arr[i].GetByte(i));
  }
//this
will print:
//00000001000200030004

See Also

Buffer Class | Buffer Members | System Namespace


Buffer.GetByte

Retrieves the byte at the specified location in the array.

[Visual Basic]
Public Shared Function GetByte( _
   ByVal array As Array, _
   ByVal index As Integer _
) As Byte
[C#]
public static byte GetByte(
   Array array,
   int index
);
[C++]
public: static unsigned char GetByte(
   Array* array,
   int index
);
[JScript]
public static function GetByte(
   array : Array,
   index : int
) : Byte;

Parameters

array
The array that contains the bytes.
index
The location in array of the bytes to get.

Return Value

Returns the index byte in the array.

Exceptions

Exception Type | Condition
ArgumentException | If the array is not a primitive.
ArgumentNullException | If the array is null.
ArgumentOutOfRangeException | If the index is negative or greater than the array length.

Remarks

The GetByte method gets a particular byte out of the array. The array must be an array of primitives. This essentially does the following:

return ((byte*)array) + index

See Also

Buffer Class | Buffer Members | System Namespace


Buffer.SetByte

Retrieves the byte at the specified location in the array.

[Visual Basic]
Public Shared Sub SetByte( _
   ByVal array As Array, _
   ByVal index As Integer, _
   ByVal value As Byte _
)
[C#]
public static void SetByte(
   Array array,
   int index,
   byte value
);
[C++]
public: static void SetByte(
   Array* array,
   int index,
   unsigned char value
);
[JScript]
public static function SetByte(
   array : Array,
   index : int,
   value : Byte
);

Parameters

array
The array that contains the new value.
index
The location in the array to put the value.
value
The new value to assign.

Return Value

An array with the value added at the specified location.

Exceptions

Exception Type | Condition
ArgumentException | If the array is not a primitive.
ArgumentNullException | If the array is null.
ArgumentOutOfRangeException | If the index is negative or greater than the array length.

Remarks

The SetByte method sets a particular byte in an array. The array must be an array of primitives. This essentially does the following:

*(((byte*)array) + index) = value

See Also

Buffer Class | Buffer Members | System Namespace


Byte Structure

Represents an unsigned byte (1-byte uint) value.

Object
ValueType
Byte

[Visual Basic]
Public Structure Byte
   Implements IComparable, IFormattable, IConvertible
[C#]
public struct Byte : IComparable, IFormattable, IConvertible
[C++]
public __value struct Byte : public IComparable, IFormattable,
   IConvertible

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

The Byte value type can represent positive integers with two significant digits in the range 0 to positive 255, inclusive. This class extends the Value class and provides object representation for the byte primitive type.

See the SByte class for a representation of the signed bytes with a range of negative 127 through positive 127. The Byte class represents the unsigned bytes (ubytes) with a range of 0 through positive 255.

VJ has an ubyte that maps to Byte and a signed byte type that maps to SByte.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

Byte Members | System Namespace | IComparable


Byte Members

Public:

Methods

CompareTo | Compares this instance to the specified object.
Equals | Determines whether two Byte objects are equal.
Format | Overloaded. Converts a numeric value to a String.
FromString | Converts a String to an unsigned byte.
GetHashCode | Returns the hash code for this Byte.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | Returns the hash code for this instance of Byte.
Parse | Overloaded. Converts a String to a Byte.
ToBoolean | Converts a string to a Byte value.
ToByte | Converts a Byte to an unsigned byte.
ToChar | Converts a Byte to a character.
ToDateTime | Converts this instance of a Byte to a DateTime object.
ToDecimal | Converts this instance of a Byte to a Decimal format.
ToDouble | Converts this instance of a Byte as a Double.
ToInt16 | Converts this instance of a Byte to an Int16.
ToInt32 | Converts this instance of a Byte value to an Int32.
ToInt64 | Converts this instance of a Byte to an Int64.
ToSByte | Converts this instance of a Byte to an SByte.
ToSingle | Converts a Byte to a Single.
ToString | Overloaded. Converts this instance of Byte to a String.
ToType | Retrieves the Type for a specified Object.
ToUInt16 | Converts a Byte to a UInt16.
ToUInt32 | Converts a Byte to a UInt32.
ToUInt64 | Converts a Byte to a UInt64.

Fields

Empty | Represents the constant that is the empty Byte value.
MaxValue | Represents the largest possible Byte value.
MinValue | Represents the smallest possible Byte value.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Byte Structure | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Byte Methods

The methods of the Byte structure are listed below. For a complete list of Byte structure members, see the Byte Members topic.

Public:

CompareTo | Compares this instance to the specified object.
Equals | Determines whether two Byte objects are equal.
Format | Overloaded. Converts a numeric value to a String.
FromString | Converts a String to an unsigned byte.
GetHashCode | Returns the hash code for this Byte.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | Returns the hash code for this instance of Byte.
Parse | Overloaded. Converts a String to a Byte.
ToBoolean | Converts a string to a Byte value.
ToByte | Converts a Byte to an unsigned byte.
ToChar | Converts a Byte to a character.
ToDateTime | Converts this instance of a Byte to a DateTime object.
ToDecimal | Converts this instance of a Byte to a Decimal format.
ToDouble | Converts this instance of a Byte as a Double.
ToInt16 | Converts this instance of a Byte to an Int16.
ToInt32 | Converts this instance of a Byte value to an Int32.
ToInt64 | Converts this instance of a Byte to an Int64.
ToSByte | Converts this instance of a Byte to an SByte.
ToSingle | Converts a Byte to a Single.
ToString | Overloaded. Converts this instance of Byte to a String.
ToType | Retrieves the Type for a specified Object.
ToUInt16 | Converts a Byte to a UInt16.
ToUInt32 | Converts a Byte to a UInt32.
ToUInt64 | Converts a Byte to a UInt64.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Byte Structure | System Namespace


Byte.CompareTo

Compares this instance to the specified object.

[Visual Basic]
Overridable Public Function CompareTo( _
   ByVal value As Object _
) As Integer
[C#]
public virtual int CompareTo(
   object value
);
[C++]
public: virtual int CompareTo(
   Object* value
);
[JScript]
public function CompareTo(
   value : Object
) : int;

Parameters

value
An object to compare with this instance.

Return Value

Value | Description
A negative integer | If this instance is less than the object.
Zero | If this instance and the object are equal.
A positive integer | If this instance is greater than the object.
A positive integer | If the object is null. This is a special case

Exceptions

Exception Type | Condition
ArgumentException | if the object is a non-null reference that is not of type Byte.

Remarks

The CompareTo method compares two objects and returns an integer that indicates their relationship. Both objects must be either a Byte type or a null reference.

In comparing two Byte values, the canonical ordering is used. As a special case, regardless of its value, an instance is considered to be greater than a null reference.

The value parameter must be either a Byte type or a null reference.

See Also

Byte Structure | Byte Members | System Namespace


Byte.Equals

Determines whether two Byte objects are equal.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The object to compare with this instance.

Return Value

true if the object is a Byte that equals the value of this instance, otherwise false.

Remarks

Overrides Equals.

See Also

Byte Structure | Byte Members | System Namespace


Byte.Format

Converts a numeric value to a String.

Overload List

Converts the value of this instance to a String that uses a specified string and has the format provided by TBD.

[Visual Basic] Overloads Overridable Public Function Format(String, IServiceObjectProvider) As String
[C#] public virtual string Format(String, IServiceObjectProvider);
[C++] public: virtual String* Format(String*, IServiceObjectProvider);
[JScript] public function Format(String, IServiceObjectProvider) : String;

Converts a numeric value to a String that uses a specified string and format.

[Visual Basic] Overloads Public Shared Function Format(Byte, String, NumberFormatInfo) As String
[C#] public static string Format(byte, String, NumberFormatInfo);
[C++] public: static String* Format(unsigned char, String, NumberFormatInfo);
[JScript] public static function Format(Byte, String, NumberFormatInfo) : String;

Converts a numeric value to a String with a default format.

[Visual Basic] Overloads Public Shared Function Format(Byte, String) As String
[C#] public static string Format(byte, String);
[C++] public: static String* Format(unsigned char, String);
[JScript] public static function Format(Byte, String) : String;

See Also

Byte Structure | Byte Members | System Namespace


Byte.Format (String, IServiceObjectProvider)

Converts the value of this instance to a String that uses a specified string and has the format provided by TBD.

[Visual Basic]
Overloads Overridable Public Function Format( _
   ByVal format As String, _
   ByVal sp As IServiceObjectProvider _
) As String
[C#]
public virtual string Format(
   string format,
   IServiceObjectProvider sp
);
[C++]
public: virtual String* Format(
   String* format,
   IServiceObjectProvider* sp
);
[JScript]
public function Format(
   format : String,
   sp : IServiceObjectProvider
) : String;

Parameters

format
The format string.
sp
The TBD used to format the number.

Return Value

A String representation for the value of this instance in the format specified by format.

Remarks

NumberFormatInfo supplies information for the characters of monetary values to use for decimal and thousand separators, and for the spelling and placement of currency symbols. (For additional information on currency symbols and current cultures, see CultureInfo.)

If format is null or an empty string, the number is formatted as if the string general format ("G") were specified.

The sp parameter specifies the format provider from which the NumberFormatInfo instance will be obtained. If sp is null, the numeric format information is obtained from the current locale.

See Also

Byte Structure | Byte Members | System Namespace | Byte.Format Overload List


Byte.Format (Byte, String, NumberFormatInfo)

Converts a numeric value to a String that uses a specified string and format.

[Visual Basic]
Overloads Public Shared Function Format( _
   ByVal value As Byte, _
   ByVal format As String, _
   ByVal info As NumberFormatInfo _
) As String
[C#]
public static string Format(
   byte value,
   string format,
   NumberFormatInfo info
);
[C++]
public: static String* Format(
   unsigned char value,
   String* format,
   NumberFormatInfo* info
);
[JScript]
public static function Format(
   value : Byte,
   format : String,
   info : NumberFormatInfo
) : String;

Parameters

value
The value to be formatted.
format
The format string.
info
The NumberFormatInfo instance used to format the number.

Return Value

A String representation of the value in the format specified format.

Remarks

The NumberFormatInfo supplies information such as the characters to use for decimal and thousand separators, and the spelling and placement of currency symbols in monetary values. (For additional information on currency symbols and current cultures, see CultureInfo.)

If format is null or an empty string, then value is formatted as if the string general format ("G") were specified.

If info is null, the numeric format information is obtained from the current locale.

See Also

Byte Structure | Byte Members | System Namespace | Byte.Format Overload List


Byte.Format (Byte, String)

Converts a numeric value to a String with a default format.

[Visual Basic]
Overloads Public Shared Function Format( _
   ByVal value As Byte, _
   ByVal format As String _
) As String
[C#]
public static string Format(
   byte value,
   string format
);
[C++]
public: static String* Format(
   unsigned char value,
   String* format
);
[JScript]
public static function Format(
   value : Byte,
   format : String
) : String;

Parameters

value
The number to be formatted.
format
The format string.

Return Value

A String representation of the number in the format specified format.

Remarks

If format is null or an empty string, then the number is formatted as if the string general format ("G") were specified. The numeric format information is obtained from the current locale. (For addition information on current cultures, see CultureInfo.

See Also

Byte Structure | Byte Members | System Namespace | Byte.Format Overload List


Byte.FromString

Converts a String to an unsigned byte.

[Visual Basic]
Public Shared Function FromString( _
   ByVal s As String _
) As Byte
[C#]
public static byte FromString(
   string s
);
[C++]
public: static unsigned char FromString(
   String* s
);
[JScript]
public static function FromString(
   s : String
) : Byte;

Parameters

s
The string that contains a number to convert.

Return Value

The Byte value of the string.

Exceptions

Exception Type | Condition
ArgumentNullException | If the string is null.
FormatException | If the string does not contain a well-formed number.
OverflowException | If the string is less than 0 or greater than 255.

Remarks

The default (locale-neutral) of NumberFormatInfo is used. Use Parse and Format for locale-dependent strings. (In addition information on cultures and locale-neutral, see CultureInfo.)

The output from ToString should be consumable by FromString. Use Parse() and Format() for locale dependent strings.

See Also

Byte Structure | Byte Members | System Namespace


Byte.GetHashCode

Returns the hash code for this Byte.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

The hash code for this instance.

Remarks

The GetHashCode method returns the absolute value of the byte value of this instance. It overrides GetHashCode.

See Also

Byte Structure | Byte Members | System Namespace


Byte.GetTypeCode

Returns the hash code for this instance of Byte.

[Visual Basic]
Overridable Public Function GetTypeCode() As TypeCode
[C#]
public virtual TypeCode GetTypeCode();
[C++]
public: virtual TypeCode GetTypeCode();
[JScript]
public function GetTypeCode() : TypeCode;

Return Value

true if the value of this instance is true, otherwise false.

Remarks

The GetTypeCode method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See the TypeCode enumeration for more information about type codes.)

This method corresponds to GetType.

See Also

Byte Structure | Byte Members | System Namespace


Byte.Parse

Converts a String to a Byte.

Overload List

Converts a String to a Byte with a default format.

[Visual Basic] Overloads Public Shared Function Parse(String) As Byte
[C#] public static byte Parse(String);
[C++] public: static unsigned char Parse(String*);
[JScript] public static function Parse(String) : Byte;

Converts a string to an 8-bit unsigned integer with a specified style and format.

[Visual Basic] Overloads Public Shared Function Parse(String, NumberStyles, NumberFormatInfo) As Byte
[C#] public static byte Parse(String, NumberStyles, NumberFormatInfo);
[C++] public: static unsigned char Parse(String*, NumberStyles, NumberFormatInfo);
[JScript] public static function Parse(String, NumberStyles, NumberFormatInfo) : Byte;

Converts a String to a Byte with a specified style.

[Visual Basic] Overloads Public Shared Function Parse(String, NumberStyles) As Byte
[C#] public static byte Parse(String, NumberStyles);
[C++] public: static unsigned char Parse(String*, NumberStyles);
[JScript] public static function Parse(String, NumberStyles) : Byte;

See Also

Byte Structure | Byte Members | System Namespace


Byte.Parse (String)

Converts a String to a Byte with a default format.

[Visual Basic]
Overloads Public Shared Function Parse( _
   ByVal s As String _
) As Byte
[C#]
public static byte Parse(
   string s
);
[C++]
public: static unsigned char Parse(
   String* s
);
[JScript]
public static function Parse(
   s : String
) : Byte;

Parameters

s
The string to convert to a Byte.

Return Value

The Byte value of the string.

Exceptions

Exception Type | Condition
ArgumentNullException | If the string is null.
FormatException | If the string is contains a character other than 0 through 9.
FormatException | If the string represents a number that is less than MinValue or greater than MaxValue.

Remarks

The Parse method converts (parses) a string to a Byte.

In order for Parse to convert a String to a Byte, the string must consist of a sequence of digits ("0"- "9"). The leading and trailing white space characters are ignored.

See Also

Byte Structure | Byte Members | System Namespace | Byte.Parse Overload List


Byte.Parse (String, NumberStyles, NumberFormatInfo)

Converts a string to an 8-bit unsigned integer with a specified style and format.

[Visual Basic]
Overloads Public Shared Function Parse( _
   ByVal s As String, _
   ByVal style As NumberStyles, _
   ByVal info As NumberFormatInfo _
) As Byte
[C#]
public static byte Parse(
   string s,
   NumberStyles style,
   NumberFormatInfo info
);
[C++]
public: static unsigned char Parse(
   String* s,
   NumberStyles style,
   NumberFormatInfo* info
);
[JScript]
public static function Parse(
   s : String,
   style : NumberStyles,
   info : NumberFormatInfo
) : Byte;

Parameters

s
The String to be interpreted.
style
The permitted style of the numeric string.
info
The NumberFormatInfo instance used to format the string.

Return Value

Returns a Byte with the value represented by the string.

Exceptions

Exception Type | Condition
ArgumentException | If the style is not a valid combination of bit flags from the NumberStyles enumeration.
ArgumentNullException | If the string is null.
FormatException | If the string is not of the correct format.
FormatException | If the string represents a number that is less than MinValue or greater than MaxValue.

Remarks

Note that the Parse methods do not accept not a number (NaN) or positive or negative infinity.

The s parameter has been created by one of the Format methods using C, D, E, F, G, or N as the format specifier, it is guaranteed that s can be parsed when style is NumberStyles Enumeration.

The style parameter must be a combination of bit flags from the NumberStyles Enumeration, except for NumberStyles.All and NumberStyles.AllowDecimalPoint, which are not valid values for this argument.

The info parameter specifies the NumberFormatInfo instance used to format the string. If the info parameter is null, the numeric format information is obtained from the current locale.

See Also

Byte Structure | Byte Members | System Namespace | Byte.Parse Overload List


Byte.Parse (String, NumberStyles)

Converts a String to a Byte with a specified style.

[Visual Basic]
Overloads Public Shared Function Parse( _
   ByVal s As String, _
   ByVal style As NumberStyles _
) As Byte
[C#]
public static byte Parse(
   string s,
   NumberStyles style
);
[C++]
public: static unsigned char Parse(
   String* s,
   NumberStyles style
);
[JScript]
public static function Parse(
   s : String,
   style : NumberStyles
) : Byte;

Parameters

s
The String to be interpreted.
style
The permitted style of the numeric string.

Return Value

A Byte with the value represented by s.

Exceptions

Exception Type | Condition
ArgumentException | If the style is not a valid combination of bit flags from the NumberStyles enumeration.
ArgumentNullException | If the string is null.
FormatException | If the string is not of the correct format.
FormatException | If the string represents a number that is less than MinValue or greater than MaxValue.

Remarks

The numeric format information is obtained from the current locale. (For additional information about current locale or cultures, see CultureInfo.)

Note that the Parse methods do not accept not a number (NaN) or positive or negative infinity.

The s parameter has been created by one of the Format methods using C, D, E, F, G, or N as the format specified, it is guaranteed that s can be parsed when the style is NumberStyles Enumeration.

The style parameter must be a combination of bit flags from the NumberStyles Enumeration, except for NumberStyles.All and NumberStyles.AllowDecimalPoint, which are not valid values for this argument.

See Also

Byte Structure | Byte Members | System Namespace | Byte.Parse Overload List


Byte.ToBoolean

Converts a string to a Byte value.

[Visual Basic]
Overridable Public Function ToBoolean() As Boolean
[C#]
public virtual bool ToBoolean();
[C++]
public: virtual bool ToBoolean();
[JScript]
public function ToBoolean() : Boolean;

Return Value

false if the number to be converted is 0, otherwise true.

Remarks

The ToBoolean method converts the "true" or "false" Boolean values to the Boolean values of true and false.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Byte Structure | Byte Members | System Namespace


Byte.ToByte

Converts a Byte to an unsigned byte.

[Visual Basic]
Overridable Public Function ToByte() As Byte
[C#]
public virtual byte ToByte();
[C++]
public: virtual unsigned char ToByte();
[JScript]
public function ToByte() : Byte;

Return Value

The converted number as a Byte .

Remarks

The ToByte method converts the number to an unsigned byte value.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Byte Structure | Byte Members | System Namespace


Byte.ToChar

Converts a Byte to a character.

[Visual Basic]
Overridable Public Function ToChar() As Char
[C#]
public virtual char ToChar();
[C++]
public: virtual __wchar_t ToChar();
[JScript]
public function ToChar() : Char;

Return Value

The Byte value as a character.

Remarks

The ToChar method returns a character.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Byte Structure | Byte Members | System Namespace


Byte.ToDateTime

Converts this instance of a Byte to a DateTime object.

[Visual Basic]
Overridable Public Function ToDateTime() As DateTime
[C#]
public virtual DateTime ToDateTime();
[C++]
public: virtual DateTime ToDateTime();
[JScript]
public function ToDateTime() : DateTime;

Return Value

A DateTime.

Exceptions

Exception Type | Condition
InvalidCastException | is thrown if it doesn't return a DateTime.

Remarks

The ToDateTime method returns a DateTime.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Byte Structure | Byte Members | System Namespace


Byte.ToDecimal

Converts this instance of a Byte to a Decimal format.

[Visual Basic]
Overridable Public Function ToDecimal() As Decimal
[C#]
public virtual Decimal ToDecimal();
[C++]
public: virtual Decimal ToDecimal();
[JScript]
public function ToDecimal() : Decimal;

Return Value

A decimal as a byte

Exceptions

Exception Type | Condition
InvalidCastException | is thrown if it doesn't return a byte.

Remarks

The ToDecimal method returns a decimal.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Byte Structure | Byte Members | System Namespace


Byte.ToDouble

Converts this instance of a Byte as a Double.

[Visual Basic]
Overridable Public Function ToDouble() As Double
[C#]
public virtual double ToDouble();
[C++]
public: virtual double ToDouble();
[JScript]
public function ToDouble() : double;

Return Value

A double as a byte.

Exceptions

Exception Type | Condition
InvalidCastException | is thrown if it doesn't return a byte.

Remarks

The ToDouble method returns the specified parameter as an 8-byte double precision floating-point number.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Byte Structure | Byte Members | System Namespace


Byte.ToInt16

Converts this instance of a Byte to an Int16.

[Visual Basic]
Overridable Public Function ToInt16() As Short
[C#]
public virtual short ToInt16();
[C++]
public: virtual short ToInt16();
[JScript]
public function ToInt16() : Int16;

Return Value

An Int16 as a byte.

Remarks

The ToInt16 method returns a short.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Byte Structure | Byte Members | System Namespace


Byte.ToInt32

Converts this instance of a Byte value to an Int32.

[Visual Basic]
Overridable Public Function ToInt32() As Integer
[C#]
public virtual int ToInt32();
[C++]
public: virtual int ToInt32();
[JScript]
public function ToInt32() : int;

Return Value

A value as an Int32.

Remarks

The ToInt32 method returns an int. It returns a 32-bit, 4-byte signed integer with the converted number.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Byte Structure | Byte Members | System Namespace


Byte.ToInt64

Converts this instance of a Byte to an Int64.

[Visual Basic]
Overridable Public Function ToInt64() As Long
[C#]
public virtual long ToInt64();
[C++]
public: virtual __int64 ToInt64();
[JScript]
public function ToInt64() : long;

Return Value

An Int64 value.

Remarks

The ToInt64 method returns a long. It returns a 64-bit, 8-byte signed integer with the converted number.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Byte Structure | Byte Members | System Namespace


Byte.ToSByte

Converts this instance of a Byte to an SByte.

[Visual Basic]
Overridable Public Function ToSByte() As SByte
[C#]
public virtual sbyte ToSByte();
[C++]
public: virtual char ToSByte();
[JScript]
public function ToSByte() : SByte;

Return Value

An SByte value.

Remarks

The ToSByte method returns an unsigned byte.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Byte Structure | Byte Members | System Namespace


Byte.ToSingle

Converts a Byte to a Single.

[Visual Basic]
Overridable Public Function ToSingle() As Single
[C#]
public virtual float ToSingle();
[C++]
public: virtual float ToSingle();
[JScript]
public function ToSingle() : float;

Return Value

A float value

Exceptions

Exception Type | Condition
InvalidCastException | is thrown if it doesn't return a float.

Remarks

The ToSingle method returns the specified parameter as a float number.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Byte Structure | Byte Members | System Namespace


Byte.ToString

Converts this instance of Byte to a String.

Overload List

Converts a specified Byte to a String and formats without leading zeros.

[Visual Basic] Overloads Public Shared Function ToString(Byte) As String
[C#] public static string ToString(byte);
[C++] public: static String* ToString(unsigned char);
[JScript] public static function ToString(Byte) : String;

Converts this instance of Byte to a String with the default.

[Visual Basic] Overloads Overrides Public Function ToString() As String
[C#] public override string ToString();
[C++] public: override String* ToString();
[JScript] public override function ToString() : String;

See Also

Byte Structure | Byte Members | System Namespace


Byte.ToString (Byte)

Converts a specified Byte to a String and formats without leading zeros.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As Byte _
) As String
[C#]
public static string ToString(
   byte value
);
[C++]
public: static String* ToString(
   unsigned char value
);
[JScript]
public static function ToString(
   value : Byte
) : String;

Parameters

value
The unsigned byte to be provided a string representation.

Return Value

Returns a string representation of value in base-10 without leading zeros.

Remarks

The ToString mehtod converts a Byte to a string.

No leading zero characters ('0') are prepended to the returned string. The following characters are allowable digits: 0, 1, 2, 3, 4, 5, 6, 7, 8, and/or 9.

See Also

Byte Structure | Byte Members | System Namespace | Byte.ToString Overload List


Byte.ToString ()

Converts this instance of Byte to a String with the default.

[Visual Basic]
Overloads Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

Returns a string representation of the value of this instance in base-10 with no extra padding.

Remarks

The ToString() method provides a string representation for the value of this instance.

No leading zero characters ('0') are prefixed to the returned string and only the following characters are used: 0, 1, 2, 3, 4, 5, 6, 7, 8, and/or 9.

See Also

Byte Structure | Byte Members | System Namespace | Byte.ToString Overload List


Byte.ToType

Retrieves the Type for a specified Object.

[Visual Basic]
Overridable Public Function ToType( _
   ByVal type As Type _
) As Object
[C#]
public virtual object ToType(
   Type type
);
[C++]
public: virtual Object* ToType(
   Type* type
);
[JScript]
public function ToType(
   type : Type
) : Object;

Parameters

type
The type.

Return Value

The type of the specified object.

Exceptions

Exception Type | Condition
InvalidCastException | is thrown if it doesn't return a type.

Remarks

The ToType method allows a means of reaching the Type class, which provides the functionality of several different services of the runtime, such as accessing the metadata and reflection.

See Also

Byte Structure | Byte Members | System Namespace


Byte.ToUInt16

Converts a Byte to a UInt16.

[Visual Basic]
Overridable Public Function ToUInt16() As UInt16
[C#]
public virtual ushort ToUInt16();
[C++]
public: virtual unsigned short ToUInt16();
[JScript]
public function ToUInt16() : UInt16;

Return Value

A number as a UInt16.

Exceptions

Exception Type | Condition
InvalidCastException | is thrown if it doesn't return a UInt16.

Remarks

The ToUInt16 method converts a byte value into a UInt16 and returns it.

See Also

Byte Structure | Byte Members | System Namespace


Byte.ToUInt32

Converts a Byte to a UInt32.

[Visual Basic]
Overridable Public Function ToUInt32() As UInt32
[C#]
public virtual uint ToUInt32();
[C++]
public: virtual unsigned int ToUInt32();
[JScript]
public function ToUInt32() : UInt32;

Return Value

A number as a UInt32.

Exceptions

Exception Type | Condition
InvalidCastException | is thrown if it doesn't return a UInt32.

Remarks

The ToUInt32method converts a byte value into a UInt32 and returns it.

See Also

Byte Structure | Byte Members | System Namespace


Byte.ToUInt64

Converts a Byte to a UInt64.

[Visual Basic]
Overridable Public Function ToUInt64() As UInt64
[C#]
public virtual ulong ToUInt64();
[C++]
public: virtual unsigned __int64 ToUInt64();
[JScript]
public function ToUInt64() : UInt64;

Return Value

A number as a UInt64.

Exceptions

Exception Type | Condition
InvalidCastException | is thrown if it doesn't return a UInt64.

Remarks

The ToUInt64 method converts a Byte value into a UInt64 and returns it.

See Also

Byte Structure | Byte Members | System Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Byte Fields

The fields of the Byte structure are listed below. For a complete list of Byte structure members, see the Byte Members topic.

Public:

Empty | Represents the constant that is the empty Byte value.
MaxValue | Represents the largest possible Byte value.
MinValue | Represents the smallest possible Byte value.

See Also

Byte Structure | System Namespace


Byte.Empty

Represents the constant that is the empty Byte value.

[Visual Basic]
Public Const Empty As Byte
[C#]
public const byte Empty;
[C++]
public: const unsigned char Empty;
[JScript]
public var Empty : Byte;

Remarks

The Empty field has the value of TBD, which is zero. (See Empty.)

See Also

Byte Structure | Byte Members | System Namespace


Byte.MaxValue

Represents the largest possible Byte value.

[Visual Basic]
Public Const MaxValue As Byte
[C#]
public const byte MaxValue;
[C++]
public: const unsigned char MaxValue;
[JScript]
public var MaxValue : Byte;

Remarks

The MaxValue hexadecimal value is (byte)0xFF.

See Also

Byte Structure | Byte Members | System Namespace


Byte.MinValue

Represents the smallest possible Byte value.

[Visual Basic]
Public Const MinValue As Byte
[C#]
public const byte MinValue;
[C++]
public: const unsigned char MinValue;
[JScript]
public var MinValue : Byte;

Remarks

The MinValue hexadecimal value is 0.0.

See Also

Byte Structure | Byte Members | System Namespace


CallContext Class

This class exposes the API for the users of call context. All methods in CallContext are static and operate upon the call context in the Thread.

NOTE: CallContext is a specialized form of something that behaves like TLS for method calls. However, since the call objects may get serialized and deserialized along the path, it is tough to guarantee identity preservation.

Object
CallContext

[Visual Basic]
NotInheritable Public Class CallContext
[C#]
public sealed class CallContext
[C++]
public __gc __sealed class CallContext
[JScript]
public class CallContext

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

Example

See Also

CallContext Members | System Namespace


CallContext Members

Public:

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FreeNamedDataSlot |
GetData |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SetData |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CallContext Class | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CallContext Methods

The methods of the CallContext class are listed below. For a complete list of CallContext class members, see the CallContext Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FreeNamedDataSlot |
GetData |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SetData |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CallContext Class | System Namespace


CallContext.FreeNamedDataSlot

[Visual Basic]
Public Shared Sub FreeNamedDataSlot( _
   ByVal name As String _
)
[C#]
public static void FreeNamedDataSlot(
   string name
);
[C++]
public: static void FreeNamedDataSlot(
   String* name
);
[JScript]
public static function FreeNamedDataSlot(
   name : String
);

Parameters

name
The name of the item in the call context

See Also

CallContext Class | CallContext Members | System Namespace


CallContext.GetData

[Visual Basic]
Public Shared Function GetData( _
   ByVal name As String _
) As Object
[C#]
public static object GetData(
   string name
);
[C++]
public: static Object* GetData(
   String* name
);
[JScript]
public static function GetData(
   name : String
) : Object;

Parameters

name
The name of the item in the call context

Return Value

The object in the call context.

See Also

CallContext Class | CallContext Members | System Namespace


CallContext.SetData

[Visual Basic]
Public Shared Sub SetData( _
   ByVal name As String, _
   ByVal data As Object _
)
[C#]
public static void SetData(
   string name,
   object data
);
[C++]
public: static void SetData(
   String* name,
   Object* data
);
[JScript]
public static function SetData(
   name : String,
   data : Object
);

Parameters

name
The name of the item in the call context
data
[To be supplied.]

See Also

CallContext Class | CallContext Members | System Namespace


Char Structure

Represents a character value.

Object
ValueType
Char

[Visual Basic]
Public Structure Char
   Implements IComparable, IConvertible
[C#]
public struct Char : IComparable, IConvertible
[C++]
public __value struct Char : public IComparable, IConvertible

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

The Char class extends the Value class that represents a Unicode character Char methods (until that functionality is added) and provides object representation for the char primitive type.

The Unicode minimum and maximum values are\u0000 through\uffff, respectively.

Char has only a subset of the functions required to determine all of the character classifications given by the Unicode standard. For a complete set of functions, see the CharacterInfo class.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

Char Members | System Namespace | IComparable | IConvertible


Char Members

Public:

Methods

CompareTo | Compares this instance to the specified object.
Equals | Compares two boxed objects.
FromString | Retrieves the first character of a String.
GetHashCode | Returns the hash code for a 2-byte Unicode character.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | Retrieves the type code of an object.
IsDigit | Determines whether the specified character is a digit.
IsISOControl | Determines whether the specified character is an ISO control character.
IsLetter | Determines whether the specified character is a letter.
IsLetterOrDigit | Determines whether the specified character is a letter or a digit.
IsLower | Determines whether the specified character is lowercase.
IsPrintable | Determines whether the specified character is printable.
IsPunctuation | Determines whether the specified character is a punctuation mark.
IsTitleCase | Determines whether the specified character is a title case character.
IsUnicodeIdentifierPart | Determines whether the specified character can be part of a Unicode identifier.
IsUnicodeIdentifierStart | Determines whether the specified character can start a Unicode identifier.
IsUpper | Determines whether the specified character is uppercase.
IsWhiteSpace | Determines whether the specified character is white space.
ToBoolean | Converts a string to a Boolean value.
ToByte | Converts a Byte to a character.
ToChar | Converts a character to a Char.
ToDateTime | Converts this instance of a Char to a DateTime object.
ToDecimal | Converts this instance of a Char to a Decimal format.
ToDouble | Converts this instance of a Char as a Double.
ToInt16 | Converts this instance of a Char to an Int16.
ToInt32 | Converts this instance of a Char value to an Int32.
ToInt64 | Converts this instance of a Char to an Int64.
ToLower | Overloaded. Converts a Char to lowercase,
ToSByte | Converts this instance of a Char to an SByte.
ToSingle | Converts a Char to a Single.
ToString | Overloaded. Converts this instance of Char to a String.
ToType | Retrieves the Type for a specified Object.
ToUInt16 | Converts a Char to a UInt16.
ToUInt32 | Converts a Char to a UInt32.
ToUInt64 | Converts a Char to a UInt64.
ToUpper | Overloaded. Converts a Char to uppercase.

Fields

Empty | Representing the constant that is the empty Char value.
MaxValue | Representing the constant that is the largest possible Char value.
MinValue | Representing the constant that is the smallest possible Char value.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Char Structure | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Char Methods

The methods of the Char structure are listed below. For a complete list of Char structure members, see the Char Members topic.

Public:

CompareTo | Compares this instance to the specified object.
Equals | Compares two boxed objects.
FromString | Retrieves the first character of a String.
GetHashCode | Returns the hash code for a 2-byte Unicode character.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | Retrieves the type code of an object.
IsDigit | Determines whether the specified character is a digit.
IsISOControl | Determines whether the specified character is an ISO control character.
IsLetter | Determines whether the specified character is a letter.
IsLetterOrDigit | Determines whether the specified character is a letter or a digit.
IsLower | Determines whether the specified character is lowercase.
IsPrintable | Determines whether the specified character is printable.
IsPunctuation | Determines whether the specified character is a punctuation mark.
IsTitleCase | Determines whether the specified character is a title case character.
IsUnicodeIdentifierPart | Determines whether the specified character can be part of a Unicode identifier.
IsUnicodeIdentifierStart | Determines whether the specified character can start a Unicode identifier.
IsUpper | Determines whether the specified character is uppercase.
IsWhiteSpace | Determines whether the specified character is white space.
ToBoolean | Converts a string to a Boolean value.
ToByte | Converts a Byte to a character.
ToChar | Converts a character to a Char.
ToDateTime | Converts this instance of a Char to a DateTime object.
ToDecimal | Converts this instance of a Char to a Decimal format.
ToDouble | Converts this instance of a Char as a Double.
ToInt16 | Converts this instance of a Char to an Int16.
ToInt32 | Converts this instance of a Char value to an Int32.
ToInt64 | Converts this instance of a Char to an Int64.
ToLower | Overloaded. Converts a Char to lowercase,
ToSByte | Converts this instance of a Char to an SByte.
ToSingle | Converts a Char to a Single.
ToString | Overloaded. Converts this instance of Char to a String.
ToType | Retrieves the Type for a specified Object.
ToUInt16 | Converts a Char to a UInt16.
ToUInt32 | Converts a Char to a UInt32.
ToUInt64 | Converts a Char to a UInt64.
ToUpper | Overloaded. Converts a Char to uppercase.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Char Structure | System Namespace


Char.CompareTo

Compares this instance to the specified object.

[Visual Basic]
Overridable Public Function CompareTo( _
   ByVal value As Object _
) As Integer
[C#]
public virtual int CompareTo(
   object value
);
[C++]
public: virtual int CompareTo(
   Object* value
);
[JScript]
public function CompareTo(
   value : Object
) : int;

Parameters

value
The object for comparison with this instance.

Return Value

Value | Description
A negative integer | If this instance is less than the object.
Zero | If this instance and the object are equal.
A positive integer | If this instance is greater than the object.
A positive integer | If the object is null. This is a special case.

Exceptions

Exception Type | Condition
ArgumentException | if the object is not null reference and not a Char.

Remarks

In the comparison of two Char values, the Unicode hexadecimal character codes are used to determine the ordering. As a special case, an instance is considered to be greater than a null reference regardless of its value.

The value parameter must be either a Char type or a null reference; otherwise an exception is thrown. Null is considered to be less than this instance.

See Also

Char Structure | Char Members | System Namespace | Object


Char.Equals

Compares two boxed objects.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The object to compare with this instance.

Return Value

true if both the object and this instance are the same, otherwise false.

Remarks

The Equals method is used to compare the current instance against an object provided. If both are character objects and both contain the same character, then true is returned. Otherwise, false is returned.

See Also

Char Structure | Char Members | System Namespace | Object


Char.FromString

Retrieves the first character of a String.

[Visual Basic]
Public Shared Function FromString( _
   ByVal s As String _
) As Char
[C#]
public static char FromString(
   string s
);
[C++]
public: static __wchar_t FromString(
   String* s
);
[JScript]
public static function FromString(
   s : String
) : Char;

Parameters

s
The string converted to a character.

Return Value

The only character in the string.

Exceptions

Exception Type | Condition
ArgumentNullException | If the string is null.
FormatException | If the string is not equal to one.

Remarks

The FromString method converts an one-character string to a character. If the provided string is longer than one character, then a FormatException is thrown.

See Also

Char Structure | Char Members | System Namespace


Char.GetHashCode

Returns the hash code for a 2-byte Unicode character.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

A hash code for this instance.

Remarks

There are no sign extension from the casts because unsigned chars are returned.

See Also

Char Structure | Char Members | System Namespace | Hashtable | IHashCodeProvider


Char.GetTypeCode

Retrieves the type code of an object.

[Visual Basic]
Overridable Public Function GetTypeCode() As TypeCode
[C#]
public virtual TypeCode GetTypeCode();
[C++]
public: virtual TypeCode GetTypeCode();
[JScript]
public function GetTypeCode() : TypeCode;

Return Value

The type code of an object.

Remarks

This is the implementation of a method required by the IConvertible interface.

See Also

Char Structure | Char Members | System Namespace | Type | TypeCode


Char.IsDigit

Determines whether the specified character is a digit.

[Visual Basic]
Public Shared Function IsDigit( _
   ByVal c As Char _
) As Boolean
[C#]
public static bool IsDigit(
   char c
);
[C++]
public: static bool IsDigit(
   __wchar_t c
);
[JScript]
public static function IsDigit(
   c : Char
) : Boolean;

Parameters

c
The character to be examined.

Return Value

True if the character is a digit, otherwise false.

Remarks

Evaluate whether the character that is checked is a digit by calling the IsDigit function.

See Also

Char Structure | Char Members | System Namespace | Boolean


Char.IsISOControl

Determines whether the specified character is an ISO control character.

[Visual Basic]
Public Shared Function IsISOControl( _
   ByVal c As Char _
) As Boolean
[C#]
public static bool IsISOControl(
   char c
);
[C++]
public: static bool IsISOControl(
   __wchar_t c
);
[JScript]
public static function IsISOControl(
   c : Char
) : Boolean;

Parameters

c
The character to examine.

Return Value

true if the character is an ISO control character, otherwise false.

Exceptions

Exception Type | Condition
ArgumentException | if it cannot get the character type information.

Remarks

The IsISOControl method compares the current character instance and determines whether it is an ISO control character. (See CultureInfo and RegionInfo for more information on ISO.)

See Also

Char Structure | Char Members | System Namespace | Boolean


Char.IsLetter

Determines whether the specified character is a letter.

[Visual Basic]
Public Shared Function IsLetter( _
   ByVal c As Char _
) As Boolean
[C#]
public static bool IsLetter(
   char c
);
[C++]
public: static bool IsLetter(
   __wchar_t c
);
[JScript]
public static function IsLetter(
   c : Char
) : Boolean;

Parameters

c
The character to examine.

Return Value

true if the character is an alphabetic character, otherwise false.

Remarks

The IsLetter method is a wrapper for a Char. It compares the current character instance with IsLetter and returns a true or false indication whether the character that was checked is a letter. (See CharacterInfo.)

See Also

Char Structure | Char Members | System Namespace | Boolean


Char.IsLetterOrDigit

Determines whether the specified character is a letter or a digit.

[Visual Basic]
Public Shared Function IsLetterOrDigit( _
   ByVal c As Char _
) As Boolean
[C#]
public static bool IsLetterOrDigit(
   char c
);
[C++]
public: static bool IsLetterOrDigit(
   __wchar_t c
);
[JScript]
public static function IsLetterOrDigit(
   c : Char
) : Boolean;

Parameters

c
The character to examine.

Return Value

true if the character is an alphabetic or numeric character, otherwise false.

Exceptions

Exception Type | Condition
ArgumentException | if it cannot get the character type information.

Remarks

The IsLetterOrDigit method compares the current character instance with the Unicode category and returns a true or false indication whether the character that was checked is a letter or number.

See Also

Char Structure | Char Members | System Namespace | Boolean | CharacterInfo | Encoding | UnicodeEncoding


Char.IsLower

Determines whether the specified character is lowercase.

[Visual Basic]
Public Shared Function IsLower( _
   ByVal c As Char _
) As Boolean
[C#]
public static bool IsLower(
   char c
);
[C++]
public: static bool IsLower(
   __wchar_t c
);
[JScript]
public static function IsLower(
   c : Char
) : Boolean;

Parameters

c
The character to examine.

Return Value

true if the character is a lowercase character, otherwise false.

Exceptions

Exception Type | Condition
ArgumentException | if it cannot get the character type information.

Remarks

The IsLower method compares the current character instance with IsLower and returns a true or false indication whether the character that was checked is lowercase. (See CharacterInfo.)

See Also

Char Structure | Char Members | System Namespace | Boolean


Char.IsPrintable

Determines whether the specified character is printable.

[Visual Basic]
Public Shared Function IsPrintable( _
   ByVal c As Char _
) As Boolean
[C#]
public static bool IsPrintable(
   char c
);
[C++]
public: static bool IsPrintable(
   __wchar_t c
);
[JScript]
public static function IsPrintable(
   c : Char
) : Boolean;

Parameters

c
The character to examine.

Return Value

true if the character is printable on the user's machine, otherwise false.

Exceptions

Exception Type | Condition
ArgumentException | if it cannot get the character type information.

Remarks

The IsPrintable method determines whether a character can be printed on the user's printer and prints it using that machine's code pages. If the character is printable, a true or false indication is returned. (See CharacterInfo.)

See Also

Char Structure | Char Members | System Namespace | Boolean


Char.IsPunctuation

Determines whether the specified character is a punctuation mark.

[Visual Basic]
Public Shared Function IsPunctuation( _
   ByVal c As Char _
) As Boolean
[C#]
public static bool IsPunctuation(
   char c
);
[C++]
public: static bool IsPunctuation(
   __wchar_t c
);
[JScript]
public static function IsPunctuation(
   c : Char
) : Boolean;

Parameters

c
The character to examine.

Return Value

true if the character is a punctuation mark, otherwise false.

Exceptions

Exception Type | Condition
ArgumentException | if it cannot get the character type information.

Remarks

The IsPunctuation method compares the current character instance with IsPunctuation and returns a true or false indication whether the character that was checked is lowercase. (See CharacterInfo.)

See Also

Char Structure | Char Members | System Namespace | Boolean


Char.IsTitleCase

Determines whether the specified character is a title case character.

[Visual Basic]
Public Shared Function IsTitleCase( _
   ByVal c As Char _
) As Boolean
[C#]
public static bool IsTitleCase(
   char c
);
[C++]
public: static bool IsTitleCase(
   __wchar_t c
);
[JScript]
public static function IsTitleCase(
   c : Char
) : Boolean;

Parameters

c
The character to examine.

Return Value

true if the character is a title case character, otherwise false.

Remarks

A title case character is a concept that applies to only 4-characters in the Unicode specification. This has to do with the mapping of some Cyrillic/Serbian characters of the Latin alphabet. (See CultureInfo

.) For example, the Cyrillic character LJ looks just like 'L' and 'J' in the Latin alphabet. However, when used in a book title, the capitalized form is 'Lj', not 'LJ'.

The title case characters are:

\u01C5 Dz with Caron.

\u01C8 Lj

\u01CB Nj

\u01F2 Dz

See Also

Char Structure | Char Members | System Namespace | Boolean


Char.IsUnicodeIdentifierPart

Determines whether the specified character can be part of a Unicode identifier.

[Visual Basic]
Public Shared Function IsUnicodeIdentifierPart( _
   ByVal c As Char _
) As Boolean
[C#]
public static bool IsUnicodeIdentifierPart(
   char c
);
[C++]
public: static bool IsUnicodeIdentifierPart(
   __wchar_t c
);
[JScript]
public static function IsUnicodeIdentifierPart(
   c : Char
) : Boolean;

Parameters

c
The character to examine.

Return Value

true if the character can be part of a Unicode identifier, otherwise false.

Remarks

This method has not been implemented yet.

See Also

Char Structure | Char Members | System Namespace | Boolean | Encoding | UnicodeEncoding


Char.IsUnicodeIdentifierStart

Determines whether the specified character can start a Unicode identifier.

[Visual Basic]
Public Shared Function IsUnicodeIdentifierStart( _
   ByVal c As Char _
) As Boolean
[C#]
public static bool IsUnicodeIdentifierStart(
   char c
);
[C++]
public: static bool IsUnicodeIdentifierStart(
   __wchar_t c
);
[JScript]
public static function IsUnicodeIdentifierStart(
   c : Char
) : Boolean;

Parameters

c
The character to examine.

Return Value

true if the character can start a Unicode identifier, otherwise false.

Remarks

This method has not been implemented yet.

See Also

Char Structure | Char Members | System Namespace | Boolean | Encoding | UnicodeEncoding


Char.IsUpper

Determines whether the specified character is uppercase.

[Visual Basic]
Public Shared Function IsUpper( _
   ByVal c As Char _
) As Boolean
[C#]
public static bool IsUpper(
   char c
);
[C++]
public: static bool IsUpper(
   __wchar_t c
);
[JScript]
public static function IsUpper(
   c : Char
) : Boolean;

Parameters

c
The character to examine.

Return Value

true if the character is uppercase, otherwise false.

Exceptions

Exception Type | Condition
ArgumentException | if it cannot get the character type information.

Remarks

The IsUpper method compares the current character instance with IsUpper and returns a true or false indication whether the character that was checked is a uppercase. (See CharacterInfo.)

See Also

Char Structure | Char Members | System Namespace | Boolean


Char.IsWhiteSpace

Determines whether the specified character is white space.

[Visual Basic]
Public Shared Function IsWhiteSpace( _
   ByVal c As Char _
) As Boolean
[C#]
public static bool IsWhiteSpace(
   char c
);
[C++]
public: static bool IsWhiteSpace(
   __wchar_t c
);
[JScript]
public static function IsWhiteSpace(
   c : Char
) : Boolean;

Parameters

c
The character to examine.

Return Value

true if the character is white space, otherwise false.

Remarks

The IsWhitespace method is a wrapper for a Char. It compares the current character instance with IsWhiteSpace and returns a true or false indication whether the character that was checked is white space. (See CharacterInfo.)

See Also

Char Structure | Char Members | System Namespace | Boolean


Char.ToBoolean

Converts a string to a Boolean value.

[Visual Basic]
Overridable Public Function ToBoolean() As Boolean
[C#]
public virtual bool ToBoolean();
[C++]
public: virtual bool ToBoolean();
[JScript]
public function ToBoolean() : Boolean;

Return Value

false if the string is zero, otherwise true.

Remarks

The ToBoolean method converts the "true" or "false" Boolean values to the Boolean values of true and false.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Char Structure | Char Members | System Namespace


Char.ToByte

Converts a Byte to a character.

[Visual Basic]
Overridable Public Function ToByte() As Byte
[C#]
public virtual byte ToByte();
[C++]
public: virtual unsigned char ToByte();
[JScript]
public function ToByte() : Byte;

Return Value

The converted number as a Char .

Remarks

The ToByte method converts the number to an unsigned Char value.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Char Structure | Char Members | System Namespace


Char.ToChar

Converts a character to a Char.

[Visual Basic]
Overridable Public Function ToChar() As Char
[C#]
public virtual char ToChar();
[C++]
public: virtual __wchar_t ToChar();
[JScript]
public function ToChar() : Char;

Return Value

The Char value as a character.

Remarks

The ToChar method returns a character.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Char Structure | Char Members | System Namespace


Char.ToDateTime

Converts this instance of a Char to a DateTime object.

[Visual Basic]
Overridable Public Function ToDateTime() As DateTime
[C#]
public virtual DateTime ToDateTime();
[C++]
public: virtual DateTime ToDateTime();
[JScript]
public function ToDateTime() : DateTime;

Return Value

A DateTime.

Exceptions

Exception Type | Condition
InvalidCastException | If it doesn't return a DateTime.

Remarks

The ToDateTime method returns a DateTime.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Char Structure | Char Members | System Namespace


Char.ToDecimal

Converts this instance of a Char to a Decimal format.

[Visual Basic]
Overridable Public Function ToDecimal() As Decimal
[C#]
public virtual Decimal ToDecimal();
[C++]
public: virtual Decimal ToDecimal();
[JScript]
public function ToDecimal() : Decimal;

Return Value

A decimal as a Char.

Exceptions

Exception Type | Condition
InvalidCastException | If it doesn't return a decimal.

Remarks

The ToDecimal method returns a decimal.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Char Structure | Char Members | System Namespace


Char.ToDouble

Converts this instance of a Char as a Double.

[Visual Basic]
Overridable Public Function ToDouble() As Double
[C#]
public virtual double ToDouble();
[C++]
public: virtual double ToDouble();
[JScript]
public function ToDouble() : double;

Return Value

A double as a double.

Exceptions

Exception Type | Condition
InvalidCastException | If it doesn't return a double.

Remarks

The ToByte method returns the specified parameter as an 8-byte double precision floating-point number.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Char Structure | Char Members | System Namespace


Char.ToInt16

Converts this instance of a Char to an Int16.

[Visual Basic]
Overridable Public Function ToInt16() As Short
[C#]
public virtual short ToInt16();
[C++]
public: virtual short ToInt16();
[JScript]
public function ToInt16() : Int16;

Return Value

An Int16 as a Char.

Remarks

The ToInt16 method returns a short.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Char Structure | Char Members | System Namespace


Char.ToInt32

Converts this instance of a Char value to an Int32.

[Visual Basic]
Overridable Public Function ToInt32() As Integer
[C#]
public virtual int ToInt32();
[C++]
public: virtual int ToInt32();
[JScript]
public function ToInt32() : int;

Return Value

A value as an Int32.

Remarks

The ToInt32 method returns an int. It returns a 32-bit, 4-byte signed integer with the converted number.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Char Structure | Char Members | System Namespace


Char.ToInt64

Converts this instance of a Char to an Int64.

[Visual Basic]
Overridable Public Function ToInt64() As Long
[C#]
public virtual long ToInt64();
[C++]
public: virtual __int64 ToInt64();
[JScript]
public function ToInt64() : long;

Return Value

An Int64 value.

Remarks

The ToInt64 method returns a long. It returns a 64-bit, 8-byte signed integer with the converted number.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Char Structure | Char Members | System Namespace


Char.ToLower

Converts a Char to lowercase,

Overload List

Converts a specified Char to lowercase for the specified culture.

[Visual Basic] Overloads Public Shared Function ToLower(Char, CultureInfo) As Char
[C#] public static char ToLower(char, CultureInfo);
[C++] public: static __wchar_t ToLower(__wchar_t, CultureInfo);
[JScript] public static function ToLower(Char, CultureInfo) : Char;

Converts a Char to lowercase with the current thread culture.

[Visual Basic] Overloads Public Shared Function ToLower(Char) As Char
[C#] public static char ToLower(char);
[C++] public: static __wchar_t ToLower(__wchar_t);
[JScript] public static function ToLower(Char) : Char;

See Also

Char Structure | Char Members | System Namespace


Char.ToLower (Char, CultureInfo)

Converts a specified Char to lowercase for the specified culture.

[Visual Basic]
Overloads Public Shared Function ToLower( _
   ByVal c As Char, _
   ByVal culture As CultureInfo _
) As Char
[C#]
public static char ToLower(
   char c,
   CultureInfo culture
);
[C++]
public: static __wchar_t ToLower(
   __wchar_t c,
   CultureInfo* culture
);
[JScript]
public static function ToLower(
   c : Char,
   culture : CultureInfo
) : Char;

Parameters

c
The character to be converted.
culture
The local specifications used to convert the character.

Return Value

The lowercase version of the character according to the specified culture.

Exceptions

Exception Type | Condition
ArgumentNullException | if the culture is null.

Remarks

The ToLower method converts this instance of the character to the specified culture (see CultureInfo). It has not been fully implemented.

It is a wrapper for Char.ToLower and converts the character to its lower case equivalent. If the character is already a lower case character or is not alphabetic, then nothing happens.

See Also

Char Structure | Char Members | System Namespace | Char.ToLower Overload List


Char.ToLower (Char)

Converts a Char to lowercase with the current thread culture.

[Visual Basic]
Overloads Public Shared Function ToLower( _
   ByVal c As Char _
) As Char
[C#]
public static char ToLower(
   char c
);
[C++]
public: static __wchar_t ToLower(
   __wchar_t c
);
[JScript]
public static function ToLower(
   c : Char
) : Char;

Parameters

c
A Char value.

Return Value

The lowercase version of the character.

Remarks

The ToLower method converts this instance of the character to the current thread culture (see CultureInfo).

It is a wrapper for Char.ToLower and converts the character to its lower case equivalent. If the character is already a lower case character or is not alphabetic, then nothing happens.

See Also

Char Structure | Char Members | System Namespace | Char.ToLower Overload List


Char.ToSByte

Converts this instance of a Char to an SByte.

[Visual Basic]
Overridable Public Function ToSByte() As SByte
[C#]
public virtual sbyte ToSByte();
[C++]
public: virtual char ToSByte();
[JScript]
public function ToSByte() : SByte;

Return Value

An SByte value.

Remarks

The ToSByte method returns a signed byte.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Char Structure | Char Members | System Namespace


Char.ToSingle

Converts a Char to a Single.

[Visual Basic]
Overridable Public Function ToSingle() As Single
[C#]
public virtual float ToSingle();
[C++]
public: virtual float ToSingle();
[JScript]
public function ToSingle() : float;

Return Value

A float value

Exceptions

Exception Type | Condition
InvalidCastException | If it doesn't return a float.

Remarks

The ToSingle method returns the specified parameter as a float number.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Char Structure | Char Members | System Namespace


Char.ToString

Converts this instance of Char to a String.

Overload List

Converts this instance of Char to its Sring representation.

[Visual Basic] Overloads Overrides Public Function ToString() As String
[C#] public override string ToString();
[C++] public: override String* ToString();
[JScript] public override function ToString() : String;

Converts a specified Char to its specified String character.

[Visual Basic] Overloads Public Shared Function ToString(Char) As String
[C#] public static string ToString(char);
[C++] public: static String* ToString(__wchar_t);
[JScript] public static function ToString(Char) : String;

See Also

Char Structure | Char Members | System Namespace


Char.ToString ()

Converts this instance of Char to its Sring representation.

[Visual Basic]
Overloads Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

The string representation of this instance.

Remarks

This method overrides ToString.

See Also

Char Structure | Char Members | System Namespace | Char.ToString Overload List


Char.ToString (Char)

Converts a specified Char to its specified String character.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal c As Char _
) As String
[C#]
public static string ToString(
   char c
);
[C++]
public: static String* ToString(
   __wchar_t c
);
[JScript]
public static function ToString(
   c : Char
) : String;

Parameters

c
The character to convert.

Return Value

The string resulting from converting the specified character.

Remarks

This static method takes a character, converts it to a string, and returns the string representation.

See Also

Char Structure | Char Members | System Namespace | Char.ToString Overload List


Char.ToType

Retrieves the Type for a specified Object.

[Visual Basic]
Overridable Public Function ToType( _
   ByVal type As Type _
) As Object
[C#]
public virtual object ToType(
   Type type
);
[C++]
public: virtual Object* ToType(
   Type* type
);
[JScript]
public function ToType(
   type : Type
) : Object;

Parameters

type
The type.

Return Value

The type of the specified object.

Exceptions

Exception Type | Condition
InvalidCastException | If it doesn't return a type.

Remarks

The ToType method allows a means of reaching the Type class, which provides the functionality of several different services of the runtime, such as accessing the metadata and the Reflection.

See Also

Char Structure | Char Members | System Namespace


Char.ToUInt16

Converts a Char to a UInt16.

[Visual Basic]
Overridable Public Function ToUInt16() As UInt16
[C#]
public virtual ushort ToUInt16();
[C++]
public: virtual unsigned short ToUInt16();
[JScript]
public function ToUInt16() : UInt16;

Return Value

A number as a UInt16.

Exceptions

Exception Type | Condition
InvalidCastException | If it doesn't return a UInt16.

Remarks

The ToUInt16 method converts a byte value into a UInt16 and returns it.

See Also

Char Structure | Char Members | System Namespace


Char.ToUInt32

Converts a Char to a UInt32.

[Visual Basic]
Overridable Public Function ToUInt32() As UInt32
[C#]
public virtual uint ToUInt32();
[C++]
public: virtual unsigned int ToUInt32();
[JScript]
public function ToUInt32() : UInt32;

Return Value

A number as a UInt32.

Exceptions

Exception Type | Condition
InvalidCastException | If it doesn't return a UInt32.

Remarks

The ToUInt32method converts a byte value into a UInt32 and returns it.

See Also

Char Structure | Char Members | System Namespace


Char.ToUInt64

Converts a Char to a UInt64.

[Visual Basic]
Overridable Public Function ToUInt64() As UInt64
[C#]
public virtual ulong ToUInt64();
[C++]
public: virtual unsigned __int64 ToUInt64();
[JScript]
public function ToUInt64() : UInt64;

Return Value

A number as a UInt64.

Exceptions

Exception Type | Condition
InvalidCastException | If it doesn't return a UInt64.

Remarks

The ToUInt64method converts a Boolean value into a UInt64 and returns it.

See Also

Char Structure | Char Members | System Namespace


Char.ToUpper

Converts a Char to uppercase.

Overload List

Converts a specified Char to uppercase for the specified locale.

[Visual Basic] Overloads Public Shared Function ToUpper(Char, CultureInfo) As Char
[C#] public static char ToUpper(char, CultureInfo);
[C++] public: static __wchar_t ToUpper(__wchar_t, CultureInfo);
[JScript] public static function ToUpper(Char, CultureInfo) : Char;

Converts a specified Char to uppercase with the default culture.

[Visual Basic] Overloads Public Shared Function ToUpper(Char) As Char
[C#] public static char ToUpper(char);
[C++] public: static __wchar_t ToUpper(__wchar_t);
[JScript] public static function ToUpper(Char) : Char;

See Also

Char Structure | Char Members | System Namespace


Char.ToUpper (Char, CultureInfo)

Converts a specified Char to uppercase for the specified locale.

[Visual Basic]
Overloads Public Shared Function ToUpper( _
   ByVal c As Char, _
   ByVal culture As CultureInfo _
) As Char
[C#]
public static char ToUpper(
   char c,
   CultureInfo culture
);
[C++]
public: static __wchar_t ToUpper(
   __wchar_t c,
   CultureInfo* culture
);
[JScript]
public static function ToUpper(
   c : Char,
   culture : CultureInfo
) : Char;

Parameters

c
A Char value.
culture
The local specifications to use when converting the character.

Return Value

The uppercase version of c according the specified culture.

Remarks

The ToUpper method converts a specified Char to upper case with a specified culture (see CultureInfo for more information on cultures).

It is a wrapper for Char.ToUpper and converts the character to its upper case equivalent. If the character is already a upper case character or is not alphabetic, then nothing happens.

See Also

Char Structure | Char Members | System Namespace | Char.ToUpper Overload List


Char.ToUpper (Char)

Converts a specified Char to uppercase with the default culture.

[Visual Basic]
Overloads Public Shared Function ToUpper( _
   ByVal c As Char _
) As Char
[C#]
public static char ToUpper(
   char c
);
[C++]
public: static __wchar_t ToUpper(
   __wchar_t c
);
[JScript]
public static function ToUpper(
   c : Char
) : Char;

Parameters

c
The Char value to convert.

Return Value

The uppercase version of c.

Remarks

The ToUpper method converts a Char to upper case with the default cultures (see CultureInfo for more infomation on cultures).

It is a wrapper for Char.ToUpper and converts the character to its upper case equivalent. If the character is already a upper case character or is not alphabetic, then nothing happens.

See Also

Char Structure | Char Members | System Namespace | Char.ToUpper Overload List


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Char Fields

The fields of the Char structure are listed below. For a complete list of Char structure members, see the Char Members topic.

Public:

Empty | Representing the constant that is the empty Char value.
MaxValue | Representing the constant that is the largest possible Char value.
MinValue | Representing the constant that is the smallest possible Char value.

See Also

Char Structure | System Namespace


Char.Empty

Representing the constant that is the empty Char value.

[Visual Basic]
Public Const Empty As Char
[C#]
public const char Empty;
[C++]
public: const __wchar_t Empty;
[JScript]
public var Empty : Char;

Remarks

The Empty character value is MinValue, which is 0x000.

See Also

Char Structure | Char Members | System Namespace


Char.MaxValue

Representing the constant that is the largest possible Char value.

[Visual Basic]
Public Const MaxValue As Char
[C#]
public const char MaxValue;
[C++]
public: const __wchar_t MaxValue;
[JScript]
public var MaxValue : Char;

Remarks

The MaxValue is the maximum character value of (char) 0xFFFF.

See Also

Char Structure | Char Members | System Namespace


Char.MinValue

Representing the constant that is the smallest possible Char value.

[Visual Basic]
Public Const MinValue As Char
[C#]
public const char MinValue;
[C++]
public: const __wchar_t MinValue;
[JScript]
public var MinValue : Char;

Remarks

The MinValue is the minimum character value of (char) 0.00.

See Also

Char Structure | Char Members | System Namespace


CLSCompliantAttribute Class

This attribute indicates if an element is compliant with the Common language specification or not.

In order to be CLS-compliant, a producer tool must have an option that enables users to produce only CLS-compliant types. Tool vendors may also wish to have an option that enables users to consume only CLS-compliant types, but this is not required for CLS-compliance.

In addition, the runtime SDK will provide a tool that verifies CLS compliance of any compiled library or executable.

The goal of the compiler switch and SDK tool is to give developers some indication of when they use features that are not guaranteed to be supported in all NGWS runtime programming languages.

The CLSCompliantAttribute indicates what assemblies are CLS compliant and what Types and Type members are not CLS Compliant in a compliant assembly.

Note: The CLSCompliantAttribute may not be applied to any member of an Interface or any abstract member of a base type as this would make the classes un-extensible.

There are two ways this custom attribute can be used:

On Assemblies- When applied to an Assembly, this attribute marks an Assembly as being CLS compliant. Unless otherwise noted all types defined in this assembly are assumed to be CLS compliant. Without this attribute, an assembly is considered to be non compliant, all type defined with in it are also considered to be non-compliant.

On Types and Type Members- This attribute may be applied to Types, Methods, Properties, Fields, or Events. It calls out those members of a CLS Compliant Assembly that are not compliant. Any member of CLS Compliant assembly that is not compliant must have a compliant alternative. The CLS compliance checking tools ignore any member that has this attribute. That is, no warning is given for violation in this member. This attribute is inherited by base classes.

For example: compiling code such as:

public int SetValue (unsigned int value);

would generate a CLS compliance warning because the type of value is not in the CLS.

However, if the method was defined as:

[CLSComplaintAttribute (false)] public int SetValue (unsigned int value); public int SetValue (long value);

No compiler warnings/errors would be generated.

This checking gets slightly more complicate when the parameter type is non-primitive type. For example:

public int SetValue (FooType value);

We have to know something about the parameter type (FooType) to know if this method is CLS compliant. We assume that types used in public interfaces but not defined in this compiland are CLS compliant if and only if:

1. The type is defined in an assembly that is marked with the System.CLSCompliantAttribute (true)

The type is not marked with the custom attribute System.CLSCompliantAttribute(false).

See the Common Langauge specification for more details.

Object
Attribute
CLSCompliantAttribute

[Visual Basic]
Public Class CLSCompliantAttribute
   Inherits Attribute
[C#]
public class CLSCompliantAttribute : Attribute
[C++]
public __gc class CLSCompliantAttribute : public Attribute
[JScript]
public class CLSCompliantAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

CLSCompliantAttribute Members | System Namespace


CLSCompliantAttribute Members

Public:

Constructor

CLSCompliantAttribute Constructor Initializes an instance of the CLSCompliantAttribute class.

Properties

IsCompliant Checks the compliance indicated by this attribute

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CLSCompliantAttribute Class | System Namespace


CLSCompliantAttribute Constructor

Initializes an instance of the CLSCompliantAttribute class.

[Visual Basic]
Public Sub New( _
   ByVal isCompliant As Boolean _
)
[C#]
public CLSCompliantAttribute(
   bool isCompliant
);
[C++]
public: CLSCompliantAttribute(
   bool isCompliant
);
[JScript]
public function CLSCompliantAttribute(
   isCompliant : Boolean
);

Parameters

isCompliant
indicates the compliance of the element it's applied to. True for compliant, False otherwise

See Also

CLSCompliantAttribute Class | CLSCompliantAttribute Members | System Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CLSCompliantAttribute Properties

The properties of the CLSCompliantAttribute class are listed below. For a complete list of CLSCompliantAttribute class members, see the CLSCompliantAttribute Members topic.

Public:

IsCompliant Checks the compliance indicated by this attribute

See Also

CLSCompliantAttribute Class | System Namespace


CLSCompliantAttribute.IsCompliant

Checks the compliance indicated by this attribute

[Visual Basic]
Public ReadOnly Property IsCompliant As Boolean
[C#]
public bool IsCompliant {get;}
[C++]
public: __property bool get_IsCompliant();
[JScript]
public function get IsCompliant() : Boolean;

See Also

CLSCompliantAttribute Class | CLSCompliantAttribute Members | System Namespace


Console Class

Provides access to the standard input, standard output, and standard error streams. These streams are represented by Console.In, Console.Out, and Console.Error, respectively. They can be redirected via the SetIn, SetOut, and SetError methods.

The read methods provided by this class read from Console.In. They are provided as an alternative to directly invoking them on Console.In that is a StreamReader.

The write methods provided by this class write to Console.Out. They are provided as an alternative to directly invoking them on Console.Out that is a StreamWriter. Console.Error is also a StreamWriter.

Object
Console

[Visual Basic]
NotInheritable Public Class Console
[C#]
public sealed class Console
[C++]
public __gc __sealed class Console
[JScript]
public class Console

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

Example

This Managed C++ code sample demonstrates how to read from and write to the standard input and output streams. Note that these streams can be redirected using the SetIn and SetOut methods.

[C++]
#import <mscorlib.dll>
void main()
{
  Console::Write(L"Hola ");
  Console::WriteLine(L"Mundo!");
  Console::WriteLine(L"What is your name: ");
  String *name = Console::ReadLine();
  Console::Write(L"Buenos Dias, ");
  Console::Write(name);
  Console::WriteLine(L"!");
};

This Managed C++ code sample demonstrates how TextReader and TextWriter objects can be synchronized using the Synchronize method provided by both of these classes.

[C++]
#import <mscorlib.dll&rt;
using namespace IO;

#define NULL 0

class console
{
    public:
    static void Loop()
    {
   while (1) {
       Console::WriteLine(L"aaaaaaaaaaaaaaaaaaaaaaaa");
       Thread::Sleep(0);
   }
    }

    static void LoopB()
    {
   while (1) {
       Console::WriteLine(L"bbbbbbbbbbbbbbbbbbbbbbbb");
       Thread::Sleep(5);
   }
    }
    static void Test()
    {
   Console::WriteLine(L"Hi there");
   ThreadStart *ts = new ThreadStart(NULL, &console::Loop);
   ThreadStart *tsb = new ThreadStart(NULL, &console::LoopB);
   (new Thread(ts))-&rt;Start();
   (new Thread(tsb))-&rt;Start();
    }
};

void main()
{
    // To synchronize the console, use these two calls:

    TextWriter *t = Console::Out;
    Console::SetOut(t);
    console::Test();
};

See Also

Console Members | System Namespace


Console Members

Public:

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
OpenStandardError | Overloaded. [To be supplied.]
OpenStandardInput | Overloaded. [To be supplied.]
OpenStandardOutput | Overloaded. [To be supplied.]
Read | Reads the next character from Console.In, which is set to the system's standard input stream by default.
ReadLine | Reads the next line of characters from Console.In, which is set to the system's standard input stream by default.
SetError | Redirects Console.Error to the specified TextWriter. By default, Console.Error is set to the system's standard error stream.
SetIn | Redirects Console.In to the specified TextReader. By default, Console.In is set to the system's standard input stream.
SetOut | Redirects Console.Out to the specified TextWriter. By default, Console.Out is set to the system's standard output stream.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Overloaded. Writes the specified information to Console.Out.
WriteLine | Overloaded. Writes information followed by a line terminator to Console.Out.

Fields

Error | This field is assigned to the standard error stream of the system. It can be redirected via the SetError method.
In | This field is assigned to the standard input stream of the system. It can be redirected via the SetIn method.
Out | This field is assigned to the standard output stream of the system. It can be redirected via the SetOut method.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Console Class | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Console Methods

The methods of the Console class are listed below. For a complete list of Console class members, see the Console Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
OpenStandardError | Overloaded. [To be supplied.]
OpenStandardInput | Overloaded. [To be supplied.]
OpenStandardOutput | Overloaded. [To be supplied.]
Read | Reads the next character from Console.In, which is set to the system's standard input stream by default.
ReadLine | Reads the next line of characters from Console.In, which is set to the system's standard input stream by default.
SetError | Redirects Console.Error to the specified TextWriter. By default, Console.Error is set to the system's standard error stream.
SetIn | Redirects Console.In to the specified TextReader. By default, Console.In is set to the system's standard input stream.
SetOut | Redirects Console.Out to the specified TextWriter. By default, Console.Out is set to the system's standard output stream.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Overloaded. Writes the specified information to Console.Out.
WriteLine | Overloaded. Writes information followed by a line terminator to Console.Out.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Console Class | System Namespace


Console.OpenStandardError

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Shared Function OpenStandardError() As Stream
[C#] public static Stream OpenStandardError();
[C++] public: static Stream* OpenStandardError();
[JScript] public static function OpenStandardError() : Stream;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function OpenStandardError(Integer) As Stream
[C#] public static Stream OpenStandardError(int);
[C++] public: static Stream* OpenStandardError(int);
[JScript] public static function OpenStandardError(int) : Stream;

See Also

Console Class | Console Members | System Namespace


Console.OpenStandardError ()

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function OpenStandardError() As Stream
[C#]
public static Stream OpenStandardError();
[C++]
public: static Stream* OpenStandardError();
[JScript]
public static function OpenStandardError() : Stream;

See Also

Console Class | Console Members | System Namespace | Console.OpenStandardError Overload List


Console.OpenStandardError (Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function OpenStandardError( _
   ByVal bufferSize As Integer _
) As Stream
[C#]
public static Stream OpenStandardError(
   int bufferSize
);
[C++]
public: static Stream* OpenStandardError(
   int bufferSize
);
[JScript]
public static function OpenStandardError(
   bufferSize : int
) : Stream;

Parameters

bufferSize
[To be supplied.]

See Also

Console Class | Console Members | System Namespace | Console.OpenStandardError Overload List


Console.OpenStandardInput

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Shared Function OpenStandardInput(Integer) As Stream
[C#] public static Stream OpenStandardInput(int);
[C++] public: static Stream* OpenStandardInput(int);
[JScript] public static function OpenStandardInput(int) : Stream;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function OpenStandardInput() As Stream
[C#] public static Stream OpenStandardInput();
[C++] public: static Stream* OpenStandardInput();
[JScript] public static function OpenStandardInput() : Stream;

See Also

Console Class | Console Members | System Namespace


Console.OpenStandardInput (Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function OpenStandardInput( _
   ByVal bufferSize As Integer _
) As Stream
[C#]
public static Stream OpenStandardInput(
   int bufferSize
);
[C++]
public: static Stream* OpenStandardInput(
   int bufferSize
);
[JScript]
public static function OpenStandardInput(
   bufferSize : int
) : Stream;

Parameters

bufferSize
[To be supplied.]

See Also

Console Class | Console Members | System Namespace | Console.OpenStandardInput Overload List


Console.OpenStandardInput ()

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function OpenStandardInput() As Stream
[C#]
public static Stream OpenStandardInput();
[C++]
public: static Stream* OpenStandardInput();
[JScript]
public static function OpenStandardInput() : Stream;

See Also

Console Class | Console Members | System Namespace | Console.OpenStandardInput Overload List


Console.OpenStandardOutput

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Shared Function OpenStandardOutput(Integer) As Stream
[C#] public static Stream OpenStandardOutput(int);
[C++] public: static Stream* OpenStandardOutput(int);
[JScript] public static function OpenStandardOutput(int) : Stream;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function OpenStandardOutput() As Stream
[C#] public static Stream OpenStandardOutput();
[C++] public: static Stream* OpenStandardOutput();
[JScript] public static function OpenStandardOutput() : Stream;

See Also

Console Class | Console Members | System Namespace


Console.OpenStandardOutput (Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function OpenStandardOutput( _
   ByVal bufferSize As Integer _
) As Stream
[C#]
public static Stream OpenStandardOutput(
   int bufferSize
);
[C++]
public: static Stream* OpenStandardOutput(
   int bufferSize
);
[JScript]
public static function OpenStandardOutput(
   bufferSize : int
) : Stream;

Parameters

bufferSize
[To be supplied.]

See Also

Console Class | Console Members | System Namespace | Console.OpenStandardOutput Overload List


Console.OpenStandardOutput ()

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function OpenStandardOutput() As Stream
[C#]
public static Stream OpenStandardOutput();
[C++]
public: static Stream* OpenStandardOutput();
[JScript]
public static function OpenStandardOutput() : Stream;

See Also

Console Class | Console Members | System Namespace | Console.OpenStandardOutput Overload List


Console.Read

Reads the next character from Console.In, which is set to the system's standard input stream by default.

[Visual Basic]
Public Shared Function Read() As Integer
[C#]
public static int Read();
[C++]
public: static int Read();
[JScript]
public static function Read() : int;

Return Value

The next character from the input stream, or negative 1 if no more characters are available.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

Example [C#]

[C#]

int i;
    char c;
    while (true)
    {
     i = Console.Read ();
     if (i == -1) break;
     c = (char) i;
     Console.WriteLine ("Echo: {0}",
c);
    }
    Console.WriteLine ("Done");
    return 0;
  }

See Also

Console Class | Console Members | System Namespace


Console.ReadLine

Reads the next line of characters from Console.In, which is set to the system's standard input stream by default.

[Visual Basic]
Public Shared Function ReadLine() As String
[C#]
public static string ReadLine();
[C++]
public: static String* ReadLine();
[JScript]
public static function ReadLine() : String;

Return Value

The next line from the input stream, or null if the end of the input stream has already been reached.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

Remarks

A line is defined as a sequence of characters followed by a carriage return ('\r'), a line feed ('\n'), or a carriage return immediately followed by a line feed ('\r\n'). The string that is returned does not contain the terminating carriage return and/or line feed. The return value is null if the end of the input stream has already been reached.

See Also

Console Class | Console Members | System Namespace


Console.SetError

Redirects Console.Error to the specified TextWriter. By default, Console.Error is set to the system's standard error stream.

[Visual Basic]
Public Shared Sub SetError( _
   ByVal newError As TextWriter _
)
[C#]
public static void SetError(
   TextWriter newError
);
[C++]
public: static void SetError(
   TextWriter* newError
);
[JScript]
public static function SetError(
   newError : TextWriter
);

Parameters

newError
The new standard error stream.

Exceptions

Exception Type | Condition
ArgumentException | newError is null.
SecurityException | The caller does not have to set the standard error stream.

Remarks

A StreamWriter that encapsulates a FileStream can be used to send error messages to a file.

Requirements

NGWS Runtime Security:

SecurityPermission Unmanaged code permission.

See Also

Console Class | Console Members | System Namespace


Console.SetIn

Redirects Console.In to the specified TextReader. By default, Console.In is set to the system's standard input stream.

[Visual Basic]
Public Shared Sub SetIn( _
   ByVal newIn As TextReader _
)
[C#]
public static void SetIn(
   TextReader newIn
);
[C++]
public: static void SetIn(
   TextReader* newIn
);
[JScript]
public static function SetIn(
   newIn : TextReader
);

Parameters

newIn
The new standard input stream.

Exceptions

Exception Type | Condition
ArgumentException | newIn is null.
SecurityException | The caller does not have SystemStreamsPermission to set the standard error stream.

Remarks

A StreamReader that encapsulates a FileStream can be used to receive input from a file. The caller must have SystemStreamsPermission to set the standard input stream.

See Also

Console Class | Console Members | System Namespace


Console.SetOut

Redirects Console.Out to the specified TextWriter. By default, Console.Out is set to the system's standard output stream.

[Visual Basic]
Public Shared Sub SetOut( _
   ByVal newOut As TextWriter _
)
[C#]
public static void SetOut(
   TextWriter newOut
);
[C++]
public: static void SetOut(
   TextWriter* newOut
);
[JScript]
public static function SetOut(
   newOut : TextWriter
);

Parameters

newOut
The new standard output stream.

Exceptions

Exception Type | Condition
ArgumentException | newOut is null.
SecurityException | The caller does not have SystemStreamsPermission to set the standard error stream.

Remarks

A StreamWriter that encapsulates a FileStream can be used, in order to send output to a file.

In multi-threaded programs, an application getting the exception IndexOutOfRangeException with an exception message about "Probable IO race condition detected while accessing a file or Console...", must be updated to use thread-safe console output. To do this, simply synchronize the console. Here's an example:

Console.SetOut(StreamWriter.Synchronized(Console.Out));

The caller must have SystemStreamsPermission to set the standard output stream.

See Also

Console Class | Console Members | System Namespace


Console.Write

Writes the specified information to Console.Out.

Overload List

Writes the text representation of a Boolean to Console.Out that is set to the system's standard output stream by default.

[Visual Basic] Overloads Public Shared Sub Write(Boolean)
[C#] public static void Write(bool);
[C++] public: static void Write(bool);
[JScript] public static function Write(Boolean);

Writes out a formatted string.

[Visual Basic] Overloads Public Shared Sub Write(String, Object)
[C#] public static void Write(String, Object);
[C++] public: static void Write(String*, Object);
[JScript] public static function Write(String, Object);

Writes a character array to Console.Out that is set to the system's standard output stream by default.

[Visual Basic] Overloads Public Shared Sub Write(Char())
[C#] public static void Write(char[]);
[C++] public: static void Write(__wchar_t*[]);
[JScript] public static function Write(Char[]);

Writes a character to Console.Outthat is set to the system's standard output stream by default.

This method is empty, but descendant classes can override the method to provide the appropriate functionality.

[Visual Basic] Overloads Public Shared Sub Write(Char)
[C#] public static void Write(char);
[C++] public: static void Write(__wchar_t);
[JScript] public static function Write(Char);

[To be supplied.]

[Visual Basic] Overloads Public Shared Sub Write(String, Object, Object, Object, Object)
[C#] public static void Write(String, Object, Object, Object, Object);
[C++] public: static void Write(String*, Object, Object, Object, Object);
[JScript] public static function Write(String, Object, Object, Object, Object);

Writes out a formatted string to Console.Out that is set to the system's standard output stream by default.

[Visual Basic] Overloads Public Shared Sub Write(String, Object())
[C#] public static void Write(String, Object[]);
[C++] public: static void Write(String*, Object[]);
[JScript] public static function Write(String, Object[]);

Writes out a formatted string to Console.Out that is set to the system's standard output stream by default.

[Visual Basic] Overloads Public Shared Sub Write(String, Object, Object)
[C#] public static void Write(String, Object, Object);
[C++] public: static void Write(String*, Object, Object);
[JScript] public static function Write(String, Object, Object);

Writes out a formatted string to Console.Out that is set to the system's standard output stream by default.

[Visual Basic] Overloads Public Shared Sub Write(String, Object, Object, Object)
[C#] public static void Write(String, Object, Object, Object);
[C++] public: static void Write(String*, Object, Object, Object);
[JScript] public static function Write(String, Object, Object, Object);

Writes a sub array of characters to Console.Out that is set to the system's standard output stream by default.

[Visual Basic] Overloads Public Shared Sub Write(Char(), Integer, Integer)
[C#] public static void Write(char[], int, int);
[C++] public: static void Write(__wchar_t*[], int, int);
[JScript] public static function Write(Char[], int, int);

Writes the text representation of a eight-byte, unsigned integer to Out that is set to the system's standard output stream by default.

[Visual Basic] Overloads Public Shared Sub Write(UInt64)
[C#] public static void Write(ulong);
[C++] public: static void Write(unsigned __int64);
[JScript] public static function Write(UInt64);

Writes the text representation of an 8-byte integer to Out that is set to the system's standard output stream by default.

[Visual Basic] Overloads Public Shared Sub Write(Long)
[C#] public static void Write(long);
[C++] public: static void Write(__int64);
[JScript] public static function Write(long);

Writes a string to Out that is set to the system's standard output stream by default.

[Visual Basic] Overloads Public Shared Sub Write(String)
[C#] public static void Write(String);
[C++] public: static void Write(String*);
[JScript] public static function Write(String);

Writes the text representation of an object to Out that is set to the system's standard output stream by default.

[Visual Basic] Overloads Public Shared Sub Write(Object)
[C#] public static void Write(Object);
[C++] public: static void Write(Object*);
[JScript] public static function Write(Object);

Writes the text representation of a single to Out that is set to the system's standard output stream by default.

[Visual Basic] Overloads Public Shared Sub Write(Single)
[C#] public static void Write(float);
[C++] public: static void Write(float);
[JScript] public static function Write(float);

Writes the text representation of a double to Out that is set to the system's standard output stream by default.

[Visual Basic] Overloads Public Shared Sub Write(Double)
[C#] public static void Write(double);
[C++] public: static void Write(double);
[JScript] public static function Write(double);

Writes the text representation of an integer to Out that is set to the system's standard output stream by default.

[Visual Basic] Overloads Public Shared Sub Write(UInt32)
[C#] public static void Write(uint);
[C++] public: static void Write(unsigned int);
[JScript] public static function Write(UInt32);

Writes the text representation of a 4-byte integer to Out that is set to the system's standard output stream by default.

[Visual Basic] Overloads Public Shared Sub Write(Integer)
[C#] public static void Write(int);
[C++] public: static void Write(int);
[JScript] public static function Write(int);

See Also

Console Class | Console Members | System Namespace


Console.Write (Boolean)

Writes the text representation of a Boolean to Console.Out that is set to the system's standard output stream by default.

[Visual Basic]
Overloads Public Shared Sub Write( _
   ByVal value As Boolean _
)
[C#]
public static void Write(
   bool value
);
[C++]
public: static void Write(
   bool value
);
[JScript]
public static function Write(
   value : Boolean
);

Parameters

value
The Boolean to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

Remarks

This method outputs either Boolean.TrueString or Boolean.FalseString.

See Also

Console Class | Console Members | System Namespace | Console.Write Overload List


Console.Write (String, Object)

Writes out a formatted string.

[Visual Basic]
Overloads Public Shared Sub Write( _
   ByVal format As String, _
   ByVal arg0 As Object _
)
[C#]
public static void Write(
   string format,
   object arg0
);
[C++]
public: static void Write(
   String* format,
   Object* arg0
);
[JScript]
public static function Write(
   format : String,
   arg0 : Object
);

Parameters

format
Formatting string.
arg0
Object to write into format string.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

Remarks

This method uses the same semantics as Format.

See Also

Console Class | Console Members | System Namespace | Console.Write Overload List


Console.Write (Char[])

Writes a character array to Console.Out that is set to the system's standard output stream by default.

[Visual Basic]
Overloads Public Shared Sub Write( _
   ByVal buffer() As Char _
)
[C#]
public static void Write(
   char[] buffer
);
[C++]
public: static void Write(
   __wchar_t* buffer[]
);
[JScript]
public static function Write(
   buffer : Char[]
);

Parameters

buffer
The character array to write to the text stream.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.
ArgumentException | The buffer parameter is a null reference (in Visual Basic Nothing).

Remarks

This method calls Write(Char) for each of the characters in the character array. If the character array is null, nothing is written.

See Also

Console Class | Console Members | System Namespace | Console.Write Overload List


Console.Write (Char)

Writes a character to Console.Outthat is set to the system's standard output stream by default.

This method is empty, but descendant classes can override the method to provide the appropriate functionality.

[Visual Basic]
Overloads Public Shared Sub Write( _
   ByVal value As Char _
)
[C#]
public static void Write(
   char value
);
[C++]
public: static void Write(
   __wchar_t value
);
[JScript]
public static function Write(
   value : Char
);

Parameters

value
The character to write to the text stream.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

See Also

Console Class | Console Members | System Namespace | Console.Write Overload List


Console.Write (String, Object, Object, Object, Object)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Sub Write( _
   ByVal format As String, _
   ByVal arg0 As Object, _
   ByVal arg1 As Object, _
   ByVal arg2 As Object, _
   ByVal arg3 As Object _
)
[C#]
public static void Write(
   string format,
   object arg0,
   object arg1,
   object arg2,
   object arg3
);
[C++]
public: static void Write(
   String* format,
   Object* arg0,
   Object* arg1,
   Object* arg2,
   Object* arg3
);
[JScript]
public static function Write(
   format : String,
   arg0 : Object,
   arg1 : Object,
   arg2 : Object,
   arg3 : Object
);

Parameters

format
[To be supplied.]
arg0
[To be supplied.]
arg1
[To be supplied.]
arg2
[To be supplied.]
arg3
[To be supplied.]

See Also

Console Class | Console Members | System Namespace | Console.Write Overload List


Console.Write (String, Object[])

Writes out a formatted string to Console.Out that is set to the system's standard output stream by default.

[Visual Basic]
Overloads Public Shared Sub Write( _
   ByVal format As String, _
   ByVal arg() As Object _
)
[C#]
public static void Write(
   string format,
   object[] arg
);
[C++]
public: static void Write(
   String* format,
   Object* arg[]
);
[JScript]
public static function Write(
   format : String,
   arg : Object[]
);

Parameters

format
Formatting string.
arg
Object array to write into format string.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

Remarks

This method uses the same semantics as Format.

See Also

Console Class | Console Members | System Namespace | Console.Write Overload List


Console.Write (String, Object, Object)

Writes out a formatted string to Console.Out that is set to the system's standard output stream by default.

[Visual Basic]
Overloads Public Shared Sub Write( _
   ByVal format As String, _
   ByVal arg0 As Object, _
   ByVal arg1 As Object _
)
[C#]
public static void Write(
   string format,
   object arg0,
   object arg1
);
[C++]
public: static void Write(
   String* format,
   Object* arg0,
   Object* arg1
);
[JScript]
public static function Write(
   format : String,
   arg0 : Object,
   arg1 : Object
);

Parameters

format
Formatting string.
arg0
Object to write into format string.
arg1
Object to write into format string.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

Remarks

This method uses the same semantics as Format.

See Also

Console Class | Console Members | System Namespace | Console.Write Overload List


Console.Write (String, Object, Object, Object)

Writes out a formatted string to Console.Out that is set to the system's standard output stream by default.

[Visual Basic]
Overloads Public Shared Sub Write( _
   ByVal format As String, _
   ByVal arg0 As Object, _
   ByVal arg1 As Object, _
   ByVal arg2 As Object _
)
[C#]
public static void Write(
   string format,
   object arg0,
   object arg1,
   object arg2
);
[C++]
public: static void Write(
   String* format,
   Object* arg0,
   Object* arg1,
   Object* arg2
);
[JScript]
public static function Write(
   format : String,
   arg0 : Object,
   arg1 : Object,
   arg2 : Object
);

Parameters

format
Formatting string.
arg0
Object to write into format string.
arg1
Object to write into format string.
arg2
Object to write into format string.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

Remarks

Uses the same semantics as Format.

See Also

Console Class | Console Members | System Namespace | Console.Write Overload List


Console.Write (Char[], Int32, Int32)

Writes a sub array of characters to Console.Out that is set to the system's standard output stream by default.

[Visual Basic]
Overloads Public Shared Sub Write( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
[C#]
public static void Write(
   char[] buffer,
   int index,
   int count
);
[C++]
public: static void Write(
   __wchar_t* buffer[],
   int index,
   int count
);
[JScript]
public static function Write(
   buffer : Char[],
   index : int,
   count : int
);

Parameters

buffer
The character array from which to write data.
index
Starting index in the buffer.
count
The number of characters to write.

Exceptions

Exception Type | Condition
ArgumentException | The buffer parameter is a null reference (in Visual Basic Nothing). index or index + count is not a valid index of buffer.count is less than 0.
IOException | An I/O error occurs.

Remarks

This method will write count characters of data into this writer from the buffer character array starting at position index.

See Also

Console Class | Console Members | System Namespace | Console.Write Overload List


Console.Write (UInt64)

Writes the text representation of a eight-byte, unsigned integer to Out that is set to the system's standard output stream by default.

[Visual Basic]
Overloads Public Shared Sub Write( _
   ByVal value As UInt64 _
)
[C#]
public static void Write(
   ulong value
);
[C++]
public: static void Write(
   unsigned __int64 value
);
[JScript]
public static function Write(
   value : UInt64
);

Parameters

value
The UInt64 to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

See Also

Console Class | Console Members | System Namespace | Console.Write Overload List


Console.Write (Int64)

Writes the text representation of an 8-byte integer to Out that is set to the system's standard output stream by default.

[Visual Basic]
Overloads Public Shared Sub Write( _
   ByVal value As Long _
)
[C#]
public static void Write(
   long value
);
[C++]
public: static void Write(
   __int64 value
);
[JScript]
public static function Write(
   value : long
);

Parameters

value
The integer to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

Remarks

The text representation of the given value is produced by calling the ToString.

See Also

Console Class | Console Members | System Namespace | Console.Write Overload List


Console.Write (String)

Writes a string to Out that is set to the system's standard output stream by default.

[Visual Basic]
Overloads Public Shared Sub Write( _
   ByVal value As String _
)
[C#]
public static void Write(
   string value
);
[C++]
public: static void Write(
   String* value
);
[JScript]
public static function Write(
   value : String
);

Parameters

value
The string to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

Remarks

If value is null, nothing is written to the output stream.

See Also

Console Class | Console Members | System Namespace | Console.Write Overload List


Console.Write (Object)

Writes the text representation of an object to Out that is set to the system's standard output stream by default.

[Visual Basic]
Overloads Public Shared Sub Write( _
   ByVal value As Object _
)
[C#]
public static void Write(
   object value
);
[C++]
public: static void Write(
   Object* value
);
[JScript]
public static function Write(
   value : Object
);

Parameters

value
The object to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

Remarks

If the given object is null, the string "null" is written to the output stream. Otherwise, the object's ToString method is called to produce the string representation, and the resulting string is then written to the output stream.

See Also

Console Class | Console Members | System Namespace | Console.Write Overload List


Console.Write (Single)

Writes the text representation of a single to Out that is set to the system's standard output stream by default.

[Visual Basic]
Overloads Public Shared Sub Write( _
   ByVal value As Single _
)
[C#]
public static void Write(
   float value
);
[C++]
public: static void Write(
   float value
);
[JScript]
public static function Write(
   value : float
);

Parameters

value
The single to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

Remarks

The text representation of the given value is produced by calling ToString. Uses the invariant CultureInfo representation (The same applies for all the ones below).

See Also

Console Class | Console Members | System Namespace | Console.Write Overload List


Console.Write (Double)

Writes the text representation of a double to Out that is set to the system's standard output stream by default.

[Visual Basic]
Overloads Public Shared Sub Write( _
   ByVal value As Double _
)
[C#]
public static void Write(
   double value
);
[C++]
public: static void Write(
   double value
);
[JScript]
public static function Write(
   value : double
);

Parameters

value
The double to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

Remarks

The text representation of the given value is produced by calling ToString.

See Also

Console Class | Console Members | System Namespace | Console.Write Overload List


Console.Write (UInt32)

Writes the text representation of an integer to Out that is set to the system's standard output stream by default.

[Visual Basic]
Overloads Public Shared Sub Write( _
   ByVal value As UInt32 _
)
[C#]
public static void Write(
   uint value
);
[C++]
public: static void Write(
   unsigned int value
);
[JScript]
public static function Write(
   value : UInt32
);

Parameters

value
The UInt32 to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

Remarks

The text representation of the given value is produced by calling ToString.

See Also

Console Class | Console Members | System Namespace | Console.Write Overload List


Console.Write (Int32)

Writes the text representation of a 4-byte integer to Out that is set to the system's standard output stream by default.

[Visual Basic]
Overloads Public Shared Sub Write( _
   ByVal value As Integer _
)
[C#]
public static void Write(
   int value
);
[C++]
public: static void Write(
   int value
);
[JScript]
public static function Write(
   value : int
);

Parameters

value
The integer to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

Remarks

The text representation of the given value is produced by calling ToString.

See Also

Console Class | Console Members | System Namespace | Console.Write Overload List


Console.WriteLine

Writes information followed by a line terminator to Console.Out.

Overload List

Writes the text representation of a Single followed by a line terminator to Console.Out that is set to the system's standard output stream by default.

[Visual Basic] Overloads Public Shared Sub WriteLine(Single)
[C#] public static void WriteLine(float);
[C++] public: static void WriteLine(float);
[JScript] public static function WriteLine(float);

Writes the text representation of a Double followed by a line terminator to Console.Out that is set to the system's standard output stream by default.

[Visual Basic] Overloads Public Shared Sub WriteLine(Double)
[C#] public static void WriteLine(double);
[C++] public: static void WriteLine(double);
[JScript] public static function WriteLine(double);

Writes the text representation of an UInt32 followed by a line terminator to Console.Out that is set to the system's standard output stream by default.

[Visual Basic] Overloads Public Shared Sub WriteLine(UInt32)
[C#] public static void WriteLine(uint);
[C++] public: static void WriteLine(unsigned int);
[JScript] public static function WriteLine(UInt32);

[To be supplied.]

[Visual Basic] Overloads Public Shared Sub WriteLine(Integer)
[C#] public static void WriteLine(int);
[C++] public: static void WriteLine(int);
[JScript] public static function WriteLine(int);

Writes a subarray of characters followed by a line terminator to Console.Out that is set to the system's standard output stream by default.

[Visual Basic] Overloads Public Shared Sub WriteLine(Char(), Integer, Integer)
[C#] public static void WriteLine(char[], int, int);
[C++] public: static void WriteLine(__wchar_t*[], int, int);
[JScript] public static function WriteLine(Char[], int, int);

Writes the text representation of a Boolean followed by a line terminator to Console.Out that is set to the system's standard output stream by default.

[Visual Basic] Overloads Public Shared Sub WriteLine(Boolean)
[C#] public static void WriteLine(bool);
[C++] public: static void WriteLine(bool);
[JScript] public static function WriteLine(Boolean);

Writes a line terminator to Console.Out that is set to the system's standard output stream by default.

[Visual Basic] Overloads Public Shared Sub WriteLine()
[C#] public static void WriteLine();
[C++] public: static void WriteLine();
[JScript] public static function WriteLine();

Writes an array of characters followed by a line terminator to Console.Out that is set to the system's standard output stream by default.

[Visual Basic] Overloads Public Shared Sub WriteLine(Char())
[C#] public static void WriteLine(char[]);
[C++] public: static void WriteLine(__wchar_t*[]);
[JScript] public static function WriteLine(Char[]);

Writes a character followed by a line terminator to Console.Out that is set to the system's standard output stream by default.

[Visual Basic] Overloads Public Shared Sub WriteLine(Char)
[C#] public static void WriteLine(char);
[C++] public: static void WriteLine(__wchar_t);
[JScript] public static function WriteLine(Char);

Writes out a formatted string and a new line to Console.Out that is set to the system's standard output stream by default.

[Visual Basic] Overloads Public Shared Sub WriteLine(String, Object, Object, Object)
[C#] public static void WriteLine(String, Object, Object, Object);
[C++] public: static void WriteLine(String*, Object, Object, Object);
[JScript] public static function WriteLine(String, Object, Object, Object);

Writes out a formatted string and a new line to Console.Out that is set to the system's standard output stream by default.

[Visual Basic] Overloads Public Shared Sub WriteLine(String, Object, Object)
[C#] public static void WriteLine(String, Object, Object);
[C++] public: static void WriteLine(String*, Object, Object);
[JScript] public static function WriteLine(String, Object, Object);

Writes out a formatted string and a new line to Console.Out that is set to the system's standard output stream by default.

Uses the same semantics as Format.

[Visual Basic] Overloads Public Shared Sub WriteLine(String, Object())
[C#] public static void WriteLine(String, Object[]);
[C++] public: static void WriteLine(String*, Object[]);
[JScript] public static function WriteLine(String, Object[]);

[To be supplied.]

[Visual Basic] Overloads Public Shared Sub WriteLine(String, Object, Object, Object, Object)
[C#] public static void WriteLine(String, Object, Object, Object, Object);
[C++] public: static void WriteLine(String*, Object, Object, Object, Object);
[JScript] public static function WriteLine(String, Object, Object, Object, Object);

Writes out a formatted string and a line terminator to Console.Out that is set to the system's standard output stream by default.

[Visual Basic] Overloads Public Shared Sub WriteLine(String, Object)
[C#] public static void WriteLine(String, Object);
[C++] public: static void WriteLine(String*, Object);
[JScript] public static function WriteLine(String, Object);

Writes the text representation of an eight-byte, unsigned integer followed by a line terminator to Console.Out that is set to the system's standard output stream by default.

[Visual Basic] Overloads Public Shared Sub WriteLine(UInt64)
[C#] public static void WriteLine(ulong);
[C++] public: static void WriteLine(unsigned __int64);
[JScript] public static function WriteLine(UInt64);

Writes the text representation of an eight-byte integer followed by a line terminator to Console.Out that is set to the system's standard output stream by default.

[Visual Basic] Overloads Public Shared Sub WriteLine(Long)
[C#] public static void WriteLine(long);
[C++] public: static void WriteLine(__int64);
[JScript] public static function WriteLine(long);

Writes a string followed by a line terminator to Console.Out that is set to the system's standard output stream by default.

[Visual Basic] Overloads Public Shared Sub WriteLine(String)
[C#] public static void WriteLine(String);
[C++] public: static void WriteLine(String*);
[JScript] public static function WriteLine(String);

Writes the text representation of an object followed by a line terminator to Console.Out that is set to the system's standard output stream by default.

[Visual Basic] Overloads Public Shared Sub WriteLine(Object)
[C#] public static void WriteLine(Object);
[C++] public: static void WriteLine(Object*);
[JScript] public static function WriteLine(Object);

See Also

Console Class | Console Members | System Namespace


Console.WriteLine (Single)

Writes the text representation of a Single followed by a line terminator to Console.Out that is set to the system's standard output stream by default.

[Visual Basic]
Overloads Public Shared Sub WriteLine( _
   ByVal value As Single _
)
[C#]
public static void WriteLine(
   float value
);
[C++]
public: static void WriteLine(
   float value
);
[JScript]
public static function WriteLine(
   value : float
);

Parameters

value
The Single to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

Remarks

The default line terminator is a carriage return followed by a line feed ("\r\n"). The line terminator can be modified via the NewLine property of Console.Out.

See Also

Console Class | Console Members | System Namespace | Console.WriteLine Overload List


Console.WriteLine (Double)

Writes the text representation of a Double followed by a line terminator to Console.Out that is set to the system's standard output stream by default.

[Visual Basic]
Overloads Public Shared Sub WriteLine( _
   ByVal value As Double _
)
[C#]
public static void WriteLine(
   double value
);
[C++]
public: static void WriteLine(
   double value
);
[JScript]
public static function WriteLine(
   value : double
);

Parameters

value
The double to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

See Also

Console Class | Console Members | System Namespace | Console.WriteLine Overload List


Console.WriteLine (UInt32)

Writes the text representation of an UInt32 followed by a line terminator to Console.Out that is set to the system's standard output stream by default.

[Visual Basic]
Overloads Public Shared Sub WriteLine( _
   ByVal value As UInt32 _
)
[C#]
public static void WriteLine(
   uint value
);
[C++]
public: static void WriteLine(
   unsigned int value
);
[JScript]
public static function WriteLine(
   value : UInt32
);

Parameters

value
The unsigned integer to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

Remarks

The default line terminator is a carriage return followed by a line feed ("\r\n"). The line terminator can be modified via the NewLine property of Console.Out.

See Also

Console Class | Console Members | System Namespace | Console.WriteLine Overload List


Console.WriteLine (Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Sub WriteLine( _
   ByVal value As Integer _
)
[C#]
public static void WriteLine(
   int value
);
[C++]
public: static void WriteLine(
   int value
);
[JScript]
public static function WriteLine(
   value : int
);

Parameters

value
The integer to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

Remarks

The default line terminator is a carriage return followed by a line feed ("\r\n"). The line terminator can be modified via the NewLine property of Console.Out.

See Also

Console Class | Console Members | System Namespace | Console.WriteLine Overload List


Console.WriteLine (Char[], Int32, Int32)

Writes a subarray of characters followed by a line terminator to Console.Out that is set to the system's standard output stream by default.

[Visual Basic]
Overloads Public Shared Sub WriteLine( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
[C#]
public static void WriteLine(
   char[] buffer,
   int index,
   int count
);
[C++]
public: static void WriteLine(
   __wchar_t* buffer[],
   int index,
   int count
);
[JScript]
public static function WriteLine(
   buffer : Char[],
   index : int,
   count : int
);

Parameters

buffer
The character array from which data is read.
index
The index into buffer at which to begin reading.
count
The maximum number of characters to write.

Exceptions

Exception Type | Condition
ArgumentException | buffer is null.Either index or index + count is not a valid index of buffer.count is less than 0.
IOException | An I/O error occurs.

Remarks

The default line terminator is a carriage return followed by a line feed ("\r\n"). The line terminator can be modified via the NewLine property of Console.Out. Characters are read from buffer beginning at index and ending at index + count. All characters are written to the underlying stream unless the end of the underlying stream is reached prematurely.

See Also

Console Class | Console Members | System Namespace | Console.WriteLine Overload List


Console.WriteLine (Boolean)

Writes the text representation of a Boolean followed by a line terminator to Console.Out that is set to the system's standard output stream by default.

[Visual Basic]
Overloads Public Shared Sub WriteLine( _
   ByVal value As Boolean _
)
[C#]
public static void WriteLine(
   bool value
);
[C++]
public: static void WriteLine(
   bool value
);
[JScript]
public static function WriteLine(
   value : Boolean
);

Parameters

value
The Boolean to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

Remarks

The default line terminator is a carriage return followed by a line feed ("\r\n"). The line terminator can be modified via the NewLine property of Console.Out.

See Also

Console Class | Console Members | System Namespace | Console.WriteLine Overload List


Console.WriteLine ()

Writes a line terminator to Console.Out that is set to the system's standard output stream by default.

[Visual Basic]
Overloads Public Shared Sub WriteLine()
[C#]
public static void WriteLine();
[C++]
public: static void WriteLine();
[JScript]
public static function WriteLine();

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

Remarks

The default line terminator is a carriage return followed by a line feed ("\r\n"). The line terminator can be modified via the NewLine property of Console.Out.

See Also

Console Class | Console Members | System Namespace | Console.WriteLine Overload List


Console.WriteLine (Char[])

Writes an array of characters followed by a line terminator to Console.Out that is set to the system's standard output stream by default.

[Visual Basic]
Overloads Public Shared Sub WriteLine( _
   ByVal buffer() As Char _
)
[C#]
public static void WriteLine(
   char[] buffer
);
[C++]
public: static void WriteLine(
   __wchar_t* buffer[]
);
[JScript]
public static function WriteLine(
   buffer : Char[]
);

Parameters

buffer
The character array from which data is read.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.
ArgumentException | The buffer parameter is a null reference (in Visual Basic Nothing).

Remarks

All the characters in buffer are written to the underlying stream unless the end of the underlying stream is reached. The default line terminator is a carriage return followed by a line feed ("\r\n"). The line terminator can be modified via the NewLine property of Console.Out.

See Also

Console Class | Console Members | System Namespace | Console.WriteLine Overload List


Console.WriteLine (Char)

Writes a character followed by a line terminator to Console.Out that is set to the system's standard output stream by default.

[Visual Basic]
Overloads Public Shared Sub WriteLine( _
   ByVal value As Char _
)
[C#]
public static void WriteLine(
   char value
);
[C++]
public: static void WriteLine(
   __wchar_t value
);
[JScript]
public static function WriteLine(
   value : Char
);

Parameters

value
The character to write to the text stream.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

Remarks

The default line terminator is a carriage return followed by a line feed ("\r\n"). The line terminator can be modified via the NewLine property of Console.Out.

See Also

Console Class | Console Members | System Namespace | Console.WriteLine Overload List


Console.WriteLine (String, Object, Object, Object)

Writes out a formatted string and a new line to Console.Out that is set to the system's standard output stream by default.

[Visual Basic]
Overloads Public Shared Sub WriteLine( _
   ByVal format As String, _
   ByVal arg0 As Object, _
   ByVal arg1 As Object, _
   ByVal arg2 As Object _
)
[C#]
public static void WriteLine(
   string format,
   object arg0,
   object arg1,
   object arg2
);
[C++]
public: static void WriteLine(
   String* format,
   Object* arg0,
   Object* arg1,
   Object* arg2
);
[JScript]
public static function WriteLine(
   format : String,
   arg0 : Object,
   arg1 : Object,
   arg2 : Object
);

Parameters

format
Formatting string.
arg0
Object to write into format string.
arg1
Object to write into format string.
arg2
Object to write into format string.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

Remarks

The default line terminator is a carriage return followed by a line feed ("\r\n"). The line terminator can be modified via the NewLine property of Console.Out.

Uses the same semantics as Format.

See Also

Console Class | Console Members | System Namespace | Console.WriteLine Overload List


Console.WriteLine (String, Object, Object)

Writes out a formatted string and a new line to Console.Out that is set to the system's standard output stream by default.

[Visual Basic]
Overloads Public Shared Sub WriteLine( _
   ByVal format As String, _
   ByVal arg0 As Object, _
   ByVal arg1 As Object _
)
[C#]
public static void WriteLine(
   string format,
   object arg0,
   object arg1
);
[C++]
public: static void WriteLine(
   String* format,
   Object* arg0,
   Object* arg1
);
[JScript]
public static function WriteLine(
   format : String,
   arg0 : Object,
   arg1 : Object
);

Parameters

format
Formatting string.
arg0
Object to write into format string.
arg1
Object to write into format string.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

Remarks

The default line terminator is a carriage return followed by a line feed ("\r\n"). The line terminator can be modified via the NewLine property of Console.Out.

This method uses the same semantics as Format.

See Also

Console Class | Console Members | System Namespace | Console.WriteLine Overload List


Console.WriteLine (String, Object[])

Writes out a formatted string and a new line to Console.Out that is set to the system's standard output stream by default.

Uses the same semantics as Format.

[Visual Basic]
Overloads Public Shared Sub WriteLine( _
   ByVal format As String, _
   ByVal arg() As Object _
)
[C#]
public static void WriteLine(
   string format,
   object[] arg
);
[C++]
public: static void WriteLine(
   String* format,
   Object* arg[]
);
[JScript]
public static function WriteLine(
   format : String,
   arg : Object[]
);

Parameters

format
Formatting string.
arg
Object array to write into format string.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

Remarks

The default line terminator is a carriage return followed by a line feed ("\r\n"). The line terminator can be modified via the NewLine property of Console.Out.

Uses the same semantics as Format.

See Also

Console Class | Console Members | System Namespace | Console.WriteLine Overload List


Console.WriteLine (String, Object, Object, Object, Object)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Sub WriteLine( _
   ByVal format As String, _
   ByVal arg0 As Object, _
   ByVal arg1 As Object, _
   ByVal arg2 As Object, _
   ByVal arg3 As Object _
)
[C#]
public static void WriteLine(
   string format,
   object arg0,
   object arg1,
   object arg2,
   object arg3
);
[C++]
public: static void WriteLine(
   String* format,
   Object* arg0,
   Object* arg1,
   Object* arg2,
   Object* arg3
);
[JScript]
public static function WriteLine(
   format : String,
   arg0 : Object,
   arg1 : Object,
   arg2 : Object,
   arg3 : Object
);

Parameters

format
[To be supplied.]
arg0
[To be supplied.]
arg1
[To be supplied.]
arg2
[To be supplied.]
arg3
[To be supplied.]

See Also

Console Class | Console Members | System Namespace | Console.WriteLine Overload List


Console.WriteLine (String, Object)

Writes out a formatted string and a line terminator to Console.Out that is set to the system's standard output stream by default.

[Visual Basic]
Overloads Public Shared Sub WriteLine( _
   ByVal format As String, _
   ByVal arg0 As Object _
)
[C#]
public static void WriteLine(
   string format,
   object arg0
);
[C++]
public: static void WriteLine(
   String* format,
   Object* arg0
);
[JScript]
public static function WriteLine(
   format : String,
   arg0 : Object
);

Parameters

format
Formatting string.
arg0
Object to write into format string.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

Remarks

The default line terminator is a carriage return followed by a line feed ("\r\n"). The line terminator can be modified via the NewLine property of Console.Out.

This method uses the same semantics as Format.

See Also

Console Class | Console Members | System Namespace | Console.WriteLine Overload List


Console.WriteLine (UInt64)

Writes the text representation of an eight-byte, unsigned integer followed by a line terminator to Console.Out that is set to the system's standard output stream by default.

[Visual Basic]
Overloads Public Shared Sub WriteLine( _
   ByVal value As UInt64 _
)
[C#]
public static void WriteLine(
   ulong value
);
[C++]
public: static void WriteLine(
   unsigned __int64 value
);
[JScript]
public static function WriteLine(
   value : UInt64
);

Parameters

value
The eight-byte, unsigned integer to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

Remarks

The default line terminator is a carriage return followed by a line feed ("\r\n"). The line terminator can be modified via the NewLine property of Console.Out.

See Also

Console Class | Console Members | System Namespace | Console.WriteLine Overload List


Console.WriteLine (Int64)

Writes the text representation of an eight-byte integer followed by a line terminator to Console.Out that is set to the system's standard output stream by default.

[Visual Basic]
Overloads Public Shared Sub WriteLine( _
   ByVal value As Long _
)
[C#]
public static void WriteLine(
   long value
);
[C++]
public: static void WriteLine(
   __int64 value
);
[JScript]
public static function WriteLine(
   value : long
);

Parameters

value
The Int64 to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

Remarks

The default line terminator is a carriage return followed by a line feed ("\r\n"). The line terminator can be modified via the NewLine property of Console.Out.

See Also

Console Class | Console Members | System Namespace | Console.WriteLine Overload List


Console.WriteLine (String)

Writes a string followed by a line terminator to Console.Out that is set to the system's standard output stream by default.

[Visual Basic]
Overloads Public Shared Sub WriteLine( _
   ByVal value As String _
)
[C#]
public static void WriteLine(
   string value
);
[C++]
public: static void WriteLine(
   String* value
);
[JScript]
public static function WriteLine(
   value : String
);

Parameters

value
The string to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

Remarks

The default line terminator is a carriage return followed by a line feed ("\r\n"). The line terminator can be modified via the NewLine property of Console.Out.

See Also

Console Class | Console Members | System Namespace | Console.WriteLine Overload List


Console.WriteLine (Object)

Writes the text representation of an object followed by a line terminator to Console.Out that is set to the system's standard output stream by default.

[Visual Basic]
Overloads Public Shared Sub WriteLine( _
   ByVal value As Object _
)
[C#]
public static void WriteLine(
   object value
);
[C++]
public: static void WriteLine(
   Object* value
);
[JScript]
public static function WriteLine(
   value : Object
);

Parameters

value
The object to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occured.

Remarks

The default line terminator is a carriage return followed by a line feed ("\r\n"). The line terminator can be modified via the NewLine property of Console.Out.

See Also

Console Class | Console Members | System Namespace | Console.WriteLine Overload List


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Console Fields

The fields of the Console class are listed below. For a complete list of Console class members, see the Console Members topic.

Public:

Error | This field is assigned to the standard error stream of the system. It can be redirected via the SetError method.
In | This field is assigned to the standard input stream of the system. It can be redirected via the SetIn method.
Out | This field is assigned to the standard output stream of the system. It can be redirected via the SetOut method.

See Also

Console Class | System Namespace


Console.Error

This field is assigned to the standard error stream of the system. It can be redirected via the SetError method.

[Visual Basic]
Public Shared ReadOnly Error As TextWriter
[C#]
public static readonly TextWriter Error;
[C++]
public: static readonly TextWriter* Error;
[JScript]
public static var Error : TextWriter;

See Also

Console Class | Console Members | System Namespace


Console.In

This field is assigned to the standard input stream of the system. It can be redirected via the SetIn method.

[Visual Basic]
Public Shared ReadOnly In As TextReader
[C#]
public static readonly TextReader In;
[C++]
public: static readonly TextReader* In;
[JScript]
public static var In : TextReader;

See Also

Console Class | Console Members | System Namespace


Console.Out

This field is assigned to the standard output stream of the system. It can be redirected via the SetOut method.

[Visual Basic]
Public Shared ReadOnly Out As TextWriter
[C#]
public static readonly TextWriter Out;
[C++]
public: static readonly TextWriter* Out;
[JScript]
public static var Out : TextWriter;

See Also

Console Class | Console Members | System Namespace


ContextBoundObject Class

Defines the root type for all context bound types.

Object
MarshalByRefObject
ContextBoundObject

[Visual Basic]
MustInherit Public Class ContextBoundObject
   Inherits MarshalByRefObject
[C#]
public abstract class ContextBoundObject : MarshalByRefObject
[C++]
public __gc __abstract class ContextBoundObject : public
   MarshalByRefObject
[JScript]
public abstract class ContextBoundObject extends MarshalByRefObject

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

ContextBoundObject Members | System Namespace


ContextBoundObject Members

Public:

Constructor

ContextBoundObject Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ContextBoundObject Class | System Namespace


ContextBoundObject Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ContextBoundObject();
[C++]
public: ContextBoundObject();
[JScript]
public function ContextBoundObject();

See Also

ContextBoundObject Class | ContextBoundObject Members | System Namespace


ContextMarshalException Class

Represents an exception that is thrown when the formal type and marshal style of the object are incompatible.

Object
Exception
SystemException
ContextMarshalException

[Visual Basic]
Public Class ContextMarshalException
   Inherits SystemException
[C#]
public class ContextMarshalException : SystemException
[C++]
public __gc class ContextMarshalException : public SystemException
[JScript]
public class ContextMarshalException extends SystemException

Remarks

ContextMarshalException is an exception that is thrown when an attempt to marshal an object across a context boundary fails.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

ContextMarshalException Members | System Namespace


ContextMarshalException Members

Public:

Constructor

ContextMarshalException Constructor Overloaded. Initializes a new instance of the ContextMarshalException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

ContextMarshalException Class | System Namespace


ContextMarshalException Constructor

Initializes a new instance of the ContextMarshalException class.

Overload List

Initializes a new instance of the ContextMarshalException class with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public ContextMarshalException();
[C++] public: ContextMarshalException();
[JScript] public function ContextMarshalException();

Initializes a new instance of ContextMarshalException with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public ContextMarshalException(String);
[C++] public: ContextMarshalException(String*);
[JScript] public function ContextMarshalException(String);

Initializes a new instance of ContextMarshalException with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public ContextMarshalException(String, Exception);
[C++] public: ContextMarshalException(String*, Exception);
[JScript] public function ContextMarshalException(String, Exception);

See Also

ContextMarshalException Class | ContextMarshalException Members | System Namespace


ContextMarshalException Constructor ()

Initializes a new instance of the ContextMarshalException class with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ContextMarshalException();
[C++]
public: ContextMarshalException();
[JScript]
public function ContextMarshalException();

Remarks

ContextMarshalException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Conditon
InnerException | null
Message | The empty string.

See Also

ContextMarshalException Class | ContextMarshalException Members | System Namespace | ContextMarshalException Constructor Overload List


ContextMarshalException Constructor (String)

Initializes a new instance of ContextMarshalException with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public ContextMarshalException(
   string message
);
[C++]
public: ContextMarshalException(
   String* message
);
[JScript]
public function ContextMarshalException(
   message : String
);

Parameters

message
The message that indicates the reason the exception occurred.

Remarks

ContextMarshalException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Conditon
InnerException | null
Message | The message string.

See Also

ContextMarshalException Class | ContextMarshalException Members | System Namespace | ContextMarshalException Constructor Overload List


ContextMarshalException Constructor (String, Exception)

Initializes a new instance of ContextMarshalException with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public ContextMarshalException(
   string message,
   Exception inner
);
[C++]
public: ContextMarshalException(
   String* message,
   Exception* inner
);
[JScript]
public function ContextMarshalException(
   message : String,
   inner : Exception
);

Parameters

message
The message that indicates the reason the exception occurred.
inner
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

ContextMarshalException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | The inner exception.
Message | The message string.

See Also

ContextMarshalException Class | ContextMarshalException Members | System Namespace | ContextMarshalException Constructor Overload List


ContextStaticAttribute Class

Object
Attribute
ContextStaticAttribute

[Visual Basic]
Public Class ContextStaticAttribute
   Inherits Attribute
[C#]
public class ContextStaticAttribute : Attribute
[C++]
public __gc class ContextStaticAttribute : public Attribute
[JScript]
public class ContextStaticAttribute extends Attribute

Remarks

Context Relative Statics provide for type member fields that are relative for the context. Whenever the static field is accessed on a particular context it will be unique or relative for that context only. The static is not shared between contexts. If the static field is access on another context the field will contain a different value, since the field is unique per context.

Requirements

Namespace: System

Assembly: mscorlib.dll

Example [C#]

[C#]

class Foo
{
    int a;
    static int b;
    [ContextStaticAttribute()]
    static int c;

    int d=5;
    static int e=6;
    [ContextStatic]
    static int f=7;

    Foo()
    {
        a = 1;
        b = 2;
        c = 3;
    }

    void Method1()
    {
        Console.WriteLine("{0}", a);
        Console.WriteLine("{0}", b);
        Console.WriteLine("{0}", c);
        Console.WriteLine("{0}", d);
        Console.WriteLine("{0}", e );
        Console.WriteLine("{0}", f );
    }
}

See Also

ContextStaticAttribute Members | System Namespace


ContextStaticAttribute Members

Public:

Constructor

ContextStaticAttribute Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ContextStaticAttribute Class | System Namespace


ContextStaticAttribute Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ContextStaticAttribute();
[C++]
public: ContextStaticAttribute();
[JScript]
public function ContextStaticAttribute();

See Also

ContextStaticAttribute Class | ContextStaticAttribute Members | System Namespace


Convert Class

Converts base data types to other base data types.

A conversion that results in a loss of precision (narrowing conversion) will not return an exception; however, an exception will be returned if the resultant magnitude is out of range. For example, when a Double is converted to a Single, a loss of precision may occur, but an exception will not be thrown. However, if the Double is too large in magnitude to be represented by a Single, an exception will be thrown.

Object
Convert

[Visual Basic]
NotInheritable Public Class Convert
[C#]
public sealed class Convert
[C++]
public __gc __sealed class Convert
[JScript]
public class Convert

Remarks

This class supports conversions in both directions between any two of the following types: Byte, SByte, Int16, Int32, Int64, UInt16, UInt32, UInt64, Single, Double, Currency, Decimal, String, Variant, and Object.

Conversions from Char to Int32, UInt32, String, Variant, and Object are supported.

Conversions to Char from Byte, SByte, Int16, Int32, UInt16, and UInt32, String, and Variant are supported.

Conversions from Boolean to Byte, Char, Int16, Int32, Int64, UInt16, UInt32, UInt64, String, Variant, and Object are supported.

You can convert to Boolean from Byte, SByte, Int16, Int32, Int64, UInt16, UInt32, and UInt64, as well as String and Variant.

Conversions of TimeSpan and DateTime are supported to and from String and Variant.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

Convert Members | System Namespace


Convert Members

Public:

Methods

ChangeType | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FromBase64CharArray | [To be supplied.]
FromBase64String | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | [To be supplied.]
IsDBNull | [To be supplied.]
IsEmpty | [To be supplied.]
ToBase64CharArray | [To be supplied.]
ToBase64String | Overloaded. [To be supplied.]
ToBoolean | Overloaded. Converts a value to a Boolean value.
ToByte | Overloaded. Converts a value to an 8-bit unsigned integer.
ToChar | Overloaded. Converts a value to a unicode character.
ToDateTime | Overloaded. Converts a value to a DateTime.
ToDecimal | Overloaded. Converts a value to a Decimal.
ToDouble | Overloaded. Returns the specified parameter as an 8-byte Double precision floating-point number.
ToInt16 | Overloaded. Converts a value to a 16-bit signed integer.
ToInt32 | Overloaded. Converts a value to a 32-bit signed integer.
ToInt64 | Overloaded. Converts a value to a 64-bit signed integer.
ToSByte | Overloaded. Converts a value to an 8-bit signed integer.
ToSingle | Overloaded. Converts a value to a single-precision floating point number.
ToString | Overloaded. Converts a value to a string.
ToUInt16 | Overloaded. Converts a value to a 16-bit unsigned integer.
ToUInt32 | Overloaded. Converts a value to a 32-bit unsigned integer.
ToUInt64 | Overloaded. Converts a value to a 64-bit unsigned integer.

Fields

DBNull [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Convert Class | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Convert Methods

The methods of the Convert class are listed below. For a complete list of Convert class members, see the Convert Members topic.

Public:

ChangeType | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FromBase64CharArray | [To be supplied.]
FromBase64String | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | [To be supplied.]
IsDBNull | [To be supplied.]
IsEmpty | [To be supplied.]
ToBase64CharArray | [To be supplied.]
ToBase64String | Overloaded. [To be supplied.]
ToBoolean | Overloaded. Converts a value to a Boolean value.
ToByte | Overloaded. Converts a value to an 8-bit unsigned integer.
ToChar | Overloaded. Converts a value to a unicode character.
ToDateTime | Overloaded. Converts a value to a DateTime.
ToDecimal | Overloaded. Converts a value to a Decimal.
ToDouble | Overloaded. Returns the specified parameter as an 8-byte Double precision floating-point number.
ToInt16 | Overloaded. Converts a value to a 16-bit signed integer.
ToInt32 | Overloaded. Converts a value to a 32-bit signed integer.
ToInt64 | Overloaded. Converts a value to a 64-bit signed integer.
ToSByte | Overloaded. Converts a value to an 8-bit signed integer.
ToSingle | Overloaded. Converts a value to a single-precision floating point number.
ToString | Overloaded. Converts a value to a string.
ToUInt16 | Overloaded. Converts a value to a 16-bit unsigned integer.
ToUInt32 | Overloaded. Converts a value to a 32-bit unsigned integer.
ToUInt64 | Overloaded. Converts a value to a 64-bit unsigned integer.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Convert Class | System Namespace


Convert.ChangeType

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ChangeType(Object, TypeCode) As Object
[C#] public static object ChangeType(Object, TypeCode);
[C++] public: static Object* ChangeType(Object*, TypeCode);
[JScript] public static function ChangeType(Object, TypeCode) : Object;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ChangeType(Object, Type) As Object
[C#] public static object ChangeType(Object, Type);
[C++] public: static Object* ChangeType(Object*, Type);
[JScript] public static function ChangeType(Object, Type) : Object;

See Also

Convert Class | Convert Members | System Namespace


Convert.ChangeType (Object, TypeCode)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ChangeType( _
   ByVal value As Object, _
   ByVal typeCode As TypeCode _
) As Object
[C#]
public static object ChangeType(
   object value,
   TypeCode typeCode
);
[C++]
public: static Object* ChangeType(
   Object* value,
   TypeCode typeCode
);
[JScript]
public static function ChangeType(
   value : Object,
   typeCode : TypeCode
) : Object;

Parameters

value
[To be supplied.]
typeCode
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ChangeType Overload List


Convert.ChangeType (Object, Type)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ChangeType( _
   ByVal value As Object, _
   ByVal conversionType As Type _
) As Object
[C#]
public static object ChangeType(
   object value,
   Type conversionType
);
[C++]
public: static Object* ChangeType(
   Object* value,
   Type* conversionType
);
[JScript]
public static function ChangeType(
   value : Object,
   conversionType : Type
) : Object;

Parameters

value
[To be supplied.]
conversionType
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ChangeType Overload List


Convert.FromBase64CharArray

[To be supplied.]

[Visual Basic]
Public Shared Function FromBase64CharArray( _
   ByVal inArray() As Char, _
   ByVal offset As Integer, _
   ByVal length As Integer _
) As Byte ()
[C#]
public static byte[] FromBase64CharArray(
   char[] inArray,
   int offset,
   int length
);
[C++]
public: static unsigned char* FromBase64CharArray(
   __wchar_t* inArray[],
   int offset,
   int length
) [];
[JScript]
public static function FromBase64CharArray(
   inArray : Char[],
   offset : int,
   length : int
) : Byte[];

Parameters

inArray
[To be supplied.]
offset
[To be supplied.]
length
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace


Convert.FromBase64String

[To be supplied.]

[Visual Basic]
Public Shared Function FromBase64String( _
   ByVal s As String _
) As Byte ()
[C#]
public static byte[] FromBase64String(
   string s
);
[C++]
public: static unsigned char* FromBase64String(
   String* s
) [];
[JScript]
public static function FromBase64String(
   s : String
) : Byte[];

Parameters

s
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace


Convert.GetTypeCode

[To be supplied.]

[Visual Basic]
Public Shared Function GetTypeCode( _
   ByVal value As Object _
) As TypeCode
[C#]
public static TypeCode GetTypeCode(
   object value
);
[C++]
public: static TypeCode GetTypeCode(
   Object* value
);
[JScript]
public static function GetTypeCode(
   value : Object
) : TypeCode;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace


Convert.IsDBNull

[To be supplied.]

[Visual Basic]
Public Shared Function IsDBNull( _
   ByVal value As Object _
) As Boolean
[C#]
public static bool IsDBNull(
   object value
);
[C++]
public: static bool IsDBNull(
   Object* value
);
[JScript]
public static function IsDBNull(
   value : Object
) : Boolean;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace


Convert.IsEmpty

[To be supplied.]

[Visual Basic]
Public Shared Function IsEmpty( _
   ByVal value As Object _
) As Boolean
[C#]
public static bool IsEmpty(
   object value
);
[C++]
public: static bool IsEmpty(
   Object* value
);
[JScript]
public static function IsEmpty(
   value : Object
) : Boolean;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace


Convert.ToBase64CharArray

[To be supplied.]

[Visual Basic]
Public Shared Function ToBase64CharArray( _
   ByVal inArray() As Byte, _
   ByVal offsetIn As Integer, _
   ByVal length As Integer, _
   ByVal outArray() As Char, _
   ByVal offsetOut As Integer _
) As Integer
[C#]
public static int ToBase64CharArray(
   byte[] inArray,
   int offsetIn,
   int length,
   char[] outArray,
   int offsetOut
);
[C++]
public: static int ToBase64CharArray(
   unsigned char* inArray[],
   int offsetIn,
   int length,
   __wchar_t* outArray[],
   int offsetOut
);
[JScript]
public static function ToBase64CharArray(
   inArray : Byte[],
   offsetIn : int,
   length : int,
   outArray : Char[],
   offsetOut : int
) : int;

Parameters

inArray
[To be supplied.]
offsetIn
[To be supplied.]
length
[To be supplied.]
outArray
[To be supplied.]
offsetOut
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace


Convert.ToBase64String

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToBase64String(Byte()) As String
[C#] public static string ToBase64String(byte[]);
[C++] public: static String* ToBase64String(unsigned char*[]);
[JScript] public static function ToBase64String(Byte[]) : String;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToBase64String(Byte(), Integer, Integer) As String
[C#] public static string ToBase64String(byte[], int, int);
[C++] public: static String* ToBase64String(unsigned char*[], int, int);
[JScript] public static function ToBase64String(Byte[], int, int) : String;

See Also

Convert Class | Convert Members | System Namespace


Convert.ToBase64String (Byte[])

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToBase64String( _
   ByVal inArray() As Byte _
) As String
[C#]
public static string ToBase64String(
   byte[] inArray
);
[C++]
public: static String* ToBase64String(
   unsigned char* inArray[]
);
[JScript]
public static function ToBase64String(
   inArray : Byte[]
) : String;

Parameters

inArray
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToBase64String Overload List


Convert.ToBase64String (Byte[], Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToBase64String( _
   ByVal inArrray() As Byte, _
   ByVal offset As Integer, _
   ByVal length As Integer _
) As String
[C#]
public static string ToBase64String(
   byte[] inArrray,
   int offset,
   int length
);
[C++]
public: static String* ToBase64String(
   unsigned char* inArrray[],
   int offset,
   int length
);
[JScript]
public static function ToBase64String(
   inArrray : Byte[],
   offset : int,
   length : int
) : String;

Parameters

inArrray
[To be supplied.]
offset
[To be supplied.]
length
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToBase64String Overload List


Convert.ToBoolean

Converts a value to a Boolean value.

Overload List

Converts an Int64 to a Boolean value.

[Visual Basic] Overloads Public Shared Function ToBoolean(Long) As Boolean
[C#] public static bool ToBoolean(long);
[C++] public: static bool ToBoolean(__int64);
[JScript] public static function ToBoolean(long) : Boolean;

Converts a UInt64 to a Boolean.

[Visual Basic] Overloads Public Shared Function ToBoolean(UInt64) As Boolean
[C#] public static bool ToBoolean(ulong);
[C++] public: static bool ToBoolean(unsigned __int64);
[JScript] public static function ToBoolean(UInt64) : Boolean;

Converts a String to a Boolean value.

[Visual Basic] Overloads Public Shared Function ToBoolean(String) As Boolean
[C#] public static bool ToBoolean(String);
[C++] public: static bool ToBoolean(String*);
[JScript] public static function ToBoolean(String) : Boolean;

Converts a Char to a Boolean.

[Visual Basic] Overloads Public Shared Function ToBoolean(SByte) As Boolean
[C#] public static bool ToBoolean(sbyte);
[C++] public: static bool ToBoolean(char);
[JScript] public static function ToBoolean(SByte) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToBoolean(Char) As Boolean
[C#] public static bool ToBoolean(char);
[C++] public: static bool ToBoolean(__wchar_t);
[JScript] public static function ToBoolean(Char) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToBoolean(Object) As Boolean
[C#] public static bool ToBoolean(Object);
[C++] public: static bool ToBoolean(Object*);
[JScript] public static function ToBoolean(Object) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToBoolean(Boolean) As Boolean
[C#] public static bool ToBoolean(bool);
[C++] public: static bool ToBoolean(bool);
[JScript] public static function ToBoolean(Boolean) : Boolean;

Returns false if the number to be converted is 0, otherwise true.

[Visual Basic] Overloads Public Shared Function ToBoolean(Byte) As Boolean
[C#] public static bool ToBoolean(byte);
[C++] public: static bool ToBoolean(unsigned char);
[JScript] public static function ToBoolean(Byte) : Boolean;

Converts an Int32 to a Boolean value.

[Visual Basic] Overloads Public Shared Function ToBoolean(Integer) As Boolean
[C#] public static bool ToBoolean(int);
[C++] public: static bool ToBoolean(int);
[JScript] public static function ToBoolean(int) : Boolean;

Converts a UInt32 to a Boolean.

[Visual Basic] Overloads Public Shared Function ToBoolean(UInt32) As Boolean
[C#] public static bool ToBoolean(uint);
[C++] public: static bool ToBoolean(unsigned int);
[JScript] public static function ToBoolean(UInt32) : Boolean;

Converts an Int16 to a Boolean value.

[Visual Basic] Overloads Public Shared Function ToBoolean(Integer) As Boolean
[C#] public static bool ToBoolean(short);
[C++] public: static bool ToBoolean(short);
[JScript] public static function ToBoolean(Int16) : Boolean;

Converts a UInt16 to a Boolean.

[Visual Basic] Overloads Public Shared Function ToBoolean(UInt16) As Boolean
[C#] public static bool ToBoolean(ushort);
[C++] public: static bool ToBoolean(unsigned short);
[JScript] public static function ToBoolean(UInt16) : Boolean;

See Also

Convert Class | Convert Members | System Namespace


Convert.ToBoolean (Int64)

Converts an Int64 to a Boolean value.

[Visual Basic]
Overloads Public Shared Function ToBoolean( _
   ByVal value As Long _
) As Boolean
[C#]
public static bool ToBoolean(
   long value
);
[C++]
public: static bool ToBoolean(
   __int64 value
);
[JScript]
public static function ToBoolean(
   value : long
) : Boolean;

Parameters

value
The number to be converted.

Return Value

true if value is non-zero; otherwise, false.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToBoolean Overload List


Convert.ToBoolean (UInt64)

Converts a UInt64 to a Boolean.

[Visual Basic]
Overloads Public Shared Function ToBoolean( _
   ByVal value As UInt64 _
) As Boolean
[C#]
public static bool ToBoolean(
   ulong value
);
[C++]
public: static bool ToBoolean(
   unsigned __int64 value
);
[JScript]
public static function ToBoolean(
   value : UInt64
) : Boolean;

Parameters

value
The UInt64 to be converted.

Return Value

true if value is non-zero; otherwise, false.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToBoolean Overload List


Convert.ToBoolean (String)

Converts a String to a Boolean value.

[Visual Basic]
Overloads Public Shared Function ToBoolean( _
   ByVal value As String _
) As Boolean
[C#]
public static bool ToBoolean(
   string value
);
[C++]
public: static bool ToBoolean(
   String* value
);
[JScript]
public static function ToBoolean(
   value : String
) : Boolean;

Parameters

value
The number to be converted.

Return Value

A Boolean representation of value.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToBoolean Overload List


Convert.ToBoolean (SByte)

Converts a Char to a Boolean.

[Visual Basic]
Overloads Public Shared Function ToBoolean( _
   ByVal value As SByte _
) As Boolean
[C#]
public static bool ToBoolean(
   sbyte value
);
[C++]
public: static bool ToBoolean(
   char value
);
[JScript]
public static function ToBoolean(
   value : SByte
) : Boolean;

Parameters

value
The Char to be converted.

Return Value

true if value is non-zero; otherwise, false.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToBoolean Overload List


Convert.ToBoolean (Char)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToBoolean( _
   ByVal value As Char _
) As Boolean
[C#]
public static bool ToBoolean(
   char value
);
[C++]
public: static bool ToBoolean(
   __wchar_t value
);
[JScript]
public static function ToBoolean(
   value : Char
) : Boolean;

Parameters

value
[To be supplied.]

Return Value

true if value is non-zero; otherwise, false.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToBoolean Overload List


Convert.ToBoolean (Object)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToBoolean( _
   ByVal value As Object _
) As Boolean
[C#]
public static bool ToBoolean(
   object value
);
[C++]
public: static bool ToBoolean(
   Object* value
);
[JScript]
public static function ToBoolean(
   value : Object
) : Boolean;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToBoolean Overload List


Convert.ToBoolean (Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToBoolean( _
   ByVal value As Boolean _
) As Boolean
[C#]
public static bool ToBoolean(
   bool value
);
[C++]
public: static bool ToBoolean(
   bool value
);
[JScript]
public static function ToBoolean(
   value : Boolean
) : Boolean;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToBoolean Overload List


Convert.ToBoolean (Byte)

Returns false if the number to be converted is 0, otherwise true.

[Visual Basic]
Overloads Public Shared Function ToBoolean( _
   ByVal value As Byte _
) As Boolean
[C#]
public static bool ToBoolean(
   byte value
);
[C++]
public: static bool ToBoolean(
   unsigned char value
);
[JScript]
public static function ToBoolean(
   value : Byte
) : Boolean;

Parameters

value
The number to be converted.

Return Value

true if value is non-zero; otherwise, false.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToBoolean Overload List


Convert.ToBoolean (Int32)

Converts an Int32 to a Boolean value.

[Visual Basic]
Overloads Public Shared Function ToBoolean( _
   ByVal value As Integer _
) As Boolean
[C#]
public static bool ToBoolean(
   int value
);
[C++]
public: static bool ToBoolean(
   int value
);
[JScript]
public static function ToBoolean(
   value : int
) : Boolean;

Parameters

value
The number to be converted.

Return Value

true if value is non-zero; otherwise, false.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToBoolean Overload List


Convert.ToBoolean (UInt32)

Converts a UInt32 to a Boolean.

[Visual Basic]
Overloads Public Shared Function ToBoolean( _
   ByVal value As UInt32 _
) As Boolean
[C#]
public static bool ToBoolean(
   uint value
);
[C++]
public: static bool ToBoolean(
   unsigned int value
);
[JScript]
public static function ToBoolean(
   value : UInt32
) : Boolean;

Parameters

value
The UInt32 to be converted.

Return Value

true if value is non-zero; otherwise, false.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToBoolean Overload List


Convert.ToBoolean (Int16)

Converts an Int16 to a Boolean value.

[Visual Basic]
Overloads Public Shared Function ToBoolean( _
   ByVal value As Short _
) As Boolean
[C#]
public static bool ToBoolean(
   short value
);
[C++]
public: static bool ToBoolean(
   short value
);
[JScript]
public static function ToBoolean(
   value : Int16
) : Boolean;

Parameters

value
[To be supplied.]

Return Value

true if value is non-zero; otherwise, false.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToBoolean Overload List


Convert.ToBoolean (UInt16)

Converts a UInt16 to a Boolean.

[Visual Basic]
Overloads Public Shared Function ToBoolean( _
   ByVal value As UInt16 _
) As Boolean
[C#]
public static bool ToBoolean(
   ushort value
);
[C++]
public: static bool ToBoolean(
   unsigned short value
);
[JScript]
public static function ToBoolean(
   value : UInt16
) : Boolean;

Parameters

value
The UInt16 to be converted.

Return Value

true if value is non-zero; otherwise, false.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToBoolean Overload List


Convert.ToByte

Converts a value to an 8-bit unsigned integer.

Overload List

Converts an Int16 to an 8-bit unsigned byte.

[Visual Basic] Overloads Public Shared Function ToByte(Integer) As Byte
[C#] public static byte ToByte(short);
[C++] public: static unsigned char ToByte(short);
[JScript] public static function ToByte(Int16) : Byte;

Converts an SByte to an 8-bit unsigned byte.

[Visual Basic] Overloads Public Shared Function ToByte(SByte) As Byte
[C#] public static byte ToByte(sbyte);
[C++] public: static unsigned char ToByte(char);
[JScript] public static function ToByte(SByte) : Byte;

Converts an Int32 to an 8-bit unsigned byte.

[Visual Basic] Overloads Public Shared Function ToByte(Integer) As Byte
[C#] public static byte ToByte(int);
[C++] public: static unsigned char ToByte(int);
[JScript] public static function ToByte(int) : Byte;

Converts a UInt16 to a Byte.

[Visual Basic] Overloads Public Shared Function ToByte(UInt16) As Byte
[C#] public static byte ToByte(ushort);
[C++] public: static unsigned char ToByte(unsigned short);
[JScript] public static function ToByte(UInt16) : Byte;

Returns an 8-bit unsigned byte whose value is true or false, depending on the value to be converted.

[Visual Basic] Overloads Public Shared Function ToByte(Boolean) As Byte
[C#] public static byte ToByte(bool);
[C++] public: static unsigned char ToByte(bool);
[JScript] public static function ToByte(Boolean) : Byte;

Converts an object to an 8-bit unsigned byte.

[Visual Basic] Overloads Public Shared Function ToByte(Object) As Byte
[C#] public static byte ToByte(Object);
[C++] public: static unsigned char ToByte(Object*);
[JScript] public static function ToByte(Object) : Byte;

Converts a Char to a Byte.

[Visual Basic] Overloads Public Shared Function ToByte(Char) As Byte
[C#] public static byte ToByte(char);
[C++] public: static unsigned char ToByte(__wchar_t);
[JScript] public static function ToByte(Char) : Byte;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToByte(Byte) As Byte
[C#] public static byte ToByte(byte);
[C++] public: static unsigned char ToByte(unsigned char);
[JScript] public static function ToByte(Byte) : Byte;

Converts a Decimal to an 8-bit unsigned byte.

[Visual Basic] Overloads Public Shared Function ToByte(Decimal) As Byte
[C#] public static byte ToByte(Decimal);
[C++] public: static unsigned char ToByte(Decimal);
[JScript] public static function ToByte(Decimal) : Byte;

Converts a Double to an 8-bit unsigned byte.

[Visual Basic] Overloads Public Shared Function ToByte(Double) As Byte
[C#] public static byte ToByte(double);
[C++] public: static unsigned char ToByte(double);
[JScript] public static function ToByte(double) : Byte;

Converts a String to a value in the specified base, represented as an 8-bit unsigned byte.

[Visual Basic] Overloads Public Shared Function ToByte(String, Integer) As Byte
[C#] public static byte ToByte(String, int);
[C++] public: static unsigned char ToByte(String*, int);
[JScript] public static function ToByte(String, int) : Byte;

Converts a String to an 8-bit unsigned byte.

[Visual Basic] Overloads Public Shared Function ToByte(String) As Byte
[C#] public static byte ToByte(String);
[C++] public: static unsigned char ToByte(String*);
[JScript] public static function ToByte(String) : Byte;

Converts an Int64 to an 8-bit unsigned byte.

[Visual Basic] Overloads Public Shared Function ToByte(Long) As Byte
[C#] public static byte ToByte(long);
[C++] public: static unsigned char ToByte(__int64);
[JScript] public static function ToByte(long) : Byte;

Converts a UInt32 to a Byte.

[Visual Basic] Overloads Public Shared Function ToByte(UInt32) As Byte
[C#] public static byte ToByte(uint);
[C++] public: static unsigned char ToByte(unsigned int);
[JScript] public static function ToByte(UInt32) : Byte;

Converts a Single to an 8-bit unsigned byte.

[Visual Basic] Overloads Public Shared Function ToByte(Single) As Byte
[C#] public static byte ToByte(float);
[C++] public: static unsigned char ToByte(float);
[JScript] public static function ToByte(float) : Byte;

Converts a UInt64 to a Byte.

[Visual Basic] Overloads Public Shared Function ToByte(UInt64) As Byte
[C#] public static byte ToByte(ulong);
[C++] public: static unsigned char ToByte(unsigned __int64);
[JScript] public static function ToByte(UInt64) : Byte;

See Also

Convert Class | Convert Members | System Namespace


Convert.ToByte (Int16)

Converts an Int16 to an 8-bit unsigned byte.

[Visual Basic]
Overloads Public Shared Function ToByte( _
   ByVal value As Short _
) As Byte
[C#]
public static byte ToByte(
   short value
);
[C++]
public: static unsigned char ToByte(
   short value
);
[JScript]
public static function ToByte(
   value : Int16
) : Byte;

Parameters

value
The number to be converted.

Return Value

The converted value.

Exceptions

Exception Type | Condition
OverflowException | The value is greater than Byte.MaxValue or less than Byte.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToByte Overload List


Convert.ToByte (SByte)

Converts an SByte to an 8-bit unsigned byte.

[Visual Basic]
Overloads Public Shared Function ToByte( _
   ByVal value As SByte _
) As Byte
[C#]
public static byte ToByte(
   sbyte value
);
[C++]
public: static unsigned char ToByte(
   char value
);
[JScript]
public static function ToByte(
   value : SByte
) : Byte;

Parameters

value
The number to be converted.

Return Value

The converted value as a Byte .

Exceptions

Exception Type | Condition
OverflowException | The value is less than Byte.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToByte Overload List


Convert.ToByte (Int32)

Converts an Int32 to an 8-bit unsigned byte.

[Visual Basic]
Overloads Public Shared Function ToByte( _
   ByVal value As Integer _
) As Byte
[C#]
public static byte ToByte(
   int value
);
[C++]
public: static unsigned char ToByte(
   int value
);
[JScript]
public static function ToByte(
   value : int
) : Byte;

Parameters

value
The number to be converted.

Return Value

The converted value.

Exceptions

Exception Type | Condition
OverflowException | The value is greater than Byte.MaxValue or less than Byte.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToByte Overload List


Convert.ToByte (UInt16)

Converts a UInt16 to a Byte.

[Visual Basic]
Overloads Public Shared Function ToByte( _
   ByVal value As UInt16 _
) As Byte
[C#]
public static byte ToByte(
   ushort value
);
[C++]
public: static unsigned char ToByte(
   unsigned short value
);
[JScript]
public static function ToByte(
   value : UInt16
) : Byte;

Parameters

value
A UInt16 value.

Return Value

True if value is non-zero, false otherwise.

Exceptions

Exception Type | Condition
OverflowException | The value is greater than Byte.MaxValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToByte Overload List


Convert.ToByte (Boolean)

Returns an 8-bit unsigned byte whose value is true or false, depending on the value to be converted.

[Visual Basic]
Overloads Public Shared Function ToByte( _
   ByVal value As Boolean _
) As Byte
[C#]
public static byte ToByte(
   bool value
);
[C++]
public: static unsigned char ToByte(
   bool value
);
[JScript]
public static function ToByte(
   value : Boolean
) : Byte;

Parameters

value
The number to be converted.

Return Value

The number 1 if value is true; otherwise, 0.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToByte Overload List


Convert.ToByte (Object)

Converts an object to an 8-bit unsigned byte.

[Visual Basic]
Overloads Public Shared Function ToByte( _
   ByVal value As Object _
) As Byte
[C#]
public static byte ToByte(
   object value
);
[C++]
public: static unsigned char ToByte(
   Object* value
);
[JScript]
public static function ToByte(
   value : Object
) : Byte;

Parameters

value
The object to be converted.

Return Value

The converted value.

Exceptions

Exception Type | Condition
InvalidCastException | The object cannot be coerced to a Byte.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToByte Overload List


Convert.ToByte (Char)

Converts a Char to a Byte.

[Visual Basic]
Overloads Public Shared Function ToByte( _
   ByVal value As Char _
) As Byte
[C#]
public static byte ToByte(
   char value
);
[C++]
public: static unsigned char ToByte(
   __wchar_t value
);
[JScript]
public static function ToByte(
   value : Char
) : Byte;

Parameters

value
A Char value.

Return Value

True if value is non-zero, false otherwise.

Exceptions

Exception Type | Condition
OverflowException | The value is greater than Byte.MaxValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToByte Overload List


Convert.ToByte (Byte)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToByte( _
   ByVal value As Byte _
) As Byte
[C#]
public static byte ToByte(
   byte value
);
[C++]
public: static unsigned char ToByte(
   unsigned char value
);
[JScript]
public static function ToByte(
   value : Byte
) : Byte;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToByte Overload List


Convert.ToByte (Decimal)

Converts a Decimal to an 8-bit unsigned byte.

[Visual Basic]
Overloads Public Shared Function ToByte( _
   ByVal value As Decimal _
) As Byte
[C#]
public static byte ToByte(
   Decimal value
);
[C++]
public: static unsigned char ToByte(
   Decimal value
);
[JScript]
public static function ToByte(
   value : Decimal
) : Byte;

Parameters

value
The number to be converted.

Return Value

value rounded to the nearest integer. If value is exactly halfway between two whole numbers, this method returns the the integer that is even (i.e. 4.5 is converted to 4, and 5.5 is converted to 6).

Exceptions

Exception Type | Condition
OverflowException | The value is greater than Byte.MaxValue or less than Byte.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToByte Overload List


Convert.ToByte (Double)

Converts a Double to an 8-bit unsigned byte.

[Visual Basic]
Overloads Public Shared Function ToByte( _
   ByVal value As Double _
) As Byte
[C#]
public static byte ToByte(
   double value
);
[C++]
public: static unsigned char ToByte(
   double value
);
[JScript]
public static function ToByte(
   value : double
) : Byte;

Parameters

value
The number to be converted.

Return Value

value rounded to the nearest integer. If value is exactly halfway between two whole numbers, this method returns the the integer that is even (i.e. 4.5 is converted to 4, and 5.5 is converted to 6).

Exceptions

Exception Type | Condition
OverflowException | The value is greater than Byte.MaxValue or less than Byte.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToByte Overload List


Convert.ToByte (String, Int32)

Converts a String to a value in the specified base, represented as an 8-bit unsigned byte.

[Visual Basic]
Overloads Public Shared Function ToByte( _
   ByVal value As String, _
   ByVal fromBase As Integer _
) As Byte
[C#]
public static byte ToByte(
   string value,
   int fromBase
);
[C++]
public: static unsigned char ToByte(
   String* value,
   int fromBase
);
[JScript]
public static function ToByte(
   value : String,
   fromBase : int
) : Byte;

Parameters

value
The String to be parsed.
fromBase
The base in which to parse value.

Return Value

The unsigned byte representation of value as a base fromBase number.

Exceptions

Exception Type | Condition
ArgumentException | fromBase is not 2, 8, 10, or 16.
FormatException | value cannot be parsed as a base fromBase number.
ArgumentNullException | value is null.
OverflowException | The value represented by value is greater than Byte.MaxValue or less than Byte.MinValue.

Remarks

If fromBase is 16, the number may be preceded by "0x"; any other leading or trailing character causes an error.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToByte Overload List


Convert.ToByte (String)

Converts a String to an 8-bit unsigned byte.

[Visual Basic]
Overloads Public Shared Function ToByte( _
   ByVal value As String _
) As Byte
[C#]
public static byte ToByte(
   string value
);
[C++]
public: static unsigned char ToByte(
   String* value
);
[JScript]
public static function ToByte(
   value : String
) : Byte;

Parameters

value
The number to be converted.

Return Value

The converted value.

Exceptions

Exception Type | Condition
ArgumentNullException | If value is null.
FormatException | If the value is not a string representation that can be converted to a Byte using the Parse(String) method implemented by that type.
OverflowException | If the value represented by value is greater than Byte.MaxValue or less than Byte.MinValue. Note that if the beginning of the string value contains a properly formatted numerical value that will result in an overflow and, in addition, the end of the string is improperly formed, it cannot be determined whether an OverflowException or a FormatException will be thrown. This has been implemented this way for performance reasons. The implementation is provided by Byte.Parse(String).

Remarks

[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToByte Overload List


Convert.ToByte (Int64)

Converts an Int64 to an 8-bit unsigned byte.

[Visual Basic]
Overloads Public Shared Function ToByte( _
   ByVal value As Long _
) As Byte
[C#]
public static byte ToByte(
   long value
);
[C++]
public: static unsigned char ToByte(
   __int64 value
);
[JScript]
public static function ToByte(
   value : long
) : Byte;

Parameters

value
The number to be converted.

Return Value

The converted value.

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than Byte.MaxValue or less than Byte.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToByte Overload List


Convert.ToByte (UInt32)

Converts a UInt32 to a Byte.

[Visual Basic]
Overloads Public Shared Function ToByte( _
   ByVal value As UInt32 _
) As Byte
[C#]
public static byte ToByte(
   uint value
);
[C++]
public: static unsigned char ToByte(
   unsigned int value
);
[JScript]
public static function ToByte(
   value : UInt32
) : Byte;

Parameters

value
A UInt32 value.

Return Value

True if value is non-zero, false otherwise.

Exceptions

Exception Type | Condition
OverflowException | The value is greater than Byte.MaxValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToByte Overload List


Convert.ToByte (Single)

Converts a Single to an 8-bit unsigned byte.

[Visual Basic]
Overloads Public Shared Function ToByte( _
   ByVal value As Single _
) As Byte
[C#]
public static byte ToByte(
   float value
);
[C++]
public: static unsigned char ToByte(
   float value
);
[JScript]
public static function ToByte(
   value : float
) : Byte;

Parameters

value
The number to be converted.

Return Value

value rounded to the nearest integer. If value is exactly halfway between two whole numbers, this method returns the the integer that is even (i.e. 4.5 is converted to 4, and 5.5 is converted to 6).

Exceptions

Exception Type | Condition
OverflowException | The value is greater than Byte.MaxValue or less than Byte.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToByte Overload List


Convert.ToByte (UInt64)

Converts a UInt64 to a Byte.

[Visual Basic]
Overloads Public Shared Function ToByte( _
   ByVal value As UInt64 _
) As Byte
[C#]
public static byte ToByte(
   ulong value
);
[C++]
public: static unsigned char ToByte(
   unsigned __int64 value
);
[JScript]
public static function ToByte(
   value : UInt64
) : Byte;

Parameters

value
A UInt64 value.

Return Value

True if value is non-zero. false otherwise.

Exceptions

Exception Type | Condition
OverflowException | The value is greater than Byte.MaxValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToByte Overload List


Convert.ToChar

Converts a value to a unicode character.

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToChar(Long) As Char
[C#] public static char ToChar(long);
[C++] public: static __wchar_t ToChar(__int64);
[JScript] public static function ToChar(long) : Char;

Converts a UInt32 to a character.

[Visual Basic] Overloads Public Shared Function ToChar(UInt32) As Char
[C#] public static char ToChar(uint);
[C++] public: static __wchar_t ToChar(unsigned int);
[JScript] public static function ToChar(UInt32) : Char;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToChar(Decimal) As Char
[C#] public static char ToChar(Decimal);
[C++] public: static __wchar_t ToChar(Decimal);
[JScript] public static function ToChar(Decimal) : Char;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToChar(UInt64) As Char
[C#] public static char ToChar(ulong);
[C++] public: static __wchar_t ToChar(unsigned __int64);
[JScript] public static function ToChar(UInt64) : Char;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToChar(Double) As Char
[C#] public static char ToChar(double);
[C++] public: static __wchar_t ToChar(double);
[JScript] public static function ToChar(double) : Char;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToChar(Single) As Char
[C#] public static char ToChar(float);
[C++] public: static __wchar_t ToChar(float);
[JScript] public static function ToChar(float) : Char;

Converts a non-empty String of length 1 to a character.

[Visual Basic] Overloads Public Shared Function ToChar(String) As Char
[C#] public static char ToChar(String);
[C++] public: static __wchar_t ToChar(String*);
[JScript] public static function ToChar(String) : Char;

Converts an Int16 to a character.

[Visual Basic] Overloads Public Shared Function ToChar(Integer) As Char
[C#] public static char ToChar(short);
[C++] public: static __wchar_t ToChar(short);
[JScript] public static function ToChar(Int16) : Char;

Converts a UInt16 to a character.

[Visual Basic] Overloads Public Shared Function ToChar(UInt16) As Char
[C#] public static char ToChar(ushort);
[C++] public: static __wchar_t ToChar(unsigned short);
[JScript] public static function ToChar(UInt16) : Char;

Converts an Int32 to a character.

[Visual Basic] Overloads Public Shared Function ToChar(Integer) As Char
[C#] public static char ToChar(int);
[C++] public: static __wchar_t ToChar(int);
[JScript] public static function ToChar(int) : Char;

Converts a Byte to a character.

[Visual Basic] Overloads Public Shared Function ToChar(Byte) As Char
[C#] public static char ToChar(byte);
[C++] public: static __wchar_t ToChar(unsigned char);
[JScript] public static function ToChar(Byte) : Char;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToChar(Object) As Char
[C#] public static char ToChar(Object);
[C++] public: static __wchar_t ToChar(Object*);
[JScript] public static function ToChar(Object) : Char;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToChar(Char) As Char
[C#] public static char ToChar(char);
[C++] public: static __wchar_t ToChar(__wchar_t);
[JScript] public static function ToChar(Char) : Char;

Converts an SByte to a character.

[Visual Basic] Overloads Public Shared Function ToChar(SByte) As Char
[C#] public static char ToChar(sbyte);
[C++] public: static __wchar_t ToChar(char);
[JScript] public static function ToChar(SByte) : Char;

See Also

Convert Class | Convert Members | System Namespace


Convert.ToChar (Int64)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToChar( _
   ByVal value As Long _
) As Char
[C#]
public static char ToChar(
   long value
);
[C++]
public: static __wchar_t ToChar(
   __int64 value
);
[JScript]
public static function ToChar(
   value : long
) : Char;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToChar Overload List


Convert.ToChar (UInt32)

Converts a UInt32 to a character.

[Visual Basic]
Overloads Public Shared Function ToChar( _
   ByVal value As UInt32 _
) As Char
[C#]
public static char ToChar(
   uint value
);
[C++]
public: static __wchar_t ToChar(
   unsigned int value
);
[JScript]
public static function ToChar(
   value : UInt32
) : Char;

Parameters

value
The UInt32 to be converted.

Return Value

value as a character.

Exceptions

Exception Type | Condition
OverflowException | if value is greater than Char.MaxValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToChar Overload List


Convert.ToChar (Decimal)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToChar( _
   ByVal value As Decimal _
) As Char
[C#]
public static char ToChar(
   Decimal value
);
[C++]
public: static __wchar_t ToChar(
   Decimal value
);
[JScript]
public static function ToChar(
   value : Decimal
) : Char;

Parameters

value
[To be supplied.]

Exceptions

Exception Type | Condition
InvalidCastException | Always.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToChar Overload List


Convert.ToChar (UInt64)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToChar( _
   ByVal value As UInt64 _
) As Char
[C#]
public static char ToChar(
   ulong value
);
[C++]
public: static __wchar_t ToChar(
   unsigned __int64 value
);
[JScript]
public static function ToChar(
   value : UInt64
) : Char;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToChar Overload List


Convert.ToChar (Double)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToChar( _
   ByVal value As Double _
) As Char
[C#]
public static char ToChar(
   double value
);
[C++]
public: static __wchar_t ToChar(
   double value
);
[JScript]
public static function ToChar(
   value : double
) : Char;

Parameters

value
[To be supplied.]

Exceptions

Exception Type | Condition
InvalidCastException | Always.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToChar Overload List


Convert.ToChar (Single)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToChar( _
   ByVal value As Single _
) As Char
[C#]
public static char ToChar(
   float value
);
[C++]
public: static __wchar_t ToChar(
   float value
);
[JScript]
public static function ToChar(
   value : float
) : Char;

Parameters

value
[To be supplied.]

Exceptions

Exception Type | Condition
InvalidCastException | Always.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToChar Overload List


Convert.ToChar (String)

Converts a non-empty String of length 1 to a character.

[Visual Basic]
Overloads Public Shared Function ToChar( _
   ByVal value As String _
) As Char
[C#]
public static char ToChar(
   string value
);
[C++]
public: static __wchar_t ToChar(
   String* value
);
[JScript]
public static function ToChar(
   value : String
) : Char;

Parameters

value
The number to be converted.

Return Value

The character at index 0 within value .

Exceptions

Exception Type | Condition
ArgumentException | If value is null. If value is not a string of length 1.
FormatException | If value is not a string of length 1 or is String.Empty.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToChar Overload List


Convert.ToChar (Int16)

Converts an Int16 to a character.

[Visual Basic]
Overloads Public Shared Function ToChar( _
   ByVal value As Short _
) As Char
[C#]
public static char ToChar(
   short value
);
[C++]
public: static __wchar_t ToChar(
   short value
);
[JScript]
public static function ToChar(
   value : Int16
) : Char;

Parameters

value
The Int16 to be converted.

Return Value

value as a character.

Exceptions

Exception Type | Condition
OverflowException | if value is less than Char.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToChar Overload List


Convert.ToChar (UInt16)

Converts a UInt16 to a character.

[Visual Basic]
Overloads Public Shared Function ToChar( _
   ByVal value As UInt16 _
) As Char
[C#]
public static char ToChar(
   ushort value
);
[C++]
public: static __wchar_t ToChar(
   unsigned short value
);
[JScript]
public static function ToChar(
   value : UInt16
) : Char;

Parameters

value
The UInt16 to be converted.

Return Value

value as a character.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToChar Overload List


Convert.ToChar (Int32)

Converts an Int32 to a character.

[Visual Basic]
Overloads Public Shared Function ToChar( _
   ByVal value As Integer _
) As Char
[C#]
public static char ToChar(
   int value
);
[C++]
public: static __wchar_t ToChar(
   int value
);
[JScript]
public static function ToChar(
   value : int
) : Char;

Parameters

value
The number to be converted.

Return Value

The converted value.

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than Char.MaxValue or less than Char.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToChar Overload List


Convert.ToChar (Byte)

Converts a Byte to a character.

[Visual Basic]
Overloads Public Shared Function ToChar( _
   ByVal value As Byte _
) As Char
[C#]
public static char ToChar(
   byte value
);
[C++]
public: static __wchar_t ToChar(
   unsigned char value
);
[JScript]
public static function ToChar(
   value : Byte
) : Char;

Parameters

value
The Byte to be converted.

Return Value

value as a character.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToChar Overload List


Convert.ToChar (Object)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToChar( _
   ByVal value As Object _
) As Char
[C#]
public static char ToChar(
   object value
);
[C++]
public: static __wchar_t ToChar(
   Object* value
);
[JScript]
public static function ToChar(
   value : Object
) : Char;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToChar Overload List


Convert.ToChar (Char)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToChar( _
   ByVal value As Char _
) As Char
[C#]
public static char ToChar(
   char value
);
[C++]
public: static __wchar_t ToChar(
   __wchar_t value
);
[JScript]
public static function ToChar(
   value : Char
) : Char;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToChar Overload List


Convert.ToChar (SByte)

Converts an SByte to a character.

[Visual Basic]
Overloads Public Shared Function ToChar( _
   ByVal value As SByte _
) As Char
[C#]
public static char ToChar(
   sbyte value
);
[C++]
public: static __wchar_t ToChar(
   char value
);
[JScript]
public static function ToChar(
   value : SByte
) : Char;

Parameters

value
The SByte to be converted.

Return Value

value as a character.

Exceptions

Exception Type | Condition
OverflowException | The value is less than Char.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToChar Overload List


Convert.ToDateTime

Converts a value to a DateTime.

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToDateTime(String) As DateTime
[C#] public static DateTime ToDateTime(String);
[C++] public: static DateTime ToDateTime(String*);
[JScript] public static function ToDateTime(String) : DateTime;

Returns the specified Object converted to DateTime format.

[Visual Basic] Overloads Public Shared Function ToDateTime(Object) As DateTime
[C#] public static DateTime ToDateTime(Object);
[C++] public: static DateTime ToDateTime(Object*);
[JScript] public static function ToDateTime(Object) : DateTime;

See Also

Convert Class | Convert Members | System Namespace


Convert.ToDateTime (String)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToDateTime( _
   ByVal value As String _
) As DateTime
[C#]
public static DateTime ToDateTime(
   string value
);
[C++]
public: static DateTime ToDateTime(
   String* value
);
[JScript]
public static function ToDateTime(
   value : String
) : DateTime;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToDateTime Overload List


Convert.ToDateTime (Object)

Returns the specified Object converted to DateTime format.

[Visual Basic]
Overloads Public Shared Function ToDateTime( _
   ByVal value As Object _
) As DateTime
[C#]
public static DateTime ToDateTime(
   object value
);
[C++]
public: static DateTime ToDateTime(
   Object* value
);
[JScript]
public static function ToDateTime(
   value : Object
) : DateTime;

Parameters

value
The number to be converted.

Return Value

The object as a DateTime type.

Remarks

Implementation is the same as Parse.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToDateTime Overload List


Convert.ToDecimal

Converts a value to a Decimal.

Overload List

Converts a Byte to a Decimal.

[Visual Basic] Overloads Public Shared Function ToDecimal(Byte) As Decimal
[C#] public static Decimal ToDecimal(byte);
[C++] public: static Decimal ToDecimal(unsigned char);
[JScript] public static function ToDecimal(Byte) : Decimal;

Converts an SByte to a Decimal.

[Visual Basic] Overloads Public Shared Function ToDecimal(SByte) As Decimal
[C#] public static Decimal ToDecimal(sbyte);
[C++] public: static Decimal ToDecimal(char);
[JScript] public static function ToDecimal(SByte) : Decimal;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToDecimal(Object) As Decimal
[C#] public static Decimal ToDecimal(Object);
[C++] public: static Decimal ToDecimal(Object*);
[JScript] public static function ToDecimal(Object) : Decimal;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToDecimal(Char) As Decimal
[C#] public static Decimal ToDecimal(char);
[C++] public: static Decimal ToDecimal(__wchar_t);
[JScript] public static function ToDecimal(Char) : Decimal;

Converts an Int32 to a Decimal.

[Visual Basic] Overloads Public Shared Function ToDecimal(Integer) As Decimal
[C#] public static Decimal ToDecimal(int);
[C++] public: static Decimal ToDecimal(int);
[JScript] public static function ToDecimal(int) : Decimal;

Converts a UInt16 to a Decimal.

[Visual Basic] Overloads Public Shared Function ToDecimal(UInt16) As Decimal
[C#] public static Decimal ToDecimal(ushort);
[C++] public: static Decimal ToDecimal(unsigned short);
[JScript] public static function ToDecimal(UInt16) : Decimal;

Converts an Int16 to a Decimal.

[Visual Basic] Overloads Public Shared Function ToDecimal(Integer) As Decimal
[C#] public static Decimal ToDecimal(short);
[C++] public: static Decimal ToDecimal(short);
[JScript] public static function ToDecimal(Int16) : Decimal;

Returns the specified parameter in Decimal format.

[Visual Basic] Overloads Public Shared Function ToDecimal(Double) As Decimal
[C#] public static Decimal ToDecimal(double);
[C++] public: static Decimal ToDecimal(double);
[JScript] public static function ToDecimal(double) : Decimal;

Converts a String to a Decimal.

[Visual Basic] Overloads Public Shared Function ToDecimal(String) As Decimal
[C#] public static Decimal ToDecimal(String);
[C++] public: static Decimal ToDecimal(String*);
[JScript] public static function ToDecimal(String) : Decimal;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToDecimal(Decimal) As Decimal
[C#] public static Decimal ToDecimal(Decimal);
[C++] public: static Decimal ToDecimal(Decimal);
[JScript] public static function ToDecimal(Decimal) : Decimal;

Converts a Single to a Decimal.

[Visual Basic] Overloads Public Shared Function ToDecimal(Single) As Decimal
[C#] public static Decimal ToDecimal(float);
[C++] public: static Decimal ToDecimal(float);
[JScript] public static function ToDecimal(float) : Decimal;

Converts a UInt32 to a Decimal.

[Visual Basic] Overloads Public Shared Function ToDecimal(UInt32) As Decimal
[C#] public static Decimal ToDecimal(uint);
[C++] public: static Decimal ToDecimal(unsigned int);
[JScript] public static function ToDecimal(UInt32) : Decimal;

Converts an Int64 to a Decimal.

[Visual Basic] Overloads Public Shared Function ToDecimal(Long) As Decimal
[C#] public static Decimal ToDecimal(long);
[C++] public: static Decimal ToDecimal(__int64);
[JScript] public static function ToDecimal(long) : Decimal;

Converts a UInt64 to a Decimal.

[Visual Basic] Overloads Public Shared Function ToDecimal(UInt64) As Decimal
[C#] public static Decimal ToDecimal(ulong);
[C++] public: static Decimal ToDecimal(unsigned __int64);
[JScript] public static function ToDecimal(UInt64) : Decimal;

See Also

Convert Class | Convert Members | System Namespace


Convert.ToDecimal (Byte)

Converts a Byte to a Decimal.

[Visual Basic]
Overloads Public Shared Function ToDecimal( _
   ByVal value As Byte _
) As Decimal
[C#]
public static Decimal ToDecimal(
   byte value
);
[C++]
public: static Decimal ToDecimal(
   unsigned char value
);
[JScript]
public static function ToDecimal(
   value : Byte
) : Decimal;

Parameters

value
The number to be converted.

Return Value

The value as a Decimal.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToDecimal Overload List


Convert.ToDecimal (SByte)

Converts an SByte to a Decimal.

[Visual Basic]
Overloads Public Shared Function ToDecimal( _
   ByVal value As SByte _
) As Decimal
[C#]
public static Decimal ToDecimal(
   sbyte value
);
[C++]
public: static Decimal ToDecimal(
   char value
);
[JScript]
public static function ToDecimal(
   value : SByte
) : Decimal;

Parameters

value
The number to be converted.

Return Value

The value as a Decimal.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToDecimal Overload List


Convert.ToDecimal (Object)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToDecimal( _
   ByVal value As Object _
) As Decimal
[C#]
public static Decimal ToDecimal(
   object value
);
[C++]
public: static Decimal ToDecimal(
   Object* value
);
[JScript]
public static function ToDecimal(
   value : Object
) : Decimal;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToDecimal Overload List


Convert.ToDecimal (Char)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToDecimal( _
   ByVal value As Char _
) As Decimal
[C#]
public static Decimal ToDecimal(
   char value
);
[C++]
public: static Decimal ToDecimal(
   __wchar_t value
);
[JScript]
public static function ToDecimal(
   value : Char
) : Decimal;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToDecimal Overload List


Convert.ToDecimal (Int32)

Converts an Int32 to a Decimal.

[Visual Basic]
Overloads Public Shared Function ToDecimal( _
   ByVal value As Integer _
) As Decimal
[C#]
public static Decimal ToDecimal(
   int value
);
[C++]
public: static Decimal ToDecimal(
   int value
);
[JScript]
public static function ToDecimal(
   value : int
) : Decimal;

Parameters

value
The number to be converted.

Return Value

The value as a Decimal.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToDecimal Overload List


Convert.ToDecimal (UInt16)

Converts a UInt16 to a Decimal.

[Visual Basic]
Overloads Public Shared Function ToDecimal( _
   ByVal value As UInt16 _
) As Decimal
[C#]
public static Decimal ToDecimal(
   ushort value
);
[C++]
public: static Decimal ToDecimal(
   unsigned short value
);
[JScript]
public static function ToDecimal(
   value : UInt16
) : Decimal;

Parameters

value
The value to be converted.

Return Value

The value as a Decimal.

Remarks

[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToDecimal Overload List


Convert.ToDecimal (Int16)

Converts an Int16 to a Decimal.

[Visual Basic]
Overloads Public Shared Function ToDecimal( _
   ByVal value As Short _
) As Decimal
[C#]
public static Decimal ToDecimal(
   short value
);
[C++]
public: static Decimal ToDecimal(
   short value
);
[JScript]
public static function ToDecimal(
   value : Int16
) : Decimal;

Parameters

value
The number to be converted.

Return Value

The value as a Decimal.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToDecimal Overload List


Convert.ToDecimal (Double)

Returns the specified parameter in Decimal format.

[Visual Basic]
Overloads Public Shared Function ToDecimal( _
   ByVal value As Double _
) As Decimal
[C#]
public static Decimal ToDecimal(
   double value
);
[C++]
public: static Decimal ToDecimal(
   double value
);
[JScript]
public static function ToDecimal(
   value : double
) : Decimal;

Parameters

value
The number to be converted.

Return Value

The value as a Decimal.

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than Decimal.MaxValue or less than Decimal.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToDecimal Overload List


Convert.ToDecimal (String)

Converts a String to a Decimal.

[Visual Basic]
Overloads Public Shared Function ToDecimal( _
   ByVal value As String _
) As Decimal
[C#]
public static Decimal ToDecimal(
   string value
);
[C++]
public: static Decimal ToDecimal(
   String* value
);
[JScript]
public static function ToDecimal(
   value : String
) : Decimal;

Parameters

value
A String representation of a Decimal.

Return Value

The Decimal with the value represented by value.

Exceptions

Exception Type | Condition
ArgumentException | value is null.
FormatException | value does not contain a representation that can be converted to a Decimal using the Parse(String) method implemented by that type.
OverflowException | value represents a number that is less than Decimal.MinValue or greater than Decimal.MaxValue. Note that if the beginning of the string value contains a properly formatted numerical value that will result in an overflow and, in addition, the end of the string is improperly formed, it cannot be determined whether an OverflowException or a FormatException will be thrown. This has been implemented this way for performance reasons.

Remarks

Implementation is the same as FromString. Note that if the beginning of the string value contains a properly formatted numerical value that will result in an overflow and, in addition, the end of the string is improperly formed, it cannot be determined whether an OverflowException or a FormatException will be thrown.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToDecimal Overload List


Convert.ToDecimal (Decimal)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToDecimal( _
   ByVal value As Decimal _
) As Decimal
[C#]
public static Decimal ToDecimal(
   Decimal value
);
[C++]
public: static Decimal ToDecimal(
   Decimal value
);
[JScript]
public static function ToDecimal(
   value : Decimal
) : Decimal;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToDecimal Overload List


Convert.ToDecimal (Single)

Converts a Single to a Decimal.

[Visual Basic]
Overloads Public Shared Function ToDecimal( _
   ByVal value As Single _
) As Decimal
[C#]
public static Decimal ToDecimal(
   float value
);
[C++]
public: static Decimal ToDecimal(
   float value
);
[JScript]
public static function ToDecimal(
   value : float
) : Decimal;

Parameters

value
The number to be converted.

Return Value

The value as a Decimal.

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than Decimal.MaxValue or less than Decimal.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToDecimal Overload List


Convert.ToDecimal (UInt32)

Converts a UInt32 to a Decimal.

[Visual Basic]
Overloads Public Shared Function ToDecimal( _
   ByVal value As UInt32 _
) As Decimal
[C#]
public static Decimal ToDecimal(
   uint value
);
[C++]
public: static Decimal ToDecimal(
   unsigned int value
);
[JScript]
public static function ToDecimal(
   value : UInt32
) : Decimal;

Parameters

value
The value to be converted.

Return Value

The value as a Decimal.

Remarks

[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToDecimal Overload List


Convert.ToDecimal (Int64)

Converts an Int64 to a Decimal.

[Visual Basic]
Overloads Public Shared Function ToDecimal( _
   ByVal value As Long _
) As Decimal
[C#]
public static Decimal ToDecimal(
   long value
);
[C++]
public: static Decimal ToDecimal(
   __int64 value
);
[JScript]
public static function ToDecimal(
   value : long
) : Decimal;

Parameters

value
The number to be converted.

Return Value

The value as a Decimal.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToDecimal Overload List


Convert.ToDecimal (UInt64)

Converts a UInt64 to a Decimal.

[Visual Basic]
Overloads Public Shared Function ToDecimal( _
   ByVal value As UInt64 _
) As Decimal
[C#]
public static Decimal ToDecimal(
   ulong value
);
[C++]
public: static Decimal ToDecimal(
   unsigned __int64 value
);
[JScript]
public static function ToDecimal(
   value : UInt64
) : Decimal;

Parameters

value
The value to be converted.

Return Value

The value as a Decimal.

Remarks

[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToDecimal Overload List


Convert.ToDouble

Returns the specified parameter as an 8-byte Double precision floating-point number.

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToDouble(Double) As Double
[C#] public static double ToDouble(double);
[C++] public: static double ToDouble(double);
[JScript] public static function ToDouble(double) : double;

Converts a Decimal to a Double.

[Visual Basic] Overloads Public Shared Function ToDouble(Decimal) As Double
[C#] public static double ToDouble(Decimal);
[C++] public: static double ToDouble(Decimal);
[JScript] public static function ToDouble(Decimal) : double;

Converts a String to a Double.

[Visual Basic] Overloads Public Shared Function ToDouble(String) As Double
[C#] public static double ToDouble(String);
[C++] public: static double ToDouble(String*);
[JScript] public static function ToDouble(String) : double;

Converts a Single to a Double.

[Visual Basic] Overloads Public Shared Function ToDouble(Single) As Double
[C#] public static double ToDouble(float);
[C++] public: static double ToDouble(float);
[JScript] public static function ToDouble(float) : double;

Converts a UInt32 to a Double.

[Visual Basic] Overloads Public Shared Function ToDouble(UInt32) As Double
[C#] public static double ToDouble(uint);
[C++] public: static double ToDouble(unsigned int);
[JScript] public static function ToDouble(UInt32) : double;

Converts an Int64 to a Double.

[Visual Basic] Overloads Public Shared Function ToDouble(Long) As Double
[C#] public static double ToDouble(long);
[C++] public: static double ToDouble(__int64);
[JScript] public static function ToDouble(long) : double;

Converts a UInt64 to a Double.

[Visual Basic] Overloads Public Shared Function ToDouble(UInt64) As Double
[C#] public static double ToDouble(ulong);
[C++] public: static double ToDouble(unsigned __int64);
[JScript] public static function ToDouble(UInt64) : double;

Converts an SByte to a Double.

[Visual Basic] Overloads Public Shared Function ToDouble(SByte) As Double
[C#] public static double ToDouble(sbyte);
[C++] public: static double ToDouble(char);
[JScript] public static function ToDouble(SByte) : double;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToDouble(Object) As Double
[C#] public static double ToDouble(Object);
[C++] public: static double ToDouble(Object*);
[JScript] public static function ToDouble(Object) : double;

Converts an Int32 to a Double.

[Visual Basic] Overloads Public Shared Function ToDouble(Integer) As Double
[C#] public static double ToDouble(int);
[C++] public: static double ToDouble(int);
[JScript] public static function ToDouble(int) : double;

Converts a Byte to a Double.

[Visual Basic] Overloads Public Shared Function ToDouble(Byte) As Double
[C#] public static double ToDouble(byte);
[C++] public: static double ToDouble(unsigned char);
[JScript] public static function ToDouble(Byte) : double;

Converts a UInt16 to a Double.

[Visual Basic] Overloads Public Shared Function ToDouble(UInt16) As Double
[C#] public static double ToDouble(ushort);
[C++] public: static double ToDouble(unsigned short);
[JScript] public static function ToDouble(UInt16) : double;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToDouble(Char) As Double
[C#] public static double ToDouble(char);
[C++] public: static double ToDouble(__wchar_t);
[JScript] public static function ToDouble(Char) : double;

Converts an Int32 to a Double.

[Visual Basic] Overloads Public Shared Function ToDouble(Integer) As Double
[C#] public static double ToDouble(short);
[C++] public: static double ToDouble(short);
[JScript] public static function ToDouble(Int16) : double;

See Also

Convert Class | Convert Members | System Namespace


Convert.ToDouble (Double)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToDouble( _
   ByVal value As Double _
) As Double
[C#]
public static double ToDouble(
   double value
);
[C++]
public: static double ToDouble(
   double value
);
[JScript]
public static function ToDouble(
   value : double
) : double;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToDouble Overload List


Convert.ToDouble (Decimal)

Converts a Decimal to a Double.

[Visual Basic]
Overloads Public Shared Function ToDouble( _
   ByVal value As Decimal _
) As Double
[C#]
public static double ToDouble(
   Decimal value
);
[C++]
public: static double ToDouble(
   Decimal value
);
[JScript]
public static function ToDouble(
   value : Decimal
) : double;

Parameters

value
The number to be converted.

Return Value

The value as a Double.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToDouble Overload List


Convert.ToDouble (String)

Converts a String to a Double.

[Visual Basic]
Overloads Public Shared Function ToDouble( _
   ByVal value As String _
) As Double
[C#]
public static double ToDouble(
   string value
);
[C++]
public: static double ToDouble(
   String* value
);
[JScript]
public static function ToDouble(
   value : String
) : double;

Parameters

value
A string representation of a Double value.

Return Value

The Double with the value represented by value.

Exceptions

Exception Type | Condition
ArgumentException | value is null.
FormatException | value does not contain a representation that can be converted to a Double using the Parse(String) method implemented by that type.
OverflowException | value represents a number that is less than Double.MinValue or greater than Double.MaxValue.

Remarks

Implementation is the same as FromString.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToDouble Overload List


Convert.ToDouble (Single)

Converts a Single to a Double.

[Visual Basic]
Overloads Public Shared Function ToDouble( _
   ByVal value As Single _
) As Double
[C#]
public static double ToDouble(
   float value
);
[C++]
public: static double ToDouble(
   float value
);
[JScript]
public static function ToDouble(
   value : float
) : double;

Parameters

value
The number to be converted.

Return Value

The value as a Double.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToDouble Overload List


Convert.ToDouble (UInt32)

Converts a UInt32 to a Double.

[Visual Basic]
Overloads Public Shared Function ToDouble( _
   ByVal value As UInt32 _
) As Double
[C#]
public static double ToDouble(
   uint value
);
[C++]
public: static double ToDouble(
   unsigned int value
);
[JScript]
public static function ToDouble(
   value : UInt32
) : double;

Parameters

value
the value to be converted.

Return Value

The value as a Double.

Remarks

[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToDouble Overload List


Convert.ToDouble (Int64)

Converts an Int64 to a Double.

[Visual Basic]
Overloads Public Shared Function ToDouble( _
   ByVal value As Long _
) As Double
[C#]
public static double ToDouble(
   long value
);
[C++]
public: static double ToDouble(
   __int64 value
);
[JScript]
public static function ToDouble(
   value : long
) : double;

Parameters

value
The number to be converted.

Return Value

The value as a Double.

Remarks

[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToDouble Overload List


Convert.ToDouble (UInt64)

Converts a UInt64 to a Double.

[Visual Basic]
Overloads Public Shared Function ToDouble( _
   ByVal value As UInt64 _
) As Double
[C#]
public static double ToDouble(
   ulong value
);
[C++]
public: static double ToDouble(
   unsigned __int64 value
);
[JScript]
public static function ToDouble(
   value : UInt64
) : double;

Parameters

value
The value to be converted.

Return Value

The value as a Double.

Remarks

[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToDouble Overload List


Convert.ToDouble (SByte)

Converts an SByte to a Double.

[Visual Basic]
Overloads Public Shared Function ToDouble( _
   ByVal value As SByte _
) As Double
[C#]
public static double ToDouble(
   sbyte value
);
[C++]
public: static double ToDouble(
   char value
);
[JScript]
public static function ToDouble(
   value : SByte
) : double;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToDouble Overload List


Convert.ToDouble (Object)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToDouble( _
   ByVal value As Object _
) As Double
[C#]
public static double ToDouble(
   object value
);
[C++]
public: static double ToDouble(
   Object* value
);
[JScript]
public static function ToDouble(
   value : Object
) : double;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToDouble Overload List


Convert.ToDouble (Int32)

Converts an Int32 to a Double.

[Visual Basic]
Overloads Public Shared Function ToDouble( _
   ByVal value As Integer _
) As Double
[C#]
public static double ToDouble(
   int value
);
[C++]
public: static double ToDouble(
   int value
);
[JScript]
public static function ToDouble(
   value : int
) : double;

Parameters

value
The number to be converted.

Return Value

The value as a Double.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToDouble Overload List


Convert.ToDouble (Byte)

Converts a Byte to a Double.

[Visual Basic]
Overloads Public Shared Function ToDouble( _
   ByVal value As Byte _
) As Double
[C#]
public static double ToDouble(
   byte value
);
[C++]
public: static double ToDouble(
   unsigned char value
);
[JScript]
public static function ToDouble(
   value : Byte
) : double;

Parameters

value
The number to be converted.

Return Value

Returns the value as a Double.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToDouble Overload List


Convert.ToDouble (UInt16)

Converts a UInt16 to a Double.

[Visual Basic]
Overloads Public Shared Function ToDouble( _
   ByVal value As UInt16 _
) As Double
[C#]
public static double ToDouble(
   ushort value
);
[C++]
public: static double ToDouble(
   unsigned short value
);
[JScript]
public static function ToDouble(
   value : UInt16
) : double;

Parameters

value
the value to be converted.

Return Value

The value as a Double.

Remarks

[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToDouble Overload List


Convert.ToDouble (Char)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToDouble( _
   ByVal value As Char _
) As Double
[C#]
public static double ToDouble(
   char value
);
[C++]
public: static double ToDouble(
   __wchar_t value
);
[JScript]
public static function ToDouble(
   value : Char
) : double;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToDouble Overload List


Convert.ToDouble (Int16)

Converts an Int32 to a Double.

[Visual Basic]
Overloads Public Shared Function ToDouble( _
   ByVal value As Short _
) As Double
[C#]
public static double ToDouble(
   short value
);
[C++]
public: static double ToDouble(
   short value
);
[JScript]
public static function ToDouble(
   value : Int16
) : double;

Parameters

value
The number to be converted.

Return Value

The value as a Double.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToDouble Overload List


Convert.ToInt16

Converts a value to a 16-bit signed integer.

Overload List

Converts a specified String to an Int16 in the specified base.

[Visual Basic] Overloads Public Shared Function ToInt16(String, Integer) As Short
[C#] public static short ToInt16(String, int);
[C++] public: static short ToInt16(String*, int);
[JScript] public static function ToInt16(String, int) : Int16;

Converts a Byte to an Int16.

[Visual Basic] Overloads Public Shared Function ToInt16(Byte) As Short
[C#] public static short ToInt16(byte);
[C++] public: static short ToInt16(unsigned char);
[JScript] public static function ToInt16(Byte) : Int16;

Converts a UInt16 to an Int16.

[Visual Basic] Overloads Public Shared Function ToInt16(UInt16) As Short
[C#] public static short ToInt16(ushort);
[C++] public: static short ToInt16(unsigned short);
[JScript] public static function ToInt16(UInt16) : Int16;

Converts an Int32 to an Int16.

[Visual Basic] Overloads Public Shared Function ToInt16(Integer) As Short
[C#] public static short ToInt16(int);
[C++] public: static short ToInt16(int);
[JScript] public static function ToInt16(int) : Int16;

Converts an SByte to an Int16.

[Visual Basic] Overloads Public Shared Function ToInt16(SByte) As Short
[C#] public static short ToInt16(sbyte);
[C++] public: static short ToInt16(char);
[JScript] public static function ToInt16(SByte) : Int16;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToInt16(Object) As Short
[C#] public static short ToInt16(Object);
[C++] public: static short ToInt16(Object*);
[JScript] public static function ToInt16(Object) : Int16;

Converts a Boolean to an Int16.

[Visual Basic] Overloads Public Shared Function ToInt16(Boolean) As Short
[C#] public static short ToInt16(bool);
[C++] public: static short ToInt16(bool);
[JScript] public static function ToInt16(Boolean) : Int16;

Converts a Char to an Int16.

[Visual Basic] Overloads Public Shared Function ToInt16(Char) As Short
[C#] public static short ToInt16(char);
[C++] public: static short ToInt16(__wchar_t);
[JScript] public static function ToInt16(Char) : Int16;

Converts a UInt32 to an Int16.

[Visual Basic] Overloads Public Shared Function ToInt16(UInt32) As Short
[C#] public static short ToInt16(uint);
[C++] public: static short ToInt16(unsigned int);
[JScript] public static function ToInt16(UInt32) : Int16;

Converts a Double to an Int16.

[Visual Basic] Overloads Public Shared Function ToInt16(Double) As Short
[C#] public static short ToInt16(double);
[C++] public: static short ToInt16(double);
[JScript] public static function ToInt16(double) : Int16;

Converts a Single to an Int16.

[Visual Basic] Overloads Public Shared Function ToInt16(Single) As Short
[C#] public static short ToInt16(float);
[C++] public: static short ToInt16(float);
[JScript] public static function ToInt16(float) : Int16;

Converts a String to an Int16.

[Visual Basic] Overloads Public Shared Function ToInt16(String) As Short
[C#] public static short ToInt16(String);
[C++] public: static short ToInt16(String*);
[JScript] public static function ToInt16(String) : Int16;

Converts a Decimal to an Int16.

[Visual Basic] Overloads Public Shared Function ToInt16(Decimal) As Short
[C#] public static short ToInt16(Decimal);
[C++] public: static short ToInt16(Decimal);
[JScript] public static function ToInt16(Decimal) : Int16;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToInt16(Integer) As Short
[C#] public static short ToInt16(short);
[C++] public: static short ToInt16(short);
[JScript] public static function ToInt16(Int16) : Int16;

Converts an Int64 to an Int16.

[Visual Basic] Overloads Public Shared Function ToInt16(Long) As Short
[C#] public static short ToInt16(long);
[C++] public: static short ToInt16(__int64);
[JScript] public static function ToInt16(long) : Int16;

Converts a UInt64 to an Int16.

[Visual Basic] Overloads Public Shared Function ToInt16(UInt64) As Short
[C#] public static short ToInt16(ulong);
[C++] public: static short ToInt16(unsigned __int64);
[JScript] public static function ToInt16(UInt64) : Int16;

See Also

Convert Class | Convert Members | System Namespace


Convert.ToInt16 (String, Int32)

Converts a specified String to an Int16 in the specified base.

[Visual Basic]
Overloads Public Shared Function ToInt16( _
   ByVal value As String, _
   ByVal fromBase As Integer _
) As Short
[C#]
public static short ToInt16(
   string value,
   int fromBase
);
[C++]
public: static short ToInt16(
   String* value,
   int fromBase
);
[JScript]
public static function ToInt16(
   value : String,
   fromBase : int
) : Int16;

Parameters

value
The String to be parsed.
fromBase
The base in which to parse value.

Return Value

The Int16 representation of value as a base base number .

Exceptions

Exception Type | Condition
ArgumentException | fromBase is not 2, 8, 10, or 16.
FormatException | value cannot be parsed as a base fromBase number.
ArgumentNullException | value is null.
OverflowException | The value represented by value is greater than Int16.MaxValue or less than Int16.MinValue.

Remarks

If fromBase is 16, the number may be preceded by "0x"; any other leading or trailing characters cause an error.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt16 Overload List


Convert.ToInt16 (Byte)

Converts a Byte to an Int16.

[Visual Basic]
Overloads Public Shared Function ToInt16( _
   ByVal value As Byte _
) As Short
[C#]
public static short ToInt16(
   byte value
);
[C++]
public: static short ToInt16(
   unsigned char value
);
[JScript]
public static function ToInt16(
   value : Byte
) : Int16;

Parameters

value
The number to be converted.

Return Value

The value as an Int16 .

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt16 Overload List


Convert.ToInt16 (UInt16)

Converts a UInt16 to an Int16.

[Visual Basic]
Overloads Public Shared Function ToInt16( _
   ByVal value As UInt16 _
) As Short
[C#]
public static short ToInt16(
   ushort value
);
[C++]
public: static short ToInt16(
   unsigned short value
);
[JScript]
public static function ToInt16(
   value : UInt16
) : Int16;

Parameters

value
The value to convert.

Return Value

The value as an Int16.

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than Int16.MaxValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt16 Overload List


Convert.ToInt16 (Int32)

Converts an Int32 to an Int16.

[Visual Basic]
Overloads Public Shared Function ToInt16( _
   ByVal value As Integer _
) As Short
[C#]
public static short ToInt16(
   int value
);
[C++]
public: static short ToInt16(
   int value
);
[JScript]
public static function ToInt16(
   value : int
) : Int16;

Parameters

value
The number to be converted.

Return Value

The value as an Int16 .

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than Int16.MaxValue or less than Int16.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt16 Overload List


Convert.ToInt16 (SByte)

Converts an SByte to an Int16.

[Visual Basic]
Overloads Public Shared Function ToInt16( _
   ByVal value As SByte _
) As Short
[C#]
public static short ToInt16(
   sbyte value
);
[C++]
public: static short ToInt16(
   char value
);
[JScript]
public static function ToInt16(
   value : SByte
) : Int16;

Parameters

value
The value to be converted.

Return Value

The value as an Int16.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt16 Overload List


Convert.ToInt16 (Object)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToInt16( _
   ByVal value As Object _
) As Short
[C#]
public static short ToInt16(
   object value
);
[C++]
public: static short ToInt16(
   Object* value
);
[JScript]
public static function ToInt16(
   value : Object
) : Int16;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt16 Overload List


Convert.ToInt16 (Boolean)

Converts a Boolean to an Int16.

[Visual Basic]
Overloads Public Shared Function ToInt16( _
   ByVal value As Boolean _
) As Short
[C#]
public static short ToInt16(
   bool value
);
[C++]
public: static short ToInt16(
   bool value
);
[JScript]
public static function ToInt16(
   value : Boolean
) : Int16;

Parameters

value
The number to be converted.

Return Value

The number 1 if value is true; otherwise, 0.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt16 Overload List


Convert.ToInt16 (Char)

Converts a Char to an Int16.

[Visual Basic]
Overloads Public Shared Function ToInt16( _
   ByVal value As Char _
) As Short
[C#]
public static short ToInt16(
   char value
);
[C++]
public: static short ToInt16(
   __wchar_t value
);
[JScript]
public static function ToInt16(
   value : Char
) : Int16;

Parameters

value
The Boolean value to be converted.

Return Value

The value as an Int16.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt16 Overload List


Convert.ToInt16 (UInt32)

Converts a UInt32 to an Int16.

[Visual Basic]
Overloads Public Shared Function ToInt16( _
   ByVal value As UInt32 _
) As Short
[C#]
public static short ToInt16(
   uint value
);
[C++]
public: static short ToInt16(
   unsigned int value
);
[JScript]
public static function ToInt16(
   value : UInt32
) : Int16;

Parameters

value
The value to convert.

Return Value

The value as an Int16.

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than Int16.MaxValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt16 Overload List


Convert.ToInt16 (Double)

Converts a Double to an Int16.

[Visual Basic]
Overloads Public Shared Function ToInt16( _
   ByVal value As Double _
) As Short
[C#]
public static short ToInt16(
   double value
);
[C++]
public: static short ToInt16(
   double value
);
[JScript]
public static function ToInt16(
   value : double
) : Int16;

Parameters

value
The number to be converted.

Return Value

value rounded to the nearest integer. If value is exactly halfway between two whole numbers, this method returns the the integer that is even (i.e. 4.5 is converted to 4, and 5.5 is converted to 6).

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than Int16.MaxValue or less than Int16.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt16 Overload List


Convert.ToInt16 (Single)

Converts a Single to an Int16.

[Visual Basic]
Overloads Public Shared Function ToInt16( _
   ByVal value As Single _
) As Short
[C#]
public static short ToInt16(
   float value
);
[C++]
public: static short ToInt16(
   float value
);
[JScript]
public static function ToInt16(
   value : float
) : Int16;

Parameters

value
The number to be converted.

Return Value

value rounded to the nearest integer. If value is exactly halfway between two whole numbers, this method returns the the integer that is even (i.e. 4.5 is converted to 4, and 5.5 is converted to 6).

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than Int16.MaxValue or less than Int16.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt16 Overload List


Convert.ToInt16 (String)

Converts a String to an Int16.

[Visual Basic]
Overloads Public Shared Function ToInt16( _
   ByVal value As String _
) As Short
[C#]
public static short ToInt16(
   string value
);
[C++]
public: static short ToInt16(
   String* value
);
[JScript]
public static function ToInt16(
   value : String
) : Int16;

Parameters

value
A string representation of an Int16 value.

Return Value

An Int16 with the value represented by value.

Exceptions

Exception Type | Condition
ArgumentException | Iif value is null.
FormatException | Is thrown if value cannot be parsed or the value represented is greater than Int16.MaxValue or less than Int16.MinValue.
OverflowException | If value represents a number that is less than Int16.MinValue or greater than Int16.MaxValue. Note that if the beginning of the string value contains a properly formatted numerical value that will result in an overflow and, in addition, the end of the string is improperly formed, it cannot be determined whether an OverflowException or a FormatException will be thrown. This has been implemented this way for performance reasons.

Remarks

Default String to Integer Parsing. value is parsed as a decimal unless it is preceded by 0x, in which case it is parsed a hexadecimal number. White space or trailing characters will cause a FormatException.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt16 Overload List


Convert.ToInt16 (Decimal)

Converts a Decimal to an Int16.

[Visual Basic]
Overloads Public Shared Function ToInt16( _
   ByVal value As Decimal _
) As Short
[C#]
public static short ToInt16(
   Decimal value
);
[C++]
public: static short ToInt16(
   Decimal value
);
[JScript]
public static function ToInt16(
   value : Decimal
) : Int16;

Parameters

value
The number to be converted.

Return Value

value rounded to the nearest integer. If value is exactly halfway between two whole numbers, this method returns the the integer that is even (i.e. 4.5 is converted to 4, and 5.5 is converted to 6).

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than Int16.MaxValue or less than Int16.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt16 Overload List


Convert.ToInt16 (Int16)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToInt16( _
   ByVal value As Short _
) As Short
[C#]
public static short ToInt16(
   short value
);
[C++]
public: static short ToInt16(
   short value
);
[JScript]
public static function ToInt16(
   value : Int16
) : Int16;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt16 Overload List


Convert.ToInt16 (Int64)

Converts an Int64 to an Int16.

[Visual Basic]
Overloads Public Shared Function ToInt16( _
   ByVal value As Long _
) As Short
[C#]
public static short ToInt16(
   long value
);
[C++]
public: static short ToInt16(
   __int64 value
);
[JScript]
public static function ToInt16(
   value : long
) : Int16;

Parameters

value
The number to be converted.

Return Value

The value as an Int16 .

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than Int16.MaxValue or less than Int16.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt16 Overload List


Convert.ToInt16 (UInt64)

Converts a UInt64 to an Int16.

[Visual Basic]
Overloads Public Shared Function ToInt16( _
   ByVal value As UInt64 _
) As Short
[C#]
public static short ToInt16(
   ulong value
);
[C++]
public: static short ToInt16(
   unsigned __int64 value
);
[JScript]
public static function ToInt16(
   value : UInt64
) : Int16;

Parameters

value
The value to convert.

Return Value

The value as an Int16.

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than Int16.MaxValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt16 Overload List


Convert.ToInt32

Converts a value to a 32-bit signed integer.

Overload List

Converts a Decimal to an Int32.

[Visual Basic] Overloads Public Shared Function ToInt32(Decimal) As Integer
[C#] public static int ToInt32(Decimal);
[C++] public: static int ToInt32(Decimal);
[JScript] public static function ToInt32(Decimal) : int;

Converts a Double to an Int32.

[Visual Basic] Overloads Public Shared Function ToInt32(Double) As Integer
[C#] public static int ToInt32(double);
[C++] public: static int ToInt32(double);
[JScript] public static function ToInt32(double) : int;

Converts a specified String to an Int32 in the specified base.

[Visual Basic] Overloads Public Shared Function ToInt32(String, Integer) As Integer
[C#] public static int ToInt32(String, int);
[C++] public: static int ToInt32(String*, int);
[JScript] public static function ToInt32(String, int) : int;

Converts a String to an Int32.

[Visual Basic] Overloads Public Shared Function ToInt32(String) As Integer
[C#] public static int ToInt32(String);
[C++] public: static int ToInt32(String*);
[JScript] public static function ToInt32(String) : int;

Converts an SByte to an Int32.

[Visual Basic] Overloads Public Shared Function ToInt32(SByte) As Integer
[C#] public static int ToInt32(sbyte);
[C++] public: static int ToInt32(char);
[JScript] public static function ToInt32(SByte) : int;

Converts a Byte to an Int32.

[Visual Basic] Overloads Public Shared Function ToInt32(Byte) As Integer
[C#] public static int ToInt32(byte);
[C++] public: static int ToInt32(unsigned char);
[JScript] public static function ToInt32(Byte) : int;

Returns a 32-bit, 4-byte signed integer with the converted number.

[Visual Basic] Overloads Public Shared Function ToInt32(Integer) As Integer
[C#] public static int ToInt32(short);
[C++] public: static int ToInt32(short);
[JScript] public static function ToInt32(Int16) : int;

Converts a Boolean value to an Int32.

[Visual Basic] Overloads Public Shared Function ToInt32(Boolean) As Integer
[C#] public static int ToInt32(bool);
[C++] public: static int ToInt32(bool);
[JScript] public static function ToInt32(Boolean) : int;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToInt32(Object) As Integer
[C#] public static int ToInt32(Object);
[C++] public: static int ToInt32(Object*);
[JScript] public static function ToInt32(Object) : int;

Converts a Char to an Int32.

[Visual Basic] Overloads Public Shared Function ToInt32(Char) As Integer
[C#] public static int ToInt32(char);
[C++] public: static int ToInt32(__wchar_t);
[JScript] public static function ToInt32(Char) : int;

Converts an Int64 to an Int32.

[Visual Basic] Overloads Public Shared Function ToInt32(Long) As Integer
[C#] public static int ToInt32(long);
[C++] public: static int ToInt32(__int64);
[JScript] public static function ToInt32(long) : int;

Convert a UInt64 to an Int32.

[Visual Basic] Overloads Public Shared Function ToInt32(UInt64) As Integer
[C#] public static int ToInt32(ulong);
[C++] public: static int ToInt32(unsigned __int64);
[JScript] public static function ToInt32(UInt64) : int;

Converts a Single to an Int32.

[Visual Basic] Overloads Public Shared Function ToInt32(Single) As Integer
[C#] public static int ToInt32(float);
[C++] public: static int ToInt32(float);
[JScript] public static function ToInt32(float) : int;

Convert a UInt16 to an Int32.

[Visual Basic] Overloads Public Shared Function ToInt32(UInt16) As Integer
[C#] public static int ToInt32(ushort);
[C++] public: static int ToInt32(unsigned short);
[JScript] public static function ToInt32(UInt16) : int;

Converts a UInt32 to an Int32.

[Visual Basic] Overloads Public Shared Function ToInt32(UInt32) As Integer
[C#] public static int ToInt32(uint);
[C++] public: static int ToInt32(unsigned int);
[JScript] public static function ToInt32(UInt32) : int;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToInt32(Integer) As Integer
[C#] public static int ToInt32(int);
[C++] public: static int ToInt32(int);
[JScript] public static function ToInt32(int) : int;

See Also

Convert Class | Convert Members | System Namespace


Convert.ToInt32 (Decimal)

Converts a Decimal to an Int32.

[Visual Basic]
Overloads Public Shared Function ToInt32( _
   ByVal value As Decimal _
) As Integer
[C#]
public static int ToInt32(
   Decimal value
);
[C++]
public: static int ToInt32(
   Decimal value
);
[JScript]
public static function ToInt32(
   value : Decimal
) : int;

Parameters

value
The number to be converted.

Return Value

value rounded to the nearest integer. If value is exactly halfway between two whole numbers, this method returns the the integer that is even (i.e. 4.5 is converted to 4, and 5.5 is converted to 6).

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than Int32.MaxValue or less than Int32.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt32 Overload List


Convert.ToInt32 (Double)

Converts a Double to an Int32.

[Visual Basic]
Overloads Public Shared Function ToInt32( _
   ByVal value As Double _
) As Integer
[C#]
public static int ToInt32(
   double value
);
[C++]
public: static int ToInt32(
   double value
);
[JScript]
public static function ToInt32(
   value : double
) : int;

Parameters

value
The number to be converted.

Return Value

value rounded to the nearest integer. If value is exactly halfway between two whole numbers, this method returns the the integer that is even (i.e. 4.5 is converted to 4, and 5.5 is converted to 6).

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than Int32.MaxValue or less than Int32.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt32 Overload List


Convert.ToInt32 (String, Int32)

Converts a specified String to an Int32 in the specified base.

[Visual Basic]
Overloads Public Shared Function ToInt32( _
   ByVal value As String, _
   ByVal fromBase As Integer _
) As Integer
[C#]
public static int ToInt32(
   string value,
   int fromBase
);
[C++]
public: static int ToInt32(
   String* value,
   int fromBase
);
[JScript]
public static function ToInt32(
   value : String,
   fromBase : int
) : int;

Parameters

value
The String to be parsed.
fromBase
The base in which to parse value.

Return Value

The Int32 representation of value as a base base number .

Exceptions

Exception Type | Condition
ArgumentException | fromBase is not 2, 8, 10, or 16.
FormatException | value cannot be parsed as a base fromBase number.
ArgumentNullException | value is null.
OverflowException | The value represented by value is greater than Int32.MaxValue or less than Int32.MinValue.

Remarks

A fromBase value can be only 2, 8, 10, or 16. If fromBase is 16, the number may be preceded by "0x"; any other leading or trailing characters cause an error.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt32 Overload List


Convert.ToInt32 (String)

Converts a String to an Int32.

[Visual Basic]
Overloads Public Shared Function ToInt32( _
   ByVal value As String _
) As Integer
[C#]
public static int ToInt32(
   string value
);
[C++]
public: static int ToInt32(
   String* value
);
[JScript]
public static function ToInt32(
   value : String
) : int;

Parameters

value
A string representation of an Int32 value.

Return Value

An Int32 with the value represented by value .

Exceptions

Exception Type | Condition
ArgumentException | If value is null.
FormatException | Is thrown if value does not contain a reprsentation that can be converted to an Int32 using the Parse(String) method implemented by that type.
OverflowException | if value represents a number that is less than Int32.MinValue or greater than Int32.MaxValue. Note that if the beginning of the string value contains a properly formatted numerical value that will result in an overflow and, in addition, the end of the string is improperly formed, it cannot be determined whether an OverflowException or a FormatException will be thrown. This has been implemented this way for performance reasons.

Remarks

value is parsed as a decimal unless it is preceded by 0x, in which case it is parsed as a hexadecimal number. White space or trailing characters will cause a FormatException.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt32 Overload List


Convert.ToInt32 (SByte)

Converts an SByte to an Int32.

[Visual Basic]
Overloads Public Shared Function ToInt32( _
   ByVal value As SByte _
) As Integer
[C#]
public static int ToInt32(
   sbyte value
);
[C++]
public: static int ToInt32(
   char value
);
[JScript]
public static function ToInt32(
   value : SByte
) : int;

Parameters

value
The value to convert.

Return Value

The value as an Int32.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt32 Overload List


Convert.ToInt32 (Byte)

Converts a Byte to an Int32.

[Visual Basic]
Overloads Public Shared Function ToInt32( _
   ByVal value As Byte _
) As Integer
[C#]
public static int ToInt32(
   byte value
);
[C++]
public: static int ToInt32(
   unsigned char value
);
[JScript]
public static function ToInt32(
   value : Byte
) : int;

Parameters

value
The number to be converted.

Return Value

value as an Int32 .

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt32 Overload List


Convert.ToInt32 (Int16)

Returns a 32-bit, 4-byte signed integer with the converted number.

[Visual Basic]
Overloads Public Shared Function ToInt32( _
   ByVal value As Short _
) As Integer
[C#]
public static int ToInt32(
   short value
);
[C++]
public: static int ToInt32(
   short value
);
[JScript]
public static function ToInt32(
   value : Int16
) : int;

Parameters

value
The number to be converted.

Return Value

value as an Int32 .

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt32 Overload List


Convert.ToInt32 (Boolean)

Converts a Boolean value to an Int32.

[Visual Basic]
Overloads Public Shared Function ToInt32( _
   ByVal value As Boolean _
) As Integer
[C#]
public static int ToInt32(
   bool value
);
[C++]
public: static int ToInt32(
   bool value
);
[JScript]
public static function ToInt32(
   value : Boolean
) : int;

Parameters

value
False

Return Value

The number 1 if value is true; otherwise, 0.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt32 Overload List


Convert.ToInt32 (Object)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToInt32( _
   ByVal value As Object _
) As Integer
[C#]
public static int ToInt32(
   object value
);
[C++]
public: static int ToInt32(
   Object* value
);
[JScript]
public static function ToInt32(
   value : Object
) : int;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt32 Overload List


Convert.ToInt32 (Char)

Converts a Char to an Int32.

[Visual Basic]
Overloads Public Shared Function ToInt32( _
   ByVal value As Char _
) As Integer
[C#]
public static int ToInt32(
   char value
);
[C++]
public: static int ToInt32(
   __wchar_t value
);
[JScript]
public static function ToInt32(
   value : Char
) : int;

Parameters

value
The number to be converted.

Return Value

value as an Int32 .

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt32 Overload List


Convert.ToInt32 (Int64)

Converts an Int64 to an Int32.

[Visual Basic]
Overloads Public Shared Function ToInt32( _
   ByVal value As Long _
) As Integer
[C#]
public static int ToInt32(
   long value
);
[C++]
public: static int ToInt32(
   __int64 value
);
[JScript]
public static function ToInt32(
   value : long
) : int;

Parameters

value
The number to be converted.

Return Value

The value as an Int32 .

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than Int32.MaxValue or less than Int32.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt32 Overload List


Convert.ToInt32 (UInt64)

Convert a UInt64 to an Int32.

[Visual Basic]
Overloads Public Shared Function ToInt32( _
   ByVal value As UInt64 _
) As Integer
[C#]
public static int ToInt32(
   ulong value
);
[C++]
public: static int ToInt32(
   unsigned __int64 value
);
[JScript]
public static function ToInt32(
   value : UInt64
) : int;

Parameters

value
the value to convert.

Return Value

The value as an Int32.

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than Int32.MaxValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt32 Overload List


Convert.ToInt32 (Single)

Converts a Single to an Int32.

[Visual Basic]
Overloads Public Shared Function ToInt32( _
   ByVal value As Single _
) As Integer
[C#]
public static int ToInt32(
   float value
);
[C++]
public: static int ToInt32(
   float value
);
[JScript]
public static function ToInt32(
   value : float
) : int;

Parameters

value
The number to be converted.

Return Value

value rounded to the nearest integer. If value is exactly halfway between two whole numbers, this method returns the the integer that is even (i.e. 4.5 is converted to 4, and 5.5 is converted to 6).

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than Int32.MaxValue or less than Int32.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt32 Overload List


Convert.ToInt32 (UInt16)

Convert a UInt16 to an Int32.

[Visual Basic]
Overloads Public Shared Function ToInt32( _
   ByVal value As UInt16 _
) As Integer
[C#]
public static int ToInt32(
   ushort value
);
[C++]
public: static int ToInt32(
   unsigned short value
);
[JScript]
public static function ToInt32(
   value : UInt16
) : int;

Parameters

value
The value to convert.

Return Value

The value as an Int32.

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than Int32.MaxValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt32 Overload List


Convert.ToInt32 (UInt32)

Converts a UInt32 to an Int32.

[Visual Basic]
Overloads Public Shared Function ToInt32( _
   ByVal value As UInt32 _
) As Integer
[C#]
public static int ToInt32(
   uint value
);
[C++]
public: static int ToInt32(
   unsigned int value
);
[JScript]
public static function ToInt32(
   value : UInt32
) : int;

Parameters

value
The value to convert.

Return Value

The value as an Int32.

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than Int32.MaxValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt32 Overload List


Convert.ToInt32 (Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToInt32( _
   ByVal value As Integer _
) As Integer
[C#]
public static int ToInt32(
   int value
);
[C++]
public: static int ToInt32(
   int value
);
[JScript]
public static function ToInt32(
   value : int
) : int;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt32 Overload List


Convert.ToInt64

Converts a value to a 64-bit signed integer.

Overload List

Converts a UInt32 to an Int64.

[Visual Basic] Overloads Public Shared Function ToInt64(UInt32) As Long
[C#] public static long ToInt64(uint);
[C++] public: static __int64 ToInt64(unsigned int);
[JScript] public static function ToInt64(UInt32) : long;

Converts a UInt64 to an Int64.

[Visual Basic] Overloads Public Shared Function ToInt64(UInt64) As Long
[C#] public static long ToInt64(ulong);
[C++] public: static __int64 ToInt64(unsigned __int64);
[JScript] public static function ToInt64(UInt64) : long;

Converts an Int16 to an Int64.

[Visual Basic] Overloads Public Shared Function ToInt64(Integer) As Long
[C#] public static long ToInt64(short);
[C++] public: static __int64 ToInt64(short);
[JScript] public static function ToInt64(Int16) : long;

Converts a UInt16 to an Int64.

[Visual Basic] Overloads Public Shared Function ToInt64(UInt16) As Long
[C#] public static long ToInt64(ushort);
[C++] public: static __int64 ToInt64(unsigned short);
[JScript] public static function ToInt64(UInt16) : long;

Converts an Int32 to an Int64.

[Visual Basic] Overloads Public Shared Function ToInt64(Integer) As Long
[C#] public static long ToInt64(int);
[C++] public: static __int64 ToInt64(int);
[JScript] public static function ToInt64(int) : long;

Converts a Decimal to an Int64.

[Visual Basic] Overloads Public Shared Function ToInt64(Decimal) As Long
[C#] public static long ToInt64(Decimal);
[C++] public: static __int64 ToInt64(Decimal);
[JScript] public static function ToInt64(Decimal) : long;

Converts a String to an Int64 value.

[Visual Basic] Overloads Public Shared Function ToInt64(String) As Long
[C#] public static long ToInt64(String);
[C++] public: static __int64 ToInt64(String*);
[JScript] public static function ToInt64(String) : long;

Converts a Double to an Int64.

[Visual Basic] Overloads Public Shared Function ToInt64(Double) As Long
[C#] public static long ToInt64(double);
[C++] public: static __int64 ToInt64(double);
[JScript] public static function ToInt64(double) : long;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToInt64(Long) As Long
[C#] public static long ToInt64(long);
[C++] public: static __int64 ToInt64(__int64);
[JScript] public static function ToInt64(long) : long;

Converts a Single to an Int64.

[Visual Basic] Overloads Public Shared Function ToInt64(Single) As Long
[C#] public static long ToInt64(float);
[C++] public: static __int64 ToInt64(float);
[JScript] public static function ToInt64(float) : long;

Converts a Byte to an Int64.

[Visual Basic] Overloads Public Shared Function ToInt64(Byte) As Long
[C#] public static long ToInt64(byte);
[C++] public: static __int64 ToInt64(unsigned char);
[JScript] public static function ToInt64(Byte) : long;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToInt64(Object) As Long
[C#] public static long ToInt64(Object);
[C++] public: static __int64 ToInt64(Object*);
[JScript] public static function ToInt64(Object) : long;

Converts a String to an Int64 in the specified base.

[Visual Basic] Overloads Public Shared Function ToInt64(String, Integer) As Long
[C#] public static long ToInt64(String, int);
[C++] public: static __int64 ToInt64(String*, int);
[JScript] public static function ToInt64(String, int) : long;

Convert a Boolean to an Int64.

[Visual Basic] Overloads Public Shared Function ToInt64(Boolean) As Long
[C#] public static long ToInt64(bool);
[C++] public: static __int64 ToInt64(bool);
[JScript] public static function ToInt64(Boolean) : long;

Converts an SByte to an Int64.

[Visual Basic] Overloads Public Shared Function ToInt64(SByte) As Long
[C#] public static long ToInt64(sbyte);
[C++] public: static __int64 ToInt64(char);
[JScript] public static function ToInt64(SByte) : long;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToInt64(Char) As Long
[C#] public static long ToInt64(char);
[C++] public: static __int64 ToInt64(__wchar_t);
[JScript] public static function ToInt64(Char) : long;

See Also

Convert Class | Convert Members | System Namespace


Convert.ToInt64 (UInt32)

Converts a UInt32 to an Int64.

[Visual Basic]
Overloads Public Shared Function ToInt64( _
   ByVal value As UInt32 _
) As Long
[C#]
public static long ToInt64(
   uint value
);
[C++]
public: static __int64 ToInt64(
   unsigned int value
);
[JScript]
public static function ToInt64(
   value : UInt32
) : long;

Parameters

value
The value to convert.

Return Value

The value as an Int64.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt64 Overload List


Convert.ToInt64 (UInt64)

Converts a UInt64 to an Int64.

[Visual Basic]
Overloads Public Shared Function ToInt64( _
   ByVal value As UInt64 _
) As Long
[C#]
public static long ToInt64(
   ulong value
);
[C++]
public: static __int64 ToInt64(
   unsigned __int64 value
);
[JScript]
public static function ToInt64(
   value : UInt64
) : long;

Parameters

value
The value to convert.

Return Value

The value as an Int64.

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than Int64.MaxValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt64 Overload List


Convert.ToInt64 (Int16)

Converts an Int16 to an Int64.

[Visual Basic]
Overloads Public Shared Function ToInt64( _
   ByVal value As Short _
) As Long
[C#]
public static long ToInt64(
   short value
);
[C++]
public: static __int64 ToInt64(
   short value
);
[JScript]
public static function ToInt64(
   value : Int16
) : long;

Parameters

value
The number to be converted.

Return Value

The converted value.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt64 Overload List


Convert.ToInt64 (UInt16)

Converts a UInt16 to an Int64.

[Visual Basic]
Overloads Public Shared Function ToInt64( _
   ByVal value As UInt16 _
) As Long
[C#]
public static long ToInt64(
   ushort value
);
[C++]
public: static __int64 ToInt64(
   unsigned short value
);
[JScript]
public static function ToInt64(
   value : UInt16
) : long;

Parameters

value
The value to convert.

Return Value

The value as an Int64.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt64 Overload List


Convert.ToInt64 (Int32)

Converts an Int32 to an Int64.

[Visual Basic]
Overloads Public Shared Function ToInt64( _
   ByVal value As Integer _
) As Long
[C#]
public static long ToInt64(
   int value
);
[C++]
public: static __int64 ToInt64(
   int value
);
[JScript]
public static function ToInt64(
   value : int
) : long;

Parameters

value
The number to be converted.

Return Value

value as an Int64 .

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt64 Overload List


Convert.ToInt64 (Decimal)

Converts a Decimal to an Int64.

[Visual Basic]
Overloads Public Shared Function ToInt64( _
   ByVal value As Decimal _
) As Long
[C#]
public static long ToInt64(
   Decimal value
);
[C++]
public: static __int64 ToInt64(
   Decimal value
);
[JScript]
public static function ToInt64(
   value : Decimal
) : long;

Parameters

value
The number to be converted.

Return Value

value rounded to the nearest integer. If value is exactly halfway between two whole numbers, this method returns the the integer that is even (i.e. 4.5 is converted to 4, and 5.5 is converted to 6).

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than Int64.MaxValue or less than Int64.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt64 Overload List


Convert.ToInt64 (String)

Converts a String to an Int64 value.

[Visual Basic]
Overloads Public Shared Function ToInt64( _
   ByVal value As String _
) As Long
[C#]
public static long ToInt64(
   string value
);
[C++]
public: static __int64 ToInt64(
   String* value
);
[JScript]
public static function ToInt64(
   value : String
) : long;

Parameters

value
A string representation of an Int64 value.

Return Value

An Int64 with the value represented by value .

Exceptions

Exception Type | Condition
ArgumentException | If value is null.
FormatException | Is thrown if value cannot be parsed or the value represented is greater than Int64.MaxValue or less than Int64.MinValue.
OverflowException | If value represents a number that is less than Int64.MinValue or greater than Int64.MaxValue. Note that if the beginning of the string value contains a properly formatted numerical value that will result in an overflow and, in addition, the end of the string is improperly formed, it cannot be determined whether an OverflowException or a FormatException will be thrown. This has been implemented this way for performance reasons.

Remarks

value is parsed as a decimal unless it is preceded by 0x, in which case it is parsed as a hexadecimal number. White space or trailing characters will cause a FormatException. The implementation is provided by FromString.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt64 Overload List


Convert.ToInt64 (Double)

Converts a Double to an Int64.

[Visual Basic]
Overloads Public Shared Function ToInt64( _
   ByVal value As Double _
) As Long
[C#]
public static long ToInt64(
   double value
);
[C++]
public: static __int64 ToInt64(
   double value
);
[JScript]
public static function ToInt64(
   value : double
) : long;

Parameters

value
The number to be converted.

Return Value

value rounded to the nearest integer. If value is exactly halfway between two whole numbers, this method returns the the integer that is even (i.e. 4.5 is converted to 4, and 5.5 is converted to 6).

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than Int64.MaxValue or less than Int64.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt64 Overload List


Convert.ToInt64 (Int64)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToInt64( _
   ByVal value As Long _
) As Long
[C#]
public static long ToInt64(
   long value
);
[C++]
public: static __int64 ToInt64(
   __int64 value
);
[JScript]
public static function ToInt64(
   value : long
) : long;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt64 Overload List


Convert.ToInt64 (Single)

Converts a Single to an Int64.

[Visual Basic]
Overloads Public Shared Function ToInt64( _
   ByVal value As Single _
) As Long
[C#]
public static long ToInt64(
   float value
);
[C++]
public: static __int64 ToInt64(
   float value
);
[JScript]
public static function ToInt64(
   value : float
) : long;

Parameters

value
The number to be converted.

Return Value

value rounded to the nearest integer. If value is exactly halfway between two whole numbers, this method returns the the integer that is even (i.e. 4.5 is converted to 4, and 5.5 is converted to 6).

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than Int64.MaxValue or less than Int64.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt64 Overload List


Convert.ToInt64 (Byte)

Converts a Byte to an Int64.

[Visual Basic]
Overloads Public Shared Function ToInt64( _
   ByVal value As Byte _
) As Long
[C#]
public static long ToInt64(
   byte value
);
[C++]
public: static __int64 ToInt64(
   unsigned char value
);
[JScript]
public static function ToInt64(
   value : Byte
) : long;

Parameters

value
the value to convert.

Return Value

value as an Int64 .

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt64 Overload List


Convert.ToInt64 (Object)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToInt64( _
   ByVal value As Object _
) As Long
[C#]
public static long ToInt64(
   object value
);
[C++]
public: static __int64 ToInt64(
   Object* value
);
[JScript]
public static function ToInt64(
   value : Object
) : long;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt64 Overload List


Convert.ToInt64 (String, Int32)

Converts a String to an Int64 in the specified base.

[Visual Basic]
Overloads Public Shared Function ToInt64( _
   ByVal value As String, _
   ByVal fromBase As Integer _
) As Long
[C#]
public static long ToInt64(
   string value,
   int fromBase
);
[C++]
public: static __int64 ToInt64(
   String* value,
   int fromBase
);
[JScript]
public static function ToInt64(
   value : String,
   fromBase : int
) : long;

Parameters

value
The String to be parsed.
fromBase
The base in which to parse value.

Return Value

The Int64 representation of value as a base base .

Exceptions

Exception Type | Condition
ArgumentException | fromBase is not 2, 8, 10, or 16.
FormatException | value cannot be parsed as a base fromBase number.
ArgumentNullException | value is null.
OverflowException | The value represented by value is greater than Int64.MaxValue or less than Int64.MinValue.

Remarks

A fromBase value can be only 2, 8, 10, or 16. If fromBase is 16, the number may be preceded by "0x"; any other leading or trailing characters cause an error.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt64 Overload List


Convert.ToInt64 (Boolean)

Convert a Boolean to an Int64.

[Visual Basic]
Overloads Public Shared Function ToInt64( _
   ByVal value As Boolean _
) As Long
[C#]
public static long ToInt64(
   bool value
);
[C++]
public: static __int64 ToInt64(
   bool value
);
[JScript]
public static function ToInt64(
   value : Boolean
) : long;

Parameters

value
The value to convert.

Return Value

The number 1 if value is true; otherwise, 0.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt64 Overload List


Convert.ToInt64 (SByte)

Converts an SByte to an Int64.

[Visual Basic]
Overloads Public Shared Function ToInt64( _
   ByVal value As SByte _
) As Long
[C#]
public static long ToInt64(
   sbyte value
);
[C++]
public: static __int64 ToInt64(
   char value
);
[JScript]
public static function ToInt64(
   value : SByte
) : long;

Parameters

value
The value to convert.

Return Value

The value as an Int64.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt64 Overload List


Convert.ToInt64 (Char)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToInt64( _
   ByVal value As Char _
) As Long
[C#]
public static long ToInt64(
   char value
);
[C++]
public: static __int64 ToInt64(
   __wchar_t value
);
[JScript]
public static function ToInt64(
   value : Char
) : long;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToInt64 Overload List


Convert.ToSByte

Converts a value to an 8-bit signed integer.

Overload List

Converts a UInt32 to an SByte.

[Visual Basic] Overloads Public Shared Function ToSByte(UInt32) As SByte
[C#] public static sbyte ToSByte(uint);
[C++] public: static char ToSByte(unsigned int);
[JScript] public static function ToSByte(UInt32) : SByte;

Converts an Int64 to an SByte.

[Visual Basic] Overloads Public Shared Function ToSByte(Long) As SByte
[C#] public static sbyte ToSByte(long);
[C++] public: static char ToSByte(__int64);
[JScript] public static function ToSByte(long) : SByte;

Converts an Int32 to an SByte.

[Visual Basic] Overloads Public Shared Function ToSByte(Integer) As SByte
[C#] public static sbyte ToSByte(int);
[C++] public: static char ToSByte(int);
[JScript] public static function ToSByte(int) : SByte;

Converts an Int16 to an SByte.

[Visual Basic] Overloads Public Shared Function ToSByte(Integer) As SByte
[C#] public static sbyte ToSByte(short);
[C++] public: static char ToSByte(short);
[JScript] public static function ToSByte(Int16) : SByte;

Converts a UInt16 to an SByte.

[Visual Basic] Overloads Public Shared Function ToSByte(UInt16) As SByte
[C#] public static sbyte ToSByte(ushort);
[C++] public: static char ToSByte(unsigned short);
[JScript] public static function ToSByte(UInt16) : SByte;

Converts a Decimal to an SByte.

[Visual Basic] Overloads Public Shared Function ToSByte(Decimal) As SByte
[C#] public static sbyte ToSByte(Decimal);
[C++] public: static char ToSByte(Decimal);
[JScript] public static function ToSByte(Decimal) : SByte;

Converts a String to an SByte.

[Visual Basic] Overloads Public Shared Function ToSByte(String) As SByte
[C#] public static sbyte ToSByte(String);
[C++] public: static char ToSByte(String*);
[JScript] public static function ToSByte(String) : SByte;

Converts a Double to an SByte.

[Visual Basic] Overloads Public Shared Function ToSByte(Double) As SByte
[C#] public static sbyte ToSByte(double);
[C++] public: static char ToSByte(double);
[JScript] public static function ToSByte(double) : SByte;

Converts a UInt64 to an SByte.

[Visual Basic] Overloads Public Shared Function ToSByte(UInt64) As SByte
[C#] public static sbyte ToSByte(ulong);
[C++] public: static char ToSByte(unsigned __int64);
[JScript] public static function ToSByte(UInt64) : SByte;

Converts a Single to an SByte.

[Visual Basic] Overloads Public Shared Function ToSByte(Single) As SByte
[C#] public static sbyte ToSByte(float);
[C++] public: static char ToSByte(float);
[JScript] public static function ToSByte(float) : SByte;

Converts a Byte to an SByte.

[Visual Basic] Overloads Public Shared Function ToSByte(Byte) As SByte
[C#] public static sbyte ToSByte(byte);
[C++] public: static char ToSByte(unsigned char);
[JScript] public static function ToSByte(Byte) : SByte;

Parses the specified String value in the specified base.

[Visual Basic] Overloads Public Shared Function ToSByte(String, Integer) As SByte
[C#] public static sbyte ToSByte(String, int);
[C++] public: static char ToSByte(String*, int);
[JScript] public static function ToSByte(String, int) : SByte;

Converts a Object to an SByte.

[Visual Basic] Overloads Public Shared Function ToSByte(Object) As SByte
[C#] public static sbyte ToSByte(Object);
[C++] public: static char ToSByte(Object*);
[JScript] public static function ToSByte(Object) : SByte;

Converts a Boolean to an SByte.

[Visual Basic] Overloads Public Shared Function ToSByte(Boolean) As SByte
[C#] public static sbyte ToSByte(bool);
[C++] public: static char ToSByte(bool);
[JScript] public static function ToSByte(Boolean) : SByte;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToSByte(Char) As SByte
[C#] public static sbyte ToSByte(char);
[C++] public: static char ToSByte(__wchar_t);
[JScript] public static function ToSByte(Char) : SByte;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToSByte(SByte) As SByte
[C#] public static sbyte ToSByte(sbyte);
[C++] public: static char ToSByte(char);
[JScript] public static function ToSByte(SByte) : SByte;

See Also

Convert Class | Convert Members | System Namespace


Convert.ToSByte (UInt32)

Converts a UInt32 to an SByte.

[Visual Basic]
Overloads Public Shared Function ToSByte( _
   ByVal value As UInt32 _
) As SByte
[C#]
public static sbyte ToSByte(
   uint value
);
[C++]
public: static char ToSByte(
   unsigned int value
);
[JScript]
public static function ToSByte(
   value : UInt32
) : SByte;

Parameters

value
The value to be converted.

Return Value

The value as an SByte.

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than SByte.MaxValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToSByte Overload List


Convert.ToSByte (Int64)

Converts an Int64 to an SByte.

[Visual Basic]
Overloads Public Shared Function ToSByte( _
   ByVal value As Long _
) As SByte
[C#]
public static sbyte ToSByte(
   long value
);
[C++]
public: static char ToSByte(
   __int64 value
);
[JScript]
public static function ToSByte(
   value : long
) : SByte;

Parameters

value
The number to be converted.

Return Value

The value as an SByte .

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than SByte.MaxValue or less than SByte.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToSByte Overload List


Convert.ToSByte (Int32)

Converts an Int32 to an SByte.

[Visual Basic]
Overloads Public Shared Function ToSByte( _
   ByVal value As Integer _
) As SByte
[C#]
public static sbyte ToSByte(
   int value
);
[C++]
public: static char ToSByte(
   int value
);
[JScript]
public static function ToSByte(
   value : int
) : SByte;

Parameters

value
The number to be converted.

Return Value

The value as an SByte .

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than SByte.MaxValue or less than SByte.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToSByte Overload List


Convert.ToSByte (Int16)

Converts an Int16 to an SByte.

[Visual Basic]
Overloads Public Shared Function ToSByte( _
   ByVal value As Short _
) As SByte
[C#]
public static sbyte ToSByte(
   short value
);
[C++]
public: static char ToSByte(
   short value
);
[JScript]
public static function ToSByte(
   value : Int16
) : SByte;

Parameters

value
The number to be converted.

Return Value

The value as an SByte .

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than SByte.MaxValue or less than SByte.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToSByte Overload List


Convert.ToSByte (UInt16)

Converts a UInt16 to an SByte.

[Visual Basic]
Overloads Public Shared Function ToSByte( _
   ByVal value As UInt16 _
) As SByte
[C#]
public static sbyte ToSByte(
   ushort value
);
[C++]
public: static char ToSByte(
   unsigned short value
);
[JScript]
public static function ToSByte(
   value : UInt16
) : SByte;

Parameters

value
The number to be converted.

Return Value

The value as an SByte.

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than SByte.MaxValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToSByte Overload List


Convert.ToSByte (Decimal)

Converts a Decimal to an SByte.

[Visual Basic]
Overloads Public Shared Function ToSByte( _
   ByVal value As Decimal _
) As SByte
[C#]
public static sbyte ToSByte(
   Decimal value
);
[C++]
public: static char ToSByte(
   Decimal value
);
[JScript]
public static function ToSByte(
   value : Decimal
) : SByte;

Parameters

value
The number to be converted.

Return Value

value rounded to the nearest integer. If value is exactly halfway between two whole numbers, this method returns the the integer that is even (i.e. 4.5 is converted to 4, and 5.5 is converted to 6).

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than SByte.MaxValue or less than SByte.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToSByte Overload List


Convert.ToSByte (String)

Converts a String to an SByte.

[Visual Basic]
Overloads Public Shared Function ToSByte( _
   ByVal value As String _
) As SByte
[C#]
public static sbyte ToSByte(
   string value
);
[C++]
public: static char ToSByte(
   String* value
);
[JScript]
public static function ToSByte(
   value : String
) : SByte;

Parameters

value
A String representation of an SByte value.

Return Value

An SByte with the value represented by value.

Exceptions

Exception Type | Condition
ArgumentException | value is null.
FormatException | value does not contain a representation that can be converted to an SByte using the Parse(String) method implemented by that type. value is greater than SByte.MaxValue or less than SByte.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToSByte Overload List


Convert.ToSByte (Double)

Converts a Double to an SByte.

[Visual Basic]
Overloads Public Shared Function ToSByte( _
   ByVal value As Double _
) As SByte
[C#]
public static sbyte ToSByte(
   double value
);
[C++]
public: static char ToSByte(
   double value
);
[JScript]
public static function ToSByte(
   value : double
) : SByte;

Parameters

value
The number to be converted.

Return Value

value rounded to the nearest integer. If value is exactly halfway between two whole numbers, this method returns the the integer that is even (i.e. 4.5 is converted to 4, and 5.5 is converted to 6).

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than SByte.MaxValue or less than SByte.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToSByte Overload List


Convert.ToSByte (UInt64)

Converts a UInt64 to an SByte.

[Visual Basic]
Overloads Public Shared Function ToSByte( _
   ByVal value As UInt64 _
) As SByte
[C#]
public static sbyte ToSByte(
   ulong value
);
[C++]
public: static char ToSByte(
   unsigned __int64 value
);
[JScript]
public static function ToSByte(
   value : UInt64
) : SByte;

Parameters

value
The value to be converted.

Return Value

value as a UInt64.

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than SByte.MaxValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToSByte Overload List


Convert.ToSByte (Single)

Converts a Single to an SByte.

[Visual Basic]
Overloads Public Shared Function ToSByte( _
   ByVal value As Single _
) As SByte
[C#]
public static sbyte ToSByte(
   float value
);
[C++]
public: static char ToSByte(
   float value
);
[JScript]
public static function ToSByte(
   value : float
) : SByte;

Parameters

value
The number to be converted.

Return Value

value rounded to the nearest integer. If value is exactly halfway between two whole numbers, this method returns the the integer that is even (i.e. 4.5 is converted to 4, and 5.5 is converted to 6).

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than SByte.MaxValue or less than SByte.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToSByte Overload List


Convert.ToSByte (Byte)

Converts a Byte to an SByte.

[Visual Basic]
Overloads Public Shared Function ToSByte( _
   ByVal value As Byte _
) As SByte
[C#]
public static sbyte ToSByte(
   byte value
);
[C++]
public: static char ToSByte(
   unsigned char value
);
[JScript]
public static function ToSByte(
   value : Byte
) : SByte;

Parameters

value
The number to be converted.

Return Value

The value as an SByte .

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than SByte.MaxValue or less than SByte.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToSByte Overload List


Convert.ToSByte (String, Int32)

Parses the specified String value in the specified base.

[Visual Basic]
Overloads Public Shared Function ToSByte( _
   ByVal value As String, _
   ByVal fromBase As Integer _
) As SByte
[C#]
public static sbyte ToSByte(
   string value,
   int fromBase
);
[C++]
public: static char ToSByte(
   String* value,
   int fromBase
);
[JScript]
public static function ToSByte(
   value : String,
   fromBase : int
) : SByte;

Parameters

value
The String to be parsed.
fromBase
The base in which to parse value.

Return Value

The SByte representation of value as a base fromBase number.

Exceptions

Exception Type | Condition
ArgumentException | fromBase is not 2, 8, 10, or 16.
FormatException | value cannot be parsed as a base fromBase number.
ArgumentNullException | value is null.
OverflowException | The value represented by value is greater than SByte.MaxValue or less than SByte.MinValue.

Remarks

If fromBase is 16, the number may be preceded by 0x; any other leading or trailing characters cause an error.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToSByte Overload List


Convert.ToSByte (Object)

Converts a Object to an SByte.

[Visual Basic]
Overloads Public Shared Function ToSByte( _
   ByVal value As Object _
) As SByte
[C#]
public static sbyte ToSByte(
   object value
);
[C++]
public: static char ToSByte(
   Object* value
);
[JScript]
public static function ToSByte(
   value : Object
) : SByte;

Parameters

value
The number to be converted.

Return Value

value as an SByte .

Exceptions

Exception Type | Condition
InvalidCastException | if this object cannot be coerced to an SByte.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToSByte Overload List


Convert.ToSByte (Boolean)

Converts a Boolean to an SByte.

[Visual Basic]
Overloads Public Shared Function ToSByte( _
   ByVal value As Boolean _
) As SByte
[C#]
public static sbyte ToSByte(
   bool value
);
[C++]
public: static char ToSByte(
   bool value
);
[JScript]
public static function ToSByte(
   value : Boolean
) : SByte;

Parameters

value
The number to be converted.

Return Value

The number 1 if value is true; otherwise, 0.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToSByte Overload List


Convert.ToSByte (Char)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToSByte( _
   ByVal value As Char _
) As SByte
[C#]
public static sbyte ToSByte(
   char value
);
[C++]
public: static char ToSByte(
   __wchar_t value
);
[JScript]
public static function ToSByte(
   value : Char
) : SByte;

Parameters

value
[To be supplied.]

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than SByte.MaxValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToSByte Overload List


Convert.ToSByte (SByte)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToSByte( _
   ByVal value As SByte _
) As SByte
[C#]
public static sbyte ToSByte(
   sbyte value
);
[C++]
public: static char ToSByte(
   char value
);
[JScript]
public static function ToSByte(
   value : SByte
) : SByte;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToSByte Overload List


Convert.ToSingle

Converts a value to a single-precision floating point number.

Overload List

Converts a UInt32 to a Single.

[Visual Basic] Overloads Public Shared Function ToSingle(UInt32) As Single
[C#] public static float ToSingle(uint);
[C++] public: static float ToSingle(unsigned int);
[JScript] public static function ToSingle(UInt32) : float;

Converts an Int64 to a Single.

[Visual Basic] Overloads Public Shared Function ToSingle(Long) As Single
[C#] public static float ToSingle(long);
[C++] public: static float ToSingle(__int64);
[JScript] public static function ToSingle(long) : float;

Converts a Byte value to a Single.

[Visual Basic] Overloads Public Shared Function ToSingle(UInt16) As Single
[C#] public static float ToSingle(ushort);
[C++] public: static float ToSingle(unsigned short);
[JScript] public static function ToSingle(UInt16) : float;

Converts an Int32 to a Single.

[Visual Basic] Overloads Public Shared Function ToSingle(Integer) As Single
[C#] public static float ToSingle(int);
[C++] public: static float ToSingle(int);
[JScript] public static function ToSingle(int) : float;

Converts a UInt64 to a Single.

[Visual Basic] Overloads Public Shared Function ToSingle(UInt64) As Single
[C#] public static float ToSingle(ulong);
[C++] public: static float ToSingle(unsigned __int64);
[JScript] public static function ToSingle(UInt64) : float;

Converts a Decimal to a Single.

[Visual Basic] Overloads Public Shared Function ToSingle(Decimal) As Single
[C#] public static float ToSingle(Decimal);
[C++] public: static float ToSingle(Decimal);
[JScript] public static function ToSingle(Decimal) : float;

Converts a String to a Single.

[Visual Basic] Overloads Public Shared Function ToSingle(String) As Single
[C#] public static float ToSingle(String);
[C++] public: static float ToSingle(String*);
[JScript] public static function ToSingle(String) : float;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToSingle(Single) As Single
[C#] public static float ToSingle(float);
[C++] public: static float ToSingle(float);
[JScript] public static function ToSingle(float) : float;

Converts a Double to a Single.

[Visual Basic] Overloads Public Shared Function ToSingle(Double) As Single
[C#] public static float ToSingle(double);
[C++] public: static float ToSingle(double);
[JScript] public static function ToSingle(double) : float;

Converts a SByte to a Single.

[Visual Basic] Overloads Public Shared Function ToSingle(SByte) As Single
[C#] public static float ToSingle(sbyte);
[C++] public: static float ToSingle(char);
[JScript] public static function ToSingle(SByte) : float;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToSingle(Object) As Single
[C#] public static float ToSingle(Object);
[C++] public: static float ToSingle(Object*);
[JScript] public static function ToSingle(Object) : float;

Converts a Byte to a Single.

[Visual Basic] Overloads Public Shared Function ToSingle(Byte) As Single
[C#] public static float ToSingle(byte);
[C++] public: static float ToSingle(unsigned char);
[JScript] public static function ToSingle(Byte) : float;

Converts an Int16 to a Single.

[Visual Basic] Overloads Public Shared Function ToSingle(Integer) As Single
[C#] public static float ToSingle(short);
[C++] public: static float ToSingle(short);
[JScript] public static function ToSingle(Int16) : float;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToSingle(Char) As Single
[C#] public static float ToSingle(char);
[C++] public: static float ToSingle(__wchar_t);
[JScript] public static function ToSingle(Char) : float;

See Also

Convert Class | Convert Members | System Namespace


Convert.ToSingle (UInt32)

Converts a UInt32 to a Single.

[Visual Basic]
Overloads Public Shared Function ToSingle( _
   ByVal value As UInt32 _
) As Single
[C#]
public static float ToSingle(
   uint value
);
[C++]
public: static float ToSingle(
   unsigned int value
);
[JScript]
public static function ToSingle(
   value : UInt32
) : float;

Parameters

value
The number to be converted.

Return Value

value as a Single.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToSingle Overload List


Convert.ToSingle (Int64)

Converts an Int64 to a Single.

[Visual Basic]
Overloads Public Shared Function ToSingle( _
   ByVal value As Long _
) As Single
[C#]
public static float ToSingle(
   long value
);
[C++]
public: static float ToSingle(
   __int64 value
);
[JScript]
public static function ToSingle(
   value : long
) : float;

Parameters

value
The number to be converted.

Return Value

Returns the value as a Single.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToSingle Overload List


Convert.ToSingle (UInt16)

Converts a Byte value to a Single.

[Visual Basic]
Overloads Public Shared Function ToSingle( _
   ByVal value As UInt16 _
) As Single
[C#]
public static float ToSingle(
   ushort value
);
[C++]
public: static float ToSingle(
   unsigned short value
);
[JScript]
public static function ToSingle(
   value : UInt16
) : float;

Parameters

value
The UInt16 value to be converted.

Return Value

The value as a String.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToSingle Overload List


Convert.ToSingle (Int32)

Converts an Int32 to a Single.

[Visual Basic]
Overloads Public Shared Function ToSingle( _
   ByVal value As Integer _
) As Single
[C#]
public static float ToSingle(
   int value
);
[C++]
public: static float ToSingle(
   int value
);
[JScript]
public static function ToSingle(
   value : int
) : float;

Parameters

value
The number to be converted.

Return Value

Returns the value as a Single.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToSingle Overload List


Convert.ToSingle (UInt64)

Converts a UInt64 to a Single.

[Visual Basic]
Overloads Public Shared Function ToSingle( _
   ByVal value As UInt64 _
) As Single
[C#]
public static float ToSingle(
   ulong value
);
[C++]
public: static float ToSingle(
   unsigned __int64 value
);
[JScript]
public static function ToSingle(
   value : UInt64
) : float;

Parameters

value
The number to be converted.

Return Value

value as a Single.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToSingle Overload List


Convert.ToSingle (Decimal)

Converts a Decimal to a Single.

[Visual Basic]
Overloads Public Shared Function ToSingle( _
   ByVal value As Decimal _
) As Single
[C#]
public static float ToSingle(
   Decimal value
);
[C++]
public: static float ToSingle(
   Decimal value
);
[JScript]
public static function ToSingle(
   value : Decimal
) : float;

Parameters

value
The number to be converted.

Return Value

Returns the value as a Single.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToSingle Overload List


Convert.ToSingle (String)

Converts a String to a Single.

[Visual Basic]
Overloads Public Shared Function ToSingle( _
   ByVal value As String _
) As Single
[C#]
public static float ToSingle(
   string value
);
[C++]
public: static float ToSingle(
   String* value
);
[JScript]
public static function ToSingle(
   value : String
) : float;

Parameters

value
A string representation of a Single value.

Return Value

Returns the value as a Single.

Exceptions

Exception Type | Condition
ArgumentException | If value is null.
FormatException | If value does not contain a representation that can be converted to a Single using the Parse(String) method implemented by that type.
OverflowException | If value represents a number that is less than Single.MinValue or greater than Single.MaxValue.

Remarks

Implementation is the same as FromString.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToSingle Overload List


Convert.ToSingle (Single)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToSingle( _
   ByVal value As Single _
) As Single
[C#]
public static float ToSingle(
   float value
);
[C++]
public: static float ToSingle(
   float value
);
[JScript]
public static function ToSingle(
   value : float
) : float;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToSingle Overload List


Convert.ToSingle (Double)

Converts a Double to a Single.

[Visual Basic]
Overloads Public Shared Function ToSingle( _
   ByVal value As Double _
) As Single
[C#]
public static float ToSingle(
   double value
);
[C++]
public: static float ToSingle(
   double value
);
[JScript]
public static function ToSingle(
   value : double
) : float;

Parameters

value
The number to be converted.

Return Value

Returns the value as a Single

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than Single.MaxValue or less than Single.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToSingle Overload List


Convert.ToSingle (SByte)

Converts a SByte to a Single.

[Visual Basic]
Overloads Public Shared Function ToSingle( _
   ByVal value As SByte _
) As Single
[C#]
public static float ToSingle(
   sbyte value
);
[C++]
public: static float ToSingle(
   char value
);
[JScript]
public static function ToSingle(
   value : SByte
) : float;

Parameters

value
The number to be converted.

Return Value

The converted value.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToSingle Overload List


Convert.ToSingle (Object)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToSingle( _
   ByVal value As Object _
) As Single
[C#]
public static float ToSingle(
   object value
);
[C++]
public: static float ToSingle(
   Object* value
);
[JScript]
public static function ToSingle(
   value : Object
) : float;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToSingle Overload List


Convert.ToSingle (Byte)

Converts a Byte to a Single.

[Visual Basic]
Overloads Public Shared Function ToSingle( _
   ByVal value As Byte _
) As Single
[C#]
public static float ToSingle(
   byte value
);
[C++]
public: static float ToSingle(
   unsigned char value
);
[JScript]
public static function ToSingle(
   value : Byte
) : float;

Parameters

value
The number to be converted.

Return Value

Returns the value as a Single.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToSingle Overload List


Convert.ToSingle (Int16)

Converts an Int16 to a Single.

[Visual Basic]
Overloads Public Shared Function ToSingle( _
   ByVal value As Short _
) As Single
[C#]
public static float ToSingle(
   short value
);
[C++]
public: static float ToSingle(
   short value
);
[JScript]
public static function ToSingle(
   value : Int16
) : float;

Parameters

value
The number to be converted.

Return Value

Returns the value as a Single.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToSingle Overload List


Convert.ToSingle (Char)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToSingle( _
   ByVal value As Char _
) As Single
[C#]
public static float ToSingle(
   char value
);
[C++]
public: static float ToSingle(
   __wchar_t value
);
[JScript]
public static function ToSingle(
   value : Char
) : float;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToSingle Overload List


Convert.ToString

Converts a value to a string.

Overload List

Converts a Char to a String.

[Visual Basic] Overloads Public Shared Function ToString(Char) As String
[C#] public static string ToString(char);
[C++] public: static String* ToString(__wchar_t);
[JScript] public static function ToString(Char) : String;

Converts an SByte to a String.

[Visual Basic] Overloads Public Shared Function ToString(SByte) As String
[C#] public static string ToString(sbyte);
[C++] public: static String* ToString(char);
[JScript] public static function ToString(SByte) : String;

Returns a String representing the specified number.

[Visual Basic] Overloads Public Shared Function ToString(Boolean) As String
[C#] public static string ToString(bool);
[C++] public: static String* ToString(bool);
[JScript] public static function ToString(Boolean) : String;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToString(Object) As String
[C#] public static string ToString(Object);
[C++] public: static String* ToString(Object*);
[JScript] public static function ToString(Object) : String;

Converts an Int64 to a String.

[Visual Basic] Overloads Public Shared Function ToString(Long) As String
[C#] public static string ToString(long);
[C++] public: static String* ToString(__int64);
[JScript] public static function ToString(long) : String;

Converts a UInt64 to a String.

[Visual Basic] Overloads Public Shared Function ToString(UInt64) As String
[C#] public static string ToString(ulong);
[C++] public: static String* ToString(unsigned __int64);
[JScript] public static function ToString(UInt64) : String;

Returns a String representing the specified number.

[Visual Basic] Overloads Public Shared Function ToString(Single) As String
[C#] public static string ToString(float);
[C++] public: static String* ToString(float);
[JScript] public static function ToString(float) : String;

Converts a UInt32 to a String.

[Visual Basic] Overloads Public Shared Function ToString(UInt32) As String
[C#] public static string ToString(uint);
[C++] public: static String* ToString(unsigned int);
[JScript] public static function ToString(UInt32) : String;

Converts an Int16 to a String.

[Visual Basic] Overloads Public Shared Function ToString(Integer) As String
[C#] public static string ToString(short);
[C++] public: static String* ToString(short);
[JScript] public static function ToString(Int16) : String;

Converts a UInt16 to a String.

[Visual Basic] Overloads Public Shared Function ToString(UInt16) As String
[C#] public static string ToString(ushort);
[C++] public: static String* ToString(unsigned short);
[JScript] public static function ToString(UInt16) : String;

Converts an Int32 to a String.

[Visual Basic] Overloads Public Shared Function ToString(Integer) As String
[C#] public static string ToString(int);
[C++] public: static String* ToString(int);
[JScript] public static function ToString(int) : String;

Converts a Double to a String.

[Visual Basic] Overloads Public Shared Function ToString(Double) As String
[C#] public static string ToString(double);
[C++] public: static String* ToString(double);
[JScript] public static function ToString(double) : String;

Converts a 16-bit signed integer to a string in a specified base.

[Visual Basic] Overloads Public Shared Function ToString(Integer, Integer) As String
[C#] public static string ToString(short, int);
[C++] public: static String* ToString(short, int);
[JScript] public static function ToString(Int16, int) : String;

Converts a 32-bit signed integer to a string using a specified base.

[Visual Basic] Overloads Public Shared Function ToString(Integer, Integer) As String
[C#] public static string ToString(int, int);
[C++] public: static String* ToString(int, int);
[JScript] public static function ToString(int, int) : String;

Converts a 64-bit signed integer to a string using a specified base.

[Visual Basic] Overloads Public Shared Function ToString(Long, Integer) As String
[C#] public static string ToString(long, int);
[C++] public: static String* ToString(__int64, int);
[JScript] public static function ToString(long, int) : String;

Converts an 8-bit unsigned integer to a string in a specified base.

[Visual Basic] Overloads Public Shared Function ToString(Byte, Integer) As String
[C#] public static string ToString(byte, int);
[C++] public: static String* ToString(unsigned char, int);
[JScript] public static function ToString(Byte, int) : String;

Converts a Decimal to a String.

[Visual Basic] Overloads Public Shared Function ToString(Decimal) As String
[C#] public static string ToString(Decimal);
[C++] public: static String* ToString(Decimal);
[JScript] public static function ToString(Decimal) : String;

Converts a DateTime to a String.

[Visual Basic] Overloads Public Shared Function ToString(DateTime) As String
[C#] public static string ToString(DateTime);
[C++] public: static String* ToString(DateTime);
[JScript] public static function ToString(DateTime) : String;

Converts a TimeSpan to a String.

[Visual Basic] Overloads Public Shared Function ToString(TimeSpan) As String
[C#] public static string ToString(TimeSpan);
[C++] public: static String* ToString(TimeSpan);
[JScript] public static function ToString(TimeSpan) : String;

Converts a Byte to a String.

[Visual Basic] Overloads Public Shared Function ToString(Byte) As String
[C#] public static string ToString(byte);
[C++] public: static String* ToString(unsigned char);
[JScript] public static function ToString(Byte) : String;

See Also

Convert Class | Convert Members | System Namespace


Convert.ToString (Char)

Converts a Char to a String.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As Char _
) As String
[C#]
public static string ToString(
   char value
);
[C++]
public: static String* ToString(
   __wchar_t value
);
[JScript]
public static function ToString(
   value : Char
) : String;

Parameters

value
The Char to be converted.

Return Value

value as a String .

Remarks

Implementation is the same as ToString.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToString Overload List


Convert.ToString (SByte)

Converts an SByte to a String.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As SByte _
) As String
[C#]
public static string ToString(
   sbyte value
);
[C++]
public: static String* ToString(
   char value
);
[JScript]
public static function ToString(
   value : SByte
) : String;

Parameters

value
The value to convert.

Return Value

value as a String.

Remarks

[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToString Overload List


Convert.ToString (Boolean)

Returns a String representing the specified number.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As Boolean _
) As String
[C#]
public static string ToString(
   bool value
);
[C++]
public: static String* ToString(
   bool value
);
[JScript]
public static function ToString(
   value : Boolean
) : String;

Parameters

value
The Boolean to be converted.

Return Value

value as a String .

Remarks

Implementation is the same as ToString.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToString Overload List


Convert.ToString (Object)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As Object _
) As String
[C#]
public static string ToString(
   object value
);
[C++]
public: static String* ToString(
   Object* value
);
[JScript]
public static function ToString(
   value : Object
) : String;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToString Overload List


Convert.ToString (Int64)

Converts an Int64 to a String.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As Long _
) As String
[C#]
public static string ToString(
   long value
);
[C++]
public: static String* ToString(
   __int64 value
);
[JScript]
public static function ToString(
   value : long
) : String;

Parameters

value
The number to be converted.

Return Value

value as a String .

Remarks

Implementation is the same as ToString.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToString Overload List


Convert.ToString (UInt64)

Converts a UInt64 to a String.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As UInt64 _
) As String
[C#]
public static string ToString(
   ulong value
);
[C++]
public: static String* ToString(
   unsigned __int64 value
);
[JScript]
public static function ToString(
   value : UInt64
) : String;

Parameters

value
The number to convert.

Return Value

value as a String.

Remarks

Implementation is the same as ToString.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToString Overload List


Convert.ToString (Single)

Returns a String representing the specified number.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As Single _
) As String
[C#]
public static string ToString(
   float value
);
[C++]
public: static String* ToString(
   float value
);
[JScript]
public static function ToString(
   value : float
) : String;

Parameters

value
The number to be converted.

Return Value

value as a String .

Remarks

Implementation is the same as ToString.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToString Overload List


Convert.ToString (UInt32)

Converts a UInt32 to a String.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As UInt32 _
) As String
[C#]
public static string ToString(
   uint value
);
[C++]
public: static String* ToString(
   unsigned int value
);
[JScript]
public static function ToString(
   value : UInt32
) : String;

Parameters

value
The number to convert.

Return Value

value as a String.

Remarks

Implementation is the same as ToString.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToString Overload List


Convert.ToString (Int16)

Converts an Int16 to a String.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As Short _
) As String
[C#]
public static string ToString(
   short value
);
[C++]
public: static String* ToString(
   short value
);
[JScript]
public static function ToString(
   value : Int16
) : String;

Parameters

value
The number to be converted.

Return Value

The converted value.

Remarks

Implementation is the same as ToString.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToString Overload List


Convert.ToString (UInt16)

Converts a UInt16 to a String.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As UInt16 _
) As String
[C#]
public static string ToString(
   ushort value
);
[C++]
public: static String* ToString(
   unsigned short value
);
[JScript]
public static function ToString(
   value : UInt16
) : String;

Parameters

value
The number to convert.

Return Value

value as a String.

Remarks

Implementation is the same as ToString.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToString Overload List


Convert.ToString (Int32)

Converts an Int32 to a String.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As Integer _
) As String
[C#]
public static string ToString(
   int value
);
[C++]
public: static String* ToString(
   int value
);
[JScript]
public static function ToString(
   value : int
) : String;

Parameters

value
The number to be converted.

Return Value

The converted value.

Remarks

Implementation is the same as ToString.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToString Overload List


Convert.ToString (Double)

Converts a Double to a String.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As Double _
) As String
[C#]
public static string ToString(
   double value
);
[C++]
public: static String* ToString(
   double value
);
[JScript]
public static function ToString(
   value : double
) : String;

Parameters

value
The number to be converted.

Return Value

The converted value.

Remarks

Implementation is the same as ToString.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToString Overload List


Convert.ToString (Int16, Int32)

Converts a 16-bit signed integer to a string in a specified base.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As Short, _
   ByVal toBase As Integer _
) As String
[C#]
public static string ToString(
   short value,
   int toBase
);
[C++]
public: static String* ToString(
   short value,
   int toBase
);
[JScript]
public static function ToString(
   value : Int16,
   toBase : int
) : String;

Parameters

value
The value to be converted.
toBase
[To be supplied.]

Return Value

The converted value.

Exceptions

Exception Type | Condition
ArgumentException | if fromBase is not 2, 8, 10, or 16.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToString Overload List


Convert.ToString (Int32, Int32)

Converts a 32-bit signed integer to a string using a specified base.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As Integer, _
   ByVal toBase As Integer _
) As String
[C#]
public static string ToString(
   int value,
   int toBase
);
[C++]
public: static String* ToString(
   int value,
   int toBase
);
[JScript]
public static function ToString(
   value : int,
   toBase : int
) : String;

Parameters

value
The value to be converted.
toBase
[To be supplied.]

Return Value

The converted value.

Exceptions

Exception Type | Condition
ArgumentException | if fromBase is not 2, 8, 10, or 16.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToString Overload List


Convert.ToString (Int64, Int32)

Converts a 64-bit signed integer to a string using a specified base.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As Long, _
   ByVal toBase As Integer _
) As String
[C#]
public static string ToString(
   long value,
   int toBase
);
[C++]
public: static String* ToString(
   __int64 value,
   int toBase
);
[JScript]
public static function ToString(
   value : long,
   toBase : int
) : String;

Parameters

value
The value to be converted.
toBase
[To be supplied.]

Return Value

The converted value.

Exceptions

Exception Type | Condition
ArgumentException | if fromBase is not 2, 8, 10, or 16.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToString Overload List


Convert.ToString (Byte, Int32)

Converts an 8-bit unsigned integer to a string in a specified base.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As Byte, _
   ByVal toBase As Integer _
) As String
[C#]
public static string ToString(
   byte value,
   int toBase
);
[C++]
public: static String* ToString(
   unsigned char value,
   int toBase
);
[JScript]
public static function ToString(
   value : Byte,
   toBase : int
) : String;

Parameters

value
The value to be converted.
toBase
[To be supplied.]

Return Value

The converted value.

Exceptions

Exception Type | Condition
ArgumentException | if fromBase is not 2, 8, 10, or 16.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToString Overload List


Convert.ToString (Decimal)

Converts a Decimal to a String.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As Decimal _
) As String
[C#]
public static string ToString(
   Decimal value
);
[C++]
public: static String* ToString(
   Decimal value
);
[JScript]
public static function ToString(
   value : Decimal
) : String;

Parameters

value
The number to be converted.

Return Value

The converted value.

Remarks

Implementation is same as ToString.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToString Overload List


Convert.ToString (DateTime)

Converts a DateTime to a String.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As DateTime _
) As String
[C#]
public static string ToString(
   DateTime value
);
[C++]
public: static String* ToString(
   DateTime value
);
[JScript]
public static function ToString(
   value : DateTime
) : String;

Parameters

value
The value to be converted.

Return Value

value as a String.

Remarks

[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToString Overload List


Convert.ToString (TimeSpan)

Converts a TimeSpan to a String.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As TimeSpan _
) As String
[C#]
public static string ToString(
   TimeSpan value
);
[C++]
public: static String* ToString(
   TimeSpan value
);
[JScript]
public static function ToString(
   value : TimeSpan
) : String;

Parameters

value
The value to convert.

Return Value

value as a String.

Remarks

[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToString Overload List


Convert.ToString (Byte)

Converts a Byte to a String.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As Byte _
) As String
[C#]
public static string ToString(
   byte value
);
[C++]
public: static String* ToString(
   unsigned char value
);
[JScript]
public static function ToString(
   value : Byte
) : String;

Parameters

value
The Byte to be converted.

Return Value

The converted value.

Remarks

Implementation is the same as ToString.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToString Overload List


Convert.ToUInt16

Converts a value to a 16-bit unsigned integer.

Overload List

Converts a String to a UInt16.

[Visual Basic] Overloads Public Shared Function ToUInt16(String) As UInt16
[C#] public static ushort ToUInt16(String);
[C++] public: static unsigned short ToUInt16(String*);
[JScript] public static function ToUInt16(String) : UInt16;

Parses a specified value in a specified base.

[Visual Basic] Overloads Public Shared Function ToUInt16(String, Integer) As UInt16
[C#] public static ushort ToUInt16(String, int);
[C++] public: static unsigned short ToUInt16(String*, int);
[JScript] public static function ToUInt16(String, int) : UInt16;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToUInt16(UInt16) As UInt16
[C#] public static ushort ToUInt16(ushort);
[C++] public: static unsigned short ToUInt16(unsigned short);
[JScript] public static function ToUInt16(UInt16) : UInt16;

Converts a UInt32 to a UInt16.

[Visual Basic] Overloads Public Shared Function ToUInt16(UInt32) As UInt16
[C#] public static ushort ToUInt16(uint);
[C++] public: static unsigned short ToUInt16(unsigned int);
[JScript] public static function ToUInt16(UInt32) : UInt16;

Converts a Single to a UInt16.

[Visual Basic] Overloads Public Shared Function ToUInt16(Single) As UInt16
[C#] public static ushort ToUInt16(float);
[C++] public: static unsigned short ToUInt16(float);
[JScript] public static function ToUInt16(float) : UInt16;

Converts a Double to a UInt16.

[Visual Basic] Overloads Public Shared Function ToUInt16(Double) As UInt16
[C#] public static ushort ToUInt16(double);
[C++] public: static unsigned short ToUInt16(double);
[JScript] public static function ToUInt16(double) : UInt16;

Converts an Int64 to a UInt16.

[Visual Basic] Overloads Public Shared Function ToUInt16(Long) As UInt16
[C#] public static ushort ToUInt16(long);
[C++] public: static unsigned short ToUInt16(__int64);
[JScript] public static function ToUInt16(long) : UInt16;

Converts a UInt64 to a UInt16.

[Visual Basic] Overloads Public Shared Function ToUInt16(UInt64) As UInt16
[C#] public static ushort ToUInt16(ulong);
[C++] public: static unsigned short ToUInt16(unsigned __int64);
[JScript] public static function ToUInt16(UInt64) : UInt16;

Converts a Char to a UInt32.

[Visual Basic] Overloads Public Shared Function ToUInt16(Char) As UInt16
[C#] public static ushort ToUInt16(char);
[C++] public: static unsigned short ToUInt16(__wchar_t);
[JScript] public static function ToUInt16(Char) : UInt16;

Converts a Decimal to a UInt16.

[Visual Basic] Overloads Public Shared Function ToUInt16(Decimal) As UInt16
[C#] public static ushort ToUInt16(Decimal);
[C++] public: static unsigned short ToUInt16(Decimal);
[JScript] public static function ToUInt16(Decimal) : UInt16;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToUInt16(Object) As UInt16
[C#] public static ushort ToUInt16(Object);
[C++] public: static unsigned short ToUInt16(Object*);
[JScript] public static function ToUInt16(Object) : UInt16;

Converts a Boolean to a UInt16.

[Visual Basic] Overloads Public Shared Function ToUInt16(Boolean) As UInt16
[C#] public static ushort ToUInt16(bool);
[C++] public: static unsigned short ToUInt16(bool);
[JScript] public static function ToUInt16(Boolean) : UInt16;

Converts an Int16 to a UInt16.

[Visual Basic] Overloads Public Shared Function ToUInt16(Integer) As UInt16
[C#] public static ushort ToUInt16(short);
[C++] public: static unsigned short ToUInt16(short);
[JScript] public static function ToUInt16(Int16) : UInt16;

Converts an Int32 to a UInt16.

[Visual Basic] Overloads Public Shared Function ToUInt16(Integer) As UInt16
[C#] public static ushort ToUInt16(int);
[C++] public: static unsigned short ToUInt16(int);
[JScript] public static function ToUInt16(int) : UInt16;

Converts an SByte to a UInt16.

[Visual Basic] Overloads Public Shared Function ToUInt16(SByte) As UInt16
[C#] public static ushort ToUInt16(sbyte);
[C++] public: static unsigned short ToUInt16(char);
[JScript] public static function ToUInt16(SByte) : UInt16;

Converts a Byte to a UInt16.

[Visual Basic] Overloads Public Shared Function ToUInt16(Byte) As UInt16
[C#] public static ushort ToUInt16(byte);
[C++] public: static unsigned short ToUInt16(unsigned char);
[JScript] public static function ToUInt16(Byte) : UInt16;

See Also

Convert Class | Convert Members | System Namespace


Convert.ToUInt16 (String)

Converts a String to a UInt16.

[Visual Basic]
Overloads Public Shared Function ToUInt16( _
   ByVal value As String _
) As UInt16
[C#]
public static ushort ToUInt16(
   string value
);
[C++]
public: static unsigned short ToUInt16(
   String* value
);
[JScript]
public static function ToUInt16(
   value : String
) : UInt16;

Parameters

value
The number to be converted.

Return Value

The converted value.

Exceptions

Exception Type | Condition
ArgumentException | If value is null.
FormatException | Is thrown if value cannot be parsed or the value represented is greater than UInt32.MaxValue or less than UInt32.MinValue.
OverflowException | If value represents a number that is less than UInt32.MinValue or greater than UInt32.MaxValue. Note that if the beginning of the string value contains a properly formatted numerical value that will result in an overflow and, in addition, the end of the string is improperly formed, it cannot be determined whether an OverflowException or a FormatException will be thrown. This has been implemented this way for performance reasons.

Remarks

The implementation is the same as FromString.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt16 Overload List


Convert.ToUInt16 (String, Int32)

Parses a specified value in a specified base.

[Visual Basic]
Overloads Public Shared Function ToUInt16( _
   ByVal value As String, _
   ByVal fromBase As Integer _
) As UInt16
[C#]
public static ushort ToUInt16(
   string value,
   int fromBase
);
[C++]
public: static unsigned short ToUInt16(
   String* value,
   int fromBase
);
[JScript]
public static function ToUInt16(
   value : String,
   fromBase : int
) : UInt16;

Parameters

value
The String to be parsed.
fromBase
The base in which to parse value.

Return Value

The UInt16 representation of value as a base fromBase number .

Exceptions

Exception Type | Condition
ArgumentException | fromBase is not 2, 8, 10, or 16.
FormatException | value cannot be parsed as a base fromBase number.
ArgumentNullException | value is null.
OverflowException | The value represented by value is greater than UInt16.MaxValue or less than UInt16.MinValue.

Remarks

If fromBase is 16, the number may be preceded by "0x"; any other leading or trailing characters cause an error.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt16 Overload List


Convert.ToUInt16 (UInt16)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToUInt16( _
   ByVal value As UInt16 _
) As UInt16
[C#]
public static ushort ToUInt16(
   ushort value
);
[C++]
public: static unsigned short ToUInt16(
   unsigned short value
);
[JScript]
public static function ToUInt16(
   value : UInt16
) : UInt16;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt16 Overload List


Convert.ToUInt16 (UInt32)

Converts a UInt32 to a UInt16.

[Visual Basic]
Overloads Public Shared Function ToUInt16( _
   ByVal value As UInt32 _
) As UInt16
[C#]
public static ushort ToUInt16(
   uint value
);
[C++]
public: static unsigned short ToUInt16(
   unsigned int value
);
[JScript]
public static function ToUInt16(
   value : UInt32
) : UInt16;

Parameters

value
The number to be converted.

Return Value

The converted value.

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than UInt16.MaxValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt16 Overload List


Convert.ToUInt16 (Single)

Converts a Single to a UInt16.

[Visual Basic]
Overloads Public Shared Function ToUInt16( _
   ByVal value As Single _
) As UInt16
[C#]
public static ushort ToUInt16(
   float value
);
[C++]
public: static unsigned short ToUInt16(
   float value
);
[JScript]
public static function ToUInt16(
   value : float
) : UInt16;

Parameters

value
The number to be converted.

Return Value

value rounded to the nearest integer. If value is exactly halfway between two whole numbers, this method returns the the integer that is even (i.e. 4.5 is converted to 4, and 5.5 is converted to 6).

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than UInt16.MaxValue or less than UInt16.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt16 Overload List


Convert.ToUInt16 (Double)

Converts a Double to a UInt16.

[Visual Basic]
Overloads Public Shared Function ToUInt16( _
   ByVal value As Double _
) As UInt16
[C#]
public static ushort ToUInt16(
   double value
);
[C++]
public: static unsigned short ToUInt16(
   double value
);
[JScript]
public static function ToUInt16(
   value : double
) : UInt16;

Parameters

value
The number to be converted.

Return Value

value rounded to the nearest integer. If value is exactly halfway between two whole numbers, this method returns the the integer that is even (i.e. 4.5 is converted to 4, and 5.5 is converted to 6).

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than UInt16.MaxValue or less than UInt16.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt16 Overload List


Convert.ToUInt16 (Int64)

Converts an Int64 to a UInt16.

[Visual Basic]
Overloads Public Shared Function ToUInt16( _
   ByVal value As Long _
) As UInt16
[C#]
public static ushort ToUInt16(
   long value
);
[C++]
public: static unsigned short ToUInt16(
   __int64 value
);
[JScript]
public static function ToUInt16(
   value : long
) : UInt16;

Parameters

value
The number to be converted.

Return Value

The converted value.

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than UInt16.MaxValue or less than UInt16.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt16 Overload List


Convert.ToUInt16 (UInt64)

Converts a UInt64 to a UInt16.

[Visual Basic]
Overloads Public Shared Function ToUInt16( _
   ByVal value As UInt64 _
) As UInt16
[C#]
public static ushort ToUInt16(
   ulong value
);
[C++]
public: static unsigned short ToUInt16(
   unsigned __int64 value
);
[JScript]
public static function ToUInt16(
   value : UInt64
) : UInt16;

Parameters

value
The number to be converted.

Return Value

The converted value.

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than UInt16.MaxValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt16 Overload List


Convert.ToUInt16 (Char)

Converts a Char to a UInt32.

[Visual Basic]
Overloads Public Shared Function ToUInt16( _
   ByVal value As Char _
) As UInt16
[C#]
public static ushort ToUInt16(
   char value
);
[C++]
public: static unsigned short ToUInt16(
   __wchar_t value
);
[JScript]
public static function ToUInt16(
   value : Char
) : UInt16;

Parameters

value
The number to be converted.

Return Value

The converted value.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt16 Overload List


Convert.ToUInt16 (Decimal)

Converts a Decimal to a UInt16.

[Visual Basic]
Overloads Public Shared Function ToUInt16( _
   ByVal value As Decimal _
) As UInt16
[C#]
public static ushort ToUInt16(
   Decimal value
);
[C++]
public: static unsigned short ToUInt16(
   Decimal value
);
[JScript]
public static function ToUInt16(
   value : Decimal
) : UInt16;

Parameters

value
The number to be converted.

Return Value

value rounded to the nearest integer. If value is exactly halfway between two whole numbers, this method returns the the integer that is even (i.e. 4.5 is converted to 4, and 5.5 is converted to 6).

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than UInt16.MaxValue or less than UInt16.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt16 Overload List


Convert.ToUInt16 (Object)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToUInt16( _
   ByVal value As Object _
) As UInt16
[C#]
public static ushort ToUInt16(
   object value
);
[C++]
public: static unsigned short ToUInt16(
   Object* value
);
[JScript]
public static function ToUInt16(
   value : Object
) : UInt16;

Parameters

value
[To be supplied.]

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than UInt16.MaxValue or less than UInt16.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt16 Overload List


Convert.ToUInt16 (Boolean)

Converts a Boolean to a UInt16.

[Visual Basic]
Overloads Public Shared Function ToUInt16( _
   ByVal value As Boolean _
) As UInt16
[C#]
public static ushort ToUInt16(
   bool value
);
[C++]
public: static unsigned short ToUInt16(
   bool value
);
[JScript]
public static function ToUInt16(
   value : Boolean
) : UInt16;

Parameters

value
The number to be converted.

Return Value

The number 1 if value is true; otherwise, 0.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt16 Overload List


Convert.ToUInt16 (Int16)

Converts an Int16 to a UInt16.

[Visual Basic]
Overloads Public Shared Function ToUInt16( _
   ByVal value As Short _
) As UInt16
[C#]
public static ushort ToUInt16(
   short value
);
[C++]
public: static unsigned short ToUInt16(
   short value
);
[JScript]
public static function ToUInt16(
   value : Int16
) : UInt16;

Parameters

value
The number to be converted.

Return Value

The converted value.

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is or less than UInt16.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt16 Overload List


Convert.ToUInt16 (Int32)

Converts an Int32 to a UInt16.

[Visual Basic]
Overloads Public Shared Function ToUInt16( _
   ByVal value As Integer _
) As UInt16
[C#]
public static ushort ToUInt16(
   int value
);
[C++]
public: static unsigned short ToUInt16(
   int value
);
[JScript]
public static function ToUInt16(
   value : int
) : UInt16;

Parameters

value
The number to be converted.

Return Value

The converted value.

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than UInt16.MaxValue or less than UInt16.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt16 Overload List


Convert.ToUInt16 (SByte)

Converts an SByte to a UInt16.

[Visual Basic]
Overloads Public Shared Function ToUInt16( _
   ByVal value As SByte _
) As UInt16
[C#]
public static ushort ToUInt16(
   sbyte value
);
[C++]
public: static unsigned short ToUInt16(
   char value
);
[JScript]
public static function ToUInt16(
   value : SByte
) : UInt16;

Parameters

value
The number to be converted.

Return Value

The converted value.

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is less than UInt16.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt16 Overload List


Convert.ToUInt16 (Byte)

Converts a Byte to a UInt16.

[Visual Basic]
Overloads Public Shared Function ToUInt16( _
   ByVal value As Byte _
) As UInt16
[C#]
public static ushort ToUInt16(
   byte value
);
[C++]
public: static unsigned short ToUInt16(
   unsigned char value
);
[JScript]
public static function ToUInt16(
   value : Byte
) : UInt16;

Parameters

value
The number to be converted.

Return Value

The converted value.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt16 Overload List


Convert.ToUInt32

Converts a value to a 32-bit unsigned integer.

Overload List

Parses a value in a specified base.

[Visual Basic] Overloads Public Shared Function ToUInt32(String, Integer) As UInt32
[C#] public static uint ToUInt32(String, int);
[C++] public: static unsigned int ToUInt32(String*, int);
[JScript] public static function ToUInt32(String, int) : UInt32;

Converts a UInt64 to a UInt32.

[Visual Basic] Overloads Public Shared Function ToUInt32(UInt64) As UInt32
[C#] public static uint ToUInt32(ulong);
[C++] public: static unsigned int ToUInt32(unsigned __int64);
[JScript] public static function ToUInt32(UInt64) : UInt32;

Converts an Int64 to a UInt32.

[Visual Basic] Overloads Public Shared Function ToUInt32(Long) As UInt32
[C#] public static uint ToUInt32(long);
[C++] public: static unsigned int ToUInt32(__int64);
[JScript] public static function ToUInt32(long) : UInt32;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToUInt32(UInt32) As UInt32
[C#] public static uint ToUInt32(uint);
[C++] public: static unsigned int ToUInt32(unsigned int);
[JScript] public static function ToUInt32(UInt32) : UInt32;

Returns a 32-bit, 4-byte unsigned integer with the converted number.

[Visual Basic] Overloads Public Shared Function ToUInt32(Single) As UInt32
[C#] public static uint ToUInt32(float);
[C++] public: static unsigned int ToUInt32(float);
[JScript] public static function ToUInt32(float) : UInt32;

Converts a String to a UInt32.

[Visual Basic] Overloads Public Shared Function ToUInt32(String) As UInt32
[C#] public static uint ToUInt32(String);
[C++] public: static unsigned int ToUInt32(String*);
[JScript] public static function ToUInt32(String) : UInt32;

Converts a Decimal to a UInt32.

[Visual Basic] Overloads Public Shared Function ToUInt32(Decimal) As UInt32
[C#] public static uint ToUInt32(Decimal);
[C++] public: static unsigned int ToUInt32(Decimal);
[JScript] public static function ToUInt32(Decimal) : UInt32;

Returns a 32-bit, 4-byte unsigned integer with the converted number.

[Visual Basic] Overloads Public Shared Function ToUInt32(Double) As UInt32
[C#] public static uint ToUInt32(double);
[C++] public: static unsigned int ToUInt32(double);
[JScript] public static function ToUInt32(double) : UInt32;

Converts an Int32 to a UInt32.

[Visual Basic] Overloads Public Shared Function ToUInt32(Integer) As UInt32
[C#] public static uint ToUInt32(int);
[C++] public: static unsigned int ToUInt32(int);
[JScript] public static function ToUInt32(int) : UInt32;

Converts a Char to a UInt32.

[Visual Basic] Overloads Public Shared Function ToUInt32(Char) As UInt32
[C#] public static uint ToUInt32(char);
[C++] public: static unsigned int ToUInt32(__wchar_t);
[JScript] public static function ToUInt32(Char) : UInt32;

Converts a Boolean to a UInt32.

[Visual Basic] Overloads Public Shared Function ToUInt32(Boolean) As UInt32
[C#] public static uint ToUInt32(bool);
[C++] public: static unsigned int ToUInt32(bool);
[JScript] public static function ToUInt32(Boolean) : UInt32;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToUInt32(Object) As UInt32
[C#] public static uint ToUInt32(Object);
[C++] public: static unsigned int ToUInt32(Object*);
[JScript] public static function ToUInt32(Object) : UInt32;

Converts an SByte to a UInt32.

[Visual Basic] Overloads Public Shared Function ToUInt32(SByte) As UInt32
[C#] public static uint ToUInt32(sbyte);
[C++] public: static unsigned int ToUInt32(char);
[JScript] public static function ToUInt32(SByte) : UInt32;

Converts a UInt16 to a UInt32.

[Visual Basic] Overloads Public Shared Function ToUInt32(UInt16) As UInt32
[C#] public static uint ToUInt32(ushort);
[C++] public: static unsigned int ToUInt32(unsigned short);
[JScript] public static function ToUInt32(UInt16) : UInt32;

Converts an Int16 to a UInt32.

[Visual Basic] Overloads Public Shared Function ToUInt32(Integer) As UInt32
[C#] public static uint ToUInt32(short);
[C++] public: static unsigned int ToUInt32(short);
[JScript] public static function ToUInt32(Int16) : UInt32;

Converts a Byte to a UInt32.

[Visual Basic] Overloads Public Shared Function ToUInt32(Byte) As UInt32
[C#] public static uint ToUInt32(byte);
[C++] public: static unsigned int ToUInt32(unsigned char);
[JScript] public static function ToUInt32(Byte) : UInt32;

See Also

Convert Class | Convert Members | System Namespace


Convert.ToUInt32 (String, Int32)

Parses a value in a specified base.

[Visual Basic]
Overloads Public Shared Function ToUInt32( _
   ByVal value As String, _
   ByVal fromBase As Integer _
) As UInt32
[C#]
public static uint ToUInt32(
   string value,
   int fromBase
);
[C++]
public: static unsigned int ToUInt32(
   String* value,
   int fromBase
);
[JScript]
public static function ToUInt32(
   value : String,
   fromBase : int
) : UInt32;

Parameters

value
The String to be parsed.
fromBase
The base in which to parse value.

Return Value

The UInt32 representation of value as a base fromBase number .

Exceptions

Exception Type | Condition
ArgumentException | fromBase is not 2, 8, 10, or 16.
FormatException | value cannot be parsed as a base fromBase number.
ArgumentNullException | value is null.
OverflowException | The value represented by value is greater than UInt32.MaxValue or less than UInt32.MinValue.

Remarks

A fromBase value can only be 2, 8, 10, or 16. If fromBase is 16, the number may be preceded by "0x"; any other leading or trailing characters cause an error.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt32 Overload List


Convert.ToUInt32 (UInt64)

Converts a UInt64 to a UInt32.

[Visual Basic]
Overloads Public Shared Function ToUInt32( _
   ByVal value As UInt64 _
) As UInt32
[C#]
public static uint ToUInt32(
   ulong value
);
[C++]
public: static unsigned int ToUInt32(
   unsigned __int64 value
);
[JScript]
public static function ToUInt32(
   value : UInt64
) : UInt32;

Parameters

value
The number to be converted.

Return Value

The converted value.

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than UInt32.MaxValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt32 Overload List


Convert.ToUInt32 (Int64)

Converts an Int64 to a UInt32.

[Visual Basic]
Overloads Public Shared Function ToUInt32( _
   ByVal value As Long _
) As UInt32
[C#]
public static uint ToUInt32(
   long value
);
[C++]
public: static unsigned int ToUInt32(
   __int64 value
);
[JScript]
public static function ToUInt32(
   value : long
) : UInt32;

Parameters

value
The number to be converted.

Return Value

The value as a UInt32.

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than UInt32.MaxValue or less than UInt32.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt32 Overload List


Convert.ToUInt32 (UInt32)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToUInt32( _
   ByVal value As UInt32 _
) As UInt32
[C#]
public static uint ToUInt32(
   uint value
);
[C++]
public: static unsigned int ToUInt32(
   unsigned int value
);
[JScript]
public static function ToUInt32(
   value : UInt32
) : UInt32;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt32 Overload List


Convert.ToUInt32 (Single)

Returns a 32-bit, 4-byte unsigned integer with the converted number.

[Visual Basic]
Overloads Public Shared Function ToUInt32( _
   ByVal value As Single _
) As UInt32
[C#]
public static uint ToUInt32(
   float value
);
[C++]
public: static unsigned int ToUInt32(
   float value
);
[JScript]
public static function ToUInt32(
   value : float
) : UInt32;

Parameters

value
The number to be converted.

Return Value

value rounded to the nearest integer. If value is exactly halfway between two whole numbers, this method returns the the integer that is even (i.e. 4.5 is converted to 4, and 5.5 is converted to 6).

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than UInt32.MaxValue or less than UInt32.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt32 Overload List


Convert.ToUInt32 (String)

Converts a String to a UInt32.

[Visual Basic]
Overloads Public Shared Function ToUInt32( _
   ByVal value As String _
) As UInt32
[C#]
public static uint ToUInt32(
   string value
);
[C++]
public: static unsigned int ToUInt32(
   String* value
);
[JScript]
public static function ToUInt32(
   value : String
) : UInt32;

Parameters

value
A string representation of a UInt32 value.

Return Value

The converted value.

Exceptions

Exception Type | Condition
ArgumentException | If value is null.
FormatException | Is thrown if value cannot be parsed or the value represented is greater than UInt32.MaxValue or less than UInt32.MinValue.
OverflowException | If value represents a number that is less than UInt32.MinValue or greater than UInt32.MaxValue. Note that if the beginning of the string value contains a properly formatted numerical value that will result in an overflow and, in addition, the end of the string is improperly formed, it cannot be determined whether an OverflowException or a FormatException will be thrown. This has been implemented this way for performance reasons.

Remarks

value is parsed as a decimal unless it is preceded by 0x, in which case it is parsed as a hexadecimal number. White space or trailing characters will cause a FormatException.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt32 Overload List


Convert.ToUInt32 (Decimal)

Converts a Decimal to a UInt32.

[Visual Basic]
Overloads Public Shared Function ToUInt32( _
   ByVal value As Decimal _
) As UInt32
[C#]
public static uint ToUInt32(
   Decimal value
);
[C++]
public: static unsigned int ToUInt32(
   Decimal value
);
[JScript]
public static function ToUInt32(
   value : Decimal
) : UInt32;

Parameters

value
The number to be converted.

Return Value

value rounded to the nearest integer. If value is exactly halfway between two whole numbers, this method returns the the integer that is even (i.e. 4.5 is converted to 4, and 5.5 is converted to 6).

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than UInt32.MaxValue or less than UInt32.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt32 Overload List


Convert.ToUInt32 (Double)

Returns a 32-bit, 4-byte unsigned integer with the converted number.

[Visual Basic]
Overloads Public Shared Function ToUInt32( _
   ByVal value As Double _
) As UInt32
[C#]
public static uint ToUInt32(
   double value
);
[C++]
public: static unsigned int ToUInt32(
   double value
);
[JScript]
public static function ToUInt32(
   value : double
) : UInt32;

Parameters

value
The number to be converted.

Return Value

value rounded to the nearest integer. If value is exactly halfway between two whole numbers, this method returns the the integer that is even (i.e. 4.5 is converted to 4, and 5.5 is converted to 6).

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than UInt32.MaxValue or less than UInt32.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt32 Overload List


Convert.ToUInt32 (Int32)

Converts an Int32 to a UInt32.

[Visual Basic]
Overloads Public Shared Function ToUInt32( _
   ByVal value As Integer _
) As UInt32
[C#]
public static uint ToUInt32(
   int value
);
[C++]
public: static unsigned int ToUInt32(
   int value
);
[JScript]
public static function ToUInt32(
   value : int
) : UInt32;

Parameters

value
The number to be converted.

Return Value

The value as a UInt32 .

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is less than UInt32.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt32 Overload List


Convert.ToUInt32 (Char)

Converts a Char to a UInt32.

[Visual Basic]
Overloads Public Shared Function ToUInt32( _
   ByVal value As Char _
) As UInt32
[C#]
public static uint ToUInt32(
   char value
);
[C++]
public: static unsigned int ToUInt32(
   __wchar_t value
);
[JScript]
public static function ToUInt32(
   value : Char
) : UInt32;

Parameters

value
The number to be converted.

Return Value

value as a UInt32 .

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt32 Overload List


Convert.ToUInt32 (Boolean)

Converts a Boolean to a UInt32.

[Visual Basic]
Overloads Public Shared Function ToUInt32( _
   ByVal value As Boolean _
) As UInt32
[C#]
public static uint ToUInt32(
   bool value
);
[C++]
public: static unsigned int ToUInt32(
   bool value
);
[JScript]
public static function ToUInt32(
   value : Boolean
) : UInt32;

Parameters

value
Boolean.False

Return Value

The number 1 if value is true; otherwise, 0.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt32 Overload List


Convert.ToUInt32 (Object)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToUInt32( _
   ByVal value As Object _
) As UInt32
[C#]
public static uint ToUInt32(
   object value
);
[C++]
public: static unsigned int ToUInt32(
   Object* value
);
[JScript]
public static function ToUInt32(
   value : Object
) : UInt32;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt32 Overload List


Convert.ToUInt32 (SByte)

Converts an SByte to a UInt32.

[Visual Basic]
Overloads Public Shared Function ToUInt32( _
   ByVal value As SByte _
) As UInt32
[C#]
public static uint ToUInt32(
   sbyte value
);
[C++]
public: static unsigned int ToUInt32(
   char value
);
[JScript]
public static function ToUInt32(
   value : SByte
) : UInt32;

Parameters

value
The number to be converted.

Return Value

The converted value.

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is less than UInt32.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt32 Overload List


Convert.ToUInt32 (UInt16)

Converts a UInt16 to a UInt32.

[Visual Basic]
Overloads Public Shared Function ToUInt32( _
   ByVal value As UInt16 _
) As UInt32
[C#]
public static uint ToUInt32(
   ushort value
);
[C++]
public: static unsigned int ToUInt32(
   unsigned short value
);
[JScript]
public static function ToUInt32(
   value : UInt16
) : UInt32;

Parameters

value
The number to be converted.

Return Value

The converted value.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt32 Overload List


Convert.ToUInt32 (Int16)

Converts an Int16 to a UInt32.

[Visual Basic]
Overloads Public Shared Function ToUInt32( _
   ByVal value As Short _
) As UInt32
[C#]
public static uint ToUInt32(
   short value
);
[C++]
public: static unsigned int ToUInt32(
   short value
);
[JScript]
public static function ToUInt32(
   value : Int16
) : UInt32;

Parameters

value
The number to be converted.

Return Value

The converted value.

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is less than UInt32.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt32 Overload List


Convert.ToUInt32 (Byte)

Converts a Byte to a UInt32.

[Visual Basic]
Overloads Public Shared Function ToUInt32( _
   ByVal value As Byte _
) As UInt32
[C#]
public static uint ToUInt32(
   byte value
);
[C++]
public: static unsigned int ToUInt32(
   unsigned char value
);
[JScript]
public static function ToUInt32(
   value : Byte
) : UInt32;

Parameters

value
The number to be converted.

Return Value

The value as a UInt32 .

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt32 Overload List


Convert.ToUInt64

Converts a value to a 64-bit unsigned integer.

Overload List

Converts an Int64 to a UInt64.

[Visual Basic] Overloads Public Shared Function ToUInt64(Long) As UInt64
[C#] public static ulong ToUInt64(long);
[C++] public: static unsigned __int64 ToUInt64(__int64);
[JScript] public static function ToUInt64(long) : UInt64;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToUInt64(UInt64) As UInt64
[C#] public static ulong ToUInt64(ulong);
[C++] public: static unsigned __int64 ToUInt64(unsigned __int64);
[JScript] public static function ToUInt64(UInt64) : UInt64;

Converts an Int32 to a UInt64.

[Visual Basic] Overloads Public Shared Function ToUInt64(Integer) As UInt64
[C#] public static ulong ToUInt64(int);
[C++] public: static unsigned __int64 ToUInt64(int);
[JScript] public static function ToUInt64(int) : UInt64;

Converts a UInt32 to a UInt64.

[Visual Basic] Overloads Public Shared Function ToUInt64(UInt32) As UInt64
[C#] public static ulong ToUInt64(uint);
[C++] public: static unsigned __int64 ToUInt64(unsigned int);
[JScript] public static function ToUInt64(UInt32) : UInt64;

Converts a Decimal to a UInt64.

[Visual Basic] Overloads Public Shared Function ToUInt64(Decimal) As UInt64
[C#] public static ulong ToUInt64(Decimal);
[C++] public: static unsigned __int64 ToUInt64(Decimal);
[JScript] public static function ToUInt64(Decimal) : UInt64;

Converts a String to a UInt64 value.

[Visual Basic] Overloads Public Shared Function ToUInt64(String) As UInt64
[C#] public static ulong ToUInt64(String);
[C++] public: static unsigned __int64 ToUInt64(String*);
[JScript] public static function ToUInt64(String) : UInt64;

Converts a Single to a UInt64.

[Visual Basic] Overloads Public Shared Function ToUInt64(Single) As UInt64
[C#] public static ulong ToUInt64(float);
[C++] public: static unsigned __int64 ToUInt64(float);
[JScript] public static function ToUInt64(float) : UInt64;

Converts a Double to a UInt64.

[Visual Basic] Overloads Public Shared Function ToUInt64(Double) As UInt64
[C#] public static ulong ToUInt64(double);
[C++] public: static unsigned __int64 ToUInt64(double);
[JScript] public static function ToUInt64(double) : UInt64;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToUInt64(Char) As UInt64
[C#] public static ulong ToUInt64(char);
[C++] public: static unsigned __int64 ToUInt64(__wchar_t);
[JScript] public static function ToUInt64(Char) : UInt64;

Converts an SByte to a UInt64.

[Visual Basic] Overloads Public Shared Function ToUInt64(SByte) As UInt64
[C#] public static ulong ToUInt64(sbyte);
[C++] public: static unsigned __int64 ToUInt64(char);
[JScript] public static function ToUInt64(SByte) : UInt64;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToUInt64(Object) As UInt64
[C#] public static ulong ToUInt64(Object);
[C++] public: static unsigned __int64 ToUInt64(Object*);
[JScript] public static function ToUInt64(Object) : UInt64;

Converts a Boolean to a UInt64.

[Visual Basic] Overloads Public Shared Function ToUInt64(Boolean) As UInt64
[C#] public static ulong ToUInt64(bool);
[C++] public: static unsigned __int64 ToUInt64(bool);
[JScript] public static function ToUInt64(Boolean) : UInt64;

Converts an Int16 to a UInt64.

[Visual Basic] Overloads Public Shared Function ToUInt64(Integer) As UInt64
[C#] public static ulong ToUInt64(short);
[C++] public: static unsigned __int64 ToUInt64(short);
[JScript] public static function ToUInt64(Int16) : UInt64;

Converts a UInt16 to a UInt64.

[Visual Basic] Overloads Public Shared Function ToUInt64(UInt16) As UInt64
[C#] public static ulong ToUInt64(ushort);
[C++] public: static unsigned __int64 ToUInt64(unsigned short);
[JScript] public static function ToUInt64(UInt16) : UInt64;

Parses a specified value in a specified base.

[Visual Basic] Overloads Public Shared Function ToUInt64(String, Integer) As UInt64
[C#] public static ulong ToUInt64(String, int);
[C++] public: static unsigned __int64 ToUInt64(String*, int);
[JScript] public static function ToUInt64(String, int) : UInt64;

Converts a Byte to a UInt64.

[Visual Basic] Overloads Public Shared Function ToUInt64(Byte) As UInt64
[C#] public static ulong ToUInt64(byte);
[C++] public: static unsigned __int64 ToUInt64(unsigned char);
[JScript] public static function ToUInt64(Byte) : UInt64;

See Also

Convert Class | Convert Members | System Namespace


Convert.ToUInt64 (Int64)

Converts an Int64 to a UInt64.

[Visual Basic]
Overloads Public Shared Function ToUInt64( _
   ByVal value As Long _
) As UInt64
[C#]
public static ulong ToUInt64(
   long value
);
[C++]
public: static unsigned __int64 ToUInt64(
   __int64 value
);
[JScript]
public static function ToUInt64(
   value : long
) : UInt64;

Parameters

value
The number to be converted.

Return Value

The converted value.

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is less than UInt64.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt64 Overload List


Convert.ToUInt64 (UInt64)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToUInt64( _
   ByVal value As UInt64 _
) As UInt64
[C#]
public static ulong ToUInt64(
   ulong value
);
[C++]
public: static unsigned __int64 ToUInt64(
   unsigned __int64 value
);
[JScript]
public static function ToUInt64(
   value : UInt64
) : UInt64;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt64 Overload List


Convert.ToUInt64 (Int32)

Converts an Int32 to a UInt64.

[Visual Basic]
Overloads Public Shared Function ToUInt64( _
   ByVal value As Integer _
) As UInt64
[C#]
public static ulong ToUInt64(
   int value
);
[C++]
public: static unsigned __int64 ToUInt64(
   int value
);
[JScript]
public static function ToUInt64(
   value : int
) : UInt64;

Parameters

value
The number to be converted.

Return Value

The converted value.

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is less than UInt64.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt64 Overload List


Convert.ToUInt64 (UInt32)

Converts a UInt32 to a UInt64.

[Visual Basic]
Overloads Public Shared Function ToUInt64( _
   ByVal value As UInt32 _
) As UInt64
[C#]
public static ulong ToUInt64(
   uint value
);
[C++]
public: static unsigned __int64 ToUInt64(
   unsigned int value
);
[JScript]
public static function ToUInt64(
   value : UInt32
) : UInt64;

Parameters

value
The number to be converted.

Return Value

The converted value.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt64 Overload List


Convert.ToUInt64 (Decimal)

Converts a Decimal to a UInt64.

[Visual Basic]
Overloads Public Shared Function ToUInt64( _
   ByVal value As Decimal _
) As UInt64
[C#]
public static ulong ToUInt64(
   Decimal value
);
[C++]
public: static unsigned __int64 ToUInt64(
   Decimal value
);
[JScript]
public static function ToUInt64(
   value : Decimal
) : UInt64;

Parameters

value
The number to be converted.

Return Value

value rounded to the nearest integer. If value is exactly halfway between two whole numbers, this method returns the the integer that is even (i.e. 4.5 is converted to 4, and 5.5 is converted to 6).

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than UInt64.MaxValue or less than UInt64.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt64 Overload List


Convert.ToUInt64 (String)

Converts a String to a UInt64 value.

[Visual Basic]
Overloads Public Shared Function ToUInt64( _
   ByVal value As String _
) As UInt64
[C#]
public static ulong ToUInt64(
   string value
);
[C++]
public: static unsigned __int64 ToUInt64(
   String* value
);
[JScript]
public static function ToUInt64(
   value : String
) : UInt64;

Parameters

value
The number to be converted.

Return Value

The converted value.

Exceptions

Exception Type | Condition
ArgumentException | If value is null.
FormatException | If value represents a number that is greater than UInt64.MaxValue or less than UInt64.MinValue. Note that if the beginning of the string value contains a properly formatted numerical value that will result in an overflow and, in addition, the end of the string is improperly formed, it cannot be determined whether an OverflowException or a FormatException will be thrown. This has been implemented this way for performance reasons. If value does not contain a representation that can be converted to a UInt64 using the Parse(String) method implemented by that type.

Remarks

value is parsed as a decimal unless it is preceded by "0x"; in that case, it is parsed as a hexadecimal number. White space or trailing characters will cause a FormatException.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt64 Overload List


Convert.ToUInt64 (Single)

Converts a Single to a UInt64.

[Visual Basic]
Overloads Public Shared Function ToUInt64( _
   ByVal value As Single _
) As UInt64
[C#]
public static ulong ToUInt64(
   float value
);
[C++]
public: static unsigned __int64 ToUInt64(
   float value
);
[JScript]
public static function ToUInt64(
   value : float
) : UInt64;

Parameters

value
The number to be converted.

Return Value

value rounded to the nearest integer. If value is exactly halfway between two whole numbers, this method returns the the integer that is even (i.e. 4.5 is converted to 4, and 5.5 is converted to 6).

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than UInt64.MaxValue or less than UInt64.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt64 Overload List


Convert.ToUInt64 (Double)

Converts a Double to a UInt64.

[Visual Basic]
Overloads Public Shared Function ToUInt64( _
   ByVal value As Double _
) As UInt64
[C#]
public static ulong ToUInt64(
   double value
);
[C++]
public: static unsigned __int64 ToUInt64(
   double value
);
[JScript]
public static function ToUInt64(
   value : double
) : UInt64;

Parameters

value
The number to be converted.

Return Value

value rounded to the nearest integer. If value is exactly halfway between two whole numbers, this method returns the the integer that is even (i.e. 4.5 is converted to 4, and 5.5 is converted to 6).

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is greater than UInt64.MaxValue or less than UInt64.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt64 Overload List


Convert.ToUInt64 (Char)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToUInt64( _
   ByVal value As Char _
) As UInt64
[C#]
public static ulong ToUInt64(
   char value
);
[C++]
public: static unsigned __int64 ToUInt64(
   __wchar_t value
);
[JScript]
public static function ToUInt64(
   value : Char
) : UInt64;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt64 Overload List


Convert.ToUInt64 (SByte)

Converts an SByte to a UInt64.

[Visual Basic]
Overloads Public Shared Function ToUInt64( _
   ByVal value As SByte _
) As UInt64
[C#]
public static ulong ToUInt64(
   sbyte value
);
[C++]
public: static unsigned __int64 ToUInt64(
   char value
);
[JScript]
public static function ToUInt64(
   value : SByte
) : UInt64;

Parameters

value
The number to be converted.

Return Value

The converted value.

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is less than UInt64.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt64 Overload List


Convert.ToUInt64 (Object)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToUInt64( _
   ByVal value As Object _
) As UInt64
[C#]
public static ulong ToUInt64(
   object value
);
[C++]
public: static unsigned __int64 ToUInt64(
   Object* value
);
[JScript]
public static function ToUInt64(
   value : Object
) : UInt64;

Parameters

value
[To be supplied.]

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt64 Overload List


Convert.ToUInt64 (Boolean)

Converts a Boolean to a UInt64.

[Visual Basic]
Overloads Public Shared Function ToUInt64( _
   ByVal value As Boolean _
) As UInt64
[C#]
public static ulong ToUInt64(
   bool value
);
[C++]
public: static unsigned __int64 ToUInt64(
   bool value
);
[JScript]
public static function ToUInt64(
   value : Boolean
) : UInt64;

Parameters

value
The value to convert.

Return Value

The number 1 if value is true; otherwise, 0.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt64 Overload List


Convert.ToUInt64 (Int16)

Converts an Int16 to a UInt64.

[Visual Basic]
Overloads Public Shared Function ToUInt64( _
   ByVal value As Short _
) As UInt64
[C#]
public static ulong ToUInt64(
   short value
);
[C++]
public: static unsigned __int64 ToUInt64(
   short value
);
[JScript]
public static function ToUInt64(
   value : Int16
) : UInt64;

Parameters

value
The number to be converted.

Return Value

The converted value.

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is less than UInt64.MinValue.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt64 Overload List


Convert.ToUInt64 (UInt16)

Converts a UInt16 to a UInt64.

[Visual Basic]
Overloads Public Shared Function ToUInt64( _
   ByVal value As UInt16 _
) As UInt64
[C#]
public static ulong ToUInt64(
   ushort value
);
[C++]
public: static unsigned __int64 ToUInt64(
   unsigned short value
);
[JScript]
public static function ToUInt64(
   value : UInt16
) : UInt64;

Parameters

value
The number to be converted.

Return Value

The converted value.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt64 Overload List


Convert.ToUInt64 (String, Int32)

Parses a specified value in a specified base.

[Visual Basic]
Overloads Public Shared Function ToUInt64( _
   ByVal value As String, _
   ByVal fromBase As Integer _
) As UInt64
[C#]
public static ulong ToUInt64(
   string value,
   int fromBase
);
[C++]
public: static unsigned __int64 ToUInt64(
   String* value,
   int fromBase
);
[JScript]
public static function ToUInt64(
   value : String,
   fromBase : int
) : UInt64;

Parameters

value
The String to be parsed.
fromBase
The base in which to parse value.

Return Value

The converted value.

Exceptions

Exception Type | Condition
ArgumentException | fromBase is not 2, 8, 10, or 16.
FormatException | value cannot be parsed as a base fromBase number.
ArgumentNullException | value is null.
OverflowException | The value represented by value is greater than UInt64.MaxValue or less than UInt64.MinValue.

Remarks

A fromBase value can be only 2, 8, 10, or 16. If fromBase is 16, the number may be preceded by "0x"; any other leading or trailing characters will cause an error.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt64 Overload List


Convert.ToUInt64 (Byte)

Converts a Byte to a UInt64.

[Visual Basic]
Overloads Public Shared Function ToUInt64( _
   ByVal value As Byte _
) As UInt64
[C#]
public static ulong ToUInt64(
   byte value
);
[C++]
public: static unsigned __int64 ToUInt64(
   unsigned char value
);
[JScript]
public static function ToUInt64(
   value : Byte
) : UInt64;

Parameters

value
The number to be converted.

Return Value

The converted value.

See Also

Convert Class | Convert Members | System Namespace | Convert.ToUInt64 Overload List


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Convert Fields

The fields of the Convert class are listed below. For a complete list of Convert class members, see the Convert Members topic.

Public:

DBNull [To be supplied.]

See Also

Convert Class | System Namespace


Convert.DBNull

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly DBNull As Object
[C#]
public static readonly object DBNull;
[C++]
public: static readonly Object* DBNull;
[JScript]
public static var DBNull : Object;

See Also

Convert Class | Convert Members | System Namespace


CoreException Class

Represents an exception that is thrown by the Runtime.

Object
Exception
SystemException
CoreException

[Visual Basic]
Public Class CoreException
   Inherits SystemException
[C#]
public class CoreException : SystemException
[C++]
public __gc class CoreException : public SystemException
[JScript]
public class CoreException extends SystemException

Remarks

The CoreException is an exception that is thrown by the Runtime.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

CoreException Members | System Namespace


CoreException Members

Public:

Constructor

CoreException Constructor Overloaded. Initializes a new CoreException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

CoreException Class | System Namespace


CoreException Constructor

Initializes a new CoreException class.

Overload List

Initializes a new CoreException class with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public CoreException();
[C++] public: CoreException();
[JScript] public function CoreException();

Initializes a new CoreException with a message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public CoreException(String);
[C++] public: CoreException(String*);
[JScript] public function CoreException(String);

Initializes a new CoreException with a message about the reason the exception occurred.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public CoreException(String, Exception);
[C++] public: CoreException(String*, Exception);
[JScript] public function CoreException(String, Exception);

See Also

CoreException Class | CoreException Members | System Namespace


CoreException Constructor ()

Initializes a new CoreException class with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CoreException();
[C++]
public: CoreException();
[JScript]
public function CoreException();

Remarks

CoreException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Conditon
InnerException | null
Message | The empty string.

See Also

CoreException Class | CoreException Members | System Namespace | CoreException Constructor Overload List


CoreException Constructor (String)

Initializes a new CoreException with a message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public CoreException(
   string message
);
[C++]
public: CoreException(
   String* message
);
[JScript]
public function CoreException(
   message : String
);

Parameters

message
The message that indicates the reason the exception occurred.

Remarks

CoreException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Conditon
InnerException | null
Message | The message string.

See Also

CoreException Class | CoreException Members | System Namespace | CoreException Constructor Overload List


CoreException Constructor (String, Exception)

Initializes a new CoreException with a message about the reason the exception occurred.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public CoreException(
   string message,
   Exception inner
);
[C++]
public: CoreException(
   String* message,
   Exception* inner
);
[JScript]
public function CoreException(
   message : String,
   inner : Exception
);

Parameters

message
The message that indicates the reason the exception occurred.
inner
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

CoreException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | The inner exception.
Message | The message string.

See Also

CoreException Class | CoreException Members | System Namespace | CoreException Constructor Overload List


Currency Structure

OBSOLETE. Use Decimal class intead.

Represents a currency value.

Object
ValueType
Currency

[Visual Basic]
Public Structure Currency
   Implements IFormattable, IComparable
[C#]
public struct Currency : IFormattable, IComparable
[C++]
public __value struct Currency : public IFormattable, IComparable

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

The Currency value type is useful for calculations involving money or for any fixed-point calculation where round-off errors cannot be tolerated.

This value type represents an 8-byte, complement integer (long), scaled by 10,000 to give a fixed-point number with 15 digits to the left of the decimal point and 4 digits to the right. This representation provides a range of positive 922,337,203,685,477.5807 or negative 922,337,203,685,477.5808.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

Currency Members | System Namespace | IFormattable | IComparable


Currency Members

Public:

Constructor

Currency Constructor Overloaded. Initializes a new instance of the Currency class.

Methods

Abs | Returns the absolute value of the given Currency.
Add | Adds two Currency values.
Compare | Compares two Currency values and returns an integer that indicates the result of the comparison.
CompareTo | Compares this instance to a specified Object.
Divide | Divides two Currency values and produces a Decimal result.
Equals | Overloaded. Determines whether two values are equal.
Floor | Rounds a Currency toward negative infinity to the nearest integer value.
Format | Overloaded. Converts a numeric value to a String.
FromOACurrency | Creates a Currency from an OLE Automation Currency.
FromString | Converts a String to a Currency.
GetHashCode | Gets the hash code for this instance of Currency.
GetType (inherited from Object) | Gets the Type of the Object.
Max | Returns the larger of two Currency values.
Min | Returns the smaller of two Currency values.
Multiply | Multiplies two Currency values and returns a Decimal result.
Negate | Returns the negated value of the specified Currency.
Parse | Overloaded. Converts a String to a Currency.
Round | Rounds a Currency value to a specified number of places.
Subtract | Subtracts two specified Currency values.
ToDecimal | Converts a Currency to a Decimal.
ToDouble | Converts a Currency to a Double.
ToInt32 | Converts a Currency to an Int32.
ToInt64 | Converts a Currency to an Int64.
ToOACurrency | Creates an OLE Automation Currency from a Currency instance.
ToSingle | Converts a Currency to a Single.
ToString | Overloaded. Converts a Currency to a String.
ToUInt32 | Converts a Currency to a UInt32.
ToUInt64 | Converts a Currency to a UInt64.
Truncate | Truncates a Currency to an integer value.

Operators and Type Conversions

Addition Operator | [To be supplied.]
Decrement Operator | [To be supplied.]
Division Operator | Divides two Currency values and produces a Currency result.
Equality Operator | [To be supplied.]
Greater Than Operator | [To be supplied.]
Greater Than Or Equal Operator | [To be supplied.]
Increment Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Less Than Operator | [To be supplied.]
Less Than Or Equal Operator | [To be supplied.]
Multiplication Operator | Multiplies two Currency values and produces a Currency result.
Subtraction Operator | [To be supplied.]
Unary Negation Operator | [To be supplied.]
Unary Plus Operator | [To be supplied.]
Double to Currency Conversion | [To be supplied.]
Currency to Byte Conversion | [To be supplied.]
Decimal to Currency Conversion | [To be supplied.]
Int64 to Currency Conversion | [To be supplied.]
UInt64 to Currency Conversion | [To be supplied.]
Single to Currency Conversion | [To be supplied.]
Currency to Int64 Conversion | [To be supplied.]
Currency to Single Conversion | [To be supplied.]
Currency to Double Conversion | [To be supplied.]
Currency to Int32 Conversion | [To be supplied.]
Currency to SByte Conversion | [To be supplied.]
Currency to Int16 Conversion | [To be supplied.]
Currency to UInt16 Conversion | [To be supplied.]
SByte to Currency Conversion | Overloaded. [To be supplied.]

Fields

Empty | Representing the constant that is a Currency value that is empty.
MaxValue | Representing the constant that is the largest possible Currency value.
MinusOne | Representing the constant that is the currency value-1.
MinValue | Representing the constant that is the smallest possible Currency value.
One | Representing the constant that is the Currency value 1.
Zero | Representing the constant that is the Currency value 0.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Currency Structure | System Namespace


Currency Constructor

Initializes a new instance of the Currency class.

Overload List

Initializes a new instance of the Currency class to a specified Int32 value.

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public Currency(int);
[C++] public: Currency(int);
[JScript] public function Currency(int);

Initializes a new instance of the Currency class to a value specified by a UInt32.

[Visual Basic] Overloads Public Sub New(UInt32)
[C#] public Currency(uint);
[C++] public: Currency(unsigned int);
[JScript] public function Currency(UInt32);

Initializes a new instance of the Currency class to a specified Int64 value.

[Visual Basic] Overloads Public Sub New(Long)
[C#] public Currency(long);
[C++] public: Currency(__int64);
[JScript] public function Currency(long);

Initializes a new instance of the Currency class to a value specified by a UInt64

[Visual Basic] Overloads Public Sub New(UInt64)
[C#] public Currency(ulong);
[C++] public: Currency(unsigned __int64);
[JScript] public function Currency(UInt64);

Initializes a new instance of the Currency class to a value specified by a float.

[Visual Basic] Overloads Public Sub New(Single)
[C#] public Currency(float);
[C++] public: Currency(float);
[JScript] public function Currency(float);

Initializes a new instance of the Currency class to a value specified by a Double.

[Visual Basic] Overloads Public Sub New(Double)
[C#] public Currency(double);
[C++] public: Currency(double);
[JScript] public function Currency(double);

Initializes a new instance of the Currency class to a value specified by a Decimal.

[Visual Basic] Overloads Public Sub New(Decimal)
[C#] public Currency(Decimal);
[C++] public: Currency(Decimal);
[JScript] public function Currency(Decimal);

See Also

Currency Structure | Currency Members | System Namespace


Currency Constructor (Int32)

Initializes a new instance of the Currency class to a specified Int32 value.

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As Integer _
)
[C#]
public Currency(
   int value
);
[C++]
public: Currency(
   int value
);
[JScript]
public function Currency(
   value : int
);

Parameters

value
The integer value to represent as a Currency.

Remarks

This constructor is called by the NGWS runtime.

This constructor initializes a new instance of the Currency to a Long (int) value.

See Also

Currency Structure | Currency Members | System Namespace | Currency Constructor Overload List


Currency Constructor (UInt32)

Initializes a new instance of the Currency class to a value specified by a UInt32.

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As UInt32 _
)
[C#]
public Currency(
   uint value
);
[C++]
public: Currency(
   unsigned int value
);
[JScript]
public function Currency(
   value : UInt32
);

Parameters

value
The value to represent as a Currency.

Remarks

This constructor initializes a new instance of Currency to an unsigned int or UInt32 (uint) value

See Also

Currency Structure | Currency Members | System Namespace | Currency Constructor Overload List


Currency Constructor (Int64)

Initializes a new instance of the Currency class to a specified Int64 value.

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As Long _
)
[C#]
public Currency(
   long value
);
[C++]
public: Currency(
   __int64 value
);
[JScript]
public function Currency(
   value : long
);

Parameters

value
The value to represent as a Currency.

Exceptions

Exception Type | Condition
OverflowException | is thrown if value is outside the Currency range.

Remarks

This constructor initializes a new instance of Currency to a __int64 or Long8 (long) value.

The Currency value range is positive 922,337,203,685,477.5807 to negative 922,337,203,685,477.5808.

See Also

Currency Structure | Currency Members | System Namespace | Currency Constructor Overload List


Currency Constructor (UInt64)

Initializes a new instance of the Currency class to a value specified by a UInt64

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As UInt64 _
)
[C#]
public Currency(
   ulong value
);
[C++]
public: Currency(
   unsigned __int64 value
);
[JScript]
public function Currency(
   value : UInt64
);

Parameters

value
The value to represent as a Currency.

Remarks

Note that this constructor is not CLS compliant.

This constructor initializes a new instances of Currency to a unisigned __in64 or UInt64, which is a ulong value.

See Also

Currency Structure | Currency Members | System Namespace | Currency Constructor Overload List


Currency Constructor (Single)

Initializes a new instance of the Currency class to a value specified by a float.

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As Single _
)
[C#]
public Currency(
   float value
);
[C++]
public: Currency(
   float value
);
[JScript]
public function Currency(
   value : float
);

Parameters

value
The value to represent as a Currency.

Exceptions

Exception Type | Condition
OverflowException | If the value is outside the Currency range, or if the value is infinity or not a number (NaN).

Remarks

Initializes a new instance of the Currency to a Single (float) value.

See Also

Currency Structure | Currency Members | System Namespace | Currency Constructor Overload List


Currency Constructor (Double)

Initializes a new instance of the Currency class to a value specified by a Double.

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As Double _
)
[C#]
public Currency(
   double value
);
[C++]
public: Currency(
   double value
);
[JScript]
public function Currency(
   value : double
);

Parameters

value
The value to represent as a Currency.

Exceptions

Exception Type | Condition
OverflowException | If the value is outside the Currency range, or if the value is infinity or not a number (NaN).

Remarks

This constructor initializes a new instance of the Currency to a Double (double) value .

See Also

Currency Structure | Currency Members | System Namespace | Currency Constructor Overload List


Currency Constructor (Decimal)

Initializes a new instance of the Currency class to a value specified by a Decimal.

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As Decimal _
)
[C#]
public Currency(
   Decimal value
);
[C++]
public: Currency(
   Decimal value
);
[JScript]
public function Currency(
   value : Decimal
);

Parameters

value
The value to represent as a Currency.

Remarks

This constructor initializes a new instance of the Currency to a decimal value.

See Also

Currency Structure | Currency Members | System Namespace | Currency Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Currency Methods

The methods of the Currency structure are listed below. For a complete list of Currency structure members, see the Currency Members topic.

Public:

Abs | Returns the absolute value of the given Currency.
Add | Adds two Currency values.
Compare | Compares two Currency values and returns an integer that indicates the result of the comparison.
CompareTo | Compares this instance to a specified Object.
Divide | Divides two Currency values and produces a Decimal result.
Equals | Overloaded. Determines whether two values are equal.
Floor | Rounds a Currency toward negative infinity to the nearest integer value.
Format | Overloaded. Converts a numeric value to a String.
FromOACurrency | Creates a Currency from an OLE Automation Currency.
FromString | Converts a String to a Currency.
GetHashCode | Gets the hash code for this instance of Currency.
GetType (inherited from Object) | Gets the Type of the Object.
Max | Returns the larger of two Currency values.
Min | Returns the smaller of two Currency values.
Multiply | Multiplies two Currency values and returns a Decimal result.
Negate | Returns the negated value of the specified Currency.
Parse | Overloaded. Converts a String to a Currency.
Round | Rounds a Currency value to a specified number of places.
Subtract | Subtracts two specified Currency values.
ToDecimal | Converts a Currency to a Decimal.
ToDouble | Converts a Currency to a Double.
ToInt32 | Converts a Currency to an Int32.
ToInt64 | Converts a Currency to an Int64.
ToOACurrency | Creates an OLE Automation Currency from a Currency instance.
ToSingle | Converts a Currency to a Single.
ToString | Overloaded. Converts a Currency to a String.
ToUInt32 | Converts a Currency to a UInt32.
ToUInt64 | Converts a Currency to a UInt64.
Truncate | Truncates a Currency to an integer value.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Currency Structure | System Namespace


Currency.Abs

Returns the absolute value of the given Currency.

[Visual Basic]
Public Shared Function Abs( _
   ByVal c As Currency _
) As Currency
[C#]
public static Currency Abs(
   Currency c
);
[C++]
public: static Currency Abs(
   Currency c
);
[JScript]
public static function Abs(
   c : Currency
) : Currency;

Parameters

c
A Currency value.

Return Value

The absolute value of the argument.

Return Value | Description
The result is c. | If c is positive.
The result is -c. | If c is negative.

Remarks

The absolute value of MinValue is MaxValue so that no exceptions are thrown.

See Also

Currency Structure | Currency Members | System Namespace


Currency.Add

Adds two Currency values.

[Visual Basic]
Public Shared Function Add( _
   ByVal c1 As Currency, _
   ByVal c2 As Currency _
) As Currency
[C#]
public static Currency Add(
   Currency c1,
   Currency c2
);
[C++]
public: static Currency Add(
   Currency c1,
   Currency c2
);
[JScript]
public static function Add(
   c1 : Currency,
   c2 : Currency
) : Currency;

Parameters

c1
The left operand.
c2
The right operand.

Return Value

The value is the sum of adding two Currency values (c1 + c2).

Exceptions

Exception Type | Condition
OverflowException | If the sum of the two values is too large to represent as a Currency.

Remarks

The Add method performs the arithmetic funtion of adding two specified Currency values (c1 + c2) and returning the sum. An OverflowException will be thrown if the sum is a value greater than MaxValue.

See Also

Currency Structure | Currency Members | System Namespace


Currency.Compare

Compares two Currency values and returns an integer that indicates the result of the comparison.

[Visual Basic]
Public Shared Function Compare( _
   ByVal c1 As Currency, _
   ByVal c2 As Currency _
) As Integer
[C#]
public static int Compare(
   Currency c1,
   Currency c2
);
[C++]
public: static int Compare(
   Currency c1,
   Currency c2
);
[JScript]
public static function Compare(
   c1 : Currency,
   c2 : Currency
) : int;

Parameters

c1
The first Currency value.
c2
The second Currency value.

Return Value

Value Type | Condition
1 | If the first Currecny value is greater than the second Currency value .
0 | If the two Currency values are equal.
-1 | If the first Currency value is less than the second Currency value.

Remarks

The Compare method evaluates and determines the relationship of two Currency values, returning an integer that indicates the result of that evaluation.

The values are determined using the following equations:

1 if c1 > c2, 0 if c1 = c2, or-1 if c1 < c2.

Currency c1 =...

Currency c2 = ...

If (Currency.Compare (c1, c2) > 0) Console.WriteLine ("c1 > c2"); If (Curency.Compare (c1, c2) == 0) Console.WriteLine ("c1 == c2"); If (Curency.Compare (c1, c2) < 0) Console.WriteLine ("c1 < c2");

See Also

Currency Structure | Currency Members | System Namespace


Currency.CompareTo

Compares this instance to a specified Object.

[Visual Basic]
Overridable Public Function CompareTo( _
   ByVal value As Object _
) As Integer
[C#]
public virtual int CompareTo(
   object value
);
[C++]
public: virtual int CompareTo(
   Object* value
);
[JScript]
public function CompareTo(
   value : Object
) : int;

Parameters

value
An object that compares with this instance.

Return Value

Value Type | Condition
A negative integer | If this instance is less than the object.
Zero | If this instance and the object have the same value.
A positive integer | If this instance is greater than the object.
A positive integer | If the object is null. This is a special case.

Exceptions

Exception Type | Condition
ArgumentException | If the object is not null or Currency.

Remarks

The CompareTo method evaluates and detrmines the relationship of this instance of Currency with a specified object, and then returns the results of that evaluation as a Int16.

The Currency values are compared in the canonical way. As a special case, an instance, regardless of its value, is considered to be greater than a null reference.The specified object must be either a Currency type or null object reference.

See Also

Currency Structure | Currency Members | System Namespace


Currency.Divide

Divides two Currency values and produces a Decimal result.

[Visual Basic]
Public Shared Function Divide( _
   ByVal c1 As Currency, _
   ByVal c2 As Currency _
) As Decimal
[C#]
public static Decimal Divide(
   Currency c1,
   Currency c2
);
[C++]
public: static Decimal Divide(
   Currency c1,
   Currency c2
);
[JScript]
public static function Divide(
   c1 : Currency,
   c2 : Currency
) : Decimal;

Parameters

c1
The left operand (the dividend).
c2
The right operand (the divisor).

Return Value

The value is the result of dividing the dividend by the divisor.

Exceptions

Exception Type | Condition
DivideByZeroException | If the divisor is zero.

Remarks

The Divide method performs the arithmetic operation of division (c1/ c2) and returns the quotient as a Currency value.A DivideByZeroException is thrown if the second operand, the divisor (c2), is 0.

See Also

Currency Structure | Currency Members | System Namespace


Currency.Equals

Determines whether two values are equal.

Overload List

Determines whether two specified Currency values are equal.

[Visual Basic] Overloads Public Shared Function Equals(Currency, Currency) As Boolean
[C#] public static bool Equals(Currency, Currency);
[C++] public: static bool Equals(Currency, Currency);
[JScript] public static function Equals(Currency, Currency) : Boolean;

Determines whether this instance of Currency is equal to a specified object.

[Visual Basic] Overloads Overrides Public Function Equals(Object) As Boolean
[C#] public override bool Equals(Object);
[C++] public: override bool Equals(Object*);
[JScript] public override function Equals(Object) : Boolean;

See Also

Currency Structure | Currency Members | System Namespace


Currency.Equals (Currency, Currency)

Determines whether two specified Currency values are equal.

[Visual Basic]
Overloads Public Shared Function Equals( _
   ByVal c1 As Currency, _
   ByVal c2 As Currency _
) As Boolean
[C#]
public static bool Equals(
   Currency c1,
   Currency c2
);
[C++]
public: static bool Equals(
   Currency c1,
   Currency c2
);
[JScript]
public static function Equals(
   c1 : Currency,
   c2 : Currency
) : Boolean;

Parameters

c1
The first (left) Currency.
c2
The second (right) Currency.

Return Value

true if the two Currency values are equal, otherwise false.

Remarks

The Equals method performs the arithmetic function of comparing two Currency values and determines their relationship, then returns the Boolean result of that determination.

See Also

Currency Structure | Currency Members | System Namespace | Currency.Equals Overload List


Currency.Equals (Object)

Determines whether this instance of Currency is equal to a specified object.

[Visual Basic]
Overloads Overrides Public Function Equals( _
   ByVal value As Object _
) As Boolean
[C#]
public override bool Equals(
   object value
);
[C++]
public: override bool Equals(
   Object* value
);
[JScript]
public override function Equals(
   value : Object
) : Boolean;

Parameters

value
An object to compare with this instance.

Return Value

true if the given object is a boxed Currency and its value is equal to the value of this Currency, otherwise false.

Remarks

The Equals method performs the arithmetic function of comparing this instance of Currency with the specified object and determines their relationship, then returns the Boolean result of that determination.

See Also

Currency Structure | Currency Members | System Namespace | Currency.Equals Overload List


Currency.Floor

Rounds a Currency toward negative infinity to the nearest integer value.

[Visual Basic]
Public Shared Function Floor( _
   ByVal c As Currency _
) As Currency
[C#]
public static Currency Floor(
   Currency c
);
[C++]
public: static Currency Floor(
   Currency c
);
[JScript]
public static function Floor(
   c : Currency
) : Currency;

Parameters

c
The Currency to truncate.

Return Value

The Currency argument rounded towards negative infinity, to the next lowest whole number value.

See Also

Currency Structure | Currency Members | System Namespace


Currency.Format

Converts a numeric value to a String.

Overload List

Converts a numeric value to a string using the specified format string.

[Visual Basic] Overloads Public Shared Function Format(Currency, String) As String
[C#] public static string Format(Currency, String);
[C++] public: static String* Format(Currency, String);
[JScript] public static function Format(Currency, String) : String;

Converts a numeric value to a String using the specified format string.

[Visual Basic] Overloads Public Shared Function Format(Currency, String, NumberFormatInfo) As String
[C#] public static string Format(Currency, String, NumberFormatInfo);
[C++] public: static String* Format(Currency, String, NumberFormatInfo);
[JScript] public static function Format(Currency, String, NumberFormatInfo) : String;

Converts the value of the instance of Currency to a string using the specified format string.

[Visual Basic] Overloads Overridable Public Function Format(String, IServiceObjectProvider) As String
[C#] public virtual string Format(String, IServiceObjectProvider);
[C++] public: virtual String* Format(String*, IServiceObjectProvider);
[JScript] public function Format(String, IServiceObjectProvider) : String;

See Also

Currency Structure | Currency Members | System Namespace


Currency.Format (Currency, String)

Converts a numeric value to a string using the specified format string.

[Visual Basic]
Overloads Public Shared Function Format( _
   ByVal value As Currency, _
   ByVal format As String _
) As String
[C#]
public static string Format(
   Currency value,
   string format
);
[C++]
public: static String* Format(
   Currency value,
   String* format
);
[JScript]
public static function Format(
   value : Currency,
   format : String
) : String;

Parameters

value
The value to be formatted.
format
The format string.

Return Value

The value is a String representation in a specified format.

Remarks

The Format method provides the functionality to convert a Currency numeric value to a string.

If the format is null or an empty string, the Currency value is formatted as if the string general format ("G") were specified. The numeric format information is obtained from the current culture (see CultureInfo for more infomation on cultures).

See Also

Currency Structure | Currency Members | System Namespace | Currency.Format Overload List | Object | String


Currency.Format (Currency, String, NumberFormatInfo)

Converts a numeric value to a String using the specified format string.

[Visual Basic]
Overloads Public Shared Function Format( _
   ByVal value As Currency, _
   ByVal format As String, _
   ByVal info As NumberFormatInfo _
) As String
[C#]
public static string Format(
   Currency value,
   string format,
   NumberFormatInfo info
);
[C++]
public: static String* Format(
   Currency value,
   String* format,
   NumberFormatInfo* info
);
[JScript]
public static function Format(
   value : Currency,
   format : String,
   info : NumberFormatInfo
) : String;

Parameters

value
The value to be formatted.
format
The format string.
info
The NumberFormatInfo instance used to format the number.

Return Value

The value is a String representation in a specified format.

Remarks

The Format method provides the functionality to convert a Currency numeric value to a string.

The info parameter specifies the NumberFormatInfo instance used to format the number. If info is null, the numeric format information is obtained from the current locale (see CultureInfo for more information on cultures).

If format is null or an empty string, the Currency value is formatted as if the string general format ("G") were specified.

Note that extrema, cannot always be converted back to Currency values after they have been formatted. For example, Currency.MinValue =-922,337,203,685,477.5807. In the Japanese NumberFormatInfo, CurrencyDecimalDigits = 0, and so MinValue becomes "-922,337,203,685,478", which cannot be converted back to a Currency value using the Parse method.

The NumberFormatInfo supplies information such as the characters to use for Currency and thousand separators, and the spelling and placement of currency symbols in monetary values. (See NumberFormatInfo for details concerning format strings.)

See Also

Currency Structure | Currency Members | System Namespace | Currency.Format Overload List | Object | String


Currency.Format (String, IServiceObjectProvider)

Converts the value of the instance of Currency to a string using the specified format string.

[Visual Basic]
Overloads Overridable Public Function Format( _
   ByVal format As String, _
   ByVal sp As IServiceObjectProvider _
) As String
[C#]
public virtual string Format(
   string format,
   IServiceObjectProvider sp
);
[C++]
public: virtual String* Format(
   String* format,
   IServiceObjectProvider* sp
);
[JScript]
public function Format(
   format : String,
   sp : IServiceObjectProvider
) : String;

Parameters

format
The format string.
sp
The IServiceObjectProvider is used asked for the NumberFormatInfo used to format the String.

Return Value

The value is a String representation of this instance in the specified format.

Remarks

The Format method provides the functionality to convert a Currency numeric value to a string.

Note that extrema cannot always be converted back to Currency values after they have been formatted. For example, Currency.MinValue =-922,337,203,685,477.5807. In the Japanese NumberFormatInfo, CurrencyDecimalDigits = 0, and so MinValue becomes "-922,337,203,685,478" that cannot be converted back to a Currency value using the Parse method.

If format is null or an empty string, the number is formatted as if the string general format ("G") were specified.

The sp parameter returns the format provider from which the NumberFormatInfo instance will be obtained. NumberFormatInfo supplies information such as the characters to use for decimal and thousand separators, and the spelling and placement of currency symbols in monetary values. If sp is null, the numeric format information is obtained from the current locale (see CultureInfo for more infomation on cultures).

See NumberStyles and NumberFormatInfo for details concerning format strings.

See Also

Currency Structure | Currency Members | System Namespace | Currency.Format Overload List


Currency.FromOACurrency

Creates a Currency from an OLE Automation Currency.

[Visual Basic]
Public Shared Function FromOACurrency( _
   ByVal cy As Long _
) As Currency
[C#]
public static Currency FromOACurrency(
   long cy
);
[C++]
public: static Currency FromOACurrency(
   __int64 cy
);
[JScript]
public static function FromOACurrency(
   cy : long
) : Currency;

Parameters

cy
An OLE Automation Currency value.

Return Value

A Currency value that is the bitwise equivalent of the OLE Automation Currency value.

Remarks

The FromOACurrency method provides the functionality of creating a Currency value from an OLE Automation Currency. The OLE Automation Currency value is stored as a long (Int64).

This method applies no scaling to the Currency value and is, essentially, a bitwise copy of the value, bit by bit.

See Also

Currency Structure | Currency Members | System Namespace


Currency.FromString

Converts a String to a Currency.

[Visual Basic]
Public Shared Function FromString( _
   ByVal s As String _
) As Currency
[C#]
public static Currency FromString(
   string s
);
[C++]
public: static Currency FromString(
   String* s
);
[JScript]
public static function FromString(
   s : String
) : Currency;

Parameters

s
The string that is converted to a Currency.

Return Value

The Currency that is the value of the string.

Exceptions

Exception Type | Condition
FormatException | If the given string does not represent a valid Currency value.

Remarks

The FromString method provides the functionality of converting a string to a Currency value.

The string must consist of an optional minus sign ("-") followed by a sequence of digits ("0"- "9"). The sequence of digits may optionally contain a single Currency point (".") character. Leading and trailing white space characters are allowed.

See Also

Currency Structure | Currency Members | System Namespace


Currency.GetHashCode

Gets the hash code for this instance of Currency.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

The hash code value for this instance of Currency.

Remarks

The GetHashCode method returns the absolute value of the Currency value of this instance and returns it as an int (see Int32). It overrides GetHashCode.

See Also

Currency Structure | Currency Members | System Namespace


Currency.Max

Returns the larger of two Currency values.

[Visual Basic]
Public Shared Function Max( _
   ByVal c1 As Currency, _
   ByVal c2 As Currency _
) As Currency
[C#]
public static Currency Max(
   Currency c1,
   Currency c2
);
[C++]
public: static Currency Max(
   Currency c1,
   Currency c2
);
[JScript]
public static function Max(
   c1 : Currency,
   c2 : Currency
) : Currency;

Parameters

c1
The first Currency.
c2
The second Currency.

Return Value

The value that is the larger of the two Currency argument parameters.

Remarks

The Max method compares two specified Currency values and returns the larger of the two values.

See Also

Currency Structure | Currency Members | System Namespace


Currency.Min

Returns the smaller of two Currency values.

[Visual Basic]
Public Shared Function Min( _
   ByVal c1 As Currency, _
   ByVal c2 As Currency _
) As Currency
[C#]
public static Currency Min(
   Currency c1,
   Currency c2
);
[C++]
public: static Currency Min(
   Currency c1,
   Currency c2
);
[JScript]
public static function Min(
   c1 : Currency,
   c2 : Currency
) : Currency;

Parameters

c1
The first Currency.
c2
The second Currency.

Return Value

The value that is the smaller of the two Currency argument parameters.

Remarks

The Min method compares two specified Currency values and returns the smaller of the two values

See Also

Currency Structure | Currency Members | System Namespace


Currency.Multiply

Multiplies two Currency values and returns a Decimal result.

[Visual Basic]
Public Shared Function Multiply( _
   ByVal c1 As Currency, _
   ByVal c2 As Currency _
) As Decimal
[C#]
public static Decimal Multiply(
   Currency c1,
   Currency c2
);
[C++]
public: static Decimal Multiply(
   Currency c1,
   Currency c2
);
[JScript]
public static function Multiply(
   c1 : Currency,
   c2 : Currency
) : Decimal;

Parameters

c1
The left operand.
c2
The right operand.

Return Value

The value is the quotient of two Currency values.

Exceptions

Exception Type | Condition
OverflowException | If the quotient is too large to represent as a Currency.

Remarks

The Multiply method performs the arithmetic funtion of multpling two Currency values and returning the quotient formated as a Decimal value. A overflow exception is thrown if the quotient (c1 * c2) are too large to represent as a Currency (see MaxValue).

See Also

Currency Structure | Currency Members | System Namespace


Currency.Negate

Returns the negated value of the specified Currency.

[Visual Basic]
Public Shared Function Negate( _
   ByVal c As Currency _
) As Currency
[C#]
public static Currency Negate(
   Currency c
);
[C++]
public: static Currency Negate(
   Currency c
);
[JScript]
public static function Negate(
   c : Currency
) : Currency;

Parameters

c
A Currency value.

Return Value

Value Type | Condition
-c | If c is other than zero.
0 | If c is zero.

Exceptions

Exception Type | Condition
OverflowException | If value is equal to MinValue.

Remarks

The Negate method returns the negated value of the argument as a long (Int64). For example:

  • If c is a non-zero number (any number other than zero), the result is negative c (-c);
  • If c is zero, the result is zero (0).

See Also

Currency Structure | Currency Members | System Namespace


Currency.Parse

Converts a String to a Currency.

Overload List

Converts a String to a Currency with the default format.

[Visual Basic] Overloads Public Shared Function Parse(String) As Currency
[C#] public static Currency Parse(String);
[C++] public: static Currency Parse(String*);
[JScript] public static function Parse(String) : Currency;

This method converts a specified String to a Currency object with a specified style.

[Visual Basic] Overloads Public Shared Function Parse(String, NumberStyles) As Currency
[C#] public static Currency Parse(String, NumberStyles);
[C++] public: static Currency Parse(String*, NumberStyles);
[JScript] public static function Parse(String, NumberStyles) : Currency;

Converts a specified String to a Currency with the specified style and formatting.

[Visual Basic] Overloads Public Shared Function Parse(String, NumberStyles, NumberFormatInfo) As Currency
[C#] public static Currency Parse(String, NumberStyles, NumberFormatInfo);
[C++] public: static Currency Parse(String*, NumberStyles, NumberFormatInfo);
[JScript] public static function Parse(String, NumberStyles, NumberFormatInfo) : Currency;

See Also

Currency Structure | Currency Members | System Namespace


Currency.Parse (String)

Converts a String to a Currency with the default format.

[Visual Basic]
Overloads Public Shared Function Parse( _
   ByVal s As String _
) As Currency
[C#]
public static Currency Parse(
   string s
);
[C++]
public: static Currency Parse(
   String* s
);
[JScript]
public static function Parse(
   s : String
) : Currency;

Parameters

s
The string to convert to a Currency.

Return Value

The Currency value of the string.

Exceptions

Exception Type | Condition
ArgumentNullException | If The string is null.
FormatException | If the string is not of the correct format.
OverflowException | If the string represents a number that is outside the expected range.

Remarks

The Parse method converts (parses) a string to a Currency.

This method obtains a NumberFormatInfo object from the locale of the current thread.

The string must consist of an optional minus sign ("-") followed by a sequence of digits ("0"- "9"). The sequence of digits may optionally contain a single decimal point (".") character. Leading and trailing white space characters are ignored.An overflow exception is thronw if the string represents a number that is less than MinValue or greater than MaxValue.

See Also

Currency Structure | Currency Members | System Namespace | Currency.Parse Overload List


Currency.Parse (String, NumberStyles)

This method converts a specified String to a Currency object with a specified style.

[Visual Basic]
Overloads Public Shared Function Parse( _
   ByVal s As String, _
   ByVal style As NumberStyles _
) As Currency
[C#]
public static Currency Parse(
   string s,
   NumberStyles style
);
[C++]
public: static Currency Parse(
   String* s,
   NumberStyles style
);
[JScript]
public static function Parse(
   s : String,
   style : NumberStyles
) : Currency;

Parameters

s
The string to be interpreted.
style
The permitted style of the numeric string.

Return Value

A Currency with the value represented by the string.

Exceptions

Exception Type | Condition
ArgumentNullException | If the string is null.
ArgumentException | If style is not a combination of bit flags from the NumberStyles enumeration.
FormatException | If the stering is not of the correct format.
OverflowException | If the string represents a number that is outside the expected range.

Remarks

The Parse method converts (parses) a string to a Currency and applies a specified format style.

Note that the Parse methods do not accept NaN or positve or negative infinity.

The numeric format information (a NumberFormatInfo) is obtained from the locale of the current thread.

If s has been created by one of the Format methods using C, D, E, F, G, or N as the format specifier, it is guaranteed that s can be parsed when style is NumberStyles.Any.

The style parameter must be a combination of bit flags from the NumberStyles enumeration.An overflow exception is thrown if the string represents a number that is less than MinValue or greater than MaxValue

See Also

Currency Structure | Currency Members | System Namespace | Currency.Parse Overload List


Currency.Parse (String, NumberStyles, NumberFormatInfo)

Converts a specified String to a Currency with the specified style and formatting.

[Visual Basic]
Overloads Public Shared Function Parse( _
   ByVal s As String, _
   ByVal style As NumberStyles, _
   ByVal info As NumberFormatInfo _
) As Currency
[C#]
public static Currency Parse(
   string s,
   NumberStyles style,
   NumberFormatInfo info
);
[C++]
public: static Currency Parse(
   String* s,
   NumberStyles style,
   NumberFormatInfo* info
);
[JScript]
public static function Parse(
   s : String,
   style : NumberStyles,
   info : NumberFormatInfo
) : Currency;

Parameters

s
The string to be interpreted.
style
The permitted style of the numeric string.
info
The NumberFormatInfo instance used to format the string.

Return Value

A Currency with the value represented by the string.

Exceptions

Exception Type | Condition
ArgumentException | If style is not a combination of bit flags from the NumberStyles enumeration.
ArgumentNullException | If the string is null.
FormatException | If the string is not of the correct format.
OverflowException | If the string represents a number that is outside the expected range.

Remarks

The Parse method converts (parses) a string to a Currency and applies a specified format style and formatting.

Note that the Parse methods do not accept NaN or positive or negative infinity.

If s has been created by one of the Format methods using C, D, E, F, G, or N as the format specifier, it is guaranteed that s can be parsed when style is NumberStylesAny.

The style parameter must be a combination of bit flags from the NumberStyles enumeration.

The info parameter specifies the NumberFormatInfo instance used to format the string. If the info parameter is null the numeric format information is obtained from the locale of the current thread.An overflow exception will be thrown if the string represents a number that is less than MinValue or greater than MaxValue.

See Also

Currency Structure | Currency Members | System Namespace | Currency.Parse Overload List


Currency.Round

Rounds a Currency value to a specified number of places.

[Visual Basic]
Public Shared Function Round( _
   ByVal c As Currency, _
   ByVal decimals As Integer _
) As Currency
[C#]
public static Currency Round(
   Currency c,
   int decimals
);
[C++]
public: static Currency Round(
   Currency c,
   int decimals
);
[JScript]
public static function Round(
   c : Currency,
   decimals : int
) : Currency;

Parameters

c
The Currency value to round.
decimals
The number of decimal places the Currency value is rounded to.

Return Value

The Currency value, rounded to the specified number of decimal places.

Exceptions

Exception Type | Condition
ArgumentException | If decimal is not between 0 and 4, inclusive.

Remarks

The Rounds method performs the arithmetic function of rounding the Currency value to the specified numbe of decimal places, which must be a number between 0 and 4, inclusively.

The operation performed by Round corresponds, conceptually, to evaluating Truncate, where the delta for positive values of the Currency value is 0.5 and for negative values of the Currency value is-0.5.

The decimals parameter returns the Currency value as an Int32.An argument exception is thrown if the decimal places to rounded is greater than four or less than zero.

See Also

Currency Structure | Currency Members | System Namespace


Currency.Subtract

Subtracts two specified Currency values.

[Visual Basic]
Public Shared Function Subtract( _
   ByVal c1 As Currency, _
   ByVal c2 As Currency _
) As Currency
[C#]
public static Currency Subtract(
   Currency c1,
   Currency c2
);
[C++]
public: static Currency Subtract(
   Currency c1,
   Currency c2
);
[JScript]
public static function Subtract(
   c1 : Currency,
   c2 : Currency
) : Currency;

Parameters

c1
The first Currency value.
c2
The second Currency value.

Return Value

The results of subtacting the two Currency values.

Exceptions

Exception Type | Condition
OverflowException | If the result is to large to represent as a Currency.

Remarks

The Subtract method performs the arithmetic function of subtracting the second Currecny value from the first Currency value (c1 - c2) and returning the results. An overflow exception will be theown if the result's of subtracting the two Currency values (c1 - c2) is greater than MaxValue and cannot be represented as a Currency.

See Also

Currency Structure | Currency Members | System Namespace


Currency.ToDecimal

Converts a Currency to a Decimal.

[Visual Basic]
Public Shared Function ToDecimal( _
   ByVal c As Currency _
) As Decimal
[C#]
public static Decimal ToDecimal(
   Currency c
);
[C++]
public: static Decimal ToDecimal(
   Currency c
);
[JScript]
public static function ToDecimal(
   c : Currency
) : Decimal;

Parameters

c
A Currency value.

Return Value

The result of converting the Curreny value to a Decimal.

Remarks

The ToDecimal method converts a Currency value to a decimal value.

See Also

Currency Structure | Currency Members | System Namespace


Currency.ToDouble

Converts a Currency to a Double.

[Visual Basic]
Public Shared Function ToDouble( _
   ByVal c As Currency _
) As Double
[C#]
public static double ToDouble(
   Currency c
);
[C++]
public: static double ToDouble(
   Currency c
);
[JScript]
public static function ToDouble(
   c : Currency
) : double;

Parameters

c
A Currency value.

Return Value

The result of converting the the Currency value to a Double.

Remarks

The ToDouble method converts a Currency value to a Double value. Since a Double has fewer significant digits than a Currency, this operation may produce round-off errors.

See Also

Currency Structure | Currency Members | System Namespace


Currency.ToInt32

Converts a Currency to an Int32.

[Visual Basic]
Public Shared Function ToInt32( _
   ByVal c As Currency _
) As Integer
[C#]
public static int ToInt32(
   Currency c
);
[C++]
public: static int ToInt32(
   Currency c
);
[JScript]
public static function ToInt32(
   c : Currency
) : int;

Parameters

c
A Currency value.

Return Value

The result of converting the Currency value to an integer.

Exceptions

Exception Type | Condition
OverflowException | If the Currency value is outside the acceptable range.

Remarks

The ToInt32 method converts a Currency value to a int (Int32) value. The Currency value is rounded towards zero to the nearest integer value, and the result of this operation is returned as an integer.

An overflow exception is thrown if the resulting Currency value is less than MinValue or greater than MaxValue.

See Also

Currency Structure | Currency Members | System Namespace


Currency.ToInt64

Converts a Currency to an Int64.

[Visual Basic]
Public Shared Function ToInt64( _
   ByVal c As Currency _
) As Long
[C#]
public static long ToInt64(
   Currency c
);
[C++]
public: static __int64 ToInt64(
   Currency c
);
[JScript]
public static function ToInt64(
   c : Currency
) : long;

Parameters

c
A Currency value.

Return Value

The result of converting the Currency value to an Int64.

Exceptions

Exception Type | Condition
OverflowException | If the Currency value is outside the acceptable range.

Remarks

The ToInt64 method converts a Currency value to a long(Int64) value. The Currency value is rounded towards zero to the nearest integer value, and the result of this operation is returned as a Int64.

An overflow exception is thrown if the Currency value is less than MinValue or greater than MaxValue.

See Also

Currency Structure | Currency Members | System Namespace


Currency.ToOACurrency

Creates an OLE Automation Currency from a Currency instance.

[Visual Basic]
Public Function ToOACurrency() As Long
[C#]
public long ToOACurrency();
[C++]
public: __int64 ToOACurrency();
[JScript]
public function ToOACurrency() : long;

Return Value

An OLE Automation Currency value.

Remarks

The ToOACurrency method converts a specified Currency to a an OLE Automation Currency value. It is stored as a long (Int64), that is bitwise equal to the Currency instance this was called upon.

This method applies no scaling to the currency value and is, essentially, doing a bitwise copy of the value, bit by bit.

See Also

Currency Structure | Currency Members | System Namespace


Currency.ToSingle

Converts a Currency to a Single.

[Visual Basic]
Public Shared Function ToSingle( _
   ByVal c As Currency _
) As Single
[C#]
public static float ToSingle(
   Currency c
);
[C++]
public: static float ToSingle(
   Currency c
);
[JScript]
public static function ToSingle(
   c : Currency
) : float;

Parameters

c
A Currency value.

Return Value

The result of converting the Currency value to a Single.

Remarks

The ToSingle method converts a Currency value to a Single (float). Since a Single has fewer significant digits than a Currency, this operation may produce round-off errors.

See Also

Currency Structure | Currency Members | System Namespace


Currency.ToString

Converts a Currency to a String.

Overload List

Converts this instance of Currency to a String.

[Visual Basic] Overloads Overrides Public Function ToString() As String
[C#] public override string ToString();
[C++] public: override String* ToString();
[JScript] public override function ToString() : String;

Converts a specified Currency to a String

[Visual Basic] Overloads Public Shared Function ToString(Currency) As String
[C#] public static string ToString(Currency);
[C++] public: static String* ToString(Currency);
[JScript] public static function ToString(Currency) : String;

See Also

Currency Structure | Currency Members | System Namespace


Currency.ToString ()

Converts this instance of Currency to a String.

[Visual Basic]
Overloads Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

The result of converting this instance to a String.

Remarks

The ToString converts this instance of Currency to a String. The returned string can not have any leading or trailing white space, and no leading zeros. It must be one of the following forms:

  • SignoptDigits.DigitsoptExponentopt
  • Signopt Digits Exponentopt

Where Sign can be "-", the digits are 0, 1, 2, 3, 4, 5, 6, 7, 8, or 9, and Exponent is of the form:

  • ExponentIndicator Signopt Digits

Where ExponentIndicator is "e", Sign can be "-".

See Also

Currency Structure | Currency Members | System Namespace | Currency.ToString Overload List


Currency.ToString (Currency)

Converts a specified Currency to a String

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal c As Currency _
) As String
[C#]
public static string ToString(
   Currency c
);
[C++]
public: static String* ToString(
   Currency c
);
[JScript]
public static function ToString(
   c : Currency
) : String;

Parameters

c
A Currency value.

Return Value

Returns the result of converting the Currency value to a string.

Remarks

The ToString converts this instance of a Currency to a String. The string returned cannot have any leading or trailing white space, and no leading zeros. It must be one of the following forms:

  • SignoptDigits.DigitsoptExponentopt
  • Signopt Digits Exponentopt

Where Sign can be "-", the digits are 0, 1, 2, 3, 4, 5, 6, 7, 8, or 9, and Exponent is of the form:

  • ExponentIndicator Signopt Digits

Where ExponentIndicator is "e", Sign can be "-".

See Also

Currency Structure | Currency Members | System Namespace | Currency.ToString Overload List


Currency.ToUInt32

Converts a Currency to a UInt32.

[Visual Basic]
Public Shared Function ToUInt32( _
   ByVal c As Currency _
) As UInt32
[C#]
public static uint ToUInt32(
   Currency c
);
[C++]
public: static unsigned int ToUInt32(
   Currency c
);
[JScript]
public static function ToUInt32(
   c : Currency
) : UInt32;

Parameters

c
A Currency value.

Return Value

The result of converting the Currency value to UInt32.

Exceptions

Exception Type | Condition
OverflowException | If the Currency value is outside the acceptable range.

Remarks

Note that this method is not CLS complaint.

The ToUInt32 converts this instance of Currency to a UInt32 (uint) value. The Currency value is rounded towards zero to the nearest integer value, and the result of this operation is returned as an unsigned integer.An overflow exception is thrown if the Currency value is less than MinValue or greater than MaxValue.

See Also

Currency Structure | Currency Members | System Namespace


Currency.ToUInt64

Converts a Currency to a UInt64.

[Visual Basic]
Public Shared Function ToUInt64( _
   ByVal c As Currency _
) As UInt64
[C#]
public static ulong ToUInt64(
   Currency c
);
[C++]
public: static unsigned __int64 ToUInt64(
   Currency c
);
[JScript]
public static function ToUInt64(
   c : Currency
) : UInt64;

Parameters

c
A Currency value.

Return Value

Returns the result of converting the Currency value to a UInt64.

Exceptions

Exception Type | Condition
OverflowException | If the Currency value is outside the acceptable range.

Remarks

Note that this method is not CLS complaint.

The ToUInt64 method converts this instance of a Currency value to a UInt64 (ulong) value. The Currency value is rounded towards zero to the nearest integer value, and the result of this operation is returned as an unsigned long.An overflow exception is thrown if the Currency value is less than MinValue or greater than MaxValue.

See Also

Currency Structure | Currency Members | System Namespace


Currency.Truncate

Truncates a Currency to an integer value.

[Visual Basic]
Public Shared Function Truncate( _
   ByVal c As Currency _
) As Currency
[C#]
public static Currency Truncate(
   Currency c
);
[C++]
public: static Currency Truncate(
   Currency c
);
[JScript]
public static function Truncate(
   c : Currency
) : Currency;

Parameters

c
The Currency to truncate.

Return Value

The Currency value, rounded towards zero to the nearest integer value.

Remarks

The Truncate method changes the Currency value by removing all the number beyond the decimal point and rounding the result to the nearest integer.

Precisely, the Currency argument is rounded towards zero to the nearest integer value, corresponding to removing all digits after the decimal point.

See Also

Currency Structure | Currency Members | System Namespace


Operators and Type Conversions

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Currency Operators and Type Conversions

The operators and type conversions of the Currency structure are listed below. For a complete list of Currency structure members, see the Currency Members topic.

Public:

Addition Operator | [To be supplied.]
Decrement Operator | [To be supplied.]
Division Operator | Divides two Currency values and produces a Currency result.
Equality Operator | [To be supplied.]
Greater Than Operator | [To be supplied.]
Greater Than Or Equal Operator | [To be supplied.]
Increment Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Less Than Operator | [To be supplied.]
Less Than Or Equal Operator | [To be supplied.]
Multiplication Operator | Multiplies two Currency values and produces a Currency result.
Subtraction Operator | [To be supplied.]
Unary Negation Operator | [To be supplied.]
Unary Plus Operator | [To be supplied.]
Double to Currency Conversion | [To be supplied.]
Currency to Byte Conversion | [To be supplied.]
Decimal to Currency Conversion | [To be supplied.]
Int64 to Currency Conversion | [To be supplied.]
UInt64 to Currency Conversion | [To be supplied.]
Single to Currency Conversion | [To be supplied.]
Currency to Int64 Conversion | [To be supplied.]
Currency to Single Conversion | [To be supplied.]
Currency to Double Conversion | [To be supplied.]
Currency to Int32 Conversion | [To be supplied.]
Currency to SByte Conversion | [To be supplied.]
Currency to Int16 Conversion | [To be supplied.]
Currency to UInt16 Conversion | [To be supplied.]
SByte to Currency Conversion | Overloaded. [To be supplied.]

See Also

Currency Structure | System Namespace


Currency Addition Operator

[To be supplied.]

[C#]
public static Currency operator +(
   Currency c1,
   Currency c2
);
[C++]
public: static Currency operator op_Addition(
   Currency c1,
   Currency c2
);
[JScript]
returnValue = c1 + c2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

c1
[To be supplied.]
c2
[To be supplied.]

Parameters [C#, C++]

c1
[To be supplied.]
c2
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace


Currency Decrement Operator

[To be supplied.]

[C#]
public static Currency operator --(
   Currency c
);
[C++]
public: static Currency operator op_Decrement(
   Currency c
);
[JScript]
returnValue = c--;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

c
[To be supplied.]

Parameters [C#, C++]

c
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace


Currency Division Operator

Divides two Currency values and produces a Currency result.

[C#]
public static Currency operator /(
   Currency c1,
   Currency c2
);
[C++]
public: static Currency operator op_Division(
   Currency c1,
   Currency c2
);
[JScript]
returnValue = c1 / c2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

c1
The left operand (the dividend).
c2
The right operand (the divisor).

Parameters [C#, C++]

c1
The left operand (the dividend).
c2
The right operand (the divisor).

Return Value [C#, C++, JScript]

The value is the Currency result of evaluating c1/ c2.

Exceptions

Exception Type | Condition
DivideByZeroException | if c2 is zero.

Remarks [C#, C++, JScript]

op_Division returns the result of dividing two Currency values (c1/ c2) as Currency.

See Also

Currency Structure | Currency Members | System Namespace


Currency Equality Operator

[To be supplied.]

[C#]
public static bool operator ==(
   Currency c1,
   Currency c2
);
[C++]
public: static bool operator op_Equality(
   Currency c1,
   Currency c2
);
[JScript]
returnValue = c1 == c2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

c1
[To be supplied.]
c2
[To be supplied.]

Parameters [C#, C++]

c1
[To be supplied.]
c2
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace


Currency Greater Than Operator

[To be supplied.]

[C#]
public static bool operator >(
   Currency c1,
   Currency c2
);
[C++]
public: static bool operator op_GreaterThan(
   Currency c1,
   Currency c2
);
[JScript]
returnValue = c1 > c2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

c1
[To be supplied.]
c2
[To be supplied.]

Parameters [C#, C++]

c1
[To be supplied.]
c2
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace


Currency Greater Than Or Equal Operator

[To be supplied.]

[C#]
public static bool operator >=(
   Currency c1,
   Currency c2
);
[C++]
public: static bool operator op_GreaterThanOrEqual(
   Currency c1,
   Currency c2
);
[JScript]
returnValue = c1 >= c2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

c1
[To be supplied.]
c2
[To be supplied.]

Parameters [C#, C++]

c1
[To be supplied.]
c2
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace


Currency Increment Operator

[To be supplied.]

[C#]
public static Currency operator ++(
   Currency c
);
[C++]
public: static Currency operator op_Increment(
   Currency c
);
[JScript]
returnValue = c++;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

c
[To be supplied.]

Parameters [C#, C++]

c
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace


Currency Inequality Operator

[To be supplied.]

[C#]
public static bool operator !=(
   Currency c1,
   Currency c2
);
[C++]
public: static bool operator op_Inequality(
   Currency c1,
   Currency c2
);
[JScript]
returnValue = c1 ! = c2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

c1
[To be supplied.]
c2
[To be supplied.]

Parameters [C#, C++]

c1
[To be supplied.]
c2
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace


Currency Less Than Operator

[To be supplied.]

[C#]
public static bool operator <(
   Currency c1,
   Currency c2
);
[C++]
public: static bool operator op_LessThan(
   Currency c1,
   Currency c2
);
[JScript]
returnValue = c1 < c2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

c1
[To be supplied.]
c2
[To be supplied.]

Parameters [C#, C++]

c1
[To be supplied.]
c2
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace


Currency Less Than Or Equal Operator

[To be supplied.]

[C#]
public static bool operator <=(
   Currency c1,
   Currency c2
);
[C++]
public: static bool operator op_LessThanOrEqual(
   Currency c1,
   Currency c2
);
[JScript]
returnValue = c1 <= c2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

c1
[To be supplied.]
c2
[To be supplied.]

Parameters [C#, C++]

c1
[To be supplied.]
c2
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace


Currency Multiplication Operator

Multiplies two Currency values and produces a Currency result.

[C#]
public static Currency operator *(
   Currency c1,
   Currency c2
);
[C++]
public: static Currency operator op_Multiply(
   Currency c1,
   Currency c2
);
[JScript]
returnValue = c1 * c2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

c1
The left operand.
c2
The right operand.

Parameters [C#, C++]

c1
The left operand.
c2
The right operand.

Return Value [C#, C++, JScript]

The Currency result of evaluating c1 * c2.

See Also

Currency Structure | Currency Members | System Namespace


Currency Subtraction Operator

[To be supplied.]

[C#]
public static Currency operator -(
   Currency c1,
   Currency c2
);
[C++]
public: static Currency operator op_Subtraction(
   Currency c1,
   Currency c2
);
[JScript]
returnValue = c1 - c2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

c1
[To be supplied.]
c2
[To be supplied.]

Parameters [C#, C++]

c1
[To be supplied.]
c2
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace


Currency Unary Negation Operator

[To be supplied.]

[C#]
public static Currency operator -(
   Currency c
);
[C++]
public: static Currency operator op_UnaryNegation(
   Currency c
);
[JScript]
returnValue = -c;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

c
[To be supplied.]

Parameters [C#, C++]

c
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace


Currency Unary Plus Operator

[To be supplied.]

[C#]
public static Currency operator +(
   Currency c
);
[C++]
public: static Currency operator op_UnaryPlus(
   Currency c
);
[JScript]
returnValue = +c;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

c
[To be supplied.]

Parameters [C#, C++]

c
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace


Double to Currency Conversion

[To be supplied.]

[C#]
public static explicit operator Currency(
   double value
);
[C++]
public: static Currency op_Explicit(
   double value
);
[JScript]
returnValue = Currency(value);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#, C++]

value
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace


Currency to Byte Conversion

[To be supplied.]

[C#]
public static explicit operator byte(
   Currency value
);
[C++]
public: operator unsigned char();
[JScript]
returnValue = Byte(value);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#]

value
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace


Decimal to Currency Conversion

[To be supplied.]

[C#]
public static explicit operator Currency(
   Decimal value
);
[C++]
public: static Currency op_Explicit(
   Decimal value
);
[JScript]
returnValue = Currency(value);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#, C++]

value
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace


Int64 to Currency Conversion

[To be supplied.]

[C#]
public static explicit operator Currency(
   long value
);
[C++]
public: static Currency op_Explicit(
   __int64 value
);
[JScript]
returnValue = Currency(value);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#, C++]

value
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace


UInt64 to Currency Conversion

[To be supplied.]

[C#]
public static explicit operator Currency(
   ulong value
);
[C++]
public: static Currency op_Explicit(
   unsigned __int64 value
);
[JScript]
returnValue = Currency(value);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#, C++]

value
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace


Single to Currency Conversion

[To be supplied.]

[C#]
public static explicit operator Currency(
   float value
);
[C++]
public: static Currency op_Explicit(
   float value
);
[JScript]
returnValue = Currency(value);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#, C++]

value
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace


Currency to Int64 Conversion

[To be supplied.]

[C#]
public static explicit operator long(
   Currency value
);
[C++]
public: operator __int64();
[JScript]
returnValue = Int64(value);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#]

value
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace


Currency to Single Conversion

[To be supplied.]

[C#]
public static explicit operator float(
   Currency value
);
[C++]
public: operator float();
[JScript]
returnValue = Single(value);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#]

value
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace


Currency to Double Conversion

[To be supplied.]

[C#]
public static explicit operator double(
   Currency value
);
[C++]
public: operator double();
[JScript]
returnValue = Double(value);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#]

value
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace


Currency to Int32 Conversion

[To be supplied.]

[C#]
public static explicit operator int(
   Currency value
);
[C++]
public: operator int();
[JScript]
returnValue = Int32(value);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#]

value
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace


Currency to SByte Conversion

[To be supplied.]

[C#]
public static explicit operator sbyte(
   Currency value
);
[C++]
public: operator char();
[JScript]
returnValue = SByte(value);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#]

value
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace


Currency to Int16 Conversion

[To be supplied.]

[C#]
public static explicit operator short(
   Currency value
);
[C++]
public: operator short();
[JScript]
returnValue = Int16(value);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#]

value
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace


Currency to UInt16 Conversion

[To be supplied.]

[C#]
public static explicit operator ushort(
   Currency value
);
[C++]
public: operator unsigned short();
[JScript]
returnValue = UInt16(value);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#]

value
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace


NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SByte to Currency Conversion

Build number 1812.

© 2000 Microsoft Corporation. All rights reserved.


SByte to Currency Conversion

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SByte to Currency Conversion (SByte)

[To be supplied.]

[C#]
public static implicit operator Currency(
   sbyte value
);
[C++]
public: static Currency op_Implicit(
   char value
);
[JScript]
returnValue = value;

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#, C++]

value
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace | Currency to Conversion Overload List


Byte to Currency Conversion

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Byte to Currency Conversion (Byte)

[To be supplied.]

[C#]
public static implicit operator Currency(
   byte value
);
[C++]
public: static Currency op_Implicit(
   unsigned char value
);
[JScript]
returnValue = value;

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#, C++]

value
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace | Currency to Conversion Overload List


Int32 to Currency Conversion

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Int32 to Currency Conversion (Int32)

[To be supplied.]

[C#]
public static implicit operator Currency(
   int value
);
[C++]
public: static Currency op_Implicit(
   int value
);
[JScript]
returnValue = value;

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#, C++]

value
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace | Currency to Conversion Overload List


Char to Currency Conversion

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Char to Currency Conversion (Char)

[To be supplied.]

[C#]
public static implicit operator Currency(
   char value
);
[C++]
public: static Currency op_Implicit(
   __wchar_t value
);
[JScript]
returnValue = value;

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#, C++]

value
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace | Currency to Conversion Overload List


Int16 to Currency Conversion

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Int16 to Currency Conversion (Int16)

[To be supplied.]

[C#]
public static implicit operator Currency(
   short value
);
[C++]
public: static Currency op_Implicit(
   short value
);
[JScript]
returnValue = value;

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#, C++]

value
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace | Currency to Conversion Overload List


UInt32 to Currency Conversion

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UInt32 to Currency Conversion (UInt32)

[To be supplied.]

[C#]
public static implicit operator Currency(
   uint value
);
[C++]
public: static Currency op_Implicit(
   unsigned int value
);
[JScript]
returnValue = value;

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#, C++]

value
[To be supplied.]

See Also

Currency Structure | Currency Members | System Namespace | Currency to Conversion Overload List


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Currency Fields

The fields of the Currency structure are listed below. For a complete list of Currency structure members, see the Currency Members topic.

Public:

Empty | Representing the constant that is a Currency value that is empty.
MaxValue | Representing the constant that is the largest possible Currency value.
MinusOne | Representing the constant that is the currency value-1.
MinValue | Representing the constant that is the smallest possible Currency value.
One | Representing the constant that is the Currency value 1.
Zero | Representing the constant that is the Currency value 0.

See Also

Currency Structure | System Namespace


Currency.Empty

Representing the constant that is a Currency value that is empty.

[Visual Basic]
Public Shared ReadOnly Empty As Currency
[C#]
public static readonly Currency Empty;
[C++]
public: static readonly Currency Empty;
[JScript]
public static var Empty : Currency;

Remarks

The Empty data member is the constant value of Zero, which is 0.

See Also

Currency Structure | Currency Members | System Namespace


Currency.MaxValue

Representing the constant that is the largest possible Currency value.

[Visual Basic]
Public Shared ReadOnly MaxValue As Currency
[C#]
public static readonly Currency MaxValue;
[C++]
public: static readonly Currency MaxValue;
[JScript]
public static var MaxValue : Currency;

Remarks

The value of the MaxValue constant is positive 922,337,203,685,477.5807.

The hexadecimal value of Currency.MaxValue is 0x7FFFFFFFFFFFFFFFL.

See Also

Currency Structure | Currency Members | System Namespace


Currency.MinusOne

Representing the constant that is the currency value-1.

[Visual Basic]
Public Shared ReadOnly MinusOne As Currency
[C#]
public static readonly Currency MinusOne;
[C++]
public: static readonly Currency MinusOne;
[JScript]
public static var MinusOne : Currency;

Remarks

The MinueOne data member is the constant value of-1.

See Also

Currency Structure | Currency Members | System Namespace


Currency.MinValue

Representing the constant that is the smallest possible Currency value.

[Visual Basic]
Public Shared ReadOnly MinValue As Currency
[C#]
public static readonly Currency MinValue;
[C++]
public: static readonly Currency MinValue;
[JScript]
public static var MinValue : Currency;

Remarks

The value of the MinValue constant is negative 922,337,203,685,477.5808.

The hexadecimal value of Currency.MinValue is 0x8000000000000000L.

See Also

Currency Structure | Currency Members | System Namespace


Currency.One

Representing the constant that is the Currency value 1.

[Visual Basic]
Public Shared ReadOnly One As Currency
[C#]
public static readonly Currency One;
[C++]
public: static readonly Currency One;
[JScript]
public static var One : Currency;

Remarks

The One data member is the constant value of 1.

See Also

Currency Structure | Currency Members | System Namespace


Currency.Zero

Representing the constant that is the Currency value 0.

[Visual Basic]
Public Shared ReadOnly Zero As Currency
[C#]
public static readonly Currency Zero;
[C++]
public: static readonly Currency Zero;
[JScript]
public static var Zero : Currency;

Remarks

The Zero data member is the constant value of 0.

See Also

Currency Structure | Currency Members | System Namespace


DateTime Structure

Represents a date and time value.

Object
ValueType
DateTime

[Visual Basic]
Public Structure DateTime
   Implements IComparable, IFormattable, IConvertible
[C#]
public struct DateTime : IComparable, IFormattable, IConvertible
[C++]
public __value struct DateTime : public IComparable, IFormattable,
   IConvertible

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

A DateTime object has a property named Ticks that stores the date and time as the number of 100-nanosecond intervals since 12:00 AM January 1, 1 A.D (year) in the GregorianCalendar.

For example, a ticks value of 31241376000000000L has the string representation "Friday, January 01, 0100 12:00:00 AM". Each additional tick increases the time interval by 100-nanoseconds.

The default string format options that may be used in Format are as follows:

d | Short Date
D | Long Date
f | Full (long date + short time)
F | Full (long date + long time)
g | General (short date + short time)
G | General (short date + long time)
m, M | Month/Day Date
r, R | RFC Standard
s | Sortable without TimeZone info
t | Short Time
T | Long Time
u | Universal with sort able format
U | Universal with Full (long date + long time) format
y, Y | Year/Month Date
Note Some systems will not be able to get dates for 2-digit years of less than 1930. This is because OLE Automation string parsing routines look for at your computer's default short date string format, which uses 2-digit years on most computers. To fix this, go to Control Panel, Regional Settings, then Date and change the short date type to specify a 4-digits year ("m/d/yyyy").

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

DateTime Members | System Namespace | IComparable | IFormattable | IConvertible | Calendar | GregorianCalendar | JulianCalendar | ization[cref.Globalization | CultureInfo | DateTimeFormatInfo | TimeSpan


DateTime Members

Public:

Constructor

DateTime Constructor Overloaded. Initializes a new instance of the DateTime class.

Properties

Date | Retrieves the date of the instance with the time value set to midnight.
Day | Retrieves the day of the month represented by this instance.
DayOfWeek | Retrieves the day of the week represented by this instance.
DayOfYear | Retrieves the day of the year represented by this instance.
Hour | Retrieves the hour part represented by this instance.
Millisecond | Retrieves the millisecond part represented by this instance.
Minute | Retrieves the minute represented by this instance.
Month | Retrieves the month represented by this instance.
Now | Retrieves a DateTime representing the current date and time.
Second | Retrieves the second's part of this instance.
Ticks | Retrieves the 100-nanosecond tick count for this instance.
TimeOfDay | Retrieves the time of day for this instance.
Today | Retrieves the current date.
Year | Retrieves the year part of this instance.

Methods

Add | Returns the DateTime result of adding this instance to a TimeSpan.
AddDays | Returns the DateTime result of adding this instance to a fractional number of days.
AddHours | Returns the DateTime result from adding this instance to a fractional number of hours.
AddMilliseconds | Returns the DateTime result from adding this instance to the specified number of milliseconds.
AddMinutes | Returns the DateTime result from adding this instance to a fractional number of minutes.
AddMonths | Returns the DateTime result from adding this instance to the specified number of months.
AddSeconds | Returns the DateTime result from adding this instance to a fractional number of seconds.
AddTicks | Returns the DateTime result from adding this instance to the specified number of 100-nanosecond ticks.
AddYears | Returns the DateTime result from adding this instance to the specified number of years.
Compare | Compares two DateTime values.
CompareTo | Compares this instance to a specified object.
DaysInMonth | Returns the number of days in a month determined by the specified year and month.
Equals | Overloaded. Determines whether this instance and as a specified time are the same.
Format | Converts this DateTime to a String with the specified format string and IServiceObjectProvider.
FromFileTime | Creates a DateTime from an Operating System file time.
FromOADate | Creates a DateTime from an OLE Automation Date.
FromString | Creates a DateTime from a String.
GetAllDateTimes | Overloaded. OBSOLETE. Use GetDateTimeFormats instead.
GetDateTimeFormats | Overloaded. Returns the DateTime format string.
GetHashCode | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | Returns the type code for this instance.
IsLeapYear | Determines whether a specified year is a leap year.
Parse | Overloaded. Creates a DateTime from a String.
ParseExact | Overloaded. Creates a DateTime from a string.
Subtract | Overloaded. Subtracts a number from this DateTime.
ToBoolean | Converts this instance to a Boolean value
ToByte | Converts this instance to a Byte value
ToChar | Converts this instance to a Char value
ToDateTime | Converts this instance to a DateTime value
ToDecimal | Converts this instance to a Decimal value
ToDouble | Converts this instance to a Double value
ToFileTime | Converts the value of this DateTime to the format of the local system file time.
ToInt16 | Converts this instance into an Int16.
ToInt32 | Converts this instance into an Int32.
ToInt64 | Converts this instance into an Int64.
ToLocalTime | Converts UTC to local time.
ToLongDateString | Converts the date value of this instance to a String.
ToLongTimeString | Converts the time value of this instance to a String.
ToOADate | Converts the DateTime instance into an OLE Automation compatible date.
ToSByte | Converts this instance to an SByte.
ToShortDateString | Converts the date value of this instance to a String.
ToShortTimeString | Converts the time value of the instance to a String.
ToSingle | Converts this instance into a Single.
ToString | Overloaded. Converts the date and time value of this instance to a String.
ToType | Converts this instance to a Type.
ToUInt16 | Converts this instance to a UInt16.
ToUInt32 | Converts this instance to a UInt32.
ToUInt64 | Converts this instance to a UInt64.
ToUniversalTime | Converts local time to UTC.

Operators

Addition Operator | Adds a TimeSpan value to a DateTime value.
Equality Operator | Determines whether two DateTime values are equal.
Greater Than Operator | Determines whether one DateTime value is greater than a specified DateTime.
Greater Than Or Equal Operator | Determines whether one DateTime value is greater than or equal to a specified DateTime.
Inequality Operator | Determines whether two DateTime values are not equal.
Less Than Operator | Determines whether one DateTime value is less than a specified DateTime.
Less Than Or Equal Operator | Determines whether one DateTime value is less than or equal to a specified DateTime.
Subtraction Operator | Overloaded. [To be supplied.]

Fields

Empty | Represents the constant DateTime empty value.
MaxValue | Represents the maximum DateTime value.
MinValue | Represents the minimum DateTime value.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DateTime Structure | System Namespace


DateTime Constructor

Initializes a new instance of the DateTime class.

Overload List

Initializes a new instance of the DateTime class to a specified number of Ticks.

[Visual Basic] Overloads Public Sub New(Long)
[C#] public DateTime(long);
[C++] public: DateTime(__int64);
[JScript] public function DateTime(long);

Initializes a new instance of the DateTime class to a specified year, month, and day.

[Visual Basic] Overloads Public Sub New(Integer, Integer, Integer)
[C#] public DateTime(int, int, int);
[C++] public: DateTime(int, int, int);
[JScript] public function DateTime(int, int, int);

Initializes a new instance of the DateTime class from the specified year, month, and day in the specified Calendar.

[Visual Basic] Overloads Public Sub New(Integer, Integer, Integer, Calendar)
[C#] public DateTime(int, int, int, Calendar);
[C++] public: DateTime(int, int, int, Calendar);
[JScript] public function DateTime(int, int, int, Calendar);

Initializes a new instance of the DateTime class using a specified year, month, day, hour, minute, and second.

[Visual Basic] Overloads Public Sub New(Integer, Integer, Integer, Integer, Integer, Integer)
[C#] public DateTime(int, int, int, int, int, int);
[C++] public: DateTime(int, int, int, int, int, int);
[JScript] public function DateTime(int, int, int, int, int, int);

Initializes a new instance of the DateTime class and sets it to a specified year, month, day, hour, minute, and second for the specified Calendar.

[Visual Basic] Overloads Public Sub New(Integer, Integer, Integer, Integer, Integer, Integer, Calendar)
[C#] public DateTime(int, int, int, int, int, int, Calendar);
[C++] public: DateTime(int, int, int, int, int, int, Calendar);
[JScript] public function DateTime(int, int, int, int, int, int, Calendar);

Initializes a new instance of the DateTime class using a specified year, month, day, hour, minute, second, and millisecond.

[Visual Basic] Overloads Public Sub New(Integer, Integer, Integer, Integer, Integer, Integer, Integer)
[C#] public DateTime(int, int, int, int, int, int, int);
[C++] public: DateTime(int, int, int, int, int, int, int);
[JScript] public function DateTime(int, int, int, int, int, int, int);

Initializes a new instance of the DateTime class using a specified year, month, day, hour, minute, second, and millisecond for the specified calendar.

[Visual Basic] Overloads Public Sub New(Integer, Integer, Integer, Integer, Integer, Integer, Integer, Calendar)
[C#] public DateTime(int, int, int, int, int, int, int, Calendar);
[C++] public: DateTime(int, int, int, int, int, int, int, Calendar);
[JScript] public function DateTime(int, int, int, int, int, int, int, Calendar);

See Also

DateTime Structure | DateTime Members | System Namespace


DateTime Constructor (Int64)

Initializes a new instance of the DateTime class to a specified number of Ticks.

[Visual Basic]
Overloads Public Sub New( _
   ByVal ticks As Long _
)
[C#]
public DateTime(
   long ticks
);
[C++]
public: DateTime(
   __int64 ticks
);
[JScript]
public function DateTime(
   ticks : long
);

Parameters

ticks
Number of 100-nanosecond intervals since 1/1/0001 12:00 AM.

Exceptions

Exception Type | Condition
ArgumentException | If ticks is less than DateTime.MinValue or greater than DateTime.MaxValue.

Remarks

This DateTime class initializes a new DateTime value that uses the ticks values for MinValue and MaxValue.

See Also

DateTime Structure | DateTime Members | System Namespace | DateTime Constructor Overload List | Int64 | Ticks


DateTime Constructor (Int32, Int32, Int32)

Initializes a new instance of the DateTime class to a specified year, month, and day.

[Visual Basic]
Overloads Public Sub New( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer _
)
[C#]
public DateTime(
   int year,
   int month,
   int day
);
[C++]
public: DateTime(
   int year,
   int month,
   int day
);
[JScript]
public function DateTime(
   year : int,
   month : int,
   day : int
);

Parameters

year
The year (1 through 9999).
month
The month (1 through 12).
day
The day (1 through 31).

Exceptions

Exception Type | Condition
ArgumentException | If the year is less than 1 or greater than 9999.
ArgumentException | If the month is less than 1 or greater than 12.
ArgumentException | If the day is less than 1 or greater than the number of days in the specified month.

Remarks

This DateTime class initializes a new instance of the DateTime to a specified year, month, and day. The time of day of the resulting DateTime is always midnight.

See Also

DateTime Structure | DateTime Members | System Namespace | DateTime Constructor Overload List | Int32


DateTime Constructor (Int32, Int32, Int32, Calendar)

Initializes a new instance of the DateTime class from the specified year, month, and day in the specified Calendar.

[Visual Basic]
Overloads Public Sub New( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal calendar As Calendar _
)
[C#]
public DateTime(
   int year,
   int month,
   int day,
   Calendar calendar
);
[C++]
public: DateTime(
   int year,
   int month,
   int day,
   Calendar* calendar
);
[JScript]
public function DateTime(
   year : int,
   month : int,
   day : int,
   calendar : Calendar
);

Parameters

year
An integer value that represents the year.
month
An integer value that represents the month.
day
An integer value that represents the day.
calendar
The Calendar in which the DateTime object is to represent a value.

Exceptions

Exception Type | Condition
ArgumentException | If the calendar is a null reference (in Visual Basic Nothing) .
ArgumentException | If the year is less than 1 or greater than 9999.
ArgumentException | If the month specifies a value outside the range of the specified calendar.
ArgumentException | If the day is less than 1 or greater than the number of days in the specified month.

Remarks

This DateTime class initializes a new instance of the DateTime from the given year, month, and day in the specified calendar. The time of day of the resulting DateTime is always midnight.

The allowable parameter values for year, month, and day depend upon the specified calendar that is used. The Globalization Namespace package provides implementation of the GregorianCalendar, JulianCalendar, and other calendars.

An argument is out of range for the specified calendar, if it is not possible to represent the specified arguments as a DateTime value. This is dependent upon the specified calendar. For example, if the Gregorian calendar is used, the value of day cannot be 8.

See Also

DateTime Structure | DateTime Members | System Namespace | DateTime Constructor Overload List | Int32 | Calendar


DateTime Constructor (Int32, Int32, Int32, Int32, Int32, Int32)

Initializes a new instance of the DateTime class using a specified year, month, day, hour, minute, and second.

[Visual Basic]
Overloads Public Sub New( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal hour As Integer, _
   ByVal minute As Integer, _
   ByVal second As Integer _
)
[C#]
public DateTime(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second
);
[C++]
public: DateTime(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second
);
[JScript]
public function DateTime(
   year : int,
   month : int,
   day : int,
   hour : int,
   minute : int,
   second : int
);

Parameters

year
The year (1 through 9999).
month
The month (1 through 12).
day
The day (1 through 31).
hour
The hours (0 through 23).
minute
The minutes (0 through 59).
second
The seconds (0 through 59).

Exceptions

Exception Type | Condition
ArgumentException | If the year is less than 1 or greater than 9999.
ArgumentException | If the month is less than 1 or greater than 12.
ArgumentException | If the day is less than 1 or greater than the number of days in the specified month.
ArgumentException | If the hour is less than 0 or greater than 23 .
ArgumentException | If the minute is less than 0 or greater than 59 .
ArgumentException | If the second is less than 0 or greater than 59 .

Remarks

This DateTime class initializes a new instance of the DateTime and sets its values to a specified year, month, day, hour, minute, and second values.

The allowable parameter values are:

  • year is between 1 and 9999 (1..9999).
  • month is between 1 and twelve (1..12).
  • day is between 1 and 31 (1..31).
  • hours is between 0 and 23 (0..23).
  • minutes is between 0 and 59 (0..59).
  • seconds is between 0 and 59 (0..59).

See Also

DateTime Structure | DateTime Members | System Namespace | DateTime Constructor Overload List | Int32


DateTime Constructor (Int32, Int32, Int32, Int32, Int32, Int32, Calendar)

Initializes a new instance of the DateTime class and sets it to a specified year, month, day, hour, minute, and second for the specified Calendar.

[Visual Basic]
Overloads Public Sub New( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal hour As Integer, _
   ByVal minute As Integer, _
   ByVal second As Integer, _
   ByVal calendar As Calendar _
)
[C#]
public DateTime(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   Calendar calendar
);
[C++]
public: DateTime(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   Calendar* calendar
);
[JScript]
public function DateTime(
   year : int,
   month : int,
   day : int,
   hour : int,
   minute : int,
   second : int,
   calendar : Calendar
);

Parameters

year
An integer value that represents the year.
month
An integer value that represents the month.
day
An integer value that represents the day.
hour
An integer value that represents the hour.
minute
An integer value that represents the minute.
second
An integer value that represents the second.
calendar
The Calendar where the DateTime object is to represent a value.

Exceptions

Exception Type | Condition
ArgumentException | If the calendar is a null reference (in Visual Basic Nothing) .
ArgumentException | If the year is less than 1 or greater than 9999.
ArgumentException | If the month specifies a value outside the range of the specified calendar.
ArgumentException | If the day is less than 1 or greater than the number of days in the specified month.
ArgumentException | If the hour is less than 0 or greater than 23 .
ArgumentException | If the minute is less than 0 or greater than 59 .
ArgumentException | If the second is less than 0 or greater than 59 .

Remarks

This DateTime class initializes a new instance of the DateTime and sets its values to a specified year, month, day, hour, minute, and second for the specified calendar.

The allowable parameter values for year, month, and day depend upon the specified calendar that is used. The Globalization Namespace package provides implementation of the GregorianCalendar, JulianCalendar, and other calendars.

An argument is out of range for the specified calendar if it is not possible to represent the given arguments as a DateTime value. This is dependent upon the specified calendar.

See Also

DateTime Structure | DateTime Members | System Namespace | DateTime Constructor Overload List | Int32 | Calendar


DateTime Constructor (Int32, Int32, Int32, Int32, Int32, Int32, Int32)

Initializes a new instance of the DateTime class using a specified year, month, day, hour, minute, second, and millisecond.

[Visual Basic]
Overloads Public Sub New( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal hour As Integer, _
   ByVal minute As Integer, _
   ByVal second As Integer, _
   ByVal millisecond As Integer _
)
[C#]
public DateTime(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   int millisecond
);
[C++]
public: DateTime(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   int millisecond
);
[JScript]
public function DateTime(
   year : int,
   month : int,
   day : int,
   hour : int,
   minute : int,
   second : int,
   millisecond : int
);

Parameters

year
The year (1 through 9999).
month
The month (1 through 12).
day
The day (1 through 31).
hour
The hours (0 through 23).
minute
The minutes (0 through 59).
second
The seconds (0 through 59).
millisecond
The milliseconds, as a floating point value.

Exceptions

Exception Type | Condition
ArgumentException | If the year is less than 1 or greater than 9999.
ArgumentException | If the month is less than 1 or greater than 12.
ArgumentException | If the day is less than 1 or greater than the number of days in the specified month.
ArgumentException | If the hour is less than 0 or greater than 23 .
ArgumentException | If the minute is less than 0 or greater than 59 .
ArgumentException | If the second is less than 0 or greater than 59 .
ArgumentException | If the millisecond is rounded up to the nearest integer.

Remarks

This DateTime class initializes a new instance of the DateTime that uses a specified year, month, day, hour, minute, second, and millisecond.

The allowable parameter values are:

  • year is between 1 and 9999 (1..9999).
  • month is between 1 and twelve (1..12).
  • day is between 1 and 31 (1..31).
  • hours is between 0 and 23 (0..23).
  • minutes is between 0 and 59 (0..59).
  • seconds is between 0 and 59 (0..59).
  • millisecond is the absolute value of the millisecond that is rounded up to the nearest integer is greater than or equal to 315537897600000.

An exception is thrown if the milliseconds parameter is less than the minimum ticks or greater than the maximum ticks.

See Also

DateTime Structure | DateTime Members | System Namespace | DateTime Constructor Overload List | Int32


DateTime Constructor (Int32, Int32, Int32, Int32, Int32, Int32, Int32, Calendar)

Initializes a new instance of the DateTime class using a specified year, month, day, hour, minute, second, and millisecond for the specified calendar.

[Visual Basic]
Overloads Public Sub New( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal hour As Integer, _
   ByVal minute As Integer, _
   ByVal second As Integer, _
   ByVal millisecond As Integer, _
   ByVal calendar As Calendar _
)
[C#]
public DateTime(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   int millisecond,
   Calendar calendar
);
[C++]
public: DateTime(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   int millisecond,
   Calendar* calendar
);
[JScript]
public function DateTime(
   year : int,
   month : int,
   day : int,
   hour : int,
   minute : int,
   second : int,
   millisecond : int,
   calendar : Calendar
);

Parameters

year
The year (1 through 9999).
month
The month (1 through 12).
day
The day (1 through 31).
hour
The hours (0 through 23).
minute
The minutes (0 through 59).
second
The seconds (0 through 59).
millisecond
The milliseconds, as a floating point value.
calendar
The Calendar where the DateTime object is to represent a value.

Exceptions

Exception Type | Condition
ArgumentException | If the calendar is a null reference (in Visual Basic Nothing).
ArgumentException | If the year is less than 1 or greater than 9999.
ArgumentException | If the month specifies a value outside the range of the specified calendar.
ArgumentException | If the day is less than 1 or greater than the number of days in the specified month.
ArgumentException | If the hour is less than 0 or greater than 23 .
ArgumentException | If the minute is less than 0 or greater than 59 .
ArgumentException | If the second is less than 0 or greater than 59 .
ArgumentException | If the millisecond is rounded up to the nearest integer.

Remarks

This DateTime class initializes a new instance of the DateTime that uses a specified year, month, day, hour, minute, second, and millisecond for the specified calendar.

The allowable parameter values are:

  • year is between 1 and 9999 (1..9999).
  • month is between 1 and twelve (1..12).
  • day is between 1 and 31 (1..31).
  • hours is between 0 and 23 (0..23).
  • minutes is between 0 and 59 (0..59).
  • seconds is between 0 and 59 (0..59).
  • millisecond is the absolute value of the millisecond that is rounded up to the nearest integer is greater than or equal to 315537897600000.
  • calendar is the value that represents the DateTime object.

An exception is thrown if the calendar arguments are out of range for the specified calendar or if it is not possible to represent the given arguments as a DateTime value. This is dependent upon the specified calendar. For example, if the GregorianCalendar calendar is used, the value of day cannot be 8.

The Calendar package provides implementation of the Gregorian, JulianCalendar, and other calendars.

An exception is thrown if milliseconds is less than the minimum ticks or greater than the maximum ticks.

See Also

DateTime Structure | DateTime Members | System Namespace | DateTime Constructor Overload List | Int32 | Calendar


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DateTime Properties

The properties of the DateTime structure are listed below. For a complete list of DateTime structure members, see the DateTime Members topic.

Public:

Date | Retrieves the date of the instance with the time value set to midnight.
Day | Retrieves the day of the month represented by this instance.
DayOfWeek | Retrieves the day of the week represented by this instance.
DayOfYear | Retrieves the day of the year represented by this instance.
Hour | Retrieves the hour part represented by this instance.
Millisecond | Retrieves the millisecond part represented by this instance.
Minute | Retrieves the minute represented by this instance.
Month | Retrieves the month represented by this instance.
Now | Retrieves a DateTime representing the current date and time.
Second | Retrieves the second's part of this instance.
Ticks | Retrieves the 100-nanosecond tick count for this instance.
TimeOfDay | Retrieves the time of day for this instance.
Today | Retrieves the current date.
Year | Retrieves the year part of this instance.

See Also

DateTime Structure | System Namespace


DateTime.Date

Retrieves the date of the instance with the time value set to midnight.

[Visual Basic]
Public ReadOnly Property Date As DateTime
[C#]
public DateTime Date {get;}
[C++]
public: __property DateTime get_Date();
[JScript]
public function get Date() : DateTime;

Property Value

Read-only.

Remarks

The Date property returns just the date portion of this DateTime instance with the time value set to midnight.

See Also

DateTime Structure | DateTime Members | System Namespace | Ticks | TicksPerDay


DateTime.Day

Retrieves the day of the month represented by this instance.

[Visual Basic]
Public ReadOnly Property Day As Integer
[C#]
public int Day {get;}
[C++]
public: __property int get_Day();
[JScript]
public function get Day() : int;

Property Value

Read-only.

Remarks

The Day property returns the day value as an 32-bit signed integer (int) between 1 and 31.

See Also

DateTime Structure | DateTime Members | System Namespace | Int32


DateTime.DayOfWeek

Retrieves the day of the week represented by this instance.

[Visual Basic]
Public ReadOnly Property DayOfWeek As Integer
[C#]
public int DayOfWeek {get;}
[C++]
public: __property int get_DayOfWeek();
[JScript]
public function get DayOfWeek() : int;

Property Value

Read-only.

Remarks

The DayOfWeek property is calculated by dividing the ticks by the ticks per day and the quotient divided by seven ((ticks/ TicksPerDay +1)/ 7) and returns an 32-bit signed integer (int) value.

The return values are integers (zero through six) that indicate the day of the week (Sunday through Saturday): 0 indicates Sunday, 1 indicates Monday, 2 indicates Tuesday, 3 indicates Wednesday, 4 indicates Thursday, 5 indicates Friday, and 6 indicates Saturday.

See Also

DateTime Structure | DateTime Members | System Namespace | Ticks | TicksPerDay | Int32


DateTime.DayOfYear

Retrieves the day of the year represented by this instance.

[Visual Basic]
Public ReadOnly Property DayOfYear As Integer
[C#]
public int DayOfYear {get;}
[C++]
public: __property int get_DayOfYear();
[JScript]
public function get DayOfYear() : int;

Property Value

Read-only.

Remarks

The DayOfYear property returns an 32-bit signed integer (int) between 1 and 366 that represents the number of the day in the year.

See Also

DateTime Structure | DateTime Members | System Namespace | Int32


DateTime.Hour

Retrieves the hour part represented by this instance.

[Visual Basic]
Public ReadOnly Property Hour As Integer
[C#]
public int Hour {get;}
[C++]
public: __property int get_Hour();
[JScript]
public function get Hour() : int;

Property Value

Read-only.

Remarks

The Hour property returns a value that is an 32-bit signed integer (int) between 0 and 23 for the number of the hour in the day.

See Also

DateTime Structure | DateTime Members | System Namespace | Int32 | Ticks


DateTime.Millisecond

Retrieves the millisecond part represented by this instance.

[Visual Basic]
Public ReadOnly Property Millisecond As Integer
[C#]
public int Millisecond {get;}
[C++]
public: __property int get_Millisecond();
[JScript]
public function get Millisecond() : int;

Property Value

Read-only.

Remarks

The Millisecond property returns a value that is an 32-bit signed integer (int) between 0 and 999 that is the number of milliseconds of this instance of DateTime.

It is calculated by dividing the ticks by the ticks per minute and the quotient divided by seven ((ticks/ TicksPerMinute)/ 60) and returns an 32-bit signed integer value.

See Also

DateTime Structure | DateTime Members | System Namespace | TicksPerMinute | Ticks | Int32


DateTime.Minute

Retrieves the minute represented by this instance.

[Visual Basic]
Public ReadOnly Property Minute As Integer
[C#]
public int Minute {get;}
[C++]
public: __property int get_Minute();
[JScript]
public function get Minute() : int;

Property Value

Read-only.

Minute value represented by this instance.

Remarks

The Minute property returns a value that is an 32-bit signed integer (int) between 0 and 59 that represents the number of minutes of this instance of DateTime.

See Also

DateTime Structure | DateTime Members | System Namespace | Int32


DateTime.Month

Retrieves the month represented by this instance.

[Visual Basic]
Public ReadOnly Property Month As Integer
[C#]
public int Month {get;}
[C++]
public: __property int get_Month();
[JScript]
public function get Month() : int;

Property Value

Read-only.

A month part value of this instance.

Remarks

The Month property returns an 32-bit signed integer (int) between 1 and 12 that represents a number for the month of this instance of DateTime.

See Also

DateTime Structure | DateTime Members | System Namespace | Int32


DateTime.Now

Retrieves a DateTime representing the current date and time.

[Visual Basic]
Public Shared ReadOnly Property Now As DateTime
[C#]
public static DateTime Now {get;}
[C++]
public: __property static DateTime get_Now();
[JScript]
public static function get Now() : DateTime;

Property Value

Read-only.

Remarks

The resolution of the Now property returns values depends on the system timer:

  • For Windows NT 3.5 and later, the timer resolution is approximately 10 milliseconds.
  • For Windows NT 3.1, it is approximately 16 milliseconds.
  • For Windows 95 and 98, it is approximately 55 milliseconds.

See Also

DateTime Structure | DateTime Members | System Namespace | Microsoft.Win32.Interop.Windows | Microsoft.Win32.SetFileTime


DateTime.Second

Retrieves the second's part of this instance.

[Visual Basic]
Public ReadOnly Property Second As Integer
[C#]
public int Second {get;}
[C++]
public: __property int get_Second();
[JScript]
public function get Second() : int;

Property Value

Read-only.

Remarks

The Second property returns a value that is an 32-bit signed integer (int) between 0 and 59 that represents the number of the seconds of this instance of DateTime.

It is calculated by dividing the ticks by the ticks per second and the quotient divided by seven ((ticks/ TicksPerSecond)/ 60) and returns an 32-bit signed integer value.

See Also

DateTime Structure | DateTime Members | System Namespace | Ticks | TicksPerSecond | Int32


DateTime.Ticks

Retrieves the 100-nanosecond tick count for this instance.

[Visual Basic]
Public ReadOnly Property Ticks As Long
[C#]
public long Ticks {get;}
[C++]
public: __property __int64 get_Ticks();
[JScript]
public function get Ticks() : long;

Property Value

Read-only.

Remarks

The Ticks property returns a value that is the number of 100-nanosecond intervals that have elapsed since 1/1/0001, 12:00am. Ticks are an 64-bit signed integer type (long).

The minimum ticks count is 0.

See Also

DateTime Structure | DateTime Members | System Namespace | Int64


DateTime.TimeOfDay

Retrieves the time of day for this instance.

[Visual Basic]
Public ReadOnly Property TimeOfDay As TimeSpan
[C#]
public TimeSpan TimeOfDay {get;}
[C++]
public: __property TimeSpan get_TimeOfDay();
[JScript]
public function get TimeOfDay() : TimeSpan;

Property Value

Read-only.

A value that is the time of day for this instance.

Remarks

The TimeOfDay property value is a TimeSpan that represents the time part of this instance (elapsed since midnight) of DateTime.

See Also

DateTime Structure | DateTime Members | System Namespace | TimeSpan


DateTime.Today

Retrieves the current date.

[Visual Basic]
Public Shared ReadOnly Property Today As DateTime
[C#]
public static DateTime Today {get;}
[C++]
public: __property static DateTime get_Today();
[JScript]
public static function get Today() : DateTime;

Property Value

Read-only.

Remarks

The Today property returns the current date for this instance of DateTime, and the time part of the day is zero (midnight).

See Also

DateTime Structure | DateTime Members | System Namespace | Calendar


DateTime.Year

Retrieves the year part of this instance.

[Visual Basic]
Public ReadOnly Property Year As Integer
[C#]
public int Year {get;}
[C++]
public: __property int get_Year();
[JScript]
public function get Year() : int;

Property Value

Read-only.

Remarks

The Year property returns value that is an 32-bit signed integer (int) between 1 and 9999 that represents the portion of the year of this instance of DateTime.

See Also

DateTime Structure | DateTime Members | System Namespace | Int32 | Calendar


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DateTime Methods

The methods of the DateTime structure are listed below. For a complete list of DateTime structure members, see the DateTime Members topic.

Public:

Add | Returns the DateTime result of adding this instance to a TimeSpan.
AddDays | Returns the DateTime result of adding this instance to a fractional number of days.
AddHours | Returns the DateTime result from adding this instance to a fractional number of hours.
AddMilliseconds | Returns the DateTime result from adding this instance to the specified number of milliseconds.
AddMinutes | Returns the DateTime result from adding this instance to a fractional number of minutes.
AddMonths | Returns the DateTime result from adding this instance to the specified number of months.
AddSeconds | Returns the DateTime result from adding this instance to a fractional number of seconds.
AddTicks | Returns the DateTime result from adding this instance to the specified number of 100-nanosecond ticks.
AddYears | Returns the DateTime result from adding this instance to the specified number of years.
Compare | Compares two DateTime values.
CompareTo | Compares this instance to a specified object.
DaysInMonth | Returns the number of days in a month determined by the specified year and month.
Equals | Overloaded. Determines whether this instance and as a specified time are the same.
Format | Converts this DateTime to a String with the specified format string and IServiceObjectProvider.
FromFileTime | Creates a DateTime from an Operating System file time.
FromOADate | Creates a DateTime from an OLE Automation Date.
FromString | Creates a DateTime from a String.
GetAllDateTimes | Overloaded. OBSOLETE. Use GetDateTimeFormats instead.
GetDateTimeFormats | Overloaded. Returns the DateTime format string.
GetHashCode | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | Returns the type code for this instance.
IsLeapYear | Determines whether a specified year is a leap year.
Parse | Overloaded. Creates a DateTime from a String.
ParseExact | Overloaded. Creates a DateTime from a string.
Subtract | Overloaded. Subtracts a number from this DateTime.
ToBoolean | Converts this instance to a Boolean value
ToByte | Converts this instance to a Byte value
ToChar | Converts this instance to a Char value
ToDateTime | Converts this instance to a DateTime value
ToDecimal | Converts this instance to a Decimal value
ToDouble | Converts this instance to a Double value
ToFileTime | Converts the value of this DateTime to the format of the local system file time.
ToInt16 | Converts this instance into an Int16.
ToInt32 | Converts this instance into an Int32.
ToInt64 | Converts this instance into an Int64.
ToLocalTime | Converts UTC to local time.
ToLongDateString | Converts the date value of this instance to a String.
ToLongTimeString | Converts the time value of this instance to a String.
ToOADate | Converts the DateTime instance into an OLE Automation compatible date.
ToSByte | Converts this instance to an SByte.
ToShortDateString | Converts the date value of this instance to a String.
ToShortTimeString | Converts the time value of the instance to a String.
ToSingle | Converts this instance into a Single.
ToString | Overloaded. Converts the date and time value of this instance to a String.
ToType | Converts this instance to a Type.
ToUInt16 | Converts this instance to a UInt16.
ToUInt32 | Converts this instance to a UInt32.
ToUInt64 | Converts this instance to a UInt64.
ToUniversalTime | Converts local time to UTC.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DateTime Structure | System Namespace


DateTime.Add

Returns the DateTime result of adding this instance to a TimeSpan.

[Visual Basic]
Public Function Add( _
   ByVal value As TimeSpan _
) As DateTime
[C#]
public DateTime Add(
   TimeSpan value
);
[C++]
public: DateTime Add(
   TimeSpan value
);
[JScript]
public function Add(
   value : TimeSpan
) : DateTime;

Parameters

value
The TimeSpan added to this instance.

Return Value

The DateTime value that results from adding the specified TimeSpan to this instance.

Exceptions

Exception Type | Condition
ArgumentException | If the resulting DateTime is outside the supported range.

Remarks

A specified TimeSpan is added to this instance of DateTime, and the result is returned as a new DateTime.

See Also

DateTime Structure | DateTime Members | System Namespace | TimeSpan


DateTime.AddDays

Returns the DateTime result of adding this instance to a fractional number of days.

[Visual Basic]
Public Function AddDays( _
   ByVal value As Double _
) As DateTime
[C#]
public DateTime AddDays(
   double value
);
[C++]
public: DateTime AddDays(
   double value
);
[JScript]
public function AddDays(
   value : double
) : DateTime;

Parameters

value
A fractional number of days.

Return Value

DateTime value that results from adding a fractional number of days to this instance.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | If the resulting DateTime is outside the supported range.

Remarks

The AddDays method returns the value parameter that is computed by rounding the fractional number of days specified by value to the nearest millisecond, and then the result of that interval is added to this instance of DateTime.

The value parameter argument can be negative.

See Also

DateTime Structure | DateTime Members | System Namespace | Double | Day


DateTime.AddHours

Returns the DateTime result from adding this instance to a fractional number of hours.

[Visual Basic]
Public Function AddHours( _
   ByVal value As Double _
) As DateTime
[C#]
public DateTime AddHours(
   double value
);
[C++]
public: DateTime AddHours(
   double value
);
[JScript]
public function AddHours(
   value : double
) : DateTime;

Parameters

value
A fractional number of hours.

Return Value

The DateTime value that results from adding a fractional number of hours to this instance.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | If the resulting DateTime is outside the supported range.

Remarks

The AddHours returns the value parameter that is computed by rounding the fractional number of hours specified by value to the nearest millisecond of the nearest integer, and then adding the interval to this instance of DateTime.

The value parameter argument is permitted to be negative.

See Also

DateTime Structure | DateTime Members | System Namespace | Double | Hour


DateTime.AddMilliseconds

Returns the DateTime result from adding this instance to the specified number of milliseconds.

[Visual Basic]
Public Function AddMilliseconds( _
   ByVal value As Double _
) As DateTime
[C#]
public DateTime AddMilliseconds(
   double value
);
[C++]
public: DateTime AddMilliseconds(
   double value
);
[JScript]
public function AddMilliseconds(
   value : double
) : DateTime;

Parameters

value
A number of milliseconds.

Return Value

The DateTime value results from adding the specified number of milliseconds to this instance.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | If the resulting DateTime is outside the supported range.

Remarks

The AddMilliseconds method is a computation from a fractional number of minutes of this instance. The result is computed by rounding the number of milliseconds specified by value to the nearest integer and the interval to this instance of DateTime.

The value parameter argument can be negative.

See Also

DateTime Structure | DateTime Members | System Namespace | Double | Millisecond


DateTime.AddMinutes

Returns the DateTime result from adding this instance to a fractional number of minutes.

[Visual Basic]
Public Function AddMinutes( _
   ByVal value As Double _
) As DateTime
[C#]
public DateTime AddMinutes(
   double value
);
[C++]
public: DateTime AddMinutes(
   double value
);
[JScript]
public function AddMinutes(
   value : double
) : DateTime;

Parameters

value
A fractional number of minutes.

Return Value

The DateTime results from adding a fractional number of minutes to this instance.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | If the resulting DateTime is outside the supported range.

Remarks

The AddMinutes method is computed by rounding the fractional number of minutes specified by value to the nearest millisecond, then that interval is added to this instance of DateTime.

The value parameter argument can be negative.

See Also

DateTime Structure | DateTime Members | System Namespace | Double | Minute


DateTime.AddMonths

Returns the DateTime result from adding this instance to the specified number of months.

[Visual Basic]
Public Function AddMonths( _
   ByVal months As Integer _
) As DateTime
[C#]
public DateTime AddMonths(
   int months
);
[C++]
public: DateTime AddMonths(
   int months
);
[JScript]
public function AddMonths(
   months : int
) : DateTime;

Parameters

months
A number of months.

Return Value

The DateTime results from adding the specified number of months to this instance.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | If the resulting DateTime is outside the supported range.

Remarks

The AddMonths method result is computed by incrementing (or decrementing) the year and month parts of this instance by value months. If required, the day part of the resulting date is adjusted downwards to the last day of the resulting month in the resulting year.

The time of day part of the result is the same as the time of day part of this instance of DateTime. In more precise terms, consider this instance to be of the form:

y/ m/ d + t,

where y is the year, m is the month, d is the day, and t is the time of day.

The result is:

y1/ m1/ d1 + t,

where y1 and m1 are computed by adding value months to y and m, and d1 is the largest value less than or equal to d that denotes a valid day in month m1 of year y1.

The months parameter argument can be positive or negative.

See Also

DateTime Structure | DateTime Members | System Namespace | Int32 | Month


DateTime.AddSeconds

Returns the DateTime result from adding this instance to a fractional number of seconds.

[Visual Basic]
Public Function AddSeconds( _
   ByVal value As Double _
) As DateTime
[C#]
public DateTime AddSeconds(
   double value
);
[C++]
public: DateTime AddSeconds(
   double value
);
[JScript]
public function AddSeconds(
   value : double
) : DateTime;

Parameters

value
A fractional number of seconds.

Return Value

The DateTime results from adding a fractional number of seconds to this instance.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | If the resulting DateTime is outside the supported range.

Remarks

The AddSeconds method is computed by rounding the fractional number of seconds specified by value to the nearest millisecond; that interval is added to this instance of DateTime.

The value parameter argument can be negative.

See Also

DateTime Structure | DateTime Members | System Namespace | Double | Second


DateTime.AddTicks

Returns the DateTime result from adding this instance to the specified number of 100-nanosecond ticks.

[Visual Basic]
Public Function AddTicks( _
   ByVal value As Long _
) As DateTime
[C#]
public DateTime AddTicks(
   long value
);
[C++]
public: DateTime AddTicks(
   __int64 value
);
[JScript]
public function AddTicks(
   value : long
) : DateTime;

Parameters

value
The number of 100-nanosecond ticks.

Return Value

The DateTime results from adding the ticks to this instance.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | If the resulting DateTime is outside the supported range.

Remarks

The AddTicks method returns the DateTime value resulting from adding the specific number of 100-nanosecond ticks to this instance of DateTime.

The value parameter argument can be negative.

See Also

DateTime Structure | DateTime Members | System Namespace | Int64 | Ticks


DateTime.AddYears

Returns the DateTime result from adding this instance to the specified number of years.

[Visual Basic]
Public Function AddYears( _
   ByVal value As Integer _
) As DateTime
[C#]
public DateTime AddYears(
   int value
);
[C++]
public: DateTime AddYears(
   int value
);
[JScript]
public function AddYears(
   value : int
) : DateTime;

Parameters

value
A number of years.

Return Value

DateTime results from adding the specified number of years to this instance.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | If the resulting DateTime is outside the supported range.

Remarks

The AddYears method is computed by incrementing or decrementing the year part of this instance of DateTime by the number of specified years.

For example, if the month and day of this DateTime is 2/29 and if the resulting year is not a leap year, the month and day of the resulting DateTime becomes 2/28. Otherwise, the month, day, and time-of-day parts of the result are the same as those of this DateTime.

The value parameter argument can be either positive or negative.

See Also

DateTime Structure | DateTime Members | System Namespace | Int32 | Calendar | Year


DateTime.Compare

Compares two DateTime values.

[Visual Basic]
Public Shared Function Compare( _
   ByVal t1 As DateTime, _
   ByVal t2 As DateTime _
) As Integer
[C#]
public static int Compare(
   DateTime t1,
   DateTime t2
);
[C++]
public: static int Compare(
   DateTime t1,
   DateTime t2
);
[JScript]
public static function Compare(
   t1 : DateTime,
   t2 : DateTime
) : int;

Parameters

t1
The first DateTime value.
t2
The second DateTime value.

Return Value

Value Type | Condition
1 | If the first value is less than the second value.
0 | If the values are equal.
-1 | If the first value is greater than the second value.

Remarks

The Compare method is used the same method as Currency to compare two numbers. It returns an integer representing the results of that comparison:

  • Returns a one, if the first value is less than the second value (1, if t1 < t2).
  • Returns a zero, if the first value is equal the second value (0, if t1 = t2).
  • Returns a negative one, if the first value is more than the second value (-1, if t1 > t2).

The values (same as Currency, a negative number) are determined using the following equations:

1 if t 1 > t 2, 0 if t 1 = t 2, or-1 if t 1 < t 2.

DateTime t1 =...

DateTime t2 = ...

If (DateTime.Compare (t1, t2) > 0) Console.WriteLine ("t1 > t2"); If (DateTime.Compare (t1, t2) == 0) Console.WriteLine ("t1 == t2"); If (DateTime.Compare (t1, t2) < 0) Console.WriteLine ("t1 < t2");

See Also

DateTime Structure | DateTime Members | System Namespace | CompareTo | Int32


DateTime.CompareTo

Compares this instance to a specified object.

[Visual Basic]
Overridable Public Function CompareTo( _
   ByVal value As Object _
) As Integer
[C#]
public virtual int CompareTo(
   object value
);
[C++]
public: virtual int CompareTo(
   Object* value
);
[JScript]
public function CompareTo(
   value : Object
) : int;

Parameters

value
A DateTime value to compare to this instance .

Return Value

Value Type | Condition
A negative integer | If this instance is less than the value.
Zero | If this instance and the value have the same value.
A positive integer | If this instance is greater than the value.
A positive integer | If the value is a null reference (in Visual Basic Nothing). This is a special case.

Exceptions

Exception Type | Condition
ArgumentException | If the value is not a DateTime.

Remarks

The CompareTo method implements CompareTo. When comparing two DateTime values, the number of ticks is used to determine the ordering.

The value parameter that is compared must be another DateTime or a null reference.

As a special case, an instance, regardless of its value, is considered to be greater than a null reference.

See Also

DateTime Structure | DateTime Members | System Namespace | Object | IComparable


DateTime.DaysInMonth

Returns the number of days in a month determined by the specified year and month.

[Visual Basic]
Public Shared Function DaysInMonth( _
   ByVal year As Integer, _
   ByVal month As Integer _
) As Integer
[C#]
public static int DaysInMonth(
   int year,
   int month
);
[C++]
public: static int DaysInMonth(
   int year,
   int month
);
[JScript]
public static function DaysInMonth(
   year : int,
   month : int
) : int;

Parameters

year
The year.
month
The month (1..12).

Return Value

The value is the number of days in the month specified by the year and month arguments.

Exceptions

Exception Type | Condition
ArgumentException | If the month is less than 1 or greater than 12.

Remarks

The DaysInMonth method is used to retrieve the number of days in a month where the month and year are specified.

The month value is an integer one through twelve (1 through 12). For example: for the month of February (month equals 2), the returned value is 28 or 29, depending upon whether the year is a leap year.

See Also

DateTime Structure | DateTime Members | System Namespace | Int32 | Calendar


DateTime.Equals

Determines whether this instance and as a specified time are the same.

Overload List

Determines whether this DateTime represents the same time as a specified object.

[Visual Basic] Overloads Overrides Public Function Equals(Object) As Boolean
[C#] public override bool Equals(Object);
[C++] public: override bool Equals(Object*);
[JScript] public override function Equals(Object) : Boolean;

Determines whether two specified DateTime values are equal.

[Visual Basic] Overloads Public Shared Function Equals(DateTime, DateTime) As Boolean
[C#] public static bool Equals(DateTime, DateTime);
[C++] public: static bool Equals(DateTime, DateTime);
[JScript] public static function Equals(DateTime, DateTime) : Boolean;

See Also

DateTime Structure | DateTime Members | System Namespace


DateTime.Equals (Object)

Determines whether this DateTime represents the same time as a specified object.

[Visual Basic]
Overloads Overrides Public Function Equals( _
   ByVal value As Object _
) As Boolean
[C#]
public override bool Equals(
   object value
);
[C++]
public: override bool Equals(
   Object* value
);
[JScript]
public override function Equals(
   value : Object
) : Boolean;

Parameters

value
An object.

Return Value

true if this instance is a boxed DateTime and its value is equal to the value of this instance; otherwise, false.

Remarks

The Equals method compares a DateTime value with a specified object to determine whether they are same time, and returns a Boolean value indicating result.

See Also

DateTime Structure | DateTime Members | System Namespace | DateTime.Equals Overload List | Boolean


DateTime.Equals (DateTime, DateTime)

Determines whether two specified DateTime values are equal.

[Visual Basic]
Overloads Public Shared Function Equals( _
   ByVal t1 As DateTime, _
   ByVal t2 As DateTime _
) As Boolean
[C#]
public static bool Equals(
   DateTime t1,
   DateTime t2
);
[C++]
public: static bool Equals(
   DateTime t1,
   DateTime t2
);
[JScript]
public static function Equals(
   t1 : DateTime,
   t2 : DateTime
) : Boolean;

Parameters

t1
The first DateTime.
t2
The second DateTime.

Return Value

true if the two DateTime values are equal; otherwise, false.

Remarks

The Equals method compares two specified DateTime values to determine whether they are equal and returns a Boolean representation of their relationship.

See Also

DateTime Structure | DateTime Members | System Namespace | DateTime.Equals Overload List | Boolean


DateTime.Format

Converts this DateTime to a String with the specified format string and IServiceObjectProvider.

[Visual Basic]
Overridable Public Function Format( _
   ByVal format As String, _
   ByVal sp As IServiceObjectProvider _
) As String
[C#]
public virtual string Format(
   string format,
   IServiceObjectProvider sp
);
[C++]
public: virtual String* Format(
   String* format,
   IServiceObjectProvider* sp
);
[JScript]
public function Format(
   format : String,
   sp : IServiceObjectProvider
) : String;

Parameters

format
The format string.
sp
The IServiceObjectProvider instance used to format this DateTime value.

Return Value

A string representation of DateTime in the format specified by format.

Remarks

The format parmeter should consist of either:

  • A single format character, as listed in the table at the top of the DateTimeFormatInfo reference page, or
  • A custom format string.

If this argument is null or an empty string, the standard format ('g') character is used.

The sp parameter is typically an instance of DateTimeFormatInfo. If this value is null, the DateTimeFormatInfo object associated with the CultureInfo of the current thread is used.

Example

The following Managed C++ sample demonstrates how DateTime values are formatted with the invariant DateTimeFormatInfo object.

#import
<mscorlib.dll>

void
main ()
{
  DateTime dt = DateTime::Now;

  __managed String * [] format= {
   L"d",
   L"D",
   L"f",
   L"F",
   L"g",
   L"G",
   L"m",
   L"r",
   L"s",
   L"S",
   L"t",
   L"T",
   L"u",
   L"U",
   L"y",
   L"dddd, MMMM dd yyyy",
   L"ddd, MMM d \"'\"yy",
   L"dddd, MMMM dd",
   L"M/yy",
   L"dd-MM-yy",
  };
  String * date;
  for (int i = 0; i < format->Length;
i++)
  {
    date = dt.Format(format[i],
DateTimeFormatInfo::GetInvariantInfo());
    Console::WriteLine(format[i] + L" :
" + date);
  }

  /** OUTPUT
   *
   * d : 07/17/1999
   * D : Saturday, July 17, 1999
   * f : Saturday, July 17, 1999 23:17
   * F : Saturday, July 17, 1999 23:17:19
   * g : 07/17/1999 23:17
   * G : 07/17/1999 23:17:19
   * m : July 17
   * r : Sun, 18 Jul 1999 06:17:19 GMT
   * s : 1999-07-17 23:17:19
   * S : S
   * t : 23:17
   * T : 23:17:19
   * u : 1999-07-18 06:17:19
   * U : Sunday, July 18, 1999 06:17:19
   * y : July, 1999
   * dddd, MMMM dd yyyy : Thursday, July 22
1999
   * ddd, MMM d "'"yy : Thu, Jul 22
'99
   * dddd, MMMM dd : Thursday, July 22
   * M/yy : 7/99
   * dd-MM-yy : 22-07-99
   */
}

See Also

DateTime Structure | DateTime Members | System Namespace | DateTimeFormatInfo | CultureInfo | String


DateTime.FromFileTime

Creates a DateTime from an Operating System file time.

[Visual Basic]
Public Shared Function FromFileTime( _
   ByVal fileTime As Long _
) As DateTime
[C#]
public static DateTime FromFileTime(
   long fileTime
);
[C++]
public: static DateTime FromFileTime(
   __int64 fileTime
);
[JScript]
public static function FromFileTime(
   fileTime : long
) : DateTime;

Parameters

fileTime
A Windows file time.

Return Value

A DateTime value representing the same date and time as the specified Windows file time.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | If the fileTime is not valid.

Remarks

The FromFileTime method is a Windows file time that has a long value representing the date and time as the number of 100-nanosecond intervals that have elapsed since 1/1/1601 12:00 AM UTC.

Note Thet FromFileTime returns the local time.

See Also

DateTime Structure | DateTime Members | System Namespace | Int64 | ToUniversalTime | System.DirectoryServices.IADsPropertyValue.UTCTime


DateTime.FromOADate

Creates a DateTime from an OLE Automation Date.

[Visual Basic]
Public Shared Function FromOADate( _
   ByVal d As Double _
) As DateTime
[C#]
public static DateTime FromOADate(
   double d
);
[C++]
public: static DateTime FromOADate(
   double d
);
[JScript]
public static function FromOADate(
   d : double
) : DateTime;

Parameters

d
An OLE Automation Date value.

Return Value

The DateTime value that represents the same date and time as the specified OLE Date.

Exceptions

Exception Type | Condition
ArgumentException | If the date is not a valid OLE Automation Date value.

Remarks

The FromOADate value must be a value between negative 657435.0 through positive 2958466.0. It is stored as a double-precision floating point number.

See ToOADate and System.OAVariantLib class, or a MSDN Online Libary search at http://MSDN.com/library/default.asp for more information on OLE Automation.

See Also

DateTime Structure | DateTime Members | System Namespace | Double | System.OAVariantLib | ToOADate


DateTime.FromString

Creates a DateTime from a String.

[Visual Basic]
Public Shared Function FromString( _
   ByVal s As String _
) As DateTime
[C#]
public static DateTime FromString(
   string s
);
[C++]
public: static DateTime FromString(
   String* s
);
[JScript]
public static function FromString(
   s : String
) : DateTime;

Parameters

s
A string value containing the date and time in the current locale format.

Return Value

A new DateTime value.

Exceptions

Exception Type | Condition
ArgumentException | If s is a null reference (in Visual Basic Nothing).
FormatException | If s does not contain a valid string representation of a date and time.

Remarks

The DateTime string must specify a date and, optionally, a time in the format required by the current locale. Use either the universal FromString or locale-specific Parse.

The output of ToString must be consumable by FromString.

See Also

DateTime Structure | DateTime Members | System Namespace | String | CultureInfo


DateTime.GetAllDateTimes

OBSOLETE. Use GetDateTimeFormats instead.

Overload List

Returns a string array containing all of the known date and time options for the current culture.

[Visual Basic] Overloads Public Function GetAllDateTimes() As String ()
[C#] public string[] GetAllDateTimes();
[C++] public: String* GetAllDateTimes() [];
[JScript] public function GetAllDateTimes() : String[];

OBSOLETE. Use GetDateTimeFormats instead.

[Visual Basic] Overloads Public Function GetAllDateTimes(Char, IServiceObjectProvider) As String ()
[C#] public string[] GetAllDateTimes(char, IServiceObjectProvider);
[C++] public: String* GetAllDateTimes(__wchar_t, IServiceObjectProvider) [];
[JScript] public function GetAllDateTimes(Char, IServiceObjectProvider) : String[];

OBSOLETE. Use GetDateTimeFormats instead.

[Visual Basic] Overloads Public Function GetAllDateTimes(Char) As String ()
[C#] public string[] GetAllDateTimes(char);
[C++] public: String* GetAllDateTimes(__wchar_t) [];
[JScript] public function GetAllDateTimes(Char) : String[];

OBSOLETE. Use GetDateTimeFormats instead.

[Visual Basic] Overloads Public Function GetAllDateTimes(IServiceObjectProvider) As String ()
[C#] public string[] GetAllDateTimes(IServiceObjectProvider);
[C++] public: String* GetAllDateTimes(IServiceObjectProvider*) [];
[JScript] public function GetAllDateTimes(IServiceObjectProvider) : String[];

See Also

DateTime Structure | DateTime Members | System Namespace


DateTime.GetAllDateTimes ()

Returns a string array containing all of the known date and time options for the current culture.

[Visual Basic]
Overloads Public Function GetAllDateTimes() As String ()
[C#]
public string[] GetAllDateTimes();
[C++]
public: String* GetAllDateTimes() [];
[JScript]
public function GetAllDateTimes() : String[];

Return Value

A string array.

Remarks

The GetAllDateTimes method returns a string array containing the value of this instance. The strings are propertly formatted in date and time string for the current instance of the DateTimeFormatInfo object associated with the CultureInfo. (See CurrentCulture for addition information.)

Returns a string array containing all of the known date and time options.

See Also

DateTime Structure | DateTime Members | System Namespace | DateTime.GetAllDateTimes Overload List | String | CultureInfo | DateTimeFormat


DateTime.GetAllDateTimes (Char, IServiceObjectProvider)

OBSOLETE. Use GetDateTimeFormats instead.

[Visual Basic]
Overloads Public Function GetAllDateTimes( _
   ByVal format As Char, _
   ByVal isop As IServiceObjectProvider _
) As String ()
[C#]
public string[] GetAllDateTimes(
   char format,
   IServiceObjectProvider isop
);
[C++]
public: String* GetAllDateTimes(
   __wchar_t format,
   IServiceObjectProvider* isop
) [];
[JScript]
public function GetAllDateTimes(
   format : Char,
   isop : IServiceObjectProvider
) : String[];

Parameters

format
A default format.
isop
The IServiceObjectProvider interface.

Return Value

A string array containing this instance formatted as specified.

Exceptions

Exception Type | Condition
ArgumentException | If the format is not one of the valid character formats.

Remarks

The GetAllDateTimes method contains:

  • A string array of this instance formatted according to the specified format character and
  • The DateTimeFormatInfo object obtained from the specified IServiceObjectProvider.

The strings returned are properly formatted date and time strings for the current instance of DateTime. (See CurrentCulture for addition information on cultures.)

The format parameter calls the default characters ('F', 'G', 'D', etc.) at the top of the DateTimeFormatInfo.

The isop parameter provides the IServiceObjectProvider instance, which provides the DateTimeFormatInfo instance.

Returns a String array containing all of the known date and time options formatted for the specified format and culture.

See Also

DateTime Structure | DateTime Members | System Namespace | DateTime.GetAllDateTimes Overload List | Char | String


DateTime.GetAllDateTimes (Char)

OBSOLETE. Use GetDateTimeFormats instead.

[Visual Basic]
Overloads Public Function GetAllDateTimes( _
   ByVal format As Char _
) As String ()
[C#]
public string[] GetAllDateTimes(
   char format
);
[C++]
public: String* GetAllDateTimes(
   __wchar_t format
) [];
[JScript]
public function GetAllDateTimes(
   format : Char
) : String[];

Parameters

format
One of the default formats used by format.

Return Value

String array that contains all the date and time options for the specified format.

Exceptions

Exception Type | Condition
ArgumentException | If the format is not one of the valid format characters.

Remarks

The GetAllDateTimes method returns a string array containing all of the date and time options for the specified format and current CultureInfo. The strings are properly formatted date and time strings for the current instance of DateTime. (See CurrentCulture for addition information.)

The format parameter uses the default formats that can be used in DateTimeFormat, such as "F", "F", "D", etc.

Returns a string array containing all of the known date and time options for the specified Format and current culture.

See Also

DateTime Structure | DateTime Members | System Namespace | DateTime.GetAllDateTimes Overload List | String | Char


DateTime.GetAllDateTimes (IServiceObjectProvider)

OBSOLETE. Use GetDateTimeFormats instead.

[Visual Basic]
Overloads Public Function GetAllDateTimes( _
   ByVal isop As IServiceObjectProvider _
) As String ()
[C#]
public string[] GetAllDateTimes(
   IServiceObjectProvider isop
);
[C++]
public: String* GetAllDateTimes(
   IServiceObjectProvider* isop
) [];
[JScript]
public function GetAllDateTimes(
   isop : IServiceObjectProvider
) : String[];

Parameters

isop
The IServiceObjectProvider instance.

Return Value

A string array containing all the known date and time options.

Remarks

The GetAllDateTimes method returns a string array containing all the known date and time options, using the information provided by IServiceObjectProvider. The strings returned are proper time and culture strings for the current instance of DateTime.

The value of this instance is formatted in every way known by the object obtained from the specified IServiceObjectProvider instance, which can provide a DateTimeFormatInfo object ('F', 'G', 'D', etc.)

Returns a String array containing all of the known date and time options provided by IServiceObjectProvider.

(See CurrentCulture for addition culture specific information.)

See Also

DateTime Structure | DateTime Members | System Namespace | DateTime.GetAllDateTimes Overload List | IServiceObjectProvider | String


DateTime.GetDateTimeFormats

Returns the DateTime format string.

Overload List

Returns a String array containing all of the known date and time options formatted for the specified format and culture.

[Visual Basic] Overloads Public Function GetDateTimeFormats(Char, IServiceObjectProvider) As String ()
[C#] public string[] GetDateTimeFormats(char, IServiceObjectProvider);
[C++] public: String* GetDateTimeFormats(__wchar_t, IServiceObjectProvider) [];
[JScript] public function GetDateTimeFormats(Char, IServiceObjectProvider) : String[];

Returns a String array containing all of the known date and time options provided by IServiceObjectProvider.

[Visual Basic] Overloads Public Function GetDateTimeFormats(IServiceObjectProvider) As String ()
[C#] public string[] GetDateTimeFormats(IServiceObjectProvider);
[C++] public: String* GetDateTimeFormats(IServiceObjectProvider*) [];
[JScript] public function GetDateTimeFormats(IServiceObjectProvider) : String[];

Returns this instance of DateTime format with the current culture string.

[Visual Basic] Overloads Public Function GetDateTimeFormats() As String ()
[C#] public string[] GetDateTimeFormats();
[C++] public: String* GetDateTimeFormats() [];
[JScript] public function GetDateTimeFormats() : String[];

Returns a string array containing all of the known date and time options for the specified Format and current culture.

[Visual Basic] Overloads Public Function GetDateTimeFormats(Char) As String ()
[C#] public string[] GetDateTimeFormats(char);
[C++] public: String* GetDateTimeFormats(__wchar_t) [];
[JScript] public function GetDateTimeFormats(Char) : String[];

See Also

DateTime Structure | DateTime Members | System Namespace


DateTime.GetDateTimeFormats (Char, IServiceObjectProvider)

Returns a String array containing all of the known date and time options formatted for the specified format and culture.

[Visual Basic]
Overloads Public Function GetDateTimeFormats( _
   ByVal format As Char, _
   ByVal isop As IServiceObjectProvider _
) As String ()
[C#]
public string[] GetDateTimeFormats(
   char format,
   IServiceObjectProvider isop
);
[C++]
public: String* GetDateTimeFormats(
   __wchar_t format,
   IServiceObjectProvider* isop
) [];
[JScript]
public function GetDateTimeFormats(
   format : Char,
   isop : IServiceObjectProvider
) : String[];

Parameters

format
A default format.
isop
[To be supplied.]

Return Value

A string array containing this instance formatted as specified.

Remarks

The GetAllDateTimes method contains both:

  • A string array of this instance formatted according to the specified format character and
  • The DateTimeFormatInfo object obtained from the specified IServiceObjectProvider.

The strings returned are properly formatted date and time strings for the current instance of DateTime. (See CurrentCulture for addition information.)

The format parameter calls the default characters ('F', 'G', 'D', etc.) at the top of the DateTimeFormatInfo.

The isop parameter provides the IServiceObjectProvider instance, which provides the DateTimeFormatInfo instance.

See Also

DateTime Structure | DateTime Members | System Namespace | DateTime.GetDateTimeFormats Overload List | Char | String


DateTime.GetDateTimeFormats (IServiceObjectProvider)

Returns a String array containing all of the known date and time options provided by IServiceObjectProvider.

[Visual Basic]
Overloads Public Function GetDateTimeFormats( _
   ByVal isop As IServiceObjectProvider _
) As String ()
[C#]
public string[] GetDateTimeFormats(
   IServiceObjectProvider isop
);
[C++]
public: String* GetDateTimeFormats(
   IServiceObjectProvider* isop
) [];
[JScript]
public function GetDateTimeFormats(
   isop : IServiceObjectProvider
) : String[];

Parameters

isop
The IServiceObjectProvider instance.

Return Value

A string array containing all the known date and time options.

Remarks

The GetDateTimeFormats method returns a string array containing all the known date and time options, using the information provided by IServiceObjectProvider. The strings returned are proper time and culture strings for the current instance of DateTime.

The value of this instance is formatted in every way known by the object obtained from the specified IServiceObjectProvider instance, which can provide a DateTimeFormatInfo object ('F', 'G', 'D', etc.)

(See CurrentCulture for addition culture specific information.)

See Also

DateTime Structure | DateTime Members | System Namespace | DateTime.GetDateTimeFormats Overload List | String | DateTimeFormat | CultureInfo


DateTime.GetDateTimeFormats ()

Returns this instance of DateTime format with the current culture string.

[Visual Basic]
Overloads Public Function GetDateTimeFormats() As String ()
[C#]
public string[] GetDateTimeFormats();
[C++]
public: String* GetDateTimeFormats() [];
[JScript]
public function GetDateTimeFormats() : String[];

Return Value

A string array containing all the known date and time options.

Remarks

The GetDateTimeFormats method returns a string array containing the value of this instance. The strings are propertly formatted in date and time string for the current instance of the DateTimeFormatInfo object associated with the CultureInfo. (See CurrentCulture for addition information.)

See Also

DateTime Structure | DateTime Members | System Namespace | DateTime.GetDateTimeFormats Overload List


DateTime.GetDateTimeFormats (Char)

Returns a string array containing all of the known date and time options for the specified Format and current culture.

[Visual Basic]
Overloads Public Function GetDateTimeFormats( _
   ByVal format As Char _
) As String ()
[C#]
public string[] GetDateTimeFormats(
   char format
);
[C++]
public: String* GetDateTimeFormats(
   __wchar_t format
) [];
[JScript]
public function GetDateTimeFormats(
   format : Char
) : String[];

Parameters

format
One of the default formats used by format.

Return Value

A string array that contains all the date and time options for the specified format.

Remarks

The GetDateTimeFormats method returns a string array containing all of the date and time options for the specified format and current CultureInfo. The strings are properly formatted date and time strings for the current instance of DateTime. (See CurrentCulture for addition information.)

The format parameter uses the default formats that can be used in DateTimeFormat, such as "F", "F", "D", etc.

See Also

DateTime Structure | DateTime Members | System Namespace | DateTime.GetDateTimeFormats Overload List | Char | String


DateTime.GetHashCode

Returns the hash code for this instance.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

The hash code for this instance.

Remarks

The GetHashCode method gets the hash code for this instance of DateTime and returns it. This overrides GetHashCode.

See Also

DateTime Structure | DateTime Members | System Namespace | Int32 | Object


DateTime.GetTypeCode

Returns the type code for this instance.

[Visual Basic]
Overridable Public Function GetTypeCode() As TypeCode
[C#]
public virtual TypeCode GetTypeCode();
[C++]
public: virtual TypeCode GetTypeCode();
[JScript]
public function GetTypeCode() : TypeCode;

Return Value

The type code.

Remarks

The GetTypeCode method gets the type code for this instance of DateTime and returns it.

See Also

DateTime Structure | DateTime Members | System Namespace | Type | TypeCode


DateTime.IsLeapYear

Determines whether a specified year is a leap year.

[Visual Basic]
Public Shared Function IsLeapYear( _
   ByVal year As Integer _
) As Boolean
[C#]
public static bool IsLeapYear(
   int year
);
[C++]
public: static bool IsLeapYear(
   int year
);
[JScript]
public static function IsLeapYear(
   year : int
) : Boolean;

Parameters

year
The year to check.

Return Value

true if the year is a leap year; otherwise, false.

Remarks

The IsLeapYear method is used to determine whether a specified year is a leap year and returns a Boolean determination for the result.

See Also

DateTime Structure | DateTime Members | System Namespace | Boolean | Calendar


DateTime.Parse

Creates a DateTime from a String.

Overload List

Creates a DateTime from a string.

[Visual Basic] Overloads Public Shared Function Parse(String) As DateTime
[C#] public static DateTime Parse(String);
[C++] public: static DateTime Parse(String*);
[JScript] public static function Parse(String) : DateTime;

Creates a DateTime from a String using specified formatting information.

[Visual Basic] Overloads Public Shared Function Parse(String, DateTimeFormatInfo) As DateTime
[C#] public static DateTime Parse(String, DateTimeFormatInfo);
[C++] public: static DateTime Parse(String*, DateTimeFormatInfo);
[JScript] public static function Parse(String, DateTimeFormatInfo) : DateTime;

See Also

DateTime Structure | DateTime Members | System Namespace


DateTime.Parse (String)

Creates a DateTime from a string.

[Visual Basic]
Overloads Public Shared Function Parse( _
   ByVal s As String _
) As DateTime
[C#]
public static DateTime Parse(
   string s
);
[C++]
public: static DateTime Parse(
   String* s
);
[JScript]
public static function Parse(
   s : String
) : DateTime;

Parameters

s
A string containing a date and a time.

Return Value

A new DateTime.

Exceptions

Exception Type | Condition
ArgumentNullException | If s is a null reference (in Visual Basic Nothing).
FormatException | If s does not contain a valid string representation and therefore cannot be parsed according to the DateTimeFormatInfo object used.

Remarks

The Parse and ParseExact methods each break the input into smaller chunks, but the ParseExact also looks for a specific (exact) string.

In order for the string to be successfully parsed, it must represent a date and time value in either of:

  • The culture-specific format determined by the DateTimeFormatInfo object for the current thread, or
  • The invariant (universal) format determined by the invariant DateTimeFormatInfo object.

Leading and trailing white space characters are allowed.

See Also

DateTime Structure | DateTime Members | System Namespace | DateTime.Parse Overload List | String | DateTimeFormatInfo | DateTimeFormat | CultureInfo


DateTime.Parse (String, DateTimeFormatInfo)

Creates a DateTime from a String using specified formatting information.

[Visual Basic]
Overloads Public Shared Function Parse( _
   ByVal s As String, _
   ByVal dtfi As DateTimeFormatInfo _
) As DateTime
[C#]
public static DateTime Parse(
   string s,
   DateTimeFormatInfo dtfi
);
[C++]
public: static DateTime Parse(
   String* s,
   DateTimeFormatInfo* dtfi
);
[JScript]
public static function Parse(
   s : String,
   dtfi : DateTimeFormatInfo
) : DateTime;

Parameters

s
A string containing a date and time.
dtfi
The DateTimeFormatInfo instance used to parse the string.

Return Value

The new DateTime.

Exceptions

Exception Type | Condition
ArgumentException | If the string is a null reference (in Visual Basic Nothing).
FormatException | If the string does not contain a valid string representation of a date and time.

Remarks

The Parse and ParseExact methods each break the input into smaller chunks, but the ParseExact also looks for a specific (exact) string.

In order for the string to be successfully parsed, it must represent a date and/or time value in the universal format determined by the specified DateTimeFormatInfo object.

The dtfi object provides culture-specific date and time formatting information, such as the days of the week: "Sabado", "Domingo", "Lunes", etc.

Leading and trailing white space characters are allowed.

See Also

DateTime Structure | DateTime Members | System Namespace | DateTime.Parse Overload List | DateTimeFormatInfo | String | CultureInfo | DateTimeFormatInfo


DateTime.ParseExact

Creates a DateTime from a string.

Overload List

Creates a DateTime from a string and uses DateTimeFormatInfo to format it with DateTimeStyles enumeration.

[Visual Basic] Overloads Public Shared Function ParseExact(String, String, DateTimeFormatInfo, DateTimeStyles) As DateTime
[C#] public static DateTime ParseExact(String, String, DateTimeFormatInfo, DateTimeStyles);
[C++] public: static DateTime ParseExact(String*, String*, DateTimeFormatInfo, DateTimeStyles);
[JScript] public static function ParseExact(String, String, DateTimeFormatInfo, DateTimeStyles) : DateTime;

Creates a DateTime from a string and uses DateTimeFormatInfo to format it.

[Visual Basic] Overloads Public Shared Function ParseExact(String, String, DateTimeFormatInfo) As DateTime
[C#] public static DateTime ParseExact(String, String, DateTimeFormatInfo);
[C++] public: static DateTime ParseExact(String*, String*, DateTimeFormatInfo);
[JScript] public static function ParseExact(String, String, DateTimeFormatInfo) : DateTime;

See Also

DateTime Structure | DateTime Members | System Namespace


DateTime.ParseExact (String, String, DateTimeFormatInfo, DateTimeStyles)

Creates a DateTime from a string and uses DateTimeFormatInfo to format it with DateTimeStyles enumeration.

[Visual Basic]
Overloads Public Shared Function ParseExact( _
   ByVal s As String, _
   ByVal format As String, _
   ByVal dtfi As DateTimeFormatInfo, _
   ByVal style As DateTimeStyles _
) As DateTime
[C#]
public static DateTime ParseExact(
   string s,
   string format,
   DateTimeFormatInfo dtfi,
   DateTimeStyles style
);
[C++]
public: static DateTime ParseExact(
   String* s,
   String* format,
   DateTimeFormatInfo* dtfi,
   DateTimeStyles style
);
[JScript]
public static function ParseExact(
   s : String,
   format : String,
   dtfi : DateTimeFormatInfo,
   style : DateTimeStyles
) : DateTime;

Parameters

s
A string that contain the date and time.
format
The format needed for parsing.
dtfi
The DateTimeFormatInfo instance that provides the information to be parsed.
style
The particular parsing flags' applied by DateTimeStyles.

Return Value

A DateTime formatted in the valid string representation and style.

Exceptions

Exception Type | Condition
ArgumentNullException | If the string is a null reference (in Visual Basic Nothing).
FormatException | If the string does not contain a valid string representation of a date and time.
FormatException | If the format uses the general format ("G") string.

Remarks

The Parse and ParseExact methods each break the input into smaller chunks, but the ParseExact also looks for a specific (exact) string.

ParseExact constructs a DateTime from a string. The string must specify a date and, optionally, a time in a culture-specific or universal format. See CultureInfo and DateTimeFormatInfo for a list of the format characters.

DateTimeStyles provides the particular parsing flags that are used.

Leading and trailing white space characters are allowed.

An unexpected FormatException occurs while using the ToString general format ("G") string when the general format DateTime string representation is not parsed correctly.

See Also

DateTime Structure | DateTime Members | System Namespace | DateTime.ParseExact Overload List | String | DateTimeFormatInfo | DateTimeFormat


DateTime.ParseExact (String, String, DateTimeFormatInfo)

Creates a DateTime from a string and uses DateTimeFormatInfo to format it.

[Visual Basic]
Overloads Public Shared Function ParseExact( _
   ByVal s As String, _
   ByVal format As String, _
   ByVal dtfi As DateTimeFormatInfo _
) As DateTime
[C#]
public static DateTime ParseExact(
   string s,
   string format,
   DateTimeFormatInfo dtfi
);
[C++]
public: static DateTime ParseExact(
   String* s,
   String* format,
   DateTimeFormatInfo* dtfi
);
[JScript]
public static function ParseExact(
   s : String,
   format : String,
   dtfi : DateTimeFormatInfo
) : DateTime;

Parameters

s
A string containing the date and time.
format
The format needed for parsing.
dtfi
The DateTimeFormatInfo instance providing the information to be parsed.

Return Value

A DateTime formatted in the valid string representation.

Exceptions

Exception Type | Condition
ArgumentNullException | If the string is a null reference (in Visual Basic Nothing).
FormatException | If the string does not contain a valid string representation of a date and time.
FormatException | If the format uses the general format ("G") string.

Remarks

The Parse and ParseExact methods each break the input into smaller chunks, but the ParseExact also looks for a specific (exact) string.

ParseExact constructs a DateTime from a string. The string must specify a date and, optionally, a time in a culture-specific or universal format. See DateTimeFormat for a list of the format characters.

Leading and trailing white space characters are allowed.

An unexpected FormatException occurs while using the ToString general format ("G") string when the general format DateTime string representation is not parsed correctly.

See Also

DateTime Structure | DateTime Members | System Namespace | DateTime.ParseExact Overload List | String | DateTimeFormatInfo | Format | CultureInfo


DateTime.Subtract

Subtracts a number from this DateTime.

Overload List

Subtracts a DateTime value from the value of this DateTime and produces a time interval.

[Visual Basic] Overloads Public Function Subtract(DateTime) As TimeSpan
[C#] public TimeSpan Subtract(DateTime);
[C++] public: TimeSpan Subtract(DateTime);
[JScript] public function Subtract(DateTime) : TimeSpan;

Subtracts a TimeSpan value from the value of this DateTime.

[Visual Basic] Overloads Public Function Subtract(TimeSpan) As DateTime
[C#] public DateTime Subtract(TimeSpan);
[C++] public: DateTime Subtract(TimeSpan);
[JScript] public function Subtract(TimeSpan) : DateTime;

See Also

DateTime Structure | DateTime Members | System Namespace


DateTime.Subtract (DateTime)

Subtracts a DateTime value from the value of this DateTime and produces a time interval.

[Visual Basic]
Overloads Public Function Subtract( _
   ByVal value As DateTime _
) As TimeSpan
[C#]
public TimeSpan Subtract(
   DateTime value
);
[C++]
public: TimeSpan Subtract(
   DateTime value
);
[JScript]
public function Subtract(
   value : DateTime
) : TimeSpan;

Parameters

value
The DateTime to subtract from this instance.

Return Value

A DateTime value with a Ticks value equal that is difference of the ticks value for this instance.

Remarks

The Subtract(DateTime) method subtracts a DateTime value from this instance of DateTime value by using a ticks value and presents the difference as a time interval as a TimeSpan (value: this- value).

See Also

DateTime Structure | DateTime Members | System Namespace | DateTime.Subtract Overload List | TimeSpan


DateTime.Subtract (TimeSpan)

Subtracts a TimeSpan value from the value of this DateTime.

[Visual Basic]
Overloads Public Function Subtract( _
   ByVal value As TimeSpan _
) As DateTime
[C#]
public DateTime Subtract(
   TimeSpan value
);
[C++]
public: DateTime Subtract(
   TimeSpan value
);
[JScript]
public function Subtract(
   value : TimeSpan
) : DateTime;

Parameters

value
The TimeSpan to subtract from this instance.

Return Value

A DateTime value with a Ticks value equal to the difference of the ticks value of this instance.

Remarks

The Subtract(TimeSpan) method subtracts a TimeSpan from this instance of DateTime and produces a new DateTime.

This method subtracts the values of a TimeSpan value from a DateTime value by using a ticks value and presents the difference as a DateTime value (value: this- value).

See Also

DateTime Structure | DateTime Members | System Namespace | DateTime.Subtract Overload List | TimeSpan


DateTime.ToBoolean

Converts this instance to a Boolean value

[Visual Basic]
Overridable Public Function ToBoolean() As Boolean
[C#]
public virtual bool ToBoolean();
[C++]
public: virtual bool ToBoolean();
[JScript]
public function ToBoolean() : Boolean;

Return Value

The Boolean value for this instance.

Exceptions

Exception Type | Condition
InvalidCastException | If this DateTime is not a Boolean.

Remarks

The ToBoolean method casts this DateTime instance into a Boolean value. An exception is thrown if this instance cannot be coerced into a Boolean (bool).

See Also

DateTime Structure | DateTime Members | System Namespace | Boolean


DateTime.ToByte

Converts this instance to a Byte value

[Visual Basic]
Overridable Public Function ToByte() As Byte
[C#]
public virtual byte ToByte();
[C++]
public: virtual unsigned char ToByte();
[JScript]
public function ToByte() : Byte;

Return Value

The Byte value for this instance.

Exceptions

Exception Type | Condition
InvalidCastException | If this DateTime cannot be a Byte.

Remarks

The ToByte method casts this DateTime instance into an Byte value. An exception is thrown if this instance cannot be coerced into an 8-bit unsigned integer (byte).

See Also

DateTime Structure | DateTime Members | System Namespace | Byte | SByte


DateTime.ToChar

Converts this instance to a Char value

[Visual Basic]
Overridable Public Function ToChar() As Char
[C#]
public virtual char ToChar();
[C++]
public: virtual __wchar_t ToChar();
[JScript]
public function ToChar() : Char;

Return Value

The Char value for this instance.

Exceptions

Exception Type | Condition
InvalidCastException | If this DateTime is not a character.

Remarks

The ToChar method casts this DateTime instance into a Char value. An exception is thrown if this instance cannot be coerced into a Unicode character (char).

See Also

DateTime Structure | DateTime Members | System Namespace | Char | UnicodeEncoding


DateTime.ToDateTime

Converts this instance to a DateTime value

[Visual Basic]
Overridable Public Function ToDateTime() As DateTime
[C#]
public virtual DateTime ToDateTime();
[C++]
public: virtual DateTime ToDateTime();
[JScript]
public function ToDateTime() : DateTime;

Return Value

The DateTime value for this instance.

Exceptions

Exception Type | Condition
InvalidCastException | If this DateTime is not a DateTime.

Remarks

The ToDateTime method casts this DateTime instance into another DateTime value. An exception is thrown if the current instance of DateTime cannot be coerced into a DateTime.

See Also

DateTime Structure | DateTime Members | System Namespace


DateTime.ToDecimal

Converts this instance to a Decimal value

[Visual Basic]
Overridable Public Function ToDecimal() As Decimal
[C#]
public virtual Decimal ToDecimal();
[C++]
public: virtual Decimal ToDecimal();
[JScript]
public function ToDecimal() : Decimal;

Return Value

The Decimal value for this instance.

Exceptions

Exception Type | Condition
InvalidCastException | If this DateTime is not a decimal value.

Remarks

The ToDecimal method casts this DateTime instance into a decimal value. An exception is thrown if this instance cannot be coerced into the decimal.

See Also

DateTime Structure | DateTime Members | System Namespace | Decimal


DateTime.ToDouble

Converts this instance to a Double value

[Visual Basic]
Overridable Public Function ToDouble() As Double
[C#]
public virtual double ToDouble();
[C++]
public: virtual double ToDouble();
[JScript]
public function ToDouble() : double;

Return Value

The Double value for this instance.

Exceptions

Exception Type | Condition
InvalidCastException | If this DateTime is not a Double value.

Remarks

The ToDouble method casts this DateTime instance into a double-precision floating point number (double) value. An exception is thrown if this instance cannot be coerced into the double.

See Also

DateTime Structure | DateTime Members | System Namespace | Double


DateTime.ToFileTime

Converts the value of this DateTime to the format of the local system file time.

[Visual Basic]
Public Function ToFileTime() As Long
[C#]
public long ToFileTime();
[C++]
public: __int64 ToFileTime();
[JScript]
public function ToFileTime() : long;

Return Value

Returns the value of this DateTime in the format of the local system file time.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | If this DateTime contains a value that cannot be converted to a system file time.

Remarks

A system file time is an unsigned 8-byte value representing the date and time as the number of 100-nanosecond intervals that have elapsed since 1/1/1601 12:00 AM.

Dates that are earlier than 01/01/1601 12:00:00 AM UTC cannot be converted to a local system file time value, and an exception will be thrown.

See Also

DateTime Structure | DateTime Members | System Namespace | Int64 | ToUniversalTime | System.DirectoryServices.IADsPropertyValue.UTCTime


DateTime.ToInt16

Converts this instance into an Int16.

[Visual Basic]
Overridable Public Function ToInt16() As Short
[C#]
public virtual short ToInt16();
[C++]
public: virtual short ToInt16();
[JScript]
public function ToInt16() : Int16;

Return Value

The Int16 value for this instance.

Exceptions

Exception Type | Condition
InvalidCastException | If this DateTime is not an Int16 value.

Remarks

The ToInt16 method casts this DateTime instance into an Int16 value. An exception is thrown if this instance cannot be coerced into a 16-bit signed integer (short).

See Also

DateTime Structure | DateTime Members | System Namespace | Int16 | UInt16


DateTime.ToInt32

Converts this instance into an Int32.

[Visual Basic]
Overridable Public Function ToInt32() As Integer
[C#]
public virtual int ToInt32();
[C++]
public: virtual int ToInt32();
[JScript]
public function ToInt32() : int;

Return Value

The Int32 value for this instance.

Exceptions

Exception Type | Condition
InvalidCastException | If this DateTime is not an Int32 value.

Remarks

The ToInt32 method casts this DateTime instance into an Int32 value. An exception is thrown if this instance cannot be coerced into an 32-bit signed integer (int).

See Also

DateTime Structure | DateTime Members | System Namespace | Int32 | UInt32


DateTime.ToInt64

Converts this instance into an Int64.

[Visual Basic]
Overridable Public Function ToInt64() As Long
[C#]
public virtual long ToInt64();
[C++]
public: virtual __int64 ToInt64();
[JScript]
public function ToInt64() : long;

Return Value

The Int64 value for this instance.

Exceptions

Exception Type | Condition
InvalidCastException | If this DateTime is not an Int64 value.

Remarks

The ToInt64 method casts this DateTime instance into an Int64 value. An exception is thrown if this instance cannot be coerced into a 64-bit signed integer (long).

See Also

DateTime Structure | DateTime Members | System Namespace | Int64 | UInt64


DateTime.ToLocalTime

Converts UTC to local time.

[Visual Basic]
Public Function ToLocalTime() As DateTime
[C#]
public DateTime ToLocalTime();
[C++]
public: DateTime ToLocalTime();
[JScript]
public function ToLocalTime() : DateTime;

Return Value

A new DateTime obtained by calculating the difference between UTC and local time and adding the result to or subtracting it from the current DateTime.

Remarks

ToLocalTime calculates the difference between the local time and UTC and adds the result to or subtracts it from the current DateTime.

The ToLocalTime method creates a DateTime that is the user's local time zone by using the coordinated universal time (UTC) offset (see GetUTCOffset).

Note The local time is the UTC plus the offset.

See Also

DateTime Structure | DateTime Members | System Namespace | TimeZone | System.DirectoryServices.IADsPropertyValue.UTCTime


DateTime.ToLongDateString

Converts the date value of this instance to a String.

[Visual Basic]
Public Function ToLongDateString() As String
[C#]
public string ToLongDateString();
[C++]
public: String* ToLongDateString();
[JScript]
public function ToLongDateString() : String;

Return Value

A string value containing the date that this instance represents.

Remarks

The ToLongDateString method converts the date value to a string value, then the format of the return value is determined by the InvariantCulture. The format is "day, month dd, yyyy", where:

  • day is the day of the week (either Monday, Tuesday, and so forth).
  • m onth is the month (January, February, and so forth).
  • dd is numberic day of the month (01, 02, and so forth).
  • yyyy is the year (0001, 0002, and so forth).

To Format a DateTime using the CurrentCulture, use Format

See Also

DateTime Structure | DateTime Members | System Namespace | String | CultureInfo | Calendar | DateTimeFormat | DateTimeFormatInfo


DateTime.ToLongTimeString

Converts the time value of this instance to a String.

[Visual Basic]
Public Function ToLongTimeString() As String
[C#]
public string ToLongTimeString();
[C++]
public: String* ToLongTimeString();
[JScript]
public function ToLongTimeString() : String;

Return Value

A string value containing the time value represented by this instance.

Remarks

The ToLongTimeString method converts the time value to a string value, then the format of the return value is determined by the InvariantCulture For example, the English (United States) format is "hh:mm:ss PP", where:

  • hh indicates hours, 0 through 12 only.
  • mm indicates minutes, 0 through 59.
  • ss indicate seconds, 0 through 59.
  • PP is either AM or PM.

To Format a DateTime using the CurrentCulture, use Format

See Also

DateTime Structure | DateTime Members | System Namespace | String | CultureInfo | DateTimeFormat | Calendar | DateTimeFormatInfo


DateTime.ToOADate

Converts the DateTime instance into an OLE Automation compatible date.

[Visual Basic]
Public Function ToOADate() As Double
[C#]
public double ToOADate();
[C++]
public: double ToOADate();
[JScript]
public function ToOADate() : double;

Return Value

A Double value that represents the OLE Automation compatible date.

Exceptions

Exception Type | Condition
OverflowException | If the value of this instance cannot be represented as an OLE Automation Date.

Remarks

In order for an un-initialized DateTime (one with a ticks value of 0) to be equivalent to an un-initialized OLE Automation Date (one with a double value of 0.0), a DateTime with a tick value of 0 is converted to 0.0, the OLE Automation Date value of midnight, 30 December 1899.

Only DateTime objects with a tick value that is greater than or equal to positive or negative 31241376000000000 can be represented as an OLE Automation Date. There is an exception.

Note The Ticks value of a DateTime is between MinValue and MaxValue.
Note The maximum value of a DateTime is equal to the maximum value of an OLE Automation Date.

See FromOADate and System.OAVariantLib class, or a MSDN Online Libary search at http://MSDN.com/library/default.asp for more information on OLE Automation.

See Also

DateTime Structure | DateTime Members | System Namespace | Double | System.OAVaiantLib | FromOADate


DateTime.ToSByte

Converts this instance to an SByte.

[Visual Basic]
Overridable Public Function ToSByte() As SByte
[C#]
public virtual sbyte ToSByte();
[C++]
public: virtual char ToSByte();
[JScript]
public function ToSByte() : SByte;

Return Value

The SByte value for this instance.

Exceptions

Exception Type | Condition
InvalidCastException | If this DateTime is not an SByte value.

Remarks

The ToSByte method casts this DateTime instance into an SByte value. An exception is thrown if this instance cannot be coerced into an unsigned byte (sbyte).

See Also

DateTime Structure | DateTime Members | System Namespace | SByte | Byte


DateTime.ToShortDateString

Converts the date value of this instance to a String.

[Visual Basic]
Public Function ToShortDateString() As String
[C#]
public string ToShortDateString();
[C++]
public: String* ToShortDateString();
[JScript]
public function ToShortDateString() : String;

Return Value

A string value that contains the date represented by this instance.

Remarks

The ToShortDateString method converts the date value to a string value and formats the return value determined by the InvariantCulture The format is "mm/dd/yy", where:

  • mm indicates the month (1 through 12).
  • dd indicates the day (1 through 31).
  • yy indicates the last two digits of the year (00 through 99).

To Format a DateTime using the CurrentCulture, use Format

See Also

DateTime Structure | DateTime Members | System Namespace | String | DateTimeFormat | CultureInfo | Calendar | DateTimeFormatInfo


DateTime.ToShortTimeString

Converts the time value of the instance to a String.

[Visual Basic]
Public Function ToShortTimeString() As String
[C#]
public string ToShortTimeString();
[C++]
public: String* ToShortTimeString();
[JScript]
public function ToShortTimeString() : String;

Return Value

Returns a string value containing the time that this instance represents.

Remarks

The ToShortTimeString method converts the time value to a string value and formats the return value determined by the InvariantCulture. The format is "hh:mm", where:

  • hh indicates hours, 0 through 23.
  • mm indicates minutes, 0 through 59.

To Format a DateTime using the CurrentCulture, use Format

See Also

DateTime Structure | DateTime Members | System Namespace | String | DateTimeFormat | Calendar | CultureInfo | DateTimeFormatInfo


DateTime.ToSingle

Converts this instance into a Single.

[Visual Basic]
Overridable Public Function ToSingle() As Single
[C#]
public virtual float ToSingle();
[C++]
public: virtual float ToSingle();
[JScript]
public function ToSingle() : float;

Return Value

The Single value for this instance.

Exceptions

Exception Type | Condition
InvalidCastException | If this DateTime is not a Single value.

Remarks

The ToSingle method casts this DateTime instance into a single-precision floating point number (Single) value. An exception is thrown if this instance cannot be coerced into a float.

See Also

DateTime Structure | DateTime Members | System Namespace | Single


DateTime.ToString

Converts the date and time value of this instance to a String.

Overload List

Converts the date and time value of this instance to a string.

[Visual Basic] Overloads Overrides Public Function ToString() As String
[C#] public override string ToString();
[C++] public: override String* ToString();
[JScript] public override function ToString() : String;

Converts the date and time value of a specified DateTime to a String.

[Visual Basic] Overloads Public Shared Function ToString(DateTime) As String
[C#] public static string ToString(DateTime);
[C++] public: static String* ToString(DateTime);
[JScript] public static function ToString(DateTime) : String;

See Also

DateTime Structure | DateTime Members | System Namespace


DateTime.ToString ()

Converts the date and time value of this instance to a string.

[Visual Basic]
Overloads Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

A string value containing the date and time represented by this instance.

Exceptions

Exception Type | Condition
FormatException | If the general format ("G") string is used.

Remarks

The ToString method uses InvariantCulture as the default. The output of ToString must be consumable by FromString.

An unexpected FormatException occurs while using the ToSring general format ("G") string when the general format DateTime string representation is not parsed correctly.

Note ToString is formatted using the invariant culture (see InvariantCulture).

ToString converts the date and time value of this instance to a string value, then formats the return value determined by the InvariantCulture The format is " mm/dd/yy hh:mm:ss PP ", where:

  • mm indicates the month, 1 through 12.
  • dd indicates the day, 1 through 31.
  • yy indicates the last two digits of the year, 00 through 99.
  • hh indicates hours, 0 through 12 only.
  • mm indicates minutes, 0 through 59.
  • ss indicates seconds, 0 through 59.
  • PP is either AM or PM.

See Also

DateTime Structure | DateTime Members | System Namespace | DateTime.ToString Overload List | String | CultureInfo | Calendar | DateTimeFormat | DateTimeFormatInfo


DateTime.ToString (DateTime)

Converts the date and time value of a specified DateTime to a String.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal dt As DateTime _
) As String
[C#]
public static string ToString(
   DateTime dt
);
[C++]
public: static String* ToString(
   DateTime dt
);
[JScript]
public static function ToString(
   dt : DateTime
) : String;

Parameters

dt
The DateTime value to be converted.

Return Value

A string value containing the date and time that the specified DateTime instance represents.

Exceptions

Exception Type | Condition
FormatException | If the general format ("G") string is used.

Remarks

The ToString method uses InvariantCulture as default. The output of ToString must be consumable by FromString.

An unexpected FormatException occurs while using the ToSring general format ("G) string when the general format DateTime string representation is not parsed correctly.

Note ToString is formatted using the invariant culture (see InvariantCulture).
Note ToString converts the date and time value of a specified DateTime to a string value, then formats the return value determined by the InvariantCulture For example, the English (United States) format is " mm/dd/yy hh:mm:ss
PP ", where:
  • mm indicates the month, 1 through 12.
  • dd indicates the day, 1 through 31.
  • yy indicates the last two digits of the year, 00 through 99.
  • hh indicates hours, 0 through 12 only.
  • mm indicates minutes, 0 through 59.
  • ss indicates seconds, 0 through 59.
  • PP is either AM or PM.

See Also

DateTime Structure | DateTime Members | System Namespace | DateTime.ToString Overload List | String | DateTimeFormat | CultureInfo | Calendar | DateTimeFormatInfo


DateTime.ToType

Converts this instance to a Type.

[Visual Basic]
Overridable Public Function ToType( _
   ByVal type As Type _
) As Object
[C#]
public virtual object ToType(
   Type type
);
[C++]
public: virtual Object* ToType(
   Type* type
);
[JScript]
public function ToType(
   type : Type
) : Object;

Parameters

type
[To be supplied.]

Return Value

The Type object for this instance.

Exceptions

Exception Type | Condition
InvalidCastException | If this DateTime is not a Type object.

Remarks

The ToType method casts this DateTime instance into a Type object. An exception is thrown if the type cannot be coerced into a single-precision floating point number (see Single).

See Also

DateTime Structure | DateTime Members | System Namespace | Object | Type | Single


DateTime.ToUInt16

Converts this instance to a UInt16.

[Visual Basic]
Overridable Public Function ToUInt16() As UInt16
[C#]
public virtual ushort ToUInt16();
[C++]
public: virtual unsigned short ToUInt16();
[JScript]
public function ToUInt16() : UInt16;

Return Value

The UInt16value for this instance.

Exceptions

Exception Type | Condition
InvalidCastException | If this DateTime is not a UInt16 value.

Remarks

The ToUInt16 method casts this DateTime instance into a UInt16 value. An exception is thrown if this instance cannot be coerced into an 16-bit unsigned integer (ushort).

See Also

DateTime Structure | DateTime Members | System Namespace | UInt16 | Int16


DateTime.ToUInt32

Converts this instance to a UInt32.

[Visual Basic]
Overridable Public Function ToUInt32() As UInt32
[C#]
public virtual uint ToUInt32();
[C++]
public: virtual unsigned int ToUInt32();
[JScript]
public function ToUInt32() : UInt32;

Return Value

The UInt32value for this instance.

Exceptions

Exception Type | Condition
InvalidCastException | If this DateTime is not a UInt32 value.

Remarks

The ToUInt32 method casts this DateTime instance into a UInt32 value. An exception is thrown if this instance cannot be coerced into a 32-bit unsigned integer (uint).

See Also

DateTime Structure | DateTime Members | System Namespace | Int32 | UInt32


DateTime.ToUInt64

Converts this instance to a UInt64.

[Visual Basic]
Overridable Public Function ToUInt64() As UInt64
[C#]
public virtual ulong ToUInt64();
[C++]
public: virtual unsigned __int64 ToUInt64();
[JScript]
public function ToUInt64() : UInt64;

Return Value

The UInt64value for this instance.

Exceptions

Exception Type | Condition
InvalidCastException | If this DateTime is not a UInt64value.

Remarks

The ToUInt64 method casts this DateTime instance into a UInt64 value. An exception is thrown if this instance cannot be coerced into an 64-bit unsigned integer (ulong).

See Also

DateTime Structure | DateTime Members | System Namespace | UInt64 | Int64


DateTime.ToUniversalTime

Converts local time to UTC.

[Visual Basic]
Public Function ToUniversalTime() As DateTime
[C#]
public DateTime ToUniversalTime();
[C++]
public: DateTime ToUniversalTime();
[JScript]
public function ToUniversalTime() : DateTime;

Return Value

A new DateTime obtained by calculating the difference between UTC and local time and adding the result to or subtracting it from the current DateTime.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | If the universal time is less than zero.

Remarks

The ToUniversalTime method creates a new DateTime object by converting this DateTime object to the coordinated universal time (UTC) time zone (see GetUTCOffset).

Note The local time is equal to UTC plus the offset.

ToUniversalTime calculates the difference between the local time (the time zone of the current thread) and UTC and adds the result to or subtracts it from the current DateTime. For example, if UTC is five hours ahead of the local time, then the return value will be five hours ahead of the value of the current DateTime object.

See Also

DateTime Structure | DateTime Members | System Namespace | TimeZone | DateTimeFormatInfo | UTF7Encoding | UTF8Encoding | System.DirectoryServices.IADsPropertyValue.UTCTime


Operators

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DateTime Operators

The operators of the DateTime structure are listed below. For a complete list of DateTime structure members, see the DateTime Members topic.

Public:

Addition Operator | Adds a TimeSpan value to a DateTime value.
Equality Operator | Determines whether two DateTime values are equal.
Greater Than Operator | Determines whether one DateTime value is greater than a specified DateTime.
Greater Than Or Equal Operator | Determines whether one DateTime value is greater than or equal to a specified DateTime.
Inequality Operator | Determines whether two DateTime values are not equal.
Less Than Operator | Determines whether one DateTime value is less than a specified DateTime.
Less Than Or Equal Operator | Determines whether one DateTime value is less than or equal to a specified DateTime.
Subtraction Operator | Overloaded. [To be supplied.]

See Also

DateTime Structure | System Namespace


DateTime Addition Operator

Adds a TimeSpan value to a DateTime value.

[C#]
public static DateTime operator +(
   DateTime d,
   TimeSpan t
);
[C++]
public: static DateTime operator op_Addition(
   DateTime d,
   TimeSpan t
);
[JScript]
returnValue = d + t;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

d
A DateTime value.
t
A TimeSpan value.

Parameters [C#, C++]

d
A DateTime value.
t
A TimeSpan value.

Return Value [C#, C++, JScript]

A DateTime sum of adding a DateTime and a TimSpan value.

Remarks [C#, C++, JScript]

This operator takes a DateTime value and a TimeSpan value and adds them together (d + t), so that the sum has a tick value equal to the sum of the tick values. The sum is formatted as a DateTime value.

See Also

DateTime Structure | DateTime Members | System Namespace | TimeSpan | Ticks


DateTime Equality Operator

Determines whether two DateTime values are equal.

[C#]
public static bool operator ==(
   DateTime d1,
   DateTime d2
);
[C++]
public: static bool operator op_Equality(
   DateTime d1,
   DateTime d2
);
[JScript]
returnValue = d1 == d2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

d1
The first DateTime.
d2
The second DateTime.

Parameters [C#, C++]

d1
The first DateTime.
d2
The second DateTime.

Return Value [C#, C++, JScript]

true if two DateTime values represent the same date and time; otherwise, false.

Remarks [C#, C++, JScript]

Thos operator compares two DateTime values for equality (d1 and d2) and returns a value the represents a Boolean determination of their are equality.

The operator is called using "==".

See Also

DateTime Structure | DateTime Members | System Namespace | Boolean


DateTime Greater Than Operator

Determines whether one DateTime value is greater than a specified DateTime.

[C#]
public static bool operator >(
   DateTime t1,
   DateTime t2
);
[C++]
public: static bool operator op_GreaterThan(
   DateTime t1,
   DateTime t2
);
[JScript]
returnValue = t1 > t2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

t1
The first DateTime value.
t2
The second DateTime value.

Parameters [C#, C++]

t1
The first DateTime value.
t2
The second DateTime value.

Return Value [C#, C++, JScript]

true if the first DateTime is greater than the second DateTime; otherwise, false.

Remarks [C#, C++, JScript]

This operator determines whether the first DateTime value is greater than the second DateTime value (t1 > t2) and returns a Boolean value that represents their relationship.

See Also

DateTime Structure | DateTime Members | System Namespace | Boolean


DateTime Greater Than Or Equal Operator

Determines whether one DateTime value is greater than or equal to a specified DateTime.

[C#]
public static bool operator >=(
   DateTime t1,
   DateTime t2
);
[C++]
public: static bool operator op_GreaterThanOrEqual(
   DateTime t1,
   DateTime t2
);
[JScript]
returnValue = t1 >= t2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

t1
The first DateTime value.
t2
The second DateTime value.

Parameters [C#, C++]

t1
The first DateTime value.
t2
The second DateTime value.

Return Value [C#, C++, JScript]

true if the first DateTime is greater than or equal to the second DateTime; otherwise, false.

Remarks [C#, C++, JScript]

This operator determines whether the first DateTime value is greater than or equal to the second DateTime value (t1 >= t2) and returns a Boolean value concerning their relationship.

See Also

DateTime Structure | DateTime Members | System Namespace | Boolean


DateTime Inequality Operator

Determines whether two DateTime values are not equal.

[C#]
public static bool operator !=(
   DateTime d1,
   DateTime d2
);
[C++]
public: static bool operator op_Inequality(
   DateTime d1,
   DateTime d2
);
[JScript]
returnValue = d1 ! = d2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

d1
The first DateTime.
d2
The second DateTime.

Parameters [C#, C++]

d1
The first DateTime.
d2
The second DateTime.

Return Value [C#, C++, JScript]

true if two DateTime values do not represent the same date and time; otherwise, false.

Remarks [C#, C++, JScript]

This operator compares two DateTime values (d1 and d2) to determine they are not equal and returns a Boolean value that represents their are inequality.

See Also

DateTime Structure | DateTime Members | System Namespace | Boolean


DateTime Less Than Operator

Determines whether one DateTime value is less than a specified DateTime.

[C#]
public static bool operator <(
   DateTime t1,
   DateTime t2
);
[C++]
public: static bool operator op_LessThan(
   DateTime t1,
   DateTime t2
);
[JScript]
returnValue = t1 < t2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

t1
The first DateTime value.
t2
The second DateTime value.

Parameters [C#, C++]

t1
The first DateTime value.
t2
The second DateTime value.

Return Value [C#, C++, JScript]

true if the first DateTime is less than the second DateTime; otherwise, false.

Remarks [C#, C++, JScript]

This operator determines whether the first DateTime value is less than the second DateTime value (t1 < t2) and returns a Boolean value that represents their relationship.

See Also

DateTime Structure | DateTime Members | System Namespace | Boolean


DateTime Less Than Or Equal Operator

Determines whether one DateTime value is less than or equal to a specified DateTime.

[C#]
public static bool operator <=(
   DateTime t1,
   DateTime t2
);
[C++]
public: static bool operator op_LessThanOrEqual(
   DateTime t1,
   DateTime t2
);
[JScript]
returnValue = t1 <= t2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

t1
The first DateTime value.
t2
The second DateTime value.

Parameters [C#, C++]

t1
The first DateTime value.
t2
The second DateTime value.

Return Value [C#, C++, JScript]

true if the first DateTime is less than or equal to the second DateTime; otherwise, false.

Remarks [C#, C++, JScript]

This operator determines whether the first DateTime value is less than or equal to the second DateTime value (t1 <= t2) and returns a Boolean value concerning their relationship.

See Also

DateTime Structure | DateTime Members | System Namespace | Boolean


DateTime Subtraction Operator

[To be supplied.]

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

Overload List [C#, C++, JScript]

Subtracts a specified TimeSpan from a specified DateTime, producing a new DateTime.

[C#] public static DateTime operator -(DateTime, TimeSpan);
[C++] public: static DateTime operator op_Subtraction(DateTime, TimeSpan);
[JScript] Subtraction Operator (DateTime, TimeSpan)

Subtracts a DateTime value from a DateTime value, producing a time interval (TimeSpan).

[C#] public static TimeSpan operator -(DateTime, DateTime);
[C++] public: static TimeSpan operator op_Subtraction(DateTime, DateTime);
[JScript] Subtraction Operator (DateTime, DateTime)

See Also

DateTime Structure | DateTime Members | System Namespace


DateTime Subtraction Operator (DateTime, TimeSpan)

Subtracts a specified TimeSpan from a specified DateTime, producing a new DateTime.

[C#]
public static DateTime operator -(
   DateTime d,
   TimeSpan t
);
[C++]
public: static DateTime operator op_Subtraction(
   DateTime d,
   TimeSpan t
);
[JScript]
returnValue = d - t;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

d
A DateTime value.
t
A TimeSpan value.

Parameters [C#, C++]

d
A DateTime value.
t
A TimeSpan value.

Return Value [C#, C++, JScript]

A DateTime value with a Ticks value equal to the difference of the ticks value.

Remarks [C#, C++, JScript]

This operator subtracts a TimeSpan value from a DateTime value after converting them to ticks, and the difference is formatted as a DateTime value (d and t: d- t).

See Also

DateTime Structure | DateTime Members | System Namespace | DateTime Subtraction Operator Overload List | Ticks | TimeSpan


DateTime Subtraction Operator (DateTime, DateTime)

Subtracts a DateTime value from a DateTime value, producing a time interval (TimeSpan).

[C#]
public static TimeSpan operator -(
   DateTime d1,
   DateTime d2
);
[C++]
public: static TimeSpan operator op_Subtraction(
   DateTime d1,
   DateTime d2
);
[JScript]
returnValue = d1 - d2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

d1
The first DateTime value.
d2
The second DateTime value.

Parameters [C#, C++]

d1
The first DateTime value.
d2
The second DateTime value.

Return Value [C#, C++, JScript]

Returns a DateTime value with a Ticks value equal to the difference of the ticks value.

Remarks [C#, C++, JScript]

This operator subtracts two DateTime values, using a ticks value, and the difference is formatted as a TimeSpan value (d1 and d2: d1- d2).

See Also

DateTime Structure | DateTime Members | System Namespace | DateTime Subtraction Operator Overload List | Ticks | TimeSpan


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DateTime Fields

The fields of the DateTime structure are listed below. For a complete list of DateTime structure members, see the DateTime Members topic.

Public:

Empty | Represents the constant DateTime empty value.
MaxValue | Represents the maximum DateTime value.
MinValue | Represents the minimum DateTime value.

See Also

DateTime Structure | System Namespace


DateTime.Empty

Represents the constant DateTime empty value.

[Visual Basic]
Public Shared ReadOnly Empty As DateTime
[C#]
public static readonly DateTime Empty;
[C++]
public: static readonly DateTime Empty;
[JScript]
public static var Empty : DateTime;

Remarks

The DateTime value represents the empty value.

Empty is equal to MinValue, which is the minimum date and time value of "1/1/0001 12:00:00 AM".

See Also

DateTime Structure | DateTime Members | System Namespace


DateTime.MaxValue

Represents the maximum DateTime value.

[Visual Basic]
Public Shared ReadOnly MaxValue As DateTime
[C#]
public static readonly DateTime MaxValue;
[C++]
public: static readonly DateTime MaxValue;
[JScript]
public static var MaxValue : DateTime;

Remarks

The MaxValue field is a constant representing the largest possible DateTime value. The maximum date and time value is "12/31/9999 11:59:59 PM".

See Also

DateTime Structure | DateTime Members | System Namespace | Ticks


DateTime.MinValue

Represents the minimum DateTime value.

[Visual Basic]
Public Shared ReadOnly MinValue As DateTime
[C#]
public static readonly DateTime MinValue;
[C++]
public: static readonly DateTime MinValue;
[JScript]
public static var MinValue : DateTime;

Remarks

The MinValue field is a constant representing the smallest possible DateTime value. The minimum date and time value is "12:00:00 AM 1/1/100 AD". Before time zone is introduced, ticks are based upon 1/1/0001 local time.

See Also

DateTime Structure | DateTime Members | System Namespace | Ticks


DBNull Class

Represents a null value.

Object
DBNull

[Visual Basic]
NotInheritable Public Class DBNull
   Implements ISerializable, IConvertible
[C#]
public sealed class DBNull : ISerializable, IConvertible
[C++]
public __gc __sealed class DBNull : public ISerializable,
   IConvertible
[JScript]
public class DBNull implements ISerializable, IConvertible

Remarks

This class is used to indicate that a parameter is missing or nonexistent. DBNull is never equal to anything. It is used in DBNull for default arguments.

DBNull is a singleton class, which means only one instance of this class can exist.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

DBNull Members | System Namespace


DBNull Members

Public:

Methods

Equals | Determines whether the specified Object is equal to DBNull.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the DBNull object.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | Gets the TypeCode value for DBNull.
SetObjectData | Implements the ISerializable interface.
ToBoolean | Throws an InvalidCastException. Called by the ToType method.
ToByte | Throws an InvalidCastException. Called by the ToType method.
ToChar | Throws an InvalidCastException. Called by the ToType method.
ToDateTime | Throws an InvalidCastException. Called by the ToType method.
ToDecimal | Throws an InvalidCastException. Called by the ToType method.
ToDouble | Throws an InvalidCastException. Called by the ToType method.
ToInt16 | Throws an InvalidCastException. Called by the ToType method.
ToInt32 | Throws an InvalidCastException. Called by the ToType method.
ToInt64 | Throws an InvalidCastException. Called by the ToType method.
ToSByte | Throws an InvalidCastException. Called by the ToType method.
ToSingle | Throws an InvalidCastException. Called by the ToType method.
ToString | Returns an empty string.
ToType | Calls the appropriate method, depending on the specified type.
ToUInt16 | Throws an InvalidCastException. Called by the ToType method.
ToUInt32 | Throws an InvalidCastException. Called by the ToType method.
ToUInt64 | Throws an InvalidCastException. Called by the ToType method.

Fields

Value Initializes a new instance of the DBNull class.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DBNull Class | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DBNull Methods

The methods of the DBNull class are listed below. For a complete list of DBNull class members, see the DBNull Members topic.

Public:

Equals | Determines whether the specified Object is equal to DBNull.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the DBNull object.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | Gets the TypeCode value for DBNull.
SetObjectData | Implements the ISerializable interface.
ToBoolean | Throws an InvalidCastException. Called by the ToType method.
ToByte | Throws an InvalidCastException. Called by the ToType method.
ToChar | Throws an InvalidCastException. Called by the ToType method.
ToDateTime | Throws an InvalidCastException. Called by the ToType method.
ToDecimal | Throws an InvalidCastException. Called by the ToType method.
ToDouble | Throws an InvalidCastException. Called by the ToType method.
ToInt16 | Throws an InvalidCastException. Called by the ToType method.
ToInt32 | Throws an InvalidCastException. Called by the ToType method.
ToInt64 | Throws an InvalidCastException. Called by the ToType method.
ToSByte | Throws an InvalidCastException. Called by the ToType method.
ToSingle | Throws an InvalidCastException. Called by the ToType method.
ToString | Returns an empty string.
ToType | Calls the appropriate method, depending on the specified type.
ToUInt16 | Throws an InvalidCastException. Called by the ToType method.
ToUInt32 | Throws an InvalidCastException. Called by the ToType method.
ToUInt64 | Throws an InvalidCastException. Called by the ToType method.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DBNull Class | System Namespace


DBNull.Equals

Determines whether the specified Object is equal to DBNull.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal other As Object _
) As Boolean
[C#]
public override bool Equals(
   object other
);
[C++]
public: override bool Equals(
   Object* other
);
[JScript]
public override function Equals(
   other : Object
) : Boolean;

Parameters

other
The Object to compare with DBNull.

Return Value

true if other refers to the sole DBNull instance; otherwise, false.

See Also

DBNull Class | DBNull Members | System Namespace


DBNull.GetObjectData

Implements the ISerializable interface and returns the data needed to serialize the DBNull object.

[Visual Basic]
Overridable Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
public: virtual void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
);
[JScript]
public function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);

Parameters

info
A SerializationInfo object containing information required to serialize the DBNull object.
context
A StreamingContext object containing the source and destination of the serialized stream associated with the DBNull object.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | info is a null reference (in Visual Basic Nothing).

See Also

DBNull Class | DBNull Members | System Namespace | ISerializable | SerializationInfo | StreamingContext | SetObjectData


DBNull.GetTypeCode

Gets the TypeCode value for DBNull.

[Visual Basic]
Overridable Public Function GetTypeCode() As TypeCode
[C#]
public virtual TypeCode GetTypeCode();
[C++]
public: virtual TypeCode GetTypeCode();
[JScript]
public function GetTypeCode() : TypeCode;

Return Value

The TypeCode value for DBNull.

See Also

DBNull Class | DBNull Members | System Namespace | TypeCode


DBNull.SetObjectData

Implements the ISerializable interface.

[Visual Basic]
Public Sub SetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
public void SetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
public: void SetObjectData(
   SerializationInfo* info,
   StreamingContext context
);
[JScript]
public function SetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);

Parameters

info
A SerializationInfo object containing information required to serialize the DBNull object.
context
A StreamingContext object containing the source and destination of the serialized stream associated with the DBNull object.

Return Value

None.

See Also

DBNull Class | DBNull Members | System Namespace | ISerializable | SerializationInfo | StreamingContext | GetObjectData


DBNull.ToBoolean

Throws an InvalidCastException. Called by the ToType method.

[Visual Basic]
Overridable Public Function ToBoolean() As Boolean
[C#]
public virtual bool ToBoolean();
[C++]
public: virtual bool ToBoolean();
[JScript]
public function ToBoolean() : Boolean;

Return Value

None, but the return value is typed bool to implement the IConvertible interface.

Exceptions

Exception Type | Condition
InvalidCastException | (Always thrown.)

See Also

DBNull Class | DBNull Members | System Namespace | ToType | IConvertible | Type | Boolean


DBNull.ToByte

Throws an InvalidCastException. Called by the ToType method.

[Visual Basic]
Overridable Public Function ToByte() As Byte
[C#]
public virtual byte ToByte();
[C++]
public: virtual unsigned char ToByte();
[JScript]
public function ToByte() : Byte;

Return Value

None, but the return value is typed byte to implement the IConvertible interface.

Exceptions

Exception Type | Condition
InvalidCastException | (Always thrown.)

Remarks

If the ToType type is a byte this method is called. This method throws an InvalidCastException().

See Also

DBNull Class | DBNull Members | System Namespace | ToType | IConvertible | Type | Byte


DBNull.ToChar

Throws an InvalidCastException. Called by the ToType method.

[Visual Basic]
Overridable Public Function ToChar() As Char
[C#]
public virtual char ToChar();
[C++]
public: virtual __wchar_t ToChar();
[JScript]
public function ToChar() : Char;

Return Value

None, but the return value is typed char to implement the IConvertible interface.

Exceptions

Exception Type | Condition
InvalidCastException | (Always thrown.)

Remarks

If the ToType type is a char this method is called. This method throws an InvalidCastException().

See Also

DBNull Class | DBNull Members | System Namespace | ToType | IConvertible | Type | Char


DBNull.ToDateTime

Throws an InvalidCastException. Called by the ToType method.

[Visual Basic]
Overridable Public Function ToDateTime() As DateTime
[C#]
public virtual DateTime ToDateTime();
[C++]
public: virtual DateTime ToDateTime();
[JScript]
public function ToDateTime() : DateTime;

Return Value

None, but the return value is typed DateTime to implement the IConvertible interface.

Exceptions

Exception Type | Condition
InvalidCastException | (Always thrown.)

Remarks

If the ToType type is a DateTime this method is called. This method throws an InvalidCastException().

See Also

DBNull Class | DBNull Members | System Namespace | ToType | IConvertible | Type | DateTime


DBNull.ToDecimal

Throws an InvalidCastException. Called by the ToType method.

[Visual Basic]
Overridable Public Function ToDecimal() As Decimal
[C#]
public virtual Decimal ToDecimal();
[C++]
public: virtual Decimal ToDecimal();
[JScript]
public function ToDecimal() : Decimal;

Return Value

None, but the return value is typed decimal to implement the IConvertible interface.

Remarks

If the ToType type is a Decimal this method is called. This method throws an InvalidCastException().

See Also

DBNull Class | DBNull Members | System Namespace | ToType | IConvertible | Type | Decimal


DBNull.ToDouble

Throws an InvalidCastException. Called by the ToType method.

[Visual Basic]
Overridable Public Function ToDouble() As Double
[C#]
public virtual double ToDouble();
[C++]
public: virtual double ToDouble();
[JScript]
public function ToDouble() : double;

Return Value

None, but the return value is typed double to implement the IConvertible interface.

Exceptions

Exception Type | Condition
InvalidCastException | (Always thrown.)

Remarks

If the ToType type is a double this method is called. This method throws an InvalidCastException().

See Also

DBNull Class | DBNull Members | System Namespace | ToType | IConvertible | Type | Double


DBNull.ToInt16

Throws an InvalidCastException. Called by the ToType method.

[Visual Basic]
Overridable Public Function ToInt16() As Short
[C#]
public virtual short ToInt16();
[C++]
public: virtual short ToInt16();
[JScript]
public function ToInt16() : Int16;

Return Value

None, but the return value is typed short to implement the IConvertible interface.

Exceptions

Exception Type | Condition
InvalidCastException | (Always thrown.)

Remarks

If the ToType type is a short this method is called. This method throws an InvalidCastException().

See Also

DBNull Class | DBNull Members | System Namespace | ToType | IConvertible | Type | Int16


DBNull.ToInt32

Throws an InvalidCastException. Called by the ToType method.

[Visual Basic]
Overridable Public Function ToInt32() As Integer
[C#]
public virtual int ToInt32();
[C++]
public: virtual int ToInt32();
[JScript]
public function ToInt32() : int;

Return Value

None, but the return value is typed int to implement the IConvertible interface.

Exceptions

Exception Type | Condition
InvalidCastException | (Always thrown.)

Remarks

If the ToType type is an int this method is called. This method throws an InvalidCastException().

See Also

DBNull Class | DBNull Members | System Namespace | ToType | IConvertible | Type | Int32


DBNull.ToInt64

Throws an InvalidCastException. Called by the ToType method.

[Visual Basic]
Overridable Public Function ToInt64() As Long
[C#]
public virtual long ToInt64();
[C++]
public: virtual __int64 ToInt64();
[JScript]
public function ToInt64() : long;

Return Value

None, but the return value is typed long to implement the IConvertible interface.

Exceptions

Exception Type | Condition
InvalidCastException | (Always thrown.)

Remarks

If the ToType type is a long this method is called. This method throws an InvalidCastException().

See Also

DBNull Class | DBNull Members | System Namespace | ToType | IConvertible | Type | Int64


DBNull.ToSByte

Throws an InvalidCastException. Called by the ToType method.

[Visual Basic]
Overridable Public Function ToSByte() As SByte
[C#]
public virtual sbyte ToSByte();
[C++]
public: virtual char ToSByte();
[JScript]
public function ToSByte() : SByte;

Return Value

None, but the return value is typed sbyte to implement the IConvertible interface.

Exceptions

Exception Type | Condition
InvalidCastException | (Always thrown.)

Remarks

If the ToType type is a sbyte this method is called. This method throws an InvalidCastException().

See Also

DBNull Class | DBNull Members | System Namespace | ToType | IConvertible | Type | SByte


DBNull.ToSingle

Throws an InvalidCastException. Called by the ToType method.

[Visual Basic]
Overridable Public Function ToSingle() As Single
[C#]
public virtual float ToSingle();
[C++]
public: virtual float ToSingle();
[JScript]
public function ToSingle() : float;

Return Value

None, but the return value is typed float to implement the IConvertible interface.

Exceptions

Exception Type | Condition
InvalidCastException | (Always thrown.)

Remarks

If the ToType type is a float this method is called. This method throws an InvalidCastException().

See Also

DBNull Class | DBNull Members | System Namespace | ToType | IConvertible | Type | Single


DBNull.ToString

Returns an empty string.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

An empty string (Empty).

See Also

DBNull Class | DBNull Members | System Namespace | String | Empty


DBNull.ToType

Calls the appropriate method, depending on the specified type.

[Visual Basic]
Overridable Public Function ToType( _
   ByVal type As Type _
) As Object
[C#]
public virtual object ToType(
   Type type
);
[C++]
public: virtual Object* ToType(
   Type* type
);
[JScript]
public function ToType(
   type : Type
) : Object;

Parameters

type
The Type to DBNull into.

Return Value

None, but the return value is typed the same as type.

Exceptions

Exception Type | Condition
InvalidCastException | (Always thrown.)

Remarks

The following table specifies the method called based on the Type of the type parameter.

Method called | Type of
ToBoolean | bool
ToChar | char
ToSByte | sbyte
ToByte | byte
ToInt16 | short
ToUInt16 | ushort
ToInt32 | int
ToUInt32 | uint
ToInt64 | long
ToUInt64 | ulong
ToSingle | float
ToDouble | Double
ToDecimal | Decimal
ToDateTime | DateTime

See Also

DBNull Class | DBNull Members | System Namespace | Type


DBNull.ToUInt16

Throws an InvalidCastException. Called by the ToType method.

[Visual Basic]
Overridable Public Function ToUInt16() As UInt16
[C#]
public virtual ushort ToUInt16();
[C++]
public: virtual unsigned short ToUInt16();
[JScript]
public function ToUInt16() : UInt16;

Return Value

None, but the return value is typed ushort to implement the IConvertible interface.

Exceptions

Exception Type | Condition
InvalidCastException | (Always thrown.)

Remarks

If the ToType type is a ushort this method is called. This method throws an InvalidCastException().

See Also

DBNull Class | DBNull Members | System Namespace | ToType | IConvertible | Type | UInt16


DBNull.ToUInt32

Throws an InvalidCastException. Called by the ToType method.

[Visual Basic]
Overridable Public Function ToUInt32() As UInt32
[C#]
public virtual uint ToUInt32();
[C++]
public: virtual unsigned int ToUInt32();
[JScript]
public function ToUInt32() : UInt32;

Return Value

None, but the return value is typed uint to implement the IConvertible interface.

Exceptions

Exception Type | Condition
InvalidCastException | (Always thrown.)

Remarks

If the ToType type is a uint this method is called. This method throws an InvalidCastException().

See Also

DBNull Class | DBNull Members | System Namespace | ToType | IConvertible | Type | UInt32


DBNull.ToUInt64

Throws an InvalidCastException. Called by the ToType method.

[Visual Basic]
Overridable Public Function ToUInt64() As UInt64
[C#]
public virtual ulong ToUInt64();
[C++]
public: virtual unsigned __int64 ToUInt64();
[JScript]
public function ToUInt64() : UInt64;

Return Value

None, but the return value is typed ulong to implement the IConvertible interface.

Exceptions

Exception Type | Condition
InvalidCastException | (Always thrown.)

Remarks

If the ToType type is a ulong this method is called. This method throws an InvalidCastException().

See Also

DBNull Class | DBNull Members | System Namespace | ToType | IConvertible | Type | UInt64


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DBNull Fields

The fields of the DBNull class are listed below. For a complete list of DBNull class members, see the DBNull Members topic.

Public:

Value Initializes a new instance of the DBNull class.

See Also

DBNull Class | System Namespace


DBNull.Value

Initializes a new instance of the DBNull class.

[Visual Basic]
Public Shared ReadOnly Value As DBNull
[C#]
public static readonly DBNull Value;
[C++]
public: static readonly DBNull* Value;
[JScript]
public static var Value : DBNull;

Remarks

DBNull is a singleton class, which means only one instance of this class can exist.

See Also

DBNull Class | DBNull Members | System Namespace


Decimal Structure

Represents a decimal value.

Object
ValueType
Decimal

[Visual Basic]
Public Structure Decimal
   Implements IFormattable, IComparable, IConvertible
[C#]
public struct Decimal : IFormattable, IComparable, IConvertible
[C++]
public __value struct Decimal : public IFormattable, IComparable,
   IConvertible

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

The Decimal data type can represent positive and negative values with 28 significant digits, ranging from positive 79,228,162,514,264,337,593,543,950,335 through negative 79,228,162,514,264,337,593,543,950,335.

The Decimal type is well suited to financial calculations that require a large number of significant digits and no round-off errors. (For additional information about specific number formatting and cultures, see Globalization Namespace, NumberFormatInfo and CultureInfo.)

The finite set of values of type Decimal are of the form m/ 10 e, where m is an integer such that-296 < m < 296, and e is an integer between 0 and 28 inclusive.

In contrast to the Single (float) and Double data types, decimal fractional numbers, such as 0.1, can be represented exactly in the decimal representation. In the Single and Double representations, such numbers are often infinite fractions, making those representations more prone to round-off errors.

The Decimal class implements widening conversions from the Byte, Char, Int16, Int32, and Int64 types to Decimal. These widening conversions never lose any information and never throw exceptions.

The Decimal class also implements narrowing conversions from Decimal to Byte, Char, Int16, Int32, and Int64. These narrowing conversions round the Decimal value toward zero to the nearest integer, and then convert that integer to the destination type. An OverflowException is thrown if the result is not within the range of the destination type.

The Decimal class also provides a widening conversion from Currency to a Decimal. This widening conversion never looses any information and never throws exceptions. The Currency class provides a narrowing conversion from Decimal to Currency. This narrowing conversion rounds the Decimal to four decimals and then converts that number to a Currency. An OverflowException is thrown if the result is not within the range of the Currency type.

The Decimal class provides narrowing conversions to and from the Single and Double types. A conversion from Decimal to Single or Double may lose precision, but will not lose information about the overall magnitude of the numeric value. It will never throw an exception. A conversion from a Single or a Double to a Decimal throws an OverflowException if the value is not within the range of the Decimal type.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

Decimal Members | System Namespace


Decimal Members

Public:

Constructor

Decimal Constructor Overloaded. [To be supplied.]

Properties

Scale Retrieves the scale value for the Decimal.

Methods

Abs | Returns the absolute value of the specified Decimal.
Add | Adds two Decimal values.
Compare | Compares specified Decimal values.
CompareTo | Compares this instance to a specified Object.
Divide | Divides two specified Decimal values.
Equals | Overloaded. Determines whether two values are equal.
Floor | Rounds a Decimal down to the next lower whole number value.
Format | Overloaded. Converts a numeric value to a String.
FromString | Converts a string to a Decimal.
GetBits | Returns a binary representation of a Decimal.
GetHashCode | Returns the hash code for this Decimal.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | Returns the hash code for this instance of Decimal.
Max | Returns the larger of two Decimal values.
Min | Returns the smaller of two Decimal values.
Mod | Returns the remainder from dividing two Decimal values.
Multiply | Divides two Decimal values and produces a Decimal result.
Negate | Returns the negated value of the specified Decimal.
Parse | Overloaded. Converts a String to a Decimal.
Round | Rounds a Decimal value to a specified number of decimal places.
Subtract | Subtracts two specified Decimal values.
ToBoolean | Converts a string to a Decimal value.
ToByte | Overloaded. Converts a Decimal to an unsigned Byte.
ToChar | Converts a Decimal to a character.
ToCurrency | Converts a Decimal to a Currency.
ToDateTime | Converts this instance of a Decimal to a DateTime object.
ToDecimal | Converts this instance of a Decimal to a Decimal format.
ToDouble | Overloaded. Converts a Decimal to a Double.
ToInt16 | Overloaded. Converts a Decimal to an Int16.
ToInt32 | Overloaded. Converts a Decimal to an Int32.
ToInt64 | Overloaded. Converts a Decimal to an Int64.
ToSByte | Overloaded. Converts a Decimal to an SByte.
ToSingle | Overloaded. Converts a Decimal to a Single.
ToString | Overloaded. [To be supplied.]
ToType | Retrieves the Type for a specified Object.
ToUInt16 | Overloaded. [To be supplied.]
ToUInt32 | Overloaded. [To be supplied.]
ToUInt64 | Overloaded. [To be supplied.]
Truncate | Truncates a specified Decimal to an integer value.

Operators and Type Conversions

Addition Operator | Adds two Decimal values.
Decrement Operator | [To be supplied.]
Division Operator | Divides two Decimal values and returns a Decimal result.
Equality Operator | Determines whether two specified Decimal values are equal.
Greater Than Operator | Determines whether one Decimal value is greater than a specified Decimal.
Greater Than Or Equal Operator | Determines whether one Decimal value is greater than or equal to a specified Decimal.
Increment Operator | [To be supplied.]
Inequality Operator | Determines whether two Decimal values are not equal.
Less Than Operator | Determines whether one Decimal value is less than a specified Decimal.
Less Than Or Equal Operator | Determines whether one Decimal value is less than or equal to a specified Decimal.
Modulus Operator | Determines the remainder from dividing two Decimal values.
Multiplication Operator | Multiplies two Decimal values and produces a Decimal result.
Subtraction Operator | Subtracts two specified Decimal values.
Unary Negation Operator | Decrements the specified number.
Unary Plus Operator | Returns the negated value of the specified Decimal.
Decimal to Double Conversion | [To be supplied.]
Decimal to Single Conversion | [To be supplied.]
Decimal to UInt32 Conversion | [To be supplied.]
Decimal to Int64 Conversion | [To be supplied.]
Decimal to UInt64 Conversion | [To be supplied.]
Single to Decimal Conversion | [To be supplied.]
Decimal to Int16 Conversion | [To be supplied.]
Decimal to Char Conversion | [To be supplied.]
Decimal to Int32 Conversion | [To be supplied.]
Decimal to UInt16 Conversion | [To be supplied.]
Decimal to SByte Conversion | [To be supplied.]
Double to Decimal Conversion | [To be supplied.]
Decimal to Byte Conversion | [To be supplied.]
Byte to Decimal Conversion | Overloaded. [To be supplied.]

Fields

Empty | Representing the constant that is the empty Decimal value.
MaxValue | Representing the constant that is the largest possible Decimal value.
MinusOne | Representing the constant that is the Decimal value of minus one:-1.
MinValue | Representing the constant that is the smallest possible Decimal value. .
One | Representing the constant that is the Decimal value of one: 1.
ScaleMask | Representing the constant that is the scale mask for the flags field.
SignMask | Representing the constant that is the sign mask for the flags field. .
Zero | Representing the constant that is the Decimal value of zero: 0.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Decimal Structure | System Namespace


Decimal Constructor

[To be supplied.]

Overload List

Initializes a new instance of the Decimal class to a value specified by an Int32.

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public Decimal(int);
[C++] public: Decimal(int);
[JScript] public function Decimal(int);

Initializes a new instance of the Decimal class to a value specified by a UInt32.

[Visual Basic] Overloads Public Sub New(UInt32)
[C#] public Decimal(uint);
[C++] public: Decimal(unsigned int);
[JScript] public function Decimal(UInt32);

Initializes a new instance of the Decimal class to a value specified by an Int64.

[Visual Basic] Overloads Public Sub New(Long)
[C#] public Decimal(long);
[C++] public: Decimal(__int64);
[JScript] public function Decimal(long);

Initializes a new instance of the Decimal class to a value specified by a UInt64.

[Visual Basic] Overloads Public Sub New(UInt64)
[C#] public Decimal(ulong);
[C++] public: Decimal(unsigned __int64);
[JScript] public function Decimal(UInt64);

Initializes a new instance of the Decimal class to a value specified by a Single.

[Visual Basic] Overloads Public Sub New(Single)
[C#] public Decimal(float);
[C++] public: Decimal(float);
[JScript] public function Decimal(float);

Initializes a new instance of the Decimal class to a value specified by a Double.

[Visual Basic] Overloads Public Sub New(Double)
[C#] public Decimal(double);
[C++] public: Decimal(double);
[JScript] public function Decimal(double);

Initializes a new instance of the Decimal class to a value specified by a Currency.

[Visual Basic] Overloads Public Sub New(Currency)
[C#] public Decimal(Currency);
[C++] public: Decimal(Currency);
[JScript] public function Decimal(Currency);

Initializes a new instance of the Decimal from an integer array containing a binary representation.

[Visual Basic] Overloads Public Sub New(Integer())
[C#] public Decimal(int[]);
[C++] public: Decimal(int*[]);
[JScript] public function Decimal(int[]);

Constructs a Decimal from its constituent parts.

[Visual Basic] Overloads Public Sub New(Integer, Integer, Integer, Boolean, Byte)
[C#] public Decimal(int, int, int, bool, byte);
[C++] public: Decimal(int, int, int, bool, unsigned char);
[JScript] public function Decimal(int, int, int, Boolean, Byte);

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal Constructor (Int32)

Initializes a new instance of the Decimal class to a value specified by an Int32.

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As Integer _
)
[C#]
public Decimal(
   int value
);
[C++]
public: Decimal(
   int value
);
[JScript]
public function Decimal(
   value : int
);

Parameters

value
The value to represent as a Decimal.

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal Constructor Overload List


Decimal Constructor (UInt32)

Initializes a new instance of the Decimal class to a value specified by a UInt32.

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As UInt32 _
)
[C#]
public Decimal(
   uint value
);
[C++]
public: Decimal(
   unsigned int value
);
[JScript]
public function Decimal(
   value : UInt32
);

Parameters

value
The value to represent as a Decimal.

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal Constructor Overload List


Decimal Constructor (Int64)

Initializes a new instance of the Decimal class to a value specified by an Int64.

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As Long _
)
[C#]
public Decimal(
   long value
);
[C++]
public: Decimal(
   __int64 value
);
[JScript]
public function Decimal(
   value : long
);

Parameters

value
The value to represent as a Decimal.

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal Constructor Overload List


Decimal Constructor (UInt64)

Initializes a new instance of the Decimal class to a value specified by a UInt64.

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As UInt64 _
)
[C#]
public Decimal(
   ulong value
);
[C++]
public: Decimal(
   unsigned __int64 value
);
[JScript]
public function Decimal(
   value : UInt64
);

Parameters

value
The value to represent as a Decimal.

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal Constructor Overload List


Decimal Constructor (Single)

Initializes a new instance of the Decimal class to a value specified by a Single.

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As Single _
)
[C#]
public Decimal(
   float value
);
[C++]
public: Decimal(
   float value
);
[JScript]
public function Decimal(
   value : float
);

Parameters

value
The value to represent as a Decimal.

Exceptions

Exception Type | Condition
OverflowException | is thrown if the resulting value is outside the Decimal range, or if value is Not a Number (NaN) or positive or negative infinity.

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal Constructor Overload List


Decimal Constructor (Double)

Initializes a new instance of the Decimal class to a value specified by a Double.

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As Double _
)
[C#]
public Decimal(
   double value
);
[C++]
public: Decimal(
   double value
);
[JScript]
public function Decimal(
   value : double
);

Parameters

value
The value to represent as a Decimal.

Exceptions

Exception Type | Condition
OverflowException | If the Decimal is outside the Decimal range
OverflowException | If the Decimal is positive or negative infinity or not a number (NaN).

Remarks

Double initializes a Decimal from an 8-byte, double-precision floating-point number.

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal Constructor Overload List


Decimal Constructor (Currency)

Initializes a new instance of the Decimal class to a value specified by a Currency.

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As Currency _
)
[C#]
public Decimal(
   Currency value
);
[C++]
public: Decimal(
   Currency value
);
[JScript]
public function Decimal(
   value : Currency
);

Parameters

value
The value to represent as a Decimal.

Remarks

This constructor initializes a Decimal from a parameter in Currency format.

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal Constructor Overload List


Decimal Constructor (Int32[])

Initializes a new instance of the Decimal from an integer array containing a binary representation.

[Visual Basic]
Overloads Public Sub New( _
   ByVal bits() As Integer _
)
[C#]
public Decimal(
   int[] bits
);
[C++]
public: Decimal(
   int* bits[]
);
[JScript]
public function Decimal(
   bits : int[]
);

Parameters

bits
Binary representation of a Decimal.

Exceptions

Exception Type | Condition
ArgumentException | If the Decimal is null.
ArgumentException | II the length of the Decimal is not 4
ArgumentException | If the representation in the Decimal is not valid.

Remarks

This constructor initializes a Decimal from an integer array containing a binary representation. (For additional information, see GetBits.)

Note that there are several possible binary representations for the same numeric value. For example, the value 1 can be represented as {1, 0, 0, 0} (integer value 1 with a scale factor of 0) and equally well as {1000, 0, 0, 0x30000} (integer value 1000 with a scale factor of 3). The possible binary representations of a particular value are all equally valid, and all are numerically equivalent.

The bits argument must be a non-null integer array with four elements.

bits[0], bits[1], and bits[2] contains the low, middle, and high 32 bits of the 96-bit integer part of the Decimal.

bits[3] contains the scale factor and sign of the Decimal:

Bits 0 through 15 (the lower word) are unused and must be 0.

Bits 16-23 must contain a value between 0 and 28, indicating the power of 10 to divide the 96-bit integer part by to produce the Decimal value.

Bits 24-30 are unused and must be 0.

Bit 31 indicates the sign of the Decimal value: 0 meaning positive and 1 meaning negative.

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal Constructor Overload List


Decimal Constructor (Int32, Int32, Int32, Boolean, Byte)

Constructs a Decimal from its constituent parts.

[Visual Basic]
Overloads Public Sub New( _
   ByVal lo As Integer, _
   ByVal mid As Integer, _
   ByVal hi As Integer, _
   ByVal isNegative As Boolean, _
   ByVal scale As Byte _
)
[C#]
public Decimal(
   int lo,
   int mid,
   int hi,
   bool isNegative,
   byte scale
);
[C++]
public: Decimal(
   int lo,
   int mid,
   int hi,
   bool isNegative,
   unsigned char scale
);
[JScript]
public function Decimal(
   lo : int,
   mid : int,
   hi : int,
   isNegative : Boolean,
   scale : Byte
);

Parameters

lo
The lowest four bytes.
mid
The middle four bytes.
hi
The highest four bytes.
isNegative
Indicates whether the Decimal is negative.
scale
The power of 10 to divide the Decimal by.

Remarks

This constructor initializes a Decimal from an integer array containing a binary representation.

The scale must be between 0 and 28, inclusive. Note that the scale value only shrinks the decimal * (dec * 10-scale).

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Decimal Properties

The properties of the Decimal structure are listed below. For a complete list of Decimal structure members, see the Decimal Members topic.

Public:

Scale Retrieves the scale value for the Decimal.

See Also

Decimal Structure | System Namespace


Decimal.Scale

Retrieves the scale value for the Decimal.

[Visual Basic]
Public ReadOnly Property Scale As Byte
[C#]
public byte Scale {get;}
[C++]
public: __property unsigned char get_Scale();
[JScript]
public function get Scale() : Byte;

Property Value

The exponent of the Decimal value.

Remarks

The Scale property returns the scale value for the Decimal, which is guaranteed to be between 0 and 28, inclusive. This is the exponent by which the Decimal is multiplied (i.e., 10Scale).

See Also

Decimal Structure | Decimal Members | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Decimal Methods

The methods of the Decimal structure are listed below. For a complete list of Decimal structure members, see the Decimal Members topic.

Public:

Abs | Returns the absolute value of the specified Decimal.
Add | Adds two Decimal values.
Compare | Compares specified Decimal values.
CompareTo | Compares this instance to a specified Object.
Divide | Divides two specified Decimal values.
Equals | Overloaded. Determines whether two values are equal.
Floor | Rounds a Decimal down to the next lower whole number value.
Format | Overloaded. Converts a numeric value to a String.
FromString | Converts a string to a Decimal.
GetBits | Returns a binary representation of a Decimal.
GetHashCode | Returns the hash code for this Decimal.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | Returns the hash code for this instance of Decimal.
Max | Returns the larger of two Decimal values.
Min | Returns the smaller of two Decimal values.
Mod | Returns the remainder from dividing two Decimal values.
Multiply | Divides two Decimal values and produces a Decimal result.
Negate | Returns the negated value of the specified Decimal.
Parse | Overloaded. Converts a String to a Decimal.
Round | Rounds a Decimal value to a specified number of decimal places.
Subtract | Subtracts two specified Decimal values.
ToBoolean | Converts a string to a Decimal value.
ToByte | Overloaded. Converts a Decimal to an unsigned Byte.
ToChar | Converts a Decimal to a character.
ToCurrency | Converts a Decimal to a Currency.
ToDateTime | Converts this instance of a Decimal to a DateTime object.
ToDecimal | Converts this instance of a Decimal to a Decimal format.
ToDouble | Overloaded. Converts a Decimal to a Double.
ToInt16 | Overloaded. Converts a Decimal to an Int16.
ToInt32 | Overloaded. Converts a Decimal to an Int32.
ToInt64 | Overloaded. Converts a Decimal to an Int64.
ToSByte | Overloaded. Converts a Decimal to an SByte.
ToSingle | Overloaded. Converts a Decimal to a Single.
ToString | Overloaded. [To be supplied.]
ToType | Retrieves the Type for a specified Object.
ToUInt16 | Overloaded. [To be supplied.]
ToUInt32 | Overloaded. [To be supplied.]
ToUInt64 | Overloaded. [To be supplied.]
Truncate | Truncates a specified Decimal to an integer value.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Decimal Structure | System Namespace


Decimal.Abs

Returns the absolute value of the specified Decimal.

[Visual Basic]
Public Shared Function Abs( _
   ByVal d As Decimal _
) As Decimal
[C#]
public static Decimal Abs(
   Decimal d
);
[C++]
public: static Decimal Abs(
   Decimal d
);
[JScript]
public static function Abs(
   d : Decimal
) : Decimal;

Parameters

d
A Decimal value.

Return Value

The absolute value of the argument.

Remarks

The Abs method returns the absolute value of the specified Decimal. For example:

If d is positive, the result is d.

If d is negative, the result is -d.

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.Add

Adds two Decimal values.

[Visual Basic]
Public Shared Function Add( _
   ByVal d1 As Decimal, _
   ByVal d2 As Decimal _
) As Decimal
[C#]
public static Decimal Add(
   Decimal d1,
   Decimal d2
);
[C++]
public: static Decimal Add(
   Decimal d1,
   Decimal d2
);
[JScript]
public static function Add(
   d1 : Decimal,
   d2 : Decimal
) : Decimal;

Parameters

d1
The left operand, a Decimal.
d2
The right operand, a Decimal.

Return Value

The sum of two decimal values.

Exceptions

Exception Type | Condition
OverflowException | is thrown if the sum of the numbers are too large to represent as a Decimal.

Remarks

The Addition method performs an arithmetic function by adding two Decimal values and returns the sum of the two values (d1 + d.).

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.Compare

Compares specified Decimal values.

[Visual Basic]
Public Shared Function Compare( _
   ByVal d1 As Decimal, _
   ByVal d2 As Decimal _
) As Integer
[C#]
public static int Compare(
   Decimal d1,
   Decimal d2
);
[C++]
public: static int Compare(
   Decimal d1,
   Decimal d2
);
[JScript]
public static function Compare(
   d1 : Decimal,
   d2 : Decimal
) : int;

Parameters

d1
The left operand, a Decimal.
d2
The right operand, a Decimal.

Return Value

Value | Description
-1 | If the first number is less than the second number.
0 | If the numbers are equal.
1 | If the first number is greater than the second number.

Remarks

The Compare method compares two decimal values and returns an integer that represents the relationship between the values.

For example: if the first value is less than the second, then a negative one is returned. If the first value is equal the second, then a zero is returned. If the first value is more than the second, then a one is returned. The relationship can be expressed by the following:

-1 if d1 < d2,

0 if d1 = d2, or

1 if d1 > d2.

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.CompareTo

Compares this instance to a specified Object.

[Visual Basic]
Overridable Public Function CompareTo( _
   ByVal value As Object _
) As Integer
[C#]
public virtual int CompareTo(
   object value
);
[C++]
public: virtual int CompareTo(
   Object* value
);
[JScript]
public function CompareTo(
   value : Object
) : int;

Parameters

value
The object to compare with this instance.

Return Value

Value | Description
A negative integer | If this instance is less than the object.
Zero | If this instance and the object have the same value.
A positive integer | If this instance is greater than the object.
A positive integer | If the object is null. This is a special case.

Exceptions

Exception Type | Condition
ArgumentException | is thrown if the object is a non-null reference that is not of type Decimal.

Remarks

The Decimal values are compared in the canonical way. As a special case, an instance, regardless of its value, is considered to be greater than a null reference.

The value parameter must be either a Decimal type or a null reference.

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.Divide

Divides two specified Decimal values.

[Visual Basic]
Public Shared Function Divide( _
   ByVal d1 As Decimal, _
   ByVal d2 As Decimal _
) As Decimal
[C#]
public static Decimal Divide(
   Decimal d1,
   Decimal d2
);
[C++]
public: static Decimal Divide(
   Decimal d1,
   Decimal d2
);
[JScript]
public static function Divide(
   d1 : Decimal,
   d2 : Decimal
) : Decimal;

Parameters

d1
The left operand (the dividend), a Decimal.
d2
The right operand (the divisor), a Decimal.

Return Value

The value that is the result of the division.

Exceptions

Exception Type | Condition
DivideByZeroException | If the dividend is zero.
OverflowException | If the quotient is too large to represent as a Decimal.

Remarks

The Divide method divides two decimal values, the dividend by the divisor (d1/ d2) to get the quotient.

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.Equals

Determines whether two values are equal.

Overload List

Determines whether this instance is equal to a specified Object.

[Visual Basic] Overloads Overrides Public Function Equals(Object) As Boolean
[C#] public override bool Equals(Object);
[C++] public: override bool Equals(Object*);
[JScript] public override function Equals(Object) : Boolean;

Compares two Decimal values for equality.

[Visual Basic] Overloads Public Shared Function Equals(Decimal, Decimal) As Boolean
[C#] public static bool Equals(Decimal, Decimal);
[C++] public: static bool Equals(Decimal, Decimal);
[JScript] public static function Equals(Decimal, Decimal) : Boolean;

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.Equals (Object)

Determines whether this instance is equal to a specified Object.

[Visual Basic]
Overloads Overrides Public Function Equals( _
   ByVal value As Object _
) As Boolean
[C#]
public override bool Equals(
   object value
);
[C++]
public: override bool Equals(
   Object* value
);
[JScript]
public override function Equals(
   value : Object
) : Boolean;

Parameters

value
An object to compare with this instance of Decimal.

Return Value

true if the given object is equal to this instance of Decimal, otherwise false.

Remarks

The Equals method compares a specified object with this instance of a Decimal value to determine whether they are equal and returns a Boolean value concerning their relationship.

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal.Equals Overload List


Decimal.Equals (Decimal, Decimal)

Compares two Decimal values for equality.

[Visual Basic]
Overloads Public Shared Function Equals( _
   ByVal d1 As Decimal, _
   ByVal d2 As Decimal _
) As Boolean
[C#]
public static bool Equals(
   Decimal d1,
   Decimal d2
);
[C++]
public: static bool Equals(
   Decimal d1,
   Decimal d2
);
[JScript]
public static function Equals(
   d1 : Decimal,
   d2 : Decimal
) : Boolean;

Parameters

d1
The left operand, a Decimal.
d2
The right operand, a Decimal.

Return Value

true if the two Decimal values are equal, otherwise false.

Remarks

The Equals method compares two Decimal values to determine whether they are equal and returns a Boolean value concerning their relationship.

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal.Equals Overload List


Decimal.Floor

Rounds a Decimal down to the next lower whole number value.

[Visual Basic]
Public Shared Function Floor( _
   ByVal d As Decimal _
) As Decimal
[C#]
public static Decimal Floor(
   Decimal d
);
[C++]
public: static Decimal Floor(
   Decimal d
);
[JScript]
public static function Floor(
   d : Decimal
) : Decimal;

Parameters

d
The Decimal to truncate.

Return Value

The Decimal argument rounded toward negative infinity to the next lower whole number value.

Remarks

The Floor method is used to truncate the Decimal value by rounding to the next lower whole number. (For more information, see Truncate.)

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.Format

Converts a numeric value to a String.

Overload List

Converts a numeric value to a String string with the default format.

[Visual Basic] Overloads Public Shared Function Format(Decimal, String) As String
[C#] public static string Format(Decimal, String);
[C++] public: static String* Format(Decimal, String);
[JScript] public static function Format(Decimal, String) : String;

Converts the value of this instance to a String with the format provided by TBD.

[Visual Basic] Overloads Overridable Public Function Format(String, IServiceObjectProvider) As String
[C#] public virtual string Format(String, IServiceObjectProvider);
[C++] public: virtual String* Format(String*, IServiceObjectProvider);
[JScript] public function Format(String, IServiceObjectProvider) : String;

Converts a numeric value to a String with the specified format string.

[Visual Basic] Overloads Public Shared Function Format(Decimal, String, NumberFormatInfo) As String
[C#] public static string Format(Decimal, String, NumberFormatInfo);
[C++] public: static String* Format(Decimal, String, NumberFormatInfo);
[JScript] public static function Format(Decimal, String, NumberFormatInfo) : String;

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.Format (Decimal, String)

Converts a numeric value to a String string with the default format.

[Visual Basic]
Overloads Public Shared Function Format( _
   ByVal value As Decimal, _
   ByVal format As String _
) As String
[C#]
public static string Format(
   Decimal value,
   string format
);
[C++]
public: static String* Format(
   Decimal value,
   String* format
);
[JScript]
public static function Format(
   value : Decimal,
   format : String
) : String;

Parameters

value
The Decimal to be formatted.
format
The format string.

Return Value

A String representation of the Decimal in the default format.

Remarks

If format is null or an empty string, value is formatted as if the string general ("G") format were specified. The numeric format information is obtained from the current locale. (For addition information on current cultures, see CultureInfo.)

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal.Format Overload List


Decimal.Format (String, IServiceObjectProvider)

Converts the value of this instance to a String with the format provided by TBD.

[Visual Basic]
Overloads Overridable Public Function Format( _
   ByVal format As String, _
   ByVal sp As IServiceObjectProvider _
) As String
[C#]
public virtual string Format(
   string format,
   IServiceObjectProvider sp
);
[C++]
public: virtual String* Format(
   String* format,
   IServiceObjectProvider* sp
);
[JScript]
public function Format(
   format : String,
   sp : IServiceObjectProvider
) : String;

Parameters

format
[To be supplied.]
sp
[To be supplied.]

Return Value

A String representation for the value of this instance in the format specified by the string.

Remarks

If format is null or an empty string, the number is formatted as if the string general ("G") format were specified.

If sp is null, the numeric format information is obtained from the current locale.

The sp parameter specifies the format provider from which the NumberFormatInfo instance will be obtained. NumberFormatInfo supplies information such as the characters to use for decimal and thousand separators, and the spelling and placement of currency symbols in monetary values.

(For additional information on currency symbols and current cultures, see CultureInfo.)

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal.Format Overload List


Decimal.Format (Decimal, String, NumberFormatInfo)

Converts a numeric value to a String with the specified format string.

[Visual Basic]
Overloads Public Shared Function Format( _
   ByVal value As Decimal, _
   ByVal format As String, _
   ByVal info As NumberFormatInfo _
) As String
[C#]
public static string Format(
   Decimal value,
   string format,
   NumberFormatInfo info
);
[C++]
public: static String* Format(
   Decimal value,
   String* format,
   NumberFormatInfo* info
);
[JScript]
public static function Format(
   value : Decimal,
   format : String,
   info : NumberFormatInfo
) : String;

Parameters

value
The Decimal to be formatted.
format
The format string.
info
The NumberFormatInfo instance used to format the number.

Return Value

The String representation of the Decimal in the specified format.

Remarks

If format is null or an empty string, value is formatted as if the string general ("G") format were specified.

If info is null, the numeric format information is obtained from the current locale.

The info parameter specifies the NumberFormatInfo instance used to format the number. The NumberFormatInfo supplies information such as the characters to use for decimal and thousand separators, and the spelling and placement of currency symbols in monetary values.

(For additional information on currency symbols and current cultures, see CultureInfo.)

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal.Format Overload List


Decimal.FromString

Converts a string to a Decimal.

[Visual Basic]
Public Shared Function FromString( _
   ByVal s As String _
) As Decimal
[C#]
public static Decimal FromString(
   string s
);
[C++]
public: static Decimal FromString(
   String* s
);
[JScript]
public static function FromString(
   s : String
) : Decimal;

Parameters

s
The string to convert to a Decimal.

Return Value

The Decimal value of the string.

Remarks

Converts a string to a Decimal. The string must consist of an optional minus sign ("-") followed by a sequence of digits ("0"- "9"). The sequence of digits may optionally contain a single decimal point (".") character. (For related information, see Parse.)

Leading and trailing white space characters are allowed.

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.GetBits

Returns a binary representation of a Decimal.

[Visual Basic]
Public Shared Function GetBits( _
   ByVal d As Decimal _
) As Integer ()
[C#]
public static int[] GetBits(
   Decimal d
);
[C++]
public: static int* GetBits(
   Decimal d
) [];
[JScript]
public static function GetBits(
   d : Decimal
) : int[];

Parameters

d
A Decimal value.

Return Value

An integer array with four elements that contain the binary representation of the argument.

Remarks

The GetBits method retrieves a binary representation of the specified Decimal. The returned array has 4 elements.

Elements 0, 1, and 2 contain the low, middle, and high 32-bits of the 96-bit integer part of the Decimal.

Element 3 contains the scale factor and sign of the Decimal:

Bits 0-15 (the lower word) are unused.

Bits 16-23 contain a value between 0 and 28, indicating the power of 10 to divide the 96-bit integer part by to produce the Decimal value.

Bits 24-30 are unused.

Bit 31 indicates the sign of the Decimal value: 0 meaning positive and 1 meaning negative.

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.GetHashCode

Returns the hash code for this Decimal.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

The hash code of this Decimal.

Remarks

The GetHashCode method returns the absolute value of value of this instance. It overrides System.Value.GetHashCode.

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.GetTypeCode

Returns the hash code for this instance of Decimal.

[Visual Basic]
Overridable Public Function GetTypeCode() As TypeCode
[C#]
public virtual TypeCode GetTypeCode();
[C++]
public: virtual TypeCode GetTypeCode();
[JScript]
public function GetTypeCode() : TypeCode;

Return Value

true if the value of this instance is true, otherwise false.

Remarks

The GetTypeCode method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See the TypeCode enumeration for more information about type codes.)

This method corresponds to Value.GetTypeCode.

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.Max

Returns the larger of two Decimal values.

[Visual Basic]
Public Shared Function Max( _
   ByVal d1 As Decimal, _
   ByVal d2 As Decimal _
) As Decimal
[C#]
public static Decimal Max(
   Decimal d1,
   Decimal d2
);
[C++]
public: static Decimal Max(
   Decimal d1,
   Decimal d2
);
[JScript]
public static function Max(
   d1 : Decimal,
   d2 : Decimal
) : Decimal;

Parameters

d1
The first Decimal.
d2
The second Decimal.

Return Value

The larger of the two Decimal arguments.

Remarks

The Max method compares two Decimal values and returns the larger of the two arguments by using the following:

Compare(d1, d2) >= 0? d1: d2;

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.Min

Returns the smaller of two Decimal values.

[Visual Basic]
Public Shared Function Min( _
   ByVal d1 As Decimal, _
   ByVal d2 As Decimal _
) As Decimal
[C#]
public static Decimal Min(
   Decimal d1,
   Decimal d2
);
[C++]
public: static Decimal Min(
   Decimal d1,
   Decimal d2
);
[JScript]
public static function Min(
   d1 : Decimal,
   d2 : Decimal
) : Decimal;

Parameters

d1
The first Decimal.
d2
The second Decimal.

Return Value

The smaller of the two Decimal arguments.

Remarks

The Min method compares two Decimal values and returns the smaller of the two arguments by using the following:

Compare(d1, d2) < 0? d1: d2;

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.Mod

Returns the remainder from dividing two Decimal values.

[Visual Basic]
Public Shared Function Mod( _
   ByVal d1 As Decimal, _
   ByVal d2 As Decimal _
) As Decimal
[C#]
public static Decimal Mod(
   Decimal d1,
   Decimal d2
);
[C++]
public: static Decimal Mod(
   Decimal d1,
   Decimal d2
);
[JScript]
public static function Mod(
   d1 : Decimal,
   d2 : Decimal
) : Decimal;

Parameters

d1
The first Decimal (the dividend).
d2
The second Decimal (the divisor).

Return Value

The result's of evaluating the two Decimal values.

Exceptions

Exception Type | Condition
DivideByZeroException | If the divisor is zero.
OverflowException | If the result is too large to represent as a Decimal.

Remarks

The Mod method divides two Decimal values and returns the remainder.

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.Multiply

Divides two Decimal values and produces a Decimal result.

[Visual Basic]
Public Shared Function Multiply( _
   ByVal d1 As Decimal, _
   ByVal d2 As Decimal _
) As Decimal
[C#]
public static Decimal Multiply(
   Decimal d1,
   Decimal d2
);
[C++]
public: static Decimal Multiply(
   Decimal d1,
   Decimal d2
);
[JScript]
public static function Multiply(
   d1 : Decimal,
   d2 : Decimal
) : Decimal;

Parameters

d1
The left operand.
d2
The right operand.

Return Value

The result of multiplying two Decimal values.

Exceptions

Exception Type | Condition
OverflowException | is thrown if the result is too large to represent as a Decimal.

Remarks

The Multiply method performs the arithmetic multiplication operation evaluating two Decimal values (d1 * d2) and returns the results.

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.Negate

Returns the negated value of the specified Decimal.

[Visual Basic]
Public Shared Function Negate( _
   ByVal d As Decimal _
) As Decimal
[C#]
public static Decimal Negate(
   Decimal d
);
[C++]
public: static Decimal Negate(
   Decimal d
);
[JScript]
public static function Negate(
   d : Decimal
) : Decimal;

Parameters

d
A Decimal value.

Return Value

The negated value of the argument.

Remarks

The Negate method returns the negative of the specified Decimal value. For example:

If d is non-zero, the result is -d.

If d is zero, the result is zero.

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.Parse

Converts a String to a Decimal.

Overload List

Converts a specified String to a Decimal.

[Visual Basic] Overloads Public Shared Function Parse(String) As Decimal
[C#] public static Decimal Parse(String);
[C++] public: static Decimal Parse(String*);
[JScript] public static function Parse(String) : Decimal;

Converts a String representation of a value to a Decimal.

[Visual Basic] Overloads Public Shared Function Parse(String, NumberStyles) As Decimal
[C#] public static Decimal Parse(String, NumberStyles);
[C++] public: static Decimal Parse(String*, NumberStyles);
[JScript] public static function Parse(String, NumberStyles) : Decimal;

Converts a String representation of a value to a Decimal.

[Visual Basic] Overloads Public Shared Function Parse(String, NumberStyles, NumberFormatInfo) As Decimal
[C#] public static Decimal Parse(String, NumberStyles, NumberFormatInfo);
[C++] public: static Decimal Parse(String*, NumberStyles, NumberFormatInfo);
[JScript] public static function Parse(String, NumberStyles, NumberFormatInfo) : Decimal;

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.Parse (String)

Converts a specified String to a Decimal.

[Visual Basic]
Overloads Public Shared Function Parse( _
   ByVal s As String _
) As Decimal
[C#]
public static Decimal Parse(
   string s
);
[C++]
public: static Decimal Parse(
   String* s
);
[JScript]
public static function Parse(
   s : String
) : Decimal;

Parameters

s
The string to convert to a Decimal.

Return Value

The Decimal value of the string.

Exceptions

Exception Type | Condition
FormatException | If the string is not of the correct format.
OverflowException | If the string represents a number that is less than Decimal.MinValue or greater than Decimal.MaxValue.

Remarks

The string must consist of an optional minus sign ("-") followed by a sequence of digits ("0"- "9"). The sequence of digits may optionally contain a single decimal point (".") character.

Leading and trailing white space characters are ignored.

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal.Parse Overload List


Decimal.Parse (String, NumberStyles)

Converts a String representation of a value to a Decimal.

[Visual Basic]
Overloads Public Shared Function Parse( _
   ByVal s As String, _
   ByVal style As NumberStyles _
) As Decimal
[C#]
public static Decimal Parse(
   string s,
   NumberStyles style
);
[C++]
public: static Decimal Parse(
   String* s,
   NumberStyles style
);
[JScript]
public static function Parse(
   s : String,
   style : NumberStyles
) : Decimal;

Parameters

s
The String to convert to a Decimal.
style
The permitted style of the numeric string.

Return Value

A Decimal with the value represented by s.

Exceptions

Exception Type | Condition
ArgumentException | If the string is null.
ArgumentException | If the style is not a combination of bit flags from the NumberStyles enumeration.
FormatException | If the string is not of the correct format.
OverflowException | If the string represents a number that is less than Decimal.MinValue or greater than Decimal.MaxValue.

Remarks

Note that the Parse methods do not accept positive or negative infinity or NaN.

If s has been created by one of the Format methods using C, D, E, F, G, or N as the format specifier, it is guaranteed that s can be parsed when style is TBD.

The style parameter specifies the permitted style of the numeric string. It must be a combination of bit flags from the cpclaSystem.NumberStylesEnumeration enumeration. The numeric format information is obtained from the current locale.

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal.Parse Overload List


Decimal.Parse (String, NumberStyles, NumberFormatInfo)

Converts a String representation of a value to a Decimal.

[Visual Basic]
Overloads Public Shared Function Parse( _
   ByVal s As String, _
   ByVal style As NumberStyles, _
   ByVal info As NumberFormatInfo _
) As Decimal
[C#]
public static Decimal Parse(
   string s,
   NumberStyles style,
   NumberFormatInfo info
);
[C++]
public: static Decimal Parse(
   String* s,
   NumberStyles style,
   NumberFormatInfo* info
);
[JScript]
public static function Parse(
   s : String,
   style : NumberStyles,
   info : NumberFormatInfo
) : Decimal;

Parameters

s
The String to convert a Decimal.
style
The permitted style of the numeric string.
info
The NumberFormatInfo instance used to format the string.

Return Value

A Decimal with the value represented by s.

Exceptions

Exception Type | Condition
ArgumentException | If the string is null.
ArgumentException | If the style is not a combination of bit flags from the NumberStyles enumeration.
FormatException | If the string is not of the correct format.
OverflowException | If the string represents a number that is less than Decimal.MinValue or greater than Decimal.MaxValue.

Remarks

Note that the Parse methods do not accept positive or negative infinity or NaN.

If s has been created by one of the Format methods using C, D, E, F, G, or N as the format specifier, it is guaranteed that s can be parsed when style is TBD.

style must be a combination of bit flags from the cpclaSystem.NumberStylesEnumeration enumeration.

The info parameter specifies the cpclaSystem.NumberFormatInfoClassinstance used to format the string. If the info parameter is null, the numeric format information is obtained from the current locale.

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal.Parse Overload List


Decimal.Round

Rounds a Decimal value to a specified number of decimal places.

[Visual Basic]
Public Shared Function Round( _
   ByVal d As Decimal, _
   ByVal decimals As Integer _
) As Decimal
[C#]
public static Decimal Round(
   Decimal d,
   int decimals
);
[C++]
public: static Decimal Round(
   Decimal d,
   int decimals
);
[JScript]
public static function Round(
   d : Decimal,
   decimals : int
) : Decimal;

Parameters

d
The Decimal value to round.
decimals
The number of decimal places to round to; it must be between 0 and 28, inclusive.

Return Value

The value specified by d rounded to the number of decimal places specified by the number of decimal places.

Exceptions

Exception Type | Condition
ArgumentException | is thrown if the number of decimal places are not between 0 and 28, inclusive.

Remarks

The operation Round conceptually corresponds to evaluating Truncate.

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.Subtract

Subtracts two specified Decimal values.

[Visual Basic]
Public Shared Function Subtract( _
   ByVal d1 As Decimal, _
   ByVal d2 As Decimal _
) As Decimal
[C#]
public static Decimal Subtract(
   Decimal d1,
   Decimal d2
);
[C++]
public: static Decimal Subtract(
   Decimal d1,
   Decimal d2
);
[JScript]
public static function Subtract(
   d1 : Decimal,
   d2 : Decimal
) : Decimal;

Parameters

d1
The left operand, a Decimal.
d2
The right operand, a Decimal.

Return Value

The result of subtracting two Decimal values.

Exceptions

Exception Type | Condition
OverflowException | is thrown if result is too large to represent as a Decimal.

Remarks

The method result's of evaluating the first decimal minus the second decimal.

The Subtaction method performs an arithmetic function by subtracting two Decimal values (d1- d) and returns the result of the operation.

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.ToBoolean

Converts a string to a Decimal value.

[Visual Basic]
Overridable Public Function ToBoolean() As Boolean
[C#]
public virtual bool ToBoolean();
[C++]
public: virtual bool ToBoolean();
[JScript]
public function ToBoolean() : Boolean;

Return Value

false if the number to be converted is 0, otherwise true.

Remarks

The ToBoolean method converts the "true" or "false" Boolean values to the Boolean values of true and false.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.ToByte

Converts a Decimal to an unsigned Byte.

Overload List

Converts a Decimal to an unsigned Byte.

[Visual Basic] Overloads Overridable Public Function ToByte() As Byte
[C#] public virtual byte ToByte();
[C++] public: virtual unsigned char ToByte();
[JScript] public function ToByte() : Byte;

Converts a Decimal to an unsigned Byte.

[Visual Basic] Overloads Public Shared Function ToByte(Decimal) As Byte
[C#] public static byte ToByte(Decimal);
[C++] public: static unsigned char ToByte(Decimal);
[JScript] public static function ToByte(Decimal) : Byte;

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.ToByte ()

Converts a Decimal to an unsigned Byte.

[Visual Basic]
Overloads Overridable Public Function ToByte() As Byte
[C#]
public virtual byte ToByte();
[C++]
public: virtual unsigned char ToByte();
[JScript]
public function ToByte() : Byte;

Return Value

The result of converting the argument to an unsigned byte.

Exceptions

Exception Type | Condition
OverflowException | is thrown if the resulting integer value is less than Byte.MinValue or greater than Byte.MaxValue.

Remarks

The Decimal value is rounded toward zero to the nearest integer value, and the result of this operation is returned as a byte.

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal.ToByte Overload List


Decimal.ToByte (Decimal)

Converts a Decimal to an unsigned Byte.

[Visual Basic]
Overloads Public Shared Function ToByte( _
   ByVal value As Decimal _
) As Byte
[C#]
public static byte ToByte(
   Decimal value
);
[C++]
public: static unsigned char ToByte(
   Decimal value
);
[JScript]
public static function ToByte(
   value : Decimal
) : Byte;

Parameters

value
The Decimal value to convert.

Return Value

The result of converting the argument to an unsigned byte.

Exceptions

Exception Type | Condition
OverflowException | is thrown if the resulting integer value is less than Byte.MinValue or greater than Byte.MaxValue.

Remarks

The Decimal value is rounded toward zero to the nearest integer value, and the result of this operation is returned as a byte.

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal.ToByte Overload List


Decimal.ToChar

Converts a Decimal to a character.

[Visual Basic]
Overridable Public Function ToChar() As Char
[C#]
public virtual char ToChar();
[C++]
public: virtual __wchar_t ToChar();
[JScript]
public function ToChar() : Char;

Return Value

The Decimal value as a character.

Remarks

The ToChar method returns a character.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.ToCurrency

Converts a Decimal to a Currency.

[Visual Basic]
Public Shared Function ToCurrency( _
   ByVal d As Decimal _
) As Currency
[C#]
public static Currency ToCurrency(
   Decimal d
);
[C++]
public: static Currency ToCurrency(
   Decimal d
);
[JScript]
public static function ToCurrency(
   d : Decimal
) : Currency;

Parameters

d
A Decimal value to convert.

Return Value

The results of converting the argument to a Currency.

Exceptions

Exception Type | Condition
OverflowException | is thrown if the Decimal is less than Decimal.MinValue or greater than Decimal.MaxValue.

Remarks

The ToCurrency method converts a currency value to a Decimal value. Since a Currency has fewer significant digits than a Decimal, this operation may produce round-off errors.

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.ToDateTime

Converts this instance of a Decimal to a DateTime object.

[Visual Basic]
Overridable Public Function ToDateTime() As DateTime
[C#]
public virtual DateTime ToDateTime();
[C++]
public: virtual DateTime ToDateTime();
[JScript]
public function ToDateTime() : DateTime;

Return Value

A DateTime.

Exceptions

Exception Type | Condition
InvalidCastException | is thrown if it doesn't return a DateTime.

Remarks

The ToDateTime method returns a DateTime.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.ToDecimal

Converts this instance of a Decimal to a Decimal format.

[Visual Basic]
Overridable Public Function ToDecimal() As Decimal
[C#]
public virtual Decimal ToDecimal();
[C++]
public: virtual Decimal ToDecimal();
[JScript]
public function ToDecimal() : Decimal;

Return Value

A Decimal.

Exceptions

Exception Type | Condition
InvalidCastException | is thrown if it doesn't return a Decimal.

Remarks

The ToDecimal method returns a decimal.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.ToDouble

Converts a Decimal to a Double.

Overload List

Converts a Decimal to a Double with a specified format.

[Visual Basic] Overloads Public Shared Function ToDouble(Decimal) As Double
[C#] public static double ToDouble(Decimal);
[C++] public: static double ToDouble(Decimal);
[JScript] public static function ToDouble(Decimal) : double;

Converts a Decimal to a Double with a default format.

[Visual Basic] Overloads Overridable Public Function ToDouble() As Double
[C#] public virtual double ToDouble();
[C++] public: virtual double ToDouble();
[JScript] public function ToDouble() : double;

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.ToDouble (Decimal)

Converts a Decimal to a Double with a specified format.

[Visual Basic]
Overloads Public Shared Function ToDouble( _
   ByVal d As Decimal _
) As Double
[C#]
public static double ToDouble(
   Decimal d
);
[C++]
public: static double ToDouble(
   Decimal d
);
[JScript]
public static function ToDouble(
   d : Decimal
) : double;

Parameters

d
The Decimal value to convert.

Return Value

The result of converting the argument to a Double.

Remarks

The ToDouble method returns the specified parameter as an 8-byte double precision floating-point number.

Since a Double has fewer significant digits than a Decimal, this operation may produce round-off errors.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal.ToDouble Overload List


Decimal.ToDouble ()

Converts a Decimal to a Double with a default format.

[Visual Basic]
Overloads Overridable Public Function ToDouble() As Double
[C#]
public virtual double ToDouble();
[C++]
public: virtual double ToDouble();
[JScript]
public function ToDouble() : double;

Return Value

The result of converting the argument to a Double.

Exceptions

Exception Type | Condition
InvalidCastException | is thrown if it doesn't return a Decimal.

Remarks

The ToDouble method returns the specified parameter as an 8-byte double precision floating-point number.

Since a Double has fewer significant digits than a Decimal, this operation may produce round-off errors.

This method implements IConvertible, which replaced IValue. This methodis used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal.ToDouble Overload List


Decimal.ToInt16

Converts a Decimal to an Int16.

Overload List

Converts a Decimal to an Int16 with a specified format.

[Visual Basic] Overloads Public Shared Function ToInt16(Decimal) As Short
[C#] public static short ToInt16(Decimal);
[C++] public: static short ToInt16(Decimal);
[JScript] public static function ToInt16(Decimal) : Int16;

Converts a Decimal to an Int16 with the default format.

[Visual Basic] Overloads Overridable Public Function ToInt16() As Short
[C#] public virtual short ToInt16();
[C++] public: virtual short ToInt16();
[JScript] public function ToInt16() : Int16;

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.ToInt16 (Decimal)

Converts a Decimal to an Int16 with a specified format.

[Visual Basic]
Overloads Public Shared Function ToInt16( _
   ByVal value As Decimal _
) As Short
[C#]
public static short ToInt16(
   Decimal value
);
[C++]
public: static short ToInt16(
   Decimal value
);
[JScript]
public static function ToInt16(
   value : Decimal
) : Int16;

Parameters

value
The Decimal value to convert.

Return Value

The result's of converting the argument to a short.

Exceptions

Exception Type | Condition
OverflowException | is thrown if the resulting integer value is less than Int16.MinValue or greater than Int16.MaxValue.

Remarks

The ToInt16 method returns a short. The Decimal value is rounded toward zero to the nearest integer value, and the result of this operation is returned as a short.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal.ToInt16 Overload List


Decimal.ToInt16 ()

Converts a Decimal to an Int16 with the default format.

[Visual Basic]
Overloads Overridable Public Function ToInt16() As Short
[C#]
public virtual short ToInt16();
[C++]
public: virtual short ToInt16();
[JScript]
public function ToInt16() : Int16;

Return Value

The result's of converting the argument to a short.

Exceptions

Exception Type | Condition
OverflowException | is thrown if the resulting integer value is less than Int16.MinValue or greater than Int16.MaxValue.

Remarks

The ToInt16 method returns a short. The Decimal value is rounded toward zero to the nearest integer value, and the result of this operation is returned as a short.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal.ToInt16 Overload List


Decimal.ToInt32

Converts a Decimal to an Int32.

Overload List

Converts a Decimal to an Int32 with a specified format.

[Visual Basic] Overloads Public Shared Function ToInt32(Decimal) As Integer
[C#] public static int ToInt32(Decimal);
[C++] public: static int ToInt32(Decimal);
[JScript] public static function ToInt32(Decimal) : int;

Converts a Decimal to an Int32 with the default format.

[Visual Basic] Overloads Overridable Public Function ToInt32() As Integer
[C#] public virtual int ToInt32();
[C++] public: virtual int ToInt32();
[JScript] public function ToInt32() : int;

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.ToInt32 (Decimal)

Converts a Decimal to an Int32 with a specified format.

[Visual Basic]
Overloads Public Shared Function ToInt32( _
   ByVal d As Decimal _
) As Integer
[C#]
public static int ToInt32(
   Decimal d
);
[C++]
public: static int ToInt32(
   Decimal d
);
[JScript]
public static function ToInt32(
   d : Decimal
) : int;

Parameters

d
The Decimal value to convert.

Return Value

The result's of converting the argument to an integer.

Exceptions

Exception Type | Condition
OverflowException | is thrown if the resulting integer value is less than Int32.MinValue or greater than Int32.MaxValue.

Remarks

The ToInt32 method returns an int. It returns a 32-bit, 4-byte signed integer with the converted number.

The Decimal value is rounded toward zero to the nearest integer value, and the result of this operation is returned as an integer.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal.ToInt32 Overload List


Decimal.ToInt32 ()

Converts a Decimal to an Int32 with the default format.

[Visual Basic]
Overloads Overridable Public Function ToInt32() As Integer
[C#]
public virtual int ToInt32();
[C++]
public: virtual int ToInt32();
[JScript]
public function ToInt32() : int;

Return Value

The result's of converting the argument to an integer.

Exceptions

Exception Type | Condition
OverflowException | is thrown if the resulting integer value is less than Int32.MinValue or greater than Int32.MaxValue.

Remarks

The ToInt32 method returns an int. It returns a 32-bit, 4-byte signed integer with the converted number.

The Decimal value is rounded toward zero to the nearest integer value, and the result of this operation is returned as an integer.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal.ToInt32 Overload List


Decimal.ToInt64

Converts a Decimal to an Int64.

Overload List

Converts a Decimal to an Int64 with a specified format.

[Visual Basic] Overloads Public Shared Function ToInt64(Decimal) As Long
[C#] public static long ToInt64(Decimal);
[C++] public: static __int64 ToInt64(Decimal);
[JScript] public static function ToInt64(Decimal) : long;

Converts a Decimal to an Int64 with the default format.

[Visual Basic] Overloads Overridable Public Function ToInt64() As Long
[C#] public virtual long ToInt64();
[C++] public: virtual __int64 ToInt64();
[JScript] public function ToInt64() : long;

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.ToInt64 (Decimal)

Converts a Decimal to an Int64 with a specified format.

[Visual Basic]
Overloads Public Shared Function ToInt64( _
   ByVal d As Decimal _
) As Long
[C#]
public static long ToInt64(
   Decimal d
);
[C++]
public: static __int64 ToInt64(
   Decimal d
);
[JScript]
public static function ToInt64(
   d : Decimal
) : long;

Parameters

d
The Decimal value to convert.

Return Value

The result's of converting the argument to a long.

Exceptions

Exception Type | Condition
OverflowException | is thrown if d is less than Int64.MinValue or greater than Int64.MaxValue.

Remarks

The ToInt64 method returns a long. It returns a 64-bit, 8-byte signed integer with the converted number.

The Decimal value is rounded toward zero to the nearest integer value, and the result of this operation is returned as a long.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal.ToInt64 Overload List


Decimal.ToInt64 ()

Converts a Decimal to an Int64 with the default format.

[Visual Basic]
Overloads Overridable Public Function ToInt64() As Long
[C#]
public virtual long ToInt64();
[C++]
public: virtual __int64 ToInt64();
[JScript]
public function ToInt64() : long;

Return Value

The result's of converting the argument to a long.

Exceptions

Exception Type | Condition
OverflowException | is thrown if d is less than Int64.MinValue or greater than Int64.MaxValue.

Remarks

The ToInt64 method returns a long. It returns a 64-bit, 8-byte signed integer with the converted number.

The Decimal value is rounded toward zero to the nearest integer value, and the result of this operation is returned as a long.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal.ToInt64 Overload List


Decimal.ToSByte

Converts a Decimal to an SByte.

Overload List

Converts a Decimal to an SByte with the default format.

[Visual Basic] Overloads Overridable Public Function ToSByte() As SByte
[C#] public virtual sbyte ToSByte();
[C++] public: virtual char ToSByte();
[JScript] public function ToSByte() : SByte;

Converts a Decimal to a, SByte with a specified format.

[Visual Basic] Overloads Public Shared Function ToSByte(Decimal) As SByte
[C#] public static sbyte ToSByte(Decimal);
[C++] public: static char ToSByte(Decimal);
[JScript] public static function ToSByte(Decimal) : SByte;

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.ToSByte ()

Converts a Decimal to an SByte with the default format.

[Visual Basic]
Overloads Overridable Public Function ToSByte() As SByte
[C#]
public virtual sbyte ToSByte();
[C++]
public: virtual char ToSByte();
[JScript]
public function ToSByte() : SByte;

Return Value

The Decimal value converted to an SByte.

Exceptions

Exception Type | Condition
OverflowException | is thrown if the resulting integer value is less than SByte.MinValue or greater than SByte.MaxValue.

Remarks

The ToSByte method returns an unsigned byte. The Decimal value is rounded toward zero to the nearest integer value and converted to an SByte.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal.ToSByte Overload List


Decimal.ToSByte (Decimal)

Converts a Decimal to a, SByte with a specified format.

[Visual Basic]
Overloads Public Shared Function ToSByte( _
   ByVal value As Decimal _
) As SByte
[C#]
public static sbyte ToSByte(
   Decimal value
);
[C++]
public: static char ToSByte(
   Decimal value
);
[JScript]
public static function ToSByte(
   value : Decimal
) : SByte;

Parameters

value
A Decimal value.

Return Value

The Decimal value converted to an SByte.

Exceptions

Exception Type | Condition
OverflowException | is thrown if the resulting integer value is less than SByte.MinValue or greater than SByte.MaxValue.

Remarks

The ToSByte method returns an unsigned byte. The Decimal value is rounded toward zero to the nearest integer value and converted to an SByte.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal.ToSByte Overload List


Decimal.ToSingle

Converts a Decimal to a Single.

Overload List

Converts a Decimal to a Single with a specified format.

[Visual Basic] Overloads Public Shared Function ToSingle(Decimal) As Single
[C#] public static float ToSingle(Decimal);
[C++] public: static float ToSingle(Decimal);
[JScript] public static function ToSingle(Decimal) : float;

Converts a Decimal to a Single with the default format.

[Visual Basic] Overloads Overridable Public Function ToSingle() As Single
[C#] public virtual float ToSingle();
[C++] public: virtual float ToSingle();
[JScript] public function ToSingle() : float;

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.ToSingle (Decimal)

Converts a Decimal to a Single with a specified format.

[Visual Basic]
Overloads Public Shared Function ToSingle( _
   ByVal d As Decimal _
) As Single
[C#]
public static float ToSingle(
   Decimal d
);
[C++]
public: static float ToSingle(
   Decimal d
);
[JScript]
public static function ToSingle(
   d : Decimal
) : float;

Parameters

d
The Decimal value to convert.

Return Value

The result's of converting the argument to a Single.

Remarks

The ToSingle method returns the specified parameter as a float number. Since a Single has fewer significant digits than a Decimal, this operation may produce round-off errors.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal.ToSingle Overload List


Decimal.ToSingle ()

Converts a Decimal to a Single with the default format.

[Visual Basic]
Overloads Overridable Public Function ToSingle() As Single
[C#]
public virtual float ToSingle();
[C++]
public: virtual float ToSingle();
[JScript]
public function ToSingle() : float;

Return Value

The result's of converting the argument to a Single.

Remarks

The ToSingle method returns the specified parameter as a float number. Since a Single has fewer significant digits than a Decimal, this operation may produce round-off errors.

This method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See Convert and Value for more information about conversions; see the Type for more information about types.)

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal.ToSingle Overload List


Decimal.ToString

[To be supplied.]

Overload List

Converts this instance of Decimal to a String.

[Visual Basic] Overloads Overrides Public Function ToString() As String
[C#] public override string ToString();
[C++] public: override String* ToString();
[JScript] public override function ToString() : String;

Converts a specified Decimal to a String

[Visual Basic] Overloads Public Shared Function ToString(Decimal) As String
[C#] public static string ToString(Decimal);
[C++] public: static String* ToString(Decimal);
[JScript] public static function ToString(Decimal) : String;

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.ToString ()

Converts this instance of Decimal to a String.

[Visual Basic]
Overloads Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

The result of converting this Decimal to a String.

Remarks

ToString() provides a string representation for the value of this instance.

No leading zero characters ('0') are prefixed to the returned string and only the following characters are used: 0, 1, 2, 3, 4, 5, 6, 7, 8, and/or 9.

The resulting string consists of an optional minus sign ("-") followed by a sequence of digits ("0"- "9"), optionally followed by a decimal point (".") and another sequence of digits.

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal.ToString Overload List


Decimal.ToString (Decimal)

Converts a specified Decimal to a String

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal d As Decimal _
) As String
[C#]
public static string ToString(
   Decimal d
);
[C++]
public: static String* ToString(
   Decimal d
);
[JScript]
public static function ToString(
   d : Decimal
) : String;

Parameters

d
The Decimal value to convert.

Return Value

The result's of converting the argument to a String.

Remarks

ToString provides a string representation for the value of this instance.

No leading zero characters ('0') are prefixed to the returned string and only the following characters are used: 0, 1, 2, 3, 4, 5, 6, 7, 8, and/or 9.

The resulting string consists of an optional minus sign ("-") followed by a sequence of digits ("0"- "9"), optionally followed by a decimal point (".") and another sequence of digits.

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal.ToString Overload List


Decimal.ToType

Retrieves the Type for a specified Object.

[Visual Basic]
Overridable Public Function ToType( _
   ByVal type As Type _
) As Object
[C#]
public virtual object ToType(
   Type type
);
[C++]
public: virtual Object* ToType(
   Type* type
);
[JScript]
public function ToType(
   type : Type
) : Object;

Parameters

type
The type.

Return Value

The type of the specified object.

Exceptions

Exception Type | Condition
InvalidCastException | is thrown if it doesn't return a type.

Remarks

The ToType method allows a means of reaching the Type class, which provides the functionality of several different services of the runtime, such as accessing the metadata and the Reflection.

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.ToUInt16

[To be supplied.]

Overload List

Converts a specified Decimal to a UInt16.

[Visual Basic] Overloads Public Shared Function ToUInt16(Decimal) As UInt16
[C#] public static ushort ToUInt16(Decimal);
[C++] public: static unsigned short ToUInt16(Decimal);
[JScript] public static function ToUInt16(Decimal) : UInt16;

Converts this instance of Decimal to a UInt16.

[Visual Basic] Overloads Overridable Public Function ToUInt16() As UInt16
[C#] public virtual ushort ToUInt16();
[C++] public: virtual unsigned short ToUInt16();
[JScript] public function ToUInt16() : UInt16;

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.ToUInt16 (Decimal)

Converts a specified Decimal to a UInt16.

[Visual Basic]
Overloads Public Shared Function ToUInt16( _
   ByVal value As Decimal _
) As UInt16
[C#]
public static ushort ToUInt16(
   Decimal value
);
[C++]
public: static unsigned short ToUInt16(
   Decimal value
);
[JScript]
public static function ToUInt16(
   value : Decimal
) : UInt16;

Parameters

value
The Decimal value to convert.

Return Value

The result's of converting the Decimal to a UInt16 value.

Exceptions

Exception Type | Condition
OverflowException | if the resulting integer value is less than UInt16.MinValue or greater than UInt16.MaxValue.

Remarks

The ToUInt16 method converts a Decimal value into a UInt16 and returns it.

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal.ToUInt16 Overload List


Decimal.ToUInt16 ()

Converts this instance of Decimal to a UInt16.

[Visual Basic]
Overloads Overridable Public Function ToUInt16() As UInt16
[C#]
public virtual ushort ToUInt16();
[C++]
public: virtual unsigned short ToUInt16();
[JScript]
public function ToUInt16() : UInt16;

Return Value

The result's of converting the Decimal to a UInt16 value.

Exceptions

Exception Type | Condition
OverflowException | if the resulting integer value is less than UInt16.MinValue or greater than UInt16.MaxValue.

Remarks

The ToUInt16 method converts a Decimal value into a UInt16 and returns it.

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal.ToUInt16 Overload List


Decimal.ToUInt32

[To be supplied.]

Overload List

Converts a specified Decimal to a UInt32.

[Visual Basic] Overloads Public Shared Function ToUInt32(Decimal) As UInt32
[C#] public static uint ToUInt32(Decimal);
[C++] public: static unsigned int ToUInt32(Decimal);
[JScript] public static function ToUInt32(Decimal) : UInt32;

Converts this instance of Decimal to a UInt32.

[Visual Basic] Overloads Overridable Public Function ToUInt32() As UInt32
[C#] public virtual uint ToUInt32();
[C++] public: virtual unsigned int ToUInt32();
[JScript] public function ToUInt32() : UInt32;

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.ToUInt32 (Decimal)

Converts a specified Decimal to a UInt32.

[Visual Basic]
Overloads Public Shared Function ToUInt32( _
   ByVal d As Decimal _
) As UInt32
[C#]
public static uint ToUInt32(
   Decimal d
);
[C++]
public: static unsigned int ToUInt32(
   Decimal d
);
[JScript]
public static function ToUInt32(
   d : Decimal
) : UInt32;

Parameters

d
The Decimal value to convert.

Return Value

The result's of converting the argument to an unsigned integer.

Exceptions

Exception Type | Condition
OverflowException | is thrown if the resulting integer value is less than UInt32.MinValue or greater than UInt32.MaxValue.

Remarks

The ToUInt32method converts a Decimal value into a UInt32 and returns it.

The Decimal value is rounded towards zero to the nearest integer value, and the result of this operation is returned as an unsigned integer.

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal.ToUInt32 Overload List


Decimal.ToUInt32 ()

Converts this instance of Decimal to a UInt32.

[Visual Basic]
Overloads Overridable Public Function ToUInt32() As UInt32
[C#]
public virtual uint ToUInt32();
[C++]
public: virtual unsigned int ToUInt32();
[JScript]
public function ToUInt32() : UInt32;

Return Value

The result's of converting the argument to an unsigned integer.

Exceptions

Exception Type | Condition
OverflowException | is thrown if the resulting integer value is less than UInt32.MinValue or greater than UInt32.MaxValue.

Remarks

The ToUInt32method converts a Decimal value into a UInt32 and returns it.

The Decimal value is rounded towards zero to the nearest integer value, and the result of this operation is returned as an unsigned integer.

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal.ToUInt32 Overload List


Decimal.ToUInt64

[To be supplied.]

Overload List

Converts a specified Decimal to a UInt64.

[Visual Basic] Overloads Public Shared Function ToUInt64(Decimal) As UInt64
[C#] public static ulong ToUInt64(Decimal);
[C++] public: static unsigned __int64 ToUInt64(Decimal);
[JScript] public static function ToUInt64(Decimal) : UInt64;

Converts this instance of Decimal to a UInt64.

[Visual Basic] Overloads Overridable Public Function ToUInt64() As UInt64
[C#] public virtual ulong ToUInt64();
[C++] public: virtual unsigned __int64 ToUInt64();
[JScript] public function ToUInt64() : UInt64;

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.ToUInt64 (Decimal)

Converts a specified Decimal to a UInt64.

[Visual Basic]
Overloads Public Shared Function ToUInt64( _
   ByVal d As Decimal _
) As UInt64
[C#]
public static ulong ToUInt64(
   Decimal d
);
[C++]
public: static unsigned __int64 ToUInt64(
   Decimal d
);
[JScript]
public static function ToUInt64(
   d : Decimal
) : UInt64;

Parameters

d
A Decimal value.

Return Value

The result's of converting the argument to a long (64 bits) unsigned integer.

Exceptions

Exception Type | Condition
OverflowException | is thrown if d is less than UInt64.MinValue or greater than UInt64.MaxValue.

Remarks

The ToUInt64method converts a Decimal value into a UInt64 (ulong) and returns it.

The Decimal value is rounded toward zero to the nearest integer value, and the result of this operation is returned as an unsigned, long integer.

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal.ToUInt64 Overload List


Decimal.ToUInt64 ()

Converts this instance of Decimal to a UInt64.

[Visual Basic]
Overloads Overridable Public Function ToUInt64() As UInt64
[C#]
public virtual ulong ToUInt64();
[C++]
public: virtual unsigned __int64 ToUInt64();
[JScript]
public function ToUInt64() : UInt64;

Return Value

The result's of converting the argument to a long (64 bits) unsigned integer.

Exceptions

Exception Type | Condition
OverflowException | is thrown if d is less than UInt64.MinValue or greater than UInt64.MaxValue.

Remarks

The ToUInt64method converts a Decimal value into a UInt64 (ulong) and returns it.

The Decimal value is rounded toward zero to the nearest integer value, and the result of this operation is returned as an unsigned, long integer.

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal.ToUInt64 Overload List


Decimal.Truncate

Truncates a specified Decimal to an integer value.

[Visual Basic]
Public Shared Function Truncate( _
   ByVal d As Decimal _
) As Decimal
[C#]
public static Decimal Truncate(
   Decimal d
);
[C++]
public: static Decimal Truncate(
   Decimal d
);
[JScript]
public static function Truncate(
   d : Decimal
) : Decimal;

Parameters

d
The Decimal to truncate.

Return Value

The Decimal argument rounded toward zero to the nearest whole number value.

Remarks

The Truncate method performs its function by rounding the Decimal argument toward zero to the nearest whole number value, corresponding to removing all digits after the decimal point.

See Also

Decimal Structure | Decimal Members | System Namespace


Operators and Type Conversions

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Decimal Operators and Type Conversions

The operators and type conversions of the Decimal structure are listed below. For a complete list of Decimal structure members, see the Decimal Members topic.

Public:

Addition Operator | Adds two Decimal values.
Decrement Operator | [To be supplied.]
Division Operator | Divides two Decimal values and returns a Decimal result.
Equality Operator | Determines whether two specified Decimal values are equal.
Greater Than Operator | Determines whether one Decimal value is greater than a specified Decimal.
Greater Than Or Equal Operator | Determines whether one Decimal value is greater than or equal to a specified Decimal.
Increment Operator | [To be supplied.]
Inequality Operator | Determines whether two Decimal values are not equal.
Less Than Operator | Determines whether one Decimal value is less than a specified Decimal.
Less Than Or Equal Operator | Determines whether one Decimal value is less than or equal to a specified Decimal.
Modulus Operator | Determines the remainder from dividing two Decimal values.
Multiplication Operator | Multiplies two Decimal values and produces a Decimal result.
Subtraction Operator | Subtracts two specified Decimal values.
Unary Negation Operator | Decrements the specified number.
Unary Plus Operator | Returns the negated value of the specified Decimal.
Decimal to Double Conversion | [To be supplied.]
Decimal to Single Conversion | [To be supplied.]
Decimal to UInt32 Conversion | [To be supplied.]
Decimal to Int64 Conversion | [To be supplied.]
Decimal to UInt64 Conversion | [To be supplied.]
Single to Decimal Conversion | [To be supplied.]
Decimal to Int16 Conversion | [To be supplied.]
Decimal to Char Conversion | [To be supplied.]
Decimal to Int32 Conversion | [To be supplied.]
Decimal to UInt16 Conversion | [To be supplied.]
Decimal to SByte Conversion | [To be supplied.]
Double to Decimal Conversion | [To be supplied.]
Decimal to Byte Conversion | [To be supplied.]
Byte to Decimal Conversion | Overloaded. [To be supplied.]

See Also

Decimal Structure | System Namespace


Decimal Addition Operator

Adds two Decimal values.

[C#]
public static Decimal operator +(
   Decimal d1,
   Decimal d2
);
[C++]
public: static Decimal operator op_Addition(
   Decimal d1,
   Decimal d2
);
[JScript]
returnValue = d1 + d2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

d1
The left operand, a Decimal.
d2
The right operand, a Decimal.

Parameters [C#, C++]

d1
The left operand, a Decimal.
d2
The right operand, a Decimal.

Return Value [C#, C++, JScript]

The sum of adding two Decimal values.

Exceptions

Exception Type | Condition
OverflowException | if the sum is too large to represent as a Decimal.

Remarks [C#, C++, JScript]

The op_Addition method performs the arithmetic addition operation by adding two Decimal values (d1 + d2)and returns the result.

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal Decrement Operator

[To be supplied.]

[C#]
public static Decimal operator --(
   Decimal d
);
[C++]
public: static Decimal operator op_Decrement(
   Decimal d
);
[JScript]
returnValue = d--;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

d
[To be supplied.]

Parameters [C#, C++]

d
[To be supplied.]

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal Division Operator

Divides two Decimal values and returns a Decimal result.

[C#]
public static Decimal operator /(
   Decimal d1,
   Decimal d2
);
[C++]
public: static Decimal operator op_Division(
   Decimal d1,
   Decimal d2
);
[JScript]
returnValue = d1 / d2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

d1
The left operand (the dividend), a Decimal.
d2
The right operand (the divisor), a Decimal.

Parameters [C#, C++]

d1
The left operand (the dividend), a Decimal.
d2
The right operand (the divisor), a Decimal.

Return Value [C#, C++, JScript]

The Decimal result of dividing the numbers.

Exceptions

Exception Type | Condition
DivideByZeroException | is thrown if the divisor is zero.

Remarks [C#, C++, JScript]

The op_Division method divides two Decimal values and returns the result as a Decimal value.

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal Equality Operator

Determines whether two specified Decimal values are equal.

[C#]
public static bool operator ==(
   Decimal d1,
   Decimal d2
);
[C++]
public: static bool operator op_Equality(
   Decimal d1,
   Decimal d2
);
[JScript]
returnValue = d1 == d2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

d1
The left operand, a Decimal.
d2
The right operand, a Decimal.

Parameters [C#, C++]

d1
The left operand, a Decimal.
d2
The right operand, a Decimal.

Return Value [C#, C++, JScript]

true if the two Decimal numbers have the same value, otherwise false.

Remarks [C#, C++, JScript]

The op_Equality method compares two specified Decimal, determines whether the values are equal (d1 + d), and returns a Boolean result.

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal Greater Than Operator

Determines whether one Decimal value is greater than a specified Decimal.

[C#]
public static bool operator >(
   Decimal d1,
   Decimal d2
);
[C++]
public: static bool operator op_GreaterThan(
   Decimal d1,
   Decimal d2
);
[JScript]
returnValue = d1 > d2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

d1
The first Decimal.
d2
The second Decimal.

Parameters [C#, C++]

d1
The first Decimal.
d2
The second Decimal.

Return Value [C#, C++, JScript]

true if the first Decimal is greater than the second Decimal, otherwise false.

Remarks [C#, C++, JScript]

The op_GreaterThan method determines whether the first DateTime value is greater than the second DateTime value (d1 > d2) and returns a Boolean value that represents their relationship.

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal Greater Than Or Equal Operator

Determines whether one Decimal value is greater than or equal to a specified Decimal.

[C#]
public static bool operator >=(
   Decimal d1,
   Decimal d2
);
[C++]
public: static bool operator op_GreaterThanOrEqual(
   Decimal d1,
   Decimal d2
);
[JScript]
returnValue = d1 >= d2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

d1
The first operand, a Decimal value.
d2
The second operand, a Decimal value.

Parameters [C#, C++]

d1
The first operand, a Decimal value.
d2
The second operand, a Decimal value.

Return Value [C#, C++, JScript]

true if the first Decimal is greater than or equal to the second Decimal, otherwise false.

Remarks [C#, C++, JScript]

The op_GreaterThanOrEqual method determines whether the first Decimal value is greater than or equal to the second Decimal value (d1 >= d2) and returns a Boolean value concerning their relationship.

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal Increment Operator

[To be supplied.]

[C#]
public static Decimal operator ++(
   Decimal d
);
[C++]
public: static Decimal operator op_Increment(
   Decimal d
);
[JScript]
returnValue = d++;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

d
[To be supplied.]

Parameters [C#, C++]

d
[To be supplied.]

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal Inequality Operator

Determines whether two Decimal values are not equal.

[C#]
public static bool operator !=(
   Decimal d1,
   Decimal d2
);
[C++]
public: static bool operator op_Inequality(
   Decimal d1,
   Decimal d2
);
[JScript]
returnValue = d1 ! = d2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

d1
The left operand, a Decimal.
d2
The right operand, a Decimal.

Parameters [C#, C++]

d1
The left operand, a Decimal.
d2
The right operand, a Decimal.

Return Value [C#, C++, JScript]

true if two Decimal values do not represent the same date and time, otherwise false.

Remarks [C#, C++, JScript]

The op_Inequality method compares two Decimal values (d1 and d2) to determine they are not equal and returns a Boolean value that represents their are inequality.

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal Less Than Operator

Determines whether one Decimal value is less than a specified Decimal.

[C#]
public static bool operator <(
   Decimal d1,
   Decimal d2
);
[C++]
public: static bool operator op_LessThan(
   Decimal d1,
   Decimal d2
);
[JScript]
returnValue = d1 < d2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

d1
The first operand, a Decimal value.
d2
The second operand, a Decimal value.

Parameters [C#, C++]

d1
The first operand, a Decimal value.
d2
The second operand, a Decimal value.

Return Value [C#, C++, JScript]

true if the first Decimal is less than the second Decimal, otherwise false.

Remarks [C#, C++, JScript]

The op_LessThan method determines whether the first Decimal value is less than the second Decimal value (d1 < d2) and returns a Boolean value that represents their relationship.

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal Less Than Or Equal Operator

Determines whether one Decimal value is less than or equal to a specified Decimal.

[C#]
public static bool operator <=(
   Decimal d1,
   Decimal d2
);
[C++]
public: static bool operator op_LessThanOrEqual(
   Decimal d1,
   Decimal d2
);
[JScript]
returnValue = d1 <= d2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

d1
The first operand, a Decimal value.
d2
The second operand, a Decimal value.

Parameters [C#, C++]

d1
The first operand, a Decimal value.
d2
The second operand, a Decimal value.

Return Value [C#, C++, JScript]

true if the first Decimal is less than or equal to the second Decimal, otherwise false.

Remarks [C#, C++, JScript]

The op_LessThanOrEqual method determines whether the first Decimal value is less than or equal to the second Decimal value (d1 <= d2) and returns a Boolean value concerning their relationship.

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal Modulus Operator

Determines the remainder from dividing two Decimal values.

[C#]
public static Decimal operator %(
   Decimal d1,
   Decimal d2
);
[C++]
public: static Decimal operator op_Modulus(
   Decimal d1,
   Decimal d2
);
[JScript]
returnValue = d1 % d2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

d1
The first Decimal (the dividend).
d2
The second Decimal (the divisor).

Parameters [C#, C++]

d1
The first Decimal (the dividend).
d2
The second Decimal (the divisor).

Return Value [C#, C++, JScript]

The result's of dividing two Decimal values.

Exceptions

Exception Type | Condition
DivideByZeroException | If the divisor is zero.
OverflowException | If the result is too large to represent as a Decimal.

Remarks [C#, C++, JScript]

The op_Mod method determines whether the result of first Decimal (the dividend) divided by second Decimal value (the divisor) (d1/ d2) and returns the remainder.

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal Multiplication Operator

Multiplies two Decimal values and produces a Decimal result.

[C#]
public static Decimal operator *(
   Decimal d1,
   Decimal d2
);
[C++]
public: static Decimal operator op_Multiply(
   Decimal d1,
   Decimal d2
);
[JScript]
returnValue = d1 * d2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

d1
The left operand, a Decimal.
d2
The right operand, a Decimal.

Parameters [C#, C++]

d1
The left operand, a Decimal.
d2
The right operand, a Decimal.

Return Value [C#, C++, JScript]

The Decimal result of multiplying two Decimal values.

Remarks [C#, C++, JScript]

The op_Multiply method determines the result of the first Decimal multiplied by second Decimal value (d1 * d2) and returns quotient the as a Decimal value.

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal Subtraction Operator

Subtracts two specified Decimal values.

[C#]
public static Decimal operator -(
   Decimal d1,
   Decimal d2
);
[C++]
public: static Decimal operator op_Subtraction(
   Decimal d1,
   Decimal d2
);
[JScript]
returnValue = d1 - d2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

d1
The left operand, a Decimal.
d2
The right operand, a Decimal.

Parameters [C#, C++]

d1
The left operand, a Decimal.
d2
The right operand, a Decimal.

Return Value [C#, C++, JScript]

The result of subtracting two Decimal values.

Exceptions

Exception Type | Condition
OverflowException | is thrown if the result is too large to represent as a Decimal.

Remarks [C#, C++, JScript]

The op_Subtraction method performs the arithmetic subtraction operation by subtracting two Decimal values (d1- d2)and returns the result.

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal Unary Negation Operator

Decrements the specified number.

[C#]
public static Decimal operator -(
   Decimal d
);
[C++]
public: static Decimal operator op_UnaryNegation(
   Decimal d
);
[JScript]
returnValue = -d;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

d
A Decimal value.

Parameters [C#, C++]

d
A Decimal value.

Return Value [C#, C++, JScript]

The result of evaluating d- 1.

Exceptions

Exception Type | Condition
OverflowException | is thrown if the result is too small to represent as a Decimal.

Remarks [C#, C++, JScript]

The op_Decrement method performs the arithmetic addition operation of decrementing a specified Decimal value (d- 1)and returns the result.

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal Unary Plus Operator

Returns the negated value of the specified Decimal.

[C#]
public static Decimal operator +(
   Decimal d
);
[C++]
public: static Decimal operator op_UnaryPlus(
   Decimal d
);
[JScript]
returnValue = +d;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

d
The Decimal value to make positive.

Parameters [C#, C++]

d
The Decimal value to make positive.

Return Value [C#, C++, JScript]

Value Type | Condition
d | If the Decimal value is non-zero.
 | If the Decimal value is zero.

Exceptions

Exception Type | Condition
OverflowException | is thrown if the Decimal value is equal to Decimal.MinValue.

Remarks [C#, C++, JScript]

The op_UnaryPlus method returns the positive value of the specified Decimal. For example:

If the Decimal value (d) is non-zero, the result is the positive of the Decimal value (+ d).

If the Decimal value (d) is zero, the result is zero (0).

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal to Double Conversion

[To be supplied.]

[C#]
public static explicit operator double(
   Decimal value
);
[C++]
public: operator double();
[JScript]
returnValue = Double(value);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#]

value
[To be supplied.]

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal to Single Conversion

[To be supplied.]

[C#]
public static explicit operator float(
   Decimal value
);
[C++]
public: operator float();
[JScript]
returnValue = Single(value);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#]

value
[To be supplied.]

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal to UInt32 Conversion

[To be supplied.]

[C#]
public static explicit operator uint(
   Decimal value
);
[C++]
public: operator unsigned int();
[JScript]
returnValue = UInt32(value);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#]

value
[To be supplied.]

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal to Int64 Conversion

[To be supplied.]

[C#]
public static explicit operator long(
   Decimal value
);
[C++]
public: operator __int64();
[JScript]
returnValue = Int64(value);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#]

value
[To be supplied.]

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal to UInt64 Conversion

[To be supplied.]

[C#]
public static explicit operator ulong(
   Decimal value
);
[C++]
public: operator unsigned __int64();
[JScript]
returnValue = UInt64(value);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#]

value
[To be supplied.]

See Also

Decimal Structure | Decimal Members | System Namespace


Single to Decimal Conversion

[To be supplied.]

[C#]
public static explicit operator Decimal(
   float value
);
[C++]
public: static Decimal op_Explicit(
   float value
);
[JScript]
returnValue = Decimal(value);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#, C++]

value
[To be supplied.]

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal to Int16 Conversion

[To be supplied.]

[C#]
public static explicit operator short(
   Decimal value
);
[C++]
public: operator short();
[JScript]
returnValue = Int16(value);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#]

value
[To be supplied.]

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal to Char Conversion

[To be supplied.]

[C#]
public static explicit operator char(
   Decimal value
);
[C++]
public: operator __wchar_t();
[JScript]
returnValue = Char(value);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#]

value
[To be supplied.]

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal to Int32 Conversion

[To be supplied.]

[C#]
public static explicit operator int(
   Decimal value
);
[C++]
public: operator int();
[JScript]
returnValue = Int32(value);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#]

value
[To be supplied.]

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal to UInt16 Conversion

[To be supplied.]

[C#]
public static explicit operator ushort(
   Decimal value
);
[C++]
public: operator unsigned short();
[JScript]
returnValue = UInt16(value);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#]

value
[To be supplied.]

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal to SByte Conversion

[To be supplied.]

[C#]
public static explicit operator sbyte(
   Decimal value
);
[C++]
public: operator char();
[JScript]
returnValue = SByte(value);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#]

value
[To be supplied.]

See Also

Decimal Structure | Decimal Members | System Namespace


Double to Decimal Conversion

[To be supplied.]

[C#]
public static explicit operator Decimal(
   double value
);
[C++]
public: static Decimal op_Explicit(
   double value
);
[JScript]
returnValue = Decimal(value);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#, C++]

value
[To be supplied.]

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal to Byte Conversion

[To be supplied.]

[C#]
public static explicit operator byte(
   Decimal value
);
[C++]
public: operator unsigned char();
[JScript]
returnValue = Byte(value);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#]

value
[To be supplied.]

See Also

Decimal Structure | Decimal Members | System Namespace


NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Byte to Decimal Conversion

Build number 1812.

© 2000 Microsoft Corporation. All rights reserved.


UInt16 to Decimal Conversion

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UInt16 to Decimal Conversion (UInt16)

[To be supplied.]

[C#]
public static implicit operator Decimal(
   ushort value
);
[C++]
public: static Decimal op_Implicit(
   unsigned short value
);
[JScript]
returnValue = value;

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#, C++]

value
[To be supplied.]

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal to Conversion Overload List


Int16 to Decimal Conversion

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Int16 to Decimal Conversion (Int16)

[To be supplied.]

[C#]
public static implicit operator Decimal(
   short value
);
[C++]
public: static Decimal op_Implicit(
   short value
);
[JScript]
returnValue = value;

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#, C++]

value
[To be supplied.]

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal to Conversion Overload List


Int32 to Decimal Conversion

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Int32 to Decimal Conversion (Int32)

[To be supplied.]

[C#]
public static implicit operator Decimal(
   int value
);
[C++]
public: static Decimal op_Implicit(
   int value
);
[JScript]
returnValue = value;

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#, C++]

value
[To be supplied.]

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal to Conversion Overload List


Char to Decimal Conversion

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Char to Decimal Conversion (Char)

[To be supplied.]

[C#]
public static implicit operator Decimal(
   char value
);
[C++]
public: static Decimal op_Implicit(
   __wchar_t value
);
[JScript]
returnValue = value;

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#, C++]

value
[To be supplied.]

See Also

Decimal Structure | Decimal Members | System Namespace | Decimal to Conversion Overload List


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Decimal Fields

The fields of the Decimal structure are listed below. For a complete list of Decimal structure members, see the Decimal Members topic.

Public:

Empty | Representing the constant that is the empty Decimal value.
MaxValue | Representing the constant that is the largest possible Decimal value.
MinusOne | Representing the constant that is the Decimal value of minus one:-1.
MinValue | Representing the constant that is the smallest possible Decimal value. .
One | Representing the constant that is the Decimal value of one: 1.
ScaleMask | Representing the constant that is the scale mask for the flags field.
SignMask | Representing the constant that is the sign mask for the flags field. .
Zero | Representing the constant that is the Decimal value of zero: 0.

See Also

Decimal Structure | System Namespace


Decimal.Empty

Representing the constant that is the empty Decimal value.

[Visual Basic]
Public Shared ReadOnly Empty As Decimal
[C#]
public static readonly Decimal Empty;
[C++]
public: static readonly Decimal Empty;
[JScript]
public static var Empty : Decimal;

Remarks

The Empty constant has a value of negative 79,228,162,514,264,337,593,543,950,335.

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.MaxValue

Representing the constant that is the largest possible Decimal value.

[Visual Basic]
Public Shared ReadOnly MaxValue As Decimal
[C#]
public static readonly Decimal MaxValue;
[C++]
public: static readonly Decimal MaxValue;
[JScript]
public static var MaxValue : Decimal;

Remarks

The value of this constant is 79,228,162,514,264,337,593,543,950,335.

The One hexadecimal value is equal to Decimal(unchecked((int)0XFFFFFFFF), unchecked((int)0xFFFFFFFF). unchecked((int)0xFFFFFFFF), 0);

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.MinusOne

Representing the constant that is the Decimal value of minus one:-1.

[Visual Basic]
Public Shared ReadOnly MinusOne As Decimal
[C#]
public static readonly Decimal MinusOne;
[C++]
public: static readonly Decimal MinusOne;
[JScript]
public static var MinusOne : Decimal;

Remarks

The Decimal.MinusOne is equal to a new Decimal(1, 0, 0, SignMask).

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.MinValue

Representing the constant that is the smallest possible Decimal value. .

[Visual Basic]
Public Shared ReadOnly MinValue As Decimal
[C#]
public static readonly Decimal MinValue;
[C++]
public: static readonly Decimal MinValue;
[JScript]
public static var MinValue : Decimal;

Remarks

The value of this constant is negative 79,228,162,514,264,337,593,543,950,335

The One hexadecimal value is equal to Decimal(unchecked((int)0XFFFFFFFF), unchecked((int)0xFFFFFFFF). unchecked((int)0xFFFFFFFF), SignMask);

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.One

Representing the constant that is the Decimal value of one: 1.

[Visual Basic]
Public Shared ReadOnly One As Decimal
[C#]
public static readonly Decimal One;
[C++]
public: static readonly Decimal One;
[JScript]
public static var One : Decimal;

Remarks

The Decimal.One is equal to a new Decimal(1, 0, 0, 0).

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.ScaleMask

Representing the constant that is the scale mask for the flags field.

[Visual Basic]
Public Const ScaleMask As Integer
[C#]
public const int ScaleMask;
[C++]
public: const int ScaleMask;
[JScript]
public var ScaleMask : int;

Remarks

The ScaleMask is for the flags field. This byte in the flags field contains the power of ten with which to divide the Decimal value. The scale byte must contain a value between 0 through 28, inconclusive.

The ScaleMask hexadecimal value is 0x00FF0000.

A value of zero in this bit indicates a positive Decimal value, and a value of one in this bit indicates a negative Decimal value.

The number of bits the scale (ScaleShift) is shifted by is 16.

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.SignMask

Representing the constant that is the sign mask for the flags field. .

[Visual Basic]
Public Const SignMask As Integer
[C#]
public const int SignMask;
[C++]
public: const int SignMask;
[JScript]
public var SignMask : int;

Remarks

The SignMask is for the flags field. A value of zero in this bit indicates a positive Decimal value, and a value of one in this bit indicates a negative Decimal value

See the OleAut's DECIMAL_NEG constant for negative values in native code.

The SignMask hexadecimal value is unchecked((int)0x80000000).

See Also

Decimal Structure | Decimal Members | System Namespace


Decimal.Zero

Representing the constant that is the Decimal value of zero: 0.

[Visual Basic]
Public Shared ReadOnly Zero As Decimal
[C#]
public static readonly Decimal Zero;
[C++]
public: static readonly Decimal Zero;
[JScript]
public static var Zero : Decimal;

Remarks

The Decimal.Zero is equal to a new Decimal(0, 0, 0, 0).

See Also

Decimal Structure | Decimal Members | System Namespace


Delegate Class

Represents a delegate, which is a data structure that refers to a static method or to an object instance and an instance method of that object.

Object
Delegate

[Visual Basic]
MustInherit Public Class Delegate
   Implements ICloneable, ISerializable
[C#]
public abstract class Delegate : ICloneable, ISerializable
[C++]
public __gc __abstract class Delegate : public ICloneable,
   ISerializable
[JScript]
public abstract class Delegate implements ICloneable, ISerializable

Remarks

The Delegate class is the base class for delegates.

The closest equivalent of a delegate in C or C++ is a function pointer. However, a function pointer can only reference static functions, whereas a delegate can reference both static and instance methods. When the delegate references instance methods, the delegate stores not only a reference to the method's entry point, but also a reference to the object instance for which to invoke the method. Unlike function pointers, delegates are object-oriented, type-safe, and secure.

An invocation list is a linked list of delegates that are to be invoked when the Invoke method is called.

A delegate that inherits directly from the Delegate class has an invocation list with only one element-- itself. A delegate that inherits from the MulticastDelegate class may have an invocation list with more than one element. The Combine and Remove methods are used to create new invocation lists.

Subclasses of Delegate and MulticastDelegate are declared with special syntax.

For example, the following declarations are for a delegate which encapsulates a method that takes a single parameter of type String and has no return value:

// Managed C++ delegate declaration
__delegate void mySingleCast(String *value);

[Visual Basic]

' VB delegate declaration
Public Delegate Sub mySingleCast(value As String)

When these declarations are compiled, a class by the name of mySingleCast is generated. This class has two members, a constructor and an Invoke method. The compiler generates metadata for these members and sets a bit indicating that no implementation is provided. The EE provides the implementation. Although the class declarations that follow are not 100% accurate, they offer a glimpse of what the declaration for mySingleCast would look like if the compiler did not generate the class from the simplified delegate declaration syntax given above.

// Managed C++ pseudo code for mySingleCast
class mySingleCast {
  public:
    mySingleCast(Object *obj, int ptr);
  public:
    void Invoke(String *value);
};

[Visual Basic]

' VB pseudo code for mySingleCast
Class mySingleCast
  Public Sub New(obj As Object, ptr As Long)
  Public Sub Invoke(value As String)
End Class

Observe that the mySingleCast class contains two members (this is true for every subclass of Delegate and MulticastDelegate). The first member is a constructor with the metadata signature .ctor (System/Object, I4), where .ctor indicates that the member is a constructor, System/Object indicates the first parameter is an Object, and I4 indicates that the second parameter is a 4-byte integer. The first parameter is the target of the delegate and the second parameter is the address of the method body. The second member of a mySingleCast is a method with the metadata signature Void Invoke(System/String). The parameter list, which consists a single String parameter, indicates that the mySingleCast delegate encapsulates methods that take a single String parameter. Note that the Invoke method is used for early bound invocation of the method encapsulated by this delegate (late bound invocation is accomplished via Delegate.DynamicInvoke).

Compilers are free to access the constructor in any way they choose; this constructor requires special handling. For example, observe the difference in how the mySingleCast constructor is invoked in Managed C++ and VB:

// Managed C++ delegate instantiation
class myEcho {
  public:
    void shout(String *value) {Console::WriteLine(value);};
};

void main() {
  myEcho *obj = new myEcho();
  mySingleCast *dlgt = new mySingleCast(obj, &myEcho::shout);
  // alternative : mySingleCast *dlgt = new mySingleCast(obj->shout);
  dlgt->Invoke("Argh!");
};

[Visual Basic]

' VB pseudo code for mySingleCast
Class myEcho
  Public Sub Shout(value As String)
    Console.WriteLine(value)
  End Sub
End Class

Sub main
  Dim obj As myEcho
  Set obj = New myEcho()
  Dim dlgt As mySingleCast
  Set dlgt = New mySingleCast(AddressOf obj.shout)
  dlgt.Invoke("Argh!")
End Sub

Observe that VB invokes the mySingleCast constructor with an expression as the parameter (AddressOf obj.shout). This is due to the fact that VB does not allow the address of a method to be determined in any other way. The IL that is emitted by the VB compiler actually calls the constructor discussed above, passing an Object reference and the address of the method body. On the other hand, Managed C++ allows the mySingleCast constructor to be invoked directly--new mySingleCast(obj, &myEcho::shout). Alternatively, the following syntax may be used: new mySingleCast(obj->shout). (Note that even if the method to be encapsulated is static, Managed C++ does not allow the constructor of a delegate to be invoked with only the address of a member of a managed class. Managed C++ may choose to do this in the future, since the constructor for every subclass of Delegate or MulticastDelegate allows the target object to be a null reference if the method is static.)

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

Delegate Members | System Namespace | MulticastDelegate


Delegate Members

Public:

Properties

Method | Gets the static method of the class represented by the Delegate.
Target | Gets the target of the Delegate.

Methods

BindToContext | Binds the Delegate to a context.
Clone | Creates a shallow copy of the Delegate.
Combine | Overloaded. Combines the invocation lists of the specified multicast Delegate instances.
CreateDelegate | Overloaded. Creates a Delegate of the specified Type.
DynamicInvoke | Invokes the method, represented by the Delegate, dynamically (late-bound).
Equals | Determines if the specified object and the singlecast Delegate share the same target, method and invocation list.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInvocationList | Returns the invocation list of the Delegate.
GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Delegate.
GetType (inherited from Object) | Gets the Type of the Object.
Remove | Removes a Delegate from the invocation list of another Delegate.
ToString (inherited from Object) | Returns a String that represents the current Object.

Operators

Equality Operator | Determines if the specified Delegate objects are equal.
Inequality Operator | Determines if the specified Delegate objects are not equal.

Protected:

Constructor

Delegate Constructor Overloaded. Initializes a new instance of the Delegate class.

Methods

CombineImpl | When overridden in a derived class, combines the invocation lists of the specified multicast Delegate with the current multicast Delegate.
DynamicInvokeImpl | Invokes the method, represented by the Delegate, dynamically (late-bound).
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetMethodImpl | Gets the static method of the class represented by the Delegate.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveImpl | Removes a Delegate from the invocation list of another Delegate.

See Also

Delegate Class | System Namespace


Delegate Constructor

Initializes a new instance of the Delegate class.

Overload List

Creates a Delegate to represent the specified target Object and the specified method.

[Visual Basic] Overloads Protected Sub New(Object, String)
[C#] protected Delegate(Object, String);
[C++] protected: Delegate(Object*, String);
[JScript] protected function Delegate(Object, String);

Creates a Delegate to represent the specified target Type and the specified method.

[Visual Basic] Overloads Protected Sub New(Type, String)
[C#] protected Delegate(Type, String);
[C++] protected: Delegate(Type*, String);
[JScript] protected function Delegate(Type, String);

See Also

Delegate Class | Delegate Members | System Namespace


Delegate Constructor (Object, String)

Creates a Delegate to represent the specified target Object and the specified method.

[Visual Basic]
Overloads Protected Sub New( _
   ByVal target As Object, _
   ByVal method As String _
)
[C#]
protected Delegate(
   object target,
   string method
);
[C++]
protected: Delegate(
   Object* target,
   String* method
);
[JScript]
protected function Delegate(
   target : Object,
   method : String
);

Parameters

target
The Object to be represented by the Delegate.
method
The String containing the name of the method to be represented by the Delegate.

Exceptions

Exception Type | Condition
ArgumentNullException | target is a null reference (in Visual Basic Nothing). -or- method is a null reference (Nothing).

Remarks

This constructor is called from the class created by the compiler generated code. (?)

See Also

Delegate Class | Delegate Members | System Namespace | Delegate Constructor Overload List | Object | String


Delegate Constructor (Type, String)

Creates a Delegate to represent the specified target Type and the specified method.

[Visual Basic]
Overloads Protected Sub New( _
   ByVal target As Type, _
   ByVal method As String _
)
[C#]
protected Delegate(
   Type target,
   string method
);
[C++]
protected: Delegate(
   Type* target,
   String* method
);
[JScript]
protected function Delegate(
   target : Type,
   method : String
);

Parameters

target
The Type to be represented by the Delegate.
method
The String containing the name of the method to be represented by the Delegate.

Exceptions

Exception Type | Condition
ArgumentNullException | target is a null reference (in Visual Basic Nothing). -or- method is a null reference (Nothing).

Remarks

This constructor is called from a class to generate a delegate based upon a static method name and the Type object for the class defining the method. (?)

See Also

Delegate Class | Delegate Members | System Namespace | Delegate Constructor Overload List | Type | String


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Delegate Properties

The properties of the Delegate class are listed below. For a complete list of Delegate class members, see the Delegate Members topic.

Public:

Method | Gets the static method of the class represented by the Delegate.
Target | Gets the target of the Delegate.

See Also

Delegate Class | System Namespace


Delegate.Method

Gets the static method of the class represented by the Delegate.

[Visual Basic]
Public ReadOnly Property Method As MethodInfo
[C#]
public MethodInfo Method {get;}
[C++]
public: __property MethodInfo* get_Method();
[JScript]
public function get Method() : MethodInfo;

Property Value

A MethodInfo describing the static method represented by the Delegate.

Exceptions

Exception Type | Condition
AccessException | The caller does not have access to the method represented by the Delegate; for instance, if the method is private. (?)

See Also

Delegate Class | Delegate Members | System Namespace | MethodInfo | GetMethodImpl


Delegate.Target

Gets the target of the Delegate.

[Visual Basic]
Public ReadOnly Property Target As Object
[C#]
public object Target {get;}
[C++]
public: __property Object* get_Target();
[JScript]
public function get Target() : Object;

Property Value

The target of the Delegate.

Remarks

The target object of a Delegate representing an instance method is an instance of a class.

The target object of a Delegate representing a static method is a class.

See Also

Delegate Class | Delegate Members | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Delegate Methods

The methods of the Delegate class are listed below. For a complete list of Delegate class members, see the Delegate Members topic.

Public:

BindToContext | Binds the Delegate to a context.
Clone | Creates a shallow copy of the Delegate.
Combine | Overloaded. Combines the invocation lists of the specified multicast Delegate instances.
CreateDelegate | Overloaded. Creates a Delegate of the specified Type.
DynamicInvoke | Invokes the method, represented by the Delegate, dynamically (late-bound).
Equals | Determines if the specified object and the singlecast Delegate share the same target, method and invocation list.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInvocationList | Returns the invocation list of the Delegate.
GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Delegate.
GetType (inherited from Object) | Gets the Type of the Object.
Remove | Removes a Delegate from the invocation list of another Delegate.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

CombineImpl | When overridden in a derived class, combines the invocation lists of the specified multicast Delegate with the current multicast Delegate.
DynamicInvokeImpl | Invokes the method, represented by the Delegate, dynamically (late-bound).
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetMethodImpl | Gets the static method of the class represented by the Delegate.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveImpl | Removes a Delegate from the invocation list of another Delegate.

See Also

Delegate Class | System Namespace


Delegate.BindToContext

Binds the Delegate to a context.

[Visual Basic]
Public Sub BindToContext()
[C#]
public void BindToContext();
[C++]
public: void BindToContext();
[JScript]
public function BindToContext();

Return Value

None.

See Also

Delegate Class | Delegate Members | System Namespace


Delegate.Clone

Creates a shallow copy of the Delegate.

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

Return Value

A shallow copy of the Delegate.

Remarks

This method can be overridden by a derived class.

The clone will have the same target object, target method, and invocation list as the original Delegate.A shallow copy of an object is a copy of the object only. If the object contains references to other objects, the shallow copy will not create copies of the referred objects, but will refer to the original objects instead. On the other hand, a deep copy of an object creates a copy of the object and a copy of everything directly or indirectly referenced by that object.

See Also

Delegate Class | Delegate Members | System Namespace


Delegate.Combine

Combines the invocation lists of the specified multicast Delegate instances.

Overload List

Combines the invocation lists of an array of multicast Delegate instances.

[Visual Basic] Overloads Public Shared Function Combine(Delegate()) As Delegate
[C#] public static Delegate Combine(Delegate[]);
[C++] public: static Delegate* Combine(Delegate*[]);
[JScript] public static function Combine(Delegate[]) : Delegate;

Combines the invocation lists of two multicast Delegate instances.

[Visual Basic] Overloads Public Shared Function Combine(Delegate, Delegate) As Delegate
[C#] public static Delegate Combine(Delegate, Delegate);
[C++] public: static Delegate* Combine(Delegate*, Delegate*);
[JScript] public static function Combine(Delegate, Delegate) : Delegate;

See Also

Delegate Class | Delegate Members | System Namespace


Delegate.Combine (Delegate[])

Combines the invocation lists of an array of multicast Delegate instances.

[Visual Basic]
Overloads Public Shared Function Combine( _
   ByVal delegates() As Delegate _
) As Delegate
[C#]
public static Delegate Combine(
   Delegate[] delegates
);
[C++]
public: static Delegate* Combine(
   Delegate* delegates[]
);
[JScript]
public static function Combine(
   delegates : Delegate[]
) : Delegate;

Parameters

delegates
The array of multicast Delegate instances to combine.

Return Value

A new multicast Delegate with an invocation list that concatenates the invocation lists of the delegates in the delegates array.

a null reference (in Visual Basic Nothing) if delegates is a null reference (Nothing), or if delegates contains zero elements, or if all the entries in delegates are a null reference (Nothing).

Exceptions

Exception Type | Condition
ArgumentException | Not all the non-null entries in delegates are instances of the same class.
MulticastNotSupportedException | One or more non-null entries in delegates are not derive from MulticastDelegate.

Remarks

If the delegates array contains entries that are a null reference (Nothing), those entries are ignored.

The invocation list can contain duplicate entries; that is, entries that refer to the same method on the same object.

See Also

Delegate Class | Delegate Members | System Namespace | Delegate.Combine Overload List | MulticastDelegate | CombineImpl


Delegate.Combine (Delegate, Delegate)

Combines the invocation lists of two multicast Delegate instances.

[Visual Basic]
Overloads Public Shared Function Combine( _
   ByVal a As Delegate, _
   ByVal b As Delegate _
) As Delegate
[C#]
public static Delegate Combine(
   Delegate a,
   Delegate b
);
[C++]
public: static Delegate* Combine(
   Delegate* a,
   Delegate* b
);
[JScript]
public static function Combine(
   a : Delegate,
   b : Delegate
) : Delegate;

Parameters

a
The multicast Delegate whose invocation list comes first.
b
The multicast Delegate whose invocation list comes last.

Return Value

A new multicast Delegate with an invocation list that concatenates the invocation lists of a and b in that order.

a null reference (in Visual Basic Nothing) if both a and b are a null reference (Nothing).

Exceptions

Exception Type | Condition
ArgumentException | Both a and b are not a null reference (Nothing) and a and b are not instances of the same class.
MulticastNotSupportedException | Both a and b are not a null reference (Nothing) and are not derived from MulticastDelegate.

Remarks

The invocation list can contain duplicate entries; that is, entries that refer to the same method on the same object.

See Also

Delegate Class | Delegate Members | System Namespace | Delegate.Combine Overload List | MulticastDelegate | CombineImpl


Delegate.CombineImpl

When overridden in a derived class, combines the invocation lists of the specified multicast Delegate with the current multicast Delegate.

[Visual Basic]
Overridable Protected Function CombineImpl( _
   ByVal d As Delegate _
) As Delegate
[C#]
protected virtual Delegate CombineImpl(
   Delegate d
);
[C++]
protected: virtual Delegate* CombineImpl(
   Delegate* d
);
[JScript]
protected function CombineImpl(
   d : Delegate
) : Delegate;

Parameters

d
The multicast Delegate whose invocation list to append to the end of the current multicast Delegate 's invocation list.

Return Value

When overridden in a derived class, a new Delegate with an invocation list that concatenates the invocation list of the current Delegate and the invocation list of d.

Exceptions

Exception Type | Condition
MulticastNotSupportedException | (Always thrown.)

Remarks

This method must be overridden by a derived class. The current implementation simply throws a MulticastNotSupportedException.

See Also

Delegate Class | Delegate Members | System Namespace | Combine


Delegate.CreateDelegate

Creates a Delegate of the specified Type.

Overload List

Creates a Delegate of the specified type to represent the specified static method.

[Visual Basic] Overloads Public Shared Function CreateDelegate(Type, MethodInfo) As Delegate
[C#] public static Delegate CreateDelegate(Type, MethodInfo);
[C++] public: static Delegate* CreateDelegate(Type*, MethodInfo);
[JScript] public static function CreateDelegate(Type, MethodInfo) : Delegate;

Creates a Delegate of the specified type to represent the specified instance method of the specified Type instance.

[Visual Basic] Overloads Public Shared Function CreateDelegate(Type, Type, String) As Delegate
[C#] public static Delegate CreateDelegate(Type, Type, String);
[C++] public: static Delegate* CreateDelegate(Type*, Type*, String);
[JScript] public static function CreateDelegate(Type, Type, String) : Delegate;

Creates a Delegate of the specified type to represent the specified instance method of the specified Object instance.

[Visual Basic] Overloads Public Shared Function CreateDelegate(Type, Object, String) As Delegate
[C#] public static Delegate CreateDelegate(Type, Object, String);
[C++] public: static Delegate* CreateDelegate(Type*, Object, String);
[JScript] public static function CreateDelegate(Type, Object, String) : Delegate;

See Also

Delegate Class | Delegate Members | System Namespace


Delegate.CreateDelegate (Type, MethodInfo)

Creates a Delegate of the specified type to represent the specified static method.

[Visual Basic]
Overloads Public Shared Function CreateDelegate( _
   ByVal type As Type, _
   ByVal method As MethodInfo _
) As Delegate
[C#]
public static Delegate CreateDelegate(
   Type type,
   MethodInfo method
);
[C++]
public: static Delegate* CreateDelegate(
   Type* type,
   MethodInfo* method
);
[JScript]
public static function CreateDelegate(
   type : Type,
   method : MethodInfo
) : Delegate;

Parameters

type
The Type of Delegate to create.
method
The MethodInfo describing the method for which the Delegate is to be created.

Return Value

A Delegate of the specified type to represent the specified static method.

Exceptions

Exception Type | Condition
ArgumentNullException | type is a null reference (in Visual Basic Nothing). -or- method is a null reference (Nothing).
ArgumentException | type does not inherit from either Delegate or MulticastDelegate. -or- method is not a static method.
ExecutionEngineException | type does not have an Invoke method.
AccessException | The caller does not have access to the method represented by the Delegate; for instance, if the method is private. (?)
SecurityException | method is outside the current assembly and the caller does not have ReflectionPermission for the assembly containing method. (?)

Remarks

This method creates delegates for static methods only. A static method is a method that is associated with the class itself.

type must inherit from either Delegate or MulticastDelegate.

See Also

Delegate Class | Delegate Members | System Namespace | Delegate.CreateDelegate Overload List | MulticastDelegate | ReflectionPermission | MethodInfo


Delegate.CreateDelegate (Type, Type, String)

Creates a Delegate of the specified type to represent the specified instance method of the specified Type instance.

[Visual Basic]
Overloads Public Shared Function CreateDelegate( _
   ByVal type As Type, _
   ByVal target As Type, _
   ByVal method As String _
) As Delegate
[C#]
public static Delegate CreateDelegate(
   Type type,
   Type target,
   string method
);
[C++]
public: static Delegate* CreateDelegate(
   Type* type,
   Type* target,
   String* method
);
[JScript]
public static function CreateDelegate(
   type : Type,
   target : Type,
   method : String
) : Delegate;

Parameters

type
The Type of Delegate to create.
target
The target Type instance which implements method.
method
The name of the method for which the delegate is to be created.

Return Value

A Delegate of the specified type to represent the specified instance method of the specified Type instance.

Exceptions

Exception Type | Condition
ArgumentNullException | type is a null reference (in Visual Basic Nothing). -or- target is a null reference (Nothing). -or- method is a null reference (Nothing).
ArgumentException | type does not inherit from either Delegate or MulticastDelegate.
AccessException | The caller does not have access to the method represented by the Delegate; for instance, if the method is private.(?)
SecurityException | method is outside the current assembly and the caller does not have ReflectionPermission for the assembly containing method. (?)

Remarks

This method creates delegates for instance methods only. An instance method is a method that is associated with an instance of a class.

type must inherit from either Delegate or MulticastDelegate.

For example, passing "System.Threading.ThreadStart" to the Type.GetType method will return a Type object for the ThreadStart delegate.

See Also

Delegate Class | Delegate Members | System Namespace | Delegate.CreateDelegate Overload List | MulticastDelegate | ReflectionPermission | Object


Delegate.CreateDelegate (Type, Object, String)

Creates a Delegate of the specified type to represent the specified instance method of the specified Object instance.

[Visual Basic]
Overloads Public Shared Function CreateDelegate( _
   ByVal type As Type, _
   ByVal target As Object, _
   ByVal method As String _
) As Delegate
[C#]
public static Delegate CreateDelegate(
   Type type,
   object target,
   string method
);
[C++]
public: static Delegate* CreateDelegate(
   Type* type,
   Object* target,
   String* method
);
[JScript]
public static function CreateDelegate(
   type : Type,
   target : Object,
   method : String
) : Delegate;

Parameters

type
The Type of Delegate to create.
target
The target Object instance which implements method.
method
The instance method for which the Delegate is to be created.

Return Value

A Delegate of the specified type to represent the specified instance method of the specified Object instance

Exceptions

Exception Type | Condition
ArgumentNullException | type is a null reference (in Visual Basic Nothing). -or- target is a null reference (Nothing). -or- method is a null reference (Nothing).
ArgumentException | type does not inherit from either Delegate or MulticastDelegate.
AccessException | The caller does not have access to the method represented by the Delegate; for instance, if the method is private. (?)
SecurityException | method is outside the current assembly and the caller does not have ReflectionPermission for the assembly containing method. (?)

Remarks

This method creates delegates for instance methods only. An instance method is a method that is associated with an instance of a class.

type must inherit from either Delegate or MulticastDelegate.

See Also

Delegate Class | Delegate Members | System Namespace | Delegate.CreateDelegate Overload List | MulticastDelegate | ReflectionPermission | Object


Delegate.DynamicInvoke

Invokes the method, represented by the Delegate, dynamically (late-bound).

[Visual Basic]
Public Function DynamicInvoke( _
   ByVal args() As Object _
) As Object
[C#]
public object DynamicInvoke(
   object[] args
);
[C++]
public: Object* DynamicInvoke(
   Object* args[]
);
[JScript]
public function DynamicInvoke(
   args : Object[]
) : Object;

Parameters

args
An array of Object instances which are the arguments to pass to the method represented by the Delegate.

-or-

a null reference (in Visual Basic Nothing), if the method represented by the Delegate does not require arguments.

Return Value

The Object returned by the method represented by the Delegate.

Exceptions

Exception Type | Condition
AccessException | The caller does not have access to the method represented by the Delegate; for instance, if the method is private. -or- The number, order or type of parameters listed in args is invalid.
TargetException | The method represented by the Delegate is an instance method and the target object is a null reference (Nothing). -or- The method represented by the Delegate is invoked on an object or a class that does not support it. (?)
TargetInvocationException | One of the encapsulated methods throws an exception. (?)

Remarks

This method calls the DynamicInvokeImpl method.

See Also

Delegate Class | Delegate Members | System Namespace | DynamicInvokeImpl | Object


Delegate.DynamicInvokeImpl

Invokes the method, represented by the Delegate, dynamically (late-bound).

[Visual Basic]
Overridable Protected Function DynamicInvokeImpl( _
   ByVal args() As Object _
) As Object
[C#]
protected virtual object DynamicInvokeImpl(
   object[] args
);
[C++]
protected: virtual Object* DynamicInvokeImpl(
   Object* args[]
);
[JScript]
protected function DynamicInvokeImpl(
   args : Object[]
) : Object;

Parameters

args
An array of Object instances which are the arguments to pass to the method represented by the Delegate.

-or-

a null reference (in Visual Basic Nothing), if the method represented by the Delegate does not require arguments.

Return Value

The Object returned by the method represented by the Delegate.

Exceptions

Exception Type | Condition
AccessException | The caller does not have access to the method represented by the Delegate; for instance, if the method is private. -or- The number, order or type of parameters listed in args is invalid.
TargetException | The method represented by the Delegate is an instance method and the target object is a null reference (Nothing). -or- The method represented by the Delegate is invoked on an object or a class that does not support it. (?)
TargetInvocationException | One of the encapsulated methods throws an exception. (?)

Remarks

This method can be overridden by a derived class.

This method implements the DynamicInvoke method.

See Also

Delegate Class | Delegate Members | System Namespace | DynamicInvoke | Object


Delegate.Equals

Determines if the specified object and the singlecast Delegate share the same target, method and invocation list.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The Object to compare with the singlecast Delegate.

Return Value

true if obj and the current Delegate have the same target, method and invocation list; otherwise, false.

Exceptions

Exception Type | Condition
AccessException | The caller does not have access to the method represented by the Delegate; for instance, if the method is private. (?)

Remarks

Two delegates with the same methods, the same targets and the same invocation lists are considered equal, even if they are not both singlecast or both multicast.

The methods and targets are compared for equality as follows:

  • If the two methods being compared are both static and are the same method on the same class, the methods are considered equal and the targets are also considered equal.
  • If the two methods being compared are instance methods and are the same method on the same object, the methods are considered equal and the targets are also considered equal.
  • Otherwise, the methods are not considered to be equal and the targets are also not considered to be equal.

Two invocation lists are considered identical if they have the same order and the corresponding elements from the two lists represent the same method and target.

See Also

Delegate Class | Delegate Members | System Namespace | Object


Delegate.GetInvocationList

Returns the invocation list of the Delegate.

[Visual Basic]
Overridable Public Function GetInvocationList() As Delegate ()
[C#]
public virtual Delegate[] GetInvocationList();
[C++]
public: virtual Delegate* GetInvocationList() [];
[JScript]
public function GetInvocationList() : Delegate[];

Return Value

An array of singlecast Delegate objects representing the invocation list of the current Delegate. If the current Delegate is singlecast, the array contains only one element. If the current Delegate is multicast, the array may contain more than one element.

Remarks

This method can be overridden by a derived class.

The invocation list of each Delegate in the returned array is guaranteed to have exactly one entry.

See Also

Delegate Class | Delegate Members | System Namespace


Delegate.GetMethodImpl

Gets the static method of the class represented by the Delegate.

[Visual Basic]
Overridable Protected Function GetMethodImpl() As MethodInfo
[C#]
protected virtual MethodInfo GetMethodImpl();
[C++]
protected: virtual MethodInfo* GetMethodImpl();
[JScript]
protected function GetMethodImpl() : MethodInfo;

Return Value

A MethodInfo describing the static method represented by the Delegate.

Exceptions

Exception Type | Condition
AccessException | The caller does not have access to the method represented by the Delegate; for instance, if the method is private. (?)

Remarks

This method can be overridden by a derived class.

See Also

Delegate Class | Delegate Members | System Namespace | MethodInfo | Method


Delegate.GetObjectData

Implements the ISerializable interface and returns the data needed to serialize the Delegate.

[Visual Basic]
Overridable Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
public: virtual void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
);
[JScript]
public function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);

Parameters

info
A SerializationInfo object containing information required to serialize the Delegate.
context
A StreamingContext object containing the source and destination of the serialized stream associated with the Delegate.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | info is a null reference (in Visual Basic Nothing).

Remarks

This method can be overridden by a derived class.

See Also

Delegate Class | Delegate Members | System Namespace | ISerializable | SerializationInfo | StreamingContext


Delegate.Remove

Removes a Delegate from the invocation list of another Delegate.

[Visual Basic]
Public Shared Function Remove( _
   ByVal source As Delegate, _
   ByVal value As Delegate _
) As Delegate
[C#]
public static Delegate Remove(
   Delegate source,
   Delegate value
);
[C++]
public: static Delegate* Remove(
   Delegate* source,
   Delegate* value
);
[JScript]
public static function Remove(
   source : Delegate,
   value : Delegate
) : Delegate;

Parameters

source
The Delegate from which to remove value.
value
The Delegate to remove from the invocation list of source.

Return Value

A new Delegate with an invocation list formed by taking the invocation list of source and removing the last occurrence of value, if value is found in the invocation list of source.

source, if value is a null reference (in Visual Basic Nothing), or if value is not found in the invocation list of source.

a null reference (Nothing), if value is the only element in the invocation list of source, or if source is a null reference (Nothing).

Exceptions

Exception Type | Condition
AccessException | The caller does not have access to the method represented by the Delegate; for instance, if the method is private. (?)

Remarks

The Delegate removed from the invocation list is the last delegate for which the following expression is true: value. Equals (delegate), where delegate is a member of source 's invocation list.

See Also

Delegate Class | Delegate Members | System Namespace | RemoveImpl | Equals


Delegate.RemoveImpl

Removes a Delegate from the invocation list of another Delegate.

[Visual Basic]
Overridable Protected Function RemoveImpl( _
   ByVal d As Delegate _
) As Delegate
[C#]
protected virtual Delegate RemoveImpl(
   Delegate d
);
[C++]
protected: virtual Delegate* RemoveImpl(
   Delegate* d
);
[JScript]
protected function RemoveImpl(
   d : Delegate
) : Delegate;

Parameters

d
The Delegate to remove from the invocation list of the current Delegate.

Return Value

source, if d is not equal to source; otherwise, a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
AccessException | The caller does not have access to the method represented by the Delegate; for instance, if the method is private. (?)

Remarks

This method can be overridden by a derived class.

See Also

Delegate Class | Delegate Members | System Namespace | Remove | Equals


Operators

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Delegate Operators

The operators of the Delegate class are listed below. For a complete list of Delegate class members, see the Delegate Members topic.

Public:

Equality Operator | Determines if the specified Delegate objects are equal.
Inequality Operator | Determines if the specified Delegate objects are not equal.

See Also

Delegate Class | System Namespace


Delegate Equality Operator

Determines if the specified Delegate objects are equal.

[C#]
public static bool operator ==(
   Delegate d1,
   Delegate d2
);
[C++]
public: static bool operator op_Equality(
   Delegate* d1,
   Delegate* d2
);
[JScript]
returnValue = d1 == d2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

d1
The first Delegate to compare.
d2
The second Delegate to compare.

Parameters [C#, C++]

d1
The first Delegate to compare.
d2
The second Delegate to compare.

Return Value [C#, C++, JScript]

true if d1 is equal to d2; otherwise, false.

Remarks [C#, C++, JScript]

Two delegates with the same methods, the same targets and the same invocation lists are considered equal, even if they are not both singlecast or both multicast.

The methods and targets are compared for equality as follows:

  • If the two methods being compared are both static and are the same method on the same class, the methods are considered equal and the targets are also considered equal.
  • If the two methods being compared are instance methods and are the same method on the same object, the methods are considered equal and the targets are also considered equal.
  • Otherwise, the methods are not considered to be equal and the targets are also not considered to be equal.

Two invocation lists are considered identical if they have the same order and the corresponding elements from the two lists represent the same method and target.

See Also

Delegate Class | Delegate Members | System Namespace | Equals


Delegate Inequality Operator

Determines if the specified Delegate objects are not equal.

[C#]
public static bool operator !=(
   Delegate d1,
   Delegate d2
);
[C++]
public: static bool operator op_Inequality(
   Delegate* d1,
   Delegate* d2
);
[JScript]
returnValue = d1 ! = d2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

d1
The first Delegate to compare.
d2
The second Delegate to compare.

Parameters [C#, C++]

d1
The first Delegate to compare.
d2
The second Delegate to compare.

Return Value [C#, C++, JScript]

true if d1 is not equal to d2; otherwise, false.

Remarks [C#, C++, JScript]

Two delegates are considered not equal if they have different methods, or different targets or different invocation lists.

The methods and targets are compared for equality as follows:

  • If the two methods being compared are both static and are the same method on the same class, the methods are considered equal and the targets are also considered equal.
  • If the two methods being compared are instance methods and are the same method on the same object, the methods are considered equal and the targets are also considered equal.
  • Otherwise, the methods are not considered to be equal and the targets are also not considered to be equal.

Two invocation lists are considered not equal if they have different sizes, or if they are ordered differently, or at least one element from one list represents a method or target that is different from that represented by its corresponding element in the other list.

See Also

Delegate Class | Delegate Members | System Namespace | Equals


DivideByZeroException Class

Represents an exception that is thrown when an attempt is made to divided by zero.

Object
Exception
SystemException
ArithmeticException
DivideByZeroException

[Visual Basic]
Public Class DivideByZeroException
   Inherits ArithmeticException
[C#]
public class DivideByZeroException : ArithmeticException
[C++]
public __gc class DivideByZeroException : public
   ArithmeticException
[JScript]
public class DivideByZeroException extends ArithmeticException

Remarks

The DivideByZero class is an exception class for bad arithmetic conditions. Dividing by zero is not an approved arithmetic operation.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

DivideByZeroException Members | System Namespace


DivideByZeroException Members

Public:

Constructor

DivideByZeroException Constructor Overloaded. Initializes a new instance of the DivideByZeroException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

DivideByZeroException Class | System Namespace


DivideByZeroException Constructor

Initializes a new instance of the DivideByZeroException class.

Overload List

Initializes a new instance of the DivideByZeroException class with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public DivideByZeroException();
[C++] public: DivideByZeroException();
[JScript] public function DivideByZeroException();

Initializes a new instance of DivideByZeroException with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public DivideByZeroException(String);
[C++] public: DivideByZeroException(String*);
[JScript] public function DivideByZeroException(String);

Initializes a new instance of DivideByZeroException with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public DivideByZeroException(String, Exception);
[C++] public: DivideByZeroException(String*, Exception);
[JScript] public function DivideByZeroException(String, Exception);

See Also

DivideByZeroException Class | DivideByZeroException Members | System Namespace


DivideByZeroException Constructor ()

Initializes a new instance of the DivideByZeroException class with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public DivideByZeroException();
[C++]
public: DivideByZeroException();
[JScript]
public function DivideByZeroException();

Remarks

DivideByZeroException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The empty string.

See Also

DivideByZeroException Class | DivideByZeroException Members | System Namespace | DivideByZeroException Constructor Overload List


DivideByZeroException Constructor (String)

Initializes a new instance of DivideByZeroException with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public DivideByZeroException(
   string message
);
[C++]
public: DivideByZeroException(
   String* message
);
[JScript]
public function DivideByZeroException(
   message : String
);

Parameters

message
The message that indicates the reason the exception occurred.

Remarks

DivideByZeroException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The message string.

See Also

DivideByZeroException Class | DivideByZeroException Members | System Namespace | DivideByZeroException Constructor Overload List


DivideByZeroException Constructor (String, Exception)

Initializes a new instance of DivideByZeroException with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public DivideByZeroException(
   string message,
   Exception innerException
);
[C++]
public: DivideByZeroException(
   String* message,
   Exception* innerException
);
[JScript]
public function DivideByZeroException(
   message : String,
   innerException : Exception
);

Parameters

message
The message that indicates the reason the exception occurred.
innerException
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

DivideByZeroException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | The inner exception.
Message | The message string.

See Also

DivideByZeroException Class | DivideByZeroException Members | System Namespace | DivideByZeroException Constructor Overload List


Double Structure

Represents a 64-bit, double precision, floating point number.

Object
ValueType
Double

[Visual Basic]
Public Structure Double
   Implements IComparable, IFormattable, IConvertible
[C#]
public struct Double : IComparable, IFormattable, IConvertible
[C++]
public __value struct Double : public IComparable, IFormattable,
   IConvertible

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

Double can represent numbers in the range negative 1.79769313486231570E+308 through positive 1.79769313486231570E+308, inclusive. The Double type represents a double precision 64-bit IEEE 754 value. The Common Language Specification (CLS) supports primitive types, including Double.

This class provides some basic coercions:

  • From a Double to various formats of String and the other way around, and
  • From Double a to the other base data types (Single and Object).

These widening coercions result in no loss in precision of magnitude. Note that programming languages are free to provide coercions that extend or differ from these.

Double provides methods and fields that deal with PositiveInfinity and NegativeInfinity, and expressions that evaluate to not a number (NaN).

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

Double Members | System Namespace | Single | String | Object


Double Members

Public:

Methods

CompareTo | Compares this instance to the specified Object.
Equals | Compares this instance with a specified Object.
Format | Overloaded. Converts a numeric value to a String.
FromString | Converts a specified String to a Double.
GetHashCode | Returns the hash code for this Double.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | [To be supplied.]
IsInfinity | Determines whether the specified Double represents infinity.
IsNaN | Determines whether the specified Double is not a number (NaN).
IsNegativeInfinity | Determines whether the specified Double is negative infinity.
IsPositiveInfinity | Determines whether the specified Double is positive infinity.
Parse | Overloaded. Converts a String to a Double.
ToBoolean | [To be supplied.]
ToByte | [To be supplied.]
ToChar | [To be supplied.]
ToDateTime | [To be supplied.]
ToDecimal | [To be supplied.]
ToDouble | [To be supplied.]
ToInt16 | [To be supplied.]
ToInt32 | [To be supplied.]
ToInt64 | [To be supplied.]
ToSByte | [To be supplied.]
ToSingle | [To be supplied.]
ToString | Overloaded. Converts a Double to a String.
ToType | [To be supplied.]
ToUInt16 | [To be supplied.]
ToUInt32 | [To be supplied.]
ToUInt64 | [To be supplied.]

Fields

Empty | Represents the constant Double value of empty.
Epsilon | Represents the constant that is the smallest nonzero Double value.
MaxValue | Represents the constant that is the largest Double value.
MinValue | Represents the constant that is the smallest possible Double value.
NaN | Represents the constant value of not a number (NaN).
NegativeInfinity | Represents the constant value of negative infinity.
PositiveInfinity | Represents the constant value of positive infinity.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Double Structure | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Double Methods

The methods of the Double structure are listed below. For a complete list of Double structure members, see the Double Members topic.

Public:

CompareTo | Compares this instance to the specified Object.
Equals | Compares this instance with a specified Object.
Format | Overloaded. Converts a numeric value to a String.
FromString | Converts a specified String to a Double.
GetHashCode | Returns the hash code for this Double.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | [To be supplied.]
IsInfinity | Determines whether the specified Double represents infinity.
IsNaN | Determines whether the specified Double is not a number (NaN).
IsNegativeInfinity | Determines whether the specified Double is negative infinity.
IsPositiveInfinity | Determines whether the specified Double is positive infinity.
Parse | Overloaded. Converts a String to a Double.
ToBoolean | [To be supplied.]
ToByte | [To be supplied.]
ToChar | [To be supplied.]
ToDateTime | [To be supplied.]
ToDecimal | [To be supplied.]
ToDouble | [To be supplied.]
ToInt16 | [To be supplied.]
ToInt32 | [To be supplied.]
ToInt64 | [To be supplied.]
ToSByte | [To be supplied.]
ToSingle | [To be supplied.]
ToString | Overloaded. Converts a Double to a String.
ToType | [To be supplied.]
ToUInt16 | [To be supplied.]
ToUInt32 | [To be supplied.]
ToUInt64 | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Double Structure | System Namespace


Double.CompareTo

Compares this instance to the specified Object.

[Visual Basic]
Overridable Public Function CompareTo( _
   ByVal value As Object _
) As Integer
[C#]
public virtual int CompareTo(
   object value
);
[C++]
public: virtual int CompareTo(
   Object* value
);
[JScript]
public function CompareTo(
   value : Object
) : int;

Parameters

value
The object to compare with this object.

Return Value

Value | Description
A negative integer | If this instance is less than the object.
Zero | If this instance and the object are equal.
A positive integer | If this instance is greater than the object.
A positive integer | If the object is null. This is a special case.

Exceptions

Exception Type | Condition
ArgumentException | If the object is a non-null reference and is not a Double.

Remarks

In the comparison of two Double values, the canonical ordering is used. As a special case, an instance, regardless of its value, is considered to be greater than a null object reference.

Note false will be returned if NaN. Not a number (NaN) should never be used for comparing.

The value parameter must be a Double type and not a null object reference.

See Also

Double Structure | Double Members | System Namespace | Object | Int32


Double.Equals

Compares this instance with a specified Object.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The object to compare with this instance.

Return Value

true if the object is a Double that equals the specified Object; otherwise, false.

Remarks

The Equals method is a way of determining object equality between two objects. It only returns true if the object is a Double and has the same value as the current instance. The two object references are compared to determine their equality in three areas: value, type, and numbers. If obj and this Double instance are:

  • For Double types, true is returned; otherwise false is returned.
  • For equal value, true is returned; otherwise false is returned.
  • For not a number, false is returned.

Overrides Equals.

Note That false will be returned if NaN. Not a number (NaN) should never be used for comparing.

See Also

Double Structure | Double Members | System Namespace | Object


Double.Format

Converts a numeric value to a String.

Overload List

Converts a numeric value to a String with the default format string.

[Visual Basic] Overloads Public Shared Function Format(Double, String) As String
[C#] public static string Format(double, String);
[C++] public: static String* Format(double, String);
[JScript] public static function Format(double, String) : String;

Converts the value of this instance to a String with the specified format string provided by IServiceObjectProvider.

[Visual Basic] Overloads Overridable Public Function Format(String, IServiceObjectProvider) As String
[C#] public virtual string Format(String, IServiceObjectProvider);
[C++] public: virtual String* Format(String*, IServiceObjectProvider);
[JScript] public function Format(String, IServiceObjectProvider) : String;

Converts a numeric value to a String with the specified format string provided by NumberFormatInfo.

[Visual Basic] Overloads Public Shared Function Format(Double, String, NumberFormatInfo) As String
[C#] public static string Format(double, String, NumberFormatInfo);
[C++] public: static String* Format(double, String, NumberFormatInfo);
[JScript] public static function Format(double, String, NumberFormatInfo) : String;

See Also

Double Structure | Double Members | System Namespace


Double.Format (Double, String)

Converts a numeric value to a String with the default format string.

[Visual Basic]
Overloads Public Shared Function Format( _
   ByVal value As Double, _
   ByVal format As String _
) As String
[C#]
public static string Format(
   double value,
   string format
);
[C++]
public: static String* Format(
   double value,
   String* format
);
[JScript]
public static function Format(
   value : double,
   format : String
) : String;

Parameters

value
The value to be formatted.
format
The format string.

Return Value

A string representation of the number in the specified format.

Remarks

If format is null or an empty string, value is formatted as if the string general format ("G") were specified.

The numeric format information is obtained from the current locale (for more information on numeric formats, see NumberFormatInfo). Various cultures have unquie numberic and currency formating, such as Portugese, Kazakh, or Farsi (for addition information on cultures, see CultureInfo).

See Also

Double Structure | Double Members | System Namespace | Double.Format Overload List | NumberFormatInfo | CultureInfo


Double.Format (String, IServiceObjectProvider)

Converts the value of this instance to a String with the specified format string provided by IServiceObjectProvider.

[Visual Basic]
Overloads Overridable Public Function Format( _
   ByVal format As String, _
   ByVal sp As IServiceObjectProvider _
) As String
[C#]
public virtual string Format(
   string format,
   IServiceObjectProvider sp
);
[C++]
public: virtual String* Format(
   String* format,
   IServiceObjectProvider* sp
);
[JScript]
public function Format(
   format : String,
   sp : IServiceObjectProvider
) : String;

Parameters

format
The format string.
sp
The IServiceObjectProvider used to format the number.

Return Value

A string representation of the number in this instance in the specified format.

Remarks

If format is null or an empty string, the number is formatted as if the string general format ("G") were specified.

The sp parameter specifies the format provider from which the NumberFormatInfo instance will be obtained. NumberFormatInfo supplies information such as the characters to use for decimal and thousand separators, and the spelling and placement of currency symbols in monetary values (see CurrentCulture).

If sp is null, the numeric format information is obtained from the current locale (for additioninformation on cultures, see CultureInfo).

The numeric format information is obtained from the current locale (for more information on numeric formats, see NumberFormatInfo). Various cultures have unquie numberic and currency formating, such as Portugese, Kazakh, or Farsi (for addition information on cultures, see CultureInfo).

See Also

Double Structure | Double Members | System Namespace | Double.Format Overload List | IServiceObjectProvider | String | CultureInfo | NumberFormatInfo


Double.Format (Double, String, NumberFormatInfo)

Converts a numeric value to a String with the specified format string provided by NumberFormatInfo.

[Visual Basic]
Overloads Public Shared Function Format( _
   ByVal value As Double, _
   ByVal format As String, _
   ByVal info As NumberFormatInfo _
) As String
[C#]
public static string Format(
   double value,
   string format,
   NumberFormatInfo info
);
[C++]
public: static String* Format(
   double value,
   String* format,
   NumberFormatInfo* info
);
[JScript]
public static function Format(
   value : double,
   format : String,
   info : NumberFormatInfo
) : String;

Parameters

value
The value to be formatted.
format
The format string.
info
The NumberFormatInfo instance used to format the number.

Return Value

A String representation of the number in the specified format.

Remarks

If format is null or an empty string, value is formatted as if the string "G" (general format) were specified.

The info parameter specifies the NumberFormatInfo instance used to format the number. If info is null, the numeric format information is obtained from the current locale (in addition see CultureInfo).

The NumberFormatInfo supplies information such as the characters to use for decimal and thousand separators, and the spelling and placement of currency symbols in monetary values. (See CultureInfo.)

The numeric format information is obtained from the current locale (for more information on numeric formats, see NumberFormatInfo). Various cultures have unquie numberic and currency formating, such as Portugese, Kazakh, or Farsi (for addition information on cultures, see CultureInfo).

See Also

Double Structure | Double Members | System Namespace | Double.Format Overload List | NumberFormatInfo | CultureInfo


Double.FromString

Converts a specified String to a Double.

[Visual Basic]
Public Shared Function FromString( _
   ByVal s As String _
) As Double
[C#]
public static double FromString(
   string s
);
[C++]
public: static double FromString(
   String* s
);
[JScript]
public static function FromString(
   s : String
) : double;

Parameters

s
A string represention of a Double value.

Return Value

The Double value represented by the specified string.

Exceptions

Exception Type | Condition
ArgumentNullException | If the string is a null reference (in Visual Basic Nothing).
FormatException | If the number is not formatted correctly.

Remarks

This method will not throw an OverflowException. Instead, it returns PositiveInfinity or NegativeInfinity if the number is too large or too small.

This method does a round-trip, to and returned to ToString, because it uses the invariant NumberFormatInfo. Use the Parse method for parse user-dependent or locale-specific strings The default (locale-neutral) NumberFormatInfo is used. (For addition inforamtion about cultures, see CultureInfo.)

The s parameter returns an expected format that is produced as if Format(format, sp) were called with the general ('G') format character and the invariant NumberFormatInfo.

See Also

Double Structure | Double Members | System Namespace | String | Format


Double.GetHashCode

Returns the hash code for this Double.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

A hash code for this instance of Double.

Remarks

The hash code for a Double is the absolute value of the integer representation of that instance of Double.

See Also

Double Structure | Double Members | System Namespace | IHashCodeProvider | Int32


Double.GetTypeCode

[To be supplied.]

[Visual Basic]
Overridable Public Function GetTypeCode() As TypeCode
[C#]
public virtual TypeCode GetTypeCode();
[C++]
public: virtual TypeCode GetTypeCode();
[JScript]
public function GetTypeCode() : TypeCode;

See Also

Double Structure | Double Members | System Namespace


Double.IsInfinity

Determines whether the specified Double represents infinity.

[Visual Basic]
Public Shared Function IsInfinity( _
   ByVal d As Double _
) As Boolean
[C#]
public static bool IsInfinity(
   double d
);
[C++]
public: static bool IsInfinity(
   double d
);
[JScript]
public static function IsInfinity(
   d : double
) : Boolean;

Parameters

d
The Double to examine.

Return Value

true if the number equals PositiveInfinity or NegativeInfinity; otherwise. false.

Remarks

This method is equivalent to the methods IsNegativeInfinity or IsPositiveInfinity.

(In addition see CultureInfo, NumberFormatInfo, PositiveInfinity, NegativeInfinity, and NaN.)

See Also

Double Structure | Double Members | System Namespace


Double.IsNaN

Determines whether the specified Double is not a number (NaN).

[Visual Basic]
Public Shared Function IsNaN( _
   ByVal d As Double _
) As Boolean
[C#]
public static bool IsNaN(
   double d
);
[C++]
public: static bool IsNaN(
   double d
);
[JScript]
public static function IsNaN(
   d : double
) : Boolean;

Parameters

d
The Double to examine.

Return Value

true if the number equals not a number (NaN); otherwise. false.

Remarks

Note when using CompareTo or Equals, false will be returned if NaN is used. IsNaN should never be used for comparison.

(In addition see CultureInfo, NumberFormatInfo, PositiveInfinity, NegativeInfinity, and NaN.)

See Also

Double Structure | Double Members | System Namespace


Double.IsNegativeInfinity

Determines whether the specified Double is negative infinity.

[Visual Basic]
Public Shared Function IsNegativeInfinity( _
   ByVal d As Double _
) As Boolean
[C#]
public static bool IsNegativeInfinity(
   double d
);
[C++]
public: static bool IsNegativeInfinity(
   double d
);
[JScript]
public static function IsNegativeInfinity(
   d : double
) : Boolean;

Parameters

d
The Double to examine.

Return Value

true if the number equals NegativeInfinity; otherwise, false.

Remarks

IsNegativeInfinity determines whether this instance of the Double is the same as the data member NegativeInfinity and returns the evaluation.

(In addition see CultureInfo, NumberFormatInfo, PositiveInfinity, and NaN.)

See Also

Double Structure | Double Members | System Namespace


Double.IsPositiveInfinity

Determines whether the specified Double is positive infinity.

[Visual Basic]
Public Shared Function IsPositiveInfinity( _
   ByVal d As Double _
) As Boolean
[C#]
public static bool IsPositiveInfinity(
   double d
);
[C++]
public: static bool IsPositiveInfinity(
   double d
);
[JScript]
public static function IsPositiveInfinity(
   d : double
) : Boolean;

Parameters

d
The Double to examine.

Return Value

true if the number equals PositiveInfinity; otherwise, false.

Remarks

IsPositiveInfinity determines whether this instance of the Double is the same as the data member PositiveInfinity and returns the evaluation.

(In addition see CultureInfo, NumberFormatInfo, NegativeInfinity, and NaN.)

See Also

Double Structure | Double Members | System Namespace


Double.Parse

Converts a String to a Double.

Overload List

Converts a string to a Double.

[Visual Basic] Overloads Public Shared Function Parse(String) As Double
[C#] public static double Parse(String);
[C++] public: static double Parse(String*);
[JScript] public static function Parse(String) : double;

Converts a String to a Double using the specified style.

[Visual Basic] Overloads Public Shared Function Parse(String, NumberStyles) As Double
[C#] public static double Parse(String, NumberStyles);
[C++] public: static double Parse(String*, NumberStyles);
[JScript] public static function Parse(String, NumberStyles) : double;

Converts a String to a Double with the number format and specified style.

[Visual Basic] Overloads Public Shared Function Parse(String, NumberStyles, NumberFormatInfo) As Double
[C#] public static double Parse(String, NumberStyles, NumberFormatInfo);
[C++] public: static double Parse(String*, NumberStyles, NumberFormatInfo);
[JScript] public static function Parse(String, NumberStyles, NumberFormatInfo) : double;

See Also

Double Structure | Double Members | System Namespace


Double.Parse (String)

Converts a string to a Double.

[Visual Basic]
Overloads Public Shared Function Parse( _
   ByVal s As String _
) As Double
[C#]
public static double Parse(
   string s
);
[C++]
public: static double Parse(
   String* s
);
[JScript]
public static function Parse(
   s : String
) : double;

Parameters

s
The string to convert to a Double.

Return Value

The Double whose value was specified by s.

Exceptions

Exception Type | Condition
ArgumentNullException | If the sting is a null reference (in Visual Basic Nothing).
FormatException | If the string is not the correct format.

Remarks

Double numbers are never beyond the scope of Parse. When the numbers are large, they return positive infinity; when they are small, they return negative infinity.

Note that the Parse methods do not accept not a number (NaN), positive infinity, or negative infinity; instead PositiveInfinity, NegativeInfinity, or NaN will be returned. (For addition information, see PositiveInfinity, NegativeInfinity, and NaN.)

The output from ToString should be consumable by FromString.

The s parameter is a representation of a floating-point number. For example, "123.12 e5" and "123.12e 5" are not acceptable strings for s. The string must consist of an optional minus sign ("-") followed by a sequence of the digits one through nine (0-9).

An exception will be thrown if s does not match one of the following regular expressions:

  • [0-9]*\.[0-9]+;
  • [0-9]*\.[0-9]+e\+[0-9]+;
  • [0-9]*\.[0-9]+e[0-9]+;
  • [0-9]*\.[0-9]+e\-[0-9]+;
  • [0-9]+e\-[0-9]+;
  • [0-9]+e\+[0-9]+;
  • [0-9]+e[0-9]+.

Leading and trailing white space characters are ignored.For specific culture informtion, see CultureInfo and NumberFormatInfo.

See Also

Double Structure | Double Members | System Namespace | Double.Parse Overload List


Double.Parse (String, NumberStyles)

Converts a String to a Double using the specified style.

[Visual Basic]
Overloads Public Shared Function Parse( _
   ByVal s As String, _
   ByVal style As NumberStyles _
) As Double
[C#]
public static double Parse(
   string s,
   NumberStyles style
);
[C++]
public: static double Parse(
   String* s,
   NumberStyles style
);
[JScript]
public static function Parse(
   s : String,
   style : NumberStyles
) : double;

Parameters

s
The string to convert to a Double.
style
The permitted style of the numeric string.

Return Value

A Double with the value represented by s.

Exceptions

Exception Type | Condition
ArgumentException | If the style is not a NumberStyles enumeration.
ArgumentNullException | If the string is a null reference (in Visual Basic Nothing).
FormatException | If the string is not of the correct format.

Remarks

Double numbers are never beyond the scope of Parse. When the numbers are large, they return positive infinity; when they are small, they return negative infinity.

Note that the Parse methods do not accept not a number (NaN), positive infinity, or negative infinity; instead PositiveInfinity, NegativeInfinity, or NaN will be returned. (For addition information, see PositiveInfinity, NegativeInfinity, and NaN.)

The output from ToString should be consumable by FromString.

The numeric format information is obtained from the current locale. (For addition information on cultures, see CultureInfo.)

If s was created by one of the Format methods using C, D, E, F, G, or N as the format specifier, it is guaranteed that s can be parsed when the Any style of NumberStyles is selected.

The style parameter specifies the permitted style of the numeric string. It must be a combination of bit flags from the NumberStyles enumeration.

See Also

Double Structure | Double Members | System Namespace | Double.Parse Overload List | String


Double.Parse (String, NumberStyles, NumberFormatInfo)

Converts a String to a Double with the number format and specified style.

[Visual Basic]
Overloads Public Shared Function Parse( _
   ByVal s As String, _
   ByVal style As NumberStyles, _
   ByVal info As NumberFormatInfo _
) As Double
[C#]
public static double Parse(
   string s,
   NumberStyles style,
   NumberFormatInfo info
);
[C++]
public: static double Parse(
   String* s,
   NumberStyles style,
   NumberFormatInfo* info
);
[JScript]
public static function Parse(
   s : String,
   style : NumberStyles,
   info : NumberFormatInfo
) : double;

Parameters

s
The string to be interpreted.
style
The permitted style of the numeric string.
info
The NumberFormatInfo instance used to format the string.

Return Value

A Double with the value represented by s.

Exceptions

Exception Type | Condition
ArgumentException | If style is not a NumberStyles enumeration.
ArgumentNullException | If the string is a null reference (in Visual Basic Nothing).
FormatException | If the string is not of the correct format.

Remarks

Double numbers are never beyond the scope of Parse. When the numbers are large, they return positive infinity; when they are small, they return negative infinity.

Note that the Parse methods do not accept not a number (NaN), positive infinity, or negative infinity; instead PositiveInfinity, NegativeInfinity, or NaN will be returned. (For addition information, see PositiveInfinity, NegativeInfinity, and NaN.)

The output from ToString should be consumable by FromString.

The numeric format information is obtained from the current locale (for addition information about culturs, see CultureInfo).

If s has been created by one of the Format methods using C, D, E, F, G, or N as the format specifier, it is guaranteed that s

can be parsed when the Any style of NumberStyles is selected.

The style parameter specifies the permitted style of the numeric string. It must be a combination of bit flags from the NumberStyles enumeration.

The info parameter specifies the NumberFormatInfo instance used to format the string. If the info parameter is null, the numeric format information is obtained from the current locale.

See Also

Double Structure | Double Members | System Namespace | Double.Parse Overload List | String


Double.ToBoolean

[To be supplied.]

[Visual Basic]
Overridable Public Function ToBoolean() As Boolean
[C#]
public virtual bool ToBoolean();
[C++]
public: virtual bool ToBoolean();
[JScript]
public function ToBoolean() : Boolean;

See Also

Double Structure | Double Members | System Namespace


Double.ToByte

[To be supplied.]

[Visual Basic]
Overridable Public Function ToByte() As Byte
[C#]
public virtual byte ToByte();
[C++]
public: virtual unsigned char ToByte();
[JScript]
public function ToByte() : Byte;

See Also

Double Structure | Double Members | System Namespace


Double.ToChar

[To be supplied.]

[Visual Basic]
Overridable Public Function ToChar() As Char
[C#]
public virtual char ToChar();
[C++]
public: virtual __wchar_t ToChar();
[JScript]
public function ToChar() : Char;

See Also

Double Structure | Double Members | System Namespace


Double.ToDateTime

[To be supplied.]

[Visual Basic]
Overridable Public Function ToDateTime() As DateTime
[C#]
public virtual DateTime ToDateTime();
[C++]
public: virtual DateTime ToDateTime();
[JScript]
public function ToDateTime() : DateTime;

See Also

Double Structure | Double Members | System Namespace


Double.ToDecimal

[To be supplied.]

[Visual Basic]
Overridable Public Function ToDecimal() As Decimal
[C#]
public virtual Decimal ToDecimal();
[C++]
public: virtual Decimal ToDecimal();
[JScript]
public function ToDecimal() : Decimal;

See Also

Double Structure | Double Members | System Namespace


Double.ToDouble

[To be supplied.]

[Visual Basic]
Overridable Public Function ToDouble() As Double
[C#]
public virtual double ToDouble();
[C++]
public: virtual double ToDouble();
[JScript]
public function ToDouble() : double;

See Also

Double Structure | Double Members | System Namespace


Double.ToInt16

[To be supplied.]

[Visual Basic]
Overridable Public Function ToInt16() As Short
[C#]
public virtual short ToInt16();
[C++]
public: virtual short ToInt16();
[JScript]
public function ToInt16() : Int16;

See Also

Double Structure | Double Members | System Namespace


Double.ToInt32

[To be supplied.]

[Visual Basic]
Overridable Public Function ToInt32() As Integer
[C#]
public virtual int ToInt32();
[C++]
public: virtual int ToInt32();
[JScript]
public function ToInt32() : int;

See Also

Double Structure | Double Members | System Namespace


Double.ToInt64

[To be supplied.]

[Visual Basic]
Overridable Public Function ToInt64() As Long
[C#]
public virtual long ToInt64();
[C++]
public: virtual __int64 ToInt64();
[JScript]
public function ToInt64() : long;

See Also

Double Structure | Double Members | System Namespace


Double.ToSByte

[To be supplied.]

[Visual Basic]
Overridable Public Function ToSByte() As SByte
[C#]
public virtual sbyte ToSByte();
[C++]
public: virtual char ToSByte();
[JScript]
public function ToSByte() : SByte;

See Also

Double Structure | Double Members | System Namespace


Double.ToSingle

[To be supplied.]

[Visual Basic]
Overridable Public Function ToSingle() As Single
[C#]
public virtual float ToSingle();
[C++]
public: virtual float ToSingle();
[JScript]
public function ToSingle() : float;

See Also

Double Structure | Double Members | System Namespace


Double.ToString

Converts a Double to a String.

Overload List

Creates a String representation of the specified Double value.

[Visual Basic] Overloads Public Shared Function ToString(Double) As String
[C#] public static string ToString(double);
[C++] public: static String* ToString(double);
[JScript] public static function ToString(double) : String;

Converts a Double to a String with the value of this instance

[Visual Basic] Overloads Overrides Public Function ToString() As String
[C#] public override string ToString();
[C++] public: override String* ToString();
[JScript] public override function ToString() : String;

See Also

Double Structure | Double Members | System Namespace


Double.ToString (Double)

Creates a String representation of the specified Double value.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal d As Double _
) As String
[C#]
public static string ToString(
   double d
);
[C++]
public: static String* ToString(
   double d
);
[JScript]
public static function ToString(
   d : double
) : String;

Parameters

d
The Double value to be converted to a String representation.

Return Value

A string representation of the specified Double value.

Remarks

The string representation produced does not depend upon the user's settings. Format calls the arguments as if Format(Double d, String format, NumberFormatInfo info). where d is for number, format for the general format ('G') character, and info the invariant NumberFormatInfo. (For addition information about cultures, see CultureInfo.)

To create user-dependent or locale-specific strings, use the Format method with an appropriate NumberFormatInfo object. The following conditions apply:

If d is a Double value, which is not equal to NaN, then d = = FromString is true.

If d is a Double value, such that either-10-17 < d <=-10-4 or 10-4 < = d < 1017, then the result will be a string in the format discussed below (e.g., 0.42 is represented as "0.42"):

  • Suppose d is positive. The string will be composed of the integer part of d, followed by the character '.', followed by the fractional part of d.
  • Suppose d is negative. The string will be composed of the character '-', followed by the integer part of d, followed by the character '.', followed by the fractional part of d.

The representation always uses the least number of digits required to represent the Double value.

If d is a Double value, such that either | d | < 10-4 or | d | > = 1017, then the result will be a string in exponential format as discussed below (e.g., 0.00001234 is represented as "1.234E-5"):

  • Suppose d is positive. Let n be the unique integer such that 10n-1 < = d < 10n. Then 1 < = d/ 10n-1 < 10. The string will be composed of the floor of the mathematical quotient d/ 10n-1, followed by the character '.', followed by the fractional part of the mathematical quotient d/ 10n-1, followed by the character 'E', followed by the character '-', and followed by the integer n.
  • Suppose d is negative. Then the result will be the same as above, except that the floor of the mathematical quotient d/ 10n-1 will be preceded by the character '-'.

The representation always uses the least number of digits required to represent the Double value, in both the mantissa and the exponent.

If d is a Double value equal to NaN, PositiveInfinity, or NegativeInfinity, the result will be "NaN", "Infinity", or "-Infinity", respectively.

See Also

Double Structure | Double Members | System Namespace | Double.ToString Overload List | String


Double.ToString ()

Converts a Double to a String with the value of this instance

[Visual Basic]
Overloads Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

The string representation of this instance.

Remarks

This method calls ToString(double) with the value of this instance.

Overrides ToString.

The output from ToString should be consumable by FromString.

See Also

Double Structure | Double Members | System Namespace | Double.ToString Overload List | Object | Int64


Double.ToType

[To be supplied.]

[Visual Basic]
Overridable Public Function ToType( _
   ByVal type As Type _
) As Object
[C#]
public virtual object ToType(
   Type type
);
[C++]
public: virtual Object* ToType(
   Type* type
);
[JScript]
public function ToType(
   type : Type
) : Object;

Parameters

type
[To be supplied.]

See Also

Double Structure | Double Members | System Namespace


Double.ToUInt16

[To be supplied.]

[Visual Basic]
Overridable Public Function ToUInt16() As UInt16
[C#]
public virtual ushort ToUInt16();
[C++]
public: virtual unsigned short ToUInt16();
[JScript]
public function ToUInt16() : UInt16;

See Also

Double Structure | Double Members | System Namespace


Double.ToUInt32

[To be supplied.]

[Visual Basic]
Overridable Public Function ToUInt32() As UInt32
[C#]
public virtual uint ToUInt32();
[C++]
public: virtual unsigned int ToUInt32();
[JScript]
public function ToUInt32() : UInt32;

See Also

Double Structure | Double Members | System Namespace


Double.ToUInt64

[To be supplied.]

[Visual Basic]
Overridable Public Function ToUInt64() As UInt64
[C#]
public virtual ulong ToUInt64();
[C++]
public: virtual unsigned __int64 ToUInt64();
[JScript]
public function ToUInt64() : UInt64;

See Also

Double Structure | Double Members | System Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Double Fields

The fields of the Double structure are listed below. For a complete list of Double structure members, see the Double Members topic.

Public:

Empty | Represents the constant Double value of empty.
Epsilon | Represents the constant that is the smallest nonzero Double value.
MaxValue | Represents the constant that is the largest Double value.
MinValue | Represents the constant that is the smallest possible Double value.
NaN | Represents the constant value of not a number (NaN).
NegativeInfinity | Represents the constant value of negative infinity.
PositiveInfinity | Represents the constant value of positive infinity.

See Also

Double Structure | System Namespace


Double.Empty

Represents the constant Double value of empty.

[Visual Basic]
Public Const Empty As Double
[C#]
public const double Empty;
[C++]
public: const double Empty;
[JScript]
public var Empty : double;

Remarks

The value of the Empty constant is (double)0.0.

In addition see the Empty method that is the universal zero.

See Also

Double Structure | Double Members | System Namespace


Double.Epsilon

Represents the constant that is the smallest nonzero Double value.

[Visual Basic]
Public Const Epsilon As Double
[C#]
public const double Epsilon;
[C++]
public: const double Epsilon;
[JScript]
public var Epsilon : double;

Remarks

Epsilon represents the granularity of a Double.

The value of Epsilon is 4.94065645841247e-324 (0x1), but some compilers do not parse the number correctly and returns 2*Epsilon (0x2).

See Also

Double Structure | Double Members | System Namespace | Parse


Double.MaxValue

Represents the constant that is the largest Double value.

[Visual Basic]
Public Const MaxValue As Double
[C#]
public const double MaxValue;
[C++]
public: const double MaxValue;
[JScript]
public var MaxValue : double;

Remarks

The value of the MaxValue constant is positive 1.7976931348623157E+308.

See Also

Double Structure | Double Members | System Namespace


Double.MinValue

Represents the constant that is the smallest possible Double value.

[Visual Basic]
Public Const MinValue As Double
[C#]
public const double MinValue;
[C++]
public: const double MinValue;
[JScript]
public var MinValue : double;

Remarks

The MinValue constant is negative 1.7976931348623157E+308.

See Also

Double Structure | Double Members | System Namespace


Double.NaN

Represents the constant value of not a number (NaN).

[Visual Basic]
Public Const NaN As Double
[C#]
public const double NaN;
[C++]
public: const double NaN;
[JScript]
public var NaN : double;

Remarks

The NaN hexadecimal value of this constant is (double)0.0/(double)0.0.

Note false will be returned if . Not a number (NaN) should never be used for comparing (see CompareTo and Equals).

(In addition see CultureInfo, NumberFormatInfo, and NegativeInfinity.)

See Also

Double Structure | Double Members | System Namespace


Double.NegativeInfinity

Represents the constant value of negative infinity.

[Visual Basic]
Public Const NegativeInfinity As Double
[C#]
public const double NegativeInfinity;
[C++]
public: const double NegativeInfinity;
[JScript]
public var NegativeInfinity : double;

Remarks

The NegativeInfinity hexadecimal value of this constant is (double)-1.0/(double)(0.0).

(In addition see CultureInfo, NumberFormatInfo, PositiveInfinity, and NaN.)

See Also

Double Structure | Double Members | System Namespace


Double.PositiveInfinity

Represents the constant value of positive infinity.

[Visual Basic]
Public Const PositiveInfinity As Double
[C#]
public const double PositiveInfinity;
[C++]
public: const double PositiveInfinity;
[JScript]
public var PositiveInfinity : double;

Remarks

The PositiveInfinity hexadecimal value of this constant is (double)1.0/(double)(0.0).

(In addition see CultureInfo, NumberFormatInfo, NegativeInfinity, and NaN.)

See Also

Double Structure | Double Members | System Namespace


DuplicateWaitObjectException Class

Represents an exception that is thrown when for duplicate objects in WaitAll or Wait Any.

Object
Exception
SystemException
ArgumentException
DuplicateWaitObjectException

[Visual Basic]
Public Class DuplicateWaitObjectException
   Inherits ArgumentException
[C#]
public class DuplicateWaitObjectException : ArgumentException
[C++]
public __gc class DuplicateWaitObjectException : public
   ArgumentException
[JScript]
public class DuplicateWaitObjectException extends ArgumentException

Remarks

The DuplicateWaitObjectException is an exception class that is thrown when an object appears more than once in the list of objects in WaitAll or WaitAny.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

DuplicateWaitObjectException Members | System Namespace


DuplicateWaitObjectException Members

Public:

Constructor

DuplicateWaitObjectException Constructor Overloaded. Initializes a new instance of the DuplicateWaitOjbectException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from ArgumentException) | Retrieves the message string for this exception or an empty string if no message is set.
ParamName (inherited from ArgumentException) | Retrieves the name of the parameter that caused this exception to be thrown.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from ArgumentException) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from ArgumentException) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

DuplicateWaitObjectException Class | System Namespace


DuplicateWaitObjectException Constructor

Initializes a new instance of the DuplicateWaitOjbectException class.

Overload List

Initializes a new instance of the DuplicateWaitObjectException class with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public DuplicateWaitObjectException();
[C++] public: DuplicateWaitObjectException();
[JScript] public function DuplicateWaitObjectException();

Initializes a new instance of DuplicateWaitObjectException with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public DuplicateWaitObjectException(String);
[C++] public: DuplicateWaitObjectException(String*);
[JScript] public function DuplicateWaitObjectException(String);

Initializes a new instance of DuplicateWaitObjectException with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, String)
[C#] public DuplicateWaitObjectException(String, String);
[C++] public: DuplicateWaitObjectException(String*, String*);
[JScript] public function DuplicateWaitObjectException(String, String);

See Also

DuplicateWaitObjectException Class | DuplicateWaitObjectException Members | System Namespace


DuplicateWaitObjectException Constructor ()

Initializes a new instance of the DuplicateWaitObjectException class with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public DuplicateWaitObjectException();
[C++]
public: DuplicateWaitObjectException();
[JScript]
public function DuplicateWaitObjectException();

Remarks

DuplicateWaitObjectException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The empty string.

See Also

DuplicateWaitObjectException Class | DuplicateWaitObjectException Members | System Namespace | DuplicateWaitObjectException Constructor Overload List


DuplicateWaitObjectException Constructor (String)

Initializes a new instance of DuplicateWaitObjectException with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal parameterName As String _
)
[C#]
public DuplicateWaitObjectException(
   string parameterName
);
[C++]
public: DuplicateWaitObjectException(
   String* parameterName
);
[JScript]
public function DuplicateWaitObjectException(
   parameterName : String
);

Parameters

parameterName
The message that indicates the reason the exception occurred.

Remarks

DuplicateWaitObjectException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The message string.

See Also

DuplicateWaitObjectException Class | DuplicateWaitObjectException Members | System Namespace | DuplicateWaitObjectException Constructor Overload List


DuplicateWaitObjectException Constructor (String, String)

Initializes a new instance of DuplicateWaitObjectException with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal parameterName As String, _
   ByVal message As String _
)
[C#]
public DuplicateWaitObjectException(
   string parameterName,
   string message
);
[C++]
public: DuplicateWaitObjectException(
   String* parameterName,
   String* message
);
[JScript]
public function DuplicateWaitObjectException(
   parameterName : String,
   message : String
);

Parameters

parameterName
A reference to an exception that is indicative of the problem exception.
message
The message that indicates the reason the exception occurred.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

DuplicateWaitObjectException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | The inner exception.
Message | The message string.

See Also

DuplicateWaitObjectException Class | DuplicateWaitObjectException Members | System Namespace | DuplicateWaitObjectException Constructor Overload List


Empty Class

Represents an empty value.

Object
Empty

[Visual Basic]
NotInheritable Public Class Empty
   Implements ISerializable
[C#]
public sealed class Empty : ISerializable
[C++]
public __gc __sealed class Empty : public ISerializable
[JScript]
public class Empty implements ISerializable

Remarks

Like DBNull and Missing, only one instance of Empty ever exists.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

Empty Members | System Namespace | DBNull | Missing | TBD


Empty Members

Public:

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Empty object.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Returns a String with zero length.

Fields

Value Represents the sole instance of the Empty class.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Empty Class | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Empty Methods

The methods of the Empty class are listed below. For a complete list of Empty class members, see the Empty Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Empty object.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Returns a String with zero length.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Empty Class | System Namespace


Empty.GetObjectData

Implements the ISerializable interface and returns the data needed to serialize the Empty object.

[Visual Basic]
Overridable Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
public: virtual void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
);
[JScript]
public function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);

Parameters

info
A SerializationInfo object containing information required to serialize the Empty object.
context
A StreamingContext object containing the source and destination of the serialized stream associated with the Empty object.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | info is a null reference (in Visual Basic Nothing).

See Also

Empty Class | Empty Members | System Namespace | ISerializable | SerializationInfo | StreamingContext


Empty.ToString

Returns a String with zero length.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

An empty string ("").

See Also

Empty Class | Empty Members | System Namespace | Empty


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Empty Fields

The fields of the Empty class are listed below. For a complete list of Empty class members, see the Empty Members topic.

Public:

Value Represents the sole instance of the Empty class.

See Also

Empty Class | System Namespace


Empty.Value

Represents the sole instance of the Empty class.

[Visual Basic]
Public Shared ReadOnly Value As Empty
[C#]
public static readonly Empty Value;
[C++]
public: static readonly Empty* Value;
[JScript]
public static var Value : Empty;

See Also

Empty Class | Empty Members | System Namespace


EntryPointNotFoundException Class

Represents the exception class for class loading failures.

Object
Exception
SystemException
TypeLoadException
EntryPointNotFoundException

[Visual Basic]
Public Class EntryPointNotFoundException
   Inherits TypeLoadException
[C#]
public class EntryPointNotFoundException : TypeLoadException
[C++]
public __gc class EntryPointNotFoundException : public
   TypeLoadException
[JScript]
public class EntryPointNotFoundException extends TypeLoadException

Remarks

The EntryPointNotFoundException is the exception class for some failed P/Invoke calls.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

EntryPointNotFoundException Members | System Namespace


EntryPointNotFoundException Members

Public:

Constructor

EntryPointNotFoundException Constructor Overloaded. Initializes a new instances of the EntryPointNotFoundException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from TypeLoadException) | Holds the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]
TypeName (inherited from TypeLoadException) | Holds the fully resolved name of the type that resulted in the exception.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from TypeLoadException) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from TypeLoadException) | Sets the SerializationInfo with all of the data needed to serialize the target object.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

EntryPointNotFoundException Class | System Namespace


EntryPointNotFoundException Constructor

Initializes a new instances of the EntryPointNotFoundException class.

Overload List

Initializes a new instance of the EntryPointNotFoundException with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public EntryPointNotFoundException();
[C++] public: EntryPointNotFoundException();
[JScript] public function EntryPointNotFoundException();

Initializes a new instance of EntryPointNotFoundException with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public EntryPointNotFoundException(String);
[C++] public: EntryPointNotFoundException(String*);
[JScript] public function EntryPointNotFoundException(String);

Initializes a new instance of EntryPointNotFoundException with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public EntryPointNotFoundException(String, Exception);
[C++] public: EntryPointNotFoundException(String*, Exception);
[JScript] public function EntryPointNotFoundException(String, Exception);

See Also

EntryPointNotFoundException Class | EntryPointNotFoundException Members | System Namespace


EntryPointNotFoundException Constructor ()

Initializes a new instance of the EntryPointNotFoundException with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public EntryPointNotFoundException();
[C++]
public: EntryPointNotFoundException();
[JScript]
public function EntryPointNotFoundException();

Remarks

EntryPointNotFoundException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The message string.

See Also

EntryPointNotFoundException Class | EntryPointNotFoundException Members | System Namespace | EntryPointNotFoundException Constructor Overload List


EntryPointNotFoundException Constructor (String)

Initializes a new instance of EntryPointNotFoundException with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public EntryPointNotFoundException(
   string message
);
[C++]
public: EntryPointNotFoundException(
   String* message
);
[JScript]
public function EntryPointNotFoundException(
   message : String
);

Parameters

message
The message that indicates the reason why the exception occurred.

Remarks

EntryPointNotFoundException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The message string.

See Also

EntryPointNotFoundException Class | EntryPointNotFoundException Members | System Namespace | EntryPointNotFoundException Constructor Overload List


EntryPointNotFoundException Constructor (String, Exception)

Initializes a new instance of EntryPointNotFoundException with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public EntryPointNotFoundException(
   string message,
   Exception inner
);
[C++]
public: EntryPointNotFoundException(
   String* message,
   Exception* inner
);
[JScript]
public function EntryPointNotFoundException(
   message : String,
   inner : Exception
);

Parameters

message
The message that indicates the reason the exception occurred.
inner
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

EntryPointNotFoundException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | The inner exception.
Message | The message string.

See Also

EntryPointNotFoundException Class | EntryPointNotFoundException Members | System Namespace | EntryPointNotFoundException Constructor Overload List


Enum Class

Provides the base class for enumerations.

Object
ValueType
Enum

[Visual Basic]
Public Class Enum
   Implements IComparable, IFormattable, IConvertible
[C#]
public class Enum : IComparable, IFormattable, IConvertible
[C++]
public __gc class Enum : public IComparable, IFormattable,
   IConvertible
[JScript]
public class Enum implements IComparable, IFormattable,
   IConvertible

Remarks

Enum overrides the virtual methods from Object and ValueType with more appropriate implementations for enumerations.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

Enum Members | System Namespace


Enum Members

Public:

Methods

CompareTo | Compares the current value to that of an object.
Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
Format | Overloaded. Converts an enumeration value to human readable format.
FromString | Overloaded. Converts a string to an enumerated value.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | [To be supplied.]
GetUnderlyingType | Returns the underlying type of the enumeration.
GetValues | Returns the values of the enumeration members of the given Enum.
IsDefined | Determines if a given value (string, value or instance) is one of the defined values of the specified enumeration.
ToBoolean | Converts the current value to a Boolean value based on the underlying type.
ToByte | Converts the current value to an 8-bit unsigned integer based on the underlying type.
ToChar | Converts the current value to a unicode character based on the underlying type.
ToDateTime | Converts the current value to a DateTime based on the underlying type.
ToDecimal | Converts the current value to a Decimal based on the underlying type.
ToDouble | Converts the current value to a double-precision floating point number based on the underlying type.
ToInt16 | Converts the current value to a 16-bit signed integer based on the underlying type.
ToInt32 | Converts the current value to a 32-bit signed integer based on the underlying type.
ToInt64 | Converts the current value to a 64-bit signed integer based on the underlying type.
ToObject | Overloaded. Returns an instance of the given enumeration type set to the given value.
ToSByte | Converts the current value to an 8-bit signed integer based on the underlying type.
ToSingle | Converts the current value to a single-precision floating point number based on the underlying type.
ToString | Returns the decimal value of this instance as a string.
ToType | Converts the current value to a specified type based on the underlying type.
ToUInt16 | Converts the current value to a 16-bit unsigned integer based on the underlying type.
ToUInt32 | Converts the current value to a 32-bit unsigned integer based on the underlying type.
ToUInt64 | Converts the current value to a 64-bit unsigned integer based on the underlying type.

Protected:

Constructor

Enum Constructor Initializes a new instance of the Enum class.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Enum Class | System Namespace


Enum Constructor

Initializes a new instance of the Enum class.

[Visual Basic]
Protected Sub New()
[C#]
protected Enum();
[C++]
protected: Enum();
[JScript]
protected function Enum();

Remarks

This constructor is defined with family access so that only subclasses may create an instance.

One interesting note here is that for unboxed value types this constructor will never be called.

See Also

Enum Class | Enum Members | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Enum Methods

The methods of the Enum class are listed below. For a complete list of Enum class members, see the Enum Members topic.

Public:

CompareTo | Compares the current value to that of an object.
Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
Format | Overloaded. Converts an enumeration value to human readable format.
FromString | Overloaded. Converts a string to an enumerated value.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | [To be supplied.]
GetUnderlyingType | Returns the underlying type of the enumeration.
GetValues | Returns the values of the enumeration members of the given Enum.
IsDefined | Determines if a given value (string, value or instance) is one of the defined values of the specified enumeration.
ToBoolean | Converts the current value to a Boolean value based on the underlying type.
ToByte | Converts the current value to an 8-bit unsigned integer based on the underlying type.
ToChar | Converts the current value to a unicode character based on the underlying type.
ToDateTime | Converts the current value to a DateTime based on the underlying type.
ToDecimal | Converts the current value to a Decimal based on the underlying type.
ToDouble | Converts the current value to a double-precision floating point number based on the underlying type.
ToInt16 | Converts the current value to a 16-bit signed integer based on the underlying type.
ToInt32 | Converts the current value to a 32-bit signed integer based on the underlying type.
ToInt64 | Converts the current value to a 64-bit signed integer based on the underlying type.
ToObject | Overloaded. Returns an instance of the given enumeration type set to the given value.
ToSByte | Converts the current value to an 8-bit signed integer based on the underlying type.
ToSingle | Converts the current value to a single-precision floating point number based on the underlying type.
ToString | Returns the decimal value of this instance as a string.
ToType | Converts the current value to a specified type based on the underlying type.
ToUInt16 | Converts the current value to a 16-bit unsigned integer based on the underlying type.
ToUInt32 | Converts the current value to a 32-bit unsigned integer based on the underlying type.
ToUInt64 | Converts the current value to a 64-bit unsigned integer based on the underlying type.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Enum Class | System Namespace


Enum.CompareTo

Compares the current value to that of an object.

[Visual Basic]
Overridable Public Function CompareTo( _
   ByVal target As Object _
) As Integer
[C#]
public virtual int CompareTo(
   object target
);
[C++]
public: virtual int CompareTo(
   Object* target
);
[JScript]
public function CompareTo(
   target : Object
) : int;

Parameters

target
The object to compare against.

Return Value

A number represtenting the relationship:

Return Value | Description
-1 | The value of this instance is less than the value of target.
0 | The value of this instance is equal to the value of target.
1 | The value of this instance is greater than the value of target.

Exceptions

Exception Type | Condition
ArgumentNullException | The target parameter is a null reference (in Visual Basic Nothing).
ArgumentException | The object is from an enumeration that differs in type from enumType.
ExecutionEngineException | The underlying type of this enumeration is unsupported.

Remarks

If target is not an enumeration type, it is converted to a type compatible with the underlying type of this enumeration before comparison.

See Also

Enum Class | Enum Members | System Namespace


Enum.Format

Converts an enumeration value to human readable format.

Overload List

Converts the current value of this enumeration to human readable format.

[Visual Basic] Overloads Public Function Format() As String
[C#] public string Format();
[C++] public: String* Format();
[JScript] public function Format() : String;

Converts an enumeration value to human readable format.

[Visual Basic] Overloads Public Shared Function Format(Type, Object, String) As String
[C#] public static string Format(Type, Object, String);
[C++] public: static String* Format(Type*, Object, String);
[JScript] public static function Format(Type, Object, String) : String;

Converts an enumeration value to human readable format.

[Visual Basic] Overloads Overridable Public Function Format(String, IServiceObjectProvider) As String
[C#] public virtual string Format(String, IServiceObjectProvider);
[C++] public: virtual String* Format(String*, IServiceObjectProvider);
[JScript] public function Format(String, IServiceObjectProvider) : String;

See Also

Enum Class | Enum Members | System Namespace


Enum.Format ()

Converts the current value of this enumeration to human readable format.

[Visual Basic]
Overloads Public Function Format() As String
[C#]
public string Format();
[C++]
public: String* Format();
[JScript]
public function Format() : String;

Return Value

The current value in human readable format.

Remarks

For PASCAL style enums who's value maps directly the name of the field is returned. For PASCAL style enums who's values do not map directly the decimal value of the field is returned. For BitFlags (indicated by the Flags custom attribute): If for each bit that is set in the value there is a corresponding constant (a pure power of 2), then the OR string (ie "Red | Yellow") is returned. Otherwise, if the value is zero or if you can't create a string that consists of pure powers of 2 OR-ed together, you return a hex value (without the leading "Ox"). That is for example: "000000003".

See Also

Enum Class | Enum Members | System Namespace | Enum.Format Overload List


Enum.Format (Type, Object, String)

Converts an enumeration value to human readable format.

[Visual Basic]
Overloads Public Shared Function Format( _
   ByVal enumType As Type, _
   ByVal value As Object, _
   ByVal format As String _
) As String
[C#]
public static string Format(
   Type enumType,
   object value,
   string format
);
[C++]
public: static String* Format(
   Type* enumType,
   Object* value,
   String* format
);
[JScript]
public static function Format(
   enumType : Type,
   value : Object,
   format : String
) : String;

Parameters

enumType
The enumeration type containing the value to be converted.
value
[To be supplied.]
format
[To be supplied.]

Return Value

The value in human readable format.

Exceptions

Exception Type | Condition
ArgumentNullException | The enumType, value or format parameter is a null reference (in Visual Basic Nothing).
ArgumentException | The enumType parameter is not an Enum type. The value is from an enumeration that differs in type from enumType. The type of value is not an underlying type of, enumType.
FormatException | The format parameter contains an invalid value.

Remarks

The valid format values are:

Item | Description
"G" or "g" | For PASCAL style enums who's value maps directly the name of the field is returned. For PASCAL style enums who's values do not map directly the decimal value of the field is returned. For BitFlags (indicated by the Flags custom attribute): If for each bit that is set in the value there is a corresponding constant (a pure power of 2), then the OR string (ie "Red | Yellow") is returned. Otherwise, if the value is zero or if you can't create a string that consists of pure powers of 2 OR-ed together, you return a hex value (without the leading "Ox"). That is for example: "000000003".
"X" or "x" | Represents the value in hex without the leading 0x.
"D" or "d" | Represents the value in decimal.

See Also

Enum Class | Enum Members | System Namespace | Enum.Format Overload List


Enum.Format (String, IServiceObjectProvider)

Converts an enumeration value to human readable format.

[Visual Basic]
Overloads Overridable Public Function Format( _
   ByVal format As String, _
   ByVal sop As IServiceObjectProvider _
) As String
[C#]
public virtual string Format(
   string format,
   IServiceObjectProvider sop
);
[C++]
public: virtual String* Format(
   String* format,
   IServiceObjectProvider* sop
);
[JScript]
public function Format(
   format : String,
   sop : IServiceObjectProvider
) : String;

Parameters

format
[To be supplied.]
sop
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentNullException | The format parameter is a null reference (in Visual Basic Nothing).
FormatException | The format parameter contains an invalid value.

See Also

Enum Class | Enum Members | System Namespace | Enum.Format Overload List


Enum.FromString

Converts a string to an enumerated value.

Overload List

Converts a string to an enumerated value.

[Visual Basic] Overloads Public Shared Function FromString(Type, String, Boolean) As Object
[C#] public static object FromString(Type, String, bool);
[C++] public: static Object* FromString(Type*, String, bool);
[JScript] public static function FromString(Type, String, Boolean) : Object;

Converts a string to an enumerated value.

[Visual Basic] Overloads Public Shared Function FromString(Type, String) As Object
[C#] public static object FromString(Type, String);
[C++] public: static Object* FromString(Type*, String);
[JScript] public static function FromString(Type, String) : Object;

See Also

Enum Class | Enum Members | System Namespace


Enum.FromString (Type, String, Boolean)

Converts a string to an enumerated value.

[Visual Basic]
Overloads Public Shared Function FromString( _
   ByVal enumType As Type, _
   ByVal value As String, _
   ByVal ignoreCase As Boolean _
) As Object
[C#]
public static object FromString(
   Type enumType,
   string value,
   bool ignoreCase
);
[C++]
public: static Object* FromString(
   Type* enumType,
   String* value,
   bool ignoreCase
);
[JScript]
public static function FromString(
   enumType : Type,
   value : String,
   ignoreCase : Boolean
) : Object;

Parameters

enumType
The enumeration in which to search for the string.
value
[To be supplied.]
ignoreCase
[To be supplied.]

Return Value

The enumerated value as an object.

Exceptions

Exception Type | Condition
ArgumentNullException | The enumType or value parameter is a null reference (in Visual Basic Nothing).
ArgumentException | The enumType parameter is not an Enum type. The string does not correspond to a valid value of the enumeration.

Remarks

Given the string representation of an enumerated name (ie "Red", "Green | Blue"), or value ("1", "12") returns the enumerated value as an object. Case sensitive by default, but if ignoreCase is true, this accepts strings of the form "green" as well.

See Also

Enum Class | Enum Members | System Namespace | Enum.FromString Overload List


Enum.FromString (Type, String)

Converts a string to an enumerated value.

[Visual Basic]
Overloads Public Shared Function FromString( _
   ByVal enumType As Type, _
   ByVal value As String _
) As Object
[C#]
public static object FromString(
   Type enumType,
   string value
);
[C++]
public: static Object* FromString(
   Type* enumType,
   String* value
);
[JScript]
public static function FromString(
   enumType : Type,
   value : String
) : Object;

Parameters

enumType
The enumeration in which to search for the string.
value
[To be supplied.]

Return Value

The enumerated value as an object.

Exceptions

Exception Type | Condition
ArgumentNullException | The enumType or value parameter is a null reference (in Visual Basic Nothing).
ArgumentException | The enumType parameter is not an Enum type. The string does not correspond to a valid value of the enumeration.

Remarks

Given the string representation of an enumerated name (ie "Red", "Green | Blue"), or value ("1", "12") returns the enumerated value as an object. This version of the call is case sensitive.

See Also

Enum Class | Enum Members | System Namespace | Enum.FromString Overload List


Enum.GetTypeCode

[To be supplied.]

[Visual Basic]
Overridable Public Function GetTypeCode() As TypeCode
[C#]
public virtual TypeCode GetTypeCode();
[C++]
public: virtual TypeCode GetTypeCode();
[JScript]
public function GetTypeCode() : TypeCode;

See Also

Enum Class | Enum Members | System Namespace


Enum.GetUnderlyingType

Returns the underlying type of the enumeration.

[Visual Basic]
Public Shared Function GetUnderlyingType( _
   ByVal enumType As Type _
) As Type
[C#]
public static Type GetUnderlyingType(
   Type enumType
);
[C++]
public: static Type* GetUnderlyingType(
   Type* enumType
);
[JScript]
public static function GetUnderlyingType(
   enumType : Type
) : Type;

Parameters

enumType
The enumeration for which to retrieve the type.

Return Value

The underlying type of the enumeration

Exceptions

Exception Type | Condition
ArgumentNullException | The enumType parameter is a null reference (in Visual Basic Nothing).
ArgumentException | The enumType parameter is not an Enum type.

See Also

Enum Class | Enum Members | System Namespace


Enum.GetValues

Returns the values of the enumeration members of the given Enum.

[Visual Basic]
Public Shared Function GetValues( _
   ByVal enumType As Type _
) As Object ()
[C#]
public static object[] GetValues(
   Type enumType
);
[C++]
public: static Object* GetValues(
   Type* enumType
) [];
[JScript]
public static function GetValues(
   enumType : Type
) : Object[];

Parameters

enumType
The enumeration from which to retrieve members.

Return Value

An array of type Object whose elements are the enumeration members of enumType.

Exceptions

Exception Type | Condition
ArgumentNullException | The enumType parameter is a null reference (in Visual Basic Nothing).
ArgumentException | The enumType parameter is not an Enum type.

See Also

Enum Class | Enum Members | System Namespace


Enum.IsDefined

Determines if a given value (string, value or instance) is one of the defined values of the specified enumeration.

[Visual Basic]
Public Shared Function IsDefined( _
   ByVal enumType As Type, _
   ByVal value As Object _
) As Boolean
[C#]
public static bool IsDefined(
   Type enumType,
   object value
);
[C++]
public: static bool IsDefined(
   Type* enumType,
   Object* value
);
[JScript]
public static function IsDefined(
   enumType : Type,
   value : Object
) : Boolean;

Parameters

enumType
The enumeration in which to search for the value.
value
[To be supplied.]

Return Value

true if value is one of the defined values of enumType; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentNullException | The enumType or value parameter is a null reference (in Visual Basic Nothing).
ArgumentException | The enumType parameter is not an Enum type. The value is from an enumeration that differs in type from enumType. The type of value is not an underlying type of, enumType.
ExecutionEngineException | The enumeration has an unsupported underlying type.

See Also

Enum Class | Enum Members | System Namespace


Enum.ToBoolean

Converts the current value to a Boolean value based on the underlying type.

[Visual Basic]
Overridable Public Function ToBoolean() As Boolean
[C#]
public virtual bool ToBoolean();
[C++]
public: virtual bool ToBoolean();
[JScript]
public function ToBoolean() : Boolean;

Exceptions

Exception Type | Condition
InvalidCastException | Always.

Remarks

Currently not implemented. Always throws an exception.

See Also

Enum Class | Enum Members | System Namespace


Enum.ToByte

Converts the current value to an 8-bit unsigned integer based on the underlying type.

[Visual Basic]
Overridable Public Function ToByte() As Byte
[C#]
public virtual byte ToByte();
[C++]
public: virtual unsigned char ToByte();
[JScript]
public function ToByte() : Byte;

Return Value

The converted value.

Remarks

Uses Convert to perform the conversion.

See Also

Enum Class | Enum Members | System Namespace


Enum.ToChar

Converts the current value to a unicode character based on the underlying type.

[Visual Basic]
Overridable Public Function ToChar() As Char
[C#]
public virtual char ToChar();
[C++]
public: virtual __wchar_t ToChar();
[JScript]
public function ToChar() : Char;

Exceptions

Exception Type | Condition
InvalidCastException | Always.

Remarks

Currently not implemented. Always throws an exception.

See Also

Enum Class | Enum Members | System Namespace


Enum.ToDateTime

Converts the current value to a DateTime based on the underlying type.

[Visual Basic]
Overridable Public Function ToDateTime() As DateTime
[C#]
public virtual DateTime ToDateTime();
[C++]
public: virtual DateTime ToDateTime();
[JScript]
public function ToDateTime() : DateTime;

Exceptions

Exception Type | Condition
InvalidCastException | Always.

Remarks

Currently not implemented. Always throws an exception.

See Also

Enum Class | Enum Members | System Namespace


Enum.ToDecimal

Converts the current value to a Decimal based on the underlying type.

[Visual Basic]
Overridable Public Function ToDecimal() As Decimal
[C#]
public virtual Decimal ToDecimal();
[C++]
public: virtual Decimal ToDecimal();
[JScript]
public function ToDecimal() : Decimal;

Exceptions

Exception Type | Condition
InvalidCastException | Always.

Remarks

Currently not implemented. Always throws an exception.

See Also

Enum Class | Enum Members | System Namespace


Enum.ToDouble

Converts the current value to a double-precision floating point number based on the underlying type.

[Visual Basic]
Overridable Public Function ToDouble() As Double
[C#]
public virtual double ToDouble();
[C++]
public: virtual double ToDouble();
[JScript]
public function ToDouble() : double;

Exceptions

Exception Type | Condition
InvalidCastException | Always.

Remarks

Currently not implemented. Always throws an exception.

See Also

Enum Class | Enum Members | System Namespace


Enum.ToInt16

Converts the current value to a 16-bit signed integer based on the underlying type.

[Visual Basic]
Overridable Public Function ToInt16() As Short
[C#]
public virtual short ToInt16();
[C++]
public: virtual short ToInt16();
[JScript]
public function ToInt16() : Int16;

Return Value

The converted value.

Remarks

Uses Convert to perform the conversion.

See Also

Enum Class | Enum Members | System Namespace


Enum.ToInt32

Converts the current value to a 32-bit signed integer based on the underlying type.

[Visual Basic]
Overridable Public Function ToInt32() As Integer
[C#]
public virtual int ToInt32();
[C++]
public: virtual int ToInt32();
[JScript]
public function ToInt32() : int;

Return Value

The converted value.

Remarks

Uses Convert to perform the conversion.

See Also

Enum Class | Enum Members | System Namespace


Enum.ToInt64

Converts the current value to a 64-bit signed integer based on the underlying type.

[Visual Basic]
Overridable Public Function ToInt64() As Long
[C#]
public virtual long ToInt64();
[C++]
public: virtual __int64 ToInt64();
[JScript]
public function ToInt64() : long;

Return Value

The converted value.

Remarks

Uses Convert to perform the conversion.

See Also

Enum Class | Enum Members | System Namespace


Enum.ToObject

Returns an instance of the given enumeration type set to the given value.

Overload List

Returns an instance of the given enumeration type set to the given value.

[Visual Basic] Overloads Public Shared Function ToObject(Type, UInt32) As Object
[C#] public static object ToObject(Type, uint);
[C++] public: static Object* ToObject(Type*, unsigned int);
[JScript] public static function ToObject(Type, UInt32) : Object;

Returns an instance of the given enumeration type set to the given value.

[Visual Basic] Overloads Public Shared Function ToObject(Type, UInt16) As Object
[C#] public static object ToObject(Type, ushort);
[C++] public: static Object* ToObject(Type*, unsigned short);
[JScript] public static function ToObject(Type, UInt16) : Object;

Returns an instance of the given enumeration type set to the given value.

[Visual Basic] Overloads Public Shared Function ToObject(Type, UInt64) As Object
[C#] public static object ToObject(Type, ulong);
[C++] public: static Object* ToObject(Type*, unsigned __int64);
[JScript] public static function ToObject(Type, UInt64) : Object;

Returns an instance of the given enumeration type set to the given value.

[Visual Basic] Overloads Public Shared Function ToObject(Type, Long) As Object
[C#] public static object ToObject(Type, long);
[C++] public: static Object* ToObject(Type*, __int64);
[JScript] public static function ToObject(Type, long) : Object;

Returns an instance of the given enumeration type set to the given value.

[Visual Basic] Overloads Public Shared Function ToObject(Type, Integer) As Object
[C#] public static object ToObject(Type, short);
[C++] public: static Object* ToObject(Type*, short);
[JScript] public static function ToObject(Type, Int16) : Object;

Returns an instance of the given enumeration type set to the given value.

[Visual Basic] Overloads Public Shared Function ToObject(Type, SByte) As Object
[C#] public static object ToObject(Type, sbyte);
[C++] public: static Object* ToObject(Type*, char);
[JScript] public static function ToObject(Type, SByte) : Object;

Returns an instance of the given enumeration type set to the given value.

[Visual Basic] Overloads Public Shared Function ToObject(Type, Byte) As Object
[C#] public static object ToObject(Type, byte);
[C++] public: static Object* ToObject(Type*, unsigned char);
[JScript] public static function ToObject(Type, Byte) : Object;

Returns an instance of the given enumeration type set to the given value.

[Visual Basic] Overloads Public Shared Function ToObject(Type, Integer) As Object
[C#] public static object ToObject(Type, int);
[C++] public: static Object* ToObject(Type*, int);
[JScript] public static function ToObject(Type, int) : Object;

See Also

Enum Class | Enum Members | System Namespace


Enum.ToObject (Type, UInt32)

Returns an instance of the given enumeration type set to the given value.

[Visual Basic]
Overloads Public Shared Function ToObject( _
   ByVal enumType As Type, _
   ByVal value As UInt32 _
) As Object
[C#]
public static object ToObject(
   Type enumType,
   uint value
);
[C++]
public: static Object* ToObject(
   Type* enumType,
   unsigned int value
);
[JScript]
public static function ToObject(
   enumType : Type,
   value : UInt32
) : Object;

Parameters

enumType
The enumeration for which to create a value.
value
[To be supplied.]

Return Value

An instance of the enumeration set to the given value.

Exceptions

Exception Type | Condition
ArgumentNullException | The enumType parameter is a null reference (in Visual Basic Nothing).
ArgumentException | The enumType parameter is not an Enum type.

See Also

Enum Class | Enum Members | System Namespace | Enum.ToObject Overload List


Enum.ToObject (Type, UInt16)

Returns an instance of the given enumeration type set to the given value.

[Visual Basic]
Overloads Public Shared Function ToObject( _
   ByVal enumType As Type, _
   ByVal value As UInt16 _
) As Object
[C#]
public static object ToObject(
   Type enumType,
   ushort value
);
[C++]
public: static Object* ToObject(
   Type* enumType,
   unsigned short value
);
[JScript]
public static function ToObject(
   enumType : Type,
   value : UInt16
) : Object;

Parameters

enumType
The enumeration for which to create a value.
value
[To be supplied.]

Return Value

An instance of the enumeration set to the given value.

Exceptions

Exception Type | Condition
ArgumentNullException | The enumType parameter is a null reference (in Visual Basic Nothing).
ArgumentException | The enumType parameter is not an Enum type.

See Also

Enum Class | Enum Members | System Namespace | Enum.ToObject Overload List


Enum.ToObject (Type, UInt64)

Returns an instance of the given enumeration type set to the given value.

[Visual Basic]
Overloads Public Shared Function ToObject( _
   ByVal enumType As Type, _
   ByVal value As UInt64 _
) As Object
[C#]
public static object ToObject(
   Type enumType,
   ulong value
);
[C++]
public: static Object* ToObject(
   Type* enumType,
   unsigned __int64 value
);
[JScript]
public static function ToObject(
   enumType : Type,
   value : UInt64
) : Object;

Parameters

enumType
The enumeration for which to create a value.
value
[To be supplied.]

Return Value

An instance of the enumeration set to the given value.

Exceptions

Exception Type | Condition
ArgumentNullException | The enumType parameter is a null reference (in Visual Basic Nothing).
ArgumentException | The enumType parameter is not an Enum type.

See Also

Enum Class | Enum Members | System Namespace | Enum.ToObject Overload List


Enum.ToObject (Type, Int64)

Returns an instance of the given enumeration type set to the given value.

[Visual Basic]
Overloads Public Shared Function ToObject( _
   ByVal enumType As Type, _
   ByVal value As Long _
) As Object
[C#]
public static object ToObject(
   Type enumType,
   long value
);
[C++]
public: static Object* ToObject(
   Type* enumType,
   __int64 value
);
[JScript]
public static function ToObject(
   enumType : Type,
   value : long
) : Object;

Parameters

enumType
The enumeration for which to create a value.
value
[To be supplied.]

Return Value

An instance of the enumeration set to the given value.

Exceptions

Exception Type | Condition
ArgumentNullException | The enumType parameter is a null reference (in Visual Basic Nothing).
ArgumentException | The enumType parameter is not an Enum type.

See Also

Enum Class | Enum Members | System Namespace | Enum.ToObject Overload List


Enum.ToObject (Type, Int16)

Returns an instance of the given enumeration type set to the given value.

[Visual Basic]
Overloads Public Shared Function ToObject( _
   ByVal enumType As Type, _
   ByVal value As Short _
) As Object
[C#]
public static object ToObject(
   Type enumType,
   short value
);
[C++]
public: static Object* ToObject(
   Type* enumType,
   short value
);
[JScript]
public static function ToObject(
   enumType : Type,
   value : Int16
) : Object;

Parameters

enumType
The enumeration for which to create a value.
value
[To be supplied.]

Return Value

An instance of the enumeration set to the given value.

Exceptions

Exception Type | Condition
ArgumentNullException | The enumType parameter is a null reference (in Visual Basic Nothing).
ArgumentException | The enumType parameter is not an Enum type.

See Also

Enum Class | Enum Members | System Namespace | Enum.ToObject Overload List


Enum.ToObject (Type, SByte)

Returns an instance of the given enumeration type set to the given value.

[Visual Basic]
Overloads Public Shared Function ToObject( _
   ByVal enumType As Type, _
   ByVal value As SByte _
) As Object
[C#]
public static object ToObject(
   Type enumType,
   sbyte value
);
[C++]
public: static Object* ToObject(
   Type* enumType,
   char value
);
[JScript]
public static function ToObject(
   enumType : Type,
   value : SByte
) : Object;

Parameters

enumType
The enumeration for which to create a value.
value
[To be supplied.]

Return Value

An instance of the enumeration set to the given value.

Exceptions

Exception Type | Condition
ArgumentNullException | The enumType parameter is a null reference (in Visual Basic Nothing).
ArgumentException | The enumType parameter is not an Enum type.

See Also

Enum Class | Enum Members | System Namespace | Enum.ToObject Overload List


Enum.ToObject (Type, Byte)

Returns an instance of the given enumeration type set to the given value.

[Visual Basic]
Overloads Public Shared Function ToObject( _
   ByVal enumType As Type, _
   ByVal value As Byte _
) As Object
[C#]
public static object ToObject(
   Type enumType,
   byte value
);
[C++]
public: static Object* ToObject(
   Type* enumType,
   unsigned char value
);
[JScript]
public static function ToObject(
   enumType : Type,
   value : Byte
) : Object;

Parameters

enumType
The enumeration for which to create a value.
value
[To be supplied.]

Return Value

An instance of the enumeration set to the given value.

Exceptions

Exception Type | Condition
ArgumentNullException | The enumType parameter is a null reference (in Visual Basic Nothing).
ArgumentException | The enumType parameter is not an Enum type.

See Also

Enum Class | Enum Members | System Namespace | Enum.ToObject Overload List


Enum.ToObject (Type, Int32)

Returns an instance of the given enumeration type set to the given value.

[Visual Basic]
Overloads Public Shared Function ToObject( _
   ByVal enumType As Type, _
   ByVal value As Integer _
) As Object
[C#]
public static object ToObject(
   Type enumType,
   int value
);
[C++]
public: static Object* ToObject(
   Type* enumType,
   int value
);
[JScript]
public static function ToObject(
   enumType : Type,
   value : int
) : Object;

Parameters

enumType
The enumeration for which to create a value.
value
[To be supplied.]

Return Value

An instance of the enumeration set to the given value.

Exceptions

Exception Type | Condition
ArgumentNullException | The enumType parameter is a null reference (in Visual Basic Nothing).
ArgumentException | The enumType parameter is not an Enum type.

See Also

Enum Class | Enum Members | System Namespace | Enum.ToObject Overload List


Enum.ToSByte

Converts the current value to an 8-bit signed integer based on the underlying type.

[Visual Basic]
Overridable Public Function ToSByte() As SByte
[C#]
public virtual sbyte ToSByte();
[C++]
public: virtual char ToSByte();
[JScript]
public function ToSByte() : SByte;

Return Value

The converted value.

Remarks

Uses Convert to perform the conversion.

See Also

Enum Class | Enum Members | System Namespace


Enum.ToSingle

Converts the current value to a single-precision floating point number based on the underlying type.

[Visual Basic]
Overridable Public Function ToSingle() As Single
[C#]
public virtual float ToSingle();
[C++]
public: virtual float ToSingle();
[JScript]
public function ToSingle() : float;

Exceptions

Exception Type | Condition
InvalidCastException | Always.

Remarks

Currently not implemented. Always throws an exception.

See Also

Enum Class | Enum Members | System Namespace


Enum.ToString

Returns the decimal value of this instance as a string.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

Enum Class | Enum Members | System Namespace


Enum.ToType

Converts the current value to a specified type based on the underlying type.

[Visual Basic]
Overridable Public Function ToType( _
   ByVal type As Type _
) As Object
[C#]
public virtual object ToType(
   Type type
);
[C++]
public: virtual Object* ToType(
   Type* type
);
[JScript]
public function ToType(
   type : Type
) : Object;

Parameters

type
The type to convert to.

Return Value

The converted value.

Remarks

Uses Convert to perform the conversion.

See Also

Enum Class | Enum Members | System Namespace


Enum.ToUInt16

Converts the current value to a 16-bit unsigned integer based on the underlying type.

[Visual Basic]
Overridable Public Function ToUInt16() As UInt16
[C#]
public virtual ushort ToUInt16();
[C++]
public: virtual unsigned short ToUInt16();
[JScript]
public function ToUInt16() : UInt16;

Return Value

The converted value.

Remarks

Uses Convert to perform the conversion.

See Also

Enum Class | Enum Members | System Namespace


Enum.ToUInt32

Converts the current value to a 32-bit unsigned integer based on the underlying type.

[Visual Basic]
Overridable Public Function ToUInt32() As UInt32
[C#]
public virtual uint ToUInt32();
[C++]
public: virtual unsigned int ToUInt32();
[JScript]
public function ToUInt32() : UInt32;

Return Value

The converted value.

Remarks

Uses Convert to perform the conversion.

See Also

Enum Class | Enum Members | System Namespace


Enum.ToUInt64

Converts the current value to a 64-bit unsigned integer based on the underlying type.

[Visual Basic]
Overridable Public Function ToUInt64() As UInt64
[C#]
public virtual ulong ToUInt64();
[C++]
public: virtual unsigned __int64 ToUInt64();
[JScript]
public function ToUInt64() : UInt64;

Return Value

The converted value.

Remarks

Uses Convert to perform the conversion.

See Also

Enum Class | Enum Members | System Namespace


Environment Class

Provides basic access to environment functionality.

Object
Environment

[Visual Basic]
Public Class Environment
[C#]
public class Environment
[C++]
public __gc class Environment
[JScript]
public class Environment

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

Environment Members | System Namespace


Environment Members

Public:

Properties

CommandLine | A string holding the command line for this process.
CurrentDirectory | Gets and sets the current directory. The original directory is the one from which the process was started.
ExitCode | Gets and sets the exit code of the process. This exit code is used by the Exit method.
NewLine | Returns the appropriate newline string for the given platform.
OSVersion | Returns the operating system name, version, and build number.
StackTrace | Returns stack trace information as a string.
SystemDirectory | Returns the system directory, for example, C:\WinNT\System32.
TickCount | The number of milliseconds that have elapsed since the system was started.
Version | Returns the NGWS frameworks and runtime version and build number.
WorkingSet | Returns the amount of memory physically mapped to the environment's process context.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Exit | Terminates this process with the specified exit code.
ExpandEnvironmentVariables | Expands environment-variable strings and replaces them with their defined values.
GetCommandLineArgs | Returns an array containing the command line arguments for this process.
GetEnvironmentVariable | Gets the specified environment variable.
GetEnvironmentVariables | Returns a Dictionary object containing all environment variables and their values.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLogicalDrives | Retrieves the names of the logical drives on this machine in the form "C:\".
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

AltDirectorySeparatorChar | Provides a platform-specific alternate directory separator character.
DirectorySeparatorChar | Provides a platform-specific directory separator character.
InvalidPathChars | Provides a platform-specific list of invalid characters in a path.
PathSeparator | Provides a platform-specific directory separator character.
VolumeSeparatorChar | Provides a platform-specific volume separator character.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Environment Class | System Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Environment Properties

The properties of the Environment class are listed below. For a complete list of Environment class members, see the Environment Members topic.

Public:

CommandLine | A string holding the command line for this process.
CurrentDirectory | Gets and sets the current directory. The original directory is the one from which the process was started.
ExitCode | Gets and sets the exit code of the process. This exit code is used by the Exit method.
NewLine | Returns the appropriate newline string for the given platform.
OSVersion | Returns the operating system name, version, and build number.
StackTrace | Returns stack trace information as a string.
SystemDirectory | Returns the system directory, for example, C:\WinNT\System32.
TickCount | The number of milliseconds that have elapsed since the system was started.
Version | Returns the NGWS frameworks and runtime version and build number.
WorkingSet | Returns the amount of memory physically mapped to the environment's process context.

See Also

Environment Class | System Namespace


Environment.CommandLine

A string holding the command line for this process.

[Visual Basic]
Public Shared ReadOnly Property CommandLine As String
[C#]
public static string CommandLine {get;}
[C++]
public: __property static String* get_CommandLine();
[JScript]
public static function get CommandLine() : String;

Property Value

The Unicode string holding the command line string.

Remarks

On Windows NT/2000, the name of the executable file does not include the path.

On Windows 95/98, the name of the executable file includes the path. Also, long file names (non-8dot3 names) may be shortened to their 8dot3 representation.

On Windows CE, a NotSupportedException is thrown because Windows CE does not support command-line arguments.

See the code sample given in the GetCommandLineArgs topic.

See Also

Environment Class | Environment Members | System Namespace


Environment.CurrentDirectory

Gets and sets the current directory. The original directory is the one from which the process was started.

[Visual Basic]
Public Shared Property CurrentDirectory As String
[C#]
public static string CurrentDirectory {get; set;}
[C++]
public: __property static String* get_CurrentDirectory();
public: __property static void set_CurrentDirectory(String*);
[JScript]
public static function get CurrentDirectory() : String;
public static function set CurrentDirectory(String);

Property Value

Get returns the current directory.

Set/Let is a string representing the fully qualified path of the current directory.

Exceptions

Exception Type | Condition
ArgumentException | The value passed to set is an empty string ("").
ArgumentNullException | A null value or object is passed to set.
IOException | An I/O error occurs.
DirectoryNotFoundException | The value passed to set specifies a path that cannot be found.
SecurityException | The caller does not have the appropriate permission.

Requirements

NGWS Runtime Security:

SecurityPermissionFlag | Permission to use unmanaged code.
PermissionSet | Full trust required.

See Also

Environment Class | Environment Members | System Namespace


Environment.ExitCode

Gets and sets the exit code of the process. This exit code is used by the Exit method.

[Visual Basic]
Public Shared Property ExitCode As Integer
[C#]
public static int ExitCode {get; set;}
[C++]
public: __property static int get_ExitCode();
public: __property static void set_ExitCode(int);
[JScript]
public static function get ExitCode() : int;
public static function set ExitCode(int);

Property Value

Get returns the exit code as an integer.

Set/Let is an integer representing the exit code.

See Also

Environment Class | Environment Members | System Namespace


Environment.NewLine

Returns the appropriate newline string for the given platform.

[Visual Basic]
Public Shared ReadOnly Property NewLine As String
[C#]
public static string NewLine {get;}
[C++]
public: __property static String* get_NewLine();
[JScript]
public static function get NewLine() : String;

Property Value

Returns\r\n on Win32.

See Also

Environment Class | Environment Members | System Namespace


Environment.OSVersion

Returns the operating system name, version, and build number.

[Visual Basic]
Public Shared ReadOnly Property OSVersion As OperatingSystem
[C#]
public static OperatingSystem OSVersion {get;}
[C++]
public: __property static OperatingSystem* get_OSVersion();
[JScript]
public static function get OSVersion() : OperatingSystem;

Property Value

Returns the operating system name, version, and build number.

Exceptions

Exception Type | Condition
ExecutionEngineException | is thrown if the operating system is not recognized.

See Also

Environment Class | Environment Members | System Namespace


Environment.StackTrace

Returns stack trace information as a string.

[Visual Basic]
Public Shared ReadOnly Property StackTrace As String
[C#]
public static string StackTrace {get;}
[C++]
public: __property static String* get_StackTrace();
[JScript]
public static function get StackTrace() : String;

Property Value

The stack trace information as a string.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | is thrown if the requested stack information is out of range.

See Also

Environment Class | Environment Members | System Namespace


Environment.SystemDirectory

Returns the system directory, for example, C:\WinNT\System32.

[Visual Basic]
Public Shared ReadOnly Property SystemDirectory As String
[C#]
public static string SystemDirectory {get;}
[C++]
public: __property static String* get_SystemDirectory();
[JScript]
public static function get SystemDirectory() : String;

Property Value

A string representing the fully qualified path of the system directory.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Read permission for the directory.

See Also

Environment Class | Environment Members | System Namespace


Environment.TickCount

The number of milliseconds that have elapsed since the system was started.

[Visual Basic]
Public Shared ReadOnly Property TickCount As Integer
[C#]
public static int TickCount {get;}
[C++]
public: __property static int get_TickCount();
[JScript]
public static function get TickCount() : int;

Property Value

The number of milliseconds elapsed since system start.

Remarks

The value is limited to the resolution of the system timer. The elapsed time is stored as an Int32 value. Therefore, the time will wrap around to zero if the system is run continuously for 49.7 days.

Notice this is different from the Tick count in System.DateTime, which is the number of 100-nanosecond intervals that have elapsed since 1/1/0001, 12:00am.

See Also

Environment Class | Environment Members | System Namespace


Environment.Version

Returns the NGWS frameworks and runtime version and build number.

[Visual Basic]
Public Shared ReadOnly Property Version As Version
[C#]
public static Version Version {get;}
[C++]
public: __property static Version* get_Version();
[JScript]
public static function get Version() : Version;

Property Value

A String representation of the current NGWS frameworks and runtime version.

See Also

Environment Class | Environment Members | System Namespace


Environment.WorkingSet

Returns the amount of memory physically mapped to the environment's process context.

[Visual Basic]
Public Shared ReadOnly Property WorkingSet As Integer
[C#]
public static int WorkingSet {get;}
[C++]
public: __property static int get_WorkingSet();
[JScript]
public static function get WorkingSet() : int;

Remarks

If "main" is not void, "main" is returned as the process exit code. If "main" is void, the last value passed in through System.SetExitCode is taken. If System.SetExitCode was not called, 0 is returned as the process exit code.

Requirements

NGWS Runtime Security:

EnvironmentPermissionAccess Read permission for the environment variables.

See Also

Environment Class | Environment Members | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Environment Methods

The methods of the Environment class are listed below. For a complete list of Environment class members, see the Environment Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Exit | Terminates this process with the specified exit code.
ExpandEnvironmentVariables | Expands environment-variable strings and replaces them with their defined values.
GetCommandLineArgs | Returns an array containing the command line arguments for this process.
GetEnvironmentVariable | Gets the specified environment variable.
GetEnvironmentVariables | Returns a Dictionary object containing all environment variables and their values.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLogicalDrives | Retrieves the names of the logical drives on this machine in the form "C:\".
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Environment Class | System Namespace


Environment.Exit

Terminates this process with the specified exit code.

[Visual Basic]
Public Shared Sub Exit( _
   ByVal exitCode As Integer _
)
[C#]
public static void Exit(
   int exitCode
);
[C++]
public: static void Exit(
   int exitCode
);
[JScript]
public static function Exit(
   exitCode : int
);

Parameters

exitCode
exit code to be returned to the OS

Exceptions

Exception Type | Condition
SecurityException | if the caller is not fully trusted. That is, the caller must have an unrestricted PermissionSet.

See Also

Environment Class | Environment Members | System Namespace


Environment.ExpandEnvironmentVariables

Expands environment-variable strings and replaces them with their defined values.

[Visual Basic]
Public Shared Function ExpandEnvironmentVariables( _
   ByVal name As String _
) As String
[C#]
public static string ExpandEnvironmentVariables(
   string name
);
[C++]
public: static String* ExpandEnvironmentVariables(
   String* name
);
[JScript]
public static function ExpandEnvironmentVariables(
   name : String
) : String;

Parameters

name
[To be supplied.]

Return Value

A string with the environment variable replaced by actual values.

Exceptions

Exception Type | Condition
ArgumentException | The return value is zero.
ArgumentNullException | name is null.

Remarks

See Also

Environment Class | Environment Members | System Namespace


Environment.GetCommandLineArgs

Returns an array containing the command line arguments for this process.

[Visual Basic]
Public Shared Function GetCommandLineArgs() As String ()
[C#]
public static string[] GetCommandLineArgs();
[C++]
public: static String* GetCommandLineArgs() [];
[JScript]
public static function GetCommandLineArgs() : String[];

Return Value

The first element in the result is the executable file name, and the following 0 or more elements contain the command-line arguments.

Exceptions

Exception Type | Condition
NotSupportedException | if the system does not support command line arguments.

Remarks

Note that quotes are handled intelligently.

On Windows NT/2000, the name of the executable file does not include the path.

On Windows 95/98, the name of the executable file includes the path. Also, long file names (non-8dot3 names) may be shortened to their 8dot3 representation.

On Windows CE, a NotSupportedException is thrown because Windows CE does not support command-line arguments.

Example

The following Managed C++ example demonstrates the usage of the GetCommandLine and GetCommandLineArgs methods. If this code is placed in a file named gecko.cpp, and compiled as shown in the in-source comment below, the gecko.exe that is produced can be used to both echo the entire command line to the console, and echo the command-line arguments to the console.

[C++]
#import
<mscorlib.dll>

void
main ()
{
    String *line =
Environment::GetCommandLine();
    [managed] String * [] args =
Environment::GetCommandLineArgs();

    Console::WriteLine(L"GetCommandLine()
returns :");
    Console::WriteLine(L"\t{0}",
line);
    Console::WriteLine();

Console::WriteLine(L"GetCommandLineArgs() returns :");
    for(int i = 0; i < args->Length;
i++)
    Console::WriteLine(L"\t{0}",
args[i]);
}

/*
  OUTPUT:

D:\TEST>c:\corsdk\compiler\vc\cl.exe
/EEi /c gecko.cpp
Microsoft
(R) 32-bit C/C++ Optimizing Compiler Vers. 13.00.8565 for 80x86 COM+
Copyright
(C) Microsoft Corp 1984-1999. All rights reserved.

gecko.cpp

D:\TEST>c:\corsdk\compiler\vc\link.exe
/libpath:c:\corsdk\compiler\vc msvccee.lib gecko.obj
Microsoft
(R) Incremental Linker Version 7.00.8565
Copyright
(C) Microsoft Corp 1992-1999. All rights reserved.

D:\TEST>gecko.exe
gecko -any lizard of the family Geckonid, named for the sound the animal
utters.
GetCommandLine()
returns :
        gecko.exe gecko -any lizard of the
family Geckonid, named for the sound the animal utters.

GetCommandLineArgs()
returns :
        gecko.exe
        gecko
        -any
        lizard
        of
        the
        family
        Geckonid,
        named
        for
        the
        sound
        the
        animal
        utters.
*/

See Also

Environment Class | Environment Members | System Namespace


Environment.GetEnvironmentVariable

Gets the specified environment variable.

[Visual Basic]
Public Shared Function GetEnvironmentVariable( _
   ByVal variable As String _
) As String
[C#]
public static string GetEnvironmentVariable(
   string variable
);
[C++]
public: static String* GetEnvironmentVariable(
   String* variable
);
[JScript]
public static function GetEnvironmentVariable(
   variable : String
) : String;

Parameters

variable
the environment variable that is sought

Return Value

The value (in string form) of the system environment variable given. If the specified environment variable is not found, null is returned.

Exceptions

Exception Type | Condition
ArgumentException | variable is null.
SecurityException | The caller does not have EnvironmentPermission with Read access.

See Also

Environment Class | Environment Members | System Namespace


Environment.GetEnvironmentVariables

Returns a Dictionary object containing all environment variables and their values.

[Visual Basic]
Public Shared Function GetEnvironmentVariables() As IDictionary
[C#]
public static IDictionary GetEnvironmentVariables();
[C++]
public: static IDictionary* GetEnvironmentVariables();
[JScript]
public static function GetEnvironmentVariables() : IDictionary;

Return Value

An IDictionary containing all environment variables and their values.

Exceptions

Exception Type | Condition
SecurityException | if the caller does not have EnvironmentPermission with Read access.

See Also

Environment Class | Environment Members | System Namespace


Environment.GetLogicalDrives

Retrieves the names of the logical drives on this machine in the form "C:\".

[Visual Basic]
Public Shared Function GetLogicalDrives() As String ()
[C#]
public static string[] GetLogicalDrives();
[C++]
public: static String* GetLogicalDrives() [];
[JScript]
public static function GetLogicalDrives() : String[];

Return Value

The logical drives on this machine.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.
SecurityException | The caller does not have the required SystemInfoPermission.

Requirements

NGWS Runtime Security:

SecurityPermissionFlag | Permission to use unmanaged code.
EnvironmentPermission | Unrestricted access to environment variables.

See Also

Environment Class | Environment Members | System Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Environment Fields

The fields of the Environment class are listed below. For a complete list of Environment class members, see the Environment Members topic.

Public:

AltDirectorySeparatorChar | Provides a platform-specific alternate directory separator character.
DirectorySeparatorChar | Provides a platform-specific directory separator character.
InvalidPathChars | Provides a platform-specific list of invalid characters in a path.
PathSeparator | Provides a platform-specific directory separator character.
VolumeSeparatorChar | Provides a platform-specific volume separator character.

See Also

Environment Class | System Namespace


Environment.AltDirectorySeparatorChar

Provides a platform-specific alternate directory separator character.

[Visual Basic]
Public Shared ReadOnly AltDirectorySeparatorChar As Char
[C#]
public static readonly char AltDirectorySeparatorChar;
[C++]
public: static readonly __wchar_t AltDirectorySeparatorChar;
[JScript]
public static var AltDirectorySeparatorChar : Char;

Remarks

This is backslash ('\') on Unix, and slash ('/') on Windows and Macintosh operating systems.

See Also

Environment Class | Environment Members | System Namespace


Environment.DirectorySeparatorChar

Provides a platform-specific directory separator character.

[Visual Basic]
Public Shared ReadOnly DirectorySeparatorChar As Char
[C#]
public static readonly char DirectorySeparatorChar;
[C++]
public: static readonly __wchar_t DirectorySeparatorChar;
[JScript]
public static var DirectorySeparatorChar : Char;

Remarks

This is backslash ('\') on Windows, slash ('/') on Unix, and colon (':') on Macintosh operating systems.

See Also

Environment Class | Environment Members | System Namespace


Environment.InvalidPathChars

Provides a platform-specific list of invalid characters in a path.

[Visual Basic]
Public Shared ReadOnly InvalidPathChars() As Char
[C#]
public static readonly char[] InvalidPathChars;
[C++]
public: static readonly __wchar_t* InvalidPathChars[];
[JScript]
public static var InvalidPathChars : Char[];

Remarks

See Also

Environment Class | Environment Members | System Namespace


Environment.PathSeparator

Provides a platform-specific directory separator character.

[Visual Basic]
Public Shared ReadOnly PathSeparator As Char
[C#]
public static readonly char PathSeparator;
[C++]
public: static readonly __wchar_t PathSeparator;
[JScript]
public static var PathSeparator : Char;

Remarks

This is the semicolon (;) by default.

See Also

Environment Class | Environment Members | System Namespace


Environment.VolumeSeparatorChar

Provides a platform-specific volume separator character.

[Visual Basic]
Public Shared ReadOnly VolumeSeparatorChar As Char
[C#]
public static readonly char VolumeSeparatorChar;
[C++]
public: static readonly __wchar_t VolumeSeparatorChar;
[JScript]
public static var VolumeSeparatorChar : Char;

Remarks

This is colon (':') on Windows and Macintosh, and slash ('/') on Unix operating systems. This is mostly useful for parsing paths like "c:\windows" or "MacVolume:System Folder".

See Also

Environment Class | Environment Members | System Namespace


EventArgs Class

The EventArgs is the base class for event data.

Object
EventArgs

[Visual Basic]
Public Class EventArgs
[C#]
public class EventArgs
[C++]
public __gc class EventArgs
[JScript]
public class EventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

EventArgs Members | System Namespace


EventArgs Members

Public:

Constructor

EventArgs Constructor Overloaded. Initializes a new instance of the EventArgs class.

Properties

ExtendedInfo Holds a reference to an object that manages the event's state.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Empty Represents an event with no state. EventArgs.Empty allows for the efficient use of events with no state, as it can be raised efficiently. The value of Empty is an Event with its ExtendedInfo field set to null.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EventArgs Class | System Namespace


EventArgs Constructor

Initializes a new instance of the EventArgs class.

Overload List

Initializes a new instance of the EventArgs class. This constructor is called only by the NGWS runtime.

[Visual Basic] Overloads Public Sub New()
[C#] public EventArgs();
[C++] public: EventArgs();
[JScript] public function EventArgs();

Initializes a new instance of the EventArgs class with the specified state.

[Visual Basic] Overloads Public Sub New(Object)
[C#] public EventArgs(Object);
[C++] public: EventArgs(Object*);
[JScript] public function EventArgs(Object);

See Also

EventArgs Class | EventArgs Members | System Namespace


EventArgs Constructor ()

Initializes a new instance of the EventArgs class. This constructor is called only by the NGWS runtime.

[Visual Basic]
Overloads Public Sub New()
[C#]
public EventArgs();
[C++]
public: EventArgs();
[JScript]
public function EventArgs();

See Also

EventArgs Class | EventArgs Members | System Namespace | EventArgs Constructor Overload List


EventArgs Constructor (Object)

Initializes a new instance of the EventArgs class with the specified state.

[Visual Basic]
Overloads Public Sub New( _
   ByVal extendedInfo As Object _
)
[C#]
public EventArgs(
   object extendedInfo
);
[C++]
public: EventArgs(
   Object* extendedInfo
);
[JScript]
public function EventArgs(
   extendedInfo : Object
);

Parameters

extendedInfo
The state to which to set ExtendedInfo.

Remarks

To be supplied.

See Also

EventArgs Class | EventArgs Members | System Namespace | EventArgs Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EventArgs Properties

The properties of the EventArgs class are listed below. For a complete list of EventArgs class members, see the EventArgs Members topic.

Public:

ExtendedInfo Holds a reference to an object that manages the event's state.

See Also

EventArgs Class | System Namespace


EventArgs.ExtendedInfo

Holds a reference to an object that manages the event's state.

[Visual Basic]
Public ReadOnly Property ExtendedInfo As Object
[C#]
public object ExtendedInfo {get;}
[C++]
public: __property Object* get_ExtendedInfo();
[JScript]
public function get ExtendedInfo() : Object;

See Also

EventArgs Class | EventArgs Members | System Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EventArgs Fields

The fields of the EventArgs class are listed below. For a complete list of EventArgs class members, see the EventArgs Members topic.

Public:

Empty Represents an event with no state. EventArgs.Empty allows for the efficient use of events with no state, as it can be raised efficiently. The value of Empty is an Event with its ExtendedInfo field set to null.

See Also

EventArgs Class | System Namespace


EventArgs.Empty

Represents an event with no state. EventArgs.Empty allows for the efficient use of events with no state, as it can be raised efficiently. The value of Empty is an Event with its ExtendedInfo field set to null.

[Visual Basic]
Public Shared ReadOnly Empty As EventArgs
[C#]
public static readonly EventArgs Empty;
[C++]
public: static readonly EventArgs* Empty;
[JScript]
public static var Empty : EventArgs;

See Also

EventArgs Class | EventArgs Members | System Namespace


EventHandler Delegate

Delegate for Events.

[Visual Basic]
Public Delegate Sub EventHandler( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
public delegate void EventHandler(
   object sender,
   EventArgs e
);
[C++]
public __gc __delegate void EventHandler(
   Object* sender,
   EventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the EventHandler delegate declaration.

Remarks

Every subclass of Delegate and MulticastDelegate has a constructor and an

Invoke method. See the Managed C++ code example given in the

Delegate topic.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

System Namespace


Exception Class

Represents the class that provides information required to handle and process errors.

Object
Exception

[Visual Basic]
Public Class Exception
   Implements ISerializable
[C#]
public class Exception : ISerializable
[C++]
public __gc class Exception : public ISerializable
[JScript]
public class Exception implements ISerializable

Remarks

The Exception class is the base class from which all runtime exceptions inherit. Exceptions are objects that result from abnormal conditions that arise while a program executes.

An object cannot be "thrown" or "caught" unless it inherits from Exception. Most of the classes that inherit from Exception do not implement additional members or provide additional functionality; they simply inherit from Exception. It is the hierarchy of the exception classes, their names, and the information they carry which allows the exceptional conditions to be handled and execution of the code to continue.

The StackTrace property of Exception carries a stack trace that is invaluable for determining where the error occurred. But exceptions carry more information than this; we will discuss in the following paragraphs.

To improve the caller's ability to determine the reason an exception is thrown, it is desirable at times for a method to catch an exception thrown by a helper routine and, then to throw an exception more indicative of the error that has occurred. A new and more meaningful exception can be created, where the inner exception reference can be set to the original exception. This more meaningful exception can be thrown to the caller. Note that with this functionality, it is possible to create a series of linked exceptions that terminates with the exception that was first thrown.

The InnerException property can be used to create and preserve a series of exceptions during exception handling. It can be very helpful for the developer to create a new exception that catches the exception(s) thrown by prior exception(s). The original exception can be captured by the second exception in the InnerException property and provides the code that handles the second exception with additional information that can be used to handle the error appropriately. For example, suppose you have a function that reads a file and formats the data that it reads. The code tries to read from the file, but a FileException is thown. The function catches the FileException and throws a BadFormatException. In this case, the FileException could be saved in the InnerException property of the BadFormatException, enabling the code that catches the BadFormatException to examine the InnerException to discover what caused the initial error.

Exception objects also carry a message that provides details concerning the cause of an exception. This is represented by the Message property. To simplify the task of localization, the message strings carried by the exceptions thrown by the base class library exist in resource files. At run time, a localized message is retrieved by name from the resource file associated with the user's default settings (see the code sample below). Developers are encouraged to use the localized message texts available in the resource files with the base name "mscorlib". This will allow developers to forego the expense of localizing resources, although the messages in these files may not work in every situation. A resource manager for these files is accessible via ResourceManager. There is also a code sample in the reference page for System.ResourceReader that displays the contents of the mscorlib.resources file.

Note: Currently the message strings used by the base class library are in US English (en-us) only, and are stored in the file mscorlib.resources. After this file has been localized, there will be a resource file for each culture: mscorlib_en-us.resources, mscorlib_jpn.resources, mscorlib_de.resources, mscorlib_zh.resources, etc. For details on localized resources, see the Resources in TBD specification and the TBD API.

Finally, to provide the user with extensive information concerning why the exception occurred, the HelpLink property can hold a URL (or URN) to a help file.

Many traditional error-handling systems use pre-defined return values to handle errors. This approach has a couple of downsides.

  • First, methods must return some kind of agreed upon code or value and a lot of conditional logic must be applied in order to react to it.
  • Second, exception values have to be "bubbled up" from calling methods in a given message flow.

For interoperability between legacy systems and the NGWS runtime, every exception has an System.Exception.ErrorCode property that stores by default the associated HRESULT, an integer value that identifies the error that has occurred and is used in COM.

A SetErrorCode method is provided (see the description of this member for the reasoning behind providing a read-only property and set method), allowing the default value to be changed.

The runtime provides a more functional error handling system. Blocks of code may be wrapped in a try block. When an exception occurs in that block, control is passed to a catch block that may be specific to a particular exception or general to a class of exceptions. The exception is passed up the call stack until a handler is found for it. If no handler can be found, the runtime's handler displays the exception name, message and a full stack trace from where it was thrown.

Requirements

Namespace: System

Assembly: mscorlib.dll

Example

The following Managed C++ example demonstrates how resource files are used in order to localize the messages carried by exceptions.

#import <mscorlib.dll>
using namespace Resources;

[managed] class Customers
{

public:
    // The ResourceManager for the
mscorlib.resources file.
    static ResourceManager
*rm = Assembly::SystemResMgr;

    static int _maxIndex =
100;

    /**
     * This method returns
the string at the specified index.
     * The index must be
greater than 0 and less than _maxIndex,
     * otherwise an
exception is thrown. The message to be
     * carried by the
exception is obtained from the
     * mscorlib.resources
file.
     */

    static String *
GetName (int index)
    {
   if (index < 0 ||
index > _maxIndex)
       {
       String *paramName =
L"index";

       //Here we use the
message string identified as ArgumentOutOfRange_ActualValue
       //in the
mscorlib.resources file.
       String *message =
String::Format (rm->GetString (L"ArgumentOutOfRange_ActualValue"),
Int32::Box(index));

       throw new
ArgumentOutOfRangeException (paramName, Int32::Box(index), message);
       }
// do some work here...

   return
L"done";
    }
};

void main ()
{
    // Call GetName with
an invalid index.
    try
    {
       Customers::GetName
(-3);
    }

catch(ArgumentOutOfRangeException *e)
    {

Console::WriteLine(L"Caught:
ArgumentOutOfRangeException\r\n\t{0}", e->Message);
   }

    /**
     * OUTPUT:
     *
     * Caught: ArgumentOutOfRangeException
     *         Actual value was -3
     */

};

See Also

Exception Members | System Namespace


Exception Members

Public:

Constructor

Exception Constructor Overloaded. Initializes a new instance of the Exception class.

Properties

HelpLink | Retrieves a link to the help file associated with this exception.
InnerException | Retrieves a reference to an inner (that may be nested) exception.
Message | Retrieves the message text.
Source | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink | Sets the HelpLink property of this exception.
SetObjectData | Sets the object that contains the context of the data from the source or destination.
ToString | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Constructor

Exception Constructor Overloaded. Initializes a new instance of the Exception class.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult Protected. Returns a HResult.

See Also

Exception Class | System Namespace


Exception Constructor

Initializes a new instance of the Exception class.

Overload List

Initializes a new instance of the Exception class with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public Exception();
[C++] public: Exception();
[JScript] public function Exception();

Initializes a new instance of the Exception class with its message set as specified.

[Visual Basic] Overloads Public Sub New(String)
[C#] public Exception(String);
[C++] public: Exception(String*);
[JScript] public function Exception(String);

Initializes a new instance of the Exception class with its message and its inner exception set as specified.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public Exception(String, Exception);
[C++] public: Exception(String*, Exception);
[JScript] public function Exception(String, Exception);

[To be supplied.]

[Visual Basic] Overloads Protected Sub New(SerializationInfo, StreamingContext)
[C#] protected Exception(SerializationInfo, StreamingContext);
[C++] protected: Exception(SerializationInfo*, StreamingContext);
[JScript] protected function Exception(SerializationInfo, StreamingContext);

See Also

Exception Class | Exception Members | System Namespace


Exception Constructor ()

Initializes a new instance of the Exception class with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public Exception();
[C++]
public: Exception();
[JScript]
public function Exception();

Exceptions

Exception Type | Condition
Exception.InnerException | null
Exception.Message | The empty string.

Remarks

All the derived classes should provide this default constructor.

Note that the stack trace is not started until the exception is thrown.

See Also

Exception Class | Exception Members | System Namespace | Exception Constructor Overload List


Exception Constructor (String)

Initializes a new instance of the Exception class with its message set as specified.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public Exception(
   string message
);
[C++]
public: Exception(
   String* message
);
[JScript]
public function Exception(
   message : String
);

Parameters

message
A message that identifies the reason the exception occurred.

Exceptions

Exception Type | Condition
Exception.InnerException | null
Exception.Message | message.

Remarks

All derived classes should provide a constructor with a parameters list identical to the constructor's list.

See Also

Exception Class | Exception Members | System Namespace | Exception Constructor Overload List


Exception Constructor (String, Exception)

Initializes a new instance of the Exception class with its message and its inner exception set as specified.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public Exception(
   string message,
   Exception innerException
);
[C++]
public: Exception(
   String* message,
   Exception* innerException
);
[JScript]
public function Exception(
   message : String,
   innerException : Exception
);

Parameters

message
A message that identifies the reason the exception occurred.
innerException
A reference to the root cause of an exception.

Exceptions

Exception Type | Condition
Exception.Message | message.
Exception.InnerException | innerException

Remarks

Note that the stack trace is not started until the exception is thrown.

All derived classes should provide a constructor with a parameters list identical to the constructor's list.

When handling exceptions, it is sometimes desirable to throw another exception, which is more indicative of the error that has occurred. In order that the original exception with the information that it carries is not lost, exceptions have a field that can hold a reference to another exception.

See Also

Exception Class | Exception Members | System Namespace | Exception Constructor Overload List


Exception Constructor (SerializationInfo, StreamingContext)

[To be supplied.]

[Visual Basic]
Overloads Protected Sub New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
protected Exception(
   SerializationInfo info,
   StreamingContext context
);
[C++]
protected: Exception(
   SerializationInfo* info,
   StreamingContext context
);
[JScript]
protected function Exception(
   info : SerializationInfo,
   context : StreamingContext
);

Parameters

info
[To be supplied.]
context
[To be supplied.]

See Also

Exception Class | Exception Members | System Namespace | Exception Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Exception Properties

The properties of the Exception class are listed below. For a complete list of Exception class members, see the Exception Members topic.

Public:

HelpLink | Retrieves a link to the help file associated with this exception.
InnerException | Retrieves a reference to an inner (that may be nested) exception.
Message | Retrieves the message text.
Source | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite | [To be supplied.]

See Also

Exception Class | System Namespace


Exception.HelpLink

Retrieves a link to the help file associated with this exception.

[Visual Basic]
Overridable Public ReadOnly Property HelpLink As String
[C#]
public string HelpLink {virtual get;}
[C++]
public: __property virtual String* get_HelpLink();
[JScript]
public function get HelpLink() : String;

Property Value

An URL or URN.

Remarks

The HelpLink property returns a help link that is defined for the exception.

The return value, which represents a help file, should be in the form of a URL (or URN), such as: "file://C:/Applications/Bazzal/help.html#ErrorNum42"

For syntax reasons instead of making this property read-write, a separate set method has been provided. See System.Exception.ErrorCode for a discussion of this design decision.

See Also

Exception Class | Exception Members | System Namespace


Exception.InnerException

Retrieves a reference to an inner (that may be nested) exception.

[Visual Basic]
Overridable Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {virtual get;}
[C++]
public: __property virtual Exception* get_InnerException();
[JScript]
public function get InnerException() : Exception;

Property Value

Read-only.

Remarks

The InnerException property is a reference to an inner exception. This property is set upon initialization of the exception object.

When handling exceptions, it is sometimes desirable to throw another exception that is more indicative of the error that has occurred. In order that the original exception and the information that it carries is not lost, exceptions have a field that can hold a reference to another exception

The InnerException property can be used to create and preserve a series of exceptions during exception handling. It can be very helpful for the developer to create a new exception that catches the exception(s) thrown by prior exception(s). The original exception can be captured by the second exception in the InnerException property, providing the code that handles the second exception with additional information that can be used to handle the error appropriately.

For example, suppose you have a function that reads a file and formats the data that it reads. The code tries to read from the file, but a FileException is thown. The function catches the FileException and throws a BadFormatException. In this case, the FileException could be saved in the InnerException property of the BadFormatException, enabling the code that catches the BadFormatException to examine the InnerException to discover what caused the initial error.

See Also

Exception Class | Exception Members | System Namespace


Exception.Message

Retrieves the message text.

[Visual Basic]
Overridable Public ReadOnly Property Message As String
[C#]
public string Message {virtual get;}
[C++]
public: __property virtual String* get_Message();
[JScript]
public function get Message() : String;

Property Value

Read-only.

Remarks

Every exception carries a message that provides information about the exception, such as why it was thrown. This property retrieves the message text. If the message is null, then the an empty string is returned (see Empty).

See Also

Exception Class | Exception Members | System Namespace


Exception.Source

Retrieves or assigns a string containing the name of the application or the object that has generated the error.

[Visual Basic]
Overridable Public Property Source As String
[C#]
public string Source {virtual get; virtual set;}
[C++]
public: __property virtual String* get_Source();
public: __property virtual void set_Source(String*);
[JScript]
public function get Source() : String;
public function set Source(String);

Property Value

A String containing the name of the application or the object that has generated the error.

Remarks

The Source method returns the source and assigns a string value to the error that has occurred, such as the application name.

See Also

Exception Class | Exception Members | System Namespace


Exception.StackTrace

Retrieves the stack trace, which is valuable for determining where the error occurred.

[Visual Basic]
Overridable Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {virtual get;}
[C++]
public: __property virtual String* get_StackTrace();
[JScript]
public function get StackTrace() : String;

Property Value

The stack trace in String form.

Remarks

By default, the stack trace is captured immediately before an exception object is thrown. However, the stack trace capture mode, as it is called, can be changed via the SetStackTraceCapture method of the System.Runtime class. The System.Runtime.GetStackTrace method of the Runtime class can be used to get the stack trace.

See Also

Exception Class | Exception Members | System Namespace


Exception.TargetSite

[To be supplied.]

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[JScript]
public function get TargetSite() : MethodBase;

See Also

Exception Class | Exception Members | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Exception Methods

The methods of the Exception class are listed below. For a complete list of Exception class members, see the Exception Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink | Sets the HelpLink property of this exception.
SetObjectData | Sets the object that contains the context of the data from the source or destination.
ToString | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Exception Class | System Namespace


Exception.GetBaseException

Returns the original exception that caused that exception and other exceptions linked to it.

[Visual Basic]
Overridable Public Function GetBaseException() As Exception
[C#]
public virtual Exception GetBaseException();
[C++]
public: virtual Exception* GetBaseException();
[JScript]
public function GetBaseException() : Exception;

Return Value

Returns the base exception.

Remarks

The GetBaseException method returns the original exception (inner most), if any, that causes this exception and any other exceptions linked via the InnerException property. The lowest exception is returned for the specified exception.

The GetBaseException method will traverse exceptions using the innerException property (see StackTrace).

See Also

Exception Class | Exception Members | System Namespace


Exception.GetObjectData

Accesses the method that contains the context of the data from the source or destination.

[Visual Basic]
Overridable Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
public: virtual void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
);
[JScript]
public function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);

Parameters

info
The serialized object.
context
[To be supplied.]

Return Value

A serialized object is returned as context by StreamingContext.

Remarks

The GetObjectData method accesses StreamingContext to return the value of the source and/or destination of a given serialized stream. (For more information, see SerializationInfo.)

See Also

Exception Class | Exception Members | System Namespace


Exception.SetHelpLink

Sets the HelpLink property of this exception.

[Visual Basic]
Overridable Public Function SetHelpLink( _
   ByVal helpLink As String _
) As Exception
[C#]
public virtual Exception SetHelpLink(
   string helpLink
);
[C++]
public: virtual Exception* SetHelpLink(
   String* helpLink
);
[JScript]
public function SetHelpLink(
   helpLink : String
) : Exception;

Parameters

helpLink
The string used for the URL or URN.

Return Value

A reference to this instance after setting the specified HelpLink property.

Remarks

SetHelpLink sets the help link for this exception. This should be in an URL or URN form, such as:

"file://C:/Applications Bazzal/help.html#ErrorNum42"

A common usage is given below in the example.

For syntactic reasons, a separate set method has been provided, instead of making the HelpLink property read-write. Please see the discussion for the ErrorCode property for the reason behind this design choice.

Example

throw new
Exception ("Program busted")::SetErrorCode (0x42)::SetHelpLink
("http://foo.com/help.html");

See Also

Exception Class | Exception Members | System Namespace


Exception.SetObjectData

Sets the object that contains the context of the data from the source or destination.

[Visual Basic]
Overridable Public Sub SetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
public virtual void SetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
public: virtual void SetObjectData(
   SerializationInfo* info,
   StreamingContext context
);
[JScript]
public function SetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);

Parameters

info
An object to hold the data.
context
[To be supplied.]

Return Value

The value of the object containing the StreamingContext.

Exceptions

Exception Type | Condition
ArgumentNullException | If the object is null.
System.SerizaliationException | If it isn't a constructor.

Remarks

This method sets the StreamingContext to return the value of the object that holds the source and/or destination of a given serialized stream (see SerializationInfo).

See Also

Exception Class | Exception Members | System Namespace


Exception.ToString

Returns the fully qualified name of this exception and the message held by the Message property.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

Returns the fully qualified class name and message.

Remarks

The ToString method returns the "ClassName: message", where ClassName is the fully qualified class name and message is the exception's message string. If the message string is the empty string, then "ClassName" alone is returned.

See Also

Exception Class | Exception Members | System Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Exception Fields

The fields of the Exception class are listed below. For a complete list of Exception class members, see the Exception Members topic.

Protected:

HResult Protected. Returns a HResult.

See Also

Exception Class | System Namespace


Exception.HResult

Protected. Returns a HResult.

[Visual Basic]
Protected HResult As Integer
[C#]
protected int HResult;
[C++]
protected: int HResult;
[JScript]
protected var HResult : int;

Remarks

HResult is an int that is used within the Execution Engine (see System._HResults). it Check with the virtual memory directory before you rename it because it is protected.

See Also

Exception Class | Exception Members | System Namespace


ExecutionEngineException Class

Represents an exception that is thrown by NGWS runtime when an error internal to the Execution Engine occurs.

Object
Exception
SystemException
CoreException
ExecutionEngineException

[Visual Basic]
NotInheritable Public Class ExecutionEngineException
   Inherits CoreException
[C#]
public sealed class ExecutionEngineException : CoreException
[C++]
public __gc __sealed class ExecutionEngineException : public
   CoreException
[JScript]
public class ExecutionEngineException extends CoreException

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

ExecutionEngineException Members | System Namespace


ExecutionEngineException Members

Public:

Constructor

ExecutionEngineException Constructor Overloaded. Initializes a new instance of the ExecutionEngineException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

ExecutionEngineException Class | System Namespace


ExecutionEngineException Constructor

Initializes a new instance of the ExecutionEngineException class.

Overload List

Initializes a new instance of the ExecutionEngineException with default properties..

[Visual Basic] Overloads Public Sub New()
[C#] public ExecutionEngineException();
[C++] public: ExecutionEngineException();
[JScript] public function ExecutionEngineException();

Initializes a new instance of ExecutionEngineException with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public ExecutionEngineException(String);
[C++] public: ExecutionEngineException(String*);
[JScript] public function ExecutionEngineException(String);

Initializes a new instance of ExecutionEngineException with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public ExecutionEngineException(String, Exception);
[C++] public: ExecutionEngineException(String*, Exception);
[JScript] public function ExecutionEngineException(String, Exception);

See Also

ExecutionEngineException Class | ExecutionEngineException Members | System Namespace


ExecutionEngineException Constructor ()

Initializes a new instance of the ExecutionEngineException with default properties..

[Visual Basic]
Overloads Public Sub New()
[C#]
public ExecutionEngineException();
[C++]
public: ExecutionEngineException();
[JScript]
public function ExecutionEngineException();

Remarks

ExecutionEngineException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The empty string.

See Also

ExecutionEngineException Class | ExecutionEngineException Members | System Namespace | ExecutionEngineException Constructor Overload List


ExecutionEngineException Constructor (String)

Initializes a new instance of ExecutionEngineException with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public ExecutionEngineException(
   string message
);
[C++]
public: ExecutionEngineException(
   String* message
);
[JScript]
public function ExecutionEngineException(
   message : String
);

Parameters

message
The message that indicates the reason the exception occurred.

Remarks

ExecutionEngineException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Conditon
InnerException | null
Message | The message string.

See Also

ExecutionEngineException Class | ExecutionEngineException Members | System Namespace | ExecutionEngineException Constructor Overload List


ExecutionEngineException Constructor (String, Exception)

Initializes a new instance of ExecutionEngineException with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public ExecutionEngineException(
   string message,
   Exception inner
);
[C++]
public: ExecutionEngineException(
   String* message,
   Exception* inner
);
[JScript]
public function ExecutionEngineException(
   message : String,
   inner : Exception
);

Parameters

message
The message that indicates the reason the exception occurred.
inner
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

ExecutionEngineException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Conditon
InnerException | The inner exception.
Message | The message string.

See Also

ExecutionEngineException Class | ExecutionEngineException Members | System Namespace | ExecutionEngineException Constructor Overload List


FieldAccessException Class

Represents an exception that is thrown when there is a failed attempt to access a field.

Object
Exception
SystemException
AccessException
FieldAccessException

[Visual Basic]
Public Class FieldAccessException
   Inherits AccessException
[C#]
public class FieldAccessException : AccessException
[C++]
public __gc class FieldAccessException : public AccessException
[JScript]
public class FieldAccessException extends AccessException

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

FieldAccessException Members | System Namespace


FieldAccessException Members

Public:

Constructor

FieldAccessException Constructor Overloaded. Initializes a new instance of the FieldAccessException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

FieldAccessException Class | System Namespace


FieldAccessException Constructor

Initializes a new instance of the FieldAccessException class.

Overload List

Initializes a new instance of the FieldAccessException with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public FieldAccessException();
[C++] public: FieldAccessException();
[JScript] public function FieldAccessException();

Initializes a new instance of FieldAccessException with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public FieldAccessException(String);
[C++] public: FieldAccessException(String*);
[JScript] public function FieldAccessException(String);

Initializes a new instance of FieldAccessException with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public FieldAccessException(String, Exception);
[C++] public: FieldAccessException(String*, Exception);
[JScript] public function FieldAccessException(String, Exception);

See Also

FieldAccessException Class | FieldAccessException Members | System Namespace


FieldAccessException Constructor ()

Initializes a new instance of the FieldAccessException with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public FieldAccessException();
[C++]
public: FieldAccessException();
[JScript]
public function FieldAccessException();

Remarks

FieldAccessException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The empty string.

See Also

FieldAccessException Class | FieldAccessException Members | System Namespace | FieldAccessException Constructor Overload List


FieldAccessException Constructor (String)

Initializes a new instance of FieldAccessException with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public FieldAccessException(
   string message
);
[C++]
public: FieldAccessException(
   String* message
);
[JScript]
public function FieldAccessException(
   message : String
);

Parameters

message
The message that indicates the reason the exception occurred.

Remarks

FieldAccessException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The message string.

See Also

FieldAccessException Class | FieldAccessException Members | System Namespace | FieldAccessException Constructor Overload List


FieldAccessException Constructor (String, Exception)

Initializes a new instance of FieldAccessException with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public FieldAccessException(
   string message,
   Exception inner
);
[C++]
public: FieldAccessException(
   String* message,
   Exception* inner
);
[JScript]
public function FieldAccessException(
   message : String,
   inner : Exception
);

Parameters

message
The message that indicates the reason the exception occurred.
inner
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

FieldAccessException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Conditon
InnerException | The inner exception.
Message | The message string.

See Also

FieldAccessException Class | FieldAccessException Members | System Namespace | FieldAccessException Constructor Overload List


FlagsAttribute Class

Custom attribute to indicate that the enum should be treated as a bitfield (or set of flags). An IDE can use this information to provide a richer development experience.

Bitfeilds are allowed to be or'ed together; enum values are not.

Object
Attribute
FlagsAttribute

[Visual Basic]
Public Class FlagsAttribute
   Inherits Attribute
[C#]
public class FlagsAttribute : Attribute
[C++]
public __gc class FlagsAttribute : public Attribute
[JScript]
public class FlagsAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

FlagsAttribute Members | System Namespace


FlagsAttribute Members

Public:

Constructor

FlagsAttribute Constructor Initializes a new FlagsAttribute object.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FlagsAttribute Class | System Namespace


FlagsAttribute Constructor

Initializes a new FlagsAttribute object.

[Visual Basic]
Public Sub New()
[C#]
public FlagsAttribute();
[C++]
public: FlagsAttribute();
[JScript]
public function FlagsAttribute();

See Also

FlagsAttribute Class | FlagsAttribute Members | System Namespace


FormatException Class

Represents an exception that is thrown when the format of an argument does not match the contract of its method.

Object
Exception
SystemException
FormatException

[Visual Basic]
Public Class FormatException
   Inherits SystemException
[C#]
public class FormatException : SystemException
[C++]
public __gc class FormatException : public SystemException
[JScript]
public class FormatException extends SystemException

Remarks

For example, a method may have a parameter of type String that is required to consist of a single digit followed by a period that is followed by a single digit. Passing the method a string that contains merely two digits would cause a FormatException to be thrown.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

FormatException Members | System Namespace


FormatException Members

Public:

Constructor

FormatException Constructor Overloaded. Initializes a new instance of the FormatException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

FormatException Class | System Namespace


FormatException Constructor

Initializes a new instance of the FormatException class.

Overload List

Initializes a new instance of the FormatException with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public FormatException();
[C++] public: FormatException();
[JScript] public function FormatException();

Initializes a new instance of FormatException with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public FormatException(String);
[C++] public: FormatException(String*);
[JScript] public function FormatException(String);

Initializes a new instance of FormatException with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public FormatException(String, Exception);
[C++] public: FormatException(String*, Exception);
[JScript] public function FormatException(String, Exception);

See Also

FormatException Class | FormatException Members | System Namespace


FormatException Constructor ()

Initializes a new instance of the FormatException with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public FormatException();
[C++]
public: FormatException();
[JScript]
public function FormatException();

Remarks

FormatException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Conditon
InnerException | null
Message | The empty string.

See Also

FormatException Class | FormatException Members | System Namespace | FormatException Constructor Overload List


FormatException Constructor (String)

Initializes a new instance of FormatException with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public FormatException(
   string message
);
[C++]
public: FormatException(
   String* message
);
[JScript]
public function FormatException(
   message : String
);

Parameters

message
The message that indicates the reason the exception occurred.

Remarks

FormatException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The message string.

See Also

FormatException Class | FormatException Members | System Namespace | FormatException Constructor Overload List


FormatException Constructor (String, Exception)

Initializes a new instance of FormatException with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public FormatException(
   string message,
   Exception inner
);
[C++]
public: FormatException(
   String* message,
   Exception* inner
);
[JScript]
public function FormatException(
   message : String,
   inner : Exception
);

Parameters

message
The message that indicates the reason the exception occurred.
inner
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

FormatException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | The inner exeption.
Message | The message string.

See Also

FormatException Class | FormatException Members | System Namespace | FormatException Constructor Overload List


GC Class

Provides methods for interacting with the memory management system, which performs garbage collection (GC) of objects that are no longer needed.

Object
GC

[Visual Basic]
NotInheritable Public Class GC
[C#]
public sealed class GC
[C++]
public __gc __sealed class GC
[JScript]
public class GC

Remarks

A new instance of this class cannot be created.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

GC Members | System Namespace


GC Members

Public:

Properties

MaxGeneration | The number of generations the system currently supports.
TotalMemory | The amount of space in bytes currently allocated to objects that are thought to be alive. This may include space that is soon to be freed.

Methods

Collect | Overloaded. Forces a collection of all generations.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetGeneration | Overloaded. Returns the generation in which an object resides.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
KeepAlive | [To be supplied.]
RequestFinalizeOnShutdown | [To be supplied.]
ReRegisterForFinalize | Indicates that the system should call the Finalize method on an object for which SuppressFinalize has already been called.
RunFinalizers | Forces all unreachable objects to have their Finalize methods called.
SuppressFinalize | Indicates that the system should not call the Finalize method on a specified object that would normally require this call.
ToString (inherited from Object) | Returns a String that represents the current Object.
WaitForPendingFinalizers | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GC Class | System Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

GC Properties

The properties of the GC class are listed below. For a complete list of GC class members, see the GC Members topic.

Public:

MaxGeneration | The number of generations the system currently supports.
TotalMemory | The amount of space in bytes currently allocated to objects that are thought to be alive. This may include space that is soon to be freed.

See Also

GC Class | System Namespace


GC.MaxGeneration

The number of generations the system currently supports.

[Visual Basic]
Public Shared ReadOnly Property MaxGeneration As Integer
[C#]
public static int MaxGeneration {get;}
[C++]
public: __property static int get_MaxGeneration();
[JScript]
public static function get MaxGeneration() : int;

Property Value

The number of generations the system currently supports.

See Also

GC Class | GC Members | System Namespace


GC.TotalMemory

The amount of space in bytes currently allocated to objects that are thought to be alive. This may include space that is soon to be freed.

[Visual Basic]
Public Shared ReadOnly Property TotalMemory As Integer
[C#]
public static int TotalMemory {get;}
[C++]
public: __property static int get_TotalMemory();
[JScript]
public static function get TotalMemory() : int;

Property Value

The number of bytes currently allocated.

Exceptions

Exception Type | Condition
SecurityException | is thrown if the caller doesn't have SystemInfoPermission.

See Also

GC Class | GC Members | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

GC Methods

The methods of the GC class are listed below. For a complete list of GC class members, see the GC Members topic.

Public:

Collect | Overloaded. Forces a collection of all generations.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetGeneration | Overloaded. Returns the generation in which an object resides.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
KeepAlive | [To be supplied.]
RequestFinalizeOnShutdown | [To be supplied.]
ReRegisterForFinalize | Indicates that the system should call the Finalize method on an object for which SuppressFinalize has already been called.
RunFinalizers | Forces all unreachable objects to have their Finalize methods called.
SuppressFinalize | Indicates that the system should not call the Finalize method on a specified object that would normally require this call.
ToString (inherited from Object) | Returns a String that represents the current Object.
WaitForPendingFinalizers | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GC Class | System Namespace


GC.Collect

Forces a collection of all generations.

Overload List

Forces a collection of generations from 0 through a specified generation.

[Visual Basic] Overloads Public Shared Sub Collect(Integer)
[C#] public static void Collect(int);
[C++] public: static void Collect(int);
[JScript] public static function Collect(int);

Forces a collection of all generations.

[Visual Basic] Overloads Public Shared Sub Collect()
[C#] public static void Collect();
[C++] public: static void Collect();
[JScript] public static function Collect();

See Also

GC Class | GC Members | System Namespace


GC.Collect (Int32)

Forces a collection of generations from 0 through a specified generation.

[Visual Basic]
Overloads Public Shared Sub Collect( _
   ByVal generation As Integer _
)
[C#]
public static void Collect(
   int generation
);
[C++]
public: static void Collect(
   int generation
);
[JScript]
public static function Collect(
   generation : int
);

Parameters

generation
The maximum generation to collect.

Exceptions

Exception Type | Condition
ArgumentException | is thrown if generation is less than 0 or greater than GetMaxGeneration().

See Also

GC Class | GC Members | System Namespace | GC.Collect Overload List


GC.Collect ()

Forces a collection of all generations.

[Visual Basic]
Overloads Public Shared Sub Collect()
[C#]
public static void Collect();
[C++]
public: static void Collect();
[JScript]
public static function Collect();

Exceptions

Exception Type | Condition
SecurityException | is thrown if the caller doesn't have SystemInfoPermission.

See Also

GC Class | GC Members | System Namespace | GC.Collect Overload List


GC.GetGeneration

Returns the generation in which an object resides.

Overload List

Returns the generation that a specified object is currently in.

[Visual Basic] Overloads Public Shared Function GetGeneration(Object) As Integer
[C#] public static int GetGeneration(Object);
[C++] public: static int GetGeneration(Object*);
[JScript] public static function GetGeneration(Object) : int;

Returns the generation in which a weak reference currently resides.

[Visual Basic] Overloads Public Shared Function GetGeneration(WeakReference) As Integer
[C#] public static int GetGeneration(WeakReference);
[C++] public: static int GetGeneration(WeakReference*);
[JScript] public static function GetGeneration(WeakReference) : int;

See Also

GC Class | GC Members | System Namespace


GC.GetGeneration (Object)

Returns the generation that a specified object is currently in.

[Visual Basic]
Overloads Public Shared Function GetGeneration( _
   ByVal obj As Object _
) As Integer
[C#]
public static int GetGeneration(
   object obj
);
[C++]
public: static int GetGeneration(
   Object* obj
);
[JScript]
public static function GetGeneration(
   obj : Object
) : int;

Parameters

obj
The object for which to get generation information.

Return Value

he generation that obj is currently in.

See Also

GC Class | GC Members | System Namespace | GC.GetGeneration Overload List


GC.GetGeneration (WeakReference)

Returns the generation in which a weak reference currently resides.

[Visual Basic]
Overloads Public Shared Function GetGeneration( _
   ByVal wo As WeakReference _
) As Integer
[C#]
public static int GetGeneration(
   WeakReference wo
);
[C++]
public: static int GetGeneration(
   WeakReference* wo
);
[JScript]
public static function GetGeneration(
   wo : WeakReference
) : int;

Parameters

wo
The weak reference for which to find the generation.

Return Value

The generation in which wo currently resides.

Exceptions

Exception Type | Condition
ArgumentException | is thrown if wo has already been collected.

Remarks

To be supplied.

See Also

GC Class | GC Members | System Namespace | GC.GetGeneration Overload List


GC.KeepAlive

[To be supplied.]

[Visual Basic]
Public Shared Sub KeepAlive( _
   ByVal obj As Object _
)
[C#]
public static void KeepAlive(
   object obj
);
[C++]
public: static void KeepAlive(
   Object* obj
);
[JScript]
public static function KeepAlive(
   obj : Object
);

Parameters

obj
[To be supplied.]

See Also

GC Class | GC Members | System Namespace


GC.RequestFinalizeOnShutdown

[To be supplied.]

[Visual Basic]
Public Shared Sub RequestFinalizeOnShutdown()
[C#]
public static void RequestFinalizeOnShutdown();
[C++]
public: static void RequestFinalizeOnShutdown();
[JScript]
public static function RequestFinalizeOnShutdown();

See Also

GC Class | GC Members | System Namespace


GC.ReRegisterForFinalize

Indicates that the system should call the Finalize method on an object for which SuppressFinalize has already been called.

[Visual Basic]
Public Shared Sub ReRegisterForFinalize( _
   ByVal obj As Object _
)
[C#]
public static void ReRegisterForFinalize(
   object obj
);
[C++]
public: static void ReRegisterForFinalize(
   Object* obj
);
[JScript]
public static function ReRegisterForFinalize(
   obj : Object
);

Parameters

obj
The object that should be re-registered for finalize.

Remarks

The other situation where calling ReRegisterForFinalize is useful is inside a finalizer that needs to resurrect itself or an object that it references.

See Also

GC Class | GC Members | System Namespace


GC.RunFinalizers

Forces all unreachable objects to have their Finalize methods called.

[Visual Basic]
Public Shared Sub RunFinalizers()
[C#]
public static void RunFinalizers();
[C++]
public: static void RunFinalizers();
[JScript]
public static function RunFinalizers();

See Also

GC Class | GC Members | System Namespace


GC.SuppressFinalize

Indicates that the system should not call the Finalize method on a specified object that would normally require this call.

[Visual Basic]
Public Shared Sub SuppressFinalize( _
   ByVal obj As Object _
)
[C#]
public static void SuppressFinalize(
   object obj
);
[C++]
public: static void SuppressFinalize(
   Object* obj
);
[JScript]
public static function SuppressFinalize(
   obj : Object
);

Parameters

obj
The object whose Finalize method should not be called.

See Also

GC Class | GC Members | System Namespace


GC.WaitForPendingFinalizers

[To be supplied.]

[Visual Basic]
Public Shared Sub WaitForPendingFinalizers()
[C#]
public static void WaitForPendingFinalizers();
[C++]
public: static void WaitForPendingFinalizers();
[JScript]
public static function WaitForPendingFinalizers();

See Also

GC Class | GC Members | System Namespace


Guid Structure

Represents a globally unique identifier (GUID). GUIDs can be used wherever a unique identifier is required.

Object
ValueType
Guid

[Visual Basic]
Public Structure Guid
   Implements IFormattable
[C#]
public struct Guid : IFormattable
[C++]
public __value struct Guid : public IFormattable

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

A GUID is a 128-bit integer with such a low probability of being duplicated that it is, for all practical purposes, unique.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

Guid Members | System Namespace


Guid Members

Public:

Constructor

Guid Constructor Overloaded. Initializes a new instance of the Guid class.

Methods

Equals | Determines whether the specified Guid is equal to this instance.
Format | [To be supplied.]
GetHashCode | Returns the first 32 bits (4 bytes) of the Guid.
GetType (inherited from Object) | Gets the Type of the Object.
NewGuid | Forms a new GUID.
NextGuid | Creates a new Guid object that is the next one in the range.
ToByteArray | Returns a 16-element unsigned byte array that represents the GUID.
ToString | Returns the Guid in registry format. This format is as follows (note the lowercase): {ffffffff-ffff-ffff-ffff-ffffffffffff}

Operators

Equality Operator | [To be supplied.]
Inequality Operator | [To be supplied.]

Fields

Empty Holds an "empty" Guid, which has all its bytes set to 0.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Guid Structure | System Namespace


Guid Constructor

Initializes a new instance of the Guid class.

Overload List

Initializes a new instance of the Guid class using the specified Byte array.

[Visual Basic] Overloads Public Sub New(Byte())
[C#] public Guid(byte[]);
[C++] public: Guid(unsigned char*[]);
[JScript] public function Guid(Byte[]);

Initializes a new instance of the Guid class based on the values of the specified arguments.

[Visual Basic] Overloads Public Sub New(UInt32, UInt16, UInt16, Byte, Byte, Byte, Byte, Byte, Byte, Byte, Byte)
[C#] public Guid(uint, ushort, ushort, byte, byte, byte, byte, byte, byte, byte, byte);
[C++] public: Guid(unsigned int, unsigned short, unsigned short, unsigned char, unsigned char, unsigned char, unsigned char, unsigned char, unsigned char, unsigned char, unsigned char);
[JScript] public function Guid(UInt32, UInt16, UInt16, Byte, Byte, Byte, Byte, Byte, Byte, Byte, Byte);

Initializes a new instance of the Guid class based on the value of a specified string.

[Visual Basic] Overloads Public Sub New(String)
[C#] public Guid(String);
[C++] public: Guid(String*);
[JScript] public function Guid(String);

Initializes a new instance of the Guid class based on the values of the specified arguments.

[Visual Basic] Overloads Public Sub New(Integer, Integer, Integer, Byte())
[C#] public Guid(int, short, short, byte[]);
[C++] public: Guid(int, short, short, unsigned char[]);
[JScript] public function Guid(int, Int16, Int16, Byte[]);

Initializes a new instance of the Guid class based on the values of the specified arguments.

[Visual Basic] Overloads Public Sub New(Integer, Integer, Integer, Byte, Byte, Byte, Byte, Byte, Byte, Byte, Byte)
[C#] public Guid(int, short, short, byte, byte, byte, byte, byte, byte, byte, byte);
[C++] public: Guid(int, short, short, unsigned char, unsigned char, unsigned char, unsigned char, unsigned char, unsigned char, unsigned char, unsigned char);
[JScript] public function Guid(int, Int16, Int16, Byte, Byte, Byte, Byte, Byte, Byte, Byte, Byte);

Example

Guid(a,b,c,0,1,2,3,4,5,6,7) creates a Guid that corresponds to "0000000a-000b-000c-0001-020304050607".

See Also

Guid Structure | Guid Members | System Namespace


Guid Constructor (Byte[])

Initializes a new instance of the Guid class using the specified Byte array.

[Visual Basic]
Overloads Public Sub New( _
   ByVal b() As Byte _
)
[C#]
public Guid(
   byte[] b
);
[C++]
public: Guid(
   unsigned char* b[]
);
[JScript]
public function Guid(
   b : Byte[]
);

Parameters

b
An unsigned byte array of length 16 to use to initialize the GUID.

Exceptions

Exception Type | Condition
ArgumentException | is thrown if b is not 16 bytes long.
ArgumentNullException | if b is null.

See Also

Guid Structure | Guid Members | System Namespace | Guid Constructor Overload List


Guid Constructor (UInt32, UInt16, UInt16, Byte, Byte, Byte, Byte, Byte, Byte, Byte, Byte)

Initializes a new instance of the Guid class based on the values of the specified arguments.

[Visual Basic]
Overloads Public Sub New( _
   ByVal a As UInt32, _
   ByVal b As UInt16, _
   ByVal c As UInt16, _
   ByVal d As Byte, _
   ByVal e As Byte, _
   ByVal f As Byte, _
   ByVal g As Byte, _
   ByVal h As Byte, _
   ByVal i As Byte, _
   ByVal j As Byte, _
   ByVal k As Byte _
)
[C#]
public Guid(
   uint a,
   ushort b,
   ushort c,
   byte d,
   byte e,
   byte f,
   byte g,
   byte h,
   byte i,
   byte j,
   byte k
);
[C++]
public: Guid(
   unsigned int a,
   unsigned short b,
   unsigned short c,
   unsigned char d,
   unsigned char e,
   unsigned char f,
   unsigned char g,
   unsigned char h,
   unsigned char i,
   unsigned char j,
   unsigned char k
);
[JScript]
public function Guid(
   a : UInt32,
   b : UInt16,
   c : UInt16,
   d : Byte,
   e : Byte,
   f : Byte,
   g : Byte,
   h : Byte,
   i : Byte,
   j : Byte,
   k : Byte
);

Parameters

a
The first 4 bytes of the GUID.
b
The next 2 bytes of the GUID.
c
The next byte of the GUID.
d
The next byte of the GUID.
e
The next byte of the GUID.
f
The next byte of the GUID.
g
The next byte of the GUID.
h
The next byte of the GUID.
i
The next byte of the GUID.
j
The next byte of the GUID.
k
The next byte of the GUID.

Remarks

Specifying the bytes in this manner avoids endianness issues.

Example

Guid(a,b,c,0,1,2,3,4,5,6,7) creates a Guid that corresponds to "0000000a-000b-000c-0001-020304050607".

See Also

Guid Structure | Guid Members | System Namespace | Guid Constructor Overload List


Guid Constructor (String)

Initializes a new instance of the Guid class based on the value of a specified string.

[Visual Basic]
Overloads Public Sub New( _
   ByVal g As String _
)
[C#]
public Guid(
   string g
);
[C++]
public: Guid(
   String* g
);
[JScript]
public function Guid(
   g : String
);

Parameters

g
A String that contains a GUID in the following format: hexadecimal digits are arranged in groups of 8, 4, 4, 4, and 12 digits with hyphens between the groups, as follows: dddddddd-dddd-dddd-dddd-dddddddddddd or {dddddddd-dddd-dddd-dddd-dddddddddddd}.

Alternatively, the following format is permitted: {0xdddddddd,0xdddd, 0xdddd,{0xdd},{0xdd},{0xdd},{0xdd},{0xdd},{0xdd},{0xdd},{0xdd}}, where d is a hexadecimal digit. If this format is used, all brackets and commas indicated are required, and all numbers must be prefixed with "0x" as shown. Fewer hexadecimal digits than shown may be used, but no more.

Exceptions

Exception Type | Condition
ArgumentNullException | if g is null.
FormatException The length of g is invalid. The length should be 38 if'{' and'}' are used, and 36 otherwise (counting digits and dashes).

The first (or last) character in g is'{' but the last ( or first) character is not'}'.

g contains'-' in the wrong places. The expected format is 8 hexadecimal digits followed by a dash, followed by 4 then a dash, followed by 4 then a dash, followed by 4 then a dash, followed by 12.

g contains improperly grouped hexadecimal digits. The expected format is 8 hexadecimal digits followed by a dash, followed by 4 then a dash, followed by 4 then a dash, followed by 4 then a dash, followed by 12.

Any element in g does not represent a valid hexadecimal number.

Remarks

The string may begin and end with braces: "{", and "}."

Example

The following strings are valid for g:

"CA761232-ED42-11CE-BACD-00AA0057B223"

or

"{CA761232-ED42-11CE-BACD-00AA0057B223}"

See Also

Guid Structure | Guid Members | System Namespace | Guid Constructor Overload List


Guid Constructor (Int32, Int16, Int16, Byte[])

Initializes a new instance of the Guid class based on the values of the specified arguments.

[Visual Basic]
Overloads Public Sub New( _
   ByVal a As Integer, _
   ByVal b As Short, _
   ByVal c As Short, _
   ByVal d() As Byte _
)
[C#]
public Guid(
   int a,
   short b,
   short c,
   byte[] d
);
[C++]
public: Guid(
   int a,
   short b,
   short c,
   unsigned char* d[]
);
[JScript]
public function Guid(
   a : int,
   b : Int16,
   c : Int16,
   d : Byte[]
);

Parameters

a
The first 4 bytes of the GUID.
b
The next 2 bytes of the GUID.
c
The next 2 bytes of the GUID.
d
The remaining 8 bytes of the GUID.

Exceptions

Exception Type | Condition
ArgumentException | is thrown if the byte array is not 8 bytes long.
ArgumentNullException | if d is null.

Remarks

The string may begin and end with braces: "{", and "}."

Example

Guid(1,2,3, {0, 1,2,3,4,5,6,7}) creates a Guid that corresponds to "00000001-0002-0003-0001-020304050607".

See Also

Guid Structure | Guid Members | System Namespace | Guid Constructor Overload List


Guid Constructor (Int32, Int16, Int16, Byte, Byte, Byte, Byte, Byte, Byte, Byte, Byte)

Initializes a new instance of the Guid class based on the values of the specified arguments.

[Visual Basic]
Overloads Public Sub New( _
   ByVal a As Integer, _
   ByVal b As Short, _
   ByVal c As Short, _
   ByVal d As Byte, _
   ByVal e As Byte, _
   ByVal f As Byte, _
   ByVal g As Byte, _
   ByVal h As Byte, _
   ByVal i As Byte, _
   ByVal j As Byte, _
   ByVal k As Byte _
)
[C#]
public Guid(
   int a,
   short b,
   short c,
   byte d,
   byte e,
   byte f,
   byte g,
   byte h,
   byte i,
   byte j,
   byte k
);
[C++]
public: Guid(
   int a,
   short b,
   short c,
   unsigned char d,
   unsigned char e,
   unsigned char f,
   unsigned char g,
   unsigned char h,
   unsigned char i,
   unsigned char j,
   unsigned char k
);
[JScript]
public function Guid(
   a : int,
   b : Int16,
   c : Int16,
   d : Byte,
   e : Byte,
   f : Byte,
   g : Byte,
   h : Byte,
   i : Byte,
   j : Byte,
   k : Byte
);

Parameters

a
The first 4 bytes of the GUID.
b
The next 2 bytes of the GUID.
c
The next byte of the GUID.
d
The next byte of the GUID.
e
The next byte of the GUID.
f
The next byte of the GUID.
g
The next byte of the GUID.
h
The next byte of the GUID.
i
The next byte of the GUID.
j
The next byte of the GUID.
k
The next byte of the GUID.

Remarks

Specifying the bytes in this manner avoids endianness issues.

Example

Guid(a,b,c,0,1,2,3,4,5,6,7) creates a Guid that corresponds to "0000000a-000b-000c-0001-020304050607".

See Also

Guid Structure | Guid Members | System Namespace | Guid Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Guid Methods

The methods of the Guid structure are listed below. For a complete list of Guid structure members, see the Guid Members topic.

Public:

Equals | Determines whether the specified Guid is equal to this instance.
Format | [To be supplied.]
GetHashCode | Returns the first 32 bits (4 bytes) of the Guid.
GetType (inherited from Object) | Gets the Type of the Object.
NewGuid | Forms a new GUID.
NextGuid | Creates a new Guid object that is the next one in the range.
ToByteArray | Returns a 16-element unsigned byte array that represents the GUID.
ToString | Returns the Guid in registry format. This format is as follows (note the lowercase): {ffffffff-ffff-ffff-ffff-ffffffffffff}

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Guid Structure | System Namespace


Guid.Equals

Determines whether the specified Guid is equal to this instance.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal o As Object _
) As Boolean
[C#]
public override bool Equals(
   object o
);
[C++]
public: override bool Equals(
   Object* o
);
[JScript]
public override function Equals(
   o : Object
) : Boolean;

Parameters

o
The Guid object to compare with this instance.

Return Value

true if o is a Guid that has the same value as this instance; false otherwise.

Remarks

Overrides Object.Equals.

See Also

Guid Structure | Guid Members | System Namespace


Guid.Format

[To be supplied.]

[Visual Basic]
Overridable Public Function Format( _
   ByVal format As String, _
   ByVal sop As IServiceObjectProvider _
) As String
[C#]
public virtual string Format(
   string format,
   IServiceObjectProvider sop
);
[C++]
public: virtual String* Format(
   String* format,
   IServiceObjectProvider* sop
);
[JScript]
public function Format(
   format : String,
   sop : IServiceObjectProvider
) : String;

Parameters

format
[To be supplied.]
sop
[To be supplied.]

See Also

Guid Structure | Guid Members | System Namespace


Guid.GetHashCode

Returns the first 32 bits (4 bytes) of the Guid.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

The first 32 bits of the Guid as an Int32.

Remarks

Overrides Object.GetHashCode. The first 32 bits of the GUID are those that change most frequently.

See Also

Guid Structure | Guid Members | System Namespace


Guid.NewGuid

Forms a new GUID.

[Visual Basic]
Public Shared Function NewGuid() As Guid
[C#]
public static Guid NewGuid();
[C++]
public: static Guid NewGuid();
[JScript]
public static function NewGuid() : Guid;

Return Value

Remarks

See Also

Guid Structure | Guid Members | System Namespace


Guid.NextGuid

Creates a new Guid object that is the next one in the range.

[Visual Basic]
Public Function NextGuid() As Guid
[C#]
public Guid NextGuid();
[C++]
public: Guid NextGuid();
[JScript]
public function NextGuid() : Guid;

Return Value

Returns the next Guid object in the range.

Remarks

The leading int 4 byte value is incremented by one. The behavior of this method is the same as the behavior of guidgen.exe.

See Also

Guid Structure | Guid Members | System Namespace


Guid.ToByteArray

Returns a 16-element unsigned byte array that represents the GUID.

[Visual Basic]
Public Function ToByteArray() As Byte ()
[C#]
public byte[] ToByteArray();
[C++]
public: unsigned char* ToByteArray() [];
[JScript]
public function ToByteArray() : Byte[];

Return Value

A 16-element unsigned byte array.

See Also

Guid Structure | Guid Members | System Namespace


Guid.ToString

Returns the Guid in registry format. This format is as follows (note the lowercase):

{ffffffff-ffff-ffff-ffff-ffffffffffff}

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

The GUID in registry format. Give an example: 382c74c3-721d-4f34-80e5-57657b6cbc27

Remarks

Overrides Object.ToString.

See Also

Guid Structure | Guid Members | System Namespace


Operators

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Guid Operators

The operators of the Guid structure are listed below. For a complete list of Guid structure members, see the Guid Members topic.

Public:

Equality Operator | [To be supplied.]
Inequality Operator | [To be supplied.]

See Also

Guid Structure | System Namespace


Guid Equality Operator

[To be supplied.]

[C#]
public static bool operator ==(
   Guid a,
   Guid b
);
[C++]
public: static bool operator op_Equality(
   Guid a,
   Guid b
);
[JScript]
returnValue = a == b;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

a
[To be supplied.]
b
[To be supplied.]

Parameters [C#, C++]

a
[To be supplied.]
b
[To be supplied.]

See Also

Guid Structure | Guid Members | System Namespace


Guid Inequality Operator

[To be supplied.]

[C#]
public static bool operator !=(
   Guid a,
   Guid b
);
[C++]
public: static bool operator op_Inequality(
   Guid a,
   Guid b
);
[JScript]
returnValue = a ! = b;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

a
[To be supplied.]
b
[To be supplied.]

Parameters [C#, C++]

a
[To be supplied.]
b
[To be supplied.]

See Also

Guid Structure | Guid Members | System Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Guid Fields

The fields of the Guid structure are listed below. For a complete list of Guid structure members, see the Guid Members topic.

Public:

Empty Holds an "empty" Guid, which has all its bytes set to 0.

See Also

Guid Structure | System Namespace


Guid.Empty

Holds an "empty" Guid, which has all its bytes set to 0.

[Visual Basic]
Public Shared ReadOnly Empty As Guid
[C#]
public static readonly Guid Empty;
[C++]
public: static readonly Guid Empty;
[JScript]
public static var Empty : Guid;

See Also

Guid Structure | Guid Members | System Namespace


IAsyncResult Interface

IAsyncResult

[Visual Basic]
Public Interface IAsyncResult
[C#]
public interface IAsyncResult
[C++]
public __gc __interface IAsyncResult

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IAsyncResult

Class | Description
AsyncResult | A helper class used to wrap an async result when implementing an async method that delegates to another async method. See System.IAsyncResult
HttpAsyncResult | [To be supplied.]

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

IAsyncResult Members | System Namespace


IAsyncResult Members

Properties

AsyncObject
AsyncState
AsyncWaitHandle The AsyncWaitHandle property returns the WaitHandle that can use to perform a WaitHandle.WaitOne or WaitAny or WaitAll. The object which implements IAsyncResult need not derive from the System.WaitHandle classes directly. The WaitHandle wraps its underlying synchronization primitive and should be signaled after the call is completed. This enables the client to wait for the call to complete instead polling. The Runtime supplies a number of waitable objects that mirror Win32 synchronization primitives e.g. ManualResetEvent, AutoResetEvent and Mutex.

WaitHandle supplies methods that support waiting for such synchronization objects to become signaled with "any" or "all" semantics i.e. WaitHandle.WaitOne, WaitAny and WaitAll. Such methods are context aware to avoid deadlocks. The AsyncWaitHandle can be allocated eagerly or on demand. It is the choice of the IAsyncResult implementer.

Implementors of classes that return IAsyncResult should note the following: The AsyncWaitHandle can be lazily allocated. However once allocated it should be kept alive until the user calls EndXXXX. At that time the object behind AsyncWaitHandle can be recycled.
CompletedSynchronously
IsCompleted

See Also

IAsyncResult Interface | System Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IAsyncResult Properties

The properties of the IAsyncResult interface are listed below. For a complete list of IAsyncResult interface members, see the IAsyncResult Members topic.

AsyncObject
AsyncState
AsyncWaitHandle The AsyncWaitHandle property returns the WaitHandle that can use to perform a WaitHandle.WaitOne or WaitAny or WaitAll. The object which implements IAsyncResult need not derive from the System.WaitHandle classes directly. The WaitHandle wraps its underlying synchronization primitive and should be signaled after the call is completed. This enables the client to wait for the call to complete instead polling. The Runtime supplies a number of waitable objects that mirror Win32 synchronization primitives e.g. ManualResetEvent, AutoResetEvent and Mutex.

WaitHandle supplies methods that support waiting for such synchronization objects to become signaled with "any" or "all" semantics i.e. WaitHandle.WaitOne, WaitAny and WaitAll. Such methods are context aware to avoid deadlocks. The AsyncWaitHandle can be allocated eagerly or on demand. It is the choice of the IAsyncResult implementer.

Implementors of classes that return IAsyncResult should note the following: The AsyncWaitHandle can be lazily allocated. However once allocated it should be kept alive until the user calls EndXXXX. At that time the object behind AsyncWaitHandle can be recycled.
CompletedSynchronously
IsCompleted

See Also

IAsyncResult Interface | System Namespace


IAsyncResult.AsyncObject

[Visual Basic]
ReadOnly Property AsyncObject As Object
[C#]
object AsyncObject {get;}
[C++]
Object* get_AsyncObject() = 0;
[JScript]
abstract function get AsyncObject() : Object;

See Also

IAsyncResult Interface | IAsyncResult Members | System Namespace


IAsyncResult.AsyncState

[Visual Basic]
ReadOnly Property AsyncState As Object
[C#]
object AsyncState {get;}
[C++]
Object* get_AsyncState() = 0;
[JScript]
abstract function get AsyncState() : Object;

See Also

IAsyncResult Interface | IAsyncResult Members | System Namespace


IAsyncResult.AsyncWaitHandle

The AsyncWaitHandle property returns the WaitHandle that can use to perform a WaitHandle.WaitOne or WaitAny or WaitAll. The object which implements IAsyncResult need not derive from the System.WaitHandle classes directly. The WaitHandle wraps its underlying synchronization primitive and should be signaled after the call is completed. This enables the client to wait for the call to complete instead polling. The Runtime supplies a number of waitable objects that mirror Win32 synchronization primitives e.g. ManualResetEvent, AutoResetEvent and Mutex.

WaitHandle supplies methods that support waiting for such synchronization objects to become signaled with "any" or "all" semantics i.e. WaitHandle.WaitOne, WaitAny and WaitAll. Such methods are context aware to avoid deadlocks. The AsyncWaitHandle can be allocated eagerly or on demand. It is the choice of the IAsyncResult implementer.

Implementors of classes that return IAsyncResult should note the following: The AsyncWaitHandle can be lazily allocated. However once allocated it should be kept alive until the user calls EndXXXX. At that time the object behind AsyncWaitHandle can be recycled.

[Visual Basic]
ReadOnly Property AsyncWaitHandle As WaitHandle
[C#]
WaitHandle AsyncWaitHandle {get;}
[C++]
WaitHandle* get_AsyncWaitHandle() = 0;
[JScript]
abstract function get AsyncWaitHandle() : WaitHandle;

See Also

IAsyncResult Interface | IAsyncResult Members | System Namespace


IAsyncResult.CompletedSynchronously

[Visual Basic]
ReadOnly Property CompletedSynchronously As Boolean
[C#]
bool CompletedSynchronously {get;}
[C++]
bool get_CompletedSynchronously() = 0;
[JScript]
abstract function get CompletedSynchronously() : Boolean;

See Also

IAsyncResult Interface | IAsyncResult Members | System Namespace


IAsyncResult.IsCompleted

[Visual Basic]
ReadOnly Property IsCompleted As Boolean
[C#]
bool IsCompleted {get;}
[C++]
bool get_IsCompleted() = 0;
[JScript]
abstract function get IsCompleted() : Boolean;

See Also

IAsyncResult Interface | IAsyncResult Members | System Namespace


ICloneable Interface

Supports cloning, which creates a new instance of a type with the same value as an existing instance. Only objects that implement ICloneable can be cloned.

ICloneable

[Visual Basic]
Public Interface ICloneable
[C#]
public interface ICloneable
[C++]
public __gc __interface ICloneable

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement ICloneable

Class | Description
ADOParameter | Represents a parameter to an ADOCommand and, optionally, its mapping to DataSet columns.
Array | Provides methods for creating, manipulating, searching, and sorting arrays. This is the base class for all arrays in the system.
ArrayList | Implements the IList interface using an array whose size is dynamically increased as required.
AssemblyName | This class fully describes an assembly's unique identity. An assembly's identity consists of several pieces of information including a simple textual name, a version number, a cryptographic key pair, and supported culture.
BaseConfigCollection | A generic implementation of the IConfigCollection interface.
BaseConfigItem | A generic implementation of the IConfigItem interface.
Brush | Classes derrived from this abstract base class define objects used to fill the interiors of graphical shapes such as rectangles, ellipses, pies, polygons, and paths.
ColumnHeader | Displays a single column header in a ListView control.
CustomLineCap | [To be supplied.]
DataColumnMapping | generic column mapping
DataSetCommand | Represents a set of data commands and a database connection which are used to fill the DataSet and update the data source. At any time, the object refers to only a single record within the current data set.
DataTableMapping | [To be supplied.]
DateTimeFormatInfo | [To be supplied.]
DBCommand | Represents a query command used when connecting to a data source.
DBConnection | Represents a database connection for use by DBCommand.
Delegate | Represents a delegate, which is a data structure that refers to a static method or to an object instance and an instance method of that object.
Font | [To be supplied.]
GraphicsPath | Represents a series of connected lines and curves.
Hashtable | Represents a collection of associated keys and values that are organized based on the hash code of the key.
Icon | This class represents a Windows icon, which is a small bitmap image used to represent an object. Icons can be thought of as transparent bitmaps, although their size is determined by the system.
Image | [To be supplied.]
ImageAttributes | [To be supplied.]
ListItem | Implements an item of a ListView.
Margins | Specifies the margins of a printed page.
NumberFormatInfo | [To be supplied.]
OperatingSystem | Contains information about an operating system version. The information includes major version number, minor version numbers, a build number, a platform identifier, and descriptive text about the operating system.
PageSettings | Settings that apply to a single page.
Pen | Defines an object used to draw lines and curves.
PrinterSettings | Information about how a document should be printed, including which printer to print it on.
SortedList | Represents a collection of associated keys and values, which are sorted by the keys and are accessible both by key and by index.
SQLParameter | Represents a parameter to an SQLCommand and, optionally, its mapping to DataSet columns.
String | Represents a static string of characters.
StringFormat | [To be supplied.]
TreeNode | Implements a node of a TreeView.
Version | Represents the version number for a NGWS runtime assembly.
XmlNavigator | Reads and writes XML data using a cursor model. This class is abstract.
XmlNode | Represents a single node in the document.
XmlNode | The XmlNode class is the abstract base class of all XML node classes.

Remarks

The ICloneable interface contains one member, Clone, which is intended to support cloning beyond that supplied by MemberwiseClone.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

ICloneable Members | System Namespace


ICloneable Members

Methods

Clone Creates a new object that is a copy of the current instance.

See Also

ICloneable Interface | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICloneable Methods

The methods of the ICloneable interface are listed below. For a complete list of ICloneable interface members, see the ICloneable Members topic.

Clone Creates a new object that is a copy of the current instance.

See Also

ICloneable Interface | System Namespace


ICloneable.Clone

Creates a new object that is a copy of the current instance.

[Visual Basic]
Function Clone() As Object
[C#]
object Clone();
[C++]
Object* Clone() = 0;
[JScript]
function Clone() : Object;

Return Value

A new object that is a copy of this instance.

Remarks

Clone may be implemented either as a deep copy or a shallow copy. In a deep copy, all objects are duplicated; whereas, in a shallow copy, only the top-level objects are duplicated and the lower levels contain references.

See Also

ICloneable Interface | ICloneable Members | System Namespace


IComparable Interface

Provides functionality to compare objects and to sort arrays and collections.

IComparable

[Visual Basic]
Public Interface IComparable
[C#]
public interface IComparable
[C++]
public __gc __interface IComparable

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IComparable

Class | Description
Enum | Provides the base class for enumerations.
String | Represents a static string of characters.
Version | Represents the version number for a NGWS runtime assembly.

Remarks

Classes which can be set in a ranking order, such as the base data types, support IComparable.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

IComparable Members | System Namespace


IComparable Members

Methods

CompareTo When implemented by a class, compares the current instance with another instance of the same type.

See Also

IComparable Interface | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IComparable Methods

The methods of the IComparable interface are listed below. For a complete list of IComparable interface members, see the IComparable Members topic.

CompareTo When implemented by a class, compares the current instance with another instance of the same type.

See Also

IComparable Interface | System Namespace


IComparable.CompareTo

When implemented by a class, compares the current instance with another instance of the same type.

[Visual Basic]
Function CompareTo( _
   ByVal object As Object _
) As Integer
[C#]
int CompareTo(
   object object
);
[C++]
int CompareTo(
   Object* object
) = 0;
[JScript]
function CompareTo(
   object : Object
) : int;

Parameters

object
The Object to compare with the current instance.

Return Value

Value | Condition
a value less than zero | The current instance is less than object.
zero | The current instance is equal to object.
a value greater than zero | The current instance is greater than object.

Exceptions

Exception Type | Condition
ArgumentException | object is not the same type as the current instance.

Remarks

a null reference (in Visual Basic Nothing) can always be compared with any other type; therefore, comparisons with a null reference (Nothing) will not generate an exception. When sorting, a null reference (Nothing) is considered to be less than any other object.

See Also

IComparable Interface | IComparable Members | System Namespace


IConvertible Interface

[To be supplied.]

IConvertible

[Visual Basic]
Public Interface IConvertible
[C#]
public interface IConvertible
[C++]
public __gc __interface IConvertible

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IConvertible

Class | Description
DBNull | Represents a null value.
Enum | Provides the base class for enumerations.
String | Represents a static string of characters.

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

IConvertible Members | System Namespace


IConvertible Members

Methods

GetTypeCode | [To be supplied.]
ToBoolean | [To be supplied.]
ToByte | [To be supplied.]
ToChar | [To be supplied.]
ToDateTime | [To be supplied.]
ToDecimal | [To be supplied.]
ToDouble | [To be supplied.]
ToInt16 | [To be supplied.]
ToInt32 | [To be supplied.]
ToInt64 | [To be supplied.]
ToSByte | [To be supplied.]
ToSingle | [To be supplied.]
ToString | [To be supplied.]
ToType | [To be supplied.]
ToUInt16 | [To be supplied.]
ToUInt32 | [To be supplied.]
ToUInt64 | [To be supplied.]

See Also

IConvertible Interface | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IConvertible Methods

The methods of the IConvertible interface are listed below. For a complete list of IConvertible interface members, see the IConvertible Members topic.

GetTypeCode | [To be supplied.]
ToBoolean | [To be supplied.]
ToByte | [To be supplied.]
ToChar | [To be supplied.]
ToDateTime | [To be supplied.]
ToDecimal | [To be supplied.]
ToDouble | [To be supplied.]
ToInt16 | [To be supplied.]
ToInt32 | [To be supplied.]
ToInt64 | [To be supplied.]
ToSByte | [To be supplied.]
ToSingle | [To be supplied.]
ToString | [To be supplied.]
ToType | [To be supplied.]
ToUInt16 | [To be supplied.]
ToUInt32 | [To be supplied.]
ToUInt64 | [To be supplied.]

See Also

IConvertible Interface | System Namespace


IConvertible.GetTypeCode

[To be supplied.]

[Visual Basic]
Function GetTypeCode() As TypeCode
[C#]
TypeCode GetTypeCode();
[C++]
TypeCode GetTypeCode() = 0;
[JScript]
function GetTypeCode() : TypeCode;

See Also

IConvertible Interface | IConvertible Members | System Namespace


IConvertible.ToBoolean

[To be supplied.]

[Visual Basic]
Function ToBoolean() As Boolean
[C#]
bool ToBoolean();
[C++]
bool ToBoolean() = 0;
[JScript]
function ToBoolean() : Boolean;

See Also

IConvertible Interface | IConvertible Members | System Namespace


IConvertible.ToByte

[To be supplied.]

[Visual Basic]
Function ToByte() As Byte
[C#]
byte ToByte();
[C++]
unsigned char ToByte() = 0;
[JScript]
function ToByte() : Byte;

See Also

IConvertible Interface | IConvertible Members | System Namespace


IConvertible.ToChar

[To be supplied.]

[Visual Basic]
Function ToChar() As Char
[C#]
char ToChar();
[C++]
__wchar_t ToChar() = 0;
[JScript]
function ToChar() : Char;

See Also

IConvertible Interface | IConvertible Members | System Namespace


IConvertible.ToDateTime

[To be supplied.]

[Visual Basic]
Function ToDateTime() As DateTime
[C#]
DateTime ToDateTime();
[C++]
DateTime ToDateTime() = 0;
[JScript]
function ToDateTime() : DateTime;

See Also

IConvertible Interface | IConvertible Members | System Namespace


IConvertible.ToDecimal

[To be supplied.]

[Visual Basic]
Function ToDecimal() As Decimal
[C#]
Decimal ToDecimal();
[C++]
Decimal ToDecimal() = 0;
[JScript]
function ToDecimal() : Decimal;

See Also

IConvertible Interface | IConvertible Members | System Namespace


IConvertible.ToDouble

[To be supplied.]

[Visual Basic]
Function ToDouble() As Double
[C#]
double ToDouble();
[C++]
double ToDouble() = 0;
[JScript]
function ToDouble() : double;

See Also

IConvertible Interface | IConvertible Members | System Namespace


IConvertible.ToInt16

[To be supplied.]

[Visual Basic]
Function ToInt16() As Short
[C#]
short ToInt16();
[C++]
short ToInt16() = 0;
[JScript]
function ToInt16() : Int16;

See Also

IConvertible Interface | IConvertible Members | System Namespace


IConvertible.ToInt32

[To be supplied.]

[Visual Basic]
Function ToInt32() As Integer
[C#]
int ToInt32();
[C++]
int ToInt32() = 0;
[JScript]
function ToInt32() : int;

See Also

IConvertible Interface | IConvertible Members | System Namespace


IConvertible.ToInt64

[To be supplied.]

[Visual Basic]
Function ToInt64() As Long
[C#]
long ToInt64();
[C++]
__int64 ToInt64() = 0;
[JScript]
function ToInt64() : long;

See Also

IConvertible Interface | IConvertible Members | System Namespace


IConvertible.ToSByte

[To be supplied.]

[Visual Basic]
Function ToSByte() As SByte
[C#]
sbyte ToSByte();
[C++]
char ToSByte() = 0;
[JScript]
function ToSByte() : SByte;

See Also

IConvertible Interface | IConvertible Members | System Namespace


IConvertible.ToSingle

[To be supplied.]

[Visual Basic]
Function ToSingle() As Single
[C#]
float ToSingle();
[C++]
float ToSingle() = 0;
[JScript]
function ToSingle() : float;

See Also

IConvertible Interface | IConvertible Members | System Namespace


IConvertible.ToString

[To be supplied.]

[Visual Basic]
Function ToString() As String
[C#]
string ToString();
[C++]
String* ToString() = 0;
[JScript]
function ToString() : String;

See Also

IConvertible Interface | IConvertible Members | System Namespace


IConvertible.ToType

[To be supplied.]

[Visual Basic]
Function ToType( _
   ByVal conversionType As Type _
) As Object
[C#]
object ToType(
   Type conversionType
);
[C++]
Object* ToType(
   Type* conversionType
) = 0;
[JScript]
function ToType(
   conversionType : Type
) : Object;

Parameters

conversionType
[To be supplied.]

See Also

IConvertible Interface | IConvertible Members | System Namespace


IConvertible.ToUInt16

[To be supplied.]

[Visual Basic]
Function ToUInt16() As UInt16
[C#]
ushort ToUInt16();
[C++]
unsigned short ToUInt16() = 0;
[JScript]
function ToUInt16() : UInt16;

See Also

IConvertible Interface | IConvertible Members | System Namespace


IConvertible.ToUInt32

[To be supplied.]

[Visual Basic]
Function ToUInt32() As UInt32
[C#]
uint ToUInt32();
[C++]
unsigned int ToUInt32() = 0;
[JScript]
function ToUInt32() : UInt32;

See Also

IConvertible Interface | IConvertible Members | System Namespace


IConvertible.ToUInt64

[To be supplied.]

[Visual Basic]
Function ToUInt64() As UInt64
[C#]
ulong ToUInt64();
[C++]
unsigned __int64 ToUInt64() = 0;
[JScript]
function ToUInt64() : UInt64;

See Also

IConvertible Interface | IConvertible Members | System Namespace


ICustomFormatter Interface

This interface is implemented by classes that special formatting.

ICustomFormatter

[Visual Basic]
Public Interface ICustomFormatter
[C#]
public interface ICustomFormatter
[C++]
public __gc __interface ICustomFormatter

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

ICustomFormatter Members | System Namespace


ICustomFormatter Members

Methods

Format To be supplied

See Also

ICustomFormatter Interface | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICustomFormatter Methods

The methods of the ICustomFormatter interface are listed below. For a complete list of ICustomFormatter interface members, see the ICustomFormatter Members topic.

Format To be supplied

See Also

ICustomFormatter Interface | System Namespace


ICustomFormatter.Format

To be supplied

[Visual Basic]
Function Format( _
   ByVal format As String, _
   ByVal arg As Object, _
   ByVal sop As IServiceObjectProvider _
) As String
[C#]
string Format(
   string format,
   object arg,
   IServiceObjectProvider sop
);
[C++]
String* Format(
   String* format,
   Object* arg,
   IServiceObjectProvider* sop
) = 0;
[JScript]
function Format(
   format : String,
   arg : Object,
   sop : IServiceObjectProvider
) : String;

Parameters

format
To be supplied
arg
To be supplied
sop
To be supplied

Return Value

To be supplied

Remarks

To be supplied

See Also

ICustomFormatter Interface | ICustomFormatter Members | System Namespace


IFormattable Interface

Provides functionality to format the value of an object.

IFormattable

[Visual Basic]
Public Interface IFormattable
[C#]
public interface IFormattable
[C++]
public __gc __interface IFormattable

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IFormattable

Class | Description
Enum | Provides the base class for enumerations.

Remarks

IFormattable is implemented by the base data types

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

IFormattable Members | System Namespace


IFormattable Members

Methods

Format Formats the value of the current instance as specified.

See Also

IFormattable Interface | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IFormattable Methods

The methods of the IFormattable interface are listed below. For a complete list of IFormattable interface members, see the IFormattable Members topic.

Format Formats the value of the current instance as specified.

See Also

IFormattable Interface | System Namespace


IFormattable.Format

Formats the value of the current instance as specified.

[Visual Basic]
Function Format( _
   ByVal format As String, _
   ByVal sop As IServiceObjectProvider _
) As String
[C#]
string Format(
   string format,
   IServiceObjectProvider sop
);
[C++]
String* Format(
   String* format,
   IServiceObjectProvider* sop
) = 0;
[JScript]
function Format(
   format : String,
   sop : IServiceObjectProvider
) : String;

Parameters

format
The String specifying the format to use.

-or-

A null reference object to use the default format denoted by the string "G" (general format).

sop
The IServiceObjectProvider to be used to format the value.

-or-

A null reference object to obtain the numeric format information from the current locale setting of the operating system.

Return Value

A String containing the value of the current instance in the specified format.

Remarks

A NumberFormatInfo instance is obtained from the format provider specified by sop. NumberFormatInfo supplies numeric format information such as the characters to use for decimal and thousand separators, and the spelling and placement of currency symbols in monetary values.

See Also

IFormattable Interface | IFormattable Members | System Namespace


ILogicalThreadAffinative Interface

[To be supplied.]

ILogicalThreadAffinative

[Visual Basic]
Public Interface ILogicalThreadAffinative
[C#]
public interface ILogicalThreadAffinative
[C++]
public __gc __interface ILogicalThreadAffinative

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

ILogicalThreadAffinative Members | System Namespace


ILogicalThreadAffinative Members

See Also

ILogicalThreadAffinative Interface | System Namespace


IndexOutOfRangeException Class

Represents an exception that is thrown when an attempt is made to access an array outside of its upper or lower bound.

Object
Exception
SystemException
CoreException
IndexOutOfRangeException

[Visual Basic]
NotInheritable Public Class IndexOutOfRangeException
   Inherits CoreException
[C#]
public sealed class IndexOutOfRangeException : CoreException
[C++]
public __gc __sealed class IndexOutOfRangeException : public
   CoreException
[JScript]
public class IndexOutOfRangeException extends CoreException

Remarks

The IndexOutOfRangeException is the exception class that is thrown for an invalid array indices.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

IndexOutOfRangeException Members | System Namespace


IndexOutOfRangeException Members

Public:

Constructor

IndexOutOfRangeException Constructor Overloaded. Initializes a new instance of the IndexOutOfRangeException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

IndexOutOfRangeException Class | System Namespace


IndexOutOfRangeException Constructor

Initializes a new instance of the IndexOutOfRangeException class.

Overload List

Initializes a new instance of the IndexOutOfRangeException with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public IndexOutOfRangeException();
[C++] public: IndexOutOfRangeException();
[JScript] public function IndexOutOfRangeException();

Initializes a new instance of IndexOutOfRangeException with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public IndexOutOfRangeException(String);
[C++] public: IndexOutOfRangeException(String*);
[JScript] public function IndexOutOfRangeException(String);

Initializes a new instance of IndexOutOfRangeException with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public IndexOutOfRangeException(String, Exception);
[C++] public: IndexOutOfRangeException(String*, Exception);
[JScript] public function IndexOutOfRangeException(String, Exception);

See Also

IndexOutOfRangeException Class | IndexOutOfRangeException Members | System Namespace


IndexOutOfRangeException Constructor ()

Initializes a new instance of the IndexOutOfRangeException with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public IndexOutOfRangeException();
[C++]
public: IndexOutOfRangeException();
[JScript]
public function IndexOutOfRangeException();

Remarks

IndexOutOfRangeException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Conditon
InnerException | null
Message | The empty string.

See Also

IndexOutOfRangeException Class | IndexOutOfRangeException Members | System Namespace | IndexOutOfRangeException Constructor Overload List


IndexOutOfRangeException Constructor (String)

Initializes a new instance of IndexOutOfRangeException with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public IndexOutOfRangeException(
   string message
);
[C++]
public: IndexOutOfRangeException(
   String* message
);
[JScript]
public function IndexOutOfRangeException(
   message : String
);

Parameters

message
The message that indicates the reason the exception occurred.

Remarks

IndexOutOfRangeException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The message string.

See Also

IndexOutOfRangeException Class | IndexOutOfRangeException Members | System Namespace | IndexOutOfRangeException Constructor Overload List


IndexOutOfRangeException Constructor (String, Exception)

Initializes a new instance of IndexOutOfRangeException with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public IndexOutOfRangeException(
   string message,
   Exception inner
);
[C++]
public: IndexOutOfRangeException(
   String* message,
   Exception* inner
);
[JScript]
public function IndexOutOfRangeException(
   message : String,
   inner : Exception
);

Parameters

message
The message that indicates the reason the exception occurred.
inner
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

IndexOutOfRangeException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | The inner exception.
Message | The message string.

See Also

IndexOutOfRangeException Class | IndexOutOfRangeException Members | System Namespace | IndexOutOfRangeException Constructor Overload List


Int16 Structure

Represents a 16-bit signed integer.

Object
ValueType
Int16

[Visual Basic]
Public Structure Int16
   Implements IComparable, IFormattable, IConvertible
[C#]
public struct Int16 : IComparable, IFormattable, IConvertible
[C++]
public __value struct Int16 : public IComparable, IFormattable,
   IConvertible

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

The Int16 represents a 2-byte signed integer and provides an Object representation. The Int16 value type can represent integers with significant digits in the range negative 32768 through positive 32767, inclusive. This class encapsulates a short and provides an Object representation of it. of it.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

Int16 Members | System Namespace | UInt16 | IComparable | IFormattable | IConvertible


Int16 Members

Public:

Methods

CompareTo | Compares this object to another object.
Equals | Compares this instance with a specified object.
Format | Overloaded. Converts a numeric value to a String.
FromString | Parses an Int16 from a String.
GetHashCode | Returns the hash code for this Int16.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | Retrieves the type code of an object.
Parse | Overloaded. Converts a String to an Int16.
ToBoolean | [To be supplied.]
ToByte | [To be supplied.]
ToChar | [To be supplied.]
ToDateTime | [To be supplied.]
ToDecimal | [To be supplied.]
ToDouble | [To be supplied.]
ToInt16 | [To be supplied.]
ToInt32 | [To be supplied.]
ToInt64 | [To be supplied.]
ToSByte | [To be supplied.]
ToSingle | [To be supplied.]
ToString | Overloaded. Converts an Int16 to a String.
ToType | [To be supplied.]
ToUInt16 | [To be supplied.]
ToUInt32 | [To be supplied.]
ToUInt64 | [To be supplied.]

Fields

Empty | Represents the constant that is the empty Int16 value.
MaxValue | Represents the constant that is the largest possible Int16 value.
MinValue | Represents the constant that is the smallest possible Int16 value.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Int16 Structure | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Int16 Methods

The methods of the Int16 structure are listed below. For a complete list of Int16 structure members, see the Int16 Members topic.

Public:

CompareTo | Compares this object to another object.
Equals | Compares this instance with a specified object.
Format | Overloaded. Converts a numeric value to a String.
FromString | Parses an Int16 from a String.
GetHashCode | Returns the hash code for this Int16.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | Retrieves the type code of an object.
Parse | Overloaded. Converts a String to an Int16.
ToBoolean | [To be supplied.]
ToByte | [To be supplied.]
ToChar | [To be supplied.]
ToDateTime | [To be supplied.]
ToDecimal | [To be supplied.]
ToDouble | [To be supplied.]
ToInt16 | [To be supplied.]
ToInt32 | [To be supplied.]
ToInt64 | [To be supplied.]
ToSByte | [To be supplied.]
ToSingle | [To be supplied.]
ToString | Overloaded. Converts an Int16 to a String.
ToType | [To be supplied.]
ToUInt16 | [To be supplied.]
ToUInt32 | [To be supplied.]
ToUInt64 | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Int16 Structure | System Namespace


Int16.CompareTo

Compares this object to another object.

[Visual Basic]
Overridable Public Function CompareTo( _
   ByVal value As Object _
) As Integer
[C#]
public virtual int CompareTo(
   object value
);
[C++]
public: virtual int CompareTo(
   Object* value
);
[JScript]
public function CompareTo(
   value : Object
) : int;

Parameters

value
An object to compare with this instance.

Return Value

Value | Description
A negative integer | If this instance is less than object.
Zero | If this instance and object have the same value.
A positive integer | If this instance is greater than object.
A positive integer | If object is a null reference (in Visual Basic Nothing). This is a special case.

Exceptions

Exception Type | Condition
ArgumentException | If the object is not null and is not an Int16 type.

Remarks

The CompareTo method compares this object to another object and returns an integer that indicates the relationship. It must be either an Int16 type or a null reference.

Whencomparing two Int16 values, canonical ordering is used. As a special case, an instance, regardless of its value, is considered to be greater than a null reference.

The object parameter must be either an Int16 type or a null reference.

See Also

Int16 Structure | Int16 Members | System Namespace | Object | UInt32


Int16.Equals

Compares this instance with a specified object.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The object to compare with this instance.

Return Value

true if obj is an Int16 with the same value as this instance; otherwise, false.

Remarks

The Equals method compares two objects and returns a Boolean determination of their relationship.

Overrides Equals.

See Also

Int16 Structure | Int16 Members | System Namespace | Boolean


Int16.Format

Converts a numeric value to a String.

Overload List

Converts the value of this instance to a String with the specified format string provided by IServiceObjectProvider.

[Visual Basic] Overloads Overridable Public Function Format(String, IServiceObjectProvider) As String
[C#] public virtual string Format(String, IServiceObjectProvider);
[C++] public: virtual String* Format(String*, IServiceObjectProvider);
[JScript] public function Format(String, IServiceObjectProvider) : String;

Converts a numeric value to a String with the specified number format string.

[Visual Basic] Overloads Public Shared Function Format(Integer, String, NumberFormatInfo) As String
[C#] public static string Format(short, String, NumberFormatInfo);
[C++] public: static String* Format(short, String, NumberFormatInfo);
[JScript] public static function Format(Int16, String, NumberFormatInfo) : String;

Converts a numeric value to a String with the specified format string.

[Visual Basic] Overloads Public Shared Function Format(Integer, String) As String
[C#] public static string Format(short, String);
[C++] public: static String* Format(short, String);
[JScript] public static function Format(Int16, String) : String;

See Also

Int16 Structure | Int16 Members | System Namespace


Int16.Format (String, IServiceObjectProvider)

Converts the value of this instance to a String with the specified format string provided by IServiceObjectProvider.

[Visual Basic]
Overloads Overridable Public Function Format( _
   ByVal format As String, _
   ByVal sop As IServiceObjectProvider _
) As String
[C#]
public virtual string Format(
   string format,
   IServiceObjectProvider sop
);
[C++]
public: virtual String* Format(
   String* format,
   IServiceObjectProvider* sop
);
[JScript]
public function Format(
   format : String,
   sop : IServiceObjectProvider
) : String;

Parameters

format
The format string.
sop
The IServiceObjectProvider used to format the number.

Return Value

A string representation for the value of this instance in the format specified by format.

Remarks

If format is null or an empty string, the number is formatted as if the general format ("G") string were specified.

The sop parameter specifies the format from which the NumberFormatInfo instance will be obtained. NumberFormatInfo supplies information such as the characters to use for decimal and thousand separators, and the spelling and placement of currency symbols in monetary values (see NumberFormatInfo and CultureInfo for more information for numeric and culture formats).

If sop is null, the numeric format information is obtained from the current locale.

See Also

Int16 Structure | Int16 Members | System Namespace | Int16.Format Overload List | String | NumberStyles | IServiceObjectProvider


Int16.Format (Int16, String, NumberFormatInfo)

Converts a numeric value to a String with the specified number format string.

[Visual Basic]
Overloads Public Shared Function Format( _
   ByVal value As Short, _
   ByVal format As String, _
   ByVal info As NumberFormatInfo _
) As String
[C#]
public static string Format(
   short value,
   string format,
   NumberFormatInfo info
);
[C++]
public: static String* Format(
   short value,
   String* format,
   NumberFormatInfo* info
);
[JScript]
public static function Format(
   value : Int16,
   format : String,
   info : NumberFormatInfo
) : String;

Parameters

value
The value to be formatted.
format
The format string.
info
The NumberFormatInfo instance used to format the number.

Return Value

A string representation of value in the format specified by format.

Remarks

The Format method converts a numeric value to a string using the format string given by format. If format is null or an empty string, value is formatted as if the general format ("G") string were specified.

The info parameter specifies the NumberFormatInfo instance used to format the number. If info is null, the numeric format information is obtained from the current locale (see CultureInfo for inforamtion on specific cultures).

The NumberFormatInfo supplies information such as the characters to use for decimal and thousand separators, and the spelling and placement of currency symbols in monetary values.

See Also

Int16 Structure | Int16 Members | System Namespace | Int16.Format Overload List | String | NumberStyles


Int16.Format (Int16, String)

Converts a numeric value to a String with the specified format string.

[Visual Basic]
Overloads Public Shared Function Format( _
   ByVal value As Short, _
   ByVal format As String _
) As String
[C#]
public static string Format(
   short value,
   string format
);
[C++]
public: static String* Format(
   short value,
   String* format
);
[JScript]
public static function Format(
   value : Int16,
   format : String
) : String;

Parameters

value
The value to be formatted.
format
The format string.

Return Value

A string representation of value in the format specified by format.

Remarks

The Format method converts a numeric value to a string using the format string given by format. If format is null or an empty string, value is formatted as if the general format ("G") string were specified.

The numeric format information is obtained from the current locale (see NumberFormatInfo and CultureInfo for more information on specific numeric and cultures). .

See Also

Int16 Structure | Int16 Members | System Namespace | Int16.Format Overload List | String


Int16.FromString

Parses an Int16 from a String.

[Visual Basic]
Public Shared Function FromString( _
   ByVal s As String _
) As Short
[C#]
public static short FromString(
   string s
);
[C++]
public: static short FromString(
   String* s
);
[JScript]
public static function FromString(
   s : String
) : Int16;

Parameters

s
The string containing a number to convert.

Return Value

The Int16 value of the string.

Exceptions

Exception Type | Condition
ArgumentException | If s is a null reference (in Visual Basic Nothing).
FormatException | If s does not contain a well-formed number.
OverflowException | If s is greater than positive 32767 or less than negative 32768.

Remarks

FromString parses an unsigned short from a string.

The default (culture-neutral) is NumberFormatInfo is used (see NumberFormatInfo and CultureInfo for more information for numeric and culture formats).

Use Parse and Format for locale dependent strings.

The output from ToString should be consumable by FromString().

See Also

Int16 Structure | Int16 Members | System Namespace | String | NumberStyles


Int16.GetHashCode

Returns the hash code for this Int16.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

A hash code for this instance.

Remarks

GetHashCode is the method used to return the hash code value for the Int16.

See Also

Int16 Structure | Int16 Members | System Namespace | IHashCodeProvider | UInt16


Int16.GetTypeCode

Retrieves the type code of an object.

[Visual Basic]
Overridable Public Function GetTypeCode() As TypeCode
[C#]
public virtual TypeCode GetTypeCode();
[C++]
public: virtual TypeCode GetTypeCode();
[JScript]
public function GetTypeCode() : TypeCode;

Return Value

A type code.

Remarks

The GetTypeCode method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See TypeCode enumeration for more information about type codes.)

See Also

Int16 Structure | Int16 Members | System Namespace | IConvertible | TypeCode


Int16.Parse

Converts a String to an Int16.

Overload List

Converts a String to an Int16.

[Visual Basic] Overloads Public Shared Function Parse(String) As Short
[C#] public static short Parse(String);
[C++] public: static short Parse(String*);
[JScript] public static function Parse(String) : Int16;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function Parse(String, NumberStyles, NumberFormatInfo) As Short
[C#] public static short Parse(String, NumberStyles, NumberFormatInfo);
[C++] public: static short Parse(String*, NumberStyles, NumberFormatInfo);
[JScript] public static function Parse(String, NumberStyles, NumberFormatInfo) : Int16;

This method converts a String to an Int16 using the NumberStyles Enumeration.

[Visual Basic] Overloads Public Shared Function Parse(String, NumberStyles) As Short
[C#] public static short Parse(String, NumberStyles);
[C++] public: static short Parse(String*, NumberStyles);
[JScript] public static function Parse(String, NumberStyles) : Int16;

See Also

Int16 Structure | Int16 Members | System Namespace


Int16.Parse (String)

Converts a String to an Int16.

[Visual Basic]
Overloads Public Shared Function Parse( _
   ByVal s As String _
) As Short
[C#]
public static short Parse(
   string s
);
[C++]
public: static short Parse(
   String* s
);
[JScript]
public static function Parse(
   s : String
) : Int16;

Parameters

s
The string to be interpreted.

Return Value

An Int16 with the value represented by s.

Exceptions

Exception Type | Condition
ArgumentNullException | If the string is a null reference (in Visual Basic Nothing).
FormatException | If the string does not match the following regular expression: [0-9].
OverflowException | If the string represents a number that is less than MinValue or greater than MaxValue.

Remarks

The Parse method converts a String to an Int16. The string must consist of an optional minus sign ("-") followed by a sequence of digits ("0"- "9").

Leading and trailing white space characters are ignored.

Note Hexadecimal strings ("0x42") are not supported. Use Value or Convert ToIntxx(string, int) and ToUIntxx methods for the conversions.
Note The Parse method does not accept not a number (NaN) or positive or negative infinity.

See Also

Int16 Structure | Int16 Members | System Namespace | Int16.Parse Overload List | String | Value | Convert | NaN | NaN | PositiveInfinity | PositiveInfinity | NegativeInfinity | NegativeInfinity


Int16.Parse (String, NumberStyles, NumberFormatInfo)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function Parse( _
   ByVal s As String, _
   ByVal style As NumberStyles, _
   ByVal info As NumberFormatInfo _
) As Short
[C#]
public static short Parse(
   string s,
   NumberStyles style,
   NumberFormatInfo info
);
[C++]
public: static short Parse(
   String* s,
   NumberStyles style,
   NumberFormatInfo* info
);
[JScript]
public static function Parse(
   s : String,
   style : NumberStyles,
   info : NumberFormatInfo
) : Int16;

Parameters

s
[To be supplied.]
style
[To be supplied.]
info
[To be supplied.]

Return Value

An Int16 with the value represented by the string.

Exceptions

Exception Type | Condition
ArgumentNullException | If the string is a null reference (in Visual Basic Nothing).
ArgumentException | If the style is not a NumberStyles enumeration.
FormatException | If the string is not of the correct format.
OverflowException | If the string represents a number that is less than MinValue or greater than MaxValue.

Remarks

The Parse method converts a string to a numeric value. The default (culture neutral) NumberFormatInfo is used. The output from ToString is consumable by FromString. Use Parse() and Format() for culture dependent strings.

If the s parameter has been created by one of the Format methods using C, D, E, F, G, or N as the format specifier, it is guaranteed that s can be parsed when style is NumberStyles.

The style parameter must be a combination of bit flags from the NumberStyles enumeration.

If the info parameter is a null reference (Nothing), the numeric format information is obtained from the current locale (see NumberFormatInfo and CultureInfo for specific information for numeric and culture formats).

Note Hexadecimal strings ("0x42") are not supported. Use the Convert ToIntxx(string, int) and ToUIntxx methods for the conversions.
Note The Parse methods do not accept not a number (NaN) or positive or negative infinity.

See Also

Int16 Structure | Int16 Members | System Namespace | Int16.Parse Overload List | String | Value | Convert | NaN | NaN | PositiveInfinity | PositiveInfinity | NegativeInfinity | NegativeInfinity


Int16.Parse (String, NumberStyles)

This method converts a String to an Int16 using the NumberStyles Enumeration.

[Visual Basic]
Overloads Public Shared Function Parse( _
   ByVal s As String, _
   ByVal style As NumberStyles _
) As Short
[C#]
public static short Parse(
   string s,
   NumberStyles style
);
[C++]
public: static short Parse(
   String* s,
   NumberStyles style
);
[JScript]
public static function Parse(
   s : String,
   style : NumberStyles
) : Int16;

Parameters

s
The string to be interpreted.
style
The permitted style of the numeric string.

Return Value

An Int16 with the value represented by s.

Exceptions

Exception Type | Condition
ArgumentException | If the style is not a NumberStyles enumeration.
ArgumentNullException | If the string is null.
FormatException | If the string is not of the correct format.
OverflowException | If the string represents a number that is less than MinValue or greater than MaxValue.

Remarks

The numeric format information is obtained from the current locale. If s has been created by one of the Format methods using C, D, E, F, G, or N as the format specifier, it is guaranteed that s can be parsed when style is Any of NumberStyles.

The style parameter must be a combination of bit flags from the NumberStyles enumeration.

Note Hexadecimal strings ("0x42") are not supported. Use the Convert ToIntxx(string, int) and ToUIntxx methods for the conversions.
Note The Parse methods do not accept not a number (NaN) or positive or negative infinity.

See Also

Int16 Structure | Int16 Members | System Namespace | Int16.Parse Overload List | String | Value | Convert | NaN | NaN | PositiveInfinity | PositiveInfinity | NegativeInfinity | NegativeInfinity


Int16.ToBoolean

[To be supplied.]

[Visual Basic]
Overridable Public Function ToBoolean() As Boolean
[C#]
public virtual bool ToBoolean();
[C++]
public: virtual bool ToBoolean();
[JScript]
public function ToBoolean() : Boolean;

See Also

Int16 Structure | Int16 Members | System Namespace


Int16.ToByte

[To be supplied.]

[Visual Basic]
Overridable Public Function ToByte() As Byte
[C#]
public virtual byte ToByte();
[C++]
public: virtual unsigned char ToByte();
[JScript]
public function ToByte() : Byte;

See Also

Int16 Structure | Int16 Members | System Namespace


Int16.ToChar

[To be supplied.]

[Visual Basic]
Overridable Public Function ToChar() As Char
[C#]
public virtual char ToChar();
[C++]
public: virtual __wchar_t ToChar();
[JScript]
public function ToChar() : Char;

See Also

Int16 Structure | Int16 Members | System Namespace


Int16.ToDateTime

[To be supplied.]

[Visual Basic]
Overridable Public Function ToDateTime() As DateTime
[C#]
public virtual DateTime ToDateTime();
[C++]
public: virtual DateTime ToDateTime();
[JScript]
public function ToDateTime() : DateTime;

See Also

Int16 Structure | Int16 Members | System Namespace


Int16.ToDecimal

[To be supplied.]

[Visual Basic]
Overridable Public Function ToDecimal() As Decimal
[C#]
public virtual Decimal ToDecimal();
[C++]
public: virtual Decimal ToDecimal();
[JScript]
public function ToDecimal() : Decimal;

See Also

Int16 Structure | Int16 Members | System Namespace


Int16.ToDouble

[To be supplied.]

[Visual Basic]
Overridable Public Function ToDouble() As Double
[C#]
public virtual double ToDouble();
[C++]
public: virtual double ToDouble();
[JScript]
public function ToDouble() : double;

See Also

Int16 Structure | Int16 Members | System Namespace


Int16.ToInt16

[To be supplied.]

[Visual Basic]
Overridable Public Function ToInt16() As Short
[C#]
public virtual short ToInt16();
[C++]
public: virtual short ToInt16();
[JScript]
public function ToInt16() : Int16;

See Also

Int16 Structure | Int16 Members | System Namespace


Int16.ToInt32

[To be supplied.]

[Visual Basic]
Overridable Public Function ToInt32() As Integer
[C#]
public virtual int ToInt32();
[C++]
public: virtual int ToInt32();
[JScript]
public function ToInt32() : int;

See Also

Int16 Structure | Int16 Members | System Namespace


Int16.ToInt64

[To be supplied.]

[Visual Basic]
Overridable Public Function ToInt64() As Long
[C#]
public virtual long ToInt64();
[C++]
public: virtual __int64 ToInt64();
[JScript]
public function ToInt64() : long;

See Also

Int16 Structure | Int16 Members | System Namespace


Int16.ToSByte

[To be supplied.]

[Visual Basic]
Overridable Public Function ToSByte() As SByte
[C#]
public virtual sbyte ToSByte();
[C++]
public: virtual char ToSByte();
[JScript]
public function ToSByte() : SByte;

See Also

Int16 Structure | Int16 Members | System Namespace


Int16.ToSingle

[To be supplied.]

[Visual Basic]
Overridable Public Function ToSingle() As Single
[C#]
public virtual float ToSingle();
[C++]
public: virtual float ToSingle();
[JScript]
public function ToSingle() : float;

See Also

Int16 Structure | Int16 Members | System Namespace


Int16.ToString

Converts an Int16 to a String.

Overload List

Converts a specified Int16 to a String.

[Visual Basic] Overloads Public Shared Function ToString(Integer) As String
[C#] public static string ToString(short);
[C++] public: static String* ToString(short);
[JScript] public static function ToString(Int16) : String;

Converts this instance of Int16 to a String.

[Visual Basic] Overloads Overrides Public Function ToString() As String
[C#] public override string ToString();
[C++] public: override String* ToString();
[JScript] public override function ToString() : String;

See Also

Int16 Structure | Int16 Members | System Namespace


Int16.ToString (Int16)

Converts a specified Int16 to a String.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal i As Short _
) As String
[C#]
public static string ToString(
   short i
);
[C++]
public: static String* ToString(
   short i
);
[JScript]
public static function ToString(
   i : Int16
) : String;

Parameters

i
The Int16 value to be converted.

Return Value

The result of converting the argument to a string.

Remarks

The ToString method converts a specified Int16 to a String in base 10 with no extra padding.

If i is negative, the first character in the string returned will be '-'. No sign character is returned if the number is non-negative. The rest of the string returned is made up of characters representing the magnitude of i.

The following characters are used as digits: 0, 1, 2, 3, 4, 5, 6, 7, 8, or9.

No leading zero characters ('0') are prepended to the returned string.

The output from ToString should be consumable by FromString.

See Also

Int16 Structure | Int16 Members | System Namespace | Int16.ToString Overload List | String | Format | Convert


Int16.ToString ()

Converts this instance of Int16 to a String.

[Visual Basic]
Overloads Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

The result of converting this Int16 to a string.

Remarks

The ToString method converts the value represented by the current Int16 instance to a String in base 10 with no extra padding.

If this instance is negative, the first charter in the string returned will be '-'. No sign character is returned if the number is non-negative. The rest of the string returned is made up of characters representing the magnitude of this instance. No leading zero characters (0) are prepended to the returned string.

The following characters are used as digits: 0, 1, 2, 3, 4, 5, 6, 7, 8, or 9.

The output from ToString should be consumable by FromString.

Overrides ToString.

See Also

Int16 Structure | Int16 Members | System Namespace | Int16.ToString Overload List | String | Format | Convert


Int16.ToType

[To be supplied.]

[Visual Basic]
Overridable Public Function ToType( _
   ByVal type As Type _
) As Object
[C#]
public virtual object ToType(
   Type type
);
[C++]
public: virtual Object* ToType(
   Type* type
);
[JScript]
public function ToType(
   type : Type
) : Object;

Parameters

type
[To be supplied.]

See Also

Int16 Structure | Int16 Members | System Namespace


Int16.ToUInt16

[To be supplied.]

[Visual Basic]
Overridable Public Function ToUInt16() As UInt16
[C#]
public virtual ushort ToUInt16();
[C++]
public: virtual unsigned short ToUInt16();
[JScript]
public function ToUInt16() : UInt16;

See Also

Int16 Structure | Int16 Members | System Namespace


Int16.ToUInt32

[To be supplied.]

[Visual Basic]
Overridable Public Function ToUInt32() As UInt32
[C#]
public virtual uint ToUInt32();
[C++]
public: virtual unsigned int ToUInt32();
[JScript]
public function ToUInt32() : UInt32;

See Also

Int16 Structure | Int16 Members | System Namespace


Int16.ToUInt64

[To be supplied.]

[Visual Basic]
Overridable Public Function ToUInt64() As UInt64
[C#]
public virtual ulong ToUInt64();
[C++]
public: virtual unsigned __int64 ToUInt64();
[JScript]
public function ToUInt64() : UInt64;

See Also

Int16 Structure | Int16 Members | System Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Int16 Fields

The fields of the Int16 structure are listed below. For a complete list of Int16 structure members, see the Int16 Members topic.

Public:

Empty | Represents the constant that is the empty Int16 value.
MaxValue | Represents the constant that is the largest possible Int16 value.
MinValue | Represents the constant that is the smallest possible Int16 value.

See Also

Int16 Structure | System Namespace


Int16.Empty

Represents the constant that is the empty Int16 value.

[Visual Basic]
Public Const Empty As Short
[C#]
public const short Empty;
[C++]
public: const short Empty;
[JScript]
public var Empty : Int16;

Remarks

The Empty hexadecimal value is (short)0x0.

See Also

Int16 Structure | Int16 Members | System Namespace | Empty


Int16.MaxValue

Represents the constant that is the largest possible Int16 value.

[Visual Basic]
Public Const MaxValue As Short
[C#]
public const short MaxValue;
[C++]
public: const short MaxValue;
[JScript]
public var MaxValue : Int16;

Remarks

The MaxValue hexadecimal value is (short)0x7FFF.

See Also

Int16 Structure | Int16 Members | System Namespace


Int16.MinValue

Represents the constant that is the smallest possible Int16 value.

[Visual Basic]
Public Const MinValue As Short
[C#]
public const short MinValue;
[C++]
public: const short MinValue;
[JScript]
public var MinValue : Int16;

Remarks

The MinValue hexadecimal is unchecked((short)0x8000).

See Also

Int16 Structure | Int16 Members | System Namespace


Int32 Structure

Represents a 32-bit signed integer.

Object
ValueType
Int32

[Visual Basic]
Public Structure Int32
   Implements IComparable, IFormattable, IConvertible
[C#]
public struct Int32 : IComparable, IFormattable, IConvertible
[C++]
public __value struct Int32 : public IComparable, IFormattable,
   IConvertible

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

The Int32 class encapsulates a 32-bit signed integer (int) and provides an object representation of it. It represents a 4-byte signed integer.

The Int32 data type can represent integers with 9 significant digits in the range negative 2,147,483,648 through positive 2,147,483,647, inclusive.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

Int32 Members | System Namespace | UInt32 | Object | IComparable | IFormattable | IConvertible


Int32 Members

Public:

Methods

CompareTo | Compares this instance to the specified Object.
Equals | Compares this instance with a specified Object.
Format | Overloaded. Converts a numeric value to a String.
FromString | Parses an Int32 from a String.
GetHashCode | Returns the hash code for this Int32.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | Retrieves the type code of an object.
Parse | Overloaded. Converts a String to an Int32.
ToBoolean | [To be supplied.]
ToByte | [To be supplied.]
ToChar | [To be supplied.]
ToDateTime | [To be supplied.]
ToDecimal | [To be supplied.]
ToDouble | [To be supplied.]
ToInt16 | [To be supplied.]
ToInt32 | [To be supplied.]
ToInt64 | [To be supplied.]
ToSByte | [To be supplied.]
ToSingle | [To be supplied.]
ToString | Overloaded. Converts an Int32 to a String.
ToType | [To be supplied.]
ToUInt16 | [To be supplied.]
ToUInt32 | [To be supplied.]
ToUInt64 | [To be supplied.]

Fields

Empty | Representing the constant of an empty Int32 value.
MaxValue | Representing the constant value of the largest possible Int32.
MinValue | Representing the constant of the smallest possible Int32 value.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Int32 Structure | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Int32 Methods

The methods of the Int32 structure are listed below. For a complete list of Int32 structure members, see the Int32 Members topic.

Public:

CompareTo | Compares this instance to the specified Object.
Equals | Compares this instance with a specified Object.
Format | Overloaded. Converts a numeric value to a String.
FromString | Parses an Int32 from a String.
GetHashCode | Returns the hash code for this Int32.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | Retrieves the type code of an object.
Parse | Overloaded. Converts a String to an Int32.
ToBoolean | [To be supplied.]
ToByte | [To be supplied.]
ToChar | [To be supplied.]
ToDateTime | [To be supplied.]
ToDecimal | [To be supplied.]
ToDouble | [To be supplied.]
ToInt16 | [To be supplied.]
ToInt32 | [To be supplied.]
ToInt64 | [To be supplied.]
ToSByte | [To be supplied.]
ToSingle | [To be supplied.]
ToString | Overloaded. Converts an Int32 to a String.
ToType | [To be supplied.]
ToUInt16 | [To be supplied.]
ToUInt32 | [To be supplied.]
ToUInt64 | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Int32 Structure | System Namespace


Int32.CompareTo

Compares this instance to the specified Object.

[Visual Basic]
Overridable Public Function CompareTo( _
   ByVal value As Object _
) As Integer
[C#]
public virtual int CompareTo(
   object value
);
[C++]
public: virtual int CompareTo(
   Object* value
);
[JScript]
public function CompareTo(
   value : Object
) : int;

Parameters

value
The object to compare with this instance.

Return Value

Value | Condition
A negative integer | If this instance is less than the object.
A zero (0) | If this instance and the object have the same value.
A positive integer | If this instance is greater than the object .
A positive integer | If the object is a null reference (in Visual Basic Nothing). This is a special case.

Remarks

When comparing two Int32 values, canonical ordering is used. As a special case, regardless of its value, an instance is considered to be greater than a null object reference.

You should use the CompareTo method instead of subtraction because very large negative numbers will wrap to positive.

The value parameter must be either an Int32 type or a null object reference.

See Also

Int32 Structure | Int32 Members | System Namespace | Object


Int32.Equals

Compares this instance with a specified Object.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The object to compare with this instance.

Return Value

true if the object is an Int32 with the same value as this instance; otherwise, false.

Remarks

The Equals method compares two objects for equality and returns a Boolean determination of the relationship.

Overrides Equals.

See Also

Int32 Structure | Int32 Members | System Namespace | Object | Boolean


Int32.Format

Converts a numeric value to a String.

Overload List

Converts the value of this instance to a String with the specified string formatted by IServiceObjectProvider.

[Visual Basic] Overloads Overridable Public Function Format(String, IServiceObjectProvider) As String
[C#] public virtual string Format(String, IServiceObjectProvider);
[C++] public: virtual String* Format(String*, IServiceObjectProvider);
[JScript] public function Format(String, IServiceObjectProvider) : String;

Converts a numeric value to a String with the specified string formatted by NumberFormatInfo.

[Visual Basic] Overloads Public Shared Function Format(Integer, String, NumberFormatInfo) As String
[C#] public static string Format(int, String, NumberFormatInfo);
[C++] public: static String* Format(int, String, NumberFormatInfo);
[JScript] public static function Format(int, String, NumberFormatInfo) : String;

Converts a numeric value to a String with the specified format string.

[Visual Basic] Overloads Public Shared Function Format(Integer, String) As String
[C#] public static string Format(int, String);
[C++] public: static String* Format(int, String);
[JScript] public static function Format(int, String) : String;

See Also

Int32 Structure | Int32 Members | System Namespace


Int32.Format (String, IServiceObjectProvider)

Converts the value of this instance to a String with the specified string formatted by IServiceObjectProvider.

[Visual Basic]
Overloads Overridable Public Function Format( _
   ByVal format As String, _
   ByVal sop As IServiceObjectProvider _
) As String
[C#]
public virtual string Format(
   string format,
   IServiceObjectProvider sop
);
[C++]
public: virtual String* Format(
   String* format,
   IServiceObjectProvider* sop
);
[JScript]
public function Format(
   format : String,
   sop : IServiceObjectProvider
) : String;

Parameters

format
The format string.
sop
The IServiceObjectProvider used to format the number.

Return Value

A string representation for the value of this instance in the format specified by format.

Remarks

If format is null or an empty string, the number is formatted as if the general format ("G") string were specified.

The sop parameter specifies the format provider from which the NumberFormatInfo instance will be obtained. NumberFormatInfo supplies information such as the characters to use for decimal and thousand separators, and the spelling and placement of currency symbols in monetary values.

If sop is null, the numeric format information is obtained from the current locale (see NumberFormatInfo and CultureInfo for more information on numeric and culture formats).

See Also

Int32 Structure | Int32 Members | System Namespace | Int32.Format Overload List | String | Object | NumberStyles | IServiceObjectProvider


Int32.Format (Int32, String, NumberFormatInfo)

Converts a numeric value to a String with the specified string formatted by NumberFormatInfo.

[Visual Basic]
Overloads Public Shared Function Format( _
   ByVal value As Integer, _
   ByVal format As String, _
   ByVal info As NumberFormatInfo _
) As String
[C#]
public static string Format(
   int value,
   string format,
   NumberFormatInfo info
);
[C++]
public: static String* Format(
   int value,
   String* format,
   NumberFormatInfo* info
);
[JScript]
public static function Format(
   value : int,
   format : String,
   info : NumberFormatInfo
) : String;

Parameters

value
The value to be formatted.
format
The format string.
info
The NumberFormatInfo instance used to format the number.

Return Value

A string representation of value in the format specified by format.

Remarks

If format is null or an empty string, value is formatted as if the general format ("G") string were specified.

The info parameter specifies the NumberFormatInfo instance used to format the number. If info is null, the numeric format information is obtained from the current locale (see NumberFormatInfo and CultureInfo for more infomation on numeric and culture formats).

The NumberFormatInfo supplies information such as the characters to use for decimal and thousand separators, and the spelling and placement of currency symbols in monetary values.

See Also

Int32 Structure | Int32 Members | System Namespace | Int32.Format Overload List | String | NumberStyles


Int32.Format (Int32, String)

Converts a numeric value to a String with the specified format string.

[Visual Basic]
Overloads Public Shared Function Format( _
   ByVal value As Integer, _
   ByVal format As String _
) As String
[C#]
public static string Format(
   int value,
   string format
);
[C++]
public: static String* Format(
   int value,
   String* format
);
[JScript]
public static function Format(
   value : int,
   format : String
) : String;

Parameters

value
The value to be formatted.
format
The format string.

Return Value

A string representation of value in the format specified by format.

Remarks

If format is null or an empty string, value is formatted as if the general format ("G") string were specified. The numeric format information is obtained from the current locale (see NumberFormatInfo and CultureInfo for more infomation on numeric and culture formats).

See Also

Int32 Structure | Int32 Members | System Namespace | Int32.Format Overload List | String


Int32.FromString

Parses an Int32 from a String.

[Visual Basic]
Public Shared Function FromString( _
   ByVal s As String _
) As Integer
[C#]
public static int FromString(
   string s
);
[C++]
public: static int FromString(
   String* s
);
[JScript]
public static function FromString(
   s : String
) : int;

Parameters

s
The string containing a number to convert.

Return Value

The Int32 value of the string.

Remarks

The Int32 method returns a signed int from parsing a string. The default (locale-neutral) NumberFormatInfo is used (see NumberFormatInfo or CultureInfo for more information on numeric and culture formats).

Use Parse and Format for locale dependent strings.

The output from ToString should be consumable by FromString().

See Also

Int32 Structure | Int32 Members | System Namespace


Int32.GetHashCode

Returns the hash code for this Int32.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

A hash code for this instance.

Remarks

GetHashCode returns the absolute value of the int contained in the hash code.

See Also

Int32 Structure | Int32 Members | System Namespace | UInt32 | IHashCodeProvider


Int32.GetTypeCode

Retrieves the type code of an object.

[Visual Basic]
Overridable Public Function GetTypeCode() As TypeCode
[C#]
public virtual TypeCode GetTypeCode();
[C++]
public: virtual TypeCode GetTypeCode();
[JScript]
public function GetTypeCode() : TypeCode;

Return Value

A type code.

Remarks

The GetTypeCode method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See TypeCode enumeration for more information about type codes.)

See Also

Int32 Structure | Int32 Members | System Namespace | TypeCode | IConvertible


Int32.Parse

Converts a String to an Int32.

Overload List

Converts a String to an Int32.

[Visual Basic] Overloads Public Shared Function Parse(String) As Integer
[C#] public static int Parse(String);
[C++] public: static int Parse(String*);
[JScript] public static function Parse(String) : int;

Converts a String representation of a value to an Int32.

[Visual Basic] Overloads Public Shared Function Parse(String, NumberStyles, NumberFormatInfo) As Integer
[C#] public static int Parse(String, NumberStyles, NumberFormatInfo);
[C++] public: static int Parse(String*, NumberStyles, NumberFormatInfo);
[JScript] public static function Parse(String, NumberStyles, NumberFormatInfo) : int;

Converts a String to an Int32 with a specified style.

[Visual Basic] Overloads Public Shared Function Parse(String, NumberStyles) As Integer
[C#] public static int Parse(String, NumberStyles);
[C++] public: static int Parse(String*, NumberStyles);
[JScript] public static function Parse(String, NumberStyles) : int;

See Also

Int32 Structure | Int32 Members | System Namespace


Int32.Parse (String)

Converts a String to an Int32.

[Visual Basic]
Overloads Public Shared Function Parse( _
   ByVal s As String _
) As Integer
[C#]
public static int Parse(
   string s
);
[C++]
public: static int Parse(
   String* s
);
[JScript]
public static function Parse(
   s : String
) : int;

Parameters

s
The string to be converted.

Return Value

An Int32 with the value represented by s.

Exceptions

Exception Type | Condition
ArgumentNullException | If s is a null reference (in Visual Basic Nothing).
FormatException | If s is not a real number.
OverflowException | If s represents a number that is less than MinValue or greater than MaxValue.

Remarks

The string is parsed according to the NumberFormatInfo object associated with the CultureInfo of the current thread, and the permitted style from Integer of NumberStyles.

In order to make a conversion, the s parameter should be a string of a sequence of digits with an optional leading sign. Leading and trailing white space is permitted, but ignored.

Note Hexadecimal strings ("0x42") are not supported. Use Value or Convert ToIntxx(string, int) and ToUIntxx methods for the conversions.
Note The Parse methods do not accept not a number (NaN) or positive or negative infinity.

See Also

Int32 Structure | Int32 Members | System Namespace | Int32.Parse Overload List | String | Value | Convert | MaxValue | MinValue | NaN | NaN | PositiveInfinity | PositiveInfinity | NegativeInfinity | NegativeInfinity


Int32.Parse (String, NumberStyles, NumberFormatInfo)

Converts a String representation of a value to an Int32.

[Visual Basic]
Overloads Public Shared Function Parse( _
   ByVal s As String, _
   ByVal style As NumberStyles, _
   ByVal info As NumberFormatInfo _
) As Integer
[C#]
public static int Parse(
   string s,
   NumberStyles style,
   NumberFormatInfo info
);
[C++]
public: static int Parse(
   String* s,
   NumberStyles style,
   NumberFormatInfo* info
);
[JScript]
public static function Parse(
   s : String,
   style : NumberStyles,
   info : NumberFormatInfo
) : int;

Parameters

s
The String to be interpreted.
style
The permitted style of the numeric string.
info
The NumberFormatInfo instance used to format the string.

Return Value

An Int32 with the value represented by s.

Remarks

The Parse method converts a string to a numeric value.

If s has been created by one of the Format methods using C, D, E, F, G, or N as the format specifier, it is guaranteed that s can be parsed when style is NumberStyles enumeration.

The style parameter must be a combination of bit flags from the NumberStyles enumeration

If the info parameter is null, the numeric format information is obtained from the current locale. If the NumberFormatInfo is not specified, the current culture is the default (see NumberFormatInfo and CultureInfo for more information on numeric and culture formats).

Note Hexadecimal strings ("0x42") are not supported. Use Value or Convert ToIntxx(string, int) and ToUIntxx methods for the conversions.
Note The Parse methods do not accept not a number (NaN) or positive or negative infinity.

See Also

Int32 Structure | Int32 Members | System Namespace | Int32.Parse Overload List | String | Value | Convert | NaN | NaN | PositiveInfinity | PositiveInfinity | NegativeInfinity | NegativeInfinity


Int32.Parse (String, NumberStyles)

Converts a String to an Int32 with a specified style.

[Visual Basic]
Overloads Public Shared Function Parse( _
   ByVal s As String, _
   ByVal style As NumberStyles _
) As Integer
[C#]
public static int Parse(
   string s,
   NumberStyles style
);
[C++]
public: static int Parse(
   String* s,
   NumberStyles style
);
[JScript]
public static function Parse(
   s : String,
   style : NumberStyles
) : int;

Parameters

s
The string to be interpreted.
style
The permitted style of the numeric string.

Return Value

An Int32 with the value represented by s.

Remarks

If s has been created by one of the format methods using C, D, E, F, G, or N as the format specifier, it is guaranteed that s can be parsed when style is NumberStyles enumeration.

The style parameter must be a combination of bit flags from the NumberStyles enumeration. The numeric format information is obtained from the current locale (see NumberFormatInfo and CultureInfo for more information on numeric and culture formats).

Note Hexadecimal strings ("0x42") are not supported. Use Value or Convert ToIntxx(string, int) and ToUIntxx methods for the conversions.
Note The Parse methods does not accept not a number (NaN), or negative or positive infinity.

See Also

Int32 Structure | Int32 Members | System Namespace | Int32.Parse Overload List | String | Value | Convert | NaN | NaN | PositiveInfinity | PositiveInfinity | NegativeInfinity | NegativeInfinity


Int32.ToBoolean

[To be supplied.]

[Visual Basic]
Overridable Public Function ToBoolean() As Boolean
[C#]
public virtual bool ToBoolean();
[C++]
public: virtual bool ToBoolean();
[JScript]
public function ToBoolean() : Boolean;

See Also

Int32 Structure | Int32 Members | System Namespace


Int32.ToByte

[To be supplied.]

[Visual Basic]
Overridable Public Function ToByte() As Byte
[C#]
public virtual byte ToByte();
[C++]
public: virtual unsigned char ToByte();
[JScript]
public function ToByte() : Byte;

See Also

Int32 Structure | Int32 Members | System Namespace


Int32.ToChar

[To be supplied.]

[Visual Basic]
Overridable Public Function ToChar() As Char
[C#]
public virtual char ToChar();
[C++]
public: virtual __wchar_t ToChar();
[JScript]
public function ToChar() : Char;

See Also

Int32 Structure | Int32 Members | System Namespace


Int32.ToDateTime

[To be supplied.]

[Visual Basic]
Overridable Public Function ToDateTime() As DateTime
[C#]
public virtual DateTime ToDateTime();
[C++]
public: virtual DateTime ToDateTime();
[JScript]
public function ToDateTime() : DateTime;

See Also

Int32 Structure | Int32 Members | System Namespace


Int32.ToDecimal

[To be supplied.]

[Visual Basic]
Overridable Public Function ToDecimal() As Decimal
[C#]
public virtual Decimal ToDecimal();
[C++]
public: virtual Decimal ToDecimal();
[JScript]
public function ToDecimal() : Decimal;

See Also

Int32 Structure | Int32 Members | System Namespace


Int32.ToDouble

[To be supplied.]

[Visual Basic]
Overridable Public Function ToDouble() As Double
[C#]
public virtual double ToDouble();
[C++]
public: virtual double ToDouble();
[JScript]
public function ToDouble() : double;

See Also

Int32 Structure | Int32 Members | System Namespace


Int32.ToInt16

[To be supplied.]

[Visual Basic]
Overridable Public Function ToInt16() As Short
[C#]
public virtual short ToInt16();
[C++]
public: virtual short ToInt16();
[JScript]
public function ToInt16() : Int16;

See Also

Int32 Structure | Int32 Members | System Namespace


Int32.ToInt32

[To be supplied.]

[Visual Basic]
Overridable Public Function ToInt32() As Integer
[C#]
public virtual int ToInt32();
[C++]
public: virtual int ToInt32();
[JScript]
public function ToInt32() : int;

See Also

Int32 Structure | Int32 Members | System Namespace


Int32.ToInt64

[To be supplied.]

[Visual Basic]
Overridable Public Function ToInt64() As Long
[C#]
public virtual long ToInt64();
[C++]
public: virtual __int64 ToInt64();
[JScript]
public function ToInt64() : long;

See Also

Int32 Structure | Int32 Members | System Namespace


Int32.ToSByte

[To be supplied.]

[Visual Basic]
Overridable Public Function ToSByte() As SByte
[C#]
public virtual sbyte ToSByte();
[C++]
public: virtual char ToSByte();
[JScript]
public function ToSByte() : SByte;

See Also

Int32 Structure | Int32 Members | System Namespace


Int32.ToSingle

[To be supplied.]

[Visual Basic]
Overridable Public Function ToSingle() As Single
[C#]
public virtual float ToSingle();
[C++]
public: virtual float ToSingle();
[JScript]
public function ToSingle() : float;

See Also

Int32 Structure | Int32 Members | System Namespace


Int32.ToString

Converts an Int32 to a String.

Overload List

Converts a String representation of a specified number.

[Visual Basic] Overloads Public Shared Function ToString(Integer) As String
[C#] public static string ToString(int);
[C++] public: static String* ToString(int);
[JScript] public static function ToString(int) : String;

Returns a String representation of this instance.

[Visual Basic] Overloads Overrides Public Function ToString() As String
[C#] public override string ToString();
[C++] public: override String* ToString();
[JScript] public override function ToString() : String;

See Also

Int32 Structure | Int32 Members | System Namespace


Int32.ToString (Int32)

Converts a String representation of a specified number.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal i As Integer _
) As String
[C#]
public static string ToString(
   int i
);
[C++]
public: static String* ToString(
   int i
);
[JScript]
public static function ToString(
   i : int
) : String;

Parameters

i
An Int32 value.

Return Value

The result of converting the Int32 value to a string.

Remarks

The ToString methods returns the base 10 representation of the number with no extra padding.

If i is negative, the first character in the string returned is a negative sign character ('-'). No sign character is returned if the number is non-negative. The rest of the string returned is made up of characters representing the magnitude of i.

Leading zero characters ('0') are not prepended to the returned string.

The following characters are used as digits: 0, 1, 2, 3, 4, 5, 6, 7, 8, or 9.

The output from ToString should be consumable by FromString.

See Also

Int32 Structure | Int32 Members | System Namespace | Int32.ToString Overload List | String


Int32.ToString ()

Returns a String representation of this instance.

[Visual Basic]
Overloads Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

The result of converting this Int32 to a string.

Remarks

The ToString method returns the base 10 representation of the number with no extra padding.

If this instance is negative, then the first character in the string returned will be a negative sign character ('-'). No sign character is returned if the number is non-negative. The rest of the string returned is made up of characters representing the magnitude of this instance.

Leading zero characters ('0') are not prepended to the returned string.

The following characters are used as digits: 0, 1, 2, 3, 4, 5, 6, 7, 8, or 9.

The output from ToString should be consumable by FromString.

Overrides ToString.

See Also

Int32 Structure | Int32 Members | System Namespace | Int32.ToString Overload List | String | Object


Int32.ToType

[To be supplied.]

[Visual Basic]
Overridable Public Function ToType( _
   ByVal type As Type _
) As Object
[C#]
public virtual object ToType(
   Type type
);
[C++]
public: virtual Object* ToType(
   Type* type
);
[JScript]
public function ToType(
   type : Type
) : Object;

Parameters

type
[To be supplied.]

See Also

Int32 Structure | Int32 Members | System Namespace


Int32.ToUInt16

[To be supplied.]

[Visual Basic]
Overridable Public Function ToUInt16() As UInt16
[C#]
public virtual ushort ToUInt16();
[C++]
public: virtual unsigned short ToUInt16();
[JScript]
public function ToUInt16() : UInt16;

See Also

Int32 Structure | Int32 Members | System Namespace


Int32.ToUInt32

[To be supplied.]

[Visual Basic]
Overridable Public Function ToUInt32() As UInt32
[C#]
public virtual uint ToUInt32();
[C++]
public: virtual unsigned int ToUInt32();
[JScript]
public function ToUInt32() : UInt32;

See Also

Int32 Structure | Int32 Members | System Namespace


Int32.ToUInt64

[To be supplied.]

[Visual Basic]
Overridable Public Function ToUInt64() As UInt64
[C#]
public virtual ulong ToUInt64();
[C++]
public: virtual unsigned __int64 ToUInt64();
[JScript]
public function ToUInt64() : UInt64;

See Also

Int32 Structure | Int32 Members | System Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Int32 Fields

The fields of the Int32 structure are listed below. For a complete list of Int32 structure members, see the Int32 Members topic.

Public:

Empty | Representing the constant of an empty Int32 value.
MaxValue | Representing the constant value of the largest possible Int32.
MinValue | Representing the constant of the smallest possible Int32 value.

See Also

Int32 Structure | System Namespace


Int32.Empty

Representing the constant of an empty Int32 value.

[Visual Basic]
Public Const Empty As Integer
[C#]
public const int Empty;
[C++]
public: const int Empty;
[JScript]
public var Empty : int;

Remarks

The Empty hexadecimal value is 0x0.

See Also

Int32 Structure | Int32 Members | System Namespace | Empty


Int32.MaxValue

Representing the constant value of the largest possible Int32.

[Visual Basic]
Public Const MaxValue As Integer
[C#]
public const int MaxValue;
[C++]
public: const int MaxValue;
[JScript]
public var MaxValue : int;

Remarks

The MaxValue hexadecimal value is 0x7fffffff.

See Also

Int32 Structure | Int32 Members | System Namespace


Int32.MinValue

Representing the constant of the smallest possible Int32 value.

[Visual Basic]
Public Const MinValue As Integer
[C#]
public const int MinValue;
[C++]
public: const int MinValue;
[JScript]
public var MinValue : int;

Remarks

The MinValue hexadecimal value is unchecked ((int)0x80000000).

See Also

Int32 Structure | Int32 Members | System Namespace


Int64 Structure

Represents a 64-bit signed integer.

Object
ValueType
Int64

[Visual Basic]
Public Structure Int64
   Implements IComparable, IFormattable, IConvertible
[C#]
public struct Int64 : IComparable, IFormattable, IConvertible
[C++]
public __value struct Int64 : public IComparable, IFormattable,
   IConvertible

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

The Int64 class is a value type that represents an eight-byte signed integer. This class will encapsulate a 64-bit signed integer (long) and provide an Object representation of it.

The Int64 data type can represent integers with 18 significant digits in the range negative 9,223,372,036,854,775,808 through positive 9,223,372,036,854,775,807, inclusive.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

Int64 Members | System Namespace | Object | UInt64


Int64 Members

Public:

Methods

CompareTo | Compares this instance to the specified Object.
Equals | Compares this instance with a specified Object.
Format | Overloaded. Converts a value to a String.
FromString | Parses an Int64 from a String.
GetHashCode | Returns the hash code for this Int64.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | Retrieves the type code of an object.
Parse | Overloaded. Converts a String to an Int64.
ToBoolean | [To be supplied.]
ToByte | [To be supplied.]
ToChar | [To be supplied.]
ToDateTime | [To be supplied.]
ToDecimal | [To be supplied.]
ToDouble | [To be supplied.]
ToInt16 | [To be supplied.]
ToInt32 | [To be supplied.]
ToInt64 | [To be supplied.]
ToSByte | [To be supplied.]
ToSingle | [To be supplied.]
ToString | Overloaded. Converts this instance of Int64 to a String.
ToType | [To be supplied.]
ToUInt16 | [To be supplied.]
ToUInt32 | [To be supplied.]
ToUInt64 | [To be supplied.]

Fields

Empty | Constant representing an empty Int64 value.
MaxValue | Constant representing the largest possible Int64 value.
MinValue | Constant representing the smallest possible Int64 value.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Int64 Structure | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Int64 Methods

The methods of the Int64 structure are listed below. For a complete list of Int64 structure members, see the Int64 Members topic.

Public:

CompareTo | Compares this instance to the specified Object.
Equals | Compares this instance with a specified Object.
Format | Overloaded. Converts a value to a String.
FromString | Parses an Int64 from a String.
GetHashCode | Returns the hash code for this Int64.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | Retrieves the type code of an object.
Parse | Overloaded. Converts a String to an Int64.
ToBoolean | [To be supplied.]
ToByte | [To be supplied.]
ToChar | [To be supplied.]
ToDateTime | [To be supplied.]
ToDecimal | [To be supplied.]
ToDouble | [To be supplied.]
ToInt16 | [To be supplied.]
ToInt32 | [To be supplied.]
ToInt64 | [To be supplied.]
ToSByte | [To be supplied.]
ToSingle | [To be supplied.]
ToString | Overloaded. Converts this instance of Int64 to a String.
ToType | [To be supplied.]
ToUInt16 | [To be supplied.]
ToUInt32 | [To be supplied.]
ToUInt64 | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Int64 Structure | System Namespace


Int64.CompareTo

Compares this instance to the specified Object.

[Visual Basic]
Overridable Public Function CompareTo( _
   ByVal value As Object _
) As Integer
[C#]
public virtual int CompareTo(
   object value
);
[C++]
public: virtual int CompareTo(
   Object* value
);
[JScript]
public function CompareTo(
   value : Object
) : int;

Parameters

value
An object to compare with this instance.

Return Value

Value Type | Condition
A negative integer | If this instance is less than the object.
Zero | If this instance and the object have the same value.
A positive integer | If this instance is greater than the object.
A positive integer | If the object is a null reference (in Visual Basic Nothing). This is a special case

Exceptions

Exception Type | Condition
ArgumentException | If the object is not a null reference and is not a type Int64.

Remarks

When comparing two Int64 values, canonical ordering is used. As a special case, an instance, regardless of its value, is considered to be greater than a null reference.

You should use the CompareTo method instead of subtraction because very large negative numbers will wrap to positive.

The object parameter must be a Int64 type and a null reference.

See Also

Int64 Structure | Int64 Members | System Namespace | Object


Int64.Equals

Compares this instance with a specified Object.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The object to compare with this instance.

Return Value

true if the object is an Int64 with the same value as this instance; otherwise, false.

Remarks

The Equals method compares two objects and returns the Boolean determination of their relationhip.

Overrides Equals.

See Also

Int64 Structure | Int64 Members | System Namespace | Boolean | Object


Int64.Format

Converts a value to a String.

Overload List

Converts the value of this instance to a String with the specified format string.

[Visual Basic] Overloads Overridable Public Function Format(String, IServiceObjectProvider) As String
[C#] public virtual string Format(String, IServiceObjectProvider);
[C++] public: virtual String* Format(String*, IServiceObjectProvider);
[JScript] public function Format(String, IServiceObjectProvider) : String;

Converts a numeric value to a String with the specified format string.

[Visual Basic] Overloads Public Shared Function Format(Long, String, NumberFormatInfo) As String
[C#] public static string Format(long, String, NumberFormatInfo);
[C++] public: static String* Format(__int64, String, NumberFormatInfo);
[JScript] public static function Format(long, String, NumberFormatInfo) : String;

Converts a numeric value to a String with the specified format string.

[Visual Basic] Overloads Public Shared Function Format(Long, String) As String
[C#] public static string Format(long, String);
[C++] public: static String* Format(__int64, String);
[JScript] public static function Format(long, String) : String;

See Also

Int64 Structure | Int64 Members | System Namespace


Int64.Format (String, IServiceObjectProvider)

Converts the value of this instance to a String with the specified format string.

[Visual Basic]
Overloads Overridable Public Function Format( _
   ByVal format As String, _
   ByVal sop As IServiceObjectProvider _
) As String
[C#]
public virtual string Format(
   string format,
   IServiceObjectProvider sop
);
[C++]
public: virtual String* Format(
   String* format,
   IServiceObjectProvider* sop
);
[JScript]
public function Format(
   format : String,
   sop : IServiceObjectProvider
) : String;

Parameters

format
The format string.
sop
The IServiceObjectProvider used to format the number.

Return Value

A string representation for the value of this instance in the format specified by format.

Remarks

If format is null or an empty string, the number is formatted as if the general format ("G") string were specified.

The sop parameter specifies the format provider from which the NumberFormatInfo instance will be obtained. NumberFormatInfo supplies information such as the characters to use for decimal and thousand separators, and the spelling and placement of currency symbols in monetary values.

If sop is null, the numeric format information is obtained from the current locale (see NumberFormatInfo and CultureInfo for more information on numeric and culture formats).

See Also

Int64 Structure | Int64 Members | System Namespace | Int64.Format Overload List | String | IServiceObjectProvider


Int64.Format (Int64, String, NumberFormatInfo)

Converts a numeric value to a String with the specified format string.

[Visual Basic]
Overloads Public Shared Function Format( _
   ByVal value As Long, _
   ByVal format As String, _
   ByVal info As NumberFormatInfo _
) As String
[C#]
public static string Format(
   long value,
   string format,
   NumberFormatInfo info
);
[C++]
public: static String* Format(
   __int64 value,
   String* format,
   NumberFormatInfo* info
);
[JScript]
public static function Format(
   value : long,
   format : String,
   info : NumberFormatInfo
) : String;

Parameters

value
The value to be formatted.
format
The format string.
info
The NumberFormatInfo instance used to format the number.

Return Value

A string representation of the value in the specified.

Remarks

If format is null or an empty string, value is formatted as if the general format ("G") string were specified.

The info parameter specifies the NumberFormatInfo instance used to format the number. The NumberFormatInfo supplies information such as the characters to use for decimal and thousand separators, and the spelling and placement of currency symbols in monetary values.

If info is null, the numeric format information is obtained from the current locale (see NumberFormatInfo and CultureInfo for more information on numeric and culture formats).

See Also

Int64 Structure | Int64 Members | System Namespace | Int64.Format Overload List | String


Int64.Format (Int64, String)

Converts a numeric value to a String with the specified format string.

[Visual Basic]
Overloads Public Shared Function Format( _
   ByVal value As Long, _
   ByVal format As String _
) As String
[C#]
public static string Format(
   long value,
   string format
);
[C++]
public: static String* Format(
   __int64 value,
   String* format
);
[JScript]
public static function Format(
   value : long,
   format : String
) : String;

Parameters

value
The value to be formatted.
format
The format string.

Return Value

A string representation of the value in the format specified by format.

Remarks

If format is null or an empty string, value is formatted as if the general format ("G") string were specified.

The numeric format information is obtained from the current locale (see NumberFormatInfo and CultureInfo for more information on numeric and culture formats).

See Also

Int64 Structure | Int64 Members | System Namespace | Int64.Format Overload List | String


Int64.FromString

Parses an Int64 from a String.

[Visual Basic]
Public Shared Function FromString( _
   ByVal s As String _
) As Long
[C#]
public static long FromString(
   string s
);
[C++]
public: static __int64 FromString(
   String* s
);
[JScript]
public static function FromString(
   s : String
) : long;

Parameters

s
The string containing a number to convert.

Return Value

Returns an Int64 parsed from the specified string.

Exceptions

Exception Type | Condition
ArgumentException | If s is a null reference (in Visual Basic Nothing).
FormatException | If s does not contain a real number.
OverflowException | If s is greater than 0x7FFFFFFFFFFFFFFF or less than 0x8000000000000000.

Remarks

The default (locale-neutral) NumberFormatInfo is used.

Use Parse and Format for locale dependent strings. The output from ToString should be consumable by FromString().

See Also

Int64 Structure | Int64 Members | System Namespace | String | CultureInfo | NumberFormatInfo


Int64.GetHashCode

Returns the hash code for this Int64.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

A hash code for this instance.

Remarks

The GetHashCode returns the value of the upper 32-bits.

See Also

Int64 Structure | Int64 Members | System Namespace | IHashCodeProvider | UInt64


Int64.GetTypeCode

Retrieves the type code of an object.

[Visual Basic]
Overridable Public Function GetTypeCode() As TypeCode
[C#]
public virtual TypeCode GetTypeCode();
[C++]
public: virtual TypeCode GetTypeCode();
[JScript]
public function GetTypeCode() : TypeCode;

Return Value

A type code.

Remarks

The GetTypeCode method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See TypeCode enumeration for more information about type codes.)

See Also

Int64 Structure | Int64 Members | System Namespace | TypeCode | IConvertible


Int64.Parse

Converts a String to an Int64.

Overload List

Converts a String to an Int64.

[Visual Basic] Overloads Public Shared Function Parse(String) As Long
[C#] public static long Parse(String);
[C++] public: static __int64 Parse(String*);
[JScript] public static function Parse(String) : long;

Converts a String to an Int64.

[Visual Basic] Overloads Public Shared Function Parse(String, NumberStyles, NumberFormatInfo) As Long
[C#] public static long Parse(String, NumberStyles, NumberFormatInfo);
[C++] public: static __int64 Parse(String*, NumberStyles, NumberFormatInfo);
[JScript] public static function Parse(String, NumberStyles, NumberFormatInfo) : long;

Converts a String representation of a value to an Int64.

[Visual Basic] Overloads Public Shared Function Parse(String, NumberStyles) As Long
[C#] public static long Parse(String, NumberStyles);
[C++] public: static __int64 Parse(String*, NumberStyles);
[JScript] public static function Parse(String, NumberStyles) : long;

See Also

Int64 Structure | Int64 Members | System Namespace


Int64.Parse (String)

Converts a String to an Int64.

[Visual Basic]
Overloads Public Shared Function Parse( _
   ByVal s As String _
) As Long
[C#]
public static long Parse(
   string s
);
[C++]
public: static __int64 Parse(
   String* s
);
[JScript]
public static function Parse(
   s : String
) : long;

Parameters

s
The string to be interpreted.

Return Value

An Int64 with the value represented by s.

Exceptions

Exception Type | Condition
ArgumentNullException | If the string is a null reference (in Visual Basic Nothing).
FormatException | If the string is not the correct format.
OverflowException | If the string represents a number that is less than MinValue or greater than MaxValue.

Remarks

The numeric format information is obtained from the current locale (see NumberFormatInfo and CultureInfo for more information on numeric and culture formats). The string s should be the return value of one of the format methods.

The string must consist of an optional minus sign ("-") followed by a sequence of digits ("0" through "9"). Leading and trailing white space characters are ignored.

An exception will be thrown if s does not match one of the following regular expressions:

[0-9]*\.[0-9]+;

[0-9]*\.[0-9]+e\+[0-9]+;

[0-9]*\.[0-9]+e[0-9]+;

[0-9]*\.[0-9]+e\-[0-9]+;

[0-9]+e\-[0-9]+;

[0-9]+e\+[0-9]+;

[0-9]+e[0-9]+.

Note Hexadecimal strings ("0x42") are not supported. Use Value or Convert ToIntxx(string, int) and ToUIntxx methods for the conversions.
Note The Parse methods do not accept not a number (NaN) or positive or negative infinity.

See Also

Int64 Structure | Int64 Members | System Namespace | Int64.Parse Overload List | String | MaxValue | MinValue | Value | Convert | NaN | NaN | PositiveInfinity | PositiveInfinity | NegativeInfinity | NegativeInfinity


Int64.Parse (String, NumberStyles, NumberFormatInfo)

Converts a String to an Int64.

[Visual Basic]
Overloads Public Shared Function Parse( _
   ByVal s As String, _
   ByVal style As NumberStyles, _
   ByVal info As NumberFormatInfo _
) As Long
[C#]
public static long Parse(
   string s,
   NumberStyles style,
   NumberFormatInfo info
);
[C++]
public: static __int64 Parse(
   String* s,
   NumberStyles style,
   NumberFormatInfo* info
);
[JScript]
public static function Parse(
   s : String,
   style : NumberStyles,
   info : NumberFormatInfo
) : long;

Parameters

s
The string to be interpreted.
style
The permitted style of the numeric string.
info
The NumberFormatInfo instance used to format the string.

Return Value

An Int64 with the value represented by s.

Exceptions

Exception Type | Condition
ArgumentException | If the string is a null reference (in Visual Basic Nothing).
ArgumentException | If style is not a combination of bit flags from the NumberStyles enumeration.
FormatException | If the sting is not of the correct format.
OverflowException | If the string represents a number that is less than MinValue or greater than MaxValue.

Remarks

If s has been created by one of the Format methods using C, D, E, F, G, or N as the format specifier, it is guaranteed that s can be parsed when style is Any of NumberStyles.

The style parameter must be a combination of bit flags from the NumberStyles enumeration.

If the info parameter is null the numeric format information is obtained from the current locale (see NumberFormatInfo and CultureInfo for more information on numeric and culture formats).

Note Hexadecimal strings ("0x42") are not supported. Use Value or Convert ToIntxx(string, int) and ToUIntxx methods for the conversions.
Note The Parse methods do not accept not a number (NaN) or positive or negative infinity.

See Also

Int64 Structure | Int64 Members | System Namespace | Int64.Parse Overload List | String | Value | Convert | MaxValue | MinValue | NaN | NaN | PositiveInfinity | PositiveInfinity | NegativeInfinity | NegativeInfinity


Int64.Parse (String, NumberStyles)

Converts a String representation of a value to an Int64.

[Visual Basic]
Overloads Public Shared Function Parse( _
   ByVal s As String, _
   ByVal style As NumberStyles _
) As Long
[C#]
public static long Parse(
   string s,
   NumberStyles style
);
[C++]
public: static __int64 Parse(
   String* s,
   NumberStyles style
);
[JScript]
public static function Parse(
   s : String,
   style : NumberStyles
) : long;

Parameters

s
The string to be interpreted.
style
The permitted style of the numeric string. It must be a combination of bit flags from the NumberStyles enumeration.

Return Value

Returns an Int64 with the value represented by s.

Exceptions

Exception Type | Condition
ArgumentException | If style is not a NumberStyles enumeration.
ArgumentNullException | If the string is a null reference (in Visual Basic Nothing).
FormatException | If the string is not of the correct format.
OverflowException | If the string represents a number that is less than MinValue or greater than MaxValue.

Remarks

The numeric format information is obtained from the current locale (see NumberFormatInfo and CultureInfo for more information on numeric and culture formats).

If s has been created by one of the Format methods using C, D, E, F, G, or N as the format specifier, it is guaranteed that s can be parsed when style is NumberStyles enumeration.

Note Hexadecimal strings ("0x42") are not supported. Use Value or Convert ToIntxx(string, int) and ToUIntxx methods for the conversions.
Note The Parse methods do not accept not a number (NaN) or positive or negative infinity.

See Also

Int64 Structure | Int64 Members | System Namespace | Int64.Parse Overload List | String | MaxValue | MinValue | Value | Convert | NaN | NaN | PositiveInfinity | PositiveInfinity | NegativeInfinity | NegativeInfinity


Int64.ToBoolean

[To be supplied.]

[Visual Basic]
Overridable Public Function ToBoolean() As Boolean
[C#]
public virtual bool ToBoolean();
[C++]
public: virtual bool ToBoolean();
[JScript]
public function ToBoolean() : Boolean;

See Also

Int64 Structure | Int64 Members | System Namespace


Int64.ToByte

[To be supplied.]

[Visual Basic]
Overridable Public Function ToByte() As Byte
[C#]
public virtual byte ToByte();
[C++]
public: virtual unsigned char ToByte();
[JScript]
public function ToByte() : Byte;

See Also

Int64 Structure | Int64 Members | System Namespace


Int64.ToChar

[To be supplied.]

[Visual Basic]
Overridable Public Function ToChar() As Char
[C#]
public virtual char ToChar();
[C++]
public: virtual __wchar_t ToChar();
[JScript]
public function ToChar() : Char;

See Also

Int64 Structure | Int64 Members | System Namespace


Int64.ToDateTime

[To be supplied.]

[Visual Basic]
Overridable Public Function ToDateTime() As DateTime
[C#]
public virtual DateTime ToDateTime();
[C++]
public: virtual DateTime ToDateTime();
[JScript]
public function ToDateTime() : DateTime;

See Also

Int64 Structure | Int64 Members | System Namespace


Int64.ToDecimal

[To be supplied.]

[Visual Basic]
Overridable Public Function ToDecimal() As Decimal
[C#]
public virtual Decimal ToDecimal();
[C++]
public: virtual Decimal ToDecimal();
[JScript]
public function ToDecimal() : Decimal;

See Also

Int64 Structure | Int64 Members | System Namespace


Int64.ToDouble

[To be supplied.]

[Visual Basic]
Overridable Public Function ToDouble() As Double
[C#]
public virtual double ToDouble();
[C++]
public: virtual double ToDouble();
[JScript]
public function ToDouble() : double;

See Also

Int64 Structure | Int64 Members | System Namespace


Int64.ToInt16

[To be supplied.]

[Visual Basic]
Overridable Public Function ToInt16() As Short
[C#]
public virtual short ToInt16();
[C++]
public: virtual short ToInt16();
[JScript]
public function ToInt16() : Int16;

See Also

Int64 Structure | Int64 Members | System Namespace


Int64.ToInt32

[To be supplied.]

[Visual Basic]
Overridable Public Function ToInt32() As Integer
[C#]
public virtual int ToInt32();
[C++]
public: virtual int ToInt32();
[JScript]
public function ToInt32() : int;

See Also

Int64 Structure | Int64 Members | System Namespace


Int64.ToInt64

[To be supplied.]

[Visual Basic]
Overridable Public Function ToInt64() As Long
[C#]
public virtual long ToInt64();
[C++]
public: virtual __int64 ToInt64();
[JScript]
public function ToInt64() : long;

See Also

Int64 Structure | Int64 Members | System Namespace


Int64.ToSByte

[To be supplied.]

[Visual Basic]
Overridable Public Function ToSByte() As SByte
[C#]
public virtual sbyte ToSByte();
[C++]
public: virtual char ToSByte();
[JScript]
public function ToSByte() : SByte;

See Also

Int64 Structure | Int64 Members | System Namespace


Int64.ToSingle

[To be supplied.]

[Visual Basic]
Overridable Public Function ToSingle() As Single
[C#]
public virtual float ToSingle();
[C++]
public: virtual float ToSingle();
[JScript]
public function ToSingle() : float;

See Also

Int64 Structure | Int64 Members | System Namespace


Int64.ToString

Converts this instance of Int64 to a String.

Overload List

Converts a specified Int64 to a String.

[Visual Basic] Overloads Public Shared Function ToString(Long) As String
[C#] public static string ToString(long);
[C++] public: static String* ToString(__int64);
[JScript] public static function ToString(long) : String;

Converts this instance of Int64 to a String.

[Visual Basic] Overloads Overrides Public Function ToString() As String
[C#] public override string ToString();
[C++] public: override String* ToString();
[JScript] public override function ToString() : String;

See Also

Int64 Structure | Int64 Members | System Namespace


Int64.ToString (Int64)

Converts a specified Int64 to a String.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal l As Long _
) As String
[C#]
public static string ToString(
   long l
);
[C++]
public: static String* ToString(
   __int64 l
);
[JScript]
public static function ToString(
   l : long
) : String;

Parameters

l
The Int64 to be converted.

Return Value

The string representation of the Int64.

Remarks

The ToString method is a base-10 representation of the number with no extra padding. If the value is negative, the first character in the string returned will be '-'. No sign character is returned if the number is non-negative. The rest of the string returned is made up of characters representing the magnitude of the number.

Leading zero characters ('0') are not prepended to the returned string.

The following characters are used as digits: 0, 1, 2, 3, 4, 5, 6, 7, 8, and 9.

The output from ToString should be consumable by FromString.

See Also

Int64 Structure | Int64 Members | System Namespace | Int64.ToString Overload List | String | Format | NumberFormatInfo


Int64.ToString ()

Converts this instance of Int64 to a String.

[Visual Basic]
Overloads Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

The string representation of this instance.

Remarks

The ToString method is a base-10 representation of the number with no extra padding. If this instance is negative, the first character in the string returned will be '-'. No sign character is returned if the number is non-negative. The rest of the returned string is made up of characters representing the magnitude of this instance.

Leading zero characters ('0') are not prepended to the returned string.

The following characters are used as digits: 0, 1, 2, 3, 4, 5, 6, 7, 8, and 9.

The output from ToString should be consumable by FromString.

See Also

Int64 Structure | Int64 Members | System Namespace | Int64.ToString Overload List | String | Format | NumberFormatInfo


Int64.ToType

[To be supplied.]

[Visual Basic]
Overridable Public Function ToType( _
   ByVal type As Type _
) As Object
[C#]
public virtual object ToType(
   Type type
);
[C++]
public: virtual Object* ToType(
   Type* type
);
[JScript]
public function ToType(
   type : Type
) : Object;

Parameters

type
[To be supplied.]

See Also

Int64 Structure | Int64 Members | System Namespace


Int64.ToUInt16

[To be supplied.]

[Visual Basic]
Overridable Public Function ToUInt16() As UInt16
[C#]
public virtual ushort ToUInt16();
[C++]
public: virtual unsigned short ToUInt16();
[JScript]
public function ToUInt16() : UInt16;

See Also

Int64 Structure | Int64 Members | System Namespace


Int64.ToUInt32

[To be supplied.]

[Visual Basic]
Overridable Public Function ToUInt32() As UInt32
[C#]
public virtual uint ToUInt32();
[C++]
public: virtual unsigned int ToUInt32();
[JScript]
public function ToUInt32() : UInt32;

See Also

Int64 Structure | Int64 Members | System Namespace


Int64.ToUInt64

[To be supplied.]

[Visual Basic]
Overridable Public Function ToUInt64() As UInt64
[C#]
public virtual ulong ToUInt64();
[C++]
public: virtual unsigned __int64 ToUInt64();
[JScript]
public function ToUInt64() : UInt64;

See Also

Int64 Structure | Int64 Members | System Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Int64 Fields

The fields of the Int64 structure are listed below. For a complete list of Int64 structure members, see the Int64 Members topic.

Public:

Empty | Constant representing an empty Int64 value.
MaxValue | Constant representing the largest possible Int64 value.
MinValue | Constant representing the smallest possible Int64 value.

See Also

Int64 Structure | System Namespace


Int64.Empty

Constant representing an empty Int64 value.

[Visual Basic]
Public Const Empty As Long
[C#]
public const long Empty;
[C++]
public: const __int64 Empty;
[JScript]
public var Empty : long;

Remarks

The Empty hexadecimal value is 0x0.

See Also

Int64 Structure | Int64 Members | System Namespace | Empty


Int64.MaxValue

Constant representing the largest possible Int64 value.

[Visual Basic]
Public Const MaxValue As Long
[C#]
public const long MaxValue;
[C++]
public: const __int64 MaxValue;
[JScript]
public var MaxValue : long;

Remarks

The MaxValue hexadecimal value is 0x7fffffffffffffffL.

See Also

Int64 Structure | Int64 Members | System Namespace


Int64.MinValue

Constant representing the smallest possible Int64 value.

[Visual Basic]
Public Const MinValue As Long
[C#]
public const long MinValue;
[C++]
public: const __int64 MinValue;
[JScript]
public var MinValue : long;

Remarks

The MinValue hexadecimal value is (long) 0x8000000000000000L.

See Also

Int64 Structure | Int64 Members | System Namespace


InvalidCastException Class

Represents an exception that is thrown when an invalid cast occurs.

Object
Exception
SystemException
InvalidCastException

[Visual Basic]
Public Class InvalidCastException
   Inherits SystemException
[C#]
public class InvalidCastException : SystemException
[C++]
public __gc class InvalidCastException : public SystemException
[JScript]
public class InvalidCastException extends SystemException

Remarks

The InvalidCastException is the exception class that is thrown when a bad cast occurs.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

InvalidCastException Members | System Namespace


InvalidCastException Members

Public:

Constructor

InvalidCastException Constructor Overloaded. Initializes an instance of the InvalidCastException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

InvalidCastException Class | System Namespace


InvalidCastException Constructor

Initializes an instance of the InvalidCastException class.

Overload List

Initializes an instance of the InvalidCastException with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public InvalidCastException();
[C++] public: InvalidCastException();
[JScript] public function InvalidCastException();

Initializes an instance of InvalidCastException with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public InvalidCastException(String);
[C++] public: InvalidCastException(String*);
[JScript] public function InvalidCastException(String);

Initializes an instance of InvalidCastException with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public InvalidCastException(String, Exception);
[C++] public: InvalidCastException(String*, Exception);
[JScript] public function InvalidCastException(String, Exception);

See Also

InvalidCastException Class | InvalidCastException Members | System Namespace


InvalidCastException Constructor ()

Initializes an instance of the InvalidCastException with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public InvalidCastException();
[C++]
public: InvalidCastException();
[JScript]
public function InvalidCastException();

Remarks

InvalidCastException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The empty string.

See Also

InvalidCastException Class | InvalidCastException Members | System Namespace | InvalidCastException Constructor Overload List


InvalidCastException Constructor (String)

Initializes an instance of InvalidCastException with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public InvalidCastException(
   string message
);
[C++]
public: InvalidCastException(
   String* message
);
[JScript]
public function InvalidCastException(
   message : String
);

Parameters

message
The message that indicates the reason the exception occurred.

Remarks

InvalidCastException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The message string.

See Also

InvalidCastException Class | InvalidCastException Members | System Namespace | InvalidCastException Constructor Overload List


InvalidCastException Constructor (String, Exception)

Initializes an instance of InvalidCastException with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public InvalidCastException(
   string message,
   Exception inner
);
[C++]
public: InvalidCastException(
   String* message,
   Exception* inner
);
[JScript]
public function InvalidCastException(
   message : String,
   inner : Exception
);

Parameters

message
The message that indicates the reason the exception occurred.
inner
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

InvalidCastException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The empty string.

See Also

InvalidCastException Class | InvalidCastException Members | System Namespace | InvalidCastException Constructor Overload List


InvalidOperationException Class

Represents an exception that is thrown when a method is invoked and, due to the current state of the object involved, the invocation is invalid.

Object
Exception
SystemException
InvalidOperationException

[Visual Basic]
Public Class InvalidOperationException
   Inherits SystemException
[C#]
public class InvalidOperationException : SystemException
[C++]
public __gc class InvalidOperationException : public
   SystemException
[JScript]
public class InvalidOperationException extends SystemException

Remarks

The InvalidOperationException is the exception class that is thrown when it denotes an object is in a state that mades calling a method illegal.

An InvalidOperationException should be used when an invocation fails and the failure was not caused by invalid arguments. For example, since DictionaryEnumerator.GetNext() is not a valid method it will throw an InvalidOperationException if the underlying set of objects is modified subsequent to the creation of the enumerator, and GetString throws an InvalidOperationException if the resource set has been closed.

On the other hand, if the invocation fails due to invalid arguments, then ArgumentException or one of its subclasses, ArgumentNullException or ArgumentOutOfRangeException, should be thrown.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

InvalidOperationException Members | System Namespace


InvalidOperationException Members

Public:

Constructor

InvalidOperationException Constructor Overloaded. Initializes an instance of the InvalidOperationException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

InvalidOperationException Class | System Namespace


InvalidOperationException Constructor

Initializes an instance of the InvalidOperationException class.

Overload List

Initializes an instance of the InvalidOperationException with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public InvalidOperationException();
[C++] public: InvalidOperationException();
[JScript] public function InvalidOperationException();

Initializes an instance of InvalidOperationException with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public InvalidOperationException(String);
[C++] public: InvalidOperationException(String*);
[JScript] public function InvalidOperationException(String);

Initializes an instance of InvalidOperationException with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public InvalidOperationException(String, Exception);
[C++] public: InvalidOperationException(String*, Exception);
[JScript] public function InvalidOperationException(String, Exception);

See Also

InvalidOperationException Class | InvalidOperationException Members | System Namespace


InvalidOperationException Constructor ()

Initializes an instance of the InvalidOperationException with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public InvalidOperationException();
[C++]
public: InvalidOperationException();
[JScript]
public function InvalidOperationException();

Remarks

InvalidOperationException inherits from the Exception class. This constructor sets the properties of the InvalidOperationException object as follows:

Property Type | Conditon
InnerException | null
Message | The empty string.

See Also

InvalidOperationException Class | InvalidOperationException Members | System Namespace | InvalidOperationException Constructor Overload List


InvalidOperationException Constructor (String)

Initializes an instance of InvalidOperationException with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public InvalidOperationException(
   string message
);
[C++]
public: InvalidOperationException(
   String* message
);
[JScript]
public function InvalidOperationException(
   message : String
);

Parameters

message
The message that identifies the reason the exception occurred.

Remarks

InvalidOperationException inherits from the Exception class. This constructor sets the properties of the InvalidOperationException object as follows:

Property Type | Condition
InnerException | null
Message | The message string.

See Also

InvalidOperationException Class | InvalidOperationException Members | System Namespace | InvalidOperationException Constructor Overload List


InvalidOperationException Constructor (String, Exception)

Initializes an instance of InvalidOperationException with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public InvalidOperationException(
   string message,
   Exception inner
);
[C++]
public: InvalidOperationException(
   String* message,
   Exception* inner
);
[JScript]
public function InvalidOperationException(
   message : String,
   inner : Exception
);

Parameters

message
The message that identifies the reason the exception occurred.
inner
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

InvalidOperationException inherits from the Exception class. This constructor sets the properties of the InvalidOperationException object as follows:

Property Type | Condition
InnerException | The inner exception.
Message | The message string.

See Also

InvalidOperationException Class | InvalidOperationException Members | System Namespace | InvalidOperationException Constructor Overload List


IServiceObjectProvider Interface

Provides a mechanism for retrieving a service object, which provides a service to other objects. Services are identified using Type objects.

IServiceObjectProvider

[Visual Basic]
Public Interface IServiceObjectProvider
[C#]
public interface IServiceObjectProvider
[C++]
public __gc __interface IServiceObjectProvider

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IServiceObjectProvider

Class | Description
Component | Provides an abstraction that enables object-sharing between applications.
CultureInfo | [To be supplied.]
DateTimeFormatInfo | [To be supplied.]
HttpContext | Encapsulates all HTTP-specific context used by the HTTP server to process Web requests. System.Web.IHttpModules and IHttpHandler instances are provided a reference to an appropriate HttpContext object.
MarshalByRefComponent | Represents the base implementation for IComponent, which is the base for all components in WinForms. A component can be hosted in a container. For each component in a container, the container creates a site that it uses to manage the component.
NumberFormatInfo | [To be supplied.]

Remarks

Currently IServiceObjectProvider is implemented by NumberFormatInfo and DateTimeFormatInfo, and in the future there will be a TimeSpanFormatInfo class that implements it.

The following classes implement IServiceObjectProvider. You might prefer to use these classes, rather than implementing IServiceObjectProvider yourself.

NumberFormatInfo: Provides locale-specific format information which is used in conjunction with the Format methods provided on the base data types.

DateTimeFormatInfo: Controls the way in which the date and time values are formatted.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

IServiceObjectProvider Members | System Namespace


IServiceObjectProvider Members

Methods

GetServiceObject Gets the service object of the specified type.

See Also

IServiceObjectProvider Interface | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IServiceObjectProvider Methods

The methods of the IServiceObjectProvider interface are listed below. For a complete list of IServiceObjectProvider interface members, see the IServiceObjectProvider Members topic.

GetServiceObject Gets the service object of the specified type.

See Also

IServiceObjectProvider Interface | System Namespace


IServiceObjectProvider.GetServiceObject

Gets the service object of the specified type.

[Visual Basic]
Function GetServiceObject( _
   ByVal service As Type _
) As Object
[C#]
object GetServiceObject(
   Type service
);
[C++]
Object* GetServiceObject(
   Type* service
) = 0;
[JScript]
function GetServiceObject(
   service : Type
) : Object;

Parameters

service
The Type object that specifies the service object to get.

Return Value

The requested service object; if the service object is not available, null is returned.

See Also

IServiceObjectProvider Interface | IServiceObjectProvider Members | System Namespace


LocalDataStore Class

[To be supplied.]

Object
LocalDataStore

[Visual Basic]
Public Class LocalDataStore
[C#]
public class LocalDataStore
[C++]
public __gc class LocalDataStore
[JScript]
public class LocalDataStore

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

LocalDataStore Members | System Namespace


LocalDataStore Members

Public:

Constructor

LocalDataStore Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetData | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SetCapacity | [To be supplied.]
SetData | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LocalDataStore Class | System Namespace


LocalDataStore Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal mgr As LocalDataStoreMgr, _
   ByVal InitialCapacity As Integer _
)
[C#]
public LocalDataStore(
   LocalDataStoreMgr mgr,
   int InitialCapacity
);
[C++]
public: LocalDataStore(
   LocalDataStoreMgr* mgr,
   int InitialCapacity
);
[JScript]
public function LocalDataStore(
   mgr : LocalDataStoreMgr,
   InitialCapacity : int
);

Parameters

mgr
[To be supplied.]
InitialCapacity
[To be supplied.]

See Also

LocalDataStore Class | LocalDataStore Members | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

LocalDataStore Methods

The methods of the LocalDataStore class are listed below. For a complete list of LocalDataStore class members, see the LocalDataStore Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetData | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SetCapacity | [To be supplied.]
SetData | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LocalDataStore Class | System Namespace


LocalDataStore.GetData

[To be supplied.]

[Visual Basic]
Public Function GetData( _
   ByVal slot As LocalDataStoreSlot _
) As Object
[C#]
public object GetData(
   LocalDataStoreSlot slot
);
[C++]
public: Object* GetData(
   LocalDataStoreSlot* slot
);
[JScript]
public function GetData(
   slot : LocalDataStoreSlot
) : Object;

Parameters

slot
[To be supplied.]

See Also

LocalDataStore Class | LocalDataStore Members | System Namespace


LocalDataStore.SetCapacity

[To be supplied.]

[Visual Basic]
Public Sub SetCapacity( _
   ByVal capacity As Integer _
)
[C#]
public void SetCapacity(
   int capacity
);
[C++]
public: void SetCapacity(
   int capacity
);
[JScript]
public function SetCapacity(
   capacity : int
);

Parameters

capacity
[To be supplied.]

See Also

LocalDataStore Class | LocalDataStore Members | System Namespace


LocalDataStore.SetData

[To be supplied.]

[Visual Basic]
Public Sub SetData( _
   ByVal slot As LocalDataStoreSlot, _
   ByVal data As Object _
)
[C#]
public void SetData(
   LocalDataStoreSlot slot,
   object data
);
[C++]
public: void SetData(
   LocalDataStoreSlot* slot,
   Object* data
);
[JScript]
public function SetData(
   slot : LocalDataStoreSlot,
   data : Object
);

Parameters

slot
[To be supplied.]
data
[To be supplied.]

See Also

LocalDataStore Class | LocalDataStore Members | System Namespace


LocalDataStoreMgr Class

[To be supplied.]

Object
LocalDataStoreMgr

[Visual Basic]
Public Class LocalDataStoreMgr
[C#]
public class LocalDataStoreMgr
[C++]
public __gc class LocalDataStoreMgr
[JScript]
public class LocalDataStoreMgr

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

LocalDataStoreMgr Members | System Namespace


LocalDataStoreMgr Members

Public:

Constructor

LocalDataStoreMgr Constructor [To be supplied.]

Methods

AllocateDataSlot | [To be supplied.]
AllocateNamedDataSlot | [To be supplied.]
CreateLocalDataStore | [To be supplied.]
DeleteLocalDataStore | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FreeNamedDataSlot | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedDataSlot | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.
ValidateSlot | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LocalDataStoreMgr Class | System Namespace


LocalDataStoreMgr Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public LocalDataStoreMgr();
[C++]
public: LocalDataStoreMgr();
[JScript]
public function LocalDataStoreMgr();

See Also

LocalDataStoreMgr Class | LocalDataStoreMgr Members | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

LocalDataStoreMgr Methods

The methods of the LocalDataStoreMgr class are listed below. For a complete list of LocalDataStoreMgr class members, see the LocalDataStoreMgr Members topic.

Public:

AllocateDataSlot | [To be supplied.]
AllocateNamedDataSlot | [To be supplied.]
CreateLocalDataStore | [To be supplied.]
DeleteLocalDataStore | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FreeNamedDataSlot | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedDataSlot | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.
ValidateSlot | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LocalDataStoreMgr Class | System Namespace


LocalDataStoreMgr.AllocateDataSlot

[To be supplied.]

[Visual Basic]
Public Function AllocateDataSlot() As LocalDataStoreSlot
[C#]
public LocalDataStoreSlot AllocateDataSlot();
[C++]
public: LocalDataStoreSlot* AllocateDataSlot();
[JScript]
public function AllocateDataSlot() : LocalDataStoreSlot;

See Also

LocalDataStoreMgr Class | LocalDataStoreMgr Members | System Namespace


LocalDataStoreMgr.AllocateNamedDataSlot

[To be supplied.]

[Visual Basic]
Public Function AllocateNamedDataSlot( _
   ByVal name As String _
) As LocalDataStoreSlot
[C#]
public LocalDataStoreSlot AllocateNamedDataSlot(
   string name
);
[C++]
public: LocalDataStoreSlot* AllocateNamedDataSlot(
   String* name
);
[JScript]
public function AllocateNamedDataSlot(
   name : String
) : LocalDataStoreSlot;

Parameters

name
[To be supplied.]

See Also

LocalDataStoreMgr Class | LocalDataStoreMgr Members | System Namespace


LocalDataStoreMgr.CreateLocalDataStore

[To be supplied.]

[Visual Basic]
Public Function CreateLocalDataStore() As LocalDataStore
[C#]
public LocalDataStore CreateLocalDataStore();
[C++]
public: LocalDataStore* CreateLocalDataStore();
[JScript]
public function CreateLocalDataStore() : LocalDataStore;

See Also

LocalDataStoreMgr Class | LocalDataStoreMgr Members | System Namespace


LocalDataStoreMgr.DeleteLocalDataStore

[To be supplied.]

[Visual Basic]
Public Sub DeleteLocalDataStore( _
   ByVal store As LocalDataStore _
)
[C#]
public void DeleteLocalDataStore(
   LocalDataStore store
);
[C++]
public: void DeleteLocalDataStore(
   LocalDataStore* store
);
[JScript]
public function DeleteLocalDataStore(
   store : LocalDataStore
);

Parameters

store
[To be supplied.]

See Also

LocalDataStoreMgr Class | LocalDataStoreMgr Members | System Namespace


LocalDataStoreMgr.FreeNamedDataSlot

[To be supplied.]

[Visual Basic]
Public Sub FreeNamedDataSlot( _
   ByVal name As String _
)
[C#]
public void FreeNamedDataSlot(
   string name
);
[C++]
public: void FreeNamedDataSlot(
   String* name
);
[JScript]
public function FreeNamedDataSlot(
   name : String
);

Parameters

name
[To be supplied.]

See Also

LocalDataStoreMgr Class | LocalDataStoreMgr Members | System Namespace


LocalDataStoreMgr.GetNamedDataSlot

[To be supplied.]

[Visual Basic]
Public Function GetNamedDataSlot( _
   ByVal name As String _
) As LocalDataStoreSlot
[C#]
public LocalDataStoreSlot GetNamedDataSlot(
   string name
);
[C++]
public: LocalDataStoreSlot* GetNamedDataSlot(
   String* name
);
[JScript]
public function GetNamedDataSlot(
   name : String
) : LocalDataStoreSlot;

Parameters

name
[To be supplied.]

See Also

LocalDataStoreMgr Class | LocalDataStoreMgr Members | System Namespace


LocalDataStoreMgr.ValidateSlot

[To be supplied.]

[Visual Basic]
Public Sub ValidateSlot( _
   ByVal slot As LocalDataStoreSlot _
)
[C#]
public void ValidateSlot(
   LocalDataStoreSlot slot
);
[C++]
public: void ValidateSlot(
   LocalDataStoreSlot* slot
);
[JScript]
public function ValidateSlot(
   slot : LocalDataStoreSlot
);

Parameters

slot
[To be supplied.]

See Also

LocalDataStoreMgr Class | LocalDataStoreMgr Members | System Namespace


LocalDataStoreSlot Class

[To be supplied.]

Object
LocalDataStoreSlot

[Visual Basic]
NotInheritable Public Class LocalDataStoreSlot
[C#]
public sealed class LocalDataStoreSlot
[C++]
public __gc __sealed class LocalDataStoreSlot
[JScript]
public class LocalDataStoreSlot

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

LocalDataStoreSlot Members | System Namespace


LocalDataStoreSlot Members

Public:

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LocalDataStoreSlot Class | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

LocalDataStoreSlot Methods

The methods of the LocalDataStoreSlot class are listed below. For a complete list of LocalDataStoreSlot class members, see the LocalDataStoreSlot Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LocalDataStoreSlot Class | System Namespace


LocalDataStoreSlot.Finalize

[To be supplied.]

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

LocalDataStoreSlot Class | LocalDataStoreSlot Members | System Namespace


LogicalCallContext Class

Reserved.

Object
LogicalCallContext

[Visual Basic]
Public Class LogicalCallContext
   Implements ISerializable
[C#]
public class LogicalCallContext : ISerializable
[C++]
public __gc class LogicalCallContext : public ISerializable
[JScript]
public class LogicalCallContext implements ISerializable

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

LogicalCallContext Members | System Namespace


LogicalCallContext Members

Public:

Properties

HasInfo [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FreeNamedDataSlot | [To be supplied.]
GetData | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
SetData | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LogicalCallContext Class | System Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

LogicalCallContext Properties

The properties of the LogicalCallContext class are listed below. For a complete list of LogicalCallContext class members, see the LogicalCallContext Members topic.

Public:

HasInfo [To be supplied.]

See Also

LogicalCallContext Class | System Namespace


LogicalCallContext.HasInfo

[To be supplied.]

[Visual Basic]
Public ReadOnly Property HasInfo As Boolean
[C#]
public bool HasInfo {get;}
[C++]
public: __property bool get_HasInfo();
[JScript]
public function get HasInfo() : Boolean;

See Also

LogicalCallContext Class | LogicalCallContext Members | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

LogicalCallContext Methods

The methods of the LogicalCallContext class are listed below. For a complete list of LogicalCallContext class members, see the LogicalCallContext Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FreeNamedDataSlot | [To be supplied.]
GetData | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
SetData | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LogicalCallContext Class | System Namespace


LogicalCallContext.FreeNamedDataSlot

[To be supplied.]

[Visual Basic]
Public Sub FreeNamedDataSlot( _
   ByVal name As String _
)
[C#]
public void FreeNamedDataSlot(
   string name
);
[C++]
public: void FreeNamedDataSlot(
   String* name
);
[JScript]
public function FreeNamedDataSlot(
   name : String
);

Parameters

name
[To be supplied.]

See Also

LogicalCallContext Class | LogicalCallContext Members | System Namespace


LogicalCallContext.GetData

[To be supplied.]

[Visual Basic]
Public Function GetData( _
   ByVal name As String _
) As Object
[C#]
public object GetData(
   string name
);
[C++]
public: Object* GetData(
   String* name
);
[JScript]
public function GetData(
   name : String
) : Object;

Parameters

name
[To be supplied.]

See Also

LogicalCallContext Class | LogicalCallContext Members | System Namespace


LogicalCallContext.GetObjectData

[To be supplied.]

[Visual Basic]
Overridable Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
public: virtual void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
);
[JScript]
public function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);

Parameters

info
[To be supplied.]
context
[To be supplied.]

See Also

LogicalCallContext Class | LogicalCallContext Members | System Namespace


LogicalCallContext.SetData

[To be supplied.]

[Visual Basic]
Public Sub SetData( _
   ByVal name As String, _
   ByVal data As Object _
)
[C#]
public void SetData(
   string name,
   object data
);
[C++]
public: void SetData(
   String* name,
   Object* data
);
[JScript]
public function SetData(
   name : String,
   data : Object
);

Parameters

name
[To be supplied.]
data
[To be supplied.]

See Also

LogicalCallContext Class | LogicalCallContext Members | System Namespace


MarshalByRefObject Class

Base class for Remoting objects that need to be marshal by reference. This includes WellKnown SingleCall and WellKnown Singleton WebService objects and Client Activated Objects.

Object
MarshalByRefObject

[Visual Basic]
MustInherit Public Class MarshalByRefObject
[C#]
public abstract class MarshalByRefObject
[C++]
public __gc __abstract class MarshalByRefObject
[JScript]
public abstract class MarshalByRefObject

Remarks

Some key points to classes that derived from MarshalByRefObject:

* Derive from System.MarshalByRefObject or any of its children (except from context bound objects which derive from System.ContextBoundObject).

* Have distributed identity.

* Instances of MarshalByRefObject classes are confined to the App Domain in which they were created, their "Home AppDomain", but are accessible directly from any context within that App Domain. An App Domain is the logical equivalent of a sub-process within the Runtime.

* MarshalByRefObject's are appropriate when the state of the object should stay in the AppDomain that created it and only references should be marshaled when the object is remoted. For example a File IO object that internally has field which is an OS handle should be made AppDomain-bound, since the OS handle would not be useful or appropriate in another AppDomain in another process or another machine.

* If a MarshalByRefObject is passed outside of the "Home AppDomain" e.g. as a parameter on a remote method call or as a return value from a remote method call, a reference is passed from the source App Domain to the target App Domain ("Marshal By Reference") i.e. a reference is marshaled into the target App Domain. The following scenarios are automatically taken care of by the NGWS runtime:

* Between AppDomains in the same physical process.

* Between AppDomains in different physical processes on the same machine.

* Between AppDomains in different physical processes on different machines.

* Subsequent calls on the reference in the target AppDomain are marshaled back in to the "Home AppDomain" in which the object was created.

* MarshalByRefObject's that are remoted out of the AppDomain and subsequently called remotely are called from the default context for the AppDomain.

Requirements

Namespace: System

Assembly: mscorlib.dll

Example [C#]

[C#]

public class Zap : MarshalByRefObject
{
  //. . .
}

public class Waz : Zap
{
  //. . .
}

See Also

MarshalByRefObject Members | System Namespace


MarshalByRefObject Members

Public:

Constructor

MarshalByRefObject Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MarshalByRefObject Class | System Namespace


MarshalByRefObject Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public MarshalByRefObject();
[C++]
public: MarshalByRefObject();
[JScript]
public function MarshalByRefObject();

See Also

MarshalByRefObject Class | MarshalByRefObject Members | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MarshalByRefObject Methods

The methods of the MarshalByRefObject class are listed below. For a complete list of MarshalByRefObject class members, see the MarshalByRefObject Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MarshalByRefObject Class | System Namespace


MarshalByRefObject.GetLifetimeService

This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.

[Visual Basic]
Public Function GetLifetimeService() As Object
[C#]
public object GetLifetimeService();
[C++]
public: Object* GetLifetimeService();
[JScript]
public function GetLifetimeService() : Object;

Return Value

Returns Object to control lifetime Service.

See Also

MarshalByRefObject Class | MarshalByRefObject Members | System Namespace


MarshalByRefObject.InitializeLifetimeService

[Visual Basic]
Overridable Public Function InitializeLifetimeService() As Object
[C#]
public virtual object InitializeLifetimeService();
[C++]
public: virtual Object* InitializeLifetimeService();
[JScript]
public function InitializeLifetimeService() : Object;

Example [C#]

[C#]

public class Foo : MarshalByRefObject
{
  public override Object InitializeLifetimeService()
  {
    ILease lease = (ILease)base.InitializeLifetimeService();
    if (lease.CurrentState == LeaseState.Initial)
    {
         lease.InitialLeaseTime = TimeSpan.FromMinutes(1);
         lease.SponsorshipTimeout = TimeSpan.FromMinutes(2);
          lease.RenewOnCallTime = TimeSpan.FromSeconds(2);
    }
      return lease;
  }
}

See Also

MarshalByRefObject Class | MarshalByRefObject Members | System Namespace


Math Class

Provides static methods for trigonometric, logarithmic, and other common mathematical functions. Overloaded methods are provided for use with standard base data types.

Object
Math

[Visual Basic]
NotInheritable Public Class Math
[C#]
public sealed class Math
[C++]
public __gc __sealed class Math
[JScript]
public class Math

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

Math Members | System Namespace


Math Members

Public:

Methods

Abs | Overloaded. Returns the absolute value of the specified number.
Acos | Returns the arc cosine (in radians) of a specified number. The arc cosine is the angle whose cosine is the specified number.
Asin | Returns the arc sine (in radians) of a specified number. The arc sine is the angle whose sine is the specified number.
Atan | Returns the arc tangent (in radians) of a specified number. The arc tangent is the angle whose tangent is the specified number.
Atan2 | Returns the arc tangent of a number whose angle is specified by drawing a vector from the origin (0,0) to a point whose coordinates are (x, y). The arc tangent is the angle whose tangent is the quotient, y/ x.
Ceil | Rounds a number up to the smallest whole number greater than or equal to the number.
Cos | Returns the cosine of the specified angle, measured in radians.
Cosh | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Exp | Returns e raised to the specified power.
Floor | Rounds a number down to the smallest whole number less than or equal to the number.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IEEERemainder | Returns the remainder of x divided by y, as defined by the remainder operation in Section5.1 of ANSI/IEEE Std 754-1985; IEEE Standard for Binary Floating-Point Arithmetic; Institute of Electrical and Electronics Engineers, Inc; 1985.
Log | Overloaded. [To be supplied.]
Log10 | Returns the base 10 logarithm of a specified number.
Max | Overloaded. Returns the maximum of two numbers.
Min | Overloaded. Returns the smaller of two numbers.
Pow | Raises a specified number to the specified power.
Rint | Returns a number rounded to the nearest integer.
Round | Rounds a number to the nearest whole number, as specified by Section 5.5 of the IEEE 754 standard.
Sign | Overloaded. Returns the sign of a number.
Sin | Returns the sine of a specified angle, measured in radians.
Sinh | [To be supplied.]
Sqrt | Returns the square root of a specified number.
Tan | Returns the tangent of a specified angle, measured in radians.
Tanh | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

E | The natural exponent, e.
PI | , the ratio of the circumference of a circle to its diameter.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Math Class | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Math Methods

The methods of the Math class are listed below. For a complete list of Math class members, see the Math Members topic.

Public:

Abs | Overloaded. Returns the absolute value of the specified number.
Acos | Returns the arc cosine (in radians) of a specified number. The arc cosine is the angle whose cosine is the specified number.
Asin | Returns the arc sine (in radians) of a specified number. The arc sine is the angle whose sine is the specified number.
Atan | Returns the arc tangent (in radians) of a specified number. The arc tangent is the angle whose tangent is the specified number.
Atan2 | Returns the arc tangent of a number whose angle is specified by drawing a vector from the origin (0,0) to a point whose coordinates are (x, y). The arc tangent is the angle whose tangent is the quotient, y/ x.
Ceil | Rounds a number up to the smallest whole number greater than or equal to the number.
Cos | Returns the cosine of the specified angle, measured in radians.
Cosh | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Exp | Returns e raised to the specified power.
Floor | Rounds a number down to the smallest whole number less than or equal to the number.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IEEERemainder | Returns the remainder of x divided by y, as defined by the remainder operation in Section5.1 of ANSI/IEEE Std 754-1985; IEEE Standard for Binary Floating-Point Arithmetic; Institute of Electrical and Electronics Engineers, Inc; 1985.
Log | Overloaded. [To be supplied.]
Log10 | Returns the base 10 logarithm of a specified number.
Max | Overloaded. Returns the maximum of two numbers.
Min | Overloaded. Returns the smaller of two numbers.
Pow | Raises a specified number to the specified power.
Rint | Returns a number rounded to the nearest integer.
Round | Rounds a number to the nearest whole number, as specified by Section 5.5 of the IEEE 754 standard.
Sign | Overloaded. Returns the sign of a number.
Sin | Returns the sine of a specified angle, measured in radians.
Sinh | [To be supplied.]
Sqrt | Returns the square root of a specified number.
Tan | Returns the tangent of a specified angle, measured in radians.
Tanh | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Math Class | System Namespace


Math.Abs

Returns the absolute value of the specified number.

Overload List

Returns the absolute value of an integer.

[Visual Basic] Overloads Public Shared Function Abs(Long) As Long
[C#] public static long Abs(long);
[C++] public: static __int64 Abs(__int64);
[JScript] public static function Abs(long) : long;

Returns the absolute value of an integer.

[Visual Basic] Overloads Public Shared Function Abs(Integer) As Integer
[C#] public static int Abs(int);
[C++] public: static int Abs(int);
[JScript] public static function Abs(int) : int;

Returns the absolute value of an integer.

[Visual Basic] Overloads Public Shared Function Abs(Integer) As Short
[C#] public static short Abs(short);
[C++] public: static short Abs(short);
[JScript] public static function Abs(Int16) : Int16;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function Abs(Single) As Single
[C#] public static float Abs(float);
[C++] public: static float Abs(float);
[JScript] public static function Abs(float) : float;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function Abs(Double) As Double
[C#] public static double Abs(double);
[C++] public: static double Abs(double);
[JScript] public static function Abs(double) : double;

Returns the absolute value of an integer.

[Visual Basic] Overloads Public Shared Function Abs(SByte) As SByte
[C#] public static sbyte Abs(sbyte);
[C++] public: static char Abs(char);
[JScript] public static function Abs(SByte) : SByte;

See Also

Math Class | Math Members | System Namespace


Math.Abs (Int64)

Returns the absolute value of an integer.

[Visual Basic]
Overloads Public Shared Function Abs( _
   ByVal value As Long _
) As Long
[C#]
public static long Abs(
   long value
);
[C++]
public: static __int64 Abs(
   __int64 value
);
[JScript]
public static function Abs(
   value : long
) : long;

Parameters

value
A number in the range MinValue value MaxValue.

Return Value

Returns x, the absolute value of value, such that 0 x MaxValue.

Exceptions

Exception Type | Condition
OverflowException | if value equals MinValue.

See Also

Math Class | Math Members | System Namespace | Math.Abs Overload List


Math.Abs (Int32)

Returns the absolute value of an integer.

[Visual Basic]
Overloads Public Shared Function Abs( _
   ByVal value As Integer _
) As Integer
[C#]
public static int Abs(
   int value
);
[C++]
public: static int Abs(
   int value
);
[JScript]
public static function Abs(
   value : int
) : int;

Parameters

value
A number in the range MinValue value MaxValue.

Return Value

Returns x, the absolute value of value, such that 0 x MaxValue.

Exceptions

Exception Type | Condition
OverflowException | if value equals MinValue.

See Also

Math Class | Math Members | System Namespace | Math.Abs Overload List


Math.Abs (Int16)

Returns the absolute value of an integer.

[Visual Basic]
Overloads Public Shared Function Abs( _
   ByVal value As Short _
) As Short
[C#]
public static short Abs(
   short value
);
[C++]
public: static short Abs(
   short value
);
[JScript]
public static function Abs(
   value : Int16
) : Int16;

Parameters

value
A number in the range MinValue value MaxValue.

Return Value

Returns x, the absolute value of value, such that 0 x MaxValue.

Exceptions

Exception Type | Condition
OverflowException | if value equals MinValue.

See Also

Math Class | Math Members | System Namespace | Math.Abs Overload List


Math.Abs (Single)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function Abs( _
   ByVal value As Single _
) As Single
[C#]
public static float Abs(
   float value
);
[C++]
public: static float Abs(
   float value
);
[JScript]
public static function Abs(
   value : float
) : float;

Parameters

value
[To be supplied.]

See Also

Math Class | Math Members | System Namespace | Math.Abs Overload List


Math.Abs (Double)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function Abs( _
   ByVal value As Double _
) As Double
[C#]
public static double Abs(
   double value
);
[C++]
public: static double Abs(
   double value
);
[JScript]
public static function Abs(
   value : double
) : double;

Parameters

value
[To be supplied.]

See Also

Math Class | Math Members | System Namespace | Math.Abs Overload List


Math.Abs (SByte)

Returns the absolute value of an integer.

[Visual Basic]
Overloads Public Shared Function Abs( _
   ByVal value As SByte _
) As SByte
[C#]
public static sbyte Abs(
   sbyte value
);
[C++]
public: static char Abs(
   char value
);
[JScript]
public static function Abs(
   value : SByte
) : SByte;

Parameters

value
A number in the range MinValue value MaxValue.

Return Value

Returns x, the absolute value of value, such that 0 x MaxValue.

Exceptions

Exception Type | Condition
OverflowException | if value equals MinValue.

See Also

Math Class | Math Members | System Namespace | Math.Abs Overload List


Math.Acos

Returns the arc cosine (in radians) of a specified number. The arc cosine is the angle whose cosine is the specified number.

[Visual Basic]
Public Shared Function Acos( _
   ByVal d As Double _
) As Double
[C#]
public static double Acos(
   double d
);
[C++]
public: static double Acos(
   double d
);
[JScript]
public static function Acos(
   d : double
) : double;

Parameters

d
A number representing a cosine,-1 d 1.

Return Value

Returns an angle q, measured in radians, such that 0 q . Returns NaN if d <-1 or d > 1.

Remarks

To convert the result from radians to degrees, multiply it by 180/.

See Also

Math Class | Math Members | System Namespace


Math.Asin

Returns the arc sine (in radians) of a specified number. The arc sine is the angle whose sine is the specified number.

[Visual Basic]
Public Shared Function Asin( _
   ByVal d As Double _
) As Double
[C#]
public static double Asin(
   double d
);
[C++]
public: static double Asin(
   double d
);
[JScript]
public static function Asin(
   d : double
) : double;

Parameters

d
A number representing a sine,-1 d 1.

Return Value

Returns an angle q, measured in radians, such that-/2 q /2. Returns NaN if d <-1 or d > 1.

Remarks

A positive result represents a counterclockwise angle from the x-axis; a negative result represents a clockwise angle. To convert the result from radians to degrees, multiply it by 180/.

See Also

Math Class | Math Members | System Namespace


Math.Atan

Returns the arc tangent (in radians) of a specified number. The arc tangent is the angle whose tangent is the specified number.

[Visual Basic]
Public Shared Function Atan( _
   ByVal d As Double _
) As Double
[C#]
public static double Atan(
   double d
);
[C++]
public: static double Atan(
   double d
);
[JScript]
public static function Atan(
   d : double
) : double;

Parameters

d
A number representing a tangent.

Return Value

Returns an angle q, measured in radians, such that-/2 < q < /2.

Remarks

A positive result represents a counterclockwise angle from the x-axis; a negative result represents a clockwise angle. To convert the result from radians to degrees, multiply it by 180/.

See Also

Math Class | Math Members | System Namespace


Math.Atan2

Returns the arc tangent of a number whose angle is specified by drawing a vector from the origin (0,0) to a point whose coordinates are (x, y). The arc tangent is the angle whose tangent is the quotient, y/ x.

[Visual Basic]
Public Shared Function Atan2( _
   ByVal y As Double, _
   ByVal x As Double _
) As Double
[C#]
public static double Atan2(
   double y,
   double x
);
[C++]
public: static double Atan2(
   double y,
   double x
);
[JScript]
public static function Atan2(
   y : double,
   x : double
) : double;

Parameters

y
The y coordinate of the point that terminates the vector.
x
The x coordinate of the point that terminates the vector.

Return Value

Returns the angle theta such that- < q , and tan(q) = y/ x, where (x, y) is a point in the Cartesian plane. Observe that:

for (x, y) in Quadrant 1, we have 0 < q < /2

for (x, y) in Quadrant 2, we have /2 < q <

for (x, y) in Quadrant 3, we have- < q <-/2

for (x, y) in Quadrant 4, we have-/2 < q < 0

Remarks

This method computes the angle q where tan(q) = y/ x. For example, if y and x are known, then the angle q is the value of atan2(y, x).

See Also

Math Class | Math Members | System Namespace


Math.Ceil

Rounds a number up to the smallest whole number greater than or equal to the number.

[Visual Basic]
Public Shared Function Ceil( _
   ByVal a As Double _
) As Double
[C#]
public static double Ceil(
   double a
);
[C++]
public: static double Ceil(
   double a
);
[JScript]
public static function Ceil(
   a : double
) : double;

Parameters

a
The number whose ceiling is desired.

Return Value

Returns the smallest mathematical integer that is not less than d, as a Double.

See Also

Math Class | Math Members | System Namespace


Math.Cos

Returns the cosine of the specified angle, measured in radians.

[Visual Basic]
Public Shared Function Cos( _
   ByVal d As Double _
) As Double
[C#]
public static double Cos(
   double d
);
[C++]
public: static double Cos(
   double d
);
[JScript]
public static function Cos(
   d : double
) : double;

Parameters

d
An angle measured in radians.

Return Value

Returns the cosine of the angle d.

Remarks

If the angle, d, is in degrees, multiply it by /180 to convert it to radians before calling this method.

See Also

Math Class | Math Members | System Namespace


Math.Cosh

[To be supplied.]

[Visual Basic]
Public Shared Function Cosh( _
   ByVal value As Double _
) As Double
[C#]
public static double Cosh(
   double value
);
[C++]
public: static double Cosh(
   double value
);
[JScript]
public static function Cosh(
   value : double
) : double;

Parameters

value
[To be supplied.]

See Also

Math Class | Math Members | System Namespace


Math.Exp

Returns e raised to the specified power.

[Visual Basic]
Public Shared Function Exp( _
   ByVal d As Double _
) As Double
[C#]
public static double Exp(
   double d
);
[C++]
public: static double Exp(
   double d
);
[JScript]
public static function Exp(
   d : double
) : double;

Parameters

d
A power to which to raise the number e.

Return Value

Returns e raised to the power d.

Remarks

To calculate powers of other bases, use the Pow method. Exp is the inverse of Log, the natural logarithm.

The constant e is 2.71828182845904, the base for natural logarithms.

See Also

Math Class | Math Members | System Namespace


Math.Floor

Rounds a number down to the smallest whole number less than or equal to the number.

[Visual Basic]
Public Shared Function Floor( _
   ByVal d As Double _
) As Double
[C#]
public static double Floor(
   double d
);
[C++]
public: static double Floor(
   double d
);
[JScript]
public static function Floor(
   d : double
) : double;

Parameters

d
The number whose floor is requested.

Return Value

Returns the largest mathematical integer that is not greater than d, as a Double.

See Also

Math Class | Math Members | System Namespace


Math.IEEERemainder

Returns the remainder of x divided by y, as defined by the remainder operation in Section5.1 of ANSI/IEEE Std 754-1985; IEEE Standard for Binary Floating-Point Arithmetic; Institute of Electrical and Electronics Engineers, Inc; 1985.

[Visual Basic]
Public Shared Function IEEERemainder( _
   ByVal x As Double, _
   ByVal y As Double _
) As Double
[C#]
public static double IEEERemainder(
   double x,
   double y
);
[C++]
public: static double IEEERemainder(
   double x,
   double y
);
[JScript]
public static function IEEERemainder(
   x : double,
   y : double
) : double;

Parameters

x
The number to divide.
y
The number by which to divide (divisor). The divisor, y, may not be 0.

Return Value

The returned value is equivalent to x- (y n), where n is the quotient x/ y rounded to the nearest integer (the even integer is chosen when x/ y falls exactly halfway between two integers). In the event that x- (y n) is zero, the floating-point value +0 is returned when x is positive, and the floating-point value-0 is returned when x is negative. If y = 0, the returned value is NaN (Not A Number).

See Also

Math Class | Math Members | System Namespace


Math.Log

[To be supplied.]

Overload List

Returns the natural (base e) logarithm of a number.

[Visual Basic] Overloads Public Shared Function Log(Double) As Double
[C#] public static double Log(double);
[C++] public: static double Log(double);
[JScript] public static function Log(double) : double;

Returns the logarithm to the specified base of a number.

[Visual Basic] Overloads Public Shared Function Log(Double, Double) As Double
[C#] public static double Log(double, double);
[C++] public: static double Log(double, double);
[JScript] public static function Log(double, double) : double;

See Also

Math Class | Math Members | System Namespace


Math.Log (Double)

Returns the natural (base e) logarithm of a number.

[Visual Basic]
Overloads Public Shared Function Log( _
   ByVal d As Double _
) As Double
[C#]
public static double Log(
   double d
);
[C++]
public: static double Log(
   double d
);
[JScript]
public static function Log(
   d : double
) : double;

Parameters

d
The number for which to find the natural logarithm.

Return Value

Returns the natural log of d: ln d or log

See Also

Math Class | Math Members | System Namespace | Math.Log Overload List


Math.Log (Double, Double)

Returns the logarithm to the specified base of a number.

[Visual Basic]
Overloads Public Shared Function Log( _
   ByVal a As Double, _
   ByVal newBase As Double _
) As Double
[C#]
public static double Log(
   double a,
   double newBase
);
[C++]
public: static double Log(
   double a,
   double newBase
);
[JScript]
public static function Log(
   a : double,
   newBase : double
) : double;

Parameters

a
The number for which to find the base newBase logarithm.
newBase
The base to use in finding the logarithm.

Return Value

Returns the base newBase logarithm of a: log

See Also

Math Class | Math Members | System Namespace | Math.Log Overload List


Math.Log10

Returns the base 10 logarithm of a specified number.

[Visual Basic]
Public Shared Function Log10( _
   ByVal d As Double _
) As Double
[C#]
public static double Log10(
   double d
);
[C++]
public: static double Log10(
   double d
);
[JScript]
public static function Log10(
   d : double
) : double;

Parameters

d
The number for which to find the base 10 logarithm.

Return Value

Returns the base 10 log of d: log

See Also

Math Class | Math Members | System Namespace


Math.Max

Returns the maximum of two numbers.

Overload List

Returns the larger of two numbers.

[Visual Basic] Overloads Public Shared Function Max(Double, Double) As Double
[C#] public static double Max(double, double);
[C++] public: static double Max(double, double);
[JScript] public static function Max(double, double) : double;

Returns the larger of two numbers.

[Visual Basic] Overloads Public Shared Function Max(Integer, Integer) As Short
[C#] public static short Max(short, short);
[C++] public: static short Max(short, short);
[JScript] public static function Max(Int16, Int16) : Int16;

Returns the larger of two numbers.

[Visual Basic] Overloads Public Shared Function Max(UInt16, UInt16) As UInt16
[C#] public static ushort Max(ushort, ushort);
[C++] public: static unsigned short Max(unsigned short, unsigned short);
[JScript] public static function Max(UInt16, UInt16) : UInt16;

Returns the larger of two numbers.

[Visual Basic] Overloads Public Shared Function Max(Single, Single) As Single
[C#] public static float Max(float, float);
[C++] public: static float Max(float, float);
[JScript] public static function Max(float, float) : float;

Returns the larger of two numbers.

[Visual Basic] Overloads Public Shared Function Max(Long, Long) As Long
[C#] public static long Max(long, long);
[C++] public: static __int64 Max(__int64, __int64);
[JScript] public static function Max(long, long) : long;

Returns the larger of two numbers.

[Visual Basic] Overloads Public Shared Function Max(UInt32, UInt32) As UInt32
[C#] public static uint Max(uint, uint);
[C++] public: static unsigned int Max(unsigned int, unsigned int);
[JScript] public static function Max(UInt32, UInt32) : UInt32;

Returns the larger of two numbers.

[Visual Basic] Overloads Public Shared Function Max(Integer, Integer) As Integer
[C#] public static int Max(int, int);
[C++] public: static int Max(int, int);
[JScript] public static function Max(int, int) : int;

Returns the larger of two numbers.

[Visual Basic] Overloads Public Shared Function Max(UInt64, UInt64) As UInt64
[C#] public static ulong Max(ulong, ulong);
[C++] public: static unsigned __int64 Max(unsigned __int64, unsigned __int64);
[JScript] public static function Max(UInt64, UInt64) : UInt64;

Returns the larger of two numbers.

[Visual Basic] Overloads Public Shared Function Max(SByte, SByte) As SByte
[C#] public static sbyte Max(sbyte, sbyte);
[C++] public: static char Max(char, char);
[JScript] public static function Max(SByte, SByte) : SByte;

Returns the larger of two numbers.

[Visual Basic] Overloads Public Shared Function Max(Byte, Byte) As Byte
[C#] public static byte Max(byte, byte);
[C++] public: static unsigned char Max(unsigned char, unsigned char);
[JScript] public static function Max(Byte, Byte) : Byte;

See Also

Math Class | Math Members | System Namespace


Math.Max (Double, Double)

Returns the larger of two numbers.

[Visual Basic]
Overloads Public Shared Function Max( _
   ByVal a As Double, _
   ByVal b As Double _
) As Double
[C#]
public static double Max(
   double a,
   double b
);
[C++]
public: static double Max(
   double a,
   double b
);
[JScript]
public static function Max(
   a : double,
   b : double
) : double;

Parameters

a
The first of two values to be compared.
b
The second of two values to be compared.

Return Value

Returns the maximum of a and b.

See Also

Math Class | Math Members | System Namespace | Math.Max Overload List


Math.Max (Int16, Int16)

Returns the larger of two numbers.

[Visual Basic]
Overloads Public Shared Function Max( _
   ByVal val1 As Short, _
   ByVal val2 As Short _
) As Short
[C#]
public static short Max(
   short val1,
   short val2
);
[C++]
public: static short Max(
   short val1,
   short val2
);
[JScript]
public static function Max(
   val1 : Int16,
   val2 : Int16
) : Int16;

Parameters

val1
The first of two values to be compared.
val2
The second of two values to be compared.

Return Value

Returns the maximum of val1 and val2.

See Also

Math Class | Math Members | System Namespace | Math.Max Overload List


Math.Max (UInt16, UInt16)

Returns the larger of two numbers.

[Visual Basic]
Overloads Public Shared Function Max( _
   ByVal val1 As UInt16, _
   ByVal val2 As UInt16 _
) As UInt16
[C#]
public static ushort Max(
   ushort val1,
   ushort val2
);
[C++]
public: static unsigned short Max(
   unsigned short val1,
   unsigned short val2
);
[JScript]
public static function Max(
   val1 : UInt16,
   val2 : UInt16
) : UInt16;

Parameters

val1
The first of two values to be compared.
val2
The second of two values to be compared.

Return Value

Returns the maximum of val1 and val2.

See Also

Math Class | Math Members | System Namespace | Math.Max Overload List


Math.Max (Single, Single)

Returns the larger of two numbers.

[Visual Basic]
Overloads Public Shared Function Max( _
   ByVal a As Single, _
   ByVal b As Single _
) As Single
[C#]
public static float Max(
   float a,
   float b
);
[C++]
public: static float Max(
   float a,
   float b
);
[JScript]
public static function Max(
   a : float,
   b : float
) : float;

Parameters

a
The first of two values to be compared.
b
The second of two values to be compared.

Return Value

Returns the maximum of a and b.

See Also

Math Class | Math Members | System Namespace | Math.Max Overload List


Math.Max (Int64, Int64)

Returns the larger of two numbers.

[Visual Basic]
Overloads Public Shared Function Max( _
   ByVal val1 As Long, _
   ByVal val2 As Long _
) As Long
[C#]
public static long Max(
   long val1,
   long val2
);
[C++]
public: static __int64 Max(
   __int64 val1,
   __int64 val2
);
[JScript]
public static function Max(
   val1 : long,
   val2 : long
) : long;

Parameters

val1
The first of two values to be compared.
val2
The second of two values to be compared.

Return Value

Returns the maximum of val1 and val2.

See Also

Math Class | Math Members | System Namespace | Math.Max Overload List


Math.Max (UInt32, UInt32)

Returns the larger of two numbers.

[Visual Basic]
Overloads Public Shared Function Max( _
   ByVal val1 As UInt32, _
   ByVal val2 As UInt32 _
) As UInt32
[C#]
public static uint Max(
   uint val1,
   uint val2
);
[C++]
public: static unsigned int Max(
   unsigned int val1,
   unsigned int val2
);
[JScript]
public static function Max(
   val1 : UInt32,
   val2 : UInt32
) : UInt32;

Parameters

val1
The first of two values to be compared.
val2
The second of two values to be compared.

Return Value

Returns the maximum of val1 and val2.

See Also

Math Class | Math Members | System Namespace | Math.Max Overload List


Math.Max (Int32, Int32)

Returns the larger of two numbers.

[Visual Basic]
Overloads Public Shared Function Max( _
   ByVal val1 As Integer, _
   ByVal val2 As Integer _
) As Integer
[C#]
public static int Max(
   int val1,
   int val2
);
[C++]
public: static int Max(
   int val1,
   int val2
);
[JScript]
public static function Max(
   val1 : int,
   val2 : int
) : int;

Parameters

val1
The first of two values to be compared.
val2
The second of two values to be compared.

Return Value

Returns the maximum of val1 and val2.

See Also

Math Class | Math Members | System Namespace | Math.Max Overload List


Math.Max (UInt64, UInt64)

Returns the larger of two numbers.

[Visual Basic]
Overloads Public Shared Function Max( _
   ByVal val1 As UInt64, _
   ByVal val2 As UInt64 _
) As UInt64
[C#]
public static ulong Max(
   ulong val1,
   ulong val2
);
[C++]
public: static unsigned __int64 Max(
   unsigned __int64 val1,
   unsigned __int64 val2
);
[JScript]
public static function Max(
   val1 : UInt64,
   val2 : UInt64
) : UInt64;

Parameters

val1
The first of two values to be compared.
val2
The second of two values to be compared.

Return Value

Returns the maximum of val1 and val2.

See Also

Math Class | Math Members | System Namespace | Math.Max Overload List


Math.Max (SByte, SByte)

Returns the larger of two numbers.

[Visual Basic]
Overloads Public Shared Function Max( _
   ByVal val1 As SByte, _
   ByVal val2 As SByte _
) As SByte
[C#]
public static sbyte Max(
   sbyte val1,
   sbyte val2
);
[C++]
public: static char Max(
   char val1,
   char val2
);
[JScript]
public static function Max(
   val1 : SByte,
   val2 : SByte
) : SByte;

Parameters

val1
The first of two values to be compared.
val2
The second of two values to be compared.

Return Value

Returns the maximum of val1 and val2.

See Also

Math Class | Math Members | System Namespace | Math.Max Overload List


Math.Max (Byte, Byte)

Returns the larger of two numbers.

[Visual Basic]
Overloads Public Shared Function Max( _
   ByVal val1 As Byte, _
   ByVal val2 As Byte _
) As Byte
[C#]
public static byte Max(
   byte val1,
   byte val2
);
[C++]
public: static unsigned char Max(
   unsigned char val1,
   unsigned char val2
);
[JScript]
public static function Max(
   val1 : Byte,
   val2 : Byte
) : Byte;

Parameters

val1
The first of two values to be compared.
val2
The second of two values to be compared.

Return Value

Returns the maximum of val1 and val2.

See Also

Math Class | Math Members | System Namespace | Math.Max Overload List


Math.Min

Returns the smaller of two numbers.

Overload List

Returns the smaller of two numbers.

[Visual Basic] Overloads Public Shared Function Min(UInt32, UInt32) As UInt32
[C#] public static uint Min(uint, uint);
[C++] public: static unsigned int Min(unsigned int, unsigned int);
[JScript] public static function Min(UInt32, UInt32) : UInt32;

Returns the smaller of two numbers.

[Visual Basic] Overloads Public Shared Function Min(Integer, Integer) As Integer
[C#] public static int Min(int, int);
[C++] public: static int Min(int, int);
[JScript] public static function Min(int, int) : int;

Returns the smaller of two numbers.

[Visual Basic] Overloads Public Shared Function Min(UInt16, UInt16) As UInt16
[C#] public static ushort Min(ushort, ushort);
[C++] public: static unsigned short Min(unsigned short, unsigned short);
[JScript] public static function Min(UInt16, UInt16) : UInt16;

Returns the smaller of two numbers.

[Visual Basic] Overloads Public Shared Function Min(Long, Long) As Long
[C#] public static long Min(long, long);
[C++] public: static __int64 Min(__int64, __int64);
[JScript] public static function Min(long, long) : long;

Returns the smaller of two numbers.

[Visual Basic] Overloads Public Shared Function Min(Double, Double) As Double
[C#] public static double Min(double, double);
[C++] public: static double Min(double, double);
[JScript] public static function Min(double, double) : double;

Returns the smaller of two numbers.

[Visual Basic] Overloads Public Shared Function Min(Single, Single) As Single
[C#] public static float Min(float, float);
[C++] public: static float Min(float, float);
[JScript] public static function Min(float, float) : float;

Returns the smaller of two numbers.

[Visual Basic] Overloads Public Shared Function Min(UInt64, UInt64) As UInt64
[C#] public static ulong Min(ulong, ulong);
[C++] public: static unsigned __int64 Min(unsigned __int64, unsigned __int64);
[JScript] public static function Min(UInt64, UInt64) : UInt64;

Returns the smaller of two numbers.

[Visual Basic] Overloads Public Shared Function Min(Integer, Integer) As Short
[C#] public static short Min(short, short);
[C++] public: static short Min(short, short);
[JScript] public static function Min(Int16, Int16) : Int16;

Returns the smaller of two numbers.

[Visual Basic] Overloads Public Shared Function Min(SByte, SByte) As SByte
[C#] public static sbyte Min(sbyte, sbyte);
[C++] public: static char Min(char, char);
[JScript] public static function Min(SByte, SByte) : SByte;

Returns the smaller of two numbers.

[Visual Basic] Overloads Public Shared Function Min(Byte, Byte) As Byte
[C#] public static byte Min(byte, byte);
[C++] public: static unsigned char Min(unsigned char, unsigned char);
[JScript] public static function Min(Byte, Byte) : Byte;

See Also

Math Class | Math Members | System Namespace


Math.Min (UInt32, UInt32)

Returns the smaller of two numbers.

[Visual Basic]
Overloads Public Shared Function Min( _
   ByVal val1 As UInt32, _
   ByVal val2 As UInt32 _
) As UInt32
[C#]
public static uint Min(
   uint val1,
   uint val2
);
[C++]
public: static unsigned int Min(
   unsigned int val1,
   unsigned int val2
);
[JScript]
public static function Min(
   val1 : UInt32,
   val2 : UInt32
) : UInt32;

Parameters

val1
The first of two values to be compared.
val2
The second of two values to be compared.

Return Value

Returns the minimum of val1 and val2.

See Also

Math Class | Math Members | System Namespace | Math.Min Overload List


Math.Min (Int32, Int32)

Returns the smaller of two numbers.

[Visual Basic]
Overloads Public Shared Function Min( _
   ByVal val1 As Integer, _
   ByVal val2 As Integer _
) As Integer
[C#]
public static int Min(
   int val1,
   int val2
);
[C++]
public: static int Min(
   int val1,
   int val2
);
[JScript]
public static function Min(
   val1 : int,
   val2 : int
) : int;

Parameters

val1
The first of two values to be compared.
val2
The second of two values to be compared.

Return Value

Returns the minimum of val1 and val2.

See Also

Math Class | Math Members | System Namespace | Math.Min Overload List


Math.Min (UInt16, UInt16)

Returns the smaller of two numbers.

[Visual Basic]
Overloads Public Shared Function Min( _
   ByVal val1 As UInt16, _
   ByVal val2 As UInt16 _
) As UInt16
[C#]
public static ushort Min(
   ushort val1,
   ushort val2
);
[C++]
public: static unsigned short Min(
   unsigned short val1,
   unsigned short val2
);
[JScript]
public static function Min(
   val1 : UInt16,
   val2 : UInt16
) : UInt16;

Parameters

val1
The first of two values to be compared.
val2
The second of two values to be compared.

Return Value

Returns the minimum of val1 and val2.

See Also

Math Class | Math Members | System Namespace | Math.Min Overload List


Math.Min (Int64, Int64)

Returns the smaller of two numbers.

[Visual Basic]
Overloads Public Shared Function Min( _
   ByVal val1 As Long, _
   ByVal val2 As Long _
) As Long
[C#]
public static long Min(
   long val1,
   long val2
);
[C++]
public: static __int64 Min(
   __int64 val1,
   __int64 val2
);
[JScript]
public static function Min(
   val1 : long,
   val2 : long
) : long;

Parameters

val1
The first of two values to be compared.
val2
The second of two values to be compared.

Return Value

Returns the minimum of val1 and val2.

See Also

Math Class | Math Members | System Namespace | Math.Min Overload List


Math.Min (Double, Double)

Returns the smaller of two numbers.

[Visual Basic]
Overloads Public Shared Function Min( _
   ByVal a As Double, _
   ByVal b As Double _
) As Double
[C#]
public static double Min(
   double a,
   double b
);
[C++]
public: static double Min(
   double a,
   double b
);
[JScript]
public static function Min(
   a : double,
   b : double
) : double;

Parameters

a
The first of two values to be compared.
b
The second of two values to be compared.

Return Value

Returns the minimum of a and b.

See Also

Math Class | Math Members | System Namespace | Math.Min Overload List


Math.Min (Single, Single)

Returns the smaller of two numbers.

[Visual Basic]
Overloads Public Shared Function Min( _
   ByVal a As Single, _
   ByVal b As Single _
) As Single
[C#]
public static float Min(
   float a,
   float b
);
[C++]
public: static float Min(
   float a,
   float b
);
[JScript]
public static function Min(
   a : float,
   b : float
) : float;

Parameters

a
The first of two values to be compared.
b
The second of two values to be compared.

Return Value

Returns the minimum of a and b.

See Also

Math Class | Math Members | System Namespace | Math.Min Overload List


Math.Min (UInt64, UInt64)

Returns the smaller of two numbers.

[Visual Basic]
Overloads Public Shared Function Min( _
   ByVal val1 As UInt64, _
   ByVal val2 As UInt64 _
) As UInt64
[C#]
public static ulong Min(
   ulong val1,
   ulong val2
);
[C++]
public: static unsigned __int64 Min(
   unsigned __int64 val1,
   unsigned __int64 val2
);
[JScript]
public static function Min(
   val1 : UInt64,
   val2 : UInt64
) : UInt64;

Parameters

val1
The first of two values to be compared.
val2
The second of two values to be compared.

Return Value

Returns the minimum of val1 and val2.

See Also

Math Class | Math Members | System Namespace | Math.Min Overload List


Math.Min (Int16, Int16)

Returns the smaller of two numbers.

[Visual Basic]
Overloads Public Shared Function Min( _
   ByVal val1 As Short, _
   ByVal val2 As Short _
) As Short
[C#]
public static short Min(
   short val1,
   short val2
);
[C++]
public: static short Min(
   short val1,
   short val2
);
[JScript]
public static function Min(
   val1 : Int16,
   val2 : Int16
) : Int16;

Parameters

val1
The first of two values to be compared.
val2
The second of two values to be compared.

Return Value

Returns the minimum of val1 and val2.

See Also

Math Class | Math Members | System Namespace | Math.Min Overload List


Math.Min (SByte, SByte)

Returns the smaller of two numbers.

[Visual Basic]
Overloads Public Shared Function Min( _
   ByVal val1 As SByte, _
   ByVal val2 As SByte _
) As SByte
[C#]
public static sbyte Min(
   sbyte val1,
   sbyte val2
);
[C++]
public: static char Min(
   char val1,
   char val2
);
[JScript]
public static function Min(
   val1 : SByte,
   val2 : SByte
) : SByte;

Parameters

val1
The first of two values to be compared.
val2
The second of two values to be compared.

Return Value

Returns the minimum of val1 and val2.

See Also

Math Class | Math Members | System Namespace | Math.Min Overload List


Math.Min (Byte, Byte)

Returns the smaller of two numbers.

[Visual Basic]
Overloads Public Shared Function Min( _
   ByVal val1 As Byte, _
   ByVal val2 As Byte _
) As Byte
[C#]
public static byte Min(
   byte val1,
   byte val2
);
[C++]
public: static unsigned char Min(
   unsigned char val1,
   unsigned char val2
);
[JScript]
public static function Min(
   val1 : Byte,
   val2 : Byte
) : Byte;

Parameters

val1
The first of two values to be compared.
val2
The second of two values to be compared.

Return Value

Returns the minimum of val1 and val2.

See Also

Math Class | Math Members | System Namespace | Math.Min Overload List


Math.Pow

Raises a specified number to the specified power.

[Visual Basic]
Public Shared Function Pow( _
   ByVal x As Double, _
   ByVal y As Double _
) As Double
[C#]
public static double Pow(
   double x,
   double y
);
[C++]
public: static double Pow(
   double x,
   double y
);
[JScript]
public static function Pow(
   x : double,
   y : double
) : double;

Parameters

x
The number that will be raised to the power y.
y
The power to which to raise x.

Return Value

Returns x raised to the power y.

See Also

Math Class | Math Members | System Namespace


Math.Rint

Returns a number rounded to the nearest integer.

[Visual Basic]
Public Shared Function Rint( _
   ByVal a As Double _
) As Long
[C#]
public static long Rint(
   double a
);
[C++]
public: static __int64 Rint(
   double a
);
[JScript]
public static function Rint(
   a : double
) : long;

Parameters

a
The number to be rounded.

Return Value

a rounded to the nearest integer. If a is exactly halfway between two whole numbers, this method returns the the integer that is even (i.e., Rint rounds up to the even number).

Example

Math.Rint (4.4) returns 4.0.
Math.Rint (4.5) returns 5.0.
Math.Rint (4.6) returns 5.0.

See Also

Math Class | Math Members | System Namespace


Math.Round

Rounds a number to the nearest whole number, as specified by Section 5.5 of the IEEE 754 standard.

[Visual Basic]
Public Shared Function Round( _
   ByVal a As Double _
) As Double
[C#]
public static double Round(
   double a
);
[C++]
public: static double Round(
   double a
);
[JScript]
public static function Round(
   a : double
) : double;

Parameters

a
A number to be rounded.

Return Value

Returns the nearest whole number. If a is exactly halfway between two whole numbers, this method returns the even whole number.

Remarks

According to IEEE 754, the default rounding direction is round towards nearest. This means that when the mathematical result of an operation lies halfway between two representable numbers, the one nearest to the mathematical result is delivered as the result. If the mathematical result lies halfway between the two representable numbers, then round to nearest mode specifies round to the nearest even number (final bit is zero.)

Example

Math.Rint (0.5) returns (double) 0.
Math.Rint (1.67) returns (double) 2.
Math.Rint (5.34) returns (double) 5.

See Also

Math Class | Math Members | System Namespace


Math.Sign

Returns the sign of a number.

Overload List

Returns the sign of a number.

[Visual Basic] Overloads Public Shared Function Sign(Long) As Integer
[C#] public static int Sign(long);
[C++] public: static int Sign(__int64);
[JScript] public static function Sign(long) : int;

Returns the sign of a number.

[Visual Basic] Overloads Public Shared Function Sign(Integer) As Integer
[C#] public static int Sign(int);
[C++] public: static int Sign(int);
[JScript] public static function Sign(int) : int;

Returns the sign of a number.

[Visual Basic] Overloads Public Shared Function Sign(Decimal) As Integer
[C#] public static int Sign(Decimal);
[C++] public: static int Sign(Decimal);
[JScript] public static function Sign(Decimal) : int;

Returns the sign of a number.

[Visual Basic] Overloads Public Shared Function Sign(Double) As Integer
[C#] public static int Sign(double);
[C++] public: static int Sign(double);
[JScript] public static function Sign(double) : int;

See Also

Math Class | Math Members | System Namespace


Math.Sign (Int64)

Returns the sign of a number.

[Visual Basic]
Overloads Public Shared Function Sign( _
   ByVal value As Long _
) As Integer
[C#]
public static int Sign(
   long value
);
[C++]
public: static int Sign(
   __int64 value
);
[JScript]
public static function Sign(
   value : long
) : int;

Parameters

value
The number from which to retrieve the sign.

Return Value

A number representing the sign of value:

Number | Description
-1 | value is negative, less than zero.
0 | value is "unsigned", equal to zero.
1 | value is positive, greater than zero.

See Also

Math Class | Math Members | System Namespace | Math.Sign Overload List


Math.Sign (Int32)

Returns the sign of a number.

[Visual Basic]
Overloads Public Shared Function Sign( _
   ByVal value As Integer _
) As Integer
[C#]
public static int Sign(
   int value
);
[C++]
public: static int Sign(
   int value
);
[JScript]
public static function Sign(
   value : int
) : int;

Parameters

value
The number from which to retrieve the sign.

Return Value

A number representing the sign of value:

Number | Description
-1 | value is negative, less than zero.
0 | value is "unsigned", equal to zero.
1 | value is positive, greater than zero.

See Also

Math Class | Math Members | System Namespace | Math.Sign Overload List


Math.Sign (Decimal)

Returns the sign of a number.

[Visual Basic]
Overloads Public Shared Function Sign( _
   ByVal value As Decimal _
) As Integer
[C#]
public static int Sign(
   Decimal value
);
[C++]
public: static int Sign(
   Decimal value
);
[JScript]
public static function Sign(
   value : Decimal
) : int;

Parameters

value
The number from which to retrieve the sign.

Return Value

A number representing the sign of value:

Number | Description
-1 | value is negative, less than zero.
0 | value is "unsigned", equal to zero.
1 | value is positive, greater than zero.

See Also

Math Class | Math Members | System Namespace | Math.Sign Overload List


Math.Sign (Double)

Returns the sign of a number.

[Visual Basic]
Overloads Public Shared Function Sign( _
   ByVal value As Double _
) As Integer
[C#]
public static int Sign(
   double value
);
[C++]
public: static int Sign(
   double value
);
[JScript]
public static function Sign(
   value : double
) : int;

Parameters

value
The number from which to retrieve the sign.

Return Value

A number representing the sign of value:

Number | Description
-1 | value is negative, less than zero.
0 | value is "unsigned", equal to zero.
1 | value is positive, greater than zero.

See Also

Math Class | Math Members | System Namespace | Math.Sign Overload List


Math.Sin

Returns the sine of a specified angle, measured in radians.

[Visual Basic]
Public Shared Function Sin( _
   ByVal a As Double _
) As Double
[C#]
public static double Sin(
   double a
);
[C++]
public: static double Sin(
   double a
);
[JScript]
public static function Sin(
   a : double
) : double;

Parameters

a
An angle measured in radians.

Return Value

Returns the sine of the angle d.

Remarks

If the angle, d, is in degrees, multiply it by p/180 to convert it to radians before calling this method.

See Also

Math Class | Math Members | System Namespace


Math.Sinh

[To be supplied.]

[Visual Basic]
Public Shared Function Sinh( _
   ByVal value As Double _
) As Double
[C#]
public static double Sinh(
   double value
);
[C++]
public: static double Sinh(
   double value
);
[JScript]
public static function Sinh(
   value : double
) : double;

Parameters

value
[To be supplied.]

See Also

Math Class | Math Members | System Namespace


Math.Sqrt

Returns the square root of a specified number.

[Visual Basic]
Public Shared Function Sqrt( _
   ByVal d As Double _
) As Double
[C#]
public static double Sqrt(
   double d
);
[C++]
public: static double Sqrt(
   double d
);
[JScript]
public static function Sqrt(
   d : double
) : double;

Parameters

d
The number whose square root is requested. This number must be non-negative.

Return Value

Returns the positive square root of d.

See Also

Math Class | Math Members | System Namespace


Math.Tan

Returns the tangent of a specified angle, measured in radians.

[Visual Basic]
Public Shared Function Tan( _
   ByVal a As Double _
) As Double
[C#]
public static double Tan(
   double a
);
[C++]
public: static double Tan(
   double a
);
[JScript]
public static function Tan(
   a : double
) : double;

Parameters

a
An angle measured in radians.

Return Value

Returns the tangent of the angle d.

Remarks

If the angle, d, is in degrees, multiply it by p/180 to convert it to radians before calling this method.

See Also

Math Class | Math Members | System Namespace


Math.Tanh

[To be supplied.]

[Visual Basic]
Public Shared Function Tanh( _
   ByVal value As Double _
) As Double
[C#]
public static double Tanh(
   double value
);
[C++]
public: static double Tanh(
   double value
);
[JScript]
public static function Tanh(
   value : double
) : double;

Parameters

value
[To be supplied.]

See Also

Math Class | Math Members | System Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Math Fields

The fields of the Math class are listed below. For a complete list of Math class members, see the Math Members topic.

Public:

E | The natural exponent, e.
PI | , the ratio of the circumference of a circle to its diameter.

See Also

Math Class | System Namespace


Math.E

The natural exponent, e.

[Visual Basic]
Public Const E As Double
[C#]
public const double E;
[C++]
public: const double E;
[JScript]
public var E : double;

See Also

Math Class | Math Members | System Namespace


Math.PI

, the ratio of the circumference of a circle to its diameter.

[Visual Basic]
Public Const PI As Double
[C#]
public const double PI;
[C++]
public: const double PI;
[JScript]
public var PI : double;

See Also

Math Class | Math Members | System Namespace


MethodAccessException Class

Represents an exception that is thrown when an attempt to access a method fails.

Object
Exception
SystemException
AccessException
MethodAccessException

[Visual Basic]
Public Class MethodAccessException
   Inherits AccessException
[C#]
public class MethodAccessException : AccessException
[C++]
public __gc class MethodAccessException : public AccessException
[JScript]
public class MethodAccessException extends AccessException

Remarks

The MethodAccessException is the exception class that is thrown for class loading failures.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

MethodAccessException Members | System Namespace


MethodAccessException Members

Public:

Constructor

MethodAccessException Constructor Overloaded. Initializes an instance of the MethodAccessException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

MethodAccessException Class | System Namespace


MethodAccessException Constructor

Initializes an instance of the MethodAccessException class.

Overload List

Initializes an instance of the MethodAccessException with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public MethodAccessException();
[C++] public: MethodAccessException();
[JScript] public function MethodAccessException();

Initializes an instance of MethodAccessException with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public MethodAccessException(String);
[C++] public: MethodAccessException(String*);
[JScript] public function MethodAccessException(String);

Initializes an instance of MethodAccessException with a specified message and the exception, which is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public MethodAccessException(String, Exception);
[C++] public: MethodAccessException(String*, Exception);
[JScript] public function MethodAccessException(String, Exception);

See Also

MethodAccessException Class | MethodAccessException Members | System Namespace


MethodAccessException Constructor ()

Initializes an instance of the MethodAccessException with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public MethodAccessException();
[C++]
public: MethodAccessException();
[JScript]
public function MethodAccessException();

Remarks

MethodAccessException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The empty string.

See Also

MethodAccessException Class | MethodAccessException Members | System Namespace | MethodAccessException Constructor Overload List


MethodAccessException Constructor (String)

Initializes an instance of MethodAccessException with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public MethodAccessException(
   string message
);
[C++]
public: MethodAccessException(
   String* message
);
[JScript]
public function MethodAccessException(
   message : String
);

Parameters

message
The message that identifies the reason the exception occurred.

Remarks

MethodAccessException inherits from the Exception class. This constructor sets the properties of the MethodAccessException object as follows:

Property Type | Condition
InnerException | null
Message | The message string.

See Also

MethodAccessException Class | MethodAccessException Members | System Namespace | MethodAccessException Constructor Overload List


MethodAccessException Constructor (String, Exception)

Initializes an instance of MethodAccessException with a specified message and the exception, which is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public MethodAccessException(
   string message,
   Exception inner
);
[C++]
public: MethodAccessException(
   String* message,
   Exception* inner
);
[JScript]
public function MethodAccessException(
   message : String,
   inner : Exception
);

Parameters

message
The message that identifies the reason the exception occurred.
inner
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

MethodAccessException inherits from the Exception class. This constructor sets the properties of the MethodAccessException object as follows:

Property Type | Condition
InnerException | The inner exception.
Message | The message string.

See Also

MethodAccessException Class | MethodAccessException Members | System Namespace | MethodAccessException Constructor Overload List


MissingFieldException Class

Represents an exception that is thrown when there is an attempt to access a nonexistent field.

Object
Exception
SystemException
AccessException
MissingMemberException
MissingFieldException

[Visual Basic]
Public Class MissingFieldException
   Inherits MissingMemberException
[C#]
public class MissingFieldException : MissingMemberException
[C++]
public __gc class MissingFieldException : public
   MissingMemberException
[JScript]
public class MissingFieldException extends MissingMemberException

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

MissingFieldException Members | System Namespace


MissingFieldException Members

Public:

Constructor

MissingFieldException Constructor Overloaded. Initializes an instance of the MissingFieldException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message | Retrieves the message string for this exception or an empty string if no message is set.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from MissingMemberException) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

ClassName (inherited from MissingMemberException) | Holds the class name of the missing member.
HResult (inherited from Exception) | Protected. Returns a HResult.
MemberName (inherited from MissingMemberException) | Holds the member name of the missing member.
Signature (inherited from MissingMemberException) | Holds the signature of the missing member.

See Also

MissingFieldException Class | System Namespace


MissingFieldException Constructor

Initializes an instance of the MissingFieldException class.

Overload List

Initializes an instance of the MissingFieldException with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public MissingFieldException();
[C++] public: MissingFieldException();
[JScript] public function MissingFieldException();

Initializes an instance of MissingFieldException with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public MissingFieldException(String);
[C++] public: MissingFieldException(String*);
[JScript] public function MissingFieldException(String);

Initializes an instance of MissingFieldException with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public MissingFieldException(String, Exception);
[C++] public: MissingFieldException(String*, Exception);
[JScript] public function MissingFieldException(String, Exception);

See Also

MissingFieldException Class | MissingFieldException Members | System Namespace


MissingFieldException Constructor ()

Initializes an instance of the MissingFieldException with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public MissingFieldException();
[C++]
public: MissingFieldException();
[JScript]
public function MissingFieldException();

Remarks

MissingFieldException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The empty string.

See Also

MissingFieldException Class | MissingFieldException Members | System Namespace | MissingFieldException Constructor Overload List


MissingFieldException Constructor (String)

Initializes an instance of MissingFieldException with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public MissingFieldException(
   string message
);
[C++]
public: MissingFieldException(
   String* message
);
[JScript]
public function MissingFieldException(
   message : String
);

Parameters

message
The message that identifies the reason the exception occurred.

Remarks

MissingFieldException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The message string.

See Also

MissingFieldException Class | MissingFieldException Members | System Namespace | MissingFieldException Constructor Overload List


MissingFieldException Constructor (String, Exception)

Initializes an instance of MissingFieldException with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public MissingFieldException(
   string message,
   Exception inner
);
[C++]
public: MissingFieldException(
   String* message,
   Exception* inner
);
[JScript]
public function MissingFieldException(
   message : String,
   inner : Exception
);

Parameters

message
The message that indicates the reason the exception occurred.
inner
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

MissingFieldException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | The inner exception.
Message | The message string.

See Also

MissingFieldException Class | MissingFieldException Members | System Namespace | MissingFieldException Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MissingFieldException Properties

The properties of the MissingFieldException class are listed below. For a complete list of MissingFieldException class members, see the MissingFieldException Members topic.

Public:

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message | Retrieves the message string for this exception or an empty string if no message is set.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

See Also

MissingFieldException Class | System Namespace


MissingFieldException.Message

Retrieves the message string for this exception or an empty string if no message is set.

[Visual Basic]
Overridable Public ReadOnly Property Message As String
[C#]
public string Message {override get;}
[C++]
public: __property virtual String* get_Message();
[JScript]
public function get Message() : String;

Property Value

Read only.

Remarks

Overrides Message.

See Also

MissingFieldException Class | MissingFieldException Members | System Namespace


MissingMemberException Class

Represents an exception that helps handle versioning problems with DLLs.

Object
Exception
SystemException
AccessException
MissingMemberException

[Visual Basic]
Public Class MissingMemberException
   Inherits AccessException
[C#]
public class MissingMemberException : AccessException
[C++]
public __gc class MissingMemberException : public AccessException
[JScript]
public class MissingMemberException extends AccessException

Remarks

The MissingMemberException is the exception class that handles dynamic-link library(dll) versioning problems.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

MissingMemberException Members | System Namespace


MissingMemberException Members

Public:

Constructor

MissingMemberException Constructor Overloaded. Initializes an instance of the MissingMemberException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message | Retrieves the message string for this exception, or an empty string if no message is set.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

ClassName | Holds the class name of the missing member.
HResult (inherited from Exception) | Protected. Returns a HResult.
MemberName | Holds the member name of the missing member.
Signature | Holds the signature of the missing member.

See Also

MissingMemberException Class | System Namespace


MissingMemberException Constructor

Initializes an instance of the MissingMemberException class.

Overload List

Initializes an instance of the MissingMemberException class with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public MissingMemberException();
[C++] public: MissingMemberException();
[JScript] public function MissingMemberException();

Initializes an instance of MissingMemberException with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public MissingMemberException(String);
[C++] public: MissingMemberException(String*);
[JScript] public function MissingMemberException(String);

Initializes an instance of MissingMemberException with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public MissingMemberException(String, Exception);
[C++] public: MissingMemberException(String*, Exception);
[JScript] public function MissingMemberException(String, Exception);

See Also

MissingMemberException Class | MissingMemberException Members | System Namespace


MissingMemberException Constructor ()

Initializes an instance of the MissingMemberException class with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public MissingMemberException();
[C++]
public: MissingMemberException();
[JScript]
public function MissingMemberException();

Remarks

MissingMemberException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | null
Message | The empty string.

See Also

MissingMemberException Class | MissingMemberException Members | System Namespace | MissingMemberException Constructor Overload List


MissingMemberException Constructor (String)

Initializes an instance of MissingMemberException with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public MissingMemberException(
   string message
);
[C++]
public: MissingMemberException(
   String* message
);
[JScript]
public function MissingMemberException(
   message : String
);

Parameters

message
The message that indicates the reason the exception occurred.

Remarks

MissingMemberException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | null
Message | The empty string.

See Also

MissingMemberException Class | MissingMemberException Members | System Namespace | MissingMemberException Constructor Overload List


MissingMemberException Constructor (String, Exception)

Initializes an instance of MissingMemberException with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public MissingMemberException(
   string message,
   Exception inner
);
[C++]
public: MissingMemberException(
   String* message,
   Exception* inner
);
[JScript]
public function MissingMemberException(
   message : String,
   inner : Exception
);

Parameters

message
The message that indicates the reason the exception occurred.
inner
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

MissingMemberException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | null
Message | The empty string.

See Also

MissingMemberException Class | MissingMemberException Members | System Namespace | MissingMemberException Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MissingMemberException Properties

The properties of the MissingMemberException class are listed below. For a complete list of MissingMemberException class members, see the MissingMemberException Members topic.

Public:

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message | Retrieves the message string for this exception, or an empty string if no message is set.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

See Also

MissingMemberException Class | System Namespace


MissingMemberException.Message

Retrieves the message string for this exception, or an empty string if no message is set.

[Visual Basic]
Overridable Public ReadOnly Property Message As String
[C#]
public string Message {override get;}
[C++]
public: __property virtual String* get_Message();
[JScript]
public function get Message() : String;

Property Value

Read-only.

Remarks

Overrides Message.

This is a message string with a new line character followed by the paramenter name. If a parameter name was not specified when the object was constructed, the value consists only of the message string.

See Also

MissingMemberException Class | MissingMemberException Members | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MissingMemberException Methods

The methods of the MissingMemberException class are listed below. For a complete list of MissingMemberException class members, see the MissingMemberException Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MissingMemberException Class | System Namespace


MissingMemberException.GetObjectData

Accesses the method that contains the context of the data from the source or destination.

[Visual Basic]
Overrides Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
public: override void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
);
[JScript]
public override function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);

Parameters

info
The serialized object.
context
[To be supplied.]

Return Value

A serialized object is returned as context by StreamingContext.

Exceptions

Exception Type | Condition
ArgumentNullException | If the object is null.

Remarks

The GetObjectData method accesses StreamingContext to return the value of hte source and/or destination of a given serialized stream. (For more information, see SerializationInfo.)

See Also

MissingMemberException Class | MissingMemberException Members | System Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MissingMemberException Fields

The fields of the MissingMemberException class are listed below. For a complete list of MissingMemberException class members, see the MissingMemberException Members topic.

Protected:

ClassName | Holds the class name of the missing member.
HResult (inherited from Exception) | Protected. Returns a HResult.
MemberName | Holds the member name of the missing member.
Signature | Holds the signature of the missing member.

See Also

MissingMemberException Class | System Namespace


MissingMemberException.ClassName

Holds the class name of the missing member.

[Visual Basic]
Protected ClassName As String
[C#]
protected string ClassName;
[C++]
protected: String* ClassName;
[JScript]
protected var ClassName : String;

Remarks

The ClassName field contains the returned class name string of the missing member. (For more nformation, see String.)

If the class name is null, the GetMessage method will construct the class name by using other variables. This allows customization of the format depending upon the language environment.

See Also

MissingMemberException Class | MissingMemberException Members | System Namespace


MissingMemberException.MemberName

Holds the member name of the missing member.

[Visual Basic]
Protected MemberName As String
[C#]
protected string MemberName;
[C++]
protected: String* MemberName;
[JScript]
protected var MemberName : String;

Remarks

The MemberName field contains the returned member name string of the missing member. (For more nformation, see String.)

See Also

MissingMemberException Class | MissingMemberException Members | System Namespace


MissingMemberException.Signature

Holds the signature of the missing member.

[Visual Basic]
Protected Signature() As Byte
[C#]
protected byte[] Signature;
[C++]
protected: unsigned char* Signature[];
[JScript]
protected var Signature : Byte[];

Remarks

The Signature field contains a Byte value that represents the signature of the missing member.

String.FormatSignature is used to format the signature. (For additional information, see SignatureHelper, SignatureToken, and String.)

See Also

MissingMemberException Class | MissingMemberException Members | System Namespace


MissingMethodException Class

Represents the exception that is thrown when there is an attempt to access a nonexistent method.

Object
Exception
SystemException
AccessException
MissingMemberException
MissingMethodException

[Visual Basic]
Public Class MissingMethodException
   Inherits MissingMemberException
[C#]
public class MissingMethodException : MissingMemberException
[C++]
public __gc class MissingMethodException : public
   MissingMemberException
[JScript]
public class MissingMethodException extends MissingMemberException

Remarks

The MissingMethodException provides an exception class for class loading failures.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

MissingMethodException Members | System Namespace


MissingMethodException Members

Public:

Constructor

MissingMethodException Constructor Overloaded. Initializes an instance of the MissingMethodException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message | Retrieves the message text for this exception, or indicates an empty string if no message is set.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from MissingMemberException) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

ClassName (inherited from MissingMemberException) | Holds the class name of the missing member.
HResult (inherited from Exception) | Protected. Returns a HResult.
MemberName (inherited from MissingMemberException) | Holds the member name of the missing member.
Signature (inherited from MissingMemberException) | Holds the signature of the missing member.

See Also

MissingMethodException Class | System Namespace


MissingMethodException Constructor

Initializes an instance of the MissingMethodException class.

Overload List

Initializes an instance of the MissingMethodException with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public MissingMethodException();
[C++] public: MissingMethodException();
[JScript] public function MissingMethodException();

Initializes an instance of MissingMethodException with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public MissingMethodException(String);
[C++] public: MissingMethodException(String*);
[JScript] public function MissingMethodException(String);

Initializes an instance of MissingMethodException with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public MissingMethodException(String, Exception);
[C++] public: MissingMethodException(String*, Exception);
[JScript] public function MissingMethodException(String, Exception);

See Also

MissingMethodException Class | MissingMethodException Members | System Namespace


MissingMethodException Constructor ()

Initializes an instance of the MissingMethodException with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public MissingMethodException();
[C++]
public: MissingMethodException();
[JScript]
public function MissingMethodException();

Remarks

MissingMethodException inherits from the Exception class. This constructor sets the properties of the MissingMethodException object as follows:

Property Type | Condition
InnerException | null
Message | The empty string.

See Also

MissingMethodException Class | MissingMethodException Members | System Namespace | MissingMethodException Constructor Overload List


MissingMethodException Constructor (String)

Initializes an instance of MissingMethodException with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public MissingMethodException(
   string message
);
[C++]
public: MissingMethodException(
   String* message
);
[JScript]
public function MissingMethodException(
   message : String
);

Parameters

message
The message that indicates the reason the exception occurred.

Remarks

MissingMethodException inherits from the Exception class. This constructor sets the properties of the MissingMethodException object as follows:

Property Type | Condition
InnerException | null
Message | The message string.

See Also

MissingMethodException Class | MissingMethodException Members | System Namespace | MissingMethodException Constructor Overload List


MissingMethodException Constructor (String, Exception)

Initializes an instance of MissingMethodException with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public MissingMethodException(
   string message,
   Exception inner
);
[C++]
public: MissingMethodException(
   String* message,
   Exception* inner
);
[JScript]
public function MissingMethodException(
   message : String,
   inner : Exception
);

Parameters

message
The message that indicates the reason the exception occurred.
inner
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

MissingMethodException inherits from the Exception class. This constructor sets the properties of the MissingMethodException object as follows:

Property Type | Condition
InnerException | The inner exception.
Message | The message string.

See Also

MissingMethodException Class | MissingMethodException Members | System Namespace | MissingMethodException Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MissingMethodException Properties

The properties of the MissingMethodException class are listed below. For a complete list of MissingMethodException class members, see the MissingMethodException Members topic.

Public:

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message | Retrieves the message text for this exception, or indicates an empty string if no message is set.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

See Also

MissingMethodException Class | System Namespace


MissingMethodException.Message

Retrieves the message text for this exception, or indicates an empty string if no message is set.

[Visual Basic]
Overridable Public ReadOnly Property Message As String
[C#]
public string Message {override get;}
[C++]
public: __property virtual String* get_Message();
[JScript]
public function get Message() : String;

Property Value

Read only.

Remarks

Overrides Message.

This property retrieves the message string for this exception. This is a message string with a new line character followed by the paramenter name. If a parameter name was not specified when the object was constructed, the value consists only of the message string.

See Also

MissingMethodException Class | MissingMethodException Members | System Namespace


MulticastDelegate Class

Represents a multicast delegate, which is a delegate that can have an invocation list with more than one element. All multicast delegates are derived from this class.

A delegate that inherits directly from Delegate has an invocation list (a linked list of delegates that are to be invoked when the "invoke" method is called) with one element- itself. The Delegate.Combine and Delegate.Remove methods are used to create new invocation lists.

Object
Delegate
MulticastDelegate

[Visual Basic]
MustInherit Public Class MulticastDelegate
   Inherits Delegate
[C#]
public abstract class MulticastDelegate : Delegate
[C++]
public __gc __abstract class MulticastDelegate : public Delegate
[JScript]
public abstract class MulticastDelegate extends Delegate

Remarks

When a multicast delegate is invoked, the delegates in the invocation list are called synchronously in the order in which they appear. If an error occurs during execution of the list then a non-resumable exception is thrown, and the execution process aborts.

While a multi-cast invoke is in progress, calls to Delegate.Combine and Delegate.Remove do not affect the invocation list employed by the multi-cast that is already in progress.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

MulticastDelegate Members | System Namespace


MulticastDelegate Members

Public:

Properties

Method (inherited from Delegate) | Gets the static method of the class represented by the Delegate.
Target (inherited from Delegate) | Gets the target of the Delegate.

Methods

BindToContext (inherited from Delegate) | Binds the Delegate to a context.
Clone (inherited from Delegate) | Creates a shallow copy of the Delegate.
DynamicInvoke (inherited from Delegate) | Invokes the method, represented by the Delegate, dynamically (late-bound).
Equals | Determines whether this multicast delegate and the specified object are equal.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order.
GetObjectData (inherited from Delegate) | Implements the ISerializable interface and returns the data needed to serialize the Delegate.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Operators

Equality Operator | Determines whether two MulticastDelegate objects are equal.
Inequality Operator | Determines whether two MulticastDelegate objects are not equal.

Protected:

Constructor

MulticastDelegate Constructor Overloaded. Initializes an instance of the MulticastDelegate class.

Methods

CombineImpl | [To be supplied.]
DynamicInvokeImpl | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetMethodImpl (inherited from Delegate) | Gets the static method of the class represented by the Delegate.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveImpl | [To be supplied.]

See Also

MulticastDelegate Class | System Namespace


MulticastDelegate Constructor

Initializes an instance of the MulticastDelegate class.

Overload List

Initializes an instance of the MulticastDelegate class. This constructor is called from the class generated by the compiler-generated code.

[Visual Basic] Overloads Protected Sub New(Object, String)
[C#] protected MulticastDelegate(Object, String);
[C++] protected: MulticastDelegate(Object*, String);
[JScript] protected function MulticastDelegate(Object, String);

Initializes an instance of the MulticastDelegate class. This constructor is called from a class to generate a delegate based upon a static method name and the Type object for the class defining the method.

[Visual Basic] Overloads Protected Sub New(Type, String)
[C#] protected MulticastDelegate(Type, String);
[C++] protected: MulticastDelegate(Type*, String);
[JScript] protected function MulticastDelegate(Type, String);

See Also

MulticastDelegate Class | MulticastDelegate Members | System Namespace


MulticastDelegate Constructor (Object, String)

Initializes an instance of the MulticastDelegate class. This constructor is called from the class generated by the compiler-generated code.

[Visual Basic]
Overloads Protected Sub New( _
   ByVal target As Object, _
   ByVal method As String _
)
[C#]
protected MulticastDelegate(
   object target,
   string method
);
[C++]
protected: MulticastDelegate(
   Object* target,
   String* method
);
[JScript]
protected function MulticastDelegate(
   target : Object,
   method : String
);

Parameters

target
the object that the specified method is defined on.
method
the name of the method for which to create a delegate

Remarks

This must match the constructor in Delegate.

See Also

MulticastDelegate Class | MulticastDelegate Members | System Namespace | MulticastDelegate Constructor Overload List


MulticastDelegate Constructor (Type, String)

Initializes an instance of the MulticastDelegate class. This constructor is called from a class to generate a delegate based upon a static method name and the Type object for the class defining the method.

[Visual Basic]
Overloads Protected Sub New( _
   ByVal target As Type, _
   ByVal method As String _
)
[C#]
protected MulticastDelegate(
   Type target,
   string method
);
[C++]
protected: MulticastDelegate(
   Type* target,
   String* method
);
[JScript]
protected function MulticastDelegate(
   target : Type,
   method : String
);

Parameters

target
the Type object that represents the class that the specified method is defined on.
method
the name of the static method for which to create a delegate.

See Also

MulticastDelegate Class | MulticastDelegate Members | System Namespace | MulticastDelegate Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MulticastDelegate Methods

The methods of the MulticastDelegate class are listed below. For a complete list of MulticastDelegate class members, see the MulticastDelegate Members topic.

Public:

BindToContext (inherited from Delegate) | Binds the Delegate to a context.
Clone (inherited from Delegate) | Creates a shallow copy of the Delegate.
DynamicInvoke (inherited from Delegate) | Invokes the method, represented by the Delegate, dynamically (late-bound).
Equals | Determines whether this multicast delegate and the specified object are equal.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order.
GetObjectData (inherited from Delegate) | Implements the ISerializable interface and returns the data needed to serialize the Delegate.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

CombineImpl | [To be supplied.]
DynamicInvokeImpl | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetMethodImpl (inherited from Delegate) | Gets the static method of the class represented by the Delegate.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveImpl | [To be supplied.]

See Also

MulticastDelegate Class | System Namespace


MulticastDelegate.CombineImpl

[To be supplied.]

[Visual Basic]
Overrides Protected Function CombineImpl( _
   ByVal follow As Delegate _
) As Delegate
[C#]
protected override Delegate CombineImpl(
   Delegate follow
);
[C++]
protected: override Delegate* CombineImpl(
   Delegate* follow
);
[JScript]
protected override function CombineImpl(
   follow : Delegate
) : Delegate;

Parameters

follow
[To be supplied.]

See Also

MulticastDelegate Class | MulticastDelegate Members | System Namespace


MulticastDelegate.DynamicInvokeImpl

[To be supplied.]

[Visual Basic]
Overrides Protected Function DynamicInvokeImpl( _
   ByVal args() As Object _
) As Object
[C#]
protected override object DynamicInvokeImpl(
   object[] args
);
[C++]
protected: override Object* DynamicInvokeImpl(
   Object* args[]
);
[JScript]
protected override function DynamicInvokeImpl(
   args : Object[]
) : Object;

Parameters

args
The arguments to be passed to the encapsulated method.

Return Value

A Variant array that contains the return value of the encapsulated method.

Exceptions

Exception Type | Condition
AccessException | There is an attempt to invoke a method to which the caller does not have access (i.e., a private method).
ArgumentException | The number, order, or type of parameters is invalid.
TargetException | An encapsulated method is non-static, and the target object is null. There is an attempt to invoke a method on an object or class that does not support the method.
TargetInvocationException | One of the encapsulated methods throws an exception.

See Also

MulticastDelegate Class | MulticastDelegate Members | System Namespace


MulticastDelegate.Equals

Determines whether this multicast delegate and the specified object are equal.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The object to compare with this instance.

Return Value

True if obj and this instance have the same invocation lists; false otherwise.

Remarks

Two delegates, whether single- or multi-cast, are equal if they have the same invocation lists. Two invocation lists are considered identical if they have the same order, and the corresponding elements from the two lists represent the same method and target.

The methods and targets are compared for equality in the following way. If the two methods being compared are static, they must be the same method on the same class, in which case the methods and targets are considered equal. If the two methods being compared are instance methods, they must be the same method on the same object, in which case the methods and targets are considered equal. Otherwise the methods and targets are not considered to be equal.

See Also

MulticastDelegate Class | MulticastDelegate Members | System Namespace


MulticastDelegate.GetInvocationList

Returns the invocation list of this multicast delegate, in invocation order.

[Visual Basic]
Overrides Public Function GetInvocationList() As Delegate ()
[C#]
public override Delegate[] GetInvocationList();
[C++]
public: override Delegate* GetInvocationList() [];
[JScript]
public override function GetInvocationList() : Delegate[];

Return Value

Returns an array containing the delegates in the invocation list.

See Also

MulticastDelegate Class | MulticastDelegate Members | System Namespace


MulticastDelegate.RemoveImpl

[To be supplied.]

[Visual Basic]
Overrides Protected Function RemoveImpl( _
   ByVal value As Delegate _
) As Delegate
[C#]
protected override Delegate RemoveImpl(
   Delegate value
);
[C++]
protected: override Delegate* RemoveImpl(
   Delegate* value
);
[JScript]
protected override function RemoveImpl(
   value : Delegate
) : Delegate;

Parameters

value
[To be supplied.]

See Also

MulticastDelegate Class | MulticastDelegate Members | System Namespace


Operators

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MulticastDelegate Operators

The operators of the MulticastDelegate class are listed below. For a complete list of MulticastDelegate class members, see the MulticastDelegate Members topic.

Public:

Equality Operator | Determines whether two MulticastDelegate objects are equal.
Inequality Operator | Determines whether two MulticastDelegate objects are not equal.

See Also

MulticastDelegate Class | System Namespace


MulticastDelegate Equality Operator

Determines whether two MulticastDelegate objects are equal.

[C#]
public static new bool operator ==(
   MulticastDelegate d1,
   MulticastDelegate d2
);
[C++]
public: static new bool operator op_Equality(
   MulticastDelegate* d1,
   MulticastDelegate* d2
);
[JScript]
returnValue = d1 == d2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

d1
The left operand.
d2
The right operand.

Parameters [C#, C++]

d1
The left operand.
d2
The right operand.

Return Value [C#, C++, JScript]

True if d1 and d2 have the same invocation lists; otherwise false.

Remarks [C#, C++, JScript]

Two delegates, whether single- or multi-cast, are equal if they have the same invocation lists. Two invocation lists are considered identical if they have the same order, and the corresponding elements from the two lists represent the same method and target.

The methods and targets are compared for equality in the following way. If the two methods being compared are static, they must be the same method on the same class, in which case the methods and targets are considered equal. If the two methods being compared are instance methods, they must be the same method on the same object, in which case the methods and targets are considered equal. Otherwise the methods and targets are not considered to be equal.

See Also

MulticastDelegate Class | MulticastDelegate Members | System Namespace


MulticastDelegate Inequality Operator

Determines whether two MulticastDelegate objects are not equal.

[C#]
public static new bool operator !=(
   MulticastDelegate d1,
   MulticastDelegate d2
);
[C++]
public: static new bool operator op_Inequality(
   MulticastDelegate* d1,
   MulticastDelegate* d2
);
[JScript]
returnValue = d1 ! = d2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

d1
The left operand.
d2
The right operand.

Parameters [C#, C++]

d1
The left operand.
d2
The right operand.

Return Value [C#, C++, JScript]

True if d1 and d2 do not have the same invocation lists; otherwise false.

Remarks [C#, C++, JScript]

Two delegates, whether single- or multi-cast, are equal if they have the same invocation lists. Two invocation lists are considered identical if they have the same order, and the corresponding elements from the two lists represent the same method and target.

The methods and targets are compared for equality in the following way. If the two methods being compared are static, they must be the same method on the same class, in which case the methods and targets are considered equal. If the two methods being compared are instance methods, they must be the same method on the same object, in which case the methods and targets are considered equal. Otherwise the methods and targets are considered to be unequal.

See Also

MulticastDelegate Class | MulticastDelegate Members | System Namespace


MulticastNotSupportedException Class

Represents the exception that is thrown when there is an attempt to add multiple callbacks to a non-multicast delegate.

Object
Exception
SystemException
MulticastNotSupportedException

[Visual Basic]
NotInheritable Public Class MulticastNotSupportedException
   Inherits SystemException
[C#]
public sealed class MulticastNotSupportedException :
   SystemException
[C++]
public __gc __sealed class MulticastNotSupportedException : public
   SystemException
[JScript]
public class MulticastNotSupportedException extends SystemException

Remarks

The MulticastNotSupportedException is the exception class that is thrown when you add multiple callbacks to a delegate that does not allow multicasts to be invoked.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

MulticastNotSupportedException Members | System Namespace


MulticastNotSupportedException Members

Public:

Constructor

MulticastNotSupportedException Constructor Overloaded. Initializes an instance of the MulticastNotSupportedException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

MulticastNotSupportedException Class | System Namespace


MulticastNotSupportedException Constructor

Initializes an instance of the MulticastNotSupportedException class.

Overload List

Initializes an instance of the MulticastNotSupportedException with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public MulticastNotSupportedException();
[C++] public: MulticastNotSupportedException();
[JScript] public function MulticastNotSupportedException();

Initializes an instance of MulticastNotSupportedException with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public MulticastNotSupportedException(String);
[C++] public: MulticastNotSupportedException(String*);
[JScript] public function MulticastNotSupportedException(String);

Initializes an instance of MulticastNotSupportedException with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public MulticastNotSupportedException(String, Exception);
[C++] public: MulticastNotSupportedException(String*, Exception);
[JScript] public function MulticastNotSupportedException(String, Exception);

See Also

MulticastNotSupportedException Class | MulticastNotSupportedException Members | System Namespace


MulticastNotSupportedException Constructor ()

Initializes an instance of the MulticastNotSupportedException with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public MulticastNotSupportedException();
[C++]
public: MulticastNotSupportedException();
[JScript]
public function MulticastNotSupportedException();

Remarks

MulticastNotSupportedException inherits from the Exception class. This constructor sets the properties of the MulticastNotSupportedException object as follows:

Property Type | Condition
InnerException | null
Message | The empty string.

See Also

MulticastNotSupportedException Class | MulticastNotSupportedException Members | System Namespace | MulticastNotSupportedException Constructor Overload List


MulticastNotSupportedException Constructor (String)

Initializes an instance of MulticastNotSupportedException with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public MulticastNotSupportedException(
   string message
);
[C++]
public: MulticastNotSupportedException(
   String* message
);
[JScript]
public function MulticastNotSupportedException(
   message : String
);

Parameters

message
The message indicating the reason why the exception occurred.

Remarks

MulticastNotSupportedException inherits from the Exception class. This constructor sets the properties of the MulticastNotSupportedException object as follows:

Property Type | Condition
InnerException | null
Message | The message string.

See Also

MulticastNotSupportedException Class | MulticastNotSupportedException Members | System Namespace | MulticastNotSupportedException Constructor Overload List


MulticastNotSupportedException Constructor (String, Exception)

Initializes an instance of MulticastNotSupportedException with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public MulticastNotSupportedException(
   string message,
   Exception inner
);
[C++]
public: MulticastNotSupportedException(
   String* message,
   Exception* inner
);
[JScript]
public function MulticastNotSupportedException(
   message : String,
   inner : Exception
);

Parameters

message
The message that indicates the reason why the exception occurred.
inner
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

MulticastNotSupportedException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | The inner exception.
Message | The message string.

See Also

MulticastNotSupportedException Class | MulticastNotSupportedException Members | System Namespace | MulticastNotSupportedException Constructor Overload List


NonSerializedAttribute Class

[To be supplied.]

Object
Attribute
NonSerializedAttribute

[Visual Basic]
Public Class NonSerializedAttribute
   Inherits Attribute
[C#]
public class NonSerializedAttribute : Attribute
[C++]
public __gc class NonSerializedAttribute : public Attribute
[JScript]
public class NonSerializedAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

NonSerializedAttribute Members | System Namespace


NonSerializedAttribute Members

Public:

Constructor

NonSerializedAttribute Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NonSerializedAttribute Class | System Namespace


NonSerializedAttribute Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public NonSerializedAttribute();
[C++]
public: NonSerializedAttribute();
[JScript]
public function NonSerializedAttribute();

See Also

NonSerializedAttribute Class | NonSerializedAttribute Members | System Namespace


NotFiniteNumberException Class

Represents an exception that helps handle numbers that are not valid.

Object
Exception
SystemException
ArithmeticException
NotFiniteNumberException

[Visual Basic]
Public Class NotFiniteNumberException
   Inherits ArithmeticException
[C#]
public class NotFiniteNumberException : ArithmeticException
[C++]
public __gc class NotFiniteNumberException : public
   ArithmeticException
[JScript]
public class NotFiniteNumberException extends ArithmeticException

Remarks

The NotFiniteNumberException is the exception class that is thown when the numbers are not finite numbers, which are a set of mathematical elements that are capable of being completely counted.

NotFiniteNumberException inheirts from ArithmeticException.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

NotFiniteNumberException Members | System Namespace


NotFiniteNumberException Members

Public:

Constructor

NotFiniteNumberException Constructor Overloaded. Initializes a new NotFiniteNumberException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
OffendingNumber | Determines whether the Double is a finite number.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

NotFiniteNumberException Class | System Namespace


NotFiniteNumberException Constructor

Initializes a new NotFiniteNumberException class.

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public NotFiniteNumberException();
[C++] public: NotFiniteNumberException();
[JScript] public function NotFiniteNumberException();

Initializes a new NotFiniteNumberException class with a offending number message.

[Visual Basic] Overloads Public Sub New(Double)
[C#] public NotFiniteNumberException(double);
[C++] public: NotFiniteNumberException(double);
[JScript] public function NotFiniteNumberException(double);

Initializes a new NotFiniteNumberException with a message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public NotFiniteNumberException(String);
[C++] public: NotFiniteNumberException(String*);
[JScript] public function NotFiniteNumberException(String);

Initializes a new NotFiniteNumberException with a message about the offending number.

[Visual Basic] Overloads Public Sub New(String, Double)
[C#] public NotFiniteNumberException(String, double);
[C++] public: NotFiniteNumberException(String*, double);
[JScript] public function NotFiniteNumberException(String, double);

Initializes a new NotFiniteNumberException with a message about the offending number and reference to the exception message.

[Visual Basic] Overloads Public Sub New(String, Double, Exception)
[C#] public NotFiniteNumberException(String, double, Exception);
[C++] public: NotFiniteNumberException(String*, double, Exception);
[JScript] public function NotFiniteNumberException(String, double, Exception);

See Also

NotFiniteNumberException Class | NotFiniteNumberException Members | System Namespace


NotFiniteNumberException Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public NotFiniteNumberException();
[C++]
public: NotFiniteNumberException();
[JScript]
public function NotFiniteNumberException();

See Also

NotFiniteNumberException Class | NotFiniteNumberException Members | System Namespace | NotFiniteNumberException Constructor Overload List


NotFiniteNumberException Constructor (Double)

Initializes a new NotFiniteNumberException class with a offending number message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal offendingNumber As Double _
)
[C#]
public NotFiniteNumberException(
   double offendingNumber
);
[C++]
public: NotFiniteNumberException(
   double offendingNumber
);
[JScript]
public function NotFiniteNumberException(
   offendingNumber : double
);

Parameters

offendingNumber
The double is not a finite number.

Remarks

The offendingNumber parameter must be a Double and a finite number.

See Also

NotFiniteNumberException Class | NotFiniteNumberException Members | System Namespace | NotFiniteNumberException Constructor Overload List


NotFiniteNumberException Constructor (String)

Initializes a new NotFiniteNumberException with a message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public NotFiniteNumberException(
   string message
);
[C++]
public: NotFiniteNumberException(
   String* message
);
[JScript]
public function NotFiniteNumberException(
   message : String
);

Parameters

message
The message that indictes the reason the exception occurred.

Remarks

NotFiniteNumberException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | null
Message | The empty string.

See Also

NotFiniteNumberException Class | NotFiniteNumberException Members | System Namespace | NotFiniteNumberException Constructor Overload List


NotFiniteNumberException Constructor (String, Double)

Initializes a new NotFiniteNumberException with a message about the offending number.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal offendingNumber As Double _
)
[C#]
public NotFiniteNumberException(
   string message,
   double offendingNumber
);
[C++]
public: NotFiniteNumberException(
   String* message,
   double offendingNumber
);
[JScript]
public function NotFiniteNumberException(
   message : String,
   offendingNumber : double
);

Parameters

message
The message that indicates the reason the exception occurred.
offendingNumber
The double that is not a finite number.

Remarks

The message parameter contains a message about the reason for the exception.

The offendingNumber parameter must be a Double and a finite number.

NotFiniteNumberException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | null
Message | The empty string.

See Also

NotFiniteNumberException Class | NotFiniteNumberException Members | System Namespace | NotFiniteNumberException Constructor Overload List


NotFiniteNumberException Constructor (String, Double, Exception)

Initializes a new NotFiniteNumberException with a message about the offending number and reference to the exception message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal offendingNumber As Double, _
   ByVal inner As Exception _
)
[C#]
public NotFiniteNumberException(
   string message,
   double offendingNumber,
   Exception inner
);
[C++]
public: NotFiniteNumberException(
   String* message,
   double offendingNumber,
   Exception* inner
);
[JScript]
public function NotFiniteNumberException(
   message : String,
   offendingNumber : double,
   inner : Exception
);

Parameters

message
The message that indicates the reason the exception occurred.
offendingNumber
[To be supplied.]
inner
[To be supplied.]

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

MissingMemberException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | null
Message | The empty string.

See Also

NotFiniteNumberException Class | NotFiniteNumberException Members | System Namespace | NotFiniteNumberException Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

NotFiniteNumberException Properties

The properties of the NotFiniteNumberException class are listed below. For a complete list of NotFiniteNumberException class members, see the NotFiniteNumberException Members topic.

Public:

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
OffendingNumber | Determines whether the Double is a finite number.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

See Also

NotFiniteNumberException Class | System Namespace


NotFiniteNumberException.OffendingNumber

Determines whether the Double is a finite number.

[Visual Basic]
Overridable Public ReadOnly Property OffendingNumber As Double
[C#]
public double OffendingNumber {virtual get;}
[C++]
public: __property virtual double get_OffendingNumber();
[JScript]
public function get OffendingNumber() : double;

Property Value

The offending number.

Remarks

The OffendingNumber property determines whether the numbers are a Double, which are numbers that are four-byte, double precision, floating-point.

See Also

NotFiniteNumberException Class | NotFiniteNumberException Members | System Namespace


NotImplementedException Class

[To be supplied.]

Object
Exception
SystemException
NotImplementedException

[Visual Basic]
Public Class NotImplementedException
   Inherits SystemException
[C#]
public class NotImplementedException : SystemException
[C++]
public __gc class NotImplementedException : public SystemException
[JScript]
public class NotImplementedException extends SystemException

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

NotImplementedException Members | System Namespace


NotImplementedException Members

Public:

Constructor

NotImplementedException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

NotImplementedException Class | System Namespace


NotImplementedException Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public NotImplementedException();
[C++] public: NotImplementedException();
[JScript] public function NotImplementedException();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public NotImplementedException(String);
[C++] public: NotImplementedException(String*);
[JScript] public function NotImplementedException(String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public NotImplementedException(String, Exception);
[C++] public: NotImplementedException(String*, Exception);
[JScript] public function NotImplementedException(String, Exception);

See Also

NotImplementedException Class | NotImplementedException Members | System Namespace


NotImplementedException Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public NotImplementedException();
[C++]
public: NotImplementedException();
[JScript]
public function NotImplementedException();

See Also

NotImplementedException Class | NotImplementedException Members | System Namespace | NotImplementedException Constructor Overload List


NotImplementedException Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public NotImplementedException(
   string message
);
[C++]
public: NotImplementedException(
   String* message
);
[JScript]
public function NotImplementedException(
   message : String
);

Parameters

message
[To be supplied.]

See Also

NotImplementedException Class | NotImplementedException Members | System Namespace | NotImplementedException Constructor Overload List


NotImplementedException Constructor (String, Exception)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public NotImplementedException(
   string message,
   Exception inner
);
[C++]
public: NotImplementedException(
   String* message,
   Exception* inner
);
[JScript]
public function NotImplementedException(
   message : String,
   inner : Exception
);

Parameters

message
[To be supplied.]
inner
[To be supplied.]

See Also

NotImplementedException Class | NotImplementedException Members | System Namespace | NotImplementedException Constructor Overload List


NotSupportedException Class

Represents the exception that is thrown to indicate that a method is not supported.

Object
Exception
SystemException
NotSupportedException

[Visual Basic]
Public Class NotSupportedException
   Inherits SystemException
[C#]
public class NotSupportedException : SystemException
[C++]
public __gc class NotSupportedException : public SystemException
[JScript]
public class NotSupportedException extends SystemException

Remarks

The NotSupportedException is the exception class that is thrown for methods that should be implemented on subclasses.

A class may implement an interface and rather than provide support for a particular method, the implementation may simply throw the NotSupportedException exception.

The NotSupportedException is thrown by a number of the System.IO Namespace classes when there is an attempt to read, seek, or write to a stream that does not support this functionality. For example, after a call to Close the various write methods will throw the NotSupportedException.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

NotSupportedException Members | System Namespace


NotSupportedException Members

Public:

Constructor

NotSupportedException Constructor Overloaded. Initializes an instance of the NotSupportedException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

NotSupportedException Class | System Namespace


NotSupportedException Constructor

Initializes an instance of the NotSupportedException class.

Overload List

Initializes an instance of the NotSupportedException class with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public NotSupportedException();
[C++] public: NotSupportedException();
[JScript] public function NotSupportedException();

Initializes an instance of NotSupportedException with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public NotSupportedException(String);
[C++] public: NotSupportedException(String*);
[JScript] public function NotSupportedException(String);

Initializes an instance of NotSupportedException with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public NotSupportedException(String, Exception);
[C++] public: NotSupportedException(String*, Exception);
[JScript] public function NotSupportedException(String, Exception);

See Also

NotSupportedException Class | NotSupportedException Members | System Namespace


NotSupportedException Constructor ()

Initializes an instance of the NotSupportedException class with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public NotSupportedException();
[C++]
public: NotSupportedException();
[JScript]
public function NotSupportedException();

Remarks

NotSupportedException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The empty string.

See Also

NotSupportedException Class | NotSupportedException Members | System Namespace | NotSupportedException Constructor Overload List


NotSupportedException Constructor (String)

Initializes an instance of NotSupportedException with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public NotSupportedException(
   string message
);
[C++]
public: NotSupportedException(
   String* message
);
[JScript]
public function NotSupportedException(
   message : String
);

Parameters

message
The message that indicates the reason why the exception occurred.

Remarks

NotSupportedException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The message string.

See Also

NotSupportedException Class | NotSupportedException Members | System Namespace | NotSupportedException Constructor Overload List


NotSupportedException Constructor (String, Exception)

Initializes an instance of NotSupportedException with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public NotSupportedException(
   string message,
   Exception inner
);
[C++]
public: NotSupportedException(
   String* message,
   Exception* inner
);
[JScript]
public function NotSupportedException(
   message : String,
   inner : Exception
);

Parameters

message
The message that indicates the reason why the exception occurred.
inner
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

NotSupportedException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | The inner exception.
Message | The message string.

See Also

NotSupportedException Class | NotSupportedException Members | System Namespace | NotSupportedException Constructor Overload List


NullReferenceException Class

Represents the exception that is thrown when there is an attempt to dereference a null object reference.

Object
Exception
SystemException
NullReferenceException

[Visual Basic]
Public Class NullReferenceException
   Inherits SystemException
[C#]
public class NullReferenceException : SystemException
[C++]
public __gc class NullReferenceException : public SystemException
[JScript]
public class NullReferenceException extends SystemException

Remarks

The NullReferenceException is the exception class that is thrown when the access reference to a null reference is changed.

Requirements

Namespace: System

Assembly: mscorlib.dll

Example

The following code would cause a NullReferenceException to be thrown:

#import <mscorlib.dll>
#define NULL 0x00
void main() {
  Object *obj = NULL;
  obj->ToString();
}

See Also

NullReferenceException Members | System Namespace


NullReferenceException Members

Public:

Constructor

NullReferenceException Constructor Overloaded. Initializes an instance of the NullReferenceException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

NullReferenceException Class | System Namespace


NullReferenceException Constructor

Initializes an instance of the NullReferenceException class.

Overload List

Initializes an instance of the NullReferenceException class with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public NullReferenceException();
[C++] public: NullReferenceException();
[JScript] public function NullReferenceException();

Initializes an instance of NullReferenceException with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public NullReferenceException(String);
[C++] public: NullReferenceException(String*);
[JScript] public function NullReferenceException(String);

Initializes an instance of NullReferenceException with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public NullReferenceException(String, Exception);
[C++] public: NullReferenceException(String*, Exception);
[JScript] public function NullReferenceException(String, Exception);

See Also

NullReferenceException Class | NullReferenceException Members | System Namespace


NullReferenceException Constructor ()

Initializes an instance of the NullReferenceException class with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public NullReferenceException();
[C++]
public: NullReferenceException();
[JScript]
public function NullReferenceException();

Remarks

NullReferenceException inherits from the Exception class. This constructor sets the properties of the NullReferenceException object as follows:

Property Type | Condition
InnerException | null
Message | The empty string.

See Also

NullReferenceException Class | NullReferenceException Members | System Namespace | NullReferenceException Constructor Overload List


NullReferenceException Constructor (String)

Initializes an instance of NullReferenceException with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public NullReferenceException(
   string message
);
[C++]
public: NullReferenceException(
   String* message
);
[JScript]
public function NullReferenceException(
   message : String
);

Parameters

message
The message identifies the reason why the exception occurred.

Remarks

NullReferenceException inherits from the Exception class. This constructor sets the properties of the NullReferenceException object as follows:

Property Type | Condition
InnerException | null
Message | The message string.

See Also

NullReferenceException Class | NullReferenceException Members | System Namespace | NullReferenceException Constructor Overload List


NullReferenceException Constructor (String, Exception)

Initializes an instance of NullReferenceException with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public NullReferenceException(
   string message,
   Exception inner
);
[C++]
public: NullReferenceException(
   String* message,
   Exception* inner
);
[JScript]
public function NullReferenceException(
   message : String,
   inner : Exception
);

Parameters

message
The message identifies the reason why the exception occurred.
inner
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

NullReferenceException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | The inner exception.
Message | The message string.

See Also

NullReferenceException Class | NullReferenceException Members | System Namespace | NullReferenceException Constructor Overload List


Object Class

Supports all classes in the NGWS frameworks class hierarchy and provides low-level services to subclasses. This is the ultimate superclass of all classes in the NGWS frameworks; it is the root of the type hierarchy.

Object

[Visual Basic]
Public Class Object
[C#]
public class Object
[C++]
public __gc class Object
[JScript]
public class Object

Remarks

Languages typically do not require a class to declare inheritance from Object-- the inheritance is implicit.

Every method defined in the Object class is available in all of its subclasses and, hence, in all objects in the system. Subclasses can and do override some of these methods, including:

  • ToString- Supports a less cluttered debugging output.
  • Equals- Supports comparisons between objects.
  • GetHashCode- Supports the use of a hashtable.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

Object Members | System Namespace


Object Members

Public:

Constructor

Object Constructor Initializes a new instance of the Object class.

Methods

Equals | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType | Gets the Type of the Object.
ToString | Returns a String that represents the current Object.

Protected:

Methods

Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone | Creates a shallow copy of the current Object.

See Also

Object Class | System Namespace


Object Constructor

Initializes a new instance of the Object class.

[Visual Basic]
Public Sub New()
[C#]
public Object();
[C++]
public: Object();
[JScript]
public function Object();

See Also

Object Class | Object Members | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Object Methods

The methods of the Object class are listed below. For a complete list of Object class members, see the Object Members topic.

Public:

Equals | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType | Gets the Type of the Object.
ToString | Returns a String that represents the current Object.

Protected:

Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone | Creates a shallow copy of the current Object.

See Also

Object Class | System Namespace


Object.Equals

Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).

[Visual Basic]
Overridable Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public virtual bool Equals(
   object obj
);
[C++]
public: virtual bool Equals(
   Object* obj
);
[JScript]
public function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is the same instance as the current Object; otherwise, false.

Remarks

For reference types, equality is defined as object equality; that is, whether the references refer to the same object. For value types, equality is defined as bitwise equality. The ValueType class supports value types.

Notes to Implementers:

This method can be overridden by a derived class. For example, many of the base data types return true if both objects represent the same value; false otherwise.

This method only compares primitives and objects. It must be overridden to compare more complex structures, such as arrays of objects.

Implementations of this method must obey the following:

  • Equals is reflexive. If x is an object reference, then x.Equals(x) == true.
  • Equals is symmetric. If x and y are object references, then x.Equals(y) == true implies that y.Equals(x) == true.
  • Equals is transitive. If x, y, and z are object references, then x.Equals(y) == true && y.Equals(z) == true implies x.Equals(z) == true.
  • Equals is consistent. x.Equals(y) returns the same value upon each invocation as long as objects x and y are not modified.
  • Equals is non-null. If x != a null reference (in Visual Basic Nothing) then x.Equals(a null reference (Nothing)) == false.

Example

Managed C++:

Object *Obj1 = new Object();
Object *Obj2 = new Object();
Console::WriteLine(Obj1->Equals(Obj2)); //===> false
Obj2 = Obj1;
Console::WriteLine(Obj1->Equals(Obj2)); //===> true

See Also

Object Class | Object Members | System Namespace


Object.Finalize

Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.

[Visual Basic]
Overridable Protected Sub Finalize()
[C#]
protected virtual void Finalize();
[C++]
protected: virtual void Finalize();
[JScript]
protected function Finalize();

Return Value

None.

Remarks

This method is invoked some time after the GC determines that the current Object is no longer being referenced by any other Object.

Notes to Implementers:

Finalize does nothing by default. It must be overridden by a derived class, because reclamation by the GC tends to take much longer if a Finalize operation must be run.

If an Object holds references to any resources, Finalize must be overridden by a derived class in order to free these resources before the Object is discarded by the GC.

Finalize may take any action, including resurrecting an object (that is, making the object accessible again) after it has been cleaned up by the GC. However, the object can only be resurrected once; the GC will not call Finalize on resurrected objects.

Finalize operations have the following limitations:

  • The finalizer is not guaranteed to be run. If the resource must be freed, the Dispose() design pattern is recommended. (See Design Guidelines spec).
  • The finalizer is not guaranteed to run at any specific time. Resources are not guaranteed to be released at any specific time, unless calling a Close method or a Dispose method.
  • The finalizers of two objects are not guaranteed to run in any specific order, even if one object refers to the other. That is, if Object A has a reference to Object B and both have finalizers, Object B may or may not have already finalized when the finalizer of Object A starts.

See Also

Object Class | Object Members | System Namespace | GC | WeakReference


Object.GetHashCode

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

[Visual Basic]
Overridable Public Function GetHashCode() As Integer
[C#]
public virtual int GetHashCode();
[C++]
public: virtual int GetHashCode();
[JScript]
public function GetHashCode() : int;

Return Value

A hash code for the current Object.

Remarks

This method can be overridden by a derived class. Value classes and classes that may be used as a key in a hash table must override this method.

The return value from GetHashCode must not be persisted for two reasons. First, the hash function of a class might be altered by its implementer to generate a better distribution, rendering any values from the old hash function useless. Second, the default implementation of Object does not guarantee that the same value will be returned by different instances.

Notes to Implementers:

A hash function is used to quickly generate a number (hash code) corresponding to the value of an object. Hash functions usually are specific for each type, and should use at least one of the instance fields as input. A hash function has two interesting properties:

  • If two objects of the same type represent the same value, the hash function must return the same constant value for each object.
  • A hash function should generate a random distribution for all input for the best performance.

Ensuring these properties are met is up to the implementor of the GetHashCode method. Object's GetHashCode does not know anything about the values represented by specific objects, so it can only guarantee that if you call GetHashCode on the same instance repeatedly, it will return the same value.

Providing a good hash function on a class can affect the performance of adding those objects to a hash table by an enormous amount. A good implementation will mean hash table lookups take constant time (ie, they are O(1)), while an extremely poor one that always returned a hard-coded number would make hash table lookups depend on the number of items in the hash table (ie, they would be O(n)). Hash functions should also be cheap to compute.

Subclass implementations of GetHashCode should guarantee the properties listed above. For example, the implementation of GetHashCode provided by the String class returns unique hash codes for unique string values. Therefore, two String objects will return the same hash code if and only if they represent the same string value. Also, the method uses all of the characters in the string to generate reasonably randomly distributed output, even when the input may be clustered in certain ranges (ie, many users may only have strings containing the lower 128 ASCII characters, though Unicode allows over 65,535 characters).

The default implementation returns an runtime-determined index for the object, which is unique to an instance of an object within an AppDomain for an instance of the EE. However, because this index can be reused after an object is garbage collected, it is possible to obtain the same hash code for two different objects. Also, two objects that represent the same value will have the same hash code only if they are the exact same object. This implementation is not particularly useful for hashing, and it is why subclasses should override GetHashCode.

See Also

Object Class | Object Members | System Namespace | Hashtable


Object.GetType

Gets the Type of the Object.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[JScript]
public function GetType() : Type;

Return Value

The Type of the Object.

Remarks

The Type object exposes the metadata associated with the class of the current Object.

See Also

Object Class | Object Members | System Namespace | Type


Object.MemberwiseClone

Creates a shallow copy of the current Object.

[Visual Basic]
Protected Function MemberwiseClone() As Object
[C#]
protected object MemberwiseClone();
[C++]
protected: Object* MemberwiseClone();
[JScript]
protected function MemberwiseClone() : Object;

Return Value

A shallow copy of the current Object.

Remarks

A shallow copy of an Object is a copy of the Object only. If the Object contains references to other objects, the shallow copy will not create copies of the referred objects, but will refer to the original objects instead. On the other hand, a deep copy of an object creates a copy of the object and a copy of everything directly or indirectly referenced by that object.

For example, if X is an Object with references to the objects A and B, and the object A also has a reference to an object M, a shallow copy of X is an object Y, which also has references to objects A and B. On the other hand, a deep copy of X is an object Y with direct references to objects C and D, and an indirect reference to object N, where C is a copy of A, D is a copy of B, and N is a copy of M.

This method cannot be overridden; a subclass should implement the ICloneable interface if a shallow copy is not appropriate. This method is protected so that only subclasses can call it on themselves.

See Also

Object Class | Object Members | System Namespace | ICloneable


Object.ToString

Returns a String that represents the current Object.

[Visual Basic]
Overridable Public Function ToString() As String
[C#]
public virtual string ToString();
[C++]
public: virtual String* ToString();
[JScript]
public function ToString() : String;

Return Value

A String that represents the current Object.

Remarks

The default implementation returns the fully qualified name of the class of the Object.

This method can be overridden by a derived class to produce more meaningful results. For example, the base data types return their value.

Example

// Prints out: "System.Object"
Object *o = new Object();
Console->WriteLine (o->ToString());

See Also

Object Class | Object Members | System Namespace | String


ObsoleteAttribute Class

Represents an attribute that is attached to members that are not to be used any longer. Message is some human readable explanation of what to use. Error indicates whether the compiler should treat usage of such a method as an error.

Object
Attribute
ObsoleteAttribute

[Visual Basic]
Public Class ObsoleteAttribute
   Inherits Attribute
[C#]
public class ObsoleteAttribute : Attribute
[C++]
public __gc class ObsoleteAttribute : public Attribute
[JScript]
public class ObsoleteAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

ObsoleteAttribute Members | System Namespace


ObsoleteAttribute Members

Public:

Constructor

ObsoleteAttribute Constructor Overloaded. Initializes a new ObsoleteAttribute.

Properties

IsError | Indicates whether the compiler should treat usage of such a method as an error.
Message | A human readable explanation of what to use.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ObsoleteAttribute Class | System Namespace


ObsoleteAttribute Constructor

Initializes a new ObsoleteAttribute.

Overload List

Initializes a new ObsoleteAttribute with default properties.

Message = String.Empty

Error = false

[Visual Basic] Overloads Public Sub New()
[C#] public ObsoleteAttribute();
[C++] public: ObsoleteAttribute();
[JScript] public function ObsoleteAttribute();

Initializes a new ObsoleteAttribute with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public ObsoleteAttribute(String);
[C++] public: ObsoleteAttribute(String*);
[JScript] public function ObsoleteAttribute(String);

Initializes a new ObsoleteAttribute with a message and a Boolean indicating whether it is an error.

[Visual Basic] Overloads Public Sub New(String, Boolean)
[C#] public ObsoleteAttribute(String, bool);
[C++] public: ObsoleteAttribute(String*, bool);
[JScript] public function ObsoleteAttribute(String, Boolean);

See Also

ObsoleteAttribute Class | ObsoleteAttribute Members | System Namespace


ObsoleteAttribute Constructor ()

Initializes a new ObsoleteAttribute with default properties.

Message = String.Empty

Error = false

[Visual Basic]
Overloads Public Sub New()
[C#]
public ObsoleteAttribute();
[C++]
public: ObsoleteAttribute();
[JScript]
public function ObsoleteAttribute();

See Also

ObsoleteAttribute Class | ObsoleteAttribute Members | System Namespace | ObsoleteAttribute Constructor Overload List


ObsoleteAttribute Constructor (String)

Initializes a new ObsoleteAttribute with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public ObsoleteAttribute(
   string message
);
[C++]
public: ObsoleteAttribute(
   String* message
);
[JScript]
public function ObsoleteAttribute(
   message : String
);

Parameters

message
Value used to initialize the message property of this ObsoleteAttribute.

See Also

ObsoleteAttribute Class | ObsoleteAttribute Members | System Namespace | ObsoleteAttribute Constructor Overload List


ObsoleteAttribute Constructor (String, Boolean)

Initializes a new ObsoleteAttribute with a message and a Boolean indicating whether it is an error.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal error As Boolean _
)
[C#]
public ObsoleteAttribute(
   string message,
   bool error
);
[C++]
public: ObsoleteAttribute(
   String* message,
   bool error
);
[JScript]
public function ObsoleteAttribute(
   message : String,
   error : Boolean
);

Parameters

message
Value used to initialize the Message property of this ObsoleteAttribute.
error
Value used to initialize the IsError property of this ObsoleteAttribute.

See Also

ObsoleteAttribute Class | ObsoleteAttribute Members | System Namespace | ObsoleteAttribute Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ObsoleteAttribute Properties

The properties of the ObsoleteAttribute class are listed below. For a complete list of ObsoleteAttribute class members, see the ObsoleteAttribute Members topic.

Public:

IsError | Indicates whether the compiler should treat usage of such a method as an error.
Message | A human readable explanation of what to use.

See Also

ObsoleteAttribute Class | System Namespace


ObsoleteAttribute.IsError

Indicates whether the compiler should treat usage of such a method as an error.

[Visual Basic]
Overridable Public ReadOnly Property IsError As Boolean
[C#]
public bool IsError {virtual get;}
[C++]
public: __property virtual bool get_IsError();
[JScript]
public function get IsError() : Boolean;

See Also

ObsoleteAttribute Class | ObsoleteAttribute Members | System Namespace


ObsoleteAttribute.Message

A human readable explanation of what to use.

[Visual Basic]
Overridable Public ReadOnly Property Message As String
[C#]
public string Message {virtual get;}
[C++]
public: __property virtual String* get_Message();
[JScript]
public function get Message() : String;

See Also

ObsoleteAttribute Class | ObsoleteAttribute Members | System Namespace


OperatingSystem Class

Contains information about an operating system version. The information includes major version number, minor version numbers, a build number, a platform identifier, and descriptive text about the operating system.

Object
OperatingSystem

[Visual Basic]
Public Class OperatingSystem
   Implements ICloneable
[C#]
public class OperatingSystem : ICloneable
[C++]
public __gc class OperatingSystem : public ICloneable
[JScript]
public class OperatingSystem implements ICloneable

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

OperatingSystem Members | System Namespace


OperatingSystem Members

Public:

Constructor

OperatingSystem Constructor Overloaded. Overloaded. Initializes an instance of the OperatingSystem class.

Properties

CSD | Identifies the Corrected Service Diskette number of the operating system.
Platform | Identifies the operating system platform.
Version | Identifies the version of the operating system.

Methods

Clone | Creates and returns an OperatingSystem object that is an identical copy of the current OperatingSystem object.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Converts the current OperatingSystem object to a string representation.

Protected:

Constructor

OperatingSystem Constructor Overloaded. Overloaded. Initializes an instance of the OperatingSystem class.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

InternalCustomerServiceDiskette | Identifies the Corrected Service Diskette number of the operating system.
InternalPlatform | Identifies the operating system platform.
InternalVersion | Identifies the version of the operating system.

See Also

OperatingSystem Class | System Namespace


OperatingSystem Constructor

Overloaded. Initializes an instance of the OperatingSystem class.

Overload List

Initializes an instance of the OperatingSystem class.

[Visual Basic] Overloads Protected Sub New()
[C#] protected OperatingSystem();
[C++] protected: OperatingSystem();
[JScript] protected function OperatingSystem();

Initializes an instance of the OperatingSystem class given the operating system platform, the operating system version, and the Corrected Service Diskette number.

[Visual Basic] Overloads Public Sub New(PlatformID, Version, String)
[C#] public OperatingSystem(PlatformID, Version, String);
[C++] public: OperatingSystem(PlatformID, Version, String);
[JScript] public function OperatingSystem(PlatformID, Version, String);

See Also

OperatingSystem Class | OperatingSystem Members | System Namespace


OperatingSystem Constructor ()

Initializes an instance of the OperatingSystem class.

[Visual Basic]
Overloads Protected Sub New()
[C#]
protected OperatingSystem();
[C++]
protected: OperatingSystem();
[JScript]
protected function OperatingSystem();

See Also

OperatingSystem Class | OperatingSystem Members | System Namespace | OperatingSystem Constructor Overload List


OperatingSystem Constructor (PlatformID, Version, String)

Initializes an instance of the OperatingSystem class given the operating system platform, the operating system version, and the Corrected Service Diskette number.

[Visual Basic]
Overloads Public Sub New( _
   ByVal platform As PlatformID, _
   ByVal version As Version, _
   ByVal csd As String _
)
[C#]
public OperatingSystem(
   PlatformID platform,
   Version version,
   string csd
);
[C++]
public: OperatingSystem(
   PlatformID platform,
   Version* version,
   String* csd
);
[JScript]
public function OperatingSystem(
   platform : PlatformID,
   version : Version,
   csd : String
);

Parameters

platform
Identifies the operating system platform.
version
Identifies the version of the operating system.
csd
Identifies the Corrected Service Diskette number of the operating system.

Exceptions

Exception Type | Condition
ArgumentNullException | If version is a null reference (in Visual Basic Nothing).

See Also

OperatingSystem Class | OperatingSystem Members | System Namespace | OperatingSystem Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

OperatingSystem Properties

The properties of the OperatingSystem class are listed below. For a complete list of OperatingSystem class members, see the OperatingSystem Members topic.

Public:

CSD | Identifies the Corrected Service Diskette number of the operating system.
Platform | Identifies the operating system platform.
Version | Identifies the version of the operating system.

See Also

OperatingSystem Class | System Namespace


OperatingSystem.CSD

Identifies the Corrected Service Diskette number of the operating system.

[Visual Basic]
Overridable Public ReadOnly Property CSD As String
[C#]
public string CSD {virtual get;}
[C++]
public: __property virtual String* get_CSD();
[JScript]
public function get CSD() : String;

Property Value

On Windows NT and Windows 2000, the value contains a null-terminated string, such as "Service Pack 3" that indicates the latest Service Pack installed on the system. If no Service Pack has been installed, the string is empty.

See Also

OperatingSystem Class | OperatingSystem Members | System Namespace


OperatingSystem.Platform

Identifies the operating system platform.

[Visual Basic]
Overridable Public ReadOnly Property Platform As PlatformID
[C#]
public PlatformID Platform {virtual get;}
[C++]
public: __property virtual PlatformID get_Platform();
[JScript]
public function get Platform() : PlatformID;

Property Value

Returns the operating system platform.

See Also

OperatingSystem Class | OperatingSystem Members | System Namespace


OperatingSystem.Version

Identifies the version of the operating system.

[Visual Basic]
Overridable Public ReadOnly Property Version As Version
[C#]
public Version Version {virtual get;}
[C++]
public: __property virtual Version* get_Version();
[JScript]
public function get Version() : Version;

Property Value

Identifies the version of the operating system. The returned object describes the major version, minor version, build, and revision of the operating system.

See Also

OperatingSystem Class | OperatingSystem Members | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

OperatingSystem Methods

The methods of the OperatingSystem class are listed below. For a complete list of OperatingSystem class members, see the OperatingSystem Members topic.

Public:

Clone | Creates and returns an OperatingSystem object that is an identical copy of the current OperatingSystem object.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Converts the current OperatingSystem object to a string representation.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OperatingSystem Class | System Namespace


OperatingSystem.Clone

Creates and returns an OperatingSystem object that is an identical copy of the current OperatingSystem object.

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

Return Value

An identical copy of the current OperatingSystem object

See Also

OperatingSystem Class | OperatingSystem Members | System Namespace


OperatingSystem.ToString

Converts the current OperatingSystem object to a string representation.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

The format of the returned string is:

<platform> <majorVersion>.<minorVersion>.<revision>.<build> [ <csd>]

For example, for Windows 2000, the returned string, assuming an empty CSD ToString would return:

Microsoft Windows NT 5.0.0.2195

See Also

OperatingSystem Class | OperatingSystem Members | System Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

OperatingSystem Fields

The fields of the OperatingSystem class are listed below. For a complete list of OperatingSystem class members, see the OperatingSystem Members topic.

Protected:

InternalCustomerServiceDiskette | Identifies the Corrected Service Diskette number of the operating system.
InternalPlatform | Identifies the operating system platform.
InternalVersion | Identifies the version of the operating system.

See Also

OperatingSystem Class | System Namespace


OperatingSystem.InternalCustomerServiceDiskette

Identifies the Corrected Service Diskette number of the operating system.

[Visual Basic]
Protected InternalCustomerServiceDiskette As String
[C#]
protected string InternalCustomerServiceDiskette;
[C++]
protected: String* InternalCustomerServiceDiskette;
[JScript]
protected var InternalCustomerServiceDiskette : String;

See Also

OperatingSystem Class | OperatingSystem Members | System Namespace


OperatingSystem.InternalPlatform

Identifies the operating system platform.

[Visual Basic]
Protected InternalPlatform As PlatformID
[C#]
protected PlatformID InternalPlatform;
[C++]
protected: PlatformID InternalPlatform;
[JScript]
protected var InternalPlatform : PlatformID;

See Also

OperatingSystem Class | OperatingSystem Members | System Namespace


OperatingSystem.InternalVersion

Identifies the version of the operating system.

[Visual Basic]
Protected InternalVersion As Version
[C#]
protected Version InternalVersion;
[C++]
protected: Version* InternalVersion;
[JScript]
protected var InternalVersion : Version;

See Also

OperatingSystem Class | OperatingSystem Members | System Namespace


OutOfMemoryException Class

Represents the exception that is thrown when there is not enough memory to continue the execution of a program.

Object
Exception
SystemException
OutOfMemoryException

[Visual Basic]
Public Class OutOfMemoryException
   Inherits SystemException
[C#]
public class OutOfMemoryException : SystemException
[C++]
public __gc class OutOfMemoryException : public SystemException
[JScript]
public class OutOfMemoryException extends SystemException

Remarks

The OutOfMemoryException is the exception class that is thrown when there is not enough memory to continue operation of the program. Out of memory errors occur when the program cannot handle the memory demands to the program and result in the program's termination.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

OutOfMemoryException Members | System Namespace


OutOfMemoryException Members

Public:

Constructor

OutOfMemoryException Constructor Overloaded. Initializes an instance of the OutOfMemoryException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

OutOfMemoryException Class | System Namespace


OutOfMemoryException Constructor

Initializes an instance of the OutOfMemoryException class.

Overload List

Initializes an instance of the OutOfMemoryException class with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public OutOfMemoryException();
[C++] public: OutOfMemoryException();
[JScript] public function OutOfMemoryException();

Initializes an instance of OutOfMemoryException with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public OutOfMemoryException(String);
[C++] public: OutOfMemoryException(String*);
[JScript] public function OutOfMemoryException(String);

Initializes an instance of OutOfMemoryException with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public OutOfMemoryException(String, Exception);
[C++] public: OutOfMemoryException(String*, Exception);
[JScript] public function OutOfMemoryException(String, Exception);

See Also

OutOfMemoryException Class | OutOfMemoryException Members | System Namespace


OutOfMemoryException Constructor ()

Initializes an instance of the OutOfMemoryException class with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public OutOfMemoryException();
[C++]
public: OutOfMemoryException();
[JScript]
public function OutOfMemoryException();

Remarks

OutOfMemoryException inherits from the Exception class. This constructor sets the properties of the OutOfMemoryException object as follows:

Property Type | Condition
InnerException | null
Message | The empty string.

See Also

OutOfMemoryException Class | OutOfMemoryException Members | System Namespace | OutOfMemoryException Constructor Overload List


OutOfMemoryException Constructor (String)

Initializes an instance of OutOfMemoryException with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public OutOfMemoryException(
   string message
);
[C++]
public: OutOfMemoryException(
   String* message
);
[JScript]
public function OutOfMemoryException(
   message : String
);

Parameters

message
The message that identifies the reason the exception occurred.

Remarks

OutOfMemoryException inherits from the Exception class. This constructor sets the properties of the OutOfMemoryException object as follows:

Property Type | Condition
InnerException | null
Message | The message string.

See Also

OutOfMemoryException Class | OutOfMemoryException Members | System Namespace | OutOfMemoryException Constructor Overload List


OutOfMemoryException Constructor (String, Exception)

Initializes an instance of OutOfMemoryException with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public OutOfMemoryException(
   string message,
   Exception inner
);
[C++]
public: OutOfMemoryException(
   String* message,
   Exception* inner
);
[JScript]
public function OutOfMemoryException(
   message : String,
   inner : Exception
);

Parameters

message
The message text of the exception.
inner
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

OutOfMemoryException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | The inner message.
Message | The message string.

See Also

OutOfMemoryException Class | OutOfMemoryException Members | System Namespace | OutOfMemoryException Constructor Overload List


OverflowException Class

Represents the exception that is thrown when an arithmetic operation results in an overflow.

Object
Exception
SystemException
ArithmeticException
OverflowException

[Visual Basic]
Public Class OverflowException
   Inherits ArithmeticException
[C#]
public class OverflowException : ArithmeticException
[C++]
public __gc class OverflowException : public ArithmeticException
[JScript]
public class OverflowException extends ArithmeticException

Remarks

The OverflowException is the exception class that is thrown when there are arithmetic overflows. This results when the value of the parameter is beyond those permitted by the operation.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

OverflowException Members | System Namespace


OverflowException Members

Public:

Constructor

OverflowException Constructor Overloaded. Initializes an instance of the OverflowException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

OverflowException Class | System Namespace


OverflowException Constructor

Initializes an instance of the OverflowException class.

Overload List

Initializes an instance of the OverflowException class with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public OverflowException();
[C++] public: OverflowException();
[JScript] public function OverflowException();

Initializes an instance of OverflowException with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public OverflowException(String);
[C++] public: OverflowException(String*);
[JScript] public function OverflowException(String);

Initializes an instance of OverflowException with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public OverflowException(String, Exception);
[C++] public: OverflowException(String*, Exception);
[JScript] public function OverflowException(String, Exception);

See Also

OverflowException Class | OverflowException Members | System Namespace


OverflowException Constructor ()

Initializes an instance of the OverflowException class with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public OverflowException();
[C++]
public: OverflowException();
[JScript]
public function OverflowException();

Remarks

OverflowException inherits from the Exception class. This constructor sets the properties of the OverflowException object as follows:

Property Type | Condition
InnerException | null
Message | The empty string.

See Also

OverflowException Class | OverflowException Members | System Namespace | OverflowException Constructor Overload List


OverflowException Constructor (String)

Initializes an instance of OverflowException with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public OverflowException(
   string message
);
[C++]
public: OverflowException(
   String* message
);
[JScript]
public function OverflowException(
   message : String
);

Parameters

message
The message identifies the reason why the exception occurred.

Remarks

OverflowException inherits from the Exception class. This constructor sets the properties of the OverflowException object as follows:

Property | Condition
InnerException | null
Message | The message string.

See Also

OverflowException Class | OverflowException Members | System Namespace | OverflowException Constructor Overload List


OverflowException Constructor (String, Exception)

Initializes an instance of OverflowException with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public OverflowException(
   string message,
   Exception inner
);
[C++]
public: OverflowException(
   String* message,
   Exception* inner
);
[JScript]
public function OverflowException(
   message : String,
   inner : Exception
);

Parameters

message
The message identifies the reason why the exception occurred.
inner
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

OverflowException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Value
InnerException | The inner exception.
Message | The message string.

See Also

OverflowException Class | OverflowException Members | System Namespace | OverflowException Constructor Overload List


ParamArray Structure

Presents an array-like abstraction over the arguments to a varargs function call. This is a value type.

Object
ValueType
ParamArray

[Visual Basic]
Public Structure ParamArray
[C#]
public struct ParamArray
[C++]
public __value struct ParamArray

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

ParamArray Members | System Namespace


ParamArray Members

Public:

Constructor

ParamArray Constructor Initializes an instance of the ParamArray class.

Methods

Equals | TODO: Remove. This should go away when we have System.Value in place
GetArg | Returns a TypedReference for the ith argument.
GetCount | Returns the count of arguments in the array.
GetHashCode | To be supplied
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ParamArray Structure | System Namespace


ParamArray Constructor

Initializes an instance of the ParamArray class.

[Visual Basic]
Public Sub New( _
   ByVal arglist As RuntimeArgumentHandle _
)
[C#]
public ParamArray(
   RuntimeArgumentHandle arglist
);
[C++]
public: ParamArray(
   RuntimeArgumentHandle arglist
);
[JScript]
public function ParamArray(
   arglist : RuntimeArgumentHandle
);

Parameters

arglist
RuntimeArgumentHandle provided by the XX IL instruction.

See Also

ParamArray Structure | ParamArray Members | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ParamArray Methods

The methods of the ParamArray structure are listed below. For a complete list of ParamArray structure members, see the ParamArray Members topic.

Public:

Equals | TODO: Remove. This should go away when we have System.Value in place
GetArg | Returns a TypedReference for the ith argument.
GetCount | Returns the count of arguments in the array.
GetHashCode | To be supplied
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ParamArray Structure | System Namespace


ParamArray.Equals

TODO: Remove. This should go away when we have System.Value in place

[Visual Basic]
Overrides Public Function Equals( _
   ByVal o As Object _
) As Boolean
[C#]
public override bool Equals(
   object o
);
[C++]
public: override bool Equals(
   Object* o
);
[JScript]
public override function Equals(
   o : Object
) : Boolean;

Parameters

o
To be supplied

Return Value

To be supplied

Remarks

To be supplied

See Also

ParamArray Structure | ParamArray Members | System Namespace


ParamArray.GetArg

Returns a TypedReference for the ith argument.

[Visual Basic]
Public Function GetArg( _
   ByVal i As Integer _
) As TypedReference
[C#]
public TypedReference GetArg(
   int i
);
[C++]
public: TypedReference GetArg(
   int i
);
[JScript]
public function GetArg(
   i : int
) : TypedReference;

Parameters

i
To be supplied

Return Value

To be supplied

Remarks

To be supplied

See Also

ParamArray Structure | ParamArray Members | System Namespace


ParamArray.GetCount

Returns the count of arguments in the array.

[Visual Basic]
Public Function GetCount() As Integer
[C#]
public int GetCount();
[C++]
public: int GetCount();
[JScript]
public function GetCount() : int;

Return Value

To be supplied

Remarks

To be supplied

See Also

ParamArray Structure | ParamArray Members | System Namespace


ParamArray.GetHashCode

To be supplied

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

To be supplied

Remarks

To be supplied

See Also

ParamArray Structure | ParamArray Members | System Namespace


ParamArrayAttribute Class

[To be supplied.]

Object
Attribute
ParamArrayAttribute

[Visual Basic]
Public Class ParamArrayAttribute
   Inherits Attribute
[C#]
public class ParamArrayAttribute : Attribute
[C++]
public __gc class ParamArrayAttribute : public Attribute
[JScript]
public class ParamArrayAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

ParamArrayAttribute Members | System Namespace


ParamArrayAttribute Members

Public:

Constructor

ParamArrayAttribute Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ParamArrayAttribute Class | System Namespace


ParamArrayAttribute Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ParamArrayAttribute();
[C++]
public: ParamArrayAttribute();
[JScript]
public function ParamArrayAttribute();

See Also

ParamArrayAttribute Class | ParamArrayAttribute Members | System Namespace


PlatformID Enumeration

Describes the platforms supported by an assembly. These flags are used to bind to an assembly.

[Visual Basic]
Public Enum PlatformID
[C#]
public enum PlatformID
[C++]
public enum PlatformID

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Win32NT | Determines whether the operating system is Windows NT.
Win32S | The operating system is Win32s running on a 16-bit version of Windows. The Win32s is a layer used on 16-bit versions of Windows to provide access to 32-bit applications.
Win32Windows | Determines whether the operating system is Windows 95 or later.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

System Namespace


Radix Class

The Radix class provides methods for converting numbers between different counting systems. Counting systems from base 2 (binary) through base 36 are supported.

Object
Radix

[Visual Basic]
NotInheritable Public Class Radix
[C#]
public sealed class Radix
[C++]
public __gc __sealed class Radix
[JScript]
public class Radix

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

Radix Members | System Namespace


Radix Members

Public:

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
ForDigit | Returns the character representing a specified number in a specified base.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsDigit | Determines whether a digit is valid in the counting system based on a specified radix.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

MaxRadix | The base of the smallest counting system supported in this radix conversion.
MinRadix | The base of the largest counting system supported in this radix conversion.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Radix Class | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Radix Methods

The methods of the Radix class are listed below. For a complete list of Radix class members, see the Radix Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
ForDigit | Returns the character representing a specified number in a specified base.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsDigit | Determines whether a digit is valid in the counting system based on a specified radix.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Radix Class | System Namespace


Radix.ForDigit

Returns the character representing a specified number in a specified base.

[Visual Basic]
Public Shared Function ForDigit( _
   ByVal value As Integer, _
   ByVal radix As Integer _
) As Char
[C#]
public static char ForDigit(
   int value,
   int radix
);
[C++]
public: static __wchar_t ForDigit(
   int value,
   int radix
);
[JScript]
public static function ForDigit(
   value : int,
   radix : int
) : Char;

Parameters

value
the value to be converted to a character
radix
the number of the counting system to which value is to be converted

Return Value

The character representing value in base radix.

Exceptions

Exception Type | Condition
FormatException | if radix is greater than MaxRadix or less than MinRadix.

Example [C#]

[C#]

ForDigit (10, 16) => "A"
ForDigit(1, 10) => "1"

ForDigit (11, 5) => Throws
NumberFormatException

See Also

Radix Class | Radix Members | System Namespace


Radix.IsDigit

Determines whether a digit is valid in the counting system based on a specified radix.

[Visual Basic]
Public Shared Function IsDigit( _
   ByVal c As Char, _
   ByVal radix As Integer _
) As Boolean
[C#]
public static bool IsDigit(
   char c,
   int radix
);
[C++]
public: static bool IsDigit(
   __wchar_t c,
   int radix
);
[JScript]
public static function IsDigit(
   c : Char,
   radix : int
) : Boolean;

Parameters

c
the character to be checked
radix
the counting system (base) against which the character is to be checked

Return Value

Returns true if and only if c is a valid digit of base radix.

Exceptions

Exception Type | Condition
FormatException | if radix is greater than MaxRadix or less than MinRadix.

Remarks

The possible digits are chosen in this order: "0123456789abcdefghijklmnopqrstuvwxyz". Case is ignored in this comparison, i.e., "a" == "A." If the radix is N, the first N characters are considered digits in that base.

See Also

Radix Class | Radix Members | System Namespace


Radix.ToString

Returns a String representation of a specified number in a specified counting system (base).

[Visual Basic]
Public Shared Function ToString( _
   ByVal value As Long, _
   ByVal radix As Integer _
) As String
[C#]
public static string ToString(
   long value,
   int radix
);
[C++]
public: static String* ToString(
   __int64 value,
   int radix
);
[JScript]
public static function ToString(
   value : long,
   radix : int
) : String;

Parameters

value
the value to be converted to a string
radix
the number of the counting system (base) to which value is to be converted

Remarks

For base 10, no prefix is printed. For base 16, "0x" is prefixed to the number, for base 8, a "0" is prefixed to the number. For all other bases "nn#" is prefixed to the number (where nn is the two digit base). The rest of the String returned is made up of characters representing the magnitude. The following characters are used in the representation: 0123456789abcdefghijklmnopqrstuvwxyz (note that uppercase characters are NOT returned). If the radix is N, the first N characters in the listing just mentioned may be used in the representation. For negative values, the negative is carried over into the string, except for base 16 and 8, which have well defined rules for dealing with negative values.

Value | Radix | String
10 | 12 | "12#a"
-10 | 16 | "0xfffffffffffffff6"
-10 | 9 | "-09#11"
16 | 16 | "0x10"
-2 | 8 | "01777777777777777777776"

See Also

Radix Class | Radix Members | System Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Radix Fields

The fields of the Radix class are listed below. For a complete list of Radix class members, see the Radix Members topic.

Public:

MaxRadix | The base of the smallest counting system supported in this radix conversion.
MinRadix | The base of the largest counting system supported in this radix conversion.

See Also

Radix Class | System Namespace


Radix.MaxRadix

The base of the smallest counting system supported in this radix conversion.

[Visual Basic]
Public Const MaxRadix As Integer
[C#]
public const int MaxRadix;
[C++]
public: const int MaxRadix;
[JScript]
public var MaxRadix : int;

See Also

Radix Class | Radix Members | System Namespace


Radix.MinRadix

The base of the largest counting system supported in this radix conversion.

[Visual Basic]
Public Const MinRadix As Integer
[C#]
public const int MinRadix;
[C++]
public: const int MinRadix;
[JScript]
public var MinRadix : int;

See Also

Radix Class | Radix Members | System Namespace


Random Class

Represents a pseudo-random-number generator, a device that meets certain statistical requirements and produces what is known as a sequence of pseudo-random numbers.

It generates numbers chosen with equal probability from a finite set of numbers. Because a mathematical algorithm is used, the numbers are not completely random but are sufficiently random for practical uses. The random number generation starts from a "seed." If the same seed is used repeatedly, the same series of numbers will be generated unless the seed is time-dependent, thereby producing a different series for each call.

Object
Random

[Visual Basic]
Public Class Random
[C#]
public class Random
[C++]
public __gc class Random
[JScript]
public class Random

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

Random Members | System Namespace


Random Members

Public:

Constructor

Random Constructor Overloaded. Initializes an instance of the Random class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Next | Overloaded. Returns a random number.
NextBytes | Fills a buffer with random bytes.
NextDouble | Returns a random number between 0.0 and 1.0.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
Sample | Returns a random number that is between 0 and 1.

See Also

Random Class | System Namespace


Random Constructor

Initializes an instance of the Random class.

Overload List

Initializes an instance of the random number generator, using the default seed, which is based on the date and time and will vary from call to call.

[Visual Basic] Overloads Public Sub New()
[C#] public Random();
[C++] public: Random();
[JScript] public function Random();

Initializes an instance of the random number generator, using the specified seed.

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public Random(int);
[C++] public: Random(int);
[JScript] public function Random(int);

See Also

Random Class | Random Members | System Namespace


Random Constructor ()

Initializes an instance of the random number generator, using the default seed, which is based on the date and time and will vary from call to call.

[Visual Basic]
Overloads Public Sub New()
[C#]
public Random();
[C++]
public: Random();
[JScript]
public function Random();

Remarks

The distribution of the generated numbers is uniform: each number is equally likely to be returned.

See Also

Random Class | Random Members | System Namespace | Random Constructor Overload List


Random Constructor (Int32)

Initializes an instance of the random number generator, using the specified seed.

[Visual Basic]
Overloads Public Sub New( _
   ByVal Seed As Integer _
)
[C#]
public Random(
   int Seed
);
[C++]
public: Random(
   int Seed
);
[JScript]
public function Random(
   Seed : int
);

Parameters

Seed
An integer used to vary the random results. An Int32 representation of the date or time is frequently used for this value.

Remarks

The distribution of the generated numbers is uniform: each number is equally likely to be returned.

See Also

Random Class | Random Members | System Namespace | Random Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Random Methods

The methods of the Random class are listed below. For a complete list of Random class members, see the Random Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Next | Overloaded. Returns a random number.
NextBytes | Fills a buffer with random bytes.
NextDouble | Returns a random number between 0.0 and 1.0.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
Sample | Returns a random number that is between 0 and 1.

See Also

Random Class | System Namespace


Random.Next

Returns a random number.

Overload List

Returns a positive random number less than the specified maximum.

[Visual Basic] Overloads Overridable Public Function Next(Integer) As Integer
[C#] public virtual int Next(int);
[C++] public: virtual int Next(int);
[JScript] public function Next(int) : int;

Returns a random number within a specified range.

[Visual Basic] Overloads Overridable Public Function Next(Integer, Integer) As Integer
[C#] public virtual int Next(int, int);
[C++] public: virtual int Next(int, int);
[JScript] public function Next(int, int) : int;

Returns a positive random number.

[Visual Basic] Overloads Overridable Public Function Next() As Integer
[C#] public virtual int Next();
[C++] public: virtual int Next();
[JScript] public function Next() : int;

See Also

Random Class | Random Members | System Namespace


Random.Next (Int32)

Returns a positive random number less than the specified maximum.

[Visual Basic]
Overloads Overridable Public Function Next( _
   ByVal maxValue As Integer _
) As Integer
[C#]
public virtual int Next(
   int maxValue
);
[C++]
public: virtual int Next(
   int maxValue
);
[JScript]
public function Next(
   maxValue : int
) : int;

Parameters

maxValue
The upper bound of the random number to be generated. maxValue must be an integer number greater than or equal to 0 and less than or equal to Int32.Max

Return Value

A number greater than or equal to 0 and less than maxValue.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | if maxValue is less than zero.

Remarks

The seed is adjusted as a side effect of this call. Successive calls to Next will yield different numbers.

See Also

Random Class | Random Members | System Namespace | Random.Next Overload List


Random.Next (Int32, Int32)

Returns a random number within a specified range.

[Visual Basic]
Overloads Overridable Public Function Next( _
   ByVal minValue As Integer, _
   ByVal maxValue As Integer _
) As Integer
[C#]
public virtual int Next(
   int minValue,
   int maxValue
);
[C++]
public: virtual int Next(
   int minValue,
   int maxValue
);
[JScript]
public function Next(
   minValue : int,
   maxValue : int
) : int;

Parameters

minValue
The lower bound of the random number to be generated. It can be any integer less than or equal to Int32.Max.
maxValue
The upper bound of the random number to be generated. It must be an integer number greater than or equal to minValue and less than or equal to Int32.Max.

Return Value

A number that is greater than or equal to minValue and less than maxValue. If minValue equals maxValue, minValue is returned.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | if minValue is greater than maxValue.

Remarks

The seed is adjusted as a side effect of this call. Multiple calls to Next will yield different numbers.

See Also

Random Class | Random Members | System Namespace | Random.Next Overload List


Random.Next ()

Returns a positive random number.

[Visual Basic]
Overloads Overridable Public Function Next() As Integer
[C#]
public virtual int Next();
[C++]
public: virtual int Next();
[JScript]
public function Next() : int;

Return Value

A number greater than or equal to 0 and less than Int32.MaxValue.

Remarks

The seed is adjusted as a side effect of this call. Multiple calls to Next will yield different numbers.

See Also

Random Class | Random Members | System Namespace | Random.Next Overload List


Random.NextBytes

Fills a buffer with random bytes.

[Visual Basic]
Overridable Public Sub NextBytes( _
   ByVal buffer() As Byte _
)
[C#]
public virtual void NextBytes(
   byte[] buffer
);
[C++]
public: virtual void NextBytes(
   unsigned char* buffer[]
);
[JScript]
public function NextBytes(
   buffer : Byte[]
);

Parameters

buffer
array to contain random numbers.

Exceptions

Exception Type | Condition
ArgumentNullException | if buffer is null.

Remarks

The seed is adjusted as a side effect of this call. That is, successive calls to NextBytes will yield different numbers.

Example

[C++]
Random *rnd = new Random ();
[managed] unsigned char b[] = new [managed] unsigned char[10];
rnd->NextBytes(b);
Console::WriteLine(L"The Random bytes are: ");
for (int i = 0; i < 10; i++) {
  Console::Write(i);
  Console::Write(L":
");

Console::WriteLine(b[i]);
  }

See Also

Random Class | Random Members | System Namespace


Random.NextDouble

Returns a random number between 0.0 and 1.0.

[Visual Basic]
Overridable Public Function NextDouble() As Double
[C#]
public virtual double NextDouble();
[C++]
public: virtual double NextDouble();
[JScript]
public function NextDouble() : double;

Return Value

A Double that is greater than or equal to 0.0 and less than 1.0.

Remarks

Each number is equally likely to be returned. The seed is adjusted as a side effect of this call. Successive calls to NextDouble will yield different numbers.

See Also

Random Class | Random Members | System Namespace


Random.Sample

Returns a random number that is between 0 and 1.

[Visual Basic]
Overridable Protected Function Sample() As Double
[C#]
protected virtual double Sample();
[C++]
protected: virtual double Sample();
[JScript]
protected function Sample() : double;

Return Value

An 8-byte double-precision number that is greater than or equal to 0.0 and less than 1.0. (0.0 < x < 1.0).

Exceptions

Exception Type | Condition
ArgumentNullException | if value is null.

Remarks

When you subclass Random, you can override this method to produce different distributions.

See Also

Random Class | Random Members | System Namespace


RankException Class

Represents the exception that is thrown when an array with the wrong number of dimensions is passed to a method.

Object
Exception
SystemException
RankException

[Visual Basic]
Public Class RankException
   Inherits SystemException
[C#]
public class RankException : SystemException
[C++]
public __gc class RankException : public SystemException
[JScript]
public class RankException extends SystemException

Remarks

The RankException is the exception class that is thrown when methods are passed arrays with the wrong numer od dimensions.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

RankException Members | System Namespace


RankException Members

Public:

Constructor

RankException Constructor Overloaded. Initializes an instance of the RankException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

RankException Class | System Namespace


RankException Constructor

Initializes an instance of the RankException class.

Overload List

Initializes an instance of the RankException with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public RankException();
[C++] public: RankException();
[JScript] public function RankException();

Initializes an instance of RankException with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public RankException(String);
[C++] public: RankException(String*);
[JScript] public function RankException(String);

Initializes an instance of RankException with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public RankException(String, Exception);
[C++] public: RankException(String*, Exception);
[JScript] public function RankException(String, Exception);

See Also

RankException Class | RankException Members | System Namespace


RankException Constructor ()

Initializes an instance of the RankException with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public RankException();
[C++]
public: RankException();
[JScript]
public function RankException();

Remarks

RankException inherits from the Exception class. This constructor sets the properties of the RankException object as follows:

Property Type | Condition
InnerException | null
Message | The empty string.

See Also

RankException Class | RankException Members | System Namespace | RankException Constructor Overload List


RankException Constructor (String)

Initializes an instance of RankException with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public RankException(
   string message
);
[C++]
public: RankException(
   String* message
);
[JScript]
public function RankException(
   message : String
);

Parameters

message
The message indicates the reason why the exception occurred.

Remarks

RankException inherits from the Exception class. This constructor sets the properties of the RankException object as follows:

Property Type | Condition
InnerException | null
Message | The message string.

See Also

RankException Class | RankException Members | System Namespace | RankException Constructor Overload List


RankException Constructor (String, Exception)

Initializes an instance of RankException with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public RankException(
   string message,
   Exception inner
);
[C++]
public: RankException(
   String* message,
   Exception* inner
);
[JScript]
public function RankException(
   message : String,
   inner : Exception
);

Parameters

message
The message indicates the reason the exception occurred.
inner
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

RankException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condtion
InnerException | The inner exception.
Message | The message string.

See Also

RankException Class | RankException Members | System Namespace | RankException Constructor Overload List


RuntimeArgumentHandle Structure

To be supplied.

Object
ValueType
RuntimeArgumentHandle

[Visual Basic]
Public Structure RuntimeArgumentHandle
[C#]
public struct RuntimeArgumentHandle
[C++]
public __value struct RuntimeArgumentHandle

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

RuntimeArgumentHandle Members | System Namespace


RuntimeArgumentHandle Members

Public:

Methods

Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RuntimeArgumentHandle Structure | System Namespace


RuntimeFieldHandle Structure

The RuntimeFieldHandle is a handle to the internal metadata representation of a field.

Object
ValueType
RuntimeFieldHandle

[Visual Basic]
Public Structure RuntimeFieldHandle
   Implements ISerializable
[C#]
public struct RuntimeFieldHandle : ISerializable
[C++]
public __value struct RuntimeFieldHandle : public ISerializable

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

RuntimeFieldHandle Members | System Namespace


RuntimeFieldHandle Members

Public:

Properties

Value The value of the handle.

Methods

Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetObjectData | Returns a SerializationInfo completely populated with all the data needed to reinstantiate the object at the other end of serialization.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RuntimeFieldHandle Structure | System Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RuntimeFieldHandle Properties

The properties of the RuntimeFieldHandle structure are listed below. For a complete list of RuntimeFieldHandle structure members, see the RuntimeFieldHandle Members topic.

Public:

Value The value of the handle.

See Also

RuntimeFieldHandle Structure | System Namespace


RuntimeFieldHandle.Value

The value of the handle.

[Visual Basic]
Public ReadOnly Property Value As Integer
[C#]
public int Value {get;}
[C++]
public: __property int get_Value();
[JScript]
public function get Value() : int;

Property Value

Read-only. Returns the value of the handle.

Exceptions

Exception Type | Condition
SerializationException | if the handle state is insufficient

See Also

RuntimeFieldHandle Structure | RuntimeFieldHandle Members | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RuntimeFieldHandle Methods

The methods of the RuntimeFieldHandle structure are listed below. For a complete list of RuntimeFieldHandle structure members, see the RuntimeFieldHandle Members topic.

Public:

Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetObjectData | Returns a SerializationInfo completely populated with all the data needed to reinstantiate the object at the other end of serialization.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RuntimeFieldHandle Structure | System Namespace


RuntimeFieldHandle.GetObjectData

Returns a SerializationInfo completely populated with all the data needed to reinstantiate the object at the other end of serialization.

[Visual Basic]
Overridable Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
public: virtual void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
);
[JScript]
public function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);

Parameters

info
The object to be populated with serialization information.
context
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentNullException | if info is a null reference (in Visual Basic Nothing)
SerializationException | if the handle is in an invalid state

See Also

RuntimeFieldHandle Structure | RuntimeFieldHandle Members | System Namespace


RuntimeMethodHandle Structure

The RuntimeMethodHandle is a handle to the internal metadata representation of a method.

Object
ValueType
RuntimeMethodHandle

[Visual Basic]
Public Structure RuntimeMethodHandle
   Implements ISerializable
[C#]
public struct RuntimeMethodHandle : ISerializable
[C++]
public __value struct RuntimeMethodHandle : public ISerializable

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

RuntimeMethodHandle Members | System Namespace


RuntimeMethodHandle Members

Public:

Properties

Value The value of the handle.

Methods

Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetObjectData | Returns a SerializationInfo completely populated with all the data needed to reinstantiate the object at the other end of serialization.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RuntimeMethodHandle Structure | System Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RuntimeMethodHandle Properties

The properties of the RuntimeMethodHandle structure are listed below. For a complete list of RuntimeMethodHandle structure members, see the RuntimeMethodHandle Members topic.

Public:

Value The value of the handle.

See Also

RuntimeMethodHandle Structure | System Namespace


RuntimeMethodHandle.Value

The value of the handle.

[Visual Basic]
Public ReadOnly Property Value As Integer
[C#]
public int Value {get;}
[C++]
public: __property int get_Value();
[JScript]
public function get Value() : int;

Property Value

Read-only. Returns the value of the handle.

Exceptions

Exception Type | Condition
SerializationException | if the handle state is insufficient

See Also

RuntimeMethodHandle Structure | RuntimeMethodHandle Members | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RuntimeMethodHandle Methods

The methods of the RuntimeMethodHandle structure are listed below. For a complete list of RuntimeMethodHandle structure members, see the RuntimeMethodHandle Members topic.

Public:

Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetObjectData | Returns a SerializationInfo completely populated with all the data needed to reinstantiate the object at the other end of serialization.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RuntimeMethodHandle Structure | System Namespace


RuntimeMethodHandle.GetObjectData

Returns a SerializationInfo completely populated with all the data needed to reinstantiate the object at the other end of serialization.

[Visual Basic]
Overridable Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
public: virtual void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
);
[JScript]
public function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);

Parameters

info
The object to be populated with serialization information.
context
The destination context of the serialization.

Exceptions

Exception Type | Condition
ArgumentNullException | if info is a null reference (in Visual Basic Nothing)
SerializationException | if the handle is in an invalid state

See Also

RuntimeMethodHandle Structure | RuntimeMethodHandle Members | System Namespace


RuntimeTypeHandle Structure

The RuntimeTypeHandle is a handle to the internal metadata representation of a type.

Object
ValueType
RuntimeTypeHandle

[Visual Basic]
Public Structure RuntimeTypeHandle
   Implements ISerializable
[C#]
public struct RuntimeTypeHandle : ISerializable
[C++]
public __value struct RuntimeTypeHandle : public ISerializable

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

RuntimeTypeHandle Members | System Namespace


RuntimeTypeHandle Members

Public:

Properties

Value The value of the handle.

Methods

Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetObjectData | Returns a SerializationInfo completely populated with all the data needed to reinstantiate the object at the other end of serialization.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RuntimeTypeHandle Structure | System Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RuntimeTypeHandle Properties

The properties of the RuntimeTypeHandle structure are listed below. For a complete list of RuntimeTypeHandle structure members, see the RuntimeTypeHandle Members topic.

Public:

Value The value of the handle.

See Also

RuntimeTypeHandle Structure | System Namespace


RuntimeTypeHandle.Value

The value of the handle.

[Visual Basic]
Public ReadOnly Property Value As Integer
[C#]
public int Value {get;}
[C++]
public: __property int get_Value();
[JScript]
public function get Value() : int;

Property Value

Read-only. Returns the value of the handle.

Exceptions

Exception Type | Condition
SerializationException | if the handle state is insufficient

See Also

RuntimeTypeHandle Structure | RuntimeTypeHandle Members | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RuntimeTypeHandle Methods

The methods of the RuntimeTypeHandle structure are listed below. For a complete list of RuntimeTypeHandle structure members, see the RuntimeTypeHandle Members topic.

Public:

Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetObjectData | Returns a SerializationInfo completely populated with all the data needed to reinstantiate the object at the other end of serialization.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RuntimeTypeHandle Structure | System Namespace


RuntimeTypeHandle.GetObjectData

Returns a SerializationInfo completely populated with all the data needed to reinstantiate the object at the other end of serialization.

[Visual Basic]
Overridable Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
public: virtual void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
);
[JScript]
public function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);

Parameters

info
The object to be populated with serialization information.
context
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentNullException | if info is a null reference (in Visual Basic Nothing)
SerializationException | if the handle is in an invalid state

See Also

RuntimeTypeHandle Structure | RuntimeTypeHandle Members | System Namespace


SByte Structure

Represents a 8-bit signed integer . The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

Object
ValueType
SByte

[C#]
public struct SByte : IComparable, IFormattable, IConvertible
[C++]
public __value struct SByte : public IComparable, IFormattable,
   IConvertible

[Visual Basic] The SByte type cannot be used in Visual Basic.

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks [C#, C++, JScript]

The SByte data type can represent positive and negative integers with 2 significant digits in the range negative 128 through positive 127, inclusive.

Requirements [C#, C++, JScript]

Namespace: System

Assembly: mscorlib.dll

See Also

SByte Members | System Namespace | IComparable | IFormattable | IConvertible | Byte


SByte Members

Public:

Methods

CompareTo | Compares this instance to the specified object, which must be either an SByte type or a null object reference.
Equals | Determines whether two SByte objects are equal.
Format | Overloaded. Converts a numeric value to a String.
FromString | Converts a String to an SByte.
GetHashCode | Returns the hash code for this SByte.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | Retrieves the type code of an object.
Parse | Overloaded. Converts a String to an SByte.
ToBoolean | [To be supplied.]
ToByte | [To be supplied.]
ToChar | [To be supplied.]
ToDateTime | [To be supplied.]
ToDecimal | [To be supplied.]
ToDouble | [To be supplied.]
ToInt16 | [To be supplied.]
ToInt32 | [To be supplied.]
ToInt64 | [To be supplied.]
ToSByte | [To be supplied.]
ToSingle | [To be supplied.]
ToString | Overloaded. Converts an SByte to a String.
ToType | [To be supplied.]
ToUInt16 | [To be supplied.]
ToUInt32 | [To be supplied.]
ToUInt64 | [To be supplied.]

Fields

Empty | Constant representing an empty SByte value.
MaxValue | Constant representing the largest possible SByte value.
MinValue | Constant representing the smallest possible SByte value.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SByte Structure | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SByte Methods

The methods of the SByte structure are listed below. For a complete list of SByte structure members, see the SByte Members topic.

Public:

CompareTo | Compares this instance to the specified object, which must be either an SByte type or a null object reference.
Equals | Determines whether two SByte objects are equal.
Format | Overloaded. Converts a numeric value to a String.
FromString | Converts a String to an SByte.
GetHashCode | Returns the hash code for this SByte.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | Retrieves the type code of an object.
Parse | Overloaded. Converts a String to an SByte.
ToBoolean | [To be supplied.]
ToByte | [To be supplied.]
ToChar | [To be supplied.]
ToDateTime | [To be supplied.]
ToDecimal | [To be supplied.]
ToDouble | [To be supplied.]
ToInt16 | [To be supplied.]
ToInt32 | [To be supplied.]
ToInt64 | [To be supplied.]
ToSByte | [To be supplied.]
ToSingle | [To be supplied.]
ToString | Overloaded. Converts an SByte to a String.
ToType | [To be supplied.]
ToUInt16 | [To be supplied.]
ToUInt32 | [To be supplied.]
ToUInt64 | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SByte Structure | System Namespace


SByte.CompareTo

Compares this instance to the specified object, which must be either an SByte type or a null object reference. The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public virtual int CompareTo(
   object obj
);
[C++]
public: virtual int CompareTo(
   Object* obj
);
[JScript]
public function CompareTo(
   obj : Object
) : int;

[Visual Basic] The SByte type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

obj
The object to compare with this object.

Return Value [C#, C++, JScript]

Value | Condition
A negative integer | If this instance is less than object.
Zero | If this instance and object have the same value.
A positive integer | If this instance is greater than object.
A positive integer | If object is null. This is a special case.

Exceptions [C#, C++, JScript]

Exception Type | Condition
ArgumentException | If the object is a non-null reference and is not of type SByte.

Remarks [C#, C++, JScript]

When comparing two SByte values, the canonical ordering is used. As a special case, an instance, regardless of its value, is considered to be greater than a null object reference.

The parameter object must be either an SByte type or a null reference.

See Also

SByte Structure | SByte Members | System Namespace | Int32


SByte.Equals

Determines whether two SByte objects are equal. The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

[Visual Basic] The SByte type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

obj
The object to compare with this instance.

Return Value [C#, C++, JScript]

true if obj is an SByte with the same byte value as this instance; otherwise, false.

Remarks [C#, C++, JScript]

Overrides Equals.

See Also

SByte Structure | SByte Members | System Namespace | Boolean


SByte.Format

Converts a numeric value to a String. The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[Visual Basic] The SByte type cannot be used in Visual Basic.

Overload List [C#, C++, JScript]

This method converts a numeric value to a String that is formatted using the specified format.

[C#] public virtual string Format(String, IServiceObjectProvider);
[C++] public: virtual String* Format(String*, IServiceObjectProvider);
[JScript] public function Format(String, IServiceObjectProvider) : String;

This method converts a numeric value to a String that is formatted using the specified number format.

[C#] public static string Format(sbyte, String, NumberFormatInfo);
[C++] public: static String* Format(char, String, NumberFormatInfo);
[JScript] public static function Format(SByte, String, NumberFormatInfo) : String;

Converts a numeric value to a formatted String.

[C#] public static string Format(sbyte, String);
[C++] public: static String* Format(char, String);
[JScript] public static function Format(SByte, String) : String;

See Also

SByte Structure | SByte Members | System Namespace


SByte.Format (String, IServiceObjectProvider)

This method converts a numeric value to a String that is formatted using the specified format. The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public virtual string Format(
   string format,
   IServiceObjectProvider sop
);
[C++]
public: virtual String* Format(
   String* format,
   IServiceObjectProvider* sop
);
[JScript]
public function Format(
   format : String,
   sop : IServiceObjectProvider
) : String;

[Visual Basic] The SByte type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

format
The format string.
sop
The IServiceObjectProvider used to format the number.

Return Value [C#, C++, JScript]

Returns a string representation for the value of this instance in the format specified by format.

Remarks [C#, C++, JScript]

If format is null or an empty string, the number is formatted as if the general format ("G") string were specified.

The sop parameter specifies the format provider from which the NumberFormatInfo instance will be obtained. If sop is null, the numeric format information is obtained from the current locale.

NumberFormatInfo supplies information such as the characters to use for decimal and thousand separators, and the spelling and placement of currency symbols in monetary values.

See Also

SByte Structure | SByte Members | System Namespace | SByte.Format Overload List | CultureInfo


SByte.Format (SByte, String, NumberFormatInfo)

This method converts a numeric value to a String that is formatted using the specified number format. The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public static string Format(
   sbyte value,
   string format,
   NumberFormatInfo info
);
[C++]
public: static String* Format(
   char value,
   String* format,
   NumberFormatInfo* info
);
[JScript]
public static function Format(
   value : SByte,
   format : String,
   info : NumberFormatInfo
) : String;

[Visual Basic] The SByte type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

value
The value to be formatted.
format
The format string.
info
The NumberFormatInfo instance used to format the number

Return Value [C#, C++, JScript]

Returns a string representation of value in the format specified by format.

Remarks [C#, C++, JScript]

If format is null or an empty string, value is formatted as if the general format ("G") string were specified.

The info parameters specifies the NumberFormatInfo instance used to format the number. If info is null, the numeric format information is obtained from the current locale (see CurrentCulture for more information on current locales).

The NumberFormatInfo supplies information such as the characters to use for decimal and thousand separators, and the spelling and placement of currency symbols in monetary values.

See Also

SByte Structure | SByte Members | System Namespace | SByte.Format Overload List | CultureInfo


SByte.Format (SByte, String)

Converts a numeric value to a formatted String. The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public static string Format(
   sbyte value,
   string format
);
[C++]
public: static String* Format(
   char value,
   String* format
);
[JScript]
public static function Format(
   value : SByte,
   format : String
) : String;

[Visual Basic] The SByte type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

value
The value to be formatted.
format
The format string.

Return Value [C#, C++, JScript]

Returns a string representation of value in the format specified by format.

Remarks [C#, C++, JScript]

If format is null or an empty string, value is formatted as if the general format ("G") string were specified. The numeric format information is obtained from the current locale (see CurrentCulture for more information on current locales).

See Also

SByte Structure | SByte Members | System Namespace | SByte.Format Overload List | CultureInfo | String


SByte.FromString

Converts a String to an SByte. The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public static sbyte FromString(
   string s
);
[C++]
public: static char FromString(
   String* s
);
[JScript]
public static function FromString(
   s : String
) : SByte;

[Visual Basic] The SByte type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

s
The string containing a number to convert.

Return Value [C#, C++, JScript]

Returns the SByte value of the string.

Exceptions [C#, C++, JScript]

Exception Type | Condition
ArgumentException | If s is a null reference (in Visual Basic Nothing).
FormatException | If s does not contain a real number.
OverflowException | If s is greater than 127 or less than-128.

Remarks [C#, C++, JScript]

The default (locale-neutral) NumberFormatInfo is used. Use Parse and Format for locale-dependent strings.

The output from ToString should be consumable by FromString.

See Also

SByte Structure | SByte Members | System Namespace | CultureInfo


SByte.GetHashCode

Returns the hash code for this SByte. The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

[Visual Basic] The SByte type cannot be used in Visual Basic.

Return Value [C#, C++, JScript]

The absolute value of SByte for this instance.

Remarks [C#, C++, JScript]

Overrides GetHashCode.

See Also

SByte Structure | SByte Members | System Namespace | Int32


SByte.GetTypeCode

Retrieves the type code of an object. The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public virtual TypeCode GetTypeCode();
[C++]
public: virtual TypeCode GetTypeCode();
[JScript]
public function GetTypeCode() : TypeCode;

[Visual Basic] The SByte type cannot be used in Visual Basic.

Return Value [C#, C++, JScript]

A type code.

Remarks [C#, C++, JScript]

The GetTypeCode method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See TypeCode enumeration for more information about type codes.)

See Also

SByte Structure | SByte Members | System Namespace | TypeCode


SByte.Parse

Converts a String to an SByte. The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[Visual Basic] The SByte type cannot be used in Visual Basic.

Overload List [C#, C++, JScript]

Converts a String to a formatted SByte.

[C#] public static sbyte Parse(String);
[C++] public: static char Parse(String*);
[JScript] public static function Parse(String) : SByte;

This method converts a String to an SByte in the style specified by NumberFormatInfo.

[C#] public static sbyte Parse(String, NumberStyles, NumberFormatInfo);
[C++] public: static char Parse(String*, NumberStyles, NumberFormatInfo);
[JScript] public static function Parse(String, NumberStyles, NumberFormatInfo) : SByte;

Converts a String to an SByte in the specified style.

[C#] public static sbyte Parse(String, NumberStyles);
[C++] public: static char Parse(String*, NumberStyles);
[JScript] public static function Parse(String, NumberStyles) : SByte;

See Also

SByte Structure | SByte Members | System Namespace


SByte.Parse (String)

Converts a String to a formatted SByte. The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public static sbyte Parse(
   string s
);
[C++]
public: static char Parse(
   String* s
);
[JScript]
public static function Parse(
   s : String
) : SByte;

[Visual Basic] The SByte type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

s
The string to convert to an SByte.

Return Value [C#, C++, JScript]

Returns the byte representation of s.

Exceptions [C#, C++, JScript]

Exception Type | Condition
ArgumentException | If s is a null reference (in Visual Basic Nothing).
FormatException | If s does not consist of an optional minus sign followed by a sequence of digits ("0"- "9").
OverflowException | If s represents a number that is less than SByte.MinValue or greater than SByte.MaxValue.

Remarks [C#, C++, JScript]

Leading and trailing white space characters are ignored.

See Also

SByte Structure | SByte Members | System Namespace | SByte.Parse Overload List | String | MaxValue | MinValue


SByte.Parse (String, NumberStyles, NumberFormatInfo)

This method converts a String to an SByte in the style specified by NumberFormatInfo. The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public static sbyte Parse(
   string s,
   NumberStyles style,
   NumberFormatInfo info
);
[C++]
public: static char Parse(
   String* s,
   NumberStyles style,
   NumberFormatInfo* info
);
[JScript]
public static function Parse(
   s : String,
   style : NumberStyles,
   info : NumberFormatInfo
) : SByte;

[Visual Basic] The SByte type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

s
The string to be interpreted.
style
The permitted style of the numeric string.
info
The NumberFormatInfo instance used to format the string.

Return Value [C#, C++, JScript]

Returns an SByte with the value represented by s.

Exceptions [C#, C++, JScript]

Exception Type | Condition
ArgumentNullException | If s is a null reference (in Visual Basic Nothing).
ArgumentException | If style is not a combination of bit flags from the NumberStyles enumeration.
FormatException | If s is not of the correct format.
OverflowException | If s represents a number that is less than SByte.MinValue or greater than SByte.MaxValue.

Remarks [C#, C++, JScript]

The style parameter must be a combination of bit flags from the NumberStyles enumeration.

If the info parameter is null the numeric format information is obtained from the current locale (see NumberFormatInfo and CultureInfo for number and culture specific formatting).

If s has been created by one of the Format methods using C, D, E, F, G, or N as the format specifier, it is guaranteed that s can be parsed when style is NumberStyles enumeration.

Note The Parse methods do not accept not a number (NaN), or positive or negative infinity.

See Also

SByte Structure | SByte Members | System Namespace | SByte.Parse Overload List | String | NumberFormatInfo | NaN | NaN | PositiveInfinity | PositiveInfinity | NegativeInfinity | NegativeInfinity


SByte.Parse (String, NumberStyles)

Converts a String to an SByte in the specified style. The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public static sbyte Parse(
   string s,
   NumberStyles style
);
[C++]
public: static char Parse(
   String* s,
   NumberStyles style
);
[JScript]
public static function Parse(
   s : String,
   style : NumberStyles
) : SByte;

[Visual Basic] The SByte type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

s
The string to be interpreted.
style
The permitted style of the numeric string.

Return Value [C#, C++, JScript]

Returns an SByte with the value represented by s.

Exceptions [C#, C++, JScript]

Exception Type | Condition
ArgumentNullException | If s is a null reference (in Visual Basic Nothing).
ArgumentException | If style is not a combination of bit flags from the NumberStyles enumeration.
FormatException | If s is not of the correct format.
OverflowException | If s represents a number that is less than SByte.MinValue or greater than SByte.MaxValue.

Remarks [C#, C++, JScript]

The numeric format information is obtained from the current locale (see NumberFormatInfo and CultureInfo for number and culture specific formatting).

If s has been created by one of the Format methods using C, D, E, F, G, or N as the format specifier, it is guaranteed that s can be parsed when style is NumberStyles enumeration .

Note The SByte.Parse methods do not accept not a number (NaN), or positive or negative infinity.

The style parameter must be a combination of bit flags from the NumberStyles enumeration.

See Also

SByte Structure | SByte Members | System Namespace | SByte.Parse Overload List | NaN | NaN | String | MinValue | MaxValue | PositiveInfinity | PositiveInfinity | NegativeInfinity | NegativeInfinity


SByte.ToBoolean

[To be supplied.] The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public virtual bool ToBoolean();
[C++]
public: virtual bool ToBoolean();
[JScript]
public function ToBoolean() : Boolean;

[Visual Basic] The SByte type cannot be used in Visual Basic.

See Also

SByte Structure | SByte Members | System Namespace


SByte.ToByte

[To be supplied.] The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public virtual byte ToByte();
[C++]
public: virtual unsigned char ToByte();
[JScript]
public function ToByte() : Byte;

[Visual Basic] The SByte type cannot be used in Visual Basic.

See Also

SByte Structure | SByte Members | System Namespace


SByte.ToChar

[To be supplied.] The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public virtual char ToChar();
[C++]
public: virtual __wchar_t ToChar();
[JScript]
public function ToChar() : Char;

[Visual Basic] The SByte type cannot be used in Visual Basic.

See Also

SByte Structure | SByte Members | System Namespace


SByte.ToDateTime

[To be supplied.] The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public virtual DateTime ToDateTime();
[C++]
public: virtual DateTime ToDateTime();
[JScript]
public function ToDateTime() : DateTime;

[Visual Basic] The SByte type cannot be used in Visual Basic.

See Also

SByte Structure | SByte Members | System Namespace


SByte.ToDecimal

[To be supplied.] The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public virtual Decimal ToDecimal();
[C++]
public: virtual Decimal ToDecimal();
[JScript]
public function ToDecimal() : Decimal;

[Visual Basic] The SByte type cannot be used in Visual Basic.

See Also

SByte Structure | SByte Members | System Namespace


SByte.ToDouble

[To be supplied.] The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public virtual double ToDouble();
[C++]
public: virtual double ToDouble();
[JScript]
public function ToDouble() : double;

[Visual Basic] The SByte type cannot be used in Visual Basic.

See Also

SByte Structure | SByte Members | System Namespace


SByte.ToInt16

[To be supplied.] The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public virtual short ToInt16();
[C++]
public: virtual short ToInt16();
[JScript]
public function ToInt16() : Int16;

[Visual Basic] The SByte type cannot be used in Visual Basic.

See Also

SByte Structure | SByte Members | System Namespace


SByte.ToInt32

[To be supplied.] The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public virtual int ToInt32();
[C++]
public: virtual int ToInt32();
[JScript]
public function ToInt32() : int;

[Visual Basic] The SByte type cannot be used in Visual Basic.

See Also

SByte Structure | SByte Members | System Namespace


SByte.ToInt64

[To be supplied.] The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public virtual long ToInt64();
[C++]
public: virtual __int64 ToInt64();
[JScript]
public function ToInt64() : long;

[Visual Basic] The SByte type cannot be used in Visual Basic.

See Also

SByte Structure | SByte Members | System Namespace


SByte.ToSByte

[To be supplied.] The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public virtual sbyte ToSByte();
[C++]
public: virtual char ToSByte();
[JScript]
public function ToSByte() : SByte;

[Visual Basic] The SByte type cannot be used in Visual Basic.

See Also

SByte Structure | SByte Members | System Namespace


SByte.ToSingle

[To be supplied.] The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public virtual float ToSingle();
[C++]
public: virtual float ToSingle();
[JScript]
public function ToSingle() : float;

[Visual Basic] The SByte type cannot be used in Visual Basic.

See Also

SByte Structure | SByte Members | System Namespace


SByte.ToString

Converts an SByte to a String. The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[Visual Basic] The SByte type cannot be used in Visual Basic.

Overload List [C#, C++, JScript]

Converts a specified SByte to a String.

[C#] public static string ToString(sbyte);
[C++] public: static String* ToString(char);
[JScript] public static function ToString(SByte) : String;

Converts this instance of SByte to a String.

[C#] public override string ToString();
[C++] public: override String* ToString();
[JScript] public override function ToString() : String;

See Also

SByte Structure | SByte Members | System Namespace


SByte.ToString (SByte)

Converts a specified SByte to a String. The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public static string ToString(
   sbyte value
);
[C++]
public: static String* ToString(
   char value
);
[JScript]
public static function ToString(
   value : SByte
) : String;

[Visual Basic] The SByte type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

value
The byte for which to provide a string representation.

Return Value [C#, C++, JScript]

A string value in base-10 without extra padding.

Remarks [C#, C++, JScript]

If value parameter is negative, the first character in the string returned will be '-'. No sign character is returned if the number is zero or positive.

The rest of the string returned is made up of characters representing the magnitude of value. No leading zero characters ('0') are prepended to the returned string.

The following characters are used as digits: 0, 1, 2, 3, 4, 5, 6, 7, 8, or 9.

The output from ToString should be consumable by FromString.

See Also

SByte Structure | SByte Members | System Namespace | SByte.ToString Overload List | String


SByte.ToString ()

Converts this instance of SByte to a String. The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

[Visual Basic] The SByte type cannot be used in Visual Basic.

Return Value [C#, C++, JScript]

Returns the result of converting this SByte to a string in base 10 without extra padding.

Remarks [C#, C++, JScript]

If the byte value for this instance is negative, the first character in the string returned will be '-'. No sign character is returned if the number is zero or positive.

The rest of the string returned is made up of characters representing the magnitude of this instance. No leading zero characters ('0') are prepended to the returned string.

The following characters are used as digits: 0, 1, 2, 3, 4, 5, 6, 7, 8, or 9.

The output from ToString should be consumable by FromString.

Overrides ToString.

See Also

SByte Structure | SByte Members | System Namespace | SByte.ToString Overload List | String


SByte.ToType

[To be supplied.] The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public virtual object ToType(
   Type type
);
[C++]
public: virtual Object* ToType(
   Type* type
);
[JScript]
public function ToType(
   type : Type
) : Object;

[Visual Basic] The SByte type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

type
[To be supplied.]

See Also

SByte Structure | SByte Members | System Namespace


SByte.ToUInt16

[To be supplied.] The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public virtual ushort ToUInt16();
[C++]
public: virtual unsigned short ToUInt16();
[JScript]
public function ToUInt16() : UInt16;

[Visual Basic] The SByte type cannot be used in Visual Basic.

See Also

SByte Structure | SByte Members | System Namespace


SByte.ToUInt32

[To be supplied.] The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public virtual uint ToUInt32();
[C++]
public: virtual unsigned int ToUInt32();
[JScript]
public function ToUInt32() : UInt32;

[Visual Basic] The SByte type cannot be used in Visual Basic.

See Also

SByte Structure | SByte Members | System Namespace


SByte.ToUInt64

[To be supplied.] The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public virtual ulong ToUInt64();
[C++]
public: virtual unsigned __int64 ToUInt64();
[JScript]
public function ToUInt64() : UInt64;

[Visual Basic] The SByte type cannot be used in Visual Basic.

See Also

SByte Structure | SByte Members | System Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SByte Fields

The fields of the SByte structure are listed below. For a complete list of SByte structure members, see the SByte Members topic.

Public:

Empty | Constant representing an empty SByte value.
MaxValue | Constant representing the largest possible SByte value.
MinValue | Constant representing the smallest possible SByte value.

See Also

SByte Structure | System Namespace


SByte.Empty

Constant representing an empty SByte value. The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public const sbyte Empty;
[C++]
public: const char Empty;
[JScript]
public var Empty : SByte;

[Visual Basic] The SByte type cannot be used in Visual Basic.

Remarks [C#, C++, JScript]

The SByte.Empty hexadecimal value is 0x0.

See Also

SByte Structure | SByte Members | System Namespace | Empty


SByte.MaxValue

Constant representing the largest possible SByte value. The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public const sbyte MaxValue;
[C++]
public: const char MaxValue;
[JScript]
public var MaxValue : SByte;

[Visual Basic] The SByte type cannot be used in Visual Basic.

Remarks [C#, C++, JScript]

The SByte.MaxValue hexidecimal value is 0x7F.

See Also

SByte Structure | SByte Members | System Namespace


SByte.MinValue

Constant representing the smallest possible SByte value. The SByte type is not CLS compliant. The CLS-compliant alternative is Byte.

[C#]
public const sbyte MinValue;
[C++]
public: const char MinValue;
[JScript]
public var MinValue : SByte;

[Visual Basic] The SByte type cannot be used in Visual Basic.

Remarks [C#, C++, JScript]

The SByte.MinValue hexidecimal value is 0x80.

See Also

SByte Structure | SByte Members | System Namespace


SerializableAttribute Class

[To be supplied.]

Object
Attribute
SerializableAttribute

[Visual Basic]
Public Class SerializableAttribute
   Inherits Attribute
[C#]
public class SerializableAttribute : Attribute
[C++]
public __gc class SerializableAttribute : public Attribute
[JScript]
public class SerializableAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

SerializableAttribute Members | System Namespace


SerializableAttribute Members

Public:

Constructor

SerializableAttribute Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SerializableAttribute Class | System Namespace


SerializableAttribute Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public SerializableAttribute();
[C++]
public: SerializableAttribute();
[JScript]
public function SerializableAttribute();

See Also

SerializableAttribute Class | SerializableAttribute Members | System Namespace


Single Structure

Represents a four-byte, single precision, floating point number.

Object
ValueType
Single

[Visual Basic]
Public Structure Single
   Implements IComparable, IFormattable, IConvertible
[C#]
public struct Single : IComparable, IFormattable, IConvertible
[C++]
public __value struct Single : public IComparable, IFormattable,
   IConvertible

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

Single is a value type that can represent numbers in the range negative 3.402823E38 through positive 3.402823E38, inclusive. The Single type represents single precision 32-bit IEEE 754 value. The Common Language Specification (CLS) supports primitive types, including Single.

This class provides some basic coercions:

  • From a Single to various formats of String and the other way around, and
  • From a Single to the other base data types (Double and Object).

These widening coercions result in no loss in precision of magnitude. Note that programming languages are free to provide coercions that extend or differ from these.

Single provides methods for dealing with PositiveInfinity and NegativeInfinity and expressions that evaluate to not a number (NaN).

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

Single Members | System Namespace | IComparable | IFormattable | IConvertible


Single Members

Public:

Methods

CompareTo | Compares this instance to specified Object.
Equals | Compares this instance with a specified Object.
Format | Overloaded. Converts a numeric value to a String.
FromString | Converts a String to a float.
GetHashCode | Returns the hash code for this Single.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | [To be supplied.]
IsInfinity | Returns a Boolean that indicates whether the specified object represents negative or positive infinity.
IsNaN | Determines whether the specified object is not a number (NaN).
IsNegativeInfinity | Determines whether the specified object represents negative infinity.
IsPositiveInfinity | Determines whether the specified object represents positive infinity.
Parse | Overloaded. Converts a String to a Single.
ToBoolean | [To be supplied.]
ToByte | [To be supplied.]
ToChar | [To be supplied.]
ToDateTime | [To be supplied.]
ToDecimal | [To be supplied.]
ToDouble | [To be supplied.]
ToInt16 | [To be supplied.]
ToInt32 | [To be supplied.]
ToInt64 | [To be supplied.]
ToSByte | [To be supplied.]
ToSingle | [To be supplied.]
ToString | Overloaded. Converts a Single to a String.
ToType | [To be supplied.]
ToUInt16 | [To be supplied.]
ToUInt32 | [To be supplied.]
ToUInt64 | [To be supplied.]

Fields

Empty | Represents the constant value that is the empty Single.
Epsilon | Represents the constant that is the closest positive number, but not less than, to zero.
MaxValue | Constant representing the largest possible Single value.
MinValue | Represents the constant that is the smallest possible Single value.
NaN | Represents the constant that is the value of not a number (NaN).
NegativeInfinity | Represents the constant that is the value of negative infinity.
PositiveInfinity | Represents the constant that is the value of positive infinity.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Single Structure | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Single Methods

The methods of the Single structure are listed below. For a complete list of Single structure members, see the Single Members topic.

Public:

CompareTo | Compares this instance to specified Object.
Equals | Compares this instance with a specified Object.
Format | Overloaded. Converts a numeric value to a String.
FromString | Converts a String to a float.
GetHashCode | Returns the hash code for this Single.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | [To be supplied.]
IsInfinity | Returns a Boolean that indicates whether the specified object represents negative or positive infinity.
IsNaN | Determines whether the specified object is not a number (NaN).
IsNegativeInfinity | Determines whether the specified object represents negative infinity.
IsPositiveInfinity | Determines whether the specified object represents positive infinity.
Parse | Overloaded. Converts a String to a Single.
ToBoolean | [To be supplied.]
ToByte | [To be supplied.]
ToChar | [To be supplied.]
ToDateTime | [To be supplied.]
ToDecimal | [To be supplied.]
ToDouble | [To be supplied.]
ToInt16 | [To be supplied.]
ToInt32 | [To be supplied.]
ToInt64 | [To be supplied.]
ToSByte | [To be supplied.]
ToSingle | [To be supplied.]
ToString | Overloaded. Converts a Single to a String.
ToType | [To be supplied.]
ToUInt16 | [To be supplied.]
ToUInt32 | [To be supplied.]
ToUInt64 | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Single Structure | System Namespace


Single.CompareTo

Compares this instance to specified Object.

[Visual Basic]
Overridable Public Function CompareTo( _
   ByVal value As Object _
) As Integer
[C#]
public virtual int CompareTo(
   object value
);
[C++]
public: virtual int CompareTo(
   Object* value
);
[JScript]
public function CompareTo(
   value : Object
) : int;

Parameters

value
The object to compare with this instance.

Return Value

Value | Description
A negative integer | If this instance is less than the object.
Zero | If this instance and the object are equal.
A positive integer | If this instance is greater than the object.
A positive integer | If the object is a null reference (in Visual Basic Nothing). This is a special case.

Exceptions

Exception Type | Condition
ArgumentException | If the object is a non-null reference and is not a Single.

Remarks

When comparing two Single values, the canonical ordering is used. As a special case, an instance, regardless of its value, is considered to be greater than a null object reference. If at least one of the objects to be compared is not a number (NaN), negative one will be returned; if both objects are NaN, one is returned.

The value parameter must be a Single type and a null object reference.

See Also

Single Structure | Single Members | System Namespace


Single.Equals

Compares this instance with a specified Object.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The specified object to compare with this instance.

Return Value

true if the object is a Single and equals the specified Object; otherwise, false.

Remarks

The Equals method is a way of determining object equality. It only returns true if the object is a Single and has the same value as the current instance. It compares two object references to determine their equality in three things: value, type, and numbers. If the object and this Single instance are:

  • Single types, true is returned, otherwise false.
  • Equal value, true is returned, otherwise false.
  • Not a number, false is returned.

Note that false will be returned if NaN. Not a number (NaN) should never be used for comparing.

Overrides Equals.

See Also

Single Structure | Single Members | System Namespace


Single.Format

Converts a numeric value to a String.

Overload List

Converts a numeric value to a String with specified format string.

[Visual Basic] Overloads Public Shared Function Format(Single, String) As String
[C#] public static string Format(float, String);
[C++] public: static String* Format(float, String);
[JScript] public static function Format(float, String) : String;

This method converts a numeric value to a String with the specified format string provided by IServiceObjectProvider.

[Visual Basic] Overloads Overridable Public Function Format(String, IServiceObjectProvider) As String
[C#] public virtual string Format(String, IServiceObjectProvider);
[C++] public: virtual String* Format(String*, IServiceObjectProvider);
[JScript] public function Format(String, IServiceObjectProvider) : String;

This method converts a numeric value to a String with the specified format string provided by NumberFormatInfo.

[Visual Basic] Overloads Public Shared Function Format(Single, String, NumberFormatInfo) As String
[C#] public static string Format(float, String, NumberFormatInfo);
[C++] public: static String* Format(float, String, NumberFormatInfo);
[JScript] public static function Format(float, String, NumberFormatInfo) : String;

See Also

Single Structure | Single Members | System Namespace


Single.Format (Single, String)

Converts a numeric value to a String with specified format string.

[Visual Basic]
Overloads Public Shared Function Format( _
   ByVal value As Single, _
   ByVal format As String _
) As String
[C#]
public static string Format(
   float value,
   string format
);
[C++]
public: static String* Format(
   float value,
   String* format
);
[JScript]
public static function Format(
   value : float,
   format : String
) : String;

Parameters

value
The value to be formatted.
format
The format string.

Return Value

Returns a string representation of the number in the specified format.

Remarks

If format is null or an empty string, value is formatted as if the string general format ("G") were specified.

The numeric format information is obtained from the current locale (in addition see CurrentCulture).

The numeric format information is obtained from the current locale (for more information on numeric formats, see NumberFormatInfo). Various cultures have unquie numberic and currency formating, such as Portugese, Kazakh, or Farsi (for addition information on cultures, see CultureInfo).

See Also

Single Structure | Single Members | System Namespace | Single.Format Overload List | CultureInfo | NumberFormatInfo | String


Single.Format (String, IServiceObjectProvider)

This method converts a numeric value to a String with the specified format string provided by IServiceObjectProvider.

[Visual Basic]
Overloads Overridable Public Function Format( _
   ByVal format As String, _
   ByVal sop As IServiceObjectProvider _
) As String
[C#]
public virtual string Format(
   string format,
   IServiceObjectProvider sop
);
[C++]
public: virtual String* Format(
   String* format,
   IServiceObjectProvider* sop
);
[JScript]
public function Format(
   format : String,
   sop : IServiceObjectProvider
) : String;

Parameters

format
The format string.
sop
The IServiceObjectProvider used to format the number.

Return Value

A string representation of the number in this instance in the specified format.

Remarks

If format is null or an empty string, the number is formatted as if the general format ("G") string were specified.

The sop parameter specifies the format provider from which the NumberFormatInfo instance will be obtained. NumberFormatInfo supplies information such as the characters to use for decimal and thousand separators, and the spelling and placement of currency symbols in monetary values. (For more information about culture specific information, see System.Globalization namespace.)

If sop is null, the numeric format information is obtained from the current locale (in addition see CultureInfo).

The numeric format information is obtained from the current locale (for more information on numeric formats, see NumberFormatInfo). Various cultures have unquie numberic and currency formating, such as Portugese, Kazakh, or Farsi (for addition information on cultures, see CultureInfo).

See Also

Single Structure | Single Members | System Namespace | Single.Format Overload List | CurrentCulture | NumberFormatInfo | String | IServiceObjectProvider


Single.Format (Single, String, NumberFormatInfo)

This method converts a numeric value to a String with the specified format string provided by NumberFormatInfo.

[Visual Basic]
Overloads Public Shared Function Format( _
   ByVal value As Single, _
   ByVal format As String, _
   ByVal info As NumberFormatInfo _
) As String
[C#]
public static string Format(
   float value,
   string format,
   NumberFormatInfo info
);
[C++]
public: static String* Format(
   float value,
   String* format,
   NumberFormatInfo* info
);
[JScript]
public static function Format(
   value : float,
   format : String,
   info : NumberFormatInfo
) : String;

Parameters

value
The value to be formatted.
format
The format string.
info
The NumberFormatInfo instance used to format the number.

Return Value

A string representation of the number in the specified format.

Remarks

The numeric format information is obtained from the current locale (for more information on numeric formats, see NumberFormatInfo). Various cultures have unquie numberic and currency formating, such as Portugese, Kazakh, or Farsi (for addition information on cultures, see CultureInfo).

See Also

Single Structure | Single Members | System Namespace | Single.Format Overload List | NumberFormatInfo | CultureInfo | String


Single.FromString

Converts a String to a float.

[Visual Basic]
Public Shared Function FromString( _
   ByVal s As String _
) As Single
[C#]
public static float FromString(
   string s
);
[C++]
public: static float FromString(
   String* s
);
[JScript]
public static function FromString(
   s : String
) : float;

Parameters

s
The string containing a number to convert.

Return Value

Returns the Single value of the string.

Exceptions

Exception Type | Condition
ArgumentException | If the string is a null reference (in Visual Basic Nothing).
FormatException | If the string does not contain a real number.

Remarks

The default (locale-neutral) NumberFormatInfo is used. Use Parse and Format for locale dependent strings. (In addition see CultureInfo.)

The FromString method does not throw a FormatException if the string is not a number (see NaN); it returns NaN instead. Nor does it throw an OverflowException; it returns PositiveInfinity or NegativeInfinity if the number is too large or too small.

The output from ToString should be consumable by FromString().

See Also

Single Structure | Single Members | System Namespace | Parse


Single.GetHashCode

Returns the hash code for this Single.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

Returns a hash code for this instance.

Remarks

The hash code is the absolute value of the value that this Single represents.

See Also

Single Structure | Single Members | System Namespace | IHashCodeProvider


Single.GetTypeCode

[To be supplied.]

[Visual Basic]
Overridable Public Function GetTypeCode() As TypeCode
[C#]
public virtual TypeCode GetTypeCode();
[C++]
public: virtual TypeCode GetTypeCode();
[JScript]
public function GetTypeCode() : TypeCode;

See Also

Single Structure | Single Members | System Namespace


Single.IsInfinity

Returns a Boolean that indicates whether the specified object represents negative or positive infinity.

[Visual Basic]
Public Shared Function IsInfinity( _
   ByVal f As Single _
) As Boolean
[C#]
public static bool IsInfinity(
   float f
);
[C++]
public: static bool IsInfinity(
   float f
);
[JScript]
public static function IsInfinity(
   f : float
) : Boolean;

Parameters

f
The object to examine.

Return Value

true if this instance represents negative or positive infinity; otherwise, false.

Remarks

The IsInfinity method is equivalent to IsNegativeInfinity or IsPositiveInfinity.

See Also

Single Structure | Single Members | System Namespace | System.Globalization,.CultureInfo | System.Globalization,.NumberFormatInfo | PositiveInfinity | NegativeInfinity | NaN


Single.IsNaN

Determines whether the specified object is not a number (NaN).

[Visual Basic]
Public Shared Function IsNaN( _
   ByVal f As Single _
) As Boolean
[C#]
public static bool IsNaN(
   float f
);
[C++]
public: static bool IsNaN(
   float f
);
[JScript]
public static function IsNaN(
   f : float
) : Boolean;

Parameters

f
The object to examine.

Return Value

true if the object is not a number; otherwise, false.

Remarks

The default value of NaN is zero.

See Also

Single Structure | Single Members | System Namespace | CultureInfo | NumberFormatInfo | IsInfinity | IsNegativeInfinity | PositiveInfinity | NegativeInfinity | NaN


Single.IsNegativeInfinity

Determines whether the specified object represents negative infinity.

[Visual Basic]
Public Shared Function IsNegativeInfinity( _
   ByVal f As Single _
) As Boolean
[C#]
public static bool IsNegativeInfinity(
   float f
);
[C++]
public: static bool IsNegativeInfinity(
   float f
);
[JScript]
public static function IsNegativeInfinity(
   f : float
) : Boolean;

Parameters

f
The object to examine.

Return Value

true if the object represents negative infinity, otherwise false.

Remarks

The IsNegativeInfinity method is equivalent to NegativeInfinity.

In addition see CultureInfo, NumberFormatInfo, IsInfinity, IsPositiveInfinity, PositiveInfinity, IsNaN, and NaN.

See Also

Single Structure | Single Members | System Namespace


Single.IsPositiveInfinity

Determines whether the specified object represents positive infinity.

[Visual Basic]
Public Shared Function IsPositiveInfinity( _
   ByVal f As Single _
) As Boolean
[C#]
public static bool IsPositiveInfinity(
   float f
);
[C++]
public: static bool IsPositiveInfinity(
   float f
);
[JScript]
public static function IsPositiveInfinity(
   f : float
) : Boolean;

Parameters

f
The object to examine.

Return Value

true if the object represents positive infinity; otherwise, false.

Remarks

IsPositiveInfinity is equivalent to PositiveInfinity.

See Also

Single Structure | Single Members | System Namespace | System,.CultureInfo | System,.NumberFormatInfo | System.Single,.IsInfinity | System.Single,.IsNegativeInfinity | System.Single,.], IsNaN


Single.Parse

Converts a String to a Single.

Overload List

Converts a String to a Single with the default format.

[Visual Basic] Overloads Public Shared Function Parse(String) As Single
[C#] public static float Parse(String);
[C++] public: static float Parse(String*);
[JScript] public static function Parse(String) : float;

This method converts a String to a numeric value.

[Visual Basic] Overloads Public Shared Function Parse(String, NumberStyles) As Single
[C#] public static float Parse(String, NumberStyles);
[C++] public: static float Parse(String*, NumberStyles);
[JScript] public static function Parse(String, NumberStyles) : float;

This method converts a String to a numeric value in the specified style using the formatting information.

[Visual Basic] Overloads Public Shared Function Parse(String, NumberStyles, NumberFormatInfo) As Single
[C#] public static float Parse(String, NumberStyles, NumberFormatInfo);
[C++] public: static float Parse(String*, NumberStyles, NumberFormatInfo);
[JScript] public static function Parse(String, NumberStyles, NumberFormatInfo) : float;

See Also

Single Structure | Single Members | System Namespace


Single.Parse (String)

Converts a String to a Single with the default format.

[Visual Basic]
Overloads Public Shared Function Parse( _
   ByVal s As String _
) As Single
[C#]
public static float Parse(
   string s
);
[C++]
public: static float Parse(
   String* s
);
[JScript]
public static function Parse(
   s : String
) : float;

Parameters

s
A string that represents a floating point number to be converted to a Single.

Return Value

Returns the Single value of the string parameter.

Exceptions

Exception Type | Condition
ArgumentNullException | If the string is a null reference (in Visual Basic Nothing).
FormatException | If the string is not a real number.

Remarks

It is not acceptable for the s parameter to contain the expressions of "123.12 e5" and "123.12e 5".

The s parameter should match one of the following regular expressions:

  • [+-]? [0-9]* . [0-9]+
  • [+-]? [0-9]+ .
  • [+-]? [0-9]* . [0-9]+ [e E] +[0-9]+
  • [+-]? [0-9]* . [0-9]+ [e E] [0-9]+
  • [+-]? [0-9]* . [0-9]+ [e E]-[0-9]+
  • [+-]? [0-9]+ [e E]-[0-9]+
  • [+-]? [0-9]+ [e E] +[0-9]+
  • [+-]? [0-9]+ [e E] [0-9]+
  • [+ -]? Infinity

Leading and trailing white space characters are ignored.

The Parse method does not throw a FormatException if the string is not a number (see NaN); it returns NaN instead. Nor does it throw an OverflowException; it returns PositiveInfinity or NegativeInfinity if the number is too large or too small.

See Also

Single Structure | Single Members | System Namespace | Single.Parse Overload List | FromString | ToString


Single.Parse (String, NumberStyles)

This method converts a String to a numeric value.

[Visual Basic]
Overloads Public Shared Function Parse( _
   ByVal s As String, _
   ByVal style As NumberStyles _
) As Single
[C#]
public static float Parse(
   string s,
   NumberStyles style
);
[C++]
public: static float Parse(
   String* s,
   NumberStyles style
);
[JScript]
public static function Parse(
   s : String,
   style : NumberStyles
) : float;

Parameters

s
The string to be interpreted.
style
The permitted s pecifiedstyle of the numeric string. It must be a combination of bit flags from the NumberStyles enumeration.

Return Value

A Single value represented by the string parameter.

Exceptions

Exception Type | Condition
ArgumentNullException | If the string is a null reference (in Visual Basic Nothing).
ArgumentException | If the style is not a combination of bit flags from the NumberStyles enumeration.
FormatException | If the string is not the correct format.
OverflowException | If the string represents a number that is less than Single.MinValue or greater than Single.MaxValue.

Remarks

The numeric format information is obtained from the current locale.

If s has been created by one of the Format methods using C, D, E, F, G, or N as the format specifier, it is guaranteed that s can be parsed when style is NumberStyles enumeration.

The Parse method does not throw a FormatException if the string is not a number (see NaN); it returns NaN instead. Nor does it throw an OverflowException; it returns PositiveInfinity or NegativeInfinity if the number is too large or too small.

See Also

Single Structure | Single Members | System Namespace | Single.Parse Overload List | NumberStyles | CultureInfo | NumberFormatInfo | PositiveInfinity | NegativeInfinity | NaN | FromString | ToString


Single.Parse (String, NumberStyles, NumberFormatInfo)

This method converts a String to a numeric value in the specified style using the formatting information.

[Visual Basic]
Overloads Public Shared Function Parse( _
   ByVal s As String, _
   ByVal style As NumberStyles, _
   ByVal info As NumberFormatInfo _
) As Single
[C#]
public static float Parse(
   string s,
   NumberStyles style,
   NumberFormatInfo info
);
[C++]
public: static float Parse(
   String* s,
   NumberStyles style,
   NumberFormatInfo* info
);
[JScript]
public static function Parse(
   s : String,
   style : NumberStyles,
   info : NumberFormatInfo
) : float;

Parameters

s
The string to be interpreted.
style
The specified style of the numeric string. It must be a combination of bit flags from the NumberStyles enumeration.
info
The NumberFormatInfo instance used to format the string. If this parameter is null the numeric format information is obtained from the current locale.

Return Value

Returns a Single with the value represented by the string parameter.

Exceptions

Exception Type | Condition
ArgumentException | If the style is not a combination of bit flags from the NumberStyle enumeration.
ArgumentNullException | If the string is a null reference (in Visual Basic Nothing).
FormatException | If the sring is not of the correct format.
OverflowException | If the string represents a number that is less than Single.MinValue or greater than Single.MaxValue.

Remarks

If s has been created by one of the Format methods using C, D, E, F, G, or N as the format specifier, it is guaranteed that s can be parsed when style is NumberStyles enumeration.

The Parse method does not throw a FormatException if the string is not a number (see NaN); it returns NaN instead. Nor does it throw an OverflowException; it returns PositiveInfinity, or NegativeInfinity if the number is too large or too small.

See Also

Single Structure | Single Members | System Namespace | Single.Parse Overload List | NumberStyles | CultureInfo | NumberFormatInfo | PositiveInfinity | NegativeInfinity | NaN | FromString | ToString


Single.ToBoolean

[To be supplied.]

[Visual Basic]
Overridable Public Function ToBoolean() As Boolean
[C#]
public virtual bool ToBoolean();
[C++]
public: virtual bool ToBoolean();
[JScript]
public function ToBoolean() : Boolean;

See Also

Single Structure | Single Members | System Namespace


Single.ToByte

[To be supplied.]

[Visual Basic]
Overridable Public Function ToByte() As Byte
[C#]
public virtual byte ToByte();
[C++]
public: virtual unsigned char ToByte();
[JScript]
public function ToByte() : Byte;

See Also

Single Structure | Single Members | System Namespace


Single.ToChar

[To be supplied.]

[Visual Basic]
Overridable Public Function ToChar() As Char
[C#]
public virtual char ToChar();
[C++]
public: virtual __wchar_t ToChar();
[JScript]
public function ToChar() : Char;

See Also

Single Structure | Single Members | System Namespace


Single.ToDateTime

[To be supplied.]

[Visual Basic]
Overridable Public Function ToDateTime() As DateTime
[C#]
public virtual DateTime ToDateTime();
[C++]
public: virtual DateTime ToDateTime();
[JScript]
public function ToDateTime() : DateTime;

See Also

Single Structure | Single Members | System Namespace


Single.ToDecimal

[To be supplied.]

[Visual Basic]
Overridable Public Function ToDecimal() As Decimal
[C#]
public virtual Decimal ToDecimal();
[C++]
public: virtual Decimal ToDecimal();
[JScript]
public function ToDecimal() : Decimal;

See Also

Single Structure | Single Members | System Namespace


Single.ToDouble

[To be supplied.]

[Visual Basic]
Overridable Public Function ToDouble() As Double
[C#]
public virtual double ToDouble();
[C++]
public: virtual double ToDouble();
[JScript]
public function ToDouble() : double;

See Also

Single Structure | Single Members | System Namespace


Single.ToInt16

[To be supplied.]

[Visual Basic]
Overridable Public Function ToInt16() As Short
[C#]
public virtual short ToInt16();
[C++]
public: virtual short ToInt16();
[JScript]
public function ToInt16() : Int16;

See Also

Single Structure | Single Members | System Namespace


Single.ToInt32

[To be supplied.]

[Visual Basic]
Overridable Public Function ToInt32() As Integer
[C#]
public virtual int ToInt32();
[C++]
public: virtual int ToInt32();
[JScript]
public function ToInt32() : int;

See Also

Single Structure | Single Members | System Namespace


Single.ToInt64

[To be supplied.]

[Visual Basic]
Overridable Public Function ToInt64() As Long
[C#]
public virtual long ToInt64();
[C++]
public: virtual __int64 ToInt64();
[JScript]
public function ToInt64() : long;

See Also

Single Structure | Single Members | System Namespace


Single.ToSByte

[To be supplied.]

[Visual Basic]
Overridable Public Function ToSByte() As SByte
[C#]
public virtual sbyte ToSByte();
[C++]
public: virtual char ToSByte();
[JScript]
public function ToSByte() : SByte;

See Also

Single Structure | Single Members | System Namespace


Single.ToSingle

[To be supplied.]

[Visual Basic]
Overridable Public Function ToSingle() As Single
[C#]
public virtual float ToSingle();
[C++]
public: virtual float ToSingle();
[JScript]
public function ToSingle() : float;

See Also

Single Structure | Single Members | System Namespace


Single.ToString

Converts a Single to a String.

Overload List

Creates a String representation of the specified Single value.

[Visual Basic] Overloads Public Shared Function ToString(Single) As String
[C#] public static string ToString(float);
[C++] public: static String* ToString(float);
[JScript] public static function ToString(float) : String;

Creates a String with the value of this instance.

[Visual Basic] Overloads Overrides Public Function ToString() As String
[C#] public override string ToString();
[C++] public: override String* ToString();
[JScript] public override function ToString() : String;

See Also

Single Structure | Single Members | System Namespace


Single.ToString (Single)

Creates a String representation of the specified Single value.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal f As Single _
) As String
[C#]
public static string ToString(
   float f
);
[C++]
public: static String* ToString(
   float f
);
[JScript]
public static function ToString(
   f : float
) : String;

Parameters

f
The Single value that is converted to a string representation.

Return Value

The string representation of the specified Single value.

Remarks

The string representation produced does not depend upon the user's settings.

The format is produced as if Format were called with the argument f, the general format ('G') character, and the invariant NumberFormatInfo. (In addition for addition inforamtion on cultures, see CultureInfo.)

To create user-dependent or locale-specific strings, use the Format method with an appropriate NumberFormatInfo object.

The following conditions apply to the f

parameter:

  • If f is a Single value which is not equal to NaN, then f = = FromString(ToString(f)) is true.
  • If f is a Single value such that either-10-9 < f <=-10-4 or 10-4 < = f < 109, then the result will be a string in the format discussed below (e.g., 0.42 is represented as "0.42"):

Suppose f is positive. The string will be composed of the integer part of f, followed by the character '.', followed by the fractional part of f.

Suppose f is negative. The string will be composed of the character '-', followed by the integer part of f, followed by the character '.', followed by the fractional part of f.

The representation always uses the least number of digits required to represent the Single value.

If f is a Single value such that either | f | < 10-4 or | f | > = 109, then the result will be a string in exponential format as discussed below (e.g., 0.00001234 is represented as "1.234E-5"):

Suppose f is positive. Let n be the unique integer such that 10n-1 < = f < 10n. Then 1 < = f/ 10n-1 < 10. The string will be composed of the floor of the mathematical quotient f/ 10n-1, followed by the character '.', followed by the fractional part of the mathematical quotient f/ 10n-1, followed by the character 'E', followed by the character '-', followed by the integer n.

Suppose f is negative. Then the result will be the same as above, except that the floor of the mathematical quotient f/ 10n-1 will be preceded by the character '-'.

The representation always uses the least number of digits required to represent the Single value, in both the mantissa and the exponent.

If f is a Single value equal to either NaN, PositiveInfinity, or NegativeInfinity, the result will be "NaN", "Infinity", or "-Infinity", respectively.

See Also

Single Structure | Single Members | System Namespace | Single.ToString Overload List


Single.ToString ()

Creates a String with the value of this instance.

[Visual Basic]
Overloads Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Remarks

The ToString method calls a ToString(float) with the value of this instance. ToString must be consumable by FromString.

Overrides ToString.

See Also

Single Structure | Single Members | System Namespace | Single.ToString Overload List | Object


Single.ToType

[To be supplied.]

[Visual Basic]
Overridable Public Function ToType( _
   ByVal type As Type _
) As Object
[C#]
public virtual object ToType(
   Type type
);
[C++]
public: virtual Object* ToType(
   Type* type
);
[JScript]
public function ToType(
   type : Type
) : Object;

Parameters

type
[To be supplied.]

See Also

Single Structure | Single Members | System Namespace


Single.ToUInt16

[To be supplied.]

[Visual Basic]
Overridable Public Function ToUInt16() As UInt16
[C#]
public virtual ushort ToUInt16();
[C++]
public: virtual unsigned short ToUInt16();
[JScript]
public function ToUInt16() : UInt16;

See Also

Single Structure | Single Members | System Namespace


Single.ToUInt32

[To be supplied.]

[Visual Basic]
Overridable Public Function ToUInt32() As UInt32
[C#]
public virtual uint ToUInt32();
[C++]
public: virtual unsigned int ToUInt32();
[JScript]
public function ToUInt32() : UInt32;

See Also

Single Structure | Single Members | System Namespace


Single.ToUInt64

[To be supplied.]

[Visual Basic]
Overridable Public Function ToUInt64() As UInt64
[C#]
public virtual ulong ToUInt64();
[C++]
public: virtual unsigned __int64 ToUInt64();
[JScript]
public function ToUInt64() : UInt64;

See Also

Single Structure | Single Members | System Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Single Fields

The fields of the Single structure are listed below. For a complete list of Single structure members, see the Single Members topic.

Public:

Empty | Represents the constant value that is the empty Single.
Epsilon | Represents the constant that is the closest positive number, but not less than, to zero.
MaxValue | Constant representing the largest possible Single value.
MinValue | Represents the constant that is the smallest possible Single value.
NaN | Represents the constant that is the value of not a number (NaN).
NegativeInfinity | Represents the constant that is the value of negative infinity.
PositiveInfinity | Represents the constant that is the value of positive infinity.

See Also

Single Structure | System Namespace


Single.Empty

Represents the constant value that is the empty Single.

[Visual Basic]
Public Const Empty As Single
[C#]
public const float Empty;
[C++]
public: const float Empty;
[JScript]
public var Empty : float;

Remarks

The value of the Empty constant is (float)0.0.

In addition see the Empty method that is the universal zero.

See Also

Single Structure | Single Members | System Namespace


Single.Epsilon

Represents the constant that is the closest positive number, but not less than, to zero.

[Visual Basic]
Public Const Epsilon As Single
[C#]
public const float Epsilon;
[C++]
public: const float Epsilon;
[JScript]
public var Epsilon : float;

Remarks

The value of the Epsilon constant is (float)1.4e-45. Epsilon represents the granularity of a Single.

See Also

Single Structure | Single Members | System Namespace


Single.MaxValue

Constant representing the largest possible Single value.

[Visual Basic]
Public Const MaxValue As Single
[C#]
public const float MaxValue;
[C++]
public: const float MaxValue;
[JScript]
public var MaxValue : float;

Remarks

The value of the MaxValue constant is (float)3.40282346638528859e+38.

See Also

Single Structure | Single Members | System Namespace


Single.MinValue

Represents the constant that is the smallest possible Single value.

[Visual Basic]
Public Const MinValue As Single
[C#]
public const float MinValue;
[C++]
public: const float MinValue;
[JScript]
public var MinValue : float;

Remarks

The value of the MinValue constant is (float)-3.40282346638528859e+38.

See Also

Single Structure | Single Members | System Namespace


Single.NaN

Represents the constant that is the value of not a number (NaN).

[Visual Basic]
Public Const NaN As Single
[C#]
public const float NaN;
[C++]
public: const float NaN;
[JScript]
public var NaN : float;

Remarks

The value of NaN constant is (float)0.0/(float)0.0.

See Also

Single Structure | Single Members | System Namespace | CultureInfo | NumberFormatInfo | IsInfinity | IsPositiveInfinity | IsNegativeInfinity | IsNaN | NegativeInfinity | PositiveInfinity


Single.NegativeInfinity

Represents the constant that is the value of negative infinity.

[Visual Basic]
Public Const NegativeInfinity As Single
[C#]
public const float NegativeInfinity;
[C++]
public: const float NegativeInfinity;
[JScript]
public var NegativeInfinity : float;

Remarks

The value of NegativeInfinity constant is (float)-1.0/(float)0.0.

See Also

Single Structure | Single Members | System Namespace | System.Globalization,.CultureInfo | System.Globalization,.NumberFormatInfo | System.Single,.IsInfinity | System.Single,.IsPositiveInfinity | PositiveInfinity | System.Single,.IsNegativeInfinity | IsNaN | NaN


Single.PositiveInfinity

Represents the constant that is the value of positive infinity.

[Visual Basic]
Public Const PositiveInfinity As Single
[C#]
public const float PositiveInfinity;
[C++]
public: const float PositiveInfinity;
[JScript]
public var PositiveInfinity : float;

Remarks

The value of the PositiveInfinity constant is (float)1.0/(float)0.0.

See Also

Single Structure | Single Members | System Namespace | CultureInfo | IsNaN | NaN | NumberFormatInfo | IsInfinity | System.Single,.IsPositiveInfinity | IsNegativeInfinity | NegativeInfinity


StackOverflowException Class

Represents the exception that is thrown when there is a stack overflow violation.

Object
Exception
SystemException
CoreException
StackOverflowException

[Visual Basic]
NotInheritable Public Class StackOverflowException
   Inherits CoreException
[C#]
public sealed class StackOverflowException : CoreException
[C++]
public __gc __sealed class StackOverflowException : public
   CoreException
[JScript]
public class StackOverflowException extends CoreException

Remarks

The StackOverflowException is the exception class that are thrown for stock overflow errors. (For more informatin, see Stack, StackFrame, and StackTrace.)

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

StackOverflowException Members | System Namespace


StackOverflowException Members

Public:

Constructor

StackOverflowException Constructor Overloaded. Initializes an instance of the StackOverflowException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

StackOverflowException Class | System Namespace


StackOverflowException Constructor

Initializes an instance of the StackOverflowException class.

Overload List

Initializes an instance of the StackOverflowException with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public StackOverflowException();
[C++] public: StackOverflowException();
[JScript] public function StackOverflowException();

Initializes an instance of StackOverflowException with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public StackOverflowException(String);
[C++] public: StackOverflowException(String*);
[JScript] public function StackOverflowException(String);

Initializes an instance of StackOverflowException with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public StackOverflowException(String, Exception);
[C++] public: StackOverflowException(String*, Exception);
[JScript] public function StackOverflowException(String, Exception);

See Also

StackOverflowException Class | StackOverflowException Members | System Namespace


StackOverflowException Constructor ()

Initializes an instance of the StackOverflowException with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public StackOverflowException();
[C++]
public: StackOverflowException();
[JScript]
public function StackOverflowException();

Remarks

StackOverflowException inherits from the Exception class. This constructor sets the properties of the StackOverflowException object as follows:

Property Type | Condition
InnerException | null
Message | The empty string.

See Also

StackOverflowException Class | StackOverflowException Members | System Namespace | StackOverflowException Constructor Overload List


StackOverflowException Constructor (String)

Initializes an instance of StackOverflowException with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public StackOverflowException(
   string message
);
[C++]
public: StackOverflowException(
   String* message
);
[JScript]
public function StackOverflowException(
   message : String
);

Parameters

message
The message text identifies the reason why the exception occurred.

Remarks

StackOverflowException inherits from the Exception class. This constructor sets the properties of the StackOverflowException object as follows:

Property Type | Condition
InnerException | null
Message | The message string.

See Also

StackOverflowException Class | StackOverflowException Members | System Namespace | StackOverflowException Constructor Overload List


StackOverflowException Constructor (String, Exception)

Initializes an instance of StackOverflowException with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public StackOverflowException(
   string message,
   Exception innerException
);
[C++]
public: StackOverflowException(
   String* message,
   Exception* innerException
);
[JScript]
public function StackOverflowException(
   message : String,
   innerException : Exception
);

Parameters

message
The message text identifies the reason that the exception occurred.
innerException
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

StackOverflowException inherits from the Exception class. This constructor sets the properties of the StackOverflowException object as follows:

Property Type | Condition
InnerException | The inner exception.
Message | The message string.

See Also

StackOverflowException Class | StackOverflowException Members | System Namespace | StackOverflowException Constructor Overload List


String Class

Represents a static string of characters.

Object
String

[Visual Basic]
NotInheritable Public Class String
   Implements IComparable, ICloneable, IConvertible
[C#]
public sealed class String : IComparable, ICloneable, IConvertible
[C++]
public __gc __sealed class String : public IComparable, ICloneable,
   IConvertible
[JScript]
public class String implements IComparable, ICloneable,
   IConvertible

Remarks

Methods are provided for comparing, formatting, and manipulating strings, but note that an instance of String cannot be modified once it has been created. Indeed, methods such as Remove, Replace, and Trim actually create a new string based on the current string. The StringBuilder can be used to create or modify strings dynamically.

Character positions (indices) within a string are 0-based, as with arrays. Comparison and search procedures are case-sensitive and use the CurrentCulture of the current thread unless otherwise specified.

When conducting textual comparisons one should use the Compare and Equals methods provided by String. These operators compare String objects for reference equality, unless they are overloaded by the language/compiler. However, the Environment makes it possible for String objects that are assigned literal values to be compared with the relational operators. This works for string literals only. A dynamically created string (one obtained via StringBuilder or one that has been created via the String methods such as Remove, Replace, and Trim) cannot be textually compared with the relational operators. The Compare and Equals methods must be used in this case, and should be used in general.

Requirements

Namespace: System

Assembly: mscorlib.dll

Example

The following examples are for illustrative purposes only; they will not run as specified in the comments. The first set of examples shows the use of relational operators.

Managed C++:

Console::WriteLine(L"twins" ==
L"twins");   // THIS IS TRUE
String *SL = L"twins";          // same as new
Console::WriteLine(SL == L"twins");         // THIS IS TRUE
String *TL = new String(L"twins");
Console::WriteLine(SL == TL);   // THIS IS TRUE
SL = SL->Remove(4,1);           // remove 's' from "twins"
SL = SL + L"s";     // append 's' to "twin"
Console::WriteLine(SL == TL);   // THIS IS FALSE
StringBuilder *UL = new StringBuilder(L"twins");
SL = UL->ToString();
Console::WriteLine(SL == TL);   // THIS IS FALSE

Visual Basic:
Console.WriteLine("twins" = "twins") ' THIS
IS TRUE
Dim SL As String
SL = "twins" ' Same as: Set SL = New
Console.WriteLine(SL = "twins")
' THIS IS TRUEDim TL As String
Set TL = New String("twins")
Console.WriteLine(SL = TL)           ' THIS IS TRUE

SL = SL.Remove(4,1)      ' Remove "s" from "twins"
SL = SL + "s"' Append "s" to "twin"
Console.WriteLine(SL = TL)           ' THIS IS FALSE
Dim UL As StringBuilder
Set UL = New StringBuilder("twins")
SL = UL.ToString()
Console.WriteLine(SL = TL)           ' THIS IS FALSE

The following example illustrates the use of String.Equals and Compare.
Managed C++
String *SL = L"twins";
Console::WriteLine(SL->Equals(L"twins"));          // THIS IS TRUE
String *TL = new String(L"twins");
Console::WriteLine(0 == String::Compare(SL,TL));   // THIS IS TRUE
SL = SL->Remove(4,1);      // Remove 's' from "twins"
SL = SL + L"s";// Append 's' to
"twin"
Console::WriteLine(SL->Equals(TL));    // THIS IS TRUE
StringBuilder *UL = new StringBuilder(L"twins");
SL = UL->ToString();
Console::WriteLine(0 == String::Compare(SL,TL));   // THIS IS TRUE

Visual Basic:
Dim SL As String
SL = "twins"
Console.WriteLine(SL.Equals("twins"))      ' THIS IS TRUE
Dim TL As String
TL = "twins"
Console.WriteLine(0 = System.String.Compare(SL,TL))    ' THIS IS TRUE
SL = SL.Remove(4,1)' Remove "s" from
"twins"
SL = SL + "s"      ' Append "s" to
"twin"
Console.WriteLine(SL.Equals(TL))           ' THIS IS TRUE
Dim UL As StringBuilder
Set UL = New StringBuilder("twins")
SL = UL.ToString()
Console.WriteLine(0 = System.String.Compare(SL,TL))    ' THIS IS TRUE

See Also

String Members | System Namespace | IComparable | ICloneable | IConvertible | Environment | Object | StringBuilder | CultureInfo


String Members

Public:

Constructor

String Constructor Overloaded. Initializes a new instance of the string that is unsafe.

Properties

Chars | Gets the character at a specified position.
Length | Retrieves the number of characters contained in this string.

Methods

Clone | Returns this string.
Compare | Overloaded. Compares two strings.
CompareOrdinal | Overloaded. Compares two string regions by an ordinal comparison.
CompareTo | Overloaded. Compares this instance with specified instance.
Concat | Overloaded. Creates a new string from two strings.
Copy | Creates a new string by copying another string.
CopyTo | Copies a specified number of characters from a specified location in this string to a specified location in an array.
EndsWith | Determines whether a specified string is a suffix of the current instance.
Equals | Overloaded. Determines whether two objects match.
Format | Overloaded. Replaces zero or more format specifications with the appropriately formatted value of an object.
GetHashCode | Gets a hash code for this string.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | Retrieves the type code of an object.
IndexOf | Overloaded. Returns the index of the first occurrence.
Insert | Returns a new string with a specified value inserted at a specified position in this string.
Intern | Retrieves the reference for the string.
IsInterned | Retrieves the reference for the string.
Join | Overloaded. [To be supplied.]
LastIndexOf | Overloaded. Gets the position of the last occurrence of the specified character in this string.
PadLeft | Overloaded. Returns this string left-aligned in a field.
PadRight | Overloaded. Returns this string right-aligned in a field and padded with spaces.
Remove | Deletes a specified number of characters from this String beginning at a specified location.
Replace | Replaces all instances of a specified character with a new one.
Split | Overloaded. Creates an array of strings by splitting this string.
StartsWith | Determines whether a specified string is a prefix of the current instance.
Substring | Overloaded. [To be supplied.]
ToBoolean | Converts a string to a Boolean value.
ToByte | Converts a string to a value in the specified base, represented as an 8-bit unsigned Byte.
ToChar | Converts a non-empty string of length one to a Char.
ToCharArray | Overloaded. Returns a string as an array of characters.
ToDateTime | Returns the specified string converted to DateTime format.
ToDecimal | Converts a string to a Decimal.
ToDouble | Converts a string to a Double.
ToInt16 | Converts a specified string to an Int16 in the specified base.
ToInt32 | Converts a string to an Int32.
ToInt64 | Converts a string to an Int64 value.
ToLower | Overloaded. Creates a copy of this string in lower case.
ToSByte | Converts an SByte to a string.
ToSingle | Returns a string representing the specified number as a Single.
ToString | Returns the current instance of string.
ToType | Retrieves the Type for a specified object.
ToUInt16 | Converts a string to a UInt16 value.
ToUInt32 | Converts a string to a UInt32 value.
ToUInt64 | Converts a string to a UInt64 value.
ToUpper | Overloaded. Creates a copy of this string in upper case.
Trim | Overloaded. Trims white space from a string.
TrimEnd | Removes a string of characters from the end of this string.
TrimStart | Removes characters from the beginning of this string.

Fields

Empty Representing the constant that is the empty string value.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

String Class | System Namespace


String Constructor

Initializes a new instance of the string that is unsafe.

Overload List

Initailizes a new instance of the string that is unsafe.

[Visual Basic] Overloads Public Sub New(Char*)
[C#] public String(Char*);
[C++] public: String(Char**);
[JScript] public function String(Char*);

Initailizes a new instance of the string that is unsafe.

[Visual Basic] Overloads Public Sub New(Char*, Integer, Integer)
[C#] public String(Char*, int, int);
[C++] public: String(Char**, int, int);
[JScript] public function String(Char*, int, int);

Initailizes a new instance of the string that is unsafe.

[Visual Basic] Overloads Public Sub New(SByte*)
[C#] public String(SByte*);
[C++] public: String(SByte**);
[JScript] public function String(SByte*);

Initailizes a new instance of the string class that is unsafe.

[Visual Basic] Overloads Public Sub New(SByte*, Integer, Integer)
[C#] public String(SByte*, int, int);
[C++] public: String(SByte**, int, int);
[JScript] public function String(SByte*, int, int);

OBSOLETE. Use Copy if you need a copy.

Initializes an instance of the string class that is a copy of a specified value.

[Visual Basic] Overloads Public Sub New(String)
[C#] public String(String);
[C++] public: String(String*);
[JScript] public function String(String);

Initializes an instance of the string class from the characters in a subarray.

[Visual Basic] Overloads Public Sub New(Char(), Integer, Integer)
[C#] public String(char[], int, int);
[C++] public: String(__wchar_t*[], int, int);
[JScript] public function String(Char[], int, int);

Initializes an instance of the string class with a specified character.

[Visual Basic] Overloads Public Sub New(Char())
[C#] public String(char[]);
[C++] public: String(__wchar_t*[]);
[JScript] public function String(Char[]);

Initializes an instance of the string class with a specified character.

[Visual Basic] Overloads Public Sub New(Char, Integer)
[C#] public String(char, int);
[C++] public: String(__wchar_t, int);
[JScript] public function String(Char, int);

See Also

String Class | String Members | System Namespace


String Constructor (Char*)

Initailizes a new instance of the string that is unsafe.

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As Char* _
)
[C#]
public String(
   Char* value
);
[C++]
public: String(
   Char** value
);
[JScript]
public function String(
   value : Char*
);

Parameters

value
The string.

Remarks

This constructor is not CLS Compliant.

This constuctor initailizes a new string with the characters copied from ptr. The ptr parameter is a WCHAR*. If ptr is null, a string is created that is initialized to No Object.

This method is assessible only from Visual C.

See Also

String Class | String Members | System Namespace | String Constructor Overload List | Char


String Constructor (Char*, Int32, Int32)

Initailizes a new instance of the string that is unsafe.

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As Char*, _
   ByVal startIndex As Integer, _
   ByVal length As Integer _
)
[C#]
public String(
   Char* value,
   int startIndex,
   int length
);
[C++]
public: String(
   Char** value,
   int startIndex,
   int length
);
[JScript]
public function String(
   value : Char*,
   startIndex : int,
   length : int
);

Parameters

value
The string.
startIndex
[To be supplied.]
length
[To be supplied.]

Remarks

This constructor is not CLS Compliant.

This constuctor initailizes a new string with the characters copied from ptr. The ptr parameter is a WCHAR*. If ptr is null, a string is created that is initialized to No Object.

This method is assessible only from Visual C.

See Also

String Class | String Members | System Namespace | String Constructor Overload List | Char | Int32


String Constructor (SByte*)

Initailizes a new instance of the string that is unsafe.

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As SByte* _
)
[C#]
public String(
   SByte* value
);
[C++]
public: String(
   SByte** value
);
[JScript]
public function String(
   value : SByte*
);

Parameters

value
The string.

Remarks

This constructor is not CLS Compliant.

This constuctor initailizes a new string with the characters copied from ptr. The ptr parameter is a WCHAR*. If ptr is null, a string is created that is initialized to No Object.This method is assessible only from Visual C.

See Also

String Class | String Members | System Namespace | String Constructor Overload List | SByte


String Constructor (SByte*, Int32, Int32)

Initailizes a new instance of the string class that is unsafe.

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As SByte*, _
   ByVal startIndex As Integer, _
   ByVal length As Integer _
)
[C#]
public String(
   SByte* value,
   int startIndex,
   int length
);
[C++]
public: String(
   SByte** value,
   int startIndex,
   int length
);
[JScript]
public function String(
   value : SByte*,
   startIndex : int,
   length : int
);

Parameters

value
The string.
startIndex
The position to start.
length
The length of the string.

Remarks

This constructor is not CLS Compliant.

This constuctor initailizes a new string with the characters copied from ptr. The ptr parameter is a WCHAR*. If ptr is null, a string is created that is initialized to No Object.This method is assessible only from Visual C.

See Also

String Class | String Members | System Namespace | String Constructor Overload List | SByte | Int32


String Constructor (String)

OBSOLETE. Use Copy if you need a copy.

Initializes an instance of the string class that is a copy of a specified value.

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As String _
)
[C#]
public String(
   string value
);
[C++]
public: String(
   String* value
);
[JScript]
public function String(
   value : String
);

Parameters

value
The string to be copied.

Remarks

If value is null, a string initialized to the Empty is created.

See Also

String Class | String Members | System Namespace | String Constructor Overload List | Empty


String Constructor (Char[], Int32, Int32)

Initializes an instance of the string class from the characters in a subarray.

[Visual Basic]
Overloads Public Sub New( _
   ByVal value() As Char, _
   ByVal startIndex As Integer, _
   ByVal length As Integer _
)
[C#]
public String(
   char[] value,
   int startIndex,
   int length
);
[C++]
public: String(
   __wchar_t* value[],
   int startIndex,
   int length
);
[JScript]
public function String(
   value : Char[],
   startIndex : int,
   length : int
);

Parameters

value
An array of characters.
startIndex
The position where the array begins.
length
The length of the array.

Exceptions

Exception Type | Condition
ArgumentNullException | If value is null.
ArgumentOutOfRangeException | If the starting position or if the combined starting position and length of the string are not valid indices of the array.

Remarks

This constructor initializes an new string that is created from a subarray. The new String will contain the number of characters (length) from the array (value) that begins at the position indicated (startIndex).

An exception will be thrown if startIndex or (startIndex + length -1) are not valid indices.

See Also

String Class | String Members | System Namespace | String Constructor Overload List | Char | Int32


String Constructor (Char[])

Initializes an instance of the string class with a specified character.

[Visual Basic]
Overloads Public Sub New( _
   ByVal value() As Char _
)
[C#]
public String(
   char[] value
);
[C++]
public: String(
   __wchar_t* value[]
);
[JScript]
public function String(
   value : Char[]
);

Parameters

value
The character from which the string is to be created.

Remarks

When passing a null string to a constructor in VJ or VC, the null should be explicitly type cast to a string. For example,

  • String s = new String ((String)null));
  • Text.Out.WriteLine(s);

See Also

String Class | String Members | System Namespace | String Constructor Overload List | Char


String Constructor (Char, Int32)

Initializes an instance of the string class with a specified character.

[Visual Basic]
Overloads Public Sub New( _
   ByVal c As Char, _
   ByVal count As Integer _
)
[C#]
public String(
   char c,
   int count
);
[C++]
public: String(
   __wchar_t c,
   int count
);
[JScript]
public function String(
   c : Char,
   count : int
);

Parameters

c
The character from which the string is to be created.
count
[To be supplied.]

Remarks

This constructor initializes an instance of the String class with a specified character from which to create the string.

See Also

String Class | String Members | System Namespace | String Constructor Overload List | Array | Char | Int32


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

String Properties

The properties of the String class are listed below. For a complete list of String class members, see the String Members topic.

Public:

Chars | Gets the character at a specified position.
Length | Retrieves the number of characters contained in this string.

See Also

String Class | System Namespace


String.Chars

Gets the character at a specified position.

[Visual Basic]
Public Default ReadOnly Property Chars( _
   ByVal index As Integer _
) As Char
[C#]
public char this[
   int index
] {get;}
[C++]
public: __property __wchar_t get_Chars(int index);
[JScript]
returnValue = StringObject.Chars(index);

Parameters

index
The position of the character to get.

Exceptions

Exception Type | Condition
ArgumentException | If the character is not at that position in the string.

Remarks

This indexer gets a character from a specified position in the string and returns it. If the charcter at the specified position doesn't match the index parameter than an exception is thrown.

See Also

String Class | String Members | System Namespace | Char | Int32


String.Length

Retrieves the number of characters contained in this string.

[Visual Basic]
Public ReadOnly Property Length As Integer
[C#]
public int Length {get;}
[C++]
public: __property int get_Length();
[JScript]
public function get Length() : int;

Property Value

Read-only.

Remarks

The Length property uses get to retrieve a specified number of characters in this string. This property returns the number of characters contained in this string.

See Also

String Class | String Members | System Namespace | Int32


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

String Methods

The methods of the String class are listed below. For a complete list of String class members, see the String Members topic.

Public:

Clone | Returns this string.
Compare | Overloaded. Compares two strings.
CompareOrdinal | Overloaded. Compares two string regions by an ordinal comparison.
CompareTo | Overloaded. Compares this instance with specified instance.
Concat | Overloaded. Creates a new string from two strings.
Copy | Creates a new string by copying another string.
CopyTo | Copies a specified number of characters from a specified location in this string to a specified location in an array.
EndsWith | Determines whether a specified string is a suffix of the current instance.
Equals | Overloaded. Determines whether two objects match.
Format | Overloaded. Replaces zero or more format specifications with the appropriately formatted value of an object.
GetHashCode | Gets a hash code for this string.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | Retrieves the type code of an object.
IndexOf | Overloaded. Returns the index of the first occurrence.
Insert | Returns a new string with a specified value inserted at a specified position in this string.
Intern | Retrieves the reference for the string.
IsInterned | Retrieves the reference for the string.
Join | Overloaded. [To be supplied.]
LastIndexOf | Overloaded. Gets the position of the last occurrence of the specified character in this string.
PadLeft | Overloaded. Returns this string left-aligned in a field.
PadRight | Overloaded. Returns this string right-aligned in a field and padded with spaces.
Remove | Deletes a specified number of characters from this String beginning at a specified location.
Replace | Replaces all instances of a specified character with a new one.
Split | Overloaded. Creates an array of strings by splitting this string.
StartsWith | Determines whether a specified string is a prefix of the current instance.
Substring | Overloaded. [To be supplied.]
ToBoolean | Converts a string to a Boolean value.
ToByte | Converts a string to a value in the specified base, represented as an 8-bit unsigned Byte.
ToChar | Converts a non-empty string of length one to a Char.
ToCharArray | Overloaded. Returns a string as an array of characters.
ToDateTime | Returns the specified string converted to DateTime format.
ToDecimal | Converts a string to a Decimal.
ToDouble | Converts a string to a Double.
ToInt16 | Converts a specified string to an Int16 in the specified base.
ToInt32 | Converts a string to an Int32.
ToInt64 | Converts a string to an Int64 value.
ToLower | Overloaded. Creates a copy of this string in lower case.
ToSByte | Converts an SByte to a string.
ToSingle | Returns a string representing the specified number as a Single.
ToString | Returns the current instance of string.
ToType | Retrieves the Type for a specified object.
ToUInt16 | Converts a string to a UInt16 value.
ToUInt32 | Converts a string to a UInt32 value.
ToUInt64 | Converts a string to a UInt64 value.
ToUpper | Overloaded. Creates a copy of this string in upper case.
Trim | Overloaded. Trims white space from a string.
TrimEnd | Removes a string of characters from the end of this string.
TrimStart | Removes characters from the beginning of this string.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

String Class | System Namespace


String.Clone

Returns this string.

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

Return Value

This string.

Remarks

The Clone method is required for the ICloneable interface.

See Also

String Class | String Members | System Namespace | Object


String.Compare

Compares two strings.

Overload List

Compares two strings with locale specific information.

[Visual Basic] Overloads Public Shared Function Compare(String, String, Boolean, CultureInfo) As Integer
[C#] public static int Compare(String, String, bool, CultureInfo);
[C++] public: static int Compare(String*, String*, bool, CultureInfo);
[JScript] public static function Compare(String, String, Boolean, CultureInfo) : int;

Compares two strings with the default CultureInfo information.

[Visual Basic] Overloads Public Shared Function Compare(String, String, Boolean) As Integer
[C#] public static int Compare(String, String, bool);
[C++] public: static int Compare(String*, String*, bool);
[JScript] public static function Compare(String, String, Boolean) : int;

Compares two strings with the default CultureInfo information.

[Visual Basic] Overloads Public Shared Function Compare(String, String) As Integer
[C#] public static int Compare(String, String);
[C++] public: static int Compare(String*, String*);
[JScript] public static function Compare(String, String) : int;

Compares two strings with the default CultureInfo information.

[Visual Basic] Overloads Public Shared Function Compare(String, Integer, String, Integer, Integer) As Integer
[C#] public static int Compare(String, int, String, int, int);
[C++] public: static int Compare(String*, int, String*, int, int);
[JScript] public static function Compare(String, int, String, int, int) : int;

Compares two strings with CultureInfo specific information.

[Visual Basic] Overloads Public Shared Function Compare(String, Integer, String, Integer, Integer, Boolean, CultureInfo) As Integer
[C#] public static int Compare(String, int, String, int, int, bool, CultureInfo);
[C++] public: static int Compare(String*, int, String*, int, int, bool, CultureInfo);
[JScript] public static function Compare(String, int, String, int, int, Boolean, CultureInfo) : int;

Compares two strings with default CultureInfo information.

[Visual Basic] Overloads Public Shared Function Compare(String, Integer, String, Integer, Integer, Boolean) As Integer
[C#] public static int Compare(String, int, String, int, int, bool);
[C++] public: static int Compare(String*, int, String*, int, int, bool);
[JScript] public static function Compare(String, int, String, int, int, Boolean) : int;

See Also

String Class | String Members | System Namespace


String.Compare (String, String, Boolean, CultureInfo)

Compares two strings with locale specific information.

[Visual Basic]
Overloads Public Shared Function Compare( _
   ByVal strA As String, _
   ByVal strB As String, _
   ByVal ignoreCase As Boolean, _
   ByVal culture As CultureInfo _
) As Integer
[C#]
public static int Compare(
   string strA,
   string strB,
   bool ignoreCase,
   CultureInfo culture
);
[C++]
public: static int Compare(
   String* strA,
   String* strB,
   bool ignoreCase,
   CultureInfo* culture
);
[JScript]
public static function Compare(
   strA : String,
   strB : String,
   ignoreCase : Boolean,
   culture : CultureInfo
) : int;

Parameters

strA
The first string.
strB
The second string.
ignoreCase
true indicates that the comparison is case-insensitive.
culture
Sets the locale.

Return Value

Value Type | Condition
A negative integer | If region A is less than region B.
0 | If the two regions or length are equal.
A positive integer | If region A is greater than region B.
true | If the comparison is case-insensitive.

Exceptions

Exception Type | Condition
ArgumentNullException | If either string is null.

Remarks

The Compare method does a locale sensitive comparison of two strings and returns a integer representation of their relationship with the specific culture information from CultureInfo, but also returns a Boolean about the strings case-sensitivity.

One string may be "less than" or "greater than" another string depending upon the rules of the national language under which the comparison is made. To compare strings without regard to national languages, see CompareOrdinal and CurrentCulture.

The comparison of strA and strB is case-insensitive if ignoreCase is true. The locale is set by culture. This method does a locale-sensitive comparison.

See Also

String Class | String Members | System Namespace | String.Compare Overload List | Int32


String.Compare (String, String, Boolean)

Compares two strings with the default CultureInfo information.

[Visual Basic]
Overloads Public Shared Function Compare( _
   ByVal strA As String, _
   ByVal strB As String, _
   ByVal ignoreCase As Boolean _
) As Integer
[C#]
public static int Compare(
   string strA,
   string strB,
   bool ignoreCase
);
[C++]
public: static int Compare(
   String* strA,
   String* strB,
   bool ignoreCase
);
[JScript]
public static function Compare(
   strA : String,
   strB : String,
   ignoreCase : Boolean
) : int;

Parameters

strA
The first string.
strB
The second string.
ignoreCase
true indicates that the comparison is case-insensitive.

Return Value

Value Type | Condition
A negative integer | If region A is less than region B.
0 | If the two regions or length are equal.
A positive integer | If region A is greater than region B.
true | If the comparison is case-insensitive.

Exceptions

Exception Type | Condition
ArgumentNullException | If either the first string or the second string is null.

Remarks

The Compare method does a locale sensitive comparison of two strings and returns a integer representation of their relationship, but also returns a Boolean.

One string may be "less than" or "greater than" another string depending upon the rules of the national language under which the comparison is made. To compare strings without regard to national languages, see CompareOrdinal and CurrentCulture.

The comparison of strA and strB is case-insensitive if ignoreCase is true. The default locale is used. This method does a locale sensitive comparison.

See Also

String Class | String Members | System Namespace | String.Compare Overload List | Int32


String.Compare (String, String)

Compares two strings with the default CultureInfo information.

[Visual Basic]
Overloads Public Shared Function Compare( _
   ByVal strA As String, _
   ByVal strB As String _
) As Integer
[C#]
public static int Compare(
   string strA,
   string strB
);
[C++]
public: static int Compare(
   String* strA,
   String* strB
);
[JScript]
public static function Compare(
   strA : String,
   strB : String
) : int;

Parameters

strA
The first string.
strB
The second string.

Return Value

Value Type | Condition
A negative integer | If region A is less than region B.
0 | If the two regions or length are equal.
A positive integer | If region A is greater than region B.

Exceptions

Exception Type | Condition
ArgumentNullException | If either string is null.

Remarks

The Compare method does a locale sensitive comparison of two strings and returns a integer representation of their relationship.

One string may be "less than" or "greater than" another string depending upon the rules of the national language under which the comparison is made. To compare strings without regard to national languages, see CompareOrdinal.

The comparison of strA and strB is case-sensitive and the default locale is used. This method does a CultureInfo sensitive comparison (see CurrentCulture for current cultures).

See Also

String Class | String Members | System Namespace | String.Compare Overload List | Int32


String.Compare (String, Int32, String, Int32, Int32)

Compares two strings with the default CultureInfo information.

[Visual Basic]
Overloads Public Shared Function Compare( _
   ByVal strA As String, _
   ByVal indexA As Integer, _
   ByVal strB As String, _
   ByVal indexB As Integer, _
   ByVal length As Integer _
) As Integer
[C#]
public static int Compare(
   string strA,
   int indexA,
   string strB,
   int indexB,
   int length
);
[C++]
public: static int Compare(
   String* strA,
   int indexA,
   String* strB,
   int indexB,
   int length
);
[JScript]
public static function Compare(
   strA : String,
   indexA : int,
   strB : String,
   indexB : int,
   length : int
) : int;

Parameters

strA
The first string.
indexA
The index into the first string at which the region begins.
strB
The second string.
indexB
The index into the second string at which the region begins.
length
The length of the regions to compare.

Return Value

Value Type | Condition
A negative integer | If region A is less than region B.
0 | If the two regions of length are equal.
A positive integer | If region A is greater than region B.

Exceptions

Exception Type | Condition
ArgumentNullException | If either string is null.
ArgumentOutOfRangeException | If either index is out of range.
ArgumentOutOfRangeException | If length is negative.

Remarks

The Compare method does a locale sensitive comparison of two strings and returns a integer representation of their relationship with the specific culture information from CultureInfo.

One string may be "less than" or "greater than" another string depending upon the rules of the national language under which the comparison is made. To compare strings without regard to national languages, see CompareOrdinal. and CurrentCulture.

The region of the first string of length, beginning at the position of the the first index, is compared with the region of the second string of length, beginning at the position of the second index. The comparison is case-sensitive and the default locale is used.

The length parameter must be non-negative. If length equals zero (length = 0), then zero is returned.

See Also

String Class | String Members | System Namespace | String.Compare Overload List | Int32


String.Compare (String, Int32, String, Int32, Int32, Boolean, CultureInfo)

Compares two strings with CultureInfo specific information.

[Visual Basic]
Overloads Public Shared Function Compare( _
   ByVal strA As String, _
   ByVal indexA As Integer, _
   ByVal strB As String, _
   ByVal indexB As Integer, _
   ByVal length As Integer, _
   ByVal ignoreCase As Boolean, _
   ByVal culture As CultureInfo _
) As Integer
[C#]
public static int Compare(
   string strA,
   int indexA,
   string strB,
   int indexB,
   int length,
   bool ignoreCase,
   CultureInfo culture
);
[C++]
public: static int Compare(
   String* strA,
   int indexA,
   String* strB,
   int indexB,
   int length,
   bool ignoreCase,
   CultureInfo* culture
);
[JScript]
public static function Compare(
   strA : String,
   indexA : int,
   strB : String,
   indexB : int,
   length : int,
   ignoreCase : Boolean,
   culture : CultureInfo
) : int;

Parameters

strA
The first string.
indexA
The index into the first string at which the region begins.
strB
The second string
indexB
The index into the first string at which the region begins.
length
The length of the regions to compare.
ignoreCase
true indicates that the comparison is case-insensitive.
culture
Sets the locale culture.

Return Value

Value Type | Condition
A negative integer | If region A is less than region B.
0 | If the two regions or length are equal.
A positive integer | If region A is greater than region B.
true | If the comparison is case-insensitive.

Exceptions

Exception Type | Condition
ArgumentNullException | If either string is null.
ArgumentOutOfRangeException | If the starting position of either string is out of range.
ArgumentOutOfRangeException | If the length is negative.

Remarks

The Compare method does a locale sensitive comparison of two strings and returns a integer representation of their relationship with the specific culture information from CultureInfo, but also returns a Boolean about the strings case-sensitivity.

One string may be "less than" or "greater than" another string depending upon the rules of the national language under which the comparison is made. To compare strings without regard to national languages, see CompareOrdinal and CurrentCulture.

The region of the first string of the specified length, beginning at the position of the index for the first string, is compared with the region of the second string of specified length beginning at the position of the index for the second string. The locale is set by the information provided by CultureInfo.

The length parameter must be non-negative. If length equals zero (length = 0), then zero is returned.

See Also

String Class | String Members | System Namespace | String.Compare Overload List


String.Compare (String, Int32, String, Int32, Int32, Boolean)

Compares two strings with default CultureInfo information.

[Visual Basic]
Overloads Public Shared Function Compare( _
   ByVal strA As String, _
   ByVal indexA As Integer, _
   ByVal strB As String, _
   ByVal indexB As Integer, _
   ByVal length As Integer, _
   ByVal ignoreCase As Boolean _
) As Integer
[C#]
public static int Compare(
   string strA,
   int indexA,
   string strB,
   int indexB,
   int length,
   bool ignoreCase
);
[C++]
public: static int Compare(
   String* strA,
   int indexA,
   String* strB,
   int indexB,
   int length,
   bool ignoreCase
);
[JScript]
public static function Compare(
   strA : String,
   indexA : int,
   strB : String,
   indexB : int,
   length : int,
   ignoreCase : Boolean
) : int;

Parameters

strA
The first string.
indexA
The index into the first string at which the region begins.
strB
The second string
indexB
The index into the second string at which the region begins.
length
The length of the regions to compare.
ignoreCase
true indicates that the comparison is case-insensitive.

Return Value

Value Type | Condition
A negative integer | If region A is less than region B.
0 | If the two regions or length are equal.
A positive integer | If region A is greater than region B.
true | If the comparison is case-insensitive.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | If either string is null.
ArgumentOutOfRangeException | If either index is out of range.
ArgumentOutOfRangeException | If the length to compare is negative.

Remarks

The Compare method does a locale sensitive comparison of two strings and returns a integer representation of their relationship with the specific culture information from CultureInfo, but also returns a Boolean about the strings case-sensitivity.

One string may be "less than" or "greater than" another string depending upon the rules of the national language under which the comparison is made. To compare strings without regard to national languages, see CompareOrdinal.

The region of the first string of specified length, beginning at the specified position for the first string, is compared with the region of the second of a specified length, beginning at the specified position for the second string. The default locale is used.

The length parameter must be non-negative. If length equals zero (length = 0), then zero is returned.

See Also

String Class | String Members | System Namespace | String.Compare Overload List | Int32


String.CompareOrdinal

Compares two string regions by an ordinal comparison.

Overload List

Compares two string regions, starting at specified points that have a specified length, and uses an ordinal comparison.

[Visual Basic] Overloads Public Shared Function CompareOrdinal(String, Integer, String, Integer, Integer) As Integer
[C#] public static int CompareOrdinal(String, int, String, int, int);
[C++] public: static int CompareOrdinal(String*, int, String*, int, int);
[JScript] public static function CompareOrdinal(String, int, String, int, int) : int;

Compares two strings by an ordinal comparison.

[Visual Basic] Overloads Public Shared Function CompareOrdinal(String, String) As Integer
[C#] public static int CompareOrdinal(String, String);
[C++] public: static int CompareOrdinal(String*, String*);
[JScript] public static function CompareOrdinal(String, String) : int;

See Also

String Class | String Members | System Namespace


String.CompareOrdinal (String, Int32, String, Int32, Int32)

Compares two string regions, starting at specified points that have a specified length, and uses an ordinal comparison.

[Visual Basic]
Overloads Public Shared Function CompareOrdinal( _
   ByVal strA As String, _
   ByVal indexA As Integer, _
   ByVal strB As String, _
   ByVal indexB As Integer, _
   ByVal length As Integer _
) As Integer
[C#]
public static int CompareOrdinal(
   string strA,
   int indexA,
   string strB,
   int indexB,
   int length
);
[C++]
public: static int CompareOrdinal(
   String* strA,
   int indexA,
   String* strB,
   int indexB,
   int length
);
[JScript]
public static function CompareOrdinal(
   strA : String,
   indexA : int,
   strB : String,
   indexB : int,
   length : int
) : int;

Parameters

strA
The first string.
indexA
The index in the first string at which the region begins.
strB
The second string.
indexB
The index in the second string at which the region begins.
length
The length of the regions to compare.

Return Value

Permission | Description
A negative integer | If region A is less than region B
0 | If the two regions are equal
A positive integer | If region A is greater than region B.

Exceptions

Exception Type | Condition
ArgumentException | If it is case-insensitive mode for characters greater than 0x80.
ArgumentNullException | If either string is null.
ArgumentOutOfRangeException | If the starting positions are less than 0.
ArgumentOutOfRangeException | If length of the total string is longer than the length of their respective strings.

Remarks

The CompareOrdinal method compares two specified strings and returns an integer representation of their relationship with the additiona criteria of the length of the string and the index.

To compare strings under the rules of specified CultureInfo, use Compare or CompareTo

The region of the first string of the specified length, beginning at position of the index for the first string, is compared with the region of the second string of specified length, beginning at postion of the index of the second string, and uses an ordinal comparison. In the comparison of two string objects, a null string is considered less than a non-null string. If both strings are null, they are considered to be equal.

The length parameter must be non-negative. If length is equal to zero (length = 0), then zero is returned. If total length

of the new string is longer than the length of the combined individual strings (indexA + count or indexB + count) that were used to create the new string.

See Also

String Class | String Members | System Namespace | String.CompareOrdinal Overload List


String.CompareOrdinal (String, String)

Compares two strings by an ordinal comparison.

[Visual Basic]
Overloads Public Shared Function CompareOrdinal( _
   ByVal strA As String, _
   ByVal strB As String _
) As Integer
[C#]
public static int CompareOrdinal(
   string strA,
   string strB
);
[C++]
public: static int CompareOrdinal(
   String* strA,
   String* strB
);
[JScript]
public static function CompareOrdinal(
   strA : String,
   strB : String
) : int;

Parameters

strA
The first string.
strB
The second string.

Return Value

Permission | Description
A negative integer | If the first string is less than the second string.
0 | If the two strings are equal
A positive integer | If the first string is greater than the second string.

Remarks

The CompareOrdinal method compares two specified strings and returns an integer representation of their relationship.

To compare strings under the rules of specified CultureInfo, use Compare or CompareTo

In the comparison of two string objects, a null string is considered less than a non-null string. If both strings are null, they are considered equal.

See Also

String Class | String Members | System Namespace | String.CompareOrdinal Overload List | Int32


String.CompareTo

Compares this instance with specified instance.

Overload List

Compares this instance with the specified Object.

[Visual Basic] Overloads Overridable Public Function CompareTo(Object) As Integer
[C#] public virtual int CompareTo(Object);
[C++] public: virtual int CompareTo(Object*);
[JScript] public function CompareTo(Object) : int;

Compares and determines the sorting order of this instance and the specified string.

[Visual Basic] Overloads Public Function CompareTo(String) As Integer
[C#] public int CompareTo(String);
[C++] public: int CompareTo(String*);
[JScript] public function CompareTo(String) : int;

See Also

String Class | String Members | System Namespace


String.CompareTo (Object)

Compares this instance with the specified Object.

[Visual Basic]
Overloads Overridable Public Function CompareTo( _
   ByVal value As Object _
) As Integer
[C#]
public virtual int CompareTo(
   object value
);
[C++]
public: virtual int CompareTo(
   Object* value
);
[JScript]
public function CompareTo(
   value : Object
) : int;

Parameters

value
The object compared with this instance.

Return Value

Value | Condition
A negative integer | If the object sorts before this instance.
Zero | If the objects sort equally.
A positive integer | If the object sorts after this instance.

Exceptions

Exception Type | Condition
ArgumentException | If the object is not a string.

Remarks

The comparison of two string values is case-sensitive and uses the CultureInfo of the current thread to determine the ordering.

An instance of string is considered to be greater than any object that is not a string. In particular, an instance of String is considered to be greater than a null reference. Note that sorted arrays with nulls, objects, and strings would put in that order. A null string sorts less than all the others.

See Also

String Class | String Members | System Namespace | String.CompareTo Overload List | Object | Int32 | CultureInfo


String.CompareTo (String)

Compares and determines the sorting order of this instance and the specified string.

[Visual Basic]
Overloads Public Function CompareTo( _
   ByVal strB As String _
) As Integer
[C#]
public int CompareTo(
   string strB
);
[C++]
public: int CompareTo(
   String* strB
);
[JScript]
public function CompareTo(
   strB : String
) : int;

Parameters

strB
The string compared with this instance.

Return Value

Value | Condition
A negative integer | If this instance is less than the string.
Zero | If this instance and the string have the same value.
A positive integer | If this instance is greater than the string.
A positive integer | If the string is null.

Remarks

The comparison of two string values is case-sensitive and uses the CultureInfo of the current thread to determine the ordering. As a special case, an instance of string is considered to be greater than a null reference.

See Also

String Class | String Members | System Namespace | String.CompareTo Overload List | Int32


String.Concat

Creates a new string from two strings.

Overload List

Creates a new string from the concatenation of three specific strings.

[Visual Basic] Overloads Public Shared Function Concat(Object, Object, Object) As String
[C#] public static string Concat(Object, Object, Object);
[C++] public: static String* Concat(Object*, Object*, Object*);
[JScript] public static function Concat(Object, Object, Object) : String;

Creates a new string from the concatenation of two specific strings.

[Visual Basic] Overloads Public Shared Function Concat(String, String) As String
[C#] public static string Concat(String, String);
[C++] public: static String* Concat(String*, String*);
[JScript] public static function Concat(String, String) : String;

Creates a new string from the concatenation of two specific strings.

[Visual Basic] Overloads Public Shared Function Concat(Object()) As String
[C#] public static string Concat(Object[]);
[C++] public: static String* Concat(Object*[]);
[JScript] public static function Concat(Object[]) : String;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function Concat(Object, Object, Object, Object) As String
[C#] public static string Concat(Object, Object, Object, Object);
[C++] public: static String* Concat(Object*, Object*, Object*, Object*);
[JScript] public static function Concat(Object, Object, Object, Object) : String;

Creates a new string from the concatenation of two specific strings.

[Visual Basic] Overloads Public Shared Function Concat(Object, Object) As String
[C#] public static string Concat(Object, Object);
[C++] public: static String* Concat(Object*, Object*);
[JScript] public static function Concat(Object, Object) : String;

A new string is created from the concatenation of two specific strings.

[Visual Basic] Overloads Public Shared Function Concat(Object) As String
[C#] public static string Concat(Object);
[C++] public: static String* Concat(Object*);
[JScript] public static function Concat(Object) : String;

Creates a new string from the concatenation of two specific strings.

[Visual Basic] Overloads Public Shared Function Concat(String()) As String
[C#] public static string Concat(String[]);
[C++] public: static String* Concat(String*[]);
[JScript] public static function Concat(String[]) : String;

Creates a new string from the concatenation of two specific strings.

[Visual Basic] Overloads Public Shared Function Concat(String, String, String) As String
[C#] public static string Concat(String, String, String);
[C++] public: static String* Concat(String*, String*, String*);
[JScript] public static function Concat(String, String, String) : String;

See Also

String Class | String Members | System Namespace


String.Concat (Object, Object, Object)

Creates a new string from the concatenation of three specific strings.

[Visual Basic]
Overloads Public Shared Function Concat( _
   ByVal arg0 As Object, _
   ByVal arg1 As Object, _
   ByVal arg2 As Object _
) As String
[C#]
public static string Concat(
   object arg0,
   object arg1,
   object arg2
);
[C++]
public: static String* Concat(
   Object* arg0,
   Object* arg1,
   Object* arg2
);
[JScript]
public static function Concat(
   arg0 : Object,
   arg1 : Object,
   arg2 : Object
) : String;

Parameters

arg0
The first object.
arg1
The second object.
arg2
The third object.

Return Value

The new string.

Remarks

The Concat method is used to create new strings from three specific prior existing objects. The empty string is inserted in place of any null strings.

See Also

String Class | String Members | System Namespace | String.Concat Overload List | Object


String.Concat (String, String)

Creates a new string from the concatenation of two specific strings.

[Visual Basic]
Overloads Public Shared Function Concat( _
   ByVal str0 As String, _
   ByVal str1 As String _
) As String
[C#]
public static string Concat(
   string str0,
   string str1
);
[C++]
public: static String* Concat(
   String* str0,
   String* str1
);
[JScript]
public static function Concat(
   str0 : String,
   str1 : String
) : String;

Parameters

str0
The first string.
str1
The second string.

Return Value

The new string.

Remarks

The Concat method is used to create new strings from two prior existing specified strings. The empty string is inserted in place of any null strings.

See Also

String Class | String Members | System Namespace | String.Concat Overload List


String.Concat (Object[])

Creates a new string from the concatenation of two specific strings.

[Visual Basic]
Overloads Public Shared Function Concat( _
   ByVal args() As Object _
) As String
[C#]
public static string Concat(
   object[] args
);
[C++]
public: static String* Concat(
   Object* args[]
);
[JScript]
public static function Concat(
   args : Object[]
) : String;

Parameters

args
The object.

Return Value

The new string.

Exceptions

Exception Type | Condition
ArgumentNullException | If the object is null.

Remarks

The Concat method is used to create new strings from several prior existing objects. The args parameter cannot be null or an exception is thrown.

See Also

String Class | String Members | System Namespace | String.Concat Overload List | Object


String.Concat (Object, Object, Object, Object)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function Concat( _
   ByVal arg0 As Object, _
   ByVal arg1 As Object, _
   ByVal arg2 As Object, _
   ByVal arg3 As Object _
) As String
[C#]
public static string Concat(
   object arg0,
   object arg1,
   object arg2,
   object arg3
);
[C++]
public: static String* Concat(
   Object* arg0,
   Object* arg1,
   Object* arg2,
   Object* arg3
);
[JScript]
public static function Concat(
   arg0 : Object,
   arg1 : Object,
   arg2 : Object,
   arg3 : Object
) : String;

Parameters

arg0
[To be supplied.]
arg1
[To be supplied.]
arg2
[To be supplied.]
arg3
[To be supplied.]

See Also

String Class | String Members | System Namespace | String.Concat Overload List


String.Concat (Object, Object)

Creates a new string from the concatenation of two specific strings.

[Visual Basic]
Overloads Public Shared Function Concat( _
   ByVal arg0 As Object, _
   ByVal arg1 As Object _
) As String
[C#]
public static string Concat(
   object arg0,
   object arg1
);
[C++]
public: static String* Concat(
   Object* arg0,
   Object* arg1
);
[JScript]
public static function Concat(
   arg0 : Object,
   arg1 : Object
) : String;

Parameters

arg0
The first object.
arg1
The second object.

Return Value

The new string.

Remarks

The Concat method is used to create new strings from two prior existing specified objects. The empty string is inserted in place of any null strings.

See Also

String Class | String Members | System Namespace | String.Concat Overload List | Object


String.Concat (Object)

A new string is created from the concatenation of two specific strings.

[Visual Basic]
Overloads Public Shared Function Concat( _
   ByVal arg0 As Object _
) As String
[C#]
public static string Concat(
   object arg0
);
[C++]
public: static String* Concat(
   Object* arg0
);
[JScript]
public static function Concat(
   arg0 : Object
) : String;

Parameters

arg0
The object to be concatentated.

Return Value

Returns a new string.

Remarks

The Concat method is used to create new strings from two prior existing specified objects. The empty string is inserted in place of any null strings.

See Also

String Class | String Members | System Namespace | String.Concat Overload List | Object


String.Concat (String[])

Creates a new string from the concatenation of two specific strings.

[Visual Basic]
Overloads Public Shared Function Concat( _
   ByVal values() As String _
) As String
[C#]
public static string Concat(
   string[] values
);
[C++]
public: static String* Concat(
   String* values[]
);
[JScript]
public static function Concat(
   values : String[]
) : String;

Parameters

values
The string to be concatenated.

Return Value

Returns a new string.

Remarks

The Concat method is used to create new strings from several prior existing strings. The empty string is inserted in place of any null strings.

See Also

String Class | String Members | System Namespace | String.Concat Overload List


String.Concat (String, String, String)

Creates a new string from the concatenation of two specific strings.

[Visual Basic]
Overloads Public Shared Function Concat( _
   ByVal str0 As String, _
   ByVal str1 As String, _
   ByVal str2 As String _
) As String
[C#]
public static string Concat(
   string str0,
   string str1,
   string str2
);
[C++]
public: static String* Concat(
   String* str0,
   String* str1,
   String* str2
);
[JScript]
public static function Concat(
   str0 : String,
   str1 : String,
   str2 : String
) : String;

Parameters

str0
The first string.
str1
The second string.
str2
The third string.

Return Value

The new string.

Remarks

The Concat method is used to create new strings from three prior existing specified strings. The empty string is inserted in place of any null strings.

See Also

String Class | String Members | System Namespace | String.Concat Overload List


String.Copy

Creates a new string by copying another string.

[Visual Basic]
Public Shared Function Copy( _
   ByVal str0 As String _
) As String
[C#]
public static string Copy(
   string str0
);
[C++]
public: static String* Copy(
   String* str0
);
[JScript]
public static function Copy(
   str0 : String
) : String;

Parameters

str0
The string to be copied

Return Value

The new string.

Remarks

The Copy method makes a duplicate of a specified string. If the value is null, a string is created that is initialized to null string.

See Also

String Class | String Members | System Namespace | MemberValueEnum | Empty | DBNull


String.CopyTo

Copies a specified number of characters from a specified location in this string to a specified location in an array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal sourceIndex As Integer, _
   ByVal destination() As Char, _
   ByVal destinationIndex As Integer, _
   ByVal count As Integer _
)
[C#]
public void CopyTo(
   int sourceIndex,
   char[] destination,
   int destinationIndex,
   int count
);
[C++]
public: void CopyTo(
   int sourceIndex,
   __wchar_t* destination[],
   int destinationIndex,
   int count
);
[JScript]
public function CopyTo(
   sourceIndex : int,
   destination : Char[],
   destinationIndex : int,
   count : int
);

Parameters

sourceIndex
The index in the string where to start copying.
destination
The array of characters to copy to.
destinationIndex
The index in the destination array where to start copying to.
count
The number of characters to copy.

Exceptions

Exception Type | Condition
ArgumentNullException | If the destination is null.
ArgumentOutOfRangeException | If soureIndex is not a valid index in this string.
ArgumentOutOfRangeException | If count and soureIndex is not a valid index in this string.
ArgumentOutOfRangeException | If destinationIndex is not a valid index in the array.
ArgumentOutOfRangeException | If count and destinationIndex is not a valid index in the array.
IndexOutOfRangeException | If the destination is not within the array.

Remarks

The CopyTo method determines the length of the string to be copied (sourceIndex plus the count), determines where to start coping the string (sourceIndex) from a specified location in this string, and copies the selected string to a specified location in an array (destinationIndex).

Only count characters are copied.

See Also

String Class | String Members | System Namespace | Char | Int32


String.EndsWith

Determines whether a specified string is a suffix of the current instance.

[Visual Basic]
Public Function EndsWith( _
   ByVal value As String _
) As Boolean
[C#]
public bool EndsWith(
   string value
);
[C++]
public: bool EndsWith(
   String* value
);
[JScript]
public function EndsWith(
   value : String
) : Boolean;

Parameters

value
The suffix to match.

Return Value

true if either value matches the end of this string or value is an empty string (i.e., equals Empty), otherwise false.

Exceptions

Exception Type | Condition
ArgumentNullException | If the suffix is null.

Remarks

The EndsWith method compares a specified string with this instance, determines whether this instance is a suffix and returns a Boolean representation of their relationship. The comparison is case-sensitive.

See Also

String Class | String Members | System Namespace


String.Equals

Determines whether two objects match.

Overload List

Determines whether this instance and a specified string match.

[Visual Basic] Overloads Public Shared Function Equals(String, String) As Boolean
[C#] public static bool Equals(String, String);
[C++] public: static bool Equals(String*, String*);
[JScript] public static function Equals(String, String) : Boolean;

Determines whether two strings match.

[Visual Basic] Overloads Shadows Public Function Equals(String) As Boolean
[C#] public new bool Equals(String);
[C++] public: new bool Equals(String*);
[JScript] public new function Equals(String) : Boolean;

Determines whether two objects, that are strings, match.

[Visual Basic] Overloads Overrides Public Function Equals(Object) As Boolean
[C#] public override bool Equals(Object);
[C++] public: override bool Equals(Object*);
[JScript] public override function Equals(Object) : Boolean;

See Also

String Class | String Members | System Namespace


String.Equals (String, String)

Determines whether this instance and a specified string match.

[Visual Basic]
Overloads Public Shared Function Equals( _
   ByVal a As String, _
   ByVal b As String _
) As Boolean
[C#]
public static bool Equals(
   string a,
   string b
);
[C++]
public: static bool Equals(
   String* a,
   String* b
);
[JScript]
public static function Equals(
   a : String,
   b : String
) : Boolean;

Parameters

a
A string to compare.
b
Another string to compare.

Return Value

Value | Condition
true | If both strings are case-sensitive and match exactly, otherwise false.
true | If both strings are null.

Remarks

The Equals method compares two strings (a and b) to determine whether they match exactly and returns a Boolean representation of their relationship. The comparison is case-sensitive. Otherwise it returns false.

If both strings are null, they are considered equal.

See Also

String Class | String Members | System Namespace | String.Equals Overload List


String.Equals (String)

Determines whether two strings match.

[Visual Basic]
Overloads Shadows Public Function Equals( _
   ByVal value As String _
) As Boolean
[C#]
public new bool Equals(
   string value
);
[C++]
public: new bool Equals(
   String* value
);
[JScript]
public new function Equals(
   value : String
) : Boolean;

Parameters

value
The value to be compared with this instance.

Return Value

Value | Condition
true | If value is a string, and if both value and this instance are a case-sensitive and match exactly.
false | If null.

Remarks

The Equals method compares two strings to determine whether they match exactly and returns a Boolean representation of their relationship. The comparison is case-sensitive. Both the value and this instance must meet the following conditions to be true:

  • The value must be a string.
  • The value and this instance must be case-sensitive.

See Also

String Class | String Members | System Namespace | String.Equals Overload List


String.Equals (Object)

Determines whether two objects, that are strings, match.

[Visual Basic]
Overloads Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The object to compare with this instance.

Return Value

Value | Condition
true | If the object is a string and if both the object and this instance are a case-sensitive exactly match, otherwise false.
false | If null.

Remarks

The Equals method compares two strings to determine whether they match exactly and returns a Boolean representation of their relationship. The comparison is case-sensitive. Both the object and this instance must meet the following conditions to be true:

  • The object must be a string.
  • The object and this instance must be case-sensitive.

See Also

String Class | String Members | System Namespace | String.Equals Overload List | Object


String.Format

Replaces zero or more format specifications with the appropriately formatted value of an object.

Overload List

Replaces zero or more format specifications with the appropriately formatted value of an object.

[Visual Basic] Overloads Public Shared Function Format(String, Object, Object, Object) As String
[C#] public static string Format(String, Object, Object, Object);
[C++] public: static String* Format(String*, Object, Object, Object);
[JScript] public static function Format(String, Object, Object, Object) : String;

Replaces zero or more format specifications with the appropriately formatted value of an object.

[Visual Basic] Overloads Public Shared Function Format(String, Object, Object) As String
[C#] public static string Format(String, Object, Object);
[C++] public: static String* Format(String*, Object, Object);
[JScript] public static function Format(String, Object, Object) : String;

Replaces zero or more format specifications with the appropriately formatted value of an object.

[Visual Basic] Overloads Public Shared Function Format(String, Object) As String
[C#] public static string Format(String, Object);
[C++] public: static String* Format(String*, Object);
[JScript] public static function Format(String, Object) : String;

Replaces zero or more format specifications with the appropriately formatted value of an object.

[Visual Basic] Overloads Public Shared Function Format(String, Object, Object, Object, Object) As String
[C#] public static string Format(String, Object, Object, Object, Object);
[C++] public: static String* Format(String*, Object, Object, Object, Object);
[JScript] public static function Format(String, Object, Object, Object, Object) : String;

Rreplaces zero or more format specifications with the appropriately formatted value of an object.

[Visual Basic] Overloads Public Shared Function Format(String, Object()) As String
[C#] public static string Format(String, Object[]);
[C++] public: static String* Format(String*, Object[]);
[JScript] public static function Format(String, Object[]) : String;

Replaces zero or more format specifications with the appropriately formatted value of an object.

[Visual Basic] Overloads Public Shared Function Format(String, Object(), IServiceObjectProvider) As String
[C#] public static string Format(String, Object[], IServiceObjectProvider);
[C++] public: static String* Format(String*, Object[], IServiceObjectProvider);
[JScript] public static function Format(String, Object[], IServiceObjectProvider) : String;

Example

If the string assigned to format is "Thank you for your purchase of {0:####} copies of Better Basket Weaving." and arg[0] is an Integer2 with the value 123, then the return value will be:

Note This example shows how to use one of the overloaded versions of Format. For other examples that may be available, see the individual overload topics.
"Thank you for your
purchase of 123 copies of Better Basket Weaving."
If the String
assigned to format is "Brad's dog has {0, -8:G}
fleas." and arg[0] is an Integer2 with the value
42, then the return value will be:
"Brad's dog has
42      fleas."

See Also

String Class | String Members | System Namespace


String.Format (String, Object, Object, Object)

Replaces zero or more format specifications with the appropriately formatted value of an object.

[Visual Basic]
Overloads Public Shared Function Format( _
   ByVal format As String, _
   ByVal arg0 As Object, _
   ByVal arg1 As Object, _
   ByVal arg2 As Object _
) As String
[C#]
public static string Format(
   string format,
   object arg0,
   object arg1,
   object arg2
);
[C++]
public: static String* Format(
   String* format,
   Object* arg0,
   Object* arg1,
   Object* arg2
);
[JScript]
public static function Format(
   format : String,
   arg0 : Object,
   arg1 : Object,
   arg2 : Object
) : String;

Parameters

format
A string containing zero or more format specifications.
arg0
The first object to be formatted.
arg1
The second object to be formatted.
arg2
The third object to be formatted.

Return Value

A copy of the string is returned after replacing any format specifications with the appropriately formatted value.

Exceptions

Exception Type | Condition
ArgumentNullException | If the string is null.
FormatException | If the string is invalid.

Remarks

The format specifications are embedded within a string and are of the form {N:FormatString}, where N is a zero-based number indicating the argument that is to be formatted and FormatString is a format string. If argN implements IFormattable then argN.Format (format, null) provides the formatting; otherwise argN.ToString() provides the formatting. If arg0, arg1 or arg2 is null then an empty string is used in its place.

To Pad With Spaces: It is possible to define a region within the string argument in which the formatted value can be left or right justified. The format specification has an optional integer field: {N[,M]:FormatString}. The magnitude of M indicates the minimum number of spaces for the region and the sign of M indicates whether the value should be left (negative values) or right (positive values) justified within the region.

ToString() is Used if the Format String is Omitted: The format string within a format specification is optional: {N[,M][:FormatString]}. When FormatString is omitted, the ToString() method of the argument specified by N is used to replace the format specification. If M is given, then the result of ToString() is padded with spaces as described above.

Example

If the string assigned to format is "Thank you for your purchase of {0:####} copies of Better Basket Weaving." and arg0 is an Int16 with the value 123, then the return value will be:

"Thank you for your purchase of 123 copies of Better Basket Weaving."

If the String assigned to format is "Brad's dog has {0, -8:G} fleas." and arg0 is an Int16 with the value 42,
then the return value will be:
"Brad's dog has 42 fleas."

See Also

String Class | String Members | System Namespace | String.Format Overload List | Object | IFormattable


String.Format (String, Object, Object)

Replaces zero or more format specifications with the appropriately formatted value of an object.

[Visual Basic]
Overloads Public Shared Function Format( _
   ByVal format As String, _
   ByVal arg0 As Object, _
   ByVal arg1 As Object _
) As String
[C#]
public static string Format(
   string format,
   object arg0,
   object arg1
);
[C++]
public: static String* Format(
   String* format,
   Object* arg0,
   Object* arg1
);
[JScript]
public static function Format(
   format : String,
   arg0 : Object,
   arg1 : Object
) : String;

Parameters

format
A string containing zero or more format specifications.
arg0
The first object to be formatted.
arg1
The second object to be formatted.

Return Value

A copy of the string is returned after replacing any format specifications with the appropriately formatted value.

Exceptions

Exception Type | Condition
ArgumentNullException | If the string is null.
FormatException | If string is invalid.

Remarks

The format specifications are embedded within a String and are of the form {N:FormatString}, where N is a zero-based number indicating the argument that is to be formatted and FormatString is a format string. If argN implements IFormattable then argN.Format (format, null) provides the formatting; otherwise argN.ToString() provides the formatting. If arg0 or arg1 is null then an empty string is used in its place.

To Pad With Spaces: It is possible to define a region within the String argument in which the formatted value can be left or right justified. The format specification has an optional integer field: {N[,M]:FormatString}. The magnitude of M indicates the minimum number of spaces for the region and the sign of M indicates whether the value should be left (negative values) or right (positive values) justified within the region.

ToString() is Used if the Format String is Omitted: The format string within a format specification is optional: {N[,M][:FormatString]}. When FormatString is omitted, the ToString() method of the argument specified by N is used to replace the format specification. If M is given, then the result of ToString() is padded with spaces as described above.

Example

If the String assigned to format is "Thank you for your purchase of {0:####} copies of Better Basket Weaving." and arg0 is an Int16 with the value 123, then the return value will be:

"Thank you for your purchase of 123 copies of Better Basket Weaving."
If the String assigned to format is "Brad's dog has {0, -8:G} fleas." and arg0 is an Int16 with the value 42,
then the return value will be:
"Brad's dog has 42
fleas."

See Also

String Class | String Members | System Namespace | String.Format Overload List | Object | IFormattable


String.Format (String, Object)

Replaces zero or more format specifications with the appropriately formatted value of an object.

[Visual Basic]
Overloads Public Shared Function Format( _
   ByVal format As String, _
   ByVal arg0 As Object _
) As String
[C#]
public static string Format(
   string format,
   object arg0
);
[C++]
public: static String* Format(
   String* format,
   Object* arg0
);
[JScript]
public static function Format(
   format : String,
   arg0 : Object
) : String;

Parameters

format
A string containing zero or more format specifications.
arg0
An object to be formatted.

Return Value

A copy of format is returned after replacing any format specifications with the appropriately formatted value.

Exceptions

Exception Type | Condition
ArgumentNullException | If the string is null.
FormatException | If the string is invalid.

Remarks

The format specifications are embedded within a string and are of the form {N:FormatString}, where N is a zero-based number indicating the argument that is to be formatted and FormatString is a format string. If arg0 implements IFormattable, then arg0.Format (FormatString, null) provides the formatting; otherwise arg0.ToString() provides the formatting. If arg0 is null then an empty string is used in its place.

To Pad With Spaces: It is possible to define a region within the string argument in which the formatted value can be left or right justified. The format specification has an optional integer field: {N[,M]:FormatString}. The magnitude of M indicates the minimum number of spaces for the region and the sign of M indicates whether the value should be left (negative values) or right (positive values) justified within the region.

ToString() is Used if the Format String is Omitted: The format string within a format specification is optional: {N[,M][:FormatString]}. When FormatString is omitted, the ToString() method of the argument specified by N is used to replace the format specification. If M is given, then the result of ToString() is padded with spaces as described above.

Example

If the string assigned to format is "Thank you for your purchase of {0:####} copies of Better Basket Weaving." and arg0 is an Int16 with the value 123, then the return value will be

"Thank you for your purchase of 123 copies of Better Basket Weaving."
If the String assigned to format is
"Brad's dog has {0, -8:G} fleas." and arg0
is an Int16 with the value 42, then the return value will be
"Brad's dog has 42
fleas."

See Also

String Class | String Members | System Namespace | String.Format Overload List | Object | IFormattable


String.Format (String, Object, Object, Object, Object)

Replaces zero or more format specifications with the appropriately formatted value of an object.

[Visual Basic]
Overloads Public Shared Function Format( _
   ByVal format As String, _
   ByVal arg0 As Object, _
   ByVal arg1 As Object, _
   ByVal arg2 As Object, _
   ByVal arg3 As Object _
) As String
[C#]
public static string Format(
   string format,
   object arg0,
   object arg1,
   object arg2,
   object arg3
);
[C++]
public: static String* Format(
   String* format,
   Object* arg0,
   Object* arg1,
   Object* arg2,
   Object* arg3
);
[JScript]
public static function Format(
   format : String,
   arg0 : Object,
   arg1 : Object,
   arg2 : Object,
   arg3 : Object
) : String;

Parameters

format
A string containing zero or more format specifications.
arg0
The first object to be formatted.
arg1
The second object to be formatted.
arg2
The third object to be formatted.
arg3
The fourth object to be formatted.

Return Value

A copy of the string is returned after replacing any format specifications with the appropriately formatted value.

Exceptions

Exception Type | Condition
ArgumentNullException | If the string is null.
FormatException | If the string is invalid.

Remarks

The Format method replaces zero or more format specifications with the appropriately formatted value of an object. The format specifications are embedded within a string and are of the form {N:FormatString}, where N is a zero-based number indicating the argument that is to be formatted and FormatString is a format string. If argN implements IFormattable then argN.Format (format, null) provides the formatting; otherwise argN.ToString() provides the formatting. If arg0, arg1, arg2, or arg3 is null then an empty string is used in its place.

To Pad With Spaces: It is possible to define a region within the string argument in which the formatted value can be left or right justified. The format specification has an optional integer field: {N[,M]:FormatString}. The magnitude of M indicates the minimum number of spaces for the region and the sign of M indicates whether the value should be left (negative values) or right (positive values) justified within the region.

ToString() is Used if the Format String is Omitted: The format string within a format specification is optional: {N[,M][:FormatString]}. When FormatString is omitted, the ToString() method of the argument specified by N is used to replace the format specification. If M is given, then the result of ToString() is padded with spaces as described above.

Example

If the string assigned to format is "Thank you for your purchase of {0:####} copies of Better Basket Weaving." and arg0 is an Int16 with the value 123, then the return value will be:

"Thank you for your purchase of 123 copies of Better Basket Weaving."
If the String assigned to format is "Brad's dog has {0, -8:G} fleas." and arg0 is an Int16 with the value 42,
then the return value will be:
"Brad's dog has 42 fleas."

See Also

String Class | String Members | System Namespace | String.Format Overload List | Object | IFormattable


String.Format (String, Object[])

Rreplaces zero or more format specifications with the appropriately formatted value of an object.

[Visual Basic]
Overloads Public Shared Function Format( _
   ByVal format As String, _
   ByVal args() As Object _
) As String
[C#]
public static string Format(
   string format,
   object[] args
);
[C++]
public: static String* Format(
   String* format,
   Object* args[]
);
[JScript]
public static function Format(
   format : String,
   args : Object[]
) : String;

Parameters

format
A string containing zero or more format specifications, as described above.
args
An array of objects to be formatted.

Return Value

A copy of the string is returned after replacing any format specifications with the appropriately formatted value.

Exceptions

Exception Type | Condition
ArgumentNullException | If the string or array of objects are null.
FormatException | If the string is invalid.

Remarks

The format specifications are embedded within a string and are of the form {N:FormatString}, where N is a zero-based number indicating the argument that is to be formatted and FormatString is a format string. If args[N] implements IFormattable then args[N].Format (format, null) provides the formatting; otherwise args[N].ToString() provides the formatting. If args[N] is null then an empty string is used in its place.

To Pad With Spaces: It is possible to define a region within the string argument in which the formatted value can be left or right justified. The format specification has an optional integer field: {N[,M]:FormatString}. The magnitude of M indicates the minimum number of spaces for the region and the sign of M indicates whether the value should be left (negative values) or right (positive values) justified within the region.

ToString() is Used if the Format String is Omitted: The format string within a format specification is optional: {N[,M][:FormatString]}. When FormatString is omitted, the ToString() method of the argument specified by N is used to replace the format specification. If M is given, then the result of ToString() is padded with spaces as described above.

Example

If the string assigned to format is "Thank you for your purchase of {0:####} copies of Better Basket Weaving." and arg[0] is an Int16 with the value 123, then the return value will be:

"Thank you for your purchase of
123 copies of Better Basket Weaving."
If the String assigned to format is "Brad's dog has {0, -8:G} fleas." and arg[0] is an Int16 with the value 42, then the return value
will be:
"Brad's dog has 42 fleas."

See Also

String Class | String Members | System Namespace | String.Format Overload List | Object | IFormattable


String.Format (String, Object[], IServiceObjectProvider)

Replaces zero or more format specifications with the appropriately formatted value of an object.

[Visual Basic]
Overloads Public Shared Function Format( _
   ByVal format As String, _
   ByVal args() As Object, _
   ByVal sop As IServiceObjectProvider _
) As String
[C#]
public static string Format(
   string format,
   object[] args,
   IServiceObjectProvider sop
);
[C++]
public: static String* Format(
   String* format,
   Object* args[],
   IServiceObjectProvider* sop
);
[JScript]
public static function Format(
   format : String,
   args : Object[],
   sop : IServiceObjectProvider
) : String;

Parameters

format
A string containing zero or more format specifications.
args
An array of objects to be formatted.
sop
The IServiceObjectProvider interface used to change the way in which formatting codes are interpreted by a type.

Return Value

A copy of the string is returned after replacing any format specifications with the appropriately formatted value.

Exceptions

Exception Type | Condition
ArgumentNullException | If the string or objects are null.
FormatException | If the string is invalid.

Remarks

The format specifications are embedded within a string and are of the form {N:FormatString}, where N is a zero-based number indicating the argument that is to be formatted and FormatString is a format string. If args[N] implements IFormattable then args[N].Format (format, null) provides the formatting; otherwise args[N].ToString() provides the formatting. If args[N] is null then an empty string is used in its place.

The so p parameter specifies the format provider from which the NumberFormatInfo instance will be obtained. NumberFormatInfo supplies information such as the characters to be used for decimal and group separators, and determines the spelling and placement of currency symbols in monetary values. If sop is null, the numeric format information is obtained from the current locale.

To Pad With Spaces: It is possible to define a region within the String argument in which the formatted value can be left or right justified. The format specification has an optional integer field: {N[,M]:FormatString}. The magnitude of M indicates the minimum number of spaces for the region and the sign of M indicates whether the value should be left (negative values) or right (positive values) justified within the region.

ToString() is Used if the Format String is Omitted: The format string within a format specification is optional: {N[,M][:FormatString]}. When FormatString is omitted, the ToString() method of the argument specified by N is used to replace the format specification. If M is given, then the result of ToString() is padded with spaces as described above.

Example

If the string assigned to format is "Thank you for your purchase of {0:####} copies of Better Basket Weaving." and arg[0] is an Integer2 with the value 123, then the return value will be:

"Thank you for your
purchase of 123 copies of Better Basket Weaving."
If the String
assigned to format is "Brad's dog has {0, -8:G}
fleas." and arg[0] is an Integer2 with the value
42, then the return value will be:
"Brad's dog has
42      fleas."

See Also

String Class | String Members | System Namespace | String.Format Overload List | Object | IFormattable | IServiceObjectProvider


String.GetHashCode

Gets a hash code for this string.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

A hash code for this string.

Remarks

If strings A and B are such that A.Equals(B), then they will return the same hash code. (For more information, see GetHashCode.)

See Also

String Class | String Members | System Namespace | Int32


String.GetTypeCode

Retrieves the type code of an object.

[Visual Basic]
Overridable Public Function GetTypeCode() As TypeCode
[C#]
public virtual TypeCode GetTypeCode();
[C++]
public: virtual TypeCode GetTypeCode();
[JScript]
public function GetTypeCode() : TypeCode;

Return Value

A type code.

Remarks

The GetTypeCode method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See TypeCode enumeration for more information about type codes.)

See Also

String Class | String Members | System Namespace | IConvertible


String.IndexOf

Returns the index of the first occurrence.

Overload List

Returns the index of the first occurrence of the character in the current instance.

[Visual Basic] Overloads Public Function IndexOf(Char) As Integer
[C#] public int IndexOf(char);
[C++] public: int IndexOf(__wchar_t);
[JScript] public function IndexOf(Char) : int;

Returns the index of the first occurrence of the charcter in the current instance.

[Visual Basic] Overloads Public Function IndexOf(Char, Integer) As Integer
[C#] public int IndexOf(char, int);
[C++] public: int IndexOf(__wchar_t, int);
[JScript] public function IndexOf(Char, int) : int;

Returns the index of the first occurrence of the character in the current instance.

[Visual Basic] Overloads Public Function IndexOf(Char, Integer, Integer) As Integer
[C#] public int IndexOf(char, int, int);
[C++] public: int IndexOf(__wchar_t, int, int);
[JScript] public function IndexOf(Char, int, int) : int;

Determines the position within this string of the first occurrence of the specified string.

[Visual Basic] Overloads Public Function IndexOf(String) As Integer
[C#] public int IndexOf(String);
[C++] public: int IndexOf(String*);
[JScript] public function IndexOf(String) : int;

Determines the position within this string of the first occurrence of the specified string.

[Visual Basic] Overloads Public Function IndexOf(String, Integer) As Integer
[C#] public int IndexOf(String, int);
[C++] public: int IndexOf(String*, int);
[JScript] public function IndexOf(String, int) : int;

Determines the position within this string of the first occurrence of the specified string.

[Visual Basic] Overloads Public Function IndexOf(String, Integer, Integer) As Integer
[C#] public int IndexOf(String, int, int);
[C++] public: int IndexOf(String*, int, int);
[JScript] public function IndexOf(String, int, int) : int;

Returns the index of the first occurrence of any character in the character array in the current instance.

[Visual Basic] Overloads Public Function IndexOf(Char()) As Integer
[C#] public int IndexOf(char[]);
[C++] public: int IndexOf(__wchar_t*[]);
[JScript] public function IndexOf(Char[]) : int;

Returns the index of the first occurrence of any character in a character array in the current instance.

[Visual Basic] Overloads Public Function IndexOf(Char(), Integer) As Integer
[C#] public int IndexOf(char[], int);
[C++] public: int IndexOf(__wchar_t*[], int);
[JScript] public function IndexOf(Char[], int) : int;

Returns the index of the first occurrence of any character in value in the current instance.

[Visual Basic] Overloads Public Function IndexOf(Char(), Integer, Integer) As Integer
[C#] public int IndexOf(char[], int, int);
[C++] public: int IndexOf(__wchar_t*[], int, int);
[JScript] public function IndexOf(Char[], int, int) : int;

See Also

String Class | String Members | System Namespace


String.IndexOf (Char)

Returns the index of the first occurrence of the character in the current instance.

[Visual Basic]
Overloads Public Function IndexOf( _
   ByVal value As Char _
) As Integer
[C#]
public int IndexOf(
   char value
);
[C++]
public: int IndexOf(
   __wchar_t value
);
[JScript]
public function IndexOf(
   value : Char
) : int;

Parameters

value
The character to search for.

Return Value

Value | Condition
The index in the string | If the character is found.
-1 | If the character is not found.

Remarks

The IndexOf method performs a search for the first occurance of the character and marks it as an index. The search is case-sensitive and begins the indexing at zero.

See Also

String Class | String Members | System Namespace | String.IndexOf Overload List | Int32 | Char


String.IndexOf (Char, Int32)

Returns the index of the first occurrence of the charcter in the current instance.

[Visual Basic]
Overloads Public Function IndexOf( _
   ByVal value As Char, _
   ByVal startIndex As Integer _
) As Integer
[C#]
public int IndexOf(
   char value,
   int startIndex
);
[C++]
public: int IndexOf(
   __wchar_t value,
   int startIndex
);
[JScript]
public function IndexOf(
   value : Char,
   startIndex : int
) : int;

Parameters

value
The character to search for.
startIndex
The position in the current instance to start searching.

Return Value

Value | Condition
The index in the string | If value is found.
-1 | If value is not found.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | If the starting index is less than zero or greater than the length of the string.

Remarks

The IndexOf method performs a search for the first occurance of the character and marks it as an index. The search begins at the specified position and continues until the end of the string. The search is case-sensitive and begins the indexing at zero.

See Also

String Class | String Members | System Namespace | String.IndexOf Overload List | Int32 | Char


String.IndexOf (Char, Int32, Int32)

Returns the index of the first occurrence of the character in the current instance.

[Visual Basic]
Overloads Public Function IndexOf( _
   ByVal value As Char, _
   ByVal startIndex As Integer, _
   ByVal endIndex As Integer _
) As Integer
[C#]
public int IndexOf(
   char value,
   int startIndex,
   int endIndex
);
[C++]
public: int IndexOf(
   __wchar_t value,
   int startIndex,
   int endIndex
);
[JScript]
public function IndexOf(
   value : Char,
   startIndex : int,
   endIndex : int
) : int;

Parameters

value
The character to search for.
startIndex
The index in the current instance where to start searching.
endIndex
The index in the current instance where to stop searching.

Return Value

Value | Condition
The index in the string | If value is found.
-1 | If value is not found.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | If either index is less than zero or greater than the length of the string.
ArgumentOutOfRangeException | If the ending index is less than the start index.

Remarks

The IndexOf method performs a search for the first occurance of the character and marks it as an index. The search begins at the specified position and continues until the end of the string (startIndex and runs to endIndex-1 (startIndex, endIndex)). The character at the position at the end of the index is not included in the search. The search is case-sensitive and begins the indexing at zero.

See Also

String Class | String Members | System Namespace | String.IndexOf Overload List | Int32


String.IndexOf (String)

Determines the position within this string of the first occurrence of the specified string.

[Visual Basic]
Overloads Public Function IndexOf( _
   ByVal value As String _
) As Integer
[C#]
public int IndexOf(
   string value
);
[C++]
public: int IndexOf(
   String* value
);
[JScript]
public function IndexOf(
   value : String
) : int;

Parameters

value
The string to search for.

Return Value

Value | Condition
The position | If the string is found.
The position search began | If the string is the empty string.
-1 | If the string is not found.

Exceptions

Exception Type | Condition
ArgumentNullException | If the string is null.

Remarks

The IndexOf method searches for a specified string and returns the index. The search begins at the first character of this string. The search is case-sensitive, CultureInfo sensitive, and the default locale is used. This method returns the CurrentCulture information.

The value parameter returns the position from where search commenced if value is the empty string (see Empty).

See Also

String Class | String Members | System Namespace | String.IndexOf Overload List | Int32


String.IndexOf (String, Int32)

Determines the position within this string of the first occurrence of the specified string.

[Visual Basic]
Overloads Public Function IndexOf( _
   ByVal value As String, _
   ByVal startIndex As Integer _
) As Integer
[C#]
public int IndexOf(
   string value,
   int startIndex
);
[C++]
public: int IndexOf(
   String* value,
   int startIndex
);
[JScript]
public function IndexOf(
   value : String,
   startIndex : int
) : int;

Parameters

value
The string to search for.
startIndex
The position to begin the search.

Return Value

Value | Condition
The position | If the string is found.
The position search began | If the string is the empty string.
-1 | If the string is not found.

Exceptions

Exception Type | Condition
ArgumentNullException | If the string is null.
ArgumentOutOfRangeException | If the start position is not a valid position in this string.

Remarks

The IndexOf method searches for a specified string from the specified starting position and returns the index. The search begins at the first character of this string; it is case-sensitive, CultureInfo sensitive, and the default locale is used. This method returns the CurrentCulture information.

The value parameter returns the position from where search commenced if value is the empty string (see Empty).

See Also

String Class | String Members | System Namespace | String.IndexOf Overload List | Int32


String.IndexOf (String, Int32, Int32)

Determines the position within this string of the first occurrence of the specified string.

[Visual Basic]
Overloads Public Function IndexOf( _
   ByVal value As String, _
   ByVal startIndex As Integer, _
   ByVal endIndex As Integer _
) As Integer
[C#]
public int IndexOf(
   string value,
   int startIndex,
   int endIndex
);
[C++]
public: int IndexOf(
   String* value,
   int startIndex,
   int endIndex
);
[JScript]
public function IndexOf(
   value : String,
   startIndex : int,
   endIndex : int
) : int;

Parameters

value
The string to search for.
startIndex
The position to begin the search.
endIndex
The position to stop searching.

Return Value

Value | Condition
The position | If the string is found.
The position search began | If the string is the empty string.
-1 | If the string is not found.

Exceptions

Exception Type | Condition
ArgumentNullException | If the string is null .
ArgumentOutOfRangeException | If the start position is not a valid position of this string.
ArgumentOutOfRangeException | If end position is less than zero or greater than the length of this string plus one.

Remarks

The IndexOf method searches for a specified string from the specified starting position and returns the index. The search begins at the first character of this string (startIndex) and ends at the end of the specified position (endIndex). It is case-sensitive, CultureInfo sensitive, and the default locale is used. This method returns the CurrentCulture information.

The value parameter returns the position from where search commenced if value is the empty string (see Empty).

See Also

String Class | String Members | System Namespace | String.IndexOf Overload List | Int32


String.IndexOf (Char[])

Returns the index of the first occurrence of any character in the character array in the current instance.

[Visual Basic]
Overloads Public Function IndexOf( _
   ByVal value() As Char _
) As Integer
[C#]
public int IndexOf(
   char[] value
);
[C++]
public: int IndexOf(
   __wchar_t* value[]
);
[JScript]
public function IndexOf(
   value : Char[]
) : int;

Parameters

value
A character array containing all of the characters to search for.

Return Value

Value | Condition
The index in the string | If the character array is found.
-1 | If the character array is not found.

Exceptions

Exception Type | Condition
ArgumentNullException | If the character array is null.

Remarks

The IndexOf method searches for a specified character array and returns the index. The search is case-sensitive and begins at index 0.

See Also

String Class | String Members | System Namespace | String.IndexOf Overload List | Int32


String.IndexOf (Char[], Int32)

Returns the index of the first occurrence of any character in a character array in the current instance.

[Visual Basic]
Overloads Public Function IndexOf( _
   ByVal value() As Char, _
   ByVal startIndex As Integer _
) As Integer
[C#]
public int IndexOf(
   char[] value,
   int startIndex
);
[C++]
public: int IndexOf(
   __wchar_t* value[],
   int startIndex
);
[JScript]
public function IndexOf(
   value : Char[],
   startIndex : int
) : int;

Parameters

value
A character array containing all of the characters to search for.
startIndex
The position in the current instance to start searching.

Return Value

Value | Condition
The index in the string | If the character array is found.
-1 | If the character array is not found.

Exceptions

Exception Type | Condition
ArgumentNullException | If the character array is null.
ArgumentOutOfRangeException | If the starting index is less than zero or greater than the length of the string.

Remarks

The IndexOf method searches for a specified character array at a specified position and returns the index. The search starts at startIndex and continues until the end of the string. The search is case-sensitive.

See Also

String Class | String Members | System Namespace | String.IndexOf Overload List | Int32


String.IndexOf (Char[], Int32, Int32)

Returns the index of the first occurrence of any character in value in the current instance.

[Visual Basic]
Overloads Public Function IndexOf( _
   ByVal value() As Char, _
   ByVal startIndex As Integer, _
   ByVal endIndex As Integer _
) As Integer
[C#]
public int IndexOf(
   char[] value,
   int startIndex,
   int endIndex
);
[C++]
public: int IndexOf(
   __wchar_t* value[],
   int startIndex,
   int endIndex
);
[JScript]
public function IndexOf(
   value : Char[],
   startIndex : int,
   endIndex : int
) : int;

Parameters

value
A character array containing all of the characters to search for.
startIndex
The position in the current instance to start searching.
endIndex
The position in the current instance to stop searching.

Return Value

Value | Condition
The index in the string | If the character is found.
-1 | If the character is not found.

Exceptions

Exception Type | Condition
ArgumentNullException | If the character is null.
ArgumentOutOfRangeException | If beginning position or the end position is less than zero or greater than the length of the string.
ArgumentOutOfRangeException | If the end position is less than the beginning position.

Remarks

The IndexOf method searches for a specified character array at a specified position and returns the index. The search starts at the beginning position (startIndex) and runs to the end position (endIndex-1 (startIndex, endIndex)). The search is case-sensitive. The character at the position of endIndex is not included in the search.

See Also

String Class | String Members | System Namespace | String.IndexOf Overload List | Int32


String.Insert

Returns a new string with a specified value inserted at a specified position in this string.

[Visual Basic]
Public Function Insert( _
   ByVal startIndex As Integer, _
   ByVal value As String _
) As String
[C#]
public string Insert(
   int startIndex,
   string value
);
[C++]
public: String* Insert(
   int startIndex,
   String* value
);
[JScript]
public function Insert(
   startIndex : int,
   value : String
) : String;

Parameters

startIndex
The position to start inserting.
value
The string to insert.

Return Value

A new string with the string inserted at position of this string.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | If the beginning position is not within the range of this instance.
ArgumentOutOfRangeException | If the string is null.

Remarks

The Insert method makes a new string by inserting a specified string (value) at a specified location (startIndex) in this string.

See Also

String Class | String Members | System Namespace


String.Intern

Retrieves the reference for the string.

[Visual Basic]
Public Shared Function Intern( _
   ByVal str As String _
) As String
[C#]
public static string Intern(
   string str
);
[C++]
public: static String* Intern(
   String* str
);
[JScript]
public static function Intern(
   str : String
) : String;

Parameters

str
The string to be interned.

Return Value

The reference to the string.

Exceptions

Exception Type | Condition
ArgumentNullException | If the string is null.

Remarks

The Intern method looks up the string in a table of string identities of AppDomain. It is used primarily for constants and returns a reference to the "official" copy of the string.

All literal strings in the program are automatically interned. The only strings that need to be interned are those that are passed by arguments or generated by the code. String interning is useful when you are creating strings on the fly.

The code below generates a one new String ("FooBar"), using the StringBuilder, and is put into the string intern pool. The string "FooBar" has already been interned because it is a literal in our program, so a reference to it returned from the String.Itern method. The string that is passed to String.Intern (s2) has the same value, but is a different object than the one that is returned (s3).

String s2 = new StringBuilder().Append("Foo").Append("Bar").ToString();

String s3 =String.Intern(s2);

String s = "FooBar";

Console.WriteLine((Object)s2==(Object)s);//Should be different.

Console.WriteLine((Object)s3==(Object)s);//Should be the same; the appropriate value is pulled from the String interning pool.

Note that the C# compiler will concatenate the first two strings while compiling so there is no need to do any explicit string interning.

The other relevant method is IsInterned. This takes a string as an argument. If that string has already been interned, it returns a reference to the interned object; otherwise it returns null.

Note that if the string is null, it will cause an exception to be thrown.

See Also

String Class | String Members | System Namespace


String.IsInterned

Retrieves the reference for the string.

[Visual Basic]
Public Shared Function IsInterned( _
   ByVal str As String _
) As String
[C#]
public static string IsInterned(
   string str
);
[C++]
public: static String* IsInterned(
   String* str
);
[JScript]
public static function IsInterned(
   str : String
) : String;

Parameters

str
The string to be interned.

Return Value

The reference to the string.

Exceptions

Exception Type | Condition
ArgumentNullException | Iif the string is null.

Remarks

The Intern method looks up the string in a table of string identities of AppDomain. It is used primarily for constants and returns a reference to the "official" copy of the string. This takes a string as an argument. If that string has already been interned, it returns a reference to the interned object; otherwise it returns null.

Note that if the string is null, it will cause an exception to be thrown.

The other relevant method is Intern.

See Also

String Class | String Members | System Namespace


String.Join

[To be supplied.]

Overload List

Joins an array of strings together as one string with a separator between each original string.

[Visual Basic] Overloads Public Shared Function Join(String, String()) As String
[C#] public static string Join(String, String[]);
[C++] public: static String* Join(String*, String*[]);
[JScript] public static function Join(String, String[]) : String;

Joins an array of strings together as one string with a separator between each original string, starting at the specification location in the array.

[Visual Basic] Overloads Public Shared Function Join(String, String(), Integer, Integer) As String
[C#] public static string Join(String, String[], int, int);
[C++] public: static String* Join(String*, String*[], int, int);
[JScript] public static function Join(String, String[], int, int) : String;

See Also

String Class | String Members | System Namespace


String.Join (String, String[])

Joins an array of strings together as one string with a separator between each original string.

[Visual Basic]
Overloads Public Shared Function Join( _
   ByVal separator As String, _
   ByVal value() As String _
) As String
[C#]
public static string Join(
   string separator,
   string[] value
);
[C++]
public: static String* Join(
   String* separator,
   String* value[]
);
[JScript]
public static function Join(
   separator : String,
   value : String[]
) : String;

Parameters

separator
The string used as a separator.
value
The array of strings to be joined.

Return Value

The string that consists of the strings that are connected by the separator.

Exceptions

Exception Type | Condition
ArgumentNullException | If value is a null reference (in Visual Basic Nothing).

Remarks

The Join method forms an array by connecting an array of strings (value) and a separator (separator) between each string. The separator is a string.

See Also

String Class | String Members | System Namespace | String.Join Overload List


String.Join (String, String[], Int32, Int32)

Joins an array of strings together as one string with a separator between each original string, starting at the specification location in the array.

[Visual Basic]
Overloads Public Shared Function Join( _
   ByVal separator As String, _
   ByVal value() As String, _
   ByVal startIndex As Integer, _
   ByVal count As Integer _
) As String
[C#]
public static string Join(
   string separator,
   string[] value,
   int startIndex,
   int count
);
[C++]
public: static String* Join(
   String* separator,
   String* value[],
   int startIndex,
   int count
);
[JScript]
public static function Join(
   separator : String,
   value : String[],
   startIndex : int,
   count : int
) : String;

Parameters

separator
The string used as a separator.
value
The array of strings to be joined.
startIndex
The position within the array to start using strings.
count
The number of strings to take from the array.

Return Value

A string that consists of the strings in value joined by the separator.

Remarks

This Join method makes a string that consists of the strings contained in value, starting at the position indicated by startIndex and removing a predetermined number of strings (startIndex to startIndex plus count), then joining them together to form a single string with each of the original strings separated by separator.

See Also

String Class | String Members | System Namespace | String.Join Overload List


String.LastIndexOf

Gets the position of the last occurrence of the specified character in this string.

Overload List

Returns the index of the last occurrence of any character in the character array of the current instance.

[Visual Basic] Overloads Public Function LastIndexOf(Char()) As Integer
[C#] public int LastIndexOf(char[]);
[C++] public: int LastIndexOf(__wchar_t*[]);
[JScript] public function LastIndexOf(Char[]) : int;

Returns the index of the last occurrence of any character in the character array of the current instance.

[Visual Basic] Overloads Public Function LastIndexOf(Char(), Integer) As Integer
[C#] public int LastIndexOf(char[], int);
[C++] public: int LastIndexOf(__wchar_t*[], int);
[JScript] public function LastIndexOf(Char[], int) : int;

Gets the position of the last occurrence of the specified character in this string.

[Visual Basic] Overloads Public Function LastIndexOf(Char, Integer) As Integer
[C#] public int LastIndexOf(char, int);
[C++] public: int LastIndexOf(__wchar_t, int);
[JScript] public function LastIndexOf(Char, int) : int;

Returns the index of the last occurrence of the specified character in this string.

[Visual Basic] Overloads Public Function LastIndexOf(Char, Integer, Integer) As Integer
[C#] public int LastIndexOf(char, int, int);
[C++] public: int LastIndexOf(__wchar_t, int, int);
[JScript] public function LastIndexOf(Char, int, int) : int;

Returns the index of the last occurrence of the string in the current instance.

[Visual Basic] Overloads Public Function LastIndexOf(String) As Integer
[C#] public int LastIndexOf(String);
[C++] public: int LastIndexOf(String*);
[JScript] public function LastIndexOf(String) : int;

Returns the index of the last occurrence of the string in the current instance.

[Visual Basic] Overloads Public Function LastIndexOf(String, Integer, Integer) As Integer
[C#] public int LastIndexOf(String, int, int);
[C++] public: int LastIndexOf(String*, int, int);
[JScript] public function LastIndexOf(String, int, int) : int;

Returns the index of the last occurrence of any character in the character array of the current instance.

[Visual Basic] Overloads Public Function LastIndexOf(Char(), Integer, Integer) As Integer
[C#] public int LastIndexOf(char[], int, int);
[C++] public: int LastIndexOf(__wchar_t*[], int, int);
[JScript] public function LastIndexOf(Char[], int, int) : int;

Returns the index of the last occurrence of the string in the current instance.

[Visual Basic] Overloads Public Function LastIndexOf(String, Integer) As Integer
[C#] public int LastIndexOf(String, int);
[C++] public: int LastIndexOf(String*, int);
[JScript] public function LastIndexOf(String, int) : int;

Gets the position of the last occurrence of the specified character in this string.

[Visual Basic] Overloads Public Function LastIndexOf(Char) As Integer
[C#] public int LastIndexOf(char);
[C++] public: int LastIndexOf(__wchar_t);
[JScript] public function LastIndexOf(Char) : int;

See Also

String Class | String Members | System Namespace


String.LastIndexOf (Char[])

Returns the index of the last occurrence of any character in the character array of the current instance.

[Visual Basic]
Overloads Public Function LastIndexOf( _
   ByVal value() As Char _
) As Integer
[C#]
public int LastIndexOf(
   char[] value
);
[C++]
public: int LastIndexOf(
   __wchar_t* value[]
);
[JScript]
public function LastIndexOf(
   value : Char[]
) : int;

Parameters

value
The character array containing all of the characters to search for.

Return Value

Value | Condition
The index in the string | If the charater array is found.
-1 | If the charater array is not found.

Exceptions

Exception Type | Condition
ArgumentNullException | If the charater array is null.

Remarks

The LastIndexOf method returns the position of the last instance of the specified character array in the string. This string is traversed backwards from right to left. The search is case-sensitive.

See Also

String Class | String Members | System Namespace | String.LastIndexOf Overload List | Char | Int32 | Array


String.LastIndexOf (Char[], Int32)

Returns the index of the last occurrence of any character in the character array of the current instance.

[Visual Basic]
Overloads Public Function LastIndexOf( _
   ByVal value() As Char, _
   ByVal startIndex As Integer _
) As Integer
[C#]
public int LastIndexOf(
   char[] value,
   int startIndex
);
[C++]
public: int LastIndexOf(
   __wchar_t* value[],
   int startIndex
);
[JScript]
public function LastIndexOf(
   value : Char[],
   startIndex : int
) : int;

Parameters

value
The character array containing all of the characters to search for.
startIndex
The index in the current instance where to start searching.

Return Value

Value | Condition
The index in the string | If the character array is found.
-1 | If the character array is not found.

Exceptions

Exception Type | Condition
ArgumentNullException | If the character array is null.
ArgumentOutOfRangeException | If starting position is less than zero or greater than the length of the string.

Remarks

The LastIndexOf method returns the position of the last instance of the specified character array in the string from a specified starting position. This string is traversed backwards from right to left, beginning at startIndex. The character at position startIndex

is included in the search. The search is case-sensitive.

See Also

String Class | String Members | System Namespace | String.LastIndexOf Overload List | Char | Int32 | Array


String.LastIndexOf (Char, Int32)

Gets the position of the last occurrence of the specified character in this string.

[Visual Basic]
Overloads Public Function LastIndexOf( _
   ByVal value As Char, _
   ByVal startIndex As Integer _
) As Integer
[C#]
public int LastIndexOf(
   char value,
   int startIndex
);
[C++]
public: int LastIndexOf(
   __wchar_t value,
   int startIndex
);
[JScript]
public function LastIndexOf(
   value : Char,
   startIndex : int
) : int;

Parameters

value
The character to search for .
startIndex
The position into the current instance at which to start searching.

Return Value

Value | Condition
The index in the string | If the character is found.
-1 | If the character is not found.

Exceptions

Exception Type | Condition
ArgumentNullException | If the character is null.
ArgumentOutOfRangeException | If start position is less than zero or greater than the length of the string.

Remarks

The LastIndexOf method returns the position of the last instance of the specified character in the string from a specified starting position.This string is traversed backwards from right to left, beginning at the position indicated by startIndex. The character at position startIndex is included in the search and is the largest index in the search. The search is case-sensitive.

See Also

String Class | String Members | System Namespace | String.LastIndexOf Overload List | Char | Int32


String.LastIndexOf (Char, Int32, Int32)

Returns the index of the last occurrence of the specified character in this string.

[Visual Basic]
Overloads Public Function LastIndexOf( _
   ByVal value As Char, _
   ByVal startIndex As Integer, _
   ByVal endIndex As Integer _
) As Integer
[C#]
public int LastIndexOf(
   char value,
   int startIndex,
   int endIndex
);
[C++]
public: int LastIndexOf(
   __wchar_t value,
   int startIndex,
   int endIndex
);
[JScript]
public function LastIndexOf(
   value : Char,
   startIndex : int,
   endIndex : int
) : int;

Parameters

value
The character to search for.
startIndex
The index in the current instance where to start searching.
endIndex
The index in the current instance where to stop searching.

Return Value

Value | Condition
The index in the string | If the character is found.
-1 | If the character is not found.

Exceptions

Exception Type | Condition
ArgumentNullException | If the character is null.
ArgumentOutOfRangeException | If either index is less than zero or greater than the length of the string.
ArgumentOutOfRangeException | If ending position is less than starting position.

Remarks

The LastIndexOf method returns the position of the last instance of the specified character in the string from a specified starting position to a specified ending position. This string is traversed backwards from right to left, beginning at startIndex and ending at endIndex. The character at position startIndex and the character at position endIndex are included in the search. The search is case-sensitive.

See Also

String Class | String Members | System Namespace | String.LastIndexOf Overload List | Char | Int32


String.LastIndexOf (String)

Returns the index of the last occurrence of the string in the current instance.

[Visual Basic]
Overloads Public Function LastIndexOf( _
   ByVal value As String _
) As Integer
[C#]
public int LastIndexOf(
   string value
);
[C++]
public: int LastIndexOf(
   String* value
);
[JScript]
public function LastIndexOf(
   value : String
) : int;

Parameters

value
A string to search for.

Return Value

Value | Condition
The position | If the string is found.
The start position | If the string is the empty string.
-1 | If the string is not found.

Exceptions

Exception Type | Condition
ArgumentNullException | If the string is null.

Remarks

The LastIndexOf method returns the position of the last instance of the specified character array in the string. This string is traversed backwards from right to left. The search is case-sensitive.

The value parameter returns the position from where search commenced if value is the empty string (see Empty).

See Also

String Class | String Members | System Namespace | String.LastIndexOf Overload List | Int32


String.LastIndexOf (String, Int32, Int32)

Returns the index of the last occurrence of the string in the current instance.

[Visual Basic]
Overloads Public Function LastIndexOf( _
   ByVal value As String, _
   ByVal startIndex As Integer, _
   ByVal endIndex As Integer _
) As Integer
[C#]
public int LastIndexOf(
   string value,
   int startIndex,
   int endIndex
);
[C++]
public: int LastIndexOf(
   String* value,
   int startIndex,
   int endIndex
);
[JScript]
public function LastIndexOf(
   value : String,
   startIndex : int,
   endIndex : int
) : int;

Parameters

value
A string to search for.
startIndex
The position in the current instance where to start searching.
endIndex
The position in the current instance where to stop searching.

Return Value

Value | Condition
The position | If the the string is found.
The starting position | If the string is the empty string.
-1 | If the string is not found.

Exceptions

Exception Type | Condition
ArgumentNullException | If the string is null.
ArgumentOutOfRangeException | If either index is less than zero or greater than the length of the string.
ArgumentOutOfRangeException | If starting index is less than ending index.

Remarks

The LastIndexOf method returns the position of the last instance of the specified character array in the string from a specified starting position to a specified ending position. This string is traversed backwards from right to left, beginning at startIndex and ending at endIndex. The character at position startIndex is included in the search. The search is case-sensitive.

The value parmeter returns the position from where search commenced if value is the empty string (see Empty).

See Also

String Class | String Members | System Namespace | String.LastIndexOf Overload List


String.LastIndexOf (Char[], Int32, Int32)

Returns the index of the last occurrence of any character in the character array of the current instance.

[Visual Basic]
Overloads Public Function LastIndexOf( _
   ByVal value() As Char, _
   ByVal startIndex As Integer, _
   ByVal endIndex As Integer _
) As Integer
[C#]
public int LastIndexOf(
   char[] value,
   int startIndex,
   int endIndex
);
[C++]
public: int LastIndexOf(
   __wchar_t* value[],
   int startIndex,
   int endIndex
);
[JScript]
public function LastIndexOf(
   value : Char[],
   startIndex : int,
   endIndex : int
) : int;

Parameters

value
A character array containing all of the characters to search for.
startIndex
The index in the current instance where to start searching.
endIndex
The index in the current instance where to stop searching.

Return Value

Value | Condition
The index in the string | If the character array is found.
-1 | If the character array is not found.

Exceptions

Exception Type | Condition
ArgumentNullException | If the character array is null.
ArgumentOutOfRangeException | If either position are less than zero or greater than the length of the string.
ArgumentOutOfRangeException | If end position is less than the start position.

Remarks

The LastIndexOf method returns the position of the last instance of the specified character array in the string from a specified starting position to a specified ending position. This string is traversed backwards from right to left, beginning at startIndex and ending at endIndex. The character at position startIndex and the character at position endIndex are included in the search. The search is case-sensitive.

See Also

String Class | String Members | System Namespace | String.LastIndexOf Overload List | Char | Int32 | Array


String.LastIndexOf (String, Int32)

Returns the index of the last occurrence of the string in the current instance.

[Visual Basic]
Overloads Public Function LastIndexOf( _
   ByVal value As String, _
   ByVal startIndex As Integer _
) As Integer
[C#]
public int LastIndexOf(
   string value,
   int startIndex
);
[C++]
public: int LastIndexOf(
   String* value,
   int startIndex
);
[JScript]
public function LastIndexOf(
   value : String,
   startIndex : int
) : int;

Parameters

value
A string to search for.
startIndex
The position in the current instance to start searching.

Return Value

Value | Condition
The index in the string | If the string is found.
-1 | If the string is not found.

Exceptions

Exception Type | Condition
ArgumentNullException | If the string is null.
ArgumentOutOfRangeException | If the starting position is less than zero or greater than the length of the string.

Remarks

The LastIndexOf method returns the position of the last instance of the specified character array in the string from a specified starting position. This string is traversed backwards from right to left, beginning at startIndex. The character at position startIndex is included in the search. The search is case-sensitive.

See Also

String Class | String Members | System Namespace | String.LastIndexOf Overload List | Int32


String.LastIndexOf (Char)

Gets the position of the last occurrence of the specified character in this string.

[Visual Basic]
Overloads Public Function LastIndexOf( _
   ByVal value As Char _
) As Integer
[C#]
public int LastIndexOf(
   char value
);
[C++]
public: int LastIndexOf(
   __wchar_t value
);
[JScript]
public function LastIndexOf(
   value : Char
) : int;

Parameters

value
The character for which to search.

Return Value

Value | Condition
The index in the string | If the character is found.
-1 | If the character is not found.

Exceptions

Exception Type | Condition
ArgumentNullException | If the character is null .

Remarks

The LastIndexOf method returns the position of the last instance of the specified character in the string. This string is traversed backwards from right to left. The search is case-sensitive.

See Also

String Class | String Members | System Namespace | String.LastIndexOf Overload List | Char | Int32


String.PadLeft

Returns this string left-aligned in a field.

Overload List

Returns this string left-aligned in a field of specified width.

[Visual Basic] Overloads Public Function PadLeft(Integer) As String
[C#] public string PadLeft(int);
[C++] public: String* PadLeft(int);
[JScript] public function PadLeft(int) : String;

Returns this string left-aligned in a field and padded with the specified padding character as needed.

[Visual Basic] Overloads Public Function PadLeft(Integer, Char) As String
[C#] public string PadLeft(int, char);
[C++] public: String* PadLeft(int, __wchar_t);
[JScript] public function PadLeft(int, Char) : String;

Example

Managed C++:

Note This example shows how to use one of the overloaded versions of PadLeft. For other examples that may be available, see the individual overload topics.
String *foo
= L"forty-two";
Console::WriteLine(foo->PadLeft(15,
L'.'));
Console::WriteLine(foo->PadLeft(2,
L'.'));

Visual
Basic:
Dim foo
As String
Dim bar
As Char
foo =
"forty-two"
bar =
Convert.ToChar(".")  'Must do
Char assignment in this round-about way for now since
   'assignment of a
character literal to a Char (e.g. bar = "."C)
   'has not yet been
implemented in VB.
Console.WriteLine(foo.PadLeft(15,
bar))
Console.WriteLine(foo.PadLeft(2,
bar))

See Also

String Class | String Members | System Namespace


String.PadLeft (Int32)

Returns this string left-aligned in a field of specified width.

[Visual Basic]
Overloads Public Function PadLeft( _
   ByVal totalWidth As Integer _
) As String
[C#]
public string PadLeft(
   int totalWidth
);
[C++]
public: String* PadLeft(
   int totalWidth
);
[JScript]
public function PadLeft(
   totalWidth : int
) : String;

Parameters

totalWidth
The field width to justify in this string.

Return Value

The PadLeft method this instance of string aligned from the left. This string as a left-aligned field with padded spaces as needed.

Exceptions

Exception Type | Condition
ArgumentException | If the field width is less than zero.

Remarks

The PadLeft method this instance of string aligned from the left. If the field width is less than the string's length, the string is returned unaltered.

Example

Visual Basic:

[VB]
Dim
foo As String
foo
= "BBQ and Slaw"
Console.WriteLine(foo.PadLeft(25))
Console.WriteLine(foo.PadLeft(5))

Managed C++:

[C++]
String foo = L"BBQ and Slaw";
Console::WriteLine
(foo->PadLeft (25));
Console::WriteLine
(foo->PadLeft (5));

See Also

String Class | String Members | System Namespace | String.PadLeft Overload List | Int32


String.PadLeft (Int32, Char)

Returns this string left-aligned in a field and padded with the specified padding character as needed.

[Visual Basic]
Overloads Public Function PadLeft( _
   ByVal totalWidth As Integer, _
   ByVal paddingChar As Char _
) As String
[C#]
public string PadLeft(
   int totalWidth,
   char paddingChar
);
[C++]
public: String* PadLeft(
   int totalWidth,
   __wchar_t paddingChar
);
[JScript]
public function PadLeft(
   totalWidth : int,
   paddingChar : Char
) : String;

Parameters

totalWidth
The field width to justify in this string.
paddingChar
The character used to pad.

Return Value

This string as left-aligned field width with padded spaces using the specified character as needed.

Exceptions

Exception Type | Condition
ArgumentException | If the field width is less than zero.

Remarks

The PadLeft method this instance of string aligned from the left and with padding charcters to make it the specified string length. If the field width is less than the string's length, the string is returned unaltered.

Example

Managed C++:

String *foo
= L"forty-two";
Console::WriteLine(foo->PadLeft(15,
L'.'));
Console::WriteLine(foo->PadLeft(2,
L'.'));

Visual
Basic:
Dim foo
As String
Dim bar
As Char
foo =
"forty-two"
bar =
Convert.ToChar(".")  'Must do
Char assignment in this round-about way for now since
   'assignment of a
character literal to a Char (e.g. bar = "."C)
   'has not yet been
implemented in VB.
Console.WriteLine(foo.PadLeft(15,
bar))
Console.WriteLine(foo.PadLeft(2,
bar))

See Also

String Class | String Members | System Namespace | String.PadLeft Overload List | Char | Int32


String.PadRight

Returns this string right-aligned in a field and padded with spaces.

Overload List

Returns this string right-aligned in a specified field width and padded with spaces as needed.

[Visual Basic] Overloads Public Function PadRight(Integer) As String
[C#] public string PadRight(int);
[C++] public: String* PadRight(int);
[JScript] public function PadRight(int) : String;

Returns this string right-aligned in a specified field width and padded with a specified character as needed.

[Visual Basic] Overloads Public Function PadRight(Integer, Char) As String
[C#] public string PadRight(int, char);
[C++] public: String* PadRight(int, __wchar_t);
[JScript] public function PadRight(int, Char) : String;

Example

Managed C++

Note This example shows how to use one of the overloaded versions of PadRight. For other examples that may be available, see the individual overload topics.
String
*foo = L"forty-two";Console::Write(L"|");
Console::Write(foo->PadRight(25,
L'.'));Console::WriteLine(L"|");
Console::Write(L"|");Console::Write(foo->PadRight(5,
L'.'));
Console::WriteLine(L"|");

Visual
Basic
Dim
foo As String
Dim
bar As Char
foo
= "forty-two"
bar
= Convert.ToChar(".")  'Must
do Char assignment in this round-about way for now since
   'assignment of a
character literal to a Char (e.g. bar = "."C)
   'has not yet been
implemented in VB.
Console.WriteLine(foo.PadLeft(15,
bar))
Console.WriteLine(foo.PadLeft(2,
bar))

See Also

String Class | String Members | System Namespace


String.PadRight (Int32)

Returns this string right-aligned in a specified field width and padded with spaces as needed.

[Visual Basic]
Overloads Public Function PadRight( _
   ByVal totalWidth As Integer _
) As String
[C#]
public string PadRight(
   int totalWidth
);
[C++]
public: String* PadRight(
   int totalWidth
);
[JScript]
public function PadRight(
   totalWidth : int
) : String;

Parameters

totalWidth
The field width to justify in this string.

Return Value

This string is a right-aligned justified field width, padded with spaces as needed.

Exceptions

Exception Type | Condition
ArgumentException | If the field width is less than zero.

Remarks

The PadRight method this instance of string aligned from the right. If the field width is less than this string's length, the string is returned unaltered.

Example

Visual Basic
Dim
foo As Stringfoo = "BBQ and Slaw"Console.Write("|")
Console.Write(foo.PadRight(25))Console.WriteLine("|")Console.Write("|")
Console.Write(foo.PadRight(5))Console.WriteLine("|")

Managed C++:
String
*foo = L"BBQ and Slaw";
Console::Write(L"|");
Console::Write(foo->PadRight(25));
Console::WriteLine(L"|");
Console::Write(L"|");
Console::Write(foo->PadRight(5));
Console::WriteLine(L"|");

See Also

String Class | String Members | System Namespace | String.PadRight Overload List | Int32


String.PadRight (Int32, Char)

Returns this string right-aligned in a specified field width and padded with a specified character as needed.

[Visual Basic]
Overloads Public Function PadRight( _
   ByVal totalWidth As Integer, _
   ByVal paddingChar As Char _
) As String
[C#]
public string PadRight(
   int totalWidth,
   char paddingChar
);
[C++]
public: String* PadRight(
   int totalWidth,
   __wchar_t paddingChar
);
[JScript]
public function PadRight(
   totalWidth : int,
   paddingChar : Char
) : String;

Parameters

totalWidth
The field width to justify in this string.
paddingChar
The character used to pad.

Return Value

This string is a right-aligned justified field width, padded with the specified character as needed.

Exceptions

Exception Type | Condition
ArgumentException | If the field width is less than zero.

Remarks

The PadRight method this instance of string aligned from the right and with padding charcters to make it the specified string length. If the field width is less than this string's length, the string is returned unaltered.

Example

Managed C++

String
*foo = L"forty-two";Console::Write(L"|");
Console::Write(foo->PadRight(25,
L'.'));Console::WriteLine(L"|");
Console::Write(L"|");Console::Write(foo->PadRight(5,
L'.'));
Console::WriteLine(L"|");

Visual
Basic
Dim
foo As String
Dim
bar As Char
foo
= "forty-two"
bar
= Convert.ToChar(".")  'Must
do Char assignment in this round-about way for now since
   'assignment of a
character literal to a Char (e.g. bar = "."C)
   'has not yet been
implemented in VB.
Console.WriteLine(foo.PadLeft(15,
bar))
Console.WriteLine(foo.PadLeft(2,
bar))

See Also

String Class | String Members | System Namespace | String.PadRight Overload List | Char | Int32


String.Remove

Deletes a specified number of characters from this String beginning at a specified location.

[Visual Basic]
Public Function Remove( _
   ByVal startIndex As Integer, _
   ByVal count As Integer _
) As String
[C#]
public string Remove(
   int startIndex,
   int count
);
[C++]
public: String* Remove(
   int startIndex,
   int count
);
[JScript]
public function Remove(
   startIndex : int,
   count : int
) : String;

Parameters

startIndex
The position to begin in the part of string to be deleted.
count
The number of characters to be deleted in the string.

Return Value

A string that consists of the number of characters removed from this instance starting at beginning point.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | If either the index or the number of characters is less than zero.
ArgumentOutOfRangeException | If the index and the number of characters are greater than the length of this string.

Remarks

The Remove method updates a string by removing trailing characters. The string is unchanged. As a special case, if the beginning position is equal to the length of this string and if the number of characters is zero, then a copy of this string is returned.

Note that the first location has an index of 0.

The startIndex parameter must be greater than 0 or equal to the length of this string.

The count parameter can be zero, in which case no characters are removed.

See Also

String Class | String Members | System Namespace


String.Replace

Replaces all instances of a specified character with a new one.

[Visual Basic]
Public Function Replace( _
   ByVal oldChar As Char, _
   ByVal newChar As Char _
) As String
[C#]
public string Replace(
   char oldChar,
   char newChar
);
[C++]
public: String* Replace(
   __wchar_t oldChar,
   __wchar_t newChar
);
[JScript]
public function Replace(
   oldChar : Char,
   newChar : Char
) : String;

Parameters

oldChar
The character to be replaced.
newChar
The character to replace the occurrences of the old character.

Return Value

A new string with all instances of old characters replaced with the new characters.

Remarks

The Replace method returns a string with all the places where the specified characters that needed replaceing with all the specified new characters.

See Also

String Class | String Members | System Namespace


String.Split

Creates an array of strings by splitting this string.

Overload List

Creates an array of strings by splitting this string with a specified separator.

[Visual Basic] Overloads Public Function Split(Char()) As String ()
[C#] public string[] Split(char[]);
[C++] public: String* Split(__wchar_t*[]) [];
[JScript] public function Split(Char[]) : String[];

Creates an array of strings by splitting this string with a specified arrays as the separator.

[Visual Basic] Overloads Public Function Split(Char(), Integer) As String ()
[C#] public string[] Split(char[], int);
[C++] public: String* Split(__wchar_t*[], int) [];
[JScript] public function Split(Char[], int) : String[];

Example

Note This example shows how to use one of the overloaded versions of Split. For other examples that may be available, see the individual overload topics.
"42,
12, 19".Split ({',', ' '}, 2) => {"42", "12, 19"}
"42..12..19".Split({'.'},
4) => {"42", "", "12", ".19"}
"Banana".Split({'.'},
2) => {"Banana"}
"Darb
Smarba".Split({}, 1) => {"Darb Smarba"}
"Darb
Smarba".Split(null,2) => {"Darb", "Smarba"}
"Darb
Smarba".Split(null,100) => {"Darb", "Smarba"}
Throws
ArgumentException if count is < 0.

See Also

String Class | String Members | System Namespace


String.Split (Char[])

Creates an array of strings by splitting this string with a specified separator.

[Visual Basic]
Overloads Public Function Split( _
   ByVal separator() As Char _
) As String ()
[C#]
public string[] Split(
   char[] separator
);
[C++]
public: String* Split(
   __wchar_t* separator[]
) [];
[JScript]
public function Split(
   separator : Char[]
) : String[];

Parameters

separator
The string used as the separator.

Return Value

Value | Condition
An array containing the substrings of this string | If they are separated by the separating string.
A one element array that holds Empty | If this instance is an empty string.

Exceptions

Exception Type | Condition
ArgumentException | If the separating string is null.

Remarks

The separator is searched for and, if found, the substring preceding the occurrence is stored as the first element in the array of strings. It is continued in this manner by searching the substring that follows the occurrence.

On the other hand, if the separator is not found, the array of strings will contain this instance as its only element. If the separator is an empty array, whitespace (i.e., IsWhiteSpace) is used as the separator.

Example

"42,
12, 19".Split ({',', ' '}) => {"42", "",
"12", "", "19"}
"42..12..19".Split({'.'})
=> {"42", "", "12", "",
"19"}
"Banana".Split({'.'})
=> {"Banana"}
"Darb
Smarba".Split({}) => {"Darb", "Smarba"}
"Darb
Smarba".Split(null) => {"Darb", "Smarba"}

See Also

String Class | String Members | System Namespace | String.Split Overload List | Char | CharacterInfo


String.Split (Char[], Int32)

Creates an array of strings by splitting this string with a specified arrays as the separator.

[Visual Basic]
Overloads Public Function Split( _
   ByVal separator() As Char, _
   ByVal count As Integer _
) As String ()
[C#]
public string[] Split(
   char[] separator,
   int count
);
[C++]
public: String* Split(
   __wchar_t* separator[],
   int count
) [];
[JScript]
public function Split(
   separator : Char[],
   count : int
) : String[];

Parameters

separator
The string used as the separator.
count
The maximum number of elements allowed in the array.

Return Value

Value | Condition
An array containing the substrings of this string | If they are separated by the separating string.
A one element array that holds Empty | If this instance is an empty string.

Exceptions

Exception Type | Condition
ArgumentException | If the separating string is null.
ArgumentOutOfRangeException | If the count is negative.

Remarks

The separator is searched for and, if found, the substring preceding the occurrence is stored as the first element in the array of strings. We then continue in this manner by searching the substring that follows the occurrence.

On the other hand, if the separator is not found, the array of strings will contain this instance as its only element.

If the separator is the empty string (i.e., Empty), then the whitespace (i.e., IsWhiteSpace) is used as the separator.

When there are more than count different strings, the last n- (count-1) elements are concatenated and added as the last string. n represents the number of substrings in this instance.

  • If n < count then the array returned contains only n elements.
  • If n > count then the remaining substrings (count- n) are appended to the last string in the array.

Example

"42,
12, 19".Split ({',', ' '}, 2) => {"42", "12, 19"}
"42..12..19".Split({'.'},
4) => {"42", "", "12", ".19"}
"Banana".Split({'.'},
2) => {"Banana"}
"Darb
Smarba".Split({}, 1) => {"Darb Smarba"}
"Darb
Smarba".Split(null,2) => {"Darb", "Smarba"}
"Darb
Smarba".Split(null,100) => {"Darb", "Smarba"}
Throws
ArgumentException if count is < 0.

See Also

String Class | String Members | System Namespace | String.Split Overload List | Char | Array | Int32


String.StartsWith

Determines whether a specified string is a prefix of the current instance.

[Visual Basic]
Public Function StartsWith( _
   ByVal value As String _
) As Boolean
[C#]
public bool StartsWith(
   string value
);
[C++]
public: bool StartsWith(
   String* value
);
[JScript]
public function StartsWith(
   value : String
) : Boolean;

Parameters

value
The string to search for.

Return Value

true if either value matches the beginning of this string or value is an empty string, otherwise false.

Exceptions

Exception Type | Condition
ArgumentNullException | If the string is null.

Remarks

The StartsWith method makes a comparison at the beginning of the string, determines whether it matches this current instance, and returns a Boolean represetation of their relationship. The specified string must match the prefix or be an empty string (i.e., equals Empty). The comparison is case-sensitive.

See Also

String Class | String Members | System Namespace


String.Substring

[To be supplied.]

Overload List

Converts a substring of this string to an array of characters, beginning at a specified point in this string.

[Visual Basic] Overloads Public Function Substring(Integer, Integer) As String
[C#] public string Substring(int, int);
[C++] public: String* Substring(int, int);
[JScript] public function Substring(int, int) : String;

Converts a substring of this string to an array of characters.

[Visual Basic] Overloads Public Function Substring(Integer) As String
[C#] public string Substring(int);
[C++] public: String* Substring(int);
[JScript] public function Substring(int) : String;

Example

Managed C++:

Note This example shows how to use one of the overloaded versions of Substring. For other examples that may be available, see the individual overload topics.
String
*myString = L"abc";
String::Compare(myString->Substring(2,1),
L"c") == 0;   // THIS IS TRUE
myString->Substring(3,1);  // THROWS AN ArgumentOutOfRangeException
String::Compare(myString->Substring(3,0),
String::Empty) == 0;  // THIS IS TRUE

See Also

String Class | String Members | System Namespace


String.Substring (Int32, Int32)

Converts a substring of this string to an array of characters, beginning at a specified point in this string.

[Visual Basic]
Overloads Public Function Substring( _
   ByVal startIndex As Integer, _
   ByVal length As Integer _
) As String
[C#]
public string Substring(
   int startIndex,
   int length
);
[C++]
public: String* Substring(
   int startIndex,
   int length
);
[JScript]
public function Substring(
   startIndex : int,
   length : int
) : String;

Parameters

startIndex
The position of this string at which the substring begins.
length
The number of characters in the substring.

Return Value

Returns the substring of characters at beginning position of the index (startIndex) through the ending position (startIndex + length- 1).

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | If the substring is greater than the length of this string.
ArgumentOutOfRangeException | If starting index less than zero.
ArgumentOutOfRangeException | If number of characters is less than zero.

Remarks

String indices are 0-based.

If startIndex is equal to the length of this string and length is 0, then the empty string is returned. The value of this parameter must be greater than or equal to zero and less than or equal to the length of this string.

The length parameter is can be 0, in which case the substring is the empty string. A length of-1 indicates the length of this string.

Example

Managed C++:

String
*myString = L"abc";
String::Compare(myString->Substring(2,1),
L"c") == 0;   // THIS IS TRUE
myString->Substring(3,1);  // THROWS AN ArgumentOutOfRangeException
String::Compare(myString->Substring(3,0),
String::Empty) == 0;  // THIS IS TRUE

See Also

String Class | String Members | System Namespace | String.Substring Overload List | Int32


String.Substring (Int32)

Converts a substring of this string to an array of characters.

[Visual Basic]
Overloads Public Function Substring( _
   ByVal startIndex As Integer _
) As String
[C#]
public string Substring(
   int startIndex
);
[C++]
public: String* Substring(
   int startIndex
);
[JScript]
public function Substring(
   startIndex : int
) : String;

Parameters

startIndex
The index of the character where the substring begins.

Return Value

The substring of characters from the index to the end of the string.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | If position where the index begins is less than zero or greater than the length of this string.

Remarks

The value of the startIndex parameter must be greater than or equal to zero and less than or equal to the length of this string.

If startIndex is equal to the length of this string, then the empty string is returned. String indices are 0-based.

See Also

String Class | String Members | System Namespace | String.Substring Overload List | Int32


String.ToBoolean

Converts a string to a Boolean value.

[Visual Basic]
Overridable Public Function ToBoolean() As Boolean
[C#]
public virtual bool ToBoolean();
[C++]
public: virtual bool ToBoolean();
[JScript]
public function ToBoolean() : Boolean;

Return Value

A Boolean representation of a string.

Remarks

The ToBoolean method implementation is provided by Parse and ToBoolean. (In addition information, see Boolean, Convert and Value.)

See Also

String Class | String Members | System Namespace


String.ToByte

Converts a string to a value in the specified base, represented as an 8-bit unsigned Byte.

[Visual Basic]
Overridable Public Function ToByte() As Byte
[C#]
public virtual byte ToByte();
[C++]
public: virtual unsigned char ToByte();
[JScript]
public function ToByte() : Byte;

Return Value

The unsigned byte representation of the string as a base number.

Exceptions

Exception Type | Condition
ArgumentException | If the string is not base 2, 8, 10, or 16.
FormatException | If the string cannot be parsed as a base number.
ArgumentNullException | If the string is null.
OverflowException | If the string is greater than Byte.MaxValue or less than Byte.MinValue.

Remarks

If the number is 16, the number may be preceded by "0x"; any other leading or trailing character causes an error.

The ToByte implementation is the same as ToByte. (In addition information, see Byte, Convert and Value.)

See Also

String Class | String Members | System Namespace


String.ToChar

Converts a non-empty string of length one to a Char.

[Visual Basic]
Overridable Public Function ToChar() As Char
[C#]
public virtual char ToChar();
[C++]
public: virtual __wchar_t ToChar();
[JScript]
public function ToChar() : Char;

Return Value

The character at index 0 within value .

Remarks

Implementation is the same as ToChar. (In addition information, see Char, Convert and Value.)

See Also

String Class | String Members | System Namespace


String.ToCharArray

Returns a string as an array of characters.

Overload List

Returns a copy of this string as an array of characters.

[Visual Basic] Overloads Public Function ToCharArray() As Char ()
[C#] public char[] ToCharArray();
[C++] public: __wchar_t* ToCharArray() [];
[JScript] public function ToCharArray() : Char[];

Returns a substring of this string as an array of characters.

[Visual Basic] Overloads Public Function ToCharArray(Integer, Integer) As Char ()
[C#] public char[] ToCharArray(int, int);
[C++] public: __wchar_t* ToCharArray(int, int) [];
[JScript] public function ToCharArray(int, int) : Char[];

See Also

String Class | String Members | System Namespace


String.ToCharArray ()

Returns a copy of this string as an array of characters.

[Visual Basic]
Overloads Public Function ToCharArray() As Char ()
[C#]
public char[] ToCharArray();
[C++]
public: __wchar_t* ToCharArray() [];
[JScript]
public function ToCharArray() : Char[];

Return Value

Returns a copy of this string as an array of characters.

Remarks

The ToCharArray method makes a copy of an entire string and returns it as an array of characters.

See Also

String Class | String Members | System Namespace | String.ToCharArray Overload List | Char | Array


String.ToCharArray (Int32, Int32)

Returns a substring of this string as an array of characters.

[Visual Basic]
Overloads Public Function ToCharArray( _
   ByVal startIndex As Integer, _
   ByVal length As Integer _
) As Char ()
[C#]
public char[] ToCharArray(
   int startIndex,
   int length
);
[C++]
public: __wchar_t* ToCharArray(
   int startIndex,
   int length
) [];
[JScript]
public function ToCharArray(
   startIndex : int,
   length : int
) : Char[];

Parameters

startIndex
The position the substring begins.
length
The length of the substring.

Return Value

Returns a character array.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | If the substring is longer than the string.
ArgumentOutOfRangeException | If substring less than zero.
ArgumentOutOfRangeException | If the starting position of the substring is not in the string.

Remarks

The ToCharArray method returns a character array containing the characters beginning at the specified start position (startIndex) through the ending at the length (startIndex + length- 1).

See Also

String Class | String Members | System Namespace | String.ToCharArray Overload List | Array | Char | Int32


String.ToDateTime

Returns the specified string converted to DateTime format.

[Visual Basic]
Overridable Public Function ToDateTime() As DateTime
[C#]
public virtual DateTime ToDateTime();
[C++]
public: virtual DateTime ToDateTime();
[JScript]
public function ToDateTime() : DateTime;

Return Value

The string formatted as a DateTime type.

Remarks

The ToDateTime implementation is the same as Parse and ToDateTime (In addition information, see DateTime, Convert and Value.)

See Also

String Class | String Members | System Namespace


String.ToDecimal

Converts a string to a Decimal.

[Visual Basic]
Overridable Public Function ToDecimal() As Decimal
[C#]
public virtual Decimal ToDecimal();
[C++]
public: virtual Decimal ToDecimal();
[JScript]
public function ToDecimal() : Decimal;

Return Value

The Decimal with the value represented by value.

Exceptions

Exception Type | Condition
ArgumentException | If the string is null.
FormatException | If the string does not contain a representation that can be converted to a Decimal using the Parse(String) method implemented by that type.
OverflowException | If the string represents a number that is less than Decimal.MaxValue or greater than Decimal.MinValue.

Remarks

The ToDecimal implementation is the same as Parse and ToDecimal. (In addition information, see Decimal, Convert and Value.)

Note that if the beginning of the string contains a properly formatted numerical value, that will result in an overflow. In addition, the end of the string is improperly formed, it cannot be determined whether an OverflowException or a FormatException will be thrown. This has been implemented this way for performance reasons.

See Also

String Class | String Members | System Namespace


String.ToDouble

Converts a string to a Double.

[Visual Basic]
Overridable Public Function ToDouble() As Double
[C#]
public virtual double ToDouble();
[C++]
public: virtual double ToDouble();
[JScript]
public function ToDouble() : double;

Return Value

The Double with the value represented by value.

Exceptions

Exception Type | Condition
ArgumentException | If the string is null.
FormatException | If the string does not contain a representation that can be converted to a Double using the Parse(String) method implemented by that type.
OverflowException | If the string represents a number that is less than Double.MaxValue or greater than Double.MinValue.

Remarks

The ToDoubel implementation is the same as Parse and ToDouble. (In addition information, see Double, Convert and Value.)

See Also

String Class | String Members | System Namespace | Double


String.ToInt16

Converts a specified string to an Int16 in the specified base.

[Visual Basic]
Overridable Public Function ToInt16() As Short
[C#]
public virtual short ToInt16();
[C++]
public: virtual short ToInt16();
[JScript]
public function ToInt16() : Int16;

Return Value

The Int16 representation of value as a base number .

Exceptions

Exception Type | Condition
ArgumentException | If the string is not base 2, 8, 10, or 16.
ArgumentException | If the string is null.
FormatException | If the string cannot be parsed as a base number or the value represented is greater than Int16.MaxValue or less than Int16.MinValue.

Remarks

If the string is 16, the number may be preceded by "0x"; any other leading or trailing characters cause an error.

The ToInt16 implementation is the same as ToInt16. (In addition information, see Int16, Convert and Value.)

See Also

String Class | String Members | System Namespace


String.ToInt32

Converts a string to an Int32.

[Visual Basic]
Overridable Public Function ToInt32() As Integer
[C#]
public virtual int ToInt32();
[C++]
public: virtual int ToInt32();
[JScript]
public function ToInt32() : int;

Return Value

An Int32 with the value represented by value .

Remarks

Implementation is the same as ToInt32. (In addition information, see Int32, Convert and Value.)

The string is parsed as a decimal unless it is preceded by "0x", in which case it is parsed as a hexadecimal number. White space or trailing characters will cause a FormatException.

Note that if the beginning of the string value contains a properly formatted numerical value that will result in an OverflowException. In addition, if the end of the string is improperly formed, it cannot be determined whether an OverflowExceptionor a FormatException will be thrown. This has been implemented this way for performance reasons.

See Also

String Class | String Members | System Namespace


String.ToInt64

Converts a string to an Int64 value.

[Visual Basic]
Overridable Public Function ToInt64() As Long
[C#]
public virtual long ToInt64();
[C++]
public: virtual __int64 ToInt64();
[JScript]
public function ToInt64() : long;

Return Value

An Int64 with the value represented by value .

Remarks

The ToInt64 implementation is the same as ToInt64. (In addition information, see Int64, Convert and Value.)

If the string is parsed as a decimal unless it is preceded by "0x", in which case it is parsed as a hexadecimal number. White space or trailing characters will cause a FormatException. The implementation is provided by Parse.

Note that if the beginning of the string value contains a properly formatted numerical value that will result in an overflow and, in addition, the end of the string is improperly formed, it cannot be determined whether an OverflowException or a FormatException will be thrown. This has been implemented this way for performance reasons.

See Also

String Class | String Members | System Namespace


String.ToLower

Creates a copy of this string in lower case.

Overload List

Creates a copy of this string in lower case with the specified CultureInfo information.

[Visual Basic] Overloads Public Function ToLower(CultureInfo) As String
[C#] public string ToLower(CultureInfo);
[C++] public: String* ToLower(CultureInfo*);
[JScript] public function ToLower(CultureInfo) : String;

Creates a copy of this string in lower case with default properties.

[Visual Basic] Overloads Public Function ToLower() As String
[C#] public string ToLower();
[C++] public: String* ToLower();
[JScript] public function ToLower() : String;

See Also

String Class | String Members | System Namespace


String.ToLower (CultureInfo)

Creates a copy of this string in lower case with the specified CultureInfo information.

[Visual Basic]
Overloads Public Function ToLower( _
   ByVal culture As CultureInfo _
) As String
[C#]
public string ToLower(
   CultureInfo culture
);
[C++]
public: String* ToLower(
   CultureInfo* culture
);
[JScript]
public function ToLower(
   culture : CultureInfo
) : String;

Parameters

culture
Sets the locale.

Return Value

A new string in lower case.

Exceptions

Exception Type | Condition
ArgumentNullException | If a specified culture is not valid.

Remarks

The ToLower method returns a string in lower case with the specified locale set by the information provided by CultureInfo.

See Also

String Class | String Members | System Namespace | String.ToLower Overload List


String.ToLower ()

Creates a copy of this string in lower case with default properties.

[Visual Basic]
Overloads Public Function ToLower() As String
[C#]
public string ToLower();
[C++]
public: String* ToLower();
[JScript]
public function ToLower() : String;

Return Value

A new string in lower case.

Remarks

This ToLower method uses the default CultureInfo locale information.

See Also

String Class | String Members | System Namespace | String.ToLower Overload List


String.ToSByte

Converts an SByte to a string.

[Visual Basic]
Overridable Public Function ToSByte() As SByte
[C#]
public virtual sbyte ToSByte();
[C++]
public: virtual char ToSByte();
[JScript]
public function ToSByte() : SByte;

Return Value

The SByte representation of the string as a base number.

Exceptions

Exception Type | Condition
ArgumentException | If the string is not base 2, 8, 10, or 16.
FormatException | If the string cannot be parsed as a base number.
ArgumentNullException | If the string is null.
OverflowException | If the string is greater than SByte.MaxValue or less than SByte.MinValue.

Remarks

If the number is 16, the number may be preceded by "0x"; any other leading or trailing character causes an error.

The ToSByte implementation is the same as ToSByte. (In addition information, see SByte, Convert and Value.)

See Also

String Class | String Members | System Namespace


String.ToSingle

Returns a string representing the specified number as a Single.

[Visual Basic]
Overridable Public Function ToSingle() As Single
[C#]
public virtual float ToSingle();
[C++]
public: virtual float ToSingle();
[JScript]
public function ToSingle() : float;

Return Value

The string represented as a Single.

Remarks

The ToSingle implementation is the same as ToString. (In addition information, see Single, Convert and Value.)

See Also

String Class | String Members | System Namespace


String.ToString

Returns the current instance of string.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

This string.

Remarks

The ToString method returns the current instance string. (In addition information, see Convert and Value.)

See Also

String Class | String Members | System Namespace


String.ToType

Retrieves the Type for a specified object.

[Visual Basic]
Overridable Public Function ToType( _
   ByVal type As Type _
) As Object
[C#]
public virtual object ToType(
   Type type
);
[C++]
public: virtual Object* ToType(
   Type* type
);
[JScript]
public function ToType(
   type : Type
) : Object;

Parameters

type
The Type of the object.

Return Value

The Type identification of the specified object.

Exceptions

Exception Type | Condition
InvalidCastException | If it is the wrong type.

Remarks

The ToType method accesses the Type class to return the classification of an object, whether it is a class, a interface, an enumeration, a method, a property, or a field.

See Also

String Class | String Members | System Namespace


String.ToUInt16

Converts a string to a UInt16 value.

[Visual Basic]
Overridable Public Function ToUInt16() As UInt16
[C#]
public virtual ushort ToUInt16();
[C++]
public: virtual unsigned short ToUInt16();
[JScript]
public function ToUInt16() : UInt16;

Return Value

The UInt16 representation of the string .

Exceptions

Exception Type | Condition
ArgumentException | If the string is not base 2, 8, 10, or 16.
ArgumentException | If the string is null.
FormatException | If the string cannot be parsed as a base number or the value represented is greater than UInt16.MaxValue or less than UInt16.MinValue.

Remarks

If the string is 16, the number may be preceded by "0x"; any other leading or trailing characters cause an error.

See Also

String Class | String Members | System Namespace


String.ToUInt32

Converts a string to a UInt32 value.

[Visual Basic]
Overridable Public Function ToUInt32() As UInt32
[C#]
public virtual uint ToUInt32();
[C++]
public: virtual unsigned int ToUInt32();
[JScript]
public function ToUInt32() : UInt32;

Return Value

The UInt32 representation of value as a base number .

Exceptions

Exception Type | Condition
ArgumentException | If the string is not 2, 8, 10, or 16.If the string is null.
FormatException | If the string cannot be parsed as a base number or the value represented is greater than UInt32.MaxValue or less than UInt32.MinValue

Remarks

A string value can only be base 2, 8, 10, or 16. If the string is 16, the number may be preceded by "0x"; any other leading or trailing characters cause an error.

See Also

String Class | String Members | System Namespace


String.ToUInt64

Converts a string to a UInt64 value.

[Visual Basic]
Overridable Public Function ToUInt64() As UInt64
[C#]
public virtual ulong ToUInt64();
[C++]
public: virtual unsigned __int64 ToUInt64();
[JScript]
public function ToUInt64() : UInt64;

Return Value

The converted string .

Remarks

The ToUInt64 implementation is the same as ToUInt64. (In addition information, see U Int64, Convert and Value.)

The string is parsed as a decimal unless it is preceded by "0x". In that case, it is parsed as a hexadecimal number.

White space or trailing characters will cause a FormatException.

Note that if the beginning of the string value contains a properly formatted numerical value that will result in an overflow and, in addition, the end of the string is improperly formed, it cannot be determined whether an OverflowException or a FormatException will be thrown. This has been implemented this way for performance reasons.

See Also

String Class | String Members | System Namespace


String.ToUpper

Creates a copy of this string in upper case.

Overload List

Creates a copy of this string in upper case with default properties.

[Visual Basic] Overloads Public Function ToUpper() As String
[C#] public string ToUpper();
[C++] public: String* ToUpper();
[JScript] public function ToUpper() : String;

Creates a copy of this string in upper case with the specified CultureInfo inforamtion.

[Visual Basic] Overloads Public Function ToUpper(CultureInfo) As String
[C#] public string ToUpper(CultureInfo);
[C++] public: String* ToUpper(CultureInfo*);
[JScript] public function ToUpper(CultureInfo) : String;

See Also

String Class | String Members | System Namespace


String.ToUpper ()

Creates a copy of this string in upper case with default properties.

[Visual Basic]
Overloads Public Function ToUpper() As String
[C#]
public string ToUpper();
[C++]
public: String* ToUpper();
[JScript]
public function ToUpper() : String;

Return Value

A new string in upper case.

Remarks

The ToUpper method uses the default CultureInfo locale information.

See Also

String Class | String Members | System Namespace | String.ToUpper Overload List


String.ToUpper (CultureInfo)

Creates a copy of this string in upper case with the specified CultureInfo inforamtion.

[Visual Basic]
Overloads Public Function ToUpper( _
   ByVal culture As CultureInfo _
) As String
[C#]
public string ToUpper(
   CultureInfo culture
);
[C++]
public: String* ToUpper(
   CultureInfo* culture
);
[JScript]
public function ToUpper(
   culture : CultureInfo
) : String;

Parameters

culture
Sets the locale.

Return Value

A new string in upper case.

Exceptions

Exception Type | Condition
ArgumentNullException | If the specified culture is not valid.

Remarks

The ToUpper method returns a string in lower case with the specified locale set by the information provided by CultureInfo.

See Also

String Class | String Members | System Namespace | String.ToUpper Overload List


String.Trim

Trims white space from a string.

Overload List

Trims the white space from both ends of the string.

[Visual Basic] Overloads Public Function Trim() As String
[C#] public string Trim();
[C++] public: String* Trim();
[JScript] public function Trim() : String;

Removes the given characters from both ends of the string.

[Visual Basic] Overloads Public Function Trim(Char()) As String
[C#] public string Trim(char[]);
[C++] public: String* Trim(__wchar_t*[]);
[JScript] public function Trim(Char[]) : String;

See Also

String Class | String Members | System Namespace


String.Trim ()

Trims the white space from both ends of the string.

[Visual Basic]
Overloads Public Function Trim() As String
[C#]
public string Trim();
[C++]
public: String* Trim();
[JScript]
public function Trim() : String;

Return Value

The substring of characters remaining after the removal of any white space from both ends of this string.

Remarks

The Trim method removes the whitespace from the beginning and ending of a specified string. White space is defined by WhitespaceChars.

See Also

String Class | String Members | System Namespace | String.Trim Overload List


String.Trim (Char[])

Removes the given characters from both ends of the string.

[Visual Basic]
Overloads Public Function Trim( _
   ByVal trimChars() As Char _
) As String
[C#]
public string Trim(
   char[] trimChars
);
[C++]
public: String* Trim(
   __wchar_t* trimChars[]
);
[JScript]
public function Trim(
   trimChars : Char[]
) : String;

Parameters

trimChars
The array of characters to be removed.

Return Value

The substring of characters that remains after the removal of characters in trimChars from both ends of this string.

Remarks

This method begins with the first character in this string and continues to remove characters until a character is found that is not in the specified array, then it moves to the last character in this string and continues to remove characters until if finds a character that is not in the specified array. It repeats this until the end of the string. As a special case, white space can be removed from both ends of this string by passing null as the character array.

This method is case-sensitive. White space is defined by WhitespaceChars.

The trimChars parameter can be null to indicate that white space should be removed from the ends of this string.

See Also

String Class | String Members | System Namespace | String.Trim Overload List | Char


String.TrimEnd

Removes a string of characters from the end of this string.

[Visual Basic]
Public Function TrimEnd( _
   ByVal trimChars() As Char _
) As String
[C#]
public string TrimEnd(
   char[] trimChars
);
[C++]
public: String* TrimEnd(
   __wchar_t* trimChars[]
);
[JScript]
public function TrimEnd(
   trimChars : Char[]
) : String;

Parameters

trimChars
A set of characters removed from the end of this string.

Return Value

Returns the substring of characters remaining after the removal of characters from the end of this string.

Remarks

The TrimEnd method begins with the last character in this string and continues to remove characters until it finds a character that is not in the specified array.

As a special case, white space can be removed from the end of the string by passing null as the character array. White space is defined by WhitespaceChars.

The trimChars parameter can be null to indicate that white space should be removed from the end of the string.

See Also

String Class | String Members | System Namespace | Char


String.TrimStart

Removes characters from the beginning of this string.

[Visual Basic]
Public Function TrimStart( _
   ByVal trimChars() As Char _
) As String
[C#]
public string TrimStart(
   char[] trimChars
);
[C++]
public: String* TrimStart(
   __wchar_t* trimChars[]
);
[JScript]
public function TrimStart(
   trimChars : Char[]
) : String;

Parameters

trimChars
A set of characters to be removed from the beginning of the string.

Return Value

Returns the substring of characters remaining after the removal of the characters from the beginning of this string.

Remarks

The TrimStart method begins with the first character in this string and continues to remove characters until it finds a character that is not in the specified array. As a special case, white space can be removed from the beginning of the string by passing null as the character array. This procedure is case-sensitive.

White space is defined by WhitespaceChars.

The trimChars parameter can be null to indicate that white space should be removed from the beginning of the string.

See Also

String Class | String Members | System Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

String Fields

The fields of the String class are listed below. For a complete list of String class members, see the String Members topic.

Public:

Empty Representing the constant that is the empty string value.

See Also

String Class | System Namespace


String.Empty

Representing the constant that is the empty string value.

[Visual Basic]
Public Shared ReadOnly Empty As String
[C#]
public static readonly string Empty;
[C++]
public: static readonly String* Empty;
[JScript]
public static var Empty : String;

Remarks

A string constructor is called so that the compiler doesn't mark Empty as a literal. When Empty is marked as a literal, it would not show up as a field that could be accessed. This empty field is represented by "".

See Also

String Class | String Members | System Namespace


SystemException Class

Represents non-fatal, "less severe" errors that may occur.

Object
Exception
SystemException

[Visual Basic]
Public Class SystemException
   Inherits Exception
[C#]
public class SystemException : Exception
[C++]
public __gc class SystemException : public Exception
[JScript]
public class SystemException extends Exception

Remarks

The SystemException is the exception that are generated (that is, thrown) by the system when there are errors. These errors are the result of a failed "runtime check" (such as an array out-of-bounds error) and may occur during the execution of any method.

SystemException adds no new functionality to Exception.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

SystemException Members | System Namespace


SystemException Members

Public:

Constructor

SystemException Constructor Overloaded. Initializes a new instance of the SystemException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

SystemException Class | System Namespace


SystemException Constructor

Initializes a new instance of the SystemException class.

Overload List

Initializes a new instance of the SystemException class with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public SystemException();
[C++] public: SystemException();
[JScript] public function SystemException();

Initializes a new instance of the SystemException class with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public SystemException(String);
[C++] public: SystemException(String*);
[JScript] public function SystemException(String);

Initializes a new instance of the SystemException class with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public SystemException(String, Exception);
[C++] public: SystemException(String*, Exception);
[JScript] public function SystemException(String, Exception);

See Also

SystemException Class | SystemException Members | System Namespace


SystemException Constructor ()

Initializes a new instance of the SystemException class with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public SystemException();
[C++]
public: SystemException();
[JScript]
public function SystemException();

Remarks

SystemException() is the default.

SystemException inherits from the Exception class. This constructor sets the properties of the SystemException object as follows:

Property Type | Condition
InnerException | null
Message | The empty string.

See Also

SystemException Class | SystemException Members | System Namespace | SystemException Constructor Overload List


SystemException Constructor (String)

Initializes a new instance of the SystemException class with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public SystemException(
   string message
);
[C++]
public: SystemException(
   String* message
);
[JScript]
public function SystemException(
   message : String
);

Parameters

message
The message that indicates the reason the exception occurred.

Remarks

SystemException inherits from the Exception class. This constructor sets the properties of the SystemException object as follows:

Property Type | Condition
InnerException | null
Message | The message string.

See Also

SystemException Class | SystemException Members | System Namespace | SystemException Constructor Overload List


SystemException Constructor (String, Exception)

Initializes a new instance of the SystemException class with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public SystemException(
   string message,
   Exception inner
);
[C++]
public: SystemException(
   String* message,
   Exception* inner
);
[JScript]
public function SystemException(
   message : String,
   inner : Exception
);

Parameters

message
The message that indicates the reason the exception occurred.
inner
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

SystemException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | The inner exception.
Message | The message string.

See Also

SystemException Class | SystemException Members | System Namespace | SystemException Constructor Overload List


ThreadStaticAttribute Class

Provides for type member fields that are relative for the thread. Whenever the static field is accessed on a particular thread it will be unique or relative for that thread only. The static is not shared between threads. If the static field is access on another thread the field will contain a different value, since the field is unique per thread. Null initialization of thread local statics. The member field is marked with a custom attribute ThreadStaticAttribute.

Object
Attribute
ThreadStaticAttribute

[Visual Basic]
Public Class ThreadStaticAttribute
   Inherits Attribute
[C#]
public class ThreadStaticAttribute : Attribute
[C++]
public __gc class ThreadStaticAttribute : public Attribute
[JScript]
public class ThreadStaticAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

Example [C#]

[C#]

class Foo
{
   int a;
   static int b;
   [ThreadStaticAttribute()]
   static int c;

   int d=5;
   static int e=6;
   [ThreadStaticAttribute()]
   static int f=7;

   Foo()
   {
      a = 1;
      b = 2;
      c = 3;
   }

   void Method1()
   {
      Console.WriteLine("{0}", a);
      Console.WriteLine("{0}", b);
      Console.WriteLine("{0}", c);
      Console.WriteLine("{0}", d);
      Console.WriteLine("{0}", e);
      Console.WriteLine("{0}", f);
   }
}

Field a is an unintialized instance member.

Field b is an uninitalized static member.

Field c is an uninitialized relative static member.

Field d is an initialized instance member.

Field e is an initialized static member.

Field f is an initialized relative static member.

See Also

ThreadStaticAttribute Members | System Namespace


ThreadStaticAttribute Members

Public:

Constructor

ThreadStaticAttribute Constructor Initializes an new instance of the ThreadStaticAttribute class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ThreadStaticAttribute Class | System Namespace


ThreadStaticAttribute Constructor

Initializes an new instance of the ThreadStaticAttribute class.

[Visual Basic]
Public Sub New()
[C#]
public ThreadStaticAttribute();
[C++]
public: ThreadStaticAttribute();
[JScript]
public function ThreadStaticAttribute();

See Also

ThreadStaticAttribute Class | ThreadStaticAttribute Members | System Namespace


TimeSpan Structure

Represents a period of time.

Object
ValueType
TimeSpan

[Visual Basic]
Public Structure TimeSpan
   Implements IComparable
[C#]
public struct TimeSpan : IComparable
[C++]
public __value struct TimeSpan : public IComparable

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

TimeSpan can be negative or positive.

The smallest unit of time is the "tick," which is equal to 100-nanoseconds. For example, a Ticks value of 0 represents the 0 time value, which has the string representation "00:00:00" ("hh:mm:ss"). Each additional tick increases the time by 100-nanoseconds.

The Ticks value can also be negative; a Ticks value of negative 1 represents the time "-00:00:00.0000001".

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

TimeSpan Members | System Namespace


TimeSpan Members

Public:

Constructor

TimeSpan Constructor Overloaded. Initializes a new instance of the TimeSpan class.

Properties

Days | Retrieves the number of whole days represented by the current instance.
Hours | Retrieves the number of whole hours represented by the current instance.
Milliseconds | Retrieves the number of whole milliseconds represented by the current instance.
Minutes | Retrieves the number of whole minutes represented by the current instance.
Seconds | Retrieves the number of whole seconds represented by the current instance.
Ticks | Retrieves the number of whole ticks represented by the current instance.
TotalDays | Retrieves the total number of days represented by the current instance.
TotalHours | Retrieves the number of whole hours represented by the current instance.
TotalMilliseconds | Retrieves the number of whole milliseconds represented by the current instance.
TotalMinutes | Retrieves the number of whole minutes represented by the current instance.
TotalSeconds | Retrieves the number of whole seconds represented by the current instance.

Methods

Add | Adds the current instance to the specified TimeSpan.
Compare | Compares two TimeSpan values and returns an integer that indicates their relationship.
CompareTo | Compares the TimeSpan value of the current instance with the specified object.
Duration | Gets the duration of the current time span.
Equals | Overloaded. Determines whether two TimeSpan objects represent the same time.
FromDays | Creates a TimeSpan that represents the number of days specified by a value specified to the nearest millisecond.
FromHours | Creates a TimeSpan that represents the number of hours specified by a value specified to the nearest millisecond.
FromMilliseconds | Creates a TimeSpan that represents the number of milliseconds specified.
FromMinutes | Creates a TimeSpan that represents the number of minutes specified.
FromSeconds | Creates a TimeSpan that represents the number of seconds specified by a specified value.
FromString | Constructs a TimeSpan from a string.
FromTicks | Creates a TimeSpan with a specified ticks value.
GetHashCode | Gets a hash code for the current instance.
GetType (inherited from Object) | Gets the Type of the Object.
Negate | Negates the current TimeSpan new instance.
Parse | Constructs a TimeSpan from a string.
Subtract | Subtracts a specified TimeSpan value from the current instance.
ToString | Overloaded. Converts a TimeSpan to a String.

Operators

Addition Operator | Adds two TimeSpan values.
Equality Operator | Determines whether two TimeSpan objects are equal.
Greater Than Operator | Determines whether the first TimeSpan is greater than to the second TimeSpan.
Greater Than Or Equal Operator | Determines wheter the first TimeSpan is greater than and equal to the second TimeSpan.
Inequality Operator | Determines whether two TimeSpan objects are equal.
Less Than Operator | Determines whether the first TimeSpan is less than to the second TimeSpan.
Less Than Or Equal Operator | Determines wheter the first TimeSpan is less than and equal to the second TimeSpan.
Subtraction Operator | Subtracts one TimeSpan value from specified TimeSpan.
Unary Negation Operator | Subtracts a specified TimeSpan from this instance.

Fields

Empty | Represents the constant that is an empty TimeSpan.
MaxValue | Represents the constant that is the maximum TimeSpan value.
MinValue | Represents the constant that is the smallest TimeSpan value.
TicksPerDay | Indicates the number of ticks equivalent to 1 day.
TicksPerHour | Indicates the number of ticks equivalent to 1 hour.
TicksPerMillisecond | Indicates the number of ticks equivalent to 1 millisecond.
TicksPerMinute | Indicates the number of ticks equivalent to 1 minute.
TicksPerSecond | Indicates the number of ticks equivalent to 1 second.
Zero | Represents the zero TimeSpan value.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimeSpan Structure | System Namespace


TimeSpan Constructor

Initializes a new instance of the TimeSpan class.

Overload List

Initializes a new instance of the TimeSpan class to a specified number of ticks.

[Visual Basic] Overloads Public Sub New(Long)
[C#] public TimeSpan(long);
[C++] public: TimeSpan(__int64);
[JScript] public function TimeSpan(long);

Initializes a new instance of the TimeSpan class to a specified number of hours, minutes, and seconds.

[Visual Basic] Overloads Public Sub New(Integer, Integer, Integer)
[C#] public TimeSpan(int, int, int);
[C++] public: TimeSpan(int, int, int);
[JScript] public function TimeSpan(int, int, int);

Initializes a new instance of the TimeSpan class to a specified number of days, hours, minutes, and seconds.

[Visual Basic] Overloads Public Sub New(Integer, Integer, Integer, Integer)
[C#] public TimeSpan(int, int, int, int);
[C++] public: TimeSpan(int, int, int, int);
[JScript] public function TimeSpan(int, int, int, int);

Initializes a new instance of the TimeSpan class to a specified number of days, hours, minutes, and seconds.

[Visual Basic] Overloads Public Sub New(Integer, Integer, Integer, Integer, Integer)
[C#] public TimeSpan(int, int, int, int, int);
[C++] public: TimeSpan(int, int, int, int, int);
[JScript] public function TimeSpan(int, int, int, int, int);

See Also

TimeSpan Structure | TimeSpan Members | System Namespace


TimeSpan Constructor (Int64)

Initializes a new instance of the TimeSpan class to a specified number of ticks.

[Visual Basic]
Overloads Public Sub New( _
   ByVal ticks As Long _
)
[C#]
public TimeSpan(
   long ticks
);
[C++]
public: TimeSpan(
   __int64 ticks
);
[JScript]
public function TimeSpan(
   ticks : long
);

Parameters

ticks
The number of ticks to initialize the TimeSpan with.

Remarks

See TicksPerMillisecond.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | TimeSpan Constructor Overload List | Int64


TimeSpan Constructor (Int32, Int32, Int32)

Initializes a new instance of the TimeSpan class to a specified number of hours, minutes, and seconds.

[Visual Basic]
Overloads Public Sub New( _
   ByVal hours As Integer, _
   ByVal minutes As Integer, _
   ByVal seconds As Integer _
)
[C#]
public TimeSpan(
   int hours,
   int minutes,
   int seconds
);
[C++]
public: TimeSpan(
   int hours,
   int minutes,
   int seconds
);
[JScript]
public function TimeSpan(
   hours : int,
   minutes : int,
   seconds : int
);

Parameters

hours
The number of hours.
minutes
The number of minutes.
seconds
The number of seconds.

Exceptions

Exception Type | Condition
ArgumentException | If any of the arguments are negative.
OverflowException | If the computed ticks value is less than TimeSpan.MinValue or greater than TimeSpan.MaxValue.

Remarks

The Ticks value is computed by converting hours and minutes into seconds, and then multiplying the total number of seconds by TicksPerSecond. The equation is:

Ticks = ((long)hour * 3600 + (long)minute * 60 + (long)second) * TicksPerSecond

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | TimeSpan Constructor Overload List | Int64


TimeSpan Constructor (Int32, Int32, Int32, Int32)

Initializes a new instance of the TimeSpan class to a specified number of days, hours, minutes, and seconds.

[Visual Basic]
Overloads Public Sub New( _
   ByVal days As Integer, _
   ByVal hours As Integer, _
   ByVal minutes As Integer, _
   ByVal seconds As Integer _
)
[C#]
public TimeSpan(
   int days,
   int hours,
   int minutes,
   int seconds
);
[C++]
public: TimeSpan(
   int days,
   int hours,
   int minutes,
   int seconds
);
[JScript]
public function TimeSpan(
   days : int,
   hours : int,
   minutes : int,
   seconds : int
);

Parameters

days
A number of days.
hours
A number of hours.
minutes
A number of minutes.
seconds
A number of seconds.

Exceptions

Exception Type | Condition
ArgumentException | If any of the arguments are negative.
OverflowException | If the computed ticks value is less than MinValue or greater than MaxValue.

Remarks

The Ticks s value is computed by converting hours and minutes into seconds, multiplying the total number of seconds by TicksPerSecond, and then adding this to the product of days and TicksPerDay. The equation is:

Ticks = (long)days * TicksPerDay + ((long)hour * 3600 + (long)minute * 60 + (long)second) * TicksPerSecond

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | TimeSpan Constructor Overload List | Int64


TimeSpan Constructor (Int32, Int32, Int32, Int32, Int32)

Initializes a new instance of the TimeSpan class to a specified number of days, hours, minutes, and seconds.

[Visual Basic]
Overloads Public Sub New( _
   ByVal days As Integer, _
   ByVal hours As Integer, _
   ByVal minutes As Integer, _
   ByVal seconds As Integer, _
   ByVal milliSeconds As Integer _
)
[C#]
public TimeSpan(
   int days,
   int hours,
   int minutes,
   int seconds,
   int milliSeconds
);
[C++]
public: TimeSpan(
   int days,
   int hours,
   int minutes,
   int seconds,
   int milliSeconds
);
[JScript]
public function TimeSpan(
   days : int,
   hours : int,
   minutes : int,
   seconds : int,
   milliSeconds : int
);

Parameters

days
A number of days.
hours
A number of hours.
minutes
A number of minutes.
seconds
A number of seconds.
milliSeconds
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentException | If any of the arguments are negative.
OverflowException | If the computed ticks value is less than MinValue or greater than MaxValue.

Remarks

The Ticks s value is computed by converting hours and minutes into seconds, multiplying the total number of seconds by TicksPerSecond, and then adding this to the product of days and TicksPerDay. The equation is:

Ticks = (long)days * TicksPerDay + ((long)hour * 3600 + (long)minute * 60 + (long)second) * TicksPerSecond + milliSeconds * TicksPerSecond

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | TimeSpan Constructor Overload List | Int64


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TimeSpan Properties

The properties of the TimeSpan structure are listed below. For a complete list of TimeSpan structure members, see the TimeSpan Members topic.

Public:

Days | Retrieves the number of whole days represented by the current instance.
Hours | Retrieves the number of whole hours represented by the current instance.
Milliseconds | Retrieves the number of whole milliseconds represented by the current instance.
Minutes | Retrieves the number of whole minutes represented by the current instance.
Seconds | Retrieves the number of whole seconds represented by the current instance.
Ticks | Retrieves the number of whole ticks represented by the current instance.
TotalDays | Retrieves the total number of days represented by the current instance.
TotalHours | Retrieves the number of whole hours represented by the current instance.
TotalMilliseconds | Retrieves the number of whole milliseconds represented by the current instance.
TotalMinutes | Retrieves the number of whole minutes represented by the current instance.
TotalSeconds | Retrieves the number of whole seconds represented by the current instance.

See Also

TimeSpan Structure | System Namespace


TimeSpan.Days

Retrieves the number of whole days represented by the current instance.

[Visual Basic]
Public ReadOnly Property Days As Integer
[C#]
public int Days {get;}
[C++]
public: __property int get_Days();
[JScript]
public function get Days() : int;

Property Value

Read-only.

The number of days represented by the current instance.

Remarks

If the current instance represents a fractional number of days, the return value is rounded down.

Note If ToString returns "+d.hh:mm:ss"; the return value of Days is d.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | Int64 | ToString


TimeSpan.Hours

Retrieves the number of whole hours represented by the current instance.

[Visual Basic]
Public ReadOnly Property Hours As Integer
[C#]
public int Hours {get;}
[C++]
public: __property int get_Hours();
[JScript]
public function get Hours() : int;

Property Value

Read only.

The value is an integer between 0 and 23 corresponding to the hour of the day represented by the current instance.

Remarks

Note that if ToString returns "+d.hh:mm:ss", the return value of GetHours is hh.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | Int64


TimeSpan.Milliseconds

Retrieves the number of whole milliseconds represented by the current instance.

[Visual Basic]
Public ReadOnly Property Milliseconds As Integer
[C#]
public int Milliseconds {get;}
[C++]
public: __property int get_Milliseconds();
[JScript]
public function get Milliseconds() : int;

Property Value

Read only.

The value is an integer between 0 and 999 corresponding to the milliseconds represented by the current instance.

Remarks

Note that if ToString returns +d.hh:mm:ss.uu", the return value of GetMilliseconds is .uu *103 (rounded down if necessary).

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | Int64


TimeSpan.Minutes

Retrieves the number of whole minutes represented by the current instance.

[Visual Basic]
Public ReadOnly Property Minutes As Integer
[C#]
public int Minutes {get;}
[C++]
public: __property int get_Minutes();
[JScript]
public function get Minutes() : int;

Property Value

Read only.

The value is an integer between 0 and 59 corresponding to the minutes represented by the current instance.

Remarks

The TotalMinutes property returns the total number of minutes as a double-recision floating point number that is calculated by using TicksPerMinute.

Note that if ToString returns "+d.hh:mm:ss", the return value of GetMinutes is mm.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | Int64


TimeSpan.Seconds

Retrieves the number of whole seconds represented by the current instance.

[Visual Basic]
Public ReadOnly Property Seconds As Integer
[C#]
public int Seconds {get;}
[C++]
public: __property int get_Seconds();
[JScript]
public function get Seconds() : int;

Property Value

Read only.

The value is an integer between 0 and 59 corresponding to the seconds represented by the current instance.

Remarks

The TotalSeconds property returns the total number of seconds as a double-recision floating point number that is calculated by using TicksPerSecond.

Note that if ToString returns "+d.hh:mm:ss.uu", the return value of GetSeconds is ss.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | Int64


TimeSpan.Ticks

Retrieves the number of whole ticks represented by the current instance.

[Visual Basic]
Public ReadOnly Property Ticks As Long
[C#]
public long Ticks {get;}
[C++]
public: __property __int64 get_Ticks();
[JScript]
public function get Ticks() : long;

Property Value

Read only.

Retrieves the number of ticks represented by the current instance.

Remarks

The smallest unit of time is the "tick," which is equal to 100-nanoseconds. For example, a ticks value of 0 represents the 0 time value, which has the string representation "00:00:00" ("hh:mm:ss"). Each additional tick increases the time by 100-nanoseconds.The Ticks value can also be negative; a Ticks value of negative 1 represents the time "-00:00:00.0000001".

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | Int64


TimeSpan.TotalDays

Retrieves the total number of days represented by the current instance.

[Visual Basic]
Public ReadOnly Property TotalDays As Double
[C#]
public double TotalDays {get;}
[C++]
public: __property double get_TotalDays();
[JScript]
public function get TotalDays() : double;

Property Value

Read only.

Retrieves the total number of days represented by the current instance.

Remarks

The TotalDays property returns the total number of days as a double-recision floating point number that is calculated by using TicksPerDay.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | Double


TimeSpan.TotalHours

Retrieves the number of whole hours represented by the current instance.

[Visual Basic]
Public ReadOnly Property TotalHours As Double
[C#]
public double TotalHours {get;}
[C++]
public: __property double get_TotalHours();
[JScript]
public function get TotalHours() : double;

Property Value

Read only.

Retrieves the total number of hours represented by the current instance.

Remarks

The TotalHours property returns the total number of hours as a double-recision floating point number that is calculated by using TicksPerHour.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | Double


TimeSpan.TotalMilliseconds

Retrieves the number of whole milliseconds represented by the current instance.

[Visual Basic]
Public ReadOnly Property TotalMilliseconds As Double
[C#]
public double TotalMilliseconds {get;}
[C++]
public: __property double get_TotalMilliseconds();
[JScript]
public function get TotalMilliseconds() : double;

Property Value

Read only.

Retrieves the total number of milliseconds represented by the current instance.

Remarks

The TotalMilliseconds property returns the total number of milliseconds as a double-recision floating point number that is calculated by using TicksPerMillisecond.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | Double


TimeSpan.TotalMinutes

Retrieves the number of whole minutes represented by the current instance.

[Visual Basic]
Public ReadOnly Property TotalMinutes As Double
[C#]
public double TotalMinutes {get;}
[C++]
public: __property double get_TotalMinutes();
[JScript]
public function get TotalMinutes() : double;

Property Value

Read only.

Retrieves the total number of minutes represented by the current instance.

Remarks

The TotalMinutes property returns the total number of minutes as a double-recision floating point number that is calculated by using TicksPerMinute.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace


TimeSpan.TotalSeconds

Retrieves the number of whole seconds represented by the current instance.

[Visual Basic]
Public ReadOnly Property TotalSeconds As Double
[C#]
public double TotalSeconds {get;}
[C++]
public: __property double get_TotalSeconds();
[JScript]
public function get TotalSeconds() : double;

Property Value

Read only.

Retrieves the total number of seconds represented by the current instance.

Remarks

The TotalSeconds property returns the total number of seconds as a double-recision floating point number that is calculated by using TicksPerSecond.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | Double


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TimeSpan Methods

The methods of the TimeSpan structure are listed below. For a complete list of TimeSpan structure members, see the TimeSpan Members topic.

Public:

Add | Adds the current instance to the specified TimeSpan.
Compare | Compares two TimeSpan values and returns an integer that indicates their relationship.
CompareTo | Compares the TimeSpan value of the current instance with the specified object.
Duration | Gets the duration of the current time span.
Equals | Overloaded. Determines whether two TimeSpan objects represent the same time.
FromDays | Creates a TimeSpan that represents the number of days specified by a value specified to the nearest millisecond.
FromHours | Creates a TimeSpan that represents the number of hours specified by a value specified to the nearest millisecond.
FromMilliseconds | Creates a TimeSpan that represents the number of milliseconds specified.
FromMinutes | Creates a TimeSpan that represents the number of minutes specified.
FromSeconds | Creates a TimeSpan that represents the number of seconds specified by a specified value.
FromString | Constructs a TimeSpan from a string.
FromTicks | Creates a TimeSpan with a specified ticks value.
GetHashCode | Gets a hash code for the current instance.
GetType (inherited from Object) | Gets the Type of the Object.
Negate | Negates the current TimeSpan new instance.
Parse | Constructs a TimeSpan from a string.
Subtract | Subtracts a specified TimeSpan value from the current instance.
ToString | Overloaded. Converts a TimeSpan to a String.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimeSpan Structure | System Namespace


TimeSpan.Add

Adds the current instance to the specified TimeSpan.

[Visual Basic]
Public Function Add( _
   ByVal ts As TimeSpan _
) As TimeSpan
[C#]
public TimeSpan Add(
   TimeSpan ts
);
[C++]
public: TimeSpan Add(
   TimeSpan ts
);
[JScript]
public function Add(
   ts : TimeSpan
) : TimeSpan;

Parameters

ts
The TimeSpan to add to the current instance.

Return Value

A TimeSpan that represents the sum of the current instance and ts.

Remarks

The Add value of the sum must be between MinValue and MaxValue, otherwise an exception will be thrown.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace


TimeSpan.Compare

Compares two TimeSpan values and returns an integer that indicates their relationship.

[Visual Basic]
Public Shared Function Compare( _
   ByVal t1 As TimeSpan, _
   ByVal t2 As TimeSpan _
) As Integer
[C#]
public static int Compare(
   TimeSpan t1,
   TimeSpan t2
);
[C++]
public: static int Compare(
   TimeSpan t1,
   TimeSpan t2
);
[JScript]
public static function Compare(
   t1 : TimeSpan,
   t2 : TimeSpan
) : int;

Parameters

t1
The left operand.
t2
The right operand.

Return Value

Value | Condition
-1 | If the first TimeSpan is less than the second TimeSpan.
0 | If the first TimeSpan is equal to the second TimeSpan.
1 | If the first TimeSpan is greater than the second TimeSpan.

Remarks

The return value is an integer of the relationship of the parameters based upon the evaluation of the following:

  • -1 if t1 < t2,
  • 0 if t1 = t, and
  • 1 if t1 = t2.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | Int64


TimeSpan.CompareTo

Compares the TimeSpan value of the current instance with the specified object.

[Visual Basic]
Overridable Public Function CompareTo( _
   ByVal value As Object _
) As Integer
[C#]
public virtual int CompareTo(
   object value
);
[C++]
public: virtual int CompareTo(
   Object* value
);
[JScript]
public function CompareTo(
   value : Object
) : int;

Parameters

value
The object to compare with the current instance.

Return Value

Value | Condition
A negative integer | If this instance is less than object.
A zero | If the current instance and object have the same value.
A positive integer | If the current instance is greater than object.
A positive integer | If object is a null reference (in Visual Basic Nothing). This is a special case.

Exceptions

Exception Type | Condition
ArgumentException | If the object isn't a TimeSpan.

Remarks

The value parameter must be either a TimeSpan type or a null object reference.

In the comparison of two TimeSpan values, the number of ticks is used to determine the ordering. A new instance, regardless of its value, is considered to be greater than a null reference.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | Int64 | Object | Ticks


TimeSpan.Duration

Gets the duration of the current time span.

[Visual Basic]
Public Function Duration() As TimeSpan
[C#]
public TimeSpan Duration();
[C++]
public: TimeSpan Duration();
[JScript]
public function Duration() : TimeSpan;

Return Value

A TimeSpan representing the absolute value of the current instance.

Remarks

The Duration method returns a new TimeSpan instance that is based upon an evaluation of two specified ticks values.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | Ticks


TimeSpan.Equals

Determines whether two TimeSpan objects represent the same time.

Overload List

Determines whether two TimeSpan objects represent the same time.

[Visual Basic] Overloads Public Shared Function Equals(TimeSpan, TimeSpan) As Boolean
[C#] public static bool Equals(TimeSpan, TimeSpan);
[C++] public: static bool Equals(TimeSpan, TimeSpan);
[JScript] public static function Equals(TimeSpan, TimeSpan) : Boolean;

Determines whether the current TimeSpan and a specified object represent the same time.

[Visual Basic] Overloads Overrides Public Function Equals(Object) As Boolean
[C#] public override bool Equals(Object);
[C++] public: override bool Equals(Object*);
[JScript] public override function Equals(Object) : Boolean;

See Also

TimeSpan Structure | TimeSpan Members | System Namespace


TimeSpan.Equals (TimeSpan, TimeSpan)

Determines whether two TimeSpan objects represent the same time.

[Visual Basic]
Overloads Public Shared Function Equals( _
   ByVal t1 As TimeSpan, _
   ByVal t2 As TimeSpan _
) As Boolean
[C#]
public static bool Equals(
   TimeSpan t1,
   TimeSpan t2
);
[C++]
public: static bool Equals(
   TimeSpan t1,
   TimeSpan t2
);
[JScript]
public static function Equals(
   t1 : TimeSpan,
   t2 : TimeSpan
) : Boolean;

Parameters

t1
A TimeSpan object.
t2
Another TimeSpan object.

Return Value

true if the two TimeSpan objects represent the same time; otherwise, false.

Remarks

The Equals method returns a true result when it compares the first TimeSpan object to another TimeSpan object (t1 = t2) and if they represent the same time. If they are unequal then it returns false.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | TimeSpan.Equals Overload List | Boolean


TimeSpan.Equals (Object)

Determines whether the current TimeSpan and a specified object represent the same time.

[Visual Basic]
Overloads Overrides Public Function Equals( _
   ByVal value As Object _
) As Boolean
[C#]
public override bool Equals(
   object value
);
[C++]
public: override bool Equals(
   Object* value
);
[JScript]
public override function Equals(
   value : Object
) : Boolean;

Parameters

value
The value to compare with the current instance.

Return Value

true if value is a TimeSpan that represents the same time as the current instance; otherwise, false.

Remarks

The Equals method evaluates two TimeSpan objects and returns a Boolean determination of their relationship.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | TimeSpan.Equals Overload List | Object


TimeSpan.FromDays

Creates a TimeSpan that represents the number of days specified by a value specified to the nearest millisecond.

[Visual Basic]
Public Shared Function FromDays( _
   ByVal value As Double _
) As TimeSpan
[C#]
public static TimeSpan FromDays(
   double value
);
[C++]
public: static TimeSpan FromDays(
   double value
);
[JScript]
public static function FromDays(
   value : double
) : TimeSpan;

Parameters

value
A floating-point number in units of days.

Return Value

A TimeSpan that represents the number of days specified by value to the nearest millisecond.

Remarks

The ticks value is computed by converting value from units of days to units of milliseconds, rounding to the nearest integer, and then converting from milliseconds to ticks.

Note that MaxValue is returned if the value parameter is PositiveInfinity. MinValue is returned if value is NegativeInfinity or NaN.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | Double


TimeSpan.FromHours

Creates a TimeSpan that represents the number of hours specified by a value specified to the nearest millisecond.

[Visual Basic]
Public Shared Function FromHours( _
   ByVal value As Double _
) As TimeSpan
[C#]
public static TimeSpan FromHours(
   double value
);
[C++]
public: static TimeSpan FromHours(
   double value
);
[JScript]
public static function FromHours(
   value : double
) : TimeSpan;

Parameters

value
A floating-point number in units of hours.

Return Value

A TimeSpan that represents value to the nearest millisecond.

Remarks

The ticks value is computed by converting the value parameter from units of hours to units of milliseconds, rounding to the nearest integer, and then converting from milliseconds to ticks.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | Double | Ticks | Milliseconds


TimeSpan.FromMilliseconds

Creates a TimeSpan that represents the number of milliseconds specified.

[Visual Basic]
Public Shared Function FromMilliseconds( _
   ByVal value As Double _
) As TimeSpan
[C#]
public static TimeSpan FromMilliseconds(
   double value
);
[C++]
public: static TimeSpan FromMilliseconds(
   double value
);
[JScript]
public static function FromMilliseconds(
   value : double
) : TimeSpan;

Parameters

value
A floating-point number in units of milliseconds.

Return Value

A TimeSpan that represents value to the nearest millisecond.

Remarks

The ticks value is computed by rounding value to the nearest integer and then converting from milliseconds to ticks.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | Double | Ticks | Milliseconds


TimeSpan.FromMinutes

Creates a TimeSpan that represents the number of minutes specified.

[Visual Basic]
Public Shared Function FromMinutes( _
   ByVal value As Double _
) As TimeSpan
[C#]
public static TimeSpan FromMinutes(
   double value
);
[C++]
public: static TimeSpan FromMinutes(
   double value
);
[JScript]
public static function FromMinutes(
   value : double
) : TimeSpan;

Parameters

value
A floating-point number in units of minutes.

Return Value

A TimeSpan that represents the number of minutes specified by value to the nearest millisecond.

Remarks

The ticks value is computed by converting the value parameter from units of minutes to units of milliseconds, rounding to the nearest integer, and then converting from milliseconds to ticks.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | Double | Ticks | Milliseconds


TimeSpan.FromSeconds

Creates a TimeSpan that represents the number of seconds specified by a specified value.

[Visual Basic]
Public Shared Function FromSeconds( _
   ByVal value As Double _
) As TimeSpan
[C#]
public static TimeSpan FromSeconds(
   double value
);
[C++]
public: static TimeSpan FromSeconds(
   double value
);
[JScript]
public static function FromSeconds(
   value : double
) : TimeSpan;

Parameters

value
A floating-point number in units of seconds.

Return Value

A TimeSpan that represents value to the nearest millisecond.

Remarks

The ticks value is computed by converting the value parameter from units of seconds to units of milliseconds, rounding to the nearest integer, and then converting from milliseconds to ticks.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | Double | Ticks | Milliseconds


TimeSpan.FromString

Constructs a TimeSpan from a string.

[Visual Basic]
Public Shared Function FromString( _
   ByVal s As String _
) As TimeSpan
[C#]
public static TimeSpan FromString(
   string s
);
[C++]
public: static TimeSpan FromString(
   String* s
);
[JScript]
public static function FromString(
   s : String
) : TimeSpan;

Parameters

s
The string to parse.

Return Value

A TimeSpan corresponding to the specified string.

Exceptions

Exception Type | Condition
ArgumentException | If the string is a null reference (in Visual Basic Nothing).
FormatException | If the string cannot be parsed.

Remarks

Leading and trailing white space characters are allowed.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | String | ToString


TimeSpan.FromTicks

Creates a TimeSpan with a specified ticks value.

[Visual Basic]
Public Shared Function FromTicks( _
   ByVal value As Long _
) As TimeSpan
[C#]
public static TimeSpan FromTicks(
   long value
);
[C++]
public: static TimeSpan FromTicks(
   __int64 value
);
[JScript]
public static function FromTicks(
   value : long
) : TimeSpan;

Parameters

value
The number of ticks used in initializing the new TimeSpan.

Return Value

A TimeSpan with a ticks value of value.

Remarks

This method is identical to the TimeSpan(Int64) constructor.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | Int64


TimeSpan.GetHashCode

Gets a hash code for the current instance.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

A hash code for the current instance.

Remarks

Two TimeSpan objects may have the same hash code, even though they represent different time values.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | Int64


TimeSpan.Negate

Negates the current TimeSpan new instance.

[Visual Basic]
Public Function Negate() As TimeSpan
[C#]
public TimeSpan Negate();
[C++]
public: TimeSpan Negate();
[JScript]
public function Negate() : TimeSpan;

Return Value

A TimeSpan represented by the negative value of t.

Remarks

An exception occurs because the magnitude of MinValue is one (1) tick larger than MaxValue.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace


TimeSpan.Parse

Constructs a TimeSpan from a string.

[Visual Basic]
Public Shared Function Parse( _
   ByVal s As String _
) As TimeSpan
[C#]
public static TimeSpan Parse(
   string s
);
[C++]
public: static TimeSpan Parse(
   String* s
);
[JScript]
public static function Parse(
   s : String
) : TimeSpan;

Parameters

s
The string to parse.

Return Value

A TimeSpan that corresponds to s.

Exceptions

Exception Type | Condition
ArgumentException | If the string is a null reference (in Visual Basic Nothing).
FormatException | If the staring cannot be parsed.

Remarks

Leading and trailing white space characters are allowed.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | String


TimeSpan.Subtract

Subtracts a specified TimeSpan value from the current instance.

[Visual Basic]
Public Function Subtract( _
   ByVal ts As TimeSpan _
) As TimeSpan
[C#]
public TimeSpan Subtract(
   TimeSpan ts
);
[C++]
public: TimeSpan Subtract(
   TimeSpan ts
);
[JScript]
public function Subtract(
   ts : TimeSpan
) : TimeSpan;

Parameters

ts
The TimeSpan to subtract from the current instance.

Return Value

The difference of the current instance and ts

(that is, the current instance minus ts).

Remarks

To prevent an exception, the difference must be between MinValue and MaxValue.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace


TimeSpan.ToString

Converts a TimeSpan to a String.

Overload List

Converts the value of the current TimeSpan to a String.

[Visual Basic] Overloads Overrides Public Function ToString() As String
[C#] public override string ToString();
[C++] public: override String* ToString();
[JScript] public override function ToString() : String;

Converts the value of a specified TimeSpan to a String.

[Visual Basic] Overloads Public Shared Function ToString(TimeSpan) As String
[C#] public static string ToString(TimeSpan);
[C++] public: static String* ToString(TimeSpan);
[JScript] public static function ToString(TimeSpan) : String;

See Also

TimeSpan Structure | TimeSpan Members | System Namespace


TimeSpan.ToString ()

Converts the value of the current TimeSpan to a String.

[Visual Basic]
Overloads Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

A string representation of the current TimeSpan.

Remarks

The return value has the following format +

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | TimeSpan.ToString Overload List


TimeSpan.ToString (TimeSpan)

Converts the value of a specified TimeSpan to a String.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal time As TimeSpan _
) As String
[C#]
public static string ToString(
   TimeSpan time
);
[C++]
public: static String* ToString(
   TimeSpan time
);
[JScript]
public static function ToString(
   time : TimeSpan
) : String;

Parameters

time
A TimeSpan value.

Return Value

A string representation of the current TimeSpan.

Remarks

The return value has the following format +

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | TimeSpan.ToString Overload List


Operators

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TimeSpan Operators

The operators of the TimeSpan structure are listed below. For a complete list of TimeSpan structure members, see the TimeSpan Members topic.

Public:

Addition Operator | Adds two TimeSpan values.
Equality Operator | Determines whether two TimeSpan objects are equal.
Greater Than Operator | Determines whether the first TimeSpan is greater than to the second TimeSpan.
Greater Than Or Equal Operator | Determines wheter the first TimeSpan is greater than and equal to the second TimeSpan.
Inequality Operator | Determines whether two TimeSpan objects are equal.
Less Than Operator | Determines whether the first TimeSpan is less than to the second TimeSpan.
Less Than Or Equal Operator | Determines wheter the first TimeSpan is less than and equal to the second TimeSpan.
Subtraction Operator | Subtracts one TimeSpan value from specified TimeSpan.
Unary Negation Operator | Subtracts a specified TimeSpan from this instance.

See Also

TimeSpan Structure | System Namespace


TimeSpan Addition Operator

Adds two TimeSpan values.

[C#]
public static TimeSpan operator +(
   TimeSpan t1,
   TimeSpan t2
);
[C++]
public: static TimeSpan operator op_Addition(
   TimeSpan t1,
   TimeSpan t2
);
[JScript]
returnValue = t1 + t2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

t1
The first TimeSpan.
t2
The second TimeSpan.

Parameters [C#, C++]

t1
The first TimeSpan.
t2
The second TimeSpan.

Return Value [C#, C++, JScript]

A TimeSpan that is the sum of the two TimeSpan values.

Remarks [C#, C++, JScript]

This TimeSpan operator performs the arithmetic operation of addition and returns a new TimeSpan that is the sum of the addition (t1

+ t2).

See Also

TimeSpan Structure | TimeSpan Members | System Namespace


TimeSpan Equality Operator

Determines whether two TimeSpan objects are equal.

[C#]
public static bool operator ==(
   TimeSpan t1,
   TimeSpan t2
);
[C++]
public: static bool operator op_Equality(
   TimeSpan t1,
   TimeSpan t2
);
[JScript]
returnValue = t1 == t2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

t1
The first TimeSpan.
t2
The second TimeSpan.

Parameters [C#, C++]

t1
The first TimeSpan.
t2
The second TimeSpan.

Return Value [C#, C++, JScript]

true if t1 and t2

represent the same time; otherwise, false.

Remarks [C#, C++, JScript]

This TimeSpan operator performs the arithmetic function of equality and returns a Boolean determination of their relationship.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | Equals


TimeSpan Greater Than Operator

Determines whether the first TimeSpan is greater than to the second TimeSpan.

[C#]
public static bool operator >(
   TimeSpan t1,
   TimeSpan t2
);
[C++]
public: static bool operator op_GreaterThan(
   TimeSpan t1,
   TimeSpan t2
);
[JScript]
returnValue = t1 > t2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

t1
The first TimeSpan.
t2
The second TimeSpan.

Parameters [C#, C++]

t1
The first TimeSpan.
t2
The second TimeSpan.

Return Value [C#, C++, JScript]

true if t1

is the greater than t2; otherwise. false.

Remarks [C#, C++, JScript]

This TimeSpan operator performs the arithmetic function of comparing two TimeSpan values whether the first TimeSpan is greater than the second TimeSpan (t1 > t2) and returning a Boolean determination of their relationship.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace


TimeSpan Greater Than Or Equal Operator

Determines wheter the first TimeSpan is greater than and equal to the second TimeSpan.

[C#]
public static bool operator >=(
   TimeSpan t1,
   TimeSpan t2
);
[C++]
public: static bool operator op_GreaterThanOrEqual(
   TimeSpan t1,
   TimeSpan t2
);
[JScript]
returnValue = t1 >= t2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

t1
The first TimeSpan.
t2
The second TimeSpan.

Parameters [C#, C++]

t1
The first TimeSpan.
t2
The second TimeSpan.

Return Value [C#, C++, JScript]

true if t1 is the greater than and equal to t2; otherwise. false.

Remarks [C#, C++, JScript]

This TimeSpan operator performs the arithmetic function of comparing two TimeSpan values whether the first TimeSpan is greater than and equal to the second TimeSpan (t1 >= t2) and returning a Boolean determination of their relationship.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace


TimeSpan Inequality Operator

Determines whether two TimeSpan objects are equal.

[C#]
public static bool operator !=(
   TimeSpan t1,
   TimeSpan t2
);
[C++]
public: static bool operator op_Inequality(
   TimeSpan t1,
   TimeSpan t2
);
[JScript]
returnValue = t1 ! = t2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

t1
The first TimeSpan.
t2
The second TimeSpan.

Parameters [C#, C++]

t1
The first TimeSpan.
t2
The second TimeSpan.

Return Value [C#, C++, JScript]

true if t1 and t2

represent the same time; otherwise, false.

Remarks [C#, C++, JScript]

This TimeSpan operator performs the arithmetic function of equality and returns a Boolean determination of their relationship.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace


TimeSpan Less Than Operator

Determines whether the first TimeSpan is less than to the second TimeSpan.

[C#]
public static bool operator <(
   TimeSpan t1,
   TimeSpan t2
);
[C++]
public: static bool operator op_LessThan(
   TimeSpan t1,
   TimeSpan t2
);
[JScript]
returnValue = t1 < t2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

t1
The first TimeSpan.
t2
The second TimeSpan.

Parameters [C#, C++]

t1
The first TimeSpan.
t2
The second TimeSpan.

Return Value [C#, C++, JScript]

true if t1 is the less than t2; otherwise. false.

Remarks [C#, C++, JScript]

This TimeSpan operator performs the arithmetic function of comparing two TimeSpan values whether the first TimeSpan is less than the second TimeSpan (t1 < t2) and returning a Boolean determination of their relationship.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace


TimeSpan Less Than Or Equal Operator

Determines wheter the first TimeSpan is less than and equal to the second TimeSpan.

[C#]
public static bool operator <=(
   TimeSpan t1,
   TimeSpan t2
);
[C++]
public: static bool operator op_LessThanOrEqual(
   TimeSpan t1,
   TimeSpan t2
);
[JScript]
returnValue = t1 <= t2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

t1
The first TimeSpan.
t2
The second TimeSpan.

Parameters [C#, C++]

t1
The first TimeSpan.
t2
The second TimeSpan.

Return Value [C#, C++, JScript]

true if t1 is the less than and equal to t2; otherwise. false.

Remarks [C#, C++, JScript]

This TimeSpan operator performs the arithmetic function of comparing two TimeSpan values whether the first TimeSpan is less than and equal to the second TimeSpan (t1 <= t2) and returning a Boolean determination of their relationship.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace


TimeSpan Subtraction Operator

Subtracts one TimeSpan value from specified TimeSpan.

[C#]
public static TimeSpan operator -(
   TimeSpan t1,
   TimeSpan t2
);
[C++]
public: static TimeSpan operator op_Subtraction(
   TimeSpan t1,
   TimeSpan t2
);
[JScript]
returnValue = t1 - t2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

t1
The first TimeSpan.
t2
The second TimeSpan.

Parameters [C#, C++]

t1
The first TimeSpan.
t2
The second TimeSpan.

Return Value [C#, C++, JScript]

The TimeSpan that results from subtracting the two TimeSpan values.

Remarks [C#, C++, JScript]

This TimeSpan operator performs the arithmetic operation of subtracting two specified TimeSpan values (t1- t2). and returns a new TimeSpan that is the difference.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace


TimeSpan Unary Negation Operator

Subtracts a specified TimeSpan from this instance.

[C#]
public static TimeSpan operator -(
   TimeSpan t
);
[C++]
public: static TimeSpan operator op_UnaryNegation(
   TimeSpan t
);
[JScript]
returnValue = -t;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

t
The operand.

Parameters [C#, C++]

t
The operand.

Return Value [C#, C++, JScript]

A new TimeSpan.

Exceptions

Exception Type | Condition
OverflowException | If t is less than TimeSpan.MinValue.

Remarks [C#, C++, JScript]

This TimeSpan operator performs the arithmetic operation of subtracting a specified TimeSpan from the currrent instance and returns a new TimeSpan in ticks.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | MinValue | Ticks


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TimeSpan Fields

The fields of the TimeSpan structure are listed below. For a complete list of TimeSpan structure members, see the TimeSpan Members topic.

Public:

Empty | Represents the constant that is an empty TimeSpan.
MaxValue | Represents the constant that is the maximum TimeSpan value.
MinValue | Represents the constant that is the smallest TimeSpan value.
TicksPerDay | Indicates the number of ticks equivalent to 1 day.
TicksPerHour | Indicates the number of ticks equivalent to 1 hour.
TicksPerMillisecond | Indicates the number of ticks equivalent to 1 millisecond.
TicksPerMinute | Indicates the number of ticks equivalent to 1 minute.
TicksPerSecond | Indicates the number of ticks equivalent to 1 second.
Zero | Represents the zero TimeSpan value.

See Also

TimeSpan Structure | System Namespace


TimeSpan.Empty

Represents the constant that is an empty TimeSpan.

[Visual Basic]
Public Shared ReadOnly Empty As TimeSpan
[C#]
public static readonly TimeSpan Empty;
[C++]
public: static readonly TimeSpan Empty;
[JScript]
public static var Empty : TimeSpan;

Remarks

Empty has the value of zero. Empty is static, read only, and equal it zero. The hexadecimal value for Empty is (short)0x0.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace


TimeSpan.MaxValue

Represents the constant that is the maximum TimeSpan value.

[Visual Basic]
Public Shared ReadOnly MaxValue As TimeSpan
[C#]
public static readonly TimeSpan MaxValue;
[C++]
public: static readonly TimeSpan MaxValue;
[JScript]
public static var MaxValue : TimeSpan;

Remarks

MaxValue equals a new TimeSpan that equals MaxValue; the relationship is MaxValue = new TimeSpan(Int64.MaxValue).

The MaxValue field is positive 10675199.02:48:05.4775808.

The hexidecimal value for Int64.MaxValue is (short)0x7FFF.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | Int64


TimeSpan.MinValue

Represents the constant that is the smallest TimeSpan value.

[Visual Basic]
Public Shared ReadOnly MinValue As TimeSpan
[C#]
public static readonly TimeSpan MinValue;
[C++]
public: static readonly TimeSpan MinValue;
[JScript]
public static var MinValue : TimeSpan;

Remarks

MinValue equals a new TimeSpan that equals MinValue; the relationship is MinValue = new TimeSpan(Int64.MinValue).

The MinValue field is negative 10675199.02:48:05.4775808.

The hexidecimal value for Int64.MinValue is (short)0x8000.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | Int64


TimeSpan.TicksPerDay

Indicates the number of ticks equivalent to 1 day.

[Visual Basic]
Public Const TicksPerDay As Long
[C#]
public const long TicksPerDay;
[C++]
public: const __int64 TicksPerDay;
[JScript]
public var TicksPerDay : long;

Remarks

TicksPerDay is equal to 864 billion(864000000000).

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | Int64


TimeSpan.TicksPerHour

Indicates the number of ticks equivalent to 1 hour.

[Visual Basic]
Public Const TicksPerHour As Long
[C#]
public const long TicksPerHour;
[C++]
public: const __int64 TicksPerHour;
[JScript]
public var TicksPerHour : long;

Remarks

TicksPerHour is equal to 36 billion(36000000000).

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | Int64


TimeSpan.TicksPerMillisecond

Indicates the number of ticks equivalent to 1 millisecond.

[Visual Basic]
Public Const TicksPerMillisecond As Long
[C#]
public const long TicksPerMillisecond;
[C++]
public: const __int64 TicksPerMillisecond;
[JScript]
public var TicksPerMillisecond : long;

Remarks

TicksPerMillisecond is equal to 10 thousand (10000).

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | Int64


TimeSpan.TicksPerMinute

Indicates the number of ticks equivalent to 1 minute.

[Visual Basic]
Public Const TicksPerMinute As Long
[C#]
public const long TicksPerMinute;
[C++]
public: const __int64 TicksPerMinute;
[JScript]
public var TicksPerMinute : long;

Remarks

TicksPerMinute is equal to 600 million(600000000).

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | Int64


TimeSpan.TicksPerSecond

Indicates the number of ticks equivalent to 1 second.

[Visual Basic]
Public Const TicksPerSecond As Long
[C#]
public const long TicksPerSecond;
[C++]
public: const __int64 TicksPerSecond;
[JScript]
public var TicksPerSecond : long;

Remarks

TicksPerSecond is equal to 10 million (10000000).

See Also

TimeSpan Structure | TimeSpan Members | System Namespace | Int64


TimeSpan.Zero

Represents the zero TimeSpan value.

[Visual Basic]
Public Shared ReadOnly Zero As TimeSpan
[C#]
public static readonly TimeSpan Zero;
[C++]
public: static readonly TimeSpan Zero;
[JScript]
public static var Zero : TimeSpan;

Remarks

This value is equivalent to a new TimeSpan(0). This field is static, read only, and equal to zero.

See Also

TimeSpan Structure | TimeSpan Members | System Namespace


TimeZone Class

[To be supplied.]

Object
TimeZone

[Visual Basic]
MustInherit Public Class TimeZone
[C#]
public abstract class TimeZone
[C++]
public __gc __abstract class TimeZone
[JScript]
public abstract class TimeZone

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

TimeZone Members | System Namespace


TimeZone Members

Public:

Properties

CurrentTimeZone | Returns the current system time zone.
DaylightName | Returns the daylight saving time zone name. If daylight saving time is not used in the time zone, a null string will be returned.
StandardName | Return the standard time zone name.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDaylightChanges | Returns an array of DaylightTime that reflects the daylight saving periods in a particular year. We currently only support having one DaylightSavingTime per year. If daylight saving time is not used in the current time zone, null will be returned.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
GetUTCOffset | Returns the coordinated universal time (UTC) offset in ticks, at the specified time.
IsDaylightSavingTime | Overloaded. Determines whether the specified time is in a daylight saving time.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimeZone Class | System Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TimeZone Properties

The properties of the TimeZone class are listed below. For a complete list of TimeZone class members, see the TimeZone Members topic.

Public:

CurrentTimeZone | Returns the current system time zone.
DaylightName | Returns the daylight saving time zone name. If daylight saving time is not used in the time zone, a null string will be returned.
StandardName | Return the standard time zone name.

See Also

TimeZone Class | System Namespace


TimeZone.CurrentTimeZone

Returns the current system time zone.

[Visual Basic]
Public Shared ReadOnly Property CurrentTimeZone As TimeZone
[C#]
public static TimeZone CurrentTimeZone {get;}
[C++]
public: __property static TimeZone* get_CurrentTimeZone();
[JScript]
public static function get CurrentTimeZone() : TimeZone;

See Also

TimeZone Class | TimeZone Members | System Namespace


TimeZone.DaylightName

Returns the daylight saving time zone name.

If daylight saving time is not used in the time zone, a null string will be returned.

[Visual Basic]
Overridable Public Property DaylightName As String
[C#]
public string DaylightName {virtual get; virtual set;}
[C++]
public: __property virtual String* get_DaylightName();
public: __property virtual void set_DaylightName(String*);
[JScript]
public function get DaylightName() : String;
public function set DaylightName(String);

See Also

TimeZone Class | TimeZone Members | System Namespace


TimeZone.StandardName

Return the standard time zone name.

[Visual Basic]
Overridable Public Property StandardName As String
[C#]
public string StandardName {virtual get; virtual set;}
[C++]
public: __property virtual String* get_StandardName();
public: __property virtual void set_StandardName(String*);
[JScript]
public function get StandardName() : String;
public function set StandardName(String);

See Also

TimeZone Class | TimeZone Members | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TimeZone Methods

The methods of the TimeZone class are listed below. For a complete list of TimeZone class members, see the TimeZone Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDaylightChanges | Returns an array of DaylightTime that reflects the daylight saving periods in a particular year. We currently only support having one DaylightSavingTime per year. If daylight saving time is not used in the current time zone, null will be returned.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
GetUTCOffset | Returns the coordinated universal time (UTC) offset in ticks, at the specified time.
IsDaylightSavingTime | Overloaded. Determines whether the specified time is in a daylight saving time.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimeZone Class | System Namespace


TimeZone.GetDaylightChanges

Returns an array of DaylightTime that reflects the daylight saving periods in a particular year.

We currently only support having one DaylightSavingTime per year. If daylight saving time is not used in the current time zone, null will be returned.

[Visual Basic]
MustOverride Public Function GetDaylightChanges( _
   ByVal year As Integer _
) As DaylightTime ()
[C#]
public abstract DaylightTime[] GetDaylightChanges(
   int year
);
[C++]
public: virtual DaylightTime* GetDaylightChanges(
   int year
) [] = 0;
[JScript]
public abstract function GetDaylightChanges(
   year : int
) : DaylightTime[];

Parameters

year
The year to get the DaylightChanges on.

Return Value

An array of DaylightTime.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | is thrown if the number of the year is less than 1 or greater than 9999.

See Also

TimeZone Class | TimeZone Members | System Namespace


TimeZone.GetUTCOffset

Returns the coordinated universal time (UTC) offset in ticks, at the specified time.

[Visual Basic]
Overridable Public Function GetUTCOffset( _
   ByVal time As DateTime _
) As Long
[C#]
public virtual long GetUTCOffset(
   DateTime time
);
[C++]
public: virtual __int64 GetUTCOffset(
   DateTime time
);
[JScript]
public function GetUTCOffset(
   time : DateTime
) : long;

Parameters

time
The time specified.

Return Value

The coordinated universal time (UTC) offset in ticks, at the time specified.

Remarks

If the specified time is in the daylight saving time, the returned offset will be the UTC offset of the daylight saving time. This is the offset to add to UTC to get local time. That is:

local time = UTC + offset

For example, US Pacific Standard timezone, which has a-8 hours of offset, GetUTCOffset(new DateTime(1999, 1, 1)) will has the value-288000000000. The specified time should be in Gregorian calendar.

NOTE: Currently, this method only supports the time zone rule of the current year. The information is from the system. It assumes that every year has the same daylight saving rule.

See Also

TimeZone Class | TimeZone Members | System Namespace


TimeZone.IsDaylightSavingTime

Determines whether the specified time is in a daylight saving time.

Overload List

Determines whether the specified time is in daylight saving time.

[Visual Basic] Overloads Overridable Public Function IsDaylightSavingTime(DateTime, DaylightTime()) As Boolean
[C#] public virtual bool IsDaylightSavingTime(DateTime, DaylightTime[]);
[C++] public: virtual bool IsDaylightSavingTime(DateTime, DaylightTime[]);
[JScript] public function IsDaylightSavingTime(DateTime, DaylightTime[]) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function IsDaylightSavingTime(DateTime) As Boolean
[C#] public virtual bool IsDaylightSavingTime(DateTime);
[C++] public: virtual bool IsDaylightSavingTime(DateTime);
[JScript] public function IsDaylightSavingTime(DateTime) : Boolean;

See Also

TimeZone Class | TimeZone Members | System Namespace


TimeZone.IsDaylightSavingTime (DateTime, DaylightTime[])

Determines whether the specified time is in daylight saving time.

[Visual Basic]
Overloads Overridable Public Function IsDaylightSavingTime( _
   ByVal time As DateTime, _
   ByVal daylightTimes() As DaylightTime _
) As Boolean
[C#]
public virtual bool IsDaylightSavingTime(
   DateTime time,
   DaylightTime[] daylightTimes
);
[C++]
public: virtual bool IsDaylightSavingTime(
   DateTime time,
   DaylightTime* daylightTimes[]
);
[JScript]
public function IsDaylightSavingTime(
   time : DateTime,
   daylightTimes : DaylightTime[]
) : Boolean;

Parameters

time
The time to check to determine whether it is in daylight saving time.
daylightTimes
A DaylightTimes object.

Return Value

true if the time is daylight saving time; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentNullException | is thrown if either time or DaylightTimes is null.

See Also

TimeZone Class | TimeZone Members | System Namespace | TimeZone.IsDaylightSavingTime Overload List


TimeZone.IsDaylightSavingTime (DateTime)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function IsDaylightSavingTime( _
   ByVal time As DateTime _
) As Boolean
[C#]
public virtual bool IsDaylightSavingTime(
   DateTime time
);
[C++]
public: virtual bool IsDaylightSavingTime(
   DateTime time
);
[JScript]
public function IsDaylightSavingTime(
   time : DateTime
) : Boolean;

Parameters

time
The time to be checked to determine whether it is in daylight saving time.

See Also

TimeZone Class | TimeZone Members | System Namespace | TimeZone.IsDaylightSavingTime Overload List


Type Class

Represents type declarations: class types, interface types, array types, value types, and enumeration types.

Object
MemberInfo
Type

[Visual Basic]
MustInherit Public Class Type
   Inherits MemberInfo
   Implements IReflect
[C#]
public abstract class Type : MemberInfo, IReflect
[C++]
public __gc __abstract class Type : public MemberInfo, IReflect
[JScript]
public abstract class Type extends MemberInfo, IReflect

Remarks

This class is abstract primarily because its functionality is required of the different services provided by the runtime.

This class is the primary means by which to access metadata, and it acts as a gateway to the Reflection API. It provides methods for obtaining information about a type declaration, such as the constructors, methods, fields, properties, and events of a class, as well as the module and the assembly in which the class is deployed.

A Type object that represents a type is unique; that is, two Type object references refer to the same object if and only if they represent the same type. This allows for the synchronization of multiple static method invocations and for comparison of Type objects through reference comparisons.

A reference to the Type object associated with a type can be obtained in several ways:

1. The GetType method provided by Object returns a Type object that represents the type of an instance.

2. The static GetType method provided by Type returns a Type object that represents a type specified by its fully qualified name.

3. The GetTypes, GetType, and FindTypes methods provided by Module return Type objects that represent the types defined in a module. The first can be used to obtain an array of Type objects for all of the public and private types defined in a module. (An instance of Module is obtained through the static GetModule method provided by Module, or through the Module property provided by Type.)

4. The FindInterfaces method returns a filtered list of interface types supported by a class.

5. The GetElementType method returns a Type object that represents the element.

6. The GetInterfaces and GetInterface methods return Type objects representing the interface types supported by a class.

7. The GetTypeArray method returns an array of Type objects representing the types specified by an arbitrary set of objects. The objects are specified with a Variant array.

8. The GetTypeFromProgID methods are provided for interoperability. The first returns a Type object that represents the type specified by a class handle, and the latter returns a Type object that represents the type specified by a ProgID.

9. The GetTypeFromHandle and GetTypeFromProgID methods are provided for interoperability. The first returns a Type object that represents the type specified by a class handle and the latter returns a Type object that represents the type specified by a ProgID.

A Note on Security: Without ReflectionPermission, a subclass is only allowed to access the public members of a class. That is, invoking the GetMethods method on the Type object for a class will only return the public methods of that class. Furthermore, invoking GetMethod with the name of a non-public method will return null, as if it did not exist.

A Note on Reflection over Interfaces: Interfaces that extend other interfaces do not inherit the methods defined in the extended interfaces. For example, in the following code, I2 does not have a MethodA, even though all classes that implement I2 will have to create an I1. In effect, all classes that implement I2 also implement I1. See the Examples section below.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

Type Members | System Namespace | Object | System.Reflection | ReflectionPermission


Type Members

Public:

Properties

AssemblyQualifiedName | Gets the fully qualified name of the Type, including the name of the assembly from which the Type was loaded.
Attributes | Gets a bitmask indicating the attributes associated with the Type.
BaseType | Gets the type from which the current Type directly inherits.
DeclaringType | Gets the current Type.
DefaultBinder | Gets the default binder used by the system.
FullName | Gets the fully qualified name of the Type, including the namespace of the Type.
GUID | Gets the globally unique identifier (GUID) associated with the Type.
HasElementType | Gets a value indicating whether the Type ...
IsAbstract | Gets a value indicating whether the Type is abstract and must be overridden.
IsAnsiClass | Gets a value indicating whether the string format attribute AnsiClass is selected for the Type.
IsArray | Gets a value indicating whether the Type is an array.
IsAutoClass | Gets a value indicating whether the string format attribute AutoClass is selected for the Type.
IsAutoLayout | Gets a value indicating whether the class layout attribute AutoLayout is selected for the Type.
IsByRef | Gets a value indicating whether the Type is passed by reference.
IsClass | Gets a value indicating whether the Type is a class; that is, not a value type or interface.
IsCOMObject | Gets a value indicating whether the Type is a COM object.
IsContextful | Gets a value indicating whether the Type can be hosted in a context.
IsEnum | Gets a value indicating whether the Type is an enumeration.
IsExplicitLayout | Gets a value indicating whether the class layout attribute ExplicitLayout is selected for the Type.
IsImport | Gets a value indicating whether the Type was imported from another class.
IsInterface | Gets a value indicating whether the Type is an interface; that is, not a class or a value type.
IsLayoutSequential | Gets a value indicating whether the class layout attribute LayoutSequential is selected for the Type.
IsMarshalByRef | Gets a value indicating whether the Type is marshalled by reference.
IsNestedAssembly | Gets a value indicating whether the Type is nested and visible only within its own assembly.
IsNestedFamANDAssem | Gets a value indicating whether the Type is nested and visible only to classes that belong to both its own family and its own assembly.
IsNestedFamily | Gets a value indicating whether the Type is nested and visible only within its own family.
IsNestedFamORAssem | Gets a value indicating whether the Type is nested and visible only to classes that belong to its own family or to its own assembly.
IsNestedPrivate | Gets a value indicating whether the Type is nested and declared private.
IsNestedPublic | Gets a value indicating whether the Type is nested and declared public.
IsNotPublic | Gets a value indicating whether the Type is not declared public.
IsPointer | Gets a value indicating whether the Type is a pointer.
IsPrimitive | Gets a value indicating whether the Type is one of the primitive types.
IsPublic | Gets a value indicating whether the Type is declared public.
IsSealed | Gets a value indicating whether the Type is declared sealed.
IsSerializable | Gets a value indicating whether the Type is serializable.
IsSpecialName | Gets a value indicating whether the Type has a name that requires special handling.
IsUnicodeClass | Gets a value indicating whether the string format attribute UnicodeClass is selected for the Type.
IsUnmanagedValueType | Gets a value indicating whether the Type is one of the unmanaged value types.
IsValueType | Gets a value indicating whether the Type is a value type; that is, not a class or an interface.
MemberType | Gets a bit mask indicating the member type.
Module | Gets the module (the DLL) in which the current Type is defined.
Name (inherited from MemberInfo) | Retrieves the name of this member.
Namespace | Gets the namespace of the Type.
ReflectedType | Gets the current Type.
TypeHandle | Gets the handle for the current Type.
TypeInitializer | Gets the name of the class constructor for the Type.
UnderlyingSystemType | Gets the underlying system type for the Type.

Methods

Equals | Overloaded. Determines if the underlying system type of the current Type is the same as the underlying system type of the specified Object or Type.
FindInterfaces | Returns an array of Type objects representing a filtered list of interfaces implemented or inherited by the current Type.
FindMembers | Returns a filtered array of MemberInfo objects of the specified member type.
GetArrayRank | When implemented by a derived class, gets the number of dimensions in an Array.
GetConstructor | Overloaded. Gets a specific constructor of the current Type.
GetConstructors | Overloaded. Gets the constructors of the current Type.
GetCustomAttributes (inherited from MemberInfo) | Overloaded. Returns all attributes defined on this member.
GetDefaultMembers | Searches for the members defined for the current Type whose DefaultMemberAttribute is set.
GetElementType | When implemented by a derived class, Returns the Type of the element.
GetEvent | Overloaded. Gets a specific event declared or inherited by the current Type.
GetEvents | Overloaded. Gets the events which are declared or inherited by the current Type.
GetField | Overloaded. Gets a specific field of the current Type.
GetFields | Overloaded. Gets the fields of the current Type.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInterface | Overloaded. Gets a specific interface implemented or inherited by the current Type.
GetInterfaceMap | When implemented by a derived class, returns an interface mapping for the specified interface type.
GetInterfaces | When implemented by a derived class, gets all the interfaces implemented or inherited by the current Type.
GetMember | Overloaded. Gets the specified members of the current Type.
GetMembers | Overloaded. Gets the members (properties, methods, fields, events, and so on) of the current Type.
GetMethod | Overloaded. Gets a specific method of the current Type.
GetMethods | Overloaded. Gets the methods of the current Type.
GetNestedType | Overloaded. Gets a specific type nested within the current Type.
GetNestedTypes | Overloaded. Gets the types nested within the current Type.
GetProperties | Overloaded. Gets the properties of the current Type.
GetProperty | Overloaded. Gets a specific property of the current Type.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeArray | Gets the types of the objects in the specified array.
GetTypeCode | Gets the underlying type code of the specified Type.
GetTypeFromHandle | Gets the Type referenced by the specified type handle.
GetTypeFromProgID | Overloaded. Gets the Type associated with the specified program identifier (progID).
GetTypeHandle | Gets the handle for the Type of an object.
InvokeMember | Overloaded. Invokes a specific member of the current Type; essentially calls a constructor member or a method member, gets or sets a property member, gets or sets a data field member, or gets or sets an element of an array member.
IsAssignableFrom | Determines whether an instance of the specified type can be assigned to the current Type instance.
IsDefined (inherited from MemberInfo) | Returns a Boolean if one or more instance of attributeType is defined on this member.
IsInstanceOfType | Determines whether the specified object is an instance of the Type.
IsSubclassOf | Determines whether the current Type is a subclass of the specified class.
ToString | Returns a String representing the name of the current Type.

Fields

Delimiter | Represents the character used to separate names in the namespace of the Type.
EmptyTypes | Represents an empty array of type Type.
FilterAttribute | Represents the member filter used on attributes.
FilterName | Represents the case-sensitive member filter used on names.
FilterNameIgnoreCase | Represents the case-insensitive member filter used on names.
Missing | Represents a missing value in the Type information.

Protected:

Constructor

Type Constructor Initializes a new instance of the Type class.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetAttributeFlagsImpl | Implements the Attributes property and, when implemented by a derived class, gets a bitmask indicating the attributes associated with the Type.
GetConstructorImpl | Searches for a constructor whose parameters match the specified argument types and modifiers, using the specified binding constraints and the specified calling convention.
GetMethodImpl | Searches for the specified method whose parameters match the specified argument types and modifiers, using the specified binding constraints and the specified calling convention.
GetPropertyImpl | When implemented by a derived class, searches for the specified property whose parameters match the specified argument types and modifiers, using the specified binding constraints.
HasElementTypeImpl | Implements the HasElementType property and, when implemented by a derived class, determines whether the Type...
IsArrayImpl | Implements the IsArray property and, when implemented by a derived class, determines whether the Type is an array.
IsByRefImpl | Implements the IsByRef property and, when implemented by a derived class, determines whether the Type is passed by reference.
IsCOMObjectImpl | Implements the IsCOMObject property and, when implemented by a derived class, determines whether the Type is a COM object.
IsContextfulImpl | Implements the IsContextful property and determines whether the Type can be hosted in a context.
IsMarshalByRefImpl | Implements the IsMarshalByRef property and determines whether the Type is marshalled by reference.
IsPointerImpl | Implements the IsPointer property and, when implemented by a derived class, determines whether the Type is a pointer.
IsPrimitiveImpl | Implements the IsPrimitive property and, when implemented by a derived class, determines whether the Type is one of the primitive types.
IsValueTypeImpl | Implements the IsValueType property and, when implemented by a derived class, determines whether the Type is a value type; that is, not a class or an interface.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Type Class | System Namespace


Type Constructor

Initializes a new instance of the Type class.

[Visual Basic]
Protected Sub New()
[C#]
protected Type();
[C++]
protected: Type();
[JScript]
protected function Type();

Remarks

This constructor is invoked by subclasses during the construction of type objects.

See Also

Type Class | Type Members | System Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Type Properties

The properties of the Type class are listed below. For a complete list of Type class members, see the Type Members topic.

Public:

AssemblyQualifiedName | Gets the fully qualified name of the Type, including the name of the assembly from which the Type was loaded.
Attributes | Gets a bitmask indicating the attributes associated with the Type.
BaseType | Gets the type from which the current Type directly inherits.
DeclaringType | Gets the current Type.
DefaultBinder | Gets the default binder used by the system.
FullName | Gets the fully qualified name of the Type, including the namespace of the Type.
GUID | Gets the globally unique identifier (GUID) associated with the Type.
HasElementType | Gets a value indicating whether the Type ...
IsAbstract | Gets a value indicating whether the Type is abstract and must be overridden.
IsAnsiClass | Gets a value indicating whether the string format attribute AnsiClass is selected for the Type.
IsArray | Gets a value indicating whether the Type is an array.
IsAutoClass | Gets a value indicating whether the string format attribute AutoClass is selected for the Type.
IsAutoLayout | Gets a value indicating whether the class layout attribute AutoLayout is selected for the Type.
IsByRef | Gets a value indicating whether the Type is passed by reference.
IsClass | Gets a value indicating whether the Type is a class; that is, not a value type or interface.
IsCOMObject | Gets a value indicating whether the Type is a COM object.
IsContextful | Gets a value indicating whether the Type can be hosted in a context.
IsEnum | Gets a value indicating whether the Type is an enumeration.
IsExplicitLayout | Gets a value indicating whether the class layout attribute ExplicitLayout is selected for the Type.
IsImport | Gets a value indicating whether the Type was imported from another class.
IsInterface | Gets a value indicating whether the Type is an interface; that is, not a class or a value type.
IsLayoutSequential | Gets a value indicating whether the class layout attribute LayoutSequential is selected for the Type.
IsMarshalByRef | Gets a value indicating whether the Type is marshalled by reference.
IsNestedAssembly | Gets a value indicating whether the Type is nested and visible only within its own assembly.
IsNestedFamANDAssem | Gets a value indicating whether the Type is nested and visible only to classes that belong to both its own family and its own assembly.
IsNestedFamily | Gets a value indicating whether the Type is nested and visible only within its own family.
IsNestedFamORAssem | Gets a value indicating whether the Type is nested and visible only to classes that belong to its own family or to its own assembly.
IsNestedPrivate | Gets a value indicating whether the Type is nested and declared private.
IsNestedPublic | Gets a value indicating whether the Type is nested and declared public.
IsNotPublic | Gets a value indicating whether the Type is not declared public.
IsPointer | Gets a value indicating whether the Type is a pointer.
IsPrimitive | Gets a value indicating whether the Type is one of the primitive types.
IsPublic | Gets a value indicating whether the Type is declared public.
IsSealed | Gets a value indicating whether the Type is declared sealed.
IsSerializable | Gets a value indicating whether the Type is serializable.
IsSpecialName | Gets a value indicating whether the Type has a name that requires special handling.
IsUnicodeClass | Gets a value indicating whether the string format attribute UnicodeClass is selected for the Type.
IsUnmanagedValueType | Gets a value indicating whether the Type is one of the unmanaged value types.
IsValueType | Gets a value indicating whether the Type is a value type; that is, not a class or an interface.
MemberType | Gets a bit mask indicating the member type.
Module | Gets the module (the DLL) in which the current Type is defined.
Name (inherited from MemberInfo) | Retrieves the name of this member.
Namespace | Gets the namespace of the Type.
ReflectedType | Gets the current Type.
TypeHandle | Gets the handle for the current Type.
TypeInitializer | Gets the name of the class constructor for the Type.
UnderlyingSystemType | Gets the underlying system type for the Type.

See Also

Type Class | System Namespace


Type.AssemblyQualifiedName

Gets the fully qualified name of the Type, including the name of the assembly from which the Type was loaded.

[Visual Basic]
MustOverride Public ReadOnly Property AssemblyQualifiedName As _
   String
[C#]
public string AssemblyQualifiedName {abstract get;}
[C++]
public: __property virtual String* get_AssemblyQualifiedName() = 0;
[JScript]
public abstract function get AssemblyQualifiedName() : String;

Property Value

The fully qualified name of the Type, including the name of the assembly from which the Type was loaded.

Remarks

This qualified name can be persisted and later used to load the Type. To search for and load a Type, use GetType either with the type name only or with the assembly qualified type name. GetType with the type name only will look for the Type in the caller's assembly and then in the System assembly. GetType with the assembly qualified type name will look for the Type in any assembly.

Type names may include trailing characters that denote additional information about the type, such as whether the type is a reference type, a pointer type or an array type. To retrieve the type name without these trailing characters, use t. GetElementType (). ToString (), where t is the type.

See Also

Type Class | Type Members | System Namespace | String | GetType


Type.Attributes

Gets a bitmask indicating the attributes associated with the Type.

[Visual Basic]
Public ReadOnly Property Attributes As TypeAttributes
[C#]
public TypeAttributes Attributes {get;}
[C++]
public: __property TypeAttributes get_Attributes();
[JScript]
public function get Attributes() : TypeAttributes;

Property Value

A TypeAttributes object representing the attribute set of the Type.

Example

if (t.Attributes & TypeAttributes.ClassSemanticsMask) == TypeAttributes.Interface)
    Console.WriteLine ("t is an Interface");
if (t.Attributes & TypeAttributes.ClassSemanticsMask) == TypeAttributes.ValueType)
    Console.WriteLine ("t is a value type");
if (t.Attributes & & TypeAttributes.Public) != 0)
    Console.WriteLine ("t is public");

See Also

Type Class | Type Members | System Namespace | GetAttributeFlagsImpl | TypeAttributes


Type.BaseType

Gets the type from which the current Type directly inherits.

[Visual Basic]
MustOverride Public ReadOnly Property BaseType As Type
[C#]
public Type BaseType {abstract get;}
[C++]
public: __property virtual Type* get_BaseType() = 0;
[JScript]
public abstract function get BaseType() : Type;

Property Value

The Type from which the current Type directly inherits.

Remarks

The base type is the type from which the current type directly inherits. Object is the only type that does not have a base type, therefore a null reference (in Visual Basic Nothing) is returned as the base type of Object.

Interfaces inherit from Object and from zero or more base interfaces; therefore, the base type of an interface is considered to be Object. The base interfaces can be determined with GetInterfaces or FindInterfaces.

See Also

Type Class | Type Members | System Namespace | Object | GetInterfaces | FindInterfaces


Type.DeclaringType

Gets the current Type.

[Visual Basic]
Overridable Public ReadOnly Property DeclaringType As Type
[C#]
public Type DeclaringType {override get;}
[C++]
public: __property virtual Type* get_DeclaringType();
[JScript]
public function get DeclaringType() : Type;

Property Value

The current Type.

Remarks

This property implements the abstract property inherited from MemberInfo.

See Also

Type Class | Type Members | System Namespace | MemberInfo


Type.DefaultBinder

Gets the default binder used by the system.

[Visual Basic]
Public Shared ReadOnly Property DefaultBinder As Binder
[C#]
public static Binder DefaultBinder {get;}
[C++]
public: __property static Binder* get_DefaultBinder();
[JScript]
public static function get DefaultBinder() : Binder;

Property Value

The default binder used by the system.

See Also

Type Class | Type Members | System Namespace


Type.FullName

Gets the fully qualified name of the Type, including the namespace of the Type.

[Visual Basic]
MustOverride Public ReadOnly Property FullName As String
[C#]
public string FullName {abstract get;}
[C++]
public: __property virtual String* get_FullName() = 0;
[JScript]
public abstract function get FullName() : String;

Property Value

The fully qualified name of the Type, including the namespace of the Type.

Remarks

Type names may include trailing characters that denote additional information about the type, such as whether the type is a reference type, a pointer type or an array type. To retrieve the type name without these trailing characters, use t. GetElementType (). ToString (), where t is the type.

See Also

Type Class | Type Members | System Namespace | String


Type.GUID

Gets the globally unique identifier (GUID) associated with the Type.

[Visual Basic]
MustOverride Public ReadOnly Property GUID As Guid
[C#]
public Guid GUID {abstract get;}
[C++]
public: __property virtual Guid get_GUID() = 0;
[JScript]
public abstract function get GUID() : Guid;

Property Value

The GUID associated with the Type.

See Also

Type Class | Type Members | System Namespace


Type.HasElementType

Gets a value indicating whether the Type ...

[Visual Basic]
Public ReadOnly Property HasElementType As Boolean
[C#]
public bool HasElementType {get;}
[C++]
public: __property bool get_HasElementType();
[JScript]
public function get HasElementType() : Boolean;

Property Value

true if the Type is ...; otherwise, false.

See Also

Type Class | Type Members | System Namespace | HasElementTypeImpl


Type.IsAbstract

Gets a value indicating whether the Type is abstract and must be overridden.

[Visual Basic]
Public ReadOnly Property IsAbstract As Boolean
[C#]
public bool IsAbstract {get;}
[C++]
public: __property bool get_IsAbstract();
[JScript]
public function get IsAbstract() : Boolean;

Property Value

true if the Type is abstract; otherwise, false.

See Also

Type Class | Type Members | System Namespace | TypeAttributes


Type.IsAnsiClass

Gets a value indicating whether the string format attribute AnsiClass is selected for the Type.

[Visual Basic]
Public ReadOnly Property IsAnsiClass As Boolean
[C#]
public bool IsAnsiClass {get;}
[C++]
public: __property bool get_IsAnsiClass();
[JScript]
public function get IsAnsiClass() : Boolean;

Property Value

true if the string format attribute AnsiClass is selected for the Type; otherwise, false.

Remarks

The StringFormatMask is used to select the string format attributes. The string format attributes are used for interoperability by defining how strings should be interpreted.

See Also

Type Class | Type Members | System Namespace | TypeAttributes | IsUnicodeClass | IsAutoClass


Type.IsArray

Gets a value indicating whether the Type is an array.

[Visual Basic]
Public ReadOnly Property IsArray As Boolean
[C#]
public bool IsArray {get;}
[C++]
public: __property bool get_IsArray();
[JScript]
public function get IsArray() : Boolean;

Property Value

true if the Type is an array; otherwise, false.

Remarks

An instance of the Array class will return false because it is an object, not an array.

See Also

Type Class | Type Members | System Namespace | IsArrayImpl


Type.IsAutoClass

Gets a value indicating whether the string format attribute AutoClass is selected for the Type.

[Visual Basic]
Public ReadOnly Property IsAutoClass As Boolean
[C#]
public bool IsAutoClass {get;}
[C++]
public: __property bool get_IsAutoClass();
[JScript]
public function get IsAutoClass() : Boolean;

Property Value

true if the string format attribute AutoClass is selected for the Type; otherwise, false.

Remarks

The StringFormatMask is used to select the string format attributes. The string format attributes are used for interoperability by defining how strings should be interpreted.

See Also

Type Class | Type Members | System Namespace | TypeAttributes | IsAnsiClass | IsUnicodeClass


Type.IsAutoLayout

Gets a value indicating whether the class layout attribute AutoLayout is selected for the Type.

[Visual Basic]
Public ReadOnly Property IsAutoLayout As Boolean
[C#]
public bool IsAutoLayout {get;}
[C++]
public: __property bool get_IsAutoLayout();
[JScript]
public function get IsAutoLayout() : Boolean;

Property Value

true if the class layout attribute AutoLayout is selected for the Type; otherwise, false.

Remarks

The LayoutMask is used to select the class layout attributes. The class layout attributes (AutoLayout, LayoutSequential and ExplicitLayout) define how the fields of the class instance are laid out in memory.

Use the AutoLayout attribute to let the runtime engine decide the best way to layout the objects of the class.

See Also

Type Class | Type Members | System Namespace | TypeAttributes | IsLayoutSequential | IsExplicitLayout


Type.IsByRef

Gets a value indicating whether the Type is passed by reference.

[Visual Basic]
Public ReadOnly Property IsByRef As Boolean
[C#]
public bool IsByRef {get;}
[C++]
public: __property bool get_IsByRef();
[JScript]
public function get IsByRef() : Boolean;

Property Value

true if the Type is passed by reference; otherwise, false.

See Also

Type Class | Type Members | System Namespace | IsByRefImpl


Type.IsClass

Gets a value indicating whether the Type is a class; that is, not a value type or interface.

[Visual Basic]
Public ReadOnly Property IsClass As Boolean
[C#]
public bool IsClass {get;}
[C++]
public: __property bool get_IsClass();
[JScript]
public function get IsClass() : Boolean;

Property Value

true if the Type is a class; otherwise, false.

Remarks

The ClassSemanticsMask is used to distinguish a type declaration as class, interface or value type.

See Also

Type Class | Type Members | System Namespace | TypeAttributes | IsInterface | IsValueType | IsUnmanagedValueType


Type.IsCOMObject

Gets a value indicating whether the Type is a COM object.

[Visual Basic]
Public ReadOnly Property IsCOMObject As Boolean
[C#]
public bool IsCOMObject {get;}
[C++]
public: __property bool get_IsCOMObject();
[JScript]
public function get IsCOMObject() : Boolean;

Property Value

true if the Type is a COM object; otherwise, false.

Remarks

This method returns false for COM interfaces because they are not objects. COM interfaces can be implemented by NGWS objects.

See Also

Type Class | Type Members | System Namespace | IsCOMObjectImpl


Type.IsContextful

Gets a value indicating whether the Type can be hosted in a context.

[Visual Basic]
Public ReadOnly Property IsContextful As Boolean
[C#]
public bool IsContextful {get;}
[C++]
public: __property bool get_IsContextful();
[JScript]
public function get IsContextful() : Boolean;

Property Value

true if the Type can be hosted in a context; otherwise, false.

Remarks

A context intercepts calls to the class members and enforce policies that are applied to the class, such as synchronization.

See Also

Type Class | Type Members | System Namespace | IsContextfulImpl


Type.IsEnum

Gets a value indicating whether the Type is an enumeration.

[Visual Basic]
Public ReadOnly Property IsEnum As Boolean
[C#]
public bool IsEnum {get;}
[C++]
public: __property bool get_IsEnum();
[JScript]
public function get IsEnum() : Boolean;

Property Value

true if the Type is an enumeration; otherwise, false.

See Also

Type Class | Type Members | System Namespace | TypeAttributes


Type.IsExplicitLayout

Gets a value indicating whether the class layout attribute ExplicitLayout is selected for the Type.

[Visual Basic]
Public ReadOnly Property IsExplicitLayout As Boolean
[C#]
public bool IsExplicitLayout {get;}
[C++]
public: __property bool get_IsExplicitLayout();
[JScript]
public function get IsExplicitLayout() : Boolean;

Property Value

true if the class layout attribute ExplicitLayout is selected for the Type; otherwise, false.

Remarks

The LayoutMask is used to select the class layout attributes. The class layout attributes (AutoLayout, LayoutSequential and ExplicitLayout) define how the fields of the class instance are laid out in memory.

Use the ExplicitLayout attribute to specify the offsets at which each field starts, or to specify the overall size and, optionally, the packing size of the objects of the class. The packing size is the empty memory space between fields and must be 1, 2, 4, 8 or 16 bytes.

See Also

Type Class | Type Members | System Namespace | TypeAttributes | IsAutoLayout | IsLayoutSequential


Type.IsImport

Gets a value indicating whether the Type was imported from another class.

[Visual Basic]
Public ReadOnly Property IsImport As Boolean
[C#]
public bool IsImport {get;}
[C++]
public: __property bool get_IsImport();
[JScript]
public function get IsImport() : Boolean;

Property Value

true if the Type was imported from another class; otherwise, false.

See Also

Type Class | Type Members | System Namespace | TypeAttributes


Type.IsInterface

Gets a value indicating whether the Type is an interface; that is, not a class or a value type.

[Visual Basic]
Public ReadOnly Property IsInterface As Boolean
[C#]
public bool IsInterface {get;}
[C++]
public: __property bool get_IsInterface();
[JScript]
public function get IsInterface() : Boolean;

Property Value

true if the Type is an interface; otherwise, false.

Remarks

The ClassSemanticsMask is used to distinguish a type declaration as class, interface or value type.

See Also

Type Class | Type Members | System Namespace | TypeAttributes | IsClass | IsValueType | IsUnmanagedValueType


Type.IsLayoutSequential

Gets a value indicating whether the class layout attribute LayoutSequential is selected for the Type.

[Visual Basic]
Public ReadOnly Property IsLayoutSequential As Boolean
[C#]
public bool IsLayoutSequential {get;}
[C++]
public: __property bool get_IsLayoutSequential();
[JScript]
public function get IsLayoutSequential() : Boolean;

Property Value

true if the class layout attribute LayoutSequential is selected for the Type; otherwise, false.

Remarks

The LayoutMask is used to select the class layout attributes. The class layout attributes (AutoLayout, LayoutSequential and ExplicitLayout) define how the fields of the class instance are laid out in memory.Use the LayoutSequential attribute to layout the objects of the class sequentially and to specify the packing size between adjacent fields. The packing size is the empty memory space between fields and must be 1, 2, 4, 8 or 16 bytes. A field will be aligned to its natural size or to the packing size, whichever results in a smaller offset.

See Also

Type Class | Type Members | System Namespace | TypeAttributes | IsAutoLayout | IsExplicitLayout


Type.IsMarshalByRef

Gets a value indicating whether the Type is marshalled by reference.

[Visual Basic]
Public ReadOnly Property IsMarshalByRef As Boolean
[C#]
public bool IsMarshalByRef {get;}
[C++]
public: __property bool get_IsMarshalByRef();
[JScript]
public function get IsMarshalByRef() : Boolean;

Property Value

true if the Type is marshalled by reference; otherwise, false.

See Also

Type Class | Type Members | System Namespace | IsMarshalByRefImpl


Type.IsNestedAssembly

Gets a value indicating whether the Type is nested and visible only within its own assembly.

[Visual Basic]
Public ReadOnly Property IsNestedAssembly As Boolean
[C#]
public bool IsNestedAssembly {get;}
[C++]
public: __property bool get_IsNestedAssembly();
[JScript]
public function get IsNestedAssembly() : Boolean;

Property Value

true if the Type is nested and visible only within its own assembly; otherwise, false.

Remarks

The VisibilityMask is used to select the visibility attributes.

See Also

Type Class | Type Members | System Namespace | TypeAttributes


Type.IsNestedFamANDAssem

Gets a value indicating whether the Type is nested and visible only to classes that belong to both its own family and its own assembly.

[Visual Basic]
Public ReadOnly Property IsNestedFamANDAssem As Boolean
[C#]
public bool IsNestedFamANDAssem {get;}
[C++]
public: __property bool get_IsNestedFamANDAssem();
[JScript]
public function get IsNestedFamANDAssem() : Boolean;

Property Value

true if the Type is nested and visible only to classes that belong to both its own family and its own assembly; otherwise, false.

Remarks

The VisibilityMask is used to select the visibility attributes.

A Type object's family is defined as all objects of the exact same Type and of its subtypes.

See Also

Type Class | Type Members | System Namespace | TypeAttributes


Type.IsNestedFamily

Gets a value indicating whether the Type is nested and visible only within its own family.

[Visual Basic]
Public ReadOnly Property IsNestedFamily As Boolean
[C#]
public bool IsNestedFamily {get;}
[C++]
public: __property bool get_IsNestedFamily();
[JScript]
public function get IsNestedFamily() : Boolean;

Property Value

true if the Type is nested and visible only within its own family; otherwise, false.

Remarks

The VisibilityMask is used to select the visibility attributes.

A Type object's family is defined as all objects of the exact same Type and of its subtypes.

See Also

Type Class | Type Members | System Namespace | TypeAttributes


Type.IsNestedFamORAssem

Gets a value indicating whether the Type is nested and visible only to classes that belong to its own family or to its own assembly.

[Visual Basic]
Public ReadOnly Property IsNestedFamORAssem As Boolean
[C#]
public bool IsNestedFamORAssem {get;}
[C++]
public: __property bool get_IsNestedFamORAssem();
[JScript]
public function get IsNestedFamORAssem() : Boolean;

Property Value

true if the Type is nested and visible only to classes that belong to its own family or to its own assembly; otherwise, false.

Remarks

The VisibilityMask is used to select the visibility attributes.

A Type object's family is defined as all objects of the exact same Type and of its subtypes.

See Also

Type Class | Type Members | System Namespace | TypeAttributes


Type.IsNestedPrivate

Gets a value indicating whether the Type is nested and declared private.

[Visual Basic]
Public ReadOnly Property IsNestedPrivate As Boolean
[C#]
public bool IsNestedPrivate {get;}
[C++]
public: __property bool get_IsNestedPrivate();
[JScript]
public function get IsNestedPrivate() : Boolean;

Property Value

true if the Type is nested and declared private; otherwise, false.

Remarks

The VisibilityMask is used to select the visibility attributes.

See Also

Type Class | Type Members | System Namespace | TypeAttributes


Type.IsNestedPublic

Gets a value indicating whether the Type is nested and declared public.

[Visual Basic]
Public ReadOnly Property IsNestedPublic As Boolean
[C#]
public bool IsNestedPublic {get;}
[C++]
public: __property bool get_IsNestedPublic();
[JScript]
public function get IsNestedPublic() : Boolean;

Property Value

true if the Type is nested and declared public; otherwise, false.

Remarks

The VisibilityMask is used to select the visibility attributes.

See Also

Type Class | Type Members | System Namespace | TypeAttributes


Type.IsNotPublic

Gets a value indicating whether the Type is not declared public.

[Visual Basic]
Public ReadOnly Property IsNotPublic As Boolean
[C#]
public bool IsNotPublic {get;}
[C++]
public: __property bool get_IsNotPublic();
[JScript]
public function get IsNotPublic() : Boolean;

Property Value

true if the Type is not declared public; otherwise, false.

Remarks

The VisibilityMask is used to select the visibility attributes.

See Also

Type Class | Type Members | System Namespace | TypeAttributes


Type.IsPointer

Gets a value indicating whether the Type is a pointer.

[Visual Basic]
Public ReadOnly Property IsPointer As Boolean
[C#]
public bool IsPointer {get;}
[C++]
public: __property bool get_IsPointer();
[JScript]
public function get IsPointer() : Boolean;

Property Value

true if the Type is a pointer; otherwise, false.

See Also

Type Class | Type Members | System Namespace | IsPointerImpl


Type.IsPrimitive

Gets a value indicating whether the Type is one of the primitive types.

[Visual Basic]
Public ReadOnly Property IsPrimitive As Boolean
[C#]
public bool IsPrimitive {get;}
[C++]
public: __property bool get_IsPrimitive();
[JScript]
public function get IsPrimitive() : Boolean;

Property Value

true if the Type is one of the primitive types; otherwise, false.

Remarks

The primitive types are Boolean, Byte, SByte, Int16, UInt16, Int32, UInt32, Int64, UInt64, Char, Double, and Single.

See Also

Type Class | Type Members | System Namespace | Boolean | Byte | SByte | Int16 | UInt16 | Int32 | UInt32 | Int64 | UInt64 | Char | Double | Single | IsPrimitiveImpl


Type.IsPublic

Gets a value indicating whether the Type is declared public.

[Visual Basic]
Public ReadOnly Property IsPublic As Boolean
[C#]
public bool IsPublic {get;}
[C++]
public: __property bool get_IsPublic();
[JScript]
public function get IsPublic() : Boolean;

Property Value

true if the Type is declared public; otherwise, false.

Remarks

The VisibilityMask is used to select the visibility attributes.

See Also

Type Class | Type Members | System Namespace | TypeAttributes


Type.IsSealed

Gets a value indicating whether the Type is declared sealed.

[Visual Basic]
Public ReadOnly Property IsSealed As Boolean
[C#]
public bool IsSealed {get;}
[C++]
public: __property bool get_IsSealed();
[JScript]
public function get IsSealed() : Boolean;

Property Value

true if the Type is declared sealed; otherwise, false.

See Also

Type Class | Type Members | System Namespace | TypeAttributes


Type.IsSerializable

Gets a value indicating whether the Type is serializable.

[Visual Basic]
Public ReadOnly Property IsSerializable As Boolean
[C#]
public bool IsSerializable {get;}
[C++]
public: __property bool get_IsSerializable();
[JScript]
public function get IsSerializable() : Boolean;

Property Value

true if the Type is serializable; otherwise, false.

See Also

Type Class | Type Members | System Namespace | TypeAttributes | ISerializable


Type.IsSpecialName

Gets a value indicating whether the Type has a name that requires special handling.

[Visual Basic]
Public ReadOnly Property IsSpecialName As Boolean
[C#]
public bool IsSpecialName {get;}
[C++]
public: __property bool get_IsSpecialName();
[JScript]
public function get IsSpecialName() : Boolean;

Property Value

true if the Type has a name that requires special handling; otherwise, false.

See Also

Type Class | Type Members | System Namespace | TypeAttributes


Type.IsUnicodeClass

Gets a value indicating whether the string format attribute UnicodeClass is selected for the Type.

[Visual Basic]
Public ReadOnly Property IsUnicodeClass As Boolean
[C#]
public bool IsUnicodeClass {get;}
[C++]
public: __property bool get_IsUnicodeClass();
[JScript]
public function get IsUnicodeClass() : Boolean;

Property Value

true if the string format attribute UnicodeClass is selected for the Type; otherwise, false.

Remarks

The StringFormatMask is used to select the string format attributes. The string format attributes are used for interoperability by defining how strings should be interpreted.

See Also

Type Class | Type Members | System Namespace | TypeAttributes | IsAnsiClass | IsAutoClass


Type.IsUnmanagedValueType

Gets a value indicating whether the Type is one of the unmanaged value types.

[Visual Basic]
Public ReadOnly Property IsUnmanagedValueType As Boolean
[C#]
public bool IsUnmanagedValueType {get;}
[C++]
public: __property bool get_IsUnmanagedValueType();
[JScript]
public function get IsUnmanagedValueType() : Boolean;

Property Value

true if the Type is one of the unmanaged value types; otherwise, false.

Remarks

The ClassSemanticsMask is used to distinguish a type declaration as class, interface or value type.

Value types are sequences of bits with equality. These are referred to as "structs" in some programming languages. Enums are a special case of value types. Value types are not classes or interfaces.

See Also

Type Class | Type Members | System Namespace | TypeAttributes | IsClass | IsInterface | IsValueType


Type.IsValueType

Gets a value indicating whether the Type is a value type; that is, not a class or an interface.

[Visual Basic]
Public ReadOnly Property IsValueType As Boolean
[C#]
public bool IsValueType {get;}
[C++]
public: __property bool get_IsValueType();
[JScript]
public function get IsValueType() : Boolean;

Property Value

true if the Type is a value type; otherwise, false.

Remarks

The ClassSemanticsMask is used to distinguish a type declaration as class, interface or value type.

Value types describe values that are represented as sequences of bits; value types are not classes or interfaces. These are referred to as "structs" in some programming languages. Enums are a special case of value types.

See Also

Type Class | Type Members | System Namespace | TypeAttributes | IsClass | IsInterface | IsUnmanagedValueType | Value | ValueType | IsValueTypeImpl


Type.MemberType

Gets a bit mask indicating the member type.

[Visual Basic]
Overridable Public ReadOnly Property MemberType As MemberTypes
[C#]
public MemberTypes MemberType {override get;}
[C++]
public: __property virtual MemberTypes get_MemberType();
[JScript]
public function get MemberType() : MemberTypes;

Property Value

A MemberTypes bitmask indicating the member type, which can be one of the following: Constructor, Event, Field, Method, Property, TypeInfo, Custom, NestedType or All.

See Also

Type Class | Type Members | System Namespace | MemberTypes


Type.Module

Gets the module (the DLL) in which the current Type is defined.

[Visual Basic]
MustOverride Public ReadOnly Property Module As Module
[C#]
public Module Module {abstract get;}
[C++]
public: __property virtual Module* get_Module() = 0;
[JScript]
public abstract function get Module() : Module;

Property Value

The name of the module in which the current Type is defined.

See Also

Type Class | Type Members | System Namespace | Module


Type.Namespace

Gets the namespace of the Type.

[Visual Basic]
MustOverride Public ReadOnly Property Namespace As String
[C#]
public string Namespace {abstract get;}
[C++]
public: __property virtual String* get_Namespace() = 0;
[JScript]
public abstract function get Namespace() : String;

Property Value

The namespace of the Type.

See Also

Type Class | Type Members | System Namespace | String


Type.ReflectedType

Gets the current Type.

[Visual Basic]
Overridable Public ReadOnly Property ReflectedType As Type
[C#]
public Type ReflectedType {override get;}
[C++]
public: __property virtual Type* get_ReflectedType();
[JScript]
public function get ReflectedType() : Type;

Property Value

The current Type.

-or-

a null reference (in Visual Basic Nothing), if the current Type is a nested type.

Remarks

This property implements the abstract property inherited from MemberInfo.

See Also

Type Class | Type Members | System Namespace | MemberInfo


Type.TypeHandle

Gets the handle for the current Type.

[Visual Basic]
MustOverride Public ReadOnly Property TypeHandle As _
   RuntimeTypeHandle
[C#]
public RuntimeTypeHandle TypeHandle {abstract get;}
[C++]
public: __property virtual RuntimeTypeHandle get_TypeHandle() = 0;
[JScript]
public abstract function get TypeHandle() : RuntimeTypeHandle;

Property Value

The handle for the current Type.

Remarks

A type handle is an integer value associated with each type, and is unique during the process lifetime.

The TypeHandle functions as an identifier that is meaningful to the Execution Engine. It is equivalent to the result of the ldtoken instruction.

See Also

Type Class | Type Members | System Namespace | RuntimeTypeHandle | GetTypeHandle | GetTypeFromHandle


Type.TypeInitializer

Gets the name of the class constructor for the Type.

[Visual Basic]
Public ReadOnly Property TypeInitializer As ConstructorInfo
[C#]
public ConstructorInfo TypeInitializer {get;}
[C++]
public: __property ConstructorInfo* get_TypeInitializer();
[JScript]
public function get TypeInitializer() : ConstructorInfo;

Property Value

A ConstructorInfo containing the name of the class constructor for the Type.

Remarks

Class initializers are available through GetMember, GetMembers, FindMembers, and GetConstructors.

See Also

Type Class | Type Members | System Namespace | ConstructorInfo


Type.UnderlyingSystemType

Gets the underlying system type for the Type.

[Visual Basic]
MustOverride Public ReadOnly Property UnderlyingSystemType As Type
[C#]
public Type UnderlyingSystemType {abstract get;}
[C++]
public: __property virtual Type* get_UnderlyingSystemType() = 0;
[JScript]
public abstract function get UnderlyingSystemType() : Type;

Property Value

The underlying system type for the Type.

See Also

Type Class | Type Members | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Type Methods

The methods of the Type class are listed below. For a complete list of Type class members, see the Type Members topic.

Public:

Equals | Overloaded. Determines if the underlying system type of the current Type is the same as the underlying system type of the specified Object or Type.
FindInterfaces | Returns an array of Type objects representing a filtered list of interfaces implemented or inherited by the current Type.
FindMembers | Returns a filtered array of MemberInfo objects of the specified member type.
GetArrayRank | When implemented by a derived class, gets the number of dimensions in an Array.
GetConstructor | Overloaded. Gets a specific constructor of the current Type.
GetConstructors | Overloaded. Gets the constructors of the current Type.
GetCustomAttributes (inherited from MemberInfo) | Overloaded. Returns all attributes defined on this member.
GetDefaultMembers | Searches for the members defined for the current Type whose DefaultMemberAttribute is set.
GetElementType | When implemented by a derived class, Returns the Type of the element.
GetEvent | Overloaded. Gets a specific event declared or inherited by the current Type.
GetEvents | Overloaded. Gets the events which are declared or inherited by the current Type.
GetField | Overloaded. Gets a specific field of the current Type.
GetFields | Overloaded. Gets the fields of the current Type.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInterface | Overloaded. Gets a specific interface implemented or inherited by the current Type.
GetInterfaceMap | When implemented by a derived class, returns an interface mapping for the specified interface type.
GetInterfaces | When implemented by a derived class, gets all the interfaces implemented or inherited by the current Type.
GetMember | Overloaded. Gets the specified members of the current Type.
GetMembers | Overloaded. Gets the members (properties, methods, fields, events, and so on) of the current Type.
GetMethod | Overloaded. Gets a specific method of the current Type.
GetMethods | Overloaded. Gets the methods of the current Type.
GetNestedType | Overloaded. Gets a specific type nested within the current Type.
GetNestedTypes | Overloaded. Gets the types nested within the current Type.
GetProperties | Overloaded. Gets the properties of the current Type.
GetProperty | Overloaded. Gets a specific property of the current Type.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeArray | Gets the types of the objects in the specified array.
GetTypeCode | Gets the underlying type code of the specified Type.
GetTypeFromHandle | Gets the Type referenced by the specified type handle.
GetTypeFromProgID | Overloaded. Gets the Type associated with the specified program identifier (progID).
GetTypeHandle | Gets the handle for the Type of an object.
InvokeMember | Overloaded. Invokes a specific member of the current Type; essentially calls a constructor member or a method member, gets or sets a property member, gets or sets a data field member, or gets or sets an element of an array member.
IsAssignableFrom | Determines whether an instance of the specified type can be assigned to the current Type instance.
IsDefined (inherited from MemberInfo) | Returns a Boolean if one or more instance of attributeType is defined on this member.
IsInstanceOfType | Determines whether the specified object is an instance of the Type.
IsSubclassOf | Determines whether the current Type is a subclass of the specified class.
ToString | Returns a String representing the name of the current Type.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetAttributeFlagsImpl | Implements the Attributes property and, when implemented by a derived class, gets a bitmask indicating the attributes associated with the Type.
GetConstructorImpl | Searches for a constructor whose parameters match the specified argument types and modifiers, using the specified binding constraints and the specified calling convention.
GetMethodImpl | Searches for the specified method whose parameters match the specified argument types and modifiers, using the specified binding constraints and the specified calling convention.
GetPropertyImpl | When implemented by a derived class, searches for the specified property whose parameters match the specified argument types and modifiers, using the specified binding constraints.
HasElementTypeImpl | Implements the HasElementType property and, when implemented by a derived class, determines whether the Type...
IsArrayImpl | Implements the IsArray property and, when implemented by a derived class, determines whether the Type is an array.
IsByRefImpl | Implements the IsByRef property and, when implemented by a derived class, determines whether the Type is passed by reference.
IsCOMObjectImpl | Implements the IsCOMObject property and, when implemented by a derived class, determines whether the Type is a COM object.
IsContextfulImpl | Implements the IsContextful property and determines whether the Type can be hosted in a context.
IsMarshalByRefImpl | Implements the IsMarshalByRef property and determines whether the Type is marshalled by reference.
IsPointerImpl | Implements the IsPointer property and, when implemented by a derived class, determines whether the Type is a pointer.
IsPrimitiveImpl | Implements the IsPrimitive property and, when implemented by a derived class, determines whether the Type is one of the primitive types.
IsValueTypeImpl | Implements the IsValueType property and, when implemented by a derived class, determines whether the Type is a value type; that is, not a class or an interface.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Type Class | System Namespace


Type.Equals

Determines if the underlying system type of the current Type is the same as the underlying system type of the specified Object or Type.

Overload List

Determines if the underlying system type of the current Type is the same as the underlying system type of the specified Object.

[Visual Basic] Overloads Overrides Public Function Equals(Object) As Boolean
[C#] public override bool Equals(Object);
[C++] public: override bool Equals(Object*);
[JScript] public override function Equals(Object) : Boolean;

Determines if the underlying system type of the current Type is the same as the underlying system type of the specified Type.

[Visual Basic] Overloads Shadows Public Function Equals(Type) As Boolean
[C#] public new bool Equals(Type);
[C++] public: new bool Equals(Type*);
[JScript] public new function Equals(Type) : Boolean;

See Also

Type Class | Type Members | System Namespace


Type.Equals (Object)

Determines if the underlying system type of the current Type is the same as the underlying system type of the specified Object.

[Visual Basic]
Overloads Overrides Public Function Equals( _
   ByVal o As Object _
) As Boolean
[C#]
public override bool Equals(
   object o
);
[C++]
public: override bool Equals(
   Object* o
);
[JScript]
public override function Equals(
   o : Object
) : Boolean;

Parameters

o
The Object whose underlying system type is to be compared with the underlying system type of the current Type.

Return Value

true if the underlying system type of o is the same as the underlying system type of the current Type; otherwise, false.

See Also

Type Class | Type Members | System Namespace | Type.Equals Overload List | UnderlyingSystemType


Type.Equals (Type)

Determines if the underlying system type of the current Type is the same as the underlying system type of the specified Type.

[Visual Basic]
Overloads Shadows Public Function Equals( _
   ByVal o As Type _
) As Boolean
[C#]
public new bool Equals(
   Type o
);
[C++]
public: new bool Equals(
   Type* o
);
[JScript]
public new function Equals(
   o : Type
) : Boolean;

Parameters

o
The Type whose underlying system type is to be compared with the underlying system type of the current Type.

Return Value

true if the underlying system type of o is the same as the underlying system type of the current Type; otherwise, false.

See Also

Type Class | Type Members | System Namespace | Type.Equals Overload List | UnderlyingSystemType


Type.FindInterfaces

Returns an array of Type objects representing a filtered list of interfaces implemented or inherited by the current Type.

[Visual Basic]
Overridable Public Function FindInterfaces( _
   ByVal filter As TypeFilter, _
   ByVal filterCriteria As Object _
) As Type ()
[C#]
public virtual Type[] FindInterfaces(
   TypeFilter filter,
   object filterCriteria
);
[C++]
public: virtual Type* FindInterfaces(
   TypeFilter* filter,
   Object* filterCriteria
) [];
[JScript]
public function FindInterfaces(
   filter : TypeFilter,
   filterCriteria : Object
) : Type[];

Parameters

filter
The TypeFilter delegate that compares the interfaces against filterCriteria.
filterCriteria
The search criteria that determines whether an interface should be included in the returned array.

Return Value

An array of Type objects representing a filtered list of the interfaces implemented or inherited by the current Type.

-or-

An empty array of type Type, if no interfaces matching the filter are implemented or inherited by the current Type.

Exceptions

Exception Type | Condition
ArgumentNullException | filter is a null reference (in Visual Basic Nothing).
TargetInvocationException | A static initializer is invoked and throws an exception.

Remarks

This method can be overridden by a derived class.

The FilterTypeName and FilterTypeNameIgnoreCase delegates supplied by the Module class may also be used, in lieu of the TypeFilter delegate.

All of the interfaces implemented by this class are considered during the search, whether declared by a super class or this class itself.

This method will search the super class hierarchy, returning all matching interfaces each class implements as well as all the matching interfaces each of those interfaces implements (that is, the transitive closure of the matching interfaces is returned). No duplicate interfaces are returned.

See Also

Type Class | Type Members | System Namespace


Type.FindMembers

Returns a filtered array of MemberInfo objects of the specified member type.

[Visual Basic]
Overridable Public Function FindMembers( _
   ByVal memberType As MemberTypes, _
   ByVal bindingAttr As BindingFlags, _
   ByVal filter As MemberFilter, _
   ByVal filterCriteria As Object _
) As MemberInfo ()
[C#]
public virtual MemberInfo[] FindMembers(
   MemberTypes memberType,
   BindingFlags bindingAttr,
   MemberFilter filter,
   object filterCriteria
);
[C++]
public: virtual MemberInfo* FindMembers(
   MemberTypes memberType,
   BindingFlags bindingAttr,
   MemberFilter* filter,
   Object* filterCriteria
) [];
[JScript]
public function FindMembers(
   memberType : MemberTypes,
   bindingAttr : BindingFlags,
   filter : MemberFilter,
   filterCriteria : Object
) : MemberInfo[];

Parameters

memberType
A MemberTypes object indicating the type of member to search for.
bindingAttr
A bit mask comprised of one or more BindingFlags that specify how the search is conducted.

-or-

zero, to conduct a case-sensitive search for public methods.

filter
The delegate that actually does the comparisons, returning true if the member currently being inspected matches the filterCriteria and false otherwise. The FilterAttribute, FilterName, and FilterNameIgnoreCase delegates supplied by this class may be used. The first uses the fields of FieldAttributes, MethodAttributes, and MethodImplAttributes as search criteria, and the latter uses String objects as the search criteria.
filterCriteria
The search criteria that determines whether a member is returned in the array of MemberInfo objects.

The fields of FieldAttributes, MethodAttributes, and MethodImplAttributes may be used in conjunction with the FilterAttribute delegate supplied by this class.

Return Value

A filtered array of MemberInfo objects of the specified member type.

-or-

An empty array of type MemberInfo, if the current Type does not have members of type memberType that match the filter criteria.

Exceptions

Exception Type | Condition
ArgumentNullException | filter is a null reference (in Visual Basic Nothing).
SecurityException | The caller does not have permission to reflect non-public members outside of the current assembly.

Remarks

This method can be overridden by a derived class.

Members include properties, methods, fields, events, and so on.

The following BindingFlags filter flags can be used to define which members should be included in the search:

  • Instance to include instance members in the search.
  • Static to include static members in the search.
  • Public to include public members in the search.
  • NonPublic to include non-public members (that is, private and protected members) in the search.

The following BindingFlags modifier flags can be used to change how the search works:

  • DeclaredOnly to search only the members declared on the Type, not members that were simply inherited.

See BindingFlags for more information.

Valid values for MemberType are defined in MemberInfo. If no such members are found, an empty array is returned.

The permission to reflect members is defined by the ReflectionPermission class.

Class initializers are available through GetMember, GetMembers, FindMembers, and GetConstructors.

See Also

Type Class | Type Members | System Namespace | ReflectionPermission


Type.GetArrayRank

When implemented by a derived class, gets the number of dimensions in an Array.

[Visual Basic]
Overridable Public Function GetArrayRank() As Integer
[C#]
public virtual int GetArrayRank();
[C++]
public: virtual int GetArrayRank();
[JScript]
public function GetArrayRank() : int;

Return Value

The number of dimensions in an Array.

Remarks

Abstract. This method must be implemented by a derived class.

See Also

Type Class | Type Members | System Namespace | Array | Rank


Type.GetAttributeFlagsImpl

Implements the Attributes property and, when implemented by a derived class, gets a bitmask indicating the attributes associated with the Type.

[Visual Basic]
MustOverride Protected Function GetAttributeFlagsImpl() As _
   TypeAttributes
[C#]
protected abstract TypeAttributes GetAttributeFlagsImpl();
[C++]
protected: virtual TypeAttributes GetAttributeFlagsImpl() = 0;
[JScript]
protected abstract function GetAttributeFlagsImpl() :
   TypeAttributes;

Return Value

A TypeAttributes object representing the attribute set of the Type.

Remarks

Abstract. This method must be implemented by a derived class.

See Also

Type Class | Type Members | System Namespace | Attributes


Type.GetConstructor

Gets a specific constructor of the current Type.

Overload List

Searches for a constructor whose parameters match the specified argument types and modifiers, using the specified binding constraints and the specified calling convention.

[Visual Basic] Overloads Public Function GetConstructor(BindingFlags, Binder, CallingConventions, Type(), ParameterModifier()) As ConstructorInfo
[C#] public ConstructorInfo GetConstructor(BindingFlags, Binder, CallingConventions, Type[], ParameterModifier[]);
[C++] public: ConstructorInfo* GetConstructor(BindingFlags, Binder, CallingConventions, Type[], ParameterModifier[]);
[JScript] public function GetConstructor(BindingFlags, Binder, CallingConventions, Type[], ParameterModifier[]) : ConstructorInfo;

Searches for a constructor whose parameters match the types in the specified array.

[Visual Basic] Overloads Public Function GetConstructor(Type()) As ConstructorInfo
[C#] public ConstructorInfo GetConstructor(Type[]);
[C++] public: ConstructorInfo* GetConstructor(Type*[]);
[JScript] public function GetConstructor(Type[]) : ConstructorInfo;

Searches for a constructor whose parameters match the specified argument types and modifiers, using the specified binding constraints.

[Visual Basic] Overloads Public Function GetConstructor(BindingFlags, Binder, Type(), ParameterModifier()) As ConstructorInfo
[C#] public ConstructorInfo GetConstructor(BindingFlags, Binder, Type[], ParameterModifier[]);
[C++] public: ConstructorInfo* GetConstructor(BindingFlags, Binder, Type[], ParameterModifier[]);
[JScript] public function GetConstructor(BindingFlags, Binder, Type[], ParameterModifier[]) : ConstructorInfo;

See Also

Type Class | Type Members | System Namespace


Type.GetConstructor (BindingFlags, Binder, CallingConventions, Type[], ParameterModifier[])

Searches for a constructor whose parameters match the specified argument types and modifiers, using the specified binding constraints and the specified calling convention.

[Visual Basic]
Overloads Public Function GetConstructor( _
   ByVal bindingAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal callConvention As CallingConventions, _
   ByVal types() As Type, _
   ByVal modifiers() As ParameterModifier _
) As ConstructorInfo
[C#]
public ConstructorInfo GetConstructor(
   BindingFlags bindingAttr,
   Binder binder,
   CallingConventions callConvention,
   Type[] types,
   ParameterModifier[] modifiers
);
[C++]
public: ConstructorInfo* GetConstructor(
   BindingFlags bindingAttr,
   Binder* binder,
   CallingConventions callConvention,
   Type* types[],
   ParameterModifier* modifiers[]
);
[JScript]
public function GetConstructor(
   bindingAttr : BindingFlags,
   binder : Binder,
   callConvention : CallingConventions,
   types : Type[],
   modifiers : ParameterModifier[]
) : ConstructorInfo;

Parameters

bindingAttr
A bit mask comprised of one or more BindingFlags that specify how the search is conducted.

-or-

zero, to conduct a case-sensitive search for public methods.

binder
A Binder object that defines a set of properties and enables binding, which may involve selection of an overloaded method, coercion of argument types, and invocation of a member through reflection.

-or-

a null reference (in Visual Basic Nothing), to use the DefaultBinder.

callConvention
The CallingConventions object that specifies the set of rules to use regarding the order and layout of arguments, how the return value is passed, what registers are used for arguments and who cleans up the stack.
types
An array of Type objects representing the number, order, and type of the parameters for the constructor to get.

-or-

An empty array of the type Type (that is, Type[] types = new Type[0]) to get a constructor that takes no parameters.

modifiers
An array of ParameterModifier objects representing the attributes associated with the corresponding element in the types array.

Return Value

A ConstructorInfo object representing the constructor that matches the specified requirements, if found; otherwise, a null reference (Nothing).

Exceptions

Exception Type | Condition
ArgumentNullException | types is a null reference (Nothing). -or- One of the elements in types is a null reference (Nothing).
ArgumentException | types is multidimensional. -or- modifiers is multidimensional. -or- types and modifiers do not have the same length. (?)
SecurityException | The requested constructor is non-public and the caller does not have ReflectionPermission to reflect non-public constructors outside the current assembly.

Remarks

The types array and the modifiers array have the same length. A parameter specified in the types array can have the following attributes, which are specified in the modifiers array: pdIn, pdOut, pdLcid, pdRetval, pdOptional, and pdHasDefault, which represent [in], [out], [lcid], [retval], [optional], and a value specifying whether the parameter has a default value. A parameter's associated attributes are stored in the metadata and are used for interoperability.

If an exact match does not exist, the binder will attempt to coerce the parameter types specified in the types array in order to select a match. If the binder is unable to select a match, then a null reference (Nothing) is returned.

The following BindingFlags filter flags can be used to define which constructors should be included in the search:

  • Public to include public constructors in the search.
  • NonPublic to include non-public constructors (that is, private and protected constructors) in the search.

See BindingFlags for more information.

GetConstructor cannot be used to obtain a class initializer. Class initializers are available only through GetMember, GetMembers, FindMembers, and GetConstructors.

See Also

Type Class | Type Members | System Namespace | Type.GetConstructor Overload List | ConstructorInfo


Type.GetConstructor (Type[])

Searches for a constructor whose parameters match the types in the specified array.

[Visual Basic]
Overloads Public Function GetConstructor( _
   ByVal types() As Type _
) As ConstructorInfo
[C#]
public ConstructorInfo GetConstructor(
   Type[] types
);
[C++]
public: ConstructorInfo* GetConstructor(
   Type* types[]
);
[JScript]
public function GetConstructor(
   types : Type[]
) : ConstructorInfo;

Parameters

types
An array of Type objects representing the number, order, and type of the parameters for the constructor to get.

-or-

An empty array of the type Type (that is, Type[] types = new Type[0]) to get a constructor that takes no parameters.

Return Value

A ConstructorInfo object representing the constructor whose parameters match the types in the types array, if found; otherwise, a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
ArgumentNullException | types is a null reference (Nothing). -or- One of the elements in types is a null reference (Nothing).
ArgumentException | types is multidimensional. (?)
SecurityException | The requested constructor is non-public and the caller does not have ReflectionPermission to reflect non-public constructors outside the current assembly.

Remarks

If an exact match can be found, then it is returned. If an exact match does not exist, the binder will attempt to coerce the parameter types specified in the types array in order to select a match. If it is not possible to select a match, then null is returned. GetConstructor cannot be used to obtain a class initializer. Class initializers are available only through GetMember, GetMembers, FindMembers, and GetConstructors.

See Also

Type Class | Type Members | System Namespace | Type.GetConstructor Overload List


Type.GetConstructor (BindingFlags, Binder, Type[], ParameterModifier[])

Searches for a constructor whose parameters match the specified argument types and modifiers, using the specified binding constraints.

[Visual Basic]
Overloads Public Function GetConstructor( _
   ByVal bindingAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal types() As Type, _
   ByVal modifiers() As ParameterModifier _
) As ConstructorInfo
[C#]
public ConstructorInfo GetConstructor(
   BindingFlags bindingAttr,
   Binder binder,
   Type[] types,
   ParameterModifier[] modifiers
);
[C++]
public: ConstructorInfo* GetConstructor(
   BindingFlags bindingAttr,
   Binder* binder,
   Type* types[],
   ParameterModifier* modifiers[]
);
[JScript]
public function GetConstructor(
   bindingAttr : BindingFlags,
   binder : Binder,
   types : Type[],
   modifiers : ParameterModifier[]
) : ConstructorInfo;

Parameters

bindingAttr
A bit mask comprised of one or more BindingFlags that specify how the search is conducted.

-or-

zero, to conduct a case-sensitive search for public methods.

binder
A Binder object that defines a set of properties and enables binding, which may involve selection of an overloaded method, coercion of argument types, and invocation of a member through reflection.

-or-

a null reference (in Visual Basic Nothing), to use the DefaultBinder.

types
An array of Type objects representing the number, order, and type of the parameters for the constructor to get.

-or-

An empty array of the type Type (that is, Type[] types = new Type[0]) to get a constructor that takes no parameters.

modifiers
An array of ParameterModifier objects representing the attributes associated with the corresponding element in the types array.

Return Value

A ConstructorInfo object representing the constructor that matches the specified requirements, if found; otherwise, a null reference (Nothing).

Exceptions

Exception Type | Condition
ArgumentNullException | types is a null reference (Nothing). -or- One of the elements in types is a null reference (Nothing).
ArgumentException | types is multidimensional. -or- modifiers is multidimensional. -or- types and modifiers do not have the same length. (?)
SecurityException | The requested constructor is non-public and the caller does not have ReflectionPermission to reflect non-public constructors outside the current assembly.

Remarks

The types array and the modifiers array have the same length. A parameter specified in the types array can have the following attributes, which are specified in the modifiers array: pdIn, pdOut, pdLcid, pdRetval, pdOptional, and pdHasDefault, which represent [in], [out], [lcid], [retval], [optional], and a value specifying whether the parameter has a default value. A parameter's associated attributes are stored in the metadata and are used for interoperability.

If an exact match does not exist, the binder will attempt to coerce the parameter types specified in the types array in order to select a match. If the binder is unable to select a match, then a null reference (Nothing) is returned.

The following BindingFlags filter flags can be used to define which constructors should be included in the search:

  • Public to include public constructors in the search.
  • NonPublic to include non-public constructors (that is, private and protected constructors) in the search.

See BindingFlags for more information. GetConstructor cannot be used to obtain a class initializer. Class initializers are available only through GetMember, GetMembers, FindMembers, and GetConstructors.

See Also

Type Class | Type Members | System Namespace | Type.GetConstructor Overload List | DefaultBinder


Type.GetConstructorImpl

Searches for a constructor whose parameters match the specified argument types and modifiers, using the specified binding constraints and the specified calling convention.

[Visual Basic]
MustOverride Protected Function GetConstructorImpl( _
   ByVal bindingAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal callConvention As CallingConventions, _
   ByVal types() As Type, _
   ByVal modifiers() As ParameterModifier _
) As ConstructorInfo
[C#]
protected abstract ConstructorInfo GetConstructorImpl(
   BindingFlags bindingAttr,
   Binder binder,
   CallingConventions callConvention,
   Type[] types,
   ParameterModifier[] modifiers
);
[C++]
protected: virtual ConstructorInfo* GetConstructorImpl(
   BindingFlags bindingAttr,
   Binder* binder,
   CallingConventions callConvention,
   Type* types[],
   ParameterModifier* modifiers[]
) = 0;
[JScript]
protected abstract function GetConstructorImpl(
   bindingAttr : BindingFlags,
   binder : Binder,
   callConvention : CallingConventions,
   types : Type[],
   modifiers : ParameterModifier[]
) : ConstructorInfo;

Parameters

bindingAttr
A bit mask comprised of one or more BindingFlags that specify how the search is conducted.

-or-

zero, to conduct a case-sensitive search for public methods.

binder
A Binder object that defines a set of properties and enables binding, which may involve selection of an overloaded method, coercion of argument types, and invocation of a member through reflection.

-or-

a null reference (in Visual Basic Nothing), to use the DefaultBinder.

callConvention
The CallingConventions object that specifies the set of rules to use regarding the order and layout of arguments, how the return value is passed, what registers are used for arguments and who cleans up the stack.
types
An array of Type objects representing the number, order, and type of the parameters for the constructor to get.

-or-

An empty array of the type Type (that is, Type[] types = new Type[0]) to get a constructor that takes no parameters.

modifiers
An array of ParameterModifier objects representing the attributes associated with the corresponding element in the types array.

Return Value

A ConstructorInfo object representing the constructor that matches the specified requirements, if found; otherwise, a null reference (Nothing).

Exceptions

Exception Type | Condition
ArgumentNullException | types is a null reference (Nothing). -or- One of the elements in types is a null reference (Nothing).
ArgumentException | types is multidimensional. -or- modifiers is multidimensional. -or- types and modifiers do not have the same length. (?)
SecurityException | The requested constructor is non-public and the caller does not have ReflectionPermission to reflect non-public constructors outside the current assembly.

Remarks

Abstract. This method must be implemented by a derived class.

The types array and the modifiers array have the same length. A parameter specified in the types array can have the following attributes, which are specified in the modifiers array: pdIn, pdOut, pdLcid, pdRetval, pdOptional, and pdHasDefault, which represent [in], [out], [lcid], [retval], [optional], and a value specifying whether the parameter has a default value. A parameter's associated attributes are stored in the metadata and are used for interoperability.

If an exact match does not exist, the binder will attempt to coerce the parameter types specified in the types array in order to select a match. If the binder is unable to select a match, then a null reference (Nothing) is returned.

The following BindingFlags filter flags can be used to define which constructors should be included in the search:

  • Public to include public constructors in the search.
  • NonPublic to include non-public constructors (that is, private and protected constructors) in the search.

See BindingFlags for more information.

This method implements GetConstructor. GetConstructor and GetConstructorImpl cannot be used to obtain a class initializer. Class initializers are available only through GetMember, GetMembers, FindMembers, and GetConstructors.

See Also

Type Class | Type Members | System Namespace | DefaultBinder


Type.GetConstructors

Gets the constructors of the current Type.

Overload List

Returns all the public constructors defined for the current Type.

[Visual Basic] Overloads Public Function GetConstructors() As ConstructorInfo ()
[C#] public ConstructorInfo[] GetConstructors();
[C++] public: ConstructorInfo* GetConstructors() [];
[JScript] public function GetConstructors() : ConstructorInfo[];

When implemented by a derived class, searches for the constructors defined for the current Type, using the specified binding constraints.

[Visual Basic] Overloads MustOverride Public Function GetConstructors(BindingFlags) As ConstructorInfo ()
[C#] public abstract ConstructorInfo[] GetConstructors(BindingFlags);
[C++] public: virtual ConstructorInfo* GetConstructors(BindingFlags) [] = 0;
[JScript] public abstract function GetConstructors(BindingFlags) : ConstructorInfo[];

See Also

Type Class | Type Members | System Namespace


Type.GetConstructors ()

Returns all the public constructors defined for the current Type.

[Visual Basic]
Overloads Public Function GetConstructors() As ConstructorInfo ()
[C#]
public ConstructorInfo[] GetConstructors();
[C++]
public: ConstructorInfo* GetConstructors() [];
[JScript]
public function GetConstructors() : ConstructorInfo[];

Return Value

An array of ConstructorInfo objects representing all the public constructors defined for the current Type, including the type initializer if it is defined.

-or-

An empty array of type ConstructorInfo, if no public constructors are defined for the current Type.

Remarks

Class initializers are available through GetMember, GetMembers, FindMembers, and GetConstructors.

See Also

Type Class | Type Members | System Namespace | Type.GetConstructors Overload List


Type.GetConstructors (BindingFlags)

When implemented by a derived class, searches for the constructors defined for the current Type, using the specified binding constraints.

[Visual Basic]
Overloads MustOverride Public Function GetConstructors( _
   ByVal bindingAttr As BindingFlags _
) As ConstructorInfo ()
[C#]
public abstract ConstructorInfo[] GetConstructors(
   BindingFlags bindingAttr
);
[C++]
public: virtual ConstructorInfo* GetConstructors(
   BindingFlags bindingAttr
) [] = 0;
[JScript]
public abstract function GetConstructors(
   bindingAttr : BindingFlags
) : ConstructorInfo[];

Parameters

bindingAttr
A bit mask comprised of one or more BindingFlags that specify how the search is conducted.

-or-

zero, to conduct a case-sensitive search for public methods.

Return Value

An array of ConstructorInfo objects representing all constructors defined for the current Type that match the specified binding constraints, including the type initializer if it is defined.

-or-

An empty array of type ConstructorInfo, if no constructors are defined for the current Type, or if none of the defined constructors match the binding constraints.

Exceptions

Exception Type | Condition
SecurityException | The BindingFlags value Public is used but the caller does not have ReflectionPermission to reflect non-public members outside the current assembly.

Remarks

Abstract. This method must be implemented by a derived class.

bindingAttr can be used to specify whether to return only public constructors or both public and non-public constructors.

If an exact match does not exist, the binder will attempt to coerce the parameter types specified in the types array in order to select a match. If the binder is unable to select a match, then a null reference (in Visual Basic Nothing) is returned.

The following BindingFlags filter flags can be used to define which constructors should be included in the search:

  • Public to include public constructors in the search.
  • NonPublic to include non-public constructors (that is, private and protected constructors) in the search.

See BindingFlags for more information.Class initializers are available through GetMember, GetMembers, FindMembers, and GetConstructors.

See Also

Type Class | Type Members | System Namespace | Type.GetConstructors Overload List


Type.GetDefaultMembers

Searches for the members defined for the current Type whose DefaultMemberAttribute is set.

[Visual Basic]
Overridable Public Function GetDefaultMembers() As MemberInfo ()
[C#]
public virtual MemberInfo[] GetDefaultMembers();
[C++]
public: virtual MemberInfo* GetDefaultMembers() [];
[JScript]
public function GetDefaultMembers() : MemberInfo[];

Return Value

An array of MemberInfo objects representing all default members of the current Type.

-or-

An empty array of type MemberInfo, if the current Type does not have default members.

Remarks

This method can be overridden by a derived class.

Members include properties, methods, fields, events, and so on.

See Also

Type Class | Type Members | System Namespace


Type.GetElementType

When implemented by a derived class, Returns the Type of the element.

[Visual Basic]
MustOverride Public Function GetElementType() As Type
[C#]
public abstract Type GetElementType();
[C++]
public: virtual Type* GetElementType() = 0;
[JScript]
public abstract function GetElementType() : Type;

Return Value

The Type of the element.

Remarks

Abstract. This method must be implemented by a derived class.

See Also

Type Class | Type Members | System Namespace


Type.GetEvent

Gets a specific event declared or inherited by the current Type.

Overload List

When implemented by a derived class, returns the EventInfo object representing the specified event, using the specified binding constraints.

[Visual Basic] Overloads MustOverride Public Function GetEvent(String, BindingFlags) As EventInfo
[C#] public abstract EventInfo GetEvent(String, BindingFlags);
[C++] public: virtual EventInfo* GetEvent(String*, BindingFlags) = 0;
[JScript] public abstract function GetEvent(String, BindingFlags) : EventInfo;

Returns the EventInfo object representing the specified event.

[Visual Basic] Overloads Public Function GetEvent(String) As EventInfo
[C#] public EventInfo GetEvent(String);
[C++] public: EventInfo* GetEvent(String*);
[JScript] public function GetEvent(String) : EventInfo;

See Also

Type Class | Type Members | System Namespace


Type.GetEvent (String, BindingFlags)

When implemented by a derived class, returns the EventInfo object representing the specified event, using the specified binding constraints.

[Visual Basic]
Overloads MustOverride Public Function GetEvent( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags _
) As EventInfo
[C#]
public abstract EventInfo GetEvent(
   string name,
   BindingFlags bindingAttr
);
[C++]
public: virtual EventInfo* GetEvent(
   String* name,
   BindingFlags bindingAttr
) = 0;
[JScript]
public abstract function GetEvent(
   name : String,
   bindingAttr : BindingFlags
) : EventInfo;

Parameters

name
The String containing the name of an event which is declared or inherited by the current Type.
bindingAttr
A bit mask comprised of one or more BindingFlags that specify how the search is conducted.

-or-

zero, to conduct a case-sensitive search for public events.

Return Value

The EventInfo object representing the specified event which is declared or inherited by the current Type, if found; otherwise, a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
ArgumentNullException | name is a null reference (Nothing).
SecurityException | The BindingFlags value Public is used but the caller does not have ReflectionPermission to reflect non-public members outside the current assembly.

Remarks

Abstract. This method must be implemented by a derived class.

The following BindingFlags filter flags can be used to define which events should be included in the search:

  • Public to include public events in the search.
  • NonPublic to include non-public events (that is, private and protected events) in the search.

The following BindingFlags modifier flags can be used to change how the search works:

  • IgnoreCase to ignore the case of name. If name has 128 or more standard ASCII characters, a case-sensitive search will be performed, regardless of the IgnoreCase flag.
  • DeclaredOnly to search only the events declared on the Type, not events that were simply inherited.

See BindingFlags for more information.

See Also

Type Class | Type Members | System Namespace | Type.GetEvent Overload List


Type.GetEvent (String)

Returns the EventInfo object representing the specified event.

[Visual Basic]
Overloads Public Function GetEvent( _
   ByVal name As String _
) As EventInfo
[C#]
public EventInfo GetEvent(
   string name
);
[C++]
public: EventInfo* GetEvent(
   String* name
);
[JScript]
public function GetEvent(
   name : String
) : EventInfo;

Parameters

name
The String containing the name of an event which is declared or inherited by the current Type.

Return Value

The EventInfo object representing the specified event which is declared or inherited by the current Type, if found; otherwise, a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
ArgumentNullException | name is a null reference (Nothing).

Remarks

The search for name is case-sensitive.

See Also

Type Class | Type Members | System Namespace | Type.GetEvent Overload List


Type.GetEvents

Gets the events which are declared or inherited by the current Type.

Overload List

When implemented by a derived class, searches for events which are declared or inherited by the current Type, using the specified binding constraints.

[Visual Basic] Overloads MustOverride Public Function GetEvents(BindingFlags) As EventInfo ()
[C#] public abstract EventInfo[] GetEvents(BindingFlags);
[C++] public: virtual EventInfo* GetEvents(BindingFlags) [] = 0;
[JScript] public abstract function GetEvents(BindingFlags) : EventInfo[];

Returns all the public events which are declared or inherited by the current Type.

[Visual Basic] Overloads Overridable Public Function GetEvents() As EventInfo ()
[C#] public virtual EventInfo[] GetEvents();
[C++] public: virtual EventInfo* GetEvents() [];
[JScript] public function GetEvents() : EventInfo[];

See Also

Type Class | Type Members | System Namespace


Type.GetEvents (BindingFlags)

When implemented by a derived class, searches for events which are declared or inherited by the current Type, using the specified binding constraints.

[Visual Basic]
Overloads MustOverride Public Function GetEvents( _
   ByVal bindingAttr As BindingFlags _
) As EventInfo ()
[C#]
public abstract EventInfo[] GetEvents(
   BindingFlags bindingAttr
);
[C++]
public: virtual EventInfo* GetEvents(
   BindingFlags bindingAttr
) [] = 0;
[JScript]
public abstract function GetEvents(
   bindingAttr : BindingFlags
) : EventInfo[];

Parameters

bindingAttr
A bit mask comprised of one or more BindingFlags that specify how the search is conducted.

-or-

zero, to conduct a case-sensitive search for public events.

Return Value

An array of EventInfo objects representing all events which are declared or inherited by the current Type that match the specified binding constraints.

-or-An empty array of type EventInfo, if the current Type does not have events, or if none of the events match the binding constraints.

Exceptions

Exception Type | Condition
SecurityException | The BindingFlags value Public is used but the caller does not have ReflectionPermission to reflect non-public members outside the current assembly.

Remarks

Abstract. This method must be implemented by a derived class.

The following BindingFlags filter flags can be used to define which events should be included in the search:

  • Public to include public events in the search.
  • NonPublic to include non-public events (that is, private and protected events) in the search.

The following BindingFlags modifier flags can be used to change how the search works:

  • DeclaredOnly to search only the events declared on the Type, not events that were simply inherited.

See BindingFlags for more information.

See Also

Type Class | Type Members | System Namespace | Type.GetEvents Overload List


Type.GetEvents ()

Returns all the public events which are declared or inherited by the current Type.

[Visual Basic]
Overloads Overridable Public Function GetEvents() As EventInfo ()
[C#]
public virtual EventInfo[] GetEvents();
[C++]
public: virtual EventInfo* GetEvents() [];
[JScript]
public function GetEvents() : EventInfo[];

Return Value

An array of EventInfo objects representing all the public events which are declared or inherited by the current Type.

-or-

An empty array of type EventInfo, if the current Type does not have public events.

Remarks

This method can be overridden by a derived class.

See Also

Type Class | Type Members | System Namespace | Type.GetEvents Overload List


Type.GetField

Gets a specific field of the current Type.

Overload List

Searches for the field with the specified name.

[Visual Basic] Overloads Public Function GetField(String) As FieldInfo
[C#] public FieldInfo GetField(String);
[C++] public: FieldInfo* GetField(String*);
[JScript] public function GetField(String) : FieldInfo;

When implemented by a derived class, searches for the specified field, using the specified binding constraints.

[Visual Basic] Overloads MustOverride Public Function GetField(String, BindingFlags) As FieldInfo
[C#] public abstract FieldInfo GetField(String, BindingFlags);
[C++] public: virtual FieldInfo* GetField(String*, BindingFlags) = 0;
[JScript] public abstract function GetField(String, BindingFlags) : FieldInfo;

See Also

Type Class | Type Members | System Namespace


Type.GetField (String)

Searches for the field with the specified name.

[Visual Basic]
Overloads Public Function GetField( _
   ByVal name As String _
) As FieldInfo
[C#]
public FieldInfo GetField(
   string name
);
[C++]
public: FieldInfo* GetField(
   String* name
);
[JScript]
public function GetField(
   name : String
) : FieldInfo;

Parameters

name
The String containing the name of the data field to get.

Return Value

A FieldInfo object representing the field with the specified name, if found; otherwise, a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
ArgumentNullException | name is a null reference (Nothing).
SecurityException | The requested field is non-public and the caller does not have ReflectionPermission to reflect non-public members outside the current assembly.

Remarks

The search for name is case-sensitive.

See Also

Type Class | Type Members | System Namespace | Type.GetField Overload List


Type.GetField (String, BindingFlags)

When implemented by a derived class, searches for the specified field, using the specified binding constraints.

[Visual Basic]
Overloads MustOverride Public Function GetField( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags _
) As FieldInfo
[C#]
public abstract FieldInfo GetField(
   string name,
   BindingFlags bindingAttr
);
[C++]
public: virtual FieldInfo* GetField(
   String* name,
   BindingFlags bindingAttr
) = 0;
[JScript]
public abstract function GetField(
   name : String,
   bindingAttr : BindingFlags
) : FieldInfo;

Parameters

name
The String containing the name of the data field to get.
bindingAttr
A bit mask comprised of one or more BindingFlags that specify how the search is conducted.

-or-

zero, to conduct a case-sensitive search for public methods.

Return Value

A FieldInfo object representing the field that matches the specified requirements, if found; otherwise, a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
ArgumentNullException | name is a null reference (Nothing).
SecurityException | The requested field is non-public and the caller does not have ReflectionPermission to reflect non-public members outside the current assembly.

Remarks

Abstract. This method must be implemented by a derived class.

The following BindingFlags filter flags can be used to define which fields should be included in the search:

  • Instance to include instance fields in the search.
  • Static to include static fields in the search.
  • Public to include public fields in the search.
  • NonPublic to include non-public fields (that is, private and protected fields) in the search.

The following BindingFlags modifier flags can be used to change how the search works:

  • IgnoreCase to ignore the case of name. If name has 128 or more standard ASCII characters, a case-sensitive search will be performed, regardless of the IgnoreCase flag.
  • DeclaredOnly to search only the fields declared on the Type, not fields that were simply inherited.

See BindingFlags for more information.

See Also

Type Class | Type Members | System Namespace | Type.GetField Overload List


Type.GetFields

Gets the fields of the current Type.

Overload List

Returns all the public fields of the current Type.

[Visual Basic] Overloads Public Function GetFields() As FieldInfo ()
[C#] public FieldInfo[] GetFields();
[C++] public: FieldInfo* GetFields() [];
[JScript] public function GetFields() : FieldInfo[];

When implemented by a derived class, searches for the fields defined for the current Type, using the specified binding constraints.

[Visual Basic] Overloads MustOverride Public Function GetFields(BindingFlags) As FieldInfo ()
[C#] public abstract FieldInfo[] GetFields(BindingFlags);
[C++] public: virtual FieldInfo* GetFields(BindingFlags) [] = 0;
[JScript] public abstract function GetFields(BindingFlags) : FieldInfo[];

See Also

Type Class | Type Members | System Namespace


Type.GetFields ()

Returns all the public fields of the current Type.

[Visual Basic]
Overloads Public Function GetFields() As FieldInfo ()
[C#]
public FieldInfo[] GetFields();
[C++]
public: FieldInfo* GetFields() [];
[JScript]
public function GetFields() : FieldInfo[];

Return Value

An array of FieldInfo objects representing all the public fields defined for the current Type.

-or-

An empty array of type FieldInfo, if no public fields are defined for the current Type.

See Also

Type Class | Type Members | System Namespace | Type.GetFields Overload List


Type.GetFields (BindingFlags)

When implemented by a derived class, searches for the fields defined for the current Type, using the specified binding constraints.

[Visual Basic]
Overloads MustOverride Public Function GetFields( _
   ByVal bindingAttr As BindingFlags _
) As FieldInfo ()
[C#]
public abstract FieldInfo[] GetFields(
   BindingFlags bindingAttr
);
[C++]
public: virtual FieldInfo* GetFields(
   BindingFlags bindingAttr
) [] = 0;
[JScript]
public abstract function GetFields(
   bindingAttr : BindingFlags
) : FieldInfo[];

Parameters

bindingAttr
A bit mask comprised of one or more BindingFlags that specify how the search is conducted.

-or-

zero, to conduct a case-sensitive search for public methods.

Return Value

An array of FieldInfo objects representing all fields defined for the current Type that match the specified binding constraints.

-or-

An empty array of type FieldInfo, if no fields are defined for the current Type, or if none of the defined fields match the binding constraints.

Exceptions

Exception Type | Condition
SecurityException | The BindingFlags value Public is used but the caller does not have ReflectionPermission to reflect non-public members outside the current assembly.

Remarks

Abstract. This method must be implemented by a derived class.

The following BindingFlags filter flags can be used to define which fields should be included in the search:

  • Instance to include instance fields in the search.
  • Static to include static fields in the search.
  • Public to include public fields in the search.
  • NonPublic to include non-public fields (that is, private and protected fields) in the search.

The following BindingFlags modifier flags can be used to change how the search works:

  • DeclaredOnly to search only the fields declared on the Type, not members that were simply inherited.

See BindingFlags for more information.

See Also

Type Class | Type Members | System Namespace | Type.GetFields Overload List


Type.GetInterface

Gets a specific interface implemented or inherited by the current Type.

Overload List

When implemented by a derived class, searches for the specified interface, specifying case-sensitivity.

[Visual Basic] Overloads MustOverride Public Function GetInterface(String, Boolean) As Type
[C#] public abstract Type GetInterface(String, bool);
[C++] public: virtual Type* GetInterface(String*, bool) = 0;
[JScript] public abstract function GetInterface(String, Boolean) : Type;

Searches for the interface with the specified name.

[Visual Basic] Overloads Public Function GetInterface(String) As Type
[C#] public Type GetInterface(String);
[C++] public: Type* GetInterface(String*);
[JScript] public function GetInterface(String) : Type;

See Also

Type Class | Type Members | System Namespace


Type.GetInterface (String, Boolean)

When implemented by a derived class, searches for the specified interface, specifying case-sensitivity.

[Visual Basic]
Overloads MustOverride Public Function GetInterface( _
   ByVal name As String, _
   ByVal ignoreCase As Boolean _
) As Type
[C#]
public abstract Type GetInterface(
   string name,
   bool ignoreCase
);
[C++]
public: virtual Type* GetInterface(
   String* name,
   bool ignoreCase
) = 0;
[JScript]
public abstract function GetInterface(
   name : String,
   ignoreCase : Boolean
) : Type;

Parameters

name
The String containing the name of the interface to get.
ignoreCase
true to perform a case-insensitive search for name.

-or-

false to perform a case-sensitive search for name.

Return Value

A Type object representing the interface with the specified name, implemented or inherited by the current Type, if found; otherwise, a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
ArgumentNullException | name is a null reference (Nothing).
TargetInvocationException | A static initializer is invoked and throws an exception.

Remarks

Abstract. This method must be implemented by a derived class.

If typeName has 128 or more standard ASCII characters, a case-sensitive search will be performed, regardless of the value of ignoreCase. Arrays or COM types are not searched for unless they have already been loaded into the table of available classes.

See Also

Type Class | Type Members | System Namespace | Type.GetInterface Overload List


Type.GetInterface (String)

Searches for the interface with the specified name.

[Visual Basic]
Overloads Public Function GetInterface( _
   ByVal name As String _
) As Type
[C#]
public Type GetInterface(
   string name
);
[C++]
public: Type* GetInterface(
   String* name
);
[JScript]
public function GetInterface(
   name : String
) : Type;

Parameters

name
The String containing the name of the interface to get.

Return Value

A Type object representing the interface with the specified name, implemented or inherited by the current Type, if found; otherwise, a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
ArgumentNullException | name is a null reference (Nothing).
TargetInvocationException | A static initializer is invoked and throws an exception.

Remarks

The search for name is case-sensitive.

See Also

Type Class | Type Members | System Namespace | Type.GetInterface Overload List


Type.GetInterfaceMap

When implemented by a derived class, returns an interface mapping for the specified interface type.

[Visual Basic]
Overridable Public Function GetInterfaceMap( _
   ByVal interfaceType As Type _
) As InterfaceMapping
[C#]
public virtual InterfaceMapping GetInterfaceMap(
   Type interfaceType
);
[C++]
public: virtual InterfaceMapping GetInterfaceMap(
   Type* interfaceType
);
[JScript]
public function GetInterfaceMap(
   interfaceType : Type
) : InterfaceMapping;

Parameters

interfaceType
The Type of the interface to retrieve a mapping of.

Return Value

An InterfaceMapping object representing the interface mapping for interfaceType.

Remarks

Abstract. This method must be implemented by a derived class.The interface map denotes how an interface is mapped into the actual methods on a class that implements that interface.

See Also

Type Class | Type Members | System Namespace | InterfaceMapping


Type.GetInterfaces

When implemented by a derived class, gets all the interfaces implemented or inherited by the current Type.

[Visual Basic]
MustOverride Public Function GetInterfaces() As Type ()
[C#]
public abstract Type[] GetInterfaces();
[C++]
public: virtual Type* GetInterfaces() [] = 0;
[JScript]
public abstract function GetInterfaces() : Type[];

Return Value

An array of Type objects representing all the interfaces implemented or inherited by the current Type.

-or-

An empty array of type Type, if no interfaces are implemented or inherited by the current Type.

Exceptions

Exception Type | Condition
TargetInvocationException | A static initializer is invoked and throws an exception.

Remarks

Abstract. This method must be implemented by a derived class.

See Also

Type Class | Type Members | System Namespace


Type.GetMember

Gets the specified members of the current Type.

Overload List

Searches for the members with the specified name.

[Visual Basic] Overloads Public Function GetMember(String) As MemberInfo ()
[C#] public MemberInfo[] GetMember(String);
[C++] public: MemberInfo* GetMember(String*) [];
[JScript] public function GetMember(String) : MemberInfo[];

Searches for the specified members, using the specified binding constraints.

[Visual Basic] Overloads Overridable Public Function GetMember(String, BindingFlags) As MemberInfo ()
[C#] public virtual MemberInfo[] GetMember(String, BindingFlags);
[C++] public: virtual MemberInfo* GetMember(String*, BindingFlags) [];
[JScript] public function GetMember(String, BindingFlags) : MemberInfo[];

When implemented by a derived class, searches for the specified members of the specified member type, using the specified binding constraints.

[Visual Basic] Overloads Overridable Public Function GetMember(String, MemberTypes, BindingFlags) As MemberInfo ()
[C#] public virtual MemberInfo[] GetMember(String, MemberTypes, BindingFlags);
[C++] public: virtual MemberInfo* GetMember(String*, MemberTypes, BindingFlags) [];
[JScript] public function GetMember(String, MemberTypes, BindingFlags) : MemberInfo[];

See Also

Type Class | Type Members | System Namespace


Type.GetMember (String)

Searches for the members with the specified name.

[Visual Basic]
Overloads Public Function GetMember( _
   ByVal name As String _
) As MemberInfo ()
[C#]
public MemberInfo[] GetMember(
   string name
);
[C++]
public: MemberInfo* GetMember(
   String* name
) [];
[JScript]
public function GetMember(
   name : String
) : MemberInfo[];

Parameters

name
The String containing the name of the public members to get.

Return Value

An array of MemberInfo objects representing the public members with the specified name, if found; otherwise, a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
ArgumentNullException | name is a null reference (Nothing).
SecurityException | The requested member is non-public and the caller does not have ReflectionPermission to reflect non-public members outside the current assembly.

Remarks

The search for name is case-sensitive.

Members include properties, methods, fields, events, and so on.

This method searches the current classes and its base classes. Only public methods can be found using this method.Class initializers are available through GetMember, GetMembers, FindMembers, and GetConstructors.

See Also

Type Class | Type Members | System Namespace | Type.GetMember Overload List


Type.GetMember (String, BindingFlags)

Searches for the specified members, using the specified binding constraints.

[Visual Basic]
Overloads Overridable Public Function GetMember( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags _
) As MemberInfo ()
[C#]
public virtual MemberInfo[] GetMember(
   string name,
   BindingFlags bindingAttr
);
[C++]
public: virtual MemberInfo* GetMember(
   String* name,
   BindingFlags bindingAttr
) [];
[JScript]
public function GetMember(
   name : String,
   bindingAttr : BindingFlags
) : MemberInfo[];

Parameters

name
The String containing the name of the members to get.
bindingAttr
A bit mask comprised of one or more BindingFlags that specify how the search is conducted.

-or-

zero, to conduct a case-sensitive search for public members.

Return Value

An array of MemberInfo objects representing the public members with the specified name, if found; otherwise, a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
ArgumentNullException | name is a null reference (Nothing).
SecurityException | The requested member is non-public and the caller does not have ReflectionPermission to reflect non-public members outside the current assembly.

Remarks

This method can be overridden by a derived class.

Members include properties, methods, fields, events, and so on.

This method searches the current classes and its base classes.

The following BindingFlags filter flags can be used to define which members should be included in the search:

  • Instance to include instance members in the search.
  • Static to include static members in the search.
  • Public to include public members in the search.
  • NonPublic to include non-public members (that is, private and protected members) in the search.

The following BindingFlags modifier flags can be used to change how the search works:

  • IgnoreCase to ignore the case of name. If name has 128 or more standard ASCII characters, a case-sensitive search will be performed, regardless of the IgnoreCase flag.
  • DeclaredOnly to search only the members declared on the Type, not members that were simply inherited.

See BindingFlags for more information.Class initializers are available through GetMember, GetMembers, FindMembers, and GetConstructors.

See Also

Type Class | Type Members | System Namespace | Type.GetMember Overload List


Type.GetMember (String, MemberTypes, BindingFlags)

When implemented by a derived class, searches for the specified members of the specified member type, using the specified binding constraints.

[Visual Basic]
Overloads Overridable Public Function GetMember( _
   ByVal name As String, _
   ByVal type As MemberTypes, _
   ByVal bindingAttr As BindingFlags _
) As MemberInfo ()
[C#]
public virtual MemberInfo[] GetMember(
   string name,
   MemberTypes type,
   BindingFlags bindingAttr
);
[C++]
public: virtual MemberInfo* GetMember(
   String* name,
   MemberTypes type,
   BindingFlags bindingAttr
) [];
[JScript]
public function GetMember(
   name : String,
   type : MemberTypes,
   bindingAttr : BindingFlags
) : MemberInfo[];

Parameters

name
The String containing the name of the members to get.
type
The Type of member to search for.
bindingAttr
A bit mask comprised of one or more BindingFlags that specify how the search is conducted.

-or-

zero, to conduct a case-sensitive search for public members.

Return Value

An array of MemberInfo objects representing the public members with the specified name, if found; otherwise, a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
ArgumentNullException | name is a null reference (Nothing).
SecurityException | The requested member is non-public and the caller does not have ReflectionPermission to reflect non-public members outside the current assembly.

Remarks

Abstract. This method must be implemented by a derived class.

Members include properties, methods, fields, events, and so on.

This method searches the current classes and its base classes.

The following BindingFlags filter flags can be used to define which members should be included in the search:

  • Instance to include instance members in the search.
  • Static to include static members in the search.
  • Public to include public members in the search.
  • NonPublic to include non-public members (that is, private and protected members) in the search.

The following BindingFlags modifier flags can be used to change how the search works:

  • IgnoreCase to ignore the case of name. If name has 128 or more standard ASCII characters, a case-sensitive search will be performed, regardless of the IgnoreCase flag.
  • DeclaredOnly to search only the members declared on the Type, not members that were simply inherited.

See BindingFlags for more information.Class initializers are available through GetMember, GetMembers, FindMembers, and GetConstructors.

See Also

Type Class | Type Members | System Namespace | Type.GetMember Overload List


Type.GetMembers

Gets the members (properties, methods, fields, events, and so on) of the current Type.

Overload List

When implemented by a derived class, searches for the members defined for the current Type, using the specified binding constraints.

[Visual Basic] Overloads MustOverride Public Function GetMembers(BindingFlags) As MemberInfo ()
[C#] public abstract MemberInfo[] GetMembers(BindingFlags);
[C++] public: virtual MemberInfo* GetMembers(BindingFlags) [] = 0;
[JScript] public abstract function GetMembers(BindingFlags) : MemberInfo[];

Returns all the public members of the current Type.

[Visual Basic] Overloads Public Function GetMembers() As MemberInfo ()
[C#] public MemberInfo[] GetMembers();
[C++] public: MemberInfo* GetMembers() [];
[JScript] public function GetMembers() : MemberInfo[];

See Also

Type Class | Type Members | System Namespace


Type.GetMembers (BindingFlags)

When implemented by a derived class, searches for the members defined for the current Type, using the specified binding constraints.

[Visual Basic]
Overloads MustOverride Public Function GetMembers( _
   ByVal bindingAttr As BindingFlags _
) As MemberInfo ()
[C#]
public abstract MemberInfo[] GetMembers(
   BindingFlags bindingAttr
);
[C++]
public: virtual MemberInfo* GetMembers(
   BindingFlags bindingAttr
) [] = 0;
[JScript]
public abstract function GetMembers(
   bindingAttr : BindingFlags
) : MemberInfo[];

Parameters

bindingAttr
A bit mask comprised of one or more BindingFlags that specify how the search is conducted.

-or-

zero, to conduct a case-sensitive search for public members.

Return Value

An array of MemberInfo objects representing all members defined for the current Type that match the specified binding constraints.

-or-

An empty array of type MemberInfo, if no members are defined for the current Type, or if none of the defined members match the binding constraints.

Remarks

Abstract. This method must be implemented by a derived class.

Members include properties, methods, fields, events, and so on.

The following BindingFlags filter flags can be used to define which members should be included in the search:

  • Instance to include instance members in the search.
  • Static to include static members in the search.
  • Public to include public members in the search.
  • NonPublic to include non-public members (that is, private and protected members) in the search.

The following BindingFlags modifier flags can be used to change how the search works:

  • DeclaredOnly to search only the members declared on the Type, not members that were simply inherited.

Calling this method with only the Public flag or only the NonPublic flag will return the specified members and does not require any other flags.

See BindingFlags for more information.Class initializers are available through GetMember, GetMembers, FindMembers, and GetConstructors.

See Also

Type Class | Type Members | System Namespace | Type.GetMembers Overload List


Type.GetMembers ()

Returns all the public members of the current Type.

[Visual Basic]
Overloads Public Function GetMembers() As MemberInfo ()
[C#]
public MemberInfo[] GetMembers();
[C++]
public: MemberInfo* GetMembers() [];
[JScript]
public function GetMembers() : MemberInfo[];

Return Value

An array of MemberInfo objects representing all the public members of the current Type.

-or-

An empty array of type MemberInfo, if the current Type does not have public members.

Remarks

Members include properties, methods, fields, events, and so on.

Class initializers are available through GetMember, GetMembers, FindMembers, and GetConstructors.

See Also

Type Class | Type Members | System Namespace | Type.GetMembers Overload List


Type.GetMethod

Gets a specific method of the current Type.

Overload List

Searches for the specified method, using the specified binding constraints.

[Visual Basic] Overloads Overridable Public Function GetMethod(String, BindingFlags) As MethodInfo
[C#] public virtual MethodInfo GetMethod(String, BindingFlags);
[C++] public: virtual MethodInfo* GetMethod(String*, BindingFlags);
[JScript] public function GetMethod(String, BindingFlags) : MethodInfo;

Searches for the specified method whose parameters match the specified argument types and modifiers, using the specified binding constraints.

[Visual Basic] Overloads Overridable Public Function GetMethod(String, BindingFlags, Binder, Type(), ParameterModifier()) As MethodInfo
[C#] public virtual MethodInfo GetMethod(String, BindingFlags, Binder, Type[], ParameterModifier[]);
[C++] public: virtual MethodInfo* GetMethod(String*, BindingFlags, Binder, Type[], ParameterModifier[]);
[JScript] public function GetMethod(String, BindingFlags, Binder, Type[], ParameterModifier[]) : MethodInfo;

Searches for the specified public method whose parameters match the specified argument types.

[Visual Basic] Overloads Public Function GetMethod(String, Type()) As MethodInfo
[C#] public MethodInfo GetMethod(String, Type[]);
[C++] public: MethodInfo* GetMethod(String*, Type[]);
[JScript] public function GetMethod(String, Type[]) : MethodInfo;

Searches for the specified public method whose parameters match the specified argument types and modifiers.

[Visual Basic] Overloads Public Function GetMethod(String, Type(), ParameterModifier()) As MethodInfo
[C#] public MethodInfo GetMethod(String, Type[], ParameterModifier[]);
[C++] public: MethodInfo* GetMethod(String*, Type[], ParameterModifier[]);
[JScript] public function GetMethod(String, Type[], ParameterModifier[]) : MethodInfo;

Searches for the specified method whose parameters match the specified argument types and modifiers, using the specified binding constraints and the specified calling convention.

[Visual Basic] Overloads Public Function GetMethod(String, BindingFlags, Binder, CallingConventions, Type(), ParameterModifier()) As MethodInfo
[C#] public MethodInfo GetMethod(String, BindingFlags, Binder, CallingConventions, Type[], ParameterModifier[]);
[C++] public: MethodInfo* GetMethod(String*, BindingFlags, Binder, CallingConventions, Type[], ParameterModifier[]);
[JScript] public function GetMethod(String, BindingFlags, Binder, CallingConventions, Type[], ParameterModifier[]) : MethodInfo;

Searches for the public method with the specified name.

[Visual Basic] Overloads Public Function GetMethod(String) As MethodInfo
[C#] public MethodInfo GetMethod(String);
[C++] public: MethodInfo* GetMethod(String*);
[JScript] public function GetMethod(String) : MethodInfo;

See Also

Type Class | Type Members | System Namespace


Type.GetMethod (String, BindingFlags)

Searches for the specified method, using the specified binding constraints.

[Visual Basic]
Overloads Overridable Public Function GetMethod( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags _
) As MethodInfo
[C#]
public virtual MethodInfo GetMethod(
   string name,
   BindingFlags bindingAttr
);
[C++]
public: virtual MethodInfo* GetMethod(
   String* name,
   BindingFlags bindingAttr
);
[JScript]
public function GetMethod(
   name : String,
   bindingAttr : BindingFlags
) : MethodInfo;

Parameters

name
The String containing the name of the method to get.
bindingAttr
A bit mask comprised of one or more BindingFlags that specify how the search is conducted.

-or-

zero, to conduct a case-sensitive search for public methods.

Return Value

A MethodInfo object representing the method that matches the specified requirements, if found; otherwise, a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
AmbiguousMatchException | More than one method is found with the specified name and matching the specified binding constraints.
ArgumentNullException | name is a null reference (Nothing).
SecurityException | The requested method is non-public and the caller does not have ReflectionPermission to reflect non-public members outside the current assembly.

Remarks

The following BindingFlags filter flags can be used to define which methods should be included in the search:

  • Instance to include instance methods in the search.
  • Static to include static methods in the search.
  • Public to include public methods in the search.
  • NonPublic to include non-public methods (that is, private and protected methods) in the search.

The following BindingFlags modifier flags can be used to change how the search works:

  • IgnoreCase to ignore the case of name. If name has 128 or more standard ASCII characters, a case-sensitive search will be performed, regardless of the IgnoreCase flag.
  • DeclaredOnly to search only the methods declared on the Type, not methods that were simply inherited.

See BindingFlags for more information.

See Also

Type Class | Type Members | System Namespace | Type.GetMethod Overload List


Type.GetMethod (String, BindingFlags, Binder, Type[], ParameterModifier[])

Searches for the specified method whose parameters match the specified argument types and modifiers, using the specified binding constraints.

[Visual Basic]
Overloads Overridable Public Function GetMethod( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal types() As Type, _
   ByVal modifiers() As ParameterModifier _
) As MethodInfo
[C#]
public virtual MethodInfo GetMethod(
   string name,
   BindingFlags bindingAttr,
   Binder binder,
   Type[] types,
   ParameterModifier[] modifiers
);
[C++]
public: virtual MethodInfo* GetMethod(
   String* name,
   BindingFlags bindingAttr,
   Binder* binder,
   Type* types[],
   ParameterModifier* modifiers[]
);
[JScript]
public function GetMethod(
   name : String,
   bindingAttr : BindingFlags,
   binder : Binder,
   types : Type[],
   modifiers : ParameterModifier[]
) : MethodInfo;

Parameters

name
The String containing the name of the method to get.
bindingAttr
A bit mask comprised of one or more BindingFlags that specify how the search is conducted.

-or-

zero, to conduct a case-sensitive search for public methods.

binder
A Binder object that defines a set of properties and enables binding, which may involve selection of an overloaded method, coercion of argument types, and invocation of a member through reflection.

-or-

a null reference (in Visual Basic Nothing), to use the DefaultBinder.

types
An array of Type objects representing the number, order, and type of the parameters for the method to get.

-or-

An empty array of the type Type (that is, Type[] types = new Type[0]) to get a method that takes no parameters.

modifiers
An array of ParameterModifier objects representing the attributes associated with the corresponding element in the types array.

Return Value

A MethodInfo object representing the method that matches the specified requirements, if found; otherwise, a null reference (Nothing).

Exceptions

Exception Type | Condition
AmbiguousMatchException | More than one method is found with the specified name and matching the specified binding constraints.
ArgumentNullException | name is a null reference (Nothing). -or- types is a null reference (Nothing). -or- One of the elements in types is a null reference (Nothing).
SecurityException | The requested method is non-public and the caller does not have ReflectionPermission to reflect non-public members outside the current assembly.
ArgumentException | types is multidimensional. -or- modifiers is multidimensional. -or- types and modifiers do not have the same length. (?)

Remarks

The types array and the modifiers array have the same length. A parameter specified in the types array can have the following attributes, which are specified in the modifiers array: pdIn, pdOut, pdLcid, pdRetval, pdOptional, and pdHasDefault, which represent [in], [out], [lcid], [retval], [optional], and a value specifying whether the parameter has a default value. A parameter's associated attributes are stored in the metadata and are used for interoperability.

The following BindingFlags filter flags can be used to define which methods should be included in the search:

  • Instance to include instance methods in the search.
  • Static to include static methods in the search.
  • Public to include public methods in the search.
  • NonPublic to include non-public methods (that is, private and protected methods) in the search.

The following BindingFlags modifier flags can be used to change how the search works:

  • IgnoreCase to ignore the case of name. If name has 128 or more standard ASCII characters, a case-sensitive search will be performed, regardless of the IgnoreCase flag.
  • DeclaredOnly to search only the methods declared on the Type, not methods that were simply inherited.

See BindingFlags for more information.

See Also

Type Class | Type Members | System Namespace | Type.GetMethod Overload List | DefaultBinder


Type.GetMethod (String, Type[])

Searches for the specified public method whose parameters match the specified argument types.

[Visual Basic]
Overloads Public Function GetMethod( _
   ByVal name As String, _
   ByVal types() As Type _
) As MethodInfo
[C#]
public MethodInfo GetMethod(
   string name,
   Type[] types
);
[C++]
public: MethodInfo* GetMethod(
   String* name,
   Type* types[]
);
[JScript]
public function GetMethod(
   name : String,
   types : Type[]
) : MethodInfo;

Parameters

name
The String containing the name of the public method to get.
types
An array of Type objects representing the number, order, and type of the parameters for the method to get.

-or-

An empty array of the type Type (that is, Type[] types = new Type[0]) to get a method that takes no parameters.

Return Value

A MethodInfo object representing the public method whose parameters match the specified argument types, if found; otherwise, a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
AmbiguousMatchException | More than one method is found with the specified name and specified parameters.
ArgumentNullException | name is a null reference (Nothing). -or- types is a null reference (Nothing). -or- One of the elements in types is a null reference (Nothing).
SecurityException | The requested method is non-public and the caller does not have ReflectionPermission to reflect non-public members outside the current assembly.
ArgumentException | types is multidimensional. -or- modifiers is multidimensional. -or- types and modifiers do not have the same length. (?)

Remarks

The search for name is case-sensitive.

See Also

Type Class | Type Members | System Namespace | Type.GetMethod Overload List


Type.GetMethod (String, Type[], ParameterModifier[])

Searches for the specified public method whose parameters match the specified argument types and modifiers.

[Visual Basic]
Overloads Public Function GetMethod( _
   ByVal name As String, _
   ByVal types() As Type, _
   ByVal modifiers() As ParameterModifier _
) As MethodInfo
[C#]
public MethodInfo GetMethod(
   string name,
   Type[] types,
   ParameterModifier[] modifiers
);
[C++]
public: MethodInfo* GetMethod(
   String* name,
   Type* types[],
   ParameterModifier* modifiers[]
);
[JScript]
public function GetMethod(
   name : String,
   types : Type[],
   modifiers : ParameterModifier[]
) : MethodInfo;

Parameters

name
The String containing the name of the public method to get.
types
An array of Type objects representing the number, order, and type of the parameters for the method to get.

-or-

An empty array of the type Type (that is, Type[] types = new Type[0]) to get a method that takes no parameters.

modifiers
An array of ParameterModifier objects representing the attributes associated with the corresponding element in the types array.

Return Value

A MethodInfo object representing the public method that matches the specified requirements, if found; otherwise, a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
AmbiguousMatchException | More than one method is found with the specified name and specified parameters.
ArgumentNullException | name is a null reference (Nothing). -or- types is a null reference (Nothing). -or- One of the elements in types is a null reference (Nothing).
SecurityException | The requested method is non-public and the caller does not have ReflectionPermission to reflect non-public members outside the current assembly.
ArgumentException | types is multidimensional. -or- modifiers is multidimensional. -or- types and modifiers do not have the same length. (?)

Remarks

The types array and the modifiers array have the same length. A parameter specified in the types array can have the following attributes, which are specified in the modifiers array: pdIn, pdOut, pdLcid, pdRetval, pdOptional, and pdHasDefault, which represent [in], [out], [lcid], [retval], [optional], and a value specifying whether the parameter has a default value. A parameter's associated attributes are stored in the metadata and are used for interoperability.

The search for name is case-sensitive.

See Also

Type Class | Type Members | System Namespace | Type.GetMethod Overload List


Type.GetMethod (String, BindingFlags, Binder, CallingConventions, Type[], ParameterModifier[])

Searches for the specified method whose parameters match the specified argument types and modifiers, using the specified binding constraints and the specified calling convention.

[Visual Basic]
Overloads Public Function GetMethod( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal callConvention As CallingConventions, _
   ByVal types() As Type, _
   ByVal modifiers() As ParameterModifier _
) As MethodInfo
[C#]
public MethodInfo GetMethod(
   string name,
   BindingFlags bindingAttr,
   Binder binder,
   CallingConventions callConvention,
   Type[] types,
   ParameterModifier[] modifiers
);
[C++]
public: MethodInfo* GetMethod(
   String* name,
   BindingFlags bindingAttr,
   Binder* binder,
   CallingConventions callConvention,
   Type* types[],
   ParameterModifier* modifiers[]
);
[JScript]
public function GetMethod(
   name : String,
   bindingAttr : BindingFlags,
   binder : Binder,
   callConvention : CallingConventions,
   types : Type[],
   modifiers : ParameterModifier[]
) : MethodInfo;

Parameters

name
The String containing the name of the method to get.
bindingAttr
A bit mask comprised of one or more BindingFlags that specify how the search is conducted.

-or-

zero, to conduct a case-sensitive search for public methods.

binder
A Binder object that defines a set of properties and enables binding, which may involve selection of an overloaded method, coercion of argument types, and invocation of a member through reflection.

-or-

a null reference (in Visual Basic Nothing), to use the DefaultBinder.

callConvention
The CallingConventions object that specifies the set of rules to use regarding the order and layout of arguments, how the return value is passed, what registers are used for arguments and who cleans up the stack.
types
An array of Type objects representing the number, order, and type of the parameters for the method to get.

-or-

An empty array of the type Type (that is, Type[] types = new Type[0]) to get a method that takes no parameters.

modifiers
An array of ParameterModifier objects representing the attributes associated with the corresponding element in the types array.

Return Value

A MethodInfo object representing the method that matches the specified requirements, if found; otherwise, a null reference (Nothing).

Exceptions

Exception Type | Condition
AmbiguousMatchException | More than one method is found with the specified name and matching the specified binding constraints.
ArgumentNullException | name is a null reference (Nothing). -or- types is a null reference (Nothing). -or- One of the elements in types is a null reference (Nothing).
SecurityException | The requested method is non-public and the caller does not have ReflectionPermission to reflect non-public members outside the current assembly.
ArgumentException | types is multidimensional. -or- modifiers is multidimensional. -or- types and modifiers do not have the same length. (?)

Remarks

The types array and the modifiers array have the same length. A parameter specified in the types array can have the following attributes, which are specified in the modifiers array: pdIn, pdOut, pdLcid, pdRetval, pdOptional, and pdHasDefault, which represent [in], [out], [lcid], [retval], [optional], and a value specifying whether the parameter has a default value. A parameter's associated attributes are stored in the metadata and are used for interoperability.

The following BindingFlags filter flags can be used to define which methods should be included in the search:

  • Instance to include instance methods in the search.
  • Static to include static methods in the search.
  • Public to include public methods in the search.
  • NonPublic to include non-public methods (that is, private and protected methods) in the search.

The following BindingFlags modifier flags can be used to change how the search works:

  • IgnoreCase to ignore the case of name. If name has 128 or more standard ASCII characters, a case-sensitive search will be performed, regardless of the IgnoreCase flag.
  • DeclaredOnly to search only the methods declared on the Type, not methods that were simply inherited.

See BindingFlags for more information.

See Also

Type Class | Type Members | System Namespace | Type.GetMethod Overload List | DefaultBinder


Type.GetMethod (String)

Searches for the public method with the specified name.

[Visual Basic]
Overloads Public Function GetMethod( _
   ByVal name As String _
) As MethodInfo
[C#]
public MethodInfo GetMethod(
   string name
);
[C++]
public: MethodInfo* GetMethod(
   String* name
);
[JScript]
public function GetMethod(
   name : String
) : MethodInfo;

Parameters

name
The String containing the name of the public method to get.

Return Value

A MethodInfo object representing the public method with the specified name, if found; otherwise, a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
AmbiguousMatchException | More than one method is found with the specified name.
ArgumentNullException | name is a null reference (Nothing).
SecurityException | The requested method is non-public and the caller does not have ReflectionPermission to reflect non-public members outside the current assembly.

Remarks

The search for name is case-sensitive.

See Also

Type Class | Type Members | System Namespace | Type.GetMethod Overload List


Type.GetMethodImpl

Searches for the specified method whose parameters match the specified argument types and modifiers, using the specified binding constraints and the specified calling convention.

[Visual Basic]
MustOverride Protected Function GetMethodImpl( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal callConvention As CallingConventions, _
   ByVal types() As Type, _
   ByVal modifiers() As ParameterModifier _
) As MethodInfo
[C#]
protected abstract MethodInfo GetMethodImpl(
   string name,
   BindingFlags bindingAttr,
   Binder binder,
   CallingConventions callConvention,
   Type[] types,
   ParameterModifier[] modifiers
);
[C++]
protected: virtual MethodInfo* GetMethodImpl(
   String* name,
   BindingFlags bindingAttr,
   Binder* binder,
   CallingConventions callConvention,
   Type* types[],
   ParameterModifier* modifiers[]
) = 0;
[JScript]
protected abstract function GetMethodImpl(
   name : String,
   bindingAttr : BindingFlags,
   binder : Binder,
   callConvention : CallingConventions,
   types : Type[],
   modifiers : ParameterModifier[]
) : MethodInfo;

Parameters

name
The String containing the name of the method to get.
bindingAttr
A bit mask comprised of one or more BindingFlags that specify how the search is conducted.

-or-

zero, to conduct a case-sensitive search for public methods.

binder
A Binder object that defines a set of properties and enables binding, which may involve selection of an overloaded method, coercion of argument types, and invocation of a member through reflection.

-or-

a null reference (in Visual Basic Nothing), to use the DefaultBinder.

callConvention
The CallingConventions object that specifies the set of rules to use regarding the order and layout of arguments, how the return value is passed, what registers are used for arguments and who cleans up the stack.
types
An array of Type objects representing the number, order, and type of the parameters for the method to get.

-or-

An empty array of the type Type (that is, Type[] types = new Type[0]) to get a method that takes no parameters.

modifiers
An array of ParameterModifier objects representing the attributes associated with the corresponding element in the types array.

Return Value

A MethodInfo object representing the method that matches the specified requirements, if found; otherwise, a null reference (Nothing).

Exceptions

Exception Type | Condition
AmbiguousMatchException | More than one method is found with the specified name and matching the specified binding constraints.
ArgumentNullException | name is a null reference (Nothing). -or- types is a null reference (Nothing). -or- One of the elements in types is a null reference (Nothing).
SecurityException | The requested method is non-public and the caller does not have ReflectionPermission to reflect non-public members outside the current assembly.
ArgumentException | types is multidimensional. -or- modifiers is multidimensional. -or- types and modifiers do not have the same length. (?)

Remarks

Abstract. This method must be implemented by a derived class.

The types array and the modifiers array have the same length. A parameter specified in the types array can have the following attributes, which are specified in the modifiers array: pdIn, pdOut, pdLcid, pdRetval, pdOptional, and pdHasDefault, which represent [in], [out], [lcid], [retval], [optional], and a value specifying whether the parameter has a default value. A parameter's associated attributes are stored in the metadata and are used for interoperability.

The following BindingFlags filter flags can be used to define which methods should be included in the search:

  • Instance to include instance methods in the search.
  • Static to include static methods in the search.
  • Public to include public methods in the search.
  • NonPublic to include non-public methods (that is, private and protected methods) in the search.

The following BindingFlags modifier flags can be used to change how the search works:

  • IgnoreCase to ignore the case of name. If name has 128 or more standard ASCII characters, a case-sensitive search will be performed, regardless of the IgnoreCase flag.
  • DeclaredOnly to search only the methods declared on the Type, not methods that were simply inherited.

See BindingFlags for more information.

See Also

Type Class | Type Members | System Namespace


Type.GetMethods

Gets the methods of the current Type.

Overload List

Returns all the public methods of the current Type.

[Visual Basic] Overloads Public Function GetMethods() As MethodInfo ()
[C#] public MethodInfo[] GetMethods();
[C++] public: MethodInfo* GetMethods() [];
[JScript] public function GetMethods() : MethodInfo[];

When implemented by a derived class, searches for the methods defined for the current Type, using the specified binding constraints.

[Visual Basic] Overloads MustOverride Public Function GetMethods(BindingFlags) As MethodInfo ()
[C#] public abstract MethodInfo[] GetMethods(BindingFlags);
[C++] public: virtual MethodInfo* GetMethods(BindingFlags) [] = 0;
[JScript] public abstract function GetMethods(BindingFlags) : MethodInfo[];

See Also

Type Class | Type Members | System Namespace


Type.GetMethods ()

Returns all the public methods of the current Type.

[Visual Basic]
Overloads Public Function GetMethods() As MethodInfo ()
[C#]
public MethodInfo[] GetMethods();
[C++]
public: MethodInfo* GetMethods() [];
[JScript]
public function GetMethods() : MethodInfo[];

Return Value

An array of MethodInfo objects representing all the public methods defined for the current Type.

-or-

An empty array of type MethodInfo, if no public methods are defined for the current Type.

See Also

Type Class | Type Members | System Namespace | Type.GetMethods Overload List


Type.GetMethods (BindingFlags)

When implemented by a derived class, searches for the methods defined for the current Type, using the specified binding constraints.

[Visual Basic]
Overloads MustOverride Public Function GetMethods( _
   ByVal bindingAttr As BindingFlags _
) As MethodInfo ()
[C#]
public abstract MethodInfo[] GetMethods(
   BindingFlags bindingAttr
);
[C++]
public: virtual MethodInfo* GetMethods(
   BindingFlags bindingAttr
) [] = 0;
[JScript]
public abstract function GetMethods(
   bindingAttr : BindingFlags
) : MethodInfo[];

Parameters

bindingAttr
A bit mask comprised of one or more BindingFlags that specify how the search is conducted.

-or-

zero, to conduct a case-sensitive search for public methods.

Return Value

An array of MethodInfo objects representing all methods defined for the current Type that match the specified binding constraints.

-or-

An empty array of type MethodInfo, if no methods are defined for the current Type, or if none of the defined methods match the binding constraints.

Exceptions

Exception Type | Condition
SecurityException | The BindingFlags value Public is used but the caller does not have ReflectionPermission to reflect non-public members outside the current assembly.

Remarks

Abstract. This method must be implemented by a derived class.

The following BindingFlags filter flags can be used to define which methods should be included in the search:

  • Instance to include instance methods in the search.
  • Static to include static methods in the search.
  • Public to include public methods in the search.
  • NonPublic to include non-public methods (that is, private and protected methods) in the search.

The following BindingFlags modifier flags can be used to change how the search works:

  • DeclaredOnly to search only the methods declared on the Type, not methods that were simply inherited.

See BindingFlags for more information.

See Also

Type Class | Type Members | System Namespace | Type.GetMethods Overload List


Type.GetNestedType

Gets a specific type nested within the current Type.

Overload List

Searches for the nested type with the specified name.

[Visual Basic] Overloads Public Function GetNestedType(String) As Type
[C#] public Type GetNestedType(String);
[C++] public: Type* GetNestedType(String*);
[JScript] public function GetNestedType(String) : Type;

When implemented by a derived class, searches for the specified nested type, using the specified binding constraints.

[Visual Basic] Overloads MustOverride Public Function GetNestedType(String, BindingFlags) As Type
[C#] public abstract Type GetNestedType(String, BindingFlags);
[C++] public: virtual Type* GetNestedType(String*, BindingFlags) = 0;
[JScript] public abstract function GetNestedType(String, BindingFlags) : Type;

See Also

Type Class | Type Members | System Namespace


Type.GetNestedType (String)

Searches for the nested type with the specified name.

[Visual Basic]
Overloads Public Function GetNestedType( _
   ByVal name As String _
) As Type
[C#]
public Type GetNestedType(
   string name
);
[C++]
public: Type* GetNestedType(
   String* name
);
[JScript]
public function GetNestedType(
   name : String
) : Type;

Parameters

name
The String containing the name of the nested type to get.

Return Value

A Type object representing the nested type with the specified name, if found; otherwise, a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
ArgumentNullException | name is a null reference (Nothing).

Remarks

The search for name is case-sensitive.

See Also

Type Class | Type Members | System Namespace | Type.GetNestedType Overload List


Type.GetNestedType (String, BindingFlags)

When implemented by a derived class, searches for the specified nested type, using the specified binding constraints.

[Visual Basic]
Overloads MustOverride Public Function GetNestedType( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags _
) As Type
[C#]
public abstract Type GetNestedType(
   string name,
   BindingFlags bindingAttr
);
[C++]
public: virtual Type* GetNestedType(
   String* name,
   BindingFlags bindingAttr
) = 0;
[JScript]
public abstract function GetNestedType(
   name : String,
   bindingAttr : BindingFlags
) : Type;

Parameters

name
The String containing the name of the nested type to get.
bindingAttr
A bit mask comprised of one or more BindingFlags that specify how the search is conducted.

-or-

zero, to conduct a case-sensitive search for public methods.

Return Value

A Type object representing the nested type that matches the specified requirements, if found; otherwise, a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
ArgumentNullException | name is a null reference (Nothing).

Remarks

Abstract. This method must be implemented by a derived class.

The following BindingFlags filter flags can be used to define which nested types should be included in the search:

  • Public to include public nested types in the search.
  • NonPublic to include non-public nested types (that is, private and protected nested types) in the search.

The following BindingFlags modifier flags can be used to change how the search works:

  • IgnoreCase to ignore the case of name. If name has 128 or more standard ASCII characters, a case-sensitive search will be performed, regardless of the IgnoreCase flag.
  • DeclaredOnly to search only the nested types declared on the Type, not nested types that were simply inherited.

See BindingFlags for more information.

See Also

Type Class | Type Members | System Namespace | Type.GetNestedType Overload List


Type.GetNestedTypes

Gets the types nested within the current Type.

Overload List

When implemented by a derived class, searches for the types nested within the current Type, using the specified binding constraints.

[Visual Basic] Overloads MustOverride Public Function GetNestedTypes(BindingFlags) As Type ()
[C#] public abstract Type[] GetNestedTypes(BindingFlags);
[C++] public: virtual Type* GetNestedTypes(BindingFlags) [] = 0;
[JScript] public abstract function GetNestedTypes(BindingFlags) : Type[];

Returns all the types nested within the current Type.

[Visual Basic] Overloads Public Function GetNestedTypes() As Type ()
[C#] public Type[] GetNestedTypes();
[C++] public: Type* GetNestedTypes() [];
[JScript] public function GetNestedTypes() : Type[];

See Also

Type Class | Type Members | System Namespace


Type.GetNestedTypes (BindingFlags)

When implemented by a derived class, searches for the types nested within the current Type, using the specified binding constraints.

[Visual Basic]
Overloads MustOverride Public Function GetNestedTypes( _
   ByVal bindingAttr As BindingFlags _
) As Type ()
[C#]
public abstract Type[] GetNestedTypes(
   BindingFlags bindingAttr
);
[C++]
public: virtual Type* GetNestedTypes(
   BindingFlags bindingAttr
) [] = 0;
[JScript]
public abstract function GetNestedTypes(
   bindingAttr : BindingFlags
) : Type[];

Parameters

bindingAttr
A bit mask comprised of one or more BindingFlags that specify how the search is conducted.

-or-

zero, to conduct a case-sensitive search for public methods.

Return Value

An array of Type objects representing all the types nested within the current Type that match the specified binding constraints.

-or-

An empty array of type Type, if no types are nested within the current Type, or if none of the nested types match the binding constraints.

Remarks

Abstract. This method must be implemented by a derived class.

The following BindingFlags filter flags can be used to define which nested types should be included in the search:

  • Public to include public nested types in the search.
  • NonPublic to include non-public nested types (that is, private and protected nested types) in the search.

The following BindingFlags modifier flags can be used to change how the search works:

  • DeclaredOnly to search only the nested types declared on the Type, not nested types that were simply inherited.

Calling this method with only the Public flag or only the NonPublic flag will return the specified nested types and does not require any other flags.

See BindingFlags for more information.

See Also

Type Class | Type Members | System Namespace | Type.GetNestedTypes Overload List


Type.GetNestedTypes ()

Returns all the types nested within the current Type.

[Visual Basic]
Overloads Public Function GetNestedTypes() As Type ()
[C#]
public Type[] GetNestedTypes();
[C++]
public: Type* GetNestedTypes() [];
[JScript]
public function GetNestedTypes() : Type[];

Return Value

An array of Type objects representing all the types nested within the current Type.

-or-An empty array of type Type, if no types are nested within the current Type.

See Also

Type Class | Type Members | System Namespace | Type.GetNestedTypes Overload List


Type.GetProperties

Gets the properties of the current Type.

Overload List

Returns all the public properties of the current Type.

[Visual Basic] Overloads Public Function GetProperties() As PropertyInfo ()
[C#] public PropertyInfo[] GetProperties();
[C++] public: PropertyInfo* GetProperties() [];
[JScript] public function GetProperties() : PropertyInfo[];

When implemented by a derived class, searches for the properties of the current Type, using the specified binding constraints.

[Visual Basic] Overloads MustOverride Public Function GetProperties(BindingFlags) As PropertyInfo ()
[C#] public abstract PropertyInfo[] GetProperties(BindingFlags);
[C++] public: virtual PropertyInfo* GetProperties(BindingFlags) [] = 0;
[JScript] public abstract function GetProperties(BindingFlags) : PropertyInfo[];

See Also

Type Class | Type Members | System Namespace


Type.GetProperties ()

Returns all the public properties of the current Type.

[Visual Basic]
Overloads Public Function GetProperties() As PropertyInfo ()
[C#]
public PropertyInfo[] GetProperties();
[C++]
public: PropertyInfo* GetProperties() [];
[JScript]
public function GetProperties() : PropertyInfo[];

Return Value

An array of PropertyInfo objects representing all public properties of the current Type.

-or-An empty array of type PropertyInfo, if the current Type does not have public properties.

See Also

Type Class | Type Members | System Namespace | Type.GetProperties Overload List


Type.GetProperties (BindingFlags)

When implemented by a derived class, searches for the properties of the current Type, using the specified binding constraints.

[Visual Basic]
Overloads MustOverride Public Function GetProperties( _
   ByVal bindingAttr As BindingFlags _
) As PropertyInfo ()
[C#]
public abstract PropertyInfo[] GetProperties(
   BindingFlags bindingAttr
);
[C++]
public: virtual PropertyInfo* GetProperties(
   BindingFlags bindingAttr
) [] = 0;
[JScript]
public abstract function GetProperties(
   bindingAttr : BindingFlags
) : PropertyInfo[];

Parameters

bindingAttr
A bit mask comprised of one or more BindingFlags that specify how the search is conducted.

-or-

zero, to conduct a case-sensitive search for public properties.

Return Value

An array of PropertyInfo objects representing all properties of the current Type that match the specified binding constraints.

-or-

An empty array of type PropertyInfo, if the current Type does not have properties, or if none of the properties match the binding constraints.

Remarks

Abstract. This method must be implemented by a derived class.

The following BindingFlags filter flags can be used to define which properties should be included in the search:

  • Instance to include instance properties in the search.
  • Static to include static properties in the search.
  • Public to include public properties in the search.
  • NonPublic to include non-public properties (that is, private and protected properties) in the search.

The following BindingFlags modifier flags can be used to change how the search works:

  • DeclaredOnly to search only the properties declared on the Type, not properties that were simply inherited.

See BindingFlags for more information.

See Also

Type Class | Type Members | System Namespace | Type.GetProperties Overload List


Type.GetProperty

Gets a specific property of the current Type.

Overload List

Searches for the specified public property whose parameters match the specified argument types and modifiers.

[Visual Basic] Overloads Public Function GetProperty(String, Type(), ParameterModifier()) As PropertyInfo
[C#] public PropertyInfo GetProperty(String, Type[], ParameterModifier[]);
[C++] public: PropertyInfo* GetProperty(String*, Type[], ParameterModifier[]);
[JScript] public function GetProperty(String, Type[], ParameterModifier[]) : PropertyInfo;

Searches for the specified public property whose parameters match the specified argument types.

[Visual Basic] Overloads Public Function GetProperty(String, Type()) As PropertyInfo
[C#] public PropertyInfo GetProperty(String, Type[]);
[C++] public: PropertyInfo* GetProperty(String*, Type[]);
[JScript] public function GetProperty(String, Type[]) : PropertyInfo;

Searches for the specified property whose parameters match the specified argument types and modifiers, using the specified binding constraints.

[Visual Basic] Overloads Overridable Public Function GetProperty(String, BindingFlags, Binder, Type(), ParameterModifier()) As PropertyInfo
[C#] public virtual PropertyInfo GetProperty(String, BindingFlags, Binder, Type[], ParameterModifier[]);
[C++] public: virtual PropertyInfo* GetProperty(String*, BindingFlags, Binder, Type[], ParameterModifier[]);
[JScript] public function GetProperty(String, BindingFlags, Binder, Type[], ParameterModifier[]) : PropertyInfo;

Searches for the public property with the specified name.

[Visual Basic] Overloads Public Function GetProperty(String) As PropertyInfo
[C#] public PropertyInfo GetProperty(String);
[C++] public: PropertyInfo* GetProperty(String*);
[JScript] public function GetProperty(String) : PropertyInfo;

Searches for the specified property, using the specified binding constraints.

[Visual Basic] Overloads Overridable Public Function GetProperty(String, BindingFlags) As PropertyInfo
[C#] public virtual PropertyInfo GetProperty(String, BindingFlags);
[C++] public: virtual PropertyInfo* GetProperty(String*, BindingFlags);
[JScript] public function GetProperty(String, BindingFlags) : PropertyInfo;

See Also

Type Class | Type Members | System Namespace


Type.GetProperty (String, Type[], ParameterModifier[])

Searches for the specified public property whose parameters match the specified argument types and modifiers.

[Visual Basic]
Overloads Public Function GetProperty( _
   ByVal name As String, _
   ByVal types() As Type, _
   ByVal modifiers() As ParameterModifier _
) As PropertyInfo
[C#]
public PropertyInfo GetProperty(
   string name,
   Type[] types,
   ParameterModifier[] modifiers
);
[C++]
public: PropertyInfo* GetProperty(
   String* name,
   Type* types[],
   ParameterModifier* modifiers[]
);
[JScript]
public function GetProperty(
   name : String,
   types : Type[],
   modifiers : ParameterModifier[]
) : PropertyInfo;

Parameters

name
The String containing the name of the public property to get.
types
An array of Type objects representing the number, order, and type of the parameters for the indexed property to get.

-or-

An empty array of the type Type (that is, Type[] types = new Type[0]) to get a property that is not indexed.

modifiers
An array of ParameterModifier objects representing the attributes associated with the corresponding element in the types array.

Return Value

A PropertyInfo object representing the public property that matches the specified requirements, if found; otherwise, a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
AmbiguousMatchException | More than one property is found with the specified name and matching the specified argument types and modifiers.
ArgumentNullException | name is a null reference (Nothing). -or- types is a null reference (Nothing). -or- One of the elements in types is a null reference (Nothing).
SecurityException | The requested property is non-public and the caller does not have ReflectionPermission to reflect non-public members outside the current assembly.
ArgumentException | types is multidimensional. -or- modifiers is multidimensional. -or- types and modifiers do not have the same length. (?)

Remarks

The types array and the modifiers array have the same length. A parameter specified in the types array can have the following attributes, which are specified in the modifiers array: pdIn, pdOut, pdLcid, pdRetval, pdOptional, and pdHasDefault, which represent [in], [out], [lcid], [retval], [optional], and a value specifying whether the parameter has a default value. A parameter's associated attributes are stored in the metadata and are used for interoperability.The search for name is case-sensitive.

See Also

Type Class | Type Members | System Namespace | Type.GetProperty Overload List


Type.GetProperty (String, Type[])

Searches for the specified public property whose parameters match the specified argument types.

[Visual Basic]
Overloads Public Function GetProperty( _
   ByVal name As String, _
   ByVal types() As Type _
) As PropertyInfo
[C#]
public PropertyInfo GetProperty(
   string name,
   Type[] types
);
[C++]
public: PropertyInfo* GetProperty(
   String* name,
   Type* types[]
);
[JScript]
public function GetProperty(
   name : String,
   types : Type[]
) : PropertyInfo;

Parameters

name
The String containing the name of the public property to get.
types
An array of Type objects representing the number, order, and type of the parameters for the indexed property to get.

-or-

An empty array of the type Type (that is, Type[] types = new Type[0]) to get a property that is not indexed.

Return Value

A PropertyInfo object representing the public property whose parameters match the specified argument types, if found; otherwise, a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
AmbiguousMatchException | More than one property is found with the specified name and matching the specified argument types.
ArgumentNullException | name is a null reference (Nothing). -or- types is a null reference (Nothing). -or- One of the elements in types is a null reference (Nothing).
SecurityException | The requested property is non-public and the caller does not have ReflectionPermission to reflect non-public members outside the current assembly.
ArgumentException | types is multidimensional. (?)

Remarks

The search for name is case-sensitive.

See Also

Type Class | Type Members | System Namespace | Type.GetProperty Overload List


Type.GetProperty (String, BindingFlags, Binder, Type[], ParameterModifier[])

Searches for the specified property whose parameters match the specified argument types and modifiers, using the specified binding constraints.

[Visual Basic]
Overloads Overridable Public Function GetProperty( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal types() As Type, _
   ByVal modifiers() As ParameterModifier _
) As PropertyInfo
[C#]
public virtual PropertyInfo GetProperty(
   string name,
   BindingFlags bindingAttr,
   Binder binder,
   Type[] types,
   ParameterModifier[] modifiers
);
[C++]
public: virtual PropertyInfo* GetProperty(
   String* name,
   BindingFlags bindingAttr,
   Binder* binder,
   Type* types[],
   ParameterModifier* modifiers[]
);
[JScript]
public function GetProperty(
   name : String,
   bindingAttr : BindingFlags,
   binder : Binder,
   types : Type[],
   modifiers : ParameterModifier[]
) : PropertyInfo;

Parameters

name
The String containing the name of the property to get.
bindingAttr
A bit mask comprised of one or more BindingFlags that specify how the search is conducted.

-or-

zero, to conduct a case-sensitive search for public properties.

binder
A Binder object that defines a set of properties and enables binding, which may involve selection of an overloaded method, coercion of argument types, and invocation of a member through reflection.

-or-

a null reference (in Visual Basic Nothing), to use the DefaultBinder.

types
An array of Type objects representing the number, order, and type of the parameters for the indexed property to get.

-or-

An empty array of the type Type (that is, Type[] types = new Type[0]) to get a property that is not indexed.

modifiers
An array of ParameterModifier objects representing the attributes associated with the corresponding element in the types array.

Return Value

A PropertyInfo object representing the property that matches the specified requirements, if found; otherwise, a null reference (Nothing).

Exceptions

Exception Type | Condition
AmbiguousMatchException | More than one property is found with the specified name and matching the specified binding constraints.
ArgumentNullException | name is a null reference (Nothing). -or- types is a null reference (Nothing). -or- One of the elements in types is a null reference (Nothing).
SecurityException | The requested property is non-public and the caller does not have ReflectionPermission to reflect non-public members outside the current assembly.
ArgumentException | types is multidimensional. -or- modifiers is multidimensional. -or- types and modifiers do not have the same length. (?)

Remarks

The types array and the modifiers array have the same length. A parameter specified in the types array can have the following attributes, which are specified in the modifiers array: pdIn, pdOut, pdLcid, pdRetval, pdOptional, and pdHasDefault, which represent [in], [out], [lcid], [retval], [optional], and a value specifying whether the parameter has a default value. A parameter's associated attributes are stored in the metadata and are used for interoperability.

The following BindingFlags filter flags can be used to define which properties should be included in the search:

  • Instance to include instance properties in the search.
  • Static to include static properties in the search.
  • Public to include public properties in the search.
  • NonPublic to include non-public properties (that is, private and protected properties) in the search.

The following BindingFlags modifier flags can be used to change how the search works:

  • IgnoreCase to ignore the case of name. If name has 128 or more standard ASCII characters, a case-sensitive search will be performed, regardless of the IgnoreCase flag.
  • DeclaredOnly to search only the properties declared on the Type, not properties that were simply inherited.

See BindingFlags for more information.

See Also

Type Class | Type Members | System Namespace | Type.GetProperty Overload List


Type.GetProperty (String)

Searches for the public property with the specified name.

[Visual Basic]
Overloads Public Function GetProperty( _
   ByVal name As String _
) As PropertyInfo
[C#]
public PropertyInfo GetProperty(
   string name
);
[C++]
public: PropertyInfo* GetProperty(
   String* name
);
[JScript]
public function GetProperty(
   name : String
) : PropertyInfo;

Parameters

name
The String containing the name of the public property to get.

Return Value

A PropertyInfo object representing the public property with the specified name, if found; otherwise, a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
AmbiguousMatchException | More than one property is found with the specified name.
ArgumentNullException | name is a null reference (Nothing).
SecurityException | The requested property is non-public and the caller does not have ReflectionPermission to reflect non-public members outside the current assembly.

Remarks

The search for name is case-sensitive.

See Also

Type Class | Type Members | System Namespace | Type.GetProperty Overload List


Type.GetProperty (String, BindingFlags)

Searches for the specified property, using the specified binding constraints.

[Visual Basic]
Overloads Overridable Public Function GetProperty( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags _
) As PropertyInfo
[C#]
public virtual PropertyInfo GetProperty(
   string name,
   BindingFlags bindingAttr
);
[C++]
public: virtual PropertyInfo* GetProperty(
   String* name,
   BindingFlags bindingAttr
);
[JScript]
public function GetProperty(
   name : String,
   bindingAttr : BindingFlags
) : PropertyInfo;

Parameters

name
The String containing the name of the property to get.
bindingAttr
A bit mask comprised of one or more BindingFlags that specify how the search is conducted.

-or-

zero, to conduct a case-sensitive search for public properties.

Return Value

A PropertyInfo object representing the property that matches the specified requirements, if found; otherwise, a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
AmbiguousMatchException | More than one property is found with the specified name and matching the specified binding constraints.
ArgumentNullException | name is a null reference (Nothing).
SecurityException | The requested property is non-public and the caller does not have ReflectionPermission to reflect non-public members outside the current assembly.

Remarks

The types array and the modifiers array have the same length. A parameter specified in the types array can have the following attributes, which are specified in the modifiers array: pdIn, pdOut, pdLcid, pdRetval, pdOptional, and pdHasDefault, which represent [in], [out], [lcid], [retval], [optional], and a value specifying whether the parameter has a default value. A parameter's associated attributes are stored in the metadata and are used for interoperability.

The following BindingFlags filter flags can be used to define which properties should be included in the search:

  • Instance to include instance properties in the search.
  • Static to include static properties in the search.
  • Public to include public properties in the search.
  • NonPublic to include non-public properties (that is, private and protected properties) in the search.

The following BindingFlags modifier flags can be used to change how the search works:

  • IgnoreCase to ignore the case of name. If name has 128 or more standard ASCII characters, a case-sensitive search will be performed, regardless of the IgnoreCase flag.
  • DeclaredOnly to search only the properties declared on the Type, not properties that were simply inherited.

See BindingFlags for more information.

See Also

Type Class | Type Members | System Namespace | Type.GetProperty Overload List


Type.GetPropertyImpl

When implemented by a derived class, searches for the specified property whose parameters match the specified argument types and modifiers, using the specified binding constraints.

[Visual Basic]
MustOverride Protected Function GetPropertyImpl( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal types() As Type, _
   ByVal modifiers() As ParameterModifier _
) As PropertyInfo
[C#]
protected abstract PropertyInfo GetPropertyImpl(
   string name,
   BindingFlags bindingAttr,
   Binder binder,
   Type[] types,
   ParameterModifier[] modifiers
);
[C++]
protected: virtual PropertyInfo* GetPropertyImpl(
   String* name,
   BindingFlags bindingAttr,
   Binder* binder,
   Type* types[],
   ParameterModifier* modifiers[]
) = 0;
[JScript]
protected abstract function GetPropertyImpl(
   name : String,
   bindingAttr : BindingFlags,
   binder : Binder,
   types : Type[],
   modifiers : ParameterModifier[]
) : PropertyInfo;

Parameters

name
The String containing the name of the property to get.
bindingAttr
A bit mask comprised of one or more BindingFlags that specify how the search is conducted.

-or-

zero, to conduct a case-sensitive search for public properties.

binder
A Binder object that defines a set of properties and enables binding, which may involve selection of an overloaded member, coercion of argument types, and invocation of a member through reflection.

-or-

a null reference (in Visual Basic Nothing), to use the DefaultBinder.

types
An array of Type objects representing the number, order, and type of the parameters for the indexed property to get.

-or-

An empty array of the type Type (that is, Type[] types = new Type[0]) to get a property that is not indexed.

modifiers
An array of ParameterModifier objects representing the attributes associated with the corresponding element in the types array.

Return Value

A PropertyInfo object representing the property that matches the specified requirements, if found; otherwise, a null reference (Nothing).

Exceptions

Exception Type | Condition
AmbiguousMatchException | More than one property is found with the specified name and matching the specified binding constraints.
ArgumentNullException | name is a null reference (Nothing). -or- types is a null reference (Nothing). -or- One of the elements in types is a null reference (Nothing).
SecurityException | The requested property is non-public and the caller does not have ReflectionPermission to reflect non-public members outside the current assembly.
ArgumentException | types is multidimensional. -or- modifiers is multidimensional. -or- types and modifiers do not have the same length. (?)

Remarks

Abstract. This method must be implemented by a derived class.

The types array and the modifiers array have the same length. A parameter specified in the types array can have the following attributes, which are specified in the modifiers array: pdIn, pdOut, pdLcid, pdRetval, pdOptional, and pdHasDefault, which represent [in], [out], [lcid], [retval], [optional], and a value specifying whether the parameter has a default value. A parameter's associated attributes are stored in the metadata and are used for interoperability.

The following BindingFlags filter flags can be used to define which properties should be included in the search:

  • Instance to include instance properties in the search.
  • Static to include static properties in the search.
  • Public to include public properties in the search.
  • NonPublic to include non-public properties (that is, private and protected properties) in the search.

The following BindingFlags modifier flags can be used to change how the search works:

  • IgnoreCase to ignore the case of name. If name has 128 or more standard ASCII characters, a case-sensitive search will be performed, regardless of the IgnoreCase flag.
  • DeclaredOnly to search only the properties declared on the Type, not properties that were simply inherited.

See BindingFlags for more information.

See Also

Type Class | Type Members | System Namespace


Type.GetType

Gets the Type with the specified name.

Overload List

Gets the Type with the specified name, performing a case-sensitive search and throwing an exception on error while loading the Type.

[Visual Basic] Overloads Public Shared Function GetType(String) As Type
[C#] public static Type GetType(String);
[C++] public: static Type* GetType(String*);
[JScript] public static function GetType(String) : Type;

Gets the Type with the specified name, performing a case-sensitive search and specifying whether to throw an exception on error while loading the Type.

[Visual Basic] Overloads Public Shared Function GetType(String, Boolean) As Type
[C#] public static Type GetType(String, bool);
[C++] public: static Type* GetType(String*, bool);
[JScript] public static function GetType(String, Boolean) : Type;

Gets the Type with the specified name, specifying whether to perform a case-sensitive search and whether to throw an exception on error while loading the Type.

[Visual Basic] Overloads Public Shared Function GetType(String, Boolean, Boolean) As Type
[C#] public static Type GetType(String, bool, bool);
[C++] public: static Type* GetType(String*, bool, bool);
[JScript] public static function GetType(String, Boolean, Boolean) : Type;

See Also

Type Class | Type Members | System Namespace


Type.GetType (String)

Gets the Type with the specified name, performing a case-sensitive search and throwing an exception on error while loading the Type.

[Visual Basic]
Overloads Public Shared Function GetType( _
   ByVal typeName As String _
) As Type
[C#]
public static Type GetType(
   string typeName
);
[C++]
public: static Type* GetType(
   String* typeName
);
[JScript]
public static function GetType(
   typeName : String
) : Type;

Parameters

typeName
The name of the Type to get.

Return Value

The Type with the specified name, if found; otherwise, a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
ArgumentNullException | typeName is a null reference (Nothing).
SecurityException | The requested Type is non-public and the caller does not have ReflectionPermission to reflect non-public objects outside the current assembly.
TargetInvocationException | A class initializer is invoked and throws an exception.

Remarks

The search for typeName is case-sensitive.

If typeName includes only the name of the Type, this method searches in the calling object's assembly, then in the System assembly. If typeName is fully qualified with the partial or complete assembly name, this method searches in the specified assembly. AssemblyQualifiedName returns a fully qualified type name including the assembly name.

To obtain a Type object for an array, pass the type name followed by an open and close bracket: [].

To obtain a Type object for an n-dimensional array, include the comma character ',' within the brackets a total of n-1 times (for example, "System.Object[,,]" represents a 3-dimensional Object array).

To obtain a Type object for a jagged array, pass the type name followed by two or more bracket pairs (for example, "System.Object[][]" represents a jagged array).If the module containing the class is not loaded, the metadata will be accessed directly without the class being loaded.

See Also

Type Class | Type Members | System Namespace | Type.GetType Overload List | AssemblyQualifiedName | GetAssembly | GetType


Type.GetType (String, Boolean)

Gets the Type with the specified name, performing a case-sensitive search and specifying whether to throw an exception on error while loading the Type.

[Visual Basic]
Overloads Public Shared Function GetType( _
   ByVal typeName As String, _
   ByVal throwOnError As Boolean _
) As Type
[C#]
public static Type GetType(
   string typeName,
   bool throwOnError
);
[C++]
public: static Type* GetType(
   String* typeName,
   bool throwOnError
);
[JScript]
public static function GetType(
   typeName : String,
   throwOnError : Boolean
) : Type;

Parameters

typeName
The name of the Type to get.
throwOnError
true to throw a TypeLoadException on error while loading the Type.

-or-

false to ignore errors while loading the Type.

Return Value

The Type with the specified name, if found; otherwise, a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
ArgumentNullException | typeName is a null reference (Nothing).
SecurityException | The requested Type is non-public and the caller does not have ReflectionPermission to reflect non-public objects outside the current assembly.
TargetInvocationException | A class initializer is invoked and throws an exception.

Remarks

The search for typeName is case-sensitive.

If typeName includes only the name of the Type, this method searches in the calling object's assembly, then in the System assembly. If typeName is fully qualified with the partial or complete assembly name, this method searches in the specified assembly. AssemblyQualifiedName returns a fully qualified type name including the assembly name.

To obtain a Type object for an array, pass the type name followed by an open and close bracket: [].

To obtain a Type object for an n-dimensional array, include the comma character ',' within the brackets a total of n-1 times (for example, "System.Object[,,]" represents a 3-dimensional Object array).

To obtain a Type object for a jagged array, pass the type name followed by two or more bracket pairs (for example, "System.Object[][]" represents a jagged array).If the module containing the class is not loaded, the metadata will be accessed directly without the class being loaded.

See Also

Type Class | Type Members | System Namespace | Type.GetType Overload List | AssemblyQualifiedName | GetAssembly | GetType


Type.GetType (String, Boolean, Boolean)

Gets the Type with the specified name, specifying whether to perform a case-sensitive search and whether to throw an exception on error while loading the Type.

[Visual Basic]
Overloads Public Shared Function GetType( _
   ByVal typeName As String, _
   ByVal throwOnError As Boolean, _
   ByVal ignoreCase As Boolean _
) As Type
[C#]
public static Type GetType(
   string typeName,
   bool throwOnError,
   bool ignoreCase
);
[C++]
public: static Type* GetType(
   String* typeName,
   bool throwOnError,
   bool ignoreCase
);
[JScript]
public static function GetType(
   typeName : String,
   throwOnError : Boolean,
   ignoreCase : Boolean
) : Type;

Parameters

typeName
The name of the Type to get.
throwOnError
true to throw a TypeLoadException on error while loading the Type.

-or-

false to ignore errors while loading the Type.

ignoreCase
true to perform a case-insensitive search for typeName, if typeName has less than 128 characters.

-or-

false to perform a case-sensitive search for typeName.

Return Value

The Type with the specified name, if found; otherwise, a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
ArgumentNullException | typeName is a null reference (Nothing).
SecurityException | The requested Type is non-public and the caller does not have ReflectionPermission to reflect non-public objects outside the current assembly.
TargetInvocationException | A class initializer is invoked and throws an exception.

Remarks

Arrays or COM types are not searched for unless they have already been loaded into the table of available classes.

If typeName includes only the name of the Type, this method searches in the calling object's assembly, then in the System assembly. If typeName is fully qualified with the partial or complete assembly name, this method searches in the specified assembly. AssemblyQualifiedName returns a fully qualified type name including the assembly name.

To obtain a Type object for an array, pass the type name followed by an open and close bracket: [].

To obtain a Type object for an n-dimensional array, include the comma character ',' within the brackets a total of n-1 times (for example, "System.Object[,,]" represents a 3-dimensional Object array).

To obtain a Type object for a jagged array, pass the type name followed by two or more bracket pairs (for example, "System.Object[][]" represents a jagged array).

If the module containing the class is not loaded, the metadata will be accessed directly without the class being loaded.

See Also

Type Class | Type Members | System Namespace | Type.GetType Overload List | AssemblyQualifiedName | GetAssembly | GetType


Type.GetTypeArray

Gets the types of the objects in the specified array.

[Visual Basic]
Public Shared Function GetTypeArray( _
   ByVal args() As Object _
) As Type ()
[C#]
public static Type[] GetTypeArray(
   object[] args
);
[C++]
public: static Type* GetTypeArray(
   Object* args[]
) [];
[JScript]
public static function GetTypeArray(
   args : Object[]
) : Type[];

Parameters

args
An array of objects whose types to determine.

Return Value

An array of Type objects representing the types of the corresponding elements in args.

Exceptions

Exception Type | Condition
ArgumentNullException | args is a null reference (in Visual Basic Nothing).
SecurityException | One of the requested Type objects is non-public and the caller does not have ReflectionPermission to reflect non-public objects outside the current assembly.
TargetInvocationException | The class initializers are invoked and at least one throws an exception.

See Also

Type Class | Type Members | System Namespace


Type.GetTypeCode

Gets the underlying type code of the specified Type.

[Visual Basic]
Public Shared Function GetTypeCode( _
   ByVal type As Type _
) As TypeCode
[C#]
public static TypeCode GetTypeCode(
   Type type
);
[C++]
public: static TypeCode GetTypeCode(
   Type* type
);
[JScript]
public static function GetTypeCode(
   type : Type
) : TypeCode;

Parameters

type
The Type whose underlying type code to get.

Return Value

The TypeCode value of the underlying type.

See Also

Type Class | Type Members | System Namespace | TypeCode


Type.GetTypeFromHandle

Gets the Type referenced by the specified type handle.

[Visual Basic]
Public Shared Function GetTypeFromHandle( _
   ByVal handle As RuntimeTypeHandle _
) As Type
[C#]
public static Type GetTypeFromHandle(
   RuntimeTypeHandle handle
);
[C++]
public: static Type* GetTypeFromHandle(
   RuntimeTypeHandle handle
);
[JScript]
public static function GetTypeFromHandle(
   handle : RuntimeTypeHandle
) : Type;

Parameters

handle
The RuntimeTypeHandle object that refers to the Type.

Return Value

The Type referenced by the specified RuntimeTypeHandle.

Exceptions

Exception Type | Condition
ArgumentNullException | handle is a null reference (in Visual Basic Nothing).
SecurityException | The requested Type is non-public and the caller does not have ReflectionPermission to reflect non-public objects outside the current assembly.
TargetInvocationException | A class initializer is invoked and throws an exception.

See Also

Type Class | Type Members | System Namespace | RuntimeTypeHandle | TypeHandle | GetTypeHandle


Type.GetTypeFromProgID

Gets the Type associated with the specified program identifier (progID).

Overload List

Gets the Type associated with the specified program identifier (progID), throwing an exception on error while loading the Type.

[Visual Basic] Overloads Public Shared Function GetTypeFromProgID(String) As Type
[C#] public static Type GetTypeFromProgID(String);
[C++] public: static Type* GetTypeFromProgID(String*);
[JScript] public static function GetTypeFromProgID(String) : Type;

Gets the Type associated with the specified program identifier (progID), specifying whether to throw an exception on error while loading the Type.

[Visual Basic] Overloads Public Shared Function GetTypeFromProgID(String, Boolean) As Type
[C#] public static Type GetTypeFromProgID(String, bool);
[C++] public: static Type* GetTypeFromProgID(String*, bool);
[JScript] public static function GetTypeFromProgID(String, Boolean) : Type;

See Also

Type Class | Type Members | System Namespace


Type.GetTypeFromProgID (String)

Gets the Type associated with the specified program identifier (progID), throwing an exception on error while loading the Type.

[Visual Basic]
Overloads Public Shared Function GetTypeFromProgID( _
   ByVal progID As String _
) As Type
[C#]
public static Type GetTypeFromProgID(
   string progID
);
[C++]
public: static Type* GetTypeFromProgID(
   String* progID
);
[JScript]
public static function GetTypeFromProgID(
   progID : String
) : Type;

Parameters

progID
The progID of the Type to get.

Return Value

The Type associated with the specified program identifier (progID), if progID is a valid entry in the registry and a type is associated with it; otherwise, a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
SecurityException | The requested Type is non-public and the caller does not have ReflectionPermission to reflect non-public objects outside the current assembly.
TargetInvocationException | A class initializer is invoked and throws an exception.

Remarks

This method is provided for COM classic support. Program IDs are not used in the NGWS runtime because they have been superceded by the concept of namespace.

See Also

Type Class | Type Members | System Namespace | Type.GetTypeFromProgID Overload List


Type.GetTypeFromProgID (String, Boolean)

Gets the Type associated with the specified program identifier (progID), specifying whether to throw an exception on error while loading the Type.

[Visual Basic]
Overloads Public Shared Function GetTypeFromProgID( _
   ByVal progID As String, _
   ByVal throwOnError As Boolean _
) As Type
[C#]
public static Type GetTypeFromProgID(
   string progID,
   bool throwOnError
);
[C++]
public: static Type* GetTypeFromProgID(
   String* progID,
   bool throwOnError
);
[JScript]
public static function GetTypeFromProgID(
   progID : String,
   throwOnError : Boolean
) : Type;

Parameters

progID
The progID of the Type to get.
throwOnError
true to throw a TypeLoadException on error while loading the Type.

-or-

false to ignore errors while loading the Type.

Return Value

The Type associated with the specified program identifier (progID), if progID is a valid entry in the registry and a type is associated with it; otherwise, a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
SecurityException | The requested Type is non-public and the caller does not have ReflectionPermission to reflect non-public objects outside the current assembly.
TargetInvocationException | A class initializer is invoked and throws an exception.

Remarks

This method is provided for COM classic support. Program IDs are not used in the NGWS runtime because they have been superceded by the concept of namespace.

See Also

Type Class | Type Members | System Namespace | Type.GetTypeFromProgID Overload List | GetType


Type.GetTypeHandle

Gets the handle for the Type of an object.

[Visual Basic]
Public Shared Function GetTypeHandle( _
   ByVal o As Object _
) As RuntimeTypeHandle
[C#]
public static RuntimeTypeHandle GetTypeHandle(
   object o
);
[C++]
public: static RuntimeTypeHandle GetTypeHandle(
   Object* o
);
[JScript]
public static function GetTypeHandle(
   o : Object
) : RuntimeTypeHandle;

Parameters

o
The Object for which to get the Type handle.

Return Value

The handle for the Type of the specified Object.

See Also

Type Class | Type Members | System Namespace | RuntimeTypeHandle | TypeHandle | GetTypeFromHandle


Type.HasElementTypeImpl

Implements the HasElementType property and, when implemented by a derived class, determines whether the Type...

[Visual Basic]
MustOverride Protected Function HasElementTypeImpl() As Boolean
[C#]
protected abstract bool HasElementTypeImpl();
[C++]
protected: virtual bool HasElementTypeImpl() = 0;
[JScript]
protected abstract function HasElementTypeImpl() : Boolean;

Return Value

true if the Type is ...; otherwise, false.

Remarks

Abstract. This method must be implemented by a derived class.

See Also

Type Class | Type Members | System Namespace | HasElementType


Type.InvokeMember

Invokes a specific member of the current Type; essentially calls a constructor member or a method member, gets or sets a property member, gets or sets a data field member, or gets or sets an element of an array member.

Overload List

Invokes the specified member, using the specified binding constraints and matching the specified argument list.

[Visual Basic] Overloads Public Function InvokeMember(String, BindingFlags, Binder, Object, Object()) As Object
[C#] public object InvokeMember(String, BindingFlags, Binder, Object, Object[]);
[C++] public: Object* InvokeMember(String*, BindingFlags, Binder, Object, Object[]);
[JScript] public function InvokeMember(String, BindingFlags, Binder, Object, Object[]) : Object;

Invokes the specified member, using the specified binding constraints and matching the specified argument list and culture.

[Visual Basic] Overloads Public Function InvokeMember(String, BindingFlags, Binder, Object, Object(), CultureInfo) As Object
[C#] public object InvokeMember(String, BindingFlags, Binder, Object, Object[], CultureInfo);
[C++] public: Object* InvokeMember(String*, BindingFlags, Binder, Object, Object[], CultureInfo);
[JScript] public function InvokeMember(String, BindingFlags, Binder, Object, Object[], CultureInfo) : Object;

When implemented by a derived class, invokes the specified member, using the specified binding constraints and matching the specified argument list, modifiers and culture.

[Visual Basic] Overloads MustOverride Public Function InvokeMember(String, BindingFlags, Binder, Object, Object(), ParameterModifier(), CultureInfo, String()) As Object
[C#] public abstract object InvokeMember(String, BindingFlags, Binder, Object, Object[], ParameterModifier[], CultureInfo, String[]);
[C++] public: virtual Object* InvokeMember(String*, BindingFlags, Binder, Object, Object[], ParameterModifier[], CultureInfo, String*[]) = 0;
[JScript] public abstract function InvokeMember(String, BindingFlags, Binder, Object, Object[], ParameterModifier[], CultureInfo, String[]) : Object;

See Also

Type Class | Type Members | System Namespace


Type.InvokeMember (String, BindingFlags, Binder, Object, Object[])

Invokes the specified member, using the specified binding constraints and matching the specified argument list.

[Visual Basic]
Overloads Public Function InvokeMember( _
   ByVal name As String, _
   ByVal invokeAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal target As Object, _
   ByVal args() As Object _
) As Object
[C#]
public object InvokeMember(
   string name,
   BindingFlags invokeAttr,
   Binder binder,
   object target,
   object[] args
);
[C++]
public: Object* InvokeMember(
   String* name,
   BindingFlags invokeAttr,
   Binder* binder,
   Object* target,
   Object* args[]
);
[JScript]
public function InvokeMember(
   name : String,
   invokeAttr : BindingFlags,
   binder : Binder,
   target : Object,
   args : Object[]
) : Object;

Parameters

name
The String containing the name of the constructor, method, property, or field member to invoke.

-or-

An empty string ("") to invoke the default member.

invokeAttr
A bit mask comprised of one or more BindingFlags that specify how the search is conducted.

-or-

zero, to conduct a case-sensitive search for public methods.

binder
A Binder object that defines a set of properties and enables binding, which may involve selection of an overloaded method, coercion of argument types, and invocation of a member through reflection.

-or-

a null reference (in Visual Basic Nothing), to use the DefaultBinder.

target
The Object on which to invoke the specified member.
args
An array containing the arguments to pass to the member to invoke.

Return Value

An Object representing the return value of the invoked member.

Exceptions

Exception Type | Condition
ArgumentNullException | invokeAttr contains CreateInstance and typeName is a null reference (Nothing).
ArgumentException | args is multidimensional. -or- invokeAttr is not a valid BindingFlags attribute. -or- invokeAttr contains CreateInstance combined with InvokeMethod, GetField, SetField, GetProperty, or SetProperty. -or- invokeAttr contains both GetField and SetField. -or- invokeAttr contains both GetProperty and SetProperty. -or- invokeAttr contains InvokeMethod combined with SetField or SetProperty. -or- invokeAttr contains SetField and args has more than one element.
AccessException | The specified member is a class initializer.
MissingFieldException | The field or property cannot be found.
MissingMethodException | The method cannot be found.
SecurityException | The specified member is non-public and the caller does not have ReflectionPermission to reflect non-public members outside the current assembly.
TargetException | The specified member cannot be invoked on target.

Remarks

The following BindingFlags filter flags can be used to define which members should be included in the search:

  • Instance to include instance members in the search.
  • Static to include static members in the search.
  • Public to include public members in the search.
  • NonPublic to include non-public members (that is, private and protected members) in the search.

The following BindingFlags modifier flags can be used to change how the search works:

  • IgnoreCase to ignore the case of name. If name has 128 or more standard ASCII characters, a case-sensitive search will be performed, regardless of the IgnoreCase flag.
  • DeclaredOnly to search only the members declared on the Type, not members that were simply inherited.

The following BindingFlags invocation flags can be used to denote what action to take with the member:

  • CreateInstance to invoke a constructor. name is ignored. Not valid with other invocation flags.
  • InvokeMethod to invoke a method, but not a constructor or a type initializer. Not valid with SetField or SetProperty.
  • GetField to get the value of a field. Not valid with SetField.
  • SetField to set the value of a field. Not valid with GetField.
  • GetProperty to get a property. Not valid with SetProperty.
  • SetProperty to set a property. Not valid with GetProperty.

See BindingFlags for more information.

A method will be invoked if:

  • the number of parameters in the method declaration equals the number of arguments in the args array (unless default arguments are defined on the member), and
  • the type of each arguments can be converted by the binder to the type of the parameter.

The binder will find all of the matching methods. These methods are found based upon the type of binding requested (BindingFlags values InvokeMethod, GetProperty, etc.). The set of methods is filtered by the name, number of arguments, and a set of search modifiers defined in the binder.

After the method is selected, it will be invoked. Accessibility is checked at that point. The search may control which set of methods are searched based upon the accessibility attribute associated with the method. The BindToMethod method of the Binder class is responsible for selecting the method to be invoked. The default binder selects the most specific match.

Access restrictions are ignored for fully trusted code; that is, private constructors, methods, fields, and properties can be accessed and invoked through System.Reflection whenever the code is fully trusted.

If the member specified by name is an array and invokeAttr contains the GetField flag, the args array must specify the elements whose values are to be returned. For example, the following call through Type object t returns the value of the first element of the string array MyArray, which is a member of the calling object:

String ret = (String) t.InvokeMember ("MyArray", BindingFlags.GetField, null, this, new Object[]{0});

InvokeMember can also set one or more elements of a member array to the same value. The args array must be formatted as follows: "{index1, index2, ..., value}".

For example, to set the first member of MyArray from the previous example, the syntax is as follows:

t.InvokeMember ("MyArray", BindingFlags.SetField, null, this, new Object[]{0,"Updated"});

See Also

Type Class | Type Members | System Namespace | Type.InvokeMember Overload List | String | Binder | DefaultBinder | BindingFlags | ParameterModifier


Type.InvokeMember (String, BindingFlags, Binder, Object, Object[], CultureInfo)

Invokes the specified member, using the specified binding constraints and matching the specified argument list and culture.

[Visual Basic]
Overloads Public Function InvokeMember( _
   ByVal name As String, _
   ByVal invokeAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal target As Object, _
   ByVal args() As Object, _
   ByVal culture As CultureInfo _
) As Object
[C#]
public object InvokeMember(
   string name,
   BindingFlags invokeAttr,
   Binder binder,
   object target,
   object[] args,
   CultureInfo culture
);
[C++]
public: Object* InvokeMember(
   String* name,
   BindingFlags invokeAttr,
   Binder* binder,
   Object* target,
   Object* args[],
   CultureInfo* culture
);
[JScript]
public function InvokeMember(
   name : String,
   invokeAttr : BindingFlags,
   binder : Binder,
   target : Object,
   args : Object[],
   culture : CultureInfo
) : Object;

Parameters

name
The String containing the name of the constructor, method, property, or field member to invoke.

-or-

An empty string ("") to invoke the default member.

invokeAttr
A bit mask comprised of one or more BindingFlags that specify how the search is conducted.

-or-

zero, to conduct a case-sensitive search for public methods.

binder
A Binder object that defines a set of properties and enables binding, which may involve selection of an overloaded method, coercion of argument types, and invocation of a member through reflection.

-or-

a null reference (in Visual Basic Nothing), to use the DefaultBinder.

target
The Object on which to invoke the specified member.
args
An array containing the arguments to pass to the member to invoke.
culture
The CultureInfo object representing the globalization locale to use, which may be necessary for locale-specific conversions, such as converting a numeric String to a Double.

-or-

a null reference (Nothing) to use the current thread's CultureInfo.

Return Value

An Object representing the return value of the invoked member.

Exceptions

Exception Type | Condition
ArgumentNullException | invokeAttr contains CreateInstance and typeName is a null reference (Nothing).
ArgumentException | args is multidimensional. -or- invokeAttr is not a valid BindingFlags attribute. -or- invokeAttr contains CreateInstance combined with InvokeMethod, GetField, SetField, GetProperty, or SetProperty. -or- invokeAttr contains both GetField and SetField. -or- invokeAttr contains both GetProperty and SetProperty. -or- invokeAttr contains InvokeMethod combined with SetField or SetProperty. -or- invokeAttr contains SetField and args has more than one element.
AccessException | The specified member is a class initializer.
MissingFieldException | The field or property cannot be found.
MissingMethodException | The method cannot be found.
SecurityException | The specified member is non-public and the caller does not have ReflectionPermission to reflect non-public members outside the current assembly.
TargetException | The specified member cannot be invoked on target.

Remarks

The following BindingFlags filter flags can be used to define which members should be included in the search:

  • Instance to include instance members in the search.
  • Static to include static members in the search.
  • Public to include public members in the search.
  • NonPublic to include non-public members (that is, private and protected members) in the search.

The following BindingFlags modifier flags can be used to change how the search works:

  • IgnoreCase to ignore the case of name. If name has 128 or more standard ASCII characters, a case-sensitive search will be performed, regardless of the IgnoreCase flag.
  • DeclaredOnly to search only the members declared on the Type, not members that were simply inherited.

The following BindingFlags invocation flags can be used to denote what action to take with the member:

  • CreateInstance to invoke a constructor. name is ignored. Not valid with other invocation flags.
  • InvokeMethod to invoke a method, but not a constructor or a type initializer. Not valid with SetField or SetProperty.
  • GetField to get the value of a field. Not valid with SetField.
  • SetField to set the value of a field. Not valid with GetField.
  • GetProperty to get a property. Not valid with SetProperty.
  • SetProperty to set a property. Not valid with GetProperty.

See BindingFlags for more information.

Other BindingFlags values can include InvokeMethod, CreateInstance, GetField, SetField, GetProperty, or SetProperty. CreateInstance cannot be combined with InvokeMethod, GetField, SetField, GetProperty, or SetProperty.

A method will be invoked if:

  • the number of parameters in the method declaration equals the number of arguments in the args array (unless default arguments are defined on the member), and
  • the type of each arguments can be converted by the binder to the type of the parameter.

The binder will find all of the matching methods. These methods are found based upon the type of binding requested (BindingFlags values InvokeMethod, GetProperty, etc.). The set of methods is filtered by the name, number of arguments, and a set of search modifiers defined in the binder.

After the method is selected, it will be invoked. Accessibility is checked at that point. The search may control which set of methods are searched based upon the accessibility attribute associated with the method. The BindToMethod method of the Binder class is responsible for selecting the method to be invoked. The default binder selects the most specific match.

Access restrictions are ignored for fully trusted code; that is, private constructors, methods, fields, and properties can be accessed and invoked through System.Reflection whenever the code is fully trusted.

If the member specified by name is an array and invokeAttr contains the GetField flag, the args array must specify the elements whose values are to be returned. For example, the following call through Type object t returns the value of the first element of the string array MyArray, which is a member of the calling object:

String ret = (String) t.InvokeMember ("MyArray", BindingFlags.GetField, null, this, new Object[]{0}, null);

InvokeMember can also set one or more elements of a member array to the same value. The args array must be formatted as follows: "{index1, index2, ..., value}".

For example, to set the first member of MyArray from the previous example, the syntax is as follows:

t.InvokeMember ("MyArray", BindingFlags.SetField, null, this, new Object[]{0,"Updated"}, null);

See Also

Type Class | Type Members | System Namespace | Type.InvokeMember Overload List | String | Binder | DefaultBinder | BindingFlags | ParameterModifier


Type.InvokeMember (String, BindingFlags, Binder, Object, Object[], ParameterModifier[], CultureInfo, String[])

When implemented by a derived class, invokes the specified member, using the specified binding constraints and matching the specified argument list, modifiers and culture.

[Visual Basic]
Overloads MustOverride Public Function InvokeMember( _
   ByVal name As String, _
   ByVal invokeAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal target As Object, _
   ByVal args() As Object, _
   ByVal modifiers() As ParameterModifier, _
   ByVal culture As CultureInfo, _
   ByVal namedParameters() As String _
) As Object
[C#]
public abstract object InvokeMember(
   string name,
   BindingFlags invokeAttr,
   Binder binder,
   object target,
   object[] args,
   ParameterModifier[] modifiers,
   CultureInfo culture,
   string[] namedParameters
);
[C++]
public: virtual Object* InvokeMember(
   String* name,
   BindingFlags invokeAttr,
   Binder* binder,
   Object* target,
   Object* args[],
   ParameterModifier* modifiers[],
   CultureInfo* culture,
   String* namedParameters[]
) = 0;
[JScript]
public abstract function InvokeMember(
   name : String,
   invokeAttr : BindingFlags,
   binder : Binder,
   target : Object,
   args : Object[],
   modifiers : ParameterModifier[],
   culture : CultureInfo,
   namedParameters : String[]
) : Object;

Parameters

name
The String containing the name of the constructor, method, property, or field member to invoke.

-or-

An empty string ("") to invoke the default member.

invokeAttr
A bit mask comprised of one or more BindingFlags that specify how the search is conducted.

-or-

zero, to conduct a case-sensitive search for public methods.

binder
A Binder object that defines a set of properties and enables binding, which may involve selection of an overloaded method, coercion of argument types, and invocation of a member through reflection.

-or-

a null reference (in Visual Basic Nothing), to use the DefaultBinder.

target
The Object on which to invoke the specified member.
args
An array containing the arguments to pass to the member to invoke.
modifiers
An array of ParameterModifier objects representing the attributes associated with the corresponding element in the args array. A parameter's associated attributes are stored in the member's signature. The default binder does exact matching on the ParameterAttributes Out and None attributes.
culture
The CultureInfo object representing the globalization locale to use, which may be necessary for locale-specific conversions, such as converting a numeric String to a Double.

-or-

a null reference (Nothing) to use the current thread's CultureInfo.

namedParameters
An array containing the names of the parameters to which the values in the args array are passed.

Return Value

An Object representing the return value of the invoked member.

Exceptions

Exception Type | Condition
ArgumentNullException | invokeAttr contains CreateInstance and typeName is a null reference (Nothing).
ArgumentException | args is multidimensional. -or- modifiers is multidimensional. -or- args and modifiers do not have the same length. -or- invokeAttr is not a valid BindingFlags attribute. -or- invokeAttr contains CreateInstance combined with InvokeMethod, GetField, SetField, GetProperty, or SetProperty. -or- invokeAttr contains both GetField and SetField. -or- invokeAttr contains both GetProperty and SetProperty. -or- invokeAttr contains InvokeMethod combined with SetField or SetProperty. -or- invokeAttr contains SetField and args has more than one element.
AccessException | The specified member is a class initializer.
MissingFieldException | The field or property cannot be found.
MissingMethodException | The method cannot be found.
SecurityException | The specified member is non-public and the caller does not have ReflectionPermission to reflect non-public members outside the current assembly.
TargetException | The specified member cannot be invoked on target.

Remarks

Abstract. This method must be implemented by a derived class.

The args array and the modifiers array have the same length. A parameter specified in the args array can have the following attributes, which are specified in the modifiers array: pdIn, pdOut, pdLcid, pdRetval, pdOptional, and pdHasDefault, which represent [in], [out], [lcid], [retval], [optional], and a value specifying whether the parameter has a default value. A parameter's associated attributes are stored in the metadata and are used for interoperability.

Each parameter in the namedParameters array gets the value in the corresponding element in the args array. If the length of args is greater than the length of namedParameters, the remaining argument values are passed in order.

The following BindingFlags filter flags can be used to define which members should be included in the search:

  • Instance to include instance members in the search.
  • Static to include static members in the search.
  • Public to include public members in the search.
  • NonPublic to include non-public members (that is, private and protected members) in the search.

The following BindingFlags modifier flags can be used to change how the search works:

  • IgnoreCase to ignore the case of name. If name has 128 or more standard ASCII characters, a case-sensitive search will be performed, regardless of the IgnoreCase flag.
  • DeclaredOnly to search only the members declared on the Type, not members that were simply inherited.

The following BindingFlags invocation flags can be used to denote what action to take with the member:

  • CreateInstance to invoke a constructor. name is ignored. Not valid with other invocation flags.
  • InvokeMethod to invoke a method, but not a constructor or a type initializer. Not valid with SetField or SetProperty.
  • GetField to get the value of a field. Not valid with SetField.
  • SetField to set the value of a field. Not valid with GetField.
  • GetProperty to get a property. Not valid with SetProperty.
  • SetProperty to set a property. Not valid with GetProperty.

See BindingFlags for more information.

A method will be invoked if:

  • the number of parameters in the method declaration equals the number of arguments in the args array (unless default arguments are defined on the member), and
  • the type of each arguments can be converted by the binder to the type of the parameter.

The binder will find all of the matching methods. These methods are found based upon the type of binding requested (BindingFlags values InvokeMethod, GetProperty, etc.). The set of methods is filtered by the name, number of arguments, and a set of search modifiers defined in the binder.

After the method is selected, it will be invoked. Accessibility is checked at that point. The search may control which set of methods are searched based upon the accessibility attribute associated with the method. The BindToMethod method of the Binder class is responsible for selecting the method to be invoked. The default binder selects the most specific match.

Access restrictions are ignored for fully trusted code; that is, private constructors, methods, fields, and properties can be accessed and invoked through System.Reflection whenever the code is fully trusted.

If the member specified by name is an array and invokeAttr contains the GetField flag, the args array must specify the elements whose values are to be returned. For example, the following call through Type object t returns the value of the first element of the string array MyArray, which is a member of the calling object:

String ret = (String) t.InvokeMember ("MyArray", BindingFlags.GetField, null, this, new Object[]{0});

InvokeMember can also set one or more elements of a member array to the same value. The args array must be formatted as follows: "{index1, index2, ..., value}".

For example, to set the first member of MyArray from the previous example, the syntax is as follows:

t.InvokeMember ("MyArray", BindingFlags.SetField, null, this, new Object[]{0,"Updated"});

See Also

Type Class | Type Members | System Namespace | Type.InvokeMember Overload List | String | Binder | DefaultBinder | BindingFlags | ParameterModifier


Type.IsArrayImpl

Implements the IsArray property and, when implemented by a derived class, determines whether the Type is an array.

[Visual Basic]
MustOverride Protected Function IsArrayImpl() As Boolean
[C#]
protected abstract bool IsArrayImpl();
[C++]
protected: virtual bool IsArrayImpl() = 0;
[JScript]
protected abstract function IsArrayImpl() : Boolean;

Return Value

true if the Type is an array; otherwise, false.

Remarks

Abstract. This method must be implemented by a derived class.

An instance of the Array class must return false because it is an object, not an array.

See Also

Type Class | Type Members | System Namespace | IsArray


Type.IsAssignableFrom

Determines whether an instance of the specified type can be assigned to the current Type instance.

[Visual Basic]
Overridable Public Function IsAssignableFrom( _
   ByVal c As Type _
) As Boolean
[C#]
public virtual bool IsAssignableFrom(
   Type c
);
[C++]
public: virtual bool IsAssignableFrom(
   Type* c
);
[JScript]
public function IsAssignableFrom(
   c : Type
) : Boolean;

Parameters

c
The Type to examine whether its objects can be assigned to the current Type instance.

Return Value

true if an instance of c can be assigned to the current Type instance; otherwise, false.

Remarks

This method can be overridden by a derived class.

See Also

Type Class | Type Members | System Namespace


Type.IsByRefImpl

Implements the IsByRef property and, when implemented by a derived class, determines whether the Type is passed by reference.

[Visual Basic]
MustOverride Protected Function IsByRefImpl() As Boolean
[C#]
protected abstract bool IsByRefImpl();
[C++]
protected: virtual bool IsByRefImpl() = 0;
[JScript]
protected abstract function IsByRefImpl() : Boolean;

Return Value

true if the Type is passed by reference; otherwise, false.

Remarks

Abstract. This method must be implemented by a derived class.

See Also

Type Class | Type Members | System Namespace | IsByRef


Type.IsCOMObjectImpl

Implements the IsCOMObject property and, when implemented by a derived class, determines whether the Type is a COM object.

[Visual Basic]
MustOverride Protected Function IsCOMObjectImpl() As Boolean
[C#]
protected abstract bool IsCOMObjectImpl();
[C++]
protected: virtual bool IsCOMObjectImpl() = 0;
[JScript]
protected abstract function IsCOMObjectImpl() : Boolean;

Return Value

true if the Type is a COM object; otherwise, false.

Remarks

Abstract. This method must be implemented by a derived class.

This method returns false for COM interfaces because they are not objects. COM interfaces can be implemented by NGWS objects.

See Also

Type Class | Type Members | System Namespace | IsCOMObject


Type.IsContextfulImpl

Implements the IsContextful property and determines whether the Type can be hosted in a context.

[Visual Basic]
Overridable Protected Function IsContextfulImpl() As Boolean
[C#]
protected virtual bool IsContextfulImpl();
[C++]
protected: virtual bool IsContextfulImpl();
[JScript]
protected function IsContextfulImpl() : Boolean;

Return Value

true if the Type can be hosted in a context; otherwise, false.

Remarks

This method can be overridden by a derived class.

A context intercepts calls to the class members and enforce policies that are applied to the class, such as synchronization.

See Also

Type Class | Type Members | System Namespace | IsContextful


Type.IsInstanceOfType

Determines whether the specified object is an instance of the Type.

[Visual Basic]
Overridable Public Function IsInstanceOfType( _
   ByVal o As Object _
) As Boolean
[C#]
public virtual bool IsInstanceOfType(
   object o
);
[C++]
public: virtual bool IsInstanceOfType(
   Object* o
);
[JScript]
public function IsInstanceOfType(
   o : Object
) : Boolean;

Parameters

o
The Object whose type to compare with Type.

Return Value

true if o is an instance of the Type; otherwise, false.

Remarks

This method can be overridden by a derived class.

a null reference (in Visual Basic Nothing) is considered an instance of any type, therefore this method will always return true if o is a null reference (Nothing).

See Also

Type Class | Type Members | System Namespace


Type.IsMarshalByRefImpl

Implements the IsMarshalByRef property and determines whether the Type is marshalled by reference.

[Visual Basic]
Overridable Protected Function IsMarshalByRefImpl() As Boolean
[C#]
protected virtual bool IsMarshalByRefImpl();
[C++]
protected: virtual bool IsMarshalByRefImpl();
[JScript]
protected function IsMarshalByRefImpl() : Boolean;

Return Value

true if the Type is marshalled by reference; otherwise, false.

Remarks

This method can be overridden by a derived class.

See Also

Type Class | Type Members | System Namespace | IsMarshalByRef


Type.IsPointerImpl

Implements the IsPointer property and, when implemented by a derived class, determines whether the Type is a pointer.

[Visual Basic]
MustOverride Protected Function IsPointerImpl() As Boolean
[C#]
protected abstract bool IsPointerImpl();
[C++]
protected: virtual bool IsPointerImpl() = 0;
[JScript]
protected abstract function IsPointerImpl() : Boolean;

Return Value

true if the Type is a pointer; otherwise, false.

Remarks

Abstract. This method must be implemented by a derived class.

See Also

Type Class | Type Members | System Namespace | IsPointer


Type.IsPrimitiveImpl

Implements the IsPrimitive property and, when implemented by a derived class, determines whether the Type is one of the primitive types.

[Visual Basic]
MustOverride Protected Function IsPrimitiveImpl() As Boolean
[C#]
protected abstract bool IsPrimitiveImpl();
[C++]
protected: virtual bool IsPrimitiveImpl() = 0;
[JScript]
protected abstract function IsPrimitiveImpl() : Boolean;

Return Value

true if the Type is one of the primitive types; otherwise, false.

Remarks

Abstract. This method must be implemented by a derived class.

The primitive types are Boolean, Byte, SByte, Int16, UInt16, Int32, UInt32, Int64, UInt64, Char, Double, and Single.

See Also

Type Class | Type Members | System Namespace | Boolean | Byte | SByte | Int16 | UInt16 | Int32 | UInt32 | Int64 | UInt64 | Char | Double | Single | IsPrimitive


Type.IsSubclassOf

Determines whether the current Type is a subclass of the specified class.

[Visual Basic]
Overridable Public Function IsSubclassOf( _
   ByVal c As Type _
) As Boolean
[C#]
public virtual bool IsSubclassOf(
   Type c
);
[C++]
public: virtual bool IsSubclassOf(
   Type* c
);
[JScript]
public function IsSubclassOf(
   c : Type
) : Boolean;

Parameters

c
The Type that might be a superclass of the current Type.

Return Value

true if the current Type is a direct or indirect subclass of c; otherwise, false.

Remarks

This method can be overridden by a derived class.

See Also

Type Class | Type Members | System Namespace


Type.IsValueTypeImpl

Implements the IsValueType property and, when implemented by a derived class, determines whether the Type is a value type; that is, not a class or an interface.

[Visual Basic]
MustOverride Protected Function IsValueTypeImpl() As Boolean
[C#]
protected abstract bool IsValueTypeImpl();
[C++]
protected: virtual bool IsValueTypeImpl() = 0;
[JScript]
protected abstract function IsValueTypeImpl() : Boolean;

Return Value

true if the Type is a value type; otherwise, false.

Remarks

Abstract. This method must be implemented by a derived class.

Value types describe values that are represented as sequences of bits; value types are not classes or interfaces. These are referred to as "structs" in some programming languages. Enums are a special case of value types.

See Also

Type Class | Type Members | System Namespace | TypeAttributes | IsClass | IsInterface | IsUnmanagedValueType | Value | ValueType | IsValueType


Type.ToString

Returns a String representing the name of the current Type.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

A String representing the name of the current Type.

See Also

Type Class | Type Members | System Namespace | String


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Type Fields

The fields of the Type class are listed below. For a complete list of Type class members, see the Type Members topic.

Public:

Delimiter | Represents the character used to separate names in the namespace of the Type.
EmptyTypes | Represents an empty array of type Type.
FilterAttribute | Represents the member filter used on attributes.
FilterName | Represents the case-sensitive member filter used on names.
FilterNameIgnoreCase | Represents the case-insensitive member filter used on names.
Missing | Represents a missing value in the Type information.

See Also

Type Class | System Namespace


Type.Delimiter

Represents the character used to separate names in the namespace of the Type.

[Visual Basic]
Public Shared ReadOnly Delimiter As Char
[C#]
public static readonly char Delimiter;
[C++]
public: static readonly __wchar_t Delimiter;
[JScript]
public static var Delimiter : Char;

See Also

Type Class | Type Members | System Namespace


Type.EmptyTypes

Represents an empty array of type Type.

[Visual Basic]
Public Shared ReadOnly EmptyTypes() As Type
[C#]
public static readonly Type[] EmptyTypes;
[C++]
public: static readonly Type* EmptyTypes[];
[JScript]
public static var EmptyTypes : Type[];

See Also

Type Class | Type Members | System Namespace


Type.FilterAttribute

Represents the member filter used on attributes.

[Visual Basic]
Public Shared ReadOnly FilterAttribute As MemberFilter
[C#]
public static readonly MemberFilter FilterAttribute;
[C++]
public: static readonly MemberFilter* FilterAttribute;
[JScript]
public static var FilterAttribute : MemberFilter;

Remarks

This field holds a reference to the delegate used by the FindMembers method. The method encapsulated by this delegate takes two parameters: the first is a MemberInfo object and the second is an Object. The method determines whether the MemberInfo object matches the criteria specified by the Object. The Object may be assigned the value of any one of the fields on the classes FieldAttributes, MethodAttributes, or MethodImplAttributes.

For example, the Object may be assigned the value of a field from FieldAttributes such as Public. In that case, when the FilterAttribute delegate is invoked, it will return true only if the method represented by the MemberInfo object is decorated with the public field attribute in metadata.

See the example in the FindMembers to learn how to use FilterAttribute.

See Also

Type Class | Type Members | System Namespace | FindMembers


Type.FilterName

Represents the case-sensitive member filter used on names.

[Visual Basic]
Public Shared ReadOnly FilterName As MemberFilter
[C#]
public static readonly MemberFilter FilterName;
[C++]
public: static readonly MemberFilter* FilterName;
[JScript]
public static var FilterName : MemberFilter;

Remarks

This field holds a reference to the delegate used by the FindMembers method. The method encapsulated by this delegate takes two parameters: the first is a MemberInfo object and the second is an Object. The method determines whether the MemberInfo object matches the criteria specified by the Object. The Object is assigned a string value, which may include a trailing "*" wildcard character.

For example, the Object may be assigned the value "Byte*". In that case, when the FilterName delegate is invoked, it will return true only if the method represented by the MemberInfo object has a name that begins with the characters "Byte".

See the example in the FindMembers topic.

See Also

Type Class | Type Members | System Namespace | FindMembers


Type.FilterNameIgnoreCase

Represents the case-insensitive member filter used on names.

[Visual Basic]
Public Shared ReadOnly FilterNameIgnoreCase As MemberFilter
[C#]
public static readonly MemberFilter FilterNameIgnoreCase;
[C++]
public: static readonly MemberFilter* FilterNameIgnoreCase;
[JScript]
public static var FilterNameIgnoreCase : MemberFilter;

Remarks

This field holds a reference to the delegate used by the FindMembers method. The method encapsulated by this delegate takes two parameters: the first is a MemberInfo object and the second is an Object. The method determines whether the MemberInfo object matches the criteria specified by the Object. The Object is assigned a string value, which may include a trailing '*' wildcard character.

For example, the Object may be assigned the value "ByTe*". In that case, when the FilterName delegate is invoked, it will return true only if the method represented by the MemberInfo object has a name that begins with the characters "byte", ignoring case.

See the example in the FindMembers topic.

See Also

Type Class | Type Members | System Namespace | FindMembers


Type.Missing

Represents a missing value in the Type information.

[Visual Basic]
Public Shared ReadOnly Missing As Object
[C#]
public static readonly object Missing;
[C++]
public: static readonly Object* Missing;
[JScript]
public static var Missing : Object;

See Also

Type Class | Type Members | System Namespace | Missing


TypeCode Enumeration

[To be supplied.]

[Visual Basic]
Public Enum TypeCode
[C#]
public enum TypeCode
[C++]
public enum TypeCode

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Boolean | [To be supplied.]
Byte | [To be supplied.]
Char | [To be supplied.]
DateTime | [To be supplied.]
DBNull | [To be supplied.]
Decimal | [To be supplied.]
Double | [To be supplied.]
Empty | [To be supplied.]
Int16 | [To be supplied.]
Int32 | [To be supplied.]
Int64 | [To be supplied.]
Object | [To be supplied.]
SByte | [To be supplied.]
Single | [To be supplied.]
String | [To be supplied.]
UInt16 | [To be supplied.]
UInt32 | [To be supplied.]
UInt64 | [To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

System Namespace


TypedReference Structure

TypedReferences are used to describe objects that contain both a managed pointer to a location and a runtime representation of the type that may be stored at that location. TypedReferences can be used for parameters and local variables. It is a built-in value type.

Object
ValueType
TypedReference

[Visual Basic]
Public Structure TypedReference
[C#]
public struct TypedReference
[C++]
public __value struct TypedReference

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

Arrays of TypedReference objects cannot be created. For example, the following call is invalid:

[C#]

Assembly.Load("mscorlib.dll").GetType("System.TypedReference[]");

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

TypedReference Members | System Namespace


TypedReference Members

Public:

Methods

Equals | Checks if this object is equal to the specified object.
GetHashCode | Returns the hash code of this object.
GetTargetType | Returns the Type of the target of the specified TypedReference.
GetType (inherited from Object) | Gets the Type of the Object.
MakeTypedReference | Makes a TypedReference for the specified target object using the specifying fields.
SetTypedReference | Converts the specified value to a TypedReference.
TargetTypeToken | Returns the internal metadata type handle for the specified TypedReference.
ToObject | Converts the specified TypedReference to an Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypedReference Structure | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypedReference Methods

The methods of the TypedReference structure are listed below. For a complete list of TypedReference structure members, see the TypedReference Members topic.

Public:

Equals | Checks if this object is equal to the specified object.
GetHashCode | Returns the hash code of this object.
GetTargetType | Returns the Type of the target of the specified TypedReference.
GetType (inherited from Object) | Gets the Type of the Object.
MakeTypedReference | Makes a TypedReference for the specified target object using the specifying fields.
SetTypedReference | Converts the specified value to a TypedReference.
TargetTypeToken | Returns the internal metadata type handle for the specified TypedReference.
ToObject | Converts the specified TypedReference to an Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypedReference Structure | System Namespace


TypedReference.Equals

Checks if this object is equal to the specified object.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal o As Object _
) As Boolean
[C#]
public override bool Equals(
   object o
);
[C++]
public: override bool Equals(
   Object* o
);
[JScript]
public override function Equals(
   o : Object
) : Boolean;

Parameters

o
[To be supplied.]

Return Value

Returns true if this object is equal to the specified object.

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

See Also

TypedReference Structure | TypedReference Members | System Namespace


TypedReference.GetHashCode

Returns the hash code of this object.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

The hash code of this object.

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

See Also

TypedReference Structure | TypedReference Members | System Namespace


TypedReference.GetTargetType

Returns the Type of the target of the specified TypedReference.

[Visual Basic]
Public Shared Function GetTargetType( _
   ByVal value As TypedReference _
) As Type
[C#]
public static Type GetTargetType(
   TypedReference value
);
[C++]
public: static Type* GetTargetType(
   TypedReference value
);
[JScript]
public static function GetTargetType(
   value : TypedReference
) : Type;

Parameters

value
The value whose target's type is to be returned.

Return Value

The Type of the target of the specified TypedReference.

See Also

TypedReference Structure | TypedReference Members | System Namespace


TypedReference.MakeTypedReference

Makes a TypedReference for the specified target object using the specifying fields.

[Visual Basic]
Public Shared Function MakeTypedReference( _
   ByVal target As Object, _
   ByVal flds() As FieldInfo _
) As TypedReference
[C#]
public static TypedReference MakeTypedReference(
   object target,
   FieldInfo[] flds
);
[C++]
public: static TypedReference MakeTypedReference(
   Object* target,
   FieldInfo* flds[]
);
[JScript]
public static function MakeTypedReference(
   target : Object,
   flds : FieldInfo[]
) : TypedReference;

Parameters

target
The target object that defines the Type of the TypedReference.
flds
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentNullException | target or flds is a null reference (in Visual Basic Nothing).
ArgumentException | The flds array has no elements.

See Also

TypedReference Structure | TypedReference Members | System Namespace


TypedReference.SetTypedReference

Converts the specified value to a TypedReference.

[Visual Basic]
Public Shared Sub SetTypedReference( _
   ByVal target As TypedReference, _
   ByVal value As Object _
)
[C#]
public static void SetTypedReference(
   TypedReference target,
   object value
);
[C++]
public: static void SetTypedReference(
   TypedReference target,
   Object* value
);
[JScript]
public static function SetTypedReference(
   target : TypedReference,
   value : Object
);

Parameters

target
The target of the conversion.
value
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentNullException | value is a null reference (in Visual Basic Nothing).

See Also

TypedReference Structure | TypedReference Members | System Namespace


TypedReference.TargetTypeToken

Returns the internal metadata type handle for the specified TypedReference.

[Visual Basic]
Public Shared Function TargetTypeToken( _
   ByVal value As TypedReference _
) As RuntimeTypeHandle
[C#]
public static RuntimeTypeHandle TargetTypeToken(
   TypedReference value
);
[C++]
public: static RuntimeTypeHandle TargetTypeToken(
   TypedReference value
);
[JScript]
public static function TargetTypeToken(
   value : TypedReference
) : RuntimeTypeHandle;

Parameters

value
The TypedReference for which the type handle is requested.

Return Value

The internal metadata type handle for the specified TypedReference.

See Also

TypedReference Structure | TypedReference Members | System Namespace


TypedReference.ToObject

Converts the specified TypedReference to an Object.

[Visual Basic]
Public Shared Function ToObject( _
   ByVal value As TypedReference _
) As Object
[C#]
public static object ToObject(
   TypedReference value
);
[C++]
public: static Object* ToObject(
   TypedReference value
);
[JScript]
public static function ToObject(
   value : TypedReference
) : Object;

Parameters

value
The TypedReference to be converted.

See Also

TypedReference Structure | TypedReference Members | System Namespace


TypeInitializationException Class

Represents the exception thrown when type's class initializer throws an exception.

Object
Exception
SystemException
TypeInitializationException

[Visual Basic]
NotInheritable Public Class TypeInitializationException
   Inherits SystemException
[C#]
public sealed class TypeInitializationException : SystemException
[C++]
public __gc __sealed class TypeInitializationException : public
   SystemException
[JScript]
public class TypeInitializationException extends SystemException

Remarks

The TypeInitializationException class represents the exception that is thrown when the type's class initializer (.cctor) throws an exception.

When it is created, it is passed a reference to the exception thrown by the type's initializer.

The InnerException property holds the underlying exception.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

TypeInitializationException Members | System Namespace


TypeInitializationException Members

Public:

Constructor

TypeInitializationException Constructor Initializes an instance of the TypeInitializationnException class with the given message and given root cause exception.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]
TypeName | Holds the fully resolved name of the type that resulted in the exception.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

TypeInitializationException Class | System Namespace


TypeInitializationException Constructor

Initializes an instance of the TypeInitializationnException class with the given message and given root cause exception.

[Visual Basic]
Public Sub New( _
   ByVal fullTypeName As String, _
   ByVal inner As Exception _
)
[C#]
public TypeInitializationException(
   string fullTypeName,
   Exception inner
);
[C++]
public: TypeInitializationException(
   String* fullTypeName,
   Exception* inner
);
[JScript]
public function TypeInitializationException(
   fullTypeName : String,
   inner : Exception
);

Parameters

fullTypeName
The fully qualiified name of the type that failed to initialize.
inner
A reference to an exception.

Remarks

When handling exceptions, it is sometimes desirable to throw another exception, one which is more indicative of the error that has occurred. In order that the original exception and the information that it carries is not lost, exceptions have a field that can hold a reference to another exception.

The ErrorCode property is set to COR_E_TYPEINITIALIZATION.When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

See Also

TypeInitializationException Class | TypeInitializationException Members | System Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypeInitializationException Properties

The properties of the TypeInitializationException class are listed below. For a complete list of TypeInitializationException class members, see the TypeInitializationException Members topic.

Public:

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]
TypeName | Holds the fully resolved name of the type that resulted in the exception.

See Also

TypeInitializationException Class | System Namespace


TypeInitializationException.TypeName

Holds the fully resolved name of the type that resulted in the exception.

[Visual Basic]
Public ReadOnly Property TypeName As String
[C#]
public string TypeName {get;}
[C++]
public: __property String* get_TypeName();
[JScript]
public function get TypeName() : String;

Property Value

Read-only.

Remarks

The TypeName property returns a fully qualified type name that caused the exception.

See Also

TypeInitializationException Class | TypeInitializationException Members | System Namespace


TypeLoadException Class

Retrieves messages when type-loading failures occur.

Object
Exception
SystemException
TypeLoadException

[Visual Basic]
Public Class TypeLoadException
   Inherits SystemException
[C#]
public class TypeLoadException : SystemException
[C++]
public __gc class TypeLoadException : public SystemException
[JScript]
public class TypeLoadException extends SystemException

Remarks

TypeLoadException is the exception class for type loading failures.

TypeLoadExceptions are thrown when the method that calls the type in question is jitted and the runtime cannot load the type. To catch any exception, the calling method must be enclosed in a try-catch block. However, when the method being jitted is Main(), there can be no outer block, and therefore there is no way to catch the TypeLoadException.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

TypeLoadException Members | System Namespace


TypeLoadException Members

Public:

Constructor

TypeLoadException Constructor Overloaded. Creates a new instance of the TypeLoadException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message | Holds the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]
TypeName | Holds the fully resolved name of the type that resulted in the exception.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData | Sets the SerializationInfo with all of the data needed to serialize the target object.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

TypeLoadException Class | System Namespace


TypeLoadException Constructor

Creates a new instance of the TypeLoadException class.

Overload List

Creates a new instance of the TypeLoadException with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public TypeLoadException();
[C++] public: TypeLoadException();
[JScript] public function TypeLoadException();

Creates a new instance of the TypeLoadException with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public TypeLoadException(String);
[C++] public: TypeLoadException(String*);
[JScript] public function TypeLoadException(String);

Creates a new instance of the TypeLoadException with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public TypeLoadException(String, Exception);
[C++] public: TypeLoadException(String*, Exception);
[JScript] public function TypeLoadException(String, Exception);

See Also

TypeLoadException Class | TypeLoadException Members | System Namespace


TypeLoadException Constructor ()

Creates a new instance of the TypeLoadException with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public TypeLoadException();
[C++]
public: TypeLoadException();
[JScript]
public function TypeLoadException();

Remarks

TypeLoadException inherits from the Exception class. This constructor sets the properties of the TypeLoadException object as follows:

Property Type | Condition
InnerException | null
Message | The empty string.

See Also

TypeLoadException Class | TypeLoadException Members | System Namespace | TypeLoadException Constructor Overload List


TypeLoadException Constructor (String)

Creates a new instance of the TypeLoadException with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public TypeLoadException(
   string message
);
[C++]
public: TypeLoadException(
   String* message
);
[JScript]
public function TypeLoadException(
   message : String
);

Parameters

message
A message providing the reason that the exception occurred.

Remarks

TypeLoadException inherits from the Exception class. This constructor sets the properties of the TypeLoadException object as follows:

Property Type | Condition
InnerException | null
Message | The message string.

See Also

TypeLoadException Class | TypeLoadException Members | System Namespace | TypeLoadException Constructor Overload List


NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypeLoadException Constructor (String, Exception)

Creates a new instance of the TypeLoadException with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public TypeLoadException(
   string message,
   Exception inner
);
[C++]
public: TypeLoadException(
   String* message,
   Exception* inner
);
[JScript]
public function TypeLoadException(
   message : String,
   inner : Exception
);

Parameters

message
A message providing the reason that the exception occurred.
inner
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

TypeLoadException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | The inner exception.
Message | The message string.

See Also

TypeLoadException Class | TypeLoadException Members | System Namespace | TypeLoadException Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypeLoadException Properties

The properties of the TypeLoadException class are listed below. For a complete list of TypeLoadException class members, see the TypeLoadException Members topic.

Public:

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message | Holds the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]
TypeName | Holds the fully resolved name of the type that resulted in the exception.

See Also

TypeLoadException Class | System Namespace


TypeLoadException.Message

Holds the message text.

[Visual Basic]
Overridable Public ReadOnly Property Message As String
[C#]
public string Message {override get;}
[C++]
public: __property virtual String* get_Message();
[JScript]
public function get Message() : String;

Property Value

Read-only.

Remarks

Every exception carries a message that provides information about the exception, such as why it was thrown.

See Also

TypeLoadException Class | TypeLoadException Members | System Namespace


TypeLoadException.TypeName

Holds the fully resolved name of the type that resulted in the exception.

[Visual Basic]
Overridable Public ReadOnly Property TypeName As String
[C#]
public string TypeName {virtual get;}
[C++]
public: __property virtual String* get_TypeName();
[JScript]
public function get TypeName() : String;

Property Value

Read-only.

Remarks

The TypeName property returns a fully qualified type name that caused the exception.

See Also

TypeLoadException Class | TypeLoadException Members | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypeLoadException Methods

The methods of the TypeLoadException class are listed below. For a complete list of TypeLoadException class members, see the TypeLoadException Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData | Sets the SerializationInfo with all of the data needed to serialize the target object.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeLoadException Class | System Namespace


TypeLoadException.GetObjectData

[To be supplied.]

[Visual Basic]
Overrides Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
public: override void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
);
[JScript]
public override function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);

Parameters

info
[To be supplied.]
context
[To be supplied.]

See Also

TypeLoadException Class | TypeLoadException Members | System Namespace


TypeLoadException.SetObjectData

Sets the SerializationInfo with all of the data needed to serialize the target object.

[Visual Basic]
Overrides Public Sub SetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
public override void SetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
public: override void SetObjectData(
   SerializationInfo* info,
   StreamingContext context
);
[JScript]
public override function SetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);

Parameters

info
The object to be populated.
context
The context for the serialization (see StreamingContext).

Return Value

The SerializationInfo data.

Remarks

SerializationInfo object must to return data; if it is null, then SerialzationInfo will throw an ArgumentNullException.

See Also

TypeLoadException Class | TypeLoadException Members | System Namespace


TypeUnloadedException Class

Represents an exception that is thrown when there is an attempt to access an unloaded class.

Object
Exception
SystemException
TypeUnloadedException

[Visual Basic]
Public Class TypeUnloadedException
   Inherits SystemException
[C#]
public class TypeUnloadedException : SystemException
[C++]
public __gc class TypeUnloadedException : public SystemException
[JScript]
public class TypeUnloadedException extends SystemException

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

Example

The TypeUnloadedException is an exception class for attempts to access an unloaded class.

See Also

TypeUnloadedException Members | System Namespace


TypeUnloadedException Members

Public:

Constructor

TypeUnloadedException Constructor Overloaded. Initializes a new instances of the TypeUnloadedException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

TypeUnloadedException Class | System Namespace


TypeUnloadedException Constructor

Initializes a new instances of the TypeUnloadedException class.

Overload List

Initializes a new instance of the TypeUnloadedException class with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public TypeUnloadedException();
[C++] public: TypeUnloadedException();
[JScript] public function TypeUnloadedException();

Initializes a new instance of the TypeUnloadedException with a specified message

[Visual Basic] Overloads Public Sub New(String)
[C#] public TypeUnloadedException(String);
[C++] public: TypeUnloadedException(String*);
[JScript] public function TypeUnloadedException(String);

Initializes a new instance of the classUnloadedException class with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public TypeUnloadedException(String, Exception);
[C++] public: TypeUnloadedException(String*, Exception);
[JScript] public function TypeUnloadedException(String, Exception);

See Also

TypeUnloadedException Class | TypeUnloadedException Members | System Namespace


TypeUnloadedException Constructor ()

Initializes a new instance of the TypeUnloadedException class with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public TypeUnloadedException();
[C++]
public: TypeUnloadedException();
[JScript]
public function TypeUnloadedException();

Remarks

TypeUnloadedException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The empty string.

See Also

TypeUnloadedException Class | TypeUnloadedException Members | System Namespace | TypeUnloadedException Constructor Overload List


TypeUnloadedException Constructor (String)

Initializes a new instance of the TypeUnloadedException with a specified message

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public TypeUnloadedException(
   string message
);
[C++]
public: TypeUnloadedException(
   String* message
);
[JScript]
public function TypeUnloadedException(
   message : String
);

Parameters

message
The message that indicates the reason the exception occurred.

Remarks

TypeUnloadedException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | null
Message | The empty string.

See Also

TypeUnloadedException Class | TypeUnloadedException Members | System Namespace | TypeUnloadedException Constructor Overload List


TypeUnloadedException Constructor (String, Exception)

Initializes a new instance of the classUnloadedException class with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public TypeUnloadedException(
   string message,
   Exception innerException
);
[C++]
public: TypeUnloadedException(
   String* message,
   Exception* innerException
);
[JScript]
public function TypeUnloadedException(
   message : String,
   innerException : Exception
);

Parameters

message
The message that indicates the reason the exception occurred.
innerException
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

TypeUnloadedException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | null
Message | The empty string.

See Also

TypeUnloadedException Class | TypeUnloadedException Members | System Namespace | TypeUnloadedException Constructor Overload List


UInt16 Structure

Represents a 16-bit unsigned integer. The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

Object
ValueType
UInt16

[C#]
public struct UInt16 : IComparable, IFormattable, IConvertible
[C++]
public __value struct UInt16 : public IComparable, IFormattable,
   IConvertible

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks [C#, C++, JScript]

UInt16 will encapsulate a short and provide an Object representation of it.

The UInt16 data type can represent integers with four significant digits in the range from 0 through positive 65535.

UInt16 supports standard widening coercions between Int32, Int64, UInt32, Single, Double, Decimal, and Object. These coercions result in no loss of precision of magnitude.

Requirements [C#, C++, JScript]

Namespace: System

Assembly: mscorlib.dll

See Also

UInt16 Members | System Namespace | Int16


UInt16 Members

Public:

Methods

CompareTo | Compares the current object to another object.
Equals | Compares the current instance with a specified object.
Format | Overloaded. Converts a numeric value to a string.
FromString | Parses a UInt16 from a String.
GetHashCode | Returns the hash code for the current instance.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | Retrieves the type code of an object.
Parse | Overloaded. Converts a String to a UInt16.
ToBoolean | [To be supplied.]
ToByte | [To be supplied.]
ToChar | [To be supplied.]
ToDateTime | [To be supplied.]
ToDecimal | [To be supplied.]
ToDouble | [To be supplied.]
ToInt16 | [To be supplied.]
ToInt32 | [To be supplied.]
ToInt64 | [To be supplied.]
ToSByte | [To be supplied.]
ToSingle | [To be supplied.]
ToString | Overloaded. Converts the current instance of UInt16 to a String.
ToType | [To be supplied.]
ToUInt16 | [To be supplied.]
ToUInt32 | [To be supplied.]
ToUInt64 | [To be supplied.]

Fields

Empty | Constant that represents an empty UInt16.
MaxValue | Constant that represents the largest possible UInt16 value: 65535.
MinValue | Constant that represents the smallest possible UInt16 value: 0.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UInt16 Structure | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UInt16 Methods

The methods of the UInt16 structure are listed below. For a complete list of UInt16 structure members, see the UInt16 Members topic.

Public:

CompareTo | Compares the current object to another object.
Equals | Compares the current instance with a specified object.
Format | Overloaded. Converts a numeric value to a string.
FromString | Parses a UInt16 from a String.
GetHashCode | Returns the hash code for the current instance.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | Retrieves the type code of an object.
Parse | Overloaded. Converts a String to a UInt16.
ToBoolean | [To be supplied.]
ToByte | [To be supplied.]
ToChar | [To be supplied.]
ToDateTime | [To be supplied.]
ToDecimal | [To be supplied.]
ToDouble | [To be supplied.]
ToInt16 | [To be supplied.]
ToInt32 | [To be supplied.]
ToInt64 | [To be supplied.]
ToSByte | [To be supplied.]
ToSingle | [To be supplied.]
ToString | Overloaded. Converts the current instance of UInt16 to a String.
ToType | [To be supplied.]
ToUInt16 | [To be supplied.]
ToUInt32 | [To be supplied.]
ToUInt64 | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UInt16 Structure | System Namespace


UInt16.CompareTo

Compares the current object to another object. The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public virtual int CompareTo(
   object value
);
[C++]
public: virtual int CompareTo(
   Object* value
);
[JScript]
public function CompareTo(
   value : Object
) : int;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

value
The object to compare to the current object.

Return Value [C#, C++, JScript]

Value | Condition
Less than 0 | The current object is less than the object.
0 | The current object is equal to the object.
Greater than 0 | The current object is greater than the object.

Exceptions [C#, C++, JScript]

Exception Type | Condition
ArgumentException | If the object is not a UInt16 type and is not a null reference (in Visual Basic Nothing).

Remarks [C#, C++, JScript]

When the value parameter is null, it is considered to be less than any instance.

See Also

UInt16 Structure | UInt16 Members | System Namespace | Int32 | Object


UInt16.Equals

Compares the current instance with a specified object. The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

obj
The object to compare with the current instance.

Return Value [C#, C++, JScript]

true if the object is a UInt16 with the same value as the current instance; otherwise, false.

Remarks [C#, C++, JScript]

The Equals method compares two objects and returns a Boolean determination of their relationship.

This method overrides Equals.

See Also

UInt16 Structure | UInt16 Members | System Namespace | Boolean


UInt16.Format

Converts a numeric value to a string. The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

Overload List [C#, C++, JScript]

Converts the value of the current instance to a String with the specified format string.

[C#] public virtual string Format(String, IServiceObjectProvider);
[C++] public: virtual String* Format(String*, IServiceObjectProvider);
[JScript] public function Format(String, IServiceObjectProvider) : String;

Converts a numeric value to a String using the specified format string.

[C#] public static string Format(ushort, String, NumberFormatInfo);
[C++] public: static String* Format(unsigned short, String, NumberFormatInfo);
[JScript] public static function Format(UInt16, String, NumberFormatInfo) : String;

Converts a numeric value to a String with the specified format string.

[C#] public static string Format(ushort, String);
[C++] public: static String* Format(unsigned short, String);
[JScript] public static function Format(UInt16, String) : String;

See Also

UInt16 Structure | UInt16 Members | System Namespace


UInt16.Format (String, IServiceObjectProvider)

Converts the value of the current instance to a String with the specified format string. The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public virtual string Format(
   string format,
   IServiceObjectProvider sop
);
[C++]
public: virtual String* Format(
   String* format,
   IServiceObjectProvider* sop
);
[JScript]
public function Format(
   format : String,
   sop : IServiceObjectProvider
) : String;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

format
The format string.
sop
The IServiceObjectProvider used to format the number.

Return Value [C#, C++, JScript]

A string representation of the value of the current instance in the format specified by format.

Remarks [C#, C++, JScript]

If format is null or an empty string, the number is formatted as if the string general format ("G") were specified.

The sop parameter specifies the format provider from which the NumberFormatInfo instance will be obtained. If sop is null, the numeric format information is obtained from the current locale (see NumberFormatInfo and CultureInfo for more information for numeric and culture formats).

NumberFormatInfo supplies information such as the characters to use for decimal and thousand separators, and the spelling and placement of currency symbols in monetary values.

See Also

UInt16 Structure | UInt16 Members | System Namespace | UInt16.Format Overload List | String | NumberStyles | IServiceObjectProvider


UInt16.Format (UInt16, String, NumberFormatInfo)

Converts a numeric value to a String using the specified format string. The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public static string Format(
   ushort value,
   string format,
   NumberFormatInfo info
);
[C++]
public: static String* Format(
   unsigned short value,
   String* format,
   NumberFormatInfo* info
);
[JScript]
public static function Format(
   value : UInt16,
   format : String,
   info : NumberFormatInfo
) : String;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

value
The value to be formatted.
format
The format string.
info
The NumberFormatInfo instance used to format the number.

Return Value [C#, C++, JScript]

A string representation of value in the format specified by format.

Remarks [C#, C++, JScript]

The Format method converts a numeric value to a string using the format string given by format. If format is null or an empty string, value is formatted as if the string general format ("G") were specified.

The info parameter specifies the NumberFormatInfo instance used to format the number. If info is null, the numeric format information is obtained from the current locale (see CultureInfo for inforamtion on specific cultures).

The NumberFormatInfo supplies information such as the characters to use for decimal and thousand separators, and the spelling and placement of currency symbols in monetary values.

See Also

UInt16 Structure | UInt16 Members | System Namespace | UInt16.Format Overload List | String | NumberStyles


UInt16.Format (UInt16, String)

Converts a numeric value to a String with the specified format string. The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public static string Format(
   ushort value,
   string format
);
[C++]
public: static String* Format(
   unsigned short value,
   String* format
);
[JScript]
public static function Format(
   value : UInt16,
   format : String
) : String;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

value
The value to be formatted.
format
The format string.

Return Value [C#, C++, JScript]

A string representation of value in the format specified by format.

Remarks [C#, C++, JScript]

The Format method converts a numeric value to a string using the format string given by format. If format is null or an empty string, value is formatted as if the string general format ("G") were specified.

The numeric format information is obtained from the current locale (see NumberFormatInfo and CultureInfo for more information on specific numeric and cultures).

See Also

UInt16 Structure | UInt16 Members | System Namespace | UInt16.Format Overload List | String


UInt16.FromString

Parses a UInt16 from a String. The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public static ushort FromString(
   string s
);
[C++]
public: static unsigned short FromString(
   String* s
);
[JScript]
public static function FromString(
   s : String
) : UInt16;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

s
A string containing a number.

Return Value [C#, C++, JScript]

The Int16 parsed from s.

Exceptions [C#, C++, JScript]

Exception Type | Condition
ArgumentNullException | If the string is a null reference (in Visual Basic Nothing).
FormatException | If the string isn't a real number.
OverflowException | If the number is greater than positive 32767or less than negative 32768.

Remarks [C#, C++, JScript]

FromString parses an unsigned short from a string.

The default (culture-neutral) is NumberFormatInfo is used (see NumberFormatInfo and CultureInfo for more information for numeric and culture formats).

Use Parse and Format for culture dependent strings.

The output from ToString should be consumable by FromString().

See Also

UInt16 Structure | UInt16 Members | System Namespace | String | NumberStyles


UInt16.GetHashCode

Returns the hash code for the current instance. The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

Return Value [C#, C++, JScript]

A hash code for the current instance.

Remarks [C#, C++, JScript]

GetHashCode performs a search and returns the hash code for Int16.

See Also

UInt16 Structure | UInt16 Members | System Namespace | Int16 | IHashCodeProvider


UInt16.GetTypeCode

Retrieves the type code of an object. The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public virtual TypeCode GetTypeCode();
[C++]
public: virtual TypeCode GetTypeCode();
[JScript]
public function GetTypeCode() : TypeCode;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

Return Value [C#, C++, JScript]

A type code.

Remarks [C#, C++, JScript]

The GetTypeCode method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See TypeCode enumeration for more information about type codes.)

See Also

UInt16 Structure | UInt16 Members | System Namespace | IConvertible | TypeCode


UInt16.Parse

Converts a String to a UInt16. The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

Overload List [C#, C++, JScript]

Converts a String to a UInt16.

[C#] public static ushort Parse(String);
[C++] public: static unsigned short Parse(String*);
[JScript] public static function Parse(String) : UInt16;

Converts a String representation of a value to an UInt16 with the NumberStyles enumeration formatted by NumberFormatInfo.

[C#] public static ushort Parse(String, NumberStyles, NumberFormatInfo);
[C++] public: static unsigned short Parse(String*, NumberStyles, NumberFormatInfo);
[JScript] public static function Parse(String, NumberStyles, NumberFormatInfo) : UInt16;

Converts a string representation of a value to a UInt16 with the NumberStyles enumeration.

[C#] public static ushort Parse(String, NumberStyles);
[C++] public: static unsigned short Parse(String*, NumberStyles);
[JScript] public static function Parse(String, NumberStyles) : UInt16;

See Also

UInt16 Structure | UInt16 Members | System Namespace


UInt16.Parse (String)

Converts a String to a UInt16. The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public static ushort Parse(
   string s
);
[C++]
public: static unsigned short Parse(
   String* s
);
[JScript]
public static function Parse(
   s : String
) : UInt16;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

s
The string to convert to a UInt16.

Return Value [C#, C++, JScript]

The UInt16 value of the string.

Exceptions [C#, C++, JScript]

Exception Type | Condition
ArgumentNullException | If the sting is a null reference (in Visual Basic Nothing).
FormatException | If the string contains a character other than a minus sign ("-") or the digits 0 through 9.
OverflowException | If s represents a number that is less than MinValue or greater than MaxValue.

Remarks [C#, C++, JScript]

The Parse method converts a String to a UInt16. The string must consist of an optional minus sign ("-") followed by a sequence of digits ("0" through "9").

Leading and trailing white space characters are ignored.

Note Hexadecimal strings ("0x42") are not supported. Use Value or Convert ToIntxx(string, int) and ToUIntxx methods for the conversions.
Note The Parse method does not accept not a number (NaN) or positive or negative infinity.

See Also

UInt16 Structure | UInt16 Members | System Namespace | UInt16.Parse Overload List | String | Value | Convert | NaN | NaN | PositiveInfinity | PositiveInfinity | NegativeInfinity | NegativeInfinity


UInt16.Parse (String, NumberStyles, NumberFormatInfo)

Converts a String representation of a value to an UInt16 with the NumberStyles enumeration formatted by NumberFormatInfo. The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public static ushort Parse(
   string s,
   NumberStyles style,
   NumberFormatInfo info
);
[C++]
public: static unsigned short Parse(
   String* s,
   NumberStyles style,
   NumberFormatInfo* info
);
[JScript]
public static function Parse(
   s : String,
   style : NumberStyles,
   info : NumberFormatInfo
) : UInt16;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

s
The string to be interpreted.
style
The permitted style of the numeric string.
info
The NumberFormatInfo instance used to format the string.

Return Value [C#, C++, JScript]

A UInt16 with the value represented by s.

Exceptions [C#, C++, JScript]

Exception Type | Condition
ArgumentException | If the style is not a NumberStyles enumeration.
ArgumentNullException | If the string is a null reference (in Visual Basic Nothing).
FormatException | If the string is not of the correct format.
OverflowException | If the string represents a number that is less than MinValue or greater than MaxValue.

See Also

UInt16 Structure | UInt16 Members | System Namespace | UInt16.Parse Overload List | String | NaN | NaN | PositiveInfinity | PositiveInfinity | NegativeInfinity | NegativeInfinity | Value | Convert


UInt16.Parse (String, NumberStyles)

Converts a string representation of a value to a UInt16 with the NumberStyles enumeration. The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public static ushort Parse(
   string s,
   NumberStyles style
);
[C++]
public: static unsigned short Parse(
   String* s,
   NumberStyles style
);
[JScript]
public static function Parse(
   s : String,
   style : NumberStyles
) : UInt16;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

s
The string to be interpreted.
style
The permitted style of the numeric string.

Return Value [C#, C++, JScript]

A UInt16 with the value represented by s.

Exceptions [C#, C++, JScript]

Exception Type | Condition
ArgumentException | If the style is not a NumberStyles enumeration.
ArgumentNullException | If the string is a null reference (in Visual Basic Nothing).
FormatException | If the string is not of the correct format.
OverflowException | If the string represents a number that is less than MinValue or greater than MaxValue.

Remarks [C#, C++, JScript]

The numeric format information is obtained from the current locale. If s has been created by one of the Format methods using C, D, E, F, G, or N as the format specifier, it is guaranteed that s can be parsed when style is Any of NumberStyles.

The style parameter must be a combination of bit flags from the NumberStyles enumeration.

Note Hexadecimal strings ("0x42") are not supported. Use the Convert ToIntxx(string, int) and ToUIntxx methods for the conversions. ReplaceThisText
Note The Parse methods do not accept not a number (NaN) or positive or negative infinity.

See Also

UInt16 Structure | UInt16 Members | System Namespace | UInt16.Parse Overload List | String | NaN | NaN | PositiveInfinity | PositiveInfinity | NegativeInfinity | NegativeInfinity | Value | Convert


UInt16.ToBoolean

[To be supplied.] The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public virtual bool ToBoolean();
[C++]
public: virtual bool ToBoolean();
[JScript]
public function ToBoolean() : Boolean;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

See Also

UInt16 Structure | UInt16 Members | System Namespace


UInt16.ToByte

[To be supplied.] The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public virtual byte ToByte();
[C++]
public: virtual unsigned char ToByte();
[JScript]
public function ToByte() : Byte;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

See Also

UInt16 Structure | UInt16 Members | System Namespace


UInt16.ToChar

[To be supplied.] The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public virtual char ToChar();
[C++]
public: virtual __wchar_t ToChar();
[JScript]
public function ToChar() : Char;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

See Also

UInt16 Structure | UInt16 Members | System Namespace


UInt16.ToDateTime

[To be supplied.] The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public virtual DateTime ToDateTime();
[C++]
public: virtual DateTime ToDateTime();
[JScript]
public function ToDateTime() : DateTime;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

See Also

UInt16 Structure | UInt16 Members | System Namespace


UInt16.ToDecimal

[To be supplied.] The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public virtual Decimal ToDecimal();
[C++]
public: virtual Decimal ToDecimal();
[JScript]
public function ToDecimal() : Decimal;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

See Also

UInt16 Structure | UInt16 Members | System Namespace


UInt16.ToDouble

[To be supplied.] The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public virtual double ToDouble();
[C++]
public: virtual double ToDouble();
[JScript]
public function ToDouble() : double;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

See Also

UInt16 Structure | UInt16 Members | System Namespace


UInt16.ToInt16

[To be supplied.] The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public virtual short ToInt16();
[C++]
public: virtual short ToInt16();
[JScript]
public function ToInt16() : Int16;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

See Also

UInt16 Structure | UInt16 Members | System Namespace


UInt16.ToInt32

[To be supplied.] The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public virtual int ToInt32();
[C++]
public: virtual int ToInt32();
[JScript]
public function ToInt32() : int;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

See Also

UInt16 Structure | UInt16 Members | System Namespace


UInt16.ToInt64

[To be supplied.] The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public virtual long ToInt64();
[C++]
public: virtual __int64 ToInt64();
[JScript]
public function ToInt64() : long;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

See Also

UInt16 Structure | UInt16 Members | System Namespace


UInt16.ToSByte

[To be supplied.] The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public virtual sbyte ToSByte();
[C++]
public: virtual char ToSByte();
[JScript]
public function ToSByte() : SByte;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

See Also

UInt16 Structure | UInt16 Members | System Namespace


UInt16.ToSingle

[To be supplied.] The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public virtual float ToSingle();
[C++]
public: virtual float ToSingle();
[JScript]
public function ToSingle() : float;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

See Also

UInt16 Structure | UInt16 Members | System Namespace


UInt16.ToString

Converts the current instance of UInt16 to a String. The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

Overload List [C#, C++, JScript]

Converts a specified UInt16 to a String.

[C#] public static string ToString(ushort);
[C++] public: static String* ToString(unsigned short);
[JScript] public static function ToString(UInt16) : String;

Converts the value represented by the current UInt16 instance to a String.

[C#] public override string ToString();
[C++] public: override String* ToString();
[JScript] public override function ToString() : String;

See Also

UInt16 Structure | UInt16 Members | System Namespace


UInt16.ToString (UInt16)

Converts a specified UInt16 to a String. The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public static string ToString(
   ushort i
);
[C++]
public: static String* ToString(
   unsigned short i
);
[JScript]
public static function ToString(
   i : UInt16
) : String;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

i
The UInt16 value to be converted.

Return Value [C#, C++, JScript]

The result of converting the argument to a string.

Remarks [C#, C++, JScript]

The ToString method converts a specified UInt16 to a String in base 10 with no extra padding.

If this instance is negative, the first charter in the string returned will be a minus sign ("-"). No sign character is returned if the number is not negative. The rest of the string returned is made up of characters representing the magnitude of the current instance, not to include leading zero characters ("0").

The following characters are allowable digits: 0, 1, 2, 3, 4, 5, 6, 7, 8, and 9.

The output from ToString should be consumable by FromString.

See Also

UInt16 Structure | UInt16 Members | System Namespace | UInt16.ToString Overload List | String | Format | Convert


UInt16.ToString ()

Converts the value represented by the current UInt16 instance to a String. The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

Return Value [C#, C++, JScript]

The result of converting the current UInt16 to a string.

Remarks [C#, C++, JScript]

The ToString method converts the value represented by the current UInt16 instance to a String in base 10 with no extra padding.

If this instance is negative, the first charter in the string returned will be "-". No sign character is returned if the number is not negative. The rest of the string returned is made up of characters representing the magnitude of the current instance, not to include leading zero characters ("0").

The following characters are allowable digits: 0, 1, 2, 3, 4, 5, 6, 7, 8, and 9.

Overrides ToString.

The output from ToString should be consumable by FromString.

See Also

UInt16 Structure | UInt16 Members | System Namespace | UInt16.ToString Overload List | String | Format | Convert


UInt16.ToType

[To be supplied.] The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public virtual object ToType(
   Type type
);
[C++]
public: virtual Object* ToType(
   Type* type
);
[JScript]
public function ToType(
   type : Type
) : Object;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

type
[To be supplied.]

See Also

UInt16 Structure | UInt16 Members | System Namespace


UInt16.ToUInt16

[To be supplied.] The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public virtual ushort ToUInt16();
[C++]
public: virtual unsigned short ToUInt16();
[JScript]
public function ToUInt16() : UInt16;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

See Also

UInt16 Structure | UInt16 Members | System Namespace


UInt16.ToUInt32

[To be supplied.] The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public virtual uint ToUInt32();
[C++]
public: virtual unsigned int ToUInt32();
[JScript]
public function ToUInt32() : UInt32;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

See Also

UInt16 Structure | UInt16 Members | System Namespace


UInt16.ToUInt64

[To be supplied.] The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public virtual ulong ToUInt64();
[C++]
public: virtual unsigned __int64 ToUInt64();
[JScript]
public function ToUInt64() : UInt64;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

See Also

UInt16 Structure | UInt16 Members | System Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UInt16 Fields

The fields of the UInt16 structure are listed below. For a complete list of UInt16 structure members, see the UInt16 Members topic.

Public:

Empty | Constant that represents an empty UInt16.
MaxValue | Constant that represents the largest possible UInt16 value: 65535.
MinValue | Constant that represents the smallest possible UInt16 value: 0.

See Also

UInt16 Structure | System Namespace


UInt16.Empty

Constant that represents an empty UInt16. The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public const ushort Empty;
[C++]
public: const unsigned short Empty;
[JScript]
public var Empty : UInt16;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

Remarks [C#, C++, JScript]

The hexadecimal value for Empty is MinValue, which is 0.

See Also

UInt16 Structure | UInt16 Members | System Namespace | Empty


UInt16.MaxValue

Constant that represents the largest possible UInt16 value: 65535. The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public const ushort MaxValue;
[C++]
public: const unsigned short MaxValue;
[JScript]
public var MaxValue : UInt16;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

Remarks [C#, C++, JScript]

The MaxValue hexadecimal value is 0xFFFF.

See Also

UInt16 Structure | UInt16 Members | System Namespace


UInt16.MinValue

Constant that represents the smallest possible UInt16 value: 0. The UInt16 type is not CLS compliant. The CLS-compliant alternative is Int16.

[C#]
public const ushort MinValue;
[C++]
public: const unsigned short MinValue;
[JScript]
public var MinValue : UInt16;

[Visual Basic] The UInt16 type cannot be used in Visual Basic.

Remarks [C#, C++, JScript]

The MinValue hexadecimal value is 0.

See Also

UInt16 Structure | UInt16 Members | System Namespace


UInt32 Structure

Represents a 32-bit unsigned integer. The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

Object
ValueType
UInt32

[C#]
public struct UInt32 : IComparable, IFormattable, IConvertible
[C++]
public __value struct UInt32 : public IComparable, IFormattable,
   IConvertible

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks [C#, C++, JScript]

The UInt32 class encapsulates a 32-bit unsigned integer (uint) and provides an object representation of it.

The UInt32 data type represents positive integers with 9 significant digits in the range from 0 through positive 4,294,967,295.

Requirements [C#, C++, JScript]

Namespace: System

Assembly: mscorlib.dll

See Also

UInt32 Members | System Namespace | IFormattable | IComparable | IConvertible | Int32 | Object


UInt32 Members

Public:

Methods

CompareTo | Compares the current object to another object.
Equals | Compares the current instance with a specified object.
Format | Overloaded. Converts a numeric value to a string.
FromString | Parses an UInt32 from a String.
GetHashCode | Returns the hash code for the current UInt32.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | Retrieves the type code of an object.
Parse | Overloaded. Converts a String to a UInt32.
ToBoolean | [To be supplied.]
ToByte | [To be supplied.]
ToChar | [To be supplied.]
ToDateTime | [To be supplied.]
ToDecimal | [To be supplied.]
ToDouble | [To be supplied.]
ToInt16 | [To be supplied.]
ToInt32 | [To be supplied.]
ToInt64 | [To be supplied.]
ToSByte | [To be supplied.]
ToSingle | [To be supplied.]
ToString | Overloaded. Converts the current instance of UInt32 to a String.
ToType | [To be supplied.]
ToUInt16 | [To be supplied.]
ToUInt32 | [To be supplied.]
ToUInt64 | [To be supplied.]

Fields

Empty | Represents the constant that is an empty UInt32 value: 0.
MaxValue | Represents the constant that is the largest possible UInt32 value: 4, 294, 967, 295.
MinValue | Represents the constant that is the smallest possible UInt32 value: 0.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UInt32 Structure | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UInt32 Methods

The methods of the UInt32 structure are listed below. For a complete list of UInt32 structure members, see the UInt32 Members topic.

Public:

CompareTo | Compares the current object to another object.
Equals | Compares the current instance with a specified object.
Format | Overloaded. Converts a numeric value to a string.
FromString | Parses an UInt32 from a String.
GetHashCode | Returns the hash code for the current UInt32.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | Retrieves the type code of an object.
Parse | Overloaded. Converts a String to a UInt32.
ToBoolean | [To be supplied.]
ToByte | [To be supplied.]
ToChar | [To be supplied.]
ToDateTime | [To be supplied.]
ToDecimal | [To be supplied.]
ToDouble | [To be supplied.]
ToInt16 | [To be supplied.]
ToInt32 | [To be supplied.]
ToInt64 | [To be supplied.]
ToSByte | [To be supplied.]
ToSingle | [To be supplied.]
ToString | Overloaded. Converts the current instance of UInt32 to a String.
ToType | [To be supplied.]
ToUInt16 | [To be supplied.]
ToUInt32 | [To be supplied.]
ToUInt64 | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UInt32 Structure | System Namespace


UInt32.CompareTo

Compares the current object to another object. The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public virtual int CompareTo(
   object value
);
[C++]
public: virtual int CompareTo(
   Object* value
);
[JScript]
public function CompareTo(
   value : Object
) : int;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

value
The object to compare with the current object.

Return Value [C#, C++, JScript]

Value | Meaning
Less than 0 | The current object is less than the specified object.
0 | The current object is equal to the specified object.
Greater than 0 | The current object is greater than the specified object.

Exceptions [C#, C++, JScript]

Exception Type | Condition
ArgumentException | If the object is not a UInt32 type.

Remarks [C#, C++, JScript]

The CompareTo method determines whether the relationship of the current object to another object and returns an integer that indicates that relationship.

The object must be a UInt32 type. The value null is less than any instance.

Note You need to use compare rather than subtraction because it will wrap large negative numbers to positive.

See Also

UInt32 Structure | UInt32 Members | System Namespace | Object


UInt32.Equals

Compares the current instance with a specified object. The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

obj
The object to compare with the current instance.

Return Value [C#, C++, JScript]

true if the object is a UInt32 the same value as the current instance; otherwise, false.

Remarks [C#, C++, JScript]

The Equals method determines whether two objects are of equal value and returns a true or false result.

This method overrides Equals.

See Also

UInt32 Structure | UInt32 Members | System Namespace | Boolean


UInt32.Format

Converts a numeric value to a string. The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

Overload List [C#, C++, JScript]

Converts the value of the current instance to a string with the specified format string.

[C#] public virtual string Format(String, IServiceObjectProvider);
[C++] public: virtual String* Format(String*, IServiceObjectProvider);
[JScript] public function Format(String, IServiceObjectProvider) : String;

Converts a numeric value to a String with the specified format string.

[C#] public static string Format(uint, String, NumberFormatInfo);
[C++] public: static String* Format(unsigned int, String, NumberFormatInfo);
[JScript] public static function Format(UInt32, String, NumberFormatInfo) : String;

Converts a numeric value to a String with the specified format string.

[C#] public static string Format(uint, String);
[C++] public: static String* Format(unsigned int, String);
[JScript] public static function Format(UInt32, String) : String;

See Also

UInt32 Structure | UInt32 Members | System Namespace


UInt32.Format (String, IServiceObjectProvider)

Converts the value of the current instance to a string with the specified format string. The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public virtual string Format(
   string format,
   IServiceObjectProvider sop
);
[C++]
public: virtual String* Format(
   String* format,
   IServiceObjectProvider* sop
);
[JScript]
public function Format(
   format : String,
   sop : IServiceObjectProvider
) : String;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

format
The format string.
sop
The IServiceObjectProvider used to format the number.

Return Value [C#, C++, JScript]

A String representation for the value of the current instance in the format specified by format.

Remarks [C#, C++, JScript]

The Format method converts the value of the current instance to a string using the format string given by format.

If format is null or an empty string, the number is formatted as if the general format ("G") string were specified.

The sop parameter specifies the format provider from which the NumberFormatInfo instance will be obtained. NumberFormatInfo supplies information such as the characters to use for decimal and thousand separators, and the spelling and placement of currency symbols in monetary values.

If sop is null, the numeric format information is obtained from the current locale (see NumberFormatInfo and CultureInfo for more information on numeric and culture formats).

See Also

UInt32 Structure | UInt32 Members | System Namespace | UInt32.Format Overload List | String | IServiceObjectProvider | Object | NumberStyles


UInt32.Format (UInt32, String, NumberFormatInfo)

Converts a numeric value to a String with the specified format string. The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public static string Format(
   uint value,
   string format,
   NumberFormatInfo info
);
[C++]
public: static String* Format(
   unsigned int value,
   String* format,
   NumberFormatInfo* info
);
[JScript]
public static function Format(
   value : UInt32,
   format : String,
   info : NumberFormatInfo
) : String;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

value
The value to be formatted.
format
The format string.
info
The NumberFormatInfo instance used to format the number.

Return Value [C#, C++, JScript]

A string that represents of value in the format specified by format.

Remarks [C#, C++, JScript]

The Format method converts a numeric value to a string using the format string specified by format. If format is null or an empty string, value is formatted as if the general format ("G") string were specified.

The info parameter specifies the NumberFormatInfo instance used to format the number. NumberFormatInfo supplies information such as the characters to use for decimal and thousand separators, and the spelling and placement of currency symbols in monetary values.

If info is null, the numeric format information is obtained from the current locale (see NumberFormatInfo and CultureInfo for more information on numeric and culture formats).

See Also

UInt32 Structure | UInt32 Members | System Namespace | UInt32.Format Overload List | String | NumberStyles


UInt32.Format (UInt32, String)

Converts a numeric value to a String with the specified format string. The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public static string Format(
   uint value,
   string format
);
[C++]
public: static String* Format(
   unsigned int value,
   String* format
);
[JScript]
public static function Format(
   value : UInt32,
   format : String
) : String;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

value
The value to be formatted.
format
The format string.

Return Value [C#, C++, JScript]

A string representation of value in the format specified by format.

Remarks [C#, C++, JScript]

The Format method converts a numeric value to a string using the format string specified by format. If format is null or an empty string, value is formatted as if the general format ("G") string were specified.

The numeric format information is obtained from the current locale (see NumberFormatInfo and CultureInfo for more information on numeric and culture formats).

See Also

UInt32 Structure | UInt32 Members | System Namespace | UInt32.Format Overload List | String | NumberStyles


UInt32.FromString

Parses an UInt32 from a String. The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public static uint FromString(
   string s
);
[C++]
public: static unsigned int FromString(
   String* s
);
[JScript]
public static function FromString(
   s : String
) : UInt32;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

s
A string containing a number.

Return Value [C#, C++, JScript]

A UInt32 parsed from s.

Exceptions [C#, C++, JScript]

Exception Type | Condition
ArgumentNullException | If the string is a null reference (in Visual Basic Nothing).
FormatException | If the string doesn't contain a real number.
OverflowException | If the number is greater than positive 32767 or less than negative 32768.

Remarks [C#, C++, JScript]

The UInt32 method returns an unsigned int from parsing a string. The default (locale-neutral) NumberFormatInfo is used (see NumberFormatInfo or CultureInfo for more information on numeric and culture formats).

The output from ToString should be consumable by FromString.

Use Parse and Format for culture dependent strings.

See Also

UInt32 Structure | UInt32 Members | System Namespace


UInt32.GetHashCode

Returns the hash code for the current UInt32. The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

Return Value [C#, C++, JScript]

The absolute value of the Int32.

Remarks [C#, C++, JScript]

GetHashCode performs a search and returns the hash code for Int32.

See Also

UInt32 Structure | UInt32 Members | System Namespace | Int32 | IHashCodeProvider


UInt32.GetTypeCode

Retrieves the type code of an object. The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public virtual TypeCode GetTypeCode();
[C++]
public: virtual TypeCode GetTypeCode();
[JScript]
public function GetTypeCode() : TypeCode;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

Return Value [C#, C++, JScript]

A type code.

Remarks [C#, C++, JScript]

The GetTypeCode method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See TypeCode enumeration for more information about type codes.)

See Also

UInt32 Structure | UInt32 Members | System Namespace | IConvertible | TypeCode


UInt32.Parse

Converts a String to a UInt32. The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

Overload List [C#, C++, JScript]

Converts a String to a UInt32.

[C#] public static uint Parse(String);
[C++] public: static unsigned int Parse(String*);
[JScript] public static function Parse(String) : UInt32;

Converts a String representation of a value to a UInt32.

[C#] public static uint Parse(String, NumberStyles, NumberFormatInfo);
[C++] public: static unsigned int Parse(String*, NumberStyles, NumberFormatInfo);
[JScript] public static function Parse(String, NumberStyles, NumberFormatInfo) : UInt32;

Converts a String representation of a value to a UInt32.

[C#] public static uint Parse(String, NumberStyles);
[C++] public: static unsigned int Parse(String*, NumberStyles);
[JScript] public static function Parse(String, NumberStyles) : UInt32;

See Also

UInt32 Structure | UInt32 Members | System Namespace


UInt32.Parse (String)

Converts a String to a UInt32. The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public static uint Parse(
   string s
);
[C++]
public: static unsigned int Parse(
   String* s
);
[JScript]
public static function Parse(
   s : String
) : UInt32;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

s
The string to be converted to a UInt32.

Return Value [C#, C++, JScript]

The UInt32 value of the string.

Exceptions [C#, C++, JScript]

Exception Type | Condition
ArgumentNullException | If the string is a null reference (in Visual Basic Nothing).
FormatException | If the string contains a character other than the minus sign ("-") or the digits 0 through 9.
OverflowException | If the string represents a number that is less than MinValue or greater than MaxValue.

Remarks [C#, C++, JScript]

The numeric format information is obtained from the current locale (see NumberFormatInfo and CultureInfo for more information for numeric and culture formats). The string s should be the return value of one of the format methods.

The string must consist of an optional minus sign ("-") followed by a sequence of digits ("0" through "9").

Leading and trailing white space characters are ignored.

Note Hexadecimal strings ("0x42") are not supported. Use the Value or Convert ToIntxx(string, int) and ToUIntxx methods for the conversions.
Note The Parse methods do not accept not a number (NaN) or positive or negative infinity.

See Also

UInt32 Structure | UInt32 Members | System Namespace | UInt32.Parse Overload List | String | Value | Convert | MaxValue | MinValue | NaN | NaN | PositiveInfinity | PositiveInfinity | NegativeInfinity | NegativeInfinity


UInt32.Parse (String, NumberStyles, NumberFormatInfo)

Converts a String representation of a value to a UInt32. The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public static uint Parse(
   string s,
   NumberStyles style,
   NumberFormatInfo info
);
[C++]
public: static unsigned int Parse(
   String* s,
   NumberStyles style,
   NumberFormatInfo* info
);
[JScript]
public static function Parse(
   s : String,
   style : NumberStyles,
   info : NumberFormatInfo
) : UInt32;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

s
The string to be interpreted.
style
The permitted style of the numeric string.
info
The NumberFormatInfo instance used to format the string.

Return Value [C#, C++, JScript]

A UInt32 with the value represented by s.

Exceptions [C#, C++, JScript]

Exception Type | Condition
ArgumentException | If style is not a NumberStyles enumeration.
ArgumentNullException | If the string is a null reference (in Visual Basic Nothing).
FormatException | If the string is not in the correct format.
OverflowException | If the string represents a number that is less than MinValue or greater than MaxValue.

Remarks [C#, C++, JScript]

The Parse method converts a string to a numeric value.

If s has been created by one of the Format methods using C, D, E, F, G, or N as the format specifier, it is guaranteed that s can be parsed when style is NumberStyles enumeration.

The style parameter must be a combination of bit flags from the NumberStyles enumeration.

If the info parameter is null, the numeric format information is obtained from the current locale (see NumberFormatInfo and CultureInfo for more information on numeric and culture formats).

Note Hexadecimal strings ("0x42") are not supported. Use Value or Convert ToIntxx(string, int) and ToUIntxx methods for the conversions.
Note The Parse methods do not accept not a number (NaN) or positive or negative infinity.

See Also

UInt32 Structure | UInt32 Members | System Namespace | UInt32.Parse Overload List | String | Value | Convert | MaxValue | MinValue | NaN | NaN | PositiveInfinity | PositiveInfinity | NegativeInfinity | NegativeInfinity


UInt32.Parse (String, NumberStyles)

Converts a String representation of a value to a UInt32. The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public static uint Parse(
   string s,
   NumberStyles style
);
[C++]
public: static unsigned int Parse(
   String* s,
   NumberStyles style
);
[JScript]
public static function Parse(
   s : String,
   style : NumberStyles
) : UInt32;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

s
The string to be interpreted.
style
The permitted style of the numeric string.

Return Value [C#, C++, JScript]

A UInt32 with the value represented by s.

Exceptions [C#, C++, JScript]

Exception Type | Condition
ArgumentException | If style is not a NumberStyles enumeration.
ArgumentNullException | If the string is a null reference (in Visual Basic Nothing).
FormatException | If the string is not of the correct format.
OverflowException | If the string represents a number that is less than MinValue or greater than MaxValue.

Remarks [C#, C++, JScript]

If s has been created by one of the Format methods using C, D, E, F, G, or N as the format specifier, it is guaranteed that s can be parsed when style is NumberStyles enumeration.

The style parameter specifies the permitted style of the numeric string. It must be a combination of bit flags from the NumberStyles enumeration. The numeric format information is obtained from the current locale (see NumberFormatInfo and CultureInfo for more information on numeric and culture formats).

The style must be a combination of bit flags from the NumberStyles enumeration.

Note Hexadecimal strings ("0x42") are not supported. Use Value or Convert ToIntxx(string, int) and ToUIntxx methods for the conversions.
Note The Parse methods do not accept not a number (NaN) or positive or negative infinity.

See Also

UInt32 Structure | UInt32 Members | System Namespace | UInt32.Parse Overload List | String | Value | Convert | NaN | NaN | PositiveInfinity | PositiveInfinity | NegativeInfinity | NegativeInfinity | MaxValue | MinValue


UInt32.ToBoolean

[To be supplied.] The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public virtual bool ToBoolean();
[C++]
public: virtual bool ToBoolean();
[JScript]
public function ToBoolean() : Boolean;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

See Also

UInt32 Structure | UInt32 Members | System Namespace


UInt32.ToByte

[To be supplied.] The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public virtual byte ToByte();
[C++]
public: virtual unsigned char ToByte();
[JScript]
public function ToByte() : Byte;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

See Also

UInt32 Structure | UInt32 Members | System Namespace


UInt32.ToChar

[To be supplied.] The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public virtual char ToChar();
[C++]
public: virtual __wchar_t ToChar();
[JScript]
public function ToChar() : Char;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

See Also

UInt32 Structure | UInt32 Members | System Namespace


UInt32.ToDateTime

[To be supplied.] The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public virtual DateTime ToDateTime();
[C++]
public: virtual DateTime ToDateTime();
[JScript]
public function ToDateTime() : DateTime;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

See Also

UInt32 Structure | UInt32 Members | System Namespace


UInt32.ToDecimal

[To be supplied.] The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public virtual Decimal ToDecimal();
[C++]
public: virtual Decimal ToDecimal();
[JScript]
public function ToDecimal() : Decimal;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

See Also

UInt32 Structure | UInt32 Members | System Namespace


UInt32.ToDouble

[To be supplied.] The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public virtual double ToDouble();
[C++]
public: virtual double ToDouble();
[JScript]
public function ToDouble() : double;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

See Also

UInt32 Structure | UInt32 Members | System Namespace


UInt32.ToInt16

[To be supplied.] The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public virtual short ToInt16();
[C++]
public: virtual short ToInt16();
[JScript]
public function ToInt16() : Int16;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

See Also

UInt32 Structure | UInt32 Members | System Namespace


UInt32.ToInt32

[To be supplied.] The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public virtual int ToInt32();
[C++]
public: virtual int ToInt32();
[JScript]
public function ToInt32() : int;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

See Also

UInt32 Structure | UInt32 Members | System Namespace


UInt32.ToInt64

[To be supplied.] The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public virtual long ToInt64();
[C++]
public: virtual __int64 ToInt64();
[JScript]
public function ToInt64() : long;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

See Also

UInt32 Structure | UInt32 Members | System Namespace


UInt32.ToSByte

[To be supplied.] The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public virtual sbyte ToSByte();
[C++]
public: virtual char ToSByte();
[JScript]
public function ToSByte() : SByte;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

See Also

UInt32 Structure | UInt32 Members | System Namespace


UInt32.ToSingle

[To be supplied.] The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public virtual float ToSingle();
[C++]
public: virtual float ToSingle();
[JScript]
public function ToSingle() : float;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

See Also

UInt32 Structure | UInt32 Members | System Namespace


UInt32.ToString

Converts the current instance of UInt32 to a String. The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

Overload List [C#, C++, JScript]

Converts a specified UInt32 to a String.

[C#] public static string ToString(uint);
[C++] public: static String* ToString(unsigned int);
[JScript] public static function ToString(UInt32) : String;

Converts the current instance of UInt32 to a String

[C#] public override string ToString();
[C++] public: override String* ToString();
[JScript] public override function ToString() : String;

See Also

UInt32 Structure | UInt32 Members | System Namespace


UInt32.ToString (UInt32)

Converts a specified UInt32 to a String. The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public static string ToString(
   uint i
);
[C++]
public: static String* ToString(
   unsigned int i
);
[JScript]
public static function ToString(
   i : UInt32
) : String;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

i
A UInt32 value.

Return Value [C#, C++, JScript]

The result of converting the argument to a string.

Remarks [C#, C++, JScript]

The ToString method uses the base-10 representation of this UInt32 and adds no extra padding.

If this instance is negative, the first character in the string returned will be a minus sign ("-"). No sign character is returned if the number is non-negative. The rest of the string returned is made up of characters representing the magnitude of this instance, not to include leading zero characters ("0").

The following characters are allowable digits: 0, 1, 2, 3, 4, 5, 6, 7, 8, and 9.

The output from ToString should be consumable by FromString.

See Also

UInt32 Structure | UInt32 Members | System Namespace | UInt32.ToString Overload List | String


UInt32.ToString ()

Converts the current instance of UInt32 to a String The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

Return Value [C#, C++, JScript]

The result of converting this UInt32 to a string.

Remarks [C#, C++, JScript]

The ToString method uses the base-10 representation of this UInt32 and adds no extra padding.

If this instance is negative, the first character in the string returned will be a minus sign ("-"). No sign character is returned if the number is non-negative. The rest of the string returned is made up of characters representing the magnitude of this instance, not to include leading zero characters ("0").

The following characters are allowable digits: 0, 1, 2, 3, 4, 5, 6, 7, 8, and 9.

The output from ToString should be consumable by FromString.

Overrides ToString.

See Also

UInt32 Structure | UInt32 Members | System Namespace | UInt32.ToString Overload List | String | Object


UInt32.ToType

[To be supplied.] The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public virtual object ToType(
   Type type
);
[C++]
public: virtual Object* ToType(
   Type* type
);
[JScript]
public function ToType(
   type : Type
) : Object;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

type
[To be supplied.]

See Also

UInt32 Structure | UInt32 Members | System Namespace


UInt32.ToUInt16

[To be supplied.] The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public virtual ushort ToUInt16();
[C++]
public: virtual unsigned short ToUInt16();
[JScript]
public function ToUInt16() : UInt16;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

See Also

UInt32 Structure | UInt32 Members | System Namespace


UInt32.ToUInt32

[To be supplied.] The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public virtual uint ToUInt32();
[C++]
public: virtual unsigned int ToUInt32();
[JScript]
public function ToUInt32() : UInt32;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

See Also

UInt32 Structure | UInt32 Members | System Namespace


UInt32.ToUInt64

[To be supplied.] The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public virtual ulong ToUInt64();
[C++]
public: virtual unsigned __int64 ToUInt64();
[JScript]
public function ToUInt64() : UInt64;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

See Also

UInt32 Structure | UInt32 Members | System Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UInt32 Fields

The fields of the UInt32 structure are listed below. For a complete list of UInt32 structure members, see the UInt32 Members topic.

Public:

Empty | Represents the constant that is an empty UInt32 value: 0.
MaxValue | Represents the constant that is the largest possible UInt32 value: 4, 294, 967, 295.
MinValue | Represents the constant that is the smallest possible UInt32 value: 0.

See Also

UInt32 Structure | System Namespace


UInt32.Empty

Represents the constant that is an empty UInt32 value: 0. The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public const uint Empty;
[C++]
public: const unsigned int Empty;
[JScript]
public var Empty : UInt32;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

Remarks [C#, C++, JScript]

Empty has the value of MinValue, which is zero. (See Empty)

See Also

UInt32 Structure | UInt32 Members | System Namespace


UInt32.MaxValue

Represents the constant that is the largest possible UInt32 value: 4, 294, 967, 295. The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public const uint MaxValue;
[C++]
public: const unsigned int MaxValue;
[JScript]
public var MaxValue : UInt32;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

Remarks [C#, C++, JScript]

The MaxValue hexadecimal value is (unit)0xffffffff.

See Also

UInt32 Structure | UInt32 Members | System Namespace


UInt32.MinValue

Represents the constant that is the smallest possible UInt32 value: 0. The UInt32 type is not CLS compliant. The CLS-compliant alternative is Int32.

[C#]
public const uint MinValue;
[C++]
public: const unsigned int MinValue;
[JScript]
public var MinValue : UInt32;

[Visual Basic] The UInt32 type cannot be used in Visual Basic.

Remarks [C#, C++, JScript]

The MinValue hexadecimal value is OU.

See Also

UInt32 Structure | UInt32 Members | System Namespace


UInt64 Structure

Represents an 64-bit unsigned integer integer. The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

Object
ValueType
UInt64

[C#]
public struct UInt64 : IComparable, IFormattable, IConvertible
[C++]
public __value struct UInt64 : public IComparable, IFormattable,
   IConvertible

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks [C#, C++, JScript]

The UInt64 structure will encapsulate an 64-bit unsigned integer (ulong) and provide an object representation of it. It is an unsigned 8-byte.

The UInt64 data type can represent positive integers with 18 significant digits in the range from 0 through positive 184,467,440,737,095,521,615.

Requirements [C#, C++, JScript]

Namespace: System

Assembly: mscorlib.dll

See Also

UInt64 Members | System Namespace | Object | Int64 | IComparable | IFormattable | IConvertible


UInt64 Members

Public:

Methods

CompareTo | Compares the current Object to another object.
Equals | Compares the current instance with a specified Object.
Format | Overloaded. Converts a numeric value to a string.
FromString | Parses an UInt 64 from a String.
GetHashCode | Returns the hash code for the current UInt64.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | Retrieves the type code of an object.
Parse | Overloaded. Converts a String to a UInt64.
ToBoolean | [To be supplied.]
ToByte | [To be supplied.]
ToChar | [To be supplied.]
ToDateTime | [To be supplied.]
ToDecimal | [To be supplied.]
ToDouble | [To be supplied.]
ToInt16 | [To be supplied.]
ToInt32 | [To be supplied.]
ToInt64 | [To be supplied.]
ToSByte | [To be supplied.]
ToSingle | [To be supplied.]
ToString | Overloaded. Converts the current instance of UInt64 to a String.
ToType | [To be supplied.]
ToUInt16 | [To be supplied.]
ToUInt32 | [To be supplied.]
ToUInt64 | [To be supplied.]

Fields

Empty | Represents the constant that is the empty UInt64 value.
MaxValue | Represents the constant value that is the empty UInt64..
MinValue | Represents the constant that is the smallest possible UInt64 value.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UInt64 Structure | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UInt64 Methods

The methods of the UInt64 structure are listed below. For a complete list of UInt64 structure members, see the UInt64 Members topic.

Public:

CompareTo | Compares the current Object to another object.
Equals | Compares the current instance with a specified Object.
Format | Overloaded. Converts a numeric value to a string.
FromString | Parses an UInt 64 from a String.
GetHashCode | Returns the hash code for the current UInt64.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeCode | Retrieves the type code of an object.
Parse | Overloaded. Converts a String to a UInt64.
ToBoolean | [To be supplied.]
ToByte | [To be supplied.]
ToChar | [To be supplied.]
ToDateTime | [To be supplied.]
ToDecimal | [To be supplied.]
ToDouble | [To be supplied.]
ToInt16 | [To be supplied.]
ToInt32 | [To be supplied.]
ToInt64 | [To be supplied.]
ToSByte | [To be supplied.]
ToSingle | [To be supplied.]
ToString | Overloaded. Converts the current instance of UInt64 to a String.
ToType | [To be supplied.]
ToUInt16 | [To be supplied.]
ToUInt32 | [To be supplied.]
ToUInt64 | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UInt64 Structure | System Namespace


UInt64.CompareTo

Compares the current Object to another object. The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public virtual int CompareTo(
   object value
);
[C++]
public: virtual int CompareTo(
   Object* value
);
[JScript]
public function CompareTo(
   value : Object
) : int;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

value
The value that compares with the current object.

Return Value [C#, C++, JScript]

Value | Condition
Less than 0 | The current object is less than the value .
0 | The current object equals the value.
Greater than 0 | The current object is greater than the value.

Exceptions [C#, C++, JScript]

Exception Type | Condition
ArgumentException | If the value is not of type UInt64 and is not a null reference (in Visual Basic Nothing).

Remarks [C#, C++, JScript]

The CompareTo method determines the relationship of the current Object to another object and returns an integer that indicates the relationship.

In the comparison of two UInt64 values, canonical ordering is used. As a special case, an instance, regardless of its value, is considered to be greater than a null reference.

You should use the CompareTo method instead of subtraction because very large negative numbers will wrap to positive.

The value parameter must be a UInt64 type and a null reference.

See Also

UInt64 Structure | UInt64 Members | System Namespace | Object


UInt64.Equals

Compares the current instance with a specified Object. The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

obj
The object that compares with the current instance.

Return Value [C#, C++, JScript]

true if the object is a UInt64 with the same value as the current instance; otherwise, false.

Remarks [C#, C++, JScript]

The Equals method compares this instance with a specified object and returns a Boolean determination of their relationship.

This method overrides Equals.

See Also

UInt64 Structure | UInt64 Members | System Namespace | Object | Boolean


UInt64.Format

Converts a numeric value to a string. The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

Overload List [C#, C++, JScript]

Converts the value of the current instance to a String with the specified format string.

[C#] public virtual string Format(String, IServiceObjectProvider);
[C++] public: virtual String* Format(String*, IServiceObjectProvider);
[JScript] public function Format(String, IServiceObjectProvider) : String;

Converts a numeric value to a String with the specified format string.

[C#] public static string Format(ulong, String, NumberFormatInfo);
[C++] public: static String* Format(unsigned __int64, String, NumberFormatInfo);
[JScript] public static function Format(UInt64, String, NumberFormatInfo) : String;

Converts a numeric value to a String with the specified format string.

[C#] public static string Format(ulong, String);
[C++] public: static String* Format(unsigned __int64, String);
[JScript] public static function Format(UInt64, String) : String;

See Also

UInt64 Structure | UInt64 Members | System Namespace


UInt64.Format (String, IServiceObjectProvider)

Converts the value of the current instance to a String with the specified format string. The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public virtual string Format(
   string format,
   IServiceObjectProvider sop
);
[C++]
public: virtual String* Format(
   String* format,
   IServiceObjectProvider* sop
);
[JScript]
public function Format(
   format : String,
   sop : IServiceObjectProvider
) : String;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

format
The format string.
sop
The IServiceObjectProvider used to format the number.

Return Value [C#, C++, JScript]

A string representation for the value of the current instance in the format specified by format.

Remarks [C#, C++, JScript]

If format is null or an empty string, the number is formatted as if the general format ("G") string were specified.

The sop parameter specifies the format provider from which the NumberFormatInfo instance will be obtained. NumberFormatInfo supplies information, such as the characters to use for decimal and thousand separators, and the spelling and placement of currency symbols in monetary values.

If sop is null, the numeric format information is obtained from the current locale (see NumberFormatInfo and CultureInfo for more information on numeric and culture formats).

See Also

UInt64 Structure | UInt64 Members | System Namespace | UInt64.Format Overload List | String | ization[cref.Globalization | NumberStyles | IServiceObjectProvider


UInt64.Format (UInt64, String, NumberFormatInfo)

Converts a numeric value to a String with the specified format string. The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public static string Format(
   ulong value,
   string format,
   NumberFormatInfo info
);
[C++]
public: static String* Format(
   unsigned __int64 value,
   String* format,
   NumberFormatInfo* info
);
[JScript]
public static function Format(
   value : UInt64,
   format : String,
   info : NumberFormatInfo
) : String;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

value
The value to be formatted.
format
The format string.
info
The NumberFormatInfo instance used to format the number.

Return Value [C#, C++, JScript]

A string representation of value in the format specified by format.

Remarks [C#, C++, JScript]

The Format method converts a numeric value to a string with the format string provided by format. If format is null or an empty string, value is formatted as if the general format ("G") string were specified.

The info parameter specifies the NumberFormatInfo instance used to format the number. NumberFormatInfo supplies information, such as the characters to use for decimal and thousand separators, and the spelling and placement of currency symbols in monetary values.

If info is null, the numeric format information is obtained from the current locale (see NumberFormatInfo and CultureInfo for more information on numeric and culture formats).

See Also

UInt64 Structure | UInt64 Members | System Namespace | UInt64.Format Overload List | String | ization[cref.Globalization | NumberStyles


UInt64.Format (UInt64, String)

Converts a numeric value to a String with the specified format string. The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public static string Format(
   ulong value,
   string format
);
[C++]
public: static String* Format(
   unsigned __int64 value,
   String* format
);
[JScript]
public static function Format(
   value : UInt64,
   format : String
) : String;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

value
The value to be formatted.
format
The format string.

Return Value [C#, C++, JScript]

A string representation of value in the format specified by format.

Remarks [C#, C++, JScript]

The Format method converts a numeric value to a string with the format string specified by format. If format is null or an empty string, value is formatted as if the general format ("G") string were specified.

The numeric format information is obtained from the current locale (see NumberFormatInfo and CultureInfo) for more information for numeric and culture formats).

See Also

UInt64 Structure | UInt64 Members | System Namespace | UInt64.Format Overload List | String | ization[cref.Globalization | NumberStyles


UInt64.FromString

Parses an UInt 64 from a String. The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public static ulong FromString(
   string s
);
[C++]
public: static unsigned __int64 FromString(
   String* s
);
[JScript]
public static function FromString(
   s : String
) : UInt64;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

s
A string containing a number.

Return Value [C#, C++, JScript]

The UInt64 parsed from s.

Exceptions [C#, C++, JScript]

Exception Type | Condition
ArgumentNullException | If the string is a null reference (in Visual Basic Nothing).
FormatException | If the string doesn't contain a real number.
OverflowException | The number is greater than 32767 or less than negative 36768.

Remarks [C#, C++, JScript]

The default (culture-neutral) NumberFormatInfo is used (see NumberFormatInfo and CultureInfo for more information on numeric and culture formats). Use Parse and Format for culture-dependent strings

The output from ToString should be consumable by FromString(). .

See Also

UInt64 Structure | UInt64 Members | System Namespace | String


UInt64.GetHashCode

Returns the hash code for the current UInt64. The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

Return Value [C#, C++, JScript]

A hash code for the current instance.

Remarks [C#, C++, JScript]

The GetHashCode method performs a search and returns the hash code for UInt64. The hash code for the current instance is the Boolean value of either the lower 32-bits or the value of the upper 32-bits.

See Also

UInt64 Structure | UInt64 Members | System Namespace | Int64 | IHashCodeProvider


UInt64.GetTypeCode

Retrieves the type code of an object. The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public virtual TypeCode GetTypeCode();
[C++]
public: virtual TypeCode GetTypeCode();
[JScript]
public function GetTypeCode() : TypeCode;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

Return Value [C#, C++, JScript]

A type code.

Remarks [C#, C++, JScript]

The GetTypeCode method implements IConvertible, which replaced IValue. This method is used to obtain the type code for a specified object. (See TypeCode enumeration for more information about type codes.)

See Also

UInt64 Structure | UInt64 Members | System Namespace | IConvertible | TypeCode


UInt64.Parse

Converts a String to a UInt64. The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

Overload List [C#, C++, JScript]

Converts a String to a UInt64.

[C#] public static ulong Parse(String);
[C++] public: static unsigned __int64 Parse(String*);
[JScript] public static function Parse(String) : UInt64;

Converts a String representation of a value to a UInt64.

[C#] public static ulong Parse(String, NumberStyles, NumberFormatInfo);
[C++] public: static unsigned __int64 Parse(String*, NumberStyles, NumberFormatInfo);
[JScript] public static function Parse(String, NumberStyles, NumberFormatInfo) : UInt64;

Converts a String representation of a value to a UInt64.

[C#] public static ulong Parse(String, NumberStyles);
[C++] public: static unsigned __int64 Parse(String*, NumberStyles);
[JScript] public static function Parse(String, NumberStyles) : UInt64;

See Also

UInt64 Structure | UInt64 Members | System Namespace


UInt64.Parse (String)

Converts a String to a UInt64. The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public static ulong Parse(
   string s
);
[C++]
public: static unsigned __int64 Parse(
   String* s
);
[JScript]
public static function Parse(
   s : String
) : UInt64;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

s
The string representation of an 8-byte integer to convert to a UInt64.

Return Value [C#, C++, JScript]

The UInt64 value of the string.

Exceptions [C#, C++, JScript]

Exception Type | Condition
ArgumentException | If s tyle is not a NumberStyles enumeration.
ArgumentNullException | If the string is a null reference (in Visual Basic Nothing).
FormatException | If the string contains a character other than the minus sign ("-") or the digits 0 through 9.
OverflowException | If the string represents a number that is less than MinValue or greater than MaxValue.

Remarks [C#, C++, JScript]

The string must consist of an optional minus sign ("-") followed by a sequence of digits ("0" through "9"). Leading and trailing white space characters are ignored.

The numeric format information is obtained from the current locale (see NumberFormatInfo and CultureInfo for more information on numeric and culture formats). The string s should be the return value of one of the format methods.

Note Hexadecimal strings ("0x42") are not supported. Use the Value or Convert ToIntxx(string, int) and ToUIntxx methods for the conversions.
Note The Parse methods do not accept not a number (NaN) or positive or negative infinity.

See Also

UInt64 Structure | UInt64 Members | System Namespace | UInt64.Parse Overload List | String | MaxValue | MinValue | Value | Convert | NaN | NaN | PositiveInfinity | PositiveInfinity | NegativeInfinity | NegativeInfinity


UInt64.Parse (String, NumberStyles, NumberFormatInfo)

Converts a String representation of a value to a UInt64. The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public static ulong Parse(
   string s,
   NumberStyles style,
   NumberFormatInfo info
);
[C++]
public: static unsigned __int64 Parse(
   String* s,
   NumberStyles style,
   NumberFormatInfo* info
);
[JScript]
public static function Parse(
   s : String,
   style : NumberStyles,
   info : NumberFormatInfo
) : UInt64;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

s
The string to be interpreted.
style
The permitted style of the numeric string.
info
The NumberFormatInfo instance used to format the string.

Return Value [C#, C++, JScript]

A UInt64 with the value represented by s.

Exceptions [C#, C++, JScript]

Exception Type | Condition
ArgumentException | If style is not a NumberStyles enumeration.
ArgumentException | If the string is a null reference (in Visual Basic Nothing).
FormatException | If the string is not in the correct format.
OverflowException | If the string represents a number that is less than MinValue or greater than MaxValue.

Remarks [C#, C++, JScript]

The Parse method converts a string to a numeric value.

If s has been created by one of the format methods using C, D, E, F, G, or N as the format specifier, it is guaranteed that s can be parsed when style is NumberStyles enumeration.

The style parameter must be a combination of bit flags from the NumberStyles enumeration.

If the info parameter is null, the numeric format information is obtained from the current locale (see NumberFormatInfo and CultureInfo for more information on numeric and culture formats).

Note Hexadecimal strings ("0x42") are not supported. Use Value or Convert ToIntxx(string, int) and ToUIntxx methods for the conversions.
Note The Parse methods do not accept not a number (NaN) or positive or negative infinity.

See Also

UInt64 Structure | UInt64 Members | System Namespace | UInt64.Parse Overload List | String | Value | Convert | MaxValue | MinValue | NaN | NaN | PositiveInfinity | PositiveInfinity | NegativeInfinity | NegativeInfinity


UInt64.Parse (String, NumberStyles)

Converts a String representation of a value to a UInt64. The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public static ulong Parse(
   string s,
   NumberStyles style
);
[C++]
public: static unsigned __int64 Parse(
   String* s,
   NumberStyles style
);
[JScript]
public static function Parse(
   s : String,
   style : NumberStyles
) : UInt64;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

s
The string to be interpreted.
style
The permitted style of the numeric string.

Return Value [C#, C++, JScript]

A UInt64 with the value represented by s.

Exceptions [C#, C++, JScript]

Exception Type | Condition
ArgumentException | If style is not a NumberStyles enumeration.
ArgumentException | If the string is a null reference (in Visual Basic Nothing).
FormatException | If the string contains a character other than the minus sign ("-") or the digits 0 through 9.
OverflowException | If the string represents a number that is less than MinValue or greater than MaxValue.

Remarks [C#, C++, JScript]

If s has been created by one of the Format methods using C, D, E, F, G, or N as the format specifier, s can be parsed when style is NumberStyles enumeration.

The style parameter specifies the permitted style of the numeric string. It must be a combination of bit flags from the NumberStyles enumeration. The numeric format information is obtained from the current locale (see NumberFormatInfo and CultureInfo for more information on numeric and culture formats).

The style must be a combination of bit flags from the NumberStyles enumeration.

Note Hexadecimal strings ("0x42") are not supported. Use Value or Convert ToIntxx(string, int) and ToUIntxx methods for the conversions.
Note The Parse methods do not accept not a number (NaN) or positive or negative infinity.

See Also

UInt64 Structure | UInt64 Members | System Namespace | UInt64.Parse Overload List | String | MaxValue | MinValue | Value | Convert | NaN | NaN | PositiveInfinity | PositiveInfinity | NegativeInfinity | NegativeInfinity


UInt64.ToBoolean

[To be supplied.] The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public virtual bool ToBoolean();
[C++]
public: virtual bool ToBoolean();
[JScript]
public function ToBoolean() : Boolean;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

See Also

UInt64 Structure | UInt64 Members | System Namespace


UInt64.ToByte

[To be supplied.] The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public virtual byte ToByte();
[C++]
public: virtual unsigned char ToByte();
[JScript]
public function ToByte() : Byte;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

See Also

UInt64 Structure | UInt64 Members | System Namespace


UInt64.ToChar

[To be supplied.] The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public virtual char ToChar();
[C++]
public: virtual __wchar_t ToChar();
[JScript]
public function ToChar() : Char;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

See Also

UInt64 Structure | UInt64 Members | System Namespace


UInt64.ToDateTime

[To be supplied.] The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public virtual DateTime ToDateTime();
[C++]
public: virtual DateTime ToDateTime();
[JScript]
public function ToDateTime() : DateTime;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

See Also

UInt64 Structure | UInt64 Members | System Namespace


UInt64.ToDecimal

[To be supplied.] The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public virtual Decimal ToDecimal();
[C++]
public: virtual Decimal ToDecimal();
[JScript]
public function ToDecimal() : Decimal;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

See Also

UInt64 Structure | UInt64 Members | System Namespace


UInt64.ToDouble

[To be supplied.] The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public virtual double ToDouble();
[C++]
public: virtual double ToDouble();
[JScript]
public function ToDouble() : double;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

See Also

UInt64 Structure | UInt64 Members | System Namespace


UInt64.ToInt16

[To be supplied.] The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public virtual short ToInt16();
[C++]
public: virtual short ToInt16();
[JScript]
public function ToInt16() : Int16;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

See Also

UInt64 Structure | UInt64 Members | System Namespace


UInt64.ToInt32

[To be supplied.] The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public virtual int ToInt32();
[C++]
public: virtual int ToInt32();
[JScript]
public function ToInt32() : int;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

See Also

UInt64 Structure | UInt64 Members | System Namespace


UInt64.ToInt64

[To be supplied.] The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public virtual long ToInt64();
[C++]
public: virtual __int64 ToInt64();
[JScript]
public function ToInt64() : long;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

See Also

UInt64 Structure | UInt64 Members | System Namespace


UInt64.ToSByte

[To be supplied.] The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public virtual sbyte ToSByte();
[C++]
public: virtual char ToSByte();
[JScript]
public function ToSByte() : SByte;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

See Also

UInt64 Structure | UInt64 Members | System Namespace


UInt64.ToSingle

[To be supplied.] The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public virtual float ToSingle();
[C++]
public: virtual float ToSingle();
[JScript]
public function ToSingle() : float;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

See Also

UInt64 Structure | UInt64 Members | System Namespace


UInt64.ToString

Converts the current instance of UInt64 to a String. The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

Overload List [C#, C++, JScript]

Converts a specified UInt64 to a String.

[C#] public static string ToString(ulong);
[C++] public: static String* ToString(unsigned __int64);
[JScript] public static function ToString(UInt64) : String;

Converts the current instance of UInt64 to a String.

[C#] public override string ToString();
[C++] public: override String* ToString();
[JScript] public override function ToString() : String;

See Also

UInt64 Structure | UInt64 Members | System Namespace


UInt64.ToString (UInt64)

Converts a specified UInt64 to a String. The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public static string ToString(
   ulong l
);
[C++]
public: static String* ToString(
   unsigned __int64 l
);
[JScript]
public static function ToString(
   l : UInt64
) : String;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

l
The UInt64 value to be converted.

Return Value [C#, C++, JScript]

The result of converting the argument to a string in base 10 with no extra padding.

Remarks [C#, C++, JScript]

The ToString method uses the base-10 representation of this UInt64 and adds no extra padding.

If this instance is negative, the first character in the string returned will be the minus sign ("-"). No sign character is returned if the number is non-negative. The rest of the string returned is made up of characters representing the magnitude of this instance, not to include leading zero characters ("0").

The following characters are allowable digits: 0, 1, 2, 3, 4, 5, 6, 7, 8, and 9.

The output from ToString should be consumable by FromString.

See Also

UInt64 Structure | UInt64 Members | System Namespace | UInt64.ToString Overload List | String | Format | NumberFormatInfo


UInt64.ToString ()

Converts the current instance of UInt64 to a String. The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

Return Value [C#, C++, JScript]

The result of converting the current UInt64 to a string.

Remarks [C#, C++, JScript]

The ToString method uses the base-10 representation of this UInt64 and adds no extra padding.

If this instance is negative, the first character in the string returned will be "-". No sign character is returned if the number is not negative. The rest of the string returned is made up of characters representing the magnitude of this instance, not to include leading zero characters ("0").

The following characters are allowable digits: 0, 1, 2, 3, 4, 5, 6, 7, 8, and 9.

The output from ToString should be consumable by FromString.

See Also

UInt64 Structure | UInt64 Members | System Namespace | UInt64.ToString Overload List | String | Format | NumberFormatInfo


UInt64.ToType

[To be supplied.] The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public virtual object ToType(
   Type type
);
[C++]
public: virtual Object* ToType(
   Type* type
);
[JScript]
public function ToType(
   type : Type
) : Object;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

Parameters [C#, C++, JScript]

type
[To be supplied.]

See Also

UInt64 Structure | UInt64 Members | System Namespace


UInt64.ToUInt16

[To be supplied.] The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public virtual ushort ToUInt16();
[C++]
public: virtual unsigned short ToUInt16();
[JScript]
public function ToUInt16() : UInt16;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

See Also

UInt64 Structure | UInt64 Members | System Namespace


UInt64.ToUInt32

[To be supplied.] The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public virtual uint ToUInt32();
[C++]
public: virtual unsigned int ToUInt32();
[JScript]
public function ToUInt32() : UInt32;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

See Also

UInt64 Structure | UInt64 Members | System Namespace


UInt64.ToUInt64

[To be supplied.] The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public virtual ulong ToUInt64();
[C++]
public: virtual unsigned __int64 ToUInt64();
[JScript]
public function ToUInt64() : UInt64;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

See Also

UInt64 Structure | UInt64 Members | System Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UInt64 Fields

The fields of the UInt64 structure are listed below. For a complete list of UInt64 structure members, see the UInt64 Members topic.

Public:

Empty | Represents the constant that is the empty UInt64 value.
MaxValue | Represents the constant value that is the empty UInt64..
MinValue | Represents the constant that is the smallest possible UInt64 value.

See Also

UInt64 Structure | System Namespace


UInt64.Empty

Represents the constant that is the empty UInt64 value. The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public const ulong Empty;
[C++]
public: const unsigned __int64 Empty;
[JScript]
public var Empty : UInt64;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

Remarks [C#, C++, JScript]

Empty is equal to MinValue, which is zero.

See Also

UInt64 Structure | UInt64 Members | System Namespace | Empty


UInt64.MaxValue

Represents the constant value that is the empty UInt64.. The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public const ulong MaxValue;
[C++]
public: const unsigned __int64 MaxValue;
[JScript]
public var MaxValue : UInt64;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

Remarks [C#, C++, JScript]

The MaxValue hexadecimal value is (ulong) 0xffffffffffffffffL.

See Also

UInt64 Structure | UInt64 Members | System Namespace


UInt64.MinValue

Represents the constant that is the smallest possible UInt64 value. The UInt64 type is not CLS compliant. The CLS-compliant alternative is Int64.

[C#]
public const ulong MinValue;
[C++]
public: const unsigned __int64 MinValue;
[JScript]
public var MinValue : UInt64;

[Visual Basic] The UInt64 type cannot be used in Visual Basic.

Remarks [C#, C++, JScript]

The MinValue hexadecimal value is 0x0.

See Also

UInt64 Structure | UInt64 Members | System Namespace


UnhandledExceptionEvent Class

Represents an exception event that was not handled by an application domain.

Object
EventArgs
UnhandledExceptionEvent

[Visual Basic]
Public Class UnhandledExceptionEvent
   Inherits EventArgs
[C#]
public class UnhandledExceptionEvent : EventArgs
[C++]
public __gc class UnhandledExceptionEvent : public EventArgs
[JScript]
public class UnhandledExceptionEvent extends EventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

UnhandledExceptionEvent Members | System Namespace


UnhandledExceptionEvent Members

Public:

Constructor

UnhandledExceptionEvent Constructor Initializes an instance of the UnhandledExceptionEvent class.

Properties

ExceptionObject | The exception object.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
IsTerminating | Indicates if the runtime is terminating.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UnhandledExceptionEvent Class | System Namespace


UnhandledExceptionEvent Constructor

Initializes an instance of the UnhandledExceptionEvent class.

[Visual Basic]
Public Sub New( _
   ByVal exception As Object, _
   ByVal isTerminating As Boolean _
)
[C#]
public UnhandledExceptionEvent(
   object exception,
   bool isTerminating
);
[C++]
public: UnhandledExceptionEvent(
   Object* exception,
   bool isTerminating
);
[JScript]
public function UnhandledExceptionEvent(
   exception : Object,
   isTerminating : Boolean
);

Parameters

exception
The exception that was not handled.
isTerminating
Indicates if the runtime is terminating.

See Also

UnhandledExceptionEvent Class | UnhandledExceptionEvent Members | System Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UnhandledExceptionEvent Properties

The properties of the UnhandledExceptionEvent class are listed below. For a complete list of UnhandledExceptionEvent class members, see the UnhandledExceptionEvent Members topic.

Public:

ExceptionObject | The exception object.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
IsTerminating | Indicates if the runtime is terminating.

See Also

UnhandledExceptionEvent Class | System Namespace


UnhandledExceptionEvent.ExceptionObject

The exception object.

[Visual Basic]
Public ReadOnly Property ExceptionObject As Object
[C#]
public object ExceptionObject {get;}
[C++]
public: __property Object* get_ExceptionObject();
[JScript]
public function get ExceptionObject() : Object;

Property Value

Read-only. The exception object.

See Also

UnhandledExceptionEvent Class | UnhandledExceptionEvent Members | System Namespace


UnhandledExceptionEvent.IsTerminating

Indicates if the runtime is terminating.

[Visual Basic]
Public ReadOnly Property IsTerminating As Boolean
[C#]
public bool IsTerminating {get;}
[C++]
public: __property bool get_IsTerminating();
[JScript]
public function get IsTerminating() : Boolean;

Property Value

Read-only. Indicates if the runtime is terminating.

See Also

UnhandledExceptionEvent Class | UnhandledExceptionEvent Members | System Namespace


UnhandledExceptionEventHandler Delegate

Exception handler for an event that is not handled by an application domain.

[Visual Basic]
Public Delegate Sub UnhandledExceptionEventHandler( _
   ByVal sender As Object, _
   ByVal e As UnhandledExceptionEvent _
)
[C#]
public delegate void UnhandledExceptionEventHandler(
   object sender,
   UnhandledExceptionEvent e
);
[C++]
public __gc __delegate void UnhandledExceptionEventHandler(
   Object* sender,
   UnhandledExceptionEvent* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the UnhandledExceptionEventHandler delegate declaration.

sender
The originator of the exception.
e
The event description.

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

System Namespace


Value Class

[To be supplied.]

Object
Value

[Visual Basic]
Public Class Value
[C#]
public class Value
[C++]
public __gc class Value
[JScript]
public class Value

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

Value Members | System Namespace


Value Members

Public:

Constructor

Value Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

DBNull [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Value Class | System Namespace


Value Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public Value();
[C++]
public: Value();
[JScript]
public function Value();

See Also

Value Class | Value Members | System Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Value Fields

The fields of the Value class are listed below. For a complete list of Value class members, see the Value Members topic.

Public:

DBNull [To be supplied.]

See Also

Value Class | System Namespace


Value.DBNull

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly DBNull As Object
[C#]
public static readonly object DBNull;
[C++]
public: static readonly Object* DBNull;
[JScript]
public static var DBNull : Object;

See Also

Value Class | Value Members | System Namespace


ValueType Class

Provides the base class for value types.

Object
ValueType

[Visual Basic]
Public Class ValueType
[C#]
public class ValueType
[C++]
public __gc class ValueType
[JScript]
public class ValueType

Remarks

ValueType overrides the virtual methods from Object with more appropriate implementations for value types. See also Enum which inherits from ValueType.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

ValueType Members | System Namespace


ValueType Members

Public:

Constructor

ValueType Constructor [To be supplied.]

Methods

Equals | Indicates whether this instance and another object are equal.
GetHashCode | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Returns the name of the type.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ValueType Class | System Namespace


ValueType Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ValueType();
[C++]
public: ValueType();
[JScript]
public function ValueType();

See Also

ValueType Class | ValueType Members | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ValueType Methods

The methods of the ValueType class are listed below. For a complete list of ValueType class members, see the ValueType Members topic.

Public:

Equals | Indicates whether this instance and another object are equal.
GetHashCode | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Returns the name of the type.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ValueType Class | System Namespace


ValueType.Equals

Indicates whether this instance and another object are equal.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The object to compare to.

Return Value

true if and only if obj and this instance are the same type and represent the same value; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentNullException | The obj parameter is a null reference (in Visual Basic Nothing).

See Also

ValueType Class | ValueType Members | System Namespace


ValueType.GetHashCode

Returns the hash code for this instance.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

The hash code for this instance. This is the or of the hash code for all of the instance fields, as illustrated by the pseudo-code:

ForEach (instance field in this instance this.X)
{
   if (this.X != null)
    m_hash |= this.X.GetHashCode();
}
return m_hash;

See Also

ValueType Class | ValueType Members | System Namespace


ValueType.ToString

Returns the name of the type.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

The name of the type.

Remarks

ToString calls ToString.

See Also

ValueType Class | ValueType Members | System Namespace


Version Class

Represents the version number for a NGWS runtime assembly.

Object
Version

[Visual Basic]
Public Class Version
   Implements ICloneable, IComparable
[C#]
public class Version : ICloneable, IComparable
[C++]
public __gc class Version : public ICloneable, IComparable
[JScript]
public class Version implements ICloneable, IComparable

Remarks

Version numbers in the NGWS runtime consist of four parts: major, minor, build, and revision. By default, only major and minor are used for binding to an assembly.

Subsequent versions of an assembly that differ only by build or revision numbers are considered to be Quick Fix Engineering (QFE) updates of the prior version. If desired, build and revision can be honored by changing the version policy in the configuration.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

Version Members | System Namespace


Version Members

Public:

Constructor

Version Constructor Overloaded. Overloaded. Initializes a new instance of the Version class with the specified major, minor, build, and revision numbers.

Properties

Build | The read-only property returns the "build" portion of the version number.
Major | The read-only property returns the "major" portion of the version number.
Minor | The read-only property returns the "minor" portion of the version number.
Revision | The read-only property returns the "revision" portion of the version number.

Methods

Clone | Copies this Version object.
CompareTo | Compares this object with another Version object.
Equals | Checks if this object is equal to another Version object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Overloaded. Overloaded. Returns a string representation of this Version.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Version Class | System Namespace


Version Constructor

Overloaded. Initializes a new instance of the Version class with the specified major, minor, build, and revision numbers.

Overload List

Initializes a new Version given the major version, minor version, and revision.

[Visual Basic] Overloads Public Sub New(Integer, Integer, Integer, Integer)
[C#] public Version(int, int, int, int);
[C++] public: Version(int, int, int, int);
[JScript] public function Version(int, int, int, int);

Initializes a new Version given the major version, minor version, and revision.

[Visual Basic] Overloads Public Sub New(Integer, Integer, Integer)
[C#] public Version(int, int, int);
[C++] public: Version(int, int, int);
[JScript] public function Version(int, int, int);

Initializes a new Version given the major version and minor version.

[Visual Basic] Overloads Public Sub New(Integer, Integer)
[C#] public Version(int, int);
[C++] public: Version(int, int);
[JScript] public function Version(int, int);

Initializes a new Version given a version string in the format returned by ToString.

[Visual Basic] Overloads Public Sub New(String)
[C#] public Version(String);
[C++] public: Version(String*);
[JScript] public function Version(String);

See Also

Version Class | Version Members | System Namespace


Version Constructor (Int32, Int32, Int32, Int32)

Initializes a new Version given the major version, minor version, and revision.

[Visual Basic]
Overloads Public Sub New( _
   ByVal major As Integer, _
   ByVal minor As Integer, _
   ByVal revision As Integer, _
   ByVal build As Integer _
)
[C#]
public Version(
   int major,
   int minor,
   int revision,
   int build
);
[C++]
public: Version(
   int major,
   int minor,
   int revision,
   int build
);
[JScript]
public function Version(
   major : int,
   minor : int,
   revision : int,
   build : int
);

Parameters

major
The major version number.
minor
The minor version number.
revision
The revision number.
build
[To be supplied.]

See Also

Version Class | Version Members | System Namespace | Version Constructor Overload List


Version Constructor (Int32, Int32, Int32)

Initializes a new Version given the major version, minor version, and revision.

[Visual Basic]
Overloads Public Sub New( _
   ByVal major As Integer, _
   ByVal minor As Integer, _
   ByVal revision As Integer _
)
[C#]
public Version(
   int major,
   int minor,
   int revision
);
[C++]
public: Version(
   int major,
   int minor,
   int revision
);
[JScript]
public function Version(
   major : int,
   minor : int,
   revision : int
);

Parameters

major
The major version number.
minor
The minor version number.
revision
The revision number.

See Also

Version Class | Version Members | System Namespace | Version Constructor Overload List


Version Constructor (Int32, Int32)

Initializes a new Version given the major version and minor version.

[Visual Basic]
Overloads Public Sub New( _
   ByVal major As Integer, _
   ByVal minor As Integer _
)
[C#]
public Version(
   int major,
   int minor
);
[C++]
public: Version(
   int major,
   int minor
);
[JScript]
public function Version(
   major : int,
   minor : int
);

Parameters

major
The major version number.
minor
The minor version number.

See Also

Version Class | Version Members | System Namespace | Version Constructor Overload List


Version Constructor (String)

Initializes a new Version given a version string in the format returned by ToString.

[Visual Basic]
Overloads Public Sub New( _
   ByVal version As String _
)
[C#]
public Version(
   string version
);
[C++]
public: Version(
   String* version
);
[JScript]
public function Version(
   version : String
);

Parameters

version
A version string.

See Also

Version Class | Version Members | System Namespace | Version Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Version Properties

The properties of the Version class are listed below. For a complete list of Version class members, see the Version Members topic.

Public:

Build | The read-only property returns the "build" portion of the version number.
Major | The read-only property returns the "major" portion of the version number.
Minor | The read-only property returns the "minor" portion of the version number.
Revision | The read-only property returns the "revision" portion of the version number.

See Also

Version Class | System Namespace


Version.Build

The read-only property returns the "build" portion of the version number.

[Visual Basic]
Public ReadOnly Property Build As Integer
[C#]
public int Build {get;}
[C++]
public: __property int get_Build();
[JScript]
public function get Build() : int;

Property Value

Read-only. Returns the build number.-1 is returned if the build number is undefined.

Remarks

For example, if the version number is 6.2.1.3, the "build" number is 3. If the version number is 6.2, the "build" number is undefined.

See Also

Version Class | Version Members | System Namespace


Version.Major

The read-only property returns the "major" portion of the version number.

[Visual Basic]
Public ReadOnly Property Major As Integer
[C#]
public int Major {get;}
[C++]
public: __property int get_Major();
[JScript]
public function get Major() : int;

Property Value

Read-only. Returns the major version.

Remarks

For example, if the version number is 6.2, the "major" version is 6.

See Also

Version Class | Version Members | System Namespace


Version.Minor

The read-only property returns the "minor" portion of the version number.

[Visual Basic]
Public ReadOnly Property Minor As Integer
[C#]
public int Minor {get;}
[C++]
public: __property int get_Minor();
[JScript]
public function get Minor() : int;

Property Value

Read-only. Returns the minor version.

Remarks

For example, if the version number is 6.2, the "minor" version is 6.

See Also

Version Class | Version Members | System Namespace


Version.Revision

The read-only property returns the "revision" portion of the version number.

[Visual Basic]
Public ReadOnly Property Revision As Integer
[C#]
public int Revision {get;}
[C++]
public: __property int get_Revision();
[JScript]
public function get Revision() : int;

Property Value

Read-only. Returns the revision number.-1 is returned if the revision number is undefined.

Remarks

For example, if the version number is 6.2.1.3, the "revision" number is 1. If the version number is 6.2, the "revision" number is undefined.

See Also

Version Class | Version Members | System Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Version Methods

The methods of the Version class are listed below. For a complete list of Version class members, see the Version Members topic.

Public:

Clone | Copies this Version object.
CompareTo | Compares this object with another Version object.
Equals | Checks if this object is equal to another Version object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Overloaded. Overloaded. Returns a string representation of this Version.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Version Class | System Namespace


Version.Clone

Copies this Version object.

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

Return Value

A copy of this Version object.

See Also

Version Class | Version Members | System Namespace


Version.CompareTo

Compares this object with another Version object.

[Visual Basic]
Overridable Public Function CompareTo( _
   ByVal version As Object _
) As Integer
[C#]
public virtual int CompareTo(
   object version
);
[C++]
public: virtual int CompareTo(
   Object* version
);
[JScript]
public function CompareTo(
   version : Object
) : int;

Parameters

version
[To be supplied.]

Return Value

-1 | If this version is older then.
0 | If this version is the same as version.
1 | If this version is newer then version.

Remarks

The components of version in the decreasing order of importance are: major, minor, revision, and build. An unknown component is assumed to be smaller than any known component. For example,

version 1.1.* is older than version 1.1.1

version 1.1.* is older than version 1.1.2.3

version 1.1.2.* is older than version 1.1.2.4

version 1.2.5 is newer than version 1.2.3.4

See Also

Version Class | Version Members | System Namespace


Version.Equals

Checks if this object is equal to another Version object.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The object with which this version is to be compared.

Return Value

Returns true if every component of this version matches the corresponding component of version. Otherwise, returns false.

See Also

Version Class | Version Members | System Namespace


Version.ToString

Overloaded. Returns a string representation of this Version.

Overload List

Returns the default string representation of this Version object. The format of the string returned is:

<majorVersion>.<minorVersion>[.<revision>[.<build>]]

Missing components of the Version are omitted in the returned string.

[Visual Basic] Overloads Overrides Public Function ToString() As String
[C#] public override string ToString();
[C++] public: override String* ToString();
[JScript] public override function ToString() : String;

Returns the default string representation of this Version that contains the specified number of components. The format of the string returned is:

<majorVersion>.<minorVersion>[.<revision>[.<build>]]

[Visual Basic] Overloads Public Function ToString(Integer) As String
[C#] public string ToString(int);
[C++] public: String* ToString(int);
[JScript] public function ToString(int) : String;

Example

For example, if Version was created using the constructor Version(1,3,5), the value returned for ToString(2) is 1.3. ArgumentException will be thrown for ToString(4).

See Also

Version Class | Version Members | System Namespace


Version.ToString ()

Returns the default string representation of this Version object. The format of the string returned is:

<majorVersion>.<minorVersion>[.<revision>[.<build>]]

Missing components of the Version are omitted in the returned string.

[Visual Basic]
Overloads Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Example

For example, if Version was created using the constructor Version(1,1), the returned string will be 1.1. If Version was created using the constructor Version(1,3,4,2), the returned string will be 1.3.4.2.

See Also

Version Class | Version Members | System Namespace | Version.ToString Overload List


Version.ToString (Int32)

Returns the default string representation of this Version that contains the specified number of components. The format of the string returned is:

<majorVersion>.<minorVersion>[.<revision>[.<build>]]

[Visual Basic]
Overloads Public Function ToString( _
   ByVal fieldCount As Integer _
) As String
[C#]
public string ToString(
   int fieldCount
);
[C++]
public: String* ToString(
   int fieldCount
);
[JScript]
public function ToString(
   fieldCount : int
) : String;

Parameters

fieldCount
The number of components of the field count that are to be returned.

Exceptions

Exception Type | Condition
ArgumentException | if fieldCount is more than the number of defined components of this Version

Example

For example, if Version was created using the constructor Version(1,3,5), the value returned for ToString(2) is 1.3. ArgumentException will be thrown for ToString(4).

See Also

Version Class | Version Members | System Namespace | Version.ToString Overload List


Void Structure

Indicates that a method has the void return type.

This class is used in the System.Reflection namespace. Instances of this class cannot be created, and the class has no members.

Object
ValueType
Void

[Visual Basic]
Public Structure Void
[C#]
public struct Void
[C++]
public __value struct Void

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

Void Members | System Namespace


Void Members

Public:

Methods

Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Void Structure | System Namespace


WeakReference Class

Supports a weak reference.

Object
WeakReference

[Visual Basic]
Public Class WeakReference
   Implements ISerializable
[C#]
public class WeakReference : ISerializable
[C++]
public __gc class WeakReference : public ISerializable
[JScript]
public class WeakReference implements ISerializable

Remarks

The WeakReference class is a wrapper for establishing a weak reference to an Object.

The garabage collector (GC) tracks all references to objects in the runtime. It collects and frees only objects that are not referenced by other objects.

Tracking ensures that references to objects are invalid. However, it does pose a problem. It is not possible to hold a refernce only as long as another object is holding it as well. For example, you may want to store objects in a collection, but not keep them alive only becuase they are a collection.

The WeakReference class solves this problem. Objects referenced through the WeakReference class are kep alive only as long as there are at least one strong (that is, normal) reference to the object. The Execution Engine (EE) supports two styles of weak reference:

  • Short weak reference
  • Long weak reference.

The distinction between the two is whether the reference is zeroed before or after finalization of the target object. The constructor for WeakReference takes a Boolean named trackResurrection and determines which of the two styles to use. By default the trackResurrection is set to false, so that the object is tracked only until finalization (that is, the object was zeroed before finalization). Note: Constant strings may be pooled by the runtime. Therefore, weak references to constant strings may live fo the life of the runtime.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

WeakReference Members | System Namespace | GCHandle | GC | System.Runtime


WeakReference Members

Public:

Constructor

WeakReference Constructor Overloaded. Initializes a new instance of the WeakReference class.

Properties

IsAlive | Retrieves a Boolean that indicates whether GC has occurred on the object.
Target | Retrieves or assigns the object an IsAlive status.
TrackResurrection | Retrieves a Boolean indicating whether objects are tracked.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Returns a SerializationInfo completely populated with all the data needed to serailze the target object.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize | Frees all resources associated with this reference.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WeakReference Class | System Namespace


WeakReference Constructor

Initializes a new instance of the WeakReference class.

Overload List

Initializes a new instance of the WeakReference class with the specified object.

[Visual Basic] Overloads Public Sub New(Object)
[C#] public WeakReference(Object);
[C++] public: WeakReference(Object*);
[JScript] public function WeakReference(Object);

Initializes a new instance of the WeakReference class with the specified object and object tracking.

[Visual Basic] Overloads Public Sub New(Object, Boolean)
[C#] public WeakReference(Object, bool);
[C++] public: WeakReference(Object*, bool);
[JScript] public function WeakReference(Object, Boolean);

See Also

WeakReference Class | WeakReference Members | System Namespace


WeakReference Constructor (Object)

Initializes a new instance of the WeakReference class with the specified object.

[Visual Basic]
Overloads Public Sub New( _
   ByVal target As Object _
)
[C#]
public WeakReference(
   object target
);
[C++]
public: WeakReference(
   Object* target
);
[JScript]
public function WeakReference(
   target : Object
);

Parameters

target
The object to track.

Exceptions

Exception Type | Condition
ArgumentException | If the target object is null.

Remarks

This WeakReference constructor creates a short weak reference to the specified object.

A short weak reference is tracked only until finalization (that is, trackResurrection is false). The reference will refer to the target until the first time it is detected to be unreachable by the runtime.

See Also

WeakReference Class | WeakReference Members | System Namespace | WeakReference Constructor Overload List | Object


WeakReference Constructor (Object, Boolean)

Initializes a new instance of the WeakReference class with the specified object and object tracking.

[Visual Basic]
Overloads Public Sub New( _
   ByVal target As Object, _
   ByVal trackResurrection As Boolean _
)
[C#]
public WeakReference(
   object target,
   bool trackResurrection
);
[C++]
public: WeakReference(
   Object* target,
   bool trackResurrection
);
[JScript]
public function WeakReference(
   target : Object,
   trackResurrection : Boolean
);

Parameters

target
The object to track.
trackResurrection
Determines when to stop tracking the object. If true, the object is tracked after finalization; otherwise, the object is only tracked until finalization.

Exceptions

Exception Type | Condition
ArgumentException | If the target object is null.

Remarks

This WeakReference constructor creates a weak reference to the specified object. The reference will refer to the target until the first time it is detected to be unreachable by the runtime. It returns a Boolean evaluation for the object tracking as follows:

  • A short weak reference is created if trackResurrection is false.
  • A long weak reference is created if trackResurrection is true.

See Also

WeakReference Class | WeakReference Members | System Namespace | WeakReference Constructor Overload List | Object | Boolean | GCHandle


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

WeakReference Properties

The properties of the WeakReference class are listed below. For a complete list of WeakReference class members, see the WeakReference Members topic.

Public:

IsAlive | Retrieves a Boolean that indicates whether GC has occurred on the object.
Target | Retrieves or assigns the object an IsAlive status.
TrackResurrection | Retrieves a Boolean indicating whether objects are tracked.

See Also

WeakReference Class | System Namespace


WeakReference.IsAlive

Retrieves a Boolean that indicates whether GC has occurred on the object.

[Visual Basic]
Overridable Public ReadOnly Property IsAlive As Boolean
[C#]
public bool IsAlive {virtual get;}
[C++]
public: __property virtual bool get_IsAlive();
[JScript]
public function get IsAlive() : Boolean;

Property Value

Read only. This property can have the following values:

Value | Description
true | The object is still accessible.
false | Otherwise.

Exceptions

Exception Type | Condition
WeakReferenceException | If the object reference encapsulated by the current instance is invalid.

Remarks

The Is Alive property retrieves a Boolean that indicates whether the current instance of WeakReference still refers to an object that has or has not been collected by the garbage collector (GC) yet.

If IsAlive returns true, the Target property will return a valid reference to the object. On the other hand, if IsAlive returns false, Target returns null.

A WeakReferenceException is thown if the the object reference encapsulated by the current instance is invalid. This will occur if the current instance has been resurrected after a call to Finalize because Finalize destroys the underlying reference.

See Also

WeakReference Class | WeakReference Members | System Namespace | GC | GCHandle | Object


WeakReference.Target

Retrieves or assigns the object an IsAlive status.

[Visual Basic]
Overridable Public Property Target As Object
[C#]
public object Target {virtual get; virtual set;}
[C++]
public: __property virtual Object* get_Target();
public: __property virtual void set_Target(Object*);
[JScript]
public function get Target() : Object;
public function set Target(Object);

Property Value

This property can have the following values:

Value | Description
null | IsAlive returns false, meaning that there are no more strong references to the current object.
Object to which the current instance refers | IsAlive returns true.

Exceptions

Exception Type | Condition
WeakReferenceException | If the object reference encapsulated by this instance is invalid.

Remarks

The Target property retrieves or assigns the object of the current instance a true or null based upon the status that is returned from IsAlive.

  • A true is retrieved when IsAlive returns the current instance of the object as still being alive.
  • A false is retrieved when IsAlive returns that the current instance of the object when there are no more strong references to the object.

A WeakReferenceException will be thrown if the object reference encapsulated by this instance is invalid. This will occur if the current instance has been resurrected after a call to Finalize because Finalize destroys the underlying reference.

See Also

WeakReference Class | WeakReference Members | System Namespace | Object | GC | GCHandle


WeakReference.TrackResurrection

Retrieves a Boolean indicating whether objects are tracked.

[Visual Basic]
Overridable Public ReadOnly Property TrackResurrection As Boolean
[C#]
public bool TrackResurrection {virtual get;}
[C++]
public: __property virtual bool get_TrackResurrection();
[JScript]
public function get TrackResurrection() : Boolean;

Property Value

Read only. This property can have the following values:

Value | Description
true | The reference will refer to the target until it is reclaimed by the Runtime (until collection).
false. | The reference will refer to the target until the first time it is detected to be unreachable by the Runtime (until finalization).

Remarks

The TrackResurrection property retrieves a Boolean indicating whether objects are tracked until they are collected (true) by the runtime or until they are finalized (false) when the first time it is detected to be unreachable by the Runtime (until finalization).

See Also

WeakReference Class | WeakReference Members | System Namespace | GCHandle | GC | System.Runtime


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

WeakReference Methods

The methods of the WeakReference class are listed below. For a complete list of WeakReference class members, see the WeakReference Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Returns a SerializationInfo completely populated with all the data needed to serailze the target object.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize | Frees all resources associated with this reference.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WeakReference Class | System Namespace


WeakReference.Finalize

Frees all resources associated with this reference.

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

Remarks

The Finalize method cancels (eliminates or voids) the calls of the current object to the runtime. The object will not longer be available for calls after Finalize.

If the current instance is resurrected after a call to Finalize and IsAlive, it will throw a WeakReferenceException.

See Also

WeakReference Class | WeakReference Members | System Namespace | Object | GCHandle | GC


WeakReference.GetObjectData

Returns a SerializationInfo completely populated with all the data needed to serailze the target object.

[Visual Basic]
Overridable Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
public: virtual void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
);
[JScript]
public function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);

Parameters

info
The data to be serialized.
context
[To be supplied.]

Return Value

A SerializationInfo with all the data needed to serialize the object.

Exceptions

Exception Type | Condition
ArgumentNullException | info is a null reference (in Visual Basic Nothing).

Remarks

The GetObjectData method is used to retrieve the data from the source and/or destination, which SerializationInfo holds together while the data is being serialized/deserialized.

See Also

WeakReference Class | WeakReference Members | System Namespace | Object | StreamingContext


WeakReferenceException Class

Represents an exception that is thrown when an attempt to access an invalid object reference encapsulated by a WeakReference object.

Object
Exception
SystemException
WeakReferenceException

[Visual Basic]
Public Class WeakReferenceException
   Inherits SystemException
[C#]
public class WeakReferenceException : SystemException
[C++]
public __gc class WeakReferenceException : public SystemException
[JScript]
public class WeakReferenceException extends SystemException

Remarks

The WeakReferenceException is the exception class that is to be used for methods that should be implemented on subclasses.

A WeakReferenceException occurs if an exception is resurrected after a call to Finalize, because Finalize destroys the underlying reference.

Requirements

Namespace: System

Assembly: mscorlib.dll

See Also

WeakReferenceException Members | System Namespace


WeakReferenceException Members

Public:

Constructor

WeakReferenceException Constructor Overloaded. Initializes a new instance of the WeakReferenceException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

WeakReferenceException Class | System Namespace


WeakReferenceException Constructor

Initializes a new instance of the WeakReferenceException class.

Overload List

Initializes a new instance of the WeakReferenceException with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public WeakReferenceException();
[C++] public: WeakReferenceException();
[JScript] public function WeakReferenceException();

Initializes a new instance of the WeakReferenceException class with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public WeakReferenceException(String);
[C++] public: WeakReferenceException(String*);
[JScript] public function WeakReferenceException(String);

Initializes a new instance of the WeakReferenceException class with a specified message and an exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public WeakReferenceException(String, Exception);
[C++] public: WeakReferenceException(String*, Exception);
[JScript] public function WeakReferenceException(String, Exception);

See Also

WeakReferenceException Class | WeakReferenceException Members | System Namespace


WeakReferenceException Constructor ()

Initializes a new instance of the WeakReferenceException with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public WeakReferenceException();
[C++]
public: WeakReferenceException();
[JScript]
public function WeakReferenceException();

Remarks

WeakReferenceException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The empty string.

See Also

WeakReferenceException Class | WeakReferenceException Members | System Namespace | WeakReferenceException Constructor Overload List


WeakReferenceException Constructor (String)

Initializes a new instance of the WeakReferenceException class with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public WeakReferenceException(
   string message
);
[C++]
public: WeakReferenceException(
   String* message
);
[JScript]
public function WeakReferenceException(
   message : String
);

Parameters

message
The message text identifies the reason that the exception occurred.

Remarks

WeakReferenceException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The message string.

See Also

WeakReferenceException Class | WeakReferenceException Members | System Namespace | WeakReferenceException Constructor Overload List


WeakReferenceException Constructor (String, Exception)

Initializes a new instance of the WeakReferenceException class with a specified message and an exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public WeakReferenceException(
   string message,
   Exception inner
);
[C++]
public: WeakReferenceException(
   String* message,
   Exception* inner
);
[JScript]
public function WeakReferenceException(
   message : String,
   inner : Exception
);

Parameters

message
The message text identifies the reason that the exception occurred.
inner
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

WeakReferenceException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | The inner exception.
Message | The message string.

See Also

WeakReferenceException Class | WeakReferenceException Members | System Namespace | WeakReferenceException Constructor Overload List


System.CodeDOM

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.CodeDOM Namespace

Classes

Class | Description
CodeArrayCreateExpression | Represents an anonymous array creation expression.
CodeAssignStatement | Represents a simple assignment statement.
CodeAttributeArgument | Represents an argument for a custom attribute declaration. The name is used for named arguments.
CodeAttributeArgumentCollection | Manages a collection of CodeAttributeArgument objects.
CodeAttributeBlock | Represents a block of custom attributes.
CodeAttributeDeclaration | Represents a single custom attribute.
CodeAttributeDeclarationCollection | Manages a collection that stores CodeAttributeDeclaration objects.
CodeBaseReferenceExpression | Represents a reference to the base, or super, class.
CodeBinaryOperatorExpression | Represents a binary operator expression.
CodeCastExpression | Represents a type cast expression.
CodeCatchClause | Represents a catch exception statement.
CodeCatchClauseCollection | Manages a collection of CodeCatchClause objects.
CodeClass | Represents a class or nested class.
CodeClassCollection | Manages a collection that stores CodeClass objects.
CodeClassConstructor | Represents a static constructor for a class.
CodeClassDelegate | Represents a class or nested class.
CodeClassMember | Represents a class member.
CodeClassMemberCollection | Manages a collection of CodeClassMember objects.
CodeCommentStatement | [To be supplied.]
CodeConstructor | Represents a class constructor.
CodeDelegateCreateExpression | Represents a delegate creation expression.
CodeDelegateInvokeExpression | Represents a delegate invoke expression.
CodeDelegateInvokeStatement | Represents a delegate invoke statement.
CodeExpression | Represents a code expression.
CodeExpressionCollection | Manages a collection of CodeExpression objects.
CodeFieldReferenceExpression | Represents a reference to a field.
CodeForLoopStatement | Represents a simple for loop.
CodeIfStatement | Represents a basic if statement.
CodeIndexerExpression | Represents an array indexer expression.
CodeLinePragma | Represents line number information for an external file.
CodeLiteralClassMember | Represents members of a class.
CodeLiteralExpression | Represents a literal expression.
CodeLiteralStatement | Represents a literal text statement.
CodeMemberEvent | Represents an event member.
CodeMemberField | Represents a class field member.
CodeMemberMethod | Represents a class method.
CodeMemberProperty | Represents a class property.
CodeMethodInvokeExpression | Represents a method invokation expression to be called on a given target.
CodeMethodInvokeStatement | Represents a method invoke statement to be called on a given target.
CodeMethodReturnStatement | Represents a return statement.
CodeNamespace | Represents a namespace declaration.
CodeNamespaceImport | Represents a namespace import into the current namespace.
CodeNamespaceImportCollection | Manages a collection of CodeNamespaceImport objects.
CodeObjectCreateExpression | Represents an object create ("new") expression.
CodeParameterDeclarationExpression | Represents a parameter declaration for method, constructor, or property arguments.
CodeParameterDeclarationExpressionCollection | Manages a collection of CodeParameterDeclarationExpression objects
CodePrimitiveExpression | Represents a primitive value.
CodePropertyReferenceExpression | Represents a reference to a property.
CodeStatement | Represents a statement. Base class for statements in the CodeDOM model.
CodeStatementCollection | Manages a collection of CodeStatement objects.
CodeThisReferenceExpression | Represents a current instance reference. (the class object that is referenced by "this" or "me".)
CodeThrowExceptionStatement | Represents a statement that throws an exception.
CodeTryCatchFinallyStatement | Represents a try block, with any number of catch clauses and an optionally finally block.
CodeTypeOfExpression | Represents a TypeOf expression.
CodeTypeReferenceExpression | Represents a reference to a type. This is normally used for the "TargetObject" of a static method call or field reference.
CodeVariableDeclarationStatement | Represents a local variable declaration.

Enumerations

Enumeration | Description
CodeBinaryOperatorType | Specifies the types for supported binary operators.
FieldDirection | Specifies values used to indicate field and parameter directions.
MemberAttributes | Specifies member attributes used for class members.


CodeArrayCreateExpression Class

Represents an anonymous array creation expression.

Object
CodeExpression
CodeArrayCreateExpression

[Visual Basic]
Public Class CodeArrayCreateExpression
   Inherits CodeExpression
[C#]
public class CodeArrayCreateExpression : CodeExpression
[C++]
public __gc class CodeArrayCreateExpression : public CodeExpression
[JScript]
public class CodeArrayCreateExpression extends CodeExpression

Remarks

Languages that don't support anonymous arrays may choose to implement this through a temporary local.

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeArrayCreateExpression Members | System.CodeDOM Namespace


CodeArrayCreateExpression Members

Public:

Constructor

CodeArrayCreateExpression Constructor Overloaded. [To be supplied.]

Properties

CreateType | Gets or sets the type of the array to create.
Initializers | Gets or sets the initializers to initialize the array with.
Size | Gets or sets the size of the array.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeArrayCreateExpression Class | System.CodeDOM Namespace


CodeArrayCreateExpression Constructor

[To be supplied.]

Overload List

Initializes a new instance of CodeArrayCreateExpression.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeArrayCreateExpression();
[C++] public: CodeArrayCreateExpression();
[JScript] public function CodeArrayCreateExpression();

Initializes a new instance of CodeArrayCreateExpression with the specified array type and initializers.

[Visual Basic] Overloads Public Sub New(String, CodeExpression())
[C#] public CodeArrayCreateExpression(String, CodeExpression[]);
[C++] public: CodeArrayCreateExpression(String*, CodeExpression[]);
[JScript] public function CodeArrayCreateExpression(String, CodeExpression[]);

Initializes a new instance of CodeArrayCreateExpression. with the specified array type and size.

[Visual Basic] Overloads Public Sub New(String, Integer)
[C#] public CodeArrayCreateExpression(String, int);
[C++] public: CodeArrayCreateExpression(String*, int);
[JScript] public function CodeArrayCreateExpression(String, int);

See Also

CodeArrayCreateExpression Class | CodeArrayCreateExpression Members | System.CodeDOM Namespace


CodeArrayCreateExpression Constructor ()

Initializes a new instance of CodeArrayCreateExpression.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeArrayCreateExpression();
[C++]
public: CodeArrayCreateExpression();
[JScript]
public function CodeArrayCreateExpression();

See Also

CodeArrayCreateExpression Class | CodeArrayCreateExpression Members | System.CodeDOM Namespace | CodeArrayCreateExpression Constructor Overload List


CodeArrayCreateExpression Constructor (String, CodeExpression[])

Initializes a new instance of CodeArrayCreateExpression with the specified array type and initializers.

[Visual Basic]
Overloads Public Sub New( _
   ByVal createType As String, _
   ByVal initializers() As CodeExpression _
)
[C#]
public CodeArrayCreateExpression(
   string createType,
   CodeExpression[] initializers
);
[C++]
public: CodeArrayCreateExpression(
   String* createType,
   CodeExpression* initializers[]
);
[JScript]
public function CodeArrayCreateExpression(
   createType : String,
   initializers : CodeExpression[]
);

Parameters

createType
The type of the array.
initializers
[To be supplied.]

See Also

CodeArrayCreateExpression Class | CodeArrayCreateExpression Members | System.CodeDOM Namespace | CodeArrayCreateExpression Constructor Overload List


CodeArrayCreateExpression Constructor (String, Int32)

Initializes a new instance of CodeArrayCreateExpression. with the specified array type and size.

[Visual Basic]
Overloads Public Sub New( _
   ByVal createType As String, _
   ByVal size As Integer _
)
[C#]
public CodeArrayCreateExpression(
   string createType,
   int size
);
[C++]
public: CodeArrayCreateExpression(
   String* createType,
   int size
);
[JScript]
public function CodeArrayCreateExpression(
   createType : String,
   size : int
);

Parameters

createType
The type of the array.
size
[To be supplied.]

See Also

CodeArrayCreateExpression Class | CodeArrayCreateExpression Members | System.CodeDOM Namespace | CodeArrayCreateExpression Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeArrayCreateExpression Properties

The properties of the CodeArrayCreateExpression class are listed below. For a complete list of CodeArrayCreateExpression class members, see the CodeArrayCreateExpression Members topic.

Public:

CreateType | Gets or sets the type of the array to create.
Initializers | Gets or sets the initializers to initialize the array with.
Size | Gets or sets the size of the array.

See Also

CodeArrayCreateExpression Class | System.CodeDOM Namespace


CodeArrayCreateExpression.CreateType

Gets or sets the type of the array to create.

[Visual Basic]
Public Property CreateType As String
[C#]
public string CreateType {get; set;}
[C++]
public: __property String* get_CreateType();
public: __property void set_CreateType(String*);
[JScript]
public function get CreateType() : String;
public function set CreateType(String);

Property Value

The name of the type of the array.

See Also

CodeArrayCreateExpression Class | CodeArrayCreateExpression Members | System.CodeDOM Namespace


CodeArrayCreateExpression.Initializers

Gets or sets the initializers to initialize the array with.

[Visual Basic]
Public ReadOnly Property Initializers As CodeExpressionCollection
[C#]
public CodeExpressionCollection Initializers {get;}
[C++]
public: __property CodeExpressionCollection* get_Initializers();
[JScript]
public function get Initializers() : CodeExpressionCollection;

Property Value

A CodeExpressionCollection that indicates the initialization values.

See Also

CodeArrayCreateExpression Class | CodeArrayCreateExpression Members | System.CodeDOM Namespace


CodeArrayCreateExpression.Size

Gets or sets the size of the array.

[Visual Basic]
Public Property Size As Integer
[C#]
public int Size {get; set;}
[C++]
public: __property int get_Size();
public: __property void set_Size(int);
[JScript]
public function get Size() : int;
public function set Size(int);

Property Value

The number of indexers in the array.

See Also

CodeArrayCreateExpression Class | CodeArrayCreateExpression Members | System.CodeDOM Namespace


CodeAssignStatement Class

Represents a simple assignment statement.

Object
CodeStatement
CodeAssignStatement

[Visual Basic]
Public Class CodeAssignStatement
   Inherits CodeStatement
[C#]
public class CodeAssignStatement : CodeStatement
[C++]
public __gc class CodeAssignStatement : public CodeStatement
[JScript]
public class CodeAssignStatement extends CodeStatement

Remarks

Simple assignment statements are normally of the form "value1 = value2".

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeAssignStatement Members | System.CodeDOM Namespace


CodeAssignStatement Members

Public:

Constructor

CodeAssignStatement Constructor Overloaded. Initializes a new instance of CodeAssignStatement.

Properties

Left | Gets or sets the variable to be assigned to.
LinePragma (inherited from CodeStatement) | The line the statement occurs on.
Right | Gets or sets the value to assign.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeAssignStatement Class | System.CodeDOM Namespace


CodeAssignStatement Constructor

Initializes a new instance of CodeAssignStatement.

Overload List

Initializes a new instance of CodeAssignStatement.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeAssignStatement();
[C++] public: CodeAssignStatement();
[JScript] public function CodeAssignStatement();

Initializes a new instance of CodeAssignStatement that represents the specified assignment values.

[Visual Basic] Overloads Public Sub New(CodeExpression, CodeExpression)
[C#] public CodeAssignStatement(CodeExpression, CodeExpression);
[C++] public: CodeAssignStatement(CodeExpression*, CodeExpression*);
[JScript] public function CodeAssignStatement(CodeExpression, CodeExpression);

See Also

CodeAssignStatement Class | CodeAssignStatement Members | System.CodeDOM Namespace


CodeAssignStatement Constructor ()

Initializes a new instance of CodeAssignStatement.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeAssignStatement();
[C++]
public: CodeAssignStatement();
[JScript]
public function CodeAssignStatement();

See Also

CodeAssignStatement Class | CodeAssignStatement Members | System.CodeDOM Namespace | CodeAssignStatement Constructor Overload List


CodeAssignStatement Constructor (CodeExpression, CodeExpression)

Initializes a new instance of CodeAssignStatement that represents the specified assignment values.

[Visual Basic]
Overloads Public Sub New( _
   ByVal left As CodeExpression, _
   ByVal right As CodeExpression _
)
[C#]
public CodeAssignStatement(
   CodeExpression left,
   CodeExpression right
);
[C++]
public: CodeAssignStatement(
   CodeExpression* left,
   CodeExpression* right
);
[JScript]
public function CodeAssignStatement(
   left : CodeExpression,
   right : CodeExpression
);

Parameters

left
The variable to assign to.
right
[To be supplied.]

See Also

CodeAssignStatement Class | CodeAssignStatement Members | System.CodeDOM Namespace | CodeAssignStatement Constructor Overload List | CodeExpression


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeAssignStatement Properties

The properties of the CodeAssignStatement class are listed below. For a complete list of CodeAssignStatement class members, see the CodeAssignStatement Members topic.

Public:

Left | Gets or sets the variable to be assigned to.
LinePragma (inherited from CodeStatement) | The line the statement occurs on.
Right | Gets or sets the value to assign.

See Also

CodeAssignStatement Class | System.CodeDOM Namespace


CodeAssignStatement.Left

Gets or sets the variable to be assigned to.

[Visual Basic]
Public Property Left As CodeExpression
[C#]
public CodeExpression Left {get; set;}
[C++]
public: __property CodeExpression* get_Left();
public: __property void set_Left(CodeExpression*);
[JScript]
public function get Left() : CodeExpression;
public function set Left(CodeExpression);

Property Value

A CodeExpression representing the value or object to be assigned to.

See Also

CodeAssignStatement Class | CodeAssignStatement Members | System.CodeDOM Namespace | CodeExpression | System.CodeDOM.CodeAssignStatement.CodeAssignStatement


CodeAssignStatement.Right

Gets or sets the value to assign.

[Visual Basic]
Public Property Right As CodeExpression
[C#]
public CodeExpression Right {get; set;}
[C++]
public: __property CodeExpression* get_Right();
public: __property void set_Right(CodeExpression*);
[JScript]
public function get Right() : CodeExpression;
public function set Right(CodeExpression);

Property Value

A CodeExpression that represents the value to assign.

See Also

CodeAssignStatement Class | CodeAssignStatement Members | System.CodeDOM Namespace | CodeExpression | System.CodeDOM.CodeAssignStatement.CodeAssignStatement


CodeAttributeArgument Class

Represents an argument for a custom attribute declaration. The name is used for named arguments.

Object
CodeAttributeArgument

[Visual Basic]
Public Class CodeAttributeArgument
[C#]
public class CodeAttributeArgument
[C++]
public __gc class CodeAttributeArgument
[JScript]
public class CodeAttributeArgument

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeAttributeArgument Members | System.CodeDOM Namespace


CodeAttributeArgument Members

Public:

Constructor

CodeAttributeArgument Constructor Overloaded. Initializes a new instance of CodeAttributeArgument.

Properties

Name | The name of the attribute.
Value | The argument for the attribute.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeAttributeArgument Class | System.CodeDOM Namespace


CodeAttributeArgument Constructor

Initializes a new instance of CodeAttributeArgument.

Overload List

Initializes a new instance of CodeAttributeArgument.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeAttributeArgument();
[C++] public: CodeAttributeArgument();
[JScript] public function CodeAttributeArgument();

Initializes a new instance of CodeAttributeArgument using the specified value.

[Visual Basic] Overloads Public Sub New(CodeExpression)
[C#] public CodeAttributeArgument(CodeExpression);
[C++] public: CodeAttributeArgument(CodeExpression*);
[JScript] public function CodeAttributeArgument(CodeExpression);

Initializes a new instance of CodeAttributeArgument using the specified name and value.

[Visual Basic] Overloads Public Sub New(String, CodeExpression)
[C#] public CodeAttributeArgument(String, CodeExpression);
[C++] public: CodeAttributeArgument(String*, CodeExpression);
[JScript] public function CodeAttributeArgument(String, CodeExpression);

See Also

CodeAttributeArgument Class | CodeAttributeArgument Members | System.CodeDOM Namespace


CodeAttributeArgument Constructor ()

Initializes a new instance of CodeAttributeArgument.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeAttributeArgument();
[C++]
public: CodeAttributeArgument();
[JScript]
public function CodeAttributeArgument();

See Also

CodeAttributeArgument Class | CodeAttributeArgument Members | System.CodeDOM Namespace | CodeAttributeArgument Constructor Overload List


CodeAttributeArgument Constructor (CodeExpression)

Initializes a new instance of CodeAttributeArgument using the specified value.

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As CodeExpression _
)
[C#]
public CodeAttributeArgument(
   CodeExpression value
);
[C++]
public: CodeAttributeArgument(
   CodeExpression* value
);
[JScript]
public function CodeAttributeArgument(
   value : CodeExpression
);

Parameters

value
A CodeExpression that represents the value of the argument.

See Also

CodeAttributeArgument Class | CodeAttributeArgument Members | System.CodeDOM Namespace | CodeAttributeArgument Constructor Overload List | CodeExpression


CodeAttributeArgument Constructor (String, CodeExpression)

Initializes a new instance of CodeAttributeArgument using the specified name and value.

[Visual Basic]
Overloads Public Sub New( _
   ByVal name As String, _
   ByVal value As CodeExpression _
)
[C#]
public CodeAttributeArgument(
   string name,
   CodeExpression value
);
[C++]
public: CodeAttributeArgument(
   String* name,
   CodeExpression* value
);
[JScript]
public function CodeAttributeArgument(
   name : String,
   value : CodeExpression
);

Parameters

name
The name of the attribute the argument applies to.
value
[To be supplied.]

See Also

CodeAttributeArgument Class | CodeAttributeArgument Members | System.CodeDOM Namespace | CodeAttributeArgument Constructor Overload List | CodeExpression


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeAttributeArgument Properties

The properties of the CodeAttributeArgument class are listed below. For a complete list of CodeAttributeArgument class members, see the CodeAttributeArgument Members topic.

Public:

Name | The name of the attribute.
Value | The argument for the attribute.

See Also

CodeAttributeArgument Class | System.CodeDOM Namespace


CodeAttributeArgument.Name

The name of the attribute.

[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}
[C++]
public: __property String* get_Name();
public: __property void set_Name(String*);
[JScript]
public function get Name() : String;
public function set Name(String);

Property Value

The name of the attribute.

See Also

CodeAttributeArgument Class | CodeAttributeArgument Members | System.CodeDOM Namespace


CodeAttributeArgument.Value

The argument for the attribute.

[Visual Basic]
Public Property Value As CodeExpression
[C#]
public CodeExpression Value {get; set;}
[C++]
public: __property CodeExpression* get_Value();
public: __property void set_Value(CodeExpression*);
[JScript]
public function get Value() : CodeExpression;
public function set Value(CodeExpression);

Property Value

A CodeExpression that indicates the value for the attribute.

See Also

CodeAttributeArgument Class | CodeAttributeArgument Members | System.CodeDOM Namespace | CodeExpression


CodeAttributeArgumentCollection Class

Manages a collection of CodeAttributeArgument objects.

Object
CodeAttributeArgumentCollection

[Visual Basic]
Public Class CodeAttributeArgumentCollection
   Implements IList, ICollection, IEnumerable
[C#]
public class CodeAttributeArgumentCollection : IList, ICollection,
   IEnumerable
[C++]
public __gc class CodeAttributeArgumentCollection : public IList,
   ICollection, IEnumerable
[JScript]
public class CodeAttributeArgumentCollection implements IList,
   ICollection, IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeAttributeArgumentCollection Members | System.CodeDOM Namespace


CodeAttributeArgumentCollection Members

Public:

Constructor

CodeAttributeArgumentCollection Constructor [To be supplied.]

Properties

Count | The count of the objects in the collection.
Item | Gets or sets the specified CodeAttributeArgument in the collection. Accessor to the stored collection. In C#, this member is the indexer for the CodeAttributeArgumentCollection class.

Methods

Add | Adds a CodeAttributeArgument to the collection.
AddRange | Adds a group of CodeAttributeArgument values to the collection.
Clear | Clears the collection.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Gets an enumerator that represents the collection's objects.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeAttributeArgumentCollection Class | System.CodeDOM Namespace


CodeAttributeArgumentCollection Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CodeAttributeArgumentCollection();
[C++]
public: CodeAttributeArgumentCollection();
[JScript]
public function CodeAttributeArgumentCollection();

See Also

CodeAttributeArgumentCollection Class | CodeAttributeArgumentCollection Members | System.CodeDOM Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeAttributeArgumentCollection Properties

The properties of the CodeAttributeArgumentCollection class are listed below. For a complete list of CodeAttributeArgumentCollection class members, see the CodeAttributeArgumentCollection Members topic.

Public:

Count | The count of the objects in the collection.
Item | Gets or sets the specified CodeAttributeArgument in the collection. Accessor to the stored collection. In C#, this member is the indexer for the CodeAttributeArgumentCollection class.

See Also

CodeAttributeArgumentCollection Class | System.CodeDOM Namespace


CodeAttributeArgumentCollection.Count

The count of the objects in the collection.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

Property Value

The number of objects in the collection.

See Also

CodeAttributeArgumentCollection Class | CodeAttributeArgumentCollection Members | System.CodeDOM Namespace


CodeAttributeArgumentCollection.Item

Gets or sets the specified CodeAttributeArgument in the collection. Accessor to the stored collection.

[C#] In C#, this member is the indexer for the CodeAttributeArgumentCollection class.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As CodeAttributeArgument
[C#]
public CodeAttributeArgument this[
   int index
] {get; set;}
[C++]
public: __property CodeAttributeArgument* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   CodeAttributeArgument*
);
[JScript]
returnValue = CodeAttributeArgumentCollectionObject.Item(index);
CodeAttributeArgumentCollectionObject.Item(index) = returnValue;
-or-
returnValue = CodeAttributeArgumentCollectionObject(index);
CodeAttributeArgumentCollectionObject(index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
The index of the collection to access.

Parameters [Visual Basic, C#, C++]

index
The index of the collection to access.

See Also

CodeAttributeArgumentCollection Class | CodeAttributeArgumentCollection Members | System.CodeDOM Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeAttributeArgumentCollection Methods

The methods of the CodeAttributeArgumentCollection class are listed below. For a complete list of CodeAttributeArgumentCollection class members, see the CodeAttributeArgumentCollection Members topic.

Public:

Add | Adds a CodeAttributeArgument to the collection.
AddRange | Adds a group of CodeAttributeArgument values to the collection.
Clear | Clears the collection.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Gets an enumerator that represents the collection's objects.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeAttributeArgumentCollection Class | System.CodeDOM Namespace


CodeAttributeArgumentCollection.Add

Adds a CodeAttributeArgument to the collection.

[Visual Basic]
Public Sub Add( _
   ByVal value As CodeAttributeArgument _
)
[C#]
public void Add(
   CodeAttributeArgument value
);
[C++]
public: void Add(
   CodeAttributeArgument* value
);
[JScript]
public function Add(
   value : CodeAttributeArgument
);

Parameters

value
The attribute argument to add to the collection.

See Also

CodeAttributeArgumentCollection Class | CodeAttributeArgumentCollection Members | System.CodeDOM Namespace | CodeAttributeArgument


CodeAttributeArgumentCollection.AddRange

Adds a group of CodeAttributeArgument values to the collection.

[Visual Basic]
Public Sub AddRange( _
   ByVal value() As CodeAttributeArgument _
)
[C#]
public void AddRange(
   CodeAttributeArgument[] value
);
[C++]
public: void AddRange(
   CodeAttributeArgument* value[]
);
[JScript]
public function AddRange(
   value : CodeAttributeArgument[]
);

Parameters

value
The set of attribute arguments to add to the collection.

See Also

CodeAttributeArgumentCollection Class | CodeAttributeArgumentCollection Members | System.CodeDOM Namespace | CodeAttributeArgument


CodeAttributeArgumentCollection.Clear

Clears the collection.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[JScript]
public function Clear();

See Also

CodeAttributeArgumentCollection Class | CodeAttributeArgumentCollection Members | System.CodeDOM Namespace


CodeAttributeArgumentCollection.GetEnumerator

Gets an enumerator that represents the collection's objects.

[Visual Basic]
Public Function GetEnumerator() As IEnumerator
[C#]
public IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

See Also

CodeAttributeArgumentCollection Class | CodeAttributeArgumentCollection Members | System.CodeDOM Namespace | System.CodeDOM.IEnumerator


CodeAttributeBlock Class

Represents a block of custom attributes.

Object
CodeAttributeBlock

[Visual Basic]
Public Class CodeAttributeBlock
[C#]
public class CodeAttributeBlock
[C++]
public __gc class CodeAttributeBlock
[JScript]
public class CodeAttributeBlock

Remarks

This may contain one or more attribute declarations.

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeAttributeBlock Members | System.CodeDOM Namespace


CodeAttributeBlock Members

Public:

Constructor

CodeAttributeBlock Constructor Overloaded. Initializes a new instance of CodeAttributeBlock.

Properties

Attributes A collection of CodeAttributeDeclaration objects.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeAttributeBlock Class | System.CodeDOM Namespace


CodeAttributeBlock Constructor

Initializes a new instance of CodeAttributeBlock.

Overload List

Initializes a new instance of CodeAttributeBlock.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeAttributeBlock();
[C++] public: CodeAttributeBlock();
[JScript] public function CodeAttributeBlock();

Initializes a new instance of CodeAttributeBlock using the specified attribute(s).

[Visual Basic] Overloads Public Sub New(CodeAttributeDeclaration())
[C#] public CodeAttributeBlock(CodeAttributeDeclaration[]);
[C++] public: CodeAttributeBlock(CodeAttributeDeclaration*[]);
[JScript] public function CodeAttributeBlock(CodeAttributeDeclaration[]);

See Also

CodeAttributeBlock Class | CodeAttributeBlock Members | System.CodeDOM Namespace


CodeAttributeBlock Constructor ()

Initializes a new instance of CodeAttributeBlock.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeAttributeBlock();
[C++]
public: CodeAttributeBlock();
[JScript]
public function CodeAttributeBlock();

See Also

CodeAttributeBlock Class | CodeAttributeBlock Members | System.CodeDOM Namespace | CodeAttributeBlock Constructor Overload List


CodeAttributeBlock Constructor (CodeAttributeDeclaration[])

Initializes a new instance of CodeAttributeBlock using the specified attribute(s).

[Visual Basic]
Overloads Public Sub New( _
   ByVal attributes() As CodeAttributeDeclaration _
)
[C#]
public CodeAttributeBlock(
   CodeAttributeDeclaration[] attributes
);
[C++]
public: CodeAttributeBlock(
   CodeAttributeDeclaration* attributes[]
);
[JScript]
public function CodeAttributeBlock(
   attributes : CodeAttributeDeclaration[]
);

Parameters

attributes
The attributes to represent.

See Also

CodeAttributeBlock Class | CodeAttributeBlock Members | System.CodeDOM Namespace | CodeAttributeBlock Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeAttributeBlock Properties

The properties of the CodeAttributeBlock class are listed below. For a complete list of CodeAttributeBlock class members, see the CodeAttributeBlock Members topic.

Public:

Attributes A collection of CodeAttributeDeclaration objects.

See Also

CodeAttributeBlock Class | System.CodeDOM Namespace


CodeAttributeBlock.Attributes

A collection of CodeAttributeDeclaration objects.

[Visual Basic]
Public ReadOnly Property Attributes As _
   CodeAttributeDeclarationCollection
[C#]
public CodeAttributeDeclarationCollection Attributes {get;}
[C++]
public: __property CodeAttributeDeclarationCollection*
   get_Attributes();
[JScript]
public function get Attributes() :
   CodeAttributeDeclarationCollection;

Property Value

A CodeAttributeDeclarationCollection that contains the CodeAttributeDeclaration objects that represent the attribute block.

See Also

CodeAttributeBlock Class | CodeAttributeBlock Members | System.CodeDOM Namespace


CodeAttributeDeclaration Class

Represents a single custom attribute.

Object
CodeAttributeDeclaration

[Visual Basic]
Public Class CodeAttributeDeclaration
[C#]
public class CodeAttributeDeclaration
[C++]
public __gc class CodeAttributeDeclaration
[JScript]
public class CodeAttributeDeclaration

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeAttributeDeclaration Members | System.CodeDOM Namespace


CodeAttributeDeclaration Members

Public:

Constructor

CodeAttributeDeclaration Constructor Overloaded. Initializes a new instance of CodeAttributeDeclaration.

Properties

Arguments | The arguments for the attribute.
Name | The name of the attribute being declared.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeAttributeDeclaration Class | System.CodeDOM Namespace


CodeAttributeDeclaration Constructor

Initializes a new instance of CodeAttributeDeclaration.

Overload List

Initializes a new instance of CodeAttributeDeclaration.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeAttributeDeclaration();
[C++] public: CodeAttributeDeclaration();
[JScript] public function CodeAttributeDeclaration();

Initializes a new instance of CodeAttributeDeclaration using the specified name.

[Visual Basic] Overloads Public Sub New(String)
[C#] public CodeAttributeDeclaration(String);
[C++] public: CodeAttributeDeclaration(String*);
[JScript] public function CodeAttributeDeclaration(String);

Initializes a new instance of CodeAttributeDeclaration using the specified arguments.

[Visual Basic] Overloads Public Sub New(String, CodeAttributeArgument())
[C#] public CodeAttributeDeclaration(String, CodeAttributeArgument[]);
[C++] public: CodeAttributeDeclaration(String*, CodeAttributeArgument[]);
[JScript] public function CodeAttributeDeclaration(String, CodeAttributeArgument[]);

See Also

CodeAttributeDeclaration Class | CodeAttributeDeclaration Members | System.CodeDOM Namespace


CodeAttributeDeclaration Constructor ()

Initializes a new instance of CodeAttributeDeclaration.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeAttributeDeclaration();
[C++]
public: CodeAttributeDeclaration();
[JScript]
public function CodeAttributeDeclaration();

See Also

CodeAttributeDeclaration Class | CodeAttributeDeclaration Members | System.CodeDOM Namespace | CodeAttributeDeclaration Constructor Overload List


CodeAttributeDeclaration Constructor (String)

Initializes a new instance of CodeAttributeDeclaration using the specified name.

[Visual Basic]
Overloads Public Sub New( _
   ByVal name As String _
)
[C#]
public CodeAttributeDeclaration(
   string name
);
[C++]
public: CodeAttributeDeclaration(
   String* name
);
[JScript]
public function CodeAttributeDeclaration(
   name : String
);

Parameters

name
The name of the attribute.

See Also

CodeAttributeDeclaration Class | CodeAttributeDeclaration Members | System.CodeDOM Namespace | CodeAttributeDeclaration Constructor Overload List


CodeAttributeDeclaration Constructor (String, CodeAttributeArgument[])

Initializes a new instance of CodeAttributeDeclaration using the specified arguments.

[Visual Basic]
Overloads Public Sub New( _
   ByVal name As String, _
   ByVal arguments() As CodeAttributeArgument _
)
[C#]
public CodeAttributeDeclaration(
   string name,
   CodeAttributeArgument[] arguments
);
[C++]
public: CodeAttributeDeclaration(
   String* name,
   CodeAttributeArgument* arguments[]
);
[JScript]
public function CodeAttributeDeclaration(
   name : String,
   arguments : CodeAttributeArgument[]
);

Parameters

name
[To be supplied.]
arguments
The arguments for the attribute.

See Also

CodeAttributeDeclaration Class | CodeAttributeDeclaration Members | System.CodeDOM Namespace | CodeAttributeDeclaration Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeAttributeDeclaration Properties

The properties of the CodeAttributeDeclaration class are listed below. For a complete list of CodeAttributeDeclaration class members, see the CodeAttributeDeclaration Members topic.

Public:

Arguments | The arguments for the attribute.
Name | The name of the attribute being declared.

See Also

CodeAttributeDeclaration Class | System.CodeDOM Namespace


CodeAttributeDeclaration.Arguments

The arguments for the attribute.

[Visual Basic]
Public ReadOnly Property Arguments As _
   CodeAttributeArgumentCollection
[C#]
public CodeAttributeArgumentCollection Arguments {get;}
[C++]
public: __property CodeAttributeArgumentCollection* get_Arguments();
[JScript]
public function get Arguments() : CodeAttributeArgumentCollection;

Property Value

An CodeAttributeArgumentCollection that indicates the arguments for the attribute.

See Also

CodeAttributeDeclaration Class | CodeAttributeDeclaration Members | System.CodeDOM Namespace


CodeAttributeDeclaration.Name

The name of the attribute being declared.

[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}
[C++]
public: __property String* get_Name();
public: __property void set_Name(String*);
[JScript]
public function get Name() : String;
public function set Name(String);

Property Value

The name of the attribute.

See Also

CodeAttributeDeclaration Class | CodeAttributeDeclaration Members | System.CodeDOM Namespace


CodeAttributeDeclarationCollection Class

Manages a collection that stores CodeAttributeDeclaration objects.

Object
CodeAttributeDeclarationCollection

[Visual Basic]
Public Class CodeAttributeDeclarationCollection
   Implements IList, ICollection, IEnumerable
[C#]
public class CodeAttributeDeclarationCollection : IList,
   ICollection, IEnumerable
[C++]
public __gc class CodeAttributeDeclarationCollection : public
   IList, ICollection, IEnumerable
[JScript]
public class CodeAttributeDeclarationCollection implements IList,
   ICollection, IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeAttributeDeclarationCollection Members | System.CodeDOM Namespace | CodeAttributeDeclaration


CodeAttributeDeclarationCollection Members

Public:

Constructor

CodeAttributeDeclarationCollection Constructor [To be supplied.]

Properties

Count | Gets or sets the count of the objects in the collection.
Item | Collection accessor indexer method. Gets or sets the CodeAttributeDeclarationCollection at the specified index. In C#, this member is the indexer for the CodeAttributeDeclarationCollection class.

Methods

Add | Adds a CodeAttributeDeclaration to the collection.
AddRange | Adds a set of CodeAttributeDeclaration objects to the collection.
Clear | Clears the collection members.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Gets an enumerator for the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeAttributeDeclarationCollection Class | System.CodeDOM Namespace


CodeAttributeDeclarationCollection Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CodeAttributeDeclarationCollection();
[C++]
public: CodeAttributeDeclarationCollection();
[JScript]
public function CodeAttributeDeclarationCollection();

See Also

CodeAttributeDeclarationCollection Class | CodeAttributeDeclarationCollection Members | System.CodeDOM Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeAttributeDeclarationCollection Properties

The properties of the CodeAttributeDeclarationCollection class are listed below. For a complete list of CodeAttributeDeclarationCollection class members, see the CodeAttributeDeclarationCollection Members topic.

Public:

Count | Gets or sets the count of the objects in the collection.
Item | Collection accessor indexer method. Gets or sets the CodeAttributeDeclarationCollection at the specified index. In C#, this member is the indexer for the CodeAttributeDeclarationCollection class.

See Also

CodeAttributeDeclarationCollection Class | System.CodeDOM Namespace


CodeAttributeDeclarationCollection.Count

Gets or sets the count of the objects in the collection.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

Property Value

The number of the objects in the collection.

See Also

CodeAttributeDeclarationCollection Class | CodeAttributeDeclarationCollection Members | System.CodeDOM Namespace


CodeAttributeDeclarationCollection.Item

Collection accessor indexer method. Gets or sets the CodeAttributeDeclarationCollection at the specified index.

[C#] In C#, this member is the indexer for the CodeAttributeDeclarationCollection class.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As CodeAttributeDeclaration
[C#]
public CodeAttributeDeclaration this[
   int index
] {get; set;}
[C++]
public: __property CodeAttributeDeclaration* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   CodeAttributeDeclaration*
);
[JScript]
returnValue = CodeAttributeDeclarationCollectionObject.Item(index);
CodeAttributeDeclarationCollectionObject.Item(index) = returnValue;
-or-
returnValue = CodeAttributeDeclarationCollectionObject(index);
CodeAttributeDeclarationCollectionObject(index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
The index to get or set.

Parameters [Visual Basic, C#, C++]

index
The index to get or set.

See Also

CodeAttributeDeclarationCollection Class | CodeAttributeDeclarationCollection Members | System.CodeDOM Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeAttributeDeclarationCollection Methods

The methods of the CodeAttributeDeclarationCollection class are listed below. For a complete list of CodeAttributeDeclarationCollection class members, see the CodeAttributeDeclarationCollection Members topic.

Public:

Add | Adds a CodeAttributeDeclaration to the collection.
AddRange | Adds a set of CodeAttributeDeclaration objects to the collection.
Clear | Clears the collection members.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Gets an enumerator for the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeAttributeDeclarationCollection Class | System.CodeDOM Namespace


CodeAttributeDeclarationCollection.Add

Adds a CodeAttributeDeclaration to the collection.

[Visual Basic]
Public Sub Add( _
   ByVal value As CodeAttributeDeclaration _
)
[C#]
public void Add(
   CodeAttributeDeclaration value
);
[C++]
public: void Add(
   CodeAttributeDeclaration* value
);
[JScript]
public function Add(
   value : CodeAttributeDeclaration
);

Parameters

value
The CodeAttributeDeclaration to add.

See Also

CodeAttributeDeclarationCollection Class | CodeAttributeDeclarationCollection Members | System.CodeDOM Namespace | CodeAttributeDeclaration


CodeAttributeDeclarationCollection.AddRange

Adds a set of CodeAttributeDeclaration objects to the collection.

[Visual Basic]
Public Sub AddRange( _
   ByVal value() As CodeAttributeDeclaration _
)
[C#]
public void AddRange(
   CodeAttributeDeclaration[] value
);
[C++]
public: void AddRange(
   CodeAttributeDeclaration* value[]
);
[JScript]
public function AddRange(
   value : CodeAttributeDeclaration[]
);

Parameters

value
An array of type CodeAttributeDeclaration.

See Also

CodeAttributeDeclarationCollection Class | CodeAttributeDeclarationCollection Members | System.CodeDOM Namespace | CodeAttributeDeclaration


CodeAttributeDeclarationCollection.Clear

Clears the collection members.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[JScript]
public function Clear();

See Also

CodeAttributeDeclarationCollection Class | CodeAttributeDeclarationCollection Members | System.CodeDOM Namespace


CodeAttributeDeclarationCollection.GetEnumerator

Gets an enumerator for the collection.

[Visual Basic]
Public Function GetEnumerator() As IEnumerator
[C#]
public IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

Return Value

An IEnumerator that enumerates the collection members.

See Also

CodeAttributeDeclarationCollection Class | CodeAttributeDeclarationCollection Members | System.CodeDOM Namespace | IEnumerator | CodeAttributeDeclaration


CodeBaseReferenceExpression Class

Represents a reference to the base, or super, class.

Object
CodeExpression
CodeBaseReferenceExpression

[Visual Basic]
Public Class CodeBaseReferenceExpression
   Inherits CodeExpression
[C#]
public class CodeBaseReferenceExpression : CodeExpression
[C++]
public __gc class CodeBaseReferenceExpression : public
   CodeExpression
[JScript]
public class CodeBaseReferenceExpression extends CodeExpression

Remarks

This is used to call base class methods.

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeBaseReferenceExpression Members | System.CodeDOM Namespace


CodeBaseReferenceExpression Members

Public:

Constructor

CodeBaseReferenceExpression Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeBaseReferenceExpression Class | System.CodeDOM Namespace


CodeBaseReferenceExpression Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CodeBaseReferenceExpression();
[C++]
public: CodeBaseReferenceExpression();
[JScript]
public function CodeBaseReferenceExpression();

See Also

CodeBaseReferenceExpression Class | CodeBaseReferenceExpression Members | System.CodeDOM Namespace


CodeBinaryOperatorExpression Class

Represents a binary operator expression.

Object
CodeExpression
CodeBinaryOperatorExpression

[Visual Basic]
Public Class CodeBinaryOperatorExpression
   Inherits CodeExpression
[C#]
public class CodeBinaryOperatorExpression : CodeExpression
[C++]
public __gc class CodeBinaryOperatorExpression : public
   CodeExpression
[JScript]
public class CodeBinaryOperatorExpression extends CodeExpression

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeBinaryOperatorExpression Members | System.CodeDOM Namespace | CodeExpression | CodeBinaryOperatorType


CodeBinaryOperatorExpression Members

Public:

Constructor

CodeBinaryOperatorExpression Constructor Overloaded. Initializes a new instance of CodeBinaryOperatorExpression.

Properties

Left | Gets or sets the code expression on the left of the operator.
Operator | Gets or sets the operator in the binary operator expression.
Right | Gets or sets the code expression on the right of the operator.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeBinaryOperatorExpression Class | System.CodeDOM Namespace


CodeBinaryOperatorExpression Constructor

Initializes a new instance of CodeBinaryOperatorExpression.

Overload List

Initializes a new instance of CodeBinaryOperatorExpression.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeBinaryOperatorExpression();
[C++] public: CodeBinaryOperatorExpression();
[JScript] public function CodeBinaryOperatorExpression();

Initializes a new instance of CodeBinaryOperatorExpression using the specified parameters.

[Visual Basic] Overloads Public Sub New(CodeExpression, CodeBinaryOperatorType, CodeExpression)
[C#] public CodeBinaryOperatorExpression(CodeExpression, CodeBinaryOperatorType, CodeExpression);
[C++] public: CodeBinaryOperatorExpression(CodeExpression*, CodeBinaryOperatorType, CodeExpression*);
[JScript] public function CodeBinaryOperatorExpression(CodeExpression, CodeBinaryOperatorType, CodeExpression);

See Also

CodeBinaryOperatorExpression Class | CodeBinaryOperatorExpression Members | System.CodeDOM Namespace


CodeBinaryOperatorExpression Constructor ()

Initializes a new instance of CodeBinaryOperatorExpression.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeBinaryOperatorExpression();
[C++]
public: CodeBinaryOperatorExpression();
[JScript]
public function CodeBinaryOperatorExpression();

See Also

CodeBinaryOperatorExpression Class | CodeBinaryOperatorExpression Members | System.CodeDOM Namespace | CodeBinaryOperatorExpression Constructor Overload List | CodeExpression | CodeBinaryOperatorType


CodeBinaryOperatorExpression Constructor (CodeExpression, CodeBinaryOperatorType, CodeExpression)

Initializes a new instance of CodeBinaryOperatorExpression using the specified parameters.

[Visual Basic]
Overloads Public Sub New( _
   ByVal left As CodeExpression, _
   ByVal op As CodeBinaryOperatorType, _
   ByVal right As CodeExpression _
)
[C#]
public CodeBinaryOperatorExpression(
   CodeExpression left,
   CodeBinaryOperatorType op,
   CodeExpression right
);
[C++]
public: CodeBinaryOperatorExpression(
   CodeExpression* left,
   CodeBinaryOperatorType op,
   CodeExpression* right
);
[JScript]
public function CodeBinaryOperatorExpression(
   left : CodeExpression,
   op : CodeBinaryOperatorType,
   right : CodeExpression
);

Parameters

left
The left CodeExpression.
op
[To be supplied.]
right
[To be supplied.]

See Also

CodeBinaryOperatorExpression Class | CodeBinaryOperatorExpression Members | System.CodeDOM Namespace | CodeBinaryOperatorExpression Constructor Overload List | CodeExpression


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeBinaryOperatorExpression Properties

The properties of the CodeBinaryOperatorExpression class are listed below. For a complete list of CodeBinaryOperatorExpression class members, see the CodeBinaryOperatorExpression Members topic.

Public:

Left | Gets or sets the code expression on the left of the operator.
Operator | Gets or sets the operator in the binary operator expression.
Right | Gets or sets the code expression on the right of the operator.

See Also

CodeBinaryOperatorExpression Class | System.CodeDOM Namespace


CodeBinaryOperatorExpression.Left

Gets or sets the code expression on the left of the operator.

[Visual Basic]
Public Property Left As CodeExpression
[C#]
public CodeExpression Left {get; set;}
[C++]
public: __property CodeExpression* get_Left();
public: __property void set_Left(CodeExpression*);
[JScript]
public function get Left() : CodeExpression;
public function set Left(CodeExpression);

Property Value

A CodeExpression representing the code on the left of the operator.

See Also

CodeBinaryOperatorExpression Class | CodeBinaryOperatorExpression Members | System.CodeDOM Namespace


CodeBinaryOperatorExpression.Operator

Gets or sets the operator in the binary operator expression.

[Visual Basic]
Public Property Operator As CodeBinaryOperatorType
[C#]
public CodeBinaryOperatorType Operator {get; set;}
[C++]
public: __property CodeBinaryOperatorType get_Operator();
public: __property void set_Operator(CodeBinaryOperatorType);
[JScript]
public function get Operator() : CodeBinaryOperatorType;
public function set Operator(CodeBinaryOperatorType);

Property Value

A CodeBinaryOperatorType that indicates the operator in the expression.

See Also

CodeBinaryOperatorExpression Class | CodeBinaryOperatorExpression Members | System.CodeDOM Namespace | CodeBinaryOperatorType


CodeBinaryOperatorExpression.Right

Gets or sets the code expression on the right of the operator.

[Visual Basic]
Public Property Right As CodeExpression
[C#]
public CodeExpression Right {get; set;}
[C++]
public: __property CodeExpression* get_Right();
public: __property void set_Right(CodeExpression*);
[JScript]
public function get Right() : CodeExpression;
public function set Right(CodeExpression);

Property Value

A CodeExpression representing the code on the right of the operator.

See Also

CodeBinaryOperatorExpression Class | CodeBinaryOperatorExpression Members | System.CodeDOM Namespace | CodeExpression


CodeBinaryOperatorType Enumeration

Specifies the types for supported binary operators.

[Visual Basic]
Public Enum CodeBinaryOperatorType
[C#]
public enum CodeBinaryOperatorType
[C++]
public enum CodeBinaryOperatorType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Add | Addition operator.
Assign | Assignment operator.
BitwiseAnd | Bitwise and operator.
BitwiseOr | Bitwise or operator.
BooleanAnd | Boolean and operator.
BooleanOr | Boolean or operator.
Divide | Division operator.
GreaterThan | Greater than operator.
GreaterThanOrEqual | Greater that or operator.
IdentityEquality | Identity equal operator.
IdentityInequality | Identity not equal operator.
LessThan | Less than operator.
LessThanOrEqual | Less than or equal operator.
Multiply | Multiplication operator.
Subtract | Subtraction operator.
ValueEquality | Value equal operator.

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

System.CodeDOM Namespace | CodeBinaryOperatorExpression


CodeCastExpression Class

Represents a type cast expression.

Object
CodeExpression
CodeCastExpression

[Visual Basic]
Public Class CodeCastExpression
   Inherits CodeExpression
[C#]
public class CodeCastExpression : CodeExpression
[C++]
public __gc class CodeCastExpression : public CodeExpression
[JScript]
public class CodeCastExpression extends CodeExpression

Remarks

Languages that don't support casts may implement this through the usage of a temp local variable.

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeCastExpression Members | System.CodeDOM Namespace


CodeCastExpression Members

Public:

Constructor

CodeCastExpression Constructor Overloaded. Initializes a new instance of CodeCastExpression.

Properties

Expression | The expression to cast.
TargetType | The target type of the cast.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeCastExpression Class | System.CodeDOM Namespace


CodeCastExpression Constructor

Initializes a new instance of CodeCastExpression.

Overload List

Initializes a new instance of CodeCastExpression.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeCastExpression();
[C++] public: CodeCastExpression();
[JScript] public function CodeCastExpression();

Initializes a new instance of CodeCastExpression using the specified parameters.

[Visual Basic] Overloads Public Sub New(String, CodeExpression)
[C#] public CodeCastExpression(String, CodeExpression);
[C++] public: CodeCastExpression(String*, CodeExpression);
[JScript] public function CodeCastExpression(String, CodeExpression);

See Also

CodeCastExpression Class | CodeCastExpression Members | System.CodeDOM Namespace


CodeCastExpression Constructor ()

Initializes a new instance of CodeCastExpression.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeCastExpression();
[C++]
public: CodeCastExpression();
[JScript]
public function CodeCastExpression();

See Also

CodeCastExpression Class | CodeCastExpression Members | System.CodeDOM Namespace | CodeCastExpression Constructor Overload List


CodeCastExpression Constructor (String, CodeExpression)

Initializes a new instance of CodeCastExpression using the specified parameters.

[Visual Basic]
Overloads Public Sub New( _
   ByVal targetType As String, _
   ByVal expression As CodeExpression _
)
[C#]
public CodeCastExpression(
   string targetType,
   CodeExpression expression
);
[C++]
public: CodeCastExpression(
   String* targetType,
   CodeExpression* expression
);
[JScript]
public function CodeCastExpression(
   targetType : String,
   expression : CodeExpression
);

Parameters

targetType
The type the cast targets.
expression
[To be supplied.]

See Also

CodeCastExpression Class | CodeCastExpression Members | System.CodeDOM Namespace | CodeCastExpression Constructor Overload List | CodeExpression


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeCastExpression Properties

The properties of the CodeCastExpression class are listed below. For a complete list of CodeCastExpression class members, see the CodeCastExpression Members topic.

Public:

Expression | The expression to cast.
TargetType | The target type of the cast.

See Also

CodeCastExpression Class | System.CodeDOM Namespace


CodeCastExpression.Expression

The expression to cast.

[Visual Basic]
Public Property Expression As CodeExpression
[C#]
public CodeExpression Expression {get; set;}
[C++]
public: __property CodeExpression* get_Expression();
public: __property void set_Expression(CodeExpression*);
[JScript]
public function get Expression() : CodeExpression;
public function set Expression(CodeExpression);

Property Value

A CodeExpression that represents the code to cast.

See Also

CodeCastExpression Class | CodeCastExpression Members | System.CodeDOM Namespace | CodeExpression


CodeCastExpression.TargetType

The target type of the cast.

[Visual Basic]
Public Property TargetType As String
[C#]
public string TargetType {get; set;}
[C++]
public: __property String* get_TargetType();
public: __property void set_TargetType(String*);
[JScript]
public function get TargetType() : String;
public function set TargetType(String);

Property Value

A the type name being cast to.

See Also

CodeCastExpression Class | CodeCastExpression Members | System.CodeDOM Namespace


CodeCatchClause Class

Represents a catch exception statement.

Object
CodeCatchClause

[Visual Basic]
Public Class CodeCatchClause
[C#]
public class CodeCatchClause
[C++]
public __gc class CodeCatchClause
[JScript]
public class CodeCatchClause

Remarks

This is used to catch an exception from a try block, when the thrown exception is derived from the type declared in Condition.

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeCatchClause Members | System.CodeDOM Namespace


CodeCatchClause Members

Public:

Constructor

CodeCatchClause Constructor Overloaded. Initializes an instance of CodeCatchClause.

Properties

Condition | Gets or set the condition to test for.
Statements | Gets or sets the statements within the clause.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeCatchClause Class | System.CodeDOM Namespace


CodeCatchClause Constructor

Initializes an instance of CodeCatchClause.

Overload List

Initializes an instance of CodeCatchClause.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeCatchClause();
[C++] public: CodeCatchClause();
[JScript] public function CodeCatchClause();

Initializes an instance of CodeCatchClause using the specified parameters.

[Visual Basic] Overloads Public Sub New(CodeParameterDeclarationExpression, CodeStatement())
[C#] public CodeCatchClause(CodeParameterDeclarationExpression, CodeStatement[]);
[C++] public: CodeCatchClause(CodeParameterDeclarationExpression*, CodeStatement[]);
[JScript] public function CodeCatchClause(CodeParameterDeclarationExpression, CodeStatement[]);

See Also

CodeCatchClause Class | CodeCatchClause Members | System.CodeDOM Namespace


CodeCatchClause Constructor ()

Initializes an instance of CodeCatchClause.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeCatchClause();
[C++]
public: CodeCatchClause();
[JScript]
public function CodeCatchClause();

See Also

CodeCatchClause Class | CodeCatchClause Members | System.CodeDOM Namespace | CodeCatchClause Constructor Overload List


CodeCatchClause Constructor (CodeParameterDeclarationExpression, CodeStatement[])

Initializes an instance of CodeCatchClause using the specified parameters.

[Visual Basic]
Overloads Public Sub New( _
   ByVal condition As CodeParameterDeclarationExpression, _
   ByVal statements() As CodeStatement _
)
[C#]
public CodeCatchClause(
   CodeParameterDeclarationExpression condition,
   CodeStatement[] statements
);
[C++]
public: CodeCatchClause(
   CodeParameterDeclarationExpression* condition,
   CodeStatement* statements[]
);
[JScript]
public function CodeCatchClause(
   condition : CodeParameterDeclarationExpression,
   statements : CodeStatement[]
);

Parameters

condition
A CodeParameterDeclarationExpression indicating the condition to test for.
statements
[To be supplied.]

See Also

CodeCatchClause Class | CodeCatchClause Members | System.CodeDOM Namespace | CodeCatchClause Constructor Overload List | CodeParameterDeclarationExpression | CodeStatement


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeCatchClause Properties

The properties of the CodeCatchClause class are listed below. For a complete list of CodeCatchClause class members, see the CodeCatchClause Members topic.

Public:

Condition | Gets or set the condition to test for.
Statements | Gets or sets the statements within the clause.

See Also

CodeCatchClause Class | System.CodeDOM Namespace


CodeCatchClause.Condition

Gets or set the condition to test for.

[Visual Basic]
Public Property Condition As CodeParameterDeclarationExpression
[C#]
public CodeParameterDeclarationExpression Condition {get; set;}
[C++]
public: __property CodeParameterDeclarationExpression* get_Condition();
public: __property void set_Condition(CodeParameterDeclarationExpression*);
[JScript]
public function get Condition() : CodeParameterDeclarationExpression;
public function set Condition(CodeParameterDeclarationExpression);

Property Value

A CodeParameterDeclarationExpression that indicates the property value pair to test for.

See Also

CodeCatchClause Class | CodeCatchClause Members | System.CodeDOM Namespace | CodeParameterDeclarationExpression


CodeCatchClause.Statements

Gets or sets the statements within the clause.

[Visual Basic]
Public ReadOnly Property Statements As CodeStatementCollection
[C#]
public CodeStatementCollection Statements {get;}
[C++]
public: __property CodeStatementCollection* get_Statements();
[JScript]
public function get Statements() : CodeStatementCollection;

Property Value

A CodeStatementCollection that indicates the statements for the clause.

See Also

CodeCatchClause Class | CodeCatchClause Members | System.CodeDOM Namespace | CodeStatementCollection | CodeStatement


CodeCatchClauseCollection Class

Manages a collection of CodeCatchClause objects.

Object
CodeCatchClauseCollection

[Visual Basic]
Public Class CodeCatchClauseCollection
   Implements IList, ICollection, IEnumerable
[C#]
public class CodeCatchClauseCollection : IList, ICollection,
   IEnumerable
[C++]
public __gc class CodeCatchClauseCollection : public IList,
   ICollection, IEnumerable
[JScript]
public class CodeCatchClauseCollection implements IList,
   ICollection, IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeCatchClauseCollection Members | System.CodeDOM Namespace | CodeCatchClause


CodeCatchClauseCollection Members

Public:

Constructor

CodeCatchClauseCollection Constructor [To be supplied.]

Properties

Count | Gets or sets the count of the collection members.
Item | Collection accessor indexer method. Gets or sets the CodeCatchClause at the specified index. In C#, this member is the indexer for the CodeCatchClauseCollection class.

Methods

Add | Adds a CodeCatchClause to the collection.
AddRange | Adds a set of CodeCatchClause objects to the collection.
Clear | Clears the collection members.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Gets an enumerator for the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeCatchClauseCollection Class | System.CodeDOM Namespace


CodeCatchClauseCollection Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CodeCatchClauseCollection();
[C++]
public: CodeCatchClauseCollection();
[JScript]
public function CodeCatchClauseCollection();

See Also

CodeCatchClauseCollection Class | CodeCatchClauseCollection Members | System.CodeDOM Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeCatchClauseCollection Properties

The properties of the CodeCatchClauseCollection class are listed below. For a complete list of CodeCatchClauseCollection class members, see the CodeCatchClauseCollection Members topic.

Public:

Count | Gets or sets the count of the collection members.
Item | Collection accessor indexer method. Gets or sets the CodeCatchClause at the specified index. In C#, this member is the indexer for the CodeCatchClauseCollection class.

See Also

CodeCatchClauseCollection Class | System.CodeDOM Namespace


CodeCatchClauseCollection.Count

Gets or sets the count of the collection members.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

Property Value

The number of collection members.

See Also

CodeCatchClauseCollection Class | CodeCatchClauseCollection Members | System.CodeDOM Namespace


CodeCatchClauseCollection.Item

Collection accessor indexer method. Gets or sets the CodeCatchClause at the specified index.

[C#] In C#, this member is the indexer for the CodeCatchClauseCollection class.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As CodeCatchClause
[C#]
public CodeCatchClause this[
   int index
] {get; set;}
[C++]
public: __property CodeCatchClause* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   CodeCatchClause*
);
[JScript]
returnValue = CodeCatchClauseCollectionObject.Item(index);
CodeCatchClauseCollectionObject.Item(index) = returnValue;
-or-
returnValue = CodeCatchClauseCollectionObject(index);
CodeCatchClauseCollectionObject(index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
The index to get or set.

Parameters [Visual Basic, C#, C++]

index
The index to get or set.

See Also

CodeCatchClauseCollection Class | CodeCatchClauseCollection Members | System.CodeDOM Namespace | CodeCatchClause


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeCatchClauseCollection Methods

The methods of the CodeCatchClauseCollection class are listed below. For a complete list of CodeCatchClauseCollection class members, see the CodeCatchClauseCollection Members topic.

Public:

Add | Adds a CodeCatchClause to the collection.
AddRange | Adds a set of CodeCatchClause objects to the collection.
Clear | Clears the collection members.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Gets an enumerator for the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeCatchClauseCollection Class | System.CodeDOM Namespace


CodeCatchClauseCollection.Add

Adds a CodeCatchClause to the collection.

[Visual Basic]
Public Sub Add( _
   ByVal value As CodeCatchClause _
)
[C#]
public void Add(
   CodeCatchClause value
);
[C++]
public: void Add(
   CodeCatchClause* value
);
[JScript]
public function Add(
   value : CodeCatchClause
);

Parameters

value
The CodeCatchClause to add.

See Also

CodeCatchClauseCollection Class | CodeCatchClauseCollection Members | System.CodeDOM Namespace | CodeCatchClause


CodeCatchClauseCollection.AddRange

Adds a set of CodeCatchClause objects to the collection.

[Visual Basic]
Public Sub AddRange( _
   ByVal value() As CodeCatchClause _
)
[C#]
public void AddRange(
   CodeCatchClause[] value
);
[C++]
public: void AddRange(
   CodeCatchClause* value[]
);
[JScript]
public function AddRange(
   value : CodeCatchClause[]
);

Parameters

value
An array of type CodeCatchClause containing the objects to add.

See Also

CodeCatchClauseCollection Class | CodeCatchClauseCollection Members | System.CodeDOM Namespace | CodeCatchClause


CodeCatchClauseCollection.Clear

Clears the collection members.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[JScript]
public function Clear();

See Also

CodeCatchClauseCollection Class | CodeCatchClauseCollection Members | System.CodeDOM Namespace


CodeCatchClauseCollection.GetEnumerator

Gets an enumerator for the collection.

[Visual Basic]
Public Function GetEnumerator() As IEnumerator
[C#]
public IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

Return Value

An IEnumerator that enumerates the collection members.

See Also

CodeCatchClauseCollection Class | CodeCatchClauseCollection Members | System.CodeDOM Namespace | IEnumerator | CodeCatchClause


CodeClass Class

Represents a class or nested class.

Object
CodeStatement
CodeClassMember
CodeClass

[Visual Basic]
Public Class CodeClass
   Inherits CodeClassMember
[C#]
public class CodeClass : CodeClassMember
[C++]
public __gc class CodeClass : public CodeClassMember
[JScript]
public class CodeClass extends CodeClassMember

Remarks

This should not be used for Enum, Interface, or Delegate declaration.

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeClass Members | System.CodeDOM Namespace


CodeClass Members

Public:

Constructor

CodeClass Constructor Overloaded. Initializes a new instance of CodeClass.

Properties

Attributes (inherited from CodeClassMember) | The attributes of the member.
BaseTypes | Gets or sets the base types of the class.
CustomAttributes (inherited from CodeClassMember) | The custom attributes of the member.
IsClass | Gets whether the class is a class.
IsEnum | Gets whether the class is an enum.
IsInterface | Gets whether the class is an interface.
IsStruct | Gets whether the class is a struct.
LinePragma (inherited from CodeStatement) | The line the statement occurs on.
Members | Gets or sets the class member collection members.
Name (inherited from CodeClassMember) | The name of the member.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeClass Class | System.CodeDOM Namespace


CodeClass Constructor

Initializes a new instance of CodeClass.

Overload List

Initializes a new instance of CodeClass.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeClass();
[C++] public: CodeClass();
[JScript] public function CodeClass();

Initializes a new instance of CodeClass with the specified name.

[Visual Basic] Overloads Public Sub New(String)
[C#] public CodeClass(String);
[C++] public: CodeClass(String*);
[JScript] public function CodeClass(String);

See Also

CodeClass Class | CodeClass Members | System.CodeDOM Namespace


CodeClass Constructor ()

Initializes a new instance of CodeClass.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeClass();
[C++]
public: CodeClass();
[JScript]
public function CodeClass();

See Also

CodeClass Class | CodeClass Members | System.CodeDOM Namespace | CodeClass Constructor Overload List


CodeClass Constructor (String)

Initializes a new instance of CodeClass with the specified name.

[Visual Basic]
Overloads Public Sub New( _
   ByVal name As String _
)
[C#]
public CodeClass(
   string name
);
[C++]
public: CodeClass(
   String* name
);
[JScript]
public function CodeClass(
   name : String
);

Parameters

name
The name for the code class.

See Also

CodeClass Class | CodeClass Members | System.CodeDOM Namespace | CodeClass Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeClass Properties

The properties of the CodeClass class are listed below. For a complete list of CodeClass class members, see the CodeClass Members topic.

Public:

Attributes (inherited from CodeClassMember) | The attributes of the member.
BaseTypes | Gets or sets the base types of the class.
CustomAttributes (inherited from CodeClassMember) | The custom attributes of the member.
IsClass | Gets whether the class is a class.
IsEnum | Gets whether the class is an enum.
IsInterface | Gets whether the class is an interface.
IsStruct | Gets whether the class is a struct.
LinePragma (inherited from CodeStatement) | The line the statement occurs on.
Members | Gets or sets the class member collection members.
Name (inherited from CodeClassMember) | The name of the member.

See Also

CodeClass Class | System.CodeDOM Namespace


CodeClass.Attributes

Gets or sets the attributes of the class.

[Visual Basic]
Public Property Attributes As TypeAttributes
[C#]
public TypeAttributes Attributes {new get; set;}
[C++]
public: __property TypeAttributes get_Attributes();
public: __property void set_Attributes(TypeAttributes);
[JScript]
public function get Attributes() : TypeAttributes;
public function set Attributes(TypeAttributes);

Property Value

A TypeAttributes that indicates the attributes of the class.

See Also

CodeClass Class | CodeClass Members | System.CodeDOM Namespace | TypeAttributes


CodeClass.BaseTypes

Gets or sets the base types of the class.

[Visual Basic]
Public ReadOnly Property BaseTypes As StringCollection
[C#]
public StringCollection BaseTypes {get;}
[C++]
public: __property StringCollection* get_BaseTypes();
[JScript]
public function get BaseTypes() : StringCollection;

Property Value

A System.StringCollection containing the base class types.

See Also

CodeClass Class | CodeClass Members | System.CodeDOM Namespace | System.StringCollection


CodeClass.IsClass

Gets whether the class is a class.

[Visual Basic]
Public Property IsClass As Boolean
[C#]
public bool IsClass {get; set;}
[C++]
public: __property bool get_IsClass();
public: __property void set_IsClass(bool);
[JScript]
public function get IsClass() : Boolean;
public function set IsClass(Boolean);

Property Value

true if the class type attributes match, otherwise false.

See Also

CodeClass Class | CodeClass Members | System.CodeDOM Namespace


CodeClass.IsEnum

Gets whether the class is an enum.

[Visual Basic]
Public Property IsEnum As Boolean
[C#]
public bool IsEnum {get; set;}
[C++]
public: __property bool get_IsEnum();
public: __property void set_IsEnum(bool);
[JScript]
public function get IsEnum() : Boolean;
public function set IsEnum(Boolean);

Property Value

true if the class type attributes match, otherwise false.

See Also

CodeClass Class | CodeClass Members | System.CodeDOM Namespace


CodeClass.IsInterface

Gets whether the class is an interface.

[Visual Basic]
Public Property IsInterface As Boolean
[C#]
public bool IsInterface {get; set;}
[C++]
public: __property bool get_IsInterface();
public: __property void set_IsInterface(bool);
[JScript]
public function get IsInterface() : Boolean;
public function set IsInterface(Boolean);

Property Value

true if the class type attributes match, otherwise false.

See Also

CodeClass Class | CodeClass Members | System.CodeDOM Namespace


CodeClass.IsStruct

Gets whether the class is a struct.

[Visual Basic]
Public Property IsStruct As Boolean
[C#]
public bool IsStruct {get; set;}
[C++]
public: __property bool get_IsStruct();
public: __property void set_IsStruct(bool);
[JScript]
public function get IsStruct() : Boolean;
public function set IsStruct(Boolean);

Property Value

true if the class type attributes match, otherwise false.

See Also

CodeClass Class | CodeClass Members | System.CodeDOM Namespace


CodeClass.Members

Gets or sets the class member collection members.

[Visual Basic]
Public ReadOnly Property Members As CodeClassMemberCollection
[C#]
public CodeClassMemberCollection Members {get;}
[C++]
public: __property CodeClassMemberCollection* get_Members();
[JScript]
public function get Members() : CodeClassMemberCollection;

Property Value

A CodeClassMemberCollection that indicates the class members.

See Also

CodeClass Class | CodeClass Members | System.CodeDOM Namespace | CodeClassMemberCollection


CodeClassCollection Class

Manages a collection that stores CodeClass objects.

Object
CodeClassCollection

[Visual Basic]
Public Class CodeClassCollection
   Implements IList, ICollection, IEnumerable
[C#]
public class CodeClassCollection : IList, ICollection, IEnumerable
[C++]
public __gc class CodeClassCollection : public IList, ICollection,
   IEnumerable
[JScript]
public class CodeClassCollection implements IList, ICollection,
   IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeClassCollection Members | System.CodeDOM Namespace | CodeClass


CodeClassCollection Members

Public:

Constructor

CodeClassCollection Constructor [To be supplied.]

Properties

Count | The count of the objects in the collection.
Item | Collection accessor indexer method. Gets or sets the CodeClassCollection at the specified index. In C#, this member is the indexer for the CodeClassCollection class.

Methods

Add | Adds a CodeClass to the collection.
AddRange | Adds a set of CodeClass objects to the collection.
Clear | Clears the collection members.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Gets an enumerator for the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeClassCollection Class | System.CodeDOM Namespace


CodeClassCollection Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CodeClassCollection();
[C++]
public: CodeClassCollection();
[JScript]
public function CodeClassCollection();

See Also

CodeClassCollection Class | CodeClassCollection Members | System.CodeDOM Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeClassCollection Properties

The properties of the CodeClassCollection class are listed below. For a complete list of CodeClassCollection class members, see the CodeClassCollection Members topic.

Public:

Count | The count of the objects in the collection.
Item | Collection accessor indexer method. Gets or sets the CodeClassCollection at the specified index. In C#, this member is the indexer for the CodeClassCollection class.

See Also

CodeClassCollection Class | System.CodeDOM Namespace


CodeClassCollection.Count

The count of the objects in the collection.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

Property Value

The number of the objects in the collection.

See Also

CodeClassCollection Class | CodeClassCollection Members | System.CodeDOM Namespace


CodeClassCollection.Item

Collection accessor indexer method. Gets or sets the CodeClassCollection at the specified index.

[C#] In C#, this member is the indexer for the CodeClassCollection class.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As CodeClass
[C#]
public CodeClass this[
   int index
] {get; set;}
[C++]
public: __property CodeClass* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   CodeClass*
);
[JScript]
returnValue = CodeClassCollectionObject.Item(index);
CodeClassCollectionObject.Item(index) = returnValue;
-or-
returnValue = CodeClassCollectionObject(index);
CodeClassCollectionObject(index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
[To be supplied.]

Parameters [Visual Basic, C#, C++]

index
[To be supplied.]

See Also

CodeClassCollection Class | CodeClassCollection Members | System.CodeDOM Namespace | CodeClass


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeClassCollection Methods

The methods of the CodeClassCollection class are listed below. For a complete list of CodeClassCollection class members, see the CodeClassCollection Members topic.

Public:

Add | Adds a CodeClass to the collection.
AddRange | Adds a set of CodeClass objects to the collection.
Clear | Clears the collection members.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Gets an enumerator for the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeClassCollection Class | System.CodeDOM Namespace


CodeClassCollection.Add

Adds a CodeClass to the collection.

[Visual Basic]
Public Sub Add( _
   ByVal value As CodeClass _
)
[C#]
public void Add(
   CodeClass value
);
[C++]
public: void Add(
   CodeClass* value
);
[JScript]
public function Add(
   value : CodeClass
);

Parameters

value
The CodeClass to add to the collection.

See Also

CodeClassCollection Class | CodeClassCollection Members | System.CodeDOM Namespace | CodeClass


CodeClassCollection.AddRange

Adds a set of CodeClass objects to the collection.

[Visual Basic]
Public Sub AddRange( _
   ByVal value() As CodeClass _
)
[C#]
public void AddRange(
   CodeClass[] value
);
[C++]
public: void AddRange(
   CodeClass* value[]
);
[JScript]
public function AddRange(
   value : CodeClass[]
);

Parameters

value
An array of type CodeClass containing the object to add to the collection.

See Also

CodeClassCollection Class | CodeClassCollection Members | System.CodeDOM Namespace | CodeClass


CodeClassCollection.Clear

Clears the collection members.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[JScript]
public function Clear();

See Also

CodeClassCollection Class | CodeClassCollection Members | System.CodeDOM Namespace


CodeClassCollection.GetEnumerator

Gets an enumerator for the collection.

[Visual Basic]
Public Function GetEnumerator() As IEnumerator
[C#]
public IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

Return Value

An IEnumerator that enumerates the collection members.

See Also

CodeClassCollection Class | CodeClassCollection Members | System.CodeDOM Namespace | IEnumerator | CodeClass


CodeClassConstructor Class

Represents a static constructor for a class.

Object
CodeStatement
CodeClassMember
CodeMemberMethod
CodeClassConstructor

[Visual Basic]
Public Class CodeClassConstructor
   Inherits CodeMemberMethod
[C#]
public class CodeClassConstructor : CodeMemberMethod
[C++]
public __gc class CodeClassConstructor : public CodeMemberMethod
[JScript]
public class CodeClassConstructor extends CodeMemberMethod

Remarks

These are called once when the type is loaded.

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeClassConstructor Members | System.CodeDOM Namespace


CodeClassConstructor Members

Public:

Constructor

CodeClassConstructor Constructor Initializes a new instance of CodeClassConstructor.

Properties

Attributes (inherited from CodeClassMember) | The attributes of the member.
CustomAttributes (inherited from CodeClassMember) | The custom attributes of the member.
ImplementsType (inherited from CodeMemberMethod) | [To be supplied.]
LinePragma (inherited from CodeStatement) | The line the statement occurs on.
Name (inherited from CodeClassMember) | The name of the member.
Parameters (inherited from CodeMemberMethod) | Gets or sets the parameter declarations for the method.
ReturnType (inherited from CodeMemberMethod) | Gets or sets the return type of the method.
Statements (inherited from CodeMemberMethod) | Gets or sets the statements within the method.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeClassConstructor Class | System.CodeDOM Namespace


CodeClassConstructor Constructor

Initializes a new instance of CodeClassConstructor.

[Visual Basic]
Public Sub New()
[C#]
public CodeClassConstructor();
[C++]
public: CodeClassConstructor();
[JScript]
public function CodeClassConstructor();

See Also

CodeClassConstructor Class | CodeClassConstructor Members | System.CodeDOM Namespace


CodeClassDelegate Class

Represents a class or nested class.

Object
CodeStatement
CodeClassMember
CodeClass
CodeClassDelegate

[Visual Basic]
Public Class CodeClassDelegate
   Inherits CodeClass
[C#]
public class CodeClassDelegate : CodeClass
[C++]
public __gc class CodeClassDelegate : public CodeClass
[JScript]
public class CodeClassDelegate extends CodeClass

Remarks

This should not be used for Enum, Interface, or Delegate declaration.

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeClassDelegate Members | System.CodeDOM Namespace


CodeClassDelegate Members

Public:

Constructor

CodeClassDelegate Constructor Overloaded. Initializes a new instance of CodeClassDelegate.

Properties

Attributes (inherited from CodeClass) | Overloaded. [To be supplied.]
BaseTypes (inherited from CodeClass) | Gets or sets the base types of the class.
CustomAttributes (inherited from CodeClassMember) | The custom attributes of the member.
IsClass (inherited from CodeClass) | Gets whether the class is a class.
IsEnum (inherited from CodeClass) | Gets whether the class is an enum.
IsInterface (inherited from CodeClass) | Gets whether the class is an interface.
IsStruct (inherited from CodeClass) | Gets whether the class is a struct.
LinePragma (inherited from CodeStatement) | The line the statement occurs on.
Members (inherited from CodeClass) | Gets or sets the class member collection members.
Name (inherited from CodeClassMember) | The name of the member.
Parameters | The parameters of the delegate.
ReturnType | Gets or sets the return type of the delegate.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeClassDelegate Class | System.CodeDOM Namespace


CodeClassDelegate Constructor

Initializes a new instance of CodeClassDelegate.

Overload List

Initializes a new instance of CodeClassDelegate.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeClassDelegate();
[C++] public: CodeClassDelegate();
[JScript] public function CodeClassDelegate();

Initializes a new instance of CodeClassDelegate.

[Visual Basic] Overloads Public Sub New(String)
[C#] public CodeClassDelegate(String);
[C++] public: CodeClassDelegate(String*);
[JScript] public function CodeClassDelegate(String);

See Also

CodeClassDelegate Class | CodeClassDelegate Members | System.CodeDOM Namespace


CodeClassDelegate Constructor ()

Initializes a new instance of CodeClassDelegate.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeClassDelegate();
[C++]
public: CodeClassDelegate();
[JScript]
public function CodeClassDelegate();

See Also

CodeClassDelegate Class | CodeClassDelegate Members | System.CodeDOM Namespace | CodeClassDelegate Constructor Overload List


CodeClassDelegate Constructor (String)

Initializes a new instance of CodeClassDelegate.

[Visual Basic]
Overloads Public Sub New( _
   ByVal name As String _
)
[C#]
public CodeClassDelegate(
   string name
);
[C++]
public: CodeClassDelegate(
   String* name
);
[JScript]
public function CodeClassDelegate(
   name : String
);

Parameters

name
The name of the delegate.

See Also

CodeClassDelegate Class | CodeClassDelegate Members | System.CodeDOM Namespace | CodeClassDelegate Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeClassDelegate Properties

The properties of the CodeClassDelegate class are listed below. For a complete list of CodeClassDelegate class members, see the CodeClassDelegate Members topic.

Public:

Attributes (inherited from CodeClass) | Overloaded. [To be supplied.]
BaseTypes (inherited from CodeClass) | Gets or sets the base types of the class.
CustomAttributes (inherited from CodeClassMember) | The custom attributes of the member.
IsClass (inherited from CodeClass) | Gets whether the class is a class.
IsEnum (inherited from CodeClass) | Gets whether the class is an enum.
IsInterface (inherited from CodeClass) | Gets whether the class is an interface.
IsStruct (inherited from CodeClass) | Gets whether the class is a struct.
LinePragma (inherited from CodeStatement) | The line the statement occurs on.
Members (inherited from CodeClass) | Gets or sets the class member collection members.
Name (inherited from CodeClassMember) | The name of the member.
Parameters | The parameters of the delegate.
ReturnType | Gets or sets the return type of the delegate.

See Also

CodeClassDelegate Class | System.CodeDOM Namespace


CodeClassDelegate.Parameters

The parameters of the delegate.

[Visual Basic]
Public ReadOnly Property Parameters As _
   CodeParameterDeclarationExpressionCollection
[C#]
public CodeParameterDeclarationExpressionCollection Parameters
   {get;}
[C++]
public: __property CodeParameterDeclarationExpressionCollection*
   get_Parameters();
[JScript]
public function get Parameters() :
   CodeParameterDeclarationExpressionCollection;

Property Value

A CodeParameterDeclarationExpressionCollection that contains the parameters of the delegate.

See Also

CodeClassDelegate Class | CodeClassDelegate Members | System.CodeDOM Namespace | CodeParameterDeclarationExpressionCollection


CodeClassDelegate.ReturnType

Gets or sets the return type of the delegate.

[Visual Basic]
Public Property ReturnType As String
[C#]
public string ReturnType {get; set;}
[C++]
public: __property String* get_ReturnType();
public: __property void set_ReturnType(String*);
[JScript]
public function get ReturnType() : String;
public function set ReturnType(String);

Property Value

A string indicating the return type of the delegate.

See Also

CodeClassDelegate Class | CodeClassDelegate Members | System.CodeDOM Namespace


CodeClassMember Class

Represents a class member.

Object
CodeStatement
CodeClassMember

[Visual Basic]
Public Class CodeClassMember
   Inherits CodeStatement
[C#]
public class CodeClassMember : CodeStatement
[C++]
public __gc class CodeClassMember : public CodeStatement
[JScript]
public class CodeClassMember extends CodeStatement

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeClassMember Members | System.CodeDOM Namespace | MemberAttributes | CodeAttributeBlock


CodeClassMember Members

Public:

Constructor

CodeClassMember Constructor [To be supplied.]

Properties

Attributes | The attributes of the member.
CustomAttributes | The custom attributes of the member.
LinePragma (inherited from CodeStatement) | The line the statement occurs on.
Name | The name of the member.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeClassMember Class | System.CodeDOM Namespace


CodeClassMember Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CodeClassMember();
[C++]
public: CodeClassMember();
[JScript]
public function CodeClassMember();

See Also

CodeClassMember Class | CodeClassMember Members | System.CodeDOM Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeClassMember Properties

The properties of the CodeClassMember class are listed below. For a complete list of CodeClassMember class members, see the CodeClassMember Members topic.

Public:

Attributes | The attributes of the member.
CustomAttributes | The custom attributes of the member.
LinePragma (inherited from CodeStatement) | The line the statement occurs on.
Name | The name of the member.

See Also

CodeClassMember Class | System.CodeDOM Namespace


CodeClassMember.Attributes

The attributes of the member.

[Visual Basic]
Public Property Attributes As MemberAttributes
[C#]
public MemberAttributes Attributes {get; set;}
[C++]
public: __property MemberAttributes get_Attributes();
public: __property void set_Attributes(MemberAttributes);
[JScript]
public function get Attributes() : MemberAttributes;
public function set Attributes(MemberAttributes);

Property Value

A MemberAttributes that indicates the attributes of the member.

See Also

CodeClassMember Class | CodeClassMember Members | System.CodeDOM Namespace | MemberAttributes


CodeClassMember.CustomAttributes

The custom attributes of the member.

[Visual Basic]
Public Property CustomAttributes As CodeAttributeBlock
[C#]
public CodeAttributeB CustomAttributes {get; set;}
[C++]
public: __property CodeAttributeBlock* get_CustomAttributes();
public: __property void set_CustomAttributes(CodeAttributeBlock*);
[JScript]
public function get CustomAttributes() : CodeAttributeBlock;
public function set CustomAttributes(CodeAttributeBlock);

Property Value

A CodeAttributeBlock that indicates the custom attributes of the member.

See Also

CodeClassMember Class | CodeClassMember Members | System.CodeDOM Namespace | CodeAttributeBlock


CodeClassMember.Name

The name of the member.

[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}
[C++]
public: __property String* get_Name();
public: __property void set_Name(String*);
[JScript]
public function get Name() : String;
public function set Name(String);

Property Value

A string containing the name of the member.

See Also

CodeClassMember Class | CodeClassMember Members | System.CodeDOM Namespace


CodeClassMemberCollection Class

Manages a collection of CodeClassMember objects.

Object
CodeClassMemberCollection

[Visual Basic]
Public Class CodeClassMemberCollection
   Implements IList, ICollection, IEnumerable
[C#]
public class CodeClassMemberCollection : IList, ICollection,
   IEnumerable
[C++]
public __gc class CodeClassMemberCollection : public IList,
   ICollection, IEnumerable
[JScript]
public class CodeClassMemberCollection implements IList,
   ICollection, IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeClassMemberCollection Members | System.CodeDOM Namespace | CodeClassMember


CodeClassMemberCollection Members

Public:

Constructor

CodeClassMemberCollection Constructor [To be supplied.]

Properties

Count | Gets or sets the count of the objects in the collection.
Item | Collection accessor indexer method. Gets or sets the CodeClassMember at the specified index. In C#, this member is the indexer for the CodeClassMemberCollection class.

Methods

Add | Adds a CodeClassMember to the collection.
AddRange | Adds a set of CodeClassMember objects to the collection.
Clear | Clears the collection members.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Gets an enumerator for the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeClassMemberCollection Class | System.CodeDOM Namespace


CodeClassMemberCollection Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CodeClassMemberCollection();
[C++]
public: CodeClassMemberCollection();
[JScript]
public function CodeClassMemberCollection();

See Also

CodeClassMemberCollection Class | CodeClassMemberCollection Members | System.CodeDOM Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeClassMemberCollection Properties

The properties of the CodeClassMemberCollection class are listed below. For a complete list of CodeClassMemberCollection class members, see the CodeClassMemberCollection Members topic.

Public:

Count | Gets or sets the count of the objects in the collection.
Item | Collection accessor indexer method. Gets or sets the CodeClassMember at the specified index. In C#, this member is the indexer for the CodeClassMemberCollection class.

See Also

CodeClassMemberCollection Class | System.CodeDOM Namespace


CodeClassMemberCollection.Count

Gets or sets the count of the objects in the collection.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

Property Value

The number of the objects in the collection.

See Also

CodeClassMemberCollection Class | CodeClassMemberCollection Members | System.CodeDOM Namespace


CodeClassMemberCollection.Item

Collection accessor indexer method. Gets or sets the CodeClassMember at the specified index.

[C#] In C#, this member is the indexer for the CodeClassMemberCollection class.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As CodeClassMember
[C#]
public CodeClassMember this[
   int index
] {get; set;}
[C++]
public: __property CodeClassMember* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   CodeClassMember*
);
[JScript]
returnValue = CodeClassMemberCollectionObject.Item(index);
CodeClassMemberCollectionObject.Item(index) = returnValue;
-or-
returnValue = CodeClassMemberCollectionObject(index);
CodeClassMemberCollectionObject(index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
The index to get or set.

Parameters [Visual Basic, C#, C++]

index
The index to get or set.

See Also

CodeClassMemberCollection Class | CodeClassMemberCollection Members | System.CodeDOM Namespace | CodeClassMember


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeClassMemberCollection Methods

The methods of the CodeClassMemberCollection class are listed below. For a complete list of CodeClassMemberCollection class members, see the CodeClassMemberCollection Members topic.

Public:

Add | Adds a CodeClassMember to the collection.
AddRange | Adds a set of CodeClassMember objects to the collection.
Clear | Clears the collection members.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Gets an enumerator for the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeClassMemberCollection Class | System.CodeDOM Namespace


CodeClassMemberCollection.Add

Adds a CodeClassMember to the collection.

[Visual Basic]
Public Sub Add( _
   ByVal value As CodeClassMember _
)
[C#]
public void Add(
   CodeClassMember value
);
[C++]
public: void Add(
   CodeClassMember* value
);
[JScript]
public function Add(
   value : CodeClassMember
);

Parameters

value
The CodeClassMember to add to the collection.

See Also

CodeClassMemberCollection Class | CodeClassMemberCollection Members | System.CodeDOM Namespace | CodeClassMember


CodeClassMemberCollection.AddRange

Adds a set of CodeClassMember objects to the collection.

[Visual Basic]
Public Sub AddRange( _
   ByVal value() As CodeClassMember _
)
[C#]
public void AddRange(
   CodeClassMember[] value
);
[C++]
public: void AddRange(
   CodeClassMember* value[]
);
[JScript]
public function AddRange(
   value : CodeClassMember[]
);

Parameters

value
An array of type CodeClassMember.

See Also

CodeClassMemberCollection Class | CodeClassMemberCollection Members | System.CodeDOM Namespace


CodeClassMemberCollection.Clear

Clears the collection members.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[JScript]
public function Clear();

See Also

CodeClassMemberCollection Class | CodeClassMemberCollection Members | System.CodeDOM Namespace


CodeClassMemberCollection.GetEnumerator

Gets an enumerator for the collection.

[Visual Basic]
Public Function GetEnumerator() As IEnumerator
[C#]
public IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

Return Value

An IEnumerator that enumerates the collection members.

See Also

CodeClassMemberCollection Class | CodeClassMemberCollection Members | System.CodeDOM Namespace | IEnumerator


CodeCommentStatement Class

[To be supplied.]

Object
CodeStatement
CodeCommentStatement

[Visual Basic]
Public Class CodeCommentStatement
   Inherits CodeStatement
[C#]
public class CodeCommentStatement : CodeStatement
[C++]
public __gc class CodeCommentStatement : public CodeStatement
[JScript]
public class CodeCommentStatement extends CodeStatement

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeCommentStatement Members | System.CodeDOM Namespace


CodeCommentStatement Members

Public:

Constructor

CodeCommentStatement Constructor Overloaded. Initializes a new instance of CodeCommentStatement.

Properties

LinePragma (inherited from CodeStatement) | The line the statement occurs on.
Text | The text of the comment.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeCommentStatement Class | System.CodeDOM Namespace


CodeCommentStatement Constructor

Initializes a new instance of CodeCommentStatement.

Overload List

Initializes a new instance of CodeCommentStatement.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeCommentStatement();
[C++] public: CodeCommentStatement();
[JScript] public function CodeCommentStatement();

Initializes a new instance of CodeCommentStatement with the specified text as contents.

[Visual Basic] Overloads Public Sub New(String)
[C#] public CodeCommentStatement(String);
[C++] public: CodeCommentStatement(String*);
[JScript] public function CodeCommentStatement(String);

See Also

CodeCommentStatement Class | CodeCommentStatement Members | System.CodeDOM Namespace


CodeCommentStatement Constructor ()

Initializes a new instance of CodeCommentStatement.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeCommentStatement();
[C++]
public: CodeCommentStatement();
[JScript]
public function CodeCommentStatement();

See Also

CodeCommentStatement Class | CodeCommentStatement Members | System.CodeDOM Namespace | CodeCommentStatement Constructor Overload List


CodeCommentStatement Constructor (String)

Initializes a new instance of CodeCommentStatement with the specified text as contents.

[Visual Basic]
Overloads Public Sub New( _
   ByVal text As String _
)
[C#]
public CodeCommentStatement(
   string text
);
[C++]
public: CodeCommentStatement(
   String* text
);
[JScript]
public function CodeCommentStatement(
   text : String
);

Parameters

text
The comment contents.

See Also

CodeCommentStatement Class | CodeCommentStatement Members | System.CodeDOM Namespace | CodeCommentStatement Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeCommentStatement Properties

The properties of the CodeCommentStatement class are listed below. For a complete list of CodeCommentStatement class members, see the CodeCommentStatement Members topic.

Public:

LinePragma (inherited from CodeStatement) | The line the statement occurs on.
Text | The text of the comment.

See Also

CodeCommentStatement Class | System.CodeDOM Namespace


CodeCommentStatement.Text

The text of the comment.

[Visual Basic]
Public Property Text As String
[C#]
public string Text {get; set;}
[C++]
public: __property String* get_Text();
public: __property void set_Text(String*);
[JScript]
public function get Text() : String;
public function set Text(String);

Property Value

A string containing the comment text.

See Also

CodeCommentStatement Class | CodeCommentStatement Members | System.CodeDOM Namespace


CodeConstructor Class

Represents a class constructor.

Object
CodeStatement
CodeClassMember
CodeMemberMethod
CodeConstructor

[Visual Basic]
Public Class CodeConstructor
   Inherits CodeMemberMethod
[C#]
public class CodeConstructor : CodeMemberMethod
[C++]
public __gc class CodeConstructor : public CodeMemberMethod
[JScript]
public class CodeConstructor extends CodeMemberMethod

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeConstructor Members | System.CodeDOM Namespace


CodeConstructor Members

Public:

Constructor

CodeConstructor Constructor Initializes a new instance of CodeConstructor.

Properties

Attributes (inherited from CodeClassMember) | The attributes of the member.
BaseConstructorArgs | Gets or sets the base constructor arguments.
ChainedConstructorArgs | Gets or sets the chained constructor arguments.
CustomAttributes (inherited from CodeClassMember) | The custom attributes of the member.
ImplementsType (inherited from CodeMemberMethod) | [To be supplied.]
LinePragma (inherited from CodeStatement) | The line the statement occurs on.
Name (inherited from CodeClassMember) | The name of the member.
Parameters (inherited from CodeMemberMethod) | Gets or sets the parameter declarations for the method.
ReturnType (inherited from CodeMemberMethod) | Gets or sets the return type of the method.
Statements (inherited from CodeMemberMethod) | Gets or sets the statements within the method.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeConstructor Class | System.CodeDOM Namespace


CodeConstructor Constructor

Initializes a new instance of CodeConstructor.

[Visual Basic]
Public Sub New()
[C#]
public CodeConstructor();
[C++]
public: CodeConstructor();
[JScript]
public function CodeConstructor();

See Also

CodeConstructor Class | CodeConstructor Members | System.CodeDOM Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeConstructor Properties

The properties of the CodeConstructor class are listed below. For a complete list of CodeConstructor class members, see the CodeConstructor Members topic.

Public:

Attributes (inherited from CodeClassMember) | The attributes of the member.
BaseConstructorArgs | Gets or sets the base constructor arguments.
ChainedConstructorArgs | Gets or sets the chained constructor arguments.
CustomAttributes (inherited from CodeClassMember) | The custom attributes of the member.
ImplementsType (inherited from CodeMemberMethod) | [To be supplied.]
LinePragma (inherited from CodeStatement) | The line the statement occurs on.
Name (inherited from CodeClassMember) | The name of the member.
Parameters (inherited from CodeMemberMethod) | Gets or sets the parameter declarations for the method.
ReturnType (inherited from CodeMemberMethod) | Gets or sets the return type of the method.
Statements (inherited from CodeMemberMethod) | Gets or sets the statements within the method.

See Also

CodeConstructor Class | System.CodeDOM Namespace


CodeConstructor.BaseConstructorArgs

Gets or sets the base constructor arguments.

[Visual Basic]
Public ReadOnly Property BaseConstructorArgs As _
   CodeExpressionCollection
[C#]
public CodeExpressionCollection BaseConstructorArgs {get;}
[C++]
public: __property CodeExpressionCollection*
   get_BaseConstructorArgs();
[JScript]
public function get BaseConstructorArgs() :
   CodeExpressionCollection;

Property Value

A CodeExpressionCollection that represents the base constructor arguments.

See Also

CodeConstructor Class | CodeConstructor Members | System.CodeDOM Namespace | CodeExpressionCollection


CodeConstructor.ChainedConstructorArgs

Gets or sets the chained constructor arguments.

[Visual Basic]
Public ReadOnly Property ChainedConstructorArgs As _
   CodeExpressionCollection
[C#]
public CodeExpressionCollection ChainedConstructorArgs {get;}
[C++]
public: __property CodeExpressionCollection*
   get_ChainedConstructorArgs();
[JScript]
public function get ChainedConstructorArgs() :
   CodeExpressionCollection;

Property Value

A CodeExpressionCollection that represents the chained constructor arguments.

See Also

CodeConstructor Class | CodeConstructor Members | System.CodeDOM Namespace | CodeExpressionCollection


CodeDelegateCreateExpression Class

Represents a delegate creation expression.

Object
CodeExpression
CodeDelegateCreateExpression

[Visual Basic]
Public Class CodeDelegateCreateExpression
   Inherits CodeExpression
[C#]
public class CodeDelegateCreateExpression : CodeExpression
[C++]
public __gc class CodeDelegateCreateExpression : public
   CodeExpression
[JScript]
public class CodeDelegateCreateExpression extends CodeExpression

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeDelegateCreateExpression Members | System.CodeDOM Namespace


CodeDelegateCreateExpression Members

Public:

Constructor

CodeDelegateCreateExpression Constructor Overloaded. Initializes a new instance of CodeDelegateCreateExpression.

Properties

DelegateType | Gets or sets the delegate type.
MethodName | Gets or sets the method name.
TargetObject | Gets or sets the target object.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeDelegateCreateExpression Class | System.CodeDOM Namespace


CodeDelegateCreateExpression Constructor

Initializes a new instance of CodeDelegateCreateExpression.

Overload List

Initializes a new instance of CodeDelegateCreateExpression.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeDelegateCreateExpression();
[C++] public: CodeDelegateCreateExpression();
[JScript] public function CodeDelegateCreateExpression();

Initializes a new instance of CodeDelegateCreateExpression.

[Visual Basic] Overloads Public Sub New(String, CodeExpression, String)
[C#] public CodeDelegateCreateExpression(String, CodeExpression, String);
[C++] public: CodeDelegateCreateExpression(String*, CodeExpression, String*);
[JScript] public function CodeDelegateCreateExpression(String, CodeExpression, String);

See Also

CodeDelegateCreateExpression Class | CodeDelegateCreateExpression Members | System.CodeDOM Namespace


CodeDelegateCreateExpression Constructor ()

Initializes a new instance of CodeDelegateCreateExpression.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeDelegateCreateExpression();
[C++]
public: CodeDelegateCreateExpression();
[JScript]
public function CodeDelegateCreateExpression();

See Also

CodeDelegateCreateExpression Class | CodeDelegateCreateExpression Members | System.CodeDOM Namespace | CodeDelegateCreateExpression Constructor Overload List


CodeDelegateCreateExpression Constructor (String, CodeExpression, String)

Initializes a new instance of CodeDelegateCreateExpression.

[Visual Basic]
Overloads Public Sub New( _
   ByVal delegateType As String, _
   ByVal targetObject As CodeExpression, _
   ByVal methodName As String _
)
[C#]
public CodeDelegateCreateExpression(
   string delegateType,
   CodeExpression targetObject,
   string methodName
);
[C++]
public: CodeDelegateCreateExpression(
   String* delegateType,
   CodeExpression* targetObject,
   String* methodName
);
[JScript]
public function CodeDelegateCreateExpression(
   delegateType : String,
   targetObject : CodeExpression,
   methodName : String
);

Parameters

delegateType
The delegate type.
targetObject
[To be supplied.]
methodName
[To be supplied.]

See Also

CodeDelegateCreateExpression Class | CodeDelegateCreateExpression Members | System.CodeDOM Namespace | CodeDelegateCreateExpression Constructor Overload List | CodeExpression


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeDelegateCreateExpression Properties

The properties of the CodeDelegateCreateExpression class are listed below. For a complete list of CodeDelegateCreateExpression class members, see the CodeDelegateCreateExpression Members topic.

Public:

DelegateType | Gets or sets the delegate type.
MethodName | Gets or sets the method name.
TargetObject | Gets or sets the target object.

See Also

CodeDelegateCreateExpression Class | System.CodeDOM Namespace


CodeDelegateCreateExpression.DelegateType

Gets or sets the delegate type.

[Visual Basic]
Public Property DelegateType As String
[C#]
public string DelegateType {get; set;}
[C++]
public: __property String* get_DelegateType();
public: __property void set_DelegateType(String*);
[JScript]
public function get DelegateType() : String;
public function set DelegateType(String);

Property Value

A string that indicates the delegate type.

See Also

CodeDelegateCreateExpression Class | CodeDelegateCreateExpression Members | System.CodeDOM Namespace


CodeDelegateCreateExpression.MethodName

Gets or sets the method name.

[Visual Basic]
Public Property MethodName As String
[C#]
public string MethodName {get; set;}
[C++]
public: __property String* get_MethodName();
public: __property void set_MethodName(String*);
[JScript]
public function get MethodName() : String;
public function set MethodName(String);

Property Value

A string that indicates the method name.

See Also

CodeDelegateCreateExpression Class | CodeDelegateCreateExpression Members | System.CodeDOM Namespace


CodeDelegateCreateExpression.TargetObject

Gets or sets the target object.

[Visual Basic]
Public Property TargetObject As CodeExpression
[C#]
public CodeExpression TargetObject {get; set;}
[C++]
public: __property CodeExpression* get_TargetObject();
public: __property void set_TargetObject(CodeExpression*);
[JScript]
public function get TargetObject() : CodeExpression;
public function set TargetObject(CodeExpression);

Property Value

A CodeExpression that indicates the target object.

See Also

CodeDelegateCreateExpression Class | CodeDelegateCreateExpression Members | System.CodeDOM Namespace


CodeDelegateInvokeExpression Class

Represents a delegate invoke expression.

Object
CodeExpression
CodeDelegateInvokeExpression

[Visual Basic]
Public Class CodeDelegateInvokeExpression
   Inherits CodeExpression
[C#]
public class CodeDelegateInvokeExpression : CodeExpression
[C++]
public __gc class CodeDelegateInvokeExpression : public
   CodeExpression
[JScript]
public class CodeDelegateInvokeExpression extends CodeExpression

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeDelegateInvokeExpression Members | System.CodeDOM Namespace | CodeExpression


CodeDelegateInvokeExpression Members

Public:

Constructor

CodeDelegateInvokeExpression Constructor Overloaded. Initializes a new instance of CodeDelegateInvokeExpression.

Properties

Parameters | The delegate parameters.
TargetObject | The delegate's target object.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeDelegateInvokeExpression Class | System.CodeDOM Namespace


CodeDelegateInvokeExpression Constructor

Initializes a new instance of CodeDelegateInvokeExpression.

Overload List

Initializes a new instance of CodeDelegateInvokeExpression.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeDelegateInvokeExpression();
[C++] public: CodeDelegateInvokeExpression();
[JScript] public function CodeDelegateInvokeExpression();

Initializes a new instance of CodeDelegateInvokeExpression.

[Visual Basic] Overloads Public Sub New(CodeExpression)
[C#] public CodeDelegateInvokeExpression(CodeExpression);
[C++] public: CodeDelegateInvokeExpression(CodeExpression*);
[JScript] public function CodeDelegateInvokeExpression(CodeExpression);

Initializes a new instance of CodeDelegateInvokeExpression.

[Visual Basic] Overloads Public Sub New(CodeExpression, CodeExpression())
[C#] public CodeDelegateInvokeExpression(CodeExpression, CodeExpression[]);
[C++] public: CodeDelegateInvokeExpression(CodeExpression*, CodeExpression*[]);
[JScript] public function CodeDelegateInvokeExpression(CodeExpression, CodeExpression[]);

See Also

CodeDelegateInvokeExpression Class | CodeDelegateInvokeExpression Members | System.CodeDOM Namespace


CodeDelegateInvokeExpression Constructor ()

Initializes a new instance of CodeDelegateInvokeExpression.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeDelegateInvokeExpression();
[C++]
public: CodeDelegateInvokeExpression();
[JScript]
public function CodeDelegateInvokeExpression();

See Also

CodeDelegateInvokeExpression Class | CodeDelegateInvokeExpression Members | System.CodeDOM Namespace | CodeDelegateInvokeExpression Constructor Overload List


CodeDelegateInvokeExpression Constructor (CodeExpression)

Initializes a new instance of CodeDelegateInvokeExpression.

[Visual Basic]
Overloads Public Sub New( _
   ByVal targetObject As CodeExpression _
)
[C#]
public CodeDelegateInvokeExpression(
   CodeExpression targetObject
);
[C++]
public: CodeDelegateInvokeExpression(
   CodeExpression* targetObject
);
[JScript]
public function CodeDelegateInvokeExpression(
   targetObject : CodeExpression
);

Parameters

targetObject
A CodeExpression that indicates the target object.

See Also

CodeDelegateInvokeExpression Class | CodeDelegateInvokeExpression Members | System.CodeDOM Namespace | CodeDelegateInvokeExpression Constructor Overload List | CodeExpression


CodeDelegateInvokeExpression Constructor (CodeExpression, CodeExpression[])

Initializes a new instance of CodeDelegateInvokeExpression.

[Visual Basic]
Overloads Public Sub New( _
   ByVal targetObject As CodeExpression, _
   ByVal parameters() As CodeExpression _
)
[C#]
public CodeDelegateInvokeExpression(
   CodeExpression targetObject,
   CodeExpression[] parameters
);
[C++]
public: CodeDelegateInvokeExpression(
   CodeExpression* targetObject,
   CodeExpression* parameters[]
);
[JScript]
public function CodeDelegateInvokeExpression(
   targetObject : CodeExpression,
   parameters : CodeExpression[]
);

Parameters

targetObject
A CodeExpression that indicates the target object.
parameters
[To be supplied.]

See Also

CodeDelegateInvokeExpression Class | CodeDelegateInvokeExpression Members | System.CodeDOM Namespace | CodeDelegateInvokeExpression Constructor Overload List | CodeExpression


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeDelegateInvokeExpression Properties

The properties of the CodeDelegateInvokeExpression class are listed below. For a complete list of CodeDelegateInvokeExpression class members, see the CodeDelegateInvokeExpression Members topic.

Public:

Parameters | The delegate parameters.
TargetObject | The delegate's target object.

See Also

CodeDelegateInvokeExpression Class | System.CodeDOM Namespace


CodeDelegateInvokeExpression.Parameters

The delegate parameters.

[Visual Basic]
Public ReadOnly Property Parameters As CodeExpressionCollection
[C#]
public CodeExpressionCollection Parameters {get;}
[C++]
public: __property CodeExpressionCollection* get_Parameters();
[JScript]
public function get Parameters() : CodeExpressionCollection;

Property Value

A CodeExpression that indicates the parameters for the delegate.

See Also

CodeDelegateInvokeExpression Class | CodeDelegateInvokeExpression Members | System.CodeDOM Namespace | CodeExpression


CodeDelegateInvokeExpression.TargetObject

The delegate's target object.

[Visual Basic]
Public Property TargetObject As CodeExpression
[C#]
public CodeExpression TargetObject {get; set;}
[C++]
public: __property CodeExpression* get_TargetObject();
public: __property void set_TargetObject(CodeExpression*);
[JScript]
public function get TargetObject() : CodeExpression;
public function set TargetObject(CodeExpression);

Property Value

A CodeExpression that indicates the target object.

See Also

CodeDelegateInvokeExpression Class | CodeDelegateInvokeExpression Members | System.CodeDOM Namespace | CodeExpression


CodeDelegateInvokeStatement Class

Represents a delegate invoke statement.

Object
CodeStatement
CodeDelegateInvokeStatement

[Visual Basic]
Public Class CodeDelegateInvokeStatement
   Inherits CodeStatement
[C#]
public class CodeDelegateInvokeStatement : CodeStatement
[C++]
public __gc class CodeDelegateInvokeStatement : public
   CodeStatement
[JScript]
public class CodeDelegateInvokeStatement extends CodeStatement

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeDelegateInvokeStatement Members | System.CodeDOM Namespace | CodeDelegateInvokeExpression


CodeDelegateInvokeStatement Members

Public:

Constructor

CodeDelegateInvokeStatement Constructor Overloaded. Initializes a new instance of CodeDelegateInvokeStatement.

Properties

DelegateInvoke | Gets or set the delegate invoke expression.
LinePragma (inherited from CodeStatement) | The line the statement occurs on.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeDelegateInvokeStatement Class | System.CodeDOM Namespace


CodeDelegateInvokeStatement Constructor

Initializes a new instance of CodeDelegateInvokeStatement.

Overload List

Initializes a new instance of CodeDelegateInvokeStatement.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeDelegateInvokeStatement();
[C++] public: CodeDelegateInvokeStatement();
[JScript] public function CodeDelegateInvokeStatement();

Initializes a new instance of CodeDelegateInvokeStatement.

[Visual Basic] Overloads Public Sub New(CodeDelegateInvokeExpression)
[C#] public CodeDelegateInvokeStatement(CodeDelegateInvokeExpression);
[C++] public: CodeDelegateInvokeStatement(CodeDelegateInvokeExpression*);
[JScript] public function CodeDelegateInvokeStatement(CodeDelegateInvokeExpression);

Initializes a new instance of CodeDelegateInvokeStatement.

[Visual Basic] Overloads Public Sub New(CodeExpression)
[C#] public CodeDelegateInvokeStatement(CodeExpression);
[C++] public: CodeDelegateInvokeStatement(CodeExpression*);
[JScript] public function CodeDelegateInvokeStatement(CodeExpression);

Initializes a new instance of CodeDelegateInvokeStatement.

[Visual Basic] Overloads Public Sub New(CodeExpression, CodeExpression())
[C#] public CodeDelegateInvokeStatement(CodeExpression, CodeExpression[]);
[C++] public: CodeDelegateInvokeStatement(CodeExpression*, CodeExpression*[]);
[JScript] public function CodeDelegateInvokeStatement(CodeExpression, CodeExpression[]);

See Also

CodeDelegateInvokeStatement Class | CodeDelegateInvokeStatement Members | System.CodeDOM Namespace


CodeDelegateInvokeStatement Constructor ()

Initializes a new instance of CodeDelegateInvokeStatement.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeDelegateInvokeStatement();
[C++]
public: CodeDelegateInvokeStatement();
[JScript]
public function CodeDelegateInvokeStatement();

See Also

CodeDelegateInvokeStatement Class | CodeDelegateInvokeStatement Members | System.CodeDOM Namespace | CodeDelegateInvokeStatement Constructor Overload List


CodeDelegateInvokeStatement Constructor (CodeDelegateInvokeExpression)

Initializes a new instance of CodeDelegateInvokeStatement.

[Visual Basic]
Overloads Public Sub New( _
   ByVal delegateInvoke As CodeDelegateInvokeExpression _
)
[C#]
public CodeDelegateInvokeStatement(
   CodeDelegateInvokeExpression delegateInvoke
);
[C++]
public: CodeDelegateInvokeStatement(
   CodeDelegateInvokeExpression* delegateInvoke
);
[JScript]
public function CodeDelegateInvokeStatement(
   delegateInvoke : CodeDelegateInvokeExpression
);

Parameters

delegateInvoke
A CodeDelegateInvokeExpression that represents the delegate to invoke.

See Also

CodeDelegateInvokeStatement Class | CodeDelegateInvokeStatement Members | System.CodeDOM Namespace | CodeDelegateInvokeStatement Constructor Overload List | CodeDelegateInvokeExpression


CodeDelegateInvokeStatement Constructor (CodeExpression)

Initializes a new instance of CodeDelegateInvokeStatement.

[Visual Basic]
Overloads Public Sub New( _
   ByVal targetObject As CodeExpression _
)
[C#]
public CodeDelegateInvokeStatement(
   CodeExpression targetObject
);
[C++]
public: CodeDelegateInvokeStatement(
   CodeExpression* targetObject
);
[JScript]
public function CodeDelegateInvokeStatement(
   targetObject : CodeExpression
);

Parameters

targetObject
A CodeExpression that indicates the target object.

See Also

CodeDelegateInvokeStatement Class | CodeDelegateInvokeStatement Members | System.CodeDOM Namespace | CodeDelegateInvokeStatement Constructor Overload List | CodeExpression


CodeDelegateInvokeStatement Constructor (CodeExpression, CodeExpression[])

Initializes a new instance of CodeDelegateInvokeStatement.

[Visual Basic]
Overloads Public Sub New( _
   ByVal targetObject As CodeExpression, _
   ByVal parameters() As CodeExpression _
)
[C#]
public CodeDelegateInvokeStatement(
   CodeExpression targetObject,
   CodeExpression[] parameters
);
[C++]
public: CodeDelegateInvokeStatement(
   CodeExpression* targetObject,
   CodeExpression* parameters[]
);
[JScript]
public function CodeDelegateInvokeStatement(
   targetObject : CodeExpression,
   parameters : CodeExpression[]
);

Parameters

targetObject
A CodeExpression that indicates the target object.
parameters
[To be supplied.]

See Also

CodeDelegateInvokeStatement Class | CodeDelegateInvokeStatement Members | System.CodeDOM Namespace | CodeDelegateInvokeStatement Constructor Overload List | CodeExpression


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeDelegateInvokeStatement Properties

The properties of the CodeDelegateInvokeStatement class are listed below. For a complete list of CodeDelegateInvokeStatement class members, see the CodeDelegateInvokeStatement Members topic.

Public:

DelegateInvoke | Gets or set the delegate invoke expression.
LinePragma (inherited from CodeStatement) | The line the statement occurs on.

See Also

CodeDelegateInvokeStatement Class | System.CodeDOM Namespace


CodeDelegateInvokeStatement.DelegateInvoke

Gets or set the delegate invoke expression.

[Visual Basic]
Public Property DelegateInvoke As CodeDelegateInvokeExpression
[C#]
public CodeDelegateInvokeExpression DelegateInvoke {get; set;}
[C++]
public: __property CodeDelegateInvokeExpression* get_DelegateInvoke();
public: __property void set_DelegateInvoke(CodeDelegateInvokeExpression*);
[JScript]
public function get DelegateInvoke() : CodeDelegateInvokeExpression;
public function set DelegateInvoke(CodeDelegateInvokeExpression);

Property Value

A CodeDelegateInvokeExpression that represents the delegate invoke expression.

See Also

CodeDelegateInvokeStatement Class | CodeDelegateInvokeStatement Members | System.CodeDOM Namespace | CodeDelegateInvokeExpression


CodeExpression Class

Represents a code expression.

Object
CodeExpression

[Visual Basic]
Public Class CodeExpression
[C#]
public class CodeExpression
[C++]
public __gc class CodeExpression
[JScript]
public class CodeExpression

Remarks

This is the base class within the CodeDOM model that represents expressions.

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeExpression Members | System.CodeDOM Namespace


CodeExpression Members

Public:

Constructor

CodeExpression Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeExpression Class | System.CodeDOM Namespace


CodeExpression Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CodeExpression();
[C++]
public: CodeExpression();
[JScript]
public function CodeExpression();

See Also

CodeExpression Class | CodeExpression Members | System.CodeDOM Namespace


CodeExpressionCollection Class

Manages a collection of CodeExpression objects.

Object
CodeExpressionCollection

[Visual Basic]
Public Class CodeExpressionCollection
   Implements IList, ICollection, IEnumerable
[C#]
public class CodeExpressionCollection : IList, ICollection,
   IEnumerable
[C++]
public __gc class CodeExpressionCollection : public IList,
   ICollection, IEnumerable
[JScript]
public class CodeExpressionCollection implements IList,
   ICollection, IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeExpressionCollection Members | System.CodeDOM Namespace | CodeExpression


CodeExpressionCollection Members

Public:

Constructor

CodeExpressionCollection Constructor [To be supplied.]

Properties

Count | Gets or sets the count of objects in the collection.
Item | Gets or sets the CodeExpression indicated by the specified index. Accessor method for the collection. In C#, this member is the indexer for the CodeExpressionCollection class.

Methods

Add | Adds the specified CodeExpression to the collection.
AddRange | Adds a set of CodeExpression objects to the collection.
Clear | Clears the collection members.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Gets an enumerator that enumerates the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeExpressionCollection Class | System.CodeDOM Namespace


CodeExpressionCollection Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CodeExpressionCollection();
[C++]
public: CodeExpressionCollection();
[JScript]
public function CodeExpressionCollection();

See Also

CodeExpressionCollection Class | CodeExpressionCollection Members | System.CodeDOM Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeExpressionCollection Properties

The properties of the CodeExpressionCollection class are listed below. For a complete list of CodeExpressionCollection class members, see the CodeExpressionCollection Members topic.

Public:

Count | Gets or sets the count of objects in the collection.
Item | Gets or sets the CodeExpression indicated by the specified index. Accessor method for the collection. In C#, this member is the indexer for the CodeExpressionCollection class.

See Also

CodeExpressionCollection Class | System.CodeDOM Namespace


CodeExpressionCollection.Count

Gets or sets the count of objects in the collection.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

Property Value

The number of objects in the collection.

See Also

CodeExpressionCollection Class | CodeExpressionCollection Members | System.CodeDOM Namespace


CodeExpressionCollection.Item

Gets or sets the CodeExpression indicated by the specified index. Accessor method for the collection.

[C#] In C#, this member is the indexer for the CodeExpressionCollection class.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As CodeExpression
[C#]
public CodeExpression this[
   int index
] {get; set;}
[C++]
public: __property CodeExpression* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   CodeExpression*
);
[JScript]
returnValue = CodeExpressionCollectionObject.Item(index);
CodeExpressionCollectionObject.Item(index) = returnValue;
-or-
returnValue = CodeExpressionCollectionObject(index);
CodeExpressionCollectionObject(index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
The index of the CodeExpression to access.

Parameters [Visual Basic, C#, C++]

index
The index of the CodeExpression to access.

See Also

CodeExpressionCollection Class | CodeExpressionCollection Members | System.CodeDOM Namespace | CodeExpression


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeExpressionCollection Methods

The methods of the CodeExpressionCollection class are listed below. For a complete list of CodeExpressionCollection class members, see the CodeExpressionCollection Members topic.

Public:

Add | Adds the specified CodeExpression to the collection.
AddRange | Adds a set of CodeExpression objects to the collection.
Clear | Clears the collection members.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Gets an enumerator that enumerates the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeExpressionCollection Class | System.CodeDOM Namespace


CodeExpressionCollection.Add

Adds the specified CodeExpression to the collection.

[Visual Basic]
Public Sub Add( _
   ByVal value As CodeExpression _
)
[C#]
public void Add(
   CodeExpression value
);
[C++]
public: void Add(
   CodeExpression* value
);
[JScript]
public function Add(
   value : CodeExpression
);

Parameters

value
The CodeExpression to add to the collection.

See Also

CodeExpressionCollection Class | CodeExpressionCollection Members | System.CodeDOM Namespace | CodeExpression


CodeExpressionCollection.AddRange

Adds a set of CodeExpression objects to the collection.

[Visual Basic]
Public Sub AddRange( _
   ByVal value() As CodeExpression _
)
[C#]
public void AddRange(
   CodeExpression[] value
);
[C++]
public: void AddRange(
   CodeExpression* value[]
);
[JScript]
public function AddRange(
   value : CodeExpression[]
);

Parameters

value
An array of type CodeExpression.

See Also

CodeExpressionCollection Class | CodeExpressionCollection Members | System.CodeDOM Namespace | CodeExpression


CodeExpressionCollection.Clear

Clears the collection members.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[JScript]
public function Clear();

See Also

CodeExpressionCollection Class | CodeExpressionCollection Members | System.CodeDOM Namespace


CodeExpressionCollection.GetEnumerator

Gets an enumerator that enumerates the collection.

[Visual Basic]
Public Function GetEnumerator() As IEnumerator
[C#]
public IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

Return Value

An IEnumerator that contains the members of the collection.

See Also

CodeExpressionCollection Class | CodeExpressionCollection Members | System.CodeDOM Namespace | IEnumerator


CodeFieldReferenceExpression Class

Represents a reference to a field.

Object
CodeExpression
CodeFieldReferenceExpression

[Visual Basic]
Public Class CodeFieldReferenceExpression
   Inherits CodeExpression
[C#]
public class CodeFieldReferenceExpression : CodeExpression
[C++]
public __gc class CodeFieldReferenceExpression : public
   CodeExpression
[JScript]
public class CodeFieldReferenceExpression extends CodeExpression

Remarks

If the TargetObject is a null reference (in Visual Basic Nothing), then the field is assumed to be a local variable. Use CodeThisReferenceExpression to refer to member variables.

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeFieldReferenceExpression Members | System.CodeDOM Namespace


CodeFieldReferenceExpression Members

Public:

Constructor

CodeFieldReferenceExpression Constructor Overloaded. Initializes a new instance of CodeFieldReferenceExpression.

Properties

Direction | Gets or sets the direction of the field.
FieldName | Gets or sets the field name.
TargetObject | Gets or sets the target object.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeFieldReferenceExpression Class | System.CodeDOM Namespace


CodeFieldReferenceExpression Constructor

Initializes a new instance of CodeFieldReferenceExpression.

Overload List

Initializes a new instance of CodeFieldReferenceExpression.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeFieldReferenceExpression();
[C++] public: CodeFieldReferenceExpression();
[JScript] public function CodeFieldReferenceExpression();

Initializes a new instance of CodeFieldReferenceExpression.

[Visual Basic] Overloads Public Sub New(CodeExpression, String)
[C#] public CodeFieldReferenceExpression(CodeExpression, String);
[C++] public: CodeFieldReferenceExpression(CodeExpression*, String);
[JScript] public function CodeFieldReferenceExpression(CodeExpression, String);

See Also

CodeFieldReferenceExpression Class | CodeFieldReferenceExpression Members | System.CodeDOM Namespace


CodeFieldReferenceExpression Constructor ()

Initializes a new instance of CodeFieldReferenceExpression.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeFieldReferenceExpression();
[C++]
public: CodeFieldReferenceExpression();
[JScript]
public function CodeFieldReferenceExpression();

See Also

CodeFieldReferenceExpression Class | CodeFieldReferenceExpression Members | System.CodeDOM Namespace | CodeFieldReferenceExpression Constructor Overload List


CodeFieldReferenceExpression Constructor (CodeExpression, String)

Initializes a new instance of CodeFieldReferenceExpression.

[Visual Basic]
Overloads Public Sub New( _
   ByVal targetObject As CodeExpression, _
   ByVal fieldName As String _
)
[C#]
public CodeFieldReferenceExpression(
   CodeExpression targetObject,
   string fieldName
);
[C++]
public: CodeFieldReferenceExpression(
   CodeExpression* targetObject,
   String* fieldName
);
[JScript]
public function CodeFieldReferenceExpression(
   targetObject : CodeExpression,
   fieldName : String
);

Parameters

targetObject
A CodeExpression that indicates the target object.
fieldName
[To be supplied.]

See Also

CodeFieldReferenceExpression Class | CodeFieldReferenceExpression Members | System.CodeDOM Namespace | CodeFieldReferenceExpression Constructor Overload List | CodeExpression


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeFieldReferenceExpression Properties

The properties of the CodeFieldReferenceExpression class are listed below. For a complete list of CodeFieldReferenceExpression class members, see the CodeFieldReferenceExpression Members topic.

Public:

Direction | Gets or sets the direction of the field.
FieldName | Gets or sets the field name.
TargetObject | Gets or sets the target object.

See Also

CodeFieldReferenceExpression Class | System.CodeDOM Namespace


CodeFieldReferenceExpression.Direction

Gets or sets the direction of the field.

[Visual Basic]
Public Property Direction As FieldDirection
[C#]
public FieldDirection Direction {get; set;}
[C++]
public: __property FieldDirection get_Direction();
public: __property void set_Direction(FieldDirection);
[JScript]
public function get Direction() : FieldDirection;
public function set Direction(FieldDirection);

Property Value

A FieldDirection indicating the direction of the field.

Remarks

The field direction represents the way in which the field is being used. Usually this is specified as in, out, ref or value, according to the member types in FieldDirection.

See Also

CodeFieldReferenceExpression Class | CodeFieldReferenceExpression Members | System.CodeDOM Namespace | FieldDirection


CodeFieldReferenceExpression.FieldName

Gets or sets the field name.

[Visual Basic]
Public Property FieldName As String
[C#]
public string FieldName {get; set;}
[C++]
public: __property String* get_FieldName();
public: __property void set_FieldName(String*);
[JScript]
public function get FieldName() : String;
public function set FieldName(String);

Property Value

A string containing the field name.

See Also

CodeFieldReferenceExpression Class | CodeFieldReferenceExpression Members | System.CodeDOM Namespace


CodeFieldReferenceExpression.TargetObject

Gets or sets the target object.

[Visual Basic]
Public Property TargetObject As CodeExpression
[C#]
public CodeExpression TargetObject {get; set;}
[C++]
public: __property CodeExpression* get_TargetObject();
public: __property void set_TargetObject(CodeExpression*);
[JScript]
public function get TargetObject() : CodeExpression;
public function set TargetObject(CodeExpression);

Property Value

A CodeExpression indicating the target object.

See Also

CodeFieldReferenceExpression Class | CodeFieldReferenceExpression Members | System.CodeDOM Namespace | CodeExpression


CodeForLoopStatement Class

Represents a simple for loop.

Object
CodeStatement
CodeForLoopStatement

[Visual Basic]
Public Class CodeForLoopStatement
   Inherits CodeStatement
[C#]
public class CodeForLoopStatement : CodeStatement
[C++]
public __gc class CodeForLoopStatement : public CodeStatement
[JScript]
public class CodeForLoopStatement extends CodeStatement

Remarks

This can also be implemented to represent a while loop, etc.

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeForLoopStatement Members | System.CodeDOM Namespace


CodeForLoopStatement Members

Public:

Constructor

CodeForLoopStatement Constructor Overloaded. Initializes a new instance of CodeForLoopStatement.

Properties

IncrementStatement | Gets or sets the per loop cycle increment statement.
InitStatement | Gets or sets the loop initialization statement.
LinePragma (inherited from CodeStatement) | The line the statement occurs on.
Statements | Gets or sets the statements to be executed within the loop.
TestExpression | Gets or sets the expression to test for.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeForLoopStatement Class | System.CodeDOM Namespace


CodeForLoopStatement Constructor

Initializes a new instance of CodeForLoopStatement.

Overload List

Initializes a new instance of CodeForLoopStatement.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeForLoopStatement();
[C++] public: CodeForLoopStatement();
[JScript] public function CodeForLoopStatement();

Initializes a new instance of CodeForLoopStatement.

[Visual Basic] Overloads Public Sub New(CodeStatement, CodeExpression, CodeStatement, CodeStatement())
[C#] public CodeForLoopStatement(CodeStatement, CodeExpression, CodeStatement, CodeStatement[]);
[C++] public: CodeForLoopStatement(CodeStatement*, CodeExpression, CodeStatement*, CodeStatement*[]);
[JScript] public function CodeForLoopStatement(CodeStatement, CodeExpression, CodeStatement, CodeStatement[]);

See Also

CodeForLoopStatement Class | CodeForLoopStatement Members | System.CodeDOM Namespace


CodeForLoopStatement Constructor ()

Initializes a new instance of CodeForLoopStatement.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeForLoopStatement();
[C++]
public: CodeForLoopStatement();
[JScript]
public function CodeForLoopStatement();

See Also

CodeForLoopStatement Class | CodeForLoopStatement Members | System.CodeDOM Namespace | CodeForLoopStatement Constructor Overload List


CodeForLoopStatement Constructor (CodeStatement, CodeExpression, CodeStatement, CodeStatement[])

Initializes a new instance of CodeForLoopStatement.

[Visual Basic]
Overloads Public Sub New( _
   ByVal initStatement As CodeStatement, _
   ByVal testExpression As CodeExpression, _
   ByVal incrementStatement As CodeStatement, _
   ByVal statments() As CodeStatement _
)
[C#]
public CodeForLoopStatement(
   CodeStatement initStatement,
   CodeExpression testExpression,
   CodeStatement incrementStatement,
   CodeStatement[] statments
);
[C++]
public: CodeForLoopStatement(
   CodeStatement* initStatement,
   CodeExpression* testExpression,
   CodeStatement* incrementStatement,
   CodeStatement* statments[]
);
[JScript]
public function CodeForLoopStatement(
   initStatement : CodeStatement,
   testExpression : CodeExpression,
   incrementStatement : CodeStatement,
   statments : CodeStatement[]
);

Parameters

initStatement
A CodeStatement containing the loop initialization statement.
testExpression
[To be supplied.]
incrementStatement
[To be supplied.]
statments
[To be supplied.]

See Also

CodeForLoopStatement Class | CodeForLoopStatement Members | System.CodeDOM Namespace | CodeForLoopStatement Constructor Overload List | CodeStatement | CodeExpression


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeForLoopStatement Properties

The properties of the CodeForLoopStatement class are listed below. For a complete list of CodeForLoopStatement class members, see the CodeForLoopStatement Members topic.

Public:

IncrementStatement | Gets or sets the per loop cycle increment statement.
InitStatement | Gets or sets the loop initialization statement.
LinePragma (inherited from CodeStatement) | The line the statement occurs on.
Statements | Gets or sets the statements to be executed within the loop.
TestExpression | Gets or sets the expression to test for.

See Also

CodeForLoopStatement Class | System.CodeDOM Namespace


CodeForLoopStatement.IncrementStatement

Gets or sets the per loop cycle increment statement.

[Visual Basic]
Public Property IncrementStatement As CodeStatement
[C#]
public CodeStatement IncrementStatement {get; set;}
[C++]
public: __property CodeStatement* get_IncrementStatement();
public: __property void set_IncrementStatement(CodeStatement*);
[JScript]
public function get IncrementStatement() : CodeStatement;
public function set IncrementStatement(CodeStatement);

Property Value

A CodeStatement containing the per cycle increment statement.

See Also

CodeForLoopStatement Class | CodeForLoopStatement Members | System.CodeDOM Namespace | CodeStatement


CodeForLoopStatement.InitStatement

Gets or sets the loop initialization statement.

[Visual Basic]
Public Property InitStatement As CodeStatement
[C#]
public CodeStatement InitStatement {get; set;}
[C++]
public: __property CodeStatement* get_InitStatement();
public: __property void set_InitStatement(CodeStatement*);
[JScript]
public function get InitStatement() : CodeStatement;
public function set InitStatement(CodeStatement);

Property Value

A CodeStatement containing the loop initialization statement.

See Also

CodeForLoopStatement Class | CodeForLoopStatement Members | System.CodeDOM Namespace


CodeForLoopStatement.Statements

Gets or sets the statements to be executed within the loop.

[Visual Basic]
Public ReadOnly Property Statements As CodeStatementCollection
[C#]
public CodeStatementCollection Statements {get;}
[C++]
public: __property CodeStatementCollection* get_Statements();
[JScript]
public function get Statements() : CodeStatementCollection;

Property Value

An array of type CodeStatement containing the statements within the loop.

See Also

CodeForLoopStatement Class | CodeForLoopStatement Members | System.CodeDOM Namespace | CodeStatement


CodeForLoopStatement.TestExpression

Gets or sets the expression to test for.

[Visual Basic]
Public Property TestExpression As CodeExpression
[C#]
public CodeExpression TestExpression {get; set;}
[C++]
public: __property CodeExpression* get_TestExpression();
public: __property void set_TestExpression(CodeExpression*);
[JScript]
public function get TestExpression() : CodeExpression;
public function set TestExpression(CodeExpression);

Property Value

A CodeExpression containing the expression to test for loop exit condition.

See Also

CodeForLoopStatement Class | CodeForLoopStatement Members | System.CodeDOM Namespace | CodeExpression


CodeIfStatement Class

Represents a basic if statement.

Object
CodeStatement
CodeIfStatement

[Visual Basic]
Public Class CodeIfStatement
   Inherits CodeStatement
[C#]
public class CodeIfStatement : CodeStatement
[C++]
public __gc class CodeIfStatement : public CodeStatement
[JScript]
public class CodeIfStatement extends CodeStatement

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeIfStatement Members | System.CodeDOM Namespace


CodeIfStatement Members

Public:

Constructor

CodeIfStatement Constructor Overloaded. Initializes a new instance of CodeIfStatement.

Properties

Condition | Gets or sets the condition to test for true.
FalseStatements | Gets or sets the statements to execute if test condition is false and there is an else clause.
LinePragma (inherited from CodeStatement) | The line the statement occurs on.
TrueStatements | Gets or sets the statements to execute if test condition is true.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeIfStatement Class | System.CodeDOM Namespace


CodeIfStatement Constructor

Initializes a new instance of CodeIfStatement.

Overload List

Initializes a new instance of CodeIfStatement.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeIfStatement();
[C++] public: CodeIfStatement();
[JScript] public function CodeIfStatement();

Initializes a new instance of CodeIfStatement.

[Visual Basic] Overloads Public Sub New(CodeExpression, CodeStatement())
[C#] public CodeIfStatement(CodeExpression, CodeStatement[]);
[C++] public: CodeIfStatement(CodeExpression*, CodeStatement[]);
[JScript] public function CodeIfStatement(CodeExpression, CodeStatement[]);

Initializes a new instance of CodeIfStatement that can represent an if.. else statement.

[Visual Basic] Overloads Public Sub New(CodeExpression, CodeStatement(), CodeStatement())
[C#] public CodeIfStatement(CodeExpression, CodeStatement[], CodeStatement[]);
[C++] public: CodeIfStatement(CodeExpression*, CodeStatement[], CodeStatement[]);
[JScript] public function CodeIfStatement(CodeExpression, CodeStatement[], CodeStatement[]);

See Also

CodeIfStatement Class | CodeIfStatement Members | System.CodeDOM Namespace


CodeIfStatement Constructor ()

Initializes a new instance of CodeIfStatement.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeIfStatement();
[C++]
public: CodeIfStatement();
[JScript]
public function CodeIfStatement();

See Also

CodeIfStatement Class | CodeIfStatement Members | System.CodeDOM Namespace | CodeIfStatement Constructor Overload List


CodeIfStatement Constructor (CodeExpression, CodeStatement[])

Initializes a new instance of CodeIfStatement.

[Visual Basic]
Overloads Public Sub New( _
   ByVal condition As CodeExpression, _
   ByVal trueStatements() As CodeStatement _
)
[C#]
public CodeIfStatement(
   CodeExpression condition,
   CodeStatement[] trueStatements
);
[C++]
public: CodeIfStatement(
   CodeExpression* condition,
   CodeStatement* trueStatements[]
);
[JScript]
public function CodeIfStatement(
   condition : CodeExpression,
   trueStatements : CodeStatement[]
);

Parameters

condition
A CodeExpression that indicates the condition to test for.
trueStatements
[To be supplied.]

See Also

CodeIfStatement Class | CodeIfStatement Members | System.CodeDOM Namespace | CodeIfStatement Constructor Overload List | CodeExpression | CodeStatement


CodeIfStatement Constructor (CodeExpression, CodeStatement[], CodeStatement[])

Initializes a new instance of CodeIfStatement that can represent an if.. else statement.

[Visual Basic]
Overloads Public Sub New( _
   ByVal condition As CodeExpression, _
   ByVal trueStatements() As CodeStatement, _
   ByVal falseStatements() As CodeStatement _
)
[C#]
public CodeIfStatement(
   CodeExpression condition,
   CodeStatement[] trueStatements,
   CodeStatement[] falseStatements
);
[C++]
public: CodeIfStatement(
   CodeExpression* condition,
   CodeStatement* trueStatements[],
   CodeStatement* falseStatements[]
);
[JScript]
public function CodeIfStatement(
   condition : CodeExpression,
   trueStatements : CodeStatement[],
   falseStatements : CodeStatement[]
);

Parameters

condition
A CodeExpression that indicates the condition to test for.
trueStatements
[To be supplied.]
falseStatements
[To be supplied.]

See Also

CodeIfStatement Class | CodeIfStatement Members | System.CodeDOM Namespace | CodeIfStatement Constructor Overload List | CodeExpression | CodeStatement


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeIfStatement Properties

The properties of the CodeIfStatement class are listed below. For a complete list of CodeIfStatement class members, see the CodeIfStatement Members topic.

Public:

Condition | Gets or sets the condition to test for true.
FalseStatements | Gets or sets the statements to execute if test condition is false and there is an else clause.
LinePragma (inherited from CodeStatement) | The line the statement occurs on.
TrueStatements | Gets or sets the statements to execute if test condition is true.

See Also

CodeIfStatement Class | System.CodeDOM Namespace


CodeIfStatement.Condition

Gets or sets the condition to test for true.

[Visual Basic]
Public Property Condition As CodeExpression
[C#]
public CodeExpression Condition {get; set;}
[C++]
public: __property CodeExpression* get_Condition();
public: __property void set_Condition(CodeExpression*);
[JScript]
public function get Condition() : CodeExpression;
public function set Condition(CodeExpression);

Property Value

A CodeExpression that indicates the condition to test for.

See Also

CodeIfStatement Class | CodeIfStatement Members | System.CodeDOM Namespace | CodeExpression


CodeIfStatement.FalseStatements

Gets or sets the statements to execute if test condition is false and there is an else clause.

[Visual Basic]
Public ReadOnly Property FalseStatements As CodeStatementCollection
[C#]
public CodeStatementCollection FalseStatements {get;}
[C++]
public: __property CodeStatementCollection* get_FalseStatements();
[JScript]
public function get FalseStatements() : CodeStatementCollection;

Property Value

An array of type CodeStatement containing the statements to execute if the condition is false.

See Also

CodeIfStatement Class | CodeIfStatement Members | System.CodeDOM Namespace | CodeStatementCollection


CodeIfStatement.TrueStatements

Gets or sets the statements to execute if test condition is true.

[Visual Basic]
Public ReadOnly Property TrueStatements As CodeStatementCollection
[C#]
public CodeStatementCollection TrueStatements {get;}
[C++]
public: __property CodeStatementCollection* get_TrueStatements();
[JScript]
public function get TrueStatements() : CodeStatementCollection;

Property Value

An array of type CodeStatement containing the statements to execute if the condition is true.

See Also

CodeIfStatement Class | CodeIfStatement Members | System.CodeDOM Namespace | CodeStatementCollection


CodeIndexerExpression Class

Represents an array indexer expression.

Object
CodeExpression
CodeIndexerExpression

[Visual Basic]
Public Class CodeIndexerExpression
   Inherits CodeExpression
[C#]
public class CodeIndexerExpression : CodeExpression
[C++]
public __gc class CodeIndexerExpression : public CodeExpression
[JScript]
public class CodeIndexerExpression extends CodeExpression

Remarks

This may also be used to index through a class indexer.

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeIndexerExpression Members | System.CodeDOM Namespace


CodeIndexerExpression Members

Public:

Constructor

CodeIndexerExpression Constructor Overloaded. Initializes a new instance of CodeIndexerExpression.

Properties

Index | Gets or sets the index.
TargetObject | Gets or sets the target object.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeIndexerExpression Class | System.CodeDOM Namespace


CodeIndexerExpression Constructor

Initializes a new instance of CodeIndexerExpression.

Overload List

Initializes a new instance of CodeIndexerExpression.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeIndexerExpression();
[C++] public: CodeIndexerExpression();
[JScript] public function CodeIndexerExpression();

Initializes a new instance of CodeIndexerExpression using the specified target object and index.

[Visual Basic] Overloads Public Sub New(CodeExpression, CodeExpression)
[C#] public CodeIndexerExpression(CodeExpression, CodeExpression);
[C++] public: CodeIndexerExpression(CodeExpression*, CodeExpression*);
[JScript] public function CodeIndexerExpression(CodeExpression, CodeExpression);

See Also

CodeIndexerExpression Class | CodeIndexerExpression Members | System.CodeDOM Namespace


CodeIndexerExpression Constructor ()

Initializes a new instance of CodeIndexerExpression.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeIndexerExpression();
[C++]
public: CodeIndexerExpression();
[JScript]
public function CodeIndexerExpression();

See Also

CodeIndexerExpression Class | CodeIndexerExpression Members | System.CodeDOM Namespace | CodeIndexerExpression Constructor Overload List


CodeIndexerExpression Constructor (CodeExpression, CodeExpression)

Initializes a new instance of CodeIndexerExpression using the specified target object and index.

[Visual Basic]
Overloads Public Sub New( _
   ByVal targetObject As CodeExpression, _
   ByVal index As CodeExpression _
)
[C#]
public CodeIndexerExpression(
   CodeExpression targetObject,
   CodeExpression index
);
[C++]
public: CodeIndexerExpression(
   CodeExpression* targetObject,
   CodeExpression* index
);
[JScript]
public function CodeIndexerExpression(
   targetObject : CodeExpression,
   index : CodeExpression
);

Parameters

targetObject
The target object.
index
[To be supplied.]

See Also

CodeIndexerExpression Class | CodeIndexerExpression Members | System.CodeDOM Namespace | CodeIndexerExpression Constructor Overload List | CodeExpression


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeIndexerExpression Properties

The properties of the CodeIndexerExpression class are listed below. For a complete list of CodeIndexerExpression class members, see the CodeIndexerExpression Members topic.

Public:

Index | Gets or sets the index.
TargetObject | Gets or sets the target object.

See Also

CodeIndexerExpression Class | System.CodeDOM Namespace


CodeIndexerExpression.Index

Gets or sets the index.

[Visual Basic]
Public Property Index As CodeExpression
[C#]
public CodeExpression Index {get; set;}
[C++]
public: __property CodeExpression* get_Index();
public: __property void set_Index(CodeExpression*);
[JScript]
public function get Index() : CodeExpression;
public function set Index(CodeExpression);

Property Value

A CodeExpression indicating the index.

See Also

CodeIndexerExpression Class | CodeIndexerExpression Members | System.CodeDOM Namespace


CodeIndexerExpression.TargetObject

Gets or sets the target object.

[Visual Basic]
Public Property TargetObject As CodeExpression
[C#]
public CodeExpression TargetObject {get; set;}
[C++]
public: __property CodeExpression* get_TargetObject();
public: __property void set_TargetObject(CodeExpression*);
[JScript]
public function get TargetObject() : CodeExpression;
public function set TargetObject(CodeExpression);

Property Value

A CodeExpression indicating the target object.

See Also

CodeIndexerExpression Class | CodeIndexerExpression Members | System.CodeDOM Namespace


CodeLinePragma Class

Represents line number information for an external file.

Object
CodeLinePragma

[Visual Basic]
Public Class CodeLinePragma
[C#]
public class CodeLinePragma
[C++]
public __gc class CodeLinePragma
[JScript]
public class CodeLinePragma

Remarks

This is normally used post-compile by debugging tools.

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeLinePragma Members | System.CodeDOM Namespace


CodeLinePragma Members

Public:

Constructor

CodeLinePragma Constructor Initializes a new instance of CodeLinePragma.

Properties

FileName | Gets or sets the filename of the associated file.
LineNumber | Gets or sets the line number of the file for the current pragma.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeLinePragma Class | System.CodeDOM Namespace


CodeLinePragma Constructor

Initializes a new instance of CodeLinePragma.

[Visual Basic]
Public Sub New( _
   ByVal fileName As String, _
   ByVal lineNumber As Integer _
)
[C#]
public CodeLinePragma(
   string fileName,
   int lineNumber
);
[C++]
public: CodeLinePragma(
   String* fileName,
   int lineNumber
);
[JScript]
public function CodeLinePragma(
   fileName : String,
   lineNumber : int
);

Parameters

fileName
The filename of the associated file.
lineNumber
[To be supplied.]

See Also

CodeLinePragma Class | CodeLinePragma Members | System.CodeDOM Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeLinePragma Properties

The properties of the CodeLinePragma class are listed below. For a complete list of CodeLinePragma class members, see the CodeLinePragma Members topic.

Public:

FileName | Gets or sets the filename of the associated file.
LineNumber | Gets or sets the line number of the file for the current pragma.

See Also

CodeLinePragma Class | System.CodeDOM Namespace


CodeLinePragma.FileName

Gets or sets the filename of the associated file.

[Visual Basic]
Public Property FileName As String
[C#]
public string FileName {get; set;}
[C++]
public: __property String* get_FileName();
public: __property void set_FileName(String*);
[JScript]
public function get FileName() : String;
public function set FileName(String);

Property Value

The filename of the associated file.

See Also

CodeLinePragma Class | CodeLinePragma Members | System.CodeDOM Namespace


CodeLinePragma.LineNumber

Gets or sets the line number of the file for the current pragma.

[Visual Basic]
Public Property LineNumber As Integer
[C#]
public int LineNumber {get; set;}
[C++]
public: __property int get_LineNumber();
public: __property void set_LineNumber(int);
[JScript]
public function get LineNumber() : int;
public function set LineNumber(int);

Property Value

The line number of the file.

See Also

CodeLinePragma Class | CodeLinePragma Members | System.CodeDOM Namespace


CodeLiteralClassMember Class

Represents members of a class.

Object
CodeStatement
CodeClassMember
CodeLiteralClassMember

[Visual Basic]
Public Class CodeLiteralClassMember
   Inherits CodeClassMember
[C#]
public class CodeLiteralClassMember : CodeClassMember
[C++]
public __gc class CodeLiteralClassMember : public CodeClassMember
[JScript]
public class CodeLiteralClassMember extends CodeClassMember

Remarks

This is the base class for representing members of a class using the code DOM.

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeLiteralClassMember Members | System.CodeDOM Namespace


CodeLiteralClassMember Members

Public:

Constructor

CodeLiteralClassMember Constructor Overloaded. Initializes a new instance of CodeLiteralClassMember.

Properties

Attributes (inherited from CodeClassMember) | The attributes of the member.
CustomAttributes (inherited from CodeClassMember) | The custom attributes of the member.
LinePragma (inherited from CodeStatement) | The line the statement occurs on.
Name (inherited from CodeClassMember) | The name of the member.
Text | Gets or sets the code for the class member.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeLiteralClassMember Class | System.CodeDOM Namespace


CodeLiteralClassMember Constructor

Initializes a new instance of CodeLiteralClassMember.

Overload List

Initializes a new instance of CodeLiteralClassMember.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeLiteralClassMember();
[C++] public: CodeLiteralClassMember();
[JScript] public function CodeLiteralClassMember();

Initializes a new instance of CodeLiteralClassMember.

[Visual Basic] Overloads Public Sub New(String)
[C#] public CodeLiteralClassMember(String);
[C++] public: CodeLiteralClassMember(String*);
[JScript] public function CodeLiteralClassMember(String);

See Also

CodeLiteralClassMember Class | CodeLiteralClassMember Members | System.CodeDOM Namespace


CodeLiteralClassMember Constructor ()

Initializes a new instance of CodeLiteralClassMember.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeLiteralClassMember();
[C++]
public: CodeLiteralClassMember();
[JScript]
public function CodeLiteralClassMember();

See Also

CodeLiteralClassMember Class | CodeLiteralClassMember Members | System.CodeDOM Namespace | CodeLiteralClassMember Constructor Overload List


CodeLiteralClassMember Constructor (String)

Initializes a new instance of CodeLiteralClassMember.

[Visual Basic]
Overloads Public Sub New( _
   ByVal text As String _
)
[C#]
public CodeLiteralClassMember(
   string text
);
[C++]
public: CodeLiteralClassMember(
   String* text
);
[JScript]
public function CodeLiteralClassMember(
   text : String
);

Parameters

text
The code for the class member.

See Also

CodeLiteralClassMember Class | CodeLiteralClassMember Members | System.CodeDOM Namespace | CodeLiteralClassMember Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeLiteralClassMember Properties

The properties of the CodeLiteralClassMember class are listed below. For a complete list of CodeLiteralClassMember class members, see the CodeLiteralClassMember Members topic.

Public:

Attributes (inherited from CodeClassMember) | The attributes of the member.
CustomAttributes (inherited from CodeClassMember) | The custom attributes of the member.
LinePragma (inherited from CodeStatement) | The line the statement occurs on.
Name (inherited from CodeClassMember) | The name of the member.
Text | Gets or sets the code for the class member.

See Also

CodeLiteralClassMember Class | System.CodeDOM Namespace


CodeLiteralClassMember.Text

Gets or sets the code for the class member.

[Visual Basic]
Public Property Text As String
[C#]
public string Text {get; set;}
[C++]
public: __property String* get_Text();
public: __property void set_Text(String*);
[JScript]
public function get Text() : String;
public function set Text(String);

Property Value

The code for the class member.

See Also

CodeLiteralClassMember Class | CodeLiteralClassMember Members | System.CodeDOM Namespace


CodeLiteralExpression Class

Represents a literal expression.

Object
CodeExpression
CodeLiteralExpression

[Visual Basic]
Public Class CodeLiteralExpression
   Inherits CodeExpression
[C#]
public class CodeLiteralExpression : CodeExpression
[C++]
public __gc class CodeLiteralExpression : public CodeExpression
[JScript]
public class CodeLiteralExpression extends CodeExpression

Remarks

This will be injected directly in the source without modification.

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeLiteralExpression Members | System.CodeDOM Namespace


CodeLiteralExpression Members

Public:

Constructor

CodeLiteralExpression Constructor Overloaded. Initializes a new instance of CodeLiteralExpression.

Properties

Value Gets or sets the literal expression.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeLiteralExpression Class | System.CodeDOM Namespace


CodeLiteralExpression Constructor

Initializes a new instance of CodeLiteralExpression.

Overload List

Initializes a new instance of CodeLiteralExpression.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeLiteralExpression();
[C++] public: CodeLiteralExpression();
[JScript] public function CodeLiteralExpression();

Initializes a new instance of CodeLiteralExpression using the specified literal expression.

[Visual Basic] Overloads Public Sub New(String)
[C#] public CodeLiteralExpression(String);
[C++] public: CodeLiteralExpression(String*);
[JScript] public function CodeLiteralExpression(String);

See Also

CodeLiteralExpression Class | CodeLiteralExpression Members | System.CodeDOM Namespace


CodeLiteralExpression Constructor ()

Initializes a new instance of CodeLiteralExpression.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeLiteralExpression();
[C++]
public: CodeLiteralExpression();
[JScript]
public function CodeLiteralExpression();

See Also

CodeLiteralExpression Class | CodeLiteralExpression Members | System.CodeDOM Namespace | CodeLiteralExpression Constructor Overload List


CodeLiteralExpression Constructor (String)

Initializes a new instance of CodeLiteralExpression using the specified literal expression.

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As String _
)
[C#]
public CodeLiteralExpression(
   string value
);
[C++]
public: CodeLiteralExpression(
   String* value
);
[JScript]
public function CodeLiteralExpression(
   value : String
);

Parameters

value
The literal expression to represent.

See Also

CodeLiteralExpression Class | CodeLiteralExpression Members | System.CodeDOM Namespace | CodeLiteralExpression Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeLiteralExpression Properties

The properties of the CodeLiteralExpression class are listed below. For a complete list of CodeLiteralExpression class members, see the CodeLiteralExpression Members topic.

Public:

Value Gets or sets the literal expression.

See Also

CodeLiteralExpression Class | System.CodeDOM Namespace


CodeLiteralExpression.Value

Gets or sets the literal expression.

[Visual Basic]
Public Property Value As String
[C#]
public string Value {get; set;}
[C++]
public: __property String* get_Value();
public: __property void set_Value(String*);
[JScript]
public function get Value() : String;
public function set Value(String);

Property Value

The literal expression.

See Also

CodeLiteralExpression Class | CodeLiteralExpression Members | System.CodeDOM Namespace


CodeLiteralStatement Class

Represents a literal text statement.

Object
CodeStatement
CodeLiteralStatement

[Visual Basic]
Public Class CodeLiteralStatement
   Inherits CodeStatement
[C#]
public class CodeLiteralStatement : CodeStatement
[C++]
public __gc class CodeLiteralStatement : public CodeStatement
[JScript]
public class CodeLiteralStatement extends CodeStatement

Remarks

This will be injected directly in the source without modification.

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeLiteralStatement Members | System.CodeDOM Namespace


CodeLiteralStatement Members

Public:

Constructor

CodeLiteralStatement Constructor Initializes a new instance of CodeLiteralStatement.

Properties

LinePragma (inherited from CodeStatement) | The line the statement occurs on.
Value | The literal text of the statement to represent.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeLiteralStatement Class | System.CodeDOM Namespace


CodeLiteralStatement Constructor

Initializes a new instance of CodeLiteralStatement.

[Visual Basic]
Public Sub New( _
   ByVal value As String _
)
[C#]
public CodeLiteralStatement(
   string value
);
[C++]
public: CodeLiteralStatement(
   String* value
);
[JScript]
public function CodeLiteralStatement(
   value : String
);

Parameters

value
The literal text to represent.

See Also

CodeLiteralStatement Class | CodeLiteralStatement Members | System.CodeDOM Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeLiteralStatement Properties

The properties of the CodeLiteralStatement class are listed below. For a complete list of CodeLiteralStatement class members, see the CodeLiteralStatement Members topic.

Public:

LinePragma (inherited from CodeStatement) | The line the statement occurs on.
Value | The literal text of the statement to represent.

See Also

CodeLiteralStatement Class | System.CodeDOM Namespace


CodeLiteralStatement.Value

The literal text of the statement to represent.

[Visual Basic]
Public Property Value As String
[C#]
public string Value {get; set;}
[C++]
public: __property String* get_Value();
public: __property void set_Value(String*);
[JScript]
public function get Value() : String;
public function set Value(String);

Property Value

The literal text of the statement to represent.

See Also

CodeLiteralStatement Class | CodeLiteralStatement Members | System.CodeDOM Namespace


CodeMemberEvent Class

Represents an event member.

Object
CodeStatement
CodeClassMember
CodeMemberEvent

[Visual Basic]
Public Class CodeMemberEvent
   Inherits CodeClassMember
[C#]
public class CodeMemberEvent : CodeClassMember
[C++]
public __gc class CodeMemberEvent : public CodeClassMember
[JScript]
public class CodeMemberEvent extends CodeClassMember

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeMemberEvent Members | System.CodeDOM Namespace


CodeMemberEvent Members

Public:

Constructor

CodeMemberEvent Constructor [To be supplied.]

Properties

Attributes (inherited from CodeClassMember) | The attributes of the member.
CustomAttributes (inherited from CodeClassMember) | The custom attributes of the member.
ImplementsType | [To be supplied.]
LinePragma (inherited from CodeStatement) | The line the statement occurs on.
Name (inherited from CodeClassMember) | The name of the member.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeMemberEvent Class | System.CodeDOM Namespace


CodeMemberEvent Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CodeMemberEvent();
[C++]
public: CodeMemberEvent();
[JScript]
public function CodeMemberEvent();

See Also

CodeMemberEvent Class | CodeMemberEvent Members | System.CodeDOM Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeMemberEvent Properties

The properties of the CodeMemberEvent class are listed below. For a complete list of CodeMemberEvent class members, see the CodeMemberEvent Members topic.

Public:

Attributes (inherited from CodeClassMember) | The attributes of the member.
CustomAttributes (inherited from CodeClassMember) | The custom attributes of the member.
ImplementsType | [To be supplied.]
LinePragma (inherited from CodeStatement) | The line the statement occurs on.
Name (inherited from CodeClassMember) | The name of the member.

See Also

CodeMemberEvent Class | System.CodeDOM Namespace


CodeMemberEvent.ImplementsType

[To be supplied.]

[Visual Basic]
Public Property
   ImplementsType As String
[C#]
public string ImplementsType {get; set;}
[C++]
public: __property String* get_ImplementsType();
public: __property void set_ImplementsType(String*);
[JScript]
public function get ImplementsType() : String;
public function set ImplementsType(String);

See Also

CodeMemberEvent Class | CodeMemberEvent Members | System.CodeDOM Namespace


CodeMemberField Class

Represents a class field member.

Object
CodeStatement
CodeClassMember
CodeMemberField

[Visual Basic]
Public Class CodeMemberField
   Inherits CodeClassMember
[C#]
public class CodeMemberField : CodeClassMember
[C++]
public __gc class CodeMemberField : public CodeClassMember
[JScript]
public class CodeMemberField extends CodeClassMember

Remarks

Languages that don't support initialization may choose to inject the InitExpression into a constructor.

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeMemberField Members | System.CodeDOM Namespace


CodeMemberField Members

Public:

Constructor

CodeMemberField Constructor Overloaded. Initializes a new CodeMemberField.

Properties

Attributes (inherited from CodeClassMember) | The attributes of the member.
CustomAttributes (inherited from CodeClassMember) | The custom attributes of the member.
InitExpression | Gets or sets the initialization expression for the member field.
LinePragma (inherited from CodeStatement) | The line the statement occurs on.
Name (inherited from CodeClassMember) | The name of the member.
Type | Gets or sets the member field type.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeMemberField Class | System.CodeDOM Namespace


CodeMemberField Constructor

Initializes a new CodeMemberField.

Overload List

Initializes a new CodeMemberField.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeMemberField();
[C++] public: CodeMemberField();
[JScript] public function CodeMemberField();

Initializes a new CodeMemberField with the specified member field type and name.

[Visual Basic] Overloads Public Sub New(String, String)
[C#] public CodeMemberField(String, String);
[C++] public: CodeMemberField(String*, String*);
[JScript] public function CodeMemberField(String, String);

See Also

CodeMemberField Class | CodeMemberField Members | System.CodeDOM Namespace


CodeMemberField Constructor ()

Initializes a new CodeMemberField.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeMemberField();
[C++]
public: CodeMemberField();
[JScript]
public function CodeMemberField();

See Also

CodeMemberField Class | CodeMemberField Members | System.CodeDOM Namespace | CodeMemberField Constructor Overload List


CodeMemberField Constructor (String, String)

Initializes a new CodeMemberField with the specified member field type and name.

[Visual Basic]
Overloads Public Sub New( _
   ByVal type As String, _
   ByVal name As String _
)
[C#]
public CodeMemberField(
   string type,
   string name
);
[C++]
public: CodeMemberField(
   String* type,
   String* name
);
[JScript]
public function CodeMemberField(
   type : String,
   name : String
);

Parameters

type
The type of the member field.
name
[To be supplied.]

See Also

CodeMemberField Class | CodeMemberField Members | System.CodeDOM Namespace | CodeMemberField Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeMemberField Properties

The properties of the CodeMemberField class are listed below. For a complete list of CodeMemberField class members, see the CodeMemberField Members topic.

Public:

Attributes (inherited from CodeClassMember) | The attributes of the member.
CustomAttributes (inherited from CodeClassMember) | The custom attributes of the member.
InitExpression | Gets or sets the initialization expression for the member field.
LinePragma (inherited from CodeStatement) | The line the statement occurs on.
Name (inherited from CodeClassMember) | The name of the member.
Type | Gets or sets the member field type.

See Also

CodeMemberField Class | System.CodeDOM Namespace


CodeMemberField.InitExpression

Gets or sets the initialization expression for the member field.

[Visual Basic]
Public Property InitExpression As CodeExpression
[C#]
public CodeExpression InitExpression {get; set;}
[C++]
public: __property CodeExpression* get_InitExpression();
public: __property void set_InitExpression(CodeExpression*);
[JScript]
public function get InitExpression() : CodeExpression;
public function set InitExpression(CodeExpression);

Property Value

A CodeExpression that indicates the initialization expression for the member field.

See Also

CodeMemberField Class | CodeMemberField Members | System.CodeDOM Namespace | CodeExpression


CodeMemberField.Type

Gets or sets the member field type.

[Visual Basic]
Public Property Type As String
[C#]
public string Type {get; set;}
[C++]
public: __property String* get_Type();
public: __property void set_Type(String*);
[JScript]
public function get Type() : String;
public function set Type(String);

Property Value

The type of the member field.

See Also

CodeMemberField Class | CodeMemberField Members | System.CodeDOM Namespace


CodeMemberMethod Class

Represents a class method.

Object
CodeStatement
CodeClassMember
CodeMemberMethod

[Visual Basic]
Public Class CodeMemberMethod
   Inherits CodeClassMember
[C#]
public class CodeMemberMethod : CodeClassMember
[C++]
public __gc class CodeMemberMethod : public CodeClassMember
[JScript]
public class CodeMemberMethod extends CodeClassMember

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeMemberMethod Members | System.CodeDOM Namespace


CodeMemberMethod Members

Public:

Constructor

CodeMemberMethod Constructor [To be supplied.]

Properties

Attributes (inherited from CodeClassMember) | The attributes of the member.
CustomAttributes (inherited from CodeClassMember) | The custom attributes of the member.
ImplementsType | [To be supplied.]
LinePragma (inherited from CodeStatement) | The line the statement occurs on.
Name (inherited from CodeClassMember) | The name of the member.
Parameters | Gets or sets the parameter declarations for the method.
ReturnType | Gets or sets the return type of the method.
Statements | Gets or sets the statements within the method.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeMemberMethod Class | System.CodeDOM Namespace


CodeMemberMethod Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CodeMemberMethod();
[C++]
public: CodeMemberMethod();
[JScript]
public function CodeMemberMethod();

See Also

CodeMemberMethod Class | CodeMemberMethod Members | System.CodeDOM Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeMemberMethod Properties

The properties of the CodeMemberMethod class are listed below. For a complete list of CodeMemberMethod class members, see the CodeMemberMethod Members topic.

Public:

Attributes (inherited from CodeClassMember) | The attributes of the member.
CustomAttributes (inherited from CodeClassMember) | The custom attributes of the member.
ImplementsType | [To be supplied.]
LinePragma (inherited from CodeStatement) | The line the statement occurs on.
Name (inherited from CodeClassMember) | The name of the member.
Parameters | Gets or sets the parameter declarations for the method.
ReturnType | Gets or sets the return type of the method.
Statements | Gets or sets the statements within the method.

See Also

CodeMemberMethod Class | System.CodeDOM Namespace


CodeMemberMethod.ImplementsType

[To be supplied.]

[Visual Basic]
Public Property
   ImplementsType As String
[C#]
public string ImplementsType {get; set;}
[C++]
public: __property String* get_ImplementsType();
public: __property void set_ImplementsType(String*);
[JScript]
public function get ImplementsType() : String;
public function set ImplementsType(String);

See Also

CodeMemberMethod Class | CodeMemberMethod Members | System.CodeDOM Namespace


CodeMemberMethod.Parameters

Gets or sets the parameter declarations for the method.

[Visual Basic]
Public ReadOnly Property Parameters As _
   CodeParameterDeclarationExpressionCollection
[C#]
public CodeParameterDeclarationExpressionCollection Parameters
   {get;}
[C++]
public: __property CodeParameterDeclarationExpressionCollection*
   get_Parameters();
[JScript]
public function get Parameters() :
   CodeParameterDeclarationExpressionCollection;

Property Value

A CodeParameterDeclarationExpressionCollection that indicates the method parameters.

See Also

CodeMemberMethod Class | CodeMemberMethod Members | System.CodeDOM Namespace | CodeParameterDeclarationExpressionCollection


CodeMemberMethod.ReturnType

Gets or sets the return type of the method.

[Visual Basic]
Public Property ReturnType As String
[C#]
public string ReturnType {get; set;}
[C++]
public: __property String* get_ReturnType();
public: __property void set_ReturnType(String*);
[JScript]
public function get ReturnType() : String;
public function set ReturnType(String);

Property Value

The return type of the method.

See Also

CodeMemberMethod Class | CodeMemberMethod Members | System.CodeDOM Namespace


CodeMemberMethod.Statements

Gets or sets the statements within the method.

[Visual Basic]
Public ReadOnly Property Statements As CodeStatementCollection
[C#]
public CodeStatementCollection Statements {get;}
[C++]
public: __property CodeStatementCollection* get_Statements();
[JScript]
public function get Statements() : CodeStatementCollection;

Property Value

A CodeStatementCollection indicating the statements within the method.

See Also

CodeMemberMethod Class | CodeMemberMethod Members | System.CodeDOM Namespace | CodeStatementCollection


CodeMemberProperty Class

Represents a class property.

Object
CodeStatement
CodeClassMember
CodeMemberProperty

[Visual Basic]
Public Class CodeMemberProperty
   Inherits CodeClassMember
[C#]
public class CodeMemberProperty : CodeClassMember
[C++]
public __gc class CodeMemberProperty : public CodeClassMember
[JScript]
public class CodeMemberProperty extends CodeClassMember

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeMemberProperty Members | System.CodeDOM Namespace


CodeMemberProperty Members

Public:

Constructor

CodeMemberProperty Constructor [To be supplied.]

Properties

Attributes (inherited from CodeClassMember) | The attributes of the member.
CustomAttributes (inherited from CodeClassMember) | The custom attributes of the member.
GetStatements | Gets or sets the collection of get statements for the property.
HasGet | Gets whether the property has a get method accessor.
HasSet | Gets whether the property has a set method accessor.
ImplementsType | [To be supplied.]
LinePragma (inherited from CodeStatement) | The line the statement occurs on.
Name (inherited from CodeClassMember) | The name of the member.
Parameters | Gets or sets the collection of declaration expressions for the property.
SetStatements | Gets or sets the collection of get statements for the property.
Type | Gets or sets the data type of the property.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeMemberProperty Class | System.CodeDOM Namespace


CodeMemberProperty Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CodeMemberProperty();
[C++]
public: CodeMemberProperty();
[JScript]
public function CodeMemberProperty();

See Also

CodeMemberProperty Class | CodeMemberProperty Members | System.CodeDOM Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeMemberProperty Properties

The properties of the CodeMemberProperty class are listed below. For a complete list of CodeMemberProperty class members, see the CodeMemberProperty Members topic.

Public:

Attributes (inherited from CodeClassMember) | The attributes of the member.
CustomAttributes (inherited from CodeClassMember) | The custom attributes of the member.
GetStatements | Gets or sets the collection of get statements for the property.
HasGet | Gets whether the property has a get method accessor.
HasSet | Gets whether the property has a set method accessor.
ImplementsType | [To be supplied.]
LinePragma (inherited from CodeStatement) | The line the statement occurs on.
Name (inherited from CodeClassMember) | The name of the member.
Parameters | Gets or sets the collection of declaration expressions for the property.
SetStatements | Gets or sets the collection of get statements for the property.
Type | Gets or sets the data type of the property.

See Also

CodeMemberProperty Class | System.CodeDOM Namespace


CodeMemberProperty.GetStatements

Gets or sets the collection of get statements for the property.

[Visual Basic]
Public ReadOnly Property GetStatements As CodeStatementCollection
[C#]
public CodeStatementCollection GetStatements {get;}
[C++]
public: __property CodeStatementCollection* get_GetStatements();
[JScript]
public function get GetStatements() : CodeStatementCollection;

Property Value

A CodeStatementCollection that contains the get statements for the member property.

See Also

CodeMemberProperty Class | CodeMemberProperty Members | System.CodeDOM Namespace | CodeStatementCollection


CodeMemberProperty.HasGet

Gets whether the property has a get method accessor.

[Visual Basic]
Public Property HasGet As Boolean
[C#]
public bool HasGet {get; set;}
[C++]
public: __property bool get_HasGet();
public: __property void set_HasGet(bool);
[JScript]
public function get HasGet() : Boolean;
public function set HasGet(Boolean);

Property Value

true if the property has a get method accessor; otherwise, false.

See Also

CodeMemberProperty Class | CodeMemberProperty Members | System.CodeDOM Namespace | HasSet


CodeMemberProperty.HasSet

Gets whether the property has a set method accessor.

[Visual Basic]
Public Property HasSet As Boolean
[C#]
public bool HasSet {get; set;}
[C++]
public: __property bool get_HasSet();
public: __property void set_HasSet(bool);
[JScript]
public function get HasSet() : Boolean;
public function set HasSet(Boolean);

Property Value

true if the property has a set method accessor; otherwise, false.

Remarks

This will should return false if the property is read-only.

See Also

CodeMemberProperty Class | CodeMemberProperty Members | System.CodeDOM Namespace | HasGet


CodeMemberProperty.ImplementsType

[To be supplied.]

[Visual Basic]
Public Property
   ImplementsType As String
[C#]
public string ImplementsType {get; set;}
[C++]
public: __property String* get_ImplementsType();
public: __property void set_ImplementsType(String*);
[JScript]
public function get ImplementsType() : String;
public function set ImplementsType(String);

See Also

CodeMemberProperty Class | CodeMemberProperty Members | System.CodeDOM Namespace


CodeMemberProperty.Parameters

Gets or sets the collection of declaration expressions for the property.

[Visual Basic]
Public ReadOnly Property Parameters As _
   CodeParameterDeclarationExpressionCollection
[C#]
public CodeParameterDeclarationExpressionCollection Parameters
   {get;}
[C++]
public: __property CodeParameterDeclarationExpressionCollection*
   get_Parameters();
[JScript]
public function get Parameters() :
   CodeParameterDeclarationExpressionCollection;

Property Value

A CodeParameterDeclarationExpressionCollection that indicates the declaration expression for the property.

See Also

CodeMemberProperty Class | CodeMemberProperty Members | System.CodeDOM Namespace | CodeParameterDeclarationExpressionCollection


CodeMemberProperty.SetStatements

Gets or sets the collection of get statements for the property.

[Visual Basic]
Public ReadOnly Property SetStatements As CodeStatementCollection
[C#]
public CodeStatementCollection SetStatements {get;}
[C++]
public: __property CodeStatementCollection* get_SetStatements();
[JScript]
public function get SetStatements() : CodeStatementCollection;

Property Value

A CodeStatementCollection that contains the set statements for the member property.

See Also

CodeMemberProperty Class | CodeMemberProperty Members | System.CodeDOM Namespace | CodeStatementCollection


CodeMemberProperty.Type

Gets or sets the data type of the property.

[Visual Basic]
Public Property Type As String
[C#]
public string Type {get; set;}
[C++]
public: __property String* get_Type();
public: __property void set_Type(String*);
[JScript]
public function get Type() : String;
public function set Type(String);

Property Value

The data type of the property.

See Also

CodeMemberProperty Class | CodeMemberProperty Members | System.CodeDOM Namespace


CodeMethodInvokeExpression Class

Represents a method invokation expression to be called on a given target.

Object
CodeExpression
CodeMethodInvokeExpression

[Visual Basic]
Public Class CodeMethodInvokeExpression
   Inherits CodeExpression
[C#]
public class CodeMethodInvokeExpression : CodeExpression
[C++]
public __gc class CodeMethodInvokeExpression : public
   CodeExpression
[JScript]
public class CodeMethodInvokeExpression extends CodeExpression

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeMethodInvokeExpression Members | System.CodeDOM Namespace


CodeMethodInvokeExpression Members

Public:

Constructor

CodeMethodInvokeExpression Constructor Overloaded. Initializes a new instance of CodeMethodInvokeExpression.

Properties

MethodName | Gets or sets the name of the method to invoke.
Parameters | The parameters to invoke the method with.
TargetObject | Gets or sets the target object.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeMethodInvokeExpression Class | System.CodeDOM Namespace


CodeMethodInvokeExpression Constructor

Initializes a new instance of CodeMethodInvokeExpression.

Overload List

Initializes a new instance of CodeMethodInvokeExpression.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeMethodInvokeExpression();
[C++] public: CodeMethodInvokeExpression();
[JScript] public function CodeMethodInvokeExpression();

Initializes a new instance of CodeMethodInvokeExpression using the specified target object and method name.

[Visual Basic] Overloads Public Sub New(CodeExpression, String)
[C#] public CodeMethodInvokeExpression(CodeExpression, String);
[C++] public: CodeMethodInvokeExpression(CodeExpression*, String);
[JScript] public function CodeMethodInvokeExpression(CodeExpression, String);

Initializes a new instance of CodeMethodInvokeExpression using the specified target object, method name and parameters.

[Visual Basic] Overloads Public Sub New(CodeExpression, String, CodeExpression())
[C#] public CodeMethodInvokeExpression(CodeExpression, String, CodeExpression[]);
[C++] public: CodeMethodInvokeExpression(CodeExpression*, String, CodeExpression*[]);
[JScript] public function CodeMethodInvokeExpression(CodeExpression, String, CodeExpression[]);

See Also

CodeMethodInvokeExpression Class | CodeMethodInvokeExpression Members | System.CodeDOM Namespace


CodeMethodInvokeExpression Constructor ()

Initializes a new instance of CodeMethodInvokeExpression.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeMethodInvokeExpression();
[C++]
public: CodeMethodInvokeExpression();
[JScript]
public function CodeMethodInvokeExpression();

See Also

CodeMethodInvokeExpression Class | CodeMethodInvokeExpression Members | System.CodeDOM Namespace | CodeMethodInvokeExpression Constructor Overload List


CodeMethodInvokeExpression Constructor (CodeExpression, String)

Initializes a new instance of CodeMethodInvokeExpression using the specified target object and method name.

[Visual Basic]
Overloads Public Sub New( _
   ByVal targetObject As CodeExpression, _
   ByVal methodName As String _
)
[C#]
public CodeMethodInvokeExpression(
   CodeExpression targetObject,
   string methodName
);
[C++]
public: CodeMethodInvokeExpression(
   CodeExpression* targetObject,
   String* methodName
);
[JScript]
public function CodeMethodInvokeExpression(
   targetObject : CodeExpression,
   methodName : String
);

Parameters

targetObject
The object to target.
methodName
[To be supplied.]

See Also

CodeMethodInvokeExpression Class | CodeMethodInvokeExpression Members | System.CodeDOM Namespace | CodeMethodInvokeExpression Constructor Overload List | CodeExpression


CodeMethodInvokeExpression Constructor (CodeExpression, String, CodeExpression[])

Initializes a new instance of CodeMethodInvokeExpression using the specified target object, method name and parameters.

[Visual Basic]
Overloads Public Sub New( _
   ByVal targetObject As CodeExpression, _
   ByVal methodName As String, _
   ByVal parameters() As CodeExpression _
)
[C#]
public CodeMethodInvokeExpression(
   CodeExpression targetObject,
   string methodName,
   CodeExpression[] parameters
);
[C++]
public: CodeMethodInvokeExpression(
   CodeExpression* targetObject,
   String* methodName,
   CodeExpression* parameters[]
);
[JScript]
public function CodeMethodInvokeExpression(
   targetObject : CodeExpression,
   methodName : String,
   parameters : CodeExpression[]
);

Parameters

targetObject
The object to call the method of.
methodName
[To be supplied.]
parameters
[To be supplied.]

See Also

CodeMethodInvokeExpression Class | CodeMethodInvokeExpression Members | System.CodeDOM Namespace | CodeMethodInvokeExpression Constructor Overload List | CodeExpression


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeMethodInvokeExpression Properties

The properties of the CodeMethodInvokeExpression class are listed below. For a complete list of CodeMethodInvokeExpression class members, see the CodeMethodInvokeExpression Members topic.

Public:

MethodName | Gets or sets the name of the method to invoke.
Parameters | The parameters to invoke the method with.
TargetObject | Gets or sets the target object.

See Also

CodeMethodInvokeExpression Class | System.CodeDOM Namespace


CodeMethodInvokeExpression.MethodName

Gets or sets the name of the method to invoke.

[Visual Basic]
Public Property MethodName As String
[C#]
public string MethodName {get; set;}
[C++]
public: __property String* get_MethodName();
public: __property void set_MethodName(String*);
[JScript]
public function get MethodName() : String;
public function set MethodName(String);

Property Value

The name of the method to invoke.

See Also

CodeMethodInvokeExpression Class | CodeMethodInvokeExpression Members | System.CodeDOM Namespace


CodeMethodInvokeExpression.Parameters

The parameters to invoke the method with.

[Visual Basic]
Public ReadOnly Property Parameters As CodeExpressionCollection
[C#]
public CodeExpressionCollection Parameters {get;}
[C++]
public: __property CodeExpressionCollection* get_Parameters();
[JScript]
public function get Parameters() : CodeExpressionCollection;

Property Value

A CodeExpressionCollection indicating the parameters to invoke the method with.

See Also

CodeMethodInvokeExpression Class | CodeMethodInvokeExpression Members | System.CodeDOM Namespace | CodeExpressionCollection


CodeMethodInvokeExpression.TargetObject

Gets or sets the target object.

[Visual Basic]
Public Property TargetObject As CodeExpression
[C#]
public CodeExpression TargetObject {get; set;}
[C++]
public: __property CodeExpression* get_TargetObject();
public: __property void set_TargetObject(CodeExpression*);
[JScript]
public function get TargetObject() : CodeExpression;
public function set TargetObject(CodeExpression);

Property Value

A CodeExpression that indicates the target object.

See Also

CodeMethodInvokeExpression Class | CodeMethodInvokeExpression Members | System.CodeDOM Namespace | CodeExpression


CodeMethodInvokeStatement Class

Represents a method invoke statement to be called on a given target.

Object
CodeStatement
CodeMethodInvokeStatement

[Visual Basic]
Public Class CodeMethodInvokeStatement
   Inherits CodeStatement
[C#]
public class CodeMethodInvokeStatement : CodeStatement
[C++]
public __gc class CodeMethodInvokeStatement : public CodeStatement
[JScript]
public class CodeMethodInvokeStatement extends CodeStatement

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeMethodInvokeStatement Members | System.CodeDOM Namespace


CodeMethodInvokeStatement Members

Public:

Constructor

CodeMethodInvokeStatement Constructor Overloaded. Initializes a new instance of CodeMethodInvokeStatement.

Properties

LinePragma (inherited from CodeStatement) | The line the statement occurs on.
MethodInvoke | Gets or sets the method invoke expression.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeMethodInvokeStatement Class | System.CodeDOM Namespace


CodeMethodInvokeStatement Constructor

Initializes a new instance of CodeMethodInvokeStatement.

Overload List

Initializes a new instance of CodeMethodInvokeStatement.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeMethodInvokeStatement();
[C++] public: CodeMethodInvokeStatement();
[JScript] public function CodeMethodInvokeStatement();

Initializes a new instance of CodeMethodInvokeStatement using the specified method invoke expression.

[Visual Basic] Overloads Public Sub New(CodeMethodInvokeExpression)
[C#] public CodeMethodInvokeStatement(CodeMethodInvokeExpression);
[C++] public: CodeMethodInvokeStatement(CodeMethodInvokeExpression*);
[JScript] public function CodeMethodInvokeStatement(CodeMethodInvokeExpression);

Initializes a new instance of CodeMethodInvokeStatement using the specified target object and method name.

[Visual Basic] Overloads Public Sub New(CodeExpression, String)
[C#] public CodeMethodInvokeStatement(CodeExpression, String);
[C++] public: CodeMethodInvokeStatement(CodeExpression*, String);
[JScript] public function CodeMethodInvokeStatement(CodeExpression, String);

Initializes a new instance of CodeMethodInvokeStatement using the specified target object, method name, and parameters.

[Visual Basic] Overloads Public Sub New(CodeExpression, String, CodeExpression())
[C#] public CodeMethodInvokeStatement(CodeExpression, String, CodeExpression[]);
[C++] public: CodeMethodInvokeStatement(CodeExpression*, String, CodeExpression*[]);
[JScript] public function CodeMethodInvokeStatement(CodeExpression, String, CodeExpression[]);

See Also

CodeMethodInvokeStatement Class | CodeMethodInvokeStatement Members | System.CodeDOM Namespace


CodeMethodInvokeStatement Constructor ()

Initializes a new instance of CodeMethodInvokeStatement.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeMethodInvokeStatement();
[C++]
public: CodeMethodInvokeStatement();
[JScript]
public function CodeMethodInvokeStatement();

See Also

CodeMethodInvokeStatement Class | CodeMethodInvokeStatement Members | System.CodeDOM Namespace | CodeMethodInvokeStatement Constructor Overload List


CodeMethodInvokeStatement Constructor (CodeMethodInvokeExpression)

Initializes a new instance of CodeMethodInvokeStatement using the specified method invoke expression.

[Visual Basic]
Overloads Public Sub New( _
   ByVal methodInvoke As CodeMethodInvokeExpression _
)
[C#]
public CodeMethodInvokeStatement(
   CodeMethodInvokeExpression methodInvoke
);
[C++]
public: CodeMethodInvokeStatement(
   CodeMethodInvokeExpression* methodInvoke
);
[JScript]
public function CodeMethodInvokeStatement(
   methodInvoke : CodeMethodInvokeExpression
);

Parameters

methodInvoke
A CodeMethodInvokeExpression that contains the method invoke expression to use.

See Also

CodeMethodInvokeStatement Class | CodeMethodInvokeStatement Members | System.CodeDOM Namespace | CodeMethodInvokeStatement Constructor Overload List | CodeMethodInvokeExpression


CodeMethodInvokeStatement Constructor (CodeExpression, String)

Initializes a new instance of CodeMethodInvokeStatement using the specified target object and method name.

[Visual Basic]
Overloads Public Sub New( _
   ByVal targetObject As CodeExpression, _
   ByVal methodName As String _
)
[C#]
public CodeMethodInvokeStatement(
   CodeExpression targetObject,
   string methodName
);
[C++]
public: CodeMethodInvokeStatement(
   CodeExpression* targetObject,
   String* methodName
);
[JScript]
public function CodeMethodInvokeStatement(
   targetObject : CodeExpression,
   methodName : String
);

Parameters

targetObject
The object to invoke the method on.
methodName
[To be supplied.]

See Also

CodeMethodInvokeStatement Class | CodeMethodInvokeStatement Members | System.CodeDOM Namespace | CodeMethodInvokeStatement Constructor Overload List


CodeMethodInvokeStatement Constructor (CodeExpression, String, CodeExpression[])

Initializes a new instance of CodeMethodInvokeStatement using the specified target object, method name, and parameters.

[Visual Basic]
Overloads Public Sub New( _
   ByVal targetObject As CodeExpression, _
   ByVal methodName As String, _
   ByVal parameters() As CodeExpression _
)
[C#]
public CodeMethodInvokeStatement(
   CodeExpression targetObject,
   string methodName,
   CodeExpression[] parameters
);
[C++]
public: CodeMethodInvokeStatement(
   CodeExpression* targetObject,
   String* methodName,
   CodeExpression* parameters[]
);
[JScript]
public function CodeMethodInvokeStatement(
   targetObject : CodeExpression,
   methodName : String,
   parameters : CodeExpression[]
);

Parameters

targetObject
The target object to call the method on.
methodName
[To be supplied.]
parameters
[To be supplied.]

See Also

CodeMethodInvokeStatement Class | CodeMethodInvokeStatement Members | System.CodeDOM Namespace | CodeMethodInvokeStatement Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeMethodInvokeStatement Properties

The properties of the CodeMethodInvokeStatement class are listed below. For a complete list of CodeMethodInvokeStatement class members, see the CodeMethodInvokeStatement Members topic.

Public:

LinePragma (inherited from CodeStatement) | The line the statement occurs on.
MethodInvoke | Gets or sets the method invoke expression.

See Also

CodeMethodInvokeStatement Class | System.CodeDOM Namespace


CodeMethodInvokeStatement.MethodInvoke

Gets or sets the method invoke expression.

[Visual Basic]
Public Property MethodInvoke As CodeMethodInvokeExpression
[C#]
public CodeMethodInvokeExpression MethodInvoke {get; set;}
[C++]
public: __property CodeMethodInvokeExpression* get_MethodInvoke();
public: __property void set_MethodInvoke(CodeMethodInvokeExpression*);
[JScript]
public function get MethodInvoke() : CodeMethodInvokeExpression;
public function set MethodInvoke(CodeMethodInvokeExpression);

Property Value

A CodeMethodInvokeExpression that indicates the method to invoke and associated parameters.

See Also

CodeMethodInvokeStatement Class | CodeMethodInvokeStatement Members | System.CodeDOM Namespace | CodeMethodInvokeExpression


CodeMethodReturnStatement Class

Represents a return statement.

Object
CodeStatement
CodeMethodReturnStatement

[Visual Basic]
Public Class CodeMethodReturnStatement
   Inherits CodeStatement
[C#]
public class CodeMethodReturnStatement : CodeStatement
[C++]
public __gc class CodeMethodReturnStatement : public CodeStatement
[JScript]
public class CodeMethodReturnStatement extends CodeStatement

Remarks

The expression should be a null reference (in Visual Basic Nothing) for subroutines, and set to something other than a null reference (Nothing) for functions.

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeMethodReturnStatement Members | System.CodeDOM Namespace


CodeMethodReturnStatement Members

Public:

Constructor

CodeMethodReturnStatement Constructor Overloaded. Initializes a new instance of CodeMethodReturnStatement.

Properties

Expression | Gets or sets the expression that indicates the return statement.
LinePragma (inherited from CodeStatement) | The line the statement occurs on.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeMethodReturnStatement Class | System.CodeDOM Namespace


CodeMethodReturnStatement Constructor

Initializes a new instance of CodeMethodReturnStatement.

Overload List

Initializes a new instance of CodeMethodReturnStatement.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeMethodReturnStatement();
[C++] public: CodeMethodReturnStatement();
[JScript] public function CodeMethodReturnStatement();

Initializes a new instance of CodeMethodReturnStatement using the specified expression.

[Visual Basic] Overloads Public Sub New(CodeExpression)
[C#] public CodeMethodReturnStatement(CodeExpression);
[C++] public: CodeMethodReturnStatement(CodeExpression*);
[JScript] public function CodeMethodReturnStatement(CodeExpression);

See Also

CodeMethodReturnStatement Class | CodeMethodReturnStatement Members | System.CodeDOM Namespace


CodeMethodReturnStatement Constructor ()

Initializes a new instance of CodeMethodReturnStatement.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeMethodReturnStatement();
[C++]
public: CodeMethodReturnStatement();
[JScript]
public function CodeMethodReturnStatement();

See Also

CodeMethodReturnStatement Class | CodeMethodReturnStatement Members | System.CodeDOM Namespace | CodeMethodReturnStatement Constructor Overload List


CodeMethodReturnStatement Constructor (CodeExpression)

Initializes a new instance of CodeMethodReturnStatement using the specified expression.

[Visual Basic]
Overloads Public Sub New( _
   ByVal expression As CodeExpression _
)
[C#]
public CodeMethodReturnStatement(
   CodeExpression expression
);
[C++]
public: CodeMethodReturnStatement(
   CodeExpression* expression
);
[JScript]
public function CodeMethodReturnStatement(
   expression : CodeExpression
);

Parameters

expression
A CodeExpression that indicates the return statement.

See Also

CodeMethodReturnStatement Class | CodeMethodReturnStatement Members | System.CodeDOM Namespace | CodeMethodReturnStatement Constructor Overload List | CodeExpression


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeMethodReturnStatement Properties

The properties of the CodeMethodReturnStatement class are listed below. For a complete list of CodeMethodReturnStatement class members, see the CodeMethodReturnStatement Members topic.

Public:

Expression | Gets or sets the expression that indicates the return statement.
LinePragma (inherited from CodeStatement) | The line the statement occurs on.

See Also

CodeMethodReturnStatement Class | System.CodeDOM Namespace


CodeMethodReturnStatement.Expression

Gets or sets the expression that indicates the return statement.

[Visual Basic]
Public Property Expression As CodeExpression
[C#]
public CodeExpression Expression {get; set;}
[C++]
public: __property CodeExpression* get_Expression();
public: __property void set_Expression(CodeExpression*);
[JScript]
public function get Expression() : CodeExpression;
public function set Expression(CodeExpression);

Property Value

A CodeExpression that indicates the return statement.

See Also

CodeMethodReturnStatement Class | CodeMethodReturnStatement Members | System.CodeDOM Namespace | CodeExpression


CodeNamespace Class

Represents a namespace declaration.

Object
CodeNamespace

[Visual Basic]
Public Class CodeNamespace
[C#]
public class CodeNamespace
[C++]
public __gc class CodeNamespace
[JScript]
public class CodeNamespace

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeNamespace Members | System.CodeDOM Namespace


CodeNamespace Members

Public:

Constructor

CodeNamespace Constructor Overloaded. Initializes a new instance of CodeNamespace.

Properties

AllowLateBound | Gets or sets whether the namespace allows late binding.
Classes | Gets or sets the collection of classes.
Imports | Gets or sets the collection of namespace imports used by the represented namespace.
Name | Gets or sets the name of the namespace.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeNamespace Class | System.CodeDOM Namespace


CodeNamespace Constructor

Initializes a new instance of CodeNamespace.

Overload List

Initializes a new instance of CodeNamespace.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeNamespace();
[C++] public: CodeNamespace();
[JScript] public function CodeNamespace();

Initializes a new instance of CodeNamespace using the specified name.

[Visual Basic] Overloads Public Sub New(String)
[C#] public CodeNamespace(String);
[C++] public: CodeNamespace(String*);
[JScript] public function CodeNamespace(String);

See Also

CodeNamespace Class | CodeNamespace Members | System.CodeDOM Namespace


CodeNamespace Constructor ()

Initializes a new instance of CodeNamespace.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeNamespace();
[C++]
public: CodeNamespace();
[JScript]
public function CodeNamespace();

See Also

CodeNamespace Class | CodeNamespace Members | System.CodeDOM Namespace | CodeNamespace Constructor Overload List


CodeNamespace Constructor (String)

Initializes a new instance of CodeNamespace using the specified name.

[Visual Basic]
Overloads Public Sub New( _
   ByVal name As String _
)
[C#]
public CodeNamespace(
   string name
);
[C++]
public: CodeNamespace(
   String* name
);
[JScript]
public function CodeNamespace(
   name : String
);

Parameters

name
The name for the namespace to represent.

See Also

CodeNamespace Class | CodeNamespace Members | System.CodeDOM Namespace | CodeNamespace Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeNamespace Properties

The properties of the CodeNamespace class are listed below. For a complete list of CodeNamespace class members, see the CodeNamespace Members topic.

Public:

AllowLateBound | Gets or sets whether the namespace allows late binding.
Classes | Gets or sets the collection of classes.
Imports | Gets or sets the collection of namespace imports used by the represented namespace.
Name | Gets or sets the name of the namespace.

See Also

CodeNamespace Class | System.CodeDOM Namespace


CodeNamespace.AllowLateBound

Gets or sets whether the namespace allows late binding.

[Visual Basic]
Public Property AllowLateBound As Boolean
[C#]
public bool AllowLateBound {get; set;}
[C++]
public: __property bool get_AllowLateBound();
public: __property void set_AllowLateBound(bool);
[JScript]
public function get AllowLateBound() : Boolean;
public function set AllowLateBound(Boolean);

Property Value

true if late binding is allowed; otherwise, false.

See Also

CodeNamespace Class | CodeNamespace Members | System.CodeDOM Namespace


CodeNamespace.Classes

Gets or sets the collection of classes.

[Visual Basic]
Public ReadOnly Property Classes As CodeClassCollection
[C#]
public CodeClassCollection Classes {get;}
[C++]
public: __property CodeClassCollection* get_Classes();
[JScript]
public function get Classes() : CodeClassCollection;

Property Value

A CodeClassCollection that indicates the classes the namespace contains.

See Also

CodeNamespace Class | CodeNamespace Members | System.CodeDOM Namespace | CodeClassCollection


CodeNamespace.Imports

Gets or sets the collection of namespace imports used by the represented namespace.

[Visual Basic]
Public ReadOnly Property Imports As CodeNamespaceImportCollection
[C#]
public CodeNamespaceImportCollection Imports {get;}
[C++]
public: __property CodeNamespaceImportCollection* get_Imports();
[JScript]
public function get Imports() : CodeNamespaceImportCollection;

Property Value

A CodeNamespaceImportCollection that indicates the namespace imports used by the represented namespace.

See Also

CodeNamespace Class | CodeNamespace Members | System.CodeDOM Namespace | CodeNamespaceImportCollection


CodeNamespace.Name

Gets or sets the name of the namespace.

[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}
[C++]
public: __property String* get_Name();
public: __property void set_Name(String*);
[JScript]
public function get Name() : String;
public function set Name(String);

Property Value

The name of the namespace.

See Also

CodeNamespace Class | CodeNamespace Members | System.CodeDOM Namespace


CodeNamespaceImport Class

Represents a namespace import into the current namespace.

Object
CodeStatement
CodeNamespaceImport

[Visual Basic]
Public Class CodeNamespaceImport
   Inherits CodeStatement
[C#]
public class CodeNamespaceImport : CodeStatement
[C++]
public __gc class CodeNamespaceImport : public CodeStatement
[JScript]
public class CodeNamespaceImport extends CodeStatement

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeNamespaceImport Members | System.CodeDOM Namespace


CodeNamespaceImport Members

Public:

Constructor

CodeNamespaceImport Constructor Overloaded. Initializes a new instance of CodeNamespaceImport.

Properties

LinePragma (inherited from CodeStatement) | The line the statement occurs on.
NameSpace | Gets or sets the namespace to import.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeNamespaceImport Class | System.CodeDOM Namespace


CodeNamespaceImport Constructor

Initializes a new instance of CodeNamespaceImport.

Overload List

Initializes a new instance of CodeNamespaceImport.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeNamespaceImport();
[C++] public: CodeNamespaceImport();
[JScript] public function CodeNamespaceImport();

Initializes a new instance of CodeNamespaceImport using the specified namespace to import.

[Visual Basic] Overloads Public Sub New(String)
[C#] public CodeNamespaceImport(String);
[C++] public: CodeNamespaceImport(String*);
[JScript] public function CodeNamespaceImport(String);

See Also

CodeNamespaceImport Class | CodeNamespaceImport Members | System.CodeDOM Namespace


CodeNamespaceImport Constructor ()

Initializes a new instance of CodeNamespaceImport.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeNamespaceImport();
[C++]
public: CodeNamespaceImport();
[JScript]
public function CodeNamespaceImport();

See Also

CodeNamespaceImport Class | CodeNamespaceImport Members | System.CodeDOM Namespace | CodeNamespaceImport Constructor Overload List


CodeNamespaceImport Constructor (String)

Initializes a new instance of CodeNamespaceImport using the specified namespace to import.

[Visual Basic]
Overloads Public Sub New( _
   ByVal nameSpace As String _
)
[C#]
public CodeNamespaceImport(
   string nameSpace
);
[C++]
public: CodeNamespaceImport(
   String* nameSpace
);
[JScript]
public function CodeNamespaceImport(
   nameSpace : String
);

Parameters

nameSpace
The namespace to import.

See Also

CodeNamespaceImport Class | CodeNamespaceImport Members | System.CodeDOM Namespace | CodeNamespaceImport Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeNamespaceImport Properties

The properties of the CodeNamespaceImport class are listed below. For a complete list of CodeNamespaceImport class members, see the CodeNamespaceImport Members topic.

Public:

LinePragma (inherited from CodeStatement) | The line the statement occurs on.
NameSpace | Gets or sets the namespace to import.

See Also

CodeNamespaceImport Class | System.CodeDOM Namespace


CodeNamespaceImport.NameSpace

Gets or sets the namespace to import.

[Visual Basic]
Public Property NameSpace As String
[C#]
public string NameSpace {get; set;}
[C++]
public: __property String* get_NameSpace();
public: __property void set_NameSpace(String*);
[JScript]
public function get NameSpace() : String;
public function set NameSpace(String);

Property Value

The namespace to import.

See Also

CodeNamespaceImport Class | CodeNamespaceImport Members | System.CodeDOM Namespace


CodeNamespaceImportCollection Class

Manages a collection of CodeNamespaceImport objects.

Object
CodeNamespaceImportCollection

[Visual Basic]
Public Class CodeNamespaceImportCollection
   Implements IList, ICollection, IEnumerable
[C#]
public class CodeNamespaceImportCollection : IList, ICollection,
   IEnumerable
[C++]
public __gc class CodeNamespaceImportCollection : public IList,
   ICollection, IEnumerable
[JScript]
public class CodeNamespaceImportCollection implements IList,
   ICollection, IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeNamespaceImportCollection Members | System.CodeDOM Namespace


CodeNamespaceImportCollection Members

Public:

Constructor

CodeNamespaceImportCollection Constructor [To be supplied.]

Properties

Count | Gets or sets the number of namespaces in the collection.
Item | Indexer method that provides collection access. In C#, this member is the indexer for the CodeNamespaceImportCollection class.

Methods

Add | Adds a namespace import to the collection.
AddRange | Adds a set of CodeNamespaceImport objects to the collection.
Clear | Clears the collection of members.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Gets an enumerator that enumerates the collection members.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeNamespaceImportCollection Class | System.CodeDOM Namespace


CodeNamespaceImportCollection Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CodeNamespaceImportCollection();
[C++]
public: CodeNamespaceImportCollection();
[JScript]
public function CodeNamespaceImportCollection();

See Also

CodeNamespaceImportCollection Class | CodeNamespaceImportCollection Members | System.CodeDOM Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeNamespaceImportCollection Properties

The properties of the CodeNamespaceImportCollection class are listed below. For a complete list of CodeNamespaceImportCollection class members, see the CodeNamespaceImportCollection Members topic.

Public:

Count | Gets or sets the number of namespaces in the collection.
Item | Indexer method that provides collection access. In C#, this member is the indexer for the CodeNamespaceImportCollection class.

See Also

CodeNamespaceImportCollection Class | System.CodeDOM Namespace


CodeNamespaceImportCollection.Count

Gets or sets the number of namespaces in the collection.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

Property Value

The number of namespaces in the collection.

See Also

CodeNamespaceImportCollection Class | CodeNamespaceImportCollection Members | System.CodeDOM Namespace


CodeNamespaceImportCollection.Item

Indexer method that provides collection access.

[C#] In C#, this member is the indexer for the CodeNamespaceImportCollection class.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As CodeNamespaceImport
[C#]
public CodeNamespaceImport this[
   int index
] {get; set;}
[C++]
public: __property CodeNamespaceImport* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   CodeNamespaceImport*
);
[JScript]
returnValue = CodeNamespaceImportCollectionObject.Item(index);
CodeNamespaceImportCollectionObject.Item(index) = returnValue;
-or-
returnValue = CodeNamespaceImportCollectionObject(index);
CodeNamespaceImportCollectionObject(index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
[To be supplied.]

Parameters [Visual Basic, C#, C++]

index
[To be supplied.]

Property Value

The CodeNamespaceImport at the specified index in the collection.

See Also

CodeNamespaceImportCollection Class | CodeNamespaceImportCollection Members | System.CodeDOM Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeNamespaceImportCollection Methods

The methods of the CodeNamespaceImportCollection class are listed below. For a complete list of CodeNamespaceImportCollection class members, see the CodeNamespaceImportCollection Members topic.

Public:

Add | Adds a namespace import to the collection.
AddRange | Adds a set of CodeNamespaceImport objects to the collection.
Clear | Clears the collection of members.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Gets an enumerator that enumerates the collection members.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeNamespaceImportCollection Class | System.CodeDOM Namespace


CodeNamespaceImportCollection.Add

Adds a namespace import to the collection.

[Visual Basic]
Public Sub Add( _
   ByVal value As CodeNamespaceImport _
)
[C#]
public void Add(
   CodeNamespaceImport value
);
[C++]
public: void Add(
   CodeNamespaceImport* value
);
[JScript]
public function Add(
   value : CodeNamespaceImport
);

Parameters

value
The CodeNamespaceImport to add to the collection.

See Also

CodeNamespaceImportCollection Class | CodeNamespaceImportCollection Members | System.CodeDOM Namespace | CodeNamespaceImport


CodeNamespaceImportCollection.AddRange

Adds a set of CodeNamespaceImport objects to the collection.

[Visual Basic]
Public Sub AddRange( _
   ByVal value() As CodeNamespaceImport _
)
[C#]
public void AddRange(
   CodeNamespaceImport[] value
);
[C++]
public: void AddRange(
   CodeNamespaceImport* value[]
);
[JScript]
public function AddRange(
   value : CodeNamespaceImport[]
);

Parameters

value
An array of type CodeNamespaceImport objects to add to the collection.

See Also

CodeNamespaceImportCollection Class | CodeNamespaceImportCollection Members | System.CodeDOM Namespace | CodeNamespaceImport


CodeNamespaceImportCollection.Clear

Clears the collection of members.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[JScript]
public function Clear();

See Also

CodeNamespaceImportCollection Class | CodeNamespaceImportCollection Members | System.CodeDOM Namespace


CodeNamespaceImportCollection.GetEnumerator

Gets an enumerator that enumerates the collection members.

[Visual Basic]
Public Function GetEnumerator() As IEnumerator
[C#]
public IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

Return Value

An IEnumerator that indicates the collection members.

See Also

CodeNamespaceImportCollection Class | CodeNamespaceImportCollection Members | System.CodeDOM Namespace | IEnumerator


CodeObjectCreateExpression Class

Represents an object create ("new") expression.

Object
CodeExpression
CodeObjectCreateExpression

[Visual Basic]
Public Class CodeObjectCreateExpression
   Inherits CodeExpression
[C#]
public class CodeObjectCreateExpression : CodeExpression
[C++]
public __gc class CodeObjectCreateExpression : public
   CodeExpression
[JScript]
public class CodeObjectCreateExpression extends CodeExpression

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeObjectCreateExpression Members | System.CodeDOM Namespace


CodeObjectCreateExpression Members

Public:

Constructor

CodeObjectCreateExpression Constructor Overloaded. Initializes a new CodeObjectCreateExpression.

Properties

CreateType | The type of the object to create.
Parameters | Gets or sets the parameters to use in creating the object.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeObjectCreateExpression Class | System.CodeDOM Namespace


CodeObjectCreateExpression Constructor

Initializes a new CodeObjectCreateExpression.

Overload List

Initializes a new CodeObjectCreateExpression.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeObjectCreateExpression();
[C++] public: CodeObjectCreateExpression();
[JScript] public function CodeObjectCreateExpression();

Initializes a new CodeObjectCreateExpression using the specified type.

[Visual Basic] Overloads Public Sub New(String)
[C#] public CodeObjectCreateExpression(String);
[C++] public: CodeObjectCreateExpression(String*);
[JScript] public function CodeObjectCreateExpression(String);

Initializes a new CodeObjectCreateExpression using the specified type and parameters.

[Visual Basic] Overloads Public Sub New(String, CodeExpression())
[C#] public CodeObjectCreateExpression(String, CodeExpression[]);
[C++] public: CodeObjectCreateExpression(String*, CodeExpression[]);
[JScript] public function CodeObjectCreateExpression(String, CodeExpression[]);

See Also

CodeObjectCreateExpression Class | CodeObjectCreateExpression Members | System.CodeDOM Namespace


CodeObjectCreateExpression Constructor ()

Initializes a new CodeObjectCreateExpression.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeObjectCreateExpression();
[C++]
public: CodeObjectCreateExpression();
[JScript]
public function CodeObjectCreateExpression();

See Also

CodeObjectCreateExpression Class | CodeObjectCreateExpression Members | System.CodeDOM Namespace | CodeObjectCreateExpression Constructor Overload List


CodeObjectCreateExpression Constructor (String)

Initializes a new CodeObjectCreateExpression using the specified type.

[Visual Basic]
Overloads Public Sub New( _
   ByVal createType As String _
)
[C#]
public CodeObjectCreateExpression(
   string createType
);
[C++]
public: CodeObjectCreateExpression(
   String* createType
);
[JScript]
public function CodeObjectCreateExpression(
   createType : String
);

Parameters

createType
The data type of the object to create.

See Also

CodeObjectCreateExpression Class | CodeObjectCreateExpression Members | System.CodeDOM Namespace | CodeObjectCreateExpression Constructor Overload List


CodeObjectCreateExpression Constructor (String, CodeExpression[])

Initializes a new CodeObjectCreateExpression using the specified type and parameters.

[Visual Basic]
Overloads Public Sub New( _
   ByVal createType As String, _
   ByVal parameters() As CodeExpression _
)
[C#]
public CodeObjectCreateExpression(
   string createType,
   CodeExpression[] parameters
);
[C++]
public: CodeObjectCreateExpression(
   String* createType,
   CodeExpression* parameters[]
);
[JScript]
public function CodeObjectCreateExpression(
   createType : String,
   parameters : CodeExpression[]
);

Parameters

createType
The data type of the object to create.
parameters
[To be supplied.]

See Also

CodeObjectCreateExpression Class | CodeObjectCreateExpression Members | System.CodeDOM Namespace | CodeObjectCreateExpression Constructor Overload List | CodeExpression


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeObjectCreateExpression Properties

The properties of the CodeObjectCreateExpression class are listed below. For a complete list of CodeObjectCreateExpression class members, see the CodeObjectCreateExpression Members topic.

Public:

CreateType | The type of the object to create.
Parameters | Gets or sets the parameters to use in creating the object.

See Also

CodeObjectCreateExpression Class | System.CodeDOM Namespace


CodeObjectCreateExpression.CreateType

The type of the object to create.

[Visual Basic]
Public Property CreateType As String
[C#]
public string CreateType {get; set;}
[C++]
public: __property String* get_CreateType();
public: __property void set_CreateType(String*);
[JScript]
public function get CreateType() : String;
public function set CreateType(String);

Property Value

The type of the object to create.

See Also

CodeObjectCreateExpression Class | CodeObjectCreateExpression Members | System.CodeDOM Namespace


CodeObjectCreateExpression.Parameters

Gets or sets the parameters to use in creating the object.

[Visual Basic]
Public ReadOnly Property Parameters As CodeExpressionCollection
[C#]
public CodeExpressionCollection Parameters {get;}
[C++]
public: __property CodeExpressionCollection* get_Parameters();
[JScript]
public function get Parameters() : CodeExpressionCollection;

Property Value

A CodeExpressionCollection that indicates the parameters to use when creating the object.

See Also

CodeObjectCreateExpression Class | CodeObjectCreateExpression Members | System.CodeDOM Namespace | CodeExpressionCollection


CodeParameterDeclarationExpression Class

Represents a parameter declaration for method, constructor, or property arguments.

Object
CodeExpression
CodeParameterDeclarationExpression

[Visual Basic]
Public Class CodeParameterDeclarationExpression
   Inherits CodeExpression
[C#]
public class CodeParameterDeclarationExpression : CodeExpression
[C++]
public __gc class CodeParameterDeclarationExpression : public
   CodeExpression
[JScript]
public class CodeParameterDeclarationExpression extends
   CodeExpression

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeParameterDeclarationExpression Members | System.CodeDOM Namespace


CodeParameterDeclarationExpression Members

Public:

Constructor

CodeParameterDeclarationExpression Constructor Overloaded. Initializes a new instance of CodeParameterDeclarationExpression.

Properties

CustomAttributes | Gets or sets the custom attributes for the parameter declaration.
Direction | Gets or sets the direction of the field.
Name | Gets or sets the name of the parameter.
Type | Gets or sets the type of the parameter.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeParameterDeclarationExpression Class | System.CodeDOM Namespace


CodeParameterDeclarationExpression Constructor

Initializes a new instance of CodeParameterDeclarationExpression.

Overload List

Initializes a new instance of CodeParameterDeclarationExpression.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeParameterDeclarationExpression();
[C++] public: CodeParameterDeclarationExpression();
[JScript] public function CodeParameterDeclarationExpression();

Initializes a new instance of CodeParameterDeclarationExpression using the specified type and name.

[Visual Basic] Overloads Public Sub New(String, String)
[C#] public CodeParameterDeclarationExpression(String, String);
[C++] public: CodeParameterDeclarationExpression(String*, String*);
[JScript] public function CodeParameterDeclarationExpression(String, String);

See Also

CodeParameterDeclarationExpression Class | CodeParameterDeclarationExpression Members | System.CodeDOM Namespace


CodeParameterDeclarationExpression Constructor ()

Initializes a new instance of CodeParameterDeclarationExpression.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeParameterDeclarationExpression();
[C++]
public: CodeParameterDeclarationExpression();
[JScript]
public function CodeParameterDeclarationExpression();

See Also

CodeParameterDeclarationExpression Class | CodeParameterDeclarationExpression Members | System.CodeDOM Namespace | CodeParameterDeclarationExpression Constructor Overload List


CodeParameterDeclarationExpression Constructor (String, String)

Initializes a new instance of CodeParameterDeclarationExpression using the specified type and name.

[Visual Basic]
Overloads Public Sub New( _
   ByVal type As String, _
   ByVal name As String _
)
[C#]
public CodeParameterDeclarationExpression(
   string type,
   string name
);
[C++]
public: CodeParameterDeclarationExpression(
   String* type,
   String* name
);
[JScript]
public function CodeParameterDeclarationExpression(
   type : String,
   name : String
);

Parameters

type
The type of the parameter to declare.
name
[To be supplied.]

See Also

CodeParameterDeclarationExpression Class | CodeParameterDeclarationExpression Members | System.CodeDOM Namespace | CodeParameterDeclarationExpression Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeParameterDeclarationExpression Properties

The properties of the CodeParameterDeclarationExpression class are listed below. For a complete list of CodeParameterDeclarationExpression class members, see the CodeParameterDeclarationExpression Members topic.

Public:

CustomAttributes | Gets or sets the custom attributes for the parameter declaration.
Direction | Gets or sets the direction of the field.
Name | Gets or sets the name of the parameter.
Type | Gets or sets the type of the parameter.

See Also

CodeParameterDeclarationExpression Class | System.CodeDOM Namespace


CodeParameterDeclarationExpression.CustomAttributes

Gets or sets the custom attributes for the parameter declaration.

[Visual Basic]
Public Property CustomAttributes As CodeAttributeBlock
[C#]
public CodeAttributeB CustomAttributes {get; set;}
[C++]
public: __property CodeAttributeBlock* get_CustomAttributes();
public: __property void set_CustomAttributes(CodeAttributeBlock*);
[JScript]
public function get CustomAttributes() : CodeAttributeBlock;
public function set CustomAttributes(CodeAttributeBlock);

Property Value

A CodeAttributeBlock indicating the custom attributes.

See Also

CodeParameterDeclarationExpression Class | CodeParameterDeclarationExpression Members | System.CodeDOM Namespace | CodeAttributeBlock


CodeParameterDeclarationExpression.Direction

Gets or sets the direction of the field.

[Visual Basic]
Public Property Direction As FieldDirection
[C#]
public FieldDirection Direction {get; set;}
[C++]
public: __property FieldDirection get_Direction();
public: __property void set_Direction(FieldDirection);
[JScript]
public function get Direction() : FieldDirection;
public function set Direction(FieldDirection);

Property Value

A FieldDirection indicating the direction of the field.

See Also

CodeParameterDeclarationExpression Class | CodeParameterDeclarationExpression Members | System.CodeDOM Namespace | FieldDirection


CodeParameterDeclarationExpression.Name

Gets or sets the name of the parameter.

[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}
[C++]
public: __property String* get_Name();
public: __property void set_Name(String*);
[JScript]
public function get Name() : String;
public function set Name(String);

Property Value

The name of the parameter.

See Also

CodeParameterDeclarationExpression Class | CodeParameterDeclarationExpression Members | System.CodeDOM Namespace


CodeParameterDeclarationExpression.Type

Gets or sets the type of the parameter.

[Visual Basic]
Public Property Type As String
[C#]
public string Type {get; set;}
[C++]
public: __property String* get_Type();
public: __property void set_Type(String*);
[JScript]
public function get Type() : String;
public function set Type(String);

Property Value

The type of the parameter.

See Also

CodeParameterDeclarationExpression Class | CodeParameterDeclarationExpression Members | System.CodeDOM Namespace


CodeParameterDeclarationExpressionCollection Class

Manages a collection of CodeParameterDeclarationExpression objects

Object
CodeParameterDeclarationExpressionCollection

[Visual Basic]
Public Class CodeParameterDeclarationExpressionCollection
   Implements IList, ICollection, IEnumerable
[C#]
public class CodeParameterDeclarationExpressionCollection : IList,
   ICollection, IEnumerable
[C++]
public __gc class CodeParameterDeclarationExpressionCollection :
   public IList, ICollection, IEnumerable
[JScript]
public class CodeParameterDeclarationExpressionCollection
   implements IList, ICollection, IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeParameterDeclarationExpressionCollection Members | System.CodeDOM Namespace | CodeParameterDeclarationExpression


CodeParameterDeclarationExpressionCollection Members

Public:

Constructor

CodeParameterDeclarationExpressionCollection Constructor [To be supplied.]

Properties

Count | Gets or sets the number of objects in the collection.
Item | Indexer method to access objects in the collection. In C#, this member is the indexer for the CodeParameterDeclarationExpressionCollection class.

Methods

Add | Adds a CodeParameterDeclarationExpression to the collection.
AddRange | Adds a set of CodeParameterDeclarationExpression objects to the collection.
Clear | Clears the collection of members.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Gets an enumerator that enumerates the collection members.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeParameterDeclarationExpressionCollection Class | System.CodeDOM Namespace


CodeParameterDeclarationExpressionCollection Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CodeParameterDeclarationExpressionCollection();
[C++]
public: CodeParameterDeclarationExpressionCollection();
[JScript]
public function CodeParameterDeclarationExpressionCollection();

See Also

CodeParameterDeclarationExpressionCollection Class | CodeParameterDeclarationExpressionCollection Members | System.CodeDOM Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeParameterDeclarationExpressionCollection Properties

The properties of the CodeParameterDeclarationExpressionCollection class are listed below. For a complete list of CodeParameterDeclarationExpressionCollection class members, see the CodeParameterDeclarationExpressionCollection Members topic.

Public:

Count | Gets or sets the number of objects in the collection.
Item | Indexer method to access objects in the collection. In C#, this member is the indexer for the CodeParameterDeclarationExpressionCollection class.

See Also

CodeParameterDeclarationExpressionCollection Class | System.CodeDOM Namespace


CodeParameterDeclarationExpressionCollection.Count

Gets or sets the number of objects in the collection.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

Property Value

The number of objects in the collection.

See Also

CodeParameterDeclarationExpressionCollection Class | CodeParameterDeclarationExpressionCollection Members | System.CodeDOM Namespace


CodeParameterDeclarationExpressionCollection.Item

Indexer method to access objects in the collection.

[C#] In C#, this member is the indexer for the CodeParameterDeclarationExpressionCollection class.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As CodeParameterDeclarationExpression
[C#]
public CodeParameterDeclarationExpression this[
   int index
] {get; set;}
[C++]
public: __property CodeParameterDeclarationExpression* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   CodeParameterDeclarationExpression*
);
[JScript]
returnValue = CodeParameterDeclarationExpressionCollectionObject.Item(index);
CodeParameterDeclarationExpressionCollectionObject.Item(index) = returnValue;
-or-
returnValue = CodeParameterDeclarationExpressionCollectionObject(index);
CodeParameterDeclarationExpressionCollectionObject(index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
[To be supplied.]

Parameters [Visual Basic, C#, C++]

index
[To be supplied.]

Property Value

The CodeParameterDeclarationExpression at the specified index in the collection.

See Also

CodeParameterDeclarationExpressionCollection Class | CodeParameterDeclarationExpressionCollection Members | System.CodeDOM Namespace | CodeParameterDeclarationExpression


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeParameterDeclarationExpressionCollection Methods

The methods of the CodeParameterDeclarationExpressionCollection class are listed below. For a complete list of CodeParameterDeclarationExpressionCollection class members, see the CodeParameterDeclarationExpressionCollection Members topic.

Public:

Add | Adds a CodeParameterDeclarationExpression to the collection.
AddRange | Adds a set of CodeParameterDeclarationExpression objects to the collection.
Clear | Clears the collection of members.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Gets an enumerator that enumerates the collection members.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeParameterDeclarationExpressionCollection Class | System.CodeDOM Namespace


CodeParameterDeclarationExpressionCollection.Add

Adds a CodeParameterDeclarationExpression to the collection.

[Visual Basic]
Public Sub Add( _
   ByVal value As CodeParameterDeclarationExpression _
)
[C#]
public void Add(
   CodeParameterDeclarationExpression value
);
[C++]
public: void Add(
   CodeParameterDeclarationExpression* value
);
[JScript]
public function Add(
   value : CodeParameterDeclarationExpression
);

Parameters

value
The CodeParameterDeclarationExpression to add to the collection

See Also

CodeParameterDeclarationExpressionCollection Class | CodeParameterDeclarationExpressionCollection Members | System.CodeDOM Namespace | CodeParameterDeclarationExpression


CodeParameterDeclarationExpressionCollection.AddRange

Adds a set of CodeParameterDeclarationExpression objects to the collection.

[Visual Basic]
Public Sub AddRange( _
   ByVal value() As CodeParameterDeclarationExpression _
)
[C#]
public void AddRange(
   CodeParameterDeclarationExpression[] value
);
[C++]
public: void AddRange(
   CodeParameterDeclarationExpression* value[]
);
[JScript]
public function AddRange(
   value : CodeParameterDeclarationExpression[]
);

Parameters

value
An array of type CodeParameterDeclarationExpression to add to the collection.

See Also

CodeParameterDeclarationExpressionCollection Class | CodeParameterDeclarationExpressionCollection Members | System.CodeDOM Namespace | CodeParameterDeclarationExpression


CodeParameterDeclarationExpressionCollection.Clear

Clears the collection of members.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[JScript]
public function Clear();

See Also

CodeParameterDeclarationExpressionCollection Class | CodeParameterDeclarationExpressionCollection Members | System.CodeDOM Namespace


CodeParameterDeclarationExpressionCollection.GetEnumerator

Gets an enumerator that enumerates the collection members.

[Visual Basic]
Public Function GetEnumerator() As IEnumerator
[C#]
public IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

Return Value

An IEnumerator that indicates the collection members.

See Also

CodeParameterDeclarationExpressionCollection Class | CodeParameterDeclarationExpressionCollection Members | System.CodeDOM Namespace | IEnumerator


CodePrimitiveExpression Class

Represents a primitive value.

Object
CodeExpression
CodePrimitiveExpression

[Visual Basic]
Public Class CodePrimitiveExpression
   Inherits CodeExpression
[C#]
public class CodePrimitiveExpression : CodeExpression
[C++]
public __gc class CodePrimitiveExpression : public CodeExpression
[JScript]
public class CodePrimitiveExpression extends CodeExpression

Remarks

Any NGWS runtime primitive type can be placed in here directly.

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodePrimitiveExpression Members | System.CodeDOM Namespace


CodePrimitiveExpression Members

Public:

Constructor

CodePrimitiveExpression Constructor Overloaded. Initializes a new instance of CodePrimitiveExpression.

Properties

Value Gets or sets the object to represent.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodePrimitiveExpression Class | System.CodeDOM Namespace


CodePrimitiveExpression Constructor

Initializes a new instance of CodePrimitiveExpression.

Overload List

Initializes a new instance of CodePrimitiveExpression.

[Visual Basic] Overloads Public Sub New()
[C#] public CodePrimitiveExpression();
[C++] public: CodePrimitiveExpression();
[JScript] public function CodePrimitiveExpression();

Initializes a new instance of CodePrimitiveExpression using the specified object.

[Visual Basic] Overloads Public Sub New(Object)
[C#] public CodePrimitiveExpression(Object);
[C++] public: CodePrimitiveExpression(Object*);
[JScript] public function CodePrimitiveExpression(Object);

See Also

CodePrimitiveExpression Class | CodePrimitiveExpression Members | System.CodeDOM Namespace


CodePrimitiveExpression Constructor ()

Initializes a new instance of CodePrimitiveExpression.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodePrimitiveExpression();
[C++]
public: CodePrimitiveExpression();
[JScript]
public function CodePrimitiveExpression();

See Also

CodePrimitiveExpression Class | CodePrimitiveExpression Members | System.CodeDOM Namespace | CodePrimitiveExpression Constructor Overload List


CodePrimitiveExpression Constructor (Object)

Initializes a new instance of CodePrimitiveExpression using the specified object.

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As Object _
)
[C#]
public CodePrimitiveExpression(
   object value
);
[C++]
public: CodePrimitiveExpression(
   Object* value
);
[JScript]
public function CodePrimitiveExpression(
   value : Object
);

Parameters

value
The object to represent.

See Also

CodePrimitiveExpression Class | CodePrimitiveExpression Members | System.CodeDOM Namespace | CodePrimitiveExpression Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodePrimitiveExpression Properties

The properties of the CodePrimitiveExpression class are listed below. For a complete list of CodePrimitiveExpression class members, see the CodePrimitiveExpression Members topic.

Public:

Value Gets or sets the object to represent.

See Also

CodePrimitiveExpression Class | System.CodeDOM Namespace


CodePrimitiveExpression.Value

Gets or sets the object to represent.

[Visual Basic]
Public Property Value As Object
[C#]
public object Value {get; set;}
[C++]
public: __property Object* get_Value();
public: __property void set_Value(Object*);
[JScript]
public function get Value() : Object;
public function set Value(Object);

Property Value

The object to represent.

See Also

CodePrimitiveExpression Class | CodePrimitiveExpression Members | System.CodeDOM Namespace


CodePropertyReferenceExpression Class

Represents a reference to a property.

Object
CodeExpression
CodePropertyReferenceExpression

[Visual Basic]
Public Class CodePropertyReferenceExpression
   Inherits CodeExpression
[C#]
public class CodePropertyReferenceExpression : CodeExpression
[C++]
public __gc class CodePropertyReferenceExpression : public
   CodeExpression
[JScript]
public class CodePropertyReferenceExpression extends CodeExpression

Remarks

This doesn't imply get or set, rather a reference. If the property reference is on the left side of an assignment, then it is a set.

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodePropertyReferenceExpression Members | System.CodeDOM Namespace


CodePropertyReferenceExpression Members

Public:

Constructor

CodePropertyReferenceExpression Constructor Overloaded. Initializes a new instance of CodePropertyReferenceExpression.

Properties

PropertyName | The name of the property to reference.
TargetObject | The target object containing the property this CodePropertyReferenceExpression references.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodePropertyReferenceExpression Class | System.CodeDOM Namespace


CodePropertyReferenceExpression Constructor

Initializes a new instance of CodePropertyReferenceExpression.

Overload List

Initializes a new instance of CodePropertyReferenceExpression.

[Visual Basic] Overloads Public Sub New()
[C#] public CodePropertyReferenceExpression();
[C++] public: CodePropertyReferenceExpression();
[JScript] public function CodePropertyReferenceExpression();

Initializes a new instance of CodePropertyReferenceExpression using the specified target object and property name.

[Visual Basic] Overloads Public Sub New(CodeExpression, String)
[C#] public CodePropertyReferenceExpression(CodeExpression, String);
[C++] public: CodePropertyReferenceExpression(CodeExpression*, String);
[JScript] public function CodePropertyReferenceExpression(CodeExpression, String);

See Also

CodePropertyReferenceExpression Class | CodePropertyReferenceExpression Members | System.CodeDOM Namespace


CodePropertyReferenceExpression Constructor ()

Initializes a new instance of CodePropertyReferenceExpression.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodePropertyReferenceExpression();
[C++]
public: CodePropertyReferenceExpression();
[JScript]
public function CodePropertyReferenceExpression();

See Also

CodePropertyReferenceExpression Class | CodePropertyReferenceExpression Members | System.CodeDOM Namespace | CodePropertyReferenceExpression Constructor Overload List


CodePropertyReferenceExpression Constructor (CodeExpression, String)

Initializes a new instance of CodePropertyReferenceExpression using the specified target object and property name.

[Visual Basic]
Overloads Public Sub New( _
   ByVal targetObject As CodeExpression, _
   ByVal propertyName As String _
)
[C#]
public CodePropertyReferenceExpression(
   CodeExpression targetObject,
   string propertyName
);
[C++]
public: CodePropertyReferenceExpression(
   CodeExpression* targetObject,
   String* propertyName
);
[JScript]
public function CodePropertyReferenceExpression(
   targetObject : CodeExpression,
   propertyName : String
);

Parameters

targetObject
The object to reference the property of.
propertyName
[To be supplied.]

See Also

CodePropertyReferenceExpression Class | CodePropertyReferenceExpression Members | System.CodeDOM Namespace | CodePropertyReferenceExpression Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodePropertyReferenceExpression Properties

The properties of the CodePropertyReferenceExpression class are listed below. For a complete list of CodePropertyReferenceExpression class members, see the CodePropertyReferenceExpression Members topic.

Public:

PropertyName | The name of the property to reference.
TargetObject | The target object containing the property this CodePropertyReferenceExpression references.

See Also

CodePropertyReferenceExpression Class | System.CodeDOM Namespace


CodePropertyReferenceExpression.PropertyName

The name of the property to reference.

[Visual Basic]
Public Property PropertyName As String
[C#]
public string PropertyName {get; set;}
[C++]
public: __property String* get_PropertyName();
public: __property void set_PropertyName(String*);
[JScript]
public function get PropertyName() : String;
public function set PropertyName(String);

Property Value

The name of the property to reference.

See Also

CodePropertyReferenceExpression Class | CodePropertyReferenceExpression Members | System.CodeDOM Namespace


CodePropertyReferenceExpression.TargetObject

The target object containing the property this CodePropertyReferenceExpression references.

[Visual Basic]
Public Property TargetObject As CodeExpression
[C#]
public CodeExpression TargetObject {get; set;}
[C++]
public: __property CodeExpression* get_TargetObject();
public: __property void set_TargetObject(CodeExpression*);
[JScript]
public function get TargetObject() : CodeExpression;
public function set TargetObject(CodeExpression);

Property Value

A CodeExpression that indicates the target object.

See Also

CodePropertyReferenceExpression Class | CodePropertyReferenceExpression Members | System.CodeDOM Namespace | CodeExpression


CodeStatement Class

Represents a statement. Base class for statements in the CodeDOM model.

Object
CodeStatement

[Visual Basic]
Public Class CodeStatement
[C#]
public class CodeStatement
[C++]
public __gc class CodeStatement
[JScript]
public class CodeStatement

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeStatement Members | System.CodeDOM Namespace


CodeStatement Members

Public:

Constructor

CodeStatement Constructor [To be supplied.]

Properties

LinePragma The line the statement occurs on.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeStatement Class | System.CodeDOM Namespace


CodeStatement Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CodeStatement();
[C++]
public: CodeStatement();
[JScript]
public function CodeStatement();

See Also

CodeStatement Class | CodeStatement Members | System.CodeDOM Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeStatement Properties

The properties of the CodeStatement class are listed below. For a complete list of CodeStatement class members, see the CodeStatement Members topic.

Public:

LinePragma The line the statement occurs on.

See Also

CodeStatement Class | System.CodeDOM Namespace


CodeStatement.LinePragma

The line the statement occurs on.

[Visual Basic]
Public Property LinePragma As CodeLinePragma
[C#]
public CodeLinePragma LinePragma {get; set;}
[C++]
public: __property CodeLinePragma* get_LinePragma();
public: __property void set_LinePragma(CodeLinePragma*);
[JScript]
public function get LinePragma() : CodeLinePragma;
public function set LinePragma(CodeLinePragma);

Property Value

A CodeLinePragma that indicates the context of the statement.

See Also

CodeStatement Class | CodeStatement Members | System.CodeDOM Namespace | CodeLinePragma


CodeStatementCollection Class

Manages a collection of CodeStatement objects.

Object
CodeStatementCollection

[Visual Basic]
Public Class CodeStatementCollection
   Implements IList, ICollection, IEnumerable
[C#]
public class CodeStatementCollection : IList, ICollection,
   IEnumerable
[C++]
public __gc class CodeStatementCollection : public IList,
   ICollection, IEnumerable
[JScript]
public class CodeStatementCollection implements IList, ICollection,
   IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeStatementCollection Members | System.CodeDOM Namespace | CodeStatement


CodeStatementCollection Members

Public:

Constructor

CodeStatementCollection Constructor [To be supplied.]

Properties

Count | Gets or sets the number of objects in the collection.
Item | Indexer method to access collection objects. In C#, this member is the indexer for the CodeStatementCollection class.

Methods

Add | Adds the specified CodeStatement to the collection.
AddRange | Adds a set of CodeStatement objects to the collection.
Clear | Clears the collection of members.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Gets an enumerator to enumerate the collection members.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeStatementCollection Class | System.CodeDOM Namespace


CodeStatementCollection Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CodeStatementCollection();
[C++]
public: CodeStatementCollection();
[JScript]
public function CodeStatementCollection();

See Also

CodeStatementCollection Class | CodeStatementCollection Members | System.CodeDOM Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeStatementCollection Properties

The properties of the CodeStatementCollection class are listed below. For a complete list of CodeStatementCollection class members, see the CodeStatementCollection Members topic.

Public:

Count | Gets or sets the number of objects in the collection.
Item | Indexer method to access collection objects. In C#, this member is the indexer for the CodeStatementCollection class.

See Also

CodeStatementCollection Class | System.CodeDOM Namespace


CodeStatementCollection.Count

Gets or sets the number of objects in the collection.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

Property Value

The number of objects in the collection.

See Also

CodeStatementCollection Class | CodeStatementCollection Members | System.CodeDOM Namespace


CodeStatementCollection.Item

Indexer method to access collection objects.

[C#] In C#, this member is the indexer for the CodeStatementCollection class.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As CodeStatement
[C#]
public CodeStatement this[
   int index
] {get; set;}
[C++]
public: __property CodeStatement* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   CodeStatement*
);
[JScript]
returnValue = CodeStatementCollectionObject.Item(index);
CodeStatementCollectionObject.Item(index) = returnValue;
-or-
returnValue = CodeStatementCollectionObject(index);
CodeStatementCollectionObject(index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
The index to retrieve.

Parameters [Visual Basic, C#, C++]

index
The index to retrieve.

See Also

CodeStatementCollection Class | CodeStatementCollection Members | System.CodeDOM Namespace | CodeStatement


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeStatementCollection Methods

The methods of the CodeStatementCollection class are listed below. For a complete list of CodeStatementCollection class members, see the CodeStatementCollection Members topic.

Public:

Add | Adds the specified CodeStatement to the collection.
AddRange | Adds a set of CodeStatement objects to the collection.
Clear | Clears the collection of members.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Gets an enumerator to enumerate the collection members.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeStatementCollection Class | System.CodeDOM Namespace


CodeStatementCollection.Add

Adds the specified CodeStatement to the collection.

[Visual Basic]
Public Sub Add( _
   ByVal value As CodeStatement _
)
[C#]
public void Add(
   CodeStatement value
);
[C++]
public: void Add(
   CodeStatement* value
);
[JScript]
public function Add(
   value : CodeStatement
);

Parameters

value
[To be supplied.]

See Also

CodeStatementCollection Class | CodeStatementCollection Members | System.CodeDOM Namespace | CodeStatement


CodeStatementCollection.AddRange

Adds a set of CodeStatement objects to the collection.

[Visual Basic]
Public Sub AddRange( _
   ByVal value() As CodeStatement _
)
[C#]
public void AddRange(
   CodeStatement[] value
);
[C++]
public: void AddRange(
   CodeStatement* value[]
);
[JScript]
public function AddRange(
   value : CodeStatement[]
);

Parameters

value
An array of type CodeStatement to add to the collection.

See Also

CodeStatementCollection Class | CodeStatementCollection Members | System.CodeDOM Namespace | CodeStatement


CodeStatementCollection.Clear

Clears the collection of members.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[JScript]
public function Clear();

See Also

CodeStatementCollection Class | CodeStatementCollection Members | System.CodeDOM Namespace


CodeStatementCollection.GetEnumerator

Gets an enumerator to enumerate the collection members.

[Visual Basic]
Public Function GetEnumerator() As IEnumerator
[C#]
public IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

Return Value

An IEnumerator that indicates the members of the collection.

See Also

CodeStatementCollection Class | CodeStatementCollection Members | System.CodeDOM Namespace | IEnumerator


CodeThisReferenceExpression Class

Represents a current instance reference. (the class object that is referenced by "this" or "me".)

Object
CodeExpression
CodeThisReferenceExpression

[Visual Basic]
Public Class CodeThisReferenceExpression
   Inherits CodeExpression
[C#]
public class CodeThisReferenceExpression : CodeExpression
[C++]
public __gc class CodeThisReferenceExpression : public
   CodeExpression
[JScript]
public class CodeThisReferenceExpression extends CodeExpression

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeThisReferenceExpression Members | System.CodeDOM Namespace


CodeThisReferenceExpression Members

Public:

Constructor

CodeThisReferenceExpression Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeThisReferenceExpression Class | System.CodeDOM Namespace


CodeThisReferenceExpression Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CodeThisReferenceExpression();
[C++]
public: CodeThisReferenceExpression();
[JScript]
public function CodeThisReferenceExpression();

See Also

CodeThisReferenceExpression Class | CodeThisReferenceExpression Members | System.CodeDOM Namespace


CodeThrowExceptionStatement Class

Represents a statement that throws an exception.

Object
CodeStatement
CodeThrowExceptionStatement

[Visual Basic]
Public Class CodeThrowExceptionStatement
   Inherits CodeStatement
[C#]
public class CodeThrowExceptionStatement : CodeStatement
[C++]
public __gc class CodeThrowExceptionStatement : public
   CodeStatement
[JScript]
public class CodeThrowExceptionStatement extends CodeStatement

Remarks

The expression should evaulate out to an instance reference to something deriving from System.Exception.

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeThrowExceptionStatement Members | System.CodeDOM Namespace


CodeThrowExceptionStatement Members

Public:

Constructor

CodeThrowExceptionStatement Constructor Overloaded. Initializes a new instance of CodeThrowExceptionStatement.

Properties

LinePragma (inherited from CodeStatement) | The line the statement occurs on.
ToThrow | Gets or sets the expression to throw.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeThrowExceptionStatement Class | System.CodeDOM Namespace


CodeThrowExceptionStatement Constructor

Initializes a new instance of CodeThrowExceptionStatement.

Overload List

Initializes a new instance of CodeThrowExceptionStatement.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeThrowExceptionStatement();
[C++] public: CodeThrowExceptionStatement();
[JScript] public function CodeThrowExceptionStatement();

Initializes a new instance of CodeThrowExceptionStatement using the specified statement.

[Visual Basic] Overloads Public Sub New(CodeExpression)
[C#] public CodeThrowExceptionStatement(CodeExpression);
[C++] public: CodeThrowExceptionStatement(CodeExpression*);
[JScript] public function CodeThrowExceptionStatement(CodeExpression);

See Also

CodeThrowExceptionStatement Class | CodeThrowExceptionStatement Members | System.CodeDOM Namespace


CodeThrowExceptionStatement Constructor ()

Initializes a new instance of CodeThrowExceptionStatement.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeThrowExceptionStatement();
[C++]
public: CodeThrowExceptionStatement();
[JScript]
public function CodeThrowExceptionStatement();

See Also

CodeThrowExceptionStatement Class | CodeThrowExceptionStatement Members | System.CodeDOM Namespace | CodeThrowExceptionStatement Constructor Overload List


CodeThrowExceptionStatement Constructor (CodeExpression)

Initializes a new instance of CodeThrowExceptionStatement using the specified statement.

[Visual Basic]
Overloads Public Sub New( _
   ByVal toThrow As CodeExpression _
)
[C#]
public CodeThrowExceptionStatement(
   CodeExpression toThrow
);
[C++]
public: CodeThrowExceptionStatement(
   CodeExpression* toThrow
);
[JScript]
public function CodeThrowExceptionStatement(
   toThrow : CodeExpression
);

Parameters

toThrow
A CodeExpression indicating the exception to throw.

See Also

CodeThrowExceptionStatement Class | CodeThrowExceptionStatement Members | System.CodeDOM Namespace | CodeThrowExceptionStatement Constructor Overload List | CodeExpression


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeThrowExceptionStatement Properties

The properties of the CodeThrowExceptionStatement class are listed below. For a complete list of CodeThrowExceptionStatement class members, see the CodeThrowExceptionStatement Members topic.

Public:

LinePragma (inherited from CodeStatement) | The line the statement occurs on.
ToThrow | Gets or sets the expression to throw.

See Also

CodeThrowExceptionStatement Class | System.CodeDOM Namespace


CodeThrowExceptionStatement.ToThrow

Gets or sets the expression to throw.

[Visual Basic]
Public Property ToThrow As CodeExpression
[C#]
public CodeExpression ToThrow {get; set;}
[C++]
public: __property CodeExpression* get_ToThrow();
public: __property void set_ToThrow(CodeExpression*);
[JScript]
public function get ToThrow() : CodeExpression;
public function set ToThrow(CodeExpression);

Property Value

A CodeExpression indicating the expression to throw.

See Also

CodeThrowExceptionStatement Class | CodeThrowExceptionStatement Members | System.CodeDOM Namespace | CodeExpression


CodeTryCatchFinallyStatement Class

Represents a try block, with any number of catch clauses and an optionally finally block.

Object
CodeStatement
CodeTryCatchFinallyStatement

[Visual Basic]
Public Class CodeTryCatchFinallyStatement
   Inherits CodeStatement
[C#]
public class CodeTryCatchFinallyStatement : CodeStatement
[C++]
public __gc class CodeTryCatchFinallyStatement : public
   CodeStatement
[JScript]
public class CodeTryCatchFinallyStatement extends CodeStatement

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeTryCatchFinallyStatement Members | System.CodeDOM Namespace


CodeTryCatchFinallyStatement Members

Public:

Constructor

CodeTryCatchFinallyStatement Constructor Overloaded. Initializes a new instance of CodeTryCatchFinallyStatement.

Properties

CatchClauses | Gets or sets the catch clauses to use.
FinallyStatements | Gets or sets the finally statements to use.
LinePragma (inherited from CodeStatement) | The line the statement occurs on.
TryStatements | Gets or sets the try statements to try.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeTryCatchFinallyStatement Class | System.CodeDOM Namespace


CodeTryCatchFinallyStatement Constructor

Initializes a new instance of CodeTryCatchFinallyStatement.

Overload List

Initializes a new instance of CodeTryCatchFinallyStatement.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeTryCatchFinallyStatement();
[C++] public: CodeTryCatchFinallyStatement();
[JScript] public function CodeTryCatchFinallyStatement();

Initializes a new instance of CodeTryCatchFinallyStatement. using the specified statements to try and catch clauses.

[Visual Basic] Overloads Public Sub New(CodeStatement(), CodeCatchClause())
[C#] public CodeTryCatchFinallyStatement(CodeStatement[], CodeCatchClause[]);
[C++] public: CodeTryCatchFinallyStatement(CodeStatement*[], CodeCatchClause[]);
[JScript] public function CodeTryCatchFinallyStatement(CodeStatement[], CodeCatchClause[]);

Initializes a new instance of CodeTryCatchFinallyStatement. using the specified statements to try, catch clauses, and finally statements.

[Visual Basic] Overloads Public Sub New(CodeStatement(), CodeCatchClause(), CodeStatement())
[C#] public CodeTryCatchFinallyStatement(CodeStatement[], CodeCatchClause[], CodeStatement[]);
[C++] public: CodeTryCatchFinallyStatement(CodeStatement*[], CodeCatchClause[], CodeStatement*[]);
[JScript] public function CodeTryCatchFinallyStatement(CodeStatement[], CodeCatchClause[], CodeStatement[]);

See Also

CodeTryCatchFinallyStatement Class | CodeTryCatchFinallyStatement Members | System.CodeDOM Namespace


CodeTryCatchFinallyStatement Constructor ()

Initializes a new instance of CodeTryCatchFinallyStatement.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeTryCatchFinallyStatement();
[C++]
public: CodeTryCatchFinallyStatement();
[JScript]
public function CodeTryCatchFinallyStatement();

See Also

CodeTryCatchFinallyStatement Class | CodeTryCatchFinallyStatement Members | System.CodeDOM Namespace | CodeTryCatchFinallyStatement Constructor Overload List


CodeTryCatchFinallyStatement Constructor (CodeStatement[], CodeCatchClause[])

Initializes a new instance of CodeTryCatchFinallyStatement. using the specified statements to try and catch clauses.

[Visual Basic]
Overloads Public Sub New( _
   ByVal tryStatements() As CodeStatement, _
   ByVal catchClauses() As CodeCatchClause _
)
[C#]
public CodeTryCatchFinallyStatement(
   CodeStatement[] tryStatements,
   CodeCatchClause[] catchClauses
);
[C++]
public: CodeTryCatchFinallyStatement(
   CodeStatement* tryStatements[],
   CodeCatchClause* catchClauses[]
);
[JScript]
public function CodeTryCatchFinallyStatement(
   tryStatements : CodeStatement[],
   catchClauses : CodeCatchClause[]
);

Parameters

tryStatements
The statements to try.
catchClauses
[To be supplied.]

See Also

CodeTryCatchFinallyStatement Class | CodeTryCatchFinallyStatement Members | System.CodeDOM Namespace | CodeTryCatchFinallyStatement Constructor Overload List


CodeTryCatchFinallyStatement Constructor (CodeStatement[], CodeCatchClause[], CodeStatement[])

Initializes a new instance of CodeTryCatchFinallyStatement. using the specified statements to try, catch clauses, and finally statements.

[Visual Basic]
Overloads Public Sub New( _
   ByVal tryStatements() As CodeStatement, _
   ByVal catchClauses() As CodeCatchClause, _
   ByVal finallyStatements() As CodeStatement _
)
[C#]
public CodeTryCatchFinallyStatement(
   CodeStatement[] tryStatements,
   CodeCatchClause[] catchClauses,
   CodeStatement[] finallyStatements
);
[C++]
public: CodeTryCatchFinallyStatement(
   CodeStatement* tryStatements[],
   CodeCatchClause* catchClauses[],
   CodeStatement* finallyStatements[]
);
[JScript]
public function CodeTryCatchFinallyStatement(
   tryStatements : CodeStatement[],
   catchClauses : CodeCatchClause[],
   finallyStatements : CodeStatement[]
);

Parameters

tryStatements
The statements to try.
catchClauses
[To be supplied.]
finallyStatements
[To be supplied.]

See Also

CodeTryCatchFinallyStatement Class | CodeTryCatchFinallyStatement Members | System.CodeDOM Namespace | CodeTryCatchFinallyStatement Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeTryCatchFinallyStatement Properties

The properties of the CodeTryCatchFinallyStatement class are listed below. For a complete list of CodeTryCatchFinallyStatement class members, see the CodeTryCatchFinallyStatement Members topic.

Public:

CatchClauses | Gets or sets the catch clauses to use.
FinallyStatements | Gets or sets the finally statements to use.
LinePragma (inherited from CodeStatement) | The line the statement occurs on.
TryStatements | Gets or sets the try statements to try.

See Also

CodeTryCatchFinallyStatement Class | System.CodeDOM Namespace


CodeTryCatchFinallyStatement.CatchClauses

Gets or sets the catch clauses to use.

[Visual Basic]
Public ReadOnly Property CatchClauses As CodeCatchClauseCollection
[C#]
public CodeCatchClauseCollection CatchClauses {get;}
[C++]
public: __property CodeCatchClauseCollection* get_CatchClauses();
[JScript]
public function get CatchClauses() : CodeCatchClauseCollection;

Property Value

A CodeCatchClauseCollection indicating the catch clauses to use.

See Also

CodeTryCatchFinallyStatement Class | CodeTryCatchFinallyStatement Members | System.CodeDOM Namespace | CodeCatchClauseCollection


CodeTryCatchFinallyStatement.FinallyStatements

Gets or sets the finally statements to use.

[Visual Basic]
Public ReadOnly Property FinallyStatements As _
   CodeStatementCollection
[C#]
public CodeStatementCollection FinallyStatements {get;}
[C++]
public: __property CodeStatementCollection* get_FinallyStatements();
[JScript]
public function get FinallyStatements() : CodeStatementCollection;

Property Value

A CodeStatementCollection indicating the finally statements.

See Also

CodeTryCatchFinallyStatement Class | CodeTryCatchFinallyStatement Members | System.CodeDOM Namespace | CodeStatementCollection


CodeTryCatchFinallyStatement.TryStatements

Gets or sets the try statements to try.

[Visual Basic]
Public ReadOnly Property TryStatements As CodeStatementCollection
[C#]
public CodeStatementCollection TryStatements {get;}
[C++]
public: __property CodeStatementCollection* get_TryStatements();
[JScript]
public function get TryStatements() : CodeStatementCollection;

Property Value

A CodeStatementCollection indicating the statements to try.

See Also

CodeTryCatchFinallyStatement Class | CodeTryCatchFinallyStatement Members | System.CodeDOM Namespace | CodeStatementCollection


CodeTypeOfExpression Class

Represents a TypeOf expression.

Object
CodeExpression
CodeTypeOfExpression

[Visual Basic]
Public Class CodeTypeOfExpression
   Inherits CodeExpression
[C#]
public class CodeTypeOfExpression : CodeExpression
[C++]
public __gc class CodeTypeOfExpression : public CodeExpression
[JScript]
public class CodeTypeOfExpression extends CodeExpression

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeTypeOfExpression Members | System.CodeDOM Namespace


CodeTypeOfExpression Members

Public:

Constructor

CodeTypeOfExpression Constructor Overloaded. Initializes a new instance of CodeTypeOfExpression.

Properties

Type Gets or sets the data type.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeTypeOfExpression Class | System.CodeDOM Namespace


CodeTypeOfExpression Constructor

Initializes a new instance of CodeTypeOfExpression.

Overload List

Initializes a new instance of CodeTypeOfExpression.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeTypeOfExpression();
[C++] public: CodeTypeOfExpression();
[JScript] public function CodeTypeOfExpression();

Initializes a new instance of CodeTypeOfExpression.

[Visual Basic] Overloads Public Sub New(String)
[C#] public CodeTypeOfExpression(String);
[C++] public: CodeTypeOfExpression(String*);
[JScript] public function CodeTypeOfExpression(String);

See Also

CodeTypeOfExpression Class | CodeTypeOfExpression Members | System.CodeDOM Namespace


CodeTypeOfExpression Constructor ()

Initializes a new instance of CodeTypeOfExpression.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeTypeOfExpression();
[C++]
public: CodeTypeOfExpression();
[JScript]
public function CodeTypeOfExpression();

See Also

CodeTypeOfExpression Class | CodeTypeOfExpression Members | System.CodeDOM Namespace | CodeTypeOfExpression Constructor Overload List


CodeTypeOfExpression Constructor (String)

Initializes a new instance of CodeTypeOfExpression.

[Visual Basic]
Overloads Public Sub New( _
   ByVal type As String _
)
[C#]
public CodeTypeOfExpression(
   string type
);
[C++]
public: CodeTypeOfExpression(
   String* type
);
[JScript]
public function CodeTypeOfExpression(
   type : String
);

Parameters

type
The data type.

See Also

CodeTypeOfExpression Class | CodeTypeOfExpression Members | System.CodeDOM Namespace | CodeTypeOfExpression Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeTypeOfExpression Properties

The properties of the CodeTypeOfExpression class are listed below. For a complete list of CodeTypeOfExpression class members, see the CodeTypeOfExpression Members topic.

Public:

Type Gets or sets the data type.

See Also

CodeTypeOfExpression Class | System.CodeDOM Namespace


CodeTypeOfExpression.Type

Gets or sets the data type.

[Visual Basic]
Public Property Type As String
[C#]
public string Type {get; set;}
[C++]
public: __property String* get_Type();
public: __property void set_Type(String*);
[JScript]
public function get Type() : String;
public function set Type(String);

Property Value

The data type.

See Also

CodeTypeOfExpression Class | CodeTypeOfExpression Members | System.CodeDOM Namespace


CodeTypeReferenceExpression Class

Represents a reference to a type. This is normally used for the "TargetObject" of a static method call or field reference.

Object
CodeExpression
CodeTypeReferenceExpression

[Visual Basic]
Public Class CodeTypeReferenceExpression
   Inherits CodeExpression
[C#]
public class CodeTypeReferenceExpression : CodeExpression
[C++]
public __gc class CodeTypeReferenceExpression : public
   CodeExpression
[JScript]
public class CodeTypeReferenceExpression extends CodeExpression

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeTypeReferenceExpression Members | System.CodeDOM Namespace


CodeTypeReferenceExpression Members

Public:

Constructor

CodeTypeReferenceExpression Constructor Overloaded. Initializes a new instance of CodeTypeReferenceExpression.

Properties

Type Gets or sets the type to reference.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeTypeReferenceExpression Class | System.CodeDOM Namespace


CodeTypeReferenceExpression Constructor

Initializes a new instance of CodeTypeReferenceExpression.

Overload List

Initializes a new instance of CodeTypeReferenceExpression.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeTypeReferenceExpression();
[C++] public: CodeTypeReferenceExpression();
[JScript] public function CodeTypeReferenceExpression();

Initializes a new instance of CodeTypeReferenceExpression using the specified type.

[Visual Basic] Overloads Public Sub New(String)
[C#] public CodeTypeReferenceExpression(String);
[C++] public: CodeTypeReferenceExpression(String*);
[JScript] public function CodeTypeReferenceExpression(String);

See Also

CodeTypeReferenceExpression Class | CodeTypeReferenceExpression Members | System.CodeDOM Namespace


CodeTypeReferenceExpression Constructor ()

Initializes a new instance of CodeTypeReferenceExpression.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeTypeReferenceExpression();
[C++]
public: CodeTypeReferenceExpression();
[JScript]
public function CodeTypeReferenceExpression();

See Also

CodeTypeReferenceExpression Class | CodeTypeReferenceExpression Members | System.CodeDOM Namespace | CodeTypeReferenceExpression Constructor Overload List


CodeTypeReferenceExpression Constructor (String)

Initializes a new instance of CodeTypeReferenceExpression using the specified type.

[Visual Basic]
Overloads Public Sub New( _
   ByVal type As String _
)
[C#]
public CodeTypeReferenceExpression(
   string type
);
[C++]
public: CodeTypeReferenceExpression(
   String* type
);
[JScript]
public function CodeTypeReferenceExpression(
   type : String
);

Parameters

type
The type to reference.

See Also

CodeTypeReferenceExpression Class | CodeTypeReferenceExpression Members | System.CodeDOM Namespace | CodeTypeReferenceExpression Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeTypeReferenceExpression Properties

The properties of the CodeTypeReferenceExpression class are listed below. For a complete list of CodeTypeReferenceExpression class members, see the CodeTypeReferenceExpression Members topic.

Public:

Type Gets or sets the type to reference.

See Also

CodeTypeReferenceExpression Class | System.CodeDOM Namespace


CodeTypeReferenceExpression.Type

Gets or sets the type to reference.

[Visual Basic]
Public Property Type As String
[C#]
public string Type {get; set;}
[C++]
public: __property String* get_Type();
public: __property void set_Type(String*);
[JScript]
public function get Type() : String;
public function set Type(String);

Property Value

The type to reference.

See Also

CodeTypeReferenceExpression Class | CodeTypeReferenceExpression Members | System.CodeDOM Namespace


CodeVariableDeclarationStatement Class

Represents a local variable declaration.

Object
CodeStatement
CodeVariableDeclarationStatement

[Visual Basic]
Public Class CodeVariableDeclarationStatement
   Inherits CodeStatement
[C#]
public class CodeVariableDeclarationStatement : CodeStatement
[C++]
public __gc class CodeVariableDeclarationStatement : public
   CodeStatement
[JScript]
public class CodeVariableDeclarationStatement extends CodeStatement

Remarks

Some languages may implement "initExpression" by making a separate assignment statement after the variable declaration.

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

CodeVariableDeclarationStatement Members | System.CodeDOM Namespace


CodeVariableDeclarationStatement Members

Public:

Constructor

CodeVariableDeclarationStatement Constructor Overloaded. Initializes a new instance of CodeVariableDeclarationStatement.

Properties

InitExpression | Gets or sets the initialization expression for the variable.
LinePragma (inherited from CodeStatement) | The line the statement occurs on.
Name | Gets or sets the name of the variable.
Type | Gets or sets the type of the variable.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeVariableDeclarationStatement Class | System.CodeDOM Namespace


CodeVariableDeclarationStatement Constructor

Initializes a new instance of CodeVariableDeclarationStatement.

Overload List

Initializes a new instance of CodeVariableDeclarationStatement.

[Visual Basic] Overloads Public Sub New()
[C#] public CodeVariableDeclarationStatement();
[C++] public: CodeVariableDeclarationStatement();
[JScript] public function CodeVariableDeclarationStatement();

Initializes a new instance of CodeVariableDeclarationStatement using the specified type and name.

[Visual Basic] Overloads Public Sub New(String, String)
[C#] public CodeVariableDeclarationStatement(String, String);
[C++] public: CodeVariableDeclarationStatement(String*, String*);
[JScript] public function CodeVariableDeclarationStatement(String, String);

Initializes a new instance of CodeVariableDeclarationStatement using the specified type, name and initialization expression.

[Visual Basic] Overloads Public Sub New(String, String, CodeExpression)
[C#] public CodeVariableDeclarationStatement(String, String, CodeExpression);
[C++] public: CodeVariableDeclarationStatement(String*, String*, CodeExpression);
[JScript] public function CodeVariableDeclarationStatement(String, String, CodeExpression);

See Also

CodeVariableDeclarationStatement Class | CodeVariableDeclarationStatement Members | System.CodeDOM Namespace


CodeVariableDeclarationStatement Constructor ()

Initializes a new instance of CodeVariableDeclarationStatement.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CodeVariableDeclarationStatement();
[C++]
public: CodeVariableDeclarationStatement();
[JScript]
public function CodeVariableDeclarationStatement();

See Also

CodeVariableDeclarationStatement Class | CodeVariableDeclarationStatement Members | System.CodeDOM Namespace | CodeVariableDeclarationStatement Constructor Overload List


CodeVariableDeclarationStatement Constructor (String, String)

Initializes a new instance of CodeVariableDeclarationStatement using the specified type and name.

[Visual Basic]
Overloads Public Sub New( _
   ByVal type As String, _
   ByVal name As String _
)
[C#]
public CodeVariableDeclarationStatement(
   string type,
   string name
);
[C++]
public: CodeVariableDeclarationStatement(
   String* type,
   String* name
);
[JScript]
public function CodeVariableDeclarationStatement(
   type : String,
   name : String
);

Parameters

type
The type of the variable.
name
[To be supplied.]

See Also

CodeVariableDeclarationStatement Class | CodeVariableDeclarationStatement Members | System.CodeDOM Namespace | CodeVariableDeclarationStatement Constructor Overload List


CodeVariableDeclarationStatement Constructor (String, String, CodeExpression)

Initializes a new instance of CodeVariableDeclarationStatement using the specified type, name and initialization expression.

[Visual Basic]
Overloads Public Sub New( _
   ByVal type As String, _
   ByVal name As String, _
   ByVal initExpression As CodeExpression _
)
[C#]
public CodeVariableDeclarationStatement(
   string type,
   string name,
   CodeExpression initExpression
);
[C++]
public: CodeVariableDeclarationStatement(
   String* type,
   String* name,
   CodeExpression* initExpression
);
[JScript]
public function CodeVariableDeclarationStatement(
   type : String,
   name : String,
   initExpression : CodeExpression
);

Parameters

type
The type of the variable.
name
[To be supplied.]
initExpression
[To be supplied.]

See Also

CodeVariableDeclarationStatement Class | CodeVariableDeclarationStatement Members | System.CodeDOM Namespace | CodeVariableDeclarationStatement Constructor Overload List | CodeExpression


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeVariableDeclarationStatement Properties

The properties of the CodeVariableDeclarationStatement class are listed below. For a complete list of CodeVariableDeclarationStatement class members, see the CodeVariableDeclarationStatement Members topic.

Public:

InitExpression | Gets or sets the initialization expression for the variable.
LinePragma (inherited from CodeStatement) | The line the statement occurs on.
Name | Gets or sets the name of the variable.
Type | Gets or sets the type of the variable.

See Also

CodeVariableDeclarationStatement Class | System.CodeDOM Namespace


CodeVariableDeclarationStatement.InitExpression

Gets or sets the initialization expression for the variable.

[Visual Basic]
Public Property InitExpression As CodeExpression
[C#]
public CodeExpression InitExpression {get; set;}
[C++]
public: __property CodeExpression* get_InitExpression();
public: __property void set_InitExpression(CodeExpression*);
[JScript]
public function get InitExpression() : CodeExpression;
public function set InitExpression(CodeExpression);

Property Value

A CodeExpression that indicates the initialization expression for the variable.

See Also

CodeVariableDeclarationStatement Class | CodeVariableDeclarationStatement Members | System.CodeDOM Namespace | CodeExpression


CodeVariableDeclarationStatement.Name

Gets or sets the name of the variable.

[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}
[C++]
public: __property String* get_Name();
public: __property void set_Name(String*);
[JScript]
public function get Name() : String;
public function set Name(String);

Property Value

The name of the variable.

See Also

CodeVariableDeclarationStatement Class | CodeVariableDeclarationStatement Members | System.CodeDOM Namespace


CodeVariableDeclarationStatement.Type

Gets or sets the type of the variable.

[Visual Basic]
Public Property Type As String
[C#]
public string Type {get; set;}
[C++]
public: __property String* get_Type();
public: __property void set_Type(String*);
[JScript]
public function get Type() : String;
public function set Type(String);

Property Value

The type of the variable.

See Also

CodeVariableDeclarationStatement Class | CodeVariableDeclarationStatement Members | System.CodeDOM Namespace


FieldDirection Enumeration

Specifies values used to indicate field and parameter directions.

[Visual Basic]
Public Enum FieldDirection
[C#]
public enum FieldDirection
[C++]
public enum FieldDirection

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

This allows for passing arguments to functions byref.

Members

Member Name | Description
In | Incoming field.
Out | Outgoing field.
Ref | Field by reference.

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

System.CodeDOM Namespace


MemberAttributes Enumeration

Specifies member attributes used for class members.

[Visual Basic]
Public Enum MemberAttributes
[C#]
public enum MemberAttributes
[C++]
public enum MemberAttributes

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Abstract | [To be supplied.]
AccessMask | [To be supplied.]
Assembly | [To be supplied.]
FamANDAssem | [To be supplied.]
Family | [To be supplied.]
FamORAssem | [To be supplied.]
Final | [To be supplied.]
New | [To be supplied.]
Override | [To be supplied.]
Private | [To be supplied.]
Public | [To be supplied.]
ScopeMask | [To be supplied.]
Static | [To be supplied.]
VTableMask | [To be supplied.]

Requirements

Namespace: System.CodeDOM

Assembly: System.dll

See Also

System.CodeDOM Namespace


System.CodeDOM.Compiler

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.CodeDOM.Compiler Namespace

Classes

Class | Description
CodeCompiler | Base class for CodeCompilers. This is a useful utility baseclass for CodeGenerators to derive from.
CodeGenerator | The base class for CodeGenerators.
CompilerError | Represents a compiler error.
CompilerErrorCollection | Manages a collection of CompilerError objects.
CompilerParameters | Represents the parameters used in to invoke the compiler.
CompilerResults | Represents results from the compiler.
CSharpCodeGenerator | C# (C Sharp) Code Generator.
Executor | Provides command execution functions for the CodeDOM compiler.
IndentedTextWriter | IndentedTextWriter- indents new lines by a token (tabString).
JSCodeGenerator | JScript (ECMAScript) Code Generator.
TempFiles | Collection of temporary file names that are all based on a single base filename located in some temporary directory.
VBCodeGenerator | Visual Basic 7 Code Generator.

Interfaces

Interface | Description
IBatchCompiler | Provides methods to invoke batch compilation.
ICodeCompiler | Code Compilation Interface.
ICodeGenerator | Provides an interface for code generation.


CodeCompiler Class

Base class for CodeCompilers. This is a useful utility baseclass for CodeGenerators to derive from.

Object
CodeGenerator
CodeCompiler

[Visual Basic]
MustInherit Public Class CodeCompiler
   Inherits CodeGenerator
   Implements IBatchCompiler, ICodeCompiler
[C#]
public abstract class CodeCompiler : CodeGenerator, IBatchCompiler,
   ICodeCompiler
[C++]
public __gc __abstract class CodeCompiler : public CodeGenerator,
   IBatchCompiler, ICodeCompiler
[JScript]
public abstract class CodeCompiler extends CodeGenerator,
   IBatchCompiler, ICodeCompiler

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM.Compiler

Assembly: System.dll

See Also

CodeCompiler Members | System.CodeDOM.Compiler Namespace


CodeCompiler Members

Public:

Constructor

CodeCompiler Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

CurrentClassName (inherited from CodeGenerator) | Gets or sets the current class name.
CurrentMember (inherited from CodeGenerator) | Gets or sets the current member of the class.
CurrentMemberName (inherited from CodeGenerator) | Gets or sets the current member name.
CurrentNamespace (inherited from CodeGenerator) | Gets or sets the name of the current namespace.
FileExtension | [To be supplied.]
Indent (inherited from CodeGenerator) | Gets or sets the amount of spaces to indent.
IsCurrentClass (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current class.
IsCurrentDelegate (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current delegate.
IsCurrentEnum (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current enumeration.
IsCurrentInterface (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current interface.
IsCurrentStruct (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current structure.
Output (inherited from CodeGenerator) | Gets or sets the TextWriter to use for output.
SupportsAdvanced | [To be supplied.]

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
FromDOM | [To be supplied.]
FromDOMBatch | [To be supplied.]
FromFile | [To be supplied.]
FromFileBatch | [To be supplied.]
FromSource | [To be supplied.]
FromSourceBatch | [To be supplied.]
GenerateArrayCreateExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based array creation expression representation.
GenerateAssignStatement (inherited from CodeGenerator) | Generates code for the specified CodeDOM based assignment statement representation.
GenerateAttributeBlockEnd (inherited from CodeGenerator) | Generates code for the specified CodeDOM based attribute block end representation.
GenerateAttributeBlockStart (inherited from CodeGenerator) | Generates code for the specified CodeDOM based attribute block start representation.
GenerateBaseReferenceExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based base reference expression representation.
GenerateBinaryOperatorExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based binary operator expression representation.
GenerateCastExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based cast expression representation.
GenerateClassConstructor (inherited from CodeGenerator) | Generates code for the specified CodeDOM based class constructor representation.
GenerateClassEnd (inherited from CodeGenerator) | Generates code for the specified CodeDOM based end class representation.
GenerateClasses (inherited from CodeGenerator) | Generates classes using CodeDOM representation for the specified namespace.
GenerateClassStart (inherited from CodeGenerator) | Generates code for the specified CodeDOM based start class representation.
GenerateCommentStatement (inherited from CodeGenerator) | Generates code for the specified CodeDOM based comment statement representation.
GenerateConstructor (inherited from CodeGenerator) | Generates code for the specified CodeDOM based constructor representation.
GenerateDelegateCreateExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based delegate creation expression representation.
GenerateDelegateInvokeExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based delegate invoke expression representation.
GenerateDelegateInvokeStatement (inherited from CodeGenerator) | Generates code for the specified CodeDOM based method invoke statement representation.
GenerateExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based code expression.
GenerateField (inherited from CodeGenerator) | Generates code for the specified CodeDOM based member field representation.
GenerateFieldReferenceExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based field reference expression representation.
GenerateForLoopStatement (inherited from CodeGenerator) | Generates code for the specified CodeDOM based for loop statement representation.
GenerateIfStatement (inherited from CodeGenerator) | Generates code for the specified CodeDOM based if statement representation.
GenerateIndexerExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based indexer expression representation.
GenerateLinePragmaEnd (inherited from CodeGenerator) | Generates code for the specified CodeDOM based line pragma end representation.
GenerateLinePragmaStart (inherited from CodeGenerator) | Generates code for the specified CodeDOM based line pragma start representation.
GenerateLiteralExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based literal expression representation.
GenerateLiteralMember (inherited from CodeGenerator) | Generates code for the specified CodeDOM based literal class member representation.
GenerateLiteralStatement (inherited from CodeGenerator) | Generates code for the specified CodeDOM based literal statement representation.
GenerateMethod (inherited from CodeGenerator) | Generates code for the specified CodeDOM based method representation.
GenerateMethodInvokeExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based method invoke expression representation.
GenerateMethodInvokeStatement (inherited from CodeGenerator) | Generates code for the specified CodeDOM based method invoke statement representation.
GenerateMethodReturnStatement (inherited from CodeGenerator) | Generates code for the specified CodeDOM based method return statement representation.
GenerateNamespace (inherited from CodeGenerator) | Generates code for the specified CodeDOM based namespace representation.
GenerateNamespaceEnd (inherited from CodeGenerator) | Generates code for the specified CodeDOM based namespace end representation.
GenerateNamespaceImport (inherited from CodeGenerator) | Generates code for the specified CodeDOM based namespace import representation.
GenerateNamespaceImports (inherited from CodeGenerator) | Generates code for the specified CodeDOM based namespace import representation.
GenerateNamespaceStart (inherited from CodeGenerator) | Generates code for the specified CodeDOM based namespace start representation.
GenerateObjectCreateExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based object creation expression representation.
GenerateParameterDeclarationExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based parameter declaration expression representation.
GeneratePrimitiveExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based primitive expression representation.
GenerateProperty (inherited from CodeGenerator) | Generates code for the specified CodeDOM based property representation.
GeneratePropertyReferenceExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based property reference expression representation.
GenerateStatement (inherited from CodeGenerator) | Generates code for the specified CodeDOM based statement representation.
GenerateStatements (inherited from CodeGenerator) | Generates code for the specified CodeDOM based statement representations.
GenerateThisReferenceExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based this reference expression representation.
GenerateThrowExceptionStatement (inherited from CodeGenerator) | Generates code for the specified CodeDOM based throw exception statement representation.
GenerateTryCatchFinallyStatement (inherited from CodeGenerator) | Generates code for the specified CodeDOM based try catch finally statement representation.
GenerateTypeOfExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based type of expression representation.
GenerateTypeReferenceExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based type reference expression representation.
GenerateVariableDeclarationStatement (inherited from CodeGenerator) | Generates code for the specified CodeDOM based variable declaration statement representation.
GetNullToken (inherited from CodeGenerator) | Gets the token that represents a null reference (in Visual Basic Nothing).
GetTypeArrayRank (inherited from CodeGenerator) | [To be supplied.]
GetTypeBaseType (inherited from CodeGenerator) | Gets the base type of the specified type.
IsValidIdentifier (inherited from CodeGenerator) | Gets or sets whether the specified value is a value identifier.
JoinStringArray | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OutputAttributeArgument (inherited from CodeGenerator) | Outputs an argument in a attribute block.
OutputAttributeBlock (inherited from CodeGenerator) | Generates code for the specified CodeAttributeBlock.
OutputDirection (inherited from CodeGenerator) | Generates code for the specified FieldDirection.
OutputExpressionList (inherited from CodeGenerator) | Overloaded. [To be supplied.]
OutputMemberAccessModifier (inherited from CodeGenerator) | Generates code for the specified member access modifier.
OutputMemberScopeModifier (inherited from CodeGenerator) | Generates code for the specified member scope modifier.
OutputOperator (inherited from CodeGenerator) | Generates code for the specified operator.
OutputParameters (inherited from CodeGenerator) | Generates code for the specified parameters.
OutputType (inherited from CodeGenerator) | Generates code for the specified type.
OutputTypeAttributes (inherited from CodeGenerator) | Generates code for the specified type attributes.
OutputTypeNamePair (inherited from CodeGenerator) | Generates code for the specified object type and name pair.
QuoteLiteralString (inherited from CodeGenerator) | Provides conversion to formatting with escape codes.
ValidateIdentifier (inherited from CodeGenerator) | Gets whether the specified identifier is valid.

See Also

CodeCompiler Class | System.CodeDOM.Compiler Namespace


CodeCompiler Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CodeCompiler();
[C++]
public: CodeCompiler();
[JScript]
public function CodeCompiler();

See Also

CodeCompiler Class | CodeCompiler Members | System.CodeDOM.Compiler Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeCompiler Properties

The properties of the CodeCompiler class are listed below. For a complete list of CodeCompiler class members, see the CodeCompiler Members topic.

Protected:

CurrentClassName (inherited from CodeGenerator) | Gets or sets the current class name.
CurrentMember (inherited from CodeGenerator) | Gets or sets the current member of the class.
CurrentMemberName (inherited from CodeGenerator) | Gets or sets the current member name.
CurrentNamespace (inherited from CodeGenerator) | Gets or sets the name of the current namespace.
FileExtension | [To be supplied.]
Indent (inherited from CodeGenerator) | Gets or sets the amount of spaces to indent.
IsCurrentClass (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current class.
IsCurrentDelegate (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current delegate.
IsCurrentEnum (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current enumeration.
IsCurrentInterface (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current interface.
IsCurrentStruct (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current structure.
Output (inherited from CodeGenerator) | Gets or sets the TextWriter to use for output.
SupportsAdvanced | [To be supplied.]

See Also

CodeCompiler Class | System.CodeDOM.Compiler Namespace


CodeCompiler.FileExtension

[To be supplied.]

[Visual Basic]
MustOverride Protected ReadOnly Property FileExtension As String
[C#]
protected string FileExtension {abstract get;}
[C++]
protected: __property virtual String* get_FileExtension() = 0;
[JScript]
protected abstract function get FileExtension() : String;

See Also

CodeCompiler Class | CodeCompiler Members | System.CodeDOM.Compiler Namespace


CodeCompiler.SupportsAdvanced

[To be supplied.]

[Visual Basic]
Overridable Protected ReadOnly Property SupportsAdvanced As Boolean
[C#]
protected bool SupportsAdvanced {virtual get;}
[C++]
protected: __property virtual bool get_SupportsAdvanced();
[JScript]
protected function get SupportsAdvanced() : Boolean;

See Also

CodeCompiler Class | CodeCompiler Members | System.CodeDOM.Compiler Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeCompiler Methods

The methods of the CodeCompiler class are listed below. For a complete list of CodeCompiler class members, see the CodeCompiler Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
FromDOM | [To be supplied.]
FromDOMBatch | [To be supplied.]
FromFile | [To be supplied.]
FromFileBatch | [To be supplied.]
FromSource | [To be supplied.]
FromSourceBatch | [To be supplied.]
GenerateArrayCreateExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based array creation expression representation.
GenerateAssignStatement (inherited from CodeGenerator) | Generates code for the specified CodeDOM based assignment statement representation.
GenerateAttributeBlockEnd (inherited from CodeGenerator) | Generates code for the specified CodeDOM based attribute block end representation.
GenerateAttributeBlockStart (inherited from CodeGenerator) | Generates code for the specified CodeDOM based attribute block start representation.
GenerateBaseReferenceExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based base reference expression representation.
GenerateBinaryOperatorExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based binary operator expression representation.
GenerateCastExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based cast expression representation.
GenerateClassConstructor (inherited from CodeGenerator) | Generates code for the specified CodeDOM based class constructor representation.
GenerateClassEnd (inherited from CodeGenerator) | Generates code for the specified CodeDOM based end class representation.
GenerateClasses (inherited from CodeGenerator) | Generates classes using CodeDOM representation for the specified namespace.
GenerateClassStart (inherited from CodeGenerator) | Generates code for the specified CodeDOM based start class representation.
GenerateCommentStatement (inherited from CodeGenerator) | Generates code for the specified CodeDOM based comment statement representation.
GenerateConstructor (inherited from CodeGenerator) | Generates code for the specified CodeDOM based constructor representation.
GenerateDelegateCreateExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based delegate creation expression representation.
GenerateDelegateInvokeExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based delegate invoke expression representation.
GenerateDelegateInvokeStatement (inherited from CodeGenerator) | Generates code for the specified CodeDOM based method invoke statement representation.
GenerateExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based code expression.
GenerateField (inherited from CodeGenerator) | Generates code for the specified CodeDOM based member field representation.
GenerateFieldReferenceExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based field reference expression representation.
GenerateForLoopStatement (inherited from CodeGenerator) | Generates code for the specified CodeDOM based for loop statement representation.
GenerateIfStatement (inherited from CodeGenerator) | Generates code for the specified CodeDOM based if statement representation.
GenerateIndexerExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based indexer expression representation.
GenerateLinePragmaEnd (inherited from CodeGenerator) | Generates code for the specified CodeDOM based line pragma end representation.
GenerateLinePragmaStart (inherited from CodeGenerator) | Generates code for the specified CodeDOM based line pragma start representation.
GenerateLiteralExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based literal expression representation.
GenerateLiteralMember (inherited from CodeGenerator) | Generates code for the specified CodeDOM based literal class member representation.
GenerateLiteralStatement (inherited from CodeGenerator) | Generates code for the specified CodeDOM based literal statement representation.
GenerateMethod (inherited from CodeGenerator) | Generates code for the specified CodeDOM based method representation.
GenerateMethodInvokeExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based method invoke expression representation.
GenerateMethodInvokeStatement (inherited from CodeGenerator) | Generates code for the specified CodeDOM based method invoke statement representation.
GenerateMethodReturnStatement (inherited from CodeGenerator) | Generates code for the specified CodeDOM based method return statement representation.
GenerateNamespace (inherited from CodeGenerator) | Generates code for the specified CodeDOM based namespace representation.
GenerateNamespaceEnd (inherited from CodeGenerator) | Generates code for the specified CodeDOM based namespace end representation.
GenerateNamespaceImport (inherited from CodeGenerator) | Generates code for the specified CodeDOM based namespace import representation.
GenerateNamespaceImports (inherited from CodeGenerator) | Generates code for the specified CodeDOM based namespace import representation.
GenerateNamespaceStart (inherited from CodeGenerator) | Generates code for the specified CodeDOM based namespace start representation.
GenerateObjectCreateExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based object creation expression representation.
GenerateParameterDeclarationExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based parameter declaration expression representation.
GeneratePrimitiveExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based primitive expression representation.
GenerateProperty (inherited from CodeGenerator) | Generates code for the specified CodeDOM based property representation.
GeneratePropertyReferenceExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based property reference expression representation.
GenerateStatement (inherited from CodeGenerator) | Generates code for the specified CodeDOM based statement representation.
GenerateStatements (inherited from CodeGenerator) | Generates code for the specified CodeDOM based statement representations.
GenerateThisReferenceExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based this reference expression representation.
GenerateThrowExceptionStatement (inherited from CodeGenerator) | Generates code for the specified CodeDOM based throw exception statement representation.
GenerateTryCatchFinallyStatement (inherited from CodeGenerator) | Generates code for the specified CodeDOM based try catch finally statement representation.
GenerateTypeOfExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based type of expression representation.
GenerateTypeReferenceExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based type reference expression representation.
GenerateVariableDeclarationStatement (inherited from CodeGenerator) | Generates code for the specified CodeDOM based variable declaration statement representation.
GetNullToken (inherited from CodeGenerator) | Gets the token that represents a null reference (in Visual Basic Nothing).
GetTypeArrayRank (inherited from CodeGenerator) | [To be supplied.]
GetTypeBaseType (inherited from CodeGenerator) | Gets the base type of the specified type.
IsValidIdentifier (inherited from CodeGenerator) | Gets or sets whether the specified value is a value identifier.
JoinStringArray | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OutputAttributeArgument (inherited from CodeGenerator) | Outputs an argument in a attribute block.
OutputAttributeBlock (inherited from CodeGenerator) | Generates code for the specified CodeAttributeBlock.
OutputDirection (inherited from CodeGenerator) | Generates code for the specified FieldDirection.
OutputExpressionList (inherited from CodeGenerator) | Overloaded. [To be supplied.]
OutputMemberAccessModifier (inherited from CodeGenerator) | Generates code for the specified member access modifier.
OutputMemberScopeModifier (inherited from CodeGenerator) | Generates code for the specified member scope modifier.
OutputOperator (inherited from CodeGenerator) | Generates code for the specified operator.
OutputParameters (inherited from CodeGenerator) | Generates code for the specified parameters.
OutputType (inherited from CodeGenerator) | Generates code for the specified type.
OutputTypeAttributes (inherited from CodeGenerator) | Generates code for the specified type attributes.
OutputTypeNamePair (inherited from CodeGenerator) | Generates code for the specified object type and name pair.
QuoteLiteralString (inherited from CodeGenerator) | Provides conversion to formatting with escape codes.
ValidateIdentifier (inherited from CodeGenerator) | Gets whether the specified identifier is valid.

See Also

CodeCompiler Class | System.CodeDOM.Compiler Namespace


CodeCompiler.FromDOM

[To be supplied.]

[Visual Basic]
Overridable Protected Function FromDOM( _
   ByVal options As CompilerParameters, _
   ByVal e As CodeNamespace _
) As CompilerResults
[C#]
protected virtual CompilerResults FromDOM(
   CompilerParameters options,
   CodeNamespace e
);
[C++]
protected: virtual CompilerResults* FromDOM(
   CompilerParameters* options,
   CodeNamespace* e
);
[JScript]
protected function FromDOM(
   options : CompilerParameters,
   e : CodeNamespace
) : CompilerResults;

Parameters

options
[To be supplied.]
e
[To be supplied.]

See Also

CodeCompiler Class | CodeCompiler Members | System.CodeDOM.Compiler Namespace


CodeCompiler.FromDOMBatch

[To be supplied.]

[Visual Basic]
Overridable Protected Function FromDOMBatch( _
   ByVal options As CompilerParameters, _
   ByVal ea() As CodeNamespace _
) As CompilerResults
[C#]
protected virtual CompilerResults FromDOMBatch(
   CompilerParameters options,
   CodeNamespace[] ea
);
[C++]
protected: virtual CompilerResults* FromDOMBatch(
   CompilerParameters* options,
   CodeNamespace* ea[]
);
[JScript]
protected function FromDOMBatch(
   options : CompilerParameters,
   ea : CodeNamespace[]
) : CompilerResults;

Parameters

options
[To be supplied.]
ea
[To be supplied.]

See Also

CodeCompiler Class | CodeCompiler Members | System.CodeDOM.Compiler Namespace


CodeCompiler.FromFile

[To be supplied.]

[Visual Basic]
Overridable Protected Function FromFile( _
   ByVal options As CompilerParameters, _
   ByVal fileName As String _
) As CompilerResults
[C#]
protected virtual CompilerResults FromFile(
   CompilerParameters options,
   string fileName
);
[C++]
protected: virtual CompilerResults* FromFile(
   CompilerParameters* options,
   String* fileName
);
[JScript]
protected function FromFile(
   options : CompilerParameters,
   fileName : String
) : CompilerResults;

Parameters

options
[To be supplied.]
fileName
[To be supplied.]

See Also

CodeCompiler Class | CodeCompiler Members | System.CodeDOM.Compiler Namespace


CodeCompiler.FromFileBatch

[To be supplied.]

[Visual Basic]
MustOverride Protected Function FromFileBatch( _
   ByVal options As CompilerParameters, _
   ByVal fileNames() As String _
) As CompilerResults
[C#]
protected abstract CompilerResults FromFileBatch(
   CompilerParameters options,
   string[] fileNames
);
[C++]
protected: virtual CompilerResults* FromFileBatch(
   CompilerParameters* options,
   String* fileNames[]
) = 0;
[JScript]
protected abstract function FromFileBatch(
   options : CompilerParameters,
   fileNames : String[]
) : CompilerResults;

Parameters

options
[To be supplied.]
fileNames
[To be supplied.]

See Also

CodeCompiler Class | CodeCompiler Members | System.CodeDOM.Compiler Namespace


CodeCompiler.FromSource

[To be supplied.]

[Visual Basic]
Overridable Protected Function FromSource( _
   ByVal options As CompilerParameters, _
   ByVal source As String _
) As CompilerResults
[C#]
protected virtual CompilerResults FromSource(
   CompilerParameters options,
   string source
);
[C++]
protected: virtual CompilerResults* FromSource(
   CompilerParameters* options,
   String* source
);
[JScript]
protected function FromSource(
   options : CompilerParameters,
   source : String
) : CompilerResults;

Parameters

options
[To be supplied.]
source
[To be supplied.]

See Also

CodeCompiler Class | CodeCompiler Members | System.CodeDOM.Compiler Namespace


CodeCompiler.FromSourceBatch

[To be supplied.]

[Visual Basic]
Overridable Protected Function FromSourceBatch( _
   ByVal options As CompilerParameters, _
   ByVal sources() As String _
) As CompilerResults
[C#]
protected virtual CompilerResults FromSourceBatch(
   CompilerParameters options,
   string[] sources
);
[C++]
protected: virtual CompilerResults* FromSourceBatch(
   CompilerParameters* options,
   String* sources[]
);
[JScript]
protected function FromSourceBatch(
   options : CompilerParameters,
   sources : String[]
) : CompilerResults;

Parameters

options
[To be supplied.]
sources
[To be supplied.]

See Also

CodeCompiler Class | CodeCompiler Members | System.CodeDOM.Compiler Namespace


CodeCompiler.JoinStringArray

[To be supplied.]

[Visual Basic]
Protected Shared Function JoinStringArray( _
   ByVal sa() As String, _
   ByVal separator As String _
) As String
[C#]
protected static string JoinStringArray(
   string[] sa,
   string separator
);
[C++]
protected: static String* JoinStringArray(
   String* sa[],
   String* separator
);
[JScript]
protected static function JoinStringArray(
   sa : String[],
   separator : String
) : String;

Parameters

sa
[To be supplied.]
separator
[To be supplied.]

See Also

CodeCompiler Class | CodeCompiler Members | System.CodeDOM.Compiler Namespace


CodeGenerator Class

The base class for CodeGenerators.

Object
CodeGenerator

[Visual Basic]
MustInherit Public Class CodeGenerator
   Implements ICodeGenerator
[C#]
public abstract class CodeGenerator : ICodeGenerator
[C++]
public __gc __abstract class CodeGenerator : public ICodeGenerator
[JScript]
public abstract class CodeGenerator implements ICodeGenerator

Remarks

This is a useful utility baseclass for CodeGenerators to derive from.

Requirements

Namespace: System.CodeDOM.Compiler

Assembly: System.dll

See Also

CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeCompiler


CodeGenerator Members

Public:

Constructor

CodeGenerator Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

CurrentClassName | Gets or sets the current class name.
CurrentMember | Gets or sets the current member of the class.
CurrentMemberName | Gets or sets the current member name.
CurrentNamespace | Gets or sets the name of the current namespace.
Indent | Gets or sets the amount of spaces to indent.
IsCurrentClass | Gets or sets a value indicating whether the current object represented is the current class.
IsCurrentDelegate | Gets or sets a value indicating whether the current object represented is the current delegate.
IsCurrentEnum | Gets or sets a value indicating whether the current object represented is the current enumeration.
IsCurrentInterface | Gets or sets a value indicating whether the current object represented is the current interface.
IsCurrentStruct | Gets or sets a value indicating whether the current object represented is the current structure.
Output | Gets or sets the TextWriter to use for output.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GenerateArrayCreateExpression | Generates code for the specified CodeDOM based array creation expression representation.
GenerateAssignStatement | Generates code for the specified CodeDOM based assignment statement representation.
GenerateAttributeBlockEnd | Generates code for the specified CodeDOM based attribute block end representation.
GenerateAttributeBlockStart | Generates code for the specified CodeDOM based attribute block start representation.
GenerateBaseReferenceExpression | Generates code for the specified CodeDOM based base reference expression representation.
GenerateBinaryOperatorExpression | Generates code for the specified CodeDOM based binary operator expression representation.
GenerateCastExpression | Generates code for the specified CodeDOM based cast expression representation.
GenerateClassConstructor | Generates code for the specified CodeDOM based class constructor representation.
GenerateClassEnd | Generates code for the specified CodeDOM based end class representation.
GenerateClasses | Generates classes using CodeDOM representation for the specified namespace.
GenerateClassStart | Generates code for the specified CodeDOM based start class representation.
GenerateCommentStatement | Generates code for the specified CodeDOM based comment statement representation.
GenerateConstructor | Generates code for the specified CodeDOM based constructor representation.
GenerateDelegateCreateExpression | Generates code for the specified CodeDOM based delegate creation expression representation.
GenerateDelegateInvokeExpression | Generates code for the specified CodeDOM based delegate invoke expression representation.
GenerateDelegateInvokeStatement | Generates code for the specified CodeDOM based method invoke statement representation.
GenerateExpression | Generates code for the specified CodeDOM based code expression.
GenerateField | Generates code for the specified CodeDOM based member field representation.
GenerateFieldReferenceExpression | Generates code for the specified CodeDOM based field reference expression representation.
GenerateForLoopStatement | Generates code for the specified CodeDOM based for loop statement representation.
GenerateIfStatement | Generates code for the specified CodeDOM based if statement representation.
GenerateIndexerExpression | Generates code for the specified CodeDOM based indexer expression representation.
GenerateLinePragmaEnd | Generates code for the specified CodeDOM based line pragma end representation.
GenerateLinePragmaStart | Generates code for the specified CodeDOM based line pragma start representation.
GenerateLiteralExpression | Generates code for the specified CodeDOM based literal expression representation.
GenerateLiteralMember | Generates code for the specified CodeDOM based literal class member representation.
GenerateLiteralStatement | Generates code for the specified CodeDOM based literal statement representation.
GenerateMethod | Generates code for the specified CodeDOM based method representation.
GenerateMethodInvokeExpression | Generates code for the specified CodeDOM based method invoke expression representation.
GenerateMethodInvokeStatement | Generates code for the specified CodeDOM based method invoke statement representation.
GenerateMethodReturnStatement | Generates code for the specified CodeDOM based method return statement representation.
GenerateNamespace | Generates code for the specified CodeDOM based namespace representation.
GenerateNamespaceEnd | Generates code for the specified CodeDOM based namespace end representation.
GenerateNamespaceImport | Generates code for the specified CodeDOM based namespace import representation.
GenerateNamespaceImports | Generates code for the specified CodeDOM based namespace import representation.
GenerateNamespaceStart | Generates code for the specified CodeDOM based namespace start representation.
GenerateObjectCreateExpression | Generates code for the specified CodeDOM based object creation expression representation.
GenerateParameterDeclarationExpression | Generates code for the specified CodeDOM based parameter declaration expression representation.
GeneratePrimitiveExpression | Generates code for the specified CodeDOM based primitive expression representation.
GenerateProperty | Generates code for the specified CodeDOM based property representation.
GeneratePropertyReferenceExpression | Generates code for the specified CodeDOM based property reference expression representation.
GenerateStatement | Generates code for the specified CodeDOM based statement representation.
GenerateStatements | Generates code for the specified CodeDOM based statement representations.
GenerateThisReferenceExpression | Generates code for the specified CodeDOM based this reference expression representation.
GenerateThrowExceptionStatement | Generates code for the specified CodeDOM based throw exception statement representation.
GenerateTryCatchFinallyStatement | Generates code for the specified CodeDOM based try catch finally statement representation.
GenerateTypeOfExpression | Generates code for the specified CodeDOM based type of expression representation.
GenerateTypeReferenceExpression | Generates code for the specified CodeDOM based type reference expression representation.
GenerateVariableDeclarationStatement | Generates code for the specified CodeDOM based variable declaration statement representation.
GetNullToken | Gets the token that represents a null reference (in Visual Basic Nothing).
GetTypeArrayRank | [To be supplied.]
GetTypeBaseType | Gets the base type of the specified type.
IsValidIdentifier | Gets or sets whether the specified value is a value identifier.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OutputAttributeArgument | Outputs an argument in a attribute block.
OutputAttributeBlock | Generates code for the specified CodeAttributeBlock.
OutputDirection | Generates code for the specified FieldDirection.
OutputExpressionList | Overloaded. [To be supplied.]
OutputMemberAccessModifier | Generates code for the specified member access modifier.
OutputMemberScopeModifier | Generates code for the specified member scope modifier.
OutputOperator | Generates code for the specified operator.
OutputParameters | Generates code for the specified parameters.
OutputType | Generates code for the specified type.
OutputTypeAttributes | Generates code for the specified type attributes.
OutputTypeNamePair | Generates code for the specified object type and name pair.
QuoteLiteralString | Provides conversion to formatting with escape codes.
ValidateIdentifier | Gets whether the specified identifier is valid.

See Also

CodeGenerator Class | System.CodeDOM.Compiler Namespace


CodeGenerator Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CodeGenerator();
[C++]
public: CodeGenerator();
[JScript]
public function CodeGenerator();

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeGenerator Properties

The properties of the CodeGenerator class are listed below. For a complete list of CodeGenerator class members, see the CodeGenerator Members topic.

Protected:

CurrentClassName | Gets or sets the current class name.
CurrentMember | Gets or sets the current member of the class.
CurrentMemberName | Gets or sets the current member name.
CurrentNamespace | Gets or sets the name of the current namespace.
Indent | Gets or sets the amount of spaces to indent.
IsCurrentClass | Gets or sets a value indicating whether the current object represented is the current class.
IsCurrentDelegate | Gets or sets a value indicating whether the current object represented is the current delegate.
IsCurrentEnum | Gets or sets a value indicating whether the current object represented is the current enumeration.
IsCurrentInterface | Gets or sets a value indicating whether the current object represented is the current interface.
IsCurrentStruct | Gets or sets a value indicating whether the current object represented is the current structure.
Output | Gets or sets the TextWriter to use for output.

See Also

CodeGenerator Class | System.CodeDOM.Compiler Namespace


CodeGenerator.CurrentClassName

Gets or sets the current class name.

[Visual Basic]
Protected ReadOnly Property CurrentClassName As String
[C#]
protected string CurrentClassName {get;}
[C++]
protected: __property String* get_CurrentClassName();
[JScript]
protected function get CurrentClassName() : String;

Property Value

The current class name.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace


CodeGenerator.CurrentMember

Gets or sets the current member of the class.

[Visual Basic]
Protected ReadOnly Property CurrentMember As CodeClassMember
[C#]
protected CodeClassMember CurrentMember {get;}
[C++]
protected: __property CodeClassMember* get_CurrentMember();
[JScript]
protected function get CurrentMember() : CodeClassMember;

Property Value

A CodeClassMember that indicates the current member of the class.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeClassMember


CodeGenerator.CurrentMemberName

Gets or sets the current member name.

[Visual Basic]
Protected ReadOnly Property CurrentMemberName As String
[C#]
protected string CurrentMemberName {get;}
[C++]
protected: __property String* get_CurrentMemberName();
[JScript]
protected function get CurrentMemberName() : String;

Property Value

The name of the current member name.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | System.CodeDOM.CodeGenerator.CurrentMemberName


CodeGenerator.CurrentNamespace

Gets or sets the name of the current namespace.

[Visual Basic]
Protected ReadOnly Property CurrentNamespace As String
[C#]
protected string CurrentNamespace {get;}
[C++]
protected: __property String* get_CurrentNamespace();
[JScript]
protected function get CurrentNamespace() : String;

Property Value

The name of the current namespace.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace


CodeGenerator.Indent

Gets or sets the amount of spaces to indent.

[Visual Basic]
Protected Property Indent As Integer
[C#]
protected int Indent {get; set;}
[C++]
protected: __property int get_Indent();
protected: __property void set_Indent(int);
[JScript]
protected function get Indent() : int;
protected function set Indent(int);

Property Value

The number of spaces to indent.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace


CodeGenerator.IsCurrentClass

Gets or sets a value indicating whether the current object represented is the current class.

[Visual Basic]
Protected ReadOnly Property IsCurrentClass As Boolean
[C#]
protected bool IsCurrentClass {get;}
[C++]
protected: __property bool get_IsCurrentClass();
[JScript]
protected function get IsCurrentClass() : Boolean;

Property Value

true if the current object is the current class; otherwise, false.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace


CodeGenerator.IsCurrentDelegate

Gets or sets a value indicating whether the current object represented is the current delegate.

[Visual Basic]
Protected ReadOnly Property IsCurrentDelegate As Boolean
[C#]
protected bool IsCurrentDelegate {get;}
[C++]
protected: __property bool get_IsCurrentDelegate();
[JScript]
protected function get IsCurrentDelegate() : Boolean;

Property Value

true if the current object is the current delegate; otherwise, false.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace


CodeGenerator.IsCurrentEnum

Gets or sets a value indicating whether the current object represented is the current enumeration.

[Visual Basic]
Protected ReadOnly Property IsCurrentEnum As Boolean
[C#]
protected bool IsCurrentEnum {get;}
[C++]
protected: __property bool get_IsCurrentEnum();
[JScript]
protected function get IsCurrentEnum() : Boolean;

Property Value

true if the current object is the current enumeration; otherwise, false.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace


CodeGenerator.IsCurrentInterface

Gets or sets a value indicating whether the current object represented is the current interface.

[Visual Basic]
Protected ReadOnly Property IsCurrentInterface As Boolean
[C#]
protected bool IsCurrentInterface {get;}
[C++]
protected: __property bool get_IsCurrentInterface();
[JScript]
protected function get IsCurrentInterface() : Boolean;

Property Value

true if the current object is the current interface; otherwise, false.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace


CodeGenerator.IsCurrentStruct

Gets or sets a value indicating whether the current object represented is the current structure.

[Visual Basic]
Protected ReadOnly Property IsCurrentStruct As Boolean
[C#]
protected bool IsCurrentStruct {get;}
[C++]
protected: __property bool get_IsCurrentStruct();
[JScript]
protected function get IsCurrentStruct() : Boolean;

Property Value

true if the current object is the current structure; otherwise, false.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace


CodeGenerator.Output

Gets or sets the TextWriter to use for output.

[Visual Basic]
Protected ReadOnly Property Output As TextWriter
[C#]
protected TextWriter Output {get;}
[C++]
protected: __property TextWriter* get_Output();
[JScript]
protected function get Output() : TextWriter;

Property Value

The TextWriter to use for output.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeGenerator Methods

The methods of the CodeGenerator class are listed below. For a complete list of CodeGenerator class members, see the CodeGenerator Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GenerateArrayCreateExpression | Generates code for the specified CodeDOM based array creation expression representation.
GenerateAssignStatement | Generates code for the specified CodeDOM based assignment statement representation.
GenerateAttributeBlockEnd | Generates code for the specified CodeDOM based attribute block end representation.
GenerateAttributeBlockStart | Generates code for the specified CodeDOM based attribute block start representation.
GenerateBaseReferenceExpression | Generates code for the specified CodeDOM based base reference expression representation.
GenerateBinaryOperatorExpression | Generates code for the specified CodeDOM based binary operator expression representation.
GenerateCastExpression | Generates code for the specified CodeDOM based cast expression representation.
GenerateClassConstructor | Generates code for the specified CodeDOM based class constructor representation.
GenerateClassEnd | Generates code for the specified CodeDOM based end class representation.
GenerateClasses | Generates classes using CodeDOM representation for the specified namespace.
GenerateClassStart | Generates code for the specified CodeDOM based start class representation.
GenerateCommentStatement | Generates code for the specified CodeDOM based comment statement representation.
GenerateConstructor | Generates code for the specified CodeDOM based constructor representation.
GenerateDelegateCreateExpression | Generates code for the specified CodeDOM based delegate creation expression representation.
GenerateDelegateInvokeExpression | Generates code for the specified CodeDOM based delegate invoke expression representation.
GenerateDelegateInvokeStatement | Generates code for the specified CodeDOM based method invoke statement representation.
GenerateExpression | Generates code for the specified CodeDOM based code expression.
GenerateField | Generates code for the specified CodeDOM based member field representation.
GenerateFieldReferenceExpression | Generates code for the specified CodeDOM based field reference expression representation.
GenerateForLoopStatement | Generates code for the specified CodeDOM based for loop statement representation.
GenerateIfStatement | Generates code for the specified CodeDOM based if statement representation.
GenerateIndexerExpression | Generates code for the specified CodeDOM based indexer expression representation.
GenerateLinePragmaEnd | Generates code for the specified CodeDOM based line pragma end representation.
GenerateLinePragmaStart | Generates code for the specified CodeDOM based line pragma start representation.
GenerateLiteralExpression | Generates code for the specified CodeDOM based literal expression representation.
GenerateLiteralMember | Generates code for the specified CodeDOM based literal class member representation.
GenerateLiteralStatement | Generates code for the specified CodeDOM based literal statement representation.
GenerateMethod | Generates code for the specified CodeDOM based method representation.
GenerateMethodInvokeExpression | Generates code for the specified CodeDOM based method invoke expression representation.
GenerateMethodInvokeStatement | Generates code for the specified CodeDOM based method invoke statement representation.
GenerateMethodReturnStatement | Generates code for the specified CodeDOM based method return statement representation.
GenerateNamespace | Generates code for the specified CodeDOM based namespace representation.
GenerateNamespaceEnd | Generates code for the specified CodeDOM based namespace end representation.
GenerateNamespaceImport | Generates code for the specified CodeDOM based namespace import representation.
GenerateNamespaceImports | Generates code for the specified CodeDOM based namespace import representation.
GenerateNamespaceStart | Generates code for the specified CodeDOM based namespace start representation.
GenerateObjectCreateExpression | Generates code for the specified CodeDOM based object creation expression representation.
GenerateParameterDeclarationExpression | Generates code for the specified CodeDOM based parameter declaration expression representation.
GeneratePrimitiveExpression | Generates code for the specified CodeDOM based primitive expression representation.
GenerateProperty | Generates code for the specified CodeDOM based property representation.
GeneratePropertyReferenceExpression | Generates code for the specified CodeDOM based property reference expression representation.
GenerateStatement | Generates code for the specified CodeDOM based statement representation.
GenerateStatements | Generates code for the specified CodeDOM based statement representations.
GenerateThisReferenceExpression | Generates code for the specified CodeDOM based this reference expression representation.
GenerateThrowExceptionStatement | Generates code for the specified CodeDOM based throw exception statement representation.
GenerateTryCatchFinallyStatement | Generates code for the specified CodeDOM based try catch finally statement representation.
GenerateTypeOfExpression | Generates code for the specified CodeDOM based type of expression representation.
GenerateTypeReferenceExpression | Generates code for the specified CodeDOM based type reference expression representation.
GenerateVariableDeclarationStatement | Generates code for the specified CodeDOM based variable declaration statement representation.
GetNullToken | Gets the token that represents a null reference (in Visual Basic Nothing).
GetTypeArrayRank | [To be supplied.]
GetTypeBaseType | Gets the base type of the specified type.
IsValidIdentifier | Gets or sets whether the specified value is a value identifier.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OutputAttributeArgument | Outputs an argument in a attribute block.
OutputAttributeBlock | Generates code for the specified CodeAttributeBlock.
OutputDirection | Generates code for the specified FieldDirection.
OutputExpressionList | Overloaded. [To be supplied.]
OutputMemberAccessModifier | Generates code for the specified member access modifier.
OutputMemberScopeModifier | Generates code for the specified member scope modifier.
OutputOperator | Generates code for the specified operator.
OutputParameters | Generates code for the specified parameters.
OutputType | Generates code for the specified type.
OutputTypeAttributes | Generates code for the specified type attributes.
OutputTypeNamePair | Generates code for the specified object type and name pair.
QuoteLiteralString | Provides conversion to formatting with escape codes.
ValidateIdentifier | Gets whether the specified identifier is valid.

See Also

CodeGenerator Class | System.CodeDOM.Compiler Namespace


CodeGenerator.GenerateArrayCreateExpression

Generates code for the specified CodeDOM based array creation expression representation.

[Visual Basic]
MustOverride Protected Sub GenerateArrayCreateExpression( _
   ByVal e As CodeArrayCreateExpression _
)
[C#]
protected abstract void GenerateArrayCreateExpression(
   CodeArrayCreateExpression e
);
[C++]
protected: virtual void GenerateArrayCreateExpression(
   CodeArrayCreateExpression* e
) = 0;
[JScript]
protected abstract function GenerateArrayCreateExpression(
   e : CodeArrayCreateExpression
);

Parameters

e
A CodeArrayCreateExpression that indicates the expression to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeArrayCreateExpression


CodeGenerator.GenerateAssignStatement

Generates code for the specified CodeDOM based assignment statement representation.

[Visual Basic]
MustOverride Protected Sub GenerateAssignStatement( _
   ByVal e As CodeAssignStatement _
)
[C#]
protected abstract void GenerateAssignStatement(
   CodeAssignStatement e
);
[C++]
protected: virtual void GenerateAssignStatement(
   CodeAssignStatement* e
) = 0;
[JScript]
protected abstract function GenerateAssignStatement(
   e : CodeAssignStatement
);

Parameters

e
A CodeAssignStatement that indicates the statement to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeAssignStatement


CodeGenerator.GenerateAttributeBlockEnd

Generates code for the specified CodeDOM based attribute block end representation.

[Visual Basic]
MustOverride Protected Sub GenerateAttributeBlockEnd( _
   ByVal attributes As CodeAttributeBlock _
)
[C#]
protected abstract void GenerateAttributeBlockEnd(
   CodeAttributeB attributes
);
[C++]
protected: virtual void GenerateAttributeBlockEnd(
   CodeAttributeBlock* attributes
) = 0;
[JScript]
protected abstract function GenerateAttributeBlockEnd(
   attributes : CodeAttributeBlock
);

Parameters

attributes
[To be supplied.]

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeAttributeBlock


CodeGenerator.GenerateAttributeBlockStart

Generates code for the specified CodeDOM based attribute block start representation.

[Visual Basic]
MustOverride Protected Sub GenerateAttributeBlockStart( _
   ByVal attributes As CodeAttributeBlock _
)
[C#]
protected abstract void GenerateAttributeBlockStart(
   CodeAttributeB attributes
);
[C++]
protected: virtual void GenerateAttributeBlockStart(
   CodeAttributeBlock* attributes
) = 0;
[JScript]
protected abstract function GenerateAttributeBlockStart(
   attributes : CodeAttributeBlock
);

Parameters

attributes
[To be supplied.]

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeAttributeBlock


CodeGenerator.GenerateBaseReferenceExpression

Generates code for the specified CodeDOM based base reference expression representation.

[Visual Basic]
MustOverride Protected Sub GenerateBaseReferenceExpression( _
   ByVal e As CodeBaseReferenceExpression _
)
[C#]
protected abstract void GenerateBaseReferenceExpression(
   CodeBaseReferenceExpression e
);
[C++]
protected: virtual void GenerateBaseReferenceExpression(
   CodeBaseReferenceExpression* e
) = 0;
[JScript]
protected abstract function GenerateBaseReferenceExpression(
   e : CodeBaseReferenceExpression
);

Parameters

e
A CodeBaseReferenceExpression that indicates the expression to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeBaseReferenceExpression


CodeGenerator.GenerateBinaryOperatorExpression

Generates code for the specified CodeDOM based binary operator expression representation.

[Visual Basic]
Overridable Protected Sub GenerateBinaryOperatorExpression( _
   ByVal e As CodeBinaryOperatorExpression _
)
[C#]
protected virtual void GenerateBinaryOperatorExpression(
   CodeBinaryOperatorExpression e
);
[C++]
protected: virtual void GenerateBinaryOperatorExpression(
   CodeBinaryOperatorExpression* e
);
[JScript]
protected function GenerateBinaryOperatorExpression(
   e : CodeBinaryOperatorExpression
);

Parameters

e
A CodeBinaryOperatorExpression that indicates the expression to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeBinaryOperatorExpression


CodeGenerator.GenerateCastExpression

Generates code for the specified CodeDOM based cast expression representation.

[Visual Basic]
MustOverride Protected Sub GenerateCastExpression( _
   ByVal e As CodeCastExpression _
)
[C#]
protected abstract void GenerateCastExpression(
   CodeCastExpression e
);
[C++]
protected: virtual void GenerateCastExpression(
   CodeCastExpression* e
) = 0;
[JScript]
protected abstract function GenerateCastExpression(
   e : CodeCastExpression
);

Parameters

e
A CodeCastExpression that indicates the expression to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeCastExpression


CodeGenerator.GenerateClassConstructor

Generates code for the specified CodeDOM based class constructor representation.

[Visual Basic]
MustOverride Protected Sub GenerateClassConstructor( _
   ByVal e As CodeClassConstructor _
)
[C#]
protected abstract void GenerateClassConstructor(
   CodeClassConstructor e
);
[C++]
protected: virtual void GenerateClassConstructor(
   CodeClassConstructor* e
) = 0;
[JScript]
protected abstract function GenerateClassConstructor(
   e : CodeClassConstructor
);

Parameters

e
A CodeClassConstructor that indicates the class constructor to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeClassConstructor


CodeGenerator.GenerateClassEnd

Generates code for the specified CodeDOM based end class representation.

[Visual Basic]
MustOverride Protected Sub GenerateClassEnd( _
   ByVal e As CodeClass _
)
[C#]
protected abstract void GenerateClassEnd(
   CodeClass e
);
[C++]
protected: virtual void GenerateClassEnd(
   CodeClass* e
) = 0;
[JScript]
protected abstract function GenerateClassEnd(
   e : CodeClass
);

Parameters

e
A CodeClass that indicates the end of the class to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeClass


CodeGenerator.GenerateClasses

Generates classes using CodeDOM representation for the specified namespace.

[Visual Basic]
Protected Sub GenerateClasses( _
   ByVal e As CodeNamespace _
)
[C#]
protected void GenerateClasses(
   CodeNamespace e
);
[C++]
protected: void GenerateClasses(
   CodeNamespace* e
);
[JScript]
protected function GenerateClasses(
   e : CodeNamespace
);

Parameters

e
A CodeNamespace indicating the namespace to generate classes for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeNamespace


CodeGenerator.GenerateClassStart

Generates code for the specified CodeDOM based start class representation.

[Visual Basic]
MustOverride Protected Sub GenerateClassStart( _
   ByVal e As CodeClass _
)
[C#]
protected abstract void GenerateClassStart(
   CodeClass e
);
[C++]
protected: virtual void GenerateClassStart(
   CodeClass* e
) = 0;
[JScript]
protected abstract function GenerateClassStart(
   e : CodeClass
);

Parameters

e
A CodeClass that indicates the start of the class to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeClass


CodeGenerator.GenerateCommentStatement

Generates code for the specified CodeDOM based comment statement representation.

[Visual Basic]
MustOverride Protected Sub GenerateCommentStatement( _
   ByVal e As CodeCommentStatement _
)
[C#]
protected abstract void GenerateCommentStatement(
   CodeCommentStatement e
);
[C++]
protected: virtual void GenerateCommentStatement(
   CodeCommentStatement* e
) = 0;
[JScript]
protected abstract function GenerateCommentStatement(
   e : CodeCommentStatement
);

Parameters

e
A CodeCommentStatement that indicates the statement to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeCommentStatement


CodeGenerator.GenerateConstructor

Generates code for the specified CodeDOM based constructor representation.

[Visual Basic]
MustOverride Protected Sub GenerateConstructor( _
   ByVal e As CodeConstructor _
)
[C#]
protected abstract void GenerateConstructor(
   CodeConstructor e
);
[C++]
protected: virtual void GenerateConstructor(
   CodeConstructor* e
) = 0;
[JScript]
protected abstract function GenerateConstructor(
   e : CodeConstructor
);

Parameters

e
A CodeConstructor that indicates the constructor to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeConstructor


CodeGenerator.GenerateDelegateCreateExpression

Generates code for the specified CodeDOM based delegate creation expression representation.

[Visual Basic]
MustOverride Protected Sub GenerateDelegateCreateExpression( _
   ByVal e As CodeDelegateCreateExpression _
)
[C#]
protected abstract void GenerateDelegateCreateExpression(
   CodeDelegateCreateExpression e
);
[C++]
protected: virtual void GenerateDelegateCreateExpression(
   CodeDelegateCreateExpression* e
) = 0;
[JScript]
protected abstract function GenerateDelegateCreateExpression(
   e : CodeDelegateCreateExpression
);

Parameters

e
A CodeDelegateCreateExpression that indicates the expression to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeDelegateCreateExpression


CodeGenerator.GenerateDelegateInvokeExpression

Generates code for the specified CodeDOM based delegate invoke expression representation.

[Visual Basic]
MustOverride Protected Sub GenerateDelegateInvokeExpression( _
   ByVal e As CodeDelegateInvokeExpression _
)
[C#]
protected abstract void GenerateDelegateInvokeExpression(
   CodeDelegateInvokeExpression e
);
[C++]
protected: virtual void GenerateDelegateInvokeExpression(
   CodeDelegateInvokeExpression* e
) = 0;
[JScript]
protected abstract function GenerateDelegateInvokeExpression(
   e : CodeDelegateInvokeExpression
);

Parameters

e
A CodeDelegateInvokeExpression that indicates the expression to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeDelegateInvokeExpression


CodeGenerator.GenerateDelegateInvokeStatement

Generates code for the specified CodeDOM based method invoke statement representation.

[Visual Basic]
MustOverride Protected Sub GenerateDelegateInvokeStatement( _
   ByVal e As CodeDelegateInvokeStatement _
)
[C#]
protected abstract void GenerateDelegateInvokeStatement(
   CodeDelegateInvokeStatement e
);
[C++]
protected: virtual void GenerateDelegateInvokeStatement(
   CodeDelegateInvokeStatement* e
) = 0;
[JScript]
protected abstract function GenerateDelegateInvokeStatement(
   e : CodeDelegateInvokeStatement
);

Parameters

e
A CodeDelegateInvokeStatement that indicates the statement to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeDelegateInvokeStatement


CodeGenerator.GenerateExpression

Generates code for the specified CodeDOM based code expression.

[Visual Basic]
Protected Sub GenerateExpression( _
   ByVal e As CodeExpression _
)
[C#]
protected void GenerateExpression(
   CodeExpression e
);
[C++]
protected: void GenerateExpression(
   CodeExpression* e
);
[JScript]
protected function GenerateExpression(
   e : CodeExpression
);

Parameters

e
A CodeExpression that indicates the CodeDOM based code expression to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeExpression


CodeGenerator.GenerateField

Generates code for the specified CodeDOM based member field representation.

[Visual Basic]
MustOverride Protected Sub GenerateField( _
   ByVal e As CodeMemberField _
)
[C#]
protected abstract void GenerateField(
   CodeMemberField e
);
[C++]
protected: virtual void GenerateField(
   CodeMemberField* e
) = 0;
[JScript]
protected abstract function GenerateField(
   e : CodeMemberField
);

Parameters

e
A CodeMemberField that indicates the field to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeMemberField


CodeGenerator.GenerateFieldReferenceExpression

Generates code for the specified CodeDOM based field reference expression representation.

[Visual Basic]
MustOverride Protected Sub GenerateFieldReferenceExpression( _
   ByVal e As CodeFieldReferenceExpression _
)
[C#]
protected abstract void GenerateFieldReferenceExpression(
   CodeFieldReferenceExpression e
);
[C++]
protected: virtual void GenerateFieldReferenceExpression(
   CodeFieldReferenceExpression* e
) = 0;
[JScript]
protected abstract function GenerateFieldReferenceExpression(
   e : CodeFieldReferenceExpression
);

Parameters

e
A CodeFieldReferenceExpression that indicates the expression to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeFieldReferenceExpression


CodeGenerator.GenerateForLoopStatement

Generates code for the specified CodeDOM based for loop statement representation.

[Visual Basic]
MustOverride Protected Sub GenerateForLoopStatement( _
   ByVal e As CodeForLoopStatement _
)
[C#]
protected abstract void GenerateForLoopStatement(
   CodeForLoopStatement e
);
[C++]
protected: virtual void GenerateForLoopStatement(
   CodeForLoopStatement* e
) = 0;
[JScript]
protected abstract function GenerateForLoopStatement(
   e : CodeForLoopStatement
);

Parameters

e
A CodeForLoopStatement that indicates the statement to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeForLoopStatement


CodeGenerator.GenerateIfStatement

Generates code for the specified CodeDOM based if statement representation.

[Visual Basic]
MustOverride Protected Sub GenerateIfStatement( _
   ByVal e As CodeIfStatement _
)
[C#]
protected abstract void GenerateIfStatement(
   CodeIfStatement e
);
[C++]
protected: virtual void GenerateIfStatement(
   CodeIfStatement* e
) = 0;
[JScript]
protected abstract function GenerateIfStatement(
   e : CodeIfStatement
);

Parameters

e
A CodeIfStatement that indicates the statement to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeIfStatement


CodeGenerator.GenerateIndexerExpression

Generates code for the specified CodeDOM based indexer expression representation.

[Visual Basic]
MustOverride Protected Sub GenerateIndexerExpression( _
   ByVal e As CodeIndexerExpression _
)
[C#]
protected abstract void GenerateIndexerExpression(
   CodeIndexerExpression e
);
[C++]
protected: virtual void GenerateIndexerExpression(
   CodeIndexerExpression* e
) = 0;
[JScript]
protected abstract function GenerateIndexerExpression(
   e : CodeIndexerExpression
);

Parameters

e
A CodeIndexerExpression that indicates the expression to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeIndexerExpression


CodeGenerator.GenerateLinePragmaEnd

Generates code for the specified CodeDOM based line pragma end representation.

[Visual Basic]
MustOverride Protected Sub GenerateLinePragmaEnd( _
   ByVal e As CodeLinePragma _
)
[C#]
protected abstract void GenerateLinePragmaEnd(
   CodeLinePragma e
);
[C++]
protected: virtual void GenerateLinePragmaEnd(
   CodeLinePragma* e
) = 0;
[JScript]
protected abstract function GenerateLinePragmaEnd(
   e : CodeLinePragma
);

Parameters

e
A CodeLinePragma that indicates the end of the line pragma to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeLinePragma


CodeGenerator.GenerateLinePragmaStart

Generates code for the specified CodeDOM based line pragma start representation.

[Visual Basic]
MustOverride Protected Sub GenerateLinePragmaStart( _
   ByVal e As CodeLinePragma _
)
[C#]
protected abstract void GenerateLinePragmaStart(
   CodeLinePragma e
);
[C++]
protected: virtual void GenerateLinePragmaStart(
   CodeLinePragma* e
) = 0;
[JScript]
protected abstract function GenerateLinePragmaStart(
   e : CodeLinePragma
);

Parameters

e
A CodeLinePragma that indicates the start of the line pragma to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeLinePragma


CodeGenerator.GenerateLiteralExpression

Generates code for the specified CodeDOM based literal expression representation.

[Visual Basic]
MustOverride Protected Sub GenerateLiteralExpression( _
   ByVal e As CodeLiteralExpression _
)
[C#]
protected abstract void GenerateLiteralExpression(
   CodeLiteralExpression e
);
[C++]
protected: virtual void GenerateLiteralExpression(
   CodeLiteralExpression* e
) = 0;
[JScript]
protected abstract function GenerateLiteralExpression(
   e : CodeLiteralExpression
);

Parameters

e
A CodeLiteralExpression that indicates the expression to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeLiteralExpression


CodeGenerator.GenerateLiteralMember

Generates code for the specified CodeDOM based literal class member representation.

[Visual Basic]
MustOverride Protected Sub GenerateLiteralMember( _
   ByVal e As CodeLiteralClassMember _
)
[C#]
protected abstract void GenerateLiteralMember(
   CodeLiteralClassMember e
);
[C++]
protected: virtual void GenerateLiteralMember(
   CodeLiteralClassMember* e
) = 0;
[JScript]
protected abstract function GenerateLiteralMember(
   e : CodeLiteralClassMember
);

Parameters

e
A CodeLiteralClassMember that indicates the member to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeLiteralClassMember


CodeGenerator.GenerateLiteralStatement

Generates code for the specified CodeDOM based literal statement representation.

[Visual Basic]
MustOverride Protected Sub GenerateLiteralStatement( _
   ByVal e As CodeLiteralStatement _
)
[C#]
protected abstract void GenerateLiteralStatement(
   CodeLiteralStatement e
);
[C++]
protected: virtual void GenerateLiteralStatement(
   CodeLiteralStatement* e
) = 0;
[JScript]
protected abstract function GenerateLiteralStatement(
   e : CodeLiteralStatement
);

Parameters

e
A CodeLiteralStatement that indicates the statement to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeLiteralStatement


CodeGenerator.GenerateMethod

Generates code for the specified CodeDOM based method representation.

[Visual Basic]
MustOverride Protected Sub GenerateMethod( _
   ByVal e As CodeMemberMethod, _
   ByVal c As CodeClass _
)
[C#]
protected abstract void GenerateMethod(
   CodeMemberMethod e,
   CodeClass c
);
[C++]
protected: virtual void GenerateMethod(
   CodeMemberMethod* e,
   CodeClass* c
) = 0;
[JScript]
protected abstract function GenerateMethod(
   e : CodeMemberMethod,
   c : CodeClass
);

Parameters

e
A CodeMemberMethod that indicates the member method to generate code for.
c
[To be supplied.]

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeMemberMethod


CodeGenerator.GenerateMethodInvokeExpression

Generates code for the specified CodeDOM based method invoke expression representation.

[Visual Basic]
MustOverride Protected Sub GenerateMethodInvokeExpression( _
   ByVal e As CodeMethodInvokeExpression _
)
[C#]
protected abstract void GenerateMethodInvokeExpression(
   CodeMethodInvokeExpression e
);
[C++]
protected: virtual void GenerateMethodInvokeExpression(
   CodeMethodInvokeExpression* e
) = 0;
[JScript]
protected abstract function GenerateMethodInvokeExpression(
   e : CodeMethodInvokeExpression
);

Parameters

e
A CodeMethodInvokeExpression that indicates the expression to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeMethodInvokeExpression


CodeGenerator.GenerateMethodInvokeStatement

Generates code for the specified CodeDOM based method invoke statement representation.

[Visual Basic]
MustOverride Protected Sub GenerateMethodInvokeStatement( _
   ByVal e As CodeMethodInvokeStatement _
)
[C#]
protected abstract void GenerateMethodInvokeStatement(
   CodeMethodInvokeStatement e
);
[C++]
protected: virtual void GenerateMethodInvokeStatement(
   CodeMethodInvokeStatement* e
) = 0;
[JScript]
protected abstract function GenerateMethodInvokeStatement(
   e : CodeMethodInvokeStatement
);

Parameters

e
A CodeMethodInvokeStatement that indicates the statement to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeMethodInvokeStatement


CodeGenerator.GenerateMethodReturnStatement

Generates code for the specified CodeDOM based method return statement representation.

[Visual Basic]
MustOverride Protected Sub GenerateMethodReturnStatement( _
   ByVal e As CodeMethodReturnStatement _
)
[C#]
protected abstract void GenerateMethodReturnStatement(
   CodeMethodReturnStatement e
);
[C++]
protected: virtual void GenerateMethodReturnStatement(
   CodeMethodReturnStatement* e
) = 0;
[JScript]
protected abstract function GenerateMethodReturnStatement(
   e : CodeMethodReturnStatement
);

Parameters

e
A CodeMethodReturnStatement that indicates the statement to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeMethodReturnStatement


CodeGenerator.GenerateNamespace

Generates code for the specified CodeDOM based namespace representation.

[Visual Basic]
Overridable Protected Sub GenerateNamespace( _
   ByVal e As CodeNamespace _
)
[C#]
protected virtual void GenerateNamespace(
   CodeNamespace e
);
[C++]
protected: virtual void GenerateNamespace(
   CodeNamespace* e
);
[JScript]
protected function GenerateNamespace(
   e : CodeNamespace
);

Parameters

e
A CodeNamespace that indicates the namespace to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeNamespace


CodeGenerator.GenerateNamespaceEnd

Generates code for the specified CodeDOM based namespace end representation.

[Visual Basic]
MustOverride Protected Sub GenerateNamespaceEnd( _
   ByVal e As CodeNamespace _
)
[C#]
protected abstract void GenerateNamespaceEnd(
   CodeNamespace e
);
[C++]
protected: virtual void GenerateNamespaceEnd(
   CodeNamespace* e
) = 0;
[JScript]
protected abstract function GenerateNamespaceEnd(
   e : CodeNamespace
);

Parameters

e
A CodeNamespace that indicates the end of namespace to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeNamespace


CodeGenerator.GenerateNamespaceImport

Generates code for the specified CodeDOM based namespace import representation.

[Visual Basic]
MustOverride Protected Sub GenerateNamespaceImport( _
   ByVal e As CodeNamespaceImport _
)
[C#]
protected abstract void GenerateNamespaceImport(
   CodeNamespaceImport e
);
[C++]
protected: virtual void GenerateNamespaceImport(
   CodeNamespaceImport* e
) = 0;
[JScript]
protected abstract function GenerateNamespaceImport(
   e : CodeNamespaceImport
);

Parameters

e
A System.CodeDOM.Compiler.CodeNamespaceImport that indicates the namespace import to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | System.CodeDOM.Compiler.CodeNamespaceImport


CodeGenerator.GenerateNamespaceImports

Generates code for the specified CodeDOM based namespace import representation.

[Visual Basic]
Protected Sub GenerateNamespaceImports( _
   ByVal e As CodeNamespace _
)
[C#]
protected void GenerateNamespaceImports(
   CodeNamespace e
);
[C++]
protected: void GenerateNamespaceImports(
   CodeNamespace* e
);
[JScript]
protected function GenerateNamespaceImports(
   e : CodeNamespace
);

Parameters

e
A CodeNamespace that indicates the namespace import to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeNamespace


CodeGenerator.GenerateNamespaceStart

Generates code for the specified CodeDOM based namespace start representation.

[Visual Basic]
MustOverride Protected Sub GenerateNamespaceStart( _
   ByVal e As CodeNamespace _
)
[C#]
protected abstract void GenerateNamespaceStart(
   CodeNamespace e
);
[C++]
protected: virtual void GenerateNamespaceStart(
   CodeNamespace* e
) = 0;
[JScript]
protected abstract function GenerateNamespaceStart(
   e : CodeNamespace
);

Parameters

e
A CodeNamespace that indicates the start of namespace to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeNamespace


CodeGenerator.GenerateObjectCreateExpression

Generates code for the specified CodeDOM based object creation expression representation.

[Visual Basic]
MustOverride Protected Sub GenerateObjectCreateExpression( _
   ByVal e As CodeObjectCreateExpression _
)
[C#]
protected abstract void GenerateObjectCreateExpression(
   CodeObjectCreateExpression e
);
[C++]
protected: virtual void GenerateObjectCreateExpression(
   CodeObjectCreateExpression* e
) = 0;
[JScript]
protected abstract function GenerateObjectCreateExpression(
   e : CodeObjectCreateExpression
);

Parameters

e
A CodeObjectCreateExpression that indicates the expression to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeObjectCreateExpression


CodeGenerator.GenerateParameterDeclarationExpression

Generates code for the specified CodeDOM based parameter declaration expression representation.

[Visual Basic]
Overridable Protected Sub GenerateParameterDeclarationExpression( _
   ByVal e As CodeParameterDeclarationExpression _
)
[C#]
protected virtual void GenerateParameterDeclarationExpression(
   CodeParameterDeclarationExpression e
);
[C++]
protected: virtual void GenerateParameterDeclarationExpression(
   CodeParameterDeclarationExpression* e
);
[JScript]
protected function GenerateParameterDeclarationExpression(
   e : CodeParameterDeclarationExpression
);

Parameters

e
A CodeParameterDeclarationExpression that indicates the expression to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeParameterDeclarationExpression


CodeGenerator.GeneratePrimitiveExpression

Generates code for the specified CodeDOM based primitive expression representation.

[Visual Basic]
Overridable Protected Sub GeneratePrimitiveExpression( _
   ByVal e As CodePrimitiveExpression _
)
[C#]
protected virtual void GeneratePrimitiveExpression(
   CodePrimitiveExpression e
);
[C++]
protected: virtual void GeneratePrimitiveExpression(
   CodePrimitiveExpression* e
);
[JScript]
protected function GeneratePrimitiveExpression(
   e : CodePrimitiveExpression
);

Parameters

e
A CodePrimitiveExpression that indicates the expression to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodePrimitiveExpression


CodeGenerator.GenerateProperty

Generates code for the specified CodeDOM based property representation.

[Visual Basic]
MustOverride Protected Sub GenerateProperty( _
   ByVal e As CodeMemberProperty, _
   ByVal c As CodeClass _
)
[C#]
protected abstract void GenerateProperty(
   CodeMemberProperty e,
   CodeClass c
);
[C++]
protected: virtual void GenerateProperty(
   CodeMemberProperty* e,
   CodeClass* c
) = 0;
[JScript]
protected abstract function GenerateProperty(
   e : CodeMemberProperty,
   c : CodeClass
);

Parameters

e
A CodeMemberProperty that indicates the property to generate code for.
c
[To be supplied.]

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeMemberProperty


CodeGenerator.GeneratePropertyReferenceExpression

Generates code for the specified CodeDOM based property reference expression representation.

[Visual Basic]
Overridable Protected Sub GeneratePropertyReferenceExpression( _
   ByVal e As CodePropertyReferenceExpression _
)
[C#]
protected virtual void GeneratePropertyReferenceExpression(
   CodePropertyReferenceExpression e
);
[C++]
protected: virtual void GeneratePropertyReferenceExpression(
   CodePropertyReferenceExpression* e
);
[JScript]
protected function GeneratePropertyReferenceExpression(
   e : CodePropertyReferenceExpression
);

Parameters

e
A CodePropertyReferenceExpression that indicates the expression to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodePropertyReferenceExpression


CodeGenerator.GenerateStatement

Generates code for the specified CodeDOM based statement representation.

[Visual Basic]
Protected Sub GenerateStatement( _
   ByVal e As CodeStatement _
)
[C#]
protected void GenerateStatement(
   CodeStatement e
);
[C++]
protected: void GenerateStatement(
   CodeStatement* e
);
[JScript]
protected function GenerateStatement(
   e : CodeStatement
);

Parameters

e
A CodeStatement that indicates the statement to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeStatement


CodeGenerator.GenerateStatements

Generates code for the specified CodeDOM based statement representations.

[Visual Basic]
Protected Sub GenerateStatements( _
   ByVal stms As CodeStatementCollection _
)
[C#]
protected void GenerateStatements(
   CodeStatementCollection stms
);
[C++]
protected: void GenerateStatements(
   CodeStatementCollection* stms
);
[JScript]
protected function GenerateStatements(
   stms : CodeStatementCollection
);

Parameters

stms
A CodeStatementCollection that indicates the statements to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeStatementCollection


CodeGenerator.GenerateThisReferenceExpression

Generates code for the specified CodeDOM based this reference expression representation.

[Visual Basic]
MustOverride Protected Sub GenerateThisReferenceExpression( _
   ByVal e As CodeThisReferenceExpression _
)
[C#]
protected abstract void GenerateThisReferenceExpression(
   CodeThisReferenceExpression e
);
[C++]
protected: virtual void GenerateThisReferenceExpression(
   CodeThisReferenceExpression* e
) = 0;
[JScript]
protected abstract function GenerateThisReferenceExpression(
   e : CodeThisReferenceExpression
);

Parameters

e
A CodeThisReferenceExpression that indicates the expression to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeThisReferenceExpression


CodeGenerator.GenerateThrowExceptionStatement

Generates code for the specified CodeDOM based throw exception statement representation.

[Visual Basic]
MustOverride Protected Sub GenerateThrowExceptionStatement( _
   ByVal e As CodeThrowExceptionStatement _
)
[C#]
protected abstract void GenerateThrowExceptionStatement(
   CodeThrowExceptionStatement e
);
[C++]
protected: virtual void GenerateThrowExceptionStatement(
   CodeThrowExceptionStatement* e
) = 0;
[JScript]
protected abstract function GenerateThrowExceptionStatement(
   e : CodeThrowExceptionStatement
);

Parameters

e
A CodeThrowExceptionStatement that indicates the statement to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeThrowExceptionStatement


CodeGenerator.GenerateTryCatchFinallyStatement

Generates code for the specified CodeDOM based try catch finally statement representation.

[Visual Basic]
MustOverride Protected Sub GenerateTryCatchFinallyStatement( _
   ByVal e As CodeTryCatchFinallyStatement _
)
[C#]
protected abstract void GenerateTryCatchFinallyStatement(
   CodeTryCatchFinallyStatement e
);
[C++]
protected: virtual void GenerateTryCatchFinallyStatement(
   CodeTryCatchFinallyStatement* e
) = 0;
[JScript]
protected abstract function GenerateTryCatchFinallyStatement(
   e : CodeTryCatchFinallyStatement
);

Parameters

e
A CodeTryCatchFinallyStatement that indicates the statement to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeTryCatchFinallyStatement


CodeGenerator.GenerateTypeOfExpression

Generates code for the specified CodeDOM based type of expression representation.

[Visual Basic]
Overridable Protected Sub GenerateTypeOfExpression( _
   ByVal e As CodeTypeOfExpression _
)
[C#]
protected virtual void GenerateTypeOfExpression(
   CodeTypeOfExpression e
);
[C++]
protected: virtual void GenerateTypeOfExpression(
   CodeTypeOfExpression* e
);
[JScript]
protected function GenerateTypeOfExpression(
   e : CodeTypeOfExpression
);

Parameters

e
A CodeTypeOfExpression that indicates the expression to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeTypeOfExpression


CodeGenerator.GenerateTypeReferenceExpression

Generates code for the specified CodeDOM based type reference expression representation.

[Visual Basic]
Overridable Protected Sub GenerateTypeReferenceExpression( _
   ByVal e As CodeTypeReferenceExpression _
)
[C#]
protected virtual void GenerateTypeReferenceExpression(
   CodeTypeReferenceExpression e
);
[C++]
protected: virtual void GenerateTypeReferenceExpression(
   CodeTypeReferenceExpression* e
);
[JScript]
protected function GenerateTypeReferenceExpression(
   e : CodeTypeReferenceExpression
);

Parameters

e
A CodeTypeReferenceExpression that indicates the expression to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeTypeReferenceExpression


CodeGenerator.GenerateVariableDeclarationStatement

Generates code for the specified CodeDOM based variable declaration statement representation.

[Visual Basic]
MustOverride Protected Sub GenerateVariableDeclarationStatement( _
   ByVal e As CodeVariableDeclarationStatement _
)
[C#]
protected abstract void GenerateVariableDeclarationStatement(
   CodeVariableDeclarationStatement e
);
[C++]
protected: virtual void GenerateVariableDeclarationStatement(
   CodeVariableDeclarationStatement* e
) = 0;
[JScript]
protected abstract function GenerateVariableDeclarationStatement(
   e : CodeVariableDeclarationStatement
);

Parameters

e
A CodeVariableDeclarationStatement that indicates the statement to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeVariableDeclarationStatement


CodeGenerator.GetNullToken

Gets the token that represents a null reference (in Visual Basic Nothing).

[Visual Basic]
MustOverride Protected Function GetNullToken() As String
[C#]
protected abstract string GetNullToken();
[C++]
protected: virtual String* GetNullToken() = 0;
[JScript]
protected abstract function GetNullToken() : String;

Return Value

The token that represents a null reference (Nothing).

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace


CodeGenerator.GetTypeArrayRank

[To be supplied.]

[Visual Basic]
Protected Function GetTypeArrayRank( _
   ByVal type As String _
) As Integer
[C#]
protected int GetTypeArrayRank(
   string type
);
[C++]
protected: int GetTypeArrayRank(
   String* type
);
[JScript]
protected function GetTypeArrayRank(
   type : String
) : int;

Parameters

type
The type of the array.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace


CodeGenerator.GetTypeBaseType

Gets the base type of the specified type.

[Visual Basic]
Protected Function GetTypeBaseType( _
   ByVal type As String _
) As String
[C#]
protected string GetTypeBaseType(
   string type
);
[C++]
protected: String* GetTypeBaseType(
   String* type
);
[JScript]
protected function GetTypeBaseType(
   type : String
) : String;

Parameters

type
The type to locate the base type for.

Return Value

The name of the base data type.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace


CodeGenerator.IsValidIdentifier

Gets or sets whether the specified value is a value identifier.

[Visual Basic]
MustOverride Protected Function IsValidIdentifier( _
   ByVal value As String _
) As Boolean
[C#]
protected abstract bool IsValidIdentifier(
   string value
);
[C++]
protected: virtual bool IsValidIdentifier(
   String* value
) = 0;
[JScript]
protected abstract function IsValidIdentifier(
   value : String
) : Boolean;

Parameters

value
The value to test for equality against known value identifiers.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace


CodeGenerator.OutputAttributeArgument

Outputs an argument in a attribute block.

[Visual Basic]
Overridable Protected Sub OutputAttributeArgument( _
   ByVal arg As CodeAttributeArgument _
)
[C#]
protected virtual void OutputAttributeArgument(
   CodeAttributeArgument arg
);
[C++]
protected: virtual void OutputAttributeArgument(
   CodeAttributeArgument* arg
);
[JScript]
protected function OutputAttributeArgument(
   arg : CodeAttributeArgument
);

Parameters

arg
A System.CodeDOM.Compiler.CodeAttributeArgument that indicates the attribute argument to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | System.CodeDOM.Compiler.CodeAttributeArgument


CodeGenerator.OutputAttributeBlock

Generates code for the specified CodeAttributeBlock.

[Visual Basic]
Overridable Protected Sub OutputAttributeBlock( _
   ByVal attributes As CodeAttributeBlock _
)
[C#]
protected virtual void OutputAttributeBlock(
   CodeAttributeB attributes
);
[C++]
protected: virtual void OutputAttributeBlock(
   CodeAttributeBlock* attributes
);
[JScript]
protected function OutputAttributeBlock(
   attributes : CodeAttributeBlock
);

Parameters

attributes
A CodeAttributeBlock that indicates the attributes to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeAttributeBlock


CodeGenerator.OutputDirection

Generates code for the specified FieldDirection.

[Visual Basic]
Overridable Protected Sub OutputDirection( _
   ByVal dir As FieldDirection _
)
[C#]
protected virtual void OutputDirection(
   FieldDirection dir
);
[C++]
protected: virtual void OutputDirection(
   FieldDirection dir
);
[JScript]
protected function OutputDirection(
   dir : FieldDirection
);

Parameters

dir
A FieldDirection that indicates the attribute of the field.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | FieldDirection


CodeGenerator.OutputExpressionList

[To be supplied.]

Overload List

Generates code for the specified expression list.

[Visual Basic] Overloads Overridable Protected Sub OutputExpressionList(CodeExpressionCollection, Boolean)
[C#] protected virtual void OutputExpressionList(CodeExpressionCollection, bool);
[C++] protected: virtual void OutputExpressionList(CodeExpressionCollection*, bool);
[JScript] protected function OutputExpressionList(CodeExpressionCollection, Boolean);

Generates code for the specified expression list.

[Visual Basic] Overloads Overridable Protected Sub OutputExpressionList(CodeExpressionCollection)
[C#] protected virtual void OutputExpressionList(CodeExpressionCollection);
[C++] protected: virtual void OutputExpressionList(CodeExpressionCollection*);
[JScript] protected function OutputExpressionList(CodeExpressionCollection);

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace


CodeGenerator.OutputExpressionList (CodeExpressionCollection, Boolean)

Generates code for the specified expression list.

[Visual Basic]
Overloads Overridable Protected Sub OutputExpressionList( _
   ByVal expressions As CodeExpressionCollection, _
   ByVal fNewlineBetweenItems As Boolean _
)
[C#]
protected virtual void OutputExpressionList(
   CodeExpressionCollection expressions,
   bool fNewlineBetweenItems
);
[C++]
protected: virtual void OutputExpressionList(
   CodeExpressionCollection* expressions,
   bool fNewlineBetweenItems
);
[JScript]
protected function OutputExpressionList(
   expressions : CodeExpressionCollection,
   fNewlineBetweenItems : Boolean
);

Parameters

expressions
A CodeExpressionCollection that indicates the expressions to generate code for.
fNewlineBetweenItems
[To be supplied.]

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeGenerator.OutputExpressionList Overload List | CodeExpressionCollection


CodeGenerator.OutputExpressionList (CodeExpressionCollection)

Generates code for the specified expression list.

[Visual Basic]
Overloads Overridable Protected Sub OutputExpressionList( _
   ByVal expressions As CodeExpressionCollection _
)
[C#]
protected virtual void OutputExpressionList(
   CodeExpressionCollection expressions
);
[C++]
protected: virtual void OutputExpressionList(
   CodeExpressionCollection* expressions
);
[JScript]
protected function OutputExpressionList(
   expressions : CodeExpressionCollection
);

Parameters

expressions
A CodeExpressionCollection that indicates the expressions to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeGenerator.OutputExpressionList Overload List | CodeExpressionCollection


CodeGenerator.OutputMemberAccessModifier

Generates code for the specified member access modifier.

[Visual Basic]
Overridable Protected Sub OutputMemberAccessModifier( _
   ByVal attrs As MemberAttributes _
)
[C#]
protected virtual void OutputMemberAccessModifier(
   MemberAttributes attrs
);
[C++]
protected: virtual void OutputMemberAccessModifier(
   MemberAttributes attrs
);
[JScript]
protected function OutputMemberAccessModifier(
   attrs : MemberAttributes
);

Parameters

attrs
A MemberAttributes that indicates the member access modifier to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | MemberAttributes


CodeGenerator.OutputMemberScopeModifier

Generates code for the specified member scope modifier.

[Visual Basic]
Overridable Protected Sub OutputMemberScopeModifier( _
   ByVal attrs As MemberAttributes _
)
[C#]
protected virtual void OutputMemberScopeModifier(
   MemberAttributes attrs
);
[C++]
protected: virtual void OutputMemberScopeModifier(
   MemberAttributes attrs
);
[JScript]
protected function OutputMemberScopeModifier(
   attrs : MemberAttributes
);

Parameters

attrs
A MemberAttributes that indicates the member access modifier to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | MemberAttributes


CodeGenerator.OutputOperator

Generates code for the specified operator.

[Visual Basic]
Overridable Protected Sub OutputOperator( _
   ByVal op As CodeBinaryOperatorType _
)
[C#]
protected virtual void OutputOperator(
   CodeBinaryOperatorType op
);
[C++]
protected: virtual void OutputOperator(
   CodeBinaryOperatorType op
);
[JScript]
protected function OutputOperator(
   op : CodeBinaryOperatorType
);

Parameters

op
A CodeBinaryOperatorType that indicates the operator to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeBinaryOperatorType


CodeGenerator.OutputParameters

Generates code for the specified parameters.

[Visual Basic]
Overridable Protected Sub OutputParameters( _
   ByVal parameters As CodeParameterDeclarationExpressionCollection _
)
[C#]
protected virtual void OutputParameters(
   CodeParameterDeclarationExpressionCollection parameters
);
[C++]
protected: virtual void OutputParameters(
   CodeParameterDeclarationExpressionCollection* parameters
);
[JScript]
protected function OutputParameters(
   parameters : CodeParameterDeclarationExpressionCollection
);

Parameters

parameters
A CodeParameterDeclarationExpressionCollection that indicates the parameter declaration expressions to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeParameterDeclarationExpressionCollection


CodeGenerator.OutputType

Generates code for the specified type.

[Visual Basic]
Overridable Protected Sub OutputType( _
   ByVal typeRef As String _
)
[C#]
protected virtual void OutputType(
   string typeRef
);
[C++]
protected: virtual void OutputType(
   String* typeRef
);
[JScript]
protected function OutputType(
   typeRef : String
);

Parameters

typeRef
The type to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace


CodeGenerator.OutputTypeAttributes

Generates code for the specified type attributes.

[Visual Basic]
Overridable Protected Sub OutputTypeAttributes( _
   ByVal attrs As TypeAttributes _
)
[C#]
protected virtual void OutputTypeAttributes(
   TypeAttributes attrs
);
[C++]
protected: virtual void OutputTypeAttributes(
   TypeAttributes attrs
);
[JScript]
protected function OutputTypeAttributes(
   attrs : TypeAttributes
);

Parameters

attrs
A TypeAttributes that indicates the type attributes to generate code for.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace | TypeAttributes


CodeGenerator.OutputTypeNamePair

Generates code for the specified object type and name pair.

[Visual Basic]
Overridable Protected Sub OutputTypeNamePair( _
   ByVal typeRef As String, _
   ByVal name As String _
)
[C#]
protected virtual void OutputTypeNamePair(
   string typeRef,
   string name
);
[C++]
protected: virtual void OutputTypeNamePair(
   String* typeRef,
   String* name
);
[JScript]
protected function OutputTypeNamePair(
   typeRef : String,
   name : String
);

Parameters

typeRef
The type.
name
[To be supplied.]

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace


CodeGenerator.QuoteLiteralString

Provides conversion to formatting with escape codes.

[Visual Basic]
MustOverride Protected Function QuoteLiteralString( _
   ByVal value As String, _
   ByVal escapeUnicode As Boolean _
) As String
[C#]
protected abstract string QuoteLiteralString(
   string value,
   bool escapeUnicode
);
[C++]
protected: virtual String* QuoteLiteralString(
   String* value,
   bool escapeUnicode
) = 0;
[JScript]
protected abstract function QuoteLiteralString(
   value : String,
   escapeUnicode : Boolean
) : String;

Parameters

value
The string to convert.
escapeUnicode
[To be supplied.]

Return Value

The converted string.

Remarks

If the value of escapeUnicode is set to true, character values above 80 will be converted to use escape code formatting.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace


CodeGenerator.ValidateIdentifier

Gets whether the specified identifier is valid.

[Visual Basic]
Overridable Protected Sub ValidateIdentifier( _
   ByVal value As String _
)
[C#]
protected virtual void ValidateIdentifier(
   string value
);
[C++]
protected: virtual void ValidateIdentifier(
   String* value
);
[JScript]
protected function ValidateIdentifier(
   value : String
);

Parameters

value
The identifier to test for validity as an identifier.

Return Value

true if the identifier is valid; otherwise, false.

See Also

CodeGenerator Class | CodeGenerator Members | System.CodeDOM.Compiler Namespace


CompilerError Class

Represents a compiler error.

Object
CompilerError

[Visual Basic]
Public Class CompilerError
[C#]
public class CompilerError
[C++]
public __gc class CompilerError
[JScript]
public class CompilerError

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM.Compiler

Assembly: System.dll

See Also

CompilerError Members | System.CodeDOM.Compiler Namespace


CompilerError Members

Public:

Constructor

CompilerError Constructor Overloaded. Initializes a new instance of CompilerError.

Properties

Column | Gets or sets the column number where the source of the error occurs.
ErrorNumber | Gets or sets the error number.
ErrorText | Gets or sets the text of the error message.
FileName | Gets or sets the filename of the source that caused the error.
IsWarning | Gets or sets whether the error is a warning.
Line | Gets or sets the line number where the source of the error occurs.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Overrides Object's ToString.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompilerError Class | System.CodeDOM.Compiler Namespace


CompilerError Constructor

Initializes a new instance of CompilerError.

Overload List

Initializes a new instance of CompilerError.

[Visual Basic] Overloads Public Sub New()
[C#] public CompilerError();
[C++] public: CompilerError();
[JScript] public function CompilerError();

Initializes a new instance of CompilerError using the specified filename, line, column, error number and error text.

[Visual Basic] Overloads Public Sub New(String, Integer, Integer, String, String)
[C#] public CompilerError(String, int, int, String, String);
[C++] public: CompilerError(String*, int, int, String*, String*);
[JScript] public function CompilerError(String, int, int, String, String);

See Also

CompilerError Class | CompilerError Members | System.CodeDOM.Compiler Namespace


CompilerError Constructor ()

Initializes a new instance of CompilerError.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CompilerError();
[C++]
public: CompilerError();
[JScript]
public function CompilerError();

See Also

CompilerError Class | CompilerError Members | System.CodeDOM.Compiler Namespace | CompilerError Constructor Overload List


CompilerError Constructor (String, Int32, Int32, String, String)

Initializes a new instance of CompilerError using the specified filename, line, column, error number and error text.

[Visual Basic]
Overloads Public Sub New( _
   ByVal fileName As String, _
   ByVal line As Integer, _
   ByVal column As Integer, _
   ByVal errorNumber As String, _
   ByVal errorText As String _
)
[C#]
public CompilerError(
   string fileName,
   int line,
   int column,
   string errorNumber,
   string errorText
);
[C++]
public: CompilerError(
   String* fileName,
   int line,
   int column,
   String* errorNumber,
   String* errorText
);
[JScript]
public function CompilerError(
   fileName : String,
   line : int,
   column : int,
   errorNumber : String,
   errorText : String
);

Parameters

fileName
The filename the compile error occurred compiling source within.
line
[To be supplied.]
column
[To be supplied.]
errorNumber
[To be supplied.]
errorText
[To be supplied.]

See Also

CompilerError Class | CompilerError Members | System.CodeDOM.Compiler Namespace | CompilerError Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CompilerError Properties

The properties of the CompilerError class are listed below. For a complete list of CompilerError class members, see the CompilerError Members topic.

Public:

Column | Gets or sets the column number where the source of the error occurs.
ErrorNumber | Gets or sets the error number.
ErrorText | Gets or sets the text of the error message.
FileName | Gets or sets the filename of the source that caused the error.
IsWarning | Gets or sets whether the error is a warning.
Line | Gets or sets the line number where the source of the error occurs.

See Also

CompilerError Class | System.CodeDOM.Compiler Namespace


CompilerError.Column

Gets or sets the column number where the source of the error occurs.

[Visual Basic]
Public Property Column As Integer
[C#]
public int Column {get; set;}
[C++]
public: __property int get_Column();
public: __property void set_Column(int);
[JScript]
public function get Column() : int;
public function set Column(int);

Property Value

The column number of the source file.

See Also

CompilerError Class | CompilerError Members | System.CodeDOM.Compiler Namespace


CompilerError.ErrorNumber

Gets or sets the error number.

[Visual Basic]
Public Property ErrorNumber As String
[C#]
public string ErrorNumber {get; set;}
[C++]
public: __property String* get_ErrorNumber();
public: __property void set_ErrorNumber(String*);
[JScript]
public function get ErrorNumber() : String;
public function set ErrorNumber(String);

Property Value

The error number as a string.

See Also

CompilerError Class | CompilerError Members | System.CodeDOM.Compiler Namespace


CompilerError.ErrorText

Gets or sets the text of the error message.

[Visual Basic]
Public Property ErrorText As String
[C#]
public string ErrorText {get; set;}
[C++]
public: __property String* get_ErrorText();
public: __property void set_ErrorText(String*);
[JScript]
public function get ErrorText() : String;
public function set ErrorText(String);

Property Value

The text of the error message.

See Also

CompilerError Class | CompilerError Members | System.CodeDOM.Compiler Namespace


CompilerError.FileName

Gets or sets the filename of the source that caused the error.

[Visual Basic]
Public Property FileName As String
[C#]
public string FileName {get; set;}
[C++]
public: __property String* get_FileName();
public: __property void set_FileName(String*);
[JScript]
public function get FileName() : String;
public function set FileName(String);

Property Value

The filename of the source that caused the error.

See Also

CompilerError Class | CompilerError Members | System.CodeDOM.Compiler Namespace


CompilerError.IsWarning

Gets or sets whether the error is a warning.

[Visual Basic]
Public Property IsWarning As Boolean
[C#]
public bool IsWarning {get; set;}
[C++]
public: __property bool get_IsWarning();
public: __property void set_IsWarning(bool);
[JScript]
public function get IsWarning() : Boolean;
public function set IsWarning(Boolean);

Property Value

true if the error is a warning; otherwise, false.

See Also

CompilerError Class | CompilerError Members | System.CodeDOM.Compiler Namespace


CompilerError.Line

Gets or sets the line number where the source of the error occurs.

[Visual Basic]
Public Property Line As Integer
[C#]
public int Line {get; set;}
[C++]
public: __property int get_Line();
public: __property void set_Line(int);
[JScript]
public function get Line() : int;
public function set Line(int);

Property Value

The line number of the source file.

See Also

CompilerError Class | CompilerError Members | System.CodeDOM.Compiler Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CompilerError Methods

The methods of the CompilerError class are listed below. For a complete list of CompilerError class members, see the CompilerError Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Overrides Object's ToString.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompilerError Class | System.CodeDOM.Compiler Namespace


CompilerError.ToString

Overrides Object's ToString.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

CompilerError Class | CompilerError Members | System.CodeDOM.Compiler Namespace


CompilerErrorCollection Class

Manages a collection of CompilerError objects.

Object
CompilerErrorCollection

[Visual Basic]
Public Class CompilerErrorCollection
   Implements IList, ICollection, IEnumerable
[C#]
public class CompilerErrorCollection : IList, ICollection,
   IEnumerable
[C++]
public __gc class CompilerErrorCollection : public IList,
   ICollection, IEnumerable
[JScript]
public class CompilerErrorCollection implements IList, ICollection,
   IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM.Compiler

Assembly: System.dll

See Also

CompilerErrorCollection Members | System.CodeDOM.Compiler Namespace | CompilerError


CompilerErrorCollection Members

Public:

Constructor

CompilerErrorCollection Constructor [To be supplied.]

Properties

Count | Gets or sets the number of the members in the collection.
HasErrors | Gets or sets whether the collection contains errors.
HasWarnings | Gets or sets whether the collection contains warnings.
Item | Provides access to collection members. Indexer method. In C#, this member is the indexer for the CompilerErrorCollection class.

Methods

Add | Adds an error to the collection.
AddRange | Adds a set of CompilerError objects to the collection.
Clear | Clears the members of the collection.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Gets an enumerator that enumerates the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompilerErrorCollection Class | System.CodeDOM.Compiler Namespace


CompilerErrorCollection Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CompilerErrorCollection();
[C++]
public: CompilerErrorCollection();
[JScript]
public function CompilerErrorCollection();

See Also

CompilerErrorCollection Class | CompilerErrorCollection Members | System.CodeDOM.Compiler Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CompilerErrorCollection Properties

The properties of the CompilerErrorCollection class are listed below. For a complete list of CompilerErrorCollection class members, see the CompilerErrorCollection Members topic.

Public:

Count | Gets or sets the number of the members in the collection.
HasErrors | Gets or sets whether the collection contains errors.
HasWarnings | Gets or sets whether the collection contains warnings.
Item | Provides access to collection members. Indexer method. In C#, this member is the indexer for the CompilerErrorCollection class.

See Also

CompilerErrorCollection Class | System.CodeDOM.Compiler Namespace


CompilerErrorCollection.Count

Gets or sets the number of the members in the collection.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

Property Value

The number of members in the collection.

See Also

CompilerErrorCollection Class | CompilerErrorCollection Members | System.CodeDOM.Compiler Namespace


CompilerErrorCollection.HasErrors

Gets or sets whether the collection contains errors.

[Visual Basic]
Public ReadOnly Property HasErrors As Boolean
[C#]
public bool HasErrors {get;}
[C++]
public: __property bool get_HasErrors();
[JScript]
public function get HasErrors() : Boolean;

Property Value

true if the collection contains errors; otherwise, false.

See Also

CompilerErrorCollection Class | CompilerErrorCollection Members | System.CodeDOM.Compiler Namespace


CompilerErrorCollection.HasWarnings

Gets or sets whether the collection contains warnings.

[Visual Basic]
Public ReadOnly Property HasWarnings As Boolean
[C#]
public bool HasWarnings {get;}
[C++]
public: __property bool get_HasWarnings();
[JScript]
public function get HasWarnings() : Boolean;

Property Value

true if the collection contains warnings; otherwise, false.

See Also

CompilerErrorCollection Class | CompilerErrorCollection Members | System.CodeDOM.Compiler Namespace


CompilerErrorCollection.Item

Provides access to collection members. Indexer method.

[C#] In C#, this member is the indexer for the CompilerErrorCollection class.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As CompilerError
[C#]
public CompilerError this[
   int index
] {get; set;}
[C++]
public: __property CompilerError* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   CompilerError*
);
[JScript]
returnValue = CompilerErrorCollectionObject.Item(index);
CompilerErrorCollectionObject.Item(index) = returnValue;
-or-
returnValue = CompilerErrorCollectionObject(index);
CompilerErrorCollectionObject(index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
The index of the member to get or set.

Parameters [Visual Basic, C#, C++]

index
The index of the member to get or set.

See Also

CompilerErrorCollection Class | CompilerErrorCollection Members | System.CodeDOM.Compiler Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CompilerErrorCollection Methods

The methods of the CompilerErrorCollection class are listed below. For a complete list of CompilerErrorCollection class members, see the CompilerErrorCollection Members topic.

Public:

Add | Adds an error to the collection.
AddRange | Adds a set of CompilerError objects to the collection.
Clear | Clears the members of the collection.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Gets an enumerator that enumerates the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompilerErrorCollection Class | System.CodeDOM.Compiler Namespace


CompilerErrorCollection.Add

Adds an error to the collection.

[Visual Basic]
Public Sub Add( _
   ByVal value As CompilerError _
)
[C#]
public void Add(
   CompilerError value
);
[C++]
public: void Add(
   CompilerError* value
);
[JScript]
public function Add(
   value : CompilerError
);

Parameters

value
A CompilerError to add to the collection.

See Also

CompilerErrorCollection Class | CompilerErrorCollection Members | System.CodeDOM.Compiler Namespace | CompilerError


CompilerErrorCollection.AddRange

Adds a set of CompilerError objects to the collection.

[Visual Basic]
Public Sub AddRange( _
   ByVal value() As CompilerError _
)
[C#]
public void AddRange(
   CompilerError[] value
);
[C++]
public: void AddRange(
   CompilerError* value[]
);
[JScript]
public function AddRange(
   value : CompilerError[]
);

Parameters

value
An array of type CompilerError that contains the objects to add to the collection.

See Also

CompilerErrorCollection Class | CompilerErrorCollection Members | System.CodeDOM.Compiler Namespace | CompilerError


CompilerErrorCollection.Clear

Clears the members of the collection.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[JScript]
public function Clear();

See Also

CompilerErrorCollection Class | CompilerErrorCollection Members | System.CodeDOM.Compiler Namespace


CompilerErrorCollection.GetEnumerator

Gets an enumerator that enumerates the collection.

[Visual Basic]
Public Function GetEnumerator() As IEnumerator
[C#]
public IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

Return Value

An IEnumerator that enumerates the collection members.

See Also

CompilerErrorCollection Class | CompilerErrorCollection Members | System.CodeDOM.Compiler Namespace | IEnumerator


CompilerParameters Class

Represents the parameters used in to invoke the compiler.

Object
CompilerParameters

[Visual Basic]
Public Class CompilerParameters
[C#]
public class CompilerParameters
[C++]
public __gc class CompilerParameters
[JScript]
public class CompilerParameters

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM.Compiler

Assembly: System.dll

See Also

CompilerParameters Members | System.CodeDOM.Compiler Namespace


CompilerParameters Members

Public:

Constructor

CompilerParameters Constructor Overloaded. Initializes a new instance of CompilerParameters.

Properties

GenerateExecutable | Gets or sets whether to generate an executable.
GenerateInMemory | Gets or sets whether to generate in memory.
IncludeDebugInformation | Gets or sets whether to include debug information in the compiled executable.
MainClass | Gets or sets the main class.
OutputAssembly | Gets or sets the output assembly.
ReferencedAssemblies | Gets or sets the assemblies referenced by the source to compile.
RequireVariableDeclaration | Gets or sets whether the source requires a variable declaration.
TempFiles | Gets or sets the temp files.
UserToken | Gets or sets user token to be employed when creating the compiler process.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompilerParameters Class | System.CodeDOM.Compiler Namespace


CompilerParameters Constructor

Initializes a new instance of CompilerParameters.

Overload List

Initializes a new instance of CompilerParameters.

[Visual Basic] Overloads Public Sub New()
[C#] public CompilerParameters();
[C++] public: CompilerParameters();
[JScript] public function CompilerParameters();

Initializes a new instance of CompilerParameters using the specified assembly names.

[Visual Basic] Overloads Public Sub New(String())
[C#] public CompilerParameters(String[]);
[C++] public: CompilerParameters(String*[]);
[JScript] public function CompilerParameters(String[]);

Initializes a new instance of CompilerParameters using the specified assembly names and output name.

[Visual Basic] Overloads Public Sub New(String(), String)
[C#] public CompilerParameters(String[], String);
[C++] public: CompilerParameters(String*[], String*);
[JScript] public function CompilerParameters(String[], String);

Initializes a new instance of CompilerParameters using the specified assembly names, output name and a whether to include debug information flag.

[Visual Basic] Overloads Public Sub New(String(), String, Boolean)
[C#] public CompilerParameters(String[], String, bool);
[C++] public: CompilerParameters(String*[], String*, bool);
[JScript] public function CompilerParameters(String[], String, Boolean);

See Also

CompilerParameters Class | CompilerParameters Members | System.CodeDOM.Compiler Namespace


CompilerParameters Constructor ()

Initializes a new instance of CompilerParameters.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CompilerParameters();
[C++]
public: CompilerParameters();
[JScript]
public function CompilerParameters();

See Also

CompilerParameters Class | CompilerParameters Members | System.CodeDOM.Compiler Namespace | CompilerParameters Constructor Overload List


CompilerParameters Constructor (String[])

Initializes a new instance of CompilerParameters using the specified assembly names.

[Visual Basic]
Overloads Public Sub New( _
   ByVal assemblyNames() As String _
)
[C#]
public CompilerParameters(
   string[] assemblyNames
);
[C++]
public: CompilerParameters(
   String* assemblyNames[]
);
[JScript]
public function CompilerParameters(
   assemblyNames : String[]
);

Parameters

assemblyNames
The names of the assembly(s) to compile.

See Also

CompilerParameters Class | CompilerParameters Members | System.CodeDOM.Compiler Namespace | CompilerParameters Constructor Overload List


CompilerParameters Constructor (String[], String)

Initializes a new instance of CompilerParameters using the specified assembly names and output name.

[Visual Basic]
Overloads Public Sub New( _
   ByVal assemblyNames() As String, _
   ByVal outputName As String _
)
[C#]
public CompilerParameters(
   string[] assemblyNames,
   string outputName
);
[C++]
public: CompilerParameters(
   String* assemblyNames[],
   String* outputName
);
[JScript]
public function CompilerParameters(
   assemblyNames : String[],
   outputName : String
);

Parameters

assemblyNames
The names of the assembly(s) to compile.
outputName
[To be supplied.]

See Also

CompilerParameters Class | CompilerParameters Members | System.CodeDOM.Compiler Namespace | CompilerParameters Constructor Overload List


CompilerParameters Constructor (String[], String, Boolean)

Initializes a new instance of CompilerParameters using the specified assembly names, output name and a whether to include debug information flag.

[Visual Basic]
Overloads Public Sub New( _
   ByVal assemblyNames() As String, _
   ByVal outputName As String, _
   ByVal includeDebugInformation As Boolean _
)
[C#]
public CompilerParameters(
   string[] assemblyNames,
   string outputName,
   bool includeDebugInformation
);
[C++]
public: CompilerParameters(
   String* assemblyNames[],
   String* outputName,
   bool includeDebugInformation
);
[JScript]
public function CompilerParameters(
   assemblyNames : String[],
   outputName : String,
   includeDebugInformation : Boolean
);

Parameters

assemblyNames
The names of the assembly(s) to compile.
outputName
[To be supplied.]
includeDebugInformation
[To be supplied.]

See Also

CompilerParameters Class | CompilerParameters Members | System.CodeDOM.Compiler Namespace | CompilerParameters Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CompilerParameters Properties

The properties of the CompilerParameters class are listed below. For a complete list of CompilerParameters class members, see the CompilerParameters Members topic.

Public:

GenerateExecutable | Gets or sets whether to generate an executable.
GenerateInMemory | Gets or sets whether to generate in memory.
IncludeDebugInformation | Gets or sets whether to include debug information in the compiled executable.
MainClass | Gets or sets the main class.
OutputAssembly | Gets or sets the output assembly.
ReferencedAssemblies | Gets or sets the assemblies referenced by the source to compile.
RequireVariableDeclaration | Gets or sets whether the source requires a variable declaration.
TempFiles | Gets or sets the temp files.
UserToken | Gets or sets user token to be employed when creating the compiler process.

See Also

CompilerParameters Class | System.CodeDOM.Compiler Namespace


CompilerParameters.GenerateExecutable

Gets or sets whether to generate an executable.

[Visual Basic]
Public Property GenerateExecutable As Boolean
[C#]
public bool GenerateExecutable {get; set;}
[C++]
public: __property bool get_GenerateExecutable();
public: __property void set_GenerateExecutable(bool);
[JScript]
public function get GenerateExecutable() : Boolean;
public function set GenerateExecutable(Boolean);

Property Value

true if an executable should be generated; otherwise, false.

See Also

CompilerParameters Class | CompilerParameters Members | System.CodeDOM.Compiler Namespace


CompilerParameters.GenerateInMemory

Gets or sets whether to generate in memory.

[Visual Basic]
Public Property GenerateInMemory As Boolean
[C#]
public bool GenerateInMemory {get; set;}
[C++]
public: __property bool get_GenerateInMemory();
public: __property void set_GenerateInMemory(bool);
[JScript]
public function get GenerateInMemory() : Boolean;
public function set GenerateInMemory(Boolean);

Property Value

true if the output should be generated in memory; otherwise, false.

See Also

CompilerParameters Class | CompilerParameters Members | System.CodeDOM.Compiler Namespace


CompilerParameters.IncludeDebugInformation

Gets or sets whether to include debug information in the compiled executable.

[Visual Basic]
Public Property IncludeDebugInformation As Boolean
[C#]
public bool IncludeDebugInformation {get; set;}
[C++]
public: __property bool get_IncludeDebugInformation();
public: __property void set_IncludeDebugInformation(bool);
[JScript]
public function get IncludeDebugInformation() : Boolean;
public function set IncludeDebugInformation(Boolean);

Property Value

true if debug information should be generated; otherwise, false.

See Also

CompilerParameters Class | CompilerParameters Members | System.CodeDOM.Compiler Namespace


CompilerParameters.MainClass

Gets or sets the main class.

[Visual Basic]
Public Property MainClass As String
[C#]
public string MainClass {get; set;}
[C++]
public: __property String* get_MainClass();
public: __property void set_MainClass(String*);
[JScript]
public function get MainClass() : String;
public function set MainClass(String);

Property Value

The main class.

See Also

CompilerParameters Class | CompilerParameters Members | System.CodeDOM.Compiler Namespace


CompilerParameters.OutputAssembly

Gets or sets the output assembly.

[Visual Basic]
Public Property OutputAssembly As String
[C#]
public string OutputAssembly {get; set;}
[C++]
public: __property String* get_OutputAssembly();
public: __property void set_OutputAssembly(String*);
[JScript]
public function get OutputAssembly() : String;
public function set OutputAssembly(String);

Property Value

The output assembly.

See Also

CompilerParameters Class | CompilerParameters Members | System.CodeDOM.Compiler Namespace


CompilerParameters.ReferencedAssemblies

Gets or sets the assemblies referenced by the source to compile.

[Visual Basic]
Public ReadOnly Property ReferencedAssemblies As StringCollection
[C#]
public StringCollection ReferencedAssemblies {get;}
[C++]
public: __property StringCollection* get_ReferencedAssemblies();
[JScript]
public function get ReferencedAssemblies() : StringCollection;

Property Value

A System.StringCollection that contains the assembly names that are referenced by the source to compile.

See Also

CompilerParameters Class | CompilerParameters Members | System.CodeDOM.Compiler Namespace | System.StringCollection


CompilerParameters.RequireVariableDeclaration

Gets or sets whether the source requires a variable declaration.

[Visual Basic]
Public Property RequireVariableDeclaration As Boolean
[C#]
public bool RequireVariableDeclaration {get; set;}
[C++]
public: __property bool get_RequireVariableDeclaration();
public: __property void set_RequireVariableDeclaration(bool);
[JScript]
public function get RequireVariableDeclaration() : Boolean;
public function set RequireVariableDeclaration(Boolean);

Property Value

true if the source requires a variable declaration; otherwise, false.

See Also

CompilerParameters Class | CompilerParameters Members | System.CodeDOM.Compiler Namespace


CompilerParameters.TempFiles

Gets or sets the temp files.

[Visual Basic]
Public Property TempFiles As TempFiles
[C#]
public TempFiles TempFiles {get; set;}
[C++]
public: __property TempFiles* get_TempFiles();
public: __property void set_TempFiles(TempFiles*);
[JScript]
public function get TempFiles() : TempFiles;
public function set TempFiles(TempFiles);

Property Value

A TempFiles that indicates the temporary files.

See Also

CompilerParameters Class | CompilerParameters Members | System.CodeDOM.Compiler Namespace


CompilerParameters.UserToken

Gets or sets user token to be employed when creating the compiler process.

[Visual Basic]
Public Property UserToken As Integer
[C#]
public int UserToken {get; set;}
[C++]
public: __property int get_UserToken();
public: __property void set_UserToken(int);
[JScript]
public function get UserToken() : int;
public function set UserToken(int);

Property Value

The user token.

See Also

CompilerParameters Class | CompilerParameters Members | System.CodeDOM.Compiler Namespace


CompilerResults Class

Represents results from the compiler.

Object
CompilerResults

[Visual Basic]
Public Class CompilerResults
[C#]
public class CompilerResults
[C++]
public __gc class CompilerResults
[JScript]
public class CompilerResults

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM.Compiler

Assembly: System.dll

See Also

CompilerResults Members | System.CodeDOM.Compiler Namespace


CompilerResults Members

Public:

Constructor

CompilerResults Constructor Initializes a new instance of CompilerResults that uses the specified temporary files.

Properties

CompiledAssembly | The compiled assembly.
Errors | Gets or sets the collection of compiler errors.
NativeCompilerReturnValue | Gets or sets the compiler's return value.
Output | Gets or sets the compiler output messages.
PathToAssembly | Gets or sets the path to the assembly.
TempFiles | Gets or sets the temporary files to use.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompilerResults Class | System.CodeDOM.Compiler Namespace


CompilerResults Constructor

Initializes a new instance of CompilerResults that uses the specified temporary files.

[Visual Basic]
Public Sub New( _
   ByVal tempFiles As TempFiles _
)
[C#]
public CompilerResults(
   TempFiles tempFiles
);
[C++]
public: CompilerResults(
   TempFiles* tempFiles
);
[JScript]
public function CompilerResults(
   tempFiles : TempFiles
);

Parameters

tempFiles
A TempFiles that indicates the temporary files to use.

See Also

CompilerResults Class | CompilerResults Members | System.CodeDOM.Compiler Namespace | TempFiles


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CompilerResults Properties

The properties of the CompilerResults class are listed below. For a complete list of CompilerResults class members, see the CompilerResults Members topic.

Public:

CompiledAssembly | The compiled assembly.
Errors | Gets or sets the collection of compiler errors.
NativeCompilerReturnValue | Gets or sets the compiler's return value.
Output | Gets or sets the compiler output messages.
PathToAssembly | Gets or sets the path to the assembly.
TempFiles | Gets or sets the temporary files to use.

See Also

CompilerResults Class | System.CodeDOM.Compiler Namespace


CompilerResults.CompiledAssembly

The compiled assembly.

[Visual Basic]
Public Property CompiledAssembly As Assembly
[C#]
public Assembly CompiledAssembly {get; set;}
[C++]
public: __property Assembly* get_CompiledAssembly();
public: __property void set_CompiledAssembly(Assembly*);
[JScript]
public function get CompiledAssembly() : Assembly;
public function set CompiledAssembly(Assembly);

Property Value

An Assembly that indicates the compiled assembly.

See Also

CompilerResults Class | CompilerResults Members | System.CodeDOM.Compiler Namespace


CompilerResults.Errors

Gets or sets the collection of compiler errors.

[Visual Basic]
Public ReadOnly Property Errors As CompilerErrorCollection
[C#]
public CompilerErrorCollection Errors {get;}
[C++]
public: __property CompilerErrorCollection* get_Errors();
[JScript]
public function get Errors() : CompilerErrorCollection;

Property Value

A CompilerErrorCollection that indicates the errors resultant from compilation, if any.

See Also

CompilerResults Class | CompilerResults Members | System.CodeDOM.Compiler Namespace


CompilerResults.NativeCompilerReturnValue

Gets or sets the compiler's return value.

[Visual Basic]
Public Property NativeCompilerReturnValue As Integer
[C#]
public int NativeCompilerReturnValue {get; set;}
[C++]
public: __property int get_NativeCompilerReturnValue();
public: __property void set_NativeCompilerReturnValue(int);
[JScript]
public function get NativeCompilerReturnValue() : int;
public function set NativeCompilerReturnValue(int);

Property Value

The compiler's return value.

See Also

CompilerResults Class | CompilerResults Members | System.CodeDOM.Compiler Namespace


CompilerResults.Output

Gets or sets the compiler output messages.

[Visual Basic]
Public ReadOnly Property Output As StringCollection
[C#]
public StringCollection Output {get;}
[C++]
public: __property StringCollection* get_Output();
[JScript]
public function get Output() : StringCollection;

Property Value

A System.StringCollection that contains the output messages.

See Also

CompilerResults Class | CompilerResults Members | System.CodeDOM.Compiler Namespace


CompilerResults.PathToAssembly

Gets or sets the path to the assembly.

[Visual Basic]
Public Property PathToAssembly As String
[C#]
public string PathToAssembly {get; set;}
[C++]
public: __property String* get_PathToAssembly();
public: __property void set_PathToAssembly(String*);
[JScript]
public function get PathToAssembly() : String;
public function set PathToAssembly(String);

Property Value

The path to the assembly.

See Also

CompilerResults Class | CompilerResults Members | System.CodeDOM.Compiler Namespace


CompilerResults.TempFiles

Gets or sets the temporary files to use.

[Visual Basic]
Public Property TempFiles As TempFiles
[C#]
public TempFiles TempFiles {get; set;}
[C++]
public: __property TempFiles* get_TempFiles();
public: __property void set_TempFiles(TempFiles*);
[JScript]
public function get TempFiles() : TempFiles;
public function set TempFiles(TempFiles);

Property Value

A TempFiles that indicates the temporary files to use.

See Also

CompilerResults Class | CompilerResults Members | System.CodeDOM.Compiler Namespace | TempFiles


CSharpCodeGenerator Class

C# (C Sharp) Code Generator.

Object
CodeGenerator
CodeCompiler
CSharpCodeGenerator

[Visual Basic]
Public Class CSharpCodeGenerator
   Inherits CodeCompiler
[C#]
public class CSharpCodeGenerator : CodeCompiler
[C++]
public __gc class CSharpCodeGenerator : public CodeCompiler
[JScript]
public class CSharpCodeGenerator extends CodeCompiler

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM.Compiler

Assembly: System.dll

See Also

CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | System.CodeDOM.CodeGenerator


CSharpCodeGenerator Members

Public:

Constructor

CSharpCodeGenerator Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

CurrentClassName (inherited from CodeGenerator) | Gets or sets the current class name.
CurrentMember (inherited from CodeGenerator) | Gets or sets the current member of the class.
CurrentMemberName (inherited from CodeGenerator) | Gets or sets the current member name.
CurrentNamespace (inherited from CodeGenerator) | Gets or sets the name of the current namespace.
FileExtension | Gets or sets the file extension.
Indent (inherited from CodeGenerator) | Gets or sets the amount of spaces to indent.
IsCurrentClass (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current class.
IsCurrentDelegate (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current delegate.
IsCurrentEnum (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current enumeration.
IsCurrentInterface (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current interface.
IsCurrentStruct (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current structure.
Output (inherited from CodeGenerator) | Gets or sets the TextWriter to use for output.
SupportsAdvanced (inherited from CodeCompiler) | [To be supplied.]

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
FromDOM (inherited from CodeCompiler) | [To be supplied.]
FromDOMBatch (inherited from CodeCompiler) | [To be supplied.]
FromFile (inherited from CodeCompiler) | [To be supplied.]
FromFileBatch | Gets the compiler results after compiling the specified batch of files using the specified compiler parameters.
FromSource (inherited from CodeCompiler) | [To be supplied.]
FromSourceBatch (inherited from CodeCompiler) | [To be supplied.]
GenerateArrayCreateExpression | Generates code for the specified CodeDOM based array creation expression representation.
GenerateAssignStatement | Generates code for the specified CodeDOM based assignment statement representation.
GenerateAttributeBlockEnd | Generates code for the specified CodeDOM based attribute block end representation.
GenerateAttributeBlockStart | Generates code for the specified CodeDOM based attribute block start representation.
GenerateBaseReferenceExpression | Generates code for the specified CodeDOM based base reference expression representation.
GenerateBinaryOperatorExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based binary operator expression representation.
GenerateCastExpression | Generates code for the specified CodeDOM based cast expression representation.
GenerateClassConstructor | Generates code for the specified CodeDOM based class constructor representation.
GenerateClassEnd | Generates code for the specified CodeDOM based class end representation.
GenerateClasses (inherited from CodeGenerator) | Generates classes using CodeDOM representation for the specified namespace.
GenerateClassStart | Generates code for the specified CodeDOM based class start representation.
GenerateCommentStatement | Generates code for the specified CodeDOM based comment statement representation.
GenerateConstructor | Generates code for the specified CodeDOM based constructor representation.
GenerateDelegateCreateExpression | Generates code for the specified CodeDOM based delegate creation expression representation.
GenerateDelegateInvokeExpression | Generates code for the specified CodeDOM based delegate invoke expression representation.
GenerateDelegateInvokeStatement | Generates code for the specified CodeDOM based delegate invoke statement representation.
GenerateExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based code expression.
GenerateField | Generates code for the specified CodeDOM based field representation.
GenerateFieldReferenceExpression | Generates code for the specified CodeDOM based field reference expression representation.
GenerateForLoopStatement | Generates code for the specified CodeDOM based for loop statement representation.
GenerateIfStatement | Generates code for the specified CodeDOM based if statement representation.
GenerateIndexerExpression | Generates code for the specified CodeDOM based indexer expression representation.
GenerateLinePragmaEnd | Generates code for the specified CodeDOM based line pragma end representation.
GenerateLinePragmaStart | Generates code for the specified CodeDOM based line pragma start representation.
GenerateLiteralExpression | Generates code for the specified CodeDOM based literal expression representation.
GenerateLiteralMember | Generates code for the specified CodeDOM based literal class member representation.
GenerateLiteralStatement | Generates code for the specified CodeDOM based literal statement representation.
GenerateMethod | Generates code for the specified CodeDOM based member method representation.
GenerateMethodInvokeExpression | Generates code for the specified CodeDOM based method invoke expression representation.
GenerateMethodInvokeStatement | Generates code for the specified CodeDOM based method invoke statement representation.
GenerateMethodReturnStatement | Generates code for the specified CodeDOM based method return statement representation.
GenerateNamespace (inherited from CodeGenerator) | Generates code for the specified CodeDOM based namespace representation.
GenerateNamespaceEnd | Generates code for the specified CodeDOM based namespace end representation.
GenerateNamespaceImport | Generates code for the specified CodeDOM based namespace import representation.
GenerateNamespaceImports (inherited from CodeGenerator) | Generates code for the specified CodeDOM based namespace import representation.
GenerateNamespaceStart | Generates code for the specified CodeDOM based namespace start representation.
GenerateObjectCreateExpression | Generates code for the specified CodeDOM based object creation expression representation.
GenerateParameterDeclarationExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based parameter declaration expression representation.
GeneratePrimitiveExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based primitive expression representation.
GenerateProperty | Generates code for the specified CodeDOM based property representation.
GeneratePropertyReferenceExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based property reference expression representation.
GenerateStatement (inherited from CodeGenerator) | Generates code for the specified CodeDOM based statement representation.
GenerateStatements (inherited from CodeGenerator) | Generates code for the specified CodeDOM based statement representations.
GenerateThisReferenceExpression | Generates code for the specified CodeDOM based this reference expression representation.
GenerateThrowExceptionStatement | Generates code for the specified CodeDOM based throw exception statement representation.
GenerateTryCatchFinallyStatement | Generates code for the specified CodeDOM based try catch finally statement representation.
GenerateTypeOfExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based type of expression representation.
GenerateTypeReferenceExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based type reference expression representation.
GenerateVariableDeclarationStatement | Generates code for the specified CodeDOM based variable declaration statement representation.
GetNullToken | Gets the token used to represent a null reference (in Visual Basic Nothing).
GetTypeArrayRank (inherited from CodeGenerator) | [To be supplied.]
GetTypeBaseType (inherited from CodeGenerator) | Gets the base type of the specified type.
IsValidIdentifier | Gets whether the specified value is a valid identifier.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OutputAttributeArgument (inherited from CodeGenerator) | Outputs an argument in a attribute block.
OutputAttributeBlock (inherited from CodeGenerator) | Generates code for the specified CodeAttributeBlock.
OutputDirection (inherited from CodeGenerator) | Generates code for the specified FieldDirection.
OutputExpressionList (inherited from CodeGenerator) | Overloaded. [To be supplied.]
OutputMemberAccessModifier (inherited from CodeGenerator) | Generates code for the specified member access modifier.
OutputMemberScopeModifier (inherited from CodeGenerator) | Generates code for the specified member scope modifier.
OutputOperator (inherited from CodeGenerator) | Generates code for the specified operator.
OutputParameters (inherited from CodeGenerator) | Generates code for the specified parameters.
OutputType | Sets the output type.
OutputTypeAttributes (inherited from CodeGenerator) | Generates code for the specified type attributes.
OutputTypeNamePair (inherited from CodeGenerator) | Generates code for the specified object type and name pair.
QuoteLiteralString | Provides conversion to formatting with escape codes.
QuoteLiteralStringCStyle | Provides conversion to C-style formatting with escape codes.
ValidateIdentifier (inherited from CodeGenerator) | Gets whether the specified identifier is valid.

See Also

CSharpCodeGenerator Class | System.CodeDOM.Compiler Namespace


CSharpCodeGenerator Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CSharpCodeGenerator();
[C++]
public: CSharpCodeGenerator();
[JScript]
public function CSharpCodeGenerator();

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CSharpCodeGenerator Properties

The properties of the CSharpCodeGenerator class are listed below. For a complete list of CSharpCodeGenerator class members, see the CSharpCodeGenerator Members topic.

Protected:

CurrentClassName (inherited from CodeGenerator) | Gets or sets the current class name.
CurrentMember (inherited from CodeGenerator) | Gets or sets the current member of the class.
CurrentMemberName (inherited from CodeGenerator) | Gets or sets the current member name.
CurrentNamespace (inherited from CodeGenerator) | Gets or sets the name of the current namespace.
FileExtension | Gets or sets the file extension.
Indent (inherited from CodeGenerator) | Gets or sets the amount of spaces to indent.
IsCurrentClass (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current class.
IsCurrentDelegate (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current delegate.
IsCurrentEnum (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current enumeration.
IsCurrentInterface (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current interface.
IsCurrentStruct (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current structure.
Output (inherited from CodeGenerator) | Gets or sets the TextWriter to use for output.
SupportsAdvanced (inherited from CodeCompiler) | [To be supplied.]

See Also

CSharpCodeGenerator Class | System.CodeDOM.Compiler Namespace


CSharpCodeGenerator.FileExtension

Gets or sets the file extension.

[Visual Basic]
Overridable Protected ReadOnly Property FileExtension As String
[C#]
protected string FileExtension {override get;}
[C++]
protected: __property virtual String* get_FileExtension();
[JScript]
protected function get FileExtension() : String;

Property Value

The file exension.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CSharpCodeGenerator Methods

The methods of the CSharpCodeGenerator class are listed below. For a complete list of CSharpCodeGenerator class members, see the CSharpCodeGenerator Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
FromDOM (inherited from CodeCompiler) | [To be supplied.]
FromDOMBatch (inherited from CodeCompiler) | [To be supplied.]
FromFile (inherited from CodeCompiler) | [To be supplied.]
FromFileBatch | Gets the compiler results after compiling the specified batch of files using the specified compiler parameters.
FromSource (inherited from CodeCompiler) | [To be supplied.]
FromSourceBatch (inherited from CodeCompiler) | [To be supplied.]
GenerateArrayCreateExpression | Generates code for the specified CodeDOM based array creation expression representation.
GenerateAssignStatement | Generates code for the specified CodeDOM based assignment statement representation.
GenerateAttributeBlockEnd | Generates code for the specified CodeDOM based attribute block end representation.
GenerateAttributeBlockStart | Generates code for the specified CodeDOM based attribute block start representation.
GenerateBaseReferenceExpression | Generates code for the specified CodeDOM based base reference expression representation.
GenerateBinaryOperatorExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based binary operator expression representation.
GenerateCastExpression | Generates code for the specified CodeDOM based cast expression representation.
GenerateClassConstructor | Generates code for the specified CodeDOM based class constructor representation.
GenerateClassEnd | Generates code for the specified CodeDOM based class end representation.
GenerateClasses (inherited from CodeGenerator) | Generates classes using CodeDOM representation for the specified namespace.
GenerateClassStart | Generates code for the specified CodeDOM based class start representation.
GenerateCommentStatement | Generates code for the specified CodeDOM based comment statement representation.
GenerateConstructor | Generates code for the specified CodeDOM based constructor representation.
GenerateDelegateCreateExpression | Generates code for the specified CodeDOM based delegate creation expression representation.
GenerateDelegateInvokeExpression | Generates code for the specified CodeDOM based delegate invoke expression representation.
GenerateDelegateInvokeStatement | Generates code for the specified CodeDOM based delegate invoke statement representation.
GenerateExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based code expression.
GenerateField | Generates code for the specified CodeDOM based field representation.
GenerateFieldReferenceExpression | Generates code for the specified CodeDOM based field reference expression representation.
GenerateForLoopStatement | Generates code for the specified CodeDOM based for loop statement representation.
GenerateIfStatement | Generates code for the specified CodeDOM based if statement representation.
GenerateIndexerExpression | Generates code for the specified CodeDOM based indexer expression representation.
GenerateLinePragmaEnd | Generates code for the specified CodeDOM based line pragma end representation.
GenerateLinePragmaStart | Generates code for the specified CodeDOM based line pragma start representation.
GenerateLiteralExpression | Generates code for the specified CodeDOM based literal expression representation.
GenerateLiteralMember | Generates code for the specified CodeDOM based literal class member representation.
GenerateLiteralStatement | Generates code for the specified CodeDOM based literal statement representation.
GenerateMethod | Generates code for the specified CodeDOM based member method representation.
GenerateMethodInvokeExpression | Generates code for the specified CodeDOM based method invoke expression representation.
GenerateMethodInvokeStatement | Generates code for the specified CodeDOM based method invoke statement representation.
GenerateMethodReturnStatement | Generates code for the specified CodeDOM based method return statement representation.
GenerateNamespace (inherited from CodeGenerator) | Generates code for the specified CodeDOM based namespace representation.
GenerateNamespaceEnd | Generates code for the specified CodeDOM based namespace end representation.
GenerateNamespaceImport | Generates code for the specified CodeDOM based namespace import representation.
GenerateNamespaceImports (inherited from CodeGenerator) | Generates code for the specified CodeDOM based namespace import representation.
GenerateNamespaceStart | Generates code for the specified CodeDOM based namespace start representation.
GenerateObjectCreateExpression | Generates code for the specified CodeDOM based object creation expression representation.
GenerateParameterDeclarationExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based parameter declaration expression representation.
GeneratePrimitiveExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based primitive expression representation.
GenerateProperty | Generates code for the specified CodeDOM based property representation.
GeneratePropertyReferenceExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based property reference expression representation.
GenerateStatement (inherited from CodeGenerator) | Generates code for the specified CodeDOM based statement representation.
GenerateStatements (inherited from CodeGenerator) | Generates code for the specified CodeDOM based statement representations.
GenerateThisReferenceExpression | Generates code for the specified CodeDOM based this reference expression representation.
GenerateThrowExceptionStatement | Generates code for the specified CodeDOM based throw exception statement representation.
GenerateTryCatchFinallyStatement | Generates code for the specified CodeDOM based try catch finally statement representation.
GenerateTypeOfExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based type of expression representation.
GenerateTypeReferenceExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based type reference expression representation.
GenerateVariableDeclarationStatement | Generates code for the specified CodeDOM based variable declaration statement representation.
GetNullToken | Gets the token used to represent a null reference (in Visual Basic Nothing).
GetTypeArrayRank (inherited from CodeGenerator) | [To be supplied.]
GetTypeBaseType (inherited from CodeGenerator) | Gets the base type of the specified type.
IsValidIdentifier | Gets whether the specified value is a valid identifier.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OutputAttributeArgument (inherited from CodeGenerator) | Outputs an argument in a attribute block.
OutputAttributeBlock (inherited from CodeGenerator) | Generates code for the specified CodeAttributeBlock.
OutputDirection (inherited from CodeGenerator) | Generates code for the specified FieldDirection.
OutputExpressionList (inherited from CodeGenerator) | Overloaded. [To be supplied.]
OutputMemberAccessModifier (inherited from CodeGenerator) | Generates code for the specified member access modifier.
OutputMemberScopeModifier (inherited from CodeGenerator) | Generates code for the specified member scope modifier.
OutputOperator (inherited from CodeGenerator) | Generates code for the specified operator.
OutputParameters (inherited from CodeGenerator) | Generates code for the specified parameters.
OutputType | Sets the output type.
OutputTypeAttributes (inherited from CodeGenerator) | Generates code for the specified type attributes.
OutputTypeNamePair (inherited from CodeGenerator) | Generates code for the specified object type and name pair.
QuoteLiteralString | Provides conversion to formatting with escape codes.
QuoteLiteralStringCStyle | Provides conversion to C-style formatting with escape codes.
ValidateIdentifier (inherited from CodeGenerator) | Gets whether the specified identifier is valid.

See Also

CSharpCodeGenerator Class | System.CodeDOM.Compiler Namespace


CSharpCodeGenerator.FromFileBatch

Gets the compiler results after compiling the specified batch of files using the specified compiler parameters.

[Visual Basic]
Overrides Protected Function FromFileBatch( _
   ByVal options As CompilerParameters, _
   ByVal fileNames() As String _
) As CompilerResults
[C#]
protected override CompilerResults FromFileBatch(
   CompilerParameters options,
   string[] fileNames
);
[C++]
protected: override CompilerResults* FromFileBatch(
   CompilerParameters* options,
   String* fileNames[]
);
[JScript]
protected override function FromFileBatch(
   options : CompilerParameters,
   fileNames : String[]
) : CompilerResults;

Parameters

options
A CompilerParameters that indicates the options to compile with.
fileNames
[To be supplied.]

Return Value

A CompilerResults that indicates the results of compilation.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace


CSharpCodeGenerator.GenerateArrayCreateExpression

Generates code for the specified CodeDOM based array creation expression representation.

[Visual Basic]
Overrides Protected Sub GenerateArrayCreateExpression( _
   ByVal e As CodeArrayCreateExpression _
)
[C#]
protected override void GenerateArrayCreateExpression(
   CodeArrayCreateExpression e
);
[C++]
protected: override void GenerateArrayCreateExpression(
   CodeArrayCreateExpression* e
);
[JScript]
protected override function GenerateArrayCreateExpression(
   e : CodeArrayCreateExpression
);

Parameters

e
A CodeArrayCreateExpression that indicates the expression to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeArrayCreateExpression


CSharpCodeGenerator.GenerateAssignStatement

Generates code for the specified CodeDOM based assignment statement representation.

[Visual Basic]
Overrides Protected Sub GenerateAssignStatement( _
   ByVal e As CodeAssignStatement _
)
[C#]
protected override void GenerateAssignStatement(
   CodeAssignStatement e
);
[C++]
protected: override void GenerateAssignStatement(
   CodeAssignStatement* e
);
[JScript]
protected override function GenerateAssignStatement(
   e : CodeAssignStatement
);

Parameters

e
A CodeAssignStatement that indicates the statement to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeAssignStatement


CSharpCodeGenerator.GenerateAttributeBlockEnd

Generates code for the specified CodeDOM based attribute block end representation.

[Visual Basic]
Overrides Protected Sub GenerateAttributeBlockEnd( _
   ByVal attributes As CodeAttributeBlock _
)
[C#]
protected override void GenerateAttributeBlockEnd(
   CodeAttributeB attributes
);
[C++]
protected: override void GenerateAttributeBlockEnd(
   CodeAttributeBlock* attributes
);
[JScript]
protected override function GenerateAttributeBlockEnd(
   attributes : CodeAttributeBlock
);

Parameters

attributes
A CodeAttributeBlock that indicates the expression to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeAttributeBlock


CSharpCodeGenerator.GenerateAttributeBlockStart

Generates code for the specified CodeDOM based attribute block start representation.

[Visual Basic]
Overrides Protected Sub GenerateAttributeBlockStart( _
   ByVal attributes As CodeAttributeBlock _
)
[C#]
protected override void GenerateAttributeBlockStart(
   CodeAttributeB attributes
);
[C++]
protected: override void GenerateAttributeBlockStart(
   CodeAttributeBlock* attributes
);
[JScript]
protected override function GenerateAttributeBlockStart(
   attributes : CodeAttributeBlock
);

Parameters

attributes
[To be supplied.]

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeAttributeBlock


CSharpCodeGenerator.GenerateBaseReferenceExpression

Generates code for the specified CodeDOM based base reference expression representation.

[Visual Basic]
Overrides Protected Sub GenerateBaseReferenceExpression( _
   ByVal e As CodeBaseReferenceExpression _
)
[C#]
protected override void GenerateBaseReferenceExpression(
   CodeBaseReferenceExpression e
);
[C++]
protected: override void GenerateBaseReferenceExpression(
   CodeBaseReferenceExpression* e
);
[JScript]
protected override function GenerateBaseReferenceExpression(
   e : CodeBaseReferenceExpression
);

Parameters

e
A CodeBaseReferenceExpression that indicates the expression to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeBaseReferenceExpression


CSharpCodeGenerator.GenerateCastExpression

Generates code for the specified CodeDOM based cast expression representation.

[Visual Basic]
Overrides Protected Sub GenerateCastExpression( _
   ByVal e As CodeCastExpression _
)
[C#]
protected override void GenerateCastExpression(
   CodeCastExpression e
);
[C++]
protected: override void GenerateCastExpression(
   CodeCastExpression* e
);
[JScript]
protected override function GenerateCastExpression(
   e : CodeCastExpression
);

Parameters

e
A CodeCastExpression that indicates the expression to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeCastExpression


CSharpCodeGenerator.GenerateClassConstructor

Generates code for the specified CodeDOM based class constructor representation.

[Visual Basic]
Overrides Protected Sub GenerateClassConstructor( _
   ByVal e As CodeClassConstructor _
)
[C#]
protected override void GenerateClassConstructor(
   CodeClassConstructor e
);
[C++]
protected: override void GenerateClassConstructor(
   CodeClassConstructor* e
);
[JScript]
protected override function GenerateClassConstructor(
   e : CodeClassConstructor
);

Parameters

e
A CodeClassConstructor that indicates the class constructor to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeClassConstructor


CSharpCodeGenerator.GenerateClassEnd

Generates code for the specified CodeDOM based class end representation.

[Visual Basic]
Overrides Protected Sub GenerateClassEnd( _
   ByVal e As CodeClass _
)
[C#]
protected override void GenerateClassEnd(
   CodeClass e
);
[C++]
protected: override void GenerateClassEnd(
   CodeClass* e
);
[JScript]
protected override function GenerateClassEnd(
   e : CodeClass
);

Parameters

e
A CodeClass that indicates the end class.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeClass


CSharpCodeGenerator.GenerateClassStart

Generates code for the specified CodeDOM based class start representation.

[Visual Basic]
Overrides Protected Sub GenerateClassStart( _
   ByVal e As CodeClass _
)
[C#]
protected override void GenerateClassStart(
   CodeClass e
);
[C++]
protected: override void GenerateClassStart(
   CodeClass* e
);
[JScript]
protected override function GenerateClassStart(
   e : CodeClass
);

Parameters

e
A CodeClass that indicates the start class.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeClass


CSharpCodeGenerator.GenerateCommentStatement

Generates code for the specified CodeDOM based comment statement representation.

[Visual Basic]
Overrides Protected Sub GenerateCommentStatement( _
   ByVal e As CodeCommentStatement _
)
[C#]
protected override void GenerateCommentStatement(
   CodeCommentStatement e
);
[C++]
protected: override void GenerateCommentStatement(
   CodeCommentStatement* e
);
[JScript]
protected override function GenerateCommentStatement(
   e : CodeCommentStatement
);

Parameters

e
A CodeCommentStatement that indicates the statement to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeCommentStatement


CSharpCodeGenerator.GenerateConstructor

Generates code for the specified CodeDOM based constructor representation.

[Visual Basic]
Overrides Protected Sub GenerateConstructor( _
   ByVal e As CodeConstructor _
)
[C#]
protected override void GenerateConstructor(
   CodeConstructor e
);
[C++]
protected: override void GenerateConstructor(
   CodeConstructor* e
);
[JScript]
protected override function GenerateConstructor(
   e : CodeConstructor
);

Parameters

e
A CodeConstructor that indicates the expression to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeConstructor


CSharpCodeGenerator.GenerateDelegateCreateExpression

Generates code for the specified CodeDOM based delegate creation expression representation.

[Visual Basic]
Overrides Protected Sub GenerateDelegateCreateExpression( _
   ByVal e As CodeDelegateCreateExpression _
)
[C#]
protected override void GenerateDelegateCreateExpression(
   CodeDelegateCreateExpression e
);
[C++]
protected: override void GenerateDelegateCreateExpression(
   CodeDelegateCreateExpression* e
);
[JScript]
protected override function GenerateDelegateCreateExpression(
   e : CodeDelegateCreateExpression
);

Parameters

e
A CodeDelegateCreateExpression that indicates the expression to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeDelegateCreateExpression


CSharpCodeGenerator.GenerateDelegateInvokeExpression

Generates code for the specified CodeDOM based delegate invoke expression representation.

[Visual Basic]
Overrides Protected Sub GenerateDelegateInvokeExpression( _
   ByVal e As CodeDelegateInvokeExpression _
)
[C#]
protected override void GenerateDelegateInvokeExpression(
   CodeDelegateInvokeExpression e
);
[C++]
protected: override void GenerateDelegateInvokeExpression(
   CodeDelegateInvokeExpression* e
);
[JScript]
protected override function GenerateDelegateInvokeExpression(
   e : CodeDelegateInvokeExpression
);

Parameters

e
A CodeDelegateInvokeExpression that indicates the expression to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeDelegateInvokeExpression


CSharpCodeGenerator.GenerateDelegateInvokeStatement

Generates code for the specified CodeDOM based delegate invoke statement representation.

[Visual Basic]
Overrides Protected Sub GenerateDelegateInvokeStatement( _
   ByVal e As CodeDelegateInvokeStatement _
)
[C#]
protected override void GenerateDelegateInvokeStatement(
   CodeDelegateInvokeStatement e
);
[C++]
protected: override void GenerateDelegateInvokeStatement(
   CodeDelegateInvokeStatement* e
);
[JScript]
protected override function GenerateDelegateInvokeStatement(
   e : CodeDelegateInvokeStatement
);

Parameters

e
A CodeDelegateInvokeStatement that indicates the statement to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeDelegateInvokeStatement


CSharpCodeGenerator.GenerateField

Generates code for the specified CodeDOM based field representation.

[Visual Basic]
Overrides Protected Sub GenerateField( _
   ByVal e As CodeMemberField _
)
[C#]
protected override void GenerateField(
   CodeMemberField e
);
[C++]
protected: override void GenerateField(
   CodeMemberField* e
);
[JScript]
protected override function GenerateField(
   e : CodeMemberField
);

Parameters

e
A CodeMemberField that indicates the expression to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeMemberField


CSharpCodeGenerator.GenerateFieldReferenceExpression

Generates code for the specified CodeDOM based field reference expression representation.

[Visual Basic]
Overrides Protected Sub GenerateFieldReferenceExpression( _
   ByVal e As CodeFieldReferenceExpression _
)
[C#]
protected override void GenerateFieldReferenceExpression(
   CodeFieldReferenceExpression e
);
[C++]
protected: override void GenerateFieldReferenceExpression(
   CodeFieldReferenceExpression* e
);
[JScript]
protected override function GenerateFieldReferenceExpression(
   e : CodeFieldReferenceExpression
);

Parameters

e
A CodeFieldReferenceExpression that indicates the expression to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeFieldReferenceExpression


CSharpCodeGenerator.GenerateForLoopStatement

Generates code for the specified CodeDOM based for loop statement representation.

[Visual Basic]
Overrides Protected Sub GenerateForLoopStatement( _
   ByVal e As CodeForLoopStatement _
)
[C#]
protected override void GenerateForLoopStatement(
   CodeForLoopStatement e
);
[C++]
protected: override void GenerateForLoopStatement(
   CodeForLoopStatement* e
);
[JScript]
protected override function GenerateForLoopStatement(
   e : CodeForLoopStatement
);

Parameters

e
A CodeForLoopStatement that indicates the statement to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeForLoopStatement


CSharpCodeGenerator.GenerateIfStatement

Generates code for the specified CodeDOM based if statement representation.

[Visual Basic]
Overrides Protected Sub GenerateIfStatement( _
   ByVal e As CodeIfStatement _
)
[C#]
protected override void GenerateIfStatement(
   CodeIfStatement e
);
[C++]
protected: override void GenerateIfStatement(
   CodeIfStatement* e
);
[JScript]
protected override function GenerateIfStatement(
   e : CodeIfStatement
);

Parameters

e
A CodeIfStatement that indicates the statement to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeIfStatement


CSharpCodeGenerator.GenerateIndexerExpression

Generates code for the specified CodeDOM based indexer expression representation.

[Visual Basic]
Overrides Protected Sub GenerateIndexerExpression( _
   ByVal e As CodeIndexerExpression _
)
[C#]
protected override void GenerateIndexerExpression(
   CodeIndexerExpression e
);
[C++]
protected: override void GenerateIndexerExpression(
   CodeIndexerExpression* e
);
[JScript]
protected override function GenerateIndexerExpression(
   e : CodeIndexerExpression
);

Parameters

e
A CodeIndexerExpression that indicates the expression to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeIndexerExpression


CSharpCodeGenerator.GenerateLinePragmaEnd

Generates code for the specified CodeDOM based line pragma end representation.

[Visual Basic]
Overrides Protected Sub GenerateLinePragmaEnd( _
   ByVal e As CodeLinePragma _
)
[C#]
protected override void GenerateLinePragmaEnd(
   CodeLinePragma e
);
[C++]
protected: override void GenerateLinePragmaEnd(
   CodeLinePragma* e
);
[JScript]
protected override function GenerateLinePragmaEnd(
   e : CodeLinePragma
);

Parameters

e
A CodeLinePragma that indicates the expression to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeLinePragma


CSharpCodeGenerator.GenerateLinePragmaStart

Generates code for the specified CodeDOM based line pragma start representation.

[Visual Basic]
Overrides Protected Sub GenerateLinePragmaStart( _
   ByVal e As CodeLinePragma _
)
[C#]
protected override void GenerateLinePragmaStart(
   CodeLinePragma e
);
[C++]
protected: override void GenerateLinePragmaStart(
   CodeLinePragma* e
);
[JScript]
protected override function GenerateLinePragmaStart(
   e : CodeLinePragma
);

Parameters

e
A CodeLinePragma that indicates the expression to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeLinePragma


CSharpCodeGenerator.GenerateLiteralExpression

Generates code for the specified CodeDOM based literal expression representation.

[Visual Basic]
Overrides Protected Sub GenerateLiteralExpression( _
   ByVal e As CodeLiteralExpression _
)
[C#]
protected override void GenerateLiteralExpression(
   CodeLiteralExpression e
);
[C++]
protected: override void GenerateLiteralExpression(
   CodeLiteralExpression* e
);
[JScript]
protected override function GenerateLiteralExpression(
   e : CodeLiteralExpression
);

Parameters

e
A CodeLiteralExpression that indicates the expression to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeLiteralExpression


CSharpCodeGenerator.GenerateLiteralMember

Generates code for the specified CodeDOM based literal class member representation.

[Visual Basic]
Overrides Protected Sub GenerateLiteralMember( _
   ByVal e As CodeLiteralClassMember _
)
[C#]
protected override void GenerateLiteralMember(
   CodeLiteralClassMember e
);
[C++]
protected: override void GenerateLiteralMember(
   CodeLiteralClassMember* e
);
[JScript]
protected override function GenerateLiteralMember(
   e : CodeLiteralClassMember
);

Parameters

e
A CodeLiteralClassMember that indicates the expression to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeLiteralClassMember


CSharpCodeGenerator.GenerateLiteralStatement

Generates code for the specified CodeDOM based literal statement representation.

[Visual Basic]
Overrides Protected Sub GenerateLiteralStatement( _
   ByVal e As CodeLiteralStatement _
)
[C#]
protected override void GenerateLiteralStatement(
   CodeLiteralStatement e
);
[C++]
protected: override void GenerateLiteralStatement(
   CodeLiteralStatement* e
);
[JScript]
protected override function GenerateLiteralStatement(
   e : CodeLiteralStatement
);

Parameters

e
A CodeLiteralStatement that indicates the statement to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeLiteralStatement


CSharpCodeGenerator.GenerateMethod

Generates code for the specified CodeDOM based member method representation.

[Visual Basic]
Overrides Protected Sub GenerateMethod( _
   ByVal e As CodeMemberMethod, _
   ByVal c As CodeClass _
)
[C#]
protected override void GenerateMethod(
   CodeMemberMethod e,
   CodeClass c
);
[C++]
protected: override void GenerateMethod(
   CodeMemberMethod* e,
   CodeClass* c
);
[JScript]
protected override function GenerateMethod(
   e : CodeMemberMethod,
   c : CodeClass
);

Parameters

e
A CodeMemberMethod that indicates the expression to generate code for.
c
[To be supplied.]

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeMemberMethod


CSharpCodeGenerator.GenerateMethodInvokeExpression

Generates code for the specified CodeDOM based method invoke expression representation.

[Visual Basic]
Overrides Protected Sub GenerateMethodInvokeExpression( _
   ByVal e As CodeMethodInvokeExpression _
)
[C#]
protected override void GenerateMethodInvokeExpression(
   CodeMethodInvokeExpression e
);
[C++]
protected: override void GenerateMethodInvokeExpression(
   CodeMethodInvokeExpression* e
);
[JScript]
protected override function GenerateMethodInvokeExpression(
   e : CodeMethodInvokeExpression
);

Parameters

e
A CodeMethodInvokeExpression that indicates the expression to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeMethodInvokeExpression


CSharpCodeGenerator.GenerateMethodInvokeStatement

Generates code for the specified CodeDOM based method invoke statement representation.

[Visual Basic]
Overrides Protected Sub GenerateMethodInvokeStatement( _
   ByVal e As CodeMethodInvokeStatement _
)
[C#]
protected override void GenerateMethodInvokeStatement(
   CodeMethodInvokeStatement e
);
[C++]
protected: override void GenerateMethodInvokeStatement(
   CodeMethodInvokeStatement* e
);
[JScript]
protected override function GenerateMethodInvokeStatement(
   e : CodeMethodInvokeStatement
);

Parameters

e
A CodeMethodInvokeStatement that indicates the statement to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeMethodInvokeStatement


CSharpCodeGenerator.GenerateMethodReturnStatement

Generates code for the specified CodeDOM based method return statement representation.

[Visual Basic]
Overrides Protected Sub GenerateMethodReturnStatement( _
   ByVal e As CodeMethodReturnStatement _
)
[C#]
protected override void GenerateMethodReturnStatement(
   CodeMethodReturnStatement e
);
[C++]
protected: override void GenerateMethodReturnStatement(
   CodeMethodReturnStatement* e
);
[JScript]
protected override function GenerateMethodReturnStatement(
   e : CodeMethodReturnStatement
);

Parameters

e
A CodeMethodReturnStatement that indicates the statement to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeMethodReturnStatement


CSharpCodeGenerator.GenerateNamespaceEnd

Generates code for the specified CodeDOM based namespace end representation.

[Visual Basic]
Overrides Protected Sub GenerateNamespaceEnd( _
   ByVal e As CodeNamespace _
)
[C#]
protected override void GenerateNamespaceEnd(
   CodeNamespace e
);
[C++]
protected: override void GenerateNamespaceEnd(
   CodeNamespace* e
);
[JScript]
protected override function GenerateNamespaceEnd(
   e : CodeNamespace
);

Parameters

e
A CodeNamespace that indicates the expression to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace


CSharpCodeGenerator.GenerateNamespaceImport

Generates code for the specified CodeDOM based namespace import representation.

[Visual Basic]
Overrides Protected Sub GenerateNamespaceImport( _
   ByVal e As CodeNamespaceImport _
)
[C#]
protected override void GenerateNamespaceImport(
   CodeNamespaceImport e
);
[C++]
protected: override void GenerateNamespaceImport(
   CodeNamespaceImport* e
);
[JScript]
protected override function GenerateNamespaceImport(
   e : CodeNamespaceImport
);

Parameters

e
A CodeNamespaceImport that indicates the expression to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeNamespaceImport


CSharpCodeGenerator.GenerateNamespaceStart

Generates code for the specified CodeDOM based namespace start representation.

[Visual Basic]
Overrides Protected Sub GenerateNamespaceStart( _
   ByVal e As CodeNamespace _
)
[C#]
protected override void GenerateNamespaceStart(
   CodeNamespace e
);
[C++]
protected: override void GenerateNamespaceStart(
   CodeNamespace* e
);
[JScript]
protected override function GenerateNamespaceStart(
   e : CodeNamespace
);

Parameters

e
A CodeNamespace that indicates the expression to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeNamespace


CSharpCodeGenerator.GenerateObjectCreateExpression

Generates code for the specified CodeDOM based object creation expression representation.

[Visual Basic]
Overrides Protected Sub GenerateObjectCreateExpression( _
   ByVal e As CodeObjectCreateExpression _
)
[C#]
protected override void GenerateObjectCreateExpression(
   CodeObjectCreateExpression e
);
[C++]
protected: override void GenerateObjectCreateExpression(
   CodeObjectCreateExpression* e
);
[JScript]
protected override function GenerateObjectCreateExpression(
   e : CodeObjectCreateExpression
);

Parameters

e
A CodeObjectCreateExpression that indicates the expression to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeObjectCreateExpression


CSharpCodeGenerator.GenerateProperty

Generates code for the specified CodeDOM based property representation.

[Visual Basic]
Overrides Protected Sub GenerateProperty( _
   ByVal e As CodeMemberProperty, _
   ByVal c As CodeClass _
)
[C#]
protected override void GenerateProperty(
   CodeMemberProperty e,
   CodeClass c
);
[C++]
protected: override void GenerateProperty(
   CodeMemberProperty* e,
   CodeClass* c
);
[JScript]
protected override function GenerateProperty(
   e : CodeMemberProperty,
   c : CodeClass
);

Parameters

e
A CodeMemberProperty that indicates the property to generate code for.
c
[To be supplied.]

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeMemberProperty


CSharpCodeGenerator.GenerateThisReferenceExpression

Generates code for the specified CodeDOM based this reference expression representation.

[Visual Basic]
Overrides Protected Sub GenerateThisReferenceExpression( _
   ByVal e As CodeThisReferenceExpression _
)
[C#]
protected override void GenerateThisReferenceExpression(
   CodeThisReferenceExpression e
);
[C++]
protected: override void GenerateThisReferenceExpression(
   CodeThisReferenceExpression* e
);
[JScript]
protected override function GenerateThisReferenceExpression(
   e : CodeThisReferenceExpression
);

Parameters

e
A CodeThisReferenceExpression that indicates the expression to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeThisReferenceExpression


CSharpCodeGenerator.GenerateThrowExceptionStatement

Generates code for the specified CodeDOM based throw exception statement representation.

[Visual Basic]
Overrides Protected Sub GenerateThrowExceptionStatement( _
   ByVal e As CodeThrowExceptionStatement _
)
[C#]
protected override void GenerateThrowExceptionStatement(
   CodeThrowExceptionStatement e
);
[C++]
protected: override void GenerateThrowExceptionStatement(
   CodeThrowExceptionStatement* e
);
[JScript]
protected override function GenerateThrowExceptionStatement(
   e : CodeThrowExceptionStatement
);

Parameters

e
A CodeThrowExceptionStatement that indicates the statement to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeThrowExceptionStatement


CSharpCodeGenerator.GenerateTryCatchFinallyStatement

Generates code for the specified CodeDOM based try catch finally statement representation.

[Visual Basic]
Overrides Protected Sub GenerateTryCatchFinallyStatement( _
   ByVal e As CodeTryCatchFinallyStatement _
)
[C#]
protected override void GenerateTryCatchFinallyStatement(
   CodeTryCatchFinallyStatement e
);
[C++]
protected: override void GenerateTryCatchFinallyStatement(
   CodeTryCatchFinallyStatement* e
);
[JScript]
protected override function GenerateTryCatchFinallyStatement(
   e : CodeTryCatchFinallyStatement
);

Parameters

e
A CodeTryCatchFinallyStatement that indicates the statement to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeTryCatchFinallyStatement


CSharpCodeGenerator.GenerateVariableDeclarationStatement

Generates code for the specified CodeDOM based variable declaration statement representation.

[Visual Basic]
Overrides Protected Sub GenerateVariableDeclarationStatement( _
   ByVal e As CodeVariableDeclarationStatement _
)
[C#]
protected override void GenerateVariableDeclarationStatement(
   CodeVariableDeclarationStatement e
);
[C++]
protected: override void GenerateVariableDeclarationStatement(
   CodeVariableDeclarationStatement* e
);
[JScript]
protected override function GenerateVariableDeclarationStatement(
   e : CodeVariableDeclarationStatement
);

Parameters

e
A CodeVariableDeclarationStatement that indicates the statement to generate code for.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeVariableDeclarationStatement


CSharpCodeGenerator.GetNullToken

Gets the token used to represent a null reference (in Visual Basic Nothing).

[Visual Basic]
Overrides Protected Function GetNullToken() As String
[C#]
protected override string GetNullToken();
[C++]
protected: override String* GetNullToken();
[JScript]
protected override function GetNullToken() : String;

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace


CSharpCodeGenerator.IsValidIdentifier

Gets whether the specified value is a valid identifier.

[Visual Basic]
Overrides Protected Function IsValidIdentifier( _
   ByVal value As String _
) As Boolean
[C#]
protected override bool IsValidIdentifier(
   string value
);
[C++]
protected: override bool IsValidIdentifier(
   String* value
);
[JScript]
protected override function IsValidIdentifier(
   value : String
) : Boolean;

Parameters

value
The value to test for validity as an identifier.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace


CSharpCodeGenerator.OutputType

Sets the output type.

[Visual Basic]
Overrides Protected Sub OutputType( _
   ByVal typeRef As String _
)
[C#]
protected override void OutputType(
   string typeRef
);
[C++]
protected: override void OutputType(
   String* typeRef
);
[JScript]
protected override function OutputType(
   typeRef : String
);

Parameters

typeRef
The name of the type to output.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace


CSharpCodeGenerator.QuoteLiteralString

Provides conversion to formatting with escape codes.

[Visual Basic]
Overrides Protected Function QuoteLiteralString( _
   ByVal value As String, _
   ByVal escapeUnicode As Boolean _
) As String
[C#]
protected override string QuoteLiteralString(
   string value,
   bool escapeUnicode
);
[C++]
protected: override String* QuoteLiteralString(
   String* value,
   bool escapeUnicode
);
[JScript]
protected override function QuoteLiteralString(
   value : String,
   escapeUnicode : Boolean
) : String;

Parameters

value
The string to convert.
escapeUnicode
[To be supplied.]

Return Value

The converted string.

Remarks

If the value of escapeUnicode is set to true, character values above 80 will be converted to use escape code formatting.

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace


CSharpCodeGenerator.QuoteLiteralStringCStyle

Provides conversion to C-style formatting with escape codes.

[Visual Basic]
Protected Function QuoteLiteralStringCStyle( _
   ByVal value As String, _
   ByVal escapeUnicode As Boolean _
) As String
[C#]
protected string QuoteLiteralStringCStyle(
   string value,
   bool escapeUnicode
);
[C++]
protected: String* QuoteLiteralStringCStyle(
   String* value,
   bool escapeUnicode
);
[JScript]
protected function QuoteLiteralStringCStyle(
   value : String,
   escapeUnicode : Boolean
) : String;

Parameters

value
[To be supplied.]
escapeUnicode
[To be supplied.]

See Also

CSharpCodeGenerator Class | CSharpCodeGenerator Members | System.CodeDOM.Compiler Namespace


Executor Class

Provides command execution functions for the CodeDOM compiler.

Object
Executor

[Visual Basic]
NotInheritable Public Class Executor
[C#]
public sealed class Executor
[C++]
public __gc __sealed class Executor
[JScript]
public class Executor

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM.Compiler

Assembly: System.dll

See Also

Executor Members | System.CodeDOM.Compiler Namespace


Executor Members

Public:

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
ExecWait | [To be supplied.]
ExecWaitWithCapture | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRuntimeInstallDirectory | Gets the runtime install directory.
GetSDKInstallDirectory | Gets the SDK install directory.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Executor Class | System.CodeDOM.Compiler Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Executor Methods

The methods of the Executor class are listed below. For a complete list of Executor class members, see the Executor Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
ExecWait | [To be supplied.]
ExecWaitWithCapture | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRuntimeInstallDirectory | Gets the runtime install directory.
GetSDKInstallDirectory | Gets the SDK install directory.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Executor Class | System.CodeDOM.Compiler Namespace


Executor.ExecWait

[To be supplied.]

[Visual Basic]
Public Shared Sub ExecWait( _
   ByVal cmd As String, _
   ByVal tempFiles As TempFiles _
)
[C#]
public static void ExecWait(
   string cmd,
   TempFiles tempFiles
);
[C++]
public: static void ExecWait(
   String* cmd,
   TempFiles* tempFiles
);
[JScript]
public static function ExecWait(
   cmd : String,
   tempFiles : TempFiles
);

Parameters

cmd
[To be supplied.]
tempFiles
[To be supplied.]

See Also

Executor Class | Executor Members | System.CodeDOM.Compiler Namespace


Executor.ExecWaitWithCapture

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ExecWaitWithCapture(String, String, TempFiles, String, String) As Integer
[C#] public static int ExecWaitWithCapture(String, String, TempFiles, String, String);
[C++] public: static int ExecWaitWithCapture(String*, String*, TempFiles, String*, String*);
[JScript] public static function ExecWaitWithCapture(String, String, TempFiles, String, String) : int;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ExecWaitWithCapture(String, TempFiles, String, String) As Integer
[C#] public static int ExecWaitWithCapture(String, TempFiles, String, String);
[C++] public: static int ExecWaitWithCapture(String*, TempFiles, String*, String*);
[JScript] public static function ExecWaitWithCapture(String, TempFiles, String, String) : int;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ExecWaitWithCapture(Integer, String, String, TempFiles, String, String) As Integer
[C#] public static int ExecWaitWithCapture(int, String, String, TempFiles, String, String);
[C++] public: static int ExecWaitWithCapture(int, String, String, TempFiles, String, String);
[JScript] public static function ExecWaitWithCapture(int, String, String, TempFiles, String, String) : int;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ExecWaitWithCapture(Integer, String, TempFiles, String, String) As Integer
[C#] public static int ExecWaitWithCapture(int, String, TempFiles, String, String);
[C++] public: static int ExecWaitWithCapture(int, String, TempFiles, String, String);
[JScript] public static function ExecWaitWithCapture(int, String, TempFiles, String, String) : int;

See Also

Executor Class | Executor Members | System.CodeDOM.Compiler Namespace


Executor.ExecWaitWithCapture (String, String, TempFiles, String, String)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ExecWaitWithCapture( _
   ByVal cmd As String, _
   ByVal currentDir As String, _
   ByVal tempFiles As TempFiles, _
   ByRef outputName As String, _
   ByRef errorName As String _
) As Integer
[C#]
public static int ExecWaitWithCapture(
   string cmd,
   string currentDir,
   TempFiles tempFiles,
   ref string outputName,
   ref string errorName
);
[C++]
public: static int ExecWaitWithCapture(
   String* cmd,
   String* currentDir,
   TempFiles* tempFiles,
   String** outputName,
   String** errorName
);
[JScript]
public static function ExecWaitWithCapture(
   cmd : String,
   currentDir : String,
   tempFiles : TempFiles,
   outputName : String,
   errorName : String
) : int;

Parameters

cmd
[To be supplied.]
currentDir
[To be supplied.]
tempFiles
[To be supplied.]
outputName
[To be supplied.]
errorName
[To be supplied.]

See Also

Executor Class | Executor Members | System.CodeDOM.Compiler Namespace | Executor.ExecWaitWithCapture Overload List


Executor.ExecWaitWithCapture (String, TempFiles, String, String)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ExecWaitWithCapture( _
   ByVal cmd As String, _
   ByVal tempFiles As TempFiles, _
   ByRef outputName As String, _
   ByRef errorName As String _
) As Integer
[C#]
public static int ExecWaitWithCapture(
   string cmd,
   TempFiles tempFiles,
   ref string outputName,
   ref string errorName
);
[C++]
public: static int ExecWaitWithCapture(
   String* cmd,
   TempFiles* tempFiles,
   String** outputName,
   String** errorName
);
[JScript]
public static function ExecWaitWithCapture(
   cmd : String,
   tempFiles : TempFiles,
   outputName : String,
   errorName : String
) : int;

Parameters

cmd
[To be supplied.]
tempFiles
[To be supplied.]
outputName
[To be supplied.]
errorName
[To be supplied.]

See Also

Executor Class | Executor Members | System.CodeDOM.Compiler Namespace | Executor.ExecWaitWithCapture Overload List


Executor.ExecWaitWithCapture (Int32, String, String, TempFiles, String, String)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ExecWaitWithCapture( _
   ByVal userToken As Integer, _
   ByVal cmd As String, _
   ByVal currentDir As String, _
   ByVal tempFiles As TempFiles, _
   ByRef outputName As String, _
   ByRef errorName As String _
) As Integer
[C#]
public static int ExecWaitWithCapture(
   int userToken,
   string cmd,
   string currentDir,
   TempFiles tempFiles,
   ref string outputName,
   ref string errorName
);
[C++]
public: static int ExecWaitWithCapture(
   int userToken,
   String* cmd,
   String* currentDir,
   TempFiles* tempFiles,
   String** outputName,
   String** errorName
);
[JScript]
public static function ExecWaitWithCapture(
   userToken : int,
   cmd : String,
   currentDir : String,
   tempFiles : TempFiles,
   outputName : String,
   errorName : String
) : int;

Parameters

userToken
[To be supplied.]
cmd
[To be supplied.]
currentDir
[To be supplied.]
tempFiles
[To be supplied.]
outputName
[To be supplied.]
errorName
[To be supplied.]

See Also

Executor Class | Executor Members | System.CodeDOM.Compiler Namespace | Executor.ExecWaitWithCapture Overload List


Executor.ExecWaitWithCapture (Int32, String, TempFiles, String, String)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ExecWaitWithCapture( _
   ByVal userToken As Integer, _
   ByVal cmd As String, _
   ByVal tempFiles As TempFiles, _
   ByRef outputName As String, _
   ByRef errorName As String _
) As Integer
[C#]
public static int ExecWaitWithCapture(
   int userToken,
   string cmd,
   TempFiles tempFiles,
   ref string outputName,
   ref string errorName
);
[C++]
public: static int ExecWaitWithCapture(
   int userToken,
   String* cmd,
   TempFiles* tempFiles,
   String** outputName,
   String** errorName
);
[JScript]
public static function ExecWaitWithCapture(
   userToken : int,
   cmd : String,
   tempFiles : TempFiles,
   outputName : String,
   errorName : String
) : int;

Parameters

userToken
[To be supplied.]
cmd
[To be supplied.]
tempFiles
[To be supplied.]
outputName
[To be supplied.]
errorName
[To be supplied.]

See Also

Executor Class | Executor Members | System.CodeDOM.Compiler Namespace | Executor.ExecWaitWithCapture Overload List


Executor.GetRuntimeInstallDirectory

Gets the runtime install directory.

[Visual Basic]
Public Shared Function GetRuntimeInstallDirectory() As String
[C#]
public static string GetRuntimeInstallDirectory();
[C++]
public: static String* GetRuntimeInstallDirectory();
[JScript]
public static function GetRuntimeInstallDirectory() : String;

Return Value

The runtime install directory.

See Also

Executor Class | Executor Members | System.CodeDOM.Compiler Namespace


Executor.GetSDKInstallDirectory

Gets the SDK install directory.

[Visual Basic]
Public Shared Function GetSDKInstallDirectory() As String
[C#]
public static string GetSDKInstallDirectory();
[C++]
public: static String* GetSDKInstallDirectory();
[JScript]
public static function GetSDKInstallDirectory() : String;

Return Value

The SDK install directory.

See Also

Executor Class | Executor Members | System.CodeDOM.Compiler Namespace


IBatchCompiler Interface

Provides methods to invoke batch compilation.

[Visual Basic]
Public Interface IBatchCompiler
   Implements ICodeCompiler, ICodeGenerator
[C#]
public interface IBatchCompiler : ICodeCompiler, ICodeGenerator
[C++]
public __gc __interface IBatchCompiler : public ICodeCompiler,
   ICodeGenerator

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IBatchCompiler

Class | Description
CodeCompiler | Base class for CodeCompilers. This is a useful utility baseclass for CodeGenerators to derive from.

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM.Compiler

Assembly: System.dll

See Also

IBatchCompiler Members | System.CodeDOM.Compiler Namespace


IBatchCompiler Members

Methods

CompileAssemblyFromDOMBatch | Compiles an assembly based on the specified options and information.
CompileAssemblyFromFileBatch | Compiles an assembly based on the specified options and contents of the specified filenames.
CompileAssemblyFromSourceBatch | Compiles an assembly based on the specified options and information from the specified sources.

See Also

IBatchCompiler Interface | System.CodeDOM.Compiler Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IBatchCompiler Methods

The methods of the IBatchCompiler interface are listed below. For a complete list of IBatchCompiler interface members, see the IBatchCompiler Members topic.

CompileAssemblyFromDOMBatch | Compiles an assembly based on the specified options and information.
CompileAssemblyFromFileBatch | Compiles an assembly based on the specified options and contents of the specified filenames.
CompileAssemblyFromSourceBatch | Compiles an assembly based on the specified options and information from the specified sources.

See Also

IBatchCompiler Interface | System.CodeDOM.Compiler Namespace


IBatchCompiler.CompileAssemblyFromDOMBatch

Compiles an assembly based on the specified options and information.

[Visual Basic]
Function CompileAssemblyFromDOMBatch( _
   ByVal options As CompilerParameters, _
   ByVal ea() As CodeNamespace _
) As CompilerResults
[C#]
CompilerResults CompileAssemblyFromDOMBatch(
   CompilerParameters options,
   CodeNamespace[] ea
);
[C++]
CompilerResults* CompileAssemblyFromDOMBatch(
   CompilerParameters* options,
   CodeNamespace* ea[]
) = 0;
[JScript]
function CompileAssemblyFromDOMBatch(
   options : CompilerParameters,
   ea : CodeNamespace[]
) : CompilerResults;

Parameters

options
A CompilerParameters that indicates the options to compile with.
ea
[To be supplied.]

See Also

IBatchCompiler Interface | IBatchCompiler Members | System.CodeDOM.Compiler Namespace


IBatchCompiler.CompileAssemblyFromFileBatch

Compiles an assembly based on the specified options and contents of the specified filenames.

[Visual Basic]
Function CompileAssemblyFromFileBatch( _
   ByVal options As CompilerParameters, _
   ByVal fileNames() As String _
) As CompilerResults
[C#]
CompilerResults CompileAssemblyFromFileBatch(
   CompilerParameters options,
   string[] fileNames
);
[C++]
CompilerResults* CompileAssemblyFromFileBatch(
   CompilerParameters* options,
   String* fileNames[]
) = 0;
[JScript]
function CompileAssemblyFromFileBatch(
   options : CompilerParameters,
   fileNames : String[]
) : CompilerResults;

Parameters

options
A CompilerParameters that indicates the options to compile with.
fileNames
[To be supplied.]

See Also

IBatchCompiler Interface | IBatchCompiler Members | System.CodeDOM.Compiler Namespace | CompilerParameters


IBatchCompiler.CompileAssemblyFromSourceBatch

Compiles an assembly based on the specified options and information from the specified sources.

[Visual Basic]
Function CompileAssemblyFromSourceBatch( _
   ByVal options As CompilerParameters, _
   ByVal sources() As String _
) As CompilerResults
[C#]
CompilerResults CompileAssemblyFromSourceBatch(
   CompilerParameters options,
   string[] sources
);
[C++]
CompilerResults* CompileAssemblyFromSourceBatch(
   CompilerParameters* options,
   String* sources[]
) = 0;
[JScript]
function CompileAssemblyFromSourceBatch(
   options : CompilerParameters,
   sources : String[]
) : CompilerResults;

Parameters

options
A CompilerParameters that indicates the options to compile with.
sources
[To be supplied.]

See Also

IBatchCompiler Interface | IBatchCompiler Members | System.CodeDOM.Compiler Namespace | CompilerParameters


ICodeCompiler Interface

Code Compilation Interface.

ICodeCompiler

[Visual Basic]
Public Interface ICodeCompiler
   Implements ICodeGenerator
[C#]
public interface ICodeCompiler : ICodeGenerator
[C++]
public __gc __interface ICodeCompiler : public ICodeGenerator

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement ICodeCompiler

Class | Description
CodeCompiler | Base class for CodeCompilers. This is a useful utility baseclass for CodeGenerators to derive from.

Remarks

Compiler vendors should provide an implementation of this interface to support server side dynamic compiling.

Requirements

Namespace: System.CodeDOM.Compiler

Assembly: System.dll

See Also

ICodeCompiler Members | System.CodeDOM.Compiler Namespace


ICodeCompiler Members

Properties

SupportsAdvancedSemantics Gets or sets whether the compiler supports advanced semantics.

Methods

CompileAssemblyFromDOM | Creates an assembly based on options, with the information from e.
CompileAssemblyFromFile | Creates an assembly based on options, with the contents of fileName.
CompileAssemblyFromSource | Creates an assembly based on options, with the information from source.

See Also

ICodeCompiler Interface | System.CodeDOM.Compiler Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeCompiler Properties

The properties of the ICodeCompiler interface are listed below. For a complete list of ICodeCompiler interface members, see the ICodeCompiler Members topic.

SupportsAdvancedSemantics Gets or sets whether the compiler supports advanced semantics.

See Also

ICodeCompiler Interface | System.CodeDOM.Compiler Namespace


ICodeCompiler.SupportsAdvancedSemantics

Gets or sets whether the compiler supports advanced semantics.

[Visual Basic]
ReadOnly Property SupportsAdvancedSemantics As Boolean
[C#]
bool SupportsAdvancedSemantics {get;}
[C++]
bool get_SupportsAdvancedSemantics() = 0;
[JScript]
abstract function get SupportsAdvancedSemantics() : Boolean;

Property Value

true if the compiler supports advanced semantics; otherwise, false.

See Also

ICodeCompiler Interface | ICodeCompiler Members | System.CodeDOM.Compiler Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeCompiler Methods

The methods of the ICodeCompiler interface are listed below. For a complete list of ICodeCompiler interface members, see the ICodeCompiler Members topic.

CompileAssemblyFromDOM | Creates an assembly based on options, with the information from e.
CompileAssemblyFromFile | Creates an assembly based on options, with the contents of fileName.
CompileAssemblyFromSource | Creates an assembly based on options, with the information from source.

See Also

ICodeCompiler Interface | System.CodeDOM.Compiler Namespace


ICodeCompiler.CompileAssemblyFromDOM

Creates an assembly based on options, with the information from e.

[Visual Basic]
Function CompileAssemblyFromDOM( _
   ByVal options As CompilerParameters, _
   ByVal e As CodeNamespace _
) As CompilerResults
[C#]
CompilerResults CompileAssemblyFromDOM(
   CompilerParameters options,
   CodeNamespace e
);
[C++]
CompilerResults* CompileAssemblyFromDOM(
   CompilerParameters* options,
   CodeNamespace* e
) = 0;
[JScript]
function CompileAssemblyFromDOM(
   options : CompilerParameters,
   e : CodeNamespace
) : CompilerResults;

Parameters

options
A CompilerParameters that indicates the options to compile with.
e
[To be supplied.]

Return Value

A CompilerResults that indicates the results of the compilation.

See Also

ICodeCompiler Interface | ICodeCompiler Members | System.CodeDOM.Compiler Namespace | System.CodeDOM.CompilerParameters | CodeNamespace


ICodeCompiler.CompileAssemblyFromFile

Creates an assembly based on options, with the contents of fileName.

[Visual Basic]
Function CompileAssemblyFromFile( _
   ByVal options As CompilerParameters, _
   ByVal fileName As String _
) As CompilerResults
[C#]
CompilerResults CompileAssemblyFromFile(
   CompilerParameters options,
   string fileName
);
[C++]
CompilerResults* CompileAssemblyFromFile(
   CompilerParameters* options,
   String* fileName
) = 0;
[JScript]
function CompileAssemblyFromFile(
   options : CompilerParameters,
   fileName : String
) : CompilerResults;

Parameters

options
A CompilerParameters that indicates the options to compile with.
fileName
[To be supplied.]

Return Value

A CompilerResults that indicates the results of the compilation.

See Also

ICodeCompiler Interface | ICodeCompiler Members | System.CodeDOM.Compiler Namespace | CompilerParameters


ICodeCompiler.CompileAssemblyFromSource

Creates an assembly based on options, with the information from source.

[Visual Basic]
Function CompileAssemblyFromSource( _
   ByVal options As CompilerParameters, _
   ByVal source As String _
) As CompilerResults
[C#]
CompilerResults CompileAssemblyFromSource(
   CompilerParameters options,
   string source
);
[C++]
CompilerResults* CompileAssemblyFromSource(
   CompilerParameters* options,
   String* source
) = 0;
[JScript]
function CompileAssemblyFromSource(
   options : CompilerParameters,
   source : String
) : CompilerResults;

Parameters

options
A CompilerParameters that indicates the options to compile with.
source
[To be supplied.]

Return Value

A CompilerResults that indicates the results of the compilation.

See Also

ICodeCompiler Interface | ICodeCompiler Members | System.CodeDOM.Compiler Namespace | CompilerParameters


ICodeGenerator Interface

Provides an interface for code generation.

ICodeGenerator

[Visual Basic]
Public Interface ICodeGenerator
[C#]
public interface ICodeGenerator
[C++]
public __gc __interface ICodeGenerator

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement ICodeGenerator

Class | Description
CodeGenerator | The base class for CodeGenerators.

Remarks

Compiler vendors should provide an implementation of this interface to support designer and server side code generation.

Requirements

Namespace: System.CodeDOM.Compiler

Assembly: System.dll

See Also

ICodeGenerator Members | System.CodeDOM.Compiler Namespace


ICodeGenerator Members

Methods

GenerateCodeFromClass | Outputs the language specific representaion of the CodeDOM tree refered to by e, into w.
GenerateCodeFromExpression | Generates code from the specified expression and outputs it to the specified textwriter.
GenerateCodeFromNamespace | Outputs the language specific representaion of the CodeDOM tree refered to by e, into w.
GenerateCodeFromStatement | Outputs the language specific representaion of the CodeDOM tree refered to by e, into w.
IsValidIdentifier | Gets whether value is a valid identifier for this language.
ValidateIdentifier | Throws an exception if value is not a valid identifier. This allows the language to produce a very informative error message based upon value.

See Also

ICodeGenerator Interface | System.CodeDOM.Compiler Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeGenerator Methods

The methods of the ICodeGenerator interface are listed below. For a complete list of ICodeGenerator interface members, see the ICodeGenerator Members topic.

GenerateCodeFromClass | Outputs the language specific representaion of the CodeDOM tree refered to by e, into w.
GenerateCodeFromExpression | Generates code from the specified expression and outputs it to the specified textwriter.
GenerateCodeFromNamespace | Outputs the language specific representaion of the CodeDOM tree refered to by e, into w.
GenerateCodeFromStatement | Outputs the language specific representaion of the CodeDOM tree refered to by e, into w.
IsValidIdentifier | Gets whether value is a valid identifier for this language.
ValidateIdentifier | Throws an exception if value is not a valid identifier. This allows the language to produce a very informative error message based upon value.

See Also

ICodeGenerator Interface | System.CodeDOM.Compiler Namespace


ICodeGenerator.GenerateCodeFromClass

Outputs the language specific representaion of the CodeDOM tree refered to by e, into w.

[Visual Basic]
Sub GenerateCodeFromClass( _
   ByVal w As TextWriter, _
   ByVal e As CodeClass _
)
[C#]
void GenerateCodeFromClass(
   TextWriter w,
   CodeClass e
);
[C++]
void GenerateCodeFromClass(
   TextWriter* w,
   CodeClass* e
) = 0;
[JScript]
function GenerateCodeFromClass(
   w : TextWriter,
   e : CodeClass
);

Parameters

w
The TextWriter to output code to.
e
[To be supplied.]

See Also

ICodeGenerator Interface | ICodeGenerator Members | System.CodeDOM.Compiler Namespace | TextWriter | CodeExpression


ICodeGenerator.GenerateCodeFromExpression

Generates code from the specified expression and outputs it to the specified textwriter.

[Visual Basic]
Sub GenerateCodeFromExpression( _
   ByVal w As TextWriter, _
   ByVal e As CodeExpression _
)
[C#]
void GenerateCodeFromExpression(
   TextWriter w,
   CodeExpression e
);
[C++]
void GenerateCodeFromExpression(
   TextWriter* w,
   CodeExpression* e
) = 0;
[JScript]
function GenerateCodeFromExpression(
   w : TextWriter,
   e : CodeExpression
);

Parameters

w
The TextWriter to output code to.
e
[To be supplied.]

See Also

ICodeGenerator Interface | ICodeGenerator Members | System.CodeDOM.Compiler Namespace | TextWriter | CodeExpression


ICodeGenerator.GenerateCodeFromNamespace

Outputs the language specific representaion of the CodeDOM tree refered to by e, into w.

[Visual Basic]
Sub GenerateCodeFromNamespace( _
   ByVal w As TextWriter, _
   ByVal e As CodeNamespace _
)
[C#]
void GenerateCodeFromNamespace(
   TextWriter w,
   CodeNamespace e
);
[C++]
void GenerateCodeFromNamespace(
   TextWriter* w,
   CodeNamespace* e
) = 0;
[JScript]
function GenerateCodeFromNamespace(
   w : TextWriter,
   e : CodeNamespace
);

Parameters

w
The TextWriter to output code to.
e
[To be supplied.]

See Also

ICodeGenerator Interface | ICodeGenerator Members | System.CodeDOM.Compiler Namespace | TextWriter | CodeExpression


ICodeGenerator.GenerateCodeFromStatement

Outputs the language specific representaion of the CodeDOM tree refered to by e, into w.

[Visual Basic]
Sub GenerateCodeFromStatement( _
   ByVal w As TextWriter, _
   ByVal e As CodeStatement _
)
[C#]
void GenerateCodeFromStatement(
   TextWriter w,
   CodeStatement e
);
[C++]
void GenerateCodeFromStatement(
   TextWriter* w,
   CodeStatement* e
) = 0;
[JScript]
function GenerateCodeFromStatement(
   w : TextWriter,
   e : CodeStatement
);

Parameters

w
The TextWriter to output code to.
e
[To be supplied.]

See Also

ICodeGenerator Interface | ICodeGenerator Members | System.CodeDOM.Compiler Namespace | TextWriter | CodeExpression


ICodeGenerator.IsValidIdentifier

Gets whether value is a valid identifier for this language.

[Visual Basic]
Function IsValidIdentifier( _
   ByVal value As String _
) As Boolean
[C#]
bool IsValidIdentifier(
   string value
);
[C++]
bool IsValidIdentifier(
   String* value
) = 0;
[JScript]
function IsValidIdentifier(
   value : String
) : Boolean;

Parameters

value
The value to test for validity as an identifier.

See Also

ICodeGenerator Interface | ICodeGenerator Members | System.CodeDOM.Compiler Namespace


ICodeGenerator.ValidateIdentifier

Throws an exception if value is not a valid identifier. This allows the language to produce a very informative error message based upon value.

[Visual Basic]
Sub ValidateIdentifier( _
   ByVal value As String _
)
[C#]
void ValidateIdentifier(
   string value
);
[C++]
void ValidateIdentifier(
   String* value
) = 0;
[JScript]
function ValidateIdentifier(
   value : String
);

Parameters

value
The value to validate.

See Also

ICodeGenerator Interface | ICodeGenerator Members | System.CodeDOM.Compiler Namespace


IndentedTextWriter Class

IndentedTextWriter- indents new lines by a token (tabString).

Object
TextWriter
IndentedTextWriter

[Visual Basic]
Public Class IndentedTextWriter
   Inherits TextWriter
[C#]
public class IndentedTextWriter : TextWriter
[C++]
public __gc class IndentedTextWriter : public TextWriter
[JScript]
public class IndentedTextWriter extends TextWriter

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM.Compiler

Assembly: System.dll

See Also

IndentedTextWriter Members | System.CodeDOM.Compiler Namespace


IndentedTextWriter Members

Public:

Constructor

IndentedTextWriter Constructor Overloaded. Initializes a new instance of IndentedTextWriter using the specified text writer and default tab string.

Properties

Indent | [To be supplied.]
InnerWriter | [To be supplied.]
NewLine | [To be supplied.]

Methods

Close | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Flush | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Overloaded. [To be supplied.]
WriteLine | Overloaded. [To be supplied.]
WriteLineNoTabs | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OutputTabs | [To be supplied.]

Fields

CoreNewLine (inherited from TextWriter) Gets the next line in the file.

See Also

IndentedTextWriter Class | System.CodeDOM.Compiler Namespace


IndentedTextWriter Constructor

Initializes a new instance of IndentedTextWriter using the specified text writer and default tab string.

Overload List

Initializes a new instance of IndentedTextWriter using the specified text writer and default tab string.

[Visual Basic] Overloads Public Sub New(TextWriter)
[C#] public IndentedTextWriter(TextWriter);
[C++] public: IndentedTextWriter(TextWriter*);
[JScript] public function IndentedTextWriter(TextWriter);

Initializes a new instance of IndentedTextWriter using the specified text writer and tab string.

[Visual Basic] Overloads Public Sub New(TextWriter, String)
[C#] public IndentedTextWriter(TextWriter, String);
[C++] public: IndentedTextWriter(TextWriter*, String);
[JScript] public function IndentedTextWriter(TextWriter, String);

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace


IndentedTextWriter Constructor (TextWriter)

Initializes a new instance of IndentedTextWriter using the specified text writer and default tab string.

[Visual Basic]
Overloads Public Sub New( _
   ByVal writer As TextWriter _
)
[C#]
public IndentedTextWriter(
   TextWriter writer
);
[C++]
public: IndentedTextWriter(
   TextWriter* writer
);
[JScript]
public function IndentedTextWriter(
   writer : TextWriter
);

Parameters

writer
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter Constructor Overload List | System.IOTextWriter.TextWriter


IndentedTextWriter Constructor (TextWriter, String)

Initializes a new instance of IndentedTextWriter using the specified text writer and tab string.

[Visual Basic]
Overloads Public Sub New( _
   ByVal writer As TextWriter, _
   ByVal tabString As String _
)
[C#]
public IndentedTextWriter(
   TextWriter writer,
   string tabString
);
[C++]
public: IndentedTextWriter(
   TextWriter* writer,
   String* tabString
);
[JScript]
public function IndentedTextWriter(
   writer : TextWriter,
   tabString : String
);

Parameters

writer
The TextWriter to use for output.
tabString
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter Constructor Overload List | TextWriter


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IndentedTextWriter Properties

The properties of the IndentedTextWriter class are listed below. For a complete list of IndentedTextWriter class members, see the IndentedTextWriter Members topic.

Public:

Indent | [To be supplied.]
InnerWriter | [To be supplied.]
NewLine | [To be supplied.]

See Also

IndentedTextWriter Class | System.CodeDOM.Compiler Namespace


IndentedTextWriter.Indent

[To be supplied.]

[Visual Basic]
Public Property Indent As Integer
[C#]
public int Indent {get; set;}
[C++]
public: __property int get_Indent();
public: __property void set_Indent(int);
[JScript]
public function get Indent() : int;
public function set Indent(int);

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace


IndentedTextWriter.InnerWriter

[To be supplied.]

[Visual Basic]
Public ReadOnly Property InnerWriter As TextWriter
[C#]
public TextWriter InnerWriter {get;}
[C++]
public: __property TextWriter* get_InnerWriter();
[JScript]
public function get InnerWriter() : TextWriter;

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace


IndentedTextWriter.NewLine

[To be supplied.]

[Visual Basic]
Overridable Public Property NewLine As String
[C#]
public string NewLine {override get; override set;}
[C++]
public: __property virtual String* get_NewLine();
public: __property virtual void set_NewLine(String*);
[JScript]
public function get NewLine() : String;
public function set NewLine(String);

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IndentedTextWriter Methods

The methods of the IndentedTextWriter class are listed below. For a complete list of IndentedTextWriter class members, see the IndentedTextWriter Members topic.

Public:

Close | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Flush | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Overloaded. [To be supplied.]
WriteLine | Overloaded. [To be supplied.]
WriteLineNoTabs | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OutputTabs | [To be supplied.]

See Also

IndentedTextWriter Class | System.CodeDOM.Compiler Namespace


IndentedTextWriter.Close

[To be supplied.]

[Visual Basic]
Overrides Public Sub Close()
[C#]
public override void Close();
[C++]
public: override void Close();
[JScript]
public override function Close();

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace


IndentedTextWriter.Flush

[To be supplied.]

[Visual Basic]
Overrides Public Sub Flush()
[C#]
public override void Flush();
[C++]
public: override void Flush();
[JScript]
public override function Flush();

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace


IndentedTextWriter.OutputTabs

[To be supplied.]

[Visual Basic]
Overridable Protected Sub OutputTabs()
[C#]
protected virtual void OutputTabs();
[C++]
protected: virtual void OutputTabs();
[JScript]
protected function OutputTabs();

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace


IndentedTextWriter.Write

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overrides Public Sub Write(Long)
[C#] public override void Write(long);
[C++] public: override void Write(__int64);
[JScript] public override function Write(long);

[To be supplied.]

[Visual Basic] Overloads Overrides Public Sub Write(Double)
[C#] public override void Write(double);
[C++] public: override void Write(double);
[JScript] public override function Write(double);

[To be supplied.]

[Visual Basic] Overloads Overrides Public Sub Write(Single)
[C#] public override void Write(float);
[C++] public: override void Write(float);
[JScript] public override function Write(float);

[To be supplied.]

[Visual Basic] Overloads Overrides Public Sub Write(Char())
[C#] public override void Write(char[]);
[C++] public: override void Write(__wchar_t*[]);
[JScript] public override function Write(Char[]);

[To be supplied.]

[Visual Basic] Overloads Overrides Public Sub Write(Char)
[C#] public override void Write(char);
[C++] public: override void Write(__wchar_t);
[JScript] public override function Write(Char);

[To be supplied.]

[Visual Basic] Overloads Overrides Public Sub Write(Char(), Integer, Integer)
[C#] public override void Write(char[], int, int);
[C++] public: override void Write(__wchar_t*[], int, int);
[JScript] public override function Write(Char[], int, int);

[To be supplied.]

[Visual Basic] Overloads Overrides Public Sub Write(Integer)
[C#] public override void Write(int);
[C++] public: override void Write(int);
[JScript] public override function Write(int);

[To be supplied.]

[Visual Basic] Overloads Overrides Public Sub Write(Boolean)
[C#] public override void Write(bool);
[C++] public: override void Write(bool);
[JScript] public override function Write(Boolean);

[To be supplied.]

[Visual Basic] Overloads Overrides Public Sub Write(String, Object, Object)
[C#] public override void Write(String, Object, Object);
[C++] public: override void Write(String*, Object, Object);
[JScript] public override function Write(String, Object, Object);

[To be supplied.]

[Visual Basic] Overloads Overrides Public Sub Write(String, Object, Object, Object)
[C#] public override void Write(String, Object, Object, Object);
[C++] public: override void Write(String*, Object, Object, Object);
[JScript] public override function Write(String, Object, Object, Object);

[To be supplied.]

[Visual Basic] Overloads Overrides Public Sub Write(String, Object())
[C#] public override void Write(String, Object[]);
[C++] public: override void Write(String*, Object[]);
[JScript] public override function Write(String, Object[]);

[To be supplied.]

[Visual Basic] Overloads Overrides Public Sub Write(String)
[C#] public override void Write(String);
[C++] public: override void Write(String*);
[JScript] public override function Write(String);

[To be supplied.]

[Visual Basic] Overloads Overrides Public Sub Write(Object)
[C#] public override void Write(Object);
[C++] public: override void Write(Object*);
[JScript] public override function Write(Object);

[To be supplied.]

[Visual Basic] Overloads Overrides Public Sub Write(String, Object)
[C#] public override void Write(String, Object);
[C++] public: override void Write(String*, Object);
[JScript] public override function Write(String, Object);

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace


IndentedTextWriter.Write (Int64)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Sub Write( _
   ByVal value As Long _
)
[C#]
public override void Write(
   long value
);
[C++]
public: override void Write(
   __int64 value
);
[JScript]
public override function Write(
   value : long
);

Parameters

value
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter.Write Overload List


IndentedTextWriter.Write (Double)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Sub Write( _
   ByVal value As Double _
)
[C#]
public override void Write(
   double value
);
[C++]
public: override void Write(
   double value
);
[JScript]
public override function Write(
   value : double
);

Parameters

value
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter.Write Overload List


IndentedTextWriter.Write (Single)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Sub Write( _
   ByVal value As Single _
)
[C#]
public override void Write(
   float value
);
[C++]
public: override void Write(
   float value
);
[JScript]
public override function Write(
   value : float
);

Parameters

value
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter.Write Overload List


IndentedTextWriter.Write (Char[])

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Sub Write( _
   ByVal buffer() As Char _
)
[C#]
public override void Write(
   char[] buffer
);
[C++]
public: override void Write(
   __wchar_t* buffer[]
);
[JScript]
public override function Write(
   buffer : Char[]
);

Parameters

buffer
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter.Write Overload List


IndentedTextWriter.Write (Char)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Sub Write( _
   ByVal value As Char _
)
[C#]
public override void Write(
   char value
);
[C++]
public: override void Write(
   __wchar_t value
);
[JScript]
public override function Write(
   value : Char
);

Parameters

value
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter.Write Overload List


IndentedTextWriter.Write (Char[], Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Sub Write( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
[C#]
public override void Write(
   char[] buffer,
   int index,
   int count
);
[C++]
public: override void Write(
   __wchar_t* buffer[],
   int index,
   int count
);
[JScript]
public override function Write(
   buffer : Char[],
   index : int,
   count : int
);

Parameters

buffer
[To be supplied.]
index
[To be supplied.]
count
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter.Write Overload List


IndentedTextWriter.Write (Int32)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Sub Write( _
   ByVal value As Integer _
)
[C#]
public override void Write(
   int value
);
[C++]
public: override void Write(
   int value
);
[JScript]
public override function Write(
   value : int
);

Parameters

value
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter.Write Overload List


IndentedTextWriter.Write (Boolean)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Sub Write( _
   ByVal value As Boolean _
)
[C#]
public override void Write(
   bool value
);
[C++]
public: override void Write(
   bool value
);
[JScript]
public override function Write(
   value : Boolean
);

Parameters

value
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter.Write Overload List


IndentedTextWriter.Write (String, Object, Object)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Sub Write( _
   ByVal format As String, _
   ByVal arg0 As Object, _
   ByVal arg1 As Object _
)
[C#]
public override void Write(
   string format,
   object arg0,
   object arg1
);
[C++]
public: override void Write(
   String* format,
   Object* arg0,
   Object* arg1
);
[JScript]
public override function Write(
   format : String,
   arg0 : Object,
   arg1 : Object
);

Parameters

format
[To be supplied.]
arg0
[To be supplied.]
arg1
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter.Write Overload List


IndentedTextWriter.Write (String, Object, Object, Object)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Sub Write( _
   ByVal format As String, _
   ByVal arg0 As Object, _
   ByVal arg1 As Object, _
   ByVal arg2 As Object _
)
[C#]
public override void Write(
   string format,
   object arg0,
   object arg1,
   object arg2
);
[C++]
public: override void Write(
   String* format,
   Object* arg0,
   Object* arg1,
   Object* arg2
);
[JScript]
public override function Write(
   format : String,
   arg0 : Object,
   arg1 : Object,
   arg2 : Object
);

Parameters

format
[To be supplied.]
arg0
[To be supplied.]
arg1
[To be supplied.]
arg2
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter.Write Overload List


IndentedTextWriter.Write (String, Object[])

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Sub Write( _
   ByVal format As String, _
   ByVal arg() As Object _
)
[C#]
public override void Write(
   string format,
   object[] arg
);
[C++]
public: override void Write(
   String* format,
   Object* arg[]
);
[JScript]
public override function Write(
   format : String,
   arg : Object[]
);

Parameters

format
[To be supplied.]
arg
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter.Write Overload List


IndentedTextWriter.Write (String)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Sub Write( _
   ByVal s As String _
)
[C#]
public override void Write(
   string s
);
[C++]
public: override void Write(
   String* s
);
[JScript]
public override function Write(
   s : String
);

Parameters

s
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter.Write Overload List


IndentedTextWriter.Write (Object)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Sub Write( _
   ByVal value As Object _
)
[C#]
public override void Write(
   object value
);
[C++]
public: override void Write(
   Object* value
);
[JScript]
public override function Write(
   value : Object
);

Parameters

value
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter.Write Overload List


IndentedTextWriter.Write (String, Object)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Sub Write( _
   ByVal format As String, _
   ByVal arg0 As Object _
)
[C#]
public override void Write(
   string format,
   object arg0
);
[C++]
public: override void Write(
   String* format,
   Object* arg0
);
[JScript]
public override function Write(
   format : String,
   arg0 : Object
);

Parameters

format
[To be supplied.]
arg0
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter.Write Overload List


IndentedTextWriter.WriteLine

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overrides Public Sub WriteLine(String)
[C#] public override void WriteLine(String);
[C++] public: override void WriteLine(String*);
[JScript] public override function WriteLine(String);

[To be supplied.]

[Visual Basic] Overloads Overrides Public Sub WriteLine(Object)
[C#] public override void WriteLine(Object);
[C++] public: override void WriteLine(Object*);
[JScript] public override function WriteLine(Object);

[To be supplied.]

[Visual Basic] Overloads Overrides Public Sub WriteLine(Single)
[C#] public override void WriteLine(float);
[C++] public: override void WriteLine(float);
[JScript] public override function WriteLine(float);

[To be supplied.]

[Visual Basic] Overloads Overrides Public Sub WriteLine(Double)
[C#] public override void WriteLine(double);
[C++] public: override void WriteLine(double);
[JScript] public override function WriteLine(double);

[To be supplied.]

[Visual Basic] Overloads Overrides Public Sub WriteLine(String, Object, Object, Object)
[C#] public override void WriteLine(String, Object, Object, Object);
[C++] public: override void WriteLine(String*, Object, Object, Object);
[JScript] public override function WriteLine(String, Object, Object, Object);

[To be supplied.]

[Visual Basic] Overloads Overrides Public Sub WriteLine(String, Object())
[C#] public override void WriteLine(String, Object[]);
[C++] public: override void WriteLine(String*, Object[]);
[JScript] public override function WriteLine(String, Object[]);

[To be supplied.]

[Visual Basic] Overloads Overrides Public Sub WriteLine(String, Object)
[C#] public override void WriteLine(String, Object);
[C++] public: override void WriteLine(String*, Object);
[JScript] public override function WriteLine(String, Object);

[To be supplied.]

[Visual Basic] Overloads Overrides Public Sub WriteLine(String, Object, Object)
[C#] public override void WriteLine(String, Object, Object);
[C++] public: override void WriteLine(String*, Object, Object);
[JScript] public override function WriteLine(String, Object, Object);

[To be supplied.]

[Visual Basic] Overloads Overrides Public Sub WriteLine(Char())
[C#] public override void WriteLine(char[]);
[C++] public: override void WriteLine(__wchar_t*[]);
[JScript] public override function WriteLine(Char[]);

[To be supplied.]

[Visual Basic] Overloads Overrides Public Sub WriteLine(Char(), Integer, Integer)
[C#] public override void WriteLine(char[], int, int);
[C++] public: override void WriteLine(__wchar_t*[], int, int);
[JScript] public override function WriteLine(Char[], int, int);

[To be supplied.]

[Visual Basic] Overloads Overrides Public Sub WriteLine()
[C#] public override void WriteLine();
[C++] public: override void WriteLine();
[JScript] public override function WriteLine();

[To be supplied.]

[Visual Basic] Overloads Overrides Public Sub WriteLine(Char)
[C#] public override void WriteLine(char);
[C++] public: override void WriteLine(__wchar_t);
[JScript] public override function WriteLine(Char);

[To be supplied.]

[Visual Basic] Overloads Overrides Public Sub WriteLine(Long)
[C#] public override void WriteLine(long);
[C++] public: override void WriteLine(__int64);
[JScript] public override function WriteLine(long);

[To be supplied.]

[Visual Basic] Overloads Overrides Public Sub WriteLine(UInt32)
[C#] public override void WriteLine(uint);
[C++] public: override void WriteLine(unsigned int);
[JScript] public override function WriteLine(UInt32);

[To be supplied.]

[Visual Basic] Overloads Overrides Public Sub WriteLine(Boolean)
[C#] public override void WriteLine(bool);
[C++] public: override void WriteLine(bool);
[JScript] public override function WriteLine(Boolean);

[To be supplied.]

[Visual Basic] Overloads Overrides Public Sub WriteLine(Integer)
[C#] public override void WriteLine(int);
[C++] public: override void WriteLine(int);
[JScript] public override function WriteLine(int);

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace


IndentedTextWriter.WriteLine (String)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Sub WriteLine( _
   ByVal s As String _
)
[C#]
public override void WriteLine(
   string s
);
[C++]
public: override void WriteLine(
   String* s
);
[JScript]
public override function WriteLine(
   s : String
);

Parameters

s
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter.WriteLine Overload List


IndentedTextWriter.WriteLine (Object)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Sub WriteLine( _
   ByVal value As Object _
)
[C#]
public override void WriteLine(
   object value
);
[C++]
public: override void WriteLine(
   Object* value
);
[JScript]
public override function WriteLine(
   value : Object
);

Parameters

value
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter.WriteLine Overload List


IndentedTextWriter.WriteLine (Single)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Sub WriteLine( _
   ByVal value As Single _
)
[C#]
public override void WriteLine(
   float value
);
[C++]
public: override void WriteLine(
   float value
);
[JScript]
public override function WriteLine(
   value : float
);

Parameters

value
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter.WriteLine Overload List


IndentedTextWriter.WriteLine (Double)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Sub WriteLine( _
   ByVal value As Double _
)
[C#]
public override void WriteLine(
   double value
);
[C++]
public: override void WriteLine(
   double value
);
[JScript]
public override function WriteLine(
   value : double
);

Parameters

value
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter.WriteLine Overload List


IndentedTextWriter.WriteLine (String, Object, Object, Object)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Sub WriteLine( _
   ByVal format As String, _
   ByVal arg0 As Object, _
   ByVal arg1 As Object, _
   ByVal arg2 As Object _
)
[C#]
public override void WriteLine(
   string format,
   object arg0,
   object arg1,
   object arg2
);
[C++]
public: override void WriteLine(
   String* format,
   Object* arg0,
   Object* arg1,
   Object* arg2
);
[JScript]
public override function WriteLine(
   format : String,
   arg0 : Object,
   arg1 : Object,
   arg2 : Object
);

Parameters

format
[To be supplied.]
arg0
[To be supplied.]
arg1
[To be supplied.]
arg2
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter.WriteLine Overload List


IndentedTextWriter.WriteLine (String, Object[])

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Sub WriteLine( _
   ByVal format As String, _
   ByVal arg() As Object _
)
[C#]
public override void WriteLine(
   string format,
   object[] arg
);
[C++]
public: override void WriteLine(
   String* format,
   Object* arg[]
);
[JScript]
public override function WriteLine(
   format : String,
   arg : Object[]
);

Parameters

format
[To be supplied.]
arg
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter.WriteLine Overload List


IndentedTextWriter.WriteLine (String, Object)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Sub WriteLine( _
   ByVal format As String, _
   ByVal arg0 As Object _
)
[C#]
public override void WriteLine(
   string format,
   object arg0
);
[C++]
public: override void WriteLine(
   String* format,
   Object* arg0
);
[JScript]
public override function WriteLine(
   format : String,
   arg0 : Object
);

Parameters

format
[To be supplied.]
arg0
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter.WriteLine Overload List


IndentedTextWriter.WriteLine (String, Object, Object)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Sub WriteLine( _
   ByVal format As String, _
   ByVal arg0 As Object, _
   ByVal arg1 As Object _
)
[C#]
public override void WriteLine(
   string format,
   object arg0,
   object arg1
);
[C++]
public: override void WriteLine(
   String* format,
   Object* arg0,
   Object* arg1
);
[JScript]
public override function WriteLine(
   format : String,
   arg0 : Object,
   arg1 : Object
);

Parameters

format
[To be supplied.]
arg0
[To be supplied.]
arg1
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter.WriteLine Overload List


IndentedTextWriter.WriteLine (Char[])

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Sub WriteLine( _
   ByVal buffer() As Char _
)
[C#]
public override void WriteLine(
   char[] buffer
);
[C++]
public: override void WriteLine(
   __wchar_t* buffer[]
);
[JScript]
public override function WriteLine(
   buffer : Char[]
);

Parameters

buffer
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter.WriteLine Overload List


IndentedTextWriter.WriteLine (Char[], Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Sub WriteLine( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
[C#]
public override void WriteLine(
   char[] buffer,
   int index,
   int count
);
[C++]
public: override void WriteLine(
   __wchar_t* buffer[],
   int index,
   int count
);
[JScript]
public override function WriteLine(
   buffer : Char[],
   index : int,
   count : int
);

Parameters

buffer
[To be supplied.]
index
[To be supplied.]
count
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter.WriteLine Overload List


IndentedTextWriter.WriteLine ()

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Sub WriteLine()
[C#]
public override void WriteLine();
[C++]
public: override void WriteLine();
[JScript]
public override function WriteLine();

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter.WriteLine Overload List


IndentedTextWriter.WriteLine (Char)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Sub WriteLine( _
   ByVal value As Char _
)
[C#]
public override void WriteLine(
   char value
);
[C++]
public: override void WriteLine(
   __wchar_t value
);
[JScript]
public override function WriteLine(
   value : Char
);

Parameters

value
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter.WriteLine Overload List


IndentedTextWriter.WriteLine (Int64)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Sub WriteLine( _
   ByVal value As Long _
)
[C#]
public override void WriteLine(
   long value
);
[C++]
public: override void WriteLine(
   __int64 value
);
[JScript]
public override function WriteLine(
   value : long
);

Parameters

value
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter.WriteLine Overload List


IndentedTextWriter.WriteLine (UInt32)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Sub WriteLine( _
   ByVal value As UInt32 _
)
[C#]
public override void WriteLine(
   uint value
);
[C++]
public: override void WriteLine(
   unsigned int value
);
[JScript]
public override function WriteLine(
   value : UInt32
);

Parameters

value
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter.WriteLine Overload List


IndentedTextWriter.WriteLine (Boolean)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Sub WriteLine( _
   ByVal value As Boolean _
)
[C#]
public override void WriteLine(
   bool value
);
[C++]
public: override void WriteLine(
   bool value
);
[JScript]
public override function WriteLine(
   value : Boolean
);

Parameters

value
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter.WriteLine Overload List


IndentedTextWriter.WriteLine (Int32)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Sub WriteLine( _
   ByVal value As Integer _
)
[C#]
public override void WriteLine(
   int value
);
[C++]
public: override void WriteLine(
   int value
);
[JScript]
public override function WriteLine(
   value : int
);

Parameters

value
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace | IndentedTextWriter.WriteLine Overload List


IndentedTextWriter.WriteLineNoTabs

[To be supplied.]

[Visual Basic]
Public Sub WriteLineNoTabs( _
   ByVal s As String _
)
[C#]
public void WriteLineNoTabs(
   string s
);
[C++]
public: void WriteLineNoTabs(
   String* s
);
[JScript]
public function WriteLineNoTabs(
   s : String
);

Parameters

s
[To be supplied.]

See Also

IndentedTextWriter Class | IndentedTextWriter Members | System.CodeDOM.Compiler Namespace


JSCodeGenerator Class

JScript (ECMAScript) Code Generator.

Object
CodeGenerator
CodeCompiler
CSharpCodeGenerator
JSCodeGenerator

[Visual Basic]
Public Class JSCodeGenerator
   Inherits CSharpCodeGenerator
[C#]
public class JSCodeGenerator : CSharpCodeGenerator
[C++]
public __gc class JSCodeGenerator : public CSharpCodeGenerator
[JScript]
public class JSCodeGenerator extends CSharpCodeGenerator

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM.Compiler

Assembly: System.dll

See Also

JSCodeGenerator Members | System.CodeDOM.Compiler Namespace


JSCodeGenerator Members

Public:

Constructor

JSCodeGenerator Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

CurrentClassName (inherited from CodeGenerator) | Gets or sets the current class name.
CurrentMember (inherited from CodeGenerator) | Gets or sets the current member of the class.
CurrentMemberName (inherited from CodeGenerator) | Gets or sets the current member name.
CurrentNamespace (inherited from CodeGenerator) | Gets or sets the name of the current namespace.
FileExtension | Gets or sets the file extension to use.
Indent (inherited from CodeGenerator) | Gets or sets the amount of spaces to indent.
IsCurrentClass (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current class.
IsCurrentDelegate (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current delegate.
IsCurrentEnum (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current enumeration.
IsCurrentInterface (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current interface.
IsCurrentStruct (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current structure.
Output (inherited from CodeGenerator) | Gets or sets the TextWriter to use for output.
SupportsAdvanced (inherited from CodeCompiler) | [To be supplied.]

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
FromDOM (inherited from CodeCompiler) | [To be supplied.]
FromDOMBatch (inherited from CodeCompiler) | [To be supplied.]
FromFile (inherited from CodeCompiler) | [To be supplied.]
FromFileBatch | Gets the results of compilation after compiling with the specified options and files.
FromSource (inherited from CodeCompiler) | [To be supplied.]
FromSourceBatch (inherited from CodeCompiler) | [To be supplied.]
GenerateArrayCreateExpression (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based array creation expression representation.
GenerateAssignStatement (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based assignment statement representation.
GenerateAttributeBlockEnd | Generates code for the specified CodeDOM based attribute block end representation.
GenerateAttributeBlockStart | Generates code for the specified CodeDOM based attribute block start representation.
GenerateBaseReferenceExpression (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based base reference expression representation.
GenerateBinaryOperatorExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based binary operator expression representation.
GenerateCastExpression | Generates code for the specified CodeDOM based cast expression representation.
GenerateClassConstructor | Generates code for the specified CodeDOM based class constructor representation.
GenerateClassEnd (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based class end representation.
GenerateClasses (inherited from CodeGenerator) | Generates classes using CodeDOM representation for the specified namespace.
GenerateClassStart | Generates code for the specified CodeDOM based class start representation.
GenerateCommentStatement (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based comment statement representation.
GenerateConstructor | Generates code for the specified CodeDOM based constructor representation.
GenerateDelegateCreateExpression | Generates code for the specified CodeDOM based delegate creation expression representation.
GenerateDelegateInvokeExpression (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based delegate invoke expression representation.
GenerateDelegateInvokeStatement (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based delegate invoke statement representation.
GenerateExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based code expression.
GenerateField | Generates code for the specified CodeDOM based member field representation.
GenerateFieldReferenceExpression (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based field reference expression representation.
GenerateForLoopStatement (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based for loop statement representation.
GenerateIfStatement (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based if statement representation.
GenerateIndexerExpression | Generates code for the specified CodeDOM based indexer expression representation.
GenerateLinePragmaEnd | Generates code for the specified CodeDOM based line pragma end representation.
GenerateLinePragmaStart | Generates code for the specified CodeDOM based line pragma start representation.
GenerateLiteralExpression (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based literal expression representation.
GenerateLiteralMember (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based literal class member representation.
GenerateLiteralStatement (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based literal statement representation.
GenerateMethod | Generates code for the specified CodeDOM based member method representation.
GenerateMethodInvokeExpression (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based method invoke expression representation.
GenerateMethodInvokeStatement (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based method invoke statement representation.
GenerateMethodReturnStatement (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based method return statement representation.
GenerateNamespace | Generates code for the specified CodeDOM based namespace representation.
GenerateNamespaceEnd | Generates code for the specified CodeDOM based namespace end representation.
GenerateNamespaceImport | Generates code for the specified CodeDOM based namespace import representation.
GenerateNamespaceImports (inherited from CodeGenerator) | Generates code for the specified CodeDOM based namespace import representation.
GenerateNamespaceStart | Generates code for the specified CodeDOM based namespace start representation.
GenerateObjectCreateExpression (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based object creation expression representation.
GenerateParameterDeclarationExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based parameter declaration expression representation.
GeneratePrimitiveExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based primitive expression representation.
GenerateProperty | Generates code for the specified CodeDOM based member property representation.
GeneratePropertyReferenceExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based property reference expression representation.
GenerateStatement (inherited from CodeGenerator) | Generates code for the specified CodeDOM based statement representation.
GenerateStatements (inherited from CodeGenerator) | Generates code for the specified CodeDOM based statement representations.
GenerateThisReferenceExpression (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based this reference expression representation.
GenerateThrowExceptionStatement (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based throw exception statement representation.
GenerateTryCatchFinallyStatement (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based try catch finally statement representation.
GenerateTypeOfExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based type of expression representation.
GenerateTypeReferenceExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based type reference expression representation.
GenerateVariableDeclarationStatement | Generates code for the specified CodeDOM based variable declaration statement representation.
GetNullToken (inherited from CSharpCodeGenerator) | Gets the token used to represent a null reference (in Visual Basic Nothing).
GetTypeArrayRank (inherited from CodeGenerator) | [To be supplied.]
GetTypeBaseType (inherited from CodeGenerator) | Gets the base type of the specified type.
IsValidIdentifier (inherited from CSharpCodeGenerator) | Gets whether the specified value is a valid identifier.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OutputAttributeArgument (inherited from CodeGenerator) | Outputs an argument in a attribute block.
OutputAttributeBlock (inherited from CodeGenerator) | Generates code for the specified CodeAttributeBlock.
OutputDirection (inherited from CodeGenerator) | Generates code for the specified FieldDirection.
OutputExpressionList (inherited from CodeGenerator) | Overloaded. [To be supplied.]
OutputMemberAccessModifier | Generates code for the specified CodeDOM based member access modifier representation.
OutputMemberScopeModifier | Generates code for the specified CodeDOM based member scope modifier representation.
OutputOperator (inherited from CodeGenerator) | Generates code for the specified operator.
OutputParameters | Generates code for the specified CodeDOM based parameter declaration expression representation.
OutputType | Generates code for the specified CodeDOM based return type representation.
OutputTypeAttributes (inherited from CodeGenerator) | Generates code for the specified type attributes.
OutputTypeNamePair | Generates code for the specified CodeDOM based type name pair representation.
QuoteLiteralString | [To be supplied.]
QuoteLiteralStringCStyle (inherited from CSharpCodeGenerator) | Provides conversion to C-style formatting with escape codes.
ValidateIdentifier (inherited from CodeGenerator) | Gets whether the specified identifier is valid.

See Also

JSCodeGenerator Class | System.CodeDOM.Compiler Namespace


JSCodeGenerator Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public JSCodeGenerator();
[C++]
public: JSCodeGenerator();
[JScript]
public function JSCodeGenerator();

See Also

JSCodeGenerator Class | JSCodeGenerator Members | System.CodeDOM.Compiler Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

JSCodeGenerator Properties

The properties of the JSCodeGenerator class are listed below. For a complete list of JSCodeGenerator class members, see the JSCodeGenerator Members topic.

Protected:

CurrentClassName (inherited from CodeGenerator) | Gets or sets the current class name.
CurrentMember (inherited from CodeGenerator) | Gets or sets the current member of the class.
CurrentMemberName (inherited from CodeGenerator) | Gets or sets the current member name.
CurrentNamespace (inherited from CodeGenerator) | Gets or sets the name of the current namespace.
FileExtension | Gets or sets the file extension to use.
Indent (inherited from CodeGenerator) | Gets or sets the amount of spaces to indent.
IsCurrentClass (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current class.
IsCurrentDelegate (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current delegate.
IsCurrentEnum (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current enumeration.
IsCurrentInterface (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current interface.
IsCurrentStruct (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current structure.
Output (inherited from CodeGenerator) | Gets or sets the TextWriter to use for output.
SupportsAdvanced (inherited from CodeCompiler) | [To be supplied.]

See Also

JSCodeGenerator Class | System.CodeDOM.Compiler Namespace


JSCodeGenerator.FileExtension

Gets or sets the file extension to use.

[Visual Basic]
Overridable Protected ReadOnly Property FileExtension As String
[C#]
protected string FileExtension {override get;}
[C++]
protected: __property virtual String* get_FileExtension();
[JScript]
protected function get FileExtension() : String;

Property Value

The file extension to use.

See Also

JSCodeGenerator Class | JSCodeGenerator Members | System.CodeDOM.Compiler Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

JSCodeGenerator Methods

The methods of the JSCodeGenerator class are listed below. For a complete list of JSCodeGenerator class members, see the JSCodeGenerator Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
FromDOM (inherited from CodeCompiler) | [To be supplied.]
FromDOMBatch (inherited from CodeCompiler) | [To be supplied.]
FromFile (inherited from CodeCompiler) | [To be supplied.]
FromFileBatch | Gets the results of compilation after compiling with the specified options and files.
FromSource (inherited from CodeCompiler) | [To be supplied.]
FromSourceBatch (inherited from CodeCompiler) | [To be supplied.]
GenerateArrayCreateExpression (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based array creation expression representation.
GenerateAssignStatement (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based assignment statement representation.
GenerateAttributeBlockEnd | Generates code for the specified CodeDOM based attribute block end representation.
GenerateAttributeBlockStart | Generates code for the specified CodeDOM based attribute block start representation.
GenerateBaseReferenceExpression (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based base reference expression representation.
GenerateBinaryOperatorExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based binary operator expression representation.
GenerateCastExpression | Generates code for the specified CodeDOM based cast expression representation.
GenerateClassConstructor | Generates code for the specified CodeDOM based class constructor representation.
GenerateClassEnd (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based class end representation.
GenerateClasses (inherited from CodeGenerator) | Generates classes using CodeDOM representation for the specified namespace.
GenerateClassStart | Generates code for the specified CodeDOM based class start representation.
GenerateCommentStatement (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based comment statement representation.
GenerateConstructor | Generates code for the specified CodeDOM based constructor representation.
GenerateDelegateCreateExpression | Generates code for the specified CodeDOM based delegate creation expression representation.
GenerateDelegateInvokeExpression (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based delegate invoke expression representation.
GenerateDelegateInvokeStatement (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based delegate invoke statement representation.
GenerateExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based code expression.
GenerateField | Generates code for the specified CodeDOM based member field representation.
GenerateFieldReferenceExpression (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based field reference expression representation.
GenerateForLoopStatement (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based for loop statement representation.
GenerateIfStatement (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based if statement representation.
GenerateIndexerExpression | Generates code for the specified CodeDOM based indexer expression representation.
GenerateLinePragmaEnd | Generates code for the specified CodeDOM based line pragma end representation.
GenerateLinePragmaStart | Generates code for the specified CodeDOM based line pragma start representation.
GenerateLiteralExpression (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based literal expression representation.
GenerateLiteralMember (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based literal class member representation.
GenerateLiteralStatement (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based literal statement representation.
GenerateMethod | Generates code for the specified CodeDOM based member method representation.
GenerateMethodInvokeExpression (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based method invoke expression representation.
GenerateMethodInvokeStatement (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based method invoke statement representation.
GenerateMethodReturnStatement (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based method return statement representation.
GenerateNamespace | Generates code for the specified CodeDOM based namespace representation.
GenerateNamespaceEnd | Generates code for the specified CodeDOM based namespace end representation.
GenerateNamespaceImport | Generates code for the specified CodeDOM based namespace import representation.
GenerateNamespaceImports (inherited from CodeGenerator) | Generates code for the specified CodeDOM based namespace import representation.
GenerateNamespaceStart | Generates code for the specified CodeDOM based namespace start representation.
GenerateObjectCreateExpression (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based object creation expression representation.
GenerateParameterDeclarationExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based parameter declaration expression representation.
GeneratePrimitiveExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based primitive expression representation.
GenerateProperty | Generates code for the specified CodeDOM based member property representation.
GeneratePropertyReferenceExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based property reference expression representation.
GenerateStatement (inherited from CodeGenerator) | Generates code for the specified CodeDOM based statement representation.
GenerateStatements (inherited from CodeGenerator) | Generates code for the specified CodeDOM based statement representations.
GenerateThisReferenceExpression (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based this reference expression representation.
GenerateThrowExceptionStatement (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based throw exception statement representation.
GenerateTryCatchFinallyStatement (inherited from CSharpCodeGenerator) | Generates code for the specified CodeDOM based try catch finally statement representation.
GenerateTypeOfExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based type of expression representation.
GenerateTypeReferenceExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based type reference expression representation.
GenerateVariableDeclarationStatement | Generates code for the specified CodeDOM based variable declaration statement representation.
GetNullToken (inherited from CSharpCodeGenerator) | Gets the token used to represent a null reference (in Visual Basic Nothing).
GetTypeArrayRank (inherited from CodeGenerator) | [To be supplied.]
GetTypeBaseType (inherited from CodeGenerator) | Gets the base type of the specified type.
IsValidIdentifier (inherited from CSharpCodeGenerator) | Gets whether the specified value is a valid identifier.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OutputAttributeArgument (inherited from CodeGenerator) | Outputs an argument in a attribute block.
OutputAttributeBlock (inherited from CodeGenerator) | Generates code for the specified CodeAttributeBlock.
OutputDirection (inherited from CodeGenerator) | Generates code for the specified FieldDirection.
OutputExpressionList (inherited from CodeGenerator) | Overloaded. [To be supplied.]
OutputMemberAccessModifier | Generates code for the specified CodeDOM based member access modifier representation.
OutputMemberScopeModifier | Generates code for the specified CodeDOM based member scope modifier representation.
OutputOperator (inherited from CodeGenerator) | Generates code for the specified operator.
OutputParameters | Generates code for the specified CodeDOM based parameter declaration expression representation.
OutputType | Generates code for the specified CodeDOM based return type representation.
OutputTypeAttributes (inherited from CodeGenerator) | Generates code for the specified type attributes.
OutputTypeNamePair | Generates code for the specified CodeDOM based type name pair representation.
QuoteLiteralString | [To be supplied.]
QuoteLiteralStringCStyle (inherited from CSharpCodeGenerator) | Provides conversion to C-style formatting with escape codes.
ValidateIdentifier (inherited from CodeGenerator) | Gets whether the specified identifier is valid.

See Also

JSCodeGenerator Class | System.CodeDOM.Compiler Namespace


JSCodeGenerator.FromFileBatch

Gets the results of compilation after compiling with the specified options and files.

[Visual Basic]
Overrides Protected Function FromFileBatch( _
   ByVal options As CompilerParameters, _
   ByVal fileNames() As String _
) As CompilerResults
[C#]
protected override CompilerResults FromFileBatch(
   CompilerParameters options,
   string[] fileNames
);
[C++]
protected: override CompilerResults* FromFileBatch(
   CompilerParameters* options,
   String* fileNames[]
);
[JScript]
protected override function FromFileBatch(
   options : CompilerParameters,
   fileNames : String[]
) : CompilerResults;

Parameters

options
A CompilerParameters that indicates the options to use to compile.
fileNames
[To be supplied.]

Return Value

A CompilerResults that indicates the results of compilation.

See Also

JSCodeGenerator Class | JSCodeGenerator Members | System.CodeDOM.Compiler Namespace | CompilerParameters | CompilerResults


JSCodeGenerator.GenerateAttributeBlockEnd

Generates code for the specified CodeDOM based attribute block end representation.

[Visual Basic]
Overrides Protected Sub GenerateAttributeBlockEnd( _
   ByVal attributes As CodeAttributeBlock _
)
[C#]
protected override void GenerateAttributeBlockEnd(
   CodeAttributeB attributes
);
[C++]
protected: override void GenerateAttributeBlockEnd(
   CodeAttributeBlock* attributes
);
[JScript]
protected override function GenerateAttributeBlockEnd(
   attributes : CodeAttributeBlock
);

Parameters

attributes
A CodeAttributeBlock that indicates the attribute block end to generate code for.

See Also

JSCodeGenerator Class | JSCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeAttributeBlock


JSCodeGenerator.GenerateAttributeBlockStart

Generates code for the specified CodeDOM based attribute block start representation.

[Visual Basic]
Overrides Protected Sub GenerateAttributeBlockStart( _
   ByVal attributes As CodeAttributeBlock _
)
[C#]
protected override void GenerateAttributeBlockStart(
   CodeAttributeB attributes
);
[C++]
protected: override void GenerateAttributeBlockStart(
   CodeAttributeBlock* attributes
);
[JScript]
protected override function GenerateAttributeBlockStart(
   attributes : CodeAttributeBlock
);

Parameters

attributes
A CodeAttributeBlock that indicates the attribute block to generate code for.

See Also

JSCodeGenerator Class | JSCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeAttributeBlock


JSCodeGenerator.GenerateCastExpression

Generates code for the specified CodeDOM based cast expression representation.

[Visual Basic]
Overrides Protected Sub GenerateCastExpression( _
   ByVal e As CodeCastExpression _
)
[C#]
protected override void GenerateCastExpression(
   CodeCastExpression e
);
[C++]
protected: override void GenerateCastExpression(
   CodeCastExpression* e
);
[JScript]
protected override function GenerateCastExpression(
   e : CodeCastExpression
);

Parameters

e
A CodeCastExpression that indicates the expression to generate code for.

See Also

JSCodeGenerator Class | JSCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeCastExpression


JSCodeGenerator.GenerateClassConstructor

Generates code for the specified CodeDOM based class constructor representation.

[Visual Basic]
Overrides Protected Sub GenerateClassConstructor( _
   ByVal e As CodeClassConstructor _
)
[C#]
protected override void GenerateClassConstructor(
   CodeClassConstructor e
);
[C++]
protected: override void GenerateClassConstructor(
   CodeClassConstructor* e
);
[JScript]
protected override function GenerateClassConstructor(
   e : CodeClassConstructor
);

Parameters

e
A CodeClassConstructor that indicates the constructor to generate code for.

See Also

JSCodeGenerator Class | JSCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeClassConstructor


JSCodeGenerator.GenerateClassStart

Generates code for the specified CodeDOM based class start representation.

[Visual Basic]
Overrides Protected Sub GenerateClassStart( _
   ByVal e As CodeClass _
)
[C#]
protected override void GenerateClassStart(
   CodeClass e
);
[C++]
protected: override void GenerateClassStart(
   CodeClass* e
);
[JScript]
protected override function GenerateClassStart(
   e : CodeClass
);

Parameters

e
A CodeClass that indicates the start of the class.

See Also

JSCodeGenerator Class | JSCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeClass


JSCodeGenerator.GenerateConstructor

Generates code for the specified CodeDOM based constructor representation.

[Visual Basic]
Overrides Protected Sub GenerateConstructor( _
   ByVal e As CodeConstructor _
)
[C#]
protected override void GenerateConstructor(
   CodeConstructor e
);
[C++]
protected: override void GenerateConstructor(
   CodeConstructor* e
);
[JScript]
protected override function GenerateConstructor(
   e : CodeConstructor
);

Parameters

e
A CodeConstructor that indicates the constructor to generate code for.

See Also

JSCodeGenerator Class | JSCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeConstructor


JSCodeGenerator.GenerateDelegateCreateExpression

Generates code for the specified CodeDOM based delegate creation expression representation.

[Visual Basic]
Overrides Protected Sub GenerateDelegateCreateExpression( _
   ByVal e As CodeDelegateCreateExpression _
)
[C#]
protected override void GenerateDelegateCreateExpression(
   CodeDelegateCreateExpression e
);
[C++]
protected: override void GenerateDelegateCreateExpression(
   CodeDelegateCreateExpression* e
);
[JScript]
protected override function GenerateDelegateCreateExpression(
   e : CodeDelegateCreateExpression
);

Parameters

e
A CodeDelegateCreateExpression that indicates the delegate creation expression to generate code for.

See Also

JSCodeGenerator Class | JSCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeDelegateCreateExpression


JSCodeGenerator.GenerateField

Generates code for the specified CodeDOM based member field representation.

[Visual Basic]
Overrides Protected Sub GenerateField( _
   ByVal e As CodeMemberField _
)
[C#]
protected override void GenerateField(
   CodeMemberField e
);
[C++]
protected: override void GenerateField(
   CodeMemberField* e
);
[JScript]
protected override function GenerateField(
   e : CodeMemberField
);

Parameters

e
A CodeMemberField that indicates the field to generate code for.

See Also

JSCodeGenerator Class | JSCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeMemberField


JSCodeGenerator.GenerateIndexerExpression

Generates code for the specified CodeDOM based indexer expression representation.

[Visual Basic]
Overrides Protected Sub GenerateIndexerExpression( _
   ByVal e As CodeIndexerExpression _
)
[C#]
protected override void GenerateIndexerExpression(
   CodeIndexerExpression e
);
[C++]
protected: override void GenerateIndexerExpression(
   CodeIndexerExpression* e
);
[JScript]
protected override function GenerateIndexerExpression(
   e : CodeIndexerExpression
);

Parameters

e
A CodeIndexerExpression that indicates the expression to generate code for.

See Also

JSCodeGenerator Class | JSCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeIndexerExpression


JSCodeGenerator.GenerateLinePragmaEnd

Generates code for the specified CodeDOM based line pragma end representation.

[Visual Basic]
Overrides Protected Sub GenerateLinePragmaEnd( _
   ByVal e As CodeLinePragma _
)
[C#]
protected override void GenerateLinePragmaEnd(
   CodeLinePragma e
);
[C++]
protected: override void GenerateLinePragmaEnd(
   CodeLinePragma* e
);
[JScript]
protected override function GenerateLinePragmaEnd(
   e : CodeLinePragma
);

Parameters

e
A CodeLinePragma that indicates the end position to generate code for.

See Also

JSCodeGenerator Class | JSCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeLinePragma


JSCodeGenerator.GenerateLinePragmaStart

Generates code for the specified CodeDOM based line pragma start representation.

[Visual Basic]
Overrides Protected Sub GenerateLinePragmaStart( _
   ByVal e As CodeLinePragma _
)
[C#]
protected override void GenerateLinePragmaStart(
   CodeLinePragma e
);
[C++]
protected: override void GenerateLinePragmaStart(
   CodeLinePragma* e
);
[JScript]
protected override function GenerateLinePragmaStart(
   e : CodeLinePragma
);

Parameters

e
A CodeLinePragma that indicates the start position to generate code for.

See Also

JSCodeGenerator Class | JSCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeLinePragma


JSCodeGenerator.GenerateMethod

Generates code for the specified CodeDOM based member method representation.

[Visual Basic]
Overrides Protected Sub GenerateMethod( _
   ByVal e As CodeMemberMethod, _
   ByVal c As CodeClass _
)
[C#]
protected override void GenerateMethod(
   CodeMemberMethod e,
   CodeClass c
);
[C++]
protected: override void GenerateMethod(
   CodeMemberMethod* e,
   CodeClass* c
);
[JScript]
protected override function GenerateMethod(
   e : CodeMemberMethod,
   c : CodeClass
);

Parameters

e
A CodeMemberMethod that indicates the method to generate code for.
c
[To be supplied.]

See Also

JSCodeGenerator Class | JSCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeMemberMethod


JSCodeGenerator.GenerateNamespace

Generates code for the specified CodeDOM based namespace representation.

[Visual Basic]
Overrides Protected Sub GenerateNamespace( _
   ByVal e As CodeNamespace _
)
[C#]
protected override void GenerateNamespace(
   CodeNamespace e
);
[C++]
protected: override void GenerateNamespace(
   CodeNamespace* e
);
[JScript]
protected override function GenerateNamespace(
   e : CodeNamespace
);

Parameters

e
A CodeNamespace that indicates the namespace to generate code for.

See Also

JSCodeGenerator Class | JSCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeNamespace


JSCodeGenerator.GenerateNamespaceEnd

Generates code for the specified CodeDOM based namespace end representation.

[Visual Basic]
Overrides Protected Sub GenerateNamespaceEnd( _
   ByVal e As CodeNamespace _
)
[C#]
protected override void GenerateNamespaceEnd(
   CodeNamespace e
);
[C++]
protected: override void GenerateNamespaceEnd(
   CodeNamespace* e
);
[JScript]
protected override function GenerateNamespaceEnd(
   e : CodeNamespace
);

Parameters

e
A CodeNamespace that indicates the namespace end to generate code for.

See Also

JSCodeGenerator Class | JSCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeNamespace


JSCodeGenerator.GenerateNamespaceImport

Generates code for the specified CodeDOM based namespace import representation.

[Visual Basic]
Overrides Protected Sub GenerateNamespaceImport( _
   ByVal e As CodeNamespaceImport _
)
[C#]
protected override void GenerateNamespaceImport(
   CodeNamespaceImport e
);
[C++]
protected: override void GenerateNamespaceImport(
   CodeNamespaceImport* e
);
[JScript]
protected override function GenerateNamespaceImport(
   e : CodeNamespaceImport
);

Parameters

e
A CodeNamespaceImport that indicates the namespace import to generate code for.

See Also

JSCodeGenerator Class | JSCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeNamespaceImport


JSCodeGenerator.GenerateNamespaceStart

Generates code for the specified CodeDOM based namespace start representation.

[Visual Basic]
Overrides Protected Sub GenerateNamespaceStart( _
   ByVal e As CodeNamespace _
)
[C#]
protected override void GenerateNamespaceStart(
   CodeNamespace e
);
[C++]
protected: override void GenerateNamespaceStart(
   CodeNamespace* e
);
[JScript]
protected override function GenerateNamespaceStart(
   e : CodeNamespace
);

Parameters

e
A CodeNamespace that indicates the namespace start to generate code for.

See Also

JSCodeGenerator Class | JSCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeNamespace


JSCodeGenerator.GenerateProperty

Generates code for the specified CodeDOM based member property representation.

[Visual Basic]
Overrides Protected Sub GenerateProperty( _
   ByVal e As CodeMemberProperty, _
   ByVal c As CodeClass _
)
[C#]
protected override void GenerateProperty(
   CodeMemberProperty e,
   CodeClass c
);
[C++]
protected: override void GenerateProperty(
   CodeMemberProperty* e,
   CodeClass* c
);
[JScript]
protected override function GenerateProperty(
   e : CodeMemberProperty,
   c : CodeClass
);

Parameters

e
A CodeMemberProperty that indicates the member property to generate code for.
c
[To be supplied.]

See Also

JSCodeGenerator Class | JSCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeMemberProperty


JSCodeGenerator.GenerateVariableDeclarationStatement

Generates code for the specified CodeDOM based variable declaration statement representation.

[Visual Basic]
Overrides Protected Sub GenerateVariableDeclarationStatement( _
   ByVal e As CodeVariableDeclarationStatement _
)
[C#]
protected override void GenerateVariableDeclarationStatement(
   CodeVariableDeclarationStatement e
);
[C++]
protected: override void GenerateVariableDeclarationStatement(
   CodeVariableDeclarationStatement* e
);
[JScript]
protected override function GenerateVariableDeclarationStatement(
   e : CodeVariableDeclarationStatement
);

Parameters

e
A CodeVariableDeclarationStatement that indicates the statement to generate code for.

See Also

JSCodeGenerator Class | JSCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeVariableDeclarationStatement


JSCodeGenerator.OutputMemberAccessModifier

Generates code for the specified CodeDOM based member access modifier representation.

[Visual Basic]
Overrides Protected Sub OutputMemberAccessModifier( _
   ByVal attrs As MemberAttributes _
)
[C#]
protected override void OutputMemberAccessModifier(
   MemberAttributes attrs
);
[C++]
protected: override void OutputMemberAccessModifier(
   MemberAttributes attrs
);
[JScript]
protected override function OutputMemberAccessModifier(
   attrs : MemberAttributes
);

Parameters

attrs
A MemberAttributes that indicates the access modifier to generate code for.

See Also

JSCodeGenerator Class | JSCodeGenerator Members | System.CodeDOM.Compiler Namespace | MemberAttributes


JSCodeGenerator.OutputMemberScopeModifier

Generates code for the specified CodeDOM based member scope modifier representation.

[Visual Basic]
Overrides Protected Sub OutputMemberScopeModifier( _
   ByVal attrs As MemberAttributes _
)
[C#]
protected override void OutputMemberScopeModifier(
   MemberAttributes attrs
);
[C++]
protected: override void OutputMemberScopeModifier(
   MemberAttributes attrs
);
[JScript]
protected override function OutputMemberScopeModifier(
   attrs : MemberAttributes
);

Parameters

attrs
A MemberAttributes that indicates the scope modifier to generate code for.

See Also

JSCodeGenerator Class | JSCodeGenerator Members | System.CodeDOM.Compiler Namespace | MemberAttributes


JSCodeGenerator.OutputParameters

Generates code for the specified CodeDOM based parameter declaration expression representation.

[Visual Basic]
Overrides Protected Sub OutputParameters( _
   ByVal parameters As CodeParameterDeclarationExpressionCollection _
)
[C#]
protected override void OutputParameters(
   CodeParameterDeclarationExpressionCollection parameters
);
[C++]
protected: override void OutputParameters(
   CodeParameterDeclarationExpressionCollection* parameters
);
[JScript]
protected override function OutputParameters(
   parameters : CodeParameterDeclarationExpressionCollection
);

Parameters

parameters
A CodeParameterDeclarationExpressionCollection that indicates the parameter declaration expressions to generate code for.

See Also

JSCodeGenerator Class | JSCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeParameterDeclarationExpressionCollection


JSCodeGenerator.OutputType

Generates code for the specified CodeDOM based return type representation.

[Visual Basic]
Overrides Protected Sub OutputType( _
   ByVal typeRef As String _
)
[C#]
protected override void OutputType(
   string typeRef
);
[C++]
protected: override void OutputType(
   String* typeRef
);
[JScript]
protected override function OutputType(
   typeRef : String
);

Parameters

typeRef
A string indicating the return type to generate code for.

See Also

JSCodeGenerator Class | JSCodeGenerator Members | System.CodeDOM.Compiler Namespace


JSCodeGenerator.OutputTypeNamePair

Generates code for the specified CodeDOM based type name pair representation.

[Visual Basic]
Overrides Protected Sub OutputTypeNamePair( _
   ByVal typeRef As String, _
   ByVal name As String _
)
[C#]
protected override void OutputTypeNamePair(
   string typeRef,
   string name
);
[C++]
protected: override void OutputTypeNamePair(
   String* typeRef,
   String* name
);
[JScript]
protected override function OutputTypeNamePair(
   typeRef : String,
   name : String
);

Parameters

typeRef
A string that indicates the type to generate code for.
name
[To be supplied.]

Remarks

This is commonly used for variable declarations.

See Also

JSCodeGenerator Class | JSCodeGenerator Members | System.CodeDOM.Compiler Namespace


JSCodeGenerator.QuoteLiteralString

[To be supplied.]

[Visual Basic]
Overrides Protected Function QuoteLiteralString( _
   ByVal value As String, _
   ByVal escapeUnicode As Boolean _
) As String
[C#]
protected override string QuoteLiteralString(
   string value,
   bool escapeUnicode
);
[C++]
protected: override String* QuoteLiteralString(
   String* value,
   bool escapeUnicode
);
[JScript]
protected override function QuoteLiteralString(
   value : String,
   escapeUnicode : Boolean
) : String;

Parameters

value
[To be supplied.]
escapeUnicode
[To be supplied.]

See Also

JSCodeGenerator Class | JSCodeGenerator Members | System.CodeDOM.Compiler Namespace


TempFiles Class

Collection of temporary file names that are all based on a single base filename located in some temporary directory.

Object
TempFiles

[Visual Basic]
Public Class TempFiles
   Implements ICollection, IEnumerable
[C#]
public class TempFiles : ICollection, IEnumerable
[C++]
public __gc class TempFiles : public ICollection, IEnumerable
[JScript]
public class TempFiles implements ICollection, IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM.Compiler

Assembly: System.dll

See Also

TempFiles Members | System.CodeDOM.Compiler Namespace


TempFiles Members

Public:

Constructor

TempFiles Constructor Overloaded. [To be supplied.]

Properties

BaseFile | [To be supplied.]
BasePath | [To be supplied.]
Count | [To be supplied.]
KeepFiles | [To be supplied.]
TempDir | [To be supplied.]

Methods

AddBaseFile | Overloaded. [To be supplied.]
AddExtension | Overloaded. [To be supplied.]
AddFile | [To be supplied.]
CopyTo | [To be supplied.]
Delete | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TempFiles Class | System.CodeDOM.Compiler Namespace


TempFiles Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public TempFiles();
[C++] public: TempFiles();
[JScript] public function TempFiles();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public TempFiles(String);
[C++] public: TempFiles(String*);
[JScript] public function TempFiles(String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Boolean)
[C#] public TempFiles(String, bool);
[C++] public: TempFiles(String*, bool);
[JScript] public function TempFiles(String, Boolean);

See Also

TempFiles Class | TempFiles Members | System.CodeDOM.Compiler Namespace


TempFiles Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public TempFiles();
[C++]
public: TempFiles();
[JScript]
public function TempFiles();

See Also

TempFiles Class | TempFiles Members | System.CodeDOM.Compiler Namespace | TempFiles Constructor Overload List


TempFiles Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal tempDir As String _
)
[C#]
public TempFiles(
   string tempDir
);
[C++]
public: TempFiles(
   String* tempDir
);
[JScript]
public function TempFiles(
   tempDir : String
);

Parameters

tempDir
[To be supplied.]

See Also

TempFiles Class | TempFiles Members | System.CodeDOM.Compiler Namespace | TempFiles Constructor Overload List


TempFiles Constructor (String, Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal tempDir As String, _
   ByVal keepFiles As Boolean _
)
[C#]
public TempFiles(
   string tempDir,
   bool keepFiles
);
[C++]
public: TempFiles(
   String* tempDir,
   bool keepFiles
);
[JScript]
public function TempFiles(
   tempDir : String,
   keepFiles : Boolean
);

Parameters

tempDir
[To be supplied.]
keepFiles
[To be supplied.]

See Also

TempFiles Class | TempFiles Members | System.CodeDOM.Compiler Namespace | TempFiles Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TempFiles Properties

The properties of the TempFiles class are listed below. For a complete list of TempFiles class members, see the TempFiles Members topic.

Public:

BaseFile | [To be supplied.]
BasePath | [To be supplied.]
Count | [To be supplied.]
KeepFiles | [To be supplied.]
TempDir | [To be supplied.]

See Also

TempFiles Class | System.CodeDOM.Compiler Namespace


TempFiles.BaseFile

[To be supplied.]

[Visual Basic]
Public ReadOnly Property BaseFile As String
[C#]
public string BaseFile {get;}
[C++]
public: __property String* get_BaseFile();
[JScript]
public function get BaseFile() : String;

See Also

TempFiles Class | TempFiles Members | System.CodeDOM.Compiler Namespace


TempFiles.BasePath

[To be supplied.]

[Visual Basic]
Public ReadOnly Property BasePath As String
[C#]
public string BasePath {get;}
[C++]
public: __property String* get_BasePath();
[JScript]
public function get BasePath() : String;

See Also

TempFiles Class | TempFiles Members | System.CodeDOM.Compiler Namespace


TempFiles.Count

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Count As Integer
[C#]
public int Count {virtual get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;

See Also

TempFiles Class | TempFiles Members | System.CodeDOM.Compiler Namespace


TempFiles.KeepFiles

[To be supplied.]

[Visual Basic]
Public Property KeepFiles As Boolean
[C#]
public bool KeepFiles {get; set;}
[C++]
public: __property bool get_KeepFiles();
public: __property void set_KeepFiles(bool);
[JScript]
public function get KeepFiles() : Boolean;
public function set KeepFiles(Boolean);

See Also

TempFiles Class | TempFiles Members | System.CodeDOM.Compiler Namespace


TempFiles.TempDir

[To be supplied.]

[Visual Basic]
Public ReadOnly Property TempDir As String
[C#]
public string TempDir {get;}
[C++]
public: __property String* get_TempDir();
[JScript]
public function get TempDir() : String;

See Also

TempFiles Class | TempFiles Members | System.CodeDOM.Compiler Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TempFiles Methods

The methods of the TempFiles class are listed below. For a complete list of TempFiles class members, see the TempFiles Members topic.

Public:

AddBaseFile | Overloaded. [To be supplied.]
AddExtension | Overloaded. [To be supplied.]
AddFile | [To be supplied.]
CopyTo | [To be supplied.]
Delete | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TempFiles Class | System.CodeDOM.Compiler Namespace


TempFiles.AddBaseFile

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function AddBaseFile(Boolean) As String
[C#] public string AddBaseFile(bool);
[C++] public: String* AddBaseFile(bool);
[JScript] public function AddBaseFile(Boolean) : String;

[To be supplied.]

[Visual Basic] Overloads Public Function AddBaseFile() As String
[C#] public string AddBaseFile();
[C++] public: String* AddBaseFile();
[JScript] public function AddBaseFile() : String;

See Also

TempFiles Class | TempFiles Members | System.CodeDOM.Compiler Namespace


TempFiles.AddBaseFile (Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Function AddBaseFile( _
   ByVal keepFile As Boolean _
) As String
[C#]
public string AddBaseFile(
   bool keepFile
);
[C++]
public: String* AddBaseFile(
   bool keepFile
);
[JScript]
public function AddBaseFile(
   keepFile : Boolean
) : String;

Parameters

keepFile
[To be supplied.]

See Also

TempFiles Class | TempFiles Members | System.CodeDOM.Compiler Namespace | TempFiles.AddBaseFile Overload List


TempFiles.AddBaseFile ()

[To be supplied.]

[Visual Basic]
Overloads Public Function AddBaseFile() As String
[C#]
public string AddBaseFile();
[C++]
public: String* AddBaseFile();
[JScript]
public function AddBaseFile() : String;

See Also

TempFiles Class | TempFiles Members | System.CodeDOM.Compiler Namespace | TempFiles.AddBaseFile Overload List


TempFiles.AddExtension

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function AddExtension(String, Boolean) As String
[C#] public string AddExtension(String, bool);
[C++] public: String* AddExtension(String*, bool);
[JScript] public function AddExtension(String, Boolean) : String;

[To be supplied.]

[Visual Basic] Overloads Public Function AddExtension(String) As String
[C#] public string AddExtension(String);
[C++] public: String* AddExtension(String*);
[JScript] public function AddExtension(String) : String;

See Also

TempFiles Class | TempFiles Members | System.CodeDOM.Compiler Namespace


TempFiles.AddExtension (String, Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Function AddExtension( _
   ByVal fileExtension As String, _
   ByVal keepFile As Boolean _
) As String
[C#]
public string AddExtension(
   string fileExtension,
   bool keepFile
);
[C++]
public: String* AddExtension(
   String* fileExtension,
   bool keepFile
);
[JScript]
public function AddExtension(
   fileExtension : String,
   keepFile : Boolean
) : String;

Parameters

fileExtension
[To be supplied.]
keepFile
[To be supplied.]

See Also

TempFiles Class | TempFiles Members | System.CodeDOM.Compiler Namespace | TempFiles.AddExtension Overload List


TempFiles.AddExtension (String)

[To be supplied.]

[Visual Basic]
Overloads Public Function AddExtension( _
   ByVal fileExtension As String _
) As String
[C#]
public string AddExtension(
   string fileExtension
);
[C++]
public: String* AddExtension(
   String* fileExtension
);
[JScript]
public function AddExtension(
   fileExtension : String
) : String;

Parameters

fileExtension
[To be supplied.]

See Also

TempFiles Class | TempFiles Members | System.CodeDOM.Compiler Namespace | TempFiles.AddExtension Overload List


TempFiles.AddFile

[To be supplied.]

[Visual Basic]
Public Sub AddFile( _
   ByVal fileName As String, _
   ByVal keepFile As Boolean _
)
[C#]
public void AddFile(
   string fileName,
   bool keepFile
);
[C++]
public: void AddFile(
   String* fileName,
   bool keepFile
);
[JScript]
public function AddFile(
   fileName : String,
   keepFile : Boolean
);

Parameters

fileName
[To be supplied.]
keepFile
[To be supplied.]

See Also

TempFiles Class | TempFiles Members | System.CodeDOM.Compiler Namespace


TempFiles.CopyTo

[To be supplied.]

[Visual Basic]
Public Sub CopyTo( _
   ByVal fileNames() As String, _
   ByVal start As Integer _
)
[C#]
public void CopyTo(
   string[] fileNames,
   int start
);
[C++]
public: void CopyTo(
   String* fileNames[],
   int start
);
[JScript]
public function CopyTo(
   fileNames : String[],
   start : int
);

Parameters

fileNames
[To be supplied.]
start
[To be supplied.]

See Also

TempFiles Class | TempFiles Members | System.CodeDOM.Compiler Namespace


TempFiles.Delete

[To be supplied.]

[Visual Basic]
Public Sub Delete()
[C#]
public void Delete();
[C++]
public: void Delete();
[JScript]
public function Delete();

See Also

TempFiles Class | TempFiles Members | System.CodeDOM.Compiler Namespace


TempFiles.Finalize

[To be supplied.]

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

TempFiles Class | TempFiles Members | System.CodeDOM.Compiler Namespace


TempFiles.GetEnumerator

[To be supplied.]

[Visual Basic]
Overridable Public Function GetEnumerator() As IEnumerator
[C#]
public virtual IEnumerator GetEnumerator();
[C++]
public: virtual IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

See Also

TempFiles Class | TempFiles Members | System.CodeDOM.Compiler Namespace


VBCodeGenerator Class

Visual Basic 7 Code Generator.

Object
CodeGenerator
CodeCompiler
VBCodeGenerator

[Visual Basic]
Public Class VBCodeGenerator
   Inherits CodeCompiler
[C#]
public class VBCodeGenerator : CodeCompiler
[C++]
public __gc class VBCodeGenerator : public CodeCompiler
[JScript]
public class VBCodeGenerator extends CodeCompiler

Remarks

[To be supplied.]

Requirements

Namespace: System.CodeDOM.Compiler

Assembly: System.dll

See Also

VBCodeGenerator Members | System.CodeDOM.Compiler Namespace


VBCodeGenerator Members

Public:

Constructor

VBCodeGenerator Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

CurrentClassName (inherited from CodeGenerator) | Gets or sets the current class name.
CurrentMember (inherited from CodeGenerator) | Gets or sets the current member of the class.
CurrentMemberName (inherited from CodeGenerator) | Gets or sets the current member name.
CurrentNamespace (inherited from CodeGenerator) | Gets or sets the name of the current namespace.
FileExtension | Gets or sets the file extension to output code to.
Indent (inherited from CodeGenerator) | Gets or sets the amount of spaces to indent.
IsCurrentClass (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current class.
IsCurrentDelegate (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current delegate.
IsCurrentEnum (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current enumeration.
IsCurrentInterface (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current interface.
IsCurrentStruct (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current structure.
Output (inherited from CodeGenerator) | Gets or sets the TextWriter to use for output.
SupportsAdvanced (inherited from CodeCompiler) | [To be supplied.]

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
FromDOM (inherited from CodeCompiler) | [To be supplied.]
FromDOMBatch | Gets the results of compilation after compiling with the specified options and files.
FromFile (inherited from CodeCompiler) | [To be supplied.]
FromFileBatch | Gets the results of compilation after compiling with the specified options and files.
FromSource (inherited from CodeCompiler) | [To be supplied.]
FromSourceBatch (inherited from CodeCompiler) | [To be supplied.]
GenerateArrayCreateExpression | Generates code for the specified CodeDOM based array creation expression representation.
GenerateAssignStatement | Generates code for the specified CodeDOM based assignment statement representation.
GenerateAttributeBlockEnd | Generates code for the specified CodeDOM based attribute block end representation.
GenerateAttributeBlockStart | Generates code for the specified CodeDOM based attribute block start representation.
GenerateBaseReferenceExpression | Generates code for the specified CodeDOM based base reference expression representation.
GenerateBinaryOperatorExpression | [To be supplied.]
GenerateCastExpression | Generates code for the specified CodeDOM based cast expression representation.
GenerateClassConstructor | Generates code for the specified CodeDOM based class constructor representation.
GenerateClassEnd | Generates code for the specified CodeDOM based class end representation.
GenerateClasses (inherited from CodeGenerator) | Generates classes using CodeDOM representation for the specified namespace.
GenerateClassStart | Generates code for the CodeDOM based class start representation.
GenerateCommentStatement | Generates code for the specified CodeDOM based comment statement representation.
GenerateConstructor | Generates code for the specified CodeDOM based constructor representation.
GenerateDelegateCreateExpression | Generates code for the specified CodeDOM based delegate creation expression representation.
GenerateDelegateInvokeExpression | Generates code for the specified CodeDOM based delegate invoke expression.
GenerateDelegateInvokeStatement | Generates code for the specified CodeDOM based delegate invoke statement representation.
GenerateExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based code expression.
GenerateField | Generates code for the specified CodeDOM based member field representation.
GenerateFieldReferenceExpression | Generates code for the specified CodeDOM based field reference expression representation.
GenerateForLoopStatement | Generates code for the specified CodeDOM based for loop statement representation.
GenerateIfStatement | Generates code for the specified CodeDOM based if statement representation.
GenerateIndexerExpression | Generates code for the specified CodeDOM based indexer expression representation.
GenerateLinePragmaEnd | Generates code for the specified CodeDOM based line pragma end representation.
GenerateLinePragmaStart | Generates code for the specified CodeDOM based line pragma start representation.
GenerateLiteralExpression | Generates code for the specified CodeDOM based code literal expression representation.
GenerateLiteralMember | Generates code for the specified CodeDOM based literal member representation.
GenerateLiteralStatement | Generates code for the specified CodeDOM based literal statement representation.
GenerateMethod | Generates code for the specified CodeDOM based member method representation.
GenerateMethodInvokeExpression | Generates code for the specified CodeDOM based method invoke expression.
GenerateMethodInvokeStatement | Generates code for the specified CodeDOM based method invoke statement representation.
GenerateMethodReturnStatement | Generates code for the specified CodeDOM based method return statement representation.
GenerateNamespace | Generates code for the CodeDOM based namespace representation.
GenerateNamespaceEnd | Generates code for the specified CodeDOM based namespace representation.
GenerateNamespaceImport | Generates code for the specified CodeDOM based namespace import representation.
GenerateNamespaceImports (inherited from CodeGenerator) | Generates code for the specified CodeDOM based namespace import representation.
GenerateNamespaceStart | Generates code for the specified CodeDOM based namespace representation.
GenerateObjectCreateExpression | Generates code for the specified CodeDOM based object creation expression.
GenerateParameterDeclarationExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based parameter declaration expression representation.
GeneratePrimitiveExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based primitive expression representation.
GenerateProperty | Generates code for the specified CodeDOM based member property representation.
GeneratePropertyReferenceExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based property reference expression representation.
GenerateStatement (inherited from CodeGenerator) | Generates code for the specified CodeDOM based statement representation.
GenerateStatements (inherited from CodeGenerator) | Generates code for the specified CodeDOM based statement representations.
GenerateThisReferenceExpression | Generates code for the specified CodeDOM based this reference expression representation.
GenerateThrowExceptionStatement | Generates code for the specified CodeDOM based throw exception statement representation.
GenerateTryCatchFinallyStatement | Generates code for the specified CodeDOM based try catch finally statement representation.
GenerateTypeOfExpression | [To be supplied.]
GenerateTypeReferenceExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based type reference expression representation.
GenerateVariableDeclarationStatement | Generates code for the specified CodeDOM variable declaration statement representation.
GetNullToken | Gets the token that is used to represent a null reference (in Visual Basic Nothing).
GetTypeArrayRank (inherited from CodeGenerator) | [To be supplied.]
GetTypeBaseType (inherited from CodeGenerator) | Gets the base type of the specified type.
IsValidIdentifier | Gets whether the specified identifier is valid.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OutputAttributeArgument | [To be supplied.]
OutputAttributeBlock (inherited from CodeGenerator) | Generates code for the specified CodeAttributeBlock.
OutputDirection | Generates code for the specified CodeDOM based field direction representation.
OutputExpressionList (inherited from CodeGenerator) | Overloaded. [To be supplied.]
OutputMemberAccessModifier | Generates code for the specified CodeDOM based member access modifier representation.
OutputMemberScopeModifier | Generates code for the specified CodeDOM based member scope modifier representation.
OutputOperator | Generates code for the specified CodeDOM based operator representation.
OutputParameters (inherited from CodeGenerator) | Generates code for the specified parameters.
OutputType | Generates code for the specified CodeDOM based return type representation.
OutputTypeAttributes | Generates code for the specified CodeDOM based type attributes representation.
OutputTypeNamePair | Generates code for the specified CodeDOM based type name pair representation.
QuoteLiteralString | Provides conversion to formatting with escape codes.
ValidateIdentifier (inherited from CodeGenerator) | Gets whether the specified identifier is valid.

See Also

VBCodeGenerator Class | System.CodeDOM.Compiler Namespace


VBCodeGenerator Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public VBCodeGenerator();
[C++]
public: VBCodeGenerator();
[JScript]
public function VBCodeGenerator();

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

VBCodeGenerator Properties

The properties of the VBCodeGenerator class are listed below. For a complete list of VBCodeGenerator class members, see the VBCodeGenerator Members topic.

Protected:

CurrentClassName (inherited from CodeGenerator) | Gets or sets the current class name.
CurrentMember (inherited from CodeGenerator) | Gets or sets the current member of the class.
CurrentMemberName (inherited from CodeGenerator) | Gets or sets the current member name.
CurrentNamespace (inherited from CodeGenerator) | Gets or sets the name of the current namespace.
FileExtension | Gets or sets the file extension to output code to.
Indent (inherited from CodeGenerator) | Gets or sets the amount of spaces to indent.
IsCurrentClass (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current class.
IsCurrentDelegate (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current delegate.
IsCurrentEnum (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current enumeration.
IsCurrentInterface (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current interface.
IsCurrentStruct (inherited from CodeGenerator) | Gets or sets a value indicating whether the current object represented is the current structure.
Output (inherited from CodeGenerator) | Gets or sets the TextWriter to use for output.
SupportsAdvanced (inherited from CodeCompiler) | [To be supplied.]

See Also

VBCodeGenerator Class | System.CodeDOM.Compiler Namespace


VBCodeGenerator.FileExtension

Gets or sets the file extension to output code to.

[Visual Basic]
Overridable Protected ReadOnly Property FileExtension As String
[C#]
protected string FileExtension {override get;}
[C++]
protected: __property virtual String* get_FileExtension();
[JScript]
protected function get FileExtension() : String;

Property Value

The file extension to output code to.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

VBCodeGenerator Methods

The methods of the VBCodeGenerator class are listed below. For a complete list of VBCodeGenerator class members, see the VBCodeGenerator Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
FromDOM (inherited from CodeCompiler) | [To be supplied.]
FromDOMBatch | Gets the results of compilation after compiling with the specified options and files.
FromFile (inherited from CodeCompiler) | [To be supplied.]
FromFileBatch | Gets the results of compilation after compiling with the specified options and files.
FromSource (inherited from CodeCompiler) | [To be supplied.]
FromSourceBatch (inherited from CodeCompiler) | [To be supplied.]
GenerateArrayCreateExpression | Generates code for the specified CodeDOM based array creation expression representation.
GenerateAssignStatement | Generates code for the specified CodeDOM based assignment statement representation.
GenerateAttributeBlockEnd | Generates code for the specified CodeDOM based attribute block end representation.
GenerateAttributeBlockStart | Generates code for the specified CodeDOM based attribute block start representation.
GenerateBaseReferenceExpression | Generates code for the specified CodeDOM based base reference expression representation.
GenerateBinaryOperatorExpression | [To be supplied.]
GenerateCastExpression | Generates code for the specified CodeDOM based cast expression representation.
GenerateClassConstructor | Generates code for the specified CodeDOM based class constructor representation.
GenerateClassEnd | Generates code for the specified CodeDOM based class end representation.
GenerateClasses (inherited from CodeGenerator) | Generates classes using CodeDOM representation for the specified namespace.
GenerateClassStart | Generates code for the CodeDOM based class start representation.
GenerateCommentStatement | Generates code for the specified CodeDOM based comment statement representation.
GenerateConstructor | Generates code for the specified CodeDOM based constructor representation.
GenerateDelegateCreateExpression | Generates code for the specified CodeDOM based delegate creation expression representation.
GenerateDelegateInvokeExpression | Generates code for the specified CodeDOM based delegate invoke expression.
GenerateDelegateInvokeStatement | Generates code for the specified CodeDOM based delegate invoke statement representation.
GenerateExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based code expression.
GenerateField | Generates code for the specified CodeDOM based member field representation.
GenerateFieldReferenceExpression | Generates code for the specified CodeDOM based field reference expression representation.
GenerateForLoopStatement | Generates code for the specified CodeDOM based for loop statement representation.
GenerateIfStatement | Generates code for the specified CodeDOM based if statement representation.
GenerateIndexerExpression | Generates code for the specified CodeDOM based indexer expression representation.
GenerateLinePragmaEnd | Generates code for the specified CodeDOM based line pragma end representation.
GenerateLinePragmaStart | Generates code for the specified CodeDOM based line pragma start representation.
GenerateLiteralExpression | Generates code for the specified CodeDOM based code literal expression representation.
GenerateLiteralMember | Generates code for the specified CodeDOM based literal member representation.
GenerateLiteralStatement | Generates code for the specified CodeDOM based literal statement representation.
GenerateMethod | Generates code for the specified CodeDOM based member method representation.
GenerateMethodInvokeExpression | Generates code for the specified CodeDOM based method invoke expression.
GenerateMethodInvokeStatement | Generates code for the specified CodeDOM based method invoke statement representation.
GenerateMethodReturnStatement | Generates code for the specified CodeDOM based method return statement representation.
GenerateNamespace | Generates code for the CodeDOM based namespace representation.
GenerateNamespaceEnd | Generates code for the specified CodeDOM based namespace representation.
GenerateNamespaceImport | Generates code for the specified CodeDOM based namespace import representation.
GenerateNamespaceImports (inherited from CodeGenerator) | Generates code for the specified CodeDOM based namespace import representation.
GenerateNamespaceStart | Generates code for the specified CodeDOM based namespace representation.
GenerateObjectCreateExpression | Generates code for the specified CodeDOM based object creation expression.
GenerateParameterDeclarationExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based parameter declaration expression representation.
GeneratePrimitiveExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based primitive expression representation.
GenerateProperty | Generates code for the specified CodeDOM based member property representation.
GeneratePropertyReferenceExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based property reference expression representation.
GenerateStatement (inherited from CodeGenerator) | Generates code for the specified CodeDOM based statement representation.
GenerateStatements (inherited from CodeGenerator) | Generates code for the specified CodeDOM based statement representations.
GenerateThisReferenceExpression | Generates code for the specified CodeDOM based this reference expression representation.
GenerateThrowExceptionStatement | Generates code for the specified CodeDOM based throw exception statement representation.
GenerateTryCatchFinallyStatement | Generates code for the specified CodeDOM based try catch finally statement representation.
GenerateTypeOfExpression | [To be supplied.]
GenerateTypeReferenceExpression (inherited from CodeGenerator) | Generates code for the specified CodeDOM based type reference expression representation.
GenerateVariableDeclarationStatement | Generates code for the specified CodeDOM variable declaration statement representation.
GetNullToken | Gets the token that is used to represent a null reference (in Visual Basic Nothing).
GetTypeArrayRank (inherited from CodeGenerator) | [To be supplied.]
GetTypeBaseType (inherited from CodeGenerator) | Gets the base type of the specified type.
IsValidIdentifier | Gets whether the specified identifier is valid.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OutputAttributeArgument | [To be supplied.]
OutputAttributeBlock (inherited from CodeGenerator) | Generates code for the specified CodeAttributeBlock.
OutputDirection | Generates code for the specified CodeDOM based field direction representation.
OutputExpressionList (inherited from CodeGenerator) | Overloaded. [To be supplied.]
OutputMemberAccessModifier | Generates code for the specified CodeDOM based member access modifier representation.
OutputMemberScopeModifier | Generates code for the specified CodeDOM based member scope modifier representation.
OutputOperator | Generates code for the specified CodeDOM based operator representation.
OutputParameters (inherited from CodeGenerator) | Generates code for the specified parameters.
OutputType | Generates code for the specified CodeDOM based return type representation.
OutputTypeAttributes | Generates code for the specified CodeDOM based type attributes representation.
OutputTypeNamePair | Generates code for the specified CodeDOM based type name pair representation.
QuoteLiteralString | Provides conversion to formatting with escape codes.
ValidateIdentifier (inherited from CodeGenerator) | Gets whether the specified identifier is valid.

See Also

VBCodeGenerator Class | System.CodeDOM.Compiler Namespace


VBCodeGenerator.FromDOMBatch

Gets the results of compilation after compiling with the specified options and files.

[Visual Basic]
Overrides Protected Function FromDOMBatch( _
   ByVal options As CompilerParameters, _
   ByVal ea() As CodeNamespace _
) As CompilerResults
[C#]
protected override CompilerResults FromDOMBatch(
   CompilerParameters options,
   CodeNamespace[] ea
);
[C++]
protected: override CompilerResults* FromDOMBatch(
   CompilerParameters* options,
   CodeNamespace* ea[]
);
[JScript]
protected override function FromDOMBatch(
   options : CompilerParameters,
   ea : CodeNamespace[]
) : CompilerResults;

Parameters

options
A CompilerParameters that indicates the options to use to compile.
ea
[To be supplied.]

Return Value

A CompilerResults that indicates the results of compilation.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CompilerParameters | CompilerResults | CodeNamespace


VBCodeGenerator.FromFileBatch

Gets the results of compilation after compiling with the specified options and files.

[Visual Basic]
Overrides Protected Function FromFileBatch( _
   ByVal options As CompilerParameters, _
   ByVal fileNames() As String _
) As CompilerResults
[C#]
protected override CompilerResults FromFileBatch(
   CompilerParameters options,
   string[] fileNames
);
[C++]
protected: override CompilerResults* FromFileBatch(
   CompilerParameters* options,
   String* fileNames[]
);
[JScript]
protected override function FromFileBatch(
   options : CompilerParameters,
   fileNames : String[]
) : CompilerResults;

Parameters

options
A CompilerParameters that indicates the options to use to compile.
fileNames
[To be supplied.]

Return Value

A CompilerResults that indicates the results of compilation.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CompilerParameters | CompilerResults


VBCodeGenerator.GenerateArrayCreateExpression

Generates code for the specified CodeDOM based array creation expression representation.

[Visual Basic]
Overrides Protected Sub GenerateArrayCreateExpression( _
   ByVal e As CodeArrayCreateExpression _
)
[C#]
protected override void GenerateArrayCreateExpression(
   CodeArrayCreateExpression e
);
[C++]
protected: override void GenerateArrayCreateExpression(
   CodeArrayCreateExpression* e
);
[JScript]
protected override function GenerateArrayCreateExpression(
   e : CodeArrayCreateExpression
);

Parameters

e
A CodeArrayCreateExpression that indicates the expression to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeArrayCreateExpression


VBCodeGenerator.GenerateAssignStatement

Generates code for the specified CodeDOM based assignment statement representation.

[Visual Basic]
Overrides Protected Sub GenerateAssignStatement( _
   ByVal e As CodeAssignStatement _
)
[C#]
protected override void GenerateAssignStatement(
   CodeAssignStatement e
);
[C++]
protected: override void GenerateAssignStatement(
   CodeAssignStatement* e
);
[JScript]
protected override function GenerateAssignStatement(
   e : CodeAssignStatement
);

Parameters

e
A CodeAssignStatement that indicates the assignment statement to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeAssignStatement


VBCodeGenerator.GenerateAttributeBlockEnd

Generates code for the specified CodeDOM based attribute block end representation.

[Visual Basic]
Overrides Protected Sub GenerateAttributeBlockEnd( _
   ByVal attributes As CodeAttributeBlock _
)
[C#]
protected override void GenerateAttributeBlockEnd(
   CodeAttributeB attributes
);
[C++]
protected: override void GenerateAttributeBlockEnd(
   CodeAttributeBlock* attributes
);
[JScript]
protected override function GenerateAttributeBlockEnd(
   attributes : CodeAttributeBlock
);

Parameters

attributes
A CodeAttributeBlock that indicates the attributes to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeAttributeBlock


VBCodeGenerator.GenerateAttributeBlockStart

Generates code for the specified CodeDOM based attribute block start representation.

[Visual Basic]
Overrides Protected Sub GenerateAttributeBlockStart( _
   ByVal attributes As CodeAttributeBlock _
)
[C#]
protected override void GenerateAttributeBlockStart(
   CodeAttributeB attributes
);
[C++]
protected: override void GenerateAttributeBlockStart(
   CodeAttributeBlock* attributes
);
[JScript]
protected override function GenerateAttributeBlockStart(
   attributes : CodeAttributeBlock
);

Parameters

attributes
A CodeAttributeBlock that indicates the attribute block to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeAttributeBlock


VBCodeGenerator.GenerateBaseReferenceExpression

Generates code for the specified CodeDOM based base reference expression representation.

[Visual Basic]
Overrides Protected Sub GenerateBaseReferenceExpression( _
   ByVal e As CodeBaseReferenceExpression _
)
[C#]
protected override void GenerateBaseReferenceExpression(
   CodeBaseReferenceExpression e
);
[C++]
protected: override void GenerateBaseReferenceExpression(
   CodeBaseReferenceExpression* e
);
[JScript]
protected override function GenerateBaseReferenceExpression(
   e : CodeBaseReferenceExpression
);

Parameters

e
A CodeBaseReferenceExpression that indicates the expression to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeBaseReferenceExpression


VBCodeGenerator.GenerateBinaryOperatorExpression

[To be supplied.]

[Visual Basic]
Overrides Protected Sub GenerateBinaryOperatorExpression( _
   ByVal e As CodeBinaryOperatorExpression _
)
[C#]
protected override void GenerateBinaryOperatorExpression(
   CodeBinaryOperatorExpression e
);
[C++]
protected: override void GenerateBinaryOperatorExpression(
   CodeBinaryOperatorExpression* e
);
[JScript]
protected override function GenerateBinaryOperatorExpression(
   e : CodeBinaryOperatorExpression
);

Parameters

e
[To be supplied.]

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace


VBCodeGenerator.GenerateCastExpression

Generates code for the specified CodeDOM based cast expression representation.

[Visual Basic]
Overrides Protected Sub GenerateCastExpression( _
   ByVal e As CodeCastExpression _
)
[C#]
protected override void GenerateCastExpression(
   CodeCastExpression e
);
[C++]
protected: override void GenerateCastExpression(
   CodeCastExpression* e
);
[JScript]
protected override function GenerateCastExpression(
   e : CodeCastExpression
);

Parameters

e
A CodeCastExpression that indicates the expression to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeCastExpression


VBCodeGenerator.GenerateClassConstructor

Generates code for the specified CodeDOM based class constructor representation.

[Visual Basic]
Overrides Protected Sub GenerateClassConstructor( _
   ByVal e As CodeClassConstructor _
)
[C#]
protected override void GenerateClassConstructor(
   CodeClassConstructor e
);
[C++]
protected: override void GenerateClassConstructor(
   CodeClassConstructor* e
);
[JScript]
protected override function GenerateClassConstructor(
   e : CodeClassConstructor
);

Parameters

e
A CodeClassConstructor that indicates the class constructor to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeClassConstructor


VBCodeGenerator.GenerateClassEnd

Generates code for the specified CodeDOM based class end representation.

[Visual Basic]
Overrides Protected Sub GenerateClassEnd( _
   ByVal e As CodeClass _
)
[C#]
protected override void GenerateClassEnd(
   CodeClass e
);
[C++]
protected: override void GenerateClassEnd(
   CodeClass* e
);
[JScript]
protected override function GenerateClassEnd(
   e : CodeClass
);

Parameters

e
A CodeClass that indicates the class end to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeClass


VBCodeGenerator.GenerateClassStart

Generates code for the CodeDOM based class start representation.

[Visual Basic]
Overrides Protected Sub GenerateClassStart( _
   ByVal e As CodeClass _
)
[C#]
protected override void GenerateClassStart(
   CodeClass e
);
[C++]
protected: override void GenerateClassStart(
   CodeClass* e
);
[JScript]
protected override function GenerateClassStart(
   e : CodeClass
);

Parameters

e
A CodeClass that indicates the class start to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeClass


VBCodeGenerator.GenerateCommentStatement

Generates code for the specified CodeDOM based comment statement representation.

[Visual Basic]
Overrides Protected Sub GenerateCommentStatement( _
   ByVal e As CodeCommentStatement _
)
[C#]
protected override void GenerateCommentStatement(
   CodeCommentStatement e
);
[C++]
protected: override void GenerateCommentStatement(
   CodeCommentStatement* e
);
[JScript]
protected override function GenerateCommentStatement(
   e : CodeCommentStatement
);

Parameters

e
A CodeCommentStatement that indicates the statement to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeCommentStatement


VBCodeGenerator.GenerateConstructor

Generates code for the specified CodeDOM based constructor representation.

[Visual Basic]
Overrides Protected Sub GenerateConstructor( _
   ByVal e As CodeConstructor _
)
[C#]
protected override void GenerateConstructor(
   CodeConstructor e
);
[C++]
protected: override void GenerateConstructor(
   CodeConstructor* e
);
[JScript]
protected override function GenerateConstructor(
   e : CodeConstructor
);

Parameters

e
A CodeConstructor that indicates the constructor to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeConstructor


VBCodeGenerator.GenerateDelegateCreateExpression

Generates code for the specified CodeDOM based delegate creation expression representation.

[Visual Basic]
Overrides Protected Sub GenerateDelegateCreateExpression( _
   ByVal e As CodeDelegateCreateExpression _
)
[C#]
protected override void GenerateDelegateCreateExpression(
   CodeDelegateCreateExpression e
);
[C++]
protected: override void GenerateDelegateCreateExpression(
   CodeDelegateCreateExpression* e
);
[JScript]
protected override function GenerateDelegateCreateExpression(
   e : CodeDelegateCreateExpression
);

Parameters

e
A CodeDelegateCreateExpression that indicates the expression to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeDelegateCreateExpression


VBCodeGenerator.GenerateDelegateInvokeExpression

Generates code for the specified CodeDOM based delegate invoke expression.

[Visual Basic]
Overrides Protected Sub GenerateDelegateInvokeExpression( _
   ByVal e As CodeDelegateInvokeExpression _
)
[C#]
protected override void GenerateDelegateInvokeExpression(
   CodeDelegateInvokeExpression e
);
[C++]
protected: override void GenerateDelegateInvokeExpression(
   CodeDelegateInvokeExpression* e
);
[JScript]
protected override function GenerateDelegateInvokeExpression(
   e : CodeDelegateInvokeExpression
);

Parameters

e
A CodeDelegateInvokeExpression that indicates the expression to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeDelegateInvokeExpression


VBCodeGenerator.GenerateDelegateInvokeStatement

Generates code for the specified CodeDOM based delegate invoke statement representation.

[Visual Basic]
Overrides Protected Sub GenerateDelegateInvokeStatement( _
   ByVal e As CodeDelegateInvokeStatement _
)
[C#]
protected override void GenerateDelegateInvokeStatement(
   CodeDelegateInvokeStatement e
);
[C++]
protected: override void GenerateDelegateInvokeStatement(
   CodeDelegateInvokeStatement* e
);
[JScript]
protected override function GenerateDelegateInvokeStatement(
   e : CodeDelegateInvokeStatement
);

Parameters

e
A CodeDelegateInvokeStatement that indicates the statement to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeDelegateInvokeStatement


VBCodeGenerator.GenerateField

Generates code for the specified CodeDOM based member field representation.

[Visual Basic]
Overrides Protected Sub GenerateField( _
   ByVal e As CodeMemberField _
)
[C#]
protected override void GenerateField(
   CodeMemberField e
);
[C++]
protected: override void GenerateField(
   CodeMemberField* e
);
[JScript]
protected override function GenerateField(
   e : CodeMemberField
);

Parameters

e
A CodeMemberField that indicates the field to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeMemberField


VBCodeGenerator.GenerateFieldReferenceExpression

Generates code for the specified CodeDOM based field reference expression representation.

[Visual Basic]
Overrides Protected Sub GenerateFieldReferenceExpression( _
   ByVal e As CodeFieldReferenceExpression _
)
[C#]
protected override void GenerateFieldReferenceExpression(
   CodeFieldReferenceExpression e
);
[C++]
protected: override void GenerateFieldReferenceExpression(
   CodeFieldReferenceExpression* e
);
[JScript]
protected override function GenerateFieldReferenceExpression(
   e : CodeFieldReferenceExpression
);

Parameters

e
A CodeFieldReferenceExpression that indicates the expression to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeFieldReferenceExpression


VBCodeGenerator.GenerateForLoopStatement

Generates code for the specified CodeDOM based for loop statement representation.

[Visual Basic]
Overrides Protected Sub GenerateForLoopStatement( _
   ByVal e As CodeForLoopStatement _
)
[C#]
protected override void GenerateForLoopStatement(
   CodeForLoopStatement e
);
[C++]
protected: override void GenerateForLoopStatement(
   CodeForLoopStatement* e
);
[JScript]
protected override function GenerateForLoopStatement(
   e : CodeForLoopStatement
);

Parameters

e
A CodeForLoopStatement that indicates the statement to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeForLoopStatement


VBCodeGenerator.GenerateIfStatement

Generates code for the specified CodeDOM based if statement representation.

[Visual Basic]
Overrides Protected Sub GenerateIfStatement( _
   ByVal e As CodeIfStatement _
)
[C#]
protected override void GenerateIfStatement(
   CodeIfStatement e
);
[C++]
protected: override void GenerateIfStatement(
   CodeIfStatement* e
);
[JScript]
protected override function GenerateIfStatement(
   e : CodeIfStatement
);

Parameters

e
A CodeIfStatement that indicates the if statement to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeIfStatement


VBCodeGenerator.GenerateIndexerExpression

Generates code for the specified CodeDOM based indexer expression representation.

[Visual Basic]
Overrides Protected Sub GenerateIndexerExpression( _
   ByVal e As CodeIndexerExpression _
)
[C#]
protected override void GenerateIndexerExpression(
   CodeIndexerExpression e
);
[C++]
protected: override void GenerateIndexerExpression(
   CodeIndexerExpression* e
);
[JScript]
protected override function GenerateIndexerExpression(
   e : CodeIndexerExpression
);

Parameters

e
A CodeIndexerExpression that indicates the expression to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeIndexerExpression


VBCodeGenerator.GenerateLinePragmaEnd

Generates code for the specified CodeDOM based line pragma end representation.

[Visual Basic]
Overrides Protected Sub GenerateLinePragmaEnd( _
   ByVal e As CodeLinePragma _
)
[C#]
protected override void GenerateLinePragmaEnd(
   CodeLinePragma e
);
[C++]
protected: override void GenerateLinePragmaEnd(
   CodeLinePragma* e
);
[JScript]
protected override function GenerateLinePragmaEnd(
   e : CodeLinePragma
);

Parameters

e
A CodeLinePragma that indicates the line pragma end to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeLinePragma


VBCodeGenerator.GenerateLinePragmaStart

Generates code for the specified CodeDOM based line pragma start representation.

[Visual Basic]
Overrides Protected Sub GenerateLinePragmaStart( _
   ByVal e As CodeLinePragma _
)
[C#]
protected override void GenerateLinePragmaStart(
   CodeLinePragma e
);
[C++]
protected: override void GenerateLinePragmaStart(
   CodeLinePragma* e
);
[JScript]
protected override function GenerateLinePragmaStart(
   e : CodeLinePragma
);

Parameters

e
A CodeLinePragma that indicates the line pragma start to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeLinePragma


VBCodeGenerator.GenerateLiteralExpression

Generates code for the specified CodeDOM based code literal expression representation.

[Visual Basic]
Overrides Protected Sub GenerateLiteralExpression( _
   ByVal e As CodeLiteralExpression _
)
[C#]
protected override void GenerateLiteralExpression(
   CodeLiteralExpression e
);
[C++]
protected: override void GenerateLiteralExpression(
   CodeLiteralExpression* e
);
[JScript]
protected override function GenerateLiteralExpression(
   e : CodeLiteralExpression
);

Parameters

e
A CodeLiteralExpression that indicates the expression to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeLiteralExpression


VBCodeGenerator.GenerateLiteralMember

Generates code for the specified CodeDOM based literal member representation.

[Visual Basic]
Overrides Protected Sub GenerateLiteralMember( _
   ByVal e As CodeLiteralClassMember _
)
[C#]
protected override void GenerateLiteralMember(
   CodeLiteralClassMember e
);
[C++]
protected: override void GenerateLiteralMember(
   CodeLiteralClassMember* e
);
[JScript]
protected override function GenerateLiteralMember(
   e : CodeLiteralClassMember
);

Parameters

e
A CodeLiteralClassMember that indicates the member to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeLiteralClassMember


VBCodeGenerator.GenerateLiteralStatement

Generates code for the specified CodeDOM based literal statement representation.

[Visual Basic]
Overrides Protected Sub GenerateLiteralStatement( _
   ByVal e As CodeLiteralStatement _
)
[C#]
protected override void GenerateLiteralStatement(
   CodeLiteralStatement e
);
[C++]
protected: override void GenerateLiteralStatement(
   CodeLiteralStatement* e
);
[JScript]
protected override function GenerateLiteralStatement(
   e : CodeLiteralStatement
);

Parameters

e
A CodeLiteralStatement that indicates the literal statement to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeLiteralStatement


VBCodeGenerator.GenerateMethod

Generates code for the specified CodeDOM based member method representation.

[Visual Basic]
Overrides Protected Sub GenerateMethod( _
   ByVal e As CodeMemberMethod, _
   ByVal c As CodeClass _
)
[C#]
protected override void GenerateMethod(
   CodeMemberMethod e,
   CodeClass c
);
[C++]
protected: override void GenerateMethod(
   CodeMemberMethod* e,
   CodeClass* c
);
[JScript]
protected override function GenerateMethod(
   e : CodeMemberMethod,
   c : CodeClass
);

Parameters

e
A CodeMemberMethod that indicates the method to generate code for.
c
[To be supplied.]

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeMemberMethod


VBCodeGenerator.GenerateMethodInvokeExpression

Generates code for the specified CodeDOM based method invoke expression.

[Visual Basic]
Overrides Protected Sub GenerateMethodInvokeExpression( _
   ByVal e As CodeMethodInvokeExpression _
)
[C#]
protected override void GenerateMethodInvokeExpression(
   CodeMethodInvokeExpression e
);
[C++]
protected: override void GenerateMethodInvokeExpression(
   CodeMethodInvokeExpression* e
);
[JScript]
protected override function GenerateMethodInvokeExpression(
   e : CodeMethodInvokeExpression
);

Parameters

e
A CodeMethodInvokeExpression that indicates the expression to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeMethodInvokeExpression


VBCodeGenerator.GenerateMethodInvokeStatement

Generates code for the specified CodeDOM based method invoke statement representation.

[Visual Basic]
Overrides Protected Sub GenerateMethodInvokeStatement( _
   ByVal e As CodeMethodInvokeStatement _
)
[C#]
protected override void GenerateMethodInvokeStatement(
   CodeMethodInvokeStatement e
);
[C++]
protected: override void GenerateMethodInvokeStatement(
   CodeMethodInvokeStatement* e
);
[JScript]
protected override function GenerateMethodInvokeStatement(
   e : CodeMethodInvokeStatement
);

Parameters

e
A CodeMethodInvokeStatement that indicates the statement to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeMethodInvokeStatement


VBCodeGenerator.GenerateMethodReturnStatement

Generates code for the specified CodeDOM based method return statement representation.

[Visual Basic]
Overrides Protected Sub GenerateMethodReturnStatement( _
   ByVal e As CodeMethodReturnStatement _
)
[C#]
protected override void GenerateMethodReturnStatement(
   CodeMethodReturnStatement e
);
[C++]
protected: override void GenerateMethodReturnStatement(
   CodeMethodReturnStatement* e
);
[JScript]
protected override function GenerateMethodReturnStatement(
   e : CodeMethodReturnStatement
);

Parameters

e
A CodeMethodReturnStatement that indicates the statement to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeMethodReturnStatement


VBCodeGenerator.GenerateNamespace

Generates code for the CodeDOM based namespace representation.

[Visual Basic]
Overrides Protected Sub GenerateNamespace( _
   ByVal e As CodeNamespace _
)
[C#]
protected override void GenerateNamespace(
   CodeNamespace e
);
[C++]
protected: override void GenerateNamespace(
   CodeNamespace* e
);
[JScript]
protected override function GenerateNamespace(
   e : CodeNamespace
);

Parameters

e
A CodeNamespace that indicates the namespace to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeNamespace


VBCodeGenerator.GenerateNamespaceEnd

Generates code for the specified CodeDOM based namespace representation.

[Visual Basic]
Overrides Protected Sub GenerateNamespaceEnd( _
   ByVal e As CodeNamespace _
)
[C#]
protected override void GenerateNamespaceEnd(
   CodeNamespace e
);
[C++]
protected: override void GenerateNamespaceEnd(
   CodeNamespace* e
);
[JScript]
protected override function GenerateNamespaceEnd(
   e : CodeNamespace
);

Parameters

e
A CodeNamespace that indicates the namespace to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeNamespace


VBCodeGenerator.GenerateNamespaceImport

Generates code for the specified CodeDOM based namespace import representation.

[Visual Basic]
Overrides Protected Sub GenerateNamespaceImport( _
   ByVal e As CodeNamespaceImport _
)
[C#]
protected override void GenerateNamespaceImport(
   CodeNamespaceImport e
);
[C++]
protected: override void GenerateNamespaceImport(
   CodeNamespaceImport* e
);
[JScript]
protected override function GenerateNamespaceImport(
   e : CodeNamespaceImport
);

Parameters

e
A CodeNamespaceImport that indicates the namespace import to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeNamespaceImport


VBCodeGenerator.GenerateNamespaceStart

Generates code for the specified CodeDOM based namespace representation.

[Visual Basic]
Overrides Protected Sub GenerateNamespaceStart( _
   ByVal e As CodeNamespace _
)
[C#]
protected override void GenerateNamespaceStart(
   CodeNamespace e
);
[C++]
protected: override void GenerateNamespaceStart(
   CodeNamespace* e
);
[JScript]
protected override function GenerateNamespaceStart(
   e : CodeNamespace
);

Parameters

e
A CodeNamespace that indicates the namespace to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeNamespace


VBCodeGenerator.GenerateObjectCreateExpression

Generates code for the specified CodeDOM based object creation expression.

[Visual Basic]
Overrides Protected Sub GenerateObjectCreateExpression( _
   ByVal e As CodeObjectCreateExpression _
)
[C#]
protected override void GenerateObjectCreateExpression(
   CodeObjectCreateExpression e
);
[C++]
protected: override void GenerateObjectCreateExpression(
   CodeObjectCreateExpression* e
);
[JScript]
protected override function GenerateObjectCreateExpression(
   e : CodeObjectCreateExpression
);

Parameters

e
A CodeObjectCreateExpression that indicates the expression to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeObjectCreateExpression


VBCodeGenerator.GenerateProperty

Generates code for the specified CodeDOM based member property representation.

[Visual Basic]
Overrides Protected Sub GenerateProperty( _
   ByVal e As CodeMemberProperty, _
   ByVal c As CodeClass _
)
[C#]
protected override void GenerateProperty(
   CodeMemberProperty e,
   CodeClass c
);
[C++]
protected: override void GenerateProperty(
   CodeMemberProperty* e,
   CodeClass* c
);
[JScript]
protected override function GenerateProperty(
   e : CodeMemberProperty,
   c : CodeClass
);

Parameters

e
A CodeMemberProperty that indicates the property to generate code for.
c
[To be supplied.]

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeMemberProperty


VBCodeGenerator.GenerateThisReferenceExpression

Generates code for the specified CodeDOM based this reference expression representation.

[Visual Basic]
Overrides Protected Sub GenerateThisReferenceExpression( _
   ByVal e As CodeThisReferenceExpression _
)
[C#]
protected override void GenerateThisReferenceExpression(
   CodeThisReferenceExpression e
);
[C++]
protected: override void GenerateThisReferenceExpression(
   CodeThisReferenceExpression* e
);
[JScript]
protected override function GenerateThisReferenceExpression(
   e : CodeThisReferenceExpression
);

Parameters

e
A CodeThisReferenceExpression that indicates the expression to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeThisReferenceExpression


VBCodeGenerator.GenerateThrowExceptionStatement

Generates code for the specified CodeDOM based throw exception statement representation.

[Visual Basic]
Overrides Protected Sub GenerateThrowExceptionStatement( _
   ByVal e As CodeThrowExceptionStatement _
)
[C#]
protected override void GenerateThrowExceptionStatement(
   CodeThrowExceptionStatement e
);
[C++]
protected: override void GenerateThrowExceptionStatement(
   CodeThrowExceptionStatement* e
);
[JScript]
protected override function GenerateThrowExceptionStatement(
   e : CodeThrowExceptionStatement
);

Parameters

e
A CodeThrowExceptionStatement that indicates the statement to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeThrowExceptionStatement


VBCodeGenerator.GenerateTryCatchFinallyStatement

Generates code for the specified CodeDOM based try catch finally statement representation.

[Visual Basic]
Overrides Protected Sub GenerateTryCatchFinallyStatement( _
   ByVal e As CodeTryCatchFinallyStatement _
)
[C#]
protected override void GenerateTryCatchFinallyStatement(
   CodeTryCatchFinallyStatement e
);
[C++]
protected: override void GenerateTryCatchFinallyStatement(
   CodeTryCatchFinallyStatement* e
);
[JScript]
protected override function GenerateTryCatchFinallyStatement(
   e : CodeTryCatchFinallyStatement
);

Parameters

e
A CodeTryCatchFinallyStatement that indicates the statement to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeTryCatchFinallyStatement


VBCodeGenerator.GenerateTypeOfExpression

[To be supplied.]

[Visual Basic]
Overrides Protected Sub GenerateTypeOfExpression( _
   ByVal e As CodeTypeOfExpression _
)
[C#]
protected override void GenerateTypeOfExpression(
   CodeTypeOfExpression e
);
[C++]
protected: override void GenerateTypeOfExpression(
   CodeTypeOfExpression* e
);
[JScript]
protected override function GenerateTypeOfExpression(
   e : CodeTypeOfExpression
);

Parameters

e
[To be supplied.]

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace


VBCodeGenerator.GenerateVariableDeclarationStatement

Generates code for the specified CodeDOM variable declaration statement representation.

[Visual Basic]
Overrides Protected Sub GenerateVariableDeclarationStatement( _
   ByVal e As CodeVariableDeclarationStatement _
)
[C#]
protected override void GenerateVariableDeclarationStatement(
   CodeVariableDeclarationStatement e
);
[C++]
protected: override void GenerateVariableDeclarationStatement(
   CodeVariableDeclarationStatement* e
);
[JScript]
protected override function GenerateVariableDeclarationStatement(
   e : CodeVariableDeclarationStatement
);

Parameters

e
A CodeVariableDeclarationStatement that indicates the variable declaration to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeVariableDeclarationStatement


VBCodeGenerator.GetNullToken

Gets the token that is used to represent a null reference (in Visual Basic Nothing).

[Visual Basic]
Overrides Protected Function GetNullToken() As String
[C#]
protected override string GetNullToken();
[C++]
protected: override String* GetNullToken();
[JScript]
protected override function GetNullToken() : String;

Return Value

The token that is used to represent a null reference (Nothing).

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace


VBCodeGenerator.IsValidIdentifier

Gets whether the specified identifier is valid.

[Visual Basic]
Overrides Protected Function IsValidIdentifier( _
   ByVal value As String _
) As Boolean
[C#]
protected override bool IsValidIdentifier(
   string value
);
[C++]
protected: override bool IsValidIdentifier(
   String* value
);
[JScript]
protected override function IsValidIdentifier(
   value : String
) : Boolean;

Parameters

value
The value to test for validity.

Return Value

true if the identifier is valid; otherwise, false.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace


VBCodeGenerator.OutputAttributeArgument

[To be supplied.]

[Visual Basic]
Overrides Protected Sub OutputAttributeArgument( _
   ByVal arg As CodeAttributeArgument _
)
[C#]
protected override void OutputAttributeArgument(
   CodeAttributeArgument arg
);
[C++]
protected: override void OutputAttributeArgument(
   CodeAttributeArgument* arg
);
[JScript]
protected override function OutputAttributeArgument(
   arg : CodeAttributeArgument
);

Parameters

arg
[To be supplied.]

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace


VBCodeGenerator.OutputDirection

Generates code for the specified CodeDOM based field direction representation.

[Visual Basic]
Overrides Protected Sub OutputDirection( _
   ByVal dir As FieldDirection _
)
[C#]
protected override void OutputDirection(
   FieldDirection dir
);
[C++]
protected: override void OutputDirection(
   FieldDirection dir
);
[JScript]
protected override function OutputDirection(
   dir : FieldDirection
);

Parameters

dir
A FieldDirection that indicates the nature of the field to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | FieldDirection


VBCodeGenerator.OutputMemberAccessModifier

Generates code for the specified CodeDOM based member access modifier representation.

[Visual Basic]
Overrides Protected Sub OutputMemberAccessModifier( _
   ByVal attrs As MemberAttributes _
)
[C#]
protected override void OutputMemberAccessModifier(
   MemberAttributes attrs
);
[C++]
protected: override void OutputMemberAccessModifier(
   MemberAttributes attrs
);
[JScript]
protected override function OutputMemberAccessModifier(
   attrs : MemberAttributes
);

Parameters

attrs
A MemberAttributes that indicates the member access modifiers to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | MemberAttributes


VBCodeGenerator.OutputMemberScopeModifier

Generates code for the specified CodeDOM based member scope modifier representation.

[Visual Basic]
Overrides Protected Sub OutputMemberScopeModifier( _
   ByVal attrs As MemberAttributes _
)
[C#]
protected override void OutputMemberScopeModifier(
   MemberAttributes attrs
);
[C++]
protected: override void OutputMemberScopeModifier(
   MemberAttributes attrs
);
[JScript]
protected override function OutputMemberScopeModifier(
   attrs : MemberAttributes
);

Parameters

attrs
A MemberAttributes that indicates the member scope modifier to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | MemberAttributes


VBCodeGenerator.OutputOperator

Generates code for the specified CodeDOM based operator representation.

[Visual Basic]
Overrides Protected Sub OutputOperator( _
   ByVal op As CodeBinaryOperatorType _
)
[C#]
protected override void OutputOperator(
   CodeBinaryOperatorType op
);
[C++]
protected: override void OutputOperator(
   CodeBinaryOperatorType op
);
[JScript]
protected override function OutputOperator(
   op : CodeBinaryOperatorType
);

Parameters

op
A CodeBinaryOperatorType that indicates the operator to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | CodeBinaryOperatorType


VBCodeGenerator.OutputType

Generates code for the specified CodeDOM based return type representation.

[Visual Basic]
Overrides Protected Sub OutputType( _
   ByVal typeRef As String _
)
[C#]
protected override void OutputType(
   string typeRef
);
[C++]
protected: override void OutputType(
   String* typeRef
);
[JScript]
protected override function OutputType(
   typeRef : String
);

Parameters

typeRef
The type to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace


VBCodeGenerator.OutputTypeAttributes

Generates code for the specified CodeDOM based type attributes representation.

[Visual Basic]
Overrides Protected Sub OutputTypeAttributes( _
   ByVal attrs As TypeAttributes _
)
[C#]
protected override void OutputTypeAttributes(
   TypeAttributes attrs
);
[C++]
protected: override void OutputTypeAttributes(
   TypeAttributes attrs
);
[JScript]
protected override function OutputTypeAttributes(
   attrs : TypeAttributes
);

Parameters

attrs
A System.CodeDOM.TypeAttributes that indicates the type attributes to generate code for.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace | System.CodeDOM.TypeAttributes


VBCodeGenerator.OutputTypeNamePair

Generates code for the specified CodeDOM based type name pair representation.

[Visual Basic]
Overrides Protected Sub OutputTypeNamePair( _
   ByVal typeRef As String, _
   ByVal name As String _
)
[C#]
protected override void OutputTypeNamePair(
   string typeRef,
   string name
);
[C++]
protected: override void OutputTypeNamePair(
   String* typeRef,
   String* name
);
[JScript]
protected override function OutputTypeNamePair(
   typeRef : String,
   name : String
);

Parameters

typeRef
The type of the variable.
name
[To be supplied.]

Remarks

This is commonly used for variable declarations.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace


VBCodeGenerator.QuoteLiteralString

Provides conversion to formatting with escape codes.

[Visual Basic]
Overrides Protected Function QuoteLiteralString( _
   ByVal value As String, _
   ByVal escapeUnicode As Boolean _
) As String
[C#]
protected override string QuoteLiteralString(
   string value,
   bool escapeUnicode
);
[C++]
protected: override String* QuoteLiteralString(
   String* value,
   bool escapeUnicode
);
[JScript]
protected override function QuoteLiteralString(
   value : String,
   escapeUnicode : Boolean
) : String;

Parameters

value
The string to convert.
escapeUnicode
[To be supplied.]

Return Value

The converted string.

Remarks

If the value of escapeUnicode is set to true, character values above 80 will be converted to use escape code formatting.

See Also

VBCodeGenerator Class | VBCodeGenerator Members | System.CodeDOM.Compiler Namespace


System.Collections

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Collections Namespace

Classes

Class | Description
ArrayList | Implements the IList interface using an array whose size is dynamically increased as required.
BitArray | Manages a compact array of bit values, which are represented as booleans, where true indicates that the bit is on (1) and false indicates the bit is off (0).
CaseInsensitiveComparer | [To be supplied.]
CaseInsensitiveHashCodeProvider | Supplies a hashcode for the implementing class. The hashing algorithm ignores the case for Strings. The default for Hashtables is to use case sensitive hashcodes. This class is typically used in conjunction with CaseInsensitiveComparer
CaseInsensitiveHashtable | [To be supplied.]
CaseInsensitiveSortedList | [To be supplied.]
Comparer | Provides the default implementation for the IComparer interface, including the method CompareTo, which compares two objects for equivalence.
Dictionary | Represents a collection of associated keys and values.
Hashtable | Represents a collection of associated keys and values that are organized based on the hash code of the key.
NameObjectCollectionBase | [To be supplied.]
NameValueCollection | [To be supplied.]
ObjectList | [To be supplied.]
Queue | Represents a first-in-first-out collection of objects.
SortedList | Represents a collection of associated keys and values, which are sorted by the keys and are accessible both by key and by index.
Stack | Represents a simple queue of Object.
StringCollection | Collection of Strings
StringTable | Represents an unsorted set of strings.

Interfaces

Interface | Description
ICollection | Defines size, enumerators and synchronization methods for all collections.
IComparer | Exposes a method that compares two objects.
IDictionary | Represents a collection of associated keys and values.
IDictionaryEnumerator | Enumerates the elements of a dictionary.
IEnumerable | Exposes the enumerator, which iterates over a collection in a simple ForEach style.
IEnumerator | Supports a simple ForEach-style iteration over a collection.
IHashCodeProvider | Supplies a hashcode for the implementing class.
IList | Represents a collection of objects that can be individually indexed.

Structures

Structure | Description
DictionaryEntry | Defines a dictionary key-and-value pair that can be set or retrieved.


ArrayList Class

Implements the IList interface using an array whose size is dynamically increased as required.

Object
ArrayList

[Visual Basic]
Public Class ArrayList
   Implements IList, ICollection, IEnumerable, ICloneable
[C#]
public class ArrayList : IList, ICollection, IEnumerable,
   ICloneable
[C++]
public __gc class ArrayList : public IList, ICollection,
   IEnumerable, ICloneable
[JScript]
public class ArrayList implements IList, ICollection, IEnumerable,
   ICloneable

Remarks

The capacity of an ArrayList is the number of elements the list can hold. As elements are added to an ArrayList, the capacity is automatically increased as required through reallocation. The capacity can be decreased by calling TrimToSize or by setting the Capacity property explicitly.

Requirements

Namespace: System.Collections

Assembly: mscorlib.dll

See Also

ArrayList Members | System.Collections Namespace | IList


ArrayList Members

Public:

Constructor

ArrayList Constructor Overloaded. Initializes a new instance of the ArrayList class.

Properties

Capacity | Gets or sets the number of elements that the ArrayList can contain.
Count | Gets the number of elements that the ArrayList actually contains.
IsReadOnly | Gets a value indicating whether the ArrayList is read-only.
IsSynchronized | Gets a value indicating whether access to the ArrayList is synchronized (thread-safe).
Item | Gets or sets the element at the specified index. In C#, this member is the indexer for the ArrayList class.
SyncRoot | Gets an object that can be used to synchronize access to the ArrayList.

Methods

Adapter | Creates an ArrayList wrapper for a specific IList.
Add | Adds an object to the end of the ArrayList.
AddRange | Adds the elements of an ICollection to the end of the ArrayList.
BinarySearch | Searches a section of the sorted ArrayList for an element, using a binary search algorithm, and returns the index of the element.
Clear | Clears the contents of the ArrayList.
Clone | Creates a shallow copy of the ArrayList.
Contains | Determines if an element is in the ArrayList.
CopyTo | Overloaded. Copies the ArrayList, or a portion of it, into a one-dimensional array.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FixedSize | Overloaded. Returns a list wrapper with a fixed size, where elements are only allowed to be modified, not added or removed.
GetEnumerator | Overloaded. Returns an enumerator which can be used to iterate through the ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRange | Copies a range of elements in the ArrayList into a new ArrayList.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | Overloaded. Returns the index of the first occurrence of a value in the ArrayList, or in a portion of it.
Insert | Inserts an element into the ArrayList at the specified index.
InsertRange | Inserts the elements of a collection into the ArrayList at the specified index.
LastIndexOf | Overloaded. Returns the index of the last occurrence of a value in the ArrayList, or in a portion of it.
ReadOnly | Overloaded. Returns a list wrapper that allows read-only access.
Remove | Removes a specific object from the ArrayList.
RemoveAt | Removes the element at the specified index of the ArrayList.
RemoveRange | Removes a range of elements from the ArrayList.
Repeat | Returns an ArrayList whose elements are copies of the specified value.
Reverse | Overloaded. Reverses the order of the elements in the ArrayList, or a portion of it.
SetRange | Copies the elements of a collection over a range of elements in the ArrayList.
Sort | Overloaded. Sorts the elements in the ArrayList, or a portion of it.
Synchronized | Overloaded. Returns a list wrapper that is synchronized (thread-safe).
ToArray | Overloaded. Copies the elements of the ArrayList to a new array.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity of the ArrayList to the actual number of elements in it.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArrayList Class | System.Collections Namespace


ArrayList Constructor

Initializes a new instance of the ArrayList class.

Overload List

Creates an empty ArrayList with an initial capacity of 16.

[Visual Basic] Overloads Public Sub New()
[C#] public ArrayList();
[C++] public: ArrayList();
[JScript] public function ArrayList();

Creates an empty ArrayList with the specified initial capacity.

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public ArrayList(int);
[C++] public: ArrayList(int);
[JScript] public function ArrayList(int);

Creates an ArrayList containing elements copied from the specified collection.

[Visual Basic] Overloads Public Sub New(ICollection)
[C#] public ArrayList(ICollection);
[C++] public: ArrayList(ICollection*);
[JScript] public function ArrayList(ICollection);

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace


ArrayList Constructor ()

Creates an empty ArrayList with an initial capacity of 16.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ArrayList();
[C++]
public: ArrayList();
[JScript]
public function ArrayList();

Remarks

When adding elements to the list and the number of elements exceeds the capacity, the capacity is doubled.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | ArrayList Constructor Overload List | Capacity


ArrayList Constructor (Int32)

Creates an empty ArrayList with the specified initial capacity.

[Visual Basic]
Overloads Public Sub New( _
   ByVal capacity As Integer _
)
[C#]
public ArrayList(
   int capacity
);
[C++]
public: ArrayList(
   int capacity
);
[JScript]
public function ArrayList(
   capacity : int
);

Parameters

capacity
The number of elements that the new list is initially capable of storing.

Remarks

When adding elements to the list and the number of elements exceeds the capacity, the capacity is doubled.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | ArrayList Constructor Overload List | Capacity


ArrayList Constructor (ICollection)

Creates an ArrayList containing elements copied from the specified collection.

[Visual Basic]
Overloads Public Sub New( _
   ByVal c As ICollection _
)
[C#]
public ArrayList(
   ICollection c
);
[C++]
public: ArrayList(
   ICollection* c
);
[JScript]
public function ArrayList(
   c : ICollection
);

Parameters

c
The ICollection whose elements are copied into the new list.

Exceptions

Exception Type | Condition
ArgumentNullException | c is a null reference (in Visual Basic Nothing).

Remarks

When adding elements to the list and the number of elements exceeds the capacity, the capacity is doubled.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | ArrayList Constructor Overload List | ICollection | Capacity


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ArrayList Properties

The properties of the ArrayList class are listed below. For a complete list of ArrayList class members, see the ArrayList Members topic.

Public:

Capacity | Gets or sets the number of elements that the ArrayList can contain.
Count | Gets the number of elements that the ArrayList actually contains.
IsReadOnly | Gets a value indicating whether the ArrayList is read-only.
IsSynchronized | Gets a value indicating whether access to the ArrayList is synchronized (thread-safe).
Item | Gets or sets the element at the specified index. In C#, this member is the indexer for the ArrayList class.
SyncRoot | Gets an object that can be used to synchronize access to the ArrayList.

See Also

ArrayList Class | System.Collections Namespace


ArrayList.Capacity

Gets or sets the number of elements that the ArrayList can contain.

[Visual Basic]
Overridable Public Property Capacity As Integer
[C#]
public int Capacity {virtual get; virtual set;}
[C++]
public: __property virtual int get_Capacity();
public: __property virtual void set_Capacity(int);
[JScript]
public function get Capacity() : int;
public function set Capacity(int);

Property Value

The number of elements that the ArrayList can contain.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Capacity is being set to a value that is less than Count.

Remarks

Capacity is the number of elements that the ArrayList is capable of storing. Count is the number of elements that are actually in the ArrayList.

Capacity is always greater than or equal to Count. If Count exceeds Capacity while adding elements, the capacity of the list is doubled by automatically reallocating the internal array.

When the value of Capacity is set explicitly, the internal array is also reallocated to accommodate the specified capacity.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | Count


ArrayList.Count

Gets the number of elements that the ArrayList actually contains.

[Visual Basic]
Overridable Public ReadOnly Property Count As Integer
[C#]
public int Count {virtual get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;

Property Value

The number of elements that the ArrayList actually contains.

Remarks

Count is the number of elements that are actually in the ArrayList. Capacity is the number of elements that the ArrayList is capable of storing.

Count is always less than or equal to Capacity. If Count exceeds Capacity while adding elements, the capacity of the list is doubled by automatically reallocating the internal array.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | Capacity


ArrayList.IsReadOnly

Gets a value indicating whether the ArrayList is read-only.

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {virtual get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;

Property Value

true if the ArrayList is read-only; otherwise, false.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace


ArrayList.IsSynchronized

Gets a value indicating whether access to the ArrayList is synchronized (thread-safe).

[Visual Basic]
Overridable Public ReadOnly Property IsSynchronized As Boolean
[C#]
public bool IsSynchronized {virtual get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;

Property Value

true if access to the ArrayList is synchronized (thread-safe); otherwise, false.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | SyncRoot | Synchronized


ArrayList.Item

Gets or sets the element at the specified index.

[C#] In C#, this member is the indexer for the ArrayList class.

[Visual Basic]
Overridable Public Default Property Item( _
   ByVal index As Integer _
) As Object
[C#]
public object this[
   int index
] {virtual get; virtual set;}
[C++]
public: __property virtual Object* get_Item(
   int index
);
public: __property virtual void set_Item(
   int index,
   Object*
);
[JScript]
returnValue = ArrayListObject.Item(index);
ArrayListObject.Item(index) = returnValue;
-or-
returnValue = ArrayListObject(index);
ArrayListObject(index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
The index of the element to get or set.

Parameters [Visual Basic, C#, C++]

index
The index of the element to get or set.

Property Value

The element at the specified index.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | Count


ArrayList.SyncRoot

Gets an object that can be used to synchronize access to the ArrayList.

[Visual Basic]
Overridable Public ReadOnly Property SyncRoot As Object
[C#]
public object SyncRoot {virtual get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;

Property Value

An object that can be used to synchronize access to the ArrayList.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | IsSynchronized | Synchronized


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ArrayList Methods

The methods of the ArrayList class are listed below. For a complete list of ArrayList class members, see the ArrayList Members topic.

Public:

Adapter | Creates an ArrayList wrapper for a specific IList.
Add | Adds an object to the end of the ArrayList.
AddRange | Adds the elements of an ICollection to the end of the ArrayList.
BinarySearch | Searches a section of the sorted ArrayList for an element, using a binary search algorithm, and returns the index of the element.
Clear | Clears the contents of the ArrayList.
Clone | Creates a shallow copy of the ArrayList.
Contains | Determines if an element is in the ArrayList.
CopyTo | Overloaded. Copies the ArrayList, or a portion of it, into a one-dimensional array.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FixedSize | Overloaded. Returns a list wrapper with a fixed size, where elements are only allowed to be modified, not added or removed.
GetEnumerator | Overloaded. Returns an enumerator which can be used to iterate through the ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRange | Copies a range of elements in the ArrayList into a new ArrayList.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | Overloaded. Returns the index of the first occurrence of a value in the ArrayList, or in a portion of it.
Insert | Inserts an element into the ArrayList at the specified index.
InsertRange | Inserts the elements of a collection into the ArrayList at the specified index.
LastIndexOf | Overloaded. Returns the index of the last occurrence of a value in the ArrayList, or in a portion of it.
ReadOnly | Overloaded. Returns a list wrapper that allows read-only access.
Remove | Removes a specific object from the ArrayList.
RemoveAt | Removes the element at the specified index of the ArrayList.
RemoveRange | Removes a range of elements from the ArrayList.
Repeat | Returns an ArrayList whose elements are copies of the specified value.
Reverse | Overloaded. Reverses the order of the elements in the ArrayList, or a portion of it.
SetRange | Copies the elements of a collection over a range of elements in the ArrayList.
Sort | Overloaded. Sorts the elements in the ArrayList, or a portion of it.
Synchronized | Overloaded. Returns a list wrapper that is synchronized (thread-safe).
ToArray | Overloaded. Copies the elements of the ArrayList to a new array.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity of the ArrayList to the actual number of elements in it.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArrayList Class | System.Collections Namespace


ArrayList.Adapter

Creates an ArrayList wrapper for a specific IList.

[Visual Basic]
Public Shared Function Adapter( _
   ByVal list As IList _
) As ArrayList
[C#]
public static ArrayList Adapter(
   IList list
);
[C++]
public: static ArrayList* Adapter(
   IList* list
);
[JScript]
public static function Adapter(
   list : IList
) : ArrayList;

Parameters

list
The IList to wrap.

Return Value

The ArrayList wrapper around the IList.

Exceptions

Exception Type | Condition
ArgumentNullException | list is a null reference (in Visual Basic Nothing).

Remarks

Adapter does not copy the contents of IList. Instead, it simply creates an ArrayList wrapper around IList; therefore, any changes made to IList also affect the ArrayList.

The ArrayList class provides generic Reverse, BinarySearch and Sort methods. This wrapper can be a vehicle to use those methods on IList. However, the performance of these generic operations through the wrapper may not be as good as operations applied directly on the IList.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | IList | BinarySearch | Reverse | Sort


ArrayList.Add

Adds an object to the end of the ArrayList.

[Visual Basic]
Overridable Public Function Add( _
   ByVal value As Object _
) As Integer
[C#]
public virtual int Add(
   object value
);
[C++]
public: virtual int Add(
   Object* value
);
[JScript]
public function Add(
   value : Object
) : int;

Parameters

value
The Object to be added to the end of the ArrayList.

Return Value

The new number of elements in the ArrayList (Count) after value has been added.

Exceptions

Exception Type | Condition
NotSupportedException | The ArrayList is read-only. -or- The ArrayList has a fixed size.

Remarks

This method can be overridden by a derived class.

If Count already equals Capacity, the capacity of the list is doubled by automatically reallocating the internal array, before the new element is added.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | Count | Insert | AddRange


ArrayList.AddRange

Adds the elements of an ICollection to the end of the ArrayList.

[Visual Basic]
Overridable Public Sub AddRange( _
   ByVal c As ICollection _
)
[C#]
public virtual void AddRange(
   ICollection c
);
[C++]
public: virtual void AddRange(
   ICollection* c
);
[JScript]
public function AddRange(
   c : ICollection
);

Parameters

c
The ICollection whose elements should be added to the end of the ArrayList.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentException | c is a null reference (in Visual Basic Nothing).
NotSupportedException | The ArrayList is read-only. -or- The ArrayList has a fixed size.

Remarks

This method can be overridden by a derived class.

If the new Count (the current Count plus the size of the collection) would be greater than Capacity, the capacity of the list is either doubled or increased to the new Count, whichever is greater. The internal array is reallocated to accommodate the new elements.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | ICollection | Capacity | Count | Add | InsertRange | SetRange | GetRange | RemoveRange


ArrayList.BinarySearch

Searches a section of the sorted ArrayList for an element, using a binary search algorithm, and returns the index of the element.

[Visual Basic]
Overridable Public Function BinarySearch( _
   ByVal index As Integer, _
   ByVal count As Integer, _
   ByVal value As Object, _
   ByVal comparer As IComparer _
) As Integer
[C#]
public virtual int BinarySearch(
   int index,
   int count,
   object value,
   IComparer comparer
);
[C++]
public: virtual int BinarySearch(
   int index,
   int count,
   Object* value,
   IComparer* comparer
);
[JScript]
public function BinarySearch(
   index : int,
   count : int,
   value : Object,
   comparer : IComparer
) : int;

Parameters

index
The starting index of the range to search.
count
The length of the range to search.
value
The Object to search for.
comparer
The IComparer implementation to use when comparing elements.

-or-

a null reference (in Visual Basic Nothing) to use the IComparable implementation of each element.

Return Value

The index of the value in the sorted ArrayList, if value is found. Otherwise, a negative number, which is the bitwise complement of the index of the next element.

Exceptions

Exception Type Condition
ArgumentException index and count do not denote a valid range in the ArrayList.

-or-

comparer is a null reference (Nothing), and neither value nor the elements of ArrayList implement the IComparable interface.

-or-

comparer is a null reference (Nothing), and value is not of the same type as the elements of the ArrayList.
ArgumentOutOfRangeException index is less than zero.

-or-

count is less than zero.

Remarks

This method can be overridden by a derived class.

If comparer is provided, the elements of the ArrayList are compared to the specified value using the specified IComparer interface.

If comparer is a null reference (Nothing), the comparison is done using the IComparable implementation provided by the element itself or by the specified value.

a null reference (Nothing) can always be compared with any other type; therefore, comparisons with a null reference (Nothing) will not generate an exception when using IComparable. When sorting, a null reference (Nothing) is considered to be less than any other object.

The specified range of the ArrayList must already be sorted using the specified BinarySearch method; otherwise, the result will be incorrect.

If the ArrayList does not contain the specified value, the method returns a negative integer. The bitwise complement operator (~) can be applied on this negative integer to retrieve the index of the first element that is larger than the search value. If inserting the value into the ArrayList, this index should be used as the insertion point to maintain the sort order.

This method is an O(log

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace


ArrayList.Clear

Clears the contents of the ArrayList.

[Visual Basic]
Overridable Public Sub Clear()
[C#]
public virtual void Clear();
[C++]
public: virtual void Clear();
[JScript]
public function Clear();

Return Value

None.

Exceptions

Exception Type | Condition
NotSupportedException | The ArrayList is read-only. -or- The ArrayList has a fixed size.

Remarks

This method can be overridden by a derived class.

Count is set to 0. You need to call TrimToSize to trim your ArrayList if required.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace


ArrayList.Clone

Creates a shallow copy of the ArrayList.

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

Return Value

A new ArrayList whose members are copied from the original ArrayList.

Remarks

This method can be overridden by a derived class.

A shallow copy of an object is a copy of the object only. If the object contains references to other objects, the shallow copy will not create copies of the referred objects, but will refer to the original objects instead. On the other hand, a deep copy of an object creates a copy of the object and a copy of everything directly or indirectly referenced by that object.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace


ArrayList.Contains

Determines if an element is in the ArrayList.

[Visual Basic]
Overridable Public Function Contains( _
   ByVal item As Object _
) As Boolean
[C#]
public virtual bool Contains(
   object item
);
[C++]
public: virtual bool Contains(
   Object* item
);
[JScript]
public function Contains(
   item : Object
) : Boolean;

Parameters

item
The Object to search for in the ArrayList.

-or-

a null reference (in Visual Basic Nothing).

Return Value

true if item is found in the ArrayList; otherwise, false.

Remarks

This method can be overridden by a derived class.

This method performs a linear O(n) search and determines equality by calling Equals.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace


ArrayList.CopyTo

Copies the ArrayList, or a portion of it, into a one-dimensional array.

Overload List

Copies a range of elements from the ArrayList into a compatible one-dimensional Array, starting at the specified index of the target array.

[Visual Basic] Overloads Overridable Public Sub CopyTo(Integer, Array, Integer, Integer)
[C#] public virtual void CopyTo(int, Array, int, int);
[C++] public: virtual void CopyTo(int, Array, int, int);
[JScript] public function CopyTo(int, Array, int, int);

Copies the entire ArrayList into a compatible one-dimensional Array, starting at the beginning of the target array.

[Visual Basic] Overloads Overridable Public Sub CopyTo(Array)
[C#] public virtual void CopyTo(Array);
[C++] public: virtual void CopyTo(Array*);
[JScript] public function CopyTo(Array);

Copies the entire ArrayList into a compatible one-dimensional Array, starting at the specified index of the target array.

[Visual Basic] Overloads Overridable Public Sub CopyTo(Array, Integer)
[C#] public virtual void CopyTo(Array, int);
[C++] public: virtual void CopyTo(Array*, int);
[JScript] public function CopyTo(Array, int);

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace


ArrayList.CopyTo (Int32, Array, Int32, Int32)

Copies a range of elements from the ArrayList into a compatible one-dimensional Array, starting at the specified index of the target array.

[Visual Basic]
Overloads Overridable Public Sub CopyTo( _
   ByVal index As Integer, _
   ByVal array As Array, _
   ByVal arrayIndex As Integer, _
   ByVal count As Integer _
)
[C#]
public virtual void CopyTo(
   int index,
   Array array,
   int arrayIndex,
   int count
);
[C++]
public: virtual void CopyTo(
   int index,
   Array* array,
   int arrayIndex,
   int count
);
[JScript]
public function CopyTo(
   index : int,
   array : Array,
   arrayIndex : int,
   count : int
);

Parameters

index
The ArrayList index to start copying from.
array
The one-dimensional Array to copy the elements into.
arrayIndex
The array index to start copying into.
count
The number of elements to copy.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentException | array is multidimensional. -or- count is greater than the available space between arrayIndex and the end of array.
ArgumentNullException | array is a null reference (in Visual Basic Nothing).
ArgumentOutOfRangeException | index and count do not specify a valid range in the ArrayList. -or- count is greater than the number of items from index to the end of ArrayList. -or- arrayIndex is less than array 's lowbound.

Remarks

This method can be overridden by a derived class.

array must be of a compatible array type.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | ArrayList.CopyTo Overload List


ArrayList.CopyTo (Array)

Copies the entire ArrayList into a compatible one-dimensional Array, starting at the beginning of the target array.

[Visual Basic]
Overloads Overridable Public Sub CopyTo( _
   ByVal array As Array _
)
[C#]
public virtual void CopyTo(
   Array array
);
[C++]
public: virtual void CopyTo(
   Array* array
);
[JScript]
public function CopyTo(
   array : Array
);

Parameters

array
The one-dimensional Array to copy the elements into.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentException | array is multidimensional.
ArgumentNullException | array is a null reference (in Visual Basic Nothing).

Remarks

This method can be overridden by a derived class.

array must be of a compatible array type.

This method uses Copy to copy the elements.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | ArrayList.CopyTo Overload List


ArrayList.CopyTo (Array, Int32)

Copies the entire ArrayList into a compatible one-dimensional Array, starting at the specified index of the target array.

[Visual Basic]
Overloads Overridable Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal arrayIndex As Integer _
)
[C#]
public virtual void CopyTo(
   Array array,
   int arrayIndex
);
[C++]
public: virtual void CopyTo(
   Array* array,
   int arrayIndex
);
[JScript]
public function CopyTo(
   array : Array,
   arrayIndex : int
);

Parameters

array
The one-dimensional Array to copy the elements into.
arrayIndex
The array index to start copying into.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentException | array is multidimensional. -or- The number of elements in the ArrayList is greater than the available space between arrayIndex and the end of array.
ArgumentNullException | array is a null reference (in Visual Basic Nothing).
ArgumentOutOfRangeException | arrayIndex is less than array 's lowbound.

Remarks

This method can be overridden by a derived class.

array must be of a compatible array type.

This method uses Copy to copy the elements.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | ArrayList.CopyTo Overload List


ArrayList.FixedSize

Returns a list wrapper with a fixed size, where elements are only allowed to be modified, not added or removed.

Overload List

Returns an IList wrapper with a fixed size.

[Visual Basic] Overloads Public Shared Function FixedSize(IList) As IList
[C#] public static IList FixedSize(IList);
[C++] public: static IList* FixedSize(IList*);
[JScript] public static function FixedSize(IList) : IList;

Returns an ArrayList wrapper with a fixed size.

[Visual Basic] Overloads Public Shared Function FixedSize(ArrayList) As ArrayList
[C#] public static ArrayList FixedSize(ArrayList);
[C++] public: static ArrayList* FixedSize(ArrayList*);
[JScript] public static function FixedSize(ArrayList) : ArrayList;

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace


ArrayList.FixedSize (IList)

Returns an IList wrapper with a fixed size.

[Visual Basic]
Overloads Public Shared Function FixedSize( _
   ByVal list As IList _
) As IList
[C#]
public static IList FixedSize(
   IList list
);
[C++]
public: static IList* FixedSize(
   IList* list
);
[JScript]
public static function FixedSize(
   list : IList
) : IList;

Parameters

list
The IList to wrap.

Return Value

An IList wrapper with a fixed size.

Exceptions

Exception Type | Condition
ArgumentNullException | list is a null reference (in Visual Basic Nothing).

Remarks

This wrapper can be used to prevent additions to and deletions from the IList. The elements can still be modified or replaced.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | ArrayList.FixedSize Overload List


ArrayList.FixedSize (ArrayList)

Returns an ArrayList wrapper with a fixed size.

[Visual Basic]
Overloads Public Shared Function FixedSize( _
   ByVal list As ArrayList _
) As ArrayList
[C#]
public static ArrayList FixedSize(
   ArrayList list
);
[C++]
public: static ArrayList* FixedSize(
   ArrayList* list
);
[JScript]
public static function FixedSize(
   list : ArrayList
) : ArrayList;

Parameters

list
The ArrayList to wrap.

Return Value

An ArrayList wrapper with a fixed size.

Exceptions

Exception Type | Condition
ArgumentNullException | list is a null reference (in Visual Basic Nothing).

Remarks

This wrapper can be used to prevent additions to and deletions from the ArrayList. The elements can still be modified or replaced.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | ArrayList.FixedSize Overload List


ArrayList.GetEnumerator

Returns an enumerator which can be used to iterate through the ArrayList.

Overload List

Returns an enumerator for the entire ArrayList.

[Visual Basic] Overloads Overridable Public Function GetEnumerator() As IEnumerator
[C#] public virtual IEnumerator GetEnumerator();
[C++] public: virtual IEnumerator* GetEnumerator();
[JScript] public function GetEnumerator() : IEnumerator;

Returns an enumerator for a section of the ArrayList.

[Visual Basic] Overloads Overridable Public Function GetEnumerator(Integer, Integer) As IEnumerator
[C#] public virtual IEnumerator GetEnumerator(int, int);
[C++] public: virtual IEnumerator* GetEnumerator(int, int);
[JScript] public function GetEnumerator(int, int) : IEnumerator;

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace


ArrayList.GetEnumerator ()

Returns an enumerator for the entire ArrayList.

[Visual Basic]
Overloads Overridable Public Function GetEnumerator() As IEnumerator
[C#]
public virtual IEnumerator GetEnumerator();
[C++]
public: virtual IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

Return Value

An IEnumerator for the entire ArrayList.

Remarks

This method can be overridden by a derived class.

The enumerator does not have exclusive access to the ArrayList; therefore, any changes made to the list may cause Current or MoveNext to throw an exception.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | ArrayList.GetEnumerator Overload List | IEnumerator


ArrayList.GetEnumerator (Int32, Int32)

Returns an enumerator for a section of the ArrayList.

[Visual Basic]
Overloads Overridable Public Function GetEnumerator( _
   ByVal index As Integer, _
   ByVal count As Integer _
) As IEnumerator
[C#]
public virtual IEnumerator GetEnumerator(
   int index,
   int count
);
[C++]
public: virtual IEnumerator* GetEnumerator(
   int index,
   int count
);
[JScript]
public function GetEnumerator(
   index : int,
   count : int
) : IEnumerator;

Parameters

index
The starting index of the ArrayList section that the enumerator should refer to.
count
The number of elements in the ArrayList section that the enumerator should refer to.

Return Value

An IEnumerator for the specified section of the ArrayList.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- count is less than zero.
ArgumentException | index and count do not specify a valid range in the ArrayList.

Remarks

This method can be overridden by a derived class.

The enumerator does not have exclusive access to the ArrayList; therefore, any changes made to the list may cause Current or MoveNext to throw an exception.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | ArrayList.GetEnumerator Overload List


ArrayList.GetRange

Copies a range of elements in the ArrayList into a new ArrayList.

[Visual Basic]
Overridable Public Function GetRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
) As ArrayList
[C#]
public virtual ArrayList GetRange(
   int index,
   int count
);
[C++]
public: virtual ArrayList* GetRange(
   int index,
   int count
);
[JScript]
public function GetRange(
   index : int,
   count : int
) : ArrayList;

Parameters

index
The ArrayList index from which to start copying.
count
[To be supplied.]

Return Value

A new ArrayList with copies of the specified range of elements from the source ArrayList.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- count is less than zero.
ArgumentException | index and count do not denote a valid range of elements in the ArrayList.

Remarks

This method can be overridden by a derived class.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | RemoveRange | AddRange | InsertRange | SetRange


ArrayList.IndexOf

Returns the index of the first occurrence of a value in the ArrayList, or in a portion of it.

Overload List

Searches the ArrayList from the specified index to the end for the specified Object and returns the index of the first occurrence.

[Visual Basic] Overloads Overridable Public Function IndexOf(Object, Integer) As Integer
[C#] public virtual int IndexOf(Object, int);
[C++] public: virtual int IndexOf(Object*, int);
[JScript] public function IndexOf(Object, int) : int;

Searches a section of the ArrayList for the specified Object and returns the index of the first occurrence.

[Visual Basic] Overloads Overridable Public Function IndexOf(Object, Integer, Integer) As Integer
[C#] public virtual int IndexOf(Object, int, int);
[C++] public: virtual int IndexOf(Object*, int, int);
[JScript] public function IndexOf(Object, int, int) : int;

Searches the entire ArrayList for the specified Object and returns the index of the first occurrence.

[Visual Basic] Overloads Overridable Public Function IndexOf(Object) As Integer
[C#] public virtual int IndexOf(Object);
[C++] public: virtual int IndexOf(Object*);
[JScript] public function IndexOf(Object) : int;

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace


ArrayList.IndexOf (Object, Int32)

Searches the ArrayList from the specified index to the end for the specified Object and returns the index of the first occurrence.

[Visual Basic]
Overloads Overridable Public Function IndexOf( _
   ByVal value As Object, _
   ByVal startIndex As Integer _
) As Integer
[C#]
public virtual int IndexOf(
   object value,
   int startIndex
);
[C++]
public: virtual int IndexOf(
   Object* value,
   int startIndex
);
[JScript]
public function IndexOf(
   value : Object,
   startIndex : int
) : int;

Parameters

value
The Object to search for.
startIndex
The index at which the search should start.

Return Value

The index of the first occurrence of value in the ArrayList within the range startIndex through the end of the ArrayList, if found; otherwise,-1.

Exceptions

Exception Type | Condition
ArgumentException | startIndex is less than zero. -or- startIndex is equal to or greater than Count.

Remarks

This method can be overridden by a derived class.

The ArrayList is searched forwards starting at startIndex and ending at the last element.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | ArrayList.IndexOf Overload List | LastIndexOf


ArrayList.IndexOf (Object, Int32, Int32)

Searches a section of the ArrayList for the specified Object and returns the index of the first occurrence.

[Visual Basic]
Overloads Overridable Public Function IndexOf( _
   ByVal value As Object, _
   ByVal startIndex As Integer, _
   ByVal endIndex As Integer _
) As Integer
[C#]
public virtual int IndexOf(
   object value,
   int startIndex,
   int endIndex
);
[C++]
public: virtual int IndexOf(
   Object* value,
   int startIndex,
   int endIndex
);
[JScript]
public function IndexOf(
   value : Object,
   startIndex : int,
   endIndex : int
) : int;

Parameters

value
The Object to search for.
startIndex
The index at which the search should start.
endIndex
The index before which the search should end.

Return Value

The index of the first occurrence of value in the ArrayList within the range startIndex through endIndex-1, if found; otherwise,-1.

Exceptions

Exception Type | Condition
ArgumentException | startIndex is less than zero. -or- startIndex is equal to or greater than Count. -or- endIndex is less than zero. -or- endIndex is greater than Count.

Remarks

This method can be overridden by a derived class.

The ArrayList is searched forwards starting at startIndex and ending at endIndex less one.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | ArrayList.IndexOf Overload List | LastIndexOf


ArrayList.IndexOf (Object)

Searches the entire ArrayList for the specified Object and returns the index of the first occurrence.

[Visual Basic]
Overloads Overridable Public Function IndexOf( _
   ByVal value As Object _
) As Integer
[C#]
public virtual int IndexOf(
   object value
);
[C++]
public: virtual int IndexOf(
   Object* value
);
[JScript]
public function IndexOf(
   value : Object
) : int;

Parameters

value
The Object to search for.

Return Value

The index of the first occurrence of value in the entire ArrayList, if found; otherwise,-1.

Remarks

This method can be overridden by a derived class.

The ArrayList is searched forwards from the beginning to the end.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | ArrayList.IndexOf Overload List | LastIndexOf


ArrayList.Insert

Inserts an element into the ArrayList at the specified index.

[Visual Basic]
Overridable Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Object _
)
[C#]
public virtual void Insert(
   int index,
   object value
);
[C++]
public: virtual void Insert(
   int index,
   Object* value
);
[JScript]
public function Insert(
   index : int,
   value : Object
);

Parameters

index
The index at which to insert value.
value
The Object to insert.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.
NotSupportedException | The ArrayList is read-only. -or- The ArrayList has a fixed size.

Remarks

This method can be overridden by a derived class.

If Count already equals Capacity, the capacity of the list is doubled by automatically reallocating the internal array, before the new element is inserted.

If index is equal to Count, value is added to the end of ArrayList.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | Add | InsertRange


ArrayList.InsertRange

Inserts the elements of a collection into the ArrayList at the specified index.

[Visual Basic]
Overridable Public Sub InsertRange( _
   ByVal index As Integer, _
   ByVal c As ICollection _
)
[C#]
public virtual void InsertRange(
   int index,
   ICollection c
);
[C++]
public: virtual void InsertRange(
   int index,
   ICollection* c
);
[JScript]
public function InsertRange(
   index : int,
   c : ICollection
);

Parameters

index
The index at which to insert the new elements.
c
The ICollection whose elements should be inserted into the ArrayList.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | c is a null reference (in Visual Basic Nothing).
ArgumentOutOfRangeException | index is less than zero. -or- index is greater than Count.
NotSupportedException | The ArrayList is read-only. -or- The ArrayList has a fixed size.

Remarks

This method can be overridden by a derived class.

If the new Count (the current Count plus the size of the collection) would be greater than Capacity, the capacity of the list is either doubled or increased to the new count, whichever is greater. The internal array is reallocated to accommodate the new elements.

If index is equal to Count, the elements are added to the end of ArrayList.

The order of the elements in the ICollection is preserved in the ArrayList.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | Insert | AddRange | SetRange | GetRange | RemoveRange


ArrayList.LastIndexOf

Returns the index of the last occurrence of a value in the ArrayList, or in a portion of it.

Overload List

Searches a section of the ArrayList for the specified Object and returns the index of the last occurrence.

[Visual Basic] Overloads Overridable Public Function LastIndexOf(Object, Integer, Integer) As Integer
[C#] public virtual int LastIndexOf(Object, int, int);
[C++] public: virtual int LastIndexOf(Object*, int, int);
[JScript] public function LastIndexOf(Object, int, int) : int;

Searches the ArrayList from the start to the specified index for the specified Object and returns the index of the last occurrence.

[Visual Basic] Overloads Overridable Public Function LastIndexOf(Object, Integer) As Integer
[C#] public virtual int LastIndexOf(Object, int);
[C++] public: virtual int LastIndexOf(Object*, int);
[JScript] public function LastIndexOf(Object, int) : int;

Searches the entire ArrayList for the specified Object and returns the index of the last occurrence.

[Visual Basic] Overloads Overridable Public Function LastIndexOf(Object) As Integer
[C#] public virtual int LastIndexOf(Object);
[C++] public: virtual int LastIndexOf(Object*);
[JScript] public function LastIndexOf(Object) : int;

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace


ArrayList.LastIndexOf (Object, Int32, Int32)

Searches a section of the ArrayList for the specified Object and returns the index of the last occurrence.

[Visual Basic]
Overloads Overridable Public Function LastIndexOf( _
   ByVal value As Object, _
   ByVal startIndex As Integer, _
   ByVal endIndex As Integer _
) As Integer
[C#]
public virtual int LastIndexOf(
   object value,
   int startIndex,
   int endIndex
);
[C++]
public: virtual int LastIndexOf(
   Object* value,
   int startIndex,
   int endIndex
);
[JScript]
public function LastIndexOf(
   value : Object,
   startIndex : int,
   endIndex : int
) : int;

Parameters

value
The Object to search for.
startIndex
The index at which the backward search should start.
endIndex
The index before which the backward search should end.

Return Value

The index of the last occurrence of value in the ArrayList within the range endIndex through startIndex, if found; otherwise,-1.

Exceptions

Exception Type | Condition
ArgumentException | startIndex is less than zero. -or- startIndex is equal to or greater than Count. -or- endIndex is less than zero. -or- endIndex is equal to or greater than Count.

Remarks

This method can be overridden by a derived class.

The ArrayList is searched backwards starting at startIndex and ending at endIndex.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | ArrayList.LastIndexOf Overload List | IndexOf


ArrayList.LastIndexOf (Object, Int32)

Searches the ArrayList from the start to the specified index for the specified Object and returns the index of the last occurrence.

[Visual Basic]
Overloads Overridable Public Function LastIndexOf( _
   ByVal value As Object, _
   ByVal startIndex As Integer _
) As Integer
[C#]
public virtual int LastIndexOf(
   object value,
   int startIndex
);
[C++]
public: virtual int LastIndexOf(
   Object* value,
   int startIndex
);
[JScript]
public function LastIndexOf(
   value : Object,
   startIndex : int
) : int;

Parameters

value
The Object to search for.
startIndex
The index at which the backward search should start.

Return Value

The index of the last occurrence of value in the ArrayList within the range from the start of the ArrayList through startIndex, if found; otherwise,-1.

Exceptions

Exception Type | Condition
ArgumentException | startIndex is less than zero. -or- startIndex is equal to or greater than Count.

Remarks

This method can be overridden by a derived class.

The ArrayList is searched backwards starting at startIndex and ending at the first element of the ArrayList.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | ArrayList.LastIndexOf Overload List | IndexOf


ArrayList.LastIndexOf (Object)

Searches the entire ArrayList for the specified Object and returns the index of the last occurrence.

[Visual Basic]
Overloads Overridable Public Function LastIndexOf( _
   ByVal value As Object _
) As Integer
[C#]
public virtual int LastIndexOf(
   object value
);
[C++]
public: virtual int LastIndexOf(
   Object* value
);
[JScript]
public function LastIndexOf(
   value : Object
) : int;

Parameters

value
The Object to search for.

Return Value

The index of the last occurrence of value in the entire ArrayList, if found; otherwise,-1.

Remarks

This method can be overridden by a derived class.

The ArrayList is searched backwards from the end to the beginning.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | ArrayList.LastIndexOf Overload List | IndexOf


ArrayList.ReadOnly

Returns a list wrapper that allows read-only access.

Overload List

Returns a read-only IList wrapper.

[Visual Basic] Overloads Public Shared Function ReadOnly(IList) As IList
[C#] public static IList ReadOnly(IList);
[C++] public: static IList* ReadOnly(IList*);
[JScript] public static function ReadOnly(IList) : IList;

Returns a read-only ArrayList wrapper.

[Visual Basic] Overloads Public Shared Function ReadOnly(ArrayList) As ArrayList
[C#] public static ArrayList ReadOnly(ArrayList);
[C++] public: static ArrayList* ReadOnly(ArrayList*);
[JScript] public static function ReadOnly(ArrayList) : ArrayList;

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace


ArrayList.ReadOnly (IList)

Returns a read-only IList wrapper.

[Visual Basic]
Overloads Public Shared Function ReadOnly( _
   ByVal list As IList _
) As IList
[C#]
public static IList ReadOnly(
   IList list
);
[C++]
public: static IList* ReadOnly(
   IList* list
);
[JScript]
public static function ReadOnly(
   list : IList
) : IList;

Parameters

list
The IList to wrap.

Return Value

A read-only IList wrapper around list.

Exceptions

Exception Type | Condition
ArgumentNullException | list is a null reference (in Visual Basic Nothing).

Remarks

This wrapper can be used to prevent any modifications to list.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | ArrayList.ReadOnly Overload List


ArrayList.ReadOnly (ArrayList)

Returns a read-only ArrayList wrapper.

[Visual Basic]
Overloads Public Shared Function ReadOnly( _
   ByVal list As ArrayList _
) As ArrayList
[C#]
public static ArrayList ReadOnly(
   ArrayList list
);
[C++]
public: static ArrayList* ReadOnly(
   ArrayList* list
);
[JScript]
public static function ReadOnly(
   list : ArrayList
) : ArrayList;

Parameters

list
The ArrayList to wrap.

Return Value

A read-only ArrayList wrapper around list.

Exceptions

Exception Type | Condition
ArgumentNullException | list is a null reference (in Visual Basic Nothing).

Remarks

This wrapper can be used to prevent any modifications to list.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | ArrayList.ReadOnly Overload List


ArrayList.Remove

Removes a specific object from the ArrayList.

[Visual Basic]
Overridable Public Sub Remove( _
   ByVal obj As Object _
)
[C#]
public virtual void Remove(
   object obj
);
[C++]
public: virtual void Remove(
   Object* obj
);
[JScript]
public function Remove(
   obj : Object
);

Parameters

obj
The Object to remove from the ArrayList.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentException | obj is not found in the ArrayList.
NotSupportedException | The ArrayList is read-only. -or- The ArrayList has a fixed size.

Remarks

This method can be overridden by a derived class.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace


ArrayList.RemoveAt

Removes the element at the specified index of the ArrayList.

[Visual Basic]
Overridable Public Sub RemoveAt( _
   ByVal index As Integer _
)
[C#]
public virtual void RemoveAt(
   int index
);
[C++]
public: virtual void RemoveAt(
   int index
);
[JScript]
public function RemoveAt(
   index : int
);

Parameters

index
The index of the element to remove.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.
NotSupportedException | The ArrayList is read-only. -or- The ArrayList has a fixed size.

Remarks

This method can be overridden by a derived class.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace


ArrayList.RemoveRange

Removes a range of elements from the ArrayList.

[Visual Basic]
Overridable Public Sub RemoveRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
[C#]
public virtual void RemoveRange(
   int index,
   int count
);
[C++]
public: virtual void RemoveRange(
   int index,
   int count
);
[JScript]
public function RemoveRange(
   index : int,
   count : int
);

Parameters

index
The starting index of the range of elements to remove.
count
The number of elements to remove.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- count is less than zero.
ArgumentException | index and count do not denote a valid range of elements in the ArrayList.
NotSupportedException | The ArrayList is read-only. -or- The ArrayList has a fixed size.

Remarks

This method can be overridden by a derived class.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | GetRange | AddRange | InsertRange | SetRange


ArrayList.Repeat

Returns an ArrayList whose elements are copies of the specified value.

[Visual Basic]
Public Shared Function Repeat( _
   ByVal value As Object, _
   ByVal count As Integer _
) As ArrayList
[C#]
public static ArrayList Repeat(
   object value,
   int count
);
[C++]
public: static ArrayList* Repeat(
   Object* value,
   int count
);
[JScript]
public static function Repeat(
   value : Object,
   count : int
) : ArrayList;

Parameters

value
The Object to copy multiple times in the new ArrayList.

-or-

a null reference (in Visual Basic Nothing).

count
The number of times value should be copied.

Return Value

An ArrayList with count number of elements, all of which are copies of value.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace


ArrayList.Reverse

Reverses the order of the elements in the ArrayList, or a portion of it.

Overload List

Reverses the order of the elements in the entire ArrayList.

[Visual Basic] Overloads Overridable Public Sub Reverse()
[C#] public virtual void Reverse();
[C++] public: virtual void Reverse();
[JScript] public function Reverse();

Reverses the order of the elements in the specified range.

[Visual Basic] Overloads Overridable Public Sub Reverse(Integer, Integer)
[C#] public virtual void Reverse(int, int);
[C++] public: virtual void Reverse(int, int);
[JScript] public function Reverse(int, int);

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace


ArrayList.Reverse ()

Reverses the order of the elements in the entire ArrayList.

[Visual Basic]
Overloads Overridable Public Sub Reverse()
[C#]
public virtual void Reverse();
[C++]
public: virtual void Reverse();
[JScript]
public function Reverse();

Return Value

None.

Exceptions

Exception Type | Condition
NotSupportedException | The ArrayList is read-only.

Remarks

This method can be overridden by a derived class.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | ArrayList.Reverse Overload List


ArrayList.Reverse (Int32, Int32)

Reverses the order of the elements in the specified range.

[Visual Basic]
Overloads Overridable Public Sub Reverse( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
[C#]
public virtual void Reverse(
   int index,
   int count
);
[C++]
public: virtual void Reverse(
   int index,
   int count
);
[JScript]
public function Reverse(
   index : int,
   count : int
);

Parameters

index
The starting index of the range to reverse.
count
The number of elements in the range to reverse.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- count is less than zero.
ArgumentException | index and count do not denote a valid range of elements in the ArrayList.
NotSupportedException | The ArrayList is read-only.

Remarks

This method can be overridden by a derived class.

This method uses Reverse to reverse the order of the elements, such that the element at ArrayList [i], where i is any index within the range, moves to ArrayList [j], where j equals index + index + count- i- 1.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | ArrayList.Reverse Overload List


ArrayList.SetRange

Copies the elements of a collection over a range of elements in the ArrayList.

[Visual Basic]
Overridable Public Sub SetRange( _
   ByVal index As Integer, _
   ByVal c As ICollection _
)
[C#]
public virtual void SetRange(
   int index,
   ICollection c
);
[C++]
public: virtual void SetRange(
   int index,
   ICollection* c
);
[JScript]
public function SetRange(
   index : int,
   c : ICollection
);

Parameters

index
The ArrayList index at which to start copying the elements of c.
c
The ICollection whose elements to copy to the ArrayList.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index plus the number of elements in c is greater than the Capacity of the ArrayList.
ArgumentNullException | c is a null reference (in Visual Basic Nothing).
NotSupportedException | The ArrayList is read-only.

Remarks

This method can be overridden by a derived class.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | AddRange | InsertRange | GetRange | RemoveRange


ArrayList.Sort

Sorts the elements in the ArrayList, or a portion of it.

Overload List

Sorts the elements in the entire ArrayList using the specified comparer.

[Visual Basic] Overloads Overridable Public Sub Sort(IComparer)
[C#] public virtual void Sort(IComparer);
[C++] public: virtual void Sort(IComparer*);
[JScript] public function Sort(IComparer);

Sorts the elements in the entire ArrayList using the IComparable implementation of each element.

[Visual Basic] Overloads Overridable Public Sub Sort()
[C#] public virtual void Sort();
[C++] public: virtual void Sort();
[JScript] public function Sort();

Sorts the elements in a section of ArrayList using the specified comparer.

[Visual Basic] Overloads Overridable Public Sub Sort(Integer, Integer, IComparer)
[C#] public virtual void Sort(int, int, IComparer);
[C++] public: virtual void Sort(int, int, IComparer);
[JScript] public function Sort(int, int, IComparer);

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace


ArrayList.Sort (IComparer)

Sorts the elements in the entire ArrayList using the specified comparer.

[Visual Basic]
Overloads Overridable Public Sub Sort( _
   ByVal comparer As IComparer _
)
[C#]
public virtual void Sort(
   IComparer comparer
);
[C++]
public: virtual void Sort(
   IComparer* comparer
);
[JScript]
public function Sort(
   comparer : IComparer
);

Parameters

comparer
The IComparer implementation to use when comparing elements.

-or-

a null reference (in Visual Basic Nothing) to use the IComparable implementation of each element.

Return Value

None.

Exceptions

Exception Type | Condition
NotSupportedException | The ArrayList is read-only.

Remarks

This method can be overridden by a derived class.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | ArrayList.Sort Overload List


ArrayList.Sort ()

Sorts the elements in the entire ArrayList using the IComparable implementation of each element.

[Visual Basic]
Overloads Overridable Public Sub Sort()
[C#]
public virtual void Sort();
[C++]
public: virtual void Sort();
[JScript]
public function Sort();

Return Value

None.

Exceptions

Exception Type | Condition
NotSupportedException | The ArrayList is read-only.

Remarks

This method can be overridden by a derived class.

This method uses Sort to sort the elements.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | ArrayList.Sort Overload List


ArrayList.Sort (Int32, Int32, IComparer)

Sorts the elements in a section of ArrayList using the specified comparer.

[Visual Basic]
Overloads Overridable Public Sub Sort( _
   ByVal index As Integer, _
   ByVal count As Integer, _
   ByVal comparer As IComparer _
)
[C#]
public virtual void Sort(
   int index,
   int count,
   IComparer comparer
);
[C++]
public: virtual void Sort(
   int index,
   int count,
   IComparer* comparer
);
[JScript]
public function Sort(
   index : int,
   count : int,
   comparer : IComparer
);

Parameters

index
The starting index of the range to sort.
count
The length of the range to sort.
comparer
The IComparer implementation to use when comparing elements.

-or-

a null reference (in Visual Basic Nothing) to use the IComparable implementation of each element.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- count is less than zero.
ArgumentException | index and count do not specify a valid range in the ArrayList.
NotSupportedException | The ArrayList is read-only.

Remarks

This method can be overridden by a derived class.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | ArrayList.Sort Overload List


ArrayList.Synchronized

Returns a list wrapper that is synchronized (thread-safe).

Overload List

Returns an IList wrapper that is synchronized (thread-safe).

[Visual Basic] Overloads Public Shared Function Synchronized(IList) As IList
[C#] public static IList Synchronized(IList);
[C++] public: static IList* Synchronized(IList*);
[JScript] public static function Synchronized(IList) : IList;

Returns an ArrayList wrapper that is synchronized (thread-safe).

[Visual Basic] Overloads Public Shared Function Synchronized(ArrayList) As ArrayList
[C#] public static ArrayList Synchronized(ArrayList);
[C++] public: static ArrayList* Synchronized(ArrayList*);
[JScript] public static function Synchronized(ArrayList) : ArrayList;

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace


ArrayList.Synchronized (IList)

Returns an IList wrapper that is synchronized (thread-safe).

[Visual Basic]
Overloads Public Shared Function Synchronized( _
   ByVal list As IList _
) As IList
[C#]
public static IList Synchronized(
   IList list
);
[C++]
public: static IList* Synchronized(
   IList* list
);
[JScript]
public static function Synchronized(
   list : IList
) : IList;

Parameters

list
The IList to synchronize.

Return Value

An IList wrapper that is synchronized (thread-safe).

Exceptions

Exception Type | Condition
ArgumentNullException | list is a null reference (in Visual Basic Nothing).

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | ArrayList.Synchronized Overload List | SyncRoot | IsSynchronized


ArrayList.Synchronized (ArrayList)

Returns an ArrayList wrapper that is synchronized (thread-safe).

[Visual Basic]
Overloads Public Shared Function Synchronized( _
   ByVal list As ArrayList _
) As ArrayList
[C#]
public static ArrayList Synchronized(
   ArrayList list
);
[C++]
public: static ArrayList* Synchronized(
   ArrayList* list
);
[JScript]
public static function Synchronized(
   list : ArrayList
) : ArrayList;

Parameters

list
The ArrayList to synchronize.

Return Value

An ArrayList wrapper that is synchronized (thread-safe).

Exceptions

Exception Type | Condition
ArgumentNullException | list is a null reference (in Visual Basic Nothing).

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | ArrayList.Synchronized Overload List | SyncRoot | IsSynchronized


ArrayList.ToArray

Copies the elements of the ArrayList to a new array.

Overload List

Copies the elements of the ArrayList to a new Object array.

[Visual Basic] Overloads Overridable Public Function ToArray() As Object ()
[C#] public virtual object[] ToArray();
[C++] public: virtual Object* ToArray() [];
[JScript] public function ToArray() : Object[];

Copies the elements of the ArrayList to a new array of the specified type.

[Visual Basic] Overloads Overridable Public Function ToArray(Type) As Array
[C#] public virtual Array ToArray(Type);
[C++] public: virtual Array* ToArray(Type*);
[JScript] public function ToArray(Type) : Array;

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace


ArrayList.ToArray ()

Copies the elements of the ArrayList to a new Object array.

[Visual Basic]
Overloads Overridable Public Function ToArray() As Object ()
[C#]
public virtual object[] ToArray();
[C++]
public: virtual Object* ToArray() [];
[JScript]
public function ToArray() : Object[];

Return Value

An Object array containing copies of the elements of the ArrayList.

Remarks

This method can be overridden by a derived class.

The elements are copied using Copy, which is an O(n) operation.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | ArrayList.ToArray Overload List


ArrayList.ToArray (Type)

Copies the elements of the ArrayList to a new array of the specified type.

[Visual Basic]
Overloads Overridable Public Function ToArray( _
   ByVal type As Type _
) As Array
[C#]
public virtual Array ToArray(
   Type type
);
[C++]
public: virtual Array* ToArray(
   Type* type
);
[JScript]
public function ToArray(
   type : Type
) : Array;

Parameters

type
The type of array to create and copy elements to.

Return Value

An array of the specified type containing copies of the elements of the ArrayList.

Exceptions

Exception Type | Condition
ArgumentNullException | type is a null reference (in Visual Basic Nothing).

Remarks

This method can be overridden by a derived class.

The elements are copied using Copy, which is an O(n) operation.Elements may be downcasted as required. The copy operation may fail if the downcasting is not allowed.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | ArrayList.ToArray Overload List


ArrayList.TrimToSize

Sets the capacity of the ArrayList to the actual number of elements in it.

[Visual Basic]
Overridable Public Sub TrimToSize()
[C#]
public virtual void TrimToSize();
[C++]
public: virtual void TrimToSize();
[JScript]
public function TrimToSize();

Return Value

None.

Exceptions

Exception Type | Condition
NotSupportedException | The ArrayList is read-only. -or- The ArrayList has a fixed size.

Remarks

This method can be overridden by a derived class.

This method can be used to minimize a list's memory overhead if no new elements would be added to the list.

To completely clear all elements in a list, call the Clear method before calling TrimToSize.

See Also

ArrayList Class | ArrayList Members | System.Collections Namespace | Clear | TrimToSize | Capacity | Count


BitArray Class

Manages a compact array of bit values, which are represented as booleans, where true indicates that the bit is on (1) and false indicates the bit is off (0).

Object
BitArray

[Visual Basic]
NotInheritable Public Class BitArray
[C#]
public sealed class BitArray
[C++]
public __gc __sealed class BitArray
[JScript]
public class BitArray

Remarks

The size of a BitArray is controlled by the client; indexing past the end of the BitArray throws an ArgumentException.

This class provides a simple set of capabilities on an array of bit values.

Requirements

Namespace: System.Collections

Assembly: mscorlib.dll

Example

The intended use for BitArray is:

if (bitflag->Get(bitindex)) { ... }

See Also

BitArray Members | System.Collections Namespace


BitArray Members

Public:

Constructor

BitArray Constructor Overloaded. Initializes a new BitArray. The capacity and the initial values can be specified.

Properties

Length Gets or sets the capacity of BitArray.

Methods

And | Performs the bitwise AND operator on the elements in the current BitArray against the corresponding elements in the specified BitArray.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | Retrieves the value of the bit at a specific position in the BitArray.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Not | Inverts all the bit values in the array, so that elements set to true are changed to false, and elements set to false are changed to true.
Or | Performs the bitwise OR operator on the elements in the current BitArray against the corresponding elements in the specified BitArray.
Set | Assigns a value to the bit at a specific position in the BitArray.
SetAll | Assigns a value to all bits in the BitArray.
ToString (inherited from Object) | Returns a String that represents the current Object.
Xor | Performs the bitwise eXclusive OR operator on the elements in the current BitArray against the corresponding elements in the specified BitArray.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BitArray Class | System.Collections Namespace


BitArray Constructor

Initializes a new BitArray. The capacity and the initial values can be specified.

Overload List

Creates a new BitArray with the capacity to hold the specified number of bit values, and initializes each bit to false.

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public BitArray(int);
[C++] public: BitArray(int);
[JScript] public function BitArray(int);

Creates a new BitArray with the capacity to hold the specified number of bit values, and initializes each bit to the specified value.

[Visual Basic] Overloads Public Sub New(Integer, Boolean)
[C#] public BitArray(int, bool);
[C++] public: BitArray(int, bool);
[JScript] public function BitArray(int, Boolean);

Copies the values of the bits in an array of bytes into a new BitArray.

[Visual Basic] Overloads Public Sub New(Byte())
[C#] public BitArray(byte[]);
[C++] public: BitArray(unsigned char*[]);
[JScript] public function BitArray(Byte[]);

Copies the values of the bits in an array of 32-bit integers into a new BitArray.

[Visual Basic] Overloads Public Sub New(Integer())
[C#] public BitArray(int[]);
[C++] public: BitArray(int*[]);
[JScript] public function BitArray(int[]);

Copies the values of the bits in the specified BitArray into a new BitArray.

[Visual Basic] Overloads Public Sub New(BitArray)
[C#] public BitArray(BitArray);
[C++] public: BitArray(BitArray*);
[JScript] public function BitArray(BitArray);

See Also

BitArray Class | BitArray Members | System.Collections Namespace


BitArray Constructor (Int32)

Creates a new BitArray with the capacity to hold the specified number of bit values, and initializes each bit to false.

[Visual Basic]
Overloads Public Sub New( _
   ByVal length As Integer _
)
[C#]
public BitArray(
   int length
);
[C++]
public: BitArray(
   int length
);
[JScript]
public function BitArray(
   length : int
);

Parameters

length
The number of bit values in the BitArray to create.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | length is less than zero.

See Also

BitArray Class | BitArray Members | System.Collections Namespace | BitArray Constructor Overload List


BitArray Constructor (Int32, Boolean)

Creates a new BitArray with the capacity to hold the specified number of bit values, and initializes each bit to the specified value.

[Visual Basic]
Overloads Public Sub New( _
   ByVal length As Integer, _
   ByVal defaultValue As Boolean _
)
[C#]
public BitArray(
   int length,
   bool defaultValue
);
[C++]
public: BitArray(
   int length,
   bool defaultValue
);
[JScript]
public function BitArray(
   length : int,
   defaultValue : Boolean
);

Parameters

length
The number of bit values in the BitArray to create.
defaultValue
The Boolean value to assign to each bit.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | length is less than zero.

See Also

BitArray Class | BitArray Members | System.Collections Namespace | BitArray Constructor Overload List


BitArray Constructor (Byte[])

Copies the values of the bits in an array of bytes into a new BitArray.

[Visual Basic]
Overloads Public Sub New( _
   ByVal bytes() As Byte _
)
[C#]
public BitArray(
   byte[] bytes
);
[C++]
public: BitArray(
   unsigned char* bytes[]
);
[JScript]
public function BitArray(
   bytes : Byte[]
);

Parameters

bytes
An array of bytes containing the values to copy, where each byte represents 8 consecutive bits.

Exceptions

Exception Type | Condition
ArgumentException | bytes is a null reference object.

Remarks

The character in the first byte represents bits 0- 7, the second byte in the array represents bits 8- 15, etc. Further, the Least Significant Bit of each byte represents the lowest index value; bytes[0] & 1 represents bit 0, bytes[0] & 2 represents bit 1, bytes[0] and 4 represents bit 2, etc.

See Also

BitArray Class | BitArray Members | System.Collections Namespace | BitArray Constructor Overload List


BitArray Constructor (Int32[])

Copies the values of the bits in an array of 32-bit integers into a new BitArray.

[Visual Basic]
Overloads Public Sub New( _
   ByVal values() As Integer _
)
[C#]
public BitArray(
   int[] values
);
[C++]
public: BitArray(
   int* values[]
);
[JScript]
public function BitArray(
   values : int[]
);

Parameters

values
An array of integers containing the values to copy, where each integer represents 32 consecutive bits.

Exceptions

Exception Type | Condition
ArgumentException | values is a null reference object.

Remarks

The number in the first values array element represents bits 0- 31, the second number in the array represents bits 32- 63, etc. Further, the Least Significant Bit of each integer represents the lowest index value; values [0] & 1 represents bit 0, values [0] & 2 represents bit 1, values [0] and 4 represents bit 2, etc.

See Also

BitArray Class | BitArray Members | System.Collections Namespace | BitArray Constructor Overload List


BitArray Constructor (BitArray)

Copies the values of the bits in the specified BitArray into a new BitArray.

[Visual Basic]
Overloads Public Sub New( _
   ByVal bits As BitArray _
)
[C#]
public BitArray(
   BitArray bits
);
[C++]
public: BitArray(
   BitArray* bits
);
[JScript]
public function BitArray(
   bits : BitArray
);

Parameters

bits
The BitArray to copy.

Exceptions

Exception Type | Condition
ArgumentException | bits is a null reference object.

See Also

BitArray Class | BitArray Members | System.Collections Namespace | BitArray Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

BitArray Properties

The properties of the BitArray class are listed below. For a complete list of BitArray class members, see the BitArray Members topic.

Public:

Length Gets or sets the capacity of BitArray.

See Also

BitArray Class | System.Collections Namespace


BitArray.Length

Gets or sets the capacity of BitArray.

[Visual Basic]
Public Property Length As Integer
[C#]
public int Length {get; set;}
[C++]
public: __property int get_Length();
public: __property void set_Length(int);
[JScript]
public function get Length() : int;
public function set Length(int);

Property Value

The number of bit values that BitArray can contain.

See Also

BitArray Class | BitArray Members | System.Collections Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

BitArray Methods

The methods of the BitArray class are listed below. For a complete list of BitArray class members, see the BitArray Members topic.

Public:

And | Performs the bitwise AND operator on the elements in the current BitArray against the corresponding elements in the specified BitArray.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | Retrieves the value of the bit at a specific position in the BitArray.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Not | Inverts all the bit values in the array, so that elements set to true are changed to false, and elements set to false are changed to true.
Or | Performs the bitwise OR operator on the elements in the current BitArray against the corresponding elements in the specified BitArray.
Set | Assigns a value to the bit at a specific position in the BitArray.
SetAll | Assigns a value to all bits in the BitArray.
ToString (inherited from Object) | Returns a String that represents the current Object.
Xor | Performs the bitwise eXclusive OR operator on the elements in the current BitArray against the corresponding elements in the specified BitArray.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BitArray Class | System.Collections Namespace


BitArray.And

Performs the bitwise AND operator on the elements in the current BitArray against the corresponding elements in the specified BitArray.

[Visual Basic]
Public Function And( _
   ByVal value As BitArray _
) As BitArray
[C#]
public BitArray And(
   BitArray value
);
[C++]
public: BitArray* And(
   BitArray* value
);
[JScript]
public function And(
   value : BitArray
) : BitArray;

Parameters

value
The BitArray with which to perform the bitwise AND operator.

Return Value

A BitArray containing the result of the bitwise AND operator on the elements in the current BitArray against the corresponding elements in the specified BitArray.

Exceptions

Exception Type | Condition
ArgumentNullException | value is a null reference object.
ArgumentException | value and the current BitArray do not have the same number of elements.

Remarks

The bitwise AND operator returns true if both operands are true, and returns false if one or both of the operands are false.

See Also

BitArray Class | BitArray Members | System.Collections Namespace


BitArray.Get

Retrieves the value of the bit at a specific position in the BitArray.

[Visual Basic]
Public Function Get( _
   ByVal index As Integer _
) As Boolean
[C#]
public bool Get(
   int index
);
[C++]
public: bool Get(
   int index
);
[JScript]
public function Get(
   index : int
) : Boolean;

Parameters

index
The index of the value to retrieve.

Return Value

The value of the bit at position index.

Exceptions

Exception Type | Condition
ArgumentException | index is less than zero. OR, index is greater than or equal to the number of elements in the BitArray.

See Also

BitArray Class | BitArray Members | System.Collections Namespace


BitArray.Not

Inverts all the bit values in the array, so that elements set to true are changed to false, and elements set to false are changed to true.

[Visual Basic]
Public Function Not() As BitArray
[C#]
public BitArray Not();
[C++]
public: BitArray* Not();
[JScript]
public function Not() : BitArray;

Return Value

The current instance with inverted bit values.

See Also

BitArray Class | BitArray Members | System.Collections Namespace


BitArray.Or

Performs the bitwise OR operator on the elements in the current BitArray against the corresponding elements in the specified BitArray.

[Visual Basic]
Public Function Or( _
   ByVal value As BitArray _
) As BitArray
[C#]
public BitArray Or(
   BitArray value
);
[C++]
public: BitArray* Or(
   BitArray* value
);
[JScript]
public function Or(
   value : BitArray
) : BitArray;

Parameters

value
The BitArray with which to perform the bitwise OR operator.

Return Value

A BitArray containing the result of the bitwise OR operator on the elements in the current BitArray against the corresponding elements in the specified BitArray.

Exceptions

Exception Type | Condition
ArgumentNullException | value is a null reference object.
ArgumentException | value and the current BitArray do not have the same number of elements.

Remarks

The bitwise OR operator returns true if one or both operands are true, and returns false if both of the operands are false.

See Also

BitArray Class | BitArray Members | System.Collections Namespace


BitArray.Set

Assigns a value to the bit at a specific position in the BitArray.

[Visual Basic]
Public Sub Set( _
   ByVal index As Integer, _
   ByVal value As Boolean _
)
[C#]
public void Set(
   int index,
   bool value
);
[C++]
public: void Set(
   int index,
   bool value
);
[JScript]
public function Set(
   index : int,
   value : Boolean
);

Parameters

index
The bit to set.
value
The Boolean value to assign to the bit.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. OR, index is greater than or equal to the number of elements in the BitArray.

See Also

BitArray Class | BitArray Members | System.Collections Namespace


BitArray.SetAll

Assigns a value to all bits in the BitArray.

[Visual Basic]
Public Sub SetAll( _
   ByVal value As Boolean _
)
[C#]
public void SetAll(
   bool value
);
[C++]
public: void SetAll(
   bool value
);
[JScript]
public function SetAll(
   value : Boolean
);

Parameters

value
The Boolean value to assign to all bits.

Return Value

None.

See Also

BitArray Class | BitArray Members | System.Collections Namespace


BitArray.Xor

Performs the bitwise eXclusive OR operator on the elements in the current BitArray against the corresponding elements in the specified BitArray.

[Visual Basic]
Public Function Xor( _
   ByVal value As BitArray _
) As BitArray
[C#]
public BitArray Xor(
   BitArray value
);
[C++]
public: BitArray* Xor(
   BitArray* value
);
[JScript]
public function Xor(
   value : BitArray
) : BitArray;

Parameters

value
The BitArray with which to perform the bitwise eXclusive OR operator.

Return Value

A BitArray containing the result of the bitwise eXclusive OR operator on the elements in the current BitArray against the corresponding elements in the specified BitArray.

Exceptions

Exception Type | Condition
ArgumentNullException | value is a null reference object.
ArgumentException | value and the current BitArray do not have the same number of elements.

Remarks

The bitwise exclusive OR operator returns true if exactly one operand is true, and returns false if both of the operands have the same Boolean value.

See Also

BitArray Class | BitArray Members | System.Collections Namespace


CaseInsensitiveComparer Class

[To be supplied.]

Object
CaseInsensitiveComparer

[Visual Basic]
Public Class CaseInsensitiveComparer
   Implements IComparer
[C#]
public class CaseInsensitiveComparer : IComparer
[C++]
public __gc class CaseInsensitiveComparer : public IComparer
[JScript]
public class CaseInsensitiveComparer implements IComparer

Remarks

[To be supplied.]

Requirements

Namespace: System.Collections

Assembly: mscorlib.dll

See Also

CaseInsensitiveComparer Members | System.Collections Namespace


CaseInsensitiveComparer Members

Public:

Constructor

CaseInsensitiveComparer Constructor [To be supplied.]

Methods

Compare | Compares two objects (case insensitive comparision) of the same type and returns a value indicating whether one is less than, equal to, or greater than the other.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Default An instance of Comparer that is always available.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CaseInsensitiveComparer Class | System.Collections Namespace


CaseInsensitiveComparer Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CaseInsensitiveComparer();
[C++]
public: CaseInsensitiveComparer();
[JScript]
public function CaseInsensitiveComparer();

See Also

CaseInsensitiveComparer Class | CaseInsensitiveComparer Members | System.Collections Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CaseInsensitiveComparer Methods

The methods of the CaseInsensitiveComparer class are listed below. For a complete list of CaseInsensitiveComparer class members, see the CaseInsensitiveComparer Members topic.

Public:

Compare | Compares two objects (case insensitive comparision) of the same type and returns a value indicating whether one is less than, equal to, or greater than the other.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CaseInsensitiveComparer Class | System.Collections Namespace


CaseInsensitiveComparer.Compare

Compares two objects (case insensitive comparision) of the same type and returns a value indicating whether one is less than, equal to, or greater than the other.

[Visual Basic]
Overridable Public Function Compare( _
   ByVal a As Object, _
   ByVal b As Object _
) As Integer
[C#]
public virtual int Compare(
   object a,
   object b
);
[C++]
public: virtual int Compare(
   Object* a,
   Object* b
);
[JScript]
public function Compare(
   a : Object,
   b : Object
) : int;

Parameters

a
The first object to compare.
b
The second object to compare.

Return Value

Value | Condition
Less than zero | a is less than b.
Zero | a equals (with casing ignored) b.
Greater than zero | a is greater than b.

Exceptions

Exception Type | Condition
ArgumentException | Neither a nor b implements the IComparable interface. -or- a and b are of different types.

Remarks

If a implements IComparable, then a. CompareTo (b) is returned; otherwise, if b implements IComparable, then b. CompareTo (a) is returned. If neither parameter implements IComparable, an exception is thrown.

An exception must also be thrown if a and b are objects of different types and neither one can handle comparisons with the other.

a null reference (in Visual Basic Nothing) can always be compared with any other type; therefore, comparisons with a null reference (Nothing) will not generate an exception when using IComparable. When sorting, a null reference (Nothing) is considered to be less than any other object.

See Also

CaseInsensitiveComparer Class | CaseInsensitiveComparer Members | System.Collections Namespace | IComparable


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CaseInsensitiveComparer Fields

The fields of the CaseInsensitiveComparer class are listed below. For a complete list of CaseInsensitiveComparer class members, see the CaseInsensitiveComparer Members topic.

Public:

Default An instance of Comparer that is always available.

See Also

CaseInsensitiveComparer Class | System.Collections Namespace


CaseInsensitiveComparer.Default

An instance of Comparer that is always available.

[Visual Basic]
Public Shared ReadOnly Default As CaseInsensitiveComparer
[C#]
public static readonly CaseInsensitiveComparer Default;
[C++]
public: static readonly CaseInsensitiveComparer* Default;
[JScript]
public static var Default : CaseInsensitiveComparer;

See Also

CaseInsensitiveComparer Class | CaseInsensitiveComparer Members | System.Collections Namespace


CaseInsensitiveHashCodeProvider Class

Supplies a hashcode for the implementing class. The hashing algorithm ignores the case for Strings. The default for Hashtables is to use case sensitive hashcodes. This class is typically used in conjunction with CaseInsensitiveComparer

Object
CaseInsensitiveHashCodeProvider

[Visual Basic]
Public Class CaseInsensitiveHashCodeProvider
   Implements IHashCodeProvider
[C#]
public class CaseInsensitiveHashCodeProvider : IHashCodeProvider
[C++]
public __gc class CaseInsensitiveHashCodeProvider : public
   IHashCodeProvider
[JScript]
public class CaseInsensitiveHashCodeProvider implements
   IHashCodeProvider

Remarks

The CaseInsensitiveHashCodeProvider class is used in conjunction with Hashtable. The objects used as keys by a Hashtable must implement or inherit the GetHashCode and Equals methods. However, if the Hashtable constructor is passed a reference to an object that implements both the IHashCodeProvider interface and the IComparer interface, then GetHashCode and Compare can be used instead.

Requirements

Namespace: System.Collections

Assembly: mscorlib.dll

See Also

CaseInsensitiveHashCodeProvider Members | System.Collections Namespace | Hashtable | IHashCodeProvider | IComparer


CaseInsensitiveHashCodeProvider Members

Public:

Constructor

CaseInsensitiveHashCodeProvider Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Default An instance of CaseInsensitiveHashCodeProvider that is always available.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CaseInsensitiveHashCodeProvider Class | System.Collections Namespace


CaseInsensitiveHashCodeProvider Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CaseInsensitiveHashCodeProvider();
[C++]
public: CaseInsensitiveHashCodeProvider();
[JScript]
public function CaseInsensitiveHashCodeProvider();

See Also

CaseInsensitiveHashCodeProvider Class | CaseInsensitiveHashCodeProvider Members | System.Collections Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CaseInsensitiveHashCodeProvider Methods

The methods of the CaseInsensitiveHashCodeProvider class are listed below. For a complete list of CaseInsensitiveHashCodeProvider class members, see the CaseInsensitiveHashCodeProvider Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CaseInsensitiveHashCodeProvider Class | System.Collections Namespace


CaseInsensitiveHashCodeProvider.GetHashCode

Returns a hash code (ignores case for Strings) for the given object.

[Visual Basic]
Overridable Public Function GetHashCode( _
   ByVal obj As Object _
) As Integer
[C#]
public virtual int GetHashCode(
   object obj
);
[C++]
public: virtual int GetHashCode(
   Object* obj
);
[JScript]
public function GetHashCode(
   obj : Object
) : int;

Parameters

obj
The Object for which a hash code is to be returned.

Return Value

Returns a hash code (ignores case for Strings) for the specified object.

See Also

CaseInsensitiveHashCodeProvider Class | CaseInsensitiveHashCodeProvider Members | System.Collections Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CaseInsensitiveHashCodeProvider Fields

The fields of the CaseInsensitiveHashCodeProvider class are listed below. For a complete list of CaseInsensitiveHashCodeProvider class members, see the CaseInsensitiveHashCodeProvider Members topic.

Public:

Default An instance of CaseInsensitiveHashCodeProvider that is always available.

See Also

CaseInsensitiveHashCodeProvider Class | System.Collections Namespace


CaseInsensitiveHashCodeProvider.Default

An instance of CaseInsensitiveHashCodeProvider that is always available.

[Visual Basic]
Public Shared ReadOnly Default As CaseInsensitiveHashCodeProvider
[C#]
public static readonly CaseInsensitiveHashCodeProvider Default;
[C++]
public: static readonly CaseInsensitiveHashCodeProvider* Default;
[JScript]
public static var Default : CaseInsensitiveHashCodeProvider;

See Also

CaseInsensitiveHashCodeProvider Class | CaseInsensitiveHashCodeProvider Members | System.Collections Namespace


CaseInsensitiveHashtable Class

[To be supplied.]

Object
Hashtable
CaseInsensitiveHashtable

[Visual Basic]
Public Class CaseInsensitiveHashtable
   Inherits Hashtable
[C#]
public class CaseInsensitiveHashtable : Hashtable
[C++]
public __gc class CaseInsensitiveHashtable : public Hashtable
[JScript]
public class CaseInsensitiveHashtable extends Hashtable

Remarks

[To be supplied.]

Requirements

Namespace: System.Collections

Assembly: System.dll

See Also

CaseInsensitiveHashtable Members | System.Collections Namespace


CaseInsensitiveHashtable Members

Public:

Constructor

CaseInsensitiveHashtable Constructor Overloaded. [To be supplied.]

Properties

Count (inherited from Hashtable) | Gets the number of key-and-value pairs in the Hashtable.
IsReadOnly (inherited from Hashtable) | Gets a value indicating whether the Hashtable is read-only.
IsSynchronized (inherited from Hashtable) | Gets a value indicating whether access to the Hashtable is synchronized (thread-safe).
Item (inherited from Hashtable) | Gets or sets the value associated with the specified key. In C#, this member is the indexer for the CaseInsensitiveHashtable class.
Keys (inherited from Hashtable) | Gets an ICollection containing the keys in the Hashtable.
SyncRoot (inherited from Hashtable) | Gets an object that can be used to synchronize access to the Hashtable.
Values (inherited from Hashtable) | Gets an ICollection containing the values in the Hashtable.

Methods

Add (inherited from Hashtable) | Adds an entry with the specified key and value into the Hashtable.
Clear (inherited from Hashtable) | Removes all entries from the Hashtable.
Clone (inherited from Hashtable) | Creates a shallow copy of the Hashtable.
Contains (inherited from Hashtable) | Determines if the Hashtable contains a specific key.
ContainsKey (inherited from Hashtable) | Determines if the Hashtable contains a specific key.
ContainsValue (inherited from Hashtable) | Determines if the Hashtable contains a specific value.
CopyTo (inherited from Hashtable) | Copies the Hashtable values into a one-dimensional Array instance at the specified index.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from Hashtable) | Returns an enumerator which can be used to iterate through the Hashtable.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Hashtable) | Implements the ISerializable interface and returns the data needed to serialize the Hashtable.
GetType (inherited from Object) | Gets the Type of the Object.
OnDeserialization (inherited from Hashtable) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from Hashtable) | Removes the entry with the specified key from the Hashtable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetHash (inherited from Hashtable) | Returns the hash code for the specified key.
KeyEquals (inherited from Hashtable) | Compares a specific Object with a specific key in the Hashtable.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

comparer (inherited from Hashtable) | Represents the comparer to use for the Hashtable.
hcp (inherited from Hashtable) | Represents the object that can dispense hash codes.

See Also

CaseInsensitiveHashtable Class | System.Collections Namespace


CaseInsensitiveHashtable Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public CaseInsensitiveHashtable();
[C++] public: CaseInsensitiveHashtable();
[JScript] public function CaseInsensitiveHashtable();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(IDictionary)
[C#] public CaseInsensitiveHashtable(IDictionary);
[C++] public: CaseInsensitiveHashtable(IDictionary*);
[JScript] public function CaseInsensitiveHashtable(IDictionary);

See Also

CaseInsensitiveHashtable Class | CaseInsensitiveHashtable Members | System.Collections Namespace


CaseInsensitiveHashtable Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public CaseInsensitiveHashtable();
[C++]
public: CaseInsensitiveHashtable();
[JScript]
public function CaseInsensitiveHashtable();

See Also

CaseInsensitiveHashtable Class | CaseInsensitiveHashtable Members | System.Collections Namespace | CaseInsensitiveHashtable Constructor Overload List


CaseInsensitiveHashtable Constructor (IDictionary)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal d As IDictionary _
)
[C#]
public CaseInsensitiveHashtable(
   IDictionary d
);
[C++]
public: CaseInsensitiveHashtable(
   IDictionary* d
);
[JScript]
public function CaseInsensitiveHashtable(
   d : IDictionary
);

Parameters

d
[To be supplied.]

See Also

CaseInsensitiveHashtable Class | CaseInsensitiveHashtable Members | System.Collections Namespace | CaseInsensitiveHashtable Constructor Overload List


CaseInsensitiveSortedList Class

[To be supplied.]

Object
SortedList
CaseInsensitiveSortedList

[Visual Basic]
Public Class CaseInsensitiveSortedList
   Inherits SortedList
[C#]
public class CaseInsensitiveSortedList : SortedList
[C++]
public __gc class CaseInsensitiveSortedList : public SortedList
[JScript]
public class CaseInsensitiveSortedList extends SortedList

Remarks

[To be supplied.]

Requirements

Namespace: System.Collections

Assembly: System.dll

See Also

CaseInsensitiveSortedList Members | System.Collections Namespace


CaseInsensitiveSortedList Members

Public:

Constructor

CaseInsensitiveSortedList Constructor [To be supplied.]

Properties

Capacity (inherited from SortedList) | Gets or sets the capacity of the SortedList.
Count (inherited from SortedList) | Gets the current number of elements in the SortedList.
IsReadOnly (inherited from SortedList) | Gets a value indicating whether the SortedList is read-only.
IsSynchronized (inherited from SortedList) | Gets a value indicating whether access to the SortedList is synchronized (thread-safe).
Item (inherited from SortedList) | Gets and sets the value associated with a specific key in the SortedList. In C#, this member is the indexer for the CaseInsensitiveSortedList class.
Keys (inherited from SortedList) | Gets the keys in the SortedList.
SyncRoot (inherited from SortedList) | Gets an object that can be used to synchronize access to the SortedList.
Values (inherited from SortedList) | Gets the values in the SortedList.

Methods

Add (inherited from SortedList) | Adds an element with the specified key and value into the SortedList.
Clear (inherited from SortedList) | Removes all elements from the SortedList.
Clone (inherited from SortedList) | Creates a shallow copy of the SortedList.
Contains (inherited from SortedList) | Determines if the SortedList contains a specific key.
ContainsKey (inherited from SortedList) | Determines if the SortedList contains a specific key.
ContainsValue (inherited from SortedList) | Determines if the SortedList contains a specific value.
CopyTo (inherited from SortedList) | Copies the SortedList values into a one-dimensional Array instance at the specified index.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetByIndex (inherited from SortedList) | Retrieves the value at the specified index of the SortedList.
GetEnumerator (inherited from SortedList) | Returns an enumerator which can be used to iterate through the SortedList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetKey (inherited from SortedList) | Retrieves the key at the specified index of the SortedList.
GetKeyList (inherited from SortedList) | Gets the keys in the SortedList.
GetType (inherited from Object) | Gets the Type of the Object.
GetValueList (inherited from SortedList) | Gets the values in the SortedList.
IndexOfKey (inherited from SortedList) | Returns the index of the specified key in the SortedList.
IndexOfValue (inherited from SortedList) | Returns the index of the first occurrence of the specified value in the SortedList.
Remove (inherited from SortedList) | Removes the element with the specified key from SortedList.
RemoveAt (inherited from SortedList) | Removes the element at the specified index of SortedList.
SetByIndex (inherited from SortedList) | Saves the value at a specific index in the SortedList.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize (inherited from SortedList) | Sets the capacity to the actual number of elements in the SortedList.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CaseInsensitiveSortedList Class | System.Collections Namespace


CaseInsensitiveSortedList Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CaseInsensitiveSortedList();
[C++]
public: CaseInsensitiveSortedList();
[JScript]
public function CaseInsensitiveSortedList();

See Also

CaseInsensitiveSortedList Class | CaseInsensitiveSortedList Members | System.Collections Namespace


Comparer Class

Provides the default implementation for the IComparer interface, including the method CompareTo, which compares two objects for equivalence.

Object
Comparer

[Visual Basic]
NotInheritable Public Class Comparer
   Implements IComparer
[C#]
public sealed class Comparer : IComparer
[C++]
public __gc __sealed class Comparer : public IComparer
[JScript]
public class Comparer implements IComparer

Remarks

[To be supplied.]

Requirements

Namespace: System.Collections

Assembly: mscorlib.dll

See Also

Comparer Members | System.Collections Namespace | IComparer | IComparable


Comparer Members

Public:

Methods

Compare | Compares two objects of the same type and returns a value indicating whether one is less than, equal to, or greater than the other.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Default An instance of Comparer that is always available.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Comparer Class | System.Collections Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Comparer Methods

The methods of the Comparer class are listed below. For a complete list of Comparer class members, see the Comparer Members topic.

Public:

Compare | Compares two objects of the same type and returns a value indicating whether one is less than, equal to, or greater than the other.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Comparer Class | System.Collections Namespace


Comparer.Compare

Compares two objects of the same type and returns a value indicating whether one is less than, equal to, or greater than the other.

[Visual Basic]
Overridable Public Function Compare( _
   ByVal a As Object, _
   ByVal b As Object _
) As Integer
[C#]
public virtual int Compare(
   object a,
   object b
);
[C++]
public: virtual int Compare(
   Object* a,
   Object* b
);
[JScript]
public function Compare(
   a : Object,
   b : Object
) : int;

Parameters

a
The first object to compare.
b
The second object to compare.

Return Value

Value | Condition
Less than zero | a is less than b.
Zero | a equals b.
Greater than zero | a is greater than b.

Exceptions

Exception Type | Condition
ArgumentException | Neither a nor b implements the IComparable interface. -or- a and b are of different types.

Remarks

If a implements IComparable, then a.CompareTo(b) is returned; otherwise, if b implements IComparable, then b.CompareTo(a) is returned. If neither parameter implements IComparable, an exception is thrown.

An exception must also be thrown if a and b are objects of different types and neither one can handle comparisons with the other.

a null reference (in Visual Basic Nothing) can always be compared with any other type; therefore, comparisons with a null reference (Nothing) will not generate an exception when using IComparable. When sorting, a null reference (Nothing) is considered to be less than any other object.

See Also

Comparer Class | Comparer Members | System.Collections Namespace | IComparable


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Comparer Fields

The fields of the Comparer class are listed below. For a complete list of Comparer class members, see the Comparer Members topic.

Public:

Default An instance of Comparer that is always available.

See Also

Comparer Class | System.Collections Namespace


Comparer.Default

An instance of Comparer that is always available.

[Visual Basic]
Public Shared ReadOnly Default As Comparer
[C#]
public static readonly Comparer Default;
[C++]
public: static readonly Comparer* Default;
[JScript]
public static var Default : Comparer;

See Also

Comparer Class | Comparer Members | System.Collections Namespace


Dictionary Class

Represents a collection of associated keys and values.

Object
Dictionary

[Visual Basic]
Public Class Dictionary
   Implements IDictionary, ICollection, IEnumerable, ISerializable, _
   IDeserializationEventListener
[C#]
public class Dictionary : IDictionary, ICollection, IEnumerable,
   ISerializable, IDeserializationEventListener
[C++]
public __gc class Dictionary : public IDictionary, ICollection,
   IEnumerable, ISerializable, IDeserializationEventListener
[JScript]
public class Dictionary implements IDictionary, ICollection,
   IEnumerable, ISerializable, IDeserializationEventListener

Remarks

Dictionary is the default implementation of the IDictionary interface.

Each association must have a unique non-null key, but the value of an association can be any object reference, including a null reference (in Visual Basic Nothing). The Dictionary class allows the keys and values to be enumerated, but it does not imply any particular sort order.

The Dictionary class is internally implemented as a hashtable. The Hashtable class inherits from this class.

The objects used as keys in a Dictionary must implement or inherit the GetHashCode and Equals methods. If key equality is simply reference equality, the inherited implementation of these methods would suffice. Furthermore, these methods must produce the same results when called with the same parameters while the key exists in the Dictionary. Key objects must be immutable, as long as they are used as keys in the Dictionary.

When an entry is added to the Dictionary, the entry is placed into a bucket based on the hashcode of the key. Subsequent lookups of the key will use the hashcode of the key to search only in one particular bucket, thus substantially reducing the number of key comparisons required to find an entry.

A Dictionary 's maximum load factor determines the maximum ratio of entries to buckets. Smaller load factors cause faster average lookup times at the cost of increased memory consumption. The default maximum load factor of 1.0 generally provides the best balance between speed and size. A different maximum load factor can also be specified when the Dictionary is instantiated.

As entries are added to a Dictionary, the Dictionary 's actual load factor increases. When the actual load factor reaches the maximum load factor, the number of buckets in the Dictionary is automatically increased to the smallest prime number that is larger than twice the current number of Dictionary buckets.

Each key object in the Dictionary must provide its own hash function, which can be accessed by calling GetHash. However, any object implementing IHashCodeProvider can be passed to a Dictionary constructor, and that hash function would be used for all objects in the table.

Requirements

Namespace: System.Collections

Assembly: mscorlib.dll

See Also

Dictionary Members | System.Collections Namespace | IDictionary | IHashCodeProvider | Hashtable


Dictionary Members

Public:

Constructor

Dictionary Constructor Overloaded. Initializes a new instance of the Dictionary class.

Properties

Count | Gets the number of key-and-value pairs in the Dictionary.
IsReadOnly | Gets a value indicating whether the Dictionary is read-only.
IsSynchronized | Gets a value indicating whether access to the Dictionary is synchronized (thread-safe).
Item | Gets or sets the value associated with the specified key. In C#, this member is the indexer for the Dictionary class.
Keys | Gets an ICollection containing the keys in the Dictionary.
SyncRoot | Gets an object that can be used to synchronize access to the Dictionary.
Values | Gets an ICollection containing the values in the Dictionary.

Methods

Add | Adds an entry with the specified key and value into the Dictionary.
Clear | Removes all entries from the Dictionary.
Contains | Determines whether the Dictionary contains an entry with the specified key.
CopyTo | Overloaded. Copies the Dictionary values into a one-dimensional array.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Returns an enumerator which can be used to iterate through the Dictionary.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary.
GetType (inherited from Object) | Gets the Type of the Object.
OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove | Removes the entry with the specified key from the Dictionary.
Synchronized | Returns a synchronized (thread-safe) wrapper for the Dictionary.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Dictionary Class | System.Collections Namespace


Dictionary Constructor

Initializes a new instance of the Dictionary class.

Overload List

Creates a new Dictionary with the default initial capacity and the default maximum load factor.

[Visual Basic] Overloads Public Sub New()
[C#] public Dictionary();
[C++] public: Dictionary();
[JScript] public function Dictionary();

Creates a new Dictionary with the specified initial capacity and the default load factor.

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public Dictionary(int);
[C++] public: Dictionary(int);
[JScript] public function Dictionary(int);

Creates a new Dictionary with the specified initial capacity and load factor.

[Visual Basic] Overloads Public Sub New(Integer, Single)
[C#] public Dictionary(int, float);
[C++] public: Dictionary(int, float);
[JScript] public function Dictionary(int, float);

Copies the entries in the specified dictionary into a new Dictionary.

[Visual Basic] Overloads Public Sub New(IDictionary)
[C#] public Dictionary(IDictionary);
[C++] public: Dictionary(IDictionary*);
[JScript] public function Dictionary(IDictionary);

See Also

Dictionary Class | Dictionary Members | System.Collections Namespace


Dictionary Constructor ()

Creates a new Dictionary with the default initial capacity and the default maximum load factor.

[Visual Basic]
Overloads Public Sub New()
[C#]
public Dictionary();
[C++]
public: Dictionary();
[JScript]
public function Dictionary();

Remarks

A dictionary's capacity is the number of key-and-value pairs it can contain. The default initial capacity is zero. Capacity is increased as the number of buckets is increased based on the load factor.

The maximum load factor is the maximum ratio of entries to buckets. A smaller load factor means faster lookup at the cost of increased memory consumption. The default maximum load factor is 1.0, which is the best balance between speed and size.

When the actual load factor reaches the maximum load factor, the number of buckets is automatically increased to the smallest prime number that is larger than twice the current number of buckets.

See Also

Dictionary Class | Dictionary Members | System.Collections Namespace | Dictionary Constructor Overload List


Dictionary Constructor (Int32)

Creates a new Dictionary with the specified initial capacity and the default load factor.

[Visual Basic]
Overloads Public Sub New( _
   ByVal capacity As Integer _
)
[C#]
public Dictionary(
   int capacity
);
[C++]
public: Dictionary(
   int capacity
);
[JScript]
public function Dictionary(
   capacity : int
);

Parameters

capacity
The initial number of entries that the Dictionary can contain.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | capacity is less than zero.

Remarks

Specifying the initial capacity eliminates a number of resizing operations that would otherwise be performed while adding entries to the Dictionary. Capacity is increased as the number of buckets is increased based on the load factor.

The maximum load factor is the maximum ratio of entries to buckets. A smaller load factor means faster lookup at the cost of increased memory consumption. The default maximum load factor is 1.0, which is the best balance between speed and size.

When the actual load factor reaches the maximum load factor, the number of buckets is automatically increased to the smallest prime number that is larger than twice the current number of buckets.

See Also

Dictionary Class | Dictionary Members | System.Collections Namespace | Dictionary Constructor Overload List


Dictionary Constructor (Int32, Single)

Creates a new Dictionary with the specified initial capacity and load factor.

[Visual Basic]
Overloads Public Sub New( _
   ByVal capacity As Integer, _
   ByVal loadFactor As Single _
)
[C#]
public Dictionary(
   int capacity,
   float loadFactor
);
[C++]
public: Dictionary(
   int capacity,
   float loadFactor
);
[JScript]
public function Dictionary(
   capacity : int,
   loadFactor : float
);

Parameters

capacity
The initial number of entries that the Dictionary can contain.
loadFactor
A number in the range from 0.1 through 1.0 indicating the maximum ratio of entries to buckets.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | capacity is less than zero. -or- loadfactor is less than 0.1. -or- loadfactor is greater than 1.0.

Remarks

Specifying the initial capacity eliminates a number of resizing operations that would otherwise be performed while adding entries to the Dictionary. Capacity is increased as the number of buckets is increased based on the load factor.

The maximum load factor is the maximum ratio of entries to buckets. A smaller load factor means faster lookup at the cost of increased memory consumption. A maximum load factor of 1.0 is the best balance between speed and size.

When the actual load factor reaches the maximum load factor, the number of buckets is automatically increased to the smallest prime number that is larger than twice the current number of buckets.

See Also

Dictionary Class | Dictionary Members | System.Collections Namespace | Dictionary Constructor Overload List


Dictionary Constructor (IDictionary)

Copies the entries in the specified dictionary into a new Dictionary.

[Visual Basic]
Overloads Public Sub New( _
   ByVal d As IDictionary _
)
[C#]
public Dictionary(
   IDictionary d
);
[C++]
public: Dictionary(
   IDictionary* d
);
[JScript]
public function Dictionary(
   d : IDictionary
);

Parameters

d
The IDictionary to copy into a new Dictionary.

Exceptions

Exception Type | Condition
ArgumentNullException | d is a null reference (in Visual Basic Nothing).

Remarks

The initial capacity is set to the number of entries in the source dictionary. Capacity is increased as the number of buckets is increased based on the load factor.

The maximum load factor is the maximum ratio of entries to buckets. A smaller load factor means faster lookup at the cost of increased memory consumption. A maximum load factor of 1.0 is the best balance between speed and size.When the actual load factor reaches the maximum load factor, the number of buckets is automatically increased to the smallest prime number that is larger than twice the current number of buckets.

See Also

Dictionary Class | Dictionary Members | System.Collections Namespace | Dictionary Constructor Overload List | IDictionary


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Dictionary Properties

The properties of the Dictionary class are listed below. For a complete list of Dictionary class members, see the Dictionary Members topic.

Public:

Count | Gets the number of key-and-value pairs in the Dictionary.
IsReadOnly | Gets a value indicating whether the Dictionary is read-only.
IsSynchronized | Gets a value indicating whether access to the Dictionary is synchronized (thread-safe).
Item | Gets or sets the value associated with the specified key. In C#, this member is the indexer for the Dictionary class.
Keys | Gets an ICollection containing the keys in the Dictionary.
SyncRoot | Gets an object that can be used to synchronize access to the Dictionary.
Values | Gets an ICollection containing the values in the Dictionary.

See Also

Dictionary Class | System.Collections Namespace


Dictionary.Count

Gets the number of key-and-value pairs in the Dictionary.

[Visual Basic]
Overridable Public ReadOnly Property Count As Integer
[C#]
public int Count {virtual get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;

Property Value

The number of key-and-value pairs in the Dictionary.

See Also

Dictionary Class | Dictionary Members | System.Collections Namespace


Dictionary.IsReadOnly

Gets a value indicating whether the Dictionary is read-only.

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {virtual get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;

Property Value

true if the Dictionary is read-only; otherwise, false.

See Also

Dictionary Class | Dictionary Members | System.Collections Namespace


Dictionary.IsSynchronized

Gets a value indicating whether access to the Dictionary is synchronized (thread-safe).

[Visual Basic]
Overridable Public ReadOnly Property IsSynchronized As Boolean
[C#]
public bool IsSynchronized {virtual get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;

Property Value

true if access to the Dictionary is synchronized (thread-safe); otherwise, false.

See Also

Dictionary Class | Dictionary Members | System.Collections Namespace | Synchronized | SyncRoot


Dictionary.Item

Gets or sets the value associated with the specified key.

[C#] In C#, this member is the indexer for the Dictionary class.

[Visual Basic]
Overridable Public Default Property Item( _
   ByVal key As Object _
) As Object
[C#]
public object this[
   object key
] {virtual get; virtual set;}
[C++]
public: __property virtual Object* get_Item(
   Object* key
);
public: __property virtual void set_Item(
   Object* key,
   Object*
);
[JScript]
returnValue = DictionaryObject.Item(key);
DictionaryObject.Item(key) = returnValue;
-or-
returnValue = DictionaryObject(key);
DictionaryObject(key) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

key
The key whose value to get or set.

Parameters [Visual Basic, C#, C++]

key
The key whose value to get or set.

Property Value

The value associated with the specified key. If the specified key is not found, Get returns a null reference (in Visual Basic Nothing), and Set creates a new entry with the specified key.

Exceptions

Exception Type | Condition
ArgumentNullException | key is a null reference (Nothing).
NotSupportedException | The Dictionary is read-only and Set is attempted.

See Also

Dictionary Class | Dictionary Members | System.Collections Namespace


Dictionary.Keys

Gets an ICollection containing the keys in the Dictionary.

[Visual Basic]
Overridable Public ReadOnly Property Keys As ICollection
[C#]
public ICollection Keys {virtual get;}
[C++]
public: __property virtual ICollection* get_Keys();
[JScript]
public function get Keys() : ICollection;

Property Value

An ICollection containing the keys in the Dictionary.

Remarks

The order of the keys in the ICollection is unspecified, but it is the same order as the associated values in the ICollection returned by the Values method.

Changes to the Dictionary will continue to be reflected in the returned ICollection. It is not a static copy.

See Also

Dictionary Class | Dictionary Members | System.Collections Namespace | ICollection | Values


Dictionary.SyncRoot

Gets an object that can be used to synchronize access to the Dictionary.

[Visual Basic]
Overridable Public ReadOnly Property SyncRoot As Object
[C#]
public object SyncRoot {virtual get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;

Property Value

An object that can be used to synchronize access to the Dictionary.

Remarks

The root object for a Dictionary is used when performing synchronized operations on the Dictionary. Instead of synchronizing directly on a Dictionary, program code should always synchronize on the root of the Dictionary. This ensures proper operation of dictionaries that are derived from other objects; proper synchronization is maintained with other threads that might be simultaneously modifying the Dictionary object.

Example

In the following example, the Message object exposes a set of properties as a Dictionary. By synchronizing on the root of d (which will return a reference to the Message object), proper synchronization is maintained with other threads that might be simultaneously modifying the Message object.

Message m = ...;
Dictionary d = m->GetProperties();
synchronized (d->GetRoot()) {
  String sender = (String)d->Get("Sender");
  byte[] bytes = (byte[])d->Get("Bytes");
  ...
}

See Also

Dictionary Class | Dictionary Members | System.Collections Namespace | IsSynchronized | Synchronized


Dictionary.Values

Gets an ICollection containing the values in the Dictionary.

[Visual Basic]
Overridable Public ReadOnly Property Values As ICollection
[C#]
public ICollection Values {virtual get;}
[C++]
public: __property virtual ICollection* get_Values();
[JScript]
public function get Values() : ICollection;

Property Value

An ICollection containing the values in the Dictionary.

Remarks

The order of the values in the ICollection is unspecified, but it is the same order as the associated keys in the ICollection returned by the Keys method.

Changes to the Dictionary will continue to be reflected in the returned ICollection. It is not a static copy.

See Also

Dictionary Class | Dictionary Members | System.Collections Namespace | ICollection | Keys


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Dictionary Methods

The methods of the Dictionary class are listed below. For a complete list of Dictionary class members, see the Dictionary Members topic.

Public:

Add | Adds an entry with the specified key and value into the Dictionary.
Clear | Removes all entries from the Dictionary.
Contains | Determines whether the Dictionary contains an entry with the specified key.
CopyTo | Overloaded. Copies the Dictionary values into a one-dimensional array.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Returns an enumerator which can be used to iterate through the Dictionary.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary.
GetType (inherited from Object) | Gets the Type of the Object.
OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove | Removes the entry with the specified key from the Dictionary.
Synchronized | Returns a synchronized (thread-safe) wrapper for the Dictionary.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Dictionary Class | System.Collections Namespace


Dictionary.Add

Adds an entry with the specified key and value into the Dictionary.

[Visual Basic]
Overridable Public Sub Add( _
   ByVal key As Object, _
   ByVal value As Object _
)
[C#]
public virtual void Add(
   object key,
   object value
);
[C++]
public: virtual void Add(
   Object* key,
   Object* value
);
[JScript]
public function Add(
   key : Object,
   value : Object
);

Parameters

key
The key of the entry to add.
value
The value of the entry to add.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | key is a null reference (in Visual Basic Nothing).
ArgumentException | An entry with the same key already exists in the Dictionary.
NotSupportedException | The Dictionary is read-only.

Remarks

This method can be overridden by a derived class.

See Also

Dictionary Class | Dictionary Members | System.Collections Namespace | Remove


Dictionary.Clear

Removes all entries from the Dictionary.

[Visual Basic]
Overridable Public Sub Clear()
[C#]
public virtual void Clear();
[C++]
public: virtual void Clear();
[JScript]
public function Clear();

Return Value

None.

Exceptions

Exception Type | Condition
NotSupportedException | The Dictionary is read-only.

Remarks

This method can be overridden by a derived class.

See Also

Dictionary Class | Dictionary Members | System.Collections Namespace


Dictionary.Contains

Determines whether the Dictionary contains an entry with the specified key.

[Visual Basic]
Overridable Public Function Contains( _
   ByVal key As Object _
) As Boolean
[C#]
public virtual bool Contains(
   object key
);
[C++]
public: virtual bool Contains(
   Object* key
);
[JScript]
public function Contains(
   key : Object
) : Boolean;

Parameters

key
The key to locate in the Dictionary.

Return Value

true if the Dictionary contains an entry with the specified key; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentNullException | key is a null reference (in Visual Basic Nothing).

Remarks

This method can be overridden by a derived class.

This implementation is an O(1) operation.

See Also

Dictionary Class | Dictionary Members | System.Collections Namespace


Dictionary.CopyTo

Copies the Dictionary values into a one-dimensional array.

Overload List

Copies the Dictionary values into a one-dimensional Array instance at the specified index.

[Visual Basic] Overloads Overridable Public Sub CopyTo(Array, Integer)
[C#] public virtual void CopyTo(Array, int);
[C++] public: virtual void CopyTo(Array*, int);
[JScript] public function CopyTo(Array, int);

Copies the Dictionary entries into a one-dimensional array of DictionaryEntry objects at the specified index.

[Visual Basic] Overloads Overridable Public Sub CopyTo(DictionaryEntry(), Integer)
[C#] public virtual void CopyTo(DictionaryEntry[], int);
[C++] public: virtual void CopyTo(DictionaryEntry*[], int);
[JScript] public function CopyTo(DictionaryEntry[], int);

See Also

Dictionary Class | Dictionary Members | System.Collections Namespace


Dictionary.CopyTo (Array, Int32)

Copies the Dictionary values into a one-dimensional Array instance at the specified index.

[Visual Basic]
Overloads Overridable Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal arrayIndex As Integer _
)
[C#]
public virtual void CopyTo(
   Array array,
   int arrayIndex
);
[C++]
public: virtual void CopyTo(
   Array* array,
   int arrayIndex
);
[JScript]
public function CopyTo(
   array : Array,
   arrayIndex : int
);

Parameters

array
The one-dimensional Array to contain the Dictionary values.
arrayIndex
The index in array at which to start copying.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentException | array is multidimensional. -or- The number of elements in the Dictionary is greater than the available space between arrayIndex and the end of array.
ArgumentNullException | array is a null reference (in Visual Basic Nothing).
ArgumentOutOfRangeException | arrayIndex is less than array 's lowbound.

Remarks

This method can be overridden by a derived class.

CopyTo only copies the values in the Dictionary, not the keys.

See Also

Dictionary Class | Dictionary Members | System.Collections Namespace | Dictionary.CopyTo Overload List


Dictionary.CopyTo (DictionaryEntry[], Int32)

Copies the Dictionary entries into a one-dimensional array of DictionaryEntry objects at the specified index.

[Visual Basic]
Overloads Overridable Public Sub CopyTo( _
   ByVal array() As DictionaryEntry, _
   ByVal arrayIndex As Integer _
)
[C#]
public virtual void CopyTo(
   DictionaryEntry[] array,
   int arrayIndex
);
[C++]
public: virtual void CopyTo(
   DictionaryEntry* array[],
   int arrayIndex
);
[JScript]
public function CopyTo(
   array : DictionaryEntry[],
   arrayIndex : int
);

Parameters

array
The one-dimensional array of DictionaryEntry objects to contain the Dictionary entries.
arrayIndex
The index in array at which to start copying.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentException | array is multidimensional. -or- The number of elements in the Dictionary is greater than the available space between arrayIndex and the end of the array.
ArgumentNullException | array is a null reference (in Visual Basic Nothing).
ArgumentOutOfRangeException | arrayIndex is less than array 's lowbound.

Remarks

This method can be overridden by a derived class.

See Also

Dictionary Class | Dictionary Members | System.Collections Namespace | Dictionary.CopyTo Overload List | DictionaryEntry


Dictionary.GetEnumerator

Returns an enumerator which can be used to iterate through the Dictionary.

[Visual Basic]
Overridable Public Function GetEnumerator() As IDictionaryEnumerator
[C#]
public virtual IDictionaryEnumerator GetEnumerator();
[C++]
public: virtual IDictionaryEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IDictionaryEnumerator;

Return Value

An IDictionaryEnumerator for the Dictionary.

Remarks

This method can be overridden by a derived class.

The enumerator does not have exclusive access to the Dictionary; therefore, any changes made to the Dictionary may cause Current or MoveNext to throw an exception.

Removing objects from the enumerator will remove them from the Dictionary.

An IDictionaryEnumerator can also be obtained by casting. Subclasses of the Dictionary class guarantee to return an IDictionaryEnumerator. This is a convenient method of calling the overloaded version of GetEnumerator that takes a Boolean parameter to specify whether the enumeration support entry removal. Note that that version of GetEnumerator must be implemented for this method to work.

Example

Dictionary d = //...
DictionaryEnumerator e = (DictionaryEnumerator) d.GetEnumerator();

See Also

Dictionary Class | Dictionary Members | System.Collections Namespace | IDictionaryEnumerator | IEnumerator


Dictionary.GetObjectData

Implements the ISerializable interface and returns the data needed to serialize the Dictionary.

[Visual Basic]
Overridable Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
public: virtual void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
);
[JScript]
public function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);

Parameters

info
A SerializationInfo object containing information required to serialize the Dictionary.
context
A StreamingContext object containing the source and destination of the serialized stream associated with the Dictionary.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | info is a null reference (in Visual Basic Nothing).

Remarks

This method can be overridden by a derived class.

A context intercepts calls to the class members and enforce policies that are applied to the class, such as synchronization.

See Also

Dictionary Class | Dictionary Members | System.Collections Namespace | ISerializable | SerializationInfo | StreamingContext | OnDeserialization


Dictionary.OnDeserialization

Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.

[Visual Basic]
Overridable Public Sub OnDeserialization( _
   ByVal sender As Object, _
   ByVal dsEvent As DeserializationEvent _
)
[C#]
public virtual void OnDeserialization(
   object sender,
   DeserializationEvent dsEvent
);
[C++]
public: virtual void OnDeserialization(
   Object* sender,
   DeserializationEvent* dsEvent
);
[JScript]
public function OnDeserialization(
   sender : Object,
   dsEvent : DeserializationEvent
);

Parameters

sender
The source of the deserialization event.
dsEvent
A DeserializationEvent object that contains the event data.

Return Value

None.

Remarks

This method can be overridden by a derived class.

See Also

Dictionary Class | Dictionary Members | System.Collections Namespace | ISerializable | DeserializationEvent | GetObjectData


Dictionary.Remove

Removes the entry with the specified key from the Dictionary.

[Visual Basic]
Overridable Public Sub Remove( _
   ByVal key As Object _
)
[C#]
public virtual void Remove(
   object key
);
[C++]
public: virtual void Remove(
   Object* key
);
[JScript]
public function Remove(
   key : Object
);

Parameters

key
The key of the entry to remove.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | key is a null reference (in Visual Basic Nothing).
NotSupportedException | The Dictionary is read-only.

Remarks

This method can be overridden by a derived class.

See Also

Dictionary Class | Dictionary Members | System.Collections Namespace | Add


Dictionary.Synchronized

Returns a synchronized (thread-safe) wrapper for the Dictionary.

[Visual Basic]
Public Shared Function Synchronized( _
   ByVal table As Dictionary _
) As Dictionary
[C#]
public static Dictionary Synchronized(
   Dictionary table
);
[C++]
public: static Dictionary* Synchronized(
   Dictionary* table
);
[JScript]
public static function Synchronized(
   table : Dictionary
) : Dictionary;

Parameters

table
The Dictionary to synchronize.

Return Value

A synchronized (thread-safe) wrapper for the Dictionary.

Exceptions

Exception Type | Condition
ArgumentNullException | table is a null reference (in Visual Basic Nothing).

Remarks

To guarantee the thread-safety of the Dictionary, all operations must be done through this wrapper only.

See Also

Dictionary Class | Dictionary Members | System.Collections Namespace | IsSynchronized | SyncRoot


DictionaryEntry Structure

Defines a dictionary key-and-value pair that can be set or retrieved.

Object
ValueType
DictionaryEntry

[Visual Basic]
Public Structure DictionaryEntry
[C#]
public struct DictionaryEntry
[C++]
public __value struct DictionaryEntry

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

The Entry method returns an instance of this class.

Requirements

Namespace: System.Collections

Assembly: mscorlib.dll

See Also

DictionaryEntry Members | System.Collections Namespace | IDictionary | IDictionaryEnumerator


DictionaryEntry Members

Public:

Constructor

DictionaryEntry Constructor Initializes an instance of the DictionaryEntry class.

Methods

Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Fields

Key | Retrieves the object defined in each key-and-value pair.
Value | Retrieves the definition associated with a key.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DictionaryEntry Structure | System.Collections Namespace


DictionaryEntry Constructor

Initializes an instance of the DictionaryEntry class.

[Visual Basic]
Public Sub New( _
   ByVal key As Object, _
   ByVal value As Object _
)
[C#]
public DictionaryEntry(
   object key,
   object value
);
[C++]
public: DictionaryEntry(
   Object* key,
   Object* value
);
[JScript]
public function DictionaryEntry(
   key : Object,
   value : Object
);

Parameters

key
The object defined in each key-and-value pair.
value
The definition associated with key.

See Also

DictionaryEntry Structure | DictionaryEntry Members | System.Collections Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DictionaryEntry Fields

The fields of the DictionaryEntry structure are listed below. For a complete list of DictionaryEntry structure members, see the DictionaryEntry Members topic.

Public:

Key | Retrieves the object defined in each key-and-value pair.
Value | Retrieves the definition associated with a key.

See Also

DictionaryEntry Structure | System.Collections Namespace


DictionaryEntry.Key

Retrieves the object defined in each key-and-value pair.

[Visual Basic]
Public Key As Object
[C#]
public object Key;
[C++]
public: Object* Key;
[JScript]
public var Key : Object;

See Also

DictionaryEntry Structure | DictionaryEntry Members | System.Collections Namespace


DictionaryEntry.Value

Retrieves the definition associated with a key.

[Visual Basic]
Public Value As Object
[C#]
public object Value;
[C++]
public: Object* Value;
[JScript]
public var Value : Object;

See Also

DictionaryEntry Structure | DictionaryEntry Members | System.Collections Namespace


Hashtable Class

Represents a collection of associated keys and values that are organized based on the hash code of the key.

Object
Hashtable

[Visual Basic]
Public Class Hashtable
   Implements IDictionary, ICollection, IEnumerable, ISerializable, _
   IDeserializationEventListener, ICloneable
[C#]
public class Hashtable : IDictionary, ICollection, IEnumerable,
   ISerializable, IDeserializationEventListener, ICloneable
[C++]
public __gc class Hashtable : public IDictionary, ICollection,
   IEnumerable, ISerializable, IDeserializationEventListener,
   ICloneable
[JScript]
public class Hashtable implements IDictionary, ICollection,
   IEnumerable, ISerializable, IDeserializationEventListener,
   ICloneable

Remarks

The objects used as keys in a Hashtable must implement or inherit the GetHashCode and Equals methods. If key equality is simply reference equality, the inherited implementation of these methods would suffice. Furthermore, these methods must produce the same results when called with the same parameters while the key exists in the Hashtable. Key objects must be immutable, as long as they are used as keys in the Hashtable.

When an entry is added to the Hashtable, the entry is placed into a bucket based on the hashcode of the key. Subsequent lookups of the key will use the hashcode of the key to search only in one particular bucket, thus substantially reducing the number of key comparisons required to find an entry.

A Hashtable 's maximum load factor determines the maximum ratio of entries to buckets. Smaller load factors cause faster average lookup times at the cost of increased memory consumption. The default maximum load factor of 1.0 generally provides the best balance between speed and size. A different maximum load factor can also be specified when the Hashtable is instantiated.

As entries are added to a Hashtable, the Hashtable 's actual load factor increases. When the actual load factor reaches the maximum load factor, the number of buckets in the Hashtable is automatically increased to the smallest prime number that is larger than twice the current number of Hashtable buckets.

Each key object in the Hashtable must provide its own hash function, which can be accessed by calling GetHash. However, any object implementing IHashCodeProvider can be passed to a Hashtable constructor, and that hash function would be used for all objects in the table.

Requirements

Namespace: System.Collections

Assembly: mscorlib.dll

See Also

Hashtable Members | System.Collections Namespace | IDictionary | Dictionary | IHashCodeProvider | GetHashCode | Equals


Hashtable Members

Public:

Constructor

Hashtable Constructor Overloaded. Initializes a new instance of the Hashtable class.

Properties

Count | Gets the number of key-and-value pairs in the Hashtable.
IsReadOnly | Gets a value indicating whether the Hashtable is read-only.
IsSynchronized | Gets a value indicating whether access to the Hashtable is synchronized (thread-safe).
Item | Gets or sets the value associated with the specified key. In C#, this member is the indexer for the Hashtable class.
Keys | Gets an ICollection containing the keys in the Hashtable.
SyncRoot | Gets an object that can be used to synchronize access to the Hashtable.
Values | Gets an ICollection containing the values in the Hashtable.

Methods

Add | Adds an entry with the specified key and value into the Hashtable.
Clear | Removes all entries from the Hashtable.
Clone | Creates a shallow copy of the Hashtable.
Contains | Determines if the Hashtable contains a specific key.
ContainsKey | Determines if the Hashtable contains a specific key.
ContainsValue | Determines if the Hashtable contains a specific value.
CopyTo | Copies the Hashtable values into a one-dimensional Array instance at the specified index.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Returns an enumerator which can be used to iterate through the Hashtable.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Hashtable.
GetType (inherited from Object) | Gets the Type of the Object.
OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove | Removes the entry with the specified key from the Hashtable.
Synchronized | Returns a synchronized (thread-safe) wrapper for the Hashtable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetHash | Returns the hash code for the specified key.
KeyEquals | Compares a specific Object with a specific key in the Hashtable.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

comparer | Represents the comparer to use for the Hashtable.
hcp | Represents the object that can dispense hash codes.

See Also

Hashtable Class | System.Collections Namespace


Hashtable Constructor

Initializes a new instance of the Hashtable class.

Overload List

Creates a new Hashtable with the default initial capacity and the default maximum load factor, using the default hash code provider and the default comparer.

[Visual Basic] Overloads Public Sub New()
[C#] public Hashtable();
[C++] public: Hashtable();
[JScript] public function Hashtable();

Creates a new Hashtable with the specified initial capacity and the default load factor, using the default hash code provider and the default comparer.

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public Hashtable(int);
[C++] public: Hashtable(int);
[JScript] public function Hashtable(int);

Creates a new Hashtable with the specified initial capacity and load factor, using the default hash code provider and the default comparer.

[Visual Basic] Overloads Public Sub New(Integer, Single)
[C#] public Hashtable(int, float);
[C++] public: Hashtable(int, float);
[JScript] public function Hashtable(int, float);

Creates a new Hashtable with the specified initial capacity and load factor, using the specified hash code provider and the specified comparer.

[Visual Basic] Overloads Public Sub New(Integer, Single, IHashCodeProvider, IComparer)
[C#] public Hashtable(int, float, IHashCodeProvider, IComparer);
[C++] public: Hashtable(int, float, IHashCodeProvider, IComparer);
[JScript] public function Hashtable(int, float, IHashCodeProvider, IComparer);

Creates a new Hashtable with the default initial capacity and the default maximum load factor, using the specified hash code provider and the specified comparer.

[Visual Basic] Overloads Public Sub New(IHashCodeProvider, IComparer)
[C#] public Hashtable(IHashCodeProvider, IComparer);
[C++] public: Hashtable(IHashCodeProvider*, IComparer);
[JScript] public function Hashtable(IHashCodeProvider, IComparer);

Creates a new Hashtable with the specified initial capacity and the default load factor, using the specified hash code provider and the specified comparer.

[Visual Basic] Overloads Public Sub New(Integer, IHashCodeProvider, IComparer)
[C#] public Hashtable(int, IHashCodeProvider, IComparer);
[C++] public: Hashtable(int, IHashCodeProvider, IComparer);
[JScript] public function Hashtable(int, IHashCodeProvider, IComparer);

Copies the entries in the specified dictionary into a new Hashtable with the default load factor, using the default hash code provider and the default comparer.

[Visual Basic] Overloads Public Sub New(IDictionary)
[C#] public Hashtable(IDictionary);
[C++] public: Hashtable(IDictionary*);
[JScript] public function Hashtable(IDictionary);

Copies the entries in the specified dictionary into a new Hashtable with the specified load factor, using the default hash code provider and the default comparer.

[Visual Basic] Overloads Public Sub New(IDictionary, Single)
[C#] public Hashtable(IDictionary, float);
[C++] public: Hashtable(IDictionary*, float);
[JScript] public function Hashtable(IDictionary, float);

Copies the entries in the specified dictionary into a new Hashtable with the default load factor, using the specified hash code provider and the specified comparer.

[Visual Basic] Overloads Public Sub New(IDictionary, IHashCodeProvider, IComparer)
[C#] public Hashtable(IDictionary, IHashCodeProvider, IComparer);
[C++] public: Hashtable(IDictionary*, IHashCodeProvider, IComparer);
[JScript] public function Hashtable(IDictionary, IHashCodeProvider, IComparer);

Copies the entries in the specified dictionary into a new Hashtable with the specified load factor, using the specified hash code provider and the specified comparer.

[Visual Basic] Overloads Public Sub New(IDictionary, Single, IHashCodeProvider, IComparer)
[C#] public Hashtable(IDictionary, float, IHashCodeProvider, IComparer);
[C++] public: Hashtable(IDictionary*, float, IHashCodeProvider, IComparer);
[JScript] public function Hashtable(IDictionary, float, IHashCodeProvider, IComparer);

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace


Hashtable Constructor ()

Creates a new Hashtable with the default initial capacity and the default maximum load factor, using the default hash code provider and the default comparer.

[Visual Basic]
Overloads Public Sub New()
[C#]
public Hashtable();
[C++]
public: Hashtable();
[JScript]
public function Hashtable();

Remarks

A hashtable's capacity is the number of key-and-value pairs it can contain. The default initial capacity is zero. Capacity is increased as the number of buckets is increased based on the load factor.

The maximum load factor is the maximum ratio of entries to buckets. A smaller load factor means faster lookup at the cost of increased memory consumption. The default maximum load factor is 1.0, which is the best balance between speed and size.

When the actual load factor reaches the maximum load factor, the number of buckets is automatically increased to the smallest prime number that is larger than twice the current number of buckets.

The hash code provider dispenses hash codes for keys in the Hashtable. The default hash code provider is the key's implementation of GetHashCode.

The comparer is used to determine if two keys are equal. Every key in a Hashtable must be unique. The default comparer is the key's implementation of Equals.

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace | Hashtable Constructor Overload List | GetHashCode | Equals


Hashtable Constructor (Int32)

Creates a new Hashtable with the specified initial capacity and the default load factor, using the default hash code provider and the default comparer.

[Visual Basic]
Overloads Public Sub New( _
   ByVal capacity As Integer _
)
[C#]
public Hashtable(
   int capacity
);
[C++]
public: Hashtable(
   int capacity
);
[JScript]
public function Hashtable(
   capacity : int
);

Parameters

capacity
The initial number of entries that the Hashtable can contain.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | capacity is less than zero.

Remarks

Specifying the initial capacity eliminates a number of resizing operations that would otherwise be performed while adding entries to the Hashtable. Capacity is increased as the number of buckets is increased based on the load factor.

The maximum load factor is the maximum ratio of entries to buckets. A smaller load factor means faster lookup at the cost of increased memory consumption. The default maximum load factor is 1.0, which is the best balance between speed and size.

When the actual load factor reaches the maximum load factor, the number of buckets is automatically increased to the smallest prime number that is larger than twice the current number of buckets.

The hash code provider dispenses hash codes for keys in the Hashtable. The default hash code provider is the key's implementation of GetHashCode.

The comparer is used to determine if two keys are equal. Every key in a Hashtable must be unique. The default comparer is the key's implementation of Equals.

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace | Hashtable Constructor Overload List | GetHashCode | Equals


Hashtable Constructor (Int32, Single)

Creates a new Hashtable with the specified initial capacity and load factor, using the default hash code provider and the default comparer.

[Visual Basic]
Overloads Public Sub New( _
   ByVal capacity As Integer, _
   ByVal loadFactor As Single _
)
[C#]
public Hashtable(
   int capacity,
   float loadFactor
);
[C++]
public: Hashtable(
   int capacity,
   float loadFactor
);
[JScript]
public function Hashtable(
   capacity : int,
   loadFactor : float
);

Parameters

capacity
The initial number of entries that the Hashtable can contain.
loadFactor
A number in the range from 0.1 through 1.0 indicating the maximum ratio of entries to buckets.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | capacity is less than zero. -or- loadfactor is less than 0.1. -or- loadfactor is greater than 1.0.

Remarks

Specifying the initial capacity eliminates a number of resizing operations that would otherwise be performed while adding entries to the Hashtable. Capacity is increased as the number of buckets is increased based on the load factor.

The maximum load factor is the maximum ratio of entries to buckets. A smaller load factor means faster lookup at the cost of increased memory consumption. A maximum load factor of 1.0 is the best balance between speed and size.

When the actual load factor reaches the maximum load factor, the number of buckets is automatically increased to the smallest prime number that is larger than twice the current number of buckets.

The hash code provider dispenses hash codes for keys in the Hashtable. The default hash code provider is the key's implementation of GetHashCode.

The comparer is used to determine if two keys are equal. Every key in a Hashtable must be unique. The default comparer is the key's implementation of Equals.

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace | Hashtable Constructor Overload List | GetHashCode | Equals


Hashtable Constructor (Int32, Single, IHashCodeProvider, IComparer)

Creates a new Hashtable with the specified initial capacity and load factor, using the specified hash code provider and the specified comparer.

[Visual Basic]
Overloads Public Sub New( _
   ByVal capacity As Integer, _
   ByVal loadFactor As Single, _
   ByVal hcp As IHashCodeProvider, _
   ByVal comparer As IComparer _
)
[C#]
public Hashtable(
   int capacity,
   float loadFactor,
   IHashCodeProvider hcp,
   IComparer comparer
);
[C++]
public: Hashtable(
   int capacity,
   float loadFactor,
   IHashCodeProvider* hcp,
   IComparer* comparer
);
[JScript]
public function Hashtable(
   capacity : int,
   loadFactor : float,
   hcp : IHashCodeProvider,
   comparer : IComparer
);

Parameters

capacity
The initial number of entries that the Hashtable can contain.
loadFactor
A number in the range from 0.1 through 1.0 indicating the maximum ratio of entries to buckets.
hcp
The IHashCodeProvider that will supply the hash codes for all keys in the Hashtable.

-or-

a null reference (in Visual Basic Nothing) to use the default hash code provider, which is each key's implementation of GetHashCode.

comparer
The IComparer to use to determine whether two keys are equal.

-or-

a null reference (Nothing) to use the default comparer, which is each key's implementation of Equals.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | capacity is less than zero. -or- loadfactor is less than 0.1. -or- loadfactor is greater than 1.0.

Remarks

Specifying the initial capacity eliminates a number of resizing operations that would otherwise be performed while adding entries to the Hashtable. Capacity is increased as the number of buckets is increased based on the load factor.

The maximum load factor is the maximum ratio of entries to buckets. A smaller load factor means faster lookup at the cost of increased memory consumption. A maximum load factor of 1.0 is the best balance between speed and size.

When the actual load factor reaches the maximum load factor, the number of buckets is automatically increased to the smallest prime number that is larger than twice the current number of buckets.

The hash code provider dispenses hash codes for keys in the Hashtable. The default hash code provider is the key's implementation of GetHashCode.

The comparer is used to determine if two keys are equal. Every key in a Hashtable must be unique. The default comparer is the key's implementation of Equals.

The custom hash code provider and the custom comparer enables scenarios such as doing lookups with case-insensitive strings.

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace | Hashtable Constructor Overload List | IHashCodeProvider | IComparer | GetHashCode | Equals


Hashtable Constructor (IHashCodeProvider, IComparer)

Creates a new Hashtable with the default initial capacity and the default maximum load factor, using the specified hash code provider and the specified comparer.

[Visual Basic]
Overloads Public Sub New( _
   ByVal hcp As IHashCodeProvider, _
   ByVal comparer As IComparer _
)
[C#]
public Hashtable(
   IHashCodeProvider hcp,
   IComparer comparer
);
[C++]
public: Hashtable(
   IHashCodeProvider* hcp,
   IComparer* comparer
);
[JScript]
public function Hashtable(
   hcp : IHashCodeProvider,
   comparer : IComparer
);

Parameters

hcp
The IHashCodeProvider that will supply the hash codes for all keys in the Hashtable.

-or-

a null reference (in Visual Basic Nothing) to use the default hash code provider, which is each key's implementation of GetHashCode.

comparer
The IComparer to use to determine whether two keys are equal.

-or-

a null reference (Nothing) to use the default comparer, which is each key's implementation of Equals.

Remarks

A hashtable's capacity is the number of key-and-value pairs it can contain. The default initial capacity is zero. Capacity is increased as the number of buckets is increased based on the load factor.

The maximum load factor is the maximum ratio of entries to buckets. A smaller load factor means faster lookup at the cost of increased memory consumption. The default maximum load factor is 1.0, which is the best balance between speed and size.

When the actual load factor reaches the maximum load factor, the number of buckets is automatically increased to the smallest prime number that is larger than twice the current number of buckets.

The hash code provider dispenses hash codes for keys in the Hashtable. The default hash code provider is the key's implementation of GetHashCode.

The comparer is used to determine if two keys are equal. Every key in a Hashtable must be unique. The default comparer is the key's implementation of Equals.

The custom hash code provider and the custom comparer enables scenarios such as doing lookups with case-insensitive strings.

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace | Hashtable Constructor Overload List | IHashCodeProvider | IComparer | GetHashCode | Equals


Hashtable Constructor (Int32, IHashCodeProvider, IComparer)

Creates a new Hashtable with the specified initial capacity and the default load factor, using the specified hash code provider and the specified comparer.

[Visual Basic]
Overloads Public Sub New( _
   ByVal capacity As Integer, _
   ByVal hcp As IHashCodeProvider, _
   ByVal comparer As IComparer _
)
[C#]
public Hashtable(
   int capacity,
   IHashCodeProvider hcp,
   IComparer comparer
);
[C++]
public: Hashtable(
   int capacity,
   IHashCodeProvider* hcp,
   IComparer* comparer
);
[JScript]
public function Hashtable(
   capacity : int,
   hcp : IHashCodeProvider,
   comparer : IComparer
);

Parameters

capacity
The initial number of entries that the Hashtable can contain.
hcp
The IHashCodeProvider that will supply the hash codes for all keys in the Hashtable.

-or-

a null reference (in Visual Basic Nothing) to use the default hash code provider, which is each key's implementation of GetHashCode.

comparer
The IComparer to use to determine whether two keys are equal.

-or-

a null reference (Nothing) to use the default comparer, which is each key's implementation of Equals.

Remarks

Specifying the initial capacity eliminates a number of resizing operations that would otherwise be performed while adding entries to the Hashtable. Capacity is increased as the number of buckets is increased based on the load factor.

The maximum load factor is the maximum ratio of entries to buckets. A smaller load factor means faster lookup at the cost of increased memory consumption. The default maximum load factor is 1.0, which is the best balance between speed and size.

When the actual load factor reaches the maximum load factor, the number of buckets is automatically increased to the smallest prime number that is larger than twice the current number of buckets.

The hash code provider dispenses hash codes for keys in the Hashtable. The default hash code provider is the key's implementation of GetHashCode.

The comparer is used to determine if two keys are equal. Every key in a Hashtable must be unique. The default comparer is the key's implementation of Equals.

The custom hash code provider and the custom comparer enables scenarios such as doing lookups with case-insensitive strings.

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace | Hashtable Constructor Overload List | IHashCodeProvider | IComparer | GetHashCode | Equals


Hashtable Constructor (IDictionary)

Copies the entries in the specified dictionary into a new Hashtable with the default load factor, using the default hash code provider and the default comparer.

[Visual Basic]
Overloads Public Sub New( _
   ByVal d As IDictionary _
)
[C#]
public Hashtable(
   IDictionary d
);
[C++]
public: Hashtable(
   IDictionary* d
);
[JScript]
public function Hashtable(
   d : IDictionary
);

Parameters

d
The IDictionary to copy into a new Hashtable.

Exceptions

Exception Type | Condition
ArgumentNullException | d is a null reference (in Visual Basic Nothing).

Remarks

The initial capacity is set to the number of entries in the source dictionary. Capacity is increased as the number of buckets is increased based on the load factor.

The maximum load factor is the maximum ratio of entries to buckets. A smaller load factor means faster lookup at the cost of increased memory consumption. The default maximum load factor is 1.0, which is the best balance between speed and size.

When the actual load factor reaches the maximum load factor, the number of buckets is automatically increased to the smallest prime number that is larger than twice the current number of buckets.

The hash code provider dispenses hash codes for keys in the Hashtable. The default hash code provider is the key's implementation of GetHashCode.

The comparer is used to determine if two keys are equal. Every key in a Hashtable must be unique. The default comparer is the key's implementation of Equals.

The elements of the new Hashtable are sorted in the same order that the IDictionary 's enumerator iterates through the IDictionary.

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace | Hashtable Constructor Overload List | IDictionary | GetHashCode | System.Object..Equals


Hashtable Constructor (IDictionary, Single)

Copies the entries in the specified dictionary into a new Hashtable with the specified load factor, using the default hash code provider and the default comparer.

[Visual Basic]
Overloads Public Sub New( _
   ByVal d As IDictionary, _
   ByVal loadFactor As Single _
)
[C#]
public Hashtable(
   IDictionary d,
   float loadFactor
);
[C++]
public: Hashtable(
   IDictionary* d,
   float loadFactor
);
[JScript]
public function Hashtable(
   d : IDictionary,
   loadFactor : float
);

Parameters

d
The IDictionary to copy into a new Hashtable.
loadFactor
A number in the range from 0.1 through 1.0 indicating the maximum ratio of entries to buckets.

Exceptions

Exception Type | Condition
ArgumentNullException | d is a null reference (in Visual Basic Nothing).
ArgumentOutOfRangeException | loadfactor is less than 0.1. -or- loadfactor is greater than 1.0.

Remarks

The initial capacity is set to the number of entries in the source dictionary. Capacity is increased as the number of buckets is increased based on the load factor.

The maximum load factor is the maximum ratio of entries to buckets. A smaller load factor means faster lookup at the cost of increased memory consumption. A maximum load factor of 1.0 is the best balance between speed and size.

When the actual load factor reaches the maximum load factor, the number of buckets is automatically increased to the smallest prime number that is larger than twice the current number of buckets.

The hash code provider dispenses hash codes for keys in the Hashtable. The default hash code provider is the key's implementation of GetHashCode.

The comparer is used to determine if two keys are equal. Every key in a Hashtable must be unique. The default comparer is the key's implementation of Equals.

The elements of the new Hashtable are sorted in the same order that the IDictionary 's enumerator iterates through the IDictionary.

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace | Hashtable Constructor Overload List | IDictionary | GetHashCode | System.Object..Equals


Hashtable Constructor (IDictionary, IHashCodeProvider, IComparer)

Copies the entries in the specified dictionary into a new Hashtable with the default load factor, using the specified hash code provider and the specified comparer.

[Visual Basic]
Overloads Public Sub New( _
   ByVal d As IDictionary, _
   ByVal hcp As IHashCodeProvider, _
   ByVal comparer As IComparer _
)
[C#]
public Hashtable(
   IDictionary d,
   IHashCodeProvider hcp,
   IComparer comparer
);
[C++]
public: Hashtable(
   IDictionary* d,
   IHashCodeProvider* hcp,
   IComparer* comparer
);
[JScript]
public function Hashtable(
   d : IDictionary,
   hcp : IHashCodeProvider,
   comparer : IComparer
);

Parameters

d
The IDictionary to copy into a new Hashtable.
hcp
The IHashCodeProvider that will supply the hash codes for all keys in the Hashtable.

-or-

a null reference (in Visual Basic Nothing) to use the default hash code provider, which is each key's implementation of GetHashCode.

comparer
The IComparer to use to determine whether two keys are equal.

-or-

a null reference (Nothing) to use the default comparer, which is each key's implementation of Equals.

Exceptions

Exception Type | Condition
ArgumentNullException | d is a null reference (Nothing).

Remarks

The initial capacity is set to the number of entries in the source dictionary. Capacity is increased as the number of buckets is increased based on the load factor.

The maximum load factor is the maximum ratio of entries to buckets. A smaller load factor means faster lookup at the cost of increased memory consumption. The default maximum load factor is 1.0, which is the best balance between speed and size.

When the actual load factor reaches the maximum load factor, the number of buckets is automatically increased to the smallest prime number that is larger than twice the current number of buckets.

The hash code provider dispenses hash codes for keys in the Hashtable. The default hash code provider is the key's implementation of GetHashCode.

The comparer is used to determine if two keys are equal. Every key in a Hashtable must be unique. The default comparer is the key's implementation of Equals.The custom hash code provider and the custom comparer enables scenarios such as doing lookups with case-insensitive strings.

The elements of the new Hashtable are sorted in the same order that the IDictionary 's enumerator iterates through the IDictionary.

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace | Hashtable Constructor Overload List | IDictionary | IHashCodeProvider | IComparer | GetHashCode | Equals


Hashtable Constructor (IDictionary, Single, IHashCodeProvider, IComparer)

Copies the entries in the specified dictionary into a new Hashtable with the specified load factor, using the specified hash code provider and the specified comparer.

[Visual Basic]
Overloads Public Sub New( _
   ByVal d As IDictionary, _
   ByVal loadFactor As Single, _
   ByVal hcp As IHashCodeProvider, _
   ByVal comparer As IComparer _
)
[C#]
public Hashtable(
   IDictionary d,
   float loadFactor,
   IHashCodeProvider hcp,
   IComparer comparer
);
[C++]
public: Hashtable(
   IDictionary* d,
   float loadFactor,
   IHashCodeProvider* hcp,
   IComparer* comparer
);
[JScript]
public function Hashtable(
   d : IDictionary,
   loadFactor : float,
   hcp : IHashCodeProvider,
   comparer : IComparer
);

Parameters

d
The IDictionary to copy into a new Hashtable.
loadFactor
A number in the range from 0.1 through 1.0 indicating the maximum ratio of entries to buckets.
hcp
The IHashCodeProvider that will supply the hash codes for all keys in the Hashtable.

-or-

a null reference (in Visual Basic Nothing) to use the default hash code provider, which is each key's implementation of GetHashCode.

comparer
The IComparer to use to determine whether two keys are equal.

-or-

a null reference (Nothing) to use the default comparer, which is each key's implementation of Equals.

Exceptions

Exception Type | Condition
ArgumentNullException | d is a null reference (Nothing).
ArgumentOutOfRangeException | loadfactor is less than 0.1. -or- loadfactor is greater than 1.0.

Remarks

The initial capacity is set to the number of entries in the source dictionary. Capacity is increased as the number of buckets is increased based on the load factor.

The maximum load factor is the maximum ratio of entries to buckets. A smaller load factor means faster lookup at the cost of increased memory consumption. A maximum load factor of 1.0 is the best balance between speed and size.

When the actual load factor reaches the maximum load factor, the number of buckets is automatically increased to the smallest prime number that is larger than twice the current number of buckets.

The hash code provider dispenses hash codes for keys in the Hashtable. The default hash code provider is the key's implementation of GetHashCode.

The comparer is used to determine if two keys are equal. Every key in a Hashtable must be unique. The default comparer is the key's implementation of Equals.The custom hash code provider and the custom comparer enables scenarios such as doing lookups with case-insensitive strings.

The elements of the new Hashtable are sorted in the same order that the IDictionary 's enumerator iterates through the IDictionary.

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace | Hashtable Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Hashtable Properties

The properties of the Hashtable class are listed below. For a complete list of Hashtable class members, see the Hashtable Members topic.

Public:

Count | Gets the number of key-and-value pairs in the Hashtable.
IsReadOnly | Gets a value indicating whether the Hashtable is read-only.
IsSynchronized | Gets a value indicating whether access to the Hashtable is synchronized (thread-safe).
Item | Gets or sets the value associated with the specified key. In C#, this member is the indexer for the Hashtable class.
Keys | Gets an ICollection containing the keys in the Hashtable.
SyncRoot | Gets an object that can be used to synchronize access to the Hashtable.
Values | Gets an ICollection containing the values in the Hashtable.

See Also

Hashtable Class | System.Collections Namespace


Hashtable.Count

Gets the number of key-and-value pairs in the Hashtable.

[Visual Basic]
Overridable Public ReadOnly Property Count As Integer
[C#]
public int Count {virtual get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;

Property Value

The number of key-and-value pairs in the Hashtable.

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace


Hashtable.IsReadOnly

Gets a value indicating whether the Hashtable is read-only.

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {virtual get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;

Property Value

true if the Hashtable is read-only; otherwise, false.

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace


Hashtable.IsSynchronized

Gets a value indicating whether access to the Hashtable is synchronized (thread-safe).

[Visual Basic]
Overridable Public ReadOnly Property IsSynchronized As Boolean
[C#]
public bool IsSynchronized {virtual get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;

Property Value

true if access to the Hashtable is synchronized (thread-safe); otherwise, false.

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace | Synchronized | SyncRoot


Hashtable.Item

Gets or sets the value associated with the specified key.

[C#] In C#, this member is the indexer for the Hashtable class.

[Visual Basic]
Overridable Public Default Property Item( _
   ByVal key As Object _
) As Object
[C#]
public object this[
   object key
] {virtual get; virtual set;}
[C++]
public: __property virtual Object* get_Item(
   Object* key
);
public: __property virtual void set_Item(
   Object* key,
   Object*
);
[JScript]
returnValue = HashtableObject.Item(key);
HashtableObject.Item(key) = returnValue;
-or-
returnValue = HashtableObject(key);
HashtableObject(key) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

key
The key whose value to get or set.

Parameters [Visual Basic, C#, C++]

key
The key whose value to get or set.

Property Value

The value associated with the specified key. If the specified key is not found, Get returns a null reference (in Visual Basic Nothing), and Set creates a new entry with the specified key.

Exceptions

Exception Type | Condition
ArgumentNullException | key is a null reference (Nothing).
NotSupportedException | The Hashtable is read-only and Set is attempted.

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace


Hashtable.Keys

Gets an ICollection containing the keys in the Hashtable.

[Visual Basic]
Overridable Public ReadOnly Property Keys As ICollection
[C#]
public ICollection Keys {virtual get;}
[C++]
public: __property virtual ICollection* get_Keys();
[JScript]
public function get Keys() : ICollection;

Property Value

An ICollection containing the keys in the Hashtable.

Remarks

The order of the keys in the ICollection is unspecified, but it is the same order as the associated values in the ICollection returned by the Values method.

Changes to the Hashtable will continue to be reflected in the returned ICollection. It is not a static copy.

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace | ICollection | Values


Hashtable.SyncRoot

Gets an object that can be used to synchronize access to the Hashtable.

[Visual Basic]
Overridable Public ReadOnly Property SyncRoot As Object
[C#]
public object SyncRoot {virtual get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;

Property Value

An object that can be used to synchronize access to the Hashtable.

Remarks

The root object for a Hashtable is used when performing synchronized operations on the Hashtable. Instead of synchronizing directly on a Hashtable, program code should always synchronize on the root of the Hashtable. This ensures proper operation of hashtables that are derived from other objects; proper synchronization is maintained with other threads that might be simultaneously modifying the Hashtable object.

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace | IsSynchronized | Synchronized


Hashtable.Values

Gets an ICollection containing the values in the Hashtable.

[Visual Basic]
Overridable Public ReadOnly Property Values As ICollection
[C#]
public ICollection Values {virtual get;}
[C++]
public: __property virtual ICollection* get_Values();
[JScript]
public function get Values() : ICollection;

Property Value

An ICollection containing the values in the Hashtable.

Remarks

The order of the values in the ICollection is unspecified, but it is the same order as the associated keys in the ICollection returned by the Keys method.

Changes to the Hashtable will continue to be reflected in the returned ICollection. It is not a static copy.

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace | ICollection | Keys


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Hashtable Methods

The methods of the Hashtable class are listed below. For a complete list of Hashtable class members, see the Hashtable Members topic.

Public:

Add | Adds an entry with the specified key and value into the Hashtable.
Clear | Removes all entries from the Hashtable.
Clone | Creates a shallow copy of the Hashtable.
Contains | Determines if the Hashtable contains a specific key.
ContainsKey | Determines if the Hashtable contains a specific key.
ContainsValue | Determines if the Hashtable contains a specific value.
CopyTo | Copies the Hashtable values into a one-dimensional Array instance at the specified index.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Returns an enumerator which can be used to iterate through the Hashtable.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Hashtable.
GetType (inherited from Object) | Gets the Type of the Object.
OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove | Removes the entry with the specified key from the Hashtable.
Synchronized | Returns a synchronized (thread-safe) wrapper for the Hashtable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetHash | Returns the hash code for the specified key.
KeyEquals | Compares a specific Object with a specific key in the Hashtable.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Hashtable Class | System.Collections Namespace


Hashtable.Add

Adds an entry with the specified key and value into the Hashtable.

[Visual Basic]
Overridable Public Sub Add( _
   ByVal key As Object, _
   ByVal value As Object _
)
[C#]
public virtual void Add(
   object key,
   object value
);
[C++]
public: virtual void Add(
   Object* key,
   Object* value
);
[JScript]
public function Add(
   key : Object,
   value : Object
);

Parameters

key
The key of the entry to add.
value
The value of the entry to add.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | key is a null reference (in Visual Basic Nothing).
ArgumentException | An entry with the same key already exists in the Hashtable.
NotSupportedException | The Hashtable is read-only.

Remarks

This method overrides the Add method of the Dictionary class and can itself be overridden by a derived class.

An object that has no correlation between its state and its hash code value should typically not be used as the key. For example, String objects are better than StringBuilder objects for use as keys.

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace | Remove | Add


Hashtable.Clear

Removes all entries from the Hashtable.

[Visual Basic]
Overridable Public Sub Clear()
[C#]
public virtual void Clear();
[C++]
public: virtual void Clear();
[JScript]
public function Clear();

Return Value

None.

Exceptions

Exception Type | Condition
NotSupportedException | The Hashtable is read-only.

Remarks

This method overrides the Clear method of the Dictionary class and can itself be overridden by a derived class.

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace | Clear


Hashtable.Clone

Creates a shallow copy of the Hashtable.

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

Return Value

A shallow copy of the Hashtable.

Remarks

This method can be overridden by a derived class.

A shallow copy of an object is a copy of the object only. If the object contains references to other objects, the shallow copy will not create copies of the referred objects, but will refer to the original objects instead. On the other hand, a deep copy of an object creates a copy of the object and a copy of everything directly or indirectly referenced by that object.

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace | CopyTo


Hashtable.Contains

Determines if the Hashtable contains a specific key.

[Visual Basic]
Overridable Public Function Contains( _
   ByVal key As Object _
) As Boolean
[C#]
public virtual bool Contains(
   object key
);
[C++]
public: virtual bool Contains(
   Object* key
);
[JScript]
public function Contains(
   key : Object
) : Boolean;

Parameters

key
The key to locate in the Hashtable.

Return Value

true if the Hashtable contains an entry with the specified key; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentNullException | key is a null reference (in Visual Basic Nothing).

Remarks

This method can be overridden by a derived class.

This implementation is an O(1) operation.

This method implements the IDictionary interface. It behaves exactly as ContainsKey.

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace | ContainsKey | IDictionary


Hashtable.ContainsKey

Determines if the Hashtable contains a specific key.

[Visual Basic]
Overridable Public Function ContainsKey( _
   ByVal key As Object _
) As Boolean
[C#]
public virtual bool ContainsKey(
   object key
);
[C++]
public: virtual bool ContainsKey(
   Object* key
);
[JScript]
public function ContainsKey(
   key : Object
) : Boolean;

Parameters

key
The key to locate in the Hashtable.

Return Value

true if the Hashtable contains an entry with the specified key; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentNullException | key is a null reference (in Visual Basic Nothing).

Remarks

This method can be overridden by a derived class.

This implementation is an O(1) operation.

This method behaves exactly as Contains.

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace | Contains | ContainsValue


Hashtable.ContainsValue

Determines if the Hashtable contains a specific value.

[Visual Basic]
Overridable Public Function ContainsValue( _
   ByVal value As Object _
) As Boolean
[C#]
public virtual bool ContainsValue(
   object value
);
[C++]
public: virtual bool ContainsValue(
   Object* value
);
[JScript]
public function ContainsValue(
   value : Object
) : Boolean;

Parameters

value
The value to locate in the Hashtable.

Return Value

true if the Hashtable contains an element with the specified value; otherwise, false.

Remarks

This method can be overridden by a derived class.

The values of the elements of the Hashtable are compared to the specified value using the Equals method.

This method uses a linear search; therefore, the average execution time is proportional to the size of the Hashtable. That is, this implementation is an O(n) operation.

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace | ContainsKey | Equals


Hashtable.CopyTo

Copies the Hashtable values into a one-dimensional Array instance at the specified index.

[Visual Basic]
Overridable Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal arrayIndex As Integer _
)
[C#]
public virtual void CopyTo(
   Array array,
   int arrayIndex
);
[C++]
public: virtual void CopyTo(
   Array* array,
   int arrayIndex
);
[JScript]
public function CopyTo(
   array : Array,
   arrayIndex : int
);

Parameters

array
The one-dimensional Array to contain the Hashtable values.
arrayIndex
The index in array at which to start copying.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentException | array is multidimensional. -or- The number of elements in the Hashtable is greater than the available space between arrayIndex and the end of array.
ArgumentNullException | array is a null reference (in Visual Basic Nothing).
ArgumentOutOfRangeException | arrayIndex is less than array 's lowbound.

Remarks

This method can be overridden by a derived class. CopyTo only copies the values in the Hashtable, not the keys.

The elements copied to the Array are sorted in the same order that the Hashtable 's enumerator iterates through the Hashtable.

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace | Array | GetEnumerator


Hashtable.GetEnumerator

Returns an enumerator which can be used to iterate through the Hashtable.

[Visual Basic]
Overridable Public Function GetEnumerator() As IDictionaryEnumerator
[C#]
public virtual IDictionaryEnumerator GetEnumerator();
[C++]
public: virtual IDictionaryEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IDictionaryEnumerator;

Return Value

An IDictionaryEnumerator for the Hashtable.

Remarks

This method can be overridden by a derived class.

The enumerator does not have exclusive access to the Hashtable; therefore, any changes made to the Hashtable may cause Current or MoveNext to throw an exception.

Removing objects from the enumerator will remove them from the Hashtable.

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace | IDictionaryEnumerator | IEnumerator


Hashtable.GetHash

Returns the hash code for the specified key.

[Visual Basic]
Overridable Protected Function GetHash( _
   ByVal key As Object _
) As Integer
[C#]
protected virtual int GetHash(
   object key
);
[C++]
protected: virtual int GetHash(
   Object* key
);
[JScript]
protected function GetHash(
   key : Object
) : int;

Parameters

key
The Object for which a hash code is to be returned.

Return Value

The hash code for key.

Exceptions

Exception Type | Condition
ArgumentNullException | key is a null reference (in Visual Basic Nothing).

Remarks

This method can be overridden by a derived class.

If the hashtable was instantiated with a specific IHashCodeProvider implementation, this method will use that hash code provider; otherwise, it uses the GetHashCode implementation of key.

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace | GetHashCode | Object | IHashCodeProvider


Hashtable.GetObjectData

Implements the ISerializable interface and returns the data needed to serialize the Hashtable.

[Visual Basic]
Overridable Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
public: virtual void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
);
[JScript]
public function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);

Parameters

info
A SerializationInfo object containing information required to serialize the Hashtable.
context
A StreamingContext object containing the source and destination of the serialized stream associated with the Hashtable.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | info is a null reference (in Visual Basic Nothing).

Remarks

This method can be overridden by a derived class.

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace | ISerializable | SerializationInfo | StreamingContext | OnDeserialization


Hashtable.KeyEquals

Compares a specific Object with a specific key in the Hashtable.

[Visual Basic]
Overridable Protected Function KeyEquals( _
   ByVal item As Object, _
   ByVal key As Object _
) As Boolean
[C#]
protected virtual bool KeyEquals(
   object item,
   object key
);
[C++]
protected: virtual bool KeyEquals(
   Object* item,
   Object* key
);
[JScript]
protected function KeyEquals(
   item : Object,
   key : Object
) : Boolean;

Parameters

item
The Object to compare with key.
key
The key in the Hashtable to compare with item.

Return Value

true if item and key are equal; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentNullException | item is a null reference (in Visual Basic Nothing). -or- key is a null reference (Nothing).

Remarks

This method can be overridden by a derived class.

If the hashtable was instantiated with a specific IComparer implementation, this method will use that comparer; that is, Compare (item, key). Otherwise, it uses item. Equals (key).

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace | Object | Compare | Equals


Hashtable.OnDeserialization

Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.

[Visual Basic]
Overridable Public Sub OnDeserialization( _
   ByVal sender As Object, _
   ByVal dsEvent As DeserializationEvent _
)
[C#]
public virtual void OnDeserialization(
   object sender,
   DeserializationEvent dsEvent
);
[C++]
public: virtual void OnDeserialization(
   Object* sender,
   DeserializationEvent* dsEvent
);
[JScript]
public function OnDeserialization(
   sender : Object,
   dsEvent : DeserializationEvent
);

Parameters

sender
The source of the deserialization event.
dsEvent
A DeserializationEvent object that contains the event data.

Return Value

None.

Remarks

This method can be overridden by a derived class.

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace | ISerializable | DeserializationEvent | GetObjectData


Hashtable.Remove

Removes the entry with the specified key from the Hashtable.

[Visual Basic]
Overridable Public Sub Remove( _
   ByVal key As Object _
)
[C#]
public virtual void Remove(
   object key
);
[C++]
public: virtual void Remove(
   Object* key
);
[JScript]
public function Remove(
   key : Object
);

Parameters

key
The key of the entry to remove.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | key is a null reference (in Visual Basic Nothing).
NotSupportedException | The Hashtable is read-only.

Remarks

This method overrides the Remove method of the Dictionary class and can itself be overridden by a derived class.

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace | Add | Remove


Hashtable.Synchronized

Returns a synchronized (thread-safe) wrapper for the Hashtable.

[Visual Basic]
Public Shared Function Synchronized( _
   ByVal table As Hashtable _
) As Hashtable
[C#]
public static Hashtable Synchronized(
   Hashtable table
);
[C++]
public: static Hashtable* Synchronized(
   Hashtable* table
);
[JScript]
public static function Synchronized(
   table : Hashtable
) : Hashtable;

Parameters

table
The Hashtable to synchronize.

Return Value

A synchronized (thread-safe) wrapper for the Hashtable.

Exceptions

Exception Type | Condition
ArgumentNullException | table is a null reference (in Visual Basic Nothing).

Remarks

To guarantee the thread-safety of the Hashtable, all operations must be done through this wrapper only.

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace | IsSynchronized | SyncRoot


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Hashtable Fields

The fields of the Hashtable class are listed below. For a complete list of Hashtable class members, see the Hashtable Members topic.

Protected:

comparer | Represents the comparer to use for the Hashtable.
hcp | Represents the object that can dispense hash codes.

See Also

Hashtable Class | System.Collections Namespace


Hashtable.comparer

Represents the comparer to use for the Hashtable.

[Visual Basic]
Protected comparer As IComparer
[C#]
protected IComparer comparer;
[C++]
protected: IComparer* comparer;
[JScript]
protected var comparer : IComparer;

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace | IComparer


Hashtable.hcp

Represents the object that can dispense hash codes.

[Visual Basic]
Protected hcp As IHashCodeProvider
[C#]
protected IHashCodeProvider hcp;
[C++]
protected: IHashCodeProvider* hcp;
[JScript]
protected var hcp : IHashCodeProvider;

See Also

Hashtable Class | Hashtable Members | System.Collections Namespace | IHashCodeProvider


ICollection Interface

Defines size, enumerators and synchronization methods for all collections.

ICollection

[Visual Basic]
Public Interface ICollection
   Implements IEnumerable
[C#]
public interface ICollection : IEnumerable
[C++]
public __gc __interface ICollection : public IEnumerable

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement ICollection

Class | Description
ADOErrors | Collects all errors generated by the adapter.
ADOParameters | Collects all parameters relevant to an ADOCommand and their mappings to DataSet columns.
ADOProperties | [To be supplied.]
Array | Provides methods for creating, manipulating, searching, and sorting arrays. This is the base class for all arrays in the system.
ArrayList | Implements the IList interface using an array whose size is dynamically increased as required.
BaseCollection | [To be supplied.]
BaseConfigCollection | A generic implementation of the IConfigCollection interface.
BaseConfigItem | A generic implementation of the IConfigItem interface.
BindingManager | Manages the collection of ListManager objects for a Win Form.
CaptureCollection | Represents a sequence of capture substrings. The object is used to return the set of captures done by a single capturing group.
CodeAttributeArgumentCollection | Manages a collection of CodeAttributeArgument objects.
CodeAttributeDeclarationCollection | Manages a collection that stores CodeAttributeDeclaration objects.
CodeCatchClauseCollection | Manages a collection of CodeCatchClause objects.
CodeClassCollection | Manages a collection that stores CodeClass objects.
CodeClassMemberCollection | Manages a collection of CodeClassMember objects.
CodeExpressionCollection | Manages a collection of CodeExpression objects.
CodeNamespaceImportCollection | Manages a collection of CodeNamespaceImport objects.
CodeParameterDeclarationExpressionCollection | Manages a collection of CodeParameterDeclarationExpression objects
CodeStatementCollection | Manages a collection of CodeStatement objects.
ColumnCollection | Represents the collection of columns to be displayed in a DataGrid control.
ComboBox.ObjectCollection | [To be supplied.]
CompilerErrorCollection | Manages a collection of CompilerError objects.
Control.ControlCollection | Collection of controls...
ControlCollection | The ControlCollection class provides a collection container that enables a control to maintain a list of its child controls.
CounterCreationDataCollection | [To be supplied.]
DataBindingCollection | [To be supplied.]
DataColumnMappings | column mapping collection
DataGridItemCollection | [To be supplied.]
DataKeyCollection | [To be supplied.]
DataListItemCollection | [To be supplied.]
DataSetView | Represents a view of a DataSet with individual filters automatically set on each of its tables.
DataTableMappings | table mapping collection
DataView | Represents a databindable, customized view of a DataTable for sorting, filtering, searching, editing, and navigation.
Dictionary | Represents a collection of associated keys and values.
DirectoryEntryCollection | Contains the children (child entries) of an entry.
DirectoryEntryCollection.CollectionOverStringVariantProperty | Represents a collection of objects that can be individually indexed.
DirectoryEntryPropertyValueCollection | Specifies a collection of values for a multi-valued property.
DocumentCollection | Provides a read-only collection of documents.
EventDescriptorCollection | Represents a collection of events.
EventLog.EventLogEntryCollection | [To be supplied.]
Evidence Evidence is the set of information that constitutes input to security policy decisions, such as what permissions can be granted to code. Common forms of evidence include signatures and location of origin of code, but can potentially be anything.

Objects of any type that are recognized by security policy represent evidence. Security policy is composed of code groups; a particular assembly (the basic unit of code for granting security permissions) is a member of a code group if it satisfies its membership condition. Evidence is the set of inputs to policy that membership conditions use to determine what code groups an assembly belongs to.

The Evidence class is a collection (ICollection) that holds a set of objects that represent evidence. (Herein big-e Evidence refers to the class; little-e evidence to objects that represent generic evidence.) The Evidence class holds two sets: host evidence and assembly evidence, corresponding to the source of the evidence.

Policy can get evidence from two different sources in evaluating permissions for code.

Host evidence is provided by the host, and can only be provided by hosts granted the SecurityPermission.ControlEvidence permission. Typically, this is evidence of location of origin of the code and digital signatures on the assembly.

Evidence about location origin typically includes URL, Site, and Zone evidence. Signatures refer to software publisher (AuthentiCode?) and strong name identities. Both kinds of digital signature based identity are built into the assembly, but must be validated and passed to policy by the host; when loaded the security system verifies the signature and only if it is valid will the corresponding evidence be collected and passed to policy.

Assembly evidence is part of the assembly itself. Developers or administrators can attach custom evidence to the assembly to extend the set of evidence for policy. (Note that signed assemblies may not be modified, and hence cannot have additional evidence added without breaking the existing signature.)
Hashtable | Represents a collection of associated keys and values that are organized based on the hash code of the key.
HtmlTableCellCollection | The HtmlTableCellCollection contains all of the table cells, both <td> and <th> elements, found within an HtmlTable server control.
HtmlTableRowCollection | The HtmlTableRowCollection contains all of the table rows found within an HtmlTable server control.
Configuration.HttpConfigurationRecord | [To be supplied.]
HttpStaticObjectsCollection | [To be supplied.]
ImageList.ImageCollection | [To be supplied.]
InstallerCollection | Contains a collection of installers to be run during an installation.
LinkLabel.LinkCollection | [To be supplied.]
ListBox.ObjectCollection | [To be supplied.]
ListBox.SelectedIndicesCollection | [To be supplied.]
ListBox.SelectedObjectCollection | [To be supplied.]
ListItemCollection | [To be supplied.]
ListView.ColumnHeaderCollection | [To be supplied.]
ListView.ListItemCollection | [To be supplied.]
ListView.SelectedListItemCollection | [To be supplied.]
MatchCollection | Represents the set of names appearing as capturing group names in a regular expression.
MemberAttributeCollection | Represents a collection of attributes.
Menu.MenuItemCollection | [To be supplied.]
NameObjectCollectionBase | [To be supplied.]
ObjectList | [To be supplied.]
PagedDataSource | This class provides a wrapper over an ICollection datasource to implement paging semantics or 'paged views' on top of the underlying datasource. It uses the best available interface to enumerate over the data belonging to the current page. If the underlying datasource supports indexed access (like Array and IList), this wrapper uses it. Otherwise it falls back on IEnumerable.
PermissionSet | Represents a set of permissions of different types. This class supports all functionality of a permission, for the set of permissions as a whole.
PrinterSettings.PaperSizeCollection | Collection of PaperSize's...
PrinterSettings.PaperSourceCollection | Collection of PaperSource's...
PrinterSettings.PrinterResolutionCollection | Collection of PrinterResolution's...
PrinterSettings.StringCollection | Collection of String's...
PropertyDescriptorCollection | Represents a collection of properties.
Queue | Represents a first-in-first-out collection of objects.
RecurrencePatterns | Specifies a collection of recurrence patterns that describe the Schedule component's behavior when raising events.
RepeaterItemCollection | [To be supplied.]
SelectedDatesCollection | [To be supplied.]
SortedList | Represents a collection of associated keys and values, which are sorted by the keys and are accessible both by key and by index.
SQLErrors | Collects all errors generated by the SQL Server adapter.
SQLParameters | Collects all parameters relevant to a SQLCommand and their mappings to DataSet columns.
Stack | Represents a simple queue of Object.
StatusBar.StatusBarPanelCollection | [To be supplied.]
StringCollection | Collection of Strings
StringTable | Represents an unsorted set of strings.
TabControl.TabPageCollection | [To be supplied.]
TableCellCollection | [To be supplied.]
TableRowCollection | [To be supplied.]
TempFiles | Collection of temporary file names that are all based on a single base filename located in some temporary directory.
ToolBar.ToolBarButtonCollection | [To be supplied.]
TraceListeners | Provides a thread-safe list of TraceListeners. A thread-safe list is synchronized.
TreeNodeCollection | [To be supplied.]
TypeConverter.StandardValuesCollection | Represents a collection of values.
TypedCollectionBase | [To be supplied.]
TypedReadonlyCollectionBase | [To be supplied.]
ValidatorCollection | The ValidatorCollection class. Exposes a read-only array of IValidator references.

Remarks

[To be supplied.]

Requirements

Namespace: System.Collections

Assembly: mscorlib.dll

See Also

ICollection Members | System.Collections Namespace


ICollection Members

Properties

Count | When implemented by a class, retrieves the number of elements in the ICollection.
IsReadOnly | When implemented by a class, retrieves a value indicating whether the ICollection is read-only.
IsSynchronized | When implemented by a class, retrieves a value indicating whether access to the ICollection is synchronized (i.e.: thread-safe).
SyncRoot | When implemented by a class, retrieves an object that can be used to synchronize access to the ICollection.

Methods

CopyTo When implemented by a class, copies the elements of the ICollection into an Array, starting at a particular Array index.

See Also

ICollection Interface | System.Collections Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICollection Properties

The properties of the ICollection interface are listed below. For a complete list of ICollection interface members, see the ICollection Members topic.

Count | When implemented by a class, retrieves the number of elements in the ICollection.
IsReadOnly | When implemented by a class, retrieves a value indicating whether the ICollection is read-only.
IsSynchronized | When implemented by a class, retrieves a value indicating whether access to the ICollection is synchronized (i.e.: thread-safe).
SyncRoot | When implemented by a class, retrieves an object that can be used to synchronize access to the ICollection.

See Also

ICollection Interface | System.Collections Namespace


ICollection.Count

When implemented by a class, retrieves the number of elements in the ICollection.

[Visual Basic]
ReadOnly Property Count As Integer
[C#]
int Count {get;}
[C++]
int get_Count() = 0;
[JScript]
abstract function get Count() : int;

Property Value

The number of elements in the ICollection.

See Also

ICollection Interface | ICollection Members | System.Collections Namespace


ICollection.IsReadOnly

When implemented by a class, retrieves a value indicating whether the ICollection is read-only.

[Visual Basic]
ReadOnly Property IsReadOnly As Boolean
[C#]
bool IsReadOnly {get;}
[C++]
bool get_IsReadOnly() = 0;
[JScript]
abstract function get IsReadOnly() : Boolean;

Property Value

true if the ICollection is read-only; otherwise, false.

See Also

ICollection Interface | ICollection Members | System.Collections Namespace


ICollection.IsSynchronized

When implemented by a class, retrieves a value indicating whether access to the ICollection is synchronized (i.e.: thread-safe).

[Visual Basic]
ReadOnly Property IsSynchronized As Boolean
[C#]
bool IsSynchronized {get;}
[C++]
bool get_IsSynchronized() = 0;
[JScript]
abstract function get IsSynchronized() : Boolean;

Property Value

true if access to the ICollection is synchronized (i.e.: thread-safe); otherwise, false.

Remarks

SyncRoot returns an object, which can be used to synchronize access to the ICollection.

Collection classes in System.Collections also implement a GetSynchronized method, which provides a synchronized wrapper around the underlying collection.

See Also

ICollection Interface | ICollection Members | System.Collections Namespace | SyncRoot


ICollection.SyncRoot

When implemented by a class, retrieves an object that can be used to synchronize access to the ICollection.

[Visual Basic]
ReadOnly Property SyncRoot As Object
[C#]
object SyncRoot {get;}
[C++]
Object* get_SyncRoot() = 0;
[JScript]
abstract function get SyncRoot() : Object;

Property Value

An object that can be used to synchronize access to the ICollection.

Remarks

Collection classes in System.Collections also implement a GetSynchronized method, which provides a synchronized wrapper around the underlying collection.

For collections whose underlying store is not publicly available, the expected implementation is to simply return 'this'. Note that the 'this' pointer may not be sufficient for collections that wrap other collections; those should return the underlying collection's SyncRoot property.

Example

In the absence of a GetSynchronized() method on a collection, the expected usage for SyncRoot would look like this:

ICollection col = ...
synchronized (col->SyncRoot) {
 // Some operation on the collection, which is now thread safe.
}

See Also

ICollection Interface | ICollection Members | System.Collections Namespace | IsSynchronized


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICollection Methods

The methods of the ICollection interface are listed below. For a complete list of ICollection interface members, see the ICollection Members topic.

CopyTo When implemented by a class, copies the elements of the ICollection into an Array, starting at a particular Array index.

See Also

ICollection Interface | System.Collections Namespace


ICollection.CopyTo

When implemented by a class, copies the elements of the ICollection into an Array, starting at a particular Array index.

[Visual Basic]
Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
[C#]
void CopyTo(
   Array array,
   int index
);
[C++]
void CopyTo(
   Array* array,
   int index
) = 0;
[JScript]
function CopyTo(
   array : Array,
   index : int
);

Parameters

array
The Array to receive the ICollection 's elements.
index
The array index at which to start copying.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentException | The sum of index and the number of elements in the ICollection is greater than the length of array.
ArgumentNullException | array is a null reference object.
ArgumentOutOfRangeException | index is not a valid index in array.

See Also

ICollection Interface | ICollection Members | System.Collections Namespace


IComparer Interface

Exposes a method that compares two objects.

IComparer

[Visual Basic]
Public Interface IComparer
[C#]
public interface IComparer
[C++]
public __gc __interface IComparer

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IComparer

Class | Description
CaseInsensitiveComparer | [To be supplied.]
Comparer | Provides the default implementation for the IComparer interface, including the method CompareTo, which compares two objects for equivalence.
ComponentModelPersister.LocalCache.LocalCacheItemComparer | [To be supplied.]
KeysConverter | KeysConverter is a class that can be used to convert Key objects from one data type to another. Access this class through the TypeDescriptor.

Remarks

This interface is used in conjunction with the Sort and BinarySearch methods in the Array class. The default implementation of this interface is the Comparer class.

Requirements

Namespace: System.Collections

Assembly: mscorlib.dll

See Also

IComparer Members | System.Collections Namespace | Comparer


IComparer Members

Methods

Compare When implemented by a class, compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.

See Also

IComparer Interface | System.Collections Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IComparer Methods

The methods of the IComparer interface are listed below. For a complete list of IComparer interface members, see the IComparer Members topic.

Compare When implemented by a class, compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.

See Also

IComparer Interface | System.Collections Namespace


IComparer.Compare

When implemented by a class, compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.

[Visual Basic]
Function Compare( _
   ByVal x As Object, _
   ByVal y As Object _
) As Integer
[C#]
int Compare(
   object x,
   object y
);
[C++]
int Compare(
   Object* x,
   Object* y
) = 0;
[JScript]
function Compare(
   x : Object,
   y : Object
) : int;

Parameters

x
First object to compare.
y
Second object to compare.

Return Value

Value | Condition
Less than zero | x is less than y.
Zero | x equals y.
Greater than zero | x is greater than y.

Exceptions

Exception Type | Condition
ArgumentException | Neither x nor y implements the IComparable interface. -or- x and y are of different types.

Remarks

The preferred implementation is to use the CompareTo method of one of the parameters. If neither parameter implements IComparable, an exception must be thrown.

An exception must also be thrown if x and y are objects of different types and neither one can handle comparisons with the other.

a null reference (in Visual Basic Nothing) can always be compared with any other type; therefore, comparisons with a null reference (Nothing) must not generate an exception when using IComparable. When sorting, a null reference (Nothing) is considered to be less than any other object.

See Also

IComparer Interface | IComparer Members | System.Collections Namespace | IComparable


IDictionary Interface

Represents a collection of associated keys and values.

[Visual Basic]
Public Interface IDictionary
   Implements ICollection, IEnumerable
[C#]
public interface IDictionary : ICollection, IEnumerable
[C++]
public __gc __interface IDictionary : public ICollection,
   IEnumerable

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IDictionary

Class | Description
Dictionary | Represents a collection of associated keys and values.
Hashtable | Represents a collection of associated keys and values that are organized based on the hash code of the key.
Configuration.HttpConfigurationRecord | [To be supplied.]
SortedList | Represents a collection of associated keys and values, which are sorted by the keys and are accessible both by key and by index.

Remarks

The IDictionary class is an abstract base class for collections of associated keys and values.

Each association must have a unique non-null key, but the value of an association can be any object reference, including a null reference. The IDictionary interface allows the contained keys and values to be enumerated, but it does not imply any particular sort order.

Requirements

Namespace: System.Collections

Assembly: mscorlib.dll

See Also

IDictionary Members | System.Collections Namespace | Dictionary


IDictionary Members

Properties

Item | When implemented by a class, retrieves the IDictionary value with the specified key. In C#, this member is the indexer for the IDictionary class.
Keys | When implemented by a class, retrieves an ICollection containing the keys of the IDictionary.
Values | When implemented by a class, retrieves an ICollection of the values in the IDictionary.

Methods

Add | When implemented by a class, adds an entry with the provided key and value into the IDictionary.
Clear | When implemented by a class, removes all entries from the IDictionary.
Contains | When implemented by a class, determines whether the IDictionary contains an entry with the specified key.
GetEnumerator | When implemented by a class, returns an IEnumerator for the IDictionary.
Remove | When implemented by a class, removes the entry with the specified key from the IDictionary.

See Also

IDictionary Interface | System.Collections Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDictionary Properties

The properties of the IDictionary interface are listed below. For a complete list of IDictionary interface members, see the IDictionary Members topic.

Item | When implemented by a class, retrieves the IDictionary value with the specified key. In C#, this member is the indexer for the IDictionary class.
Keys | When implemented by a class, retrieves an ICollection containing the keys of the IDictionary.
Values | When implemented by a class, retrieves an ICollection of the values in the IDictionary.

See Also

IDictionary Interface | System.Collections Namespace


IDictionary.Item

When implemented by a class, retrieves the IDictionary value with the specified key.

[C#] In C#, this member is the indexer for the IDictionary class.

[Visual Basic]
Default Property Item( _
   ByVal key As Object _
) As Object
[C#]
object this[
   object key
] {get; set;}
[C++]
Object* get_Item(
   Object* key
) = 0;void set_Item(
   Object* key,
   Object*
) = 0;
[JScript]
abstract returnValue = IDictionaryObject.Item(key);
IDictionaryObject.Item(key) = returnValue;
-or-
abstract returnValue = IDictionaryObject(key);
IDictionaryObject(key) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

key
[To be supplied.]

Parameters [Visual Basic, C#, C++]

key
[To be supplied.]

See Also

IDictionary Interface | IDictionary Members | System.Collections Namespace


IDictionary.Keys

When implemented by a class, retrieves an ICollection containing the keys of the IDictionary.

[Visual Basic]
ReadOnly Property Keys As ICollection
[C#]
ICollection Keys {get;}
[C++]
ICollection* get_Keys() = 0;
[JScript]
abstract function get Keys() : ICollection;

Property Value

An ICollection containing the keys of the IDictionary.

Remarks

The order of the keys in the returned ICollection is unspecified, but it is guaranteed to be the same order as the corresponding values in the ICollection returned by the Values method.

See Also

IDictionary Interface | IDictionary Members | System.Collections Namespace | ICollection


IDictionary.Values

When implemented by a class, retrieves an ICollection of the values in the IDictionary.

[Visual Basic]
ReadOnly Property Values As ICollection
[C#]
ICollection Values {get;}
[C++]
ICollection* get_Values() = 0;
[JScript]
abstract function get Values() : ICollection;

Property Value

An ICollection of the values in the IDictionary.

Remarks

The order of the values in the returned ICollection is unspecified, but it is guaranteed to be the same order as the corresponding keys in the ICollection returned by the Keys method.

See Also

IDictionary Interface | IDictionary Members | System.Collections Namespace | ICollection


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDictionary Methods

The methods of the IDictionary interface are listed below. For a complete list of IDictionary interface members, see the IDictionary Members topic.

Add | When implemented by a class, adds an entry with the provided key and value into the IDictionary.
Clear | When implemented by a class, removes all entries from the IDictionary.
Contains | When implemented by a class, determines whether the IDictionary contains an entry with the specified key.
GetEnumerator | When implemented by a class, returns an IEnumerator for the IDictionary.
Remove | When implemented by a class, removes the entry with the specified key from the IDictionary.

See Also

IDictionary Interface | System.Collections Namespace


IDictionary.Add

When implemented by a class, adds an entry with the provided key and value into the IDictionary.

[Visual Basic]
Sub Add( _
   ByVal key As Object, _
   ByVal value As Object _
)
[C#]
void Add(
   object key,
   object value
);
[C++]
void Add(
   Object* key,
   Object* value
) = 0;
[JScript]
function Add(
   key : Object,
   value : Object
);

Parameters

key
The key of the entry to add.
value
The value of the entry to add.

Exceptions

Exception Type | Condition
ArgumentException | key is null reference object. OR, an entry with the same key already exists in the IDictionary.
NotSupportedException | The IDictionary is read-only.

See Also

IDictionary Interface | IDictionary Members | System.Collections Namespace


IDictionary.Clear

When implemented by a class, removes all entries from the IDictionary.

[Visual Basic]
Sub Clear()
[C#]
void Clear();
[C++]
void Clear() = 0;
[JScript]
function Clear();

Exceptions

Exception Type | Condition
NotSupportedException | The IDictionary is read-only.

See Also

IDictionary Interface | IDictionary Members | System.Collections Namespace


IDictionary.Contains

When implemented by a class, determines whether the IDictionary contains an entry with the specified key.

[Visual Basic]
Function Contains( _
   ByVal key As Object _
) As Boolean
[C#]
bool Contains(
   object key
);
[C++]
bool Contains(
   Object* key
) = 0;
[JScript]
function Contains(
   key : Object
) : Boolean;

Parameters

key
The key to locate in the IDictionary.

Return Value

true if the IDictionary contains an entry with the key; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentNullException | key is a null reference object.

See Also

IDictionary Interface | IDictionary Members | System.Collections Namespace


IDictionary.GetEnumerator

When implemented by a class, returns an IEnumerator for the IDictionary.

[Visual Basic]
Function GetEnumerator() As IDictionaryEnumerator
[C#]
IDictionaryEnumerator GetEnumerator();
[C++]
IDictionaryEnumerator* GetEnumerator() = 0;
[JScript]
function GetEnumerator() : IDictionaryEnumerator;

Return Value

An IEnumerator for the IDictionary.

See Also

IDictionary Interface | IDictionary Members | System.Collections Namespace | IDictionaryEnumerator | IEnumerator


IDictionary.Remove

When implemented by a class, removes the entry with the specified key from the IDictionary.

[Visual Basic]
Sub Remove( _
   ByVal key As Object _
)
[C#]
void Remove(
   object key
);
[C++]
void Remove(
   Object* key
) = 0;
[JScript]
function Remove(
   key : Object
);

Parameters

key
The key of the entry to remove.

Exceptions

Exception Type | Condition
ArgumentException | key is null.
NotSupportedException | The IDictionary is read-only.

See Also

IDictionary Interface | IDictionary Members | System.Collections Namespace


IDictionaryEnumerator Interface

Enumerates the elements of a dictionary.

IDictionaryEnumerator

[Visual Basic]
Public Interface IDictionaryEnumerator
   Implements IEnumerator
[C#]
public interface IDictionaryEnumerator : IEnumerator
[C++]
public __gc __interface IDictionaryEnumerator : public IEnumerator

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Collections

Assembly: mscorlib.dll

See Also

IDictionaryEnumerator Members | System.Collections Namespace | Dictionary | IDictionary | IEnumerator


IDictionaryEnumerator Members

Properties

Entry | When implemented by a class, retrieves both the key and the value of the current dictionary entry.
Key | When implemented by a class, retrieves the key of the current dictionary entry.
Value | When implemented by a class, retrieves the value of the current dictionary entry.

See Also

IDictionaryEnumerator Interface | System.Collections Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDictionaryEnumerator Properties

The properties of the IDictionaryEnumerator interface are listed below. For a complete list of IDictionaryEnumerator interface members, see the IDictionaryEnumerator Members topic.

Entry | When implemented by a class, retrieves both the key and the value of the current dictionary entry.
Key | When implemented by a class, retrieves the key of the current dictionary entry.
Value | When implemented by a class, retrieves the value of the current dictionary entry.

See Also

IDictionaryEnumerator Interface | System.Collections Namespace


IDictionaryEnumerator.Entry

When implemented by a class, retrieves both the key and the value of the current dictionary entry.

[Visual Basic]
ReadOnly Property Entry As DictionaryEntry
[C#]
DictionaryEntry Entry {get;}
[C++]
DictionaryEntry get_Entry() = 0;
[JScript]
abstract function get Entry() : DictionaryEntry;

See Also

IDictionaryEnumerator Interface | IDictionaryEnumerator Members | System.Collections Namespace


IDictionaryEnumerator.Key

When implemented by a class, retrieves the key of the current dictionary entry.

[Visual Basic]
ReadOnly Property Key As Object
[C#]
object Key {get;}
[C++]
Object* get_Key() = 0;
[JScript]
abstract function get Key() : Object;

Property Value

The key of the current element of the enumeration.

Exceptions

Exception Type | Condition
InvalidOperationException | The IDictionaryEnumerator is positioned before the first entry of the dictionary or after the last entry. -or- The dictionary is modified after the IDictionaryEnumerator was created.

Remarks

After an enumerator is created or after a call to Reset, MoveNext must be called to advance the enumerator to the first entry of the dictionary before calling the Key method.

Key will also throw an exception if the last call to MoveNext returned false which indicates the end of the collection.

Key does not move the position of the enumerator and multiple calls to Key will return the same object until either MoveNext or Reset is called.

See Also

IDictionaryEnumerator Interface | IDictionaryEnumerator Members | System.Collections Namespace | Reset | MoveNext | Value


IDictionaryEnumerator.Value

When implemented by a class, retrieves the value of the current dictionary entry.

[Visual Basic]
ReadOnly Property Value As Object
[C#]
object Value {get;}
[C++]
Object* get_Value() = 0;
[JScript]
abstract function get Value() : Object;

Property Value

The value of the current element of the enumeration.

Exceptions

Exception Type | Condition
InvalidOperationException | The IDictionaryEnumerator is positioned before the first entry of the dictionary or after the last entry. OR, the dictionary is modified after the IDictionaryEnumerator was created.

Remarks

After an enumerator is created or after a call to Reset, MoveNext must be called to advance the enumerator to the first entry of the dictionary before calling the Value method.

Value will also throw an exception if the last call to MoveNext returned false which indicates the end of the collection.

Value does not move the position of the enumerator and multiple calls to Value will return the same object until either MoveNext or Reset is called.

See Also

IDictionaryEnumerator Interface | IDictionaryEnumerator Members | System.Collections Namespace | Reset | MoveNext | Key


IEnumerable Interface

Exposes the enumerator, which iterates over a collection in a simple ForEach style.

IEnumerable

[Visual Basic]
Public Interface IEnumerable
[C#]
public interface IEnumerable
[C++]
public __gc __interface IEnumerable

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IEnumerable

Class | Description
ADOErrors | Collects all errors generated by the adapter.
ADOParameters | Collects all parameters relevant to an ADOCommand and their mappings to DataSet columns.
ADOProperties | [To be supplied.]
Array | Provides methods for creating, manipulating, searching, and sorting arrays. This is the base class for all arrays in the system.
ArrayList | Implements the IList interface using an array whose size is dynamically increased as required.
BaseCollection | [To be supplied.]
BaseConfigCollection | A generic implementation of the IConfigCollection interface.
BaseConfigItem | A generic implementation of the IConfigItem interface.
BindingManager | Manages the collection of ListManager objects for a Win Form.
Caching.Cache | [To be supplied.]
CaptureCollection | Represents a sequence of capture substrings. The object is used to return the set of captures done by a single capturing group.
CodeAttributeArgumentCollection | Manages a collection of CodeAttributeArgument objects.
CodeAttributeDeclarationCollection | Manages a collection that stores CodeAttributeDeclaration objects.
CodeCatchClauseCollection | Manages a collection of CodeCatchClause objects.
CodeClassCollection | Manages a collection that stores CodeClass objects.
CodeClassMemberCollection | Manages a collection of CodeClassMember objects.
CodeExpressionCollection | Manages a collection of CodeExpression objects.
CodeNamespaceImportCollection | Manages a collection of CodeNamespaceImport objects.
CodeParameterDeclarationExpressionCollection | Manages a collection of CodeParameterDeclarationExpression objects
CodeStatementCollection | Manages a collection of CodeStatement objects.
ColumnCollection | Represents the collection of columns to be displayed in a DataGrid control.
ComboBox.ObjectCollection | [To be supplied.]
CompilerErrorCollection | Manages a collection of CompilerError objects.
Control.ControlCollection | Collection of controls...
ControlCollection | The ControlCollection class provides a collection container that enables a control to maintain a list of its child controls.
CounterCreationDataCollection | [To be supplied.]
DataBindingCollection | [To be supplied.]
DataColumnMappings | column mapping collection
DataGridItemCollection | [To be supplied.]
DataKeyCollection | [To be supplied.]
DataListItemCollection | [To be supplied.]
DataSetView | Represents a view of a DataSet with individual filters automatically set on each of its tables.
DataTableMappings | table mapping collection
DataView | Represents a databindable, customized view of a DataTable for sorting, filtering, searching, editing, and navigation.
Dictionary | Represents a collection of associated keys and values.
DirectoryEntryCollection | Contains the children (child entries) of an entry.
DirectoryEntryCollection.CollectionOverStringVariantProperty | Represents a collection of objects that can be individually indexed.
DirectoryEntryPropertyValueCollection | Specifies a collection of values for a multi-valued property.
DocumentCollection | Provides a read-only collection of documents.
EventDescriptorCollection | Represents a collection of events.
EventLog.EventLogEntryCollection | [To be supplied.]
Evidence Evidence is the set of information that constitutes input to security policy decisions, such as what permissions can be granted to code. Common forms of evidence include signatures and location of origin of code, but can potentially be anything.

Objects of any type that are recognized by security policy represent evidence. Security policy is composed of code groups; a particular assembly (the basic unit of code for granting security permissions) is a member of a code group if it satisfies its membership condition. Evidence is the set of inputs to policy that membership conditions use to determine what code groups an assembly belongs to.

The Evidence class is a collection (ICollection) that holds a set of objects that represent evidence. (Herein big-e Evidence refers to the class; little-e evidence to objects that represent generic evidence.) The Evidence class holds two sets: host evidence and assembly evidence, corresponding to the source of the evidence.

Policy can get evidence from two different sources in evaluating permissions for code.

Host evidence is provided by the host, and can only be provided by hosts granted the SecurityPermission.ControlEvidence permission. Typically, this is evidence of location of origin of the code and digital signatures on the assembly.

Evidence about location origin typically includes URL, Site, and Zone evidence. Signatures refer to software publisher (AuthentiCode?) and strong name identities. Both kinds of digital signature based identity are built into the assembly, but must be validated and passed to policy by the host; when loaded the security system verifies the signature and only if it is valid will the corresponding evidence be collected and passed to policy.

Assembly evidence is part of the assembly itself. Developers or administrators can attach custom evidence to the assembly to extend the set of evidence for policy. (Note that signed assemblies may not be modified, and hence cannot have additional evidence added without breaking the existing signature.)
Hashtable | Represents a collection of associated keys and values that are organized based on the hash code of the key.
HtmlTableCellCollection | The HtmlTableCellCollection contains all of the table cells, both <td> and <th> elements, found within an HtmlTable server control.
HtmlTableRowCollection | The HtmlTableRowCollection contains all of the table rows found within an HtmlTable server control.
Configuration.HttpConfigurationRecord | [To be supplied.]
HttpStaticObjectsCollection | [To be supplied.]
ImageList.ImageCollection | [To be supplied.]
InstallerCollection | Contains a collection of installers to be run during an installation.
LinkLabel.LinkCollection | [To be supplied.]
ListBox.ObjectCollection | [To be supplied.]
ListBox.SelectedIndicesCollection | [To be supplied.]
ListBox.SelectedObjectCollection | [To be supplied.]
ListItemCollection | [To be supplied.]
ListView.ColumnHeaderCollection | [To be supplied.]
ListView.ListItemCollection | [To be supplied.]
ListView.SelectedListItemCollection | [To be supplied.]
MatchCollection | Represents the set of names appearing as capturing group names in a regular expression.
MemberAttributeCollection | Represents a collection of attributes.
Menu.MenuItemCollection | [To be supplied.]
NameObjectCollectionBase | [To be supplied.]
ObjectList | [To be supplied.]
PagedDataSource | This class provides a wrapper over an ICollection datasource to implement paging semantics or 'paged views' on top of the underlying datasource. It uses the best available interface to enumerate over the data belonging to the current page. If the underlying datasource supports indexed access (like Array and IList), this wrapper uses it. Otherwise it falls back on IEnumerable.
PermissionSet | Represents a set of permissions of different types. This class supports all functionality of a permission, for the set of permissions as a whole.
PrinterSettings.PaperSizeCollection | Collection of PaperSize's...
PrinterSettings.PaperSourceCollection | Collection of PaperSource's...
PrinterSettings.PrinterResolutionCollection | Collection of PrinterResolution's...
PrinterSettings.StringCollection | Collection of String's...
PropertyDescriptorCollection | Represents a collection of properties.
Queue | Represents a first-in-first-out collection of objects.
RecurrencePatterns | Specifies a collection of recurrence patterns that describe the Schedule component's behavior when raising events.
RepeaterItemCollection | [To be supplied.]
ResourceReader | Provides a default implementation of the IResourceReader interface and implements a resource reader. Resource readers are used to read resource name and resource value pairs from ".resources" files. These methods are used to advance to the next resource and read the name and value of each resource in the ".resources" file. This class can be used to enumerate the resources only one time.
SearchResults | [To be supplied.]
SelectedDatesCollection | [To be supplied.]
SortedList | Represents a collection of associated keys and values, which are sorted by the keys and are accessible both by key and by index.
SQLErrors | Collects all errors generated by the SQL Server adapter.
SQLParameters | Collects all parameters relevant to a SQLCommand and their mappings to DataSet columns.
Stack | Represents a simple queue of Object.
StatusBar.StatusBarPanelCollection | [To be supplied.]
StringCollection | Collection of Strings
StringTable | Represents an unsorted set of strings.
TabControl.TabPageCollection | [To be supplied.]
TableCellCollection | [To be supplied.]
TableRowCollection | [To be supplied.]
TempFiles | Collection of temporary file names that are all based on a single base filename located in some temporary directory.
ToolBar.ToolBarButtonCollection | [To be supplied.]
TraceListeners | Provides a thread-safe list of TraceListeners. A thread-safe list is synchronized.
TreeNodeCollection | [To be supplied.]
TypeConverter.StandardValuesCollection | Represents a collection of values.
TypedCollectionBase | [To be supplied.]
TypedReadonlyCollectionBase | [To be supplied.]
ValidatorCollection | The ValidatorCollection class. Exposes a read-only array of IValidator references.
XmlNamedNodeMap | Represents a collection of nodes that can be accessed by name or index.
XmlNode | Represents a single node in the document.
XmlNodeList | Represents an ordered collection of nodes.

Remarks

Notes to Implementers:

IEnumerable must be implemented to support VB's ForEach semantics. COM classes that allow enumerators will also implement this interface.

Requirements

Namespace: System.Collections

Assembly: mscorlib.dll

See Also

IEnumerable Members | System.Collections Namespace | IEnumerator


IEnumerable Members

Methods

GetEnumerator When implemented by a class, returns an enumerator which can be used to iterate through a collection.

See Also

IEnumerable Interface | System.Collections Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IEnumerable Methods

The methods of the IEnumerable interface are listed below. For a complete list of IEnumerable interface members, see the IEnumerable Members topic.

GetEnumerator When implemented by a class, returns an enumerator which can be used to iterate through a collection.

See Also

IEnumerable Interface | System.Collections Namespace


IEnumerable.GetEnumerator

When implemented by a class, returns an enumerator which can be used to iterate through a collection.

[Visual Basic]
Function GetEnumerator() As IEnumerator
[C#]
IEnumerator GetEnumerator();
[C++]
IEnumerator* GetEnumerator() = 0;
[JScript]
function GetEnumerator() : IEnumerator;

Return Value

An IEnumerator, which can be used to iterate through the collection.

Remarks

When an enumerator is instantiated, it takes a snapshot of the current state of the collection. The enumerator also does not have exclusive access to the collection and multiple enumerators may have access to the same collection at the same time. Therefore, any changes made to the collection, either directly or through another enumerator, may cause Current or MoveNext to throw an exception.

Two enumerators instantiated from the same collection at the same time may not have exactly the same snapshots of the collection.

Removing objects from the enumerator will remove them from the collection.

Notes to Implementers:

The enumerator must be initially positioned before the first element of the collection and must be advanced by the caller of the implementation before use.

See Also

IEnumerable Interface | IEnumerable Members | System.Collections Namespace | IEnumerator


IEnumerator Interface

Supports a simple ForEach-style iteration over a collection.

IEnumerator

[Visual Basic]
Public Interface IEnumerator
[C#]
public interface IEnumerator
[C++]
public __gc __interface IEnumerator

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IEnumerator

Class | Description
DirectoryEntryCollection.ChildEnumerator | Supports a simple ForEach-style iteration over a collection and defines enumerators, size, and synchronization methods.
DirectoryEntryPropertyCollection.PropertyEnumerator | Supports a simple ForEach-style iteration over a collection and defines enumerators, size, and synchronization methods.
EventLog.EntriesEnumerator | Holds an EventLog.EventLogEntryCollection that consists of the entries in an event log.
MessageQueuesEnumerator | [To be supplied.]
MessagesEnumerator | Provides forward only cursor semantics to enumerate the messages contained in a queue. Each instance of this object uses a separate cursor.
SearchResults.ResultsEnumerator | [To be supplied.]
SearchResultsPropertyCollection.SearchResultsPropertyEnumerator | [To be supplied.]
SerializationInfoEnumerator | [To be supplied.]
TextElementEnumerator | [To be supplied.]

Remarks

IEnumerator is the base interface for all enumerators.

The enumerator also does not have exclusive access to the collection, so multiple enumerators may have access to the same collection.

When an enumerator is instantiated, it takes a snapshot of the current state of the collection.

Two enumerators instantiated from the same collection at the same time may not have exactly the same snapshots of the collection.

Changes made to the collection, either directly or through another enumerator, would cause the snapshot to be out of sync and the enumerator to be invalidated. An invalid enumerator may cause Current or MoveNext to throw an exception.

The enumerator is initially positioned before the first element in the collection and it must be advanced before it is used.

Removing objects from the enumerator will remove them from the collection.

Requirements

Namespace: System.Collections

Assembly: mscorlib.dll

See Also

IEnumerator Members | System.Collections Namespace | IEnumerable | ICollection


IEnumerator Members

Properties

Current When implemented by a class, gets the current element in the collection.

Methods

MoveNext | When implemented by a class, advances the enumerator to the next element of the collection.
Reset | When implemented by a class, sets the enumerator back to its initial position, which is before the first element in the collection.

See Also

IEnumerator Interface | System.Collections Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IEnumerator Properties

The properties of the IEnumerator interface are listed below. For a complete list of IEnumerator interface members, see the IEnumerator Members topic.

Current When implemented by a class, gets the current element in the collection.

See Also

IEnumerator Interface | System.Collections Namespace


IEnumerator.Current

When implemented by a class, gets the current element in the collection.

[Visual Basic]
ReadOnly Property Current As Object
[C#]
object Current {get;}
[C++]
Object* get_Current() = 0;
[JScript]
abstract function get Current() : Object;

Property Value

The current element in the collection.

Exceptions

Exception Type | Condition
InvalidOperationException | The enumerator is positioned before the first element of the collection or after the last element. -or- The collection was modified after the enumerator was instantiated.

Remarks

After an enumerator is created or after a Reset, MoveNext must be called to advance the enumerator to the first element of the collection before reading the value of Current. Otherwise, Current is undefined.

Current will also throw an exception if the last call to MoveNext returned false which indicates the end of the collection.

Current does not move the position of the enumerator and consecutive calls to Current will return the same object until either MoveNext or Reset is called.

See Also

IEnumerator Interface | IEnumerator Members | System.Collections Namespace | MoveNext | Reset


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IEnumerator Methods

The methods of the IEnumerator interface are listed below. For a complete list of IEnumerator interface members, see the IEnumerator Members topic.

MoveNext | When implemented by a class, advances the enumerator to the next element of the collection.
Reset | When implemented by a class, sets the enumerator back to its initial position, which is before the first element in the collection.

See Also

IEnumerator Interface | System.Collections Namespace


IEnumerator.MoveNext

When implemented by a class, advances the enumerator to the next element of the collection.

[Visual Basic]
Function MoveNext() As Boolean
[C#]
bool MoveNext();
[C++]
bool MoveNext() = 0;
[JScript]
function MoveNext() : Boolean;

Return Value

true if the enumerator was successfully advanced to the next element.

false if the enumerator has passed the end of the collection.

Exceptions

Exception Type | Condition
InvalidOperationException | The collection was modified after the enumerator was instantiated.

Remarks

After an enumerator is created or after a Reset, an enumerator is conceptually positioned before the first element of the collection, and the first call to MoveNext moves the enumerator over the first element of the collection.

If elements are added, removed or repositioned in the collection after this enumerator was created, MoveNext may throw an exception.

Once the end of the collection is passed, subsequent calls to MoveNext will return false until Reset is called.

See Also

IEnumerator Interface | IEnumerator Members | System.Collections Namespace | Current | Reset


IEnumerator.Reset

When implemented by a class, sets the enumerator back to its initial position, which is before the first element in the collection.

[Visual Basic]
Sub Reset()
[C#]
void Reset();
[C++]
void Reset() = 0;
[JScript]
function Reset();

Return Value

None.

Exceptions

Exception Type | Condition
InvalidOperationException | The collection was modified after the enumerator was instantiated.

Remarks

Notes to Implementers:

All calls to Reset must result in logically the same state for the enumerator. This may involve taking a new snapshot of the collection or simply moving to the beginning of the collection.

The preferred implementation is to simply move the enumerator to the beginning of the collection, before the first element. This would invalidate the enumerator if the collection has been modified since the enumerator was instantiated, but this behavior would be consistent with MoveNext and Current.

See Also

IEnumerator Interface | IEnumerator Members | System.Collections Namespace | MoveNext | Current


IHashCodeProvider Interface

Supplies a hashcode for the implementing class.

IHashCodeProvider

[Visual Basic]
Public Interface IHashCodeProvider
[C#]
public interface IHashCodeProvider
[C++]
public __gc __interface IHashCodeProvider

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IHashCodeProvider

Class | Description
CaseInsensitiveHashCodeProvider | Supplies a hashcode for the implementing class. The hashing algorithm ignores the case for Strings. The default for Hashtables is to use case sensitive hashcodes. This class is typically used in conjunction with CaseInsensitiveComparer

Remarks

The IHashCodeProvider interface is used in conjunction with Hashtable. The objects used as keys by a Hashtable must implement or inherit the GetHashCode and Equals methods. However, if the Hashtable constructor is passed a reference to an object that implements both the IHashCodeProvider interface and the IComparer interface, then GetHashCode and Compare can be used instead.

Requirements

Namespace: System.Collections

Assembly: mscorlib.dll

See Also

IHashCodeProvider Members | System.Collections Namespace | Hashtable | IHashCodeProvider | IComparer


IHashCodeProvider Members

Methods

GetHashCode When implemented by a class, returns a hash code for the given object.

See Also

IHashCodeProvider Interface | System.Collections Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IHashCodeProvider Methods

The methods of the IHashCodeProvider interface are listed below. For a complete list of IHashCodeProvider interface members, see the IHashCodeProvider Members topic.

GetHashCode When implemented by a class, returns a hash code for the given object.

See Also

IHashCodeProvider Interface | System.Collections Namespace


IHashCodeProvider.GetHashCode

When implemented by a class, returns a hash code for the given object.

[Visual Basic]
Function GetHashCode( _
   ByVal obj As Object _
) As Integer
[C#]
int GetHashCode(
   object obj
);
[C++]
int GetHashCode(
   Object* obj
) = 0;
[JScript]
function GetHashCode(
   obj : Object
) : int;

Parameters

obj
The Object for which a hash code is to be returned.

Return Value

Returns a hash code for the specified object.

See Also

IHashCodeProvider Interface | IHashCodeProvider Members | System.Collections Namespace


IList Interface

Represents a collection of objects that can be individually indexed.

[Visual Basic]
Public Interface IList
   Implements ICollection, IEnumerable
[C#]
public interface IList : ICollection, IEnumerable
[C++]
public __gc __interface IList : public ICollection, IEnumerable

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IList

Class | Description
ADOParameters | Collects all parameters relevant to an ADOCommand and their mappings to DataSet columns.
ArrayList | Implements the IList interface using an array whose size is dynamically increased as required.
BaseConfigCollection | A generic implementation of the IConfigCollection interface.
CodeAttributeArgumentCollection | Manages a collection of CodeAttributeArgument objects.
CodeAttributeDeclarationCollection | Manages a collection that stores CodeAttributeDeclaration objects.
CodeCatchClauseCollection | Manages a collection of CodeCatchClause objects.
CodeClassCollection | Manages a collection that stores CodeClass objects.
CodeClassMemberCollection | Manages a collection of CodeClassMember objects.
CodeExpressionCollection | Manages a collection of CodeExpression objects.
CodeNamespaceImportCollection | Manages a collection of CodeNamespaceImport objects.
CodeParameterDeclarationExpressionCollection | Manages a collection of CodeParameterDeclarationExpression objects
CodeStatementCollection | Manages a collection of CodeStatement objects.
CompilerErrorCollection | Manages a collection of CompilerError objects.
DataColumnMappings | column mapping collection
DataSetView | Represents a view of a DataSet with individual filters automatically set on each of its tables.
DataTableMappings | table mapping collection
DataView | Represents a databindable, customized view of a DataTable for sorting, filtering, searching, editing, and navigation.
DirectoryEntryCollection.CollectionOverStringVariantProperty | Represents a collection of objects that can be individually indexed.
ObjectList | [To be supplied.]
PropertyDescriptorCollection | Represents a collection of properties.
SQLParameters | Collects all parameters relevant to a SQLCommand and their mappings to DataSet columns.
StringCollection | Collection of Strings
TraceListeners | Provides a thread-safe list of TraceListeners. A thread-safe list is synchronized.
TypedCollectionBase | [To be supplied.]

Remarks

IList is a descendant of the ICollection interface and is the abstract base class of all lists. IList implementations fall into three categories: read-only, fixed-size, variable-size. A read-only IList cannot be modified. A fixed-size IList allows individual elements to be modified, but does not support adding or removing elements. A variable-size IList allows elements to be modified, added and removed.

Requirements

Namespace: System.Collections

Assembly: mscorlib.dll

See Also

IList Members | System.Collections Namespace | ICollection


IList Members

Properties

Item When implemented by a class, gets or sets the element at the specified index.

In C#, this member is the indexer for the IList class.

Methods

Add | When implemented by a class, adds an item to the IList.
Clear | When implemented by a class, removes all items from the IList.
Contains | When implemented by a class, determines if the IList contains a specific value.
IndexOf | When implemented by a class, determines the index of a specific item in the IList.
Insert | When implemented by a class, inserts an item to the IList at the specified position.
Remove | When implemented by a class, removes an item from the IList.
RemoveAt | When implemented by a class, removes the IList item at the specified index.

See Also

IList Interface | System.Collections Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IList Properties

The properties of the IList interface are listed below. For a complete list of IList interface members, see the IList Members topic.

Item When implemented by a class, gets or sets the element at the specified index.

In C#, this member is the indexer for the IList class.

See Also

IList Interface | System.Collections Namespace


IList.Item

When implemented by a class, gets or sets the element at the specified index.

[C#] In C#, this member is the indexer for the IList class.

[Visual Basic]
Default Property Item( _
   ByVal index As Integer _
) As Object
[C#]
object this[
   int index
] {get; set;}
[C++]
Object* get_Item(
   int index
) = 0;void set_Item(
   int index,
   Object*
) = 0;
[JScript]
abstract returnValue = IListObject.Item(index);
IListObject.Item(index) = returnValue;
-or-
abstract returnValue = IListObject(index);
IListObject(index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
[To be supplied.]

Parameters [Visual Basic, C#, C++]

index
[To be supplied.]

Property Value

The element at the specified index.

See Also

IList Interface | IList Members | System.Collections Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IList Methods

The methods of the IList interface are listed below. For a complete list of IList interface members, see the IList Members topic.

Add | When implemented by a class, adds an item to the IList.
Clear | When implemented by a class, removes all items from the IList.
Contains | When implemented by a class, determines if the IList contains a specific value.
IndexOf | When implemented by a class, determines the index of a specific item in the IList.
Insert | When implemented by a class, inserts an item to the IList at the specified position.
Remove | When implemented by a class, removes an item from the IList.
RemoveAt | When implemented by a class, removes the IList item at the specified index.

See Also

IList Interface | System.Collections Namespace


IList.Add

When implemented by a class, adds an item to the IList.

[Visual Basic]
Function Add( _
   ByVal value As Object _
) As Integer
[C#]
int Add(
   object value
);
[C++]
int Add(
   Object* value
) = 0;
[JScript]
function Add(
   value : Object
) : int;

Parameters

value
The Object to add to the IList.

Return Value

The position into which the new element was inserted.

See Also

IList Interface | IList Members | System.Collections Namespace


IList.Clear

When implemented by a class, removes all items from the IList.

[Visual Basic]
Sub Clear()
[C#]
void Clear();
[C++]
void Clear() = 0;
[JScript]
function Clear();

See Also

IList Interface | IList Members | System.Collections Namespace


IList.Contains

When implemented by a class, determines if the IList contains a specific value.

[Visual Basic]
Function Contains( _
   ByVal value As Object _
) As Boolean
[C#]
bool Contains(
   object value
);
[C++]
bool Contains(
   Object* value
) = 0;
[JScript]
function Contains(
   value : Object
) : Boolean;

Parameters

value
The Object to search for in the IList.

Return Value

true if the Object is found in the IList; otherwise, false.

See Also

IList Interface | IList Members | System.Collections Namespace


IList.IndexOf

When implemented by a class, determines the index of a specific item in the IList.

[Visual Basic]
Function IndexOf( _
   ByVal value As Object _
) As Integer
[C#]
int IndexOf(
   object value
);
[C++]
int IndexOf(
   Object* value
) = 0;
[JScript]
function IndexOf(
   value : Object
) : int;

Parameters

value
The Object to search for in the IList.

Return Value

The index of value if found in the list; otherwise,-1.

See Also

IList Interface | IList Members | System.Collections Namespace


IList.Insert

When implemented by a class, inserts an item to the IList at the specified position.

[Visual Basic]
Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Object _
)
[C#]
void Insert(
   int index,
   object value
);
[C++]
void Insert(
   int index,
   Object* value
) = 0;
[JScript]
function Insert(
   index : int,
   value : Object
);

Parameters

index
The position in IList at which to insert value.
value
The Object to insert into the IList.

Remarks

If index equals the number of items in the IList, then value is appended to the end.

See Also

IList Interface | IList Members | System.Collections Namespace


IList.Remove

When implemented by a class, removes an item from the IList.

[Visual Basic]
Sub Remove( _
   ByVal value As Object _
)
[C#]
void Remove(
   object value
);
[C++]
void Remove(
   Object* value
) = 0;
[JScript]
function Remove(
   value : Object
);

Parameters

value
The Object to remove from the IList.

See Also

IList Interface | IList Members | System.Collections Namespace


IList.RemoveAt

When implemented by a class, removes the IList item at the specified index.

[Visual Basic]
Sub RemoveAt( _
   ByVal index As Integer _
)
[C#]
void RemoveAt(
   int index
);
[C++]
void RemoveAt(
   int index
) = 0;
[JScript]
function RemoveAt(
   index : int
);

Parameters

index
The position of the item to remove.

See Also

IList Interface | IList Members | System.Collections Namespace


NameObjectCollectionBase Class

[To be supplied.]

Object
NameObjectCollectionBase

[Visual Basic]
MustInherit Public Class NameObjectCollectionBase
   Implements ICollection, IEnumerable
[C#]
public abstract class NameObjectCollectionBase : ICollection,
   IEnumerable
[C++]
public __gc __abstract class NameObjectCollectionBase : public
   ICollection, IEnumerable
[JScript]
public abstract class NameObjectCollectionBase implements
   ICollection, IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.Collections

Assembly: System.dll

See Also

NameObjectCollectionBase Members | System.Collections Namespace


NameObjectCollectionBase Members

Public:

Constructor

NameObjectCollectionBase Constructor [To be supplied.]

Properties

Count [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

ReadOnly [To be supplied.]

Methods

BaseAdd | [To be supplied.]
BaseClear | [To be supplied.]
BaseGet | Overloaded. [To be supplied.]
BaseGetAllKeys | [To be supplied.]
BaseGetAllValues | Overloaded. [To be supplied.]
BaseGetKey | [To be supplied.]
BaseHasKeys | [To be supplied.]
BaseRemove | Overloaded. [To be supplied.]
BaseSet | Overloaded. [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NameObjectCollectionBase Class | System.Collections Namespace


NameObjectCollectionBase Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public NameObjectCollectionBase();
[C++]
public: NameObjectCollectionBase();
[JScript]
public function NameObjectCollectionBase();

See Also

NameObjectCollectionBase Class | NameObjectCollectionBase Members | System.Collections Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

NameObjectCollectionBase Properties

The properties of the NameObjectCollectionBase class are listed below. For a complete list of NameObjectCollectionBase class members, see the NameObjectCollectionBase Members topic.

Public:

Count [To be supplied.]

Protected:

ReadOnly [To be supplied.]

See Also

NameObjectCollectionBase Class | System.Collections Namespace


NameObjectCollectionBase.Count

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Count As Integer
[C#]
public int Count {virtual get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;

See Also

NameObjectCollectionBase Class | NameObjectCollectionBase Members | System.Collections Namespace


NameObjectCollectionBase.ReadOnly

[To be supplied.]

[Visual Basic]
Protected Property ReadOnly As Boolean
[C#]
protected bool ReadOnly {get; set;}
[C++]
protected: __property bool get_ReadOnly();
protected: __property void set_ReadOnly(bool);
[JScript]
protected function get ReadOnly() : Boolean;
protected function set ReadOnly(Boolean);

See Also

NameObjectCollectionBase Class | NameObjectCollectionBase Members | System.Collections Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

NameObjectCollectionBase Methods

The methods of the NameObjectCollectionBase class are listed below. For a complete list of NameObjectCollectionBase class members, see the NameObjectCollectionBase Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

BaseAdd | [To be supplied.]
BaseClear | [To be supplied.]
BaseGet | Overloaded. [To be supplied.]
BaseGetAllKeys | [To be supplied.]
BaseGetAllValues | Overloaded. [To be supplied.]
BaseGetKey | [To be supplied.]
BaseHasKeys | [To be supplied.]
BaseRemove | Overloaded. [To be supplied.]
BaseSet | Overloaded. [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NameObjectCollectionBase Class | System.Collections Namespace


NameObjectCollectionBase.BaseAdd

[To be supplied.]

[Visual Basic]
Protected Sub BaseAdd( _
   ByVal name As String, _
   ByVal value As Object _
)
[C#]
protected void BaseAdd(
   string name,
   object value
);
[C++]
protected: void BaseAdd(
   String* name,
   Object* value
);
[JScript]
protected function BaseAdd(
   name : String,
   value : Object
);

Parameters

name
[To be supplied.]
value
[To be supplied.]

See Also

NameObjectCollectionBase Class | NameObjectCollectionBase Members | System.Collections Namespace


NameObjectCollectionBase.BaseClear

[To be supplied.]

[Visual Basic]
Protected Sub BaseClear()
[C#]
protected void BaseClear();
[C++]
protected: void BaseClear();
[JScript]
protected function BaseClear();

See Also

NameObjectCollectionBase Class | NameObjectCollectionBase Members | System.Collections Namespace


NameObjectCollectionBase.BaseGet

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Protected Function BaseGet(Integer) As Object
[C#] protected object BaseGet(int);
[C++] protected: Object* BaseGet(int);
[JScript] protected function BaseGet(int) : Object;

[To be supplied.]

[Visual Basic] Overloads Protected Function BaseGet(String) As Object
[C#] protected object BaseGet(String);
[C++] protected: Object* BaseGet(String*);
[JScript] protected function BaseGet(String) : Object;

See Also

NameObjectCollectionBase Class | NameObjectCollectionBase Members | System.Collections Namespace


NameObjectCollectionBase.BaseGet (Int32)

[To be supplied.]

[Visual Basic]
Overloads Protected Function BaseGet( _
   ByVal index As Integer _
) As Object
[C#]
protected object BaseGet(
   int index
);
[C++]
protected: Object* BaseGet(
   int index
);
[JScript]
protected function BaseGet(
   index : int
) : Object;

Parameters

index
[To be supplied.]

See Also

NameObjectCollectionBase Class | NameObjectCollectionBase Members | System.Collections Namespace | NameObjectCollectionBase.BaseGet Overload List


NameObjectCollectionBase.BaseGet (String)

[To be supplied.]

[Visual Basic]
Overloads Protected Function BaseGet( _
   ByVal name As String _
) As Object
[C#]
protected object BaseGet(
   string name
);
[C++]
protected: Object* BaseGet(
   String* name
);
[JScript]
protected function BaseGet(
   name : String
) : Object;

Parameters

name
[To be supplied.]

See Also

NameObjectCollectionBase Class | NameObjectCollectionBase Members | System.Collections Namespace | NameObjectCollectionBase.BaseGet Overload List


NameObjectCollectionBase.BaseGetAllKeys

[To be supplied.]

[Visual Basic]
Protected Function BaseGetAllKeys() As String ()
[C#]
protected string[] BaseGetAllKeys();
[C++]
protected: String* BaseGetAllKeys() [];
[JScript]
protected function BaseGetAllKeys() : String[];

See Also

NameObjectCollectionBase Class | NameObjectCollectionBase Members | System.Collections Namespace


NameObjectCollectionBase.BaseGetAllValues

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Protected Function BaseGetAllValues(Type) As Object ()
[C#] protected object[] BaseGetAllValues(Type);
[C++] protected: Object* BaseGetAllValues(Type*) [];
[JScript] protected function BaseGetAllValues(Type) : Object[];

[To be supplied.]

[Visual Basic] Overloads Protected Function BaseGetAllValues() As Object ()
[C#] protected object[] BaseGetAllValues();
[C++] protected: Object* BaseGetAllValues() [];
[JScript] protected function BaseGetAllValues() : Object[];

See Also

NameObjectCollectionBase Class | NameObjectCollectionBase Members | System.Collections Namespace


NameObjectCollectionBase.BaseGetAllValues (Type)

[To be supplied.]

[Visual Basic]
Overloads Protected Function BaseGetAllValues( _
   ByVal type As Type _
) As Object ()
[C#]
protected object[] BaseGetAllValues(
   Type type
);
[C++]
protected: Object* BaseGetAllValues(
   Type* type
) [];
[JScript]
protected function BaseGetAllValues(
   type : Type
) : Object[];

Parameters

type
[To be supplied.]

See Also

NameObjectCollectionBase Class | NameObjectCollectionBase Members | System.Collections Namespace | NameObjectCollectionBase.BaseGetAllValues Overload List


NameObjectCollectionBase.BaseGetAllValues ()

[To be supplied.]

[Visual Basic]
Overloads Protected Function BaseGetAllValues() As Object ()
[C#]
protected object[] BaseGetAllValues();
[C++]
protected: Object* BaseGetAllValues() [];
[JScript]
protected function BaseGetAllValues() : Object[];

See Also

NameObjectCollectionBase Class | NameObjectCollectionBase Members | System.Collections Namespace | NameObjectCollectionBase.BaseGetAllValues Overload List


NameObjectCollectionBase.BaseGetKey

[To be supplied.]

[Visual Basic]
Protected Function BaseGetKey( _
   ByVal index As Integer _
) As String
[C#]
protected string BaseGetKey(
   int index
);
[C++]
protected: String* BaseGetKey(
   int index
);
[JScript]
protected function BaseGetKey(
   index : int
) : String;

Parameters

index
[To be supplied.]

See Also

NameObjectCollectionBase Class | NameObjectCollectionBase Members | System.Collections Namespace


NameObjectCollectionBase.BaseHasKeys

[To be supplied.]

[Visual Basic]
Protected Function BaseHasKeys() As Boolean
[C#]
protected bool BaseHasKeys();
[C++]
protected: bool BaseHasKeys();
[JScript]
protected function BaseHasKeys() : Boolean;

See Also

NameObjectCollectionBase Class | NameObjectCollectionBase Members | System.Collections Namespace


NameObjectCollectionBase.BaseRemove

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Protected Sub BaseRemove(String)
[C#] protected void BaseRemove(String);
[C++] protected: void BaseRemove(String*);
[JScript] protected function BaseRemove(String);

[To be supplied.]

[Visual Basic] Overloads Protected Sub BaseRemove(Integer)
[C#] protected void BaseRemove(int);
[C++] protected: void BaseRemove(int);
[JScript] protected function BaseRemove(int);

See Also

NameObjectCollectionBase Class | NameObjectCollectionBase Members | System.Collections Namespace


NameObjectCollectionBase.BaseRemove (String)

[To be supplied.]

[Visual Basic]
Overloads Protected Sub BaseRemove( _
   ByVal name As String _
)
[C#]
protected void BaseRemove(
   string name
);
[C++]
protected: void BaseRemove(
   String* name
);
[JScript]
protected function BaseRemove(
   name : String
);

Parameters

name
[To be supplied.]

See Also

NameObjectCollectionBase Class | NameObjectCollectionBase Members | System.Collections Namespace | NameObjectCollectionBase.BaseRemove Overload List


NameObjectCollectionBase.BaseRemove (Int32)

[To be supplied.]

[Visual Basic]
Overloads Protected Sub BaseRemove( _
   ByVal index As Integer _
)
[C#]
protected void BaseRemove(
   int index
);
[C++]
protected: void BaseRemove(
   int index
);
[JScript]
protected function BaseRemove(
   index : int
);

Parameters

index
[To be supplied.]

See Also

NameObjectCollectionBase Class | NameObjectCollectionBase Members | System.Collections Namespace | NameObjectCollectionBase.BaseRemove Overload List


NameObjectCollectionBase.BaseSet

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Protected Sub BaseSet(Integer, Object)
[C#] protected void BaseSet(int, Object);
[C++] protected: void BaseSet(int, Object);
[JScript] protected function BaseSet(int, Object);

[To be supplied.]

[Visual Basic] Overloads Protected Sub BaseSet(String, Object)
[C#] protected void BaseSet(String, Object);
[C++] protected: void BaseSet(String*, Object);
[JScript] protected function BaseSet(String, Object);

See Also

NameObjectCollectionBase Class | NameObjectCollectionBase Members | System.Collections Namespace


NameObjectCollectionBase.BaseSet (Int32, Object)

[To be supplied.]

[Visual Basic]
Overloads Protected Sub BaseSet( _
   ByVal index As Integer, _
   ByVal value As Object _
)
[C#]
protected void BaseSet(
   int index,
   object value
);
[C++]
protected: void BaseSet(
   int index,
   Object* value
);
[JScript]
protected function BaseSet(
   index : int,
   value : Object
);

Parameters

index
[To be supplied.]
value
[To be supplied.]

See Also

NameObjectCollectionBase Class | NameObjectCollectionBase Members | System.Collections Namespace | NameObjectCollectionBase.BaseSet Overload List


NameObjectCollectionBase.BaseSet (String, Object)

[To be supplied.]

[Visual Basic]
Overloads Protected Sub BaseSet( _
   ByVal name As String, _
   ByVal value As Object _
)
[C#]
protected void BaseSet(
   string name,
   object value
);
[C++]
protected: void BaseSet(
   String* name,
   Object* value
);
[JScript]
protected function BaseSet(
   name : String,
   value : Object
);

Parameters

name
[To be supplied.]
value
[To be supplied.]

See Also

NameObjectCollectionBase Class | NameObjectCollectionBase Members | System.Collections Namespace | NameObjectCollectionBase.BaseSet Overload List


NameObjectCollectionBase.GetEnumerator

[To be supplied.]

[Visual Basic]
Overridable Public Function GetEnumerator() As IEnumerator
[C#]
public virtual IEnumerator GetEnumerator();
[C++]
public: virtual IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

See Also

NameObjectCollectionBase Class | NameObjectCollectionBase Members | System.Collections Namespace


NameValueCollection Class

[To be supplied.]

Object
NameObjectCollectionBase
NameValueCollection

[Visual Basic]
Public Class NameValueCollection
   Inherits NameObjectCollectionBase
[C#]
public class NameValueCollection : NameObjectCollectionBase
[C++]
public __gc class NameValueCollection : public
   NameObjectCollectionBase
[JScript]
public class NameValueCollection extends NameObjectCollectionBase

Remarks

[To be supplied.]

Requirements

Namespace: System.Collections

Assembly: System.dll

See Also

NameValueCollection Members | System.Collections Namespace


NameValueCollection Members

Public:

Constructor

NameValueCollection Constructor Overloaded. [To be supplied.]

Properties

All | [To be supplied.]
AllKeys | [To be supplied.]
Count (inherited from NameObjectCollectionBase) | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the NameValueCollection class.

Methods

Add | Overloaded. [To be supplied.]
Clear | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | Overloaded. [To be supplied.]
GetEnumerator (inherited from NameObjectCollectionBase) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetKey | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValues | Overloaded. [To be supplied.]
HasKeys | [To be supplied.]
Remove | [To be supplied.]
Set | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

ReadOnly (inherited from NameObjectCollectionBase) [To be supplied.]

Methods

BaseAdd (inherited from NameObjectCollectionBase) | [To be supplied.]
BaseClear (inherited from NameObjectCollectionBase) | [To be supplied.]
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. [To be supplied.]
BaseGetAllKeys (inherited from NameObjectCollectionBase) | [To be supplied.]
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. [To be supplied.]
BaseGetKey (inherited from NameObjectCollectionBase) | [To be supplied.]
BaseHasKeys (inherited from NameObjectCollectionBase) | [To be supplied.]
BaseRemove (inherited from NameObjectCollectionBase) | Overloaded. [To be supplied.]
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
InvalidateCachedArrays | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NameValueCollection Class | System.Collections Namespace


NameValueCollection Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public NameValueCollection();
[C++] public: NameValueCollection();
[JScript] public function NameValueCollection();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(NameValueCollection)
[C#] public NameValueCollection(NameValueCollection);
[C++] public: NameValueCollection(NameValueCollection*);
[JScript] public function NameValueCollection(NameValueCollection);

See Also

NameValueCollection Class | NameValueCollection Members | System.Collections Namespace


NameValueCollection Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public NameValueCollection();
[C++]
public: NameValueCollection();
[JScript]
public function NameValueCollection();

See Also

NameValueCollection Class | NameValueCollection Members | System.Collections Namespace | NameValueCollection Constructor Overload List


NameValueCollection Constructor (NameValueCollection)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal col As NameValueCollection _
)
[C#]
public NameValueCollection(
   NameValueCollection col
);
[C++]
public: NameValueCollection(
   NameValueCollection* col
);
[JScript]
public function NameValueCollection(
   col : NameValueCollection
);

Parameters

col
[To be supplied.]

See Also

NameValueCollection Class | NameValueCollection Members | System.Collections Namespace | NameValueCollection Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

NameValueCollection Properties

The properties of the NameValueCollection class are listed below. For a complete list of NameValueCollection class members, see the NameValueCollection Members topic.

Public:

All | [To be supplied.]
AllKeys | [To be supplied.]
Count (inherited from NameObjectCollectionBase) | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the NameValueCollection class.

Protected:

ReadOnly (inherited from NameObjectCollectionBase) [To be supplied.]

See Also

NameValueCollection Class | System.Collections Namespace


NameValueCollection.All

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property All As String ()
[C#]
public string[] All {virtual get;}
[C++]
public: __property virtual String* get_All();
[JScript]
public function get All() : String[];

See Also

NameValueCollection Class | NameValueCollection Members | System.Collections Namespace


NameValueCollection.AllKeys

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property AllKeys As String ()
[C#]
public string[] AllKeys {virtual get;}
[C++]
public: __property virtual String* get_AllKeys();
[JScript]
public function get AllKeys() : String[];

See Also

NameValueCollection Class | NameValueCollection Members | System.Collections Namespace


NameValueCollection.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the NameValueCollection class.

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Default ReadOnly Property Item(Integer) As String
[C#] public string this[int] {get;}
[C++] public: __property String* get_Item(int);
[JScript] NameValueCollection.Item (int)

[To be supplied.]

[Visual Basic] Overloads Public Default Property Item(String) As String
[C#] public string this[String] {get; set;}
[C++] public: __property String* get_Item(String*);
public: __property void set_Item(String*, String*);
[JScript] NameValueCollection.Item (String)

See Also

NameValueCollection Class | NameValueCollection Members | System.Collections Namespace


NameValueCollection.Item (Int32)

[To be supplied.]

[C#] In C#, this member is the indexer for the NameValueCollection class.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
   ByVal index As Integer _
) As String
[C#]
public string this[
   int index
] {get;}
[C++]
public: __property String* get_Item(
   int index
);
[JScript]
returnValue = NameValueCollectionObject.Item(index);
-or-
returnValue = NameValueCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
[To be supplied.]

Parameters [Visual Basic, C#, C++]

index
[To be supplied.]

See Also

NameValueCollection Class | NameValueCollection Members | System.Collections Namespace | NameValueCollection.Item Overload List


NameValueCollection.Item (String)

[To be supplied.]

[C#] In C#, this member is the indexer for the NameValueCollection class.

[Visual Basic]
Overloads Public Default Property Item( _
   ByVal name As String _
) As String
[C#]
public string this[
   string name
] {get; set;}
[C++]
public: __property String* get_Item(
   String* name
);
public: __property void set_Item(
   String* name,
   String*
);
[JScript]
returnValue = NameValueCollectionObject.Item(name);
NameValueCollectionObject.Item(name) = returnValue;
-or-
returnValue = NameValueCollectionObject(name);
NameValueCollectionObject(name) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
[To be supplied.]

Parameters [Visual Basic, C#, C++]

name
[To be supplied.]

See Also

NameValueCollection Class | NameValueCollection Members | System.Collections Namespace | NameValueCollection.Item Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

NameValueCollection Methods

The methods of the NameValueCollection class are listed below. For a complete list of NameValueCollection class members, see the NameValueCollection Members topic.

Public:

Add | Overloaded. [To be supplied.]
Clear | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | Overloaded. [To be supplied.]
GetEnumerator (inherited from NameObjectCollectionBase) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetKey | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValues | Overloaded. [To be supplied.]
HasKeys | [To be supplied.]
Remove | [To be supplied.]
Set | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

BaseAdd (inherited from NameObjectCollectionBase) | [To be supplied.]
BaseClear (inherited from NameObjectCollectionBase) | [To be supplied.]
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. [To be supplied.]
BaseGetAllKeys (inherited from NameObjectCollectionBase) | [To be supplied.]
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. [To be supplied.]
BaseGetKey (inherited from NameObjectCollectionBase) | [To be supplied.]
BaseHasKeys (inherited from NameObjectCollectionBase) | [To be supplied.]
BaseRemove (inherited from NameObjectCollectionBase) | Overloaded. [To be supplied.]
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
InvalidateCachedArrays | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NameValueCollection Class | System.Collections Namespace


NameValueCollection.Add

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Sub Add(String, String)
[C#] public virtual void Add(String, String);
[C++] public: virtual void Add(String*, String*);
[JScript] public function Add(String, String);

[To be supplied.]

[Visual Basic] Overloads Public Sub Add(NameValueCollection)
[C#] public void Add(NameValueCollection);
[C++] public: void Add(NameValueCollection*);
[JScript] public function Add(NameValueCollection);

See Also

NameValueCollection Class | NameValueCollection Members | System.Collections Namespace


NameValueCollection.Add (String, String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Sub Add( _
   ByVal name As String, _
   ByVal value As String _
)
[C#]
public virtual void Add(
   string name,
   string value
);
[C++]
public: virtual void Add(
   String* name,
   String* value
);
[JScript]
public function Add(
   name : String,
   value : String
);

Parameters

name
[To be supplied.]
value
[To be supplied.]

See Also

NameValueCollection Class | NameValueCollection Members | System.Collections Namespace | NameValueCollection.Add Overload List


NameValueCollection.Add (NameValueCollection)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Add( _
   ByVal c As NameValueCollection _
)
[C#]
public void Add(
   NameValueCollection c
);
[C++]
public: void Add(
   NameValueCollection* c
);
[JScript]
public function Add(
   c : NameValueCollection
);

Parameters

c
[To be supplied.]

See Also

NameValueCollection Class | NameValueCollection Members | System.Collections Namespace | NameValueCollection.Add Overload List


NameValueCollection.Clear

[To be supplied.]

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[JScript]
public function Clear();

See Also

NameValueCollection Class | NameValueCollection Members | System.Collections Namespace


NameValueCollection.Get

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Get(Integer) As String
[C#] public virtual string Get(int);
[C++] public: virtual String* Get(int);
[JScript] public function Get(int) : String;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Get(String) As String
[C#] public virtual string Get(String);
[C++] public: virtual String* Get(String*);
[JScript] public function Get(String) : String;

See Also

NameValueCollection Class | NameValueCollection Members | System.Collections Namespace


NameValueCollection.Get (Int32)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Get( _
   ByVal index As Integer _
) As String
[C#]
public virtual string Get(
   int index
);
[C++]
public: virtual String* Get(
   int index
);
[JScript]
public function Get(
   index : int
) : String;

Parameters

index
[To be supplied.]

See Also

NameValueCollection Class | NameValueCollection Members | System.Collections Namespace | NameValueCollection.Get Overload List


NameValueCollection.Get (String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Get( _
   ByVal name As String _
) As String
[C#]
public virtual string Get(
   string name
);
[C++]
public: virtual String* Get(
   String* name
);
[JScript]
public function Get(
   name : String
) : String;

Parameters

name
[To be supplied.]

See Also

NameValueCollection Class | NameValueCollection Members | System.Collections Namespace | NameValueCollection.Get Overload List


NameValueCollection.GetKey

[To be supplied.]

[Visual Basic]
Overridable Public Function GetKey( _
   ByVal index As Integer _
) As String
[C#]
public virtual string GetKey(
   int index
);
[C++]
public: virtual String* GetKey(
   int index
);
[JScript]
public function GetKey(
   index : int
) : String;

Parameters

index
[To be supplied.]

See Also

NameValueCollection Class | NameValueCollection Members | System.Collections Namespace


NameValueCollection.GetValues

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function GetValues(Integer) As String ()
[C#] public virtual string[] GetValues(int);
[C++] public: virtual String* GetValues(int) [];
[JScript] public function GetValues(int) : String[];

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function GetValues(String) As String ()
[C#] public virtual string[] GetValues(String);
[C++] public: virtual String* GetValues(String*) [];
[JScript] public function GetValues(String) : String[];

See Also

NameValueCollection Class | NameValueCollection Members | System.Collections Namespace


NameValueCollection.GetValues (Int32)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function GetValues( _
   ByVal index As Integer _
) As String ()
[C#]
public virtual string[] GetValues(
   int index
);
[C++]
public: virtual String* GetValues(
   int index
) [];
[JScript]
public function GetValues(
   index : int
) : String[];

Parameters

index
[To be supplied.]

See Also

NameValueCollection Class | NameValueCollection Members | System.Collections Namespace | NameValueCollection.GetValues Overload List


NameValueCollection.GetValues (String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function GetValues( _
   ByVal name As String _
) As String ()
[C#]
public virtual string[] GetValues(
   string name
);
[C++]
public: virtual String* GetValues(
   String* name
) [];
[JScript]
public function GetValues(
   name : String
) : String[];

Parameters

name
[To be supplied.]

See Also

NameValueCollection Class | NameValueCollection Members | System.Collections Namespace | NameValueCollection.GetValues Overload List


NameValueCollection.HasKeys

[To be supplied.]

[Visual Basic]
Public Function HasKeys() As Boolean
[C#]
public bool HasKeys();
[C++]
public: bool HasKeys();
[JScript]
public function HasKeys() : Boolean;

See Also

NameValueCollection Class | NameValueCollection Members | System.Collections Namespace


NameValueCollection.InvalidateCachedArrays

[To be supplied.]

[Visual Basic]
Protected Sub InvalidateCachedArrays()
[C#]
protected void InvalidateCachedArrays();
[C++]
protected: void InvalidateCachedArrays();
[JScript]
protected function InvalidateCachedArrays();

See Also

NameValueCollection Class | NameValueCollection Members | System.Collections Namespace


NameValueCollection.Remove

[To be supplied.]

[Visual Basic]
Overridable Public Sub Remove( _
   ByVal name As String _
)
[C#]
public virtual void Remove(
   string name
);
[C++]
public: virtual void Remove(
   String* name
);
[JScript]
public function Remove(
   name : String
);

Parameters

name
[To be supplied.]

See Also

NameValueCollection Class | NameValueCollection Members | System.Collections Namespace


NameValueCollection.Set

[To be supplied.]

[Visual Basic]
Overridable Public Sub Set( _
   ByVal name As String, _
   ByVal value As String _
)
[C#]
public virtual void Set(
   string name,
   string value
);
[C++]
public: virtual void Set(
   String* name,
   String* value
);
[JScript]
public function Set(
   name : String,
   value : String
);

Parameters

name
[To be supplied.]
value
[To be supplied.]

See Also

NameValueCollection Class | NameValueCollection Members | System.Collections Namespace


ObjectList Class

[To be supplied.]

Object
ObjectList

[Visual Basic]
Public Class ObjectList
   Implements IList, ICollection, IEnumerable
[C#]
public class ObjectList : IList, ICollection, IEnumerable
[C++]
public __gc class ObjectList : public IList, ICollection,
   IEnumerable
[JScript]
public class ObjectList implements IList, ICollection, IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.Collections

Assembly: mscorlib.dll

See Also

ObjectList Members | System.Collections Namespace


ObjectList Members

Public:

Constructor

ObjectList Constructor Overloaded. [To be supplied.]

Properties

Count | [To be supplied.]
IsReadOnly | [To be supplied.]
IsSynchronized | [To be supplied.]
Item | [To be supplied.] In C#, this member is the indexer for the ObjectList class.
SyncRoot | [To be supplied.]

Methods

Add | [To be supplied.]
Clear | [To be supplied.]
Contains | [To be supplied.]
CopyTo | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | [To be supplied.]
Insert | [To be supplied.]
Remove | [To be supplied.]
RemoveAt | [To be supplied.]
Synchronized | [To be supplied.]
ToArray | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ObjectList Class | System.Collections Namespace


ObjectList Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public ObjectList();
[C++] public: ObjectList();
[JScript] public function ObjectList();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public ObjectList(int);
[C++] public: ObjectList(int);
[JScript] public function ObjectList(int);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(ICollection)
[C#] public ObjectList(ICollection);
[C++] public: ObjectList(ICollection*);
[JScript] public function ObjectList(ICollection);

See Also

ObjectList Class | ObjectList Members | System.Collections Namespace


ObjectList Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public ObjectList();
[C++]
public: ObjectList();
[JScript]
public function ObjectList();

See Also

ObjectList Class | ObjectList Members | System.Collections Namespace | ObjectList Constructor Overload List


ObjectList Constructor (Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal capacity As Integer _
)
[C#]
public ObjectList(
   int capacity
);
[C++]
public: ObjectList(
   int capacity
);
[JScript]
public function ObjectList(
   capacity : int
);

Parameters

capacity
[To be supplied.]

See Also

ObjectList Class | ObjectList Members | System.Collections Namespace | ObjectList Constructor Overload List


ObjectList Constructor (ICollection)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal col As ICollection _
)
[C#]
public ObjectList(
   ICollection col
);
[C++]
public: ObjectList(
   ICollection* col
);
[JScript]
public function ObjectList(
   col : ICollection
);

Parameters

col
[To be supplied.]

See Also

ObjectList Class | ObjectList Members | System.Collections Namespace | ObjectList Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ObjectList Properties

The properties of the ObjectList class are listed below. For a complete list of ObjectList class members, see the ObjectList Members topic.

Public:

Count | [To be supplied.]
IsReadOnly | [To be supplied.]
IsSynchronized | [To be supplied.]
Item | [To be supplied.] In C#, this member is the indexer for the ObjectList class.
SyncRoot | [To be supplied.]

See Also

ObjectList Class | System.Collections Namespace


ObjectList.Count

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Count As Integer
[C#]
public int Count {virtual get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;

See Also

ObjectList Class | ObjectList Members | System.Collections Namespace


ObjectList.IsReadOnly

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {virtual get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;

See Also

ObjectList Class | ObjectList Members | System.Collections Namespace


ObjectList.IsSynchronized

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsSynchronized As Boolean
[C#]
public bool IsSynchronized {virtual get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;

See Also

ObjectList Class | ObjectList Members | System.Collections Namespace


ObjectList.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the ObjectList class.

[Visual Basic]
Overridable Public Default Property Item( _
   ByVal index As Integer _
) As Object
[C#]
public object this[
   int index
] {virtual get; virtual set;}
[C++]
public: __property virtual Object* get_Item(
   int index
);
public: __property virtual void set_Item(
   int index,
   Object*
);
[JScript]
returnValue = ObjectListObject.Item(index);
ObjectListObject.Item(index) = returnValue;
-or-
returnValue = ObjectListObject(index);
ObjectListObject(index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
[To be supplied.]

Parameters [Visual Basic, C#, C++]

index
[To be supplied.]

See Also

ObjectList Class | ObjectList Members | System.Collections Namespace


ObjectList.SyncRoot

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property SyncRoot As Object
[C#]
public object SyncRoot {virtual get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;

See Also

ObjectList Class | ObjectList Members | System.Collections Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ObjectList Methods

The methods of the ObjectList class are listed below. For a complete list of ObjectList class members, see the ObjectList Members topic.

Public:

Add | [To be supplied.]
Clear | [To be supplied.]
Contains | [To be supplied.]
CopyTo | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | [To be supplied.]
Insert | [To be supplied.]
Remove | [To be supplied.]
RemoveAt | [To be supplied.]
Synchronized | [To be supplied.]
ToArray | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ObjectList Class | System.Collections Namespace


ObjectList.Add

[To be supplied.]

[Visual Basic]
Overridable Public Function Add( _
   ByVal value As Object _
) As Integer
[C#]
public virtual int Add(
   object value
);
[C++]
public: virtual int Add(
   Object* value
);
[JScript]
public function Add(
   value : Object
) : int;

Parameters

value
[To be supplied.]

See Also

ObjectList Class | ObjectList Members | System.Collections Namespace


ObjectList.Clear

[To be supplied.]

[Visual Basic]
Overridable Public Sub Clear()
[C#]
public virtual void Clear();
[C++]
public: virtual void Clear();
[JScript]
public function Clear();

See Also

ObjectList Class | ObjectList Members | System.Collections Namespace


ObjectList.Contains

[To be supplied.]

[Visual Basic]
Overridable Public Function Contains( _
   ByVal value As Object _
) As Boolean
[C#]
public virtual bool Contains(
   object value
);
[C++]
public: virtual bool Contains(
   Object* value
);
[JScript]
public function Contains(
   value : Object
) : Boolean;

Parameters

value
[To be supplied.]

See Also

ObjectList Class | ObjectList Members | System.Collections Namespace


ObjectList.CopyTo

[To be supplied.]

[Visual Basic]
Overridable Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
[C#]
public virtual void CopyTo(
   Array array,
   int index
);
[C++]
public: virtual void CopyTo(
   Array* array,
   int index
);
[JScript]
public function CopyTo(
   array : Array,
   index : int
);

Parameters

array
[To be supplied.]
index
[To be supplied.]

See Also

ObjectList Class | ObjectList Members | System.Collections Namespace


ObjectList.GetEnumerator

[To be supplied.]

[Visual Basic]
Overridable Public Function GetEnumerator() As IEnumerator
[C#]
public virtual IEnumerator GetEnumerator();
[C++]
public: virtual IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

See Also

ObjectList Class | ObjectList Members | System.Collections Namespace


ObjectList.IndexOf

[To be supplied.]

[Visual Basic]
Overridable Public Function IndexOf( _
   ByVal value As Object _
) As Integer
[C#]
public virtual int IndexOf(
   object value
);
[C++]
public: virtual int IndexOf(
   Object* value
);
[JScript]
public function IndexOf(
   value : Object
) : int;

Parameters

value
[To be supplied.]

See Also

ObjectList Class | ObjectList Members | System.Collections Namespace


ObjectList.Insert

[To be supplied.]

[Visual Basic]
Overridable Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Object _
)
[C#]
public virtual void Insert(
   int index,
   object value
);
[C++]
public: virtual void Insert(
   int index,
   Object* value
);
[JScript]
public function Insert(
   index : int,
   value : Object
);

Parameters

index
[To be supplied.]
value
[To be supplied.]

See Also

ObjectList Class | ObjectList Members | System.Collections Namespace


ObjectList.Remove

[To be supplied.]

[Visual Basic]
Overridable Public Sub Remove( _
   ByVal value As Object _
)
[C#]
public virtual void Remove(
   object value
);
[C++]
public: virtual void Remove(
   Object* value
);
[JScript]
public function Remove(
   value : Object
);

Parameters

value
[To be supplied.]

See Also

ObjectList Class | ObjectList Members | System.Collections Namespace


ObjectList.RemoveAt

[To be supplied.]

[Visual Basic]
Overridable Public Sub RemoveAt( _
   ByVal index As Integer _
)
[C#]
public virtual void RemoveAt(
   int index
);
[C++]
public: virtual void RemoveAt(
   int index
);
[JScript]
public function RemoveAt(
   index : int
);

Parameters

index
[To be supplied.]

See Also

ObjectList Class | ObjectList Members | System.Collections Namespace


ObjectList.Synchronized

[To be supplied.]

[Visual Basic]
Public Shared Function Synchronized( _
   ByVal list As ObjectList _
) As ObjectList
[C#]
public static ObjectList Synchronized(
   ObjectList list
);
[C++]
public: static ObjectList* Synchronized(
   ObjectList* list
);
[JScript]
public static function Synchronized(
   list : ObjectList
) : ObjectList;

Parameters

list
[To be supplied.]

See Also

ObjectList Class | ObjectList Members | System.Collections Namespace


ObjectList.ToArray

[To be supplied.]

[Visual Basic]
Overridable Public Function ToArray() As Object ()
[C#]
public virtual object[] ToArray();
[C++]
public: virtual Object* ToArray() [];
[JScript]
public function ToArray() : Object[];

See Also

ObjectList Class | ObjectList Members | System.Collections Namespace


Queue Class

Represents a first-in-first-out collection of objects.

Object
Queue

[Visual Basic]
Public Class Queue
   Implements ICollection, IEnumerable
[C#]
public class Queue : ICollection, IEnumerable
[C++]
public __gc class Queue : public ICollection, IEnumerable
[JScript]
public class Queue implements ICollection, IEnumerable

Remarks

Objects stored in a Queue are inserted in one end and removed from the other.

Queues are useful for storing messages in the order they were received for sequential processing.

This class implements a queue as a circular array.

When the number of elements in the Queue reaches its capacity, the capacity is automatically increased to accommodate more elements.

Requirements

Namespace: System.Collections

Assembly: mscorlib.dll

See Also

Queue Members | System.Collections Namespace


Queue Members

Public:

Constructor

Queue Constructor Overloaded. Initializes a new instance of the Queue class.

Properties

Count | Gets the number of elements in the Queue.
IsReadOnly | Gets a value indicating whether the Queue is read-only.
IsSynchronized | Gets a value indicating whether access to the Queue is synchronized (thread-safe).
SyncRoot | Gets an object that can be used to synchronize access to the Queue.

Methods

Clear | Removes all objects from the Queue.
CopyTo | Copies the Queue elements into an existing one-dimensional Array, starting at the specified array index.
Dequeue | Removes and returns the object at the head of the Queue.
Enqueue | Adds an object to the tail of the Queue.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Returns an enumerator which can be used to iterate through the Queue.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Peek | Returns the object at the head of the Queue without removing it.
Synchronized | Returns a Queue wrapper that is synchronized (thread-safe).
ToArray | Copies the Queue elements into a new array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Queue Class | System.Collections Namespace


Queue Constructor

Initializes a new instance of the Queue class.

Overload List

Creates a new Queue with the default initial capacity and growth factor.

[Visual Basic] Overloads Public Sub New()
[C#] public Queue();
[C++] public: Queue();
[JScript] public function Queue();

Creates a new Queue with the specified initial capacity and the default growth factor.

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public Queue(int);
[C++] public: Queue(int);
[JScript] public function Queue(int);

Creates a new Queue with the specified initial capacity and growth factor.

[Visual Basic] Overloads Public Sub New(Integer, Single)
[C#] public Queue(int, float);
[C++] public: Queue(int, float);
[JScript] public function Queue(int, float);

Copies the elements from a collection into a new Queue with the same initial capacity as the number of elements copied, and the default growth factor.

[Visual Basic] Overloads Public Sub New(ICollection)
[C#] public Queue(ICollection);
[C++] public: Queue(ICollection*);
[JScript] public function Queue(ICollection);

See Also

Queue Class | Queue Members | System.Collections Namespace


Queue Constructor ()

Creates a new Queue with the default initial capacity and growth factor.

[Visual Basic]
Overloads Public Sub New()
[C#]
public Queue();
[C++]
public: Queue();
[JScript]
public function Queue();

Remarks

When the number of elements in the Queue reaches its capacity, the capacity is automatically increased. The new capacity is determined by multiplying the current capacity by the growth factor.

The initial capacity is the starting capacity of the new Queue.

The default initial capacity is 32 and the default growth factor is 2.0.

See Also

Queue Class | Queue Members | System.Collections Namespace | Queue Constructor Overload List


Queue Constructor (Int32)

Creates a new Queue with the specified initial capacity and the default growth factor.

[Visual Basic]
Overloads Public Sub New( _
   ByVal capacity As Integer _
)
[C#]
public Queue(
   int capacity
);
[C++]
public: Queue(
   int capacity
);
[JScript]
public function Queue(
   capacity : int
);

Parameters

capacity
The initial number of elements that the Queue can contain.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | capacity is less than (or equal to?) zero.

Remarks

When the number of elements in the Queue reaches its capacity, the capacity is automatically increased. The new capacity is determined by multiplying the current capacity by the growth factor.

The initial capacity is the starting capacity of the new Queue.

The default growth factor is 2.0.

See Also

Queue Class | Queue Members | System.Collections Namespace | Queue Constructor Overload List


Queue Constructor (Int32, Single)

Creates a new Queue with the specified initial capacity and growth factor.

[Visual Basic]
Overloads Public Sub New( _
   ByVal capacity As Integer, _
   ByVal growFactor As Single _
)
[C#]
public Queue(
   int capacity,
   float growFactor
);
[C++]
public: Queue(
   int capacity,
   float growFactor
);
[JScript]
public function Queue(
   capacity : int,
   growFactor : float
);

Parameters

capacity
The initial number of elements that the Queue can contain.
growFactor
The factor by which the Queue 's capacity is expanded.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | capacity is less than (or equal to?) zero. -or- growFactor is less than (or equal to?) 1.0 or greater than 10.0.

Remarks

When the number of elements in the Queue reaches its capacity, the capacity is automatically increased. The new capacity is determined by multiplying the current capacity by the growth factor.

The initial capacity is the starting capacity of the new Queue.

See Also

Queue Class | Queue Members | System.Collections Namespace | Queue Constructor Overload List


Queue Constructor (ICollection)

Copies the elements from a collection into a new Queue with the same initial capacity as the number of elements copied, and the default growth factor.

[Visual Basic]
Overloads Public Sub New( _
   ByVal col As ICollection _
)
[C#]
public Queue(
   ICollection col
);
[C++]
public: Queue(
   ICollection* col
);
[JScript]
public function Queue(
   col : ICollection
);

Parameters

col
The ICollection to copy elements from.

Exceptions

Exception Type | Condition
ArgumentNullException | col is a null reference (in Visual Basic Nothing).

Remarks

The order of the elements in the new Queue is the same order that the ICollection 's enumerator iterates through the ICollection 's elements.

When the number of elements in the Queue reaches its capacity, the capacity is automatically increased. The new capacity is determined by multiplying the current capacity by the growth factor.

The initial capacity is the starting capacity of the new Queue.

The default growth factor is 2.0.

See Also

Queue Class | Queue Members | System.Collections Namespace | Queue Constructor Overload List | ICollection


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Queue Properties

The properties of the Queue class are listed below. For a complete list of Queue class members, see the Queue Members topic.

Public:

Count | Gets the number of elements in the Queue.
IsReadOnly | Gets a value indicating whether the Queue is read-only.
IsSynchronized | Gets a value indicating whether access to the Queue is synchronized (thread-safe).
SyncRoot | Gets an object that can be used to synchronize access to the Queue.

See Also

Queue Class | System.Collections Namespace


Queue.Count

Gets the number of elements in the Queue.

[Visual Basic]
Overridable Public ReadOnly Property Count As Integer
[C#]
public int Count {virtual get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;

Property Value

The number of elements in the Queue.

See Also

Queue Class | Queue Members | System.Collections Namespace


Queue.IsReadOnly

Gets a value indicating whether the Queue is read-only.

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {virtual get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;

Property Value

true if the Queue is read-only; otherwise, false.

See Also

Queue Class | Queue Members | System.Collections Namespace


Queue.IsSynchronized

Gets a value indicating whether access to the Queue is synchronized (thread-safe).

[Visual Basic]
Overridable Public ReadOnly Property IsSynchronized As Boolean
[C#]
public bool IsSynchronized {virtual get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;

Property Value

true if access to the Queue is synchronized (thread-safe); otherwise, false.

See Also

Queue Class | Queue Members | System.Collections Namespace | System.Collections.Queue.IsSychronized | SyncRoot


Queue.SyncRoot

Gets an object that can be used to synchronize access to the Queue.

[Visual Basic]
Overridable Public ReadOnly Property SyncRoot As Object
[C#]
public object SyncRoot {virtual get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;

Property Value

An object that can be used to synchronize access to the Queue.

Remarks

The root object for a Queue is used when performing synchronized operations on the Queue. Instead of synchronizing directly on the Queue, program code should always synchronize on the root of the Queue. This ensures proper operation of collections that are derived from other objects; proper synchronization is maintained with other threads that might be simultaneously modifying the Queue object.

See Also

Queue Class | Queue Members | System.Collections Namespace | IsSynchronized | Synchronized


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Queue Methods

The methods of the Queue class are listed below. For a complete list of Queue class members, see the Queue Members topic.

Public:

Clear | Removes all objects from the Queue.
CopyTo | Copies the Queue elements into an existing one-dimensional Array, starting at the specified array index.
Dequeue | Removes and returns the object at the head of the Queue.
Enqueue | Adds an object to the tail of the Queue.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Returns an enumerator which can be used to iterate through the Queue.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Peek | Returns the object at the head of the Queue without removing it.
Synchronized | Returns a Queue wrapper that is synchronized (thread-safe).
ToArray | Copies the Queue elements into a new array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Queue Class | System.Collections Namespace


Queue.Clear

Removes all objects from the Queue.

[Visual Basic]
Overridable Public Sub Clear()
[C#]
public virtual void Clear();
[C++]
public: virtual void Clear();
[JScript]
public function Clear();

Return Value

None.

Remarks

This method can be overridden by a derived class.

See Also

Queue Class | Queue Members | System.Collections Namespace


Queue.CopyTo

Copies the Queue elements into an existing one-dimensional Array, starting at the specified array index.

[Visual Basic]
Overridable Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
[C#]
public virtual void CopyTo(
   Array array,
   int index
);
[C++]
public: virtual void CopyTo(
   Array* array,
   int index
);
[JScript]
public function CopyTo(
   array : Array,
   index : int
);

Parameters

array
The one-dimensional Array to paste the Queue elements into.
index
The starting index in the array.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentException | array is multidimensional. -or- The number of elements in the Queue is greater than the available space between index and the end of array.
ArgumentNullException | array is a null reference (in Visual Basic Nothing).
ArgumentOutOfRangeException | index is less than array 's lowbound.

Remarks

This method can be overridden by a derived class.

See Also

Queue Class | Queue Members | System.Collections Namespace


Queue.Dequeue

Removes and returns the object at the head of the Queue.

[Visual Basic]
Overridable Public Function Dequeue() As Object
[C#]
public virtual object Dequeue();
[C++]
public: virtual Object* Dequeue();
[JScript]
public function Dequeue() : Object;

Return Value

The object removed from the head of the Queue, if the Queue is not empty; otherwise, a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
InvalidOperationException | The Queue is empty.

Remarks

This method can be overridden by a derived class.

This method is similar to the Peek method, but Peek does not modify the Queue.

This method is an O(1) operation.

See Also

Queue Class | Queue Members | System.Collections Namespace | Enqueue | Peek


Queue.Enqueue

Adds an object to the tail of the Queue.

[Visual Basic]
Overridable Public Sub Enqueue( _
   ByVal obj As Object _
)
[C#]
public virtual void Enqueue(
   object obj
);
[C++]
public: virtual void Enqueue(
   Object* obj
);
[JScript]
public function Enqueue(
   obj : Object
);

Parameters

obj
The object to add to the Queue.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | obj is a null reference (in Visual Basic Nothing).

Remarks

This method can be overridden by a derived class.

When the number of elements in the Queue reaches its capacity, the capacity is automatically increased to accommodate more elements.

This method is an O(n) operation.

See Also

Queue Class | Queue Members | System.Collections Namespace | Dequeue | Peek


Queue.GetEnumerator

Returns an enumerator which can be used to iterate through the Queue.

[Visual Basic]
Overridable Public Function GetEnumerator() As IEnumerator
[C#]
public virtual IEnumerator GetEnumerator();
[C++]
public: virtual IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

Return Value

An IEnumerator for the Queue.

Remarks

This method can be overridden by a derived class.

The enumerator does not have exclusive access to the Queue; therefore, any changes made to the Queue may cause Current or MoveNext to throw an exception.

Removing objects from the enumerator will remove them from the Queue.

See Also

Queue Class | Queue Members | System.Collections Namespace | IEnumerator


Queue.Peek

Returns the object at the head of the Queue without removing it.

[Visual Basic]
Overridable Public Function Peek() As Object
[C#]
public virtual object Peek();
[C++]
public: virtual Object* Peek();
[JScript]
public function Peek() : Object;

Return Value

The object at the head of the Queue, if the Queue is not empty; otherwise, a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
InvalidOperationException | The Queue is empty.

Remarks

This method can be overridden by a derived class.

This method is similar to the Dequeue method, but Peek does not modify the Queue.

See Also

Queue Class | Queue Members | System.Collections Namespace | Enqueue | Dequeue


Queue.Synchronized

Returns a Queue wrapper that is synchronized (thread-safe).

[Visual Basic]
Public Shared Function Synchronized( _
   ByVal q As Queue _
) As Queue
[C#]
public static Queue Synchronized(
   Queue q
);
[C++]
public: static Queue* Synchronized(
   Queue* q
);
[JScript]
public static function Synchronized(
   q : Queue
) : Queue;

Parameters

q
The Queue to synchronize.

Return Value

A Queue wrapper that is synchronized (thread-safe).

Exceptions

Exception Type | Condition
ArgumentNullException | q is a null reference (in Visual Basic Nothing).

Remarks

To guarantee the thread-safety of the Queue, all operations must be done through this wrapper only.

See Also

Queue Class | Queue Members | System.Collections Namespace | IsSynchronized | SyncRoot


Queue.ToArray

Copies the Queue elements into a new array.

[Visual Basic]
Overridable Public Function ToArray() As Object ()
[C#]
public virtual object[] ToArray();
[C++]
public: virtual Object* ToArray() [];
[JScript]
public function ToArray() : Object[];

Return Value

A new array containing copies of the Queue 's elements.

Remarks

This method can be overridden by a derived class.

The Queue is not modified. The order of the elements in the new array is the same as the order of the elements from the Queue 's head to its tail.

See Also

Queue Class | Queue Members | System.Collections Namespace


SortedList Class

Represents a collection of associated keys and values, which are sorted by the keys and are accessible both by key and by index.

Object
SortedList

[Visual Basic]
Public Class SortedList
   Implements IDictionary, ICollection, IEnumerable, ICloneable
[C#]
public class SortedList : IDictionary, ICollection, IEnumerable,
   ICloneable
[C++]
public __gc class SortedList : public IDictionary, ICollection,
   IEnumerable, ICloneable
[JScript]
public class SortedList implements IDictionary, ICollection,
   IEnumerable, ICloneable

Remarks

A SortedList internally maintains two arrays to store the entries to the list-- one array for the keys and another array for the associated values. An entry is a key-and-value pair.

The capacity of a SortedList is the number of entries that the list can hold. As elements are added to a SortedList, the capacity is automatically increased as required through reallocation. The capacity can be decreased by calling TrimToSize or by setting the Capacity property explicitly.

The keys of a SortedList can be sorted either according to a specific IComparer implementation specified when the SortedList is instantiated, or according to the IComparable implementation provided by the keys themselves. In either case, a SortedList does not allow duplicate keys.

a null reference (in Visual Basic Nothing) is not allowed as a key, but is allowed as a value.

Requirements

Namespace: System.Collections

Assembly: mscorlib.dll

See Also

SortedList Members | System.Collections Namespace | IComparable | IComparer | IDictionary | Dictionary | Hashtable


SortedList Members

Public:

Constructor

SortedList Constructor Overloaded. Initializes a new instance of the SortedList class.

Properties

Capacity | Gets or sets the capacity of the SortedList.
Count | Gets the current number of elements in the SortedList.
IsReadOnly | Gets a value indicating whether the SortedList is read-only.
IsSynchronized | Gets a value indicating whether access to the SortedList is synchronized (thread-safe).
Item | Gets and sets the value associated with a specific key in the SortedList. In C#, this member is the indexer for the SortedList class.
Keys | Gets the keys in the SortedList.
SyncRoot | Gets an object that can be used to synchronize access to the SortedList.
Values | Gets the values in the SortedList.

Methods

Add | Adds an element with the specified key and value into the SortedList.
Clear | Removes all elements from the SortedList.
Clone | Creates a shallow copy of the SortedList.
Contains | Determines if the SortedList contains a specific key.
ContainsKey | Determines if the SortedList contains a specific key.
ContainsValue | Determines if the SortedList contains a specific value.
CopyTo | Copies the SortedList values into a one-dimensional Array instance at the specified index.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetByIndex | Retrieves the value at the specified index of the SortedList.
GetEnumerator | Returns an enumerator which can be used to iterate through the SortedList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetKey | Retrieves the key at the specified index of the SortedList.
GetKeyList | Gets the keys in the SortedList.
GetType (inherited from Object) | Gets the Type of the Object.
GetValueList | Gets the values in the SortedList.
IndexOfKey | Returns the index of the specified key in the SortedList.
IndexOfValue | Returns the index of the first occurrence of the specified value in the SortedList.
Remove | Removes the element with the specified key from SortedList.
RemoveAt | Removes the element at the specified index of SortedList.
SetByIndex | Saves the value at a specific index in the SortedList.
Synchronized | Returns a synchronized (thread-safe) wrapper for the SortedList.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements in the SortedList.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SortedList Class | System.Collections Namespace


SortedList Constructor

Initializes a new instance of the SortedList class.

Overload List

Creates an empty SortedList with an initial capacity of 16, sorted according to the IComparable interface implemented by each key added to the SortedList.

[Visual Basic] Overloads Public Sub New()
[C#] public SortedList();
[C++] public: SortedList();
[JScript] public function SortedList();

Creates an empty SortedList with the specified initial capacity, sorted according to the IComparable interface implemented by each key added to the SortedList.

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public SortedList(int);
[C++] public: SortedList(int);
[JScript] public function SortedList(int);

Creates an empty SortedList with an initial capacity of 16, sorted according to the specified IComparer interface.

[Visual Basic] Overloads Public Sub New(IComparer)
[C#] public SortedList(IComparer);
[C++] public: SortedList(IComparer*);
[JScript] public function SortedList(IComparer);

Creates an empty SortedList with the specified initial capacity, sorted according to the specified IComparer interface.

[Visual Basic] Overloads Public Sub New(IComparer, Integer)
[C#] public SortedList(IComparer, int);
[C++] public: SortedList(IComparer*, int);
[JScript] public function SortedList(IComparer, int);

Copies the entries from a dictionary to a new SortedList, sorted according to the IComparable interface implemented by each key.

[Visual Basic] Overloads Public Sub New(IDictionary)
[C#] public SortedList(IDictionary);
[C++] public: SortedList(IDictionary*);
[JScript] public function SortedList(IDictionary);

Copies the entries from a dictionary to a new SortedList, sorted according to the specified IComparer interface.

[Visual Basic] Overloads Public Sub New(IDictionary, IComparer)
[C#] public SortedList(IDictionary, IComparer);
[C++] public: SortedList(IDictionary*, IComparer);
[JScript] public function SortedList(IDictionary, IComparer);

See Also

SortedList Class | SortedList Members | System.Collections Namespace


SortedList Constructor ()

Creates an empty SortedList with an initial capacity of 16, sorted according to the IComparable interface implemented by each key added to the SortedList.

[Visual Basic]
Overloads Public Sub New()
[C#]
public SortedList();
[C++]
public: SortedList();
[JScript]
public function SortedList();

Remarks

When adding elements to the list and the number of elements exceeds the capacity, the capacity is doubled.

The elements are sorted according to the IComparable implementation of each key added to the SortedList.

See Also

SortedList Class | SortedList Members | System.Collections Namespace | SortedList Constructor Overload List | IComparable | Capacity


SortedList Constructor (Int32)

Creates an empty SortedList with the specified initial capacity, sorted according to the IComparable interface implemented by each key added to the SortedList.

[Visual Basic]
Overloads Public Sub New( _
   ByVal initialCapacity As Integer _
)
[C#]
public SortedList(
   int initialCapacity
);
[C++]
public: SortedList(
   int initialCapacity
);
[JScript]
public function SortedList(
   initialCapacity : int
);

Parameters

initialCapacity
The initial number of entries that the SortedList can contain .

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | initialCapacity is less than zero.

Remarks

When adding elements to the list and the number of elements exceeds the capacity, the capacity is doubled.

The elements are sorted according to the IComparable implementation of each key added to the SortedList.

See Also

SortedList Class | SortedList Members | System.Collections Namespace | SortedList Constructor Overload List | IComparable | Capacity


SortedList Constructor (IComparer)

Creates an empty SortedList with an initial capacity of 16, sorted according to the specified IComparer interface.

[Visual Basic]
Overloads Public Sub New( _
   ByVal comparer As IComparer _
)
[C#]
public SortedList(
   IComparer comparer
);
[C++]
public: SortedList(
   IComparer* comparer
);
[JScript]
public function SortedList(
   comparer : IComparer
);

Parameters

comparer
The IComparer implementation to use when comparing keys.

-or-

a null reference (in Visual Basic Nothing) to use the IComparable implementation of each key.

Remarks

When adding elements to the list and the number of elements exceeds the capacity, the capacity is doubled.

The elements are sorted according to the specified IComparer implementation. If comparer is a null reference (Nothing), the IComparable implementation of each key is used.

See Also

SortedList Class | SortedList Members | System.Collections Namespace | SortedList Constructor Overload List | IComparer | IComparable | Capacity


SortedList Constructor (IComparer, Int32)

Creates an empty SortedList with the specified initial capacity, sorted according to the specified IComparer interface.

[Visual Basic]
Overloads Public Sub New( _
   ByVal comparer As IComparer, _
   ByVal capacity As Integer _
)
[C#]
public SortedList(
   IComparer comparer,
   int capacity
);
[C++]
public: SortedList(
   IComparer* comparer,
   int capacity
);
[JScript]
public function SortedList(
   comparer : IComparer,
   capacity : int
);

Parameters

comparer
The IComparer implementation to use when comparing keys.

-or-

a null reference (in Visual Basic Nothing) to use the IComparable implementation of each key.

capacity
The initial number of entries that the SortedList can contain.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | initialCapacity is less than zero.

Remarks

When adding elements to the list and the number of elements exceeds the capacity, the capacity is doubled.

The elements are sorted according to the specified IComparer implementation. If comparer is a null reference (Nothing), the IComparable implementation of each key is used.

See Also

SortedList Class | SortedList Members | System.Collections Namespace | SortedList Constructor Overload List | IComparer | IComparable | Capacity


SortedList Constructor (IDictionary)

Copies the entries from a dictionary to a new SortedList, sorted according to the IComparable interface implemented by each key.

[Visual Basic]
Overloads Public Sub New( _
   ByVal d As IDictionary _
)
[C#]
public SortedList(
   IDictionary d
);
[C++]
public: SortedList(
   IDictionary* d
);
[JScript]
public function SortedList(
   d : IDictionary
);

Parameters

d
The IDictionary to copy into a new SortedList.

Exceptions

Exception Type | Condition
ArgumentNullException | d is a null reference (in Visual Basic Nothing).
InvalidCastException | One or more elements in d do not implement the IComparable interface.

Remarks

When adding elements to the list and the number of elements exceeds the capacity, the capacity is doubled.

The elements are sorted according to the IComparable implementation of each key added to the SortedList.

A Hashtable is an example of a Dictionary that can be passed to this constructor. The new SortedList will contain a copy of the keys and values stored in the Hashtable.

See Also

SortedList Class | SortedList Members | System.Collections Namespace | SortedList Constructor Overload List | IDictionary | IComparable | Dictionary | Hashtable | Capacity


SortedList Constructor (IDictionary, IComparer)

Copies the entries from a dictionary to a new SortedList, sorted according to the specified IComparer interface.

[Visual Basic]
Overloads Public Sub New( _
   ByVal d As IDictionary, _
   ByVal comparer As IComparer _
)
[C#]
public SortedList(
   IDictionary d,
   IComparer comparer
);
[C++]
public: SortedList(
   IDictionary* d,
   IComparer* comparer
);
[JScript]
public function SortedList(
   d : IDictionary,
   comparer : IComparer
);

Parameters

d
The IDictionary to copy into a new SortedList.
comparer
The IComparer implementation to use when comparing keys.

-or-

a null reference (in Visual Basic Nothing) to use the IComparable implementation of each key.

Exceptions

Exception Type | Condition
ArgumentNullException | d is a null reference (Nothing).
InvalidCastException | comparer is a null reference (Nothing), and one or more elements in d do not implement the IComparable interface.

Remarks

When adding elements to the list and the number of elements exceeds the capacity, the capacity is doubled.

The elements are sorted according to the specified IComparer implementation. If comparer is a null reference (Nothing), the IComparable implementation of each key is used.

A Hashtable is an example of a Dictionary that can be passed to this constructor. The new SortedList will contain a copy of the keys and values stored in the Hashtable.

See Also

SortedList Class | SortedList Members | System.Collections Namespace | SortedList Constructor Overload List | IDictionary | IComparer | IComparable | Dictionary | Hashtable | Capacity


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SortedList Properties

The properties of the SortedList class are listed below. For a complete list of SortedList class members, see the SortedList Members topic.

Public:

Capacity | Gets or sets the capacity of the SortedList.
Count | Gets the current number of elements in the SortedList.
IsReadOnly | Gets a value indicating whether the SortedList is read-only.
IsSynchronized | Gets a value indicating whether access to the SortedList is synchronized (thread-safe).
Item | Gets and sets the value associated with a specific key in the SortedList. In C#, this member is the indexer for the SortedList class.
Keys | Gets the keys in the SortedList.
SyncRoot | Gets an object that can be used to synchronize access to the SortedList.
Values | Gets the values in the SortedList.

See Also

SortedList Class | System.Collections Namespace


SortedList.Capacity

Gets or sets the capacity of the SortedList.

[Visual Basic]
Overridable Public Property Capacity As Integer
[C#]
public int Capacity {virtual get; virtual set;}
[C++]
public: __property virtual int get_Capacity();
public: __property virtual void set_Capacity(int);
[JScript]
public function get Capacity() : int;
public function set Capacity(int);

Property Value

The number of elements that the SortedList can contain.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | The value assigned is less than the current number of elements in the SortedList.

Remarks

When adding elements to the list and the number of elements exceeds the capacity, the capacity is doubled.

When Capacity is set, the internal arrays are reallocated to accommodate the new capacity.

TrimToSize can also be used to reduce the capacity of the SortedList.

See Also

SortedList Class | SortedList Members | System.Collections Namespace | TrimToSize


SortedList.Count

Gets the current number of elements in the SortedList.

[Visual Basic]
Overridable Public ReadOnly Property Count As Integer
[C#]
public int Count {virtual get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;

Property Value

The current number of elements in the SortedList.

See Also

SortedList Class | SortedList Members | System.Collections Namespace | Capacity


SortedList.IsReadOnly

Gets a value indicating whether the SortedList is read-only.

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {virtual get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;

Property Value

true if the SortedList is read-only; otherwise, false.

See Also

SortedList Class | SortedList Members | System.Collections Namespace


SortedList.IsSynchronized

Gets a value indicating whether access to the SortedList is synchronized (thread-safe).

[Visual Basic]
Overridable Public ReadOnly Property IsSynchronized As Boolean
[C#]
public bool IsSynchronized {virtual get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;

Property Value

true if access to the SortedList is synchronized (thread-safe); otherwise, false.

See Also

SortedList Class | SortedList Members | System.Collections Namespace | SyncRoot | Synchronized


SortedList.Item

Gets and sets the value associated with a specific key in the SortedList.

[C#] In C#, this member is the indexer for the SortedList class.

[Visual Basic]
Overridable Public Default Property Item( _
   ByVal key As Object _
) As Object
[C#]
public object this[
   object key
] {virtual get; virtual set;}
[C++]
public: __property virtual Object* get_Item(
   Object* key
);
public: __property virtual void set_Item(
   Object* key,
   Object*
);
[JScript]
returnValue = SortedListObject.Item(key);
SortedListObject.Item(key) = returnValue;
-or-
returnValue = SortedListObject(key);
SortedListObject(key) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

key
The key associated with the value to get or set.

Parameters [Visual Basic, C#, C++]

key
The key associated with the value to get or set.

Property Value

The value associated with key in the SortedList, if key is found; otherwise, a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
ArgumentNullException | key is a null reference (Nothing).

Remarks

If setting the value of key and key does not exist in the SortedList, a new entry is created with the specified key and the specified value.

A value in the SortedList can be a null reference (Nothing). To distinguish between a null that is returned because the specified key is not found and a null that is returned because the value of the specified key is a null reference (Nothing), use the Contains method or the ContainsKey method to determine if the key exists in the list.

See Also

SortedList Class | SortedList Members | System.Collections Namespace | Add | Contains | ContainsKey


SortedList.Keys

Gets the keys in the SortedList.

[Visual Basic]
Overridable Public ReadOnly Property Keys As ICollection
[C#]
public ICollection Keys {virtual get;}
[C++]
public: __property virtual ICollection* get_Keys();
[JScript]
public function get Keys() : ICollection;

Property Value

An ICollection containing the keys in the SortedList.

Remarks

Similar to GetKeyList, but returns an ICollection instead of an IList.

See Also

SortedList Class | SortedList Members | System.Collections Namespace | ICollection | Values | GetKeyList


SortedList.SyncRoot

Gets an object that can be used to synchronize access to the SortedList.

[Visual Basic]
Overridable Public ReadOnly Property SyncRoot As Object
[C#]
public object SyncRoot {virtual get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;

Property Value

An object that can be used to synchronize access to the SortedList.

Remarks

The root object for a SortedList is used when performing synchronized operations on the SortedList. Instead of synchronizing directly on a SortedList, program code should always synchronize on the root of the SortedList. This ensures proper operation of lists that are derived from other objects; proper synchronization is maintained with other threads that might be simultaneously modifying the SortedList object.

See Also

SortedList Class | SortedList Members | System.Collections Namespace | IsSynchronized | Synchronized


SortedList.Values

Gets the values in the SortedList.

[Visual Basic]
Overridable Public ReadOnly Property Values As ICollection
[C#]
public ICollection Values {virtual get;}
[C++]
public: __property virtual ICollection* get_Values();
[JScript]
public function get Values() : ICollection;

Property Value

An ICollection containing the values in the SortedList.

Remarks

Similar to GetValueList, but returns an ICollection instead of an IList.

See Also

SortedList Class | SortedList Members | System.Collections Namespace | ICollection | Keys | GetValueList


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SortedList Methods

The methods of the SortedList class are listed below. For a complete list of SortedList class members, see the SortedList Members topic.

Public:

Add | Adds an element with the specified key and value into the SortedList.
Clear | Removes all elements from the SortedList.
Clone | Creates a shallow copy of the SortedList.
Contains | Determines if the SortedList contains a specific key.
ContainsKey | Determines if the SortedList contains a specific key.
ContainsValue | Determines if the SortedList contains a specific value.
CopyTo | Copies the SortedList values into a one-dimensional Array instance at the specified index.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetByIndex | Retrieves the value at the specified index of the SortedList.
GetEnumerator | Returns an enumerator which can be used to iterate through the SortedList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetKey | Retrieves the key at the specified index of the SortedList.
GetKeyList | Gets the keys in the SortedList.
GetType (inherited from Object) | Gets the Type of the Object.
GetValueList | Gets the values in the SortedList.
IndexOfKey | Returns the index of the specified key in the SortedList.
IndexOfValue | Returns the index of the first occurrence of the specified value in the SortedList.
Remove | Removes the element with the specified key from SortedList.
RemoveAt | Removes the element at the specified index of SortedList.
SetByIndex | Saves the value at a specific index in the SortedList.
Synchronized | Returns a synchronized (thread-safe) wrapper for the SortedList.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements in the SortedList.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SortedList Class | System.Collections Namespace


SortedList.Add

Adds an element with the specified key and value into the SortedList.

[Visual Basic]
Overridable Public Sub Add( _
   ByVal key As Object, _
   ByVal value As Object _
)
[C#]
public virtual void Add(
   object key,
   object value
);
[C++]
public: virtual void Add(
   Object* key,
   Object* value
);
[JScript]
public function Add(
   key : Object,
   value : Object
);

Parameters

key
The key of the element to add.
value
The value of the element to add.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | key is a null reference (in Visual Basic Nothing).
ArgumentException | An element with the specified key already exists in the SortedList. -or- The SortedList is set to use the IComparable interface, and key does not implement the IComparable interface.

Remarks

This method can be overridden by a derived class.

When adding elements to the list and the number of elements exceeds the capacity, the capacity is doubled.The insertion point is determined based on the comparer selected, either explicitly or by default, when the SortedList was instantiated.

a null reference (Nothing) is not allowed as a key, but is allowed as a value.

See Also

SortedList Class | SortedList Members | System.Collections Namespace | Item | IComparer | IComparable | Capacity


SortedList.Clear

Removes all elements from the SortedList.

[Visual Basic]
Overridable Public Sub Clear()
[C#]
public virtual void Clear();
[C++]
public: virtual void Clear();
[JScript]
public function Clear();

Return Value

None.

Remarks

This method can be overridden by a derived class.

See Also

SortedList Class | SortedList Members | System.Collections Namespace


SortedList.Clone

Creates a shallow copy of the SortedList.

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

Return Value

A shallow copy of the SortedList.

Remarks

This method can be overridden by a derived class.

A shallow copy of an object is a copy of the object only. If the object contains references to other objects, the shallow copy will not create copies of the referred objects, but will refer to the original objects instead. On the other hand, a deep copy of an object creates a copy of the object and a copy of everything directly or indirectly referenced by that object.

See Also

SortedList Class | SortedList Members | System.Collections Namespace | CopyTo


SortedList.Contains

Determines if the SortedList contains a specific key.

[Visual Basic]
Overridable Public Function Contains( _
   ByVal key As Object _
) As Boolean
[C#]
public virtual bool Contains(
   object key
);
[C++]
public: virtual bool Contains(
   Object* key
);
[JScript]
public function Contains(
   key : Object
) : Boolean;

Parameters

key
The key to search for in the SortedList.

Return Value

true if the SortedList contains an element with the specified key; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentNullException | key is a null reference (in Visual Basic Nothing).

Remarks

This method can be overridden by a derived class.

This method uses a binary search algorithm; therefore, the average execution time is proportional to Log2 (size), where size is the size of the SortedList.

This method implements the IDictionary interface. It behaves exactly as ContainsKey.

See Also

SortedList Class | SortedList Members | System.Collections Namespace | ContainsKey | IndexOfKey


SortedList.ContainsKey

Determines if the SortedList contains a specific key.

[Visual Basic]
Overridable Public Function ContainsKey( _
   ByVal key As Object _
) As Boolean
[C#]
public virtual bool ContainsKey(
   object key
);
[C++]
public: virtual bool ContainsKey(
   Object* key
);
[JScript]
public function ContainsKey(
   key : Object
) : Boolean;

Parameters

key
The key to search for in the SortedList.

Return Value

true if the SortedList contains an element with the specified key; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentNullException | key is a null reference (in Visual Basic Nothing).

Remarks

This method can be overridden by a derived class.

This method uses a binary search algorithm; therefore, the average execution time is proportional to Log2 (size), where size is the size of the SortedList.This method behaves exactly as Contains.

See Also

SortedList Class | SortedList Members | System.Collections Namespace | Contains | ContainsValue | IndexOfKey


SortedList.ContainsValue

Determines if the SortedList contains a specific value.

[Visual Basic]
Overridable Public Function ContainsValue( _
   ByVal value As Object _
) As Boolean
[C#]
public virtual bool ContainsValue(
   object value
);
[C++]
public: virtual bool ContainsValue(
   Object* value
);
[JScript]
public function ContainsValue(
   value : Object
) : Boolean;

Parameters

value
The value to search for in the SortedList.

Return Value

true if the SortedList contains an element with the specified value; otherwise, false.

Remarks

This method can be overridden by a derived class.

The values of the elements of the SortedList are compared to the specified value using the Equals method.

This method uses a linear search; therefore, the average execution time is proportional to the size of the SortedList. That is, this implementation is an O(n) operation.

See Also

SortedList Class | SortedList Members | System.Collections Namespace | ContainsKey | IndexOfValue


SortedList.CopyTo

Copies the SortedList values into a one-dimensional Array instance at the specified index.

[Visual Basic]
Overridable Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
[C#]
public virtual void CopyTo(
   Array array,
   int index
);
[C++]
public: virtual void CopyTo(
   Array* array,
   int index
);
[JScript]
public function CopyTo(
   array : Array,
   index : int
);

Parameters

array
The one-dimensional Array to contain the SortedList values.
index
The index in array at which to start copying.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentException | array is multidimensional. -or- The number of elements in the SortedList is greater than the available space between index and the end of array.
ArgumentNullException | array is a null reference (in Visual Basic Nothing).
ArgumentOutOfRangeException | index is less than array 's lowbound.

Remarks

This method can be overridden by a derived class.

CopyTo only copies the values in the SortedList, not the keys.

The elements of the new Array are sorted in the same order as the values of the SortedList.

See Also

SortedList Class | SortedList Members | System.Collections Namespace | Array


SortedList.GetByIndex

Retrieves the value at the specified index of the SortedList.

[Visual Basic]
Overridable Public Function GetByIndex( _
   ByVal index As Integer _
) As Object
[C#]
public virtual object GetByIndex(
   int index
);
[C++]
public: virtual Object* GetByIndex(
   int index
);
[JScript]
public function GetByIndex(
   index : int
) : Object;

Parameters

index
The index of the value to retrieve.

Return Value

The value at the specified index of the SortedList.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is outside the range of valid indices for the SortedList.

Remarks

This method can be overridden by a derived class.

See Also

SortedList Class | SortedList Members | System.Collections Namespace | IndexOfKey | IndexOfValue


SortedList.GetEnumerator

Returns an enumerator which can be used to iterate through the SortedList.

[Visual Basic]
Overridable Public Function GetEnumerator() As IDictionaryEnumerator
[C#]
public virtual IDictionaryEnumerator GetEnumerator();
[C++]
public: virtual IDictionaryEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IDictionaryEnumerator;

Return Value

An IDictionaryEnumerator for the SortedList.

Remarks

This method can be overridden by a derived class.

The enumerator does not have exclusive access to the SortedList; therefore, any changes made to the SortedList may cause Current or MoveNext to throw an exception.

Removing objects from the enumerator will remove them from the SortedList.

See Also

SortedList Class | SortedList Members | System.Collections Namespace | IDictionaryEnumerator | IEnumerator


SortedList.GetKey

Retrieves the key at the specified index of the SortedList.

[Visual Basic]
Overridable Public Function GetKey( _
   ByVal index As Integer _
) As Object
[C#]
public virtual object GetKey(
   int index
);
[C++]
public: virtual Object* GetKey(
   int index
);
[JScript]
public function GetKey(
   index : int
) : Object;

Parameters

index
The index of the key to retrieve.

Return Value

The key at the specified index of the SortedList.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is outside the range of valid indices for the SortedList.

Remarks

This method can be overridden by a derived class.

See Also

SortedList Class | SortedList Members | System.Collections Namespace


SortedList.GetKeyList

Gets the keys in the SortedList.

[Visual Basic]
Overridable Public Function GetKeyList() As IList
[C#]
public virtual IList GetKeyList();
[C++]
public: virtual IList* GetKeyList();
[JScript]
public function GetKeyList() : IList;

Return Value

An IList containing the keys in the SortedList.

Remarks

This method can be overridden by a derived class.

The returned IList is a read-only view of the keys of the SortedList. Modifications made to the underlying SortedList are immediately reflected in the IList.

The elements of the returned IList are sorted in the same order as the keys of the SortedList.

Similar to Keys, but returns an IList instead of an ICollection.

See Also

SortedList Class | SortedList Members | System.Collections Namespace | IList | GetValueList | Keys


SortedList.GetValueList

Gets the values in the SortedList.

[Visual Basic]
Overridable Public Function GetValueList() As IList
[C#]
public virtual IList GetValueList();
[C++]
public: virtual IList* GetValueList();
[JScript]
public function GetValueList() : IList;

Return Value

An IList containing the values in the SortedList.

Remarks

This method can be overridden by a derived class.

The returned IList is a read-only view of the values of the SortedList. Modifications made to the underlying SortedList are immediately reflected in the IList.

The elements of the returned IList are sorted in the same order as the values of the SortedList.

Similar to Values, but returns an IList instead of an ICollection.

See Also

SortedList Class | SortedList Members | System.Collections Namespace | IList | GetKeyList | Values


SortedList.IndexOfKey

Returns the index of the specified key in the SortedList.

[Visual Basic]
Overridable Public Function IndexOfKey( _
   ByVal key As Object _
) As Integer
[C#]
public virtual int IndexOfKey(
   object key
);
[C++]
public: virtual int IndexOfKey(
   Object* key
);
[JScript]
public function IndexOfKey(
   key : Object
) : int;

Parameters

key
The key to search for in the SortedList.

Return Value

The index of key, if key is found in the SortedList; otherwise,-1.

Exceptions

Exception Type | Condition
ArgumentNullException | key is a null reference (in Visual Basic Nothing).

Remarks

This method can be overridden by a derived class.

This method uses a binary search algorithm; therefore, the average execution time is proportional to Log2 (size), where size is the size of the SortedList.

See Also

SortedList Class | SortedList Members | System.Collections Namespace | ContainsKey | IndexOfValue


SortedList.IndexOfValue

Returns the index of the first occurrence of the specified value in the SortedList.

[Visual Basic]
Overridable Public Function IndexOfValue( _
   ByVal value As Object _
) As Integer
[C#]
public virtual int IndexOfValue(
   object value
);
[C++]
public: virtual int IndexOfValue(
   Object* value
);
[JScript]
public function IndexOfValue(
   value : Object
) : int;

Parameters

value
The value to search for in the SortedList.

Return Value

The index of the first occurence of value, if value is found in the SortedList; otherwise,-1.

Remarks

This method can be overridden by a derived class.

The values of the elements of the SortedList are compared to the specified value using the Equals method.

This method uses a linear search; therefore, the average execution time is proportional to the size of the SortedList.

See Also

SortedList Class | SortedList Members | System.Collections Namespace | ContainsValue | IndexOfKey


SortedList.Remove

Removes the element with the specified key from SortedList.

[Visual Basic]
Overridable Public Sub Remove( _
   ByVal key As Object _
)
[C#]
public virtual void Remove(
   object key
);
[C++]
public: virtual void Remove(
   Object* key
);
[JScript]
public function Remove(
   key : Object
);

Parameters

key
The key of the element to remove.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | key is a null reference (in Visual Basic Nothing).

Remarks

This method can be overridden by a derived class.

See Also

SortedList Class | SortedList Members | System.Collections Namespace


SortedList.RemoveAt

Removes the element at the specified index of SortedList.

[Visual Basic]
Overridable Public Sub RemoveAt( _
   ByVal index As Integer _
)
[C#]
public virtual void RemoveAt(
   int index
);
[C++]
public: virtual void RemoveAt(
   int index
);
[JScript]
public function RemoveAt(
   index : int
);

Parameters

index
The index of the element to remove.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is outside the range of valid indices for the SortedList.

Remarks

This method can be overridden by a derived class.

See Also

SortedList Class | SortedList Members | System.Collections Namespace


SortedList.SetByIndex

Saves the value at a specific index in the SortedList.

[Visual Basic]
Overridable Public Sub SetByIndex( _
   ByVal index As Integer, _
   ByVal value As Object _
)
[C#]
public virtual void SetByIndex(
   int index,
   object value
);
[C++]
public: virtual void SetByIndex(
   int index,
   Object* value
);
[JScript]
public function SetByIndex(
   index : int,
   value : Object
);

Parameters

index
The index at which to save value.
value
The Object to save into the SortedList.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is outside the range of valid indices for the SortedList.

Remarks

This method can be overridden by a derived class.

See Also

SortedList Class | SortedList Members | System.Collections Namespace | IndexOfKey | IndexOfValue


SortedList.Synchronized

Returns a synchronized (thread-safe) wrapper for the SortedList.

[Visual Basic]
Public Shared Function Synchronized( _
   ByVal list As SortedList _
) As SortedList
[C#]
public static SortedList Synchronized(
   SortedList list
);
[C++]
public: static SortedList* Synchronized(
   SortedList* list
);
[JScript]
public static function Synchronized(
   list : SortedList
) : SortedList;

Parameters

list
The SortedList to synchronize.

Return Value

A synchronized (thread-safe) wrapper for the SortedList.

Exceptions

Exception Type | Condition
ArgumentNullException | list is a null reference (in Visual Basic Nothing).

Remarks

To guarantee the thread-safety of the SortedList, all operations must be done through this wrapper only.

See Also

SortedList Class | SortedList Members | System.Collections Namespace | IsSynchronized | SyncRoot


SortedList.TrimToSize

Sets the capacity to the actual number of elements in the SortedList.

[Visual Basic]
Overridable Public Sub TrimToSize()
[C#]
public virtual void TrimToSize();
[C++]
public: virtual void TrimToSize();
[JScript]
public function TrimToSize();

Return Value

None.

Remarks

This method can be overridden by a derived class.

This method can be used to minimize a list's memory overhead if no new elements would be added to the list.

To completely clear all elements in a list, call the Clear method before calling TrimToSize.

See Also

SortedList Class | SortedList Members | System.Collections Namespace | Clear | Capacity


Stack Class

Represents a simple queue of Object.

Object
Stack

[Visual Basic]
Public Class Stack
   Implements ICollection, IEnumerable
[C#]
public class Stack : ICollection, IEnumerable
[C++]
public __gc class Stack : public ICollection, IEnumerable
[JScript]
public class Stack implements ICollection, IEnumerable

Remarks

Stack is implemented as a circular buffer. Push is an O(n) operation; Pop is an O(1) operation.

Requirements

Namespace: System.Collections

Assembly: mscorlib.dll

See Also

Stack Members | System.Collections Namespace


Stack Members

Public:

Constructor

Stack Constructor Overloaded. Initializes a new instance of the Stack class.

Properties

Count | Gets the number of elements in the Stack.
IsReadOnly | Gets a value indicating whether the Stack is read-only.
IsSynchronized | Gets a value indicating whether access to the Stack is synchronized (thread-safe).
SyncRoot | Gets an object that can be used to synchronize access to the Stack.

Methods

Clear | Removes all objects from the Stack.
CopyTo | Copies the Stack into an existing one-dimensional Array, starting at the specified array index.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Returns an IEnumerator for the Stack.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Peek | Returns the object at the head of the Stack without removing it.
Pop | Removes and returns the object at the top of the Stack.
Push | Inserts an object at the top of the Stack.
Synchronized | Returns a synchronized (thread-safe) wrapper for the Stack.
ToArray | Copies the Stack into a new array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Stack Class | System.Collections Namespace


Stack Constructor

Initializes a new instance of the Stack class.

Overload List

Initializes an empty Stack with the default initial capacity.

[Visual Basic] Overloads Public Sub New()
[C#] public Stack();
[C++] public: Stack();
[JScript] public function Stack();

Initializes an empty Stack with the specified initial capacity or the default initial capacity, whichever is greater.

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public Stack(int);
[C++] public: Stack(int);
[JScript] public function Stack(int);

Copies the elements of a collection into a new Stack with the same capacity as the number of elements copied.

[Visual Basic] Overloads Public Sub New(ICollection)
[C#] public Stack(ICollection);
[C++] public: Stack(ICollection*);
[JScript] public function Stack(ICollection);

See Also

Stack Class | Stack Members | System.Collections Namespace


Stack Constructor ()

Initializes an empty Stack with the default initial capacity.

[Visual Basic]
Overloads Public Sub New()
[C#]
public Stack();
[C++]
public: Stack();
[JScript]
public function Stack();

Remarks

The default initial capacity for a Stack is 10.

See Also

Stack Class | Stack Members | System.Collections Namespace | Stack Constructor Overload List


Stack Constructor (Int32)

Initializes an empty Stack with the specified initial capacity or the default initial capacity, whichever is greater.

[Visual Basic]
Overloads Public Sub New( _
   ByVal initialCapacity As Integer _
)
[C#]
public Stack(
   int initialCapacity
);
[C++]
public: Stack(
   int initialCapacity
);
[JScript]
public function Stack(
   initialCapacity : int
);

Parameters

initialCapacity
The initial number of elements that the Stack can contain.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | initialCapacity is less than zero.

Remarks

The default initial capacity for a Stack is 10.

See Also

Stack Class | Stack Members | System.Collections Namespace | Stack Constructor Overload List


Stack Constructor (ICollection)

Copies the elements of a collection into a new Stack with the same capacity as the number of elements copied.

[Visual Basic]
Overloads Public Sub New( _
   ByVal col As ICollection _
)
[C#]
public Stack(
   ICollection col
);
[C++]
public: Stack(
   ICollection* col
);
[JScript]
public function Stack(
   col : ICollection
);

Parameters

col
The ICollection to copy elements from.

Exceptions

Exception Type | Condition
ArgumentNullException | col is a null reference (in Visual Basic Nothing).

Remarks

The elements are copied onto the Stack in the same order they are read by the ICollection 's IEnumerator.

See Also

Stack Class | Stack Members | System.Collections Namespace | Stack Constructor Overload List | ICollection | IEnumerator


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Stack Properties

The properties of the Stack class are listed below. For a complete list of Stack class members, see the Stack Members topic.

Public:

Count | Gets the number of elements in the Stack.
IsReadOnly | Gets a value indicating whether the Stack is read-only.
IsSynchronized | Gets a value indicating whether access to the Stack is synchronized (thread-safe).
SyncRoot | Gets an object that can be used to synchronize access to the Stack.

See Also

Stack Class | System.Collections Namespace


Stack.Count

Gets the number of elements in the Stack.

[Visual Basic]
Overridable Public ReadOnly Property Count As Integer
[C#]
public int Count {virtual get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;

Property Value

The number of elements in the Stack.

See Also

Stack Class | Stack Members | System.Collections Namespace


Stack.IsReadOnly

Gets a value indicating whether the Stack is read-only.

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {virtual get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;

Property Value

true if the Stack is read-only; otherwise, false.

See Also

Stack Class | Stack Members | System.Collections Namespace


Stack.IsSynchronized

Gets a value indicating whether access to the Stack is synchronized (thread-safe).

[Visual Basic]
Overridable Public ReadOnly Property IsSynchronized As Boolean
[C#]
public bool IsSynchronized {virtual get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;

Property Value

true if access to the Stack is synchronized (thread-safe); otherwise, false.

See Also

Stack Class | Stack Members | System.Collections Namespace


Stack.SyncRoot

Gets an object that can be used to synchronize access to the Stack.

[Visual Basic]
Overridable Public ReadOnly Property SyncRoot As Object
[C#]
public object SyncRoot {virtual get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;

Property Value

An Object that can be used to synchronize access to the Stack.

See Also

Stack Class | Stack Members | System.Collections Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Stack Methods

The methods of the Stack class are listed below. For a complete list of Stack class members, see the Stack Members topic.

Public:

Clear | Removes all objects from the Stack.
CopyTo | Copies the Stack into an existing one-dimensional Array, starting at the specified array index.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Returns an IEnumerator for the Stack.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Peek | Returns the object at the head of the Stack without removing it.
Pop | Removes and returns the object at the top of the Stack.
Push | Inserts an object at the top of the Stack.
Synchronized | Returns a synchronized (thread-safe) wrapper for the Stack.
ToArray | Copies the Stack into a new array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Stack Class | System.Collections Namespace


Stack.Clear

Removes all objects from the Stack.

[Visual Basic]
Overridable Public Sub Clear()
[C#]
public virtual void Clear();
[C++]
public: virtual void Clear();
[JScript]
public function Clear();

Return Value

None.

Remarks

This method can be overridden by a derived class.

See Also

Stack Class | Stack Members | System.Collections Namespace


Stack.CopyTo

Copies the Stack into an existing one-dimensional Array, starting at the specified array index.

[Visual Basic]
Overridable Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
[C#]
public virtual void CopyTo(
   Array array,
   int index
);
[C++]
public: virtual void CopyTo(
   Array* array,
   int index
);
[JScript]
public function CopyTo(
   array : Array,
   index : int
);

Parameters

array
The one-dimensional Array to paste the Stack elements into.
index
The starting index in array.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference (in Visual Basic Nothing).
ArgumentOutOfRangeException | index is less than the lowbound of array.
ArgumentException | array is multidimensional. -or- The number of elements in the Stack is greater than the available space between index and the end of array.

Remarks

This method can be overridden by a derived class.

See Also

Stack Class | Stack Members | System.Collections Namespace | ToArray


Stack.GetEnumerator

Returns an IEnumerator for the Stack.

[Visual Basic]
Overridable Public Function GetEnumerator() As IEnumerator
[C#]
public virtual IEnumerator GetEnumerator();
[C++]
public: virtual IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

Return Value

An IEnumerator for the Stack.

Remarks

This method can be overridden by a derived class.

See Also

Stack Class | Stack Members | System.Collections Namespace | IEnumerator


Stack.Peek

Returns the object at the head of the Stack without removing it.

[Visual Basic]
Overridable Public Function Peek() As Object
[C#]
public virtual object Peek();
[C++]
public: virtual Object* Peek();
[JScript]
public function Peek() : Object;

Return Value

The Object at the top of the Stack.

Exceptions

Exception Type | Condition
InvalidOperationException | The Stack has no elements.

Remarks

This method can be overridden by a derived class.

a null reference (in Visual Basic Nothing) can be pushed onto the Stack as a placeholder, if needed. To distinguish between a null value and the end of the stack, check the Count property or catch theInvalidOperationException, which is thrown when the Stack is empty.

See Also

Stack Class | Stack Members | System.Collections Namespace | Pop | Push


Stack.Pop

Removes and returns the object at the top of the Stack.

[Visual Basic]
Overridable Public Function Pop() As Object
[C#]
public virtual object Pop();
[C++]
public: virtual Object* Pop();
[JScript]
public function Pop() : Object;

Return Value

The Object removed from the top of the Stack.

Exceptions

Exception Type | Condition
InvalidOperationException | The Stack has no elements.

Remarks

This method can be overridden by a derived class.

Stack is implemented as a circular buffer. Push is an O(n) operation; Pop is an O(1) operation.

a null reference (in Visual Basic Nothing) can be pushed onto the Stack as a placeholder, if needed. To distinguish between a null value and the end of the stack, check the Count property or catch theInvalidOperationException, which is thrown when the Stack is empty.

Example

The following example shows a null value inserted into a stack and then retrieved.

Stack s = new Stack ();
     s.Push ("Red");
     s.Push ("Green");
     s.Push (null);
     s.Push ("Blue");
     s.Push ("Green");
     String sc;
     while (s.Count > 0)
     {
         sc = (string) s.Pop();
         Console.WriteLine (sc);
     }

See Also

Stack Class | Stack Members | System.Collections Namespace | Peek | Push


Stack.Push

Inserts an object at the top of the Stack.

[Visual Basic]
Overridable Public Sub Push( _
   ByVal obj As Object _
)
[C#]
public virtual void Push(
   object obj
);
[C++]
public: virtual void Push(
   Object* obj
);
[JScript]
public function Push(
   obj : Object
);

Parameters

obj
The Object to push onto the Stack.

Return Value

None.

Remarks

This method can be overridden by a derived class.

Stack is implemented as a circular buffer. Push is an O(n) operation; Pop is an O(1) operation.

a null reference (in Visual Basic Nothing) can be pushed onto the Stack as a placeholder, if needed. It occupies a slot in the stack and is treated like any object.

See Also

Stack Class | Stack Members | System.Collections Namespace | Peek | Pop


Stack.Synchronized

Returns a synchronized (thread-safe) wrapper for the Stack.

[Visual Basic]
Public Shared Function Synchronized( _
   ByVal stack As Stack _
) As Stack
[C#]
public static Stack Synchronized(
   Stack stack
);
[C++]
public: static Stack* Synchronized(
   Stack* stack
);
[JScript]
public static function Synchronized(
   stack : Stack
) : Stack;

Parameters

stack
The Stack to synchronize.

Return Value

A synchronized wrapper around the Stack.

Exceptions

Exception Type | Condition
ArgumentNullException | stack is a null reference (in Visual Basic Nothing).

See Also

Stack Class | Stack Members | System.Collections Namespace


Stack.ToArray

Copies the Stack into a new array.

[Visual Basic]
Overridable Public Function ToArray() As Object ()
[C#]
public virtual object[] ToArray();
[C++]
public: virtual Object* ToArray() [];
[JScript]
public function ToArray() : Object[];

Return Value

A new array containing copies of the Stack 's elements.

Remarks

This method can be overridden by a derived class.

The elements are copied onto the array in a last-in-first-out order, similar to the order a succession of calls to Pop would return the elements.

See Also

Stack Class | Stack Members | System.Collections Namespace | CopyTo | Pop


StringCollection Class

Collection of Strings

Object
StringCollection

[Visual Basic]
Public Class StringCollection
   Implements IList, ICollection, IEnumerable
[C#]
public class StringCollection : IList, ICollection, IEnumerable
[C++]
public __gc class StringCollection : public IList, ICollection,
   IEnumerable
[JScript]
public class StringCollection implements IList, ICollection,
   IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.Collections

Assembly: System.dll

See Also

StringCollection Members | System.Collections Namespace


StringCollection Members

Public:

Constructor

StringCollection Constructor [To be supplied.]

Properties

Count | [To be supplied.]
IsReadOnly | [To be supplied.]
IsSynchronized | [To be supplied.]
Item | [To be supplied.] In C#, this member is the indexer for the StringCollection class.
SyncRoot | [To be supplied.]

Methods

Add | [To be supplied.]
AddRange | [To be supplied.]
Clear | [To be supplied.]
Contains | [To be supplied.]
CopyTo | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | [To be supplied.]
Insert | [To be supplied.]
Remove | [To be supplied.]
RemoveAt | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StringCollection Class | System.Collections Namespace


StringCollection Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public StringCollection();
[C++]
public: StringCollection();
[JScript]
public function StringCollection();

See Also

StringCollection Class | StringCollection Members | System.Collections Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StringCollection Properties

The properties of the StringCollection class are listed below. For a complete list of StringCollection class members, see the StringCollection Members topic.

Public:

Count | [To be supplied.]
IsReadOnly | [To be supplied.]
IsSynchronized | [To be supplied.]
Item | [To be supplied.] In C#, this member is the indexer for the StringCollection class.
SyncRoot | [To be supplied.]

See Also

StringCollection Class | System.Collections Namespace


StringCollection.Count

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Count As Integer
[C#]
public int Count {virtual get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;

See Also

StringCollection Class | StringCollection Members | System.Collections Namespace


StringCollection.IsReadOnly

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {virtual get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;

See Also

StringCollection Class | StringCollection Members | System.Collections Namespace


StringCollection.IsSynchronized

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsSynchronized As Boolean
[C#]
public bool IsSynchronized {virtual get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;

See Also

StringCollection Class | StringCollection Members | System.Collections Namespace


StringCollection.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the StringCollection class.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As String
[C#]
public string this[
   int index
] {get; set;}
[C++]
public: __property String* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   String*
);
[JScript]
returnValue = StringCollectionObject.Item(index);
StringCollectionObject.Item(index) = returnValue;
-or-
returnValue = StringCollectionObject(index);
StringCollectionObject(index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
[To be supplied.]

Parameters [Visual Basic, C#, C++]

index
[To be supplied.]

See Also

StringCollection Class | StringCollection Members | System.Collections Namespace


StringCollection.SyncRoot

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property SyncRoot As Object
[C#]
public object SyncRoot {virtual get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;

See Also

StringCollection Class | StringCollection Members | System.Collections Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StringCollection Methods

The methods of the StringCollection class are listed below. For a complete list of StringCollection class members, see the StringCollection Members topic.

Public:

Add | [To be supplied.]
AddRange | [To be supplied.]
Clear | [To be supplied.]
Contains | [To be supplied.]
CopyTo | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | [To be supplied.]
Insert | [To be supplied.]
Remove | [To be supplied.]
RemoveAt | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StringCollection Class | System.Collections Namespace


StringCollection.Add

[To be supplied.]

[Visual Basic]
Public Function Add( _
   ByVal value As String _
) As Integer
[C#]
public int Add(
   string value
);
[C++]
public: int Add(
   String* value
);
[JScript]
public function Add(
   value : String
) : int;

Parameters

value
[To be supplied.]

See Also

StringCollection Class | StringCollection Members | System.Collections Namespace


StringCollection.AddRange

[To be supplied.]

[Visual Basic]
Public Sub AddRange( _
   ByVal value() As String _
)
[C#]
public void AddRange(
   string[] value
);
[C++]
public: void AddRange(
   String* value[]
);
[JScript]
public function AddRange(
   value : String[]
);

Parameters

value
[To be supplied.]

See Also

StringCollection Class | StringCollection Members | System.Collections Namespace


StringCollection.Clear

[To be supplied.]

[Visual Basic]
Overridable Public Sub Clear()
[C#]
public virtual void Clear();
[C++]
public: virtual void Clear();
[JScript]
public function Clear();

See Also

StringCollection Class | StringCollection Members | System.Collections Namespace


StringCollection.Contains

[To be supplied.]

[Visual Basic]
Public Function Contains( _
   ByVal value As String _
) As Boolean
[C#]
public bool Contains(
   string value
);
[C++]
public: bool Contains(
   String* value
);
[JScript]
public function Contains(
   value : String
) : Boolean;

Parameters

value
[To be supplied.]

See Also

StringCollection Class | StringCollection Members | System.Collections Namespace


StringCollection.CopyTo

[To be supplied.]

[Visual Basic]
Overridable Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
[C#]
public virtual void CopyTo(
   Array array,
   int index
);
[C++]
public: virtual void CopyTo(
   Array* array,
   int index
);
[JScript]
public function CopyTo(
   array : Array,
   index : int
);

Parameters

array
[To be supplied.]
index
[To be supplied.]

See Also

StringCollection Class | StringCollection Members | System.Collections Namespace


StringCollection.GetEnumerator

[To be supplied.]

[Visual Basic]
Overridable Public Function GetEnumerator() As IEnumerator
[C#]
public virtual IEnumerator GetEnumerator();
[C++]
public: virtual IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

See Also

StringCollection Class | StringCollection Members | System.Collections Namespace


StringCollection.IndexOf

[To be supplied.]

[Visual Basic]
Public Function IndexOf( _
   ByVal value As String _
) As Integer
[C#]
public int IndexOf(
   string value
);
[C++]
public: int IndexOf(
   String* value
);
[JScript]
public function IndexOf(
   value : String
) : int;

Parameters

value
[To be supplied.]

See Also

StringCollection Class | StringCollection Members | System.Collections Namespace


StringCollection.Insert

[To be supplied.]

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As String _
)
[C#]
public void Insert(
   int index,
   string value
);
[C++]
public: void Insert(
   int index,
   String* value
);
[JScript]
public function Insert(
   index : int,
   value : String
);

Parameters

index
[To be supplied.]
value
[To be supplied.]

See Also

StringCollection Class | StringCollection Members | System.Collections Namespace


StringCollection.Remove

[To be supplied.]

[Visual Basic]
Public Sub Remove( _
   ByVal value As String _
)
[C#]
public void Remove(
   string value
);
[C++]
public: void Remove(
   String* value
);
[JScript]
public function Remove(
   value : String
);

Parameters

value
[To be supplied.]

See Also

StringCollection Class | StringCollection Members | System.Collections Namespace


StringCollection.RemoveAt

[To be supplied.]

[Visual Basic]
Overridable Public Sub RemoveAt( _
   ByVal index As Integer _
)
[C#]
public virtual void RemoveAt(
   int index
);
[C++]
public: virtual void RemoveAt(
   int index
);
[JScript]
public function RemoveAt(
   index : int
);

Parameters

index
[To be supplied.]

See Also

StringCollection Class | StringCollection Members | System.Collections Namespace


StringTable Class

Represents an unsorted set of strings.

Object
StringTable

[Visual Basic]
Public Class StringTable
   Implements ICollection, IEnumerable
[C#]
public class StringTable : ICollection, IEnumerable
[C++]
public __gc class StringTable : public ICollection, IEnumerable
[JScript]
public class StringTable implements ICollection, IEnumerable

Remarks

The strings are internally stored as a hash table containing only keys.

Requirements

Namespace: System.Collections

Assembly: mscorlib.dll

See Also

StringTable Members | System.Collections Namespace | String | IHashCodeProvider | Hashtable


StringTable Members

Public:

Constructor

StringTable Constructor Overloaded. Initializes a new instance of the StringTable class.

Properties

Count | Gets the number of strings in the StringTable.
IsReadOnly | Gets a value indicating whether the StringTable is read-only.
IsSynchronized | Gets a value indicating whether access to the StringTable is synchronized (thread-safe).
SyncRoot | Gets an object that can be used to synchronize access to the StringTable.

Methods

Add | Adds a string to the StringTable.
Clear | Removes all strings from the StringTable.
Contains | Determines whether a specific string is in the StringTable.
CopyTo | Overloaded. Copies the strings in the StringTable into a one-dimensional array.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Returns an enumerator which can be used to iterate through the StringTable.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Remove | Removes a string from the StringTable.
Synchronized | Returns a synchronized (thread-safe) wrapper for the StringTable.
ToArray | Copies the strings in the StringTable into a new array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StringTable Class | System.Collections Namespace


StringTable Constructor

Initializes a new instance of the StringTable class.

Overload List

Creates a new StringTable with the default capacity and the default maximum load factor.

[Visual Basic] Overloads Public Sub New()
[C#] public StringTable();
[C++] public: StringTable();
[JScript] public function StringTable();

Creates a new StringTable with the specified initial capacity and the default load factor.

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public StringTable(int);
[C++] public: StringTable(int);
[JScript] public function StringTable(int);

Creates a new StringTable with the specified initial capacity and the specified load factor.

[Visual Basic] Overloads Public Sub New(Integer, Single)
[C#] public StringTable(int, float);
[C++] public: StringTable(int, float);
[JScript] public function StringTable(int, float);

See Also

StringTable Class | StringTable Members | System.Collections Namespace


StringTable Constructor ()

Creates a new StringTable with the default capacity and the default maximum load factor.

[Visual Basic]
Overloads Public Sub New()
[C#]
public StringTable();
[C++]
public: StringTable();
[JScript]
public function StringTable();

Remarks

The capacity of a StringTable is the number of elements it can contain. The default initial capacity is 11. Capacity is increased as the number of buckets is increased based on the load factor.

The maximum load factor is the maximum ratio of elements to buckets. A smaller load factor means faster lookup at the cost of increased memory consumption. The default maximum load factor is 0.73, which is the best balance between speed and size.

When the actual load factor reaches the maximum load factor, the number of buckets is automatically increased to the smallest prime number that is larger than twice the current number of buckets.

See Also

StringTable Class | StringTable Members | System.Collections Namespace | StringTable Constructor Overload List


StringTable Constructor (Int32)

Creates a new StringTable with the specified initial capacity and the default load factor.

[Visual Basic]
Overloads Public Sub New( _
   ByVal capacity As Integer _
)
[C#]
public StringTable(
   int capacity
);
[C++]
public: StringTable(
   int capacity
);
[JScript]
public function StringTable(
   capacity : int
);

Parameters

capacity
The initial number of entries that the StringTable can contain.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | capacity is less than zero.

Remarks

Specifying the initial capacity eliminates a number of resizing operations that would otherwise be performed while adding entries to the StringTable. Capacity is increased as the number of buckets is increased based on the load factor.

The maximum load factor is the maximum ratio of entries to buckets. A smaller load factor means faster lookup at the cost of increased memory consumption. The default maximum load factor is 0.73, which is the best balance between speed and size.

When the actual load factor reaches the maximum load factor, the number of buckets is automatically increased to the smallest prime number that is larger than twice the current number of buckets.

See Also

StringTable Class | StringTable Members | System.Collections Namespace | StringTable Constructor Overload List


StringTable Constructor (Int32, Single)

Creates a new StringTable with the specified initial capacity and the specified load factor.

[Visual Basic]
Overloads Public Sub New( _
   ByVal capacity As Integer, _
   ByVal loadFactor As Single _
)
[C#]
public StringTable(
   int capacity,
   float loadFactor
);
[C++]
public: StringTable(
   int capacity,
   float loadFactor
);
[JScript]
public function StringTable(
   capacity : int,
   loadFactor : float
);

Parameters

capacity
The initial number of entries that the StringTable can contain.
loadFactor
A number in the range from 0.25 through 0.95 indicating the maximum ratio of entries to buckets.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | capacity is less than zero. -or- loadfactor is less than 0.25. -or- loadfactor is greater than 0.95.

Remarks

Specifying the initial capacity eliminates a number of resizing operations that would otherwise be performed while adding entries to the StringTable. Capacity is increased as the number of buckets is increased based on the load factor.

The maximum load factor is the maximum ratio of entries to buckets. A smaller load factor means faster lookup at the cost of increased memory consumption. A maximum load factor of 0.73 is the best balance between speed and size.

When the actual load factor reaches the maximum load factor, the number of buckets is automatically increased to the smallest prime number that is larger than twice the current number of buckets.

See Also

StringTable Class | StringTable Members | System.Collections Namespace | StringTable Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StringTable Properties

The properties of the StringTable class are listed below. For a complete list of StringTable class members, see the StringTable Members topic.

Public:

Count | Gets the number of strings in the StringTable.
IsReadOnly | Gets a value indicating whether the StringTable is read-only.
IsSynchronized | Gets a value indicating whether access to the StringTable is synchronized (thread-safe).
SyncRoot | Gets an object that can be used to synchronize access to the StringTable.

See Also

StringTable Class | System.Collections Namespace


StringTable.Count

Gets the number of strings in the StringTable.

[Visual Basic]
Overridable Public ReadOnly Property Count As Integer
[C#]
public int Count {virtual get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;

Property Value

The number of strings in the StringTable.

See Also

StringTable Class | StringTable Members | System.Collections Namespace


StringTable.IsReadOnly

Gets a value indicating whether the StringTable is read-only.

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {virtual get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;

Property Value

true if the StringTable is read-only; otherwise, false.

See Also

StringTable Class | StringTable Members | System.Collections Namespace


StringTable.IsSynchronized

Gets a value indicating whether access to the StringTable is synchronized (thread-safe).

[Visual Basic]
Overridable Public ReadOnly Property IsSynchronized As Boolean
[C#]
public bool IsSynchronized {virtual get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;

Property Value

true if access to the StringTable is synchronized (thread-safe); otherwise, false.

Remarks

If you want a synchronized collection, you can use SyncRoot as an object to synchronize your collection.

See Also

StringTable Class | StringTable Members | System.Collections Namespace | SyncRoot | Synchronized


StringTable.SyncRoot

Gets an object that can be used to synchronize access to the StringTable.

[Visual Basic]
Overridable Public ReadOnly Property SyncRoot As Object
[C#]
public object SyncRoot {virtual get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;

Property Value

An object that can be used to synchronize access to the StringTable.

Remarks

The root object for a StringTable is used when performing synchronized operations on the StringTable. Instead of synchronizing directly on a StringTable, program code should always synchronize on the root of the StringTable. This ensures proper operation of string tables; proper synchronization is maintained with other threads that might be simultaneously modifying the StringTable object.

See Also

StringTable Class | StringTable Members | System.Collections Namespace | IsSynchronized | Synchronized


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StringTable Methods

The methods of the StringTable class are listed below. For a complete list of StringTable class members, see the StringTable Members topic.

Public:

Add | Adds a string to the StringTable.
Clear | Removes all strings from the StringTable.
Contains | Determines whether a specific string is in the StringTable.
CopyTo | Overloaded. Copies the strings in the StringTable into a one-dimensional array.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Returns an enumerator which can be used to iterate through the StringTable.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Remove | Removes a string from the StringTable.
Synchronized | Returns a synchronized (thread-safe) wrapper for the StringTable.
ToArray | Copies the strings in the StringTable into a new array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StringTable Class | System.Collections Namespace


StringTable.Add

Adds a string to the StringTable.

[Visual Basic]
Overridable Public Sub Add( _
   ByVal key As String _
)
[C#]
public virtual void Add(
   string key
);
[C++]
public: virtual void Add(
   String* key
);
[JScript]
public function Add(
   key : String
);

Parameters

key
The String to add to the StringTable.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | key is a null reference (in Visual Basic Nothing).

Remarks

This method can be overridden by a derived class.

If key is already in the StringTable, the default implementation replaces the existing string.

See Also

StringTable Class | StringTable Members | System.Collections Namespace | String


StringTable.Clear

Removes all strings from the StringTable.

[Visual Basic]
Overridable Public Sub Clear()
[C#]
public virtual void Clear();
[C++]
public: virtual void Clear();
[JScript]
public function Clear();

Return Value

None.

Remarks

This method can be overridden by a derived class.

See Also

StringTable Class | StringTable Members | System.Collections Namespace


StringTable.Contains

Determines whether a specific string is in the StringTable.

[Visual Basic]
Overridable Public Function Contains( _
   ByVal key As String _
) As Boolean
[C#]
public virtual bool Contains(
   string key
);
[C++]
public: virtual bool Contains(
   String* key
);
[JScript]
public function Contains(
   key : String
) : Boolean;

Parameters

key
The String to locate.

Return Value

true if key is in the StringTable; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentNullException | key is a null reference (in Visual Basic Nothing).

Remarks

This method can be overridden by a derived class.

This method is an O(1) operation.

See Also

StringTable Class | StringTable Members | System.Collections Namespace | String


StringTable.CopyTo

Copies the strings in the StringTable into a one-dimensional array.

Overload List

Copies the StringTable values into a one-dimensional Array instance at the specified index.

[Visual Basic] Overloads Overridable Public Sub CopyTo(Array, Integer)
[C#] public virtual void CopyTo(Array, int);
[C++] public: virtual void CopyTo(Array*, int);
[JScript] public function CopyTo(Array, int);

Copies the strings in the StringTable into a one-dimensional array of String objects at the specified index.

[Visual Basic] Overloads Overridable Public Sub CopyTo(String(), Integer)
[C#] public virtual void CopyTo(String[], int);
[C++] public: virtual void CopyTo(String*[], int);
[JScript] public function CopyTo(String[], int);

See Also

StringTable Class | StringTable Members | System.Collections Namespace


StringTable.CopyTo (Array, Int32)

Copies the StringTable values into a one-dimensional Array instance at the specified index.

[Visual Basic]
Overloads Overridable Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
[C#]
public virtual void CopyTo(
   Array array,
   int index
);
[C++]
public: virtual void CopyTo(
   Array* array,
   int index
);
[JScript]
public function CopyTo(
   array : Array,
   index : int
);

Parameters

array
The one-dimensional Array to contain the StringTable strings.
index
The index in array at which to start copying.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentException | The Type of array is neither String nor Object. -or- array is multidimensional. -or- The number of elements in the StringTable is greater than the available space between index and the end of array.
ArgumentNullException | array is a null reference (in Visual Basic Nothing).
ArgumentOutOfRangeException | index is less than array 's lowbound.

Remarks

This method can be overridden by a derived class.

If a string in the StringTable is a null reference (Nothing), it is skipped and not copied to array.

The order of the elements in the destination array is the same as the order of the elements in the StringTable.

See Also

StringTable Class | StringTable Members | System.Collections Namespace | StringTable.CopyTo Overload List | Array | Type | String | Object


StringTable.CopyTo (String[], Int32)

Copies the strings in the StringTable into a one-dimensional array of String objects at the specified index.

[Visual Basic]
Overloads Overridable Public Sub CopyTo( _
   ByVal array() As String, _
   ByVal index As Integer _
)
[C#]
public virtual void CopyTo(
   string[] array,
   int index
);
[C++]
public: virtual void CopyTo(
   String* array[],
   int index
);
[JScript]
public function CopyTo(
   array : String[],
   index : int
);

Parameters

array
The one-dimensional array of String objects to contain the strings from the StringTable.
index
The index in array at which to start copying.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentException | The Type of array is neither String nor Object. -or- array is multidimensional. -or- The number of elements in the StringTable is greater than the available space between index and the end of array.
ArgumentNullException | array is a null reference (in Visual Basic Nothing).
ArgumentOutOfRangeException | index is less than array 's lowbound.

Remarks

This method can be overridden by a derived class.

If a string in the StringTable is a null reference (Nothing), it is skipped and not copied to array.

The order of the elements in the destination array is the same as the order of the elements in the StringTable.

See Also

StringTable Class | StringTable Members | System.Collections Namespace | StringTable.CopyTo Overload List | Array | Type | String | Object


StringTable.GetEnumerator

Returns an enumerator which can be used to iterate through the StringTable.

[Visual Basic]
Overridable Public Function GetEnumerator() As IEnumerator
[C#]
public virtual IEnumerator GetEnumerator();
[C++]
public: virtual IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

Return Value

An IEnumerator for the StringTable.

Remarks

This method can be overridden by a derived class.

The enumerator does not have exclusive access to the StringTable; therefore, any changes made to the StringTable may cause Current or MoveNext to throw an exception.

Removing objects from the enumerator will remove them from the StringTable.

See Also

StringTable Class | StringTable Members | System.Collections Namespace | IEnumerator


StringTable.Remove

Removes a string from the StringTable.

[Visual Basic]
Overridable Public Sub Remove( _
   ByVal key As String _
)
[C#]
public virtual void Remove(
   string key
);
[C++]
public: virtual void Remove(
   String* key
);
[JScript]
public function Remove(
   key : String
);

Parameters

key
The String to remove from the StringTable.

Return Value

None.

Exceptions

Exception Type | Condition
ArgumentNullException | key is a null reference (in Visual Basic Nothing).

Remarks

This method can be overridden by a derived class.

See Also

StringTable Class | StringTable Members | System.Collections Namespace | String


StringTable.Synchronized

Returns a synchronized (thread-safe) wrapper for the StringTable.

[Visual Basic]
Public Shared Function Synchronized( _
   ByVal st As StringTable _
) As StringTable
[C#]
public static StringTable Synchronized(
   StringTable st
);
[C++]
public: static StringTable* Synchronized(
   StringTable* st
);
[JScript]
public static function Synchronized(
   st : StringTable
) : StringTable;

Parameters

st
The StringTable to synchronize.

Return Value

A StringTable wrapper that is synchronized (thread-safe).

Exceptions

Exception Type | Condition
ArgumentNullException | st is a null reference (in Visual Basic Nothing).

Remarks

To guarantee the thread-safety of the StringTable, all operations must be done through this wrapper only.

See Also

StringTable Class | StringTable Members | System.Collections Namespace | SyncRoot | IsSynchronized


StringTable.ToArray

Copies the strings in the StringTable into a new array.

[Visual Basic]
Overridable Public Function ToArray() As String ()
[C#]
public virtual string[] ToArray();
[C++]
public: virtual String* ToArray() [];
[JScript]
public function ToArray() : String[];

Return Value

An array of String objects containing copies of the strings from the StringTable.

Remarks

This method can be overridden by a derived class.

The order of the elements in the new array is the same as the order of the elements in the StringTable.

See Also

StringTable Class | StringTable Members | System.Collections Namespace | String


System.Collections.Bases

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Collections.Bases Namespace

Classes

Class | Description
TypedCollectionBase | [To be supplied.]
TypedReadonlyCollectionBase | [To be supplied.]


TypedCollectionBase Class

[To be supplied.]

Object
TypedCollectionBase

[Visual Basic]
MustInherit Public Class TypedCollectionBase
   Implements IList, ICollection, IEnumerable
[C#]
public abstract class TypedCollectionBase : IList, ICollection,
   IEnumerable
[C++]
public __gc __abstract class TypedCollectionBase : public IList,
   ICollection, IEnumerable
[JScript]
public abstract class TypedCollectionBase implements IList,
   ICollection, IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.Collections.Bases

Assembly: System.dll

See Also

TypedCollectionBase Members | System.Collections.Bases Namespace


TypedCollectionBase Members

Public:

Constructor

TypedCollectionBase Constructor [To be supplied.]

Properties

Count [To be supplied.]

Methods

Clear | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
RemoveAt | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

InnerList | [To be supplied.]
List | [To be supplied.]

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear | [To be supplied.]
OnInsert | [To be supplied.]
OnRemove | [To be supplied.]
OnSet | [To be supplied.]
OnValidate | [To be supplied.]

See Also

TypedCollectionBase Class | System.Collections.Bases Namespace


TypedCollectionBase Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public TypedCollectionBase();
[C++]
public: TypedCollectionBase();
[JScript]
public function TypedCollectionBase();

See Also

TypedCollectionBase Class | TypedCollectionBase Members | System.Collections.Bases Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypedCollectionBase Properties

The properties of the TypedCollectionBase class are listed below. For a complete list of TypedCollectionBase class members, see the TypedCollectionBase Members topic.

Public:

Count [To be supplied.]

Protected:

InnerList | [To be supplied.]
List | [To be supplied.]

See Also

TypedCollectionBase Class | System.Collections.Bases Namespace


TypedCollectionBase.Count

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Count As Integer
[C#]
public int Count {virtual get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;

See Also

TypedCollectionBase Class | TypedCollectionBase Members | System.Collections.Bases Namespace


TypedCollectionBase.InnerList

[To be supplied.]

[Visual Basic]
Protected ReadOnly Property InnerList As ArrayList
[C#]
protected ArrayList InnerList {get;}
[C++]
protected: __property ArrayList* get_InnerList();
[JScript]
protected function get InnerList() : ArrayList;

See Also

TypedCollectionBase Class | TypedCollectionBase Members | System.Collections.Bases Namespace


TypedCollectionBase.List

[To be supplied.]

[Visual Basic]
Protected ReadOnly Property List As IList
[C#]
protected IList List {get;}
[C++]
protected: __property IList* get_List();
[JScript]
protected function get List() : IList;

See Also

TypedCollectionBase Class | TypedCollectionBase Members | System.Collections.Bases Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypedCollectionBase Methods

The methods of the TypedCollectionBase class are listed below. For a complete list of TypedCollectionBase class members, see the TypedCollectionBase Members topic.

Public:

Clear | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
RemoveAt | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear | [To be supplied.]
OnInsert | [To be supplied.]
OnRemove | [To be supplied.]
OnSet | [To be supplied.]
OnValidate | [To be supplied.]

See Also

TypedCollectionBase Class | System.Collections.Bases Namespace


TypedCollectionBase.Clear

[To be supplied.]

[Visual Basic]
Overridable Public Sub Clear()
[C#]
public virtual void Clear();
[C++]
public: virtual void Clear();
[JScript]
public function Clear();

See Also

TypedCollectionBase Class | TypedCollectionBase Members | System.Collections.Bases Namespace


TypedCollectionBase.GetEnumerator

[To be supplied.]

[Visual Basic]
Overridable Public Function GetEnumerator() As IEnumerator
[C#]
public virtual IEnumerator GetEnumerator();
[C++]
public: virtual IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

See Also

TypedCollectionBase Class | TypedCollectionBase Members | System.Collections.Bases Namespace


TypedCollectionBase.OnClear

[To be supplied.]

[Visual Basic]
Overridable Protected Sub OnClear()
[C#]
protected virtual void OnClear();
[C++]
protected: virtual void OnClear();
[JScript]
protected function OnClear();

See Also

TypedCollectionBase Class | TypedCollectionBase Members | System.Collections.Bases Namespace


TypedCollectionBase.OnInsert

[To be supplied.]

[Visual Basic]
Overridable Protected Sub OnInsert( _
   ByVal index As Integer, _
   ByVal value As Object _
)
[C#]
protected virtual void OnInsert(
   int index,
   object value
);
[C++]
protected: virtual void OnInsert(
   int index,
   Object* value
);
[JScript]
protected function OnInsert(
   index : int,
   value : Object
);

Parameters

index
[To be supplied.]
value
[To be supplied.]

See Also

TypedCollectionBase Class | TypedCollectionBase Members | System.Collections.Bases Namespace


TypedCollectionBase.OnRemove

[To be supplied.]

[Visual Basic]
Overridable Protected Sub OnRemove( _
   ByVal index As Integer, _
   ByVal value As Object _
)
[C#]
protected virtual void OnRemove(
   int index,
   object value
);
[C++]
protected: virtual void OnRemove(
   int index,
   Object* value
);
[JScript]
protected function OnRemove(
   index : int,
   value : Object
);

Parameters

index
[To be supplied.]
value
[To be supplied.]

See Also

TypedCollectionBase Class | TypedCollectionBase Members | System.Collections.Bases Namespace


TypedCollectionBase.OnSet

[To be supplied.]

[Visual Basic]
Overridable Protected Sub OnSet( _
   ByVal index As Integer, _
   ByVal oldValue As Object, _
   ByVal newValue As Object _
)
[C#]
protected virtual void OnSet(
   int index,
   object oldValue,
   object newValue
);
[C++]
protected: virtual void OnSet(
   int index,
   Object* oldValue,
   Object* newValue
);
[JScript]
protected function OnSet(
   index : int,
   oldValue : Object,
   newValue : Object
);

Parameters

index
[To be supplied.]
oldValue
[To be supplied.]
newValue
[To be supplied.]

See Also

TypedCollectionBase Class | TypedCollectionBase Members | System.Collections.Bases Namespace


TypedCollectionBase.OnValidate

[To be supplied.]

[Visual Basic]
Overridable Protected Sub OnValidate( _
   ByVal value As Object _
)
[C#]
protected virtual void OnValidate(
   object value
);
[C++]
protected: virtual void OnValidate(
   Object* value
);
[JScript]
protected function OnValidate(
   value : Object
);

Parameters

value
[To be supplied.]

See Also

TypedCollectionBase Class | TypedCollectionBase Members | System.Collections.Bases Namespace


TypedCollectionBase.RemoveAt

[To be supplied.]

[Visual Basic]
Overridable Public Sub RemoveAt( _
   ByVal index As Integer _
)
[C#]
public virtual void RemoveAt(
   int index
);
[C++]
public: virtual void RemoveAt(
   int index
);
[JScript]
public function RemoveAt(
   index : int
);

Parameters

index
[To be supplied.]

See Also

TypedCollectionBase Class | TypedCollectionBase Members | System.Collections.Bases Namespace


TypedReadonlyCollectionBase Class

[To be supplied.]

Object
TypedReadonlyCollectionBase

[Visual Basic]
MustInherit Public Class TypedReadonlyCollectionBase
   Implements ICollection, IEnumerable
[C#]
public abstract class TypedReadonlyCollectionBase : ICollection,
   IEnumerable
[C++]
public __gc __abstract class TypedReadonlyCollectionBase : public
   ICollection, IEnumerable
[JScript]
public abstract class TypedReadonlyCollectionBase implements
   ICollection, IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.Collections.Bases

Assembly: System.dll

See Also

TypedReadonlyCollectionBase Members | System.Collections.Bases Namespace


TypedReadonlyCollectionBase Members

Public:

Constructor

TypedReadonlyCollectionBase Constructor [To be supplied.]

Properties

Count [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

InnerList | [To be supplied.]
List | [To be supplied.]

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypedReadonlyCollectionBase Class | System.Collections.Bases Namespace


TypedReadonlyCollectionBase Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public TypedReadonlyCollectionBase();
[C++]
public: TypedReadonlyCollectionBase();
[JScript]
public function TypedReadonlyCollectionBase();

See Also

TypedReadonlyCollectionBase Class | TypedReadonlyCollectionBase Members | System.Collections.Bases Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypedReadonlyCollectionBase Properties

The properties of the TypedReadonlyCollectionBase class are listed below. For a complete list of TypedReadonlyCollectionBase class members, see the TypedReadonlyCollectionBase Members topic.

Public:

Count [To be supplied.]

Protected:

InnerList | [To be supplied.]
List | [To be supplied.]

See Also

TypedReadonlyCollectionBase Class | System.Collections.Bases Namespace


TypedReadonlyCollectionBase.Count

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Count As Integer
[C#]
public int Count {virtual get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;

See Also

TypedReadonlyCollectionBase Class | TypedReadonlyCollectionBase Members | System.Collections.Bases Namespace


TypedReadonlyCollectionBase.InnerList

[To be supplied.]

[Visual Basic]
Protected ReadOnly Property InnerList As ArrayList
[C#]
protected ArrayList InnerList {get;}
[C++]
protected: __property ArrayList* get_InnerList();
[JScript]
protected function get InnerList() : ArrayList;

See Also

TypedReadonlyCollectionBase Class | TypedReadonlyCollectionBase Members | System.Collections.Bases Namespace


TypedReadonlyCollectionBase.List

[To be supplied.]

[Visual Basic]
Protected ReadOnly Property List As IList
[C#]
protected IList List {get;}
[C++]
protected: __property IList* get_List();
[JScript]
protected function get List() : IList;

See Also

TypedReadonlyCollectionBase Class | TypedReadonlyCollectionBase Members | System.Collections.Bases Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypedReadonlyCollectionBase Methods

The methods of the TypedReadonlyCollectionBase class are listed below. For a complete list of TypedReadonlyCollectionBase class members, see the TypedReadonlyCollectionBase Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypedReadonlyCollectionBase Class | System.Collections.Bases Namespace


TypedReadonlyCollectionBase.GetEnumerator

[To be supplied.]

[Visual Basic]
Overridable Public Function GetEnumerator() As IEnumerator
[C#]
public virtual IEnumerator GetEnumerator();
[C++]
public: virtual IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

See Also

TypedReadonlyCollectionBase Class | TypedReadonlyCollectionBase Members | System.Collections.Bases Namespace


System.ComponentModel

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.ComponentModel Namespace

Classes

Class | Description
ArrayConverter | Provides a type converter to convert Array objects to and from various other representations.
BindableAttribute | Specifies whether a property is appropriate to bind data to.
BooleanConverter | Provides a type converter to convert boolean objects to and from various other representations.
BrowsableAttribute | Specifies whether a property, or event can be modified at design time.
ByteConverter | Provides a type converter to convert byte objects to and from various other representations.
CancelEventArgs | Provides data for the Cancel event.
CategoryAttribute | Specifies the category in which the property or event will be displayed in a visual designer.
CharConverter | Provides a type converter to convert character objects to and from various other representations.
CollectionConverter | Provides a type converter to convert Collection objects to and from various other representations.
Component | Provides an abstraction that enables object-sharing between applications.
ComponentConverter | Provides a type converter to convert Component objects to and from various other representations. This class adds support for properties on a component.
ComponentEditorAttribute | Specifies the editor to use to change a component.
Container | Encapsulates zero or more components.
CultureInfoConverter | Provides a type converter to convert CultureInfo objects to and from various other representations.
CurrencyConverter | Provides a type converter to convert Currency objects to and from various other representations.
DateTimeConverter | Provides a type converter to convert DateTime objects to and from various other representations.
DecimalConverter | Provides a type converter to convert decimal objects to and from various other representations.
DefaultEventAttribute | Specifies the default event for a component.
DefaultPropertyAttribute | Specifies the default property for a component.
DefaultValueAttribute | Specifies the default value for a property.
DescriptionAttribute | Specifies a description for a property or event.
DesignerAttribute | Specifies the class to use to implement design-time services.
DesignerCategoryAttribute | Specifies that the designer for a class belongs to a certain category.
DesignOnlyAttribute | Specifies that a property can be set only at design time.
DoubleConverter | Provides a type converter to convert double objects to and from various other representations.
EditorAttribute | Specifies the editor to use to change a property.
EnumConverter | Provides a type converter to convert enum objects to and from various other representations.
EventDescriptor | Provides a description of an event.
EventDescriptorAttribute | Specifies that the property was originally an event and provides the event information.
EventDescriptorCollection | Represents a collection of events.
ExpandableObjectConverter | Provides a type converter to convert objects to and from various other representations. This class adds support for the properties of the object.
ExtenderPropertyAttribute | Specifies which components can accept the extender.
GuidConverter | Provides a type converter to convert Guid objects to and from various other representations.
HelpAttribute | Specifies Help file and Help topic for a property or event. A visual designer can use this information to provide help for the member.
Int16Converter | Provides a type converter to convert 16-bit signed integer objects to and from various other representations.
Int32Converter | Provides a type converter to convert 32-bit signed integer objects to and from various other representations.
Int64Converter | Provides a type converter to convert 64-bit signed integer objects to and from various other representations.
License | Provides the abstract (in Visual Basic MustInherit) base class for all licenses. A license is granted to a specific instance of a component.
LicenseContext | Specifies when the licensed object can be used.
LicenseException | Represents the exception thrown when a component cannot be granted a license.
LicenseManager | Provides properties and methods to add a license to a component and to manage a LicenseProvider. This class cannot be inherited.
LicenseProvider | Provides the abstract (MustInherit) base class for implementing a LicenseProvider.
LicenseProviderAttribute | Specifies the LicenseProvider to use with a class.
LicFileLicenseProvider | Provides an implementation of a LicenseProvider. The provider works in a similar fashion to Microsoft's standard NGWS licensing module.
LocalizableAttribute | Specifies whether a property or extender should be localized.
MarshalByRefComponent | Represents the base implementation for IComponent, which is the base for all components in WinForms. A component can be hosted in a container. For each component in a container, the container creates a site that it uses to manage the component.
MemberAttribute | Defines basic functions for all attributes. MemberAttribute is the abstract (MustInherit) base class from which all other attribute classes derive.
MemberAttributeCollection | Represents a collection of attributes.
MemberDescriptor | Declares an array of attributes for a member and defines the properties and methods that give you access to the attributes in the array. All attributes must derive from MemberAttribute.
MergablePropertyAttribute | Specifies that this property can be combined with properties belonging to other objects in a property browser.
NotificationAttribute | Specifies whether a property should send notification events when changed.
ObjectDisposedException | ObjectDisposedExceptions are thrown when an object is accessed that has been disposed. Once objects have been disposed, they normally cannot be used.
PersistableAttribute | Specifies which values are saved for a property, or event.
PersistContentsAttribute | Specifies whether a visual designer must generate special code to persist the value of a property.
PersisterAttribute | Specifies what class to use as a value persister.
PersistInfo | The PersistInfo class defines a generic way to persist an object's values.
PropertyChangedEventArgs | Provides data for the OnPropertyChanged event.
PropertyDescriptor | Provides a description of a property.
PropertyDescriptorCollection | Represents a collection of properties.
ProvidePropertyAttribute | Specifies which methods are extender properties.
ReadOnlyAttribute | Specifies that a property is read-only.
RecommendedAsConfigurableAttribute | Specifies that the property could be used as an application setting.
ReferenceConverter | Provides a type converter to convert object references to and from various other representations.
RefreshEventArgs | Provides data for the Refresh event.
RunInstallerAttribute | Specifies whether an installer should be invoked during installation of an assembly.
ServerExplorerBrowsableAttribute | Specifies whether a property or event can be modified at design time in the server explorer.
ServerExplorerReadOnlyAttribute | Specifies that a property is read-only in the server explorer.
SingleConverter | Provides a type converter to convert single objects to and from various other representations.
StringConverter | Provides a type converter to convert string objects to and from various other representations.
SyntaxCheck | [To be supplied.]
TimeSpanConverter | Provides a type converter to convert TimeSpan objects to and from various other representations.
TypeConverter | Converts the value of an object into a different data type.
TypeConverter.StandardValuesCollection | Represents a collection of values.
TypeConverterAttribute | Specifies what type to use as a converter for values.
TypeDescriptor | Provides information about the properties and events for a component. This class cannot be inherited.
TypeListConverter | TypeListConverter is a class that can be used select type from a list. It is abstract, and you must provide your own list of types. rectangles from one data type to another. Access this class through the TypeDescriptor.
ValidatingEventArgs | [To be supplied.]

Interfaces

Interface | Description
IComponent | Provides functionality required by all components.
IContainer | Provides functionality for containers. Containers are objects that logically contain zero or more components.
ICustomTypeDescriptor | [To be supplied.]
IExtenderProvider | Defines the interface for extending properties to other components in a container.
ISite | Provides functionality required by sites. Sites bind a Component to a Container and enable communication between them, as well as provide a way for the container to manage its components.
ISupportInitialize | Specifies that this object supports a simple, transacted notification for batch initialization.
ISynchronizeInvoke | [To be supplied.]
ITypeDescriptorContext | Provides a context to a value formatter, so that the value formatter can perform a conversion.
IValueAccess | [To be supplied.]

Delegates

Delegate | Description
CancelEventHandler | Represents the method that will handle the event raised when canceling an event.
PropertyChangedEventHandler | Represents the method that will handle the PropertyChanged XXX event raised when a property is changed on a component.
RefreshEventHandler | Represents the method that will handle the Refresh event raised when a Type or component is changed during design time.
ValidatingEventHandler | [To be supplied.]

Enumerations

Enumeration | Description
LicenseUsageMode | Specifies when the license can be used.
PersistableSupport | Specifies which values to save for a property or event.


ArrayConverter Class

Provides a type converter to convert Array objects to and from various other representations.

Object
TypeConverter
CollectionConverter
ArrayConverter

[Visual Basic]
Public Class ArrayConverter
   Inherits CollectionConverter
[C#]
public class ArrayConverter : CollectionConverter
[C++]
public __gc class ArrayConverter : public CollectionConverter
[JScript]
public class ArrayConverter extends CollectionConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace


BindableAttribute Class

Specifies whether a property is appropriate to bind data to.

Object
Attribute
MemberAttribute
BindableAttribute

[Visual Basic]
Public Class BindableAttribute
   Inherits MemberAttribute
[C#]
public class BindableAttribute : MemberAttribute
[C++]
public __gc class BindableAttribute : public MemberAttribute
[JScript]
public class BindableAttribute extends MemberAttribute

Remarks

A data binder typically makes available only the properties marked with Bindable(true). If the property has no bindable attribute or is marked with Bindable(false), then it is not appropriate for binding. The default is false.

Note When you mark a property with Bindable(true), the value of this attribute is set to the constant member BindableAttribute.Yes. For a property marked with Bindable(false), the value is BindableAttribute.No. Therefore, when you want to check the value of this attribute in your code, you must specify the attribute as BindableAttribute.Yes or BindableAttribute.No.

For more information, see TBD and TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | MemberAttribute | PropertyDescriptor | EventDescriptor


BooleanConverter Class

Provides a type converter to convert boolean objects to and from various other representations.

Object
TypeConverter
BooleanConverter

[Visual Basic]
Public Class BooleanConverter
   Inherits TypeConverter
[C#]
public class BooleanConverter : TypeConverter
[C++]
public __gc class BooleanConverter : public TypeConverter
[JScript]
public class BooleanConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace


BrowsableAttribute Class

Specifies whether a property, or event can be modified at design time.

Object
Attribute
MemberAttribute
BrowsableAttribute

[Visual Basic]
Public Class BrowsableAttribute
   Inherits MemberAttribute
[C#]
public class BrowsableAttribute : MemberAttribute
[C++]
public __gc class BrowsableAttribute : public MemberAttribute
[JScript]
public class BrowsableAttribute extends MemberAttribute

Remarks

A visual designer typically displays in the property browser those members that either have no browsable attribute or are marked with Browsable(true). These members can be modified at design time. Members marked with Browsable(false) are not appropriate for design-time editing and therefore are not displayed in a visual designer. The default is true.

Note When you mark a property with Browsable(true), the value of this attribute is set to the constant member BrowsableAttribute.Yes. For a property marked with Browsable(false), the value is BrowsableAttribute.No. Therefore, when you want to check the value of this attribute in your code, you must specify the attribute as BrowsableAttribute.Yes or BrowsableAttribute.No.

For more information, see TBD and TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | MemberAttribute | PropertyDescriptor | EventDescriptor


ByteConverter Class

Provides a type converter to convert byte objects to and from various other representations.

Object
TypeConverter
ByteConverter

[Visual Basic]
Public Class ByteConverter
   Inherits TypeConverter
[C#]
public class ByteConverter : TypeConverter
[C++]
public __gc class ByteConverter : public TypeConverter
[JScript]
public class ByteConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace


CancelEventArgs Class

Provides data for the Cancel event.

Object
EventArgs
CancelEventArgs

[Visual Basic]
Public Class CancelEventArgs
   Inherits EventArgs
[C#]
public class CancelEventArgs : EventArgs
[C++]
public __gc class CancelEventArgs : public EventArgs
[JScript]
public class CancelEventArgs extends EventArgs

Remarks

A Cancel event is raised by a component when you want cancel a particular operation. A CancelEventArgs object specifies whether the operation should be canceled.

CancelEventArgs provides the Cancel property to get or set whether the event should be canceled.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

CancelEventArgs Members | System.ComponentModel Namespace | CancelEventHandler


CancelEventArgs Members

Public:

Constructor

CancelEventArgs Constructor Overloaded. Initializes a new instance of the CancelEventArgs class.

Properties

Cancel | Gets or sets a value indicating whether the operation should be cancelled.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CancelEventArgs Class | System.ComponentModel Namespace


CancelEventArgs Constructor

[To be supplied.]

Overload List

Initializes a new instance of the CancelEventArgs class with cancel set to false.

[Visual Basic] Overloads Public Sub New()
[C#] public CancelEventArgs();
[C++] public: CancelEventArgs();
[JScript] public function CancelEventArgs();

Initializes a new instance of the CancelEventArgs class with cancel set to the given value.

[Visual Basic] Overloads Public Sub New(Boolean)
[C#] public CancelEventArgs(bool);
[C++] public: CancelEventArgs(bool);
[JScript] public function CancelEventArgs(Boolean);

See Also

CancelEventArgs Class | CancelEventArgs Members | System.ComponentModel Namespace


CancelEventArgs Constructor ()

Initializes a new instance of the CancelEventArgs class with cancel set to false.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CancelEventArgs();
[C++]
public: CancelEventArgs();
[JScript]
public function CancelEventArgs();

See Also

CancelEventArgs Class | CancelEventArgs Members | System.ComponentModel Namespace | CancelEventArgs Constructor Overload List | CancelEventHandler


CancelEventArgs Constructor (Boolean)

Initializes a new instance of the CancelEventArgs class with cancel set to the given value.

[Visual Basic]
Overloads Public Sub New( _
   ByVal cancel As Boolean _
)
[C#]
public CancelEventArgs(
   bool cancel
);
[C++]
public: CancelEventArgs(
   bool cancel
);
[JScript]
public function CancelEventArgs(
   cancel : Boolean
);

Parameters

cancel
true to cancel; otherwise, false.

See Also

CancelEventArgs Class | CancelEventArgs Members | System.ComponentModel Namespace | CancelEventArgs Constructor Overload List | CancelEventHandler


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CancelEventArgs Properties

The properties of the CancelEventArgs class are listed below. For a complete list of CancelEventArgs class members, see the CancelEventArgs Members topic.

Public:

Cancel | Gets or sets a value indicating whether the operation should be cancelled.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.

See Also

CancelEventArgs Class | System.ComponentModel Namespace


CancelEventArgs.Cancel

Gets or sets a value indicating whether the operation should be cancelled.

[Visual Basic]
Public Property Cancel As Boolean
[C#]
public bool Cancel {get; set;}
[C++]
public: __property bool get_Cancel();
public: __property void set_Cancel(bool);
[JScript]
public function get Cancel() : Boolean;
public function set Cancel(Boolean);

Property Value

true if the operation should be cancelled; otherwise, false.

See Also

CancelEventArgs Class | CancelEventArgs Members | System.ComponentModel Namespace


CancelEventHandler Delegate

Represents the method that will handle the event raised when canceling an event.

[Visual Basic]
Public Delegate Sub CancelEventHandler( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
)
[C#]
public delegate void CancelEventHandler(
   object sender,
   CancelEventArgs e
);
[C++]
public __gc __delegate void CancelEventHandler(
   Object* sender,
   CancelEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the CancelEventHandler delegate declaration.

sender
The source of the event.
e
A CancelEventArgs that contains the event data.

Remarks

When you create a CancelEventHandler delegate, you identify the method that will handle the event. To associate the event with your event-handling method, add an instance of the delegate to the event. The event-handler method is called whenever the event occurs, unless you remove the delegate. For more information about event handler delegates, see TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | CancelEventArgs


CategoryAttribute Class

Specifies the category in which the property or event will be displayed in a visual designer.

Object
Attribute
MemberAttribute
CategoryAttribute

[Visual Basic]
Public Class CategoryAttribute
   Inherits MemberAttribute
[C#]
public class CategoryAttribute : MemberAttribute
[C++]
public __gc class CategoryAttribute : public MemberAttribute
[JScript]
public class CategoryAttribute extends MemberAttribute

Remarks

A visual designer can use categories to organize members into groups of similar behavior. A category can be created for any name. The CategoryAttribute class defines the following common categories:

Category | Description
Appearance | Properties affecting how an entity looks.
Behavior | Properties that affect how an entity acts.
Data | Properties concerning data.
Design | Properties that are available only at design time.
Action | Properties regarding available actions.
Format | Properties that affect format.
Layout | Properties concerning layout.
Mouse | Properties pertaining to the mouse.
Key | Properties affecting the keyboard.
Focus | Properties pertaining to focus.
Window Style | Properties affecting the window style of top-level forms.
Drag Drop | Properties about drag and drop.
Misc | Properties that do not fit into any other category. This is the default category.

For more information, see TBD and TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | MemberAttribute | PropertyDescriptor | EventDescriptor


CharConverter Class

Provides a type converter to convert character objects to and from various other representations.

Object
TypeConverter
CharConverter

[Visual Basic]
Public Class CharConverter
   Inherits TypeConverter
[C#]
public class CharConverter : TypeConverter
[C++]
public __gc class CharConverter : public TypeConverter
[JScript]
public class CharConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace


CollectionConverter Class

Provides a type converter to convert Collection objects to and from various other representations.

Object
TypeConverter
CollectionConverter

[Visual Basic]
Public Class CollectionConverter
   Inherits TypeConverter
[C#]
public class CollectionConverter : TypeConverter
[C++]
public __gc class CollectionConverter : public TypeConverter
[JScript]
public class CollectionConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace


Component Class

Provides an abstraction that enables object-sharing between applications.

Object
Component

[Visual Basic]
Public Class Component
   Implements IComponent, IServiceObjectProvider
[C#]
public class Component : IComponent, IServiceObjectProvider
[C++]
public __gc class Component : public IComponent,
   IServiceObjectProvider
[JScript]
public class Component implements IComponent,
   IServiceObjectProvider

Remarks

The Component class is the default implementation for the IComponent interface.

A Component can use objects supplied by another application and it can expose its own objects for use by another application.

A Component can be hosted in an IContainer, which creates an ISite for each Component it contains. The ISite is used by the IContainer to manage the Component.

Requirements

Namespace: System.ComponentModel

Assembly: mscorlib.dll

See Also

Component Members | System.ComponentModel Namespace | IComponent | IContainer | Container | ISite


Component Members

Public:

Constructor

Component Constructor Initializes a new instance of the Component class.

Properties

Site Gets or sets the site of the Component.

Methods

Dispose | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer | Returns the IContainer that contains the Component.
GetDesignMode | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Component Class | System.ComponentModel Namespace


Component Constructor

Initializes a new instance of the Component class.

[Visual Basic]
Public Sub New()
[C#]
public Component();
[C++]
public: Component();
[JScript]
public function Component();

See Also

Component Class | Component Members | System.ComponentModel Namespace | Dispose


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Component Properties

The properties of the Component class are listed below. For a complete list of Component class members, see the Component Members topic.

Public:

Site Gets or sets the site of the Component.

See Also

Component Class | System.ComponentModel Namespace


Component.Site

Gets or sets the site of the Component.

[Visual Basic]
Overridable Public Property Site As ISite
[C#]
public ISite Site {virtual get; virtual set;}
[C++]
public: __property virtual ISite* get_Site();
public: __property virtual void set_Site(ISite*);
[JScript]
public function get Site() : ISite;
public function set Site(ISite);

Property Value

The ISite associated with the Component, if any.

a null reference (in Visual Basic Nothing) if the Component is not encapsulated in an IContainer, or the Component does not have an ISite associated with it, or the Component is being removed from its IContainer.

Exceptions

Exception Type | Condition
InvalidOperationException | The Component is not encapsulated in an IContainer. -or- The Component does not have an ISite associated with it.

Remarks

A Component can only have a ISite if it has been added to an IContainer and the IContainer assigns an ISite to it.

a null reference (Nothing) indicates that the Component is being removed from its IContainer; but assigning a null reference (Nothing) to this property does not necessarily remove the Component from the IContainer.

A Component may or may not have a name. If a Component is given a name, the name must be unique among other Component objects within its IContainer. The ISite stores the Component 's name; therefore, a Component can only be named if it has an ISite associated with it.

See Also

Component Class | Component Members | System.ComponentModel Namespace | IContainer | Container | ISite


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Component Methods

The methods of the Component class are listed below. For a complete list of Component class members, see the Component Members topic.

Public:

Dispose | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer | Returns the IContainer that contains the Component.
GetDesignMode | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Component Class | System.ComponentModel Namespace


Component.Dispose

Disposes of the Component.

[Visual Basic]
Overridable Public Sub Dispose()
[C#]
public virtual void Dispose();
[C++]
public: virtual void Dispose();
[JScript]
public function Dispose();

Return Value

None.

Remarks

This method can be overridden by a derived class.

This method removes the Component from its IContainer, if any, and triggers the Dispose event.

See Also

Component Class | Component Members | System.ComponentModel Namespace | IContainer | Container


Component.GetContainer

Returns the IContainer that contains the Component.

[Visual Basic]
Overridable Public Function GetContainer() As IContainer
[C#]
public virtual IContainer GetContainer();
[C++]
public: virtual IContainer* GetContainer();
[JScript]
public function GetContainer() : IContainer;

Return Value

The IContainer that contains the Component, if any.

a null reference (in Visual Basic Nothing) if the Component is not encapsulated in an IContainer.

Remarks

This method can be overridden by a derived class.

See Also

Component Class | Component Members | System.ComponentModel Namespace | IContainer | Container


Component.GetDesignMode

Gets a value indicating whether the Component is currently in design mode.

[Visual Basic]
Overridable Public Function GetDesignMode() As Boolean
[C#]
public virtual bool GetDesignMode();
[C++]
public: virtual bool GetDesignMode();
[JScript]
public function GetDesignMode() : Boolean;

Return Value

true, if the Component is in design mode; otherwise, false.

Remarks

This method can be overridden by a derived class.

The design mode indicator is stored in the ISite; therefore, if the Component does not have an ISite associated with it, this property is always false.

See Also

Component Class | Component Members | System.ComponentModel Namespace | IContainer | Container | ISite


Component.GetServiceObject

Returns an object representing a service provided by the Component.

[Visual Basic]
Overridable Public Function GetServiceObject( _
   ByVal service As Type _
) As Object
[C#]
public virtual object GetServiceObject(
   Type service
);
[C++]
public: virtual Object* GetServiceObject(
   Type* service
);
[JScript]
public function GetServiceObject(
   service : Type
) : Object;

Parameters

service
A service provided by the Component.

Return Value

An Object representing a service provided by the Component.

a null reference (in Visual Basic Nothing) if the Component does not provide the specified service.

Remarks

This method can be overridden by a derived class.

This method implements IServiceObjectProvider.

See Also

Component Class | Component Members | System.ComponentModel Namespace | IContainer | Container | ISite | IServiceObjectProvider


ComponentConverter Class

Provides a type converter to convert Component objects to and from various other representations. This class adds support for properties on a component.

Object
TypeConverter
ReferenceConverter
ComponentConverter

[Visual Basic]
Public Class ComponentConverter
   Inherits ReferenceConverter
[C#]
public class ComponentConverter : ReferenceConverter
[C++]
public __gc class ComponentConverter : public ReferenceConverter
[JScript]
public class ComponentConverter extends ReferenceConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace


ComponentEditorAttribute Class

Specifies the editor to use to change a component.

Object
Attribute
MemberAttribute
ComponentEditorAttribute

[Visual Basic]
NotInheritable Public Class ComponentEditorAttribute
   Inherits MemberAttribute
[C#]
public sealed class ComponentEditorAttribute : MemberAttribute
[C++]
public __gc __sealed class ComponentEditorAttribute : public
   MemberAttribute
[JScript]
public class ComponentEditorAttribute extends MemberAttribute

Remarks

When editing the component, a visual designer should instantiate the specified editor through a dialog box.

For more information, see TBD and TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | MemberAttribute


Container Class

Encapsulates zero or more components.

Object
Container

[Visual Basic]
Public Class Container
   Implements IContainer
[C#]
public class Container : IContainer
[C++]
public __gc class Container : public IContainer
[JScript]
public class Container implements IContainer

Remarks

The Container class is the default implementation for the IContainer interface.

Containers are objects that encapsulate and track zero or more components. In this context, "containment" refers to logical containment, not visual containment. Components and containers can be used in a variety of scenarios, including both visual and non-visual scenarios.

The components in a container are tracked in a first-in-first-out list, which also defines the order of the components within the container.

Requirements

Namespace: System.ComponentModel

Assembly: mscorlib.dll

See Also

Container Members | System.ComponentModel Namespace | IContainer | IComponent | Component


Container Members

Public:

Constructor

Container Constructor Initializes a new instance of the Container class.

Methods

Add | Overloaded. Adds a component to the Container.
Dispose | Disposes of the Container.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetComponent | Gets a specific Component in the Container.
GetComponents | Gets all the components in the Container.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Remove | Removes a component from the Container.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Container Class | System.ComponentModel Namespace


Container Constructor

Initializes a new instance of the Container class.

[Visual Basic]
Public Sub New()
[C#]
public Container();
[C++]
public: Container();
[JScript]
public function Container();

See Also

Container Class | Container Members | System.ComponentModel Namespace | Dispose


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Container Methods

The methods of the Container class are listed below. For a complete list of Container class members, see the Container Members topic.

Public:

Add | Overloaded. Adds a component to the Container.
Dispose | Disposes of the Container.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetComponent | Gets a specific Component in the Container.
GetComponents | Gets all the components in the Container.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Remove | Removes a component from the Container.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Container Class | System.ComponentModel Namespace


Container.Add

Adds a component to the Container.

Overload List

Adds the specified component to the Container and assigns a name to it.

[Visual Basic] Overloads Overridable Public Sub Add(IComponent, String)
[C#] public virtual void Add(IComponent, String);
[C++] public: virtual void Add(IComponent*, String);
[JScript] public function Add(IComponent, String);

Adds the specified component to the Container. The component is unnamed.

[Visual Basic] Overloads Overridable Public Sub Add(IComponent)
[C#] public virtual void Add(IComponent);
[C++] public: virtual void Add(IComponent*);
[JScript] public function Add(IComponent);

See Also

Container Class | Container Members | System.ComponentModel Namespace


Container.Add (IComponent, String)

Adds the specified component to the Container and assigns a name to it.

[Visual Basic]
Overloads Overridable Public Sub Add( _
   ByVal component As IComponent, _
   ByVal name As String _
)
[C#]
public virtual void Add(
   IComponent component,
   string name
);
[C++]
public: virtual void Add(
   IComponent* component,
   String* name
);
[JScript]
public function Add(
   component : IComponent,
   name : String
);

Parameters

component
The component to add.
name
The unique name to assign to the component.

-or-

a null reference (in Visual Basic Nothing) to leave the component unnamed.

Return Value

None.

Exceptions

Exception Type | Condition
InvalidOperationException | name is already used by another component in the Container.

Remarks

This method can be overridden by a derived class.

The components in a container are tracked in a first-in-first-out list, which also defines the order of the components within the container. The new component is added to the end of the list.Components may or may not have a name. If a component is given a name, the name must be unique among the names of the components within the Container.

See Also

Container Class | Container Members | System.ComponentModel Namespace | Container.Add Overload List | Remove


Container.Add (IComponent)

Adds the specified component to the Container. The component is unnamed.

[Visual Basic]
Overloads Overridable Public Sub Add( _
   ByVal component As IComponent _
)
[C#]
public virtual void Add(
   IComponent component
);
[C++]
public: virtual void Add(
   IComponent* component
);
[JScript]
public function Add(
   component : IComponent
);

Parameters

component
The component to add.

Return Value

None.

Remarks

This method can be overridden by a derived class.

The components in a container are tracked in a first-in-first-out list, which also defines the order of the components within the container. The new component is added to the end of the list.

See Also

Container Class | Container Members | System.ComponentModel Namespace | Container.Add Overload List | Remove


Container.Dispose

Disposes of the Container.

[Visual Basic]
Overridable Public Sub Dispose()
[C#]
public virtual void Dispose();
[C++]
public: virtual void Dispose();
[JScript]
public function Dispose();

Return Value

None.

Remarks

This method can be overridden by a derived class.

Notes to Implementers:

The implementation of Dispose must:

  • Remove any references to other components. This is typically accomplished by assigning a null reference (in Visual Basic Nothing) to fields that contain those references.
  • Release any system resources that are associated with the Container, such as file handles, window handles, or database connections.
  • Dispose of child components by calling the Dispose method of each.

The preferred implementation is to return the Container to its initial state, as it was immediately after it was created.

Following a call to this method, a Container is permitted to raise exceptions for operations it can no longer perform.

See Also

Container Class | Container Members | System.ComponentModel Namespace


Container.GetComponent

Gets a specific Component in the Container.

[Visual Basic]
Overridable Public Function GetComponent( _
   ByVal name As String _
) As IComponent
[C#]
public virtual IComponent GetComponent(
   string name
);
[C++]
public: virtual IComponent* GetComponent(
   String* name
);
[JScript]
public function GetComponent(
   name : String
) : IComponent;

Parameters

name
The name of the Component to get.

Return Value

The component specified by name.

a null reference (in Visual Basic Nothing) if the named component cannot be found.

Remarks

This method can be overridden by a derived class.

See Also

Container Class | Container Members | System.ComponentModel Namespace


Container.GetComponents

Gets all the components in the Container.

[Visual Basic]
Overridable Public Function GetComponents() As IComponent ()
[C#]
public virtual IComponent[] GetComponents();
[C++]
public: virtual IComponent* GetComponents() [];
[JScript]
public function GetComponents() : IComponent[];

Return Value

An array containing the components in the Container.

Remarks

This method can be overridden by a derived class.

The components in the array are sorted in the same order as they were added to the Container.

See Also

Container Class | Container Members | System.ComponentModel Namespace


Container.Remove

Removes a component from the Container.

[Visual Basic]
Overridable Public Sub Remove( _
   ByVal component As IComponent _
)
[C#]
public virtual void Remove(
   IComponent component
);
[C++]
public: virtual void Remove(
   IComponent* component
);
[JScript]
public function Remove(
   component : IComponent
);

Parameters

component
The component to remove.

Return Value

None.

Remarks

This method can be overridden by a derived class.

See Also

Container Class | Container Members | System.ComponentModel Namespace | Add


CultureInfoConverter Class

Provides a type converter to convert CultureInfo objects to and from various other representations.

Object
TypeConverter
CultureInfoConverter

[Visual Basic]
Public Class CultureInfoConverter
   Inherits TypeConverter
[C#]
public class CultureInfoConverter : TypeConverter
[C++]
public __gc class CultureInfoConverter : public TypeConverter
[JScript]
public class CultureInfoConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace


CurrencyConverter Class

Provides a type converter to convert Currency objects to and from various other representations.

Object
TypeConverter
CurrencyConverter

[Visual Basic]
Public Class CurrencyConverter
   Inherits TypeConverter
[C#]
public class CurrencyConverter : TypeConverter
[C++]
public __gc class CurrencyConverter : public TypeConverter
[JScript]
public class CurrencyConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace


DateTimeConverter Class

Provides a type converter to convert DateTime objects to and from various other representations.

Object
TypeConverter
DateTimeConverter

[Visual Basic]
Public Class DateTimeConverter
   Inherits TypeConverter
[C#]
public class DateTimeConverter : TypeConverter
[C++]
public __gc class DateTimeConverter : public TypeConverter
[JScript]
public class DateTimeConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace


DecimalConverter Class

Provides a type converter to convert decimal objects to and from various other representations.

Object
TypeConverter
DecimalConverter

[Visual Basic]
Public Class DecimalConverter
   Inherits TypeConverter
[C#]
public class DecimalConverter : TypeConverter
[C++]
public __gc class DecimalConverter : public TypeConverter
[JScript]
public class DecimalConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace


DefaultEventAttribute Class

Specifies the default event for a component.

Object
Attribute
MemberAttribute
DefaultEventAttribute

[Visual Basic]
Public Class DefaultEventAttribute
   Inherits MemberAttribute
[C#]
public class DefaultEventAttribute : MemberAttribute
[C++]
public __gc class DefaultEventAttribute : public MemberAttribute
[JScript]
public class DefaultEventAttribute extends MemberAttribute

Remarks

For more information, see TBD and TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | MemberAttribute


DefaultPropertyAttribute Class

Specifies the default property for a component.

Object
Attribute
MemberAttribute
DefaultPropertyAttribute

[Visual Basic]
Public Class DefaultPropertyAttribute
   Inherits MemberAttribute
[C#]
public class DefaultPropertyAttribute : MemberAttribute
[C++]
public __gc class DefaultPropertyAttribute : public MemberAttribute
[JScript]
public class DefaultPropertyAttribute extends MemberAttribute

Remarks

For more information, see TBD and TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | MemberAttribute


DefaultValueAttribute Class

Specifies the default value for a property.

Object
Attribute
MemberAttribute
DefaultValueAttribute

[Visual Basic]
Public Class DefaultValueAttribute
   Inherits MemberAttribute
[C#]
public class DefaultValueAttribute : MemberAttribute
[C++]
public __gc class DefaultValueAttribute : public MemberAttribute
[JScript]
public class DefaultValueAttribute extends MemberAttribute

Remarks

You can create a DefaultValueAttribute with any value. A member's default value is typically its initial value. A visual designer can use the default value to reset the member's value. Default values also can be used by a code generator to determine whether code should be generated for the member.

For more information, see TBD and TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | MemberAttribute | PropertyDescriptor


DescriptionAttribute Class

Specifies a description for a property or event.

Object
Attribute
MemberAttribute
DescriptionAttribute

[Visual Basic]
Public Class DescriptionAttribute
   Inherits MemberAttribute
[C#]
public class DescriptionAttribute : MemberAttribute
[C++]
public __gc class DescriptionAttribute : public MemberAttribute
[JScript]
public class DescriptionAttribute extends MemberAttribute

Remarks

A visual designer can display the specified description when referencing the component member, such as in a property browser. Call GetDescription to access the value of this attribute.

For more information, see TBD and TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | MemberAttribute | PropertyDescriptor | EventDescriptor


DesignerAttribute Class

Specifies the class to use to implement design-time services.

Object
Attribute
MemberAttribute
DesignerAttribute

[Visual Basic]
Public Class DesignerAttribute
   Inherits MemberAttribute
[C#]
public class DesignerAttribute : MemberAttribute
[C++]
public __gc class DesignerAttribute : public MemberAttribute
[JScript]
public class DesignerAttribute extends MemberAttribute

Remarks

The class you use for the design-time services must implement the IDesigner interface.

Use the DesignerBaseTypeName property to find the designer's base type. Use the DesignerTypeName property to get the name of the type of designer associated with this member.

For more information, see TBD and TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | MemberAttribute


DesignerCategoryAttribute Class

Specifies that the designer for a class belongs to a certain category.

Object
Attribute
MemberAttribute
DesignerCategoryAttribute

[Visual Basic]
Public Class DesignerCategoryAttribute
   Inherits MemberAttribute
[C#]
public class DesignerCategoryAttribute : MemberAttribute
[C++]
public __gc class DesignerCategoryAttribute : public
   MemberAttribute
[JScript]
public class DesignerCategoryAttribute extends MemberAttribute

Remarks

A visual designer can use categories to organize members into groups of similar behavior. A category can be created for any name.

When you mark a property with this attribute, it is set to a constant member. When you want to check the value of this attribute in your code, you must specify the constant member. The constant member that each value is set to is listed in the Description column in the table below.

The DesignerCategoryAttribute class defines the following common categories:

Category | Description
Component | Designers that are used with components. The attribute is set to the constant member DesignerCategoryAttribute.Component.
Form | Designers that are used with forms. The attribute is set to the constant member DesignerCategoryAttribute.Form.
Designer | Designers that are used with designers. The attribute is set to the constant member DesignerCategoryAttribute. Generic.
Empty String ("") | This is the default category. The attribute is set to the constant member DesignerCategoryAttribute.Default.

For more information, see TBD and TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | MemberAttribute | DesignerAttribute


DesignOnlyAttribute Class

Specifies that a property can be set only at design time.

Object
Attribute
MemberAttribute
DesignOnlyAttribute

[Visual Basic]
Public Class DesignOnlyAttribute
   Inherits MemberAttribute
[C#]
public class DesignOnlyAttribute : MemberAttribute
[C++]
public __gc class DesignOnlyAttribute : public MemberAttribute
[JScript]
public class DesignOnlyAttribute extends MemberAttribute

Remarks

Members marked with DesignOnly(true) can be set only at design time. Members that either have no attribute or are marked with DesignOnly(false) can be set during run time. The default is false.

For more information, see TBD and TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | MemberAttribute | PropertyDescriptor


DoubleConverter Class

Provides a type converter to convert double objects to and from various other representations.

Object
TypeConverter
DoubleConverter

[Visual Basic]
Public Class DoubleConverter
   Inherits TypeConverter
[C#]
public class DoubleConverter : TypeConverter
[C++]
public __gc class DoubleConverter : public TypeConverter
[JScript]
public class DoubleConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace


EditorAttribute Class

Specifies the editor to use to change a property.

Object
Attribute
MemberAttribute
EditorAttribute

[Visual Basic]
NotInheritable Public Class EditorAttribute
   Inherits MemberAttribute
[C#]
public sealed class EditorAttribute : MemberAttribute
[C++]
public __gc __sealed class EditorAttribute : public MemberAttribute
[JScript]
public class EditorAttribute extends MemberAttribute

Remarks

When editing the property, a visual designer should instantiate the specified editor through a dialog box.

Use the EditorBaseTypeName property to find this editor's base type. Use the EditorTypeName property to get the name of the type of editor associated with this attribute.

For more information, see TBD and TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace


EnumConverter Class

Provides a type converter to convert enum objects to and from various other representations.

Object
TypeConverter
EnumConverter

[Visual Basic]
Public Class EnumConverter
   Inherits TypeConverter
[C#]
public class EnumConverter : TypeConverter
[C++]
public __gc class EnumConverter : public TypeConverter
[JScript]
public class EnumConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace


EventDescriptor Class

Provides a description of an event.

Object
MemberDescriptor
EventDescriptor

[Visual Basic]
MustInherit Public Class EventDescriptor
   Inherits MemberDescriptor
[C#]
public abstract class EventDescriptor : MemberDescriptor
[C++]
public __gc __abstract class EventDescriptor : public
   MemberDescriptor
[JScript]
public abstract class EventDescriptor extends MemberDescriptor

Remarks

A description of an event consists of a name, its attributes, the component that the event is bound to, the event delegate, the type of the delegate, and whether the delegate is multicast.

Typically, the abstract (in Visual Basic MustOverride) members of this class are implemented through reflection. EventDescriptor provides the following abstract (MustOverride) properties and methods:

  • ComponentType contains type of the component this event is bound to.
  • EventType contains the type of delegate for the event.
  • IsMulticast contains a value indicating whether the event delegate is a multicast delegate.
  • AddEventHandler binds the event to a component.
  • RemoveEventHandler unbinds the delegate from the component so that the delegate will no longer receive events from the component.

For more information on events see TBD. For more information about reflection, see TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

EventDescriptor Members | System.ComponentModel Namespace | MemberDescriptor | MemberAttribute


EventDescriptor Members

Public:

Properties

Attributes (inherited from MemberDescriptor) | Gets the collection of attributes for this member.
Category (inherited from MemberDescriptor) | Gets the name of the category that the member belongs to, as specified in the CategoryAttribute.
ComponentType | When overridden in a derived class, gets the type of the component this event is bound to.
Description (inherited from MemberDescriptor) | Gets the description of the member as specified in the DescriptionAttribute.
EventType | When overridden in a derived class, gets the type of delegate for the event.
IsBrowsable (inherited from MemberDescriptor) | Gets a value indicating whether the member is browsable as specified in the BrowsableAttribute.
IsMulticast | When overridden in a derived class, gets a value indicating whether the event delegate is a multicast delegate.
Name (inherited from MemberDescriptor) | Gets the name of the member.

Methods

AddEventHandler | When overridden in a derived class, binds the event to the component.
Equals (inherited from MemberDescriptor) | Compares this instance to the specified MemberDescriptor to see if they are equivalent.
GetDesignTimeOnly (inherited from MemberDescriptor) | Determines whether this member should be set only at design time as specified in the DesignOnlyAttribute.
GetDisplayName (inherited from MemberDescriptor) | Gets the name that can be displayed in a window like a property browser.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHelpTopic (inherited from MemberDescriptor) | Gets the name of the Help topic specified in the HelpAttribute.
GetHelpURL (inherited from MemberDescriptor) | Gets the URL for the Help file specified in the HelpAttribute.
GetType (inherited from Object) | Gets the Type of the Object.
RemoveEventHandler | When overridden in a derived class, unbinds the delegate from the component so that the delegate will no longer receive events from the component.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Constructor

EventDescriptor Constructor Overloaded. Initializes a new instance of the EventDescriptor class.

Properties

AttributeArray (inherited from MemberDescriptor) | Gets or sets an array of attributes.
NameHashCode (inherited from MemberDescriptor) | Gets the hash code for the name of the member as specified in GetHashCode.

Methods

CreateAttributeCollection (inherited from MemberDescriptor) | Creates a collection of attributes using the array of attributes that you passed to the constructor.
FillAttributes (inherited from MemberDescriptor) | In an inheriting class, adds the attributes of the inheriting class to the specified list of attributes in the parent class.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EventDescriptor Class | System.ComponentModel Namespace


EventDescriptor Constructor

Initializes a new instance of the EventDescriptor class.

Overload List

Initializes a new instance of the EventDescriptor class with the specified name and attribute array.

[Visual Basic] Overloads Protected Sub New(String, MemberAttribute())
[C#] protected EventDescriptor(String, MemberAttribute[]);
[C++] protected: EventDescriptor(String*, MemberAttribute[]);
[JScript] protected function EventDescriptor(String, MemberAttribute[]);

Initializes a new instance of the EventDescriptor class with the name and attributes in the specified MemberDescriptor.

[Visual Basic] Overloads Protected Sub New(MemberDescriptor)
[C#] protected EventDescriptor(MemberDescriptor);
[C++] protected: EventDescriptor(MemberDescriptor*);
[JScript] protected function EventDescriptor(MemberDescriptor);

Initializes a new instance of the EventDescriptor class with the name in the specified MemberDescriptor and the attributes in both the MemberDescriptor and the MemberAttribute array.

[Visual Basic] Overloads Protected Sub New(MemberDescriptor, MemberAttribute())
[C#] protected EventDescriptor(MemberDescriptor, MemberAttribute[]);
[C++] protected: EventDescriptor(MemberDescriptor*, MemberAttribute[]);
[JScript] protected function EventDescriptor(MemberDescriptor, MemberAttribute[]);

See Also

EventDescriptor Class | EventDescriptor Members | System.ComponentModel Namespace


EventDescriptor Constructor (String, MemberAttribute[])

Initializes a new instance of the EventDescriptor class with the specified name and attribute array.

[Visual Basic]
Overloads Protected Sub New( _
   ByVal name As String, _
   ByVal attrs() As MemberAttribute _
)
[C#]
protected EventDescriptor(
   string name,
   MemberAttribute[] attrs
);
[C++]
protected: EventDescriptor(
   String* name,
   MemberAttribute* attrs[]
);
[JScript]
protected function EventDescriptor(
   name : String,
   attrs : MemberAttribute[]
);

Parameters

name
The name of the event.
attrs
An array of type MemberAttribute that contains the event attributes.

See Also

EventDescriptor Class | EventDescriptor Members | System.ComponentModel Namespace | EventDescriptor Constructor Overload List


EventDescriptor Constructor (MemberDescriptor)

Initializes a new instance of the EventDescriptor class with the name and attributes in the specified MemberDescriptor.

[Visual Basic]
Overloads Protected Sub New( _
   ByVal descr As MemberDescriptor _
)
[C#]
protected EventDescriptor(
   MemberDescriptor descr
);
[C++]
protected: EventDescriptor(
   MemberDescriptor* descr
);
[JScript]
protected function EventDescriptor(
   descr : MemberDescriptor
);

Parameters

descr
A MemberDescriptor that contains the name of the event and its attributes.

See Also

EventDescriptor Class | EventDescriptor Members | System.ComponentModel Namespace | EventDescriptor Constructor Overload List


EventDescriptor Constructor (MemberDescriptor, MemberAttribute[])

Initializes a new instance of the EventDescriptor class with the name in the specified MemberDescriptor and the attributes in both the MemberDescriptor and the MemberAttribute array.

[Visual Basic]
Overloads Protected Sub New( _
   ByVal descr As MemberDescriptor, _
   ByVal attrs() As MemberAttribute _
)
[C#]
protected EventDescriptor(
   MemberDescriptor descr,
   MemberAttribute[] attrs
);
[C++]
protected: EventDescriptor(
   MemberDescriptor* descr,
   MemberAttribute* attrs[]
);
[JScript]
protected function EventDescriptor(
   descr : MemberDescriptor,
   attrs : MemberAttribute[]
);

Parameters

descr
A MemberDescriptor that has the name of the member and its attributes.
attrs
A MemberAttribute array with the attributes you wish to add to this event description.

Remarks

This constructor appends the attributes in the MemberAttribute array to the attributes in the MemberDescriptor.

See Also

EventDescriptor Class | EventDescriptor Members | System.ComponentModel Namespace | EventDescriptor Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EventDescriptor Properties

The properties of the EventDescriptor class are listed below. For a complete list of EventDescriptor class members, see the EventDescriptor Members topic.

Public:

Attributes (inherited from MemberDescriptor) | Gets the collection of attributes for this member.
Category (inherited from MemberDescriptor) | Gets the name of the category that the member belongs to, as specified in the CategoryAttribute.
ComponentType | When overridden in a derived class, gets the type of the component this event is bound to.
Description (inherited from MemberDescriptor) | Gets the description of the member as specified in the DescriptionAttribute.
EventType | When overridden in a derived class, gets the type of delegate for the event.
IsBrowsable (inherited from MemberDescriptor) | Gets a value indicating whether the member is browsable as specified in the BrowsableAttribute.
IsMulticast | When overridden in a derived class, gets a value indicating whether the event delegate is a multicast delegate.
Name (inherited from MemberDescriptor) | Gets the name of the member.

Protected:

AttributeArray (inherited from MemberDescriptor) | Gets or sets an array of attributes.
NameHashCode (inherited from MemberDescriptor) | Gets the hash code for the name of the member as specified in GetHashCode.

See Also

EventDescriptor Class | System.ComponentModel Namespace


EventDescriptor.ComponentType

When overridden in a derived class, gets the type of the component this event is bound to.

[Visual Basic]
MustOverride Public ReadOnly Property ComponentType As Type
[C#]
public Type ComponentType {abstract get;}
[C++]
public: __property virtual Type* get_ComponentType() = 0;
[JScript]
public abstract function get ComponentType() : Type;

Property Value

A Type that represents the type of component the event is bound to.

Remarks

Typically, this property is implemented through reflection.

See Also

EventDescriptor Class | EventDescriptor Members | System.ComponentModel Namespace | EventType | IsMulticast


EventDescriptor.EventType

When overridden in a derived class, gets the type of delegate for the event.

[Visual Basic]
MustOverride Public ReadOnly Property EventType As Type
[C#]
public Type EventType {abstract get;}
[C++]
public: __property virtual Type* get_EventType() = 0;
[JScript]
public abstract function get EventType() : Type;

Property Value

A Type that represents the type of delegate for the event.

Remarks

Typically, this property is implemented through reflection.

See Also

EventDescriptor Class | EventDescriptor Members | System.ComponentModel Namespace | ComponentType | IsMulticast


EventDescriptor.IsMulticast

When overridden in a derived class, gets a value indicating whether the event delegate is a multicast delegate.

[Visual Basic]
MustOverride Public ReadOnly Property IsMulticast As Boolean
[C#]
public bool IsMulticast {abstract get;}
[C++]
public: __property virtual bool get_IsMulticast() = 0;
[JScript]
public abstract function get IsMulticast() : Boolean;

Property Value

true if the event delegate is multicast; otherwise, false.

Remarks

Typically, this property is implemented through reflection.

See Also

EventDescriptor Class | EventDescriptor Members | System.ComponentModel Namespace | EventType | ComponentType


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EventDescriptor Methods

The methods of the EventDescriptor class are listed below. For a complete list of EventDescriptor class members, see the EventDescriptor Members topic.

Public:

AddEventHandler | When overridden in a derived class, binds the event to the component.
Equals (inherited from MemberDescriptor) | Compares this instance to the specified MemberDescriptor to see if they are equivalent.
GetDesignTimeOnly (inherited from MemberDescriptor) | Determines whether this member should be set only at design time as specified in the DesignOnlyAttribute.
GetDisplayName (inherited from MemberDescriptor) | Gets the name that can be displayed in a window like a property browser.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHelpTopic (inherited from MemberDescriptor) | Gets the name of the Help topic specified in the HelpAttribute.
GetHelpURL (inherited from MemberDescriptor) | Gets the URL for the Help file specified in the HelpAttribute.
GetType (inherited from Object) | Gets the Type of the Object.
RemoveEventHandler | When overridden in a derived class, unbinds the delegate from the component so that the delegate will no longer receive events from the component.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

CreateAttributeCollection (inherited from MemberDescriptor) | Creates a collection of attributes using the array of attributes that you passed to the constructor.
FillAttributes (inherited from MemberDescriptor) | In an inheriting class, adds the attributes of the inheriting class to the specified list of attributes in the parent class.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EventDescriptor Class | System.ComponentModel Namespace


EventDescriptor.AddEventHandler

When overridden in a derived class, binds the event to the component.

[Visual Basic]
MustOverride Public Sub AddEventHandler( _
   ByVal component As Object, _
   ByVal value As Delegate _
)
[C#]
public abstract void AddEventHandler(
   object component,
   Delegate value
);
[C++]
public: virtual void AddEventHandler(
   Object* component,
   Delegate* value
) = 0;
[JScript]
public abstract function AddEventHandler(
   component : Object,
   value : Delegate
);

Parameters

component
A component that provides events to the delegate.
value
A delegate that represents the method that handles the event.

Remarks

Typically, this method is implemented through reflection.

Notes to Inheritors: When you override this method, it should add the delegate to the component's event list by invoking the appropriate AddOn XXX method.

For more information about delegates, see TBD.

See Also

EventDescriptor Class | EventDescriptor Members | System.ComponentModel Namespace | AddEventHandler


EventDescriptor.RemoveEventHandler

When overridden in a derived class, unbinds the delegate from the component so that the delegate will no longer receive events from the component.

[Visual Basic]
MustOverride Public Sub RemoveEventHandler( _
   ByVal component As Object, _
   ByVal value As Delegate _
)
[C#]
public abstract void RemoveEventHandler(
   object component,
   Delegate value
);
[C++]
public: virtual void RemoveEventHandler(
   Object* component,
   Delegate* value
) = 0;
[JScript]
public abstract function RemoveEventHandler(
   component : Object,
   value : Delegate
);

Parameters

component
The component that the delegate is bound to.
value
The delegate to unbind from the component.

Remarks

Typically, this method is implemented through reflection.

Notes to Inheritors: When you override this method, it should remove the delegate from the component's event list by invoking the appropriate RemoveOn XXX method.

For more information about delegates, see TBD.

See Also

EventDescriptor Class | EventDescriptor Members | System.ComponentModel Namespace | AddEventHandler


EventDescriptorAttribute Class

Specifies that the property was originally an event and provides the event information.

Object
Attribute
MemberAttribute
EventDescriptorAttribute

[Visual Basic]
Public Class EventDescriptorAttribute
   Inherits MemberAttribute
[C#]
public class EventDescriptorAttribute : MemberAttribute
[C++]
public __gc class EventDescriptorAttribute : public MemberAttribute
[JScript]
public class EventDescriptorAttribute extends MemberAttribute

Remarks

You use an EventDescriptor at design time when you convert an event to a property. Events are converted to properties so they can be viewed and changed. The EventDescriptor provides a way to identify that the property was an event and allows you to recover the original event.

Use the InnerEvent property to get the instance of the EventDescriptor that this attribute is set to.

For more information, see TBD and TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | MemberAttribute | EventDescriptor


EventDescriptorCollection Class

Represents a collection of events.

Object
EventDescriptorCollection

[Visual Basic]
Public Class EventDescriptorCollection
   Implements ICollection, IEnumerable
[C#]
public class EventDescriptorCollection : ICollection, IEnumerable
[C++]
public __gc class EventDescriptorCollection : public ICollection,
   IEnumerable
[JScript]
public class EventDescriptorCollection implements ICollection,
   IEnumerable

Remarks

EventDescriptorCollection is read-only; it does not implement methods that add or remove events. You must inherit from this class to implement these methods.

Using the properties available in the EventDescriptorCollection class, you can query the collection about its contents. Use the Count property to determine the number of elements in the collection. Use the Item property (EventDescriptorCollection indexer) to get a specific property by index number or by name.

In addition to properties, you can use the Find method to get a description of the event with the specified name from the collection.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

Example [Visual Basic]

The following example prints all the events on a button in a text box. It assumes that Button1 has been instantiated on a form.

[Visual Basic]

Private Sub MyEventCollection()
   ' Create a new collection and assign it the events for Button1.
   Dim events As EventDescriptorCollection
   events = TypeDescriptor.GetEvents(Button1)

   ' Use myEvent to print the name of each event.
   Dim myEvent As EventDescriptor
   For Each myEvent In events
      TextBox1.Text &= " " & myEvent.Name
   Next
End Sub

See Also

EventDescriptorCollection Members | System.ComponentModel Namespace | EventDescriptor | TypeDescriptor


EventDescriptorCollection Members

Public:

Constructor

EventDescriptorCollection Constructor Initializes a new instance of the EventDescriptorCollection class.

Properties

All | Gets an array of descriptions of events.
Count | Gets the number of event descriptors in the collection.
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the EventDescriptorCollection class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Find | Gets the description of the event with the specified name in the collection.
GetEnumerator | Gets an enumerator for this EventDescriptorCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EventDescriptorCollection Class | System.ComponentModel Namespace


EventDescriptorCollection Constructor

Initializes a new instance of the EventDescriptorCollection class.

[Visual Basic]
Public Sub New( _
   ByVal events() As EventDescriptor _
)
[C#]
public EventDescriptorCollection(
   EventDescriptor[] events
);
[C++]
public: EventDescriptorCollection(
   EventDescriptor* events[]
);
[JScript]
public function EventDescriptorCollection(
   events : EventDescriptor[]
);

Parameters

events
An array of type EventDescriptor that provides the events for this collection.

Remarks

If events is empty, this constructor creates an empty EventDescriptorCollection.

Example [Visual Basic]

The following example creates a new EventDescriptorCollection using the events on Button1. It assumes that Button1 has been instantiated on a form.

[Visual Basic]

Dim events As EventDescriptorCollection
events = TypeDescriptor.GetEvents(Button1)

See Also

EventDescriptorCollection Class | EventDescriptorCollection Members | System.ComponentModel Namespace | EventDescriptor | TypeDescriptor


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EventDescriptorCollection Properties

The properties of the EventDescriptorCollection class are listed below. For a complete list of EventDescriptorCollection class members, see the EventDescriptorCollection Members topic.

Public:

All | Gets an array of descriptions of events.
Count | Gets the number of event descriptors in the collection.
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the EventDescriptorCollection class.

See Also

EventDescriptorCollection Class | System.ComponentModel Namespace


EventDescriptorCollection.All

Gets an array of descriptions of events.

[Visual Basic]
Overridable Public Property All As EventDescriptor ()
[C#]
public EventDescriptor[] All {virtual get; virtual set;}
[C++]
public: __property virtual EventDescriptor* get_All();
public: __property virtual void set_All(EventDescriptor*[]);
[JScript]
public function get All() : EventDescriptor[];
public function set All(EventDescriptor[]);

Property Value

An array of type EventDescriptor with descriptions of the events.

Exceptions

Exception Type | Condition
NotSupportedException | Setting the property.

Remarks

This property is read-only. To set its value, you must inherit from this class.

Example [Visual Basic]

The following example shows how to get an array of type EventDescriptor using the All property. It assumes that Button1 has been instantiated on a form.

[Visual Basic]

Private Sub GetAllEvents()
   ' Create a new collection and assign it the events for Button1.
   Dim events As EventDescriptorCollection
   events = TypeDescriptor.GetEvents(Button1)

   ' Get all the EventDescriptors.
   Dim eArray() As EventDescriptor
   eArray = events.All

   ' Print all the event names in a text box.
   Dim i As Integer
   For i = 0 To eArray.Length - 1
      TextBox1.Text &= " " & eArray(i).Name
   Next
End Sub

See Also

EventDescriptorCollection Class | EventDescriptorCollection Members | System.ComponentModel Namespace | EventDescriptor | TypeDescriptor


EventDescriptorCollection.Count

Gets the number of event descriptors in the collection.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

Property Value

The number of event descriptors in the collection.

Remarks

The Count property can be used to set the limits of a loop that iterates through a collection of objects. If the collection is zero-based, be sure to use "Count- 1" as the upper bound of the loop.

Example [Visual Basic]

The following example uses the Count property to print the number of events attached to Button1. It assumes that Button1 has been instantianted on a form.

[Visual Basic]

Private Sub GetCount()
   Dim events As EventDescriptorCollection
   events = TypeDescriptor.GetEvents(Button1)

   ' Print the number of events on Button 1 in a text box.
   TextBox1.Text = events.Count.ToString
End Sub

See Also

EventDescriptorCollection Class | EventDescriptorCollection Members | System.ComponentModel Namespace | EventDescriptor | TypeDescriptor


EventDescriptorCollection.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the EventDescriptorCollection class.

Overload List

Gets the event with the specified name.

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(String) As EventDescriptor
[C#] public EventDescriptor this[String] {virtual get;}
[C++] public: __property virtual EventDescriptor* get_Item(String*);
[JScript] EventDescriptorCollection.Item (String)

Gets the event with the specified index number.

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(Integer) As EventDescriptor
[C#] public EventDescriptor this[int] {virtual get;}
[C++] public: __property virtual EventDescriptor* get_Item(int);
[JScript] EventDescriptorCollection.Item (int)

Example [Visual Basic]

The following example uses the Item property (EventDescriptorCollection indexer) to print the name of the EventDescriptor specified by the index number in a text box. Since the index number is zero-based, this example prints the name of the second EventDescriptor. It assumes Button1 has been instantiated on a form.

Note This example shows how to use one of the overloaded versions of the Item property (EventDescriptorCollection indexer). For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub PrintIndexItem()
   Dim events As EventDescriptorCollection
   events = TypeDescriptor.GetEvents(Button1)

   ' Print the second event's name.
   TextBox1.Text = events.Item(1).Name
End Sub

See Also

EventDescriptorCollection Class | EventDescriptorCollection Members | System.ComponentModel Namespace


EventDescriptorCollection.Item (String)

Gets the event with the specified name.

[C#] In C#, this member is the indexer for the EventDescriptorCollection class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal name As String _
) As EventDescriptor
[C#]
public EventDescriptor this[
   string name
] {virtual get;}
[C++]
public: __property virtual EventDescriptor* get_Item(
   String* name
);
[JScript]
returnValue = EventDescriptorCollectionObject.Item(name);
-or-
returnValue = EventDescriptorCollectionObject(name);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
The name of the EventDescriptor to get from the collection.

Parameters [Visual Basic, C#, C++]

name
The name of the EventDescriptor to get from the collection.

Property Value

The EventDescriptor with the specified name, or a null reference (in Visual Basic Nothing) if the event does not exist.

Remarks

Item property (EventDescriptorCollection indexer)is case-sensitive when searching for names. That is, if two events exist with the names "Ename" and "ename," Item property (EventDescriptorCollection indexer)will find the specific event you name.

Example [Visual Basic]

The following example uses the Item property (EventDescriptorCollection indexer) to print the type of component for the EventDescriptor specified by the index. It assumes that Button1 has been instantiated on a form.

[Visual Basic]

Private Sub PrintIndexItem2()
   Dim events As EventDescriptorCollection
   events = TypeDescriptor.GetEvents(Button1)

   ' Set a EventDescriptor to the specific event.
   Dim myEvent As EventDescriptor
   myEvent = events.Item("KeyDown")

   ' Print the type of component for the Event.
   TextBox1.Text = myEvent.ComponentType.ToString
End Sub

See Also

EventDescriptorCollection Class | EventDescriptorCollection Members | System.ComponentModel Namespace | EventDescriptorCollection.Item Overload List | EventDescriptor | TypeDescriptor


EventDescriptorCollection.Item (Int32)

Gets the event with the specified index number.

[C#] In C#, this member is the indexer for the EventDescriptorCollection class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal index As Integer _
) As EventDescriptor
[C#]
public EventDescriptor this[
   int index
] {virtual get;}
[C++]
public: __property virtual EventDescriptor* get_Item(
   int index
);
[JScript]
returnValue = EventDescriptorCollectionObject.Item(index);
-or-
returnValue = EventDescriptorCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
The zero-based index number of the EventDescriptor to get from the collection.

Parameters [Visual Basic, C#, C++]

index
The zero-based index number of the EventDescriptor to get from the collection.

Property Value

The EventDescriptor with the specified index number.

Remarks

The index number is zero-based. Therefore, you must subtract one from the numerical position of a particular EventDescriptor to access that EventDescriptor. For example, to get the third EventDescriptor, you need to specify Item property (EventDescriptorCollection indexer)(2).

Example [Visual Basic]

The following example uses the Item property (EventDescriptorCollection indexer) to print the name of the EventDescriptor specified by the index number in a text box. Since the index number is zero-based, this example prints the name of the second EventDescriptor. It assumes Button1 has been instantiated on a form.

[Visual Basic]

Private Sub PrintIndexItem()
   Dim events As EventDescriptorCollection
   events = TypeDescriptor.GetEvents(Button1)

   ' Print the second event's name.
   TextBox1.Text = events.Item(1).Name
End Sub

See Also

EventDescriptorCollection Class | EventDescriptorCollection Members | System.ComponentModel Namespace | EventDescriptorCollection.Item Overload List | EventDescriptor | TypeDescriptor


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EventDescriptorCollection Methods

The methods of the EventDescriptorCollection class are listed below. For a complete list of EventDescriptorCollection class members, see the EventDescriptorCollection Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Find | Gets the description of the event with the specified name in the collection.
GetEnumerator | Gets an enumerator for this EventDescriptorCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EventDescriptorCollection Class | System.ComponentModel Namespace


EventDescriptorCollection.Find

Gets the description of the event with the specified name in the collection.

[Visual Basic]
Overridable Public Function Find( _
   ByVal name As String, _
   ByVal ignoreCase As Boolean _
) As EventDescriptor
[C#]
public virtual EventDescriptor Find(
   string name,
   bool ignoreCase
);
[C++]
public: virtual EventDescriptor* Find(
   String* name,
   bool ignoreCase
);
[JScript]
public function Find(
   name : String,
   ignoreCase : Boolean
) : EventDescriptor;

Parameters

name
The name of the event to get from the collection.
ignoreCase
true if you want to ignore the case of the event; otherwise, false.

Return Value

The EventDescriptor with the specified name, or a null reference (in Visual Basic Nothing) if the event does not exist.

Example [Visual Basic]

The following example finds a specific EventDescriptor. It prints the type of component for this EventDescriptor in a text box. It assumes that Button1 has been instantiated on a form.

[Visual Basic]

Private Sub FindEvent()
   Dim events As EventDescriptorCollection
   events = TypeDescriptor.Getevents(Button1)

   ' Set a EventDescriptor to the specific event.
   Dim myEvent As EventDescriptor
   myEvent = events.Find("Resize", False)

   ' Print the type of component for the Event.
   TextBox1.Text = myEvent.ComponentType.ToString
End Sub

See Also

EventDescriptorCollection Class | EventDescriptorCollection Members | System.ComponentModel Namespace | EventDescriptor | TypeDescriptor


EventDescriptorCollection.GetEnumerator

Gets an enumerator for this EventDescriptorCollection.

[Visual Basic]
Public Function GetEnumerator() As IEnumerator
[C#]
public IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

Return Value

An enumerator of type IEnumerator.

Example [Visual Basic]

The following example gets an enumerator for the events on Button1. It uses the enumerator to print the names of the events in the collection. It assumes that Button1 has been instantiated on a form.

[Visual Basic]

Private Sub MyEnumerator()
   Dim events As EventDescriptorCollection
   events = TypeDescriptor.GetEvents(Button1)

   ' Create an enumerator
   Dim ie As IEnumerator
   ie = events.GetEnumerator

   ' Print the name of each Event in the collecction.
   Dim myEvent As Object
   Do While ie.MoveNext = True
      myEvent = ie.Current
      TextBox1.Text &= " " & myEvent.ToString
   Loop
End Sub

See Also

EventDescriptorCollection Class | EventDescriptorCollection Members | System.ComponentModel Namespace | EventDescriptor | TypeDescriptor | IEnumerator


ExpandableObjectConverter Class

Provides a type converter to convert objects to and from various other representations. This class adds support for the properties of the object.

Object
TypeConverter
ExpandableObjectConverter

[Visual Basic]
Public Class ExpandableObjectConverter
   Inherits TypeConverter
[C#]
public class ExpandableObjectConverter : TypeConverter
[C++]
public __gc class ExpandableObjectConverter : public TypeConverter
[JScript]
public class ExpandableObjectConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace


ExtenderPropertyAttribute Class

Specifies which components can accept the extender.

Object
Attribute
MemberAttribute
ExtenderPropertyAttribute

[Visual Basic]
Public Class ExtenderPropertyAttribute
   Inherits MemberAttribute
[C#]
public class ExtenderPropertyAttribute : MemberAttribute
[C++]
public __gc class ExtenderPropertyAttribute : public
   MemberAttribute
[JScript]
public class ExtenderPropertyAttribute extends MemberAttribute

Remarks

The ReceiverType property contains the type of object that can receive the extender property.

For more information, see TBD and TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | MemberAttribute


GuidConverter Class

Provides a type converter to convert Guid objects to and from various other representations.

Object
TypeConverter
GuidConverter

[Visual Basic]
Public Class GuidConverter
   Inherits TypeConverter
[C#]
public class GuidConverter : TypeConverter
[C++]
public __gc class GuidConverter : public TypeConverter
[JScript]
public class GuidConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace


HelpAttribute Class

Specifies Help file and Help topic for a property or event. A visual designer can use this information to provide help for the member.

Object
Attribute
MemberAttribute
HelpAttribute

[Visual Basic]
Public Class HelpAttribute
   Inherits MemberAttribute
[C#]
public class HelpAttribute : MemberAttribute
[C++]
public __gc class HelpAttribute : public MemberAttribute
[JScript]
public class HelpAttribute extends MemberAttribute

Remarks

Use the URL property to get the URL of the Help file associated with this member. Use the Topic property to get the name of the Help topic.

For more information, see TBD and TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | MemberAttribute | PropertyDescriptor | EventDescriptor


IComponent Interface

Provides functionality required by all components.

IComponent

[Visual Basic]
Public Interface IComponent
[C#]
public interface IComponent
[C++]
public __gc __interface IComponent

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IComponent

Class | Description
Component | Provides an abstraction that enables object-sharing between applications.
Control | Defines the properties, methods, and events common to all server controls in the ASP+ Page framework.
HttpApplication |
MarshalByRefComponent | Represents the base implementation for IComponent, which is the base for all components in WinForms. A component can be hosted in a container. For each component in a container, the container creates a site that it uses to manage the component.

Remarks

Components can be contained in a container. In this context, "containment" refers to logical containment, not visual containment. Components and containers can be used in a variety of scenarios, including both visual and non-visual scenarios.

A component interacts with its container primarily through a container-provided ISite, which is a repository of container-specific per-component information.

Notes to Implementers: To be a component, a class must implement the IComponent interface and provide a basic constructor that requires no parameters.

Requirements

Namespace: System.ComponentModel

Assembly: mscorlib.dll

See Also

IComponent Members | System.ComponentModel Namespace | Container | IContainer | ISite


IComponent Members

Properties

Site When implemented by a class, gets or sets the ISite associated with the IComponent.

Methods

Dispose When implemented by a class, disposes of the IComponent.

See Also

IComponent Interface | System.ComponentModel Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IComponent Properties

The properties of the IComponent interface are listed below. For a complete list of IComponent interface members, see the IComponent Members topic.

Site When implemented by a class, gets or sets the ISite associated with the IComponent.

See Also

IComponent Interface | System.ComponentModel Namespace


IComponent.Site

When implemented by a class, gets or sets the ISite associated with the IComponent.

[Visual Basic]
Property Site As ISite
[C#]
ISite Site {get; set;}
[C++]
ISite* get_Site() = 0;void set_Site(ISite*) = 0;
[JScript]
abstract function get Site() : ISite;
public abstract function set Site(ISite);

Property Value

The ISite object associated with the component; or a null reference object, if the component does not have a site.

See Also

IComponent Interface | IComponent Members | System.ComponentModel Namespace | ISite


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IComponent Methods

The methods of the IComponent interface are listed below. For a complete list of IComponent interface members, see the IComponent Members topic.

Dispose When implemented by a class, disposes of the IComponent.

See Also

IComponent Interface | System.ComponentModel Namespace


IComponent.Dispose

When implemented by a class, disposes of the IComponent.

[Visual Basic]
Sub Dispose()
[C#]
void Dispose();
[C++]
void Dispose() = 0;
[JScript]
function Dispose();

Remarks

The implementation of Dispose must:

  1. Remove any references to other components. Typically, this can be accomplished by assigning a null reference object to any field that contains references to other components.
  2. Release any system resources that are associated with the component, such as file handles, window handles, or database connections.
  3. Dispose of any child components, such as child windows or submenu items, by calling the Dispose method of those components.
  4. Remove the component from its container. If the component has a site, the component must remove itself from its container.
  5. Raise the component's Dispose event.

Ideally, a call to Dispose will cause the component to revert to its initial state, as it was immediately after it was created. However, this is not a requirement. Following a call to the Dispose method, a component is permitted to raise exceptions for operations that it cannot meaningfully perform.

See Also

IComponent Interface | IComponent Members | System.ComponentModel Namespace


IContainer Interface

Provides functionality for containers. Containers are objects that logically contain zero or more components.

IContainer

[Visual Basic]
Public Interface IContainer
[C#]
public interface IContainer
[C++]
public __gc __interface IContainer

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IContainer

Class | Description
Container | Encapsulates zero or more components.

Remarks

Components and containers can be used in a variety of visual and non-visual scenarios.

Notes to Implementers: To be a container, the class must implement the IContainer interface, which supports methods for adding, removing, and retrieving components.

Requirements

Namespace: System.ComponentModel

Assembly: mscorlib.dll

See Also

IContainer Members | System.ComponentModel Namespace | Component | IComponent | Container


IContainer Members

Methods

Add | Overloaded. Adds the specified component to the IContainer.
Dispose | Disposes of the IContainer.
GetComponent | Gets a specific component in the IContainer.
GetComponents | Gets all the components in the IContainer.
Remove | Removes a component from the IContainer.

See Also

IContainer Interface | System.ComponentModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IContainer Methods

The methods of the IContainer interface are listed below. For a complete list of IContainer interface members, see the IContainer Members topic.

Add | Overloaded. Adds the specified component to the IContainer.
Dispose | Disposes of the IContainer.
GetComponent | Gets a specific component in the IContainer.
GetComponents | Gets all the components in the IContainer.
Remove | Removes a component from the IContainer.

See Also

IContainer Interface | System.ComponentModel Namespace


IContainer.Add

Adds the specified component to the IContainer.

Overload List

Adds the specified IComponent to the IContainer at the end of the list, and assigns a name to the component.

[Visual Basic] Overloads Sub Add(IComponent, String)
[C#] void Add(IComponent, String);
[C++] void Add(IComponent*, String) = 0;
[JScript] function Add(IComponent, String);

Adds the specified IComponent to the IContainer at the end of the list.

[Visual Basic] Overloads Sub Add(IComponent)
[C#] void Add(IComponent);
[C++] void Add(IComponent*) = 0;
[JScript] function Add(IComponent);

See Also

IContainer Interface | IContainer Members | System.ComponentModel Namespace


IContainer.Add (IComponent, String)

Adds the specified IComponent to the IContainer at the end of the list, and assigns a name to the component.

[Visual Basic]
Overloads Sub Add( _
   ByVal component As IComponent, _
   ByVal name As String _
)
[C#]
void Add(
   IComponent component,
   string name
);
[C++]
void Add(
   IComponent* component,
   String* name
) = 0;
[JScript]
function Add(
   component : IComponent,
   name : String
);

Parameters

component
The IComponent to add.
name
The name to assign to component; or a null reference object to skip the name assignment.

Return Value

None.

Exceptions

Exception Type | Condition
InvalidOperationException | name is already used by another component in the same container.

Remarks

The components within a container may or may not be named. If a component is given a name, the name must be unique among all the components within the container.

See Also

IContainer Interface | IContainer Members | System.ComponentModel Namespace | IContainer.Add Overload List


IContainer.Add (IComponent)

Adds the specified IComponent to the IContainer at the end of the list.

[Visual Basic]
Overloads Sub Add( _
   ByVal component As IComponent _
)
[C#]
void Add(
   IComponent component
);
[C++]
void Add(
   IComponent* component
) = 0;
[JScript]
function Add(
   component : IComponent
);

Parameters

component
The IComponent to add.

Return Value

None.

See Also

IContainer Interface | IContainer Members | System.ComponentModel Namespace | IContainer.Add Overload List


IContainer.Dispose

Disposes of the IContainer.

[Visual Basic]
Sub Dispose()
[C#]
void Dispose();
[C++]
void Dispose() = 0;
[JScript]
function Dispose();

Return Value

None.

Remarks

The implementation of Dispose must:

  1. Remove the components contained in the container, by using the Remove method.
  2. Remove any references to other containers. Typically, this can be accomplished by assigning a null reference object to any field that contains references to other containers.
  3. Release any system resources that are associated with the component, such as file handles, window handles, or database connections.
  4. Dispose of any child containers, such as child windows or submenu items, by calling the Dispose method of those components.

Ideally, a call to Dispose will cause the container to revert to its initial state, as it was immediately after it was created. However, this is not a requirement. Following a call to the Dispose method, a container is permitted to raise exceptions for operations that it cannot meaningfully perform.

See Also

IContainer Interface | IContainer Members | System.ComponentModel Namespace


IContainer.GetComponent

Gets a specific component in the IContainer.

[Visual Basic]
Function GetComponent( _
   ByVal name As String _
) As IComponent
[C#]
IComponent GetComponent(
   string name
);
[C++]
IComponent* GetComponent(
   String* name
) = 0;
[JScript]
function GetComponent(
   name : String
) : IComponent;

Parameters

name
The name of the IComponent to get.

Return Value

The IComponent specified by name; or a null reference object, if the named component cannot be found.

See Also

IContainer Interface | IContainer Members | System.ComponentModel Namespace


IContainer.GetComponents

Gets all the components in the IContainer.

[Visual Basic]
Function GetComponents() As IComponent ()
[C#]
IComponent[] GetComponents();
[C++]
IComponent* GetComponents() [] = 0;
[JScript]
function GetComponents() : IComponent[];

Return Value

An array of IComponent objects representing all the components in the IContainer.

See Also

IContainer Interface | IContainer Members | System.ComponentModel Namespace


IContainer.Remove

Removes a component from the IContainer.

[Visual Basic]
Sub Remove( _
   ByVal component As IComponent _
)
[C#]
void Remove(
   IComponent component
);
[C++]
void Remove(
   IComponent* component
) = 0;
[JScript]
function Remove(
   component : IComponent
);

Parameters

component
The IComponent to remove.

Return Value

None.

See Also

IContainer Interface | IContainer Members | System.ComponentModel Namespace


ICustomTypeDescriptor Interface

[To be supplied.]

ICustomTypeDescriptor

[Visual Basic]
Public Interface ICustomTypeDescriptor
[C#]
public interface ICustomTypeDescriptor
[C++]
public __gc __interface ICustomTypeDescriptor

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement ICustomTypeDescriptor

Class | Description
AxHost | Wraps ActiveX controls and exposes them as fully featured WinForms controls.
DataRowViewTypeDescriptor | [To be supplied.]
DataSetViewListItemTypeDescriptor | [To be supplied.]

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

ICustomTypeDescriptor Members | System.ComponentModel Namespace


ICustomTypeDescriptor Members

Methods

GetAttributes | Retrieves an array of member attributes for the given object.
GetClassName | Retrieves the class name for this object. If null is returned, the type name is used.
GetComponentName | Retrieves the name for this object. If null is returned, the default is used.
GetConverter | Retrieves the type converter for this object.
GetDefaultEvent | Retrieves the default event.
GetDefaultProperty | Retrieves the default property.
GetEditor | Retrieves the an editor for this object.
GetEvents | Overloaded. [To be supplied.]
GetProperties | Overloaded. [To be supplied.]
GetPropertyOwner | Retrieves the object that directly depends on this value being edited. This is generally the object that is required for the PropertyDescriptor's GetValue and SetValue methods. If 'null' is passed for the PropertyDescriptor, the ICustomComponent descripotor implemementation should return the default object, that is the main object that exposes the properties and attributes,

See Also

ICustomTypeDescriptor Interface | System.ComponentModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICustomTypeDescriptor Methods

The methods of the ICustomTypeDescriptor interface are listed below. For a complete list of ICustomTypeDescriptor interface members, see the ICustomTypeDescriptor Members topic.

GetAttributes | Retrieves an array of member attributes for the given object.
GetClassName | Retrieves the class name for this object. If null is returned, the type name is used.
GetComponentName | Retrieves the name for this object. If null is returned, the default is used.
GetConverter | Retrieves the type converter for this object.
GetDefaultEvent | Retrieves the default event.
GetDefaultProperty | Retrieves the default property.
GetEditor | Retrieves the an editor for this object.
GetEvents | Overloaded. [To be supplied.]
GetProperties | Overloaded. [To be supplied.]
GetPropertyOwner | Retrieves the object that directly depends on this value being edited. This is generally the object that is required for the PropertyDescriptor's GetValue and SetValue methods. If 'null' is passed for the PropertyDescriptor, the ICustomComponent descripotor implemementation should return the default object, that is the main object that exposes the properties and attributes,

See Also

ICustomTypeDescriptor Interface | System.ComponentModel Namespace


ICustomTypeDescriptor.GetAttributes

Retrieves an array of member attributes for the given object.

[Visual Basic]
Function GetAttributes() As MemberAttributeCollection
[C#]
MemberAttributeCollection GetAttributes();
[C++]
MemberAttributeCollection* GetAttributes() = 0;
[JScript]
function GetAttributes() : MemberAttributeCollection;

Return Value

the array of attributes on the class. This will never be null.

See Also

ICustomTypeDescriptor Interface | ICustomTypeDescriptor Members | System.ComponentModel Namespace


ICustomTypeDescriptor.GetClassName

Retrieves the class name for this object. If null is returned, the type name is used.

[Visual Basic]
Function GetClassName() As String
[C#]
string GetClassName();
[C++]
String* GetClassName() = 0;
[JScript]
function GetClassName() : String;

Return Value

The class name for the object, or null if the default will be used.

See Also

ICustomTypeDescriptor Interface | ICustomTypeDescriptor Members | System.ComponentModel Namespace


ICustomTypeDescriptor.GetComponentName

Retrieves the name for this object. If null is returned, the default is used.

[Visual Basic]
Function GetComponentName() As String
[C#]
string GetComponentName();
[C++]
String* GetComponentName() = 0;
[JScript]
function GetComponentName() : String;

Return Value

The name for the object, or null if the default will be used.

See Also

ICustomTypeDescriptor Interface | ICustomTypeDescriptor Members | System.ComponentModel Namespace


ICustomTypeDescriptor.GetConverter

Retrieves the type converter for this object.

[Visual Basic]
Function GetConverter() As TypeConverter
[C#]
TypeConverter GetConverter();
[C++]
TypeConverter* GetConverter() = 0;
[JScript]
function GetConverter() : TypeConverter;

Return Value

A TypeConverter. If null is returned, the default is used.

See Also

ICustomTypeDescriptor Interface | ICustomTypeDescriptor Members | System.ComponentModel Namespace


ICustomTypeDescriptor.GetDefaultEvent

Retrieves the default event.

[Visual Basic]
Function GetDefaultEvent() As EventDescriptor
[C#]
EventDescriptor GetDefaultEvent();
[C++]
EventDescriptor* GetDefaultEvent() = 0;
[JScript]
function GetDefaultEvent() : EventDescriptor;

Return Value

the default event, or null if there are no events

See Also

ICustomTypeDescriptor Interface | ICustomTypeDescriptor Members | System.ComponentModel Namespace


ICustomTypeDescriptor.GetDefaultProperty

Retrieves the default property.

[Visual Basic]
Function GetDefaultProperty() As PropertyDescriptor
[C#]
PropertyDescriptor GetDefaultProperty();
[C++]
PropertyDescriptor* GetDefaultProperty() = 0;
[JScript]
function GetDefaultProperty() : PropertyDescriptor;

Return Value

the default property, or null if there are no properties

See Also

ICustomTypeDescriptor Interface | ICustomTypeDescriptor Members | System.ComponentModel Namespace


ICustomTypeDescriptor.GetEditor

Retrieves the an editor for this object.

[Visual Basic]
Function GetEditor( _
   ByVal editorBaseType As Type _
) As Object
[C#]
object GetEditor(
   Type editorBaseType
);
[C++]
Object* GetEditor(
   Type* editorBaseType
) = 0;
[JScript]
function GetEditor(
   editorBaseType : Type
) : Object;

Parameters

editorBaseType
[To be supplied.]

Return Value

An editor of the requested type, or null.

See Also

ICustomTypeDescriptor Interface | ICustomTypeDescriptor Members | System.ComponentModel Namespace


ICustomTypeDescriptor.GetEvents

[To be supplied.]

Overload List

Retrieves an array of events that the given component instance provides. This may differ from the set of events the class provides. If the component is sited, the site may add or remove additional events. The returned array of events will be filtered by the given set of attributes.

[Visual Basic] Overloads Function GetEvents(MemberAttribute()) As EventDescriptorCollection
[C#] EventDescriptorCollection GetEvents(MemberAttribute[]);
[C++] EventDescriptorCollection* GetEvents(MemberAttribute*[]) = 0;
[JScript] function GetEvents(MemberAttribute[]) : EventDescriptorCollection;

Retrieves an array of events that the given component instance provides. This may differ from the set of events the class provides. If the component is sited, the site may add or remove additional events.

[Visual Basic] Overloads Function GetEvents() As EventDescriptorCollection
[C#] EventDescriptorCollection GetEvents();
[C++] EventDescriptorCollection* GetEvents() = 0;
[JScript] function GetEvents() : EventDescriptorCollection;

See Also

ICustomTypeDescriptor Interface | ICustomTypeDescriptor Members | System.ComponentModel Namespace


ICustomTypeDescriptor.GetEvents (MemberAttribute[])

Retrieves an array of events that the given component instance provides. This may differ from the set of events the class provides. If the component is sited, the site may add or remove additional events. The returned array of events will be filtered by the given set of attributes.

[Visual Basic]
Overloads Function GetEvents( _
   ByVal attributes() As MemberAttribute _
) As EventDescriptorCollection
[C#]
EventDescriptorCollection GetEvents(
   MemberAttribute[] attributes
);
[C++]
EventDescriptorCollection* GetEvents(
   MemberAttribute* attributes[]
) = 0;
[JScript]
function GetEvents(
   attributes : MemberAttribute[]
) : EventDescriptorCollection;

Parameters

attributes
A set of attributes to use as a filter. If a MemberAttribute instance is specified and the event does not have an instance of that attribute's class, this will still include the event if the MemberAttribute is the same as it's Default property.

Return Value

an array of events this component surfaces that match the given set of attributes..

See Also

ICustomTypeDescriptor Interface | ICustomTypeDescriptor Members | System.ComponentModel Namespace | ICustomTypeDescriptor.GetEvents Overload List


ICustomTypeDescriptor.GetEvents ()

Retrieves an array of events that the given component instance provides. This may differ from the set of events the class provides. If the component is sited, the site may add or remove additional events.

[Visual Basic]
Overloads Function GetEvents() As EventDescriptorCollection
[C#]
EventDescriptorCollection GetEvents();
[C++]
EventDescriptorCollection* GetEvents() = 0;
[JScript]
function GetEvents() : EventDescriptorCollection;

Return Value

an array of events this component surfaces.

See Also

ICustomTypeDescriptor Interface | ICustomTypeDescriptor Members | System.ComponentModel Namespace | ICustomTypeDescriptor.GetEvents Overload List


ICustomTypeDescriptor.GetProperties

[To be supplied.]

Overload List

Retrieves an array of properties that the given component instance provides. This may differ from the set of properties the class provides. If the component is sited, the site may add or remove additional properties. The returned array of properties will be filtered by the given set of attributes.

[Visual Basic] Overloads Function GetProperties(MemberAttribute()) As PropertyDescriptorCollection
[C#] PropertyDescriptorCollection GetProperties(MemberAttribute[]);
[C++] PropertyDescriptorCollection* GetProperties(MemberAttribute*[]) = 0;
[JScript] function GetProperties(MemberAttribute[]) : PropertyDescriptorCollection;

Retrieves an array of properties that the given component instance provides. This may differ from the set of properties the class provides. If the component is sited, the site may add or remove additional properties.

[Visual Basic] Overloads Function GetProperties() As PropertyDescriptorCollection
[C#] PropertyDescriptorCollection GetProperties();
[C++] PropertyDescriptorCollection* GetProperties() = 0;
[JScript] function GetProperties() : PropertyDescriptorCollection;

See Also

ICustomTypeDescriptor Interface | ICustomTypeDescriptor Members | System.ComponentModel Namespace


ICustomTypeDescriptor.GetProperties (MemberAttribute[])

Retrieves an array of properties that the given component instance provides. This may differ from the set of properties the class provides. If the component is sited, the site may add or remove additional properties. The returned array of properties will be filtered by the given set of attributes.

[Visual Basic]
Overloads Function GetProperties( _
   ByVal attributes() As MemberAttribute _
) As PropertyDescriptorCollection
[C#]
PropertyDescriptorCollection GetProperties(
   MemberAttribute[] attributes
);
[C++]
PropertyDescriptorCollection* GetProperties(
   MemberAttribute* attributes[]
) = 0;
[JScript]
function GetProperties(
   attributes : MemberAttribute[]
) : PropertyDescriptorCollection;

Parameters

attributes
A set of attributes to use as a filter. If a MemberAttribute instance is specified and the property does not have an instance of that attribute's class, this will still include the property if the MemberAttribute is the same as it's Default property.

Return Value

an array of properties this component surfaces that match the given set of attributes..

See Also

ICustomTypeDescriptor Interface | ICustomTypeDescriptor Members | System.ComponentModel Namespace | ICustomTypeDescriptor.GetProperties Overload List


ICustomTypeDescriptor.GetProperties ()

Retrieves an array of properties that the given component instance provides. This may differ from the set of properties the class provides. If the component is sited, the site may add or remove additional properties.

[Visual Basic]
Overloads Function GetProperties() As PropertyDescriptorCollection
[C#]
PropertyDescriptorCollection GetProperties();
[C++]
PropertyDescriptorCollection* GetProperties() = 0;
[JScript]
function GetProperties() : PropertyDescriptorCollection;

Return Value

an array of properties this component surfaces.

See Also

ICustomTypeDescriptor Interface | ICustomTypeDescriptor Members | System.ComponentModel Namespace | ICustomTypeDescriptor.GetProperties Overload List


ICustomTypeDescriptor.GetPropertyOwner

Retrieves the object that directly depends on this value being edited. This is generally the object that is required for the PropertyDescriptor's GetValue and SetValue methods. If 'null' is passed for the PropertyDescriptor, the ICustomComponent descripotor implemementation should return the default object, that is the main object that exposes the properties and attributes,

[Visual Basic]
Function GetPropertyOwner( _
   ByVal pd As PropertyDescriptor _
) As Object
[C#]
object GetPropertyOwner(
   PropertyDescriptor pd
);
[C++]
Object* GetPropertyOwner(
   PropertyDescriptor* pd
) = 0;
[JScript]
function GetPropertyOwner(
   pd : PropertyDescriptor
) : Object;

Parameters

pd
The PropertyDescriptor to find the owner for. This call should return an object such that the call "pd.GetValue(GetPropertyOwner(pd));" will generally succeed. If 'null' is passed for pd, the main object that owns the properties and attributes should be returned.

Return Value

valueOwner

See Also

ICustomTypeDescriptor Interface | ICustomTypeDescriptor Members | System.ComponentModel Namespace


IExtenderProvider Interface

Defines the interface for extending properties to other components in a container.

IExtenderProvider

[Visual Basic]
Public Interface IExtenderProvider
[C#]
public interface IExtenderProvider
[C++]
public __gc __interface IExtenderProvider

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IExtenderProvider

Class | Description
ErrorProvider | ErrorProvider presents a simple user interface for indicating to the user that a control on a form has an error associated with it. If a error description string is specified for the control, then an icon will appear next to the control, and when the mouse hovers over the icon, a tooltip will appear showing the error description string.
HelpProvider | Provides pop-up or online Help for controls.
Localizer | [To be supplied.]
PropertyTab | [To be supplied.]
ToolTip | Provides a small pop-up window containing a line of text that describes the purpose of a tool or control (usually represented as a graphical object) in a program.

Remarks

Any component that provides extender properties must implement IExtenderProvider. A visual designer can then call CanExtend to determine which objects in a container should receive the extender properties.

For more information about extender properties, see <TopicTBD>.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

IExtenderProvider Members | System.ComponentModel Namespace


IExtenderProvider Members

Methods

CanExtend Specifies whether this object can provide its extender properties to specified object.

See Also

IExtenderProvider Interface | System.ComponentModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IExtenderProvider Methods

The methods of the IExtenderProvider interface are listed below. For a complete list of IExtenderProvider interface members, see the IExtenderProvider Members topic.

CanExtend Specifies whether this object can provide its extender properties to specified object.

See Also

IExtenderProvider Interface | System.ComponentModel Namespace


IExtenderProvider.CanExtend

Specifies whether this object can provide its extender properties to specified object.

[Visual Basic]
Function CanExtend( _
   ByVal extendee As Object _
) As Boolean
[C#]
bool CanExtend(
   object extendee
);
[C++]
bool CanExtend(
   Object* extendee
) = 0;
[JScript]
function CanExtend(
   extendee : Object
) : Boolean;

Parameters

extendee
The Object to receive the extender properties.

Return Value

true if this object can provide extender properties to the extendee; otherwise, false.

Remarks

For more information on extender properties, see TopicTBD.

See Also

IExtenderProvider Interface | IExtenderProvider Members | System.ComponentModel Namespace


Int16Converter Class

Provides a type converter to convert 16-bit signed integer objects to and from various other representations.

Object
TypeConverter
Int16Converter

[Visual Basic]
Public Class Int16Converter
   Inherits TypeConverter
[C#]
public class Int16Converter : TypeConverter
[C++]
public __gc class Int16Converter : public TypeConverter
[JScript]
public class Int16Converter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace


Int32Converter Class

Provides a type converter to convert 32-bit signed integer objects to and from various other representations.

Object
TypeConverter
Int32Converter

[Visual Basic]
Public Class Int32Converter
   Inherits TypeConverter
[C#]
public class Int32Converter : TypeConverter
[C++]
public __gc class Int32Converter : public TypeConverter
[JScript]
public class Int32Converter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace


Int64Converter Class

Provides a type converter to convert 64-bit signed integer objects to and from various other representations.

Object
TypeConverter
Int64Converter

[Visual Basic]
Public Class Int64Converter
   Inherits TypeConverter
[C#]
public class Int64Converter : TypeConverter
[C++]
public __gc class Int64Converter : public TypeConverter
[JScript]
public class Int64Converter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | TypeConverter


ISite Interface

Provides functionality required by sites. Sites bind a Component to a Container and enable communication between them, as well as provide a way for the container to manage its components.

ISite

[Visual Basic]
Public Interface ISite
   Implements IServiceObjectProvider
[C#]
public interface ISite : IServiceObjectProvider
[C++]
public __gc __interface ISite : public IServiceObjectProvider

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

Sites can also serve as a repository for container-specific per-component information, such as the component name.

Notes to Implementers: To be a site, a class must implement the ISite interface.

Requirements

Namespace: System.ComponentModel

Assembly: mscorlib.dll

See Also

ISite Members | System.ComponentModel Namespace | Component | IComponent | Container | IContainer


ISite Members

Properties

Name When implemented by a class, gets or sets the name of the component associated with the ISite.

Methods

GetComponent | When implemented by a class, gets the component associated with the ISite.
GetContainer | When implemented by a class, gets the container associated with the ISite.
GetDesignMode | When implemented by a class, determines whether the component is in design mode.
GetService | When implemented by a class, gets a service provided by the ISite.

See Also

ISite Interface | System.ComponentModel Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ISite Properties

The properties of the ISite interface are listed below. For a complete list of ISite interface members, see the ISite Members topic.

Name When implemented by a class, gets or sets the name of the component associated with the ISite.

See Also

ISite Interface | System.ComponentModel Namespace


ISite.Name

When implemented by a class, gets or sets the name of the component associated with the ISite.

[Visual Basic]
Property Name As String
[C#]
string Name {get; set;}
[C++]
String* get_Name() = 0;void set_Name(String*) = 0;
[JScript]
abstract function get Name() : String;
public abstract function set Name(String);

Property Value

The name of the component associated with the ISite; or a null reference object, if no name is assigned to the component.

Remarks

The components within a container may or may not be named. If a component is given a name, the name must be unique among all the components within the container.

See Also

ISite Interface | ISite Members | System.ComponentModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ISite Methods

The methods of the ISite interface are listed below. For a complete list of ISite interface members, see the ISite Members topic.

GetComponent | When implemented by a class, gets the component associated with the ISite.
GetContainer | When implemented by a class, gets the container associated with the ISite.
GetDesignMode | When implemented by a class, determines whether the component is in design mode.
GetService | When implemented by a class, gets a service provided by the ISite.

See Also

ISite Interface | System.ComponentModel Namespace


ISite.GetComponent

When implemented by a class, gets the component associated with the ISite.

[Visual Basic]
Function GetComponent() As IComponent
[C#]
IComponent GetComponent();
[C++]
IComponent* GetComponent() = 0;
[JScript]
function GetComponent() : IComponent;

Return Value

The IComponent instance associated with the ISite.

See Also

ISite Interface | ISite Members | System.ComponentModel Namespace


ISite.GetContainer

When implemented by a class, gets the container associated with the ISite.

[Visual Basic]
Function GetContainer() As IContainer
[C#]
IContainer GetContainer();
[C++]
IContainer* GetContainer() = 0;
[JScript]
function GetContainer() : IContainer;

Return Value

The IContainer instance associated with the ISite.

See Also

ISite Interface | ISite Members | System.ComponentModel Namespace


ISite.GetDesignMode

When implemented by a class, determines whether the component is in design mode.

[Visual Basic]
Function GetDesignMode() As Boolean
[C#]
bool GetDesignMode();
[C++]
bool GetDesignMode() = 0;
[JScript]
function GetDesignMode() : Boolean;

Return Value

true if the component is in design mode; otherwise, false.

See Also

ISite Interface | ISite Members | System.ComponentModel Namespace


ISite.GetService

When implemented by a class, gets a service provided by the ISite.

[Visual Basic]
Function GetService( _
   ByVal service As Type _
) As Object
[C#]
object GetService(
   Type service
);
[C++]
Object* GetService(
   Type* service
) = 0;
[JScript]
function GetService(
   service : Type
) : Object;

Parameters

service
The class or interface that represents the service.

Return Value

An object representing the specified service; or a null reference object, if the ISite does not support the specified service.

See Also

ISite Interface | ISite Members | System.ComponentModel Namespace


ISupportInitialize Interface

Specifies that this object supports a simple, transacted notification for batch initialization.

ISupportInitialize

[Visual Basic]
Public Interface ISupportInitialize
[C#]
public interface ISupportInitialize
[C++]
public __gc __interface ISupportInitialize

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement ISupportInitialize

Class | Description
AxHost | Wraps ActiveX controls and exposes them as fully featured WinForms controls.
DataGrid | Displays ADO+ data in a scrollable grid.
EventLog | Provides interaction with Windows 2000 event logs.
FileSystemWatcher | Listens to the system directory change notifications and raises events when a directory or file within a directory changes.
NumericUpDown | Represents a Windows up-down control that displays numeric values.
Schedule | Represents a component that holds a set of time patterns which describe when to raise an event.
Timer | Handles recurring events in the application.
TrackBar | The TrackBar is a scrollable control similar to the ScrollBar, but has a different UI. You can configure ranges through which it should scroll, and also define increments for off-button clicks. It can be aligned horizontally or vertically. You can also configure how many 'ticks' are shown for the total range of values

Remarks

ISupportInitialize allows controls to optimize for multiple property sets.

Call the BeginInit method to signal the object that initialization is starting. Call the EndInit method to signal that initialization is complete.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

ISupportInitialize Members | System.ComponentModel Namespace


ISupportInitialize Members

Methods

BeginInit | When overridden in a derived class, signals the object that initialization is starting.
EndInit | When overridden in a derived class, signals the object that initialization is complete.

See Also

ISupportInitialize Interface | System.ComponentModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ISupportInitialize Methods

The methods of the ISupportInitialize interface are listed below. For a complete list of ISupportInitialize interface members, see the ISupportInitialize Members topic.

BeginInit | When overridden in a derived class, signals the object that initialization is starting.
EndInit | When overridden in a derived class, signals the object that initialization is complete.

See Also

ISupportInitialize Interface | System.ComponentModel Namespace


ISupportInitialize.BeginInit

When overridden in a derived class, signals the object that initialization is starting.

[Visual Basic]
Sub BeginInit()
[C#]
void BeginInit();
[C++]
void BeginInit() = 0;
[JScript]
function BeginInit();

See Also

ISupportInitialize Interface | ISupportInitialize Members | System.ComponentModel Namespace


ISupportInitialize.EndInit

When overridden in a derived class, signals the object that initialization is complete.

[Visual Basic]
Sub EndInit()
[C#]
void EndInit();
[C++]
void EndInit() = 0;
[JScript]
function EndInit();

See Also

ISupportInitialize Interface | ISupportInitialize Members | System.ComponentModel Namespace


ISynchronizeInvoke Interface

[To be supplied.]

ISynchronizeInvoke

[Visual Basic]
Public Interface ISynchronizeInvoke
[C#]
public interface ISynchronizeInvoke
[C++]
public __gc __interface ISynchronizeInvoke

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement ISynchronizeInvoke

Class | Description
RichControl | Defines a base class for controls, which are components with visual representation.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

ISynchronizeInvoke Members | System.ComponentModel Namespace


ISynchronizeInvoke Members

Properties

InvokeRequired Determines if the caller must call invoke when making method calls to object that implements this interface. Such objects are bound to a specific thread and are not thread safe. Therefore, if you are calling an method from a different thread, you must use the invoke method to marshal the call to the proper thread.

Methods

BeginInvoke | Executes the given delegate on the main thread that this object executes on. The delegate is called asynchronously and this method returns immediately. You may call this from any thread.
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult interface passed. If the async operation has not been completed, this function will block until the result is available.
Invoke | Executes the given delegate on the main thread that this object executes on. Exceptions that are raised during the call will be propapgated back to the caller.

See Also

ISynchronizeInvoke Interface | System.ComponentModel Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ISynchronizeInvoke Properties

The properties of the ISynchronizeInvoke interface are listed below. For a complete list of ISynchronizeInvoke interface members, see the ISynchronizeInvoke Members topic.

InvokeRequired Determines if the caller must call invoke when making method calls to object that implements this interface. Such objects are bound to a specific thread and are not thread safe. Therefore, if you are calling an method from a different thread, you must use the invoke method to marshal the call to the proper thread.

See Also

ISynchronizeInvoke Interface | System.ComponentModel Namespace


ISynchronizeInvoke.InvokeRequired

Determines if the caller must call invoke when making method calls to object that implements this interface. Such objects are bound to a specific thread and are not thread safe. Therefore, if you are calling an method from a different thread, you must use the invoke method to marshal the call to the proper thread.

[Visual Basic]
ReadOnly Property InvokeRequired As Boolean
[C#]
bool InvokeRequired {get;}
[C++]
bool get_InvokeRequired() = 0;
[JScript]
abstract function get InvokeRequired() : Boolean;

Property Value

true if the control's main thread is differnet than the calling thread, indicating that you should make calls to the control through the invoke method.

See Also

ISynchronizeInvoke Interface | ISynchronizeInvoke Members | System.ComponentModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ISynchronizeInvoke Methods

The methods of the ISynchronizeInvoke interface are listed below. For a complete list of ISynchronizeInvoke interface members, see the ISynchronizeInvoke Members topic.

BeginInvoke | Executes the given delegate on the main thread that this object executes on. The delegate is called asynchronously and this method returns immediately. You may call this from any thread.
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult interface passed. If the async operation has not been completed, this function will block until the result is available.
Invoke | Executes the given delegate on the main thread that this object executes on. Exceptions that are raised during the call will be propapgated back to the caller.

See Also

ISynchronizeInvoke Interface | System.ComponentModel Namespace


ISynchronizeInvoke.BeginInvoke

Executes the given delegate on the main thread that this object executes on. The delegate is called asynchronously and this method returns immediately. You may call this from any thread.

[Visual Basic]
Function BeginInvoke( _
   ByVal method As Delegate, _
   ByVal args() As Object _
) As IAsyncResult
[C#]
IAsyncResult BeginInvoke(
   Delegate method,
   object[] args
);
[C++]
IAsyncResult* BeginInvoke(
   Delegate* method,
   Object* args[]
) = 0;
[JScript]
function BeginInvoke(
   method : Delegate,
   args : Object[]
) : IAsyncResult;

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in args.
args
An array of objects to pass as arguments to the given method. This can be null if no arguments are needed.

See Also

ISynchronizeInvoke Interface | ISynchronizeInvoke Members | System.ComponentModel Namespace


ISynchronizeInvoke.EndInvoke

Retrieves the return value of the asynchronous operation represented by the IAsyncResult interface passed. If the async operation has not been completed, this function will block until the result is available.

[Visual Basic]
Function EndInvoke( _
   ByVal result As IAsyncResult _
) As Object
[C#]
object EndInvoke(
   IAsyncResult result
);
[C++]
Object* EndInvoke(
   IAsyncResult* result
) = 0;
[JScript]
function EndInvoke(
   result : IAsyncResult
) : Object;

Parameters

result
[To be supplied.]

Return Value

The return value generated by the asynchronous operation.

See Also

ISynchronizeInvoke Interface | ISynchronizeInvoke Members | System.ComponentModel Namespace


ISynchronizeInvoke.Invoke

Executes the given delegate on the main thread that this object executes on. Exceptions that are raised during the call will be propapgated back to the caller.

[Visual Basic]
Function Invoke( _
   ByVal method As Delegate, _
   ByVal args() As Object _
) As Object
[C#]
object Invoke(
   Delegate method,
   object[] args
);
[C++]
Object* Invoke(
   Delegate* method,
   Object* args[]
) = 0;
[JScript]
function Invoke(
   method : Delegate,
   args : Object[]
) : Object;

Parameters

method
A delegate that contains a method to be called in in the control's thread context.
args
An array of objects to pass as arguments to the given method. This can be null if no arguments are needed.

Return Value

the return value from the delegate being invoked, or null if the delegate has no return value.

See Also

ISynchronizeInvoke Interface | ISynchronizeInvoke Members | System.ComponentModel Namespace


ITypeDescriptorContext Interface

Provides a context to a value formatter, so that the value formatter can perform a conversion.

ITypeDescriptorContext

[Visual Basic]
Public Interface ITypeDescriptorContext
   Implements IServiceObjectProvider
[C#]
public interface ITypeDescriptorContext : IServiceObjectProvider
[C++]
public __gc __interface ITypeDescriptorContext : public
   IServiceObjectProvider

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

This interface is typically used at design time to provide information about a design-time container. This interface is optional. It can enable a conversion that is otherwise impossible.

Notes to Callers: You should not rely on the presence of this context interface when you design a formatter. If a particular interface, property, or service is necessary but not available, the formatter should return a null reference (in Visual Basic Nothing) rather than throw an exception. This interface's properties can return a null reference (Nothing) at any time, and you should plan for this.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

ITypeDescriptorContext Members | System.ComponentModel Namespace


ITypeDescriptorContext Members

Properties

Container | When overridden in a derived class, gets the container with the set of objects for this formatter.
Instance | When implemented in a deriving class, gets the instance that is invoking the method on the formatter object.

Methods

OnComponentChanged | Fires the notification that the Instance object has been changed.
OnComponentChanging | Fires the notification that the Instance object is going to be changed. If this object may be changed, true is returned. If false is returned, the change should not be made.

See Also

ITypeDescriptorContext Interface | System.ComponentModel Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ITypeDescriptorContext Properties

The properties of the ITypeDescriptorContext interface are listed below. For a complete list of ITypeDescriptorContext interface members, see the ITypeDescriptorContext Members topic.

Container | When overridden in a derived class, gets the container with the set of objects for this formatter.
Instance | When implemented in a deriving class, gets the instance that is invoking the method on the formatter object.

See Also

ITypeDescriptorContext Interface | System.ComponentModel Namespace


ITypeDescriptorContext.Container

When overridden in a derived class, gets the container with the set of objects for this formatter.

[Visual Basic]
ReadOnly Property Container As IContainer
[C#]
IContainer Container {get;}
[C++]
IContainer* get_Container() = 0;
[JScript]
abstract function get Container() : IContainer;

Property Value

An IContainer with the set of objects for this formatter. It returns a null reference (in Visual Basic Nothing) if there is no container, or if the formatter does not use any outside objects.

See Also

ITypeDescriptorContext Interface | ITypeDescriptorContext Members | System.ComponentModel Namespace


ITypeDescriptorContext.Instance

When implemented in a deriving class, gets the instance that is invoking the method on the formatter object.

[Visual Basic]
ReadOnly Property Instance As Object
[C#]
object Instance {get;}
[C++]
Object* get_Instance() = 0;
[JScript]
abstract function get Instance() : Object;

Property Value

The instance that is invoking the method on the formatter object. This returns a null reference (in Visual Basic Nothing) if there is no instance responsible for the call.

See Also

ITypeDescriptorContext Interface | ITypeDescriptorContext Members | System.ComponentModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ITypeDescriptorContext Methods

The methods of the ITypeDescriptorContext interface are listed below. For a complete list of ITypeDescriptorContext interface members, see the ITypeDescriptorContext Members topic.

OnComponentChanged | Fires the notification that the Instance object has been changed.
OnComponentChanging | Fires the notification that the Instance object is going to be changed. If this object may be changed, true is returned. If false is returned, the change should not be made.

See Also

ITypeDescriptorContext Interface | System.ComponentModel Namespace


ITypeDescriptorContext.OnComponentChanged

Fires the notification that the Instance object has been changed.

[Visual Basic]
Sub OnComponentChanged()
[C#]
void OnComponentChanged();
[C++]
void OnComponentChanged() = 0;
[JScript]
function OnComponentChanged();

See Also

ITypeDescriptorContext Interface | ITypeDescriptorContext Members | System.ComponentModel Namespace


ITypeDescriptorContext.OnComponentChanging

Fires the notification that the Instance object is going to be changed. If this object may be changed, true is returned. If false is returned, the change should not be made.

[Visual Basic]
Function OnComponentChanging() As Boolean
[C#]
bool OnComponentChanging();
[C++]
bool OnComponentChanging() = 0;
[JScript]
function OnComponentChanging() : Boolean;

See Also

ITypeDescriptorContext Interface | ITypeDescriptorContext Members | System.ComponentModel Namespace


IValueAccess Interface

[To be supplied.]

IValueAccess

[Visual Basic]
Public Interface IValueAccess
[C#]
public interface IValueAccess
[C++]
public __gc __interface IValueAccess

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

IValueAccess Members | System.ComponentModel Namespace


IValueAccess Members

Properties

Value Value to be edited.

Methods

GetServiceObject | Retrieves host services that assist the value editor. The only service currently available in IEditorHost, which will be obtained by passing in typeof(IEditorSite), and IEditorSite, which can be obtained by passing in typeof(IEditorSite).
ValueChanged | Notifies the ValueAccess implementation that the object returned from the value property has been modified.

See Also

IValueAccess Interface | System.ComponentModel Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IValueAccess Properties

The properties of the IValueAccess interface are listed below. For a complete list of IValueAccess interface members, see the IValueAccess Members topic.

Value Value to be edited.

See Also

IValueAccess Interface | System.ComponentModel Namespace


IValueAccess.Value

Value to be edited.

[Visual Basic]
Property Value As Object
[C#]
object Value {get; set;}
[C++]
Object* get_Value() = 0;void set_Value(Object*) = 0;
[JScript]
abstract function get Value() : Object;
public abstract function set Value(Object);

See Also

IValueAccess Interface | IValueAccess Members | System.ComponentModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IValueAccess Methods

The methods of the IValueAccess interface are listed below. For a complete list of IValueAccess interface members, see the IValueAccess Members topic.

GetServiceObject | Retrieves host services that assist the value editor. The only service currently available in IEditorHost, which will be obtained by passing in typeof(IEditorSite), and IEditorSite, which can be obtained by passing in typeof(IEditorSite).
ValueChanged | Notifies the ValueAccess implementation that the object returned from the value property has been modified.

See Also

IValueAccess Interface | System.ComponentModel Namespace


IValueAccess.GetServiceObject

Retrieves host services that assist the value editor. The only service currently available in IEditorHost, which will be obtained by passing in typeof(IEditorSite), and IEditorSite, which can be obtained by passing in typeof(IEditorSite).

[Visual Basic]
Function GetServiceObject( _
   ByVal serviceClass As Type _
) As Object
[C#]
object GetServiceObject(
   Type serviceClass
);
[C++]
Object* GetServiceObject(
   Type* serviceClass
) = 0;
[JScript]
function GetServiceObject(
   serviceClass : Type
) : Object;

Parameters

serviceClass
[To be supplied.]

Return Value

service that was requested. (returning null if service wasn't available.)

See Also

IValueAccess Interface | IValueAccess Members | System.ComponentModel Namespace


IValueAccess.ValueChanged

Notifies the ValueAccess implementation that the object returned from the value property has been modified.

[Visual Basic]
Sub ValueChanged()
[C#]
void ValueChanged();
[C++]
void ValueChanged() = 0;
[JScript]
function ValueChanged();

Remarks

If you replace the value (by setting the value property) it is not neccessary to call ValueChanged. However, if you modify the object, you must call ValueChanged.

See Also

IValueAccess Interface | IValueAccess Members | System.ComponentModel Namespace


License Class

Provides the abstract (in Visual Basic MustInherit) base class for all licenses. A license is granted to a specific instance of a component.

Object
License

[Visual Basic]
MustInherit Public Class License
[C#]
public abstract class License
[C++]
public __gc __abstract class License
[JScript]
public abstract class License

Remarks

All components must call Dispose for the licenses that they grant when the component is disposed or finalized.

Notes to Inheritors: When you inherit from License, you must override the following members: LicenseKey and Dispose.

For more information on licensing, see TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

License Members | System.ComponentModel Namespace | LicenseContext | LicenseException | LicenseManager | LicenseProvider | LicenseProviderAttribute | LicFileLicenseProvider | LicenseUsageMode


License Members

Public:

Constructor

License Constructor [To be supplied.]

Properties

LicenseKey When overridden in a derived class, gets the license key granted to this component.

Methods

Dispose | When overridden in a derived class, releases the license.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

License Class | System.ComponentModel Namespace


License Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public License();
[C++]
public: License();
[JScript]
public function License();

See Also

License Class | License Members | System.ComponentModel Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

License Properties

The properties of the License class are listed below. For a complete list of License class members, see the License Members topic.

Public:

LicenseKey When overridden in a derived class, gets the license key granted to this component.

See Also

License Class | System.ComponentModel Namespace


License.LicenseKey

When overridden in a derived class, gets the license key granted to this component.

[Visual Basic]
MustOverride Public ReadOnly Property LicenseKey As String
[C#]
public string LicenseKey {abstract get;}
[C++]
public: __property virtual String* get_LicenseKey() = 0;
[JScript]
public abstract function get LicenseKey() : String;

Property Value

A license key granted to this component.

Remarks

System.ComponentModel.LicenseProviders can use any Unicode character string as a license key. The LicenseKey should be treated as an opaque cookie.

See Also

License Class | License Members | System.ComponentModel Namespace | License | LicenseContext | LicenseException | LicenseManager | LicenseProvider | LicenseProviderAttribute | LicFileLicenseProvider | LicenseUsageMode


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

License Methods

The methods of the License class are listed below. For a complete list of License class members, see the License Members topic.

Public:

Dispose | When overridden in a derived class, releases the license.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

License Class | System.ComponentModel Namespace


License.Dispose

When overridden in a derived class, releases the license.

[Visual Basic]
MustOverride Public Sub Dispose()
[C#]
public abstract void Dispose();
[C++]
public: virtual void Dispose() = 0;
[JScript]
public abstract function Dispose();

Remarks

All components must call Dispose for the licenses that they grant when the component is disposed or finalized.

A LicenseProvider can use the licenses it grants to track its usage.

See Also

License Class | License Members | System.ComponentModel Namespace | License | LicenseContext | LicenseException | LicenseManager | LicenseProvider | LicenseProviderAttribute | LicFileLicenseProvider | LicenseUsageMode


LicenseContext Class

Specifies when the licensed object can be used.

Object
LicenseContext

[Visual Basic]
Public Class LicenseContext
[C#]
public class LicenseContext
[C++]
public __gc class LicenseContext
[JScript]
public class LicenseContext

Remarks

This class provides the default LicenseContext. It only implements run-time support and it does not support saved license keys.

Notes to Inheritors: If you want to implement design-time license support, you must inherit from this class, and override the following members: UsageMode, GetSavedLicenseKey, and SetSavedLicenseKey. If you want to implement saved license keys, override the SetSavedLicenseKey method.

For more information on licensing, see TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

LicenseContext Members | System.ComponentModel Namespace | License | LicenseException | LicenseManager | LicenseProvider | LicenseProviderAttribute | LicFileLicenseProvider | LicenseUsageMode


LicenseContext Members

Public:

Constructor

LicenseContext Constructor [To be supplied.]

Properties

UsageMode When overridden in a derived class, gets a value that specifies when a license can be used.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSavedLicenseKey | When overridden in a derived class, gets a saved license key for the specified type, from the specified resourceAssembly.
GetType (inherited from Object) | Gets the Type of the Object.
SetSavedLicenseKey | When overridden in a derived class, sets a license key for the specified type.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LicenseContext Class | System.ComponentModel Namespace


LicenseContext Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public LicenseContext();
[C++]
public: LicenseContext();
[JScript]
public function LicenseContext();

See Also

LicenseContext Class | LicenseContext Members | System.ComponentModel Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

LicenseContext Properties

The properties of the LicenseContext class are listed below. For a complete list of LicenseContext class members, see the LicenseContext Members topic.

Public:

UsageMode When overridden in a derived class, gets a value that specifies when a license can be used.

See Also

LicenseContext Class | System.ComponentModel Namespace


LicenseContext.UsageMode

When overridden in a derived class, gets a value that specifies when a license can be used.

[Visual Basic]
Overridable Public ReadOnly Property UsageMode As LicenseUsageMode
[C#]
public LicenseUsageMode UsageMode {virtual get;}
[C++]
public: __property virtual LicenseUsageMode get_UsageMode();
[JScript]
public function get UsageMode() : LicenseUsageMode;

Property Value

One of the LicenseUsageMode values that specifies when a license can be used.

Remarks

As implemented in this class, this property returns the LicenseUsageMode Runtime.

Notes to Inheritors: To implement design-time support, override this property in an inheriting class.

See Also

LicenseContext Class | LicenseContext Members | System.ComponentModel Namespace | License | LicenseContext | LicenseException | LicenseManager | LicenseProvider | LicenseProviderAttribute | LicFileLicenseProvider | LicenseUsageMode


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

LicenseContext Methods

The methods of the LicenseContext class are listed below. For a complete list of LicenseContext class members, see the LicenseContext Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSavedLicenseKey | When overridden in a derived class, gets a saved license key for the specified type, from the specified resourceAssembly.
GetType (inherited from Object) | Gets the Type of the Object.
SetSavedLicenseKey | When overridden in a derived class, sets a license key for the specified type.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LicenseContext Class | System.ComponentModel Namespace


LicenseContext.GetSavedLicenseKey

When overridden in a derived class, gets a saved license key for the specified type, from the specified resourceAssembly.

[Visual Basic]
Overridable Public Function GetSavedLicenseKey( _
   ByVal type As Type, _
   ByVal resourceAssembly As Assembly _
) As String
[C#]
public virtual string GetSavedLicenseKey(
   Type type,
   Assembly resourceAssembly
);
[C++]
public: virtual String* GetSavedLicenseKey(
   Type* type,
   Assembly* resourceAssembly
);
[JScript]
public function GetSavedLicenseKey(
   type : Type,
   resourceAssembly : Assembly
) : String;

Parameters

type
A Type that represents the type of component.
resourceAssembly
An Assembly with the license key.

Return Value

The LicenseKey for the specified type.

Remarks

As implemented in this class, this method returns a null reference (in Visual Basic Nothing).

Notes to Inheritors: If resourceAssembly is a null reference (Nothing), then you should retrieve the resource from the primary executing Assembly.

See Also

LicenseContext Class | LicenseContext Members | System.ComponentModel Namespace | License | LicenseContext | LicenseException | LicenseManager | LicenseProvider | LicenseProviderAttribute | LicFileLicenseProvider | LicenseUsageMode


LicenseContext.SetSavedLicenseKey

When overridden in a derived class, sets a license key for the specified type.

[Visual Basic]
Overridable Public Sub SetSavedLicenseKey( _
   ByVal type As Type, _
   ByVal key As String _
)
[C#]
public virtual void SetSavedLicenseKey(
   Type type,
   string key
);
[C++]
public: virtual void SetSavedLicenseKey(
   Type* type,
   String* key
);
[JScript]
public function SetSavedLicenseKey(
   type : Type,
   key : String
);

Parameters

type
A Type that represents the component associated with the license key.
key
The LicenseKey to save for the type of component.

Remarks

This class, as implemented, does not provide support for saved license keys.

Notes to Inheritors: Typically, you should call this method when you set System.LicenseUsageMode at design time.

See Also

LicenseContext Class | LicenseContext Members | System.ComponentModel Namespace | License | LicenseContext | LicenseException | LicenseManager | LicenseProvider | LicenseProviderAttribute | LicFileLicenseProvider | LicenseUsageMode


LicenseException Class

Represents the exception thrown when a component cannot be granted a license.

Object
Exception
LicenseException

[Visual Basic]
Public Class LicenseException
   Inherits Exception
[C#]
public class LicenseException : Exception
[C++]
public __gc class LicenseException : public Exception
[JScript]
public class LicenseException extends Exception

Remarks

LicenseException is thrown by the Validate method when a component cannot obtain a valid license. This occurs when a component is either not licensed, or is licensed, but cannot be granted a valid license.For more information on licensing, see TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

LicenseException Members | System.ComponentModel Namespace | License | LicenseContext | LicenseManager | LicenseProvider | LicenseProviderAttribute | LicFileLicenseProvider | LicenseUsageMode


LicenseException Members

Public:

Constructor

LicenseException Constructor Overloaded. Initializes a new instance of the LicenseException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
LicensedType | Gets the type of the component that was not granted a license.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

LicenseException Class | System.ComponentModel Namespace


LicenseException Constructor

Initializes a new instance of the LicenseException class.

Overload List

Initializes a new instance of the LicenseException class for the specified type.

[Visual Basic] Overloads Public Sub New(Type)
[C#] public LicenseException(Type);
[C++] public: LicenseException(Type*);
[JScript] public function LicenseException(Type);

Initializes a new instance of the LicenseException class for the specified type and instance.

[Visual Basic] Overloads Public Sub New(Type, Object)
[C#] public LicenseException(Type, Object);
[C++] public: LicenseException(Type*, Object);
[JScript] public function LicenseException(Type, Object);

Initializes a new instance of the LicenseException class for the specified type and instance with the specified message.

[Visual Basic] Overloads Public Sub New(Type, Object, String)
[C#] public LicenseException(Type, Object, String);
[C++] public: LicenseException(Type*, Object, String);
[JScript] public function LicenseException(Type, Object, String);

Initializes a new instance of the LicenseException class for the specified innerException, type and instance with the specified message.

[Visual Basic] Overloads Public Sub New(Type, Object, String, Exception)
[C#] public LicenseException(Type, Object, String, Exception);
[C++] public: LicenseException(Type*, Object, String, Exception);
[JScript] public function LicenseException(Type, Object, String, Exception);

See Also

LicenseException Class | LicenseException Members | System.ComponentModel Namespace


LicenseException Constructor (Type)

Initializes a new instance of the LicenseException class for the specified type.

[Visual Basic]
Overloads Public Sub New( _
   ByVal type As Type _
)
[C#]
public LicenseException(
   Type type
);
[C++]
public: LicenseException(
   Type* type
);
[JScript]
public function LicenseException(
   type : Type
);

Parameters

type
A Type that represents the type of component that was not granted a license.

See Also

LicenseException Class | LicenseException Members | System.ComponentModel Namespace | LicenseException Constructor Overload List | License | LicenseContext | LicenseException | LicenseManager | LicenseProvider | LicenseProviderAttribute | LicFileLicenseProvider | LicenseUsageMode


LicenseException Constructor (Type, Object)

Initializes a new instance of the LicenseException class for the specified type and instance.

[Visual Basic]
Overloads Public Sub New( _
   ByVal type As Type, _
   ByVal instance As Object _
)
[C#]
public LicenseException(
   Type type,
   object instance
);
[C++]
public: LicenseException(
   Type* type,
   Object* instance
);
[JScript]
public function LicenseException(
   type : Type,
   instance : Object
);

Parameters

type
A Type that represents the type of component that was not granted a license.
instance
The instance of the component that was not granted a license.

See Also

LicenseException Class | LicenseException Members | System.ComponentModel Namespace | LicenseException Constructor Overload List | License | LicenseContext | LicenseException | LicenseManager | LicenseProvider | LicenseProviderAttribute | LicFileLicenseProvider | LicenseUsageMode


LicenseException Constructor (Type, Object, String)

Initializes a new instance of the LicenseException class for the specified type and instance with the specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal type As Type, _
   ByVal instance As Object, _
   ByVal message As String _
)
[C#]
public LicenseException(
   Type type,
   object instance,
   string message
);
[C++]
public: LicenseException(
   Type* type,
   Object* instance,
   String* message
);
[JScript]
public function LicenseException(
   type : Type,
   instance : Object,
   message : String
);

Parameters

type
A Type that represents the type of component that was not granted a license.
instance
The instance of the component that was not granted a license.
message
The exception message to display.

See Also

LicenseException Class | LicenseException Members | System.ComponentModel Namespace | LicenseException Constructor Overload List | License | LicenseContext | LicenseException | LicenseManager | LicenseProvider | LicenseProviderAttribute | LicFileLicenseProvider | LicenseUsageMode


LicenseException Constructor (Type, Object, String, Exception)

Initializes a new instance of the LicenseException class for the specified innerException, type and instance with the specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal type As Type, _
   ByVal instance As Object, _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public LicenseException(
   Type type,
   object instance,
   string message,
   Exception innerException
);
[C++]
public: LicenseException(
   Type* type,
   Object* instance,
   String* message,
   Exception* innerException
);
[JScript]
public function LicenseException(
   type : Type,
   instance : Object,
   message : String,
   innerException : Exception
);

Parameters

type
A Type that represents the type of component that was not granted a license.
instance
The instance of the component that was not granted a license.
message
The exception message to display.
innerException
An Exception that represents theoriginal exception.

See Also

LicenseException Class | LicenseException Members | System.ComponentModel Namespace | LicenseException Constructor Overload List | License | LicenseContext | LicenseException | LicenseManager | LicenseProvider | LicenseProviderAttribute | LicFileLicenseProvider | LicenseUsageMode


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

LicenseException Properties

The properties of the LicenseException class are listed below. For a complete list of LicenseException class members, see the LicenseException Members topic.

Public:

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
LicensedType | Gets the type of the component that was not granted a license.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

See Also

LicenseException Class | System.ComponentModel Namespace


LicenseException.LicensedType

Gets the type of the component that was not granted a license.

[Visual Basic]
Public ReadOnly Property LicensedType As Type
[C#]
public Type LicensedType {get;}
[C++]
public: __property Type* get_LicensedType();
[JScript]
public function get LicensedType() : Type;

Property Value

A Type that represents the type of component that was not granted a license.

See Also

LicenseException Class | LicenseException Members | System.ComponentModel Namespace | License | LicenseContext | LicenseException | LicenseManager | LicenseProvider | LicenseProviderAttribute | LicFileLicenseProvider | LicenseUsageMode


LicenseManager Class

Provides properties and methods to add a license to a component and to manage a LicenseProvider. This class cannot be inherited.

Object
LicenseManager

[Visual Basic]
NotInheritable Public Class LicenseManager
[C#]
public sealed class LicenseManager
[C++]
public __gc __sealed class LicenseManager
[JScript]
public class LicenseManager

Remarks

LicenseManager provides the following static (in Visual Basic Shared) properties: CurrentContext and UsageMode. The class also provides the following static (Shared) methods: CreateWithContext, IsValid, Validate.

When you create a component that you want to license, you must:

  1. Specify the LicenseProvider by marking the component with a LicenseProviderAttribute.
  2. Call Validate or IsValid in the constructor of the component. Validate will throw a LicenseException when it tries to create an instance without a valid license. IsValid will not throw an exception.
  3. Dispose any license that is granted when the component is disposed or finalized.

For more information on licensing, see TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

Example [C#]

This example creates a licensed control using the Validate method. It uses a LicenseProvider that is implemented by the LicFileLicenseProvider class.

[C#]

// Add the LicenseProviderAttribute to the control.

{LicenseProvider[typeof[LicFileLicenseProvider}}]
public class MyControl : RichControl {

   // Create a new null license.

   private License license = null;

   public MyControl () {

      // Add Validate to the control's constructor.

      license = LicenseManager.Validate(typeof(MyControl), this);

      // Perform other instantiation tasks.

   }

   public override void Dispose() {
      if (license != null) {
         license.Dispose();
         license = null;
      }
   }

   protected override void Finalize() {
      Dispose();
      base.Finalize();
   }
}

See Also

LicenseManager Members | System.ComponentModel Namespace | License | LicenseContext | LicenseException | LicenseProvider | LicenseProviderAttribute | LicFileLicenseProvider | LicenseUsageMode


LicenseManager Members

Public:

Constructor

LicenseManager Constructor [To be supplied.]

Properties

CurrentContext | Gets or sets the current LicenseContext which specifies when the licensed object can be used.
UsageMode | Gets the LicenseUsageMode that specifies when the licensed object can be used, for the CurrentContext.

Methods

CreateWithContext | Overloaded. Creates an instance of the specified type.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsValid | Overloaded. Determines if a valid license can be granted.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Overloaded. Determines if a license can be granted.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LicenseManager Class | System.ComponentModel Namespace


LicenseManager Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public LicenseManager();
[C++]
public: LicenseManager();
[JScript]
public function LicenseManager();

See Also

LicenseManager Class | LicenseManager Members | System.ComponentModel Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

LicenseManager Properties

The properties of the LicenseManager class are listed below. For a complete list of LicenseManager class members, see the LicenseManager Members topic.

Public:

CurrentContext | Gets or sets the current LicenseContext which specifies when the licensed object can be used.
UsageMode | Gets the LicenseUsageMode that specifies when the licensed object can be used, for the CurrentContext.

See Also

LicenseManager Class | System.ComponentModel Namespace


LicenseManager.CurrentContext

Gets or sets the current LicenseContext which specifies when the licensed object can be used.

[Visual Basic]
Public Shared Property CurrentContext As LicenseContext
[C#]
public static LicenseContext CurrentContext {get; set;}
[C++]
public: __property static LicenseContext* get_CurrentContext();
public: __property static void set_CurrentContext(LicenseContext*);
[JScript]
public static function get CurrentContext() : LicenseContext;
public static function set CurrentContext(LicenseContext);

Property Value

A LicenseContext that specifies when the licensed object can be used.

Remarks

The LicenseContext is passed into all calls to the LicenseProvider.

See Also

LicenseManager Class | LicenseManager Members | System.ComponentModel Namespace | License | LicenseContext | LicenseException | LicenseProvider | LicenseProviderAttribute | LicFileLicenseProvider | LicenseUsageMode


LicenseManager.UsageMode

Gets the LicenseUsageMode that specifies when the licensed object can be used, for the CurrentContext.

[Visual Basic]
Public Shared ReadOnly Property UsageMode As LicenseUsageMode
[C#]
public static LicenseUsageMode UsageMode {get;}
[C++]
public: __property static LicenseUsageMode get_UsageMode();
[JScript]
public static function get UsageMode() : LicenseUsageMode;

Property Value

One of the LicenseUsageMode values, as specified in the CurrentContext.

Remarks

If this property cannot find a CurrentContext value, it returns Runtime.

See Also

LicenseManager Class | LicenseManager Members | System.ComponentModel Namespace | CurrentContext | License | LicenseContext | LicenseException | LicenseProvider | LicenseProviderAttribute | LicFileLicenseProvider | LicenseUsageMode


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

LicenseManager Methods

The methods of the LicenseManager class are listed below. For a complete list of LicenseManager class members, see the LicenseManager Members topic.

Public:

CreateWithContext | Overloaded. Creates an instance of the specified type.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsValid | Overloaded. Determines if a valid license can be granted.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Overloaded. Determines if a license can be granted.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LicenseManager Class | System.ComponentModel Namespace


LicenseManager.CreateWithContext

Creates an instance of the specified type.

Overload List

Creates an instance of the specified type with the specified args, using creationContext as the context in which the licensed instance can be used.

[Visual Basic] Overloads Public Shared Function CreateWithContext(Type, LicenseContext, Object()) As Object
[C#] public static object CreateWithContext(Type, LicenseContext, Object[]);
[C++] public: static Object* CreateWithContext(Type*, LicenseContext, Object[]);
[JScript] public static function CreateWithContext(Type, LicenseContext, Object[]) : Object;

Creates an instance of the specified type, using creationContext as the context in which the licensed instance can be used.

[Visual Basic] Overloads Public Shared Function CreateWithContext(Type, LicenseContext) As Object
[C#] public static object CreateWithContext(Type, LicenseContext);
[C++] public: static Object* CreateWithContext(Type*, LicenseContext);
[JScript] public static function CreateWithContext(Type, LicenseContext) : Object;

See Also

LicenseManager Class | LicenseManager Members | System.ComponentModel Namespace


LicenseManager.CreateWithContext (Type, LicenseContext, Object[])

Creates an instance of the specified type with the specified args, using creationContext as the context in which the licensed instance can be used.

[Visual Basic]
Overloads Public Shared Function CreateWithContext( _
   ByVal type As Type, _
   ByVal creationContext As LicenseContext, _
   ByVal args() As Object _
) As Object
[C#]
public static object CreateWithContext(
   Type type,
   LicenseContext creationContext,
   object[] args
);
[C++]
public: static Object* CreateWithContext(
   Type* type,
   LicenseContext* creationContext,
   Object* args[]
);
[JScript]
public static function CreateWithContext(
   type : Type,
   creationContext : LicenseContext,
   args : Object[]
) : Object;

Parameters

type
A Type that represents the type to create.
creationContext
A LicenseContext that specifies when the licensed instance can be used.
args
An array of type Object that represent the arguments for the type.

Return Value

An instance of the specified type with the specified args, using creationContext as the LicenseContext.

Remarks

This method makes creationContext the CurrentContext for the duration of the construction. This method blocks all other threads in the AppDomain from modifying the CurrentContext, allowing CreateWithContext to behave as an atomic operation.

See Also

LicenseManager Class | LicenseManager Members | System.ComponentModel Namespace | LicenseManager.CreateWithContext Overload List | License | LicenseContext | LicenseException | LicenseProvider | LicenseProviderAttribute | LicFileLicenseProvider | LicenseUsageMode


LicenseManager.CreateWithContext (Type, LicenseContext)

Creates an instance of the specified type, using creationContext as the context in which the licensed instance can be used.

[Visual Basic]
Overloads Public Shared Function CreateWithContext( _
   ByVal type As Type, _
   ByVal creationContext As LicenseContext _
) As Object
[C#]
public static object CreateWithContext(
   Type type,
   LicenseContext creationContext
);
[C++]
public: static Object* CreateWithContext(
   Type* type,
   LicenseContext* creationContext
);
[JScript]
public static function CreateWithContext(
   type : Type,
   creationContext : LicenseContext
) : Object;

Parameters

type
A Type that represents the type to create.
creationContext
A LicenseContext that specifies when the licensed instance can be used.

Return Value

An instance of the specified type, using creationContext as the LicenseContext.

Remarks

This method makes creationContext the CurrentContext for the duration of the construction. This method blocks all other threads in the AppDomain from modifying the CurrentContext, allowing CreateWithContext to behave as an atomic operation.

See Also

LicenseManager Class | LicenseManager Members | System.ComponentModel Namespace | LicenseManager.CreateWithContext Overload List | License | LicenseContext | LicenseException | LicenseProvider | LicenseProviderAttribute | LicFileLicenseProvider | LicenseUsageMode


LicenseManager.IsValid

Determines if a valid license can be granted.

Overload List

Determines if a valid license can be granted for the specified instance of the type. This method creates a valid License.

[Visual Basic] Overloads Public Shared Function IsValid(Type, Object, License) As Boolean
[C#] public static bool IsValid(Type, Object, License);
[C++] public: static bool IsValid(Type*, Object, License);
[JScript] public static function IsValid(Type, Object, License) : Boolean;

Determines if a valid license can be granted for the specified type.

[Visual Basic] Overloads Public Shared Function IsValid(Type) As Boolean
[C#] public static bool IsValid(Type);
[C++] public: static bool IsValid(Type*);
[JScript] public static function IsValid(Type) : Boolean;

See Also

LicenseManager Class | LicenseManager Members | System.ComponentModel Namespace


LicenseManager.IsValid (Type, Object, License)

Determines if a valid license can be granted for the specified instance of the type. This method creates a valid License.

[Visual Basic]
Overloads Public Shared Function IsValid( _
   ByVal type As Type, _
   ByVal instance As Object, _
   ByRef license As License _
) As Boolean
[C#]
public static bool IsValid(
   Type type,
   object instance,
   ref License license
);
[C++]
public: static bool IsValid(
   Type* type,
   Object* instance,
   License** license
);
[JScript]
public static function IsValid(
   type : Type,
   instance : Object,
   license : License
) : Boolean;

Parameters

type
A Type that represents the type of object that is requesting the license.
instance
An object of the specified type or a type derived from the specified type.
license
This will contain a valid License on return from this method. If a valid License cannot be granted, this will be set to a null reference (in Visual Basic Nothing).

Return Value

true if a valid License can be granted; otherwise, false.

Remarks

IsValid will return true when the type is either not licensed, or is licensed and the license is valid.

This method does not throw a LicenseException when it cannot grant a valid License. The Validate method throws exceptions.

If the license parameter is not a null reference (Nothing) after this call, the object asking for a License must dispose the license by calling the Dispose method when the object is disposed or finalized.

See Also

LicenseManager Class | LicenseManager Members | System.ComponentModel Namespace | LicenseManager.IsValid Overload List | License | LicenseContext | LicenseException | LicenseProvider | LicenseProviderAttribute | LicFileLicenseProvider | LicenseUsageMode


LicenseManager.IsValid (Type)

Determines if a valid license can be granted for the specified type.

[Visual Basic]
Overloads Public Shared Function IsValid( _
   ByVal type As Type _
) As Boolean
[C#]
public static bool IsValid(
   Type type
);
[C++]
public: static bool IsValid(
   Type* type
);
[JScript]
public static function IsValid(
   type : Type
) : Boolean;

Parameters

type
A Type that represents the type of object that is requesting the License.

Return Value

true if a valid license can be granted; otherwise, false.

Remarks

IsValid will return true when the type is either not licensed, or is licensed and the license is valid.

This method does not throw a LicenseException when it cannot grant a valid License. The Validate method throws exceptions.

See Also

LicenseManager Class | LicenseManager Members | System.ComponentModel Namespace | LicenseManager.IsValid Overload List | License | LicenseContext | LicenseException | LicenseProvider | LicenseProviderAttribute | LicFileLicenseProvider | LicenseUsageMode


LicenseManager.Validate

Determines if a license can be granted.

Overload List

Determines if a license can be granted for the instance of the specified type.

[Visual Basic] Overloads Public Shared Function Validate(Type, Object) As License
[C#] public static License Validate(Type, Object);
[C++] public: static License* Validate(Type*, Object);
[JScript] public static function Validate(Type, Object) : License;

Determines if a license can be granted for the specified type.

[Visual Basic] Overloads Public Shared Sub Validate(Type)
[C#] public static void Validate(Type);
[C++] public: static void Validate(Type*);
[JScript] public static function Validate(Type);

See Also

LicenseManager Class | LicenseManager Members | System.ComponentModel Namespace


LicenseManager.Validate (Type, Object)

Determines if a license can be granted for the instance of the specified type.

[Visual Basic]
Overloads Public Shared Function Validate( _
   ByVal type As Type, _
   ByVal instance As Object _
) As License
[C#]
public static License Validate(
   Type type,
   object instance
);
[C++]
public: static License* Validate(
   Type* type,
   Object* instance
);
[JScript]
public static function Validate(
   type : Type,
   instance : Object
) : License;

Parameters

type
A Type that represents the type of object that wants the license.
instance
An object of the specified type or a type derived from the specified type.

Return Value

A valid License.

Exceptions

Exception Type | Condition
LicenseException | The type is licensed, but a License could not be granted.

Remarks

This method throws a LicenseException when a valid License cannot be granted. IsValid does not throw an exception.

If the license parameter is not a null reference (in Visual Basic Nothing) after this call, the object asking for a License must dispose the license by calling the Dispose method when the object is disposed or finalized.

See Also

LicenseManager Class | LicenseManager Members | System.ComponentModel Namespace | LicenseManager.Validate Overload List | License | LicenseContext | LicenseException | LicenseProvider | LicenseProviderAttribute | LicFileLicenseProvider | LicenseUsageMode


LicenseManager.Validate (Type)

Determines if a license can be granted for the specified type.

[Visual Basic]
Overloads Public Shared Sub Validate( _
   ByVal type As Type _
)
[C#]
public static void Validate(
   Type type
);
[C++]
public: static void Validate(
   Type* type
);
[JScript]
public static function Validate(
   type : Type
);

Parameters

type
A Type that represents the type of object that is requesting the license.

Exceptions

Exception Type | Condition
LicenseException | A License cannot be granted.

Remarks

This method throws a LicenseException when a valid License cannot be granted. IsValid does not throw an exception.

See Also

LicenseManager Class | LicenseManager Members | System.ComponentModel Namespace | LicenseManager.Validate Overload List | License | LicenseContext | LicenseException | LicenseProvider | LicenseProviderAttribute | LicFileLicenseProvider | LicenseUsageMode


LicenseProvider Class

Provides the abstract (in Visual Basic MustInherit) base class for implementing a LicenseProvider.

Object
LicenseProvider

[Visual Basic]
MustInherit Public Class LicenseProvider
[C#]
public abstract class LicenseProvider
[C++]
public __gc __abstract class LicenseProvider
[JScript]
public abstract class LicenseProvider

Remarks

Notes to Inheritors: When you inherit from LicenseProvider, you must override the GetLicense method.

See LicFileLicenseProvider for an implementation of this class. For more information on licensing, see TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

LicenseProvider Members | System.ComponentModel Namespace | License | LicenseContext | LicenseException | LicenseManager | LicenseProviderAttribute | LicFileLicenseProvider | LicenseUsageMode


LicenseProvider Members

Public:

Constructor

LicenseProvider Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLicense | When overridden in a derived class, gets a license for an instance or type of component.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LicenseProvider Class | System.ComponentModel Namespace


LicenseProvider Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public LicenseProvider();
[C++]
public: LicenseProvider();
[JScript]
public function LicenseProvider();

See Also

LicenseProvider Class | LicenseProvider Members | System.ComponentModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

LicenseProvider Methods

The methods of the LicenseProvider class are listed below. For a complete list of LicenseProvider class members, see the LicenseProvider Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLicense | When overridden in a derived class, gets a license for an instance or type of component.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LicenseProvider Class | System.ComponentModel Namespace


LicenseProvider.GetLicense

When overridden in a derived class, gets a license for an instance or type of component.

[Visual Basic]
MustOverride Public Function GetLicense( _
   ByVal context As LicenseContext, _
   ByVal type As Type, _
   ByVal instance As Object, _
   ByVal allowExceptions As Boolean _
) As License
[C#]
public abstract License GetLicense(
   LicenseContext context,
   Type type,
   object instance,
   bool allowExceptions
);
[C++]
public: virtual License* GetLicense(
   LicenseContext* context,
   Type* type,
   Object* instance,
   bool allowExceptions
) = 0;
[JScript]
public abstract function GetLicense(
   context : LicenseContext,
   type : Type,
   instance : Object,
   allowExceptions : Boolean
) : License;

Parameters

context
A LicenseContext that specifies where the licensed object can be used.
type
A Type that represents the component requesting the license.
instance
An object that is requesting the license.
allowExceptions
true if System.ComponentModel.LicenseExceptions should be thrown when a component cannot be granted a license; otherwise, false.

Return Value

A valid License.

Remarks

Notes to Inheritors: The object asking for a License must Dispose the License when the object is disposed or finalized.

When you inherit from LicenseProvider, you must override GetLicense to implement a validation method for the license key.

See Also

LicenseProvider Class | LicenseProvider Members | System.ComponentModel Namespace | System.License.Dispose | License | LicenseContext | LicenseException | LicenseManager | LicenseProvider | LicenseProviderAttribute | LicFileLicenseProvider | LicenseUsageMode


LicenseProviderAttribute Class

Specifies the LicenseProvider to use with a class.

Object
Attribute
MemberAttribute
LicenseProviderAttribute

[Visual Basic]
Public Class LicenseProviderAttribute
   Inherits MemberAttribute
[C#]
public class LicenseProviderAttribute : MemberAttribute
[C++]
public __gc class LicenseProviderAttribute : public MemberAttribute
[JScript]
public class LicenseProviderAttribute extends MemberAttribute

Remarks

When you create a component that you want to license, you must specify the LicenseProvider by marking the component with a LicenseProviderAttribute.

Use the LicenseProvider property to get the Type of the LicenseProvider.

For more information on attributes, see TBD and TBD. For more information on licensing, see TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | License | LicenseContext | LicenseException | LicenseManager | LicenseProvider | LicFileLicenseProvider | LicenseUsageMode


LicenseUsageMode Enumeration

Specifies when the license can be used.

[Visual Basic]
Public Enum LicenseUsageMode
[C#]
public enum LicenseUsageMode
[C++]
public enum LicenseUsageMode

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

This enumeration is used by the LicenseManager and the LicenseContext classes. It is used to set a component's CurrentContext. See the LicenseManager class for details.For more information on licensing, see TBD.

Members

Member Name | Description
Designtime | Used during design time by a visual designer or the compiler.
Runtime | Used during runtime.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | License | LicenseContext | LicenseException | LicenseManager | LicenseProvider | LicenseProviderAttribute | LicFileLicenseProvider


LicFileLicenseProvider Class

Provides an implementation of a LicenseProvider. The provider works in a similar fashion to Microsoft's standard NGWS licensing module.

Object
LicenseProvider
LicFileLicenseProvider

[Visual Basic]
Public Class LicFileLicenseProvider
   Inherits LicenseProvider
[C#]
public class LicFileLicenseProvider : LicenseProvider
[C++]
public __gc class LicFileLicenseProvider : public LicenseProvider
[JScript]
public class LicFileLicenseProvider extends LicenseProvider

Remarks

The LicFileLicenseProvider offers GetLicense and IsKeyValid methods. The IsKeyValid method determines if the LicenseKey retrieved by the GetLicense method is valid. When you inherit from this class, you can override the IsKeyValid method to provide your own validation logic.

For more information on licensing, see TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

LicFileLicenseProvider Members | System.ComponentModel Namespace | License | LicenseContext | LicenseException | LicenseManager | LicenseProvider | LicenseProviderAttribute | LicFileLicenseProvider | LicenseUsageMode


LicFileLicenseProvider Members

Public:

Constructor

LicFileLicenseProvider Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLicense | Gets a license for the instance of the component and determines if it is valid.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
IsKeyValid | Determines if the key retrieved by the GetLicense method is valid for the specified type.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LicFileLicenseProvider Class | System.ComponentModel Namespace


LicFileLicenseProvider Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public LicFileLicenseProvider();
[C++]
public: LicFileLicenseProvider();
[JScript]
public function LicFileLicenseProvider();

See Also

LicFileLicenseProvider Class | LicFileLicenseProvider Members | System.ComponentModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

LicFileLicenseProvider Methods

The methods of the LicFileLicenseProvider class are listed below. For a complete list of LicFileLicenseProvider class members, see the LicFileLicenseProvider Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLicense | Gets a license for the instance of the component and determines if it is valid.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
IsKeyValid | Determines if the key retrieved by the GetLicense method is valid for the specified type.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LicFileLicenseProvider Class | System.ComponentModel Namespace


LicFileLicenseProvider.GetLicense

Gets a license for the instance of the component and determines if it is valid.

[Visual Basic]
Overrides Public Function GetLicense( _
   ByVal context As LicenseContext, _
   ByVal type As Type, _
   ByVal instance As Object, _
   ByVal allowExceptions As Boolean _
) As License
[C#]
public override License GetLicense(
   LicenseContext context,
   Type type,
   object instance,
   bool allowExceptions
);
[C++]
public: override License* GetLicense(
   LicenseContext* context,
   Type* type,
   Object* instance,
   bool allowExceptions
);
[JScript]
public override function GetLicense(
   context : LicenseContext,
   type : Type,
   instance : Object,
   allowExceptions : Boolean
) : License;

Parameters

context
A LicenseContext that specifies where the licensed object can be used.
type
A Type that represents the component requesting the License.
instance
An object that is requesting the License.
allowExceptions
true if a LicenseException should be thrown when a component cannot be granted a license; otherwise, false.

Return Value

A valid License. If this method cannot find a valid License or a valid context, it returns a null reference (in Visual Basic Nothing).

Remarks

At design time, the GetLicense method looks for a license file named "className.LIC" where className is the FullName of the component you want to create. This file must be in the same directory as the DLL with the class.

Then this method checks the first line of the license file against a key specified in the IsKeyValid method. If the key is valid, this line is used as the LicenseKey.

See Also

LicFileLicenseProvider Class | LicFileLicenseProvider Members | System.ComponentModel Namespace | License | LicenseContext | LicenseException | LicenseManager | LicenseProvider | LicenseProviderAttribute | LicFileLicenseProvider | LicenseUsageMode


LicFileLicenseProvider.IsKeyValid

Determines if the key retrieved by the GetLicense method is valid for the specified type.

[Visual Basic]
Overridable Protected Function IsKeyValid( _
   ByVal key As String, _
   ByVal type As Type _
) As Boolean
[C#]
protected virtual bool IsKeyValid(
   string key,
   Type type
);
[C++]
protected: virtual bool IsKeyValid(
   String* key,
   Type* type
);
[JScript]
protected function IsKeyValid(
   key : String,
   type : Type
) : Boolean;

Parameters

key
The LicenseKey to check.
type
A Type that represents the component that is requesting the License.

Return Value

true if the key is a valid LicenseKey for the specified type; otherwise, false.

Remarks

This method checks the key against the phrase: "className is a licensed component." where className is the FullName of the component you want to create.

Notes to Inheritors: When you inherit from this class, you can override this method to provide your own validation logic.

See Also

LicFileLicenseProvider Class | LicFileLicenseProvider Members | System.ComponentModel Namespace | License | LicenseContext | LicenseException | LicenseManager | LicenseProvider | LicenseProviderAttribute | LicFileLicenseProvider | LicenseUsageMode


LocalizableAttribute Class

Specifies whether a property or extender should be localized.

Object
Attribute
MemberAttribute
LocalizableAttribute

[Visual Basic]
Public Class LocalizableAttribute
   Inherits MemberAttribute
[C#]
public class LocalizableAttribute : MemberAttribute
[C++]
public __gc class LocalizableAttribute : public MemberAttribute
[JScript]
public class LocalizableAttribute extends MemberAttribute

Remarks

When code is generated for a component, members that are marked with Localizable(true) have their property values saved in resource files. You can localize the resource files. You do not have to modify the code.

Members that have no localizable attribute or are marked with Localizable(false) do not have their property values saved. The default is false.

Note When you mark a property with Localizable(true), the value of this attribute is set to the constant member LocalizableAttribute.Yes. For a property marked with Localizable(false), the value is LocalizableAttribute.No. Therefore, when you want to check the value of this attribute in your code, you must specify the attribute as LocalizableAttribute.Yes or LocalizableAttribute.No.

For more information, see TBD and TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | MemberAttribute | PropertyDescriptor


MarshalByRefComponent Class

Represents the base implementation for IComponent, which is the base for all components in WinForms. A component can be hosted in a container. For each component in a container, the container creates a site that it uses to manage the component.

Object
MarshalByRefObject
MarshalByRefComponent

[Visual Basic]
Public Class MarshalByRefComponent
   Inherits MarshalByRefObject
   Implements IComponent, IServiceObjectProvider
[C#]
public class MarshalByRefComponent : MarshalByRefObject,
   IComponent, IServiceObjectProvider
[C++]
public __gc class MarshalByRefComponent : public
   MarshalByRefObject, IComponent, IServiceObjectProvider
[JScript]
public class MarshalByRefComponent extends MarshalByRefObject,
   IComponent, IServiceObjectProvider

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

MarshalByRefComponent Members | System.ComponentModel Namespace


MarshalByRefComponent Members

Public:

Constructor

MarshalByRefComponent Constructor Creates a Component object.

Properties

Site Gets or sets the site of the component.

Methods

Dispose | Disposes of the component. Call dispose when the component is no longer needed. This method removes the component from its container (if the component has a site) and triggers the dispose event.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer | Returns the component's container.
GetDesignMode | Determines whether the component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetServiceObject | The implementation of IServiceObjectProvider
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
ToString (inherited from MarshalByRefObject) | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MarshalByRefComponent Class | System.ComponentModel Namespace


MarshalByRefComponent Constructor

Creates a Component object.

[Visual Basic]
Public Sub New()
[C#]
public MarshalByRefComponent();
[C++]
public: MarshalByRefComponent();
[JScript]
public function MarshalByRefComponent();

See Also

MarshalByRefComponent Class | MarshalByRefComponent Members | System.ComponentModel Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MarshalByRefComponent Properties

The properties of the MarshalByRefComponent class are listed below. For a complete list of MarshalByRefComponent class members, see the MarshalByRefComponent Members topic.

Public:

Site Gets or sets the site of the component.

See Also

MarshalByRefComponent Class | System.ComponentModel Namespace


MarshalByRefComponent.Site

Gets or sets the site of the component.

[Visual Basic]
Overridable Public Property Site As ISite
[C#]
public ISite Site {virtual get; virtual set;}
[C++]
public: __property virtual ISite* get_Site();
public: __property virtual void set_Site(ISite*);
[JScript]
public function get Site() : ISite;
public function set Site(ISite);

Remarks

An object implementing the ISite interface that represents the component's site. A non-null value indicates that the component has been added to a container; a null value indicates that the component is being removed (but does not remove it) from a container.

See Also

MarshalByRefComponent Class | MarshalByRefComponent Members | System.ComponentModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MarshalByRefComponent Methods

The methods of the MarshalByRefComponent class are listed below. For a complete list of MarshalByRefComponent class members, see the MarshalByRefComponent Members topic.

Public:

Dispose | Disposes of the component. Call dispose when the component is no longer needed. This method removes the component from its container (if the component has a site) and triggers the dispose event.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer | Returns the component's container.
GetDesignMode | Determines whether the component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetServiceObject | The implementation of IServiceObjectProvider
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
ToString (inherited from MarshalByRefObject) | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MarshalByRefComponent Class | System.ComponentModel Namespace


MarshalByRefComponent.Dispose

Disposes of the component. Call dispose when the component is no longer needed. This method removes the component from its container (if the component has a site) and triggers the dispose event.

[Visual Basic]
Overridable Public Sub Dispose()
[C#]
public virtual void Dispose();
[C++]
public: virtual void Dispose();
[JScript]
public function Dispose();

See Also

MarshalByRefComponent Class | MarshalByRefComponent Members | System.ComponentModel Namespace


MarshalByRefComponent.GetContainer

Returns the component's container.

[Visual Basic]
Overridable Public Function GetContainer() As IContainer
[C#]
public virtual IContainer GetContainer();
[C++]
public: virtual IContainer* GetContainer();
[JScript]
public function GetContainer() : IContainer;

Return Value

Returns an object implementing the IContainer interface that represents the component's container. If the component does not have a site, null is returned.

See Also

MarshalByRefComponent Class | MarshalByRefComponent Members | System.ComponentModel Namespace


MarshalByRefComponent.GetDesignMode

Determines whether the component is currently in design mode.

[Visual Basic]
Overridable Public Function GetDesignMode() As Boolean
[C#]
public virtual bool GetDesignMode();
[C++]
public: virtual bool GetDesignMode();
[JScript]
public function GetDesignMode() : Boolean;

Return Value

Returns true if the component is in design mode; otherwise, returns false. (If the component does not have a site, this method always returns false.)

See Also

MarshalByRefComponent Class | MarshalByRefComponent Members | System.ComponentModel Namespace


MarshalByRefComponent.GetServiceObject

The implementation of IServiceObjectProvider

[Visual Basic]
Overridable Public Function GetServiceObject( _
   ByVal service As Type _
) As Object
[C#]
public virtual object GetServiceObject(
   Type service
);
[C++]
public: virtual Object* GetServiceObject(
   Type* service
);
[JScript]
public function GetServiceObject(
   service : Type
) : Object;

Parameters

service
[To be supplied.]

See Also

MarshalByRefComponent Class | MarshalByRefComponent Members | System.ComponentModel Namespace


MemberAttribute Class

Defines basic functions for all attributes. MemberAttribute is the abstract (in Visual Basic MustInherit) base class from which all other attribute classes derive.

Object
Attribute
MemberAttribute

[Visual Basic]
MustInherit Public Class MemberAttribute
   Inherits Attribute
[C#]
public abstract class MemberAttribute : Attribute
[C++]
public __gc __abstract class MemberAttribute : public Attribute
[JScript]
public abstract class MemberAttribute extends Attribute

Remarks

Attributes provide information about an entity such as a component, event, interface or property. This information is stored as NGWS runtime metadata.

Use the TypeId property to get a unique ID for this MemberAttribute. For most attributes, this is the Type instance for the attribute. Call Match to determine whether one attribute is the same as another.

The following attributes in System.ComponentModel inherit from this base class:

Class | Description
BindableAttribute | Specifies whether a property is appropriate to bind data to.
BrowsableAttribute | Specifies whether a property or event can be modified at design time.
CategoryAttribute | Specifies that a property or event belongs to a certain category.
ComponentEditorAttribute | Specifies the editor to use to change a component.
DefaultEventAttribute | Specifies the default event for the component.
DefaultPropertyAttribute | Specifies the default property for the component.
DefaultValueAttribute | Specifies the default value for a property or extender.
DescriptionAttribute | Specifies a description for a property or event.
DesignerAttribute | Specifies the designer class to use to display a component at design time.
DesignOnlyAttribute | Specifies that a property can be set only at design time.
EditorAttribute | Specifies the editor to use to change a property.
EventDescriptorAttribute | Specifies how to identify a property as an event.
ExtenderPropertyAttribute | Specifies which components can accept the extender.
HelpAttribute | Specifies Help file and Help topic for a property or event.
LicenseProviderAttribute | Specifies the license provider to use with a class.
LocalizableAttribute | Specifies whether a property should be localized.
MergablePropertyAttribute | Specifies that this property can be combined with properties belonging to other objects in a property browser.
NotificationAttribute | Specifies whether a property should send notification events when changed.
PersistableAttribute | Specifies which values are saved for a property or event.
PersistContentsAttribute | Specifies whether a visual designer must generate special code to persist the value of a property.
PersisterAttribute | Specifies what class to use as a value persister.
ProvidePropertyAttribute | Specifies which methods are extender properties.
ReadOnlyAttribute | Specifies that a property is read-only.
RecommendedAsConfigurableAttribute | Specifies that the property could be used as an application setting.
RunInstallerAttribute | Specifies whether an installer should be invoked during installation of an assembly.
ServerExplorerBrowsableAttribute | Specifies whether a property or event can be modified at design time in the server explorer.
ServerExplorerReadOnlyAttribute | Specifies that a property is read-only in the server explorer.
TypeConverterAttribute | Specifies what to use as a converter for values.

For more information, see TBD and TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

MemberAttribute Members | System.ComponentModel Namespace


MemberAttribute Members

Public:

Constructor

MemberAttribute Constructor [To be supplied.]

Properties

TypeId Gets a unique ID for this MemberAttribute.

Methods

Equals (inherited from Attribute) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsDefaultAttribute | When overridden in a derived class, specifies whether this MemberAttribute is the default attribute for the class.
Match | Determines whether one attribute matches another.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MemberAttribute Class | System.ComponentModel Namespace


MemberAttribute Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public MemberAttribute();
[C++]
public: MemberAttribute();
[JScript]
public function MemberAttribute();

See Also

MemberAttribute Class | MemberAttribute Members | System.ComponentModel Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MemberAttribute Properties

The properties of the MemberAttribute class are listed below. For a complete list of MemberAttribute class members, see the MemberAttribute Members topic.

Public:

TypeId Gets a unique ID for this MemberAttribute.

See Also

MemberAttribute Class | System.ComponentModel Namespace


MemberAttribute.TypeId

Gets a unique ID for this MemberAttribute.

[Visual Basic]
Overridable Public ReadOnly Property TypeId As Object
[C#]
public object TypeId {virtual get;}
[C++]
public: __property virtual Object* get_TypeId();
[JScript]
public function get TypeId() : Object;

Property Value

A unique ID. For most attributes, this ID represents the type of the attribute.

Remarks

The unique ID is used by filtering methods to identify two attributes that are the same type.

See Also

MemberAttribute Class | MemberAttribute Members | System.ComponentModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MemberAttribute Methods

The methods of the MemberAttribute class are listed below. For a complete list of MemberAttribute class members, see the MemberAttribute Members topic.

Public:

Equals (inherited from Attribute) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsDefaultAttribute | When overridden in a derived class, specifies whether this MemberAttribute is the default attribute for the class.
Match | Determines whether one attribute matches another.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MemberAttribute Class | System.ComponentModel Namespace


MemberAttribute.IsDefaultAttribute

When overridden in a derived class, specifies whether this MemberAttribute is the default attribute for the class.

[Visual Basic]
Overridable Public Function IsDefaultAttribute() As Boolean
[C#]
public virtual bool IsDefaultAttribute();
[C++]
public: virtual bool IsDefaultAttribute();
[JScript]
public function IsDefaultAttribute() : Boolean;

Return Value

true if this MemberAttribute is the default attribute for the class; otherwise, false.

Remarks

This method must be overridden to return the correct value if the attribute is the default attribute. As implemented in this class, it returns false.

See Also

MemberAttribute Class | MemberAttribute Members | System.ComponentModel Namespace


MemberAttribute.Match

Determines whether one attribute matches another.

[Visual Basic]
Overridable Public Function Match( _
   ByVal obj As Object _
) As Boolean
[C#]
public virtual bool Match(
   object obj
);
[C++]
public: virtual bool Match(
   Object* obj
);
[JScript]
public function Match(
   obj : Object
) : Boolean;

Parameters

obj
The attribute to compare with this attribute.

Return Value

true if the attributes match; otherwise, false.

Remarks

Notes to Inheritors: This method determines if one MemberAttribute equals another MemberAttribute. You can override this method to determine if one attribute matches another attribute's criteria instead.

See Also

MemberAttribute Class | MemberAttribute Members | System.ComponentModel Namespace


MemberAttributeCollection Class

Represents a collection of attributes.

Object
MemberAttributeCollection

[Visual Basic]
Public Class MemberAttributeCollection
   Implements ICollection, IEnumerable
[C#]
public class MemberAttributeCollection : ICollection, IEnumerable
[C++]
public __gc class MemberAttributeCollection : public ICollection,
   IEnumerable
[JScript]
public class MemberAttributeCollection implements ICollection,
   IEnumerable

Remarks

The MemberAttributeCollection class is read-only; it does not implement methods to add or remove attributes. You must inherit from this class to implement these methods.

Use the Count property to find how many attributes are assigned to this collection.

You can also use the the methods of this class to query the collection about its contents. Call Contains to verify that a specified attribute or attribute array exists in the collection. Call Matches to verify that a specified attribute or array of attributes exists in the collection, and that the values of the specified attributes are the same as the values in the collection.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

Example [Visual Basic]

When using attributes, you will want to check that an attribute has been set or access its value. The first example checks to see if the BrowsableAttribute has been set in this collection. It assumes that Button1 has been instantiated on a form.

[Visual Basic]

Private Sub ContainsAttribute()
   'Create a new collection and assign it the attributes for Button1.
   Dim attributes As MemberAttributeCollection
   attributes = TypeDescriptor.GetAttributes(Button1)

   'Set a MemberAttribute to a specific attribute.
   Dim myAttribute As BrowsableAttribute
   myAttribute = BrowsableAttribute.Yes

   If attributes.Contains(myAttribute) Then
      TextBox1.Text = "Button1 has a browsable attribute"
   Else
      TextBox1.Text = "Button1 does not have a browsable attribute"
   End If
End Sub

The second example gets the actual value of the DescriptionAttribute for a button. It assumes that Button1 has been instantiated on a form.

[Visual Basic]

Private Sub GetAttributeValue()
   'Create a new collection and assign it the attributes for Button1.
   Dim attributes As MemberAttributeCollection
   attributes = TypeDescriptor.GetAttributes(Button1)

   'Get the description attribute from the collection.
   Dim myAttribute As MemberAttribute
   myAttribute = attributes.Item(GetType(System.ComponentModel.DescriptionAttribute))

   Dim myDescription As DescriptionAttribute
   myDescription = myAttribute
   'Print the value of the attribute in a text box.
   TextBox1.Text = myDescription.GetDescription
End Sub

See Also

MemberAttributeCollection Members | System.ComponentModel Namespace | MemberAttribute | BrowsableAttribute | DescriptionAttribute


MemberAttributeCollection Members

Public:

Constructor

MemberAttributeCollection Constructor Initializes a new instance of the MemberAttributeCollection class.

Properties

All | Gets an array with the attributes for this collection.
Count | Gets the number of attributes.
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the MemberAttributeCollection class.

Methods

Contains | Overloaded. Determines if this collection of attributes has the specified attribute or array of attributes.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Gets an enumerator for this collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Matches | Overloaded. Determines if a specified attribute or array of attributes is the same as an attribute or array of attributes in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MemberAttributeCollection Class | System.ComponentModel Namespace


MemberAttributeCollection Constructor

Initializes a new instance of the MemberAttributeCollection class.

[Visual Basic]
Public Sub New( _
   ByVal attributes() As MemberAttribute _
)
[C#]
public MemberAttributeCollection(
   MemberAttribute[] attributes
);
[C++]
public: MemberAttributeCollection(
   MemberAttribute* attributes[]
);
[JScript]
public function MemberAttributeCollection(
   attributes : MemberAttribute[]
);

Parameters

attributes
An array of type MemberAttribute that provides the attributes for this collection.

Example [Visual Basic]

The following example creates a new MemberAttributeCollection using the attributes on Button1. It assumes that Button1 has been instantiated on a form.

[Visual Basic]

Dim attributes As MemberAttributeCollection
attributes = TypeDescriptor.GetAttributes(Button1)

See Also

MemberAttributeCollection Class | MemberAttributeCollection Members | System.ComponentModel Namespace | MemberAttribute


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MemberAttributeCollection Properties

The properties of the MemberAttributeCollection class are listed below. For a complete list of MemberAttributeCollection class members, see the MemberAttributeCollection Members topic.

Public:

All | Gets an array with the attributes for this collection.
Count | Gets the number of attributes.
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the MemberAttributeCollection class.

See Also

MemberAttributeCollection Class | System.ComponentModel Namespace


MemberAttributeCollection.All

Gets an array with the attributes for this collection.

[Visual Basic]
Overridable Public Property All As MemberAttribute ()
[C#]
public MemberAttribute[] All {virtual get; virtual set;}
[C++]
public: __property virtual MemberAttribute* get_All();
public: __property virtual void set_All(MemberAttribute*[]);
[JScript]
public function get All() : MemberAttribute[];
public function set All(MemberAttribute[]);

Property Value

An array of type MemberAttribute with the attributes for this collection.

Exceptions

Exception Type | Condition
NotSupportedException | Setting the property.

Remarks

This property is read-only. It will throw an exception if you try to set its value.

Notes to Inheritors: If you want to add to the collection, you must inherit from this class and implement set in this property.

Example [Visual Basic]

The following example shows how to get an array of type MemberAttribute using the All property. It assumes that Button1 has been instantiated on a form.

[Visual Basic]

Private Sub GetAllAttributes()
   'Create a new collection and assign it the attributes for Button1.
   Dim attributes As MemberAttributeCollection
   attributes = TypeDescriptor.GetAttributes(Button1)

   'Get all the MemberAttributes.
   Dim aArray() As MemberAttribute
   aArray = attributes.All

   'Print all the attributes in a text box.
   Dim i As Integer
   For i = 0 To aArray.Length - 1
      TextBox1.Text &= aArray(i).ToString & " "
   Next
End Sub

See Also

MemberAttributeCollection Class | MemberAttributeCollection Members | System.ComponentModel Namespace | MemberAttribute


MemberAttributeCollection.Count

Gets the number of attributes.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

Property Value

The number of attributes.

Remarks

The Count property can be used to set the limits of a loop that iterates through a collection of objects. If the collection is zero-based, be sure to use "Count- 1" as the upper bound of the loop.

Example [Visual Basic]

The following example uses the Count property to print the number of properties on Button1. It assumes that Button1 has been instantianted on a form.

[Visual Basic]

Private Sub GetCount()
   'Create a new collection and assign it the attributes for Button1.
   Dim attributes As MemberAttributeCollection
   attributes = TypeDescriptor.GetAttributes(Button1)

   'Print the number of attributes attached to Button1 in a text box.
   TextBox1.Text = attributes.Count.ToString
End Sub

See Also

MemberAttributeCollection Class | MemberAttributeCollection Members | System.ComponentModel Namespace | MemberAttribute


MemberAttributeCollection.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the MemberAttributeCollection class.

Overload List

Gets the attribute with the specified type.

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(Type) As MemberAttribute
[C#] public MemberAttribute this[Type] {virtual get;}
[C++] public: __property virtual MemberAttribute* get_Item(Type*);
[JScript] MemberAttributeCollection.Item (Type)

Gets the attribute with the specified index

number.

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(Integer) As MemberAttribute
[C#] public MemberAttribute this[int] {virtual get;}
[C++] public: __property virtual MemberAttribute* get_Item(int);
[JScript] MemberAttributeCollection.Item (int)

Example [Visual Basic]

The following example uses the Item property (MemberAttributeCollection indexer) to print the name of the MemberAttribute specified by the index number in a text box. Since the index number is zero-based, this example prints the name of the second MemberAttribute in a text box. It assumes Button1 has been instantiated on a form.

Note This example shows how to use one of the overloaded versions of the Item property (MemberAttributeCollection indexer). For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub PrintIndexItem()
   'Create a new collection and assign it the attributes for Button1.
   Dim attributes As MemberAttributeCollection
   attributes = TypeDescriptor.GetAttributes(Button1)

   'Print the second attribute's name.
   TextBox1.Text = attributes.Item(1).ToString
End Sub

See Also

MemberAttributeCollection Class | MemberAttributeCollection Members | System.ComponentModel Namespace


MemberAttributeCollection.Item (Type)

Gets the attribute with the specified type.

[C#] In C#, this member is the indexer for the MemberAttributeCollection class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal attributeType As Type _
) As MemberAttribute
[C#]
public MemberAttribute this[
   Type attributeType
] {virtual get;}
[C++]
public: __property virtual MemberAttribute* get_Item(
   Type* attributeType
);
[JScript]
returnValue = MemberAttributeCollectionObject.Item(attributeType);
-or-
returnValue = MemberAttributeCollectionObject(attributeType);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

attributeType
The type of the MemberAttribute to get from the collection.

Parameters [Visual Basic, C#, C++]

attributeType
The type of the MemberAttribute to get from the collection.

Property Value

The MemberAttribute with the specified type, or if the attribute does not exist, the default value for the attributeType.

Remarks

If the attribute does not exist in the collection, this property returns the default value for the attributeType.

Example [Visual Basic]

The following example gets the DescriptionAttribute from the collection and prints its value. It assumes that Button1 has been instantiated on a form.

[Visual Basic]

Private Sub PrintIndexItem2()
   'Create a new collection and assign it the attributes for Button1.
   Dim attributes As MemberAttributeCollection
   attributes = TypeDescriptor.GetAttributes(Button1)

   'Get the description attribute from the collection.
   Dim myDescription As DescriptionAttribute
   myDescription = CType(attributes.Item(GetType(System.ComponentModel.DescriptionAttribute)), DescriptionAttribute)

   'Print the value of the attribute in a text box.
   TextBox1.Text = myDescription.GetDescription
End Sub

See Also

MemberAttributeCollection Class | MemberAttributeCollection Members | System.ComponentModel Namespace | MemberAttributeCollection.Item Overload List | MemberAttribute


MemberAttributeCollection.Item (Int32)

Gets the attribute with the specified index

number.

[C#] In C#, this member is the indexer for the MemberAttributeCollection class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal index As Integer _
) As MemberAttribute
[C#]
public MemberAttribute this[
   int index
] {virtual get;}
[C++]
public: __property virtual MemberAttribute* get_Item(
   int index
);
[JScript]
returnValue = MemberAttributeCollectionObject.Item(index);
-or-
returnValue = MemberAttributeCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
The zero-based index of MemberAttributeCollection.

Parameters [Visual Basic, C#, C++]

index
The zero-based index of MemberAttributeCollection.

Property Value

The MemberAttribute with the specified index number.

Remarks

The index number is zero-based. Therefore, you must subtract one from the numerical position of a particular MemberAttribute to access that MemberAttribute. For example, to get the third MemberAttribute, you need to specify Item property (MemberAttributeCollection indexer)(2).

Example [Visual Basic]

The following example uses the Item property (MemberAttributeCollection indexer) to print the name of the MemberAttribute specified by the index number in a text box. Since the index number is zero-based, this example prints the name of the second MemberAttribute in a text box. It assumes Button1 has been instantiated on a form.

[Visual Basic]

Private Sub PrintIndexItem()
   'Create a new collection and assign it the attributes for Button1.
   Dim attributes As MemberAttributeCollection
   attributes = TypeDescriptor.GetAttributes(Button1)

   'Print the second attribute's name.
   TextBox1.Text = attributes.Item(1).ToString
End Sub

See Also

MemberAttributeCollection Class | MemberAttributeCollection Members | System.ComponentModel Namespace | MemberAttributeCollection.Item Overload List | MemberAttribute


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MemberAttributeCollection Methods

The methods of the MemberAttributeCollection class are listed below. For a complete list of MemberAttributeCollection class members, see the MemberAttributeCollection Members topic.

Public:

Contains | Overloaded. Determines if this collection of attributes has the specified attribute or array of attributes.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Gets an enumerator for this collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Matches | Overloaded. Determines if a specified attribute or array of attributes is the same as an attribute or array of attributes in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MemberAttributeCollection Class | System.ComponentModel Namespace


MemberAttributeCollection.Contains

Determines if this collection of attributes has the specified attribute or array of attributes.

Overload List

Determines if this collection of attributes has the specified attribute.

[Visual Basic] Overloads Public Function Contains(MemberAttribute) As Boolean
[C#] public bool Contains(MemberAttribute);
[C++] public: bool Contains(MemberAttribute*);
[JScript] public function Contains(MemberAttribute) : Boolean;

Determines if this attribute collection contains the all the specified attributes in the attribute array.

[Visual Basic] Overloads Public Function Contains(MemberAttribute()) As Boolean
[C#] public bool Contains(MemberAttribute[]);
[C++] public: bool Contains(MemberAttribute*[]);
[JScript] public function Contains(MemberAttribute[]) : Boolean;

Example [Visual Basic]

The following example compares the attributes in Button1 and Edit1 to see if the attributes for Edit1 are contained in the attributes

for Button1. It assumes that both Button1 and Edit1 have been instantiated on a form.

Note This example shows how to use one of the overloaded versions of Contains. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub ContainsAttributes()
   'Create a new collection and assign it the attributes for Button1.
   Dim collection1 As MemberAttributeCollection
   collection1 = TypeDescriptor.GetAttributes(Button1)

   'Create a new collection and assign it the attributes for TextBox1.
   Dim collection2 As MemberAttributeCollection
   collection2 = TypeDescriptor.GetAttributes(TextBox1)

   'Check to see if the attributes in collection1 are contained in collection2.
   If collection1.Contains(collection2.All) Then
      TextBox1.Text = "Both the button and the text box contain the same attributes"
   Else
      TextBox1.Text = "The button and the text box do not contain the same attributes"
   End If
End Sub

See Also

MemberAttributeCollection Class | MemberAttributeCollection Members | System.ComponentModel Namespace


MemberAttributeCollection.Contains (MemberAttribute)

Determines if this collection of attributes has the specified attribute.

[Visual Basic]
Overloads Public Function Contains( _
   ByVal attribute As MemberAttribute _
) As Boolean
[C#]
public bool Contains(
   MemberAttribute attribute
);
[C++]
public: bool Contains(
   MemberAttribute* attribute
);
[JScript]
public function Contains(
   attribute : MemberAttribute
) : Boolean;

Parameters

attribute
A MemberAttribute to find in the collection.

Return Value

true if the collection contains the attribute or is the default attribute for the type of attribute; otherwise, false.

Remarks

This collection has the specified attribute if the specified type of attribute exists in the collection and value the specified attribute is the same as the value of the instance of the attribute in the collection.

Example [Visual Basic]

The following example checks to see if the collection has a BrowsableAttribute set to true. It assumes that Button1 has been instantiated on a form.

[Visual Basic]

Private Sub ContainsAttribute()
   'Create a new collection and assign it the attributes for Button1.
   Dim attributes As MemberAttributeCollection
   attributes = TypeDescriptor.GetAttributes(Button1)

   'Set a MemberAttribute to a specific attribute.
   Dim myAttribute As BrowsableAttribute
   myAttribute = BrowsableAttribute.Yes

   If attributes.Contains(myAttribute) Then
      TextBox1.Text = "Button1 has a browsable attribute"
   Else
      TextBox1.Text = "Button1 does not have a browsable attribute"
   End If
End Sub

See Also

MemberAttributeCollection Class | MemberAttributeCollection Members | System.ComponentModel Namespace | MemberAttributeCollection.Contains Overload List | MemberAttribute


MemberAttributeCollection.Contains (MemberAttribute[])

Determines if this attribute collection contains the all the specified attributes in the attribute array.

[Visual Basic]
Overloads Public Function Contains( _
   ByVal attributes() As MemberAttribute _
) As Boolean
[C#]
public bool Contains(
   MemberAttribute[] attributes
);
[C++]
public: bool Contains(
   MemberAttribute* attributes[]
);
[JScript]
public function Contains(
   attributes : MemberAttribute[]
) : Boolean;

Parameters

attributes
An array of type MemberAttribute to find in the collection.

Return Value

true if the collection contains all the attributes; otherwise, false.

Remarks

This collection has the specified array of attributes if all the specified attribute types exist in the collection and each attribute in the specified array is the same as an attribute in the collection.

Example [Visual Basic]

The following example compares the attributes in Button1 and Edit1 to see if the attributes for Edit1 are contained in the attributes

for Button1. It assumes that both Button1 and Edit1 have been instantiated on a form.

[Visual Basic]

Private Sub ContainsAttributes()
   'Create a new collection and assign it the attributes for Button1.
   Dim collection1 As MemberAttributeCollection
   collection1 = TypeDescriptor.GetAttributes(Button1)

   'Create a new collection and assign it the attributes for TextBox1.
   Dim collection2 As MemberAttributeCollection
   collection2 = TypeDescriptor.GetAttributes(TextBox1)

   'Check to see if the attributes in collection1 are contained in collection2.
   If collection1.Contains(collection2.All) Then
      TextBox1.Text = "Both the button and the text box contain the same attributes"
   Else
      TextBox1.Text = "The button and the text box do not contain the same attributes"
   End If
End Sub

See Also

MemberAttributeCollection Class | MemberAttributeCollection Members | System.ComponentModel Namespace | MemberAttributeCollection.Contains Overload List | MemberAttribute


MemberAttributeCollection.GetEnumerator

Gets an enumerator for this collection.

[Visual Basic]
Public Function GetEnumerator() As IEnumerator
[C#]
public IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

Return Value

An enumerator of type IEnumerator.

Example [Visual Basic]

The following example gets an enumerator for the attributes on Button1. It uses the enumerator to print the names of the attributes in the collection. It assumes that Button1 has been instantiated on a form.

[Visual Basic]

Private Sub MyEnumerator()
   'Create a new collection and assign it the attributes for Button1.
   Dim attributes As MemberAttributeCollection
   attributes = TypeDescriptor.GetAttributes(Button1)

   'Create an enumerator
   Dim ie As IEnumerator
   ie = attributes.GetEnumerator

   'Print the type of each attribute in the collection.
   Dim myAttribute As Object
   Do While ie.MoveNext = True
      myAttribute = ie.Current
      TextBox1.Text &= myAttribute.ToString & " "
   Loop
End Sub

See Also

MemberAttributeCollection Class | MemberAttributeCollection Members | System.ComponentModel Namespace | MemberAttribute | IEnumerator


MemberAttributeCollection.Matches

Determines if a specified attribute or array of attributes is the same as an attribute or array of attributes in the collection.

Overload List

Determines if the attributes in the specified array are the same as the attributes in the collection.

[Visual Basic] Overloads Public Function Matches(MemberAttribute()) As Boolean
[C#] public bool Matches(MemberAttribute[]);
[C++] public: bool Matches(MemberAttribute*[]);
[JScript] public function Matches(MemberAttribute[]) : Boolean;

Determines if a specified attribute is the same as an attribute in the collection.

[Visual Basic] Overloads Public Function Matches(MemberAttribute) As Boolean
[C#] public bool Matches(MemberAttribute);
[C++] public: bool Matches(MemberAttribute*);
[JScript] public function Matches(MemberAttribute) : Boolean;

Example [Visual Basic]

The following example verifies that the BrowsableAttribute is a member of the collection and that it has been set to true. It assumes that Button1 has been instantiated on a form.

Note This example shows how to use one of the overloaded versions of Matches. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub MatchesAttribute()
   'Create a new collection and assign it the attributes for Button1.
   Dim attributes As MemberAttributeCollection
   attributes = TypeDescriptor.GetAttributes(Button1)

   'Check to see if the browsable attribute is true.
   If attributes.Matches(BrowsableAttribute.Yes) Then
      TextBox1.Text = "Button1 is browsable"
   Else
      TextBox1.Text = "Button1 is not browsable"
   End If
End Sub

See Also

MemberAttributeCollection Class | MemberAttributeCollection Members | System.ComponentModel Namespace


MemberAttributeCollection.Matches (MemberAttribute[])

Determines if the attributes in the specified array are the same as the attributes in the collection.

[Visual Basic]
Overloads Public Function Matches( _
   ByVal attributes() As MemberAttribute _
) As Boolean
[C#]
public bool Matches(
   MemberAttribute[] attributes
);
[C++]
public: bool Matches(
   MemberAttribute* attributes[]
);
[JScript]
public function Matches(
   attributes : MemberAttribute[]
) : Boolean;

Parameters

attributes
An array of MemberAttributes to compare with the attributes in this collection.

Return Value

true if all the attributes in the array are contained in the collection and have the same values as the attributes in the collection; otherwise, false.

Remarks

An attribute can provide support for matching.

Example [Visual Basic]

The following example compares the attributes in two buttons. It assumes that both buttons have been instantiated on a form.

[Visual Basic]

Private Sub MatchesAttributes()
   'Create a new collection and assign it the attributes for Button1.
   Dim collection1 As MemberAttributeCollection
   collection1 = TypeDescriptor.GetAttributes(Button1)

   'Create a new collection and assign it the attributes for TextBox1.
   Dim collection2 As MemberAttributeCollection
   collection2 = TypeDescriptor.GetAttributes(TextBox1)

   'Check to see if the attributes in collection1 are contained in collection2.
   If collection1.Matches(collection2.All) Then
      TextBox1.Text = "The attributes in the button and the text box match"
   Else
      TextBox1.Text = "The attributes in the button and the text box do not match"
   End If
End Sub

See Also

MemberAttributeCollection Class | MemberAttributeCollection Members | System.ComponentModel Namespace | MemberAttributeCollection.Matches Overload List | MemberAttribute


MemberAttributeCollection.Matches (MemberAttribute)

Determines if a specified attribute is the same as an attribute in the collection.

[Visual Basic]
Overloads Public Function Matches( _
   ByVal attribute As MemberAttribute _
) As Boolean
[C#]
public bool Matches(
   MemberAttribute attribute
);
[C++]
public: bool Matches(
   MemberAttribute* attribute
);
[JScript]
public function Matches(
   attribute : MemberAttribute
) : Boolean;

Parameters

attribute
An instance of MemberAttribute to compare with the attributes in this collection.

Return Value

true if the attribute is contained within the collection and has the same value as the attribute in the collection; otherwise, false.

Remarks

An attribute can provide support for matching.

Example [Visual Basic]

The following example verifies that the BrowsableAttribute is a member of the collection and that it has been set to true. It assumes that Button1 has been instantiated on a form.

[Visual Basic]

Private Sub MatchesAttribute()
   'Create a new collection and assign it the attributes for Button1.
   Dim attributes As MemberAttributeCollection
   attributes = TypeDescriptor.GetAttributes(Button1)

   'Check to see if the browsable attribute is true.
   If attributes.Matches(BrowsableAttribute.Yes) Then
      TextBox1.Text = "Button1 is browsable"
   Else
      TextBox1.Text = "Button1 is not browsable"
   End If
End Sub

See Also

MemberAttributeCollection Class | MemberAttributeCollection Members | System.ComponentModel Namespace | MemberAttributeCollection.Matches Overload List | MemberAttribute


MemberDescriptor Class

Declares an array of attributes for a member and defines the properties and methods that give you access to the attributes in the array. All attributes must derive from MemberAttribute.

Object
MemberDescriptor

[Visual Basic]
MustInherit Public Class MemberDescriptor
[C#]
public abstract class MemberDescriptor
[C++]
public __gc __abstract class MemberDescriptor
[JScript]
public abstract class MemberDescriptor

Remarks

MemberDescriptor is the base class for the MemberDescriptor and the MemberDescriptor classes. The PropertyDescriptor class provides a description of a property, and the EventDescriptor class provides a description of an event.

Note Typically, you inherit from the MemberDescriptor and PropertyDescriptor classes, and not from this class.

This class defines properties and methods to access its stored attributes. Attributes gets the collection of attributes. Category, IsBrowsable, Description, GetDesignTimeOnly, GetHelpURL, and GetHelpTopic retrieve the values of those specific attributes. Name and GetDisplayName give you the name of the member.

The MemberDescriptor also defines an Equals method to compares this MemberDescriptor to another.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

MemberDescriptor Members | System.ComponentModel Namespace | PropertyDescriptor | EventDescriptor


MemberDescriptor Members

Public:

Constructor

MemberDescriptor Constructor Overloaded. Initializes a new instance of the MemberDescriptor class.

Properties

Attributes | Gets the collection of attributes for this member.
Category | Gets the name of the category that the member belongs to, as specified in the CategoryAttribute.
Description | Gets the description of the member as specified in the DescriptionAttribute.
IsBrowsable | Gets a value indicating whether the member is browsable as specified in the BrowsableAttribute.
Name | Gets the name of the member.

Methods

Equals | Compares this instance to the specified MemberDescriptor to see if they are equivalent.
GetDesignTimeOnly | Determines whether this member should be set only at design time as specified in the DesignOnlyAttribute.
GetDisplayName | Gets the name that can be displayed in a window like a property browser.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHelpTopic | Gets the name of the Help topic specified in the HelpAttribute.
GetHelpURL | Gets the URL for the Help file specified in the HelpAttribute.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

AttributeArray | Gets or sets an array of attributes.
NameHashCode | Gets the hash code for the name of the member as specified in GetHashCode.

Methods

CreateAttributeCollection | Creates a collection of attributes using the array of attributes that you passed to the constructor.
FillAttributes | In an inheriting class, adds the attributes of the inheriting class to the specified list of attributes in the parent class.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
FindMethod | Finds the given method through reflection.
GetInvokee | Gets the component that a method should be invoked on.
GetSite | Gets a component site for the given component.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MemberDescriptor Class | System.ComponentModel Namespace


MemberDescriptor Constructor

Initializes a new instance of the MemberDescriptor class.

Overload List

Initializes a new instance of the MemberDescriptor class with the specified name

and no attributes.

[Visual Basic] Overloads Public Sub New(String)
[C#] public MemberDescriptor(String);
[C++] public: MemberDescriptor(String*);
[JScript] public function MemberDescriptor(String);

Initializes a new instance of the MemberDescriptor class with the specified name and attributes array.

[Visual Basic] Overloads Public Sub New(String, MemberAttribute())
[C#] public MemberDescriptor(String, MemberAttribute[]);
[C++] public: MemberDescriptor(String*, MemberAttribute[]);
[JScript] public function MemberDescriptor(String, MemberAttribute[]);

Initializes a new instance of the MemberDescriptor class with the specified MemberDescriptor.

[Visual Basic] Overloads Public Sub New(MemberDescriptor)
[C#] public MemberDescriptor(MemberDescriptor);
[C++] public: MemberDescriptor(MemberDescriptor*);
[JScript] public function MemberDescriptor(MemberDescriptor);

Initializes a new instance of the MemberDescriptor class with the name in the specified MemberDescriptor and the attributes in both the old MemberDescriptor and the MemberAttribute array.

[Visual Basic] Overloads Public Sub New(MemberDescriptor, MemberAttribute())
[C#] public MemberDescriptor(MemberDescriptor, MemberAttribute[]);
[C++] public: MemberDescriptor(MemberDescriptor*, MemberAttribute[]);
[JScript] public function MemberDescriptor(MemberDescriptor, MemberAttribute[]);

See Also

MemberDescriptor Class | MemberDescriptor Members | System.ComponentModel Namespace


MemberDescriptor Constructor (String)

Initializes a new instance of the MemberDescriptor class with the specified name

and no attributes.

[Visual Basic]
Overloads Public Sub New( _
   ByVal name As String _
)
[C#]
public MemberDescriptor(
   string name
);
[C++]
public: MemberDescriptor(
   String* name
);
[JScript]
public function MemberDescriptor(
   name : String
);

Parameters

name
The name of the member.

See Also

MemberDescriptor Class | MemberDescriptor Members | System.ComponentModel Namespace | MemberDescriptor Constructor Overload List


MemberDescriptor Constructor (String, MemberAttribute[])

Initializes a new instance of the MemberDescriptor class with the specified name and attributes array.

[Visual Basic]
Overloads Public Sub New( _
   ByVal name As String, _
   ByVal attributes() As MemberAttribute _
)
[C#]
public MemberDescriptor(
   string name,
   MemberAttribute[] attributes
);
[C++]
public: MemberDescriptor(
   String* name,
   MemberAttribute* attributes[]
);
[JScript]
public function MemberDescriptor(
   name : String,
   attributes : MemberAttribute[]
);

Parameters

name
The name of the member.
attributes
An array of type MemberAttribute that contains the member attributes.

Exceptions

Exception Type | Condition
ArgumentException | The name is an empty string ("") or a null reference (in Visual Basic Nothing).

See Also

MemberDescriptor Class | MemberDescriptor Members | System.ComponentModel Namespace | MemberDescriptor Constructor Overload List


MemberDescriptor Constructor (MemberDescriptor)

Initializes a new instance of the MemberDescriptor class with the specified MemberDescriptor.

[Visual Basic]
Overloads Public Sub New( _
   ByVal descr As MemberDescriptor _
)
[C#]
public MemberDescriptor(
   MemberDescriptor descr
);
[C++]
public: MemberDescriptor(
   MemberDescriptor* descr
);
[JScript]
public function MemberDescriptor(
   descr : MemberDescriptor
);

Parameters

descr
A MemberDescriptor that contains the name of the member and its attributes.

See Also

MemberDescriptor Class | MemberDescriptor Members | System.ComponentModel Namespace | MemberDescriptor Constructor Overload List


MemberDescriptor Constructor (MemberDescriptor, MemberAttribute[])

Initializes a new instance of the MemberDescriptor class with the name in the specified MemberDescriptor and the attributes in both the old MemberDescriptor and the MemberAttribute array.

[Visual Basic]
Overloads Public Sub New( _
   ByVal oldMemberDescriptor As MemberDescriptor, _
   ByVal newAttributes() As MemberAttribute _
)
[C#]
public MemberDescriptor(
   MemberDescriptor oldMemberDescriptor,
   MemberAttribute[] newAttributes
);
[C++]
public: MemberDescriptor(
   MemberDescriptor* oldMemberDescriptor,
   MemberAttribute* newAttributes[]
);
[JScript]
public function MemberDescriptor(
   oldMemberDescriptor : MemberDescriptor,
   newAttributes : MemberAttribute[]
);

Parameters

oldMemberDescriptor
A MemberDescriptor that has the name of the member and its attributes.
newAttributes
A MemberAttribute array with the attributes you wish to add to the member.

Remarks

This constructor appends the attributes in the MemberAttribute array to the attributes in the old MemberDescriptor.

See Also

MemberDescriptor Class | MemberDescriptor Members | System.ComponentModel Namespace | MemberDescriptor Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MemberDescriptor Properties

The properties of the MemberDescriptor class are listed below. For a complete list of MemberDescriptor class members, see the MemberDescriptor Members topic.

Public:

Attributes | Gets the collection of attributes for this member.
Category | Gets the name of the category that the member belongs to, as specified in the CategoryAttribute.
Description | Gets the description of the member as specified in the DescriptionAttribute.
IsBrowsable | Gets a value indicating whether the member is browsable as specified in the BrowsableAttribute.
Name | Gets the name of the member.

Protected:

AttributeArray | Gets or sets an array of attributes.
NameHashCode | Gets the hash code for the name of the member as specified in GetHashCode.

See Also

MemberDescriptor Class | System.ComponentModel Namespace


MemberDescriptor.AttributeArray

Gets or sets an array of attributes.

[Visual Basic]
Overridable Protected Property AttributeArray As MemberAttribute ()
[C#]
protected MemberAttribute
    AttributeArray {virtual get; virtual
   set;}
[C++]
protected: __property virtual MemberAttribute* get_AttributeArray();
protected: __property virtual void set_AttributeArray(MemberAttribute*[]);
[JScript]
protected function get AttributeArray() : MemberAttribute[];
protected function set AttributeArray(MemberAttribute[]);

Property Value

An array of type MemberAttribute that contains the attributes of this member.

See Also

MemberDescriptor Class | MemberDescriptor Members | System.ComponentModel Namespace | Attributes


MemberDescriptor.Attributes

Gets the collection of attributes for this member.

[Visual Basic]
Overridable Public ReadOnly Property Attributes As _
   MemberAttributeCollection
[C#]
public MemberAttributeCollection Attributes {virtual get;}
[C++]
public: __property virtual MemberAttributeCollection*
   get_Attributes();
[JScript]
public function get Attributes() : MemberAttributeCollection;

Property Value

A MemberAttributeCollection that provides the attributes for this member. If there are no attributes in the AttributeArray, then the property value is an empty collection.

Remarks

If there is no MemberAttributeCollection for this member, this property calls CreateAttributeCollection to create a new MemberAttributeCollection using the array of MemberAttributes that you passed to the constructor.

See Also

MemberDescriptor Class | MemberDescriptor Members | System.ComponentModel Namespace | AttributeArray


MemberDescriptor.Category

Gets the name of the category that the member belongs to, as specified in the CategoryAttribute.

[Visual Basic]
Overridable Public ReadOnly Property Category As String
[C#]
public string Category {virtual get;}
[C++]
public: __property virtual String* get_Category();
[JScript]
public function get Category() : String;

Property Value

The name of the category that the member belongs to. If there is no CategoryAttribute, the category name is set to the default category, Misc.

Remarks

This property value can be used by a visual designer to display members in categories.

See Also

MemberDescriptor Class | MemberDescriptor Members | System.ComponentModel Namespace | Description | IsBrowsable | Name


MemberDescriptor.Description

Gets the description of the member as specified in the DescriptionAttribute.

[Visual Basic]
Overridable Public ReadOnly Property Description As String
[C#]
public string Description {virtual get;}
[C++]
public: __property virtual String* get_Description();
[JScript]
public function get Description() : String;

Property Value

The description of the member. If there is no DescriptionAttribute, the property value is set to the default, which is the empty string ("").

Remarks

This description can be used by a visual designer to display a information about this member.

See Also

MemberDescriptor Class | MemberDescriptor Members | System.ComponentModel Namespace | Category | IsBrowsable | Name


MemberDescriptor.IsBrowsable

Gets a value indicating whether the member is browsable as specified in the BrowsableAttribute.

[Visual Basic]
Overridable Public ReadOnly Property IsBrowsable As Boolean
[C#]
public bool IsBrowsable {virtual get;}
[C++]
public: __property virtual bool get_IsBrowsable();
[JScript]
public function get IsBrowsable() : Boolean;

Property Value

true if the member is browsable; otherwise, false. If there is no BrowsableAttribute, the property value is set to the default, which is true.

Remarks

A visual designer typically displays the members that are browsable in the property browser.

See Also

MemberDescriptor Class | MemberDescriptor Members | System.ComponentModel Namespace | Category | Description | Name


MemberDescriptor.Name

Gets the name of the member.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {virtual get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

Property Value

The name of the member.

See Also

MemberDescriptor Class | MemberDescriptor Members | System.ComponentModel Namespace | Category | Description | IsBrowsable


MemberDescriptor.NameHashCode

Gets the hash code for the name of the member as specified in GetHashCode.

[Visual Basic]
Overridable Protected ReadOnly Property NameHashCode As Integer
[C#]
protected int NameHashCode {virtual get;}
[C++]
protected: __property virtual int get_NameHashCode();
[JScript]
protected function get NameHashCode() : int;

Property Value

The hash code for the name of the member.

See Also

MemberDescriptor Class | MemberDescriptor Members | System.ComponentModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MemberDescriptor Methods

The methods of the MemberDescriptor class are listed below. For a complete list of MemberDescriptor class members, see the MemberDescriptor Members topic.

Public:

Equals | Compares this instance to the specified MemberDescriptor to see if they are equivalent.
GetDesignTimeOnly | Determines whether this member should be set only at design time as specified in the DesignOnlyAttribute.
GetDisplayName | Gets the name that can be displayed in a window like a property browser.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHelpTopic | Gets the name of the Help topic specified in the HelpAttribute.
GetHelpURL | Gets the URL for the Help file specified in the HelpAttribute.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

CreateAttributeCollection | Creates a collection of attributes using the array of attributes that you passed to the constructor.
FillAttributes | In an inheriting class, adds the attributes of the inheriting class to the specified list of attributes in the parent class.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
FindMethod | Finds the given method through reflection.
GetInvokee | Gets the component that a method should be invoked on.
GetSite | Gets a component site for the given component.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MemberDescriptor Class | System.ComponentModel Namespace


MemberDescriptor.CreateAttributeCollection

Creates a collection of attributes using the array of attributes that you passed to the constructor.

[Visual Basic]
Overridable Protected Function CreateAttributeCollection() As _
   MemberAttributeCollection
[C#]
protected virtual MemberAttributeCollection
   CreateAttributeCollection();
[C++]
protected: virtual MemberAttributeCollection*
   CreateAttributeCollection();
[JScript]
protected function CreateAttributeCollection() :
   MemberAttributeCollection;

Return Value

A new MemberAttributeCollection that contains the AttributeArray attributes.

Remarks

This method is called from the Attributes property when there is no MemberAttributeCollection for this member. If there are no attributes in the AttributeArray, this will return an empty MemberAttributeCollection.

See Also

MemberDescriptor Class | MemberDescriptor Members | System.ComponentModel Namespace


MemberDescriptor.Equals

Compares this instance to the specified MemberDescriptor to see if they are equivalent.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The MemberDescriptor to compare to the current instance.

Return Value

true if equivalent; otherwise, false.

See Also

MemberDescriptor Class | MemberDescriptor Members | System.ComponentModel Namespace


MemberDescriptor.FillAttributes

In an inheriting class, adds the attributes of the inheriting class to the specified list of attributes in the parent class.

[Visual Basic]
Overridable Protected Sub FillAttributes( _
   ByVal attributeList As IList _
)
[C#]
protected virtual void FillAttributes(
   IList attributeList
);
[C++]
protected: virtual void FillAttributes(
   IList* attributeList
);
[JScript]
protected function FillAttributes(
   attributeList : IList
);

Parameters

attributeList
An IList that lists the attributes in the parent class. Initially, this will be empty.

Remarks

The IList with the attributes is created once. If there are duplicate attributes in the list, only the first instance is saved; all subsequent duplicate attributes are removed from the list.

See Also

MemberDescriptor Class | MemberDescriptor Members | System.ComponentModel Namespace


MemberDescriptor.FindMethod

Finds the given method through reflection.

[Visual Basic]
Protected Shared Function FindMethod( _
   ByVal componentClass As Type, _
   ByVal name As String, _
   ByVal args() As Type, _
   ByVal returnType As Type _
) As MethodInfo
[C#]
protected static MethodInfo FindMethod(
   Type componentClass,
   string name,
   Type[] args,
   Type returnType
);
[C++]
protected: static MethodInfo* FindMethod(
   Type* componentClass,
   String* name,
   Type* args[],
   Type* returnType
);
[JScript]
protected static function FindMethod(
   componentClass : Type,
   name : String,
   args : Type[],
   returnType : Type
) : MethodInfo;

Parameters

componentClass
The component that contains the method.
name
The name of the method to find.
args
An array of parameters for the method. This is used to choose between overloaded methods.
returnType
The type to return for the method.

Return Value

A MethodInfo that represents the method. If the method is not found, a null reference (in Visual Basic Nothing) is returned.

See Also

MemberDescriptor Class | MemberDescriptor Members | System.ComponentModel Namespace


MemberDescriptor.GetDesignTimeOnly

Determines whether this member should be set only at design time as specified in the DesignOnlyAttribute.

[Visual Basic]
Overridable Public Function GetDesignTimeOnly() As Boolean
[C#]
public virtual bool GetDesignTimeOnly();
[C++]
public: virtual bool GetDesignTimeOnly();
[JScript]
public function GetDesignTimeOnly() : Boolean;

Return Value

true if this member should be set only at design time; false if the member can be set during run time.

Remarks

If there is no DesignOnlyAttribute, the return value is the default, which is false.

See Also

MemberDescriptor Class | MemberDescriptor Members | System.ComponentModel Namespace | GetDisplayName


MemberDescriptor.GetDisplayName

Gets the name that can be displayed in a window like a property browser.

[Visual Basic]
Overridable Public Function GetDisplayName() As String
[C#]
public virtual string GetDisplayName();
[C++]
public: virtual String* GetDisplayName();
[JScript]
public function GetDisplayName() : String;

Return Value

The name to display for the member.

See Also

MemberDescriptor Class | MemberDescriptor Members | System.ComponentModel Namespace | GetDesignTimeOnly


MemberDescriptor.GetHelpTopic

Gets the name of the Help topic specified in the HelpAttribute.

[Visual Basic]
Overridable Public Function GetHelpTopic() As String
[C#]
public virtual string GetHelpTopic();
[C++]
public: virtual String* GetHelpTopic();
[JScript]
public function GetHelpTopic() : String;

Return Value

The Help topic that provides information for the member. If there is no HelpAttribute, the return value is set to the empty string ("").

Remarks

A visual designer can use this information to provide help for the member.

See Also

MemberDescriptor Class | MemberDescriptor Members | System.ComponentModel Namespace | GetHelpURL


MemberDescriptor.GetHelpURL

Gets the URL for the Help file specified in the HelpAttribute.

[Visual Basic]
Overridable Public Function GetHelpURL() As String
[C#]
public virtual string GetHelpURL();
[C++]
public: virtual String* GetHelpURL();
[JScript]
public function GetHelpURL() : String;

Return Value

The URL of the Help file that provides information for the member. If there is no HelpAttribute, the return value is set to the empty string ("").

Remarks

A visual designer can use this information to provide help for the member.

See Also

MemberDescriptor Class | MemberDescriptor Members | System.ComponentModel Namespace | GetHelpTopic


MemberDescriptor.GetInvokee

Gets the component that a method should be invoked on.

[Visual Basic]
Protected Shared Function GetInvokee( _
   ByVal componentClass As Type, _
   ByVal component As Object _
) As Object
[C#]
protected static object GetInvokee(
   Type componentClass,
   object component
);
[C++]
protected: static Object* GetInvokee(
   Type* componentClass,
   Object* component
);
[JScript]
protected static function GetInvokee(
   componentClass : Type,
   component : Object
) : Object;

Parameters

componentClass
A Type representing the type of component this MemberDescriptor is bound to. For example, if this MemberDescriptor describes a property, this parameter should be the class that the property is declared on.
component
An instance of the object to call.

Return Value

An instance of the component to invoke. This method returns a visual designer when the property is attached to a visual designer.

See Also

MemberDescriptor Class | MemberDescriptor Members | System.ComponentModel Namespace


MemberDescriptor.GetSite

Gets a component site for the given component.

[Visual Basic]
Protected Shared Function GetSite( _
   ByVal component As Object _
) As ISite
[C#]
protected static ISite GetSite(
   object component
);
[C++]
protected: static ISite* GetSite(
   Object* component
);
[JScript]
protected static function GetSite(
   component : Object
) : ISite;

Parameters

component
The component whose site you want to find.

Return Value

The site of the component, or a null reference (in Visual Basic Nothing) if a site does not exist.

See Also

MemberDescriptor Class | MemberDescriptor Members | System.ComponentModel Namespace


MergablePropertyAttribute Class

Specifies that this property can be combined with properties belonging to other objects in a property browser.

Object
Attribute
MemberAttribute
MergablePropertyAttribute

[Visual Basic]
Public Class MergablePropertyAttribute
   Inherits MemberAttribute
[C#]
public class MergablePropertyAttribute : MemberAttribute
[C++]
public __gc class MergablePropertyAttribute : public
   MemberAttribute
[JScript]
public class MergablePropertyAttribute extends MemberAttribute

Remarks

Properties that are marked with MergableProperty(true) can be combined with oproperties belonging to other objects in a property browser. Properties that are marked with MergableProperty(false) must be displayed separately. The default is true.

Note When you mark a property with MergableProperty(true), the value of this attribute is set to the constant member MergablePropertyAttribute.Yes. For a property marked with MergableProperty(false), the value is MergablePropertyAttribute.No. Therefore, when you want to check the value of this attribute in your code, you must specify the attribute as MergablePropertyAttribute.Yes or MergablePropertyAttribute.No.

For more information, see TBD and TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | MemberAttribute


NotificationAttribute Class

Specifies whether a property should send notification events when changed.

Object
Attribute
MemberAttribute
NotificationAttribute

[Visual Basic]
Public Class NotificationAttribute
   Inherits MemberAttribute
[C#]
public class NotificationAttribute : MemberAttribute
[C++]
public __gc class NotificationAttribute : public MemberAttribute
[JScript]
public class NotificationAttribute extends MemberAttribute

Remarks

Members that have no notification attribute or that are marked with Notification(???) should send notification events when changed. Members that are marked with Notification(???) do not need to send notification events. The default is Yes.For more information, see TBD and TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | MemberAttribute | PropertyDescriptor


ObjectDisposedException Class

ObjectDisposedExceptions are thrown when an object is accessed that has been disposed. Once objects have been disposed, they normally cannot be used.

Object
Exception
ObjectDisposedException

[Visual Basic]
Public Class ObjectDisposedException
   Inherits Exception
[C#]
public class ObjectDisposedException : Exception
[C++]
public __gc class ObjectDisposedException : public Exception
[JScript]
public class ObjectDisposedException extends Exception

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

ObjectDisposedException Members | System.ComponentModel Namespace


ObjectDisposedException Members

Public:

Constructor

ObjectDisposedException Constructor Creates a new ObjectDisposedException.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message | [To be supplied.]
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

ObjectDisposedException Class | System.ComponentModel Namespace


ObjectDisposedException Constructor

Creates a new ObjectDisposedException.

[Visual Basic]
Public Sub New( _
   ByVal objectName As String _
)
[C#]
public ObjectDisposedException(
   string objectName
);
[C++]
public: ObjectDisposedException(
   String* objectName
);
[JScript]
public function ObjectDisposedException(
   objectName : String
);

Parameters

objectName
Name of the object that is disposed

See Also

ObjectDisposedException Class | ObjectDisposedException Members | System.ComponentModel Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ObjectDisposedException Properties

The properties of the ObjectDisposedException class are listed below. For a complete list of ObjectDisposedException class members, see the ObjectDisposedException Members topic.

Public:

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message | [To be supplied.]
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

See Also

ObjectDisposedException Class | System.ComponentModel Namespace


ObjectDisposedException.Message

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Message As String
[C#]
public string Message {override get;}
[C++]
public: __property virtual String* get_Message();
[JScript]
public function get Message() : String;

See Also

ObjectDisposedException Class | ObjectDisposedException Members | System.ComponentModel Namespace


PersistableAttribute Class

Specifies which values are saved for a property, or event.

Object
Attribute
MemberAttribute
PersistableAttribute

[Visual Basic]
Public Class PersistableAttribute
   Inherits MemberAttribute
[C#]
public class PersistableAttribute : MemberAttribute
[C++]
public __gc class PersistableAttribute : public MemberAttribute
[JScript]
public class PersistableAttribute extends MemberAttribute

Remarks

When generating code, the value used to set persistence determines which aspects of the property, or event are examined and saved.

When you mark a property with this attribute, it is set to a constant member. When you want to check the value of this attribute in your code, you must specify the constant member. The constant member that each value is set to, is listed in the Description column in the table below.

The following persistence values are defined:

Persistence Value | Description
PersistableSupport.None | The component code generator will not generate code for any format. The attribute is set to the constant member PersistableAttribute.None.
PersistableSupport.All | The component code generator will generate code for all formats. This is the default. The attribute is set to the constant member PersistableAttribute.All.
PersistableSupport.Resource | The component code generator will generate code only for resources. The attribute is set to the constant member PersistableAttribute.Resource.
PersistableSupport.Code | The component code generator will generate code only for code. The attribute is set to the constant member PersistableAttribute.Code.
PersistableSupport.Declarative | The component code generator will generate code for a declarative format such as HTML. The attribute is set to the constant member PersistableAttribute.Declarative.
PersistableSupport.NotCode | The component code generator will generate code for any format except code. The attribute is set to the constant member PersistableAttribute.NotCode.
PersistableSupport.NotDeclarative | The component code generator will generate code for any format except declarative, for example HTML. The attribute is set to the constant member PersistableAttribute.NotDeclarative.
Yes | The component code generator will generate code for all formats. The attribute is set to the constant member PersistableAttribute.All.
No | The component code generator will not generate code for any format. The attribute is set to the constant member PersistableAttribute.None.

Use the Support property to get the type of persistence that is defined for a member.

For more information, see TBD and TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | MemberAttribute | PropertyDescriptor


PersistableSupport Enumeration

Specifies which values to save for a property or event.

[Visual Basic]
Public Enum PersistableSupport
[C#]
public enum PersistableSupport
[C++]
public enum PersistableSupport

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

A PersistableSupport value is used by a visual designer to determine which aspects of the property or event, should be examined and saved.

Members

Member Name | Description
All | The code generator will produce code for all formats.
Code | The code generator will produce code only for code.
Declarative | The code generator will produce code for a declarative format such as HTML.
None | The code generator will not produce code for any format.
NotCode | The code generator will produce code for any format except code; that is, it will generate code for the declarative and resource formats.
NotDeclarative | The code generator will produce code for any format except declarative; that is, it will generate code for code and resources.
Resource | The code generator will produce code only for resources.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace


PersistContentsAttribute Class

Specifies whether a visual designer must generate special code to persist the value of a property.

Object
Attribute
MemberAttribute
PersistContentsAttribute

[Visual Basic]
Public Class PersistContentsAttribute
   Inherits MemberAttribute
[C#]
public class PersistContentsAttribute : MemberAttribute
[C++]
public __gc class PersistContentsAttribute : public MemberAttribute
[JScript]
public class PersistContentsAttribute extends MemberAttribute

Remarks

Typically a visual designer only generates code to set the read/write properties of a new component; it skips read-only properties. Some properties, such as the properties that return collections, are read-only and therefore are skipped. If you want a visual designer to generate code for the read-only property, you must mark the property with PersistContents(true). This would allow you, for example, to add items to a collection.

Members that do not have the PersistContentsAttribute or that are marked with PersistContents(false) will use the default code generation rules; that is, their code will be persisted in the normal fashion. The default is false.

Note When you mark a property with PersistContents(true), the value of this attribute is set to the constant member PersistContentsAttribute.Yes. For a property marked with PersistContents(false), the value is PersistContentsAttribute.No. Therefore, when you want to check the value of this attribute in your code, you must specify the attribute as PersistContentsAttribute.Yes or PersistContentsAttribute.No.

For more information, see TBD and TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | MemberAttribute | PropertyDescriptor


PersisterAttribute Class

Specifies what class to use as a value persister.

Object
Attribute
MemberAttribute
PersisterAttribute

[Visual Basic]
NotInheritable Public Class PersisterAttribute
   Inherits MemberAttribute
[C#]
public sealed class PersisterAttribute : MemberAttribute
[C++]
public __gc __sealed class PersisterAttribute : public
   MemberAttribute
[JScript]
public class PersisterAttribute extends MemberAttribute

Remarks

Use the PersisterTypeName property to get the name of the class to use as a persister.

For more information, see TBD and TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace


PersistInfo Class

The PersistInfo class defines a generic way to persist an object's values.

Object
PersistInfo

[Visual Basic]
MustInherit Public Class PersistInfo
[C#]
public abstract class PersistInfo
[C++]
public __gc __abstract class PersistInfo
[JScript]
public abstract class PersistInfo

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

PersistInfo Members | System.ComponentModel Namespace


PersistInfo Members

Public:

Constructor

PersistInfo Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PersistInfo Class | System.ComponentModel Namespace


PersistInfo Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public PersistInfo();
[C++]
public: PersistInfo();
[JScript]
public function PersistInfo();

See Also

PersistInfo Class | PersistInfo Members | System.ComponentModel Namespace


PropertyChangedEventArgs Class

Provides data for the OnPropertyChanged event.

Object
EventArgs
PropertyChangedEventArgs

[Visual Basic]
Public Class PropertyChangedEventArgs
   Inherits EventArgs
[C#]
public class PropertyChangedEventArgs : EventArgs
[C++]
public __gc class PropertyChangedEventArgs : public EventArgs
[JScript]
public class PropertyChangedEventArgs extends EventArgs

Remarks

A OnPropertyChanged event is raised when a property is changed on a component. A PropertyChangedEventArgs object specifies the name of the property that changed.

PropertyChangedEventArgs provides the PropertyName property to get the name of the property that changed.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

PropertyChangedEventArgs Members | System.ComponentModel Namespace | PropertyChangedEventHandler


PropertyChangedEventArgs Members

Public:

Constructor

PropertyChangedEventArgs Constructor Initializes a new instance of PropertyChangedEventArgs class.

Properties

ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
PropertyName | Gets the name of the property that changed.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyChangedEventArgs Class | System.ComponentModel Namespace


PropertyChangedEventArgs Constructor

Initializes a new instance of PropertyChangedEventArgs class.

[Visual Basic]
Public Sub New( _
   ByVal propertyName As String _
)
[C#]
public PropertyChangedEventArgs(
   string propertyName
);
[C++]
public: PropertyChangedEventArgs(
   String* propertyName
);
[JScript]
public function PropertyChangedEventArgs(
   propertyName : String
);

Parameters

propertyName
The name of the property that changed.

See Also

PropertyChangedEventArgs Class | PropertyChangedEventArgs Members | System.ComponentModel Namespace | PropertyChangedEventHandler


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PropertyChangedEventArgs Properties

The properties of the PropertyChangedEventArgs class are listed below. For a complete list of PropertyChangedEventArgs class members, see the PropertyChangedEventArgs Members topic.

Public:

ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
PropertyName | Gets the name of the property that changed.

See Also

PropertyChangedEventArgs Class | System.ComponentModel Namespace


PropertyChangedEventArgs.PropertyName

Gets the name of the property that changed.

[Visual Basic]
Overridable Public ReadOnly Property PropertyName As String
[C#]
public string PropertyName {virtual get;}
[C++]
public: __property virtual String* get_PropertyName();
[JScript]
public function get PropertyName() : String;

Property Value

The name of the property that changed.

See Also

PropertyChangedEventArgs Class | PropertyChangedEventArgs Members | System.ComponentModel Namespace


PropertyChangedEventHandler Delegate

Represents the method that will handle the PropertyChanged XXX event raised when a property is changed on a component.

[Visual Basic]
Public Delegate Sub PropertyChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As PropertyChangedEventArgs _
)
[C#]
public delegate void PropertyChangedEventHandler(
   object sender,
   PropertyChangedEventArgs e
);
[C++]
public __gc __delegate void PropertyChangedEventHandler(
   Object* sender,
   PropertyChangedEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the PropertyChangedEventHandler delegate declaration.

sender
The source of the event.
e
A PropertyChangedEventArgs that contains the property data.

Remarks

When you create a PropertyChangedEventHandler delegate, you identify the method that will handle the event. To associate the event with your event-handling method, add an instance of the delegate to the event. The event-handler method is called whenever the event occurs, unless you remove the delegate. For more information about event handler delegates, see TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | PropertyChangedEventArgs


PropertyDescriptor Class

Provides a description of a property.

Object
MemberDescriptor
PropertyDescriptor

[Visual Basic]
MustInherit Public Class PropertyDescriptor
   Inherits MemberDescriptor
[C#]
public abstract class PropertyDescriptor : MemberDescriptor
[C++]
public __gc __abstract class PropertyDescriptor : public
   MemberDescriptor
[JScript]
public abstract class PropertyDescriptor extends MemberDescriptor

Remarks

A description of a property consists of a name, its attributes, the component class that the property is associated with, and the type of the property.

PropertyDescriptor provides the following properties and methods:

  • Converter contains the type converter for this property.
  • IsLocalizable contains a value indicating whether this property should be localized.
  • PersistableSupport contains a value indicating whether this property should be persisted.
  • GetEditor gets an editor of the specified type.

PropertyDescriptor also provides the following abstract (in Visual Basic MustOverride) properties and methods:

  • ComponentType contains the type of component this property is bound to.
  • IsReadOnly contains a value indicating whether this property is read-only.
  • PropertyType gets the type of the property.
  • CanResetValue indicates whether resetting the component will change the value of the component.
  • GetValue gets the current value of the property on a component.
  • ResetValue resets the value for this property of the component.
  • SetValue sets the value of the component to a different value.
  • ShouldPersistValue indicates whether the value of this property needs to be persisted.

Typically, these abstract (MustOverride) members are implemented through reflection.

[Need link to conceptual property topic when created by Vandana.]

[Need link to conceptual reflection topic.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

PropertyDescriptor Members | System.ComponentModel Namespace | MemberDescriptor | MemberAttribute | DefaultValueAttribute


PropertyDescriptor Members

Public:

Properties

Attributes (inherited from MemberDescriptor) | Gets the collection of attributes for this member.
Category (inherited from MemberDescriptor) | Gets the name of the category that the member belongs to, as specified in the CategoryAttribute.
ComponentType | When overridden in a derived class, gets the type of the component this property is bound to.
Converter | Gets the type converter for this property.
Description (inherited from MemberDescriptor) | Gets the description of the member as specified in the DescriptionAttribute.
IsBrowsable (inherited from MemberDescriptor) | Gets a value indicating whether the member is browsable as specified in the BrowsableAttribute.
IsLocalizable | Gets a value indicating whether this property should be localized, as specified in the LocalizableAttribute.
IsReadOnly | When overridden in a derived class, gets a value indicating whether this property is read-only.
Name (inherited from MemberDescriptor) | Gets the name of the member.
PersistableSupport | Gets a value indicating whether this property should be persisted as specified in the PersistableAttribute.
PropertyType | When overridden in a derived class, gets the type of the property.

Methods

CanResetValue | When overridden in a derived class, indicates whether resetting the component will change the value of the component.
Equals | Compares this to another PropertyDescriptor to see if they are equivalent.
GetDesignTimeOnly (inherited from MemberDescriptor) | Determines whether this member should be set only at design time as specified in the DesignOnlyAttribute.
GetDisplayName (inherited from MemberDescriptor) | Gets the name that can be displayed in a window like a property browser.
GetEditor | Gets an editor of the specified type.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHelpTopic (inherited from MemberDescriptor) | Gets the name of the Help topic specified in the HelpAttribute.
GetHelpURL (inherited from MemberDescriptor) | Gets the URL for the Help file specified in the HelpAttribute.
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | When overridden in a derived class, gets the current value of the property on a component.
ResetValue | When overridden in a derived class, resets the value for this property of the component.
SetValue | When overridden in a derived class, sets the value of the component to a different value.
ShouldPersistValue | When overridden in a derived class, indicates whether the value of this property needs to be persisted.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Constructor

PropertyDescriptor Constructor Overloaded. Initializes a new instance of the PropertyDescriptor class.

Properties

AttributeArray (inherited from MemberDescriptor) | Gets or sets an array of attributes.
NameHashCode (inherited from MemberDescriptor) | Gets the hash code for the name of the member as specified in GetHashCode.

Methods

CreateAttributeCollection (inherited from MemberDescriptor) | Creates a collection of attributes using the array of attributes that you passed to the constructor.
CreateInstance | Creates an instance of the specified type.
FillAttributes (inherited from MemberDescriptor) | In an inheriting class, adds the attributes of the inheriting class to the specified list of attributes in the parent class.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyDescriptor Class | System.ComponentModel Namespace


PropertyDescriptor Constructor

Initializes a new instance of the PropertyDescriptor class.

Overload List

Initializes a new instance of the PropertyDescriptor class with the specified name and attributes.

[Visual Basic] Overloads Protected Sub New(String, MemberAttribute())
[C#] protected PropertyDescriptor(String, MemberAttribute[]);
[C++] protected: PropertyDescriptor(String*, MemberAttribute[]);
[JScript] protected function PropertyDescriptor(String, MemberAttribute[]);

Initializes a new instance of the PropertyDescriptor class with the name and attributes in the specified MemberDescriptor.

[Visual Basic] Overloads Protected Sub New(MemberDescriptor)
[C#] protected PropertyDescriptor(MemberDescriptor);
[C++] protected: PropertyDescriptor(MemberDescriptor*);
[JScript] protected function PropertyDescriptor(MemberDescriptor);

Initializes a new instance of the PropertyDescriptor class with the name in the specified MemberDescriptor and the attributes in both the MemberDescriptor and the MemberAttribute array.

[Visual Basic] Overloads Protected Sub New(MemberDescriptor, MemberAttribute())
[C#] protected PropertyDescriptor(MemberDescriptor, MemberAttribute[]);
[C++] protected: PropertyDescriptor(MemberDescriptor*, MemberAttribute[]);
[JScript] protected function PropertyDescriptor(MemberDescriptor, MemberAttribute[]);

See Also

PropertyDescriptor Class | PropertyDescriptor Members | System.ComponentModel Namespace


PropertyDescriptor Constructor (String, MemberAttribute[])

Initializes a new instance of the PropertyDescriptor class with the specified name and attributes.

[Visual Basic]
Overloads Protected Sub New( _
   ByVal name As String, _
   ByVal attrs() As MemberAttribute _
)
[C#]
protected PropertyDescriptor(
   string name,
   MemberAttribute[] attrs
);
[C++]
protected: PropertyDescriptor(
   String* name,
   MemberAttribute* attrs[]
);
[JScript]
protected function PropertyDescriptor(
   name : String,
   attrs : MemberAttribute[]
);

Parameters

name
The name of the property.
attrs
An array of type MemberAttribute that contains the property attributes.

See Also

PropertyDescriptor Class | PropertyDescriptor Members | System.ComponentModel Namespace | PropertyDescriptor Constructor Overload List | MemberAttribute


PropertyDescriptor Constructor (MemberDescriptor)

Initializes a new instance of the PropertyDescriptor class with the name and attributes in the specified MemberDescriptor.

[Visual Basic]
Overloads Protected Sub New( _
   ByVal descr As MemberDescriptor _
)
[C#]
protected PropertyDescriptor(
   MemberDescriptor descr
);
[C++]
protected: PropertyDescriptor(
   MemberDescriptor* descr
);
[JScript]
protected function PropertyDescriptor(
   descr : MemberDescriptor
);

Parameters

descr
A MemberDescriptor that contains the name of the property and its attributes.

See Also

PropertyDescriptor Class | PropertyDescriptor Members | System.ComponentModel Namespace | PropertyDescriptor Constructor Overload List | MemberDescriptor


PropertyDescriptor Constructor (MemberDescriptor, MemberAttribute[])

Initializes a new instance of the PropertyDescriptor class with the name in the specified MemberDescriptor and the attributes in both the MemberDescriptor and the MemberAttribute array.

[Visual Basic]
Overloads Protected Sub New( _
   ByVal descr As MemberDescriptor, _
   ByVal attrs() As MemberAttribute _
)
[C#]
protected PropertyDescriptor(
   MemberDescriptor descr,
   MemberAttribute[] attrs
);
[C++]
protected: PropertyDescriptor(
   MemberDescriptor* descr,
   MemberAttribute* attrs[]
);
[JScript]
protected function PropertyDescriptor(
   descr : MemberDescriptor,
   attrs : MemberAttribute[]
);

Parameters

descr
A MemberDescriptor that has the name of the member and its attributes.
attrs
A MemberAttribute array with the attributes you want to associate with the property.

Remarks

This constructor appends the attributes in the MemberAttribute array to the attributes in the MemberDescriptor.

See Also

PropertyDescriptor Class | PropertyDescriptor Members | System.ComponentModel Namespace | PropertyDescriptor Constructor Overload List | MemberDescriptor | MemberAttribute


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PropertyDescriptor Properties

The properties of the PropertyDescriptor class are listed below. For a complete list of PropertyDescriptor class members, see the PropertyDescriptor Members topic.

Public:

Attributes (inherited from MemberDescriptor) | Gets the collection of attributes for this member.
Category (inherited from MemberDescriptor) | Gets the name of the category that the member belongs to, as specified in the CategoryAttribute.
ComponentType | When overridden in a derived class, gets the type of the component this property is bound to.
Converter | Gets the type converter for this property.
Description (inherited from MemberDescriptor) | Gets the description of the member as specified in the DescriptionAttribute.
IsBrowsable (inherited from MemberDescriptor) | Gets a value indicating whether the member is browsable as specified in the BrowsableAttribute.
IsLocalizable | Gets a value indicating whether this property should be localized, as specified in the LocalizableAttribute.
IsReadOnly | When overridden in a derived class, gets a value indicating whether this property is read-only.
Name (inherited from MemberDescriptor) | Gets the name of the member.
PersistableSupport | Gets a value indicating whether this property should be persisted as specified in the PersistableAttribute.
PropertyType | When overridden in a derived class, gets the type of the property.

Protected:

AttributeArray (inherited from MemberDescriptor) | Gets or sets an array of attributes.
NameHashCode (inherited from MemberDescriptor) | Gets the hash code for the name of the member as specified in GetHashCode.

See Also

PropertyDescriptor Class | System.ComponentModel Namespace


PropertyDescriptor.ComponentType

When overridden in a derived class, gets the type of the component this property is bound to.

[Visual Basic]
MustOverride Public ReadOnly Property ComponentType As Type
[C#]
public Type ComponentType {abstract get;}
[C++]
public: __property virtual Type* get_ComponentType() = 0;
[JScript]
public abstract function get ComponentType() : Type;

Property Value

A Type that represents the type of component this property is bound to.

Remarks

Typically, this property is implemented through reflection.

See Also

PropertyDescriptor Class | PropertyDescriptor Members | System.ComponentModel Namespace


PropertyDescriptor.Converter

Gets the type converter for this property.

[Visual Basic]
Overridable Public ReadOnly Property Converter As TypeConverter
[C#]
public TypeConverter Converter {virtual get;}
[C++]
public: __property virtual TypeConverter* get_Converter();
[JScript]
public function get Converter() : TypeConverter;

Property Value

A TypeConverter that is used to convert the Type of this property.

See Also

PropertyDescriptor Class | PropertyDescriptor Members | System.ComponentModel Namespace | TypeConverter


PropertyDescriptor.IsLocalizable

Gets a value indicating whether this property should be localized, as specified in the LocalizableAttribute.

[Visual Basic]
Overridable Public ReadOnly Property IsLocalizable As Boolean
[C#]
public bool IsLocalizable {virtual get;}
[C++]
public: __property virtual bool get_IsLocalizable();
[JScript]
public function get IsLocalizable() : Boolean;

Property Value

true if the member is marked with Localizable(true) attribute; otherwise, false.

Remarks

When a property is marked with Localizable(true) attribute, its values are saved in a resource file.

See Also

PropertyDescriptor Class | PropertyDescriptor Members | System.ComponentModel Namespace | LocalizableAttribute


PropertyDescriptor.IsReadOnly

When overridden in a derived class, gets a value indicating whether this property is read-only.

[Visual Basic]
MustOverride Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {abstract get;}
[C++]
public: __property virtual bool get_IsReadOnly() = 0;
[JScript]
public abstract function get IsReadOnly() : Boolean;

Property Value

true if the property is read-only; false if the property is read/write.

See Also

PropertyDescriptor Class | PropertyDescriptor Members | System.ComponentModel Namespace | ReadOnlyAttribute


PropertyDescriptor.PersistableSupport

Gets a value indicating whether this property should be persisted as specified in the PersistableAttribute.

[Visual Basic]
Public ReadOnly Property PersistableSupport As PersistableSupport
[C#]
public PersistableSupport PersistableSupport {get;}
[C++]
public: __property PersistableSupport get_PersistableSupport();
[JScript]
public function get PersistableSupport() : PersistableSupport;

Property Value

One of the PersistableSupport enumeration values that specifies whether this property should be persisted.

See Also

PropertyDescriptor Class | PropertyDescriptor Members | System.ComponentModel Namespace | PersistableSupport | PersistableAttribute


PropertyDescriptor.PropertyType

When overridden in a derived class, gets the type of the property.

[Visual Basic]
MustOverride Public ReadOnly Property PropertyType As Type
[C#]
public Type PropertyType {abstract get;}
[C++]
public: __property virtual Type* get_PropertyType() = 0;
[JScript]
public abstract function get PropertyType() : Type;

Property Value

A Type that represents the type of the property.

Remarks

Typically, this property is implemented through reflection.

See Also

PropertyDescriptor Class | PropertyDescriptor Members | System.ComponentModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PropertyDescriptor Methods

The methods of the PropertyDescriptor class are listed below. For a complete list of PropertyDescriptor class members, see the PropertyDescriptor Members topic.

Public:

CanResetValue | When overridden in a derived class, indicates whether resetting the component will change the value of the component.
Equals | Compares this to another PropertyDescriptor to see if they are equivalent.
GetDesignTimeOnly (inherited from MemberDescriptor) | Determines whether this member should be set only at design time as specified in the DesignOnlyAttribute.
GetDisplayName (inherited from MemberDescriptor) | Gets the name that can be displayed in a window like a property browser.
GetEditor | Gets an editor of the specified type.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHelpTopic (inherited from MemberDescriptor) | Gets the name of the Help topic specified in the HelpAttribute.
GetHelpURL (inherited from MemberDescriptor) | Gets the URL for the Help file specified in the HelpAttribute.
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | When overridden in a derived class, gets the current value of the property on a component.
ResetValue | When overridden in a derived class, resets the value for this property of the component.
SetValue | When overridden in a derived class, sets the value of the component to a different value.
ShouldPersistValue | When overridden in a derived class, indicates whether the value of this property needs to be persisted.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

CreateAttributeCollection (inherited from MemberDescriptor) | Creates a collection of attributes using the array of attributes that you passed to the constructor.
CreateInstance | Creates an instance of the specified type.
FillAttributes (inherited from MemberDescriptor) | In an inheriting class, adds the attributes of the inheriting class to the specified list of attributes in the parent class.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyDescriptor Class | System.ComponentModel Namespace


PropertyDescriptor.CanResetValue

When overridden in a derived class, indicates whether resetting the component will change the value of the component.

[Visual Basic]
MustOverride Public Function CanResetValue( _
   ByVal component As Object _
) As Boolean
[C#]
public abstract bool CanResetValue(
   object component
);
[C++]
public: virtual bool CanResetValue(
   Object* component
) = 0;
[JScript]
public abstract function CanResetValue(
   component : Object
) : Boolean;

Parameters

component
The component to test for reset capability.

Return Value

true if resetting the component will change the value of the component; otherwise, false.

Remarks

Typically, this method is implemented through reflection.

Notes to Inheritors: When overridden in a derived class, this method looks for a DefaultValueAttribute. If it finds one, it compares the value of the attribute with the property's current value. It will return true when the default value does not match the property's current value. If this method cannot find a DefaultValueAttribute, it looks for a ShouldPersist XXX method. If it finds a ShouldPersist XXX method, it returns what ShouldPersist XXX returns. If this method cannot find a ShouldPersist XXX method, it looks for a Reset XXX method. If it finds a Reset XXX method, it returns true. If this method cannot find a DefaultValueAttribute, a ShouldPersist XXX method, or a Reset XXX method, then it returns false.

See Also

PropertyDescriptor Class | PropertyDescriptor Members | System.ComponentModel Namespace | PropertyDescriptor


PropertyDescriptor.CreateInstance

Creates an instance of the specified type.

[Visual Basic]
Protected Function CreateInstance( _
   ByVal type As Type _
) As Object
[C#]
protected object CreateInstance(
   Type type
);
[C++]
protected: Object* CreateInstance(
   Type* type
);
[JScript]
protected function CreateInstance(
   type : Type
) : Object;

Parameters

type
A Type that represents the type to create.

Return Value

A new instance of the type.

Remarks

CreateInstance looks for a constructor that takes the specified type. If it finds a constructor, the type of the property is passed in.

This method is used by converters and editors to create versions of a component. It allows a single component to be reused for more than one type.

See Also

PropertyDescriptor Class | PropertyDescriptor Members | System.ComponentModel Namespace


PropertyDescriptor.Equals

Compares this to another PropertyDescriptor to see if they are equivalent.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The you want to compare to this PropertyDescriptor.

Return Value

true if equivalent; otherwise, false.

See Also

PropertyDescriptor Class | PropertyDescriptor Members | System.ComponentModel Namespace


PropertyDescriptor.GetEditor

Gets an editor of the specified type.

[Visual Basic]
Overridable Public Function GetEditor( _
   ByVal editorBaseType As Type _
) As Object
[C#]
public virtual object GetEditor(
   Type editorBaseType
);
[C++]
public: virtual Object* GetEditor(
   Type* editorBaseType
);
[JScript]
public function GetEditor(
   editorBaseType : Type
) : Object;

Parameters

editorBaseType
The base type of editor, which is used to differentiate between multiple editors that a property may support.

Return Value

An instance of the requested editor type, or a null reference (in Visual Basic Nothing) if an editor could not be found.

See Also

PropertyDescriptor Class | PropertyDescriptor Members | System.ComponentModel Namespace


PropertyDescriptor.GetValue

When overridden in a derived class, gets the current value of the property on a component.

[Visual Basic]
MustOverride Public Function GetValue( _
   ByVal component As Object _
) As Object
[C#]
public abstract object GetValue(
   object component
);
[C++]
public: virtual Object* GetValue(
   Object* component
) = 0;
[JScript]
public abstract function GetValue(
   component : Object
) : Object;

Parameters

component
The component with the property whose value will be retrieved.

Return Value

The value of a property for a given component.

Remarks

Typically, this method is implemented through reflection.

Notes to Inheritors: When you override this method, it should get the current value of the property by invoking the appropriate Get XXX method. An exception in the Get XXX method should pass through.

See Also

PropertyDescriptor Class | PropertyDescriptor Members | System.ComponentModel Namespace


PropertyDescriptor.ResetValue

When overridden in a derived class, resets the value for this property of the component.

[Visual Basic]
MustOverride Public Sub ResetValue( _
   ByVal component As Object _
)
[C#]
public abstract void ResetValue(
   object component
);
[C++]
public: virtual void ResetValue(
   Object* component
) = 0;
[JScript]
public abstract function ResetValue(
   component : Object
);

Parameters

component
The component with the property whose value will be reset.

Remarks

Typically, this method is implemented through reflection.

Notes to Inheritors: When overridden in a derived class, this method looks for a DefaultValueAttribute. If it finds one, it sets the value of the property to this. If this method cannot find a DefaultValueAttribute, it looks for a Reset XXX method. If it finds a Reset XXX method, it invokes it. If this method cannot find a DefaultValueAttribute or a Reset XXX method, then it does not perform an operation.

See Also

PropertyDescriptor Class | PropertyDescriptor Members | System.ComponentModel Namespace | PropertyDescriptor


PropertyDescriptor.SetValue

When overridden in a derived class, sets the value of the component to a different value.

[Visual Basic]
MustOverride Public Sub SetValue( _
   ByVal component As Object, _
   ByVal value As Object _
)
[C#]
public abstract void SetValue(
   object component,
   object value
);
[C++]
public: virtual void SetValue(
   Object* component,
   Object* value
) = 0;
[JScript]
public abstract function SetValue(
   component : Object,
   value : Object
);

Parameters

component
The component with the property whose value will be set.
value
The new value.

Remarks

Typically, this method is implemented through reflection.

Notes to Inheritors: When you override this method, it should set the value of the property by invoking the appropriate Set XXX method of the component. If the value specified is invalid, the component should throw an exception, which will be passed up. The component designer should design the property so that a Set XXX method following a Set XXX method will return the value passed in when the Set XXX method does not throw an exception.

See Also

PropertyDescriptor Class | PropertyDescriptor Members | System.ComponentModel Namespace | PropertyDescriptor


PropertyDescriptor.ShouldPersistValue

When overridden in a derived class, indicates whether the value of this property needs to be persisted.

[Visual Basic]
MustOverride Public Function ShouldPersistValue( _
   ByVal component As Object _
) As Boolean
[C#]
public abstract bool ShouldPersistValue(
   object component
);
[C++]
public: virtual bool ShouldPersistValue(
   Object* component
) = 0;
[JScript]
public abstract function ShouldPersistValue(
   component : Object
) : Boolean;

Parameters

component
The component with the property will be examined for persistance.

Return Value

true when the property should be persisted; otherwise, false.

Remarks

Typically, this method is implemented through reflection.

Notes to Inheritors: When overridden in a derived class, this method returns true if the current value of the property is different than its default value. It looks for a default value by first looking for a DefaultValueAttribute. If the method finds this attribute, it compares the value of the attribute with the property's current value. If this method cannot find a DefaultValueAttribute, it looks for a ShouldPersist XXX method. If this method finds a ShouldPersist XXX method, it invokes it. If this method cannot find a DefaultValueAttribute or a ShouldPersist XXX method, it cannot create optimizations and it returns true.

See Also

PropertyDescriptor Class | PropertyDescriptor Members | System.ComponentModel Namespace


PropertyDescriptorCollection Class

Represents a collection of properties.

Object
PropertyDescriptorCollection

[Visual Basic]
Public Class PropertyDescriptorCollection
   Implements ICollection, IEnumerable, IList
[C#]
public class PropertyDescriptorCollection : ICollection,
   IEnumerable, IList
[C++]
public __gc class PropertyDescriptorCollection : public
   ICollection, IEnumerable, IList
[JScript]
public class PropertyDescriptorCollection implements ICollection,
   IEnumerable, IList

Remarks

PropertyDescriptorCollection is read-only; it does not implement methods that add or remove properties. You must inherit from this class to implement these methods.

Using the properties available in the EventDescriptorCollection class, you can query the collection about its contents. Use the Count property to determine the number of elements in the collection. Use the Item property (PropertyDescriptorCollection indexer) to get a specific property by index number or by name.

In addition to properties, you can use the Find method to get a description of the event with the specified name from the collection.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

Example [Visual Basic]

The following example prints all the events on a button in a text box. It assumes that Button1 has been instantiated on a form.

[Visual Basic]

Private Sub MyPropertyCollection()
   ' Create a new collection and assign it the properties for Button1.
   Dim properties As PropertyDescriptorCollection
   properties = TypeDescriptor.GetProperties(Button1)

   ' Use myProperty to print the name of each property.
   Dim myProperty As PropertyDescriptor
   For Each myProperty In properties
      TextBox1.Text &= " " & myProperty.Name
   Next
End Sub

See Also

PropertyDescriptorCollection Members | System.ComponentModel Namespace | PropertyDescriptor | TypeDescriptor


PropertyDescriptorCollection Members

Public:

Constructor

PropertyDescriptorCollection Constructor Initializes a new instance of the PropertyDescriptorCollection class.

Properties

All | Gets an array of descriptions of properties.
Count | Gets the number of property descriptors in the collection.
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the PropertyDescriptorCollection class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Find | Gets the description of the property with the specified name.
GetEnumerator | Gets an enumerator for this PropertyDescriptorCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyDescriptorCollection Class | System.ComponentModel Namespace


PropertyDescriptorCollection Constructor

Initializes a new instance of the PropertyDescriptorCollection class.

[Visual Basic]
Public Sub New( _
   ByVal properties() As PropertyDescriptor _
)
[C#]
public PropertyDescriptorCollection(
   PropertyDescriptor[] properties
);
[C++]
public: PropertyDescriptorCollection(
   PropertyDescriptor* properties[]
);
[JScript]
public function PropertyDescriptorCollection(
   properties : PropertyDescriptor[]
);

Parameters

properties
An array of type PropertyDescriptor that provides the properties for this collection.

Example [Visual Basic]

The following example creates a new PropertyDescriptorCollection using the events on Button1. It assumes that Button1 has been instantiated on a form.

[Visual Basic]

Dim properties As PropertyDescriptorCollection
properties = TypeDescriptor.GetProperties(Button1)

See Also

PropertyDescriptorCollection Class | PropertyDescriptorCollection Members | System.ComponentModel Namespace | PropertyDescriptor | TypeDescriptor


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PropertyDescriptorCollection Properties

The properties of the PropertyDescriptorCollection class are listed below. For a complete list of PropertyDescriptorCollection class members, see the PropertyDescriptorCollection Members topic.

Public:

All | Gets an array of descriptions of properties.
Count | Gets the number of property descriptors in the collection.
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the PropertyDescriptorCollection class.

See Also

PropertyDescriptorCollection Class | System.ComponentModel Namespace


PropertyDescriptorCollection.All

Gets an array of descriptions of properties.

[Visual Basic]
Overridable Public Property All As PropertyDescriptor ()
[C#]
public PropertyDescriptor[] All {virtual get; virtual set;}
[C++]
public: __property virtual PropertyDescriptor* get_All();
public: __property virtual void set_All(PropertyDescriptor*[]);
[JScript]
public function get All() : PropertyDescriptor[];
public function set All(PropertyDescriptor[]);

Property Value

An array of type PropertyDescriptor with descriptions of the properties.

Exceptions

Exception Type | Condition
NotSupportedException | Setting the property.

Example [Visual Basic]

The following example shows how to get an array of type PropertyDescriptor using the All property. It assumes that Button1 has been instantiated on a form.

[Visual Basic]

Private Sub GetAllProperties()
   ' Create a new collection and assign it the properties for Button1.
   Dim properties As PropertyDescriptorCollection
   properties = TypeDescriptor.GetProperties(Button1)

   ' Get all the PropertyDescriptors.
   Dim pArray() As PropertyDescriptor
   pArray = properties.All

   ' Print all the property names in a text box.
   Dim i As Integer
   For i = 0 To pArray.Length - 1
      TextBox1.Text &= " " & pArray(i).Name
   Next
End Sub

See Also

PropertyDescriptorCollection Class | PropertyDescriptorCollection Members | System.ComponentModel Namespace | PropertyDescriptor | TypeDescriptor


PropertyDescriptorCollection.Count

Gets the number of property descriptors in the collection.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

Property Value

The number of property descriptors in the collection.

Remarks

The Count property can be used to set the limits of a loop that iterates through a collection of objects. If the collection is zero-based, be sure to use "Count- 1" as the upper bound of the loop.

Example [Visual Basic]

The following example uses the Count property to print the number of properties on Button1. It assumes that Button1 has been instantianted on a form.

[Visual Basic]

Private Sub GetCount()
   Dim properties As PropertyDescriptorCollection
   properties = TypeDescriptor.GetProperties(Button1)

   ' Print the number of properties on Button 1 in a text box.
   TextBox1.Text = properties.Count.ToString
End Sub

See Also

PropertyDescriptorCollection Class | PropertyDescriptorCollection Members | System.ComponentModel Namespace | PropertyDescriptor | TypeDescriptor


PropertyDescriptorCollection.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the PropertyDescriptorCollection class.

Overload List

Gets the property with the specified name.

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(String) As PropertyDescriptor
[C#] public PropertyDescriptor this[String] {virtual get;}
[C++] public: __property virtual PropertyDescriptor* get_Item(String*);
[JScript] PropertyDescriptorCollection.Item (String)

Gets the property with the specified index number.

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(Integer) As PropertyDescriptor
[C#] public PropertyDescriptor this[int] {virtual get;}
[C++] public: __property virtual PropertyDescriptor* get_Item(int);
[JScript] PropertyDescriptorCollection.Item (int)

Example [Visual Basic]

The following example uses the Item property (PropertyDescriptorCollection indexer) to print the name of the PropertyDescriptor specified by the index number in a text box. Since the index number is zero-based, this example prints the name of the second PropertyDescriptor. It assumes Button1 has been instantiated on a form.

Note This example shows how to use one of the overloaded versions of the Item property (PropertyDescriptorCollection indexer). For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub PrintIndexItem()
   Dim properties As PropertyDescriptorCollection
   properties = TypeDescriptor.GetProperties(Button1)

   ' Print the second property's name.
   TextBox1.Text = properties.Item(1).Name
End Sub

See Also

PropertyDescriptorCollection Class | PropertyDescriptorCollection Members | System.ComponentModel Namespace


PropertyDescriptorCollection.Item (String)

Gets the property with the specified name.

[C#] In C#, this member is the indexer for the PropertyDescriptorCollection class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal name As String _
) As PropertyDescriptor
[C#]
public PropertyDescriptor this[
   string name
] {virtual get;}
[C++]
public: __property virtual PropertyDescriptor* get_Item(
   String* name
);
[JScript]
returnValue = PropertyDescriptorCollectionObject.Item(name);
-or-
returnValue = PropertyDescriptorCollectionObject(name);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
The name of the PropertyDescriptor to get from the collection.

Parameters [Visual Basic, C#, C++]

name
The name of the PropertyDescriptor to get from the collection.

Property Value

The PropertyDescriptor with the specified name, or a null reference (in Visual Basic Nothing) if the property does not exist.

Remarks

Item property (PropertyDescriptorCollection indexer)is case-sensitive when searching for names. That is, if two properties exist with the names "Pname" and "pname," Item property (PropertyDescriptorCollection indexer)will find the specific property you name.

Example [Visual Basic]

The following example uses the Item property (EventDescriptorCollection indexer) to print the type of component for the EventDescriptor specified by the index. It assumes that Button1 has been instantiated on a form.

[Visual Basic]

Private Sub PrintIndexItem2()
   Dim properties As PropertyDescriptorCollection
   properties = TypeDescriptor.GetProperties(Button1)

   ' Set a PropertyDescriptor to the specific event.
   Dim myProperty As PropertyDescriptor
   myProperty = properties.Item("Opacity")

   ' Print the type of component for the property.
   TextBox1.Text = myProperty.ComponentType.ToString
End Sub

See Also

PropertyDescriptorCollection Class | PropertyDescriptorCollection Members | System.ComponentModel Namespace | PropertyDescriptorCollection.Item Overload List | PropertyDescriptor | TypeDescriptor


PropertyDescriptorCollection.Item (Int32)

Gets the property with the specified index number.

[C#] In C#, this member is the indexer for the PropertyDescriptorCollection class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal index As Integer _
) As PropertyDescriptor
[C#]
public PropertyDescriptor this[
   int index
] {virtual get;}
[C++]
public: __property virtual PropertyDescriptor* get_Item(
   int index
);
[JScript]
returnValue = PropertyDescriptorCollectionObject.Item(index);
-or-
returnValue = PropertyDescriptorCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
The zero-based index number of the PropertyDescriptor to get from the collection.

Parameters [Visual Basic, C#, C++]

index
The zero-based index number of the PropertyDescriptor to get from the collection.

Property Value

The PropertyDescriptor with the specified index number.

Remarks

The index number is zero-based. Therefore, you must subtract one from the numerical position of a particular PropertyDescriptor to access that PropertyDescriptor. For example, to get the third PropertyDescriptor, you need to specify Item property (PropertyDescriptorCollection indexer)(2).

Example [Visual Basic]

The following example uses the Item property (PropertyDescriptorCollection indexer) to print the name of the PropertyDescriptor specified by the index number in a text box. Since the index number is zero-based, this example prints the name of the second PropertyDescriptor. It assumes Button1 has been instantiated on a form.

[Visual Basic]

Private Sub PrintIndexItem()
   Dim properties As PropertyDescriptorCollection
   properties = TypeDescriptor.GetProperties(Button1)

   ' Print the second property's name.
   TextBox1.Text = properties.Item(1).Name
End Sub

See Also

PropertyDescriptorCollection Class | PropertyDescriptorCollection Members | System.ComponentModel Namespace | PropertyDescriptorCollection.Item Overload List | PropertyDescriptor | TypeDescriptor


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PropertyDescriptorCollection Methods

The methods of the PropertyDescriptorCollection class are listed below. For a complete list of PropertyDescriptorCollection class members, see the PropertyDescriptorCollection Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Find | Gets the description of the property with the specified name.
GetEnumerator | Gets an enumerator for this PropertyDescriptorCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyDescriptorCollection Class | System.ComponentModel Namespace


PropertyDescriptorCollection.Find

Gets the description of the property with the specified name.

[Visual Basic]
Overridable Public Function Find( _
   ByVal name As String, _
   ByVal ignoreCase As Boolean _
) As PropertyDescriptor
[C#]
public virtual PropertyDescriptor Find(
   string name,
   bool ignoreCase
);
[C++]
public: virtual PropertyDescriptor* Find(
   String* name,
   bool ignoreCase
);
[JScript]
public function Find(
   name : String,
   ignoreCase : Boolean
) : PropertyDescriptor;

Parameters

name
The name of the property to get from the collection.
ignoreCase
true if you want to ignore the case of the event; otherwise, false.

Return Value

A PropertyDescriptor with the specified name, or a null reference (in Visual Basic Nothing) if the property does not exist.

Example [Visual Basic]

The following example finds a specific PropertyDescriptor. It prints the type of component for this PropertyDescriptor in a text box. It assumes that Button1 has been instantiated on a form.

[Visual Basic]

Private Sub FindProperty()
   Dim properties As PropertyDescriptorCollection
   properties = TypeDescriptor.GetProperties(Button1)

   ' Set a PropertyDescriptor to the specific event.
   Dim myProperty As PropertyDescriptor
   myProperty = properties.Find("Opacity", False)

   ' Print the type of component for the property.
   TextBox1.Text = myProperty.ComponentType.ToString
End Sub

See Also

PropertyDescriptorCollection Class | PropertyDescriptorCollection Members | System.ComponentModel Namespace | PropertyDescriptor | TypeDescriptor


PropertyDescriptorCollection.GetEnumerator

Gets an enumerator for this PropertyDescriptorCollection.

[Visual Basic]
Overridable Public Function GetEnumerator() As IEnumerator
[C#]
public virtual IEnumerator GetEnumerator();
[C++]
public: virtual IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

Return Value

An enumerator of type IEnumerator.

Example [Visual Basic]

The following example gets an enumerator for the events on Button1. It uses the enumerator to print the names of the events in the collection. It assumes that Button1 has been instantiated on a form.

[Visual Basic]

Private Sub MyEnumerator()
   Dim properties As PropertyDescriptorCollection
   properties = TypeDescriptor.GetProperties(Button1)

   ' Create an enumerator
   Dim ie As IEnumerator
   ie = properties.GetEnumerator

   ' Print the name of each property in the collecction.
   Dim myProperty As Object
   Do While ie.MoveNext = True
      myProperty = ie.Current
      TextBox1.Text &= " " & myProperty.ToString
   Loop
End Sub

See Also

PropertyDescriptorCollection Class | PropertyDescriptorCollection Members | System.ComponentModel Namespace | PropertyDescriptor | TypeDescriptor | IEnumerator


ProvidePropertyAttribute Class

Specifies which methods are extender properties.

Object
Attribute
MemberAttribute
ProvidePropertyAttribute

[Visual Basic]
Public Class ProvidePropertyAttribute
   Inherits MemberAttribute
[C#]
public class ProvidePropertyAttribute : MemberAttribute
[C++]
public __gc class ProvidePropertyAttribute : public MemberAttribute
[JScript]
public class ProvidePropertyAttribute extends MemberAttribute

Remarks

For more information, see TBD and TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | MemberAttribute


ReadOnlyAttribute Class

Specifies that a property is read-only.

Object
Attribute
MemberAttribute
ReadOnlyAttribute

[Visual Basic]
Public Class ReadOnlyAttribute
   Inherits MemberAttribute
[C#]
public class ReadOnlyAttribute : MemberAttribute
[C++]
public __gc class ReadOnlyAttribute : public MemberAttribute
[JScript]
public class ReadOnlyAttribute extends MemberAttribute

Remarks

Members that are marked with ReadOnly(true) or that do not have a Set method cannot be changed. Members that do not have this attribute or that are marked with ReadOnly(false) are read-write, and they may be changed. The default is No.

Note When you mark a property with ReadOnly(true), the value of this attribute is set to the constant member ReadOnlyAttribute.Yes. For a property marked with ReadOnly(false), the value is ReadOnlyAttribute.No. Therefore, when you want to check the value of this attribute in your code, you must specify the attribute as ReadOnlyAttribute.Yes or ReadOnlyAttribute.No.

For more information, see TBD and TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | MemberAttribute | PropertyDescriptor


RecommendedAsConfigurableAttribute Class

Specifies that the property could be used as an application setting.

Object
Attribute
MemberAttribute
RecommendedAsConfigurableAttribute

[Visual Basic]
Public Class RecommendedAsConfigurableAttribute
   Inherits MemberAttribute
[C#]
public class RecommendedAsConfigurableAttribute : MemberAttribute
[C++]
public __gc class RecommendedAsConfigurableAttribute : public
   MemberAttribute
[JScript]
public class RecommendedAsConfigurableAttribute extends
   MemberAttribute

Remarks

A property browser automatically includes properties that are marked with RecommendedAsConfigurable(true). A property that has no recommended setting or that is marked with RecommendedAsConfigurable(false) is not shown in a property browser and it is an unlikely candidate for being an application setting. The default is false.

You can bind a property that does not have a RecommendedAsConfigurableAttribute to a setting in Visual Studio by clicking the ellipsis button (...) under Settings in the Properties Window and selecting the appropriate property from the list.

Note When you mark a property with RecommendedAsConfigurable(true), the value of this attribute is set to the constant member RecommendedAsConfigurableAttribute.Yes. For a property marked with RecommendedAsConfigurable(false), the value is RecommendedAsConfigurableAttribute.No. Therefore, when you want to check the value of this attribute in your code, you must specify the attribute as RecommendedAsConfigurableAttribute.Yes or RecommendedAsConfigurableAttribute.No.

For more information, see TBD and TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | MemberAttribute


ReferenceConverter Class

Provides a type converter to convert object references to and from various other representations.

Object
TypeConverter
ReferenceConverter

[Visual Basic]
Public Class ReferenceConverter
   Inherits TypeConverter
[C#]
public class ReferenceConverter : TypeConverter
[C++]
public __gc class ReferenceConverter : public TypeConverter
[JScript]
public class ReferenceConverter extends TypeConverter

Remarks

It is typically used within the context of sited components or a design environment. Without a component site or a usable ITypeDescriptorContext this converter is of little use.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace


RefreshEventArgs Class

Provides data for the Refresh event.

Object
EventArgs
RefreshEventArgs

[Visual Basic]
Public Class RefreshEventArgs
   Inherits EventArgs
[C#]
public class RefreshEventArgs : EventArgs
[C++]
public __gc class RefreshEventArgs : public EventArgs
[JScript]
public class RefreshEventArgs extends EventArgs

Remarks

Typically, component information does not change for the life of a process. During design time, however, you can change the component's properties, or events. As a result, the component's information in TypeDescriptor is out of date, and a Refresh event is raised. A Refresh event is also raised when a Type is changed during design time.

A RefreshEventArgs object specifies the data associated with the Refresh event, that is, the component and the type of component that changed.

The RefreshEventArgs class provides ComponentChanged and TypeChanged properties to get the component or type that raised the event.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

RefreshEventArgs Members | System.ComponentModel Namespace | RefreshEventHandler | TypeDescriptor | Refresh


RefreshEventArgs Members

Public:

Constructor

RefreshEventArgs Constructor Overloaded. Initializes a new instance of the RefreshEventArgs class.

Properties

ComponentChanged | Gets the component that has changed its properties, events, or extenders.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
TypeChanged | Gets the type that has changed its properties, or events.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RefreshEventArgs Class | System.ComponentModel Namespace


RefreshEventArgs Constructor

Initializes a new instance of the RefreshEventArgs class.

Overload List

Initializes a new instance of the RefreshEventArgs class with the component that has changed.

[Visual Basic] Overloads Public Sub New(Object)
[C#] public RefreshEventArgs(Object);
[C++] public: RefreshEventArgs(Object*);
[JScript] public function RefreshEventArgs(Object);

Initializes a new instance of the RefreshEventArgs class with the type of component that has changed.

[Visual Basic] Overloads Public Sub New(Type)
[C#] public RefreshEventArgs(Type);
[C++] public: RefreshEventArgs(Type*);
[JScript] public function RefreshEventArgs(Type);

See Also

RefreshEventArgs Class | RefreshEventArgs Members | System.ComponentModel Namespace


RefreshEventArgs Constructor (Object)

Initializes a new instance of the RefreshEventArgs class with the component that has changed.

[Visual Basic]
Overloads Public Sub New( _
   ByVal componentChanged As Object _
)
[C#]
public RefreshEventArgs(
   object componentChanged
);
[C++]
public: RefreshEventArgs(
   Object* componentChanged
);
[JScript]
public function RefreshEventArgs(
   componentChanged : Object
);

Parameters

componentChanged
The component that has changed.

See Also

RefreshEventArgs Class | RefreshEventArgs Members | System.ComponentModel Namespace | RefreshEventArgs Constructor Overload List | RefreshEventHandler | TypeDescriptor | Refresh


RefreshEventArgs Constructor (Type)

Initializes a new instance of the RefreshEventArgs class with the type of component that has changed.

[Visual Basic]
Overloads Public Sub New( _
   ByVal typeChanged As Type _
)
[C#]
public RefreshEventArgs(
   Type typeChanged
);
[C++]
public: RefreshEventArgs(
   Type* typeChanged
);
[JScript]
public function RefreshEventArgs(
   typeChanged : Type
);

Parameters

typeChanged
The type that has changed.

See Also

RefreshEventArgs Class | RefreshEventArgs Members | System.ComponentModel Namespace | RefreshEventArgs Constructor Overload List | RefreshEventHandler | TypeDescriptor | Refresh


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RefreshEventArgs Properties

The properties of the RefreshEventArgs class are listed below. For a complete list of RefreshEventArgs class members, see the RefreshEventArgs Members topic.

Public:

ComponentChanged | Gets the component that has changed its properties, events, or extenders.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
TypeChanged | Gets the type that has changed its properties, or events.

See Also

RefreshEventArgs Class | System.ComponentModel Namespace


RefreshEventArgs.ComponentChanged

Gets the component that has changed its properties, events, or extenders.

[Visual Basic]
Public ReadOnly Property ComponentChanged As Object
[C#]
public object ComponentChanged {get;}
[C++]
public: __property Object* get_ComponentChanged();
[JScript]
public function get ComponentChanged() : Object;

Property Value

The component that has changed its properties, events, or extenders; or a null reference (in Visual Basic Nothing) if all components of the same type have changed.

See Also

RefreshEventArgs Class | RefreshEventArgs Members | System.ComponentModel Namespace


RefreshEventArgs.TypeChanged

Gets the type that has changed its properties, or events.

[Visual Basic]
Public ReadOnly Property TypeChanged As Type
[C#]
public Type TypeChanged {get;}
[C++]
public: __property Type* get_TypeChanged();
[JScript]
public function get TypeChanged() : Type;

Property Value

The type that has changed its properties, or events.

See Also

RefreshEventArgs Class | RefreshEventArgs Members | System.ComponentModel Namespace


RefreshEventHandler Delegate

Represents the method that will handle the Refresh event raised when a Type or component is changed during design time.

[Visual Basic]
Public Delegate Sub RefreshEventHandler( _
   ByVal e As RefreshEventArgs _
)
[C#]
public delegate void RefreshEventHandler(
   RefreshEventArgs e
);
[C++]
public __gc __delegate void RefreshEventHandler(
   RefreshEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the RefreshEventHandler delegate declaration.

e
A RefreshEventArgs that contains the component or Type that has changed.

Remarks

When you create a RefreshEventHandler delegate, you identify the method that will handle the event. To associate the event with your event-handling method, add an instance of the delegate to the event. The event-handler method is called whenever the event occurs, unless you remove the delegate. For more information about event handler delegates, see TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | RefreshEventArgs | TypeDescriptor | Refresh


RunInstallerAttribute Class

Specifies whether an installer should be invoked during installation of an assembly.

Object
Attribute
MemberAttribute
RunInstallerAttribute

[Visual Basic]
Public Class RunInstallerAttribute
   Inherits MemberAttribute
[C#]
public class RunInstallerAttribute : MemberAttribute
[C++]
public __gc class RunInstallerAttribute : public MemberAttribute
[JScript]
public class RunInstallerAttribute extends MemberAttribute

Remarks

If a class that inherits from Installer is marked with with RunInstaller(true), Visual Studio 7's Custom Action Installer or the installutil.exe will be invoked when the assembly is installed. Members marked with RunInstaller(false) will not invoke an installer. The default is false.

Note When you mark a property with RunInstaller(true), the value of this attribute is set to the constant member RunInstallerAttribute.Yes. For a property marked with RunInstaller(false), the value is RunInstallerAttribute.No. Therefore, when you want to check the value of this attribute in your code, you must specify the attribute as RunInstallerAttribute.Yes or RunInstallerAttribute.No.

For more information, see TBD and TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | MemberAttribute | System.Configuration.Install.Installer


ServerExplorerBrowsableAttribute Class

Specifies whether a property or event can be modified at design time in the server explorer.

Object
Attribute
MemberAttribute
ServerExplorerBrowsableAttribute

[Visual Basic]
Public Class ServerExplorerBrowsableAttribute
   Inherits MemberAttribute
[C#]
public class ServerExplorerBrowsableAttribute : MemberAttribute
[C++]
public __gc class ServerExplorerBrowsableAttribute : public
   MemberAttribute
[JScript]
public class ServerExplorerBrowsableAttribute extends
   MemberAttribute

Remarks

A visual designer typically displays in the server explorer those members that either have no browsable attribute or are marked with ServerExplorerBrowsable(true). Members that are marked with ServerExplorerBrowsable(false) are not appropriate for design-time editing. The default is True.

For more information, see TBD and TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | MemberAttribute | PropertyDescriptor | EventDescriptor


ServerExplorerReadOnlyAttribute Class

Specifies that a property is read-only in the server explorer.

Object
Attribute
MemberAttribute
ServerExplorerReadOnlyAttribute

[Visual Basic]
Public Class ServerExplorerReadOnlyAttribute
   Inherits MemberAttribute
[C#]
public class ServerExplorerReadOnlyAttribute : MemberAttribute
[C++]
public __gc class ServerExplorerReadOnlyAttribute : public
   MemberAttribute
[JScript]
public class ServerExplorerReadOnlyAttribute extends
   MemberAttribute

Remarks

Members that are marked with ServerExplorerReadOnly(true) or that do not have a Set method cannot be changed in the server explorer. Members that do not have this attribute or that are marked with ServerExplorerReadOnly(false) are read-write, and they may be changed. The default is false.

Note When you mark a property with ServerExplorerReadOnly(true), the value of this attribute is set to the constant member ServerExplorerReadOnlyAttribute.Yes. For a property marked with ServerExplorerReadOnly(false), the value is ServerExplorerReadOnlyAttribute.No. Therefore, when you want to check the value of this attribute in your code, you must specify the attribute as ServerExplorerReadOnlyAttribute.Yes or ServerExplorerReadOnlyAttribute.No.

For more information, see TBD and TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace | MemberAttribute | PropertyDescriptor


SingleConverter Class

Provides a type converter to convert single objects to and from various other representations.

Object
TypeConverter
SingleConverter

[Visual Basic]
Public Class SingleConverter
   Inherits TypeConverter
[C#]
public class SingleConverter : TypeConverter
[C++]
public __gc class SingleConverter : public TypeConverter
[JScript]
public class SingleConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace


StringConverter Class

Provides a type converter to convert string objects to and from various other representations.

Object
TypeConverter
StringConverter

[Visual Basic]
Public Class StringConverter
   Inherits TypeConverter
[C#]
public class StringConverter : TypeConverter
[C++]
public __gc class StringConverter : public TypeConverter
[JScript]
public class StringConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace


SyntaxCheck Class

[To be supplied.]

Object
SyntaxCheck

[Visual Basic]
Public Class SyntaxCheck
[C#]
public class SyntaxCheck
[C++]
public __gc class SyntaxCheck
[JScript]
public class SyntaxCheck

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

SyntaxCheck Members | System.ComponentModel Namespace


SyntaxCheck Members

Public:

Constructor

SyntaxCheck Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyntaxCheck Class | System.ComponentModel Namespace


SyntaxCheck Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public SyntaxCheck();
[C++]
public: SyntaxCheck();
[JScript]
public function SyntaxCheck();

See Also

SyntaxCheck Class | SyntaxCheck Members | System.ComponentModel Namespace


TimeSpanConverter Class

Provides a type converter to convert TimeSpan objects to and from various other representations.

Object
TypeConverter
TimeSpanConverter

[Visual Basic]
Public Class TimeSpanConverter
   Inherits TypeConverter
[C#]
public class TimeSpanConverter : TypeConverter
[C++]
public __gc class TimeSpanConverter : public TypeConverter
[JScript]
public class TimeSpanConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace


TypeConverter Class

Converts the value of an object into a different data type.

Object
TypeConverter

[Visual Basic]
Public Class TypeConverter
[C#]
public class TypeConverter
[C++]
public __gc class TypeConverter
[JScript]
public class TypeConverter

Remarks

The most common type of value converter is one that converts to and from a text representation.

Notes to Inheritors: You should inherit from TypeConverter to provide your own conversion requirements.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

TypeConverter Members | System.ComponentModel Namespace


TypeConverter Members

Public:

Constructor

TypeConverter Constructor [To be supplied.]

Methods

CanConvertFrom | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter.
CanConvertTo | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type.
ConvertFrom | Overloaded. Converts the given value to the converter's native type.
ConvertFromString | Overloaded. Converts the specified text into an object.
ConvertTo | Overloaded. Converts the given object to another type.
ConvertToString | Overloaded. Converts the specified value to a string representation.
CreateInstance | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo | Overloaded. [To be supplied.]
GetProperties | Overloaded. [To be supplied.]
GetPropertiesSupported | Overloaded. [To be supplied.]
GetStandardValues | Overloaded. [To be supplied.]
GetStandardValuesExclusive | Overloaded. [To be supplied.]
GetStandardValuesSupported | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties | Sorts a collection of properties.

See Also

TypeConverter Class | System.ComponentModel Namespace


TypeConverter Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public TypeConverter();
[C++]
public: TypeConverter();
[JScript]
public function TypeConverter();

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypeConverter Methods

The methods of the TypeConverter class are listed below. For a complete list of TypeConverter class members, see the TypeConverter Members topic.

Public:

CanConvertFrom | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter.
CanConvertTo | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type.
ConvertFrom | Overloaded. Converts the given value to the converter's native type.
ConvertFromString | Overloaded. Converts the specified text into an object.
ConvertTo | Overloaded. Converts the given object to another type.
ConvertToString | Overloaded. Converts the specified value to a string representation.
CreateInstance | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo | Overloaded. [To be supplied.]
GetProperties | Overloaded. [To be supplied.]
GetPropertiesSupported | Overloaded. [To be supplied.]
GetStandardValues | Overloaded. [To be supplied.]
GetStandardValuesExclusive | Overloaded. [To be supplied.]
GetStandardValuesSupported | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties | Sorts a collection of properties.

See Also

TypeConverter Class | System.ComponentModel Namespace


TypeConverter.CanConvertFrom

Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter.

Overload List

Determines if this converter can convert an object in the given source type to the native type of the converter.

[Visual Basic] Overloads Public Function CanConvertFrom(Type) As Boolean
[C#] public bool CanConvertFrom(Type);
[C++] public: bool CanConvertFrom(Type*);
[JScript] public function CanConvertFrom(Type) : Boolean;

Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter using the context.

[Visual Basic] Overloads Overridable Public Function CanConvertFrom(ITypeDescriptorContext, Type) As Boolean
[C#] public virtual bool CanConvertFrom(ITypeDescriptorContext, Type);
[C++] public: virtual bool CanConvertFrom(ITypeDescriptorContext*, Type);
[JScript] public function CanConvertFrom(ITypeDescriptorContext, Type) : Boolean;

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace


TypeConverter.CanConvertFrom (Type)

Determines if this converter can convert an object in the given source type to the native type of the converter.

[Visual Basic]
Overloads Public Function CanConvertFrom( _
   ByVal sourceType As Type _
) As Boolean
[C#]
public bool CanConvertFrom(
   Type sourceType
);
[C++]
public: bool CanConvertFrom(
   Type* sourceType
);
[JScript]
public function CanConvertFrom(
   sourceType : Type
) : Boolean;

Parameters

sourceType
A Type that represents the type you wish to convert from.

Return Value

true if this converter can perform the conversion; otherwise, false.

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.CanConvertFrom Overload List


TypeConverter.CanConvertFrom (ITypeDescriptorContext, Type)

Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter using the context.

[Visual Basic]
Overloads Overridable Public Function CanConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal sourceType As Type _
) As Boolean
[C#]
public virtual bool CanConvertFrom(
   ITypeDescriptorContext context,
   Type sourceType
);
[C++]
public: virtual bool CanConvertFrom(
   ITypeDescriptorContext* context,
   Type* sourceType
);
[JScript]
public function CanConvertFrom(
   context : ITypeDescriptorContext,
   sourceType : Type
) : Boolean;

Parameters

context
An ITypeDescriptorContext that represents a context for the formatter.
sourceType
A Type that represents the type you wish to convert from.

Return Value

true if this converter can perform the conversion; otherwise, false.

Remarks

The context can be used to extract additional information about the environment this converter is being invoked from. This may be a null reference (in Visual Basic Nothing), so you should always check. Also, properties on the context object may also return a null reference (Nothing).

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.CanConvertFrom Overload List | ITypeDescriptorContext


TypeConverter.CanConvertTo

Gets a value indicating whether this converter can convert an object to the given destination type.

Overload List

Gets a value indicating whether this converter can convert an object to the given destination type using the context.

[Visual Basic] Overloads Overridable Public Function CanConvertTo(ITypeDescriptorContext, Type) As Boolean
[C#] public virtual bool CanConvertTo(ITypeDescriptorContext, Type);
[C++] public: virtual bool CanConvertTo(ITypeDescriptorContext*, Type);
[JScript] public function CanConvertTo(ITypeDescriptorContext, Type) : Boolean;

Gets a value indicating whether this converter can convert an object to the given destination type.

[Visual Basic] Overloads Public Function CanConvertTo(Type) As Boolean
[C#] public bool CanConvertTo(Type);
[C++] public: bool CanConvertTo(Type*);
[JScript] public function CanConvertTo(Type) : Boolean;

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace


TypeConverter.CanConvertTo (ITypeDescriptorContext, Type)

Gets a value indicating whether this converter can convert an object to the given destination type using the context.

[Visual Basic]
Overloads Overridable Public Function CanConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal destinationType As Type _
) As Boolean
[C#]
public virtual bool CanConvertTo(
   ITypeDescriptorContext context,
   Type destinationType
);
[C++]
public: virtual bool CanConvertTo(
   ITypeDescriptorContext* context,
   Type* destinationType
);
[JScript]
public function CanConvertTo(
   context : ITypeDescriptorContext,
   destinationType : Type
) : Boolean;

Parameters

context
An ITypeDescriptorContext that represents a context for the formatter.
destinationType
A Type that represents the type you wish to convert to.

Return Value

true if this converter can perform the conversion; otherwise, false.

Remarks

The context can be used to extract additional information about the environment this converter is being invoked from. This may be a null reference (in Visual Basic Nothing), so you should always check. Also, properties on the context object may also return a null reference (Nothing).

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.CanConvertTo Overload List | ITypeDescriptorContext


TypeConverter.CanConvertTo (Type)

Gets a value indicating whether this converter can convert an object to the given destination type.

[Visual Basic]
Overloads Public Function CanConvertTo( _
   ByVal destinationType As Type _
) As Boolean
[C#]
public bool CanConvertTo(
   Type destinationType
);
[C++]
public: bool CanConvertTo(
   Type* destinationType
);
[JScript]
public function CanConvertTo(
   destinationType : Type
) : Boolean;

Parameters

destinationType
A Type that represents the type you wish to convert to.

Return Value

true if this converter can perform the conversion; otherwise, false.

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.CanConvertTo Overload List


TypeConverter.ConvertFrom

Converts the given value to the converter's native type.

Overload List

Converts the given object to the converter's native type.

[Visual Basic] Overloads Overridable Public Function ConvertFrom(ITypeDescriptorContext, Object, Object()) As Object
[C#] public virtual object ConvertFrom(ITypeDescriptorContext, Object, Object[]);
[C++] public: virtual Object* ConvertFrom(ITypeDescriptorContext*, Object, Object[]);
[JScript] public function ConvertFrom(ITypeDescriptorContext, Object, Object[]) : Object;

Converts the given value to the converter's native type.

[Visual Basic] Overloads Public Function ConvertFrom(Object, Object()) As Object
[C#] public object ConvertFrom(Object, Object[]);
[C++] public: Object* ConvertFrom(Object*, Object*[]);
[JScript] public function ConvertFrom(Object, Object[]) : Object;

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace


TypeConverter.ConvertFrom (ITypeDescriptorContext, Object, Object[])

Converts the given object to the converter's native type.

[Visual Basic]
Overloads Overridable Public Function ConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal arguments() As Object _
) As Object
[C#]
public virtual object ConvertFrom(
   ITypeDescriptorContext context,
   object value,
   object[] arguments
);
[C++]
public: virtual Object* ConvertFrom(
   ITypeDescriptorContext* context,
   Object* value,
   Object* arguments[]
);
[JScript]
public function ConvertFrom(
   context : ITypeDescriptorContext,
   value : Object,
   arguments : Object[]
) : Object;

Parameters

context
An ITypeDescriptorContext that represents a context for the formatter.
value
The object to convert.
arguments
An optional array of arguments to use when doing the conversion. The number and content of these arguments is dependent on the implementer of the value formatter.

Return Value

The converted object.

Exceptions

Exception Type | Condition
GetConvertFromException(System.Object) | The conversion could not be performed.

Remarks

The context can be used to extract additional information about the environment this converter is being invoked from. This may be a null reference (in Visual Basic Nothing), so you should always check. Also, properties on the context object may also return a null reference (Nothing).

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.ConvertFrom Overload List | ITypeDescriptorContext


TypeConverter.ConvertFrom (Object, Object[])

Converts the given value to the converter's native type.

[Visual Basic]
Overloads Public Function ConvertFrom( _
   ByVal value As Object, _
   ByVal arguments() As Object _
) As Object
[C#]
public object ConvertFrom(
   object value,
   object[] arguments
);
[C++]
public: Object* ConvertFrom(
   Object* value,
   Object* arguments[]
);
[JScript]
public function ConvertFrom(
   value : Object,
   arguments : Object[]
) : Object;

Parameters

value
The object to convert.
arguments
An optional array of arguments to use when doing the conversion. The number and content of these arguments is dependent on the implementer of the value formatter.

Return Value

The converted object.

Exceptions

Exception Type | Condition
GetConvertFromException(System.Object) | The conversion could not be performed.

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.ConvertFrom Overload List


TypeConverter.ConvertFromString

Converts the specified text into an object.

Overload List

Converts the specified text into an object.

[Visual Basic] Overloads Public Function ConvertFromString(String) As Object
[C#] public object ConvertFromString(String);
[C++] public: Object* ConvertFromString(String*);
[JScript] public function ConvertFromString(String) : Object;

Converts the specified text into an object.

[Visual Basic] Overloads Public Function ConvertFromString(ITypeDescriptorContext, String) As Object
[C#] public object ConvertFromString(ITypeDescriptorContext, String);
[C++] public: Object* ConvertFromString(ITypeDescriptorContext*, String);
[JScript] public function ConvertFromString(ITypeDescriptorContext, String) : Object;

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace


TypeConverter.ConvertFromString (String)

Converts the specified text into an object.

[Visual Basic]
Overloads Public Function ConvertFromString( _
   ByVal text As String _
) As Object
[C#]
public object ConvertFromString(
   string text
);
[C++]
public: Object* ConvertFromString(
   String* text
);
[JScript]
public function ConvertFromString(
   text : String
) : Object;

Parameters

text
The text representation of the object to convert.

Return Value

A new Object with the value of the string.

A new object that the string contents represent.

Exceptions

Exception Type | Condition
GetConvertFromException(System.Object) | The string could not be converted into the appropriate object.

Remarks

An exception will be raised if the string cannot be converted into the appropriate object.

The default implementation always returns null.

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.ConvertFromString Overload List


TypeConverter.ConvertFromString (ITypeDescriptorContext, String)

Converts the specified text into an object.

[Visual Basic]
Overloads Public Function ConvertFromString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal text As String _
) As Object
[C#]
public object ConvertFromString(
   ITypeDescriptorContext context,
   string text
);
[C++]
public: Object* ConvertFromString(
   ITypeDescriptorContext* context,
   String* text
);
[JScript]
public function ConvertFromString(
   context : ITypeDescriptorContext,
   text : String
) : Object;

Parameters

context
An ITypeDescriptorContext that represents a context for the formatter.
text
The text representation of the object to convert.

Return Value

A new Object with the value of the string.

A new object that the string contents represent.

Exceptions

Exception Type | Condition
GetConvertFromException(System.Object) | The conversion could not be performed.

Remarks

An exception will be raised if the string cannot be converted into the appropriate object. The default implementation always returns null.

The context can be used to extract additional information about the environment this converter is being invoked from. This may be a null reference (in Visual Basic Nothing), so you should always check. Also, properties on the context object may also return a null reference (Nothing).

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.ConvertFromString Overload List | ITypeDescriptorContext


TypeConverter.ConvertTo

Converts the given object to another type.

Overload List

Converts the given object to another type.

[Visual Basic] Overloads Overridable Public Function ConvertTo(ITypeDescriptorContext, Object, Type, Object()) As Object
[C#] public virtual object ConvertTo(ITypeDescriptorContext, Object, Type, Object[]);
[C++] public: virtual Object* ConvertTo(ITypeDescriptorContext*, Object, Type, Object[]);
[JScript] public function ConvertTo(ITypeDescriptorContext, Object, Type, Object[]) : Object;

Converts the given object to another type.

[Visual Basic] Overloads Public Function ConvertTo(Object, Type, Object()) As Object
[C#] public object ConvertTo(Object, Type, Object[]);
[C++] public: Object* ConvertTo(Object*, Type, Object*[]);
[JScript] public function ConvertTo(Object, Type, Object[]) : Object;

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace


TypeConverter.ConvertTo (ITypeDescriptorContext, Object, Type, Object[])

Converts the given object to another type.

[Visual Basic]
Overloads Overridable Public Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal destinationType As Type, _
   ByVal arguments() As Object _
) As Object
[C#]
public virtual object ConvertTo(
   ITypeDescriptorContext context,
   object value,
   Type destinationType,
   object[] arguments
);
[C++]
public: virtual Object* ConvertTo(
   ITypeDescriptorContext* context,
   Object* value,
   Type* destinationType,
   Object* arguments[]
);
[JScript]
public function ConvertTo(
   context : ITypeDescriptorContext,
   value : Object,
   destinationType : Type,
   arguments : Object[]
) : Object;

Parameters

context
An ITypeDescriptorContext that represents a context for the formatter.
value
The object to convert.
destinationType
The type to convert the object to.
arguments
An optional array of arguments to use when doing the conversion. The number and content of these arguments is dependent on the implementer of the value formatter.

Return Value

The converted object.

Exceptions

Exception Type | Condition
NotSupportedException | The conversion could not be performed.

Remarks

The most common types to convert are to and from a string object. The default implementation will make a call to ToString on the object if the object is valid and if the destination type is string.

The context can be used to extract additional information about the environment this converter is being invoked from. This may be a null reference (in Visual Basic Nothing), so you should always check. Also, properties on the context object may also return a null reference (Nothing).

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.ConvertTo Overload List | ITypeDescriptorContext


TypeConverter.ConvertTo (Object, Type, Object[])

Converts the given object to another type.

[Visual Basic]
Overloads Public Function ConvertTo( _
   ByVal value As Object, _
   ByVal destinationType As Type, _
   ByVal arguments() As Object _
) As Object
[C#]
public object ConvertTo(
   object value,
   Type destinationType,
   object[] arguments
);
[C++]
public: Object* ConvertTo(
   Object* value,
   Type* destinationType,
   Object* arguments[]
);
[JScript]
public function ConvertTo(
   value : Object,
   destinationType : Type,
   arguments : Object[]
) : Object;

Parameters

value
The object to convert.
destinationType
The type to convert the object to.
arguments
An optional array of arguments to use when doing the conversion. The number and content of these arguments is dependent on the implementer of the value formatter.

Return Value

The converted object.

Exceptions

Exception Type | Condition
NotSupportedException | The conversion could not be performed.

Remarks

The most common types to convert are to and from a string object.

The default implementation will make a call to ToString on the object if the object is valid and if the destination type is string.

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.ConvertTo Overload List


TypeConverter.ConvertToString

Converts the specified value to a string representation.

Overload List

Converts the specified value to a string representation.

[Visual Basic] Overloads Public Function ConvertToString(Object) As String
[C#] public string ConvertToString(Object);
[C++] public: String* ConvertToString(Object*);
[JScript] public function ConvertToString(Object) : String;

Converts the specified value to a string representation.

[Visual Basic] Overloads Public Function ConvertToString(ITypeDescriptorContext, Object) As String
[C#] public string ConvertToString(ITypeDescriptorContext, Object);
[C++] public: String* ConvertToString(ITypeDescriptorContext*, Object);
[JScript] public function ConvertToString(ITypeDescriptorContext, Object) : String;

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace


TypeConverter.ConvertToString (Object)

Converts the specified value to a string representation.

[Visual Basic]
Overloads Public Function ConvertToString( _
   ByVal value As Object _
) As String
[C#]
public string ConvertToString(
   object value
);
[C++]
public: String* ConvertToString(
   Object* value
);
[JScript]
public function ConvertToString(
   value : Object
) : String;

Parameters

value
The object to convert.

Return Value

A string representation of the object. Depending on the implementation of the value formatter, it may be possible to pass this string back into the value formatter to re-create an instance of the object.

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.ConvertToString Overload List


TypeConverter.ConvertToString (ITypeDescriptorContext, Object)

Converts the specified value to a string representation.

[Visual Basic]
Overloads Public Function ConvertToString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As String
[C#]
public string ConvertToString(
   ITypeDescriptorContext context,
   object value
);
[C++]
public: String* ConvertToString(
   ITypeDescriptorContext* context,
   Object* value
);
[JScript]
public function ConvertToString(
   context : ITypeDescriptorContext,
   value : Object
) : String;

Parameters

context
An ITypeDescriptorContext that represents a context for the formatter.
value
The object to convert.

Return Value

A string representation of the object. Depending on the implementation of the value formatter, it may be possible to pass this string back into the value formatter to re-create an instance of the object.

Remarks

The context can be used to extract additional information about the environment this converter is being invoked from. This may be a null reference (in Visual Basic Nothing), so you should always check. Also, properties on the context object may also return a null reference (Nothing).

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.ConvertToString Overload List | ITypeDescriptorContext


TypeConverter.CreateInstance

[To be supplied.]

Overload List

Recreates an object given its PersistInfo. This information was generated by a prior call to GetPersistInfo.

[Visual Basic] Overloads Overridable Public Function CreateInstance(ITypeDescriptorContext, PersistInfo) As Object
[C#] public virtual object CreateInstance(ITypeDescriptorContext, PersistInfo);
[C++] public: virtual Object* CreateInstance(ITypeDescriptorContext*, PersistInfo);
[JScript] public function CreateInstance(ITypeDescriptorContext, PersistInfo) : Object;

Creates an instance of this type given a set of property values for the object. This is useful for objects that are immutable, but still want to provide changable properties.

[Visual Basic] Overloads Overridable Public Function CreateInstance(ITypeDescriptorContext, IDictionary) As Object
[C#] public virtual object CreateInstance(ITypeDescriptorContext, IDictionary);
[C++] public: virtual Object* CreateInstance(ITypeDescriptorContext*, IDictionary);
[JScript] public function CreateInstance(ITypeDescriptorContext, IDictionary) : Object;

Creates an instance of this type given a set of property values for the object. This is useful for objects that are immutable, but still want to provide changable properties.

[Visual Basic] Overloads Public Function CreateInstance(IDictionary) As Object
[C#] public object CreateInstance(IDictionary);
[C++] public: Object* CreateInstance(IDictionary*);
[JScript] public function CreateInstance(IDictionary) : Object;

Recreates an object given its PersistInfo. This information was generated by a prior call to GetPersistInfo.

[Visual Basic] Overloads Public Function CreateInstance(PersistInfo) As Object
[C#] public object CreateInstance(PersistInfo);
[C++] public: Object* CreateInstance(PersistInfo*);
[JScript] public function CreateInstance(PersistInfo) : Object;

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace


TypeConverter.CreateInstance (ITypeDescriptorContext, PersistInfo)

Recreates an object given its PersistInfo. This information was generated by a prior call to GetPersistInfo.

[Visual Basic]
Overloads Overridable Public Function CreateInstance( _
   ByVal context As ITypeDescriptorContext, _
   ByVal persistInfo As PersistInfo _
) As Object
[C#]
public virtual object CreateInstance(
   ITypeDescriptorContext context,
   PersistInfo persistInfo
);
[C++]
public: virtual Object* CreateInstance(
   ITypeDescriptorContext* context,
   PersistInfo* persistInfo
);
[JScript]
public function CreateInstance(
   context : ITypeDescriptorContext,
   persistInfo : PersistInfo
) : Object;

Parameters

context
An ITypeDescriptorContext that represents a context for the formatter.
persistInfo
The persistence information to use when re-creating the object.

Return Value

An object representing the given PersistInfo.

Remarks

The context can be used to extract additional information about the environment this converter is being invoked from. This may be a null reference (in Visual Basic Nothing), so you should always check. Also, properties on the context object may also return a null reference (Nothing).

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.CreateInstance Overload List | ITypeDescriptorContext | PersistInfo


TypeConverter.CreateInstance (ITypeDescriptorContext, IDictionary)

Creates an instance of this type given a set of property values for the object. This is useful for objects that are immutable, but still want to provide changable properties.

[Visual Basic]
Overloads Overridable Public Function CreateInstance( _
   ByVal context As ITypeDescriptorContext, _
   ByVal propertyValues As IDictionary _
) As Object
[C#]
public virtual object CreateInstance(
   ITypeDescriptorContext context,
   IDictionary propertyValues
);
[C++]
public: virtual Object* CreateInstance(
   ITypeDescriptorContext* context,
   IDictionary* propertyValues
);
[JScript]
public function CreateInstance(
   context : ITypeDescriptorContext,
   propertyValues : IDictionary
) : Object;

Parameters

context
An ITypeDescriptorContext that represents a context for the formatter.
propertyValues
An IDictionary of new property values. The dictionary contains a series of name-value pairs, one for each property returned from GetProperties.

Return Value

The newly created object, or null if the object could not be created. The default implementation returns null.

Remarks

The context can be used to extract additional information about the environment this converter is being invoked from. This may be a null reference (in Visual Basic Nothing), so you should always check. Also, properties on the context object may also return a null reference (Nothing).

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.CreateInstance Overload List | ITypeDescriptorContext | IDictionary


TypeConverter.CreateInstance (IDictionary)

Creates an instance of this type given a set of property values for the object. This is useful for objects that are immutable, but still want to provide changable properties.

[Visual Basic]
Overloads Public Function CreateInstance( _
   ByVal propertyValues As IDictionary _
) As Object
[C#]
public object CreateInstance(
   IDictionary propertyValues
);
[C++]
public: Object* CreateInstance(
   IDictionary* propertyValues
);
[JScript]
public function CreateInstance(
   propertyValues : IDictionary
) : Object;

Parameters

propertyValues
An IDictionary that represents a dictionary of new property values. The dictionary contains a series of name-value pairs, one for each property returned from GetProperties.

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.CreateInstance Overload List | IDictionary


TypeConverter.CreateInstance (PersistInfo)

Recreates an object given its PersistInfo. This information was generated by a prior call to GetPersistInfo.

[Visual Basic]
Overloads Public Function CreateInstance( _
   ByVal persistInfo As PersistInfo _
) As Object
[C#]
public object CreateInstance(
   PersistInfo persistInfo
);
[C++]
public: Object* CreateInstance(
   PersistInfo* persistInfo
);
[JScript]
public function CreateInstance(
   persistInfo : PersistInfo
) : Object;

Parameters

persistInfo
A PersistInfo that specifies the persistence information to use when re-creating the object.

Return Value

An object representing the given PersistInfo.

Remarks

Recreates an object given its PersistInfo. This information was generated by a prior call to GetPersistInfo.

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.CreateInstance Overload List | PersistInfo


TypeConverter.GetConvertFromException

Retrieves a suitable exception to throw when a conversion cannot be performed.

[Visual Basic]
Protected Function GetConvertFromException( _
   ByVal value As Object _
) As Exception
[C#]
protected Exception GetConvertFromException(
   object value
);
[C++]
protected: Exception* GetConvertFromException(
   Object* value
);
[JScript]
protected function GetConvertFromException(
   value : Object
) : Exception;

Parameters

value
The value of the object to be converted, or null if the object isn't available.

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace


TypeConverter.GetConvertToException

Retrieves a suitable exception to throw when a conversion cannot be performed.

[Visual Basic]
Protected Function GetConvertToException( _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Exception
[C#]
protected Exception GetConvertToException(
   object value,
   Type destinationType
);
[C++]
protected: Exception* GetConvertToException(
   Object* value,
   Type* destinationType
);
[JScript]
protected function GetConvertToException(
   value : Object,
   destinationType : Type
) : Exception;

Parameters

value
The value of the object to be converted, or null if the object isn't available.
destinationType
A Type that represents the type the conversion was trying to convert to.

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace


TypeConverter.GetCreateInstanceSupported

[To be supplied.]

Overload List

Gets a value indicating whether changing a value on this object should require a call to CreateInstance to create a new value.

[Visual Basic] Overloads Overridable Public Function GetCreateInstanceSupported(ITypeDescriptorContext) As Boolean
[C#] public virtual bool GetCreateInstanceSupported(ITypeDescriptorContext);
[C++] public: virtual bool GetCreateInstanceSupported(ITypeDescriptorContext*);
[JScript] public function GetCreateInstanceSupported(ITypeDescriptorContext) : Boolean;

Gets a value indicating whether changing a value on this object should require a call to CreateInstance to create a new value.

[Visual Basic] Overloads Public Function GetCreateInstanceSupported() As Boolean
[C#] public bool GetCreateInstanceSupported();
[C++] public: bool GetCreateInstanceSupported();
[JScript] public function GetCreateInstanceSupported() : Boolean;

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace


TypeConverter.GetCreateInstanceSupported (ITypeDescriptorContext)

Gets a value indicating whether changing a value on this object should require a call to CreateInstance to create a new value.

[Visual Basic]
Overloads Overridable Public Function GetCreateInstanceSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
[C#]
public virtual bool GetCreateInstanceSupported(
   ITypeDescriptorContext context
);
[C++]
public: virtual bool GetCreateInstanceSupported(
   ITypeDescriptorContext* context
);
[JScript]
public function GetCreateInstanceSupported(
   context : ITypeDescriptorContext
) : Boolean;

Parameters

context
An ITypeDescriptorContext that represents a context for the formatter.

Return Value

true if CreateInstance should be called when a change is made to one or more properties of this object.

Remarks

The context can be used to extract additional information about the environment this converter is being invoked from. This may be a null reference (in Visual Basic Nothing), so you should always check. Also, properties on the context object may also return a null reference (Nothing).

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.GetCreateInstanceSupported Overload List | ITypeDescriptorContext


TypeConverter.GetCreateInstanceSupported ()

Gets a value indicating whether changing a value on this object should require a call to CreateInstance to create a new value.

[Visual Basic]
Overloads Public Function GetCreateInstanceSupported() As Boolean
[C#]
public bool GetCreateInstanceSupported();
[C++]
public: bool GetCreateInstanceSupported();
[JScript]
public function GetCreateInstanceSupported() : Boolean;

Return Value

true if CreateInstance should be called when a change is made to one or more properties of this object.

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.GetCreateInstanceSupported Overload List


TypeConverter.GetPersistInfo

[To be supplied.]

Overload List

Retrieves the PersistInfo object for the given value. This object describes the given value as persisted information, which can be saved to disk or moved. This information can later be reconstructed by passing the PersistInfo to GetValue.

[Visual Basic] Overloads Public Function GetPersistInfo(Object) As PersistInfo
[C#] public PersistInfo GetPersistInfo(Object);
[C++] public: PersistInfo* GetPersistInfo(Object*);
[JScript] public function GetPersistInfo(Object) : PersistInfo;

Retrieves the PersistInfo object for the given value. This object describes the given value as persisted information, which can be saved to disk or moved. This information can later be reconstructed by passing the PersistInfo to GetValue.

[Visual Basic] Overloads Overridable Public Function GetPersistInfo(ITypeDescriptorContext, Object) As PersistInfo
[C#] public virtual PersistInfo GetPersistInfo(ITypeDescriptorContext, Object);
[C++] public: virtual PersistInfo* GetPersistInfo(ITypeDescriptorContext*, Object);
[JScript] public function GetPersistInfo(ITypeDescriptorContext, Object) : PersistInfo;

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace


TypeConverter.GetPersistInfo (Object)

Retrieves the PersistInfo object for the given value. This object describes the given value as persisted information, which can be saved to disk or moved. This information can later be reconstructed by passing the PersistInfo to GetValue.

[Visual Basic]
Overloads Public Function GetPersistInfo( _
   ByVal value As Object _
) As PersistInfo
[C#]
public PersistInfo GetPersistInfo(
   object value
);
[C++]
public: PersistInfo* GetPersistInfo(
   Object* value
);
[JScript]
public function GetPersistInfo(
   value : Object
) : PersistInfo;

Parameters

value
The object to persist.

Return Value

The PersistInfo representing the persisted state of the given object.

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.GetPersistInfo Overload List | PersistInfo | TBD


TypeConverter.GetPersistInfo (ITypeDescriptorContext, Object)

Retrieves the PersistInfo object for the given value. This object describes the given value as persisted information, which can be saved to disk or moved. This information can later be reconstructed by passing the PersistInfo to GetValue.

[Visual Basic]
Overloads Overridable Public Function GetPersistInfo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As PersistInfo
[C#]
public virtual PersistInfo GetPersistInfo(
   ITypeDescriptorContext context,
   object value
);
[C++]
public: virtual PersistInfo* GetPersistInfo(
   ITypeDescriptorContext* context,
   Object* value
);
[JScript]
public function GetPersistInfo(
   context : ITypeDescriptorContext,
   value : Object
) : PersistInfo;

Parameters

context
An ITypeDescriptorContext that represents a context for the formatter.
value
The object to persist.

Return Value

The PersistInfo representing the persisted state of the given object.

Remarks

The context can be used to extract additional information about the environment this converter is being invoked from. This may be a null reference (in Visual Basic Nothing), so you should always check. Also, properties on the context object may also return a null reference (Nothing).

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.GetPersistInfo Overload List | PersistInfo | ITypeDescriptorContext


TypeConverter.GetProperties

[To be supplied.]

Overload List

Retrieves the set of properties for this type. By default, a type has does not return any properties. An easy implementation of this method can just call TypeDescriptor.GetProperties for the correct data type.

[Visual Basic] Overloads Public Function GetProperties(Object) As PropertyDescriptorCollection
[C#] public PropertyDescriptorCollection GetProperties(Object);
[C++] public: PropertyDescriptorCollection* GetProperties(Object*);
[JScript] public function GetProperties(Object) : PropertyDescriptorCollection;

Retrieves the set of properties for this type. By default, a type has does not return any properties. An easy implementation of this method can just call TypeDescriptor.GetProperties for the correct data type.

[Visual Basic] Overloads Public Function GetProperties(ITypeDescriptorContext, Object) As PropertyDescriptorCollection
[C#] public PropertyDescriptorCollection GetProperties(ITypeDescriptorContext, Object);
[C++] public: PropertyDescriptorCollection* GetProperties(ITypeDescriptorContext*, Object);
[JScript] public function GetProperties(ITypeDescriptorContext, Object) : PropertyDescriptorCollection;

Retrieves the set of properties for this type. By default, a type has does not return any properties. An easy implementation of this method can just call TypeDescriptor.GetProperties for the correct data type.

[Visual Basic] Overloads Overridable Public Function GetProperties(ITypeDescriptorContext, Object, MemberAttribute()) As PropertyDescriptorCollection
[C#] public virtual PropertyDescriptorCollection GetProperties(ITypeDescriptorContext, Object, MemberAttribute[]);
[C++] public: virtual PropertyDescriptorCollection* GetProperties(ITypeDescriptorContext*, Object, MemberAttribute[]);
[JScript] public function GetProperties(ITypeDescriptorContext, Object, MemberAttribute[]) : PropertyDescriptorCollection;

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace


TypeConverter.GetProperties (Object)

Retrieves the set of properties for this type. By default, a type has does not return any properties. An easy implementation of this method can just call TypeDescriptor.GetProperties for the correct data type.

[Visual Basic]
Overloads Public Function GetProperties( _
   ByVal value As Object _
) As PropertyDescriptorCollection
[C#]
public PropertyDescriptorCollection GetProperties(
   object value
);
[C++]
public: PropertyDescriptorCollection* GetProperties(
   Object* value
);
[JScript]
public function GetProperties(
   value : Object
) : PropertyDescriptorCollection;

Parameters

value
The value of the object to get the properties for.

Return Value

A PropertyDescriptorCollection that specifies the set of properties for this data type. this will return null if

The set of properties that should be exposed for this data type. If no properties should be exposed, thsi may return null. The default implementation always returns null.

Remarks

As implemented in this class, returns a null reference (in Visual Basic Nothing).

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.GetProperties Overload List


TypeConverter.GetProperties (ITypeDescriptorContext, Object)

Retrieves the set of properties for this type. By default, a type has does not return any properties. An easy implementation of this method can just call TypeDescriptor.GetProperties for the correct data type.

[Visual Basic]
Overloads Public Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As PropertyDescriptorCollection
[C#]
public PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value
);
[C++]
public: PropertyDescriptorCollection* GetProperties(
   ITypeDescriptorContext* context,
   Object* value
);
[JScript]
public function GetProperties(
   context : ITypeDescriptorContext,
   value : Object
) : PropertyDescriptorCollection;

Parameters

context
An ITypeDescriptorContext that represents a context for the formatter.
value
The value of the object to get the properties for.

Return Value

The set of properties that should be exposed for this data type. If no properties should be exposed, thsi may return null. The default implementation always returns null.

Remarks

As implemented in this class, returns a null reference (in Visual Basic Nothing).

The context can be used to extract additional information about the environment this converter is being invoked from. This may be a null reference (Nothing), so you should always check. Also, properties on the context object may also return a null reference (Nothing).

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.GetProperties Overload List | ITypeDescriptorContext


TypeConverter.GetProperties (ITypeDescriptorContext, Object, MemberAttribute[])

Retrieves the set of properties for this type. By default, a type has does not return any properties. An easy implementation of this method can just call TypeDescriptor.GetProperties for the correct data type.

[Visual Basic]
Overloads Overridable Public Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal attributes() As MemberAttribute _
) As PropertyDescriptorCollection
[C#]
public virtual PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value,
   MemberAttribute[] attributes
);
[C++]
public: virtual PropertyDescriptorCollection* GetProperties(
   ITypeDescriptorContext* context,
   Object* value,
   MemberAttribute* attributes[]
);
[JScript]
public function GetProperties(
   context : ITypeDescriptorContext,
   value : Object,
   attributes : MemberAttribute[]
) : PropertyDescriptorCollection;

Parameters

context
An ITypeDescriptorContext that represents a context for the formatter.
value
The value of the object to get the properties for.
attributes
[To be supplied.]

Return Value

The set of properties that should be exposed for this data type. If no properties should be exposed, thsi may return null. The default implementation always returns null.

Remarks

As implemented in this class, returns a null reference (in Visual Basic Nothing).

The context can be used to extract additional information about the environment this converter is being invoked from. This may be a null reference (Nothing), so you should always check. Also, properties on the context object may also return a null reference (Nothing).

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.GetProperties Overload List | ITypeDescriptorContext | MemberAttribute


TypeConverter.GetPropertiesSupported

[To be supplied.]

Overload List

Gets a value indicating whether this object supports properties. By default, this is false.

[Visual Basic] Overloads Public Function GetPropertiesSupported() As Boolean
[C#] public bool GetPropertiesSupported();
[C++] public: bool GetPropertiesSupported();
[JScript] public function GetPropertiesSupported() : Boolean;

Gets a value indicating whether this object supports properties. By default, this is false.

[Visual Basic] Overloads Overridable Public Function GetPropertiesSupported(ITypeDescriptorContext) As Boolean
[C#] public virtual bool GetPropertiesSupported(ITypeDescriptorContext);
[C++] public: virtual bool GetPropertiesSupported(ITypeDescriptorContext*);
[JScript] public function GetPropertiesSupported(ITypeDescriptorContext) : Boolean;

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace


TypeConverter.GetPropertiesSupported ()

Gets a value indicating whether this object supports properties. By default, this is false.

[Visual Basic]
Overloads Public Function GetPropertiesSupported() As Boolean
[C#]
public bool GetPropertiesSupported();
[C++]
public: bool GetPropertiesSupported();
[JScript]
public function GetPropertiesSupported() : Boolean;

Return Value

Returns true if GetProperties should be called to find the properties of this object.

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.GetPropertiesSupported Overload List


TypeConverter.GetPropertiesSupported (ITypeDescriptorContext)

Gets a value indicating whether this object supports properties. By default, this is false.

[Visual Basic]
Overloads Overridable Public Function GetPropertiesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
[C#]
public virtual bool GetPropertiesSupported(
   ITypeDescriptorContext context
);
[C++]
public: virtual bool GetPropertiesSupported(
   ITypeDescriptorContext* context
);
[JScript]
public function GetPropertiesSupported(
   context : ITypeDescriptorContext
) : Boolean;

Parameters

context
An ITypeDescriptorContext that represents a context for the formatter.

Return Value

Returns true if GetProperties should be called to find the properties of this object.

Remarks

The context can be used to extract additional information about the environment this converter is being invoked from. This may be a null reference (in Visual Basic Nothing), so you should always check. Also, properties on the context object may also return a null reference (Nothing).

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.GetPropertiesSupported Overload List | ITypeDescriptorContext


TypeConverter.GetStandardValues

[To be supplied.]

Overload List

Retrieves a collection containing a set of standard values for the data type this validator is designed for. This will return null if the data type does not support a standard set of values.

[Visual Basic] Overloads Public Function GetStandardValues() As ICollection
[C#] public ICollection GetStandardValues();
[C++] public: ICollection* GetStandardValues();
[JScript] public function GetStandardValues() : ICollection;

Retrieves a collection containing a set of standard values for the data type this validator is designed for. This will return null if the data type does not support a standard set of values.

[Visual Basic] Overloads Overridable Public Function GetStandardValues(ITypeDescriptorContext) As StandardValuesCollection
[C#] public virtual StandardValuesCollection GetStandardValues(ITypeDescriptorContext);
[C++] public: virtual StandardValuesCollection* GetStandardValues(ITypeDescriptorContext*);
[JScript] public function GetStandardValues(ITypeDescriptorContext) : StandardValuesCollection;

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace


TypeConverter.GetStandardValues ()

Retrieves a collection containing a set of standard values for the data type this validator is designed for. This will return null if the data type does not support a standard set of values.

[Visual Basic]
Overloads Public Function GetStandardValues() As ICollection
[C#]
public ICollection GetStandardValues();
[C++]
public: ICollection* GetStandardValues();
[JScript]
public function GetStandardValues() : ICollection;

Return Value

A collection containing a standard set of valid values, or null. The default implementation always returns null.

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.GetStandardValues Overload List


TypeConverter.GetStandardValues (ITypeDescriptorContext)

Retrieves a collection containing a set of standard values for the data type this validator is designed for. This will return null if the data type does not support a standard set of values.

[Visual Basic]
Overloads Overridable Public Function GetStandardValues( _
   ByVal context As ITypeDescriptorContext _
) As StandardValuesCollection
[C#]
public virtual StandardValuesCollection GetStandardValues(
   ITypeDescriptorContext context
);
[C++]
public: virtual StandardValuesCollection* GetStandardValues(
   ITypeDescriptorContext* context
);
[JScript]
public function GetStandardValues(
   context : ITypeDescriptorContext
) : StandardValuesCollection;

Parameters

context
An ITypeDescriptorContext that represents a context for the formatter.

Return Value

A StandardValuesCollection containing a standard set of valid values, or a null reference (in Visual Basic Nothing).

Remarks

As implemented in this class, this method always returns a null reference (Nothing).

The context can be used to extract additional information about the environment this converter is being invoked from. This may be a null reference (Nothing), so you should always check. Also, properties on the context object may also return a null reference (Nothing).

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.GetStandardValues Overload List | ITypeDescriptorContext


TypeConverter.GetStandardValuesExclusive

[To be supplied.]

Overload List

Gets a value indicating whether the list of standard values returned from GetStandardValues is an exclusive list. If the list is exclusive, then no other values are valid, such as in an enum data type. If the list is not exclusive, then there are other valid values besides the list of standard values GetStandardValues provides.

[Visual Basic] Overloads Public Function GetStandardValuesExclusive() As Boolean
[C#] public bool GetStandardValuesExclusive();
[C++] public: bool GetStandardValuesExclusive();
[JScript] public function GetStandardValuesExclusive() : Boolean;

Gets a value indicating whether the list of standard values returned from GetStandardValues is an exclusive list. If the list is exclusive, then no other values are valid, such as in an enum data type. If the list is not exclusive, then there are other valid values besides the list of standard values GetStandardValues provides.

[Visual Basic] Overloads Overridable Public Function GetStandardValuesExclusive(ITypeDescriptorContext) As Boolean
[C#] public virtual bool GetStandardValuesExclusive(ITypeDescriptorContext);
[C++] public: virtual bool GetStandardValuesExclusive(ITypeDescriptorContext*);
[JScript] public function GetStandardValuesExclusive(ITypeDescriptorContext) : Boolean;

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace


TypeConverter.GetStandardValuesExclusive ()

Gets a value indicating whether the list of standard values returned from GetStandardValues is an exclusive list. If the list is exclusive, then no other values are valid, such as in an enum data type. If the list is not exclusive, then there are other valid values besides the list of standard values GetStandardValues provides.

[Visual Basic]
Overloads Public Function GetStandardValuesExclusive() As Boolean
[C#]
public bool GetStandardValuesExclusive();
[C++]
public: bool GetStandardValuesExclusive();
[JScript]
public function GetStandardValuesExclusive() : Boolean;

Return Value

True if the collection returned from GetStandardValues is an exhaustive list of possible values, or false if other values are possible. The default for this method always returns false;

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.GetStandardValuesExclusive Overload List


TypeConverter.GetStandardValuesExclusive (ITypeDescriptorContext)

Gets a value indicating whether the list of standard values returned from GetStandardValues is an exclusive list. If the list is exclusive, then no other values are valid, such as in an enum data type. If the list is not exclusive, then there are other valid values besides the list of standard values GetStandardValues provides.

[Visual Basic]
Overloads Overridable Public Function GetStandardValuesExclusive( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
[C#]
public virtual bool GetStandardValuesExclusive(
   ITypeDescriptorContext context
);
[C++]
public: virtual bool GetStandardValuesExclusive(
   ITypeDescriptorContext* context
);
[JScript]
public function GetStandardValuesExclusive(
   context : ITypeDescriptorContext
) : Boolean;

Parameters

context
An ITypeDescriptorContext that represents a context for the formatter.

Return Value

True if the collection returned from GetStandardValues is an exhaustive list of possible values, or false if other values are possible. The default for this method always returns false;

Remarks

The context can be used to extract additional information about the environment this converter is being invoked from. This may be a null reference (in Visual Basic Nothing), so you should always check. Also, properties on the context object may also return a null reference (Nothing).

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.GetStandardValuesExclusive Overload List | ITypeDescriptorContext


TypeConverter.GetStandardValuesSupported

[To be supplied.]

Overload List

Gets a value indicating whether this object supports a standard set of values that can be picked from a list.

[Visual Basic] Overloads Public Function GetStandardValuesSupported() As Boolean
[C#] public bool GetStandardValuesSupported();
[C++] public: bool GetStandardValuesSupported();
[JScript] public function GetStandardValuesSupported() : Boolean;

Gets a value indicating whether this object supports a standard set of values that can be picked from a list.

[Visual Basic] Overloads Overridable Public Function GetStandardValuesSupported(ITypeDescriptorContext) As Boolean
[C#] public virtual bool GetStandardValuesSupported(ITypeDescriptorContext);
[C++] public: virtual bool GetStandardValuesSupported(ITypeDescriptorContext*);
[JScript] public function GetStandardValuesSupported(ITypeDescriptorContext) : Boolean;

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace


TypeConverter.GetStandardValuesSupported ()

Gets a value indicating whether this object supports a standard set of values that can be picked from a list.

[Visual Basic]
Overloads Public Function GetStandardValuesSupported() As Boolean
[C#]
public bool GetStandardValuesSupported();
[C++]
public: bool GetStandardValuesSupported();
[JScript]
public function GetStandardValuesSupported() : Boolean;

Return Value

Returns true if GetStandardValues should be called to find a common set of values the object supports.

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.GetStandardValuesSupported Overload List


TypeConverter.GetStandardValuesSupported (ITypeDescriptorContext)

Gets a value indicating whether this object supports a standard set of values that can be picked from a list.

[Visual Basic]
Overloads Overridable Public Function GetStandardValuesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
[C#]
public virtual bool GetStandardValuesSupported(
   ITypeDescriptorContext context
);
[C++]
public: virtual bool GetStandardValuesSupported(
   ITypeDescriptorContext* context
);
[JScript]
public function GetStandardValuesSupported(
   context : ITypeDescriptorContext
) : Boolean;

Parameters

context
An ITypeDescriptorContext that represents a context for the formatter.

Return Value

Returns true if GetStandardValues should be called to find a common set of values the object supports.

Remarks

The context can be used to extract additional information about the environment this converter is being invoked from. This may be a null reference (in Visual Basic Nothing), so you should always check. Also, properties on the context object may also return a null reference (Nothing).

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.GetStandardValuesSupported Overload List | ITypeDescriptorContext


TypeConverter.IsValid

[To be supplied.]

Overload List

Gets a value indicating whether the given object value is valid for this type.

[Visual Basic] Overloads Public Function IsValid(Object) As Boolean
[C#] public bool IsValid(Object);
[C++] public: bool IsValid(Object*);
[JScript] public function IsValid(Object) : Boolean;

Gets a value indicating whether the given object value is valid for this type.

[Visual Basic] Overloads Overridable Public Function IsValid(ITypeDescriptorContext, Object) As Boolean
[C#] public virtual bool IsValid(ITypeDescriptorContext, Object);
[C++] public: virtual bool IsValid(ITypeDescriptorContext*, Object);
[JScript] public function IsValid(ITypeDescriptorContext, Object) : Boolean;

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace


TypeConverter.IsValid (Object)

Gets a value indicating whether the given object value is valid for this type.

[Visual Basic]
Overloads Public Function IsValid( _
   ByVal value As Object _
) As Boolean
[C#]
public bool IsValid(
   object value
);
[C++]
public: bool IsValid(
   Object* value
);
[JScript]
public function IsValid(
   value : Object
) : Boolean;

Parameters

value
The object to test.

Return Value

True if the provided value is valid for this object.

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.IsValid Overload List


TypeConverter.IsValid (ITypeDescriptorContext, Object)

Gets a value indicating whether the given object value is valid for this type.

[Visual Basic]
Overloads Overridable Public Function IsValid( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As Boolean
[C#]
public virtual bool IsValid(
   ITypeDescriptorContext context,
   object value
);
[C++]
public: virtual bool IsValid(
   ITypeDescriptorContext* context,
   Object* value
);
[JScript]
public function IsValid(
   context : ITypeDescriptorContext,
   value : Object
) : Boolean;

Parameters

context
An ITypeDescriptorContext that represents a context for the formatter.
value
The object to test.

Return Value

True if the provided value is valid for this object.

Remarks

The context can be used to extract additional information about the environment this converter is being invoked from. This may be a null reference (in Visual Basic Nothing), so you should always check. Also, properties on the context object may also return a null reference (Nothing).

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | TypeConverter.IsValid Overload List | ITypeDescriptorContext


TypeConverter.SortProperties

Sorts a collection of properties.

[Visual Basic]
Protected Function SortProperties( _
   ByVal props As PropertyDescriptorCollection, _
   ByVal names() As String _
) As PropertyDescriptorCollection
[C#]
protected PropertyDescriptorCollection SortProperties(
   PropertyDescriptorCollection props,
   string[] names
);
[C++]
protected: PropertyDescriptorCollection* SortProperties(
   PropertyDescriptorCollection* props,
   String* names[]
);
[JScript]
protected function SortProperties(
   props : PropertyDescriptorCollection,
   names : String[]
) : PropertyDescriptorCollection;

Parameters

props
A PropertyDescriptorCollection that has the properties to sort.
names
An array of names in the order you want the properties to appear in the collection.

Remarks

All properties in the collection that are not in the array of names, will be added alphabetically to the end. If the names array is empty or a null reference (in Visual Basic Nothing), all the properties in the collection will be sorted alphabetically.

See Also

TypeConverter Class | TypeConverter Members | System.ComponentModel Namespace | PropertyDescriptorCollection | TypeConverter


TypeConverter.StandardValuesCollection Class

Represents a collection of values.

Object
TypeConverter.StandardValuesCollection

[Visual Basic]
Public Class TypeConverter.StandardValuesCollection
   Implements ICollection, IEnumerable
[C#]
public class TypeConverter.StandardValuesCollection : ICollection,
   IEnumerable
[C++]
public __gc class TypeConverter.StandardValuesCollection : public
   ICollection, IEnumerable
[JScript]
public class TypeConverter.StandardValuesCollection implements
   ICollection, IEnumerable

Remarks

This is a simple collection class that takes an array of values and converts it to a collection. It is very lightweight and is well suited for use in GetStandardValues.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

TypeConverter.StandardValuesCollection Members | System.ComponentModel Namespace | GetStandardValues | TypeConverter


TypeConverter.StandardValuesCollection Members

Public:

Constructor

TypeConverterStandardValuesCollection Constructor [To be supplied.]

Properties

Count | [To be supplied.]
Item | [To be supplied.] In C#, this member is the indexer for the TypeConverter.StandardValuesCollection class.

Methods

CopyTo | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeConverter.StandardValuesCollection Class | System.ComponentModel Namespace


TypeConverter.StandardValuesCollection Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal values As ICollection _
)
[C#]
public TypeConverter.StandardValuesCollection(
   ICollection values
);
[C++]
public: TypeConverter.StandardValuesCollection(
   ICollection* values
);
[JScript]
public function TypeConverter.StandardValuesCollection(
   values : ICollection
);

Parameters

values
[To be supplied.]

See Also

TypeConverter.StandardValuesCollection Class | TypeConverter.StandardValuesCollection Members | System.ComponentModel Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypeConverter.StandardValuesCollection Properties

The properties of the TypeConverter.StandardValuesCollection class are listed below. For a complete list of TypeConverter.StandardValuesCollection class members, see the TypeConverter.StandardValuesCollection Members topic.

Public:

Count | [To be supplied.]
Item | [To be supplied.] In C#, this member is the indexer for the TypeConverter.StandardValuesCollection class.

See Also

TypeConverter.StandardValuesCollection Class | System.ComponentModel Namespace


TypeConverter.StandardValuesCollection.Count

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

See Also

TypeConverter.StandardValuesCollection Class | TypeConverter.StandardValuesCollection Members | System.ComponentModel Namespace


TypeConverter.StandardValuesCollection.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the TypeConverter.StandardValuesCollection class.

[Visual Basic]
Public Default ReadOnly Property Item( _
   ByVal index As Integer _
) As Object
[C#]
public object this[
   int index
] {get;}
[C++]
public: __property Object* get_Item(
   int index
);
[JScript]
returnValue = TypeConverter.StandardValuesCollectionObject.Item(index);
-or-
returnValue = TypeConverter.StandardValuesCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
[To be supplied.]

Parameters [Visual Basic, C#, C++]

index
[To be supplied.]

See Also

TypeConverter.StandardValuesCollection Class | TypeConverter.StandardValuesCollection Members | System.ComponentModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypeConverter.StandardValuesCollection Methods

The methods of the TypeConverter.StandardValuesCollection class are listed below. For a complete list of TypeConverter.StandardValuesCollection class members, see the TypeConverter.StandardValuesCollection Members topic.

Public:

CopyTo | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeConverter.StandardValuesCollection Class | System.ComponentModel Namespace


TypeConverter.StandardValuesCollection.CopyTo

[To be supplied.]

[Visual Basic]
Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   Array array,
   int index
);
[C++]
public: void CopyTo(
   Array* array,
   int index
);
[JScript]
public function CopyTo(
   array : Array,
   index : int
);

Parameters

array
[To be supplied.]
index
[To be supplied.]

See Also

TypeConverter.StandardValuesCollection Class | TypeConverter.StandardValuesCollection Members | System.ComponentModel Namespace


TypeConverter.StandardValuesCollection.GetEnumerator

[To be supplied.]

[Visual Basic]
Public Function GetEnumerator() As IEnumerator
[C#]
public IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

See Also

TypeConverter.StandardValuesCollection Class | TypeConverter.StandardValuesCollection Members | System.ComponentModel Namespace


TypeConverterAttribute Class

Specifies what type to use as a converter for values.

Object
Attribute
MemberAttribute
TypeConverterAttribute

[Visual Basic]
NotInheritable Public Class TypeConverterAttribute
   Inherits MemberAttribute
[C#]
public sealed class TypeConverterAttribute : MemberAttribute
[C++]
public __gc __sealed class TypeConverterAttribute : public
   MemberAttribute
[JScript]
public class TypeConverterAttribute extends MemberAttribute

Remarks

The class you use for convertion must inherit from TypeConverter. Use the ConverterTypeName property to get the name of the type to use as a converter.

For more information, see TBD and TBD.

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace


TypeDescriptor Class

Provides information about the properties and events for a component. This class cannot be inherited.

Object
TypeDescriptor

[Visual Basic]
NotInheritable Public Class TypeDescriptor
[C#]
public sealed class TypeDescriptor
[C++]
public __gc __sealed class TypeDescriptor
[JScript]
public class TypeDescriptor

Remarks

Use the static (in Visual Basic Shared) methods provided in this class to get information about a component. All the methods in this class are static (Shared).

Property and event values can be set in two different ways: they can be specified in the component class, or they can be changed at design time. Because of this, the overloaded methods in this class take two different types of parameters: a method can take the type of class, or it can take an instance of an object. At design time, these two kinds of methods can be different. At run time, these methods are usually the same.

When you want to access TypeDescriptor information, use the method that calls for a component when you have an instance of the object. Use the method that calls for type of the class method only when you do not have an instance of the object.

TypeDescriptor provides the following methods:

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

TypeDescriptor Members | System.ComponentModel Namespace


TypeDescriptor Members

Public:

Properties

ComNativeDescriptorHandler [To be supplied.]

Methods

CreateDesigner | Creates an instance of the designer associated with the specified component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetAttributes | Overloaded. Gets a collection of attributes.
GetClassName | Overloaded. Gets the name of the class for the specified component.
GetComponentName | Overloaded. Gets the name of the class for the specified component.
GetConverter | Overloaded. Gets a type converter for a component.
GetDefaultEvent | Overloaded. Gets the default event for a component.
GetDefaultProperty | Overloaded. Gets the default property for a component.
GetEditor | Overloaded. Gets an editor with the specified base type.
GetEvents | Overloaded. Gets a collection of events.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProperties | Overloaded. Gets a collection of properties.
GetType (inherited from Object) | Gets the Type of the Object.
Refresh | Overloaded. Clears the properties and events from the cache.
SortDescriptorArray | Sorts descriptors by name of the descriptor.
ToString (inherited from Object) | Returns a String that represents the current Object.

Events

Refresh Occurs when Refresh XXX is raised for a component.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Event Hookup:

Methods

AddOnRefresh | Adds an event handler for the Refresh XXX event.
RemoveOnRefresh | Removes a previously added event handler for the AddOnRefresh event.

See Also

TypeDescriptor Class | System.ComponentModel Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypeDescriptor Properties

The properties of the TypeDescriptor class are listed below. For a complete list of TypeDescriptor class members, see the TypeDescriptor Members topic.

Public:

ComNativeDescriptorHandler [To be supplied.]

See Also

TypeDescriptor Class | System.ComponentModel Namespace


TypeDescriptor.ComNativeDescriptorHandler

[To be supplied.]

[Visual Basic]
Public Shared Property ComNativeDescriptorHandler As _
   IComNativeDescriptorHandler
[C#]
public static IComNativeDescriptorHandler
   ComNativeDescriptorHandler {get; set;}
[C++]
public: __property static IComNativeDescriptorHandler* get_ComNativeDescriptorHandler();
public: __property static void set_ComNativeDescriptorHandler(IComNativeDescriptorHandler*);
[JScript]
public static function get ComNativeDescriptorHandler() : IComNativeDescriptorHandler;
public static function set ComNativeDescriptorHandler(IComNativeDescriptorHandler);

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypeDescriptor Methods

The methods of the TypeDescriptor class are listed below. For a complete list of TypeDescriptor class members, see the TypeDescriptor Members topic.

Public:

CreateDesigner | Creates an instance of the designer associated with the specified component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetAttributes | Overloaded. Gets a collection of attributes.
GetClassName | Overloaded. Gets the name of the class for the specified component.
GetComponentName | Overloaded. Gets the name of the class for the specified component.
GetConverter | Overloaded. Gets a type converter for a component.
GetDefaultEvent | Overloaded. Gets the default event for a component.
GetDefaultProperty | Overloaded. Gets the default property for a component.
GetEditor | Overloaded. Gets an editor with the specified base type.
GetEvents | Overloaded. Gets a collection of events.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProperties | Overloaded. Gets a collection of properties.
GetType (inherited from Object) | Gets the Type of the Object.
Refresh | Overloaded. Clears the properties and events from the cache.
SortDescriptorArray | Sorts descriptors by name of the descriptor.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Event Hookup:

AddOnRefresh | Adds an event handler for the Refresh XXX event.
RemoveOnRefresh | Removes a previously added event handler for the AddOnRefresh event.

See Also

TypeDescriptor Class | System.ComponentModel Namespace


TypeDescriptor.AddOnRefresh

Adds an event handler for the Refresh XXX event.

[Visual Basic]
Public Shared Sub AddOnRefresh( _
   ByVal handler As RefreshEventHandler _
)
[C#]
public static void AddOnRefresh(
   RefreshEventHandler handler
);
[C++]
public: static void AddOnRefresh(
   RefreshEventHandler* handler
);
[JScript]
public static function AddOnRefresh(
   handler : RefreshEventHandler
);

Parameters

handler
A RefreshEventHandler that specifies the event handler to add.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor | EventDescriptor | PropertyDescriptor | Refresh | RemoveOnRefresh | RefreshEventHandler


TypeDescriptor.CreateDesigner

Creates an instance of the designer associated with the specified component.

[Visual Basic]
Public Shared Function CreateDesigner( _
   ByVal component As IComponent, _
   ByVal designerBaseType As Type _
) As IDesigner
[C#]
public static IDesigner CreateDesigner(
   IComponent component,
   Type designerBaseType
);
[C++]
public: static IDesigner* CreateDesigner(
   IComponent* component,
   Type* designerBaseType
);
[JScript]
public static function CreateDesigner(
   component : IComponent,
   designerBaseType : Type
) : IDesigner;

Parameters

component
An IComponent that specifies the component to associate with the designer.
designerBaseType
A Type that represents the type of designer to create.

Return Value

An IDesigner that is an instance of the designer for the component, or a null reference (in Visual Basic Nothing) if no designer can be found.

Remarks

If this method cannot find a valid DesignerAttribute, it searches up the class hierarchy for a designer. If it cannot find a designer in the class hierarchy, it returns a null reference (Nothing).

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor | EventDescriptor | PropertyDescriptor | IComponent | IDesigner


TypeDescriptor.GetAttributes

Gets a collection of attributes.

Overload List

Gets a collection of attributes for the specified component.

[Visual Basic] Overloads Public Shared Function GetAttributes(Object, Boolean) As MemberAttributeCollection
[C#] public static MemberAttributeCollection GetAttributes(Object, bool);
[C++] public: static MemberAttributeCollection* GetAttributes(Object*, bool);
[JScript] public static function GetAttributes(Object, Boolean) : MemberAttributeCollection;

Gets a collection of attributes for the specified component.

[Visual Basic] Overloads Public Shared Function GetAttributes(Object) As MemberAttributeCollection
[C#] public static MemberAttributeCollection GetAttributes(Object);
[C++] public: static MemberAttributeCollection* GetAttributes(Object*);
[JScript] public static function GetAttributes(Object) : MemberAttributeCollection;

Gets a collection of attributes for the specified type of component.

[Visual Basic] Overloads Public Shared Function GetAttributes(Type) As MemberAttributeCollection
[C#] public static MemberAttributeCollection GetAttributes(Type);
[C++] public: static MemberAttributeCollection* GetAttributes(Type*);
[JScript] public static function GetAttributes(Type) : MemberAttributeCollection;

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace


TypeDescriptor.GetAttributes (Object, Boolean)

Gets a collection of attributes for the specified component.

[Visual Basic]
Overloads Public Shared Function GetAttributes( _
   ByVal component As Object, _
   ByVal fNoCustomTypeDesc As Boolean _
) As MemberAttributeCollection
[C#]
public static MemberAttributeCollection GetAttributes(
   object component,
   bool fNoCustomTypeDesc
);
[C++]
public: static MemberAttributeCollection* GetAttributes(
   Object* component,
   bool fNoCustomTypeDesc
);
[JScript]
public static function GetAttributes(
   component : Object,
   fNoCustomTypeDesc : Boolean
) : MemberAttributeCollection;

Parameters

component
The component whose attributes you want to get.
fNoCustomTypeDesc
true if TypeDescriptor has been called by an instance of ICustomTypeDescriptor; otherwise, false.

Return Value

A MemberAttributeCollection with the attributes for the component. If the component is a null reference (in Visual Basic Nothing), this method returns an empty collection.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.GetAttributes Overload List | TypeDescriptor | EventDescriptor | PropertyDescriptor | MemberAttribute | MemberAttributeCollection | ICustomTypeDescriptor


TypeDescriptor.GetAttributes (Object)

Gets a collection of attributes for the specified component.

[Visual Basic]
Overloads Public Shared Function GetAttributes( _
   ByVal component As Object _
) As MemberAttributeCollection
[C#]
public static MemberAttributeCollection GetAttributes(
   object component
);
[C++]
public: static MemberAttributeCollection* GetAttributes(
   Object* component
);
[JScript]
public static function GetAttributes(
   component : Object
) : MemberAttributeCollection;

Parameters

component
The component whose attributes you want to get.

Return Value

A MemberAttributeCollection with the attributes for the component. If the component is a null reference (in Visual Basic Nothing), this method returns an empty collection.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.GetAttributes Overload List | TypeDescriptor | EventDescriptor | PropertyDescriptor | MemberAttribute | MemberAttributeCollection


TypeDescriptor.GetAttributes (Type)

Gets a collection of attributes for the specified type of component.

[Visual Basic]
Overloads Public Shared Function GetAttributes( _
   ByVal componentType As Type _
) As MemberAttributeCollection
[C#]
public static MemberAttributeCollection GetAttributes(
   Type componentType
);
[C++]
public: static MemberAttributeCollection* GetAttributes(
   Type* componentType
);
[JScript]
public static function GetAttributes(
   componentType : Type
) : MemberAttributeCollection;

Parameters

componentType
A Type that represents the class of the component to get the attribute for.

Return Value

A MemberAttributeCollection with the attributes for the type of the component. If the component is a null reference (in Visual Basic Nothing), this method returns an empty collection.

Remarks

Call this version of this method only when you do not have an instance of the object.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.GetAttributes Overload List | TypeDescriptor | EventDescriptor | PropertyDescriptor | MemberAttribute | MemberAttributeCollection


TypeDescriptor.GetClassName

Gets the name of the class for the specified component.

Overload List

Gets the name of the class for the specified component.

[Visual Basic] Overloads Public Shared Function GetClassName(Object) As String
[C#] public static string GetClassName(Object);
[C++] public: static String* GetClassName(Object*);
[JScript] public static function GetClassName(Object) : String;

Gets the name of the class for the specified component using the custom type descriptor when fNoCustomTypeDesc

is false.

[Visual Basic] Overloads Public Shared Function GetClassName(Object, Boolean) As String
[C#] public static string GetClassName(Object, bool);
[C++] public: static String* GetClassName(Object*, bool);
[JScript] public static function GetClassName(Object, Boolean) : String;

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace


TypeDescriptor.GetClassName (Object)

Gets the name of the class for the specified component.

[Visual Basic]
Overloads Public Shared Function GetClassName( _
   ByVal component As Object _
) As String
[C#]
public static string GetClassName(
   object component
);
[C++]
public: static String* GetClassName(
   Object* component
);
[JScript]
public static function GetClassName(
   component : Object
) : String;

Parameters

component
The Object whose class name you want.

Return Value

The name of the class for the specified component.

Remarks

Typically, this returns the full Type name for the component's type. If the component implements ICustomTypeDescriptor, it can return an alternate name.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.GetClassName Overload List | TypeDescriptor | EventDescriptor | PropertyDescriptor


TypeDescriptor.GetClassName (Object, Boolean)

Gets the name of the class for the specified component using the custom type descriptor when fNoCustomTypeDesc

is false.

[Visual Basic]
Overloads Public Shared Function GetClassName( _
   ByVal component As Object, _
   ByVal fNoCustomTypeDesc As Boolean _
) As String
[C#]
public static string GetClassName(
   object component,
   bool fNoCustomTypeDesc
);
[C++]
public: static String* GetClassName(
   Object* component,
   bool fNoCustomTypeDesc
);
[JScript]
public static function GetClassName(
   component : Object,
   fNoCustomTypeDesc : Boolean
) : String;

Parameters

component
The Object whose class name you want.
fNoCustomTypeDesc
true if TypeDescriptor has been called by an instance of ICustomTypeDescriptor; otherwise, false.

Return Value

The name of the class for the specified component.

Remarks

Typically, this returns the full Type name for the component's type. If the component implements ICustomTypeDescriptor, it can return an alternate name.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.GetClassName Overload List | TypeDescriptor | EventDescriptor | PropertyDescriptor | ICustomTypeDescriptor


TypeDescriptor.GetComponentName

Gets the name of the class for the specified component.

Overload List

The name of the class for the specified component.

[Visual Basic] Overloads Public Shared Function GetComponentName(Object) As String
[C#] public static string GetComponentName(Object);
[C++] public: static String* GetComponentName(Object*);
[JScript] public static function GetComponentName(Object) : String;

Gets the name of the class for the specified component.

[Visual Basic] Overloads Public Shared Function GetComponentName(Object, Boolean) As String
[C#] public static string GetComponentName(Object, bool);
[C++] public: static String* GetComponentName(Object*, bool);
[JScript] public static function GetComponentName(Object, Boolean) : String;

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace


TypeDescriptor.GetComponentName (Object)

The name of the class for the specified component.

[Visual Basic]
Overloads Public Shared Function GetComponentName( _
   ByVal component As Object _
) As String
[C#]
public static string GetComponentName(
   object component
);
[C++]
public: static String* GetComponentName(
   Object* component
);
[JScript]
public static function GetComponentName(
   component : Object
) : String;

Parameters

component
The Object whose class name you want.

Return Value

The name of the class name of the object.

Remarks

Typically, this method returns the name for the site of the component, if one exists. If the component

implements ICustomTypeDescriptor, it can return an alternate name.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.GetComponentName Overload List | TypeDescriptor | EventDescriptor | PropertyDescriptor


TypeDescriptor.GetComponentName (Object, Boolean)

Gets the name of the class for the specified component.

[Visual Basic]
Overloads Public Shared Function GetComponentName( _
   ByVal component As Object, _
   ByVal fNoCustomTypeDesc As Boolean _
) As String
[C#]
public static string GetComponentName(
   object component,
   bool fNoCustomTypeDesc
);
[C++]
public: static String* GetComponentName(
   Object* component,
   bool fNoCustomTypeDesc
);
[JScript]
public static function GetComponentName(
   component : Object,
   fNoCustomTypeDesc : Boolean
) : String;

Parameters

component
The Object whose class name you want.
fNoCustomTypeDesc
true if TypeDescriptor has been called by an instance of ICustomTypeDescriptor; otherwise, false.

Return Value

The name of the class for the specified component.

Remarks

Typically, this returns the name for the site of the component, if one exists. If the component

implements ICustomTypeDescriptor, it can return an alternate name.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.GetComponentName Overload List | TypeDescriptor | EventDescriptor | PropertyDescriptor | ICustomTypeDescriptor


TypeDescriptor.GetConverter

Gets a type converter for a component.

Overload List

Gets a type converter for the type of the specified component.

[Visual Basic] Overloads Public Shared Function GetConverter(Object) As TypeConverter
[C#] public static TypeConverter GetConverter(Object);
[C++] public: static TypeConverter* GetConverter(Object*);
[JScript] public static function GetConverter(Object) : TypeConverter;

Gets a converter for the type of the specified component.

[Visual Basic] Overloads Public Shared Function GetConverter(Object, Boolean) As TypeConverter
[C#] public static TypeConverter GetConverter(Object, bool);
[C++] public: static TypeConverter* GetConverter(Object*, bool);
[JScript] public static function GetConverter(Object, Boolean) : TypeConverter;

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace


TypeDescriptor.GetConverter (Object)

Gets a type converter for the type of the specified component.

[Visual Basic]
Overloads Public Shared Function GetConverter( _
   ByVal component As Object _
) As TypeConverter
[C#]
public static TypeConverter GetConverter(
   object component
);
[C++]
public: static TypeConverter* GetConverter(
   Object* component
);
[JScript]
public static function GetConverter(
   component : Object
) : TypeConverter;

Parameters

component
A component to get the converter for.

Return Value

A TypeConverter for the specified component, or a null reference (in Visual Basic Nothing) if a TypeConverter cannot be found.

Exceptions

Exception Type | Condition
ArgumentNullException | Specified component is a null reference (Nothing).

Remarks

This method looks for the appropriate type converter by looking for a TypeConverterAttribute. If it cannot find a TypeConverterAttribute, it traverses the base class hierarchy of the class until a primitive type is found.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.GetConverter Overload List | TypeDescriptor | EventDescriptor | PropertyDescriptor


TypeDescriptor.GetConverter (Object, Boolean)

Gets a converter for the type of the specified component.

[Visual Basic]
Overloads Public Shared Function GetConverter( _
   ByVal component As Object, _
   ByVal fNoCustomTypeDesc As Boolean _
) As TypeConverter
[C#]
public static TypeConverter GetConverter(
   object component,
   bool fNoCustomTypeDesc
);
[C++]
public: static TypeConverter* GetConverter(
   Object* component,
   bool fNoCustomTypeDesc
);
[JScript]
public static function GetConverter(
   component : Object,
   fNoCustomTypeDesc : Boolean
) : TypeConverter;

Parameters

component
A component to get the converter for.
fNoCustomTypeDesc
true if TypeDescriptor has been called by an instance of ICustomTypeDescriptor; otherwise, false.

Return Value

A TypeConverter for the specified component, or a null reference (in Visual Basic Nothing) if a TypeConverter cannot be found.

Exceptions

Exception Type | Condition
ArgumentNullException | Specified component is a null reference (Nothing).

Remarks

This method looks for the appropriate type converter by looking for a TypeConverterAttribute. If it cannot find a TypeConverterAttribute, it traverses the base class hierarchy of the class until a primitive type is found.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.GetConverter Overload List | TypeDescriptor | EventDescriptor | PropertyDescriptor | ICustomTypeDescriptor


TypeDescriptor.GetDefaultEvent

Gets the default event for a component.

Overload List

Gets the default event for a component.

[Visual Basic] Overloads Public Shared Function GetDefaultEvent(Object, Boolean) As EventDescriptor
[C#] public static EventDescriptor GetDefaultEvent(Object, bool);
[C++] public: static EventDescriptor* GetDefaultEvent(Object*, bool);
[JScript] public static function GetDefaultEvent(Object, Boolean) : EventDescriptor;

Gets the default event for the specified component.

[Visual Basic] Overloads Public Shared Function GetDefaultEvent(Object) As EventDescriptor
[C#] public static EventDescriptor GetDefaultEvent(Object);
[C++] public: static EventDescriptor* GetDefaultEvent(Object*);
[JScript] public static function GetDefaultEvent(Object) : EventDescriptor;

Gets the default event for the specified type of component.

[Visual Basic] Overloads Public Shared Function GetDefaultEvent(Type) As EventDescriptor
[C#] public static EventDescriptor GetDefaultEvent(Type);
[C++] public: static EventDescriptor* GetDefaultEvent(Type*);
[JScript] public static function GetDefaultEvent(Type) : EventDescriptor;

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace


TypeDescriptor.GetDefaultEvent (Object, Boolean)

Gets the default event for a component.

[Visual Basic]
Overloads Public Shared Function GetDefaultEvent( _
   ByVal component As Object, _
   ByVal fNoCustomTypeDesc As Boolean _
) As EventDescriptor
[C#]
public static EventDescriptor GetDefaultEvent(
   object component,
   bool fNoCustomTypeDesc
);
[C++]
public: static EventDescriptor* GetDefaultEvent(
   Object* component,
   bool fNoCustomTypeDesc
);
[JScript]
public static function GetDefaultEvent(
   component : Object,
   fNoCustomTypeDesc : Boolean
) : EventDescriptor;

Parameters

component
The component to get the event for.
fNoCustomTypeDesc
[To be supplied.]

Return Value

An EventDescriptor with the default event, or a null reference (in Visual Basic Nothing) if there are no events.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.GetDefaultEvent Overload List | TypeDescriptor | EventDescriptor | PropertyDescriptor | ICustomTypeDescriptor


TypeDescriptor.GetDefaultEvent (Object)

Gets the default event for the specified component.

[Visual Basic]
Overloads Public Shared Function GetDefaultEvent( _
   ByVal component As Object _
) As EventDescriptor
[C#]
public static EventDescriptor GetDefaultEvent(
   object component
);
[C++]
public: static EventDescriptor* GetDefaultEvent(
   Object* component
);
[JScript]
public static function GetDefaultEvent(
   component : Object
) : EventDescriptor;

Parameters

component
The component to get the event for.

Return Value

An EventDescriptor with the default event, or a null reference (in Visual Basic Nothing) if there are no events.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.GetDefaultEvent Overload List | TypeDescriptor | EventDescriptor | PropertyDescriptor


TypeDescriptor.GetDefaultEvent (Type)

Gets the default event for the specified type of component.

[Visual Basic]
Overloads Public Shared Function GetDefaultEvent( _
   ByVal componentType As Type _
) As EventDescriptor
[C#]
public static EventDescriptor GetDefaultEvent(
   Type componentType
);
[C++]
public: static EventDescriptor* GetDefaultEvent(
   Type* componentType
);
[JScript]
public static function GetDefaultEvent(
   componentType : Type
) : EventDescriptor;

Parameters

componentType
A Type that represents the type of component to get the event for.

Return Value

An EventDescriptor with the default event, or a null reference (in Visual Basic Nothing) if there are no events.

Remarks

Call this version of this method only when you do not have an instance of the object.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.GetDefaultEvent Overload List | TypeDescriptor | EventDescriptor | PropertyDescriptor


TypeDescriptor.GetDefaultProperty

Gets the default property for a component.

Overload List

Gets the default property for the specified type of component.

[Visual Basic] Overloads Public Shared Function GetDefaultProperty(Type) As PropertyDescriptor
[C#] public static PropertyDescriptor GetDefaultProperty(Type);
[C++] public: static PropertyDescriptor* GetDefaultProperty(Type*);
[JScript] public static function GetDefaultProperty(Type) : PropertyDescriptor;

Gets the default property for the specified component.

[Visual Basic] Overloads Public Shared Function GetDefaultProperty(Object) As PropertyDescriptor
[C#] public static PropertyDescriptor GetDefaultProperty(Object);
[C++] public: static PropertyDescriptor* GetDefaultProperty(Object*);
[JScript] public static function GetDefaultProperty(Object) : PropertyDescriptor;

Gets the default property for the specified component.

[Visual Basic] Overloads Public Shared Function GetDefaultProperty(Object, Boolean) As PropertyDescriptor
[C#] public static PropertyDescriptor GetDefaultProperty(Object, bool);
[C++] public: static PropertyDescriptor* GetDefaultProperty(Object*, bool);
[JScript] public static function GetDefaultProperty(Object, Boolean) : PropertyDescriptor;

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace


TypeDescriptor.GetDefaultProperty (Type)

Gets the default property for the specified type of component.

[Visual Basic]
Overloads Public Shared Function GetDefaultProperty( _
   ByVal componentType As Type _
) As PropertyDescriptor
[C#]
public static PropertyDescriptor GetDefaultProperty(
   Type componentType
);
[C++]
public: static PropertyDescriptor* GetDefaultProperty(
   Type* componentType
);
[JScript]
public static function GetDefaultProperty(
   componentType : Type
) : PropertyDescriptor;

Parameters

componentType
A Type that represents the class to get the property for.

Return Value

A PropertyDescriptor with the default property, or a null reference (in Visual Basic Nothing) if there are no properties.

Remarks

Call this version of this method only when you do not have an instance of the object.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.GetDefaultProperty Overload List | TypeDescriptor | EventDescriptor | PropertyDescriptor


TypeDescriptor.GetDefaultProperty (Object)

Gets the default property for the specified component.

[Visual Basic]
Overloads Public Shared Function GetDefaultProperty( _
   ByVal component As Object _
) As PropertyDescriptor
[C#]
public static PropertyDescriptor GetDefaultProperty(
   object component
);
[C++]
public: static PropertyDescriptor* GetDefaultProperty(
   Object* component
);
[JScript]
public static function GetDefaultProperty(
   component : Object
) : PropertyDescriptor;

Parameters

component
The component to get the default property for.

Return Value

A PropertyDescriptor with the default property, or a null reference (in Visual Basic Nothing) if there are no properties.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.GetDefaultProperty Overload List | TypeDescriptor | EventDescriptor | PropertyDescriptor


TypeDescriptor.GetDefaultProperty (Object, Boolean)

Gets the default property for the specified component.

[Visual Basic]
Overloads Public Shared Function GetDefaultProperty( _
   ByVal component As Object, _
   ByVal fNoCustomTypeDesc As Boolean _
) As PropertyDescriptor
[C#]
public static PropertyDescriptor GetDefaultProperty(
   object component,
   bool fNoCustomTypeDesc
);
[C++]
public: static PropertyDescriptor* GetDefaultProperty(
   Object* component,
   bool fNoCustomTypeDesc
);
[JScript]
public static function GetDefaultProperty(
   component : Object,
   fNoCustomTypeDesc : Boolean
) : PropertyDescriptor;

Parameters

component
The component to get the default property for.
fNoCustomTypeDesc
[To be supplied.]

Return Value

A PropertyDescriptor with the default property, or a null reference (in Visual Basic Nothing) if there are no properties.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.GetDefaultProperty Overload List | TypeDescriptor | EventDescriptor | PropertyDescriptor | ICustomTypeDescriptor


TypeDescriptor.GetEditor

Gets an editor with the specified base type.

Overload List

Gets an editor with the specified base type for the specified component.

[Visual Basic] Overloads Public Shared Function GetEditor(Object, Type, Boolean) As Object
[C#] public static object GetEditor(Object, Type, bool);
[C++] public: static Object* GetEditor(Object*, Type, bool);
[JScript] public static function GetEditor(Object, Type, Boolean) : Object;

Gets an editor with the specified base type for the specified component.

[Visual Basic] Overloads Public Shared Function GetEditor(Object, Type) As Object
[C#] public static object GetEditor(Object, Type);
[C++] public: static Object* GetEditor(Object*, Type);
[JScript] public static function GetEditor(Object, Type) : Object;

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace


TypeDescriptor.GetEditor (Object, Type, Boolean)

Gets an editor with the specified base type for the specified component.

[Visual Basic]
Overloads Public Shared Function GetEditor( _
   ByVal component As Object, _
   ByVal editorBaseType As Type, _
   ByVal fNoCustomTypeDesc As Boolean _
) As Object
[C#]
public static object GetEditor(
   object component,
   Type editorBaseType,
   bool fNoCustomTypeDesc
);
[C++]
public: static Object* GetEditor(
   Object* component,
   Type* editorBaseType,
   bool fNoCustomTypeDesc
);
[JScript]
public static function GetEditor(
   component : Object,
   editorBaseType : Type,
   fNoCustomTypeDesc : Boolean
) : Object;

Parameters

component
The component to get the editor for.
editorBaseType
A Type that represents the base type of the editor you want to find.
fNoCustomTypeDesc
true if TypeDescriptor has been called by an instance of ICustomTypeDescriptor; otherwise, false.

Return Value

An instance of the editor that can be typecast to the specified editorBaseType. This returns a null reference (in Visual Basic Nothing) if no editor of the requested type can be found.

Remarks

You can define multiple editors for a property. This method allows you to select which editor you want to use.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.GetEditor Overload List | TypeDescriptor | EventDescriptor | PropertyDescriptor | ICustomTypeDescriptor


TypeDescriptor.GetEditor (Object, Type)

Gets an editor with the specified base type for the specified component.

[Visual Basic]
Overloads Public Shared Function GetEditor( _
   ByVal component As Object, _
   ByVal editorBaseType As Type _
) As Object
[C#]
public static object GetEditor(
   object component,
   Type editorBaseType
);
[C++]
public: static Object* GetEditor(
   Object* component,
   Type* editorBaseType
);
[JScript]
public static function GetEditor(
   component : Object,
   editorBaseType : Type
) : Object;

Parameters

component
The component to get the editor for.
editorBaseType
A Type that represents the base type of the editor you want to find.

Return Value

An instance of the editor that can be type cast to the specified editorBaseType. This returns a null reference (in Visual Basic Nothing) if no editor of the requested type can be found.

Remarks

You can define multiple editors for a property. This method allows you to select which editor you want to use.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.GetEditor Overload List | TypeDescriptor | EventDescriptor | PropertyDescriptor


TypeDescriptor.GetEvents

Gets a collection of events.

Overload List

Gets a collection of events for a specified component.

[Visual Basic] Overloads Public Shared Function GetEvents(Object) As EventDescriptorCollection
[C#] public static EventDescriptorCollection GetEvents(Object);
[C++] public: static EventDescriptorCollection* GetEvents(Object*);
[JScript] public static function GetEvents(Object) : EventDescriptorCollection;

Gets a collection of events for a specified component.

[Visual Basic] Overloads Public Shared Function GetEvents(Object, Boolean) As EventDescriptorCollection
[C#] public static EventDescriptorCollection GetEvents(Object, bool);
[C++] public: static EventDescriptorCollection* GetEvents(Object*, bool);
[JScript] public static function GetEvents(Object, Boolean) : EventDescriptorCollection;

Gets a collection of events for a specified type of component using a specified array of attributes as a filter.

[Visual Basic] Overloads Public Shared Function GetEvents(Type, MemberAttribute()) As EventDescriptorCollection
[C#] public static EventDescriptorCollection GetEvents(Type, MemberAttribute[]);
[C++] public: static EventDescriptorCollection* GetEvents(Type*, MemberAttribute[]);
[JScript] public static function GetEvents(Type, MemberAttribute[]) : EventDescriptorCollection;

Gets a collection of events for a specified component using a specified array of attributes

as a filter.

[Visual Basic] Overloads Public Shared Function GetEvents(Object, MemberAttribute(), Boolean) As EventDescriptorCollection
[C#] public static EventDescriptorCollection GetEvents(Object, MemberAttribute[], bool);
[C++] public: static EventDescriptorCollection* GetEvents(Object*, MemberAttribute[], bool);
[JScript] public static function GetEvents(Object, MemberAttribute[], Boolean) : EventDescriptorCollection;

Gets a collection of events for a specified component using a specified array of attributes as a filter.

[Visual Basic] Overloads Public Shared Function GetEvents(Object, MemberAttribute()) As EventDescriptorCollection
[C#] public static EventDescriptorCollection GetEvents(Object, MemberAttribute[]);
[C++] public: static EventDescriptorCollection* GetEvents(Object*, MemberAttribute[]);
[JScript] public static function GetEvents(Object, MemberAttribute[]) : EventDescriptorCollection;

Gets a collection of events for a specified type of component.

[Visual Basic] Overloads Public Shared Function GetEvents(Type) As EventDescriptorCollection
[C#] public static EventDescriptorCollection GetEvents(Type);
[C++] public: static EventDescriptorCollection* GetEvents(Type*);
[JScript] public static function GetEvents(Type) : EventDescriptorCollection;

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace


TypeDescriptor.GetEvents (Object)

Gets a collection of events for a specified component.

[Visual Basic]
Overloads Public Shared Function GetEvents( _
   ByVal component As Object _
) As EventDescriptorCollection
[C#]
public static EventDescriptorCollection GetEvents(
   object component
);
[C++]
public: static EventDescriptorCollection* GetEvents(
   Object* component
);
[JScript]
public static function GetEvents(
   component : Object
) : EventDescriptorCollection;

Parameters

component
A component to get the events for.

Return Value

An EventDescriptorCollection with the events for this component.

Remarks

Retrieves an array of events that the given component instance provides. This can differ from the set of events the class provides. If the component is sited, the site may add or remove additional events.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.GetEvents Overload List | TypeDescriptor | EventDescriptor | EventDescriptorCollection | PropertyDescriptor


TypeDescriptor.GetEvents (Object, Boolean)

Gets a collection of events for a specified component.

[Visual Basic]
Overloads Public Shared Function GetEvents( _
   ByVal component As Object, _
   ByVal fNoCustomTypeDesc As Boolean _
) As EventDescriptorCollection
[C#]
public static EventDescriptorCollection GetEvents(
   object component,
   bool fNoCustomTypeDesc
);
[C++]
public: static EventDescriptorCollection* GetEvents(
   Object* component,
   bool fNoCustomTypeDesc
);
[JScript]
public static function GetEvents(
   component : Object,
   fNoCustomTypeDesc : Boolean
) : EventDescriptorCollection;

Parameters

component
A component to get the events for.
fNoCustomTypeDesc
true if TypeDescriptor has been called by an instance of ICustomTypeDescriptor; otherwise, false.

Return Value

An EventDescriptorCollection with the events for this component.

Remarks

Retrieves an array of events that the given component instance provides. This can differ from the set of events the class provides. If the component is sited, the site can add or remove additional events.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.GetEvents Overload List | TypeDescriptor | EventDescriptor | EventDescriptorCollection | PropertyDescriptor | ICustomTypeDescriptor


TypeDescriptor.GetEvents (Type, MemberAttribute[])

Gets a collection of events for a specified type of component using a specified array of attributes as a filter.

[Visual Basic]
Overloads Public Shared Function GetEvents( _
   ByVal componentType As Type, _
   ByVal attributes() As MemberAttribute _
) As EventDescriptorCollection
[C#]
public static EventDescriptorCollection GetEvents(
   Type componentType,
   MemberAttribute[] attributes
);
[C++]
public: static EventDescriptorCollection* GetEvents(
   Type* componentType,
   MemberAttribute* attributes[]
);
[JScript]
public static function GetEvents(
   componentType : Type,
   attributes : MemberAttribute[]
) : EventDescriptorCollection;

Parameters

componentType
A Type that represents the component to get events for.
attributes
An array of type MemberAttribute that will be used as a filter.

Return Value

An EventDescriptorCollection with the events that match the specified attributes for this component.

Remarks

Call this version of this method only when you do not have an instance of the object.

The attributes array can have a mix of Type and MemberAttribute objects. Filtering is defined by the following rules:

  • A Type object will be treated as a wildcard; it will match any event that has the Type in its set of attributes.
  • If an event does not have an Attribute of the same class, the event will not be included in the returned array.
  • If the attribute is an instance of MemberAttribute, the event must be an exact match or it will not be included in the returned array.
  • If a MemberAttribute instance is specified and it is the default event, it will be included in the returned array even if there is no instance of the MemberAttribute in the event.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.GetEvents Overload List | TypeDescriptor | EventDescriptor | EventDescriptorCollection | PropertyDescriptor | MemberAttribute


TypeDescriptor.GetEvents (Object, MemberAttribute[], Boolean)

Gets a collection of events for a specified component using a specified array of attributes

as a filter.

[Visual Basic]
Overloads Public Shared Function GetEvents( _
   ByVal component As Object, _
   ByVal attributes() As MemberAttribute, _
   ByVal fNoCustomTypeDesc As Boolean _
) As EventDescriptorCollection
[C#]
public static EventDescriptorCollection GetEvents(
   object component,
   MemberAttribute[] attributes,
   bool fNoCustomTypeDesc
);
[C++]
public: static EventDescriptorCollection* GetEvents(
   Object* component,
   MemberAttribute* attributes[],
   bool fNoCustomTypeDesc
);
[JScript]
public static function GetEvents(
   component : Object,
   attributes : MemberAttribute[],
   fNoCustomTypeDesc : Boolean
) : EventDescriptorCollection;

Parameters

component
A component to get the events for.
attributes
An array of type MemberAttribute that will be used as a filter.
fNoCustomTypeDesc
true if TypeDescriptor has been called by an instance of ICustomTypeDescriptor; otherwise, false.

Return Value

An EventDescriptorCollection with the events that match the specified attributes for this component.

Remarks

The events for a component can differ from the events of a class, because if the component is sited, the site can add or remove events.

The attributes array can have a mix of Type and MemberAttribute objects. Filtering is defined by the following rules:

  • A Type object will be treated as a wildcard; it will match any event that has the Type in its set of attributes.
  • If an event does not have an Attribute of the same class, the event will not be included in the returned array.
  • If the attribute is an instance of MemberAttribute, the event must be an exact match or it will not be included in the returned array.
  • If a MemberAttribute instance is specified and it is the default event, it will be included in the returned array even if there is no instance of the MemberAttribute in the event.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.GetEvents Overload List | TypeDescriptor | EventDescriptor | EventDescriptorCollection | PropertyDescriptor | MemberAttribute | ICustomTypeDescriptor


TypeDescriptor.GetEvents (Object, MemberAttribute[])

Gets a collection of events for a specified component using a specified array of attributes as a filter.

[Visual Basic]
Overloads Public Shared Function GetEvents( _
   ByVal component As Object, _
   ByVal attributes() As MemberAttribute _
) As EventDescriptorCollection
[C#]
public static EventDescriptorCollection GetEvents(
   object component,
   MemberAttribute[] attributes
);
[C++]
public: static EventDescriptorCollection* GetEvents(
   Object* component,
   MemberAttribute* attributes[]
);
[JScript]
public static function GetEvents(
   component : Object,
   attributes : MemberAttribute[]
) : EventDescriptorCollection;

Parameters

component
A component to get the events for.
attributes
An array of type MemberAttribute that will be used as a filter.

Return Value

An EventDescriptorCollection with the events that match the specified attributes for this component.

Remarks

The events for a component can differ from the events of a class, because if the component is sited, the site can add or remove events.

The attributes array can have a mix of Type and MemberAttribute objects. Filtering is defined by the following rules:

  • A Type object will be treated as a wildcard; it will match any event that has the Type in its set of attributes.
  • If an event does not have an Attribute of the same class, the event will not be included in the returned array.
  • If the attribute is an instance of MemberAttribute, the event must be an exact match or it will not be included in the returned array.
  • If a MemberAttribute instance is specified and it is the default event, it will be included in the returned array even if there is no instance of the MemberAttribute in the event.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.GetEvents Overload List | TypeDescriptor | EventDescriptor | EventDescriptorCollection | PropertyDescriptor | MemberAttribute


TypeDescriptor.GetEvents (Type)

Gets a collection of events for a specified type of component.

[Visual Basic]
Overloads Public Shared Function GetEvents( _
   ByVal componentType As Type _
) As EventDescriptorCollection
[C#]
public static EventDescriptorCollection GetEvents(
   Type componentType
);
[C++]
public: static EventDescriptorCollection* GetEvents(
   Type* componentType
);
[JScript]
public static function GetEvents(
   componentType : Type
) : EventDescriptorCollection;

Parameters

componentType
A Type that represents the component to get events for.

Return Value

An EventDescriptorCollection with the events for this component.

Remarks

Call this version of this method only when you do not have an instance of the object.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.GetEvents Overload List | TypeDescriptor | EventDescriptor | EventDescriptorCollection | PropertyDescriptor


TypeDescriptor.GetProperties

Gets a collection of properties.

Overload List

Gets a collection of properties for a specified component.

[Visual Basic] Overloads Public Shared Function GetProperties(Object, Boolean) As PropertyDescriptorCollection
[C#] public static PropertyDescriptorCollection GetProperties(Object, bool);
[C++] public: static PropertyDescriptorCollection* GetProperties(Object*, bool);
[JScript] public static function GetProperties(Object, Boolean) : PropertyDescriptorCollection;

Gets a collection of properties for a specified component.

[Visual Basic] Overloads Public Shared Function GetProperties(Object) As PropertyDescriptorCollection
[C#] public static PropertyDescriptorCollection GetProperties(Object);
[C++] public: static PropertyDescriptorCollection* GetProperties(Object*);
[JScript] public static function GetProperties(Object) : PropertyDescriptorCollection;

Gets a collection of properties for a specified type of component using a specified array of attributes as a filter.

[Visual Basic] Overloads Public Shared Function GetProperties(Type, MemberAttribute()) As PropertyDescriptorCollection
[C#] public static PropertyDescriptorCollection GetProperties(Type, MemberAttribute[]);
[C++] public: static PropertyDescriptorCollection* GetProperties(Type*, MemberAttribute[]);
[JScript] public static function GetProperties(Type, MemberAttribute[]) : PropertyDescriptorCollection;

Gets a collection of properties for a specified component using a specified array of attributes

as a filter.

[Visual Basic] Overloads Public Shared Function GetProperties(Object, MemberAttribute(), Boolean) As PropertyDescriptorCollection
[C#] public static PropertyDescriptorCollection GetProperties(Object, MemberAttribute[], bool);
[C++] public: static PropertyDescriptorCollection* GetProperties(Object*, MemberAttribute[], bool);
[JScript] public static function GetProperties(Object, MemberAttribute[], Boolean) : PropertyDescriptorCollection;

Gets a collection of properties for a specified component using a specified array of attributes

as a filter.

[Visual Basic] Overloads Public Shared Function GetProperties(Object, MemberAttribute()) As PropertyDescriptorCollection
[C#] public static PropertyDescriptorCollection GetProperties(Object, MemberAttribute[]);
[C++] public: static PropertyDescriptorCollection* GetProperties(Object*, MemberAttribute[]);
[JScript] public static function GetProperties(Object, MemberAttribute[]) : PropertyDescriptorCollection;

Gets a collection of properties for a specified type of component.

[Visual Basic] Overloads Public Shared Function GetProperties(Type) As PropertyDescriptorCollection
[C#] public static PropertyDescriptorCollection GetProperties(Type);
[C++] public: static PropertyDescriptorCollection* GetProperties(Type*);
[JScript] public static function GetProperties(Type) : PropertyDescriptorCollection;

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace


TypeDescriptor.GetProperties (Object, Boolean)

Gets a collection of properties for a specified component.

[Visual Basic]
Overloads Public Shared Function GetProperties( _
   ByVal component As Object, _
   ByVal fNoCustomTypeDesc As Boolean _
) As PropertyDescriptorCollection
[C#]
public static PropertyDescriptorCollection GetProperties(
   object component,
   bool fNoCustomTypeDesc
);
[C++]
public: static PropertyDescriptorCollection* GetProperties(
   Object* component,
   bool fNoCustomTypeDesc
);
[JScript]
public static function GetProperties(
   component : Object,
   fNoCustomTypeDesc : Boolean
) : PropertyDescriptorCollection;

Parameters

component
A component to get the properties for.
fNoCustomTypeDesc
true if TypeDescriptor has been called by an instance of ICustomTypeDescriptor; otherwise, false.

Return Value

A PropertyDescriptorCollection with the properties for a specified component.

Remarks

The properties for a component can differ from the properties of a class, because if the component is sited, the site can add or remove properties.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.GetProperties Overload List | TypeDescriptor | EventDescriptor | PropertyDescriptor | PropertyDescriptorCollection | ICustomTypeDescriptor


TypeDescriptor.GetProperties (Object)

Gets a collection of properties for a specified component.

[Visual Basic]
Overloads Public Shared Function GetProperties( _
   ByVal component As Object _
) As PropertyDescriptorCollection
[C#]
public static PropertyDescriptorCollection GetProperties(
   object component
);
[C++]
public: static PropertyDescriptorCollection* GetProperties(
   Object* component
);
[JScript]
public static function GetProperties(
   component : Object
) : PropertyDescriptorCollection;

Parameters

component
A component to get the properties for.

Return Value

A PropertyDescriptorCollection with the properties for the specified component.

Remarks

The properties for a component can differ from the properties of a class, because if the component is sited, the site can add or remove properties.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.GetProperties Overload List | TypeDescriptor | EventDescriptor | PropertyDescriptor | PropertyDescriptorCollection


TypeDescriptor.GetProperties (Type, MemberAttribute[])

Gets a collection of properties for a specified type of component using a specified array of attributes as a filter.

[Visual Basic]
Overloads Public Shared Function GetProperties( _
   ByVal componentType As Type, _
   ByVal attributes() As MemberAttribute _
) As PropertyDescriptorCollection
[C#]
public static PropertyDescriptorCollection GetProperties(
   Type componentType,
   MemberAttribute[] attributes
);
[C++]
public: static PropertyDescriptorCollection* GetProperties(
   Type* componentType,
   MemberAttribute* attributes[]
);
[JScript]
public static function GetProperties(
   componentType : Type,
   attributes : MemberAttribute[]
) : PropertyDescriptorCollection;

Parameters

componentType
A Type that represents the component to get properties for.
attributes
An array of type MemberAttribute to use as a filter.

Return Value

A PropertyDescriptorCollection with the properties that match the specified attributes for this type of component.

Remarks

Call this version of this method only when you do not have an instance of the object.

The attributes array can have a mix of Type and MemberAttribute objects. Filtering is defined by the following rules:

  • A Type object will be treated as a wildcard; it will match any property that has the Type in its set of attributes.
  • If a property does not have an Attribute of the same class, the property will not be included in the returned array.
  • If the attribute is an instance of MemberAttribute, the property must be an exact match or it will not be included in the returned array.
  • If a MemberAttribute instance is specified and it is the default property, it will be included in the returned array even if there is no instance of the MemberAttribute in the property.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.GetProperties Overload List | TypeDescriptor | EventDescriptor | PropertyDescriptor | PropertyDescriptorCollection | MemberAttribute


TypeDescriptor.GetProperties (Object, MemberAttribute[], Boolean)

Gets a collection of properties for a specified component using a specified array of attributes

as a filter.

[Visual Basic]
Overloads Public Shared Function GetProperties( _
   ByVal component As Object, _
   ByVal attributes() As MemberAttribute, _
   ByVal fNoCustomTypeDesc As Boolean _
) As PropertyDescriptorCollection
[C#]
public static PropertyDescriptorCollection GetProperties(
   object component,
   MemberAttribute[] attributes,
   bool fNoCustomTypeDesc
);
[C++]
public: static PropertyDescriptorCollection* GetProperties(
   Object* component,
   MemberAttribute* attributes[],
   bool fNoCustomTypeDesc
);
[JScript]
public static function GetProperties(
   component : Object,
   attributes : MemberAttribute[],
   fNoCustomTypeDesc : Boolean
) : PropertyDescriptorCollection;

Parameters

component
A component to get the properties for.
attributes
An array of type MemberAttribute to use as a filter.
fNoCustomTypeDesc
true if TypeDescriptor has been called by an instance of ICustomTypeDescriptor; otherwise, false.

Return Value

A PropertyDescriptorCollection with the events that match the specified attributes for the specified component.

Remarks

The properties for a component can differ from the properties of a class, because if the component is sited, the site may add or remove properties.

The attributes array can have a mix of Type and MemberAttribute objects. Filtering is defined by the following rules:

  • A Type object will be treated as a wildcard; it will match any property that has the Type in its set of attributes.
  • If a property does not have an Attribute of the same class, the property will not be included in the returned array.
  • If the attribute is an instance of MemberAttribute, the property must be an exact match or it will not be included in the returned array.
  • If a MemberAttribute instance is specified and it is the default property, it will be included in the returned array even if there is no instance of the MemberAttribute in the property.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.GetProperties Overload List | TypeDescriptor | EventDescriptor | PropertyDescriptor | PropertyDescriptorCollection | MemberAttribute | ICustomTypeDescriptor


TypeDescriptor.GetProperties (Object, MemberAttribute[])

Gets a collection of properties for a specified component using a specified array of attributes

as a filter.

[Visual Basic]
Overloads Public Shared Function GetProperties( _
   ByVal component As Object, _
   ByVal attributes() As MemberAttribute _
) As PropertyDescriptorCollection
[C#]
public static PropertyDescriptorCollection GetProperties(
   object component,
   MemberAttribute[] attributes
);
[C++]
public: static PropertyDescriptorCollection* GetProperties(
   Object* component,
   MemberAttribute* attributes[]
);
[JScript]
public static function GetProperties(
   component : Object,
   attributes : MemberAttribute[]
) : PropertyDescriptorCollection;

Parameters

component
A component to get the properties for.
attributes
An array of type MemberAttribute to use as a filter.

Return Value

A PropertyDescriptorCollection with the properties that match the specified attributes for the specified component.

Remarks

The properties for a component can differ from the properties of a class, because if the component is sited, the site can add or remove properties.

The attributes array can have a mix of Type and MemberAttribute objects. Filtering is defined by the following rules:

  • A Type object will be treated as a wildcard; it will match any property that has the Type in its set of attributes.
  • If a property does not have an Attribute of the same class, the property will not be included in the returned array.
  • If the attribute is an instance of MemberAttribute, the property must be an exact match or it will not be included in the returned array.
  • If a MemberAttribute instance is specified and it is the default property, it will be included in the returned array even if there is no instance of the MemberAttribute in the property.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.GetProperties Overload List | TypeDescriptor | EventDescriptor | PropertyDescriptor | PropertyDescriptorCollection | MemberAttribute


TypeDescriptor.GetProperties (Type)

Gets a collection of properties for a specified type of component.

[Visual Basic]
Overloads Public Shared Function GetProperties( _
   ByVal componentType As Type _
) As PropertyDescriptorCollection
[C#]
public static PropertyDescriptorCollection GetProperties(
   Type componentType
);
[C++]
public: static PropertyDescriptorCollection* GetProperties(
   Type* componentType
);
[JScript]
public static function GetProperties(
   componentType : Type
) : PropertyDescriptorCollection;

Parameters

componentType
A Type that represents the component to get properties for.

Return Value

A PropertyDescriptorCollection with the properties for a specified type of component.

Remarks

Call this version of this method only when you do not have an instance of the object.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.GetProperties Overload List | TypeDescriptor | EventDescriptor | PropertyDescriptor | PropertyDescriptorCollection


TypeDescriptor.Refresh

Clears the properties and events from the cache.

Overload List

Clears the properties and events for the specified type of component from the cache.

[Visual Basic] Overloads Public Shared Sub Refresh(Type)
[C#] public static void Refresh(Type);
[C++] public: static void Refresh(Type*);
[JScript] public static function Refresh(Type);

Clears the properties and events for the specified module from the cache.

[Visual Basic] Overloads Public Shared Sub Refresh(Module)
[C#] public static void Refresh(Module);
[C++] public: static void Refresh(Module*);
[JScript] public static function Refresh(Module);

Clears the properties and events for the specified component from the cache.

[Visual Basic] Overloads Public Shared Sub Refresh(Object)
[C#] public static void Refresh(Object);
[C++] public: static void Refresh(Object*);
[JScript] public static function Refresh(Object);

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace


TypeDescriptor.Refresh (Type)

Clears the properties and events for the specified type of component from the cache.

[Visual Basic]
Overloads Public Shared Sub Refresh( _
   ByVal type As Type _
)
[C#]
public static void Refresh(
   Type type
);
[C++]
public: static void Refresh(
   Type* type
);
[JScript]
public static function Refresh(
   type : Type
);

Parameters

type
A Type that represents the type whose properties or events have changed.

Remarks

Call this version of this method only when you do not have an instance of the object.

Properties and events are cached by TypeDescriptor for speed. Typically, they are constant for the lifetime of an object. However, extender providers and designers can change the set of properties on an object. If they do, they should call this method to clear the object's property and event descriptors. This method is used only at design time. It is not used during run time.This method will also raise an AddOnRefresh event to notify all classes that want to be notified when a component's property set changes.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.Refresh Overload List | TypeDescriptor | EventDescriptor | PropertyDescriptor | AddOnRefresh | RemoveOnRefresh


TypeDescriptor.Refresh (Module)

Clears the properties and events for the specified module from the cache.

[Visual Basic]
Overloads Public Shared Sub Refresh( _
   ByVal module As Module _
)
[C#]
public static void Refresh(
   Module module
);
[C++]
public: static void Refresh(
   Module* module
);
[JScript]
public static function Refresh(
   module : Module
);

Parameters

module
The Module that represents the module to refresh. Each Type in this module will be refreshed.

Remarks

Properties and events are cached by TypeDescriptor for speed. Typically, they are constant for the lifetime of an object. However, extender providers and designers can change the set of properties on an object. If they do, they should call this method to clear the object's property and event descriptors. This method is used only at design time. It is not used during run time.This method will also raise an AddOnRefresh event to notify all classes that want to be notified when a component's property set changes.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.Refresh Overload List | TypeDescriptor | EventDescriptor | PropertyDescriptor | AddOnRefresh | RemoveOnRefresh | Module


TypeDescriptor.Refresh (Object)

Clears the properties and events for the specified component from the cache.

[Visual Basic]
Overloads Public Shared Sub Refresh( _
   ByVal component As Object _
)
[C#]
public static void Refresh(
   object component
);
[C++]
public: static void Refresh(
   Object* component
);
[JScript]
public static function Refresh(
   component : Object
);

Parameters

component
A component whose properties or events have changed.

Remarks

Properties and events are cached by TypeDescriptor for speed. Typically, they are constant for the lifetime of an object. However, extender providers and designers can change the set of properties on an object. If they do, they should call this method to clear the object's property and event descriptors. This method is used only at design time. It is not used during run time.

This method will also raise an AddOnRefresh event to notify all classes that want to be notified when a component's property set changes.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor.Refresh Overload List | TypeDescriptor | EventDescriptor | PropertyDescriptor | AddOnRefresh | RemoveOnRefresh


TypeDescriptor.RemoveOnRefresh

Removes a previously added event handler for the AddOnRefresh event.

[Visual Basic]
Public Shared Sub RemoveOnRefresh( _
   ByVal handler As RefreshEventHandler _
)
[C#]
public static void RemoveOnRefresh(
   RefreshEventHandler handler
);
[C++]
public: static void RemoveOnRefresh(
   RefreshEventHandler* handler
);
[JScript]
public static function RemoveOnRefresh(
   handler : RefreshEventHandler
);

Parameters

handler
A RefreshEventHandler that specifies the event handler to remove.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor | EventDescriptor | PropertyDescriptor | Refresh | AddOnRefresh | RefreshEventHandler


TypeDescriptor.SortDescriptorArray

Sorts descriptors by name of the descriptor.

[Visual Basic]
Public Shared Sub SortDescriptorArray( _
   ByVal infos As IList _
)
[C#]
public static void SortDescriptorArray(
   IList infos
);
[C++]
public: static void SortDescriptorArray(
   IList* infos
);
[JScript]
public static function SortDescriptorArray(
   infos : IList
);

Parameters

infos
An IList that contains the descriptors to sort.

See Also

TypeDescriptor Class | TypeDescriptor Members | System.ComponentModel Namespace | TypeDescriptor | EventDescriptor | PropertyDescriptor | System.Reflection.IList


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypeDescriptor Events

The events of the TypeDescriptor class are listed below. For a complete list of TypeDescriptor class members, see the TypeDescriptor Members topic.

Public:

Refresh Occurs when Refresh XXX is raised for a component.

See Also

TypeDescriptor Class | System.ComponentModel Namespace


TypeListConverter Class

TypeListConverter is a class that can be used select type from a list. It is abstract, and you must provide your own list of types. rectangles from one data type to another. Access this class through the TypeDescriptor.

Object
TypeConverter
TypeListConverter

[Visual Basic]
MustInherit Public Class TypeListConverter
   Inherits TypeConverter
[C#]
public abstract class TypeListConverter : TypeConverter
[C++]
public __gc __abstract class TypeListConverter : public
   TypeConverter
[JScript]
public abstract class TypeListConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace


ValidatingEventArgs Class

[To be supplied.]

Object
ValidatingEventArgs

[Visual Basic]
Public Class ValidatingEventArgs
[C#]
public class ValidatingEventArgs
[C++]
public __gc class ValidatingEventArgs
[JScript]
public class ValidatingEventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

ValidatingEventArgs Members | System.ComponentModel Namespace


ValidatingEventArgs Members

Public:

Constructor

ValidatingEventArgs Constructor [To be supplied.]

Properties

ProposedValue | [To be supplied.]
Text | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ValidatingEventArgs Class | System.ComponentModel Namespace


ValidatingEventArgs Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal text As String _
)
[C#]
public ValidatingEventArgs(
   string text
);
[C++]
public: ValidatingEventArgs(
   String* text
);
[JScript]
public function ValidatingEventArgs(
   text : String
);

Parameters

text
[To be supplied.]

See Also

ValidatingEventArgs Class | ValidatingEventArgs Members | System.ComponentModel Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ValidatingEventArgs Properties

The properties of the ValidatingEventArgs class are listed below. For a complete list of ValidatingEventArgs class members, see the ValidatingEventArgs Members topic.

Public:

ProposedValue | [To be supplied.]
Text | [To be supplied.]

See Also

ValidatingEventArgs Class | System.ComponentModel Namespace


ValidatingEventArgs.ProposedValue

[To be supplied.]

[Visual Basic]
Public Property ProposedValue As Object
[C#]
public object ProposedValue {get; set;}
[C++]
public: __property Object* get_ProposedValue();
public: __property void set_ProposedValue(Object*);
[JScript]
public function get ProposedValue() : Object;
public function set ProposedValue(Object);

See Also

ValidatingEventArgs Class | ValidatingEventArgs Members | System.ComponentModel Namespace


ValidatingEventArgs.Text

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Text As String
[C#]
public string Text {get;}
[C++]
public: __property String* get_Text();
[JScript]
public function get Text() : String;

See Also

ValidatingEventArgs Class | ValidatingEventArgs Members | System.ComponentModel Namespace


ValidatingEventHandler Delegate

[To be supplied.]

[Visual Basic]
Public Delegate Sub ValidatingEventHandler( _
   ByVal sender As Object, _
   ByVal e As ValidatingEventArgs _
)
[C#]
public delegate void ValidatingEventHandler(
   object sender,
   ValidatingEventArgs e
);
[C++]
public __gc __delegate void ValidatingEventHandler(
   Object* sender,
   ValidatingEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the ValidatingEventHandler delegate declaration.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel

Assembly: System.dll

See Also

System.ComponentModel Namespace


System.ComponentModel.Design

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.ComponentModel.Design Namespace

Classes

Class | Description
ActiveDocumentEventArgs | Provides data for the System.ComponentModel.Design.IDesignerEventService.ActiveDocument event.
AliasEditor | AliasEditor is a value editor that intelligently edits strings that have aliases.
ArrayDialog | ArrayDialog is a modal dialog that allows editing of arrays. With it, you can add, remove, and sort the items in the array. It requires an ArrayEditor which it calls to create new values.
ArrayEditor | ArrayEditor derives from CollectionEditor to edit arrays of values.
BatchOperationEventArgs | Provides data about the System.ComponentModel.Design.IDesignerHost.BatchOperation event.
BinaryEditor | Generic editor for editing binary data. This presents a hex editing window to the user.
BlankIntegerEditor | [To be supplied.]
ByteEditor | [To be supplied.]
ByteViewer | This class implements a ByteViewer component. This component is capable of displaying byte arrays in HEXDUMP, ANSI and UNICODE views. The HEXDUMP view is a view with hex values and corresponding byte representations (chars). The dafault number of columns is 16. The ANSI and UNICODE views show the byte aray in a read only edit box. In this view the null characters are replaced with Windows box charcter alowing to display the entire buffer. The AUTO view selects a default display mode based on the contents of the byte array. It uses a simple algorithm to establish what kind of data is stored in the buffer
CheckoutException | Represents the exception thrown when an attempt is made to edit a file that is checked into a source control program.
CodePersister | The code persister is part of a trio of objects that load and save the document. At the base of this trio is the CodeStream object, which is required for loading and saving documents. On top of the code stream is an optional language layer. This language layer allows documents that are based on source code to be loaded and saved in a generic manner. The language layer implements a series of "code access" interfaces through which an object may read and write source code in a language independent way. The code persister is the object responsible for reading and writing to the code access interfaces.
CodeStream | The code stream is used to load and save the document.
CollectionEditor |
CommandID | Represents a numeric Command ID and globally unique ID (GUID) menu identifier that together uniquely identify a command.
ComponentChangedEventArgs | Provides data for the System.ComponentModel.Design.ComponentChangedEvent.ComponentChangedEvent event.
ComponentChangingEventArgs | Provides data for the System.ComponentModel.Design.ComponentChangingEvent event.
ComponentDesigner | The default designer for all components. Almost everything that extends from Component will typically have one of these designers as their base designer. Designers do not have to inherit from this class, but it does provide some convenient features.
ComponentEventArgs | Provides data for the System.ComponentModel.Design.ComponentEvent event raised for component-level events.
ComponentModelPersister | Component model persister. This object can convert a component object graph to and from source code. It also provides code navigation services to the designer.
ComponentModelPersister.LocalCache.LocalCacheItemComparer | [To be supplied.]
ComponentRenameEventArgs | Provides data for the System.ComponentModel.Design.ComponentRenameEvent.ComponentRenameEvent event.
CompoundPropertyChangeActionUnit | Represents a series of property change action units that can be treated as a single atomic action.
ContentAlignmentEditor | [To be supplied.]
ContentAlignmentEditor.EditControl | [To be supplied.]
CultureInfoEditor | [To be supplied.]
CurrencyEditor | [To be supplied.]
DatePickerEditor | This is a value editor bringing up a dialog with calendar control in it for user to pick a date.
DatePickerEditor.DatePicker | [To be supplied.]
DateTimeEditor | This date time editor is a UITypeEditor suitable for visually editing DateTime objects.
DateTimeFormatEditor | [To be supplied.]
DecimalEditor | [To be supplied.]
DesignerVerb | Represents a verb that can be executed by a component's designer. Verbs are dynamic menu commands whose text image can be determined at runtime.
DesigntimeLicenseContext | Provides design-time support for licensing.
DesigntimeLicenseContextSerializer | Provides support for design-time license context serialization.
DocumentCollection | Provides a read-only collection of documents.
DocumentEventArgs | Provides data for the DocumentEventArgs event that is generated when a document is created or disposed.
EventHandlerSetActionUnit | Represents an atomic undoable action unit to be added to the IUndoService implementation.
GuidEditor | GuidEditor is the default editor for Guids.
ImmediateStringEditor | [To be supplied.]
InheritanceAttribute | Marks instances of objects that are inherited from their base superclass. This class cannot be inherited.
InheritanceService | The inheritance service provides a set of utilities for analyzing and identifying inherited components.
InheritedPropertyDescriptor | An inherited property descriptor is used to replace all properties on a component that is being inherited. An inherited property descriptor is identical to the component's original property descriptor except for two things. First, you can tie additional attributes into this property descriptor, such as ReadOnly if the property should not be accessible on an inherited component. Second, this property descriptor stores a new default value attribute for the property that is the current value of this property on the component. This override is important because the inherited component may have different values for its defaults than its own property descriptor states.
IntegerEditor | [To be supplied.]
Localizer | [To be supplied.]
MemberModifier | Specifies constant values for common attributes applied to member functions.
MenuCommand | Represents a Windows menu or toolbar item.
NameEditor | [To be supplied.]
NonEditableReferenceEditor | NonEditableReferenceEditor is an editor that displays the name of a component. Other references can not be substituted.
NotifyParentPropertyAttribute | Indicates whether the parent property is notified if a child namespace property is modified.
NumericFormatEditor | [To be supplied.]
NumericFormatTypeEditor | [To be supplied.]
ObjectPropertiesEditor | [To be supplied.]
ObjectSelectorEditor | [To be supplied.]
ObjectSelectorEditor.Selector | [To be supplied.]
ObjectSelectorEditor.SelectorNode | [To be supplied.]
OldArrayEditor | ArrayEditor is a value editor that intelligently edits arrays. It uses ArrayDialog in editValue to visually add, remove, and sort arrays. It is a value editor that takes a Class in it's constructor so it knows the type of the array it is editing. ArrayEditor supports editing values, but does not convert text into values.
OldCollectionEditor | Generic editor for any collection property
OldCollectionEditor.CollectionDialog | ArrayDialog is a modal dialog that allows editing of arrays. With it, you can add, remove, and sort the items in the array. It requires an ArrayEditor which it calls to create new values.
ParenthesizePropertyNameAttribute | Indicates whether the name of the associated property is paraenthesized in the property browser.
PropertyChangeActionUnit | Represents a property change action unit.
PropertyTabAttribute | This attribute identifies the property tab or tabs that should be displayed for a given class.
PropertyValue | PropertyValue encapsulates information about a property's type and value. The goal of the class is to enable persistence in code (code-spit) of any object. @author stefanph, August 1998 UNDONE: Brianpe/ ChrisAn, 5/15/99- Is this really the thing we want to surface here?: I think we should probably be using the code model interfaces more...
ReadOnlyValueEditor | [To be supplied.]
ReferenceEditor | ReferenceEditor is an editor that handles references to other components. When asked to list the possible values, it will query the container of the hosting component for all components that implement the given type and return that list.
RefreshPropertiesAttribute | Specifies how a forms designer refreshes when the property value is changed.
ResourceValueProvider | ValueProvider for the ResourceManager
StandardCommands | This class contains the standard set of commands that are available to most applications.
StandardToolWindows | This class defines GUIDs that reference the standard set of tool windows that are available in the design environment.
StringEditor | [To be supplied.]
StringListEditor | StringListEditor supports design time editing of an array of Strings using the StringListDialog.
TimeSpanEditor | [To be supplied.]
ToolboxComponentsCreatedEvent | Provides data for the ToolboxComponentsCreatedEventHandler that handles the event that occurs when components are added to the toolbox.
ToolboxItemAttribute | Specifies attributes for a toolbox item.
TypeChangedEventArgs | Provides data for the System.ComponentModel.Design.TypeChangedEvent that occurs when the source code for a specified type has been modified.
UIActivationStateEventArgs | Provides data for the System.ComponentModel.Design.UIActivationStateEvent event.
ValueEditorConverter | [To be supplied.]
ValueEditorHost | [To be supplied.]
ValueProvider | Interface defining an object that needs to participate in code generation to persist data outside of the code. This allows the runtime object to "provide values" to components on the form.
ValueProviderCollection | Collection of IValueProvider objects.
ValueProviderService | The value provider service provides a collection of value providers that will be called on when code is persisted or depersisted.
VariantEditor | [To be supplied.]

Interfaces

Interface | Description
IActionUnit | Represents an atomic undoable action unit to be added to the IUndoService implementation.
IApplicationExtensibilityService | The application extensibility service.
ICheckoutService | Provides an interface for checking out files to edit.
ICodeNavigatorService | Provides simple code navigation services.
ICodePersisterTaskListService | The ICodePersisterTaskListService interface provides a way to create a list of failures during the code persistance routines.
IComponentChangeService | Provides an interface to add and remove the event handlers for component add, change, remove and rename events.
IComponentCodePersistanceService | Provides an interface for retrieving components from code or persisting components to code.
ICompoundActionUnit | Represents a series of action units that should be treated as a single atomic action.
IDeferLoadService | Allows asynchronous loading of designers.
IDesigner | This interface provides the framework for building a custom designer. This interface stores the verbs available to the designer, as well as basic services for the designer.
IDesignerEventService | Provides global event notifications and the ability to create designers.
IDesignerFilter | Provides access to, and an interface for filtering, the dictionaries that store the properties, attributes, and events of a component.
IDesignerHost | Provides methods to adjust the configuration of and retrieve information about the services and behavior of a designer.
IDesignerOptionService | Provides access to get and set option values for a designer.
IDictionaryService | Provides a generic dictionary service that a designer can store user-defined data on the site.
IEditorSite | IEditorSite is a callback through which value editors can get at the owners of the values they are editing. This is useful to get at other objects on the form.
IEventPropertyService | This interface can convert EventDescriptors to PropertyDescriptors.
IExtenderListService | Provides an interface to track extender providers.
IExtenderProviderService | Provides an interface to add and remove extender providers.
IExtensibilityService | Provides an interface to get an extensibility service object to control various properties of the project within the development environment.
IFilePersistanceService | This service allows designers to open files as binary data. If applicable, source control rules for the files will be followed if a write to the file is attempted.
IHelpService | The help service provides a way to provide the IDE (Integrated Development Environment) help system with contextual information for the current task. The help system evaluates all contextual information it gets and determines the most relevant topics to display to the user.
IInheritanceService | Provides a set of utilities for analyzing and identifying inherited components.
IMenuCommandService | Provides an interface for a designer to add menu items to the Visual Studio menu.
IReferenceService | Provides an interface to get names and references to objects. These methods can search using the specified name or reference.
ISelectionService | Provides an interface for a designer to select components.
ITestCommandService | The test command interface allows various test commands to be added to the designer.
ITypeDescriptorFilterService | Modifies the set of type descriptors that a component provides.
IUIActivationService | Service that adds and removes event handlers when a UI component's activation state is switched after selection or deselection.
IUndoService | Allows access to undo/redo functionality.
IValueProvider | Defines an object that participates in code generation to persist data outside of the code.
IValueProviderCollection | Provides an interface to manage a collection of IValueProvider objects.
IValueProviderService | Provides access to the value provider collection that can be used for managing and checking the value providers that will be used during code persistance and depersistance.

Delegates

Delegate | Description
ActiveDocumentEventHandler | Represents the method that will handle the System.ComponentModel.Design.DocumentManager.ActiveDocument event raised on changes to the currently active document.
BatchOperationEventHandler | Represents the method that will handle the System.ComponentModel.Design.IDesignerHost.BatchOperation event.
ComponentChangedEventHandler | Represents the method that will handle a System.ComponentModel.Design.ComponentChangedEvent event.
ComponentChangingEventHandler | Represents the method that will handle a System.ComponentModel.Design.ComponentChangingEvent event.
ComponentEventHandler | Represents the method that will handle the System.ComponentModel.Design.ComponentEvent event raised for component-level events.
ComponentRenameEventHandler | Represents the method that will handle a System.ComponentModel.Design.ComponentRenameEvent.ComponentRenameEvent.
ContainerSelectorActiveEventHandler | Represents the method that will handle a System.ComponentModel.Design.ContainerSelectorActiveEvent event.
DocumentEventHandler | Represents the method that will handle the DocumentEventArgs event raised when a document is created or disposed.
TestCommand | [To be supplied.]
ToolboxComponentsCreatedEventHandler | Represents the method that will handle the System.ComponentModel.Design.ToolboxComponentsCreatedEvent.ToolboxComponentsCreatedEvent event.
TypeChangedEventHandler | Represents the method that handles the event raised when a System.ComponentModel.Design.TypeChangedEvent.TypeChangedEvent occurs.
UIActivationStateEventHandler | Represents the method that will handle the event raised when a System.ComponentModel.Design.UIActiavationStateEvent.UIActivationStateEvent occurs.

Enumerations

Enumeration | Description
ActionType | Specifies the values to represent an action's undo/redo ActionType state.
DisplayMode | [To be supplied.]
HelpKeywordType | [To be supplied.]
InheritanceLevel | Specifies numeric IDs for different inheritance levels.
PropertyTabScope | Specifies the function scope of a tab in the property browser.
RefreshProperties | Specifies values for use in refreshing the design time view.
SelectionRules | Specifies a set of selection rule identifiers that can be used to indicate attributes for a selected component.
SelectionStyles | Specifies identifiers to use to indicate the style of the selection frame of a component.
SelectionTypes | Specifies identifiers that indicate the type of selection for a component or group of components that are selected.
ValueExpressionLevel | Specifies the levels of support for an IValueProvider.


ActionType Enumeration

Specifies the values to represent an action's undo/redo ActionType state.

[Visual Basic]
Public Enum ActionType
[C#]
public enum ActionType
[C++]
public enum ActionType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Redo | One of the ActionType values. This attribute indicates the action is a redo action. An action unit will apply it's new values on the next call to DoAction.
Undo | One of the ActionType values. This attribute indicates the action is an undo action. An action unit will revert to its original values on the next call to DoAction.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

System.ComponentModel.Design Namespace


ActiveDocumentEventArgs Class

Provides data for the System.ComponentModel.Design.IDesignerEventService.ActiveDocument event.

Object
EventArgs
ActiveDocumentEventArgs

[Visual Basic]
Public Class ActiveDocumentEventArgs
   Inherits EventArgs
[C#]
public class ActiveDocumentEventArgs : EventArgs
[C++]
public __gc class ActiveDocumentEventArgs : public EventArgs
[JScript]
public class ActiveDocumentEventArgs extends EventArgs

Remarks

This event occurs when the currently active document changes. The active document changes when opening or setting focus to a new document, or when closing a document.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

ActiveDocumentEventArgs Members | System.ComponentModel.Design Namespace | ActiveDocumentEventHandler


ActiveDocumentEventArgs Members

Public:

Constructor

ActiveDocumentEventArgs Constructor Initializes a new instance of the ActiveDocumentEventArgs class.

Properties

ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
NewDocument | Gets or sets the document that is gaining activation.
OldDocument | Gets or sets the document that is losing activation.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ActiveDocumentEventArgs Class | System.ComponentModel.Design Namespace


ActiveDocumentEventArgs Constructor

Initializes a new instance of the ActiveDocumentEventArgs class.

[Visual Basic]
Public Sub New( _
   ByVal oldDocument As IDesignerHost, _
   ByVal newDocument As IDesignerHost _
)
[C#]
public ActiveDocumentEventArgs(
   IDesignerHost oldDocument,
   IDesignerHost newDocument
);
[C++]
public: ActiveDocumentEventArgs(
   IDesignerHost* oldDocument,
   IDesignerHost* newDocument
);
[JScript]
public function ActiveDocumentEventArgs(
   oldDocument : IDesignerHost,
   newDocument : IDesignerHost
);

Parameters

oldDocument
The document that is losing activation.
newDocument
The document that is gaining activation.

See Also

ActiveDocumentEventArgs Class | ActiveDocumentEventArgs Members | System.ComponentModel.Design Namespace | IDesignerHost


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ActiveDocumentEventArgs Properties

The properties of the ActiveDocumentEventArgs class are listed below. For a complete list of ActiveDocumentEventArgs class members, see the ActiveDocumentEventArgs Members topic.

Public:

ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
NewDocument | Gets or sets the document that is gaining activation.
OldDocument | Gets or sets the document that is losing activation.

See Also

ActiveDocumentEventArgs Class | System.ComponentModel.Design Namespace


ActiveDocumentEventArgs.NewDocument

Gets or sets the document that is gaining activation.

[Visual Basic]
Public ReadOnly Property NewDocument As IDesignerHost
[C#]
public IDesignerHost NewDocument {get;}
[C++]
public: __property IDesignerHost* get_NewDocument();
[JScript]
public function get NewDocument() : IDesignerHost;

Property Value

An IDesignerHost that represents the document gaining activation.

See Also

ActiveDocumentEventArgs Class | ActiveDocumentEventArgs Members | System.ComponentModel.Design Namespace | OldDocument | IDesignerHost


ActiveDocumentEventArgs.OldDocument

Gets or sets the document that is losing activation.

[Visual Basic]
Public ReadOnly Property OldDocument As IDesignerHost
[C#]
public IDesignerHost OldDocument {get;}
[C++]
public: __property IDesignerHost* get_OldDocument();
[JScript]
public function get OldDocument() : IDesignerHost;

Property Value

An IDesignerHost that represents the document losing activation.

See Also

ActiveDocumentEventArgs Class | ActiveDocumentEventArgs Members | System.ComponentModel.Design Namespace | NewDocument | IDesignerHost


ActiveDocumentEventHandler Delegate

Represents the method that will handle the System.ComponentModel.Design.DocumentManager.ActiveDocument event raised on changes to the currently active document.

[Visual Basic]
Public Delegate Sub ActiveDocumentEventHandler( _
   ByVal sender As Object, _
   ByVal e As ActiveDocumentEventArgs _
)
[C#]
public delegate void ActiveDocumentEventHandler(
   object sender,
   ActiveDocumentEventArgs e
);
[C++]
public __gc __delegate void ActiveDocumentEventHandler(
   Object* sender,
   ActiveDocumentEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the ActiveDocumentEventHandler delegate declaration.

sender
The source of the event.
e
An ActiveDocumentEventArgs that contains the event data.

Remarks

When you create an ActiveDocumentEventHandler delegate, you identify the method that will handle the event. To associate the event with your event-handling method, add an instance of the delegate to the event. The event-handling method is called whenever the event occurs, unless you remove the delegate. For more information about handling events with delegates, see TBD.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

System.ComponentModel.Design Namespace | ActiveDocumentEventArgs | System.ComponentModel.Design.DocumentManager.ActiveDocument


AliasEditor Class

AliasEditor is a value editor that intelligently edits strings that have aliases.

Object
ValueEditor
AliasEditor

[Visual Basic]
Public Class AliasEditor
   Inherits ValueEditor
[C#]
public class AliasEditor : ValueEditor
[C++]
public __gc class AliasEditor : public ValueEditor
[JScript]
public class AliasEditor extends ValueEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

AliasEditor Members | System.ComponentModel.Design Namespace | ArrayDialog | ValueEditor


AliasEditor Members

Public:

Constructor

AliasEditor Constructor [To be supplied.]

Properties

Style | [To be supplied.]
Values | [To be supplied.]

Methods

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from ValueEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue (inherited from ValueEditor) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AliasEditor Class | System.ComponentModel.Design Namespace


AliasEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal names() As String, _
   ByVal aliases() As String _
)
[C#]
public AliasEditor(
   string[] names,
   string[] aliases
);
[C++]
public: AliasEditor(
   String* names[],
   String* aliases[]
);
[JScript]
public function AliasEditor(
   names : String[],
   aliases : String[]
);

Parameters

names
[To be supplied.]
aliases
[To be supplied.]

See Also

AliasEditor Class | AliasEditor Members | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AliasEditor Properties

The properties of the AliasEditor class are listed below. For a complete list of AliasEditor class members, see the AliasEditor Members topic.

Public:

Style | [To be supplied.]
Values | [To be supplied.]

See Also

AliasEditor Class | System.ComponentModel.Design Namespace


AliasEditor.Style

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Style As ValueEditorStyles
[C#]
public ValueEditorStyles Style {override get;}
[C++]
public: __property virtual ValueEditorStyles get_Style();
[JScript]
public function get Style() : ValueEditorStyles;

See Also

AliasEditor Class | AliasEditor Members | System.ComponentModel.Design Namespace


AliasEditor.Values

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Values As Object ()
[C#]
public object[] Values {override get;}
[C++]
public: __property virtual Object* get_Values();
[JScript]
public function get Values() : Object[];

See Also

AliasEditor Class | AliasEditor Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AliasEditor Methods

The methods of the AliasEditor class are listed below. For a complete list of AliasEditor class members, see the AliasEditor Members topic.

Public:

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from ValueEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue (inherited from ValueEditor) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AliasEditor Class | System.ComponentModel.Design Namespace


AliasEditor.GetValueFromText

[To be supplied.]

[Visual Basic]
Overrides Public Function GetValueFromText( _
   ByVal text As String _
) As Object
[C#]
public override object GetValueFromText(
   string text
);
[C++]
public: override Object* GetValueFromText(
   String* text
);
[JScript]
public override function GetValueFromText(
   text : String
) : Object;

Parameters

text
[To be supplied.]

See Also

AliasEditor Class | AliasEditor Members | System.ComponentModel.Design Namespace


ArrayDialog Class

ArrayDialog is a modal dialog that allows editing of arrays. With it, you can add, remove, and sort the items in the array. It requires an ArrayEditor which it calls to create new values.

Object
MarshalByRefObject
MarshalByRefComponent
Control
RichControl
ScrollableControl
ContainerControl
Form
ArrayDialog

[Visual Basic]
Public Class ArrayDialog
   Inherits Form
[C#]
public class ArrayDialog : Form
[C++]
public __gc class ArrayDialog : public Form
[JScript]
public class ArrayDialog extends Form

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

ArrayDialog Members | System.ComponentModel.Design Namespace | ArrayEditor


ArrayDialog Members

Public:

Constructor

ArrayDialog Constructor Constructs an ArrayDialog given a type and the ArrayEditor.

Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from RichControl) | The Accessibility Object for this RichControl
AccessibleDefaultActionDescription (inherited from RichControl) | The default action description of the control
AccessibleDescription (inherited from RichControl) | The accessible description of the control
AccessibleHelpProvider (inherited from RichControl) | The help provider for this RichControl
AccessibleName (inherited from RichControl) | The accessible name of the control
AccessibleRole (inherited from RichControl) | The accessible role of the control
ActiveControl (inherited from ContainerControl) | The current active control.
ActiveMDIChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from RichControl) | The allowDrop property. If allowDrop is set to true then this control will allow drag and drop operations and events to be used.
AllowTransparency (inherited from RichControl) | Determines if the control should be allowed to have the opacity adjusted. This is primarily a performance optimization, in that you can always set the opacity to any value, and that will force AllowTransparency to true. However, setting the opacity to any given value will switch the control into layered mode. By setting the AllowTransparency property to false the control will actually switch out of layered mode, which provides better performance if you don't intend to adjust the opacity.
Anchor (inherited from RichControl) | The current value of the anchor property. The anchor property determines which edges of the control are anchored to the container's edges.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form will adjust its size to fit the height of the font used on the form and scale its controls.
AutoScaleBaseSize (inherited from Form) | The base size used for autoscaling. The AutoScaleBaseSize is used internally to determine how much to scale the form when AutoScaling is used.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form implements autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Retrieves the current value of the AutoScrollMinSize property. The AutoScrollMinSize property is used internally to manage the screen size allocated to the automatic scrollbars.
AutoScrollPosition (inherited from ScrollableControl) | Retrieves the current value of the AutoScrollPosition property. The AutoScrollPosition property is used internally to adjust the position of controls that there placed on the Form throughout the form designer.
BackColor (inherited from RichControl) | The background color of this control. This is an ambient property and will always return a non-null value.
BackgroundImage (inherited from RichControl) | The background image of the control.
BindingManager (inherited from ContainerControl) | The binding manager for the container control.
Bindings (inherited from RichControl) | Retrieves the bindings for this control.
BorderStyle (inherited from Form) | Gets or sets the border style of the form.
Bottom (inherited from Control) | The bottom coordinate of this control.
Bounds (inherited from Control) | The bounds of this control. This is the window coordinates of the control in parent client coordinates.
CancelButton (inherited from Form) | Gets or sets the button control that will be clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Checks if this control can receive focus. The result is true if the control has a handle and if it and all of its parent controls are both visible and enabled.
CanSelect (inherited from Control) | Checks if this control can be selected. The result is true if the control is contained in a form and if all of its parent controls are both visible and enabled.
Capture (inherited from Control) | If this control has captured the mouse then this will return true.
CausesValidation (inherited from Control) | Indicates whether entering this control causes validation on the controls requiring validation. This is set to false usually for things like the Help button, etc...
ClientRectangle (inherited from Control) | The client rect of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from RichControl) | Retrieves the company name of this specific component.
ContainsFocus (inherited from Control) | Indicates whether the control or one of its children currently has the system focus.
ContextMenu (inherited from RichControl) | The contextMenu associated with this control. The contextMenu will be shown when the user right clicks the mouse on the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether the form has a control box.
Controls (inherited from Control) | Collection of child controls.
Created (inherited from Control) | Returns true if the control has been created.
Cursor (inherited from RichControl) | Retrieves the cursor that will be displayed when the mouse is over this control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Retreives the current display rectangle. The display rectangle is the virtual display area that is used to layout components. The position and dimensions of the Form's display rectangle change during autoScroll.
Disposed (inherited from Control) | Indicates that the control has been disposed, and is no longer a valid Windows control even though the object instance is still alive.
Disposing (inherited from Control) | Indicates that the control is in the process of being beendisposed, and is no longer a valid Windows control even though the object instance is still alive.
Dock (inherited from RichControl) | The dock property. The dock property controls to which edge of the container this control is docked to. For example, when docked to the top of the container, the control will be displayed flush at the top of the container, extending the length of the container.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | The current enabled state of this control.
Focused (inherited from Control) | Returns true if this control has focus.
Font (inherited from RichControl) | Retrieves the current font for this control. This will be the font used by default for painting and text in the control.
ForeColor (inherited from RichControl) | The foreground color of the control.
Handle (inherited from Control) | The HWND handle that this control is bound to. If the handle has not yet been created, this will force handle creation.
HandleCreated (inherited from Control) | Whether or not this control has a handle associated with it.
Height (inherited from Control) | The height of this control
HelpButton (inherited from Form) | Gets or sets a value indicating whether a help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
IMEMode (inherited from RichControl) | Specifies a value that determines the IME (Input Method Editor) status of the object when that object is selected.
InvokeRequired (inherited from RichControl) | Determines if the caller must call invoke when making method calls to this control. Controls in WinForms are bound to a specific thread, and are not thread safe. Therefore, if you are calling a control's method from a different thread, you must use the control's invoke method to marshal the call to the proper thread. This function can be used to determine if you must call invoke, which can be handy if you don't know what thread owns a control. There are five functions on a control that are safe to call from any thread: GetInvokeRequired, Invoke, BeginInvoke, EndInvoke and CreateGraphics. For all other metohd calls, you should use one of the invoke methods.
IsAccessible (inherited from RichControl) | Indicates whether or not this control is an accessible control i.e. whether it should be visible to accessibility applications.
IsMDIChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMDIContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | The left coordinate of this control.
Location (inherited from Control) | The location of this control.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize box is displayed in the caption box of the form.
MDIChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MDIParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize box is displayed in the caption box of the form.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Opacity (inherited from Form) | [To be supplied.]
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from Form) | The form that is the visual parent of this form.
ProductName (inherited from RichControl) | Retrieves the product name of this specific component.
ProductVersion (inherited from RichControl) | Retrieves the product version of this specific component.
RecreatingHandle (inherited from Control) | This is true if the control is currently recreating its handle.
Region (inherited from RichControl) | The Region associated with this control. (defines the outline/silhouette/boundary of control)
Right (inherited from Control) | The right coordinate of this control.
RightToLeft (inherited from RichControl) | This is used for international applications where the language is written from RightToLeft. When this property is true, control placement and text will be from right to left.
ShowInTaskbar (inherited from Form) | If ShowInTaskbar is true then the form will be displayed in the Windows Taskbar.
Site (inherited from MarshalByRefComponent) | Gets or sets the site of the component.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of size grip to display in the lower-left corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | [To be supplied.]
TabStop (inherited from Control) | A boolean value indicating whether the user can give the focus to this control using the TAB key.
Text (inherited from Control) | The current text associated with this control.
Top (inherited from Control) | Top coordinate of this control.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | The top level control that contains this control. This doesn't have to be the same as the value returned from getForm since forms can be parented to other controls.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
Visible (inherited from Form) | Gets or sets a value indicating whether the form is visible.
Width (inherited from Control) | The width of this control.
WindowState (inherited from Form) The WindowState of the Form. Valid values are:
FormWindowState.Normal
    FormWindowState.Maximized
    FormWindowState.Minimized
WindowTarget (inherited from Control) | The target of Win32 window messages.

Methods

Activate (inherited from Form) | Activates the form and gives it focus.
ActivateControl (inherited from ContainerControl) | [To be supplied.]
AddOwnedForm (inherited from Form) | Adds an owned form to this form. Owned forms are other top level forms that are children of this form.
BeginInvoke (inherited from RichControl) | Overloaded. [To be supplied.]
BringToFront (inherited from Control) | Brings this control to the front of the zorder.
CallWndProc (inherited from Control) | Dispatch the method to this window's wndProc directly.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Checks if a control is a child of this control.
CreateControl (inherited from Control) | Forces the creation of the control. This includes the creation of the handle, and any child controls.
CreateGraphics (inherited from RichControl) | Overloaded. [To be supplied.]
CreateWindowGraphics (inherited from RichControl) | Creates a Graphics for the entire window of the control rather than just it's client area. The controls foreground color and background color become the default values for the Graphics. The returned Graphics must be disposed through a call to its dispose() method when it is no longer needed. The Graphics Object is only valid for the duration of the current window's message.
Dispose (inherited from Form) | Releases all the system resources associated with the Form. If a subclass overrides this function, it must call the super implementation.
DoDragDrop (inherited from RichControl) | Begins a drag operation. The allowedEffects determine which drag operations can occur. If the drag operation needs to interop with applications in another process, data should either be a base managed class (String, Bitmap, or Metafile) or some Object that implements System.ComponentModel.IPersistable. data can also be any Object that implements System.WinForms.IDataObject.
EndInvoke (inherited from RichControl) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult interface passed. If the async operation has not been completed, this function will block until the result is available.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FindForm (inherited from Form) | Retrieves the form that this control is parented to.
Focus (inherited from Control) | Attempts to set focus to this control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified client coordinates.
GetContainer (inherited from MarshalByRefComponent) | Returns the component's container.
GetContainerControl (inherited from Control) | Returns the closest ContainerControl in the control's chain of parent controls and forms.
GetDesignMode (inherited from MarshalByRefComponent) | Determines whether the component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetItems | Returns an array of items, typed as type[] (where type was passed in to the constructor).
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetMDIClient (inherited from Form) | Returns the control that is the MDI Client region.
GetNextControl (inherited from Control) | Retrieves the next control in the tab order of child controls.
GetServiceObject (inherited from MarshalByRefComponent) | The implementation of IServiceObjectProvider
GetType (inherited from Object) | Gets the Type of the Object.
Hide (inherited from Control) | Hides the control by setting the visible property to false;
InitializeLifetimeService (inherited from MarshalByRefObject)
Invalidate (inherited from RichControl) | Overloaded. [To be supplied.]
Invoke (inherited from RichControl) | Overloaded. [To be supplied.]
LayoutMDI (inherited from Form) | Arranges the MDI child forms according to value, which should be a member of the MDILayout enum.
PerformLayout (inherited from Control) | Overloaded. [To be supplied.]
PointToClient (inherited from Form) | [To be supplied.]
PointToScreen (inherited from Form) | [To be supplied.]
PreProcessMessage (inherited from Control) | This method is called by the application's message loop to pre-process input messages before they are dispatched. Possible values for the msg.message field are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR. If this method processes the message it must return true, in which case the message loop will not dispatch the message. For WM_KEYDOWN and WM_SYSKEYDOWN messages, preProcessMessage() first calls processCmdKey() to check for command keys such as accelerators and menu shortcuts. If processCmdKey() doesn't process the message, then isInputKey() is called to check whether the key message represents an input key for the control. Finally, if isInputKey() indicates that the control isn't interested in the key message, then processDialogKey() is called to check for dialog keys such as TAB, arrow keys, and mnemonics. For WM_CHAR messages, preProcessMessage() first calls isInputChar() to check whether the character message represents an input character for the control. If isInputChar() indicates that the control isn't interested in the character message, then processDialogChar() is called to check for dialog characters such as mnemonics. For WM_SYSCHAR messages, preProcessMessage() calls processDialogChar() to check for dialog characters such as mnemonics. When overriding preProcessMessage(), a control should return true to indicate that it has processed the message. For messages that aren't processed by the control, the result of "base.preProcessMessage()" should be returned. Controls will typically override one of the more specialized methods (isInputChar(), isInputKey(), processCmdKey(), processDialogChar(), or processDialogKey()) instead of overriding preProcessMessage().
RectangleToClient (inherited from Form) | [To be supplied.]
RectangleToScreen (inherited from Form) | [To be supplied.]
Refresh (inherited from Control) | Forces the control to invalidate and immediately repaint itself and any children.
RemoveOwnedForm (inherited from Form) | Removes a form from the list of owned forms. Also sets the owner of the removed form to null.
ResetBackColor (inherited from RichControl) | Resets the back color to be based on the parent's back color.
ResetBindings (inherited from RichControl) | [To be supplied.]
ResetCursor (inherited from RichControl) | [To be supplied.]
ResetFont (inherited from RichControl) | Resets the font to be based on the parent's font.
ResetForeColor (inherited from RichControl) | Resets the fore color to be based on the parent's fore color.
ResetRightToLeft (inherited from RichControl) | Resets the RightToLeft to be the default.
ResetText (inherited from Control) | Resets the text to it's default value.
ResumeLayout (inherited from Control) | Overloaded. [To be supplied.]
Scale (inherited from Control) | Overloaded. [To be supplied.]
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the currently active control into view if we are an AutoScroll Form that has the Horiz or Vert scrollbar displayed...
Select (inherited from Control) | Activates this control.
SelectNextControl (inherited from Control) | Selects the next control following ctl.
SendMessage (inherited from Control) | Overloaded. [To be supplied.]
SendToBack (inherited from Control) | sends this control to the back of the z-order
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. [To be supplied.]
SetClientSize (inherited from Control) | Sets the height and width of the client area of the control.
SetDesktopBounds (inherited from Form) | Sets the bounds of the Form in desktop coordinates. Desktop coordinates are based on the working area of the screen, which excludes the Taskbar.
SetDesktopLocation (inherited from Form) | Sets the location of the Form in desktop coordinates.
SetItems | Sets the array of items to be edited by the ArrayDialog.
SetLocation (inherited from Control) | Sets the location of this control.
SetNewControls (inherited from Form) | [To be supplied.]
SetSize (inherited from Control) | Sets the size of this control.
ShouldPersistAutoScaleBaseSize (inherited from Form) | [To be supplied.]
ShouldPersistAutoScrollMargin (inherited from ScrollableControl) | Indicates whether the AutoScrollMargin property should be persisted.
ShouldPersistAutoScrollMinSize (inherited from ScrollableControl) | Indicates whether the AutoScrollMinSize property should be persisted.
ShouldPersistAutoScrollPosition (inherited from ScrollableControl) | Indicates whether the AutoScrollPosition property should be persisted.
ShouldPersistBackColor (inherited from Form) | [To be supplied.]
ShouldPersistBindings (inherited from RichControl) | [To be supplied.]
ShouldPersistCursor (inherited from RichControl) | Returns true if the cursor should be persisted in code gen.
ShouldPersistFont (inherited from RichControl) | Returns true if the font should be persisted in code gen.
ShouldPersistForeColor (inherited from Form) | [To be supplied.]
ShouldPersistIcon (inherited from Form) | [To be supplied.]
ShouldPersistLocation (inherited from Control) | Determines if the Location property needs to be persisted.
ShouldPersistRightToLeft (inherited from RichControl) | Returns true if the RightToLeft should be persisted in code gen.
ShouldPersistSize (inherited from Form) | [To be supplied.]
ShouldPersistText (inherited from Control) | Determines if the Text property needs to be persisted.
Show (inherited from Control) | Makes the control display by setting the visible property to true
ShowDialog (inherited from Form) | Overloaded. [To be supplied.]
SuspendLayout (inherited from Control) | Suspends the layout logic for the control.
ToString (inherited from Form) | Returns a string representation for this control.
Update (inherited from Control) | Forces the control to paint any currently invalid areas.
Validate (inherited from ContainerControl) | Validates the last unvalidated control and it's ancestors up through (but not including) this.

Events

Activate (inherited from Form) | [To be supplied.]
Click (inherited from Control) | [To be supplied.]
Closed (inherited from Form) | [To be supplied.]
Closing (inherited from Form) | [To be supplied.]
ControlAdded (inherited from Control) | [To be supplied.]
ControlRemoved (inherited from Control) | [To be supplied.]
CreateHandle (inherited from Control) | [To be supplied.]
Deactivate (inherited from Form) | [To be supplied.]
DestroyHandle (inherited from Control) | [To be supplied.]
DoubleClick (inherited from Control) | [To be supplied.]
DragDrop (inherited from RichControl) | [To be supplied.]
DragEnter (inherited from RichControl) | [To be supplied.]
DragLeave (inherited from RichControl) | [To be supplied.]
DragOver (inherited from RichControl) | [To be supplied.]
Enter (inherited from Control) | [To be supplied.]
GiveFeedback (inherited from RichControl) | [To be supplied.]
GotFocus (inherited from Control) | [To be supplied.]
Help (inherited from RichControl) | [To be supplied.]
InputLangChange (inherited from Form) | [To be supplied.]
InputLangChangeRequest (inherited from Form) | [To be supplied.]
Invalidate (inherited from RichControl) | [To be supplied.]
KeyDown (inherited from Control) | [To be supplied.]
KeyPress (inherited from Control) | [To be supplied.]
KeyUp (inherited from Control) | [To be supplied.]
Layout (inherited from Control) | [To be supplied.]
Leave (inherited from Control) | [To be supplied.]
LostFocus (inherited from Control) | [To be supplied.]
MDIChildActivate (inherited from Form) | [To be supplied.]
MenuComplete (inherited from Form) | [To be supplied.]
MenuStart (inherited from Form) | [To be supplied.]
MouseDown (inherited from Control) | [To be supplied.]
MouseEnter (inherited from Control) | [To be supplied.]
MouseHover (inherited from Control) | [To be supplied.]
MouseLeave (inherited from Control) | [To be supplied.]
MouseMove (inherited from Control) | [To be supplied.]
MouseUp (inherited from Control) | [To be supplied.]
MouseWheel (inherited from Control) | [To be supplied.]
Move (inherited from Control) | [To be supplied.]
Paint (inherited from RichControl) | [To be supplied.]
PropertyChanged (inherited from Control) | [To be supplied.]
QueryContinueDrag (inherited from RichControl) | [To be supplied.]
Resize (inherited from Control) | [To be supplied.]
Validated (inherited from Control) | [To be supplied.]
Validating (inherited from Control) | [To be supplied.]

Protected:

Properties

CreateParams (inherited from Form) | Retrieves the CreateParams used to create the window. If a subclass overrides this function, it must call the super implementation.
CreateThreadId (inherited from Control) | Retrieves the Win32 thread ID of the thread that created the handle for this control. If the control's handle hasn't been created yet, this method will return the current thread's ID.
FontHeight (inherited from RichControl) | [To be supplied.]
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
InternalHandle (inherited from Control) | Returns the current value of the handle. This may be zero if the handle has not been created.
MaximizedBounds (inherited from Form) | Gets the size of the form when it is maximized.
MaxTrackSize (inherited from Form) | Gets the maximum size the form can be resized to.
MinTrackSize (inherited from Form) | Gets the minimum size the form can be resized to.
ParkingFormHandle (inherited from RichControl) | [To be supplied.]
RenderRightToLeft (inherited from RichControl) | [To be supplied.]
RichParent (inherited from RichControl) | [To be supplied.]
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.
WarningBanner (inherited from Form) | Determines if this form should be displayed with a warning banner.
WindowText (inherited from Form) | Gets or sets the text to display in the caption bar of the form.

Methods

AddEventHandler (inherited from Control) | [To be supplied.]
AdjustFormScrollbars (inherited from Form) | [To be supplied.]
ApplyAutoScaling (inherited from Form) | This auto scales the form based on the AutoScaleBaseSize.
AssignParent (inherited from RichControl) | Assigns a new parent control. Sends out the appropriate property change notifications for properties that are affected by the change of parent.
CenterToScreen (inherited from Form) | Centers the dialog to the screen. This will first attempt to use the owner property to determine the correct screen, then it will try the HWND owner of the form, and finally this will center the form on the same monitor as the mouse cursor.
ChildGotFocus (inherited from Control) | [To be supplied.]
CreateAccessibilityInstance (inherited from RichControl) | Constructs the new instance of the accessibility object for this control. Subclasses should not call base.CreateAccessibilityObject.
CreateControlsInstance (inherited from Form) | [To be supplied.]
CreateHandle (inherited from Form) | Creates the handle for the Form. If a subclass overrides this function, it must call the super implementation.
DefWndProc (inherited from Form) | Calls the default window proc for the form. If a subclass overrides this function, it must call the super implementation.
DestroyHandle (inherited from RichControl) | [To be supplied.]
Finalize (inherited from Control) | [To be supplied.]
GetEventHandler (inherited from RichControl) | RichControl overrides the default implementation of this for AX sourcing. ActiveX controls can "freeze" their events, and we implement this by returning null here if events are frozen.
GetScrollState (inherited from ScrollableControl) | Tests a given scroll state bit to determine if it is set.
GetStyle (inherited from Control) | Retrieves the current value of the specified bit in the control's style. NOTE: This is control style, not the Win32 style of the hwnd.
InitLayout (inherited from RichControl) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | [To be supplied.]
InvokeLostFocus (inherited from Control) | [To be supplied.]
InvokeOnClick (inherited from Control) | [To be supplied.]
InvokePaint (inherited from RichControl) | [To be supplied.]
InvokePaintBackground (inherited from RichControl) | [To be supplied.]
IsInputChar (inherited from Control) | Determines if charCode is an input character that the control wants. This method is called during window message pre-processing to determine whether the given input character should be pre-processed or sent directly to the control. If isInputChar returns true, the given character is sent directly to the control. If isInputChar returns false, the character is pre-processed and only sent to the control if it is not consumed by the pre-processing phase. The pre-processing of a character includes checking whether the character is a mnemonic of another control.
IsInputKey (inherited from Control) | Determines if keyData is an input key that the control wants. This method is called during window message pre-processing to determine whether the given input key should be pre-processed or sent directly to the control. If isInputKey returns true, the given key is sent directly to the control. If isInputKey returns false, the key is pre-processed and only sent to the control if it is not consumed by the pre-processing phase. Keys that are pre-processed include TAB, RETURN, ESCAPE, and arrow keys.
Listbox_drawItem | This draws a row of the listbox.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from RichControl) | [To be supplied.]
OnActivate (inherited from Form) | The activate event is fired when the form is activated.
OnClick (inherited from Control) | This method actually raises the Click event. Inheriting classes should override this if they wish to be notified of a Click event. (This is far preferable to actually adding an event handler.) They should not, however, forget to call base.onClick(e); before exiting, to ensure that other recipients do actually get the event.
OnClosed (inherited from Form) | The Closed event is fired when the form is closed.
OnClosing (inherited from Form) | The Closing event is fired when the form is closed.
OnControlAdded (inherited from Control) | Called when a child control is added to this control.
OnControlRemoved (inherited from ContainerControl) | Called when a child control is removed from this control.
OnCreateControl (inherited from Form) | Fired when this control is first created.
OnCreateHandle (inherited from RichControl) | Inheriting classes should override this method to find out when the handle has been created. Call base.onCreateHandle first.
OnDeactivate (inherited from Form) | The deactivate event is fired when the form is deactivated.
OnDestroyHandle (inherited from RichControl) | Inheriting classes should override this method to find out when the handle is about to be destroyed. Call base.onDestroyHandle last.
OnDoubleClick (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onDoubleClick to send this event to any registered event listeners.
OnDragDrop (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragDrop to send this event to any registered event listeners.
OnDragEnter (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragEnter to send this event to any registered event listeners.
OnDragLeave (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragLeave to send this event to any registered event listeners.
OnDragOver (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragOver to send this event to any registered event listeners.
OnEnter (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onEnter to send this event to any registered event listeners.
OnGiveFeedback (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onGiveFeedback to send this event to any registered event listeners.
OnGotFocus (inherited from RichControl) | [To be supplied.]
OnHelp (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onHelp to send this event to any registered event listeners.
OnInputLangChange (inherited from Form) | The InputLangChange event is fired after the input language has changed for this form.
OnInputLangChangeRequest (inherited from Form) | The InputLangChangeRequest event is fired when the user attempts to change the input language for this form. If the event is cancel then the input language will not change.
OnInvalidate (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.OnInvalidate to send this event to any registered event listeners.
OnKeyDown (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onKeyDown to send this event to any registered event listeners.
OnKeyPress (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.OnKeyPress to send this event to any registered event listeners.
OnKeyUp (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onKeyUp to send this event to any registered event listeners.
OnLayout (inherited from ScrollableControl) | Forces the layout of any docked or anchored child controls.
OnLeave (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onLeave to send this event to any registered event listeners.
OnLostFocus (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onLostFocus to send this event to any registered event listeners.
OnMDIChildActivate (inherited from Form) | Overloaded. [To be supplied.]
OnMenuComplete (inherited from Form) | Inheriting classes should override this method to provide user feedback after a menu selection has been completed. This method will be called when the menu selection has been completed, regardless of whether the user selected a menu item, or canceled the selection. This event signifies that the menu modal message loop has been exited.
OnMenuStart (inherited from Form) | Inheriting classes should override this method to provide user feedback when a menu is displayed. This method will be called when any menu is displayed. This event signifies that the menu modal message loop has been entered.
OnMouseDown (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseDown to send this event to any registered event listeners.
OnMouseEnter (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseEnter to send this event to any registered event listeners.
OnMouseHover (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseHover to send this event to any registered event listeners.
OnMouseLeave (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseLeave to send this event to any registered event listeners.
OnMouseMove (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseMove to send this event to any registered event listeners.
OnMouseUp (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseUp to send this event to any registered event listeners.
OnMouseWheel (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseWheel to send this event to any registered event listeners.
OnMove (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMove to send this event to any registered event listeners.
OnPaint (inherited from Form) | [To be supplied.]
OnPaintBackground (inherited from RichControl) | Inheriting classes should override this method to handle the erase background request from windows. It is not necessary to call base.onPaintBackground, however if you do not want the default Windows behavior you must set event.handled to true.
OnParentPropertyChanged (inherited from RichControl) | This method is called by the parent control when any property changes on the parent. This can be overriden by inheriting classes, however they must call base.OnParentPropertyChanged.
OnPropertyChanged (inherited from Form) | [To be supplied.]
OnQueryContinueDrag (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onQueryContinueDrag to send this event to any registered event listeners.
OnResize (inherited from Form) | [To be supplied.]
OnValidated (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onResize to send this event to any registered event listeners.
OnValidating (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onResize to send this event to any registered event listeners.
ParentChanged (inherited from Control) | Called by the framework after a control's parent changes. This allows (for example) child controls to automatically hook events on their parent, giving better encapsulation.
ProcessCmdKey (inherited from Form) | Processes a command key. Overrides Control.processCmdKey() to provide additional handling of main menu command keys and MDI accelerators.
ProcessDialogChar (inherited from ContainerControl) | Processes a dialog character. Overrides Control.processDialogChar(). This method calls the processMnemonic() method to check if the character is a mnemonic for one of the controls on the form. If processMnemonic() does not consume the character, then base.processDialogChar() is called.
ProcessDialogKey (inherited from Form) | Processes a dialog key. Overrides Control.processDialogKey(). This method implements handling of the RETURN, and ESCAPE keys in dialogs. The method performs no processing on keys that include the ALT or CONTROL modifiers.
ProcessKeyEventArgs (inherited from Control) | Processes a key message. This method is called when a control receives a keyboard message. The method is responsible for generating the appropriate key events for the message by calling OnKeyPress(), onKeyDown(), or onKeyUp(). The m parameter contains the window message that must be processed. Possible values for the m.msg field are WM_CHAR, WM_KEYDOWN, WM_SYSKEYDOWN, WM_KEYUP, WM_SYSKEYUP, and WM_IMECHAR. When overriding processKeyEventArgs(), a control should return true to indicate that it has processed the key. For keys that aren't processed by the control, the result of "base.processKeyEventArgs()" should be returned. Controls will seldom, if ever, need to override this method.
ProcessKeyPreview (inherited from Form) | UNDONE: ChrisAn, 12/13/1997- Need description 'processKeyPreview'
ProcessMnemonic (inherited from ContainerControl) | UNDONE: ChrisAn, 12/13/1997- Need description 'processMnemonic'
ProcessTabKey (inherited from Form) | UNDONE: ChrisAn, 12/13/1997- Need description 'processTabKey'
RaiseDragEventArgs (inherited from RichControl) | Raises the event associated with key with the event data of e and a sender of this control.
RaiseEvent (inherited from Control) | [To be supplied.]
RaiseKeyEventArgs (inherited from Control) | Raises the event associated with key with the event data of e and a sender of this control.
RaiseMouseEventArgs (inherited from Control) | Raises the event associated with key with the event data of e and a sender of this control.
RaisePaintEventArgs (inherited from RichControl) | Raises the event associated with key with the event data of e and a sender of this control.
RaisePropertyChangedEvent (inherited from Control) | Raises the property changed event. This creates the needed event data and then calls OnPropertyChanged.
RecreateHandle (inherited from Form) | [To be supplied.]
RemoveEventHandler (inherited from Control) | [To be supplied.]
RemoveEventHandlers (inherited from Control) | [To be supplied.]
ResetMouseEventArgs (inherited from Control) | Resets the mouse leave listeners.
ResumeLayout (inherited from Control) | Overloaded. [To be supplied.]
RTLTranslateAlignment (inherited from RichControl) | Overloaded. [To be supplied.]
RTLTranslateContent (inherited from RichControl) | [To be supplied.]
RTLTranslateHorizontal (inherited from RichControl) | [To be supplied.]
RTLTranslateLeftRight (inherited from RichControl) | [To be supplied.]
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
SendMessage (inherited from Control) | Overloaded. [To be supplied.]
SetBoundsCore (inherited from Form) | [To be supplied.]
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Adjusts the displayRect to be at the offset x, y. The contents of the Form is scrolled using Windows.ScrollWindowEx.
SetScrollState (inherited from ScrollableControl) | Sets a given scroll state bit.
SetStyle (inherited from Control) | Sets the current value of the specified bit in the control's style. NOTE: This is control style, not the Win32 style of the hwnd.
UpdateBounds (inherited from Control) | Overloaded. [To be supplied.]
UpdateDefaultButton (inherited from Form) | Updates the default button based on current selection, and the acceptButton property.
UpdateStyles (inherited from Control) | Forces styles to be reapplied to the handle. This function will call CreateParams to get the styles to apply.
UpdateZOrder (inherited from Control) | Updates this control in it's parent's zorder.
WmSysColorChange (inherited from Control) | Handles the WM_SYSCOLORCHANGE message
WndProc (inherited from Form) | Base wndProc encapsulation.
WndProcException (inherited from RichControl) | [To be supplied.]

Fields

editor | Associated ArrayEditor.
type | Type of the elements of the array.

Event Hookup:

Methods

AddOnActivate (inherited from Form) | Adds an event handler for the activate event. The activate event is fired when the form is activated.
AddOnClick (inherited from Control) | Adds an event handler for the click event. The click event occurs when the user clicks in the client area of the control.
AddOnClosed (inherited from Form) | Adds an event handler for the Close devent. The Closed event is fired when the form is closed.
AddOnClosing (inherited from Form) | Adds an event handler for the Closing event. The Closing event is fired when the form is closed.
AddOnControlAdded (inherited from Control) | Adds an event handler for the ControlAdded event. This event is raised after a control is added as a child to this control.
AddOnControlRemoved (inherited from Control) | Adds an event handler for the ControlRemoved event. This event is raised after a child control is removed from this control.
AddOnCreateHandle (inherited from Control) | Adds an event handler for the createHandle event. The createHandle event occurs immediately after the control's handle is created.
AddOnDeactivate (inherited from Form) | Adds an event handler for the deactivate event. The deactivate event is fired when the form is deactivated.
AddOnDestroyHandle (inherited from Control) | Adds an event handler for the destroyHandle event. The destroyHandle event occurs immediately before the control's handle is destroyed.
AddOnDoubleClick (inherited from Control) | Adds an event handler for the doubleClick event. The doubleClick event occurs when the user double clicks in the client area of the control.
AddOnDragDrop (inherited from RichControl) | Adds an event handler for the dragDrop event. The dragDrop evnet occurs when the user releases the mouse button while dragging some Object over the control.
AddOnDragEnter (inherited from RichControl) | Adds an event handler for the dragEnter event. The drawEnter event occurs when the user first moves the mouse over the control while dragging some Object.
AddOnDragLeave (inherited from RichControl) | Adds an event handler for the dragLeave event. The dragLeave event occurs when the user first moves the mouse out of the control while dragging some Object.
AddOnDragOver (inherited from RichControl) | Adds an event handler for the dragOver event. The dragOver event occurs whenever the user moves the mouse over the control while draggin some Object.
AddOnEnter (inherited from Control) | Adds an event handler for the enter event. The enter event occurs when focus enters this control. This doesn't imply that this control has focus, but rather that this control or some child control of this control has gotten focus.
AddOnGiveFeedback (inherited from RichControl) | Adds an event handler for the giveFeedback event. The giveFeedback event occurs during a drag operation. This allows the source of a drag event to modify the mouse pointer to give the user visual feedback as to what would happen if they droped.
AddOnGotFocus (inherited from Control) | Adds an event handler for the gotFocus event. The gotFocus event occurs when the this control gains focus.
AddOnHelp (inherited from RichControl) | Adds an event handler for the help event. The help event occurs when the user requests help for this control. This may be caused by the user pressing F1, or used "Whats This Help".
AddOnInputLangChange (inherited from Form) | Adds an event handler for the InputLangChange event. The InputLangChange event is fired after the input language has changed for this form.
AddOnInputLangChangeRequest (inherited from Form) | Adds an event handler for the InputLangChangeRequest event. The InputLangChangeRequest event is fired when the user attempts to change the input language for this form. If the event is cancel then the input language will not change.
AddOnInvalidate (inherited from RichControl) | Adds an event handler for the invalidate event. The invalidate event occurs when the Invalidate method is called on some part of the control's client area. This event may be used to identify when the contents of a window have changed.
AddOnKeyDown (inherited from Control) | Adds an event handler for the keyDown event. The keyDown event occurs when the user presses a key down.
AddOnKeyPress (inherited from Control) | Adds an event handler for the keyPress event. The keyPress event occurs when the user presses a key.
AddOnKeyUp (inherited from Control) | Adds an event handler for the keyUp event. The keyUp event occurs when the user releases a key.
AddOnLayout (inherited from Control) | Adds an event handler for the layout event. The layout event occurs when any event occurs that would cause the control to layout child controls. These events include; resize, show/hide child controls, add/remove child controls. This event should be used to perform any custom layout logic.
AddOnLeave (inherited from Control) | Adds an event handler for the leave event. The leave event occurs when focus leaves this control. This doesn't imply that this control lost focus, but rather that focus has been moved out of this control and any child controls.
AddOnLostFocus (inherited from Control) | Adds an event handler for the lostFocus event. The lostFocus event occurs when this control looses focus.
AddOnMDIChildActivate (inherited from Form) | Adds an event handler for the MDIChildActivate event. The MDIChildActivate occurs when a MDIChild window is activated.
AddOnMenuComplete (inherited from Form) | [To be supplied.]
AddOnMenuStart (inherited from Form) | [To be supplied.]
AddOnMouseDown (inherited from Control) | Adds an event handler for the mouseDown event. The mouseDown event occurs when the user presses the mouseDown over this control.
AddOnMouseEnter (inherited from Control) | Adds an event handler for the mouseEnter event. The mouseEnter event occurs when the mouse first moves over this control.
AddOnMouseHover (inherited from Control) | Adds an event handler for the mouseHover event. The mouseHover event occurs after the mouse is inside a control for an amount.
AddOnMouseLeave (inherited from Control) | Adds an event handler for the mouseLeave event. The mouseLeave event occurs when the mouse first moves out of this control.
AddOnMouseMove (inherited from Control) | Adds an event handler for the mouseMove event. The mouseMove event occurs whenever the user moves the mouse over this control.
AddOnMouseUp (inherited from Control) | Adds an event handler for the mouseUp event. The mouseUp event occurs when the user releases a mouse button inside the control.
AddOnMouseWheel (inherited from Control) | Adds an event handler for the mouseWheel event. The mouseWheel event occurs when the user scrolls the mouse wheel up or down. The delta value in the event data indicates the amount that the mouse wheel has moved. The Microsoft standards indicate that the view should scroll by System.WinForms.SystemInformation.getMouseWheelScrollLines() when the delta value has reach win.WHEEL_DELTA. If a mouseWheel event occurs with a value less that WHEEL_DELTA, the control should either increment a stored value and wait until the total delta is an increment of WHEEL_DELTA, or scroll the view a percentage of MouseWheelScrollLines. NOTE: A press of the mouseWheel will generate a mouseDown event with the middle button pressed.
AddOnMove (inherited from Control) | Adds an event handler for the move event. The move event occurs when the controls location changes.
AddOnPaint (inherited from RichControl) | Adds an event handler for the paint event. The paint event occurs when the control needs to paint some part of it's client area.
AddOnPropertyChanged (inherited from Control) | Adds an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.
AddOnQueryContinueDrag (inherited from RichControl) | Adds an event handler for the queryContinueDrag event. The queryContinueDrag event occurs during a drag operation. This allows the drag source to determine if the drag operation should be canceled.
AddOnResize (inherited from Control) | Adds an event handler for the resize event. The resize event occurs when the bounds of the control change. This event may be fired from the constructor of base controls.
AddOnValidated (inherited from Control) | Adds an event handler for the validated event. The validated event occurs when a control was successfully validated.
AddOnValidating (inherited from Control) | Adds an event handler for the validating event. The validating event occurs when the control loses focus and a control that causes validation gains focus. This is where users can write code to validate the current values of the control.
RemoveOnActivate (inherited from Form) | Removes an event handler for the activate event.
RemoveOnClick (inherited from Control) | Removes the given handler for the "OnClick" event. If there are duplicate entries, ALL are removed.
RemoveOnClosed (inherited from Form) | Removes an event handler for the Closed event.
RemoveOnClosing (inherited from Form) | Removes an event handler for the Closing event.
RemoveOnControlAdded (inherited from Control) | Removes the given handler for the "ControlAdded" event. If there are duplicate entries, ALL are removed.
RemoveOnControlRemoved (inherited from Control) | Removes the given handler for the "ControlRemoved" event. If there are duplicate entries, ALL are removed.
RemoveOnCreateHandle (inherited from Control) | Removes the given handler for the "createHandle" event. If there are duplicate entries, ALL are removed.
RemoveOnDeactivate (inherited from Form) | Removes an event handler for the deactivate event.
RemoveOnDestroyHandle (inherited from Control) | Removes the given handler for the "destroyHandle" event. If there are duplicate entries, ALL are removed.
RemoveOnDoubleClick (inherited from Control) | Removes the given handler for the "OnDoubleClick" event. If there are duplicate entries, ALL are removed.
RemoveOnDragDrop (inherited from RichControl) | Removes the given handler for the "dragDrop" event. If there are duplicate entries, ALL are removed.
RemoveOnDragEnter (inherited from RichControl) | Removes the given handler for the "OnDragEnter" event. If there are duplicate entries, ALL are removed.
RemoveOnDragLeave (inherited from RichControl) | Removes the given handler for the "OnDragLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnDragOver (inherited from RichControl) | f final Removes the given handler for the "OnDragOver" event. If there are duplicate entries, ALL are removed.
RemoveOnEnter (inherited from Control) | Removes the given handler for the "OnEnter" event. If there are dfinal uplicate entries, ALL are removed.
RemoveOnGiveFeedback (inherited from RichControl) | Removes the given handler for the "OnGiveFeedback" event. If there are duplicate entries, ALL are removed.
RemoveOnGotFocus (inherited from Control) | Removes the given handler for the "OnGotFocus" event. If there are duplicate entries, ALL are removed.
RemoveOnHelp (inherited from RichControl) | Removes the given handler for the "OnHelp" event. If there are duplicate entries, ALL are removed.
RemoveOnInputLangChange (inherited from Form) | Removes an event handler for the InputLangChange event.
RemoveOnInputLangChangeRequest (inherited from Form) | Removes an event handler for the InputLangChangeRequest event.
RemoveOnInvalidate (inherited from RichControl) | Removes the given handler for the "OnInvalidate" event. If there are duplicate entries, ALL are removed.
RemoveOnKeyDown (inherited from Control) | Removes the given handler for the "OnKeyDown" event. If there are duplicate entries, ALL are removed.
RemoveOnKeyPress (inherited from Control) | Removes the given handler for the "OnKeyPress" event. If there are duplicate entries, ALL are removed.
RemoveOnKeyUp (inherited from Control) | Removes the given handler for the "OnKeyUp" event. If there are duplicate entries, ALL are removed.
RemoveOnLayout (inherited from Control) | Removes the given handler for the layout event. If there are duplicate entries, ALL are removed.
RemoveOnLeave (inherited from Control) | Removes the given handler for the "OnLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnLostFocus (inherited from Control) | Removes the given handler for the "OnLostFocus" event. If there are duplicate entries, ALL are removed.
RemoveOnMDIChildActivate (inherited from Form) | Removes an event handler for the MDIChildActivate event.
RemoveOnMenuComplete (inherited from Form) | [To be supplied.]
RemoveOnMenuStart (inherited from Form) | [To be supplied.]
RemoveOnMouseDown (inherited from Control) | Removes the given handler for the "OnMouseDown" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseEnter (inherited from Control) | Removes the given handler for the "OnMouseEnter" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseHover (inherited from Control) | Removes the given handler for the "OnMouseHover" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseLeave (inherited from Control) | Removes the given handler for the "OnMouseLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseMove (inherited from Control) | Removes the given handler for the "OnMouseMove" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseUp (inherited from Control) | Removes the given handler for the "OnMouseUp" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseWheel (inherited from Control) | Removes the given handler for the "OnMouseWheel" event. If there are duplicate entries, ALL are removed.
RemoveOnMove (inherited from Control) | Removes the given handler for the "OnMove" event. If there are duplicate entries, ALL are removed.
RemoveOnPaint (inherited from RichControl) | Removes the given handler for the "OnPaint" event. If there are duplicate entries, ALL are removed.
RemoveOnPropertyChanged (inherited from Control) | Removes an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.
RemoveOnQueryContinueDrag (inherited from RichControl) | Removes the given handler for the "OnQueryContinueDrag" event. If there are duplicate entries, ALL are removed.
RemoveOnResize (inherited from Control) | Removes the given handler for the "OnResize" event. If there are duplicate entries, ALL are removed.
RemoveOnValidated (inherited from Control) | Removes an event handler for the validated event. The validated event occurs when a control was successfully validated.
RemoveOnValidating (inherited from Control) | Removes an event handler for the validating event. The validating event occurs when the control loses focus and a control that causes validation gains focus. This is where users can write code to validate the current values of the control.

See Also

ArrayDialog Class | System.ComponentModel.Design Namespace


ArrayDialog Constructor

Constructs an ArrayDialog given a type and the ArrayEditor.

[Visual Basic]
Public Sub New( _
   ByVal type As Type, _
   ByVal editor As OldArrayEditor _
)
[C#]
public ArrayDialog(
   Type type,
   OldArrayEditor editor
);
[C++]
public: ArrayDialog(
   Type* type,
   OldArrayEditor* editor
);
[JScript]
public function ArrayDialog(
   type : Type,
   editor : OldArrayEditor
);

Parameters

type
of the array to be edited.
editor
that contains a method to create new elements.

See Also

ArrayDialog Class | ArrayDialog Members | System.ComponentModel.Design Namespace | ArrayEditor


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ArrayDialog Methods

The methods of the ArrayDialog class are listed below. For a complete list of ArrayDialog class members, see the ArrayDialog Members topic.

Public:

Activate (inherited from Form) | Activates the form and gives it focus.
ActivateControl (inherited from ContainerControl) | [To be supplied.]
AddOwnedForm (inherited from Form) | Adds an owned form to this form. Owned forms are other top level forms that are children of this form.
BeginInvoke (inherited from RichControl) | Overloaded. [To be supplied.]
BringToFront (inherited from Control) | Brings this control to the front of the zorder.
CallWndProc (inherited from Control) | Dispatch the method to this window's wndProc directly.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Checks if a control is a child of this control.
CreateControl (inherited from Control) | Forces the creation of the control. This includes the creation of the handle, and any child controls.
CreateGraphics (inherited from RichControl) | Overloaded. [To be supplied.]
CreateWindowGraphics (inherited from RichControl) | Creates a Graphics for the entire window of the control rather than just it's client area. The controls foreground color and background color become the default values for the Graphics. The returned Graphics must be disposed through a call to its dispose() method when it is no longer needed. The Graphics Object is only valid for the duration of the current window's message.
Dispose (inherited from Form) | Releases all the system resources associated with the Form. If a subclass overrides this function, it must call the super implementation.
DoDragDrop (inherited from RichControl) | Begins a drag operation. The allowedEffects determine which drag operations can occur. If the drag operation needs to interop with applications in another process, data should either be a base managed class (String, Bitmap, or Metafile) or some Object that implements System.ComponentModel.IPersistable. data can also be any Object that implements System.WinForms.IDataObject.
EndInvoke (inherited from RichControl) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult interface passed. If the async operation has not been completed, this function will block until the result is available.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FindForm (inherited from Form) | Retrieves the form that this control is parented to.
Focus (inherited from Control) | Attempts to set focus to this control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified client coordinates.
GetContainer (inherited from MarshalByRefComponent) | Returns the component's container.
GetContainerControl (inherited from Control) | Returns the closest ContainerControl in the control's chain of parent controls and forms.
GetDesignMode (inherited from MarshalByRefComponent) | Determines whether the component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetItems | Returns an array of items, typed as type[] (where type was passed in to the constructor).
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetMDIClient (inherited from Form) | Returns the control that is the MDI Client region.
GetNextControl (inherited from Control) | Retrieves the next control in the tab order of child controls.
GetServiceObject (inherited from MarshalByRefComponent) | The implementation of IServiceObjectProvider
GetType (inherited from Object) | Gets the Type of the Object.
Hide (inherited from Control) | Hides the control by setting the visible property to false;
InitializeLifetimeService (inherited from MarshalByRefObject)
Invalidate (inherited from RichControl) | Overloaded. [To be supplied.]
Invoke (inherited from RichControl) | Overloaded. [To be supplied.]
LayoutMDI (inherited from Form) | Arranges the MDI child forms according to value, which should be a member of the MDILayout enum.
PerformLayout (inherited from Control) | Overloaded. [To be supplied.]
PointToClient (inherited from Form) | [To be supplied.]
PointToScreen (inherited from Form) | [To be supplied.]
PreProcessMessage (inherited from Control) | This method is called by the application's message loop to pre-process input messages before they are dispatched. Possible values for the msg.message field are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR. If this method processes the message it must return true, in which case the message loop will not dispatch the message. For WM_KEYDOWN and WM_SYSKEYDOWN messages, preProcessMessage() first calls processCmdKey() to check for command keys such as accelerators and menu shortcuts. If processCmdKey() doesn't process the message, then isInputKey() is called to check whether the key message represents an input key for the control. Finally, if isInputKey() indicates that the control isn't interested in the key message, then processDialogKey() is called to check for dialog keys such as TAB, arrow keys, and mnemonics. For WM_CHAR messages, preProcessMessage() first calls isInputChar() to check whether the character message represents an input character for the control. If isInputChar() indicates that the control isn't interested in the character message, then processDialogChar() is called to check for dialog characters such as mnemonics. For WM_SYSCHAR messages, preProcessMessage() calls processDialogChar() to check for dialog characters such as mnemonics. When overriding preProcessMessage(), a control should return true to indicate that it has processed the message. For messages that aren't processed by the control, the result of "base.preProcessMessage()" should be returned. Controls will typically override one of the more specialized methods (isInputChar(), isInputKey(), processCmdKey(), processDialogChar(), or processDialogKey()) instead of overriding preProcessMessage().
RectangleToClient (inherited from Form) | [To be supplied.]
RectangleToScreen (inherited from Form) | [To be supplied.]
Refresh (inherited from Control) | Forces the control to invalidate and immediately repaint itself and any children.
RemoveOwnedForm (inherited from Form) | Removes a form from the list of owned forms. Also sets the owner of the removed form to null.
ResetBackColor (inherited from RichControl) | Resets the back color to be based on the parent's back color.
ResetBindings (inherited from RichControl) | [To be supplied.]
ResetCursor (inherited from RichControl) | [To be supplied.]
ResetFont (inherited from RichControl) | Resets the font to be based on the parent's font.
ResetForeColor (inherited from RichControl) | Resets the fore color to be based on the parent's fore color.
ResetRightToLeft (inherited from RichControl) | Resets the RightToLeft to be the default.
ResetText (inherited from Control) | Resets the text to it's default value.
ResumeLayout (inherited from Control) | Overloaded. [To be supplied.]
Scale (inherited from Control) | Overloaded. [To be supplied.]
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the currently active control into view if we are an AutoScroll Form that has the Horiz or Vert scrollbar displayed...
Select (inherited from Control) | Activates this control.
SelectNextControl (inherited from Control) | Selects the next control following ctl.
SendMessage (inherited from Control) | Overloaded. [To be supplied.]
SendToBack (inherited from Control) | sends this control to the back of the z-order
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. [To be supplied.]
SetClientSize (inherited from Control) | Sets the height and width of the client area of the control.
SetDesktopBounds (inherited from Form) | Sets the bounds of the Form in desktop coordinates. Desktop coordinates are based on the working area of the screen, which excludes the Taskbar.
SetDesktopLocation (inherited from Form) | Sets the location of the Form in desktop coordinates.
SetItems | Sets the array of items to be edited by the ArrayDialog.
SetLocation (inherited from Control) | Sets the location of this control.
SetNewControls (inherited from Form) | [To be supplied.]
SetSize (inherited from Control) | Sets the size of this control.
ShouldPersistAutoScaleBaseSize (inherited from Form) | [To be supplied.]
ShouldPersistAutoScrollMargin (inherited from ScrollableControl) | Indicates whether the AutoScrollMargin property should be persisted.
ShouldPersistAutoScrollMinSize (inherited from ScrollableControl) | Indicates whether the AutoScrollMinSize property should be persisted.
ShouldPersistAutoScrollPosition (inherited from ScrollableControl) | Indicates whether the AutoScrollPosition property should be persisted.
ShouldPersistBackColor (inherited from Form) | [To be supplied.]
ShouldPersistBindings (inherited from RichControl) | [To be supplied.]
ShouldPersistCursor (inherited from RichControl) | Returns true if the cursor should be persisted in code gen.
ShouldPersistFont (inherited from RichControl) | Returns true if the font should be persisted in code gen.
ShouldPersistForeColor (inherited from Form) | [To be supplied.]
ShouldPersistIcon (inherited from Form) | [To be supplied.]
ShouldPersistLocation (inherited from Control) | Determines if the Location property needs to be persisted.
ShouldPersistRightToLeft (inherited from RichControl) | Returns true if the RightToLeft should be persisted in code gen.
ShouldPersistSize (inherited from Form) | [To be supplied.]
ShouldPersistText (inherited from Control) | Determines if the Text property needs to be persisted.
Show (inherited from Control) | Makes the control display by setting the visible property to true
ShowDialog (inherited from Form) | Overloaded. [To be supplied.]
SuspendLayout (inherited from Control) | Suspends the layout logic for the control.
ToString (inherited from Form) | Returns a string representation for this control.
Update (inherited from Control) | Forces the control to paint any currently invalid areas.
Validate (inherited from ContainerControl) | Validates the last unvalidated control and it's ancestors up through (but not including) this.

Protected:

AddEventHandler (inherited from Control) | [To be supplied.]
AdjustFormScrollbars (inherited from Form) | [To be supplied.]
ApplyAutoScaling (inherited from Form) | This auto scales the form based on the AutoScaleBaseSize.
AssignParent (inherited from RichControl) | Assigns a new parent control. Sends out the appropriate property change notifications for properties that are affected by the change of parent.
CenterToScreen (inherited from Form) | Centers the dialog to the screen. This will first attempt to use the owner property to determine the correct screen, then it will try the HWND owner of the form, and finally this will center the form on the same monitor as the mouse cursor.
ChildGotFocus (inherited from Control) | [To be supplied.]
CreateAccessibilityInstance (inherited from RichControl) | Constructs the new instance of the accessibility object for this control. Subclasses should not call base.CreateAccessibilityObject.
CreateControlsInstance (inherited from Form) | [To be supplied.]
CreateHandle (inherited from Form) | Creates the handle for the Form. If a subclass overrides this function, it must call the super implementation.
DefWndProc (inherited from Form) | Calls the default window proc for the form. If a subclass overrides this function, it must call the super implementation.
DestroyHandle (inherited from RichControl) | [To be supplied.]
Finalize (inherited from Control) | [To be supplied.]
GetEventHandler (inherited from RichControl) | RichControl overrides the default implementation of this for AX sourcing. ActiveX controls can "freeze" their events, and we implement this by returning null here if events are frozen.
GetScrollState (inherited from ScrollableControl) | Tests a given scroll state bit to determine if it is set.
GetStyle (inherited from Control) | Retrieves the current value of the specified bit in the control's style. NOTE: This is control style, not the Win32 style of the hwnd.
InitLayout (inherited from RichControl) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | [To be supplied.]
InvokeLostFocus (inherited from Control) | [To be supplied.]
InvokeOnClick (inherited from Control) | [To be supplied.]
InvokePaint (inherited from RichControl) | [To be supplied.]
InvokePaintBackground (inherited from RichControl) | [To be supplied.]
IsInputChar (inherited from Control) | Determines if charCode is an input character that the control wants. This method is called during window message pre-processing to determine whether the given input character should be pre-processed or sent directly to the control. If isInputChar returns true, the given character is sent directly to the control. If isInputChar returns false, the character is pre-processed and only sent to the control if it is not consumed by the pre-processing phase. The pre-processing of a character includes checking whether the character is a mnemonic of another control.
IsInputKey (inherited from Control) | Determines if keyData is an input key that the control wants. This method is called during window message pre-processing to determine whether the given input key should be pre-processed or sent directly to the control. If isInputKey returns true, the given key is sent directly to the control. If isInputKey returns false, the key is pre-processed and only sent to the control if it is not consumed by the pre-processing phase. Keys that are pre-processed include TAB, RETURN, ESCAPE, and arrow keys.
Listbox_drawItem | This draws a row of the listbox.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from RichControl) | [To be supplied.]
OnActivate (inherited from Form) | The activate event is fired when the form is activated.
OnClick (inherited from Control) | This method actually raises the Click event. Inheriting classes should override this if they wish to be notified of a Click event. (This is far preferable to actually adding an event handler.) They should not, however, forget to call base.onClick(e); before exiting, to ensure that other recipients do actually get the event.
OnClosed (inherited from Form) | The Closed event is fired when the form is closed.
OnClosing (inherited from Form) | The Closing event is fired when the form is closed.
OnControlAdded (inherited from Control) | Called when a child control is added to this control.
OnControlRemoved (inherited from ContainerControl) | Called when a child control is removed from this control.
OnCreateControl (inherited from Form) | Fired when this control is first created.
OnCreateHandle (inherited from RichControl) | Inheriting classes should override this method to find out when the handle has been created. Call base.onCreateHandle first.
OnDeactivate (inherited from Form) | The deactivate event is fired when the form is deactivated.
OnDestroyHandle (inherited from RichControl) | Inheriting classes should override this method to find out when the handle is about to be destroyed. Call base.onDestroyHandle last.
OnDoubleClick (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onDoubleClick to send this event to any registered event listeners.
OnDragDrop (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragDrop to send this event to any registered event listeners.
OnDragEnter (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragEnter to send this event to any registered event listeners.
OnDragLeave (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragLeave to send this event to any registered event listeners.
OnDragOver (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragOver to send this event to any registered event listeners.
OnEnter (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onEnter to send this event to any registered event listeners.
OnGiveFeedback (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onGiveFeedback to send this event to any registered event listeners.
OnGotFocus (inherited from RichControl) | [To be supplied.]
OnHelp (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onHelp to send this event to any registered event listeners.
OnInputLangChange (inherited from Form) | The InputLangChange event is fired after the input language has changed for this form.
OnInputLangChangeRequest (inherited from Form) | The InputLangChangeRequest event is fired when the user attempts to change the input language for this form. If the event is cancel then the input language will not change.
OnInvalidate (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.OnInvalidate to send this event to any registered event listeners.
OnKeyDown (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onKeyDown to send this event to any registered event listeners.
OnKeyPress (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.OnKeyPress to send this event to any registered event listeners.
OnKeyUp (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onKeyUp to send this event to any registered event listeners.
OnLayout (inherited from ScrollableControl) | Forces the layout of any docked or anchored child controls.
OnLeave (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onLeave to send this event to any registered event listeners.
OnLostFocus (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onLostFocus to send this event to any registered event listeners.
OnMDIChildActivate (inherited from Form) | Overloaded. [To be supplied.]
OnMenuComplete (inherited from Form) | Inheriting classes should override this method to provide user feedback after a menu selection has been completed. This method will be called when the menu selection has been completed, regardless of whether the user selected a menu item, or canceled the selection. This event signifies that the menu modal message loop has been exited.
OnMenuStart (inherited from Form) | Inheriting classes should override this method to provide user feedback when a menu is displayed. This method will be called when any menu is displayed. This event signifies that the menu modal message loop has been entered.
OnMouseDown (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseDown to send this event to any registered event listeners.
OnMouseEnter (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseEnter to send this event to any registered event listeners.
OnMouseHover (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseHover to send this event to any registered event listeners.
OnMouseLeave (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseLeave to send this event to any registered event listeners.
OnMouseMove (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseMove to send this event to any registered event listeners.
OnMouseUp (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseUp to send this event to any registered event listeners.
OnMouseWheel (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseWheel to send this event to any registered event listeners.
OnMove (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMove to send this event to any registered event listeners.
OnPaint (inherited from Form) | [To be supplied.]
OnPaintBackground (inherited from RichControl) | Inheriting classes should override this method to handle the erase background request from windows. It is not necessary to call base.onPaintBackground, however if you do not want the default Windows behavior you must set event.handled to true.
OnParentPropertyChanged (inherited from RichControl) | This method is called by the parent control when any property changes on the parent. This can be overriden by inheriting classes, however they must call base.OnParentPropertyChanged.
OnPropertyChanged (inherited from Form) | [To be supplied.]
OnQueryContinueDrag (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onQueryContinueDrag to send this event to any registered event listeners.
OnResize (inherited from Form) | [To be supplied.]
OnValidated (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onResize to send this event to any registered event listeners.
OnValidating (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onResize to send this event to any registered event listeners.
ParentChanged (inherited from Control) | Called by the framework after a control's parent changes. This allows (for example) child controls to automatically hook events on their parent, giving better encapsulation.
ProcessCmdKey (inherited from Form) | Processes a command key. Overrides Control.processCmdKey() to provide additional handling of main menu command keys and MDI accelerators.
ProcessDialogChar (inherited from ContainerControl) | Processes a dialog character. Overrides Control.processDialogChar(). This method calls the processMnemonic() method to check if the character is a mnemonic for one of the controls on the form. If processMnemonic() does not consume the character, then base.processDialogChar() is called.
ProcessDialogKey (inherited from Form) | Processes a dialog key. Overrides Control.processDialogKey(). This method implements handling of the RETURN, and ESCAPE keys in dialogs. The method performs no processing on keys that include the ALT or CONTROL modifiers.
ProcessKeyEventArgs (inherited from Control) | Processes a key message. This method is called when a control receives a keyboard message. The method is responsible for generating the appropriate key events for the message by calling OnKeyPress(), onKeyDown(), or onKeyUp(). The m parameter contains the window message that must be processed. Possible values for the m.msg field are WM_CHAR, WM_KEYDOWN, WM_SYSKEYDOWN, WM_KEYUP, WM_SYSKEYUP, and WM_IMECHAR. When overriding processKeyEventArgs(), a control should return true to indicate that it has processed the key. For keys that aren't processed by the control, the result of "base.processKeyEventArgs()" should be returned. Controls will seldom, if ever, need to override this method.
ProcessKeyPreview (inherited from Form) | UNDONE: ChrisAn, 12/13/1997- Need description 'processKeyPreview'
ProcessMnemonic (inherited from ContainerControl) | UNDONE: ChrisAn, 12/13/1997- Need description 'processMnemonic'
ProcessTabKey (inherited from Form) | UNDONE: ChrisAn, 12/13/1997- Need description 'processTabKey'
RaiseDragEventArgs (inherited from RichControl) | Raises the event associated with key with the event data of e and a sender of this control.
RaiseEvent (inherited from Control) | [To be supplied.]
RaiseKeyEventArgs (inherited from Control) | Raises the event associated with key with the event data of e and a sender of this control.
RaiseMouseEventArgs (inherited from Control) | Raises the event associated with key with the event data of e and a sender of this control.
RaisePaintEventArgs (inherited from RichControl) | Raises the event associated with key with the event data of e and a sender of this control.
RaisePropertyChangedEvent (inherited from Control) | Raises the property changed event. This creates the needed event data and then calls OnPropertyChanged.
RecreateHandle (inherited from Form) | [To be supplied.]
RemoveEventHandler (inherited from Control) | [To be supplied.]
RemoveEventHandlers (inherited from Control) | [To be supplied.]
ResetMouseEventArgs (inherited from Control) | Resets the mouse leave listeners.
ResumeLayout (inherited from Control) | Overloaded. [To be supplied.]
RTLTranslateAlignment (inherited from RichControl) | Overloaded. [To be supplied.]
RTLTranslateContent (inherited from RichControl) | [To be supplied.]
RTLTranslateHorizontal (inherited from RichControl) | [To be supplied.]
RTLTranslateLeftRight (inherited from RichControl) | [To be supplied.]
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
SendMessage (inherited from Control) | Overloaded. [To be supplied.]
SetBoundsCore (inherited from Form) | [To be supplied.]
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Adjusts the displayRect to be at the offset x, y. The contents of the Form is scrolled using Windows.ScrollWindowEx.
SetScrollState (inherited from ScrollableControl) | Sets a given scroll state bit.
SetStyle (inherited from Control) | Sets the current value of the specified bit in the control's style. NOTE: This is control style, not the Win32 style of the hwnd.
UpdateBounds (inherited from Control) | Overloaded. [To be supplied.]
UpdateDefaultButton (inherited from Form) | Updates the default button based on current selection, and the acceptButton property.
UpdateStyles (inherited from Control) | Forces styles to be reapplied to the handle. This function will call CreateParams to get the styles to apply.
UpdateZOrder (inherited from Control) | Updates this control in it's parent's zorder.
WmSysColorChange (inherited from Control) | Handles the WM_SYSCOLORCHANGE message
WndProc (inherited from Form) | Base wndProc encapsulation.
WndProcException (inherited from RichControl) | [To be supplied.]

Event Hookup:

AddOnActivate (inherited from Form) | Adds an event handler for the activate event. The activate event is fired when the form is activated.
AddOnClick (inherited from Control) | Adds an event handler for the click event. The click event occurs when the user clicks in the client area of the control.
AddOnClosed (inherited from Form) | Adds an event handler for the Close devent. The Closed event is fired when the form is closed.
AddOnClosing (inherited from Form) | Adds an event handler for the Closing event. The Closing event is fired when the form is closed.
AddOnControlAdded (inherited from Control) | Adds an event handler for the ControlAdded event. This event is raised after a control is added as a child to this control.
AddOnControlRemoved (inherited from Control) | Adds an event handler for the ControlRemoved event. This event is raised after a child control is removed from this control.
AddOnCreateHandle (inherited from Control) | Adds an event handler for the createHandle event. The createHandle event occurs immediately after the control's handle is created.
AddOnDeactivate (inherited from Form) | Adds an event handler for the deactivate event. The deactivate event is fired when the form is deactivated.
AddOnDestroyHandle (inherited from Control) | Adds an event handler for the destroyHandle event. The destroyHandle event occurs immediately before the control's handle is destroyed.
AddOnDoubleClick (inherited from Control) | Adds an event handler for the doubleClick event. The doubleClick event occurs when the user double clicks in the client area of the control.
AddOnDragDrop (inherited from RichControl) | Adds an event handler for the dragDrop event. The dragDrop evnet occurs when the user releases the mouse button while dragging some Object over the control.
AddOnDragEnter (inherited from RichControl) | Adds an event handler for the dragEnter event. The drawEnter event occurs when the user first moves the mouse over the control while dragging some Object.
AddOnDragLeave (inherited from RichControl) | Adds an event handler for the dragLeave event. The dragLeave event occurs when the user first moves the mouse out of the control while dragging some Object.
AddOnDragOver (inherited from RichControl) | Adds an event handler for the dragOver event. The dragOver event occurs whenever the user moves the mouse over the control while draggin some Object.
AddOnEnter (inherited from Control) | Adds an event handler for the enter event. The enter event occurs when focus enters this control. This doesn't imply that this control has focus, but rather that this control or some child control of this control has gotten focus.
AddOnGiveFeedback (inherited from RichControl) | Adds an event handler for the giveFeedback event. The giveFeedback event occurs during a drag operation. This allows the source of a drag event to modify the mouse pointer to give the user visual feedback as to what would happen if they droped.
AddOnGotFocus (inherited from Control) | Adds an event handler for the gotFocus event. The gotFocus event occurs when the this control gains focus.
AddOnHelp (inherited from RichControl) | Adds an event handler for the help event. The help event occurs when the user requests help for this control. This may be caused by the user pressing F1, or used "Whats This Help".
AddOnInputLangChange (inherited from Form) | Adds an event handler for the InputLangChange event. The InputLangChange event is fired after the input language has changed for this form.
AddOnInputLangChangeRequest (inherited from Form) | Adds an event handler for the InputLangChangeRequest event. The InputLangChangeRequest event is fired when the user attempts to change the input language for this form. If the event is cancel then the input language will not change.
AddOnInvalidate (inherited from RichControl) | Adds an event handler for the invalidate event. The invalidate event occurs when the Invalidate method is called on some part of the control's client area. This event may be used to identify when the contents of a window have changed.
AddOnKeyDown (inherited from Control) | Adds an event handler for the keyDown event. The keyDown event occurs when the user presses a key down.
AddOnKeyPress (inherited from Control) | Adds an event handler for the keyPress event. The keyPress event occurs when the user presses a key.
AddOnKeyUp (inherited from Control) | Adds an event handler for the keyUp event. The keyUp event occurs when the user releases a key.
AddOnLayout (inherited from Control) | Adds an event handler for the layout event. The layout event occurs when any event occurs that would cause the control to layout child controls. These events include; resize, show/hide child controls, add/remove child controls. This event should be used to perform any custom layout logic.
AddOnLeave (inherited from Control) | Adds an event handler for the leave event. The leave event occurs when focus leaves this control. This doesn't imply that this control lost focus, but rather that focus has been moved out of this control and any child controls.
AddOnLostFocus (inherited from Control) | Adds an event handler for the lostFocus event. The lostFocus event occurs when this control looses focus.
AddOnMDIChildActivate (inherited from Form) | Adds an event handler for the MDIChildActivate event. The MDIChildActivate occurs when a MDIChild window is activated.
AddOnMenuComplete (inherited from Form) | [To be supplied.]
AddOnMenuStart (inherited from Form) | [To be supplied.]
AddOnMouseDown (inherited from Control) | Adds an event handler for the mouseDown event. The mouseDown event occurs when the user presses the mouseDown over this control.
AddOnMouseEnter (inherited from Control) | Adds an event handler for the mouseEnter event. The mouseEnter event occurs when the mouse first moves over this control.
AddOnMouseHover (inherited from Control) | Adds an event handler for the mouseHover event. The mouseHover event occurs after the mouse is inside a control for an amount.
AddOnMouseLeave (inherited from Control) | Adds an event handler for the mouseLeave event. The mouseLeave event occurs when the mouse first moves out of this control.
AddOnMouseMove (inherited from Control) | Adds an event handler for the mouseMove event. The mouseMove event occurs whenever the user moves the mouse over this control.
AddOnMouseUp (inherited from Control) | Adds an event handler for the mouseUp event. The mouseUp event occurs when the user releases a mouse button inside the control.
AddOnMouseWheel (inherited from Control) | Adds an event handler for the mouseWheel event. The mouseWheel event occurs when the user scrolls the mouse wheel up or down. The delta value in the event data indicates the amount that the mouse wheel has moved. The Microsoft standards indicate that the view should scroll by System.WinForms.SystemInformation.getMouseWheelScrollLines() when the delta value has reach win.WHEEL_DELTA. If a mouseWheel event occurs with a value less that WHEEL_DELTA, the control should either increment a stored value and wait until the total delta is an increment of WHEEL_DELTA, or scroll the view a percentage of MouseWheelScrollLines. NOTE: A press of the mouseWheel will generate a mouseDown event with the middle button pressed.
AddOnMove (inherited from Control) | Adds an event handler for the move event. The move event occurs when the controls location changes.
AddOnPaint (inherited from RichControl) | Adds an event handler for the paint event. The paint event occurs when the control needs to paint some part of it's client area.
AddOnPropertyChanged (inherited from Control) | Adds an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.
AddOnQueryContinueDrag (inherited from RichControl) | Adds an event handler for the queryContinueDrag event. The queryContinueDrag event occurs during a drag operation. This allows the drag source to determine if the drag operation should be canceled.
AddOnResize (inherited from Control) | Adds an event handler for the resize event. The resize event occurs when the bounds of the control change. This event may be fired from the constructor of base controls.
AddOnValidated (inherited from Control) | Adds an event handler for the validated event. The validated event occurs when a control was successfully validated.
AddOnValidating (inherited from Control) | Adds an event handler for the validating event. The validating event occurs when the control loses focus and a control that causes validation gains focus. This is where users can write code to validate the current values of the control.
RemoveOnActivate (inherited from Form) | Removes an event handler for the activate event.
RemoveOnClick (inherited from Control) | Removes the given handler for the "OnClick" event. If there are duplicate entries, ALL are removed.
RemoveOnClosed (inherited from Form) | Removes an event handler for the Closed event.
RemoveOnClosing (inherited from Form) | Removes an event handler for the Closing event.
RemoveOnControlAdded (inherited from Control) | Removes the given handler for the "ControlAdded" event. If there are duplicate entries, ALL are removed.
RemoveOnControlRemoved (inherited from Control) | Removes the given handler for the "ControlRemoved" event. If there are duplicate entries, ALL are removed.
RemoveOnCreateHandle (inherited from Control) | Removes the given handler for the "createHandle" event. If there are duplicate entries, ALL are removed.
RemoveOnDeactivate (inherited from Form) | Removes an event handler for the deactivate event.
RemoveOnDestroyHandle (inherited from Control) | Removes the given handler for the "destroyHandle" event. If there are duplicate entries, ALL are removed.
RemoveOnDoubleClick (inherited from Control) | Removes the given handler for the "OnDoubleClick" event. If there are duplicate entries, ALL are removed.
RemoveOnDragDrop (inherited from RichControl) | Removes the given handler for the "dragDrop" event. If there are duplicate entries, ALL are removed.
RemoveOnDragEnter (inherited from RichControl) | Removes the given handler for the "OnDragEnter" event. If there are duplicate entries, ALL are removed.
RemoveOnDragLeave (inherited from RichControl) | Removes the given handler for the "OnDragLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnDragOver (inherited from RichControl) | f final Removes the given handler for the "OnDragOver" event. If there are duplicate entries, ALL are removed.
RemoveOnEnter (inherited from Control) | Removes the given handler for the "OnEnter" event. If there are dfinal uplicate entries, ALL are removed.
RemoveOnGiveFeedback (inherited from RichControl) | Removes the given handler for the "OnGiveFeedback" event. If there are duplicate entries, ALL are removed.
RemoveOnGotFocus (inherited from Control) | Removes the given handler for the "OnGotFocus" event. If there are duplicate entries, ALL are removed.
RemoveOnHelp (inherited from RichControl) | Removes the given handler for the "OnHelp" event. If there are duplicate entries, ALL are removed.
RemoveOnInputLangChange (inherited from Form) | Removes an event handler for the InputLangChange event.
RemoveOnInputLangChangeRequest (inherited from Form) | Removes an event handler for the InputLangChangeRequest event.
RemoveOnInvalidate (inherited from RichControl) | Removes the given handler for the "OnInvalidate" event. If there are duplicate entries, ALL are removed.
RemoveOnKeyDown (inherited from Control) | Removes the given handler for the "OnKeyDown" event. If there are duplicate entries, ALL are removed.
RemoveOnKeyPress (inherited from Control) | Removes the given handler for the "OnKeyPress" event. If there are duplicate entries, ALL are removed.
RemoveOnKeyUp (inherited from Control) | Removes the given handler for the "OnKeyUp" event. If there are duplicate entries, ALL are removed.
RemoveOnLayout (inherited from Control) | Removes the given handler for the layout event. If there are duplicate entries, ALL are removed.
RemoveOnLeave (inherited from Control) | Removes the given handler for the "OnLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnLostFocus (inherited from Control) | Removes the given handler for the "OnLostFocus" event. If there are duplicate entries, ALL are removed.
RemoveOnMDIChildActivate (inherited from Form) | Removes an event handler for the MDIChildActivate event.
RemoveOnMenuComplete (inherited from Form) | [To be supplied.]
RemoveOnMenuStart (inherited from Form) | [To be supplied.]
RemoveOnMouseDown (inherited from Control) | Removes the given handler for the "OnMouseDown" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseEnter (inherited from Control) | Removes the given handler for the "OnMouseEnter" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseHover (inherited from Control) | Removes the given handler for the "OnMouseHover" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseLeave (inherited from Control) | Removes the given handler for the "OnMouseLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseMove (inherited from Control) | Removes the given handler for the "OnMouseMove" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseUp (inherited from Control) | Removes the given handler for the "OnMouseUp" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseWheel (inherited from Control) | Removes the given handler for the "OnMouseWheel" event. If there are duplicate entries, ALL are removed.
RemoveOnMove (inherited from Control) | Removes the given handler for the "OnMove" event. If there are duplicate entries, ALL are removed.
RemoveOnPaint (inherited from RichControl) | Removes the given handler for the "OnPaint" event. If there are duplicate entries, ALL are removed.
RemoveOnPropertyChanged (inherited from Control) | Removes an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.
RemoveOnQueryContinueDrag (inherited from RichControl) | Removes the given handler for the "OnQueryContinueDrag" event. If there are duplicate entries, ALL are removed.
RemoveOnResize (inherited from Control) | Removes the given handler for the "OnResize" event. If there are duplicate entries, ALL are removed.
RemoveOnValidated (inherited from Control) | Removes an event handler for the validated event. The validated event occurs when a control was successfully validated.
RemoveOnValidating (inherited from Control) | Removes an event handler for the validating event. The validating event occurs when the control loses focus and a control that causes validation gains focus. This is where users can write code to validate the current values of the control.

See Also

ArrayDialog Class | System.ComponentModel.Design Namespace


ArrayDialog.GetItems

Returns an array of items, typed as type[] (where type was passed in to the constructor).

[Visual Basic]
Overridable Public Function GetItems() As Array
[C#]
public virtual Array GetItems();
[C++]
public: virtual Array* GetItems();
[JScript]
public function GetItems() : Array;

Return Value

array that was constructed using the ArrayDialog.

See Also

ArrayDialog Class | ArrayDialog Members | System.ComponentModel.Design Namespace


ArrayDialog.Listbox_drawItem

This draws a row of the listbox.

[Visual Basic]
Overridable Protected Sub Listbox_drawItem( _
   ByVal sender As Object, _
   ByVal e As DrawItemEventArgs _
)
[C#]
protected virtual void Listbox_drawItem(
   object sender,
   DrawItemEventArgs e
);
[C++]
protected: virtual void Listbox_drawItem(
   Object* sender,
   DrawItemEventArgs* e
);
[JScript]
protected function Listbox_drawItem(
   sender : Object,
   e : DrawItemEventArgs
);

Parameters

sender
[To be supplied.]
e
[To be supplied.]

See Also

ArrayDialog Class | ArrayDialog Members | System.ComponentModel.Design Namespace


ArrayDialog.SetItems

Sets the array of items to be edited by the ArrayDialog.

[Visual Basic]
Overridable Public Sub SetItems( _
   ByVal items As Array _
)
[C#]
public virtual void SetItems(
   Array items
);
[C++]
public: virtual void SetItems(
   Array* items
);
[JScript]
public function SetItems(
   items : Array
);

Parameters

items
array of items to be edited.

See Also

ArrayDialog Class | ArrayDialog Members | System.ComponentModel.Design Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ArrayDialog Fields

The fields of the ArrayDialog class are listed below. For a complete list of ArrayDialog class members, see the ArrayDialog Members topic.

Protected:

editor | Associated ArrayEditor.
type | Type of the elements of the array.

See Also

ArrayDialog Class | System.ComponentModel.Design Namespace


ArrayDialog.editor

Associated ArrayEditor.

[Visual Basic]
Protected editor As OldArrayEditor
[C#]
protected OldArrayEditor editor;
[C++]
protected: OldArrayEditor* editor;
[JScript]
protected var editor : OldArrayEditor;

See Also

ArrayDialog Class | ArrayDialog Members | System.ComponentModel.Design Namespace


ArrayDialog.type

Type of the elements of the array.

[Visual Basic]
Protected type As Type
[C#]
protected Type type;
[C++]
protected: Type* type;
[JScript]
protected var type : Type;

See Also

ArrayDialog Class | ArrayDialog Members | System.ComponentModel.Design Namespace


ArrayEditor Class

ArrayEditor derives from CollectionEditor to edit arrays of values.

Object
UITypeEditor
CollectionEditor
ArrayEditor

[Visual Basic]
Public Class ArrayEditor
   Inherits CollectionEditor
[C#]
public class ArrayEditor : CollectionEditor
[C++]
public __gc class ArrayEditor : public CollectionEditor
[JScript]
public class ArrayEditor extends CollectionEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

ArrayEditor Members | System.ComponentModel.Design Namespace


ArrayEditor Members

Public:

Constructor

ArrayEditor Constructor [To be supplied.]

Methods

EditValue (inherited from CollectionEditor) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEditStyle (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

CollectionItemType (inherited from CollectionEditor) | The data type of each item in the collection.
CollectionType (inherited from CollectionEditor) | Retrieves the data type of the collection we are editing.
Context (inherited from CollectionEditor) | The type descriptor context that is currently in use, or null if no context is available.
NewItemTypes (inherited from CollectionEditor) | The available item types that can be created for this collection. This defaults to a single type of CollectionItemType. If more than one type is returned the collection editor will provide a way to choose which item to create.

Methods

CanRemoveInstance (inherited from CollectionEditor) | This will be called when the user tries to remove an instance from the collection that is an original member of the collection. It will not be called when removing instances that were added in this editing session since they are not yet part of the collection.
CreateCollectionForm (inherited from CollectionEditor) | Creates a new form to show the current collection. You may inherit from CollectionForm to provide your own form.
CreateCollectionItemType | Retrieves the data type this collection contains. The default implementation looks inside of the collection for the Item property and returns the returning datatype of the item. Do not call this method directly. Instead, use the CollectionItemType property. Use this method to override the default implementation.
CreateInstance (inherited from CollectionEditor) | Creates a new instance of the given collection item type.
CreateNewItemTypes (inherited from CollectionEditor) | Retrieves the data types this collection editor can create. The default implementation looks inside of the collection for the Item property and returns the returning datatype of the item. Do not call this method directly. Instead, use the NewItemTypes property. Use this method to override the default implementation.
DestroyInstance (inherited from CollectionEditor) | Destroys the given instance of the object.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetItems | We implement the getting and setting of items on this collection.
GetServiceObject (inherited from CollectionEditor) | Retrieves the requested service, if it is available.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetItems | We implement the getting and setting of items on this collection. It should return an instance to replace editValue with, or editValue if there is no need to replace the instance.

See Also

ArrayEditor Class | System.ComponentModel.Design Namespace


ArrayEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal type As Type _
)
[C#]
public ArrayEditor(
   Type type
);
[C++]
public: ArrayEditor(
   Type* type
);
[JScript]
public function ArrayEditor(
   type : Type
);

Parameters

type
[To be supplied.]

See Also

ArrayEditor Class | ArrayEditor Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ArrayEditor Methods

The methods of the ArrayEditor class are listed below. For a complete list of ArrayEditor class members, see the ArrayEditor Members topic.

Public:

EditValue (inherited from CollectionEditor) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEditStyle (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

CanRemoveInstance (inherited from CollectionEditor) | This will be called when the user tries to remove an instance from the collection that is an original member of the collection. It will not be called when removing instances that were added in this editing session since they are not yet part of the collection.
CreateCollectionForm (inherited from CollectionEditor) | Creates a new form to show the current collection. You may inherit from CollectionForm to provide your own form.
CreateCollectionItemType | Retrieves the data type this collection contains. The default implementation looks inside of the collection for the Item property and returns the returning datatype of the item. Do not call this method directly. Instead, use the CollectionItemType property. Use this method to override the default implementation.
CreateInstance (inherited from CollectionEditor) | Creates a new instance of the given collection item type.
CreateNewItemTypes (inherited from CollectionEditor) | Retrieves the data types this collection editor can create. The default implementation looks inside of the collection for the Item property and returns the returning datatype of the item. Do not call this method directly. Instead, use the NewItemTypes property. Use this method to override the default implementation.
DestroyInstance (inherited from CollectionEditor) | Destroys the given instance of the object.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetItems | We implement the getting and setting of items on this collection.
GetServiceObject (inherited from CollectionEditor) | Retrieves the requested service, if it is available.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetItems | We implement the getting and setting of items on this collection. It should return an instance to replace editValue with, or editValue if there is no need to replace the instance.

See Also

ArrayEditor Class | System.ComponentModel.Design Namespace


ArrayEditor.CreateCollectionItemType

Retrieves the data type this collection contains. The default implementation looks inside of the collection for the Item property and returns the returning datatype of the item. Do not call this method directly. Instead, use the CollectionItemType property. Use this method to override the default implementation.

[Visual Basic]
Overrides Protected Function CreateCollectionItemType() As Type
[C#]
protected override Type CreateCollectionItemType();
[C++]
protected: override Type* CreateCollectionItemType();
[JScript]
protected override function CreateCollectionItemType() : Type;

Return Value

The data type the collection is designed to contain.

See Also

ArrayEditor Class | ArrayEditor Members | System.ComponentModel.Design Namespace


ArrayEditor.GetItems

We implement the getting and setting of items on this collection.

[Visual Basic]
Overrides Protected Function GetItems( _
   ByVal editValue As Object _
) As Object ()
[C#]
protected override object[] GetItems(
   object editValue
);
[C++]
protected: override Object* GetItems(
   Object* editValue
) [];
[JScript]
protected override function GetItems(
   editValue : Object
) : Object[];

Parameters

editValue
[To be supplied.]

See Also

ArrayEditor Class | ArrayEditor Members | System.ComponentModel.Design Namespace


ArrayEditor.SetItems

We implement the getting and setting of items on this collection. It should return an instance to replace editValue with, or editValue if there is no need to replace the instance.

[Visual Basic]
Overrides Protected Function SetItems( _
   ByVal editValue As Object, _
   ByVal value() As Object _
) As Object
[C#]
protected override object SetItems(
   object editValue,
   object[] value
);
[C++]
protected: override Object* SetItems(
   Object* editValue,
   Object* value[]
);
[JScript]
protected override function SetItems(
   editValue : Object,
   value : Object[]
) : Object;

Parameters

editValue
[To be supplied.]
value
[To be supplied.]

See Also

ArrayEditor Class | ArrayEditor Members | System.ComponentModel.Design Namespace


BatchOperationEventArgs Class

Provides data about the System.ComponentModel.Design.IDesignerHost.BatchOperation event.

Object
EventArgs
BatchOperationEventArgs

[Visual Basic]
Public Class BatchOperationEventArgs
   Inherits EventArgs
[C#]
public class BatchOperationEventArgs : EventArgs
[C++]
public __gc class BatchOperationEventArgs : public EventArgs
[JScript]
public class BatchOperationEventArgs extends EventArgs

Remarks

Batch operations can refresh multiple components at once. Batch operation methods provide a convenient way to prevent performance and flicker problems by deferring expensive processing on multiple components until after the operation has completed.

A System.ComponentModel.Design.BatchOperationEvent.BatchOperationEvent event will occur at the start of a batch operation, and again be raised upon last exit of the operation; nested calls do not generate these events. Also, if the designer host is currently within a batch operation and an object adds an event handler, the handler will be invoked immediately.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

BatchOperationEventArgs Members | System.ComponentModel.Design Namespace | BatchOperationEventHandler


BatchOperationEventArgs Members

Public:

Constructor

BatchOperationEventArgs Constructor Initializes a new instance of the BatchOperationEventArgs class.

Properties

ExtendedInfo (inherited from EventArgs) Holds a reference to an object that manages the event's state.

Methods

Beginning | Gets a value indicating whether the batch operation is beginning.
Ending | Gets a value indicating whether the batch operation is ending.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BatchOperationEventArgs Class | System.ComponentModel.Design Namespace


BatchOperationEventArgs Constructor

Initializes a new instance of the BatchOperationEventArgs class.

[Visual Basic]
Public Sub New( _
   ByVal begin As Boolean _
)
[C#]
public BatchOperationEventArgs(
   bool begin
);
[C++]
public: BatchOperationEventArgs(
   bool begin
);
[JScript]
public function BatchOperationEventArgs(
   begin : Boolean
);

Parameters

begin
true to indicate the call is at the beginning of the batch operation; false to indicate the call is at the end of the batch operation.

Remarks

The constructor takes a boolean value as a parameter indicating whether or not the batch operation is just beginning.

See Also

BatchOperationEventArgs Class | BatchOperationEventArgs Members | System.ComponentModel.Design Namespace | BatchOperationEventHandler


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

BatchOperationEventArgs Methods

The methods of the BatchOperationEventArgs class are listed below. For a complete list of BatchOperationEventArgs class members, see the BatchOperationEventArgs Members topic.

Public:

Beginning | Gets a value indicating whether the batch operation is beginning.
Ending | Gets a value indicating whether the batch operation is ending.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BatchOperationEventArgs Class | System.ComponentModel.Design Namespace


BatchOperationEventArgs.Beginning

Gets a value indicating whether the batch operation is beginning.

[Visual Basic]
Overridable Public Function Beginning() As Boolean
[C#]
public virtual bool Beginning();
[C++]
public: virtual bool Beginning();
[JScript]
public function Beginning() : Boolean;

Return Value

true if the beginning of a batch operation; otherwise, false.

See Also

BatchOperationEventArgs Class | BatchOperationEventArgs Members | System.ComponentModel.Design Namespace | System.ComponentModel.Design.BatchOperationEvent.Ending


BatchOperationEventArgs.Ending

Gets a value indicating whether the batch operation is ending.

[Visual Basic]
Overridable Public Function Ending() As Boolean
[C#]
public virtual bool Ending();
[C++]
public: virtual bool Ending();
[JScript]
public function Ending() : Boolean;

Return Value

true if the ending of a batch operation; otherwise, false.

See Also

BatchOperationEventArgs Class | BatchOperationEventArgs Members | System.ComponentModel.Design Namespace | System.ComponentModel.Design.BatchOperationEvent.Beginning


BatchOperationEventHandler Delegate

Represents the method that will handle the System.ComponentModel.Design.IDesignerHost.BatchOperation event.

[Visual Basic]
Public Delegate Sub BatchOperationEventHandler( _
   ByVal sender As Object, _
   ByVal e As BatchOperationEventArgs _
)
[C#]
public delegate void BatchOperationEventHandler(
   object sender,
   BatchOperationEventArgs e
);
[C++]
public __gc __delegate void BatchOperationEventHandler(
   Object* sender,
   BatchOperationEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the BatchOperationEventHandler delegate declaration.

sender
The source of the event.
e
A BatchOperationEventArgs that contains the event data.

Remarks

When you create a BatchOperationEventHandler delegate, you identify the method that handles the event. For an overview, see TBD.

To associate the event with your event-handling method, call the AddOn method of the IDesignerHost. The event-handling method is called whenever the event occurs, until you call the RemoveOn method of the control.

Note Delegates are the underlying mechanism for events, but most of the time you won't use them directly. For details, see TBD.

Batch operations can refresh multiple components at once. Batch operation methods provide a way to prevent performance and flicker problems by deferring expensive processing on multiple components until after the operation has completed. A System.ComponentModel.Design.IDesignerHost.BatchOperation event will occur upon first entry of a batch operation, and again upon last exit of the operation; nested calls do not generate events. Also, if the designer host is currently within a batch operation and an object adds an event handler, the handler will be invoked immediately.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

System.ComponentModel.Design Namespace | System.ComponentModel.Design.BatchOperationEvent


BinaryEditor Class

Generic editor for editing binary data. This presents a hex editing window to the user.

Object
UITypeEditor
BinaryEditor

[Visual Basic]
Public Class BinaryEditor
   Inherits UITypeEditor
[C#]
public class BinaryEditor : UITypeEditor
[C++]
public __gc class BinaryEditor : public UITypeEditor
[JScript]
public class BinaryEditor extends UITypeEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

BinaryEditor Members | System.ComponentModel.Design Namespace


BinaryEditor Members

Public:

Constructor

BinaryEditor Constructor [To be supplied.]

Methods

EditValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEditStyle (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

ConvertToBytes | Converts the given object to an array of bytes to be manipulated by the editor. The default implementation of this supports byte[] and stream objects.
ConvertToValue | Converts the given byte array back into a native object. If the object itself needs to be replace (as is the case for arrays), then a new object may be assigned out through the parameter.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BinaryEditor Class | System.ComponentModel.Design Namespace


BinaryEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public BinaryEditor();
[C++]
public: BinaryEditor();
[JScript]
public function BinaryEditor();

See Also

BinaryEditor Class | BinaryEditor Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

BinaryEditor Methods

The methods of the BinaryEditor class are listed below. For a complete list of BinaryEditor class members, see the BinaryEditor Members topic.

Public:

EditValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEditStyle (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

ConvertToBytes | Converts the given object to an array of bytes to be manipulated by the editor. The default implementation of this supports byte[] and stream objects.
ConvertToValue | Converts the given byte array back into a native object. If the object itself needs to be replace (as is the case for arrays), then a new object may be assigned out through the parameter.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BinaryEditor Class | System.ComponentModel.Design Namespace


BinaryEditor.ConvertToBytes

Converts the given object to an array of bytes to be manipulated by the editor. The default implementation of this supports byte[] and stream objects.

[Visual Basic]
Overridable Protected Function ConvertToBytes( _
   ByVal value As Object _
) As Byte ()
[C#]
protected virtual byte[] ConvertToBytes(
   object value
);
[C++]
protected: virtual unsigned char* ConvertToBytes(
   Object* value
) [];
[JScript]
protected function ConvertToBytes(
   value : Object
) : Byte[];

Parameters

value
An object value to convert.

Return Value

An array of bytes representing this object, or null if there is no known conversion.

See Also

BinaryEditor Class | BinaryEditor Members | System.ComponentModel.Design Namespace


BinaryEditor.ConvertToValue

Converts the given byte array back into a native object. If the object itself needs to be replace (as is the case for arrays), then a new object may be assigned out through the parameter.

[Visual Basic]
Overridable Protected Sub ConvertToValue( _
   ByVal bytes() As Byte, _
   ByRef value As Object _
)
[C#]
protected virtual void ConvertToValue(
   byte[] bytes,
   ref object value
);
[C++]
protected: virtual void ConvertToValue(
   unsigned char* bytes[],
   Object** value
);
[JScript]
protected function ConvertToValue(
   bytes : Byte[],
   value : Object
);

Parameters

bytes
The array of bytes to convert.
value
The object to store the array into. If you relace value, you should replace it with the same type.

See Also

BinaryEditor Class | BinaryEditor Members | System.ComponentModel.Design Namespace


BinaryEditor.EditValue

Edits the given object value using the editor style provided by GetEditorStyle. A service provider is provided so that any required editing services can be obtained.

[Visual Basic]
Overrides Public Function EditValue( _
   ByVal context As ITypeDescriptorContext, _
   ByVal provider As IServiceObjectProvider, _
   ByVal value As Object _
) As Object
[C#]
public override object EditValue(
   ITypeDescriptorContext context,
   IServiceObjectProvider provider,
   object value
);
[C++]
public: override Object* EditValue(
   ITypeDescriptorContext* context,
   IServiceObjectProvider* provider,
   Object* value
);
[JScript]
public override function EditValue(
   context : ITypeDescriptorContext,
   provider : IServiceObjectProvider,
   value : Object
) : Object;

Parameters

context
A type descriptor context that can be used to provide additional context information.
provider
A service provider object through which editing services may be obtained.
value
An instance of the value being edited.

Return Value

The new value of the object. If the value of the object hasn't changed, this should return the same object it was passed.

See Also

BinaryEditor Class | BinaryEditor Members | System.ComponentModel.Design Namespace


BinaryEditor.GetEditStyle

Retrieves the editing style of the Edit method. If the method is not supported, this will return None.

[Visual Basic]
Overrides Public Function GetEditStyle( _
   ByVal context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
[C#]
public override UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext context
);
[C++]
public: override UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetEditStyle(
   context : ITypeDescriptorContext
) : UITypeEditorEditStyle;

Parameters

context
A type descriptor context that can be used to provide additional context information.

Return Value

An enum value indicating the provided editing style.

See Also

BinaryEditor Class | BinaryEditor Members | System.ComponentModel.Design Namespace


BlankIntegerEditor Class

[To be supplied.]

Object
ValueEditor
WinFormValueEditor
IntegerEditor
BlankIntegerEditor

[Visual Basic]
Public Class BlankIntegerEditor
   Inherits IntegerEditor
[C#]
public class BlankIntegerEditor : IntegerEditor
[C++]
public __gc class BlankIntegerEditor : public IntegerEditor
[JScript]
public class BlankIntegerEditor extends IntegerEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

BlankIntegerEditor Members | System.ComponentModel.Design Namespace


BlankIntegerEditor Members

Public:

Constructor

BlankIntegerEditor Constructor [To be supplied.]

Properties

Style (inherited from ValueEditor) | [To be supplied.]
Values (inherited from ValueEditor) | [To be supplied.]

Methods

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from ValueEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue (inherited from ValueEditor) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from IntegerEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
PaintValue (inherited from WinFormValueEditor) | Paints a representation of the given value in the given Rectangle of the given Graphics. This method will only be called if the value editor specifies the StylePaintValue style.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BlankIntegerEditor Class | System.ComponentModel.Design Namespace


BlankIntegerEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public BlankIntegerEditor();
[C++]
public: BlankIntegerEditor();
[JScript]
public function BlankIntegerEditor();

See Also

BlankIntegerEditor Class | BlankIntegerEditor Members | System.ComponentModel.Design Namespace


ByteEditor Class

[To be supplied.]

Object
ValueEditor
ByteEditor

[Visual Basic]
Public Class ByteEditor
   Inherits ValueEditor
[C#]
public class ByteEditor : ValueEditor
[C++]
public __gc class ByteEditor : public ValueEditor
[JScript]
public class ByteEditor extends ValueEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

ByteEditor Members | System.ComponentModel.Design Namespace


ByteEditor Members

Public:

Constructor

ByteEditor Constructor [To be supplied.]

Properties

Style (inherited from ValueEditor) | [To be supplied.]
Values (inherited from ValueEditor) | [To be supplied.]

Methods

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from ValueEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue (inherited from ValueEditor) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from ValueEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ByteEditor Class | System.ComponentModel.Design Namespace


ByteEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ByteEditor();
[C++]
public: ByteEditor();
[JScript]
public function ByteEditor();

See Also

ByteEditor Class | ByteEditor Members | System.ComponentModel.Design Namespace


ByteViewer Class

This class implements a ByteViewer component. This component is capable of displaying byte arrays in HEXDUMP, ANSI and UNICODE views. The HEXDUMP view is a view with hex values and corresponding byte representations (chars). The dafault number of columns is 16. The ANSI and UNICODE views show the byte aray in a read only edit box. In this view the null characters are replaced with Windows box charcter alowing to display the entire buffer. The AUTO view selects a default display mode based on the contents of the byte array. It uses a simple algorithm to establish what kind of data is stored in the buffer

Object
MarshalByRefObject
MarshalByRefComponent
Control
RichControl
ByteViewer

[Visual Basic]
Public Class ByteViewer
   Inherits RichControl
[C#]
public class ByteViewer : RichControl
[C++]
public __gc class ByteViewer : public RichControl
[JScript]
public class ByteViewer extends RichControl

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

ByteViewer Members | System.ComponentModel.Design Namespace


ByteViewer Members

Public:

Constructor

ByteViewer Constructor Creates a ByteViewer objct

Properties

AccessibilityObject (inherited from RichControl) | The Accessibility Object for this RichControl
AccessibleDefaultActionDescription (inherited from RichControl) | The default action description of the control
AccessibleDescription (inherited from RichControl) | The accessible description of the control
AccessibleHelpProvider (inherited from RichControl) | The help provider for this RichControl
AccessibleName (inherited from RichControl) | The accessible name of the control
AccessibleRole (inherited from RichControl) | The accessible role of the control
AllowDrop (inherited from RichControl) | The allowDrop property. If allowDrop is set to true then this control will allow drag and drop operations and events to be used.
AllowTransparency (inherited from RichControl) | Determines if the control should be allowed to have the opacity adjusted. This is primarily a performance optimization, in that you can always set the opacity to any value, and that will force AllowTransparency to true. However, setting the opacity to any given value will switch the control into layered mode. By setting the AllowTransparency property to false the control will actually switch out of layered mode, which provides better performance if you don't intend to adjust the opacity.
Anchor (inherited from RichControl) | The current value of the anchor property. The anchor property determines which edges of the control are anchored to the container's edges.
BackColor (inherited from RichControl) | The background color of this control. This is an ambient property and will always return a non-null value.
BackgroundImage (inherited from RichControl) | The background image of the control.
BindingManager (inherited from RichControl) | [To be supplied.]
Bindings (inherited from RichControl) | Retrieves the bindings for this control.
Bottom (inherited from Control) | The bottom coordinate of this control.
Bounds (inherited from Control) | The bounds of this control. This is the window coordinates of the control in parent client coordinates.
CanFocus (inherited from Control) | Checks if this control can receive focus. The result is true if the control has a handle and if it and all of its parent controls are both visible and enabled.
CanSelect (inherited from Control) | Checks if this control can be selected. The result is true if the control is contained in a form and if all of its parent controls are both visible and enabled.
Capture (inherited from Control) | If this control has captured the mouse then this will return true.
CausesValidation (inherited from Control) | Indicates whether entering this control causes validation on the controls requiring validation. This is set to false usually for things like the Help button, etc...
ClientRectangle (inherited from Control) | The client rect of the control.
ClientSize (inherited from Control) | The size of the clientRect.
CompanyName (inherited from RichControl) | Retrieves the company name of this specific component.
ContainsFocus (inherited from Control) | Indicates whether the control or one of its children currently has the system focus.
ContextMenu (inherited from RichControl) | The contextMenu associated with this control. The contextMenu will be shown when the user right clicks the mouse on the control.
Controls (inherited from Control) | Collection of child controls.
Created (inherited from Control) | Returns true if the control has been created.
Cursor (inherited from RichControl) | Retrieves the cursor that will be displayed when the mouse is over this control.
DisplayRectangle (inherited from Control) | Returns the client rect of the display area of the control. For the base control class, this is identical to getClientRect. However, inheriting controls may want to change this if their client area differs from their display area.
Disposed (inherited from Control) | Indicates that the control has been disposed, and is no longer a valid Windows control even though the object instance is still alive.
Disposing (inherited from Control) | Indicates that the control is in the process of being beendisposed, and is no longer a valid Windows control even though the object instance is still alive.
Dock (inherited from RichControl) | The dock property. The dock property controls to which edge of the container this control is docked to. For example, when docked to the top of the container, the control will be displayed flush at the top of the container, extending the length of the container.
Enabled (inherited from Control) | The current enabled state of this control.
Focused (inherited from Control) | Returns true if this control has focus.
Font (inherited from RichControl) | Retrieves the current font for this control. This will be the font used by default for painting and text in the control.
ForeColor (inherited from RichControl) | The foreground color of the control.
Handle (inherited from Control) | The HWND handle that this control is bound to. If the handle has not yet been created, this will force handle creation.
HandleCreated (inherited from Control) | Whether or not this control has a handle associated with it.
Height (inherited from Control) | The height of this control
IMEMode (inherited from RichControl) | Specifies a value that determines the IME (Input Method Editor) status of the object when that object is selected.
InvokeRequired (inherited from RichControl) | Determines if the caller must call invoke when making method calls to this control. Controls in WinForms are bound to a specific thread, and are not thread safe. Therefore, if you are calling a control's method from a different thread, you must use the control's invoke method to marshal the call to the proper thread. This function can be used to determine if you must call invoke, which can be handy if you don't know what thread owns a control. There are five functions on a control that are safe to call from any thread: GetInvokeRequired, Invoke, BeginInvoke, EndInvoke and CreateGraphics. For all other metohd calls, you should use one of the invoke methods.
IsAccessible (inherited from RichControl) | Indicates whether or not this control is an accessible control i.e. whether it should be visible to accessibility applications.
Left (inherited from Control) | The left coordinate of this control.
Location (inherited from Control) | The location of this control.
Opacity (inherited from RichControl) | Determines the opacity of the control. This can only be set on top level controls. Opacity requires Windows 2000 or later, and is ignored on earlier operating systems.
Parent (inherited from Control) | The parent of this control.
ProductName (inherited from RichControl) | Retrieves the product name of this specific component.
ProductVersion (inherited from RichControl) | Retrieves the product version of this specific component.
RecreatingHandle (inherited from Control) | This is true if the control is currently recreating its handle.
Region (inherited from RichControl) | The Region associated with this control. (defines the outline/silhouette/boundary of control)
Right (inherited from Control) | The right coordinate of this control.
RightToLeft (inherited from RichControl) | This is used for international applications where the language is written from RightToLeft. When this property is true, control placement and text will be from right to left.
Site (inherited from MarshalByRefComponent) | Gets or sets the site of the component.
Size (inherited from Control) | The size of this control.
TabIndex (inherited from Control) | The tab index of this control. A tab index may consist of any valid integer number greater than or equal to zero. If more than one control on the same parent control has the same tab index, the z-order of the controls will be used to determine the order to pick the controls.
TabStop (inherited from Control) | A boolean value indicating whether the user can give the focus to this control using the TAB key.
Text (inherited from Control) | The current text associated with this control.
Top (inherited from Control) | Top coordinate of this control.
TopLevel (inherited from Control) | true if this control is a top level window, meaning that it has no parent.
TopLevelControl (inherited from Control) | The top level control that contains this control. This doesn't have to be the same as the value returned from getForm since forms can be parented to other controls.
Visible (inherited from Control) | Controls whether the control is visible.
Width (inherited from Control) | The width of this control.
WindowTarget (inherited from Control) | The target of Win32 window messages.

Methods

BeginInvoke (inherited from RichControl) | Overloaded. [To be supplied.]
BringToFront (inherited from Control) | Brings this control to the front of the zorder.
CallWndProc (inherited from Control) | Dispatch the method to this window's wndProc directly.
Contains (inherited from Control) | Checks if a control is a child of this control.
CreateControl (inherited from Control) | Forces the creation of the control. This includes the creation of the handle, and any child controls.
CreateGraphics (inherited from RichControl) | Overloaded. [To be supplied.]
CreateWindowGraphics (inherited from RichControl) | Creates a Graphics for the entire window of the control rather than just it's client area. The controls foreground color and background color become the default values for the Graphics. The returned Graphics must be disposed through a call to its dispose() method when it is no longer needed. The Graphics Object is only valid for the duration of the current window's message.
Dispose (inherited from RichControl) | [To be supplied.]
DoDragDrop (inherited from RichControl) | Begins a drag operation. The allowedEffects determine which drag operations can occur. If the drag operation needs to interop with applications in another process, data should either be a base managed class (String, Bitmap, or Metafile) or some Object that implements System.ComponentModel.IPersistable. data can also be any Object that implements System.WinForms.IDataObject.
EndInvoke (inherited from RichControl) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult interface passed. If the async operation has not been completed, this function will block until the result is available.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FindForm (inherited from RichControl) | Retrieves the form that this control is on. The control's parent may not be the same as the form.
Focus (inherited from Control) | Attempts to set focus to this control.
GetBytes | Returns the buffer
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified client coordinates.
GetContainer (inherited from MarshalByRefComponent) | Returns the component's container.
GetContainerControl (inherited from Control) | Returns the closest ContainerControl in the control's chain of parent controls and forms.
GetDesignMode (inherited from MarshalByRefComponent) | Determines whether the component is currently in design mode.
GetDisplayMode | Returns the display mode for the control
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetNextControl (inherited from Control) | Retrieves the next control in the tab order of child controls.
GetServiceObject (inherited from MarshalByRefComponent) | The implementation of IServiceObjectProvider
GetType (inherited from Object) | Gets the Type of the Object.
Hide (inherited from Control) | Hides the control by setting the visible property to false;
InitializeLifetimeService (inherited from MarshalByRefObject)
Invalidate (inherited from RichControl) | Overloaded. [To be supplied.]
Invoke (inherited from RichControl) | Overloaded. [To be supplied.]
PerformLayout (inherited from Control) | Overloaded. [To be supplied.]
PointToClient (inherited from Control) | Computes the location of the screen point p in client coords.
PointToScreen (inherited from Control) | Computes the location of the client point p in screen coords.
PreProcessMessage (inherited from Control) | This method is called by the application's message loop to pre-process input messages before they are dispatched. Possible values for the msg.message field are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR. If this method processes the message it must return true, in which case the message loop will not dispatch the message. For WM_KEYDOWN and WM_SYSKEYDOWN messages, preProcessMessage() first calls processCmdKey() to check for command keys such as accelerators and menu shortcuts. If processCmdKey() doesn't process the message, then isInputKey() is called to check whether the key message represents an input key for the control. Finally, if isInputKey() indicates that the control isn't interested in the key message, then processDialogKey() is called to check for dialog keys such as TAB, arrow keys, and mnemonics. For WM_CHAR messages, preProcessMessage() first calls isInputChar() to check whether the character message represents an input character for the control. If isInputChar() indicates that the control isn't interested in the character message, then processDialogChar() is called to check for dialog characters such as mnemonics. For WM_SYSCHAR messages, preProcessMessage() calls processDialogChar() to check for dialog characters such as mnemonics. When overriding preProcessMessage(), a control should return true to indicate that it has processed the message. For messages that aren't processed by the control, the result of "base.preProcessMessage()" should be returned. Controls will typically override one of the more specialized methods (isInputChar(), isInputKey(), processCmdKey(), processDialogChar(), or processDialogKey()) instead of overriding preProcessMessage().
RectangleToClient (inherited from Control) | Computes the location of the screen rectangle r in client coords.
RectangleToScreen (inherited from Control) | Computes the location of the client rectangle r in screen coords.
Refresh (inherited from Control) | Forces the control to invalidate and immediately repaint itself and any children.
ResetBackColor (inherited from RichControl) | Resets the back color to be based on the parent's back color.
ResetBindings (inherited from RichControl) | [To be supplied.]
ResetCursor (inherited from RichControl) | [To be supplied.]
ResetFont (inherited from RichControl) | Resets the font to be based on the parent's font.
ResetForeColor (inherited from RichControl) | Resets the fore color to be based on the parent's fore color.
ResetRightToLeft (inherited from RichControl) | Resets the RightToLeft to be the default.
ResetText (inherited from Control) | Resets the text to it's default value.
ResumeLayout (inherited from Control) | Overloaded. [To be supplied.]
SaveToFile | Writes the raw data from the data buffer to a file. Rethrows the WinIOException if could not write.
Scale (inherited from Control) | Overloaded. [To be supplied.]
Select (inherited from Control) | Activates this control.
SelectNextControl (inherited from Control) | Selects the next control following ctl.
SendMessage (inherited from Control) | Overloaded. [To be supplied.]
SendToBack (inherited from Control) | sends this control to the back of the z-order
SetBounds (inherited from Control) | Overloaded. [To be supplied.]
SetBytes | Sets the byte array to be displayed in the viewer
SetClientSize (inherited from Control) | Sets the height and width of the client area of the control.
SetDisplayMode | Sets the current display mode. See DisplayMode for more details
SetFile | Sets the file to be displayed in the viewer. The viewer will load the file
SetLocation (inherited from Control) | Sets the location of this control.
SetNewControls (inherited from Control) | Performs the work of setting the array of the child controls contained in this control.
SetSize (inherited from Control) | Sets the size of this control.
SetStartLine | Sets the current line for the HEXDUMP view. The HEXDUMP viewer will start displaying the buffer starting fromtheat line
ShouldPersistBackColor (inherited from RichControl) | Returns true if the backColor should be persisted in code gen.
ShouldPersistBindings (inherited from RichControl) | [To be supplied.]
ShouldPersistCursor (inherited from RichControl) | Returns true if the cursor should be persisted in code gen.
ShouldPersistFont (inherited from RichControl) | Returns true if the font should be persisted in code gen.
ShouldPersistForeColor (inherited from RichControl) | Returns true if the foreColor should be persisted in code gen.
ShouldPersistLocation (inherited from Control) | Determines if the Location property needs to be persisted.
ShouldPersistRightToLeft (inherited from RichControl) | Returns true if the RightToLeft should be persisted in code gen.
ShouldPersistSize (inherited from Control) | Determines if the Size property needs to be persisted.
ShouldPersistText (inherited from Control) | Determines if the Text property needs to be persisted.
Show (inherited from Control) | Makes the control display by setting the visible property to true
SuspendLayout (inherited from Control) | Suspends the layout logic for the control.
ToString (inherited from MarshalByRefComponent) | Basic Implementation of toString() for all controls.
Update (inherited from Control) | Forces the control to paint any currently invalid areas.

Events

Click (inherited from Control) | [To be supplied.]
ControlAdded (inherited from Control) | [To be supplied.]
ControlRemoved (inherited from Control) | [To be supplied.]
CreateHandle (inherited from Control) | [To be supplied.]
DestroyHandle (inherited from Control) | [To be supplied.]
DoubleClick (inherited from Control) | [To be supplied.]
DragDrop (inherited from RichControl) | [To be supplied.]
DragEnter (inherited from RichControl) | [To be supplied.]
DragLeave (inherited from RichControl) | [To be supplied.]
DragOver (inherited from RichControl) | [To be supplied.]
Enter (inherited from Control) | [To be supplied.]
GiveFeedback (inherited from RichControl) | [To be supplied.]
GotFocus (inherited from Control) | [To be supplied.]
Help (inherited from RichControl) | [To be supplied.]
Invalidate (inherited from RichControl) | [To be supplied.]
KeyDown (inherited from Control) | [To be supplied.]
KeyPress (inherited from Control) | [To be supplied.]
KeyUp (inherited from Control) | [To be supplied.]
Layout (inherited from Control) | [To be supplied.]
Leave (inherited from Control) | [To be supplied.]
LostFocus (inherited from Control) | [To be supplied.]
MouseDown (inherited from Control) | [To be supplied.]
MouseEnter (inherited from Control) | [To be supplied.]
MouseHover (inherited from Control) | [To be supplied.]
MouseLeave (inherited from Control) | [To be supplied.]
MouseMove (inherited from Control) | [To be supplied.]
MouseUp (inherited from Control) | [To be supplied.]
MouseWheel (inherited from Control) | [To be supplied.]
Move (inherited from Control) | [To be supplied.]
Paint (inherited from RichControl) | [To be supplied.]
PropertyChanged (inherited from Control) | [To be supplied.]
QueryContinueDrag (inherited from RichControl) | [To be supplied.]
Resize (inherited from Control) | [To be supplied.]
Validated (inherited from Control) | [To be supplied.]
Validating (inherited from Control) | [To be supplied.]

Protected:

Properties

CreateParams (inherited from RichControl) | [To be supplied.]
CreateThreadId (inherited from Control) | Retrieves the Win32 thread ID of the thread that created the handle for this control. If the control's handle hasn't been created yet, this method will return the current thread's ID.
FontHeight (inherited from RichControl) | [To be supplied.]
InternalHandle (inherited from Control) | Returns the current value of the handle. This may be zero if the handle has not been created.
ParkingFormHandle (inherited from RichControl) | [To be supplied.]
RenderRightToLeft (inherited from RichControl) | [To be supplied.]
RichParent (inherited from RichControl) | [To be supplied.]
WindowText (inherited from Control) | The current text of the Window; if the window has not yet been created, stores it in the control. If the window has been created, stores the text in the underlying win32 control. This property should be used whenever you want to get at the win32 control's text. For all other cases, use the Text property- but note that this is overridable, and any of your code that uses it will use the overridden version in controls that subclass your own.

Methods

AddEventHandler (inherited from Control) | [To be supplied.]
AssignParent (inherited from RichControl) | Assigns a new parent control. Sends out the appropriate property change notifications for properties that are affected by the change of parent.
ChildGotFocus (inherited from Control) | [To be supplied.]
CreateAccessibilityInstance (inherited from RichControl) | Constructs the new instance of the accessibility object for this control. Subclasses should not call base.CreateAccessibilityObject.
CreateControlsInstance (inherited from RichControl) | Constructs the new instance of the Controls collection objects. Subclasses should not call base.CreateControlsInstance.
CreateHandle (inherited from Control) | Creates a handle for this control. This method is called by the framework, this should not be called. Inheriting classes should always call base.createHandle when overriding this method.
DefWndProc (inherited from Control) | Sends the message to the default window proc.
DestroyHandle (inherited from RichControl) | [To be supplied.]
Finalize (inherited from Control) | [To be supplied.]
GetEventHandler (inherited from RichControl) | RichControl overrides the default implementation of this for AX sourcing. ActiveX controls can "freeze" their events, and we implement this by returning null here if events are frozen.
GetStyle (inherited from Control) | Retrieves the current value of the specified bit in the control's style. NOTE: This is control style, not the Win32 style of the hwnd.
InitLayout (inherited from RichControl) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | [To be supplied.]
InvokeLostFocus (inherited from Control) | [To be supplied.]
InvokeOnClick (inherited from Control) | [To be supplied.]
InvokePaint (inherited from RichControl) | [To be supplied.]
InvokePaintBackground (inherited from RichControl) | [To be supplied.]
IsInputChar (inherited from Control) | Determines if charCode is an input character that the control wants. This method is called during window message pre-processing to determine whether the given input character should be pre-processed or sent directly to the control. If isInputChar returns true, the given character is sent directly to the control. If isInputChar returns false, the character is pre-processed and only sent to the control if it is not consumed by the pre-processing phase. The pre-processing of a character includes checking whether the character is a mnemonic of another control.
IsInputKey (inherited from Control) | Determines if keyData is an input key that the control wants. This method is called during window message pre-processing to determine whether the given input key should be pre-processed or sent directly to the control. If isInputKey returns true, the given key is sent directly to the control. If isInputKey returns false, the key is pre-processed and only sent to the control if it is not consumed by the pre-processing phase. Keys that are pre-processed include TAB, RETURN, ESCAPE, and arrow keys.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from RichControl) | [To be supplied.]
OnClick (inherited from Control) | This method actually raises the Click event. Inheriting classes should override this if they wish to be notified of a Click event. (This is far preferable to actually adding an event handler.) They should not, however, forget to call base.onClick(e); before exiting, to ensure that other recipients do actually get the event.
OnControlAdded (inherited from Control) | Called when a child control is added to this control.
OnControlRemoved (inherited from Control) | Called when a child control is removed from this control.
OnCreateControl (inherited from Control) | Called when the control is first created.
OnCreateHandle (inherited from RichControl) | Inheriting classes should override this method to find out when the handle has been created. Call base.onCreateHandle first.
OnDestroyHandle (inherited from RichControl) | Inheriting classes should override this method to find out when the handle is about to be destroyed. Call base.onDestroyHandle last.
OnDoubleClick (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onDoubleClick to send this event to any registered event listeners.
OnDragDrop (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragDrop to send this event to any registered event listeners.
OnDragEnter (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragEnter to send this event to any registered event listeners.
OnDragLeave (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragLeave to send this event to any registered event listeners.
OnDragOver (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragOver to send this event to any registered event listeners.
OnEnter (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onEnter to send this event to any registered event listeners.
OnGiveFeedback (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onGiveFeedback to send this event to any registered event listeners.
OnGotFocus (inherited from RichControl) | [To be supplied.]
OnHelp (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onHelp to send this event to any registered event listeners.
OnInvalidate (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.OnInvalidate to send this event to any registered event listeners.
OnKeyDown (inherited from RichControl) | [To be supplied.]
OnKeyPress (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.OnKeyPress to send this event to any registered event listeners.
OnKeyUp (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onKeyUp to send this event to any registered event listeners.
OnLayout (inherited from RichControl) | Core layout logic. Inheriting controls should override this function to do any custom layout logic. It is not neccessary to call base.layoutCore, however for normal docking and anchoring functions to work, base.layoutCore must be called.
OnLeave (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onLeave to send this event to any registered event listeners.
OnLostFocus (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onLostFocus to send this event to any registered event listeners.
OnMouseDown (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseDown to send this event to any registered event listeners.
OnMouseEnter (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseEnter to send this event to any registered event listeners.
OnMouseHover (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseHover to send this event to any registered event listeners.
OnMouseLeave (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseLeave to send this event to any registered event listeners.
OnMouseMove (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseMove to send this event to any registered event listeners.
OnMouseUp (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseUp to send this event to any registered event listeners.
OnMouseWheel (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseWheel to send this event to any registered event listeners.
OnMove (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMove to send this event to any registered event listeners.
OnPaint (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onPaint to send this event to any registered event listeners.
OnPaintBackground (inherited from RichControl) | Inheriting classes should override this method to handle the erase background request from windows. It is not necessary to call base.onPaintBackground, however if you do not want the default Windows behavior you must set event.handled to true.
OnParentPropertyChanged (inherited from RichControl) | This method is called by the parent control when any property changes on the parent. This can be overriden by inheriting classes, however they must call base.OnParentPropertyChanged.
OnPropertyChanged (inherited from RichControl) | [To be supplied.]
OnQueryContinueDrag (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onQueryContinueDrag to send this event to any registered event listeners.
OnResize (inherited from RichControl) | [To be supplied.]
OnValidated (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onResize to send this event to any registered event listeners.
OnValidating (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onResize to send this event to any registered event listeners.
ParentChanged (inherited from Control) | Called by the framework after a control's parent changes. This allows (for example) child controls to automatically hook events on their parent, giving better encapsulation.
ProcessCmdKey (inherited from RichControl) | [To be supplied.]
ProcessDialogChar (inherited from Control) | Processes a dialog character. This method is called during message pre-processing to handle dialog characters, such as control mnemonics. This method is called only if the isInputChar() method indicates that the control isn't interested in the character. processDialogChar() simply sends the character to the parent's processDialogChar() method, or returns false if the control has no parent. The Form class overrides this method to perform actual processing of dialog characters. When overriding processDialogChar(), a control should return true to indicate that it has processed the character. For characters that aren't processed by the control, the result of "base.processDialogChar()" should be returned. Controls will seldom, if ever, need to override this method.
ProcessDialogKey (inherited from Control) | Processes a dialog key. This method is called during message pre-processing to handle dialog characters, such as TAB, RETURN, ESCAPE, and arrow keys. This method is called only if the isInputKey() method indicates that the control isn't interested in the key. processDialogKey() simply sends the character to the parent's processDialogKey() method, or returns false if the control has no parent. The Form class overrides this method to perform actual processing of dialog keys. When overriding processDialogKey(), a control should return true to indicate that it has processed the key. For keys that aren't processed by the control, the result of "base.processDialogChar()" should be returned. Controls will seldom, if ever, need to override this method.
ProcessKeyEventArgs (inherited from Control) | Processes a key message. This method is called when a control receives a keyboard message. The method is responsible for generating the appropriate key events for the message by calling OnKeyPress(), onKeyDown(), or onKeyUp(). The m parameter contains the window message that must be processed. Possible values for the m.msg field are WM_CHAR, WM_KEYDOWN, WM_SYSKEYDOWN, WM_KEYUP, WM_SYSKEYUP, and WM_IMECHAR. When overriding processKeyEventArgs(), a control should return true to indicate that it has processed the key. For keys that aren't processed by the control, the result of "base.processKeyEventArgs()" should be returned. Controls will seldom, if ever, need to override this method.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message. This method is called by a child control when the child control receives a keyboard message. The child control calls this method before generating any keyboard events for the message. If this method returns true, the child control considers the message consumed and does not generate any keyboard events. The m parameter contains the window message to preview. Possible values for the m.msg field are WM_CHAR, WM_KEYDOWN, WM_SYSKEYDOWN, WM_KEYUP, and WM_SYSKEYUP. processKeyPreview() simply sends the character to the parent's processKeyPreview() method, or returns false if the control has no parent. The Form class overrides this method to perform actual processing of dialog keys. When overriding processKeyPreview(), a control should return true to indicate that it has processed the key. For keys that aren't processed by the control, the result of "base.processKeyEventArgs()" should be returned.
ProcessMnemonic (inherited from Control) Processes a mnemonic character. This method is called to give a control the opportunity to process a mnemonic character. The method should check if the control is in a state to process mnemonics and if the given character represents a mnemonic. If so, the method should perform the action associated with the mnemonic and return true. If not, the method should return false. Implementations of this method often use the isMnemonic() method to check if the given character matches a mnemonic in the control's text, for example:
if (canSelect() && isMnemonic(charCode, getText()) {
    // perform action associated with mnemonic
    }

This default implementation of processMnemonic() simply returns false to indicate that the control has no mnemonic.
RaiseDragEventArgs (inherited from RichControl) | Raises the event associated with key with the event data of e and a sender of this control.
RaiseEvent (inherited from Control) | [To be supplied.]
RaiseKeyEventArgs (inherited from Control) | Raises the event associated with key with the event data of e and a sender of this control.
RaiseMouseEventArgs (inherited from Control) | Raises the event associated with key with the event data of e and a sender of this control.
RaisePaintEventArgs (inherited from RichControl) | Raises the event associated with key with the event data of e and a sender of this control.
RaisePropertyChangedEvent (inherited from Control) | Raises the property changed event. This creates the needed event data and then calls OnPropertyChanged.
RecreateHandle (inherited from Control) | Forces the recreation of the handle for this control. Inheriting controls must call base.recreateHandle.
RemoveEventHandler (inherited from Control) | [To be supplied.]
RemoveEventHandlers (inherited from Control) | [To be supplied.]
ResetMouseEventArgs (inherited from Control) | Resets the mouse leave listeners.
ResumeLayout (inherited from Control) | Overloaded. [To be supplied.]
RTLTranslateAlignment (inherited from RichControl) | Overloaded. [To be supplied.]
RTLTranslateContent (inherited from RichControl) | [To be supplied.]
RTLTranslateHorizontal (inherited from RichControl) | [To be supplied.]
RTLTranslateLeftRight (inherited from RichControl) | [To be supplied.]
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
SendMessage (inherited from Control) | Overloaded. [To be supplied.]
SetBoundsCore (inherited from RichControl) | [To be supplied.]
SetClientSizeCore (inherited from Control) | Performs the work of setting the size of the client area of the control.
SetStyle (inherited from Control) | Sets the current value of the specified bit in the control's style. NOTE: This is control style, not the Win32 style of the hwnd.
UpdateBounds (inherited from Control) | Overloaded. [To be supplied.]
UpdateStyles (inherited from Control) | Forces styles to be reapplied to the handle. This function will call CreateParams to get the styles to apply.
UpdateZOrder (inherited from Control) | Updates this control in it's parent's zorder.
WmSysColorChange (inherited from Control) | Handles the WM_SYSCOLORCHANGE message
WndProc (inherited from RichControl) | Base wndProc. All messages are sent to wndProc after getting filtered through the preProcessMessage function. Inheriting controls should call base.wndProc for any messages that they don't handle.
WndProcException (inherited from RichControl) | [To be supplied.]

Event Hookup:

Methods

AddOnClick (inherited from Control) | Adds an event handler for the click event. The click event occurs when the user clicks in the client area of the control.
AddOnControlAdded (inherited from Control) | Adds an event handler for the ControlAdded event. This event is raised after a control is added as a child to this control.
AddOnControlRemoved (inherited from Control) | Adds an event handler for the ControlRemoved event. This event is raised after a child control is removed from this control.
AddOnCreateHandle (inherited from Control) | Adds an event handler for the createHandle event. The createHandle event occurs immediately after the control's handle is created.
AddOnDestroyHandle (inherited from Control) | Adds an event handler for the destroyHandle event. The destroyHandle event occurs immediately before the control's handle is destroyed.
AddOnDoubleClick (inherited from Control) | Adds an event handler for the doubleClick event. The doubleClick event occurs when the user double clicks in the client area of the control.
AddOnDragDrop (inherited from RichControl) | Adds an event handler for the dragDrop event. The dragDrop evnet occurs when the user releases the mouse button while dragging some Object over the control.
AddOnDragEnter (inherited from RichControl) | Adds an event handler for the dragEnter event. The drawEnter event occurs when the user first moves the mouse over the control while dragging some Object.
AddOnDragLeave (inherited from RichControl) | Adds an event handler for the dragLeave event. The dragLeave event occurs when the user first moves the mouse out of the control while dragging some Object.
AddOnDragOver (inherited from RichControl) | Adds an event handler for the dragOver event. The dragOver event occurs whenever the user moves the mouse over the control while draggin some Object.
AddOnEnter (inherited from Control) | Adds an event handler for the enter event. The enter event occurs when focus enters this control. This doesn't imply that this control has focus, but rather that this control or some child control of this control has gotten focus.
AddOnGiveFeedback (inherited from RichControl) | Adds an event handler for the giveFeedback event. The giveFeedback event occurs during a drag operation. This allows the source of a drag event to modify the mouse pointer to give the user visual feedback as to what would happen if they droped.
AddOnGotFocus (inherited from Control) | Adds an event handler for the gotFocus event. The gotFocus event occurs when the this control gains focus.
AddOnHelp (inherited from RichControl) | Adds an event handler for the help event. The help event occurs when the user requests help for this control. This may be caused by the user pressing F1, or used "Whats This Help".
AddOnInvalidate (inherited from RichControl) | Adds an event handler for the invalidate event. The invalidate event occurs when the Invalidate method is called on some part of the control's client area. This event may be used to identify when the contents of a window have changed.
AddOnKeyDown (inherited from Control) | Adds an event handler for the keyDown event. The keyDown event occurs when the user presses a key down.
AddOnKeyPress (inherited from Control) | Adds an event handler for the keyPress event. The keyPress event occurs when the user presses a key.
AddOnKeyUp (inherited from Control) | Adds an event handler for the keyUp event. The keyUp event occurs when the user releases a key.
AddOnLayout (inherited from Control) | Adds an event handler for the layout event. The layout event occurs when any event occurs that would cause the control to layout child controls. These events include; resize, show/hide child controls, add/remove child controls. This event should be used to perform any custom layout logic.
AddOnLeave (inherited from Control) | Adds an event handler for the leave event. The leave event occurs when focus leaves this control. This doesn't imply that this control lost focus, but rather that focus has been moved out of this control and any child controls.
AddOnLostFocus (inherited from Control) | Adds an event handler for the lostFocus event. The lostFocus event occurs when this control looses focus.
AddOnMouseDown (inherited from Control) | Adds an event handler for the mouseDown event. The mouseDown event occurs when the user presses the mouseDown over this control.
AddOnMouseEnter (inherited from Control) | Adds an event handler for the mouseEnter event. The mouseEnter event occurs when the mouse first moves over this control.
AddOnMouseHover (inherited from Control) | Adds an event handler for the mouseHover event. The mouseHover event occurs after the mouse is inside a control for an amount.
AddOnMouseLeave (inherited from Control) | Adds an event handler for the mouseLeave event. The mouseLeave event occurs when the mouse first moves out of this control.
AddOnMouseMove (inherited from Control) | Adds an event handler for the mouseMove event. The mouseMove event occurs whenever the user moves the mouse over this control.
AddOnMouseUp (inherited from Control) | Adds an event handler for the mouseUp event. The mouseUp event occurs when the user releases a mouse button inside the control.
AddOnMouseWheel (inherited from Control) | Adds an event handler for the mouseWheel event. The mouseWheel event occurs when the user scrolls the mouse wheel up or down. The delta value in the event data indicates the amount that the mouse wheel has moved. The Microsoft standards indicate that the view should scroll by System.WinForms.SystemInformation.getMouseWheelScrollLines() when the delta value has reach win.WHEEL_DELTA. If a mouseWheel event occurs with a value less that WHEEL_DELTA, the control should either increment a stored value and wait until the total delta is an increment of WHEEL_DELTA, or scroll the view a percentage of MouseWheelScrollLines. NOTE: A press of the mouseWheel will generate a mouseDown event with the middle button pressed.
AddOnMove (inherited from Control) | Adds an event handler for the move event. The move event occurs when the controls location changes.
AddOnPaint (inherited from RichControl) | Adds an event handler for the paint event. The paint event occurs when the control needs to paint some part of it's client area.
AddOnPropertyChanged (inherited from Control) | Adds an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.
AddOnQueryContinueDrag (inherited from RichControl) | Adds an event handler for the queryContinueDrag event. The queryContinueDrag event occurs during a drag operation. This allows the drag source to determine if the drag operation should be canceled.
AddOnResize (inherited from Control) | Adds an event handler for the resize event. The resize event occurs when the bounds of the control change. This event may be fired from the constructor of base controls.
AddOnValidated (inherited from Control) | Adds an event handler for the validated event. The validated event occurs when a control was successfully validated.
AddOnValidating (inherited from Control) | Adds an event handler for the validating event. The validating event occurs when the control loses focus and a control that causes validation gains focus. This is where users can write code to validate the current values of the control.
RemoveOnClick (inherited from Control) | Removes the given handler for the "OnClick" event. If there are duplicate entries, ALL are removed.
RemoveOnControlAdded (inherited from Control) | Removes the given handler for the "ControlAdded" event. If there are duplicate entries, ALL are removed.
RemoveOnControlRemoved (inherited from Control) | Removes the given handler for the "ControlRemoved" event. If there are duplicate entries, ALL are removed.
RemoveOnCreateHandle (inherited from Control) | Removes the given handler for the "createHandle" event. If there are duplicate entries, ALL are removed.
RemoveOnDestroyHandle (inherited from Control) | Removes the given handler for the "destroyHandle" event. If there are duplicate entries, ALL are removed.
RemoveOnDoubleClick (inherited from Control) | Removes the given handler for the "OnDoubleClick" event. If there are duplicate entries, ALL are removed.
RemoveOnDragDrop (inherited from RichControl) | Removes the given handler for the "dragDrop" event. If there are duplicate entries, ALL are removed.
RemoveOnDragEnter (inherited from RichControl) | Removes the given handler for the "OnDragEnter" event. If there are duplicate entries, ALL are removed.
RemoveOnDragLeave (inherited from RichControl) | Removes the given handler for the "OnDragLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnDragOver (inherited from RichControl) | f final Removes the given handler for the "OnDragOver" event. If there are duplicate entries, ALL are removed.
RemoveOnEnter (inherited from Control) | Removes the given handler for the "OnEnter" event. If there are dfinal uplicate entries, ALL are removed.
RemoveOnGiveFeedback (inherited from RichControl) | Removes the given handler for the "OnGiveFeedback" event. If there are duplicate entries, ALL are removed.
RemoveOnGotFocus (inherited from Control) | Removes the given handler for the "OnGotFocus" event. If there are duplicate entries, ALL are removed.
RemoveOnHelp (inherited from RichControl) | Removes the given handler for the "OnHelp" event. If there are duplicate entries, ALL are removed.
RemoveOnInvalidate (inherited from RichControl) | Removes the given handler for the "OnInvalidate" event. If there are duplicate entries, ALL are removed.
RemoveOnKeyDown (inherited from Control) | Removes the given handler for the "OnKeyDown" event. If there are duplicate entries, ALL are removed.
RemoveOnKeyPress (inherited from Control) | Removes the given handler for the "OnKeyPress" event. If there are duplicate entries, ALL are removed.
RemoveOnKeyUp (inherited from Control) | Removes the given handler for the "OnKeyUp" event. If there are duplicate entries, ALL are removed.
RemoveOnLayout (inherited from Control) | Removes the given handler for the layout event. If there are duplicate entries, ALL are removed.
RemoveOnLeave (inherited from Control) | Removes the given handler for the "OnLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnLostFocus (inherited from Control) | Removes the given handler for the "OnLostFocus" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseDown (inherited from Control) | Removes the given handler for the "OnMouseDown" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseEnter (inherited from Control) | Removes the given handler for the "OnMouseEnter" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseHover (inherited from Control) | Removes the given handler for the "OnMouseHover" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseLeave (inherited from Control) | Removes the given handler for the "OnMouseLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseMove (inherited from Control) | Removes the given handler for the "OnMouseMove" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseUp (inherited from Control) | Removes the given handler for the "OnMouseUp" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseWheel (inherited from Control) | Removes the given handler for the "OnMouseWheel" event. If there are duplicate entries, ALL are removed.
RemoveOnMove (inherited from Control) | Removes the given handler for the "OnMove" event. If there are duplicate entries, ALL are removed.
RemoveOnPaint (inherited from RichControl) | Removes the given handler for the "OnPaint" event. If there are duplicate entries, ALL are removed.
RemoveOnPropertyChanged (inherited from Control) | Removes an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.
RemoveOnQueryContinueDrag (inherited from RichControl) | Removes the given handler for the "OnQueryContinueDrag" event. If there are duplicate entries, ALL are removed.
RemoveOnResize (inherited from Control) | Removes the given handler for the "OnResize" event. If there are duplicate entries, ALL are removed.
RemoveOnValidated (inherited from Control) | Removes an event handler for the validated event. The validated event occurs when a control was successfully validated.
RemoveOnValidating (inherited from Control) | Removes an event handler for the validating event. The validating event occurs when the control loses focus and a control that causes validation gains focus. This is where users can write code to validate the current values of the control.

See Also

ByteViewer Class | System.ComponentModel.Design Namespace


ByteViewer Constructor

Creates a ByteViewer objct

[Visual Basic]
Public Sub New()
[C#]
public ByteViewer();
[C++]
public: ByteViewer();
[JScript]
public function ByteViewer();

See Also

ByteViewer Class | ByteViewer Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ByteViewer Methods

The methods of the ByteViewer class are listed below. For a complete list of ByteViewer class members, see the ByteViewer Members topic.

Public:

BeginInvoke (inherited from RichControl) | Overloaded. [To be supplied.]
BringToFront (inherited from Control) | Brings this control to the front of the zorder.
CallWndProc (inherited from Control) | Dispatch the method to this window's wndProc directly.
Contains (inherited from Control) | Checks if a control is a child of this control.
CreateControl (inherited from Control) | Forces the creation of the control. This includes the creation of the handle, and any child controls.
CreateGraphics (inherited from RichControl) | Overloaded. [To be supplied.]
CreateWindowGraphics (inherited from RichControl) | Creates a Graphics for the entire window of the control rather than just it's client area. The controls foreground color and background color become the default values for the Graphics. The returned Graphics must be disposed through a call to its dispose() method when it is no longer needed. The Graphics Object is only valid for the duration of the current window's message.
Dispose (inherited from RichControl) | [To be supplied.]
DoDragDrop (inherited from RichControl) | Begins a drag operation. The allowedEffects determine which drag operations can occur. If the drag operation needs to interop with applications in another process, data should either be a base managed class (String, Bitmap, or Metafile) or some Object that implements System.ComponentModel.IPersistable. data can also be any Object that implements System.WinForms.IDataObject.
EndInvoke (inherited from RichControl) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult interface passed. If the async operation has not been completed, this function will block until the result is available.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FindForm (inherited from RichControl) | Retrieves the form that this control is on. The control's parent may not be the same as the form.
Focus (inherited from Control) | Attempts to set focus to this control.
GetBytes | Returns the buffer
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified client coordinates.
GetContainer (inherited from MarshalByRefComponent) | Returns the component's container.
GetContainerControl (inherited from Control) | Returns the closest ContainerControl in the control's chain of parent controls and forms.
GetDesignMode (inherited from MarshalByRefComponent) | Determines whether the component is currently in design mode.
GetDisplayMode | Returns the display mode for the control
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetNextControl (inherited from Control) | Retrieves the next control in the tab order of child controls.
GetServiceObject (inherited from MarshalByRefComponent) | The implementation of IServiceObjectProvider
GetType (inherited from Object) | Gets the Type of the Object.
Hide (inherited from Control) | Hides the control by setting the visible property to false;
InitializeLifetimeService (inherited from MarshalByRefObject)
Invalidate (inherited from RichControl) | Overloaded. [To be supplied.]
Invoke (inherited from RichControl) | Overloaded. [To be supplied.]
PerformLayout (inherited from Control) | Overloaded. [To be supplied.]
PointToClient (inherited from Control) | Computes the location of the screen point p in client coords.
PointToScreen (inherited from Control) | Computes the location of the client point p in screen coords.
PreProcessMessage (inherited from Control) | This method is called by the application's message loop to pre-process input messages before they are dispatched. Possible values for the msg.message field are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR. If this method processes the message it must return true, in which case the message loop will not dispatch the message. For WM_KEYDOWN and WM_SYSKEYDOWN messages, preProcessMessage() first calls processCmdKey() to check for command keys such as accelerators and menu shortcuts. If processCmdKey() doesn't process the message, then isInputKey() is called to check whether the key message represents an input key for the control. Finally, if isInputKey() indicates that the control isn't interested in the key message, then processDialogKey() is called to check for dialog keys such as TAB, arrow keys, and mnemonics. For WM_CHAR messages, preProcessMessage() first calls isInputChar() to check whether the character message represents an input character for the control. If isInputChar() indicates that the control isn't interested in the character message, then processDialogChar() is called to check for dialog characters such as mnemonics. For WM_SYSCHAR messages, preProcessMessage() calls processDialogChar() to check for dialog characters such as mnemonics. When overriding preProcessMessage(), a control should return true to indicate that it has processed the message. For messages that aren't processed by the control, the result of "base.preProcessMessage()" should be returned. Controls will typically override one of the more specialized methods (isInputChar(), isInputKey(), processCmdKey(), processDialogChar(), or processDialogKey()) instead of overriding preProcessMessage().
RectangleToClient (inherited from Control) | Computes the location of the screen rectangle r in client coords.
RectangleToScreen (inherited from Control) | Computes the location of the client rectangle r in screen coords.
Refresh (inherited from Control) | Forces the control to invalidate and immediately repaint itself and any children.
ResetBackColor (inherited from RichControl) | Resets the back color to be based on the parent's back color.
ResetBindings (inherited from RichControl) | [To be supplied.]
ResetCursor (inherited from RichControl) | [To be supplied.]
ResetFont (inherited from RichControl) | Resets the font to be based on the parent's font.
ResetForeColor (inherited from RichControl) | Resets the fore color to be based on the parent's fore color.
ResetRightToLeft (inherited from RichControl) | Resets the RightToLeft to be the default.
ResetText (inherited from Control) | Resets the text to it's default value.
ResumeLayout (inherited from Control) | Overloaded. [To be supplied.]
SaveToFile | Writes the raw data from the data buffer to a file. Rethrows the WinIOException if could not write.
Scale (inherited from Control) | Overloaded. [To be supplied.]
Select (inherited from Control) | Activates this control.
SelectNextControl (inherited from Control) | Selects the next control following ctl.
SendMessage (inherited from Control) | Overloaded. [To be supplied.]
SendToBack (inherited from Control) | sends this control to the back of the z-order
SetBounds (inherited from Control) | Overloaded. [To be supplied.]
SetBytes | Sets the byte array to be displayed in the viewer
SetClientSize (inherited from Control) | Sets the height and width of the client area of the control.
SetDisplayMode | Sets the current display mode. See DisplayMode for more details
SetFile | Sets the file to be displayed in the viewer. The viewer will load the file
SetLocation (inherited from Control) | Sets the location of this control.
SetNewControls (inherited from Control) | Performs the work of setting the array of the child controls contained in this control.
SetSize (inherited from Control) | Sets the size of this control.
SetStartLine | Sets the current line for the HEXDUMP view. The HEXDUMP viewer will start displaying the buffer starting fromtheat line
ShouldPersistBackColor (inherited from RichControl) | Returns true if the backColor should be persisted in code gen.
ShouldPersistBindings (inherited from RichControl) | [To be supplied.]
ShouldPersistCursor (inherited from RichControl) | Returns true if the cursor should be persisted in code gen.
ShouldPersistFont (inherited from RichControl) | Returns true if the font should be persisted in code gen.
ShouldPersistForeColor (inherited from RichControl) | Returns true if the foreColor should be persisted in code gen.
ShouldPersistLocation (inherited from Control) | Determines if the Location property needs to be persisted.
ShouldPersistRightToLeft (inherited from RichControl) | Returns true if the RightToLeft should be persisted in code gen.
ShouldPersistSize (inherited from Control) | Determines if the Size property needs to be persisted.
ShouldPersistText (inherited from Control) | Determines if the Text property needs to be persisted.
Show (inherited from Control) | Makes the control display by setting the visible property to true
SuspendLayout (inherited from Control) | Suspends the layout logic for the control.
ToString (inherited from MarshalByRefComponent) | Basic Implementation of toString() for all controls.
Update (inherited from Control) | Forces the control to paint any currently invalid areas.

Protected:

AddEventHandler (inherited from Control) | [To be supplied.]
AssignParent (inherited from RichControl) | Assigns a new parent control. Sends out the appropriate property change notifications for properties that are affected by the change of parent.
ChildGotFocus (inherited from Control) | [To be supplied.]
CreateAccessibilityInstance (inherited from RichControl) | Constructs the new instance of the accessibility object for this control. Subclasses should not call base.CreateAccessibilityObject.
CreateControlsInstance (inherited from RichControl) | Constructs the new instance of the Controls collection objects. Subclasses should not call base.CreateControlsInstance.
CreateHandle (inherited from Control) | Creates a handle for this control. This method is called by the framework, this should not be called. Inheriting classes should always call base.createHandle when overriding this method.
DefWndProc (inherited from Control) | Sends the message to the default window proc.
DestroyHandle (inherited from RichControl) | [To be supplied.]
Finalize (inherited from Control) | [To be supplied.]
GetEventHandler (inherited from RichControl) | RichControl overrides the default implementation of this for AX sourcing. ActiveX controls can "freeze" their events, and we implement this by returning null here if events are frozen.
GetStyle (inherited from Control) | Retrieves the current value of the specified bit in the control's style. NOTE: This is control style, not the Win32 style of the hwnd.
InitLayout (inherited from RichControl) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | [To be supplied.]
InvokeLostFocus (inherited from Control) | [To be supplied.]
InvokeOnClick (inherited from Control) | [To be supplied.]
InvokePaint (inherited from RichControl) | [To be supplied.]
InvokePaintBackground (inherited from RichControl) | [To be supplied.]
IsInputChar (inherited from Control) | Determines if charCode is an input character that the control wants. This method is called during window message pre-processing to determine whether the given input character should be pre-processed or sent directly to the control. If isInputChar returns true, the given character is sent directly to the control. If isInputChar returns false, the character is pre-processed and only sent to the control if it is not consumed by the pre-processing phase. The pre-processing of a character includes checking whether the character is a mnemonic of another control.
IsInputKey (inherited from Control) | Determines if keyData is an input key that the control wants. This method is called during window message pre-processing to determine whether the given input key should be pre-processed or sent directly to the control. If isInputKey returns true, the given key is sent directly to the control. If isInputKey returns false, the key is pre-processed and only sent to the control if it is not consumed by the pre-processing phase. Keys that are pre-processed include TAB, RETURN, ESCAPE, and arrow keys.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from RichControl) | [To be supplied.]
OnClick (inherited from Control) | This method actually raises the Click event. Inheriting classes should override this if they wish to be notified of a Click event. (This is far preferable to actually adding an event handler.) They should not, however, forget to call base.onClick(e); before exiting, to ensure that other recipients do actually get the event.
OnControlAdded (inherited from Control) | Called when a child control is added to this control.
OnControlRemoved (inherited from Control) | Called when a child control is removed from this control.
OnCreateControl (inherited from Control) | Called when the control is first created.
OnCreateHandle (inherited from RichControl) | Inheriting classes should override this method to find out when the handle has been created. Call base.onCreateHandle first.
OnDestroyHandle (inherited from RichControl) | Inheriting classes should override this method to find out when the handle is about to be destroyed. Call base.onDestroyHandle last.
OnDoubleClick (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onDoubleClick to send this event to any registered event listeners.
OnDragDrop (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragDrop to send this event to any registered event listeners.
OnDragEnter (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragEnter to send this event to any registered event listeners.
OnDragLeave (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragLeave to send this event to any registered event listeners.
OnDragOver (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragOver to send this event to any registered event listeners.
OnEnter (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onEnter to send this event to any registered event listeners.
OnGiveFeedback (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onGiveFeedback to send this event to any registered event listeners.
OnGotFocus (inherited from RichControl) | [To be supplied.]
OnHelp (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onHelp to send this event to any registered event listeners.
OnInvalidate (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.OnInvalidate to send this event to any registered event listeners.
OnKeyDown (inherited from RichControl) | [To be supplied.]
OnKeyPress (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.OnKeyPress to send this event to any registered event listeners.
OnKeyUp (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onKeyUp to send this event to any registered event listeners.
OnLayout (inherited from RichControl) | Core layout logic. Inheriting controls should override this function to do any custom layout logic. It is not neccessary to call base.layoutCore, however for normal docking and anchoring functions to work, base.layoutCore must be called.
OnLeave (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onLeave to send this event to any registered event listeners.
OnLostFocus (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onLostFocus to send this event to any registered event listeners.
OnMouseDown (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseDown to send this event to any registered event listeners.
OnMouseEnter (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseEnter to send this event to any registered event listeners.
OnMouseHover (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseHover to send this event to any registered event listeners.
OnMouseLeave (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseLeave to send this event to any registered event listeners.
OnMouseMove (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseMove to send this event to any registered event listeners.
OnMouseUp (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseUp to send this event to any registered event listeners.
OnMouseWheel (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseWheel to send this event to any registered event listeners.
OnMove (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMove to send this event to any registered event listeners.
OnPaint (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onPaint to send this event to any registered event listeners.
OnPaintBackground (inherited from RichControl) | Inheriting classes should override this method to handle the erase background request from windows. It is not necessary to call base.onPaintBackground, however if you do not want the default Windows behavior you must set event.handled to true.
OnParentPropertyChanged (inherited from RichControl) | This method is called by the parent control when any property changes on the parent. This can be overriden by inheriting classes, however they must call base.OnParentPropertyChanged.
OnPropertyChanged (inherited from RichControl) | [To be supplied.]
OnQueryContinueDrag (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onQueryContinueDrag to send this event to any registered event listeners.
OnResize (inherited from RichControl) | [To be supplied.]
OnValidated (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onResize to send this event to any registered event listeners.
OnValidating (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onResize to send this event to any registered event listeners.
ParentChanged (inherited from Control) | Called by the framework after a control's parent changes. This allows (for example) child controls to automatically hook events on their parent, giving better encapsulation.
ProcessCmdKey (inherited from RichControl) | [To be supplied.]
ProcessDialogChar (inherited from Control) | Processes a dialog character. This method is called during message pre-processing to handle dialog characters, such as control mnemonics. This method is called only if the isInputChar() method indicates that the control isn't interested in the character. processDialogChar() simply sends the character to the parent's processDialogChar() method, or returns false if the control has no parent. The Form class overrides this method to perform actual processing of dialog characters. When overriding processDialogChar(), a control should return true to indicate that it has processed the character. For characters that aren't processed by the control, the result of "base.processDialogChar()" should be returned. Controls will seldom, if ever, need to override this method.
ProcessDialogKey (inherited from Control) | Processes a dialog key. This method is called during message pre-processing to handle dialog characters, such as TAB, RETURN, ESCAPE, and arrow keys. This method is called only if the isInputKey() method indicates that the control isn't interested in the key. processDialogKey() simply sends the character to the parent's processDialogKey() method, or returns false if the control has no parent. The Form class overrides this method to perform actual processing of dialog keys. When overriding processDialogKey(), a control should return true to indicate that it has processed the key. For keys that aren't processed by the control, the result of "base.processDialogChar()" should be returned. Controls will seldom, if ever, need to override this method.
ProcessKeyEventArgs (inherited from Control) | Processes a key message. This method is called when a control receives a keyboard message. The method is responsible for generating the appropriate key events for the message by calling OnKeyPress(), onKeyDown(), or onKeyUp(). The m parameter contains the window message that must be processed. Possible values for the m.msg field are WM_CHAR, WM_KEYDOWN, WM_SYSKEYDOWN, WM_KEYUP, WM_SYSKEYUP, and WM_IMECHAR. When overriding processKeyEventArgs(), a control should return true to indicate that it has processed the key. For keys that aren't processed by the control, the result of "base.processKeyEventArgs()" should be returned. Controls will seldom, if ever, need to override this method.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message. This method is called by a child control when the child control receives a keyboard message. The child control calls this method before generating any keyboard events for the message. If this method returns true, the child control considers the message consumed and does not generate any keyboard events. The m parameter contains the window message to preview. Possible values for the m.msg field are WM_CHAR, WM_KEYDOWN, WM_SYSKEYDOWN, WM_KEYUP, and WM_SYSKEYUP. processKeyPreview() simply sends the character to the parent's processKeyPreview() method, or returns false if the control has no parent. The Form class overrides this method to perform actual processing of dialog keys. When overriding processKeyPreview(), a control should return true to indicate that it has processed the key. For keys that aren't processed by the control, the result of "base.processKeyEventArgs()" should be returned.
ProcessMnemonic (inherited from Control) Processes a mnemonic character. This method is called to give a control the opportunity to process a mnemonic character. The method should check if the control is in a state to process mnemonics and if the given character represents a mnemonic. If so, the method should perform the action associated with the mnemonic and return true. If not, the method should return false. Implementations of this method often use the isMnemonic() method to check if the given character matches a mnemonic in the control's text, for example:
if (canSelect() && isMnemonic(charCode, getText()) {
    // perform action associated with mnemonic
    }

This default implementation of processMnemonic() simply returns false to indicate that the control has no mnemonic.
RaiseDragEventArgs (inherited from RichControl) | Raises the event associated with key with the event data of e and a sender of this control.
RaiseEvent (inherited from Control) | [To be supplied.]
RaiseKeyEventArgs (inherited from Control) | Raises the event associated with key with the event data of e and a sender of this control.
RaiseMouseEventArgs (inherited from Control) | Raises the event associated with key with the event data of e and a sender of this control.
RaisePaintEventArgs (inherited from RichControl) | Raises the event associated with key with the event data of e and a sender of this control.
RaisePropertyChangedEvent (inherited from Control) | Raises the property changed event. This creates the needed event data and then calls OnPropertyChanged.
RecreateHandle (inherited from Control) | Forces the recreation of the handle for this control. Inheriting controls must call base.recreateHandle.
RemoveEventHandler (inherited from Control) | [To be supplied.]
RemoveEventHandlers (inherited from Control) | [To be supplied.]
ResetMouseEventArgs (inherited from Control) | Resets the mouse leave listeners.
ResumeLayout (inherited from Control) | Overloaded. [To be supplied.]
RTLTranslateAlignment (inherited from RichControl) | Overloaded. [To be supplied.]
RTLTranslateContent (inherited from RichControl) | [To be supplied.]
RTLTranslateHorizontal (inherited from RichControl) | [To be supplied.]
RTLTranslateLeftRight (inherited from RichControl) | [To be supplied.]
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
SendMessage (inherited from Control) | Overloaded. [To be supplied.]
SetBoundsCore (inherited from RichControl) | [To be supplied.]
SetClientSizeCore (inherited from Control) | Performs the work of setting the size of the client area of the control.
SetStyle (inherited from Control) | Sets the current value of the specified bit in the control's style. NOTE: This is control style, not the Win32 style of the hwnd.
UpdateBounds (inherited from Control) | Overloaded. [To be supplied.]
UpdateStyles (inherited from Control) | Forces styles to be reapplied to the handle. This function will call CreateParams to get the styles to apply.
UpdateZOrder (inherited from Control) | Updates this control in it's parent's zorder.
WmSysColorChange (inherited from Control) | Handles the WM_SYSCOLORCHANGE message
WndProc (inherited from RichControl) | Base wndProc. All messages are sent to wndProc after getting filtered through the preProcessMessage function. Inheriting controls should call base.wndProc for any messages that they don't handle.
WndProcException (inherited from RichControl) | [To be supplied.]

Event Hookup:

AddOnClick (inherited from Control) | Adds an event handler for the click event. The click event occurs when the user clicks in the client area of the control.
AddOnControlAdded (inherited from Control) | Adds an event handler for the ControlAdded event. This event is raised after a control is added as a child to this control.
AddOnControlRemoved (inherited from Control) | Adds an event handler for the ControlRemoved event. This event is raised after a child control is removed from this control.
AddOnCreateHandle (inherited from Control) | Adds an event handler for the createHandle event. The createHandle event occurs immediately after the control's handle is created.
AddOnDestroyHandle (inherited from Control) | Adds an event handler for the destroyHandle event. The destroyHandle event occurs immediately before the control's handle is destroyed.
AddOnDoubleClick (inherited from Control) | Adds an event handler for the doubleClick event. The doubleClick event occurs when the user double clicks in the client area of the control.
AddOnDragDrop (inherited from RichControl) | Adds an event handler for the dragDrop event. The dragDrop evnet occurs when the user releases the mouse button while dragging some Object over the control.
AddOnDragEnter (inherited from RichControl) | Adds an event handler for the dragEnter event. The drawEnter event occurs when the user first moves the mouse over the control while dragging some Object.
AddOnDragLeave (inherited from RichControl) | Adds an event handler for the dragLeave event. The dragLeave event occurs when the user first moves the mouse out of the control while dragging some Object.
AddOnDragOver (inherited from RichControl) | Adds an event handler for the dragOver event. The dragOver event occurs whenever the user moves the mouse over the control while draggin some Object.
AddOnEnter (inherited from Control) | Adds an event handler for the enter event. The enter event occurs when focus enters this control. This doesn't imply that this control has focus, but rather that this control or some child control of this control has gotten focus.
AddOnGiveFeedback (inherited from RichControl) | Adds an event handler for the giveFeedback event. The giveFeedback event occurs during a drag operation. This allows the source of a drag event to modify the mouse pointer to give the user visual feedback as to what would happen if they droped.
AddOnGotFocus (inherited from Control) | Adds an event handler for the gotFocus event. The gotFocus event occurs when the this control gains focus.
AddOnHelp (inherited from RichControl) | Adds an event handler for the help event. The help event occurs when the user requests help for this control. This may be caused by the user pressing F1, or used "Whats This Help".
AddOnInvalidate (inherited from RichControl) | Adds an event handler for the invalidate event. The invalidate event occurs when the Invalidate method is called on some part of the control's client area. This event may be used to identify when the contents of a window have changed.
AddOnKeyDown (inherited from Control) | Adds an event handler for the keyDown event. The keyDown event occurs when the user presses a key down.
AddOnKeyPress (inherited from Control) | Adds an event handler for the keyPress event. The keyPress event occurs when the user presses a key.
AddOnKeyUp (inherited from Control) | Adds an event handler for the keyUp event. The keyUp event occurs when the user releases a key.
AddOnLayout (inherited from Control) | Adds an event handler for the layout event. The layout event occurs when any event occurs that would cause the control to layout child controls. These events include; resize, show/hide child controls, add/remove child controls. This event should be used to perform any custom layout logic.
AddOnLeave (inherited from Control) | Adds an event handler for the leave event. The leave event occurs when focus leaves this control. This doesn't imply that this control lost focus, but rather that focus has been moved out of this control and any child controls.
AddOnLostFocus (inherited from Control) | Adds an event handler for the lostFocus event. The lostFocus event occurs when this control looses focus.
AddOnMouseDown (inherited from Control) | Adds an event handler for the mouseDown event. The mouseDown event occurs when the user presses the mouseDown over this control.
AddOnMouseEnter (inherited from Control) | Adds an event handler for the mouseEnter event. The mouseEnter event occurs when the mouse first moves over this control.
AddOnMouseHover (inherited from Control) | Adds an event handler for the mouseHover event. The mouseHover event occurs after the mouse is inside a control for an amount.
AddOnMouseLeave (inherited from Control) | Adds an event handler for the mouseLeave event. The mouseLeave event occurs when the mouse first moves out of this control.
AddOnMouseMove (inherited from Control) | Adds an event handler for the mouseMove event. The mouseMove event occurs whenever the user moves the mouse over this control.
AddOnMouseUp (inherited from Control) | Adds an event handler for the mouseUp event. The mouseUp event occurs when the user releases a mouse button inside the control.
AddOnMouseWheel (inherited from Control) | Adds an event handler for the mouseWheel event. The mouseWheel event occurs when the user scrolls the mouse wheel up or down. The delta value in the event data indicates the amount that the mouse wheel has moved. The Microsoft standards indicate that the view should scroll by System.WinForms.SystemInformation.getMouseWheelScrollLines() when the delta value has reach win.WHEEL_DELTA. If a mouseWheel event occurs with a value less that WHEEL_DELTA, the control should either increment a stored value and wait until the total delta is an increment of WHEEL_DELTA, or scroll the view a percentage of MouseWheelScrollLines. NOTE: A press of the mouseWheel will generate a mouseDown event with the middle button pressed.
AddOnMove (inherited from Control) | Adds an event handler for the move event. The move event occurs when the controls location changes.
AddOnPaint (inherited from RichControl) | Adds an event handler for the paint event. The paint event occurs when the control needs to paint some part of it's client area.
AddOnPropertyChanged (inherited from Control) | Adds an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.
AddOnQueryContinueDrag (inherited from RichControl) | Adds an event handler for the queryContinueDrag event. The queryContinueDrag event occurs during a drag operation. This allows the drag source to determine if the drag operation should be canceled.
AddOnResize (inherited from Control) | Adds an event handler for the resize event. The resize event occurs when the bounds of the control change. This event may be fired from the constructor of base controls.
AddOnValidated (inherited from Control) | Adds an event handler for the validated event. The validated event occurs when a control was successfully validated.
AddOnValidating (inherited from Control) | Adds an event handler for the validating event. The validating event occurs when the control loses focus and a control that causes validation gains focus. This is where users can write code to validate the current values of the control.
RemoveOnClick (inherited from Control) | Removes the given handler for the "OnClick" event. If there are duplicate entries, ALL are removed.
RemoveOnControlAdded (inherited from Control) | Removes the given handler for the "ControlAdded" event. If there are duplicate entries, ALL are removed.
RemoveOnControlRemoved (inherited from Control) | Removes the given handler for the "ControlRemoved" event. If there are duplicate entries, ALL are removed.
RemoveOnCreateHandle (inherited from Control) | Removes the given handler for the "createHandle" event. If there are duplicate entries, ALL are removed.
RemoveOnDestroyHandle (inherited from Control) | Removes the given handler for the "destroyHandle" event. If there are duplicate entries, ALL are removed.
RemoveOnDoubleClick (inherited from Control) | Removes the given handler for the "OnDoubleClick" event. If there are duplicate entries, ALL are removed.
RemoveOnDragDrop (inherited from RichControl) | Removes the given handler for the "dragDrop" event. If there are duplicate entries, ALL are removed.
RemoveOnDragEnter (inherited from RichControl) | Removes the given handler for the "OnDragEnter" event. If there are duplicate entries, ALL are removed.
RemoveOnDragLeave (inherited from RichControl) | Removes the given handler for the "OnDragLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnDragOver (inherited from RichControl) | f final Removes the given handler for the "OnDragOver" event. If there are duplicate entries, ALL are removed.
RemoveOnEnter (inherited from Control) | Removes the given handler for the "OnEnter" event. If there are dfinal uplicate entries, ALL are removed.
RemoveOnGiveFeedback (inherited from RichControl) | Removes the given handler for the "OnGiveFeedback" event. If there are duplicate entries, ALL are removed.
RemoveOnGotFocus (inherited from Control) | Removes the given handler for the "OnGotFocus" event. If there are duplicate entries, ALL are removed.
RemoveOnHelp (inherited from RichControl) | Removes the given handler for the "OnHelp" event. If there are duplicate entries, ALL are removed.
RemoveOnInvalidate (inherited from RichControl) | Removes the given handler for the "OnInvalidate" event. If there are duplicate entries, ALL are removed.
RemoveOnKeyDown (inherited from Control) | Removes the given handler for the "OnKeyDown" event. If there are duplicate entries, ALL are removed.
RemoveOnKeyPress (inherited from Control) | Removes the given handler for the "OnKeyPress" event. If there are duplicate entries, ALL are removed.
RemoveOnKeyUp (inherited from Control) | Removes the given handler for the "OnKeyUp" event. If there are duplicate entries, ALL are removed.
RemoveOnLayout (inherited from Control) | Removes the given handler for the layout event. If there are duplicate entries, ALL are removed.
RemoveOnLeave (inherited from Control) | Removes the given handler for the "OnLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnLostFocus (inherited from Control) | Removes the given handler for the "OnLostFocus" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseDown (inherited from Control) | Removes the given handler for the "OnMouseDown" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseEnter (inherited from Control) | Removes the given handler for the "OnMouseEnter" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseHover (inherited from Control) | Removes the given handler for the "OnMouseHover" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseLeave (inherited from Control) | Removes the given handler for the "OnMouseLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseMove (inherited from Control) | Removes the given handler for the "OnMouseMove" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseUp (inherited from Control) | Removes the given handler for the "OnMouseUp" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseWheel (inherited from Control) | Removes the given handler for the "OnMouseWheel" event. If there are duplicate entries, ALL are removed.
RemoveOnMove (inherited from Control) | Removes the given handler for the "OnMove" event. If there are duplicate entries, ALL are removed.
RemoveOnPaint (inherited from RichControl) | Removes the given handler for the "OnPaint" event. If there are duplicate entries, ALL are removed.
RemoveOnPropertyChanged (inherited from Control) | Removes an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.
RemoveOnQueryContinueDrag (inherited from RichControl) | Removes the given handler for the "OnQueryContinueDrag" event. If there are duplicate entries, ALL are removed.
RemoveOnResize (inherited from Control) | Removes the given handler for the "OnResize" event. If there are duplicate entries, ALL are removed.
RemoveOnValidated (inherited from Control) | Removes an event handler for the validated event. The validated event occurs when a control was successfully validated.
RemoveOnValidating (inherited from Control) | Removes an event handler for the validating event. The validating event occurs when the control loses focus and a control that causes validation gains focus. This is where users can write code to validate the current values of the control.

See Also

ByteViewer Class | System.ComponentModel.Design Namespace


ByteViewer.GetBytes

Returns the buffer

[Visual Basic]
Overridable Public Function GetBytes() As Byte ()
[C#]
public virtual byte[] GetBytes();
[C++]
public: virtual unsigned char* GetBytes() [];
[JScript]
public function GetBytes() : Byte[];

Return Value

the ubyte array reference

See Also

ByteViewer Class | ByteViewer Members | System.ComponentModel.Design Namespace


ByteViewer.GetDisplayMode

Returns the display mode for the control

[Visual Basic]
Overridable Public Function GetDisplayMode() As DisplayMode
[C#]
public virtual DisplayMode GetDisplayMode();
[C++]
public: virtual DisplayMode GetDisplayMode();
[JScript]
public function GetDisplayMode() : DisplayMode;

Return Value

display mode (This value is an int defined in DisplayMode)

See Also

ByteViewer Class | ByteViewer Members | System.ComponentModel.Design Namespace


ByteViewer.SaveToFile

Writes the raw data from the data buffer to a file. Rethrows the WinIOException if could not write.

[Visual Basic]
Overridable Public Sub SaveToFile( _
   ByVal path As String _
)
[C#]
public virtual void SaveToFile(
   string path
);
[C++]
public: virtual void SaveToFile(
   String* path
);
[JScript]
public function SaveToFile(
   path : String
);

Parameters

path
file path

See Also

ByteViewer Class | ByteViewer Members | System.ComponentModel.Design Namespace


ByteViewer.SetBytes

Sets the byte array to be displayed in the viewer

[Visual Basic]
Overridable Public Sub SetBytes( _
   ByVal bytes() As Byte _
)
[C#]
public virtual void SetBytes(
   byte[] bytes
);
[C++]
public: virtual void SetBytes(
   unsigned char* bytes[]
);
[JScript]
public function SetBytes(
   bytes : Byte[]
);

Parameters

bytes
byte array to be displayed

See Also

ByteViewer Class | ByteViewer Members | System.ComponentModel.Design Namespace


ByteViewer.SetDisplayMode

Sets the current display mode. See DisplayMode for more details

[Visual Basic]
Overridable Public Sub SetDisplayMode( _
   ByVal mode As DisplayMode _
)
[C#]
public virtual void SetDisplayMode(
   DisplayMode mode
);
[C++]
public: virtual void SetDisplayMode(
   DisplayMode mode
);
[JScript]
public function SetDisplayMode(
   mode : DisplayMode
);

Parameters

mode
display mode

See Also

ByteViewer Class | ByteViewer Members | System.ComponentModel.Design Namespace | DisplayMode


ByteViewer.SetFile

Sets the file to be displayed in the viewer. The viewer will load the file

[Visual Basic]
Overridable Public Sub SetFile( _
   ByVal path As String _
)
[C#]
public virtual void SetFile(
   string path
);
[C++]
public: virtual void SetFile(
   String* path
);
[JScript]
public function SetFile(
   path : String
);

Parameters

path
file path

See Also

ByteViewer Class | ByteViewer Members | System.ComponentModel.Design Namespace


ByteViewer.SetStartLine

Sets the current line for the HEXDUMP view. The HEXDUMP viewer will start displaying the buffer starting fromtheat line

[Visual Basic]
Overridable Public Sub SetStartLine( _
   ByVal line As Integer _
)
[C#]
public virtual void SetStartLine(
   int line
);
[C++]
public: virtual void SetStartLine(
   int line
);
[JScript]
public function SetStartLine(
   line : int
);

Parameters

line
[To be supplied.]

See Also

ByteViewer Class | ByteViewer Members | System.ComponentModel.Design Namespace


CheckoutException Class

Represents the exception thrown when an attempt is made to edit a file that is checked into a source control program.

Object
Exception
SystemException
ExternalException
CheckoutException

[Visual Basic]
Public Class CheckoutException
   Inherits ExternalException
[C#]
public class CheckoutException : ExternalException
[C++]
public __gc class CheckoutException : public ExternalException
[JScript]
public class CheckoutException extends ExternalException

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

CheckoutException Members | System.ComponentModel.Design Namespace


CheckoutException Members

Public:

Constructor

CheckoutException Constructor Overloaded. Initializes a new instance of the CheckoutException class.

Properties

ErrorCode (inherited from ExternalException) | [To be supplied.]
HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Fields

Canceled Initializes a CheckoutException that specifies that the checkout was canceled. This field is read-only.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

CheckoutException Class | System.ComponentModel.Design Namespace


CheckoutException Constructor

Initializes a new instance of the CheckoutException class.

Overload List

Initializes a new instance of the CheckoutException class with no associated message or error code.

[Visual Basic] Overloads Public Sub New()
[C#] public CheckoutException();
[C++] public: CheckoutException();
[JScript] public function CheckoutException();

Initializes a new instance of the CheckoutException class with the specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public CheckoutException(String);
[C++] public: CheckoutException(String*);
[JScript] public function CheckoutException(String);

Initializes a new instance of the CheckoutException class with the specified message and error code.

[Visual Basic] Overloads Public Sub New(String, Integer)
[C#] public CheckoutException(String, int);
[C++] public: CheckoutException(String*, int);
[JScript] public function CheckoutException(String, int);

See Also

CheckoutException Class | CheckoutException Members | System.ComponentModel.Design Namespace


CheckoutException Constructor ()

Initializes a new instance of the CheckoutException class with no associated message or error code.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CheckoutException();
[C++]
public: CheckoutException();
[JScript]
public function CheckoutException();

Remarks

This exception should be thrown when an edit has been attempted on a file that has not been checked out of a source code control program.

See Also

CheckoutException Class | CheckoutException Members | System.ComponentModel.Design Namespace | CheckoutException Constructor Overload List


CheckoutException Constructor (String)

Initializes a new instance of the CheckoutException class with the specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public CheckoutException(
   string message
);
[C++]
public: CheckoutException(
   String* message
);
[JScript]
public function CheckoutException(
   message : String
);

Parameters

message
A message describing the exception.

See Also

CheckoutException Class | CheckoutException Members | System.ComponentModel.Design Namespace | CheckoutException Constructor Overload List


CheckoutException Constructor (String, Int32)

Initializes a new instance of the CheckoutException class with the specified message and error code.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal errorCode As Integer _
)
[C#]
public CheckoutException(
   string message,
   int errorCode
);
[C++]
public: CheckoutException(
   String* message,
   int errorCode
);
[JScript]
public function CheckoutException(
   message : String,
   errorCode : int
);

Parameters

message
A message describing the exception.
errorCode
The error code to pass.

See Also

CheckoutException Class | CheckoutException Members | System.ComponentModel.Design Namespace | CheckoutException Constructor Overload List


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CheckoutException Fields

The fields of the CheckoutException class are listed below. For a complete list of CheckoutException class members, see the CheckoutException Members topic.

Public:

Canceled Initializes a CheckoutException that specifies that the checkout was canceled. This field is read-only.

Protected:

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

CheckoutException Class | System.ComponentModel.Design Namespace


CheckoutException.Canceled

Initializes a CheckoutException that specifies that the checkout was canceled. This field is read-only.

[Visual Basic]
Public Shared ReadOnly Canceled As CheckoutException
[C#]
public static readonly CheckoutException Canceled;
[C++]
public: static readonly CheckoutException* Canceled;
[JScript]
public static var Canceled : CheckoutException;

Remarks

This exception occurs if the user selects Cancel on the checkout dialog.

See Also

CheckoutException Class | CheckoutException Members | System.ComponentModel.Design Namespace


CodePersister Class

The code persister is part of a trio of objects that load and save the document. At the base of this trio is the CodeStream object, which is required for loading and saving documents. On top of the code stream is an optional language layer. This language layer allows documents that are based on source code to be loaded and saved in a generic manner. The language layer implements a series of "code access" interfaces through which an object may read and write source code in a language independent way. The code persister is the object responsible for reading and writing to the code access interfaces.

Object
CodePersister

[Visual Basic]
MustInherit Public Class CodePersister
[C#]
public abstract class CodePersister
[C++]
public __gc __abstract class CodePersister
[JScript]
public abstract class CodePersister

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

CodePersister Members | System.ComponentModel.Design Namespace


CodePersister Members

Public:

Constructor

CodePersister Constructor [To be supplied.]

Properties

CanReload This can be called to check if the persister can be reloaded. This will return true by default, thereby forcing a reload of the designer.

Methods

Dispose | Disposes this object. After this call the object is no longer useful.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetComponentCode | Parse code fragments into statements. This should be fragments that normally would live inside a method body.
GetComponentsFromCode | Parse code fragments into components. This should be fragments that normally would live inside a method body.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNameFromReference | Returns the name of the given reference. This will look up in either the referenceService or the component's site.
GetReferenceFromName | Retrieves the component with the specified reference name. If the component has not been declared yet, this will call CreateComponentInstance to create it.
GetType (inherited from Object) | Gets the Type of the Object.
Init | Initializes this persister with the specified host and sourceFile.
Load | Called by the code stream when it needs to load the document. This should parse the source code in the document and create the instances of the individual components.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

DocumentCodeClass | Class that is currently being edited. This must be overriden by subclasses. Note that you should always get the editing class from the source file; never cache it. As the source file changes you do not know if the underlying implemenation will keep the class instances in sync with the file.
FirstLoadException | First load exception that occurs. This allows the parsing to continue on and still report the first failure.
Host | IDesignerHost this persister should communicate with.
IgnoreCase | [To be supplied.]
SourceFile | Source code that this persister should read/write to. Since the sub objects from source file (i.e. class, method, etc) change often, only the sourcefile can be cached. You should never cache instances you get from this source file.
ValueProviderSorter | [To be supplied.]

Methods

AlwaysPersist | If any value provider indicates that a value is "UserSelected" then we must force the persistence of the value.
BeginDepersisting | Notifies value providers that depersisting has begun.
BeginPersisting | Notifies value providers that persisting has begun.
CreateComponentInstance | Create the component specified and initialize its Modifiers property.
CreateExpressionFromPropertyValue | Creates an expression value object from a PropertyValue. This will perform a deep scan on the PropertyValue and convert any nested object creates, array creates, name references, or constants. For more information on values and expressions see the ICodeSourceFile documentation.
CreateExpressionFromValue | Creates an expression from a component/propertyName combination. This should only be used for property sets.
CreateValueFromExpression | Creates a value from an expression object returned form the CodeSense APIs. This will take the various expressions and execute them, so to say. For example, if you pass in a ICodeObjectCreateExpression for value and it refers to the Point class, then a Point object will be returned. For more information on values and expression see the ICodeSourceFile documentation.
DeclareComponent | This is used during code parsing to declare a given data member. We declare the member, and then we create an instance of this data member. This will throw an exception if the data member has already been declared.
EndDepersisting | Notifies value providers that depersisting has completed.
EndPersisting | Notifies value providers that persisting has completed.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetServiceObject | Searches for the requested service.
GetValueProviderDeclarations | Returns the array of value provider local variable declarations.
IsValueProviderDeclaration | Determines if the specified statement is a the local declaration for a value provider.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PersistNamedResource | Creates an expression from a name/value pair.

See Also

CodePersister Class | System.ComponentModel.Design Namespace


CodePersister Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CodePersister();
[C++]
public: CodePersister();
[JScript]
public function CodePersister();

See Also

CodePersister Class | CodePersister Members | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodePersister Properties

The properties of the CodePersister class are listed below. For a complete list of CodePersister class members, see the CodePersister Members topic.

Public:

CanReload This can be called to check if the persister can be reloaded. This will return true by default, thereby forcing a reload of the designer.

Protected:

DocumentCodeClass | Class that is currently being edited. This must be overriden by subclasses. Note that you should always get the editing class from the source file; never cache it. As the source file changes you do not know if the underlying implemenation will keep the class instances in sync with the file.
FirstLoadException | First load exception that occurs. This allows the parsing to continue on and still report the first failure.
Host | IDesignerHost this persister should communicate with.
IgnoreCase | [To be supplied.]
SourceFile | Source code that this persister should read/write to. Since the sub objects from source file (i.e. class, method, etc) change often, only the sourcefile can be cached. You should never cache instances you get from this source file.
ValueProviderSorter | [To be supplied.]

See Also

CodePersister Class | System.ComponentModel.Design Namespace


CodePersister.CanReload

This can be called to check if the persister can be reloaded. This will return true by default, thereby forcing a reload of the designer.

[Visual Basic]
Overridable Public ReadOnly Property CanReload As Boolean
[C#]
public bool CanReload {virtual get;}
[C++]
public: __property virtual bool get_CanReload();
[JScript]
public function get CanReload() : Boolean;

See Also

CodePersister Class | CodePersister Members | System.ComponentModel.Design Namespace


CodePersister.DocumentCodeClass

Class that is currently being edited. This must be overriden by subclasses. Note that you should always get the editing class from the source file; never cache it. As the source file changes you do not know if the underlying implemenation will keep the class instances in sync with the file.

[Visual Basic]
MustOverride Protected ReadOnly Property DocumentCodeClass As _
   ICodeClass
[C#]
protected ICodeClass DocumentCodeClass {abstract get;}
[C++]
protected: __property virtual ICodeClass* get_DocumentCodeClass() =
   0;
[JScript]
protected abstract function get DocumentCodeClass() : ICodeClass;

Property Value

An ICodeClass that indicates the type of the main class this persister is editing.

See Also

CodePersister Class | CodePersister Members | System.ComponentModel.Design Namespace


CodePersister.FirstLoadException

First load exception that occurs. This allows the parsing to continue on and still report the first failure.

[Visual Basic]
Protected Property FirstLoadException As Exception
[C#]
protected Exception FirstLoadException {get; set;}
[C++]
protected: __property Exception* get_FirstLoadException();
protected: __property void set_FirstLoadException(Exception*);
[JScript]
protected function get FirstLoadException() : Exception;
protected function set FirstLoadException(Exception);

See Also

CodePersister Class | CodePersister Members | System.ComponentModel.Design Namespace


CodePersister.Host

IDesignerHost this persister should communicate with.

[Visual Basic]
Overridable Protected ReadOnly Property Host As IDesignerHost
[C#]
protected IDesignerHost Host {virtual get;}
[C++]
protected: __property virtual IDesignerHost* get_Host();
[JScript]
protected function get Host() : IDesignerHost;

See Also

CodePersister Class | CodePersister Members | System.ComponentModel.Design Namespace


CodePersister.IgnoreCase

[To be supplied.]

[Visual Basic]
Protected Property IgnoreCase As Boolean
[C#]
protected bool IgnoreCase {get; set;}
[C++]
protected: __property bool get_IgnoreCase();
protected: __property void set_IgnoreCase(bool);
[JScript]
protected function get IgnoreCase() : Boolean;
protected function set IgnoreCase(Boolean);

See Also

CodePersister Class | CodePersister Members | System.ComponentModel.Design Namespace


CodePersister.SourceFile

Source code that this persister should read/write to. Since the sub objects from source file (i.e. class, method, etc) change often, only the sourcefile can be cached. You should never cache instances you get from this source file.

[Visual Basic]
Overridable Protected ReadOnly Property SourceFile As _
   ICodeSourceFile
[C#]
protected ICodeSourceFile SourceFile {virtual get;}
[C++]
protected: __property virtual ICodeSourceFile* get_SourceFile();
[JScript]
protected function get SourceFile() : ICodeSourceFile;

See Also

CodePersister Class | CodePersister Members | System.ComponentModel.Design Namespace


CodePersister.ValueProviderSorter

[To be supplied.]

[Visual Basic]
Protected ReadOnly Property ValueProviderSorter As IComparer
[C#]
protected IComparer ValueProviderSorter {get;}
[C++]
protected: __property IComparer* get_ValueProviderSorter();
[JScript]
protected function get ValueProviderSorter() : IComparer;

See Also

CodePersister Class | CodePersister Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodePersister Methods

The methods of the CodePersister class are listed below. For a complete list of CodePersister class members, see the CodePersister Members topic.

Public:

Dispose | Disposes this object. After this call the object is no longer useful.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetComponentCode | Parse code fragments into statements. This should be fragments that normally would live inside a method body.
GetComponentsFromCode | Parse code fragments into components. This should be fragments that normally would live inside a method body.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNameFromReference | Returns the name of the given reference. This will look up in either the referenceService or the component's site.
GetReferenceFromName | Retrieves the component with the specified reference name. If the component has not been declared yet, this will call CreateComponentInstance to create it.
GetType (inherited from Object) | Gets the Type of the Object.
Init | Initializes this persister with the specified host and sourceFile.
Load | Called by the code stream when it needs to load the document. This should parse the source code in the document and create the instances of the individual components.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

AlwaysPersist | If any value provider indicates that a value is "UserSelected" then we must force the persistence of the value.
BeginDepersisting | Notifies value providers that depersisting has begun.
BeginPersisting | Notifies value providers that persisting has begun.
CreateComponentInstance | Create the component specified and initialize its Modifiers property.
CreateExpressionFromPropertyValue | Creates an expression value object from a PropertyValue. This will perform a deep scan on the PropertyValue and convert any nested object creates, array creates, name references, or constants. For more information on values and expressions see the ICodeSourceFile documentation.
CreateExpressionFromValue | Creates an expression from a component/propertyName combination. This should only be used for property sets.
CreateValueFromExpression | Creates a value from an expression object returned form the CodeSense APIs. This will take the various expressions and execute them, so to say. For example, if you pass in a ICodeObjectCreateExpression for value and it refers to the Point class, then a Point object will be returned. For more information on values and expression see the ICodeSourceFile documentation.
DeclareComponent | This is used during code parsing to declare a given data member. We declare the member, and then we create an instance of this data member. This will throw an exception if the data member has already been declared.
EndDepersisting | Notifies value providers that depersisting has completed.
EndPersisting | Notifies value providers that persisting has completed.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetServiceObject | Searches for the requested service.
GetValueProviderDeclarations | Returns the array of value provider local variable declarations.
IsValueProviderDeclaration | Determines if the specified statement is a the local declaration for a value provider.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PersistNamedResource | Creates an expression from a name/value pair.

See Also

CodePersister Class | System.ComponentModel.Design Namespace


CodePersister.AlwaysPersist

If any value provider indicates that a value is "UserSelected" then we must force the persistence of the value.

[Visual Basic]
Protected Function AlwaysPersist( _
   ByVal property As PropertyDescriptor, _
   ByVal comp As Object _
) As Boolean
[C#]
protected bool AlwaysPersist(
   PropertyDescriptor property,
   object comp
);
[C++]
protected: bool AlwaysPersist(
   PropertyDescriptor* property,
   Object* comp
);
[JScript]
protected function AlwaysPersist(
   property : PropertyDescriptor,
   comp : Object
) : Boolean;

Parameters

property
[To be supplied.]
comp
[To be supplied.]

See Also

CodePersister Class | CodePersister Members | System.ComponentModel.Design Namespace


CodePersister.BeginDepersisting

Notifies value providers that depersisting has begun.

[Visual Basic]
Protected Sub BeginDepersisting()
[C#]
protected void BeginDepersisting();
[C++]
protected: void BeginDepersisting();
[JScript]
protected function BeginDepersisting();

See Also

CodePersister Class | CodePersister Members | System.ComponentModel.Design Namespace


CodePersister.BeginPersisting

Notifies value providers that persisting has begun.

[Visual Basic]
Protected Sub BeginPersisting()
[C#]
protected void BeginPersisting();
[C++]
protected: void BeginPersisting();
[JScript]
protected function BeginPersisting();

See Also

CodePersister Class | CodePersister Members | System.ComponentModel.Design Namespace


CodePersister.CreateComponentInstance

Create the component specified and initialize its Modifiers property.

[Visual Basic]
Overridable Protected Function CreateComponentInstance( _
   ByVal componentClass As Type, _
   ByVal componentsDecl As ICodeDataMember _
) As IComponent
[C#]
protected virtual IComponent CreateComponentInstance(
   Type componentClass,
   ICodeDataMember componentsDecl
);
[C++]
protected: virtual IComponent* CreateComponentInstance(
   Type* componentClass,
   ICodeDataMember* componentsDecl
);
[JScript]
protected function CreateComponentInstance(
   componentClass : Type,
   componentsDecl : ICodeDataMember
) : IComponent;

Parameters

componentClass
[To be supplied.]
componentsDecl
[To be supplied.]

See Also

CodePersister Class | CodePersister Members | System.ComponentModel.Design Namespace


CodePersister.CreateExpressionFromPropertyValue

Creates an expression value object from a PropertyValue. This will perform a deep scan on the PropertyValue and convert any nested object creates, array creates, name references, or constants.

For more information on values and expressions see the ICodeSourceFile documentation.

[Visual Basic]
Protected Function CreateExpressionFromPropertyValue( _
   ByVal value As PropertyValue _
) As Object
[C#]
protected object CreateExpressionFromPropertyValue(
   PropertyValue value
);
[C++]
protected: Object* CreateExpressionFromPropertyValue(
   PropertyValue* value
);
[JScript]
protected function CreateExpressionFromPropertyValue(
   value : PropertyValue
) : Object;

Parameters

value
PropertyValue to convert.

See Also

CodePersister Class | CodePersister Members | System.ComponentModel.Design Namespace | ICodeSourceFile


CodePersister.CreateExpressionFromValue

Creates an expression from a component/propertyName combination. This should only be used for property sets.

[Visual Basic]
Protected Function CreateExpressionFromValue( _
   ByVal component As Object, _
   ByVal property As PropertyDescriptor, _
   ByVal persistable As PersistableSupport, _
   ByVal value As Object _
) As Object
[C#]
protected object CreateExpressionFromValue(
   object component,
   PropertyDescriptor property,
   PersistableSupport persistable,
   object value
);
[C++]
protected: Object* CreateExpressionFromValue(
   Object* component,
   PropertyDescriptor* property,
   PersistableSupport persistable,
   Object* value
);
[JScript]
protected function CreateExpressionFromValue(
   component : Object,
   property : PropertyDescriptor,
   persistable : PersistableSupport,
   value : Object
) : Object;

Parameters

component
[To be supplied.]
property
[To be supplied.]
persistable
[To be supplied.]
value
[To be supplied.]

See Also

CodePersister Class | CodePersister Members | System.ComponentModel.Design Namespace


CodePersister.CreateValueFromExpression

Creates a value from an expression object returned form the CodeSense APIs. This will take the various expressions and execute them, so to say. For example, if you pass in a ICodeObjectCreateExpression for value and it refers to the Point class, then a Point object will be returned.

For more information on values and expression see the ICodeSourceFile documentation.

[Visual Basic]
Protected Function CreateValueFromExpression( _
   ByVal component As Object, _
   ByVal propertyName As String, _
   ByVal value As Object _
) As Object
[C#]
protected object CreateValueFromExpression(
   object component,
   string propertyName,
   object value
);
[C++]
protected: Object* CreateValueFromExpression(
   Object* component,
   String* propertyName,
   Object* value
);
[JScript]
protected function CreateValueFromExpression(
   component : Object,
   propertyName : String,
   value : Object
) : Object;

Parameters

component
[To be supplied.]
propertyName
[To be supplied.]
value
Expression to evaluate.

See Also

CodePersister Class | CodePersister Members | System.ComponentModel.Design Namespace | ICodeSourceFile


CodePersister.DeclareComponent

This is used during code parsing to declare a given data member. We declare the member, and then we create an instance of this data member. This will throw an exception if the data member has already been declared.

[Visual Basic]
Protected Sub DeclareComponent( _
   ByVal member As ICodeDataMember _
)
[C#]
protected void DeclareComponent(
   ICodeDataMember member
);
[C++]
protected: void DeclareComponent(
   ICodeDataMember* member
);
[JScript]
protected function DeclareComponent(
   member : ICodeDataMember
);

Parameters

member
The data member to declare.

See Also

CodePersister Class | CodePersister Members | System.ComponentModel.Design Namespace


CodePersister.Dispose

Disposes this object. After this call the object is no longer useful.

[Visual Basic]
Overridable Public Sub Dispose()
[C#]
public virtual void Dispose();
[C++]
public: virtual void Dispose();
[JScript]
public function Dispose();

See Also

CodePersister Class | CodePersister Members | System.ComponentModel.Design Namespace


CodePersister.EndDepersisting

Notifies value providers that depersisting has completed.

[Visual Basic]
Protected Sub EndDepersisting()
[C#]
protected void EndDepersisting();
[C++]
protected: void EndDepersisting();
[JScript]
protected function EndDepersisting();

See Also

CodePersister Class | CodePersister Members | System.ComponentModel.Design Namespace


CodePersister.EndPersisting

Notifies value providers that persisting has completed.

[Visual Basic]
Protected Sub EndPersisting()
[C#]
protected void EndPersisting();
[C++]
protected: void EndPersisting();
[JScript]
protected function EndPersisting();

See Also

CodePersister Class | CodePersister Members | System.ComponentModel.Design Namespace


CodePersister.GetComponentCode

Parse code fragments into statements. This should be fragments that normally would live inside a method body.

[Visual Basic]
MustOverride Public Function GetComponentCode( _
   ByVal components() As IComponent, _
   ByVal sourceFile As ICodeSourceFile, _
   ByVal xOffset As Integer, _
   ByVal yOffset As Integer _
) As String
[C#]
public abstract string GetComponentCode(
   IComponent[] components,
   ICodeSourceFile sourceFile,
   int xOffset,
   int yOffset
);
[C++]
public: virtual String* GetComponentCode(
   IComponent* components[],
   ICodeSourceFile* sourceFile,
   int xOffset,
   int yOffset
) = 0;
[JScript]
public abstract function GetComponentCode(
   components : IComponent[],
   sourceFile : ICodeSourceFile,
   xOffset : int,
   yOffset : int
) : String;

Parameters

components
[To be supplied.]
sourceFile
[To be supplied.]
xOffset
[To be supplied.]
yOffset
[To be supplied.]

See Also

CodePersister Class | CodePersister Members | System.ComponentModel.Design Namespace


CodePersister.GetComponentsFromCode

Parse code fragments into components. This should be fragments that normally would live inside a method body.

[Visual Basic]
MustOverride Public Function GetComponentsFromCode( _
   ByVal code As String, _
   ByVal maxComps As Integer, _
   ByVal sourceFile As ICodeSourceFile _
) As IComponent ()
[C#]
public abstract IComponent[] GetComponentsFromCode(
   string code,
   int maxComps,
   ICodeSourceFile sourceFile
);
[C++]
public: virtual IComponent* GetComponentsFromCode(
   String* code,
   int maxComps,
   ICodeSourceFile* sourceFile
) [] = 0;
[JScript]
public abstract function GetComponentsFromCode(
   code : String,
   maxComps : int,
   sourceFile : ICodeSourceFile
) : IComponent[];

Parameters

code
[To be supplied.]
maxComps
The maximum number of components to parse.
sourceFile
[To be supplied.]

See Also

CodePersister Class | CodePersister Members | System.ComponentModel.Design Namespace


CodePersister.GetNameFromReference

Returns the name of the given reference. This will look up in either the referenceService or the component's site.

[Visual Basic]
Overridable Public Function GetNameFromReference( _
   ByVal reference As Object _
) As String
[C#]
public virtual string GetNameFromReference(
   object reference
);
[C++]
public: virtual String* GetNameFromReference(
   Object* reference
);
[JScript]
public function GetNameFromReference(
   reference : Object
) : String;

Parameters

reference
[To be supplied.]

See Also

CodePersister Class | CodePersister Members | System.ComponentModel.Design Namespace


CodePersister.GetReferenceFromName

Retrieves the component with the specified reference name. If the component has not been declared yet, this will call CreateComponentInstance to create it.

[Visual Basic]
Overridable Public Function GetReferenceFromName( _
   ByVal name As String _
) As Object
[C#]
public virtual object GetReferenceFromName(
   string name
);
[C++]
public: virtual Object* GetReferenceFromName(
   String* name
);
[JScript]
public function GetReferenceFromName(
   name : String
) : Object;

Parameters

name
[To be supplied.]

See Also

CodePersister Class | CodePersister Members | System.ComponentModel.Design Namespace


CodePersister.GetServiceObject

Searches for the requested service.

[Visual Basic]
Overridable Protected Function GetServiceObject( _
   ByVal serviceType As Type _
) As Object
[C#]
protected virtual object GetServiceObject(
   Type serviceType
);
[C++]
protected: virtual Object* GetServiceObject(
   Type* serviceType
);
[JScript]
protected function GetServiceObject(
   serviceType : Type
) : Object;

Parameters

serviceType
The service being requested.

Return Value

An instance of the service, or null if the service could not be found.

See Also

CodePersister Class | CodePersister Members | System.ComponentModel.Design Namespace


CodePersister.GetValueProviderDeclarations

Returns the array of value provider local variable declarations.

[Visual Basic]
Protected Function GetValueProviderDeclarations() As ICodeStatement _
   ()
[C#]
protected ICodeStatement[] GetValueProviderDeclarations();
[C++]
protected: ICodeStatement* GetValueProviderDeclarations() [];
[JScript]
protected function GetValueProviderDeclarations() : ICodeStatement[];

See Also

CodePersister Class | CodePersister Members | System.ComponentModel.Design Namespace


CodePersister.Init

Initializes this persister with the specified host and sourceFile.

[Visual Basic]
Overridable Public Sub Init( _
   ByVal sourceFile As ICodeSourceFile, _
   ByVal host As IDesignerHost _
)
[C#]
public virtual void Init(
   ICodeSourceFile sourceFile,
   IDesignerHost host
);
[C++]
public: virtual void Init(
   ICodeSourceFile* sourceFile,
   IDesignerHost* host
);
[JScript]
public function Init(
   sourceFile : ICodeSourceFile,
   host : IDesignerHost
);

Parameters

sourceFile
Source code that this persister should read/write to.
host
IDesignerHost that this persister should communicate with.

See Also

CodePersister Class | CodePersister Members | System.ComponentModel.Design Namespace


CodePersister.IsValueProviderDeclaration

Determines if the specified statement is a the local declaration for a value provider.

[Visual Basic]
Protected Function IsValueProviderDeclaration( _
   ByVal stmt As ICodeStatement _
) As Boolean
[C#]
protected bool IsValueProviderDeclaration(
   ICodeStatement stmt
);
[C++]
protected: bool IsValueProviderDeclaration(
   ICodeStatement* stmt
);
[JScript]
protected function IsValueProviderDeclaration(
   stmt : ICodeStatement
) : Boolean;

Parameters

stmt
[To be supplied.]

See Also

CodePersister Class | CodePersister Members | System.ComponentModel.Design Namespace


CodePersister.Load

Called by the code stream when it needs to load the document. This should parse the source code in the document and create the instances of the individual components.

[Visual Basic]
MustOverride Public Function Load() As String
[C#]
public abstract string Load();
[C++]
public: virtual String* Load() = 0;
[JScript]
public abstract function Load() : String;

Return Value

The fully qualified class name of the base component in the document. The base component is the "root" of the document and represents the object that is being designed. The base class of the document base component is typically substituted at design time. As an example, if a document called "Form1" is being edited, and the class "Form1" inherits from "Form", the persister would create an instance of "Form" and return "Form1" from the load method.

See Also

CodePersister Class | CodePersister Members | System.ComponentModel.Design Namespace


CodePersister.PersistNamedResource

Creates an expression from a name/value pair.

[Visual Basic]
Protected Sub PersistNamedResource( _
   ByVal name As String, _
   ByVal value As String _
)
[C#]
protected void PersistNamedResource(
   string name,
   string value
);
[C++]
protected: void PersistNamedResource(
   String* name,
   String* value
);
[JScript]
protected function PersistNamedResource(
   name : String,
   value : String
);

Parameters

name
[To be supplied.]
value
[To be supplied.]

See Also

CodePersister Class | CodePersister Members | System.ComponentModel.Design Namespace


CodeStream Class

The code stream is used to load and save the document.

Object
CodeStream

[Visual Basic]
MustInherit Public Class CodeStream
[C#]
public abstract class CodeStream
[C++]
public __gc __abstract class CodeStream
[JScript]
public abstract class CodeStream

Remarks

When the user wants to display the design view for a document, the file type of the document file will be used to determine what code stream to create. The code stream will be created and instructed to load.

Notes to Inheritors: Certain members of this class must be overridden in a derived class in order to implement them.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

CodeStream Members | System.ComponentModel.Design Namespace | IDesignerHost


CodeStream Members

Public:

Constructor

CodeStream Constructor [To be supplied.]

Properties

CanEdit | Gets or sets a value indicating whether the code stream can be modified.
IgnoreCase | Gets if the code stream is case sensitive or not.
IsLoaded | Gets or sets a value indicating whether the code stream is loaded.
ShouldReload | Gets or sets a value indicating whether, due to changes, the code stream should be reloaded.

Methods

Dispose | Disposes of the resources (other than memory) being used by the CodeStream.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Load | Loads a document, using the specified designer host.
ToString (inherited from Object) | Returns a String that represents the current Object.
Unload | Unloads the currently loaded document.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeStream Class | System.ComponentModel.Design Namespace


CodeStream Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CodeStream();
[C++]
public: CodeStream();
[JScript]
public function CodeStream();

See Also

CodeStream Class | CodeStream Members | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeStream Properties

The properties of the CodeStream class are listed below. For a complete list of CodeStream class members, see the CodeStream Members topic.

Public:

CanEdit | Gets or sets a value indicating whether the code stream can be modified.
IgnoreCase | Gets if the code stream is case sensitive or not.
IsLoaded | Gets or sets a value indicating whether the code stream is loaded.
ShouldReload | Gets or sets a value indicating whether, due to changes, the code stream should be reloaded.

See Also

CodeStream Class | System.ComponentModel.Design Namespace


CodeStream.CanEdit

Gets or sets a value indicating whether the code stream can be modified.

[Visual Basic]
Overridable Public ReadOnly Property CanEdit As Boolean
[C#]
public bool CanEdit {virtual get;}
[C++]
public: __property virtual bool get_CanEdit();
[JScript]
public function get CanEdit() : Boolean;

Property Value

true if the code stream can be modified; otherwise, false.

Remarks

The editable state of the code stream may be affected by the checked out state of the document or if the file is read-only.

See Also

CodeStream Class | CodeStream Members | System.ComponentModel.Design Namespace


CodeStream.IgnoreCase

Gets if the code stream is case sensitive or not.

[Visual Basic]
Overridable Public ReadOnly Property IgnoreCase As Boolean
[C#]
public bool IgnoreCase {virtual get;}
[C++]
public: __property virtual bool get_IgnoreCase();
[JScript]
public function get IgnoreCase() : Boolean;

Property Value

true if case is ignored; false if the code stream is case sensitive.

See Also

CodeStream Class | CodeStream Members | System.ComponentModel.Design Namespace


CodeStream.IsLoaded

Gets or sets a value indicating whether the code stream is loaded.

[Visual Basic]
MustOverride Public ReadOnly Property IsLoaded As Boolean
[C#]
public bool IsLoaded {abstract get;}
[C++]
public: __property virtual bool get_IsLoaded() = 0;
[JScript]
public abstract function get IsLoaded() : Boolean;

Property Value

true if the code stream is loaded; otherwise, false.

Remarks

Reloading the document has no effect on the return value of this method. Only loading or unloading affects the load state.

See Also

CodeStream Class | CodeStream Members | System.ComponentModel.Design Namespace | ShouldReload


CodeStream.ShouldReload

Gets or sets a value indicating whether, due to changes, the code stream should be reloaded.

[Visual Basic]
MustOverride Public ReadOnly Property ShouldReload As Boolean
[C#]
public bool ShouldReload {abstract get;}
[C++]
public: __property virtual bool get_ShouldReload() = 0;
[JScript]
public abstract function get ShouldReload() : Boolean;

Property Value

true if the underlying data from the code stream has been modified since the prior load; otherwise, false.

See Also

CodeStream Class | CodeStream Members | System.ComponentModel.Design Namespace | IsLoaded


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodeStream Methods

The methods of the CodeStream class are listed below. For a complete list of CodeStream class members, see the CodeStream Members topic.

Public:

Dispose | Disposes of the resources (other than memory) being used by the CodeStream.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Load | Loads a document, using the specified designer host.
ToString (inherited from Object) | Returns a String that represents the current Object.
Unload | Unloads the currently loaded document.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeStream Class | System.ComponentModel.Design Namespace


CodeStream.Dispose

Disposes of the resources (other than memory) being used by the CodeStream.

[Visual Basic]
MustOverride Public Sub Dispose()
[C#]
public abstract void Dispose();
[C++]
public: virtual void Dispose() = 0;
[JScript]
public abstract function Dispose();

Remarks

This method is called when the CodeStream is no longer needed. This method is typically called when the document is closed by the user. The CodeStream should remove any events it had connected to. This method will be called only once.

Call Dispose when you are finished using the CodeStream. The Dispose method leaves the CodeStream in an unusuable state. After calling Dispose, you must release all references to the CodeStream so the memory it was occupying can be reclaimed by garbage collection.

Always call Dispose before you release your last reference to the CodeStream. Otherwise, the resources the CodeStream is using will not be freed until garbage collection calls the CodeStream object's destructor.

See Also

CodeStream Class | CodeStream Members | System.ComponentModel.Design Namespace


CodeStream.GetType

Gets the type of the object matching the specified type name. This method is used by the designer host to load classes and other data types.

Overload List

Gets the type of the object matching the specified type name. This method is used by the designer host to load classes and other data types.

[Visual Basic] Overloads Overridable Public Function GetType(String) As Type
[C#] public virtual Type GetType(String);
[C++] public: virtual Type* GetType(String*);
[JScript] public function GetType(String) : Type;

Gets the type of the object matching the specified type name within the specified assembly. This method will be used by the designer host to load classes and other data types.

[Visual Basic] Overloads Overridable Public Function GetType(String, AssemblyName) As Type
[C#] public virtual Type GetType(String, AssemblyName);
[C++] public: virtual Type* GetType(String*, AssemblyName);
[JScript] public function GetType(String, AssemblyName) : Type;

See Also

CodeStream Class | CodeStream Members | System.ComponentModel.Design Namespace


CodeStream.GetType (String)

Gets the type of the object matching the specified type name. This method is used by the designer host to load classes and other data types.

[Visual Basic]
Overloads Overridable Public Function GetType( _
   ByVal typeName As String _
) As Type
[C#]
public virtual Type GetType(
   string typeName
);
[C++]
public: virtual Type* GetType(
   String* typeName
);
[JScript]
public function GetType(
   typeName : String
) : Type;

Parameters

typeName
The name of the type to load.

Return Value

The type of the object indicated by the specified name.

Remarks

Notes to Inheritors: The default implementation simply calls Type.GetType, but you may override this to provide your own functionality.

See Also

CodeStream Class | CodeStream Members | System.ComponentModel.Design Namespace | CodeStream.GetType Overload List


CodeStream.GetType (String, AssemblyName)

Gets the type of the object matching the specified type name within the specified assembly. This method will be used by the designer host to load classes and other data types.

[Visual Basic]
Overloads Overridable Public Function GetType( _
   ByVal typeName As String, _
   ByVal assemblyName As AssemblyName _
) As Type
[C#]
public virtual Type GetType(
   string typeName,
   AssemblyName assemblyName
);
[C++]
public: virtual Type* GetType(
   String* typeName,
   AssemblyName* assemblyName
);
[JScript]
public function GetType(
   typeName : String,
   assemblyName : AssemblyName
) : Type;

Parameters

typeName
The name of the type to load.
assemblyName
The name of the assembly that contains the type.

Return Value

The type of the object indicated by the specified name and assembly.

Remarks

Notes to Inheritors: The default implementation simply calls Type.GetType, but you can override this to provide your own functionality.

See Also

CodeStream Class | CodeStream Members | System.ComponentModel.Design Namespace | CodeStream.GetType Overload List


CodeStream.Load

Loads a document, using the specified designer host.

[Visual Basic]
MustOverride Public Sub Load( _
   ByVal host As IDesignerHost _
)
[C#]
public abstract void Load(
   IDesignerHost host
);
[C++]
public: virtual void Load(
   IDesignerHost* host
) = 0;
[JScript]
public abstract function Load(
   host : IDesignerHost
);

Parameters

host
The IDesignerHost that this code stream should load the document into. After loading, the code stream should connect any events it needs to monitor changes in the document.

Remarks

Notes to Inheritors: Meant to be overridden in a derived class, this method should be called to load the document. Documents can be reloaded, so this may be called more than once. When called, this should fully load the document from start to finish. If a document is to be reloaded, Unload should always be called first.

See Also

CodeStream Class | CodeStream Members | System.ComponentModel.Design Namespace | Unload | IDesignerHost


CodeStream.Unload

Unloads the currently loaded document.

[Visual Basic]
MustOverride Public Sub Unload()
[C#]
public abstract void Unload();
[C++]
public: virtual void Unload() = 0;
[JScript]
public abstract function Unload();

Remarks

Notes to Inheritors: Meant to be overridden in a derived class, call this method to unload the document. The code stream should detach any events it may be checking for at that time. After this call, the document may undergo many changes, none of which should impact the underlying document code. If a document is being reloaded from disk, the designer host will typically call Unload, then Load.

See Also

CodeStream Class | CodeStream Members | System.ComponentModel.Design Namespace | Load


CollectionEditor Class

Object
UITypeEditor
CollectionEditor

[Visual Basic]
Public Class CollectionEditor
   Inherits UITypeEditor
[C#]
public class CollectionEditor : UITypeEditor
[C++]
public __gc class CollectionEditor : public UITypeEditor
[JScript]
public class CollectionEditor extends UITypeEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

CollectionEditor Members | System.ComponentModel.Design Namespace


CollectionEditor Members

Public:

Constructor

CollectionEditor Constructor Creates a new collection editor.

Methods

EditValue | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEditStyle (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

CollectionItemType | The data type of each item in the collection.
CollectionType | Retrieves the data type of the collection we are editing.
Context | The type descriptor context that is currently in use, or null if no context is available.
NewItemTypes | The available item types that can be created for this collection. This defaults to a single type of CollectionItemType. If more than one type is returned the collection editor will provide a way to choose which item to create.

Methods

CanRemoveInstance | This will be called when the user tries to remove an instance from the collection that is an original member of the collection. It will not be called when removing instances that were added in this editing session since they are not yet part of the collection.
CreateCollectionForm | Creates a new form to show the current collection. You may inherit from CollectionForm to provide your own form.
CreateCollectionItemType | Retrieves the data type this collection contains. The default implementation looks inside of the collection for the Item property and returns the returning datatype of the item. Do not call this method directly. Instead, use the CollectionItemType property. Use this method to override the default implementation.
CreateInstance | Creates a new instance of the given collection item type.
CreateNewItemTypes | Retrieves the data types this collection editor can create. The default implementation looks inside of the collection for the Item property and returns the returning datatype of the item. Do not call this method directly. Instead, use the NewItemTypes property. Use this method to override the default implementation.
DestroyInstance | Destroys the given instance of the object.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetItems | Converts the given collection into an array of objects. This is used by the editing dialog to manipulate the individual collection.
GetServiceObject | Retrieves the requested service, if it is available.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetItems | Sets the given collection to have the given array of items. If setting requires that a new object be created, the new object should be returned. Otherwise, editValue should be returned.

See Also

CollectionEditor Class | System.ComponentModel.Design Namespace


CollectionEditor Constructor

Creates a new collection editor.

[Visual Basic]
Public Sub New( _
   ByVal type As Type _
)
[C#]
public CollectionEditor(
   Type type
);
[C++]
public: CollectionEditor(
   Type* type
);
[JScript]
public function CollectionEditor(
   type : Type
);

Parameters

type
The type of collection this object is to edit.

See Also

CollectionEditor Class | CollectionEditor Members | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CollectionEditor Properties

The properties of the CollectionEditor class are listed below. For a complete list of CollectionEditor class members, see the CollectionEditor Members topic.

Protected:

CollectionItemType | The data type of each item in the collection.
CollectionType | Retrieves the data type of the collection we are editing.
Context | The type descriptor context that is currently in use, or null if no context is available.
NewItemTypes | The available item types that can be created for this collection. This defaults to a single type of CollectionItemType. If more than one type is returned the collection editor will provide a way to choose which item to create.

See Also

CollectionEditor Class | System.ComponentModel.Design Namespace


CollectionEditor.CollectionItemType

The data type of each item in the collection.

[Visual Basic]
Protected ReadOnly Property CollectionItemType As Type
[C#]
protected Type CollectionItemType {get;}
[C++]
protected: __property Type* get_CollectionItemType();
[JScript]
protected function get CollectionItemType() : Type;

See Also

CollectionEditor Class | CollectionEditor Members | System.ComponentModel.Design Namespace


CollectionEditor.CollectionType

Retrieves the data type of the collection we are editing.

[Visual Basic]
Protected ReadOnly Property CollectionType As Type
[C#]
protected Type CollectionType {get;}
[C++]
protected: __property Type* get_CollectionType();
[JScript]
protected function get CollectionType() : Type;

See Also

CollectionEditor Class | CollectionEditor Members | System.ComponentModel.Design Namespace


CollectionEditor.Context

The type descriptor context that is currently in use, or null if no context is available.

[Visual Basic]
Protected ReadOnly Property Context As ITypeDescriptorContext
[C#]
protected ITypeDescriptorContext Context {get;}
[C++]
protected: __property ITypeDescriptorContext* get_Context();
[JScript]
protected function get Context() : ITypeDescriptorContext;

See Also

CollectionEditor Class | CollectionEditor Members | System.ComponentModel.Design Namespace


CollectionEditor.NewItemTypes

The available item types that can be created for this collection. This defaults to a single type of CollectionItemType. If more than one type is returned the collection editor will provide a way to choose which item to create.

[Visual Basic]
Protected ReadOnly Property NewItemTypes As Type ()
[C#]
protected Type[] NewItemTypes {get;}
[C++]
protected: __property Type* get_NewItemTypes();
[JScript]
protected function get NewItemTypes() : Type[];

See Also

CollectionEditor Class | CollectionEditor Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CollectionEditor Methods

The methods of the CollectionEditor class are listed below. For a complete list of CollectionEditor class members, see the CollectionEditor Members topic.

Public:

EditValue | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEditStyle (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

CanRemoveInstance | This will be called when the user tries to remove an instance from the collection that is an original member of the collection. It will not be called when removing instances that were added in this editing session since they are not yet part of the collection.
CreateCollectionForm | Creates a new form to show the current collection. You may inherit from CollectionForm to provide your own form.
CreateCollectionItemType | Retrieves the data type this collection contains. The default implementation looks inside of the collection for the Item property and returns the returning datatype of the item. Do not call this method directly. Instead, use the CollectionItemType property. Use this method to override the default implementation.
CreateInstance | Creates a new instance of the given collection item type.
CreateNewItemTypes | Retrieves the data types this collection editor can create. The default implementation looks inside of the collection for the Item property and returns the returning datatype of the item. Do not call this method directly. Instead, use the NewItemTypes property. Use this method to override the default implementation.
DestroyInstance | Destroys the given instance of the object.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetItems | Converts the given collection into an array of objects. This is used by the editing dialog to manipulate the individual collection.
GetServiceObject | Retrieves the requested service, if it is available.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetItems | Sets the given collection to have the given array of items. If setting requires that a new object be created, the new object should be returned. Otherwise, editValue should be returned.

See Also

CollectionEditor Class | System.ComponentModel.Design Namespace


CollectionEditor.CanRemoveInstance

This will be called when the user tries to remove an instance from the collection that is an original member of the collection. It will not be called when removing instances that were added in this editing session since they are not yet part of the collection.

[Visual Basic]
Overridable Protected Function CanRemoveInstance( _
   ByVal value As Object _
) As Boolean
[C#]
protected virtual bool CanRemoveInstance(
   object value
);
[C++]
protected: virtual bool CanRemoveInstance(
   Object* value
);
[JScript]
protected function CanRemoveInstance(
   value : Object
) : Boolean;

Parameters

value
The value to remove.

Return Value

This should return true if it is ok to remove this value from the collection, or false otherwise. The default implementation always returns true.

See Also

CollectionEditor Class | CollectionEditor Members | System.ComponentModel.Design Namespace


CollectionEditor.CreateCollectionForm

Creates a new form to show the current collection. You may inherit from CollectionForm to provide your own form.

[Visual Basic]
Overridable Protected Function CreateCollectionForm() As _
   CollectionForm
[C#]
protected virtual CollectionForm CreateCollectionForm();
[C++]
protected: virtual CollectionForm* CreateCollectionForm();
[JScript]
protected function CreateCollectionForm() : CollectionForm;

Return Value

An instance of CollectionForm to provide as the user interface for editing the collection.

See Also

CollectionEditor Class | CollectionEditor Members | System.ComponentModel.Design Namespace


CollectionEditor.CreateCollectionItemType

Retrieves the data type this collection contains. The default implementation looks inside of the collection for the Item property and returns the returning datatype of the item. Do not call this method directly. Instead, use the CollectionItemType property. Use this method to override the default implementation.

[Visual Basic]
Overridable Protected Function CreateCollectionItemType() As Type
[C#]
protected virtual Type CreateCollectionItemType();
[C++]
protected: virtual Type* CreateCollectionItemType();
[JScript]
protected function CreateCollectionItemType() : Type;

Return Value

The data type the collection is designed to contain.

See Also

CollectionEditor Class | CollectionEditor Members | System.ComponentModel.Design Namespace


CollectionEditor.CreateInstance

Creates a new instance of the given collection item type.

[Visual Basic]
Overridable Protected Function CreateInstance( _
   ByVal itemType As Type _
) As Object
[C#]
protected virtual object CreateInstance(
   Type itemType
);
[C++]
protected: virtual Object* CreateInstance(
   Type* itemType
);
[JScript]
protected function CreateInstance(
   itemType : Type
) : Object;

Parameters

itemType
The type of item to create.

Return Value

A new instance of the given object. This may throw an exception if a new instance could not be created. If the user chose to cancel the creation of this instance, this method may return null.

See Also

CollectionEditor Class | CollectionEditor Members | System.ComponentModel.Design Namespace


CollectionEditor.CreateNewItemTypes

Retrieves the data types this collection editor can create. The default implementation looks inside of the collection for the Item property and returns the returning datatype of the item. Do not call this method directly. Instead, use the NewItemTypes property. Use this method to override the default implementation.

[Visual Basic]
Overridable Protected Function CreateNewItemTypes() As Type ()
[C#]
protected virtual Type[] CreateNewItemTypes();
[C++]
protected: virtual Type* CreateNewItemTypes() [];
[JScript]
protected function CreateNewItemTypes() : Type[];

Return Value

An array of types this collection can contain.

See Also

CollectionEditor Class | CollectionEditor Members | System.ComponentModel.Design Namespace


CollectionEditor.DestroyInstance

Destroys the given instance of the object.

[Visual Basic]
Overridable Protected Sub DestroyInstance( _
   ByVal instance As Object _
)
[C#]
protected virtual void DestroyInstance(
   object instance
);
[C++]
protected: virtual void DestroyInstance(
   Object* instance
);
[JScript]
protected function DestroyInstance(
   instance : Object
);

Parameters

instance
The object to destroy.

See Also

CollectionEditor Class | CollectionEditor Members | System.ComponentModel.Design Namespace


CollectionEditor.EditValue

Edits the given object value using the editor style provided by GetEditorStyle. A service provider is provided so that any required editing services can be obtained.

[Visual Basic]
Overrides Public Function EditValue( _
   ByVal context As ITypeDescriptorContext, _
   ByVal provider As IServiceObjectProvider, _
   ByVal value As Object _
) As Object
[C#]
public override object EditValue(
   ITypeDescriptorContext context,
   IServiceObjectProvider provider,
   object value
);
[C++]
public: override Object* EditValue(
   ITypeDescriptorContext* context,
   IServiceObjectProvider* provider,
   Object* value
);
[JScript]
public override function EditValue(
   context : ITypeDescriptorContext,
   provider : IServiceObjectProvider,
   value : Object
) : Object;

Parameters

context
A type descriptor context that can be used to provide additional context information.
provider
A service provider object through which editing services may be obtained.
value
An instance of the value being edited.

Return Value

The new value of the object. If the value of the object hasn't changed, this should return the same object it was passed.

See Also

CollectionEditor Class | CollectionEditor Members | System.ComponentModel.Design Namespace


CollectionEditor.GetEditStyle

Retrieves the editing style of the Edit method. If the method is not supported, this will return None.

[Visual Basic]
Overrides Public Function GetEditStyle( _
   ByVal context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
[C#]
public override UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext context
);
[C++]
public: override UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetEditStyle(
   context : ITypeDescriptorContext
) : UITypeEditorEditStyle;

Parameters

context
A type descriptor context that can be used to provide additional context information.

Return Value

An enum value indicating the provided editing style.

See Also

CollectionEditor Class | CollectionEditor Members | System.ComponentModel.Design Namespace


CollectionEditor.GetItems

Converts the given collection into an array of objects. This is used by the editing dialog to manipulate the individual collection.

[Visual Basic]
Overridable Protected Function GetItems( _
   ByVal editValue As Object _
) As Object ()
[C#]
protected virtual object[] GetItems(
   object editValue
);
[C++]
protected: virtual Object* GetItems(
   Object* editValue
) [];
[JScript]
protected function GetItems(
   editValue : Object
) : Object[];

Parameters

editValue
[To be supplied.]

See Also

CollectionEditor Class | CollectionEditor Members | System.ComponentModel.Design Namespace


CollectionEditor.GetServiceObject

Retrieves the requested service, if it is available.

[Visual Basic]
Protected Function GetServiceObject( _
   ByVal serviceType As Type _
) As Object
[C#]
protected object GetServiceObject(
   Type serviceType
);
[C++]
protected: Object* GetServiceObject(
   Type* serviceType
);
[JScript]
protected function GetServiceObject(
   serviceType : Type
) : Object;

Parameters

serviceType
The type of service to retrieve.

Return Value

An instance of the service, or null if the service could not be found.

See Also

CollectionEditor Class | CollectionEditor Members | System.ComponentModel.Design Namespace


CollectionEditor.SetItems

Sets the given collection to have the given array of items. If setting requires that a new object be created, the new object should be returned. Otherwise, editValue should be returned.

[Visual Basic]
Overridable Protected Function SetItems( _
   ByVal editValue As Object, _
   ByVal value() As Object _
) As Object
[C#]
protected virtual object SetItems(
   object editValue,
   object[] value
);
[C++]
protected: virtual Object* SetItems(
   Object* editValue,
   Object* value[]
);
[JScript]
protected function SetItems(
   editValue : Object,
   value : Object[]
) : Object;

Parameters

editValue
[To be supplied.]
value
[To be supplied.]

See Also

CollectionEditor Class | CollectionEditor Members | System.ComponentModel.Design Namespace


CommandID Class

Represents a numeric Command ID and globally unique ID (GUID) menu identifier that together uniquely identify a command.

Object
CommandID

[Visual Basic]
Public Class CommandID
[C#]
public class CommandID
[C++]
public __gc class CommandID
[JScript]
public class CommandID

Remarks

The CommandID class can be used to uniquely identify a command. This allows multiple command issuers to implement the same command. Command IDs consist of a menu group GUID and a command ID integer.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

CommandID Members | System.ComponentModel.Design Namespace | IMenuCommandService | MenuCommand


CommandID Members

Public:

Constructor

CommandID Constructor Initializes a new instance of the CommandID class. Creates a new command ID.

Properties

Guid | Gets or sets the globally unique ID (GUID) of the menu group that the menu command this CommandID represents belongs to.
ID | Gets or sets the numeric command ID.

Methods

Equals | Overrides Object's Equals method.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Overrides Object's ToString method.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommandID Class | System.ComponentModel.Design Namespace


CommandID Constructor

Initializes a new instance of the CommandID class. Creates a new command ID.

[Visual Basic]
Public Sub New( _
   ByVal menuGroup As Guid, _
   ByVal commandID As Integer _
)
[C#]
public CommandID(
   Guid menuGroup,
   int commandID
);
[C++]
public: CommandID(
   Guid menuGroup,
   int commandID
);
[JScript]
public function CommandID(
   menuGroup : Guid,
   commandID : int
);

Parameters

menuGroup
The GUID of the group that this menu command belongs to.
commandID
The identifier of this menu command within the group.

See Also

CommandID Class | CommandID Members | System.ComponentModel.Design Namespace | IMenuCommandService | MenuCommand


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CommandID Properties

The properties of the CommandID class are listed below. For a complete list of CommandID class members, see the CommandID Members topic.

Public:

Guid | Gets or sets the globally unique ID (GUID) of the menu group that the menu command this CommandID represents belongs to.
ID | Gets or sets the numeric command ID.

See Also

CommandID Class | System.ComponentModel.Design Namespace


CommandID.Guid

Gets or sets the globally unique ID (GUID) of the menu group that the menu command this CommandID represents belongs to.

[Visual Basic]
Overridable Public ReadOnly Property Guid As Guid
[C#]
public Guid Guid {virtual get;}
[C++]
public: __property virtual Guid get_Guid();
[JScript]
public function get Guid() : Guid;

Property Value

The GUID of the command group.

See Also

CommandID Class | CommandID Members | System.ComponentModel.Design Namespace


CommandID.ID

Gets or sets the numeric command ID.

[Visual Basic]
Overridable Public ReadOnly Property ID As Integer
[C#]
public int ID {virtual get;}
[C++]
public: __property virtual int get_ID();
[JScript]
public function get ID() : int;

Property Value

The command ID number.

See Also

CommandID Class | CommandID Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CommandID Methods

The methods of the CommandID class are listed below. For a complete list of CommandID class members, see the CommandID Members topic.

Public:

Equals | Overrides Object's Equals method.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Overrides Object's ToString method.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommandID Class | System.ComponentModel.Design Namespace


CommandID.Equals

Overrides Object's Equals method.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The object to compare.

Return Value

true if the specified object is equivalent to this one, otherwise false.

See Also

CommandID Class | CommandID Members | System.ComponentModel.Design Namespace


CommandID.ToString

Overrides Object's ToString method.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

A string containing the Command ID information (GUID and ID).

See Also

CommandID Class | CommandID Members | System.ComponentModel.Design Namespace


ComponentChangedEventArgs Class

Provides data for the System.ComponentModel.Design.ComponentChangedEvent.ComponentChangedEvent event.

Object
EventArgs
ComponentChangedEventArgs

[Visual Basic]
NotInheritable Public Class ComponentChangedEventArgs
   Inherits EventArgs
[C#]
public sealed class ComponentChangedEventArgs : EventArgs
[C++]
public __gc __sealed class ComponentChangedEventArgs : public
   EventArgs
[JScript]
public class ComponentChangedEventArgs extends EventArgs

Remarks

The System.ComponentModel.Design.ComponentChangedEventArgs.ComponentChangedEvent notifies the component change service that a particular component in the document has been, or is to be changed.

The framework typically calls the System.ComponentModel.Design.ComponentChangedEventArgs.ComponentChangedEvent for you. In general, you don't need to explicitly call it. A component's customizer might call the System.ComponentModel.Design.ComponentChangedEventArgs.ComponentChangedEvent event of this class when it changes a property of the component; this ensures a property browser will display the updated property. A System.ComponentModel.Design.ComponentChangedEventArgs.ComponentChangedEvent will not be raised during form load and unload, because changes at this time are expected.

An error occurs if this class is specified as the base class of another class.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

ComponentChangedEventArgs Members | System.ComponentModel.Design Namespace | ComponentChangingEventHandler


ComponentChangedEventArgs Members

Public:

Constructor

ComponentChangedEventArgs Constructor Initializes a new instance of the ComponentChangedEventArgs class.

Properties

Component | Gets or sets the component that is the cause of this event.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
Member | Gets or sets the member that is about to change.
NewValue | Gets or sets the new value of the changed member.
OldValue | Gets or sets the old value of the changed member.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ComponentChangedEventArgs Class | System.ComponentModel.Design Namespace


ComponentChangedEventArgs Constructor

Initializes a new instance of the ComponentChangedEventArgs class.

[Visual Basic]
Public Sub New( _
   ByVal component As Object, _
   ByVal member As MemberDescriptor, _
   ByVal oldValue As Object, _
   ByVal newValue As Object _
)
[C#]
public ComponentChangedEventArgs(
   object component,
   MemberDescriptor member,
   object oldValue,
   object newValue
);
[C++]
public: ComponentChangedEventArgs(
   Object* component,
   MemberDescriptor* member,
   Object* oldValue,
   Object* newValue
);
[JScript]
public function ComponentChangedEventArgs(
   component : Object,
   member : MemberDescriptor,
   oldValue : Object,
   newValue : Object
);

Parameters

component
The component that is about to change.
member
A MemberDescriptor that represents the component that is about to change.
oldValue
The old value of the changed member.
newValue
The new value of the changed member.

Remarks

A component's customizer should call this constructor when it changes a property of the component; this will ensure that a property browser will display the updated property.

See Also

ComponentChangedEventArgs Class | ComponentChangedEventArgs Members | System.ComponentModel.Design Namespace | ComponentChangedEventHandler


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ComponentChangedEventArgs Properties

The properties of the ComponentChangedEventArgs class are listed below. For a complete list of ComponentChangedEventArgs class members, see the ComponentChangedEventArgs Members topic.

Public:

Component | Gets or sets the component that is the cause of this event.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
Member | Gets or sets the member that is about to change.
NewValue | Gets or sets the new value of the changed member.
OldValue | Gets or sets the old value of the changed member.

See Also

ComponentChangedEventArgs Class | System.ComponentModel.Design Namespace


ComponentChangedEventArgs.Component

Gets or sets the component that is the cause of this event.

[Visual Basic]
Public ReadOnly Property Component As Object
[C#]
public object Component {get;}
[C++]
public: __property Object* get_Component();
[JScript]
public function get Component() : Object;

Property Value

An System.ComponentModel.Design.IComponent that represents the associated component.

See Also

ComponentChangedEventArgs Class | ComponentChangedEventArgs Members | System.ComponentModel.Design Namespace


ComponentChangedEventArgs.Member

Gets or sets the member that is about to change.

[Visual Basic]
Public ReadOnly Property Member As MemberDescriptor
[C#]
public MemberDescriptor Member {get;}
[C++]
public: __property MemberDescriptor* get_Member();
[JScript]
public function get Member() : MemberDescriptor;

Property Value

A MemberDescriptor indicating the member that is about to change.

Remarks

This can be a null reference (in Visual Basic Nothing) if the member is unknown.

See Also

ComponentChangedEventArgs Class | ComponentChangedEventArgs Members | System.ComponentModel.Design Namespace


ComponentChangedEventArgs.NewValue

Gets or sets the new value of the changed member.

[Visual Basic]
Public ReadOnly Property NewValue As Object
[C#]
public object NewValue {get;}
[C++]
public: __property Object* get_NewValue();
[JScript]
public function get NewValue() : Object;

Property Value

The new value of the changed member.

Remarks

This property has meaning only if member is not a null reference (in Visual Basic Nothing).

See Also

ComponentChangedEventArgs Class | ComponentChangedEventArgs Members | System.ComponentModel.Design Namespace


ComponentChangedEventArgs.OldValue

Gets or sets the old value of the changed member.

[Visual Basic]
Public ReadOnly Property OldValue As Object
[C#]
public object OldValue {get;}
[C++]
public: __property Object* get_OldValue();
[JScript]
public function get OldValue() : Object;

Property Value

The old value of the changed member.

Remarks

This property has meaning only if the member is not a null reference (in Visual Basic Nothing).

See Also

ComponentChangedEventArgs Class | ComponentChangedEventArgs Members | System.ComponentModel.Design Namespace


ComponentChangedEventHandler Delegate

Represents the method that will handle a System.ComponentModel.Design.ComponentChangedEvent event.

[Visual Basic]
Public Delegate Sub ComponentChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As ComponentChangedEventArgs _
)
[C#]
public delegate void ComponentChangedEventHandler(
   object sender,
   ComponentChangedEventArgs e
);
[C++]
public __gc __delegate void ComponentChangedEventHandler(
   Object* sender,
   ComponentChangedEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the ComponentChangedEventHandler delegate declaration.

sender
The source of the event.
e
A System.ComponentModel.Design.ComponentChangedEvent.ComponentChangedEventArgs event that contains the event data.

Remarks

When you create a ComponentChangedEventHandler delegate, you identify the method that will handle the event. For an overview, see TBD.

To associate the event with your event-handling method, call the AddOn XXX method of the System.ComponentModel.Design.ComponentChangeService. The event-handling method is called whenever the event occurs, until you call the RemoveOn XXX method of the control.

Note Delegates are the underlying mechanism for events, but most of the time you won't use them directly. For details, see TBD.

A System.ComponentModel.Design.ComponentChangedEvent will not occur during form load and unload because changes are expected when this occurs.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

System.ComponentModel.Design Namespace | TBD | TBD


ComponentChangingEventArgs Class

Provides data for the System.ComponentModel.Design.ComponentChangingEvent event.

Object
EventArgs
ComponentChangingEventArgs

[Visual Basic]
NotInheritable Public Class ComponentChangingEventArgs
   Inherits EventArgs
[C#]
public sealed class ComponentChangingEventArgs : EventArgs
[C++]
public __gc __sealed class ComponentChangingEventArgs : public
   EventArgs
[JScript]
public class ComponentChangingEventArgs extends EventArgs

Remarks

A ComponentChangingEventArgs is raised before the component is actually changed and gives a designer the chance to abort the change. Generally, only the top-level designer cares about such change requests.

The System.ComponentModel.Design.ComponentChangingEventArgs.ComponentChangingEvent event notifies the component change service that a particular component in the document is about to be changed.

The framework typically calls this method for you. In general, you don't need to explicitly call it.

If a property cannot be changed, a method should throw an exception. This class is not intended to validate the values of a particular property. Instead, it is intended to be a global way to prevent a component from changing. For example, if a designer file is checked into source code control, this would typically throw an exception if the user refused to check out the file.

Notes to Inheritors: An error occurs if this class is specified as the base class of another class.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

ComponentChangingEventArgs Members | System.ComponentModel.Design Namespace | ComponentChangingEventHandler | System.ComponentModel.Design.ComponentChangedEvent


ComponentChangingEventArgs Members

Public:

Constructor

ComponentChangingEventArgs Constructor Initializes a new instance of the ComponentChangingEventArgs class.

Properties

Component | Gets or sets the component that is being changed or that is the parent container of the member being changed.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
Member | Gets or sets the member of the component that is about to be changed.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ComponentChangingEventArgs Class | System.ComponentModel.Design Namespace


ComponentChangingEventArgs Constructor

Initializes a new instance of the ComponentChangingEventArgs class.

[Visual Basic]
Public Sub New( _
   ByVal component As Object, _
   ByVal member As MemberDescriptor _
)
[C#]
public ComponentChangingEventArgs(
   object component,
   MemberDescriptor member
);
[C++]
public: ComponentChangingEventArgs(
   Object* component,
   MemberDescriptor* member
);
[JScript]
public function ComponentChangingEventArgs(
   component : Object,
   member : MemberDescriptor
);

Parameters

component
The component that is about to have a member changed.
member
A MemberDescriptor indicating the member of the component that is about to change.

Remarks

A ComponentChangingEventArgs event specifies the component and member that are about to be changed.

See Also

ComponentChangingEventArgs Class | ComponentChangingEventArgs Members | System.ComponentModel.Design Namespace | ComponentChangedEventHandler | MemberDescriptor


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ComponentChangingEventArgs Properties

The properties of the ComponentChangingEventArgs class are listed below. For a complete list of ComponentChangingEventArgs class members, see the ComponentChangingEventArgs Members topic.

Public:

Component | Gets or sets the component that is being changed or that is the parent container of the member being changed.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
Member | Gets or sets the member of the component that is about to be changed.

See Also

ComponentChangingEventArgs Class | System.ComponentModel.Design Namespace


ComponentChangingEventArgs.Component

Gets or sets the component that is being changed or that is the parent container of the member being changed.

[Visual Basic]
Public ReadOnly Property Component As Object
[C#]
public object Component {get;}
[C++]
public: __property Object* get_Component();
[JScript]
public function get Component() : Object;

Property Value

The component that is about to have a member changed.

See Also

ComponentChangingEventArgs Class | ComponentChangingEventArgs Members | System.ComponentModel.Design Namespace


ComponentChangingEventArgs.Member

Gets or sets the member of the component that is about to be changed.

[Visual Basic]
Public ReadOnly Property Member As MemberDescriptor
[C#]
public MemberDescriptor Member {get;}
[C++]
public: __property MemberDescriptor* get_Member();
[JScript]
public function get Member() : MemberDescriptor;

Property Value

A MemberDescriptor indicating the member to be changed, if known, or a null reference (in Visual Basic Nothing) otherwise.

Remarks

This returns a null reference (Nothing) if the member is unknown.

See Also

ComponentChangingEventArgs Class | ComponentChangingEventArgs Members | System.ComponentModel.Design Namespace | MemberDescriptor


ComponentChangingEventHandler Delegate

Represents the method that will handle a System.ComponentModel.Design.ComponentChangingEvent event.

[Visual Basic]
Public Delegate Sub ComponentChangingEventHandler( _
   ByVal sender As Object, _
   ByVal e As ComponentChangingEventArgs _
)
[C#]
public delegate void ComponentChangingEventHandler(
   object sender,
   ComponentChangingEventArgs e
);
[C++]
public __gc __delegate void ComponentChangingEventHandler(
   Object* sender,
   ComponentChangingEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the ComponentChangingEventHandler delegate declaration.

sender
The source of the event.
e
A System.ComponentModel.Design.ComponentChangingEvent.ComponentChangingEventArgs event that contains the event data.

Remarks

When you create a ComponentChangingEventHandler delegate, you identify the method that will handle the event. For an overview, see TBD.

To associate the event with your event-handling method, call the AddOn XXX method of the System.ComponentModel.Design.ComponentChangeService. The event-handling method is called whenever the event occurs, until you call the RemoveOn XXX method of the control.

Note Delegates are the underlying mechanism for events, but most of the time you won't use them directly. For details, see TBD.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

System.ComponentModel.Design Namespace | TBD | ComponentChangedEventHandler | TBD


ComponentDesigner Class

The default designer for all components. Almost everything that extends from Component will typically have one of these designers as their base designer. Designers do not have to inherit from this class, but it does provide some convenient features.

Object
ComponentDesigner

[Visual Basic]
Public Class ComponentDesigner
   Implements IDesigner, IDesignerFilter
[C#]
public class ComponentDesigner : IDesigner, IDesignerFilter
[C++]
public __gc class ComponentDesigner : public IDesigner,
   IDesignerFilter
[JScript]
public class ComponentDesigner implements IDesigner,
   IDesignerFilter

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

ComponentDesigner Members | System.ComponentModel.Design Namespace | IDesigner


ComponentDesigner Members

Public:

Constructor

ComponentDesigner Constructor [To be supplied.]

Properties

Component | Gets or sets the component this designer is designing.
Verbs | Gets the design-time verbs supported by the component associated with the designer. The verbs returned by this method are typically displayed in a right-click menu by the design-time environment. The return value may be null if the component has no design-time verbs. When a user selects one of the verbs, the performVerb() method is invoked with the the corresponding DesignerVerb object. NOTE: A design-time environment will typically provide a "Properties..." entry on a component's right-click menu. The getVerbs() method should therefore not include such an entry in the returned list of verbs.

Methods

Dispose | Disposes of the resources (other than memory) used by the ComponentDesigner.
DoDefaultAction | This creates a method signature in the source code file for the default event on the component and navigates the user's cursor to that location.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Initialize | Establishes the component for this designer. The designer host will set this when it is ready for the designer to be used.
OnSetComponentDefaults | Called when the designer is intialized. This allows the designer to provide some meaningful default values in the component. The default implementation of this sets the components's default property to it's name, if that property is a string.
PostFilterAttributes | Allows a designer to filter the set of member attributes the component it is designing will expose through the TypeDescriptor object. This method is called immediately after its corresponding "Pre" method. If you are overriding this method you should call the the base implementation after you perform your own filtering.
PostFilterEvents | Allows a designer to filter the set of events the component it is designing will expose through the TypeDescriptor object. This method is called immediately after its corresponding "Pre" method. If you are overriding this method you should call the the base implementation after you perform your own filtering.
PostFilterProperties | Allows a designer to filter the set of properties the component it is designing will expose through the TypeDescriptor object. This method is called immediately after its corresponding "Pre" method. If you are overriding this method you should call the the base implementation after you perform your own filtering.
PreFilterAttributes | Allows a designer to filter the set of member attributes the component it is designing will expose through the TypeDescriptor object. This method is called immediately before its corresponding "Post" method. If you are overriding this method you should call the base implementation before you perform your own filtering.
PreFilterEvents | Allows a designer to filter the set of events the component it is designing will expose through the TypeDescriptor object. This method is called immediately before its corresponding "Post" method. If you are overriding this method you should call the base implementation before you perform your own filtering.
PreFilterProperties | Allows a designer to filter the set of properties the component it is designing will expose through the TypeDescriptor object. This method is called immediately before its corresponding "Post" method. If you are overriding this method you should call the base implementation before you perform your own filtering.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

InheritanceAttribute | Gets or sets the inheritance attribute for this component.
Inherited | Gets whether or not this component is being inherited.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetDefaultValue | Retrieves the default value for the given property. If there is no default value attribute, this will assume that comp already contains the default value and request the value directly from it.
GetServiceObject | Provides a way for a designer to get services from the hosting environment. The default implementation of this requests the service from the compoent's site.
InvokeGetInheritanceAttribute | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnInitializeShadowProperties | Called when the designer is intialized. This allows the designer to initialize the values of any shadow properties it has.
RaiseComponentChanged | Notifies the IComponentChangeService that this component has been changed. You only need to call this when you are affecting component properties directly and not through the MemberDescriptor's accessors.
RaiseComponentChanging | Notifies the IComponentChangeService that this component is about to be changed. You only need to call this when you are affecting component properties directly and not through the MemberDescriptor's accessors.
SetPropertyWithUndo | Overloaded. [To be supplied.]

See Also

ComponentDesigner Class | System.ComponentModel.Design Namespace


ComponentDesigner Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ComponentDesigner();
[C++]
public: ComponentDesigner();
[JScript]
public function ComponentDesigner();

See Also

ComponentDesigner Class | ComponentDesigner Members | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ComponentDesigner Properties

The properties of the ComponentDesigner class are listed below. For a complete list of ComponentDesigner class members, see the ComponentDesigner Members topic.

Public:

Component | Gets or sets the component this designer is designing.
Verbs | Gets the design-time verbs supported by the component associated with the designer. The verbs returned by this method are typically displayed in a right-click menu by the design-time environment. The return value may be null if the component has no design-time verbs. When a user selects one of the verbs, the performVerb() method is invoked with the the corresponding DesignerVerb object. NOTE: A design-time environment will typically provide a "Properties..." entry on a component's right-click menu. The getVerbs() method should therefore not include such an entry in the returned list of verbs.

Protected:

InheritanceAttribute | Gets or sets the inheritance attribute for this component.
Inherited | Gets whether or not this component is being inherited.

See Also

ComponentDesigner Class | System.ComponentModel.Design Namespace


ComponentDesigner.Component

Gets or sets the component this designer is designing.

[Visual Basic]
Overridable Public ReadOnly Property Component As IComponent
[C#]
public IComponent Component {virtual get;}
[C++]
public: __property virtual IComponent* get_Component();
[JScript]
public function get Component() : IComponent;

Property Value

The component instance.

See Also

ComponentDesigner Class | ComponentDesigner Members | System.ComponentModel.Design Namespace | IDesigner


ComponentDesigner.InheritanceAttribute

Gets or sets the inheritance attribute for this component.

[Visual Basic]
Protected ReadOnly Property InheritanceAttribute As _
   InheritanceAttribute
[C#]
protected InheritanceAttribute InheritanceAttribute {get;}
[C++]
protected: __property InheritanceAttribute*
   get_InheritanceAttribute();
[JScript]
protected function get InheritanceAttribute() :
   InheritanceAttribute;

See Also

ComponentDesigner Class | ComponentDesigner Members | System.ComponentModel.Design Namespace


ComponentDesigner.Inherited

Gets whether or not this component is being inherited.

[Visual Basic]
Protected ReadOnly Property Inherited As Boolean
[C#]
protected bool Inherited {get;}
[C++]
protected: __property bool get_Inherited();
[JScript]
protected function get Inherited() : Boolean;

See Also

ComponentDesigner Class | ComponentDesigner Members | System.ComponentModel.Design Namespace


ComponentDesigner.Verbs

Gets the design-time verbs supported by the component associated with the designer. The verbs returned by this method are typically displayed in a right-click menu by the design-time environment. The return value may be null if the component has no design-time verbs. When a user selects one of the verbs, the performVerb() method is invoked with the the corresponding DesignerVerb object. NOTE: A design-time environment will typically provide a "Properties..." entry on a component's right-click menu. The getVerbs() method should therefore not include such an entry in the returned list of verbs.

[Visual Basic]
Overridable Public ReadOnly Property Verbs As DesignerVerb ()
[C#]
public DesignerVerb[] Verbs {virtual get;}
[C++]
public: __property virtual DesignerVerb* get_Verbs();
[JScript]
public function get Verbs() : DesignerVerb[];

Property Value

An array of design-time verb objects. This default implementation always returns null.

See Also

ComponentDesigner Class | ComponentDesigner Members | System.ComponentModel.Design Namespace | IDesigner


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ComponentDesigner Methods

The methods of the ComponentDesigner class are listed below. For a complete list of ComponentDesigner class members, see the ComponentDesigner Members topic.

Public:

Dispose | Disposes of the resources (other than memory) used by the ComponentDesigner.
DoDefaultAction | This creates a method signature in the source code file for the default event on the component and navigates the user's cursor to that location.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Initialize | Establishes the component for this designer. The designer host will set this when it is ready for the designer to be used.
OnSetComponentDefaults | Called when the designer is intialized. This allows the designer to provide some meaningful default values in the component. The default implementation of this sets the components's default property to it's name, if that property is a string.
PostFilterAttributes | Allows a designer to filter the set of member attributes the component it is designing will expose through the TypeDescriptor object. This method is called immediately after its corresponding "Pre" method. If you are overriding this method you should call the the base implementation after you perform your own filtering.
PostFilterEvents | Allows a designer to filter the set of events the component it is designing will expose through the TypeDescriptor object. This method is called immediately after its corresponding "Pre" method. If you are overriding this method you should call the the base implementation after you perform your own filtering.
PostFilterProperties | Allows a designer to filter the set of properties the component it is designing will expose through the TypeDescriptor object. This method is called immediately after its corresponding "Pre" method. If you are overriding this method you should call the the base implementation after you perform your own filtering.
PreFilterAttributes | Allows a designer to filter the set of member attributes the component it is designing will expose through the TypeDescriptor object. This method is called immediately before its corresponding "Post" method. If you are overriding this method you should call the base implementation before you perform your own filtering.
PreFilterEvents | Allows a designer to filter the set of events the component it is designing will expose through the TypeDescriptor object. This method is called immediately before its corresponding "Post" method. If you are overriding this method you should call the base implementation before you perform your own filtering.
PreFilterProperties | Allows a designer to filter the set of properties the component it is designing will expose through the TypeDescriptor object. This method is called immediately before its corresponding "Post" method. If you are overriding this method you should call the base implementation before you perform your own filtering.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetDefaultValue | Retrieves the default value for the given property. If there is no default value attribute, this will assume that comp already contains the default value and request the value directly from it.
GetServiceObject | Provides a way for a designer to get services from the hosting environment. The default implementation of this requests the service from the compoent's site.
InvokeGetInheritanceAttribute | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnInitializeShadowProperties | Called when the designer is intialized. This allows the designer to initialize the values of any shadow properties it has.
RaiseComponentChanged | Notifies the IComponentChangeService that this component has been changed. You only need to call this when you are affecting component properties directly and not through the MemberDescriptor's accessors.
RaiseComponentChanging | Notifies the IComponentChangeService that this component is about to be changed. You only need to call this when you are affecting component properties directly and not through the MemberDescriptor's accessors.
SetPropertyWithUndo | Overloaded. [To be supplied.]

See Also

ComponentDesigner Class | System.ComponentModel.Design Namespace


ComponentDesigner.Dispose

Disposes of the resources (other than memory) used by the ComponentDesigner.

[Visual Basic]
Overridable Public Sub Dispose()
[C#]
public virtual void Dispose();
[C++]
public: virtual void Dispose();
[JScript]
public function Dispose();

Remarks

Call Dispose when you are finished using the ComponentDesigner. The Dispose method leaves the ComponentDesigner in an unusuable state. After calling Dispose, you must release all references to the ComponentDesigner so the memory it was occupying can be reclaimed by garbage collection.

Note Always call Dispose before you release your last reference to the ComponentDesigner. Otherwise, the resources the ComponentDesigner is using will not be freed until garbage collection calls the ComponentDesigner object's destructor.

See Also

ComponentDesigner Class | ComponentDesigner Members | System.ComponentModel.Design Namespace | IDesigner


ComponentDesigner.DoDefaultAction

This creates a method signature in the source code file for the default event on the component and navigates the user's cursor to that location.

[Visual Basic]
Overridable Public Sub DoDefaultAction()
[C#]
public virtual void DoDefaultAction();
[C++]
public: virtual void DoDefaultAction();
[JScript]
public function DoDefaultAction();

See Also

ComponentDesigner Class | ComponentDesigner Members | System.ComponentModel.Design Namespace | IDesigner


ComponentDesigner.GetDefaultValue

Retrieves the default value for the given property. If there is no default value attribute, this will assume that comp already contains the default value and request the value directly from it.

[Visual Basic]
Protected Function GetDefaultValue( _
   ByVal comp As Object, _
   ByVal name As String _
) As Object
[C#]
protected object GetDefaultValue(
   object comp,
   string name
);
[C++]
protected: Object* GetDefaultValue(
   Object* comp,
   String* name
);
[JScript]
protected function GetDefaultValue(
   comp : Object,
   name : String
) : Object;

Parameters

comp
The component to retrieve the property on.
name
The name of the property.

Return Value

An object representing the default value for the property.

See Also

ComponentDesigner Class | ComponentDesigner Members | System.ComponentModel.Design Namespace


ComponentDesigner.GetServiceObject

Provides a way for a designer to get services from the hosting environment. The default implementation of this requests the service from the compoent's site.

[Visual Basic]
Overridable Protected Function GetServiceObject( _
   ByVal serviceType As Type _
) As Object
[C#]
protected virtual object GetServiceObject(
   Type serviceType
);
[C++]
protected: virtual Object* GetServiceObject(
   Type* serviceType
);
[JScript]
protected function GetServiceObject(
   serviceType : Type
) : Object;

Parameters

serviceType
The type of service to request.

Return Value

An object implementing the requested service, or null of the service could not be resolved.

See Also

ComponentDesigner Class | ComponentDesigner Members | System.ComponentModel.Design Namespace


ComponentDesigner.Initialize

Establishes the component for this designer. The designer host will set this when it is ready for the designer to be used.

[Visual Basic]
Overridable Public Sub Initialize( _
   ByVal component As IComponent _
)
[C#]
public virtual void Initialize(
   IComponent component
);
[C++]
public: virtual void Initialize(
   IComponent* component
);
[JScript]
public function Initialize(
   component : IComponent
);

Parameters

component
The component this class is designing.

See Also

ComponentDesigner Class | ComponentDesigner Members | System.ComponentModel.Design Namespace | IDesigner


ComponentDesigner.InvokeGetInheritanceAttribute

[To be supplied.]

[Visual Basic]
Protected Function InvokeGetInheritanceAttribute( _
   ByVal toInvoke As ComponentDesigner _
) As InheritanceAttribute
[C#]
protected InheritanceAttribute InvokeGetInheritanceAttribute(
   ComponentDesigner toInvoke
);
[C++]
protected: InheritanceAttribute* InvokeGetInheritanceAttribute(
   ComponentDesigner* toInvoke
);
[JScript]
protected function InvokeGetInheritanceAttribute(
   toInvoke : ComponentDesigner
) : InheritanceAttribute;

Parameters

toInvoke
[To be supplied.]

See Also

ComponentDesigner Class | ComponentDesigner Members | System.ComponentModel.Design Namespace


ComponentDesigner.OnInitializeShadowProperties

Called when the designer is intialized. This allows the designer to initialize the values of any shadow properties it has.

[Visual Basic]
Overridable Protected Sub OnInitializeShadowProperties()
[C#]
protected virtual void OnInitializeShadowProperties();
[C++]
protected: virtual void OnInitializeShadowProperties();
[JScript]
protected function OnInitializeShadowProperties();

See Also

ComponentDesigner Class | ComponentDesigner Members | System.ComponentModel.Design Namespace


ComponentDesigner.OnSetComponentDefaults

Called when the designer is intialized. This allows the designer to provide some meaningful default values in the component. The default implementation of this sets the components's default property to it's name, if that property is a string.

[Visual Basic]
Overridable Public Sub OnSetComponentDefaults()
[C#]
public virtual void OnSetComponentDefaults();
[C++]
public: virtual void OnSetComponentDefaults();
[JScript]
public function OnSetComponentDefaults();

See Also

ComponentDesigner Class | ComponentDesigner Members | System.ComponentModel.Design Namespace


ComponentDesigner.PostFilterAttributes

Allows a designer to filter the set of member attributes the component it is designing will expose through the TypeDescriptor object. This method is called immediately after its corresponding "Pre" method. If you are overriding this method you should call the the base implementation after you perform your own filtering.

[Visual Basic]
Overridable Public Sub PostFilterAttributes( _
   ByVal attributes As IDictionary _
)
[C#]
public virtual void PostFilterAttributes(
   IDictionary attributes
);
[C++]
public: virtual void PostFilterAttributes(
   IDictionary* attributes
);
[JScript]
public function PostFilterAttributes(
   attributes : IDictionary
);

Parameters

attributes
The member attributes for the class of the component.

Return Value

The augmented set of attributes. If the method does not modify any attributes, it may just return a reference to its input parameter. If you do make a change to the attributes, you must create a new array.

See Also

ComponentDesigner Class | ComponentDesigner Members | System.ComponentModel.Design Namespace | IDesignerFilter


ComponentDesigner.PostFilterEvents

Allows a designer to filter the set of events the component it is designing will expose through the TypeDescriptor object. This method is called immediately after its corresponding "Pre" method. If you are overriding this method you should call the the base implementation after you perform your own filtering.

[Visual Basic]
Overridable Public Sub PostFilterEvents( _
   ByVal events As IDictionary _
)
[C#]
public virtual void PostFilterEvents(
   IDictionary events
);
[C++]
public: virtual void PostFilterEvents(
   IDictionary* events
);
[JScript]
public function PostFilterEvents(
   events : IDictionary
);

Parameters

events
The events for the class of the component.

Return Value

The augmented set of events. If the method does not modify any events, it may just return a reference to its input parameter. If you do make a change to the events, you must create a new array.

See Also

ComponentDesigner Class | ComponentDesigner Members | System.ComponentModel.Design Namespace | IDesignerFilter


ComponentDesigner.PostFilterProperties

Allows a designer to filter the set of properties the component it is designing will expose through the TypeDescriptor object. This method is called immediately after its corresponding "Pre" method. If you are overriding this method you should call the the base implementation after you perform your own filtering.

[Visual Basic]
Overridable Public Sub PostFilterProperties( _
   ByVal properties As IDictionary _
)
[C#]
public virtual void PostFilterProperties(
   IDictionary properties
);
[C++]
public: virtual void PostFilterProperties(
   IDictionary* properties
);
[JScript]
public function PostFilterProperties(
   properties : IDictionary
);

Parameters

properties
The properties for the class of the component.

Return Value

The augmented set of properties. If the method does not modify any properties, it may just return a reference to its input parameter. If you do make a change to the properties, you must create a new array.

See Also

ComponentDesigner Class | ComponentDesigner Members | System.ComponentModel.Design Namespace | IDesignerFilter


ComponentDesigner.PreFilterAttributes

Allows a designer to filter the set of member attributes the component it is designing will expose through the TypeDescriptor object. This method is called immediately before its corresponding "Post" method. If you are overriding this method you should call the base implementation before you perform your own filtering.

[Visual Basic]
Overridable Public Sub PreFilterAttributes( _
   ByVal attributes As IDictionary _
)
[C#]
public virtual void PreFilterAttributes(
   IDictionary attributes
);
[C++]
public: virtual void PreFilterAttributes(
   IDictionary* attributes
);
[JScript]
public function PreFilterAttributes(
   attributes : IDictionary
);

Parameters

attributes
The member attributes for the class of the component.

Return Value

The augmented set of attributes. If the method does not modify any attributes, it may just return a reference to its input parameter. If you do make a change to the attributes, you must create a new array.

See Also

ComponentDesigner Class | ComponentDesigner Members | System.ComponentModel.Design Namespace | IDesignerFilter


ComponentDesigner.PreFilterEvents

Allows a designer to filter the set of events the component it is designing will expose through the TypeDescriptor object. This method is called immediately before its corresponding "Post" method. If you are overriding this method you should call the base implementation before you perform your own filtering.

[Visual Basic]
Overridable Public Sub PreFilterEvents( _
   ByVal events As IDictionary _
)
[C#]
public virtual void PreFilterEvents(
   IDictionary events
);
[C++]
public: virtual void PreFilterEvents(
   IDictionary* events
);
[JScript]
public function PreFilterEvents(
   events : IDictionary
);

Parameters

events
The events for the class of the component.

Return Value

The augmented set of events. If the method does not modify any events, it may just return a reference to its input parameter. If you do make a change to the events, you must create a new array.

See Also

ComponentDesigner Class | ComponentDesigner Members | System.ComponentModel.Design Namespace | IDesignerFilter


ComponentDesigner.PreFilterProperties

Allows a designer to filter the set of properties the component it is designing will expose through the TypeDescriptor object. This method is called immediately before its corresponding "Post" method. If you are overriding this method you should call the base implementation before you perform your own filtering.

[Visual Basic]
Overridable Public Sub PreFilterProperties( _
   ByVal properties As IDictionary _
)
[C#]
public virtual void PreFilterProperties(
   IDictionary properties
);
[C++]
public: virtual void PreFilterProperties(
   IDictionary* properties
);
[JScript]
public function PreFilterProperties(
   properties : IDictionary
);

Parameters

properties
The properties for the class of the component.

Return Value

The augmented set of properties. If the method does not modify any properties, it may just return a reference to its input parameter. If you do make a change to the properties, you must create a new array.

See Also

ComponentDesigner Class | ComponentDesigner Members | System.ComponentModel.Design Namespace | IDesignerFilter


ComponentDesigner.RaiseComponentChanged

Notifies the IComponentChangeService that this component has been changed. You only need to call this when you are affecting component properties directly and not through the MemberDescriptor's accessors.

[Visual Basic]
Protected Sub RaiseComponentChanged( _
   ByVal member As MemberDescriptor, _
   ByVal oldValue As Object, _
   ByVal newValue As Object _
)
[C#]
protected void RaiseComponentChanged(
   MemberDescriptor member,
   object oldValue,
   object newValue
);
[C++]
protected: void RaiseComponentChanged(
   MemberDescriptor* member,
   Object* oldValue,
   Object* newValue
);
[JScript]
protected function RaiseComponentChanged(
   member : MemberDescriptor,
   oldValue : Object,
   newValue : Object
);

Parameters

member
[To be supplied.]
oldValue
[To be supplied.]
newValue
[To be supplied.]

See Also

ComponentDesigner Class | ComponentDesigner Members | System.ComponentModel.Design Namespace


ComponentDesigner.RaiseComponentChanging

Notifies the IComponentChangeService that this component is about to be changed. You only need to call this when you are affecting component properties directly and not through the MemberDescriptor's accessors.

[Visual Basic]
Protected Sub RaiseComponentChanging( _
   ByVal member As MemberDescriptor _
)
[C#]
protected void RaiseComponentChanging(
   MemberDescriptor member
);
[C++]
protected: void RaiseComponentChanging(
   MemberDescriptor* member
);
[JScript]
protected function RaiseComponentChanging(
   member : MemberDescriptor
);

Parameters

member
[To be supplied.]

See Also

ComponentDesigner Class | ComponentDesigner Members | System.ComponentModel.Design Namespace


ComponentDesigner.SetPropertyWithUndo

[To be supplied.]

Overload List

Sets the given property to the given value by using the undo service, so the property set can be undone by the user.

[Visual Basic] Overloads Overridable Protected Sub SetPropertyWithUndo(IComponent, String, Object)
[C#] protected virtual void SetPropertyWithUndo(IComponent, String, Object);
[C++] protected: virtual void SetPropertyWithUndo(IComponent*, String, Object);
[JScript] protected function SetPropertyWithUndo(IComponent, String, Object);

Sets the given property to the given value by using the undo service, so the property set can be undone by the user.

[Visual Basic] Overloads Overridable Protected Sub SetPropertyWithUndo(IComponent, PropertyDescriptor, Object)
[C#] protected virtual void SetPropertyWithUndo(IComponent, PropertyDescriptor, Object);
[C++] protected: virtual void SetPropertyWithUndo(IComponent*, PropertyDescriptor, Object);
[JScript] protected function SetPropertyWithUndo(IComponent, PropertyDescriptor, Object);

See Also

ComponentDesigner Class | ComponentDesigner Members | System.ComponentModel.Design Namespace


ComponentDesigner.SetPropertyWithUndo (IComponent, String, Object)

Sets the given property to the given value by using the undo service, so the property set can be undone by the user.

[Visual Basic]
Overloads Overridable Protected Sub SetPropertyWithUndo( _
   ByVal comp As IComponent, _
   ByVal propertyName As String, _
   ByVal newValue As Object _
)
[C#]
protected virtual void SetPropertyWithUndo(
   IComponent comp,
   string propertyName,
   object newValue
);
[C++]
protected: virtual void SetPropertyWithUndo(
   IComponent* comp,
   String* propertyName,
   Object* newValue
);
[JScript]
protected function SetPropertyWithUndo(
   comp : IComponent,
   propertyName : String,
   newValue : Object
);

Parameters

comp
The component to set the property on.
propertyName
The name of the property.
newValue
The value to set the property to.

See Also

ComponentDesigner Class | ComponentDesigner Members | System.ComponentModel.Design Namespace | ComponentDesigner.SetPropertyWithUndo Overload List


ComponentDesigner.SetPropertyWithUndo (IComponent, PropertyDescriptor, Object)

Sets the given property to the given value by using the undo service, so the property set can be undone by the user.

[Visual Basic]
Overloads Overridable Protected Sub SetPropertyWithUndo( _
   ByVal comp As IComponent, _
   ByVal prop As PropertyDescriptor, _
   ByVal newValue As Object _
)
[C#]
protected virtual void SetPropertyWithUndo(
   IComponent comp,
   PropertyDescriptor prop,
   object newValue
);
[C++]
protected: virtual void SetPropertyWithUndo(
   IComponent* comp,
   PropertyDescriptor* prop,
   Object* newValue
);
[JScript]
protected function SetPropertyWithUndo(
   comp : IComponent,
   prop : PropertyDescriptor,
   newValue : Object
);

Parameters

comp
The component to set the property on.
prop
The property to set.
newValue
The value to set the property to.

See Also

ComponentDesigner Class | ComponentDesigner Members | System.ComponentModel.Design Namespace | ComponentDesigner.SetPropertyWithUndo Overload List


ComponentEventArgs Class

Provides data for the System.ComponentModel.Design.ComponentEvent event raised for component-level events.

Object
EventArgs
ComponentEventArgs

[Visual Basic]
Public Class ComponentEventArgs
   Inherits EventArgs
[C#]
public class ComponentEventArgs : EventArgs
[C++]
public __gc class ComponentEventArgs : public EventArgs
[JScript]
public class ComponentEventArgs extends EventArgs

Remarks

This class is the root event arguments class for all component-level events.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

ComponentEventArgs Members | System.ComponentModel.Design Namespace | ComponentEventHandler | System.ComponentModel.Design.ComponentChangedEvent | System.ComponentModel.Design.ComponentChangingEvent | System.ComponentModel.Design.ComponentRenameEvent | IComponentChangeService


ComponentEventArgs Members

Public:

Constructor

ComponentEventArgs Constructor Initializes a new instance of the ComponentEventArgs class.

Properties

Component | Gets or sets the component associated with the event.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ComponentEventArgs Class | System.ComponentModel.Design Namespace


ComponentEventArgs Constructor

Initializes a new instance of the ComponentEventArgs class.

[Visual Basic]
Public Sub New( _
   ByVal component As IComponent _
)
[C#]
public ComponentEventArgs(
   IComponent component
);
[C++]
public: ComponentEventArgs(
   IComponent* component
);
[JScript]
public function ComponentEventArgs(
   component : IComponent
);

Parameters

component
The component that is the source of the event.

See Also

ComponentEventArgs Class | ComponentEventArgs Members | System.ComponentModel.Design Namespace | ComponentEventHandler


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ComponentEventArgs Properties

The properties of the ComponentEventArgs class are listed below. For a complete list of ComponentEventArgs class members, see the ComponentEventArgs Members topic.

Public:

Component | Gets or sets the component associated with the event.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.

See Also

ComponentEventArgs Class | System.ComponentModel.Design Namespace


ComponentEventArgs.Component

Gets or sets the component associated with the event.

[Visual Basic]
Overridable Public ReadOnly Property Component As IComponent
[C#]
public IComponent Component {virtual get;}
[C++]
public: __property virtual IComponent* get_Component();
[JScript]
public function get Component() : IComponent;

Property Value

The component associated with the event.

See Also

ComponentEventArgs Class | ComponentEventArgs Members | System.ComponentModel.Design Namespace | IComponent


ComponentEventHandler Delegate

Represents the method that will handle the System.ComponentModel.Design.ComponentEvent event raised for component-level events.

[Visual Basic]
Public Delegate Sub ComponentEventHandler( _
   ByVal sender As Object, _
   ByVal e As ComponentEventArgs _
)
[C#]
public delegate void ComponentEventHandler(
   object sender,
   ComponentEventArgs e
);
[C++]
public __gc __delegate void ComponentEventHandler(
   Object* sender,
   ComponentEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the ComponentEventHandler delegate declaration.

sender
The source of the event.
e
A ComponentEventArgs that contains the event data.

Remarks

When you create a ComponentEventHandler delegate, you identify the method that will handle the event. For an overview, see TBD.

To associate the event with your event-handling method, call the AddOn XXX method of the System.ComponentModel.Design.ComponentManager. The event-handling method is called whenever the event occurs, until you call the RemoveOn XXX method of the control.

Note Delegates are the underlying mechanism for events, but most of the time you won't use them directly. For details, see TBD.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

System.ComponentModel.Design Namespace | ComponentEventArgs


ComponentModelPersister Class

Component model persister. This object can convert a component object graph to and from source code. It also provides code navigation services to the designer.

Object
CodePersister
ComponentModelPersister

[Visual Basic]
Public Class ComponentModelPersister
   Inherits CodePersister
   Implements ICodeNavigatorService
[C#]
public class ComponentModelPersister : CodePersister,
   ICodeNavigatorService
[C++]
public __gc class ComponentModelPersister : public CodePersister,
   ICodeNavigatorService
[JScript]
public class ComponentModelPersister extends CodePersister,
   ICodeNavigatorService

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister Members

Public:

Constructor

ComponentModelPersister Constructor [To be supplied.]

Properties

CanReload (inherited from CodePersister) This can be called to check if the persister can be reloaded. This will return true by default, thereby forcing a reload of the designer.

Methods

Dispose | Disposes of the resources (other than memory) used by the ComponentModelPersister.
DoesHandlerExist | Gets whether or not a handler for the specified event descriptor exists in the code.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCompatibleMethods | Gets the names of methods that have signatures compatible with the specified delegate class.
GetComponentCode | Generates the source code for the specified subcomponents.
GetComponentsFromCode | [To be supplied.]
GetDoesFieldExist | Determines if a field of the specified name exists in the code.
GetDoesMethodExist | Determines if a method of the specified name exists in the code.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNameFromReference (inherited from CodePersister) | Returns the name of the given reference. This will look up in either the referenceService or the component's site.
GetReferenceFromName | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
Init | Initializes this persister with the specified host and sourceFile.
Load | Called when the source file should be reparsed. This should only populate the designer host the first time it is called. Subclasses must provide an implementation.
NavigateToEvent | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

BaseComponent | The base component.
DocumentCodeClass | The class that is currently in the designer for editing.
FirstLoadException (inherited from CodePersister) | First load exception that occurs. This allows the parsing to continue on and still report the first failure.
Host (inherited from CodePersister) | IDesignerHost this persister should communicate with.
IgnoreCase (inherited from CodePersister) | [To be supplied.]
SourceFile | The source file to persist to.
ValueProviderSorter (inherited from CodePersister) | [To be supplied.]

Methods

AlwaysPersist (inherited from CodePersister) | If any value provider indicates that a value is "UserSelected" then we must force the persistence of the value.
AppendInitMethodStatements | Provides a way for subclasses to append methods to the initMethod function. The base.AppendInitMethodStatements method should be called to do this.
BeginDepersisting (inherited from CodePersister) | Notifies value providers that depersisting has begun.
BeginPersisting (inherited from CodePersister) | Notifies value providers that persisting has begun.
CreateComponentInstance (inherited from CodePersister) | Create the component specified and initialize its Modifiers property.
CreateDeclaration | [To be supplied.]
CreateExpressionFromPropertyValue (inherited from CodePersister) | Creates an expression value object from a PropertyValue. This will perform a deep scan on the PropertyValue and convert any nested object creates, array creates, name references, or constants. For more information on values and expressions see the ICodeSourceFile documentation.
CreateExpressionFromValue (inherited from CodePersister) | Creates an expression from a component/propertyName combination. This should only be used for property sets.
CreateValueFromExpression (inherited from CodePersister) | Creates a value from an expression object returned form the CodeSense APIs. This will take the various expressions and execute them, so to say. For example, if you pass in a ICodeObjectCreateExpression for value and it refers to the Point class, then a Point object will be returned. For more information on values and expression see the ICodeSourceFile documentation.
DeclareComponent (inherited from CodePersister) | This is used during code parsing to declare a given data member. We declare the member, and then we create an instance of this data member. This will throw an exception if the data member has already been declared.
EndDepersisting (inherited from CodePersister) | Notifies value providers that depersisting has completed.
EndPersisting (inherited from CodePersister) | Notifies value providers that persisting has completed.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
FindInitMethod | Finds the initialization method for this class.
Generate | Generates the source code for the document.
GenerateComponentParenting | Generates any parenting statemetns for the specified control.
GenerateEvent | Generates a single event hookup method for the initialization method.
GenerateEvents | Generates the code for the bound events of the control. Subclasses can override if their persistence mechanism is different (e.g. Web Forms)
GenerateExtenderSet | Generates a single property set statement for an extender property.
GenerateHierarchyForObject | [To be supplied.]
GenerateInitMethod | Generates the initialization method for persistance.
GenerateMemberInstanceCreation | Generates a single member create statement. This is used to construct objects inside of InitForm, instead of in the data member declaration.
GeneratePropertySet | Overloaded. [To be supplied.]
GenerateResourcesDecl | Generates the resource creation statement.
GenerateUpdateDataMembers | Updates the modifiers on data members if they have changed.
GetComponentName | Gets the name of the specified component.
GetServiceObject | Searches for the requested service.
GetValueProviderDeclarations (inherited from CodePersister) | Returns the array of value provider local variable declarations.
IsValueProviderDeclaration (inherited from CodePersister) | Determines if the specified statement is a the local declaration for a value provider.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseComponentDeclarations | Walks through the list of data members, finds all that implement IComponent and adds them to the Host.
ParseEventAdd | Parses a single event add statement.
ParseExtenderSet | Parses a single extender property set statement.
ParseInitMethod | Parses all the statements in the init method.
ParseInitMethodMethod | Parses a single method invoke inside of the init method. Subclasses should call base.ParseInitMethodMethod(...). You can choose to call super before or after custom parsing, but you should only call it if you want the default parsing to occur.
ParseMethodInvoke | Parses a single no-arg method invoke of any name
ParsePropertySet | Parses a single property set statement.
PersistNamedResource (inherited from CodePersister) | Creates an expression from a name/value pair.
RemoveDeclaration | Called when the designer host fires the OnComponentRemove event.
ShouldPersist | Helper function to determine if a property should be persisted.

See Also

ComponentModelPersister Class | System.ComponentModel.Design Namespace


ComponentModelPersister Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ComponentModelPersister();
[C++]
public: ComponentModelPersister();
[JScript]
public function ComponentModelPersister();

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ComponentModelPersister Properties

The properties of the ComponentModelPersister class are listed below. For a complete list of ComponentModelPersister class members, see the ComponentModelPersister Members topic.

Public:

CanReload (inherited from CodePersister) This can be called to check if the persister can be reloaded. This will return true by default, thereby forcing a reload of the designer.

Protected:

BaseComponent | The base component.
DocumentCodeClass | The class that is currently in the designer for editing.
FirstLoadException (inherited from CodePersister) | First load exception that occurs. This allows the parsing to continue on and still report the first failure.
Host (inherited from CodePersister) | IDesignerHost this persister should communicate with.
IgnoreCase (inherited from CodePersister) | [To be supplied.]
SourceFile | The source file to persist to.
ValueProviderSorter (inherited from CodePersister) | [To be supplied.]

See Also

ComponentModelPersister Class | System.ComponentModel.Design Namespace


ComponentModelPersister.BaseComponent

The base component.

[Visual Basic]
Overridable Protected Property BaseComponent As IComponent
[C#]
protected IComponent BaseComponent {virtual get; virtual set;}
[C++]
protected: __property virtual IComponent* get_BaseComponent();
protected: __property virtual void set_BaseComponent(IComponent*);
[JScript]
protected function get BaseComponent() : IComponent;
protected function set BaseComponent(IComponent);

Property Value

The base component.

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.DocumentCodeClass

The class that is currently in the designer for editing.

[Visual Basic]
Overridable Protected ReadOnly Property DocumentCodeClass As _
   ICodeClass
[C#]
protected ICodeClass DocumentCodeClass {override get;}
[C++]
protected: __property virtual ICodeClass* get_DocumentCodeClass();
[JScript]
protected function get DocumentCodeClass() : ICodeClass;

Remarks

This shouldn't be cached since the CodeSense engine may re-parse and create new objects.

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace | CodePersister


ComponentModelPersister.SourceFile

The source file to persist to.

[Visual Basic]
Overridable Protected ReadOnly Property SourceFile As _
   ICodeSourceFile
[C#]
protected ICodeSourceFile SourceFile {override get;}
[C++]
protected: __property virtual ICodeSourceFile* get_SourceFile();
[JScript]
protected function get SourceFile() : ICodeSourceFile;

Property Value

An ICodeSourceFile that will be used in persistance.

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ComponentModelPersister Methods

The methods of the ComponentModelPersister class are listed below. For a complete list of ComponentModelPersister class members, see the ComponentModelPersister Members topic.

Public:

Dispose | Disposes of the resources (other than memory) used by the ComponentModelPersister.
DoesHandlerExist | Gets whether or not a handler for the specified event descriptor exists in the code.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCompatibleMethods | Gets the names of methods that have signatures compatible with the specified delegate class.
GetComponentCode | Generates the source code for the specified subcomponents.
GetComponentsFromCode | [To be supplied.]
GetDoesFieldExist | Determines if a field of the specified name exists in the code.
GetDoesMethodExist | Determines if a method of the specified name exists in the code.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNameFromReference (inherited from CodePersister) | Returns the name of the given reference. This will look up in either the referenceService or the component's site.
GetReferenceFromName | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
Init | Initializes this persister with the specified host and sourceFile.
Load | Called when the source file should be reparsed. This should only populate the designer host the first time it is called. Subclasses must provide an implementation.
NavigateToEvent | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

AlwaysPersist (inherited from CodePersister) | If any value provider indicates that a value is "UserSelected" then we must force the persistence of the value.
AppendInitMethodStatements | Provides a way for subclasses to append methods to the initMethod function. The base.AppendInitMethodStatements method should be called to do this.
BeginDepersisting (inherited from CodePersister) | Notifies value providers that depersisting has begun.
BeginPersisting (inherited from CodePersister) | Notifies value providers that persisting has begun.
CreateComponentInstance (inherited from CodePersister) | Create the component specified and initialize its Modifiers property.
CreateDeclaration | [To be supplied.]
CreateExpressionFromPropertyValue (inherited from CodePersister) | Creates an expression value object from a PropertyValue. This will perform a deep scan on the PropertyValue and convert any nested object creates, array creates, name references, or constants. For more information on values and expressions see the ICodeSourceFile documentation.
CreateExpressionFromValue (inherited from CodePersister) | Creates an expression from a component/propertyName combination. This should only be used for property sets.
CreateValueFromExpression (inherited from CodePersister) | Creates a value from an expression object returned form the CodeSense APIs. This will take the various expressions and execute them, so to say. For example, if you pass in a ICodeObjectCreateExpression for value and it refers to the Point class, then a Point object will be returned. For more information on values and expression see the ICodeSourceFile documentation.
DeclareComponent (inherited from CodePersister) | This is used during code parsing to declare a given data member. We declare the member, and then we create an instance of this data member. This will throw an exception if the data member has already been declared.
EndDepersisting (inherited from CodePersister) | Notifies value providers that depersisting has completed.
EndPersisting (inherited from CodePersister) | Notifies value providers that persisting has completed.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
FindInitMethod | Finds the initialization method for this class.
Generate | Generates the source code for the document.
GenerateComponentParenting | Generates any parenting statemetns for the specified control.
GenerateEvent | Generates a single event hookup method for the initialization method.
GenerateEvents | Generates the code for the bound events of the control. Subclasses can override if their persistence mechanism is different (e.g. Web Forms)
GenerateExtenderSet | Generates a single property set statement for an extender property.
GenerateHierarchyForObject | [To be supplied.]
GenerateInitMethod | Generates the initialization method for persistance.
GenerateMemberInstanceCreation | Generates a single member create statement. This is used to construct objects inside of InitForm, instead of in the data member declaration.
GeneratePropertySet | Overloaded. [To be supplied.]
GenerateResourcesDecl | Generates the resource creation statement.
GenerateUpdateDataMembers | Updates the modifiers on data members if they have changed.
GetComponentName | Gets the name of the specified component.
GetServiceObject | Searches for the requested service.
GetValueProviderDeclarations (inherited from CodePersister) | Returns the array of value provider local variable declarations.
IsValueProviderDeclaration (inherited from CodePersister) | Determines if the specified statement is a the local declaration for a value provider.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseComponentDeclarations | Walks through the list of data members, finds all that implement IComponent and adds them to the Host.
ParseEventAdd | Parses a single event add statement.
ParseExtenderSet | Parses a single extender property set statement.
ParseInitMethod | Parses all the statements in the init method.
ParseInitMethodMethod | Parses a single method invoke inside of the init method. Subclasses should call base.ParseInitMethodMethod(...). You can choose to call super before or after custom parsing, but you should only call it if you want the default parsing to occur.
ParseMethodInvoke | Parses a single no-arg method invoke of any name
ParsePropertySet | Parses a single property set statement.
PersistNamedResource (inherited from CodePersister) | Creates an expression from a name/value pair.
RemoveDeclaration | Called when the designer host fires the OnComponentRemove event.
ShouldPersist | Helper function to determine if a property should be persisted.

See Also

ComponentModelPersister Class | System.ComponentModel.Design Namespace


ComponentModelPersister.AppendInitMethodStatements

Provides a way for subclasses to append methods to the initMethod function. The base.AppendInitMethodStatements method should be called to do this.

[Visual Basic]
Overridable Protected Sub AppendInitMethodStatements( _
   ByVal initForm As ICodeMethod, _
   ByVal statements As ObjectList _
)
[C#]
protected virtual void AppendInitMethodStatements(
   ICodeMethod initForm,
   ObjectList statements
);
[C++]
protected: virtual void AppendInitMethodStatements(
   ICodeMethod* initForm,
   ObjectList* statements
);
[JScript]
protected function AppendInitMethodStatements(
   initForm : ICodeMethod,
   statements : ObjectList
);

Parameters

initForm
The method being generated.
statements
A list of statements that will be added to the method.

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.CreateDeclaration

[To be supplied.]

[Visual Basic]
Overridable Protected Sub CreateDeclaration( _
   ByVal sender As Object, _
   ByVal ce As ComponentEventArgs _
)
[C#]
protected virtual void CreateDeclaration(
   object sender,
   ComponentEventArgs ce
);
[C++]
protected: virtual void CreateDeclaration(
   Object* sender,
   ComponentEventArgs* ce
);
[JScript]
protected function CreateDeclaration(
   sender : Object,
   ce : ComponentEventArgs
);

Parameters

sender
The source of the event.
ce
[To be supplied.]

Remarks

This is called when the designer host fires the OnComponentAdd event.

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.Dispose

Disposes of the resources (other than memory) used by the ComponentModelPersister.

[Visual Basic]
Overrides Public Sub Dispose()
[C#]
public override void Dispose();
[C++]
public: override void Dispose();
[JScript]
public override function Dispose();

Remarks

Call Dispose when you are finished using the ComponentModelPersister. The Dispose method leaves the ComponentModelPersister in an unusable state. After calling Dispose, you must release all references to the ComponentModelPersister so the memory it was occupying can be reclaimed by garbage collection.

Note Always call Dispose before you release your last reference to the ComponentModelPersister. Otherwise, the resources the ComponentModelPersister is using will not be freed until garbage collection calls the ComponentModelPersister object's destructor.

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace | CodePersister


ComponentModelPersister.DoesHandlerExist

Gets whether or not a handler for the specified event descriptor exists in the code.

[Visual Basic]
Overridable Public Function DoesHandlerExist( _
   ByVal handler As String, _
   ByVal evevent As EventDescriptor _
) As Boolean
[C#]
public virtual bool DoesHandlerExist(
   string handler,
   EventDescriptor evevent
);
[C++]
public: virtual bool DoesHandlerExist(
   String* handler,
   EventDescriptor* evevent
);
[JScript]
public function DoesHandlerExist(
   handler : String,
   evevent : EventDescriptor
) : Boolean;

Parameters

handler
[To be supplied.]
evevent
[To be supplied.]

Return Value

true if the handler exists, otherwise false.

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.FindInitMethod

Finds the initialization method for this class.

[Visual Basic]
Overridable Protected Function FindInitMethod() As ICodeMethod
[C#]
protected virtual ICodeMethod FindInitMethod();
[C++]
protected: virtual ICodeMethod* FindInitMethod();
[JScript]
protected function FindInitMethod() : ICodeMethod;

Remarks

Notes to Implementers: This can be overridden to return any method that they want to be treated as the "init" method.

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.Generate

Generates the source code for the document.

[Visual Basic]
Overridable Protected Sub Generate()
[C#]
protected virtual void Generate();
[C++]
protected: virtual void Generate();
[JScript]
protected function Generate();

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.GenerateComponentParenting

Generates any parenting statemetns for the specified control.

[Visual Basic]
Overridable Protected Sub GenerateComponentParenting( _
   ByVal statements As ObjectList, _
   ByVal objectName As String, _
   ByVal component As Object _
)
[C#]
protected virtual void GenerateComponentParenting(
   ObjectList statements,
   string objectName,
   object component
);
[C++]
protected: virtual void GenerateComponentParenting(
   ObjectList* statements,
   String* objectName,
   Object* component
);
[JScript]
protected function GenerateComponentParenting(
   statements : ObjectList,
   objectName : String,
   component : Object
);

Parameters

statements
[To be supplied.]
objectName
The name of the control.
component
The instance of the component.

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.GenerateEvent

Generates a single event hookup method for the initialization method.

[Visual Basic]
Protected Function GenerateEvent( _
   ByVal component As IComponent, _
   ByVal objectName() As String, _
   ByVal eventProp As PropertyDescriptor _
) As ICodeStatement
[C#]
protected ICodeStatement GenerateEvent(
   IComponent component,
   string[] objectName,
   PropertyDescriptor eventProp
);
[C++]
protected: ICodeStatement* GenerateEvent(
   IComponent* component,
   String* objectName[],
   PropertyDescriptor* eventProp
);
[JScript]
protected function GenerateEvent(
   component : IComponent,
   objectName : String[],
   eventProp : PropertyDescriptor
) : ICodeStatement;

Parameters

component
The component that the event is getting hooked to.
objectName
The name of the component. Passed in here for performance reasons only.
eventProp
The "pseudo" property that represents the event. Undone. This is really a kludge- we want a good way at design time to determine the name of the method to bind to... but this is what we have for now!

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.GenerateEvents

Generates the code for the bound events of the control. Subclasses can override if their persistence mechanism is different (e.g. Web Forms)

[Visual Basic]
Overridable Protected Sub GenerateEvents( _
   ByVal component As IComponent, _
   ByVal objectName() As String, _
   ByVal eventPropertyService As IEventPropertyService, _
   ByVal statements As ObjectList _
)
[C#]
protected virtual void GenerateEvents(
   IComponent component,
   string[] objectName,
   IEventPropertyService eventPropertyService,
   ObjectList statements
);
[C++]
protected: virtual void GenerateEvents(
   IComponent* component,
   String* objectName[],
   IEventPropertyService* eventPropertyService,
   ObjectList* statements
);
[JScript]
protected function GenerateEvents(
   component : IComponent,
   objectName : String[],
   eventPropertyService : IEventPropertyService,
   statements : ObjectList
);

Parameters

component
The component that the event is hooked to.
objectName
The name of the object firing the events.
eventPropertyService
The service used to map events to properties.
statements
A statement list onto which the generated event is to be tacked.

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.GenerateExtenderSet

Generates a single property set statement for an extender property.

[Visual Basic]
Protected Function GenerateExtenderSet( _
   ByVal provider As IExtenderProvider, _
   ByVal objectName() As String, _
   ByVal component As Object, _
   ByVal prop As PropertyDescriptor, _
   ByVal pv As PropertyValue _
) As ICodeStatement
[C#]
protected ICodeStatement GenerateExtenderSet(
   IExtenderProvider provider,
   string[] objectName,
   object component,
   PropertyDescriptor prop,
   PropertyValue pv
);
[C++]
protected: ICodeStatement* GenerateExtenderSet(
   IExtenderProvider* provider,
   String* objectName[],
   Object* component,
   PropertyDescriptor* prop,
   PropertyValue* pv
);
[JScript]
protected function GenerateExtenderSet(
   provider : IExtenderProvider,
   objectName : String[],
   component : Object,
   prop : PropertyDescriptor,
   pv : PropertyValue
) : ICodeStatement;

Parameters

provider
The object providing this extender property.
objectName
The name of the object to set the property on. Note: This is a string array to support setting properties on sub objects, like "Foo.Bar.All = ...". In this case the string array would contain "Foo" and "Bar".
component
The component instance.
prop
A PropertyDescriptor that represents the property to set.
pv
A PropertyValue that represents the value to set.

Return Value

An ICodeStatement that can persist the extender property.

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.GenerateHierarchyForObject

[To be supplied.]

[Visual Basic]
Protected Sub GenerateHierarchyForObject( _
   ByVal currentObject As Object, _
   ByVal objectName() As String _
)
[C#]
protected void GenerateHierarchyForObject(
   object currentObject,
   string[] objectName
);
[C++]
protected: void GenerateHierarchyForObject(
   Object* currentObject,
   String* objectName[]
);
[JScript]
protected function GenerateHierarchyForObject(
   currentObject : Object,
   objectName : String[]
);

Parameters

currentObject
[To be supplied.]
objectName
[To be supplied.]

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.GenerateInitMethod

Generates the initialization method for persistance.

[Visual Basic]
Protected Sub GenerateInitMethod( _
   ByVal initForm As ICodeMethod _
)
[C#]
protected void GenerateInitMethod(
   ICodeMethod initForm
);
[C++]
protected: void GenerateInitMethod(
   ICodeMethod* initForm
);
[JScript]
protected function GenerateInitMethod(
   initForm : ICodeMethod
);

Parameters

initForm
The method to generate into.

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.GenerateMemberInstanceCreation

Generates a single member create statement. This is used to construct objects inside of InitForm, instead of in the data member declaration.

[Visual Basic]
Overridable Protected Function GenerateMemberInstanceCreation( _
   ByVal memberName As String, _
   ByVal memberType As String, _
   ByVal constructorArgs() As Object _
) As ICodeStatement
[C#]
protected virtual ICodeStatement GenerateMemberInstanceCreation(
   string memberName,
   string memberType,
   object[] constructorArgs
);
[C++]
protected: virtual ICodeStatement* GenerateMemberInstanceCreation(
   String* memberName,
   String* memberType,
   Object* constructorArgs[]
);
[JScript]
protected function GenerateMemberInstanceCreation(
   memberName : String,
   memberType : String,
   constructorArgs : Object[]
) : ICodeStatement;

Parameters

memberName
The name of member to construct.
memberType
The string name of the class of the data member to construct.
constructorArgs
The arguments to pass to the constructor.

Return Value

An ICodeStatement that can persist the member's creation statement.

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.GeneratePropertySet

[To be supplied.]

Overload List

Generates a single property set statement.

[Visual Basic] Overloads Protected Function GeneratePropertySet(String, Object, PropertyDescriptor, PropertyValue) As ICodeStatement
[C#] protected ICodeStatement GeneratePropertySet(String, Object, PropertyDescriptor, PropertyValue);
[C++] protected: ICodeStatement* GeneratePropertySet(String*, Object, PropertyDescriptor, PropertyValue);
[JScript] protected function GeneratePropertySet(String, Object, PropertyDescriptor, PropertyValue) : ICodeStatement;

Generates a single property set statement.

[Visual Basic] Overloads Protected Function GeneratePropertySet(String(), Object, PropertyDescriptor, PropertyValue) As ICodeStatement
[C#] protected ICodeStatement GeneratePropertySet(String[], Object, PropertyDescriptor, PropertyValue);
[C++] protected: ICodeStatement* GeneratePropertySet(String*[], Object, PropertyDescriptor, PropertyValue);
[JScript] protected function GeneratePropertySet(String[], Object, PropertyDescriptor, PropertyValue) : ICodeStatement;

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.GeneratePropertySet (String, Object, PropertyDescriptor, PropertyValue)

Generates a single property set statement.

[Visual Basic]
Overloads Protected Function GeneratePropertySet( _
   ByVal objectName As String, _
   ByVal component As Object, _
   ByVal prop As PropertyDescriptor, _
   ByVal pv As PropertyValue _
) As ICodeStatement
[C#]
protected ICodeStatement GeneratePropertySet(
   string objectName,
   object component,
   PropertyDescriptor prop,
   PropertyValue pv
);
[C++]
protected: ICodeStatement* GeneratePropertySet(
   String* objectName,
   Object* component,
   PropertyDescriptor* prop,
   PropertyValue* pv
);
[JScript]
protected function GeneratePropertySet(
   objectName : String,
   component : Object,
   prop : PropertyDescriptor,
   pv : PropertyValue
) : ICodeStatement;

Parameters

objectName
Name of object to set the property on.
component
The component the property belongs to.
prop
A PropertyDescriptor that represents the property to set.
pv
A PropertyValue that represents the value to set.

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace | ComponentModelPersister.GeneratePropertySet Overload List


ComponentModelPersister.GeneratePropertySet (String[], Object, PropertyDescriptor, PropertyValue)

Generates a single property set statement.

[Visual Basic]
Overloads Protected Function GeneratePropertySet( _
   ByVal objectName() As String, _
   ByVal component As Object, _
   ByVal prop As PropertyDescriptor, _
   ByVal pv As PropertyValue _
) As ICodeStatement
[C#]
protected ICodeStatement GeneratePropertySet(
   string[] objectName,
   object component,
   PropertyDescriptor prop,
   PropertyValue pv
);
[C++]
protected: ICodeStatement* GeneratePropertySet(
   String* objectName[],
   Object* component,
   PropertyDescriptor* prop,
   PropertyValue* pv
);
[JScript]
protected function GeneratePropertySet(
   objectName : String[],
   component : Object,
   prop : PropertyDescriptor,
   pv : PropertyValue
) : ICodeStatement;

Parameters

objectName
Name of object to set the property on. Note: This is a string array to support setting properties on sub objects, like "Foo.Bar.All = ...". In this case the string array would contain "Foo" and "Bar".
component
The component the property belongs to.
prop
A PropertyDescriptor that represents the property to set.
pv
A PropertyValue that represents the value to set.

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace | ComponentModelPersister.GeneratePropertySet Overload List


ComponentModelPersister.GenerateResourcesDecl

Generates the resource creation statement.

[Visual Basic]
Overridable Protected Function GenerateResourcesDecl() As _
   ICodeStatement
[C#]
protected virtual ICodeStatement GenerateResourcesDecl();
[C++]
protected: virtual ICodeStatement* GenerateResourcesDecl();
[JScript]
protected function GenerateResourcesDecl() : ICodeStatement;

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.GenerateUpdateDataMembers

Updates the modifiers on data members if they have changed.

[Visual Basic]
Overridable Protected Sub GenerateUpdateDataMembers()
[C#]
protected virtual void GenerateUpdateDataMembers();
[C++]
protected: virtual void GenerateUpdateDataMembers();
[JScript]
protected function GenerateUpdateDataMembers();

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.GetCompatibleMethods

Gets the names of methods that have signatures compatible with the specified delegate class.

[Visual Basic]
Overridable Public Function GetCompatibleMethods( _
   ByVal delegateClass As Type _
) As String ()
[C#]
public virtual string[] GetCompatibleMethods(
   Type delegateClass
);
[C++]
public: virtual String* GetCompatibleMethods(
   Type* delegateClass
) [];
[JScript]
public function GetCompatibleMethods(
   delegateClass : Type
) : String[];

Parameters

delegateClass
The class of delegate to get compatible methods for.

Return Value

An array of strings that contain the names of compatible methods.

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.GetComponentCode

Generates the source code for the specified subcomponents.

[Visual Basic]
Overrides Public Function GetComponentCode( _
   ByVal components() As IComponent, _
   ByVal sourceFile As ICodeSourceFile, _
   ByVal xLocOffset As Integer, _
   ByVal yLocOffset As Integer _
) As String
[C#]
public override string GetComponentCode(
   IComponent[] components,
   ICodeSourceFile sourceFile,
   int xLocOffset,
   int yLocOffset
);
[C++]
public: override String* GetComponentCode(
   IComponent* components[],
   ICodeSourceFile* sourceFile,
   int xLocOffset,
   int yLocOffset
);
[JScript]
public override function GetComponentCode(
   components : IComponent[],
   sourceFile : ICodeSourceFile,
   xLocOffset : int,
   yLocOffset : int
) : String;

Parameters

components
[To be supplied.]
sourceFile
[To be supplied.]
xLocOffset
[To be supplied.]
yLocOffset
[To be supplied.]

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.GetComponentName

Gets the name of the specified component.

[Visual Basic]
Protected Function GetComponentName( _
   ByVal component As IComponent _
) As String
[C#]
protected string GetComponentName(
   IComponent component
);
[C++]
protected: String* GetComponentName(
   IComponent* component
);
[JScript]
protected function GetComponentName(
   component : IComponent
) : String;

Parameters

component
The name of the component.

Remarks

This will return an empty string for the top level component, since that is what CodeSense wants for references to "this" or "me".

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.GetComponentsFromCode

[To be supplied.]

[Visual Basic]
Overrides Public Function GetComponentsFromCode( _
   ByVal code As String, _
   ByVal maxComps As Integer, _
   ByVal sourceFile As ICodeSourceFile _
) As IComponent ()
[C#]
public override IComponent[] GetComponentsFromCode(
   string code,
   int maxComps,
   ICodeSourceFile sourceFile
);
[C++]
public: override IComponent* GetComponentsFromCode(
   String* code,
   int maxComps,
   ICodeSourceFile* sourceFile
) [];
[JScript]
public override function GetComponentsFromCode(
   code : String,
   maxComps : int,
   sourceFile : ICodeSourceFile
) : IComponent[];

Parameters

code
[To be supplied.]
maxComps
[To be supplied.]
sourceFile
[To be supplied.]

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.GetDoesFieldExist

Determines if a field of the specified name exists in the code.

[Visual Basic]
Overridable Public Function GetDoesFieldExist( _
   ByVal name As String _
) As Boolean
[C#]
public virtual bool GetDoesFieldExist(
   string name
);
[C++]
public: virtual bool GetDoesFieldExist(
   String* name
);
[JScript]
public function GetDoesFieldExist(
   name : String
) : Boolean;

Parameters

name
The name of the field to test for existance.

Return Value

true if the field exists, otherwise false.

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.GetDoesMethodExist

Determines if a method of the specified name exists in the code.

[Visual Basic]
Overridable Public Function GetDoesMethodExist( _
   ByVal name As String, _
   ByVal argTypes() As Type _
) As Boolean
[C#]
public virtual bool GetDoesMethodExist(
   string name,
   Type[] argTypes
);
[C++]
public: virtual bool GetDoesMethodExist(
   String* name,
   Type* argTypes[]
);
[JScript]
public function GetDoesMethodExist(
   name : String,
   argTypes : Type[]
) : Boolean;

Parameters

name
The name of the method.
argTypes
The types of the arguments for the method.

Return Value

true if the method exists, otherwise false.

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.GetReferenceFromName

[To be supplied.]

[Visual Basic]
Overrides Public Function GetReferenceFromName( _
   ByVal name As String _
) As Object
[C#]
public override object GetReferenceFromName(
   string name
);
[C++]
public: override Object* GetReferenceFromName(
   String* name
);
[JScript]
public override function GetReferenceFromName(
   name : String
) : Object;

Parameters

name
[To be supplied.]

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.GetServiceObject

Searches for the requested service.

[Visual Basic]
Overrides Protected Function GetServiceObject( _
   ByVal serviceType As Type _
) As Object
[C#]
protected override object GetServiceObject(
   Type serviceType
);
[C++]
protected: override Object* GetServiceObject(
   Type* serviceType
);
[JScript]
protected override function GetServiceObject(
   serviceType : Type
) : Object;

Parameters

serviceType
The service being requested.

Return Value

An instance of the service, or a null reference (in Visual Basic Nothing) if the service could not be found.

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace | CodePersister


ComponentModelPersister.Init

Initializes this persister with the specified host and sourceFile.

[Visual Basic]
Overrides Public Sub Init( _
   ByVal sourceFile As ICodeSourceFile, _
   ByVal host As IDesignerHost _
)
[C#]
public override void Init(
   ICodeSourceFile sourceFile,
   IDesignerHost host
);
[C++]
public: override void Init(
   ICodeSourceFile* sourceFile,
   IDesignerHost* host
);
[JScript]
public override function Init(
   sourceFile : ICodeSourceFile,
   host : IDesignerHost
);

Parameters

sourceFile
Source code that this persister should read/write to.
host
IDesignerHost that this persister should communicate with.

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace | CodePersister


ComponentModelPersister.Load

Called when the source file should be reparsed. This should only populate the designer host the first time it is called. Subclasses must provide an implementation.

[Visual Basic]
Overrides Public Function Load() As String
[C#]
public override string Load();
[C++]
public: override String* Load();
[JScript]
public override function Load() : String;

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace | CodePersister


ComponentModelPersister.NavigateToEvent

[To be supplied.]

Overload List

Creates a new event handler and navigates to it. The name will be autogenerated from the component and event name

[Visual Basic] Overloads Overridable Public Function NavigateToEvent(IComponent, EventDescriptor, Integer) As String
[C#] public virtual string NavigateToEvent(IComponent, EventDescriptor, int);
[C++] public: virtual String* NavigateToEvent(IComponent*, EventDescriptor, int);
[JScript] public function NavigateToEvent(IComponent, EventDescriptor, int) : String;

Navigates the text editor to the specified event handler. If no event handler is found, a new method should be created.

[Visual Basic] Overloads Overridable Public Function NavigateToEvent(IComponent, EventDescriptor, Integer, String) As String
[C#] public virtual string NavigateToEvent(IComponent, EventDescriptor, int, String);
[C++] public: virtual String* NavigateToEvent(IComponent*, EventDescriptor, int, String);
[JScript] public function NavigateToEvent(IComponent, EventDescriptor, int, String) : String;

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.NavigateToEvent (IComponent, EventDescriptor, Int32)

Creates a new event handler and navigates to it. The name will be autogenerated from the component and event name

[Visual Basic]
Overloads Overridable Public Function NavigateToEvent( _
   ByVal component As IComponent, _
   ByVal evevent As EventDescriptor, _
   ByVal modifiers As Integer _
) As String
[C#]
public virtual string NavigateToEvent(
   IComponent component,
   EventDescriptor evevent,
   int modifiers
);
[C++]
public: virtual String* NavigateToEvent(
   IComponent* component,
   EventDescriptor* evevent,
   int modifiers
);
[JScript]
public function NavigateToEvent(
   component : IComponent,
   evevent : EventDescriptor,
   modifiers : int
) : String;

Parameters

component
Component the event will be fired from
evevent
Event information to match
modifiers
to apply to handler

Return Value

name given to the event handler

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace | ComponentModelPersister.NavigateToEvent Overload List


ComponentModelPersister.NavigateToEvent (IComponent, EventDescriptor, Int32, String)

Navigates the text editor to the specified event handler. If no event handler is found, a new method should be created.

[Visual Basic]
Overloads Overridable Public Function NavigateToEvent( _
   ByVal component As IComponent, _
   ByVal evevent As EventDescriptor, _
   ByVal modifiers As Integer, _
   ByVal name As String _
) As String
[C#]
public virtual string NavigateToEvent(
   IComponent component,
   EventDescriptor evevent,
   int modifiers,
   string name
);
[C++]
public: virtual String* NavigateToEvent(
   IComponent* component,
   EventDescriptor* evevent,
   int modifiers,
   String* name
);
[JScript]
public function NavigateToEvent(
   component : IComponent,
   evevent : EventDescriptor,
   modifiers : int,
   name : String
) : String;

Parameters

component
Component the event will be fired from
evevent
Event information to match
modifiers
to apply to handler
name
to of handler to create/find.

Return Value

the name of the event method that was created, or null if an existing method was found

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace | ComponentModelPersister.NavigateToEvent Overload List | ICodeNavigatorService


ComponentModelPersister.ParseComponentDeclarations

Walks through the list of data members, finds all that implement IComponent and adds them to the Host.

[Visual Basic]
Protected Sub ParseComponentDeclarations( _
   ByVal components() As ICodeDataMember _
)
[C#]
protected void ParseComponentDeclarations(
   ICodeDataMember[] components
);
[C++]
protected: void ParseComponentDeclarations(
   ICodeDataMember* components[]
);
[JScript]
protected function ParseComponentDeclarations(
   components : ICodeDataMember[]
);

Parameters

components
[To be supplied.]

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.ParseEventAdd

Parses a single event add statement.

[Visual Basic]
Protected Sub ParseEventAdd( _
   ByVal target() As String, _
   ByVal eventName As String, _
   ByVal value As Object _
)
[C#]
protected void ParseEventAdd(
   string[] target,
   string eventName,
   object value
);
[C++]
protected: void ParseEventAdd(
   String* target[],
   String* eventName,
   Object* value
);
[JScript]
protected function ParseEventAdd(
   target : String[],
   eventName : String,
   value : Object
);

Parameters

target
Name of object that is having the event added to.
eventName
name of the event that is getting hooked.
value
Value/Expression that was passed into the AddOnXXX method invoke.

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.ParseExtenderSet

Parses a single extender property set statement.

[Visual Basic]
Protected Sub ParseExtenderSet( _
   ByVal target() As String, _
   ByVal extendeeName As String, _
   ByVal propname As String, _
   ByVal value As Object _
)
[C#]
protected void ParseExtenderSet(
   string[] target,
   string extendeeName,
   string propname,
   object value
);
[C++]
protected: void ParseExtenderSet(
   String* target[],
   String* extendeeName,
   String* propname,
   Object* value
);
[JScript]
protected function ParseExtenderSet(
   target : String[],
   extendeeName : String,
   propname : String,
   value : Object
);

Parameters

target
Name of the object that the property is getting set on.
extendeeName
Name of the target of the extender object.
propname
Name of property to set
value
Value/Expression to set the property to.

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.ParseInitMethod

Parses all the statements in the init method.

[Visual Basic]
Overridable Protected Sub ParseInitMethod( _
   ByVal initForm As ICodeMethod _
)
[C#]
protected virtual void ParseInitMethod(
   ICodeMethod initForm
);
[C++]
protected: virtual void ParseInitMethod(
   ICodeMethod* initForm
);
[JScript]
protected function ParseInitMethod(
   initForm : ICodeMethod
);

Parameters

initForm
initmethod.

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.ParseInitMethodMethod

Parses a single method invoke inside of the init method. Subclasses should call base.ParseInitMethodMethod(...). You can choose to call super before or after custom parsing, but you should only call it if you want the default parsing to occur.

[Visual Basic]
Overridable Protected Function ParseInitMethodMethod( _
   ByVal methodInvoke As ICodeMethodInvokeStatement _
) As Boolean
[C#]
protected virtual bool ParseInitMethodMethod(
   ICodeMethodInvokeStatement methodInvoke
);
[C++]
protected: virtual bool ParseInitMethodMethod(
   ICodeMethodInvokeStatement* methodInvoke
);
[JScript]
protected function ParseInitMethodMethod(
   methodInvoke : ICodeMethodInvokeStatement
) : Boolean;

Parameters

methodInvoke
statement to parse

Return Value

true if the statement was parsed, false if it was ignored.

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.ParseMethodInvoke

Parses a single no-arg method invoke of any name

[Visual Basic]
Protected Sub ParseMethodInvoke( _
   ByVal target() As String, _
   ByVal methodName As String _
)
[C#]
protected void ParseMethodInvoke(
   string[] target,
   string methodName
);
[C++]
protected: void ParseMethodInvoke(
   String* target[],
   String* methodName
);
[JScript]
protected function ParseMethodInvoke(
   target : String[],
   methodName : String
);

Parameters

target
Name of object that is having the method called on it
methodName
name of the method that is getting invoked

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.ParsePropertySet

Parses a single property set statement.

[Visual Basic]
Protected Sub ParsePropertySet( _
   ByVal target() As String, _
   ByVal propname As String, _
   ByVal value As Object _
)
[C#]
protected void ParsePropertySet(
   string[] target,
   string propname,
   object value
);
[C++]
protected: void ParsePropertySet(
   String* target[],
   String* propname,
   Object* value
);
[JScript]
protected function ParsePropertySet(
   target : String[],
   propname : String,
   value : Object
);

Parameters

target
Name of the object that the property is getting set on.
propname
Name of property to set
value
Value/Expression to set the property to.

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.RemoveDeclaration

Called when the designer host fires the OnComponentRemove event.

[Visual Basic]
Overridable Protected Sub RemoveDeclaration( _
   ByVal sender As Object, _
   ByVal ce As ComponentEventArgs _
)
[C#]
protected virtual void RemoveDeclaration(
   object sender,
   ComponentEventArgs ce
);
[C++]
protected: virtual void RemoveDeclaration(
   Object* sender,
   ComponentEventArgs* ce
);
[JScript]
protected function RemoveDeclaration(
   sender : Object,
   ce : ComponentEventArgs
);

Parameters

sender
The object sending the event.
ce
Event object used when firing a component removed notification.

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.ShouldPersist

Helper function to determine if a property should be persisted.

[Visual Basic]
Overridable Protected Function ShouldPersist( _
   ByVal iprop As PropertyDescriptor, _
   ByVal comp As Object _
) As Boolean
[C#]
protected virtual bool ShouldPersist(
   PropertyDescriptor iprop,
   object comp
);
[C++]
protected: virtual bool ShouldPersist(
   PropertyDescriptor* iprop,
   Object* comp
);
[JScript]
protected function ShouldPersist(
   iprop : PropertyDescriptor,
   comp : Object
) : Boolean;

Parameters

iprop
property to check
comp
Component to check

See Also

ComponentModelPersister Class | ComponentModelPersister Members | System.ComponentModel.Design Namespace


ComponentModelPersister.LocalCache.LocalCacheItemComparer Class

[To be supplied.]

Object
ComponentModelPersister.LocalCache.LocalCacheItemComparer

[Visual Basic]
Public Class _
   ComponentModelPersister.LocalCache.LocalCacheItemComparer
   Implements IComparer
[C#]
public class
   ComponentModelPersister.LocalCache.LocalCacheItemComparer :
   IComparer
[C++]
public __gc class
   ComponentModelPersister.LocalCache.LocalCacheItemComparer : public
   IComparer
[JScript]
public class
   ComponentModelPersister.LocalCache.LocalCacheItemComparer implements
   IComparer

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

ComponentModelPersister.LocalCache.LocalCacheItemComparer Members | System.ComponentModel.Design Namespace


ComponentModelPersister.LocalCache.LocalCacheItemComparer Members

Public:

Constructor

ComponentModelPersisterLocalCacheLocalCacheItemComparer Constructor [To be supplied.]

Methods

Compare | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ComponentModelPersister.LocalCache.LocalCacheItemComparer Class | System.ComponentModel.Design Namespace


ComponentModelPersister.LocalCache.LocalCacheItemComparer Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ComponentModelPersister.LocalCache.LocalCacheItemComparer();
[C++]
public: ComponentModelPersister.LocalCache.LocalCacheItemComparer();
[JScript]
public function
   ComponentModelPersister.LocalCache.LocalCacheItemComparer();

See Also

ComponentModelPersister.LocalCache.LocalCacheItemComparer Class | ComponentModelPersister.LocalCache.LocalCacheItemComparer Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ComponentModelPersister.LocalCache.LocalCacheItemComparer Methods

The methods of the ComponentModelPersister.LocalCache.LocalCacheItemComparer class are listed below. For a complete list of ComponentModelPersister.LocalCache.LocalCacheItemComparer class members, see the ComponentModelPersister.LocalCache.LocalCacheItemComparer Members topic.

Public:

Compare | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ComponentModelPersister.LocalCache.LocalCacheItemComparer Class | System.ComponentModel.Design Namespace


ComponentModelPersister.LocalCache.LocalCacheItemComparer.Compare

[To be supplied.]

[Visual Basic]
Overridable Public Function Compare( _
   ByVal x As Object, _
   ByVal y As Object _
) As Integer
[C#]
public virtual int Compare(
   object x,
   object y
);
[C++]
public: virtual int Compare(
   Object* x,
   Object* y
);
[JScript]
public function Compare(
   x : Object,
   y : Object
) : int;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

ComponentModelPersister.LocalCache.LocalCacheItemComparer Class | ComponentModelPersister.LocalCache.LocalCacheItemComparer Members | System.ComponentModel.Design Namespace


ComponentRenameEventArgs Class

Provides data for the System.ComponentModel.Design.ComponentRenameEvent.ComponentRenameEvent event.

Object
EventArgs
ComponentRenameEventArgs

[Visual Basic]
Public Class ComponentRenameEventArgs
   Inherits EventArgs
[C#]
public class ComponentRenameEventArgs : EventArgs
[C++]
public __gc class ComponentRenameEventArgs : public EventArgs
[JScript]
public class ComponentRenameEventArgs extends EventArgs

Remarks

A ComponentRenameEventArgs specifies the old and new names of a component.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

ComponentRenameEventArgs Members | System.ComponentModel.Design Namespace | ComponentRenameEventHandler


ComponentRenameEventArgs Members

Public:

Constructor

ComponentRenameEventArgs Constructor Initializes a new instance of the ComponentRenameEventArgs class.

Properties

Component | Gets or sets the component that is being renamed.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
NewName | Gets or sets the current name of the component.
OldName | Gets or sets the name of the component before the rename.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ComponentRenameEventArgs Class | System.ComponentModel.Design Namespace


ComponentRenameEventArgs Constructor

Initializes a new instance of the ComponentRenameEventArgs class.

[Visual Basic]
Public Sub New( _
   ByVal component As Object, _
   ByVal oldName As String, _
   ByVal newName As String _
)
[C#]
public ComponentRenameEventArgs(
   object component,
   string oldName,
   string newName
);
[C++]
public: ComponentRenameEventArgs(
   Object* component,
   String* oldName,
   String* newName
);
[JScript]
public function ComponentRenameEventArgs(
   component : Object,
   oldName : String,
   newName : String
);

Parameters

component
The component to be renamed.
oldName
The old name of the component.
newName
The current name of the component.

See Also

ComponentRenameEventArgs Class | ComponentRenameEventArgs Members | System.ComponentModel.Design Namespace | ComponentRenameEventHandler


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ComponentRenameEventArgs Properties

The properties of the ComponentRenameEventArgs class are listed below. For a complete list of ComponentRenameEventArgs class members, see the ComponentRenameEventArgs Members topic.

Public:

Component | Gets or sets the component that is being renamed.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
NewName | Gets or sets the current name of the component.
OldName | Gets or sets the name of the component before the rename.

See Also

ComponentRenameEventArgs Class | System.ComponentModel.Design Namespace


ComponentRenameEventArgs.Component

Gets or sets the component that is being renamed.

[Visual Basic]
Public ReadOnly Property Component As Object
[C#]
public object Component {get;}
[C++]
public: __property Object* get_Component();
[JScript]
public function get Component() : Object;

Property Value

The component that is being renamed.

See Also

ComponentRenameEventArgs Class | ComponentRenameEventArgs Members | System.ComponentModel.Design Namespace


ComponentRenameEventArgs.NewName

Gets or sets the current name of the component.

[Visual Basic]
Overridable Public ReadOnly Property NewName As String
[C#]
public string NewName {virtual get;}
[C++]
public: __property virtual String* get_NewName();
[JScript]
public function get NewName() : String;

Property Value

The current name of the component.

See Also

ComponentRenameEventArgs Class | ComponentRenameEventArgs Members | System.ComponentModel.Design Namespace | OldName


ComponentRenameEventArgs.OldName

Gets or sets the name of the component before the rename.

[Visual Basic]
Overridable Public ReadOnly Property OldName As String
[C#]
public string OldName {virtual get;}
[C++]
public: __property virtual String* get_OldName();
[JScript]
public function get OldName() : String;

Property Value

The previous name of the component.

See Also

ComponentRenameEventArgs Class | ComponentRenameEventArgs Members | System.ComponentModel.Design Namespace | NewName


ComponentRenameEventHandler Delegate

Represents the method that will handle a System.ComponentModel.Design.ComponentRenameEvent.ComponentRenameEvent.

[Visual Basic]
Public Delegate Sub ComponentRenameEventHandler( _
   ByVal sender As Object, _
   ByVal e As ComponentRenameEventArgs _
)
[C#]
public delegate void ComponentRenameEventHandler(
   object sender,
   ComponentRenameEventArgs e
);
[C++]
public __gc __delegate void ComponentRenameEventHandler(
   Object* sender,
   ComponentRenameEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the ComponentRenameEventHandler delegate declaration.

sender
The source of the event.
e
A System.ComponentModel.Design.ComponentRenameEvent.ComponentRenameEventArgs that contains the event data.

Remarks

When you create a ComponentRenameEventHandler delegate, you identify the method that will handle the event. For an overview, see TBD.

To associate the event with your event-handling method, call the AddOn method of the System.ComponentModel.Design.ComponentManager. The event-handling method is called whenever the event occurs, until you call the RemoveOn method of the control.

Note Delegates are the underlying mechanism for events, but most of the time you won't use them directly. For details, see TBD.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

System.ComponentModel.Design Namespace | TBD


CompoundPropertyChangeActionUnit Class

Represents a series of property change action units that can be treated as a single atomic action.

Object
CompoundActionUnit
CompoundPropertyChangeActionUnit

[Visual Basic]
Public Class CompoundPropertyChangeActionUnit
   Inherits CompoundActionUnit
[C#]
public class CompoundPropertyChangeActionUnit : CompoundActionUnit
[C++]
public __gc class CompoundPropertyChangeActionUnit : public
   CompoundActionUnit
[JScript]
public class CompoundPropertyChangeActionUnit extends
   CompoundActionUnit

Remarks

Undoing or redoing this action will cause all of the child actions to be done or undone in the appropriate order. The appropriate order for undoing child actions is from last to first and the appropriate order for redoing child actions is from first to last.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

CompoundPropertyChangeActionUnit Members | System.ComponentModel.Design Namespace | IUndoService | IActionUnit


CompoundPropertyChangeActionUnit Members

Public:

Constructor

CompoundPropertyChangeActionUnit Constructor Overloaded. Initializes a new instance of the CompoundPropertyChangeActionUnit class.

Methods

Add (inherited from CompoundActionUnit) | [To be supplied.]
CanAddChildren (inherited from CompoundActionUnit) | [To be supplied.]
DoAction (inherited from CompoundActionUnit) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetChild (inherited from CompoundActionUnit) | [To be supplied.]
GetChildCount (inherited from CompoundActionUnit) | [To be supplied.]
GetChildren (inherited from CompoundActionUnit) | [To be supplied.]
GetDescription (inherited from CompoundActionUnit) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNextActionType (inherited from CompoundActionUnit) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
Remove (inherited from CompoundActionUnit) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompoundPropertyChangeActionUnit Class | System.ComponentModel.Design Namespace


CompoundPropertyChangeActionUnit Constructor

Initializes a new instance of the CompoundPropertyChangeActionUnit class.

Overload List

Initializes a new instance of the CompoundPropertyChangeActionUnit class using the specified description.

[Visual Basic] Overloads Public Sub New(String)
[C#] public CompoundPropertyChangeActionUnit(String);
[C++] public: CompoundPropertyChangeActionUnit(String*);
[JScript] public function CompoundPropertyChangeActionUnit(String);

Initializes a new instance of the CompoundPropertyChangeActionUnit class with the specified property changes and description.

[Visual Basic] Overloads Public Sub New(String, PropertyChangeActionUnit())
[C#] public CompoundPropertyChangeActionUnit(String, PropertyChangeActionUnit[]);
[C++] public: CompoundPropertyChangeActionUnit(String*, PropertyChangeActionUnit[]);
[JScript] public function CompoundPropertyChangeActionUnit(String, PropertyChangeActionUnit[]);

See Also

CompoundPropertyChangeActionUnit Class | CompoundPropertyChangeActionUnit Members | System.ComponentModel.Design Namespace


CompoundPropertyChangeActionUnit Constructor (String)

Initializes a new instance of the CompoundPropertyChangeActionUnit class using the specified description.

[Visual Basic]
Overloads Public Sub New( _
   ByVal description As String _
)
[C#]
public CompoundPropertyChangeActionUnit(
   string description
);
[C++]
public: CompoundPropertyChangeActionUnit(
   String* description
);
[JScript]
public function CompoundPropertyChangeActionUnit(
   description : String
);

Parameters

description
A description for the compound property change action unit.

See Also

CompoundPropertyChangeActionUnit Class | CompoundPropertyChangeActionUnit Members | System.ComponentModel.Design Namespace | CompoundPropertyChangeActionUnit Constructor Overload List | IUndoService | IActionUnit


CompoundPropertyChangeActionUnit Constructor (String, PropertyChangeActionUnit[])

Initializes a new instance of the CompoundPropertyChangeActionUnit class with the specified property changes and description.

[Visual Basic]
Overloads Public Sub New( _
   ByVal description As String, _
   ByVal propertyChanges() As PropertyChangeActionUnit _
)
[C#]
public CompoundPropertyChangeActionUnit(
   string description,
   PropertyChangeActionUnit[] propertyChanges
);
[C++]
public: CompoundPropertyChangeActionUnit(
   String* description,
   PropertyChangeActionUnit* propertyChanges[]
);
[JScript]
public function CompoundPropertyChangeActionUnit(
   description : String,
   propertyChanges : PropertyChangeActionUnit[]
);

Parameters

description
A description for the compound property change action unit.
propertyChanges
[To be supplied.]

See Also

CompoundPropertyChangeActionUnit Class | CompoundPropertyChangeActionUnit Members | System.ComponentModel.Design Namespace | CompoundPropertyChangeActionUnit Constructor Overload List | PropertyChangeActionUnit | IActionUnit | IUndoService


ContainerSelectorActiveEventHandler Delegate

Represents the method that will handle a System.ComponentModel.Design.ContainerSelectorActiveEvent event.

[Visual Basic]
Public Delegate Sub ContainerSelectorActiveEventHandler( _
   ByVal sender As Object, _
   ByVal e As ContainerSelectorActiveEventArgs _
)
[C#]
public delegate void ContainerSelectorActiveEventHandler(
   object sender,
   ContainerSelectorActiveEventArgs e
);
[C++]
public __gc __delegate void ContainerSelectorActiveEventHandler(
   Object* sender,
   ContainerSelectorActiveEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the ContainerSelectorActiveEventHandler delegate declaration.

sender
The source of the event.
e
A System.ComponentModel.Design.ContainerSelectorActiveEvent event that contains the event data.

Remarks

When you create a ContainerSelectorActiveEventHandler delegate, you identify the method that will handle the event. For an overview, see TBD.

To associate the event with your event-handling method, call the AddOn XXX method of the System.ComponentModel.Design.ComponentManager. The event-handling method is called whenever the event occurs, until you call the RemoveOn XXX method of the control.

Note Delegates are the underlying mechanism for events, but most of the time you won't use them directly. For details, see TBD.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

System.ComponentModel.Design Namespace | System.ComponentModel.Design.ContainerSelectorActiveEvent


ContentAlignmentEditor Class

[To be supplied.]

Object
ValueEditor
ContentAlignmentEditor

[Visual Basic]
Public Class ContentAlignmentEditor
   Inherits ValueEditor
[C#]
public class ContentAlignmentEditor : ValueEditor
[C++]
public __gc class ContentAlignmentEditor : public ValueEditor
[JScript]
public class ContentAlignmentEditor extends ValueEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

ContentAlignmentEditor Members | System.ComponentModel.Design Namespace


ContentAlignmentEditor Members

Public:

Constructor

ContentAlignmentEditor Constructor [To be supplied.]

Properties

Style | [To be supplied.]
Values (inherited from ValueEditor) | [To be supplied.]

Methods

EditValue | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle | Retrieves the CreationBundle for the given value. null will be returned if the value cannot be created from either a static method or constructor call.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from ValueEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ContentAlignmentEditor Class | System.ComponentModel.Design Namespace


ContentAlignmentEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ContentAlignmentEditor();
[C++]
public: ContentAlignmentEditor();
[JScript]
public function ContentAlignmentEditor();

See Also

ContentAlignmentEditor Class | ContentAlignmentEditor Members | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ContentAlignmentEditor Properties

The properties of the ContentAlignmentEditor class are listed below. For a complete list of ContentAlignmentEditor class members, see the ContentAlignmentEditor Members topic.

Public:

Style | [To be supplied.]
Values (inherited from ValueEditor) | [To be supplied.]

See Also

ContentAlignmentEditor Class | System.ComponentModel.Design Namespace


ContentAlignmentEditor.Style

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Style As ValueEditorStyles
[C#]
public ValueEditorStyles Style {override get;}
[C++]
public: __property virtual ValueEditorStyles get_Style();
[JScript]
public function get Style() : ValueEditorStyles;

See Also

ContentAlignmentEditor Class | ContentAlignmentEditor Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ContentAlignmentEditor Methods

The methods of the ContentAlignmentEditor class are listed below. For a complete list of ContentAlignmentEditor class members, see the ContentAlignmentEditor Members topic.

Public:

EditValue | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle | Retrieves the CreationBundle for the given value. null will be returned if the value cannot be created from either a static method or constructor call.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from ValueEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ContentAlignmentEditor Class | System.ComponentModel.Design Namespace


ContentAlignmentEditor.EditValue

[To be supplied.]

[Visual Basic]
Overrides Public Sub EditValue( _
   ByVal iva As IValueAccess _
)
[C#]
public override void EditValue(
   IValueAccess iva
);
[C++]
public: override void EditValue(
   IValueAccess* iva
);
[JScript]
public override function EditValue(
   iva : IValueAccess
);

Parameters

iva
[To be supplied.]

See Also

ContentAlignmentEditor Class | ContentAlignmentEditor Members | System.ComponentModel.Design Namespace


ContentAlignmentEditor.GetCreationBundle

Retrieves the CreationBundle for the given value. null will be returned if the value cannot be created from either a static method or constructor call.

[Visual Basic]
Overrides Public Function GetCreationBundle( _
   ByVal value As Object _
) As CreationBundle
[C#]
public override CreationBundle GetCreationBundle(
   object value
);
[C++]
public: override CreationBundle* GetCreationBundle(
   Object* value
);
[JScript]
public override function GetCreationBundle(
   value : Object
) : CreationBundle;

Parameters

value
[To be supplied.]

See Also

ContentAlignmentEditor Class | ContentAlignmentEditor Members | System.ComponentModel.Design Namespace


ContentAlignmentEditor.GetTextFromValue

[To be supplied.]

[Visual Basic]
Overrides Public Function GetTextFromValue( _
   ByVal value As Object _
) As String
[C#]
public override string GetTextFromValue(
   object value
);
[C++]
public: override String* GetTextFromValue(
   Object* value
);
[JScript]
public override function GetTextFromValue(
   value : Object
) : String;

Parameters

value
[To be supplied.]

See Also

ContentAlignmentEditor Class | ContentAlignmentEditor Members | System.ComponentModel.Design Namespace


ContentAlignmentEditor.EditControl Class

[To be supplied.]

Object
MarshalByRefObject
MarshalByRefComponent
Control
RichControl
ScrollableControl
ContainerControl
UserControl
ContentAlignmentEditor.EditControl

[Visual Basic]
Public Class ContentAlignmentEditor.EditControl
   Inherits UserControl
[C#]
public class ContentAlignmentEditor.EditControl : UserControl
[C++]
public __gc class ContentAlignmentEditor.EditControl : public
   UserControl
[JScript]
public class ContentAlignmentEditor.EditControl extends UserControl

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

ContentAlignmentEditor.EditControl Members | System.ComponentModel.Design Namespace


ContentAlignmentEditor.EditControl Members

Public:

Constructor

ContentAlignmentEditorEditControl Constructor Overloaded. [To be supplied.]

Properties

AccessibilityObject (inherited from RichControl) | The Accessibility Object for this RichControl
AccessibleDefaultActionDescription (inherited from RichControl) | The default action description of the control
AccessibleDescription (inherited from RichControl) | The accessible description of the control
AccessibleHelpProvider (inherited from RichControl) | The help provider for this RichControl
AccessibleName (inherited from RichControl) | The accessible name of the control
AccessibleRole (inherited from RichControl) | The accessible role of the control
ActiveControl (inherited from ContainerControl) | The current active control.
AllowDrop (inherited from RichControl) | The allowDrop property. If allowDrop is set to true then this control will allow drag and drop operations and events to be used.
AllowTransparency (inherited from RichControl) | Determines if the control should be allowed to have the opacity adjusted. This is primarily a performance optimization, in that you can always set the opacity to any value, and that will force AllowTransparency to true. However, setting the opacity to any given value will switch the control into layered mode. By setting the AllowTransparency property to false the control will actually switch out of layered mode, which provides better performance if you don't intend to adjust the opacity.
Anchor (inherited from RichControl) | The current value of the anchor property. The anchor property determines which edges of the control are anchored to the container's edges.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Retrieves the current value of the AutoScrollMinSize property. The AutoScrollMinSize property is used internally to manage the screen size allocated to the automatic scrollbars.
AutoScrollPosition (inherited from ScrollableControl) | Retrieves the current value of the AutoScrollPosition property. The AutoScrollPosition property is used internally to adjust the position of controls that there placed on the Form throughout the form designer.
BackColor (inherited from RichControl) | The background color of this control. This is an ambient property and will always return a non-null value.
BackgroundImage (inherited from RichControl) | The background image of the control.
BindingManager (inherited from ContainerControl) | The binding manager for the container control.
Bindings (inherited from RichControl) | Retrieves the bindings for this control.
Bottom (inherited from Control) | The bottom coordinate of this control.
Bounds (inherited from Control) | The bounds of this control. This is the window coordinates of the control in parent client coordinates.
CanFocus (inherited from Control) | Checks if this control can receive focus. The result is true if the control has a handle and if it and all of its parent controls are both visible and enabled.
CanSelect (inherited from Control) | Checks if this control can be selected. The result is true if the control is contained in a form and if all of its parent controls are both visible and enabled.
Capture (inherited from Control) | If this control has captured the mouse then this will return true.
CausesValidation (inherited from Control) | Indicates whether entering this control causes validation on the controls requiring validation. This is set to false usually for things like the Help button, etc...
ClientRectangle (inherited from Control) | The client rect of the control.
ClientSize (inherited from Control) | The size of the clientRect.
CompanyName (inherited from RichControl) | Retrieves the company name of this specific component.
ContainsFocus (inherited from Control) | Indicates whether the control or one of its children currently has the system focus.
ContextMenu (inherited from RichControl) | The contextMenu associated with this control. The contextMenu will be shown when the user right clicks the mouse on the control.
Controls (inherited from Control) | Collection of child controls.
Created (inherited from Control) | Returns true if the control has been created.
Cursor (inherited from RichControl) | Retrieves the cursor that will be displayed when the mouse is over this control.
DisplayRectangle (inherited from ScrollableControl) | Retreives the current display rectangle. The display rectangle is the virtual display area that is used to layout components. The position and dimensions of the Form's display rectangle change during autoScroll.
Disposed (inherited from Control) | Indicates that the control has been disposed, and is no longer a valid Windows control even though the object instance is still alive.
Disposing (inherited from Control) | Indicates that the control is in the process of being beendisposed, and is no longer a valid Windows control even though the object instance is still alive.
Dock (inherited from RichControl) | The dock property. The dock property controls to which edge of the container this control is docked to. For example, when docked to the top of the container, the control will be displayed flush at the top of the container, extending the length of the container.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | The current enabled state of this control.
Focused (inherited from Control) | Returns true if this control has focus.
Font (inherited from RichControl) | Retrieves the current font for this control. This will be the font used by default for painting and text in the control.
ForeColor (inherited from RichControl) | The foreground color of the control.
Handle (inherited from Control) | The HWND handle that this control is bound to. If the handle has not yet been created, this will force handle creation.
HandleCreated (inherited from Control) | Whether or not this control has a handle associated with it.
Height (inherited from Control) | The height of this control
IMEMode (inherited from RichControl) | Specifies a value that determines the IME (Input Method Editor) status of the object when that object is selected.
InvokeRequired (inherited from RichControl) | Determines if the caller must call invoke when making method calls to this control. Controls in WinForms are bound to a specific thread, and are not thread safe. Therefore, if you are calling a control's method from a different thread, you must use the control's invoke method to marshal the call to the proper thread. This function can be used to determine if you must call invoke, which can be handy if you don't know what thread owns a control. There are five functions on a control that are safe to call from any thread: GetInvokeRequired, Invoke, BeginInvoke, EndInvoke and CreateGraphics. For all other metohd calls, you should use one of the invoke methods.
IsAccessible (inherited from RichControl) | Indicates whether or not this control is an accessible control i.e. whether it should be visible to accessibility applications.
Left (inherited from Control) | The left coordinate of this control.
Location (inherited from Control) | The location of this control.
Opacity (inherited from RichControl) | Determines the opacity of the control. This can only be set on top level controls. Opacity requires Windows 2000 or later, and is ignored on earlier operating systems.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from ContainerControl) | The form that is the visual parent of this form.
ProductName (inherited from RichControl) | Retrieves the product name of this specific component.
ProductVersion (inherited from RichControl) | Retrieves the product version of this specific component.
RecreatingHandle (inherited from Control) | This is true if the control is currently recreating its handle.
Region (inherited from RichControl) | The Region associated with this control. (defines the outline/silhouette/boundary of control)
Right (inherited from Control) | The right coordinate of this control.
RightToLeft (inherited from RichControl) | This is used for international applications where the language is written from RightToLeft. When this property is true, control placement and text will be from right to left.
Site (inherited from MarshalByRefComponent) | Gets or sets the site of the component.
Size (inherited from Control) | The size of this control.
TabIndex (inherited from Control) | The tab index of this control. A tab index may consist of any valid integer number greater than or equal to zero. If more than one control on the same parent control has the same tab index, the z-order of the controls will be used to determine the order to pick the controls.
TabStop (inherited from Control) | A boolean value indicating whether the user can give the focus to this control using the TAB key.
Text (inherited from Control) | The current text associated with this control.
Top (inherited from Control) | Top coordinate of this control.
TopLevel (inherited from Control) | true if this control is a top level window, meaning that it has no parent.
TopLevelControl (inherited from Control) | The top level control that contains this control. This doesn't have to be the same as the value returned from getForm since forms can be parented to other controls.
Visible (inherited from Control) | Controls whether the control is visible.
Width (inherited from Control) | The width of this control.
WindowTarget (inherited from Control) | The target of Win32 window messages.

Methods

ActivateControl (inherited from ContainerControl) | [To be supplied.]
BeginInvoke (inherited from RichControl) | Overloaded. [To be supplied.]
BringToFront (inherited from Control) | Brings this control to the front of the zorder.
CallWndProc (inherited from Control) | Dispatch the method to this window's wndProc directly.
Contains (inherited from Control) | Checks if a control is a child of this control.
CreateControl (inherited from Control) | Forces the creation of the control. This includes the creation of the handle, and any child controls.
CreateGraphics (inherited from RichControl) | Overloaded. [To be supplied.]
CreateWindowGraphics (inherited from RichControl) | Creates a Graphics for the entire window of the control rather than just it's client area. The controls foreground color and background color become the default values for the Graphics. The returned Graphics must be disposed through a call to its dispose() method when it is no longer needed. The Graphics Object is only valid for the duration of the current window's message.
Dispose (inherited from ContainerControl) | Releases all the system resources associated with the Form. If a subclass overrides this function, it must call the super implementation.
DoDragDrop (inherited from RichControl) | Begins a drag operation. The allowedEffects determine which drag operations can occur. If the drag operation needs to interop with applications in another process, data should either be a base managed class (String, Bitmap, or Metafile) or some Object that implements System.ComponentModel.IPersistable. data can also be any Object that implements System.WinForms.IDataObject.
EndInvoke (inherited from RichControl) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult interface passed. If the async operation has not been completed, this function will block until the result is available.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FindForm (inherited from RichControl) | Retrieves the form that this control is on. The control's parent may not be the same as the form.
Focus (inherited from Control) | Attempts to set focus to this control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified client coordinates.
GetContainer (inherited from MarshalByRefComponent) | Returns the component's container.
GetContainerControl (inherited from Control) | Returns the closest ContainerControl in the control's chain of parent controls and forms.
GetDesignMode (inherited from MarshalByRefComponent) | Determines whether the component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetNextControl (inherited from Control) | Retrieves the next control in the tab order of child controls.
GetServiceObject (inherited from MarshalByRefComponent) | The implementation of IServiceObjectProvider
GetType (inherited from Object) | Gets the Type of the Object.
Hide (inherited from Control) | Hides the control by setting the visible property to false;
InitializeLifetimeService (inherited from MarshalByRefObject)
Invalidate (inherited from Control) | Overloaded. [To be supplied.]
Invoke (inherited from RichControl) | Overloaded. [To be supplied.]
PerformLayout (inherited from Control) | Overloaded. [To be supplied.]
PointToClient (inherited from Control) | Computes the location of the screen point p in client coords.
PointToScreen (inherited from Control) | Computes the location of the client point p in screen coords.
PreProcessMessage (inherited from Control) | This method is called by the application's message loop to pre-process input messages before they are dispatched. Possible values for the msg.message field are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR. If this method processes the message it must return true, in which case the message loop will not dispatch the message. For WM_KEYDOWN and WM_SYSKEYDOWN messages, preProcessMessage() first calls processCmdKey() to check for command keys such as accelerators and menu shortcuts. If processCmdKey() doesn't process the message, then isInputKey() is called to check whether the key message represents an input key for the control. Finally, if isInputKey() indicates that the control isn't interested in the key message, then processDialogKey() is called to check for dialog keys such as TAB, arrow keys, and mnemonics. For WM_CHAR messages, preProcessMessage() first calls isInputChar() to check whether the character message represents an input character for the control. If isInputChar() indicates that the control isn't interested in the character message, then processDialogChar() is called to check for dialog characters such as mnemonics. For WM_SYSCHAR messages, preProcessMessage() calls processDialogChar() to check for dialog characters such as mnemonics. When overriding preProcessMessage(), a control should return true to indicate that it has processed the message. For messages that aren't processed by the control, the result of "base.preProcessMessage()" should be returned. Controls will typically override one of the more specialized methods (isInputChar(), isInputKey(), processCmdKey(), processDialogChar(), or processDialogKey()) instead of overriding preProcessMessage().
RectangleToClient (inherited from Control) | Computes the location of the screen rectangle r in client coords.
RectangleToScreen (inherited from Control) | Computes the location of the client rectangle r in screen coords.
Refresh (inherited from Control) | Forces the control to invalidate and immediately repaint itself and any children.
ResetBackColor (inherited from RichControl) | Resets the back color to be based on the parent's back color.
ResetBindings (inherited from RichControl) | [To be supplied.]
ResetCursor (inherited from RichControl) | [To be supplied.]
ResetFont (inherited from RichControl) | Resets the font to be based on the parent's font.
ResetForeColor (inherited from RichControl) | Resets the fore color to be based on the parent's fore color.
ResetRightToLeft (inherited from RichControl) | Resets the RightToLeft to be the default.
ResetText (inherited from Control) | Resets the text to it's default value.
ResumeLayout (inherited from Control) | Overloaded. [To be supplied.]
Scale (inherited from Control) | Overloaded. [To be supplied.]
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the currently active control into view if we are an AutoScroll Form that has the Horiz or Vert scrollbar displayed...
Select (inherited from Control) | Activates this control.
SelectNextControl (inherited from Control) | Selects the next control following ctl.
SendMessage (inherited from Control) | Overloaded. [To be supplied.]
SendToBack (inherited from Control) | sends this control to the back of the z-order
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. [To be supplied.]
SetClientSize (inherited from Control) | Sets the height and width of the client area of the control.
SetLocation (inherited from Control) | Sets the location of this control.
SetNewControls (inherited from Control) | Performs the work of setting the array of the child controls contained in this control.
SetSize (inherited from Control) | Sets the size of this control.
ShouldPersistAutoScrollMargin (inherited from ScrollableControl) | Indicates whether the AutoScrollMargin property should be persisted.
ShouldPersistAutoScrollMinSize (inherited from ScrollableControl) | Indicates whether the AutoScrollMinSize property should be persisted.
ShouldPersistAutoScrollPosition (inherited from ScrollableControl) | Indicates whether the AutoScrollPosition property should be persisted.
ShouldPersistBackColor (inherited from RichControl) | Returns true if the backColor should be persisted in code gen.
ShouldPersistBindings (inherited from RichControl) | [To be supplied.]
ShouldPersistCursor (inherited from RichControl) | Returns true if the cursor should be persisted in code gen.
ShouldPersistFont (inherited from RichControl) | Returns true if the font should be persisted in code gen.
ShouldPersistForeColor (inherited from RichControl) | Returns true if the foreColor should be persisted in code gen.
ShouldPersistLocation (inherited from Control) | Determines if the Location property needs to be persisted.
ShouldPersistRightToLeft (inherited from RichControl) | Returns true if the RightToLeft should be persisted in code gen.
ShouldPersistSize (inherited from Control) | Determines if the Size property needs to be persisted.
ShouldPersistText (inherited from Control) | Determines if the Text property needs to be persisted.
Show (inherited from Control) | Makes the control display by setting the visible property to true
SuspendLayout (inherited from Control) | Suspends the layout logic for the control.
ToString (inherited from MarshalByRefComponent) | Basic Implementation of toString() for all controls.
Update (inherited from Control) | Forces the control to paint any currently invalid areas.
Validate (inherited from ContainerControl) | Validates the last unvalidated control and it's ancestors up through (but not including) this.

Events

Click (inherited from Control) | [To be supplied.]
ControlAdded (inherited from Control) | [To be supplied.]
ControlRemoved (inherited from Control) | [To be supplied.]
CreateHandle (inherited from Control) | [To be supplied.]
DestroyHandle (inherited from Control) | [To be supplied.]
DoubleClick (inherited from Control) | [To be supplied.]
DragDrop (inherited from RichControl) | [To be supplied.]
DragEnter (inherited from RichControl) | [To be supplied.]
DragLeave (inherited from RichControl) | [To be supplied.]
DragOver (inherited from RichControl) | [To be supplied.]
Enter (inherited from Control) | [To be supplied.]
GiveFeedback (inherited from RichControl) | [To be supplied.]
GotFocus (inherited from Control) | [To be supplied.]
Help (inherited from RichControl) | [To be supplied.]
Invalidate (inherited from RichControl) | [To be supplied.]
KeyDown (inherited from Control) | [To be supplied.]
KeyPress (inherited from Control) | [To be supplied.]
KeyUp (inherited from Control) | [To be supplied.]
Layout (inherited from Control) | [To be supplied.]
Leave (inherited from Control) | [To be supplied.]
LostFocus (inherited from Control) | [To be supplied.]
MouseDown (inherited from Control) | [To be supplied.]
MouseEnter (inherited from Control) | [To be supplied.]
MouseHover (inherited from Control) | [To be supplied.]
MouseLeave (inherited from Control) | [To be supplied.]
MouseMove (inherited from Control) | [To be supplied.]
MouseUp (inherited from Control) | [To be supplied.]
MouseWheel (inherited from Control) | [To be supplied.]
Move (inherited from Control) | [To be supplied.]
Paint (inherited from UserControl) | [To be supplied.]
PropertyChanged (inherited from Control) | [To be supplied.]
QueryContinueDrag (inherited from RichControl) | [To be supplied.]
Resize (inherited from Control) | [To be supplied.]
Validated (inherited from Control) | [To be supplied.]
Validating (inherited from Control) | [To be supplied.]

Protected:

Properties

CreateParams (inherited from ScrollableControl) | Retrieves the CreateParams used to create the window. If a subclass overrides this function, it must call the super implementation.
CreateThreadId (inherited from Control) | Retrieves the Win32 thread ID of the thread that created the handle for this control. If the control's handle hasn't been created yet, this method will return the current thread's ID.
FontHeight (inherited from RichControl) | [To be supplied.]
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
InternalHandle (inherited from Control) | Returns the current value of the handle. This may be zero if the handle has not been created.
ParkingFormHandle (inherited from RichControl) | [To be supplied.]
RenderRightToLeft (inherited from RichControl) | [To be supplied.]
RichParent (inherited from RichControl) | [To be supplied.]
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.
WindowText (inherited from Control) | The current text of the Window; if the window has not yet been created, stores it in the control. If the window has been created, stores the text in the underlying win32 control. This property should be used whenever you want to get at the win32 control's text. For all other cases, use the Text property- but note that this is overridable, and any of your code that uses it will use the overridden version in controls that subclass your own.

Methods

AddEventHandler (inherited from Control) | [To be supplied.]
AdjustFormScrollbars (inherited from ContainerControl) | [To be supplied.]
AssignParent (inherited from RichControl) | Assigns a new parent control. Sends out the appropriate property change notifications for properties that are affected by the change of parent.
ChildGotFocus (inherited from Control) | [To be supplied.]
CreateAccessibilityInstance (inherited from RichControl) | Constructs the new instance of the accessibility object for this control. Subclasses should not call base.CreateAccessibilityObject.
CreateControlsInstance (inherited from RichControl) | Constructs the new instance of the Controls collection objects. Subclasses should not call base.CreateControlsInstance.
CreateHandle (inherited from Control) | Creates a handle for this control. This method is called by the framework, this should not be called. Inheriting classes should always call base.createHandle when overriding this method.
DefWndProc (inherited from Control) | Sends the message to the default window proc.
DestroyHandle (inherited from RichControl) | [To be supplied.]
Finalize (inherited from Control) | [To be supplied.]
GetEventHandler (inherited from RichControl) | RichControl overrides the default implementation of this for AX sourcing. ActiveX controls can "freeze" their events, and we implement this by returning null here if events are frozen.
GetScrollState (inherited from ScrollableControl) | Tests a given scroll state bit to determine if it is set.
GetStyle (inherited from Control) | Retrieves the current value of the specified bit in the control's style. NOTE: This is control style, not the Win32 style of the hwnd.
InitLayout (inherited from RichControl) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | [To be supplied.]
InvokeLostFocus (inherited from Control) | [To be supplied.]
InvokeOnClick (inherited from Control) | [To be supplied.]
InvokePaint (inherited from RichControl) | [To be supplied.]
InvokePaintBackground (inherited from RichControl) | [To be supplied.]
IsInputChar (inherited from Control) | Determines if charCode is an input character that the control wants. This method is called during window message pre-processing to determine whether the given input character should be pre-processed or sent directly to the control. If isInputChar returns true, the given character is sent directly to the control. If isInputChar returns false, the character is pre-processed and only sent to the control if it is not consumed by the pre-processing phase. The pre-processing of a character includes checking whether the character is a mnemonic of another control.
IsInputKey (inherited from Control) | Determines if keyData is an input key that the control wants. This method is called during window message pre-processing to determine whether the given input key should be pre-processed or sent directly to the control. If isInputKey returns true, the given key is sent directly to the control. If isInputKey returns false, the key is pre-processed and only sent to the control if it is not consumed by the pre-processing phase. Keys that are pre-processed include TAB, RETURN, ESCAPE, and arrow keys.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from RichControl) | [To be supplied.]
OnClick (inherited from Control) | This method actually raises the Click event. Inheriting classes should override this if they wish to be notified of a Click event. (This is far preferable to actually adding an event handler.) They should not, however, forget to call base.onClick(e); before exiting, to ensure that other recipients do actually get the event.
OnControlAdded (inherited from Control) | Called when a child control is added to this control.
OnControlRemoved (inherited from ContainerControl) | Called when a child control is removed from this control.
OnCreateControl (inherited from Control) | Called when the control is first created.
OnCreateHandle (inherited from RichControl) | Inheriting classes should override this method to find out when the handle has been created. Call base.onCreateHandle first.
OnDestroyHandle (inherited from RichControl) | Inheriting classes should override this method to find out when the handle is about to be destroyed. Call base.onDestroyHandle last.
OnDoubleClick (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onDoubleClick to send this event to any registered event listeners.
OnDragDrop (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragDrop to send this event to any registered event listeners.
OnDragEnter (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragEnter to send this event to any registered event listeners.
OnDragLeave (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragLeave to send this event to any registered event listeners.
OnDragOver (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragOver to send this event to any registered event listeners.
OnEnter (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onEnter to send this event to any registered event listeners.
OnGiveFeedback (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onGiveFeedback to send this event to any registered event listeners.
OnGotFocus (inherited from RichControl) | [To be supplied.]
OnHelp (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onHelp to send this event to any registered event listeners.
OnInvalidate (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.OnInvalidate to send this event to any registered event listeners.
OnKeyDown (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onKeyDown to send this event to any registered event listeners.
OnKeyPress (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.OnKeyPress to send this event to any registered event listeners.
OnKeyUp (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onKeyUp to send this event to any registered event listeners.
OnLayout (inherited from ScrollableControl) | Forces the layout of any docked or anchored child controls.
OnLeave (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onLeave to send this event to any registered event listeners.
OnLostFocus (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onLostFocus to send this event to any registered event listeners.
OnMouseDown (inherited from UserControl) | [To be supplied.]
OnMouseEnter (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseEnter to send this event to any registered event listeners.
OnMouseHover (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseHover to send this event to any registered event listeners.
OnMouseLeave (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseLeave to send this event to any registered event listeners.
OnMouseMove (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseMove to send this event to any registered event listeners.
OnMouseUp (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseUp to send this event to any registered event listeners.
OnMouseWheel (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseWheel to send this event to any registered event listeners.
OnMove (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMove to send this event to any registered event listeners.
OnPaint (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onPaint to send this event to any registered event listeners.
OnPaintBackground (inherited from RichControl) | Inheriting classes should override this method to handle the erase background request from windows. It is not necessary to call base.onPaintBackground, however if you do not want the default Windows behavior you must set event.handled to true.
OnParentPropertyChanged (inherited from RichControl) | This method is called by the parent control when any property changes on the parent. This can be overriden by inheriting classes, however they must call base.OnParentPropertyChanged.
OnPropertyChanged (inherited from RichControl) | [To be supplied.]
OnQueryContinueDrag (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onQueryContinueDrag to send this event to any registered event listeners.
OnResize (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onResize to send this event to any registered event listeners.
OnValidated (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onResize to send this event to any registered event listeners.
OnValidating (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onResize to send this event to any registered event listeners.
ParentChanged (inherited from Control) | Called by the framework after a control's parent changes. This allows (for example) child controls to automatically hook events on their parent, giving better encapsulation.
ProcessCmdKey (inherited from RichControl) | [To be supplied.]
ProcessDialogChar (inherited from ContainerControl) | Processes a dialog character. Overrides Control.processDialogChar(). This method calls the processMnemonic() method to check if the character is a mnemonic for one of the controls on the form. If processMnemonic() does not consume the character, then base.processDialogChar() is called.
ProcessDialogKey (inherited from ContainerControl) | Processes a dialog key. Overrides Control.processDialogKey(). This method implements handling of the TAB, LEFT, RIGHT, UP, and DOWN keys in dialogs. The method performs no processing on keys that include the ALT or CONTROL modifiers. For the TAB key, the method selects the next control on the form. For the arrow keys, !!!
ProcessKeyEventArgs (inherited from Control) | Processes a key message. This method is called when a control receives a keyboard message. The method is responsible for generating the appropriate key events for the message by calling OnKeyPress(), onKeyDown(), or onKeyUp(). The m parameter contains the window message that must be processed. Possible values for the m.msg field are WM_CHAR, WM_KEYDOWN, WM_SYSKEYDOWN, WM_KEYUP, WM_SYSKEYUP, and WM_IMECHAR. When overriding processKeyEventArgs(), a control should return true to indicate that it has processed the key. For keys that aren't processed by the control, the result of "base.processKeyEventArgs()" should be returned. Controls will seldom, if ever, need to override this method.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message. This method is called by a child control when the child control receives a keyboard message. The child control calls this method before generating any keyboard events for the message. If this method returns true, the child control considers the message consumed and does not generate any keyboard events. The m parameter contains the window message to preview. Possible values for the m.msg field are WM_CHAR, WM_KEYDOWN, WM_SYSKEYDOWN, WM_KEYUP, and WM_SYSKEYUP. processKeyPreview() simply sends the character to the parent's processKeyPreview() method, or returns false if the control has no parent. The Form class overrides this method to perform actual processing of dialog keys. When overriding processKeyPreview(), a control should return true to indicate that it has processed the key. For keys that aren't processed by the control, the result of "base.processKeyEventArgs()" should be returned.
ProcessMnemonic (inherited from ContainerControl) | UNDONE: ChrisAn, 12/13/1997- Need description 'processMnemonic'
ProcessTabKey (inherited from ContainerControl) | UNDONE: ChrisAn, 12/13/1997- Need description 'processTabKey'
RaiseDragEventArgs (inherited from RichControl) | Raises the event associated with key with the event data of e and a sender of this control.
RaiseEvent (inherited from Control) | [To be supplied.]
RaiseKeyEventArgs (inherited from Control) | Raises the event associated with key with the event data of e and a sender of this control.
RaiseMouseEventArgs (inherited from Control) | Raises the event associated with key with the event data of e and a sender of this control.
RaisePaintEventArgs (inherited from RichControl) | Raises the event associated with key with the event data of e and a sender of this control.
RaisePropertyChangedEvent (inherited from Control) | Raises the property changed event. This creates the needed event data and then calls OnPropertyChanged.
RecreateHandle (inherited from Control) | Forces the recreation of the handle for this control. Inheriting controls must call base.recreateHandle.
RemoveEventHandler (inherited from Control) | [To be supplied.]
RemoveEventHandlers (inherited from Control) | [To be supplied.]
ResetMouseEventArgs (inherited from Control) | Resets the mouse leave listeners.
ResumeLayout (inherited from Control) | Overloaded. [To be supplied.]
RTLTranslateAlignment (inherited from RichControl) | Overloaded. [To be supplied.]
RTLTranslateContent (inherited from RichControl) | [To be supplied.]
RTLTranslateHorizontal (inherited from RichControl) | [To be supplied.]
RTLTranslateLeftRight (inherited from RichControl) | [To be supplied.]
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
SendMessage (inherited from Control) | Overloaded. [To be supplied.]
SetBoundsCore (inherited from RichControl) | [To be supplied.]
SetClientSizeCore (inherited from Control) | Performs the work of setting the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Adjusts the displayRect to be at the offset x, y. The contents of the Form is scrolled using Windows.ScrollWindowEx.
SetScrollState (inherited from ScrollableControl) | Sets a given scroll state bit.
SetStyle (inherited from Control) | Sets the current value of the specified bit in the control's style. NOTE: This is control style, not the Win32 style of the hwnd.
UpdateBounds (inherited from Control) | Overloaded. [To be supplied.]
UpdateDefaultButton (inherited from ContainerControl) | Updates the default button based on current selection, and the acceptButton property.
UpdateStyles (inherited from Control) | Forces styles to be reapplied to the handle. This function will call CreateParams to get the styles to apply.
UpdateZOrder (inherited from Control) | Updates this control in it's parent's zorder.
WmSysColorChange (inherited from Control) | Handles the WM_SYSCOLORCHANGE message
WndProc (inherited from UserControl) | [To be supplied.]
WndProcException (inherited from RichControl) | [To be supplied.]

Event Hookup:

Methods

AddOnClick (inherited from Control) | Adds an event handler for the click event. The click event occurs when the user clicks in the client area of the control.
AddOnControlAdded (inherited from Control) | Adds an event handler for the ControlAdded event. This event is raised after a control is added as a child to this control.
AddOnControlRemoved (inherited from Control) | Adds an event handler for the ControlRemoved event. This event is raised after a child control is removed from this control.
AddOnCreateHandle (inherited from Control) | Adds an event handler for the createHandle event. The createHandle event occurs immediately after the control's handle is created.
AddOnDestroyHandle (inherited from Control) | Adds an event handler for the destroyHandle event. The destroyHandle event occurs immediately before the control's handle is destroyed.
AddOnDoubleClick (inherited from Control) | Adds an event handler for the doubleClick event. The doubleClick event occurs when the user double clicks in the client area of the control.
AddOnDragDrop (inherited from RichControl) | Adds an event handler for the dragDrop event. The dragDrop evnet occurs when the user releases the mouse button while dragging some Object over the control.
AddOnDragEnter (inherited from RichControl) | Adds an event handler for the dragEnter event. The drawEnter event occurs when the user first moves the mouse over the control while dragging some Object.
AddOnDragLeave (inherited from RichControl) | Adds an event handler for the dragLeave event. The dragLeave event occurs when the user first moves the mouse out of the control while dragging some Object.
AddOnDragOver (inherited from RichControl) | Adds an event handler for the dragOver event. The dragOver event occurs whenever the user moves the mouse over the control while draggin some Object.
AddOnEnter (inherited from Control) | Adds an event handler for the enter event. The enter event occurs when focus enters this control. This doesn't imply that this control has focus, but rather that this control or some child control of this control has gotten focus.
AddOnGiveFeedback (inherited from RichControl) | Adds an event handler for the giveFeedback event. The giveFeedback event occurs during a drag operation. This allows the source of a drag event to modify the mouse pointer to give the user visual feedback as to what would happen if they droped.
AddOnGotFocus (inherited from Control) | Adds an event handler for the gotFocus event. The gotFocus event occurs when the this control gains focus.
AddOnHelp (inherited from RichControl) | Adds an event handler for the help event. The help event occurs when the user requests help for this control. This may be caused by the user pressing F1, or used "Whats This Help".
AddOnInvalidate (inherited from RichControl) | Adds an event handler for the invalidate event. The invalidate event occurs when the Invalidate method is called on some part of the control's client area. This event may be used to identify when the contents of a window have changed.
AddOnKeyDown (inherited from Control) | Adds an event handler for the keyDown event. The keyDown event occurs when the user presses a key down.
AddOnKeyPress (inherited from Control) | Adds an event handler for the keyPress event. The keyPress event occurs when the user presses a key.
AddOnKeyUp (inherited from Control) | Adds an event handler for the keyUp event. The keyUp event occurs when the user releases a key.
AddOnLayout (inherited from Control) | Adds an event handler for the layout event. The layout event occurs when any event occurs that would cause the control to layout child controls. These events include; resize, show/hide child controls, add/remove child controls. This event should be used to perform any custom layout logic.
AddOnLeave (inherited from Control) | Adds an event handler for the leave event. The leave event occurs when focus leaves this control. This doesn't imply that this control lost focus, but rather that focus has been moved out of this control and any child controls.
AddOnLostFocus (inherited from Control) | Adds an event handler for the lostFocus event. The lostFocus event occurs when this control looses focus.
AddOnMouseDown (inherited from Control) | Adds an event handler for the mouseDown event. The mouseDown event occurs when the user presses the mouseDown over this control.
AddOnMouseEnter (inherited from Control) | Adds an event handler for the mouseEnter event. The mouseEnter event occurs when the mouse first moves over this control.
AddOnMouseHover (inherited from Control) | Adds an event handler for the mouseHover event. The mouseHover event occurs after the mouse is inside a control for an amount.
AddOnMouseLeave (inherited from Control) | Adds an event handler for the mouseLeave event. The mouseLeave event occurs when the mouse first moves out of this control.
AddOnMouseMove (inherited from Control) | Adds an event handler for the mouseMove event. The mouseMove event occurs whenever the user moves the mouse over this control.
AddOnMouseUp (inherited from Control) | Adds an event handler for the mouseUp event. The mouseUp event occurs when the user releases a mouse button inside the control.
AddOnMouseWheel (inherited from Control) | Adds an event handler for the mouseWheel event. The mouseWheel event occurs when the user scrolls the mouse wheel up or down. The delta value in the event data indicates the amount that the mouse wheel has moved. The Microsoft standards indicate that the view should scroll by System.WinForms.SystemInformation.getMouseWheelScrollLines() when the delta value has reach win.WHEEL_DELTA. If a mouseWheel event occurs with a value less that WHEEL_DELTA, the control should either increment a stored value and wait until the total delta is an increment of WHEEL_DELTA, or scroll the view a percentage of MouseWheelScrollLines. NOTE: A press of the mouseWheel will generate a mouseDown event with the middle button pressed.
AddOnMove (inherited from Control) | Adds an event handler for the move event. The move event occurs when the controls location changes.
AddOnPaint (inherited from UserControl) | [To be supplied.]
AddOnPropertyChanged (inherited from Control) | Adds an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.
AddOnQueryContinueDrag (inherited from RichControl) | Adds an event handler for the queryContinueDrag event. The queryContinueDrag event occurs during a drag operation. This allows the drag source to determine if the drag operation should be canceled.
AddOnResize (inherited from Control) | Adds an event handler for the resize event. The resize event occurs when the bounds of the control change. This event may be fired from the constructor of base controls.
AddOnValidated (inherited from Control) | Adds an event handler for the validated event. The validated event occurs when a control was successfully validated.
AddOnValidating (inherited from Control) | Adds an event handler for the validating event. The validating event occurs when the control loses focus and a control that causes validation gains focus. This is where users can write code to validate the current values of the control.
RemoveOnClick (inherited from Control) | Removes the given handler for the "OnClick" event. If there are duplicate entries, ALL are removed.
RemoveOnControlAdded (inherited from Control) | Removes the given handler for the "ControlAdded" event. If there are duplicate entries, ALL are removed.
RemoveOnControlRemoved (inherited from Control) | Removes the given handler for the "ControlRemoved" event. If there are duplicate entries, ALL are removed.
RemoveOnCreateHandle (inherited from Control) | Removes the given handler for the "createHandle" event. If there are duplicate entries, ALL are removed.
RemoveOnDestroyHandle (inherited from Control) | Removes the given handler for the "destroyHandle" event. If there are duplicate entries, ALL are removed.
RemoveOnDoubleClick (inherited from Control) | Removes the given handler for the "OnDoubleClick" event. If there are duplicate entries, ALL are removed.
RemoveOnDragDrop (inherited from RichControl) | Removes the given handler for the "dragDrop" event. If there are duplicate entries, ALL are removed.
RemoveOnDragEnter (inherited from RichControl) | Removes the given handler for the "OnDragEnter" event. If there are duplicate entries, ALL are removed.
RemoveOnDragLeave (inherited from RichControl) | Removes the given handler for the "OnDragLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnDragOver (inherited from RichControl) | f final Removes the given handler for the "OnDragOver" event. If there are duplicate entries, ALL are removed.
RemoveOnEnter (inherited from Control) | Removes the given handler for the "OnEnter" event. If there are dfinal uplicate entries, ALL are removed.
RemoveOnGiveFeedback (inherited from RichControl) | Removes the given handler for the "OnGiveFeedback" event. If there are duplicate entries, ALL are removed.
RemoveOnGotFocus (inherited from Control) | Removes the given handler for the "OnGotFocus" event. If there are duplicate entries, ALL are removed.
RemoveOnHelp (inherited from RichControl) | Removes the given handler for the "OnHelp" event. If there are duplicate entries, ALL are removed.
RemoveOnInvalidate (inherited from RichControl) | Removes the given handler for the "OnInvalidate" event. If there are duplicate entries, ALL are removed.
RemoveOnKeyDown (inherited from Control) | Removes the given handler for the "OnKeyDown" event. If there are duplicate entries, ALL are removed.
RemoveOnKeyPress (inherited from Control) | Removes the given handler for the "OnKeyPress" event. If there are duplicate entries, ALL are removed.
RemoveOnKeyUp (inherited from Control) | Removes the given handler for the "OnKeyUp" event. If there are duplicate entries, ALL are removed.
RemoveOnLayout (inherited from Control) | Removes the given handler for the layout event. If there are duplicate entries, ALL are removed.
RemoveOnLeave (inherited from Control) | Removes the given handler for the "OnLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnLostFocus (inherited from Control) | Removes the given handler for the "OnLostFocus" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseDown (inherited from Control) | Removes the given handler for the "OnMouseDown" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseEnter (inherited from Control) | Removes the given handler for the "OnMouseEnter" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseHover (inherited from Control) | Removes the given handler for the "OnMouseHover" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseLeave (inherited from Control) | Removes the given handler for the "OnMouseLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseMove (inherited from Control) | Removes the given handler for the "OnMouseMove" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseUp (inherited from Control) | Removes the given handler for the "OnMouseUp" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseWheel (inherited from Control) | Removes the given handler for the "OnMouseWheel" event. If there are duplicate entries, ALL are removed.
RemoveOnMove (inherited from Control) | Removes the given handler for the "OnMove" event. If there are duplicate entries, ALL are removed.
RemoveOnPaint (inherited from RichControl) | Removes the given handler for the "OnPaint" event. If there are duplicate entries, ALL are removed.
RemoveOnPropertyChanged (inherited from Control) | Removes an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.
RemoveOnQueryContinueDrag (inherited from RichControl) | Removes the given handler for the "OnQueryContinueDrag" event. If there are duplicate entries, ALL are removed.
RemoveOnResize (inherited from Control) | Removes the given handler for the "OnResize" event. If there are duplicate entries, ALL are removed.
RemoveOnValidated (inherited from Control) | Removes an event handler for the validated event. The validated event occurs when a control was successfully validated.
RemoveOnValidating (inherited from Control) | Removes an event handler for the validating event. The validating event occurs when the control loses focus and a control that causes validation gains focus. This is where users can write code to validate the current values of the control.

See Also

ContentAlignmentEditor.EditControl Class | System.ComponentModel.Design Namespace


ContentAlignmentEditor.EditControl Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public ContentAlignmentEditor.EditControl();
[C++] public: ContentAlignmentEditor.EditControl();
[JScript] public function ContentAlignmentEditor.EditControl();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(ContentAlignmentEditor, ContentAlignment)
[C#] public ContentAlignmentEditor.EditControl(ContentAlignmentEditor, ContentAlignment);
[C++] public: ContentAlignmentEditor.EditControl(ContentAlignmentEditor*, ContentAlignment);
[JScript] public function ContentAlignmentEditor.EditControl(ContentAlignmentEditor, ContentAlignment);

See Also

ContentAlignmentEditor.EditControl Class | ContentAlignmentEditor.EditControl Members | System.ComponentModel.Design Namespace


ContentAlignmentEditor.EditControl Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public ContentAlignmentEditor.EditControl();
[C++]
public: ContentAlignmentEditor.EditControl();
[JScript]
public function ContentAlignmentEditor.EditControl();

See Also

ContentAlignmentEditor.EditControl Class | ContentAlignmentEditor.EditControl Members | System.ComponentModel.Design Namespace | ContentAlignmentEditor.EditControl Constructor Overload List


ContentAlignmentEditor.EditControl Constructor (ContentAlignmentEditor, ContentAlignment)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal parent As ContentAlignmentEditor, _
   ByVal align As ContentAlignment _
)
[C#]
public ContentAlignmentEditor.EditControl(
   ContentAlignmentEditor parent,
   ContentAlignment align
);
[C++]
public: ContentAlignmentEditor.EditControl(
   ContentAlignmentEditor* parent,
   ContentAlignment align
);
[JScript]
public function ContentAlignmentEditor.EditControl(
   parent : ContentAlignmentEditor,
   align : ContentAlignment
);

Parameters

parent
[To be supplied.]
align
[To be supplied.]

See Also

ContentAlignmentEditor.EditControl Class | ContentAlignmentEditor.EditControl Members | System.ComponentModel.Design Namespace | ContentAlignmentEditor.EditControl Constructor Overload List


CultureInfoEditor Class

[To be supplied.]

Object
ValueEditor
CultureInfoEditor

[Visual Basic]
Public Class CultureInfoEditor
   Inherits ValueEditor
[C#]
public class CultureInfoEditor : ValueEditor
[C++]
public __gc class CultureInfoEditor : public ValueEditor
[JScript]
public class CultureInfoEditor extends ValueEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

CultureInfoEditor Members | System.ComponentModel.Design Namespace


CultureInfoEditor Members

Public:

Constructor

CultureInfoEditor Constructor [To be supplied.]

Properties

Style | [To be supplied.]
Values | [To be supplied.]

Methods

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CultureInfoEditor Class | System.ComponentModel.Design Namespace


CultureInfoEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CultureInfoEditor();
[C++]
public: CultureInfoEditor();
[JScript]
public function CultureInfoEditor();

See Also

CultureInfoEditor Class | CultureInfoEditor Members | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CultureInfoEditor Properties

The properties of the CultureInfoEditor class are listed below. For a complete list of CultureInfoEditor class members, see the CultureInfoEditor Members topic.

Public:

Style | [To be supplied.]
Values | [To be supplied.]

See Also

CultureInfoEditor Class | System.ComponentModel.Design Namespace


CultureInfoEditor.Style

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Style As ValueEditorStyles
[C#]
public ValueEditorStyles Style {override get;}
[C++]
public: __property virtual ValueEditorStyles get_Style();
[JScript]
public function get Style() : ValueEditorStyles;

See Also

CultureInfoEditor Class | CultureInfoEditor Members | System.ComponentModel.Design Namespace


CultureInfoEditor.Values

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Values As Object ()
[C#]
public object[] Values {override get;}
[C++]
public: __property virtual Object* get_Values();
[JScript]
public function get Values() : Object[];

See Also

CultureInfoEditor Class | CultureInfoEditor Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CultureInfoEditor Methods

The methods of the CultureInfoEditor class are listed below. For a complete list of CultureInfoEditor class members, see the CultureInfoEditor Members topic.

Public:

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CultureInfoEditor Class | System.ComponentModel.Design Namespace


CultureInfoEditor.GetCreationBundle

[To be supplied.]

[Visual Basic]
Overrides Public Function GetCreationBundle( _
   ByVal value As Object _
) As CreationBundle
[C#]
public override CreationBundle GetCreationBundle(
   object value
);
[C++]
public: override CreationBundle* GetCreationBundle(
   Object* value
);
[JScript]
public override function GetCreationBundle(
   value : Object
) : CreationBundle;

Parameters

value
[To be supplied.]

See Also

CultureInfoEditor Class | CultureInfoEditor Members | System.ComponentModel.Design Namespace


CultureInfoEditor.GetTextFromValue

[To be supplied.]

[Visual Basic]
Overrides Public Function GetTextFromValue( _
   ByVal value As Object _
) As String
[C#]
public override string GetTextFromValue(
   object value
);
[C++]
public: override String* GetTextFromValue(
   Object* value
);
[JScript]
public override function GetTextFromValue(
   value : Object
) : String;

Parameters

value
[To be supplied.]

See Also

CultureInfoEditor Class | CultureInfoEditor Members | System.ComponentModel.Design Namespace


CultureInfoEditor.GetValueFromText

[To be supplied.]

[Visual Basic]
Overrides Public Function GetValueFromText( _
   ByVal text As String _
) As Object
[C#]
public override object GetValueFromText(
   string text
);
[C++]
public: override Object* GetValueFromText(
   String* text
);
[JScript]
public override function GetValueFromText(
   text : String
) : Object;

Parameters

text
[To be supplied.]

See Also

CultureInfoEditor Class | CultureInfoEditor Members | System.ComponentModel.Design Namespace


CurrencyEditor Class

[To be supplied.]

Object
ValueEditor
CurrencyEditor

[Visual Basic]
Public Class CurrencyEditor
   Inherits ValueEditor
[C#]
public class CurrencyEditor : ValueEditor
[C++]
public __gc class CurrencyEditor : public ValueEditor
[JScript]
public class CurrencyEditor extends ValueEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

CurrencyEditor Members | System.ComponentModel.Design Namespace


CurrencyEditor Members

Public:

Constructor

CurrencyEditor Constructor [To be supplied.]

Properties

Style (inherited from ValueEditor) | [To be supplied.]
Values (inherited from ValueEditor) | [To be supplied.]

Methods

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from ValueEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from ValueEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CurrencyEditor Class | System.ComponentModel.Design Namespace


CurrencyEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CurrencyEditor();
[C++]
public: CurrencyEditor();
[JScript]
public function CurrencyEditor();

See Also

CurrencyEditor Class | CurrencyEditor Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CurrencyEditor Methods

The methods of the CurrencyEditor class are listed below. For a complete list of CurrencyEditor class members, see the CurrencyEditor Members topic.

Public:

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from ValueEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from ValueEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CurrencyEditor Class | System.ComponentModel.Design Namespace


CurrencyEditor.GetTextFromValue

[To be supplied.]

[Visual Basic]
Overrides Public Function GetTextFromValue( _
   ByVal value As Object _
) As String
[C#]
public override string GetTextFromValue(
   object value
);
[C++]
public: override String* GetTextFromValue(
   Object* value
);
[JScript]
public override function GetTextFromValue(
   value : Object
) : String;

Parameters

value
[To be supplied.]

See Also

CurrencyEditor Class | CurrencyEditor Members | System.ComponentModel.Design Namespace


DatePickerEditor Class

This is a value editor bringing up a dialog with calendar control in it for user to pick a date.

Object
ValueEditor
DatePickerEditor

[Visual Basic]
Public Class DatePickerEditor
   Inherits ValueEditor
[C#]
public class DatePickerEditor : ValueEditor
[C++]
public __gc class DatePickerEditor : public ValueEditor
[JScript]
public class DatePickerEditor extends ValueEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

DatePickerEditor Members | System.ComponentModel.Design Namespace


DatePickerEditor Members

Public:

Constructor

DatePickerEditor Constructor [To be supplied.]

Properties

Style | [To be supplied.]
Values (inherited from ValueEditor) | [To be supplied.]

Methods

EditValue | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from ValueEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DatePickerEditor Class | System.ComponentModel.Design Namespace


DatePickerEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public DatePickerEditor();
[C++]
public: DatePickerEditor();
[JScript]
public function DatePickerEditor();

See Also

DatePickerEditor Class | DatePickerEditor Members | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DatePickerEditor Properties

The properties of the DatePickerEditor class are listed below. For a complete list of DatePickerEditor class members, see the DatePickerEditor Members topic.

Public:

Style | [To be supplied.]
Values (inherited from ValueEditor) | [To be supplied.]

See Also

DatePickerEditor Class | System.ComponentModel.Design Namespace


DatePickerEditor.Style

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Style As ValueEditorStyles
[C#]
public ValueEditorStyles Style {override get;}
[C++]
public: __property virtual ValueEditorStyles get_Style();
[JScript]
public function get Style() : ValueEditorStyles;

See Also

DatePickerEditor Class | DatePickerEditor Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DatePickerEditor Methods

The methods of the DatePickerEditor class are listed below. For a complete list of DatePickerEditor class members, see the DatePickerEditor Members topic.

Public:

EditValue | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from ValueEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DatePickerEditor Class | System.ComponentModel.Design Namespace


DatePickerEditor.EditValue

[To be supplied.]

[Visual Basic]
Overrides Public Sub EditValue( _
   ByVal iva As IValueAccess _
)
[C#]
public override void EditValue(
   IValueAccess iva
);
[C++]
public: override void EditValue(
   IValueAccess* iva
);
[JScript]
public override function EditValue(
   iva : IValueAccess
);

Parameters

iva
[To be supplied.]

See Also

DatePickerEditor Class | DatePickerEditor Members | System.ComponentModel.Design Namespace


DatePickerEditor.GetTextFromValue

[To be supplied.]

[Visual Basic]
Overrides Public Function GetTextFromValue( _
   ByVal value As Object _
) As String
[C#]
public override string GetTextFromValue(
   object value
);
[C++]
public: override String* GetTextFromValue(
   Object* value
);
[JScript]
public override function GetTextFromValue(
   value : Object
) : String;

Parameters

value
[To be supplied.]

See Also

DatePickerEditor Class | DatePickerEditor Members | System.ComponentModel.Design Namespace


DatePickerEditor.GetValueFromText

[To be supplied.]

[Visual Basic]
Overrides Public Function GetValueFromText( _
   ByVal text As String _
) As Object
[C#]
public override object GetValueFromText(
   string text
);
[C++]
public: override Object* GetValueFromText(
   String* text
);
[JScript]
public override function GetValueFromText(
   text : String
) : Object;

Parameters

text
[To be supplied.]

See Also

DatePickerEditor Class | DatePickerEditor Members | System.ComponentModel.Design Namespace


DatePickerEditor.DatePicker Class

[To be supplied.]

Object
DatePickerEditor.DatePicker

[Visual Basic]
Public Class DatePickerEditor.DatePicker
[C#]
public class DatePickerEditor.DatePicker
[C++]
public __gc class DatePickerEditor.DatePicker
[JScript]
public class DatePickerEditor.DatePicker

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

DatePickerEditor.DatePicker Members | System.ComponentModel.Design Namespace


DatePickerEditor.DatePicker Members

Public:

Constructor

DatePickerEditorDatePicker Constructor [To be supplied.]

Methods

CreateDatePicker | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDatePicker | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DatePickerEditor.DatePicker Class | System.ComponentModel.Design Namespace


DatePickerEditor.DatePicker Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal editor As DatePickerEditor _
)
[C#]
public DatePickerEditor.DatePicker(
   DatePickerEditor editor
);
[C++]
public: DatePickerEditor.DatePicker(
   DatePickerEditor* editor
);
[JScript]
public function DatePickerEditor.DatePicker(
   editor : DatePickerEditor
);

Parameters

editor
[To be supplied.]

See Also

DatePickerEditor.DatePicker Class | DatePickerEditor.DatePicker Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DatePickerEditor.DatePicker Methods

The methods of the DatePickerEditor.DatePicker class are listed below. For a complete list of DatePickerEditor.DatePicker class members, see the DatePickerEditor.DatePicker Members topic.

Public:

CreateDatePicker | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDatePicker | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DatePickerEditor.DatePicker Class | System.ComponentModel.Design Namespace


DatePickerEditor.DatePicker.CreateDatePicker

[To be supplied.]

[Visual Basic]
Overridable Public Sub CreateDatePicker()
[C#]
public virtual void CreateDatePicker();
[C++]
public: virtual void CreateDatePicker();
[JScript]
public function CreateDatePicker();

See Also

DatePickerEditor.DatePicker Class | DatePickerEditor.DatePicker Members | System.ComponentModel.Design Namespace


DatePickerEditor.DatePicker.GetDatePicker

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDatePicker() As Control
[C#]
public virtual Control GetDatePicker();
[C++]
public: virtual Control* GetDatePicker();
[JScript]
public function GetDatePicker() : Control;

See Also

DatePickerEditor.DatePicker Class | DatePickerEditor.DatePicker Members | System.ComponentModel.Design Namespace


DateTimeEditor Class

This date time editor is a UITypeEditor suitable for visually editing DateTime objects.

Object
UITypeEditor
DateTimeEditor

[Visual Basic]
Public Class DateTimeEditor
   Inherits UITypeEditor
[C#]
public class DateTimeEditor : UITypeEditor
[C++]
public __gc class DateTimeEditor : public UITypeEditor
[JScript]
public class DateTimeEditor extends UITypeEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

DateTimeEditor Members | System.ComponentModel.Design Namespace


DateTimeEditor Members

Public:

Constructor

DateTimeEditor Constructor [To be supplied.]

Methods

EditValue | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEditStyle | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DateTimeEditor Class | System.ComponentModel.Design Namespace


DateTimeEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public DateTimeEditor();
[C++]
public: DateTimeEditor();
[JScript]
public function DateTimeEditor();

See Also

DateTimeEditor Class | DateTimeEditor Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DateTimeEditor Methods

The methods of the DateTimeEditor class are listed below. For a complete list of DateTimeEditor class members, see the DateTimeEditor Members topic.

Public:

EditValue | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEditStyle | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DateTimeEditor Class | System.ComponentModel.Design Namespace


DateTimeEditor.EditValue

Edits the given object value using the editor style provided by GetEditorStyle. A service provider is provided so that any required editing services can be obtained.

[Visual Basic]
Overrides Public Function EditValue( _
   ByVal context As ITypeDescriptorContext, _
   ByVal provider As IServiceObjectProvider, _
   ByVal value As Object _
) As Object
[C#]
public override object EditValue(
   ITypeDescriptorContext context,
   IServiceObjectProvider provider,
   object value
);
[C++]
public: override Object* EditValue(
   ITypeDescriptorContext* context,
   IServiceObjectProvider* provider,
   Object* value
);
[JScript]
public override function EditValue(
   context : ITypeDescriptorContext,
   provider : IServiceObjectProvider,
   value : Object
) : Object;

Parameters

context
A type descriptor context that can be used to provide additional context information.
provider
A service provider object through which editing services may be obtained.
value
An instance of the value being edited.

Return Value

The new value of the object. If the value of the object hasn't changed, this should return the same object it was passed.

See Also

DateTimeEditor Class | DateTimeEditor Members | System.ComponentModel.Design Namespace


DateTimeEditor.GetEditStyle

Retrieves the editing style of the Edit method. If the method is not supported, this will return None.

[Visual Basic]
Overrides Public Function GetEditStyle( _
   ByVal context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
[C#]
public override UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext context
);
[C++]
public: override UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetEditStyle(
   context : ITypeDescriptorContext
) : UITypeEditorEditStyle;

Parameters

context
A type descriptor context that can be used to provide additional context information.

Return Value

An enum value indicating the provided editing style.

See Also

DateTimeEditor Class | DateTimeEditor Members | System.ComponentModel.Design Namespace


DateTimeFormatEditor Class

[To be supplied.]

Object
ValueEditor
AliasEditor
DateTimeFormatEditor

[Visual Basic]
Public Class DateTimeFormatEditor
   Inherits AliasEditor
[C#]
public class DateTimeFormatEditor : AliasEditor
[C++]
public __gc class DateTimeFormatEditor : public AliasEditor
[JScript]
public class DateTimeFormatEditor extends AliasEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

DateTimeFormatEditor Members | System.ComponentModel.Design Namespace


DateTimeFormatEditor Members

Public:

Constructor

DateTimeFormatEditor Constructor [To be supplied.]

Properties

Style (inherited from AliasEditor) | [To be supplied.]
Values (inherited from AliasEditor) | [To be supplied.]

Methods

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from ValueEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue (inherited from AliasEditor) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from AliasEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DateTimeFormatEditor Class | System.ComponentModel.Design Namespace


DateTimeFormatEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public DateTimeFormatEditor();
[C++]
public: DateTimeFormatEditor();
[JScript]
public function DateTimeFormatEditor();

See Also

DateTimeFormatEditor Class | DateTimeFormatEditor Members | System.ComponentModel.Design Namespace


DecimalEditor Class

[To be supplied.]

Object
ValueEditor
DecimalEditor

[Visual Basic]
Public Class DecimalEditor
   Inherits ValueEditor
[C#]
public class DecimalEditor : ValueEditor
[C++]
public __gc class DecimalEditor : public ValueEditor
[JScript]
public class DecimalEditor extends ValueEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

DecimalEditor Members | System.ComponentModel.Design Namespace


DecimalEditor Members

Public:

Constructor

DecimalEditor Constructor [To be supplied.]

Properties

Style (inherited from ValueEditor) | [To be supplied.]
Values (inherited from ValueEditor) | [To be supplied.]

Methods

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle | Retrieves the CreationBundle for the given value. a null reference (in Visual Basic Nothing) will be returned if the value cannot be created from either a static method or constructor call.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue (inherited from ValueEditor) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from ValueEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DecimalEditor Class | System.ComponentModel.Design Namespace


DecimalEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public DecimalEditor();
[C++]
public: DecimalEditor();
[JScript]
public function DecimalEditor();

See Also

DecimalEditor Class | DecimalEditor Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DecimalEditor Methods

The methods of the DecimalEditor class are listed below. For a complete list of DecimalEditor class members, see the DecimalEditor Members topic.

Public:

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle | Retrieves the CreationBundle for the given value. a null reference (in Visual Basic Nothing) will be returned if the value cannot be created from either a static method or constructor call.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue (inherited from ValueEditor) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from ValueEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DecimalEditor Class | System.ComponentModel.Design Namespace


DecimalEditor.GetCreationBundle

Retrieves the CreationBundle for the given value. a null reference (in Visual Basic Nothing) will be returned if the value cannot be created from either a static method or constructor call.

[Visual Basic]
Overrides Public Function GetCreationBundle( _
   ByVal value As Object _
) As CreationBundle
[C#]
public override CreationBundle GetCreationBundle(
   object value
);
[C++]
public: override CreationBundle* GetCreationBundle(
   Object* value
);
[JScript]
public override function GetCreationBundle(
   value : Object
) : CreationBundle;

Parameters

value
[To be supplied.]

See Also

DecimalEditor Class | DecimalEditor Members | System.ComponentModel.Design Namespace


DesignerVerb Class

Represents a verb that can be executed by a component's designer. Verbs are dynamic menu commands whose text image can be determined at runtime.

Object
MenuCommand
DesignerVerb

[Visual Basic]
Public Class DesignerVerb
   Inherits MenuCommand
[C#]
public class DesignerVerb : MenuCommand
[C++]
public __gc class DesignerVerb : public MenuCommand
[JScript]
public class DesignerVerb extends MenuCommand

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

DesignerVerb Members | System.ComponentModel.Design Namespace | CommandID | MenuCommand | IMenuCommandService


DesignerVerb Members

Public:

Constructor

DesignerVerb Constructor Overloaded. Initializes a new instance of the DesignerVerb class.

Properties

Checked (inherited from MenuCommand) | Gets or sets a value that indicates whether this menu item is checked.
CommandID (inherited from MenuCommand) | Gets the CommandID associated with this menu.
Enabled (inherited from MenuCommand) | Gets or sets a value that indicates whether this menu item is available.
OleStatus (inherited from MenuCommand) | Gets the OLE command status code for this menu item.
Supported (inherited from MenuCommand) | Gets or sets a value that indicates whether this menu item is supported.
Text | Gets or sets the text to show on the menu item for the verb.
Visible (inherited from MenuCommand) | Gets or sets a value that indicates if this menu item is visible.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Invoke (inherited from MenuCommand) | Invokes a menu item.
ToString | Overrides object's ToString().

Events

CommandChanged (inherited from MenuCommand) Occurs when the menu command changes.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnCommandChanged (inherited from MenuCommand) | Provides notification and is called in response to a CommandChanged event.

Event Hookup:

Methods

AddOnCommandChanged (inherited from MenuCommand) | Allows a caller to attach an event that will be called when this command changes.
RemoveOnCommandChanged (inherited from MenuCommand) | Removes a CommandChanged event handler.

See Also

DesignerVerb Class | System.ComponentModel.Design Namespace


DesignerVerb Constructor

Initializes a new instance of the DesignerVerb class.

Overload List

Initializes a new instance of the DesignerVerb class.

[Visual Basic] Overloads Public Sub New(String, EventHandler)
[C#] public DesignerVerb(String, EventHandler);
[C++] public: DesignerVerb(String*, EventHandler);
[JScript] public function DesignerVerb(String, EventHandler);

Initializes a new instance of the DesignerVerb class.

[Visual Basic] Overloads Public Sub New(String, EventHandler, CommandID)
[C#] public DesignerVerb(String, EventHandler, CommandID);
[C++] public: DesignerVerb(String*, EventHandler, CommandID);
[JScript] public function DesignerVerb(String, EventHandler, CommandID);

See Also

DesignerVerb Class | DesignerVerb Members | System.ComponentModel.Design Namespace


DesignerVerb Constructor (String, EventHandler)

Initializes a new instance of the DesignerVerb class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal text As String, _
   ByVal handler As EventHandler _
)
[C#]
public DesignerVerb(
   string text,
   EventHandler handler
);
[C++]
public: DesignerVerb(
   String* text,
   EventHandler* handler
);
[JScript]
public function DesignerVerb(
   text : String,
   handler : EventHandler
);

Parameters

text
The text of the menu command that is shown to the user.
handler
The event handler to be invoked when the verb is executed.

Remarks

Verbs are dynamic menu commands whose text and image can be determined at runtime. Verb commands generally show up on either an edit menu or a component's context menu.

See Also

DesignerVerb Class | DesignerVerb Members | System.ComponentModel.Design Namespace | DesignerVerb Constructor Overload List | CommandID | MenuCommand | IMenuCommandService


DesignerVerb Constructor (String, EventHandler, CommandID)

Initializes a new instance of the DesignerVerb class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal text As String, _
   ByVal handler As EventHandler, _
   ByVal startCommandID As CommandID _
)
[C#]
public DesignerVerb(
   string text,
   EventHandler handler,
   CommandID startCommandID
);
[C++]
public: DesignerVerb(
   String* text,
   EventHandler* handler,
   CommandID* startCommandID
);
[JScript]
public function DesignerVerb(
   text : String,
   handler : EventHandler,
   startCommandID : CommandID
);

Parameters

text
The text of the menu command that is shown to the user.
handler
The event handler to be invoked when the verb is executed.
startCommandID
The starting command ID for this verb. By default, the designer architecture sets aside a range of command IDs for verbs. You may override this by providing a custom command ID here.

Remarks

Verbs are dynamic menu commands whose text and image can be determined at runtime. Verb commands generally show up on either an edit menu or a component's context menu.

See Also

DesignerVerb Class | DesignerVerb Members | System.ComponentModel.Design Namespace | DesignerVerb Constructor Overload List | CommandID | MenuCommand | IMenuCommandService


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DesignerVerb Properties

The properties of the DesignerVerb class are listed below. For a complete list of DesignerVerb class members, see the DesignerVerb Members topic.

Public:

Checked (inherited from MenuCommand) | Gets or sets a value that indicates whether this menu item is checked.
CommandID (inherited from MenuCommand) | Gets the CommandID associated with this menu.
Enabled (inherited from MenuCommand) | Gets or sets a value that indicates whether this menu item is available.
OleStatus (inherited from MenuCommand) | Gets the OLE command status code for this menu item.
Supported (inherited from MenuCommand) | Gets or sets a value that indicates whether this menu item is supported.
Text | Gets or sets the text to show on the menu item for the verb.
Visible (inherited from MenuCommand) | Gets or sets a value that indicates if this menu item is visible.

See Also

DesignerVerb Class | System.ComponentModel.Design Namespace


DesignerVerb.Text

Gets or sets the text to show on the menu item for the verb.

[Visual Basic]
Public ReadOnly Property Text As String
[C#]
public string Text {get;}
[C++]
public: __property String* get_Text();
[JScript]
public function get Text() : String;

Property Value

The text to show on the menu for the verb command.

See Also

DesignerVerb Class | DesignerVerb Members | System.ComponentModel.Design Namespace | MenuCommand | IMenuCommandService


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DesignerVerb Methods

The methods of the DesignerVerb class are listed below. For a complete list of DesignerVerb class members, see the DesignerVerb Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Invoke (inherited from MenuCommand) | Invokes a menu item.
ToString | Overrides object's ToString().

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnCommandChanged (inherited from MenuCommand) | Provides notification and is called in response to a CommandChanged event.

Event Hookup:

AddOnCommandChanged (inherited from MenuCommand) | Allows a caller to attach an event that will be called when this command changes.
RemoveOnCommandChanged (inherited from MenuCommand) | Removes a CommandChanged event handler.

See Also

DesignerVerb Class | System.ComponentModel.Design Namespace


DesignerVerb.ToString

Overrides object's ToString().

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

The verb's text.

See Also

DesignerVerb Class | DesignerVerb Members | System.ComponentModel.Design Namespace


DesigntimeLicenseContext Class

Provides design-time support for licensing.

Object
LicenseContext
DesigntimeLicenseContext

[Visual Basic]
Public Class DesigntimeLicenseContext
   Inherits LicenseContext
[C#]
public class DesigntimeLicenseContext : LicenseContext
[C++]
public __gc class DesigntimeLicenseContext : public LicenseContext
[JScript]
public class DesigntimeLicenseContext extends LicenseContext

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

DesigntimeLicenseContext Members | System.ComponentModel.Design Namespace | LicenseContext | DesigntimeLicenseContextSerializer


DesigntimeLicenseContext Members

Public:

Constructor

DesigntimeLicenseContext Constructor [To be supplied.]

Properties

UsageMode Gets or sets the license usage mode.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSavedLicenseKey | Gets a saved license key.
GetType (inherited from Object) | Gets the Type of the Object.
SetSavedLicenseKey | Sets a saved license key.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DesigntimeLicenseContext Class | System.ComponentModel.Design Namespace


DesigntimeLicenseContext Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public DesigntimeLicenseContext();
[C++]
public: DesigntimeLicenseContext();
[JScript]
public function DesigntimeLicenseContext();

See Also

DesigntimeLicenseContext Class | DesigntimeLicenseContext Members | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DesigntimeLicenseContext Properties

The properties of the DesigntimeLicenseContext class are listed below. For a complete list of DesigntimeLicenseContext class members, see the DesigntimeLicenseContext Members topic.

Public:

UsageMode Gets or sets the license usage mode.

See Also

DesigntimeLicenseContext Class | System.ComponentModel.Design Namespace


DesigntimeLicenseContext.UsageMode

Gets or sets the license usage mode.

[Visual Basic]
Overridable Public ReadOnly Property UsageMode As LicenseUsageMode
[C#]
public LicenseUsageMode UsageMode {override get;}
[C++]
public: __property virtual LicenseUsageMode get_UsageMode();
[JScript]
public function get UsageMode() : LicenseUsageMode;

Property Value

A LicenseUsageMode indicating the license usage mode.

See Also

DesigntimeLicenseContext Class | DesigntimeLicenseContext Members | System.ComponentModel.Design Namespace | LicenseContext


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DesigntimeLicenseContext Methods

The methods of the DesigntimeLicenseContext class are listed below. For a complete list of DesigntimeLicenseContext class members, see the DesigntimeLicenseContext Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSavedLicenseKey | Gets a saved license key.
GetType (inherited from Object) | Gets the Type of the Object.
SetSavedLicenseKey | Sets a saved license key.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DesigntimeLicenseContext Class | System.ComponentModel.Design Namespace


DesigntimeLicenseContext.GetSavedLicenseKey

Gets a saved license key.

[Visual Basic]
Overrides Public Function GetSavedLicenseKey( _
   ByVal type As Type, _
   ByVal resourceAssembly As Assembly _
) As String
[C#]
public override string GetSavedLicenseKey(
   Type type,
   Assembly resourceAssembly
);
[C++]
public: override String* GetSavedLicenseKey(
   Type* type,
   Assembly* resourceAssembly
);
[JScript]
public override function GetSavedLicenseKey(
   type : Type,
   resourceAssembly : Assembly
) : String;

Parameters

type
The type of the license key.
resourceAssembly
[To be supplied.]

Return Value

The saved license key that matches the specified attributes.

See Also

DesigntimeLicenseContext Class | DesigntimeLicenseContext Members | System.ComponentModel.Design Namespace | LicenseContext


DesigntimeLicenseContext.SetSavedLicenseKey

Sets a saved license key.

[Visual Basic]
Overrides Public Sub SetSavedLicenseKey( _
   ByVal type As Type, _
   ByVal key As String _
)
[C#]
public override void SetSavedLicenseKey(
   Type type,
   string key
);
[C++]
public: override void SetSavedLicenseKey(
   Type* type,
   String* key
);
[JScript]
public override function SetSavedLicenseKey(
   type : Type,
   key : String
);

Parameters

type
The type of the license key.
key
[To be supplied.]

See Also

DesigntimeLicenseContext Class | DesigntimeLicenseContext Members | System.ComponentModel.Design Namespace | LicenseContext


DesigntimeLicenseContextSerializer Class

Provides support for design-time license context serialization.

Object
DesigntimeLicenseContextSerializer

[Visual Basic]
Public Class DesigntimeLicenseContextSerializer
[C#]
public class DesigntimeLicenseContextSerializer
[C++]
public __gc class DesigntimeLicenseContextSerializer
[JScript]
public class DesigntimeLicenseContextSerializer

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

DesigntimeLicenseContextSerializer Members | System.ComponentModel.Design Namespace | System.ComponentModel.Design.DesignTimeLicenseContext | LicenseContext


DesigntimeLicenseContextSerializer Members

Public:

Constructor

DesigntimeLicenseContextSerializer Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Serialize | Serializes the licenses within the specified design-time license context using the specified key and output stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DesigntimeLicenseContextSerializer Class | System.ComponentModel.Design Namespace


DesigntimeLicenseContextSerializer Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public DesigntimeLicenseContextSerializer();
[C++]
public: DesigntimeLicenseContextSerializer();
[JScript]
public function DesigntimeLicenseContextSerializer();

See Also

DesigntimeLicenseContextSerializer Class | DesigntimeLicenseContextSerializer Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DesigntimeLicenseContextSerializer Methods

The methods of the DesigntimeLicenseContextSerializer class are listed below. For a complete list of DesigntimeLicenseContextSerializer class members, see the DesigntimeLicenseContextSerializer Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Serialize | Serializes the licenses within the specified design-time license context using the specified key and output stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DesigntimeLicenseContextSerializer Class | System.ComponentModel.Design Namespace


DesigntimeLicenseContextSerializer.Serialize

Serializes the licenses within the specified design-time license context using the specified key and output stream.

[Visual Basic]
Public Shared Sub Serialize( _
   ByVal o As Stream, _
   ByVal cryptoKey As String, _
   ByVal context As DesigntimeLicenseContext _
)
[C#]
public static void Serialize(
   Stream o,
   string cryptoKey,
   DesigntimeLicenseContext context
);
[C++]
public: static void Serialize(
   Stream* o,
   String* cryptoKey,
   DesigntimeLicenseContext* context
);
[JScript]
public static function Serialize(
   o : Stream,
   cryptoKey : String,
   context : DesigntimeLicenseContext
);

Parameters

o
[To be supplied.]
cryptoKey
[To be supplied.]
context
A DesigntimeLicenseContext indicating the license context.

See Also

DesigntimeLicenseContextSerializer Class | DesigntimeLicenseContextSerializer Members | System.ComponentModel.Design Namespace | DesigntimeLicenseContext | LicenseContext


DisplayMode Enumeration

[To be supplied.]

[Visual Basic]
Public Enum DisplayMode
[C#]
public enum DisplayMode
[C++]
public enum DisplayMode

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Ansi | [To be supplied.]
Auto | [To be supplied.]
Hexdump | [To be supplied.]
Unicode | [To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

System.ComponentModel.Design Namespace


DocumentCollection Class

Provides a read-only collection of documents.

Object
DocumentCollection

[Visual Basic]
Public Class DocumentCollection
   Implements ICollection, IEnumerable
[C#]
public class DocumentCollection : ICollection, IEnumerable
[C++]
public __gc class DocumentCollection : public ICollection,
   IEnumerable
[JScript]
public class DocumentCollection implements ICollection, IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

DocumentCollection Members | System.ComponentModel.Design Namespace


DocumentCollection Members

Public:

Constructor

DocumentCollection Constructor Initializes a new instance of the DocumentCollection class that stores an array with a pointer to each IDesignerHost for each document in the collection.

Properties

All | Gets or sets the array of designers.
Count | Gets or sets the number of documents in the collection.
Item | Gets or sets the document with the specified index. In C#, this member is the indexer for the DocumentCollection class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Creates and retrieves a new enumerator for this collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DocumentCollection Class | System.ComponentModel.Design Namespace


DocumentCollection Constructor

Initializes a new instance of the DocumentCollection class that stores an array with a pointer to each IDesignerHost for each document in the collection.

[Visual Basic]
Public Sub New( _
   ByVal designers() As IDesignerHost _
)
[C#]
public DocumentCollection(
   IDesignerHost[] designers
);
[C++]
public: DocumentCollection(
   IDesignerHost* designers[]
);
[JScript]
public function DocumentCollection(
   designers : IDesignerHost[]
);

Parameters

designers
An array of IDesignerHost objects.

Remarks

Creates a new document collection from an array of designers. The collection does not clone the array.

See Also

DocumentCollection Class | DocumentCollection Members | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DocumentCollection Properties

The properties of the DocumentCollection class are listed below. For a complete list of DocumentCollection class members, see the DocumentCollection Members topic.

Public:

All | Gets or sets the array of designers.
Count | Gets or sets the number of documents in the collection.
Item | Gets or sets the document with the specified index. In C#, this member is the indexer for the DocumentCollection class.

See Also

DocumentCollection Class | System.ComponentModel.Design Namespace


DocumentCollection.All

Gets or sets the array of designers.

[Visual Basic]
Overridable Public ReadOnly Property All As IDesignerHost ()
[C#]
public IDesignerHost[] All {virtual get;}
[C++]
public: __property virtual IDesignerHost* get_All();
[JScript]
public function get All() : IDesignerHost[];

Property Value

An array of type IDesignerHost.

See Also

DocumentCollection Class | DocumentCollection Members | System.ComponentModel.Design Namespace


DocumentCollection.Count

Gets or sets the number of documents in the collection.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

Property Value

The number of documents.

See Also

DocumentCollection Class | DocumentCollection Members | System.ComponentModel.Design Namespace


DocumentCollection.Item

Gets or sets the document with the specified index.

[C#] In C#, this member is the indexer for the DocumentCollection class.

[Visual Basic]
Overridable Public Default ReadOnly Property Item( _
   ByVal index As Integer _
) As IDesignerHost
[C#]
public IDesignerHost this[
   int index
] {virtual get;}
[C++]
public: __property virtual IDesignerHost* get_Item(
   int index
);
[JScript]
returnValue = DocumentCollectionObject.Item(index);
-or-
returnValue = DocumentCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
The index of the document to return.

Parameters [Visual Basic, C#, C++]

index
The index of the document to return.

Property Value

The document with the specified index.

See Also

DocumentCollection Class | DocumentCollection Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DocumentCollection Methods

The methods of the DocumentCollection class are listed below. For a complete list of DocumentCollection class members, see the DocumentCollection Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Creates and retrieves a new enumerator for this collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DocumentCollection Class | System.ComponentModel.Design Namespace


DocumentCollection.GetEnumerator

Creates and retrieves a new enumerator for this collection.

[Visual Basic]
Public Function GetEnumerator() As IEnumerator
[C#]
public IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

Return Value

An enumerator that enumerates the collection.

See Also

DocumentCollection Class | DocumentCollection Members | System.ComponentModel.Design Namespace


DocumentEventArgs Class

Provides data for the DocumentEventArgs event that is generated when a document is created or disposed.

Object
EventArgs
DocumentEventArgs

[Visual Basic]
Public Class DocumentEventArgs
   Inherits EventArgs
[C#]
public class DocumentEventArgs : EventArgs
[C++]
public __gc class DocumentEventArgs : public EventArgs
[JScript]
public class DocumentEventArgs extends EventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

DocumentEventArgs Members | System.ComponentModel.Design Namespace | IDesignerEventService | DocumentEventHandler


DocumentEventArgs Members

Public:

Constructor

DocumentEventArgs Constructor Initializes a new instance of the DocumentEventArgs class.

Properties

Document | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DocumentEventArgs Class | System.ComponentModel.Design Namespace


DocumentEventArgs Constructor

Initializes a new instance of the DocumentEventArgs class.

[Visual Basic]
Public Sub New( _
   ByVal host As IDesignerHost _
)
[C#]
public DocumentEventArgs(
   IDesignerHost host
);
[C++]
public: DocumentEventArgs(
   IDesignerHost* host
);
[JScript]
public function DocumentEventArgs(
   host : IDesignerHost
);

Parameters

host
The IDesignerHost of the document.

See Also

DocumentEventArgs Class | DocumentEventArgs Members | System.ComponentModel.Design Namespace | DocumentEventHandler


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DocumentEventArgs Properties

The properties of the DocumentEventArgs class are listed below. For a complete list of DocumentEventArgs class members, see the DocumentEventArgs Members topic.

Public:

Document | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.

See Also

DocumentEventArgs Class | System.ComponentModel.Design Namespace


DocumentEventArgs.Document

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Document As IDesignerHost
[C#]
public IDesignerHost Document {get;}
[C++]
public: __property IDesignerHost* get_Document();
[JScript]
public function get Document() : IDesignerHost;

See Also

DocumentEventArgs Class | DocumentEventArgs Members | System.ComponentModel.Design Namespace


DocumentEventHandler Delegate

Represents the method that will handle the DocumentEventArgs event raised when a document is created or disposed.

[Visual Basic]
Public Delegate Sub DocumentEventHandler( _
   ByVal sender As Object, _
   ByVal e As DocumentEventArgs _
)
[C#]
public delegate void DocumentEventHandler(
   object sender,
   DocumentEventArgs e
);
[C++]
public __gc __delegate void DocumentEventHandler(
   Object* sender,
   DocumentEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the DocumentEventHandler delegate declaration.

sender
The source of the event.
e
A DocumentEventArgs that contains the event data.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

System.ComponentModel.Design Namespace | DocumentEventArgs


EventHandlerSetActionUnit Class

Represents an atomic undoable action unit to be added to the IUndoService implementation.

Object
ComponentChangeBaseActionUnit
PropertyChangeActionUnit
EventHandlerSetActionUnit

[Visual Basic]
Public Class EventHandlerSetActionUnit
   Inherits PropertyChangeActionUnit
[C#]
public class EventHandlerSetActionUnit : PropertyChangeActionUnit
[C++]
public __gc class EventHandlerSetActionUnit : public
   PropertyChangeActionUnit
[JScript]
public class EventHandlerSetActionUnit extends
   PropertyChangeActionUnit

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

EventHandlerSetActionUnit Members | System.ComponentModel.Design Namespace | IUndoService | IActionUnit


EventHandlerSetActionUnit Members

Public:

Constructor

EventHandlerSetActionUnit Constructor Initializes a new instance of the EventHandlerSetActionUnit class.

Methods

DoAction | Performs the action represented by this IActionUnit.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDescription | Gets the description for this action unit.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNextActionType (inherited from ComponentChangeBaseActionUnit) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

NewValue (inherited from PropertyChangeActionUnit) Gets or sets the new value for the property.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetTarget (inherited from PropertyChangeActionUnit) | Gets the target the property change occured on.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

propertyDesc (inherited from PropertyChangeActionUnit) Gets or sets a PropertyDescriptor that describes this action unit. This field is read-only.

See Also

EventHandlerSetActionUnit Class | System.ComponentModel.Design Namespace


EventHandlerSetActionUnit Constructor

Initializes a new instance of the EventHandlerSetActionUnit class.

[Visual Basic]
Public Sub New( _
   ByVal component As Object, _
   ByVal propertyEvent As PropertyDescriptor, _
   ByVal eventName As String, _
   ByVal eventDesc As EventDescriptor, _
   ByVal mods As Integer, _
   ByVal serviceProvider As IServiceObjectProvider _
)
[C#]
public EventHandlerSetActionUnit(
   object component,
   PropertyDescriptor propertyEvent,
   string eventName,
   EventDescriptor eventDesc,
   int mods,
   IServiceObjectProvider serviceProvider
);
[C++]
public: EventHandlerSetActionUnit(
   Object* component,
   PropertyDescriptor* propertyEvent,
   String* eventName,
   EventDescriptor* eventDesc,
   int mods,
   IServiceObjectProvider* serviceProvider
);
[JScript]
public function EventHandlerSetActionUnit(
   component : Object,
   propertyEvent : PropertyDescriptor,
   eventName : String,
   eventDesc : EventDescriptor,
   mods : int,
   serviceProvider : IServiceObjectProvider
);

Parameters

component
The source of the event.
propertyEvent
[To be supplied.]
eventName
[To be supplied.]
eventDesc
[To be supplied.]
mods
[To be supplied.]
serviceProvider
[To be supplied.]

See Also

EventHandlerSetActionUnit Class | EventHandlerSetActionUnit Members | System.ComponentModel.Design Namespace | IUndoService | IActionUnit


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EventHandlerSetActionUnit Methods

The methods of the EventHandlerSetActionUnit class are listed below. For a complete list of EventHandlerSetActionUnit class members, see the EventHandlerSetActionUnit Members topic.

Public:

DoAction | Performs the action represented by this IActionUnit.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDescription | Gets the description for this action unit.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNextActionType (inherited from ComponentChangeBaseActionUnit) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetTarget (inherited from PropertyChangeActionUnit) | Gets the target the property change occured on.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EventHandlerSetActionUnit Class | System.ComponentModel.Design Namespace


EventHandlerSetActionUnit.DoAction

Performs the action represented by this IActionUnit.

[Visual Basic]
Overrides Public Function DoAction() As Boolean
[C#]
public override bool DoAction();
[C++]
public: override bool DoAction();
[JScript]
public override function DoAction() : Boolean;

Return Value

true if the action was successfully carried out; otherwise, false.

Remarks

The implementation of DoAction should automatcially toggle between being an Undo or Redo action each time DoAction is called.

See Also

EventHandlerSetActionUnit Class | EventHandlerSetActionUnit Members | System.ComponentModel.Design Namespace | IUndoService | IActionUnit


EventHandlerSetActionUnit.GetDescription

Gets the description for this action unit.

[Visual Basic]
Overrides Public Function GetDescription() As String
[C#]
public override string GetDescription();
[C++]
public: override String* GetDescription();
[JScript]
public override function GetDescription() : String;

Return Value

A string description for this action unit.

See Also

EventHandlerSetActionUnit Class | EventHandlerSetActionUnit Members | System.ComponentModel.Design Namespace | IActionUnit


GuidEditor Class

GuidEditor is the default editor for Guids.

Object
ValueEditor
GuidEditor

[Visual Basic]
Public Class GuidEditor
   Inherits ValueEditor
[C#]
public class GuidEditor : ValueEditor
[C++]
public __gc class GuidEditor : public ValueEditor
[JScript]
public class GuidEditor extends ValueEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

GuidEditor Members | System.ComponentModel.Design Namespace | ValueEditor


GuidEditor Members

Public:

Constructor

GuidEditor Constructor [To be supplied.]

Properties

Style (inherited from ValueEditor) | [To be supplied.]
Values (inherited from ValueEditor) | [To be supplied.]

Methods

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from ValueEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue (inherited from ValueEditor) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from ValueEditor) | Converts a string to a Guid value.
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GuidEditor Class | System.ComponentModel.Design Namespace


GuidEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public GuidEditor();
[C++]
public: GuidEditor();
[JScript]
public function GuidEditor();

See Also

GuidEditor Class | GuidEditor Members | System.ComponentModel.Design Namespace


HelpKeywordType Enumeration

[To be supplied.]

[Visual Basic]
Public Enum HelpKeywordType
[C#]
public enum HelpKeywordType
[C++]
public enum HelpKeywordType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
F1Keyword | [To be supplied.]
FilterKeyword | [To be supplied.]
GeneralKeyword | [To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

System.ComponentModel.Design Namespace


IActionUnit Interface

Represents an atomic undoable action unit to be added to the IUndoService implementation.

IActionUnit

[Visual Basic]
Public Interface IActionUnit
[C#]
public interface IActionUnit
[C++]
public __gc __interface IActionUnit

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

IActionUnit Members | System.ComponentModel.Design Namespace | IUndoService | ICompoundActionUnit


IActionUnit Members

Methods

DoAction | Performs the action encapsulated in this IActionUnit.
GetDescription | Gets the description for this action unit.
GetNextActionType | Gets the current action state.

See Also

IActionUnit Interface | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IActionUnit Methods

The methods of the IActionUnit interface are listed below. For a complete list of IActionUnit interface members, see the IActionUnit Members topic.

DoAction | Performs the action encapsulated in this IActionUnit.
GetDescription | Gets the description for this action unit.
GetNextActionType | Gets the current action state.

See Also

IActionUnit Interface | System.ComponentModel.Design Namespace


IActionUnit.DoAction

Performs the action encapsulated in this IActionUnit.

[Visual Basic]
Function DoAction() As Boolean
[C#]
bool DoAction();
[C++]
bool DoAction() = 0;
[JScript]
function DoAction() : Boolean;

Return Value

true if the action was successfully carried out; otherwise false.

Remarks

The implementation should automatcially toggle between being an Undo or Redo action each time DoAction is called.

See Also

IActionUnit Interface | IActionUnit Members | System.ComponentModel.Design Namespace


IActionUnit.GetDescription

Gets the description for this action unit.

[Visual Basic]
Function GetDescription() As String
[C#]
string GetDescription();
[C++]
String* GetDescription() = 0;
[JScript]
function GetDescription() : String;

Return Value

A description for this action unit.

See Also

IActionUnit Interface | IActionUnit Members | System.ComponentModel.Design Namespace


IActionUnit.GetNextActionType

Gets the current action state.

[Visual Basic]
Function GetNextActionType() As ActionType
[C#]
ActionType GetNextActionType();
[C++]
ActionType GetNextActionType() = 0;
[JScript]
function GetNextActionType() : ActionType;

Return Value

The current state, Undo or Redo.

Remarks

The current action state is the type of operation that will be performed on the next call to DoAction. The return value is either Undo or Redo.

See Also

IActionUnit Interface | IActionUnit Members | System.ComponentModel.Design Namespace


IApplicationExtensibilityService Interface

The application extensibility service.

IApplicationExtensibilityService

[Visual Basic]
Public Interface IApplicationExtensibilityService
[C#]
public interface IApplicationExtensibilityService
[C++]
public __gc __interface IApplicationExtensibilityService

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

The application object service is used to get at the application object for the development enviornment. The application object can be used to control the development enviornment. To use the application object service, request it through a call to GetServiceObject. You may cast the resulting object to an extensibility interface or access it as a dispatch interface.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

IApplicationExtensibilityService Members | System.ComponentModel.Design Namespace


IApplicationExtensibilityService Members

See Also

IApplicationExtensibilityService Interface | System.ComponentModel.Design Namespace


ICheckoutService Interface

Provides an interface for checking out files to edit.

ICheckoutService

[Visual Basic]
Public Interface ICheckoutService
[C#]
public interface ICheckoutService
[C++]
public __gc __interface ICheckoutService

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

ICheckoutService Members | System.ComponentModel.Design Namespace


ICheckoutService Members

Methods

CheckoutFile | Checks out the specified file, if possible.
DoesFileNeedCheckout | Verifies whether a file must be checked out to be edited.

See Also

ICheckoutService Interface | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICheckoutService Methods

The methods of the ICheckoutService interface are listed below. For a complete list of ICheckoutService interface members, see the ICheckoutService Members topic.

CheckoutFile | Checks out the specified file, if possible.
DoesFileNeedCheckout | Verifies whether a file must be checked out to be edited.

See Also

ICheckoutService Interface | System.ComponentModel.Design Namespace


ICheckoutService.CheckoutFile

Checks out the specified file, if possible.

[Visual Basic]
Sub CheckoutFile( _
   ByVal fileName As String _
)
[C#]
void CheckoutFile(
   string fileName
);
[C++]
void CheckoutFile(
   String* fileName
) = 0;
[JScript]
function CheckoutFile(
   fileName : String
);

Parameters

fileName
The file to check out.

Exceptions

Exception Type | Condition
System.CheckoutException.Canceled | The file cannot be checked out to be edited.

Remarks

If the file needs be be checked out to be edited, and it cannot be checked out, a CheckoutException exception is thrown. If the file is already checked out, or does not need to be checked out, no exception is thrown and the function returns.

See Also

ICheckoutService Interface | ICheckoutService Members | System.ComponentModel.Design Namespace


ICheckoutService.DoesFileNeedCheckout

Verifies whether a file must be checked out to be edited.

[Visual Basic]
Function DoesFileNeedCheckout( _
   ByVal fileName As String _
) As Boolean
[C#]
bool DoesFileNeedCheckout(
   string fileName
);
[C++]
bool DoesFileNeedCheckout(
   String* fileName
) = 0;
[JScript]
function DoesFileNeedCheckout(
   fileName : String
) : Boolean;

Parameters

fileName
The file to retrieve source control status for.

Return Value

true if file is under source control and needs to be checked out to be edited; otherwise false.

Remarks

It will return true only if the file is under source control and is currently not checked out.

See Also

ICheckoutService Interface | ICheckoutService Members | System.ComponentModel.Design Namespace


ICodeNavigatorService Interface

Provides simple code navigation services.

ICodeNavigatorService

[Visual Basic]
Public Interface ICodeNavigatorService
[C#]
public interface ICodeNavigatorService
[C++]
public __gc __interface ICodeNavigatorService

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement ICodeNavigatorService

Class | Description
ComponentModelPersister | Component model persister. This object can convert a component object graph to and from source code. It also provides code navigation services to the designer.

Remarks

A code stream can support event navigation to code. If so, it can provide this service to the designer host. There can be only one code navigator at a time.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

ICodeNavigatorService Members | System.ComponentModel.Design Namespace


ICodeNavigatorService Members

Methods

DoesHandlerExist | Gets whether or not a handler for the specified event descriptor exists in the code.
GetCompatibleMethods | Gets the names of methods that have signatures compatible with the specified delegate class.
GetDoesFieldExist | Gets if a field of the given name exists in the code.
GetDoesMethodExist | Gets whether or not a method of the specified name exists in the code.
NavigateToEvent | Overloaded. Requests that the source view for the file be displayed and that the cursor be placed within the block for the given event.

See Also

ICodeNavigatorService Interface | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeNavigatorService Methods

The methods of the ICodeNavigatorService interface are listed below. For a complete list of ICodeNavigatorService interface members, see the ICodeNavigatorService Members topic.

DoesHandlerExist | Gets whether or not a handler for the specified event descriptor exists in the code.
GetCompatibleMethods | Gets the names of methods that have signatures compatible with the specified delegate class.
GetDoesFieldExist | Gets if a field of the given name exists in the code.
GetDoesMethodExist | Gets whether or not a method of the specified name exists in the code.
NavigateToEvent | Overloaded. Requests that the source view for the file be displayed and that the cursor be placed within the block for the given event.

See Also

ICodeNavigatorService Interface | System.ComponentModel.Design Namespace


ICodeNavigatorService.DoesHandlerExist

Gets whether or not a handler for the specified event descriptor exists in the code.

[Visual Basic]
Function DoesHandlerExist( _
   ByVal name As String, _
   ByVal e As EventDescriptor _
) As Boolean
[C#]
bool DoesHandlerExist(
   string name,
   EventDescriptor e
);
[C++]
bool DoesHandlerExist(
   String* name,
   EventDescriptor* e
) = 0;
[JScript]
function DoesHandlerExist(
   name : String,
   e : EventDescriptor
) : Boolean;

Parameters

name
The name of the handler to search for.
e
The event descriptor describing the methods signature

Return Value

true if the handler exists, otherwise false.

See Also

ICodeNavigatorService Interface | ICodeNavigatorService Members | System.ComponentModel.Design Namespace


ICodeNavigatorService.GetCompatibleMethods

Gets the names of methods that have signatures compatible with the specified delegate class.

[Visual Basic]
Function GetCompatibleMethods( _
   ByVal delegateClass As Type _
) As String ()
[C#]
string[] GetCompatibleMethods(
   Type delegateClass
);
[C++]
String* GetCompatibleMethods(
   Type* delegateClass
) [] = 0;
[JScript]
function GetCompatibleMethods(
   delegateClass : Type
) : String[];

Parameters

delegateClass
The class of delegate to get compatible methods for.

Return Value

An array of strings that reflect the names of compatible methods.

See Also

ICodeNavigatorService Interface | ICodeNavigatorService Members | System.ComponentModel.Design Namespace


ICodeNavigatorService.GetDoesFieldExist

Gets if a field of the given name exists in the code.

[Visual Basic]
Function GetDoesFieldExist( _
   ByVal name As String _
) As Boolean
[C#]
bool GetDoesFieldExist(
   string name
);
[C++]
bool GetDoesFieldExist(
   String* name
) = 0;
[JScript]
function GetDoesFieldExist(
   name : String
) : Boolean;

Parameters

name
The name of the field.

Return Value

true if the field exists, otherwise false.

See Also

ICodeNavigatorService Interface | ICodeNavigatorService Members | System.ComponentModel.Design Namespace


ICodeNavigatorService.GetDoesMethodExist

Gets whether or not a method of the specified name exists in the code.

[Visual Basic]
Function GetDoesMethodExist( _
   ByVal name As String, _
   ByVal argTypes() As Type _
) As Boolean
[C#]
bool GetDoesMethodExist(
   string name,
   Type[] argTypes
);
[C++]
bool GetDoesMethodExist(
   String* name,
   Type* argTypes[]
) = 0;
[JScript]
function GetDoesMethodExist(
   name : String,
   argTypes : Type[]
) : Boolean;

Parameters

name
The name of the method.
argTypes
The types of the arguments for the method.

Return Value

true if the method exists, otherwise false.

See Also

ICodeNavigatorService Interface | ICodeNavigatorService Members | System.ComponentModel.Design Namespace


ICodeNavigatorService.NavigateToEvent

Requests that the source view for the file be displayed and that the cursor be placed within the block for the given event.

Overload List

Requests that the source view for the file be displayed and that the cursor be placed within the block for the given event.

[Visual Basic] Overloads Function NavigateToEvent(IComponent, EventDescriptor, Integer, String) As String
[C#] string NavigateToEvent(IComponent, EventDescriptor, int, String);
[C++] String* NavigateToEvent(IComponent*, EventDescriptor, int, String) = 0;
[JScript] function NavigateToEvent(IComponent, EventDescriptor, int, String) : String;

Requests that the source view for the file be displayed and that the cursor be placed within the block for the given event.

[Visual Basic] Overloads Function NavigateToEvent(IComponent, EventDescriptor, Integer) As String
[C#] string NavigateToEvent(IComponent, EventDescriptor, int);
[C++] String* NavigateToEvent(IComponent*, EventDescriptor, int) = 0;
[JScript] function NavigateToEvent(IComponent, EventDescriptor, int) : String;

See Also

ICodeNavigatorService Interface | ICodeNavigatorService Members | System.ComponentModel.Design Namespace


ICodeNavigatorService.NavigateToEvent (IComponent, EventDescriptor, Int32, String)

Requests that the source view for the file be displayed and that the cursor be placed within the block for the given event.

[Visual Basic]
Overloads Function NavigateToEvent( _
   ByVal component As IComponent, _
   ByVal eventdesc As EventDescriptor, _
   ByVal mods As Integer, _
   ByVal name As String _
) As String
[C#]
string NavigateToEvent(
   IComponent component,
   EventDescriptor eventdesc,
   int mods,
   string name
);
[C++]
String* NavigateToEvent(
   IComponent* component,
   EventDescriptor* eventdesc,
   int mods,
   String* name
) = 0;
[JScript]
function NavigateToEvent(
   component : IComponent,
   eventdesc : EventDescriptor,
   mods : int,
   name : String
) : String;

Parameters

component
The component that the event is bound to.
eventdesc
[To be supplied.]
mods
The modifiers for the method, should it need to be created.
name
The name of the method.

Return Value

The name of the event method that was created, or a null reference (in Visual Basic Nothing) if an existing method was found.

Remarks

This will navigate to the given event name, and if no such method exists, it should create one.

See Also

ICodeNavigatorService Interface | ICodeNavigatorService Members | System.ComponentModel.Design Namespace | ICodeNavigatorService.NavigateToEvent Overload List


ICodeNavigatorService.NavigateToEvent (IComponent, EventDescriptor, Int32)

Requests that the source view for the file be displayed and that the cursor be placed within the block for the given event.

[Visual Basic]
Overloads Function NavigateToEvent( _
   ByVal component As IComponent, _
   ByVal eventdesc As EventDescriptor, _
   ByVal mods As Integer _
) As String
[C#]
string NavigateToEvent(
   IComponent component,
   EventDescriptor eventdesc,
   int mods
);
[C++]
String* NavigateToEvent(
   IComponent* component,
   EventDescriptor* eventdesc,
   int mods
) = 0;
[JScript]
function NavigateToEvent(
   component : IComponent,
   eventdesc : EventDescriptor,
   mods : int
) : String;

Parameters

component
The component that the event is bound to.
eventdesc
The event to navigate to.
mods
The modifiers for the method, should it need to be created.

Return Value

The name of the event method.

See Also

ICodeNavigatorService Interface | ICodeNavigatorService Members | System.ComponentModel.Design Namespace | ICodeNavigatorService.NavigateToEvent Overload List


ICodePersisterTaskListService Interface

The ICodePersisterTaskListService interface provides a way to create a list of failures during the code persistance routines.

ICodePersisterTaskListService

[Visual Basic]
Public Interface ICodePersisterTaskListService
[C#]
public interface ICodePersisterTaskListService
[C++]
public __gc __interface ICodePersisterTaskListService

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

ICodePersisterTaskListService Members | System.ComponentModel.Design Namespace


ICodePersisterTaskListService Members

Methods

AddFailure | Adds a failure to the task list.
Clear | Clears the task list.

See Also

ICodePersisterTaskListService Interface | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodePersisterTaskListService Methods

The methods of the ICodePersisterTaskListService interface are listed below. For a complete list of ICodePersisterTaskListService interface members, see the ICodePersisterTaskListService Members topic.

AddFailure | Adds a failure to the task list.
Clear | Clears the task list.

See Also

ICodePersisterTaskListService Interface | System.ComponentModel.Design Namespace


ICodePersisterTaskListService.AddFailure

Adds a failure to the task list.

[Visual Basic]
Sub AddFailure( _
   ByVal text As String, _
   ByVal file As String, _
   ByVal beginLine As Integer, _
   ByVal beginColumn As Integer, _
   ByVal endLine As Integer, _
   ByVal endColumn As Integer _
)
[C#]
void AddFailure(
   string text,
   string file,
   int beginLine,
   int beginColumn,
   int endLine,
   int endColumn
);
[C++]
void AddFailure(
   String* text,
   String* file,
   int beginLine,
   int beginColumn,
   int endLine,
   int endColumn
) = 0;
[JScript]
function AddFailure(
   text : String,
   file : String,
   beginLine : int,
   beginColumn : int,
   endLine : int,
   endColumn : int
);

Parameters

text
A text descriptor.
file
The file name.
beginLine
The beginning line position.
beginColumn
The beginning column position.
endLine
The ending line position.
endColumn
The ending column position.

See Also

ICodePersisterTaskListService Interface | ICodePersisterTaskListService Members | System.ComponentModel.Design Namespace


ICodePersisterTaskListService.Clear

Clears the task list.

[Visual Basic]
Sub Clear()
[C#]
void Clear();
[C++]
void Clear() = 0;
[JScript]
function Clear();

See Also

ICodePersisterTaskListService Interface | ICodePersisterTaskListService Members | System.ComponentModel.Design Namespace


IComponentChangeService Interface

Provides an interface to add and remove the event handlers for component add, change, remove and rename events.

IComponentChangeService

[Visual Basic]
Public Interface IComponentChangeService
[C#]
public interface IComponentChangeService
[C++]
public __gc __interface IComponentChangeService

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

This service is used by property descriptors to announce when a component has changed or is about to change. A set of properties and events is provided for each type of component. The design environment can alter the property and event set at design time through the use of extender providers and designers. Typically, this service is implemented at design time when a container is expected to mark a form design changed.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

IComponentChangeService Members | System.ComponentModel.Design Namespace | ComponentEventHandler | ComponentChangedEventHandler | ComponentChangingEventHandler | ComponentRenameEventHandler | MemberDescriptor


IComponentChangeService Members

Methods

OnComponentChanged | Announces to the component change service that a particular component has changed.
OnComponentChanging | Announces to the component change service that a particular component is changing.

Events

ComponentAdded | [To be supplied.]
ComponentAdding | [To be supplied.]
ComponentChanged | [To be supplied.]
ComponentChanging | [To be supplied.]
ComponentRemoved | [To be supplied.]
ComponentRemoving | [To be supplied.]
ComponentRename | [To be supplied.]

Event Hookup:

Methods

AddOnComponentAdded | Adds an event handler for the System.ComponentModel.Design.IComponentChangeService.OnComponentAdded event.
AddOnComponentAdding | Adds an event handler for the System.ComponentModel.Design.IComponentChangeService.OnComponentAdding event.
AddOnComponentChanged | Adds an event handler for the OnComponentChanged event.
AddOnComponentChanging | Adds an event handler for the OnComponentChanging event.
AddOnComponentRemoved | Adds an event handler for the System.ComponentModel.Design.IComponentChangeService.OnComponentRemoved event.
AddOnComponentRemoving | Adds an event handler for the System.ComponentModel.Design.IComponentChangeService.OnComponentRemoving event.
AddOnComponentRename | Adds an event handler for the System.ComponentModel.Design.IComponentChangeService.OnComponentRename event.
RemoveOnComponentAdded | Removes the System.ComponentModel.Design.IComponentChangeService.OnComponentAdded event handler.
RemoveOnComponentAdding | Removes the System.ComponentModel.Design.IComponentChangeService.OnComponentAdding event handler.
RemoveOnComponentChanged | Removes the OnComponentChanged event handler.
RemoveOnComponentChanging | Removes the OnComponentChanging event handler.
RemoveOnComponentRemoved | Removes the System.ComponentModel.Design.IComponentChangeService.OnComponentRemoved event handler.
RemoveOnComponentRemoving | Removes the System.ComponentModel.Design.IComponentChangeService.OnComponentRemoving event handler.
RemoveOnComponentRename | Removes the System.ComponentModel.Design.IComponentChangeService.OnComponentRename event handler.

See Also

IComponentChangeService Interface | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IComponentChangeService Methods

The methods of the IComponentChangeService interface are listed below. For a complete list of IComponentChangeService interface members, see the IComponentChangeService Members topic.

OnComponentChanged | Announces to the component change service that a particular component has changed.
OnComponentChanging | Announces to the component change service that a particular component is changing.

Event Hookup:

AddOnComponentAdded | Adds an event handler for the System.ComponentModel.Design.IComponentChangeService.OnComponentAdded event.
AddOnComponentAdding | Adds an event handler for the System.ComponentModel.Design.IComponentChangeService.OnComponentAdding event.
AddOnComponentChanged | Adds an event handler for the OnComponentChanged event.
AddOnComponentChanging | Adds an event handler for the OnComponentChanging event.
AddOnComponentRemoved | Adds an event handler for the System.ComponentModel.Design.IComponentChangeService.OnComponentRemoved event.
AddOnComponentRemoving | Adds an event handler for the System.ComponentModel.Design.IComponentChangeService.OnComponentRemoving event.
AddOnComponentRename | Adds an event handler for the System.ComponentModel.Design.IComponentChangeService.OnComponentRename event.
RemoveOnComponentAdded | Removes the System.ComponentModel.Design.IComponentChangeService.OnComponentAdded event handler.
RemoveOnComponentAdding | Removes the System.ComponentModel.Design.IComponentChangeService.OnComponentAdding event handler.
RemoveOnComponentChanged | Removes the OnComponentChanged event handler.
RemoveOnComponentChanging | Removes the OnComponentChanging event handler.
RemoveOnComponentRemoved | Removes the System.ComponentModel.Design.IComponentChangeService.OnComponentRemoved event handler.
RemoveOnComponentRemoving | Removes the System.ComponentModel.Design.IComponentChangeService.OnComponentRemoving event handler.
RemoveOnComponentRename | Removes the System.ComponentModel.Design.IComponentChangeService.OnComponentRename event handler.

See Also

IComponentChangeService Interface | System.ComponentModel.Design Namespace


IComponentChangeService.AddOnComponentAdded

Adds an event handler for the System.ComponentModel.Design.IComponentChangeService.OnComponentAdded event.

[Visual Basic]
Sub AddOnComponentAdded( _
   ByVal handler As ComponentEventHandler _
)
[C#]
void AddOnComponentAdded(
   ComponentEventHandler handler
);
[C++]
void AddOnComponentAdded(
   ComponentEventHandler* handler
) = 0;
[JScript]
function AddOnComponentAdded(
   handler : ComponentEventHandler
);

Parameters

handler
A ComponentEventHandler delegate that represents the method that will handle the ComponentEvent.

Remarks

This event occurs during load and when new components are created by the user, after the component has been sited.

See Also

IComponentChangeService Interface | IComponentChangeService Members | System.ComponentModel.Design Namespace | RemoveOnComponentAdded | ComponentEventHandler


IComponentChangeService.AddOnComponentAdding

Adds an event handler for the System.ComponentModel.Design.IComponentChangeService.OnComponentAdding event.

[Visual Basic]
Sub AddOnComponentAdding( _
   ByVal handler As ComponentEventHandler _
)
[C#]
void AddOnComponentAdding(
   ComponentEventHandler handler
);
[C++]
void AddOnComponentAdding(
   ComponentEventHandler* handler
) = 0;
[JScript]
function AddOnComponentAdding(
   handler : ComponentEventHandler
);

Parameters

handler
A ComponentEventHandler delegate that represents the method that will handle the ComponentEvent.

Remarks

This event occurs during load and when the user creates a new component. You can cancel the add by throwing an exception here.

See Also

IComponentChangeService Interface | IComponentChangeService Members | System.ComponentModel.Design Namespace | RemoveOnComponentAdding | ComponentEventHandler


IComponentChangeService.AddOnComponentChanged

Adds an event handler for the OnComponentChanged event.

[Visual Basic]
Sub AddOnComponentChanged( _
   ByVal handler As ComponentChangedEventHandler _
)
[C#]
void AddOnComponentChanged(
   ComponentChangedEventHandler handler
);
[C++]
void AddOnComponentChanged(
   ComponentChangedEventHandler* handler
) = 0;
[JScript]
function AddOnComponentChanged(
   handler : ComponentChangedEventHandler
);

Parameters

handler
A ComponentChangedEventHandler delegate that represents the method that will handle the ComponentChangedEvent.

Remarks

This event occurs when any component on the form changes. It will not occur during form load and unload, because changes are expected at this time.

See Also

IComponentChangeService Interface | IComponentChangeService Members | System.ComponentModel.Design Namespace | RemoveOnComponentChanged | ComponentChangedEventHandler


IComponentChangeService.AddOnComponentChanging

Adds an event handler for the OnComponentChanging event.

[Visual Basic]
Sub AddOnComponentChanging( _
   ByVal handler As ComponentChangingEventHandler _
)
[C#]
void AddOnComponentChanging(
   ComponentChangingEventHandler handler
);
[C++]
void AddOnComponentChanging(
   ComponentChangingEventHandler* handler
) = 0;
[JScript]
function AddOnComponentChanging(
   handler : ComponentChangingEventHandler
);

Parameters

handler
A ComponentChangingEventHandler delegate that represents the method that will handle the ComponentChangingEvent.

Remarks

This event occurs before the component is actually changed. It gives a designer the chance to abort the change. Generally, only the top-level designer cares about such change requests. This event does not occur during form load and unload, because changes are expected at this time.

See Also

IComponentChangeService Interface | IComponentChangeService Members | System.ComponentModel.Design Namespace | RemoveOnComponentChanging | ComponentChangingEventHandler


IComponentChangeService.AddOnComponentRemoved

Adds an event handler for the System.ComponentModel.Design.IComponentChangeService.OnComponentRemoved event.

[Visual Basic]
Sub AddOnComponentRemoved( _
   ByVal handler As ComponentEventHandler _
)
[C#]
void AddOnComponentRemoved(
   ComponentEventHandler handler
);
[C++]
void AddOnComponentRemoved(
   ComponentEventHandler* handler
) = 0;
[JScript]
function AddOnComponentRemoved(
   handler : ComponentEventHandler
);

Parameters

handler
A ComponentEventHandler delegate that represents the method that will handle the ComponentRemovedEvent.

Remarks

This event occurs during unload and when a component is deleted by the user. The event occurs before the site has been removed from the component.

See Also

IComponentChangeService Interface | IComponentChangeService Members | System.ComponentModel.Design Namespace | RemoveOnComponentRemoved | ComponentEventHandler


IComponentChangeService.AddOnComponentRemoving

Adds an event handler for the System.ComponentModel.Design.IComponentChangeService.OnComponentRemoving event.

[Visual Basic]
Sub AddOnComponentRemoving( _
   ByVal handler As ComponentEventHandler _
)
[C#]
void AddOnComponentRemoving(
   ComponentEventHandler handler
);
[C++]
void AddOnComponentRemoving(
   ComponentEventHandler* handler
) = 0;
[JScript]
function AddOnComponentRemoving(
   handler : ComponentEventHandler
);

Parameters

handler
A ComponentEventHandler delegate that represents the method that will handle the ComponentRemovingEvent.

Remarks

This event occurs during unload and when the user deletes a component. You can veto the remove by throwing an exception here.

See Also

IComponentChangeService Interface | IComponentChangeService Members | System.ComponentModel.Design Namespace | RemoveOnComponentRemoving | ComponentEventHandler


IComponentChangeService.AddOnComponentRename

Adds an event handler for the System.ComponentModel.Design.IComponentChangeService.OnComponentRename event.

[Visual Basic]
Sub AddOnComponentRename( _
   ByVal handler As ComponentRenameEventHandler _
)
[C#]
void AddOnComponentRename(
   ComponentRenameEventHandler handler
);
[C++]
void AddOnComponentRename(
   ComponentRenameEventHandler* handler
) = 0;
[JScript]
function AddOnComponentRename(
   handler : ComponentRenameEventHandler
);

Parameters

handler
A ComponentRenameEventHandler delegate that represents the method that will handle the ComponentRenameEvent.

Remarks

This event occurs after the OnComponentChanged event when a component has been renamed.

See Also

IComponentChangeService Interface | IComponentChangeService Members | System.ComponentModel.Design Namespace | RemoveOnComponentRename | ComponentRenameEventHandler


IComponentChangeService.OnComponentChanged

Announces to the component change service that a particular component has changed.

[Visual Basic]
Sub OnComponentChanged( _
   ByVal component As Object, _
   ByVal member As MemberDescriptor, _
   ByVal oldValue As Object, _
   ByVal newValue As Object _
)
[C#]
void OnComponentChanged(
   object component,
   MemberDescriptor member,
   object oldValue,
   object newValue
);
[C++]
void OnComponentChanged(
   Object* component,
   MemberDescriptor* member,
   Object* oldValue,
   Object* newValue
) = 0;
[JScript]
function OnComponentChanged(
   component : Object,
   member : MemberDescriptor,
   oldValue : Object,
   newValue : Object
);

Parameters

component
The component that has changed.
member
The member that has changed. If this change is not related to a single member, this can be a null reference (in Visual Basic Nothing).
oldValue
The old value of the member. This is only valid if member is not a null reference (Nothing).
newValue
The new value of the member. This is only valid if member is not a null reference (Nothing).

Remarks

This event is called after a property has been changed. The framework typically calls these for you, so most of the time you don't need to explictly call them.

This event allows the implementor to do any post-processing that may be needed after a property change. For example, a designer will typically update the source code that sets the property with the new value.

See Also

IComponentChangeService Interface | IComponentChangeService Members | System.ComponentModel.Design Namespace | System.ComponentModel.Design.MemberDescriptor


IComponentChangeService.OnComponentChanging

Announces to the component change service that a particular component is changing.

[Visual Basic]
Sub OnComponentChanging( _
   ByVal component As Object, _
   ByVal member As MemberDescriptor _
)
[C#]
void OnComponentChanging(
   object component,
   MemberDescriptor member
);
[C++]
void OnComponentChanging(
   Object* component,
   MemberDescriptor* member
) = 0;
[JScript]
function OnComponentChanging(
   component : Object,
   member : MemberDescriptor
);

Parameters

component
The component that is about to change.
member
The memeber that is changing. If this change is not related to a single member, this can be a null reference (in Visual Basic Nothing).

Remarks

This event is called when a property is about to change. The framework typically calls this event for you, so most of the time you don't need to explictly call it.

The property descriptor calls this method before it commits the property. This method should throw an exception if the property cannot be changed. This is not intended to validate the values of a particular property. Instead, it is intended to provide a global method of preventing a component from changing. For example, if a designer file is checked into source code control, this event's handler would typically throw an exception if the user refused to check out the file.

See Also

IComponentChangeService Interface | IComponentChangeService Members | System.ComponentModel.Design Namespace | System.ComponentModel.Design.MemberDescriptor


IComponentChangeService.RemoveOnComponentAdded

Removes the System.ComponentModel.Design.IComponentChangeService.OnComponentAdded event handler.

[Visual Basic]
Sub RemoveOnComponentAdded( _
   ByVal handler As ComponentEventHandler _
)
[C#]
void RemoveOnComponentAdded(
   ComponentEventHandler handler
);
[C++]
void RemoveOnComponentAdded(
   ComponentEventHandler* handler
) = 0;
[JScript]
function RemoveOnComponentAdded(
   handler : ComponentEventHandler
);

Parameters

handler
The ComponentEventHandler to remove.

See Also

IComponentChangeService Interface | IComponentChangeService Members | System.ComponentModel.Design Namespace | AddOnComponentAdded | ComponentEventHandler


IComponentChangeService.RemoveOnComponentAdding

Removes the System.ComponentModel.Design.IComponentChangeService.OnComponentAdding event handler.

[Visual Basic]
Sub RemoveOnComponentAdding( _
   ByVal handler As ComponentEventHandler _
)
[C#]
void RemoveOnComponentAdding(
   ComponentEventHandler handler
);
[C++]
void RemoveOnComponentAdding(
   ComponentEventHandler* handler
) = 0;
[JScript]
function RemoveOnComponentAdding(
   handler : ComponentEventHandler
);

Parameters

handler
The ComponentEventHandler to remove.

See Also

IComponentChangeService Interface | IComponentChangeService Members | System.ComponentModel.Design Namespace | AddOnComponentAdding | ComponentEventHandler


IComponentChangeService.RemoveOnComponentChanged

Removes the OnComponentChanged event handler.

[Visual Basic]
Sub RemoveOnComponentChanged( _
   ByVal handler As ComponentChangedEventHandler _
)
[C#]
void RemoveOnComponentChanged(
   ComponentChangedEventHandler handler
);
[C++]
void RemoveOnComponentChanged(
   ComponentChangedEventHandler* handler
) = 0;
[JScript]
function RemoveOnComponentChanged(
   handler : ComponentChangedEventHandler
);

Parameters

handler
The ComponentEventHandler to remove.

See Also

IComponentChangeService Interface | IComponentChangeService Members | System.ComponentModel.Design Namespace | AddOnComponentChanged | ComponentChangedEventHandler


IComponentChangeService.RemoveOnComponentChanging

Removes the OnComponentChanging event handler.

[Visual Basic]
Sub RemoveOnComponentChanging( _
   ByVal handler As ComponentChangingEventHandler _
)
[C#]
void RemoveOnComponentChanging(
   ComponentChangingEventHandler handler
);
[C++]
void RemoveOnComponentChanging(
   ComponentChangingEventHandler* handler
) = 0;
[JScript]
function RemoveOnComponentChanging(
   handler : ComponentChangingEventHandler
);

Parameters

handler
The ComponentChangingEventHandler to remove.

See Also

IComponentChangeService Interface | IComponentChangeService Members | System.ComponentModel.Design Namespace | AddOnComponentChanging | ComponentChangingEventHandler


IComponentChangeService.RemoveOnComponentRemoved

Removes the System.ComponentModel.Design.IComponentChangeService.OnComponentRemoved event handler.

[Visual Basic]
Sub RemoveOnComponentRemoved( _
   ByVal handler As ComponentEventHandler _
)
[C#]
void RemoveOnComponentRemoved(
   ComponentEventHandler handler
);
[C++]
void RemoveOnComponentRemoved(
   ComponentEventHandler* handler
) = 0;
[JScript]
function RemoveOnComponentRemoved(
   handler : ComponentEventHandler
);

Parameters

handler
The ComponentEventHandler to remove.

See Also

IComponentChangeService Interface | IComponentChangeService Members | System.ComponentModel.Design Namespace | AddOnComponentRemoved | ComponentEventHandler


IComponentChangeService.RemoveOnComponentRemoving

Removes the System.ComponentModel.Design.IComponentChangeService.OnComponentRemoving event handler.

[Visual Basic]
Sub RemoveOnComponentRemoving( _
   ByVal handler As ComponentEventHandler _
)
[C#]
void RemoveOnComponentRemoving(
   ComponentEventHandler handler
);
[C++]
void RemoveOnComponentRemoving(
   ComponentEventHandler* handler
) = 0;
[JScript]
function RemoveOnComponentRemoving(
   handler : ComponentEventHandler
);

Parameters

handler
The ComponentEventHandler to remove.

See Also

IComponentChangeService Interface | IComponentChangeService Members | System.ComponentModel.Design Namespace | AddOnComponentRemoving | ComponentEventHandler


IComponentChangeService.RemoveOnComponentRename

Removes the System.ComponentModel.Design.IComponentChangeService.OnComponentRename event handler.

[Visual Basic]
Sub RemoveOnComponentRename( _
   ByVal handler As ComponentRenameEventHandler _
)
[C#]
void RemoveOnComponentRename(
   ComponentRenameEventHandler handler
);
[C++]
void RemoveOnComponentRename(
   ComponentRenameEventHandler* handler
) = 0;
[JScript]
function RemoveOnComponentRename(
   handler : ComponentRenameEventHandler
);

Parameters

handler
The ComponentRenameEventHandler to remove.

See Also

IComponentChangeService Interface | IComponentChangeService Members | System.ComponentModel.Design Namespace | AddOnComponentRename | ComponentRenameEventHandler


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IComponentChangeService Events

The events of the IComponentChangeService interface are listed below. For a complete list of IComponentChangeService interface members, see the IComponentChangeService Members topic.

ComponentAdded | [To be supplied.]
ComponentAdding | [To be supplied.]
ComponentChanged | [To be supplied.]
ComponentChanging | [To be supplied.]
ComponentRemoved | [To be supplied.]
ComponentRemoving | [To be supplied.]
ComponentRename | [To be supplied.]

See Also

IComponentChangeService Interface | System.ComponentModel.Design Namespace


IComponentChangeService ComponentAdded Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the ComponentAdded event.

[Visual Basic]
Private Sub IComponentChangeServiceName_ComponentAdded( _
   ByVal sender As Object, _
   ByVal e As ComponentEventArgs _
)
[C#]
private void IComponentChangeServiceName_ComponentAdded(
   object sender,
   ComponentEventArgs e
);
[C++]
private: void IComponentChangeServiceName_ComponentAdded(
   Object* sender,
   ComponentEventArgs* e
);
[JScript]
private IComponentChangeServiceName_ComponentAdded(
   sender : Object,
   e : ComponentEventArgs
);

Parameters

sender
The source of the event.
e
A ComponentEventArgs that contains the event data. The following ComponentEventArgs properties provide information specific to this event.
Property Description
Component
Gets or sets the component associated with the event.

Remarks

This event occurs during load and when new components are created by the user, after the component has been sited.

See Also

IComponentChangeService Interface | IComponentChangeService MembersTopic | System.ComponentModel.Design Namespace


IComponentChangeService ComponentAdding Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the ComponentAdding event.

[Visual Basic]
Private Sub IComponentChangeServiceName_ComponentAdding( _
   ByVal sender As Object, _
   ByVal e As ComponentEventArgs _
)
[C#]
private void IComponentChangeServiceName_ComponentAdding(
   object sender,
   ComponentEventArgs e
);
[C++]
private: void IComponentChangeServiceName_ComponentAdding(
   Object* sender,
   ComponentEventArgs* e
);
[JScript]
private IComponentChangeServiceName_ComponentAdding(
   sender : Object,
   e : ComponentEventArgs
);

Parameters

sender
The source of the event.
e
A ComponentEventArgs that contains the event data. The following ComponentEventArgs properties provide information specific to this event.
Property Description
Component
Gets or sets the component associated with the event.

Remarks

This event occurs during load and when the user creates a new component. You can cancel the add by throwing an exception here.

See Also

IComponentChangeService Interface | IComponentChangeService MembersTopic | System.ComponentModel.Design Namespace


IComponentChangeService ComponentChanged Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the ComponentChanged event.

[Visual Basic]
Private Sub IComponentChangeServiceName_ComponentChanged( _
   ByVal sender As Object, _
   ByVal e As ComponentChangedEventArgs _
)
[C#]
private void IComponentChangeServiceName_ComponentChanged(
   object sender,
   ComponentChangedEventArgs e
);
[C++]
private: void IComponentChangeServiceName_ComponentChanged(
   Object* sender,
   ComponentChangedEventArgs* e
);
[JScript]
private IComponentChangeServiceName_ComponentChanged(
   sender : Object,
   e : ComponentChangedEventArgs
);

Parameters

sender
The source of the event.
e
A ComponentChangedEventArgs that contains the event data. The following ComponentChangedEventArgs properties provide information specific to this event.
Property Description
Component
Gets or sets the component that is the cause of this event.
Member
Gets or sets the member that is about to change.
NewValue
Gets or sets the new value of the changed member.
OldValue
Gets or sets the old value of the changed member.

Remarks

This event occurs when any component on the form changes. It will not occur during form load and unload, because changes are expected at this time.

See Also

IComponentChangeService Interface | IComponentChangeService MembersTopic | System.ComponentModel.Design Namespace


IComponentChangeService ComponentChanging Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the ComponentChanging event.

[Visual Basic]
Private Sub IComponentChangeServiceName_ComponentChanging( _
   ByVal sender As Object, _
   ByVal e As ComponentChangingEventArgs _
)
[C#]
private void IComponentChangeServiceName_ComponentChanging(
   object sender,
   ComponentChangingEventArgs e
);
[C++]
private: void IComponentChangeServiceName_ComponentChanging(
   Object* sender,
   ComponentChangingEventArgs* e
);
[JScript]
private IComponentChangeServiceName_ComponentChanging(
   sender : Object,
   e : ComponentChangingEventArgs
);

Parameters

sender
The source of the event.
e
A ComponentChangingEventArgs that contains the event data. The following ComponentChangingEventArgs properties provide information specific to this event.
Property Description
Component
Gets or sets the component that is being changed or that is the parent container of the member being changed.
Member
Gets or sets the member of the component that is about to be changed.

Remarks

This event occurs before the component is actually changed. It gives a designer the chance to abort the change. Generally, only the top-level designer cares about such change requests. This event does not occur during form load and unload, because changes are expected at this time.

See Also

IComponentChangeService Interface | IComponentChangeService MembersTopic | System.ComponentModel.Design Namespace


IComponentChangeService ComponentRemoved Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the ComponentRemoved event.

[Visual Basic]
Private Sub IComponentChangeServiceName_ComponentRemoved( _
   ByVal sender As Object, _
   ByVal e As ComponentEventArgs _
)
[C#]
private void IComponentChangeServiceName_ComponentRemoved(
   object sender,
   ComponentEventArgs e
);
[C++]
private: void IComponentChangeServiceName_ComponentRemoved(
   Object* sender,
   ComponentEventArgs* e
);
[JScript]
private IComponentChangeServiceName_ComponentRemoved(
   sender : Object,
   e : ComponentEventArgs
);

Parameters

sender
The source of the event.
e
A ComponentEventArgs that contains the event data. The following ComponentEventArgs properties provide information specific to this event.
Property Description
Component
Gets or sets the component associated with the event.

Remarks

This event occurs during unload and when a component is deleted by the user. The event occurs before the site has been removed from the component.

See Also

IComponentChangeService Interface | IComponentChangeService MembersTopic | System.ComponentModel.Design Namespace


IComponentChangeService ComponentRemoving Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the ComponentRemoving event.

[Visual Basic]
Private Sub IComponentChangeServiceName_ComponentRemoving( _
   ByVal sender As Object, _
   ByVal e As ComponentEventArgs _
)
[C#]
private void IComponentChangeServiceName_ComponentRemoving(
   object sender,
   ComponentEventArgs e
);
[C++]
private: void IComponentChangeServiceName_ComponentRemoving(
   Object* sender,
   ComponentEventArgs* e
);
[JScript]
private IComponentChangeServiceName_ComponentRemoving(
   sender : Object,
   e : ComponentEventArgs
);

Parameters

sender
The source of the event.
e
A ComponentEventArgs that contains the event data. The following ComponentEventArgs properties provide information specific to this event.
Property Description
Component
Gets or sets the component associated with the event.

Remarks

This event occurs during unload and when the user deletes a component. You can veto the remove by throwing an exception here

See Also

IComponentChangeService Interface | IComponentChangeService MembersTopic | System.ComponentModel.Design Namespace


IComponentChangeService ComponentRename Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the ComponentRename event.

[Visual Basic]
Private Sub IComponentChangeServiceName_ComponentRename( _
   ByVal sender As Object, _
   ByVal e As ComponentRenameEventArgs _
)
[C#]
private void IComponentChangeServiceName_ComponentRename(
   object sender,
   ComponentRenameEventArgs e
);
[C++]
private: void IComponentChangeServiceName_ComponentRename(
   Object* sender,
   ComponentRenameEventArgs* e
);
[JScript]
private IComponentChangeServiceName_ComponentRename(
   sender : Object,
   e : ComponentRenameEventArgs
);

Parameters

sender
The source of the event.
e
A ComponentRenameEventArgs that contains the event data. The following ComponentRenameEventArgs properties provide information specific to this event.
Property Description
Component
Gets or sets the component that is being renamed.
NewName
Gets or sets the current name of the component.
OldName
Gets or sets the name of the component before the rename.

Remarks

This event occurs after the OnComponentChanged event when a component has been renamed.

See Also

IComponentChangeService Interface | IComponentChangeService MembersTopic | System.ComponentModel.Design Namespace


IComponentCodePersistanceService Interface

Provides an interface for retrieving components from code or persisting components to code.

IComponentCodePersistanceService

[Visual Basic]
Public Interface IComponentCodePersistanceService
[C#]
public interface IComponentCodePersistanceService
[C++]
public __gc __interface IComponentCodePersistanceService

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

IComponentCodePersistanceService Members | System.ComponentModel.Design Namespace | IComponent


IComponentCodePersistanceService Members

Methods

GetCodeFromComponents | Overloaded. Gets code that persists the specified components.
GetComponentsFromCode | Gets the components persisted in the specified code, up to the specified maximum number of components.

See Also

IComponentCodePersistanceService Interface | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IComponentCodePersistanceService Methods

The methods of the IComponentCodePersistanceService interface are listed below. For a complete list of IComponentCodePersistanceService interface members, see the IComponentCodePersistanceService Members topic.

GetCodeFromComponents | Overloaded. Gets code that persists the specified components.
GetComponentsFromCode | Gets the components persisted in the specified code, up to the specified maximum number of components.

See Also

IComponentCodePersistanceService Interface | System.ComponentModel.Design Namespace


IComponentCodePersistanceService.GetCodeFromComponents

Gets code that persists the specified components.

Overload List

Gets code that persists the specified components.

[Visual Basic] Overloads Function GetCodeFromComponents(IComponent()) As String
[C#] string GetCodeFromComponents(IComponent[]);
[C++] String* GetCodeFromComponents(IComponent*[]) = 0;
[JScript] function GetCodeFromComponents(IComponent[]) : String;

Gets code that persists the specified components.

[Visual Basic] Overloads Function GetCodeFromComponents(IComponent(), Integer, Integer) As String
[C#] string GetCodeFromComponents(IComponent[], int, int);
[C++] String* GetCodeFromComponents(IComponent*[], int, int) = 0;
[JScript] function GetCodeFromComponents(IComponent[], int, int) : String;

See Also

IComponentCodePersistanceService Interface | IComponentCodePersistanceService Members | System.ComponentModel.Design Namespace


IComponentCodePersistanceService.GetCodeFromComponents (IComponent[])

Gets code that persists the specified components.

[Visual Basic]
Overloads Function GetCodeFromComponents( _
   ByVal components() As IComponent _
) As String
[C#]
string GetCodeFromComponents(
   IComponent[] components
);
[C++]
String* GetCodeFromComponents(
   IComponent* components[]
) = 0;
[JScript]
function GetCodeFromComponents(
   components : IComponent[]
) : String;

Parameters

components
An array of type IComponent that indicates the components to return code to represent.

Return Value

Code that persists the specified components.

See Also

IComponentCodePersistanceService Interface | IComponentCodePersistanceService Members | System.ComponentModel.Design Namespace | IComponentCodePersistanceService.GetCodeFromComponents Overload List | IComponent


IComponentCodePersistanceService.GetCodeFromComponents (IComponent[], Int32, Int32)

Gets code that persists the specified components.

[Visual Basic]
Overloads Function GetCodeFromComponents( _
   ByVal components() As IComponent, _
   ByVal xLocationOffset As Integer, _
   ByVal yLocationOffset As Integer _
) As String
[C#]
string GetCodeFromComponents(
   IComponent[] components,
   int xLocationOffset,
   int yLocationOffset
);
[C++]
String* GetCodeFromComponents(
   IComponent* components[],
   int xLocationOffset,
   int yLocationOffset
) = 0;
[JScript]
function GetCodeFromComponents(
   components : IComponent[],
   xLocationOffset : int,
   yLocationOffset : int
) : String;

Parameters

components
An array of type IComponent that indicates the components to return code to represent.
xLocationOffset
[To be supplied.]
yLocationOffset
[To be supplied.]

Return Value

Code that persists the specified components.

See Also

IComponentCodePersistanceService Interface | IComponentCodePersistanceService Members | System.ComponentModel.Design Namespace | IComponentCodePersistanceService.GetCodeFromComponents Overload List | IComponent


IComponentCodePersistanceService.GetComponentsFromCode

Gets the components persisted in the specified code, up to the specified maximum number of components.

[Visual Basic]
Function GetComponentsFromCode( _
   ByVal code As String, _
   ByVal maxComponents As Integer _
) As IComponent ()
[C#]
IComponent[] GetComponentsFromCode(
   string code,
   int maxComponents
);
[C++]
IComponent* GetComponentsFromCode(
   String* code,
   int maxComponents
) [] = 0;
[JScript]
function GetComponentsFromCode(
   code : String,
   maxComponents : int
) : IComponent[];

Parameters

code
The code to build components from.
maxComponents
[To be supplied.]

Return Value

An array of type IComponent containing the components rebuilt from the specified code.

See Also

IComponentCodePersistanceService Interface | IComponentCodePersistanceService Members | System.ComponentModel.Design Namespace | IComponent


ICompoundActionUnit Interface

Represents a series of action units that should be treated as a single atomic action.

ICompoundActionUnit

[Visual Basic]
Public Interface ICompoundActionUnit
   Implements IActionUnit
[C#]
public interface ICompoundActionUnit : IActionUnit
[C++]
public __gc __interface ICompoundActionUnit : public IActionUnit

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

Undoing or redoing this action will cause all of the child actions to be done or undone in the appropriate order.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

ICompoundActionUnit Members | System.ComponentModel.Design Namespace | IUndoService | IActionUnit


ICompoundActionUnit Members

Methods

Add | Adds a child unit to this compound event.
CanAddChildren | Gets whether or not this compound action is in a state that can recieve child actions.
GetChild | Gets the child action at the specified index.
GetChildCount | Gets the current number of child actions this compound action contains.
GetChildren | Gets an array of the child actions, if any exist.
Remove | Removes a child item from this compound action.

See Also

ICompoundActionUnit Interface | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICompoundActionUnit Methods

The methods of the ICompoundActionUnit interface are listed below. For a complete list of ICompoundActionUnit interface members, see the ICompoundActionUnit Members topic.

Add | Adds a child unit to this compound event.
CanAddChildren | Gets whether or not this compound action is in a state that can recieve child actions.
GetChild | Gets the child action at the specified index.
GetChildCount | Gets the current number of child actions this compound action contains.
GetChildren | Gets an array of the child actions, if any exist.
Remove | Removes a child item from this compound action.

See Also

ICompoundActionUnit Interface | System.ComponentModel.Design Namespace


ICompoundActionUnit.Add

Adds a child unit to this compound event.

[Visual Basic]
Sub Add( _
   ByVal childAction As IActionUnit _
)
[C#]
void Add(
   IActionUnit childAction
);
[C++]
void Add(
   IActionUnit* childAction
) = 0;
[JScript]
function Add(
   childAction : IActionUnit
);

Parameters

childAction
The IActionUnit child to add.

Remarks

Child units will be executed in the order added and undone in the reverse order. If this compund action is in a state so that it cannot accept children, an exception is thrown.

See Also

ICompoundActionUnit Interface | ICompoundActionUnit Members | System.ComponentModel.Design Namespace


ICompoundActionUnit.CanAddChildren

Gets whether or not this compound action is in a state that can recieve child actions.

[Visual Basic]
Function CanAddChildren() As Boolean
[C#]
bool CanAddChildren();
[C++]
bool CanAddChildren() = 0;
[JScript]
function CanAddChildren() : Boolean;

Return Value

true if children can be added; otherwise false.

See Also

ICompoundActionUnit Interface | ICompoundActionUnit Members | System.ComponentModel.Design Namespace | Add


ICompoundActionUnit.GetChild

Gets the child action at the specified index.

[Visual Basic]
Function GetChild( _
   ByVal index As Integer _
) As IActionUnit
[C#]
IActionUnit GetChild(
   int index
);
[C++]
IActionUnit* GetChild(
   int index
) = 0;
[JScript]
function GetChild(
   index : int
) : IActionUnit;

Parameters

index
The zero-based index of the child to retrieve.

Return Value

The IActionUnit at the specified index.

Exceptions

Exception Type | Condition
ArgumentException | The index is less than zero or greater than the number of children.

Remarks

If index is less than zero or greater than the number of children, an ArgumentException is thrown. Index zero correpsonds to the first child added to the compound action.

See Also

ICompoundActionUnit Interface | ICompoundActionUnit Members | System.ComponentModel.Design Namespace | GetChildren


ICompoundActionUnit.GetChildCount

Gets the current number of child actions this compound action contains.

[Visual Basic]
Function GetChildCount() As Integer
[C#]
int GetChildCount();
[C++]
int GetChildCount() = 0;
[JScript]
function GetChildCount() : int;

Return Value

The current number of child actions contained in this compound action.

See Also

ICompoundActionUnit Interface | ICompoundActionUnit Members | System.ComponentModel.Design Namespace


ICompoundActionUnit.GetChildren

Gets an array of the child actions, if any exist.

[Visual Basic]
Function GetChildren() As IActionUnit ()
[C#]
IActionUnit[] GetChildren();
[C++]
IActionUnit* GetChildren() [] = 0;
[JScript]
function GetChildren() : IActionUnit[];

Return Value

An array of type IActionUnit that represents the child items. If no child actions exist, a zero-length array is returned.

See Also

ICompoundActionUnit Interface | ICompoundActionUnit Members | System.ComponentModel.Design Namespace | GetChild


ICompoundActionUnit.Remove

Removes a child item from this compound action.

[Visual Basic]
Sub Remove( _
   ByVal childAction As IActionUnit _
)
[C#]
void Remove(
   IActionUnit childAction
);
[C++]
void Remove(
   IActionUnit* childAction
) = 0;
[JScript]
function Remove(
   childAction : IActionUnit
);

Parameters

childAction
The IActionUnit action to remove.

Exceptions

Exception Type | Condition
ArgumentException | The child to remove is not a child of the compound action.

Remarks

If this action is not the parent of the child action, an ArgumentException is thrown.

See Also

ICompoundActionUnit Interface | ICompoundActionUnit Members | System.ComponentModel.Design Namespace


IDeferLoadService Interface

Allows asynchronous loading of designers.

IDeferLoadService

[Visual Basic]
Public Interface IDeferLoadService
[C#]
public interface IDeferLoadService
[C++]
public __gc __interface IDeferLoadService

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

The designer host will not consider itself completely loaded until all calls to DeferLoad have been satisified by a corresponding OnDeferredLoadComplete.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

IDeferLoadService Members | System.ComponentModel.Design Namespace


IDeferLoadService Members

Methods

DeferLoad | Defers the load-complete state until a subsequent call to OnDeferredLoadComplete.
OnDeferredLoadComplete | Signals the completion of a previous deferred load.

See Also

IDeferLoadService Interface | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDeferLoadService Methods

The methods of the IDeferLoadService interface are listed below. For a complete list of IDeferLoadService interface members, see the IDeferLoadService Members topic.

DeferLoad | Defers the load-complete state until a subsequent call to OnDeferredLoadComplete.
OnDeferredLoadComplete | Signals the completion of a previous deferred load.

See Also

IDeferLoadService Interface | System.ComponentModel.Design Namespace


IDeferLoadService.DeferLoad

Defers the load-complete state until a subsequent call to OnDeferredLoadComplete.

[Visual Basic]
Sub DeferLoad()
[C#]
void DeferLoad();
[C++]
void DeferLoad() = 0;
[JScript]
function DeferLoad();

See Also

IDeferLoadService Interface | IDeferLoadService Members | System.ComponentModel.Design Namespace


IDeferLoadService.OnDeferredLoadComplete

Signals the completion of a previous deferred load.

[Visual Basic]
Sub OnDeferredLoadComplete()
[C#]
void OnDeferredLoadComplete();
[C++]
void OnDeferredLoadComplete() = 0;
[JScript]
function OnDeferredLoadComplete();

See Also

IDeferLoadService Interface | IDeferLoadService Members | System.ComponentModel.Design Namespace


IDesigner Interface

This interface provides the framework for building a custom designer. This interface stores the verbs available to the designer, as well as basic services for the designer.

IDesigner

[Visual Basic]
Public Interface IDesigner
[C#]
public interface IDesigner
[C++]
public __gc __interface IDesigner

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IDesigner

Class | Description
ComponentDesigner | The default designer for all components. Almost everything that extends from Component will typically have one of these designers as their base designer. Designers do not have to inherit from this class, but it does provide some convenient features.

Remarks

A designer is an object that can modify a component's design-time behavior. All visual components should have a designer, as the designer is responsible for updating a component's user interface at design-time. Designers do not directly provide their own UI, but they may draw adornments on their component's UI.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

IDesigner Members | System.ComponentModel.Design Namespace


IDesigner Members

Properties

Component | Gets or sets the component this designer is designing.
Verbs | Gets or sets the design-time verbs supported by the component associated with the designer.

Methods

Dispose | Disposes of the resources (other than memory) used by the IDesigner.
DoDefaultAction | Performs the default action for this designer.
Initialize | Initializes the designer with the given component.

See Also

IDesigner Interface | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDesigner Properties

The properties of the IDesigner interface are listed below. For a complete list of IDesigner interface members, see the IDesigner Members topic.

Component | Gets or sets the component this designer is designing.
Verbs | Gets or sets the design-time verbs supported by the component associated with the designer.

See Also

IDesigner Interface | System.ComponentModel.Design Namespace


IDesigner.Component

Gets or sets the component this designer is designing.

[Visual Basic]
ReadOnly Property Component As IComponent
[C#]
IComponent Component {get;}
[C++]
IComponent* get_Component() = 0;
[JScript]
abstract function get Component() : IComponent;

Property Value

An System.ComponentModel.Design.IComponent this designer is designing.

See Also

IDesigner Interface | IDesigner Members | System.ComponentModel.Design Namespace


IDesigner.Verbs

Gets or sets the design-time verbs supported by the component associated with the designer.

[Visual Basic]
ReadOnly Property Verbs As DesignerVerb ()
[C#]
DesignerVerb[] Verbs {get;}
[C++]
DesignerVerb* get_Verbs() = 0;
[JScript]
abstract function get Verbs() : DesignerVerb[];

Remarks

Returns the design-time verbs supported by the component associated with the designer. The verbs returned by this method are typically displayed in a right-click menu by the design-time environment. The return value may be null if the component has no design-time verbs. When a user selects one of the verbs, the performVerb() method is invoked with the the corresponding DesignerVerb object.

Note A design-time environment will typically provide a "Properties..." entry on a component's right-click menu. The getVerbs() method should therefore not include such an entry in the returned list of verbs.

See Also

IDesigner Interface | IDesigner Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDesigner Methods

The methods of the IDesigner interface are listed below. For a complete list of IDesigner interface members, see the IDesigner Members topic.

Dispose | Disposes of the resources (other than memory) used by the IDesigner.
DoDefaultAction | Performs the default action for this designer.
Initialize | Initializes the designer with the given component.

See Also

IDesigner Interface | System.ComponentModel.Design Namespace


IDesigner.Dispose

Disposes of the resources (other than memory) used by the IDesigner.

[Visual Basic]
Sub Dispose()
[C#]
void Dispose();
[C++]
void Dispose() = 0;
[JScript]
function Dispose();

Remarks

Call Dispose when you are finished using the IDesigner. The Dispose method leaves the IDesigner in an unusable state. After calling Dispose, you must release all references to the IDesigner so the memory it was occupying can be reclaimed by garbage collection.

Note Always call Dispose before you release your last reference to the IDesigner. Otherwise, the resources the IDesigner is using will not be freed until garbage collection calls the IDesigner object's destructor.

This disposal method should be called when the designer should be destroyed. It will be called before the designer's component is disposed. The designer should detach any events it is listening to at this time. It should not dispose of the component it is designing, however.

See Also

IDesigner Interface | IDesigner Members | System.ComponentModel.Design Namespace


IDesigner.DoDefaultAction

Performs the default action for this designer.

[Visual Basic]
Sub DoDefaultAction()
[C#]
void DoDefaultAction();
[C++]
void DoDefaultAction() = 0;
[JScript]
function DoDefaultAction();

Remarks

This method is usually called in response to a user action such as double-clicking on the representation of the component.

See Also

IDesigner Interface | IDesigner Members | System.ComponentModel.Design Namespace


IDesigner.Initialize

Initializes the designer with the given component.

[Visual Basic]
Sub Initialize( _
   ByVal component As IComponent _
)
[C#]
void Initialize(
   IComponent component
);
[C++]
void Initialize(
   IComponent* component
) = 0;
[JScript]
function Initialize(
   component : IComponent
);

Parameters

component
The component to associate with this designer.

See Also

IDesigner Interface | IDesigner Members | System.ComponentModel.Design Namespace


IDesignerEventService Interface

Provides global event notifications and the ability to create designers.

IDesignerEventService

[Visual Basic]
Public Interface IDesignerEventService
[C#]
public interface IDesignerEventService
[C++]
public __gc __interface IDesignerEventService

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

IDesignerEventService is a global service that is available to all designers, tool windows and services.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

IDesignerEventService Members | System.ComponentModel.Design Namespace


IDesignerEventService Members

Properties

Documents Gets or sets a collection of running design documents in the development environment.

Methods

GetActiveDocument Gets the currently active document.

Events

ActiveDocumentChanged | Occurs when the currently active document changes.
DocumentCreated | Occurs when a document is created.
DocumentDisposed | Occurs when a document is disposed.
SelectionChanged | Occurs when the global selection changes.

Event Hookup:

Methods

AddOnActiveDocumentChanged | Adds an event that will be raised when the currently active document changes.
AddOnDocumentCreated | Adds a handler to the document created event.
AddOnDocumentDisposed | Adds a handler to the document disposed event.
AddOnSelectionChanged | Adds an event that will be fired when the global selection changes.
RemoveOnActiveDocumentChanged | Removes a previously added event handler.
RemoveOnDocumentCreated | Removes a previously added event handler.
RemoveOnDocumentDisposed | Removes a previously added event handler.
RemoveOnSelectionChanged | Removes a previously added event handler.

See Also

IDesignerEventService Interface | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDesignerEventService Properties

The properties of the IDesignerEventService interface are listed below. For a complete list of IDesignerEventService interface members, see the IDesignerEventService Members topic.

Documents Gets or sets a collection of running design documents in the development environment.

See Also

IDesignerEventService Interface | System.ComponentModel.Design Namespace


IDesignerEventService.Documents

Gets or sets a collection of running design documents in the development environment.

[Visual Basic]
ReadOnly Property Documents As DocumentCollection
[C#]
DocumentCollection Documents {get;}
[C++]
DocumentCollection* get_Documents() = 0;
[JScript]
abstract function get Documents() : DocumentCollection;

Property Value

A DocumentCollection of open documents.

See Also

IDesignerEventService Interface | IDesignerEventService Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDesignerEventService Methods

The methods of the IDesignerEventService interface are listed below. For a complete list of IDesignerEventService interface members, see the IDesignerEventService Members topic.

GetActiveDocument Gets the currently active document.

Event Hookup:

AddOnActiveDocumentChanged | Adds an event that will be raised when the currently active document changes.
AddOnDocumentCreated | Adds a handler to the document created event.
AddOnDocumentDisposed | Adds a handler to the document disposed event.
AddOnSelectionChanged | Adds an event that will be fired when the global selection changes.
RemoveOnActiveDocumentChanged | Removes a previously added event handler.
RemoveOnDocumentCreated | Removes a previously added event handler.
RemoveOnDocumentDisposed | Removes a previously added event handler.
RemoveOnSelectionChanged | Removes a previously added event handler.

See Also

IDesignerEventService Interface | System.ComponentModel.Design Namespace


IDesignerEventService.AddOnActiveDocumentChanged

Adds an event that will be raised when the currently active document changes.

[Visual Basic]
Sub AddOnActiveDocumentChanged( _
   ByVal handler As ActiveDocumentEventHandler _
)
[C#]
void AddOnActiveDocumentChanged(
   ActiveDocumentEventHandler handler
);
[C++]
void AddOnActiveDocumentChanged(
   ActiveDocumentEventHandler* handler
) = 0;
[JScript]
function AddOnActiveDocumentChanged(
   handler : ActiveDocumentEventHandler
);

Parameters

handler
The event handler to add.

Remarks

This can result from the user opening or setting focus to a new document, or by closing a document.

See Also

IDesignerEventService Interface | IDesignerEventService Members | System.ComponentModel.Design Namespace


IDesignerEventService.AddOnDocumentCreated

Adds a handler to the document created event.

[Visual Basic]
Sub AddOnDocumentCreated( _
   ByVal handler As DocumentEventHandler _
)
[C#]
void AddOnDocumentCreated(
   DocumentEventHandler handler
);
[C++]
void AddOnDocumentCreated(
   DocumentEventHandler* handler
) = 0;
[JScript]
function AddOnDocumentCreated(
   handler : DocumentEventHandler
);

Parameters

handler
The event handler to add.

Remarks

The document created event will be raised when a new document has been created and fully loaded and is ready for user input.

See Also

IDesignerEventService Interface | IDesignerEventService Members | System.ComponentModel.Design Namespace


IDesignerEventService.AddOnDocumentDisposed

Adds a handler to the document disposed event.

[Visual Basic]
Sub AddOnDocumentDisposed( _
   ByVal handler As DocumentEventHandler _
)
[C#]
void AddOnDocumentDisposed(
   DocumentEventHandler handler
);
[C++]
void AddOnDocumentDisposed(
   DocumentEventHandler* handler
) = 0;
[JScript]
function AddOnDocumentDisposed(
   handler : DocumentEventHandler
);

Parameters

handler
The event handler to add.

Remarks

This event will be raised when a document is about to be disposed, but before the document actually starts to dispose itself.

See Also

IDesignerEventService Interface | IDesignerEventService Members | System.ComponentModel.Design Namespace


IDesignerEventService.AddOnSelectionChanged

Adds an event that will be fired when the global selection changes.

[Visual Basic]
Sub AddOnSelectionChanged( _
   ByVal handler As EventHandler _
)
[C#]
void AddOnSelectionChanged(
   EventHandler handler
);
[C++]
void AddOnSelectionChanged(
   EventHandler* handler
) = 0;
[JScript]
function AddOnSelectionChanged(
   handler : EventHandler
);

Parameters

handler
The event handler to add.

Remarks

A global selection change may result from the user changing the selection in the currently active document, or from the user switching to a new document.

See Also

IDesignerEventService Interface | IDesignerEventService Members | System.ComponentModel.Design Namespace


IDesignerEventService.GetActiveDocument

Gets the currently active document.

[Visual Basic]
Function GetActiveDocument() As IDesignerHost
[C#]
IDesignerHost GetActiveDocument();
[C++]
IDesignerHost* GetActiveDocument() = 0;
[JScript]
function GetActiveDocument() : IDesignerHost;

Return Value

The currently active document, or a null reference (in Visual Basic Nothing) if there is no active document.

See Also

IDesignerEventService Interface | IDesignerEventService Members | System.ComponentModel.Design Namespace


IDesignerEventService.RemoveOnActiveDocumentChanged

Removes a previously added event handler.

[Visual Basic]
Sub RemoveOnActiveDocumentChanged( _
   ByVal handler As ActiveDocumentEventHandler _
)
[C#]
void RemoveOnActiveDocumentChanged(
   ActiveDocumentEventHandler handler
);
[C++]
void RemoveOnActiveDocumentChanged(
   ActiveDocumentEventHandler* handler
) = 0;
[JScript]
function RemoveOnActiveDocumentChanged(
   handler : ActiveDocumentEventHandler
);

Parameters

handler
The event handler to remove.

See Also

IDesignerEventService Interface | IDesignerEventService Members | System.ComponentModel.Design Namespace


IDesignerEventService.RemoveOnDocumentCreated

Removes a previously added event handler.

[Visual Basic]
Sub RemoveOnDocumentCreated( _
   ByVal handler As DocumentEventHandler _
)
[C#]
void RemoveOnDocumentCreated(
   DocumentEventHandler handler
);
[C++]
void RemoveOnDocumentCreated(
   DocumentEventHandler* handler
) = 0;
[JScript]
function RemoveOnDocumentCreated(
   handler : DocumentEventHandler
);

Parameters

handler
The event handler to remove.

See Also

IDesignerEventService Interface | IDesignerEventService Members | System.ComponentModel.Design Namespace


IDesignerEventService.RemoveOnDocumentDisposed

Removes a previously added event handler.

[Visual Basic]
Sub RemoveOnDocumentDisposed( _
   ByVal handler As DocumentEventHandler _
)
[C#]
void RemoveOnDocumentDisposed(
   DocumentEventHandler handler
);
[C++]
void RemoveOnDocumentDisposed(
   DocumentEventHandler* handler
) = 0;
[JScript]
function RemoveOnDocumentDisposed(
   handler : DocumentEventHandler
);

Parameters

handler
The event handler to remove.

See Also

IDesignerEventService Interface | IDesignerEventService Members | System.ComponentModel.Design Namespace


IDesignerEventService.RemoveOnSelectionChanged

Removes a previously added event handler.

[Visual Basic]
Sub RemoveOnSelectionChanged( _
   ByVal handler As EventHandler _
)
[C#]
void RemoveOnSelectionChanged(
   EventHandler handler
);
[C++]
void RemoveOnSelectionChanged(
   EventHandler* handler
) = 0;
[JScript]
function RemoveOnSelectionChanged(
   handler : EventHandler
);

Parameters

handler
The event handler to remove.

See Also

IDesignerEventService Interface | IDesignerEventService Members | System.ComponentModel.Design Namespace


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDesignerEventService Events

The events of the IDesignerEventService interface are listed below. For a complete list of IDesignerEventService interface members, see the IDesignerEventService Members topic.

ActiveDocumentChanged | Occurs when the currently active document changes.
DocumentCreated | Occurs when a document is created.
DocumentDisposed | Occurs when a document is disposed.
SelectionChanged | Occurs when the global selection changes.

See Also

IDesignerEventService Interface | System.ComponentModel.Design Namespace


IDesignerEventService ActiveDocumentChanged Event

Occurs when the currently active document changes.

The following declaration shows the syntax for a method that handles the ActiveDocumentChanged event.

[Visual Basic]
Private Sub IDesignerEventServiceName_ActiveDocumentChanged( _
   ByVal sender As Object, _
   ByVal e As ActiveDocumentEventArgs _
)
[C#]
private void IDesignerEventServiceName_ActiveDocumentChanged(
   object sender,
   ActiveDocumentEventArgs e
);
[C++]
private: void IDesignerEventServiceName_ActiveDocumentChanged(
   Object* sender,
   ActiveDocumentEventArgs* e
);
[JScript]
private IDesignerEventServiceName_ActiveDocumentChanged(
   sender : Object,
   e : ActiveDocumentEventArgs
);

Parameters

sender
The source of the event.
e
An ActiveDocumentEventArgs that contains the event data. The following ActiveDocumentEventArgs properties provide information specific to this event.
Property Description
NewDocument
Gets or sets the document that is gaining activation.
OldDocument
Gets or sets the document that is losing activation.

Remarks

This can result from the user opening or setting focus to a new document, or by closing a document.

See Also

IDesignerEventService Interface | IDesignerEventService MembersTopic | System.ComponentModel.Design Namespace


IDesignerEventService DocumentCreated Event

Occurs when a document is created.

The following declaration shows the syntax for a method that handles the DocumentCreated event.

[Visual Basic]
Private Sub IDesignerEventServiceName_DocumentCreated( _
   ByVal sender As Object, _
   ByVal e As DocumentEventArgs _
)
[C#]
private void IDesignerEventServiceName_DocumentCreated(
   object sender,
   DocumentEventArgs e
);
[C++]
private: void IDesignerEventServiceName_DocumentCreated(
   Object* sender,
   DocumentEventArgs* e
);
[JScript]
private IDesignerEventServiceName_DocumentCreated(
   sender : Object,
   e : DocumentEventArgs
);

Parameters

sender
The source of the event.
e
A DocumentEventArgs that contains the event data. The following DocumentEventArgs properties provide information specific to this event.
Property Description
Document
[To be supplied.]

Remarks

The document created event will be raised when a new document has been created and fully loaded and is ready for user input.

See Also

IDesignerEventService Interface | IDesignerEventService MembersTopic | System.ComponentModel.Design Namespace


IDesignerEventService DocumentDisposed Event

Occurs when a document is disposed.

The following declaration shows the syntax for a method that handles the DocumentDisposed event.

[Visual Basic]
Private Sub IDesignerEventServiceName_DocumentDisposed( _
   ByVal sender As Object, _
   ByVal e As DocumentEventArgs _
)
[C#]
private void IDesignerEventServiceName_DocumentDisposed(
   object sender,
   DocumentEventArgs e
);
[C++]
private: void IDesignerEventServiceName_DocumentDisposed(
   Object* sender,
   DocumentEventArgs* e
);
[JScript]
private IDesignerEventServiceName_DocumentDisposed(
   sender : Object,
   e : DocumentEventArgs
);

Parameters

sender
The source of the event.
e
A DocumentEventArgs that contains the event data. The following DocumentEventArgs properties provide information specific to this event.
Property Description
Document
[To be supplied.]

Remarks

This event will be raised when a document is about to be disposed, but before the document actually starts to dispose itself.

See Also

IDesignerEventService Interface | IDesignerEventService MembersTopic | System.ComponentModel.Design Namespace


IDesignerEventService SelectionChanged Event

Occurs when the global selection changes.

The following declaration shows the syntax for a method that handles the SelectionChanged event.

[Visual Basic]
Private Sub IDesignerEventServiceName_SelectionChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
private void IDesignerEventServiceName_SelectionChanged(
   object sender,
   EventArgs e
);
[C++]
private: void IDesignerEventServiceName_SelectionChanged(
   Object* sender,
   EventArgs* e
);
[JScript]
private IDesignerEventServiceName_SelectionChanged(
   sender : Object,
   e : EventArgs
);

Parameters

sender
The source of the event.
e
An EventArgs that contains the event data. The following EventArgs properties provide information specific to this event.
Property Description
ExtendedInfo
Holds a reference to an object that manages the event's state.

Remarks

A global selection change may result from the user changing the selection in the currently active document, or from the user switching to a new document.

See Also

IDesignerEventService Interface | IDesignerEventService MembersTopic | System.ComponentModel.Design Namespace


IDesignerFilter Interface

Provides access to, and an interface for filtering, the dictionaries that store the properties, attributes, and events of a component.

IDesignerFilter

[Visual Basic]
Public Interface IDesignerFilter
[C#]
public interface IDesignerFilter
[C++]
public __gc __interface IDesignerFilter

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IDesignerFilter

Class | Description
ComponentDesigner | The default designer for all components. Almost everything that extends from Component will typically have one of these designers as their base designer. Designers do not have to inherit from this class, but it does provide some convenient features.

Remarks

Provides an interface that allows a designer to filter the set of properties the component it is designing will expose through the TypeDescriptor object.

There are two sets of methods. PreXXX methods are called immediately before PostXXX methods. If you are adding or changing specific properties, events, or attributes, use a Pre method. If you want to modify all properties, methods or events you should use a Post method.

Notes to Implementers: If you are overriding this method, call the base implementation before you perform your own filtering.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

IDesignerFilter Members | System.ComponentModel.Design Namespace | System.ComponentModel.Design.ITypeDescriptorService | TypeDescriptor


IDesignerFilter Members

Methods

PostFilterAttributes | Allows a designer to filter the set of attributes the component it is designing will expose through the TypeDescriptor object.
PostFilterEvents | Allows a designer to filter the set of events the component it is designing will expose through the TypeDescriptor object.
PostFilterProperties | Allows a designer to filter the set of properties the component it is designing will expose through the TypeDescriptor object.
PreFilterAttributes | Allows a designer to filter the set of attributes the component it is designing will expose through the TypeDescriptor object.
PreFilterEvents | Allows a designer to filter the set of events the component it is designing will expose through the TypeDescriptor object.
PreFilterProperties | Allows a designer to filter the set of properties the component it is designing will expose through the TypeDescriptor object.

See Also

IDesignerFilter Interface | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDesignerFilter Methods

The methods of the IDesignerFilter interface are listed below. For a complete list of IDesignerFilter interface members, see the IDesignerFilter Members topic.

PostFilterAttributes | Allows a designer to filter the set of attributes the component it is designing will expose through the TypeDescriptor object.
PostFilterEvents | Allows a designer to filter the set of events the component it is designing will expose through the TypeDescriptor object.
PostFilterProperties | Allows a designer to filter the set of properties the component it is designing will expose through the TypeDescriptor object.
PreFilterAttributes | Allows a designer to filter the set of attributes the component it is designing will expose through the TypeDescriptor object.
PreFilterEvents | Allows a designer to filter the set of events the component it is designing will expose through the TypeDescriptor object.
PreFilterProperties | Allows a designer to filter the set of properties the component it is designing will expose through the TypeDescriptor object.

See Also

IDesignerFilter Interface | System.ComponentModel.Design Namespace


IDesignerFilter.PostFilterAttributes

Allows a designer to filter the set of attributes the component it is designing will expose through the TypeDescriptor object.

[Visual Basic]
Sub PostFilterAttributes( _
   ByVal attributes As IDictionary _
)
[C#]
void PostFilterAttributes(
   IDictionary attributes
);
[C++]
void PostFilterAttributes(
   IDictionary* attributes
) = 0;
[JScript]
function PostFilterAttributes(
   attributes : IDictionary
);

Parameters

attributes
The attributes for the class of the component. The keys in the dictionary are attribute type IDs.

Return Value

The augmented set of attributes.

Remarks

This method is called immediately after its corresponding "Pre" method. If you are overriding this method, call the the base implementation after you perform your own filtering.If the method does not modify any attributes, it may just return a reference to its input parameter. If you do make a change to the attributes, you must create a new array.

See Also

IDesignerFilter Interface | IDesignerFilter Members | System.ComponentModel.Design Namespace | System.ComponentModel.Design.ITypeDescriptorService.FilterAttributes


IDesignerFilter.PostFilterEvents

Allows a designer to filter the set of events the component it is designing will expose through the TypeDescriptor object.

[Visual Basic]
Sub PostFilterEvents( _
   ByVal events As IDictionary _
)
[C#]
void PostFilterEvents(
   IDictionary events
);
[C++]
void PostFilterEvents(
   IDictionary* events
) = 0;
[JScript]
function PostFilterEvents(
   events : IDictionary
);

Parameters

events
The events for the class of the component. The keys in the dictionary are event names.

Return Value

The augmented set of events.

Remarks

This method is called immediately after its corresponding "Pre" method. If you are overriding this method, call the the base implementation after you perform your own filtering.If the method does not modify any events, it may just return a reference to its input parameter. If you do make a change to the events, you must create a new array.

See Also

IDesignerFilter Interface | IDesignerFilter Members | System.ComponentModel.Design Namespace | System.ComponentModel.Design.ITypeDescriptorService.FilterEvents


IDesignerFilter.PostFilterProperties

Allows a designer to filter the set of properties the component it is designing will expose through the TypeDescriptor object.

[Visual Basic]
Sub PostFilterProperties( _
   ByVal properties As IDictionary _
)
[C#]
void PostFilterProperties(
   IDictionary properties
);
[C++]
void PostFilterProperties(
   IDictionary* properties
) = 0;
[JScript]
function PostFilterProperties(
   properties : IDictionary
);

Parameters

properties
The properties for the class of the component. The keys in the dictionary are property names.

Return Value

The augmented set of properties.

Remarks

This method is called immediately after its corresponding "Pre" method. If you are overriding this method, call the the base implementation after you perform your own filtering.If the method does not modify any properties, it may just return a reference to its input parameter. If you do make a change to the properties, you must create a new array.

See Also

IDesignerFilter Interface | IDesignerFilter Members | System.ComponentModel.Design Namespace | System.ComponentModel.Design.ITypeDescriptorService.FilterProperties


IDesignerFilter.PreFilterAttributes

Allows a designer to filter the set of attributes the component it is designing will expose through the TypeDescriptor object.

[Visual Basic]
Sub PreFilterAttributes( _
   ByVal attributes As IDictionary _
)
[C#]
void PreFilterAttributes(
   IDictionary attributes
);
[C++]
void PreFilterAttributes(
   IDictionary* attributes
) = 0;
[JScript]
function PreFilterAttributes(
   attributes : IDictionary
);

Parameters

attributes
The attributes for the class of the component. The keys in the dictionary are attribute type IDs.

Return Value

The augmented set of attributes.

Remarks

This method is called immediately before its corresponding "Post" method. If you are overriding this method, call the base implementation before you perform your own filtering.If the method does not modify any attributes, it may just return a reference to its input parameter. If you do make a change to the attributes, you must create a new array.

See Also

IDesignerFilter Interface | IDesignerFilter Members | System.ComponentModel.Design Namespace | System.ComponentModel.Design.ITypeDescriptorService.FilterAttributes


IDesignerFilter.PreFilterEvents

Allows a designer to filter the set of events the component it is designing will expose through the TypeDescriptor object.

[Visual Basic]
Sub PreFilterEvents( _
   ByVal events As IDictionary _
)
[C#]
void PreFilterEvents(
   IDictionary events
);
[C++]
void PreFilterEvents(
   IDictionary* events
) = 0;
[JScript]
function PreFilterEvents(
   events : IDictionary
);

Parameters

events
The events for the class of the component. The keys in the dictionary are event names.

Return Value

The augmented set of events.

Remarks

This method is called immediately before its corresponding "Post" method. If you are overriding this method, call the base implementation before you perform your own filtering.If the method does not modify any events, it may just return a reference to its input parameter. If you do make a change to the events, you must create a new array.

See Also

IDesignerFilter Interface | IDesignerFilter Members | System.ComponentModel.Design Namespace | System.ComponentModel.Design.ITypeDescriptorService.FilterEvents


IDesignerFilter.PreFilterProperties

Allows a designer to filter the set of properties the component it is designing will expose through the TypeDescriptor object.

[Visual Basic]
Sub PreFilterProperties( _
   ByVal properties As IDictionary _
)
[C#]
void PreFilterProperties(
   IDictionary properties
);
[C++]
void PreFilterProperties(
   IDictionary* properties
) = 0;
[JScript]
function PreFilterProperties(
   properties : IDictionary
);

Parameters

properties
The properties for the class of the component. The keys in the dictionary are event names.

Return Value

The augmented set of properties.

Remarks

This method is called immediately before its corresponding "Post" method. If you are overriding this method, call the base implementation before you perform your own filtering.If the method does not modify any properties, it may just return a reference to its input parameter. If you do make a change to the properties, you must create a new array.

See Also

IDesignerFilter Interface | IDesignerFilter Members | System.ComponentModel.Design Namespace | System.ComponentModel.Design.ITypeDescriptorService.FilterProperties


IDesignerHost Interface

Provides methods to adjust the configuration of and retrieve information about the services and behavior of a designer.

IDesignerHost

[Visual Basic]
Public Interface IDesignerHost
   Implements IServiceObjectProvider
[C#]
public interface IDesignerHost : IServiceObjectProvider
[C++]
public __gc __interface IDesignerHost : public
   IServiceObjectProvider

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

IDesignerHost is an interface that works with the form designer architecture and provides designer configuration and customization methods.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

IDesignerHost Members | System.ComponentModel.Design Namespace | IDesigner | IDesignerEventService | IDesignerOptionService


IDesignerHost Members

Properties

Loading Gets or sets a value indicating whether the designer host is currently loading the document.

Methods

ActivateDesigner | Activates the designer that this host is hosting.
AddService | Adds a service to the host.
BeginBatchOperation | Overloaded. Begins a lengthy operation that usually raises multiple notifications.
CreateComponent | Overloaded. Creates a component of the specified class type.
DestroyComponent | Destroys the given component, removing it from the design container.
EndBatchOperation | Ends a lengthy operation.
GetBaseComponent | Gets the instance of the base class used as the base class for the current design.
GetBaseComponentClassName | Gets the fully qualified name of the class that is being designed.
GetBatchOperationDescription | Gets the description of the current batch operation.
GetContainer | Gets the container for this designer host.
GetDesigner | Gets the designer instance for the specified component.
GetType | Overloaded. Gets an instance of the type.
Reload | Causes the entire document to reload.
RemoveService | Removes a service from the host.
SetBaseComponentClassName | Sets the class name of the fully qualified class that is being designed.

Events

AfterBatchOperation | Occurs when all BeginBatchOperation calls are matched with EndBatchOperation calls.
BatchOperation | Occurs at the starting and ending points of a batch operation.
BeforeBatchOperation | Occurs before a batch operation is to begin.
CodeLoaded | Occurs after the code is parsed.
CodeUnloaded | Occurs before the code is unloaded.
DocumentActivate | Occurs when this designer host's document becomes the active document in the environment.
DocumentDeactivate | Occurs when this designer host's document is no longer the active document in the environment.

Event Hookup:

Methods

AddOnAfterBatchOperation | Adds an event handler for the System.ComponentModel.Design.IDesignerHost.AfterBatchOperation event.
AddOnBatchOperation | Adds an event handler for the System.ComponentModel.Design.IDesignerHost.BatchOperation event.
AddOnBeforeBatchOperation | Adds an event handler for the System.ComponentModel.Design.IDesignerHost.BeforeBatchOperation event.
AddOnCodeLoaded | Adds an event handler for the System.ComponentModel.Design.IDesignerHost.CodeLoaded event.
AddOnCodeUnloaded | Adds an event handler for the System.ComponentModel.Design.IDesignerHost.CodeUnloaded event.
AddOnDocumentActivate | Adds an event handler for the System.ComponentModel.Design.IDesignerHost.DocumentActivate event.
AddOnDocumentDeactivate | Adds an event handler for the System.ComponentModel.Design.IDesignerHost.DocumentDeactivate event.
RemoveOnAfterBatchOperation | Removes an event handler that has been associated with the System.ComponentModel.Design.IDesignerHost.AfterBatchOperation event.
RemoveOnBatchOperation | Removes an event handler that has been associated with the System.ComponentModel.Design.IDesignerHost.BatchOperation event.
RemoveOnBeforeBatchOperation | Removes an event handler that has been associated with the System.ComponentModel.Design.IDesignerHost.BeforeBatchOperation event.
RemoveOnCodeLoaded | Removes an event handler that has been associated with the the System.ComponentModel.Design.IDesignerHost.CodeLoaded event.
RemoveOnCodeUnloaded | Removes an event handler that has been associated with the System.ComponentModel.Design.IDesignerHost.CodeUnloaded event.
RemoveOnDocumentActivate | Removes an event handler that has been associated with the System.ComponentModel.Design.IDesignerHost.DocumentActivated event.
RemoveOnDocumentDeactivate | Removes an event handler that has been associated with the System.ComponentModel.Design.IDesignerHost.DocumentDeactivated event.

See Also

IDesignerHost Interface | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDesignerHost Properties

The properties of the IDesignerHost interface are listed below. For a complete list of IDesignerHost interface members, see the IDesignerHost Members topic.

Loading Gets or sets a value indicating whether the designer host is currently loading the document.

See Also

IDesignerHost Interface | System.ComponentModel.Design Namespace


IDesignerHost.Loading

Gets or sets a value indicating whether the designer host is currently loading the document.

[Visual Basic]
ReadOnly Property Loading As Boolean
[C#]
bool Loading {get;}
[C++]
bool get_Loading() = 0;
[JScript]
abstract function get Loading() : Boolean;

Property Value

true if the designer host is currently loading the document; otherwise, false.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDesignerHost Methods

The methods of the IDesignerHost interface are listed below. For a complete list of IDesignerHost interface members, see the IDesignerHost Members topic.

ActivateDesigner | Activates the designer that this host is hosting.
AddService | Adds a service to the host.
BeginBatchOperation | Overloaded. Begins a lengthy operation that usually raises multiple notifications.
CreateComponent | Overloaded. Creates a component of the specified class type.
DestroyComponent | Destroys the given component, removing it from the design container.
EndBatchOperation | Ends a lengthy operation.
GetBaseComponent | Gets the instance of the base class used as the base class for the current design.
GetBaseComponentClassName | Gets the fully qualified name of the class that is being designed.
GetBatchOperationDescription | Gets the description of the current batch operation.
GetContainer | Gets the container for this designer host.
GetDesigner | Gets the designer instance for the specified component.
GetType | Overloaded. Gets an instance of the type.
Reload | Causes the entire document to reload.
RemoveService | Removes a service from the host.
SetBaseComponentClassName | Sets the class name of the fully qualified class that is being designed.

Event Hookup:

AddOnAfterBatchOperation | Adds an event handler for the System.ComponentModel.Design.IDesignerHost.AfterBatchOperation event.
AddOnBatchOperation | Adds an event handler for the System.ComponentModel.Design.IDesignerHost.BatchOperation event.
AddOnBeforeBatchOperation | Adds an event handler for the System.ComponentModel.Design.IDesignerHost.BeforeBatchOperation event.
AddOnCodeLoaded | Adds an event handler for the System.ComponentModel.Design.IDesignerHost.CodeLoaded event.
AddOnCodeUnloaded | Adds an event handler for the System.ComponentModel.Design.IDesignerHost.CodeUnloaded event.
AddOnDocumentActivate | Adds an event handler for the System.ComponentModel.Design.IDesignerHost.DocumentActivate event.
AddOnDocumentDeactivate | Adds an event handler for the System.ComponentModel.Design.IDesignerHost.DocumentDeactivate event.
RemoveOnAfterBatchOperation | Removes an event handler that has been associated with the System.ComponentModel.Design.IDesignerHost.AfterBatchOperation event.
RemoveOnBatchOperation | Removes an event handler that has been associated with the System.ComponentModel.Design.IDesignerHost.BatchOperation event.
RemoveOnBeforeBatchOperation | Removes an event handler that has been associated with the System.ComponentModel.Design.IDesignerHost.BeforeBatchOperation event.
RemoveOnCodeLoaded | Removes an event handler that has been associated with the the System.ComponentModel.Design.IDesignerHost.CodeLoaded event.
RemoveOnCodeUnloaded | Removes an event handler that has been associated with the System.ComponentModel.Design.IDesignerHost.CodeUnloaded event.
RemoveOnDocumentActivate | Removes an event handler that has been associated with the System.ComponentModel.Design.IDesignerHost.DocumentActivated event.
RemoveOnDocumentDeactivate | Removes an event handler that has been associated with the System.ComponentModel.Design.IDesignerHost.DocumentDeactivated event.

See Also

IDesignerHost Interface | System.ComponentModel.Design Namespace


IDesignerHost.ActivateDesigner

Activates the designer that this host is hosting.

[Visual Basic]
Sub ActivateDesigner()
[C#]
void ActivateDesigner();
[C++]
void ActivateDesigner() = 0;
[JScript]
function ActivateDesigner();

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace


IDesignerHost.AddOnAfterBatchOperation

Adds an event handler for the System.ComponentModel.Design.IDesignerHost.AfterBatchOperation event.

[Visual Basic]
Sub AddOnAfterBatchOperation( _
   ByVal handler As EventHandler _
)
[C#]
void AddOnAfterBatchOperation(
   EventHandler handler
);
[C++]
void AddOnAfterBatchOperation(
   EventHandler* handler
) = 0;
[JScript]
function AddOnAfterBatchOperation(
   handler : EventHandler
);

Parameters

handler
An EventHandler that represents the method that will handle the System.ComponentModel.Design.IDesignerHost.AfterBatchOperation event.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace | BeginBatchOperation | EndBatchOperation | AddOnAfterBatchOperation | RemoveOnAfterBatchOperation


IDesignerHost.AddOnBatchOperation

Adds an event handler for the System.ComponentModel.Design.IDesignerHost.BatchOperation event.

[Visual Basic]
Sub AddOnBatchOperation( _
   ByVal handler As BatchOperationEventHandler _
)
[C#]
void AddOnBatchOperation(
   BatchOperationEventHandler handler
);
[C++]
void AddOnBatchOperation(
   BatchOperationEventHandler* handler
) = 0;
[JScript]
function AddOnBatchOperation(
   handler : BatchOperationEventHandler
);

Parameters

handler
An EventHandler that represents the method that will handle the System.ComponentModel.Design.IDesignerHost.BatchOperation event.

Remarks

Batch operations can refresh multiple components at once. The batch operation methods provide a way to prevent performance and flicker problems by deferring expensive processing on multiple components until after the operation has completed.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace | RemoveOnBatchOperation | BeginBatchOperation | EndBatchOperation | BatchOperationEventHandler | BatchOperationEventArgs


IDesignerHost.AddOnBeforeBatchOperation

Adds an event handler for the System.ComponentModel.Design.IDesignerHost.BeforeBatchOperation event.

[Visual Basic]
Sub AddOnBeforeBatchOperation( _
   ByVal handler As EventHandler _
)
[C#]
void AddOnBeforeBatchOperation(
   EventHandler handler
);
[C++]
void AddOnBeforeBatchOperation(
   EventHandler* handler
) = 0;
[JScript]
function AddOnBeforeBatchOperation(
   handler : EventHandler
);

Parameters

handler
An EventHandler delegate that represents the method that will handle the System.ComponentModel.Design.IDesignerHost.BeforeBatchOperation event.

Remarks

This method allows any designer host clients to perform operations before other handlers are notified of the batch operation beginning. The specified handler will only be called when the first call to System.ComponentModel.Design.BeginBatchOperation is made in an operation. Subsquent calls will not generate this event until all the matching EndBatchOperation calls have been made.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace | BeginBatchOperation | EndBatchOperation | AddOnAfterBatchOperation | RemoveOnAfterBatchOperation


IDesignerHost.AddOnCodeLoaded

Adds an event handler for the System.ComponentModel.Design.IDesignerHost.CodeLoaded event.

[Visual Basic]
Sub AddOnCodeLoaded( _
   ByVal handler As EventHandler _
)
[C#]
void AddOnCodeLoaded(
   EventHandler handler
);
[C++]
void AddOnCodeLoaded(
   EventHandler* handler
) = 0;
[JScript]
function AddOnCodeLoaded(
   handler : EventHandler
);

Parameters

handler
An EventHandler that represents the method that will handle the System.ComponentModel.Design.IDesignerHost.CodeLoaded event.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace | RemoveOnCodeLoaded


IDesignerHost.AddOnCodeUnloaded

Adds an event handler for the System.ComponentModel.Design.IDesignerHost.CodeUnloaded event.

[Visual Basic]
Sub AddOnCodeUnloaded( _
   ByVal handler As EventHandler _
)
[C#]
void AddOnCodeUnloaded(
   EventHandler handler
);
[C++]
void AddOnCodeUnloaded(
   EventHandler* handler
) = 0;
[JScript]
function AddOnCodeUnloaded(
   handler : EventHandler
);

Parameters

handler
An System.ComponentModel.Design.EventHandler that represents the method that will handle the System.ComponentModel.Design.IDesignerHost.CodeUnloaded event.

Remarks

Code unloading can occur when the document is being destroyed or reloaded.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace | RemoveOnCodeUnloaded


IDesignerHost.AddOnDocumentActivate

Adds an event handler for the System.ComponentModel.Design.IDesignerHost.DocumentActivate event.

[Visual Basic]
Sub AddOnDocumentActivate( _
   ByVal handler As EventHandler _
)
[C#]
void AddOnDocumentActivate(
   EventHandler handler
);
[C++]
void AddOnDocumentActivate(
   EventHandler* handler
) = 0;
[JScript]
function AddOnDocumentActivate(
   handler : EventHandler
);

Parameters

handler
An EventHandler that represents the method that will handle the System.ComponentModel.Design.IDesignerHost.DocumentActivate event.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace | RemoveOnDocumentActivate | IDesignerHost


IDesignerHost.AddOnDocumentDeactivate

Adds an event handler for the System.ComponentModel.Design.IDesignerHost.DocumentDeactivate event.

[Visual Basic]
Sub AddOnDocumentDeactivate( _
   ByVal handler As EventHandler _
)
[C#]
void AddOnDocumentDeactivate(
   EventHandler handler
);
[C++]
void AddOnDocumentDeactivate(
   EventHandler* handler
) = 0;
[JScript]
function AddOnDocumentDeactivate(
   handler : EventHandler
);

Parameters

handler
An EventHandler that represents the method that will handle the System.ComponentModel.Design.IDesignerHost.DocumentDeactivate event.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace | RemoveOnDocumentDeactivate | IDesignerHost


IDesignerHost.AddService

Adds a service to the host.

[Visual Basic]
Sub AddService( _
   ByVal serviceClass As Type, _
   ByVal serviceInstance As Object _
)
[C#]
void AddService(
   Type serviceClass,
   object serviceInstance
);
[C++]
void AddService(
   Type* serviceClass,
   Object* serviceInstance
) = 0;
[JScript]
function AddService(
   serviceClass : Type,
   serviceInstance : Object
);

Parameters

serviceClass
The class of the service to add.
serviceInstance
An instance of the type of serviceClass.

Remarks

Any service can be added, but an exception will be thrown if an existing service exists for the specified service class. The service will be available from the site of any component .

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace | RemoveService


IDesignerHost.BeginBatchOperation

Begins a lengthy operation that usually raises multiple notifications.

Overload List

Begins a System.ComponentModel.Design.IDesignerHost.BatchOperation event with the name or description specified.

[Visual Basic] Overloads Sub BeginBatchOperation(String)
[C#] void BeginBatchOperation(String);
[C++] void BeginBatchOperation(String*) = 0;
[JScript] function BeginBatchOperation(String);

Begins a System.ComponentModel.Design.IDesignerHost.BatchOperation event.

[Visual Basic] Overloads Sub BeginBatchOperation()
[C#] void BeginBatchOperation();
[C++] void BeginBatchOperation() = 0;
[JScript] function BeginBatchOperation();

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace


IDesignerHost.BeginBatchOperation (String)

Begins a System.ComponentModel.Design.IDesignerHost.BatchOperation event with the name or description specified.

[Visual Basic]
Overloads Sub BeginBatchOperation( _
   ByVal description As String _
)
[C#]
void BeginBatchOperation(
   string description
);
[C++]
void BeginBatchOperation(
   String* description
) = 0;
[JScript]
function BeginBatchOperation(
   description : String
);

Parameters

description
A title or description for the current batch operation.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace | IDesignerHost.BeginBatchOperation Overload List | EndBatchOperation | AddOnBatchOperation | RemoveOnBatchOperation | BatchOperationEventHandler | BatchOperationEventArgs


IDesignerHost.BeginBatchOperation ()

Begins a System.ComponentModel.Design.IDesignerHost.BatchOperation event.

[Visual Basic]
Overloads Sub BeginBatchOperation()
[C#]
void BeginBatchOperation();
[C++]
void BeginBatchOperation() = 0;
[JScript]
function BeginBatchOperation();

Remarks

After this call, events are not raised but the need to raise the event is remembered. Then, when EndBatchOperation is called, the queued events are all raised at once.This method includes no parameters and returns void.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace | IDesignerHost.BeginBatchOperation Overload List | EndBatchOperation | AddOnBatchOperation | RemoveOnBatchOperation | BatchOperationEventHandler | BatchOperationEventArgs


IDesignerHost.CreateComponent

Creates a component of the specified class type.

Overload List

Creates a component of the given class type and name and places it into the designer container.

[Visual Basic] Overloads Function CreateComponent(Type, String) As IComponent
[C#] IComponent CreateComponent(Type, String);
[C++] IComponent* CreateComponent(Type*, String) = 0;
[JScript] function CreateComponent(Type, String) : IComponent;

Creates a component of the specified class type.

[Visual Basic] Overloads Function CreateComponent(Type) As IComponent
[C#] IComponent CreateComponent(Type);
[C++] IComponent* CreateComponent(Type*) = 0;
[JScript] function CreateComponent(Type) : IComponent;

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace


IDesignerHost.CreateComponent (Type, String)

Creates a component of the given class type and name and places it into the designer container.

[Visual Basic]
Overloads Function CreateComponent( _
   ByVal componentClass As Type, _
   ByVal name As String _
) As IComponent
[C#]
IComponent CreateComponent(
   Type componentClass,
   string name
);
[C++]
IComponent* CreateComponent(
   Type* componentClass,
   String* name
) = 0;
[JScript]
function CreateComponent(
   componentClass : Type,
   name : String
) : IComponent;

Parameters

componentClass
The class of the component to create. Exceptions will be thrown if the class cannot be resolved into an object that implements IComponent.
name
The name for the component.

Return Value

The newly created component.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace | IDesignerHost.CreateComponent Overload List | IComponent


IDesignerHost.CreateComponent (Type)

Creates a component of the specified class type.

[Visual Basic]
Overloads Function CreateComponent( _
   ByVal componentClass As Type _
) As IComponent
[C#]
IComponent CreateComponent(
   Type componentClass
);
[C++]
IComponent* CreateComponent(
   Type* componentClass
) = 0;
[JScript]
function CreateComponent(
   componentClass : Type
) : IComponent;

Parameters

componentClass
The class of the component to create. Exceptions will be thrown if the class cannot be resolved into an object that implements IComponent.

Return Value

The newly created component.

Remarks

No name is specified with this method. The method creates the component and sites it into the designer container.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace | IDesignerHost.CreateComponent Overload List | IComponent


IDesignerHost.DestroyComponent

Destroys the given component, removing it from the design container.

[Visual Basic]
Sub DestroyComponent( _
   ByVal component As IComponent _
)
[C#]
void DestroyComponent(
   IComponent component
);
[C++]
void DestroyComponent(
   IComponent* component
) = 0;
[JScript]
function DestroyComponent(
   component : IComponent
);

Parameters

component
The component to destroy.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace | CreateComponent | IComponent


IDesignerHost.EndBatchOperation

Ends a lengthy operation.

[Visual Basic]
Sub EndBatchOperation()
[C#]
void EndBatchOperation();
[C++]
void EndBatchOperation() = 0;
[JScript]
function EndBatchOperation();

Remarks

After this call any notifications that were pending during the batch operation will be fired.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace | BeginBatchOperation


IDesignerHost.GetBaseComponent

Gets the instance of the base class used as the base class for the current design.

[Visual Basic]
Function GetBaseComponent() As IComponent
[C#]
IComponent GetBaseComponent();
[C++]
IComponent* GetBaseComponent() = 0;
[JScript]
function GetBaseComponent() : IComponent;

Return Value

The instance of the base class component that is being designed.

Remarks

This base class is typically a System.WinForms.Form or System.WinForms.UserControl instance; it defines the class for which the user's derived class will extend.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace


IDesignerHost.GetBaseComponentClassName

Gets the fully qualified name of the class that is being designed.

[Visual Basic]
Function GetBaseComponentClassName() As String
[C#]
string GetBaseComponentClassName();
[C++]
String* GetBaseComponentClassName() = 0;
[JScript]
function GetBaseComponentClassName() : String;

Return Value

The fully qualified name of the base component class.

Remarks

This class is not available at design time because it is the class being designed, so the class's superclass is substituted. This allows you to get at the fully qualified name of the class that will be used at run time.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace


IDesignerHost.GetBatchOperationDescription

Gets the description of the current batch operation.

[Visual Basic]
Function GetBatchOperationDescription() As String
[C#]
string GetBatchOperationDescription();
[C++]
String* GetBatchOperationDescription() = 0;
[JScript]
function GetBatchOperationDescription() : String;

Return Value

The current batch operation description.

Remarks

The description corresponds to the last description specified with System.WinForms.IDesignerHost.BeginBatchOperation that was not ended with a call to System.WinForms.IDesignerHost.EndBatchOperation.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace | BeginBatchOperation | EndBatchOperation


IDesignerHost.GetContainer

Gets the container for this designer host.

[Visual Basic]
Function GetContainer() As IContainer
[C#]
IContainer GetContainer();
[C++]
IContainer* GetContainer() = 0;
[JScript]
function GetContainer() : IContainer;

Return Value

The IContainer instance for this host.

Remarks

From the container, you can enumerate all components that are a part of the class.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace


IDesignerHost.GetDesigner

Gets the designer instance for the specified component.

[Visual Basic]
Function GetDesigner( _
   ByVal component As IComponent _
) As IDesigner
[C#]
IDesigner GetDesigner(
   IComponent component
);
[C++]
IDesigner* GetDesigner(
   IComponent* component
) = 0;
[JScript]
function GetDesigner(
   component : IComponent
) : IDesigner;

Parameters

component
The System.ComponentModel.Design.IComponent to retrieve the designer for.

Return Value

An IDesigner instance, or a null reference (in Visual Basic Nothing) if there is no designer for the specified component.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace


IDesignerHost.GetType

Gets an instance of the type.

Overload List

Gets an instance of the type for the specified fully qualified type name TypeName within the assembly AssemblyName.

[Visual Basic] Overloads Function GetType(String, AssemblyName) As Type
[C#] Type GetType(String, AssemblyName);
[C++] Type* GetType(String*, AssemblyName) = 0;
[JScript] function GetType(String, AssemblyName) : Type;

Gets the type instance for the specified fully qualified type name TypeName.

[Visual Basic] Overloads Function GetType(String) As Type
[C#] Type GetType(String);
[C++] Type* GetType(String*) = 0;
[JScript] function GetType(String) : Type;

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace


IDesignerHost.GetType (String, AssemblyName)

Gets an instance of the type for the specified fully qualified type name TypeName within the assembly AssemblyName.

[Visual Basic]
Overloads Function GetType( _
   ByVal typeName As String, _
   ByVal assemblyName As AssemblyName _
) As Type
[C#]
Type GetType(
   string typeName,
   AssemblyName assemblyName
);
[C++]
Type* GetType(
   String* typeName,
   AssemblyName* assemblyName
) = 0;
[JScript]
function GetType(
   typeName : String,
   assemblyName : AssemblyName
) : Type;

Parameters

typeName
The name of the type to load.
assemblyName
The name of the assembly that contains the type.

Return Value

The type object for the specified type name, or a null reference (in Visual Basic Nothing) if the type could not be found.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace | IDesignerHost.GetType Overload List


IDesignerHost.GetType (String)

Gets the type instance for the specified fully qualified type name TypeName.

[Visual Basic]
Overloads Function GetType( _
   ByVal typeName As String _
) As Type
[C#]
Type GetType(
   string typeName
);
[C++]
Type* GetType(
   String* typeName
) = 0;
[JScript]
function GetType(
   typeName : String
) : Type;

Parameters

typeName
The name of the type to load.

Return Value

The type object for the given type name, or a null reference (in Visual Basic Nothing) if the type could not be found.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace | IDesignerHost.GetType Overload List


IDesignerHost.Reload

Causes the entire document to reload.

[Visual Basic]
Sub Reload()
[C#]
void Reload();
[C++]
void Reload() = 0;
[JScript]
function Reload();

Remarks

All components and designers will be destroyed and the document will be reloaded from the development environment. Changes to the document that have not been saved will be abandonded with this call.If this call is made from a designer or component, the object is likely to be disposed.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace


IDesignerHost.RemoveOnAfterBatchOperation

Removes an event handler that has been associated with the System.ComponentModel.Design.IDesignerHost.AfterBatchOperation event.

[Visual Basic]
Sub RemoveOnAfterBatchOperation( _
   ByVal handler As EventHandler _
)
[C#]
void RemoveOnAfterBatchOperation(
   EventHandler handler
);
[C++]
void RemoveOnAfterBatchOperation(
   EventHandler* handler
) = 0;
[JScript]
function RemoveOnAfterBatchOperation(
   handler : EventHandler
);

Parameters

handler
The EventHandler to remove.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace | BeginBatchOperation | EndBatchOperation | AddOnAfterBatchOperation | RemoveOnAfterBatchOperation


IDesignerHost.RemoveOnBatchOperation

Removes an event handler that has been associated with the System.ComponentModel.Design.IDesignerHost.BatchOperation event.

[Visual Basic]
Sub RemoveOnBatchOperation( _
   ByVal handler As BatchOperationEventHandler _
)
[C#]
void RemoveOnBatchOperation(
   BatchOperationEventHandler handler
);
[C++]
void RemoveOnBatchOperation(
   BatchOperationEventHandler* handler
) = 0;
[JScript]
function RemoveOnBatchOperation(
   handler : BatchOperationEventHandler
);

Parameters

handler
The EventHandler to remove.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace | AddOnBatchOperation | EndBatchOperation | BatchOperationEventHandler | BatchOperationEventArgs


IDesignerHost.RemoveOnBeforeBatchOperation

Removes an event handler that has been associated with the System.ComponentModel.Design.IDesignerHost.BeforeBatchOperation event.

[Visual Basic]
Sub RemoveOnBeforeBatchOperation( _
   ByVal handler As EventHandler _
)
[C#]
void RemoveOnBeforeBatchOperation(
   EventHandler handler
);
[C++]
void RemoveOnBeforeBatchOperation(
   EventHandler* handler
) = 0;
[JScript]
function RemoveOnBeforeBatchOperation(
   handler : EventHandler
);

Parameters

handler
The EventHandler to remove.

Remarks

This method allows designer host clients to perform operations before other handlers are notified of the batch operation beginning. This handler will only be called when the first call to BeginBatchOperation is made in an operation. Subsquent calls will not generate this event until all the matching EndBatchOperation calls have been made.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace | BeginBatchOperation | EndBatchOperation | AddOnAfterBatchOperation | RemoveOnAfterBatchOperation


IDesignerHost.RemoveOnCodeLoaded

Removes an event handler that has been associated with the the System.ComponentModel.Design.IDesignerHost.CodeLoaded event.

[Visual Basic]
Sub RemoveOnCodeLoaded( _
   ByVal handler As EventHandler _
)
[C#]
void RemoveOnCodeLoaded(
   EventHandler handler
);
[C++]
void RemoveOnCodeLoaded(
   EventHandler* handler
) = 0;
[JScript]
function RemoveOnCodeLoaded(
   handler : EventHandler
);

Parameters

handler
The EventHandler to remove.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace | AddOnCodeLoaded


IDesignerHost.RemoveOnCodeUnloaded

Removes an event handler that has been associated with the System.ComponentModel.Design.IDesignerHost.CodeUnloaded event.

[Visual Basic]
Sub RemoveOnCodeUnloaded( _
   ByVal handler As EventHandler _
)
[C#]
void RemoveOnCodeUnloaded(
   EventHandler handler
);
[C++]
void RemoveOnCodeUnloaded(
   EventHandler* handler
) = 0;
[JScript]
function RemoveOnCodeUnloaded(
   handler : EventHandler
);

Parameters

handler
The EventHandler to remove.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace | AddOnCodeUnloaded


IDesignerHost.RemoveOnDocumentActivate

Removes an event handler that has been associated with the System.ComponentModel.Design.IDesignerHost.DocumentActivated event.

[Visual Basic]
Sub RemoveOnDocumentActivate( _
   ByVal handler As EventHandler _
)
[C#]
void RemoveOnDocumentActivate(
   EventHandler handler
);
[C++]
void RemoveOnDocumentActivate(
   EventHandler* handler
) = 0;
[JScript]
function RemoveOnDocumentActivate(
   handler : EventHandler
);

Parameters

handler
The EventHandler to remove.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace | AddOnDocumentActivate


IDesignerHost.RemoveOnDocumentDeactivate

Removes an event handler that has been associated with the System.ComponentModel.Design.IDesignerHost.DocumentDeactivated event.

[Visual Basic]
Sub RemoveOnDocumentDeactivate( _
   ByVal handler As EventHandler _
)
[C#]
void RemoveOnDocumentDeactivate(
   EventHandler handler
);
[C++]
void RemoveOnDocumentDeactivate(
   EventHandler* handler
) = 0;
[JScript]
function RemoveOnDocumentDeactivate(
   handler : EventHandler
);

Parameters

handler
The EventHandler to remove.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace | AddOnDocumentDeactivate


IDesignerHost.RemoveService

Removes a service from the host.

[Visual Basic]
Sub RemoveService( _
   ByVal serviceClass As Type _
)
[C#]
void RemoveService(
   Type serviceClass
);
[C++]
void RemoveService(
   Type* serviceClass
) = 0;
[JScript]
function RemoveService(
   serviceClass : Type
);

Parameters

serviceClass
The class of the service to remove.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace | AddService


IDesignerHost.SetBaseComponentClassName

Sets the class name of the fully qualified class that is being designed.

[Visual Basic]
Sub SetBaseComponentClassName( _
   ByVal className As String _
)
[C#]
void SetBaseComponentClassName(
   string className
);
[C++]
void SetBaseComponentClassName(
   String* className
) = 0;
[JScript]
function SetBaseComponentClassName(
   className : String
);

Parameters

className
The fully qualified name of the class to set.

Remarks

This value can only be set during the load of a document.

See Also

IDesignerHost Interface | IDesignerHost Members | System.ComponentModel.Design Namespace


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDesignerHost Events

The events of the IDesignerHost interface are listed below. For a complete list of IDesignerHost interface members, see the IDesignerHost Members topic.

AfterBatchOperation | Occurs when all BeginBatchOperation calls are matched with EndBatchOperation calls.
BatchOperation | Occurs at the starting and ending points of a batch operation.
BeforeBatchOperation | Occurs before a batch operation is to begin.
CodeLoaded | Occurs after the code is parsed.
CodeUnloaded | Occurs before the code is unloaded.
DocumentActivate | Occurs when this designer host's document becomes the active document in the environment.
DocumentDeactivate | Occurs when this designer host's document is no longer the active document in the environment.

See Also

IDesignerHost Interface | System.ComponentModel.Design Namespace


IDesignerHost AfterBatchOperation Event

Occurs when all BeginBatchOperation calls are matched with EndBatchOperation calls.

The following declaration shows the syntax for a method that handles the AfterBatchOperation event.

[Visual Basic]
Private Sub IDesignerHostName_AfterBatchOperation( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
private void IDesignerHostName_AfterBatchOperation(
   object sender,
   EventArgs e
);
[C++]
private: void IDesignerHostName_AfterBatchOperation(
   Object* sender,
   EventArgs* e
);
[JScript]
private IDesignerHostName_AfterBatchOperation(
   sender : Object,
   e : EventArgs
);

Parameters

sender
The source of the event.
e
An EventArgs that contains the event data. The following EventArgs properties provide information specific to this event.
Property Description
ExtendedInfo
Holds a reference to an object that manages the event's state.

Remarks

An System.ComponentModel.Design.IDesignerHost.AfterBatchOperation event would be called when a batch operation completes, that is, when all BeginBatchOperation calls are matched with EndBatchOperation calls. Intermediate calls to either BeginBatchOperation or EndBatchOperation will not generate this event.

See Also

IDesignerHost Interface | IDesignerHost MembersTopic | System.ComponentModel.Design Namespace


IDesignerHost BatchOperation Event

Occurs at the starting and ending points of a batch operation.

The following declaration shows the syntax for a method that handles the BatchOperation event.

[Visual Basic]
Private Sub IDesignerHostName_BatchOperation( _
   ByVal sender As Object, _
   ByVal e As BatchOperationEventArgs _
)
[C#]
private void IDesignerHostName_BatchOperation(
   object sender,
   BatchOperationEventArgs e
);
[C++]
private: void IDesignerHostName_BatchOperation(
   Object* sender,
   BatchOperationEventArgs* e
);
[JScript]
private IDesignerHostName_BatchOperation(
   sender : Object,
   e : BatchOperationEventArgs
);

Parameters

sender
The source of the event.
e
A BatchOperationEventArgs that contains the event data.

Remarks

A batch operation event occurs upon first entry of a batch operation, and again upon last exit of the operation; nested calls do not generate events. Also, if the designer host is currently within a batch operation and an object adds an event handler, the handler will be invoked immediately.

See Also

IDesignerHost Interface | IDesignerHost MembersTopic | System.ComponentModel.Design Namespace


IDesignerHost BeforeBatchOperation Event

Occurs before a batch operation is to begin.

The following declaration shows the syntax for a method that handles the BeforeBatchOperation event.

[Visual Basic]
Private Sub IDesignerHostName_BeforeBatchOperation( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
private void IDesignerHostName_BeforeBatchOperation(
   object sender,
   EventArgs e
);
[C++]
private: void IDesignerHostName_BeforeBatchOperation(
   Object* sender,
   EventArgs* e
);
[JScript]
private IDesignerHostName_BeforeBatchOperation(
   sender : Object,
   e : EventArgs
);

Parameters

sender
The source of the event.
e
An EventArgs that contains the event data. The following EventArgs properties provide information specific to this event.
Property Description
ExtendedInfo
Holds a reference to an object that manages the event's state.

Remarks

This occurs only on the first call to BeginBatchOperation. Subsquent calls will not generate this event until all the matching EndBatchOperation calls have been made.

See Also

IDesignerHost Interface | IDesignerHost MembersTopic | System.ComponentModel.Design Namespace


IDesignerHost CodeLoaded Event

Occurs after the code is parsed.

The following declaration shows the syntax for a method that handles the CodeLoaded event.

[Visual Basic]
Private Sub IDesignerHostName_CodeLoaded( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
private void IDesignerHostName_CodeLoaded(
   object sender,
   EventArgs e
);
[C++]
private: void IDesignerHostName_CodeLoaded(
   Object* sender,
   EventArgs* e
);
[JScript]
private IDesignerHostName_CodeLoaded(
   sender : Object,
   e : EventArgs
);

Parameters

sender
The source of the event.
e
An EventArgs that contains the event data. The following EventArgs properties provide information specific to this event.
Property Description
ExtendedInfo
Holds a reference to an object that manages the event's state.

See Also

IDesignerHost Interface | IDesignerHost MembersTopic | System.ComponentModel.Design Namespace


IDesignerHost CodeUnloaded Event

Occurs before the code is unloaded.

The following declaration shows the syntax for a method that handles the CodeUnloaded event.

[Visual Basic]
Private Sub IDesignerHostName_CodeUnloaded( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
private void IDesignerHostName_CodeUnloaded(
   object sender,
   EventArgs e
);
[C++]
private: void IDesignerHostName_CodeUnloaded(
   Object* sender,
   EventArgs* e
);
[JScript]
private IDesignerHostName_CodeUnloaded(
   sender : Object,
   e : EventArgs
);

Parameters

sender
The source of the event.
e
An EventArgs that contains the event data. The following EventArgs properties provide information specific to this event.
Property Description
ExtendedInfo
Holds a reference to an object that manages the event's state.

Remarks

Code unloading can occur when the document is being destroyed or reloaded.

See Also

IDesignerHost Interface | IDesignerHost MembersTopic | System.ComponentModel.Design Namespace


IDesignerHost DocumentActivate Event

Occurs when this designer host's document becomes the active document in the environment.

The following declaration shows the syntax for a method that handles the DocumentActivate event.

[Visual Basic]
Private Sub IDesignerHostName_DocumentActivate( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
private void IDesignerHostName_DocumentActivate(
   object sender,
   EventArgs e
);
[C++]
private: void IDesignerHostName_DocumentActivate(
   Object* sender,
   EventArgs* e
);
[JScript]
private IDesignerHostName_DocumentActivate(
   sender : Object,
   e : EventArgs
);

Parameters

sender
The source of the event.
e
An EventArgs that contains the event data. The following EventArgs properties provide information specific to this event.
Property Description
ExtendedInfo
Holds a reference to an object that manages the event's state.

See Also

IDesignerHost Interface | IDesignerHost MembersTopic | System.ComponentModel.Design Namespace


IDesignerHost DocumentDeactivate Event

Occurs when this designer host's document is no longer the active document in the environment.

The following declaration shows the syntax for a method that handles the DocumentDeactivate event.

[Visual Basic]
Private Sub IDesignerHostName_DocumentDeactivate( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
private void IDesignerHostName_DocumentDeactivate(
   object sender,
   EventArgs e
);
[C++]
private: void IDesignerHostName_DocumentDeactivate(
   Object* sender,
   EventArgs* e
);
[JScript]
private IDesignerHostName_DocumentDeactivate(
   sender : Object,
   e : EventArgs
);

Parameters

sender
The source of the event.
e
An EventArgs that contains the event data. The following EventArgs properties provide information specific to this event.
Property Description
ExtendedInfo
Holds a reference to an object that manages the event's state.

See Also

IDesignerHost Interface | IDesignerHost MembersTopic | System.ComponentModel.Design Namespace


IDesignerOptionService Interface

Provides access to get and set option values for a designer.

IDesignerOptionService

[Visual Basic]
Public Interface IDesignerOptionService
[C#]
public interface IDesignerOptionService
[C++]
public __gc __interface IDesignerOptionService

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

IDesignerOptionService Members | System.ComponentModel.Design Namespace | IDesigner


IDesignerOptionService Members

Methods

GetOptionValue | Gets the value of an option defined in this package.
SetOptionValue | Sets the value of an option defined in this package.

See Also

IDesignerOptionService Interface | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDesignerOptionService Methods

The methods of the IDesignerOptionService interface are listed below. For a complete list of IDesignerOptionService interface members, see the IDesignerOptionService Members topic.

GetOptionValue | Gets the value of an option defined in this package.
SetOptionValue | Sets the value of an option defined in this package.

See Also

IDesignerOptionService Interface | System.ComponentModel.Design Namespace


IDesignerOptionService.GetOptionValue

Gets the value of an option defined in this package.

[Visual Basic]
Function GetOptionValue( _
   ByVal pageName As String, _
   ByVal valueName As String _
) As Object
[C#]
object GetOptionValue(
   string pageName,
   string valueName
);
[C++]
Object* GetOptionValue(
   String* pageName,
   String* valueName
) = 0;
[JScript]
function GetOptionValue(
   pageName : String,
   valueName : String
) : Object;

Parameters

pageName
The name of the page that defines the option.
valueName
The name of the option property.

Return Value

The value of the specified option.

Remarks

For sub-pages, the page name should be a backslash-delineated concatenation of the page names up to the main page node. Specifying just the main node name will access the first (the default) page for the node.

See Also

IDesignerOptionService Interface | IDesignerOptionService Members | System.ComponentModel.Design Namespace


IDesignerOptionService.SetOptionValue

Sets the value of an option defined in this package.

[Visual Basic]
Sub SetOptionValue( _
   ByVal pageName As String, _
   ByVal valueName As String, _
   ByVal value As Object _
)
[C#]
void SetOptionValue(
   string pageName,
   string valueName,
   object value
);
[C++]
void SetOptionValue(
   String* pageName,
   String* valueName,
   Object* value
) = 0;
[JScript]
function SetOptionValue(
   pageName : String,
   valueName : String,
   value : Object
);

Parameters

pageName
The name of the page that defines the option.
valueName
The name of the option property.
value
The new value.

Remarks

For sub-pages, the page name should be a backslash-delineated concatenation of the page names up to the main page node. Specifying just the main node name will access the first (the default) page for the node.

See Also

IDesignerOptionService Interface | IDesignerOptionService Members | System.ComponentModel.Design Namespace


IDictionaryService Interface

Provides a generic dictionary service that a designer can store user-defined data on the site.

IDictionaryService

[Visual Basic]
Public Interface IDictionaryService
[C#]
public interface IDictionaryService
[C++]
public __gc __interface IDictionaryService

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

IDictionaryService Members | System.ComponentModel.Design Namespace


IDictionaryService Members

Methods

GetKey | Gets the key corresponding to the specified value.
GetValue | Gets the value corresponding to the specified key.
SetValue | Sets the given key-value pair in an object's site.

See Also

IDictionaryService Interface | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDictionaryService Methods

The methods of the IDictionaryService interface are listed below. For a complete list of IDictionaryService interface members, see the IDictionaryService Members topic.

GetKey | Gets the key corresponding to the specified value.
GetValue | Gets the value corresponding to the specified key.
SetValue | Sets the given key-value pair in an object's site.

See Also

IDictionaryService Interface | System.ComponentModel.Design Namespace


IDictionaryService.GetKey

Gets the key corresponding to the specified value.

[Visual Basic]
Function GetKey( _
   ByVal value As Object _
) As Object
[C#]
object GetKey(
   object value
);
[C++]
Object* GetKey(
   Object* value
) = 0;
[JScript]
function GetKey(
   value : Object
) : Object;

Parameters

value
The value object to look up in the dictionary.

Return Value

The associated key object, or a null reference (in Visual Basic Nothing) if no key exists.

See Also

IDictionaryService Interface | IDictionaryService Members | System.ComponentModel.Design Namespace


IDictionaryService.GetValue

Gets the value corresponding to the specified key.

[Visual Basic]
Function GetValue( _
   ByVal key As Object _
) As Object
[C#]
object GetValue(
   object key
);
[C++]
Object* GetValue(
   Object* key
) = 0;
[JScript]
function GetValue(
   key : Object
) : Object;

Parameters

key
The key object to look up the value for.

Return Value

The associated value object, or a null reference (in Visual Basic Nothing) if no value exists.

See Also

IDictionaryService Interface | IDictionaryService Members | System.ComponentModel.Design Namespace


IDictionaryService.SetValue

Sets the given key-value pair in an object's site.

[Visual Basic]
Sub SetValue( _
   ByVal key As Object, _
   ByVal value As Object _
)
[C#]
void SetValue(
   object key,
   object value
);
[C++]
void SetValue(
   Object* key,
   Object* value
) = 0;
[JScript]
function SetValue(
   key : Object,
   value : Object
);

Parameters

key
An object that will be used as the key to associate value with.
value
The value to store.

Remarks

The key-value pair is stored on a per-object basis, and is a good place to save additional information about a component.

See Also

IDictionaryService Interface | IDictionaryService Members | System.ComponentModel.Design Namespace


IEditorSite Interface

IEditorSite is a callback through which value editors can get at the owners of the values they are editing. This is useful to get at other objects on the form.

IEditorSite

[Visual Basic]
Public Interface IEditorSite
[C#]
public interface IEditorSite
[C++]
public __gc __interface IEditorSite

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IEditorSite

Class | Description
ValueEditorHost | [To be supplied.]

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

IEditorSite Members | System.ComponentModel.Design Namespace


IEditorSite Members

Properties

Component Gets the primary component that depends on this value being edited. This is useful when an editor wishes to get at the design-time site information. (For example, the ReferenceEditor uses this information to get at other components in the logical container.)

Methods

FindPropertyValue | Gets the value for the specified property. This method searches up the property outline chain looking for a property of the specified type.
GetComponents | Gets all components that depend on this value being edited.
GetValueOwner | Gets the object that directly depends on this value being edited. If it is a component, it will be the same object that GetComponents returns. This differs from GetComponents in that this editing may occur on a property of a non-component object that in turn is the current value of a component's property.
GetValueOwners | Gets the objects that directly depend on this value being edited.
GetValueType | Gets the type of the values being edited.

See Also

IEditorSite Interface | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IEditorSite Properties

The properties of the IEditorSite interface are listed below. For a complete list of IEditorSite interface members, see the IEditorSite Members topic.

Component Gets the primary component that depends on this value being edited. This is useful when an editor wishes to get at the design-time site information. (For example, the ReferenceEditor uses this information to get at other components in the logical container.)

See Also

IEditorSite Interface | System.ComponentModel.Design Namespace


IEditorSite.Component

Gets the primary component that depends on this value being edited. This is useful when an editor wishes to get at the design-time site information. (For example, the ReferenceEditor uses this information to get at other components in the logical container.)

[Visual Basic]
ReadOnly Property Component As IComponent
[C#]
IComponent Component {get;}
[C++]
IComponent* get_Component() = 0;
[JScript]
abstract function get Component() : IComponent;

Property Value

The primary component.

See Also

IEditorSite Interface | IEditorSite Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IEditorSite Methods

The methods of the IEditorSite interface are listed below. For a complete list of IEditorSite interface members, see the IEditorSite Members topic.

FindPropertyValue | Gets the value for the specified property. This method searches up the property outline chain looking for a property of the specified type.
GetComponents | Gets all components that depend on this value being edited.
GetValueOwner | Gets the object that directly depends on this value being edited. If it is a component, it will be the same object that GetComponents returns. This differs from GetComponents in that this editing may occur on a property of a non-component object that in turn is the current value of a component's property.
GetValueOwners | Gets the objects that directly depend on this value being edited.
GetValueType | Gets the type of the values being edited.

See Also

IEditorSite Interface | System.ComponentModel.Design Namespace


IEditorSite.FindPropertyValue

Gets the value for the specified property. This method searches up the property outline chain looking for a property of the specified type.

[Visual Basic]
Function FindPropertyValue( _
   ByVal name As String, _
   ByVal type As Type _
) As Object
[C#]
object FindPropertyValue(
   string name,
   Type type
);
[C++]
Object* FindPropertyValue(
   String* name,
   Type* type
) = 0;
[JScript]
function FindPropertyValue(
   name : String,
   type : Type
) : Object;

Parameters

name
The name of the property.
type
The type of the property.

Return Value

The value of the property.

See Also

IEditorSite Interface | IEditorSite Members | System.ComponentModel.Design Namespace


IEditorSite.GetComponents

Gets all components that depend on this value being edited.

[Visual Basic]
Function GetComponents() As IComponent ()
[C#]
IComponent[] GetComponents();
[C++]
IComponent* GetComponents() [] = 0;
[JScript]
function GetComponents() : IComponent[];

Return Value

The dependent components.

See Also

IEditorSite Interface | IEditorSite Members | System.ComponentModel.Design Namespace


IEditorSite.GetValueOwner

Gets the object that directly depends on this value being edited. If it is a component, it will be the same object that GetComponents returns. This differs from GetComponents in that this editing may occur on a property of a non-component object that in turn is the current value of a component's property.

[Visual Basic]
Function GetValueOwner() As Object
[C#]
object GetValueOwner();
[C++]
Object* GetValueOwner() = 0;
[JScript]
function GetValueOwner() : Object;

Return Value

The owner of the value being edited.

See Also

IEditorSite Interface | IEditorSite Members | System.ComponentModel.Design Namespace


IEditorSite.GetValueOwners

Gets the objects that directly depend on this value being edited.

[Visual Basic]
Function GetValueOwners() As Object ()
[C#]
object[] GetValueOwners();
[C++]
Object* GetValueOwners() [] = 0;
[JScript]
function GetValueOwners() : Object[];

Return Value

The objects dependent on the value being edited.

See Also

IEditorSite Interface | IEditorSite Members | System.ComponentModel.Design Namespace


IEditorSite.GetValueType

Gets the type of the values being edited.

[Visual Basic]
Function GetValueType() As Type
[C#]
Type GetValueType();
[C++]
Type* GetValueType() = 0;
[JScript]
function GetValueType() : Type;

Return Value

The type of the values being edited.

See Also

IEditorSite Interface | IEditorSite Members | System.ComponentModel.Design Namespace


IEventPropertyService Interface

This interface can convert EventDescriptors to PropertyDescriptors.

IEventPropertyService

[Visual Basic]
Public Interface IEventPropertyService
[C#]
public interface IEventPropertyService
[C++]
public __gc __interface IEventPropertyService

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

The property event service provides a way to expose events as properties. This is useful at design time because you are typically more concerned with the names of the functions the events are bound to rather than binding events to functions. The service will expose events for a given component as an array of PropertyDescriptor objects with a data type of String.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

IEventPropertyService Members | System.ComponentModel.Design Namespace | PropertyDescriptor | EventDescriptor | PropertyDescriptorCollection | EventDescriptorCollection


IEventPropertyService Members

Methods

GetEventProperties | Converts a set of event descriptors to a set of property descriptors.
GetEventProperty | Converts a single event to a property.

See Also

IEventPropertyService Interface | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IEventPropertyService Methods

The methods of the IEventPropertyService interface are listed below. For a complete list of IEventPropertyService interface members, see the IEventPropertyService Members topic.

GetEventProperties | Converts a set of event descriptors to a set of property descriptors.
GetEventProperty | Converts a single event to a property.

See Also

IEventPropertyService Interface | System.ComponentModel.Design Namespace


IEventPropertyService.GetEventProperties

Converts a set of event descriptors to a set of property descriptors.

[Visual Basic]
Function GetEventProperties( _
   ByVal events As EventDescriptorCollection _
) As PropertyDescriptorCollection
[C#]
PropertyDescriptorCollection GetEventProperties(
   EventDescriptorCollection events
);
[C++]
PropertyDescriptorCollection* GetEventProperties(
   EventDescriptorCollection* events
) = 0;
[JScript]
function GetEventProperties(
   events : EventDescriptorCollection
) : PropertyDescriptorCollection;

Parameters

events
The events to convert to properties.

Return Value

An array of type PropertyDescriptor that describes the given event set.

See Also

IEventPropertyService Interface | IEventPropertyService Members | System.ComponentModel.Design Namespace


IEventPropertyService.GetEventProperty

Converts a single event to a property.

[Visual Basic]
Function GetEventProperty( _
   ByVal e As EventDescriptor _
) As PropertyDescriptor
[C#]
PropertyDescriptor GetEventProperty(
   EventDescriptor e
);
[C++]
PropertyDescriptor* GetEventProperty(
   EventDescriptor* e
) = 0;
[JScript]
function GetEventProperty(
   e : EventDescriptor
) : PropertyDescriptor;

Parameters

e
The event to convert.

Return Value

A PropertyDescriptor that describes the event.

See Also

IEventPropertyService Interface | IEventPropertyService Members | System.ComponentModel.Design Namespace


IExtenderListService Interface

Provides an interface to track extender providers.

IExtenderListService

[Visual Basic]
Public Interface IExtenderListService
[C#]
public interface IExtenderListService
[C++]
public __gc __interface IExtenderListService

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

A site can implement this service if it wants to provide a list of extender providers. By default, the list of extenders is taken from all compnents in the container that implement IExtenderProvider. By providing this service on a component site a container can override the list of providers.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

IExtenderListService Members | System.ComponentModel.Design Namespace | IExtenderProvider


IExtenderListService Members

Methods

GetExtenderProviders Gets a list of extender providers for the component.

See Also

IExtenderListService Interface | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IExtenderListService Methods

The methods of the IExtenderListService interface are listed below. For a complete list of IExtenderListService interface members, see the IExtenderListService Members topic.

GetExtenderProviders Gets a list of extender providers for the component.

See Also

IExtenderListService Interface | System.ComponentModel.Design Namespace


IExtenderListService.GetExtenderProviders

Gets a list of extender providers for the component.

[Visual Basic]
Function GetExtenderProviders() As IExtenderProvider ()
[C#]
IExtenderProvider[] GetExtenderProviders();
[C++]
IExtenderProvider* GetExtenderProviders() [] = 0;
[JScript]
function GetExtenderProviders() : IExtenderProvider[];

Return Value

An array of type IExtenderProvider that lists the extender providers. If there are no providers, an empty array will be returned.

See Also

IExtenderListService Interface | IExtenderListService Members | System.ComponentModel.Design Namespace


IExtenderProviderService Interface

Provides an interface to add and remove extender providers.

IExtenderProviderService

[Visual Basic]
Public Interface IExtenderProviderService
[C#]
public interface IExtenderProviderService
[C++]
public __gc __interface IExtenderProviderService

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

Normally extender providers are only offered by components that have been added to a container. This service allows you extend this capability to objects that are not in the container.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

IExtenderProviderService Members | System.ComponentModel.Design Namespace | System.ComponentModel.Design.IExtenderProvider


IExtenderProviderService Members

Methods

AddExtenderProvider | Adds an extender provider.
RemoveExtenderProvider | Removes an extender provider.

See Also

IExtenderProviderService Interface | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IExtenderProviderService Methods

The methods of the IExtenderProviderService interface are listed below. For a complete list of IExtenderProviderService interface members, see the IExtenderProviderService Members topic.

AddExtenderProvider | Adds an extender provider.
RemoveExtenderProvider | Removes an extender provider.

See Also

IExtenderProviderService Interface | System.ComponentModel.Design Namespace


IExtenderProviderService.AddExtenderProvider

Adds an extender provider.

[Visual Basic]
Sub AddExtenderProvider( _
   ByVal provider As IExtenderProvider _
)
[C#]
void AddExtenderProvider(
   IExtenderProvider provider
);
[C++]
void AddExtenderProvider(
   IExtenderProvider* provider
) = 0;
[JScript]
function AddExtenderProvider(
   provider : IExtenderProvider
);

Parameters

provider
The extender provider to add.

Remarks

This interface allows extender providers to be added into the design time set of extender providers, even by something other than a component. All properties that appear from these extender providers will be marked as design time only.

See Also

IExtenderProviderService Interface | IExtenderProviderService Members | System.ComponentModel.Design Namespace


IExtenderProviderService.RemoveExtenderProvider

Removes an extender provider.

[Visual Basic]
Sub RemoveExtenderProvider( _
   ByVal provider As IExtenderProvider _
)
[C#]
void RemoveExtenderProvider(
   IExtenderProvider provider
);
[C++]
void RemoveExtenderProvider(
   IExtenderProvider* provider
) = 0;
[JScript]
function RemoveExtenderProvider(
   provider : IExtenderProvider
);

Parameters

provider
The extender provider to remove.

Remarks

This interface allows extender providers to be removed from the design time set of extender providers, even by something other than a component. All properties that appear from these extender providers will be marked as design time only.

See Also

IExtenderProviderService Interface | IExtenderProviderService Members | System.ComponentModel.Design Namespace


IExtensibilityService Interface

Provides an interface to get an extensibility service object to control various properties of the project within the development environment.

IExtensibilityService

[Visual Basic]
Public Interface IExtensibilityService
[C#]
public interface IExtensibilityService
[C++]
public __gc __interface IExtensibilityService

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

This interface is used to get at the extensibility object for the current project in the development enviornment. The project's extensibility object can be used to control various properties of the project within the development enviornment. To use the project object service, request it through a call to GetServiceObject. You may cast the resulting object to an extensibility interface or you may access it as a dispatch interface.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

IExtensibilityService Members | System.ComponentModel.Design Namespace


IExtensibilityService Members

See Also

IExtensibilityService Interface | System.ComponentModel.Design Namespace


IFilePersistanceService Interface

This service allows designers to open files as binary data. If applicable, source control rules for the files will be followed if a write to the file is attempted.

IFilePersistanceService

[Visual Basic]
Public Interface IFilePersistanceService
[C#]
public interface IFilePersistanceService
[C++]
public __gc __interface IFilePersistanceService

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

IFilePersistanceService Members | System.ComponentModel.Design Namespace


IFilePersistanceService Members

Methods

GetStreamForFile Gets a Stream of the file's contents from the specified file.

See Also

IFilePersistanceService Interface | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IFilePersistanceService Methods

The methods of the IFilePersistanceService interface are listed below. For a complete list of IFilePersistanceService interface members, see the IFilePersistanceService Members topic.

GetStreamForFile Gets a Stream of the file's contents from the specified file.

See Also

IFilePersistanceService Interface | System.ComponentModel.Design Namespace


IFilePersistanceService.GetStreamForFile

Gets a Stream of the file's contents from the specified file.

[Visual Basic]
Function GetStreamForFile( _
   ByVal fileName As String, _
   ByVal overwrite As Boolean _
) As Stream
[C#]
Stream GetStreamForFile(
   string fileName,
   bool overwrite
);
[C++]
Stream* GetStreamForFile(
   String* fileName,
   bool overwrite
) = 0;
[JScript]
function GetStreamForFile(
   fileName : String,
   overwrite : Boolean
) : Stream;

Parameters

fileName
The name of the file to be loaded. If a relative file name is used, the current directory will be searched. If the file does not exist, an ArgumentException will be thrown. If the file cannot be opened, an Exception describing the reason is thrown.
overwrite
If true, any existing file will be overwritten. Otherwise, a new file will be created if one doesn't exist, or opened if it does.

Return Value

The opened file as a Stream.

See Also

IFilePersistanceService Interface | IFilePersistanceService Members | System.ComponentModel.Design Namespace


IHelpService Interface

The help service provides a way to provide the IDE (Integrated Development Environment) help system with contextual information for the current task. The help system evaluates all contextual information it gets and determines the most relevant topics to display to the user.

IHelpService

[Visual Basic]
Public Interface IHelpService
[C#]
public interface IHelpService
[C++]
public __gc __interface IHelpService

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

IHelpService Members | System.ComponentModel.Design Namespace


IHelpService Members

Methods

AddContextAttribute | Overloaded. [To be supplied.]
ClearContextAttributes | Clears all existing context attributes from the document.
RemoveContextAttribute | Removes a previously added context attribute.
ShowHelp | Overloaded. [To be supplied.]

See Also

IHelpService Interface | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IHelpService Methods

The methods of the IHelpService interface are listed below. For a complete list of IHelpService interface members, see the IHelpService Members topic.

AddContextAttribute | Overloaded. [To be supplied.]
ClearContextAttributes | Clears all existing context attributes from the document.
RemoveContextAttribute | Removes a previously added context attribute.
ShowHelp | Overloaded. [To be supplied.]

See Also

IHelpService Interface | System.ComponentModel.Design Namespace


IHelpService.AddContextAttribute

[To be supplied.]

Overload List

Adds a context attribute to the document. Context attributes are used to provide context-sensitive help to users. The designer host will automatically add context attributes from available help attributes on selected components and properties. This method allows you to further customize the context-sensitive help.

[Visual Basic] Overloads Sub AddContextAttribute(String, String, Boolean)
[C#] void AddContextAttribute(String, String, bool);
[C++] void AddContextAttribute(String*, String*, bool) = 0;
[JScript] function AddContextAttribute(String, String, Boolean);

Adds a context attribute to the document. Context attributes are used to provide context-sensitive help to users. The designer host will automatically add context attributes from available help attributes on selected components and properties. This method allows you to further customize the context-sensitive help.

[Visual Basic] Overloads Sub AddContextAttribute(String, String, HelpKeywordType)
[C#] void AddContextAttribute(String, String, HelpKeywordType);
[C++] void AddContextAttribute(String*, String*, HelpKeywordType) = 0;
[JScript] function AddContextAttribute(String, String, HelpKeywordType);

See Also

IHelpService Interface | IHelpService Members | System.ComponentModel.Design Namespace


IHelpService.AddContextAttribute (String, String, Boolean)

Adds a context attribute to the document. Context attributes are used to provide context-sensitive help to users. The designer host will automatically add context attributes from available help attributes on selected components and properties. This method allows you to further customize the context-sensitive help.

[Visual Basic]
Overloads Sub AddContextAttribute( _
   ByVal name As String, _
   ByVal value As String, _
   ByVal required As Boolean _
)
[C#]
void AddContextAttribute(
   string name,
   string value,
   bool required
);
[C++]
void AddContextAttribute(
   String* name,
   String* value,
   bool required
) = 0;
[JScript]
function AddContextAttribute(
   name : String,
   value : String,
   required : Boolean
);

Parameters

name
The name of the attribute to add.
value
The value of the attribute.
required
Whether help topics should only be displayed if they have this attribute.

See Also

IHelpService Interface | IHelpService Members | System.ComponentModel.Design Namespace | IHelpService.AddContextAttribute Overload List


IHelpService.AddContextAttribute (String, String, HelpKeywordType)

Adds a context attribute to the document. Context attributes are used to provide context-sensitive help to users. The designer host will automatically add context attributes from available help attributes on selected components and properties. This method allows you to further customize the context-sensitive help.

[Visual Basic]
Overloads Sub AddContextAttribute( _
   ByVal name As String, _
   ByVal value As String, _
   ByVal keywordType As HelpKeywordType _
)
[C#]
void AddContextAttribute(
   string name,
   string value,
   HelpKeywordType keywordType
);
[C++]
void AddContextAttribute(
   String* name,
   String* value,
   HelpKeywordType keywordType
) = 0;
[JScript]
function AddContextAttribute(
   name : String,
   value : String,
   keywordType : HelpKeywordType
);

Parameters

name
The name of the attribute to add.
value
The value of the attribute.
keywordType
The type of the keyword, from the enum HelpKeywordType

See Also

IHelpService Interface | IHelpService Members | System.ComponentModel.Design Namespace | IHelpService.AddContextAttribute Overload List


IHelpService.ClearContextAttributes

Clears all existing context attributes from the document.

[Visual Basic]
Sub ClearContextAttributes()
[C#]
void ClearContextAttributes();
[C++]
void ClearContextAttributes() = 0;
[JScript]
function ClearContextAttributes();

See Also

IHelpService Interface | IHelpService Members | System.ComponentModel.Design Namespace


IHelpService.RemoveContextAttribute

Removes a previously added context attribute.

[Visual Basic]
Sub RemoveContextAttribute( _
   ByVal name As String, _
   ByVal value As String _
)
[C#]
void RemoveContextAttribute(
   string name,
   string value
);
[C++]
void RemoveContextAttribute(
   String* name,
   String* value
) = 0;
[JScript]
function RemoveContextAttribute(
   name : String,
   value : String
);

Parameters

name
The name of the attribute to remove.
value
The value of the attribute to remove.

See Also

IHelpService Interface | IHelpService Members | System.ComponentModel.Design Namespace


IHelpService.ShowHelp

[To be supplied.]

Overload List

Shows the help topic that corresponds with the specified URL and topic navigation ID.

[Visual Basic] Overloads Sub ShowHelp(String, Integer)
[C#] void ShowHelp(String, int);
[C++] void ShowHelp(String*, int) = 0;
[JScript] function ShowHelp(String, int);

Shows the help topic that corresponds to the specified URL.

[Visual Basic] Overloads Sub ShowHelp(String)
[C#] void ShowHelp(String);
[C++] void ShowHelp(String*) = 0;
[JScript] function ShowHelp(String);

See Also

IHelpService Interface | IHelpService Members | System.ComponentModel.Design Namespace


IHelpService.ShowHelp (String, Int32)

Shows the help topic that corresponds with the specified URL and topic navigation ID.

[Visual Basic]
Overloads Sub ShowHelp( _
   ByVal helpURL As String, _
   ByVal topic As Integer _
)
[C#]
void ShowHelp(
   string helpURL,
   int topic
);
[C++]
void ShowHelp(
   String* helpURL,
   int topic
) = 0;
[JScript]
function ShowHelp(
   helpURL : String,
   topic : int
);

Parameters

helpURL
The URL of the help topic to display.
topic
An integer that provides navigation clues within the help topic.

Remarks

The topic will be displayed in the environment's integrated help system.

See Also

IHelpService Interface | IHelpService Members | System.ComponentModel.Design Namespace | IHelpService.ShowHelp Overload List


IHelpService.ShowHelp (String)

Shows the help topic that corresponds to the specified URL.

[Visual Basic]
Overloads Sub ShowHelp( _
   ByVal helpURL As String _
)
[C#]
void ShowHelp(
   string helpURL
);
[C++]
void ShowHelp(
   String* helpURL
) = 0;
[JScript]
function ShowHelp(
   helpURL : String
);

Parameters

helpURL
The URL of the help topic to display.

Remarks

The topic will be displayed in the environment's integrated help system.

See Also

IHelpService Interface | IHelpService Members | System.ComponentModel.Design Namespace | IHelpService.ShowHelp Overload List


IInheritanceService Interface

Provides a set of utilities for analyzing and identifying inherited components.

IInheritanceService

[Visual Basic]
Public Interface IInheritanceService
[C#]
public interface IInheritanceService
[C++]
public __gc __interface IInheritanceService

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IInheritanceService

Class | Description
InheritanceService | The inheritance service provides a set of utilities for analyzing and identifying inherited components.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

IInheritanceService Members | System.ComponentModel.Design Namespace


IInheritanceService Members

Methods

AddInheritedComponents | Adds inherited components from the specified component to the specified container.
GetInheritanceAttribute | Gets the inheritance attribute of the specified component. If the component is not being inherited, this method will return the value System.ComponentModel.InheritanceAttribute.NotInherited. Otherwise it will return the inheritance attribute for this component.

See Also

IInheritanceService Interface | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IInheritanceService Methods

The methods of the IInheritanceService interface are listed below. For a complete list of IInheritanceService interface members, see the IInheritanceService Members topic.

AddInheritedComponents | Adds inherited components from the specified component to the specified container.
GetInheritanceAttribute | Gets the inheritance attribute of the specified component. If the component is not being inherited, this method will return the value System.ComponentModel.InheritanceAttribute.NotInherited. Otherwise it will return the inheritance attribute for this component.

See Also

IInheritanceService Interface | System.ComponentModel.Design Namespace


IInheritanceService.AddInheritedComponents

Adds inherited components from the specified component to the specified container.

[Visual Basic]
Sub AddInheritedComponents( _
   ByVal component As IComponent, _
   ByVal container As IContainer _
)
[C#]
void AddInheritedComponents(
   IComponent component,
   IContainer container
);
[C++]
void AddInheritedComponents(
   IComponent* component,
   IContainer* container
) = 0;
[JScript]
function AddInheritedComponents(
   component : IComponent,
   container : IContainer
);

Parameters

component
The component to search. Searching will begin with this component.
container
The container to add inherited components to.

Remarks

This method walks all the fields of all base classes of the specified component. Each field that implements IComponent is added to the specified container.

See Also

IInheritanceService Interface | IInheritanceService Members | System.ComponentModel.Design Namespace


IInheritanceService.GetInheritanceAttribute

Gets the inheritance attribute of the specified component. If the component is not being inherited, this method will return the value System.ComponentModel.InheritanceAttribute.NotInherited. Otherwise it will return the inheritance attribute for this component.

[Visual Basic]
Function GetInheritanceAttribute( _
   ByVal component As IComponent _
) As InheritanceAttribute
[C#]
InheritanceAttribute GetInheritanceAttribute(
   IComponent component
);
[C++]
InheritanceAttribute* GetInheritanceAttribute(
   IComponent* component
) = 0;
[JScript]
function GetInheritanceAttribute(
   component : IComponent
) : InheritanceAttribute;

Parameters

component
The component to retrieve the inheritance attribute for.

Return Value

An instance of InheritanceAttribute that describes what level of inheritance this component comes from.

See Also

IInheritanceService Interface | IInheritanceService Members | System.ComponentModel.Design Namespace | System.WinForms.Design.InheritanceAttribute


IMenuCommandService Interface

Provides an interface for a designer to add menu items to the Visual Studio menu.

IMenuCommandService

[Visual Basic]
Public Interface IMenuCommandService
[C#]
public interface IMenuCommandService
[C++]
public __gc __interface IMenuCommandService

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

Menu commands are handled through a handler interface, which is associated with a document designer. Only the active document can handle commands.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

IMenuCommandService Members | System.ComponentModel.Design Namespace


IMenuCommandService Members

Properties

Verbs Gets or sets an array of type DesignerVerb that indicates the set of verbs that are currently available.

Methods

AddCommand | Adds a menu command to the document.
AddVerb | Adds a verb to the set of global verbs.
FindCommand | Searches for the given command ID and returns the MenuCommand associated with it.
GlobalInvoke | Invokes a command on the local form or in the global environment.
RemoveCommand | Removes the specified MenuCommand from the document.
RemoveVerb | Removes the specified verb from the document.
ShowContextMenu | Shows the context menu with the given command ID at the specified location.

See Also

IMenuCommandService Interface | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IMenuCommandService Properties

The properties of the IMenuCommandService interface are listed below. For a complete list of IMenuCommandService interface members, see the IMenuCommandService Members topic.

Verbs Gets or sets an array of type DesignerVerb that indicates the set of verbs that are currently available.

See Also

IMenuCommandService Interface | System.ComponentModel.Design Namespace


IMenuCommandService.Verbs

Gets or sets an array of type DesignerVerb that indicates the set of verbs that are currently available.

[Visual Basic]
ReadOnly Property Verbs As DesignerVerb ()
[C#]
DesignerVerb[] Verbs {get;}
[C++]
DesignerVerb* get_Verbs() = 0;
[JScript]
abstract function get Verbs() : DesignerVerb[];

Property Value

An array of type DesignerVerb that indicates the set of verbs that are currently available.

Remarks

The set of verbs consists of a merge of global verbs, which are added by the AddVerb method on this interface, and individual designer verbs, which are offered by individual designers. If the name of a global verb conflicts with a designer verb, the designer verb will take precedence.

See Also

IMenuCommandService Interface | IMenuCommandService Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IMenuCommandService Methods

The methods of the IMenuCommandService interface are listed below. For a complete list of IMenuCommandService interface members, see the IMenuCommandService Members topic.

AddCommand | Adds a menu command to the document.
AddVerb | Adds a verb to the set of global verbs.
FindCommand | Searches for the given command ID and returns the MenuCommand associated with it.
GlobalInvoke | Invokes a command on the local form or in the global environment.
RemoveCommand | Removes the specified MenuCommand from the document.
RemoveVerb | Removes the specified verb from the document.
ShowContextMenu | Shows the context menu with the given command ID at the specified location.

See Also

IMenuCommandService Interface | System.ComponentModel.Design Namespace


IMenuCommandService.AddCommand

Adds a menu command to the document.

[Visual Basic]
Sub AddCommand( _
   ByVal command As MenuCommand _
)
[C#]
void AddCommand(
   MenuCommand command
);
[C++]
void AddCommand(
   MenuCommand* command
) = 0;
[JScript]
function AddCommand(
   command : MenuCommand
);

Parameters

command
The command to add.

Remarks

The menu command must already exist on a menu; this method merely adds a handler for it.

See Also

IMenuCommandService Interface | IMenuCommandService Members | System.ComponentModel.Design Namespace


IMenuCommandService.AddVerb

Adds a verb to the set of global verbs.

[Visual Basic]
Sub AddVerb( _
   ByVal verb As DesignerVerb _
)
[C#]
void AddVerb(
   DesignerVerb verb
);
[C++]
void AddVerb(
   DesignerVerb* verb
) = 0;
[JScript]
function AddVerb(
   verb : DesignerVerb
);

Parameters

verb
The verb to add.

Remarks

Individual components should use the Verbs property of their designer, rather than call this method. This method is intended for objects that offer a verb that is available regardless of what components are selected.

See Also

IMenuCommandService Interface | IMenuCommandService Members | System.ComponentModel.Design Namespace


IMenuCommandService.FindCommand

Searches for the given command ID and returns the MenuCommand associated with it.

[Visual Basic]
Function FindCommand( _
   ByVal commandID As CommandID _
) As MenuCommand
[C#]
MenuCommand FindCommand(
   CommandID commandID
);
[C++]
MenuCommand* FindCommand(
   CommandID* commandID
) = 0;
[JScript]
function FindCommand(
   commandID : CommandID
) : MenuCommand;

Parameters

commandID
The command ID to search for.

Return Value

The menu command associated with this command ID, or a null reference (in Visual Basic Nothing) if no command is found.

See Also

IMenuCommandService Interface | IMenuCommandService Members | System.ComponentModel.Design Namespace


IMenuCommandService.GlobalInvoke

Invokes a command on the local form or in the global environment.

[Visual Basic]
Function GlobalInvoke( _
   ByVal commandID As CommandID _
) As Boolean
[C#]
bool GlobalInvoke(
   CommandID commandID
);
[C++]
bool GlobalInvoke(
   CommandID* commandID
) = 0;
[JScript]
function GlobalInvoke(
   commandID : CommandID
) : Boolean;

Parameters

commandID
The command ID to search for and execute.

Return Value

true if the command was found and invoked successfully; otherwise, false.

Remarks

The local form is first searched for the given command ID. If it is found, it is invoked. Otherwise the the command ID is passed to the global environment command handler, if one is available.

See Also

IMenuCommandService Interface | IMenuCommandService Members | System.ComponentModel.Design Namespace


IMenuCommandService.RemoveCommand

Removes the specified MenuCommand from the document.

[Visual Basic]
Sub RemoveCommand( _
   ByVal command As MenuCommand _
)
[C#]
void RemoveCommand(
   MenuCommand command
);
[C++]
void RemoveCommand(
   MenuCommand* command
) = 0;
[JScript]
function RemoveCommand(
   command : MenuCommand
);

Parameters

command
The menu command to remove.

See Also

IMenuCommandService Interface | IMenuCommandService Members | System.ComponentModel.Design Namespace


IMenuCommandService.RemoveVerb

Removes the specified verb from the document.

[Visual Basic]
Sub RemoveVerb( _
   ByVal verb As DesignerVerb _
)
[C#]
void RemoveVerb(
   DesignerVerb verb
);
[C++]
void RemoveVerb(
   DesignerVerb* verb
) = 0;
[JScript]
function RemoveVerb(
   verb : DesignerVerb
);

Parameters

verb
The verb to remove.

See Also

IMenuCommandService Interface | IMenuCommandService Members | System.ComponentModel.Design Namespace


IMenuCommandService.ShowContextMenu

Shows the context menu with the given command ID at the specified location.

[Visual Basic]
Sub ShowContextMenu( _
   ByVal menuID As CommandID, _
   ByVal x As Integer, _
   ByVal y As Integer _
)
[C#]
void ShowContextMenu(
   CommandID menuID,
   int x,
   int y
);
[C++]
void ShowContextMenu(
   CommandID* menuID,
   int x,
   int y
) = 0;
[JScript]
function ShowContextMenu(
   menuID : CommandID,
   x : int,
   y : int
);

Parameters

menuID
The command ID for the context menu to show.
x
The x coordinate of the menu in screen coordinates.
y
The y coordinate of the menu in screen coordinates.

See Also

IMenuCommandService Interface | IMenuCommandService Members | System.ComponentModel.Design Namespace


ImmediateStringEditor Class

[To be supplied.]

Object
ValueEditor
ImmediateStringEditor

[Visual Basic]
Public Class ImmediateStringEditor
   Inherits ValueEditor
[C#]
public class ImmediateStringEditor : ValueEditor
[C++]
public __gc class ImmediateStringEditor : public ValueEditor
[JScript]
public class ImmediateStringEditor extends ValueEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

ImmediateStringEditor Members | System.ComponentModel.Design Namespace


ImmediateStringEditor Members

Public:

Constructor

ImmediateStringEditor Constructor [To be supplied.]

Properties

Style |
Values (inherited from ValueEditor) | [To be supplied.]

Methods

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from ValueEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue (inherited from ValueEditor) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from ValueEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ImmediateStringEditor Class | System.ComponentModel.Design Namespace


ImmediateStringEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ImmediateStringEditor();
[C++]
public: ImmediateStringEditor();
[JScript]
public function ImmediateStringEditor();

See Also

ImmediateStringEditor Class | ImmediateStringEditor Members | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ImmediateStringEditor Properties

The properties of the ImmediateStringEditor class are listed below. For a complete list of ImmediateStringEditor class members, see the ImmediateStringEditor Members topic.

Public:

Style |
Values (inherited from ValueEditor) | [To be supplied.]

See Also

ImmediateStringEditor Class | System.ComponentModel.Design Namespace


ImmediateStringEditor.Style

[Visual Basic]
Overridable Public ReadOnly Property Style As ValueEditorStyles
[C#]
public ValueEditorStyles Style {override get;}
[C++]
public: __property virtual ValueEditorStyles get_Style();
[JScript]
public function get Style() : ValueEditorStyles;

See Also

ImmediateStringEditor Class | ImmediateStringEditor Members | System.ComponentModel.Design Namespace


InheritanceAttribute Class

Marks instances of objects that are inherited from their base superclass. This class cannot be inherited.

Object
Attribute
MemberAttribute
InheritanceAttribute

[Visual Basic]
NotInheritable Public Class InheritanceAttribute
   Inherits MemberAttribute
[C#]
public sealed class InheritanceAttribute : MemberAttribute
[C++]
public __gc __sealed class InheritanceAttribute : public
   MemberAttribute
[JScript]
public class InheritanceAttribute extends MemberAttribute

Remarks

To find inherited objects, the method cycles through the base classes. When an inherited object is found, it is added to the design container so that its properties can be browsed in the property browser. It should be marked inherited so that declarations are not added for the component.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

InheritanceAttribute Members | System.ComponentModel.Design Namespace | MemberAttribute


InheritanceAttribute Members

Public:

Constructor

InheritanceAttribute Constructor Overloaded. Initializes a new instance of InheritanceAttribute.

Properties

InheritanceLevel | Gets or sets the current inheritance level stored in this attribute.
TypeId (inherited from MemberAttribute) | Gets a unique ID for this MemberAttribute.

Methods

Equals | Override to test for equality.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsDefaultAttribute | Gets whether this attribute is the default.
Match (inherited from MemberAttribute) | Determines whether one attribute matches another.
ToString | Converts this attribute to a string.

Fields

Default | Specifies the default value for the InheritanceAttribute as NotInherited.
Inherited | Specifies that the component is inherited. This field is read-only.
InheritedReadOnly | Specifies that the component is inherited and is read-only. This field is read-only.
NotInherited | Specifies that the component is not inherited. This field is read-only.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InheritanceAttribute Class | System.ComponentModel.Design Namespace


InheritanceAttribute Constructor

Initializes a new instance of InheritanceAttribute.

Overload List

Initializes a new instance of InheritanceAttribute.

[Visual Basic] Overloads Public Sub New()
[C#] public InheritanceAttribute();
[C++] public: InheritanceAttribute();
[JScript] public function InheritanceAttribute();

Initializes a new InheritanceAttribute with the specified inheritance level.

[Visual Basic] Overloads Public Sub New(InheritanceLevel)
[C#] public InheritanceAttribute(InheritanceLevel);
[C++] public: InheritanceAttribute(InheritanceLevel);
[JScript] public function InheritanceAttribute(InheritanceLevel);

See Also

InheritanceAttribute Class | InheritanceAttribute Members | System.ComponentModel.Design Namespace


InheritanceAttribute Constructor ()

Initializes a new instance of InheritanceAttribute.

[Visual Basic]
Overloads Public Sub New()
[C#]
public InheritanceAttribute();
[C++]
public: InheritanceAttribute();
[JScript]
public function InheritanceAttribute();

See Also

InheritanceAttribute Class | InheritanceAttribute Members | System.ComponentModel.Design Namespace | InheritanceAttribute Constructor Overload List


InheritanceAttribute Constructor (InheritanceLevel)

Initializes a new InheritanceAttribute with the specified inheritance level.

[Visual Basic]
Overloads Public Sub New( _
   ByVal inheritanceLevel As InheritanceLevel _
)
[C#]
public InheritanceAttribute(
   InheritanceLevel inheritanceLevel
);
[C++]
public: InheritanceAttribute(
   InheritanceLevel inheritanceLevel
);
[JScript]
public function InheritanceAttribute(
   inheritanceLevel : InheritanceLevel
);

Parameters

inheritanceLevel
An InheritanceLevel that indicates the level of inheritance to set this attribute to.

See Also

InheritanceAttribute Class | InheritanceAttribute Members | System.ComponentModel.Design Namespace | InheritanceAttribute Constructor Overload List | InheritanceLevel


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

InheritanceAttribute Properties

The properties of the InheritanceAttribute class are listed below. For a complete list of InheritanceAttribute class members, see the InheritanceAttribute Members topic.

Public:

InheritanceLevel | Gets or sets the current inheritance level stored in this attribute.
TypeId (inherited from MemberAttribute) | Gets a unique ID for this MemberAttribute.

See Also

InheritanceAttribute Class | System.ComponentModel.Design Namespace


InheritanceAttribute.InheritanceLevel

Gets or sets the current inheritance level stored in this attribute.

[Visual Basic]
Public ReadOnly Property InheritanceLevel As InheritanceLevel
[C#]
public InheritanceLevel InheritanceLevel {get;}
[C++]
public: __property InheritanceLevel get_InheritanceLevel();
[JScript]
public function get InheritanceLevel() : InheritanceLevel;

Property Value

The InheritanceLevel stored in this attribute.

See Also

InheritanceAttribute Class | InheritanceAttribute Members | System.ComponentModel.Design Namespace | InheritanceLevel


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

InheritanceAttribute Methods

The methods of the InheritanceAttribute class are listed below. For a complete list of InheritanceAttribute class members, see the InheritanceAttribute Members topic.

Public:

Equals | Override to test for equality.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsDefaultAttribute | Gets whether this attribute is the default.
Match (inherited from MemberAttribute) | Determines whether one attribute matches another.
ToString | Converts this attribute to a string.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InheritanceAttribute Class | System.ComponentModel.Design Namespace


InheritanceAttribute.Equals

Override to test for equality.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal value As Object _
) As Boolean
[C#]
public override bool Equals(
   object value
);
[C++]
public: override bool Equals(
   Object* value
);
[JScript]
public override function Equals(
   value : Object
) : Boolean;

Parameters

value
The object to test.

Return Value

true if the object is the same; otherwise, false.

See Also

InheritanceAttribute Class | InheritanceAttribute Members | System.ComponentModel.Design Namespace


InheritanceAttribute.IsDefaultAttribute

Gets whether this attribute is the default.

[Visual Basic]
Overrides Public Function IsDefaultAttribute() As Boolean
[C#]
public override bool IsDefaultAttribute();
[C++]
public: override bool IsDefaultAttribute();
[JScript]
public override function IsDefaultAttribute() : Boolean;

Return Value

true if this attribute is default, false otherwise.

See Also

InheritanceAttribute Class | InheritanceAttribute Members | System.ComponentModel.Design Namespace | MemberAttribute


InheritanceAttribute.ToString

Converts this attribute to a string.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

InheritanceAttribute Class | InheritanceAttribute Members | System.ComponentModel.Design Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

InheritanceAttribute Fields

The fields of the InheritanceAttribute class are listed below. For a complete list of InheritanceAttribute class members, see the InheritanceAttribute Members topic.

Public:

Default | Specifies the default value for the InheritanceAttribute as NotInherited.
Inherited | Specifies that the component is inherited. This field is read-only.
InheritedReadOnly | Specifies that the component is inherited and is read-only. This field is read-only.
NotInherited | Specifies that the component is not inherited. This field is read-only.

See Also

InheritanceAttribute Class | System.ComponentModel.Design Namespace


InheritanceAttribute.Default

Specifies the default value for the InheritanceAttribute as NotInherited.

[Visual Basic]
Public Shared ReadOnly Default As InheritanceAttribute
[C#]
public static readonly InheritanceAttribute Default;
[C++]
public: static readonly InheritanceAttribute* Default;
[JScript]
public static var Default : InheritanceAttribute;

See Also

InheritanceAttribute Class | InheritanceAttribute Members | System.ComponentModel.Design Namespace


InheritanceAttribute.Inherited

Specifies that the component is inherited. This field is read-only.

[Visual Basic]
Public Shared ReadOnly Inherited As InheritanceAttribute
[C#]
public static readonly InheritanceAttribute Inherited;
[C++]
public: static readonly InheritanceAttribute* Inherited;
[JScript]
public static var Inherited : InheritanceAttribute;

See Also

InheritanceAttribute Class | InheritanceAttribute Members | System.ComponentModel.Design Namespace


InheritanceAttribute.InheritedReadOnly

Specifies that the component is inherited and is read-only. This field is read-only.

[Visual Basic]
Public Shared ReadOnly InheritedReadOnly As InheritanceAttribute
[C#]
public static readonly InheritanceAttribute InheritedReadOnly;
[C++]
public: static readonly InheritanceAttribute* InheritedReadOnly;
[JScript]
public static var InheritedReadOnly : InheritanceAttribute;

See Also

InheritanceAttribute Class | InheritanceAttribute Members | System.ComponentModel.Design Namespace


InheritanceAttribute.NotInherited

Specifies that the component is not inherited. This field is read-only.

[Visual Basic]
Public Shared ReadOnly NotInherited As InheritanceAttribute
[C#]
public static readonly InheritanceAttribute NotInherited;
[C++]
public: static readonly InheritanceAttribute* NotInherited;
[JScript]
public static var NotInherited : InheritanceAttribute;

See Also

InheritanceAttribute Class | InheritanceAttribute Members | System.ComponentModel.Design Namespace


InheritanceLevel Enumeration

Specifies numeric IDs for different inheritance levels.

[Visual Basic]
Public Enum InheritanceLevel
[C#]
public enum InheritanceLevel
[C++]
public enum InheritanceLevel

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

These numeric IDs are used with the InheritanceAttribute attribute to define various levels of inheritance.

Members

Member Name | Description
Inherited | Indicates that the object is inherited.
InheritedReadOnly | Indicates that the object is inherited, but has private access.
NotInherited | Indicates that the object is not inherited.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

System.ComponentModel.Design Namespace | MemberAttribute


InheritanceService Class

The inheritance service provides a set of utilities for analyzing and identifying inherited components.

Object
InheritanceService

[Visual Basic]
Public Class InheritanceService
   Implements IInheritanceService
[C#]
public class InheritanceService : IInheritanceService
[C++]
public __gc class InheritanceService : public IInheritanceService
[JScript]
public class InheritanceService implements IInheritanceService

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

InheritanceService Members | System.ComponentModel.Design Namespace


InheritanceService Members

Public:

Constructor

InheritanceService Constructor Creates a new inheritance service.

Methods

AddInheritedComponents | Overloaded. [To be supplied.]
Dispose | Disposes this object.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInheritanceAttribute | Retrieves the inheritance attribute of the given component. If the component is not being inherited, this will return the value NotInherited. Otherwise it will return the inheritance attribute for this component.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

AddInheritedComponents | Overloaded. [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
IgnoreInheritedField | This provides a way for users to modify the set of fields that the inheritance service will ignore. By default, the service ignores all fields that are private, and only allows public or protected fields. You may modify this behavior by overriding this method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InheritanceService Class | System.ComponentModel.Design Namespace


InheritanceService Constructor

Creates a new inheritance service.

[Visual Basic]
Public Sub New()
[C#]
public InheritanceService();
[C++]
public: InheritanceService();
[JScript]
public function InheritanceService();

See Also

InheritanceService Class | InheritanceService Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

InheritanceService Methods

The methods of the InheritanceService class are listed below. For a complete list of InheritanceService class members, see the InheritanceService Members topic.

Public:

AddInheritedComponents | Overloaded. [To be supplied.]
Dispose | Disposes this object.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInheritanceAttribute | Retrieves the inheritance attribute of the given component. If the component is not being inherited, this will return the value NotInherited. Otherwise it will return the inheritance attribute for this component.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

AddInheritedComponents | Overloaded. [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
IgnoreInheritedField | This provides a way for users to modify the set of fields that the inheritance service will ignore. By default, the service ignores all fields that are private, and only allows public or protected fields. You may modify this behavior by overriding this method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InheritanceService Class | System.ComponentModel.Design Namespace


InheritanceService.AddInheritedComponents

[To be supplied.]

Overload List

This method walks all the fields of all base classes of component. Each field that implements IComponent is added to an internal list that stores an InheritanceAttribute that identifies the inheritance level of the component. The component is then added to the given container.

[Visual Basic] Overloads Overridable Protected Sub AddInheritedComponents(Type, IComponent, IContainer)
[C#] protected virtual void AddInheritedComponents(Type, IComponent, IContainer);
[C++] protected: virtual void AddInheritedComponents(Type*, IComponent, IContainer);
[JScript] protected function AddInheritedComponents(Type, IComponent, IContainer);

This method walks all the fields of all base classes of component. Each field that implements IComponent is added to the given container.

[Visual Basic] Overloads Overridable Public Sub AddInheritedComponents(IComponent, IContainer)
[C#] public virtual void AddInheritedComponents(IComponent, IContainer);
[C++] public: virtual void AddInheritedComponents(IComponent*, IContainer);
[JScript] public function AddInheritedComponents(IComponent, IContainer);

See Also

InheritanceService Class | InheritanceService Members | System.ComponentModel.Design Namespace


InheritanceService.AddInheritedComponents (Type, IComponent, IContainer)

This method walks all the fields of all base classes of component. Each field that implements IComponent is added to an internal list that stores an InheritanceAttribute that identifies the inheritance level of the component. The component is then added to the given container.

[Visual Basic]
Overloads Overridable Protected Sub AddInheritedComponents( _
   ByVal type As Type, _
   ByVal component As IComponent, _
   ByVal container As IContainer _
)
[C#]
protected virtual void AddInheritedComponents(
   Type type,
   IComponent component,
   IContainer container
);
[C++]
protected: virtual void AddInheritedComponents(
   Type* type,
   IComponent* component,
   IContainer* container
);
[JScript]
protected function AddInheritedComponents(
   type : Type,
   component : IComponent,
   container : IContainer
);

Parameters

type
The base type to begin searching.
component
The component to search. This will begin searching the base class of the component.
container
The container to add inherited components to.

See Also

InheritanceService Class | InheritanceService Members | System.ComponentModel.Design Namespace | InheritanceService.AddInheritedComponents Overload List


InheritanceService.AddInheritedComponents (IComponent, IContainer)

This method walks all the fields of all base classes of component. Each field that implements IComponent is added to the given container.

[Visual Basic]
Overloads Overridable Public Sub AddInheritedComponents( _
   ByVal component As IComponent, _
   ByVal container As IContainer _
)
[C#]
public virtual void AddInheritedComponents(
   IComponent component,
   IContainer container
);
[C++]
public: virtual void AddInheritedComponents(
   IComponent* component,
   IContainer* container
);
[JScript]
public function AddInheritedComponents(
   component : IComponent,
   container : IContainer
);

Parameters

component
The component to search. This will begin searching with this component's class.
container
The container to add inherited components to.

See Also

InheritanceService Class | InheritanceService Members | System.ComponentModel.Design Namespace | InheritanceService.AddInheritedComponents Overload List | IInheritanceService


InheritanceService.Dispose

Disposes this object.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[JScript]
public function Dispose();

See Also

InheritanceService Class | InheritanceService Members | System.ComponentModel.Design Namespace


InheritanceService.GetInheritanceAttribute

Retrieves the inheritance attribute of the given component. If the component is not being inherited, this will return the value NotInherited. Otherwise it will return the inheritance attribute for this component.

[Visual Basic]
Overridable Public Function GetInheritanceAttribute( _
   ByVal component As IComponent _
) As InheritanceAttribute
[C#]
public virtual InheritanceAttribute GetInheritanceAttribute(
   IComponent component
);
[C++]
public: virtual InheritanceAttribute* GetInheritanceAttribute(
   IComponent* component
);
[JScript]
public function GetInheritanceAttribute(
   component : IComponent
) : InheritanceAttribute;

Parameters

component
The component to retrieve the inheritance attribute for.

Return Value

An instance of InheritanceAttribute that describes what level of inheritance this component comes from.

See Also

InheritanceService Class | InheritanceService Members | System.ComponentModel.Design Namespace | InheritanceAttribute | IInheritanceService


InheritanceService.IgnoreInheritedField

This provides a way for users to modify the set of fields that the inheritance service will ignore. By default, the service ignores all fields that are private, and only allows public or protected fields. You may modify this behavior by overriding this method.

[Visual Basic]
Overridable Protected Function IgnoreInheritedField( _
   ByVal field As FieldInfo, _
   ByVal component As IComponent _
) As Boolean
[C#]
protected virtual bool IgnoreInheritedField(
   FieldInfo field,
   IComponent component
);
[C++]
protected: virtual bool IgnoreInheritedField(
   FieldInfo* field,
   IComponent* component
);
[JScript]
protected function IgnoreInheritedField(
   field : FieldInfo,
   component : IComponent
) : Boolean;

Parameters

field
The field to check.
component
The component instance this field is bound to.

Return Value

This should return true if the given field should be included in the set of inherited components, or false otherwise.

See Also

InheritanceService Class | InheritanceService Members | System.ComponentModel.Design Namespace


InheritedPropertyDescriptor Class

An inherited property descriptor is used to replace all properties on a component that is being inherited. An inherited property descriptor is identical to the component's original property descriptor except for two things. First, you can tie additional attributes into this property descriptor, such as ReadOnly if the property should not be accessible on an inherited component. Second, this property descriptor stores a new default value attribute for the property that is the current value of this property on the component. This override is important because the inherited component may have different values for its defaults than its own property descriptor states.

Object
MemberDescriptor
PropertyDescriptor
InheritedPropertyDescriptor

[Visual Basic]
Public Class InheritedPropertyDescriptor
   Inherits PropertyDescriptor
[C#]
public class InheritedPropertyDescriptor : PropertyDescriptor
[C++]
public __gc class InheritedPropertyDescriptor : public
   PropertyDescriptor
[JScript]
public class InheritedPropertyDescriptor extends PropertyDescriptor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

InheritedPropertyDescriptor Members | System.ComponentModel.Design Namespace | PropertyDescriptor


InheritedPropertyDescriptor Members

Public:

Constructor

InheritedPropertyDescriptor Constructor Overloaded. [To be supplied.]

Properties

Attributes (inherited from MemberDescriptor) | Gets the collection of attributes for this member.
Category (inherited from MemberDescriptor) | Gets the name of the category that the member belongs to, as specified in the CategoryAttribute.
ComponentType | Retrieves the type of the component this PropertyDescriptor is bound to.
Converter (inherited from PropertyDescriptor) | Gets the type converter for this property.
Description (inherited from MemberDescriptor) | Gets the description of the member as specified in the DescriptionAttribute.
IsBrowsable (inherited from MemberDescriptor) | Gets a value indicating whether the member is browsable as specified in the BrowsableAttribute.
IsLocalizable (inherited from PropertyDescriptor) | Gets a value indicating whether this property should be localized, as specified in the LocalizableAttribute.
IsReadOnly | Indicates whether this property is read only.
IsRealProperty | Indicates whether this property is read only.
Name (inherited from MemberDescriptor) | Gets the name of the member.
PersistableSupport (inherited from PropertyDescriptor) | Gets a value indicating whether this property should be persisted as specified in the PersistableAttribute.
PropertyType | Retrieves the type of the property.

Methods

CanResetValue | Indicates whether reset will change the value of the component. If there is a DefaultValueAttribute, then this will return true if getValue returns something different than the default value. If there is a reset method and a shouldPersist method, this will return what shouldPersist returns. If there is just a reset method, this always returns true. If none of these cases apply, this returns false.
Equals (inherited from PropertyDescriptor) | Compares this to another PropertyDescriptor to see if they are equivalent.
GetDesignTimeOnly (inherited from MemberDescriptor) | Determines whether this member should be set only at design time as specified in the DesignOnlyAttribute.
GetDisplayName (inherited from MemberDescriptor) | Gets the name that can be displayed in a window like a property browser.
GetEditor (inherited from PropertyDescriptor) | Gets an editor of the specified type.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHelpTopic (inherited from MemberDescriptor) | Gets the name of the Help topic specified in the HelpAttribute.
GetHelpURL (inherited from MemberDescriptor) | Gets the URL for the Help file specified in the HelpAttribute.
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | Retrieves the current value of the property on component, invoking the getXXX method. An exception in the getXXX method will pass through.
ResetValue | Will reset the default value for this property on the component. If there was a default value passed in as a DefaultValueAttribute, that value will be set as the value of the property on the component. If there was no default value passed in, a ResetXXX method will be looked for. If one is found, it will be invoked. If one is not found, this is a nop.
SetValue | This will set value to be the new value of this property on the component by invoking the setXXX method on the component. If the value specified is invalid, the component should throw an exception which will be passed up. The component designer should design the property so that getXXX following a setXXX should return the value passed in if no exception was thrown in the setXXX call.
ShouldPersistValue | Indicates whether the value of this property needs to be persisted. In other words, it indicates whether the state of the property is distinct from when the component is first instantiated. If there is a default value specified in this PropertyDescriptor, it will be compared against the property's current value to determine this. If there is't, the shouldPersistXXX method is looked for and invoked if found. If both these routes fail, true will be returned. If this returns false, a tool should not persist this property's value.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

AttributeArray (inherited from MemberDescriptor) | Gets or sets an array of attributes.
DefaultValue | Retrieves the default value for this property.
NameHashCode (inherited from MemberDescriptor) | Gets the hash code for the name of the member as specified in GetHashCode.

Methods

CreateAttributeCollection (inherited from MemberDescriptor) | Creates a collection of attributes using the array of attributes that you passed to the constructor.
CreateInstance (inherited from PropertyDescriptor) | Creates an instance of the specified type.
FillAttributes (inherited from MemberDescriptor) | In an inheriting class, adds the attributes of the inheriting class to the specified list of attributes in the parent class.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InheritedPropertyDescriptor Class | System.ComponentModel.Design Namespace


InheritedPropertyDescriptor Constructor

[To be supplied.]

Overload List

Creates a new inherited property descriptor.

[Visual Basic] Overloads Public Sub New(PropertyDescriptor, Object, MemberAttribute())
[C#] public InheritedPropertyDescriptor(PropertyDescriptor, Object, MemberAttribute[]);
[C++] public: InheritedPropertyDescriptor(PropertyDescriptor*, Object, MemberAttribute[]);
[JScript] public function InheritedPropertyDescriptor(PropertyDescriptor, Object, MemberAttribute[]);

Creates a new inherited property descriptor.

[Visual Basic] Overloads Public Sub New(PropertyDescriptor, Object)
[C#] public InheritedPropertyDescriptor(PropertyDescriptor, Object);
[C++] public: InheritedPropertyDescriptor(PropertyDescriptor*, Object);
[JScript] public function InheritedPropertyDescriptor(PropertyDescriptor, Object);

Creates a new inherited property descriptor.

[Visual Basic] Overloads Public Sub New(PropertyDescriptor, Object, MemberAttribute)
[C#] public InheritedPropertyDescriptor(PropertyDescriptor, Object, MemberAttribute);
[C++] public: InheritedPropertyDescriptor(PropertyDescriptor*, Object, MemberAttribute);
[JScript] public function InheritedPropertyDescriptor(PropertyDescriptor, Object, MemberAttribute);

Creates a new inherited property descriptor.

[Visual Basic] Overloads Public Sub New(PropertyDescriptor, Object, MemberAttribute, MemberAttribute)
[C#] public InheritedPropertyDescriptor(PropertyDescriptor, Object, MemberAttribute, MemberAttribute);
[C++] public: InheritedPropertyDescriptor(PropertyDescriptor*, Object, MemberAttribute, MemberAttribute);
[JScript] public function InheritedPropertyDescriptor(PropertyDescriptor, Object, MemberAttribute, MemberAttribute);

Creates a new inherited property descriptor.

[Visual Basic] Overloads Public Sub New(PropertyDescriptor, Object, MemberAttribute, MemberAttribute, MemberAttribute)
[C#] public InheritedPropertyDescriptor(PropertyDescriptor, Object, MemberAttribute, MemberAttribute, MemberAttribute);
[C++] public: InheritedPropertyDescriptor(PropertyDescriptor*, Object, MemberAttribute, MemberAttribute, MemberAttribute);
[JScript] public function InheritedPropertyDescriptor(PropertyDescriptor, Object, MemberAttribute, MemberAttribute, MemberAttribute);

Creates a new inherited property descriptor.

[Visual Basic] Overloads Public Sub New(PropertyDescriptor, Object, MemberAttribute, MemberAttribute, MemberAttribute, MemberAttribute)
[C#] public InheritedPropertyDescriptor(PropertyDescriptor, Object, MemberAttribute, MemberAttribute, MemberAttribute, MemberAttribute);
[C++] public: InheritedPropertyDescriptor(PropertyDescriptor*, Object, MemberAttribute, MemberAttribute, MemberAttribute, MemberAttribute);
[JScript] public function InheritedPropertyDescriptor(PropertyDescriptor, Object, MemberAttribute, MemberAttribute, MemberAttribute, MemberAttribute);

See Also

InheritedPropertyDescriptor Class | InheritedPropertyDescriptor Members | System.ComponentModel.Design Namespace


InheritedPropertyDescriptor Constructor (PropertyDescriptor, Object, MemberAttribute[])

Creates a new inherited property descriptor.

[Visual Basic]
Overloads Public Sub New( _
   ByVal propertyDescriptor As PropertyDescriptor, _
   ByVal component As Object, _
   ByVal attrs() As MemberAttribute _
)
[C#]
public InheritedPropertyDescriptor(
   PropertyDescriptor propertyDescriptor,
   object component,
   MemberAttribute[] attrs
);
[C++]
public: InheritedPropertyDescriptor(
   PropertyDescriptor* propertyDescriptor,
   Object* component,
   MemberAttribute* attrs[]
);
[JScript]
public function InheritedPropertyDescriptor(
   propertyDescriptor : PropertyDescriptor,
   component : Object,
   attrs : MemberAttribute[]
);

Parameters

propertyDescriptor
The property descriptor to inherit from.
component
The compnent to create this inherited property descriptor for.
attrs
An array of new member attributes to merge into this property's attribute set.

See Also

InheritedPropertyDescriptor Class | InheritedPropertyDescriptor Members | System.ComponentModel.Design Namespace | InheritedPropertyDescriptor Constructor Overload List | PropertyDescriptor


InheritedPropertyDescriptor Constructor (PropertyDescriptor, Object)

Creates a new inherited property descriptor.

[Visual Basic]
Overloads Public Sub New( _
   ByVal propertyDescriptor As PropertyDescriptor, _
   ByVal component As Object _
)
[C#]
public InheritedPropertyDescriptor(
   PropertyDescriptor propertyDescriptor,
   object component
);
[C++]
public: InheritedPropertyDescriptor(
   PropertyDescriptor* propertyDescriptor,
   Object* component
);
[JScript]
public function InheritedPropertyDescriptor(
   propertyDescriptor : PropertyDescriptor,
   component : Object
);

Parameters

propertyDescriptor
The property descriptor to inherit from.
component
The compnent to create this inherited property descriptor for.

See Also

InheritedPropertyDescriptor Class | InheritedPropertyDescriptor Members | System.ComponentModel.Design Namespace | InheritedPropertyDescriptor Constructor Overload List | PropertyDescriptor


InheritedPropertyDescriptor Constructor (PropertyDescriptor, Object, MemberAttribute)

Creates a new inherited property descriptor.

[Visual Basic]
Overloads Public Sub New( _
   ByVal propertyDescriptor As PropertyDescriptor, _
   ByVal component As Object, _
   ByVal a1 As MemberAttribute _
)
[C#]
public InheritedPropertyDescriptor(
   PropertyDescriptor propertyDescriptor,
   object component,
   MemberAttribute a1
);
[C++]
public: InheritedPropertyDescriptor(
   PropertyDescriptor* propertyDescriptor,
   Object* component,
   MemberAttribute* a1
);
[JScript]
public function InheritedPropertyDescriptor(
   propertyDescriptor : PropertyDescriptor,
   component : Object,
   a1 : MemberAttribute
);

Parameters

propertyDescriptor
The property descriptor to inherit from.
component
The compnent to create this inherited property descriptor for.
a1
An additional attribute to merge into the property's attribute set.

See Also

InheritedPropertyDescriptor Class | InheritedPropertyDescriptor Members | System.ComponentModel.Design Namespace | InheritedPropertyDescriptor Constructor Overload List | PropertyDescriptor


InheritedPropertyDescriptor Constructor (PropertyDescriptor, Object, MemberAttribute, MemberAttribute)

Creates a new inherited property descriptor.

[Visual Basic]
Overloads Public Sub New( _
   ByVal propertyDescriptor As PropertyDescriptor, _
   ByVal component As Object, _
   ByVal a1 As MemberAttribute, _
   ByVal a2 As MemberAttribute _
)
[C#]
public InheritedPropertyDescriptor(
   PropertyDescriptor propertyDescriptor,
   object component,
   MemberAttribute a1,
   MemberAttribute a2
);
[C++]
public: InheritedPropertyDescriptor(
   PropertyDescriptor* propertyDescriptor,
   Object* component,
   MemberAttribute* a1,
   MemberAttribute* a2
);
[JScript]
public function InheritedPropertyDescriptor(
   propertyDescriptor : PropertyDescriptor,
   component : Object,
   a1 : MemberAttribute,
   a2 : MemberAttribute
);

Parameters

propertyDescriptor
The property descriptor to inherit from.
component
The compnent to create this inherited property descriptor for.
a1
An additional attribute to merge into the property's attribute set.
a2
An additional attribute to merge into the property's attribute set.

See Also

InheritedPropertyDescriptor Class | InheritedPropertyDescriptor Members | System.ComponentModel.Design Namespace | InheritedPropertyDescriptor Constructor Overload List | PropertyDescriptor


InheritedPropertyDescriptor Constructor (PropertyDescriptor, Object, MemberAttribute, MemberAttribute, MemberAttribute)

Creates a new inherited property descriptor.

[Visual Basic]
Overloads Public Sub New( _
   ByVal propertyDescriptor As PropertyDescriptor, _
   ByVal component As Object, _
   ByVal a1 As MemberAttribute, _
   ByVal a2 As MemberAttribute, _
   ByVal a3 As MemberAttribute _
)
[C#]
public InheritedPropertyDescriptor(
   PropertyDescriptor propertyDescriptor,
   object component,
   MemberAttribute a1,
   MemberAttribute a2,
   MemberAttribute a3
);
[C++]
public: InheritedPropertyDescriptor(
   PropertyDescriptor* propertyDescriptor,
   Object* component,
   MemberAttribute* a1,
   MemberAttribute* a2,
   MemberAttribute* a3
);
[JScript]
public function InheritedPropertyDescriptor(
   propertyDescriptor : PropertyDescriptor,
   component : Object,
   a1 : MemberAttribute,
   a2 : MemberAttribute,
   a3 : MemberAttribute
);

Parameters

propertyDescriptor
The property descriptor to inherit from.
component
The compnent to create this inherited property descriptor for.
a1
An additional attribute to merge into the property's attribute set.
a2
An additional attribute to merge into the property's attribute set.
a3
An additional attribute to merge into the property's attribute set.

See Also

InheritedPropertyDescriptor Class | InheritedPropertyDescriptor Members | System.ComponentModel.Design Namespace | InheritedPropertyDescriptor Constructor Overload List | PropertyDescriptor


InheritedPropertyDescriptor Constructor (PropertyDescriptor, Object, MemberAttribute, MemberAttribute, MemberAttribute, MemberAttribute)

Creates a new inherited property descriptor.

[Visual Basic]
Overloads Public Sub New( _
   ByVal propertyDescriptor As PropertyDescriptor, _
   ByVal component As Object, _
   ByVal a1 As MemberAttribute, _
   ByVal a2 As MemberAttribute, _
   ByVal a3 As MemberAttribute, _
   ByVal a4 As MemberAttribute _
)
[C#]
public InheritedPropertyDescriptor(
   PropertyDescriptor propertyDescriptor,
   object component,
   MemberAttribute a1,
   MemberAttribute a2,
   MemberAttribute a3,
   MemberAttribute a4
);
[C++]
public: InheritedPropertyDescriptor(
   PropertyDescriptor* propertyDescriptor,
   Object* component,
   MemberAttribute* a1,
   MemberAttribute* a2,
   MemberAttribute* a3,
   MemberAttribute* a4
);
[JScript]
public function InheritedPropertyDescriptor(
   propertyDescriptor : PropertyDescriptor,
   component : Object,
   a1 : MemberAttribute,
   a2 : MemberAttribute,
   a3 : MemberAttribute,
   a4 : MemberAttribute
);

Parameters

propertyDescriptor
The property descriptor to inherit from.
component
The compnent to create this inherited property descriptor for.
a1
An additional attribute to merge into the property's attribute set.
a2
An additional attribute to merge into the property's attribute set.
a3
An additional attribute to merge into the property's attribute set.
a4
An additional attribute to merge into the property's attribute set.

See Also

InheritedPropertyDescriptor Class | InheritedPropertyDescriptor Members | System.ComponentModel.Design Namespace | InheritedPropertyDescriptor Constructor Overload List | PropertyDescriptor


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

InheritedPropertyDescriptor Properties

The properties of the InheritedPropertyDescriptor class are listed below. For a complete list of InheritedPropertyDescriptor class members, see the InheritedPropertyDescriptor Members topic.

Public:

Attributes (inherited from MemberDescriptor) | Gets the collection of attributes for this member.
Category (inherited from MemberDescriptor) | Gets the name of the category that the member belongs to, as specified in the CategoryAttribute.
ComponentType | Retrieves the type of the component this PropertyDescriptor is bound to.
Converter (inherited from PropertyDescriptor) | Gets the type converter for this property.
Description (inherited from MemberDescriptor) | Gets the description of the member as specified in the DescriptionAttribute.
IsBrowsable (inherited from MemberDescriptor) | Gets a value indicating whether the member is browsable as specified in the BrowsableAttribute.
IsLocalizable (inherited from PropertyDescriptor) | Gets a value indicating whether this property should be localized, as specified in the LocalizableAttribute.
IsReadOnly | Indicates whether this property is read only.
IsRealProperty | Indicates whether this property is read only.
Name (inherited from MemberDescriptor) | Gets the name of the member.
PersistableSupport (inherited from PropertyDescriptor) | Gets a value indicating whether this property should be persisted as specified in the PersistableAttribute.
PropertyType | Retrieves the type of the property.

Protected:

AttributeArray (inherited from MemberDescriptor) | Gets or sets an array of attributes.
DefaultValue | Retrieves the default value for this property.
NameHashCode (inherited from MemberDescriptor) | Gets the hash code for the name of the member as specified in GetHashCode.

See Also

InheritedPropertyDescriptor Class | System.ComponentModel.Design Namespace


InheritedPropertyDescriptor.ComponentType

Retrieves the type of the component this PropertyDescriptor is bound to.

[Visual Basic]
Overridable Public ReadOnly Property ComponentType As Type
[C#]
public Type ComponentType {override get;}
[C++]
public: __property virtual Type* get_ComponentType();
[JScript]
public function get ComponentType() : Type;

Property Value

the type of component.

See Also

InheritedPropertyDescriptor Class | InheritedPropertyDescriptor Members | System.ComponentModel.Design Namespace


InheritedPropertyDescriptor.DefaultValue

Retrieves the default value for this property.

[Visual Basic]
Overridable Protected ReadOnly Property DefaultValue As Object
[C#]
protected object DefaultValue {virtual get;}
[C++]
protected: __property virtual Object* get_DefaultValue();
[JScript]
protected function get DefaultValue() : Object;

See Also

InheritedPropertyDescriptor Class | InheritedPropertyDescriptor Members | System.ComponentModel.Design Namespace


InheritedPropertyDescriptor.IsReadOnly

Indicates whether this property is read only.

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {override get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;

Property Value

whether this property is read only.

See Also

InheritedPropertyDescriptor Class | InheritedPropertyDescriptor Members | System.ComponentModel.Design Namespace


InheritedPropertyDescriptor.IsRealProperty

Indicates whether this property is read only.

[Visual Basic]
Overridable Public ReadOnly Property IsRealProperty As Boolean
[C#]
public bool IsRealProperty {override get;}
[C++]
public: __property virtual bool get_IsRealProperty();
[JScript]
public function get IsRealProperty() : Boolean;

Property Value

whether this property is read only.

See Also

InheritedPropertyDescriptor Class | InheritedPropertyDescriptor Members | System.ComponentModel.Design Namespace


InheritedPropertyDescriptor.PropertyType

Retrieves the type of the property.

[Visual Basic]
Overridable Public ReadOnly Property PropertyType As Type
[C#]
public Type PropertyType {override get;}
[C++]
public: __property virtual Type* get_PropertyType();
[JScript]
public function get PropertyType() : Type;

Property Value

type of property.

See Also

InheritedPropertyDescriptor Class | InheritedPropertyDescriptor Members | System.ComponentModel.Design Namespace | PropertyDescriptor


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

InheritedPropertyDescriptor Methods

The methods of the InheritedPropertyDescriptor class are listed below. For a complete list of InheritedPropertyDescriptor class members, see the InheritedPropertyDescriptor Members topic.

Public:

CanResetValue | Indicates whether reset will change the value of the component. If there is a DefaultValueAttribute, then this will return true if getValue returns something different than the default value. If there is a reset method and a shouldPersist method, this will return what shouldPersist returns. If there is just a reset method, this always returns true. If none of these cases apply, this returns false.
Equals (inherited from PropertyDescriptor) | Compares this to another PropertyDescriptor to see if they are equivalent.
GetDesignTimeOnly (inherited from MemberDescriptor) | Determines whether this member should be set only at design time as specified in the DesignOnlyAttribute.
GetDisplayName (inherited from MemberDescriptor) | Gets the name that can be displayed in a window like a property browser.
GetEditor (inherited from PropertyDescriptor) | Gets an editor of the specified type.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHelpTopic (inherited from MemberDescriptor) | Gets the name of the Help topic specified in the HelpAttribute.
GetHelpURL (inherited from MemberDescriptor) | Gets the URL for the Help file specified in the HelpAttribute.
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | Retrieves the current value of the property on component, invoking the getXXX method. An exception in the getXXX method will pass through.
ResetValue | Will reset the default value for this property on the component. If there was a default value passed in as a DefaultValueAttribute, that value will be set as the value of the property on the component. If there was no default value passed in, a ResetXXX method will be looked for. If one is found, it will be invoked. If one is not found, this is a nop.
SetValue | This will set value to be the new value of this property on the component by invoking the setXXX method on the component. If the value specified is invalid, the component should throw an exception which will be passed up. The component designer should design the property so that getXXX following a setXXX should return the value passed in if no exception was thrown in the setXXX call.
ShouldPersistValue | Indicates whether the value of this property needs to be persisted. In other words, it indicates whether the state of the property is distinct from when the component is first instantiated. If there is a default value specified in this PropertyDescriptor, it will be compared against the property's current value to determine this. If there is't, the shouldPersistXXX method is looked for and invoked if found. If both these routes fail, true will be returned. If this returns false, a tool should not persist this property's value.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

CreateAttributeCollection (inherited from MemberDescriptor) | Creates a collection of attributes using the array of attributes that you passed to the constructor.
CreateInstance (inherited from PropertyDescriptor) | Creates an instance of the specified type.
FillAttributes (inherited from MemberDescriptor) | In an inheriting class, adds the attributes of the inheriting class to the specified list of attributes in the parent class.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InheritedPropertyDescriptor Class | System.ComponentModel.Design Namespace


InheritedPropertyDescriptor.CanResetValue

Indicates whether reset will change the value of the component. If there is a DefaultValueAttribute, then this will return true if getValue returns something different than the default value. If there is a reset method and a shouldPersist method, this will return what shouldPersist returns. If there is just a reset method, this always returns true. If none of these cases apply, this returns false.

[Visual Basic]
Overrides Public Function CanResetValue( _
   ByVal component As Object _
) As Boolean
[C#]
public override bool CanResetValue(
   object component
);
[C++]
public: override bool CanResetValue(
   Object* component
);
[JScript]
public override function CanResetValue(
   component : Object
) : Boolean;

Parameters

component
The component who's property's value we should test for resetability.

See Also

InheritedPropertyDescriptor Class | InheritedPropertyDescriptor Members | System.ComponentModel.Design Namespace | PropertyDescriptor


InheritedPropertyDescriptor.GetValue

Retrieves the current value of the property on component, invoking the getXXX method. An exception in the getXXX method will pass through.

[Visual Basic]
Overrides Public Function GetValue( _
   ByVal component As Object _
) As Object
[C#]
public override object GetValue(
   object component
);
[C++]
public: override Object* GetValue(
   Object* component
);
[JScript]
public override function GetValue(
   component : Object
) : Object;

Parameters

component
The component who's property's value will be retrieved.

Return Value

the value of the property for the given component.

See Also

InheritedPropertyDescriptor Class | InheritedPropertyDescriptor Members | System.ComponentModel.Design Namespace


InheritedPropertyDescriptor.ResetValue

Will reset the default value for this property on the component. If there was a default value passed in as a DefaultValueAttribute, that value will be set as the value of the property on the component. If there was no default value passed in, a ResetXXX method will be looked for. If one is found, it will be invoked. If one is not found, this is a nop.

[Visual Basic]
Overrides Public Sub ResetValue( _
   ByVal component As Object _
)
[C#]
public override void ResetValue(
   object component
);
[C++]
public: override void ResetValue(
   Object* component
);
[JScript]
public override function ResetValue(
   component : Object
);

Parameters

component
The component who's property's value should be reset.

See Also

InheritedPropertyDescriptor Class | InheritedPropertyDescriptor Members | System.ComponentModel.Design Namespace | PropertyDescriptor


InheritedPropertyDescriptor.SetValue

This will set value to be the new value of this property on the component by invoking the setXXX method on the component. If the value specified is invalid, the component should throw an exception which will be passed up. The component designer should design the property so that getXXX following a setXXX should return the value passed in if no exception was thrown in the setXXX call.

[Visual Basic]
Overrides Public Sub SetValue( _
   ByVal component As Object, _
   ByVal value As Object _
)
[C#]
public override void SetValue(
   object component,
   object value
);
[C++]
public: override void SetValue(
   Object* component,
   Object* value
);
[JScript]
public override function SetValue(
   component : Object,
   value : Object
);

Parameters

component
The component to set the property's value on.
value
The new value for the property on the component.

See Also

InheritedPropertyDescriptor Class | InheritedPropertyDescriptor Members | System.ComponentModel.Design Namespace | PropertyDescriptor


InheritedPropertyDescriptor.ShouldPersistValue

Indicates whether the value of this property needs to be persisted. In other words, it indicates whether the state of the property is distinct from when the component is first instantiated. If there is a default value specified in this PropertyDescriptor, it will be compared against the property's current value to determine this. If there is't, the shouldPersistXXX method is looked for and invoked if found. If both these routes fail, true will be returned. If this returns false, a tool should not persist this property's value.

[Visual Basic]
Overrides Public Function ShouldPersistValue( _
   ByVal component As Object _
) As Boolean
[C#]
public override bool ShouldPersistValue(
   object component
);
[C++]
public: override bool ShouldPersistValue(
   Object* component
);
[JScript]
public override function ShouldPersistValue(
   component : Object
) : Boolean;

Parameters

component
who's property should be examined for persistance.

Return Value

whether the property should be persisted.

See Also

InheritedPropertyDescriptor Class | InheritedPropertyDescriptor Members | System.ComponentModel.Design Namespace


IntegerEditor Class

[To be supplied.]

Object
ValueEditor
WinFormValueEditor
IntegerEditor

[Visual Basic]
Public Class IntegerEditor
   Inherits WinFormValueEditor
[C#]
public class IntegerEditor : WinFormValueEditor
[C++]
public __gc class IntegerEditor : public WinFormValueEditor
[JScript]
public class IntegerEditor extends WinFormValueEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

IntegerEditor Members | System.ComponentModel.Design Namespace


IntegerEditor Members

Public:

Constructor

IntegerEditor Constructor [To be supplied.]

Properties

Style (inherited from ValueEditor) | [To be supplied.]
Values (inherited from ValueEditor) | [To be supplied.]

Methods

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from ValueEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue (inherited from ValueEditor) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from WinFormValueEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
PaintValue (inherited from WinFormValueEditor) | Paints a representation of the given value in the given Rectangle of the given Graphics. This method will only be called if the value editor specifies the StylePaintValue style.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IntegerEditor Class | System.ComponentModel.Design Namespace


IntegerEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public IntegerEditor();
[C++]
public: IntegerEditor();
[JScript]
public function IntegerEditor();

See Also

IntegerEditor Class | IntegerEditor Members | System.ComponentModel.Design Namespace


IReferenceService Interface

Provides an interface to get names and references to objects. These methods can search using the specified name or reference.

IReferenceService

[Visual Basic]
Public Interface IReferenceService
[C#]
public interface IReferenceService
[C++]
public __gc __interface IReferenceService

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

IReferenceService Members | System.ComponentModel.Design Namespace


IReferenceService Members

Methods

GetComponent | Gets the base component that anchors this reference.
GetName | Gets the name for this reference.
GetReference | Gets a reference for the specified name.
GetReferences | Overloaded. Gets all available references.

See Also

IReferenceService Interface | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IReferenceService Methods

The methods of the IReferenceService interface are listed below. For a complete list of IReferenceService interface members, see the IReferenceService Members topic.

GetComponent | Gets the base component that anchors this reference.
GetName | Gets the name for this reference.
GetReference | Gets a reference for the specified name.
GetReferences | Overloaded. Gets all available references.

See Also

IReferenceService Interface | System.ComponentModel.Design Namespace


IReferenceService.GetComponent

Gets the base component that anchors this reference.

[Visual Basic]
Function GetComponent( _
   ByVal reference As Object _
) As IComponent
[C#]
IComponent GetComponent(
   object reference
);
[C++]
IComponent* GetComponent(
   Object* reference
) = 0;
[JScript]
function GetComponent(
   reference : Object
) : IComponent;

Parameters

reference
The referent to return the component associated with.

Return Value

The IComponent underlying the reference specified.

See Also

IReferenceService Interface | IReferenceService Members | System.ComponentModel.Design Namespace


IReferenceService.GetName

Gets the name for this reference.

[Visual Basic]
Function GetName( _
   ByVal reference As Object _
) As String
[C#]
string GetName(
   object reference
);
[C++]
String* GetName(
   Object* reference
) = 0;
[JScript]
function GetName(
   reference : Object
) : String;

Parameters

reference
The reference to return the name for.

Return Value

The name of the object referenced, or a null reference (in Visual Basic Nothing) if this is not a valid reference.

See Also

IReferenceService Interface | IReferenceService Members | System.ComponentModel.Design Namespace


IReferenceService.GetReference

Gets a reference for the specified name.

[Visual Basic]
Function GetReference( _
   ByVal name As String _
) As Object
[C#]
object GetReference(
   string name
);
[C++]
Object* GetReference(
   String* name
) = 0;
[JScript]
function GetReference(
   name : String
) : Object;

Parameters

name
The name of the component to return the reference for.

Return Value

An object the name specified refers to, or a null reference (in Visual Basic Nothing) if no reference is found.

See Also

IReferenceService Interface | IReferenceService Members | System.ComponentModel.Design Namespace


IReferenceService.GetReferences

Gets all available references.

Overload List

Gets all available references of this type.

[Visual Basic] Overloads Function GetReferences(Type) As Object ()
[C#] object[] GetReferences(Type);
[C++] Object* GetReferences(Type*) [] = 0;
[JScript] function GetReferences(Type) : Object[];

Gets all available references.

[Visual Basic] Overloads Function GetReferences() As Object ()
[C#] object[] GetReferences();
[C++] Object* GetReferences() [] = 0;
[JScript] function GetReferences() : Object[];

See Also

IReferenceService Interface | IReferenceService Members | System.ComponentModel.Design Namespace


IReferenceService.GetReferences (Type)

Gets all available references of this type.

[Visual Basic]
Overloads Function GetReferences( _
   ByVal baseType As Type _
) As Object ()
[C#]
object[] GetReferences(
   Type baseType
);
[C++]
Object* GetReferences(
   Type* baseType
) [] = 0;
[JScript]
function GetReferences(
   baseType : Type
) : Object[];

Parameters

baseType
The type to filter by.

Return Value

An array of all available objects of the specified type.

See Also

IReferenceService Interface | IReferenceService Members | System.ComponentModel.Design Namespace | IReferenceService.GetReferences Overload List


IReferenceService.GetReferences ()

Gets all available references.

[Visual Basic]
Overloads Function GetReferences() As Object ()
[C#]
object[] GetReferences();
[C++]
Object* GetReferences() [] = 0;
[JScript]
function GetReferences() : Object[];

Return Value

An array of all objects with references available to the IReferenceService.

See Also

IReferenceService Interface | IReferenceService Members | System.ComponentModel.Design Namespace | IReferenceService.GetReferences Overload List


ISelectionService Interface

Provides an interface for a designer to select components.

ISelectionService

[Visual Basic]
Public Interface ISelectionService
[C#]
public interface ISelectionService
[C++]
public __gc __interface ISelectionService

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

Selecting a component allows the component's properties to be shown in the property browser.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

ISelectionService Members | System.ComponentModel.Design Namespace


ISelectionService Members

Methods

GetComponentSelected | Gets whether the component is currently selected.
GetContainerSelected | Gets whether the specified component is the currently selected container.
GetPrimarySelection | Gets the object that is currently the primary selection.
GetSelectedComponents | Gets an array of components that are currently part of the user's selection.
GetSelectionCount | Gets the count of selected objects.
SetContainerSelected | Changes the container selection status of the given component.
SetSelectedComponents | Overloaded. Sets the currently selected set of components.

Events

SelectionChanged | Occurs when the user changes the current list of selected components in the designer.
SelectionChanging | Occurs when the user changes the current list of selected components in the designer. This event is raised before the actual selection changes.

Event Hookup:

Methods

AddOnSelectionChanged | Adds a System.ComponentModel.Design.ISelectionService.SelectionChanged event handler to the selection service.
AddOnSelectionChanging | Adds an event handler to the selection service.
RemoveOnSelectionChanged | Removes a selection changed event handler from the selection service.
RemoveOnSelectionChanging | Removes a selection changing event handler from the selection service.

See Also

ISelectionService Interface | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ISelectionService Methods

The methods of the ISelectionService interface are listed below. For a complete list of ISelectionService interface members, see the ISelectionService Members topic.

GetComponentSelected | Gets whether the component is currently selected.
GetContainerSelected | Gets whether the specified component is the currently selected container.
GetPrimarySelection | Gets the object that is currently the primary selection.
GetSelectedComponents | Gets an array of components that are currently part of the user's selection.
GetSelectionCount | Gets the count of selected objects.
SetContainerSelected | Changes the container selection status of the given component.
SetSelectedComponents | Overloaded. Sets the currently selected set of components.

Event Hookup:

AddOnSelectionChanged | Adds a System.ComponentModel.Design.ISelectionService.SelectionChanged event handler to the selection service.
AddOnSelectionChanging | Adds an event handler to the selection service.
RemoveOnSelectionChanged | Removes a selection changed event handler from the selection service.
RemoveOnSelectionChanging | Removes a selection changing event handler from the selection service.

See Also

ISelectionService Interface | System.ComponentModel.Design Namespace


ISelectionService.AddOnSelectionChanged

Adds a System.ComponentModel.Design.ISelectionService.SelectionChanged event handler to the selection service.

[Visual Basic]
Sub AddOnSelectionChanged( _
   ByVal handler As EventHandler _
)
[C#]
void AddOnSelectionChanged(
   EventHandler handler
);
[C++]
void AddOnSelectionChanged(
   EventHandler* handler
) = 0;
[JScript]
function AddOnSelectionChanged(
   handler : EventHandler
);

Parameters

handler
An EventHandler that will be called whenever the current selection changes. The sender parameter of the event will be a reference to the ISelectionService.

Remarks

Keep processing to a minimum during this event, as this can affect the overall performance of the form designer.

See Also

ISelectionService Interface | ISelectionService Members | System.ComponentModel.Design Namespace | EventHandler | RemoveOnSelectionChanged


ISelectionService.AddOnSelectionChanging

Adds an event handler to the selection service.

[Visual Basic]
Sub AddOnSelectionChanging( _
   ByVal handler As EventHandler _
)
[C#]
void AddOnSelectionChanging(
   EventHandler handler
);
[C++]
void AddOnSelectionChanging(
   EventHandler* handler
) = 0;
[JScript]
function AddOnSelectionChanging(
   handler : EventHandler
);

Parameters

handler
An EventHandler that will be called when the current selection is about to change. The sender parameter of the event will be a reference to the ISelectionService.

Remarks

Keep processing to a minimum during this event, as this can affect the overall performance of the form designer.

See Also

ISelectionService Interface | ISelectionService Members | System.ComponentModel.Design Namespace | EventHandler | RemoveOnSelectionChanging


ISelectionService.GetComponentSelected

Gets whether the component is currently selected.

[Visual Basic]
Function GetComponentSelected( _
   ByVal component As Object _
) As Boolean
[C#]
bool GetComponentSelected(
   object component
);
[C++]
bool GetComponentSelected(
   Object* component
) = 0;
[JScript]
function GetComponentSelected(
   component : Object
) : Boolean;

Parameters

component
The component to test.

Return Value

true if the component is part of the user's current selection; otherwise, false.

Remarks

Using this method is faster than getting the entire list of selelected components.

See Also

ISelectionService Interface | ISelectionService Members | System.ComponentModel.Design Namespace


ISelectionService.GetContainerSelected

Gets whether the specified component is the currently selected container.

[Visual Basic]
Function GetContainerSelected( _
   ByVal component As Object _
) As Boolean
[C#]
bool GetContainerSelected(
   object component
);
[C++]
bool GetContainerSelected(
   Object* component
) = 0;
[JScript]
function GetContainerSelected(
   component : Object
) : Boolean;

Parameters

component
The component to test.

Return Value

true if the component is part of the user's current container selection; otherwise, false.

Remarks

Container selection is a visual aid for selecting containers. It doesn't affect the normal component selection.

See Also

ISelectionService Interface | ISelectionService Members | System.ComponentModel.Design Namespace


ISelectionService.GetPrimarySelection

Gets the object that is currently the primary selection.

[Visual Basic]
Function GetPrimarySelection() As Object
[C#]
object GetPrimarySelection();
[C++]
Object* GetPrimarySelection() = 0;
[JScript]
function GetPrimarySelection() : Object;

Return Value

The primary selection.

Remarks

The primary selection has a slightly different UI look and is used as a "key" when an operation is to be done on multiple components.

See Also

ISelectionService Interface | ISelectionService Members | System.ComponentModel.Design Namespace


ISelectionService.GetSelectedComponents

Gets an array of components that are currently part of the user's selection.

[Visual Basic]
Function GetSelectedComponents() As Object ()
[C#]
object[] GetSelectedComponents();
[C++]
Object* GetSelectedComponents() [] = 0;
[JScript]
function GetSelectedComponents() : Object[];

Return Value

An array of type IComponent that represents the current set of components the user has selected.

See Also

ISelectionService Interface | ISelectionService Members | System.ComponentModel.Design Namespace


ISelectionService.GetSelectionCount

Gets the count of selected objects.

[Visual Basic]
Function GetSelectionCount() As Integer
[C#]
int GetSelectionCount();
[C++]
int GetSelectionCount() = 0;
[JScript]
function GetSelectionCount() : int;

Return Value

A count of selected objects.

See Also

ISelectionService Interface | ISelectionService Members | System.ComponentModel.Design Namespace


ISelectionService.RemoveOnSelectionChanged

Removes a selection changed event handler from the selection service.

[Visual Basic]
Sub RemoveOnSelectionChanged( _
   ByVal handler As EventHandler _
)
[C#]
void RemoveOnSelectionChanged(
   EventHandler handler
);
[C++]
void RemoveOnSelectionChanged(
   EventHandler* handler
) = 0;
[JScript]
function RemoveOnSelectionChanged(
   handler : EventHandler
);

Parameters

handler
An EventHandler that is to be removed from the selection changed event.

Remarks

A selection changed event will fire every time the user changes the current list of selected components.

See Also

ISelectionService Interface | ISelectionService Members | System.ComponentModel.Design Namespace


ISelectionService.RemoveOnSelectionChanging

Removes a selection changing event handler from the selection service.

[Visual Basic]
Sub RemoveOnSelectionChanging( _
   ByVal handler As EventHandler _
)
[C#]
void RemoveOnSelectionChanging(
   EventHandler handler
);
[C++]
void RemoveOnSelectionChanging(
   EventHandler* handler
) = 0;
[JScript]
function RemoveOnSelectionChanging(
   handler : EventHandler
);

Parameters

handler
An EventHandler that is to be removed from the selection changing event.

Remarks

A selection changing event will fire every time the user changes the current list of selected components.

See Also

ISelectionService Interface | ISelectionService Members | System.ComponentModel.Design Namespace


ISelectionService.SetContainerSelected

Changes the container selection status of the given component.

[Visual Basic]
Sub SetContainerSelected( _
   ByVal component As Object, _
   ByVal selected As Boolean _
)
[C#]
void SetContainerSelected(
   object component,
   bool selected
);
[C++]
void SetContainerSelected(
   Object* component,
   bool selected
) = 0;
[JScript]
function SetContainerSelected(
   component : Object,
   selected : Boolean
);

Parameters

component
The component to modify the container selection status of.
selected
true to set the component to become the selected container; false to be unselected.

Remarks

Container selection is a visual aid for selecting containers. It doesn't affect the normal component selection.

See Also

ISelectionService Interface | ISelectionService Members | System.ComponentModel.Design Namespace


ISelectionService.SetSelectedComponents

Sets the currently selected set of components.

Overload List

Sets the currently selected set of components to those with the specified selection type within the specified array of components.

[Visual Basic] Overloads Sub SetSelectedComponents(Object(), SelectionTypes)
[C#] void SetSelectedComponents(Object[], SelectionTypes);
[C++] void SetSelectedComponents(Object*[], SelectionTypes) = 0;
[JScript] function SetSelectedComponents(Object[], SelectionTypes);

Sets the currently selected set of components.

[Visual Basic] Overloads Sub SetSelectedComponents(Object())
[C#] void SetSelectedComponents(Object[]);
[C++] void SetSelectedComponents(Object*[]) = 0;
[JScript] function SetSelectedComponents(Object[]);

See Also

ISelectionService Interface | ISelectionService Members | System.ComponentModel.Design Namespace


ISelectionService.SetSelectedComponents (Object[], SelectionTypes)

Sets the currently selected set of components to those with the specified selection type within the specified array of components.

[Visual Basic]
Overloads Sub SetSelectedComponents( _
   ByVal components() As Object, _
   ByVal selectionType As SelectionTypes _
)
[C#]
void SetSelectedComponents(
   object[] components,
   SelectionTypes selectionType
);
[C++]
void SetSelectedComponents(
   Object* components[],
   SelectionTypes selectionType
) = 0;
[JScript]
function SetSelectedComponents(
   components : Object[],
   selectionType : SelectionTypes
);

Parameters

components
The array of components to select.
selectionType
A value from the SelectionType enum. The default is System.ComponentModel.Design.SelectionTypes.NORMAL.

Remarks

If the array is a null reference (in Visual Basic Nothing) or doesn't contain any components, SetSelectedComponents will select the top level component in the designer.

See Also

ISelectionService Interface | ISelectionService Members | System.ComponentModel.Design Namespace | ISelectionService.SetSelectedComponents Overload List | System.ComponentModel.Design.SelectionType


ISelectionService.SetSelectedComponents (Object[])

Sets the currently selected set of components.

[Visual Basic]
Overloads Sub SetSelectedComponents( _
   ByVal components() As Object _
)
[C#]
void SetSelectedComponents(
   object[] components
);
[C++]
void SetSelectedComponents(
   Object* components[]
) = 0;
[JScript]
function SetSelectedComponents(
   components : Object[]
);

Parameters

components
The array of components to select.

Remarks

If the array is a null reference (in Visual Basic Nothing) or doesn't contain any components, SetSelectedComponents will select the top level component in the designer.

See Also

ISelectionService Interface | ISelectionService Members | System.ComponentModel.Design Namespace | ISelectionService.SetSelectedComponents Overload List


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ISelectionService Events

The events of the ISelectionService interface are listed below. For a complete list of ISelectionService interface members, see the ISelectionService Members topic.

SelectionChanged | Occurs when the user changes the current list of selected components in the designer.
SelectionChanging | Occurs when the user changes the current list of selected components in the designer. This event is raised before the actual selection changes.

See Also

ISelectionService Interface | System.ComponentModel.Design Namespace


ISelectionService SelectionChanged Event

Occurs when the user changes the current list of selected components in the designer.

The following declaration shows the syntax for a method that handles the SelectionChanged event.

[Visual Basic]
Private Sub ISelectionServiceName_SelectionChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
private void ISelectionServiceName_SelectionChanged(
   object sender,
   EventArgs e
);
[C++]
private: void ISelectionServiceName_SelectionChanged(
   Object* sender,
   EventArgs* e
);
[JScript]
private ISelectionServiceName_SelectionChanged(
   sender : Object,
   e : EventArgs
);

Parameters

sender
The source of the event.
e
An EventArgs that contains the event data. The following EventArgs properties provide information specific to this event.
Property Description
ExtendedInfo
Holds a reference to an object that manages the event's state.

Remarks

A selection changed event will occur every time the user changes the current list of selected components in the designer.

See Also

ISelectionService Interface | ISelectionService MembersTopic | System.ComponentModel.Design Namespace


ISelectionService SelectionChanging Event

Occurs when the user changes the current list of selected components in the designer. This event is raised before the actual selection changes.

The following declaration shows the syntax for a method that handles the SelectionChanging event.

[Visual Basic]
Private Sub ISelectionServiceName_SelectionChanging( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
private void ISelectionServiceName_SelectionChanging(
   object sender,
   EventArgs e
);
[C++]
private: void ISelectionServiceName_SelectionChanging(
   Object* sender,
   EventArgs* e
);
[JScript]
private ISelectionServiceName_SelectionChanging(
   sender : Object,
   e : EventArgs
);

Parameters

sender
The source of the event.
e
An EventArgs that contains the event data. The following EventArgs properties provide information specific to this event.
Property Description
ExtendedInfo
Holds a reference to an object that manages the event's state.

Remarks

A selection changing event will occur every time the user changes the current list of selected components in the designer.

See Also

ISelectionService Interface | ISelectionService MembersTopic | System.ComponentModel.Design Namespace


ITestCommandService Interface

The test command interface allows various test commands to be added to the designer.

ITestCommandService

[Visual Basic]
Public Interface ITestCommandService
[C#]
public interface ITestCommandService
[C++]
public __gc __interface ITestCommandService

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

ITestCommandService Members | System.ComponentModel.Design Namespace


ITestCommandService Members

Methods

AddCommand | Adds a test command with the specified name and description to the service.
GetCommand | Gets the command matching the specified name, if recognized by the service.
RemoveCommand | Removes a command from the service.

See Also

ITestCommandService Interface | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ITestCommandService Methods

The methods of the ITestCommandService interface are listed below. For a complete list of ITestCommandService interface members, see the ITestCommandService Members topic.

AddCommand | Adds a test command with the specified name and description to the service.
GetCommand | Gets the command matching the specified name, if recognized by the service.
RemoveCommand | Removes a command from the service.

See Also

ITestCommandService Interface | System.ComponentModel.Design Namespace


ITestCommandService.AddCommand

Adds a test command with the specified name and description to the service.

[Visual Basic]
Sub AddCommand( _
   ByVal name As String, _
   ByVal command As TestCommand, _
   ByVal description As String _
)
[C#]
void AddCommand(
   string name,
   TestCommand command,
   string description
);
[C++]
void AddCommand(
   String* name,
   TestCommand* command,
   String* description
) = 0;
[JScript]
function AddCommand(
   name : String,
   command : TestCommand,
   description : String
);

Parameters

name
The name for the command.
command
The command to add.
description
A description of the command.

See Also

ITestCommandService Interface | ITestCommandService Members | System.ComponentModel.Design Namespace


ITestCommandService.GetCommand

Gets the command matching the specified name, if recognized by the service.

[Visual Basic]
Function GetCommand( _
   ByVal name As String _
) As TestCommand
[C#]
TestCommand GetCommand(
   string name
);
[C++]
TestCommand* GetCommand(
   String* name
) = 0;
[JScript]
function GetCommand(
   name : String
) : TestCommand;

Parameters

name
The name of the command to retrieve.

Return Value

The command listed with the specified name.

See Also

ITestCommandService Interface | ITestCommandService Members | System.ComponentModel.Design Namespace


ITestCommandService.RemoveCommand

Removes a command from the service.

[Visual Basic]
Sub RemoveCommand( _
   ByVal name As String _
)
[C#]
void RemoveCommand(
   string name
);
[C++]
void RemoveCommand(
   String* name
) = 0;
[JScript]
function RemoveCommand(
   name : String
);

Parameters

name
The name of the command to remove.

See Also

ITestCommandService Interface | ITestCommandService Members | System.ComponentModel.Design Namespace


ITypeDescriptorFilterService Interface

Modifies the set of type descriptors that a component provides.

ITypeDescriptorFilterService

[Visual Basic]
Public Interface ITypeDescriptorFilterService
[C#]
public interface ITypeDescriptorFilterService
[C++]
public __gc __interface ITypeDescriptorFilterService

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

The type descriptor will query a component's site for this service before providing properties, attributes, and events. This provides a way for the container to modify the set of descriptors that a component provides.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

ITypeDescriptorFilterService Members | System.ComponentModel.Design Namespace


ITypeDescriptorFilterService Members

Methods

FilterAttributes | Provides a way to filter the attributes from a component that are displayed to the user.
FilterEvents | Provides a way to filter the events from a component that are displayed to the user.
FilterProperties | Provides a way to filter the properties from a component that are displayed to the user.

See Also

ITypeDescriptorFilterService Interface | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ITypeDescriptorFilterService Methods

The methods of the ITypeDescriptorFilterService interface are listed below. For a complete list of ITypeDescriptorFilterService interface members, see the ITypeDescriptorFilterService Members topic.

FilterAttributes | Provides a way to filter the attributes from a component that are displayed to the user.
FilterEvents | Provides a way to filter the events from a component that are displayed to the user.
FilterProperties | Provides a way to filter the properties from a component that are displayed to the user.

See Also

ITypeDescriptorFilterService Interface | System.ComponentModel.Design Namespace


ITypeDescriptorFilterService.FilterAttributes

Provides a way to filter the attributes from a component that are displayed to the user.

[Visual Basic]
Function FilterAttributes( _
   ByVal component As IComponent, _
   ByVal attributes As IDictionary _
) As Boolean
[C#]
bool FilterAttributes(
   IComponent component,
   IDictionary attributes
);
[C++]
bool FilterAttributes(
   IComponent* component,
   IDictionary* attributes
) = 0;
[JScript]
function FilterAttributes(
   component : IComponent,
   attributes : IDictionary
) : Boolean;

Parameters

component
The component to filter attributes for.
attributes
A dictionary of attributes. Modifications to this dictionary may be made in place.

Return Value

The service should return true if the resulting set of filtered attributes can be cached; false if the filter service should be re-queried.

Remarks

This method is called when a user requests a set of attributes for a component. The attributes will be added to the dictionary with the attribute type ID as the keys. Implementers of this service may make changes, add, or remove attributes in the dictionary.

Notes to Implementers: Return false only when absolutely necessary, as it impacts performance.

See Also

ITypeDescriptorFilterService Interface | ITypeDescriptorFilterService Members | System.ComponentModel.Design Namespace


ITypeDescriptorFilterService.FilterEvents

Provides a way to filter the events from a component that are displayed to the user.

[Visual Basic]
Function FilterEvents( _
   ByVal component As IComponent, _
   ByVal events As IDictionary _
) As Boolean
[C#]
bool FilterEvents(
   IComponent component,
   IDictionary events
);
[C++]
bool FilterEvents(
   IComponent* component,
   IDictionary* events
) = 0;
[JScript]
function FilterEvents(
   component : IComponent,
   events : IDictionary
) : Boolean;

Parameters

component
The component to filter events for.
events
A dictionary of events. Modifications to this dictionary may be made in place.

Return Value

The service should return true if the resulting set of filtered events can be cached; false if the filter service should be re-queried.

Remarks

This method is called when a user requests a set of events for a component. The events will be added to the dictionary with the event names as the keys. Implementers of this service may make changes, add, or remove events in the dictionary.

Notes to Implementers: Return false only when absolutely necessary, as it impacts performance.

See Also

ITypeDescriptorFilterService Interface | ITypeDescriptorFilterService Members | System.ComponentModel.Design Namespace


ITypeDescriptorFilterService.FilterProperties

Provides a way to filter the properties from a component that are displayed to the user.

[Visual Basic]
Function FilterProperties( _
   ByVal component As IComponent, _
   ByVal properties As IDictionary _
) As Boolean
[C#]
bool FilterProperties(
   IComponent component,
   IDictionary properties
);
[C++]
bool FilterProperties(
   IComponent* component,
   IDictionary* properties
) = 0;
[JScript]
function FilterProperties(
   component : IComponent,
   properties : IDictionary
) : Boolean;

Parameters

component
The component to filter properties for.
properties
A dictionary of properties. Modifications to this dictionary may be made in place.

Return Value

The service should return true if the resulting set of filtered properties can be cached; false if the filter service should be re-queried.

Remarks

This method is called when a user requests a set of properties for a component. The properties will be added to the dictionary with the property names as the keys. Implementers of this service may make changes, add, or remove properties in the dictionary.

Notes to Implementers: Return false only when absolutely necessary, as it impacts performance.

See Also

ITypeDescriptorFilterService Interface | ITypeDescriptorFilterService Members | System.ComponentModel.Design Namespace


IUIActivationService Interface

Service that adds and removes event handlers when a UI component's activation state is switched after selection or deselection.

IUIActivationService

[Visual Basic]
Public Interface IUIActivationService
[C#]
public interface IUIActivationService
[C++]
public __gc __interface IUIActivationService

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

IUIActivationService Members | System.ComponentModel.Design Namespace


IUIActivationService Members

Methods

DeactivateUIActive | Transitions any currently UI active designer from UI active mode to normal selected or unselected mode, as appropriate.
RequestUIActivate | Requests that a designer be placed into UI active design mode. A designer can be placed into UI active mode only if the associated component is the only item selected. This method should be called by the designer.

Events

UIActivated | [To be supplied.]
UIDeactivated | [To be supplied.]

Event Hookup:

Methods

AddOnUIActivated | Adds a Delegate that will be invoked when a component has been set to UI active state. On invocation, the UIActivationStateEventArgs.component variable holds a reference to the component that has been transitioned.
AddOnUIDeactivated | Adds a Delegate that will be invoked when a component has been moved out of UI active state. On invocation, the UIActivationStateEventArgs.component variable holds a reference to the component that has been transitioned.
RemoveOnUIActivated | Removes a Delegate that will be invoked when a component has been sent to UI active state. On invocation, the UIActivationStateEventArgs.component variable holds a reference to the component that has been transitioned.
RemoveOnUIDeactivated | Removes a Delegate that will be invoked when a component has been moved out of UI active state. On invocation, the UIActivationStateEventArgs.component variable holds a reference to the component that has been transitioned.

See Also

IUIActivationService Interface | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IUIActivationService Methods

The methods of the IUIActivationService interface are listed below. For a complete list of IUIActivationService interface members, see the IUIActivationService Members topic.

DeactivateUIActive | Transitions any currently UI active designer from UI active mode to normal selected or unselected mode, as appropriate.
RequestUIActivate | Requests that a designer be placed into UI active design mode. A designer can be placed into UI active mode only if the associated component is the only item selected. This method should be called by the designer.

Event Hookup:

AddOnUIActivated | Adds a Delegate that will be invoked when a component has been set to UI active state. On invocation, the UIActivationStateEventArgs.component variable holds a reference to the component that has been transitioned.
AddOnUIDeactivated | Adds a Delegate that will be invoked when a component has been moved out of UI active state. On invocation, the UIActivationStateEventArgs.component variable holds a reference to the component that has been transitioned.
RemoveOnUIActivated | Removes a Delegate that will be invoked when a component has been sent to UI active state. On invocation, the UIActivationStateEventArgs.component variable holds a reference to the component that has been transitioned.
RemoveOnUIDeactivated | Removes a Delegate that will be invoked when a component has been moved out of UI active state. On invocation, the UIActivationStateEventArgs.component variable holds a reference to the component that has been transitioned.

See Also

IUIActivationService Interface | System.ComponentModel.Design Namespace


IUIActivationService.AddOnUIActivated

Adds a Delegate that will be invoked when a component has been set to UI active state. On invocation, the UIActivationStateEventArgs.component variable holds a reference to the component that has been transitioned.

[Visual Basic]
Sub AddOnUIActivated( _
   ByVal handler As UIActivationStateEventHandler _
)
[C#]
void AddOnUIActivated(
   UIActivationStateEventHandler handler
);
[C++]
void AddOnUIActivated(
   UIActivationStateEventHandler* handler
) = 0;
[JScript]
function AddOnUIActivated(
   handler : UIActivationStateEventHandler
);

Parameters

handler
A UIActivationStateEventHandler to be invoked when a component is transitioned to UI active mode.

See Also

IUIActivationService Interface | IUIActivationService Members | System.ComponentModel.Design Namespace


IUIActivationService.AddOnUIDeactivated

Adds a Delegate that will be invoked when a component has been moved out of UI active state. On invocation, the UIActivationStateEventArgs.component variable holds a reference to the component that has been transitioned.

[Visual Basic]
Sub AddOnUIDeactivated( _
   ByVal handler As UIActivationStateEventHandler _
)
[C#]
void AddOnUIDeactivated(
   UIActivationStateEventHandler handler
);
[C++]
void AddOnUIDeactivated(
   UIActivationStateEventHandler* handler
) = 0;
[JScript]
function AddOnUIDeactivated(
   handler : UIActivationStateEventHandler
);

Parameters

handler
A UIActivationStateEventHandler to be invoked when a component is transitioned from UI active mode.

See Also

IUIActivationService Interface | IUIActivationService Members | System.ComponentModel.Design Namespace


IUIActivationService.DeactivateUIActive

Transitions any currently UI active designer from UI active mode to normal selected or unselected mode, as appropriate.

[Visual Basic]
Function DeactivateUIActive() As Boolean
[C#]
bool DeactivateUIActive();
[C++]
bool DeactivateUIActive() = 0;
[JScript]
function DeactivateUIActive() : Boolean;

Return Value

true if successful; false if no designer was in UI active mode.

See Also

IUIActivationService Interface | IUIActivationService Members | System.ComponentModel.Design Namespace


IUIActivationService.RemoveOnUIActivated

Removes a Delegate that will be invoked when a component has been sent to UI active state. On invocation, the UIActivationStateEventArgs.component variable holds a reference to the component that has been transitioned.

[Visual Basic]
Sub RemoveOnUIActivated( _
   ByVal handler As UIActivationStateEventHandler _
)
[C#]
void RemoveOnUIActivated(
   UIActivationStateEventHandler handler
);
[C++]
void RemoveOnUIActivated(
   UIActivationStateEventHandler* handler
) = 0;
[JScript]
function RemoveOnUIActivated(
   handler : UIActivationStateEventHandler
);

Parameters

handler
A UIActivationStateEventHandler to be invoked when a component is transitioned to UI active mode.

See Also

IUIActivationService Interface | IUIActivationService Members | System.ComponentModel.Design Namespace


IUIActivationService.RemoveOnUIDeactivated

Removes a Delegate that will be invoked when a component has been moved out of UI active state. On invocation, the UIActivationStateEventArgs.component variable holds a reference to the component that has been transitioned.

[Visual Basic]
Sub RemoveOnUIDeactivated( _
   ByVal handler As UIActivationStateEventHandler _
)
[C#]
void RemoveOnUIDeactivated(
   UIActivationStateEventHandler handler
);
[C++]
void RemoveOnUIDeactivated(
   UIActivationStateEventHandler* handler
) = 0;
[JScript]
function RemoveOnUIDeactivated(
   handler : UIActivationStateEventHandler
);

Parameters

handler
A UIActivationStateEventHandler to be invoked when a component is transitioned from UI active mode.

See Also

IUIActivationService Interface | IUIActivationService Members | System.ComponentModel.Design Namespace


IUIActivationService.RequestUIActivate

Requests that a designer be placed into UI active design mode. A designer can be placed into UI active mode only if the associated component is the only item selected. This method should be called by the designer.

[Visual Basic]
Function RequestUIActivate( _
   ByVal component As IComponent _
) As Boolean
[C#]
bool RequestUIActivate(
   IComponent component
);
[C++]
bool RequestUIActivate(
   IComponent* component
) = 0;
[JScript]
function RequestUIActivate(
   component : IComponent
) : Boolean;

Parameters

component
The component to UI activate.

Return Value

true if the activation was successful, otherwise false.

See Also

IUIActivationService Interface | IUIActivationService Members | System.ComponentModel.Design Namespace


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IUIActivationService Events

The events of the IUIActivationService interface are listed below. For a complete list of IUIActivationService interface members, see the IUIActivationService Members topic.

UIActivated | [To be supplied.]
UIDeactivated | [To be supplied.]

See Also

IUIActivationService Interface | System.ComponentModel.Design Namespace


IUIActivationService UIActivated Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the UIActivated event.

[Visual Basic]
Private Sub IUIActivationServiceName_UIActivated( _
   ByVal sender As Object, _
   ByVal e As UIActivationStateEventArgs _
)
[C#]
private void IUIActivationServiceName_UIActivated(
   object sender,
   UIActivationStateEventArgs e
);
[C++]
private: void IUIActivationServiceName_UIActivated(
   Object* sender,
   UIActivationStateEventArgs* e
);
[JScript]
private IUIActivationServiceName_UIActivated(
   sender : Object,
   e : UIActivationStateEventArgs
);

Parameters

sender
The source of the event.
e
An UIActivationStateEventArgs that contains the event data. The following UIActivationStateEventArgs properties provide information specific to this event.
Property Description
Component
The component whose UI activation state is changing.

See Also

IUIActivationService Interface | IUIActivationService MembersTopic | System.ComponentModel.Design Namespace


IUIActivationService UIDeactivated Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the UIDeactivated event.

[Visual Basic]
Private Sub IUIActivationServiceName_UIDeactivated( _
   ByVal sender As Object, _
   ByVal e As UIActivationStateEventArgs _
)
[C#]
private void IUIActivationServiceName_UIDeactivated(
   object sender,
   UIActivationStateEventArgs e
);
[C++]
private: void IUIActivationServiceName_UIDeactivated(
   Object* sender,
   UIActivationStateEventArgs* e
);
[JScript]
private IUIActivationServiceName_UIDeactivated(
   sender : Object,
   e : UIActivationStateEventArgs
);

Parameters

sender
The source of the event.
e
An UIActivationStateEventArgs that contains the event data. The following UIActivationStateEventArgs properties provide information specific to this event.
Property Description
Component
The component whose UI activation state is changing.

See Also

IUIActivationService Interface | IUIActivationService MembersTopic | System.ComponentModel.Design Namespace


IUndoService Interface

Allows access to undo/redo functionality.

IUndoService

[Visual Basic]
Public Interface IUndoService
[C#]
public interface IUndoService
[C++]
public __gc __interface IUndoService

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

Undo actions are added to the service, and are automatically transformed to redo actions if they are undone. An instance of this service is provided for each document, so multiple undo/redo states can be maintained across the application.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

IUndoService Members | System.ComponentModel.Design Namespace | IActionUnit


IUndoService Members

Properties

Enabled | Gets or sets the current state of the current undo service.
RedoActionList | Gets or sets an array of type IActionUnit that contains the redo actions that represent actions that have been undone.
UndoActionList | Gets or sets an array of type IActionUnit that contains the undo actions that represent actions that have been undone.

Methods

AddAction | Overloaded. [To be supplied.]
CanAddAction | Gets whether the current action can be added to the IUndoService implementation.
DiscardRedoItems | Clears actions from the redo stack before and including the specified action.
DiscardUndoItems | Clears actions from the undo stack before and including the specified action.
RedoActions | Redoes the specified number of actions.
RedoActionsTo | Instructs the undo service to invoke redo actions down to and including action.
SetEnabledAutoReset | Enables or disables the current undo service.
UndoActions | Undoes the specified number of actions.
UndoActionsTo | Instructs the undo service to invoke undo actions down to and including the specified action.

Events

ActionAdded | [To be supplied.]
Redo | [To be supplied.]
Undo | [To be supplied.]

Event Hookup:

Methods

AddOnActionAdded | Adds an event handler to be invoked when a new action is added to the service.
AddOnRedo | Adds a handler to be invoked when an action is redone.
AddOnUndo | Adds a handler to be invoked when an action is undone.
RemoveOnActionAdded | Removes an event handler that would be invoked when a new action is added to the service.
RemoveOnRedo | Removes a handler to be invoked when an action is redone.
RemoveOnUndo | Removes a handler to be invoked when an action is undone.

See Also

IUndoService Interface | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IUndoService Properties

The properties of the IUndoService interface are listed below. For a complete list of IUndoService interface members, see the IUndoService Members topic.

Enabled | Gets or sets the current state of the current undo service.
RedoActionList | Gets or sets an array of type IActionUnit that contains the redo actions that represent actions that have been undone.
UndoActionList | Gets or sets an array of type IActionUnit that contains the undo actions that represent actions that have been undone.

See Also

IUndoService Interface | System.ComponentModel.Design Namespace


IUndoService.Enabled

Gets or sets the current state of the current undo service.

[Visual Basic]
Property Enabled As Boolean
[C#]
bool Enabled {get; set;}
[C++]
bool get_Enabled() = 0;void set_Enabled(bool) = 0;
[JScript]
abstract function get Enabled() : Boolean;
public abstract function set Enabled(Boolean);

Property Value

true if new actions can be added; otherwise, false.

Remarks

If enabled is set to false, any added actions are ignored.

See Also

IUndoService Interface | IUndoService Members | System.ComponentModel.Design Namespace


IUndoService.RedoActionList

Gets or sets an array of type IActionUnit that contains the redo actions that represent actions that have been undone.

[Visual Basic]
ReadOnly Property RedoActionList As IActionUnit ()
[C#]
IActionUnit[] RedoActionList {get;}
[C++]
IActionUnit* get_RedoActionList() = 0;
[JScript]
abstract function get RedoActionList() : IActionUnit[];

Property Value

An array of the current redoable actions.

Remarks

This is an array of the actions currently on the redo stack. These are for inspection only; invoking these actions may create unpredictable undo/redo behavior from the service. The item at index zero (if any) is the first action that would be redone. That is, it is the top of the stack.

See Also

IUndoService Interface | IUndoService Members | System.ComponentModel.Design Namespace


IUndoService.UndoActionList

Gets or sets an array of type IActionUnit that contains the undo actions that represent actions that have been undone.

[Visual Basic]
ReadOnly Property UndoActionList As IActionUnit ()
[C#]
IActionUnit[] UndoActionList {get;}
[C++]
IActionUnit* get_UndoActionList() = 0;
[JScript]
abstract function get UndoActionList() : IActionUnit[];

Property Value

An array of the current undoable actions.

Remarks

This is an array of the actions currently on the undo stack. These are for inspection only; invoking these actions may create unpredictable undo/redo behavior from the service. The item at index zero (if any) is the first action that would be undone. That is, it is the top of the stack.

See Also

IUndoService Interface | IUndoService Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IUndoService Methods

The methods of the IUndoService interface are listed below. For a complete list of IUndoService interface members, see the IUndoService Members topic.

AddAction | Overloaded. [To be supplied.]
CanAddAction | Gets whether the current action can be added to the IUndoService implementation.
DiscardRedoItems | Clears actions from the redo stack before and including the specified action.
DiscardUndoItems | Clears actions from the undo stack before and including the specified action.
RedoActions | Redoes the specified number of actions.
RedoActionsTo | Instructs the undo service to invoke redo actions down to and including action.
SetEnabledAutoReset | Enables or disables the current undo service.
UndoActions | Undoes the specified number of actions.
UndoActionsTo | Instructs the undo service to invoke undo actions down to and including the specified action.

Event Hookup:

AddOnActionAdded | Adds an event handler to be invoked when a new action is added to the service.
AddOnRedo | Adds a handler to be invoked when an action is redone.
AddOnUndo | Adds a handler to be invoked when an action is undone.
RemoveOnActionAdded | Removes an event handler that would be invoked when a new action is added to the service.
RemoveOnRedo | Removes a handler to be invoked when an action is redone.
RemoveOnUndo | Removes a handler to be invoked when an action is undone.

See Also

IUndoService Interface | System.ComponentModel.Design Namespace


IUndoService.AddAction

[To be supplied.]

Overload List

Adds an action unit to the undo stack.

[Visual Basic] Overloads Sub AddAction(IActionUnit, Boolean, Boolean)
[C#] void AddAction(IActionUnit, bool, bool);
[C++] void AddAction(IActionUnit*, bool, bool) = 0;
[JScript] function AddAction(IActionUnit, Boolean, Boolean);

Adds an action unit to the undo stack.

[Visual Basic] Overloads Sub AddAction(IActionUnit, Boolean)
[C#] void AddAction(IActionUnit, bool);
[C++] void AddAction(IActionUnit*, bool) = 0;
[JScript] function AddAction(IActionUnit, Boolean);

Adds an action unit to the undo stack.

[Visual Basic] Overloads Sub AddAction(IActionUnit)
[C#] void AddAction(IActionUnit);
[C++] void AddAction(IActionUnit*) = 0;
[JScript] function AddAction(IActionUnit);

See Also

IUndoService Interface | IUndoService Members | System.ComponentModel.Design Namespace


IUndoService.AddAction (IActionUnit, Boolean, Boolean)

Adds an action unit to the undo stack.

[Visual Basic]
Overloads Sub AddAction( _
   ByVal action As IActionUnit, _
   ByVal needsExecute As Boolean, _
   ByVal supressChildUndoAdds As Boolean _
)
[C#]
void AddAction(
   IActionUnit action,
   bool needsExecute,
   bool supressChildUndoAdds
);
[C++]
void AddAction(
   IActionUnit* action,
   bool needsExecute,
   bool supressChildUndoAdds
) = 0;
[JScript]
function AddAction(
   action : IActionUnit,
   needsExecute : Boolean,
   supressChildUndoAdds : Boolean
);

Parameters

action
The action to perform and add to the undo stack.
needsExecute
true for the undo service to call DoAction on action when it is added.
supressChildUndoAdds
true to prevent this action from adding more undo actions when it is executed.

Remarks

If this action is ever undone, it will be added automatically to the redo stack, if appropriate. If needsExecute is true, it will be executed, so actions may be created before they are to be executed. If the action has already been performed, set needsExcecute to false and create the action in the "UNDO" state. suppressChildUndoAdds specified as true will cause the undo service to ignore any undo actions that action attempts to add when it is executed. If needsExecute is false, this parameter is ignored.

See Also

IUndoService Interface | IUndoService Members | System.ComponentModel.Design Namespace | IUndoService.AddAction Overload List


IUndoService.AddAction (IActionUnit, Boolean)

Adds an action unit to the undo stack.

[Visual Basic]
Overloads Sub AddAction( _
   ByVal action As IActionUnit, _
   ByVal needsExecute As Boolean _
)
[C#]
void AddAction(
   IActionUnit action,
   bool needsExecute
);
[C++]
void AddAction(
   IActionUnit* action,
   bool needsExecute
) = 0;
[JScript]
function AddAction(
   action : IActionUnit,
   needsExecute : Boolean
);

Parameters

action
The action to perform and add to the undo stack.
needsExecute
true for the undo service to call DoAction on action when it is added.

Remarks

If this action is undone, it will be added to the redo stack, if appropriate. If needsExecute is true, it will be executed; so actions may be created before they are to be executed. If the action has already been performed, set needsExcecute to false and create the action in the "UNDO" state.

See Also

IUndoService Interface | IUndoService Members | System.ComponentModel.Design Namespace | IUndoService.AddAction Overload List


IUndoService.AddAction (IActionUnit)

Adds an action unit to the undo stack.

[Visual Basic]
Overloads Sub AddAction( _
   ByVal action As IActionUnit _
)
[C#]
void AddAction(
   IActionUnit action
);
[C++]
void AddAction(
   IActionUnit* action
) = 0;
[JScript]
function AddAction(
   action : IActionUnit
);

Parameters

action
The action to perform and add to the undo stack.

Remarks

If this action is undone, it will be added to the redo stack, if appropriate. The action will be executed when it is added, so this method expects the action to be in the "REDO" state.

See Also

IUndoService Interface | IUndoService Members | System.ComponentModel.Design Namespace | IUndoService.AddAction Overload List | IActionUnit


IUndoService.AddOnActionAdded

Adds an event handler to be invoked when a new action is added to the service.

[Visual Basic]
Sub AddOnActionAdded( _
   ByVal handler As EventHandler _
)
[C#]
void AddOnActionAdded(
   EventHandler handler
);
[C++]
void AddOnActionAdded(
   EventHandler* handler
) = 0;
[JScript]
function AddOnActionAdded(
   handler : EventHandler
);

Parameters

handler
The handler that will be invoked when an action is added to the service.

See Also

IUndoService Interface | IUndoService Members | System.ComponentModel.Design Namespace


IUndoService.AddOnRedo

Adds a handler to be invoked when an action is redone.

[Visual Basic]
Sub AddOnRedo( _
   ByVal handler As ActionUnitEventHandler _
)
[C#]
void AddOnRedo(
   ActionUnitEventHandler handler
);
[C++]
void AddOnRedo(
   ActionUnitEventHandler* handler
) = 0;
[JScript]
function AddOnRedo(
   handler : ActionUnitEventHandler
);

Parameters

handler
The handler to be invoked when an action is redone, of the signature SomeRedoHandlerName(Objects, ActionUnitEventArgs event).

See Also

IUndoService Interface | IUndoService Members | System.ComponentModel.Design Namespace


IUndoService.AddOnUndo

Adds a handler to be invoked when an action is undone.

[Visual Basic]
Sub AddOnUndo( _
   ByVal handler As ActionUnitEventHandler _
)
[C#]
void AddOnUndo(
   ActionUnitEventHandler handler
);
[C++]
void AddOnUndo(
   ActionUnitEventHandler* handler
) = 0;
[JScript]
function AddOnUndo(
   handler : ActionUnitEventHandler
);

Parameters

handler
The handler to be invoked when an action is undone, of the signature SomeUndoHandlerName(Objects, ActionUnitEventArgs event).

See Also

IUndoService Interface | IUndoService Members | System.ComponentModel.Design Namespace


IUndoService.CanAddAction

Gets whether the current action can be added to the IUndoService implementation.

[Visual Basic]
Function CanAddAction( _
   ByVal action As IActionUnit _
) As Boolean
[C#]
bool CanAddAction(
   IActionUnit action
);
[C++]
bool CanAddAction(
   IActionUnit* action
) = 0;
[JScript]
function CanAddAction(
   action : IActionUnit
) : Boolean;

Parameters

action
The action that will be added.

Return Value

true if the action can be added; otherwise, false.

Remarks

If action requires a parent action or the service is currently not accepting new actions, it will return false.

See Also

IUndoService Interface | IUndoService Members | System.ComponentModel.Design Namespace


IUndoService.DiscardRedoItems

Clears actions from the redo stack before and including the specified action.

[Visual Basic]
Sub DiscardRedoItems( _
   ByVal action As IActionUnit _
)
[C#]
void DiscardRedoItems(
   IActionUnit action
);
[C++]
void DiscardRedoItems(
   IActionUnit* action
) = 0;
[JScript]
function DiscardRedoItems(
   action : IActionUnit
);

Parameters

action
The action to clear the redo stack down to and including. This action is also removed, and all items are removed if action is a null reference (in Visual Basic Nothing).

Remarks

If action is a null reference (Nothing) then all actions are removed. If action is not found in the stack, an ArgumentException is thrown.

See Also

IUndoService Interface | IUndoService Members | System.ComponentModel.Design Namespace


IUndoService.DiscardUndoItems

Clears actions from the undo stack before and including the specified action.

[Visual Basic]
Sub DiscardUndoItems( _
   ByVal action As IActionUnit _
)
[C#]
void DiscardUndoItems(
   IActionUnit action
);
[C++]
void DiscardUndoItems(
   IActionUnit* action
) = 0;
[JScript]
function DiscardUndoItems(
   action : IActionUnit
);

Parameters

action
The action to clear the undo stack down to and including. This action is also removed, and all items are removed if action is a null reference (in Visual Basic Nothing).

Remarks

If action is a null reference (Nothing) then all actions are removed. If action is not found in the stack, an ArgumentException is thrown.

See Also

IUndoService Interface | IUndoService Members | System.ComponentModel.Design Namespace


IUndoService.RedoActions

Redoes the specified number of actions.

[Visual Basic]
Sub RedoActions( _
   ByVal actions As Integer _
)
[C#]
void RedoActions(
   int actions
);
[C++]
void RedoActions(
   int actions
) = 0;
[JScript]
function RedoActions(
   actions : int
);

Parameters

actions
The number of actions to redo.

Remarks

If the number of available redos is less than the number requested, all the available redos are performed.

See Also

IUndoService Interface | IUndoService Members | System.ComponentModel.Design Namespace


IUndoService.RedoActionsTo

Instructs the undo service to invoke redo actions down to and including action.

[Visual Basic]
Sub RedoActionsTo( _
   ByVal action As IActionUnit _
)
[C#]
void RedoActionsTo(
   IActionUnit action
);
[C++]
void RedoActionsTo(
   IActionUnit* action
) = 0;
[JScript]
function RedoActionsTo(
   action : IActionUnit
);

Parameters

action
The action to redo down to and including.

See Also

IUndoService Interface | IUndoService Members | System.ComponentModel.Design Namespace


IUndoService.RemoveOnActionAdded

Removes an event handler that would be invoked when a new action is added to the service.

[Visual Basic]
Sub RemoveOnActionAdded( _
   ByVal handler As EventHandler _
)
[C#]
void RemoveOnActionAdded(
   EventHandler handler
);
[C++]
void RemoveOnActionAdded(
   EventHandler* handler
) = 0;
[JScript]
function RemoveOnActionAdded(
   handler : EventHandler
);

Parameters

handler
The handler to be removed.

See Also

IUndoService Interface | IUndoService Members | System.ComponentModel.Design Namespace


IUndoService.RemoveOnRedo

Removes a handler to be invoked when an action is redone.

[Visual Basic]
Sub RemoveOnRedo( _
   ByVal handler As ActionUnitEventHandler _
)
[C#]
void RemoveOnRedo(
   ActionUnitEventHandler handler
);
[C++]
void RemoveOnRedo(
   ActionUnitEventHandler* handler
) = 0;
[JScript]
function RemoveOnRedo(
   handler : ActionUnitEventHandler
);

Parameters

handler
The handler to be removed.

See Also

IUndoService Interface | IUndoService Members | System.ComponentModel.Design Namespace


IUndoService.RemoveOnUndo

Removes a handler to be invoked when an action is undone.

[Visual Basic]
Sub RemoveOnUndo( _
   ByVal handler As ActionUnitEventHandler _
)
[C#]
void RemoveOnUndo(
   ActionUnitEventHandler handler
);
[C++]
void RemoveOnUndo(
   ActionUnitEventHandler* handler
) = 0;
[JScript]
function RemoveOnUndo(
   handler : ActionUnitEventHandler
);

Parameters

handler
The handler to be removed.

See Also

IUndoService Interface | IUndoService Members | System.ComponentModel.Design Namespace


IUndoService.SetEnabledAutoReset

Enables or disables the current undo service.

[Visual Basic]
Sub SetEnabledAutoReset( _
   ByVal value As Boolean _
)
[C#]
void SetEnabledAutoReset(
   bool value
);
[C++]
void SetEnabledAutoReset(
   bool value
) = 0;
[JScript]
function SetEnabledAutoReset(
   value : Boolean
);

Parameters

value
true to allow new actions to be added, otherwise false.

Remarks

If a current batch operation is in progress, the enabled state will automatically be reset to true when the batch operation is completed. If enabled is set to false, any added actions are ignored.

See Also

IUndoService Interface | IUndoService Members | System.ComponentModel.Design Namespace


IUndoService.UndoActions

Undoes the specified number of actions.

[Visual Basic]
Sub UndoActions( _
   ByVal actions As Integer _
)
[C#]
void UndoActions(
   int actions
);
[C++]
void UndoActions(
   int actions
) = 0;
[JScript]
function UndoActions(
   actions : int
);

Parameters

actions
The number of actions to undo.

Remarks

If the number of available undos is less than the number requested, all the available undos are performed.

See Also

IUndoService Interface | IUndoService Members | System.ComponentModel.Design Namespace


IUndoService.UndoActionsTo

Instructs the undo service to invoke undo actions down to and including the specified action.

[Visual Basic]
Sub UndoActionsTo( _
   ByVal action As IActionUnit _
)
[C#]
void UndoActionsTo(
   IActionUnit action
);
[C++]
void UndoActionsTo(
   IActionUnit* action
) = 0;
[JScript]
function UndoActionsTo(
   action : IActionUnit
);

Parameters

action
The action to undo down to and including.

See Also

IUndoService Interface | IUndoService Members | System.ComponentModel.Design Namespace


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IUndoService Events

The events of the IUndoService interface are listed below. For a complete list of IUndoService interface members, see the IUndoService Members topic.

ActionAdded | [To be supplied.]
Redo | [To be supplied.]
Undo | [To be supplied.]

See Also

IUndoService Interface | System.ComponentModel.Design Namespace


IUndoService ActionAdded Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the ActionAdded event.

[Visual Basic]
Private Sub IUndoServiceName_ActionAdded( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
private void IUndoServiceName_ActionAdded(
   object sender,
   EventArgs e
);
[C++]
private: void IUndoServiceName_ActionAdded(
   Object* sender,
   EventArgs* e
);
[JScript]
private IUndoServiceName_ActionAdded(
   sender : Object,
   e : EventArgs
);

Parameters

sender
The source of the event.
e
An EventArgs that contains the event data. The following EventArgs properties provide information specific to this event.
Property Description
ExtendedInfo
Holds a reference to an object that manages the event's state.

See Also

IUndoService Interface | IUndoService MembersTopic | System.ComponentModel.Design Namespace


IUndoService Redo Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the Redo event.

[Visual Basic]
Private Sub IUndoServiceName_Redo( _
   ByVal sender As Object, _
   ByVal e As ActionUnitEventArgs _
)
[C#]
private void IUndoServiceName_Redo(
   object sender,
   ActionUnitEventArgs e
);
[C++]
private: void IUndoServiceName_Redo(
   Object* sender,
   ActionUnitEventArgs* e
);
[JScript]
private IUndoServiceName_Redo(
   sender : Object,
   e : ActionUnitEventArgs
);

Parameters

sender
The source of the event.
e
An ActionUnitEventArgs that contains the event data.

See Also

IUndoService Interface | IUndoService MembersTopic | System.ComponentModel.Design Namespace


IUndoService Undo Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the Undo event.

[Visual Basic]
Private Sub IUndoServiceName_Undo( _
   ByVal sender As Object, _
   ByVal e As ActionUnitEventArgs _
)
[C#]
private void IUndoServiceName_Undo(
   object sender,
   ActionUnitEventArgs e
);
[C++]
private: void IUndoServiceName_Undo(
   Object* sender,
   ActionUnitEventArgs* e
);
[JScript]
private IUndoServiceName_Undo(
   sender : Object,
   e : ActionUnitEventArgs
);

Parameters

sender
The source of the event.
e
An ActionUnitEventArgs that contains the event data.

See Also

IUndoService Interface | IUndoService MembersTopic | System.ComponentModel.Design Namespace


IValueProvider Interface

Defines an object that participates in code generation to persist data outside of the code.

IValueProvider

[Visual Basic]
Public Interface IValueProvider
[C#]
public interface IValueProvider
[C++]
public __gc __interface IValueProvider

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IValueProvider

Class | Description
ValueProvider | Interface defining an object that needs to participate in code generation to persist data outside of the code. This allows the runtime object to "provide values" to components on the form.

Remarks

This interface allows the runtime object to provide values to components on the form.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

IValueProvider Members | System.ComponentModel.Design Namespace | IValueProviderService | IValueProviderCollection


IValueProvider Members

Properties

ServiceProvider Gets or sets the service provider for this value provider.

Methods

BeginDepersist | Begins depersistence.
BeginPersist | Begins persistence.
CanProvideValue | Gets whether the provider can provide a value for the specified expression.
EndDepersist | Ends depersistence.
EndPersist | Ends persistence.
GetExpressionLevel | Gets the level of support to generate an expression for the specified property on the specified object.
GetLocalVariableDeclaration | Gets the local variable declaration.
GetRequireComponents | Provides a list of components that are required to be initialized before this value provider can provide values.
IsLocalVariableDeclaration | Gets a value indicating whether the specified statement is the local variable declaration for this value provider.
ProvideExpression | Creates a new expression that represents the property value for the specified component.
ProvideValue | Gets the value that the code expression represents or contains.

See Also

IValueProvider Interface | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IValueProvider Properties

The properties of the IValueProvider interface are listed below. For a complete list of IValueProvider interface members, see the IValueProvider Members topic.

ServiceProvider Gets or sets the service provider for this value provider.

See Also

IValueProvider Interface | System.ComponentModel.Design Namespace


IValueProvider.ServiceProvider

Gets or sets the service provider for this value provider.

[Visual Basic]
Property ServiceProvider As IServiceObjectProvider
[C#]
IServiceObjectProvider ServiceProvider {get; set;}
[C++]
IServiceObjectProvider* get_ServiceProvider() = 0;void set_ServiceProvider(IServiceObjectProvider*) = 0;
[JScript]
abstract function get ServiceProvider() : IServiceObjectProvider;
public abstract function set ServiceProvider(IServiceObjectProvider);

Property Value

An System.ComponentModel.Design.IServiceObjectProvider that indicates the service provider for this value provider.

Remarks

The service provider is normally an IValueProviderService.

See Also

IValueProvider Interface | IValueProvider Members | System.ComponentModel.Design Namespace | IValueProviderService


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IValueProvider Methods

The methods of the IValueProvider interface are listed below. For a complete list of IValueProvider interface members, see the IValueProvider Members topic.

BeginDepersist | Begins depersistence.
BeginPersist | Begins persistence.
CanProvideValue | Gets whether the provider can provide a value for the specified expression.
EndDepersist | Ends depersistence.
EndPersist | Ends persistence.
GetExpressionLevel | Gets the level of support to generate an expression for the specified property on the specified object.
GetLocalVariableDeclaration | Gets the local variable declaration.
GetRequireComponents | Provides a list of components that are required to be initialized before this value provider can provide values.
IsLocalVariableDeclaration | Gets a value indicating whether the specified statement is the local variable declaration for this value provider.
ProvideExpression | Creates a new expression that represents the property value for the specified component.
ProvideValue | Gets the value that the code expression represents or contains.

See Also

IValueProvider Interface | System.ComponentModel.Design Namespace


IValueProvider.BeginDepersist

Begins depersistence.

[Visual Basic]
Sub BeginDepersist()
[C#]
void BeginDepersist();
[C++]
void BeginDepersist() = 0;
[JScript]
function BeginDepersist();

Remarks

This method is called by the code generator before any statements in the code are parsed. This allows the provider to clear the previous state.

See Also

IValueProvider Interface | IValueProvider Members | System.ComponentModel.Design Namespace


IValueProvider.BeginPersist

Begins persistence.

[Visual Basic]
Sub BeginPersist()
[C#]
void BeginPersist();
[C++]
void BeginPersist() = 0;
[JScript]
function BeginPersist();

Remarks

This method is called by the code generator before statements in the code are generated. This allows the provider to clear the previous state.

See Also

IValueProvider Interface | IValueProvider Members | System.ComponentModel.Design Namespace


IValueProvider.CanProvideValue

Gets whether the provider can provide a value for the specified expression.

[Visual Basic]
Function CanProvideValue( _
   ByVal component As Object, _
   ByVal propertyName As String, _
   ByVal exp As Object _
) As Boolean
[C#]
bool CanProvideValue(
   object component,
   string propertyName,
   object exp
);
[C++]
bool CanProvideValue(
   Object* component,
   String* propertyName,
   Object* exp
) = 0;
[JScript]
function CanProvideValue(
   component : Object,
   propertyName : String,
   exp : Object
) : Boolean;

Parameters

component
The component whose property is being depersisted.
propertyName
The property that is being depersisted.
exp
The expression to determine if this value provider can provide a value for.

Remarks

This method is called for every expression found in the code. If the IValueProvider returns true, then the ProvideValue method will be called.

See Also

IValueProvider Interface | IValueProvider Members | System.ComponentModel.Design Namespace


IValueProvider.EndDepersist

Ends depersistence.

[Visual Basic]
Sub EndDepersist()
[C#]
void EndDepersist();
[C++]
void EndDepersist() = 0;
[JScript]
function EndDepersist();

Remarks

This method is called by the code generator after all statements have been parsed.

See Also

IValueProvider Interface | IValueProvider Members | System.ComponentModel.Design Namespace


IValueProvider.EndPersist

Ends persistence.

[Visual Basic]
Sub EndPersist()
[C#]
void EndPersist();
[C++]
void EndPersist() = 0;
[JScript]
function EndPersist();

Remarks

This method is called by the code generator after all statements have been generated.

See Also

IValueProvider Interface | IValueProvider Members | System.ComponentModel.Design Namespace


IValueProvider.GetExpressionLevel

Gets the level of support to generate an expression for the specified property on the specified object.

[Visual Basic]
Function GetExpressionLevel( _
   ByVal component As Object, _
   ByVal property As PropertyDescriptor, _
   ByVal persistable As PersistableSupport _
) As ValueExpressionLevel
[C#]
ValueExpressionLevel GetExpressionLevel(
   object component,
   PropertyDescriptor property,
   PersistableSupport persistable
);
[C++]
ValueExpressionLevel GetExpressionLevel(
   Object* component,
   PropertyDescriptor* property,
   PersistableSupport persistable
) = 0;
[JScript]
function GetExpressionLevel(
   component : Object,
   property : PropertyDescriptor,
   persistable : PersistableSupport
) : ValueExpressionLevel;

Parameters

component
The component whose property is being persisted.
property
[To be supplied.]
persistable
The PersistableAttribute for the property in the current context.

Remarks

If a value provider returns anything but NotSupported then it must return a non- a null reference (in Visual Basic Nothing) value from ProvideExpression.

See Also

IValueProvider Interface | IValueProvider Members | System.ComponentModel.Design Namespace | PropertyDescriptor | PersistableSupport | ValueExpressionLevel


IValueProvider.GetLocalVariableDeclaration

Gets the local variable declaration.

[Visual Basic]
Function GetLocalVariableDeclaration() As ICodeStatement
[C#]
ICodeStatement GetLocalVariableDeclaration();
[C++]
ICodeStatement* GetLocalVariableDeclaration() = 0;
[JScript]
function GetLocalVariableDeclaration() : ICodeStatement;

Remarks

If this value provider requires that a local variable is declared then this must return a non- a null reference (in Visual Basic Nothing) ICodeStatement.

See Also

IValueProvider Interface | IValueProvider Members | System.ComponentModel.Design Namespace


IValueProvider.GetRequireComponents

Provides a list of components that are required to be initialized before this value provider can provide values.

[Visual Basic]
Function GetRequireComponents() As Object ()
[C#]
object[] GetRequireComponents();
[C++]
Object* GetRequireComponents() [] = 0;
[JScript]
function GetRequireComponents() : Object[];

Remarks

This method allows a value provider to force the component that is actually providing the values to be code generated before the calls to it.

See Also

IValueProvider Interface | IValueProvider Members | System.ComponentModel.Design Namespace


IValueProvider.IsLocalVariableDeclaration

Gets a value indicating whether the specified statement is the local variable declaration for this value provider.

[Visual Basic]
Function IsLocalVariableDeclaration( _
   ByVal stmt As ICodeStatement _
) As Boolean
[C#]
bool IsLocalVariableDeclaration(
   ICodeStatement stmt
);
[C++]
bool IsLocalVariableDeclaration(
   ICodeStatement* stmt
) = 0;
[JScript]
function IsLocalVariableDeclaration(
   stmt : ICodeStatement
) : Boolean;

Parameters

stmt
The statement to compare.

Return Value

true if the specified statement is the local variable declaration for the value provider; otherwise, false.

See Also

IValueProvider Interface | IValueProvider Members | System.ComponentModel.Design Namespace | ICodeStatement


IValueProvider.ProvideExpression

Creates a new expression that represents the property value for the specified component.

[Visual Basic]
Function ProvideExpression( _
   ByVal component As Object, _
   ByVal propertyName As String, _
   ByVal value As Object _
) As Object
[C#]
object ProvideExpression(
   object component,
   string propertyName,
   object value
);
[C++]
Object* ProvideExpression(
   Object* component,
   String* propertyName,
   Object* value
) = 0;
[JScript]
function ProvideExpression(
   component : Object,
   propertyName : String,
   value : Object
) : Object;

Parameters

component
The component whose property is being persisted.
propertyName
The name of the property that is being persisted.
value
The value of the property that is being persisted.

Return Value

The new expression.

See Also

IValueProvider Interface | IValueProvider Members | System.ComponentModel.Design Namespace


IValueProvider.ProvideValue

Gets the value that the code expression represents or contains.

[Visual Basic]
Function ProvideValue( _
   ByVal component As Object, _
   ByVal propertyName As String, _
   ByVal exp As Object _
) As Object
[C#]
object ProvideValue(
   object component,
   string propertyName,
   object exp
);
[C++]
Object* ProvideValue(
   Object* component,
   String* propertyName,
   Object* exp
) = 0;
[JScript]
function ProvideValue(
   component : Object,
   propertyName : String,
   exp : Object
) : Object;

Parameters

component
The component that contains the value.
propertyName
The name of the property to retrieve the value for.
exp
The expression representing the property that is being depersisted.

Return Value

The value from the code expression.

See Also

IValueProvider Interface | IValueProvider Members | System.ComponentModel.Design Namespace


IValueProviderCollection Interface

Provides an interface to manage a collection of IValueProvider objects.

[Visual Basic]
Public Interface IValueProviderCollection
   Implements ICollection, IEnumerable
[C#]
public interface IValueProviderCollection : ICollection,
   IEnumerable
[C++]
public __gc __interface IValueProviderCollection : public
   ICollection, IEnumerable

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IValueProviderCollection

Class | Description
ValueProviderCollection | Collection of IValueProvider objects.

Remarks

Allows you to manage a document's value provider collection.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

IValueProviderCollection Members | System.ComponentModel.Design Namespace | IValueProvider


IValueProviderCollection Members

Properties

All Gets or sets a snapshot array of all the IValueProvider items.

Methods

Add | Adds a value provider to the collection.
Remove | Removes a value provider from the collection.

See Also

IValueProviderCollection Interface | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IValueProviderCollection Properties

The properties of the IValueProviderCollection interface are listed below. For a complete list of IValueProviderCollection interface members, see the IValueProviderCollection Members topic.

All Gets or sets a snapshot array of all the IValueProvider items.

See Also

IValueProviderCollection Interface | System.ComponentModel.Design Namespace


IValueProviderCollection.All

Gets or sets a snapshot array of all the IValueProvider items.

[Visual Basic]
ReadOnly Property All As IValueProvider ()
[C#]
IValueProvider[] All {get;}
[C++]
IValueProvider* get_All() = 0;
[JScript]
abstract function get All() : IValueProvider[];

Property Value

An array of all IValueProvider objects referenced by the collection.

Remarks

Use the Add and Remove methods for most operations on the collection.

See Also

IValueProviderCollection Interface | IValueProviderCollection Members | System.ComponentModel.Design Namespace | IValueProvider


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IValueProviderCollection Methods

The methods of the IValueProviderCollection interface are listed below. For a complete list of IValueProviderCollection interface members, see the IValueProviderCollection Members topic.

Add | Adds a value provider to the collection.
Remove | Removes a value provider from the collection.

See Also

IValueProviderCollection Interface | System.ComponentModel.Design Namespace


IValueProviderCollection.Add

Adds a value provider to the collection.

[Visual Basic]
Sub Add( _
   ByVal value As IValueProvider _
)
[C#]
void Add(
   IValueProvider value
);
[C++]
void Add(
   IValueProvider* value
) = 0;
[JScript]
function Add(
   value : IValueProvider
);

Parameters

value
The IValueProvider to add to the collection.

Remarks

Use this to add a value provider to the collection.

See Also

IValueProviderCollection Interface | IValueProviderCollection Members | System.ComponentModel.Design Namespace | Remove | IValueProvider


IValueProviderCollection.Remove

Removes a value provider from the collection.

[Visual Basic]
Sub Remove( _
   ByVal value As IValueProvider _
)
[C#]
void Remove(
   IValueProvider value
);
[C++]
void Remove(
   IValueProvider* value
) = 0;
[JScript]
function Remove(
   value : IValueProvider
);

Parameters

value
The IValueProvider to remove from the collection.

Remarks

Use this to remove a value provider form the collection.

See Also

IValueProviderCollection Interface | IValueProviderCollection Members | System.ComponentModel.Design Namespace | Add | IValueProvider


IValueProviderService Interface

Provides access to the value provider collection that can be used for managing and checking the value providers that will be used during code persistance and depersistance.

IValueProviderService

[Visual Basic]
Public Interface IValueProviderService
[C#]
public interface IValueProviderService
[C++]
public __gc __interface IValueProviderService

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IValueProviderService

Class | Description
ValueProviderService | The value provider service provides a collection of value providers that will be called on when code is persisted or depersisted.

Remarks

Provides access to a collection of value providers that will all be called on when code is persisted or depersisted.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

IValueProviderService Members | System.ComponentModel.Design Namespace | IValueProviderCollection


IValueProviderService Members

Properties

Providers Gets or sets the collection of value providers.

See Also

IValueProviderService Interface | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IValueProviderService Properties

The properties of the IValueProviderService interface are listed below. For a complete list of IValueProviderService interface members, see the IValueProviderService Members topic.

Providers Gets or sets the collection of value providers.

See Also

IValueProviderService Interface | System.ComponentModel.Design Namespace


IValueProviderService.Providers

Gets or sets the collection of value providers.

[Visual Basic]
ReadOnly Property Providers As IValueProviderCollection
[C#]
IValueProviderCollection Providers {get;}
[C++]
IValueProviderCollection* get_Providers() = 0;
[JScript]
abstract function get Providers() : IValueProviderCollection;

Property Value

An IValueProviderCollection that contains the value providers for the document.

See Also

IValueProviderService Interface | IValueProviderService Members | System.ComponentModel.Design Namespace | IValueProviderCollection


Localizer Class

[To be supplied.]

Object
Localizer

[Visual Basic]
Public Class Localizer
   Implements IExtenderProvider
[C#]
public class Localizer : IExtenderProvider
[C++]
public __gc class Localizer : public IExtenderProvider
[JScript]
public class Localizer implements IExtenderProvider

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

Localizer Members | System.ComponentModel.Design Namespace


Localizer Members

Public:

Constructor

Localizer Constructor [To be supplied.]

Methods

CanExtend | [To be supplied.]
Dispose | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLanguage | [To be supplied.]
GetLocalizable | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
ResetLanguage | [To be supplied.]
SetLanguage | [To be supplied.]
SetLocalizable | [To be supplied.]
ShouldPersistLanguage | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Localizer Class | System.ComponentModel.Design Namespace


Localizer Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal serviceProvider As ISite, _
   ByVal baseComponent As IComponent _
)
[C#]
public Localizer(
   ISite serviceProvider,
   IComponent baseComponent
);
[C++]
public: Localizer(
   ISite* serviceProvider,
   IComponent* baseComponent
);
[JScript]
public function Localizer(
   serviceProvider : ISite,
   baseComponent : IComponent
);

Parameters

serviceProvider
[To be supplied.]
baseComponent
[To be supplied.]

See Also

Localizer Class | Localizer Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Localizer Methods

The methods of the Localizer class are listed below. For a complete list of Localizer class members, see the Localizer Members topic.

Public:

CanExtend | [To be supplied.]
Dispose | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLanguage | [To be supplied.]
GetLocalizable | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
ResetLanguage | [To be supplied.]
SetLanguage | [To be supplied.]
SetLocalizable | [To be supplied.]
ShouldPersistLanguage | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Localizer Class | System.ComponentModel.Design Namespace


Localizer.CanExtend

[To be supplied.]

[Visual Basic]
Overridable Public Function CanExtend( _
   ByVal o As Object _
) As Boolean
[C#]
public virtual bool CanExtend(
   object o
);
[C++]
public: virtual bool CanExtend(
   Object* o
);
[JScript]
public function CanExtend(
   o : Object
) : Boolean;

Parameters

o
[To be supplied.]

See Also

Localizer Class | Localizer Members | System.ComponentModel.Design Namespace


Localizer.Dispose

[To be supplied.]

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[JScript]
public function Dispose();

See Also

Localizer Class | Localizer Members | System.ComponentModel.Design Namespace


Localizer.GetLanguage

[To be supplied.]

[Visual Basic]
Public Function GetLanguage( _
   ByVal o As Object _
) As CultureInfo
[C#]
public CultureInfo GetLanguage(
   object o
);
[C++]
public: CultureInfo* GetLanguage(
   Object* o
);
[JScript]
public function GetLanguage(
   o : Object
) : CultureInfo;

Parameters

o
[To be supplied.]

See Also

Localizer Class | Localizer Members | System.ComponentModel.Design Namespace


Localizer.GetLocalizable

[To be supplied.]

[Visual Basic]
Public Function GetLocalizable( _
   ByVal o As Object _
) As Boolean
[C#]
public bool GetLocalizable(
   object o
);
[C++]
public: bool GetLocalizable(
   Object* o
);
[JScript]
public function GetLocalizable(
   o : Object
) : Boolean;

Parameters

o
[To be supplied.]

See Also

Localizer Class | Localizer Members | System.ComponentModel.Design Namespace


Localizer.ResetLanguage

[To be supplied.]

[Visual Basic]
Public Sub ResetLanguage( _
   ByVal o As Object _
)
[C#]
public void ResetLanguage(
   object o
);
[C++]
public: void ResetLanguage(
   Object* o
);
[JScript]
public function ResetLanguage(
   o : Object
);

Parameters

o
[To be supplied.]

See Also

Localizer Class | Localizer Members | System.ComponentModel.Design Namespace


Localizer.SetLanguage

[To be supplied.]

[Visual Basic]
Public Sub SetLanguage( _
   ByVal o As Object, _
   ByVal language As CultureInfo _
)
[C#]
public void SetLanguage(
   object o,
   CultureInfo language
);
[C++]
public: void SetLanguage(
   Object* o,
   CultureInfo* language
);
[JScript]
public function SetLanguage(
   o : Object,
   language : CultureInfo
);

Parameters

o
[To be supplied.]
language
[To be supplied.]

See Also

Localizer Class | Localizer Members | System.ComponentModel.Design Namespace


Localizer.SetLocalizable

[To be supplied.]

[Visual Basic]
Public Sub SetLocalizable( _
   ByVal o As Object, _
   ByVal localizable As Boolean _
)
[C#]
public void SetLocalizable(
   object o,
   bool localizable
);
[C++]
public: void SetLocalizable(
   Object* o,
   bool localizable
);
[JScript]
public function SetLocalizable(
   o : Object,
   localizable : Boolean
);

Parameters

o
[To be supplied.]
localizable
[To be supplied.]

See Also

Localizer Class | Localizer Members | System.ComponentModel.Design Namespace


Localizer.ShouldPersistLanguage

[To be supplied.]

[Visual Basic]
Public Function ShouldPersistLanguage( _
   ByVal o As Object _
) As Boolean
[C#]
public bool ShouldPersistLanguage(
   object o
);
[C++]
public: bool ShouldPersistLanguage(
   Object* o
);
[JScript]
public function ShouldPersistLanguage(
   o : Object
) : Boolean;

Parameters

o
[To be supplied.]

See Also

Localizer Class | Localizer Members | System.ComponentModel.Design Namespace


MemberModifier Class

Specifies constant values for common attributes applied to member functions.

Object
MemberModifier

[Visual Basic]
Public Class MemberModifier
[C#]
public class MemberModifier
[C++]
public __gc class MemberModifier
[JScript]
public class MemberModifier

Remarks

These follow the NGWS frameworks names rather than any specific language.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

MemberModifier Members | System.ComponentModel.Design Namespace


MemberModifier Members

Public:

Constructor

MemberModifier Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Abstract | Specifies that the member is abstract. This field is constant.
Const | Specifies that the member is abstract. This field is constant.
Extern | Specifies that the member is external. This field is constant.
Final | Specifies that the member is final. This field is constant.
Internal | Specifies that the member is internal. This field is constant.
Multicast | Specifies that the member is a multicast. This field is constant.
Native | Specifies that the member is native. This field is constant.
New | Specifies that the member is new. This field is constant.
Override | Specifies that the member is an override. This field is constant.
Private | Specifies that the member is private. This field is constant.
Protected | Specifies that the member is protected. This field is constant.
Public | Specifies that the member is public. This field is constant.
Readonly | Specifies that the member is read-only. This field is constant.
Sealed | Specifies that the member is sealed. This field is constant.
Static | Specifies that the member is static. This field is constant.
Synchronized | Specifies that the member is synchronized. This field is constant.
Transient | Specifies that the member is transient. This field is constant.
Unknown | Specifies that the member is unknown. This field is constant.
Value | Specifies that the member is a value. This field is constant.
Virtual | Specifies that the member is virtual. This field is constant.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MemberModifier Class | System.ComponentModel.Design Namespace


MemberModifier Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public MemberModifier();
[C++]
public: MemberModifier();
[JScript]
public function MemberModifier();

See Also

MemberModifier Class | MemberModifier Members | System.ComponentModel.Design Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MemberModifier Fields

The fields of the MemberModifier class are listed below. For a complete list of MemberModifier class members, see the MemberModifier Members topic.

Public:

Abstract | Specifies that the member is abstract. This field is constant.
Const | Specifies that the member is abstract. This field is constant.
Extern | Specifies that the member is external. This field is constant.
Final | Specifies that the member is final. This field is constant.
Internal | Specifies that the member is internal. This field is constant.
Multicast | Specifies that the member is a multicast. This field is constant.
Native | Specifies that the member is native. This field is constant.
New | Specifies that the member is new. This field is constant.
Override | Specifies that the member is an override. This field is constant.
Private | Specifies that the member is private. This field is constant.
Protected | Specifies that the member is protected. This field is constant.
Public | Specifies that the member is public. This field is constant.
Readonly | Specifies that the member is read-only. This field is constant.
Sealed | Specifies that the member is sealed. This field is constant.
Static | Specifies that the member is static. This field is constant.
Synchronized | Specifies that the member is synchronized. This field is constant.
Transient | Specifies that the member is transient. This field is constant.
Unknown | Specifies that the member is unknown. This field is constant.
Value | Specifies that the member is a value. This field is constant.
Virtual | Specifies that the member is virtual. This field is constant.

See Also

MemberModifier Class | System.ComponentModel.Design Namespace


MemberModifier.Abstract

Specifies that the member is abstract. This field is constant.

[Visual Basic]
Public Const Abstract As Integer
[C#]
public const int Abstract;
[C++]
public: const int Abstract;
[JScript]
public var Abstract : int;

See Also

MemberModifier Class | MemberModifier Members | System.ComponentModel.Design Namespace


MemberModifier.Const

Specifies that the member is abstract. This field is constant.

[Visual Basic]
Public Const Const As Integer
[C#]
public const int Const;
[C++]
public: const int Const;
[JScript]
public var Const : int;

See Also

MemberModifier Class | MemberModifier Members | System.ComponentModel.Design Namespace


MemberModifier.Extern

Specifies that the member is external. This field is constant.

[Visual Basic]
Public Const Extern As Integer
[C#]
public const int Extern;
[C++]
public: const int Extern;
[JScript]
public var Extern : int;

See Also

MemberModifier Class | MemberModifier Members | System.ComponentModel.Design Namespace


MemberModifier.Final

Specifies that the member is final. This field is constant.

[Visual Basic]
Public Const Final As Integer
[C#]
public const int Final;
[C++]
public: const int Final;
[JScript]
public var Final : int;

See Also

MemberModifier Class | MemberModifier Members | System.ComponentModel.Design Namespace


MemberModifier.Internal

Specifies that the member is internal. This field is constant.

[Visual Basic]
Public Const Internal As Integer
[C#]
public const int Internal;
[C++]
public: const int Internal;
[JScript]
public var Internal : int;

See Also

MemberModifier Class | MemberModifier Members | System.ComponentModel.Design Namespace


MemberModifier.Multicast

Specifies that the member is a multicast. This field is constant.

[Visual Basic]
Public Const Multicast As Integer
[C#]
public const int Multicast;
[C++]
public: const int Multicast;
[JScript]
public var Multicast : int;

See Also

MemberModifier Class | MemberModifier Members | System.ComponentModel.Design Namespace


MemberModifier.Native

Specifies that the member is native. This field is constant.

[Visual Basic]
Public Const Native As Integer
[C#]
public const int Native;
[C++]
public: const int Native;
[JScript]
public var Native : int;

See Also

MemberModifier Class | MemberModifier Members | System.ComponentModel.Design Namespace


MemberModifier.New

Specifies that the member is new. This field is constant.

[Visual Basic]
Public Const New As Integer
[C#]
public const int New;
[C++]
public: const int New;
[JScript]
public var New : int;

See Also

MemberModifier Class | MemberModifier Members | System.ComponentModel.Design Namespace


MemberModifier.Override

Specifies that the member is an override. This field is constant.

[Visual Basic]
Public Const Override As Integer
[C#]
public const int Override;
[C++]
public: const int Override;
[JScript]
public var Override : int;

See Also

MemberModifier Class | MemberModifier Members | System.ComponentModel.Design Namespace


MemberModifier.Private

Specifies that the member is private. This field is constant.

[Visual Basic]
Public Const Private As Integer
[C#]
public const int Private;
[C++]
public: const int Private;
[JScript]
public var Private : int;

See Also

MemberModifier Class | MemberModifier Members | System.ComponentModel.Design Namespace


MemberModifier.Protected

Specifies that the member is protected. This field is constant.

[Visual Basic]
Public Const Protected As Integer
[C#]
public const int Protected;
[C++]
public: const int Protected;
[JScript]
public var Protected : int;

See Also

MemberModifier Class | MemberModifier Members | System.ComponentModel.Design Namespace


MemberModifier.Public

Specifies that the member is public. This field is constant.

[Visual Basic]
Public Const Public As Integer
[C#]
public const int Public;
[C++]
public: const int Public;
[JScript]
public var Public : int;

See Also

MemberModifier Class | MemberModifier Members | System.ComponentModel.Design Namespace


MemberModifier.Readonly

Specifies that the member is read-only. This field is constant.

[Visual Basic]
Public Const Readonly As Integer
[C#]
public const int Readonly;
[C++]
public: const int Readonly;
[JScript]
public var Readonly : int;

See Also

MemberModifier Class | MemberModifier Members | System.ComponentModel.Design Namespace


MemberModifier.Sealed

Specifies that the member is sealed. This field is constant.

[Visual Basic]
Public Const Sealed As Integer
[C#]
public const int Sealed;
[C++]
public: const int Sealed;
[JScript]
public var Sealed : int;

See Also

MemberModifier Class | MemberModifier Members | System.ComponentModel.Design Namespace


MemberModifier.Static

Specifies that the member is static. This field is constant.

[Visual Basic]
Public Const Static As Integer
[C#]
public const int Static;
[C++]
public: const int Static;
[JScript]
public var Static : int;

See Also

MemberModifier Class | MemberModifier Members | System.ComponentModel.Design Namespace


MemberModifier.Synchronized

Specifies that the member is synchronized. This field is constant.

[Visual Basic]
Public Const Synchronized As Integer
[C#]
public const int Synchronized;
[C++]
public: const int Synchronized;
[JScript]
public var Synchronized : int;

See Also

MemberModifier Class | MemberModifier Members | System.ComponentModel.Design Namespace


MemberModifier.Transient

Specifies that the member is transient. This field is constant.

[Visual Basic]
Public Const Transient As Integer
[C#]
public const int Transient;
[C++]
public: const int Transient;
[JScript]
public var Transient : int;

See Also

MemberModifier Class | MemberModifier Members | System.ComponentModel.Design Namespace


MemberModifier.Unknown

Specifies that the member is unknown. This field is constant.

[Visual Basic]
Public Const Unknown As Integer
[C#]
public const int Unknown;
[C++]
public: const int Unknown;
[JScript]
public var Unknown : int;

See Also

MemberModifier Class | MemberModifier Members | System.ComponentModel.Design Namespace


MemberModifier.Value

Specifies that the member is a value. This field is constant.

[Visual Basic]
Public Const Value As Integer
[C#]
public const int Value;
[C++]
public: const int Value;
[JScript]
public var Value : int;

See Also

MemberModifier Class | MemberModifier Members | System.ComponentModel.Design Namespace


MemberModifier.Virtual

Specifies that the member is virtual. This field is constant.

[Visual Basic]
Public Const Virtual As Integer
[C#]
public const int Virtual;
[C++]
public: const int Virtual;
[JScript]
public var Virtual : int;

See Also

MemberModifier Class | MemberModifier Members | System.ComponentModel.Design Namespace


MenuCommand Class

Represents a Windows menu or toolbar item.

Object
MenuCommand

[Visual Basic]
Public Class MenuCommand
[C#]
public class MenuCommand
[C++]
public __gc class MenuCommand
[JScript]
public class MenuCommand

Remarks

The physical layout of the menu is defined elsewhere, as are the names and icons on the menu.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

MenuCommand Members | System.ComponentModel.Design Namespace | IMenuCommandService | CommandID


MenuCommand Members

Public:

Constructor

MenuCommand Constructor Initializes a new instance of MenuCommand.

Properties

Checked | Gets or sets a value that indicates whether this menu item is checked.
CommandID | Gets the CommandID associated with this menu.
Enabled | Gets or sets a value that indicates whether this menu item is available.
OleStatus | Gets the OLE command status code for this menu item.
Supported | Gets or sets a value that indicates whether this menu item is supported.
Visible | Gets or sets a value that indicates if this menu item is visible.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Invoke | Invokes a menu item.
ToString | Overrides object's ToString().

Events

CommandChanged Occurs when the menu command changes.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnCommandChanged | Provides notification and is called in response to a CommandChanged event.

Event Hookup:

Methods

AddOnCommandChanged | Allows a caller to attach an event that will be called when this command changes.
RemoveOnCommandChanged | Removes a CommandChanged event handler.

See Also

MenuCommand Class | System.ComponentModel.Design Namespace


MenuCommand Constructor

Initializes a new instance of MenuCommand.

[Visual Basic]
Public Sub New( _
   ByVal handler As EventHandler, _
   ByVal command As CommandID _
)
[C#]
public MenuCommand(
   EventHandler handler,
   CommandID command
);
[C++]
public: MenuCommand(
   EventHandler* handler,
   CommandID* command
);
[JScript]
public function MenuCommand(
   handler : EventHandler,
   command : CommandID
);

Parameters

handler
The event to raise when the user selects the menu item or toolbar button.
command
The unique command ID that is used to link this menu command to the environment's menu.

Remarks

This menu command can then be added to the IMenuCommandService.

See Also

MenuCommand Class | MenuCommand Members | System.ComponentModel.Design Namespace | IMenuCommandService | CommandID


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MenuCommand Properties

The properties of the MenuCommand class are listed below. For a complete list of MenuCommand class members, see the MenuCommand Members topic.

Public:

Checked | Gets or sets a value that indicates whether this menu item is checked.
CommandID | Gets the CommandID associated with this menu.
Enabled | Gets or sets a value that indicates whether this menu item is available.
OleStatus | Gets the OLE command status code for this menu item.
Supported | Gets or sets a value that indicates whether this menu item is supported.
Visible | Gets or sets a value that indicates if this menu item is visible.

See Also

MenuCommand Class | System.ComponentModel.Design Namespace


MenuCommand.Checked

Gets or sets a value that indicates whether this menu item is checked.

[Visual Basic]
Overridable Public Property Checked As Boolean
[C#]
public bool Checked {virtual get; virtual set;}
[C++]
public: __property virtual bool get_Checked();
public: __property virtual void set_Checked(bool);
[JScript]
public function get Checked() : Boolean;
public function set Checked(Boolean);

Property Value

true if the item is checked; otherwise, false.

See Also

MenuCommand Class | MenuCommand Members | System.ComponentModel.Design Namespace


MenuCommand.CommandID

Gets the CommandID associated with this menu.

[Visual Basic]
Overridable Public ReadOnly Property CommandID As CommandID
[C#]
public CommandID CommandID {virtual get;}
[C++]
public: __property virtual CommandID* get_CommandID();
[JScript]
public function get CommandID() : CommandID;

See Also

MenuCommand Class | MenuCommand Members | System.ComponentModel.Design Namespace | CommandID


MenuCommand.Enabled

Gets or sets a value that indicates whether this menu item is available.

[Visual Basic]
Overridable Public Property Enabled As Boolean
[C#]
public bool Enabled {virtual get; virtual set;}
[C++]
public: __property virtual bool get_Enabled();
public: __property virtual void set_Enabled(bool);
[JScript]
public function get Enabled() : Boolean;
public function set Enabled(Boolean);

Property Value

true if the item is enabled; otherwise, false.

See Also

MenuCommand Class | MenuCommand Members | System.ComponentModel.Design Namespace


MenuCommand.OleStatus

Gets the OLE command status code for this menu item.

[Visual Basic]
Overridable Public ReadOnly Property OleStatus As Integer
[C#]
public int OleStatus {virtual get;}
[C++]
public: __property virtual int get_OleStatus();
[JScript]
public function get OleStatus() : int;

Property Value

An integer containing a mixture of status flags that reflect the state of this menu item.

See Also

MenuCommand Class | MenuCommand Members | System.ComponentModel.Design Namespace


MenuCommand.Supported

Gets or sets a value that indicates whether this menu item is supported.

[Visual Basic]
Overridable Public Property Supported As Boolean
[C#]
public bool Supported {virtual get; virtual set;}
[C++]
public: __property virtual bool get_Supported();
public: __property virtual void set_Supported(bool);
[JScript]
public function get Supported() : Boolean;
public function set Supported(Boolean);

Property Value

true if the item is supported, which is the default; otherwise, false.

See Also

MenuCommand Class | MenuCommand Members | System.ComponentModel.Design Namespace


MenuCommand.Visible

Gets or sets a value that indicates if this menu item is visible.

[Visual Basic]
Overridable Public Property Visible As Boolean
[C#]
public bool Visible {virtual get; virtual set;}
[C++]
public: __property virtual bool get_Visible();
public: __property virtual void set_Visible(bool);
[JScript]
public function get Visible() : Boolean;
public function set Visible(Boolean);

Property Value

true if the item is visible, otherwise false.

See Also

MenuCommand Class | MenuCommand Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MenuCommand Methods

The methods of the MenuCommand class are listed below. For a complete list of MenuCommand class members, see the MenuCommand Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Invoke | Invokes a menu item.
ToString | Overrides object's ToString().

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnCommandChanged | Provides notification and is called in response to a CommandChanged event.

Event Hookup:

AddOnCommandChanged | Allows a caller to attach an event that will be called when this command changes.
RemoveOnCommandChanged | Removes a CommandChanged event handler.

See Also

MenuCommand Class | System.ComponentModel.Design Namespace


MenuCommand.AddOnCommandChanged

Allows a caller to attach an event that will be called when this command changes.

[Visual Basic]
Overridable Public Sub AddOnCommandChanged( _
   ByVal handler As EventHandler _
)
[C#]
public virtual void AddOnCommandChanged(
   EventHandler handler
);
[C++]
public: virtual void AddOnCommandChanged(
   EventHandler* handler
);
[JScript]
public function AddOnCommandChanged(
   handler : EventHandler
);

Parameters

handler
The event handler to add.

Remarks

A command may change if it becomes checked or disabled.

See Also

MenuCommand Class | MenuCommand Members | System.ComponentModel.Design Namespace


MenuCommand.Invoke

Invokes a menu item.

[Visual Basic]
Overridable Public Sub Invoke()
[C#]
public virtual void Invoke();
[C++]
public: virtual void Invoke();
[JScript]
public function Invoke();

See Also

MenuCommand Class | MenuCommand Members | System.ComponentModel.Design Namespace


MenuCommand.OnCommandChanged

Provides notification and is called in response to a CommandChanged event.

[Visual Basic]
Overridable Protected Sub OnCommandChanged( _
   ByVal e As EventArgs _
)
[C#]
protected virtual void OnCommandChanged(
   EventArgs e
);
[C++]
protected: virtual void OnCommandChanged(
   EventArgs* e
);
[JScript]
protected function OnCommandChanged(
   e : EventArgs
);

Parameters

e
An EventArgs that contains the event data.

See Also

MenuCommand Class | MenuCommand Members | System.ComponentModel.Design Namespace


MenuCommand.RemoveOnCommandChanged

Removes a CommandChanged event handler.

[Visual Basic]
Overridable Public Sub RemoveOnCommandChanged( _
   ByVal handler As EventHandler _
)
[C#]
public virtual void RemoveOnCommandChanged(
   EventHandler handler
);
[C++]
public: virtual void RemoveOnCommandChanged(
   EventHandler* handler
);
[JScript]
public function RemoveOnCommandChanged(
   handler : EventHandler
);

Parameters

handler
The event handler to remove.

See Also

MenuCommand Class | MenuCommand Members | System.ComponentModel.Design Namespace


MenuCommand.ToString

Overrides object's ToString().

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

MenuCommand Class | MenuCommand Members | System.ComponentModel.Design Namespace


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MenuCommand Events

The events of the MenuCommand class are listed below. For a complete list of MenuCommand class members, see the MenuCommand Members topic.

Public:

CommandChanged Occurs when the menu command changes.

See Also

MenuCommand Class | System.ComponentModel.Design Namespace


MenuCommand CommandChanged Event

Occurs when the menu command changes.

The following declaration shows the syntax for a method that handles the CommandChanged event.

[Visual Basic]
Private Sub MenuCommandName_CommandChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
private void MenuCommandName_CommandChanged(
   object sender,
   EventArgs e
);
[C++]
private: void MenuCommandName_CommandChanged(
   Object* sender,
   EventArgs* e
);
[JScript]
private MenuCommandName_CommandChanged(
   sender : Object,
   e : EventArgs
);

Parameters

sender
The source of the event.
e
An EventArgs that contains the event data. The following EventArgs properties provide information specific to this event.
Property Description
ExtendedInfo
Holds a reference to an object that manages the event's state.

Remarks

A command may change if it becomes checked or disabled.

See Also

MenuCommand Class | MenuCommand MembersTopic | System.ComponentModel.Design Namespace


NameEditor Class

[To be supplied.]

Object
ValueEditor
NameEditor

[Visual Basic]
Public Class NameEditor
   Inherits ValueEditor
[C#]
public class NameEditor : ValueEditor
[C++]
public __gc class NameEditor : public ValueEditor
[JScript]
public class NameEditor extends ValueEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

NameEditor Members | System.ComponentModel.Design Namespace


NameEditor Members

Public:

Constructor

NameEditor Constructor [To be supplied.]

Properties

Style (inherited from ValueEditor) | [To be supplied.]
Values (inherited from ValueEditor) | [To be supplied.]

Methods

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from ValueEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue (inherited from ValueEditor) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NameEditor Class | System.ComponentModel.Design Namespace


NameEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public NameEditor();
[C++]
public: NameEditor();
[JScript]
public function NameEditor();

See Also

NameEditor Class | NameEditor Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

NameEditor Methods

The methods of the NameEditor class are listed below. For a complete list of NameEditor class members, see the NameEditor Members topic.

Public:

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from ValueEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue (inherited from ValueEditor) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NameEditor Class | System.ComponentModel.Design Namespace


NameEditor.GetValueFromText

[To be supplied.]

[Visual Basic]
Overrides Public Function GetValueFromText( _
   ByVal text As String _
) As Object
[C#]
public override object GetValueFromText(
   string text
);
[C++]
public: override Object* GetValueFromText(
   String* text
);
[JScript]
public override function GetValueFromText(
   text : String
) : Object;

Parameters

text
[To be supplied.]

See Also

NameEditor Class | NameEditor Members | System.ComponentModel.Design Namespace


NonEditableReferenceEditor Class

NonEditableReferenceEditor is an editor that displays the name of a component. Other references can not be substituted.

Object
ValueEditor
ReferenceEditor
NonEditableReferenceEditor

[Visual Basic]
Public Class NonEditableReferenceEditor
   Inherits ReferenceEditor
[C#]
public class NonEditableReferenceEditor : ReferenceEditor
[C++]
public __gc class NonEditableReferenceEditor : public
   ReferenceEditor
[JScript]
public class NonEditableReferenceEditor extends ReferenceEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

NonEditableReferenceEditor Members | System.ComponentModel.Design Namespace | ValueEditor | IContainer | IComponent


NonEditableReferenceEditor Members

Public:

Constructor

NonEditableReferenceEditor Constructor Constructs a NonEditableReferenceEditor. The site contains the hosting component and the type to look for.

Properties

Style (inherited from ReferenceEditor) | [To be supplied.]
Values (inherited from ReferenceEditor) | Retrieves the components on the form that can be assigned to the type of the editor.

Methods

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from ValueEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue (inherited from ReferenceEditor) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from ReferenceEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

Container (inherited from ReferenceEditor) | [To be supplied.]
ReferenceService (inherited from ReferenceEditor) | [To be supplied.]
Type (inherited from ReferenceEditor) | [To be supplied.]

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NonEditableReferenceEditor Class | System.ComponentModel.Design Namespace


NonEditableReferenceEditor Constructor

Constructs a NonEditableReferenceEditor. The site contains the hosting component and the type to look for.

[Visual Basic]
Public Sub New( _
   ByVal site As IEditorSite _
)
[C#]
public NonEditableReferenceEditor(
   IEditorSite site
);
[C++]
public: NonEditableReferenceEditor(
   IEditorSite* site
);
[JScript]
public function NonEditableReferenceEditor(
   site : IEditorSite
);

Parameters

site
[To be supplied.]

See Also

NonEditableReferenceEditor Class | NonEditableReferenceEditor Members | System.ComponentModel.Design Namespace


NotifyParentPropertyAttribute Class

Indicates whether the parent property is notified if a child namespace property is modified.

Object
Attribute
MemberAttribute
NotifyParentPropertyAttribute

[Visual Basic]
Public Class NotifyParentPropertyAttribute
   Inherits MemberAttribute
[C#]
public class NotifyParentPropertyAttribute : MemberAttribute
[C++]
public __gc class NotifyParentPropertyAttribute : public
   MemberAttribute
[JScript]
public class NotifyParentPropertyAttribute extends MemberAttribute

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

NotifyParentPropertyAttribute Members | System.ComponentModel.Design Namespace | System.ComponentModel.Design.MemberAttribute


NotifyParentPropertyAttribute Members

Public:

Constructor

NotifyParentPropertyAttribute Constructor Initiailzes a new instance of System.ComponentModel.Design.NotifyPropertyAttribute that uses the specified value to indicate whether the parent property should be notified when a child namespace property is modified.

Properties

NotifyParent | Gets or sets whether the parent property should be notified on changes to a child namespace property.
TypeId (inherited from MemberAttribute) | Gets a unique ID for this MemberAttribute.

Methods

Equals | Tests whether the specified object is the same as the current object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsDefaultAttribute | Gets whether this attribute is true by default.
Match (inherited from MemberAttribute) | Determines whether one attribute matches another.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Default | Specifies the default attribute state, that the parent property should not be notified on changes to the child class property. This field is read-only.
No | Specifies that the parent property should not be notified on changes to the child class property. This field is read-only.
Yes | Specifies that the parent property should be notified on changes to the child class property. This field is read-only.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NotifyParentPropertyAttribute Class | System.ComponentModel.Design Namespace


NotifyParentPropertyAttribute Constructor

Initiailzes a new instance of System.ComponentModel.Design.NotifyPropertyAttribute that uses the specified value to indicate whether the parent property should be notified when a child namespace property is modified.

[Visual Basic]
Public Sub New( _
   ByVal notifyParent As Boolean _
)
[C#]
public NotifyParentPropertyAttribute(
   bool notifyParent
);
[C++]
public: NotifyParentPropertyAttribute(
   bool notifyParent
);
[JScript]
public function NotifyParentPropertyAttribute(
   notifyParent : Boolean
);

Parameters

notifyParent
Whether the parent should be notified on changes.

See Also

NotifyParentPropertyAttribute Class | NotifyParentPropertyAttribute Members | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

NotifyParentPropertyAttribute Properties

The properties of the NotifyParentPropertyAttribute class are listed below. For a complete list of NotifyParentPropertyAttribute class members, see the NotifyParentPropertyAttribute Members topic.

Public:

NotifyParent | Gets or sets whether the parent property should be notified on changes to a child namespace property.
TypeId (inherited from MemberAttribute) | Gets a unique ID for this MemberAttribute.

See Also

NotifyParentPropertyAttribute Class | System.ComponentModel.Design Namespace


NotifyParentPropertyAttribute.NotifyParent

Gets or sets whether the parent property should be notified on changes to a child namespace property.

[Visual Basic]
Public ReadOnly Property NotifyParent As Boolean
[C#]
public bool NotifyParent {get;}
[C++]
public: __property bool get_NotifyParent();
[JScript]
public function get NotifyParent() : Boolean;

Property Value

true if the parent property should be notified on changes; otherwise, false.

See Also

NotifyParentPropertyAttribute Class | NotifyParentPropertyAttribute Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

NotifyParentPropertyAttribute Methods

The methods of the NotifyParentPropertyAttribute class are listed below. For a complete list of NotifyParentPropertyAttribute class members, see the NotifyParentPropertyAttribute Members topic.

Public:

Equals | Tests whether the specified object is the same as the current object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsDefaultAttribute | Gets whether this attribute is true by default.
Match (inherited from MemberAttribute) | Determines whether one attribute matches another.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NotifyParentPropertyAttribute Class | System.ComponentModel.Design Namespace


NotifyParentPropertyAttribute.Equals

Tests whether the specified object is the same as the current object.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The object to test for equality.

Return Value

true if the object is the same, false otherwise.

See Also

NotifyParentPropertyAttribute Class | NotifyParentPropertyAttribute Members | System.ComponentModel.Design Namespace


NotifyParentPropertyAttribute.IsDefaultAttribute

Gets whether this attribute is true by default.

[Visual Basic]
Overrides Public Function IsDefaultAttribute() As Boolean
[C#]
public override bool IsDefaultAttribute();
[C++]
public: override bool IsDefaultAttribute();
[JScript]
public override function IsDefaultAttribute() : Boolean;

Return Value

true if this attribute is true by default; otherwise, false.

See Also

NotifyParentPropertyAttribute Class | NotifyParentPropertyAttribute Members | System.ComponentModel.Design Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

NotifyParentPropertyAttribute Fields

The fields of the NotifyParentPropertyAttribute class are listed below. For a complete list of NotifyParentPropertyAttribute class members, see the NotifyParentPropertyAttribute Members topic.

Public:

Default | Specifies the default attribute state, that the parent property should not be notified on changes to the child class property. This field is read-only.
No | Specifies that the parent property should not be notified on changes to the child class property. This field is read-only.
Yes | Specifies that the parent property should be notified on changes to the child class property. This field is read-only.

See Also

NotifyParentPropertyAttribute Class | System.ComponentModel.Design Namespace


NotifyParentPropertyAttribute.Default

Specifies the default attribute state, that the parent property should not be notified on changes to the child class property. This field is read-only.

[Visual Basic]
Public Shared ReadOnly Default As NotifyParentPropertyAttribute
[C#]
public static readonly NotifyParentPropertyAttribute Default;
[C++]
public: static readonly NotifyParentPropertyAttribute* Default;
[JScript]
public static var Default : NotifyParentPropertyAttribute;

See Also

NotifyParentPropertyAttribute Class | NotifyParentPropertyAttribute Members | System.ComponentModel.Design Namespace


NotifyParentPropertyAttribute.No

Specifies that the parent property should not be notified on changes to the child class property. This field is read-only.

[Visual Basic]
Public Shared ReadOnly No As NotifyParentPropertyAttribute
[C#]
public static readonly NotifyParentPropertyAttribute No;
[C++]
public: static readonly NotifyParentPropertyAttribute* No;
[JScript]
public static var No : NotifyParentPropertyAttribute;

See Also

NotifyParentPropertyAttribute Class | NotifyParentPropertyAttribute Members | System.ComponentModel.Design Namespace


NotifyParentPropertyAttribute.Yes

Specifies that the parent property should be notified on changes to the child class property. This field is read-only.

[Visual Basic]
Public Shared ReadOnly Yes As NotifyParentPropertyAttribute
[C#]
public static readonly NotifyParentPropertyAttribute Yes;
[C++]
public: static readonly NotifyParentPropertyAttribute* Yes;
[JScript]
public static var Yes : NotifyParentPropertyAttribute;

See Also

NotifyParentPropertyAttribute Class | NotifyParentPropertyAttribute Members | System.ComponentModel.Design Namespace


NumericFormatEditor Class

[To be supplied.]

Object
ValueEditor
AliasEditor
NumericFormatEditor

[Visual Basic]
Public Class NumericFormatEditor
   Inherits AliasEditor
[C#]
public class NumericFormatEditor : AliasEditor
[C++]
public __gc class NumericFormatEditor : public AliasEditor
[JScript]
public class NumericFormatEditor extends AliasEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

NumericFormatEditor Members | System.ComponentModel.Design Namespace


NumericFormatEditor Members

Public:

Constructor

NumericFormatEditor Constructor [To be supplied.]

Properties

Style (inherited from AliasEditor) | [To be supplied.]
Values (inherited from AliasEditor) | [To be supplied.]

Methods

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from ValueEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue (inherited from AliasEditor) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from AliasEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NumericFormatEditor Class | System.ComponentModel.Design Namespace


NumericFormatEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public NumericFormatEditor();
[C++]
public: NumericFormatEditor();
[JScript]
public function NumericFormatEditor();

See Also

NumericFormatEditor Class | NumericFormatEditor Members | System.ComponentModel.Design Namespace


NumericFormatTypeEditor Class

[To be supplied.]

Object
ValueEditor
TypeListEditor
NumericFormatTypeEditor

[Visual Basic]
Public Class NumericFormatTypeEditor
   Inherits TypeListEditor
[C#]
public class NumericFormatTypeEditor : TypeListEditor
[C++]
public __gc class NumericFormatTypeEditor : public TypeListEditor
[JScript]
public class NumericFormatTypeEditor extends TypeListEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

NumericFormatTypeEditor Members | System.ComponentModel.Design Namespace


NumericFormatTypeEditor Members

Public:

Constructor

NumericFormatTypeEditor Constructor [To be supplied.]

Properties

Style (inherited from TypeListEditor) | [To be supplied.]
Values (inherited from TypeListEditor) | [To be supplied.]

Methods

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from TypeListEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue (inherited from TypeListEditor) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from TypeListEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NumericFormatTypeEditor Class | System.ComponentModel.Design Namespace


NumericFormatTypeEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public NumericFormatTypeEditor();
[C++]
public: NumericFormatTypeEditor();
[JScript]
public function NumericFormatTypeEditor();

See Also

NumericFormatTypeEditor Class | NumericFormatTypeEditor Members | System.ComponentModel.Design Namespace


ObjectPropertiesEditor Class

[To be supplied.]

Object
ValueEditor
ObjectPropertiesEditor

[Visual Basic]
Public Class ObjectPropertiesEditor
   Inherits ValueEditor
[C#]
public class ObjectPropertiesEditor : ValueEditor
[C++]
public __gc class ObjectPropertiesEditor : public ValueEditor
[JScript]
public class ObjectPropertiesEditor extends ValueEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

ObjectPropertiesEditor Members | System.ComponentModel.Design Namespace


ObjectPropertiesEditor Members

Public:

Constructor

ObjectPropertiesEditor Constructor [To be supplied.]

Properties

Style | [To be supplied.]
Values (inherited from ValueEditor) | [To be supplied.]

Methods

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from ValueEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from ValueEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ObjectPropertiesEditor Class | System.ComponentModel.Design Namespace


ObjectPropertiesEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ObjectPropertiesEditor();
[C++]
public: ObjectPropertiesEditor();
[JScript]
public function ObjectPropertiesEditor();

See Also

ObjectPropertiesEditor Class | ObjectPropertiesEditor Members | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ObjectPropertiesEditor Properties

The properties of the ObjectPropertiesEditor class are listed below. For a complete list of ObjectPropertiesEditor class members, see the ObjectPropertiesEditor Members topic.

Public:

Style | [To be supplied.]
Values (inherited from ValueEditor) | [To be supplied.]

See Also

ObjectPropertiesEditor Class | System.ComponentModel.Design Namespace


ObjectPropertiesEditor.Style

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Style As ValueEditorStyles
[C#]
public ValueEditorStyles Style {override get;}
[C++]
public: __property virtual ValueEditorStyles get_Style();
[JScript]
public function get Style() : ValueEditorStyles;

See Also

ObjectPropertiesEditor Class | ObjectPropertiesEditor Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ObjectPropertiesEditor Methods

The methods of the ObjectPropertiesEditor class are listed below. For a complete list of ObjectPropertiesEditor class members, see the ObjectPropertiesEditor Members topic.

Public:

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from ValueEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from ValueEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ObjectPropertiesEditor Class | System.ComponentModel.Design Namespace


ObjectPropertiesEditor.GetTextFromValue

[To be supplied.]

[Visual Basic]
Overrides Public Function GetTextFromValue( _
   ByVal value As Object _
) As String
[C#]
public override string GetTextFromValue(
   object value
);
[C++]
public: override String* GetTextFromValue(
   Object* value
);
[JScript]
public override function GetTextFromValue(
   value : Object
) : String;

Parameters

value
[To be supplied.]

See Also

ObjectPropertiesEditor Class | ObjectPropertiesEditor Members | System.ComponentModel.Design Namespace


ObjectSelectorEditor Class

[To be supplied.]

Object
UITypeEditor
ObjectSelectorEditor

[Visual Basic]
MustInherit Public Class ObjectSelectorEditor
   Inherits UITypeEditor
[C#]
public abstract class ObjectSelectorEditor : UITypeEditor
[C++]
public __gc __abstract class ObjectSelectorEditor : public
   UITypeEditor
[JScript]
public abstract class ObjectSelectorEditor extends UITypeEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

ObjectSelectorEditor Members | System.ComponentModel.Design Namespace


ObjectSelectorEditor Members

Public:

Constructor

ObjectSelectorEditor Constructor Overloaded. [To be supplied.]

Methods

EditValue | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
EqualsToValue | [To be supplied.]
GetEditStyle (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
SetValue | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

subObjectSelector [To be supplied.]

Protected:

Methods

FillTreeWithData | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

currValue | [To be supplied.]
prevValue | [To be supplied.]

See Also

ObjectSelectorEditor Class | System.ComponentModel.Design Namespace


ObjectSelectorEditor Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public ObjectSelectorEditor();
[C++] public: ObjectSelectorEditor();
[JScript] public function ObjectSelectorEditor();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Boolean)
[C#] public ObjectSelectorEditor(bool);
[C++] public: ObjectSelectorEditor(bool);
[JScript] public function ObjectSelectorEditor(Boolean);

See Also

ObjectSelectorEditor Class | ObjectSelectorEditor Members | System.ComponentModel.Design Namespace


ObjectSelectorEditor Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public ObjectSelectorEditor();
[C++]
public: ObjectSelectorEditor();
[JScript]
public function ObjectSelectorEditor();

See Also

ObjectSelectorEditor Class | ObjectSelectorEditor Members | System.ComponentModel.Design Namespace | ObjectSelectorEditor Constructor Overload List


ObjectSelectorEditor Constructor (Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal subObjectSelector As Boolean _
)
[C#]
public ObjectSelectorEditor(
   bool subObjectSelector
);
[C++]
public: ObjectSelectorEditor(
   bool subObjectSelector
);
[JScript]
public function ObjectSelectorEditor(
   subObjectSelector : Boolean
);

Parameters

subObjectSelector
[To be supplied.]

See Also

ObjectSelectorEditor Class | ObjectSelectorEditor Members | System.ComponentModel.Design Namespace | ObjectSelectorEditor Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ObjectSelectorEditor Methods

The methods of the ObjectSelectorEditor class are listed below. For a complete list of ObjectSelectorEditor class members, see the ObjectSelectorEditor Members topic.

Public:

EditValue | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
EqualsToValue | [To be supplied.]
GetEditStyle (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
SetValue | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

FillTreeWithData | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ObjectSelectorEditor Class | System.ComponentModel.Design Namespace


ObjectSelectorEditor.EditValue

[To be supplied.]

[Visual Basic]
Overrides Public Function EditValue( _
   ByVal context As ITypeDescriptorContext, _
   ByVal provider As IServiceObjectProvider, _
   ByVal value As Object _
) As Object
[C#]
public override object EditValue(
   ITypeDescriptorContext context,
   IServiceObjectProvider provider,
   object value
);
[C++]
public: override Object* EditValue(
   ITypeDescriptorContext* context,
   IServiceObjectProvider* provider,
   Object* value
);
[JScript]
public override function EditValue(
   context : ITypeDescriptorContext,
   provider : IServiceObjectProvider,
   value : Object
) : Object;

Parameters

context
[To be supplied.]
provider
[To be supplied.]
value
[To be supplied.]

See Also

ObjectSelectorEditor Class | ObjectSelectorEditor Members | System.ComponentModel.Design Namespace


ObjectSelectorEditor.EqualsToValue

[To be supplied.]

[Visual Basic]
Public Function EqualsToValue( _
   ByVal value As Object _
) As Boolean
[C#]
public bool EqualsToValue(
   object value
);
[C++]
public: bool EqualsToValue(
   Object* value
);
[JScript]
public function EqualsToValue(
   value : Object
) : Boolean;

Parameters

value
[To be supplied.]

See Also

ObjectSelectorEditor Class | ObjectSelectorEditor Members | System.ComponentModel.Design Namespace


ObjectSelectorEditor.FillTreeWithData

[To be supplied.]

[Visual Basic]
Overridable Protected Sub FillTreeWithData( _
   ByVal selector As ObjectSelectorEditor.Selector, _
   ByVal context As ITypeDescriptorContext, _
   ByVal provider As IServiceObjectProvider _
)
[C#]
protected virtual void FillTreeWithData(
   ObjectSelectorEditor.Selector selector,
   ITypeDescriptorContext context,
   IServiceObjectProvider provider
);
[C++]
protected: virtual void FillTreeWithData(
   ObjectSelectorEditor.Selector* selector,
   ITypeDescriptorContext* context,
   IServiceObjectProvider* provider
);
[JScript]
protected function FillTreeWithData(
   selector : ObjectSelectorEditor.Selector,
   context : ITypeDescriptorContext,
   provider : IServiceObjectProvider
);

Parameters

selector
[To be supplied.]
context
[To be supplied.]
provider
[To be supplied.]

See Also

ObjectSelectorEditor Class | ObjectSelectorEditor Members | System.ComponentModel.Design Namespace


ObjectSelectorEditor.GetEditStyle

[To be supplied.]

[Visual Basic]
Overrides Public Function GetEditStyle( _
   ByVal context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
[C#]
public override UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext context
);
[C++]
public: override UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetEditStyle(
   context : ITypeDescriptorContext
) : UITypeEditorEditStyle;

Parameters

context
[To be supplied.]

See Also

ObjectSelectorEditor Class | ObjectSelectorEditor Members | System.ComponentModel.Design Namespace


ObjectSelectorEditor.SetValue

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetValue( _
   ByVal value As Object _
)
[C#]
public virtual void SetValue(
   object value
);
[C++]
public: virtual void SetValue(
   Object* value
);
[JScript]
public function SetValue(
   value : Object
);

Parameters

value
[To be supplied.]

See Also

ObjectSelectorEditor Class | ObjectSelectorEditor Members | System.ComponentModel.Design Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ObjectSelectorEditor Fields

The fields of the ObjectSelectorEditor class are listed below. For a complete list of ObjectSelectorEditor class members, see the ObjectSelectorEditor Members topic.

Public:

subObjectSelector [To be supplied.]

Protected:

currValue | [To be supplied.]
prevValue | [To be supplied.]

See Also

ObjectSelectorEditor Class | System.ComponentModel.Design Namespace


ObjectSelectorEditor.currValue

[To be supplied.]

[Visual Basic]
Protected currValue As Object
[C#]
protected object currValue;
[C++]
protected: Object* currValue;
[JScript]
protected var currValue : Object;

See Also

ObjectSelectorEditor Class | ObjectSelectorEditor Members | System.ComponentModel.Design Namespace


ObjectSelectorEditor.prevValue

[To be supplied.]

[Visual Basic]
Protected prevValue As Object
[C#]
protected object prevValue;
[C++]
protected: Object* prevValue;
[JScript]
protected var prevValue : Object;

See Also

ObjectSelectorEditor Class | ObjectSelectorEditor Members | System.ComponentModel.Design Namespace


ObjectSelectorEditor.subObjectSelector

[To be supplied.]

[Visual Basic]
Public subObjectSelector As Boolean
[C#]
public bool subObjectSelector;
[C++]
public: bool subObjectSelector;
[JScript]
public var subObjectSelector : Boolean;

See Also

ObjectSelectorEditor Class | ObjectSelectorEditor Members | System.ComponentModel.Design Namespace


ObjectSelectorEditor.Selector Class

[To be supplied.]

Object
MarshalByRefObject
MarshalByRefComponent
Control
RichControl
TreeView
ObjectSelectorEditor.Selector

[Visual Basic]
Public Class ObjectSelectorEditor.Selector
   Inherits TreeView
[C#]
public class ObjectSelectorEditor.Selector : TreeView
[C++]
public __gc class ObjectSelectorEditor.Selector : public TreeView
[JScript]
public class ObjectSelectorEditor.Selector extends TreeView

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

ObjectSelectorEditor.Selector Members | System.ComponentModel.Design Namespace


ObjectSelectorEditor.Selector Members

Public:

Constructor

ObjectSelectorEditorSelector Constructor [To be supplied.]

Properties

AccessibilityObject (inherited from RichControl) | The Accessibility Object for this RichControl
AccessibleDefaultActionDescription (inherited from RichControl) | The default action description of the control
AccessibleDescription (inherited from RichControl) | The accessible description of the control
AccessibleHelpProvider (inherited from RichControl) | The help provider for this RichControl
AccessibleName (inherited from RichControl) | The accessible name of the control
AccessibleRole (inherited from RichControl) | The accessible role of the control
AllowDrop (inherited from RichControl) | The allowDrop property. If allowDrop is set to true then this control will allow drag and drop operations and events to be used.
AllowTransparency (inherited from RichControl) | Determines if the control should be allowed to have the opacity adjusted. This is primarily a performance optimization, in that you can always set the opacity to any value, and that will force AllowTransparency to true. However, setting the opacity to any given value will switch the control into layered mode. By setting the AllowTransparency property to false the control will actually switch out of layered mode, which provides better performance if you don't intend to adjust the opacity.
Anchor (inherited from RichControl) | The current value of the anchor property. The anchor property determines which edges of the control are anchored to the container's edges.
BackColor (inherited from TreeView) | The background color for this control. Specifying null for this parameter sets the control's background color to its parent's background color.
BackgroundImage (inherited from TreeView) | [To be supplied.]
BindingManager (inherited from RichControl) | [To be supplied.]
Bindings (inherited from RichControl) | Retrieves the bindings for this control.
BorderStyle (inherited from TreeView) | The border style of the window.
Bottom (inherited from Control) | The bottom coordinate of this control.
Bounds (inherited from Control) | The bounds of this control. This is the window coordinates of the control in parent client coordinates.
CanFocus (inherited from Control) | Checks if this control can receive focus. The result is true if the control has a handle and if it and all of its parent controls are both visible and enabled.
CanSelect (inherited from Control) | Checks if this control can be selected. The result is true if the control is contained in a form and if all of its parent controls are both visible and enabled.
Capture (inherited from Control) | If this control has captured the mouse then this will return true.
CausesValidation (inherited from Control) | Indicates whether entering this control causes validation on the controls requiring validation. This is set to false usually for things like the Help button, etc...
CheckBoxes (inherited from TreeView) | The value of the CheckBoxes property. The CheckBoxes property determines if check boxes are shown next to node in the tree view.
ClientRectangle (inherited from Control) | The client rect of the control.
ClientSize (inherited from Control) | The size of the clientRect.
CompanyName (inherited from RichControl) | Retrieves the company name of this specific component.
ContainsFocus (inherited from Control) | Indicates whether the control or one of its children currently has the system focus.
ContextMenu (inherited from RichControl) | The contextMenu associated with this control. The contextMenu will be shown when the user right clicks the mouse on the control.
Controls (inherited from Control) | Collection of child controls.
Created (inherited from Control) | Returns true if the control has been created.
Cursor (inherited from RichControl) | Retrieves the cursor that will be displayed when the mouse is over this control.
DisplayRectangle (inherited from Control) | Returns the client rect of the display area of the control. For the base control class, this is identical to getClientRect. However, inheriting controls may want to change this if their client area differs from their display area.
Disposed (inherited from Control) | Indicates that the control has been disposed, and is no longer a valid Windows control even though the object instance is still alive.
Disposing (inherited from Control) | Indicates that the control is in the process of being beendisposed, and is no longer a valid Windows control even though the object instance is still alive.
Dock (inherited from RichControl) | The dock property. The dock property controls to which edge of the container this control is docked to. For example, when docked to the top of the container, the control will be displayed flush at the top of the container, extending the length of the container.
Enabled (inherited from Control) | The current enabled state of this control.
Focused (inherited from Control) | Returns true if this control has focus.
Font (inherited from RichControl) | Retrieves the current font for this control. This will be the font used by default for painting and text in the control.
ForeColor (inherited from TreeView) | The current foreground color for this control, which is the color the control uses to draw its text.
FullRowSelect (inherited from TreeView) | Determines whether the selection highlight spans across the width of the TreeView.
Handle (inherited from Control) | The HWND handle that this control is bound to. If the handle has not yet been created, this will force handle creation.
HandleCreated (inherited from Control) | Whether or not this control has a handle associated with it.
Height (inherited from Control) | The height of this control
HideSelection (inherited from TreeView) | The hideSelection property specifies whether the selected node will be highlighted even when the TreeView loses focus.
HotTracking (inherited from TreeView) | The value of the HotTracking property. The HotTracking property determines if nodes are highlighted as the mousepointer passes over them.
ImageIndex (inherited from TreeView) | The default image index for nodes in the tree view.
ImageList (inherited from TreeView) | Returns the image list control that is bound to the tree view.
IMEMode (inherited from RichControl) | Specifies a value that determines the IME (Input Method Editor) status of the object when that object is selected.
Indent (inherited from TreeView) | The indentation level in pixels.
InvokeRequired (inherited from RichControl) | Determines if the caller must call invoke when making method calls to this control. Controls in WinForms are bound to a specific thread, and are not thread safe. Therefore, if you are calling a control's method from a different thread, you must use the control's invoke method to marshal the call to the proper thread. This function can be used to determine if you must call invoke, which can be handy if you don't know what thread owns a control. There are five functions on a control that are safe to call from any thread: GetInvokeRequired, Invoke, BeginInvoke, EndInvoke and CreateGraphics. For all other metohd calls, you should use one of the invoke methods.
IsAccessible (inherited from RichControl) | Indicates whether or not this control is an accessible control i.e. whether it should be visible to accessibility applications.
ItemHeight (inherited from TreeView) | The height of every item in the tree view, in pixels.
LabelEdit (inherited from TreeView) | The LabelEdit property determines if the label text of nodes in the tree view is editable.
Left (inherited from Control) | The left coordinate of this control.
Location (inherited from Control) | The location of this control.
Nodes (inherited from TreeView) | The collection of nodes associated with this TreeView control
Opacity (inherited from RichControl) | Determines the opacity of the control. This can only be set on top level controls. Opacity requires Windows 2000 or later, and is ignored on earlier operating systems.
Parent (inherited from Control) | The parent of this control.
PathSeparator (inherited from TreeView) | The delimeter string used by TreeNode.getFullPath().
ProductName (inherited from RichControl) | Retrieves the product name of this specific component.
ProductVersion (inherited from RichControl) | Retrieves the product version of this specific component.
RecreatingHandle (inherited from Control) | This is true if the control is currently recreating its handle.
Region (inherited from RichControl) | The Region associated with this control. (defines the outline/silhouette/boundary of control)
Right (inherited from Control) | The right coordinate of this control.
RightToLeft (inherited from RichControl) | This is used for international applications where the language is written from RightToLeft. When this property is true, control placement and text will be from right to left.
Scrollable (inherited from TreeView) | [To be supplied.]
SelectedImageIndex (inherited from TreeView) | The image index that a node will display when selected. The index applies to the ImageList referred to by the imageList property,
SelectedNode (inherited from TreeView) | The currently selected tree node.
ShowLines (inherited from TreeView) | The ShowLines property determines if lines are drawn between nodes in the tree view.
ShowPlusMinus (inherited from TreeView) | The ShowPlusMinus property determines if the "plus/minus" expand button is shown next to tree nodes that have children.
ShowRootLines (inherited from TreeView) | Determines if lines are draw between nodes at the root of the tree view.
Site (inherited from MarshalByRefComponent) | Gets or sets the site of the component.
Size (inherited from Control) | The size of this control.
Sorted (inherited from TreeView) | The Sorted property determines if nodes in the tree view are sorted.
TabIndex (inherited from Control) | The tab index of this control. A tab index may consist of any valid integer number greater than or equal to zero. If more than one control on the same parent control has the same tab index, the z-order of the controls will be used to determine the order to pick the controls.
TabStop (inherited from Control) | A boolean value indicating whether the user can give the focus to this control using the TAB key.
Text (inherited from TreeView) | [To be supplied.]
Top (inherited from Control) | Top coordinate of this control.
TopLevel (inherited from Control) | true if this control is a top level window, meaning that it has no parent.
TopLevelControl (inherited from Control) | The top level control that contains this control. This doesn't have to be the same as the value returned from getForm since forms can be parented to other controls.
TopNode (inherited from TreeView) | The first visible node in the TreeView. Initially the first root node is at the top of the TreeView, but if the contents have been scrolled another node may be at the top.
Visible (inherited from Control) | Controls whether the control is visible.
VisibleCount (inherited from TreeView) | The count of fully visible nodes in the tree view. This number may be greater than the number of nodes in the control. The control calculates this value by dividing the height of the client window by the height of an item
Width (inherited from Control) | The width of this control.
WindowTarget (inherited from Control) | The target of Win32 window messages.

Methods

AddNode | [To be supplied.]
BeginInvoke (inherited from RichControl) | Overloaded. [To be supplied.]
BeginUpdate (inherited from TreeView) | Disables redrawing of the tree view. A call to beginUpdate() must be balanced by a following call to endUpdate(). Following a call to beginUpdate(), any redrawing caused by operations performed on the tree view is deferred until the call to endUpdate().
BringToFront (inherited from Control) | Brings this control to the front of the zorder.
CallWndProc (inherited from Control) | Dispatch the method to this window's wndProc directly.
Clear | [To be supplied.]
CollapseAll (inherited from TreeView) | Collapses all nodes at the root level.
Contains (inherited from Control) | Checks if a control is a child of this control.
CreateControl (inherited from Control) | Forces the creation of the control. This includes the creation of the handle, and any child controls.
CreateGraphics (inherited from RichControl) | Overloaded. [To be supplied.]
CreateWindowGraphics (inherited from RichControl) | Creates a Graphics for the entire window of the control rather than just it's client area. The controls foreground color and background color become the default values for the Graphics. The returned Graphics must be disposed through a call to its dispose() method when it is no longer needed. The Graphics Object is only valid for the duration of the current window's message.
Dispose (inherited from TreeView) | [To be supplied.]
DoDragDrop (inherited from RichControl) | Begins a drag operation. The allowedEffects determine which drag operations can occur. If the drag operation needs to interop with applications in another process, data should either be a base managed class (String, Bitmap, or Metafile) or some Object that implements System.ComponentModel.IPersistable. data can also be any Object that implements System.WinForms.IDataObject.
EndInvoke (inherited from RichControl) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult interface passed. If the async operation has not been completed, this function will block until the result is available.
EndUpdate (inherited from TreeView) | Reenables redrawing of the tree view. A call to beginUpdate() must be balanced by a following call to endUpdate(). Following a call to beginUpdate(), any redrawing caused by operations performed on the combo box is deferred until the call to endUpdate().
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
ExpandAll (inherited from TreeView) | Expands all nodes at the root level.
FindForm (inherited from RichControl) | Retrieves the form that this control is on. The control's parent may not be the same as the form.
Focus (inherited from Control) | Attempts to set focus to this control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified client coordinates.
GetContainer (inherited from MarshalByRefComponent) | Returns the component's container.
GetContainerControl (inherited from Control) | Returns the closest ContainerControl in the control's chain of parent controls and forms.
GetDesignMode (inherited from MarshalByRefComponent) | Determines whether the component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetNextControl (inherited from Control) | Retrieves the next control in the tab order of child controls.
GetNodeAt (inherited from TreeView) | Overloaded. [To be supplied.]
GetNodeCount (inherited from TreeView) | Returns count of nodes at root, optionally including all subtrees.
GetServiceObject (inherited from MarshalByRefComponent) | The implementation of IServiceObjectProvider
GetType (inherited from Object) | Gets the Type of the Object.
Hide (inherited from Control) | Hides the control by setting the visible property to false;
InitializeLifetimeService (inherited from MarshalByRefObject)
Invalidate (inherited from Control) | Overloaded. [To be supplied.]
Invoke (inherited from RichControl) | Overloaded. [To be supplied.]
PerformLayout (inherited from Control) | Overloaded. [To be supplied.]
PointToClient (inherited from Control) | Computes the location of the screen point p in client coords.
PointToScreen (inherited from Control) | Computes the location of the client point p in screen coords.
PreProcessMessage (inherited from Control) | This method is called by the application's message loop to pre-process input messages before they are dispatched. Possible values for the msg.message field are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR. If this method processes the message it must return true, in which case the message loop will not dispatch the message. For WM_KEYDOWN and WM_SYSKEYDOWN messages, preProcessMessage() first calls processCmdKey() to check for command keys such as accelerators and menu shortcuts. If processCmdKey() doesn't process the message, then isInputKey() is called to check whether the key message represents an input key for the control. Finally, if isInputKey() indicates that the control isn't interested in the key message, then processDialogKey() is called to check for dialog keys such as TAB, arrow keys, and mnemonics. For WM_CHAR messages, preProcessMessage() first calls isInputChar() to check whether the character message represents an input character for the control. If isInputChar() indicates that the control isn't interested in the character message, then processDialogChar() is called to check for dialog characters such as mnemonics. For WM_SYSCHAR messages, preProcessMessage() calls processDialogChar() to check for dialog characters such as mnemonics. When overriding preProcessMessage(), a control should return true to indicate that it has processed the message. For messages that aren't processed by the control, the result of "base.preProcessMessage()" should be returned. Controls will typically override one of the more specialized methods (isInputChar(), isInputKey(), processCmdKey(), processDialogChar(), or processDialogKey()) instead of overriding preProcessMessage().
RectangleToClient (inherited from Control) | Computes the location of the screen rectangle r in client coords.
RectangleToScreen (inherited from Control) | Computes the location of the client rectangle r in screen coords.
Refresh (inherited from Control) | Forces the control to invalidate and immediately repaint itself and any children.
ResetBackColor (inherited from RichControl) | Resets the back color to be based on the parent's back color.
ResetBindings (inherited from RichControl) | [To be supplied.]
ResetCursor (inherited from RichControl) | [To be supplied.]
ResetFont (inherited from RichControl) | Resets the font to be based on the parent's font.
ResetForeColor (inherited from RichControl) | Resets the fore color to be based on the parent's fore color.
ResetIndent (inherited from TreeView) | This resets the indentation to the system default.
ResetRightToLeft (inherited from RichControl) | Resets the RightToLeft to be the default.
ResetText (inherited from Control) | Resets the text to it's default value.
ResumeLayout (inherited from Control) | Overloaded. [To be supplied.]
Scale (inherited from Control) | Overloaded. [To be supplied.]
Select (inherited from Control) | Activates this control.
SelectNextControl (inherited from Control) | Selects the next control following ctl.
SendMessage (inherited from Control) | Overloaded. [To be supplied.]
SendToBack (inherited from Control) | sends this control to the back of the z-order
SetBounds (inherited from Control) | Overloaded. [To be supplied.]
SetClientSize (inherited from Control) | Sets the height and width of the client area of the control.
SetLocation (inherited from Control) | Sets the location of this control.
SetNewControls (inherited from Control) | Performs the work of setting the array of the child controls contained in this control.
SetSelection | [To be supplied.]
SetSize (inherited from Control) | Sets the size of this control.
ShouldPersistBackColor (inherited from TreeView) | Returns true if the backColor should be persisted in code gen.
ShouldPersistBindings (inherited from RichControl) | [To be supplied.]
ShouldPersistCursor (inherited from RichControl) | Returns true if the cursor should be persisted in code gen.
ShouldPersistFont (inherited from RichControl) | Returns true if the font should be persisted in code gen.
ShouldPersistForeColor (inherited from TreeView) | [To be supplied.]
ShouldPersistIndent (inherited from TreeView) | Retrieves true if the indent should be persisted in code gen.
ShouldPersistItemHeight (inherited from TreeView) | Retrieves true if the itemHeight should be persisted in code gen.
ShouldPersistLocation (inherited from Control) | Determines if the Location property needs to be persisted.
ShouldPersistRightToLeft (inherited from RichControl) | Returns true if the RightToLeft should be persisted in code gen.
ShouldPersistSize (inherited from Control) | Determines if the Size property needs to be persisted.
ShouldPersistText (inherited from Control) | Determines if the Text property needs to be persisted.
Show (inherited from Control) | Makes the control display by setting the visible property to true
Start | [To be supplied.]
Stop | [To be supplied.]
SuspendLayout (inherited from Control) | Suspends the layout logic for the control.
ToString (inherited from TreeView) | Returns a string representation for this control.
Update (inherited from Control) | Forces the control to paint any currently invalid areas.

Events

AfterCheck (inherited from TreeView) | [To be supplied.]
AfterCollapse (inherited from TreeView) | [To be supplied.]
AfterExpand (inherited from TreeView) | [To be supplied.]
AfterLabelEdit (inherited from TreeView) | [To be supplied.]
AfterSelect (inherited from TreeView) | [To be supplied.]
BeforeCheck (inherited from TreeView) | [To be supplied.]
BeforeCollapse (inherited from TreeView) | [To be supplied.]
BeforeExpand (inherited from TreeView) | [To be supplied.]
BeforeLabelEdit (inherited from TreeView) | [To be supplied.]
BeforeSelect (inherited from TreeView) | [To be supplied.]
Click (inherited from Control) | [To be supplied.]
ControlAdded (inherited from Control) | [To be supplied.]
ControlRemoved (inherited from Control) | [To be supplied.]
CreateHandle (inherited from Control) | [To be supplied.]
DestroyHandle (inherited from Control) | [To be supplied.]
DoubleClick (inherited from Control) | [To be supplied.]
DragDrop (inherited from RichControl) | [To be supplied.]
DragEnter (inherited from RichControl) | [To be supplied.]
DragLeave (inherited from RichControl) | [To be supplied.]
DragOver (inherited from RichControl) | [To be supplied.]
Enter (inherited from Control) | [To be supplied.]
GiveFeedback (inherited from RichControl) | [To be supplied.]
GotFocus (inherited from Control) | [To be supplied.]
Help (inherited from RichControl) | [To be supplied.]
Invalidate (inherited from RichControl) | [To be supplied.]
ItemDrag (inherited from TreeView) | [To be supplied.]
KeyDown (inherited from Control) | [To be supplied.]
KeyPress (inherited from Control) | [To be supplied.]
KeyUp (inherited from Control) | [To be supplied.]
Layout (inherited from Control) | [To be supplied.]
Leave (inherited from Control) | [To be supplied.]
LostFocus (inherited from Control) | [To be supplied.]
MouseDown (inherited from Control) | [To be supplied.]
MouseEnter (inherited from Control) | [To be supplied.]
MouseHover (inherited from Control) | [To be supplied.]
MouseLeave (inherited from Control) | [To be supplied.]
MouseMove (inherited from Control) | [To be supplied.]
MouseUp (inherited from Control) | [To be supplied.]
MouseWheel (inherited from Control) | [To be supplied.]
Move (inherited from Control) | [To be supplied.]
Paint (inherited from RichControl) | [To be supplied.]
PropertyChanged (inherited from Control) | [To be supplied.]
QueryContinueDrag (inherited from RichControl) | [To be supplied.]
Resize (inherited from Control) | [To be supplied.]
Validated (inherited from Control) | [To be supplied.]
Validating (inherited from Control) | [To be supplied.]

Fields

clickSeen [To be supplied.]

Protected:

Properties

CreateParams (inherited from TreeView) | [To be supplied.]
CreateThreadId (inherited from Control) | Retrieves the Win32 thread ID of the thread that created the handle for this control. If the control's handle hasn't been created yet, this method will return the current thread's ID.
FontHeight (inherited from RichControl) | [To be supplied.]
InternalHandle (inherited from Control) | Returns the current value of the handle. This may be zero if the handle has not been created.
ParkingFormHandle (inherited from RichControl) | [To be supplied.]
RenderRightToLeft (inherited from RichControl) | [To be supplied.]
RichParent (inherited from RichControl) | [To be supplied.]
WindowText (inherited from Control) | The current text of the Window; if the window has not yet been created, stores it in the control. If the window has been created, stores the text in the underlying win32 control. This property should be used whenever you want to get at the win32 control's text. For all other cases, use the Text property- but note that this is overridable, and any of your code that uses it will use the overridden version in controls that subclass your own.

Methods

AddEventHandler (inherited from Control) | [To be supplied.]
AssignParent (inherited from RichControl) | Assigns a new parent control. Sends out the appropriate property change notifications for properties that are affected by the change of parent.
ChildGotFocus (inherited from Control) | [To be supplied.]
CreateAccessibilityInstance (inherited from RichControl) | Constructs the new instance of the accessibility object for this control. Subclasses should not call base.CreateAccessibilityObject.
CreateControlsInstance (inherited from RichControl) | Constructs the new instance of the Controls collection objects. Subclasses should not call base.CreateControlsInstance.
CreateHandle (inherited from TreeView) | [To be supplied.]
DefWndProc (inherited from Control) | Sends the message to the default window proc.
DestroyHandle (inherited from RichControl) | [To be supplied.]
Finalize (inherited from Control) | [To be supplied.]
GetEventHandler (inherited from RichControl) | RichControl overrides the default implementation of this for AX sourcing. ActiveX controls can "freeze" their events, and we implement this by returning null here if events are frozen.
GetItemRenderStyles (inherited from TreeView) | Generates colors for each item. This can be overridden to provide colors on a per state/per node basis, rather than using the ForeColor/BackColor/NodeFont properties on TreeNode.
GetStyle (inherited from Control) | Retrieves the current value of the specified bit in the control's style. NOTE: This is control style, not the Win32 style of the hwnd.
InitLayout (inherited from RichControl) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | [To be supplied.]
InvokeLostFocus (inherited from Control) | [To be supplied.]
InvokeOnClick (inherited from Control) | [To be supplied.]
InvokePaint (inherited from RichControl) | [To be supplied.]
InvokePaintBackground (inherited from RichControl) | [To be supplied.]
IsInputChar (inherited from Control) | Determines if charCode is an input character that the control wants. This method is called during window message pre-processing to determine whether the given input character should be pre-processed or sent directly to the control. If isInputChar returns true, the given character is sent directly to the control. If isInputChar returns false, the character is pre-processed and only sent to the control if it is not consumed by the pre-processing phase. The pre-processing of a character includes checking whether the character is a mnemonic of another control.
IsInputKey (inherited from Control) | Determines if keyData is an input key that the control wants. This method is called during window message pre-processing to determine whether the given input key should be pre-processed or sent directly to the control. If isInputKey returns true, the given key is sent directly to the control. If isInputKey returns false, the key is pre-processed and only sent to the control if it is not consumed by the pre-processing phase. Keys that are pre-processed include TAB, RETURN, ESCAPE, and arrow keys.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from RichControl) | [To be supplied.]
OnAfterCheck (inherited from TreeView) | Fires the afterCheck event.
OnAfterCollapse (inherited from TreeView) | Fires the afterCollapse event.
OnAfterExpand (inherited from TreeView) | Fires the afterExpand event.
OnAfterLabelEdit (inherited from TreeView) | Fires the afterLabelEdit event.
OnAfterSelect | Overloaded. [To be supplied.]
OnBeforeCheck (inherited from TreeView) | Fires the beforeCheck event.
OnBeforeCollapse (inherited from TreeView) | Fires the beforeCollapse event.
OnBeforeExpand (inherited from TreeView) | Fires the beforeExpand event.
OnBeforeLabelEdit (inherited from TreeView) | Fires the beforeLabelEdit event.
OnBeforeSelect (inherited from TreeView) | Fires the beforeSelect event.
OnClick (inherited from Control) | This method actually raises the Click event. Inheriting classes should override this if they wish to be notified of a Click event. (This is far preferable to actually adding an event handler.) They should not, however, forget to call base.onClick(e); before exiting, to ensure that other recipients do actually get the event.
OnControlAdded (inherited from Control) | Called when a child control is added to this control.
OnControlRemoved (inherited from Control) | Called when a child control is removed from this control.
OnCreateControl (inherited from Control) | Called when the control is first created.
OnCreateHandle (inherited from TreeView) | [To be supplied.]
OnDestroyHandle (inherited from RichControl) | Inheriting classes should override this method to find out when the handle is about to be destroyed. Call base.onDestroyHandle last.
OnDoubleClick (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onDoubleClick to send this event to any registered event listeners.
OnDragDrop (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragDrop to send this event to any registered event listeners.
OnDragEnter (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragEnter to send this event to any registered event listeners.
OnDragLeave (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragLeave to send this event to any registered event listeners.
OnDragOver (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragOver to send this event to any registered event listeners.
OnEnter (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onEnter to send this event to any registered event listeners.
OnGiveFeedback (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onGiveFeedback to send this event to any registered event listeners.
OnGotFocus (inherited from RichControl) | [To be supplied.]
OnHelp (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onHelp to send this event to any registered event listeners.
OnInvalidate (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.OnInvalidate to send this event to any registered event listeners.
OnItemDrag (inherited from TreeView) | Fires the ItemDrag event.
OnKeyDown | [To be supplied.]
OnKeyPress | [To be supplied.]
OnKeyUp (inherited from TreeView) | Handles the OnBeforeCheck/ OnAfterCheck for keyboard clicks
OnLayout (inherited from RichControl) | Core layout logic. Inheriting controls should override this function to do any custom layout logic. It is not neccessary to call base.layoutCore, however for normal docking and anchoring functions to work, base.layoutCore must be called.
OnLeave (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onLeave to send this event to any registered event listeners.
OnLostFocus (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onLostFocus to send this event to any registered event listeners.
OnMouseDown (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseDown to send this event to any registered event listeners.
OnMouseEnter (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseEnter to send this event to any registered event listeners.
OnMouseHover (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseHover to send this event to any registered event listeners.
OnMouseLeave (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseLeave to send this event to any registered event listeners.
OnMouseMove (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseMove to send this event to any registered event listeners.
OnMouseUp (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseUp to send this event to any registered event listeners.
OnMouseWheel (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseWheel to send this event to any registered event listeners.
OnMove (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMove to send this event to any registered event listeners.
OnPaint (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onPaint to send this event to any registered event listeners.
OnPaintBackground (inherited from RichControl) | Inheriting classes should override this method to handle the erase background request from windows. It is not necessary to call base.onPaintBackground, however if you do not want the default Windows behavior you must set event.handled to true.
OnParentPropertyChanged (inherited from RichControl) | This method is called by the parent control when any property changes on the parent. This can be overriden by inheriting classes, however they must call base.OnParentPropertyChanged.
OnPropertyChanged (inherited from RichControl) | [To be supplied.]
OnQueryContinueDrag (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onQueryContinueDrag to send this event to any registered event listeners.
OnResize (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onResize to send this event to any registered event listeners.
OnValidated (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onResize to send this event to any registered event listeners.
OnValidating (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onResize to send this event to any registered event listeners.
ParentChanged (inherited from Control) | Called by the framework after a control's parent changes. This allows (for example) child controls to automatically hook events on their parent, giving better encapsulation.
ProcessCmdKey (inherited from RichControl) | [To be supplied.]
ProcessDialogChar (inherited from Control) | Processes a dialog character. This method is called during message pre-processing to handle dialog characters, such as control mnemonics. This method is called only if the isInputChar() method indicates that the control isn't interested in the character. processDialogChar() simply sends the character to the parent's processDialogChar() method, or returns false if the control has no parent. The Form class overrides this method to perform actual processing of dialog characters. When overriding processDialogChar(), a control should return true to indicate that it has processed the character. For characters that aren't processed by the control, the result of "base.processDialogChar()" should be returned. Controls will seldom, if ever, need to override this method.
ProcessDialogKey (inherited from Control) | Processes a dialog key. This method is called during message pre-processing to handle dialog characters, such as TAB, RETURN, ESCAPE, and arrow keys. This method is called only if the isInputKey() method indicates that the control isn't interested in the key. processDialogKey() simply sends the character to the parent's processDialogKey() method, or returns false if the control has no parent. The Form class overrides this method to perform actual processing of dialog keys. When overriding processDialogKey(), a control should return true to indicate that it has processed the key. For keys that aren't processed by the control, the result of "base.processDialogChar()" should be returned. Controls will seldom, if ever, need to override this method.
ProcessKeyEventArgs (inherited from Control) | Processes a key message. This method is called when a control receives a keyboard message. The method is responsible for generating the appropriate key events for the message by calling OnKeyPress(), onKeyDown(), or onKeyUp(). The m parameter contains the window message that must be processed. Possible values for the m.msg field are WM_CHAR, WM_KEYDOWN, WM_SYSKEYDOWN, WM_KEYUP, WM_SYSKEYUP, and WM_IMECHAR. When overriding processKeyEventArgs(), a control should return true to indicate that it has processed the key. For keys that aren't processed by the control, the result of "base.processKeyEventArgs()" should be returned. Controls will seldom, if ever, need to override this method.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message. This method is called by a child control when the child control receives a keyboard message. The child control calls this method before generating any keyboard events for the message. If this method returns true, the child control considers the message consumed and does not generate any keyboard events. The m parameter contains the window message to preview. Possible values for the m.msg field are WM_CHAR, WM_KEYDOWN, WM_SYSKEYDOWN, WM_KEYUP, and WM_SYSKEYUP. processKeyPreview() simply sends the character to the parent's processKeyPreview() method, or returns false if the control has no parent. The Form class overrides this method to perform actual processing of dialog keys. When overriding processKeyPreview(), a control should return true to indicate that it has processed the key. For keys that aren't processed by the control, the result of "base.processKeyEventArgs()" should be returned.
ProcessMnemonic (inherited from Control) Processes a mnemonic character. This method is called to give a control the opportunity to process a mnemonic character. The method should check if the control is in a state to process mnemonics and if the given character represents a mnemonic. If so, the method should perform the action associated with the mnemonic and return true. If not, the method should return false. Implementations of this method often use the isMnemonic() method to check if the given character matches a mnemonic in the control's text, for example:
if (canSelect() && isMnemonic(charCode, getText()) {
    // perform action associated with mnemonic
    }

This default implementation of processMnemonic() simply returns false to indicate that the control has no mnemonic.
RaiseDragEventArgs (inherited from RichControl) | Raises the event associated with key with the event data of e and a sender of this control.
RaiseEvent (inherited from Control) | [To be supplied.]
RaiseKeyEventArgs (inherited from Control) | Raises the event associated with key with the event data of e and a sender of this control.
RaiseMouseEventArgs (inherited from Control) | Raises the event associated with key with the event data of e and a sender of this control.
RaisePaintEventArgs (inherited from RichControl) | Raises the event associated with key with the event data of e and a sender of this control.
RaisePropertyChangedEvent (inherited from Control) | Raises the property changed event. This creates the needed event data and then calls OnPropertyChanged.
RecreateHandle (inherited from Control) | Forces the recreation of the handle for this control. Inheriting controls must call base.recreateHandle.
RemoveEventHandler (inherited from Control) | [To be supplied.]
RemoveEventHandlers (inherited from Control) | [To be supplied.]
ResetMouseEventArgs (inherited from Control) | Resets the mouse leave listeners.
ResumeLayout (inherited from Control) | Overloaded. [To be supplied.]
RTLTranslateAlignment (inherited from RichControl) | Overloaded. [To be supplied.]
RTLTranslateContent (inherited from RichControl) | [To be supplied.]
RTLTranslateHorizontal (inherited from RichControl) | [To be supplied.]
RTLTranslateLeftRight (inherited from RichControl) | [To be supplied.]
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
SendMessage (inherited from Control) | Overloaded. [To be supplied.]
SetBoundsCore (inherited from RichControl) | [To be supplied.]
SetClientSizeCore (inherited from Control) | Performs the work of setting the size of the client area of the control.
SetStyle (inherited from Control) | Sets the current value of the specified bit in the control's style. NOTE: This is control style, not the Win32 style of the hwnd.
UpdateBounds (inherited from Control) | Overloaded. [To be supplied.]
UpdateStyles (inherited from Control) | Forces styles to be reapplied to the handle. This function will call CreateParams to get the styles to apply.
UpdateZOrder (inherited from Control) | Updates this control in it's parent's zorder.
WmSysColorChange (inherited from Control) | Handles the WM_SYSCOLORCHANGE message
WndProc | [To be supplied.]
WndProcException (inherited from RichControl) | [To be supplied.]

Event Hookup:

Methods

AddOnAfterCheck (inherited from TreeView) | Adds an event handler for the "afterCheck" event notification.
AddOnAfterCollapse (inherited from TreeView) | Adds an event handler for the "afterCollapse" event notification. The afterCollapse event is fired after the user has successfully collapsed a node. Collapsing a node hides all child nodes of that node from view.
AddOnAfterExpand (inherited from TreeView) | Adds an event handler for the "afterExpand" event notification. The afterExpand event is fired after the user has successfully expanded a node. Expanding a node causes its child nodes to be displayed.
AddOnAfterLabelEdit (inherited from TreeView) | Adds an event handler for the "afterLabelEdit" event notification. The afterLabelEdit event is fired when the user finishes editing the text of a node in the TreeView. The labelEdit property of the TreeView must be true to enable the user to do this. The string to which the user changed the text is passed to the event, and the event handler is given the opportunity to reject the change, in which case the text will revert back to what it was before the user started the change.
AddOnAfterSelect (inherited from TreeView) | Adds an event handler for the "afterSelect" event notification. The onAfterSelect event is fired after the user has selected a node.
AddOnBeforeCheck (inherited from TreeView) | Adds an event handler for the "beforeCheck" event notification.
AddOnBeforeCollapse (inherited from TreeView) | Adds an event handler for the "beforeCollapse" event notification. The beforeCollapse event is fired when the user attempts to collapse a node. Collapsing a node hides all child nodes of that node from view. The event can be cancelled by the handler, in which case the node won't collapse.
AddOnBeforeExpand (inherited from TreeView) | Adds an event handler for the "beforeExpand" event notification. The beforeExpand event is fired when the user attempts to expand a node. Expanding a node causes its child nodes to be displayed. The event can be cancelled by the handler, in which case the node won't expand.
AddOnBeforeLabelEdit (inherited from TreeView) | Adds an event handler for the "beforeLabelEdit" event notification. The beforeLabelEdit event is fired when the user attempts to begin changing the text of a node in the TreeView. The event handler can cancel this event, in which case the user won't be allowed to edit the text. This event can be used to prevent the user from editing specific nodes in the TreeView. If the labelEdit property of the TreeView is false, this event will not be fired, and all user attempts to edit node labels will be automatically rejected.
AddOnBeforeSelect (inherited from TreeView) | Adds an event handler for the "beforeSelect" event notification. The onBeforeSelect event is fired when the user attempts to select a node. The event can be cancelled by the handler, in which case the node won't be selected.
AddOnClick (inherited from Control) | Adds an event handler for the click event. The click event occurs when the user clicks in the client area of the control.
AddOnControlAdded (inherited from Control) | Adds an event handler for the ControlAdded event. This event is raised after a control is added as a child to this control.
AddOnControlRemoved (inherited from Control) | Adds an event handler for the ControlRemoved event. This event is raised after a child control is removed from this control.
AddOnCreateHandle (inherited from Control) | Adds an event handler for the createHandle event. The createHandle event occurs immediately after the control's handle is created.
AddOnDestroyHandle (inherited from Control) | Adds an event handler for the destroyHandle event. The destroyHandle event occurs immediately before the control's handle is destroyed.
AddOnDoubleClick (inherited from Control) | Adds an event handler for the doubleClick event. The doubleClick event occurs when the user double clicks in the client area of the control.
AddOnDragDrop (inherited from RichControl) | Adds an event handler for the dragDrop event. The dragDrop evnet occurs when the user releases the mouse button while dragging some Object over the control.
AddOnDragEnter (inherited from RichControl) | Adds an event handler for the dragEnter event. The drawEnter event occurs when the user first moves the mouse over the control while dragging some Object.
AddOnDragLeave (inherited from RichControl) | Adds an event handler for the dragLeave event. The dragLeave event occurs when the user first moves the mouse out of the control while dragging some Object.
AddOnDragOver (inherited from RichControl) | Adds an event handler for the dragOver event. The dragOver event occurs whenever the user moves the mouse over the control while draggin some Object.
AddOnEnter (inherited from Control) | Adds an event handler for the enter event. The enter event occurs when focus enters this control. This doesn't imply that this control has focus, but rather that this control or some child control of this control has gotten focus.
AddOnGiveFeedback (inherited from RichControl) | Adds an event handler for the giveFeedback event. The giveFeedback event occurs during a drag operation. This allows the source of a drag event to modify the mouse pointer to give the user visual feedback as to what would happen if they droped.
AddOnGotFocus (inherited from Control) | Adds an event handler for the gotFocus event. The gotFocus event occurs when the this control gains focus.
AddOnHelp (inherited from RichControl) | Adds an event handler for the help event. The help event occurs when the user requests help for this control. This may be caused by the user pressing F1, or used "Whats This Help".
AddOnInvalidate (inherited from RichControl) | Adds an event handler for the invalidate event. The invalidate event occurs when the Invalidate method is called on some part of the control's client area. This event may be used to identify when the contents of a window have changed.
AddOnItemDrag (inherited from TreeView) | Adds an event handler for the "itemDrag" event notification The itemDrag event is fired when the user presses the left or right mouse button over a node and begins to move the mouse. A typical response to this event would be to call doDragDrop.
AddOnKeyDown (inherited from Control) | Adds an event handler for the keyDown event. The keyDown event occurs when the user presses a key down.
AddOnKeyPress (inherited from Control) | Adds an event handler for the keyPress event. The keyPress event occurs when the user presses a key.
AddOnKeyUp (inherited from Control) | Adds an event handler for the keyUp event. The keyUp event occurs when the user releases a key.
AddOnLayout (inherited from Control) | Adds an event handler for the layout event. The layout event occurs when any event occurs that would cause the control to layout child controls. These events include; resize, show/hide child controls, add/remove child controls. This event should be used to perform any custom layout logic.
AddOnLeave (inherited from Control) | Adds an event handler for the leave event. The leave event occurs when focus leaves this control. This doesn't imply that this control lost focus, but rather that focus has been moved out of this control and any child controls.
AddOnLostFocus (inherited from Control) | Adds an event handler for the lostFocus event. The lostFocus event occurs when this control looses focus.
AddOnMouseDown (inherited from Control) | Adds an event handler for the mouseDown event. The mouseDown event occurs when the user presses the mouseDown over this control.
AddOnMouseEnter (inherited from Control) | Adds an event handler for the mouseEnter event. The mouseEnter event occurs when the mouse first moves over this control.
AddOnMouseHover (inherited from Control) | Adds an event handler for the mouseHover event. The mouseHover event occurs after the mouse is inside a control for an amount.
AddOnMouseLeave (inherited from Control) | Adds an event handler for the mouseLeave event. The mouseLeave event occurs when the mouse first moves out of this control.
AddOnMouseMove (inherited from Control) | Adds an event handler for the mouseMove event. The mouseMove event occurs whenever the user moves the mouse over this control.
AddOnMouseUp (inherited from Control) | Adds an event handler for the mouseUp event. The mouseUp event occurs when the user releases a mouse button inside the control.
AddOnMouseWheel (inherited from Control) | Adds an event handler for the mouseWheel event. The mouseWheel event occurs when the user scrolls the mouse wheel up or down. The delta value in the event data indicates the amount that the mouse wheel has moved. The Microsoft standards indicate that the view should scroll by System.WinForms.SystemInformation.getMouseWheelScrollLines() when the delta value has reach win.WHEEL_DELTA. If a mouseWheel event occurs with a value less that WHEEL_DELTA, the control should either increment a stored value and wait until the total delta is an increment of WHEEL_DELTA, or scroll the view a percentage of MouseWheelScrollLines. NOTE: A press of the mouseWheel will generate a mouseDown event with the middle button pressed.
AddOnMove (inherited from Control) | Adds an event handler for the move event. The move event occurs when the controls location changes.
AddOnPaint (inherited from RichControl) | Adds an event handler for the paint event. The paint event occurs when the control needs to paint some part of it's client area.
AddOnPropertyChanged (inherited from Control) | Adds an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.
AddOnQueryContinueDrag (inherited from RichControl) | Adds an event handler for the queryContinueDrag event. The queryContinueDrag event occurs during a drag operation. This allows the drag source to determine if the drag operation should be canceled.
AddOnResize (inherited from Control) | Adds an event handler for the resize event. The resize event occurs when the bounds of the control change. This event may be fired from the constructor of base controls.
AddOnValidated (inherited from Control) | Adds an event handler for the validated event. The validated event occurs when a control was successfully validated.
AddOnValidating (inherited from Control) | Adds an event handler for the validating event. The validating event occurs when the control loses focus and a control that causes validation gains focus. This is where users can write code to validate the current values of the control.
RemoveOnAfterCheck (inherited from TreeView) | Removes the given handler from the "afterCheck" event. If there are duplicate entries, all are removed.
RemoveOnAfterCollapse (inherited from TreeView) | Removes the given handler from the "afterCollapse" event. If there are duplicate entries, all are removed.
RemoveOnAfterExpand (inherited from TreeView) | Removes the given handler from the "afterExpand" event. If there are duplicate entries, all are removed.
RemoveOnAfterLabelEdit (inherited from TreeView) | Removes the given handler from the "afterLabelEdit" event. If there are duplicate entries, all are removed.
RemoveOnAfterSelect (inherited from TreeView) | Removes the given handler from the "afterSelect" event. If there are duplicate entries, all are removed.
RemoveOnBeforeCheck (inherited from TreeView) | Removes the given handler from the "beforeCheck" event. If there are duplicate entries, all are removed.
RemoveOnBeforeCollapse (inherited from TreeView) | Removes the given handler from the "beforeCollapse" event. If there are duplicate entries, all are removed.
RemoveOnBeforeExpand (inherited from TreeView) | Removes the given handler from the "beforeExpand" event. If there are duplicate entries, all are removed.
RemoveOnBeforeLabelEdit (inherited from TreeView) | Removes the given handler from the "beforeLabelEdit" event. If there are duplicate entries, all are removed.
RemoveOnBeforeSelect (inherited from TreeView) | Removes the given handler from the "beforeSelect" event. If there are duplicate entries, all are removed.
RemoveOnClick (inherited from Control) | Removes the given handler for the "OnClick" event. If there are duplicate entries, ALL are removed.
RemoveOnControlAdded (inherited from Control) | Removes the given handler for the "ControlAdded" event. If there are duplicate entries, ALL are removed.
RemoveOnControlRemoved (inherited from Control) | Removes the given handler for the "ControlRemoved" event. If there are duplicate entries, ALL are removed.
RemoveOnCreateHandle (inherited from Control) | Removes the given handler for the "createHandle" event. If there are duplicate entries, ALL are removed.
RemoveOnDestroyHandle (inherited from Control) | Removes the given handler for the "destroyHandle" event. If there are duplicate entries, ALL are removed.
RemoveOnDoubleClick (inherited from Control) | Removes the given handler for the "OnDoubleClick" event. If there are duplicate entries, ALL are removed.
RemoveOnDragDrop (inherited from RichControl) | Removes the given handler for the "dragDrop" event. If there are duplicate entries, ALL are removed.
RemoveOnDragEnter (inherited from RichControl) | Removes the given handler for the "OnDragEnter" event. If there are duplicate entries, ALL are removed.
RemoveOnDragLeave (inherited from RichControl) | Removes the given handler for the "OnDragLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnDragOver (inherited from RichControl) | f final Removes the given handler for the "OnDragOver" event. If there are duplicate entries, ALL are removed.
RemoveOnEnter (inherited from Control) | Removes the given handler for the "OnEnter" event. If there are dfinal uplicate entries, ALL are removed.
RemoveOnGiveFeedback (inherited from RichControl) | Removes the given handler for the "OnGiveFeedback" event. If there are duplicate entries, ALL are removed.
RemoveOnGotFocus (inherited from Control) | Removes the given handler for the "OnGotFocus" event. If there are duplicate entries, ALL are removed.
RemoveOnHelp (inherited from RichControl) | Removes the given handler for the "OnHelp" event. If there are duplicate entries, ALL are removed.
RemoveOnInvalidate (inherited from RichControl) | Removes the given handler for the "OnInvalidate" event. If there are duplicate entries, ALL are removed.
RemoveOnItemDrag (inherited from TreeView) | Removes the given handler from the "itemDrag" event. If there are duplicate entries, all are removed.
RemoveOnKeyDown (inherited from Control) | Removes the given handler for the "OnKeyDown" event. If there are duplicate entries, ALL are removed.
RemoveOnKeyPress (inherited from Control) | Removes the given handler for the "OnKeyPress" event. If there are duplicate entries, ALL are removed.
RemoveOnKeyUp (inherited from Control) | Removes the given handler for the "OnKeyUp" event. If there are duplicate entries, ALL are removed.
RemoveOnLayout (inherited from Control) | Removes the given handler for the layout event. If there are duplicate entries, ALL are removed.
RemoveOnLeave (inherited from Control) | Removes the given handler for the "OnLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnLostFocus (inherited from Control) | Removes the given handler for the "OnLostFocus" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseDown (inherited from Control) | Removes the given handler for the "OnMouseDown" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseEnter (inherited from Control) | Removes the given handler for the "OnMouseEnter" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseHover (inherited from Control) | Removes the given handler for the "OnMouseHover" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseLeave (inherited from Control) | Removes the given handler for the "OnMouseLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseMove (inherited from Control) | Removes the given handler for the "OnMouseMove" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseUp (inherited from Control) | Removes the given handler for the "OnMouseUp" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseWheel (inherited from Control) | Removes the given handler for the "OnMouseWheel" event. If there are duplicate entries, ALL are removed.
RemoveOnMove (inherited from Control) | Removes the given handler for the "OnMove" event. If there are duplicate entries, ALL are removed.
RemoveOnPaint (inherited from RichControl) | Removes the given handler for the "OnPaint" event. If there are duplicate entries, ALL are removed.
RemoveOnPropertyChanged (inherited from Control) | Removes an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.
RemoveOnQueryContinueDrag (inherited from RichControl) | Removes the given handler for the "OnQueryContinueDrag" event. If there are duplicate entries, ALL are removed.
RemoveOnResize (inherited from Control) | Removes the given handler for the "OnResize" event. If there are duplicate entries, ALL are removed.
RemoveOnValidated (inherited from Control) | Removes an event handler for the validated event. The validated event occurs when a control was successfully validated.
RemoveOnValidating (inherited from Control) | Removes an event handler for the validating event. The validating event occurs when the control loses focus and a control that causes validation gains focus. This is where users can write code to validate the current values of the control.

See Also

ObjectSelectorEditor.Selector Class | System.ComponentModel.Design Namespace


ObjectSelectorEditor.Selector Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal editor As ObjectSelectorEditor _
)
[C#]
public ObjectSelectorEditor.Selector(
   ObjectSelectorEditor editor
);
[C++]
public: ObjectSelectorEditor.Selector(
   ObjectSelectorEditor* editor
);
[JScript]
public function ObjectSelectorEditor.Selector(
   editor : ObjectSelectorEditor
);

Parameters

editor
[To be supplied.]

See Also

ObjectSelectorEditor.Selector Class | ObjectSelectorEditor.Selector Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ObjectSelectorEditor.Selector Methods

The methods of the ObjectSelectorEditor.Selector class are listed below. For a complete list of ObjectSelectorEditor.Selector class members, see the ObjectSelectorEditor.Selector Members topic.

Public:

AddNode | [To be supplied.]
BeginInvoke (inherited from RichControl) | Overloaded. [To be supplied.]
BeginUpdate (inherited from TreeView) | Disables redrawing of the tree view. A call to beginUpdate() must be balanced by a following call to endUpdate(). Following a call to beginUpdate(), any redrawing caused by operations performed on the tree view is deferred until the call to endUpdate().
BringToFront (inherited from Control) | Brings this control to the front of the zorder.
CallWndProc (inherited from Control) | Dispatch the method to this window's wndProc directly.
Clear | [To be supplied.]
CollapseAll (inherited from TreeView) | Collapses all nodes at the root level.
Contains (inherited from Control) | Checks if a control is a child of this control.
CreateControl (inherited from Control) | Forces the creation of the control. This includes the creation of the handle, and any child controls.
CreateGraphics (inherited from RichControl) | Overloaded. [To be supplied.]
CreateWindowGraphics (inherited from RichControl) | Creates a Graphics for the entire window of the control rather than just it's client area. The controls foreground color and background color become the default values for the Graphics. The returned Graphics must be disposed through a call to its dispose() method when it is no longer needed. The Graphics Object is only valid for the duration of the current window's message.
Dispose (inherited from TreeView) | [To be supplied.]
DoDragDrop (inherited from RichControl) | Begins a drag operation. The allowedEffects determine which drag operations can occur. If the drag operation needs to interop with applications in another process, data should either be a base managed class (String, Bitmap, or Metafile) or some Object that implements System.ComponentModel.IPersistable. data can also be any Object that implements System.WinForms.IDataObject.
EndInvoke (inherited from RichControl) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult interface passed. If the async operation has not been completed, this function will block until the result is available.
EndUpdate (inherited from TreeView) | Reenables redrawing of the tree view. A call to beginUpdate() must be balanced by a following call to endUpdate(). Following a call to beginUpdate(), any redrawing caused by operations performed on the combo box is deferred until the call to endUpdate().
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
ExpandAll (inherited from TreeView) | Expands all nodes at the root level.
FindForm (inherited from RichControl) | Retrieves the form that this control is on. The control's parent may not be the same as the form.
Focus (inherited from Control) | Attempts to set focus to this control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified client coordinates.
GetContainer (inherited from MarshalByRefComponent) | Returns the component's container.
GetContainerControl (inherited from Control) | Returns the closest ContainerControl in the control's chain of parent controls and forms.
GetDesignMode (inherited from MarshalByRefComponent) | Determines whether the component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetNextControl (inherited from Control) | Retrieves the next control in the tab order of child controls.
GetNodeAt (inherited from TreeView) | Overloaded. [To be supplied.]
GetNodeCount (inherited from TreeView) | Returns count of nodes at root, optionally including all subtrees.
GetServiceObject (inherited from MarshalByRefComponent) | The implementation of IServiceObjectProvider
GetType (inherited from Object) | Gets the Type of the Object.
Hide (inherited from Control) | Hides the control by setting the visible property to false;
InitializeLifetimeService (inherited from MarshalByRefObject)
Invalidate (inherited from Control) | Overloaded. [To be supplied.]
Invoke (inherited from RichControl) | Overloaded. [To be supplied.]
PerformLayout (inherited from Control) | Overloaded. [To be supplied.]
PointToClient (inherited from Control) | Computes the location of the screen point p in client coords.
PointToScreen (inherited from Control) | Computes the location of the client point p in screen coords.
PreProcessMessage (inherited from Control) | This method is called by the application's message loop to pre-process input messages before they are dispatched. Possible values for the msg.message field are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR. If this method processes the message it must return true, in which case the message loop will not dispatch the message. For WM_KEYDOWN and WM_SYSKEYDOWN messages, preProcessMessage() first calls processCmdKey() to check for command keys such as accelerators and menu shortcuts. If processCmdKey() doesn't process the message, then isInputKey() is called to check whether the key message represents an input key for the control. Finally, if isInputKey() indicates that the control isn't interested in the key message, then processDialogKey() is called to check for dialog keys such as TAB, arrow keys, and mnemonics. For WM_CHAR messages, preProcessMessage() first calls isInputChar() to check whether the character message represents an input character for the control. If isInputChar() indicates that the control isn't interested in the character message, then processDialogChar() is called to check for dialog characters such as mnemonics. For WM_SYSCHAR messages, preProcessMessage() calls processDialogChar() to check for dialog characters such as mnemonics. When overriding preProcessMessage(), a control should return true to indicate that it has processed the message. For messages that aren't processed by the control, the result of "base.preProcessMessage()" should be returned. Controls will typically override one of the more specialized methods (isInputChar(), isInputKey(), processCmdKey(), processDialogChar(), or processDialogKey()) instead of overriding preProcessMessage().
RectangleToClient (inherited from Control) | Computes the location of the screen rectangle r in client coords.
RectangleToScreen (inherited from Control) | Computes the location of the client rectangle r in screen coords.
Refresh (inherited from Control) | Forces the control to invalidate and immediately repaint itself and any children.
ResetBackColor (inherited from RichControl) | Resets the back color to be based on the parent's back color.
ResetBindings (inherited from RichControl) | [To be supplied.]
ResetCursor (inherited from RichControl) | [To be supplied.]
ResetFont (inherited from RichControl) | Resets the font to be based on the parent's font.
ResetForeColor (inherited from RichControl) | Resets the fore color to be based on the parent's fore color.
ResetIndent (inherited from TreeView) | This resets the indentation to the system default.
ResetRightToLeft (inherited from RichControl) | Resets the RightToLeft to be the default.
ResetText (inherited from Control) | Resets the text to it's default value.
ResumeLayout (inherited from Control) | Overloaded. [To be supplied.]
Scale (inherited from Control) | Overloaded. [To be supplied.]
Select (inherited from Control) | Activates this control.
SelectNextControl (inherited from Control) | Selects the next control following ctl.
SendMessage (inherited from Control) | Overloaded. [To be supplied.]
SendToBack (inherited from Control) | sends this control to the back of the z-order
SetBounds (inherited from Control) | Overloaded. [To be supplied.]
SetClientSize (inherited from Control) | Sets the height and width of the client area of the control.
SetLocation (inherited from Control) | Sets the location of this control.
SetNewControls (inherited from Control) | Performs the work of setting the array of the child controls contained in this control.
SetSelection | [To be supplied.]
SetSize (inherited from Control) | Sets the size of this control.
ShouldPersistBackColor (inherited from TreeView) | Returns true if the backColor should be persisted in code gen.
ShouldPersistBindings (inherited from RichControl) | [To be supplied.]
ShouldPersistCursor (inherited from RichControl) | Returns true if the cursor should be persisted in code gen.
ShouldPersistFont (inherited from RichControl) | Returns true if the font should be persisted in code gen.
ShouldPersistForeColor (inherited from TreeView) | [To be supplied.]
ShouldPersistIndent (inherited from TreeView) | Retrieves true if the indent should be persisted in code gen.
ShouldPersistItemHeight (inherited from TreeView) | Retrieves true if the itemHeight should be persisted in code gen.
ShouldPersistLocation (inherited from Control) | Determines if the Location property needs to be persisted.
ShouldPersistRightToLeft (inherited from RichControl) | Returns true if the RightToLeft should be persisted in code gen.
ShouldPersistSize (inherited from Control) | Determines if the Size property needs to be persisted.
ShouldPersistText (inherited from Control) | Determines if the Text property needs to be persisted.
Show (inherited from Control) | Makes the control display by setting the visible property to true
Start | [To be supplied.]
Stop | [To be supplied.]
SuspendLayout (inherited from Control) | Suspends the layout logic for the control.
ToString (inherited from TreeView) | Returns a string representation for this control.
Update (inherited from Control) | Forces the control to paint any currently invalid areas.

Protected:

AddEventHandler (inherited from Control) | [To be supplied.]
AssignParent (inherited from RichControl) | Assigns a new parent control. Sends out the appropriate property change notifications for properties that are affected by the change of parent.
ChildGotFocus (inherited from Control) | [To be supplied.]
CreateAccessibilityInstance (inherited from RichControl) | Constructs the new instance of the accessibility object for this control. Subclasses should not call base.CreateAccessibilityObject.
CreateControlsInstance (inherited from RichControl) | Constructs the new instance of the Controls collection objects. Subclasses should not call base.CreateControlsInstance.
CreateHandle (inherited from TreeView) | [To be supplied.]
DefWndProc (inherited from Control) | Sends the message to the default window proc.
DestroyHandle (inherited from RichControl) | [To be supplied.]
Finalize (inherited from Control) | [To be supplied.]
GetEventHandler (inherited from RichControl) | RichControl overrides the default implementation of this for AX sourcing. ActiveX controls can "freeze" their events, and we implement this by returning null here if events are frozen.
GetItemRenderStyles (inherited from TreeView) | Generates colors for each item. This can be overridden to provide colors on a per state/per node basis, rather than using the ForeColor/BackColor/NodeFont properties on TreeNode.
GetStyle (inherited from Control) | Retrieves the current value of the specified bit in the control's style. NOTE: This is control style, not the Win32 style of the hwnd.
InitLayout (inherited from RichControl) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | [To be supplied.]
InvokeLostFocus (inherited from Control) | [To be supplied.]
InvokeOnClick (inherited from Control) | [To be supplied.]
InvokePaint (inherited from RichControl) | [To be supplied.]
InvokePaintBackground (inherited from RichControl) | [To be supplied.]
IsInputChar (inherited from Control) | Determines if charCode is an input character that the control wants. This method is called during window message pre-processing to determine whether the given input character should be pre-processed or sent directly to the control. If isInputChar returns true, the given character is sent directly to the control. If isInputChar returns false, the character is pre-processed and only sent to the control if it is not consumed by the pre-processing phase. The pre-processing of a character includes checking whether the character is a mnemonic of another control.
IsInputKey (inherited from Control) | Determines if keyData is an input key that the control wants. This method is called during window message pre-processing to determine whether the given input key should be pre-processed or sent directly to the control. If isInputKey returns true, the given key is sent directly to the control. If isInputKey returns false, the key is pre-processed and only sent to the control if it is not consumed by the pre-processing phase. Keys that are pre-processed include TAB, RETURN, ESCAPE, and arrow keys.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from RichControl) | [To be supplied.]
OnAfterCheck (inherited from TreeView) | Fires the afterCheck event.
OnAfterCollapse (inherited from TreeView) | Fires the afterCollapse event.
OnAfterExpand (inherited from TreeView) | Fires the afterExpand event.
OnAfterLabelEdit (inherited from TreeView) | Fires the afterLabelEdit event.
OnAfterSelect | Overloaded. [To be supplied.]
OnBeforeCheck (inherited from TreeView) | Fires the beforeCheck event.
OnBeforeCollapse (inherited from TreeView) | Fires the beforeCollapse event.
OnBeforeExpand (inherited from TreeView) | Fires the beforeExpand event.
OnBeforeLabelEdit (inherited from TreeView) | Fires the beforeLabelEdit event.
OnBeforeSelect (inherited from TreeView) | Fires the beforeSelect event.
OnClick (inherited from Control) | This method actually raises the Click event. Inheriting classes should override this if they wish to be notified of a Click event. (This is far preferable to actually adding an event handler.) They should not, however, forget to call base.onClick(e); before exiting, to ensure that other recipients do actually get the event.
OnControlAdded (inherited from Control) | Called when a child control is added to this control.
OnControlRemoved (inherited from Control) | Called when a child control is removed from this control.
OnCreateControl (inherited from Control) | Called when the control is first created.
OnCreateHandle (inherited from TreeView) | [To be supplied.]
OnDestroyHandle (inherited from RichControl) | Inheriting classes should override this method to find out when the handle is about to be destroyed. Call base.onDestroyHandle last.
OnDoubleClick (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onDoubleClick to send this event to any registered event listeners.
OnDragDrop (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragDrop to send this event to any registered event listeners.
OnDragEnter (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragEnter to send this event to any registered event listeners.
OnDragLeave (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragLeave to send this event to any registered event listeners.
OnDragOver (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragOver to send this event to any registered event listeners.
OnEnter (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onEnter to send this event to any registered event listeners.
OnGiveFeedback (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onGiveFeedback to send this event to any registered event listeners.
OnGotFocus (inherited from RichControl) | [To be supplied.]
OnHelp (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onHelp to send this event to any registered event listeners.
OnInvalidate (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.OnInvalidate to send this event to any registered event listeners.
OnItemDrag (inherited from TreeView) | Fires the ItemDrag event.
OnKeyDown | [To be supplied.]
OnKeyPress | [To be supplied.]
OnKeyUp (inherited from TreeView) | Handles the OnBeforeCheck/ OnAfterCheck for keyboard clicks
OnLayout (inherited from RichControl) | Core layout logic. Inheriting controls should override this function to do any custom layout logic. It is not neccessary to call base.layoutCore, however for normal docking and anchoring functions to work, base.layoutCore must be called.
OnLeave (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onLeave to send this event to any registered event listeners.
OnLostFocus (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onLostFocus to send this event to any registered event listeners.
OnMouseDown (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseDown to send this event to any registered event listeners.
OnMouseEnter (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseEnter to send this event to any registered event listeners.
OnMouseHover (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseHover to send this event to any registered event listeners.
OnMouseLeave (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseLeave to send this event to any registered event listeners.
OnMouseMove (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseMove to send this event to any registered event listeners.
OnMouseUp (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseUp to send this event to any registered event listeners.
OnMouseWheel (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseWheel to send this event to any registered event listeners.
OnMove (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMove to send this event to any registered event listeners.
OnPaint (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onPaint to send this event to any registered event listeners.
OnPaintBackground (inherited from RichControl) | Inheriting classes should override this method to handle the erase background request from windows. It is not necessary to call base.onPaintBackground, however if you do not want the default Windows behavior you must set event.handled to true.
OnParentPropertyChanged (inherited from RichControl) | This method is called by the parent control when any property changes on the parent. This can be overriden by inheriting classes, however they must call base.OnParentPropertyChanged.
OnPropertyChanged (inherited from RichControl) | [To be supplied.]
OnQueryContinueDrag (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onQueryContinueDrag to send this event to any registered event listeners.
OnResize (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onResize to send this event to any registered event listeners.
OnValidated (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onResize to send this event to any registered event listeners.
OnValidating (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onResize to send this event to any registered event listeners.
ParentChanged (inherited from Control) | Called by the framework after a control's parent changes. This allows (for example) child controls to automatically hook events on their parent, giving better encapsulation.
ProcessCmdKey (inherited from RichControl) | [To be supplied.]
ProcessDialogChar (inherited from Control) | Processes a dialog character. This method is called during message pre-processing to handle dialog characters, such as control mnemonics. This method is called only if the isInputChar() method indicates that the control isn't interested in the character. processDialogChar() simply sends the character to the parent's processDialogChar() method, or returns false if the control has no parent. The Form class overrides this method to perform actual processing of dialog characters. When overriding processDialogChar(), a control should return true to indicate that it has processed the character. For characters that aren't processed by the control, the result of "base.processDialogChar()" should be returned. Controls will seldom, if ever, need to override this method.
ProcessDialogKey (inherited from Control) | Processes a dialog key. This method is called during message pre-processing to handle dialog characters, such as TAB, RETURN, ESCAPE, and arrow keys. This method is called only if the isInputKey() method indicates that the control isn't interested in the key. processDialogKey() simply sends the character to the parent's processDialogKey() method, or returns false if the control has no parent. The Form class overrides this method to perform actual processing of dialog keys. When overriding processDialogKey(), a control should return true to indicate that it has processed the key. For keys that aren't processed by the control, the result of "base.processDialogChar()" should be returned. Controls will seldom, if ever, need to override this method.
ProcessKeyEventArgs (inherited from Control) | Processes a key message. This method is called when a control receives a keyboard message. The method is responsible for generating the appropriate key events for the message by calling OnKeyPress(), onKeyDown(), or onKeyUp(). The m parameter contains the window message that must be processed. Possible values for the m.msg field are WM_CHAR, WM_KEYDOWN, WM_SYSKEYDOWN, WM_KEYUP, WM_SYSKEYUP, and WM_IMECHAR. When overriding processKeyEventArgs(), a control should return true to indicate that it has processed the key. For keys that aren't processed by the control, the result of "base.processKeyEventArgs()" should be returned. Controls will seldom, if ever, need to override this method.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message. This method is called by a child control when the child control receives a keyboard message. The child control calls this method before generating any keyboard events for the message. If this method returns true, the child control considers the message consumed and does not generate any keyboard events. The m parameter contains the window message to preview. Possible values for the m.msg field are WM_CHAR, WM_KEYDOWN, WM_SYSKEYDOWN, WM_KEYUP, and WM_SYSKEYUP. processKeyPreview() simply sends the character to the parent's processKeyPreview() method, or returns false if the control has no parent. The Form class overrides this method to perform actual processing of dialog keys. When overriding processKeyPreview(), a control should return true to indicate that it has processed the key. For keys that aren't processed by the control, the result of "base.processKeyEventArgs()" should be returned.
ProcessMnemonic (inherited from Control) Processes a mnemonic character. This method is called to give a control the opportunity to process a mnemonic character. The method should check if the control is in a state to process mnemonics and if the given character represents a mnemonic. If so, the method should perform the action associated with the mnemonic and return true. If not, the method should return false. Implementations of this method often use the isMnemonic() method to check if the given character matches a mnemonic in the control's text, for example:
if (canSelect() && isMnemonic(charCode, getText()) {
    // perform action associated with mnemonic
    }

This default implementation of processMnemonic() simply returns false to indicate that the control has no mnemonic.
RaiseDragEventArgs (inherited from RichControl) | Raises the event associated with key with the event data of e and a sender of this control.
RaiseEvent (inherited from Control) | [To be supplied.]
RaiseKeyEventArgs (inherited from Control) | Raises the event associated with key with the event data of e and a sender of this control.
RaiseMouseEventArgs (inherited from Control) | Raises the event associated with key with the event data of e and a sender of this control.
RaisePaintEventArgs (inherited from RichControl) | Raises the event associated with key with the event data of e and a sender of this control.
RaisePropertyChangedEvent (inherited from Control) | Raises the property changed event. This creates the needed event data and then calls OnPropertyChanged.
RecreateHandle (inherited from Control) | Forces the recreation of the handle for this control. Inheriting controls must call base.recreateHandle.
RemoveEventHandler (inherited from Control) | [To be supplied.]
RemoveEventHandlers (inherited from Control) | [To be supplied.]
ResetMouseEventArgs (inherited from Control) | Resets the mouse leave listeners.
ResumeLayout (inherited from Control) | Overloaded. [To be supplied.]
RTLTranslateAlignment (inherited from RichControl) | Overloaded. [To be supplied.]
RTLTranslateContent (inherited from RichControl) | [To be supplied.]
RTLTranslateHorizontal (inherited from RichControl) | [To be supplied.]
RTLTranslateLeftRight (inherited from RichControl) | [To be supplied.]
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
SendMessage (inherited from Control) | Overloaded. [To be supplied.]
SetBoundsCore (inherited from RichControl) | [To be supplied.]
SetClientSizeCore (inherited from Control) | Performs the work of setting the size of the client area of the control.
SetStyle (inherited from Control) | Sets the current value of the specified bit in the control's style. NOTE: This is control style, not the Win32 style of the hwnd.
UpdateBounds (inherited from Control) | Overloaded. [To be supplied.]
UpdateStyles (inherited from Control) | Forces styles to be reapplied to the handle. This function will call CreateParams to get the styles to apply.
UpdateZOrder (inherited from Control) | Updates this control in it's parent's zorder.
WmSysColorChange (inherited from Control) | Handles the WM_SYSCOLORCHANGE message
WndProc | [To be supplied.]
WndProcException (inherited from RichControl) | [To be supplied.]

Event Hookup:

AddOnAfterCheck (inherited from TreeView) | Adds an event handler for the "afterCheck" event notification.
AddOnAfterCollapse (inherited from TreeView) | Adds an event handler for the "afterCollapse" event notification. The afterCollapse event is fired after the user has successfully collapsed a node. Collapsing a node hides all child nodes of that node from view.
AddOnAfterExpand (inherited from TreeView) | Adds an event handler for the "afterExpand" event notification. The afterExpand event is fired after the user has successfully expanded a node. Expanding a node causes its child nodes to be displayed.
AddOnAfterLabelEdit (inherited from TreeView) | Adds an event handler for the "afterLabelEdit" event notification. The afterLabelEdit event is fired when the user finishes editing the text of a node in the TreeView. The labelEdit property of the TreeView must be true to enable the user to do this. The string to which the user changed the text is passed to the event, and the event handler is given the opportunity to reject the change, in which case the text will revert back to what it was before the user started the change.
AddOnAfterSelect (inherited from TreeView) | Adds an event handler for the "afterSelect" event notification. The onAfterSelect event is fired after the user has selected a node.
AddOnBeforeCheck (inherited from TreeView) | Adds an event handler for the "beforeCheck" event notification.
AddOnBeforeCollapse (inherited from TreeView) | Adds an event handler for the "beforeCollapse" event notification. The beforeCollapse event is fired when the user attempts to collapse a node. Collapsing a node hides all child nodes of that node from view. The event can be cancelled by the handler, in which case the node won't collapse.
AddOnBeforeExpand (inherited from TreeView) | Adds an event handler for the "beforeExpand" event notification. The beforeExpand event is fired when the user attempts to expand a node. Expanding a node causes its child nodes to be displayed. The event can be cancelled by the handler, in which case the node won't expand.
AddOnBeforeLabelEdit (inherited from TreeView) | Adds an event handler for the "beforeLabelEdit" event notification. The beforeLabelEdit event is fired when the user attempts to begin changing the text of a node in the TreeView. The event handler can cancel this event, in which case the user won't be allowed to edit the text. This event can be used to prevent the user from editing specific nodes in the TreeView. If the labelEdit property of the TreeView is false, this event will not be fired, and all user attempts to edit node labels will be automatically rejected.
AddOnBeforeSelect (inherited from TreeView) | Adds an event handler for the "beforeSelect" event notification. The onBeforeSelect event is fired when the user attempts to select a node. The event can be cancelled by the handler, in which case the node won't be selected.
AddOnClick (inherited from Control) | Adds an event handler for the click event. The click event occurs when the user clicks in the client area of the control.
AddOnControlAdded (inherited from Control) | Adds an event handler for the ControlAdded event. This event is raised after a control is added as a child to this control.
AddOnControlRemoved (inherited from Control) | Adds an event handler for the ControlRemoved event. This event is raised after a child control is removed from this control.
AddOnCreateHandle (inherited from Control) | Adds an event handler for the createHandle event. The createHandle event occurs immediately after the control's handle is created.
AddOnDestroyHandle (inherited from Control) | Adds an event handler for the destroyHandle event. The destroyHandle event occurs immediately before the control's handle is destroyed.
AddOnDoubleClick (inherited from Control) | Adds an event handler for the doubleClick event. The doubleClick event occurs when the user double clicks in the client area of the control.
AddOnDragDrop (inherited from RichControl) | Adds an event handler for the dragDrop event. The dragDrop evnet occurs when the user releases the mouse button while dragging some Object over the control.
AddOnDragEnter (inherited from RichControl) | Adds an event handler for the dragEnter event. The drawEnter event occurs when the user first moves the mouse over the control while dragging some Object.
AddOnDragLeave (inherited from RichControl) | Adds an event handler for the dragLeave event. The dragLeave event occurs when the user first moves the mouse out of the control while dragging some Object.
AddOnDragOver (inherited from RichControl) | Adds an event handler for the dragOver event. The dragOver event occurs whenever the user moves the mouse over the control while draggin some Object.
AddOnEnter (inherited from Control) | Adds an event handler for the enter event. The enter event occurs when focus enters this control. This doesn't imply that this control has focus, but rather that this control or some child control of this control has gotten focus.
AddOnGiveFeedback (inherited from RichControl) | Adds an event handler for the giveFeedback event. The giveFeedback event occurs during a drag operation. This allows the source of a drag event to modify the mouse pointer to give the user visual feedback as to what would happen if they droped.
AddOnGotFocus (inherited from Control) | Adds an event handler for the gotFocus event. The gotFocus event occurs when the this control gains focus.
AddOnHelp (inherited from RichControl) | Adds an event handler for the help event. The help event occurs when the user requests help for this control. This may be caused by the user pressing F1, or used "Whats This Help".
AddOnInvalidate (inherited from RichControl) | Adds an event handler for the invalidate event. The invalidate event occurs when the Invalidate method is called on some part of the control's client area. This event may be used to identify when the contents of a window have changed.
AddOnItemDrag (inherited from TreeView) | Adds an event handler for the "itemDrag" event notification The itemDrag event is fired when the user presses the left or right mouse button over a node and begins to move the mouse. A typical response to this event would be to call doDragDrop.
AddOnKeyDown (inherited from Control) | Adds an event handler for the keyDown event. The keyDown event occurs when the user presses a key down.
AddOnKeyPress (inherited from Control) | Adds an event handler for the keyPress event. The keyPress event occurs when the user presses a key.
AddOnKeyUp (inherited from Control) | Adds an event handler for the keyUp event. The keyUp event occurs when the user releases a key.
AddOnLayout (inherited from Control) | Adds an event handler for the layout event. The layout event occurs when any event occurs that would cause the control to layout child controls. These events include; resize, show/hide child controls, add/remove child controls. This event should be used to perform any custom layout logic.
AddOnLeave (inherited from Control) | Adds an event handler for the leave event. The leave event occurs when focus leaves this control. This doesn't imply that this control lost focus, but rather that focus has been moved out of this control and any child controls.
AddOnLostFocus (inherited from Control) | Adds an event handler for the lostFocus event. The lostFocus event occurs when this control looses focus.
AddOnMouseDown (inherited from Control) | Adds an event handler for the mouseDown event. The mouseDown event occurs when the user presses the mouseDown over this control.
AddOnMouseEnter (inherited from Control) | Adds an event handler for the mouseEnter event. The mouseEnter event occurs when the mouse first moves over this control.
AddOnMouseHover (inherited from Control) | Adds an event handler for the mouseHover event. The mouseHover event occurs after the mouse is inside a control for an amount.
AddOnMouseLeave (inherited from Control) | Adds an event handler for the mouseLeave event. The mouseLeave event occurs when the mouse first moves out of this control.
AddOnMouseMove (inherited from Control) | Adds an event handler for the mouseMove event. The mouseMove event occurs whenever the user moves the mouse over this control.
AddOnMouseUp (inherited from Control) | Adds an event handler for the mouseUp event. The mouseUp event occurs when the user releases a mouse button inside the control.
AddOnMouseWheel (inherited from Control) | Adds an event handler for the mouseWheel event. The mouseWheel event occurs when the user scrolls the mouse wheel up or down. The delta value in the event data indicates the amount that the mouse wheel has moved. The Microsoft standards indicate that the view should scroll by System.WinForms.SystemInformation.getMouseWheelScrollLines() when the delta value has reach win.WHEEL_DELTA. If a mouseWheel event occurs with a value less that WHEEL_DELTA, the control should either increment a stored value and wait until the total delta is an increment of WHEEL_DELTA, or scroll the view a percentage of MouseWheelScrollLines. NOTE: A press of the mouseWheel will generate a mouseDown event with the middle button pressed.
AddOnMove (inherited from Control) | Adds an event handler for the move event. The move event occurs when the controls location changes.
AddOnPaint (inherited from RichControl) | Adds an event handler for the paint event. The paint event occurs when the control needs to paint some part of it's client area.
AddOnPropertyChanged (inherited from Control) | Adds an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.
AddOnQueryContinueDrag (inherited from RichControl) | Adds an event handler for the queryContinueDrag event. The queryContinueDrag event occurs during a drag operation. This allows the drag source to determine if the drag operation should be canceled.
AddOnResize (inherited from Control) | Adds an event handler for the resize event. The resize event occurs when the bounds of the control change. This event may be fired from the constructor of base controls.
AddOnValidated (inherited from Control) | Adds an event handler for the validated event. The validated event occurs when a control was successfully validated.
AddOnValidating (inherited from Control) | Adds an event handler for the validating event. The validating event occurs when the control loses focus and a control that causes validation gains focus. This is where users can write code to validate the current values of the control.
RemoveOnAfterCheck (inherited from TreeView) | Removes the given handler from the "afterCheck" event. If there are duplicate entries, all are removed.
RemoveOnAfterCollapse (inherited from TreeView) | Removes the given handler from the "afterCollapse" event. If there are duplicate entries, all are removed.
RemoveOnAfterExpand (inherited from TreeView) | Removes the given handler from the "afterExpand" event. If there are duplicate entries, all are removed.
RemoveOnAfterLabelEdit (inherited from TreeView) | Removes the given handler from the "afterLabelEdit" event. If there are duplicate entries, all are removed.
RemoveOnAfterSelect (inherited from TreeView) | Removes the given handler from the "afterSelect" event. If there are duplicate entries, all are removed.
RemoveOnBeforeCheck (inherited from TreeView) | Removes the given handler from the "beforeCheck" event. If there are duplicate entries, all are removed.
RemoveOnBeforeCollapse (inherited from TreeView) | Removes the given handler from the "beforeCollapse" event. If there are duplicate entries, all are removed.
RemoveOnBeforeExpand (inherited from TreeView) | Removes the given handler from the "beforeExpand" event. If there are duplicate entries, all are removed.
RemoveOnBeforeLabelEdit (inherited from TreeView) | Removes the given handler from the "beforeLabelEdit" event. If there are duplicate entries, all are removed.
RemoveOnBeforeSelect (inherited from TreeView) | Removes the given handler from the "beforeSelect" event. If there are duplicate entries, all are removed.
RemoveOnClick (inherited from Control) | Removes the given handler for the "OnClick" event. If there are duplicate entries, ALL are removed.
RemoveOnControlAdded (inherited from Control) | Removes the given handler for the "ControlAdded" event. If there are duplicate entries, ALL are removed.
RemoveOnControlRemoved (inherited from Control) | Removes the given handler for the "ControlRemoved" event. If there are duplicate entries, ALL are removed.
RemoveOnCreateHandle (inherited from Control) | Removes the given handler for the "createHandle" event. If there are duplicate entries, ALL are removed.
RemoveOnDestroyHandle (inherited from Control) | Removes the given handler for the "destroyHandle" event. If there are duplicate entries, ALL are removed.
RemoveOnDoubleClick (inherited from Control) | Removes the given handler for the "OnDoubleClick" event. If there are duplicate entries, ALL are removed.
RemoveOnDragDrop (inherited from RichControl) | Removes the given handler for the "dragDrop" event. If there are duplicate entries, ALL are removed.
RemoveOnDragEnter (inherited from RichControl) | Removes the given handler for the "OnDragEnter" event. If there are duplicate entries, ALL are removed.
RemoveOnDragLeave (inherited from RichControl) | Removes the given handler for the "OnDragLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnDragOver (inherited from RichControl) | f final Removes the given handler for the "OnDragOver" event. If there are duplicate entries, ALL are removed.
RemoveOnEnter (inherited from Control) | Removes the given handler for the "OnEnter" event. If there are dfinal uplicate entries, ALL are removed.
RemoveOnGiveFeedback (inherited from RichControl) | Removes the given handler for the "OnGiveFeedback" event. If there are duplicate entries, ALL are removed.
RemoveOnGotFocus (inherited from Control) | Removes the given handler for the "OnGotFocus" event. If there are duplicate entries, ALL are removed.
RemoveOnHelp (inherited from RichControl) | Removes the given handler for the "OnHelp" event. If there are duplicate entries, ALL are removed.
RemoveOnInvalidate (inherited from RichControl) | Removes the given handler for the "OnInvalidate" event. If there are duplicate entries, ALL are removed.
RemoveOnItemDrag (inherited from TreeView) | Removes the given handler from the "itemDrag" event. If there are duplicate entries, all are removed.
RemoveOnKeyDown (inherited from Control) | Removes the given handler for the "OnKeyDown" event. If there are duplicate entries, ALL are removed.
RemoveOnKeyPress (inherited from Control) | Removes the given handler for the "OnKeyPress" event. If there are duplicate entries, ALL are removed.
RemoveOnKeyUp (inherited from Control) | Removes the given handler for the "OnKeyUp" event. If there are duplicate entries, ALL are removed.
RemoveOnLayout (inherited from Control) | Removes the given handler for the layout event. If there are duplicate entries, ALL are removed.
RemoveOnLeave (inherited from Control) | Removes the given handler for the "OnLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnLostFocus (inherited from Control) | Removes the given handler for the "OnLostFocus" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseDown (inherited from Control) | Removes the given handler for the "OnMouseDown" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseEnter (inherited from Control) | Removes the given handler for the "OnMouseEnter" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseHover (inherited from Control) | Removes the given handler for the "OnMouseHover" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseLeave (inherited from Control) | Removes the given handler for the "OnMouseLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseMove (inherited from Control) | Removes the given handler for the "OnMouseMove" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseUp (inherited from Control) | Removes the given handler for the "OnMouseUp" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseWheel (inherited from Control) | Removes the given handler for the "OnMouseWheel" event. If there are duplicate entries, ALL are removed.
RemoveOnMove (inherited from Control) | Removes the given handler for the "OnMove" event. If there are duplicate entries, ALL are removed.
RemoveOnPaint (inherited from RichControl) | Removes the given handler for the "OnPaint" event. If there are duplicate entries, ALL are removed.
RemoveOnPropertyChanged (inherited from Control) | Removes an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.
RemoveOnQueryContinueDrag (inherited from RichControl) | Removes the given handler for the "OnQueryContinueDrag" event. If there are duplicate entries, ALL are removed.
RemoveOnResize (inherited from Control) | Removes the given handler for the "OnResize" event. If there are duplicate entries, ALL are removed.
RemoveOnValidated (inherited from Control) | Removes an event handler for the validated event. The validated event occurs when a control was successfully validated.
RemoveOnValidating (inherited from Control) | Removes an event handler for the validating event. The validating event occurs when the control loses focus and a control that causes validation gains focus. This is where users can write code to validate the current values of the control.

See Also

ObjectSelectorEditor.Selector Class | System.ComponentModel.Design Namespace


ObjectSelectorEditor.Selector.AddNode

[To be supplied.]

[Visual Basic]
Public Function AddNode( _
   ByVal label As String, _
   ByVal value As Object, _
   ByVal parent As ObjectSelectorEditor.SelectorNode _
) As SelectorNode
[C#]
public SelectorNode AddNode(
   string label,
   object value,
   ObjectSelectorEditor.SelectorNode parent
);
[C++]
public: SelectorNode* AddNode(
   String* label,
   Object* value,
   ObjectSelectorEditor.SelectorNode* parent
);
[JScript]
public function AddNode(
   label : String,
   value : Object,
   parent : ObjectSelectorEditor.SelectorNode
) : SelectorNode;

Parameters

label
[To be supplied.]
value
[To be supplied.]
parent
[To be supplied.]

See Also

ObjectSelectorEditor.Selector Class | ObjectSelectorEditor.Selector Members | System.ComponentModel.Design Namespace


ObjectSelectorEditor.Selector.Clear

[To be supplied.]

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[JScript]
public function Clear();

See Also

ObjectSelectorEditor.Selector Class | ObjectSelectorEditor.Selector Members | System.ComponentModel.Design Namespace


ObjectSelectorEditor.Selector.OnAfterSelect

[To be supplied.]

[Visual Basic]
Protected Sub OnAfterSelect( _
   ByVal sender As Object, _
   ByVal e As TreeViewEventArgs _
)
[C#]
protected void OnAfterSelect(
   object sender,
   TreeViewEventArgs e
);
[C++]
protected: void OnAfterSelect(
   Object* sender,
   TreeViewEventArgs* e
);
[JScript]
protected function OnAfterSelect(
   sender : Object,
   e : TreeViewEventArgs
);

Parameters

sender
[To be supplied.]
e
[To be supplied.]

See Also

ObjectSelectorEditor.Selector Class | ObjectSelectorEditor.Selector Members | System.ComponentModel.Design Namespace


ObjectSelectorEditor.Selector.OnKeyDown

[To be supplied.]

[Visual Basic]
Overrides Protected Sub OnKeyDown( _
   ByVal e As KeyEventArgs _
)
[C#]
protected override void OnKeyDown(
   KeyEventArgs e
);
[C++]
protected: override void OnKeyDown(
   KeyEventArgs* e
);
[JScript]
protected override function OnKeyDown(
   e : KeyEventArgs
);

Parameters

e
[To be supplied.]

See Also

ObjectSelectorEditor.Selector Class | ObjectSelectorEditor.Selector Members | System.ComponentModel.Design Namespace


ObjectSelectorEditor.Selector.OnKeyPress

[To be supplied.]

[Visual Basic]
Overrides Protected Sub OnKeyPress( _
   ByVal e As KeyPressEventArgs _
)
[C#]
protected override void OnKeyPress(
   KeyPressEventArgs e
);
[C++]
protected: override void OnKeyPress(
   KeyPressEventArgs* e
);
[JScript]
protected override function OnKeyPress(
   e : KeyPressEventArgs
);

Parameters

e
[To be supplied.]

See Also

ObjectSelectorEditor.Selector Class | ObjectSelectorEditor.Selector Members | System.ComponentModel.Design Namespace


ObjectSelectorEditor.Selector.SetSelection

[To be supplied.]

[Visual Basic]
Public Function SetSelection( _
   ByVal value As Object, _
   ByVal nodes As TreeNodeCollection _
) As Boolean
[C#]
public bool SetSelection(
   object value,
   TreeNodeCollection nodes
);
[C++]
public: bool SetSelection(
   Object* value,
   TreeNodeCollection* nodes
);
[JScript]
public function SetSelection(
   value : Object,
   nodes : TreeNodeCollection
) : Boolean;

Parameters

value
[To be supplied.]
nodes
[To be supplied.]

See Also

ObjectSelectorEditor.Selector Class | ObjectSelectorEditor.Selector Members | System.ComponentModel.Design Namespace


ObjectSelectorEditor.Selector.Start

[To be supplied.]

[Visual Basic]
Public Sub Start( _
   ByVal edSvc As IWinFormsEditorService, _
   ByVal value As Object _
)
[C#]
public void Start(
   IWinFormsEditorService edSvc,
   object value
);
[C++]
public: void Start(
   IWinFormsEditorService* edSvc,
   Object* value
);
[JScript]
public function Start(
   edSvc : IWinFormsEditorService,
   value : Object
);

Parameters

edSvc
[To be supplied.]
value
[To be supplied.]

See Also

ObjectSelectorEditor.Selector Class | ObjectSelectorEditor.Selector Members | System.ComponentModel.Design Namespace


ObjectSelectorEditor.Selector.Stop

[To be supplied.]

[Visual Basic]
Public Sub Stop()
[C#]
public void Stop();
[C++]
public: void Stop();
[JScript]
public function Stop();

See Also

ObjectSelectorEditor.Selector Class | ObjectSelectorEditor.Selector Members | System.ComponentModel.Design Namespace


ObjectSelectorEditor.Selector.WndProc

[To be supplied.]

[Visual Basic]
Overrides Protected Sub WndProc( _
   ByRef m As Message _
)
[C#]
protected override void WndProc(
   ref Message m
);
[C++]
protected: override void WndProc(
   Message** m
);
[JScript]
protected override function WndProc(
   m : Message
);

Parameters

m
[To be supplied.]

See Also

ObjectSelectorEditor.Selector Class | ObjectSelectorEditor.Selector Members | System.ComponentModel.Design Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ObjectSelectorEditor.Selector Fields

The fields of the ObjectSelectorEditor.Selector class are listed below. For a complete list of ObjectSelectorEditor.Selector class members, see the ObjectSelectorEditor.Selector Members topic.

Public:

clickSeen [To be supplied.]

See Also

ObjectSelectorEditor.Selector Class | System.ComponentModel.Design Namespace


ObjectSelectorEditor.Selector.clickSeen

[To be supplied.]

[Visual Basic]
Public clickSeen As Boolean
[C#]
public bool clickSeen;
[C++]
public: bool clickSeen;
[JScript]
public var clickSeen : Boolean;

See Also

ObjectSelectorEditor.Selector Class | ObjectSelectorEditor.Selector Members | System.ComponentModel.Design Namespace


ObjectSelectorEditor.SelectorNode Class

[To be supplied.]

Object
MarshalByRefObject
TreeNode
ObjectSelectorEditor.SelectorNode

[Visual Basic]
Public Class ObjectSelectorEditor.SelectorNode
   Inherits TreeNode
[C#]
public class ObjectSelectorEditor.SelectorNode : TreeNode
[C++]
public __gc class ObjectSelectorEditor.SelectorNode : public
   TreeNode
[JScript]
public class ObjectSelectorEditor.SelectorNode extends TreeNode

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

ObjectSelectorEditor.SelectorNode Members | System.ComponentModel.Design Namespace


ObjectSelectorEditor.SelectorNode Members

Public:

Constructor

ObjectSelectorEditorSelectorNode Constructor [To be supplied.]

Properties

BackColor (inherited from TreeNode) | The background color of this node. If null, the color used will be the default color from the TreeView control that this node is attached to
Bounds (inherited from TreeNode) | The bounding rectangle for the node. The coordinates are relative to the upper left corner of the TreeView control.
Checked (inherited from TreeNode) | Indicates whether the node's checkbox is checked.
Extension (inherited from TreeNode) | Retrieves a filename extension to save this object's persistance data with.
FirstNode (inherited from TreeNode) | The first child node of this node.
ForeColor (inherited from TreeNode) | The foreground color of this node. If null, the color used will be the default color from the TreeView control that this node is attached to
FullPath (inherited from TreeNode) | Returns the full path of this node. The path consists of the labels of each of the nodes from the root to this node, each separated by the pathSeperator.
Handle (inherited from TreeNode) | The HTREEITEM handle associated with this node. If the handle has not yet been created, this will force handle creation.
ImageIndex (inherited from TreeNode) | The index of the image to be displayed when the node is in the unselected state. The image is contained in the ImageList referenced by the imageList property.
Index (inherited from TreeNode) | Returns the position of this node in relation to its siblings
IsEditing (inherited from TreeNode) | Specifies whether this node is being edited by the user.
IsExpanded (inherited from TreeNode) | Specifies whether this node is in the expanded state.
IsSelected (inherited from TreeNode) | Specifies whether this node is in the selected state.
IsVisible (inherited from TreeNode) | Specifies whether this node is visible.
LastNode (inherited from TreeNode) | The last child node of this node.
NextNode (inherited from TreeNode) | The next sibling node.
NextVisibleNode (inherited from TreeNode) | The next visible node. It may be a child, sibling, or a node from another branch.
NodeFont (inherited from TreeNode) | The font that will be used to draw this node If null, the font used will be the default font from the TreeView control that this node is attached to. NOTE: If the node font is larger than the default font from the TreeView control, then the node will be clipped.
Nodes (inherited from TreeNode) | [To be supplied.]
Parent (inherited from TreeNode) | Retrieves parent node.
PrevNode (inherited from TreeNode) | The previous sibling node.
PrevVisibleNode (inherited from TreeNode) | The next visible node. It may be a parent, sibling, or a node from another branch.
SelectedImageIndex (inherited from TreeNode) | The index of the image displayed when the node is in the selected state. The image is contained in the ImageList referenced by the imageList property.
Text (inherited from TreeNode) | The label text for the tree node
TreeView (inherited from TreeNode) | Return the TreeView control this node belongs to.

Methods

BeginEdit (inherited from TreeNode) | Initiate editing of the node's label. Only effective if LabelEdit property is true.
Clone (inherited from TreeNode) | Clone the entire subtree rooted at this node.
Collapse (inherited from TreeNode) | Collapse the node.
EndEdit (inherited from TreeNode) | Terminate the editing of any tree view item's label.
EnsureVisible (inherited from TreeNode) | Ensure that the node is visible, expanding nodes and scrolling the TreeView control as necessary.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Expand (inherited from TreeNode) | Expand the node.
ExpandAll (inherited from TreeNode) | Expand the node.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetNodeCount (inherited from TreeNode) | Returns number of child nodes.
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
Remove (inherited from TreeNode) | Remove this node from the TreeView control. Child nodes are also removed from the TreeView, but are still attached to this node.
Toggle (inherited from TreeNode) | Toggle the state of the node. Expand if collapsed or collapse if expanded.
ToString (inherited from TreeNode) | Returns the label text for the tree node

Fields

value [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ObjectSelectorEditor.SelectorNode Class | System.ComponentModel.Design Namespace


ObjectSelectorEditor.SelectorNode Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal label As String, _
   ByVal value As Object _
)
[C#]
public ObjectSelectorEditor.SelectorNode(
   string label,
   object value
);
[C++]
public: ObjectSelectorEditor.SelectorNode(
   String* label,
   Object* value
);
[JScript]
public function ObjectSelectorEditor.SelectorNode(
   label : String,
   value : Object
);

Parameters

label
[To be supplied.]
value
[To be supplied.]

See Also

ObjectSelectorEditor.SelectorNode Class | ObjectSelectorEditor.SelectorNode Members | System.ComponentModel.Design Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ObjectSelectorEditor.SelectorNode Fields

The fields of the ObjectSelectorEditor.SelectorNode class are listed below. For a complete list of ObjectSelectorEditor.SelectorNode class members, see the ObjectSelectorEditor.SelectorNode Members topic.

Public:

value [To be supplied.]

See Also

ObjectSelectorEditor.SelectorNode Class | System.ComponentModel.Design Namespace


ObjectSelectorEditor.SelectorNode.value

[To be supplied.]

[Visual Basic]
Public value As Object
[C#]
public object value;
[C++]
public: Object* value;
[JScript]
public var value : Object;

See Also

ObjectSelectorEditor.SelectorNode Class | ObjectSelectorEditor.SelectorNode Members | System.ComponentModel.Design Namespace


OldArrayEditor Class

ArrayEditor is a value editor that intelligently edits arrays. It uses ArrayDialog in editValue to visually add, remove, and sort arrays. It is a value editor that takes a Class in it's constructor so it knows the type of the array it is editing. ArrayEditor supports editing values, but does not convert text into values.

Object
ValueEditor
OldArrayEditor

[Visual Basic]
Public Class OldArrayEditor
   Inherits ValueEditor
[C#]
public class OldArrayEditor : ValueEditor
[C++]
public __gc class OldArrayEditor : public ValueEditor
[JScript]
public class OldArrayEditor extends ValueEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

OldArrayEditor Members | System.ComponentModel.Design Namespace | ArrayDialog | ValueEditor


OldArrayEditor Members

Public:

Constructor

OldArrayEditor Constructor Constructs the ArrayEditor. Takes a Class an an argument which is the type of the object being edited (should be an array).

Properties

Style (inherited from ValueEditor) | [To be supplied.]
Values (inherited from ValueEditor) | [To be supplied.]

Methods

CreateNewInstance | Creates a new instance of an element. The index is solely for assisting in coming up with default text.
EditValue | This launches the ArrayDialog. This is a base function of ValueEditor.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseName | Retrieves the base name of the type of the elements being edited.
GetCreationBundle (inherited from ValueEditor) | [To be supplied.]
GetDisplayText | Retrieves the text that should be displayed in the ArrayDialog for a given element.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties | Returns the logical sub properties of a given value. These sub properties represent values that together compose the given value. Each of these values can be edited by the user, and GetValueFromSubPropertyValues() will be called to see if a new set of values can compose a new value of this type. This method will only be called if the StyleProperties style is present.
GetTextFromValue (inherited from ValueEditor) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeDescription | Retrieves a visible description of the array type.
GetValueFromSubPropertyValues | Attempts to compose a value of this editor's type from the given array of values. If it is successful, it returns the composed value, otherwise it returns null. This array of values is usually a modified version of the values contained in the sub properties returned by GetSubProperties(). This method will only be called if the StyleProperties style is present.
GetValueFromText (inherited from ValueEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

defaultPropInfo | the default property info for the elements being edited, if it is a string. Used to set the default text.
type | type of the elements of the array.

See Also

OldArrayEditor Class | System.ComponentModel.Design Namespace


OldArrayEditor Constructor

Constructs the ArrayEditor. Takes a Class an an argument which is the type of the object being edited (should be an array).

[Visual Basic]
Public Sub New( _
   ByVal type As Type _
)
[C#]
public OldArrayEditor(
   Type type
);
[C++]
public: OldArrayEditor(
   Type* type
);
[JScript]
public function OldArrayEditor(
   type : Type
);

Parameters

type
of the array being edited.

See Also

OldArrayEditor Class | OldArrayEditor Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

OldArrayEditor Methods

The methods of the OldArrayEditor class are listed below. For a complete list of OldArrayEditor class members, see the OldArrayEditor Members topic.

Public:

CreateNewInstance | Creates a new instance of an element. The index is solely for assisting in coming up with default text.
EditValue | This launches the ArrayDialog. This is a base function of ValueEditor.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseName | Retrieves the base name of the type of the elements being edited.
GetCreationBundle (inherited from ValueEditor) | [To be supplied.]
GetDisplayText | Retrieves the text that should be displayed in the ArrayDialog for a given element.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties | Returns the logical sub properties of a given value. These sub properties represent values that together compose the given value. Each of these values can be edited by the user, and GetValueFromSubPropertyValues() will be called to see if a new set of values can compose a new value of this type. This method will only be called if the StyleProperties style is present.
GetTextFromValue (inherited from ValueEditor) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetTypeDescription | Retrieves a visible description of the array type.
GetValueFromSubPropertyValues | Attempts to compose a value of this editor's type from the given array of values. If it is successful, it returns the composed value, otherwise it returns null. This array of values is usually a modified version of the values contained in the sub properties returned by GetSubProperties(). This method will only be called if the StyleProperties style is present.
GetValueFromText (inherited from ValueEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OldArrayEditor Class | System.ComponentModel.Design Namespace


OldArrayEditor.CreateNewInstance

Creates a new instance of an element. The index is solely for assisting in coming up with default text.

[Visual Basic]
Overridable Public Function CreateNewInstance( _
   ByVal index As Integer _
) As Object
[C#]
public virtual object CreateNewInstance(
   int index
);
[C++]
public: virtual Object* CreateNewInstance(
   int index
);
[JScript]
public function CreateNewInstance(
   index : int
) : Object;

Parameters

index
A hint for coming up with default text.

Return Value

new element.

See Also

OldArrayEditor Class | OldArrayEditor Members | System.ComponentModel.Design Namespace


OldArrayEditor.EditValue

This launches the ArrayDialog. This is a base function of ValueEditor.

[Visual Basic]
Overrides Public Sub EditValue( _
   ByVal valueAccess As IValueAccess _
)
[C#]
public override void EditValue(
   IValueAccess valueAccess
);
[C++]
public: override void EditValue(
   IValueAccess* valueAccess
);
[JScript]
public override function EditValue(
   valueAccess : IValueAccess
);

Parameters

valueAccess
an interface that allows access to the value being edited.

See Also

OldArrayEditor Class | OldArrayEditor Members | System.ComponentModel.Design Namespace | ValueEditor


OldArrayEditor.GetBaseName

Retrieves the base name of the type of the elements being edited.

[Visual Basic]
Overridable Public Function GetBaseName() As String
[C#]
public virtual string GetBaseName();
[C++]
public: virtual String* GetBaseName();
[JScript]
public function GetBaseName() : String;

Return Value

the base name of the type of the elements of the array.

See Also

OldArrayEditor Class | OldArrayEditor Members | System.ComponentModel.Design Namespace


OldArrayEditor.GetDisplayText

Retrieves the text that should be displayed in the ArrayDialog for a given element.

[Visual Basic]
Overridable Public Function GetDisplayText( _
   ByVal value As Object _
) As String
[C#]
public virtual string GetDisplayText(
   object value
);
[C++]
public: virtual String* GetDisplayText(
   Object* value
);
[JScript]
public function GetDisplayText(
   value : Object
) : String;

Parameters

value
[To be supplied.]

Return Value

displayable text for the object.

See Also

OldArrayEditor Class | OldArrayEditor Members | System.ComponentModel.Design Namespace


OldArrayEditor.GetSubProperties

Returns the logical sub properties of a given value. These sub properties represent values that together compose the given value. Each of these values can be edited by the user, and GetValueFromSubPropertyValues() will be called to see if a new set of values can compose a new value of this type. This method will only be called if the StyleProperties style is present.

[Visual Basic]
Overrides Public Function GetSubProperties( _
   ByVal value As Object _
) As SubProperty ()
[C#]
public override SubProperty[] GetSubProperties(
   object value
);
[C++]
public: override SubProperty* GetSubProperties(
   Object* value
) [];
[JScript]
public override function GetSubProperties(
   value : Object
) : SubProperty[];

Parameters

value
Value to be decomposed

Return Value

subproperties The decomposition of the value into editable values.

See Also

OldArrayEditor Class | OldArrayEditor Members | System.ComponentModel.Design Namespace


OldArrayEditor.GetTypeDescription

Retrieves a visible description of the array type.

[Visual Basic]
Overridable Public Function GetTypeDescription() As String
[C#]
public virtual string GetTypeDescription();
[C++]
public: virtual String* GetTypeDescription();
[JScript]
public function GetTypeDescription() : String;

Return Value

a description of the array type.

See Also

OldArrayEditor Class | OldArrayEditor Members | System.ComponentModel.Design Namespace


OldArrayEditor.GetValueFromSubPropertyValues

Attempts to compose a value of this editor's type from the given array of values. If it is successful, it returns the composed value, otherwise it returns null. This array of values is usually a modified version of the values contained in the sub properties returned by GetSubProperties(). This method will only be called if the StyleProperties style is present.

[Visual Basic]
Overrides Public Function GetValueFromSubPropertyValues( _
   ByVal values() As Object _
) As Object
[C#]
public override object GetValueFromSubPropertyValues(
   object[] values
);
[C++]
public: override Object* GetValueFromSubPropertyValues(
   Object* values[]
);
[JScript]
public override function GetValueFromSubPropertyValues(
   values : Object[]
) : Object;

Parameters

values
array of values.

Return Value

value that results from the composition of the inputs. (null if a composition wasn't possible.)

See Also

OldArrayEditor Class | OldArrayEditor Members | System.ComponentModel.Design Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

OldArrayEditor Fields

The fields of the OldArrayEditor class are listed below. For a complete list of OldArrayEditor class members, see the OldArrayEditor Members topic.

Protected:

defaultPropInfo | the default property info for the elements being edited, if it is a string. Used to set the default text.
type | type of the elements of the array.

See Also

OldArrayEditor Class | System.ComponentModel.Design Namespace


OldArrayEditor.defaultPropInfo

the default property info for the elements being edited, if it is a string. Used to set the default text.

[Visual Basic]
Protected defaultPropInfo As PropertyDescriptor
[C#]
protected PropertyDescriptor defaultPropInfo;
[C++]
protected: PropertyDescriptor* defaultPropInfo;
[JScript]
protected var defaultPropInfo : PropertyDescriptor;

See Also

OldArrayEditor Class | OldArrayEditor Members | System.ComponentModel.Design Namespace


OldArrayEditor.type

type of the elements of the array.

[Visual Basic]
Protected type As Type
[C#]
protected Type type;
[C++]
protected: Type* type;
[JScript]
protected var type : Type;

See Also

OldArrayEditor Class | OldArrayEditor Members | System.ComponentModel.Design Namespace


OldCollectionEditor Class

Generic editor for any collection property

Object
ValueEditor
OldCollectionEditor

[Visual Basic]
Public Class OldCollectionEditor
   Inherits ValueEditor
[C#]
public class OldCollectionEditor : ValueEditor
[C++]
public __gc class OldCollectionEditor : public ValueEditor
[JScript]
public class OldCollectionEditor extends ValueEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

OldCollectionEditor Members | System.ComponentModel.Design Namespace


OldCollectionEditor Members

Public:

Constructor

OldCollectionEditor Constructor [To be supplied.]

Properties

Style | Returns the style flags for the value editor. The returned value must be a combination of the STYLE_XXX bit masks defined in this interface.
Values (inherited from ValueEditor) | [To be supplied.]

Methods

EditValue | Takes the value returned from valueAccess.getValue() and modifies or replaces the value, passing the result into valueAccess.setValue(). This is where an editor can launch a modal dialog or create a drop down editor to allow the user to modify the value. Host assistance in presenting UI to the user can be found through the valueAccess.getService function.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from ValueEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue | Converts the given value to a text string. The return value may be null if the value cannot be converted to a text string.
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from ValueEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

AddTypes [To be supplied.]

Methods

CreateNewInstance | [To be supplied.]
DestroyNewInstance | [To be supplied.]
DestroyOldInstance | Called every time user clicks Remove button for the item which existed in initial Collection. Supposed to check if the item can be removed from collection. If item cannot be removed ArgumentException(<reasonString>) should be thrown.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OldCollectionEditor Class | System.ComponentModel.Design Namespace


OldCollectionEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public OldCollectionEditor();
[C++]
public: OldCollectionEditor();
[JScript]
public function OldCollectionEditor();

See Also

OldCollectionEditor Class | OldCollectionEditor Members | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

OldCollectionEditor Properties

The properties of the OldCollectionEditor class are listed below. For a complete list of OldCollectionEditor class members, see the OldCollectionEditor Members topic.

Public:

Style | Returns the style flags for the value editor. The returned value must be a combination of the STYLE_XXX bit masks defined in this interface.
Values (inherited from ValueEditor) | [To be supplied.]

Protected:

AddTypes [To be supplied.]

See Also

OldCollectionEditor Class | System.ComponentModel.Design Namespace


OldCollectionEditor.AddTypes

[To be supplied.]

[Visual Basic]
Overridable Protected ReadOnly Property AddTypes As Type ()
[C#]
protected Type[] AddTypes {virtual get;}
[C++]
protected: __property virtual Type* get_AddTypes();
[JScript]
protected function get AddTypes() : Type[];

See Also

OldCollectionEditor Class | OldCollectionEditor Members | System.ComponentModel.Design Namespace


OldCollectionEditor.Style

Returns the style flags for the value editor. The returned value must be a combination of the STYLE_XXX bit masks defined in this interface.

[Visual Basic]
Overridable Public ReadOnly Property Style As ValueEditorStyles
[C#]
public ValueEditorStyles Style {override get;}
[C++]
public: __property virtual ValueEditorStyles get_Style();
[JScript]
public function get Style() : ValueEditorStyles;

See Also

OldCollectionEditor Class | OldCollectionEditor Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

OldCollectionEditor Methods

The methods of the OldCollectionEditor class are listed below. For a complete list of OldCollectionEditor class members, see the OldCollectionEditor Members topic.

Public:

EditValue | Takes the value returned from valueAccess.getValue() and modifies or replaces the value, passing the result into valueAccess.setValue(). This is where an editor can launch a modal dialog or create a drop down editor to allow the user to modify the value. Host assistance in presenting UI to the user can be found through the valueAccess.getService function.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from ValueEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue | Converts the given value to a text string. The return value may be null if the value cannot be converted to a text string.
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from ValueEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

CreateNewInstance | [To be supplied.]
DestroyNewInstance | [To be supplied.]
DestroyOldInstance | Called every time user clicks Remove button for the item which existed in initial Collection. Supposed to check if the item can be removed from collection. If item cannot be removed ArgumentException(<reasonString>) should be thrown.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OldCollectionEditor Class | System.ComponentModel.Design Namespace


OldCollectionEditor.CreateNewInstance

[To be supplied.]

[Visual Basic]
Overridable Protected Function CreateNewInstance( _
   ByVal valueAccess As IValueAccess, _
   ByVal type As Type _
) As Object
[C#]
protected virtual object CreateNewInstance(
   IValueAccess valueAccess,
   Type type
);
[C++]
protected: virtual Object* CreateNewInstance(
   IValueAccess* valueAccess,
   Type* type
);
[JScript]
protected function CreateNewInstance(
   valueAccess : IValueAccess,
   type : Type
) : Object;

Parameters

valueAccess
[To be supplied.]
type
[To be supplied.]

See Also

OldCollectionEditor Class | OldCollectionEditor Members | System.ComponentModel.Design Namespace


OldCollectionEditor.DestroyNewInstance

[To be supplied.]

[Visual Basic]
Overridable Protected Sub DestroyNewInstance( _
   ByVal valueAccess As IValueAccess, _
   ByVal value As Object _
)
[C#]
protected virtual void DestroyNewInstance(
   IValueAccess valueAccess,
   object value
);
[C++]
protected: virtual void DestroyNewInstance(
   IValueAccess* valueAccess,
   Object* value
);
[JScript]
protected function DestroyNewInstance(
   valueAccess : IValueAccess,
   value : Object
);

Parameters

valueAccess
[To be supplied.]
value
[To be supplied.]

See Also

OldCollectionEditor Class | OldCollectionEditor Members | System.ComponentModel.Design Namespace


OldCollectionEditor.DestroyOldInstance

Called every time user clicks Remove button for the item which existed in initial Collection. Supposed to check if the item can be removed from collection. If item cannot be removed ArgumentException(<reasonString>) should be thrown.

[Visual Basic]
Overridable Protected Sub DestroyOldInstance( _
   ByVal valueAccess As IValueAccess, _
   ByVal value As Object _
)
[C#]
protected virtual void DestroyOldInstance(
   IValueAccess valueAccess,
   object value
);
[C++]
protected: virtual void DestroyOldInstance(
   IValueAccess* valueAccess,
   Object* value
);
[JScript]
protected function DestroyOldInstance(
   valueAccess : IValueAccess,
   value : Object
);

Parameters

valueAccess
[To be supplied.]
value
[To be supplied.]

See Also

OldCollectionEditor Class | OldCollectionEditor Members | System.ComponentModel.Design Namespace


OldCollectionEditor.EditValue

Takes the value returned from valueAccess.getValue() and modifies or replaces the value, passing the result into valueAccess.setValue(). This is where an editor can launch a modal dialog or create a drop down editor to allow the user to modify the value. Host assistance in presenting UI to the user can be found through the valueAccess.getService function.

[Visual Basic]
Overrides Public Sub EditValue( _
   ByVal valueAccess As IValueAccess _
)
[C#]
public override void EditValue(
   IValueAccess valueAccess
);
[C++]
public: override void EditValue(
   IValueAccess* valueAccess
);
[JScript]
public override function EditValue(
   valueAccess : IValueAccess
);

Parameters

valueAccess
The way that editValue accesses and modifies a given value.

See Also

OldCollectionEditor Class | OldCollectionEditor Members | System.ComponentModel.Design Namespace | IValueAccess


OldCollectionEditor.GetTextFromValue

Converts the given value to a text string. The return value may be null if the value cannot be converted to a text string.

[Visual Basic]
Overrides Public Function GetTextFromValue( _
   ByVal value As Object _
) As String
[C#]
public override string GetTextFromValue(
   object value
);
[C++]
public: override String* GetTextFromValue(
   Object* value
);
[JScript]
public override function GetTextFromValue(
   value : Object
) : String;

Parameters

value
[To be supplied.]

See Also

OldCollectionEditor Class | OldCollectionEditor Members | System.ComponentModel.Design Namespace


OldCollectionEditor.CollectionDialog Class

ArrayDialog is a modal dialog that allows editing of arrays. With it, you can add, remove, and sort the items in the array. It requires an ArrayEditor which it calls to create new values.

Object
MarshalByRefObject
MarshalByRefComponent
Control
RichControl
ScrollableControl
ContainerControl
Form
OldCollectionEditor.CollectionDialog

[Visual Basic]
Public Class OldCollectionEditor.CollectionDialog
   Inherits Form
[C#]
public class OldCollectionEditor.CollectionDialog : Form
[C++]
public __gc class OldCollectionEditor.CollectionDialog : public
   Form
[JScript]
public class OldCollectionEditor.CollectionDialog extends Form

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

OldCollectionEditor.CollectionDialog Members | System.ComponentModel.Design Namespace | ArrayEditor


OldCollectionEditor.CollectionDialog Members

Public:

Constructor

OldCollectionEditorCollectionDialog Constructor [To be supplied.]

Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from RichControl) | The Accessibility Object for this RichControl
AccessibleDefaultActionDescription (inherited from RichControl) | The default action description of the control
AccessibleDescription (inherited from RichControl) | The accessible description of the control
AccessibleHelpProvider (inherited from RichControl) | The help provider for this RichControl
AccessibleName (inherited from RichControl) | The accessible name of the control
AccessibleRole (inherited from RichControl) | The accessible role of the control
ActiveControl (inherited from ContainerControl) | The current active control.
ActiveMDIChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from RichControl) | The allowDrop property. If allowDrop is set to true then this control will allow drag and drop operations and events to be used.
AllowTransparency (inherited from RichControl) | Determines if the control should be allowed to have the opacity adjusted. This is primarily a performance optimization, in that you can always set the opacity to any value, and that will force AllowTransparency to true. However, setting the opacity to any given value will switch the control into layered mode. By setting the AllowTransparency property to false the control will actually switch out of layered mode, which provides better performance if you don't intend to adjust the opacity.
Anchor (inherited from RichControl) | The current value of the anchor property. The anchor property determines which edges of the control are anchored to the container's edges.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form will adjust its size to fit the height of the font used on the form and scale its controls.
AutoScaleBaseSize (inherited from Form) | The base size used for autoscaling. The AutoScaleBaseSize is used internally to determine how much to scale the form when AutoScaling is used.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form implements autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Retrieves the current value of the AutoScrollMinSize property. The AutoScrollMinSize property is used internally to manage the screen size allocated to the automatic scrollbars.
AutoScrollPosition (inherited from ScrollableControl) | Retrieves the current value of the AutoScrollPosition property. The AutoScrollPosition property is used internally to adjust the position of controls that there placed on the Form throughout the form designer.
BackColor (inherited from RichControl) | The background color of this control. This is an ambient property and will always return a non-null value.
BackgroundImage (inherited from RichControl) | The background image of the control.
BindingManager (inherited from ContainerControl) | The binding manager for the container control.
Bindings (inherited from RichControl) | Retrieves the bindings for this control.
BorderStyle (inherited from Form) | Gets or sets the border style of the form.
Bottom (inherited from Control) | The bottom coordinate of this control.
Bounds (inherited from Control) | The bounds of this control. This is the window coordinates of the control in parent client coordinates.
CancelButton (inherited from Form) | Gets or sets the button control that will be clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Checks if this control can receive focus. The result is true if the control has a handle and if it and all of its parent controls are both visible and enabled.
CanSelect (inherited from Control) | Checks if this control can be selected. The result is true if the control is contained in a form and if all of its parent controls are both visible and enabled.
Capture (inherited from Control) | If this control has captured the mouse then this will return true.
CausesValidation (inherited from Control) | Indicates whether entering this control causes validation on the controls requiring validation. This is set to false usually for things like the Help button, etc...
ClientRectangle (inherited from Control) | The client rect of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from RichControl) | Retrieves the company name of this specific component.
ContainsFocus (inherited from Control) | Indicates whether the control or one of its children currently has the system focus.
ContextMenu (inherited from RichControl) | The contextMenu associated with this control. The contextMenu will be shown when the user right clicks the mouse on the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether the form has a control box.
Controls (inherited from Control) | Collection of child controls.
Created (inherited from Control) | Returns true if the control has been created.
Cursor (inherited from RichControl) | Retrieves the cursor that will be displayed when the mouse is over this control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Retreives the current display rectangle. The display rectangle is the virtual display area that is used to layout components. The position and dimensions of the Form's display rectangle change during autoScroll.
Disposed (inherited from Control) | Indicates that the control has been disposed, and is no longer a valid Windows control even though the object instance is still alive.
Disposing (inherited from Control) | Indicates that the control is in the process of being beendisposed, and is no longer a valid Windows control even though the object instance is still alive.
Dock (inherited from RichControl) | The dock property. The dock property controls to which edge of the container this control is docked to. For example, when docked to the top of the container, the control will be displayed flush at the top of the container, extending the length of the container.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | The current enabled state of this control.
Focused (inherited from Control) | Returns true if this control has focus.
Font (inherited from RichControl) | Retrieves the current font for this control. This will be the font used by default for painting and text in the control.
ForeColor (inherited from RichControl) | The foreground color of the control.
Handle (inherited from Control) | The HWND handle that this control is bound to. If the handle has not yet been created, this will force handle creation.
HandleCreated (inherited from Control) | Whether or not this control has a handle associated with it.
Height (inherited from Control) | The height of this control
HelpButton (inherited from Form) | Gets or sets a value indicating whether a help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
IMEMode (inherited from RichControl) | Specifies a value that determines the IME (Input Method Editor) status of the object when that object is selected.
InvokeRequired (inherited from RichControl) | Determines if the caller must call invoke when making method calls to this control. Controls in WinForms are bound to a specific thread, and are not thread safe. Therefore, if you are calling a control's method from a different thread, you must use the control's invoke method to marshal the call to the proper thread. This function can be used to determine if you must call invoke, which can be handy if you don't know what thread owns a control. There are five functions on a control that are safe to call from any thread: GetInvokeRequired, Invoke, BeginInvoke, EndInvoke and CreateGraphics. For all other metohd calls, you should use one of the invoke methods.
IsAccessible (inherited from RichControl) | Indicates whether or not this control is an accessible control i.e. whether it should be visible to accessibility applications.
IsMDIChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMDIContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | The left coordinate of this control.
Location (inherited from Control) | The location of this control.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize box is displayed in the caption box of the form.
MDIChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MDIParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize box is displayed in the caption box of the form.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Opacity (inherited from Form) | [To be supplied.]
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from Form) | The form that is the visual parent of this form.
ProductName (inherited from RichControl) | Retrieves the product name of this specific component.
ProductVersion (inherited from RichControl) | Retrieves the product version of this specific component.
RecreatingHandle (inherited from Control) | This is true if the control is currently recreating its handle.
Region (inherited from RichControl) | The Region associated with this control. (defines the outline/silhouette/boundary of control)
Right (inherited from Control) | The right coordinate of this control.
RightToLeft (inherited from RichControl) | This is used for international applications where the language is written from RightToLeft. When this property is true, control placement and text will be from right to left.
ShowInTaskbar (inherited from Form) | If ShowInTaskbar is true then the form will be displayed in the Windows Taskbar.
Site (inherited from MarshalByRefComponent) | Gets or sets the site of the component.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of size grip to display in the lower-left corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | [To be supplied.]
TabStop (inherited from Control) | A boolean value indicating whether the user can give the focus to this control using the TAB key.
Text (inherited from Control) | The current text associated with this control.
Top (inherited from Control) | Top coordinate of this control.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | The top level control that contains this control. This doesn't have to be the same as the value returned from getForm since forms can be parented to other controls.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
Visible (inherited from Form) | Gets or sets a value indicating whether the form is visible.
Width (inherited from Control) | The width of this control.
WindowState (inherited from Form) The WindowState of the Form. Valid values are:
FormWindowState.Normal
    FormWindowState.Maximized
    FormWindowState.Minimized
WindowTarget (inherited from Control) | The target of Win32 window messages.

Methods

Activate (inherited from Form) | Activates the form and gives it focus.
ActivateControl (inherited from ContainerControl) | [To be supplied.]
AddOwnedForm (inherited from Form) | Adds an owned form to this form. Owned forms are other top level forms that are children of this form.
BeginInvoke (inherited from RichControl) | Overloaded. [To be supplied.]
BringToFront (inherited from Control) | Brings this control to the front of the zorder.
CallWndProc (inherited from Control) | Dispatch the method to this window's wndProc directly.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Checks if a control is a child of this control.
CreateControl (inherited from Control) | Forces the creation of the control. This includes the creation of the handle, and any child controls.
CreateGraphics (inherited from RichControl) | Overloaded. [To be supplied.]
CreateWindowGraphics (inherited from RichControl) | Creates a Graphics for the entire window of the control rather than just it's client area. The controls foreground color and background color become the default values for the Graphics. The returned Graphics must be disposed through a call to its dispose() method when it is no longer needed. The Graphics Object is only valid for the duration of the current window's message.
Dispose | [To be supplied.]
DoDragDrop (inherited from RichControl) | Begins a drag operation. The allowedEffects determine which drag operations can occur. If the drag operation needs to interop with applications in another process, data should either be a base managed class (String, Bitmap, or Metafile) or some Object that implements System.ComponentModel.IPersistable. data can also be any Object that implements System.WinForms.IDataObject.
EndInvoke (inherited from RichControl) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult interface passed. If the async operation has not been completed, this function will block until the result is available.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FindForm (inherited from Form) | Retrieves the form that this control is parented to.
Focus (inherited from Control) | Attempts to set focus to this control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified client coordinates.
GetContainer (inherited from MarshalByRefComponent) | Returns the component's container.
GetContainerControl (inherited from Control) | Returns the closest ContainerControl in the control's chain of parent controls and forms.
GetDesignMode (inherited from MarshalByRefComponent) | Determines whether the component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetItems | [To be supplied.]
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetMDIClient (inherited from Form) | Returns the control that is the MDI Client region.
GetNextControl (inherited from Control) | Retrieves the next control in the tab order of child controls.
GetServiceObject (inherited from MarshalByRefComponent) | The implementation of IServiceObjectProvider
GetType (inherited from Object) | Gets the Type of the Object.
Hide (inherited from Control) | Hides the control by setting the visible property to false;
InitializeLifetimeService (inherited from MarshalByRefObject)
Invalidate (inherited from Control) | Overloaded. [To be supplied.]
Invoke (inherited from RichControl) | Overloaded. [To be supplied.]
LayoutMDI (inherited from Form) | Arranges the MDI child forms according to value, which should be a member of the MDILayout enum.
PerformLayout (inherited from Control) | Overloaded. [To be supplied.]
PointToClient (inherited from Form) | [To be supplied.]
PointToScreen (inherited from Form) | [To be supplied.]
PreProcessMessage (inherited from Control) | This method is called by the application's message loop to pre-process input messages before they are dispatched. Possible values for the msg.message field are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR. If this method processes the message it must return true, in which case the message loop will not dispatch the message. For WM_KEYDOWN and WM_SYSKEYDOWN messages, preProcessMessage() first calls processCmdKey() to check for command keys such as accelerators and menu shortcuts. If processCmdKey() doesn't process the message, then isInputKey() is called to check whether the key message represents an input key for the control. Finally, if isInputKey() indicates that the control isn't interested in the key message, then processDialogKey() is called to check for dialog keys such as TAB, arrow keys, and mnemonics. For WM_CHAR messages, preProcessMessage() first calls isInputChar() to check whether the character message represents an input character for the control. If isInputChar() indicates that the control isn't interested in the character message, then processDialogChar() is called to check for dialog characters such as mnemonics. For WM_SYSCHAR messages, preProcessMessage() calls processDialogChar() to check for dialog characters such as mnemonics. When overriding preProcessMessage(), a control should return true to indicate that it has processed the message. For messages that aren't processed by the control, the result of "base.preProcessMessage()" should be returned. Controls will typically override one of the more specialized methods (isInputChar(), isInputKey(), processCmdKey(), processDialogChar(), or processDialogKey()) instead of overriding preProcessMessage().
RectangleToClient (inherited from Form) | [To be supplied.]
RectangleToScreen (inherited from Form) | [To be supplied.]
Refresh (inherited from Control) | Forces the control to invalidate and immediately repaint itself and any children.
RemoveOwnedForm (inherited from Form) | Removes a form from the list of owned forms. Also sets the owner of the removed form to null.
ResetBackColor (inherited from RichControl) | Resets the back color to be based on the parent's back color.
ResetBindings (inherited from RichControl) | [To be supplied.]
ResetCursor (inherited from RichControl) | [To be supplied.]
ResetFont (inherited from RichControl) | Resets the font to be based on the parent's font.
ResetForeColor (inherited from RichControl) | Resets the fore color to be based on the parent's fore color.
ResetRightToLeft (inherited from RichControl) | Resets the RightToLeft to be the default.
ResetText (inherited from Control) | Resets the text to it's default value.
ResumeLayout (inherited from Control) | Overloaded. [To be supplied.]
Scale (inherited from Control) | Overloaded. [To be supplied.]
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the currently active control into view if we are an AutoScroll Form that has the Horiz or Vert scrollbar displayed...
Select (inherited from Control) | Activates this control.
SelectNextControl (inherited from Control) | Selects the next control following ctl.
SendMessage (inherited from Control) | Overloaded. [To be supplied.]
SendToBack (inherited from Control) | sends this control to the back of the z-order
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. [To be supplied.]
SetClientSize (inherited from Control) | Sets the height and width of the client area of the control.
SetDesktopBounds (inherited from Form) | Sets the bounds of the Form in desktop coordinates. Desktop coordinates are based on the working area of the screen, which excludes the Taskbar.
SetDesktopLocation (inherited from Form) | Sets the location of the Form in desktop coordinates.
SetItems | [To be supplied.]
SetLocation (inherited from Control) | Sets the location of this control.
SetNewControls (inherited from Form) | [To be supplied.]
SetSize (inherited from Control) | Sets the size of this control.
ShouldPersistAutoScaleBaseSize (inherited from Form) | [To be supplied.]
ShouldPersistAutoScrollMargin (inherited from ScrollableControl) | Indicates whether the AutoScrollMargin property should be persisted.
ShouldPersistAutoScrollMinSize (inherited from ScrollableControl) | Indicates whether the AutoScrollMinSize property should be persisted.
ShouldPersistAutoScrollPosition (inherited from ScrollableControl) | Indicates whether the AutoScrollPosition property should be persisted.
ShouldPersistBackColor (inherited from Form) | [To be supplied.]
ShouldPersistBindings (inherited from RichControl) | [To be supplied.]
ShouldPersistCursor (inherited from RichControl) | Returns true if the cursor should be persisted in code gen.
ShouldPersistFont (inherited from RichControl) | Returns true if the font should be persisted in code gen.
ShouldPersistForeColor (inherited from Form) | [To be supplied.]
ShouldPersistIcon (inherited from Form) | [To be supplied.]
ShouldPersistLocation (inherited from Control) | Determines if the Location property needs to be persisted.
ShouldPersistRightToLeft (inherited from RichControl) | Returns true if the RightToLeft should be persisted in code gen.
ShouldPersistSize (inherited from Form) | [To be supplied.]
ShouldPersistText (inherited from Control) | Determines if the Text property needs to be persisted.
Show (inherited from Control) | Makes the control display by setting the visible property to true
ShowDialog (inherited from Form) | Overloaded. [To be supplied.]
SuspendLayout (inherited from Control) | Suspends the layout logic for the control.
ToString (inherited from Form) | Returns a string representation for this control.
Update (inherited from Control) | Forces the control to paint any currently invalid areas.
Validate (inherited from ContainerControl) | Validates the last unvalidated control and it's ancestors up through (but not including) this.

Events

Activate (inherited from Form) | [To be supplied.]
Click (inherited from Control) | [To be supplied.]
Closed (inherited from Form) | [To be supplied.]
Closing (inherited from Form) | [To be supplied.]
ControlAdded (inherited from Control) | [To be supplied.]
ControlRemoved (inherited from Control) | [To be supplied.]
CreateHandle (inherited from Control) | [To be supplied.]
Deactivate (inherited from Form) | [To be supplied.]
DestroyHandle (inherited from Control) | [To be supplied.]
DoubleClick (inherited from Control) | [To be supplied.]
DragDrop (inherited from RichControl) | [To be supplied.]
DragEnter (inherited from RichControl) | [To be supplied.]
DragLeave (inherited from RichControl) | [To be supplied.]
DragOver (inherited from RichControl) | [To be supplied.]
Enter (inherited from Control) | [To be supplied.]
GiveFeedback (inherited from RichControl) | [To be supplied.]
GotFocus (inherited from Control) | [To be supplied.]
Help (inherited from RichControl) | [To be supplied.]
InputLangChange (inherited from Form) | [To be supplied.]
InputLangChangeRequest (inherited from Form) | [To be supplied.]
Invalidate (inherited from RichControl) | [To be supplied.]
KeyDown (inherited from Control) | [To be supplied.]
KeyPress (inherited from Control) | [To be supplied.]
KeyUp (inherited from Control) | [To be supplied.]
Layout (inherited from Control) | [To be supplied.]
Leave (inherited from Control) | [To be supplied.]
LostFocus (inherited from Control) | [To be supplied.]
MDIChildActivate (inherited from Form) | [To be supplied.]
MenuComplete (inherited from Form) | [To be supplied.]
MenuStart (inherited from Form) | [To be supplied.]
MouseDown (inherited from Control) | [To be supplied.]
MouseEnter (inherited from Control) | [To be supplied.]
MouseHover (inherited from Control) | [To be supplied.]
MouseLeave (inherited from Control) | [To be supplied.]
MouseMove (inherited from Control) | [To be supplied.]
MouseUp (inherited from Control) | [To be supplied.]
MouseWheel (inherited from Control) | [To be supplied.]
Move (inherited from Control) | [To be supplied.]
Paint (inherited from RichControl) | [To be supplied.]
PropertyChanged (inherited from Control) | [To be supplied.]
QueryContinueDrag (inherited from RichControl) | [To be supplied.]
Resize (inherited from Control) | [To be supplied.]
Validated (inherited from Control) | [To be supplied.]
Validating (inherited from Control) | [To be supplied.]

Protected:

Properties

CreateParams (inherited from Form) | Retrieves the CreateParams used to create the window. If a subclass overrides this function, it must call the super implementation.
CreateThreadId (inherited from Control) | Retrieves the Win32 thread ID of the thread that created the handle for this control. If the control's handle hasn't been created yet, this method will return the current thread's ID.
FontHeight (inherited from RichControl) | [To be supplied.]
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
InternalHandle (inherited from Control) | Returns the current value of the handle. This may be zero if the handle has not been created.
MaximizedBounds (inherited from Form) | Gets the size of the form when it is maximized.
MaxTrackSize (inherited from Form) | Gets the maximum size the form can be resized to.
MinTrackSize | [To be supplied.]
ParkingFormHandle (inherited from RichControl) | [To be supplied.]
RenderRightToLeft (inherited from RichControl) | [To be supplied.]
RichParent (inherited from RichControl) | [To be supplied.]
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.
WarningBanner (inherited from Form) | Determines if this form should be displayed with a warning banner.
WindowText (inherited from Form) | Gets or sets the text to display in the caption bar of the form.

Methods

AddEventHandler (inherited from Control) | [To be supplied.]
AdjustFormScrollbars (inherited from Form) | [To be supplied.]
ApplyAutoScaling (inherited from Form) | This auto scales the form based on the AutoScaleBaseSize.
AssignParent (inherited from RichControl) | Assigns a new parent control. Sends out the appropriate property change notifications for properties that are affected by the change of parent.
CenterToScreen (inherited from Form) | Centers the dialog to the screen. This will first attempt to use the owner property to determine the correct screen, then it will try the HWND owner of the form, and finally this will center the form on the same monitor as the mouse cursor.
ChildGotFocus (inherited from Control) | [To be supplied.]
CreateAccessibilityInstance (inherited from RichControl) | Constructs the new instance of the accessibility object for this control. Subclasses should not call base.CreateAccessibilityObject.
CreateControlsInstance (inherited from Form) | [To be supplied.]
CreateHandle (inherited from Form) | Creates the handle for the Form. If a subclass overrides this function, it must call the super implementation.
CreateNewInstance | [To be supplied.]
DefWndProc (inherited from Form) | Calls the default window proc for the form. If a subclass overrides this function, it must call the super implementation.
DestroyHandle (inherited from RichControl) | [To be supplied.]
DestroyNewInstance | [To be supplied.]
DestroyOldInstance | [To be supplied.]
Finalize (inherited from Control) | [To be supplied.]
GetEventHandler (inherited from RichControl) | RichControl overrides the default implementation of this for AX sourcing. ActiveX controls can "freeze" their events, and we implement this by returning null here if events are frozen.
GetScrollState (inherited from ScrollableControl) | Tests a given scroll state bit to determine if it is set.
GetStyle (inherited from Control) | Retrieves the current value of the specified bit in the control's style. NOTE: This is control style, not the Win32 style of the hwnd.
InitLayout (inherited from RichControl) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | [To be supplied.]
InvokeLostFocus (inherited from Control) | [To be supplied.]
InvokeOnClick (inherited from Control) | [To be supplied.]
InvokePaint (inherited from RichControl) | [To be supplied.]
InvokePaintBackground (inherited from RichControl) | [To be supplied.]
IsInputChar (inherited from Control) | Determines if charCode is an input character that the control wants. This method is called during window message pre-processing to determine whether the given input character should be pre-processed or sent directly to the control. If isInputChar returns true, the given character is sent directly to the control. If isInputChar returns false, the character is pre-processed and only sent to the control if it is not consumed by the pre-processing phase. The pre-processing of a character includes checking whether the character is a mnemonic of another control.
IsInputKey (inherited from Control) | Determines if keyData is an input key that the control wants. This method is called during window message pre-processing to determine whether the given input key should be pre-processed or sent directly to the control. If isInputKey returns true, the given key is sent directly to the control. If isInputKey returns false, the key is pre-processed and only sent to the control if it is not consumed by the pre-processing phase. Keys that are pre-processed include TAB, RETURN, ESCAPE, and arrow keys.
Listbox_drawItem | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from RichControl) | [To be supplied.]
OnActivate (inherited from Form) | The activate event is fired when the form is activated.
OnClick (inherited from Control) | This method actually raises the Click event. Inheriting classes should override this if they wish to be notified of a Click event. (This is far preferable to actually adding an event handler.) They should not, however, forget to call base.onClick(e); before exiting, to ensure that other recipients do actually get the event.
OnClosed (inherited from Form) | The Closed event is fired when the form is closed.
OnClosing (inherited from Form) | The Closing event is fired when the form is closed.
OnControlAdded (inherited from Control) | Called when a child control is added to this control.
OnControlRemoved (inherited from ContainerControl) | Called when a child control is removed from this control.
OnCreateControl (inherited from Form) | Fired when this control is first created.
OnCreateHandle (inherited from RichControl) | Inheriting classes should override this method to find out when the handle has been created. Call base.onCreateHandle first.
OnDeactivate (inherited from Form) | The deactivate event is fired when the form is deactivated.
OnDestroyHandle (inherited from RichControl) | Inheriting classes should override this method to find out when the handle is about to be destroyed. Call base.onDestroyHandle last.
OnDoubleClick (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onDoubleClick to send this event to any registered event listeners.
OnDragDrop (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragDrop to send this event to any registered event listeners.
OnDragEnter (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragEnter to send this event to any registered event listeners.
OnDragLeave (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragLeave to send this event to any registered event listeners.
OnDragOver (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragOver to send this event to any registered event listeners.
OnEnter (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onEnter to send this event to any registered event listeners.
OnGiveFeedback (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onGiveFeedback to send this event to any registered event listeners.
OnGotFocus (inherited from RichControl) | [To be supplied.]
OnHelp (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onHelp to send this event to any registered event listeners.
OnInputLangChange (inherited from Form) | The InputLangChange event is fired after the input language has changed for this form.
OnInputLangChangeRequest (inherited from Form) | The InputLangChangeRequest event is fired when the user attempts to change the input language for this form. If the event is cancel then the input language will not change.
OnInvalidate (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.OnInvalidate to send this event to any registered event listeners.
OnKeyDown (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onKeyDown to send this event to any registered event listeners.
OnKeyPress (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.OnKeyPress to send this event to any registered event listeners.
OnKeyUp (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onKeyUp to send this event to any registered event listeners.
OnLayout (inherited from ScrollableControl) | Forces the layout of any docked or anchored child controls.
OnLeave (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onLeave to send this event to any registered event listeners.
OnLostFocus (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onLostFocus to send this event to any registered event listeners.
OnMDIChildActivate (inherited from Form) | Overloaded. [To be supplied.]
OnMenuComplete (inherited from Form) | Inheriting classes should override this method to provide user feedback after a menu selection has been completed. This method will be called when the menu selection has been completed, regardless of whether the user selected a menu item, or canceled the selection. This event signifies that the menu modal message loop has been exited.
OnMenuStart (inherited from Form) | Inheriting classes should override this method to provide user feedback when a menu is displayed. This method will be called when any menu is displayed. This event signifies that the menu modal message loop has been entered.
OnMouseDown (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseDown to send this event to any registered event listeners.
OnMouseEnter (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseEnter to send this event to any registered event listeners.
OnMouseHover (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseHover to send this event to any registered event listeners.
OnMouseLeave (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseLeave to send this event to any registered event listeners.
OnMouseMove (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseMove to send this event to any registered event listeners.
OnMouseUp (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseUp to send this event to any registered event listeners.
OnMouseWheel (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseWheel to send this event to any registered event listeners.
OnMove (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMove to send this event to any registered event listeners.
OnPaint (inherited from Form) | [To be supplied.]
OnPaintBackground (inherited from RichControl) | Inheriting classes should override this method to handle the erase background request from windows. It is not necessary to call base.onPaintBackground, however if you do not want the default Windows behavior you must set event.handled to true.
OnParentPropertyChanged (inherited from RichControl) | This method is called by the parent control when any property changes on the parent. This can be overriden by inheriting classes, however they must call base.OnParentPropertyChanged.
OnPropertyChanged (inherited from Form) | [To be supplied.]
OnQueryContinueDrag (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onQueryContinueDrag to send this event to any registered event listeners.
OnResize (inherited from Form) | [To be supplied.]
OnValidated (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onResize to send this event to any registered event listeners.
OnValidating (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onResize to send this event to any registered event listeners.
ParentChanged (inherited from Control) | Called by the framework after a control's parent changes. This allows (for example) child controls to automatically hook events on their parent, giving better encapsulation.
ProcessCmdKey (inherited from Form) | Processes a command key. Overrides Control.processCmdKey() to provide additional handling of main menu command keys and MDI accelerators.
ProcessDialogChar (inherited from ContainerControl) | Processes a dialog character. Overrides Control.processDialogChar(). This method calls the processMnemonic() method to check if the character is a mnemonic for one of the controls on the form. If processMnemonic() does not consume the character, then base.processDialogChar() is called.
ProcessDialogKey (inherited from Form) | Processes a dialog key. Overrides Control.processDialogKey(). This method implements handling of the RETURN, and ESCAPE keys in dialogs. The method performs no processing on keys that include the ALT or CONTROL modifiers.
ProcessKeyEventArgs (inherited from Control) | Processes a key message. This method is called when a control receives a keyboard message. The method is responsible for generating the appropriate key events for the message by calling OnKeyPress(), onKeyDown(), or onKeyUp(). The m parameter contains the window message that must be processed. Possible values for the m.msg field are WM_CHAR, WM_KEYDOWN, WM_SYSKEYDOWN, WM_KEYUP, WM_SYSKEYUP, and WM_IMECHAR. When overriding processKeyEventArgs(), a control should return true to indicate that it has processed the key. For keys that aren't processed by the control, the result of "base.processKeyEventArgs()" should be returned. Controls will seldom, if ever, need to override this method.
ProcessKeyPreview (inherited from Form) | UNDONE: ChrisAn, 12/13/1997- Need description 'processKeyPreview'
ProcessMnemonic (inherited from ContainerControl) | UNDONE: ChrisAn, 12/13/1997- Need description 'processMnemonic'
ProcessTabKey (inherited from Form) | UNDONE: ChrisAn, 12/13/1997- Need description 'processTabKey'
RaiseDragEventArgs (inherited from RichControl) | Raises the event associated with key with the event data of e and a sender of this control.
RaiseEvent (inherited from Control) | [To be supplied.]
RaiseKeyEventArgs (inherited from Control) | Raises the event associated with key with the event data of e and a sender of this control.
RaiseMouseEventArgs (inherited from Control) | Raises the event associated with key with the event data of e and a sender of this control.
RaisePaintEventArgs (inherited from RichControl) | Raises the event associated with key with the event data of e and a sender of this control.
RaisePropertyChangedEvent (inherited from Control) | Raises the property changed event. This creates the needed event data and then calls OnPropertyChanged.
RecreateHandle (inherited from Form) | [To be supplied.]
RemoveEventHandler (inherited from Control) | [To be supplied.]
RemoveEventHandlers (inherited from Control) | [To be supplied.]
ResetMouseEventArgs (inherited from Control) | Resets the mouse leave listeners.
ResumeLayout (inherited from Control) | Overloaded. [To be supplied.]
RTLTranslateAlignment (inherited from RichControl) | Overloaded. [To be supplied.]
RTLTranslateContent (inherited from RichControl) | [To be supplied.]
RTLTranslateHorizontal (inherited from RichControl) | [To be supplied.]
RTLTranslateLeftRight (inherited from RichControl) | [To be supplied.]
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
SendMessage (inherited from Control) | Overloaded. [To be supplied.]
SetBoundsCore (inherited from Form) | [To be supplied.]
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Adjusts the displayRect to be at the offset x, y. The contents of the Form is scrolled using Windows.ScrollWindowEx.
SetScrollState (inherited from ScrollableControl) | Sets a given scroll state bit.
SetStyle (inherited from Control) | Sets the current value of the specified bit in the control's style. NOTE: This is control style, not the Win32 style of the hwnd.
UpdateBounds (inherited from Control) | Overloaded. [To be supplied.]
UpdateDefaultButton (inherited from Form) | Updates the default button based on current selection, and the acceptButton property.
UpdateStyles (inherited from Control) | Forces styles to be reapplied to the handle. This function will call CreateParams to get the styles to apply.
UpdateZOrder (inherited from Control) | Updates this control in it's parent's zorder.
WmSysColorChange (inherited from Control) | Handles the WM_SYSCOLORCHANGE message
WndProc (inherited from Form) | Base wndProc encapsulation.
WndProcException (inherited from RichControl) | [To be supplied.]

Fields

createdItems | [To be supplied.]
editor | [To be supplied.]
removedItems | [To be supplied.]
type | [To be supplied.]

Event Hookup:

Methods

AddOnActivate (inherited from Form) | Adds an event handler for the activate event. The activate event is fired when the form is activated.
AddOnClick (inherited from Control) | Adds an event handler for the click event. The click event occurs when the user clicks in the client area of the control.
AddOnClosed (inherited from Form) | Adds an event handler for the Close devent. The Closed event is fired when the form is closed.
AddOnClosing (inherited from Form) | Adds an event handler for the Closing event. The Closing event is fired when the form is closed.
AddOnControlAdded (inherited from Control) | Adds an event handler for the ControlAdded event. This event is raised after a control is added as a child to this control.
AddOnControlRemoved (inherited from Control) | Adds an event handler for the ControlRemoved event. This event is raised after a child control is removed from this control.
AddOnCreateHandle (inherited from Control) | Adds an event handler for the createHandle event. The createHandle event occurs immediately after the control's handle is created.
AddOnDeactivate (inherited from Form) | Adds an event handler for the deactivate event. The deactivate event is fired when the form is deactivated.
AddOnDestroyHandle (inherited from Control) | Adds an event handler for the destroyHandle event. The destroyHandle event occurs immediately before the control's handle is destroyed.
AddOnDoubleClick (inherited from Control) | Adds an event handler for the doubleClick event. The doubleClick event occurs when the user double clicks in the client area of the control.
AddOnDragDrop (inherited from RichControl) | Adds an event handler for the dragDrop event. The dragDrop evnet occurs when the user releases the mouse button while dragging some Object over the control.
AddOnDragEnter (inherited from RichControl) | Adds an event handler for the dragEnter event. The drawEnter event occurs when the user first moves the mouse over the control while dragging some Object.
AddOnDragLeave (inherited from RichControl) | Adds an event handler for the dragLeave event. The dragLeave event occurs when the user first moves the mouse out of the control while dragging some Object.
AddOnDragOver (inherited from RichControl) | Adds an event handler for the dragOver event. The dragOver event occurs whenever the user moves the mouse over the control while draggin some Object.
AddOnEnter (inherited from Control) | Adds an event handler for the enter event. The enter event occurs when focus enters this control. This doesn't imply that this control has focus, but rather that this control or some child control of this control has gotten focus.
AddOnGiveFeedback (inherited from RichControl) | Adds an event handler for the giveFeedback event. The giveFeedback event occurs during a drag operation. This allows the source of a drag event to modify the mouse pointer to give the user visual feedback as to what would happen if they droped.
AddOnGotFocus (inherited from Control) | Adds an event handler for the gotFocus event. The gotFocus event occurs when the this control gains focus.
AddOnHelp (inherited from RichControl) | Adds an event handler for the help event. The help event occurs when the user requests help for this control. This may be caused by the user pressing F1, or used "Whats This Help".
AddOnInputLangChange (inherited from Form) | Adds an event handler for the InputLangChange event. The InputLangChange event is fired after the input language has changed for this form.
AddOnInputLangChangeRequest (inherited from Form) | Adds an event handler for the InputLangChangeRequest event. The InputLangChangeRequest event is fired when the user attempts to change the input language for this form. If the event is cancel then the input language will not change.
AddOnInvalidate (inherited from RichControl) | Adds an event handler for the invalidate event. The invalidate event occurs when the Invalidate method is called on some part of the control's client area. This event may be used to identify when the contents of a window have changed.
AddOnKeyDown (inherited from Control) | Adds an event handler for the keyDown event. The keyDown event occurs when the user presses a key down.
AddOnKeyPress (inherited from Control) | Adds an event handler for the keyPress event. The keyPress event occurs when the user presses a key.
AddOnKeyUp (inherited from Control) | Adds an event handler for the keyUp event. The keyUp event occurs when the user releases a key.
AddOnLayout (inherited from Control) | Adds an event handler for the layout event. The layout event occurs when any event occurs that would cause the control to layout child controls. These events include; resize, show/hide child controls, add/remove child controls. This event should be used to perform any custom layout logic.
AddOnLeave (inherited from Control) | Adds an event handler for the leave event. The leave event occurs when focus leaves this control. This doesn't imply that this control lost focus, but rather that focus has been moved out of this control and any child controls.
AddOnLostFocus (inherited from Control) | Adds an event handler for the lostFocus event. The lostFocus event occurs when this control looses focus.
AddOnMDIChildActivate (inherited from Form) | Adds an event handler for the MDIChildActivate event. The MDIChildActivate occurs when a MDIChild window is activated.
AddOnMenuComplete (inherited from Form) | [To be supplied.]
AddOnMenuStart (inherited from Form) | [To be supplied.]
AddOnMouseDown (inherited from Control) | Adds an event handler for the mouseDown event. The mouseDown event occurs when the user presses the mouseDown over this control.
AddOnMouseEnter (inherited from Control) | Adds an event handler for the mouseEnter event. The mouseEnter event occurs when the mouse first moves over this control.
AddOnMouseHover (inherited from Control) | Adds an event handler for the mouseHover event. The mouseHover event occurs after the mouse is inside a control for an amount.
AddOnMouseLeave (inherited from Control) | Adds an event handler for the mouseLeave event. The mouseLeave event occurs when the mouse first moves out of this control.
AddOnMouseMove (inherited from Control) | Adds an event handler for the mouseMove event. The mouseMove event occurs whenever the user moves the mouse over this control.
AddOnMouseUp (inherited from Control) | Adds an event handler for the mouseUp event. The mouseUp event occurs when the user releases a mouse button inside the control.
AddOnMouseWheel (inherited from Control) | Adds an event handler for the mouseWheel event. The mouseWheel event occurs when the user scrolls the mouse wheel up or down. The delta value in the event data indicates the amount that the mouse wheel has moved. The Microsoft standards indicate that the view should scroll by System.WinForms.SystemInformation.getMouseWheelScrollLines() when the delta value has reach win.WHEEL_DELTA. If a mouseWheel event occurs with a value less that WHEEL_DELTA, the control should either increment a stored value and wait until the total delta is an increment of WHEEL_DELTA, or scroll the view a percentage of MouseWheelScrollLines. NOTE: A press of the mouseWheel will generate a mouseDown event with the middle button pressed.
AddOnMove (inherited from Control) | Adds an event handler for the move event. The move event occurs when the controls location changes.
AddOnPaint (inherited from RichControl) | Adds an event handler for the paint event. The paint event occurs when the control needs to paint some part of it's client area.
AddOnPropertyChanged (inherited from Control) | Adds an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.
AddOnQueryContinueDrag (inherited from RichControl) | Adds an event handler for the queryContinueDrag event. The queryContinueDrag event occurs during a drag operation. This allows the drag source to determine if the drag operation should be canceled.
AddOnResize (inherited from Control) | Adds an event handler for the resize event. The resize event occurs when the bounds of the control change. This event may be fired from the constructor of base controls.
AddOnValidated (inherited from Control) | Adds an event handler for the validated event. The validated event occurs when a control was successfully validated.
AddOnValidating (inherited from Control) | Adds an event handler for the validating event. The validating event occurs when the control loses focus and a control that causes validation gains focus. This is where users can write code to validate the current values of the control.
RemoveOnActivate (inherited from Form) | Removes an event handler for the activate event.
RemoveOnClick (inherited from Control) | Removes the given handler for the "OnClick" event. If there are duplicate entries, ALL are removed.
RemoveOnClosed (inherited from Form) | Removes an event handler for the Closed event.
RemoveOnClosing (inherited from Form) | Removes an event handler for the Closing event.
RemoveOnControlAdded (inherited from Control) | Removes the given handler for the "ControlAdded" event. If there are duplicate entries, ALL are removed.
RemoveOnControlRemoved (inherited from Control) | Removes the given handler for the "ControlRemoved" event. If there are duplicate entries, ALL are removed.
RemoveOnCreateHandle (inherited from Control) | Removes the given handler for the "createHandle" event. If there are duplicate entries, ALL are removed.
RemoveOnDeactivate (inherited from Form) | Removes an event handler for the deactivate event.
RemoveOnDestroyHandle (inherited from Control) | Removes the given handler for the "destroyHandle" event. If there are duplicate entries, ALL are removed.
RemoveOnDoubleClick (inherited from Control) | Removes the given handler for the "OnDoubleClick" event. If there are duplicate entries, ALL are removed.
RemoveOnDragDrop (inherited from RichControl) | Removes the given handler for the "dragDrop" event. If there are duplicate entries, ALL are removed.
RemoveOnDragEnter (inherited from RichControl) | Removes the given handler for the "OnDragEnter" event. If there are duplicate entries, ALL are removed.
RemoveOnDragLeave (inherited from RichControl) | Removes the given handler for the "OnDragLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnDragOver (inherited from RichControl) | f final Removes the given handler for the "OnDragOver" event. If there are duplicate entries, ALL are removed.
RemoveOnEnter (inherited from Control) | Removes the given handler for the "OnEnter" event. If there are dfinal uplicate entries, ALL are removed.
RemoveOnGiveFeedback (inherited from RichControl) | Removes the given handler for the "OnGiveFeedback" event. If there are duplicate entries, ALL are removed.
RemoveOnGotFocus (inherited from Control) | Removes the given handler for the "OnGotFocus" event. If there are duplicate entries, ALL are removed.
RemoveOnHelp (inherited from RichControl) | Removes the given handler for the "OnHelp" event. If there are duplicate entries, ALL are removed.
RemoveOnInputLangChange (inherited from Form) | Removes an event handler for the InputLangChange event.
RemoveOnInputLangChangeRequest (inherited from Form) | Removes an event handler for the InputLangChangeRequest event.
RemoveOnInvalidate (inherited from RichControl) | Removes the given handler for the "OnInvalidate" event. If there are duplicate entries, ALL are removed.
RemoveOnKeyDown (inherited from Control) | Removes the given handler for the "OnKeyDown" event. If there are duplicate entries, ALL are removed.
RemoveOnKeyPress (inherited from Control) | Removes the given handler for the "OnKeyPress" event. If there are duplicate entries, ALL are removed.
RemoveOnKeyUp (inherited from Control) | Removes the given handler for the "OnKeyUp" event. If there are duplicate entries, ALL are removed.
RemoveOnLayout (inherited from Control) | Removes the given handler for the layout event. If there are duplicate entries, ALL are removed.
RemoveOnLeave (inherited from Control) | Removes the given handler for the "OnLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnLostFocus (inherited from Control) | Removes the given handler for the "OnLostFocus" event. If there are duplicate entries, ALL are removed.
RemoveOnMDIChildActivate (inherited from Form) | Removes an event handler for the MDIChildActivate event.
RemoveOnMenuComplete (inherited from Form) | [To be supplied.]
RemoveOnMenuStart (inherited from Form) | [To be supplied.]
RemoveOnMouseDown (inherited from Control) | Removes the given handler for the "OnMouseDown" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseEnter (inherited from Control) | Removes the given handler for the "OnMouseEnter" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseHover (inherited from Control) | Removes the given handler for the "OnMouseHover" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseLeave (inherited from Control) | Removes the given handler for the "OnMouseLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseMove (inherited from Control) | Removes the given handler for the "OnMouseMove" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseUp (inherited from Control) | Removes the given handler for the "OnMouseUp" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseWheel (inherited from Control) | Removes the given handler for the "OnMouseWheel" event. If there are duplicate entries, ALL are removed.
RemoveOnMove (inherited from Control) | Removes the given handler for the "OnMove" event. If there are duplicate entries, ALL are removed.
RemoveOnPaint (inherited from RichControl) | Removes the given handler for the "OnPaint" event. If there are duplicate entries, ALL are removed.
RemoveOnPropertyChanged (inherited from Control) | Removes an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.
RemoveOnQueryContinueDrag (inherited from RichControl) | Removes the given handler for the "OnQueryContinueDrag" event. If there are duplicate entries, ALL are removed.
RemoveOnResize (inherited from Control) | Removes the given handler for the "OnResize" event. If there are duplicate entries, ALL are removed.
RemoveOnValidated (inherited from Control) | Removes an event handler for the validated event. The validated event occurs when a control was successfully validated.
RemoveOnValidating (inherited from Control) | Removes an event handler for the validating event. The validating event occurs when the control loses focus and a control that causes validation gains focus. This is where users can write code to validate the current values of the control.

See Also

OldCollectionEditor.CollectionDialog Class | System.ComponentModel.Design Namespace


OldCollectionEditor.CollectionDialog Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal type As Type, _
   ByVal editor As OldCollectionEditor, _
   ByVal valueAccess As IValueAccess _
)
[C#]
public OldCollectionEditor.CollectionDialog(
   Type type,
   OldCollectionEditor editor,
   IValueAccess valueAccess
);
[C++]
public: OldCollectionEditor.CollectionDialog(
   Type* type,
   OldCollectionEditor* editor,
   IValueAccess* valueAccess
);
[JScript]
public function OldCollectionEditor.CollectionDialog(
   type : Type,
   editor : OldCollectionEditor,
   valueAccess : IValueAccess
);

Parameters

type
[To be supplied.]
editor
[To be supplied.]
valueAccess
[To be supplied.]

See Also

OldCollectionEditor.CollectionDialog Class | OldCollectionEditor.CollectionDialog Members | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

OldCollectionEditor.CollectionDialog Properties

The properties of the OldCollectionEditor.CollectionDialog class are listed below. For a complete list of OldCollectionEditor.CollectionDialog class members, see the OldCollectionEditor.CollectionDialog Members topic.

Public:

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from RichControl) | The Accessibility Object for this RichControl
AccessibleDefaultActionDescription (inherited from RichControl) | The default action description of the control
AccessibleDescription (inherited from RichControl) | The accessible description of the control
AccessibleHelpProvider (inherited from RichControl) | The help provider for this RichControl
AccessibleName (inherited from RichControl) | The accessible name of the control
AccessibleRole (inherited from RichControl) | The accessible role of the control
ActiveControl (inherited from ContainerControl) | The current active control.
ActiveMDIChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from RichControl) | The allowDrop property. If allowDrop is set to true then this control will allow drag and drop operations and events to be used.
AllowTransparency (inherited from RichControl) | Determines if the control should be allowed to have the opacity adjusted. This is primarily a performance optimization, in that you can always set the opacity to any value, and that will force AllowTransparency to true. However, setting the opacity to any given value will switch the control into layered mode. By setting the AllowTransparency property to false the control will actually switch out of layered mode, which provides better performance if you don't intend to adjust the opacity.
Anchor (inherited from RichControl) | The current value of the anchor property. The anchor property determines which edges of the control are anchored to the container's edges.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form will adjust its size to fit the height of the font used on the form and scale its controls.
AutoScaleBaseSize (inherited from Form) | The base size used for autoscaling. The AutoScaleBaseSize is used internally to determine how much to scale the form when AutoScaling is used.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form implements autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Retrieves the current value of the AutoScrollMinSize property. The AutoScrollMinSize property is used internally to manage the screen size allocated to the automatic scrollbars.
AutoScrollPosition (inherited from ScrollableControl) | Retrieves the current value of the AutoScrollPosition property. The AutoScrollPosition property is used internally to adjust the position of controls that there placed on the Form throughout the form designer.
BackColor (inherited from RichControl) | The background color of this control. This is an ambient property and will always return a non-null value.
BackgroundImage (inherited from RichControl) | The background image of the control.
BindingManager (inherited from ContainerControl) | The binding manager for the container control.
Bindings (inherited from RichControl) | Retrieves the bindings for this control.
BorderStyle (inherited from Form) | Gets or sets the border style of the form.
Bottom (inherited from Control) | The bottom coordinate of this control.
Bounds (inherited from Control) | The bounds of this control. This is the window coordinates of the control in parent client coordinates.
CancelButton (inherited from Form) | Gets or sets the button control that will be clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Checks if this control can receive focus. The result is true if the control has a handle and if it and all of its parent controls are both visible and enabled.
CanSelect (inherited from Control) | Checks if this control can be selected. The result is true if the control is contained in a form and if all of its parent controls are both visible and enabled.
Capture (inherited from Control) | If this control has captured the mouse then this will return true.
CausesValidation (inherited from Control) | Indicates whether entering this control causes validation on the controls requiring validation. This is set to false usually for things like the Help button, etc...
ClientRectangle (inherited from Control) | The client rect of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from RichControl) | Retrieves the company name of this specific component.
ContainsFocus (inherited from Control) | Indicates whether the control or one of its children currently has the system focus.
ContextMenu (inherited from RichControl) | The contextMenu associated with this control. The contextMenu will be shown when the user right clicks the mouse on the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether the form has a control box.
Controls (inherited from Control) | Collection of child controls.
Created (inherited from Control) | Returns true if the control has been created.
Cursor (inherited from RichControl) | Retrieves the cursor that will be displayed when the mouse is over this control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Retreives the current display rectangle. The display rectangle is the virtual display area that is used to layout components. The position and dimensions of the Form's display rectangle change during autoScroll.
Disposed (inherited from Control) | Indicates that the control has been disposed, and is no longer a valid Windows control even though the object instance is still alive.
Disposing (inherited from Control) | Indicates that the control is in the process of being beendisposed, and is no longer a valid Windows control even though the object instance is still alive.
Dock (inherited from RichControl) | The dock property. The dock property controls to which edge of the container this control is docked to. For example, when docked to the top of the container, the control will be displayed flush at the top of the container, extending the length of the container.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | The current enabled state of this control.
Focused (inherited from Control) | Returns true if this control has focus.
Font (inherited from RichControl) | Retrieves the current font for this control. This will be the font used by default for painting and text in the control.
ForeColor (inherited from RichControl) | The foreground color of the control.
Handle (inherited from Control) | The HWND handle that this control is bound to. If the handle has not yet been created, this will force handle creation.
HandleCreated (inherited from Control) | Whether or not this control has a handle associated with it.
Height (inherited from Control) | The height of this control
HelpButton (inherited from Form) | Gets or sets a value indicating whether a help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
IMEMode (inherited from RichControl) | Specifies a value that determines the IME (Input Method Editor) status of the object when that object is selected.
InvokeRequired (inherited from RichControl) | Determines if the caller must call invoke when making method calls to this control. Controls in WinForms are bound to a specific thread, and are not thread safe. Therefore, if you are calling a control's method from a different thread, you must use the control's invoke method to marshal the call to the proper thread. This function can be used to determine if you must call invoke, which can be handy if you don't know what thread owns a control. There are five functions on a control that are safe to call from any thread: GetInvokeRequired, Invoke, BeginInvoke, EndInvoke and CreateGraphics. For all other metohd calls, you should use one of the invoke methods.
IsAccessible (inherited from RichControl) | Indicates whether or not this control is an accessible control i.e. whether it should be visible to accessibility applications.
IsMDIChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMDIContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | The left coordinate of this control.
Location (inherited from Control) | The location of this control.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize box is displayed in the caption box of the form.
MDIChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MDIParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize box is displayed in the caption box of the form.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Opacity (inherited from Form) | [To be supplied.]
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from Form) | The form that is the visual parent of this form.
ProductName (inherited from RichControl) | Retrieves the product name of this specific component.
ProductVersion (inherited from RichControl) | Retrieves the product version of this specific component.
RecreatingHandle (inherited from Control) | This is true if the control is currently recreating its handle.
Region (inherited from RichControl) | The Region associated with this control. (defines the outline/silhouette/boundary of control)
Right (inherited from Control) | The right coordinate of this control.
RightToLeft (inherited from RichControl) | This is used for international applications where the language is written from RightToLeft. When this property is true, control placement and text will be from right to left.
ShowInTaskbar (inherited from Form) | If ShowInTaskbar is true then the form will be displayed in the Windows Taskbar.
Site (inherited from MarshalByRefComponent) | Gets or sets the site of the component.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of size grip to display in the lower-left corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | [To be supplied.]
TabStop (inherited from Control) | A boolean value indicating whether the user can give the focus to this control using the TAB key.
Text (inherited from Control) | The current text associated with this control.
Top (inherited from Control) | Top coordinate of this control.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | The top level control that contains this control. This doesn't have to be the same as the value returned from getForm since forms can be parented to other controls.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
Visible (inherited from Form) | Gets or sets a value indicating whether the form is visible.
Width (inherited from Control) | The width of this control.
WindowState (inherited from Form) The WindowState of the Form. Valid values are:
FormWindowState.Normal
    FormWindowState.Maximized
    FormWindowState.Minimized
WindowTarget (inherited from Control) | The target of Win32 window messages.

Protected:

CreateParams (inherited from Form) | Retrieves the CreateParams used to create the window. If a subclass overrides this function, it must call the super implementation.
CreateThreadId (inherited from Control) | Retrieves the Win32 thread ID of the thread that created the handle for this control. If the control's handle hasn't been created yet, this method will return the current thread's ID.
FontHeight (inherited from RichControl) | [To be supplied.]
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
InternalHandle (inherited from Control) | Returns the current value of the handle. This may be zero if the handle has not been created.
MaximizedBounds (inherited from Form) | Gets the size of the form when it is maximized.
MaxTrackSize (inherited from Form) | Gets the maximum size the form can be resized to.
MinTrackSize | [To be supplied.]
ParkingFormHandle (inherited from RichControl) | [To be supplied.]
RenderRightToLeft (inherited from RichControl) | [To be supplied.]
RichParent (inherited from RichControl) | [To be supplied.]
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.
WarningBanner (inherited from Form) | Determines if this form should be displayed with a warning banner.
WindowText (inherited from Form) | Gets or sets the text to display in the caption bar of the form.

See Also

OldCollectionEditor.CollectionDialog Class | System.ComponentModel.Design Namespace


OldCollectionEditor.CollectionDialog.MinTrackSize

[To be supplied.]

[Visual Basic]
Overridable Protected ReadOnly Property MinTrackSize As Size
[C#]
protected Size MinTrackSize {override get;}
[C++]
protected: __property virtual Size get_MinTrackSize();
[JScript]
protected function get MinTrackSize() : Size;

See Also

OldCollectionEditor.CollectionDialog Class | OldCollectionEditor.CollectionDialog Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

OldCollectionEditor.CollectionDialog Methods

The methods of the OldCollectionEditor.CollectionDialog class are listed below. For a complete list of OldCollectionEditor.CollectionDialog class members, see the OldCollectionEditor.CollectionDialog Members topic.

Public:

Activate (inherited from Form) | Activates the form and gives it focus.
ActivateControl (inherited from ContainerControl) | [To be supplied.]
AddOwnedForm (inherited from Form) | Adds an owned form to this form. Owned forms are other top level forms that are children of this form.
BeginInvoke (inherited from RichControl) | Overloaded. [To be supplied.]
BringToFront (inherited from Control) | Brings this control to the front of the zorder.
CallWndProc (inherited from Control) | Dispatch the method to this window's wndProc directly.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Checks if a control is a child of this control.
CreateControl (inherited from Control) | Forces the creation of the control. This includes the creation of the handle, and any child controls.
CreateGraphics (inherited from RichControl) | Overloaded. [To be supplied.]
CreateWindowGraphics (inherited from RichControl) | Creates a Graphics for the entire window of the control rather than just it's client area. The controls foreground color and background color become the default values for the Graphics. The returned Graphics must be disposed through a call to its dispose() method when it is no longer needed. The Graphics Object is only valid for the duration of the current window's message.
Dispose | [To be supplied.]
DoDragDrop (inherited from RichControl) | Begins a drag operation. The allowedEffects determine which drag operations can occur. If the drag operation needs to interop with applications in another process, data should either be a base managed class (String, Bitmap, or Metafile) or some Object that implements System.ComponentModel.IPersistable. data can also be any Object that implements System.WinForms.IDataObject.
EndInvoke (inherited from RichControl) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult interface passed. If the async operation has not been completed, this function will block until the result is available.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FindForm (inherited from Form) | Retrieves the form that this control is parented to.
Focus (inherited from Control) | Attempts to set focus to this control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified client coordinates.
GetContainer (inherited from MarshalByRefComponent) | Returns the component's container.
GetContainerControl (inherited from Control) | Returns the closest ContainerControl in the control's chain of parent controls and forms.
GetDesignMode (inherited from MarshalByRefComponent) | Determines whether the component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetItems | [To be supplied.]
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetMDIClient (inherited from Form) | Returns the control that is the MDI Client region.
GetNextControl (inherited from Control) | Retrieves the next control in the tab order of child controls.
GetServiceObject (inherited from MarshalByRefComponent) | The implementation of IServiceObjectProvider
GetType (inherited from Object) | Gets the Type of the Object.
Hide (inherited from Control) | Hides the control by setting the visible property to false;
InitializeLifetimeService (inherited from MarshalByRefObject)
Invalidate (inherited from Control) | Overloaded. [To be supplied.]
Invoke (inherited from RichControl) | Overloaded. [To be supplied.]
LayoutMDI (inherited from Form) | Arranges the MDI child forms according to value, which should be a member of the MDILayout enum.
PerformLayout (inherited from Control) | Overloaded. [To be supplied.]
PointToClient (inherited from Form) | [To be supplied.]
PointToScreen (inherited from Form) | [To be supplied.]
PreProcessMessage (inherited from Control) | This method is called by the application's message loop to pre-process input messages before they are dispatched. Possible values for the msg.message field are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR. If this method processes the message it must return true, in which case the message loop will not dispatch the message. For WM_KEYDOWN and WM_SYSKEYDOWN messages, preProcessMessage() first calls processCmdKey() to check for command keys such as accelerators and menu shortcuts. If processCmdKey() doesn't process the message, then isInputKey() is called to check whether the key message represents an input key for the control. Finally, if isInputKey() indicates that the control isn't interested in the key message, then processDialogKey() is called to check for dialog keys such as TAB, arrow keys, and mnemonics. For WM_CHAR messages, preProcessMessage() first calls isInputChar() to check whether the character message represents an input character for the control. If isInputChar() indicates that the control isn't interested in the character message, then processDialogChar() is called to check for dialog characters such as mnemonics. For WM_SYSCHAR messages, preProcessMessage() calls processDialogChar() to check for dialog characters such as mnemonics. When overriding preProcessMessage(), a control should return true to indicate that it has processed the message. For messages that aren't processed by the control, the result of "base.preProcessMessage()" should be returned. Controls will typically override one of the more specialized methods (isInputChar(), isInputKey(), processCmdKey(), processDialogChar(), or processDialogKey()) instead of overriding preProcessMessage().
RectangleToClient (inherited from Form) | [To be supplied.]
RectangleToScreen (inherited from Form) | [To be supplied.]
Refresh (inherited from Control) | Forces the control to invalidate and immediately repaint itself and any children.
RemoveOwnedForm (inherited from Form) | Removes a form from the list of owned forms. Also sets the owner of the removed form to null.
ResetBackColor (inherited from RichControl) | Resets the back color to be based on the parent's back color.
ResetBindings (inherited from RichControl) | [To be supplied.]
ResetCursor (inherited from RichControl) | [To be supplied.]
ResetFont (inherited from RichControl) | Resets the font to be based on the parent's font.
ResetForeColor (inherited from RichControl) | Resets the fore color to be based on the parent's fore color.
ResetRightToLeft (inherited from RichControl) | Resets the RightToLeft to be the default.
ResetText (inherited from Control) | Resets the text to it's default value.
ResumeLayout (inherited from Control) | Overloaded. [To be supplied.]
Scale (inherited from Control) | Overloaded. [To be supplied.]
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the currently active control into view if we are an AutoScroll Form that has the Horiz or Vert scrollbar displayed...
Select (inherited from Control) | Activates this control.
SelectNextControl (inherited from Control) | Selects the next control following ctl.
SendMessage (inherited from Control) | Overloaded. [To be supplied.]
SendToBack (inherited from Control) | sends this control to the back of the z-order
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. [To be supplied.]
SetClientSize (inherited from Control) | Sets the height and width of the client area of the control.
SetDesktopBounds (inherited from Form) | Sets the bounds of the Form in desktop coordinates. Desktop coordinates are based on the working area of the screen, which excludes the Taskbar.
SetDesktopLocation (inherited from Form) | Sets the location of the Form in desktop coordinates.
SetItems | [To be supplied.]
SetLocation (inherited from Control) | Sets the location of this control.
SetNewControls (inherited from Form) | [To be supplied.]
SetSize (inherited from Control) | Sets the size of this control.
ShouldPersistAutoScaleBaseSize (inherited from Form) | [To be supplied.]
ShouldPersistAutoScrollMargin (inherited from ScrollableControl) | Indicates whether the AutoScrollMargin property should be persisted.
ShouldPersistAutoScrollMinSize (inherited from ScrollableControl) | Indicates whether the AutoScrollMinSize property should be persisted.
ShouldPersistAutoScrollPosition (inherited from ScrollableControl) | Indicates whether the AutoScrollPosition property should be persisted.
ShouldPersistBackColor (inherited from Form) | [To be supplied.]
ShouldPersistBindings (inherited from RichControl) | [To be supplied.]
ShouldPersistCursor (inherited from RichControl) | Returns true if the cursor should be persisted in code gen.
ShouldPersistFont (inherited from RichControl) | Returns true if the font should be persisted in code gen.
ShouldPersistForeColor (inherited from Form) | [To be supplied.]
ShouldPersistIcon (inherited from Form) | [To be supplied.]
ShouldPersistLocation (inherited from Control) | Determines if the Location property needs to be persisted.
ShouldPersistRightToLeft (inherited from RichControl) | Returns true if the RightToLeft should be persisted in code gen.
ShouldPersistSize (inherited from Form) | [To be supplied.]
ShouldPersistText (inherited from Control) | Determines if the Text property needs to be persisted.
Show (inherited from Control) | Makes the control display by setting the visible property to true
ShowDialog (inherited from Form) | Overloaded. [To be supplied.]
SuspendLayout (inherited from Control) | Suspends the layout logic for the control.
ToString (inherited from Form) | Returns a string representation for this control.
Update (inherited from Control) | Forces the control to paint any currently invalid areas.
Validate (inherited from ContainerControl) | Validates the last unvalidated control and it's ancestors up through (but not including) this.

Protected:

AddEventHandler (inherited from Control) | [To be supplied.]
AdjustFormScrollbars (inherited from Form) | [To be supplied.]
ApplyAutoScaling (inherited from Form) | This auto scales the form based on the AutoScaleBaseSize.
AssignParent (inherited from RichControl) | Assigns a new parent control. Sends out the appropriate property change notifications for properties that are affected by the change of parent.
CenterToScreen (inherited from Form) | Centers the dialog to the screen. This will first attempt to use the owner property to determine the correct screen, then it will try the HWND owner of the form, and finally this will center the form on the same monitor as the mouse cursor.
ChildGotFocus (inherited from Control) | [To be supplied.]
CreateAccessibilityInstance (inherited from RichControl) | Constructs the new instance of the accessibility object for this control. Subclasses should not call base.CreateAccessibilityObject.
CreateControlsInstance (inherited from Form) | [To be supplied.]
CreateHandle (inherited from Form) | Creates the handle for the Form. If a subclass overrides this function, it must call the super implementation.
CreateNewInstance | [To be supplied.]
DefWndProc (inherited from Form) | Calls the default window proc for the form. If a subclass overrides this function, it must call the super implementation.
DestroyHandle (inherited from RichControl) | [To be supplied.]
DestroyNewInstance | [To be supplied.]
DestroyOldInstance | [To be supplied.]
Finalize (inherited from Control) | [To be supplied.]
GetEventHandler (inherited from RichControl) | RichControl overrides the default implementation of this for AX sourcing. ActiveX controls can "freeze" their events, and we implement this by returning null here if events are frozen.
GetScrollState (inherited from ScrollableControl) | Tests a given scroll state bit to determine if it is set.
GetStyle (inherited from Control) | Retrieves the current value of the specified bit in the control's style. NOTE: This is control style, not the Win32 style of the hwnd.
InitLayout (inherited from RichControl) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | [To be supplied.]
InvokeLostFocus (inherited from Control) | [To be supplied.]
InvokeOnClick (inherited from Control) | [To be supplied.]
InvokePaint (inherited from RichControl) | [To be supplied.]
InvokePaintBackground (inherited from RichControl) | [To be supplied.]
IsInputChar (inherited from Control) | Determines if charCode is an input character that the control wants. This method is called during window message pre-processing to determine whether the given input character should be pre-processed or sent directly to the control. If isInputChar returns true, the given character is sent directly to the control. If isInputChar returns false, the character is pre-processed and only sent to the control if it is not consumed by the pre-processing phase. The pre-processing of a character includes checking whether the character is a mnemonic of another control.
IsInputKey (inherited from Control) | Determines if keyData is an input key that the control wants. This method is called during window message pre-processing to determine whether the given input key should be pre-processed or sent directly to the control. If isInputKey returns true, the given key is sent directly to the control. If isInputKey returns false, the key is pre-processed and only sent to the control if it is not consumed by the pre-processing phase. Keys that are pre-processed include TAB, RETURN, ESCAPE, and arrow keys.
Listbox_drawItem | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from RichControl) | [To be supplied.]
OnActivate (inherited from Form) | The activate event is fired when the form is activated.
OnClick (inherited from Control) | This method actually raises the Click event. Inheriting classes should override this if they wish to be notified of a Click event. (This is far preferable to actually adding an event handler.) They should not, however, forget to call base.onClick(e); before exiting, to ensure that other recipients do actually get the event.
OnClosed (inherited from Form) | The Closed event is fired when the form is closed.
OnClosing (inherited from Form) | The Closing event is fired when the form is closed.
OnControlAdded (inherited from Control) | Called when a child control is added to this control.
OnControlRemoved (inherited from ContainerControl) | Called when a child control is removed from this control.
OnCreateControl (inherited from Form) | Fired when this control is first created.
OnCreateHandle (inherited from RichControl) | Inheriting classes should override this method to find out when the handle has been created. Call base.onCreateHandle first.
OnDeactivate (inherited from Form) | The deactivate event is fired when the form is deactivated.
OnDestroyHandle (inherited from RichControl) | Inheriting classes should override this method to find out when the handle is about to be destroyed. Call base.onDestroyHandle last.
OnDoubleClick (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onDoubleClick to send this event to any registered event listeners.
OnDragDrop (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragDrop to send this event to any registered event listeners.
OnDragEnter (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragEnter to send this event to any registered event listeners.
OnDragLeave (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragLeave to send this event to any registered event listeners.
OnDragOver (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragOver to send this event to any registered event listeners.
OnEnter (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onEnter to send this event to any registered event listeners.
OnGiveFeedback (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onGiveFeedback to send this event to any registered event listeners.
OnGotFocus (inherited from RichControl) | [To be supplied.]
OnHelp (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onHelp to send this event to any registered event listeners.
OnInputLangChange (inherited from Form) | The InputLangChange event is fired after the input language has changed for this form.
OnInputLangChangeRequest (inherited from Form) | The InputLangChangeRequest event is fired when the user attempts to change the input language for this form. If the event is cancel then the input language will not change.
OnInvalidate (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.OnInvalidate to send this event to any registered event listeners.
OnKeyDown (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onKeyDown to send this event to any registered event listeners.
OnKeyPress (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.OnKeyPress to send this event to any registered event listeners.
OnKeyUp (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onKeyUp to send this event to any registered event listeners.
OnLayout (inherited from ScrollableControl) | Forces the layout of any docked or anchored child controls.
OnLeave (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onLeave to send this event to any registered event listeners.
OnLostFocus (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onLostFocus to send this event to any registered event listeners.
OnMDIChildActivate (inherited from Form) | Overloaded. [To be supplied.]
OnMenuComplete (inherited from Form) | Inheriting classes should override this method to provide user feedback after a menu selection has been completed. This method will be called when the menu selection has been completed, regardless of whether the user selected a menu item, or canceled the selection. This event signifies that the menu modal message loop has been exited.
OnMenuStart (inherited from Form) | Inheriting classes should override this method to provide user feedback when a menu is displayed. This method will be called when any menu is displayed. This event signifies that the menu modal message loop has been entered.
OnMouseDown (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseDown to send this event to any registered event listeners.
OnMouseEnter (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseEnter to send this event to any registered event listeners.
OnMouseHover (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseHover to send this event to any registered event listeners.
OnMouseLeave (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseLeave to send this event to any registered event listeners.
OnMouseMove (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseMove to send this event to any registered event listeners.
OnMouseUp (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseUp to send this event to any registered event listeners.
OnMouseWheel (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseWheel to send this event to any registered event listeners.
OnMove (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMove to send this event to any registered event listeners.
OnPaint (inherited from Form) | [To be supplied.]
OnPaintBackground (inherited from RichControl) | Inheriting classes should override this method to handle the erase background request from windows. It is not necessary to call base.onPaintBackground, however if you do not want the default Windows behavior you must set event.handled to true.
OnParentPropertyChanged (inherited from RichControl) | This method is called by the parent control when any property changes on the parent. This can be overriden by inheriting classes, however they must call base.OnParentPropertyChanged.
OnPropertyChanged (inherited from Form) | [To be supplied.]
OnQueryContinueDrag (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onQueryContinueDrag to send this event to any registered event listeners.
OnResize (inherited from Form) | [To be supplied.]
OnValidated (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onResize to send this event to any registered event listeners.
OnValidating (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onResize to send this event to any registered event listeners.
ParentChanged (inherited from Control) | Called by the framework after a control's parent changes. This allows (for example) child controls to automatically hook events on their parent, giving better encapsulation.
ProcessCmdKey (inherited from Form) | Processes a command key. Overrides Control.processCmdKey() to provide additional handling of main menu command keys and MDI accelerators.
ProcessDialogChar (inherited from ContainerControl) | Processes a dialog character. Overrides Control.processDialogChar(). This method calls the processMnemonic() method to check if the character is a mnemonic for one of the controls on the form. If processMnemonic() does not consume the character, then base.processDialogChar() is called.
ProcessDialogKey (inherited from Form) | Processes a dialog key. Overrides Control.processDialogKey(). This method implements handling of the RETURN, and ESCAPE keys in dialogs. The method performs no processing on keys that include the ALT or CONTROL modifiers.
ProcessKeyEventArgs (inherited from Control) | Processes a key message. This method is called when a control receives a keyboard message. The method is responsible for generating the appropriate key events for the message by calling OnKeyPress(), onKeyDown(), or onKeyUp(). The m parameter contains the window message that must be processed. Possible values for the m.msg field are WM_CHAR, WM_KEYDOWN, WM_SYSKEYDOWN, WM_KEYUP, WM_SYSKEYUP, and WM_IMECHAR. When overriding processKeyEventArgs(), a control should return true to indicate that it has processed the key. For keys that aren't processed by the control, the result of "base.processKeyEventArgs()" should be returned. Controls will seldom, if ever, need to override this method.
ProcessKeyPreview (inherited from Form) | UNDONE: ChrisAn, 12/13/1997- Need description 'processKeyPreview'
ProcessMnemonic (inherited from ContainerControl) | UNDONE: ChrisAn, 12/13/1997- Need description 'processMnemonic'
ProcessTabKey (inherited from Form) | UNDONE: ChrisAn, 12/13/1997- Need description 'processTabKey'
RaiseDragEventArgs (inherited from RichControl) | Raises the event associated with key with the event data of e and a sender of this control.
RaiseEvent (inherited from Control) | [To be supplied.]
RaiseKeyEventArgs (inherited from Control) | Raises the event associated with key with the event data of e and a sender of this control.
RaiseMouseEventArgs (inherited from Control) | Raises the event associated with key with the event data of e and a sender of this control.
RaisePaintEventArgs (inherited from RichControl) | Raises the event associated with key with the event data of e and a sender of this control.
RaisePropertyChangedEvent (inherited from Control) | Raises the property changed event. This creates the needed event data and then calls OnPropertyChanged.
RecreateHandle (inherited from Form) | [To be supplied.]
RemoveEventHandler (inherited from Control) | [To be supplied.]
RemoveEventHandlers (inherited from Control) | [To be supplied.]
ResetMouseEventArgs (inherited from Control) | Resets the mouse leave listeners.
ResumeLayout (inherited from Control) | Overloaded. [To be supplied.]
RTLTranslateAlignment (inherited from RichControl) | Overloaded. [To be supplied.]
RTLTranslateContent (inherited from RichControl) | [To be supplied.]
RTLTranslateHorizontal (inherited from RichControl) | [To be supplied.]
RTLTranslateLeftRight (inherited from RichControl) | [To be supplied.]
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
SendMessage (inherited from Control) | Overloaded. [To be supplied.]
SetBoundsCore (inherited from Form) | [To be supplied.]
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Adjusts the displayRect to be at the offset x, y. The contents of the Form is scrolled using Windows.ScrollWindowEx.
SetScrollState (inherited from ScrollableControl) | Sets a given scroll state bit.
SetStyle (inherited from Control) | Sets the current value of the specified bit in the control's style. NOTE: This is control style, not the Win32 style of the hwnd.
UpdateBounds (inherited from Control) | Overloaded. [To be supplied.]
UpdateDefaultButton (inherited from Form) | Updates the default button based on current selection, and the acceptButton property.
UpdateStyles (inherited from Control) | Forces styles to be reapplied to the handle. This function will call CreateParams to get the styles to apply.
UpdateZOrder (inherited from Control) | Updates this control in it's parent's zorder.
WmSysColorChange (inherited from Control) | Handles the WM_SYSCOLORCHANGE message
WndProc (inherited from Form) | Base wndProc encapsulation.
WndProcException (inherited from RichControl) | [To be supplied.]

Event Hookup:

AddOnActivate (inherited from Form) | Adds an event handler for the activate event. The activate event is fired when the form is activated.
AddOnClick (inherited from Control) | Adds an event handler for the click event. The click event occurs when the user clicks in the client area of the control.
AddOnClosed (inherited from Form) | Adds an event handler for the Close devent. The Closed event is fired when the form is closed.
AddOnClosing (inherited from Form) | Adds an event handler for the Closing event. The Closing event is fired when the form is closed.
AddOnControlAdded (inherited from Control) | Adds an event handler for the ControlAdded event. This event is raised after a control is added as a child to this control.
AddOnControlRemoved (inherited from Control) | Adds an event handler for the ControlRemoved event. This event is raised after a child control is removed from this control.
AddOnCreateHandle (inherited from Control) | Adds an event handler for the createHandle event. The createHandle event occurs immediately after the control's handle is created.
AddOnDeactivate (inherited from Form) | Adds an event handler for the deactivate event. The deactivate event is fired when the form is deactivated.
AddOnDestroyHandle (inherited from Control) | Adds an event handler for the destroyHandle event. The destroyHandle event occurs immediately before the control's handle is destroyed.
AddOnDoubleClick (inherited from Control) | Adds an event handler for the doubleClick event. The doubleClick event occurs when the user double clicks in the client area of the control.
AddOnDragDrop (inherited from RichControl) | Adds an event handler for the dragDrop event. The dragDrop evnet occurs when the user releases the mouse button while dragging some Object over the control.
AddOnDragEnter (inherited from RichControl) | Adds an event handler for the dragEnter event. The drawEnter event occurs when the user first moves the mouse over the control while dragging some Object.
AddOnDragLeave (inherited from RichControl) | Adds an event handler for the dragLeave event. The dragLeave event occurs when the user first moves the mouse out of the control while dragging some Object.
AddOnDragOver (inherited from RichControl) | Adds an event handler for the dragOver event. The dragOver event occurs whenever the user moves the mouse over the control while draggin some Object.
AddOnEnter (inherited from Control) | Adds an event handler for the enter event. The enter event occurs when focus enters this control. This doesn't imply that this control has focus, but rather that this control or some child control of this control has gotten focus.
AddOnGiveFeedback (inherited from RichControl) | Adds an event handler for the giveFeedback event. The giveFeedback event occurs during a drag operation. This allows the source of a drag event to modify the mouse pointer to give the user visual feedback as to what would happen if they droped.
AddOnGotFocus (inherited from Control) | Adds an event handler for the gotFocus event. The gotFocus event occurs when the this control gains focus.
AddOnHelp (inherited from RichControl) | Adds an event handler for the help event. The help event occurs when the user requests help for this control. This may be caused by the user pressing F1, or used "Whats This Help".
AddOnInputLangChange (inherited from Form) | Adds an event handler for the InputLangChange event. The InputLangChange event is fired after the input language has changed for this form.
AddOnInputLangChangeRequest (inherited from Form) | Adds an event handler for the InputLangChangeRequest event. The InputLangChangeRequest event is fired when the user attempts to change the input language for this form. If the event is cancel then the input language will not change.
AddOnInvalidate (inherited from RichControl) | Adds an event handler for the invalidate event. The invalidate event occurs when the Invalidate method is called on some part of the control's client area. This event may be used to identify when the contents of a window have changed.
AddOnKeyDown (inherited from Control) | Adds an event handler for the keyDown event. The keyDown event occurs when the user presses a key down.
AddOnKeyPress (inherited from Control) | Adds an event handler for the keyPress event. The keyPress event occurs when the user presses a key.
AddOnKeyUp (inherited from Control) | Adds an event handler for the keyUp event. The keyUp event occurs when the user releases a key.
AddOnLayout (inherited from Control) | Adds an event handler for the layout event. The layout event occurs when any event occurs that would cause the control to layout child controls. These events include; resize, show/hide child controls, add/remove child controls. This event should be used to perform any custom layout logic.
AddOnLeave (inherited from Control) | Adds an event handler for the leave event. The leave event occurs when focus leaves this control. This doesn't imply that this control lost focus, but rather that focus has been moved out of this control and any child controls.
AddOnLostFocus (inherited from Control) | Adds an event handler for the lostFocus event. The lostFocus event occurs when this control looses focus.
AddOnMDIChildActivate (inherited from Form) | Adds an event handler for the MDIChildActivate event. The MDIChildActivate occurs when a MDIChild window is activated.
AddOnMenuComplete (inherited from Form) | [To be supplied.]
AddOnMenuStart (inherited from Form) | [To be supplied.]
AddOnMouseDown (inherited from Control) | Adds an event handler for the mouseDown event. The mouseDown event occurs when the user presses the mouseDown over this control.
AddOnMouseEnter (inherited from Control) | Adds an event handler for the mouseEnter event. The mouseEnter event occurs when the mouse first moves over this control.
AddOnMouseHover (inherited from Control) | Adds an event handler for the mouseHover event. The mouseHover event occurs after the mouse is inside a control for an amount.
AddOnMouseLeave (inherited from Control) | Adds an event handler for the mouseLeave event. The mouseLeave event occurs when the mouse first moves out of this control.
AddOnMouseMove (inherited from Control) | Adds an event handler for the mouseMove event. The mouseMove event occurs whenever the user moves the mouse over this control.
AddOnMouseUp (inherited from Control) | Adds an event handler for the mouseUp event. The mouseUp event occurs when the user releases a mouse button inside the control.
AddOnMouseWheel (inherited from Control) | Adds an event handler for the mouseWheel event. The mouseWheel event occurs when the user scrolls the mouse wheel up or down. The delta value in the event data indicates the amount that the mouse wheel has moved. The Microsoft standards indicate that the view should scroll by System.WinForms.SystemInformation.getMouseWheelScrollLines() when the delta value has reach win.WHEEL_DELTA. If a mouseWheel event occurs with a value less that WHEEL_DELTA, the control should either increment a stored value and wait until the total delta is an increment of WHEEL_DELTA, or scroll the view a percentage of MouseWheelScrollLines. NOTE: A press of the mouseWheel will generate a mouseDown event with the middle button pressed.
AddOnMove (inherited from Control) | Adds an event handler for the move event. The move event occurs when the controls location changes.
AddOnPaint (inherited from RichControl) | Adds an event handler for the paint event. The paint event occurs when the control needs to paint some part of it's client area.
AddOnPropertyChanged (inherited from Control) | Adds an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.
AddOnQueryContinueDrag (inherited from RichControl) | Adds an event handler for the queryContinueDrag event. The queryContinueDrag event occurs during a drag operation. This allows the drag source to determine if the drag operation should be canceled.
AddOnResize (inherited from Control) | Adds an event handler for the resize event. The resize event occurs when the bounds of the control change. This event may be fired from the constructor of base controls.
AddOnValidated (inherited from Control) | Adds an event handler for the validated event. The validated event occurs when a control was successfully validated.
AddOnValidating (inherited from Control) | Adds an event handler for the validating event. The validating event occurs when the control loses focus and a control that causes validation gains focus. This is where users can write code to validate the current values of the control.
RemoveOnActivate (inherited from Form) | Removes an event handler for the activate event.
RemoveOnClick (inherited from Control) | Removes the given handler for the "OnClick" event. If there are duplicate entries, ALL are removed.
RemoveOnClosed (inherited from Form) | Removes an event handler for the Closed event.
RemoveOnClosing (inherited from Form) | Removes an event handler for the Closing event.
RemoveOnControlAdded (inherited from Control) | Removes the given handler for the "ControlAdded" event. If there are duplicate entries, ALL are removed.
RemoveOnControlRemoved (inherited from Control) | Removes the given handler for the "ControlRemoved" event. If there are duplicate entries, ALL are removed.
RemoveOnCreateHandle (inherited from Control) | Removes the given handler for the "createHandle" event. If there are duplicate entries, ALL are removed.
RemoveOnDeactivate (inherited from Form) | Removes an event handler for the deactivate event.
RemoveOnDestroyHandle (inherited from Control) | Removes the given handler for the "destroyHandle" event. If there are duplicate entries, ALL are removed.
RemoveOnDoubleClick (inherited from Control) | Removes the given handler for the "OnDoubleClick" event. If there are duplicate entries, ALL are removed.
RemoveOnDragDrop (inherited from RichControl) | Removes the given handler for the "dragDrop" event. If there are duplicate entries, ALL are removed.
RemoveOnDragEnter (inherited from RichControl) | Removes the given handler for the "OnDragEnter" event. If there are duplicate entries, ALL are removed.
RemoveOnDragLeave (inherited from RichControl) | Removes the given handler for the "OnDragLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnDragOver (inherited from RichControl) | f final Removes the given handler for the "OnDragOver" event. If there are duplicate entries, ALL are removed.
RemoveOnEnter (inherited from Control) | Removes the given handler for the "OnEnter" event. If there are dfinal uplicate entries, ALL are removed.
RemoveOnGiveFeedback (inherited from RichControl) | Removes the given handler for the "OnGiveFeedback" event. If there are duplicate entries, ALL are removed.
RemoveOnGotFocus (inherited from Control) | Removes the given handler for the "OnGotFocus" event. If there are duplicate entries, ALL are removed.
RemoveOnHelp (inherited from RichControl) | Removes the given handler for the "OnHelp" event. If there are duplicate entries, ALL are removed.
RemoveOnInputLangChange (inherited from Form) | Removes an event handler for the InputLangChange event.
RemoveOnInputLangChangeRequest (inherited from Form) | Removes an event handler for the InputLangChangeRequest event.
RemoveOnInvalidate (inherited from RichControl) | Removes the given handler for the "OnInvalidate" event. If there are duplicate entries, ALL are removed.
RemoveOnKeyDown (inherited from Control) | Removes the given handler for the "OnKeyDown" event. If there are duplicate entries, ALL are removed.
RemoveOnKeyPress (inherited from Control) | Removes the given handler for the "OnKeyPress" event. If there are duplicate entries, ALL are removed.
RemoveOnKeyUp (inherited from Control) | Removes the given handler for the "OnKeyUp" event. If there are duplicate entries, ALL are removed.
RemoveOnLayout (inherited from Control) | Removes the given handler for the layout event. If there are duplicate entries, ALL are removed.
RemoveOnLeave (inherited from Control) | Removes the given handler for the "OnLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnLostFocus (inherited from Control) | Removes the given handler for the "OnLostFocus" event. If there are duplicate entries, ALL are removed.
RemoveOnMDIChildActivate (inherited from Form) | Removes an event handler for the MDIChildActivate event.
RemoveOnMenuComplete (inherited from Form) | [To be supplied.]
RemoveOnMenuStart (inherited from Form) | [To be supplied.]
RemoveOnMouseDown (inherited from Control) | Removes the given handler for the "OnMouseDown" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseEnter (inherited from Control) | Removes the given handler for the "OnMouseEnter" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseHover (inherited from Control) | Removes the given handler for the "OnMouseHover" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseLeave (inherited from Control) | Removes the given handler for the "OnMouseLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseMove (inherited from Control) | Removes the given handler for the "OnMouseMove" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseUp (inherited from Control) | Removes the given handler for the "OnMouseUp" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseWheel (inherited from Control) | Removes the given handler for the "OnMouseWheel" event. If there are duplicate entries, ALL are removed.
RemoveOnMove (inherited from Control) | Removes the given handler for the "OnMove" event. If there are duplicate entries, ALL are removed.
RemoveOnPaint (inherited from RichControl) | Removes the given handler for the "OnPaint" event. If there are duplicate entries, ALL are removed.
RemoveOnPropertyChanged (inherited from Control) | Removes an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.
RemoveOnQueryContinueDrag (inherited from RichControl) | Removes the given handler for the "OnQueryContinueDrag" event. If there are duplicate entries, ALL are removed.
RemoveOnResize (inherited from Control) | Removes the given handler for the "OnResize" event. If there are duplicate entries, ALL are removed.
RemoveOnValidated (inherited from Control) | Removes an event handler for the validated event. The validated event occurs when a control was successfully validated.
RemoveOnValidating (inherited from Control) | Removes an event handler for the validating event. The validating event occurs when the control loses focus and a control that causes validation gains focus. This is where users can write code to validate the current values of the control.

See Also

OldCollectionEditor.CollectionDialog Class | System.ComponentModel.Design Namespace


OldCollectionEditor.CollectionDialog.CreateNewInstance

[To be supplied.]

[Visual Basic]
Protected Sub CreateNewInstance()
[C#]
protected void CreateNewInstance();
[C++]
protected: void CreateNewInstance();
[JScript]
protected function CreateNewInstance();

See Also

OldCollectionEditor.CollectionDialog Class | OldCollectionEditor.CollectionDialog Members | System.ComponentModel.Design Namespace


OldCollectionEditor.CollectionDialog.DestroyNewInstance

[To be supplied.]

[Visual Basic]
Protected Sub DestroyNewInstance( _
   ByVal value As Object _
)
[C#]
protected void DestroyNewInstance(
   object value
);
[C++]
protected: void DestroyNewInstance(
   Object* value
);
[JScript]
protected function DestroyNewInstance(
   value : Object
);

Parameters

value
[To be supplied.]

See Also

OldCollectionEditor.CollectionDialog Class | OldCollectionEditor.CollectionDialog Members | System.ComponentModel.Design Namespace


OldCollectionEditor.CollectionDialog.DestroyOldInstance

[To be supplied.]

[Visual Basic]
Overridable Protected Sub DestroyOldInstance( _
   ByVal value As Object _
)
[C#]
protected virtual void DestroyOldInstance(
   object value
);
[C++]
protected: virtual void DestroyOldInstance(
   Object* value
);
[JScript]
protected function DestroyOldInstance(
   value : Object
);

Parameters

value
[To be supplied.]

See Also

OldCollectionEditor.CollectionDialog Class | OldCollectionEditor.CollectionDialog Members | System.ComponentModel.Design Namespace


OldCollectionEditor.CollectionDialog.Dispose

[To be supplied.]

[Visual Basic]
Overrides Public Sub Dispose()
[C#]
public override void Dispose();
[C++]
public: override void Dispose();
[JScript]
public override function Dispose();

See Also

OldCollectionEditor.CollectionDialog Class | OldCollectionEditor.CollectionDialog Members | System.ComponentModel.Design Namespace


OldCollectionEditor.CollectionDialog.GetItems

[To be supplied.]

[Visual Basic]
Overridable Public Function GetItems() As Object ()
[C#]
public virtual object[] GetItems();
[C++]
public: virtual Object* GetItems() [];
[JScript]
public function GetItems() : Object[];

See Also

OldCollectionEditor.CollectionDialog Class | OldCollectionEditor.CollectionDialog Members | System.ComponentModel.Design Namespace


OldCollectionEditor.CollectionDialog.Listbox_drawItem

[To be supplied.]

[Visual Basic]
Overridable Protected Sub Listbox_drawItem( _
   ByVal sender As Object, _
   ByVal e As DrawItemEventArgs _
)
[C#]
protected virtual void Listbox_drawItem(
   object sender,
   DrawItemEventArgs e
);
[C++]
protected: virtual void Listbox_drawItem(
   Object* sender,
   DrawItemEventArgs* e
);
[JScript]
protected function Listbox_drawItem(
   sender : Object,
   e : DrawItemEventArgs
);

Parameters

sender
[To be supplied.]
e
[To be supplied.]

See Also

OldCollectionEditor.CollectionDialog Class | OldCollectionEditor.CollectionDialog Members | System.ComponentModel.Design Namespace


OldCollectionEditor.CollectionDialog.SetItems

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetItems( _
   ByVal items() As Object _
)
[C#]
public virtual void SetItems(
   object[] items
);
[C++]
public: virtual void SetItems(
   Object* items[]
);
[JScript]
public function SetItems(
   items : Object[]
);

Parameters

items
[To be supplied.]

See Also

OldCollectionEditor.CollectionDialog Class | OldCollectionEditor.CollectionDialog Members | System.ComponentModel.Design Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

OldCollectionEditor.CollectionDialog Fields

The fields of the OldCollectionEditor.CollectionDialog class are listed below. For a complete list of OldCollectionEditor.CollectionDialog class members, see the OldCollectionEditor.CollectionDialog Members topic.

Protected:

createdItems | [To be supplied.]
editor | [To be supplied.]
removedItems | [To be supplied.]
type | [To be supplied.]

See Also

OldCollectionEditor.CollectionDialog Class | System.ComponentModel.Design Namespace


OldCollectionEditor.CollectionDialog.createdItems

[To be supplied.]

[Visual Basic]
Protected createdItems As ObjectList
[C#]
protected ObjectList createdItems;
[C++]
protected: ObjectList* createdItems;
[JScript]
protected var createdItems : ObjectList;

See Also

OldCollectionEditor.CollectionDialog Class | OldCollectionEditor.CollectionDialog Members | System.ComponentModel.Design Namespace


OldCollectionEditor.CollectionDialog.editor

[To be supplied.]

[Visual Basic]
Protected editor As OldCollectionEditor
[C#]
protected OldCollectionEditor editor;
[C++]
protected: OldCollectionEditor* editor;
[JScript]
protected var editor : OldCollectionEditor;

See Also

OldCollectionEditor.CollectionDialog Class | OldCollectionEditor.CollectionDialog Members | System.ComponentModel.Design Namespace


OldCollectionEditor.CollectionDialog.removedItems

[To be supplied.]

[Visual Basic]
Protected removedItems As ObjectList
[C#]
protected ObjectList removedItems;
[C++]
protected: ObjectList* removedItems;
[JScript]
protected var removedItems : ObjectList;

See Also

OldCollectionEditor.CollectionDialog Class | OldCollectionEditor.CollectionDialog Members | System.ComponentModel.Design Namespace


OldCollectionEditor.CollectionDialog.type

[To be supplied.]

[Visual Basic]
Protected type As Type
[C#]
protected Type type;
[C++]
protected: Type* type;
[JScript]
protected var type : Type;

See Also

OldCollectionEditor.CollectionDialog Class | OldCollectionEditor.CollectionDialog Members | System.ComponentModel.Design Namespace


ParenthesizePropertyNameAttribute Class

Indicates whether the name of the associated property is paraenthesized in the property browser.

Object
Attribute
MemberAttribute
ParenthesizePropertyNameAttribute

[Visual Basic]
Public Class ParenthesizePropertyNameAttribute
   Inherits MemberAttribute
[C#]
public class ParenthesizePropertyNameAttribute : MemberAttribute
[C++]
public __gc class ParenthesizePropertyNameAttribute : public
   MemberAttribute
[JScript]
public class ParenthesizePropertyNameAttribute extends
   MemberAttribute

Remarks

This attribute will also cause the property to be sorted to the top of the list in alphabetical mode, or to the top of its category if the property grid is in categorize mode.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

ParenthesizePropertyNameAttribute Members | System.ComponentModel.Design Namespace


ParenthesizePropertyNameAttribute Members

Public:

Constructor

ParenthesizePropertyNameAttribute Constructor Initializes a new instance of ParenthesizePropertyNameAttribute using the specified value to indicate whether or not the attribute is marked for display with parenthesis or not.

Properties

NeedParenthesis | [To be supplied.]
TypeId (inherited from MemberAttribute) | Gets a unique ID for this MemberAttribute.

Methods

Equals | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsDefaultAttribute | [To be supplied.]
Match (inherited from MemberAttribute) | Determines whether one attribute matches another.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Default Sets the System.ComponentModel.Design.ParenthesizePropertyName attribute by default to false.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ParenthesizePropertyNameAttribute Class | System.ComponentModel.Design Namespace


ParenthesizePropertyNameAttribute Constructor

Initializes a new instance of ParenthesizePropertyNameAttribute using the specified value to indicate whether or not the attribute is marked for display with parenthesis or not.

[Visual Basic]
Public Sub New( _
   ByVal needParenthesis As Boolean _
)
[C#]
public ParenthesizePropertyNameAttribute(
   bool needParenthesis
);
[C++]
public: ParenthesizePropertyNameAttribute(
   bool needParenthesis
);
[JScript]
public function ParenthesizePropertyNameAttribute(
   needParenthesis : Boolean
);

Parameters

needParenthesis
Whether the name should be enclosed in parenthesis.

See Also

ParenthesizePropertyNameAttribute Class | ParenthesizePropertyNameAttribute Members | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ParenthesizePropertyNameAttribute Properties

The properties of the ParenthesizePropertyNameAttribute class are listed below. For a complete list of ParenthesizePropertyNameAttribute class members, see the ParenthesizePropertyNameAttribute Members topic.

Public:

NeedParenthesis | [To be supplied.]
TypeId (inherited from MemberAttribute) | Gets a unique ID for this MemberAttribute.

See Also

ParenthesizePropertyNameAttribute Class | System.ComponentModel.Design Namespace


ParenthesizePropertyNameAttribute.NeedParenthesis

[To be supplied.]

[Visual Basic]
Public ReadOnly Property NeedParenthesis As Boolean
[C#]
public bool NeedParenthesis {get;}
[C++]
public: __property bool get_NeedParenthesis();
[JScript]
public function get NeedParenthesis() : Boolean;

See Also

ParenthesizePropertyNameAttribute Class | ParenthesizePropertyNameAttribute Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ParenthesizePropertyNameAttribute Methods

The methods of the ParenthesizePropertyNameAttribute class are listed below. For a complete list of ParenthesizePropertyNameAttribute class members, see the ParenthesizePropertyNameAttribute Members topic.

Public:

Equals | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsDefaultAttribute | [To be supplied.]
Match (inherited from MemberAttribute) | Determines whether one attribute matches another.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ParenthesizePropertyNameAttribute Class | System.ComponentModel.Design Namespace


ParenthesizePropertyNameAttribute.Equals

[To be supplied.]

[Visual Basic]
Overrides Public Function Equals( _
   ByVal o As Object _
) As Boolean
[C#]
public override bool Equals(
   object o
);
[C++]
public: override bool Equals(
   Object* o
);
[JScript]
public override function Equals(
   o : Object
) : Boolean;

Parameters

o
[To be supplied.]

See Also

ParenthesizePropertyNameAttribute Class | ParenthesizePropertyNameAttribute Members | System.ComponentModel.Design Namespace


ParenthesizePropertyNameAttribute.IsDefaultAttribute

[To be supplied.]

[Visual Basic]
Overrides Public Function IsDefaultAttribute() As Boolean
[C#]
public override bool IsDefaultAttribute();
[C++]
public: override bool IsDefaultAttribute();
[JScript]
public override function IsDefaultAttribute() : Boolean;

See Also

ParenthesizePropertyNameAttribute Class | ParenthesizePropertyNameAttribute Members | System.ComponentModel.Design Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ParenthesizePropertyNameAttribute Fields

The fields of the ParenthesizePropertyNameAttribute class are listed below. For a complete list of ParenthesizePropertyNameAttribute class members, see the ParenthesizePropertyNameAttribute Members topic.

Public:

Default Sets the System.ComponentModel.Design.ParenthesizePropertyName attribute by default to false.

See Also

ParenthesizePropertyNameAttribute Class | System.ComponentModel.Design Namespace


ParenthesizePropertyNameAttribute.Default

Sets the System.ComponentModel.Design.ParenthesizePropertyName attribute by default to false.

[Visual Basic]
Public Shared Default As ParenthesizePropertyNameAttribute
[C#]
public static ParenthesizePropertyNameAttribute Default;
[C++]
public: static ParenthesizePropertyNameAttribute* Default;
[JScript]
public static var Default : ParenthesizePropertyNameAttribute;

See Also

ParenthesizePropertyNameAttribute Class | ParenthesizePropertyNameAttribute Members | System.ComponentModel.Design Namespace


PropertyChangeActionUnit Class

Represents a property change action unit.

Object
ComponentChangeBaseActionUnit
PropertyChangeActionUnit

[Visual Basic]
Public Class PropertyChangeActionUnit
   Inherits ComponentChangeBaseActionUnit
[C#]
public class PropertyChangeActionUnit :
   ComponentChangeBaseActionUnit
[C++]
public __gc class PropertyChangeActionUnit : public
   ComponentChangeBaseActionUnit
[JScript]
public class PropertyChangeActionUnit extends
   ComponentChangeBaseActionUnit

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

PropertyChangeActionUnit Members | System.ComponentModel.Design Namespace | IUndoService


PropertyChangeActionUnit Members

Public:

Constructor

PropertyChangeActionUnit Constructor Overloaded. Initializes a new instance of PropertyChangeActionUnit using the specified values.

Methods

DoAction | Performs the action encapsulated in this action unit. The implementation should automatcially toggle between being an Undo or Redo action each time DoAction is called.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDescription | Gets the description for this action unit.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNextActionType (inherited from ComponentChangeBaseActionUnit) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

NewValue Gets or sets the new value for the property.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetTarget | Gets the target the property change occured on.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

propertyDesc Gets or sets a PropertyDescriptor that describes this action unit. This field is read-only.

See Also

PropertyChangeActionUnit Class | System.ComponentModel.Design Namespace


PropertyChangeActionUnit Constructor

Initializes a new instance of PropertyChangeActionUnit using the specified values.

Overload List

Initializes a new instance of PropertyChangeActionUnit using the specified values.

[Visual Basic] Overloads Public Sub New(Object, PropertyDescriptor, Object)
[C#] public PropertyChangeActionUnit(Object, PropertyDescriptor, Object);
[C++] public: PropertyChangeActionUnit(Object*, PropertyDescriptor, Object*);
[JScript] public function PropertyChangeActionUnit(Object, PropertyDescriptor, Object);

Initializes a new instance of PropertyChangeActionUnit using the specified values.

[Visual Basic] Overloads Public Sub New(Object, PropertyDescriptor, Object, Object)
[C#] public PropertyChangeActionUnit(Object, PropertyDescriptor, Object, Object);
[C++] public: PropertyChangeActionUnit(Object*, PropertyDescriptor, Object*, Object*);
[JScript] public function PropertyChangeActionUnit(Object, PropertyDescriptor, Object, Object);

See Also

PropertyChangeActionUnit Class | PropertyChangeActionUnit Members | System.ComponentModel.Design Namespace


PropertyChangeActionUnit Constructor (Object, PropertyDescriptor, Object)

Initializes a new instance of PropertyChangeActionUnit using the specified values.

[Visual Basic]
Overloads Public Sub New( _
   ByVal target As Object, _
   ByVal propDesc As PropertyDescriptor, _
   ByVal newValue As Object _
)
[C#]
public PropertyChangeActionUnit(
   object target,
   PropertyDescriptor propDesc,
   object newValue
);
[C++]
public: PropertyChangeActionUnit(
   Object* target,
   PropertyDescriptor* propDesc,
   Object* newValue
);
[JScript]
public function PropertyChangeActionUnit(
   target : Object,
   propDesc : PropertyDescriptor,
   newValue : Object
);

Parameters

target
The object that contains the property being changed.
propDesc
[To be supplied.]
newValue
[To be supplied.]

See Also

PropertyChangeActionUnit Class | PropertyChangeActionUnit Members | System.ComponentModel.Design Namespace | PropertyChangeActionUnit Constructor Overload List | PropertyDescriptor


PropertyChangeActionUnit Constructor (Object, PropertyDescriptor, Object, Object)

Initializes a new instance of PropertyChangeActionUnit using the specified values.

[Visual Basic]
Overloads Public Sub New( _
   ByVal target As Object, _
   ByVal propDesc As PropertyDescriptor, _
   ByVal newValue As Object, _
   ByVal oldValue As Object _
)
[C#]
public PropertyChangeActionUnit(
   object target,
   PropertyDescriptor propDesc,
   object newValue,
   object oldValue
);
[C++]
public: PropertyChangeActionUnit(
   Object* target,
   PropertyDescriptor* propDesc,
   Object* newValue,
   Object* oldValue
);
[JScript]
public function PropertyChangeActionUnit(
   target : Object,
   propDesc : PropertyDescriptor,
   newValue : Object,
   oldValue : Object
);

Parameters

target
The object that contains the property being changed.
propDesc
[To be supplied.]
newValue
[To be supplied.]
oldValue
[To be supplied.]

See Also

PropertyChangeActionUnit Class | PropertyChangeActionUnit Members | System.ComponentModel.Design Namespace | PropertyChangeActionUnit Constructor Overload List | PropertyDescriptor


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PropertyChangeActionUnit Properties

The properties of the PropertyChangeActionUnit class are listed below. For a complete list of PropertyChangeActionUnit class members, see the PropertyChangeActionUnit Members topic.

Protected:

NewValue Gets or sets the new value for the property.

See Also

PropertyChangeActionUnit Class | System.ComponentModel.Design Namespace


PropertyChangeActionUnit.NewValue

Gets or sets the new value for the property.

[Visual Basic]
Protected Property NewValue As Object
[C#]
protected object NewValue {get; set;}
[C++]
protected: __property Object* get_NewValue();
protected: __property void set_NewValue(Object*);
[JScript]
protected function get NewValue() : Object;
protected function set NewValue(Object);

Property Value

The new value for the property.

See Also

PropertyChangeActionUnit Class | PropertyChangeActionUnit Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PropertyChangeActionUnit Methods

The methods of the PropertyChangeActionUnit class are listed below. For a complete list of PropertyChangeActionUnit class members, see the PropertyChangeActionUnit Members topic.

Public:

DoAction | Performs the action encapsulated in this action unit. The implementation should automatcially toggle between being an Undo or Redo action each time DoAction is called.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDescription | Gets the description for this action unit.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNextActionType (inherited from ComponentChangeBaseActionUnit) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetTarget | Gets the target the property change occured on.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyChangeActionUnit Class | System.ComponentModel.Design Namespace


PropertyChangeActionUnit.DoAction

Performs the action encapsulated in this action unit. The implementation should automatcially toggle between being an Undo or Redo action each time DoAction is called.

[Visual Basic]
Overrides Public Function DoAction() As Boolean
[C#]
public override bool DoAction();
[C++]
public: override bool DoAction();
[JScript]
public override function DoAction() : Boolean;

Return Value

true if the action was successfully carried out; otherwise, false.

See Also

PropertyChangeActionUnit Class | PropertyChangeActionUnit Members | System.ComponentModel.Design Namespace


PropertyChangeActionUnit.GetDescription

Gets the description for this action unit.

[Visual Basic]
Overrides Public Function GetDescription() As String
[C#]
public override string GetDescription();
[C++]
public: override String* GetDescription();
[JScript]
public override function GetDescription() : String;

Return Value

A description of the action encapsulated in this action unit.

See Also

PropertyChangeActionUnit Class | PropertyChangeActionUnit Members | System.ComponentModel.Design Namespace


PropertyChangeActionUnit.GetTarget

Gets the target the property change occured on.

[Visual Basic]
Overrides Protected Function GetTarget() As Object
[C#]
protected override object GetTarget();
[C++]
protected: override Object* GetTarget();
[JScript]
protected override function GetTarget() : Object;

See Also

PropertyChangeActionUnit Class | PropertyChangeActionUnit Members | System.ComponentModel.Design Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PropertyChangeActionUnit Fields

The fields of the PropertyChangeActionUnit class are listed below. For a complete list of PropertyChangeActionUnit class members, see the PropertyChangeActionUnit Members topic.

Protected:

propertyDesc Gets or sets a PropertyDescriptor that describes this action unit. This field is read-only.

See Also

PropertyChangeActionUnit Class | System.ComponentModel.Design Namespace


PropertyChangeActionUnit.propertyDesc

Gets or sets a PropertyDescriptor that describes this action unit. This field is read-only.

[Visual Basic]
Protected ReadOnly propertyDesc As PropertyDescriptor
[C#]
protected readonly PropertyDescriptor propertyDesc;
[C++]
protected: readonly PropertyDescriptor* propertyDesc;
[JScript]
protected var propertyDesc : PropertyDescriptor;

See Also

PropertyChangeActionUnit Class | PropertyChangeActionUnit Members | System.ComponentModel.Design Namespace | IActionUnit


PropertyTabAttribute Class

This attribute identifies the property tab or tabs that should be displayed for a given class.

Object
Attribute
MemberAttribute
PropertyTabAttribute

[Visual Basic]
Public Class PropertyTabAttribute
   Inherits MemberAttribute
[C#]
public class PropertyTabAttribute : MemberAttribute
[C++]
public __gc class PropertyTabAttribute : public MemberAttribute
[JScript]
public class PropertyTabAttribute extends MemberAttribute

Remarks

A tab can add additional property tabs to expose property information other than its default set of properties.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

PropertyTabAttribute Members | System.ComponentModel.Design Namespace


PropertyTabAttribute Members

Public:

Constructor

PropertyTabAttribute Constructor Overloaded. [To be supplied.]

Properties

TabClasses | Gets the types of tab that this attribute specifies.
TabScopes | Gets the scopes of tabs for this PropertyTabAttribute, from PropertyTabScope.
TypeId (inherited from MemberAttribute) | Gets a unique ID for this MemberAttribute.

Methods

Equals (inherited from MemberAttribute) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsDefaultAttribute (inherited from MemberAttribute) | When overridden in a derived class, specifies whether this MemberAttribute is the default attribute for the class.
Match (inherited from MemberAttribute) | Determines whether one attribute matches another.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyTabAttribute Class | System.ComponentModel.Design Namespace


PropertyTabAttribute Constructor

[To be supplied.]

Overload List

Basic constructor that creates a property tab attribute that will create a tab of the specified type.

[Visual Basic] Overloads Public Sub New(Type)
[C#] public PropertyTabAttribute(Type);
[C++] public: PropertyTabAttribute(Type*);
[JScript] public function PropertyTabAttribute(Type);

Basic constructor that creates a property tab attribute that will create a tab of the specified type.

[Visual Basic] Overloads Public Sub New(String)
[C#] public PropertyTabAttribute(String);
[C++] public: PropertyTabAttribute(String*);
[JScript] public function PropertyTabAttribute(String);

Basic constructor that creates a property tab attribute that will create a tab of the specified type.

[Visual Basic] Overloads Public Sub New(Type, PropertyTabScope)
[C#] public PropertyTabAttribute(Type, PropertyTabScope);
[C++] public: PropertyTabAttribute(Type*, PropertyTabScope);
[JScript] public function PropertyTabAttribute(Type, PropertyTabScope);

Basic constructor that creates a property tab attribute that will create a tab of the specified type.

[Visual Basic] Overloads Public Sub New(String, PropertyTabScope)
[C#] public PropertyTabAttribute(String, PropertyTabScope);
[C++] public: PropertyTabAttribute(String*, PropertyTabScope);
[JScript] public function PropertyTabAttribute(String, PropertyTabScope);

Basic constructor that creates a property tab attribute that will create a tab of the specified type.

[Visual Basic] Overloads Public Sub New(Type())
[C#] public PropertyTabAttribute(Type[]);
[C++] public: PropertyTabAttribute(Type*[]);
[JScript] public function PropertyTabAttribute(Type[]);

Basic constructor that creates a property tab attribute that will create a tab of the specified type.

[Visual Basic] Overloads Public Sub New(String(), PropertyTabScope())
[C#] public PropertyTabAttribute(String[], PropertyTabScope[]);
[C++] public: PropertyTabAttribute(String*[], PropertyTabScope[]);
[JScript] public function PropertyTabAttribute(String[], PropertyTabScope[]);

Basic constructor that creates a property tab attribute that will create a tab of the specified type.

[Visual Basic] Overloads Public Sub New(Type(), PropertyTabScope())
[C#] public PropertyTabAttribute(Type[], PropertyTabScope[]);
[C++] public: PropertyTabAttribute(Type*[], PropertyTabScope[]);
[JScript] public function PropertyTabAttribute(Type[], PropertyTabScope[]);

See Also

PropertyTabAttribute Class | PropertyTabAttribute Members | System.ComponentModel.Design Namespace


PropertyTabAttribute Constructor (Type)

Basic constructor that creates a property tab attribute that will create a tab of the specified type.

[Visual Basic]
Overloads Public Sub New( _
   ByVal tabClass As Type _
)
[C#]
public PropertyTabAttribute(
   Type tabClass
);
[C++]
public: PropertyTabAttribute(
   Type* tabClass
);
[JScript]
public function PropertyTabAttribute(
   tabClass : Type
);

Parameters

tabClass
The type of tab this attribute will create.

See Also

PropertyTabAttribute Class | PropertyTabAttribute Members | System.ComponentModel.Design Namespace | PropertyTabAttribute Constructor Overload List


PropertyTabAttribute Constructor (String)

Basic constructor that creates a property tab attribute that will create a tab of the specified type.

[Visual Basic]
Overloads Public Sub New( _
   ByVal tabClassName As String _
)
[C#]
public PropertyTabAttribute(
   string tabClassName
);
[C++]
public: PropertyTabAttribute(
   String* tabClassName
);
[JScript]
public function PropertyTabAttribute(
   tabClassName : String
);

Parameters

tabClassName
The fully qualified name type of tab this attriute will create. An assembly or module name can also be specified by appending a comma and then the module name. Example: "MyNameSpace.MyPropertyTab,MyPropertyTab.dll"

See Also

PropertyTabAttribute Class | PropertyTabAttribute Members | System.ComponentModel.Design Namespace | PropertyTabAttribute Constructor Overload List


PropertyTabAttribute Constructor (Type, PropertyTabScope)

Basic constructor that creates a property tab attribute that will create a tab of the specified type.

[Visual Basic]
Overloads Public Sub New( _
   ByVal tabClass As Type, _
   ByVal tabScope As PropertyTabScope _
)
[C#]
public PropertyTabAttribute(
   Type tabClass,
   PropertyTabScope tabScope
);
[C++]
public: PropertyTabAttribute(
   Type* tabClass,
   PropertyTabScope tabScope
);
[JScript]
public function PropertyTabAttribute(
   tabClass : Type,
   tabScope : PropertyTabScope
);

Parameters

tabClass
The type of tab this attriute will create.
tabScope
The scope of this tab. If the scope is PropertyTabScope.Component, it will only be shown for the components with the corrsponding PropertyTabAttribute. If it is PropertyTabScope.Document, it will be shown for all components on the document.

See Also

PropertyTabAttribute Class | PropertyTabAttribute Members | System.ComponentModel.Design Namespace | PropertyTabAttribute Constructor Overload List


PropertyTabAttribute Constructor (String, PropertyTabScope)

Basic constructor that creates a property tab attribute that will create a tab of the specified type.

[Visual Basic]
Overloads Public Sub New( _
   ByVal tabClassName As String, _
   ByVal tabScope As PropertyTabScope _
)
[C#]
public PropertyTabAttribute(
   string tabClassName,
   PropertyTabScope tabScope
);
[C++]
public: PropertyTabAttribute(
   String* tabClassName,
   PropertyTabScope tabScope
);
[JScript]
public function PropertyTabAttribute(
   tabClassName : String,
   tabScope : PropertyTabScope
);

Parameters

tabClassName
The fully qualified name type of tab this attriute will create. An assembly or module name can also be specified by appending a comma and then the module name. Example: "MyNameSpace.MyPropertyTab,MyPropertyTab.dll"
tabScope
The scope of this tab. If the scope is PropertyTabScope.Component, it will only be shown for the components with the corrsponding PropertyTabAttribute. If it is PropertyTabScope.Document, it will be shown for all components on the document.

See Also

PropertyTabAttribute Class | PropertyTabAttribute Members | System.ComponentModel.Design Namespace | PropertyTabAttribute Constructor Overload List


PropertyTabAttribute Constructor (Type[])

Basic constructor that creates a property tab attribute that will create a tab of the specified type.

[Visual Basic]
Overloads Public Sub New( _
   ByVal tabClasses() As Type _
)
[C#]
public PropertyTabAttribute(
   Type[] tabClasses
);
[C++]
public: PropertyTabAttribute(
   Type* tabClasses[]
);
[JScript]
public function PropertyTabAttribute(
   tabClasses : Type[]
);

Parameters

tabClasses
The types of tabs this attriute will create.

See Also

PropertyTabAttribute Class | PropertyTabAttribute Members | System.ComponentModel.Design Namespace | PropertyTabAttribute Constructor Overload List


PropertyTabAttribute Constructor (String[], PropertyTabScope[])

Basic constructor that creates a property tab attribute that will create a tab of the specified type.

[Visual Basic]
Overloads Public Sub New( _
   ByVal tabClassNames() As String, _
   ByVal tabScopes() As PropertyTabScope _
)
[C#]
public PropertyTabAttribute(
   string[] tabClassNames,
   PropertyTabScope[] tabScopes
);
[C++]
public: PropertyTabAttribute(
   String* tabClassNames[],
   PropertyTabScope* tabScopes[]
);
[JScript]
public function PropertyTabAttribute(
   tabClassNames : String[],
   tabScopes : PropertyTabScope[]
);

Parameters

tabClassNames
The fully qualified name types of tabs this attriute will create. An assembly or module name can also be specified by appending a comma and then the module name. Example: "MyNameSpace.MyPropertyTab,MyPropertyTab.dll"
tabScopes
The scope of this tab. If the scope is PropertyTabScope.Component, it will only be shown for the components with the corrsponding PropertyTabAttribute. If it is PropertyTabScope.Document, it will be shown for all components on the document.

See Also

PropertyTabAttribute Class | PropertyTabAttribute Members | System.ComponentModel.Design Namespace | PropertyTabAttribute Constructor Overload List


PropertyTabAttribute Constructor (Type[], PropertyTabScope[])

Basic constructor that creates a property tab attribute that will create a tab of the specified type.

[Visual Basic]
Overloads Public Sub New( _
   ByVal tabClasses() As Type, _
   ByVal tabScopes() As PropertyTabScope _
)
[C#]
public PropertyTabAttribute(
   Type[] tabClasses,
   PropertyTabScope[] tabScopes
);
[C++]
public: PropertyTabAttribute(
   Type* tabClasses[],
   PropertyTabScope* tabScopes[]
);
[JScript]
public function PropertyTabAttribute(
   tabClasses : Type[],
   tabScopes : PropertyTabScope[]
);

Parameters

tabClasses
The types of tabs this attriute will create.
tabScopes
The scope of this tab. If the scope is PropertyTabScope.Component, it will only be shown for the components with the corrsponding PropertyTabAttribute. If it is PropertyTabScope.Document, it will be shown for all components on the document.

See Also

PropertyTabAttribute Class | PropertyTabAttribute Members | System.ComponentModel.Design Namespace | PropertyTabAttribute Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PropertyTabAttribute Properties

The properties of the PropertyTabAttribute class are listed below. For a complete list of PropertyTabAttribute class members, see the PropertyTabAttribute Members topic.

Public:

TabClasses | Gets the types of tab that this attribute specifies.
TabScopes | Gets the scopes of tabs for this PropertyTabAttribute, from PropertyTabScope.
TypeId (inherited from MemberAttribute) | Gets a unique ID for this MemberAttribute.

See Also

PropertyTabAttribute Class | System.ComponentModel.Design Namespace


PropertyTabAttribute.TabClasses

Gets the types of tab that this attribute specifies.

[Visual Basic]
Public ReadOnly Property TabClasses As Type ()
[C#]
public Type[] TabClasses {get;}
[C++]
public: __property Type* get_TabClasses();
[JScript]
public function get TabClasses() : Type[];

Remarks

All of these types must be assignable to PropertyTab.

See Also

PropertyTabAttribute Class | PropertyTabAttribute Members | System.ComponentModel.Design Namespace


PropertyTabAttribute.TabScopes

Gets the scopes of tabs for this PropertyTabAttribute, from PropertyTabScope.

[Visual Basic]
Public ReadOnly Property TabScopes As PropertyTabScope ()
[C#]
public PropertyTabScope[] TabScopes {get;}
[C++]
public: __property PropertyTabScope* get_TabScopes();
[JScript]
public function get TabScopes() : PropertyTabScope[];

See Also

PropertyTabAttribute Class | PropertyTabAttribute Members | System.ComponentModel.Design Namespace | PropertyTabScope


PropertyTabScope Enumeration

Specifies the function scope of a tab in the property browser.

[Visual Basic]
Public Enum PropertyTabScope
[C#]
public enum PropertyTabScope
[C++]
public enum PropertyTabScope

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

PropertyTabScope defines the scope of a tab that will show up in the property browser when a component on the form/class has the correct PropertyTabAttribute.

Members

Member Name | Description
Component | This tab will be added to the property browser for the current component only, and is removed when the component is no longer selected.
Document | This tab will be added to the property browser and will be removed when the currently selected document changes. This tab is relevant to items on the current document.
Global | This tab will be added to the property browser and can only be explictly removed by a component outside the property browser.
Static | This tab will be added to the property browser and can never be removed.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

System.ComponentModel.Design Namespace | PropertyTabAttribute


PropertyValue Class

PropertyValue encapsulates information about a property's type and value. The goal of the class is to enable persistence in code (code-spit) of any object. @author stefanph, August 1998 UNDONE: Brianpe/ ChrisAn, 5/15/99- Is this really the thing we want to surface here?: I think we should probably be using the code model interfaces more...

Object
PropertyValue

[Visual Basic]
NotInheritable Public Class PropertyValue
[C#]
public sealed class PropertyValue
[C++]
public __gc __sealed class PropertyValue
[JScript]
public class PropertyValue

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

PropertyValue Members | System.ComponentModel.Design Namespace


PropertyValue Members

Public:

Properties

Value | [To be supplied.]
ValueType | [To be supplied.]
ValueTypeName | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetArrayElems | [To be supplied.]
GetArrayType | [To be supplied.]
GetConstantValue | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetIPersistableElems | UNDONE, stefanph: Documentation
GetIPersistableObject | [To be supplied.]
GetIPersistableResourceName | [To be supplied.]
GetIPersistableTypeName | [To be supplied.]
GetKind | Gets the type of value represented by this object
GetNewObjectArgs | [To be supplied.]
GetNewObjectMethodName | [To be supplied.]
GetNewObjectTypeName | [To be supplied.]
GetObjectResourceName | UNDONE, stefanph: documentation
GetObjectType | [To be supplied.]
GetObjectValue | [To be supplied.]
GetReference | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
MakeArray | Use this to store an array.
MakeConstant | Use this to store a named constant, like System.Drawing.Font.BOLD.
MakeIPersistable | Use this to store an object that can persist itself.
MakeNewObject | Use this to store an object whose constructor argument types and values are known (typically gotten from an object through a CreationBundle).
MakeObject | Use this to store a simple typed value, like Integer or String (or any other Object-derived type) or...UNDONE, stefanph: What's resourceName for?
MakePropertyValue | Overloaded. [To be supplied.]
MakeReference | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

TYPE_ARRAY | [To be supplied.]
TYPE_CONSTANT | [To be supplied.]
TYPE_IPERSISTABLE | [To be supplied.]
TYPE_NEWOBJECT | [To be supplied.]
TYPE_OBJECT | [To be supplied.]
TYPE_REFERENCE | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyValue Class | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PropertyValue Properties

The properties of the PropertyValue class are listed below. For a complete list of PropertyValue class members, see the PropertyValue Members topic.

Public:

Value | [To be supplied.]
ValueType | [To be supplied.]
ValueTypeName | [To be supplied.]

See Also

PropertyValue Class | System.ComponentModel.Design Namespace


PropertyValue.Value

[To be supplied.]

[Visual Basic]
Public Property Value As Object
[C#]
public object Value {get; set;}
[C++]
public: __property Object* get_Value();
public: __property void set_Value(Object*);
[JScript]
public function get Value() : Object;
public function set Value(Object);

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


PropertyValue.ValueType

[To be supplied.]

[Visual Basic]
Public ReadOnly Property ValueType As Type
[C#]
public Type ValueType {get;}
[C++]
public: __property Type* get_ValueType();
[JScript]
public function get ValueType() : Type;

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


PropertyValue.ValueTypeName

[To be supplied.]

[Visual Basic]
Public ReadOnly Property ValueTypeName As String
[C#]
public string ValueTypeName {get;}
[C++]
public: __property String* get_ValueTypeName();
[JScript]
public function get ValueTypeName() : String;

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PropertyValue Methods

The methods of the PropertyValue class are listed below. For a complete list of PropertyValue class members, see the PropertyValue Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetArrayElems | [To be supplied.]
GetArrayType | [To be supplied.]
GetConstantValue | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetIPersistableElems | UNDONE, stefanph: Documentation
GetIPersistableObject | [To be supplied.]
GetIPersistableResourceName | [To be supplied.]
GetIPersistableTypeName | [To be supplied.]
GetKind | Gets the type of value represented by this object
GetNewObjectArgs | [To be supplied.]
GetNewObjectMethodName | [To be supplied.]
GetNewObjectTypeName | [To be supplied.]
GetObjectResourceName | UNDONE, stefanph: documentation
GetObjectType | [To be supplied.]
GetObjectValue | [To be supplied.]
GetReference | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
MakeArray | Use this to store an array.
MakeConstant | Use this to store a named constant, like System.Drawing.Font.BOLD.
MakeIPersistable | Use this to store an object that can persist itself.
MakeNewObject | Use this to store an object whose constructor argument types and values are known (typically gotten from an object through a CreationBundle).
MakeObject | Use this to store a simple typed value, like Integer or String (or any other Object-derived type) or...UNDONE, stefanph: What's resourceName for?
MakePropertyValue | Overloaded. [To be supplied.]
MakeReference | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyValue Class | System.ComponentModel.Design Namespace


PropertyValue.GetArrayElems

[To be supplied.]

[Visual Basic]
Public Function GetArrayElems() As PropertyValue ()
[C#]
public PropertyValue[] GetArrayElems();
[C++]
public: PropertyValue* GetArrayElems() [];
[JScript]
public function GetArrayElems() : PropertyValue[];

Return Value

the elements of the array

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


PropertyValue.GetArrayType

[To be supplied.]

[Visual Basic]
Public Function GetArrayType() As String
[C#]
public string GetArrayType();
[C++]
public: String* GetArrayType();
[JScript]
public function GetArrayType() : String;

Return Value

the type of the array

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


PropertyValue.GetConstantValue

[To be supplied.]

[Visual Basic]
Public Function GetConstantValue() As String
[C#]
public string GetConstantValue();
[C++]
public: String* GetConstantValue();
[JScript]
public function GetConstantValue() : String;

Return Value

The name of the constant this value represents

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


PropertyValue.GetIPersistableElems

UNDONE, stefanph: Documentation

[Visual Basic]
Public Function GetIPersistableElems() As PropertyValue ()
[C#]
public PropertyValue[] GetIPersistableElems();
[C++]
public: PropertyValue* GetIPersistableElems() [];
[JScript]
public function GetIPersistableElems() : PropertyValue[];

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


PropertyValue.GetIPersistableObject

[To be supplied.]

[Visual Basic]
Public Function GetIPersistableObject() As IPersistable
[C#]
public IPersistable GetIPersistableObject();
[C++]
public: IPersistable* GetIPersistableObject();
[JScript]
public function GetIPersistableObject() : IPersistable;

Return Value

the IPersistable object

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


PropertyValue.GetIPersistableResourceName

[To be supplied.]

[Visual Basic]
Public Function GetIPersistableResourceName() As String
[C#]
public string GetIPersistableResourceName();
[C++]
public: String* GetIPersistableResourceName();
[JScript]
public function GetIPersistableResourceName() : String;

Return Value

the filename to/from which the object can persist itself

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


PropertyValue.GetIPersistableTypeName

[To be supplied.]

[Visual Basic]
Public Function GetIPersistableTypeName() As String
[C#]
public string GetIPersistableTypeName();
[C++]
public: String* GetIPersistableTypeName();
[JScript]
public function GetIPersistableTypeName() : String;

Return Value

the type name of the object

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


PropertyValue.GetKind

Gets the type of value represented by this object

[Visual Basic]
Public Function GetKind() As Integer
[C#]
public int GetKind();
[C++]
public: int GetKind();
[JScript]
public function GetKind() : int;

Return Value

an integer matching one of the TYPE_* constants in PropertyValue

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


PropertyValue.GetNewObjectArgs

[To be supplied.]

[Visual Basic]
Public Function GetNewObjectArgs() As PropertyValue ()
[C#]
public PropertyValue[] GetNewObjectArgs();
[C++]
public: PropertyValue* GetNewObjectArgs() [];
[JScript]
public function GetNewObjectArgs() : PropertyValue[];

Return Value

the arguments to pass to the object's constructor

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


PropertyValue.GetNewObjectMethodName

[To be supplied.]

[Visual Basic]
Public Function GetNewObjectMethodName() As String
[C#]
public string GetNewObjectMethodName();
[C++]
public: String* GetNewObjectMethodName();
[JScript]
public function GetNewObjectMethodName() : String;

Return Value

the name of the method to call to create this object. null will be returned if the constructor should be called.

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


PropertyValue.GetNewObjectTypeName

[To be supplied.]

[Visual Basic]
Public Function GetNewObjectTypeName() As String
[C#]
public string GetNewObjectTypeName();
[C++]
public: String* GetNewObjectTypeName();
[JScript]
public function GetNewObjectTypeName() : String;

Return Value

the name of the constructor to call to create this object again

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


PropertyValue.GetObjectResourceName

UNDONE, stefanph: documentation

[Visual Basic]
Public Function GetObjectResourceName() As String
[C#]
public string GetObjectResourceName();
[C++]
public: String* GetObjectResourceName();
[JScript]
public function GetObjectResourceName() : String;

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


PropertyValue.GetObjectType

[To be supplied.]

[Visual Basic]
Public Function GetObjectType() As Type
[C#]
public Type GetObjectType();
[C++]
public: Type* GetObjectType();
[JScript]
public function GetObjectType() : Type;

Return Value

the type of the object value

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


PropertyValue.GetObjectValue

[To be supplied.]

[Visual Basic]
Public Function GetObjectValue() As Object
[C#]
public object GetObjectValue();
[C++]
public: Object* GetObjectValue();
[JScript]
public function GetObjectValue() : Object;

Return Value

the object value

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


PropertyValue.GetReference

[To be supplied.]

[Visual Basic]
Public Function GetReference() As Object
[C#]
public object GetReference();
[C++]
public: Object* GetReference();
[JScript]
public function GetReference() : Object;

Return Value

the object that is refered to.

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


PropertyValue.MakeArray

Use this to store an array.

[Visual Basic]
Public Shared Function MakeArray( _
   ByVal service As IServiceObjectProvider, _
   ByVal className As String, _
   ByVal elems() As PropertyValue _
) As PropertyValue
[C#]
public static PropertyValue MakeArray(
   IServiceObjectProvider service,
   string className,
   PropertyValue[] elems
);
[C++]
public: static PropertyValue* MakeArray(
   IServiceObjectProvider* service,
   String* className,
   PropertyValue* elems[]
);
[JScript]
public static function MakeArray(
   service : IServiceObjectProvider,
   className : String,
   elems : PropertyValue[]
) : PropertyValue;

Parameters

service
[To be supplied.]
className
the array type, like Integer[]
elems
the values of the array, each represented by a PropertyValue

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


PropertyValue.MakeConstant

Use this to store a named constant, like System.Drawing.Font.BOLD.

[Visual Basic]
Public Shared Function MakeConstant( _
   ByVal service As IServiceObjectProvider, _
   ByVal bundle As CreationBundle _
) As PropertyValue
[C#]
public static PropertyValue MakeConstant(
   IServiceObjectProvider service,
   CreationBundle bundle
);
[C++]
public: static PropertyValue* MakeConstant(
   IServiceObjectProvider* service,
   CreationBundle* bundle
);
[JScript]
public static function MakeConstant(
   service : IServiceObjectProvider,
   bundle : CreationBundle
) : PropertyValue;

Parameters

service
[To be supplied.]
bundle
A creation bundle that contains the constant. Null for a void type.

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


PropertyValue.MakeIPersistable

Use this to store an object that can persist itself.

[Visual Basic]
Public Shared Function MakeIPersistable( _
   ByVal service As IServiceObjectProvider, _
   ByVal resourceName As String, _
   ByVal className As String, _
   ByVal ip As IPersistable, _
   ByVal elems() As PropertyValue _
) As PropertyValue
[C#]
public static PropertyValue MakeIPersistable(
   IServiceObjectProvider service,
   string resourceName,
   string className,
   IPersistable ip,
   PropertyValue[] elems
);
[C++]
public: static PropertyValue* MakeIPersistable(
   IServiceObjectProvider* service,
   String* resourceName,
   String* className,
   IPersistable* ip,
   PropertyValue* elems[]
);
[JScript]
public static function MakeIPersistable(
   service : IServiceObjectProvider,
   resourceName : String,
   className : String,
   ip : IPersistable,
   elems : PropertyValue[]
) : PropertyValue;

Parameters

service
[To be supplied.]
resourceName
the filename to which the object will be persisted
className
the type of the object
ip
the object itself
elems
UNDONE, stefanph: what's this for?

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


PropertyValue.MakeNewObject

Use this to store an object whose constructor argument types and values are known (typically gotten from an object through a CreationBundle).

[Visual Basic]
Public Shared Function MakeNewObject( _
   ByVal service As IServiceObjectProvider, _
   ByVal name As String, _
   ByVal method As String, _
   ByVal args() As PropertyValue _
) As PropertyValue
[C#]
public static PropertyValue MakeNewObject(
   IServiceObjectProvider service,
   string name,
   string method,
   PropertyValue[] args
);
[C++]
public: static PropertyValue* MakeNewObject(
   IServiceObjectProvider* service,
   String* name,
   String* method,
   PropertyValue* args[]
);
[JScript]
public static function MakeNewObject(
   service : IServiceObjectProvider,
   name : String,
   method : String,
   args : PropertyValue[]
) : PropertyValue;

Parameters

service
[To be supplied.]
name
the name of the contstructor (the object's type name)
method
[To be supplied.]
args
PropertyValue's representing type and value of all constructor arguments

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


PropertyValue.MakeObject

Use this to store a simple typed value, like Integer or String (or any other Object-derived type) or...UNDONE, stefanph: What's resourceName for?

[Visual Basic]
Public Shared Function MakeObject( _
   ByVal service As IServiceObjectProvider, _
   ByVal obj As Object, _
   ByVal resourceName As String, _
   ByVal objType As Type _
) As PropertyValue
[C#]
public static PropertyValue MakeObject(
   IServiceObjectProvider service,
   object obj,
   string resourceName,
   Type objType
);
[C++]
public: static PropertyValue* MakeObject(
   IServiceObjectProvider* service,
   Object* obj,
   String* resourceName,
   Type* objType
);
[JScript]
public static function MakeObject(
   service : IServiceObjectProvider,
   obj : Object,
   resourceName : String,
   objType : Type
) : PropertyValue;

Parameters

service
[To be supplied.]
obj
the value to store
resourceName
UNDONE, stefanph: What's this for?
objType
the type of that value

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


PropertyValue.MakePropertyValue

[To be supplied.]

Overload List

Given a property value, name, type, and other information, creates a PropertyValue object that correctly represents that property.

[Visual Basic] Overloads Public Shared Function MakePropertyValue(IServiceObjectProvider, Object, PropertyDescriptor, Boolean, Object) As PropertyValue
[C#] public static PropertyValue MakePropertyValue(IServiceObjectProvider, Object, PropertyDescriptor, bool, Object);
[C++] public: static PropertyValue* MakePropertyValue(IServiceObjectProvider*, Object, PropertyDescriptor, bool, Object);
[JScript] public static function MakePropertyValue(IServiceObjectProvider, Object, PropertyDescriptor, Boolean, Object) : PropertyValue;

Given a property value, name, type, and other information, creates a PropertyValue object that correctly represents that property.

[Visual Basic] Overloads Public Shared Function MakePropertyValue(IServiceObjectProvider, Object, PropertyDescriptor, Boolean) As PropertyValue
[C#] public static PropertyValue MakePropertyValue(IServiceObjectProvider, Object, PropertyDescriptor, bool);
[C++] public: static PropertyValue* MakePropertyValue(IServiceObjectProvider*, Object, PropertyDescriptor, bool);
[JScript] public static function MakePropertyValue(IServiceObjectProvider, Object, PropertyDescriptor, Boolean) : PropertyValue;

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


PropertyValue.MakePropertyValue (IServiceObjectProvider, Object, PropertyDescriptor, Boolean, Object)

Given a property value, name, type, and other information, creates a PropertyValue object that correctly represents that property.

[Visual Basic]
Overloads Public Shared Function MakePropertyValue( _
   ByVal service As IServiceObjectProvider, _
   ByVal component As Object, _
   ByVal property As PropertyDescriptor, _
   ByVal localizeMode As Boolean, _
   ByVal value As Object _
) As PropertyValue
[C#]
public static PropertyValue MakePropertyValue(
   IServiceObjectProvider service,
   object component,
   PropertyDescriptor property,
   bool localizeMode,
   object value
);
[C++]
public: static PropertyValue* MakePropertyValue(
   IServiceObjectProvider* service,
   Object* component,
   PropertyDescriptor* property,
   bool localizeMode,
   Object* value
);
[JScript]
public static function MakePropertyValue(
   service : IServiceObjectProvider,
   component : Object,
   property : PropertyDescriptor,
   localizeMode : Boolean,
   value : Object
) : PropertyValue;

Parameters

service
[To be supplied.]
component
[To be supplied.]
property
PropertyDescriptor for the property being persisted
localizeMode
whether the property can and will be localized.
value
the value of the property being persisted

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace | PropertyValue.MakePropertyValue Overload List


PropertyValue.MakePropertyValue (IServiceObjectProvider, Object, PropertyDescriptor, Boolean)

Given a property value, name, type, and other information, creates a PropertyValue object that correctly represents that property.

[Visual Basic]
Overloads Public Shared Function MakePropertyValue( _
   ByVal service As IServiceObjectProvider, _
   ByVal component As Object, _
   ByVal property As PropertyDescriptor, _
   ByVal localizeMode As Boolean _
) As PropertyValue
[C#]
public static PropertyValue MakePropertyValue(
   IServiceObjectProvider service,
   object component,
   PropertyDescriptor property,
   bool localizeMode
);
[C++]
public: static PropertyValue* MakePropertyValue(
   IServiceObjectProvider* service,
   Object* component,
   PropertyDescriptor* property,
   bool localizeMode
);
[JScript]
public static function MakePropertyValue(
   service : IServiceObjectProvider,
   component : Object,
   property : PropertyDescriptor,
   localizeMode : Boolean
) : PropertyValue;

Parameters

service
[To be supplied.]
component
[To be supplied.]
property
PropertyDescriptor for the property being persisted
localizeMode
whether the property can and will be localized.

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace | PropertyValue.MakePropertyValue Overload List


PropertyValue.MakeReference

[To be supplied.]

[Visual Basic]
Public Shared Function MakeReference( _
   ByVal service As IServiceObjectProvider, _
   ByVal reference As Object _
) As PropertyValue
[C#]
public static PropertyValue MakeReference(
   IServiceObjectProvider service,
   object reference
);
[C++]
public: static PropertyValue* MakeReference(
   IServiceObjectProvider* service,
   Object* reference
);
[JScript]
public static function MakeReference(
   service : IServiceObjectProvider,
   reference : Object
) : PropertyValue;

Parameters

service
[To be supplied.]
reference
[To be supplied.]

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PropertyValue Fields

The fields of the PropertyValue class are listed below. For a complete list of PropertyValue class members, see the PropertyValue Members topic.

Public:

TYPE_ARRAY | [To be supplied.]
TYPE_CONSTANT | [To be supplied.]
TYPE_IPERSISTABLE | [To be supplied.]
TYPE_NEWOBJECT | [To be supplied.]
TYPE_OBJECT | [To be supplied.]
TYPE_REFERENCE | [To be supplied.]

See Also

PropertyValue Class | System.ComponentModel.Design Namespace


PropertyValue.TYPE_ARRAY

[To be supplied.]

[Visual Basic]
Public Const TYPE_ARRAY As Integer
[C#]
public const int TYPE_ARRAY;
[C++]
public: const int TYPE_ARRAY;
[JScript]
public var TYPE_ARRAY : int;

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


PropertyValue.TYPE_CONSTANT

[To be supplied.]

[Visual Basic]
Public Const TYPE_CONSTANT As Integer
[C#]
public const int TYPE_CONSTANT;
[C++]
public: const int TYPE_CONSTANT;
[JScript]
public var TYPE_CONSTANT : int;

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


PropertyValue.TYPE_IPERSISTABLE

[To be supplied.]

[Visual Basic]
Public Const TYPE_IPERSISTABLE As Integer
[C#]
public const int TYPE_IPERSISTABLE;
[C++]
public: const int TYPE_IPERSISTABLE;
[JScript]
public var TYPE_IPERSISTABLE : int;

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


PropertyValue.TYPE_NEWOBJECT

[To be supplied.]

[Visual Basic]
Public Const TYPE_NEWOBJECT As Integer
[C#]
public const int TYPE_NEWOBJECT;
[C++]
public: const int TYPE_NEWOBJECT;
[JScript]
public var TYPE_NEWOBJECT : int;

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


PropertyValue.TYPE_OBJECT

[To be supplied.]

[Visual Basic]
Public Const TYPE_OBJECT As Integer
[C#]
public const int TYPE_OBJECT;
[C++]
public: const int TYPE_OBJECT;
[JScript]
public var TYPE_OBJECT : int;

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


PropertyValue.TYPE_REFERENCE

[To be supplied.]

[Visual Basic]
Public Const TYPE_REFERENCE As Integer
[C#]
public const int TYPE_REFERENCE;
[C++]
public: const int TYPE_REFERENCE;
[JScript]
public var TYPE_REFERENCE : int;

See Also

PropertyValue Class | PropertyValue Members | System.ComponentModel.Design Namespace


ReadOnlyValueEditor Class

[To be supplied.]

Object
ValueEditor
ReadOnlyValueEditor

[Visual Basic]
Public Class ReadOnlyValueEditor
   Inherits ValueEditor
[C#]
public class ReadOnlyValueEditor : ValueEditor
[C++]
public __gc class ReadOnlyValueEditor : public ValueEditor
[JScript]
public class ReadOnlyValueEditor extends ValueEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

ReadOnlyValueEditor Members | System.ComponentModel.Design Namespace


ReadOnlyValueEditor Members

Public:

Constructor

ReadOnlyValueEditor Constructor [To be supplied.]

Properties

Style | [To be supplied.]
Values (inherited from ValueEditor) | [To be supplied.]

Methods

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from ValueEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from ValueEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReadOnlyValueEditor Class | System.ComponentModel.Design Namespace


ReadOnlyValueEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ReadOnlyValueEditor();
[C++]
public: ReadOnlyValueEditor();
[JScript]
public function ReadOnlyValueEditor();

See Also

ReadOnlyValueEditor Class | ReadOnlyValueEditor Members | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ReadOnlyValueEditor Properties

The properties of the ReadOnlyValueEditor class are listed below. For a complete list of ReadOnlyValueEditor class members, see the ReadOnlyValueEditor Members topic.

Public:

Style | [To be supplied.]
Values (inherited from ValueEditor) | [To be supplied.]

See Also

ReadOnlyValueEditor Class | System.ComponentModel.Design Namespace


ReadOnlyValueEditor.Style

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Style As ValueEditorStyles
[C#]
public ValueEditorStyles Style {override get;}
[C++]
public: __property virtual ValueEditorStyles get_Style();
[JScript]
public function get Style() : ValueEditorStyles;

See Also

ReadOnlyValueEditor Class | ReadOnlyValueEditor Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ReadOnlyValueEditor Methods

The methods of the ReadOnlyValueEditor class are listed below. For a complete list of ReadOnlyValueEditor class members, see the ReadOnlyValueEditor Members topic.

Public:

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from ValueEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from ValueEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReadOnlyValueEditor Class | System.ComponentModel.Design Namespace


ReadOnlyValueEditor.GetTextFromValue

[To be supplied.]

[Visual Basic]
Overrides Public Function GetTextFromValue( _
   ByVal value As Object _
) As String
[C#]
public override string GetTextFromValue(
   object value
);
[C++]
public: override String* GetTextFromValue(
   Object* value
);
[JScript]
public override function GetTextFromValue(
   value : Object
) : String;

Parameters

value
[To be supplied.]

See Also

ReadOnlyValueEditor Class | ReadOnlyValueEditor Members | System.ComponentModel.Design Namespace


ReferenceEditor Class

ReferenceEditor is an editor that handles references to other components. When asked to list the possible values, it will query the container of the hosting component for all components that implement the given type and return that list.

Object
ValueEditor
ReferenceEditor

[Visual Basic]
Public Class ReferenceEditor
   Inherits ValueEditor
[C#]
public class ReferenceEditor : ValueEditor
[C++]
public __gc class ReferenceEditor : public ValueEditor
[JScript]
public class ReferenceEditor extends ValueEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

ReferenceEditor Members | System.ComponentModel.Design Namespace | IContainer | IComponent


ReferenceEditor Members

Public:

Constructor

ReferenceEditor Constructor Overloaded. [To be supplied.]

Properties

Style (inherited from ValueEditor) | [To be supplied.]
Values | Retrieves the components on the form that can be assigned to the type of the editor.

Methods

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from ValueEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue (inherited from ValueEditor) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from ValueEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

Container | [To be supplied.]
ReferenceService | [To be supplied.]
Type | [To be supplied.]

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

none What we return textually for null.

See Also

ReferenceEditor Class | System.ComponentModel.Design Namespace


ReferenceEditor Constructor

[To be supplied.]

Overload List

Constructs a ReferenceEditor. The site contains the hosting component and the type to look for.

[Visual Basic] Overloads Public Sub New()
[C#] public ReferenceEditor();
[C++] public: ReferenceEditor();
[JScript] public function ReferenceEditor();

Constructs a ReferenceEditor. The site contains the hosting component and the type to look for.

[Visual Basic] Overloads Public Sub New(IEditorSite)
[C#] public ReferenceEditor(IEditorSite);
[C++] public: ReferenceEditor(IEditorSite*);
[JScript] public function ReferenceEditor(IEditorSite);

See Also

ReferenceEditor Class | ReferenceEditor Members | System.ComponentModel.Design Namespace


ReferenceEditor Constructor ()

Constructs a ReferenceEditor. The site contains the hosting component and the type to look for.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ReferenceEditor();
[C++]
public: ReferenceEditor();
[JScript]
public function ReferenceEditor();

See Also

ReferenceEditor Class | ReferenceEditor Members | System.ComponentModel.Design Namespace | ReferenceEditor Constructor Overload List


ReferenceEditor Constructor (IEditorSite)

Constructs a ReferenceEditor. The site contains the hosting component and the type to look for.

[Visual Basic]
Overloads Public Sub New( _
   ByVal site As IEditorSite _
)
[C#]
public ReferenceEditor(
   IEditorSite site
);
[C++]
public: ReferenceEditor(
   IEditorSite* site
);
[JScript]
public function ReferenceEditor(
   site : IEditorSite
);

Parameters

site
[To be supplied.]

See Also

ReferenceEditor Class | ReferenceEditor Members | System.ComponentModel.Design Namespace | ReferenceEditor Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ReferenceEditor Properties

The properties of the ReferenceEditor class are listed below. For a complete list of ReferenceEditor class members, see the ReferenceEditor Members topic.

Public:

Style (inherited from ValueEditor) | [To be supplied.]
Values | Retrieves the components on the form that can be assigned to the type of the editor.

Protected:

Container | [To be supplied.]
ReferenceService | [To be supplied.]
Type | [To be supplied.]

See Also

ReferenceEditor Class | System.ComponentModel.Design Namespace


ReferenceEditor.Container

[To be supplied.]

[Visual Basic]
Protected ReadOnly Property Container As IContainer
[C#]
protected IContainer Container {get;}
[C++]
protected: __property IContainer* get_Container();
[JScript]
protected function get Container() : IContainer;

See Also

ReferenceEditor Class | ReferenceEditor Members | System.ComponentModel.Design Namespace


ReferenceEditor.ReferenceService

[To be supplied.]

[Visual Basic]
Protected ReadOnly Property ReferenceService As IReferenceService
[C#]
protected IReferenceService ReferenceService {get;}
[C++]
protected: __property IReferenceService* get_ReferenceService();
[JScript]
protected function get ReferenceService() : IReferenceService;

See Also

ReferenceEditor Class | ReferenceEditor Members | System.ComponentModel.Design Namespace


ReferenceEditor.Type

[To be supplied.]

[Visual Basic]
Protected Property Type As Type
[C#]
protected Type Type {get; set;}
[C++]
protected: __property Type* get_Type();
protected: __property void set_Type(Type*);
[JScript]
protected function get Type() : Type;
protected function set Type(Type);

See Also

ReferenceEditor Class | ReferenceEditor Members | System.ComponentModel.Design Namespace


ReferenceEditor.Values

Retrieves the components on the form that can be assigned to the type of the editor.

[Visual Basic]
Overridable Public ReadOnly Property Values As Object ()
[C#]
public object[] Values {override get;}
[C++]
public: __property virtual Object* get_Values();
[JScript]
public function get Values() : Object[];

Property Value

references list of components that can be assigned to the type of the editor.

See Also

ReferenceEditor Class | ReferenceEditor Members | System.ComponentModel.Design Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ReferenceEditor Fields

The fields of the ReferenceEditor class are listed below. For a complete list of ReferenceEditor class members, see the ReferenceEditor Members topic.

Protected:

none What we return textually for null.

See Also

ReferenceEditor Class | System.ComponentModel.Design Namespace


ReferenceEditor.none

What we return textually for null.

[Visual Basic]
Protected Shared ReadOnly none As String
[C#]
protected static readonly string none;
[C++]
protected: static readonly String* none;
[JScript]
protected static var none : String;

See Also

ReferenceEditor Class | ReferenceEditor Members | System.ComponentModel.Design Namespace


RefreshProperties Enumeration

Specifies values for use in refreshing the design time view.

[Visual Basic]
Public Enum RefreshProperties
[C#]
public enum RefreshProperties
[C++]
public enum RefreshProperties

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

These values are used to indicate the properties to use when refreshing the design time view.

Members

Member Name | Description
All | [To be supplied.]
None | [To be supplied.]
Repaint | [To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

System.ComponentModel.Design Namespace


RefreshPropertiesAttribute Class

Specifies how a forms designer refreshes when the property value is changed.

Object
Attribute
MemberAttribute
RefreshPropertiesAttribute

[Visual Basic]
Public Class RefreshPropertiesAttribute
   Inherits MemberAttribute
[C#]
public class RefreshPropertiesAttribute : MemberAttribute
[C++]
public __gc class RefreshPropertiesAttribute : public
   MemberAttribute
[JScript]
public class RefreshPropertiesAttribute extends MemberAttribute

Remarks

Specify this attribute on a property to cause all properties in the System.WinForms.PropertyGrid to be refreshed if the property value is changed.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

RefreshPropertiesAttribute Members | System.ComponentModel.Design Namespace | RefreshProperties


RefreshPropertiesAttribute Members

Public:

Properties

RefreshProperties | Gets or sets the refresh properties for the member.
TypeId (inherited from MemberAttribute) | Gets a unique ID for this MemberAttribute.

Methods

Equals | Overrides object's Equals method.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsDefaultAttribute | Gets whether the current attribute is the default.
Match (inherited from MemberAttribute) | Determines whether one attribute matches another.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

All | Indicates all properties should be refreshed if the property value is changed. This field is read-only.
Default | Indicates that by default no properties should be refreshed if the property value is changed. This field is read-only.
Repaint | Indicates all properties should be invalidated and repainted if the property value is changed. This field is read-only.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RefreshPropertiesAttribute Class | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RefreshPropertiesAttribute Properties

The properties of the RefreshPropertiesAttribute class are listed below. For a complete list of RefreshPropertiesAttribute class members, see the RefreshPropertiesAttribute Members topic.

Public:

RefreshProperties | Gets or sets the refresh properties for the member.
TypeId (inherited from MemberAttribute) | Gets a unique ID for this MemberAttribute.

See Also

RefreshPropertiesAttribute Class | System.ComponentModel.Design Namespace


RefreshPropertiesAttribute.RefreshProperties

Gets or sets the refresh properties for the member.

[Visual Basic]
Public ReadOnly Property RefreshProperties As RefreshProperties
[C#]
public RefreshProperties RefreshProperties {get;}
[C++]
public: __property RefreshProperties get_RefreshProperties();
[JScript]
public function get RefreshProperties() : RefreshProperties;

Property Value

A RefreshProperties that indicates the current refresh properties for the member.

See Also

RefreshPropertiesAttribute Class | RefreshPropertiesAttribute Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RefreshPropertiesAttribute Methods

The methods of the RefreshPropertiesAttribute class are listed below. For a complete list of RefreshPropertiesAttribute class members, see the RefreshPropertiesAttribute Members topic.

Public:

Equals | Overrides object's Equals method.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsDefaultAttribute | Gets whether the current attribute is the default.
Match (inherited from MemberAttribute) | Determines whether one attribute matches another.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RefreshPropertiesAttribute Class | System.ComponentModel.Design Namespace


RefreshPropertiesAttribute.Equals

Overrides object's Equals method.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal value As Object _
) As Boolean
[C#]
public override bool Equals(
   object value
);
[C++]
public: override bool Equals(
   Object* value
);
[JScript]
public override function Equals(
   value : Object
) : Boolean;

Parameters

value
The object to test for equality.

See Also

RefreshPropertiesAttribute Class | RefreshPropertiesAttribute Members | System.ComponentModel.Design Namespace


RefreshPropertiesAttribute.IsDefaultAttribute

Gets whether the current attribute is the default.

[Visual Basic]
Overrides Public Function IsDefaultAttribute() As Boolean
[C#]
public override bool IsDefaultAttribute();
[C++]
public: override bool IsDefaultAttribute();
[JScript]
public override function IsDefaultAttribute() : Boolean;

Return Value

true if the current attribute is the default attribute; otherwise, false.

See Also

RefreshPropertiesAttribute Class | RefreshPropertiesAttribute Members | System.ComponentModel.Design Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RefreshPropertiesAttribute Fields

The fields of the RefreshPropertiesAttribute class are listed below. For a complete list of RefreshPropertiesAttribute class members, see the RefreshPropertiesAttribute Members topic.

Public:

All | Indicates all properties should be refreshed if the property value is changed. This field is read-only.
Default | Indicates that by default no properties should be refreshed if the property value is changed. This field is read-only.
Repaint | Indicates all properties should be invalidated and repainted if the property value is changed. This field is read-only.

See Also

RefreshPropertiesAttribute Class | System.ComponentModel.Design Namespace


RefreshPropertiesAttribute.All

Indicates all properties should be refreshed if the property value is changed. This field is read-only.

[Visual Basic]
Public Shared ReadOnly All As RefreshPropertiesAttribute
[C#]
public static readonly RefreshPropertiesAttribute All;
[C++]
public: static readonly RefreshPropertiesAttribute* All;
[JScript]
public static var All : RefreshPropertiesAttribute;

Remarks

Specify this attribute on a property to cause all properties in the System.WinForms.PropertyGrid to be refreshed if the property value is changed.

See Also

RefreshPropertiesAttribute Class | RefreshPropertiesAttribute Members | System.ComponentModel.Design Namespace


RefreshPropertiesAttribute.Default

Indicates that by default no properties should be refreshed if the property value is changed. This field is read-only.

[Visual Basic]
Public Shared ReadOnly Default As RefreshPropertiesAttribute
[C#]
public static readonly RefreshPropertiesAttribute Default;
[C++]
public: static readonly RefreshPropertiesAttribute* Default;
[JScript]
public static var Default : RefreshPropertiesAttribute;

Remarks

Specify this attribute on a property to cause no refresh of other properties when the property is changed.

See Also

RefreshPropertiesAttribute Class | RefreshPropertiesAttribute Members | System.ComponentModel.Design Namespace | RefreshProperties


RefreshPropertiesAttribute.Repaint

Indicates all properties should be invalidated and repainted if the property value is changed. This field is read-only.

[Visual Basic]
Public Shared ReadOnly Repaint As RefreshPropertiesAttribute
[C#]
public static readonly RefreshPropertiesAttribute Repaint;
[C++]
public: static readonly RefreshPropertiesAttribute* Repaint;
[JScript]
public static var Repaint : RefreshPropertiesAttribute;

Remarks

Specify this attribute on a property to cause all properties in the System.WinForms.PropertyGrid to be invalidated and repainted when the property is changed.

See Also

RefreshPropertiesAttribute Class | RefreshPropertiesAttribute Members | System.ComponentModel.Design Namespace


ResourceValueProvider Class

ValueProvider for the ResourceManager

Object
ValueProvider
ResourceValueProvider

[Visual Basic]
NotInheritable Public Class ResourceValueProvider
   Inherits ValueProvider
[C#]
public sealed class ResourceValueProvider : ValueProvider
[C++]
public __gc __sealed class ResourceValueProvider : public
   ValueProvider
[JScript]
public class ResourceValueProvider extends ValueProvider

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

ResourceValueProvider Members | System.ComponentModel.Design Namespace


ResourceValueProvider Members

Public:

Constructor

ResourceValueProvider Constructor [To be supplied.]

Properties

ServiceProvider (inherited from ValueProvider) The service provider for this value provider. This is normally provided by the IValueProviderService.

Methods

AddResource | Creates a new expression that represents the provided name/value pair
BeginDepersist | Called by the code generator when before any statements in the code are parsed. This allows the provider to clear any previous state.
BeginPersist | Called by the code generator when before any statements in the code are generated. This allows the provider to clear any previous state.
CanProvideValue | Called for every expression found in the code. If the IValueProvider returns true, then the ProvideValue method will be called.
EndDepersist | Called by the code generator after all statements have been parsed.
EndPersist | Called by the code generator after all statements have been generated.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetExpressionLevel | Determines the level of support for generating an expression for the specified property on the specified object. If a value provider returns anything but ValueExpressionLevel.NotSupported then it must return a non-null value from ProvideExpression.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLocalVariableDeclaration | If this value provider requires that a local variable is declared then this must return a non-null ICodeStatement.
GetRequireComponents (inherited from ValueProvider) | Gets the components required to be initialized before the value provider can provide values.
GetType (inherited from Object) | Gets the Type of the Object.
IsLocalVariableDeclaration | Determines if the specified statement is the local variable declaration for this value provider.
ProvideExpression | Creates a new expression that represents the property value for the specified component.
ProvideValue | Retrieves the value that the code expression represents.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResourceValueProvider Class | System.ComponentModel.Design Namespace


ResourceValueProvider Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ResourceValueProvider();
[C++]
public: ResourceValueProvider();
[JScript]
public function ResourceValueProvider();

See Also

ResourceValueProvider Class | ResourceValueProvider Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ResourceValueProvider Methods

The methods of the ResourceValueProvider class are listed below. For a complete list of ResourceValueProvider class members, see the ResourceValueProvider Members topic.

Public:

AddResource | Creates a new expression that represents the provided name/value pair
BeginDepersist | Called by the code generator when before any statements in the code are parsed. This allows the provider to clear any previous state.
BeginPersist | Called by the code generator when before any statements in the code are generated. This allows the provider to clear any previous state.
CanProvideValue | Called for every expression found in the code. If the IValueProvider returns true, then the ProvideValue method will be called.
EndDepersist | Called by the code generator after all statements have been parsed.
EndPersist | Called by the code generator after all statements have been generated.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetExpressionLevel | Determines the level of support for generating an expression for the specified property on the specified object. If a value provider returns anything but ValueExpressionLevel.NotSupported then it must return a non-null value from ProvideExpression.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLocalVariableDeclaration | If this value provider requires that a local variable is declared then this must return a non-null ICodeStatement.
GetRequireComponents (inherited from ValueProvider) | Gets the components required to be initialized before the value provider can provide values.
GetType (inherited from Object) | Gets the Type of the Object.
IsLocalVariableDeclaration | Determines if the specified statement is the local variable declaration for this value provider.
ProvideExpression | Creates a new expression that represents the property value for the specified component.
ProvideValue | Retrieves the value that the code expression represents.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResourceValueProvider Class | System.ComponentModel.Design Namespace


ResourceValueProvider.AddResource

Creates a new expression that represents the provided name/value pair

[Visual Basic]
Public Sub AddResource( _
   ByVal name As String, _
   ByVal value As String _
)
[C#]
public void AddResource(
   string name,
   string value
);
[C++]
public: void AddResource(
   String* name,
   String* value
);
[JScript]
public function AddResource(
   name : String,
   value : String
);

Parameters

name
The name
value
The value

See Also

ResourceValueProvider Class | ResourceValueProvider Members | System.ComponentModel.Design Namespace


ResourceValueProvider.BeginDepersist

Called by the code generator when before any statements in the code are parsed. This allows the provider to clear any previous state.

[Visual Basic]
Overrides Public Sub BeginDepersist()
[C#]
public override void BeginDepersist();
[C++]
public: override void BeginDepersist();
[JScript]
public override function BeginDepersist();

See Also

ResourceValueProvider Class | ResourceValueProvider Members | System.ComponentModel.Design Namespace


ResourceValueProvider.BeginPersist

Called by the code generator when before any statements in the code are generated. This allows the provider to clear any previous state.

[Visual Basic]
Overrides Public Sub BeginPersist()
[C#]
public override void BeginPersist();
[C++]
public: override void BeginPersist();
[JScript]
public override function BeginPersist();

See Also

ResourceValueProvider Class | ResourceValueProvider Members | System.ComponentModel.Design Namespace


ResourceValueProvider.CanProvideValue

Called for every expression found in the code. If the IValueProvider returns true, then the ProvideValue method will be called.

[Visual Basic]
Overrides Public Function CanProvideValue( _
   ByVal component As Object, _
   ByVal propertyName As String, _
   ByVal exp As Object _
) As Boolean
[C#]
public override bool CanProvideValue(
   object component,
   string propertyName,
   object exp
);
[C++]
public: override bool CanProvideValue(
   Object* component,
   String* propertyName,
   Object* exp
);
[JScript]
public override function CanProvideValue(
   component : Object,
   propertyName : String,
   exp : Object
) : Boolean;

Parameters

component
The component whose property is being depersisted.
propertyName
The property that is being depersisted.
exp
The expression to determine if this value provider can provide a value for.

See Also

ResourceValueProvider Class | ResourceValueProvider Members | System.ComponentModel.Design Namespace


ResourceValueProvider.EndDepersist

Called by the code generator after all statements have been parsed.

[Visual Basic]
Overrides Public Sub EndDepersist()
[C#]
public override void EndDepersist();
[C++]
public: override void EndDepersist();
[JScript]
public override function EndDepersist();

See Also

ResourceValueProvider Class | ResourceValueProvider Members | System.ComponentModel.Design Namespace


ResourceValueProvider.EndPersist

Called by the code generator after all statements have been generated.

[Visual Basic]
Overrides Public Sub EndPersist()
[C#]
public override void EndPersist();
[C++]
public: override void EndPersist();
[JScript]
public override function EndPersist();

See Also

ResourceValueProvider Class | ResourceValueProvider Members | System.ComponentModel.Design Namespace


ResourceValueProvider.GetExpressionLevel

Determines the level of support for generating an expression for the specified property on the specified object. If a value provider returns anything but ValueExpressionLevel.NotSupported then it must return a non-null value from ProvideExpression.

[Visual Basic]
Overrides Public Function GetExpressionLevel( _
   ByVal component As Object, _
   ByVal property As PropertyDescriptor, _
   ByVal persistable As PersistableSupport _
) As ValueExpressionLevel
[C#]
public override ValueExpressionLevel GetExpressionLevel(
   object component,
   PropertyDescriptor property,
   PersistableSupport persistable
);
[C++]
public: override ValueExpressionLevel GetExpressionLevel(
   Object* component,
   PropertyDescriptor* property,
   PersistableSupport persistable
);
[JScript]
public override function GetExpressionLevel(
   component : Object,
   property : PropertyDescriptor,
   persistable : PersistableSupport
) : ValueExpressionLevel;

Parameters

component
The component whose property is being persisted.
property
PropertyDescriptor for the property that is being persisted.
persistable
[To be supplied.]

See Also

ResourceValueProvider Class | ResourceValueProvider Members | System.ComponentModel.Design Namespace


ResourceValueProvider.GetLocalVariableDeclaration

If this value provider requires that a local variable is declared then this must return a non-null ICodeStatement.

[Visual Basic]
Overrides Public Function GetLocalVariableDeclaration() As _
   ICodeStatement
[C#]
public override ICodeStatement GetLocalVariableDeclaration();
[C++]
public: override ICodeStatement* GetLocalVariableDeclaration();
[JScript]
public override function GetLocalVariableDeclaration() :
   ICodeStatement;

See Also

ResourceValueProvider Class | ResourceValueProvider Members | System.ComponentModel.Design Namespace


ResourceValueProvider.IsLocalVariableDeclaration

Determines if the specified statement is the local variable declaration for this value provider.

[Visual Basic]
Overrides Public Function IsLocalVariableDeclaration( _
   ByVal stmt As ICodeStatement _
) As Boolean
[C#]
public override bool IsLocalVariableDeclaration(
   ICodeStatement stmt
);
[C++]
public: override bool IsLocalVariableDeclaration(
   ICodeStatement* stmt
);
[JScript]
public override function IsLocalVariableDeclaration(
   stmt : ICodeStatement
) : Boolean;

Parameters

stmt
Statement to check.

See Also

ResourceValueProvider Class | ResourceValueProvider Members | System.ComponentModel.Design Namespace


ResourceValueProvider.ProvideExpression

Creates a new expression that represents the property value for the specified component.

[Visual Basic]
Overrides Public Function ProvideExpression( _
   ByVal component As Object, _
   ByVal propertyName As String, _
   ByVal value As Object _
) As Object
[C#]
public override object ProvideExpression(
   object component,
   string propertyName,
   object value
);
[C++]
public: override Object* ProvideExpression(
   Object* component,
   String* propertyName,
   Object* value
);
[JScript]
public override function ProvideExpression(
   component : Object,
   propertyName : String,
   value : Object
) : Object;

Parameters

component
The component whose property is being persisted.
propertyName
The property that is being persisted.
value
The value of the property that is being persisted.

See Also

ResourceValueProvider Class | ResourceValueProvider Members | System.ComponentModel.Design Namespace


ResourceValueProvider.ProvideValue

Retrieves the value that the code expression represents.

[Visual Basic]
Overrides Public Function ProvideValue( _
   ByVal component As Object, _
   ByVal propertyName As String, _
   ByVal exp As Object _
) As Object
[C#]
public override object ProvideValue(
   object component,
   string propertyName,
   object exp
);
[C++]
public: override Object* ProvideValue(
   Object* component,
   String* propertyName,
   Object* exp
);
[JScript]
public override function ProvideValue(
   component : Object,
   propertyName : String,
   exp : Object
) : Object;

Parameters

component
The component whose property is being depersisted.
propertyName
The property that is being depersisted.
exp
The expression for the property that is being depersisted.

See Also

ResourceValueProvider Class | ResourceValueProvider Members | System.ComponentModel.Design Namespace


SelectionRules Enumeration

Specifies a set of selection rule identifiers that can be used to indicate attributes for a selected component.

[Visual Basic]
Public Enum SelectionRules
[C#]
public enum SelectionRules
[C++]
public enum SelectionRules

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

The SelectionRules enum specifies identifiers which can be used to determine whether the selected component has some form of visible user interface and whether the user can take actions to move or alter the size of an object.

Members

Member Name | Description
AllSizeable | Indicates the given component supports sizing in all directions, and the selection service is not currently locked.
BottomSizeable | Indicates the given component supports resize from the bottom. This bit will be ignored unless the Sizeable bit is also set.
LeftSizeable | Indicates the given component supports resize from the left. This bit will be ignored unless the Sizeable bit is also set.
Locked | Indicates the given component is locked to its container. Overrides the moveable and sizeable properties of this enum.
Moveable | Indicates the given component supports a location property that allows it to be moved on the screen, and that the selection service is not currently locked.
None | Indicates no special selection attributes.
RightSizeable | Indicates the given component supports resize from the right. This bit will be ignored unless the Sizeable bit is also set.
TopSizeable | Indicates the given component supports resize from the top. This bit will be ignored unless the Sizeable bit is also set.
Visible | Indicates the given component has some form of visible user interface and the selection service is drawing a selection border around this user interface. If a selected component has this rule set, you can assume that the component implements IComponent and that it is associated with a corresponding design instance.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

System.ComponentModel.Design Namespace | SelectionTypes


SelectionStyles Enumeration

Specifies identifiers to use to indicate the style of the selection frame of a component.

[Visual Basic]
Public Enum SelectionStyles
[C#]
public enum SelectionStyles
[C++]
public enum SelectionStyles

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

When a component becomes selected, the selection border for the component defaults to Selected. The user can know what mode a component is in through the use of a different selection border. While a component can configure different selection border styles, changing a border style does not affect the behavior of the component in the designer. Developers must make use of the IDesigner interface to modify the component's behavior when running in a design environment.

Selection involves an action a user or interface takes to select an object. Once the object is selected, the user can specify an action for the object. System.ComponentModel.Design.SelectionStyleEnum allows you to specify the style of the selection frame that a component uses. This is useful if your component supports different modes of operation (such as an in-place editing mode and a static design mode). Where possible, leave the selection style as is and use the design-time hit testing feature of the IDesigner interface to provide features at design time. The value of style must be one of the SelectionStyles enum values.

Members

Member Name | Description
Active | An alternative selection border, indicating that a component is in active editing mode and that clicking and dragging on the component affects the component itself, not its position in the designer.
None | The component is not currently selected.
Selected | A component is selected and may be dragged around the designer freely (see SelectionRules). This is the default.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

System.ComponentModel.Design Namespace


SelectionTypes Enumeration

Specifies identifiers that indicate the type of selection for a component or group of components that are selected.

[Visual Basic]
Public Enum SelectionTypes
[C#]
public enum SelectionTypes
[C++]
public enum SelectionTypes

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

Selection of components involves an action a user or interface takes to select an object. Once the object is selected, the user can specify an action for the object. Use the members of this enumeration to determine how a user can select controls.

Members

Member Name | Description
Click | A Click selection. Happens when a user clicks on a component. If a component in the selection list is already selected, it does not remove the existing selection, but promotes that component to be the primary selection.
MouseDown | A MouseDown selection. Happens when the user presses down on the mouse button when the pointer is over a control (or component). If a component in the selection list is already selected, it does not remove the existing selection, but promotes that component to be the primary selection.
MouseUp | A MouseUp selection. Happens when the user releases the mouse button when a control (or component) has been selected. If a component in the selection list is already selected, it does not remove the existing selection, but promotes that component to be the primary selection.
Normal | A normal selection. With this type of selection, the selection service responds to the control and shift keys to support appending or toggling components into the selection as needed.
Replace | A replace selection. This causes the selection service to always replace the current selection with the replacement.
Valid | Limits valid selection types to Normal, Replace, MouseDown, MouseUp or Click.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

System.ComponentModel.Design Namespace | SelectionStyles


StandardCommands Class

This class contains the standard set of commands that are available to most applications.

Object
StandardCommands

[Visual Basic]
Public Class StandardCommands
[C#]
public class StandardCommands
[C++]
public __gc class StandardCommands
[JScript]
public class StandardCommands

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

Example [C#]

Question: I'm writing my own top-level designer, and I want to handle cut/copy/paste. How do I handle them?

Answer: Get IMenuCommandService and add a MenuCommand as follows:

[C#]

IMenuCommandService mcs = ...; mcs.AddCommand(new MenuCommand(StandardCommands.Copy, new EventHandler(this.OnMenuCopy));

See Also

StandardCommands Members | System.ComponentModel.Design Namespace | MenuCommand | CommandID


StandardCommands Members

Public:

Constructor

StandardCommands Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

AlignBottom | Gets the GUID/integer value pair for the AlignBottom command. Read only.
AlignHorizontalCenters | Gets the GUID/integer value pair for the AlignHorizontalCenters command. Read only.
AlignLeft | Gets the GUID/integer value pair for the AlignLeft command. Read only.
AlignRight | Gets the GUID/integer value pair for the AlignRight command. Read only.
AlignToGrid | Gets the GUID/integer value pair for the AlignToGrid command. Read only.
AlignTop | Gets the GUID/integer value pair for the AlignTop command. Read only.
AlignVerticalCenters | Gets the GUID/integer value pair for the AlignVerticalCenters command. Read only.
ArrangeBottom | Gets the GUID/integer value pair for the ArrangeBottom command. Read only.
ArrangeIcons | Gets the GUID/integer value pair for the ArrangeIcons command. Read only.
ArrangeRight | Gets the GUID/integer value pair for the ArrangeRight command. Read only.
BringForward | Gets the GUID/integer value pair for the BringForward command. Read only.
BringToFront | Gets the GUID/integer value pair for the BringToFront command. Read only.
CenterHorizontally | Gets the GUID/integer value pair for the CenterHorizontally command. Read only.
CenterVertically | Gets the GUID/integer value pair for the CenterVertically command. Read only.
cmdidArrangeIcons | [To be supplied.]
cmdidLineupIcons | [To be supplied.]
cmdidShowLargeIcons | [To be supplied.]
Copy | Gets the GUID/integer value pair for the Copy command. Read only.
Cut | Gets the GUID/integer value pair for the Cut command. Read only.
Delete | Gets the GUID/integer value pair for the Delete command. Read only.
F1Help | Gets the GUID/integer value pair for the F1Help command. Read only.
Group | Gets the GUID/integer value pair for the Group command. Read only.
HorizSpaceConcatenate | Gets the GUID/integer value pair for the HorizSpaceConcatenate command. Read only.
HorizSpaceDecrease | Gets the GUID/integer value pair for the HorizSpaceDecrease command. Read only.
HorizSpaceIncrease | Gets the GUID/integer value pair for the HorizSpaceIncrease command. Read only.
HorizSpaceMakeEqual | Gets the GUID/integer value pair for the HorizSpaceMakeEqual command. Read only.
LineupIcons | Gets the GUID/integer value pair for the LineupIcons command. Read only.
LockControls | Gets the GUID/integer value pair for the LockControls command. Read only.
MultiLevelRedo | Gets the GUID/integer value pair for the MultiLevelRedo command. Read only.
MultiLevelUndo | Gets the GUID/integer value pair for the MultiLevelUndo command. Read only.
Paste | Gets the GUID/integer value pair for the Paste command. Read only.
Properties | Gets the GUID/integer value pair for the Properties command. Read only.
PropertiesWindow | Gets the GUID/integer value pair for the PropertiesWindow command. Read only.
Redo | Gets the GUID/integer value pair for the Redo command. Read only.
Replace | Gets the GUID/integer value pair for the Replace command. Read only.
SelectAll | Gets the GUID/integer value pair for the SelectAll command. Read only.
SendBackward | Gets the GUID/integer value pair for the SendBackward command. Read only.
SendToBack | Gets the GUID/integer value pair for the SendToBack command. Read only.
ShowGrid | Gets the GUID/integer value pair for the ShowGrid command. Read only.
ShowLargeIcons | Gets the GUID/integer value pair for the ShowLargeIcons command. Read only.
SizeToControl | Gets the GUID/integer value pair for the SizeToControl command. Read only.
SizeToControlHeight | Gets the GUID/integer value pair for the SizeToControlHeight command. Read only.
SizeToControlWidth | Gets the GUID/integer value pair for the SizeToControlWidth command. Read only.
SizeToFit | Gets the GUID/integer value pair for the SizeToFit command. Read only.
SizeToGrid | Gets the GUID/integer value pair for the SizeToGrid command. Read only.
SnapToGrid | Gets the GUID/integer value pair for the SnapToGrid command. Read only.
TabOrder | Gets the GUID/integer value pair for the TabOrder command. Read only.
Undo | Gets the GUID/integer value pair for the Undo command. Read only.
Ungroup | Gets the GUID/integer value pair for the Ungroup command. Read only.
VerbFirst | Identifies the first of a set of verbs. Read only.
VerbLast | Identifies the last of a set of verbs. Read only.
VertSpaceConcatenate | Gets the GUID/integer value pair for the VertSpaceConcatenate command. Read only.
VertSpaceDecrease | Gets the GUID/integer value pair for the VertSpaceDecrease command. Read only.
VertSpaceIncrease | Gets the GUID/integer value pair for the VertSpaceIncrease command. Read only.
VertSpaceMakeEqual | Gets the GUID/integer value pair for the VertSpaceMakeEqual command. Read only.
ViewGrid | Gets the GUID/integer value pair for the ViewGrid command. Read only.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StandardCommands Class | System.ComponentModel.Design Namespace


StandardCommands Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public StandardCommands();
[C++]
public: StandardCommands();
[JScript]
public function StandardCommands();

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StandardCommands Fields

The fields of the StandardCommands class are listed below. For a complete list of StandardCommands class members, see the StandardCommands Members topic.

Public:

AlignBottom | Gets the GUID/integer value pair for the AlignBottom command. Read only.
AlignHorizontalCenters | Gets the GUID/integer value pair for the AlignHorizontalCenters command. Read only.
AlignLeft | Gets the GUID/integer value pair for the AlignLeft command. Read only.
AlignRight | Gets the GUID/integer value pair for the AlignRight command. Read only.
AlignToGrid | Gets the GUID/integer value pair for the AlignToGrid command. Read only.
AlignTop | Gets the GUID/integer value pair for the AlignTop command. Read only.
AlignVerticalCenters | Gets the GUID/integer value pair for the AlignVerticalCenters command. Read only.
ArrangeBottom | Gets the GUID/integer value pair for the ArrangeBottom command. Read only.
ArrangeIcons | Gets the GUID/integer value pair for the ArrangeIcons command. Read only.
ArrangeRight | Gets the GUID/integer value pair for the ArrangeRight command. Read only.
BringForward | Gets the GUID/integer value pair for the BringForward command. Read only.
BringToFront | Gets the GUID/integer value pair for the BringToFront command. Read only.
CenterHorizontally | Gets the GUID/integer value pair for the CenterHorizontally command. Read only.
CenterVertically | Gets the GUID/integer value pair for the CenterVertically command. Read only.
cmdidArrangeIcons | [To be supplied.]
cmdidLineupIcons | [To be supplied.]
cmdidShowLargeIcons | [To be supplied.]
Copy | Gets the GUID/integer value pair for the Copy command. Read only.
Cut | Gets the GUID/integer value pair for the Cut command. Read only.
Delete | Gets the GUID/integer value pair for the Delete command. Read only.
F1Help | Gets the GUID/integer value pair for the F1Help command. Read only.
Group | Gets the GUID/integer value pair for the Group command. Read only.
HorizSpaceConcatenate | Gets the GUID/integer value pair for the HorizSpaceConcatenate command. Read only.
HorizSpaceDecrease | Gets the GUID/integer value pair for the HorizSpaceDecrease command. Read only.
HorizSpaceIncrease | Gets the GUID/integer value pair for the HorizSpaceIncrease command. Read only.
HorizSpaceMakeEqual | Gets the GUID/integer value pair for the HorizSpaceMakeEqual command. Read only.
LineupIcons | Gets the GUID/integer value pair for the LineupIcons command. Read only.
LockControls | Gets the GUID/integer value pair for the LockControls command. Read only.
MultiLevelRedo | Gets the GUID/integer value pair for the MultiLevelRedo command. Read only.
MultiLevelUndo | Gets the GUID/integer value pair for the MultiLevelUndo command. Read only.
Paste | Gets the GUID/integer value pair for the Paste command. Read only.
Properties | Gets the GUID/integer value pair for the Properties command. Read only.
PropertiesWindow | Gets the GUID/integer value pair for the PropertiesWindow command. Read only.
Redo | Gets the GUID/integer value pair for the Redo command. Read only.
Replace | Gets the GUID/integer value pair for the Replace command. Read only.
SelectAll | Gets the GUID/integer value pair for the SelectAll command. Read only.
SendBackward | Gets the GUID/integer value pair for the SendBackward command. Read only.
SendToBack | Gets the GUID/integer value pair for the SendToBack command. Read only.
ShowGrid | Gets the GUID/integer value pair for the ShowGrid command. Read only.
ShowLargeIcons | Gets the GUID/integer value pair for the ShowLargeIcons command. Read only.
SizeToControl | Gets the GUID/integer value pair for the SizeToControl command. Read only.
SizeToControlHeight | Gets the GUID/integer value pair for the SizeToControlHeight command. Read only.
SizeToControlWidth | Gets the GUID/integer value pair for the SizeToControlWidth command. Read only.
SizeToFit | Gets the GUID/integer value pair for the SizeToFit command. Read only.
SizeToGrid | Gets the GUID/integer value pair for the SizeToGrid command. Read only.
SnapToGrid | Gets the GUID/integer value pair for the SnapToGrid command. Read only.
TabOrder | Gets the GUID/integer value pair for the TabOrder command. Read only.
Undo | Gets the GUID/integer value pair for the Undo command. Read only.
Ungroup | Gets the GUID/integer value pair for the Ungroup command. Read only.
VerbFirst | Identifies the first of a set of verbs. Read only.
VerbLast | Identifies the last of a set of verbs. Read only.
VertSpaceConcatenate | Gets the GUID/integer value pair for the VertSpaceConcatenate command. Read only.
VertSpaceDecrease | Gets the GUID/integer value pair for the VertSpaceDecrease command. Read only.
VertSpaceIncrease | Gets the GUID/integer value pair for the VertSpaceIncrease command. Read only.
VertSpaceMakeEqual | Gets the GUID/integer value pair for the VertSpaceMakeEqual command. Read only.
ViewGrid | Gets the GUID/integer value pair for the ViewGrid command. Read only.

See Also

StandardCommands Class | System.ComponentModel.Design Namespace


StandardCommands.AlignBottom

Gets the GUID/integer value pair for the AlignBottom command. Read only.

[Visual Basic]
Public Shared ReadOnly AlignBottom As CommandID
[C#]
public static readonly CommandID AlignBottom;
[C++]
public: static readonly CommandID* AlignBottom;
[JScript]
public static var AlignBottom : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.AlignHorizontalCenters

Gets the GUID/integer value pair for the AlignHorizontalCenters command. Read only.

[Visual Basic]
Public Shared ReadOnly AlignHorizontalCenters As CommandID
[C#]
public static readonly CommandID AlignHorizontalCenters;
[C++]
public: static readonly CommandID* AlignHorizontalCenters;
[JScript]
public static var AlignHorizontalCenters : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.AlignLeft

Gets the GUID/integer value pair for the AlignLeft command. Read only.

[Visual Basic]
Public Shared ReadOnly AlignLeft As CommandID
[C#]
public static readonly CommandID AlignLeft;
[C++]
public: static readonly CommandID* AlignLeft;
[JScript]
public static var AlignLeft : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.AlignRight

Gets the GUID/integer value pair for the AlignRight command. Read only.

[Visual Basic]
Public Shared ReadOnly AlignRight As CommandID
[C#]
public static readonly CommandID AlignRight;
[C++]
public: static readonly CommandID* AlignRight;
[JScript]
public static var AlignRight : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.AlignToGrid

Gets the GUID/integer value pair for the AlignToGrid command. Read only.

[Visual Basic]
Public Shared ReadOnly AlignToGrid As CommandID
[C#]
public static readonly CommandID AlignToGrid;
[C++]
public: static readonly CommandID* AlignToGrid;
[JScript]
public static var AlignToGrid : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.AlignTop

Gets the GUID/integer value pair for the AlignTop command. Read only.

[Visual Basic]
Public Shared ReadOnly AlignTop As CommandID
[C#]
public static readonly CommandID AlignTop;
[C++]
public: static readonly CommandID* AlignTop;
[JScript]
public static var AlignTop : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.AlignVerticalCenters

Gets the GUID/integer value pair for the AlignVerticalCenters command. Read only.

[Visual Basic]
Public Shared ReadOnly AlignVerticalCenters As CommandID
[C#]
public static readonly CommandID AlignVerticalCenters;
[C++]
public: static readonly CommandID* AlignVerticalCenters;
[JScript]
public static var AlignVerticalCenters : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.ArrangeBottom

Gets the GUID/integer value pair for the ArrangeBottom command. Read only.

[Visual Basic]
Public Shared ReadOnly ArrangeBottom As CommandID
[C#]
public static readonly CommandID ArrangeBottom;
[C++]
public: static readonly CommandID* ArrangeBottom;
[JScript]
public static var ArrangeBottom : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.ArrangeIcons

Gets the GUID/integer value pair for the ArrangeIcons command. Read only.

[Visual Basic]
Public Shared ReadOnly ArrangeIcons As CommandID
[C#]
public static readonly CommandID ArrangeIcons;
[C++]
public: static readonly CommandID* ArrangeIcons;
[JScript]
public static var ArrangeIcons : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.ArrangeRight

Gets the GUID/integer value pair for the ArrangeRight command. Read only.

[Visual Basic]
Public Shared ReadOnly ArrangeRight As CommandID
[C#]
public static readonly CommandID ArrangeRight;
[C++]
public: static readonly CommandID* ArrangeRight;
[JScript]
public static var ArrangeRight : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.BringForward

Gets the GUID/integer value pair for the BringForward command. Read only.

[Visual Basic]
Public Shared ReadOnly BringForward As CommandID
[C#]
public static readonly CommandID BringForward;
[C++]
public: static readonly CommandID* BringForward;
[JScript]
public static var BringForward : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.BringToFront

Gets the GUID/integer value pair for the BringToFront command. Read only.

[Visual Basic]
Public Shared ReadOnly BringToFront As CommandID
[C#]
public static readonly CommandID BringToFront;
[C++]
public: static readonly CommandID* BringToFront;
[JScript]
public static var BringToFront : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.CenterHorizontally

Gets the GUID/integer value pair for the CenterHorizontally command. Read only.

[Visual Basic]
Public Shared ReadOnly CenterHorizontally As CommandID
[C#]
public static readonly CommandID CenterHorizontally;
[C++]
public: static readonly CommandID* CenterHorizontally;
[JScript]
public static var CenterHorizontally : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.CenterVertically

Gets the GUID/integer value pair for the CenterVertically command. Read only.

[Visual Basic]
Public Shared ReadOnly CenterVertically As CommandID
[C#]
public static readonly CommandID CenterVertically;
[C++]
public: static readonly CommandID* CenterVertically;
[JScript]
public static var CenterVertically : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.cmdidArrangeIcons

[To be supplied.]

[Visual Basic]
Public Const cmdidArrangeIcons As Integer
[C#]
public const int cmdidArrangeIcons;
[C++]
public: const int cmdidArrangeIcons;
[JScript]
public var cmdidArrangeIcons : int;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.cmdidLineupIcons

[To be supplied.]

[Visual Basic]
Public Const cmdidLineupIcons As Integer
[C#]
public const int cmdidLineupIcons;
[C++]
public: const int cmdidLineupIcons;
[JScript]
public var cmdidLineupIcons : int;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.cmdidShowLargeIcons

[To be supplied.]

[Visual Basic]
Public Const cmdidShowLargeIcons As Integer
[C#]
public const int cmdidShowLargeIcons;
[C++]
public: const int cmdidShowLargeIcons;
[JScript]
public var cmdidShowLargeIcons : int;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.Copy

Gets the GUID/integer value pair for the Copy command. Read only.

[Visual Basic]
Public Shared ReadOnly Copy As CommandID
[C#]
public static readonly CommandID Copy;
[C++]
public: static readonly CommandID* Copy;
[JScript]
public static var Copy : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.Cut

Gets the GUID/integer value pair for the Cut command. Read only.

[Visual Basic]
Public Shared ReadOnly Cut As CommandID
[C#]
public static readonly CommandID Cut;
[C++]
public: static readonly CommandID* Cut;
[JScript]
public static var Cut : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.Delete

Gets the GUID/integer value pair for the Delete command. Read only.

[Visual Basic]
Public Shared ReadOnly Delete As CommandID
[C#]
public static readonly CommandID Delete;
[C++]
public: static readonly CommandID* Delete;
[JScript]
public static var Delete : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.F1Help

Gets the GUID/integer value pair for the F1Help command. Read only.

[Visual Basic]
Public Shared ReadOnly F1Help As CommandID
[C#]
public static readonly CommandID F1Help;
[C++]
public: static readonly CommandID* F1Help;
[JScript]
public static var F1Help : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.Group

Gets the GUID/integer value pair for the Group command. Read only.

[Visual Basic]
Public Shared ReadOnly Group As CommandID
[C#]
public static readonly CommandID Group;
[C++]
public: static readonly CommandID* Group;
[JScript]
public static var Group : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.HorizSpaceConcatenate

Gets the GUID/integer value pair for the HorizSpaceConcatenate command. Read only.

[Visual Basic]
Public Shared ReadOnly HorizSpaceConcatenate As CommandID
[C#]
public static readonly CommandID HorizSpaceConcatenate;
[C++]
public: static readonly CommandID* HorizSpaceConcatenate;
[JScript]
public static var HorizSpaceConcatenate : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.HorizSpaceDecrease

Gets the GUID/integer value pair for the HorizSpaceDecrease command. Read only.

[Visual Basic]
Public Shared ReadOnly HorizSpaceDecrease As CommandID
[C#]
public static readonly CommandID HorizSpaceDecrease;
[C++]
public: static readonly CommandID* HorizSpaceDecrease;
[JScript]
public static var HorizSpaceDecrease : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.HorizSpaceIncrease

Gets the GUID/integer value pair for the HorizSpaceIncrease command. Read only.

[Visual Basic]
Public Shared ReadOnly HorizSpaceIncrease As CommandID
[C#]
public static readonly CommandID HorizSpaceIncrease;
[C++]
public: static readonly CommandID* HorizSpaceIncrease;
[JScript]
public static var HorizSpaceIncrease : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.HorizSpaceMakeEqual

Gets the GUID/integer value pair for the HorizSpaceMakeEqual command. Read only.

[Visual Basic]
Public Shared ReadOnly HorizSpaceMakeEqual As CommandID
[C#]
public static readonly CommandID HorizSpaceMakeEqual;
[C++]
public: static readonly CommandID* HorizSpaceMakeEqual;
[JScript]
public static var HorizSpaceMakeEqual : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.LineupIcons

Gets the GUID/integer value pair for the LineupIcons command. Read only.

[Visual Basic]
Public Shared ReadOnly LineupIcons As CommandID
[C#]
public static readonly CommandID LineupIcons;
[C++]
public: static readonly CommandID* LineupIcons;
[JScript]
public static var LineupIcons : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.LockControls

Gets the GUID/integer value pair for the LockControls command. Read only.

[Visual Basic]
Public Shared ReadOnly LockControls As CommandID
[C#]
public static readonly CommandID LockControls;
[C++]
public: static readonly CommandID* LockControls;
[JScript]
public static var LockControls : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.MultiLevelRedo

Gets the GUID/integer value pair for the MultiLevelRedo command. Read only.

[Visual Basic]
Public Shared ReadOnly MultiLevelRedo As CommandID
[C#]
public static readonly CommandID MultiLevelRedo;
[C++]
public: static readonly CommandID* MultiLevelRedo;
[JScript]
public static var MultiLevelRedo : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.MultiLevelUndo

Gets the GUID/integer value pair for the MultiLevelUndo command. Read only.

[Visual Basic]
Public Shared ReadOnly MultiLevelUndo As CommandID
[C#]
public static readonly CommandID MultiLevelUndo;
[C++]
public: static readonly CommandID* MultiLevelUndo;
[JScript]
public static var MultiLevelUndo : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.Paste

Gets the GUID/integer value pair for the Paste command. Read only.

[Visual Basic]
Public Shared ReadOnly Paste As CommandID
[C#]
public static readonly CommandID Paste;
[C++]
public: static readonly CommandID* Paste;
[JScript]
public static var Paste : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.Properties

Gets the GUID/integer value pair for the Properties command. Read only.

[Visual Basic]
Public Shared ReadOnly Properties As CommandID
[C#]
public static readonly CommandID Properties;
[C++]
public: static readonly CommandID* Properties;
[JScript]
public static var Properties : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.PropertiesWindow

Gets the GUID/integer value pair for the PropertiesWindow command. Read only.

[Visual Basic]
Public Shared ReadOnly PropertiesWindow As CommandID
[C#]
public static readonly CommandID PropertiesWindow;
[C++]
public: static readonly CommandID* PropertiesWindow;
[JScript]
public static var PropertiesWindow : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.Redo

Gets the GUID/integer value pair for the Redo command. Read only.

[Visual Basic]
Public Shared ReadOnly Redo As CommandID
[C#]
public static readonly CommandID Redo;
[C++]
public: static readonly CommandID* Redo;
[JScript]
public static var Redo : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.Replace

Gets the GUID/integer value pair for the Replace command. Read only.

[Visual Basic]
Public Shared ReadOnly Replace As CommandID
[C#]
public static readonly CommandID Replace;
[C++]
public: static readonly CommandID* Replace;
[JScript]
public static var Replace : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.SelectAll

Gets the GUID/integer value pair for the SelectAll command. Read only.

[Visual Basic]
Public Shared ReadOnly SelectAll As CommandID
[C#]
public static readonly CommandID SelectAll;
[C++]
public: static readonly CommandID* SelectAll;
[JScript]
public static var SelectAll : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.SendBackward

Gets the GUID/integer value pair for the SendBackward command. Read only.

[Visual Basic]
Public Shared ReadOnly SendBackward As CommandID
[C#]
public static readonly CommandID SendBackward;
[C++]
public: static readonly CommandID* SendBackward;
[JScript]
public static var SendBackward : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.SendToBack

Gets the GUID/integer value pair for the SendToBack command. Read only.

[Visual Basic]
Public Shared ReadOnly SendToBack As CommandID
[C#]
public static readonly CommandID SendToBack;
[C++]
public: static readonly CommandID* SendToBack;
[JScript]
public static var SendToBack : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.ShowGrid

Gets the GUID/integer value pair for the ShowGrid command. Read only.

[Visual Basic]
Public Shared ReadOnly ShowGrid As CommandID
[C#]
public static readonly CommandID ShowGrid;
[C++]
public: static readonly CommandID* ShowGrid;
[JScript]
public static var ShowGrid : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.ShowLargeIcons

Gets the GUID/integer value pair for the ShowLargeIcons command. Read only.

[Visual Basic]
Public Shared ReadOnly ShowLargeIcons As CommandID
[C#]
public static readonly CommandID ShowLargeIcons;
[C++]
public: static readonly CommandID* ShowLargeIcons;
[JScript]
public static var ShowLargeIcons : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.SizeToControl

Gets the GUID/integer value pair for the SizeToControl command. Read only.

[Visual Basic]
Public Shared ReadOnly SizeToControl As CommandID
[C#]
public static readonly CommandID SizeToControl;
[C++]
public: static readonly CommandID* SizeToControl;
[JScript]
public static var SizeToControl : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.SizeToControlHeight

Gets the GUID/integer value pair for the SizeToControlHeight command. Read only.

[Visual Basic]
Public Shared ReadOnly SizeToControlHeight As CommandID
[C#]
public static readonly CommandID SizeToControlHeight;
[C++]
public: static readonly CommandID* SizeToControlHeight;
[JScript]
public static var SizeToControlHeight : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.SizeToControlWidth

Gets the GUID/integer value pair for the SizeToControlWidth command. Read only.

[Visual Basic]
Public Shared ReadOnly SizeToControlWidth As CommandID
[C#]
public static readonly CommandID SizeToControlWidth;
[C++]
public: static readonly CommandID* SizeToControlWidth;
[JScript]
public static var SizeToControlWidth : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.SizeToFit

Gets the GUID/integer value pair for the SizeToFit command. Read only.

[Visual Basic]
Public Shared ReadOnly SizeToFit As CommandID
[C#]
public static readonly CommandID SizeToFit;
[C++]
public: static readonly CommandID* SizeToFit;
[JScript]
public static var SizeToFit : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.SizeToGrid

Gets the GUID/integer value pair for the SizeToGrid command. Read only.

[Visual Basic]
Public Shared ReadOnly SizeToGrid As CommandID
[C#]
public static readonly CommandID SizeToGrid;
[C++]
public: static readonly CommandID* SizeToGrid;
[JScript]
public static var SizeToGrid : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.SnapToGrid

Gets the GUID/integer value pair for the SnapToGrid command. Read only.

[Visual Basic]
Public Shared ReadOnly SnapToGrid As CommandID
[C#]
public static readonly CommandID SnapToGrid;
[C++]
public: static readonly CommandID* SnapToGrid;
[JScript]
public static var SnapToGrid : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.TabOrder

Gets the GUID/integer value pair for the TabOrder command. Read only.

[Visual Basic]
Public Shared ReadOnly TabOrder As CommandID
[C#]
public static readonly CommandID TabOrder;
[C++]
public: static readonly CommandID* TabOrder;
[JScript]
public static var TabOrder : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.Undo

Gets the GUID/integer value pair for the Undo command. Read only.

[Visual Basic]
Public Shared ReadOnly Undo As CommandID
[C#]
public static readonly CommandID Undo;
[C++]
public: static readonly CommandID* Undo;
[JScript]
public static var Undo : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.Ungroup

Gets the GUID/integer value pair for the Ungroup command. Read only.

[Visual Basic]
Public Shared ReadOnly Ungroup As CommandID
[C#]
public static readonly CommandID Ungroup;
[C++]
public: static readonly CommandID* Ungroup;
[JScript]
public static var Ungroup : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.VerbFirst

Identifies the first of a set of verbs. Read only.

[Visual Basic]
Public Shared ReadOnly VerbFirst As CommandID
[C#]
public static readonly CommandID VerbFirst;
[C++]
public: static readonly CommandID* VerbFirst;
[JScript]
public static var VerbFirst : CommandID;

Remarks

This is a special command that identifies the first of a set of verbs. The Visual Studio form designer automatically maps verbs back to the Verbs property on IDesigner, so generally you do not need to access this command. All verbs for an object become commands that start with VerbFirst, up to a maximum of VerbLast.

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.VerbLast

Identifies the last of a set of verbs. Read only.

[Visual Basic]
Public Shared ReadOnly VerbLast As CommandID
[C#]
public static readonly CommandID VerbLast;
[C++]
public: static readonly CommandID* VerbLast;
[JScript]
public static var VerbLast : CommandID;

Remarks

This is a special command that identifies the last of a set of verbs. The Visual Studio form designer automatically maps verbs back to the Verbs property on IDesigner, so generally you do not need to access this command. All verbs for an object become commands that start with VerbFirst, up to a maximum of VerbLast.

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.VertSpaceConcatenate

Gets the GUID/integer value pair for the VertSpaceConcatenate command. Read only.

[Visual Basic]
Public Shared ReadOnly VertSpaceConcatenate As CommandID
[C#]
public static readonly CommandID VertSpaceConcatenate;
[C++]
public: static readonly CommandID* VertSpaceConcatenate;
[JScript]
public static var VertSpaceConcatenate : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.VertSpaceDecrease

Gets the GUID/integer value pair for the VertSpaceDecrease command. Read only.

[Visual Basic]
Public Shared ReadOnly VertSpaceDecrease As CommandID
[C#]
public static readonly CommandID VertSpaceDecrease;
[C++]
public: static readonly CommandID* VertSpaceDecrease;
[JScript]
public static var VertSpaceDecrease : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.VertSpaceIncrease

Gets the GUID/integer value pair for the VertSpaceIncrease command. Read only.

[Visual Basic]
Public Shared ReadOnly VertSpaceIncrease As CommandID
[C#]
public static readonly CommandID VertSpaceIncrease;
[C++]
public: static readonly CommandID* VertSpaceIncrease;
[JScript]
public static var VertSpaceIncrease : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.VertSpaceMakeEqual

Gets the GUID/integer value pair for the VertSpaceMakeEqual command. Read only.

[Visual Basic]
Public Shared ReadOnly VertSpaceMakeEqual As CommandID
[C#]
public static readonly CommandID VertSpaceMakeEqual;
[C++]
public: static readonly CommandID* VertSpaceMakeEqual;
[JScript]
public static var VertSpaceMakeEqual : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardCommands.ViewGrid

Gets the GUID/integer value pair for the ViewGrid command. Read only.

[Visual Basic]
Public Shared ReadOnly ViewGrid As CommandID
[C#]
public static readonly CommandID ViewGrid;
[C++]
public: static readonly CommandID* ViewGrid;
[JScript]
public static var ViewGrid : CommandID;

See Also

StandardCommands Class | StandardCommands Members | System.ComponentModel.Design Namespace


StandardToolWindows Class

This class defines GUIDs that reference the standard set of tool windows that are available in the design environment.

Object
StandardToolWindows

[Visual Basic]
Public Class StandardToolWindows
[C#]
public class StandardToolWindows
[C++]
public __gc class StandardToolWindows
[JScript]
public class StandardToolWindows

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

StandardToolWindows Members | System.ComponentModel.Design Namespace


StandardToolWindows Members

Public:

Constructor

StandardToolWindows Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

ObjectBrowser | The GUID for the object browser.
OutputWindow | The GUID for the output window.
ProjectExplorer | The GUID for the project explorer.
PropertyBrowser | The GUID for the property browser.
RelatedLinks | The GUID for the related links frame.
ServerExplorer | The GUID for the server explorer.
TaskList | The GUID for the task list.
Toolbox | The GUID for the toolbox.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StandardToolWindows Class | System.ComponentModel.Design Namespace


StandardToolWindows Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public StandardToolWindows();
[C++]
public: StandardToolWindows();
[JScript]
public function StandardToolWindows();

See Also

StandardToolWindows Class | StandardToolWindows Members | System.ComponentModel.Design Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StandardToolWindows Fields

The fields of the StandardToolWindows class are listed below. For a complete list of StandardToolWindows class members, see the StandardToolWindows Members topic.

Public:

ObjectBrowser | The GUID for the object browser.
OutputWindow | The GUID for the output window.
ProjectExplorer | The GUID for the project explorer.
PropertyBrowser | The GUID for the property browser.
RelatedLinks | The GUID for the related links frame.
ServerExplorer | The GUID for the server explorer.
TaskList | The GUID for the task list.
Toolbox | The GUID for the toolbox.

See Also

StandardToolWindows Class | System.ComponentModel.Design Namespace


StandardToolWindows.ObjectBrowser

The GUID for the object browser.

[Visual Basic]
Public Shared ReadOnly ObjectBrowser As Guid
[C#]
public static readonly Guid ObjectBrowser;
[C++]
public: static readonly Guid ObjectBrowser;
[JScript]
public static var ObjectBrowser : Guid;

See Also

StandardToolWindows Class | StandardToolWindows Members | System.ComponentModel.Design Namespace


StandardToolWindows.OutputWindow

The GUID for the output window.

[Visual Basic]
Public Shared ReadOnly OutputWindow As Guid
[C#]
public static readonly Guid OutputWindow;
[C++]
public: static readonly Guid OutputWindow;
[JScript]
public static var OutputWindow : Guid;

See Also

StandardToolWindows Class | StandardToolWindows Members | System.ComponentModel.Design Namespace


StandardToolWindows.ProjectExplorer

The GUID for the project explorer.

[Visual Basic]
Public Shared ReadOnly ProjectExplorer As Guid
[C#]
public static readonly Guid ProjectExplorer;
[C++]
public: static readonly Guid ProjectExplorer;
[JScript]
public static var ProjectExplorer : Guid;

See Also

StandardToolWindows Class | StandardToolWindows Members | System.ComponentModel.Design Namespace


StandardToolWindows.PropertyBrowser

The GUID for the property browser.

[Visual Basic]
Public Shared ReadOnly PropertyBrowser As Guid
[C#]
public static readonly Guid PropertyBrowser;
[C++]
public: static readonly Guid PropertyBrowser;
[JScript]
public static var PropertyBrowser : Guid;

See Also

StandardToolWindows Class | StandardToolWindows Members | System.ComponentModel.Design Namespace


StandardToolWindows.RelatedLinks

The GUID for the related links frame.

[Visual Basic]
Public Shared ReadOnly RelatedLinks As Guid
[C#]
public static readonly Guid RelatedLinks;
[C++]
public: static readonly Guid RelatedLinks;
[JScript]
public static var RelatedLinks : Guid;

See Also

StandardToolWindows Class | StandardToolWindows Members | System.ComponentModel.Design Namespace


StandardToolWindows.ServerExplorer

The GUID for the server explorer.

[Visual Basic]
Public Shared ReadOnly ServerExplorer As Guid
[C#]
public static readonly Guid ServerExplorer;
[C++]
public: static readonly Guid ServerExplorer;
[JScript]
public static var ServerExplorer : Guid;

See Also

StandardToolWindows Class | StandardToolWindows Members | System.ComponentModel.Design Namespace


StandardToolWindows.TaskList

The GUID for the task list.

[Visual Basic]
Public Shared ReadOnly TaskList As Guid
[C#]
public static readonly Guid TaskList;
[C++]
public: static readonly Guid TaskList;
[JScript]
public static var TaskList : Guid;

See Also

StandardToolWindows Class | StandardToolWindows Members | System.ComponentModel.Design Namespace


StandardToolWindows.Toolbox

The GUID for the toolbox.

[Visual Basic]
Public Shared ReadOnly Toolbox As Guid
[C#]
public static readonly Guid Toolbox;
[C++]
public: static readonly Guid Toolbox;
[JScript]
public static var Toolbox : Guid;

See Also

StandardToolWindows Class | StandardToolWindows Members | System.ComponentModel.Design Namespace


StringEditor Class

[To be supplied.]

Object
ValueEditor
StringEditor

[Visual Basic]
Public Class StringEditor
   Inherits ValueEditor
[C#]
public class StringEditor : ValueEditor
[C++]
public __gc class StringEditor : public ValueEditor
[JScript]
public class StringEditor extends ValueEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

StringEditor Members | System.ComponentModel.Design Namespace


StringEditor Members

Public:

Constructor

StringEditor Constructor [To be supplied.]

Properties

Style (inherited from ValueEditor) | [To be supplied.]
Values (inherited from ValueEditor) | [To be supplied.]

Methods

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from ValueEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue (inherited from ValueEditor) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from ValueEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StringEditor Class | System.ComponentModel.Design Namespace


StringEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public StringEditor();
[C++]
public: StringEditor();
[JScript]
public function StringEditor();

See Also

StringEditor Class | StringEditor Members | System.ComponentModel.Design Namespace


StringListEditor Class

StringListEditor supports design time editing of an array of Strings using the StringListDialog.

Object
ValueEditor
StringListEditor

[Visual Basic]
Public Class StringListEditor
   Inherits ValueEditor
[C#]
public class StringListEditor : ValueEditor
[C++]
public __gc class StringListEditor : public ValueEditor
[JScript]
public class StringListEditor extends ValueEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

StringListEditor Members | System.ComponentModel.Design Namespace | ValueEditor | StringListEditor.StringListDialog


StringListEditor Members

Public:

Constructor

StringListEditor Constructor [To be supplied.]

Properties

Style (inherited from ValueEditor) | [To be supplied.]
Values (inherited from ValueEditor) | [To be supplied.]

Methods

EditValue | Launches StringListDialog.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from ValueEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue (inherited from ValueEditor) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from ValueEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StringListEditor Class | System.ComponentModel.Design Namespace


StringListEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public StringListEditor();
[C++]
public: StringListEditor();
[JScript]
public function StringListEditor();

See Also

StringListEditor Class | StringListEditor Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StringListEditor Methods

The methods of the StringListEditor class are listed below. For a complete list of StringListEditor class members, see the StringListEditor Members topic.

Public:

EditValue | Launches StringListDialog.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from ValueEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue (inherited from ValueEditor) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from ValueEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StringListEditor Class | System.ComponentModel.Design Namespace


StringListEditor.EditValue

Launches StringListDialog.

[Visual Basic]
Overrides Public Sub EditValue( _
   ByVal iva As IValueAccess _
)
[C#]
public override void EditValue(
   IValueAccess iva
);
[C++]
public: override void EditValue(
   IValueAccess* iva
);
[JScript]
public override function EditValue(
   iva : IValueAccess
);

Parameters

iva
object editor gets/sets the array of strings from.

See Also

StringListEditor Class | StringListEditor Members | System.ComponentModel.Design Namespace


TestCommand Delegate

[To be supplied.]

[Visual Basic]
Public Delegate Sub TestCommand( _
   ByVal argv() As String _
)
[C#]
public delegate void TestCommand(
   string[] argv
);
[C++]
public __gc __delegate void TestCommand(
   String* argv[]
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the TestCommand delegate declaration.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

System.ComponentModel.Design Namespace


TimeSpanEditor Class

[To be supplied.]

Object
ValueEditor
TimeSpanEditor

[Visual Basic]
Public Class TimeSpanEditor
   Inherits ValueEditor
[C#]
public class TimeSpanEditor : ValueEditor
[C++]
public __gc class TimeSpanEditor : public ValueEditor
[JScript]
public class TimeSpanEditor extends ValueEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

TimeSpanEditor Members | System.ComponentModel.Design Namespace


TimeSpanEditor Members

Public:

Constructor

TimeSpanEditor Constructor [To be supplied.]

Properties

Style (inherited from ValueEditor) | [To be supplied.]
Values (inherited from ValueEditor) | [To be supplied.]

Methods

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle | Retrieves the CreationBundle for the given value. null will be returned if the value cannot be created from either a static method or constructor call.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue (inherited from ValueEditor) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from ValueEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimeSpanEditor Class | System.ComponentModel.Design Namespace


TimeSpanEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public TimeSpanEditor();
[C++]
public: TimeSpanEditor();
[JScript]
public function TimeSpanEditor();

See Also

TimeSpanEditor Class | TimeSpanEditor Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TimeSpanEditor Methods

The methods of the TimeSpanEditor class are listed below. For a complete list of TimeSpanEditor class members, see the TimeSpanEditor Members topic.

Public:

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle | Retrieves the CreationBundle for the given value. null will be returned if the value cannot be created from either a static method or constructor call.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue (inherited from ValueEditor) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from ValueEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimeSpanEditor Class | System.ComponentModel.Design Namespace


TimeSpanEditor.GetCreationBundle

Retrieves the CreationBundle for the given value. null will be returned if the value cannot be created from either a static method or constructor call.

[Visual Basic]
Overrides Public Function GetCreationBundle( _
   ByVal value As Object _
) As CreationBundle
[C#]
public override CreationBundle GetCreationBundle(
   object value
);
[C++]
public: override CreationBundle* GetCreationBundle(
   Object* value
);
[JScript]
public override function GetCreationBundle(
   value : Object
) : CreationBundle;

Parameters

value
[To be supplied.]

See Also

TimeSpanEditor Class | TimeSpanEditor Members | System.ComponentModel.Design Namespace


ToolboxComponentsCreatedEvent Class

Provides data for the ToolboxComponentsCreatedEventHandler that handles the event that occurs when components are added to the toolbox.

Object
EventArgs
ToolboxComponentsCreatedEvent

[Visual Basic]
Public Class ToolboxComponentsCreatedEvent
   Inherits EventArgs
[C#]
public class ToolboxComponentsCreatedEvent : EventArgs
[C++]
public __gc class ToolboxComponentsCreatedEvent : public EventArgs
[JScript]
public class ToolboxComponentsCreatedEvent extends EventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

ToolboxComponentsCreatedEvent Members | System.ComponentModel.Design Namespace | ToolboxComponentsCreatedEventHandler


ToolboxComponentsCreatedEvent Members

Public:

Constructor

ToolboxComponentsCreatedEvent Constructor Initializes a new instance of the ToolboxComponentsCreatedEvent object.

Properties

Components | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ToolboxComponentsCreatedEvent Class | System.ComponentModel.Design Namespace


ToolboxComponentsCreatedEvent Constructor

Initializes a new instance of the ToolboxComponentsCreatedEvent object.

[Visual Basic]
Public Sub New( _
   ByVal components() As IComponent _
)
[C#]
public ToolboxComponentsCreatedEvent(
   IComponent[] components
);
[C++]
public: ToolboxComponentsCreatedEvent(
   IComponent* components[]
);
[JScript]
public function ToolboxComponentsCreatedEvent(
   components : IComponent[]
);

Parameters

components
The components being included in the toolbox.

See Also

ToolboxComponentsCreatedEvent Class | ToolboxComponentsCreatedEvent Members | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ToolboxComponentsCreatedEvent Properties

The properties of the ToolboxComponentsCreatedEvent class are listed below. For a complete list of ToolboxComponentsCreatedEvent class members, see the ToolboxComponentsCreatedEvent Members topic.

Public:

Components | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.

See Also

ToolboxComponentsCreatedEvent Class | System.ComponentModel.Design Namespace


ToolboxComponentsCreatedEvent.Components

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Components As IComponent ()
[C#]
public IComponent[] Components {get;}
[C++]
public: __property IComponent* get_Components();
[JScript]
public function get Components() : IComponent[];

See Also

ToolboxComponentsCreatedEvent Class | ToolboxComponentsCreatedEvent Members | System.ComponentModel.Design Namespace


ToolboxComponentsCreatedEventHandler Delegate

Represents the method that will handle the System.ComponentModel.Design.ToolboxComponentsCreatedEvent.ToolboxComponentsCreatedEvent event.

[Visual Basic]
Public Delegate Sub ToolboxComponentsCreatedEventHandler( _
   ByVal sender As Object, _
   ByVal e As ToolboxComponentsCreatedEvent _
)
[C#]
public delegate void ToolboxComponentsCreatedEventHandler(
   object sender,
   ToolboxComponentsCreatedEvent e
);
[C++]
public __gc __delegate void ToolboxComponentsCreatedEventHandler(
   Object* sender,
   ToolboxComponentsCreatedEvent* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the ToolboxComponentsCreatedEventHandler delegate declaration.

sender
The source of the event.
e
A ToolboxComponentsCreatedEvent that provides data for the event.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

System.ComponentModel.Design Namespace | ToolboxComponentsCreatedEvent


ToolboxItemAttribute Class

Specifies attributes for a toolbox item.

Object
Attribute
MemberAttribute
ToolboxItemAttribute

[Visual Basic]
Public Class ToolboxItemAttribute
   Inherits MemberAttribute
[C#]
public class ToolboxItemAttribute : MemberAttribute
[C++]
public __gc class ToolboxItemAttribute : public MemberAttribute
[JScript]
public class ToolboxItemAttribute extends MemberAttribute

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

ToolboxItemAttribute Members | System.ComponentModel.Design Namespace


ToolboxItemAttribute Members

Public:

Constructor

ToolboxItemAttribute Constructor Overloaded. Initializes a new instance of ToolboxItemAttribute and specifies the name of the type.

Properties

ToolboxItemType | Gets or sets the toolbox item's type.
TypeId (inherited from MemberAttribute) | Gets a unique ID for this MemberAttribute.

Methods

Equals (inherited from MemberAttribute) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsDefaultAttribute | Gets whether the attribute is the default attribute.
Match (inherited from MemberAttribute) | Determines whether one attribute matches another.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Default Initializes a new instance of ToolboxItemAttribute and sets the type to a null reference (in Visual Basic Nothing).

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ToolboxItemAttribute Class | System.ComponentModel.Design Namespace


ToolboxItemAttribute Constructor

Initializes a new instance of ToolboxItemAttribute and specifies the name of the type.

Overload List

Initializes a new instance of ToolboxItemAttribute and specifies the name of the type.

[Visual Basic] Overloads Public Sub New(String)
[C#] public ToolboxItemAttribute(String);
[C++] public: ToolboxItemAttribute(String*);
[JScript] public function ToolboxItemAttribute(String);

Initializes a new instance of ToolboxItemAttribute and specifies the type of the toolbox item.

[Visual Basic] Overloads Public Sub New(Type)
[C#] public ToolboxItemAttribute(Type);
[C++] public: ToolboxItemAttribute(Type*);
[JScript] public function ToolboxItemAttribute(Type);

See Also

ToolboxItemAttribute Class | ToolboxItemAttribute Members | System.ComponentModel.Design Namespace


ToolboxItemAttribute Constructor (String)

Initializes a new instance of ToolboxItemAttribute and specifies the name of the type.

[Visual Basic]
Overloads Public Sub New( _
   ByVal toolboxItemTypeName As String _
)
[C#]
public ToolboxItemAttribute(
   string toolboxItemTypeName
);
[C++]
public: ToolboxItemAttribute(
   String* toolboxItemTypeName
);
[JScript]
public function ToolboxItemAttribute(
   toolboxItemTypeName : String
);

Parameters

toolboxItemTypeName
The name of the type of the toolbox item.

See Also

ToolboxItemAttribute Class | ToolboxItemAttribute Members | System.ComponentModel.Design Namespace | ToolboxItemAttribute Constructor Overload List


ToolboxItemAttribute Constructor (Type)

Initializes a new instance of ToolboxItemAttribute and specifies the type of the toolbox item.

[Visual Basic]
Overloads Public Sub New( _
   ByVal toolboxItemType As Type _
)
[C#]
public ToolboxItemAttribute(
   Type toolboxItemType
);
[C++]
public: ToolboxItemAttribute(
   Type* toolboxItemType
);
[JScript]
public function ToolboxItemAttribute(
   toolboxItemType : Type
);

Parameters

toolboxItemType
The type of the toolbox item.

See Also

ToolboxItemAttribute Class | ToolboxItemAttribute Members | System.ComponentModel.Design Namespace | ToolboxItemAttribute Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ToolboxItemAttribute Properties

The properties of the ToolboxItemAttribute class are listed below. For a complete list of ToolboxItemAttribute class members, see the ToolboxItemAttribute Members topic.

Public:

ToolboxItemType | Gets or sets the toolbox item's type.
TypeId (inherited from MemberAttribute) | Gets a unique ID for this MemberAttribute.

See Also

ToolboxItemAttribute Class | System.ComponentModel.Design Namespace


ToolboxItemAttribute.ToolboxItemType

Gets or sets the toolbox item's type.

[Visual Basic]
Public ReadOnly Property ToolboxItemType As Type
[C#]
public Type ToolboxItemType {get;}
[C++]
public: __property Type* get_ToolboxItemType();
[JScript]
public function get ToolboxItemType() : Type;

Property Value

The type identifier for the toolbox item's type.

See Also

ToolboxItemAttribute Class | ToolboxItemAttribute Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ToolboxItemAttribute Methods

The methods of the ToolboxItemAttribute class are listed below. For a complete list of ToolboxItemAttribute class members, see the ToolboxItemAttribute Members topic.

Public:

Equals (inherited from MemberAttribute) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsDefaultAttribute | Gets whether the attribute is the default attribute.
Match (inherited from MemberAttribute) | Determines whether one attribute matches another.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ToolboxItemAttribute Class | System.ComponentModel.Design Namespace


ToolboxItemAttribute.IsDefaultAttribute

Gets whether the attribute is the default attribute.

[Visual Basic]
Overrides Public Function IsDefaultAttribute() As Boolean
[C#]
public override bool IsDefaultAttribute();
[C++]
public: override bool IsDefaultAttribute();
[JScript]
public override function IsDefaultAttribute() : Boolean;

Return Value

true if the current attribute is the default attribute; otherwise, false.

See Also

ToolboxItemAttribute Class | ToolboxItemAttribute Members | System.ComponentModel.Design Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ToolboxItemAttribute Fields

The fields of the ToolboxItemAttribute class are listed below. For a complete list of ToolboxItemAttribute class members, see the ToolboxItemAttribute Members topic.

Public:

Default Initializes a new instance of ToolboxItemAttribute and sets the type to a null reference (in Visual Basic Nothing).

See Also

ToolboxItemAttribute Class | System.ComponentModel.Design Namespace


ToolboxItemAttribute.Default

Initializes a new instance of ToolboxItemAttribute and sets the type to a null reference (in Visual Basic Nothing).

[Visual Basic]
Public Shared Default As ToolboxItemAttribute
[C#]
public static ToolboxItemAttribute Default;
[C++]
public: static ToolboxItemAttribute* Default;
[JScript]
public static var Default : ToolboxItemAttribute;

See Also

ToolboxItemAttribute Class | ToolboxItemAttribute Members | System.ComponentModel.Design Namespace


TypeChangedEventArgs Class

Provides data for the System.ComponentModel.Design.TypeChangedEvent that occurs when the source code for a specified type has been modified.

Object
EventArgs
TypeChangedEventArgs

[Visual Basic]
Public Class TypeChangedEventArgs
   Inherits EventArgs
[C#]
public class TypeChangedEventArgs : EventArgs
[C++]
public __gc class TypeChangedEventArgs : public EventArgs
[JScript]
public class TypeChangedEventArgs extends EventArgs

Remarks

A type changed event will be raised when the source code for a specific type has been modified. Only code that is part of the current development project can cause this.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

TypeChangedEventArgs Members | System.ComponentModel.Design Namespace | TypeChangedEventHandler


TypeChangedEventArgs Members

Public:

Constructor

TypeChangedEventArgs Constructor Initializes a new instance of TypeChangedEventArgs.

Properties

ChangedType | The type of the changed type.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeChangedEventArgs Class | System.ComponentModel.Design Namespace


TypeChangedEventArgs Constructor

Initializes a new instance of TypeChangedEventArgs.

[Visual Basic]
Public Sub New( _
   ByVal type As Type _
)
[C#]
public TypeChangedEventArgs(
   Type type
);
[C++]
public: TypeChangedEventArgs(
   Type* type
);
[JScript]
public function TypeChangedEventArgs(
   type : Type
);

Parameters

type
The type that has changed.

Remarks

A type invalidate event will be raised when the code in an assembly has changed. All types that are being referenced within that assembly will be considered invalid.

See Also

TypeChangedEventArgs Class | TypeChangedEventArgs Members | System.ComponentModel.Design Namespace | TypeChangedEventHandler


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypeChangedEventArgs Properties

The properties of the TypeChangedEventArgs class are listed below. For a complete list of TypeChangedEventArgs class members, see the TypeChangedEventArgs Members topic.

Public:

ChangedType | The type of the changed type.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.

See Also

TypeChangedEventArgs Class | System.ComponentModel.Design Namespace


TypeChangedEventArgs.ChangedType

The type of the changed type.

[Visual Basic]
Public ReadOnly Property ChangedType As Type
[C#]
public Type ChangedType {get;}
[C++]
public: __property Type* get_ChangedType();
[JScript]
public function get ChangedType() : Type;

Property Value

The type of the changed type.

Remarks

A type invalidate event will be raised when the code in an assembly has changed. All types that are being referenced within that assembly will be considered invalid.

See Also

TypeChangedEventArgs Class | TypeChangedEventArgs Members | System.ComponentModel.Design Namespace | System.ComponentModel.Design.TypeInvalidateEventHandler


TypeChangedEventHandler Delegate

Represents the method that handles the event raised when a System.ComponentModel.Design.TypeChangedEvent.TypeChangedEvent occurs.

[Visual Basic]
Public Delegate Sub TypeChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As TypeChangedEventArgs _
)
[C#]
public delegate void TypeChangedEventHandler(
   object sender,
   TypeChangedEventArgs e
);
[C++]
public __gc __delegate void TypeChangedEventHandler(
   Object* sender,
   TypeChangedEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the TypeChangedEventHandler delegate declaration.

sender
The source of the event.
e
A System.ComponentModel.Design.TypeChangedEvent.TypeChangedEvent that contains the event data.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

System.ComponentModel.Design Namespace | System.ComponentModel.Design.TypeChangedEvent


UIActivationStateEventArgs Class

Provides data for the System.ComponentModel.Design.UIActivationStateEvent event.

Object
EventArgs
UIActivationStateEventArgs

[Visual Basic]
Public Class UIActivationStateEventArgs
   Inherits EventArgs
[C#]
public class UIActivationStateEventArgs : EventArgs
[C++]
public __gc class UIActivationStateEventArgs : public EventArgs
[JScript]
public class UIActivationStateEventArgs extends EventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

UIActivationStateEventArgs Members | System.ComponentModel.Design Namespace | UIActivationStateEventHandler


UIActivationStateEventArgs Members

Public:

Constructor

UIActivationStateEventArgs Constructor Initializes a new instance of UIActivationStateEventArgs.

Properties

Component | The component whose UI activation state is changing.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UIActivationStateEventArgs Class | System.ComponentModel.Design Namespace


UIActivationStateEventArgs Constructor

Initializes a new instance of UIActivationStateEventArgs.

[Visual Basic]
Public Sub New( _
   ByVal component As Object _
)
[C#]
public UIActivationStateEventArgs(
   object component
);
[C++]
public: UIActivationStateEventArgs(
   Object* component
);
[JScript]
public function UIActivationStateEventArgs(
   component : Object
);

Parameters

component
The component that is going UI active or inactive.

See Also

UIActivationStateEventArgs Class | UIActivationStateEventArgs Members | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UIActivationStateEventArgs Properties

The properties of the UIActivationStateEventArgs class are listed below. For a complete list of UIActivationStateEventArgs class members, see the UIActivationStateEventArgs Members topic.

Public:

Component | The component whose UI activation state is changing.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.

See Also

UIActivationStateEventArgs Class | System.ComponentModel.Design Namespace


UIActivationStateEventArgs.Component

The component whose UI activation state is changing.

[Visual Basic]
Public ReadOnly Property Component As Object
[C#]
public object Component {get;}
[C++]
public: __property Object* get_Component();
[JScript]
public function get Component() : Object;

Property Value

The component whose UI activation state is changing.

See Also

UIActivationStateEventArgs Class | UIActivationStateEventArgs Members | System.ComponentModel.Design Namespace


UIActivationStateEventHandler Delegate

Represents the method that will handle the event raised when a System.ComponentModel.Design.UIActiavationStateEvent.UIActivationStateEvent occurs.

[Visual Basic]
Public Delegate Sub UIActivationStateEventHandler( _
   ByVal sender As Object, _
   ByVal e As UIActivationStateEventArgs _
)
[C#]
public delegate void UIActivationStateEventHandler(
   object sender,
   UIActivationStateEventArgs e
);
[C++]
public __gc __delegate void UIActivationStateEventHandler(
   Object* sender,
   UIActivationStateEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the UIActivationStateEventHandler delegate declaration.

sender
The source of the event.
e
A System.ComponentModel.Design.UIActiavationStateEvent.UIActivationStateEvent that contains the event data.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

System.ComponentModel.Design Namespace | System.ComponentModel.Design.UIActivationStateEvent


ValueEditorConverter Class

[To be supplied.]

Object
TypeConverter
ValueEditorConverter

[Visual Basic]
Public Class ValueEditorConverter
   Inherits TypeConverter
[C#]
public class ValueEditorConverter : TypeConverter
[C++]
public __gc class ValueEditorConverter : public TypeConverter
[JScript]
public class ValueEditorConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

ValueEditorConverter Members | System.ComponentModel.Design Namespace


ValueEditorConverter Members

Public:

Constructor

ValueEditorConverter Constructor [To be supplied.]

Methods

CanConvertFrom (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter.
CanConvertTo | Overloaded. [To be supplied.]
ConvertFrom | Overloaded. [To be supplied.]
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text into an object.
ConvertTo | Overloaded. [To be supplied.]
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetProperties (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValues (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid (inherited from TypeConverter) | Overloaded. [To be supplied.]
ToString | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

ValueEditorConverter Class | System.ComponentModel.Design Namespace


ValueEditorConverter Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal host As ValueEditorHost _
)
[C#]
public ValueEditorConverter(
   ValueEditorHost host
);
[C++]
public: ValueEditorConverter(
   ValueEditorHost* host
);
[JScript]
public function ValueEditorConverter(
   host : ValueEditorHost
);

Parameters

host
[To be supplied.]

See Also

ValueEditorConverter Class | ValueEditorConverter Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ValueEditorConverter Methods

The methods of the ValueEditorConverter class are listed below. For a complete list of ValueEditorConverter class members, see the ValueEditorConverter Members topic.

Public:

CanConvertFrom (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter.
CanConvertTo | Overloaded. [To be supplied.]
ConvertFrom | Overloaded. [To be supplied.]
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text into an object.
ConvertTo | Overloaded. [To be supplied.]
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetProperties (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValues (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid (inherited from TypeConverter) | Overloaded. [To be supplied.]
ToString | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

ValueEditorConverter Class | System.ComponentModel.Design Namespace


ValueEditorConverter.CanConvertFrom

[To be supplied.]

[Visual Basic]
Overrides Public Function CanConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal sourceType As Type _
) As Boolean
[C#]
public override bool CanConvertFrom(
   ITypeDescriptorContext context,
   Type sourceType
);
[C++]
public: override bool CanConvertFrom(
   ITypeDescriptorContext* context,
   Type* sourceType
);
[JScript]
public override function CanConvertFrom(
   context : ITypeDescriptorContext,
   sourceType : Type
) : Boolean;

Parameters

context
[To be supplied.]
sourceType
[To be supplied.]

See Also

ValueEditorConverter Class | ValueEditorConverter Members | System.ComponentModel.Design Namespace


ValueEditorConverter.CanConvertTo

[To be supplied.]

[Visual Basic]
Overrides Public Function CanConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal destinationType As Type _
) As Boolean
[C#]
public override bool CanConvertTo(
   ITypeDescriptorContext context,
   Type destinationType
);
[C++]
public: override bool CanConvertTo(
   ITypeDescriptorContext* context,
   Type* destinationType
);
[JScript]
public override function CanConvertTo(
   context : ITypeDescriptorContext,
   destinationType : Type
) : Boolean;

Parameters

context
[To be supplied.]
destinationType
[To be supplied.]

See Also

ValueEditorConverter Class | ValueEditorConverter Members | System.ComponentModel.Design Namespace


ValueEditorConverter.ConvertFrom

[To be supplied.]

[Visual Basic]
Overrides Public Function ConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal arguments() As Object _
) As Object
[C#]
public override object ConvertFrom(
   ITypeDescriptorContext context,
   object value,
   object[] arguments
);
[C++]
public: override Object* ConvertFrom(
   ITypeDescriptorContext* context,
   Object* value,
   Object* arguments[]
);
[JScript]
public override function ConvertFrom(
   context : ITypeDescriptorContext,
   value : Object,
   arguments : Object[]
) : Object;

Parameters

context
[To be supplied.]
value
[To be supplied.]
arguments
[To be supplied.]

See Also

ValueEditorConverter Class | ValueEditorConverter Members | System.ComponentModel.Design Namespace


ValueEditorConverter.ConvertTo

[To be supplied.]

[Visual Basic]
Overrides Public Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal destinationType As Type, _
   ByVal arguments() As Object _
) As Object
[C#]
public override object ConvertTo(
   ITypeDescriptorContext context,
   object value,
   Type destinationType,
   object[] arguments
);
[C++]
public: override Object* ConvertTo(
   ITypeDescriptorContext* context,
   Object* value,
   Type* destinationType,
   Object* arguments[]
);
[JScript]
public override function ConvertTo(
   context : ITypeDescriptorContext,
   value : Object,
   destinationType : Type,
   arguments : Object[]
) : Object;

Parameters

context
[To be supplied.]
value
[To be supplied.]
destinationType
[To be supplied.]
arguments
[To be supplied.]

See Also

ValueEditorConverter Class | ValueEditorConverter Members | System.ComponentModel.Design Namespace


ValueEditorConverter.CreateInstance

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overrides Public Function CreateInstance(ITypeDescriptorContext, PersistInfo) As Object
[C#] public override object CreateInstance(ITypeDescriptorContext, PersistInfo);
[C++] public: override Object* CreateInstance(ITypeDescriptorContext*, PersistInfo);
[JScript] public override function CreateInstance(ITypeDescriptorContext, PersistInfo) : Object;

[To be supplied.]

[Visual Basic] Overloads Overrides Public Function CreateInstance(ITypeDescriptorContext, IDictionary) As Object
[C#] public override object CreateInstance(ITypeDescriptorContext, IDictionary);
[C++] public: override Object* CreateInstance(ITypeDescriptorContext*, IDictionary);
[JScript] public override function CreateInstance(ITypeDescriptorContext, IDictionary) : Object;

See Also

ValueEditorConverter Class | ValueEditorConverter Members | System.ComponentModel.Design Namespace


ValueEditorConverter.CreateInstance (ITypeDescriptorContext, PersistInfo)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Function CreateInstance( _
   ByVal context As ITypeDescriptorContext, _
   ByVal persistInfo As PersistInfo _
) As Object
[C#]
public override object CreateInstance(
   ITypeDescriptorContext context,
   PersistInfo persistInfo
);
[C++]
public: override Object* CreateInstance(
   ITypeDescriptorContext* context,
   PersistInfo* persistInfo
);
[JScript]
public override function CreateInstance(
   context : ITypeDescriptorContext,
   persistInfo : PersistInfo
) : Object;

Parameters

context
[To be supplied.]
persistInfo
[To be supplied.]

See Also

ValueEditorConverter Class | ValueEditorConverter Members | System.ComponentModel.Design Namespace | ValueEditorConverter.CreateInstance Overload List


ValueEditorConverter.CreateInstance (ITypeDescriptorContext, IDictionary)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Function CreateInstance( _
   ByVal context As ITypeDescriptorContext, _
   ByVal propertyValues As IDictionary _
) As Object
[C#]
public override object CreateInstance(
   ITypeDescriptorContext context,
   IDictionary propertyValues
);
[C++]
public: override Object* CreateInstance(
   ITypeDescriptorContext* context,
   IDictionary* propertyValues
);
[JScript]
public override function CreateInstance(
   context : ITypeDescriptorContext,
   propertyValues : IDictionary
) : Object;

Parameters

context
[To be supplied.]
propertyValues
[To be supplied.]

See Also

ValueEditorConverter Class | ValueEditorConverter Members | System.ComponentModel.Design Namespace | ValueEditorConverter.CreateInstance Overload List


ValueEditorConverter.GetCreateInstanceSupported

[To be supplied.]

[Visual Basic]
Overrides Public Function GetCreateInstanceSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
[C#]
public override bool GetCreateInstanceSupported(
   ITypeDescriptorContext context
);
[C++]
public: override bool GetCreateInstanceSupported(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetCreateInstanceSupported(
   context : ITypeDescriptorContext
) : Boolean;

Parameters

context
[To be supplied.]

See Also

ValueEditorConverter Class | ValueEditorConverter Members | System.ComponentModel.Design Namespace


ValueEditorConverter.GetPersistInfo

[To be supplied.]

[Visual Basic]
Overrides Public Function GetPersistInfo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As PersistInfo
[C#]
public override PersistInfo GetPersistInfo(
   ITypeDescriptorContext context,
   object value
);
[C++]
public: override PersistInfo* GetPersistInfo(
   ITypeDescriptorContext* context,
   Object* value
);
[JScript]
public override function GetPersistInfo(
   context : ITypeDescriptorContext,
   value : Object
) : PersistInfo;

Parameters

context
[To be supplied.]
value
[To be supplied.]

See Also

ValueEditorConverter Class | ValueEditorConverter Members | System.ComponentModel.Design Namespace


ValueEditorConverter.GetProperties

[To be supplied.]

[Visual Basic]
Overrides Public Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal attributes() As MemberAttribute _
) As PropertyDescriptorCollection
[C#]
public override PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value,
   MemberAttribute[] attributes
);
[C++]
public: override PropertyDescriptorCollection* GetProperties(
   ITypeDescriptorContext* context,
   Object* value,
   MemberAttribute* attributes[]
);
[JScript]
public override function GetProperties(
   context : ITypeDescriptorContext,
   value : Object,
   attributes : MemberAttribute[]
) : PropertyDescriptorCollection;

Parameters

context
[To be supplied.]
value
[To be supplied.]
attributes
[To be supplied.]

See Also

ValueEditorConverter Class | ValueEditorConverter Members | System.ComponentModel.Design Namespace


ValueEditorConverter.GetPropertiesSupported

[To be supplied.]

[Visual Basic]
Overrides Public Function GetPropertiesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
[C#]
public override bool GetPropertiesSupported(
   ITypeDescriptorContext context
);
[C++]
public: override bool GetPropertiesSupported(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetPropertiesSupported(
   context : ITypeDescriptorContext
) : Boolean;

Parameters

context
[To be supplied.]

See Also

ValueEditorConverter Class | ValueEditorConverter Members | System.ComponentModel.Design Namespace


ValueEditorConverter.GetStandardValues

[To be supplied.]

[Visual Basic]
Overrides Public Function GetStandardValues( _
   ByVal context As ITypeDescriptorContext _
) As StandardValuesCollection
[C#]
public override StandardValuesCollection GetStandardValues(
   ITypeDescriptorContext context
);
[C++]
public: override StandardValuesCollection* GetStandardValues(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetStandardValues(
   context : ITypeDescriptorContext
) : StandardValuesCollection;

Parameters

context
[To be supplied.]

See Also

ValueEditorConverter Class | ValueEditorConverter Members | System.ComponentModel.Design Namespace


ValueEditorConverter.GetStandardValuesExclusive

[To be supplied.]

[Visual Basic]
Overrides Public Function GetStandardValuesExclusive( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
[C#]
public override bool GetStandardValuesExclusive(
   ITypeDescriptorContext context
);
[C++]
public: override bool GetStandardValuesExclusive(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetStandardValuesExclusive(
   context : ITypeDescriptorContext
) : Boolean;

Parameters

context
[To be supplied.]

See Also

ValueEditorConverter Class | ValueEditorConverter Members | System.ComponentModel.Design Namespace


ValueEditorConverter.GetStandardValuesSupported

[To be supplied.]

[Visual Basic]
Overrides Public Function GetStandardValuesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
[C#]
public override bool GetStandardValuesSupported(
   ITypeDescriptorContext context
);
[C++]
public: override bool GetStandardValuesSupported(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetStandardValuesSupported(
   context : ITypeDescriptorContext
) : Boolean;

Parameters

context
[To be supplied.]

See Also

ValueEditorConverter Class | ValueEditorConverter Members | System.ComponentModel.Design Namespace


ValueEditorConverter.IsValid

[To be supplied.]

[Visual Basic]
Overrides Public Function IsValid( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As Boolean
[C#]
public override bool IsValid(
   ITypeDescriptorContext context,
   object value
);
[C++]
public: override bool IsValid(
   ITypeDescriptorContext* context,
   Object* value
);
[JScript]
public override function IsValid(
   context : ITypeDescriptorContext,
   value : Object
) : Boolean;

Parameters

context
[To be supplied.]
value
[To be supplied.]

See Also

ValueEditorConverter Class | ValueEditorConverter Members | System.ComponentModel.Design Namespace


ValueEditorConverter.ToString

[To be supplied.]

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

ValueEditorConverter Class | ValueEditorConverter Members | System.ComponentModel.Design Namespace


ValueEditorHost Class

[To be supplied.]

Object
ValueEditorHost

[Visual Basic]
Public Class ValueEditorHost
   Implements IEditorSite
[C#]
public class ValueEditorHost : IEditorSite
[C++]
public __gc class ValueEditorHost : public IEditorSite
[JScript]
public class ValueEditorHost implements IEditorSite

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

ValueEditorHost Members | System.ComponentModel.Design Namespace


ValueEditorHost Members

Public:

Constructor

ValueEditorHost Constructor Overloaded. [To be supplied.]

Properties

Component | [To be supplied.]
Editor | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FindPropertyValue | [To be supplied.]
GetComponents | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
GetValueOwner | [To be supplied.]
GetValueOwners | [To be supplied.]
GetValueType | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Context | [To be supplied.]
Type | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ValueEditorHost Class | System.ComponentModel.Design Namespace


ValueEditorHost Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Type, Type)
[C#] public ValueEditorHost(Type, Type);
[C++] public: ValueEditorHost(Type*, Type*);
[JScript] public function ValueEditorHost(Type, Type);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Type, ValueEditor)
[C#] public ValueEditorHost(Type, ValueEditor);
[C++] public: ValueEditorHost(Type*, ValueEditor);
[JScript] public function ValueEditorHost(Type, ValueEditor);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Type)
[C#] public ValueEditorHost(Type);
[C++] public: ValueEditorHost(Type*);
[JScript] public function ValueEditorHost(Type);

See Also

ValueEditorHost Class | ValueEditorHost Members | System.ComponentModel.Design Namespace


ValueEditorHost Constructor (Type, Type)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal type As Type, _
   ByVal valueEditorType As Type _
)
[C#]
public ValueEditorHost(
   Type type,
   Type valueEditorType
);
[C++]
public: ValueEditorHost(
   Type* type,
   Type* valueEditorType
);
[JScript]
public function ValueEditorHost(
   type : Type,
   valueEditorType : Type
);

Parameters

type
[To be supplied.]
valueEditorType
[To be supplied.]

See Also

ValueEditorHost Class | ValueEditorHost Members | System.ComponentModel.Design Namespace | ValueEditorHost Constructor Overload List


ValueEditorHost Constructor (Type, ValueEditor)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal type As Type, _
   ByVal editor As ValueEditor _
)
[C#]
public ValueEditorHost(
   Type type,
   ValueEditor editor
);
[C++]
public: ValueEditorHost(
   Type* type,
   ValueEditor* editor
);
[JScript]
public function ValueEditorHost(
   type : Type,
   editor : ValueEditor
);

Parameters

type
[To be supplied.]
editor
[To be supplied.]

See Also

ValueEditorHost Class | ValueEditorHost Members | System.ComponentModel.Design Namespace | ValueEditorHost Constructor Overload List


ValueEditorHost Constructor (Type)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal type As Type _
)
[C#]
public ValueEditorHost(
   Type type
);
[C++]
public: ValueEditorHost(
   Type* type
);
[JScript]
public function ValueEditorHost(
   type : Type
);

Parameters

type
[To be supplied.]

See Also

ValueEditorHost Class | ValueEditorHost Members | System.ComponentModel.Design Namespace | ValueEditorHost Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ValueEditorHost Properties

The properties of the ValueEditorHost class are listed below. For a complete list of ValueEditorHost class members, see the ValueEditorHost Members topic.

Public:

Component | [To be supplied.]
Editor | [To be supplied.]

See Also

ValueEditorHost Class | System.ComponentModel.Design Namespace


ValueEditorHost.Component

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Component As IComponent
[C#]
public IComponent Component {virtual get;}
[C++]
public: __property virtual IComponent* get_Component();
[JScript]
public function get Component() : IComponent;

See Also

ValueEditorHost Class | ValueEditorHost Members | System.ComponentModel.Design Namespace


ValueEditorHost.Editor

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Editor As ValueEditor
[C#]
public ValueEditor Editor {virtual get;}
[C++]
public: __property virtual ValueEditor* get_Editor();
[JScript]
public function get Editor() : ValueEditor;

See Also

ValueEditorHost Class | ValueEditorHost Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ValueEditorHost Methods

The methods of the ValueEditorHost class are listed below. For a complete list of ValueEditorHost class members, see the ValueEditorHost Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FindPropertyValue | [To be supplied.]
GetComponents | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
GetValueOwner | [To be supplied.]
GetValueOwners | [To be supplied.]
GetValueType | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ValueEditorHost Class | System.ComponentModel.Design Namespace


ValueEditorHost.FindPropertyValue

[To be supplied.]

[Visual Basic]
Overridable Public Function FindPropertyValue( _
   ByVal name As String, _
   ByVal type As Type _
) As Object
[C#]
public virtual object FindPropertyValue(
   string name,
   Type type
);
[C++]
public: virtual Object* FindPropertyValue(
   String* name,
   Type* type
);
[JScript]
public function FindPropertyValue(
   name : String,
   type : Type
) : Object;

Parameters

name
[To be supplied.]
type
[To be supplied.]

See Also

ValueEditorHost Class | ValueEditorHost Members | System.ComponentModel.Design Namespace


ValueEditorHost.GetComponents

[To be supplied.]

[Visual Basic]
Overridable Public Function GetComponents() As IComponent ()
[C#]
public virtual IComponent[] GetComponents();
[C++]
public: virtual IComponent* GetComponents() [];
[JScript]
public function GetComponents() : IComponent[];

See Also

ValueEditorHost Class | ValueEditorHost Members | System.ComponentModel.Design Namespace


ValueEditorHost.GetValueOwner

[To be supplied.]

[Visual Basic]
Overridable Public Function GetValueOwner() As Object
[C#]
public virtual object GetValueOwner();
[C++]
public: virtual Object* GetValueOwner();
[JScript]
public function GetValueOwner() : Object;

See Also

ValueEditorHost Class | ValueEditorHost Members | System.ComponentModel.Design Namespace


ValueEditorHost.GetValueOwners

[To be supplied.]

[Visual Basic]
Overridable Public Function GetValueOwners() As Object ()
[C#]
public virtual object[] GetValueOwners();
[C++]
public: virtual Object* GetValueOwners() [];
[JScript]
public function GetValueOwners() : Object[];

See Also

ValueEditorHost Class | ValueEditorHost Members | System.ComponentModel.Design Namespace


ValueEditorHost.GetValueType

[To be supplied.]

[Visual Basic]
Overridable Public Function GetValueType() As Type
[C#]
public virtual Type GetValueType();
[C++]
public: virtual Type* GetValueType();
[JScript]
public function GetValueType() : Type;

See Also

ValueEditorHost Class | ValueEditorHost Members | System.ComponentModel.Design Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ValueEditorHost Fields

The fields of the ValueEditorHost class are listed below. For a complete list of ValueEditorHost class members, see the ValueEditorHost Members topic.

Public:

Context | [To be supplied.]
Type | [To be supplied.]

See Also

ValueEditorHost Class | System.ComponentModel.Design Namespace


ValueEditorHost.Context

[To be supplied.]

[Visual Basic]
Public Context As ITypeDescriptorContext
[C#]
public ITypeDescriptorContext Context;
[C++]
public: ITypeDescriptorContext* Context;
[JScript]
public var Context : ITypeDescriptorContext;

See Also

ValueEditorHost Class | ValueEditorHost Members | System.ComponentModel.Design Namespace


ValueEditorHost.Type

[To be supplied.]

[Visual Basic]
Public Type As Type
[C#]
public Type Type;
[C++]
public: Type* Type;
[JScript]
public var Type : Type;

See Also

ValueEditorHost Class | ValueEditorHost Members | System.ComponentModel.Design Namespace


ValueExpressionLevel Enumeration

Specifies the levels of support for an IValueProvider.

[Visual Basic]
Public Enum ValueExpressionLevel
[C#]
public enum ValueExpressionLevel
[C++]
public enum ValueExpressionLevel

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
NotSupported | Indicates that the IValueProvider can not provide an expression for the value.
Supported | Indicates that the IValueProvider can provide an expression for the value.
UserSelected | Indicates that the IValueProvider can provide an expression for the value, and the user has specified that this IValueProvider should provide the expression.

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

System.ComponentModel.Design Namespace | IValueProvider | IValueProviderService


ValueProvider Class

Interface defining an object that needs to participate in code generation to persist data outside of the code. This allows the runtime object to "provide values" to components on the form.

Object
ValueProvider

[Visual Basic]
Public Class ValueProvider
   Implements IValueProvider
[C#]
public class ValueProvider : IValueProvider
[C++]
public __gc class ValueProvider : public IValueProvider
[JScript]
public class ValueProvider implements IValueProvider

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

ValueProvider Members | System.ComponentModel.Design Namespace


ValueProvider Members

Public:

Constructor

ValueProvider Constructor [To be supplied.]

Properties

ServiceProvider The service provider for this value provider. This is normally provided by the IValueProviderService.

Methods

BeginDepersist | Alerts the ValueProvider that depersistance has begun.
BeginPersist | Alerts the ValueProvider that persistance has begun.
CanProvideValue | Returns whether or not the value provider is capable of providing a value.
EndDepersist | Alerts the ValueProvider that depersistance has ended.
EndPersist | Alerts the ValueProvider that persistance has ended.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetExpressionLevel | Gets the expression level of the value for the specified property on the specified object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLocalVariableDeclaration | Gets the local variable declaration required for this value provider.
GetRequireComponents | Gets the components required to be initialized before the value provider can provide values.
GetType (inherited from Object) | Gets the Type of the Object.
IsLocalVariableDeclaration | Gets whether or not the specified statement is the local variable declaration for this value provider.
ProvideExpression | Creates a new expression that represents the property value for the specified component.
ProvideValue | Gets the value that the code expression represents.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ValueProvider Class | System.ComponentModel.Design Namespace


ValueProvider Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ValueProvider();
[C++]
public: ValueProvider();
[JScript]
public function ValueProvider();

See Also

ValueProvider Class | ValueProvider Members | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ValueProvider Properties

The properties of the ValueProvider class are listed below. For a complete list of ValueProvider class members, see the ValueProvider Members topic.

Public:

ServiceProvider The service provider for this value provider. This is normally provided by the IValueProviderService.

See Also

ValueProvider Class | System.ComponentModel.Design Namespace


ValueProvider.ServiceProvider

The service provider for this value provider. This is normally provided by the IValueProviderService.

[Visual Basic]
Overridable Public Property ServiceProvider As _
   IServiceObjectProvider
[C#]
public IServiceObjectProvider ServiceProvider {virtual get; virtual
   set;}
[C++]
public: __property virtual IServiceObjectProvider* get_ServiceProvider();
public: __property virtual void set_ServiceProvider(IServiceObjectProvider*);
[JScript]
public function get ServiceProvider() : IServiceObjectProvider;
public function set ServiceProvider(IServiceObjectProvider);

See Also

ValueProvider Class | ValueProvider Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ValueProvider Methods

The methods of the ValueProvider class are listed below. For a complete list of ValueProvider class members, see the ValueProvider Members topic.

Public:

BeginDepersist | Alerts the ValueProvider that depersistance has begun.
BeginPersist | Alerts the ValueProvider that persistance has begun.
CanProvideValue | Returns whether or not the value provider is capable of providing a value.
EndDepersist | Alerts the ValueProvider that depersistance has ended.
EndPersist | Alerts the ValueProvider that persistance has ended.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetExpressionLevel | Gets the expression level of the value for the specified property on the specified object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLocalVariableDeclaration | Gets the local variable declaration required for this value provider.
GetRequireComponents | Gets the components required to be initialized before the value provider can provide values.
GetType (inherited from Object) | Gets the Type of the Object.
IsLocalVariableDeclaration | Gets whether or not the specified statement is the local variable declaration for this value provider.
ProvideExpression | Creates a new expression that represents the property value for the specified component.
ProvideValue | Gets the value that the code expression represents.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ValueProvider Class | System.ComponentModel.Design Namespace


ValueProvider.BeginDepersist

Alerts the ValueProvider that depersistance has begun.

[Visual Basic]
Overridable Public Sub BeginDepersist()
[C#]
public virtual void BeginDepersist();
[C++]
public: virtual void BeginDepersist();
[JScript]
public function BeginDepersist();

Remarks

This is called by the code generator before any statements in the code are parsed. This allows the provider to clear any previous state.

See Also

ValueProvider Class | ValueProvider Members | System.ComponentModel.Design Namespace


ValueProvider.BeginPersist

Alerts the ValueProvider that persistance has begun.

[Visual Basic]
Overridable Public Sub BeginPersist()
[C#]
public virtual void BeginPersist();
[C++]
public: virtual void BeginPersist();
[JScript]
public function BeginPersist();

Remarks

This is called by the code generator before any statements in the code are generated. This allows the provider to clear any previous state.

See Also

ValueProvider Class | ValueProvider Members | System.ComponentModel.Design Namespace


ValueProvider.CanProvideValue

Returns whether or not the value provider is capable of providing a value.

[Visual Basic]
Overridable Public Function CanProvideValue( _
   ByVal component As Object, _
   ByVal propertyName As String, _
   ByVal exp As Object _
) As Boolean
[C#]
public virtual bool CanProvideValue(
   object component,
   string propertyName,
   object exp
);
[C++]
public: virtual bool CanProvideValue(
   Object* component,
   String* propertyName,
   Object* exp
);
[JScript]
public function CanProvideValue(
   component : Object,
   propertyName : String,
   exp : Object
) : Boolean;

Parameters

component
The component whose property is being depersisted.
propertyName
The property that is being depersisted.
exp
The expression to determine if this value provider can provide a value for.

Return Value

true if the value provider is capable of providing a value, false otherwise.

Remarks

This is called for every expression found in the code. If the IValueProvider returns true, then the ProvideValue method will be called.

See Also

ValueProvider Class | ValueProvider Members | System.ComponentModel.Design Namespace


ValueProvider.EndDepersist

Alerts the ValueProvider that depersistance has ended.

[Visual Basic]
Overridable Public Sub EndDepersist()
[C#]
public virtual void EndDepersist();
[C++]
public: virtual void EndDepersist();
[JScript]
public function EndDepersist();

Remarks

This is called by the code generator after all statements have been parsed.

See Also

ValueProvider Class | ValueProvider Members | System.ComponentModel.Design Namespace


ValueProvider.EndPersist

Alerts the ValueProvider that persistance has ended.

[Visual Basic]
Overridable Public Sub EndPersist()
[C#]
public virtual void EndPersist();
[C++]
public: virtual void EndPersist();
[JScript]
public function EndPersist();

Remarks

This is called by the code generator after all statements have been generated.

See Also

ValueProvider Class | ValueProvider Members | System.ComponentModel.Design Namespace


ValueProvider.GetExpressionLevel

Gets the expression level of the value for the specified property on the specified object.

[Visual Basic]
Overridable Public Function GetExpressionLevel( _
   ByVal component As Object, _
   ByVal property As PropertyDescriptor, _
   ByVal persistable As PersistableSupport _
) As ValueExpressionLevel
[C#]
public virtual ValueExpressionLevel GetExpressionLevel(
   object component,
   PropertyDescriptor property,
   PersistableSupport persistable
);
[C++]
public: virtual ValueExpressionLevel GetExpressionLevel(
   Object* component,
   PropertyDescriptor* property,
   PersistableSupport persistable
);
[JScript]
public function GetExpressionLevel(
   component : Object,
   property : PropertyDescriptor,
   persistable : PersistableSupport
) : ValueExpressionLevel;

Parameters

component
The component whose property is being persisted.
property
[To be supplied.]
persistable
[To be supplied.]

Return Value

A ValueExpressionLevel object representing the expression level of the specified property of the specified object.

Remarks

If a value provider returns anything but ValueExpressionLevel.NotSupported then it must return a non-null value from ProvideExpression.

See Also

ValueProvider Class | ValueProvider Members | System.ComponentModel.Design Namespace


ValueProvider.GetLocalVariableDeclaration

Gets the local variable declaration required for this value provider.

[Visual Basic]
Overridable Public Function GetLocalVariableDeclaration() As _
   ICodeStatement
[C#]
public virtual ICodeStatement GetLocalVariableDeclaration();
[C++]
public: virtual ICodeStatement* GetLocalVariableDeclaration();
[JScript]
public function GetLocalVariableDeclaration() : ICodeStatement;

Return Value

An ICodeStatement representing the local variable declaration.

Remarks

If this value provider requires that a local variable is declared then this must return a non-null ICodeStatement.

See Also

ValueProvider Class | ValueProvider Members | System.ComponentModel.Design Namespace


ValueProvider.GetRequireComponents

Gets the components required to be initialized before the value provider can provide values.

[Visual Basic]
Overridable Public Function GetRequireComponents() As Object ()
[C#]
public virtual object[] GetRequireComponents();
[C++]
public: virtual Object* GetRequireComponents() [];
[JScript]
public function GetRequireComponents() : Object[];

Return Value

An array representing the components required to be initialized before the value provider can provide values.

Remarks

Returns an array of components that are required to be initialized before this value provider can provide values. Basically this allows a value provider to force the component that is actually providing the values to be code gen'd before the calls to it.

See Also

ValueProvider Class | ValueProvider Members | System.ComponentModel.Design Namespace


ValueProvider.IsLocalVariableDeclaration

Gets whether or not the specified statement is the local variable declaration for this value provider.

[Visual Basic]
Overridable Public Function IsLocalVariableDeclaration( _
   ByVal stmt As ICodeStatement _
) As Boolean
[C#]
public virtual bool IsLocalVariableDeclaration(
   ICodeStatement stmt
);
[C++]
public: virtual bool IsLocalVariableDeclaration(
   ICodeStatement* stmt
);
[JScript]
public function IsLocalVariableDeclaration(
   stmt : ICodeStatement
) : Boolean;

Parameters

stmt
The statement to check.

Return Value

true if the specified statement is the local variable declaration for this value provider, otherwise false.

See Also

ValueProvider Class | ValueProvider Members | System.ComponentModel.Design Namespace


ValueProvider.ProvideExpression

Creates a new expression that represents the property value for the specified component.

[Visual Basic]
Overridable Public Function ProvideExpression( _
   ByVal component As Object, _
   ByVal propertyName As String, _
   ByVal value As Object _
) As Object
[C#]
public virtual object ProvideExpression(
   object component,
   string propertyName,
   object value
);
[C++]
public: virtual Object* ProvideExpression(
   Object* component,
   String* propertyName,
   Object* value
);
[JScript]
public function ProvideExpression(
   component : Object,
   propertyName : String,
   value : Object
) : Object;

Parameters

component
The component whose property is being persisted.
propertyName
The property that is being persisted.
value
The value of the property that is being persisted.

See Also

ValueProvider Class | ValueProvider Members | System.ComponentModel.Design Namespace


ValueProvider.ProvideValue

Gets the value that the code expression represents.

[Visual Basic]
Overridable Public Function ProvideValue( _
   ByVal component As Object, _
   ByVal propertyName As String, _
   ByVal exp As Object _
) As Object
[C#]
public virtual object ProvideValue(
   object component,
   string propertyName,
   object exp
);
[C++]
public: virtual Object* ProvideValue(
   Object* component,
   String* propertyName,
   Object* exp
);
[JScript]
public function ProvideValue(
   component : Object,
   propertyName : String,
   exp : Object
) : Object;

Parameters

component
The component whose property is being depersisted.
propertyName
The property that is being depersisted.
exp
[To be supplied.]

See Also

ValueProvider Class | ValueProvider Members | System.ComponentModel.Design Namespace


ValueProviderCollection Class

Collection of IValueProvider objects.

Object
ObjectList
ValueProviderCollection

[Visual Basic]
NotInheritable Public Class ValueProviderCollection
   Inherits ObjectList
   Implements IValueProviderCollection
[C#]
public sealed class ValueProviderCollection : ObjectList,
   IValueProviderCollection
[C++]
public __gc __sealed class ValueProviderCollection : public
   ObjectList, IValueProviderCollection
[JScript]
public class ValueProviderCollection extends ObjectList,
   IValueProviderCollection

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

ValueProviderCollection Members | System.ComponentModel.Design Namespace


ValueProviderCollection Members

Public:

Constructor

ValueProviderCollection Constructor Initializes a new instance of the ValueProviderCollection class.

Properties

All | Gets or sets a snapshot array of all the items contained in the collection.
Count (inherited from ObjectList) | [To be supplied.]
IsReadOnly (inherited from ObjectList) | [To be supplied.]
IsSynchronized (inherited from ObjectList) | [To be supplied.]
Item (inherited from ObjectList) | [To be supplied.] In C#, this member is the indexer for the ValueProviderCollection class.
SyncRoot (inherited from ObjectList) | [To be supplied.]

Methods

Add | Overloaded. [To be supplied.]
Clear (inherited from ObjectList) | [To be supplied.]
Contains (inherited from ObjectList) | [To be supplied.]
CopyTo (inherited from ObjectList) | [To be supplied.]
Dispose | Disposes of the resources (other than memory) associated with the ValueProviderCollection.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from ObjectList) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf (inherited from ObjectList) | [To be supplied.]
Insert (inherited from ObjectList) | [To be supplied.]
Remove | Overloaded. [To be supplied.]
RemoveAt (inherited from ObjectList) | [To be supplied.]
ToArray (inherited from ObjectList) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ValueProviderCollection Class | System.ComponentModel.Design Namespace


ValueProviderCollection Constructor

Initializes a new instance of the ValueProviderCollection class.

[Visual Basic]
Public Sub New( _
   ByVal service As ValueProviderService _
)
[C#]
public ValueProviderCollection(
   ValueProviderService service
);
[C++]
public: ValueProviderCollection(
   ValueProviderService* service
);
[JScript]
public function ValueProviderCollection(
   service : ValueProviderService
);

Parameters

service
The value provider service.

See Also

ValueProviderCollection Class | ValueProviderCollection Members | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ValueProviderCollection Properties

The properties of the ValueProviderCollection class are listed below. For a complete list of ValueProviderCollection class members, see the ValueProviderCollection Members topic.

Public:

All | Gets or sets a snapshot array of all the items contained in the collection.
Count (inherited from ObjectList) | [To be supplied.]
IsReadOnly (inherited from ObjectList) | [To be supplied.]
IsSynchronized (inherited from ObjectList) | [To be supplied.]
Item (inherited from ObjectList) | [To be supplied.] In C#, this member is the indexer for the ValueProviderCollection class.
SyncRoot (inherited from ObjectList) | [To be supplied.]

See Also

ValueProviderCollection Class | System.ComponentModel.Design Namespace


ValueProviderCollection.All

Gets or sets a snapshot array of all the items contained in the collection.

[Visual Basic]
Overridable Public ReadOnly Property All As IValueProvider ()
[C#]
public IValueProvider[] All {virtual get;}
[C++]
public: __property virtual IValueProvider* get_All();
[JScript]
public function get All() : IValueProvider[];

Property Value

An array of IValueProvider objects listed by the ValueProviderCollection.

See Also

ValueProviderCollection Class | ValueProviderCollection Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ValueProviderCollection Methods

The methods of the ValueProviderCollection class are listed below. For a complete list of ValueProviderCollection class members, see the ValueProviderCollection Members topic.

Public:

Add | Overloaded. [To be supplied.]
Clear (inherited from ObjectList) | [To be supplied.]
Contains (inherited from ObjectList) | [To be supplied.]
CopyTo (inherited from ObjectList) | [To be supplied.]
Dispose | Disposes of the resources (other than memory) associated with the ValueProviderCollection.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from ObjectList) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf (inherited from ObjectList) | [To be supplied.]
Insert (inherited from ObjectList) | [To be supplied.]
Remove | Overloaded. [To be supplied.]
RemoveAt (inherited from ObjectList) | [To be supplied.]
ToArray (inherited from ObjectList) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ValueProviderCollection Class | System.ComponentModel.Design Namespace


ValueProviderCollection.Add

Adds a new value provider to the collection.

[Visual Basic]
Overridable Public Sub Add( _
   ByVal value As IValueProvider _
)
[C#]
public virtual void Add(
   IValueProvider value
);
[C++]
public: virtual void Add(
   IValueProvider* value
);
[JScript]
public function Add(
   value : IValueProvider
);

Parameters

value
The value provider to add.

See Also

ValueProviderCollection Class | ValueProviderCollection Members | System.ComponentModel.Design Namespace


ValueProviderCollection.Dispose

Disposes of the resources (other than memory) associated with the ValueProviderCollection.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[JScript]
public function Dispose();

Remarks

Call Dispose when you are finished using the ValueProviderCollection. The Dispose method leaves the ValueProviderCollection in an unusuable state. After calling Dispose, you must release all references to the ValueProviderCollection so the memory it was occupying can be reclaimed by garbage collection.

Note Always call Dispose before you release your last reference to the ValueProviderCollection. Otherwise, the resources the ValueProviderCollection is using will not be freed until garbage collection calls the ValueProviderCollection object's destructor.

See Also

ValueProviderCollection Class | ValueProviderCollection Members | System.ComponentModel.Design Namespace


ValueProviderCollection.Remove

Removes a value provider from the collection.

[Visual Basic]
Overridable Public Sub Remove( _
   ByVal value As IValueProvider _
)
[C#]
public virtual void Remove(
   IValueProvider value
);
[C++]
public: virtual void Remove(
   IValueProvider* value
);
[JScript]
public function Remove(
   value : IValueProvider
);

Parameters

value
The value provider to remove.

See Also

ValueProviderCollection Class | ValueProviderCollection Members | System.ComponentModel.Design Namespace


ValueProviderService Class

The value provider service provides a collection of value providers that will be called on when code is persisted or depersisted.

Object
ValueProviderService

[Visual Basic]
NotInheritable Public Class ValueProviderService
   Implements IValueProviderService
[C#]
public sealed class ValueProviderService : IValueProviderService
[C++]
public __gc __sealed class ValueProviderService : public
   IValueProviderService
[JScript]
public class ValueProviderService implements IValueProviderService

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.dll

See Also

ValueProviderService Members | System.ComponentModel.Design Namespace


ValueProviderService Members

Public:

Constructor

ValueProviderService Constructor Initializes a new instance of the ValueProviderService class.

Properties

Providers The collection of value providers.

Methods

Dispose | Disposes of the resources (other than memory) used by this service.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ValueProviderService Class | System.ComponentModel.Design Namespace


ValueProviderService Constructor

Initializes a new instance of the ValueProviderService class.

[Visual Basic]
Public Sub New( _
   ByVal host As IDesignerHost _
)
[C#]
public ValueProviderService(
   IDesignerHost host
);
[C++]
public: ValueProviderService(
   IDesignerHost* host
);
[JScript]
public function ValueProviderService(
   host : IDesignerHost
);

Parameters

host
The designer host.

See Also

ValueProviderService Class | ValueProviderService Members | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ValueProviderService Properties

The properties of the ValueProviderService class are listed below. For a complete list of ValueProviderService class members, see the ValueProviderService Members topic.

Public:

Providers The collection of value providers.

See Also

ValueProviderService Class | System.ComponentModel.Design Namespace


ValueProviderService.Providers

The collection of value providers.

[Visual Basic]
Overridable Public ReadOnly Property Providers As _
   IValueProviderCollection
[C#]
public IValueProviderCollection Providers {virtual get;}
[C++]
public: __property virtual IValueProviderCollection*
   get_Providers();
[JScript]
public function get Providers() : IValueProviderCollection;

Property Value

The collection of value providers.

See Also

ValueProviderService Class | ValueProviderService Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ValueProviderService Methods

The methods of the ValueProviderService class are listed below. For a complete list of ValueProviderService class members, see the ValueProviderService Members topic.

Public:

Dispose | Disposes of the resources (other than memory) used by this service.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ValueProviderService Class | System.ComponentModel.Design Namespace


ValueProviderService.Dispose

Disposes of the resources (other than memory) used by this service.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[JScript]
public function Dispose();

Remarks

Call Dispose when you are finished using the ValueProviderService. The Dispose method leaves the ValueProviderService in an unusuable state. After calling Dispose, you must release all references to the ValueProviderService so the memory it was occupying can be reclaimed by garbage collection.

Note Always call Dispose before you release your last reference to the ValueProviderService. Otherwise, the resources the ValueProviderService is using will not be freed until garbage collection calls the ValueProviderService object's destructor.

See Also

ValueProviderService Class | ValueProviderService Members | System.ComponentModel.Design Namespace


VariantEditor Class

[To be supplied.]

Object
ValueEditor
VariantEditor

[Visual Basic]
Public Class VariantEditor
   Inherits ValueEditor
[C#]
public class VariantEditor : ValueEditor
[C++]
public __gc class VariantEditor : public ValueEditor
[JScript]
public class VariantEditor extends ValueEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design

Assembly: System.ComponentModel.Design.dll

See Also

VariantEditor Members | System.ComponentModel.Design Namespace


VariantEditor Members

Public:

Constructor

VariantEditor Constructor [To be supplied.]

Properties

Style | [To be supplied.]
Values (inherited from ValueEditor) | [To be supplied.]

Methods

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle | Retrieves the CreationBundle for the given value. null will be returned if the value cannot be created from either a static method or constructor call.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties | [To be supplied.]
GetTextFromValue | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues | [To be supplied.]
GetValueFromText | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

VariantEditor Class | System.ComponentModel.Design Namespace


VariantEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public VariantEditor();
[C++]
public: VariantEditor();
[JScript]
public function VariantEditor();

See Also

VariantEditor Class | VariantEditor Members | System.ComponentModel.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

VariantEditor Properties

The properties of the VariantEditor class are listed below. For a complete list of VariantEditor class members, see the VariantEditor Members topic.

Public:

Style | [To be supplied.]
Values (inherited from ValueEditor) | [To be supplied.]

See Also

VariantEditor Class | System.ComponentModel.Design Namespace


VariantEditor.Style

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Style As ValueEditorStyles
[C#]
public ValueEditorStyles Style {override get;}
[C++]
public: __property virtual ValueEditorStyles get_Style();
[JScript]
public function get Style() : ValueEditorStyles;

See Also

VariantEditor Class | VariantEditor Members | System.ComponentModel.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

VariantEditor Methods

The methods of the VariantEditor class are listed below. For a complete list of VariantEditor class members, see the VariantEditor Members topic.

Public:

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle | Retrieves the CreationBundle for the given value. null will be returned if the value cannot be created from either a static method or constructor call.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties | [To be supplied.]
GetTextFromValue | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues | [To be supplied.]
GetValueFromText | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

VariantEditor Class | System.ComponentModel.Design Namespace


VariantEditor.GetCreationBundle

Retrieves the CreationBundle for the given value. null will be returned if the value cannot be created from either a static method or constructor call.

[Visual Basic]
Overrides Public Function GetCreationBundle( _
   ByVal value As Object _
) As CreationBundle
[C#]
public override CreationBundle GetCreationBundle(
   object value
);
[C++]
public: override CreationBundle* GetCreationBundle(
   Object* value
);
[JScript]
public override function GetCreationBundle(
   value : Object
) : CreationBundle;

Parameters

value
[To be supplied.]

See Also

VariantEditor Class | VariantEditor Members | System.ComponentModel.Design Namespace


VariantEditor.GetSubProperties

[To be supplied.]

[Visual Basic]
Overrides Public Function GetSubProperties( _
   ByVal value As Object _
) As SubProperty ()
[C#]
public override SubProperty[] GetSubProperties(
   object value
);
[C++]
public: override SubProperty* GetSubProperties(
   Object* value
) [];
[JScript]
public override function GetSubProperties(
   value : Object
) : SubProperty[];

Parameters

value
[To be supplied.]

See Also

VariantEditor Class | VariantEditor Members | System.ComponentModel.Design Namespace


VariantEditor.GetTextFromValue

[To be supplied.]

[Visual Basic]
Overrides Public Function GetTextFromValue( _
   ByVal value As Object _
) As String
[C#]
public override string GetTextFromValue(
   object value
);
[C++]
public: override String* GetTextFromValue(
   Object* value
);
[JScript]
public override function GetTextFromValue(
   value : Object
) : String;

Parameters

value
[To be supplied.]

See Also

VariantEditor Class | VariantEditor Members | System.ComponentModel.Design Namespace


VariantEditor.GetValueFromSubPropertyValues

[To be supplied.]

[Visual Basic]
Overrides Public Function GetValueFromSubPropertyValues( _
   ByVal args() As Object _
) As Object
[C#]
public override object GetValueFromSubPropertyValues(
   object[] args
);
[C++]
public: override Object* GetValueFromSubPropertyValues(
   Object* args[]
);
[JScript]
public override function GetValueFromSubPropertyValues(
   args : Object[]
) : Object;

Parameters

args
[To be supplied.]

See Also

VariantEditor Class | VariantEditor Members | System.ComponentModel.Design Namespace


VariantEditor.GetValueFromText

[To be supplied.]

[Visual Basic]
Overrides Public Function GetValueFromText( _
   ByVal text As String _
) As Object
[C#]
public override object GetValueFromText(
   string text
);
[C++]
public: override Object* GetValueFromText(
   String* text
);
[JScript]
public override function GetValueFromText(
   text : String
) : Object;

Parameters

text
[To be supplied.]

See Also

VariantEditor Class | VariantEditor Members | System.ComponentModel.Design Namespace


System.ComponentModel.Design.CodeModel

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.ComponentModel.Design.CodeModel Namespace

Classes

Class | Description
DelegateTypeInfo | Stores and gets the type information of a delegate.

Interfaces

Interface | Description
ICodeArrayCreateExpression | Represents an array creation expression.
ICodeBlockComment | Represents a block comment in the code.
ICodeClass | Represents a single class.
ICodeClassImport | Represents the import of a single class into the source file's namespace.
ICodeConstructor | Represents a constructor in the class.
ICodeDataMember | Represents a data member declaration in the class.
ICodeDelegate | Represents a delegate in the class.
ICodeDOMStatement | Represents a CodeDOM model based statement.
ICodeElement | Base interface for all code elements.
ICodeElementLocation | Temporary
ICodeElements | Collection of ICodeElement objects.
ICodeLocalVariableStatement | Represents a local variable declaration statement in a method.
ICodeMember | Base interface used by all members inside of a class.
ICodeMembers | Collection of ICodeMember objects.
ICodeMethod | Represents a method declaration inside of a class.
ICodeMethodInvokeExpression | Represents a method invoke expression. The documentation for ICodeSourceFile has information about expressions.
ICodeMethodInvokeStatement | Represents a method invoke statment.
ICodeNameReferenceExpression | Represents a reference to any name or literal expression.
ICodeNamespaceImport | Represents the import of a namespace into the source file's namespace.
ICodeObjectCreateExpression | Represents an object creation expression. The documentation for ICodeSourceFile has information about expressions.
ICodeParameter | Represents a single parameter.
ICodeParameters | Collection of ICodeParameter objects.
ICodeProperty | Represents a property declaration in a class.
ICodePropertySetStatement | Represents a property set statement inside a method.
ICodeReturnValueStatement | Represents a single return value statement.
ICodeSourceFile | Provides a logical representation of a single source file.
ICodeStatement | Represents a single statement in the source file.
ICodeStatements | Collection of ICodeStatement objects.


DelegateTypeInfo Class

Stores and gets the type information of a delegate.

Object
DelegateTypeInfo

[Visual Basic]
Public Class DelegateTypeInfo
[C#]
public class DelegateTypeInfo
[C++]
public __gc class DelegateTypeInfo
[JScript]
public class DelegateTypeInfo

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design.CodeModel

Assembly: System.dll

See Also

DelegateTypeInfo Members | System.ComponentModel.Design.CodeModel Namespace


DelegateTypeInfo Members

Public:

Constructor

DelegateTypeInfo Constructor Overloaded. Initializes a new instance of the DelegateTypeInfo class to represent the delegate called within the specified source file and with the specified event descriptor.

Properties

Parameters | The parameters used in the Invoke method of the delegate.
ReturnType | The return type of the delegate.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DelegateTypeInfo Class | System.ComponentModel.Design.CodeModel Namespace


DelegateTypeInfo Constructor

Initializes a new instance of the DelegateTypeInfo class to represent the delegate called within the specified source file and with the specified event descriptor.

Overload List

Initializes a new instance of the DelegateTypeInfo class to represent the delegate called within the specified source file and with the specified event descriptor.

[Visual Basic] Overloads Public Sub New(ICodeSourceFile, EventDescriptor)
[C#] public DelegateTypeInfo(ICodeSourceFile, EventDescriptor);
[C++] public: DelegateTypeInfo(ICodeSourceFile*, EventDescriptor);
[JScript] public function DelegateTypeInfo(ICodeSourceFile, EventDescriptor);

Initializes a new instance of the DelegateTypeInfo class to represent the delegate called within the specified source file and with the specified event descriptor.

[Visual Basic] Overloads Public Sub New(ICodeSourceFile, Type)
[C#] public DelegateTypeInfo(ICodeSourceFile, Type);
[C++] public: DelegateTypeInfo(ICodeSourceFile*, Type);
[JScript] public function DelegateTypeInfo(ICodeSourceFile, Type);

See Also

DelegateTypeInfo Class | DelegateTypeInfo Members | System.ComponentModel.Design.CodeModel Namespace


DelegateTypeInfo Constructor (ICodeSourceFile, EventDescriptor)

Initializes a new instance of the DelegateTypeInfo class to represent the delegate called within the specified source file and with the specified event descriptor.

[Visual Basic]
Overloads Public Sub New( _
   ByVal sourceFile As ICodeSourceFile, _
   ByVal eventdesc As EventDescriptor _
)
[C#]
public DelegateTypeInfo(
   ICodeSourceFile sourceFile,
   EventDescriptor eventdesc
);
[C++]
public: DelegateTypeInfo(
   ICodeSourceFile* sourceFile,
   EventDescriptor* eventdesc
);
[JScript]
public function DelegateTypeInfo(
   sourceFile : ICodeSourceFile,
   eventdesc : EventDescriptor
);

Parameters

sourceFile
The source file to use when creating parameter information.
eventdesc
The event to get the type information for.

See Also

DelegateTypeInfo Class | DelegateTypeInfo Members | System.ComponentModel.Design.CodeModel Namespace | DelegateTypeInfo Constructor Overload List


DelegateTypeInfo Constructor (ICodeSourceFile, Type)

Initializes a new instance of the DelegateTypeInfo class to represent the delegate called within the specified source file and with the specified event descriptor.

[Visual Basic]
Overloads Public Sub New( _
   ByVal sourceFile As ICodeSourceFile, _
   ByVal delegateClass As Type _
)
[C#]
public DelegateTypeInfo(
   ICodeSourceFile sourceFile,
   Type delegateClass
);
[C++]
public: DelegateTypeInfo(
   ICodeSourceFile* sourceFile,
   Type* delegateClass
);
[JScript]
public function DelegateTypeInfo(
   sourceFile : ICodeSourceFile,
   delegateClass : Type
);

Parameters

sourceFile
The source file to use when creating parameter information.
delegateClass
The delegate to get the type information for.

See Also

DelegateTypeInfo Class | DelegateTypeInfo Members | System.ComponentModel.Design.CodeModel Namespace | DelegateTypeInfo Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DelegateTypeInfo Properties

The properties of the DelegateTypeInfo class are listed below. For a complete list of DelegateTypeInfo class members, see the DelegateTypeInfo Members topic.

Public:

Parameters | The parameters used in the Invoke method of the delegate.
ReturnType | The return type of the delegate.

See Also

DelegateTypeInfo Class | System.ComponentModel.Design.CodeModel Namespace


DelegateTypeInfo.Parameters

The parameters used in the Invoke method of the delegate.

[Visual Basic]
Public ReadOnly Property Parameters As ICodeParameter ()
[C#]
public ICodeParameter[] Parameters {get;}
[C++]
public: __property ICodeParameter* get_Parameters();
[JScript]
public function get Parameters() : ICodeParameter[];

Property Value

An array of type ICodeParameter storing the parameters for the Invoke method of the delegate.

See Also

DelegateTypeInfo Class | DelegateTypeInfo Members | System.ComponentModel.Design.CodeModel Namespace


DelegateTypeInfo.ReturnType

The return type of the delegate.

[Visual Basic]
Public ReadOnly Property ReturnType As ICodeClass
[C#]
public ICodeClass ReturnType {get;}
[C++]
public: __property ICodeClass* get_ReturnType();
[JScript]
public function get ReturnType() : ICodeClass;

Property Value

An ICodeClass object representing the return type of the delegate.

See Also

DelegateTypeInfo Class | DelegateTypeInfo Members | System.ComponentModel.Design.CodeModel Namespace


ICodeArrayCreateExpression Interface

Represents an array creation expression.

ICodeArrayCreateExpression

[Visual Basic]
Public Interface ICodeArrayCreateExpression
   Implements ICodeElement
[C#]
public interface ICodeArrayCreateExpression : ICodeElement
[C++]
public __gc __interface ICodeArrayCreateExpression : public
   ICodeElement

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

Each item in the Items property can be any of the expression objects. See the documentation for ICodeSourceFile for more information.

Requirements

Namespace: System.ComponentModel.Design.CodeModel

Assembly: System.dll

See Also

ICodeArrayCreateExpression Members | System.ComponentModel.Design.CodeModel Namespace | ICodeClass | ICodeSourceFile


ICodeArrayCreateExpression Members

Methods

GetArrayType | Gets the class or base class of each element in the array.
GetItems | Gets the items in the array.
SetArrayType | Sets the class or base class of each element in the array.
SetItems | Sets the items in the array.

See Also

ICodeArrayCreateExpression Interface | System.ComponentModel.Design.CodeModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeArrayCreateExpression Methods

The methods of the ICodeArrayCreateExpression interface are listed below. For a complete list of ICodeArrayCreateExpression interface members, see the ICodeArrayCreateExpression Members topic.

GetArrayType | Gets the class or base class of each element in the array.
GetItems | Gets the items in the array.
SetArrayType | Sets the class or base class of each element in the array.
SetItems | Sets the items in the array.

See Also

ICodeArrayCreateExpression Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeArrayCreateExpression.GetArrayType

Gets the class or base class of each element in the array.

[Visual Basic]
Function GetArrayType() As ICodeClass
[C#]
ICodeClass GetArrayType();
[C++]
ICodeClass* GetArrayType() = 0;
[JScript]
function GetArrayType() : ICodeClass;

Return Value

An ICodeClass object representing the type of the array elements.

See Also

ICodeArrayCreateExpression Interface | ICodeArrayCreateExpression Members | System.ComponentModel.Design.CodeModel Namespace


ICodeArrayCreateExpression.GetItems

Gets the items in the array.

[Visual Basic]
Function GetItems() As Object ()
[C#]
object[] GetItems();
[C++]
Object* GetItems() [] = 0;
[JScript]
function GetItems() : Object[];

Return Value

An array of the objects in the array.

Remarks

Each object returned can be an object, or an object implementing one of the expression interfaces. See documentation for ICodeSourceFile for more information.

See Also

ICodeArrayCreateExpression Interface | ICodeArrayCreateExpression Members | System.ComponentModel.Design.CodeModel Namespace | ICodeSourceFile


ICodeArrayCreateExpression.SetArrayType

Sets the class or base class of each element in the array.

[Visual Basic]
Sub SetArrayType( _
   ByVal value As ICodeClass _
)
[C#]
void SetArrayType(
   ICodeClass value
);
[C++]
void SetArrayType(
   ICodeClass* value
) = 0;
[JScript]
function SetArrayType(
   value : ICodeClass
);

Parameters

value
An ICodeClass that represents the class type to set for the elements of the array.

See Also

ICodeArrayCreateExpression Interface | ICodeArrayCreateExpression Members | System.ComponentModel.Design.CodeModel Namespace


ICodeArrayCreateExpression.SetItems

Sets the items in the array.

[Visual Basic]
Sub SetItems( _
   ByVal value() As Object _
)
[C#]
void SetItems(
   object[] value
);
[C++]
void SetItems(
   Object* value[]
) = 0;
[JScript]
function SetItems(
   value : Object[]
);

Parameters

value
An array of objects.

Remarks

Each object returned can be an object, or an object implementing one of the expression interfaces. See documentation for ICodeSourceFile for more information.

See Also

ICodeArrayCreateExpression Interface | ICodeArrayCreateExpression Members | System.ComponentModel.Design.CodeModel Namespace | ICodeSourceFile


ICodeBlockComment Interface

Represents a block comment in the code.

[Visual Basic]
Public Interface ICodeBlockComment
   Implements ICodeStatement, ICodeElement
[C#]
public interface ICodeBlockComment : ICodeStatement, ICodeElement
[C++]
public __gc __interface ICodeBlockComment : public ICodeStatement,
   ICodeElement

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design.CodeModel

Assembly: System.dll

See Also

ICodeBlockComment Members | System.ComponentModel.Design.CodeModel Namespace


ICodeBlockComment Members

Methods

GetText | Gets the contents of the comment.
SetText | Sets the contents of the comment.

See Also

ICodeBlockComment Interface | System.ComponentModel.Design.CodeModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeBlockComment Methods

The methods of the ICodeBlockComment interface are listed below. For a complete list of ICodeBlockComment interface members, see the ICodeBlockComment Members topic.

GetText | Gets the contents of the comment.
SetText | Sets the contents of the comment.

See Also

ICodeBlockComment Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeBlockComment.GetText

Gets the contents of the comment.

[Visual Basic]
Function GetText() As String
[C#]
string GetText();
[C++]
String* GetText() = 0;
[JScript]
function GetText() : String;

Return Value

A string containing the block comment.

Remarks

No comment indicators should be retrieved (such as "//" or "/*").

See Also

ICodeBlockComment Interface | ICodeBlockComment Members | System.ComponentModel.Design.CodeModel Namespace


ICodeBlockComment.SetText

Sets the contents of the comment.

[Visual Basic]
Sub SetText( _
   ByVal value As String _
)
[C#]
void SetText(
   string value
);
[C++]
void SetText(
   String* value
) = 0;
[JScript]
function SetText(
   value : String
);

Parameters

value
A string specifying the contents of the comment.

Remarks

No comment indicators should be used (such as, "//" or "/*").

See Also

ICodeBlockComment Interface | ICodeBlockComment Members | System.ComponentModel.Design.CodeModel Namespace


ICodeClass Interface

Represents a single class.

[Visual Basic]
Public Interface ICodeClass
   Implements ICodeMember, ICodeElement
[C#]
public interface ICodeClass : ICodeMember, ICodeElement
[C++]
public __gc __interface ICodeClass : public ICodeMember,
   ICodeElement

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

Each class to be represented can have a single superclass and implement multiple interfaces. In addition each class is scoped by a namespace and has a name associated with it. The FullName property retrieves the namespace and name of the class, from which you can use NGWS runtime reflection to get a class object from. The members collection contains all the members of the class, including any nested classes. Several helper functions exist to retrieve subsets of the members collection like FindAllProperties or FindAllDataMembers.

Requirements

Namespace: System.ComponentModel.Design.CodeModel

Assembly: System.dll

See Also

ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace | ICodeConstructor | ICodeDataMember | ICodeMethod | ICodeProperty | ICodeConstructor | ICodeDataMember | ICodeMethod | ICodeProperty


ICodeClass Members

Properties

BaseClass | The base class that the class derives from.
FullName | The namespace and name of the class.

Methods

ClassForName | Creates an ICodeClass object representing the class with the name specified.
CreateDataMember | Creates an ICodeDataMember object to represent a data member in the class.
CreateDataMemberAfter | Creates an ICodeDataMember object representing a data member in the class and positions it immediately following the specified element.
CreateDataMemberBefore | Creates an ICodeDataMember object representing a data member in the class and positions it immediately before the element specified.
CreateDataMemberFirst | Creates an ICodeDataMember object representing a data member in the class and positions it in the first available location.
CreateDataMemberLast | Creates an ICodeDataMember object representing a data member in the class and positions it in the last available location.
CreateMethod | Creates an ICodeMethod object representing a method in the class.
CreateMethodAfter | Creates an ICodeMethod object representing a method in the class and positions it immediately after the specified element.
CreateMethodBefore | Creates an ICodeMethod object representing a method in the class and positions it immediately before the specified element.
CreateMethodFirst | Creates an ICodeMethod object representing a method in the class and positions it in the first available location.
CreateMethodLast | Creates an ICodeMethod object representing a method in the class and positions it in the last available location.
FindAllDataMembers | Finds all data members of the class.
FindAllMethods | Finds all methods declared in this class.
FindAllProperties | Finds all properties declared in the class.
FindDataMember | Overloaded. Finds the data member in the class that has the specified name, type, and modifiers.
FindDataMembers | Finds the data members in the class matching the specified type.
FindDataMembersDerivedFrom | Finds the data members in the class whose type is derived from the specified type.
FindMethod | Overloaded. Finds the method in the class with the specified name, arguments, return type, and modifiers.
FindMethods | Overloaded. Finds all the methods in the class with the specified arguments and return type.
FindProperties | Overloaded. Finds all properties in the class with the specified name.
FindProperty | Finds the property of the class that has the specified name, type, and modifiers.
GetInterfaces | Gets all the interfaces that the class implements.
GetMembers | Gets the collection of members that the class contains.
GetNamespace | Gets the namespace that the class is in.
IsInterface | Gets whether or not this object represents an interface rather than a true class.
SetInterfaces | Sets all the interfaces that the class implements.
SetNamespace | Sets the namespace that the class is in.

See Also

ICodeClass Interface | System.ComponentModel.Design.CodeModel Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeClass Properties

The properties of the ICodeClass interface are listed below. For a complete list of ICodeClass interface members, see the ICodeClass Members topic.

BaseClass | The base class that the class derives from.
FullName | The namespace and name of the class.

See Also

ICodeClass Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeClass.BaseClass

The base class that the class derives from.

[Visual Basic]
Property BaseClass As ICodeClass
[C#]
ICodeClass BaseClass {get; set;}
[C++]
ICodeClass* get_BaseClass() = 0;void set_BaseClass(ICodeClass*) = 0;
[JScript]
abstract function get BaseClass() : ICodeClass;
public abstract function set BaseClass(ICodeClass);

Property Value

An ICodeClass object indicating the base class for the class being represented.

Remarks

All classes, except Object, derive from Object. This property will return a null reference (in Visual Basic Nothing) if the class is Object.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace


ICodeClass.FullName

The namespace and name of the class.

[Visual Basic]
ReadOnly Property FullName As String
[C#]
string FullName {get;}
[C++]
String* get_FullName() = 0;
[JScript]
abstract function get FullName() : String;

Property Value

A string containing the namespace and name of the class.

Example

This value can be used by NGWS runtime reflection to obtain a Class reference:

public Class GetClassFromCodeClass(ICodeClass cls) {
    return Class.GetClass(cls.GetFullName());
    }

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeClass Methods

The methods of the ICodeClass interface are listed below. For a complete list of ICodeClass interface members, see the ICodeClass Members topic.

ClassForName | Creates an ICodeClass object representing the class with the name specified.
CreateDataMember | Creates an ICodeDataMember object to represent a data member in the class.
CreateDataMemberAfter | Creates an ICodeDataMember object representing a data member in the class and positions it immediately following the specified element.
CreateDataMemberBefore | Creates an ICodeDataMember object representing a data member in the class and positions it immediately before the element specified.
CreateDataMemberFirst | Creates an ICodeDataMember object representing a data member in the class and positions it in the first available location.
CreateDataMemberLast | Creates an ICodeDataMember object representing a data member in the class and positions it in the last available location.
CreateMethod | Creates an ICodeMethod object representing a method in the class.
CreateMethodAfter | Creates an ICodeMethod object representing a method in the class and positions it immediately after the specified element.
CreateMethodBefore | Creates an ICodeMethod object representing a method in the class and positions it immediately before the specified element.
CreateMethodFirst | Creates an ICodeMethod object representing a method in the class and positions it in the first available location.
CreateMethodLast | Creates an ICodeMethod object representing a method in the class and positions it in the last available location.
FindAllDataMembers | Finds all data members of the class.
FindAllMethods | Finds all methods declared in this class.
FindAllProperties | Finds all properties declared in the class.
FindDataMember | Overloaded. Finds the data member in the class that has the specified name, type, and modifiers.
FindDataMembers | Finds the data members in the class matching the specified type.
FindDataMembersDerivedFrom | Finds the data members in the class whose type is derived from the specified type.
FindMethod | Overloaded. Finds the method in the class with the specified name, arguments, return type, and modifiers.
FindMethods | Overloaded. Finds all the methods in the class with the specified arguments and return type.
FindProperties | Overloaded. Finds all properties in the class with the specified name.
FindProperty | Finds the property of the class that has the specified name, type, and modifiers.
GetInterfaces | Gets all the interfaces that the class implements.
GetMembers | Gets the collection of members that the class contains.
GetNamespace | Gets the namespace that the class is in.
IsInterface | Gets whether or not this object represents an interface rather than a true class.
SetInterfaces | Sets all the interfaces that the class implements.
SetNamespace | Sets the namespace that the class is in.

See Also

ICodeClass Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeClass.ClassForName

Creates an ICodeClass object representing the class with the name specified.

[Visual Basic]
Function ClassForName( _
   ByVal className As String _
) As ICodeClass
[C#]
ICodeClass ClassForName(
   string className
);
[C++]
ICodeClass* ClassForName(
   String* className
) = 0;
[JScript]
function ClassForName(
   className : String
) : ICodeClass;

Parameters

className
The name of the class to represent with an ICodeClass object.

Return Value

An ICodeClass object for the specified class.

Remarks

This method takes into account any imports or namespaces that the specified class uses. It looks these up using the same rules that the compiler would use.

Note Calling ClassForName twice with the same name will not return the same instance of the ICodeClass object. Each request to ClassForName will generate a new object.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace


ICodeClass.CreateDataMember

Creates an ICodeDataMember object to represent a data member in the class.

[Visual Basic]
Function CreateDataMember( _
   ByVal name As String, _
   ByVal type As ICodeClass, _
   ByVal modifiers As Integer, _
   ByVal value As Object _
) As ICodeDataMember
[C#]
ICodeDataMember CreateDataMember(
   string name,
   ICodeClass type,
   int modifiers,
   object value
);
[C++]
ICodeDataMember* CreateDataMember(
   String* name,
   ICodeClass* type,
   int modifiers,
   Object* value
) = 0;
[JScript]
function CreateDataMember(
   name : String,
   type : ICodeClass,
   modifiers : int,
   value : Object
) : ICodeDataMember;

Parameters

name
The name of the data member.
type
An ICodeClass that represents the class of the data member.
modifiers
The access modifiers for the data member.
value
The initialization expression for the data member. The member will not be initialized if a null reference (in Visual Basic Nothing) is passed in.

Return Value

An ICodeDataMember object for the specified parameters.

Remarks

The ICodeDataMember will be positioned in the first available location.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace | ICodeDataMember | MemberModifier


ICodeClass.CreateDataMemberAfter

Creates an ICodeDataMember object representing a data member in the class and positions it immediately following the specified element.

[Visual Basic]
Function CreateDataMemberAfter( _
   ByVal name As String, _
   ByVal type As ICodeClass, _
   ByVal modifiers As Integer, _
   ByVal value As Object, _
   ByVal relativeTo As ICodeMember _
) As ICodeDataMember
[C#]
ICodeDataMember CreateDataMemberAfter(
   string name,
   ICodeClass type,
   int modifiers,
   object value,
   ICodeMember relativeTo
);
[C++]
ICodeDataMember* CreateDataMemberAfter(
   String* name,
   ICodeClass* type,
   int modifiers,
   Object* value,
   ICodeMember* relativeTo
) = 0;
[JScript]
function CreateDataMemberAfter(
   name : String,
   type : ICodeClass,
   modifiers : int,
   value : Object,
   relativeTo : ICodeMember
) : ICodeDataMember;

Parameters

name
The name of the data member.
type
An ICodeClass that represents the class of the data member.
modifiers
The access modifiers for the data member.
value
The initialization expression for the data member. The member will not be initialized if a null reference (in Visual Basic Nothing) is passed in.
relativeTo
The ICodeMember to place this element after.

Return Value

An ICodeDataMember object for the specified parameters.

Remarks

The ICodeDataMember will be positioned immediately following the element specified by the relativeTo parameter.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace | ICodeDataMember | MemberModifier


ICodeClass.CreateDataMemberBefore

Creates an ICodeDataMember object representing a data member in the class and positions it immediately before the element specified.

[Visual Basic]
Function CreateDataMemberBefore( _
   ByVal name As String, _
   ByVal type As ICodeClass, _
   ByVal modifiers As Integer, _
   ByVal value As Object, _
   ByVal relativeTo As ICodeMember _
) As ICodeDataMember
[C#]
ICodeDataMember CreateDataMemberBefore(
   string name,
   ICodeClass type,
   int modifiers,
   object value,
   ICodeMember relativeTo
);
[C++]
ICodeDataMember* CreateDataMemberBefore(
   String* name,
   ICodeClass* type,
   int modifiers,
   Object* value,
   ICodeMember* relativeTo
) = 0;
[JScript]
function CreateDataMemberBefore(
   name : String,
   type : ICodeClass,
   modifiers : int,
   value : Object,
   relativeTo : ICodeMember
) : ICodeDataMember;

Parameters

name
The name of the data member.
type
An ICodeClass that represents the class of the data member.
modifiers
The access modifiers for the data member.
value
The initialization expression for the data member. The member will not be initialized if a null reference (in Visual Basic Nothing) is passed in.
relativeTo
The ICodeMember to place this element before.

Return Value

An ICodeDataMember object for the specified parameters.

Remarks

The ICodeDataMember will be positioned immediately before the element specified by the relativeTo parameter.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace | ICodeDataMember | MemberModifier


ICodeClass.CreateDataMemberFirst

Creates an ICodeDataMember object representing a data member in the class and positions it in the first available location.

[Visual Basic]
Function CreateDataMemberFirst( _
   ByVal name As String, _
   ByVal type As ICodeClass, _
   ByVal modifiers As Integer, _
   ByVal value As Object _
) As ICodeDataMember
[C#]
ICodeDataMember CreateDataMemberFirst(
   string name,
   ICodeClass type,
   int modifiers,
   object value
);
[C++]
ICodeDataMember* CreateDataMemberFirst(
   String* name,
   ICodeClass* type,
   int modifiers,
   Object* value
) = 0;
[JScript]
function CreateDataMemberFirst(
   name : String,
   type : ICodeClass,
   modifiers : int,
   value : Object
) : ICodeDataMember;

Parameters

name
The name of the data member.
type
An ICodeClass that represents the class of the data member.
modifiers
The access modifiers for the data member.
value
The initialization expression for the data member. The member will not be initialized if a null reference (in Visual Basic Nothing) is passed in.

Return Value

An ICodeDataMember object for the specified parameters.

Remarks

The ICodeDataMember will be positioned in the first available location.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace | ICodeDataMember | MemberModifier


ICodeClass.CreateDataMemberLast

Creates an ICodeDataMember object representing a data member in the class and positions it in the last available location.

[Visual Basic]
Function CreateDataMemberLast( _
   ByVal name As String, _
   ByVal type As ICodeClass, _
   ByVal modifiers As Integer, _
   ByVal value As Object _
) As ICodeDataMember
[C#]
ICodeDataMember CreateDataMemberLast(
   string name,
   ICodeClass type,
   int modifiers,
   object value
);
[C++]
ICodeDataMember* CreateDataMemberLast(
   String* name,
   ICodeClass* type,
   int modifiers,
   Object* value
) = 0;
[JScript]
function CreateDataMemberLast(
   name : String,
   type : ICodeClass,
   modifiers : int,
   value : Object
) : ICodeDataMember;

Parameters

name
The name of the data member.
type
An ICodeClass that represents the class of the data member.
modifiers
The access modifiers for the data member.
value
The initialization expression for the data member. The member will not be initialized if a null reference (in Visual Basic Nothing) is passed in.

Return Value

An ICodeDataMember object for the specified parameters.

Remarks

The ICodeDataMember will be positioned in the last available location.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace | ICodeDataMember | MemberModifier


ICodeClass.CreateMethod

Creates an ICodeMethod object representing a method in the class.

[Visual Basic]
Function CreateMethod( _
   ByVal name As String, _
   ByVal arguments() As ICodeParameter, _
   ByVal returnType As ICodeClass, _
   ByVal modifiers As Integer _
) As ICodeMethod
[C#]
ICodeMethod CreateMethod(
   string name,
   ICodeParameter[] arguments,
   ICodeClass returnType,
   int modifiers
);
[C++]
ICodeMethod* CreateMethod(
   String* name,
   ICodeParameter* arguments[],
   ICodeClass* returnType,
   int modifiers
) = 0;
[JScript]
function CreateMethod(
   name : String,
   arguments : ICodeParameter[],
   returnType : ICodeClass,
   modifiers : int
) : ICodeMethod;

Parameters

name
The name of the method.
arguments
An array of type ICodeParameter that represents the method's parameters. Although only the value portion of the parameter is required, languages such as Visual Basic may support using named arguments.
returnType
An ICodeClass that represents the type returned from the method.
modifiers
The access modifiers for the method.

Return Value

An ICodeMethod object containing the specified parameters.

Remarks

The ICodeMethod will be positioned in the first available location.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace | ICodeMethod | ICodeParameter | MemberModifier


ICodeClass.CreateMethodAfter

Creates an ICodeMethod object representing a method in the class and positions it immediately after the specified element.

[Visual Basic]
Function CreateMethodAfter( _
   ByVal name As String, _
   ByVal arguments() As ICodeParameter, _
   ByVal returnType As ICodeClass, _
   ByVal modifiers As Integer, _
   ByVal relativeTo As ICodeMember _
) As ICodeMethod
[C#]
ICodeMethod CreateMethodAfter(
   string name,
   ICodeParameter[] arguments,
   ICodeClass returnType,
   int modifiers,
   ICodeMember relativeTo
);
[C++]
ICodeMethod* CreateMethodAfter(
   String* name,
   ICodeParameter* arguments[],
   ICodeClass* returnType,
   int modifiers,
   ICodeMember* relativeTo
) = 0;
[JScript]
function CreateMethodAfter(
   name : String,
   arguments : ICodeParameter[],
   returnType : ICodeClass,
   modifiers : int,
   relativeTo : ICodeMember
) : ICodeMethod;

Parameters

name
The name of the method.
arguments
An array of type ICodeParameter that represents the method's parameters. Although only the value portion of the parameter is required, languages such as Visual Basic may support using named arguments.
returnType
An ICodeClass that represents the data type returned from the method.
modifiers
The access modifiers for the method.
relativeTo
The ICodeMethod to place the method after.

Return Value

An ICodeMethod object containing the specified parameters.

Remarks

The ICodeMethod will be positioned immediately after the element specified by the relativeTo parameter.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace | ICodeMethod | ICodeParameter | MemberModifier


ICodeClass.CreateMethodBefore

Creates an ICodeMethod object representing a method in the class and positions it immediately before the specified element.

[Visual Basic]
Function CreateMethodBefore( _
   ByVal name As String, _
   ByVal arguments() As ICodeParameter, _
   ByVal returnType As ICodeClass, _
   ByVal modifiers As Integer, _
   ByVal relativeTo As ICodeMember _
) As ICodeMethod
[C#]
ICodeMethod CreateMethodBefore(
   string name,
   ICodeParameter[] arguments,
   ICodeClass returnType,
   int modifiers,
   ICodeMember relativeTo
);
[C++]
ICodeMethod* CreateMethodBefore(
   String* name,
   ICodeParameter* arguments[],
   ICodeClass* returnType,
   int modifiers,
   ICodeMember* relativeTo
) = 0;
[JScript]
function CreateMethodBefore(
   name : String,
   arguments : ICodeParameter[],
   returnType : ICodeClass,
   modifiers : int,
   relativeTo : ICodeMember
) : ICodeMethod;

Parameters

name
The name of the method.
arguments
An array of type ICodeParameter that represents the method's parameters. Although only the value portion of the parameter is required, languages such as Visual Basic may support using named arguments.
returnType
An ICodeClass that represents the data type returned from the method.
modifiers
The access modifiers for the method.
relativeTo
The ICodeMethod to place the method before.

Return Value

An ICodeMethod object containing the specified parameters.

Remarks

The ICodeMethod will be positioned immediately before the element specified by the relativeTo parameter.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace | ICodeMethod | ICodeParameter | MemberModifier


ICodeClass.CreateMethodFirst

Creates an ICodeMethod object representing a method in the class and positions it in the first available location.

[Visual Basic]
Function CreateMethodFirst( _
   ByVal name As String, _
   ByVal arguments() As ICodeParameter, _
   ByVal returnType As ICodeClass, _
   ByVal modifiers As Integer _
) As ICodeMethod
[C#]
ICodeMethod CreateMethodFirst(
   string name,
   ICodeParameter[] arguments,
   ICodeClass returnType,
   int modifiers
);
[C++]
ICodeMethod* CreateMethodFirst(
   String* name,
   ICodeParameter* arguments[],
   ICodeClass* returnType,
   int modifiers
) = 0;
[JScript]
function CreateMethodFirst(
   name : String,
   arguments : ICodeParameter[],
   returnType : ICodeClass,
   modifiers : int
) : ICodeMethod;

Parameters

name
The name of the method.
arguments
An array of type ICodeParameter that represents the method's parameters. Although only the value portion of the parameter is required, languages such as Visual Basic may support using named arguments.
returnType
An ICodeClass that represents the data type returned from the method.
modifiers
The access modifiers for the method.

Return Value

An ICodeMethod object containing the specified parameters.

Remarks

The ICodeMethod will be positioned in the first available location.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace | ICodeMethod | ICodeParameter | MemberModifier


ICodeClass.CreateMethodLast

Creates an ICodeMethod object representing a method in the class and positions it in the last available location.

[Visual Basic]
Function CreateMethodLast( _
   ByVal name As String, _
   ByVal arguments() As ICodeParameter, _
   ByVal returnType As ICodeClass, _
   ByVal modifiers As Integer _
) As ICodeMethod
[C#]
ICodeMethod CreateMethodLast(
   string name,
   ICodeParameter[] arguments,
   ICodeClass returnType,
   int modifiers
);
[C++]
ICodeMethod* CreateMethodLast(
   String* name,
   ICodeParameter* arguments[],
   ICodeClass* returnType,
   int modifiers
) = 0;
[JScript]
function CreateMethodLast(
   name : String,
   arguments : ICodeParameter[],
   returnType : ICodeClass,
   modifiers : int
) : ICodeMethod;

Parameters

name
The name of the method.
arguments
An array of type ICodeParameter that represents the method's parameters. Although only the value portion of the parameter is required, languages such as Visual Basic may support using named arguments.
returnType
An ICodeClass that represents the data type returned from the method.
modifiers
The access modifiers for the method.

Return Value

An ICodeMethod object containing the specified parameters.

Remarks

The ICodeMethod will be positioned in the last available location.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace | ICodeMethod | ICodeParameter | MemberModifier


ICodeClass.FindAllDataMembers

Finds all data members of the class.

[Visual Basic]
Function FindAllDataMembers() As ICodeDataMember ()
[C#]
ICodeDataMember[] FindAllDataMembers();
[C++]
ICodeDataMember* FindAllDataMembers() [] = 0;
[JScript]
function FindAllDataMembers() : ICodeDataMember[];

Return Value

An array of type ICodeDataMember representing all of the data members in the class. If no matching data member is found, a null reference (in Visual Basic Nothing) is returned.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace


ICodeClass.FindAllMethods

Finds all methods declared in this class.

[Visual Basic]
Function FindAllMethods() As ICodeMethod ()
[C#]
ICodeMethod[] FindAllMethods();
[C++]
ICodeMethod* FindAllMethods() [] = 0;
[JScript]
function FindAllMethods() : ICodeMethod[];

Return Value

An array of type ICodeMethod representing all of the methods in the class. If no methods are found, a null reference (in Visual Basic Nothing) is returned.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace


ICodeClass.FindAllProperties

Finds all properties declared in the class.

[Visual Basic]
Function FindAllProperties() As ICodeProperty ()
[C#]
ICodeProperty[] FindAllProperties();
[C++]
ICodeProperty* FindAllProperties() [] = 0;
[JScript]
function FindAllProperties() : ICodeProperty[];

Return Value

An array of type ICodeProperty representing all the properties in the class. If no properties are found, a null reference (in Visual Basic Nothing) is returned.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace


ICodeClass.FindDataMember

Finds the data member in the class that has the specified name, type, and modifiers.

Overload List

Finds the data member in the class with the specified name.

[Visual Basic] Overloads Function FindDataMember(String) As ICodeDataMember
[C#] ICodeDataMember FindDataMember(String);
[C++] ICodeDataMember* FindDataMember(String*) = 0;
[JScript] function FindDataMember(String) : ICodeDataMember;

Finds the data member in the class that has the specified name, type, and modifiers.

[Visual Basic] Overloads Function FindDataMember(String, ICodeClass, Integer) As ICodeDataMember
[C#] ICodeDataMember FindDataMember(String, ICodeClass, int);
[C++] ICodeDataMember* FindDataMember(String*, ICodeClass, int) = 0;
[JScript] function FindDataMember(String, ICodeClass, int) : ICodeDataMember;

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace


ICodeClass.FindDataMember (String)

Finds the data member in the class with the specified name.

[Visual Basic]
Overloads Function FindDataMember( _
   ByVal name As String _
) As ICodeDataMember
[C#]
ICodeDataMember FindDataMember(
   string name
);
[C++]
ICodeDataMember* FindDataMember(
   String* name
) = 0;
[JScript]
function FindDataMember(
   name : String
) : ICodeDataMember;

Parameters

name
The name of the data member to find.

Return Value

An ICodeDataMember representing the data member in the class matching the specified name. If no matching data member is found, a null reference (in Visual Basic Nothing) is returned.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace | ICodeClass.FindDataMember Overload List


ICodeClass.FindDataMember (String, ICodeClass, Int32)

Finds the data member in the class that has the specified name, type, and modifiers.

[Visual Basic]
Overloads Function FindDataMember( _
   ByVal name As String, _
   ByVal type As ICodeClass, _
   ByVal modifiers As Integer _
) As ICodeDataMember
[C#]
ICodeDataMember FindDataMember(
   string name,
   ICodeClass type,
   int modifiers
);
[C++]
ICodeDataMember* FindDataMember(
   String* name,
   ICodeClass* type,
   int modifiers
) = 0;
[JScript]
function FindDataMember(
   name : String,
   type : ICodeClass,
   modifiers : int
) : ICodeDataMember;

Parameters

name
The name of the data member to find.
type
An ICodeClass representing the data type of the data member to find.
modifiers
The modifiers to search for, or MemberModifier.UNKNOWN if you don't want to specify the modifiers.

Return Value

An ICodeDataMember representing the data member in the class matching the specified member attributes. If no matching data member is found, a null reference (in Visual Basic Nothing) is returned.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace | ICodeClass.FindDataMember Overload List


ICodeClass.FindDataMembers

Finds the data members in the class matching the specified type.

[Visual Basic]
Function FindDataMembers( _
   ByVal type As ICodeClass _
) As ICodeDataMember ()
[C#]
ICodeDataMember[] FindDataMembers(
   ICodeClass type
);
[C++]
ICodeDataMember* FindDataMembers(
   ICodeClass* type
) [] = 0;
[JScript]
function FindDataMembers(
   type : ICodeClass
) : ICodeDataMember[];

Parameters

type
An ICodeClass representing the data type of the data member to search for.

Return Value

An array of type ICodeDataMember representing the data members in the class matching the specified type. If no matching data member is found, a null reference (in Visual Basic Nothing) is returned.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace


ICodeClass.FindDataMembersDerivedFrom

Finds the data members in the class whose type is derived from the specified type.

[Visual Basic]
Function FindDataMembersDerivedFrom( _
   ByVal type As ICodeClass _
) As ICodeDataMember ()
[C#]
ICodeDataMember[] FindDataMembersDerivedFrom(
   ICodeClass type
);
[C++]
ICodeDataMember* FindDataMembersDerivedFrom(
   ICodeClass* type
) [] = 0;
[JScript]
function FindDataMembersDerivedFrom(
   type : ICodeClass
) : ICodeDataMember[];

Parameters

type
An ICodeClass representing the data type to search for.

Return Value

An array of type ICodeDataMember representing the data members in the class that are derived from the specified class. If no matching data member is found, a null reference (in Visual Basic Nothing) is returned.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace


ICodeClass.FindMethod

Finds the method in the class with the specified name, arguments, return type, and modifiers.

Overload List

Finds the method in the class with the specified name, arguments, return type, and modifiers.

[Visual Basic] Overloads Function FindMethod(String, ICodeClass(), ICodeClass) As ICodeMethod
[C#] ICodeMethod FindMethod(String, ICodeClass[], ICodeClass);
[C++] ICodeMethod* FindMethod(String*, ICodeClass[], ICodeClass) = 0;
[JScript] function FindMethod(String, ICodeClass[], ICodeClass) : ICodeMethod;

Finds the method in the class with the specified name, arguments, return type, and modifiers.

[Visual Basic] Overloads Function FindMethod(String, ICodeClass(), ICodeClass, Integer) As ICodeMethod
[C#] ICodeMethod FindMethod(String, ICodeClass[], ICodeClass, int);
[C++] ICodeMethod* FindMethod(String*, ICodeClass[], ICodeClass, int) = 0;
[JScript] function FindMethod(String, ICodeClass[], ICodeClass, int) : ICodeMethod;

Finds the method in the class with the specified name, arguments, and return type.

[Visual Basic] Overloads Function FindMethod(String, ICodeParameter(), ICodeClass) As ICodeMethod
[C#] ICodeMethod FindMethod(String, ICodeParameter[], ICodeClass);
[C++] ICodeMethod* FindMethod(String*, ICodeParameter[], ICodeClass) = 0;
[JScript] function FindMethod(String, ICodeParameter[], ICodeClass) : ICodeMethod;

Finds the method in the class with the specified name, arguments, return type, and modifiers.

[Visual Basic] Overloads Function FindMethod(String, ICodeParameter(), ICodeClass, Integer) As ICodeMethod
[C#] ICodeMethod FindMethod(String, ICodeParameter[], ICodeClass, int);
[C++] ICodeMethod* FindMethod(String*, ICodeParameter[], ICodeClass, int) = 0;
[JScript] function FindMethod(String, ICodeParameter[], ICodeClass, int) : ICodeMethod;

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace


ICodeClass.FindMethod (String, ICodeClass[], ICodeClass)

Finds the method in the class with the specified name, arguments, return type, and modifiers.

[Visual Basic]
Overloads Function FindMethod( _
   ByVal name As String, _
   ByVal arguments() As ICodeClass, _
   ByVal returnType As ICodeClass _
) As ICodeMethod
[C#]
ICodeMethod FindMethod(
   string name,
   ICodeClass[] arguments,
   ICodeClass returnType
);
[C++]
ICodeMethod* FindMethod(
   String* name,
   ICodeClass* arguments[],
   ICodeClass* returnType
) = 0;
[JScript]
function FindMethod(
   name : String,
   arguments : ICodeClass[],
   returnType : ICodeClass
) : ICodeMethod;

Parameters

name
The name of the method to find.
arguments
An array of type ICodeClass that represents the classes of the arguments to search for.
returnType
An ICodeClass that represents the return type of the method to find.

Return Value

An ICodeMethod object representing the method in the class matching the specified parameters. If no matching method is found, a null reference (in Visual Basic Nothing) is returned.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace | ICodeClass.FindMethod Overload List


ICodeClass.FindMethod (String, ICodeClass[], ICodeClass, Int32)

Finds the method in the class with the specified name, arguments, return type, and modifiers.

[Visual Basic]
Overloads Function FindMethod( _
   ByVal name As String, _
   ByVal arguments() As ICodeClass, _
   ByVal returnType As ICodeClass, _
   ByVal modifiers As Integer _
) As ICodeMethod
[C#]
ICodeMethod FindMethod(
   string name,
   ICodeClass[] arguments,
   ICodeClass returnType,
   int modifiers
);
[C++]
ICodeMethod* FindMethod(
   String* name,
   ICodeClass* arguments[],
   ICodeClass* returnType,
   int modifiers
) = 0;
[JScript]
function FindMethod(
   name : String,
   arguments : ICodeClass[],
   returnType : ICodeClass,
   modifiers : int
) : ICodeMethod;

Parameters

name
The name of the method to find.
arguments
An array of type ICodeClass that represents the classes of the arguments to search for.
returnType
An ICodeClass that represents the return type of the method to find.
modifiers
The modifiers to search for, or MemberModifier.UNKNOWN if you don't want to specify the modifiers.

Return Value

An ICodeMethod object representing the method in the class matching the specified parameters. If no matching method is found, a null reference (in Visual Basic Nothing) is returned.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace | ICodeClass.FindMethod Overload List


ICodeClass.FindMethod (String, ICodeParameter[], ICodeClass)

Finds the method in the class with the specified name, arguments, and return type.

[Visual Basic]
Overloads Function FindMethod( _
   ByVal name As String, _
   ByVal arguments() As ICodeParameter, _
   ByVal returnType As ICodeClass _
) As ICodeMethod
[C#]
ICodeMethod FindMethod(
   string name,
   ICodeParameter[] arguments,
   ICodeClass returnType
);
[C++]
ICodeMethod* FindMethod(
   String* name,
   ICodeParameter* arguments[],
   ICodeClass* returnType
) = 0;
[JScript]
function FindMethod(
   name : String,
   arguments : ICodeParameter[],
   returnType : ICodeClass
) : ICodeMethod;

Parameters

name
The name of the method to find.
arguments
An array of type ICodeParameter that represents the arguments of the method to find.
returnType
An ICodeClass representing the return type of the method to find.

Return Value

An ICodeMethod object representing the method in the class matching the specified parameters. If no matching method is found, a null reference (in Visual Basic Nothing) is returned.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace | ICodeClass.FindMethod Overload List


ICodeClass.FindMethod (String, ICodeParameter[], ICodeClass, Int32)

Finds the method in the class with the specified name, arguments, return type, and modifiers.

[Visual Basic]
Overloads Function FindMethod( _
   ByVal name As String, _
   ByVal arguments() As ICodeParameter, _
   ByVal returnType As ICodeClass, _
   ByVal modifiers As Integer _
) As ICodeMethod
[C#]
ICodeMethod FindMethod(
   string name,
   ICodeParameter[] arguments,
   ICodeClass returnType,
   int modifiers
);
[C++]
ICodeMethod* FindMethod(
   String* name,
   ICodeParameter* arguments[],
   ICodeClass* returnType,
   int modifiers
) = 0;
[JScript]
function FindMethod(
   name : String,
   arguments : ICodeParameter[],
   returnType : ICodeClass,
   modifiers : int
) : ICodeMethod;

Parameters

name
The name of the method to find.
arguments
An array of type ICodeParameter that represents the arguments of the method to find.
returnType
An ICodeClass representing the return type of the method to find.
modifiers
The modifiers to search for, or MemberModifier.UNKNOWN if you don't want to specify the modifiers.

Return Value

An ICodeMethod object representing the method in the class matching the specified parameters. If no matching method is found, a null reference (in Visual Basic Nothing) is returned.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace | ICodeClass.FindMethod Overload List


ICodeClass.FindMethods

Finds all the methods in the class with the specified arguments and return type.

Overload List

Finds all the methods in the class with the specified arguments and return type.

[Visual Basic] Overloads Function FindMethods(ICodeParameter(), ICodeClass) As ICodeMethod ()
[C#] ICodeMethod[] FindMethods(ICodeParameter[], ICodeClass);
[C++] ICodeMethod* FindMethods(ICodeParameter*[], ICodeClass) [] = 0;
[JScript] function FindMethods(ICodeParameter[], ICodeClass) : ICodeMethod[];

Finds all the methods with the specified argument types and return type.

[Visual Basic] Overloads Function FindMethods(ICodeClass(), ICodeClass) As ICodeMethod ()
[C#] ICodeMethod[] FindMethods(ICodeClass[], ICodeClass);
[C++] ICodeMethod* FindMethods(ICodeClass*[], ICodeClass*) [] = 0;
[JScript] function FindMethods(ICodeClass[], ICodeClass) : ICodeMethod[];

Finds all the methods with the specified name.

[Visual Basic] Overloads Function FindMethods(String) As ICodeMethod ()
[C#] ICodeMethod[] FindMethods(String);
[C++] ICodeMethod* FindMethods(String*) [] = 0;
[JScript] function FindMethods(String) : ICodeMethod[];

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace


ICodeClass.FindMethods (ICodeParameter[], ICodeClass)

Finds all the methods in the class with the specified arguments and return type.

[Visual Basic]
Overloads Function FindMethods( _
   ByVal arguments() As ICodeParameter, _
   ByVal returnType As ICodeClass _
) As ICodeMethod ()
[C#]
ICodeMethod[] FindMethods(
   ICodeParameter[] arguments,
   ICodeClass returnType
);
[C++]
ICodeMethod* FindMethods(
   ICodeParameter* arguments[],
   ICodeClass* returnType
) [] = 0;
[JScript]
function FindMethods(
   arguments : ICodeParameter[],
   returnType : ICodeClass
) : ICodeMethod[];

Parameters

arguments
An array of type ICodeParameter that represents the arguments of the methods to find.
returnType
An ICodeClass that represents the return type of the methods to find.

Return Value

An array of type ICodeMethod representing the methods in the class matching the specified parameters. If no matching method is found, a null reference (in Visual Basic Nothing) is returned.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace | ICodeClass.FindMethods Overload List


ICodeClass.FindMethods (ICodeClass[], ICodeClass)

Finds all the methods with the specified argument types and return type.

[Visual Basic]
Overloads Function FindMethods( _
   ByVal arguments() As ICodeClass, _
   ByVal returnType As ICodeClass _
) As ICodeMethod ()
[C#]
ICodeMethod[] FindMethods(
   ICodeClass[] arguments,
   ICodeClass returnType
);
[C++]
ICodeMethod* FindMethods(
   ICodeClass* arguments[],
   ICodeClass* returnType
) [] = 0;
[JScript]
function FindMethods(
   arguments : ICodeClass[],
   returnType : ICodeClass
) : ICodeMethod[];

Parameters

arguments
An array of type ICodeClass that represents the classes of the arguments to search for.
returnType
An ICodeClass that represents the return type of the methods to find.

Return Value

An array of type ICodeMethod representing the methods in the class matching the specified parameters. If no matching method is found, a null reference (in Visual Basic Nothing) is returned.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace | ICodeClass.FindMethods Overload List


ICodeClass.FindMethods (String)

Finds all the methods with the specified name.

[Visual Basic]
Overloads Function FindMethods( _
   ByVal name As String _
) As ICodeMethod ()
[C#]
ICodeMethod[] FindMethods(
   string name
);
[C++]
ICodeMethod* FindMethods(
   String* name
) [] = 0;
[JScript]
function FindMethods(
   name : String
) : ICodeMethod[];

Parameters

name
The name of the methods to find.

Return Value

An array of type ICodeMethod representing the methods in the class matching the specified parameters. If no matching method is found, a null reference (in Visual Basic Nothing) is returned.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace | ICodeClass.FindMethods Overload List


ICodeClass.FindProperties

Finds all properties in the class with the specified name.

Overload List

Finds all properties in the class with the specified name.

[Visual Basic] Overloads Function FindProperties(String) As ICodeProperty ()
[C#] ICodeProperty[] FindProperties(String);
[C++] ICodeProperty* FindProperties(String*) [] = 0;
[JScript] function FindProperties(String) : ICodeProperty[];

Finds all properties in the class with the specified type.

[Visual Basic] Overloads Function FindProperties(ICodeClass) As ICodeProperty ()
[C#] ICodeProperty[] FindProperties(ICodeClass);
[C++] ICodeProperty* FindProperties(ICodeClass*) [] = 0;
[JScript] function FindProperties(ICodeClass) : ICodeProperty[];

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace


ICodeClass.FindProperties (String)

Finds all properties in the class with the specified name.

[Visual Basic]
Overloads Function FindProperties( _
   ByVal name As String _
) As ICodeProperty ()
[C#]
ICodeProperty[] FindProperties(
   string name
);
[C++]
ICodeProperty* FindProperties(
   String* name
) [] = 0;
[JScript]
function FindProperties(
   name : String
) : ICodeProperty[];

Parameters

name
The name of the property to search for.

Return Value

An array of type ICodeProperty representing the properties in the class matching the specified name. If no matching property is found, a null reference (in Visual Basic Nothing) is returned.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace | ICodeClass.FindProperties Overload List


ICodeClass.FindProperties (ICodeClass)

Finds all properties in the class with the specified type.

[Visual Basic]
Overloads Function FindProperties( _
   ByVal type As ICodeClass _
) As ICodeProperty ()
[C#]
ICodeProperty[] FindProperties(
   ICodeClass type
);
[C++]
ICodeProperty* FindProperties(
   ICodeClass* type
) [] = 0;
[JScript]
function FindProperties(
   type : ICodeClass
) : ICodeProperty[];

Parameters

type
An ICodeClass representing the data type of the property to search for.

Return Value

An array of type ICodeProperty representing the properties in the class matching the specified type. If no matching property is found, a null reference (in Visual Basic Nothing) is returned.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace | ICodeClass.FindProperties Overload List


ICodeClass.FindProperty

Finds the property of the class that has the specified name, type, and modifiers.

[Visual Basic]
Function FindProperty( _
   ByVal name As String, _
   ByVal type As ICodeClass, _
   ByVal modifiers As Integer _
) As ICodeProperty
[C#]
ICodeProperty FindProperty(
   string name,
   ICodeClass type,
   int modifiers
);
[C++]
ICodeProperty* FindProperty(
   String* name,
   ICodeClass* type,
   int modifiers
) = 0;
[JScript]
function FindProperty(
   name : String,
   type : ICodeClass,
   modifiers : int
) : ICodeProperty;

Parameters

name
The name of the property to find.
type
The data type of the property to find.
modifiers
The modifiers to search for, or MemberModifier.UNKNOWN if you don't want to specify the modifiers.

Return Value

An ICodeProperty representing the property of the class matching the specified property attributes. If no matching property is found, a null reference (in Visual Basic Nothing) is returned.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace


ICodeClass.GetInterfaces

Gets all the interfaces that the class implements.

[Visual Basic]
Function GetInterfaces() As ICodeClass ()
[C#]
ICodeClass[] GetInterfaces();
[C++]
ICodeClass* GetInterfaces() [] = 0;
[JScript]
function GetInterfaces() : ICodeClass[];

Return Value

An array of type ICodeClass listing the interface classes that the class implements.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace | System.ComponentModel.Design.CodeModelSetInterfaces.ICodeClass.SetInterfaces


ICodeClass.GetMembers

Gets the collection of members that the class contains.

[Visual Basic]
Function GetMembers() As ICodeMembers
[C#]
ICodeMembers GetMembers();
[C++]
ICodeMembers* GetMembers() = 0;
[JScript]
function GetMembers() : ICodeMembers;

Return Value

An ICodeMembers object representing the collection of members that the class contains.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace | ICodeMembers


ICodeClass.GetNamespace

Gets the namespace that the class is in.

[Visual Basic]
Function GetNamespace() As String
[C#]
string GetNamespace();
[C++]
String* GetNamespace() = 0;
[JScript]
function GetNamespace() : String;

Return Value

A string containing the namespace, or an empty string ("") if the class has no declared namespace.

Remarks

An empty string will be returned if the class has no declared namespace.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace | SetNamespace


ICodeClass.IsInterface

Gets whether or not this object represents an interface rather than a true class.

[Visual Basic]
Function IsInterface() As Boolean
[C#]
bool IsInterface();
[C++]
bool IsInterface() = 0;
[JScript]
function IsInterface() : Boolean;

Return Value

true if the class is an interface; false if the class is a true class.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace


ICodeClass.SetInterfaces

Sets all the interfaces that the class implements.

[Visual Basic]
Sub SetInterfaces( _
   ByVal value() As ICodeClass _
)
[C#]
void SetInterfaces(
   ICodeClass[] value
);
[C++]
void SetInterfaces(
   ICodeClass* value[]
) = 0;
[JScript]
function SetInterfaces(
   value : ICodeClass[]
);

Parameters

value
An array of type ICodeClass listing the interface classes that the class implements.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace | GetInterfaces


ICodeClass.SetNamespace

Sets the namespace that the class is in.

[Visual Basic]
Sub SetNamespace( _
   ByVal value As String _
)
[C#]
void SetNamespace(
   string value
);
[C++]
void SetNamespace(
   String* value
) = 0;
[JScript]
function SetNamespace(
   value : String
);

Parameters

value
The namespace for the class contained within a string.

See Also

ICodeClass Interface | ICodeClass Members | System.ComponentModel.Design.CodeModel Namespace | GetNamespace


ICodeClassImport Interface

Represents the import of a single class into the source file's namespace.

[Visual Basic]
Public Interface ICodeClassImport
   Implements ICodeStatement, ICodeElement
[C#]
public interface ICodeClassImport : ICodeStatement, ICodeElement
[C++]
public __gc __interface ICodeClassImport : public ICodeStatement,
   ICodeElement

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

Undone. Namespace representation isn't fixed. This API is likely to change drastically.

Requirements

Namespace: System.ComponentModel.Design.CodeModel

Assembly: System.dll

See Also

ICodeClassImport Members | System.ComponentModel.Design.CodeModel Namespace


ICodeClassImport Members

Methods

GetCodeType | Gets the class type that is being imported.
SetCodeType | Sets the class type that is being imported.

See Also

ICodeClassImport Interface | System.ComponentModel.Design.CodeModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeClassImport Methods

The methods of the ICodeClassImport interface are listed below. For a complete list of ICodeClassImport interface members, see the ICodeClassImport Members topic.

GetCodeType | Gets the class type that is being imported.
SetCodeType | Sets the class type that is being imported.

See Also

ICodeClassImport Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeClassImport.GetCodeType

Gets the class type that is being imported.

[Visual Basic]
Function GetCodeType() As ICodeClass
[C#]
ICodeClass GetCodeType();
[C++]
ICodeClass* GetCodeType() = 0;
[JScript]
function GetCodeType() : ICodeClass;

Return Value

An ICodeClass object that represents the type of class that is being imported.

See Also

ICodeClassImport Interface | ICodeClassImport Members | System.ComponentModel.Design.CodeModel Namespace


ICodeClassImport.SetCodeType

Sets the class type that is being imported.

[Visual Basic]
Sub SetCodeType( _
   ByVal value As ICodeClass _
)
[C#]
void SetCodeType(
   ICodeClass value
);
[C++]
void SetCodeType(
   ICodeClass* value
) = 0;
[JScript]
function SetCodeType(
   value : ICodeClass
);

Parameters

value
An ICodeClass that represents the type of the class to import.

See Also

ICodeClassImport Interface | ICodeClassImport Members | System.ComponentModel.Design.CodeModel Namespace


ICodeConstructor Interface

Represents a constructor in the class.

[Visual Basic]
Public Interface ICodeConstructor
   Implements ICodeMember, ICodeElement
[C#]
public interface ICodeConstructor : ICodeMember, ICodeElement
[C++]
public __gc __interface ICodeConstructor : public ICodeMember,
   ICodeElement

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

Undone. This interface is not yet complete.

Requirements

Namespace: System.ComponentModel.Design.CodeModel

Assembly: System.dll

See Also

ICodeConstructor Members | System.ComponentModel.Design.CodeModel Namespace


ICodeConstructor Members

See Also

ICodeConstructor Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeDataMember Interface

Represents a data member declaration in the class.

[Visual Basic]
Public Interface ICodeDataMember
   Implements ICodeMember, ICodeElement
[C#]
public interface ICodeDataMember : ICodeMember, ICodeElement
[C++]
public __gc __interface ICodeDataMember : public ICodeMember,
   ICodeElement

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design.CodeModel

Assembly: System.dll

See Also

ICodeDataMember Members | System.ComponentModel.Design.CodeModel Namespace


ICodeDataMember Members

Properties

Value The value to initialize the data member with.

Methods

GetCodeType | Gets the data type of the data member.
SetCodeType | Sets the data type of the data member.

See Also

ICodeDataMember Interface | System.ComponentModel.Design.CodeModel Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeDataMember Properties

The properties of the ICodeDataMember interface are listed below. For a complete list of ICodeDataMember interface members, see the ICodeDataMember Members topic.

Value The value to initialize the data member with.

See Also

ICodeDataMember Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeDataMember.Value

The value to initialize the data member with.

[Visual Basic]
Property Value As Object
[C#]
object Value {get; set;}
[C++]
Object* get_Value() = 0;void set_Value(Object*) = 0;
[JScript]
abstract function get Value() : Object;
public abstract function set Value(Object);

Property Value

An object storing the value to initialize the data member with.

Remarks

This can be a Variant or any expression type. See the ICodeSourceFile documentation for more information about expressions. Setting this to a null reference (in Visual Basic Nothing) will result in the data member not getting initialized.

See Also

ICodeDataMember Interface | ICodeDataMember Members | System.ComponentModel.Design.CodeModel Namespace | ICodeSourceFile


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeDataMember Methods

The methods of the ICodeDataMember interface are listed below. For a complete list of ICodeDataMember interface members, see the ICodeDataMember Members topic.

GetCodeType | Gets the data type of the data member.
SetCodeType | Sets the data type of the data member.

See Also

ICodeDataMember Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeDataMember.GetCodeType

Gets the data type of the data member.

[Visual Basic]
Function GetCodeType() As ICodeClass
[C#]
ICodeClass GetCodeType();
[C++]
ICodeClass* GetCodeType() = 0;
[JScript]
function GetCodeType() : ICodeClass;

Return Value

An ICodeClass object that represents the type of the data member.

See Also

ICodeDataMember Interface | ICodeDataMember Members | System.ComponentModel.Design.CodeModel Namespace | SetCodeType


ICodeDataMember.SetCodeType

Sets the data type of the data member.

[Visual Basic]
Sub SetCodeType( _
   ByVal value As ICodeClass _
)
[C#]
void SetCodeType(
   ICodeClass value
);
[C++]
void SetCodeType(
   ICodeClass* value
) = 0;
[JScript]
function SetCodeType(
   value : ICodeClass
);

Parameters

value
An ICodeClass that represents the data type of the data member.

See Also

ICodeDataMember Interface | ICodeDataMember Members | System.ComponentModel.Design.CodeModel Namespace | GetCodeType


ICodeDelegate Interface

Represents a delegate in the class.

[Visual Basic]
Public Interface ICodeDelegate
   Implements ICodeMember, ICodeElement
[C#]
public interface ICodeDelegate : ICodeMember, ICodeElement
[C++]
public __gc __interface ICodeDelegate : public ICodeMember,
   ICodeElement

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

Undone. This interface is not yet complete.

Requirements

Namespace: System.ComponentModel.Design.CodeModel

Assembly: System.dll

See Also

ICodeDelegate Members | System.ComponentModel.Design.CodeModel Namespace


ICodeDelegate Members

See Also

ICodeDelegate Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeDOMStatement Interface

Represents a CodeDOM model based statement.

[Visual Basic]
Public Interface ICodeDOMStatement
   Implements ICodeStatement, ICodeElement
[C#]
public interface ICodeDOMStatement : ICodeStatement, ICodeElement
[C++]
public __gc __interface ICodeDOMStatement : public ICodeStatement,
   ICodeElement

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design.CodeModel

Assembly: System.dll

See Also

ICodeDOMStatement Members | System.ComponentModel.Design.CodeModel Namespace


ICodeDOMStatement Members

Properties

Statement A CodeStatement that represents the DOM-based statement.

See Also

ICodeDOMStatement Interface | System.ComponentModel.Design.CodeModel Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeDOMStatement Properties

The properties of the ICodeDOMStatement interface are listed below. For a complete list of ICodeDOMStatement interface members, see the ICodeDOMStatement Members topic.

Statement A CodeStatement that represents the DOM-based statement.

See Also

ICodeDOMStatement Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeDOMStatement.Statement

A CodeStatement that represents the DOM-based statement.

[Visual Basic]
Property Statement As CodeStatement
[C#]
CodeStatement Statement {get; set;}
[C++]
CodeStatement* get_Statement() = 0;void set_Statement(CodeStatement*) = 0;
[JScript]
abstract function get Statement() : CodeStatement;
public abstract function set Statement(CodeStatement);

Property Value

A CodeStatement that represents the DOM-based statement.

See Also

ICodeDOMStatement Interface | ICodeDOMStatement Members | System.ComponentModel.Design.CodeModel Namespace | ICodeSourceFile | CodeStatement


ICodeElement Interface

Base interface for all code elements.

ICodeElement

[Visual Basic]
Public Interface ICodeElement
[C#]
public interface ICodeElement
[C++]
public __gc __interface ICodeElement

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design.CodeModel

Assembly: System.dll

See Also

ICodeElement Members | System.ComponentModel.Design.CodeModel Namespace


ICodeElement Members

Properties

ReadOnly Gets the current read-only status of this element.

Methods

GetElements | Gets the collection of sub elements.
GetLiteralText | Gets the literal text that this element contains. This is a string copy of the contents from the actual source file.
Remove | Removes this element from the source file. This is equivalent to the user selecting the element and pressing delete.
SetLiteralText | Sets the literal text that this element contains. This is a string copy to the contents of the actual source file.
Show | Causes this element to be displayed in the text editor window. This will also move the caret to the correct location in this element.

See Also

ICodeElement Interface | System.ComponentModel.Design.CodeModel Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeElement Properties

The properties of the ICodeElement interface are listed below. For a complete list of ICodeElement interface members, see the ICodeElement Members topic.

ReadOnly Gets the current read-only status of this element.

See Also

ICodeElement Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeElement.ReadOnly

Gets the current read-only status of this element.

[Visual Basic]
Property ReadOnly As Boolean
[C#]
bool ReadOnly {get; set;}
[C++]
bool get_ReadOnly() = 0;void set_ReadOnly(bool) = 0;
[JScript]
abstract function get ReadOnly() : Boolean;
public abstract function set ReadOnly(Boolean);

Remarks

When a element is set to be read-only, the text editor will prevent the user from editing that section of code.

See Also

ICodeElement Interface | ICodeElement Members | System.ComponentModel.Design.CodeModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeElement Methods

The methods of the ICodeElement interface are listed below. For a complete list of ICodeElement interface members, see the ICodeElement Members topic.

GetElements | Gets the collection of sub elements.
GetLiteralText | Gets the literal text that this element contains. This is a string copy of the contents from the actual source file.
Remove | Removes this element from the source file. This is equivalent to the user selecting the element and pressing delete.
SetLiteralText | Sets the literal text that this element contains. This is a string copy to the contents of the actual source file.
Show | Causes this element to be displayed in the text editor window. This will also move the caret to the correct location in this element.

See Also

ICodeElement Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeElement.GetElements

Gets the collection of sub elements.

[Visual Basic]
Function GetElements() As ICodeElements
[C#]
ICodeElements GetElements();
[C++]
ICodeElements* GetElements() = 0;
[JScript]
function GetElements() : ICodeElements;

Return Value

An ICodeElements object representing the collection of sub elements.

See Also

ICodeElement Interface | ICodeElement Members | System.ComponentModel.Design.CodeModel Namespace


ICodeElement.GetLiteralText

Gets the literal text that this element contains. This is a string copy of the contents from the actual source file.

[Visual Basic]
Function GetLiteralText() As String
[C#]
string GetLiteralText();
[C++]
String* GetLiteralText() = 0;
[JScript]
function GetLiteralText() : String;

Return Value

A string representing the text element.

See Also

ICodeElement Interface | ICodeElement Members | System.ComponentModel.Design.CodeModel Namespace


ICodeElement.Remove

Removes this element from the source file. This is equivalent to the user selecting the element and pressing delete.

[Visual Basic]
Sub Remove()
[C#]
void Remove();
[C++]
void Remove() = 0;
[JScript]
function Remove();

See Also

ICodeElement Interface | ICodeElement Members | System.ComponentModel.Design.CodeModel Namespace


ICodeElement.SetLiteralText

Sets the literal text that this element contains. This is a string copy to the contents of the actual source file.

[Visual Basic]
Sub SetLiteralText( _
   ByVal value As String _
)
[C#]
void SetLiteralText(
   string value
);
[C++]
void SetLiteralText(
   String* value
) = 0;
[JScript]
function SetLiteralText(
   value : String
);

Parameters

value
The text string to set the element to.

See Also

ICodeElement Interface | ICodeElement Members | System.ComponentModel.Design.CodeModel Namespace


ICodeElement.Show

Causes this element to be displayed in the text editor window. This will also move the caret to the correct location in this element.

[Visual Basic]
Sub Show()
[C#]
void Show();
[C++]
void Show() = 0;
[JScript]
function Show();

See Also

ICodeElement Interface | ICodeElement Members | System.ComponentModel.Design.CodeModel Namespace


ICodeElementLocation Interface

Temporary

ICodeElementLocation

[Visual Basic]
Public Interface ICodeElementLocation
[C#]
public interface ICodeElementLocation
[C++]
public __gc __interface ICodeElementLocation

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design.CodeModel

Assembly: System.dll

See Also

ICodeElementLocation Members | System.ComponentModel.Design.CodeModel Namespace


ICodeElementLocation Members

Properties

Length | [To be supplied.]
Start | [To be supplied.]

See Also

ICodeElementLocation Interface | System.ComponentModel.Design.CodeModel Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeElementLocation Properties

The properties of the ICodeElementLocation interface are listed below. For a complete list of ICodeElementLocation interface members, see the ICodeElementLocation Members topic.

Length | [To be supplied.]
Start | [To be supplied.]

See Also

ICodeElementLocation Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeElementLocation.Length

[To be supplied.]

[Visual Basic]
ReadOnly Property Length As Integer
[C#]
int Length {get;}
[C++]
int get_Length() = 0;
[JScript]
abstract function get Length() : int;

See Also

ICodeElementLocation Interface | ICodeElementLocation Members | System.ComponentModel.Design.CodeModel Namespace


ICodeElementLocation.Start

[To be supplied.]

[Visual Basic]
ReadOnly Property Start As Integer
[C#]
int Start {get;}
[C++]
int get_Start() = 0;
[JScript]
abstract function get Start() : int;

See Also

ICodeElementLocation Interface | ICodeElementLocation Members | System.ComponentModel.Design.CodeModel Namespace


ICodeElements Interface

Collection of ICodeElement objects.

ICodeElements

[Visual Basic]
Public Interface ICodeElements
[C#]
public interface ICodeElements
[C++]
public __gc __interface ICodeElements

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design.CodeModel

Assembly: System.dll

See Also

ICodeElements Members | System.ComponentModel.Design.CodeModel Namespace


ICodeElements Members

Methods

Add | Adds a new statement to the collection.
GetCount | Gets the number of elements currently in the collection.
GetItemAt | Gets the element at the specified index.
GetItems | Gets a snapshot of all contained elements.
SetItemAt | Sets the item at the specified index.
SetItems | Sets the element collection items to those specified. The current set of elements are replaced.

See Also

ICodeElements Interface | System.ComponentModel.Design.CodeModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeElements Methods

The methods of the ICodeElements interface are listed below. For a complete list of ICodeElements interface members, see the ICodeElements Members topic.

Add | Adds a new statement to the collection.
GetCount | Gets the number of elements currently in the collection.
GetItemAt | Gets the element at the specified index.
GetItems | Gets a snapshot of all contained elements.
SetItemAt | Sets the item at the specified index.
SetItems | Sets the element collection items to those specified. The current set of elements are replaced.

See Also

ICodeElements Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeElements.Add

Adds a new statement to the collection.

[Visual Basic]
Sub Add( _
   ByVal item As ICodeElement _
)
[C#]
void Add(
   ICodeElement item
);
[C++]
void Add(
   ICodeElement* item
) = 0;
[JScript]
function Add(
   item : ICodeElement
);

Parameters

item
The new statement to add to the collection.

See Also

ICodeElements Interface | ICodeElements Members | System.ComponentModel.Design.CodeModel Namespace


ICodeElements.GetCount

Gets the number of elements currently in the collection.

[Visual Basic]
Function GetCount() As Integer
[C#]
int GetCount();
[C++]
int GetCount() = 0;
[JScript]
function GetCount() : int;

Return Value

The number of elements currently in the collection.

See Also

ICodeElements Interface | ICodeElements Members | System.ComponentModel.Design.CodeModel Namespace


ICodeElements.GetItemAt

Gets the element at the specified index.

[Visual Basic]
Function GetItemAt( _
   ByVal index As Integer _
) As ICodeElement
[C#]
ICodeElement GetItemAt(
   int index
);
[C++]
ICodeElement* GetItemAt(
   int index
) = 0;
[JScript]
function GetItemAt(
   index : int
) : ICodeElement;

Parameters

index
The index of the item to retrieve.

Return Value

The element at the specified index.

See Also

ICodeElements Interface | ICodeElements Members | System.ComponentModel.Design.CodeModel Namespace


ICodeElements.GetItems

Gets a snapshot of all contained elements.

[Visual Basic]
Function GetItems() As ICodeElement ()
[C#]
ICodeElement[] GetItems();
[C++]
ICodeElement* GetItems() [] = 0;
[JScript]
function GetItems() : ICodeElement[];

Return Value

An array of all contained elements.

See Also

ICodeElements Interface | ICodeElements Members | System.ComponentModel.Design.CodeModel Namespace


ICodeElements.SetItemAt

Sets the item at the specified index.

[Visual Basic]
Sub SetItemAt( _
   ByVal index As Integer, _
   ByVal value As ICodeElement _
)
[C#]
void SetItemAt(
   int index,
   ICodeElement value
);
[C++]
void SetItemAt(
   int index,
   ICodeElement* value
) = 0;
[JScript]
function SetItemAt(
   index : int,
   value : ICodeElement
);

Parameters

index
The index of the item to replace.
value
The element to replace the existing element with.

See Also

ICodeElements Interface | ICodeElements Members | System.ComponentModel.Design.CodeModel Namespace


ICodeElements.SetItems

Sets the element collection items to those specified. The current set of elements are replaced.

[Visual Basic]
Sub SetItems( _
   ByVal value() As ICodeElement _
)
[C#]
void SetItems(
   ICodeElement[] value
);
[C++]
void SetItems(
   ICodeElement* value[]
) = 0;
[JScript]
function SetItems(
   value : ICodeElement[]
);

Parameters

value
An array of elements to set as current.

See Also

ICodeElements Interface | ICodeElements Members | System.ComponentModel.Design.CodeModel Namespace


ICodeLocalVariableStatement Interface

Represents a local variable declaration statement in a method.

[Visual Basic]
Public Interface ICodeLocalVariableStatement
   Implements ICodeStatement, ICodeElement
[C#]
public interface ICodeLocalVariableStatement : ICodeStatement,
   ICodeElement
[C++]
public __gc __interface ICodeLocalVariableStatement : public
   ICodeStatement, ICodeElement

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design.CodeModel

Assembly: System.dll

See Also

ICodeLocalVariableStatement Members | System.ComponentModel.Design.CodeModel Namespace


ICodeLocalVariableStatement Members

Properties

Value The value to initialize the variable with.

Methods

GetCodeType | Gets the data type of the variable.
GetName | Gets the name of the variable.
SetCodeType | Sets the data type of the variable.
SetName | Sets the name of the variable.

See Also

ICodeLocalVariableStatement Interface | System.ComponentModel.Design.CodeModel Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeLocalVariableStatement Properties

The properties of the ICodeLocalVariableStatement interface are listed below. For a complete list of ICodeLocalVariableStatement interface members, see the ICodeLocalVariableStatement Members topic.

Value The value to initialize the variable with.

See Also

ICodeLocalVariableStatement Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeLocalVariableStatement.Value

The value to initialize the variable with.

[Visual Basic]
Property Value As Object
[C#]
object Value {get; set;}
[C++]
Object* get_Value() = 0;void set_Value(Object*) = 0;
[JScript]
abstract function get Value() : Object;
public abstract function set Value(Object);

Property Value

An object the variable is initialized with.

Remarks

This can be a Variant or any expression type. See ICodeSourceFile for more information about expressions. Setting this to a null reference (in Visual Basic Nothing) will result in the variable not getting initialized.

See Also

ICodeLocalVariableStatement Interface | ICodeLocalVariableStatement Members | System.ComponentModel.Design.CodeModel Namespace | ICodeSourceFile


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeLocalVariableStatement Methods

The methods of the ICodeLocalVariableStatement interface are listed below. For a complete list of ICodeLocalVariableStatement interface members, see the ICodeLocalVariableStatement Members topic.

GetCodeType | Gets the data type of the variable.
GetName | Gets the name of the variable.
SetCodeType | Sets the data type of the variable.
SetName | Sets the name of the variable.

See Also

ICodeLocalVariableStatement Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeLocalVariableStatement.GetCodeType

Gets the data type of the variable.

[Visual Basic]
Function GetCodeType() As ICodeClass
[C#]
ICodeClass GetCodeType();
[C++]
ICodeClass* GetCodeType() = 0;
[JScript]
function GetCodeType() : ICodeClass;

Return Value

An ICodeClass object representing the data type of the variable.

See Also

ICodeLocalVariableStatement Interface | ICodeLocalVariableStatement Members | System.ComponentModel.Design.CodeModel Namespace


ICodeLocalVariableStatement.GetName

Gets the name of the variable.

[Visual Basic]
Function GetName() As String
[C#]
string GetName();
[C++]
String* GetName() = 0;
[JScript]
function GetName() : String;

Return Value

A string representing the name of the variable.

See Also

ICodeLocalVariableStatement Interface | ICodeLocalVariableStatement Members | System.ComponentModel.Design.CodeModel Namespace


ICodeLocalVariableStatement.SetCodeType

Sets the data type of the variable.

[Visual Basic]
Sub SetCodeType( _
   ByVal value As ICodeClass _
)
[C#]
void SetCodeType(
   ICodeClass value
);
[C++]
void SetCodeType(
   ICodeClass* value
) = 0;
[JScript]
function SetCodeType(
   value : ICodeClass
);

Parameters

value
The data type of the variable.

See Also

ICodeLocalVariableStatement Interface | ICodeLocalVariableStatement Members | System.ComponentModel.Design.CodeModel Namespace


ICodeLocalVariableStatement.SetName

Sets the name of the variable.

[Visual Basic]
Sub SetName( _
   ByVal value As String _
)
[C#]
void SetName(
   string value
);
[C++]
void SetName(
   String* value
) = 0;
[JScript]
function SetName(
   value : String
);

Parameters

value
The name of the variable.

See Also

ICodeLocalVariableStatement Interface | ICodeLocalVariableStatement Members | System.ComponentModel.Design.CodeModel Namespace


ICodeMember Interface

Base interface used by all members inside of a class.

ICodeMember

[Visual Basic]
Public Interface ICodeMember
   Implements ICodeElement
[C#]
public interface ICodeMember : ICodeElement
[C++]
public __gc __interface ICodeMember : public ICodeElement

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design.CodeModel

Assembly: System.dll

See Also

ICodeMember Members | System.ComponentModel.Design.CodeModel Namespace


ICodeMember Members

Methods

GetDescription | Gets the description of the member.
GetModifiers | Gets the modifiers for the member.
GetName | Gets the name of the member.
SetDescription | Sets the description of the member.
SetModifiers | Sets the modifiers for the member.
SetName | Sets the name of the member.

See Also

ICodeMember Interface | System.ComponentModel.Design.CodeModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeMember Methods

The methods of the ICodeMember interface are listed below. For a complete list of ICodeMember interface members, see the ICodeMember Members topic.

GetDescription | Gets the description of the member.
GetModifiers | Gets the modifiers for the member.
GetName | Gets the name of the member.
SetDescription | Sets the description of the member.
SetModifiers | Sets the modifiers for the member.
SetName | Sets the name of the member.

See Also

ICodeMember Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeMember.GetDescription

Gets the description of the member.

[Visual Basic]
Function GetDescription() As String
[C#]
string GetDescription();
[C++]
String* GetDescription() = 0;
[JScript]
function GetDescription() : String;

Remarks

This is normally stored in some sort of documentation comment near the member.

See Also

ICodeMember Interface | ICodeMember Members | System.ComponentModel.Design.CodeModel Namespace


ICodeMember.GetModifiers

Gets the modifiers for the member.

[Visual Basic]
Function GetModifiers() As Integer
[C#]
int GetModifiers();
[C++]
int GetModifiers() = 0;
[JScript]
function GetModifiers() : int;

Remarks

The modifiers returned are defined in the MemberModifier class. These all represent the NGWS runtime defined names for various attributes. Each language may represent these attributes in a different format. For example, SafeC uses the keyword "virtual" to denote a non-final member, while VB uses "canoveride".

See Also

ICodeMember Interface | ICodeMember Members | System.ComponentModel.Design.CodeModel Namespace | System.ComponentModel.Design.CodeModel.MemberModifier


ICodeMember.GetName

Gets the name of the member.

[Visual Basic]
Function GetName() As String
[C#]
string GetName();
[C++]
String* GetName() = 0;
[JScript]
function GetName() : String;

See Also

ICodeMember Interface | ICodeMember Members | System.ComponentModel.Design.CodeModel Namespace


ICodeMember.SetDescription

Sets the description of the member.

[Visual Basic]
Sub SetDescription( _
   ByVal value As String _
)
[C#]
void SetDescription(
   string value
);
[C++]
void SetDescription(
   String* value
) = 0;
[JScript]
function SetDescription(
   value : String
);

Parameters

value
The description for the member.

Remarks

This is normally stored in some sort of documentation comment near the member.

See Also

ICodeMember Interface | ICodeMember Members | System.ComponentModel.Design.CodeModel Namespace


ICodeMember.SetModifiers

Sets the modifiers for the member.

[Visual Basic]
Sub SetModifiers( _
   ByVal value As Integer _
)
[C#]
void SetModifiers(
   int value
);
[C++]
void SetModifiers(
   int value
) = 0;
[JScript]
function SetModifiers(
   value : int
);

Parameters

value
The new modifiers.

Remarks

The modifiers returned are defined in the MemberModifier class. These all represent the NGWS runtime defined names for various attributes. Each language may represent these attributes in a different format. For example, SafeC uses the keyword "virtual" to denote a non-final member, while VB uses "canoveride".

See Also

ICodeMember Interface | ICodeMember Members | System.ComponentModel.Design.CodeModel Namespace | MemberModifier


ICodeMember.SetName

Sets the name of the member.

[Visual Basic]
Sub SetName( _
   ByVal value As String _
)
[C#]
void SetName(
   string value
);
[C++]
void SetName(
   String* value
) = 0;
[JScript]
function SetName(
   value : String
);

Parameters

value
The name of the member.

See Also

ICodeMember Interface | ICodeMember Members | System.ComponentModel.Design.CodeModel Namespace


ICodeMembers Interface

Collection of ICodeMember objects.

ICodeMembers

[Visual Basic]
Public Interface ICodeMembers
[C#]
public interface ICodeMembers
[C++]
public __gc __interface ICodeMembers

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design.CodeModel

Assembly: System.dll

See Also

ICodeMembers Members | System.ComponentModel.Design.CodeModel Namespace


ICodeMembers Members

Methods

Add | Adds a new member to the collection.
GetCount | Gets the number of members currently in the collection.
GetItemAt | Gets the member at the specified index.
GetItems | Gets a snapshot of all contained members.
SetItemAt | Sets the member at the specified index.
SetItems | Sets the member items to those specified. The current set of members are replaced.

See Also

ICodeMembers Interface | System.ComponentModel.Design.CodeModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeMembers Methods

The methods of the ICodeMembers interface are listed below. For a complete list of ICodeMembers interface members, see the ICodeMembers Members topic.

Add | Adds a new member to the collection.
GetCount | Gets the number of members currently in the collection.
GetItemAt | Gets the member at the specified index.
GetItems | Gets a snapshot of all contained members.
SetItemAt | Sets the member at the specified index.
SetItems | Sets the member items to those specified. The current set of members are replaced.

See Also

ICodeMembers Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeMembers.Add

Adds a new member to the collection.

[Visual Basic]
Sub Add( _
   ByVal item As ICodeMember _
)
[C#]
void Add(
   ICodeMember item
);
[C++]
void Add(
   ICodeMember* item
) = 0;
[JScript]
function Add(
   item : ICodeMember
);

Parameters

item
The member to add to the collection.

See Also

ICodeMembers Interface | ICodeMembers Members | System.ComponentModel.Design.CodeModel Namespace


ICodeMembers.GetCount

Gets the number of members currently in the collection.

[Visual Basic]
Function GetCount() As Integer
[C#]
int GetCount();
[C++]
int GetCount() = 0;
[JScript]
function GetCount() : int;

Return Value

The number of members currently in the collection.

See Also

ICodeMembers Interface | ICodeMembers Members | System.ComponentModel.Design.CodeModel Namespace


ICodeMembers.GetItemAt

Gets the member at the specified index.

[Visual Basic]
Function GetItemAt( _
   ByVal index As Integer _
) As ICodeMember
[C#]
ICodeMember GetItemAt(
   int index
);
[C++]
ICodeMember* GetItemAt(
   int index
) = 0;
[JScript]
function GetItemAt(
   index : int
) : ICodeMember;

Parameters

index
The index of the member to retrieve.

Return Value

The ICodeMember at the specified index.

See Also

ICodeMembers Interface | ICodeMembers Members | System.ComponentModel.Design.CodeModel Namespace


ICodeMembers.GetItems

Gets a snapshot of all contained members.

[Visual Basic]
Function GetItems() As ICodeMember ()
[C#]
ICodeMember[] GetItems();
[C++]
ICodeMember* GetItems() [] = 0;
[JScript]
function GetItems() : ICodeMember[];

Return Value

An array of type ICodeMember representing all contained members.

See Also

ICodeMembers Interface | ICodeMembers Members | System.ComponentModel.Design.CodeModel Namespace


ICodeMembers.SetItemAt

Sets the member at the specified index.

[Visual Basic]
Sub SetItemAt( _
   ByVal index As Integer, _
   ByVal value As ICodeMember _
)
[C#]
void SetItemAt(
   int index,
   ICodeMember value
);
[C++]
void SetItemAt(
   int index,
   ICodeMember* value
) = 0;
[JScript]
function SetItemAt(
   index : int,
   value : ICodeMember
);

Parameters

index
The index of the member to replace.
value
The member to replace the existing member with.

See Also

ICodeMembers Interface | ICodeMembers Members | System.ComponentModel.Design.CodeModel Namespace


ICodeMembers.SetItems

Sets the member items to those specified. The current set of members are replaced.

[Visual Basic]
Sub SetItems( _
   ByVal value() As ICodeMember _
)
[C#]
void SetItems(
   ICodeMember[] value
);
[C++]
void SetItems(
   ICodeMember* value[]
) = 0;
[JScript]
function SetItems(
   value : ICodeMember[]
);

Parameters

value
The new array of members.

Remarks

This clears the members and replaces the set with the specified set.

See Also

ICodeMembers Interface | ICodeMembers Members | System.ComponentModel.Design.CodeModel Namespace


ICodeMethod Interface

Represents a method declaration inside of a class.

[Visual Basic]
Public Interface ICodeMethod
   Implements ICodeMember, ICodeElement
[C#]
public interface ICodeMethod : ICodeMember, ICodeElement
[C++]
public __gc __interface ICodeMethod : public ICodeMember,
   ICodeElement

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design.CodeModel

Assembly: System.dll

See Also

ICodeMethod Members | System.ComponentModel.Design.CodeModel Namespace


ICodeMethod Members

Methods

GetParameters | Gets the collection of parameters for the method.
GetReturnType | Gets the return type of the method.
GetStatements Gets the statements inside of the method. The CodeSense APIs only support parsing and generating a small number of statements and expressions. The only supported statements are:
  • Property Set
  • Method Invoke
  • Local variable declaration

Each statment can have various expressions, the documentation for ICodeSourceFile details the various expressions.

See Also

ICodeMethod Interface | System.ComponentModel.Design.CodeModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeMethod Methods

The methods of the ICodeMethod interface are listed below. For a complete list of ICodeMethod interface members, see the ICodeMethod Members topic.

GetParameters | Gets the collection of parameters for the method.
GetReturnType | Gets the return type of the method.
GetStatements Gets the statements inside of the method. The CodeSense APIs only support parsing and generating a small number of statements and expressions. The only supported statements are:
  • Property Set
  • Method Invoke
  • Local variable declaration

Each statment can have various expressions, the documentation for ICodeSourceFile details the various expressions.

See Also

ICodeMethod Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeMethod.GetParameters

Gets the collection of parameters for the method.

[Visual Basic]
Function GetParameters() As ICodeParameters
[C#]
ICodeParameters GetParameters();
[C++]
ICodeParameters* GetParameters() = 0;
[JScript]
function GetParameters() : ICodeParameters;

Return Value

An ICodeParameters object containing the collection of parameters for the method.

See Also

ICodeMethod Interface | ICodeMethod Members | System.ComponentModel.Design.CodeModel Namespace | ICodeParameter


ICodeMethod.GetReturnType

Gets the return type of the method.

[Visual Basic]
Function GetReturnType() As ICodeClass
[C#]
ICodeClass GetReturnType();
[C++]
ICodeClass* GetReturnType() = 0;
[JScript]
function GetReturnType() : ICodeClass;

Return Value

An ICodeClass object representing the return type of the method.

See Also

ICodeMethod Interface | ICodeMethod Members | System.ComponentModel.Design.CodeModel Namespace


ICodeMethod.GetStatements

Gets the statements inside of the method. The CodeSense APIs only support parsing and generating a small number of statements and expressions. The only supported statements are:

  • Property Set
  • Method Invoke
  • Local variable declaration

Each statment can have various expressions, the documentation for ICodeSourceFile details the various expressions.

[Visual Basic]
Function GetStatements() As ICodeStatements
[C#]
ICodeStatements GetStatements();
[C++]
ICodeStatements* GetStatements() = 0;
[JScript]
function GetStatements() : ICodeStatements;

Return Value

An ICodeStatements object representing the statements inside of the method.

See Also

ICodeMethod Interface | ICodeMethod Members | System.ComponentModel.Design.CodeModel Namespace | ICodeSourceFile | System.ComponentModel.Design.CodeModel.ICodeSatatement


ICodeMethodInvokeExpression Interface

Represents a method invoke expression. The documentation for ICodeSourceFile has information about expressions.

ICodeMethodInvokeExpression

[Visual Basic]
Public Interface ICodeMethodInvokeExpression
   Implements ICodeElement
[C#]
public interface ICodeMethodInvokeExpression : ICodeElement
[C++]
public __gc __interface ICodeMethodInvokeExpression : public
   ICodeElement

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

See the documentation for ICodeSourceFile for more information about expressions.

Requirements

Namespace: System.ComponentModel.Design.CodeModel

Assembly: System.dll

See Also

ICodeMethodInvokeExpression Members | System.ComponentModel.Design.CodeModel Namespace | ICodeSourceFile | ICodeSourceFile


ICodeMethodInvokeExpression Members

Methods

GetMethodName | Gets the name of the method to invoke.
GetParameters | Gets the collection of parameters that will be used to invoke the method.
GetTarget | Gets the target of the method invoke.
SetMethodName | Sets the name of the method to invoke.
SetTarget | Sets the target of the method invoke.

See Also

ICodeMethodInvokeExpression Interface | System.ComponentModel.Design.CodeModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeMethodInvokeExpression Methods

The methods of the ICodeMethodInvokeExpression interface are listed below. For a complete list of ICodeMethodInvokeExpression interface members, see the ICodeMethodInvokeExpression Members topic.

GetMethodName | Gets the name of the method to invoke.
GetParameters | Gets the collection of parameters that will be used to invoke the method.
GetTarget | Gets the target of the method invoke.
SetMethodName | Sets the name of the method to invoke.
SetTarget | Sets the target of the method invoke.

See Also

ICodeMethodInvokeExpression Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeMethodInvokeExpression.GetMethodName

Gets the name of the method to invoke.

[Visual Basic]
Function GetMethodName() As String
[C#]
string GetMethodName();
[C++]
String* GetMethodName() = 0;
[JScript]
function GetMethodName() : String;

Return Value

The name of the method to invoke.

See Also

ICodeMethodInvokeExpression Interface | ICodeMethodInvokeExpression Members | System.ComponentModel.Design.CodeModel Namespace


ICodeMethodInvokeExpression.GetParameters

Gets the collection of parameters that will be used to invoke the method.

[Visual Basic]
Function GetParameters() As ICodeParameters
[C#]
ICodeParameters GetParameters();
[C++]
ICodeParameters* GetParameters() = 0;
[JScript]
function GetParameters() : ICodeParameters;

Return Value

The parameters that will be used to invoke the method.

See Also

ICodeMethodInvokeExpression Interface | ICodeMethodInvokeExpression Members | System.ComponentModel.Design.CodeModel Namespace


ICodeMethodInvokeExpression.GetTarget

Gets the target of the method invoke.

[Visual Basic]
Function GetTarget() As String ()
[C#]
string[] GetTarget();
[C++]
String* GetTarget() [] = 0;
[JScript]
function GetTarget() : String[];

Remarks

Undone. This is currently a string array to support invoking methods on sub objects (i.e. "Foo.Bar.DoSomething(...)"), however in the long term we need a better solution.

See Also

ICodeMethodInvokeExpression Interface | ICodeMethodInvokeExpression Members | System.ComponentModel.Design.CodeModel Namespace


ICodeMethodInvokeExpression.SetMethodName

Sets the name of the method to invoke.

[Visual Basic]
Sub SetMethodName( _
   ByVal value As String _
)
[C#]
void SetMethodName(
   string value
);
[C++]
void SetMethodName(
   String* value
) = 0;
[JScript]
function SetMethodName(
   value : String
);

Parameters

value
The name of the method to invoke.

See Also

ICodeMethodInvokeExpression Interface | ICodeMethodInvokeExpression Members | System.ComponentModel.Design.CodeModel Namespace


ICodeMethodInvokeExpression.SetTarget

Sets the target of the method invoke.

[Visual Basic]
Sub SetTarget( _
   ByVal value() As String _
)
[C#]
void SetTarget(
   string[] value
);
[C++]
void SetTarget(
   String* value[]
) = 0;
[JScript]
function SetTarget(
   value : String[]
);

Parameters

value
The new target for the method invoke expression.

Remarks

Undone. This is currently a string array to support invoking methods on sub objects (i.e. "Foo.Bar.DoSomething(...)"), however in the long term we need a better solution.

See Also

ICodeMethodInvokeExpression Interface | ICodeMethodInvokeExpression Members | System.ComponentModel.Design.CodeModel Namespace


ICodeMethodInvokeStatement Interface

Represents a method invoke statment.

[Visual Basic]
Public Interface ICodeMethodInvokeStatement
   Implements ICodeStatement, ICodeElement
[C#]
public interface ICodeMethodInvokeStatement : ICodeStatement,
   ICodeElement
[C++]
public __gc __interface ICodeMethodInvokeStatement : public
   ICodeStatement, ICodeElement

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design.CodeModel

Assembly: System.dll

See Also

ICodeMethodInvokeStatement Members | System.ComponentModel.Design.CodeModel Namespace


ICodeMethodInvokeStatement Members

Methods

GetMethodName | Gets the name of the method to invoke.
GetParameters | Gets the collection of parameters that will be used to invoke the method.
GetTarget | Gets the target of the method invoke.
SetMethodName | Sets the name of the method to invoke.
SetTarget | Sets the target of the method invoke.

See Also

ICodeMethodInvokeStatement Interface | System.ComponentModel.Design.CodeModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeMethodInvokeStatement Methods

The methods of the ICodeMethodInvokeStatement interface are listed below. For a complete list of ICodeMethodInvokeStatement interface members, see the ICodeMethodInvokeStatement Members topic.

GetMethodName | Gets the name of the method to invoke.
GetParameters | Gets the collection of parameters that will be used to invoke the method.
GetTarget | Gets the target of the method invoke.
SetMethodName | Sets the name of the method to invoke.
SetTarget | Sets the target of the method invoke.

See Also

ICodeMethodInvokeStatement Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeMethodInvokeStatement.GetMethodName

Gets the name of the method to invoke.

[Visual Basic]
Function GetMethodName() As String
[C#]
string GetMethodName();
[C++]
String* GetMethodName() = 0;
[JScript]
function GetMethodName() : String;

Return Value

The name of the method to invoke.

See Also

ICodeMethodInvokeStatement Interface | ICodeMethodInvokeStatement Members | System.ComponentModel.Design.CodeModel Namespace


ICodeMethodInvokeStatement.GetParameters

Gets the collection of parameters that will be used to invoke the method.

[Visual Basic]
Function GetParameters() As ICodeParameters
[C#]
ICodeParameters GetParameters();
[C++]
ICodeParameters* GetParameters() = 0;
[JScript]
function GetParameters() : ICodeParameters;

Return Value

The parameters that will be used to invoke the method.

See Also

ICodeMethodInvokeStatement Interface | ICodeMethodInvokeStatement Members | System.ComponentModel.Design.CodeModel Namespace | ICodeParameters


ICodeMethodInvokeStatement.GetTarget

Gets the target of the method invoke.

[Visual Basic]
Function GetTarget() As String ()
[C#]
string[] GetTarget();
[C++]
String* GetTarget() [] = 0;
[JScript]
function GetTarget() : String[];

Remarks

Undone. This is currently a string array to support invoking methods on sub objects (i.e. "Foo.Bar.DoSomething(...)"), however in the long term we need a better solution.

See Also

ICodeMethodInvokeStatement Interface | ICodeMethodInvokeStatement Members | System.ComponentModel.Design.CodeModel Namespace


ICodeMethodInvokeStatement.SetMethodName

Sets the name of the method to invoke.

[Visual Basic]
Sub SetMethodName( _
   ByVal value As String _
)
[C#]
void SetMethodName(
   string value
);
[C++]
void SetMethodName(
   String* value
) = 0;
[JScript]
function SetMethodName(
   value : String
);

Parameters

value
The name of the method to invoke.

See Also

ICodeMethodInvokeStatement Interface | ICodeMethodInvokeStatement Members | System.ComponentModel.Design.CodeModel Namespace


ICodeMethodInvokeStatement.SetTarget

Sets the target of the method invoke.

[Visual Basic]
Sub SetTarget( _
   ByVal value() As String _
)
[C#]
void SetTarget(
   string[] value
);
[C++]
void SetTarget(
   String* value[]
) = 0;
[JScript]
function SetTarget(
   value : String[]
);

Parameters

value
The new target for the method invoke.

Remarks

Undone This is currently a string array to support invoking methods on sub objects (i.e. "Foo.Bar.DoSomething(...)"), however in the long term we need a better solution.

See Also

ICodeMethodInvokeStatement Interface | ICodeMethodInvokeStatement Members | System.ComponentModel.Design.CodeModel Namespace


ICodeNameReferenceExpression Interface

Represents a reference to any name or literal expression.

ICodeNameReferenceExpression

[Visual Basic]
Public Interface ICodeNameReferenceExpression
   Implements ICodeElement
[C#]
public interface ICodeNameReferenceExpression : ICodeElement
[C++]
public __gc __interface ICodeNameReferenceExpression : public
   ICodeElement

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

This is used for references to static members in classes, or to member variables. This is not used for any primitive or string type. Variants are used to represent primitve or string types. The documentation for ICodeSourceFile has information about expressions.

Requirements

Namespace: System.ComponentModel.Design.CodeModel

Assembly: System.dll

See Also

ICodeNameReferenceExpression Members | System.ComponentModel.Design.CodeModel Namespace | ICodeSourceFile | ICodeSourceFile


ICodeNameReferenceExpression Members

Methods

GetName | Gets the name (or text) that this expression represents.
SetName | Sets the name (or text) that this expression represents.

See Also

ICodeNameReferenceExpression Interface | System.ComponentModel.Design.CodeModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeNameReferenceExpression Methods

The methods of the ICodeNameReferenceExpression interface are listed below. For a complete list of ICodeNameReferenceExpression interface members, see the ICodeNameReferenceExpression Members topic.

GetName | Gets the name (or text) that this expression represents.
SetName | Sets the name (or text) that this expression represents.

See Also

ICodeNameReferenceExpression Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeNameReferenceExpression.GetName

Gets the name (or text) that this expression represents.

[Visual Basic]
Function GetName() As String
[C#]
string GetName();
[C++]
String* GetName() = 0;
[JScript]
function GetName() : String;

Return Value

The name (or text) that this expression represents.

See Also

ICodeNameReferenceExpression Interface | ICodeNameReferenceExpression Members | System.ComponentModel.Design.CodeModel Namespace


ICodeNameReferenceExpression.SetName

Sets the name (or text) that this expression represents.

[Visual Basic]
Sub SetName( _
   ByVal value As String _
)
[C#]
void SetName(
   string value
);
[C++]
void SetName(
   String* value
) = 0;
[JScript]
function SetName(
   value : String
);

Parameters

value
The new name.

See Also

ICodeNameReferenceExpression Interface | ICodeNameReferenceExpression Members | System.ComponentModel.Design.CodeModel Namespace


ICodeNamespaceImport Interface

Represents the import of a namespace into the source file's namespace.

[Visual Basic]
Public Interface ICodeNamespaceImport
   Implements ICodeStatement, ICodeElement
[C#]
public interface ICodeNamespaceImport : ICodeStatement,
   ICodeElement
[C++]
public __gc __interface ICodeNamespaceImport : public
   ICodeStatement, ICodeElement

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

Undone. Namespace representation isn't fixed. This API is likely to change drastically.

Requirements

Namespace: System.ComponentModel.Design.CodeModel

Assembly: System.dll

See Also

ICodeNamespaceImport Members | System.ComponentModel.Design.CodeModel Namespace


ICodeNamespaceImport Members

Methods

GetNamespace | Gets the string name of the namespace.
SetNamespace | Sets the string name of the namespace.

See Also

ICodeNamespaceImport Interface | System.ComponentModel.Design.CodeModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeNamespaceImport Methods

The methods of the ICodeNamespaceImport interface are listed below. For a complete list of ICodeNamespaceImport interface members, see the ICodeNamespaceImport Members topic.

GetNamespace | Gets the string name of the namespace.
SetNamespace | Sets the string name of the namespace.

See Also

ICodeNamespaceImport Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeNamespaceImport.GetNamespace

Gets the string name of the namespace.

[Visual Basic]
Function GetNamespace() As String
[C#]
string GetNamespace();
[C++]
String* GetNamespace() = 0;
[JScript]
function GetNamespace() : String;

Return Value

The name of the namespace.

Remarks

Namespaces should always be represented by a series of names with dots (.) between each level of the namespace, such as "System".

See Also

ICodeNamespaceImport Interface | ICodeNamespaceImport Members | System.ComponentModel.Design.CodeModel Namespace


ICodeNamespaceImport.SetNamespace

Sets the string name of the namespace.

[Visual Basic]
Sub SetNamespace( _
   ByVal value As String _
)
[C#]
void SetNamespace(
   string value
);
[C++]
void SetNamespace(
   String* value
) = 0;
[JScript]
function SetNamespace(
   value : String
);

Parameters

value
The namespace to import.

Remarks

Namespaces should always be represented by a series of names with dots (.) between each level of the namespace, such as "System".

See Also

ICodeNamespaceImport Interface | ICodeNamespaceImport Members | System.ComponentModel.Design.CodeModel Namespace


ICodeObjectCreateExpression Interface

Represents an object creation expression. The documentation for ICodeSourceFile has information about expressions.

ICodeObjectCreateExpression

[Visual Basic]
Public Interface ICodeObjectCreateExpression
   Implements ICodeElement
[C#]
public interface ICodeObjectCreateExpression : ICodeElement
[C++]
public __gc __interface ICodeObjectCreateExpression : public
   ICodeElement

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

The documentation for ICodeSourceFile has information about expressions.

Requirements

Namespace: System.ComponentModel.Design.CodeModel

Assembly: System.dll

See Also

ICodeObjectCreateExpression Members | System.ComponentModel.Design.CodeModel Namespace | ICodeSourceFile | ICodeSourceFile


ICodeObjectCreateExpression Members

Methods

GetArguments | Gets the array of objects that will be used to construct the class object.
GetCodeType | Gets the class type that will be constructed.
SetArguments | Sets the array of values that will be used to construct the object.
SetCodeType | Sets the class type that will be constructed.

See Also

ICodeObjectCreateExpression Interface | System.ComponentModel.Design.CodeModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeObjectCreateExpression Methods

The methods of the ICodeObjectCreateExpression interface are listed below. For a complete list of ICodeObjectCreateExpression interface members, see the ICodeObjectCreateExpression Members topic.

GetArguments | Gets the array of objects that will be used to construct the class object.
GetCodeType | Gets the class type that will be constructed.
SetArguments | Sets the array of values that will be used to construct the object.
SetCodeType | Sets the class type that will be constructed.

See Also

ICodeObjectCreateExpression Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeObjectCreateExpression.GetArguments

Gets the array of objects that will be used to construct the class object.

[Visual Basic]
Function GetArguments() As Object ()
[C#]
object[] GetArguments();
[C++]
Object* GetArguments() [] = 0;
[JScript]
function GetArguments() : Object[];

Return Value

An array of objects to serve as arguments.

Remarks

Each of these objects can be a Variant or any expression type. See ICodeSourceFile for more information about expressions.

See Also

ICodeObjectCreateExpression Interface | ICodeObjectCreateExpression Members | System.ComponentModel.Design.CodeModel Namespace | ICodeSourceFile


ICodeObjectCreateExpression.GetCodeType

Gets the class type that will be constructed.

[Visual Basic]
Function GetCodeType() As ICodeClass
[C#]
ICodeClass GetCodeType();
[C++]
ICodeClass* GetCodeType() = 0;
[JScript]
function GetCodeType() : ICodeClass;

Return Value

An ICodeClass object representing the class type the code expression references.

See Also

ICodeObjectCreateExpression Interface | ICodeObjectCreateExpression Members | System.ComponentModel.Design.CodeModel Namespace


ICodeObjectCreateExpression.SetArguments

Sets the array of values that will be used to construct the object.

[Visual Basic]
Sub SetArguments( _
   ByVal value() As Object _
)
[C#]
void SetArguments(
   object[] value
);
[C++]
void SetArguments(
   Object* value[]
) = 0;
[JScript]
function SetArguments(
   value : Object[]
);

Parameters

value
An array of object values to serve as arguments.

Remarks

Each of these objects can be a Variant or any expression type. See ICodeSourceFile for more information about expressions.

See Also

ICodeObjectCreateExpression Interface | ICodeObjectCreateExpression Members | System.ComponentModel.Design.CodeModel Namespace | ICodeSourceFile


ICodeObjectCreateExpression.SetCodeType

Sets the class type that will be constructed.

[Visual Basic]
Sub SetCodeType( _
   ByVal value As ICodeClass _
)
[C#]
void SetCodeType(
   ICodeClass value
);
[C++]
void SetCodeType(
   ICodeClass* value
) = 0;
[JScript]
function SetCodeType(
   value : ICodeClass
);

Parameters

value
The class type to construct.

See Also

ICodeObjectCreateExpression Interface | ICodeObjectCreateExpression Members | System.ComponentModel.Design.CodeModel Namespace


ICodeParameter Interface

Represents a single parameter.

ICodeParameter

[Visual Basic]
Public Interface ICodeParameter
   Implements ICodeElement
[C#]
public interface ICodeParameter : ICodeElement
[C++]
public __gc __interface ICodeParameter : public ICodeElement

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

This class provides representation for parameters in an ICodeSourceFile. ICodeParameters can be parameters of method invoke expressions, or from the declaration of properties or methods.

Requirements

Namespace: System.ComponentModel.Design.CodeModel

Assembly: System.dll

See Also

ICodeParameter Members | System.ComponentModel.Design.CodeModel Namespace | ICodeParameters


ICodeParameter Members

Properties

Value The parameter value.

Methods

GetCodeType | Gets the data type of the parameter.
GetName | Gets the name of this parameter.
SetCodeType | Sets the data type of the parameter.
SetName | Sets the name of this parameter. The parameter name will be used in the declaration of a property or method, or in method invokes- if the langauge supports named parameters.

See Also

ICodeParameter Interface | System.ComponentModel.Design.CodeModel Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeParameter Properties

The properties of the ICodeParameter interface are listed below. For a complete list of ICodeParameter interface members, see the ICodeParameter Members topic.

Value The parameter value.

See Also

ICodeParameter Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeParameter.Value

The parameter value.

[Visual Basic]
Property Value As Object
[C#]
object Value {get; set;}
[C++]
Object* get_Value() = 0;void set_Value(Object*) = 0;
[JScript]
abstract function get Value() : Object;
public abstract function set Value(Object);

Property Value

The parameter value.

Remarks

The parameter value will be used as the default value of a parameter in method and property declaration, or just the value of the parameter in method invokes. The documentation for ICodeSourceFile has information regarding the valid values for this property.

See Also

ICodeParameter Interface | ICodeParameter Members | System.ComponentModel.Design.CodeModel Namespace | ICodeSourceFile


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeParameter Methods

The methods of the ICodeParameter interface are listed below. For a complete list of ICodeParameter interface members, see the ICodeParameter Members topic.

GetCodeType | Gets the data type of the parameter.
GetName | Gets the name of this parameter.
SetCodeType | Sets the data type of the parameter.
SetName | Sets the name of this parameter. The parameter name will be used in the declaration of a property or method, or in method invokes- if the langauge supports named parameters.

See Also

ICodeParameter Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeParameter.GetCodeType

Gets the data type of the parameter.

[Visual Basic]
Function GetCodeType() As ICodeClass
[C#]
ICodeClass GetCodeType();
[C++]
ICodeClass* GetCodeType() = 0;
[JScript]
function GetCodeType() : ICodeClass;

Return Value

The ICodeClass representing the data type of the parameter.

Remarks

The parameter type will be used in the declaration of a property or method, or used for strong type conversion in method invokes.

See Also

ICodeParameter Interface | ICodeParameter Members | System.ComponentModel.Design.CodeModel Namespace | ICodeClass


ICodeParameter.GetName

Gets the name of this parameter.

[Visual Basic]
Function GetName() As String
[C#]
string GetName();
[C++]
String* GetName() = 0;
[JScript]
function GetName() : String;

Return Value

The string name of this parameter.

Remarks

The parameter name will be used in the declaration of a property or method, or in method invokes- if the langauge supports named parameters.

See Also

ICodeParameter Interface | ICodeParameter Members | System.ComponentModel.Design.CodeModel Namespace


ICodeParameter.SetCodeType

Sets the data type of the parameter.

[Visual Basic]
Sub SetCodeType( _
   ByVal value As ICodeClass _
)
[C#]
void SetCodeType(
   ICodeClass value
);
[C++]
void SetCodeType(
   ICodeClass* value
) = 0;
[JScript]
function SetCodeType(
   value : ICodeClass
);

Parameters

value
An ICodeClass object that represents the new data type of the parameter.

Remarks

The parameter type will be used in the declaration of a property or method, or used for strong type conversion in method invokes.

See Also

ICodeParameter Interface | ICodeParameter Members | System.ComponentModel.Design.CodeModel Namespace


ICodeParameter.SetName

Sets the name of this parameter. The parameter name will be used in the declaration of a property or method, or in method invokes- if the langauge supports named parameters.

[Visual Basic]
Sub SetName( _
   ByVal value As String _
)
[C#]
void SetName(
   string value
);
[C++]
void SetName(
   String* value
) = 0;
[JScript]
function SetName(
   value : String
);

Parameters

value
The new name of the parameter.

See Also

ICodeParameter Interface | ICodeParameter Members | System.ComponentModel.Design.CodeModel Namespace


ICodeParameters Interface

Collection of ICodeParameter objects.

ICodeParameters

[Visual Basic]
Public Interface ICodeParameters
[C#]
public interface ICodeParameters
[C++]
public __gc __interface ICodeParameters

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design.CodeModel

Assembly: System.dll

See Also

ICodeParameters Members | System.ComponentModel.Design.CodeModel Namespace | ICodeParameter


ICodeParameters Members

Methods

Add | Adds a new statement to the collection.
GetCount | Gets the number of parameters currently in the collection.
GetItemAt | Gets the parameter at the specified index.
GetItems | Gets a snapshot of all contained parameters.
SetItemAt | Sets the item at the specified index.
SetItems | Clears the current set of parameters, and replaces them with the parameters in value.

See Also

ICodeParameters Interface | System.ComponentModel.Design.CodeModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeParameters Methods

The methods of the ICodeParameters interface are listed below. For a complete list of ICodeParameters interface members, see the ICodeParameters Members topic.

Add | Adds a new statement to the collection.
GetCount | Gets the number of parameters currently in the collection.
GetItemAt | Gets the parameter at the specified index.
GetItems | Gets a snapshot of all contained parameters.
SetItemAt | Sets the item at the specified index.
SetItems | Clears the current set of parameters, and replaces them with the parameters in value.

See Also

ICodeParameters Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeParameters.Add

Adds a new statement to the collection.

[Visual Basic]
Sub Add( _
   ByVal item As ICodeParameter _
)
[C#]
void Add(
   ICodeParameter item
);
[C++]
void Add(
   ICodeParameter* item
) = 0;
[JScript]
function Add(
   item : ICodeParameter
);

Parameters

item
The code statement to be added to the collection.

See Also

ICodeParameters Interface | ICodeParameters Members | System.ComponentModel.Design.CodeModel Namespace


ICodeParameters.GetCount

Gets the number of parameters currently in the collection.

[Visual Basic]
Function GetCount() As Integer
[C#]
int GetCount();
[C++]
int GetCount() = 0;
[JScript]
function GetCount() : int;

Return Value

The number of parameters currently in the collection.

See Also

ICodeParameters Interface | ICodeParameters Members | System.ComponentModel.Design.CodeModel Namespace


ICodeParameters.GetItemAt

Gets the parameter at the specified index.

[Visual Basic]
Function GetItemAt( _
   ByVal index As Integer _
) As ICodeParameter
[C#]
ICodeParameter GetItemAt(
   int index
);
[C++]
ICodeParameter* GetItemAt(
   int index
) = 0;
[JScript]
function GetItemAt(
   index : int
) : ICodeParameter;

Parameters

index
The index of the item to retrieve.

Return Value

The parameter at the specified index.

See Also

ICodeParameters Interface | ICodeParameters Members | System.ComponentModel.Design.CodeModel Namespace


ICodeParameters.GetItems

Gets a snapshot of all contained parameters.

[Visual Basic]
Function GetItems() As ICodeParameter ()
[C#]
ICodeParameter[] GetItems();
[C++]
ICodeParameter* GetItems() [] = 0;
[JScript]
function GetItems() : ICodeParameter[];

Return Value

An array of type ICodeParameter representing all contained parameters.

See Also

ICodeParameters Interface | ICodeParameters Members | System.ComponentModel.Design.CodeModel Namespace


ICodeParameters.SetItemAt

Sets the item at the specified index.

[Visual Basic]
Sub SetItemAt( _
   ByVal index As Integer, _
   ByVal value As ICodeParameter _
)
[C#]
void SetItemAt(
   int index,
   ICodeParameter value
);
[C++]
void SetItemAt(
   int index,
   ICodeParameter* value
) = 0;
[JScript]
function SetItemAt(
   index : int,
   value : ICodeParameter
);

Parameters

index
The index of the item to replace.
value
The parameter to replace the existing parameter with.

See Also

ICodeParameters Interface | ICodeParameters Members | System.ComponentModel.Design.CodeModel Namespace


ICodeParameters.SetItems

Clears the current set of parameters, and replaces them with the parameters in value.

[Visual Basic]
Sub SetItems( _
   ByVal value() As ICodeParameter _
)
[C#]
void SetItems(
   ICodeParameter[] value
);
[C++]
void SetItems(
   ICodeParameter* value[]
) = 0;
[JScript]
function SetItems(
   value : ICodeParameter[]
);

Parameters

value
The new array of statements.

See Also

ICodeParameters Interface | ICodeParameters Members | System.ComponentModel.Design.CodeModel Namespace


ICodeProperty Interface

Represents a property declaration in a class.

[Visual Basic]
Public Interface ICodeProperty
   Implements ICodeMember, ICodeElement
[C#]
public interface ICodeProperty : ICodeMember, ICodeElement
[C++]
public __gc __interface ICodeProperty : public ICodeMember,
   ICodeElement

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design.CodeModel

Assembly: System.dll

See Also

ICodeProperty Members | System.ComponentModel.Design.CodeModel Namespace


ICodeProperty Members

Methods

GetCodeType | Gets the data type of this property.
GetGetMethod | Gets the get method for the property.
GetParameters | Gets the collection of parameters for the property.
GetSetMethod | Gets the set method for the property.

See Also

ICodeProperty Interface | System.ComponentModel.Design.CodeModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeProperty Methods

The methods of the ICodeProperty interface are listed below. For a complete list of ICodeProperty interface members, see the ICodeProperty Members topic.

GetCodeType | Gets the data type of this property.
GetGetMethod | Gets the get method for the property.
GetParameters | Gets the collection of parameters for the property.
GetSetMethod | Gets the set method for the property.

See Also

ICodeProperty Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeProperty.GetCodeType

Gets the data type of this property.

[Visual Basic]
Function GetCodeType() As ICodeClass
[C#]
ICodeClass GetCodeType();
[C++]
ICodeClass* GetCodeType() = 0;
[JScript]
function GetCodeType() : ICodeClass;

Return Value

The data type of this property.

See Also

ICodeProperty Interface | ICodeProperty Members | System.ComponentModel.Design.CodeModel Namespace


ICodeProperty.GetGetMethod

Gets the get method for the property.

[Visual Basic]
Function GetGetMethod() As ICodeMethod
[C#]
ICodeMethod GetGetMethod();
[C++]
ICodeMethod* GetGetMethod() = 0;
[JScript]
function GetGetMethod() : ICodeMethod;

Return Value

The get method for the property.

See Also

ICodeProperty Interface | ICodeProperty Members | System.ComponentModel.Design.CodeModel Namespace


ICodeProperty.GetParameters

Gets the collection of parameters for the property.

[Visual Basic]
Function GetParameters() As ICodeParameters
[C#]
ICodeParameters GetParameters();
[C++]
ICodeParameters* GetParameters() = 0;
[JScript]
function GetParameters() : ICodeParameters;

Return Value

The collection of parameters for the property.

See Also

ICodeProperty Interface | ICodeProperty Members | System.ComponentModel.Design.CodeModel Namespace | ICodeParameter


ICodeProperty.GetSetMethod

Gets the set method for the property.

[Visual Basic]
Function GetSetMethod() As ICodeMethod
[C#]
ICodeMethod GetSetMethod();
[C++]
ICodeMethod* GetSetMethod() = 0;
[JScript]
function GetSetMethod() : ICodeMethod;

Return Value

The set method for the property.

See Also

ICodeProperty Interface | ICodeProperty Members | System.ComponentModel.Design.CodeModel Namespace


ICodePropertySetStatement Interface

Represents a property set statement inside a method.

[Visual Basic]
Public Interface ICodePropertySetStatement
   Implements ICodeStatement, ICodeElement
[C#]
public interface ICodePropertySetStatement : ICodeStatement,
   ICodeElement
[C++]
public __gc __interface ICodePropertySetStatement : public
   ICodeStatement, ICodeElement

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design.CodeModel

Assembly: System.dll

See Also

ICodePropertySetStatement Members | System.ComponentModel.Design.CodeModel Namespace


ICodePropertySetStatement Members

Properties

Value The value of the property.

Methods

GetPropertyName | Gets the name of the property.
GetTarget | Gets the target of the property.
SetPropertyName | Sets the name of the property.
SetTarget | Sets the target of the property.

See Also

ICodePropertySetStatement Interface | System.ComponentModel.Design.CodeModel Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodePropertySetStatement Properties

The properties of the ICodePropertySetStatement interface are listed below. For a complete list of ICodePropertySetStatement interface members, see the ICodePropertySetStatement Members topic.

Value The value of the property.

See Also

ICodePropertySetStatement Interface | System.ComponentModel.Design.CodeModel Namespace


ICodePropertySetStatement.Value

The value of the property.

[Visual Basic]
Property Value As Object
[C#]
object Value {get; set;}
[C++]
Object* get_Value() = 0;void set_Value(Object*) = 0;
[JScript]
abstract function get Value() : Object;
public abstract function set Value(Object);

Property Value

The value of the property.

Remarks

This can be a Variant or any expression type. See ICodeSourceFile for more information about expressions.

See Also

ICodePropertySetStatement Interface | ICodePropertySetStatement Members | System.ComponentModel.Design.CodeModel Namespace | ICodeSourceFile


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodePropertySetStatement Methods

The methods of the ICodePropertySetStatement interface are listed below. For a complete list of ICodePropertySetStatement interface members, see the ICodePropertySetStatement Members topic.

GetPropertyName | Gets the name of the property.
GetTarget | Gets the target of the property.
SetPropertyName | Sets the name of the property.
SetTarget | Sets the target of the property.

See Also

ICodePropertySetStatement Interface | System.ComponentModel.Design.CodeModel Namespace


ICodePropertySetStatement.GetPropertyName

Gets the name of the property.

[Visual Basic]
Function GetPropertyName() As String
[C#]
string GetPropertyName();
[C++]
String* GetPropertyName() = 0;
[JScript]
function GetPropertyName() : String;

Return Value

The name of the property.

See Also

ICodePropertySetStatement Interface | ICodePropertySetStatement Members | System.ComponentModel.Design.CodeModel Namespace


ICodePropertySetStatement.GetTarget

Gets the target of the property.

[Visual Basic]
Function GetTarget() As String ()
[C#]
string[] GetTarget();
[C++]
String* GetTarget() [] = 0;
[JScript]
function GetTarget() : String[];

Return Value

The target of the property.

Remarks

Undone. This is currently a string array to support setting properties on sub objects (i.e. "Foo.Bar.All = (...)"), however in the long term we need a better solution.

See Also

ICodePropertySetStatement Interface | ICodePropertySetStatement Members | System.ComponentModel.Design.CodeModel Namespace


ICodePropertySetStatement.SetPropertyName

Sets the name of the property.

[Visual Basic]
Sub SetPropertyName( _
   ByVal value As String _
)
[C#]
void SetPropertyName(
   string value
);
[C++]
void SetPropertyName(
   String* value
) = 0;
[JScript]
function SetPropertyName(
   value : String
);

Parameters

value
The name of the property to set.

See Also

ICodePropertySetStatement Interface | ICodePropertySetStatement Members | System.ComponentModel.Design.CodeModel Namespace


ICodePropertySetStatement.SetTarget

Sets the target of the property.

[Visual Basic]
Sub SetTarget( _
   ByVal value() As String _
)
[C#]
void SetTarget(
   string[] value
);
[C++]
void SetTarget(
   String* value[]
) = 0;
[JScript]
function SetTarget(
   value : String[]
);

Parameters

value
The new target for each property.

Remarks

Undone. This is currently a string array to support setting properties on sub objects (i.e. "Foo.Bar.All = (...)"), however in the long term we need a better solution.

See Also

ICodePropertySetStatement Interface | ICodePropertySetStatement Members | System.ComponentModel.Design.CodeModel Namespace


ICodeReturnValueStatement Interface

Represents a single return value statement.

[Visual Basic]
Public Interface ICodeReturnValueStatement
   Implements ICodeStatement, ICodeElement
[C#]
public interface ICodeReturnValueStatement : ICodeStatement,
   ICodeElement
[C++]
public __gc __interface ICodeReturnValueStatement : public
   ICodeStatement, ICodeElement

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design.CodeModel

Assembly: System.dll

See Also

ICodeReturnValueStatement Members | System.ComponentModel.Design.CodeModel Namespace


ICodeReturnValueStatement Members

Properties

Method | The method that returns the value represented by this code statement.
ReturnValue | Gets the return value object.

Methods

GetReturnValueType Gets the data type of the return value.

See Also

ICodeReturnValueStatement Interface | System.ComponentModel.Design.CodeModel Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeReturnValueStatement Properties

The properties of the ICodeReturnValueStatement interface are listed below. For a complete list of ICodeReturnValueStatement interface members, see the ICodeReturnValueStatement Members topic.

Method | The method that returns the value represented by this code statement.
ReturnValue | Gets the return value object.

See Also

ICodeReturnValueStatement Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeReturnValueStatement.Method

The method that returns the value represented by this code statement.

[Visual Basic]
ReadOnly Property Method As ICodeMethod
[C#]
ICodeMethod Method {get;}
[C++]
ICodeMethod* get_Method() = 0;
[JScript]
abstract function get Method() : ICodeMethod;

Property Value

An ICodeMethod that represents this code statement.

See Also

ICodeReturnValueStatement Interface | ICodeReturnValueStatement Members | System.ComponentModel.Design.CodeModel Namespace


ICodeReturnValueStatement.ReturnValue

Gets the return value object.

[Visual Basic]
Property ReturnValue As Object
[C#]
object ReturnValue {get; set;}
[C++]
Object* get_ReturnValue() = 0;void set_ReturnValue(Object*) = 0;
[JScript]
abstract function get ReturnValue() : Object;
public abstract function set ReturnValue(Object);

Property Value

An object that represents the return value.

Remarks

The return value type will be used by deafult as the return type of a method or property declaration, or else as the value of a parameter in method invokes. The documentation for ICodeSourceFile has information regarding the valid values for this property.

See Also

ICodeReturnValueStatement Interface | ICodeReturnValueStatement Members | System.ComponentModel.Design.CodeModel Namespace | ICodeSourceFile


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeReturnValueStatement Methods

The methods of the ICodeReturnValueStatement interface are listed below. For a complete list of ICodeReturnValueStatement interface members, see the ICodeReturnValueStatement Members topic.

GetReturnValueType Gets the data type of the return value.

See Also

ICodeReturnValueStatement Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeReturnValueStatement.GetReturnValueType

Gets the data type of the return value.

[Visual Basic]
Function GetReturnValueType() As ICodeClass
[C#]
ICodeClass GetReturnValueType();
[C++]
ICodeClass* GetReturnValueType() = 0;
[JScript]
function GetReturnValueType() : ICodeClass;

Return Value

An ICodeClass that represents the data type of the return value.

Remarks

The parameter type will be used in the declaration of a property or method, or used for strong type conversion in method invokes.

See Also

ICodeReturnValueStatement Interface | ICodeReturnValueStatement Members | System.ComponentModel.Design.CodeModel Namespace


ICodeSourceFile Interface

Provides a logical representation of a single source file.

ICodeSourceFile

[Visual Basic]
Public Interface ICodeSourceFile
[C#]
public interface ICodeSourceFile
[C++]
public __gc __interface ICodeSourceFile

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

A source file can contain many logical elements. These elements normally consist of classes, interfaces, and other top level constructs. When walking the object model of a file you will normally start with a specific class. You can either access the Elements collection and look for a specific class, or use the FindPublicClasses function to retrieve the list of public classes contained in this file. Note: ClassForName should not be used to access the ICodeClass for a class in the current file. For more information see the System.ComponentModel.Design.CodeModel.ClassForName method. Editing the Object Model Creating complex statements is accomplished by composing together the various expressions. In addition there are method, data member, and other editing functions on ICodeClass.

The places in the object model that take Object value as an argument can take any of the following:

Literal Syntax | Actual value. This would be persisted in code as the number or string that you passed in, with the correct language syntax.
ICodeArrayCreateExpression | A creation of an array. Contains the type of the array and an array of "values".
ICodeObjectCreateExpression | A creation of an array. Contains the type of the object to construct and an array of "values" that will be used as arguments to the constructor of that class.
ICodeMethodInvokeExpression | Invokes a method on some object. Contains the name of the object and method to invoke, and an array of "values" that will be used as arguments to the methods.
ICodeNameReferenceExpression | Reference to some object or value in the namespace of this class. This can be both static references to fields, and references to other members in this class. This contains a simple string.

Requirements

Namespace: System.ComponentModel.Design.CodeModel

Assembly: System.dll

Example

An example of how to represent complex code statements using the ICodeSourceFile interface:

// SafeC source to generate
    foo = new Control[] { new Button("caption"), button1 };

    // Objects to create to represent the right side of the equals
    ICodeArrayCreateExpression ( Button.class,
    new Object[] {
 ICodeObjectCreateExpression ( "caption" ),
    ICodeNameReferenceExpression ( "button1 " )
    } )

See Also

ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace | ICodeClass | ICodeArrayCreateExpression | ICodeObjectCreateExpression | ICodeMethodInvokeExpression | ICodeNameReferenceExpression | ICodeClass | ICodeArrayCreateExpression | ICodeObjectCreateExpression | ICodeMethodInvokeExpression | ICodeNameReferenceExpression


ICodeSourceFile Members

Properties

GenerateLongNames Gets whether fully qualified class names are set to always be generated or not.

Methods

ClassForName | Creates an ICodeClass reference to a class with the name specified. This will take into account any imports or namespaces that this file uses. Basically it will do a lookup using the same rules that the compiler would.
CreateArrayCreateExpression | Constructs a new array creation expression.
CreateCodeDOMStatement | Constructs an ICodeDOMStatement for a code statement.
CreateLocalVariableStatement | Overloaded. [To be supplied.]
CreateMethodInvokeExpression | Constructs a new method invoke expression.
CreateMethodInvokeStatement | Constructs a method invoke statement.
CreateMethodReferenceExpression | Constructs a name reference expression for a method. A name reference is basically a reference to any object in this objects namespace (or an absolute reference to any object).
CreateNameReferenceExpression | Overloaded. [To be supplied.]
CreateObjectCreateExpression | Constructs a new object creation expression.
CreateParameter | Constructs a new parameter object.
CreatePropertySetStatement | Constructs a property set statement. This represents a single property set inside of a method.
CreateReturnValueStatement | Constructs a return value statement.
FindPublicClasses | Gets an array of all the public classes that are defined in this file.
GenerateUniqueDataMemberName | Overloaded. [To be supplied.]
GetCodeGenerator | Gets the code generator for this ICodeSourceFile.
GetDescription | Gets the description of this file.
GetElements | Gets the collection of elements contained in this file.
GetIgnoreCase | Gets whether case is ignored in the underlying language or not.
GetPath | Gets the physical path of this file. This may be a URL.
IsSelfReferenceKeyword | Determines if the token refers to the "this" or "me" object.
IsValidIdentifier | Determines if the identifier is valid to be used. This will not check for duplicates, but rather ensure that the identifier is not a reserved word, keyword, or other illegal identifier.
ParseStatements | Parses the given set of statements into code elements.
ReplaceText | Replaces a section of text in the file with the sepecified text.
ShortestClassName | Determines the shortest name using the schema that will uniquely identify the specified class, given any namesapce and imports in this file.
ShowText | Overloaded. [To be supplied.]

See Also

ICodeSourceFile Interface | System.ComponentModel.Design.CodeModel Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeSourceFile Properties

The properties of the ICodeSourceFile interface are listed below. For a complete list of ICodeSourceFile interface members, see the ICodeSourceFile Members topic.

GenerateLongNames Gets whether fully qualified class names are set to always be generated or not.

See Also

ICodeSourceFile Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeSourceFile.GenerateLongNames

Gets whether fully qualified class names are set to always be generated or not.

[Visual Basic]
Property GenerateLongNames As Boolean
[C#]
bool GenerateLongNames {get; set;}
[C++]
bool get_GenerateLongNames() = 0;void set_GenerateLongNames(bool) = 0;
[JScript]
abstract function get GenerateLongNames() : Boolean;
public abstract function set GenerateLongNames(Boolean);

Property Value

true if class names will always be fully qualified; otherwise false.

Remarks

Default is false, where class names are shortened according to current imports.

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeSourceFile Methods

The methods of the ICodeSourceFile interface are listed below. For a complete list of ICodeSourceFile interface members, see the ICodeSourceFile Members topic.

ClassForName | Creates an ICodeClass reference to a class with the name specified. This will take into account any imports or namespaces that this file uses. Basically it will do a lookup using the same rules that the compiler would.
CreateArrayCreateExpression | Constructs a new array creation expression.
CreateCodeDOMStatement | Constructs an ICodeDOMStatement for a code statement.
CreateLocalVariableStatement | Overloaded. [To be supplied.]
CreateMethodInvokeExpression | Constructs a new method invoke expression.
CreateMethodInvokeStatement | Constructs a method invoke statement.
CreateMethodReferenceExpression | Constructs a name reference expression for a method. A name reference is basically a reference to any object in this objects namespace (or an absolute reference to any object).
CreateNameReferenceExpression | Overloaded. [To be supplied.]
CreateObjectCreateExpression | Constructs a new object creation expression.
CreateParameter | Constructs a new parameter object.
CreatePropertySetStatement | Constructs a property set statement. This represents a single property set inside of a method.
CreateReturnValueStatement | Constructs a return value statement.
FindPublicClasses | Gets an array of all the public classes that are defined in this file.
GenerateUniqueDataMemberName | Overloaded. [To be supplied.]
GetCodeGenerator | Gets the code generator for this ICodeSourceFile.
GetDescription | Gets the description of this file.
GetElements | Gets the collection of elements contained in this file.
GetIgnoreCase | Gets whether case is ignored in the underlying language or not.
GetPath | Gets the physical path of this file. This may be a URL.
IsSelfReferenceKeyword | Determines if the token refers to the "this" or "me" object.
IsValidIdentifier | Determines if the identifier is valid to be used. This will not check for duplicates, but rather ensure that the identifier is not a reserved word, keyword, or other illegal identifier.
ParseStatements | Parses the given set of statements into code elements.
ReplaceText | Replaces a section of text in the file with the sepecified text.
ShortestClassName | Determines the shortest name using the schema that will uniquely identify the specified class, given any namesapce and imports in this file.
ShowText | Overloaded. [To be supplied.]

See Also

ICodeSourceFile Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeSourceFile.ClassForName

Creates an ICodeClass reference to a class with the name specified. This will take into account any imports or namespaces that this file uses. Basically it will do a lookup using the same rules that the compiler would.

[Visual Basic]
Function ClassForName( _
   ByVal className As String _
) As ICodeClass
[C#]
ICodeClass ClassForName(
   string className
);
[C++]
ICodeClass* ClassForName(
   String* className
) = 0;
[JScript]
function ClassForName(
   className : String
) : ICodeClass;

Parameters

className
The name of the class to create a reference to.

Return Value

The newly created ICodeClass reference to the class specified.

Remarks

Note Calling ClassForName twice with the same name will not return the same instance of the ICodeClass object. Each request to ClassForName will generate a new object.

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace


ICodeSourceFile.CreateArrayCreateExpression

Constructs a new array creation expression.

[Visual Basic]
Function CreateArrayCreateExpression( _
   ByVal arrayType As ICodeClass, _
   ByVal values() As Object _
) As ICodeArrayCreateExpression
[C#]
ICodeArrayCreateExpression CreateArrayCreateExpression(
   ICodeClass arrayType,
   object[] values
);
[C++]
ICodeArrayCreateExpression* CreateArrayCreateExpression(
   ICodeClass* arrayType,
   Object* values[]
) = 0;
[JScript]
function CreateArrayCreateExpression(
   arrayType : ICodeClass,
   values : Object[]
) : ICodeArrayCreateExpression;

Parameters

arrayType
The type of the array to create.
values
An array of objects to initialize the array with.

Return Value

The newly created array creation expression.

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace


ICodeSourceFile.CreateCodeDOMStatement

Constructs an ICodeDOMStatement for a code statement.

[Visual Basic]
Function CreateCodeDOMStatement( _
   ByVal codeStatement As CodeStatement _
) As ICodeDOMStatement
[C#]
ICodeDOMStatement CreateCodeDOMStatement(
   CodeStatement codeStatement
);
[C++]
ICodeDOMStatement* CreateCodeDOMStatement(
   CodeStatement* codeStatement
) = 0;
[JScript]
function CreateCodeDOMStatement(
   codeStatement : CodeStatement
) : ICodeDOMStatement;

Parameters

codeStatement
The code statement to convert.

Return Value

The newly created ICodeDOMStatement.

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace


ICodeSourceFile.CreateLocalVariableStatement

[To be supplied.]

Overload List

Constructs a local variable statement. This represents the declaration of a variable inside of a method.

[Visual Basic] Overloads Function CreateLocalVariableStatement(ICodeClass, Integer, String, Object) As ICodeLocalVariableStatement
[C#] ICodeLocalVariableStatement CreateLocalVariableStatement(ICodeClass, int, String, Object);
[C++] ICodeLocalVariableStatement* CreateLocalVariableStatement(ICodeClass*, int, String, Object) = 0;
[JScript] function CreateLocalVariableStatement(ICodeClass, int, String, Object) : ICodeLocalVariableStatement;

Constructs a local variable statement. This represents the declaration of a variable inside of a method.

[Visual Basic] Overloads Function CreateLocalVariableStatement(ICodeClass, String, Object) As ICodeLocalVariableStatement
[C#] ICodeLocalVariableStatement CreateLocalVariableStatement(ICodeClass, String, Object);
[C++] ICodeLocalVariableStatement* CreateLocalVariableStatement(ICodeClass*, String, Object) = 0;
[JScript] function CreateLocalVariableStatement(ICodeClass, String, Object) : ICodeLocalVariableStatement;

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace


ICodeSourceFile.CreateLocalVariableStatement (ICodeClass, Int32, String, Object)

Constructs a local variable statement. This represents the declaration of a variable inside of a method.

[Visual Basic]
Overloads Function CreateLocalVariableStatement( _
   ByVal type As ICodeClass, _
   ByVal rank As Integer, _
   ByVal name As String, _
   ByVal value As Object _
) As ICodeLocalVariableStatement
[C#]
ICodeLocalVariableStatement CreateLocalVariableStatement(
   ICodeClass type,
   int rank,
   string name,
   object value
);
[C++]
ICodeLocalVariableStatement* CreateLocalVariableStatement(
   ICodeClass* type,
   int rank,
   String* name,
   Object* value
) = 0;
[JScript]
function CreateLocalVariableStatement(
   type : ICodeClass,
   rank : int,
   name : String,
   value : Object
) : ICodeLocalVariableStatement;

Parameters

type
The data type of the variable to create.
rank
The array rank of the variable. This refers to the number of array dimensions. Pass 0 in for rank for a non array type.
name
The name to give the object.
value
The value to initialize the object with. Passing a null reference (in Visual Basic Nothing) as the value will result in no initialization. This can either be a variant for a specific value, or an object that implements one of the expression interfaces.

Return Value

The newly created local variable statement.

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace | ICodeSourceFile.CreateLocalVariableStatement Overload List | ICodeArrayCreateExpression | ICodeObjectCreateExpression | ICodeMethodInvokeExpression | ICodeNameReferenceExpression


ICodeSourceFile.CreateLocalVariableStatement (ICodeClass, String, Object)

Constructs a local variable statement. This represents the declaration of a variable inside of a method.

[Visual Basic]
Overloads Function CreateLocalVariableStatement( _
   ByVal type As ICodeClass, _
   ByVal name As String, _
   ByVal value As Object _
) As ICodeLocalVariableStatement
[C#]
ICodeLocalVariableStatement CreateLocalVariableStatement(
   ICodeClass type,
   string name,
   object value
);
[C++]
ICodeLocalVariableStatement* CreateLocalVariableStatement(
   ICodeClass* type,
   String* name,
   Object* value
) = 0;
[JScript]
function CreateLocalVariableStatement(
   type : ICodeClass,
   name : String,
   value : Object
) : ICodeLocalVariableStatement;

Parameters

type
The data type of the variable to create.
name
The name to give the object.
value
The value to initialize the object with. Passing a null reference (in Visual Basic Nothing) as the value will result in no initialization. This can either be a variant for a specific value, or an object that implements one of the expression interfaces.

Return Value

The newly created local variable statement.

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace | ICodeSourceFile.CreateLocalVariableStatement Overload List | ICodeArrayCreateExpression | ICodeObjectCreateExpression | ICodeMethodInvokeExpression | ICodeNameReferenceExpression


ICodeSourceFile.CreateMethodInvokeExpression

Constructs a new method invoke expression.

[Visual Basic]
Function CreateMethodInvokeExpression( _
   ByVal target() As String, _
   ByVal targetType As ICodeClass, _
   ByVal methodName As String, _
   ByVal parameters() As ICodeParameter _
) As ICodeMethodInvokeExpression
[C#]
ICodeMethodInvokeExpression CreateMethodInvokeExpression(
   string[] target,
   ICodeClass targetType,
   string methodName,
   ICodeParameter[] parameters
);
[C++]
ICodeMethodInvokeExpression* CreateMethodInvokeExpression(
   String* target[],
   ICodeClass* targetType,
   String* methodName,
   ICodeParameter* parameters[]
) = 0;
[JScript]
function CreateMethodInvokeExpression(
   target : String[],
   targetType : ICodeClass,
   methodName : String,
   parameters : ICodeParameter[]
) : ICodeMethodInvokeExpression;

Parameters

target
An array of names to invoke. These targets must be subobjects. For example, to create a method invoke expression for this code:
Panel1.Children.Add new Control()

You would need to pass in a string array that contained "Panel1" and "Children".

targetType
[To be supplied.]
methodName
The name of the method to invoke.
parameters
An array of ICodeParameter objects to invoke the method with.

Return Value

The newly created method invoke expression.

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace | CreateParameter


ICodeSourceFile.CreateMethodInvokeStatement

Constructs a method invoke statement.

[Visual Basic]
Function CreateMethodInvokeStatement( _
   ByVal target() As String, _
   ByVal targetType As ICodeClass, _
   ByVal methodName As String, _
   ByVal parameters() As ICodeParameter, _
   ByVal designTime As Boolean _
) As ICodeMethodInvokeStatement
[C#]
ICodeMethodInvokeStatement CreateMethodInvokeStatement(
   string[] target,
   ICodeClass targetType,
   string methodName,
   ICodeParameter[] parameters,
   bool designTime
);
[C++]
ICodeMethodInvokeStatement* CreateMethodInvokeStatement(
   String* target[],
   ICodeClass* targetType,
   String* methodName,
   ICodeParameter* parameters[],
   bool designTime
) = 0;
[JScript]
function CreateMethodInvokeStatement(
   target : String[],
   targetType : ICodeClass,
   methodName : String,
   parameters : ICodeParameter[],
   designTime : Boolean
) : ICodeMethodInvokeStatement;

Parameters

target
Array of names to invoke. These statement must be subobjects. For example, to create a method invoke expression for this code:
Panel1.Children.Add new Control()

You would need to pass in a string array that contained "Panel1" and "Children".

targetType
[To be supplied.]
methodName
The name of the method to invoke.
parameters
An array of ICodeParameter objects to invoke the method with.
designTime
Whether this method should only be available at design time. A design time method is commented in the persisted source code but interpreted at design time.

Return Value

The newly created method invoke statement.

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace | CreateParameter


ICodeSourceFile.CreateMethodReferenceExpression

Constructs a name reference expression for a method. A name reference is basically a reference to any object in this objects namespace (or an absolute reference to any object).

[Visual Basic]
Function CreateMethodReferenceExpression( _
   ByVal name As String _
) As ICodeNameReferenceExpression
[C#]
ICodeNameReferenceExpression CreateMethodReferenceExpression(
   string name
);
[C++]
ICodeNameReferenceExpression* CreateMethodReferenceExpression(
   String* name
) = 0;
[JScript]
function CreateMethodReferenceExpression(
   name : String
) : ICodeNameReferenceExpression;

Parameters

name
The name of the object to reference.

Return Value

The newly created name reference expression.

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace


ICodeSourceFile.CreateNameReferenceExpression

[To be supplied.]

Overload List

Constructs a name reference expression. A name reference is basically a reference to any object in this object's namespace (or an absolute reference to any object).

[Visual Basic] Overloads Function CreateNameReferenceExpression(String()) As ICodeNameReferenceExpression
[C#] ICodeNameReferenceExpression CreateNameReferenceExpression(String[]);
[C++] ICodeNameReferenceExpression* CreateNameReferenceExpression(String*[]) = 0;
[JScript] function CreateNameReferenceExpression(String[]) : ICodeNameReferenceExpression;

Constructs a name reference expression. A name reference is basically a reference to any object in this object's namespace (or an absolute reference to any object).

[Visual Basic] Overloads Function CreateNameReferenceExpression(String) As ICodeNameReferenceExpression
[C#] ICodeNameReferenceExpression CreateNameReferenceExpression(String);
[C++] ICodeNameReferenceExpression* CreateNameReferenceExpression(String*) = 0;
[JScript] function CreateNameReferenceExpression(String) : ICodeNameReferenceExpression;

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace


ICodeSourceFile.CreateNameReferenceExpression (String[])

Constructs a name reference expression. A name reference is basically a reference to any object in this object's namespace (or an absolute reference to any object).

[Visual Basic]
Overloads Function CreateNameReferenceExpression( _
   ByVal name() As String _
) As ICodeNameReferenceExpression
[C#]
ICodeNameReferenceExpression CreateNameReferenceExpression(
   string[] name
);
[C++]
ICodeNameReferenceExpression* CreateNameReferenceExpression(
   String* name[]
) = 0;
[JScript]
function CreateNameReferenceExpression(
   name : String[]
) : ICodeNameReferenceExpression;

Parameters

name
The name of the object to reference.

Return Value

The newly created name reference expression.

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace | ICodeSourceFile.CreateNameReferenceExpression Overload List


ICodeSourceFile.CreateNameReferenceExpression (String)

Constructs a name reference expression. A name reference is basically a reference to any object in this object's namespace (or an absolute reference to any object).

[Visual Basic]
Overloads Function CreateNameReferenceExpression( _
   ByVal name As String _
) As ICodeNameReferenceExpression
[C#]
ICodeNameReferenceExpression CreateNameReferenceExpression(
   string name
);
[C++]
ICodeNameReferenceExpression* CreateNameReferenceExpression(
   String* name
) = 0;
[JScript]
function CreateNameReferenceExpression(
   name : String
) : ICodeNameReferenceExpression;

Parameters

name
The name of the object to reference.

Return Value

The newly created name reference expression.

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace | ICodeSourceFile.CreateNameReferenceExpression Overload List


ICodeSourceFile.CreateObjectCreateExpression

Constructs a new object creation expression.

[Visual Basic]
Function CreateObjectCreateExpression( _
   ByVal type As ICodeClass, _
   ByVal arguments() As Object _
) As ICodeObjectCreateExpression
[C#]
ICodeObjectCreateExpression CreateObjectCreateExpression(
   ICodeClass type,
   object[] arguments
);
[C++]
ICodeObjectCreateExpression* CreateObjectCreateExpression(
   ICodeClass* type,
   Object* arguments[]
) = 0;
[JScript]
function CreateObjectCreateExpression(
   type : ICodeClass,
   arguments : Object[]
) : ICodeObjectCreateExpression;

Parameters

type
The type of the object to create.
arguments
[To be supplied.]

Return Value

The newly created object creation expression.

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace


ICodeSourceFile.CreateParameter

Constructs a new parameter object.

[Visual Basic]
Function CreateParameter( _
   ByVal name As String, _
   ByVal type As ICodeClass, _
   ByVal value As Object _
) As ICodeParameter
[C#]
ICodeParameter CreateParameter(
   string name,
   ICodeClass type,
   object value
);
[C++]
ICodeParameter* CreateParameter(
   String* name,
   ICodeClass* type,
   Object* value
) = 0;
[JScript]
function CreateParameter(
   name : String,
   type : ICodeClass,
   value : Object
) : ICodeParameter;

Parameters

name
The name to give the parameter.
type
The type of the parameter.
value
The default value for the parameter. Passing in a null reference (in Visual Basic Nothing) for this will result in no default being set. This can either be a Variant, to represent a specific value, or an object that implements one of the expression interfaces.

Return Value

The newly created parameter object.

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace | ICodeArrayCreateExpression | ICodeObjectCreateExpression | ICodeMethodInvokeExpression | ICodeNameReferenceExpression


ICodeSourceFile.CreatePropertySetStatement

Constructs a property set statement. This represents a single property set inside of a method.

[Visual Basic]
Function CreatePropertySetStatement( _
   ByVal target() As String, _
   ByVal targetType As ICodeClass, _
   ByVal propertyName As String, _
   ByVal neededPropType As ICodeClass, _
   ByVal value As Object, _
   ByVal reference As Boolean, _
   ByVal designTime As Boolean _
) As ICodePropertySetStatement
[C#]
ICodePropertySetStatement CreatePropertySetStatement(
   string[] target,
   ICodeClass targetType,
   string propertyName,
   ICodeClass neededPropType,
   object value,
   bool reference,
   bool designTime
);
[C++]
ICodePropertySetStatement* CreatePropertySetStatement(
   String* target[],
   ICodeClass* targetType,
   String* propertyName,
   ICodeClass* neededPropType,
   Object* value,
   bool reference,
   bool designTime
) = 0;
[JScript]
function CreatePropertySetStatement(
   target : String[],
   targetType : ICodeClass,
   propertyName : String,
   neededPropType : ICodeClass,
   value : Object,
   reference : Boolean,
   designTime : Boolean
) : ICodePropertySetStatement;

Parameters

target
An array of names to set the property on. These targets must be subobjects. For example, to create a property set expression for this code:
Panel1.Children.Items myControlArray

You would need to pass in a string array that contained "Panel1" and "Children".

targetType
[To be supplied.]
propertyName
[To be supplied.]
neededPropType
If the'value' isn't the correct type, then this can be set to any type. The code generator will then generate any needed casts or conversions to ensure type consistency.
value
The value to set the property to. This can either be a variant for a specific value, or an object that implements one of the expression interfaces.
reference
[To be supplied.]
designTime
Whether this method should only be available at design time. A design time method is commented in the persisted source code but interpreted at design time.

Return Value

The newly created code property set.

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace | ICodeArrayCreateExpression | ICodeObjectCreateExpression | ICodeMethodInvokeExpression | ICodeNameReferenceExpression


ICodeSourceFile.CreateReturnValueStatement

Constructs a return value statement.

[Visual Basic]
Function CreateReturnValueStatement( _
   ByVal method As ICodeMethod, _
   ByVal returnvalueType As ICodeClass, _
   ByVal returnValue As Object _
) As ICodeReturnValueStatement
[C#]
ICodeReturnValueStatement CreateReturnValueStatement(
   ICodeMethod method,
   ICodeClass returnvalueType,
   object returnValue
);
[C++]
ICodeReturnValueStatement* CreateReturnValueStatement(
   ICodeMethod* method,
   ICodeClass* returnvalueType,
   Object* returnValue
) = 0;
[JScript]
function CreateReturnValueStatement(
   method : ICodeMethod,
   returnvalueType : ICodeClass,
   returnValue : Object
) : ICodeReturnValueStatement;

Parameters

method
The method which will be returning a value.
returnvalueType
The type of value to be returned.
returnValue
The value to be returned.

Return Value

The newly created return value statement.

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace


ICodeSourceFile.FindPublicClasses

Gets an array of all the public classes that are defined in this file.

[Visual Basic]
Function FindPublicClasses() As ICodeClass ()
[C#]
ICodeClass[] FindPublicClasses();
[C++]
ICodeClass* FindPublicClasses() [] = 0;
[JScript]
function FindPublicClasses() : ICodeClass[];

Return Value

An array of ICodeClass objects listing the public classes defined in this file.

Remarks

Usually this will only return a single item.

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace


ICodeSourceFile.GenerateUniqueDataMemberName

[To be supplied.]

Overload List

Generates a unique valid identifier name for a data member of the specified type.

[Visual Basic] Overloads Function GenerateUniqueDataMemberName(ICodeClass, String()) As String
[C#] string GenerateUniqueDataMemberName(ICodeClass, String[]);
[C++] String* GenerateUniqueDataMemberName(ICodeClass*, String[]) = 0;
[JScript] function GenerateUniqueDataMemberName(ICodeClass, String[]) : String;

Generates a unique valid identifier name for a data member using the specified base name.

[Visual Basic] Overloads Function GenerateUniqueDataMemberName(String, String()) As String
[C#] string GenerateUniqueDataMemberName(String, String[]);
[C++] String* GenerateUniqueDataMemberName(String*, String*[]) = 0;
[JScript] function GenerateUniqueDataMemberName(String, String[]) : String;

Generates a unique valid identifier name for a data member of the specified type.

[Visual Basic] Overloads Function GenerateUniqueDataMemberName(ICodeClass) As String
[C#] string GenerateUniqueDataMemberName(ICodeClass);
[C++] String* GenerateUniqueDataMemberName(ICodeClass*) = 0;
[JScript] function GenerateUniqueDataMemberName(ICodeClass) : String;

Generates a unique valid identifier name for a data member using the specified base name.

[Visual Basic] Overloads Function GenerateUniqueDataMemberName(String) As String
[C#] string GenerateUniqueDataMemberName(String);
[C++] String* GenerateUniqueDataMemberName(String*) = 0;
[JScript] function GenerateUniqueDataMemberName(String) : String;

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace


ICodeSourceFile.GenerateUniqueDataMemberName (ICodeClass, String[])

Generates a unique valid identifier name for a data member of the specified type.

[Visual Basic]
Overloads Function GenerateUniqueDataMemberName( _
   ByVal memberType As ICodeClass, _
   ByVal exceptions() As String _
) As String
[C#]
string GenerateUniqueDataMemberName(
   ICodeClass memberType,
   string[] exceptions
);
[C++]
String* GenerateUniqueDataMemberName(
   ICodeClass* memberType,
   String* exceptions[]
) = 0;
[JScript]
function GenerateUniqueDataMemberName(
   memberType : ICodeClass,
   exceptions : String[]
) : String;

Parameters

memberType
The type of the member to generate a name for.
exceptions
The names to avoid assigning.

Remarks

The purpose of this is to allow designers to create names of instance variables that won't conflict with existing members. It is most common for the language service to return a name of the form "className[N]" where [N] is a number starting at 1. For example "button1", "button2", etc..

The exceptions parameter allows the caller to supply a set of names to be excluded when searching for a unique data member name. This is useful if the caller already has a set of names that the source file does not know about.

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace | ICodeSourceFile.GenerateUniqueDataMemberName Overload List


ICodeSourceFile.GenerateUniqueDataMemberName (String, String[])

Generates a unique valid identifier name for a data member using the specified base name.

[Visual Basic]
Overloads Function GenerateUniqueDataMemberName( _
   ByVal baseName As String, _
   ByVal exceptions() As String _
) As String
[C#]
string GenerateUniqueDataMemberName(
   string baseName,
   string[] exceptions
);
[C++]
String* GenerateUniqueDataMemberName(
   String* baseName,
   String* exceptions[]
) = 0;
[JScript]
function GenerateUniqueDataMemberName(
   baseName : String,
   exceptions : String[]
) : String;

Parameters

baseName
The base name to use for the member name.
exceptions
The names to avoid assigning.

Remarks

The purpose of this is to allow designers to create names of instance variables that won't conflict with existing members. It is most common for the language service to return a name of the form "className[N]" where [N] is a number starting at 1. For example "button1", "button2", etc..

The exceptions parameter allows the caller to supply a set of names to be excluded when searching for a unique data member name. This is useful if the caller already has a set of names that the source file does not know about.

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace | ICodeSourceFile.GenerateUniqueDataMemberName Overload List


ICodeSourceFile.GenerateUniqueDataMemberName (ICodeClass)

Generates a unique valid identifier name for a data member of the specified type.

[Visual Basic]
Overloads Function GenerateUniqueDataMemberName( _
   ByVal memberType As ICodeClass _
) As String
[C#]
string GenerateUniqueDataMemberName(
   ICodeClass memberType
);
[C++]
String* GenerateUniqueDataMemberName(
   ICodeClass* memberType
) = 0;
[JScript]
function GenerateUniqueDataMemberName(
   memberType : ICodeClass
) : String;

Parameters

memberType
The type of the member to generate a name for.

Remarks

The purpose of this is to allow designers to create names of instance variables that won't conflict with existing members. It is most common for the language service to return a name of the form "className[N]" where [N] is a number starting at 1. For example "button1", "button2", etc..

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace | ICodeSourceFile.GenerateUniqueDataMemberName Overload List


ICodeSourceFile.GenerateUniqueDataMemberName (String)

Generates a unique valid identifier name for a data member using the specified base name.

[Visual Basic]
Overloads Function GenerateUniqueDataMemberName( _
   ByVal baseName As String _
) As String
[C#]
string GenerateUniqueDataMemberName(
   string baseName
);
[C++]
String* GenerateUniqueDataMemberName(
   String* baseName
) = 0;
[JScript]
function GenerateUniqueDataMemberName(
   baseName : String
) : String;

Parameters

baseName
The base name to use for the member name.

Remarks

The purpose of this is to allow designers to create names of instance variables that won't conflict with existing members. It is most common for the language service to return a name of the form "className[N]" where [N] is a number starting at 1. For example "button1", "button2", etc..

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace | ICodeSourceFile.GenerateUniqueDataMemberName Overload List


ICodeSourceFile.GetCodeGenerator

Gets the code generator for this ICodeSourceFile.

[Visual Basic]
Function GetCodeGenerator() As ICodeGenerator
[C#]
ICodeGenerator GetCodeGenerator();
[C++]
ICodeGenerator* GetCodeGenerator() = 0;
[JScript]
function GetCodeGenerator() : ICodeGenerator;

Return Value

The ICodeGenerator for this file.

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace


ICodeSourceFile.GetDescription

Gets the description of this file.

[Visual Basic]
Function GetDescription() As String
[C#]
string GetDescription();
[C++]
String* GetDescription() = 0;
[JScript]
function GetDescription() : String;

Return Value

A description of this file.

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace


ICodeSourceFile.GetElements

Gets the collection of elements contained in this file.

[Visual Basic]
Function GetElements() As ICodeElements
[C#]
ICodeElements GetElements();
[C++]
ICodeElements* GetElements() = 0;
[JScript]
function GetElements() : ICodeElements;

Return Value

A collection of elements contained in this file.

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace


ICodeSourceFile.GetIgnoreCase

Gets whether case is ignored in the underlying language or not.

[Visual Basic]
Function GetIgnoreCase() As Boolean
[C#]
bool GetIgnoreCase();
[C++]
bool GetIgnoreCase() = 0;
[JScript]
function GetIgnoreCase() : Boolean;

Return Value

true if case is ignored in the underlying language, otherwise false.

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace


ICodeSourceFile.GetPath

Gets the physical path of this file. This may be a URL.

[Visual Basic]
Function GetPath() As String
[C#]
string GetPath();
[C++]
String* GetPath() = 0;
[JScript]
function GetPath() : String;

Return Value

The path to this file.

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace


ICodeSourceFile.IsSelfReferenceKeyword

Determines if the token refers to the "this" or "me" object.

[Visual Basic]
Function IsSelfReferenceKeyword( _
   ByVal token As String _
) As Boolean
[C#]
bool IsSelfReferenceKeyword(
   string token
);
[C++]
bool IsSelfReferenceKeyword(
   String* token
) = 0;
[JScript]
function IsSelfReferenceKeyword(
   token : String
) : Boolean;

Parameters

token
The token to check for "this"-ness.

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace


ICodeSourceFile.IsValidIdentifier

Determines if the identifier is valid to be used. This will not check for duplicates, but rather ensure that the identifier is not a reserved word, keyword, or other illegal identifier.

[Visual Basic]
Function IsValidIdentifier( _
   ByVal identifier As String _
) As Boolean
[C#]
bool IsValidIdentifier(
   string identifier
);
[C++]
bool IsValidIdentifier(
   String* identifier
) = 0;
[JScript]
function IsValidIdentifier(
   identifier : String
) : Boolean;

Parameters

identifier
The identifier to check for validity.

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace


ICodeSourceFile.ParseStatements

Parses the given set of statements into code elements.

[Visual Basic]
Function ParseStatements( _
   ByVal code As String _
) As ICodeElement ()
[C#]
ICodeElement[] ParseStatements(
   string code
);
[C++]
ICodeElement* ParseStatements(
   String* code
) [] = 0;
[JScript]
function ParseStatements(
   code : String
) : ICodeElement[];

Parameters

code
The statements to be parsed.

Return Value

An array of ICodeElements produced based on the specified statements.

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace


ICodeSourceFile.ReplaceText

Replaces a section of text in the file with the sepecified text.

[Visual Basic]
Sub ReplaceText( _
   ByVal start As Integer, _
   ByVal count As Integer, _
   ByVal text As String _
)
[C#]
void ReplaceText(
   int start,
   int count,
   string text
);
[C++]
void ReplaceText(
   int start,
   int count,
   String* text
) = 0;
[JScript]
function ReplaceText(
   start : int,
   count : int,
   text : String
);

Parameters

start
The character position to start inserting at.
count
The number of characters to remove from the stream before inserting text.
text
The text to insert into the stream.

Remarks

Note This method is primarily used by other CodeSense objects. The primary way for users to manipulate the text contained in a source file should be through manipulating the object model, rather than directly editing the file.

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace


ICodeSourceFile.ShortestClassName

Determines the shortest name using the schema that will uniquely identify the specified class, given any namesapce and imports in this file.

[Visual Basic]
Function ShortestClassName( _
   ByVal cls As ICodeClass _
) As String
[C#]
string ShortestClassName(
   ICodeClass cls
);
[C++]
String* ShortestClassName(
   ICodeClass* cls
) = 0;
[JScript]
function ShortestClassName(
   cls : ICodeClass
) : String;

Parameters

cls
The class to determine the name for.

Return Value

Short name to reference the class.

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace


ICodeSourceFile.ShowText

[To be supplied.]

Overload List

Shows the text in the file, but doesn't move the caret from its current position.

[Visual Basic] Overloads Sub ShowText()
[C#] void ShowText();
[C++] void ShowText() = 0;
[JScript] function ShowText();

Shows the text in the file and moves the caret to the given positon.

[Visual Basic] Overloads Sub ShowText(Integer)
[C#] void ShowText(int);
[C++] void ShowText(int) = 0;
[JScript] function ShowText(int);

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace


ICodeSourceFile.ShowText ()

Shows the text in the file, but doesn't move the caret from its current position.

[Visual Basic]
Overloads Sub ShowText()
[C#]
void ShowText();
[C++]
void ShowText() = 0;
[JScript]
function ShowText();

Remarks

This method will do nothing if it was unable to show the file.

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace | ICodeSourceFile.ShowText Overload List


ICodeSourceFile.ShowText (Int32)

Shows the text in the file and moves the caret to the given positon.

[Visual Basic]
Overloads Sub ShowText( _
   ByVal caretPosition As Integer _
)
[C#]
void ShowText(
   int caretPosition
);
[C++]
void ShowText(
   int caretPosition
) = 0;
[JScript]
function ShowText(
   caretPosition : int
);

Parameters

caretPosition
[To be supplied.]

Remarks

This will do nothing if it was unable to show the file.

See Also

ICodeSourceFile Interface | ICodeSourceFile Members | System.ComponentModel.Design.CodeModel Namespace | ICodeSourceFile.ShowText Overload List


ICodeStatement Interface

Represents a single statement in the source file.

ICodeStatement

[Visual Basic]
Public Interface ICodeStatement
   Implements ICodeElement
[C#]
public interface ICodeStatement : ICodeElement
[C++]
public __gc __interface ICodeStatement : public ICodeElement

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design.CodeModel

Assembly: System.dll

See Also

ICodeStatement Members | System.ComponentModel.Design.CodeModel Namespace


ICodeStatement Members

Methods

GetDesignTime | Gets the current design-time status of this element.
SetDesignTime | Sets the current design-time only status of this element.

See Also

ICodeStatement Interface | System.ComponentModel.Design.CodeModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeStatement Methods

The methods of the ICodeStatement interface are listed below. For a complete list of ICodeStatement interface members, see the ICodeStatement Members topic.

GetDesignTime | Gets the current design-time status of this element.
SetDesignTime | Sets the current design-time only status of this element.

See Also

ICodeStatement Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeStatement.GetDesignTime

Gets the current design-time status of this element.

[Visual Basic]
Function GetDesignTime() As Boolean
[C#]
bool GetDesignTime();
[C++]
bool GetDesignTime() = 0;
[JScript]
function GetDesignTime() : Boolean;

Return Value

Whether or not the current status of this element is set to design-time only.

Remarks

When an element is set to design-time only, the element will exist in the code in such a way as to not be a part of the compile at runtime. This element will still be available at design time.

See Also

ICodeStatement Interface | ICodeStatement Members | System.ComponentModel.Design.CodeModel Namespace


ICodeStatement.SetDesignTime

Sets the current design-time only status of this element.

[Visual Basic]
Sub SetDesignTime( _
   ByVal value As Boolean _
)
[C#]
void SetDesignTime(
   bool value
);
[C++]
void SetDesignTime(
   bool value
) = 0;
[JScript]
function SetDesignTime(
   value : Boolean
);

Parameters

value
The new design-time status.

Remarks

When an element is set to design-time only, it will exist in the code in such a way as to not be a part of the compile at runtime. This element will still be available at design time.

See Also

ICodeStatement Interface | ICodeStatement Members | System.ComponentModel.Design.CodeModel Namespace


ICodeStatements Interface

Collection of ICodeStatement objects.

ICodeStatements

[Visual Basic]
Public Interface ICodeStatements
[C#]
public interface ICodeStatements
[C++]
public __gc __interface ICodeStatements

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.ComponentModel.Design.CodeModel

Assembly: System.dll

See Also

ICodeStatements Members | System.ComponentModel.Design.CodeModel Namespace


ICodeStatements Members

Methods

Add | Adds a new statement to the collection.
GetCount | Gets the number of statements currently in the collection.
GetItemAt | Gets the statement at the specified index.
GetItems | Gets a snapshot of all contained statements.
SetItemAt | Sets the item at the specified index.
SetItems | Clears the current set of statements, and replaces them with the statements in value.

See Also

ICodeStatements Interface | System.ComponentModel.Design.CodeModel Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICodeStatements Methods

The methods of the ICodeStatements interface are listed below. For a complete list of ICodeStatements interface members, see the ICodeStatements Members topic.

Add | Adds a new statement to the collection.
GetCount | Gets the number of statements currently in the collection.
GetItemAt | Gets the statement at the specified index.
GetItems | Gets a snapshot of all contained statements.
SetItemAt | Sets the item at the specified index.
SetItems | Clears the current set of statements, and replaces them with the statements in value.

See Also

ICodeStatements Interface | System.ComponentModel.Design.CodeModel Namespace


ICodeStatements.Add

Adds a new statement to the collection.

[Visual Basic]
Sub Add( _
   ByVal item As ICodeStatement _
)
[C#]
void Add(
   ICodeStatement item
);
[C++]
void Add(
   ICodeStatement* item
) = 0;
[JScript]
function Add(
   item : ICodeStatement
);

Parameters

item
The statement to add to the collection.

See Also

ICodeStatements Interface | ICodeStatements Members | System.ComponentModel.Design.CodeModel Namespace


ICodeStatements.GetCount

Gets the number of statements currently in the collection.

[Visual Basic]
Function GetCount() As Integer
[C#]
int GetCount();
[C++]
int GetCount() = 0;
[JScript]
function GetCount() : int;

Return Value

The number of statements currently in the collection.

See Also

ICodeStatements Interface | ICodeStatements Members | System.ComponentModel.Design.CodeModel Namespace


ICodeStatements.GetItemAt

Gets the statement at the specified index.

[Visual Basic]
Function GetItemAt( _
   ByVal index As Integer _
) As ICodeStatement
[C#]
ICodeStatement GetItemAt(
   int index
);
[C++]
ICodeStatement* GetItemAt(
   int index
) = 0;
[JScript]
function GetItemAt(
   index : int
) : ICodeStatement;

Parameters

index
The index of the item to retrieve.

Return Value

The ICodeStatement at the specified index.

See Also

ICodeStatements Interface | ICodeStatements Members | System.ComponentModel.Design.CodeModel Namespace


ICodeStatements.GetItems

Gets a snapshot of all contained statements.

[Visual Basic]
Function GetItems() As ICodeStatement ()
[C#]
ICodeStatement[] GetItems();
[C++]
ICodeStatement* GetItems() [] = 0;
[JScript]
function GetItems() : ICodeStatement[];

Return Value

An array of type ICodeStatement representing all contained statements.

See Also

ICodeStatements Interface | ICodeStatements Members | System.ComponentModel.Design.CodeModel Namespace


ICodeStatements.SetItemAt

Sets the item at the specified index.

[Visual Basic]
Sub SetItemAt( _
   ByVal index As Integer, _
   ByVal value As ICodeStatement _
)
[C#]
void SetItemAt(
   int index,
   ICodeStatement value
);
[C++]
void SetItemAt(
   int index,
   ICodeStatement* value
) = 0;
[JScript]
function SetItemAt(
   index : int,
   value : ICodeStatement
);

Parameters

index
The index of the item to replace.
value
The statement to replace the existing statement with.

See Also

ICodeStatements Interface | ICodeStatements Members | System.ComponentModel.Design.CodeModel Namespace


ICodeStatements.SetItems

Clears the current set of statements, and replaces them with the statements in value.

[Visual Basic]
Sub SetItems( _
   ByVal value() As ICodeStatement _
)
[C#]
void SetItems(
   ICodeStatement[] value
);
[C++]
void SetItems(
   ICodeStatement* value[]
) = 0;
[JScript]
function SetItems(
   value : ICodeStatement[]
);

Parameters

value
The new array of statements.

See Also

ICodeStatements Interface | ICodeStatements Members | System.ComponentModel.Design.CodeModel Namespace


System.Configuration

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Configuration Namespace

Classes

Class | Description
AppDomainSelector | Indicates the location of the configuration file for the current AppDomain.
BaseConfigCollection | A generic implementation of the IConfigCollection interface.
BaseConfigItem | A generic implementation of the IConfigItem interface.
ConfigException | [To be supplied.]
ConfigManager | The Configuration System is designed to give system runtimes, administrative tools, applications and other consumers of configuration information easy and efficient access to configuration information, regardless of the details of the storage format and location of the configuration information.
ConfigQuery | Allows simple queries against configuration information.
FileSelector | Indicates the file location for configuration information that is stored in configuration files.
HttpSelector | Indicates the configuration file hierarchy for configuration information for web server configuration. The configuration system can convert the URL into a list of physical configuration file locations (FileSelector) and then performs a merge across the hierarchy of configuration files. Refer to Interceptors.IConfigTransformer and Interceptors.IConfigMerger for details.
LevelOfService | Allows the caller to control the behavior of the configuration system when retrieving configuration information.
LocalMachineSelector | Indicates the location of the machine configuration file.
NullSelector | Used for configuration information that does not require a location. For example, configuration schema information can be retrieved without specifying a configuration file.
QueryCell | A QueryCell represents one condition in the query. All QueryCells in the ConfigQuery are ANDed together to determine the outcome of the query.
Selector | Selectors indicates the storage location of configuration information. The configuration system defines several selector classes which all derive from the abstract Selector base class. Selectors are modeled after URLs. The configuration system itself uses the URL protocol prefix to determine the kind of storage location (file, web server file, query etc.). The individual selector classes determine the semantics of the remainder of the URL.

Interfaces

Interface | Description
IConfigCollection | Provides access to a collection of configuration items.
IConfigItem | Provides late-bound access to the properties in a configuration item.

Enumerations

Enumeration | Description
PutFlags | Controls how the Put methods behave when a previous item exists/does not exist in a configuration store.
QueryCellOp | Indicates how filtering should be performed.


AppDomainSelector Class

Indicates the location of the configuration file for the current AppDomain.

Object
Selector
Internal.UrlSelectorBase
FileSelector
AppDomainSelector

[Visual Basic]
Public Class AppDomainSelector
   Inherits FileSelector
[C#]
public class AppDomainSelector : FileSelector
[C++]
public __gc class AppDomainSelector : public FileSelector
[JScript]
public class AppDomainSelector extends FileSelector

Remarks

Instead of directly specifying a file location, applications can read from their own configuration file by using the AppDomainSelector instead of a FileSelector. The AppDomainSelector retrieves the location of the configuration file from the currently running application domain:

Tip The AppDomainSelector.Argument method retrieves the file path to the application configuration file.

Requirements

Namespace: System.Configuration

Assembly: System.Configuration.dll

Example [C#]

[C#]

[C#]
using System.Configuration;
using System.Configuration.Core;

IConfigCollection bindings = ConfigManager.Get("BindingPolicy", new AppDomainSelector());
foreach (bindingredir in bindings) {
  Console.WriteLine(bindingredir.Name+": "+bindingredir.Version);
}

See Also

AppDomainSelector Members | System.Configuration Namespace


AppDomainSelector Members

Public:

Constructor

AppDomainSelector Constructor Creates an AppDomainSelector for the current AppDomain.

Properties

Argument (inherited from UrlSelectorBase) | [To be supplied.]
Prefix | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AppDomainSelector Class | System.Configuration Namespace


AppDomainSelector Constructor

Creates an AppDomainSelector for the current AppDomain.

[Visual Basic]
Public Sub New()
[C#]
public AppDomainSelector();
[C++]
public: AppDomainSelector();
[JScript]
public function AppDomainSelector();

See Also

AppDomainSelector Class | AppDomainSelector Members | System.Configuration Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AppDomainSelector Properties

The properties of the AppDomainSelector class are listed below. For a complete list of AppDomainSelector class members, see the AppDomainSelector Members topic.

Public:

Argument (inherited from UrlSelectorBase) | [To be supplied.]
Prefix | [To be supplied.]

See Also

AppDomainSelector Class | System.Configuration Namespace


AppDomainSelector.Prefix

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Prefix As String
[C#]
public string Prefix {override get;}
[C++]
public: __property virtual String* get_Prefix();
[JScript]
public function get Prefix() : String;

Property Value

Returns "appdomain" as the prefix for the AppDomainSelector.

See Also

AppDomainSelector Class | AppDomainSelector Members | System.Configuration Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AppDomainSelector Methods

The methods of the AppDomainSelector class are listed below. For a complete list of AppDomainSelector class members, see the AppDomainSelector Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AppDomainSelector Class | System.Configuration Namespace


AppDomainSelector.ToString

[To be supplied.]

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

Returns "appdomain://" as the string representation of an AppDomainSelector.

See Also

AppDomainSelector Class | AppDomainSelector Members | System.Configuration Namespace


BaseConfigCollection Class

A generic implementation of the IConfigCollection interface.

Object
BaseConfigCollection

[Visual Basic]
Public Class BaseConfigCollection
   Implements IConfigCollection, ICloneable, IList, ICollection, _
   IEnumerable
[C#]
public class BaseConfigCollection : IConfigCollection, ICloneable,
   IList, ICollection, IEnumerable
[C++]
public __gc class BaseConfigCollection : public IConfigCollection,
   ICloneable, IList, ICollection, IEnumerable
[JScript]
public class BaseConfigCollection implements IConfigCollection,
   ICloneable, IList, ICollection, IEnumerable

Remarks

The configuration system returns a BaseConfigCollection when no strongly typed accessor class has been defined in the schema for the ConfigType (CollectionClass attribute).

Requirements

Namespace: System.Configuration

Assembly: System.Configuration.dll

See Also

BaseConfigCollection Members | System.Configuration Namespace


BaseConfigCollection Members

Public:

Constructor

BaseConfigCollection Constructor [To be supplied.]

Properties

ConfigType | [To be supplied.]
Count | [To be supplied.]
IsFrozen | [To be supplied.]
IsReadOnly | [To be supplied.]
IsSynchronized | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the BaseConfigCollection class.
Selector | [To be supplied.]
SyncRoot | [To be supplied.]

Methods

Add | Overloaded. [To be supplied.]
Clear | [To be supplied.]
Clone | [To be supplied.]
Contains | [To be supplied.]
CopyTo | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FindByKey | Overloaded. [To be supplied.]
Freeze | [To be supplied.]
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | Overloaded. [To be supplied.]
Insert | Overloaded. [To be supplied.]
Remove | [To be supplied.]
RemoveAt | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseConfigCollection Class | System.Configuration Namespace


BaseConfigCollection Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public BaseConfigCollection();
[C++]
public: BaseConfigCollection();
[JScript]
public function BaseConfigCollection();

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

BaseConfigCollection Properties

The properties of the BaseConfigCollection class are listed below. For a complete list of BaseConfigCollection class members, see the BaseConfigCollection Members topic.

Public:

ConfigType | [To be supplied.]
Count | [To be supplied.]
IsFrozen | [To be supplied.]
IsReadOnly | [To be supplied.]
IsSynchronized | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the BaseConfigCollection class.
Selector | [To be supplied.]
SyncRoot | [To be supplied.]

See Also

BaseConfigCollection Class | System.Configuration Namespace


BaseConfigCollection.ConfigType

[To be supplied.]

[Visual Basic]
Overridable Public Property ConfigType As String
[C#]
public string ConfigType {virtual get; virtual set;}
[C++]
public: __property virtual String* get_ConfigType();
public: __property virtual void set_ConfigType(String*);
[JScript]
public function get ConfigType() : String;
public function set ConfigType(String);

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace


BaseConfigCollection.Count

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Count As Integer
[C#]
public int Count {virtual get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace


BaseConfigCollection.IsFrozen

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsFrozen As Boolean
[C#]
public bool IsFrozen {virtual get;}
[C++]
public: __property virtual bool get_IsFrozen();
[JScript]
public function get IsFrozen() : Boolean;

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace


BaseConfigCollection.IsReadOnly

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {virtual get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace


BaseConfigCollection.IsSynchronized

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsSynchronized As Boolean
[C#]
public bool IsSynchronized {virtual get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace


BaseConfigCollection.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the BaseConfigCollection class.

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Default Property Item(Integer) As IConfigItem
[C#] public IConfigItem this[int] {virtual get; virtual set;}
[C++] public: __property virtual IConfigItem* get_Item(int);
public: __property virtual void set_Item(int, IConfigItem*);
[JScript] BaseConfigCollection.Item (int)

[To be supplied.]

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(String) As IConfigItem
[C#] public IConfigItem this[String] {virtual get;}
[C++] public: __property virtual IConfigItem* get_Item(String*);
[JScript] BaseConfigCollection.Item (String)

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace


BaseConfigCollection.Item (Int32)

[To be supplied.]

[C#] In C#, this member is the indexer for the BaseConfigCollection class.

[Visual Basic]
Overloads Overridable Public Default Property Item( _
   ByVal Index As Integer _
) As IConfigItem
[C#]
public IConfigItem this[
   int Index
] {virtual get; virtual set;}
[C++]
public: __property virtual IConfigItem* get_Item(
   int Index
);
public: __property virtual void set_Item(
   int Index,
   IConfigItem*
);
[JScript]
returnValue = BaseConfigCollectionObject.Item(Index);
BaseConfigCollectionObject.Item(Index) = returnValue;
-or-
returnValue = BaseConfigCollectionObject(Index);
BaseConfigCollectionObject(Index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

Index
[To be supplied.]

Parameters [Visual Basic, C#, C++]

Index
[To be supplied.]

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace | BaseConfigCollection.Item Overload List


BaseConfigCollection.Item (String)

[To be supplied.]

[C#] In C#, this member is the indexer for the BaseConfigCollection class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal Key As String _
) As IConfigItem
[C#]
public IConfigItem this[
   string Key
] {virtual get;}
[C++]
public: __property virtual IConfigItem* get_Item(
   String* Key
);
[JScript]
returnValue = BaseConfigCollectionObject.Item(Key);
-or-
returnValue = BaseConfigCollectionObject(Key);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

Key
[To be supplied.]

Parameters [Visual Basic, C#, C++]

Key
[To be supplied.]

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace | BaseConfigCollection.Item Overload List


BaseConfigCollection.Selector

[To be supplied.]

[Visual Basic]
Overridable Public Property Selector As Selector
[C#]
public Selector Selector {virtual get; virtual set;}
[C++]
public: __property virtual Selector* get_Selector();
public: __property virtual void set_Selector(Selector*);
[JScript]
public function get Selector() : Selector;
public function set Selector(Selector);

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace


BaseConfigCollection.SyncRoot

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property SyncRoot As Object
[C#]
public object SyncRoot {virtual get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

BaseConfigCollection Methods

The methods of the BaseConfigCollection class are listed below. For a complete list of BaseConfigCollection class members, see the BaseConfigCollection Members topic.

Public:

Add | Overloaded. [To be supplied.]
Clear | [To be supplied.]
Clone | [To be supplied.]
Contains | [To be supplied.]
CopyTo | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FindByKey | Overloaded. [To be supplied.]
Freeze | [To be supplied.]
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | Overloaded. [To be supplied.]
Insert | Overloaded. [To be supplied.]
Remove | [To be supplied.]
RemoveAt | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseConfigCollection Class | System.Configuration Namespace


BaseConfigCollection.Add

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Add(Object) As Integer
[C#] public virtual int Add(Object);
[C++] public: virtual int Add(Object*);
[JScript] public function Add(Object) : int;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Add(IConfigItem) As Integer
[C#] public virtual int Add(IConfigItem);
[C++] public: virtual int Add(IConfigItem*);
[JScript] public function Add(IConfigItem) : int;

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace


BaseConfigCollection.Add (Object)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Add( _
   ByVal item As Object _
) As Integer
[C#]
public virtual int Add(
   object item
);
[C++]
public: virtual int Add(
   Object* item
);
[JScript]
public function Add(
   item : Object
) : int;

Parameters

item
[To be supplied.]

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace | BaseConfigCollection.Add Overload List


BaseConfigCollection.Add (IConfigItem)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Add( _
   ByVal Item As IConfigItem _
) As Integer
[C#]
public virtual int Add(
   IConfigItem Item
);
[C++]
public: virtual int Add(
   IConfigItem* Item
);
[JScript]
public function Add(
   Item : IConfigItem
) : int;

Parameters

Item
[To be supplied.]

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace | BaseConfigCollection.Add Overload List


BaseConfigCollection.Clear

[To be supplied.]

[Visual Basic]
Overridable Public Sub Clear()
[C#]
public virtual void Clear();
[C++]
public: virtual void Clear();
[JScript]
public function Clear();

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace


BaseConfigCollection.Clone

[To be supplied.]

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace


BaseConfigCollection.Contains

[To be supplied.]

[Visual Basic]
Overridable Public Function Contains( _
   ByVal item As Object _
) As Boolean
[C#]
public virtual bool Contains(
   object item
);
[C++]
public: virtual bool Contains(
   Object* item
);
[JScript]
public function Contains(
   item : Object
) : Boolean;

Parameters

item
[To be supplied.]

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace


BaseConfigCollection.CopyTo

[To be supplied.]

[Visual Basic]
Overridable Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
[C#]
public virtual void CopyTo(
   Array array,
   int index
);
[C++]
public: virtual void CopyTo(
   Array* array,
   int index
);
[JScript]
public function CopyTo(
   array : Array,
   index : int
);

Parameters

array
[To be supplied.]
index
[To be supplied.]

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace


BaseConfigCollection.FindByKey

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function FindByKey(Object()) As IConfigItem
[C#] public virtual IConfigItem FindByKey(Object[]);
[C++] public: virtual IConfigItem* FindByKey(Object*[]);
[JScript] public function FindByKey(Object[]) : IConfigItem;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function FindByKey(String) As IConfigItem
[C#] public virtual IConfigItem FindByKey(String);
[C++] public: virtual IConfigItem* FindByKey(String*);
[JScript] public function FindByKey(String) : IConfigItem;

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace


BaseConfigCollection.FindByKey (Object[])

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function FindByKey( _
   ByVal Key() As Object _
) As IConfigItem
[C#]
public virtual IConfigItem FindByKey(
   object[] Key
);
[C++]
public: virtual IConfigItem* FindByKey(
   Object* Key[]
);
[JScript]
public function FindByKey(
   Key : Object[]
) : IConfigItem;

Parameters

Key
[To be supplied.]

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace | BaseConfigCollection.FindByKey Overload List


BaseConfigCollection.FindByKey (String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function FindByKey( _
   ByVal Key As String _
) As IConfigItem
[C#]
public virtual IConfigItem FindByKey(
   string Key
);
[C++]
public: virtual IConfigItem* FindByKey(
   String* Key
);
[JScript]
public function FindByKey(
   Key : String
) : IConfigItem;

Parameters

Key
[To be supplied.]

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace | BaseConfigCollection.FindByKey Overload List


BaseConfigCollection.Freeze

[To be supplied.]

[Visual Basic]
Overridable Public Sub Freeze()
[C#]
public virtual void Freeze();
[C++]
public: virtual void Freeze();
[JScript]
public function Freeze();

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace


BaseConfigCollection.GetEnumerator

[To be supplied.]

[Visual Basic]
Overridable Public Function GetEnumerator() As IEnumerator
[C#]
public virtual IEnumerator GetEnumerator();
[C++]
public: virtual IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace


BaseConfigCollection.IndexOf

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function IndexOf(Object) As Integer
[C#] public virtual int IndexOf(Object);
[C++] public: virtual int IndexOf(Object*);
[JScript] public function IndexOf(Object) : int;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function IndexOf(IConfigItem) As Integer
[C#] public virtual int IndexOf(IConfigItem);
[C++] public: virtual int IndexOf(IConfigItem*);
[JScript] public function IndexOf(IConfigItem) : int;

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace


BaseConfigCollection.IndexOf (Object)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function IndexOf( _
   ByVal item As Object _
) As Integer
[C#]
public virtual int IndexOf(
   object item
);
[C++]
public: virtual int IndexOf(
   Object* item
);
[JScript]
public function IndexOf(
   item : Object
) : int;

Parameters

item
[To be supplied.]

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace | BaseConfigCollection.IndexOf Overload List


BaseConfigCollection.IndexOf (IConfigItem)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function IndexOf( _
   ByVal Item As IConfigItem _
) As Integer
[C#]
public virtual int IndexOf(
   IConfigItem Item
);
[C++]
public: virtual int IndexOf(
   IConfigItem* Item
);
[JScript]
public function IndexOf(
   Item : IConfigItem
) : int;

Parameters

Item
[To be supplied.]

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace | BaseConfigCollection.IndexOf Overload List


BaseConfigCollection.Insert

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Sub Insert(Integer, Object)
[C#] public virtual void Insert(int, Object);
[C++] public: virtual void Insert(int, Object);
[JScript] public function Insert(int, Object);

[To be supplied.]

[Visual Basic] Overloads Overridable Public Sub Insert(Integer, IConfigItem)
[C#] public virtual void Insert(int, IConfigItem);
[C++] public: virtual void Insert(int, IConfigItem);
[JScript] public function Insert(int, IConfigItem);

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace


BaseConfigCollection.Insert (Int32, Object)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Object _
)
[C#]
public virtual void Insert(
   int index,
   object value
);
[C++]
public: virtual void Insert(
   int index,
   Object* value
);
[JScript]
public function Insert(
   index : int,
   value : Object
);

Parameters

index
[To be supplied.]
value
[To be supplied.]

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace | BaseConfigCollection.Insert Overload List


BaseConfigCollection.Insert (Int32, IConfigItem)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Sub Insert( _
   ByVal Index As Integer, _
   ByVal Item As IConfigItem _
)
[C#]
public virtual void Insert(
   int Index,
   IConfigItem Item
);
[C++]
public: virtual void Insert(
   int Index,
   IConfigItem* Item
);
[JScript]
public function Insert(
   Index : int,
   Item : IConfigItem
);

Parameters

Index
[To be supplied.]
Item
[To be supplied.]

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace | BaseConfigCollection.Insert Overload List


BaseConfigCollection.Remove

[To be supplied.]

[Visual Basic]
Overridable Public Sub Remove( _
   ByVal value As Object _
)
[C#]
public virtual void Remove(
   object value
);
[C++]
public: virtual void Remove(
   Object* value
);
[JScript]
public function Remove(
   value : Object
);

Parameters

value
[To be supplied.]

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace


BaseConfigCollection.RemoveAt

[To be supplied.]

[Visual Basic]
Overridable Public Sub RemoveAt( _
   ByVal Index As Integer _
)
[C#]
public virtual void RemoveAt(
   int Index
);
[C++]
public: virtual void RemoveAt(
   int Index
);
[JScript]
public function RemoveAt(
   Index : int
);

Parameters

Index
[To be supplied.]

See Also

BaseConfigCollection Class | BaseConfigCollection Members | System.Configuration Namespace


BaseConfigItem Class

A generic implementation of the IConfigItem interface.

Object
BaseConfigItem

[Visual Basic]
Public Class BaseConfigItem
   Implements IConfigItem, ICloneable, ICollection, IEnumerable
[C#]
public class BaseConfigItem : IConfigItem, ICloneable, ICollection,
   IEnumerable
[C++]
public __gc class BaseConfigItem : public IConfigItem, ICloneable,
   ICollection, IEnumerable
[JScript]
public class BaseConfigItem implements IConfigItem, ICloneable,
   ICollection, IEnumerable

Remarks

The configuration system returns a BaseConfigItem when no strongly typed accessor class has been defined in the schema for the ConfigType (ItemClass attribute).

Requirements

Namespace: System.Configuration

Assembly: System.Configuration.dll

See Also

BaseConfigItem Members | System.Configuration Namespace


BaseConfigItem Members

Public:

Constructor

BaseConfigItem Constructor [To be supplied.]

Properties

Collection | [To be supplied.]
ConfigType | [To be supplied.]
Count | [To be supplied.]
IsFrozen | [To be supplied.]
IsReadOnly | [To be supplied.]
IsSynchronized | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the BaseConfigItem class.
Selector | [To be supplied.]
SyncRoot | [To be supplied.]

Methods

Clone | [To be supplied.]
CopyTo | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Freeze | [To be supplied.]
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseConfigItem Class | System.Configuration Namespace


BaseConfigItem Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal ObjectCount As Integer _
)
[C#]
public BaseConfigItem(
   int ObjectCount
);
[C++]
public: BaseConfigItem(
   int ObjectCount
);
[JScript]
public function BaseConfigItem(
   ObjectCount : int
);

Parameters

ObjectCount
[To be supplied.]

See Also

BaseConfigItem Class | BaseConfigItem Members | System.Configuration Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

BaseConfigItem Properties

The properties of the BaseConfigItem class are listed below. For a complete list of BaseConfigItem class members, see the BaseConfigItem Members topic.

Public:

Collection | [To be supplied.]
ConfigType | [To be supplied.]
Count | [To be supplied.]
IsFrozen | [To be supplied.]
IsReadOnly | [To be supplied.]
IsSynchronized | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the BaseConfigItem class.
Selector | [To be supplied.]
SyncRoot | [To be supplied.]

See Also

BaseConfigItem Class | System.Configuration Namespace


BaseConfigItem.Collection

[To be supplied.]

[Visual Basic]
Overridable Public Property Collection As IConfigCollection
[C#]
public IConfigCollection Collection {virtual get; virtual set;}
[C++]
public: __property virtual IConfigCollection* get_Collection();
public: __property virtual void set_Collection(IConfigCollection*);
[JScript]
public function get Collection() : IConfigCollection;
public function set Collection(IConfigCollection);

See Also

BaseConfigItem Class | BaseConfigItem Members | System.Configuration Namespace


BaseConfigItem.ConfigType

[To be supplied.]

[Visual Basic]
Overridable Public Property ConfigType As String
[C#]
public string ConfigType {virtual get; virtual set;}
[C++]
public: __property virtual String* get_ConfigType();
public: __property virtual void set_ConfigType(String*);
[JScript]
public function get ConfigType() : String;
public function set ConfigType(String);

See Also

BaseConfigItem Class | BaseConfigItem Members | System.Configuration Namespace


BaseConfigItem.Count

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Count As Integer
[C#]
public int Count {virtual get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;

See Also

BaseConfigItem Class | BaseConfigItem Members | System.Configuration Namespace


BaseConfigItem.IsFrozen

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsFrozen As Boolean
[C#]
public bool IsFrozen {virtual get;}
[C++]
public: __property virtual bool get_IsFrozen();
[JScript]
public function get IsFrozen() : Boolean;

See Also

BaseConfigItem Class | BaseConfigItem Members | System.Configuration Namespace


BaseConfigItem.IsReadOnly

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {virtual get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;

See Also

BaseConfigItem Class | BaseConfigItem Members | System.Configuration Namespace


BaseConfigItem.IsSynchronized

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsSynchronized As Boolean
[C#]
public bool IsSynchronized {virtual get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;

See Also

BaseConfigItem Class | BaseConfigItem Members | System.Configuration Namespace


BaseConfigItem.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the BaseConfigItem class.

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Default Property Item(String) As Object
[C#] public object this[String] {virtual get; virtual set;}
[C++] public: __property virtual Object* get_Item(String*);
public: __property virtual void set_Item(String*, Object*);
[JScript] BaseConfigItem.Item (String)

[To be supplied.]

[Visual Basic] Overloads Overridable Public Default Property Item(Integer) As Object
[C#] public object this[int] {virtual get; virtual set;}
[C++] public: __property virtual Object* get_Item(int);
public: __property virtual void set_Item(int, Object*);
[JScript] BaseConfigItem.Item (int)

See Also

BaseConfigItem Class | BaseConfigItem Members | System.Configuration Namespace


BaseConfigItem.Item (String)

[To be supplied.]

[C#] In C#, this member is the indexer for the BaseConfigItem class.

[Visual Basic]
Overloads Overridable Public Default Property Item( _
   ByVal PropertyName As String _
) As Object
[C#]
public object this[
   string PropertyName
] {virtual get; virtual set;}
[C++]
public: __property virtual Object* get_Item(
   String* PropertyName
);
public: __property virtual void set_Item(
   String* PropertyName,
   Object*
);
[JScript]
returnValue = BaseConfigItemObject.Item(PropertyName);
BaseConfigItemObject.Item(PropertyName) = returnValue;
-or-
returnValue = BaseConfigItemObject(PropertyName);
BaseConfigItemObject(PropertyName) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

PropertyName
[To be supplied.]

Parameters [Visual Basic, C#, C++]

PropertyName
[To be supplied.]

See Also

BaseConfigItem Class | BaseConfigItem Members | System.Configuration Namespace | BaseConfigItem.Item Overload List


BaseConfigItem.Item (Int32)

[To be supplied.]

[C#] In C#, this member is the indexer for the BaseConfigItem class.

[Visual Basic]
Overloads Overridable Public Default Property Item( _
   ByVal PropertyIndex As Integer _
) As Object
[C#]
public object this[
   int PropertyIndex
] {virtual get; virtual set;}
[C++]
public: __property virtual Object* get_Item(
   int PropertyIndex
);
public: __property virtual void set_Item(
   int PropertyIndex,
   Object*
);
[JScript]
returnValue = BaseConfigItemObject.Item(PropertyIndex);
BaseConfigItemObject.Item(PropertyIndex) = returnValue;
-or-
returnValue = BaseConfigItemObject(PropertyIndex);
BaseConfigItemObject(PropertyIndex) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

PropertyIndex
[To be supplied.]

Parameters [Visual Basic, C#, C++]

PropertyIndex
[To be supplied.]

See Also

BaseConfigItem Class | BaseConfigItem Members | System.Configuration Namespace | BaseConfigItem.Item Overload List


BaseConfigItem.Selector

[To be supplied.]

[Visual Basic]
Overridable Public Property Selector As Selector
[C#]
public Selector Selector {virtual get; virtual set;}
[C++]
public: __property virtual Selector* get_Selector();
public: __property virtual void set_Selector(Selector*);
[JScript]
public function get Selector() : Selector;
public function set Selector(Selector);

See Also

BaseConfigItem Class | BaseConfigItem Members | System.Configuration Namespace


BaseConfigItem.SyncRoot

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property SyncRoot As Object
[C#]
public object SyncRoot {virtual get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;

See Also

BaseConfigItem Class | BaseConfigItem Members | System.Configuration Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

BaseConfigItem Methods

The methods of the BaseConfigItem class are listed below. For a complete list of BaseConfigItem class members, see the BaseConfigItem Members topic.

Public:

Clone | [To be supplied.]
CopyTo | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Freeze | [To be supplied.]
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseConfigItem Class | System.Configuration Namespace


BaseConfigItem.Clone

[To be supplied.]

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

See Also

BaseConfigItem Class | BaseConfigItem Members | System.Configuration Namespace


BaseConfigItem.CopyTo

[To be supplied.]

[Visual Basic]
Overridable Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
[C#]
public virtual void CopyTo(
   Array array,
   int index
);
[C++]
public: virtual void CopyTo(
   Array* array,
   int index
);
[JScript]
public function CopyTo(
   array : Array,
   index : int
);

Parameters

array
[To be supplied.]
index
[To be supplied.]

See Also

BaseConfigItem Class | BaseConfigItem Members | System.Configuration Namespace


BaseConfigItem.Freeze

[To be supplied.]

[Visual Basic]
Overridable Public Sub Freeze()
[C#]
public virtual void Freeze();
[C++]
public: virtual void Freeze();
[JScript]
public function Freeze();

See Also

BaseConfigItem Class | BaseConfigItem Members | System.Configuration Namespace


BaseConfigItem.GetEnumerator

[To be supplied.]

[Visual Basic]
Overridable Public Function GetEnumerator() As IEnumerator
[C#]
public virtual IEnumerator GetEnumerator();
[C++]
public: virtual IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

See Also

BaseConfigItem Class | BaseConfigItem Members | System.Configuration Namespace


ConfigException Class

[To be supplied.]

Object
Exception
ApplicationException
ConfigException

[Visual Basic]
Public Class ConfigException
   Inherits ApplicationException
[C#]
public class ConfigException : ApplicationException
[C++]
public __gc class ConfigException : public ApplicationException
[JScript]
public class ConfigException extends ApplicationException

Remarks

[To be supplied.]

Requirements

Namespace: System.Configuration

Assembly: System.Configuration.dll

See Also

ConfigException Members | System.Configuration Namespace


ConfigException Members

Public:

Constructor

ConfigException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Fields

AllWiring | [To be supplied.]
AppDomainInvalidBaseDirectoryPrefix | [To be supplied.]
ColectionFrozen | [To be supplied.]
CollectionType | [To be supplied.]
ConfigQueryConfigTypeDifferent | [To be supplied.]
DBTYPENotSupported | [To be supplied.]
ErrorCode | [To be supplied.]
FileNotFound | [To be supplied.]
FileNotFoundMessage | [To be supplied.]
IndexOutOfBounds | [To be supplied.]
InterceptorCantServeRequest | [To be supplied.]
InterceptorError | [To be supplied.]
InterceptorNotFound | [To be supplied.]
InterceptorReturnedNull | [To be supplied.]
InvalidPropertyType | [To be supplied.]
InvalidQueryStringInvalidPropertyName | [To be supplied.]
InvalidQueryStringNoConfigType | [To be supplied.]
InvalidQueryStringNoEqual | [To be supplied.]
InvalidQueryStringNoValue | [To be supplied.]
InvalidQueryStringTwoSelectors | [To be supplied.]
InvalidSelector | [To be supplied.]
InvalidSelectorType | [To be supplied.]
InvalidType | [To be supplied.]
InvalidWiring | [To be supplied.]
ItemFrozen | [To be supplied.]
ItemType | [To be supplied.]
MetaNotPresent | [To be supplied.]
MoreThanOneItem | [To be supplied.]
MultipePrimaryKeys | [To be supplied.]
NoInterceptorKnew | [To be supplied.]
NotEnoughPrimaryKeys | [To be supplied.]
NotImplemented | [To be supplied.]
PropertyName | [To be supplied.]
SelectorNotSupported | [To be supplied.]
SelectorNotSupportedOnQuery | [To be supplied.]
WiringNotPresent | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

ConfigException Class | System.Configuration Namespace


ConfigException Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public ConfigException();
[C++] public: ConfigException();
[JScript] public function ConfigException();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public ConfigException(String);
[C++] public: ConfigException(String*);
[JScript] public function ConfigException(String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public ConfigException(String, Exception);
[C++] public: ConfigException(String*, Exception);
[JScript] public function ConfigException(String, Exception);

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public ConfigException();
[C++]
public: ConfigException();
[JScript]
public function ConfigException();

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace | ConfigException Constructor Overload List


ConfigException Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public ConfigException(
   string message
);
[C++]
public: ConfigException(
   String* message
);
[JScript]
public function ConfigException(
   message : String
);

Parameters

message
[To be supplied.]

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace | ConfigException Constructor Overload List


ConfigException Constructor (String, Exception)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public ConfigException(
   string message,
   Exception innerException
);
[C++]
public: ConfigException(
   String* message,
   Exception* innerException
);
[JScript]
public function ConfigException(
   message : String,
   innerException : Exception
);

Parameters

message
[To be supplied.]
innerException
[To be supplied.]

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace | ConfigException Constructor Overload List


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ConfigException Fields

The fields of the ConfigException class are listed below. For a complete list of ConfigException class members, see the ConfigException Members topic.

Public:

AllWiring | [To be supplied.]
AppDomainInvalidBaseDirectoryPrefix | [To be supplied.]
ColectionFrozen | [To be supplied.]
CollectionType | [To be supplied.]
ConfigQueryConfigTypeDifferent | [To be supplied.]
DBTYPENotSupported | [To be supplied.]
ErrorCode | [To be supplied.]
FileNotFound | [To be supplied.]
FileNotFoundMessage | [To be supplied.]
IndexOutOfBounds | [To be supplied.]
InterceptorCantServeRequest | [To be supplied.]
InterceptorError | [To be supplied.]
InterceptorNotFound | [To be supplied.]
InterceptorReturnedNull | [To be supplied.]
InvalidPropertyType | [To be supplied.]
InvalidQueryStringInvalidPropertyName | [To be supplied.]
InvalidQueryStringNoConfigType | [To be supplied.]
InvalidQueryStringNoEqual | [To be supplied.]
InvalidQueryStringNoValue | [To be supplied.]
InvalidQueryStringTwoSelectors | [To be supplied.]
InvalidSelector | [To be supplied.]
InvalidSelectorType | [To be supplied.]
InvalidType | [To be supplied.]
InvalidWiring | [To be supplied.]
ItemFrozen | [To be supplied.]
ItemType | [To be supplied.]
MetaNotPresent | [To be supplied.]
MoreThanOneItem | [To be supplied.]
MultipePrimaryKeys | [To be supplied.]
NoInterceptorKnew | [To be supplied.]
NotEnoughPrimaryKeys | [To be supplied.]
NotImplemented | [To be supplied.]
PropertyName | [To be supplied.]
SelectorNotSupported | [To be supplied.]
SelectorNotSupportedOnQuery | [To be supplied.]
WiringNotPresent | [To be supplied.]

Protected:

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

ConfigException Class | System.Configuration Namespace


ConfigException.AllWiring

[To be supplied.]

[Visual Basic]
Public Shared AllWiring As String
[C#]
public static string AllWiring;
[C++]
public: static String* AllWiring;
[JScript]
public static var AllWiring : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.AppDomainInvalidBaseDirectoryPrefix

[To be supplied.]

[Visual Basic]
Public Shared AppDomainInvalidBaseDirectoryPrefix As String
[C#]
public static string AppDomainInvalidBaseDirectoryPrefix;
[C++]
public: static String* AppDomainInvalidBaseDirectoryPrefix;
[JScript]
public static var AppDomainInvalidBaseDirectoryPrefix : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.ColectionFrozen

[To be supplied.]

[Visual Basic]
Public Shared ColectionFrozen As String
[C#]
public static string ColectionFrozen;
[C++]
public: static String* ColectionFrozen;
[JScript]
public static var ColectionFrozen : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.CollectionType

[To be supplied.]

[Visual Basic]
Public Shared CollectionType As String
[C#]
public static string CollectionType;
[C++]
public: static String* CollectionType;
[JScript]
public static var CollectionType : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.ConfigQueryConfigTypeDifferent

[To be supplied.]

[Visual Basic]
Public Shared ConfigQueryConfigTypeDifferent As String
[C#]
public static string ConfigQueryConfigTypeDifferent;
[C++]
public: static String* ConfigQueryConfigTypeDifferent;
[JScript]
public static var ConfigQueryConfigTypeDifferent : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.DBTYPENotSupported

[To be supplied.]

[Visual Basic]
Public Shared DBTYPENotSupported As String
[C#]
public static string DBTYPENotSupported;
[C++]
public: static String* DBTYPENotSupported;
[JScript]
public static var DBTYPENotSupported : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.ErrorCode

[To be supplied.]

[Visual Basic]
Public ErrorCode As Integer
[C#]
public int ErrorCode;
[C++]
public: int ErrorCode;
[JScript]
public var ErrorCode : int;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.FileNotFound

[To be supplied.]

[Visual Basic]
Public Shared FileNotFound As Integer
[C#]
public static int FileNotFound;
[C++]
public: static int FileNotFound;
[JScript]
public static var FileNotFound : int;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.FileNotFoundMessage

[To be supplied.]

[Visual Basic]
Public Shared FileNotFoundMessage As String
[C#]
public static string FileNotFoundMessage;
[C++]
public: static String* FileNotFoundMessage;
[JScript]
public static var FileNotFoundMessage : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.IndexOutOfBounds

[To be supplied.]

[Visual Basic]
Public Shared IndexOutOfBounds As String
[C#]
public static string IndexOutOfBounds;
[C++]
public: static String* IndexOutOfBounds;
[JScript]
public static var IndexOutOfBounds : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.InterceptorCantServeRequest

[To be supplied.]

[Visual Basic]
Public Shared InterceptorCantServeRequest As Integer
[C#]
public static int InterceptorCantServeRequest;
[C++]
public: static int InterceptorCantServeRequest;
[JScript]
public static var InterceptorCantServeRequest : int;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.InterceptorError

[To be supplied.]

[Visual Basic]
Public Shared InterceptorError As String
[C#]
public static string InterceptorError;
[C++]
public: static String* InterceptorError;
[JScript]
public static var InterceptorError : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.InterceptorNotFound

[To be supplied.]

[Visual Basic]
Public Shared InterceptorNotFound As String
[C#]
public static string InterceptorNotFound;
[C++]
public: static String* InterceptorNotFound;
[JScript]
public static var InterceptorNotFound : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.InterceptorReturnedNull

[To be supplied.]

[Visual Basic]
Public Shared InterceptorReturnedNull As String
[C#]
public static string InterceptorReturnedNull;
[C++]
public: static String* InterceptorReturnedNull;
[JScript]
public static var InterceptorReturnedNull : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.InvalidPropertyType

[To be supplied.]

[Visual Basic]
Public Shared InvalidPropertyType As String
[C#]
public static string InvalidPropertyType;
[C++]
public: static String* InvalidPropertyType;
[JScript]
public static var InvalidPropertyType : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.InvalidQueryStringInvalidPropertyName

[To be supplied.]

[Visual Basic]
Public Shared InvalidQueryStringInvalidPropertyName As String
[C#]
public static string InvalidQueryStringInvalidPropertyName;
[C++]
public: static String* InvalidQueryStringInvalidPropertyName;
[JScript]
public static var InvalidQueryStringInvalidPropertyName : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.InvalidQueryStringNoConfigType

[To be supplied.]

[Visual Basic]
Public Shared InvalidQueryStringNoConfigType As String
[C#]
public static string InvalidQueryStringNoConfigType;
[C++]
public: static String* InvalidQueryStringNoConfigType;
[JScript]
public static var InvalidQueryStringNoConfigType : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.InvalidQueryStringNoEqual

[To be supplied.]

[Visual Basic]
Public Shared InvalidQueryStringNoEqual As String
[C#]
public static string InvalidQueryStringNoEqual;
[C++]
public: static String* InvalidQueryStringNoEqual;
[JScript]
public static var InvalidQueryStringNoEqual : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.InvalidQueryStringNoValue

[To be supplied.]

[Visual Basic]
Public Shared InvalidQueryStringNoValue As String
[C#]
public static string InvalidQueryStringNoValue;
[C++]
public: static String* InvalidQueryStringNoValue;
[JScript]
public static var InvalidQueryStringNoValue : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.InvalidQueryStringTwoSelectors

[To be supplied.]

[Visual Basic]
Public Shared InvalidQueryStringTwoSelectors As String
[C#]
public static string InvalidQueryStringTwoSelectors;
[C++]
public: static String* InvalidQueryStringTwoSelectors;
[JScript]
public static var InvalidQueryStringTwoSelectors : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.InvalidSelector

[To be supplied.]

[Visual Basic]
Public Shared InvalidSelector As String
[C#]
public static string InvalidSelector;
[C++]
public: static String* InvalidSelector;
[JScript]
public static var InvalidSelector : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.InvalidSelectorType

[To be supplied.]

[Visual Basic]
Public Shared InvalidSelectorType As String
[C#]
public static string InvalidSelectorType;
[C++]
public: static String* InvalidSelectorType;
[JScript]
public static var InvalidSelectorType : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.InvalidType

[To be supplied.]

[Visual Basic]
Public Shared InvalidType As String
[C#]
public static string InvalidType;
[C++]
public: static String* InvalidType;
[JScript]
public static var InvalidType : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.InvalidWiring

[To be supplied.]

[Visual Basic]
Public Shared InvalidWiring As String
[C#]
public static string InvalidWiring;
[C++]
public: static String* InvalidWiring;
[JScript]
public static var InvalidWiring : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.ItemFrozen

[To be supplied.]

[Visual Basic]
Public Shared ItemFrozen As String
[C#]
public static string ItemFrozen;
[C++]
public: static String* ItemFrozen;
[JScript]
public static var ItemFrozen : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.ItemType

[To be supplied.]

[Visual Basic]
Public Shared ItemType As String
[C#]
public static string ItemType;
[C++]
public: static String* ItemType;
[JScript]
public static var ItemType : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.MetaNotPresent

[To be supplied.]

[Visual Basic]
Public Shared MetaNotPresent As String
[C#]
public static string MetaNotPresent;
[C++]
public: static String* MetaNotPresent;
[JScript]
public static var MetaNotPresent : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.MoreThanOneItem

[To be supplied.]

[Visual Basic]
Public Shared MoreThanOneItem As String
[C#]
public static string MoreThanOneItem;
[C++]
public: static String* MoreThanOneItem;
[JScript]
public static var MoreThanOneItem : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.MultipePrimaryKeys

[To be supplied.]

[Visual Basic]
Public Shared MultipePrimaryKeys As String
[C#]
public static string MultipePrimaryKeys;
[C++]
public: static String* MultipePrimaryKeys;
[JScript]
public static var MultipePrimaryKeys : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.NoInterceptorKnew

[To be supplied.]

[Visual Basic]
Public Shared NoInterceptorKnew As String
[C#]
public static string NoInterceptorKnew;
[C++]
public: static String* NoInterceptorKnew;
[JScript]
public static var NoInterceptorKnew : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.NotEnoughPrimaryKeys

[To be supplied.]

[Visual Basic]
Public Shared NotEnoughPrimaryKeys As String
[C#]
public static string NotEnoughPrimaryKeys;
[C++]
public: static String* NotEnoughPrimaryKeys;
[JScript]
public static var NotEnoughPrimaryKeys : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.NotImplemented

[To be supplied.]

[Visual Basic]
Public Shared NotImplemented As String
[C#]
public static string NotImplemented;
[C++]
public: static String* NotImplemented;
[JScript]
public static var NotImplemented : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.PropertyName

[To be supplied.]

[Visual Basic]
Public Shared PropertyName As String
[C#]
public static string PropertyName;
[C++]
public: static String* PropertyName;
[JScript]
public static var PropertyName : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.SelectorNotSupported

[To be supplied.]

[Visual Basic]
Public Shared SelectorNotSupported As String
[C#]
public static string SelectorNotSupported;
[C++]
public: static String* SelectorNotSupported;
[JScript]
public static var SelectorNotSupported : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.SelectorNotSupportedOnQuery

[To be supplied.]

[Visual Basic]
Public Shared SelectorNotSupportedOnQuery As String
[C#]
public static string SelectorNotSupportedOnQuery;
[C++]
public: static String* SelectorNotSupportedOnQuery;
[JScript]
public static var SelectorNotSupportedOnQuery : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigException.WiringNotPresent

[To be supplied.]

[Visual Basic]
Public Shared WiringNotPresent As String
[C#]
public static string WiringNotPresent;
[C++]
public: static String* WiringNotPresent;
[JScript]
public static var WiringNotPresent : String;

See Also

ConfigException Class | ConfigException Members | System.Configuration Namespace


ConfigManager Class

The Configuration System is designed to give system runtimes, administrative tools, applications and other consumers of configuration information easy and efficient access to configuration information, regardless of the details of the storage format and location of the configuration information.

Object
ConfigManager

[Visual Basic]
Public Class ConfigManager
[C#]
public class ConfigManager
[C++]
public __gc class ConfigManager
[JScript]
public class ConfigManager

Remarks

Reading Configuration Information: Refer to the documentation on the Get methods for details and examples.

Writing Configuration Information: Refer to the documentation on the Put methods for details and examples.

Defining your own schema:

By simply defining schema information for their application's configuration information, application developers obtain a large number of benefits:

  • Common, human readable XML format for configuration information.
  • Common APIs to read and write configuration information at runtime.
  • Discoverability of configuration information to administrative tools.
  • Automatic exposure through Microsoft's WMI infrastructure.
  • Command-line scriptability from WSH (through WMI).
  • Programmatic remote administration (through WMI).

In the PDC release, some of the core system components already use the configuration system to retrieve their configuration information at runtime (assembly binding resolution, AppDomain configuration). Other system components define their configuration information in such a way that it can be accessed through the configuration system (most ASP+ configuration), while others are currently only configurable by direct file manipulation or through specific APIs (code access securitypolicy).

The details on the configuration information of system components can be found in the respective documentation.

Application developers can store their application's configuration information using the same Configuration System and can access their configuration information through the ConfigManager. In order to access your own configuration information through the ConfigManager, you need to define schema for your configuration information.

The ConfigManager introduces several key concepts:

  • Configuration Property: a named value of type int, Boolean, String or Byte[].
  • ConfigType: a string that identifies a group of related Configuration Properties.
  • Configuration Item: an instance of a ConfigType. The IConfigItem interface represents this concept.
  • Configuration Collection: a set of Configuration Items that have the same ConfigType. The IConfigCollection interface represents this concept.
  • Selector: a class that indicates the storage location of configuration information. The Selector class represents this concept.

Configuration Files

While the configuration system is designed to be storage independent, and any applications or administrative tools written against configuration system APIs can be easily moved to a different backing store in the future, it is highly recommended to store configuration information in XML text files.

Using XML text files has the following advantages:

  • Low barrier of entry to configuration: any text-based tool can be used. Any file protocol (Windows's SMB/CIFS, FTP etc.) can be used for basic administration.
  • XCOPY deployment: no registration is needed on application install, no cleanup is needed on application uninstall.
  • XML editors can provide relatively rich consistency checking.

Most system configuration is stored in user-editable XML text files.

Configuration File Format

The XML format for configuration files is optimized for human readability: Configurable properties are expressed as XML attributes and related properties are grouped under XML elements, to render a compact, yet legible representation.Configurable properties should have a well-defined XML schema that can be used by XML editors and other XML-aware applications to perform validation or provide syntactic hints to the user. The XML schema also makes all configurable properties discoverable to generic consumers, like some administrative tools and development tools.

Example 1: Singleton item- AppDomain configuration

An example of a singleton configuration entry is the AppDomain configuration: AppDomain settings can be specified at most once in each application configuration file:

<?xml version ="1.0"?>
<configuration xmlns="x-schema:catalog.xms">

  <AppDomain
      PrivatePath=".\bin;.\blaa"
      SharedPath="c:\common\bin;c:\suite\utils"
      ShadowCopy="True"/>

</configuration>

The first line ("<?xml ...>") declares that this file is an XML document. It is optional, but should be specified to leverage XML editingtools.

The second line ("<configuration ...>") defines the root element of the XML document and declares the XML schema to be used to validate the content of the root element. The "xmlns" attribute on the root <configuration> element is optional, but in order to fully leverage XML editing tools (ie. Visual Studio's XML editor with autocomplete etc.) it is highly recommended to include the "xmlns" attribute. The root element in NGWS RUNTIME configuration files must have the name "configuration". XML is casesensitive.

The subsequent lines (<AppDomain.../>) carry actual configuration information, in this example the settings for the Application Domain. Individual configuration properties are expressed as XML attributes ("ShadowCopy" and "PrivatePath"). An XML element ("AppDomain>") groups these properties into logicalunits.

The last line ("/configuration>") closes the root element and thus the XMLdocument.

Example 2: Collection of items- Assembly Binding Policy

<?xml version ="1.0"?>
<configuration xmlns="x-schema:catalog.xms">

    <BindingPolicy>
        <BindingRedir Name="MyDll" Originator="xxxx" Version="1.0.0.0" VersionNew="3.0.0.0"/>
    </BindingPolicy>

</configuration>

The Assembly Binding Policy- used here again merely as an example of configuration information- is typically specified in an application configuration file. There can be one for every assembly that is to be loaded into an application. A binding redirection has several properties ("Name", "Version" etc.). In the configuration file, each binding redirection is represented by an XML element ("BindingRedir"), while each of its properties is an attribute of this element. All binding redirection elements are grouped together by a containing element ("<BindingPolicy>"), to ensure that all binding policy is stored in a single location in the file.

Note Refer to the Runtime Configuration documentation for more information on code base hints.

Example 3: Nested Collections- Window/Toolbarpositions

Often, configuration information is more complex and requires one or more sub-items for each configurationentry.

Take the example of a (fictitious) Windows application that needs to store information for each of its windows: the window position, the background color and the applicable toolbars and theirposition:

<?xml version ="1.0"?>
<configuration xmlns="x-schema:catalog.xms">

  <Windows>

    <Window Name="MainWindow" PosX="0" PosY="0" Width="100" Height="100" Color="Green" >
        <Toolbar Name="Formatting" PosX="0" PosY="0" />
        <Toolbar Name="Standard" PosX="0" PosY="40" />
    </Window>

    <Window Name="StockTicker" PosX="0" PosY="101" Width="100" Height="20" Color="Red">
        <Toolbar Name="BuySell" PosX="0" PosY="0" />
    </Window>

  </Windows>

</configuration>

This example represents the definition of two "Windows" (a collection of "Window" items). Each Window in turn has one or more "Toolbar" items. The simple properties of a "Window" are expressed as XML attributes ("Name", "PosX" etc.). The "Toolbars" that the used chose for each Window are expressed as "Toolbar" sub-elements of the "Window" element, which in turn have attributes. The last line ("/configuration>") closes the root element and thus the XML document.

Example 4: Directives

In some cases, configuration information needs to be accumulated across a hierarchy of configuration files. Directives can be used to control the accumulation (or merge) process across the hierarchy:

<?xml version ="1.0"?>
<configuration xmlns="x-schema:catalog.xms">
  <assemblies>
    <add assembly="System.Data"/>
    <add assembly="System.Web.Services"/>
    <remove assembly="System.Xml.Serialization"/>
    <add assembly="System"/>
    <add assembly="System.Text.RegularExpressions"/>
    <add assembly="System.Drawing"/>
    <add assembly="*"/>
   </assemblies>
</configuration>

In this example (from an ASP+ configuration file), the element name of each of the items in the <assemblies> list controls if the item is to be added to or removed from the list during merge of configuration files. Each item can carry one or more additional attributes, just like any configuration item. The only difference to regular configuration is that the element name is replaced with the directive.

For more information on configuration file hierarchies refer to the documentation of Interceptors.IConfigTransformer.

Tip Configuration information is automatically exposed through Microsoft's WMI infrastructure:
  • WMI namespace: "root/ComPlus20"
  • The "FilePath" WMI property on classes in this namespace indicates the configuration file to read from.

Requirements

Namespace: System.Configuration

Assembly: System.Configuration.dll

See Also

ConfigManager Members | System.Configuration Namespace | Interceptors.IConfigTransformer


ConfigManager Members

Public:

Constructor

ConfigManager Constructor [To be supplied.]

Methods

Delete Overloaded. The Delete, DeleteItem and DeleteProperty methods allow configuration information to be deleted from a configuration store.

The Delete methods allow deletion of more than one configuration item at a time. They can be used to delete any configuration information, including singleton ConfigTypes, as long as configuration schema has been defined.

Other methods exist to delete a single configuration item (DeleteItem) or individual configuration properties (DeleteProperty).
DeleteItem The Delete, DeleteItem and DeleteProperty methods allow configuration information to be deleted from a configuration store.

The DeleteItem method allows deletion of one configuration item at a time. It can be used to delete any configuration information, including singleton ConfigTypes, as long as configuration schema has been defined.

Other methods exist to delete a single configuration item (DeleteItem) or individual configuration properties (DeleteProperty).
DeleteProperty Overloaded. Resets a configuration property to its default value.

It does not remove the configuration property from the configuration schema for a config type.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get Overloaded. System runtimes, modules that extend the system runtimes, applications, as well as administrative tools, can retrieve configuration information through the GetItem and GetProperty methods.

The Get methods return configuration information as collections of configuration items (IConfigCollection). They can be used to retrieve any configuration information, including singleton ConfigTypes, as long as configuration schema has been defined.

Other methods exist to retrieve singleton configuration items (GetItem) or individual configuration properties (GetProperty).

Example 1: Singleton property- AppDomain ShadowCopy

In this example, the configuration information consists of a single named value, which occurs exactly once in a configuration scope (file).

The NGWS runtime system setting for application domains (as used by the EXE host) consists of such singleton properties: there can be only one "ShadowCopy" flag for each application.

[C#]

using System.Configuration;

 // Reading a single value: Boolean ShadowCopy = (Boolean)
 Boolean ShadowCopy = (Boolean) ConfigManager.GetProperty("AppDomain", "c:\myapp\foo.cfg", "ShadowCopy");

Example 2: Singleton Item- AppDomain

The AppDomain configuration consists of more than one property, but still each of the properties can appear at most once in a configuration scope (file).

The configuration system makes it easy to retrieve all properties in a ConfigType at once:

[C#]

using System.Configuration;
 using System.Configuration.Core;

 AppDomain appdomain = ConfigManager.GetItem("AppDomain", "c:\myapp\foo.cfg");

 if (appdomain.ShadowCopy) { ... }
 String path = appdomain.SharedPath;

Example 3: Collection of items- Binding Policy

In this example, the configuration information is slightly more complex: every property in a ConfigType can actually occur more than once within a given configuration scope (file).

The NGWS runtime system setting for binding policy ("<BindingPolicy>"), is a good example of such a configuration setting: every assembly that could potentially be loaded into an application can have it's own binding redirection entry.

[C#]

using System.Configuration;
 using System.Configuration.Core;

 IConfigCollection bindings = ConfigManager.Get("BindingPolicy", "c:\myapp\foo.cfg");
 foreach (BindingPolicy bindingredir in bindings) {
   Console.WriteLine(bindingredir.Name+": "+bindingredir.Version);
 }

Example 4: Generic configuration reader

In some cases (administrative tools, generic applications), it is necessary to process arbitrary configuration information without prior knowledge. The configuration system provides schema (property names, types etc.) discovery mechanisms for sophisticated tools, but also lets simple tools read configuration information in a generic way, by letting a caller enumerate the available properties in a configuration item.

The example code below outputs an arbitrary set of configuration information, by only modifying the ConfigType and Selector passed to the ConfigManager.Get method:

[C#]

// Late bound, generic
 IConfigCollection collection = ConfigManager.Get( "BindingPolicy", "c:\myapp\foo.cfg");
 foreach (IConfigItem item in collection) {
   Console.WriteLine("");
   foreach (Object property in item) {
     Console.WriteLine( property );
   }
 }
GetEmptyConfigCollection | Returns an empty configuration collection. It is used primarily for update, creation of deletion of configuration items.
GetEmptyConfigItem | Returns an empty configuration item. It is used primarily for update, creation of deletion of configuration items.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetItem Overloaded. The Get, GetItem and GetProperty methods provide read access to configuration information.

The GetItem methods return configuration information as single configuration items (IConfigItem). They can only be used to retrieve singleton ConfigTypes. If more than one instance of this ConfigType exists (within the scope indicated by the Selector), the GetItem methods throw an exception.

Other methods exist to retrieve collections of configuration items (Get) or individual configuration properties (GetProperty).
GetProperty Overloaded. The Get, GetItem and GetProperty methods provide read access to configuration information.

The GetProperty methods return a single property value. They can only be used to retrieve properties for singleton ConfigTypes. If more than one instance of this ConfigType exists (within the scope indicated by the Selector), the GetItem methods throw an exception.

Other methods exist to retrieve an entire singleton configuration items (GetItem) or collections of configuration items (Get).
GetSelectorFromString | Parses a selector string and creates the appropriate selector object for the string.
GetType (inherited from Object) | Gets the Type of the Object.
Put Overloaded. The Put, PutItem and PutProperty methods provide write access to configuration information.

The Put methods allow writes to more than one configuration item at a time. They can be used to write any configuration information, including singleton ConfigTypes, as long as configuration schema has been defined.

Other methods exist to write singleton configuration items (PutItem) or individual configuration properties (PutProperty).
PutItem | Overloaded. [To be supplied.]
PutProperty | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConfigManager Class | System.Configuration Namespace


ConfigManager Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ConfigManager();
[C++]
public: ConfigManager();
[JScript]
public function ConfigManager();

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ConfigManager Methods

The methods of the ConfigManager class are listed below. For a complete list of ConfigManager class members, see the ConfigManager Members topic.

Public:

Delete Overloaded. The Delete, DeleteItem and DeleteProperty methods allow configuration information to be deleted from a configuration store.

The Delete methods allow deletion of more than one configuration item at a time. They can be used to delete any configuration information, including singleton ConfigTypes, as long as configuration schema has been defined.

Other methods exist to delete a single configuration item (DeleteItem) or individual configuration properties (DeleteProperty).
DeleteItem The Delete, DeleteItem and DeleteProperty methods allow configuration information to be deleted from a configuration store.

The DeleteItem method allows deletion of one configuration item at a time. It can be used to delete any configuration information, including singleton ConfigTypes, as long as configuration schema has been defined.

Other methods exist to delete a single configuration item (DeleteItem) or individual configuration properties (DeleteProperty).
DeleteProperty Overloaded. Resets a configuration property to its default value.

It does not remove the configuration property from the configuration schema for a config type.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get Overloaded. System runtimes, modules that extend the system runtimes, applications, as well as administrative tools, can retrieve configuration information through the GetItem and GetProperty methods.

The Get methods return configuration information as collections of configuration items (IConfigCollection). They can be used to retrieve any configuration information, including singleton ConfigTypes, as long as configuration schema has been defined.

Other methods exist to retrieve singleton configuration items (GetItem) or individual configuration properties (GetProperty).

Example 1: Singleton property- AppDomain ShadowCopy

In this example, the configuration information consists of a single named value, which occurs exactly once in a configuration scope (file).

The NGWS runtime system setting for application domains (as used by the EXE host) consists of such singleton properties: there can be only one "ShadowCopy" flag for each application.

[C#]

using System.Configuration;

 // Reading a single value: Boolean ShadowCopy = (Boolean)
 Boolean ShadowCopy = (Boolean) ConfigManager.GetProperty("AppDomain", "c:\myapp\foo.cfg", "ShadowCopy");

Example 2: Singleton Item- AppDomain

The AppDomain configuration consists of more than one property, but still each of the properties can appear at most once in a configuration scope (file).

The configuration system makes it easy to retrieve all properties in a ConfigType at once:

[C#]

using System.Configuration;
 using System.Configuration.Core;

 AppDomain appdomain = ConfigManager.GetItem("AppDomain", "c:\myapp\foo.cfg");

 if (appdomain.ShadowCopy) { ... }
 String path = appdomain.SharedPath;

Example 3: Collection of items- Binding Policy

In this example, the configuration information is slightly more complex: every property in a ConfigType can actually occur more than once within a given configuration scope (file).

The NGWS runtime system setting for binding policy ("<BindingPolicy>"), is a good example of such a configuration setting: every assembly that could potentially be loaded into an application can have it's own binding redirection entry.

[C#]

using System.Configuration;
 using System.Configuration.Core;

 IConfigCollection bindings = ConfigManager.Get("BindingPolicy", "c:\myapp\foo.cfg");
 foreach (BindingPolicy bindingredir in bindings) {
   Console.WriteLine(bindingredir.Name+": "+bindingredir.Version);
 }

Example 4: Generic configuration reader

In some cases (administrative tools, generic applications), it is necessary to process arbitrary configuration information without prior knowledge. The configuration system provides schema (property names, types etc.) discovery mechanisms for sophisticated tools, but also lets simple tools read configuration information in a generic way, by letting a caller enumerate the available properties in a configuration item.

The example code below outputs an arbitrary set of configuration information, by only modifying the ConfigType and Selector passed to the ConfigManager.Get method:

[C#]

// Late bound, generic
 IConfigCollection collection = ConfigManager.Get( "BindingPolicy", "c:\myapp\foo.cfg");
 foreach (IConfigItem item in collection) {
   Console.WriteLine("");
   foreach (Object property in item) {
     Console.WriteLine( property );
   }
 }
GetEmptyConfigCollection | Returns an empty configuration collection. It is used primarily for update, creation of deletion of configuration items.
GetEmptyConfigItem | Returns an empty configuration item. It is used primarily for update, creation of deletion of configuration items.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetItem Overloaded. The Get, GetItem and GetProperty methods provide read access to configuration information.

The GetItem methods return configuration information as single configuration items (IConfigItem). They can only be used to retrieve singleton ConfigTypes. If more than one instance of this ConfigType exists (within the scope indicated by the Selector), the GetItem methods throw an exception.

Other methods exist to retrieve collections of configuration items (Get) or individual configuration properties (GetProperty).
GetProperty Overloaded. The Get, GetItem and GetProperty methods provide read access to configuration information.

The GetProperty methods return a single property value. They can only be used to retrieve properties for singleton ConfigTypes. If more than one instance of this ConfigType exists (within the scope indicated by the Selector), the GetItem methods throw an exception.

Other methods exist to retrieve an entire singleton configuration items (GetItem) or collections of configuration items (Get).
GetSelectorFromString | Parses a selector string and creates the appropriate selector object for the string.
GetType (inherited from Object) | Gets the Type of the Object.
Put Overloaded. The Put, PutItem and PutProperty methods provide write access to configuration information.

The Put methods allow writes to more than one configuration item at a time. They can be used to write any configuration information, including singleton ConfigTypes, as long as configuration schema has been defined.

Other methods exist to write singleton configuration items (PutItem) or individual configuration properties (PutProperty).
PutItem | Overloaded. [To be supplied.]
PutProperty | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConfigManager Class | System.Configuration Namespace


ConfigManager.Delete

The Delete, DeleteItem and DeleteProperty methods allow configuration information to be deleted from a configuration store.

The Delete methods allow deletion of more than one configuration item at a time. They can be used to delete any configuration information, including singleton ConfigTypes, as long as configuration schema has been defined.

Other methods exist to delete a single configuration item (DeleteItem) or individual configuration properties (DeleteProperty).

Overload List

Deletes all configuration for a configuration type within a configuration store.

[Visual Basic] Overloads Public Shared Sub Delete(String, String)
[C#] public static void Delete(String, String);
[C++] public: static void Delete(String*, String*);
[JScript] public static function Delete(String, String);

Deletes all configuration for a configuration type within a configuration store.

[Visual Basic] Overloads Public Shared Sub Delete(String, Selector)
[C#] public static void Delete(String, Selector);
[C++] public: static void Delete(String*, Selector);
[JScript] public static function Delete(String, Selector);

[To be supplied.]

[Visual Basic] Overloads Public Shared Sub Delete(IConfigCollection)
[C#] public static void Delete(IConfigCollection);
[C++] public: static void Delete(IConfigCollection*);
[JScript] public static function Delete(IConfigCollection);

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace


ConfigManager.Delete (String, String)

Deletes all configuration for a configuration type within a configuration store.

[Visual Basic]
Overloads Public Shared Sub Delete( _
   ByVal ConfigType As String, _
   ByVal selector As String _
)
[C#]
public static void Delete(
   string ConfigType,
   string selector
);
[C++]
public: static void Delete(
   String* ConfigType,
   String* selector
);
[JScript]
public static function Delete(
   ConfigType : String,
   selector : String
);

Parameters

ConfigType
[To be supplied.]
selector
[To be supplied.]

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace | ConfigManager.Delete Overload List


ConfigManager.Delete (String, Selector)

Deletes all configuration for a configuration type within a configuration store.

[Visual Basic]
Overloads Public Shared Sub Delete( _
   ByVal ConfigType As String, _
   ByVal selector As Selector _
)
[C#]
public static void Delete(
   string ConfigType,
   Selector selector
);
[C++]
public: static void Delete(
   String* ConfigType,
   Selector* selector
);
[JScript]
public static function Delete(
   ConfigType : String,
   selector : Selector
);

Parameters

ConfigType
[To be supplied.]
selector
[To be supplied.]

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace | ConfigManager.Delete Overload List


ConfigManager.Delete (IConfigCollection)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Sub Delete( _
   ByVal cc As IConfigCollection _
)
[C#]
public static void Delete(
   IConfigCollection cc
);
[C++]
public: static void Delete(
   IConfigCollection* cc
);
[JScript]
public static function Delete(
   cc : IConfigCollection
);

Parameters

cc
[To be supplied.]

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace | ConfigManager.Delete Overload List


ConfigManager.DeleteItem

The Delete, DeleteItem and DeleteProperty methods allow configuration information to be deleted from a configuration store.

The DeleteItem method allows deletion of one configuration item at a time. It can be used to delete any configuration information, including singleton ConfigTypes, as long as configuration schema has been defined.

Other methods exist to delete a single configuration item (DeleteItem) or individual configuration properties (DeleteProperty).

[Visual Basic]
Public Shared Sub DeleteItem( _
   ByVal ci As IConfigItem _
)
[C#]
public static void DeleteItem(
   IConfigItem ci
);
[C++]
public: static void DeleteItem(
   IConfigItem* ci
);
[JScript]
public static function DeleteItem(
   ci : IConfigItem
);

Parameters

ci
[To be supplied.]

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace


ConfigManager.DeleteProperty

Resets a configuration property to its default value.

It does not remove the configuration property from the configuration schema for a config type.

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Shared Sub DeleteProperty(String, Selector, String)
[C#] public static void DeleteProperty(String, Selector, String);
[C++] public: static void DeleteProperty(String*, Selector, String*);
[JScript] public static function DeleteProperty(String, Selector, String);

[To be supplied.]

[Visual Basic] Overloads Public Shared Sub DeleteProperty(String, String, String)
[C#] public static void DeleteProperty(String, String, String);
[C++] public: static void DeleteProperty(String*, String*, String*);
[JScript] public static function DeleteProperty(String, String, String);

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace


ConfigManager.DeleteProperty (String, Selector, String)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Sub DeleteProperty( _
   ByVal configType As String, _
   ByVal selector As Selector, _
   ByVal PropertyName As String _
)
[C#]
public static void DeleteProperty(
   string configType,
   Selector selector,
   string PropertyName
);
[C++]
public: static void DeleteProperty(
   String* configType,
   Selector* selector,
   String* PropertyName
);
[JScript]
public static function DeleteProperty(
   configType : String,
   selector : Selector,
   PropertyName : String
);

Parameters

configType
[To be supplied.]
selector
[To be supplied.]
PropertyName
[To be supplied.]

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace | ConfigManager.DeleteProperty Overload List


ConfigManager.DeleteProperty (String, String, String)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Sub DeleteProperty( _
   ByVal configType As String, _
   ByVal selector As String, _
   ByVal PropertyName As String _
)
[C#]
public static void DeleteProperty(
   string configType,
   string selector,
   string PropertyName
);
[C++]
public: static void DeleteProperty(
   String* configType,
   String* selector,
   String* PropertyName
);
[JScript]
public static function DeleteProperty(
   configType : String,
   selector : String,
   PropertyName : String
);

Parameters

configType
[To be supplied.]
selector
[To be supplied.]
PropertyName
[To be supplied.]

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace | ConfigManager.DeleteProperty Overload List


ConfigManager.Get

System runtimes, modules that extend the system runtimes, applications, as well as administrative tools, can retrieve configuration information through the GetItem and GetProperty methods.

The Get methods return configuration information as collections of configuration items (IConfigCollection). They can be used to retrieve any configuration information, including singleton ConfigTypes, as long as configuration schema has been defined.

Other methods exist to retrieve singleton configuration items (GetItem) or individual configuration properties (GetProperty).

Example 1: Singleton property- AppDomain ShadowCopy

In this example, the configuration information consists of a single named value, which occurs exactly once in a configuration scope (file).

The NGWS runtime system setting for application domains (as used by the EXE host) consists of such singleton properties: there can be only one "ShadowCopy" flag for each application.

[C#]

using System.Configuration;

 // Reading a single value: Boolean ShadowCopy = (Boolean)
 Boolean ShadowCopy = (Boolean) ConfigManager.GetProperty("AppDomain", "c:\myapp\foo.cfg", "ShadowCopy");

Example 2: Singleton Item- AppDomain

The AppDomain configuration consists of more than one property, but still each of the properties can appear at most once in a configuration scope (file).

The configuration system makes it easy to retrieve all properties in a ConfigType at once:

[C#]

using System.Configuration;
 using System.Configuration.Core;

 AppDomain appdomain = ConfigManager.GetItem("AppDomain", "c:\myapp\foo.cfg");

 if (appdomain.ShadowCopy) { ... }
 String path = appdomain.SharedPath;

Example 3: Collection of items- Binding Policy

In this example, the configuration information is slightly more complex: every property in a ConfigType can actually occur more than once within a given configuration scope (file).

The NGWS runtime 2.0 system setting for binding policy ("<BindingPolicy>"), is a good example of such a configuration setting: every assembly that could potentially be loaded into an application can have it's own binding redirection entry.

[C#]

using System.Configuration;
 using System.Configuration.Core;

 IConfigCollection bindings = ConfigManager.Get("BindingPolicy", "c:\myapp\foo.cfg");
 foreach (BindingPolicy bindingredir in bindings) {
   Console.WriteLine(bindingredir.Name+": "+bindingredir.Version);
 }

Example 4: Generic configuration reader

In some cases (administrative tools, generic applications), it is necessary to process arbitrary configuration information without prior knowledge. The configuration system provides schema (property names, types etc.) discovery mechanisms for sophisticated tools, but also lets simple tools read configuration information in a generic way, by letting a caller enumerate the available properties in a configuration item.

The example code below outputs an arbitrary set of configuration information, by only modifying the ConfigType and Selector passed to the ConfigManager.Get method:

[C#]

// Late bound, generic
 IConfigCollection collection = ConfigManager.Get( "BindingPolicy", "c:\myapp\foo.cfg");
 foreach (IConfigItem item in collection) {
   Console.WriteLine("");
   foreach (Object property in item) {
     Console.WriteLine( property );
   }
 }

Overload List

This overload of the Get method accepts a selector in string form. It attempts to create a Selector from this string. It also accepts a set of flags indicating the desired level of service.

[Visual Basic] Overloads Public Shared Function Get(String, String, Integer) As IConfigCollection
[C#] public static IConfigCollection Get(String, String, int);
[C++] public: static IConfigCollection* Get(String*, String*, int);
[JScript] public static function Get(String, String, int) : IConfigCollection;

This overload of the Get method accepts a selector in string form. It attempts to create a Selector from this string.

[Visual Basic] Overloads Public Shared Function Get(String, String) As IConfigCollection
[C#] public static IConfigCollection Get(String, String);
[C++] public: static IConfigCollection* Get(String*, String*);
[JScript] public static function Get(String, String) : IConfigCollection;

This overload of the Get method accepts a selector in the form of an object and also accepts a set of flags indicating the desired level of service.

[Visual Basic] Overloads Public Shared Function Get(String, Selector, Integer) As IConfigCollection
[C#] public static IConfigCollection Get(String, Selector, int);
[C++] public: static IConfigCollection* Get(String*, Selector, int);
[JScript] public static function Get(String, Selector, int) : IConfigCollection;

This overload of the Get method accepts a selector in the form of an object.

[Visual Basic] Overloads Public Shared Function Get(String, Selector) As IConfigCollection
[C#] public static IConfigCollection Get(String, Selector);
[C++] public: static IConfigCollection* Get(String*, Selector);
[JScript] public static function Get(String, Selector) : IConfigCollection;

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace


ConfigManager.Get (String, String, Int32)

This overload of the Get method accepts a selector in string form. It attempts to create a Selector from this string. It also accepts a set of flags indicating the desired level of service.

[Visual Basic]
Overloads Public Shared Function Get( _
   ByVal configType As String, _
   ByVal selector As String, _
   ByVal los As Integer _
) As IConfigCollection
[C#]
public static IConfigCollection Get(
   string configType,
   string selector,
   int los
);
[C++]
public: static IConfigCollection* Get(
   String* configType,
   String* selector,
   int los
);
[JScript]
public static function Get(
   configType : String,
   selector : String,
   los : int
) : IConfigCollection;

Parameters

configType
A String indicating the type of configuration information to be retrieved.
selector
A String indicating the storage location of the configuration information to be retrieved. Refer to Selector for more details.
los
An integer indicating one or more LevelOfService flags.

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace | ConfigManager.Get Overload List


ConfigManager.Get (String, String)

This overload of the Get method accepts a selector in string form. It attempts to create a Selector from this string.

[Visual Basic]
Overloads Public Shared Function Get( _
   ByVal configType As String, _
   ByVal selector As String _
) As IConfigCollection
[C#]
public static IConfigCollection Get(
   string configType,
   string selector
);
[C++]
public: static IConfigCollection* Get(
   String* configType,
   String* selector
);
[JScript]
public static function Get(
   configType : String,
   selector : String
) : IConfigCollection;

Parameters

configType
A String indicating the type of configuration information to be retrieved.
selector
A String indicating the storage location of the configuration information to be retrieved. Refer to Selector for more details.

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace | ConfigManager.Get Overload List


ConfigManager.Get (String, Selector, Int32)

This overload of the Get method accepts a selector in the form of an object and also accepts a set of flags indicating the desired level of service.

[Visual Basic]
Overloads Public Shared Function Get( _
   ByVal configType As String, _
   ByVal selector As Selector, _
   ByVal los As Integer _
) As IConfigCollection
[C#]
public static IConfigCollection Get(
   string configType,
   Selector selector,
   int los
);
[C++]
public: static IConfigCollection* Get(
   String* configType,
   Selector* selector,
   int los
);
[JScript]
public static function Get(
   configType : String,
   selector : Selector,
   los : int
) : IConfigCollection;

Parameters

configType
A String indicating the type of configuration information to be retrieved.
selector
An object deriving from Selector, that indicates the storage location of the configuration information to be retrieved.
los
An integer indicating one or more LevelOfService flags.

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace | ConfigManager.Get Overload List


ConfigManager.Get (String, Selector)

This overload of the Get method accepts a selector in the form of an object.

[Visual Basic]
Overloads Public Shared Function Get( _
   ByVal configType As String, _
   ByVal selector As Selector _
) As IConfigCollection
[C#]
public static IConfigCollection Get(
   string configType,
   Selector selector
);
[C++]
public: static IConfigCollection* Get(
   String* configType,
   Selector* selector
);
[JScript]
public static function Get(
   configType : String,
   selector : Selector
) : IConfigCollection;

Parameters

configType
A String indicating the type of configuration information to be retrieved.
selector
An object deriving from Selector, that indicates the storage location of the configuration information to be retrieved.

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace | ConfigManager.Get Overload List | IConfigCollection | Selector


ConfigManager.GetEmptyConfigCollection

Returns an empty configuration collection. It is used primarily for update, creation of deletion of configuration items.

[Visual Basic]
Public Shared Function GetEmptyConfigCollection( _
   ByVal ConfigType As String _
) As IConfigCollection
[C#]
public static IConfigCollection GetEmptyConfigCollection(
   string ConfigType
);
[C++]
public: static IConfigCollection* GetEmptyConfigCollection(
   String* ConfigType
);
[JScript]
public static function GetEmptyConfigCollection(
   ConfigType : String
) : IConfigCollection;

Parameters

ConfigType
[To be supplied.]

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace


ConfigManager.GetEmptyConfigItem

Returns an empty configuration item. It is used primarily for update, creation of deletion of configuration items.

[Visual Basic]
Public Shared Function GetEmptyConfigItem( _
   ByVal ConfigType As String _
) As IConfigItem
[C#]
public static IConfigItem GetEmptyConfigItem(
   string ConfigType
);
[C++]
public: static IConfigItem* GetEmptyConfigItem(
   String* ConfigType
);
[JScript]
public static function GetEmptyConfigItem(
   ConfigType : String
) : IConfigItem;

Parameters

ConfigType
[To be supplied.]

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace


ConfigManager.GetItem

The Get, GetItem and GetProperty methods provide read access to configuration information.

The GetItem methods return configuration information as single configuration items (IConfigItem). They can only be used to retrieve singleton ConfigTypes. If more than one instance of this ConfigType exists (within the scope indicated by the Selector), the GetItem methods throw an exception.

Other methods exist to retrieve collections of configuration items (Get) or individual configuration properties (GetProperty).

Overload List

This overload of the GetItem method accepts a selector in the form of an object.

[Visual Basic] Overloads Public Shared Function GetItem(String, Selector) As IConfigItem
[C#] public static IConfigItem GetItem(String, Selector);
[C++] public: static IConfigItem* GetItem(String*, Selector);
[JScript] public static function GetItem(String, Selector) : IConfigItem;

This overload of the GetItem method accepts a selector in string form. It attempts to create a Selector from this string.

[Visual Basic] Overloads Public Shared Function GetItem(String, String) As IConfigItem
[C#] public static IConfigItem GetItem(String, String);
[C++] public: static IConfigItem* GetItem(String*, String*);
[JScript] public static function GetItem(String, String) : IConfigItem;

This overload of the GetItem method accepts a selector in the form of an object and also accepts a set of flags indicating the desired level of service.

[Visual Basic] Overloads Public Shared Function GetItem(String, Selector, Integer) As IConfigItem
[C#] public static IConfigItem GetItem(String, Selector, int);
[C++] public: static IConfigItem* GetItem(String*, Selector, int);
[JScript] public static function GetItem(String, Selector, int) : IConfigItem;

This overload of the GetItem method accepts a selector in string form. It attempts to create a Selector from this string. It also accepts a set of flags indicating the desired level of service.

[Visual Basic] Overloads Public Shared Function GetItem(String, String, Integer) As IConfigItem
[C#] public static IConfigItem GetItem(String, String, int);
[C++] public: static IConfigItem* GetItem(String*, String*, int);
[JScript] public static function GetItem(String, String, int) : IConfigItem;

Example [C#]

Note This example shows how to use one of the overloaded versions of GetItem. For other examples that may be available, see the individual overload topics.

[C#]

using System.Configuration.Core;
 using System;

 AppDomainConfigItem adc = (AppDomainConfigItem) ConfigManager.GetItem("AppDomain", "file://c:\\Program Files\\MyApplication\\config.cfg");

 Console.WriteLine(adc.GlobalPath);
 Console.WriteLine(adc.PrivatePath);
 Console.WriteLine(adc.ShadowCopy);

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace


ConfigManager.GetItem (String, Selector)

This overload of the GetItem method accepts a selector in the form of an object.

[Visual Basic]
Overloads Public Shared Function GetItem( _
   ByVal configType As String, _
   ByVal selector As Selector _
) As IConfigItem
[C#]
public static IConfigItem GetItem(
   string configType,
   Selector selector
);
[C++]
public: static IConfigItem* GetItem(
   String* configType,
   Selector* selector
);
[JScript]
public static function GetItem(
   configType : String,
   selector : Selector
) : IConfigItem;

Parameters

configType
A String indicating the type of configuration information to be retrieved.
selector
An object deriving from Selector, that indicates the storage location of the configuration information to be retrieved.

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace | ConfigManager.GetItem Overload List


ConfigManager.GetItem (String, String)

This overload of the GetItem method accepts a selector in string form. It attempts to create a Selector from this string.

[Visual Basic]
Overloads Public Shared Function GetItem( _
   ByVal configType As String, _
   ByVal selector As String _
) As IConfigItem
[C#]
public static IConfigItem GetItem(
   string configType,
   string selector
);
[C++]
public: static IConfigItem* GetItem(
   String* configType,
   String* selector
);
[JScript]
public static function GetItem(
   configType : String,
   selector : String
) : IConfigItem;

Parameters

configType
A String indicating the type of configuration information to be retrieved.
selector
A String indicating the storage location of the configuration information to be retrieved. Refer to Selector for more details.

Example [C#]

[C#]

using System.Configuration.Core;
 using System;

 AppDomainConfigItem adc = (AppDomainConfigItem) ConfigManager.GetItem("AppDomain", "file://c:\\Program Files\\MyApplication\\config.cfg");

 Console.WriteLine(adc.GlobalPath);
 Console.WriteLine(adc.PrivatePath);
 Console.WriteLine(adc.ShadowCopy);

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace | ConfigManager.GetItem Overload List


ConfigManager.GetItem (String, Selector, Int32)

This overload of the GetItem method accepts a selector in the form of an object and also accepts a set of flags indicating the desired level of service.

[Visual Basic]
Overloads Public Shared Function GetItem( _
   ByVal configType As String, _
   ByVal selector As Selector, _
   ByVal los As Integer _
) As IConfigItem
[C#]
public static IConfigItem GetItem(
   string configType,
   Selector selector,
   int los
);
[C++]
public: static IConfigItem* GetItem(
   String* configType,
   Selector* selector,
   int los
);
[JScript]
public static function GetItem(
   configType : String,
   selector : Selector,
   los : int
) : IConfigItem;

Parameters

configType
A String indicating the type of configuration information to be retrieved.
selector
An object deriving from Selector, that indicates the storage location of the configuration information to be retrieved.
los
An integer indicating one or more LevelOfService flags.

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace | ConfigManager.GetItem Overload List


ConfigManager.GetItem (String, String, Int32)

This overload of the GetItem method accepts a selector in string form. It attempts to create a Selector from this string. It also accepts a set of flags indicating the desired level of service.

[Visual Basic]
Overloads Public Shared Function GetItem( _
   ByVal configType As String, _
   ByVal selector As String, _
   ByVal los As Integer _
) As IConfigItem
[C#]
public static IConfigItem GetItem(
   string configType,
   string selector,
   int los
);
[C++]
public: static IConfigItem* GetItem(
   String* configType,
   String* selector,
   int los
);
[JScript]
public static function GetItem(
   configType : String,
   selector : String,
   los : int
) : IConfigItem;

Parameters

configType
A String indicating the type of configuration information to be retrieved.
selector
A String indicating the storage location of the configuration information to be retrieved. Refer to Selector for more details.
los
An integer indicating one or more LevelOfService flags.

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace | ConfigManager.GetItem Overload List


ConfigManager.GetProperty

The Get, GetItem and GetProperty methods provide read access to configuration information.

The GetProperty methods return a single property value. They can only be used to retrieve properties for singleton ConfigTypes. If more than one instance of this ConfigType exists (within the scope indicated by the Selector), the GetItem methods throw an exception.

Other methods exist to retrieve an entire singleton configuration items (GetItem) or collections of configuration items (Get).

Overload List

This overload of the GetProperty method accepts a selector in the form of an object.

[Visual Basic] Overloads Public Shared Function GetProperty(String, Selector, String) As Object
[C#] public static object GetProperty(String, Selector, String);
[C++] public: static Object* GetProperty(String*, Selector, String*);
[JScript] public static function GetProperty(String, Selector, String) : Object;

This overload of the GetProperty method accepts a selector in string form. It attempts to create a Selector from this string. It also accepts a set of flags indicating the desired level of service.

[Visual Basic] Overloads Public Shared Function GetProperty(String, String, Integer, String) As Object
[C#] public static object GetProperty(String, String, int, String);
[C++] public: static Object* GetProperty(String*, String*, int, String*);
[JScript] public static function GetProperty(String, String, int, String) : Object;

This overload of the GetProperty method accepts a selector in string form. It attempts to create a Selector from this string.

[Visual Basic] Overloads Public Shared Function GetProperty(String, String, String) As Object
[C#] public static object GetProperty(String, String, String);
[C++] public: static Object* GetProperty(String*, String*, String*);
[JScript] public static function GetProperty(String, String, String) : Object;

This overload of the GetProperty method accepts a selector in string form. It attempts to create a Selector from this string. It also accepts a set of flags indicating the desired level of service.

[Visual Basic] Overloads Public Shared Function GetProperty(String, Selector, Integer, String) As Object
[C#] public static object GetProperty(String, Selector, int, String);
[C++] public: static Object* GetProperty(String*, Selector, int, String*);
[JScript] public static function GetProperty(String, Selector, int, String) : Object;

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace


ConfigManager.GetProperty (String, Selector, String)

This overload of the GetProperty method accepts a selector in the form of an object.

[Visual Basic]
Overloads Public Shared Function GetProperty( _
   ByVal configType As String, _
   ByVal selector As Selector, _
   ByVal PropertyName As String _
) As Object
[C#]
public static object GetProperty(
   string configType,
   Selector selector,
   string PropertyName
);
[C++]
public: static Object* GetProperty(
   String* configType,
   Selector* selector,
   String* PropertyName
);
[JScript]
public static function GetProperty(
   configType : String,
   selector : Selector,
   PropertyName : String
) : Object;

Parameters

configType
A String indicating the type of configuration information to be retrieved.
selector
An object deriving from Selector, that indicates the storage location of the configuration information to be retrieved.
PropertyName
A String indicating the name of the property to be retrieved.

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace | ConfigManager.GetProperty Overload List


ConfigManager.GetProperty (String, String, Int32, String)

This overload of the GetProperty method accepts a selector in string form. It attempts to create a Selector from this string. It also accepts a set of flags indicating the desired level of service.

[Visual Basic]
Overloads Public Shared Function GetProperty( _
   ByVal configType As String, _
   ByVal selector As String, _
   ByVal los As Integer, _
   ByVal PropertyName As String _
) As Object
[C#]
public static object GetProperty(
   string configType,
   string selector,
   int los,
   string PropertyName
);
[C++]
public: static Object* GetProperty(
   String* configType,
   String* selector,
   int los,
   String* PropertyName
);
[JScript]
public static function GetProperty(
   configType : String,
   selector : String,
   los : int,
   PropertyName : String
) : Object;

Parameters

configType
A String indicating the type of configuration information to be retrieved.
selector
[To be supplied.]
los
An integer indicating one or more LevelOfService flags.
PropertyName
A String indicating the name of the property to be retrieved.

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace | ConfigManager.GetProperty Overload List


ConfigManager.GetProperty (String, String, String)

This overload of the GetProperty method accepts a selector in string form. It attempts to create a Selector from this string.

[Visual Basic]
Overloads Public Shared Function GetProperty( _
   ByVal configType As String, _
   ByVal selector As String, _
   ByVal PropertyName As String _
) As Object
[C#]
public static object GetProperty(
   string configType,
   string selector,
   string PropertyName
);
[C++]
public: static Object* GetProperty(
   String* configType,
   String* selector,
   String* PropertyName
);
[JScript]
public static function GetProperty(
   configType : String,
   selector : String,
   PropertyName : String
) : Object;

Parameters

configType
A String indicating the type of configuration information to be retrieved.
selector
A String indicating the storage location of the configuration information to be retrieved. Refer to Selector for more details.
PropertyName
A String indicating the name of the property to be retrieved.

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace | ConfigManager.GetProperty Overload List


ConfigManager.GetProperty (String, Selector, Int32, String)

This overload of the GetProperty method accepts a selector in string form. It attempts to create a Selector from this string. It also accepts a set of flags indicating the desired level of service.

[Visual Basic]
Overloads Public Shared Function GetProperty( _
   ByVal configType As String, _
   ByVal selector As Selector, _
   ByVal los As Integer, _
   ByVal PropertyName As String _
) As Object
[C#]
public static object GetProperty(
   string configType,
   Selector selector,
   int los,
   string PropertyName
);
[C++]
public: static Object* GetProperty(
   String* configType,
   Selector* selector,
   int los,
   String* PropertyName
);
[JScript]
public static function GetProperty(
   configType : String,
   selector : Selector,
   los : int,
   PropertyName : String
) : Object;

Parameters

configType
A String indicating the type of configuration information to be retrieved.
selector
An object deriving from Selector, that indicates the storage location of the configuration information to be retrieved.
los
An integer indicating one or more LevelOfService flags.
PropertyName
A String indicating the name of the property to be retrieved.

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace | ConfigManager.GetProperty Overload List


ConfigManager.GetSelectorFromString

Parses a selector string and creates the appropriate selector object for the string.

[Visual Basic]
Public Shared Function GetSelectorFromString( _
   ByVal selector As String _
) As Selector
[C#]
public static Selector GetSelectorFromString(
   string selector
);
[C++]
public: static Selector* GetSelectorFromString(
   String* selector
);
[JScript]
public static function GetSelectorFromString(
   selector : String
) : Selector;

Parameters

selector
A String representation of a Selector.

Remarks

The GetSelectorFromString method uses the prefix in the selector string to determine the selector class to be returned.

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace


ConfigManager.Put

The Put, PutItem and PutProperty methods provide write access to configuration information.

The Put methods allow writes to more than one configuration item at a time. They can be used to write any configuration information, including singleton ConfigTypes, as long as configuration schema has been defined.

Other methods exist to write singleton configuration items (PutItem) or individual configuration properties (PutProperty).

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Shared Sub Put(IConfigCollection, PutFlags)
[C#] public static void Put(IConfigCollection, PutFlags);
[C++] public: static void Put(IConfigCollection*, PutFlags);
[JScript] public static function Put(IConfigCollection, PutFlags);

[To be supplied.]

[Visual Basic] Overloads Public Shared Sub Put(IConfigCollection)
[C#] public static void Put(IConfigCollection);
[C++] public: static void Put(IConfigCollection*);
[JScript] public static function Put(IConfigCollection);

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace


ConfigManager.Put (IConfigCollection, PutFlags)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Sub Put( _
   ByVal cc As IConfigCollection, _
   ByVal pflags As PutFlags _
)
[C#]
public static void Put(
   IConfigCollection cc,
   PutFlags pflags
);
[C++]
public: static void Put(
   IConfigCollection* cc,
   PutFlags pflags
);
[JScript]
public static function Put(
   cc : IConfigCollection,
   pflags : PutFlags
);

Parameters

cc
[To be supplied.]
pflags
[To be supplied.]

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace | ConfigManager.Put Overload List


ConfigManager.Put (IConfigCollection)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Sub Put( _
   ByVal cc As IConfigCollection _
)
[C#]
public static void Put(
   IConfigCollection cc
);
[C++]
public: static void Put(
   IConfigCollection* cc
);
[JScript]
public static function Put(
   cc : IConfigCollection
);

Parameters

cc
[To be supplied.]

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace | ConfigManager.Put Overload List


ConfigManager.PutItem

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Shared Sub PutItem(IConfigItem)
[C#] public static void PutItem(IConfigItem);
[C++] public: static void PutItem(IConfigItem*);
[JScript] public static function PutItem(IConfigItem);

[To be supplied.]

[Visual Basic] Overloads Public Shared Sub PutItem(IConfigItem, PutFlags)
[C#] public static void PutItem(IConfigItem, PutFlags);
[C++] public: static void PutItem(IConfigItem*, PutFlags);
[JScript] public static function PutItem(IConfigItem, PutFlags);

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace


ConfigManager.PutItem (IConfigItem)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Sub PutItem( _
   ByVal ci As IConfigItem _
)
[C#]
public static void PutItem(
   IConfigItem ci
);
[C++]
public: static void PutItem(
   IConfigItem* ci
);
[JScript]
public static function PutItem(
   ci : IConfigItem
);

Parameters

ci
[To be supplied.]

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace | ConfigManager.PutItem Overload List


ConfigManager.PutItem (IConfigItem, PutFlags)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Sub PutItem( _
   ByVal ci As IConfigItem, _
   ByVal pflags As PutFlags _
)
[C#]
public static void PutItem(
   IConfigItem ci,
   PutFlags pflags
);
[C++]
public: static void PutItem(
   IConfigItem* ci,
   PutFlags pflags
);
[JScript]
public static function PutItem(
   ci : IConfigItem,
   pflags : PutFlags
);

Parameters

ci
[To be supplied.]
pflags
[To be supplied.]

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace | ConfigManager.PutItem Overload List


ConfigManager.PutProperty

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Shared Sub PutProperty(String, Selector, String, Object)
[C#] public static void PutProperty(String, Selector, String, Object);
[C++] public: static void PutProperty(String*, Selector, String*, Object);
[JScript] public static function PutProperty(String, Selector, String, Object);

[To be supplied.]

[Visual Basic] Overloads Public Shared Sub PutProperty(String, String, String, Object)
[C#] public static void PutProperty(String, String, String, Object);
[C++] public: static void PutProperty(String*, String*, String*, Object);
[JScript] public static function PutProperty(String, String, String, Object);

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace


ConfigManager.PutProperty (String, Selector, String, Object)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Sub PutProperty( _
   ByVal configType As String, _
   ByVal selector As Selector, _
   ByVal PropertyName As String, _
   ByVal Value As Object _
)
[C#]
public static void PutProperty(
   string configType,
   Selector selector,
   string PropertyName,
   object Value
);
[C++]
public: static void PutProperty(
   String* configType,
   Selector* selector,
   String* PropertyName,
   Object* Value
);
[JScript]
public static function PutProperty(
   configType : String,
   selector : Selector,
   PropertyName : String,
   Value : Object
);

Parameters

configType
[To be supplied.]
selector
[To be supplied.]
PropertyName
[To be supplied.]
Value
[To be supplied.]

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace | ConfigManager.PutProperty Overload List


ConfigManager.PutProperty (String, String, String, Object)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Sub PutProperty( _
   ByVal configType As String, _
   ByVal selector As String, _
   ByVal PropertyName As String, _
   ByVal Value As Object _
)
[C#]
public static void PutProperty(
   string configType,
   string selector,
   string PropertyName,
   object Value
);
[C++]
public: static void PutProperty(
   String* configType,
   String* selector,
   String* PropertyName,
   Object* Value
);
[JScript]
public static function PutProperty(
   configType : String,
   selector : String,
   PropertyName : String,
   Value : Object
);

Parameters

configType
[To be supplied.]
selector
[To be supplied.]
PropertyName
[To be supplied.]
Value
[To be supplied.]

See Also

ConfigManager Class | ConfigManager Members | System.Configuration Namespace | ConfigManager.PutProperty Overload List


ConfigQuery Class

Allows simple queries against configuration information.

Object
Selector
ConfigQuery

[Visual Basic]
Public Class ConfigQuery
   Inherits Selector
[C#]
public class ConfigQuery : Selector
[C++]
public __gc class ConfigQuery : public Selector
[JScript]
public class ConfigQuery extends Selector

Remarks

A caller can limit the items returned into a collection by specifying a ConfigQuery, instead of a FileSelector (or AppDomainSelector) in calls to methods on the ConfigManager.

Query capability is particularly useful for larger collections.

Requirements

Namespace: System.Configuration

Assembly: System.Configuration.dll

Example [C#]

[C#]

ConfigQuery query = new ConfigQuery("SELECT * FROM CodeBase WHERE Name=Wininet AND Selector=appdomain://");

IConfigCollection hints = ConfigManager.Get("CodeBase", query);
foreach (CodeBaseHint codebase in hints) {
 Console.WriteLine(codebase.Name+": "+codebase.CodeBase);
}

See Also

ConfigQuery Members | System.Configuration Namespace


ConfigQuery Members

Public:

Constructor

ConfigQuery Constructor Overloaded. [To be supplied.]

Properties

ConfigType | Indicates the ConfigType to which this query is to be applied.
Count | The number of QueryCells in the ConfigQuery.
Item | Returns a QueryCell from the ConfigQuery. In C#, this member is the indexer for the ConfigQuery class.
Prefix | [To be supplied.]
Query | The string representation of the current ConfigQuery.
Selector | Indicates the selector to use for this query (if applicable).

Methods

Add | Overloaded. Adds a QueryCell to the ConfigQuery.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Remove | Removes a QueryCell from a ConfigQuery.
ToString | Returns a string representation of the ConfigQuery, which can be passed as a string parameter to any ConfigManager method that expects a selector in string form.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConfigQuery Class | System.Configuration Namespace


ConfigQuery Constructor

[To be supplied.]

Overload List

Creates an empty ConfigQuery.

[Visual Basic] Overloads Public Sub New()
[C#] public ConfigQuery();
[C++] public: ConfigQuery();
[JScript] public function ConfigQuery();

Creates a ConfigQuery and parses the query string.

[Visual Basic] Overloads Public Sub New(String)
[C#] public ConfigQuery(String);
[C++] public: ConfigQuery(String*);
[JScript] public function ConfigQuery(String);

See Also

ConfigQuery Class | ConfigQuery Members | System.Configuration Namespace


ConfigQuery Constructor ()

Creates an empty ConfigQuery.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ConfigQuery();
[C++]
public: ConfigQuery();
[JScript]
public function ConfigQuery();

See Also

ConfigQuery Class | ConfigQuery Members | System.Configuration Namespace | ConfigQuery Constructor Overload List


ConfigQuery Constructor (String)

Creates a ConfigQuery and parses the query string.

[Visual Basic]
Overloads Public Sub New( _
   ByVal query As String _
)
[C#]
public ConfigQuery(
   string query
);
[C++]
public: ConfigQuery(
   String* query
);
[JScript]
public function ConfigQuery(
   query : String
);

Parameters

query
A query string of the form "SELECT * FROM <configtype> WHERE <propertyname> = <value> AND <propertyname2>=<value2>"

Remarks

In order to specify a storage location in the query string, the special property name "SELECTOR" can be used.

See Also

ConfigQuery Class | ConfigQuery Members | System.Configuration Namespace | ConfigQuery Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ConfigQuery Properties

The properties of the ConfigQuery class are listed below. For a complete list of ConfigQuery class members, see the ConfigQuery Members topic.

Public:

ConfigType | Indicates the ConfigType to which this query is to be applied.
Count | The number of QueryCells in the ConfigQuery.
Item | Returns a QueryCell from the ConfigQuery. In C#, this member is the indexer for the ConfigQuery class.
Prefix | [To be supplied.]
Query | The string representation of the current ConfigQuery.
Selector | Indicates the selector to use for this query (if applicable).

See Also

ConfigQuery Class | System.Configuration Namespace


ConfigQuery.ConfigType

Indicates the ConfigType to which this query is to be applied.

[Visual Basic]
Public ReadOnly Property ConfigType As String
[C#]
public string ConfigType {get;}
[C++]
public: __property String* get_ConfigType();
[JScript]
public function get ConfigType() : String;

See Also

ConfigQuery Class | ConfigQuery Members | System.Configuration Namespace


ConfigQuery.Count

The number of QueryCells in the ConfigQuery.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

See Also

ConfigQuery Class | ConfigQuery Members | System.Configuration Namespace


ConfigQuery.Item

Returns a QueryCell from the ConfigQuery.

[C#] In C#, this member is the indexer for the ConfigQuery class.

[Visual Basic]
Public Default Property Item( _
   ByVal Index As Integer _
) As QueryCell
[C#]
public QueryCell this[
   int Index
] {get; set;}
[C++]
public: __property QueryCell* get_Item(
   int Index
);
public: __property void set_Item(
   int Index,
   QueryCell*
);
[JScript]
returnValue = ConfigQueryObject.Item(Index);
ConfigQueryObject.Item(Index) = returnValue;
-or-
returnValue = ConfigQueryObject(Index);
ConfigQueryObject(Index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

Index
The index of the QueryCell to be retrieved (not the property index!).

Parameters [Visual Basic, C#, C++]

Index
The index of the QueryCell to be retrieved (not the property index!).

See Also

ConfigQuery Class | ConfigQuery Members | System.Configuration Namespace


ConfigQuery.Prefix

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Prefix As String
[C#]
public string Prefix {override get;}
[C++]
public: __property virtual String* get_Prefix();
[JScript]
public function get Prefix() : String;

Property Value

Returns "query" as the prefix for the ConfigQuery class, when used as a selector.

See Also

ConfigQuery Class | ConfigQuery Members | System.Configuration Namespace


ConfigQuery.Query

The string representation of the current ConfigQuery.

[Visual Basic]
Public ReadOnly Property Query As String
[C#]
public string Query {get;}
[C++]
public: __property String* get_Query();
[JScript]
public function get Query() : String;

See Also

ConfigQuery Class | ConfigQuery Members | System.Configuration Namespace


ConfigQuery.Selector

Indicates the selector to use for this query (if applicable).

[Visual Basic]
Public Property Selector As Selector
[C#]
public Selector Selector {get; set;}
[C++]
public: __property Selector* get_Selector();
public: __property void set_Selector(Selector*);
[JScript]
public function get Selector() : Selector;
public function set Selector(Selector);

See Also

ConfigQuery Class | ConfigQuery Members | System.Configuration Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ConfigQuery Methods

The methods of the ConfigQuery class are listed below. For a complete list of ConfigQuery class members, see the ConfigQuery Members topic.

Public:

Add | Overloaded. Adds a QueryCell to the ConfigQuery.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Remove | Removes a QueryCell from a ConfigQuery.
ToString | Returns a string representation of the ConfigQuery, which can be passed as a string parameter to any ConfigManager method that expects a selector in string form.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConfigQuery Class | System.Configuration Namespace


ConfigQuery.Add

Adds a QueryCell to the ConfigQuery.

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub Add(QueryCell)
[C#] public void Add(QueryCell);
[C++] public: void Add(QueryCell*);
[JScript] public function Add(QueryCell);

[To be supplied.]

[Visual Basic] Overloads Public Sub Add(String, String, QueryCellOp, Object)
[C#] public void Add(String, String, QueryCellOp, Object);
[C++] public: void Add(String*, String*, QueryCellOp, Object);
[JScript] public function Add(String, String, QueryCellOp, Object);

[To be supplied.]

[Visual Basic] Overloads Public Sub Add(Integer, QueryCellOp, Object)
[C#] public void Add(int, QueryCellOp, Object);
[C++] public: void Add(int, QueryCellOp, Object);
[JScript] public function Add(int, QueryCellOp, Object);

See Also

ConfigQuery Class | ConfigQuery Members | System.Configuration Namespace


ConfigQuery.Add (QueryCell)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Add( _
   ByVal cell As QueryCell _
)
[C#]
public void Add(
   QueryCell cell
);
[C++]
public: void Add(
   QueryCell* cell
);
[JScript]
public function Add(
   cell : QueryCell
);

Parameters

cell
The QueryCell to be added.

See Also

ConfigQuery Class | ConfigQuery Members | System.Configuration Namespace | ConfigQuery.Add Overload List


ConfigQuery.Add (String, String, QueryCellOp, Object)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Add( _
   ByVal configType As String, _
   ByVal propertyName As String, _
   ByVal Operator As QueryCellOp, _
   ByVal Value As Object _
)
[C#]
public void Add(
   string configType,
   string propertyName,
   QueryCellOp Operator,
   object Value
);
[C++]
public: void Add(
   String* configType,
   String* propertyName,
   QueryCellOp Operator,
   Object* Value
);
[JScript]
public function Add(
   configType : String,
   propertyName : String,
   Operator : QueryCellOp,
   Value : Object
);

Parameters

configType
The ConfigType to which this query is to be applied. Required to validate that the property name exists in the ConfigType.
propertyName
[To be supplied.]
Operator
A QueryCellOp indicating how filtering should be performed.
Value
[To be supplied.]

See Also

ConfigQuery Class | ConfigQuery Members | System.Configuration Namespace | ConfigQuery.Add Overload List


ConfigQuery.Add (Int32, QueryCellOp, Object)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Add( _
   ByVal PropertyIndex As Integer, _
   ByVal Operator As QueryCellOp, _
   ByVal Value As Object _
)
[C#]
public void Add(
   int PropertyIndex,
   QueryCellOp Operator,
   object Value
);
[C++]
public: void Add(
   int PropertyIndex,
   QueryCellOp Operator,
   Object* Value
);
[JScript]
public function Add(
   PropertyIndex : int,
   Operator : QueryCellOp,
   Value : Object
);

Parameters

PropertyIndex
The numeric index of the property by which the query is to filter.
Operator
[To be supplied.]
Value
[To be supplied.]

See Also

ConfigQuery Class | ConfigQuery Members | System.Configuration Namespace | ConfigQuery.Add Overload List


ConfigQuery.Remove

Removes a QueryCell from a ConfigQuery.

[Visual Basic]
Public Sub Remove( _
   ByVal nIndex As Integer _
)
[C#]
public void Remove(
   int nIndex
);
[C++]
public: void Remove(
   int nIndex
);
[JScript]
public function Remove(
   nIndex : int
);

Parameters

nIndex
The index of the QueryCell to be removed (not the property index!).

See Also

ConfigQuery Class | ConfigQuery Members | System.Configuration Namespace


ConfigQuery.ToString

Returns a string representation of the ConfigQuery, which can be passed as a string parameter to any ConfigManager method that expects a selector in string form.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

ConfigQuery Class | ConfigQuery Members | System.Configuration Namespace


FileSelector Class

Indicates the file location for configuration information that is stored in configuration files.

Object
Selector
Internal.UrlSelectorBase
FileSelector

[Visual Basic]
Public Class FileSelector
   Inherits UrlSelectorBase
[C#]
public class FileSelector : UrlSelectorBase
[C++]
public __gc class FileSelector : public UrlSelectorBase
[JScript]
public class FileSelector extends UrlSelectorBase

Remarks

[To be supplied.]

Requirements

Namespace: System.Configuration

Assembly: System.Configuration.dll

See Also

FileSelector Members | System.Configuration Namespace


FileSelector Members

Public:

Constructor

FileSelector Constructor The string representation of a file selector is "file://<localpath>".

Properties

Argument (inherited from UrlSelectorBase) | [To be supplied.]
Prefix | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from UrlSelectorBase) | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FileSelector Class | System.Configuration Namespace


FileSelector Constructor

The string representation of a file selector is "file://<localpath>".

[Visual Basic]
Public Sub New( _
   ByVal s As String _
)
[C#]
public FileSelector(
   string s
);
[C++]
public: FileSelector(
   String* s
);
[JScript]
public function FileSelector(
   s : String
);

Parameters

s
[To be supplied.]

See Also

FileSelector Class | FileSelector Members | System.Configuration Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

FileSelector Properties

The properties of the FileSelector class are listed below. For a complete list of FileSelector class members, see the FileSelector Members topic.

Public:

Argument (inherited from UrlSelectorBase) | [To be supplied.]
Prefix | [To be supplied.]

See Also

FileSelector Class | System.Configuration Namespace


FileSelector.Prefix

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Prefix As String
[C#]
public string Prefix {override get;}
[C++]
public: __property virtual String* get_Prefix();
[JScript]
public function get Prefix() : String;

Property Value

The prefix for FileSelector is "file".

See Also

FileSelector Class | FileSelector Members | System.Configuration Namespace


HttpSelector Class

Indicates the configuration file hierarchy for configuration information for web server configuration.

The configuration system can convert the URL into a list of physical configuration file locations (FileSelector) and then performs a merge across the hierarchy of configuration files. Refer to Interceptors.IConfigTransformer and Interceptors.IConfigMerger for details.

Object
Selector
Internal.UrlSelectorBase
HttpSelector

[Visual Basic]
Public Class HttpSelector
   Inherits UrlSelectorBase
[C#]
public class HttpSelector : UrlSelectorBase
[C++]
public __gc class HttpSelector : public UrlSelectorBase
[JScript]
public class HttpSelector extends UrlSelectorBase

Remarks

[To be supplied.]

Requirements

Namespace: System.Configuration

Assembly: System.Configuration.dll

See Also

HttpSelector Members | System.Configuration Namespace


HttpSelector Members

Public:

Constructor

HttpSelector Constructor The string representation of a HttpSelector is "http://<urlpath>".

Properties

Argument (inherited from UrlSelectorBase) | [To be supplied.]
Prefix | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from UrlSelectorBase) | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HttpSelector Class | System.Configuration Namespace


HttpSelector Constructor

The string representation of a HttpSelector is "http://<urlpath>".

[Visual Basic]
Public Sub New( _
   ByVal s As String _
)
[C#]
public HttpSelector(
   string s
);
[C++]
public: HttpSelector(
   String* s
);
[JScript]
public function HttpSelector(
   s : String
);

Parameters

s
[To be supplied.]

See Also

HttpSelector Class | HttpSelector Members | System.Configuration Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

HttpSelector Properties

The properties of the HttpSelector class are listed below. For a complete list of HttpSelector class members, see the HttpSelector Members topic.

Public:

Argument (inherited from UrlSelectorBase) | [To be supplied.]
Prefix | [To be supplied.]

See Also

HttpSelector Class | System.Configuration Namespace


HttpSelector.Prefix

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Prefix As String
[C#]
public string Prefix {override get;}
[C++]
public: __property virtual String* get_Prefix();
[JScript]
public function get Prefix() : String;

Property Value

The prefix for HttpSelector is "http".

See Also

HttpSelector Class | HttpSelector Members | System.Configuration Namespace


IConfigCollection Interface

Provides access to a collection of configuration items.

[Visual Basic]
Public Interface IConfigCollection
   Implements ICloneable, IList, ICollection, IEnumerable
[C#]
public interface IConfigCollection : ICloneable, IList,
   ICollection, IEnumerable
[C++]
public __gc __interface IConfigCollection : public ICloneable,
   IList, ICollection, IEnumerable

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IConfigCollection

Class | Description
BaseConfigCollection | A generic implementation of the IConfigCollection interface.

Remarks

Notes to Callers: IConfigCollection.Remove does not actually delete a configuration item from a configuration store. It only removes it from the collection in memory. In order to delete a configuration from a configuration store, you must use Delete.

Requirements

Namespace: System.Configuration

Assembly: System.Configuration.dll

See Also

IConfigCollection Members | System.Configuration Namespace


IConfigCollection Members

Properties

ConfigType | Returns the ConfigType of the configuration items in this collection.
IsFrozen | Indicates if a configuration collection can be changed or not.
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the IConfigCollection class.
Selector | Returns the Selector which was used to retrieve this configuration collection.

Methods

Add | Adds a new item to the configuration collection.
FindByKey | Overloaded. Returns the configuration item whose primary key properties match the specified values.
Freeze | Makes the configuration item read-only.
IndexOf | Returns the index of a configuration item in the configuration collection.
Insert | Inserts a configuration item into the configuration collection.

See Also

IConfigCollection Interface | System.Configuration Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IConfigCollection Properties

The properties of the IConfigCollection interface are listed below. For a complete list of IConfigCollection interface members, see the IConfigCollection Members topic.

ConfigType | Returns the ConfigType of the configuration items in this collection.
IsFrozen | Indicates if a configuration collection can be changed or not.
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the IConfigCollection class.
Selector | Returns the Selector which was used to retrieve this configuration collection.

See Also

IConfigCollection Interface | System.Configuration Namespace


IConfigCollection.ConfigType

Returns the ConfigType of the configuration items in this collection.

[Visual Basic]
Property ConfigType As String
[C#]
string ConfigType {get; set;}
[C++]
String* get_ConfigType() = 0;void set_ConfigType(String*) = 0;
[JScript]
abstract function get ConfigType() : String;
public abstract function set ConfigType(String);

See Also

IConfigCollection Interface | IConfigCollection Members | System.Configuration Namespace


IConfigCollection.IsFrozen

Indicates if a configuration collection can be changed or not.

[Visual Basic]
ReadOnly Property IsFrozen As Boolean
[C#]
bool IsFrozen {get;}
[C++]
bool get_IsFrozen() = 0;
[JScript]
abstract function get IsFrozen() : Boolean;

See Also

IConfigCollection Interface | IConfigCollection Members | System.Configuration Namespace


IConfigCollection.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the IConfigCollection class.

Overload List

[To be supplied.]

[Visual Basic] Overloads Default Property Item(Integer) As IConfigItem
[C#] IConfigItem this[int] {get; set;}
[C++] IConfigItem* get_Item(int) = 0;
void set_Item(int, IConfigItem*) = 0;
[JScript] IConfigCollection.Item (int)

Returns the configuration item whose primary key property matched the specified value.

[Visual Basic] Overloads Default ReadOnly Property Item(String) As IConfigItem
[C#] IConfigItem this[String] {get;}
[C++] IConfigItem* get_Item(String*) = 0;
[JScript] IConfigCollection.Item (String)

See Also

IConfigCollection Interface | IConfigCollection Members | System.Configuration Namespace


IConfigCollection.Item (Int32)

[To be supplied.]

[C#] In C#, this member is the indexer for the IConfigCollection class.

[Visual Basic]
Overloads Default Property Item( _
   ByVal Index As Integer _
) As IConfigItem
[C#]
IConfigItem this[
   int Index
] {get; set;}
[C++]
IConfigItem* get_Item(
   int Index
) = 0;void set_Item(
   int Index,
   IConfigItem*
) = 0;
[JScript]
abstract returnValue = IConfigCollectionObject.Item(Index);
IConfigCollectionObject.Item(Index) = returnValue;
-or-
abstract returnValue = IConfigCollectionObject(Index);
IConfigCollectionObject(Index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

Index
[To be supplied.]

Parameters [Visual Basic, C#, C++]

Index
[To be supplied.]

See Also

IConfigCollection Interface | IConfigCollection Members | System.Configuration Namespace | IConfigCollection.Item Overload List


IConfigCollection.Item (String)

Returns the configuration item whose primary key property matched the specified value.

[C#] In C#, this member is the indexer for the IConfigCollection class.

[Visual Basic]
Overloads Default ReadOnly Property Item( _
   ByVal Key As String _
) As IConfigItem
[C#]
IConfigItem this[
   string Key
] {get;}
[C++]
IConfigItem* get_Item(
   String* Key
) = 0;
[JScript]
abstract returnValue = IConfigCollectionObject.Item(Key);
-or-
abstract returnValue = IConfigCollectionObject(Key);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

Key
[To be supplied.]

Parameters [Visual Basic, C#, C++]

Key
[To be supplied.]

Remarks

Can only be used for ConfigTypes that have a single primary key property. For ConfigTypes with multi-valued primary keys use FindByKey

See Also

IConfigCollection Interface | IConfigCollection Members | System.Configuration Namespace | IConfigCollection.Item Overload List


IConfigCollection.Selector

Returns the Selector which was used to retrieve this configuration collection.

[Visual Basic]
Property Selector As Selector
[C#]
Selector Selector {get; set;}
[C++]
Selector* get_Selector() = 0;void set_Selector(Selector*) = 0;
[JScript]
abstract function get Selector() : Selector;
public abstract function set Selector(Selector);

Remarks

If the configuration collection was not read through the ConfigManager the Selector property may return null.

See Also

IConfigCollection Interface | IConfigCollection Members | System.Configuration Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IConfigCollection Methods

The methods of the IConfigCollection interface are listed below. For a complete list of IConfigCollection interface members, see the IConfigCollection Members topic.

Add | Adds a new item to the configuration collection.
FindByKey | Overloaded. Returns the configuration item whose primary key properties match the specified values.
Freeze | Makes the configuration item read-only.
IndexOf | Returns the index of a configuration item in the configuration collection.
Insert | Inserts a configuration item into the configuration collection.

See Also

IConfigCollection Interface | System.Configuration Namespace


IConfigCollection.Add

Adds a new item to the configuration collection.

[Visual Basic]
Function Add( _
   ByVal Item As IConfigItem _
) As Integer
[C#]
int Add(
   IConfigItem Item
);
[C++]
int Add(
   IConfigItem* Item
) = 0;
[JScript]
function Add(
   Item : IConfigItem
) : int;

Parameters

Item
[To be supplied.]

Remarks

The GetEmptyConfigItem method can be used to obtain a new configuration item.

See Also

IConfigCollection Interface | IConfigCollection Members | System.Configuration Namespace


IConfigCollection.FindByKey

Returns the configuration item whose primary key properties match the specified values.

Overload List

Returns the configuration item whose primary key properties match the specified values.

[Visual Basic] Overloads Function FindByKey(Object()) As IConfigItem
[C#] IConfigItem FindByKey(Object[]);
[C++] IConfigItem* FindByKey(Object*[]) = 0;
[JScript] function FindByKey(Object[]) : IConfigItem;

Returns the configuration item whose primary key property matched the specified value.

[Visual Basic] Overloads Function FindByKey(String) As IConfigItem
[C#] IConfigItem FindByKey(String);
[C++] IConfigItem* FindByKey(String*) = 0;
[JScript] function FindByKey(String) : IConfigItem;

See Also

IConfigCollection Interface | IConfigCollection Members | System.Configuration Namespace


IConfigCollection.FindByKey (Object[])

Returns the configuration item whose primary key properties match the specified values.

[Visual Basic]
Overloads Function FindByKey( _
   ByVal Key() As Object _
) As IConfigItem
[C#]
IConfigItem FindByKey(
   object[] Key
);
[C++]
IConfigItem* FindByKey(
   Object* Key[]
) = 0;
[JScript]
function FindByKey(
   Key : Object[]
) : IConfigItem;

Parameters

Key
An array of values indicating the primary key values. All primary key values must be specified and must be in order of increasing property index of the primary key properties.

See Also

IConfigCollection Interface | IConfigCollection Members | System.Configuration Namespace | IConfigCollection.FindByKey Overload List


IConfigCollection.FindByKey (String)

Returns the configuration item whose primary key property matched the specified value.

[Visual Basic]
Overloads Function FindByKey( _
   ByVal Key As String _
) As IConfigItem
[C#]
IConfigItem FindByKey(
   string Key
);
[C++]
IConfigItem* FindByKey(
   String* Key
) = 0;
[JScript]
function FindByKey(
   Key : String
) : IConfigItem;

Parameters

Key
[To be supplied.]

Remarks

Can only be used for ConfigTypes that have a single primary key property.

See Also

IConfigCollection Interface | IConfigCollection Members | System.Configuration Namespace | IConfigCollection.FindByKey Overload List


IConfigCollection.Freeze

Makes the configuration item read-only.

[Visual Basic]
Sub Freeze()
[C#]
void Freeze();
[C++]
void Freeze() = 0;
[JScript]
function Freeze();

Remarks

After Freeze has been called on a configuration collection, all changes to the collection will throw an exception.

See Also

IConfigCollection Interface | IConfigCollection Members | System.Configuration Namespace


IConfigCollection.IndexOf

Returns the index of a configuration item in the configuration collection.

[Visual Basic]
Function IndexOf( _
   ByVal Item As IConfigItem _
) As Integer
[C#]
int IndexOf(
   IConfigItem Item
);
[C++]
int IndexOf(
   IConfigItem* Item
) = 0;
[JScript]
function IndexOf(
   Item : IConfigItem
) : int;

Parameters

Item
[To be supplied.]

See Also

IConfigCollection Interface | IConfigCollection Members | System.Configuration Namespace


IConfigCollection.Insert

Inserts a configuration item into the configuration collection.

[Visual Basic]
Sub Insert( _
   ByVal Index As Integer, _
   ByVal Item As IConfigItem _
)
[C#]
void Insert(
   int Index,
   IConfigItem Item
);
[C++]
void Insert(
   int Index,
   IConfigItem* Item
) = 0;
[JScript]
function Insert(
   Index : int,
   Item : IConfigItem
);

Parameters

Index
[To be supplied.]
Item
[To be supplied.]

See Also

IConfigCollection Interface | IConfigCollection Members | System.Configuration Namespace


IConfigItem Interface

Provides late-bound access to the properties in a configuration item.

[Visual Basic]
Public Interface IConfigItem
   Implements ICloneable, ICollection, IEnumerable
[C#]
public interface IConfigItem : ICloneable, ICollection, IEnumerable
[C++]
public __gc __interface IConfigItem : public ICloneable,
   ICollection, IEnumerable

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IConfigItem

Class | Description
BaseConfigItem | A generic implementation of the IConfigItem interface.

Remarks

A configuration item consists of an ordered collection of properties. Properties have a Name, an Index, a Type and a Value.

A configuration item carries its configuration type and the storage location from which it was retrieved.

A configuration item is a ICollection and can be enumerated.

Requirements

Namespace: System.Configuration

Assembly: System.Configuration.dll

See Also

IConfigItem Members | System.Configuration Namespace


IConfigItem Members

Properties

Collection | Returns the IConfigCollection to which this configuration item belongs.
ConfigType | Returns the ConfigType of this configuration item.
IsFrozen | Indicates if a configuration item can be changed or not.
Item | Overloaded. Gets ot sets the value of a property. Values can be of type Int32, Boolean, String or String[]. In C#, this member is the indexer for the IConfigItem class.
Selector | Returns the Selector which was used to retrieve this configuration item.

Methods

Freeze Makes the configuration item read-only.

See Also

IConfigItem Interface | System.Configuration Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IConfigItem Properties

The properties of the IConfigItem interface are listed below. For a complete list of IConfigItem interface members, see the IConfigItem Members topic.

Collection | Returns the IConfigCollection to which this configuration item belongs.
ConfigType | Returns the ConfigType of this configuration item.
IsFrozen | Indicates if a configuration item can be changed or not.
Item | Overloaded. Gets ot sets the value of a property. Values can be of type Int32, Boolean, String or String[]. In C#, this member is the indexer for the IConfigItem class.
Selector | Returns the Selector which was used to retrieve this configuration item.

See Also

IConfigItem Interface | System.Configuration Namespace


IConfigItem.Collection

Returns the IConfigCollection to which this configuration item belongs.

[Visual Basic]
Property Collection As IConfigCollection
[C#]
IConfigCollection Collection {get; set;}
[C++]
IConfigCollection* get_Collection() = 0;void set_Collection(IConfigCollection*) = 0;
[JScript]
abstract function get Collection() : IConfigCollection;
public abstract function set Collection(IConfigCollection);

Remarks

If the configuration item does not belong to a collection, this property is null.

See Also

IConfigItem Interface | IConfigItem Members | System.Configuration Namespace


IConfigItem.ConfigType

Returns the ConfigType of this configuration item.

[Visual Basic]
Property ConfigType As String
[C#]
string ConfigType {get; set;}
[C++]
String* get_ConfigType() = 0;void set_ConfigType(String*) = 0;
[JScript]
abstract function get ConfigType() : String;
public abstract function set ConfigType(String);

See Also

IConfigItem Interface | IConfigItem Members | System.Configuration Namespace


IConfigItem.IsFrozen

Indicates if a configuration item can be changed or not.

[Visual Basic]
ReadOnly Property IsFrozen As Boolean
[C#]
bool IsFrozen {get;}
[C++]
bool get_IsFrozen() = 0;
[JScript]
abstract function get IsFrozen() : Boolean;

See Also

IConfigItem Interface | IConfigItem Members | System.Configuration Namespace


IConfigItem.Item

Gets ot sets the value of a property. Values can be of type Int32, Boolean, String or String[].

[C#] In C#, this member is the indexer for the IConfigItem class.

Overload List

Retrieves the value of a property given the index of the property. The index of the property is simply its order in the schema definition of the Config Type.

[Visual Basic] Overloads Default Property Item(Integer) As Object
[C#] object this[int] {get; set;}
[C++] Object* get_Item(int) = 0;
void set_Item(int, Object*) = 0;
[JScript] IConfigItem.Item (int)

Retrieves the value of a property given the name of the property.

[Visual Basic] Overloads Default Property Item(String) As Object
[C#] object this[String] {get; set;}
[C++] Object* get_Item(String*) = 0;
void set_Item(String*, Object*) = 0;
[JScript] IConfigItem.Item (String)

See Also

IConfigItem Interface | IConfigItem Members | System.Configuration Namespace


IConfigItem.Item (Int32)

Retrieves the value of a property given the index of the property. The index of the property is simply its order in the schema definition of the Config Type.

[C#] In C#, this member is the indexer for the IConfigItem class.

[Visual Basic]
Overloads Default Property Item( _
   ByVal PropertyIndex As Integer _
) As Object
[C#]
object this[
   int PropertyIndex
] {get; set;}
[C++]
Object* get_Item(
   int PropertyIndex
) = 0;void set_Item(
   int PropertyIndex,
   Object*
) = 0;
[JScript]
abstract returnValue = IConfigItemObject.Item(PropertyIndex);
IConfigItemObject.Item(PropertyIndex) = returnValue;
-or-
abstract returnValue = IConfigItemObject(PropertyIndex);
IConfigItemObject(PropertyIndex) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

PropertyIndex
[To be supplied.]

Parameters [Visual Basic, C#, C++]

PropertyIndex
[To be supplied.]

See Also

IConfigItem Interface | IConfigItem Members | System.Configuration Namespace | IConfigItem.Item Overload List


IConfigItem.Item (String)

Retrieves the value of a property given the name of the property.

[C#] In C#, this member is the indexer for the IConfigItem class.

[Visual Basic]
Overloads Default Property Item( _
   ByVal PropertyName As String _
) As Object
[C#]
object this[
   string PropertyName
] {get; set;}
[C++]
Object* get_Item(
   String* PropertyName
) = 0;void set_Item(
   String* PropertyName,
   Object*
) = 0;
[JScript]
abstract returnValue = IConfigItemObject.Item(PropertyName);
IConfigItemObject.Item(PropertyName) = returnValue;
-or-
abstract returnValue = IConfigItemObject(PropertyName);
IConfigItemObject(PropertyName) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

PropertyName
Name of the property as defined in the schema for the ConfigType.

Parameters [Visual Basic, C#, C++]

PropertyName
Name of the property as defined in the schema for the ConfigType.

See Also

IConfigItem Interface | IConfigItem Members | System.Configuration Namespace | IConfigItem.Item Overload List


IConfigItem.Selector

Returns the Selector which was used to retrieve this configuration item.

[Visual Basic]
Property Selector As Selector
[C#]
Selector Selector {get; set;}
[C++]
Selector* get_Selector() = 0;void set_Selector(Selector*) = 0;
[JScript]
abstract function get Selector() : Selector;
public abstract function set Selector(Selector);

Remarks

If the configuration item was not read through the ConfigManager the Selector property may return null.

See Also

IConfigItem Interface | IConfigItem Members | System.Configuration Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IConfigItem Methods

The methods of the IConfigItem interface are listed below. For a complete list of IConfigItem interface members, see the IConfigItem Members topic.

Freeze Makes the configuration item read-only.

See Also

IConfigItem Interface | System.Configuration Namespace


IConfigItem.Freeze

Makes the configuration item read-only.

[Visual Basic]
Sub Freeze()
[C#]
void Freeze();
[C++]
void Freeze() = 0;
[JScript]
function Freeze();

Remarks

After Freeze has been called on a configuration item, all set operations on any properties will throw an exception.

See Also

IConfigItem Interface | IConfigItem Members | System.Configuration Namespace


LevelOfService Class

Allows the caller to control the behavior of the configuration system when retrieving configuration information.

Object
LevelOfService

[Visual Basic]
Public Class LevelOfService
[C#]
public class LevelOfService
[C++]
public __gc class LevelOfService
[JScript]
public class LevelOfService

Remarks

[To be supplied.]

Requirements

Namespace: System.Configuration

Assembly: System.Configuration.dll

See Also

LevelOfService Members | System.Configuration Namespace


LevelOfService Members

Public:

Constructor

LevelOfService Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

BypassCache | Not used in the PDC release.
Delete | Not used in the PDC release.
DoNotApplyDefaults | Not used in the PDC release.
DoNotCacheResult | Not used in the PDC release.
Empty | Not used in the PDC release.
NoInheritance | Not used in the PDC release.
NoValidation | Not used in the PDC release.
Read | Indicates that read access is desired.
UseBaseCollection | Forces the configuration system to return BaseConfigItem or BaseConfigCollection instead of strongly typed accessor classes that may be defined for a ConfigType.
Write | Indicates that write access to configuration items or configuration collections is desired.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LevelOfService Class | System.Configuration Namespace


LevelOfService Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public LevelOfService();
[C++]
public: LevelOfService();
[JScript]
public function LevelOfService();

See Also

LevelOfService Class | LevelOfService Members | System.Configuration Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

LevelOfService Fields

The fields of the LevelOfService class are listed below. For a complete list of LevelOfService class members, see the LevelOfService Members topic.

Public:

BypassCache | Not used in the PDC release.
Delete | Not used in the PDC release.
DoNotApplyDefaults | Not used in the PDC release.
DoNotCacheResult | Not used in the PDC release.
Empty | Not used in the PDC release.
NoInheritance | Not used in the PDC release.
NoValidation | Not used in the PDC release.
Read | Indicates that read access is desired.
UseBaseCollection | Forces the configuration system to return BaseConfigItem or BaseConfigCollection instead of strongly typed accessor classes that may be defined for a ConfigType.
Write | Indicates that write access to configuration items or configuration collections is desired.

See Also

LevelOfService Class | System.Configuration Namespace


LevelOfService.BypassCache

Not used in the PDC release.

[Visual Basic]
Public Shared BypassCache As Integer
[C#]
public static int BypassCache;
[C++]
public: static int BypassCache;
[JScript]
public static var BypassCache : int;

See Also

LevelOfService Class | LevelOfService Members | System.Configuration Namespace


LevelOfService.Delete

Not used in the PDC release.

[Visual Basic]
Public Shared Delete As Integer
[C#]
public static int Delete;
[C++]
public: static int Delete;
[JScript]
public static var Delete : int;

See Also

LevelOfService Class | LevelOfService Members | System.Configuration Namespace


LevelOfService.DoNotApplyDefaults

Not used in the PDC release.

[Visual Basic]
Public Shared DoNotApplyDefaults As Integer
[C#]
public static int DoNotApplyDefaults;
[C++]
public: static int DoNotApplyDefaults;
[JScript]
public static var DoNotApplyDefaults : int;

See Also

LevelOfService Class | LevelOfService Members | System.Configuration Namespace


LevelOfService.DoNotCacheResult

Not used in the PDC release.

[Visual Basic]
Public Shared DoNotCacheResult As Integer
[C#]
public static int DoNotCacheResult;
[C++]
public: static int DoNotCacheResult;
[JScript]
public static var DoNotCacheResult : int;

See Also

LevelOfService Class | LevelOfService Members | System.Configuration Namespace


LevelOfService.Empty

Not used in the PDC release.

[Visual Basic]
Public Shared Empty As Integer
[C#]
public static int Empty;
[C++]
public: static int Empty;
[JScript]
public static var Empty : int;

See Also

LevelOfService Class | LevelOfService Members | System.Configuration Namespace


LevelOfService.NoInheritance

Not used in the PDC release.

[Visual Basic]
Public Shared NoInheritance As Integer
[C#]
public static int NoInheritance;
[C++]
public: static int NoInheritance;
[JScript]
public static var NoInheritance : int;

See Also

LevelOfService Class | LevelOfService Members | System.Configuration Namespace


LevelOfService.NoValidation

Not used in the PDC release.

[Visual Basic]
Public Shared NoValidation As Integer
[C#]
public static int NoValidation;
[C++]
public: static int NoValidation;
[JScript]
public static var NoValidation : int;

See Also

LevelOfService Class | LevelOfService Members | System.Configuration Namespace


LevelOfService.Read

Indicates that read access is desired.

[Visual Basic]
Public Shared Read As Integer
[C#]
public static int Read;
[C++]
public: static int Read;
[JScript]
public static var Read : int;

Remarks

This is the default for methods that do not take a level of service parameter.

The ConfigManager will call Freeze on configuration items and collections.

See Also

LevelOfService Class | LevelOfService Members | System.Configuration Namespace


LevelOfService.UseBaseCollection

Forces the configuration system to return BaseConfigItem or BaseConfigCollection instead of strongly typed accessor classes that may be defined for a ConfigType.

[Visual Basic]
Public Shared UseBaseCollection As Integer
[C#]
public static int UseBaseCollection;
[C++]
public: static int UseBaseCollection;
[JScript]
public static var UseBaseCollection : int;

See Also

LevelOfService Class | LevelOfService Members | System.Configuration Namespace


LevelOfService.Write

Indicates that write access to configuration items or configuration collections is desired.

[Visual Basic]
Public Shared Write As Integer
[C#]
public static int Write;
[C++]
public: static int Write;
[JScript]
public static var Write : int;

See Also

LevelOfService Class | LevelOfService Members | System.Configuration Namespace


LocalMachineSelector Class

Indicates the location of the machine configuration file.

Object
Selector
Internal.UrlSelectorBase
FileSelector
LocalMachineSelector

[Visual Basic]
Public Class LocalMachineSelector
   Inherits FileSelector
[C#]
public class LocalMachineSelector : FileSelector
[C++]
public __gc class LocalMachineSelector : public FileSelector
[JScript]
public class LocalMachineSelector extends FileSelector

Remarks

The LocalMachineSelector.Argument method retrieves the file path to the machine configuration file.

Requirements

Namespace: System.Configuration

Assembly: System.Configuration.dll

See Also

LocalMachineSelector Members | System.Configuration Namespace


LocalMachineSelector Members

Public:

Constructor

LocalMachineSelector Constructor Creates a LocalMachineSelector.

Properties

Argument (inherited from UrlSelectorBase) | [To be supplied.]
Prefix | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LocalMachineSelector Class | System.Configuration Namespace


LocalMachineSelector Constructor

Creates a LocalMachineSelector.

[Visual Basic]
Public Sub New()
[C#]
public LocalMachineSelector();
[C++]
public: LocalMachineSelector();
[JScript]
public function LocalMachineSelector();

See Also

LocalMachineSelector Class | LocalMachineSelector Members | System.Configuration Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

LocalMachineSelector Properties

The properties of the LocalMachineSelector class are listed below. For a complete list of LocalMachineSelector class members, see the LocalMachineSelector Members topic.

Public:

Argument (inherited from UrlSelectorBase) | [To be supplied.]
Prefix | [To be supplied.]

See Also

LocalMachineSelector Class | System.Configuration Namespace


LocalMachineSelector.Prefix

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Prefix As String
[C#]
public string Prefix {override get;}
[C++]
public: __property virtual String* get_Prefix();
[JScript]
public function get Prefix() : String;

Property Value

Returns "localmachine" as the prefix for the LocalMachineSelector.

See Also

LocalMachineSelector Class | LocalMachineSelector Members | System.Configuration Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

LocalMachineSelector Methods

The methods of the LocalMachineSelector class are listed below. For a complete list of LocalMachineSelector class members, see the LocalMachineSelector Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LocalMachineSelector Class | System.Configuration Namespace


LocalMachineSelector.ToString

[To be supplied.]

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

Returns "localmachine://" as the string representation of an AppDomainSelector.

See Also

LocalMachineSelector Class | LocalMachineSelector Members | System.Configuration Namespace


NullSelector Class

Used for configuration information that does not require a location. For example, configuration schema information can be retrieved without specifying a configuration file.

Object
Selector
NullSelector

[Visual Basic]
Public Class NullSelector
   Inherits Selector
[C#]
public class NullSelector : Selector
[C++]
public __gc class NullSelector : public Selector
[JScript]
public class NullSelector extends Selector

Remarks

Passing an empty string of null to Get is equivalent to passing a NullSelector.

Requirements

Namespace: System.Configuration

Assembly: System.Configuration.dll

See Also

NullSelector Members | System.Configuration Namespace


NullSelector Members

Public:

Constructor

NullSelector Constructor [To be supplied.]

Properties

Prefix [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NullSelector Class | System.Configuration Namespace


NullSelector Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public NullSelector();
[C++]
public: NullSelector();
[JScript]
public function NullSelector();

See Also

NullSelector Class | NullSelector Members | System.Configuration Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

NullSelector Properties

The properties of the NullSelector class are listed below. For a complete list of NullSelector class members, see the NullSelector Members topic.

Public:

Prefix [To be supplied.]

See Also

NullSelector Class | System.Configuration Namespace


NullSelector.Prefix

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Prefix As String
[C#]
public string Prefix {override get;}
[C++]
public: __property virtual String* get_Prefix();
[JScript]
public function get Prefix() : String;

Property Value

Returns "null".

See Also

NullSelector Class | NullSelector Members | System.Configuration Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

NullSelector Methods

The methods of the NullSelector class are listed below. For a complete list of NullSelector class members, see the NullSelector Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NullSelector Class | System.Configuration Namespace


NullSelector.ToString

[To be supplied.]

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

Returns "null://"

See Also

NullSelector Class | NullSelector Members | System.Configuration Namespace


PutFlags Enumeration

Controls how the Put methods behave when a previous item exists/does not exist in a configuration store.

[Visual Basic]
Public Enum PutFlags
[C#]
public enum PutFlags
[C++]
public enum PutFlags

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
CreateOnly | Ensures that the configuration item will only be written if no item with the same primary key exists in the configuration store.
CreateOrUpdate | Not supported in the PDC release.
UpdateOnly | Ensures that the configuration item will only be written if an item with the same primary key already exists in the configuration store.

Requirements

Namespace: System.Configuration

Assembly: System.Configuration.dll

See Also

System.Configuration Namespace


QueryCell Class

A QueryCell represents one condition in the query. All QueryCells in the ConfigQuery are ANDed together to determine the outcome of the query.

Object
QueryCell

[Visual Basic]
Public Class QueryCell
[C#]
public class QueryCell
[C++]
public __gc class QueryCell
[JScript]
public class QueryCell

Remarks

[To be supplied.]

Requirements

Namespace: System.Configuration

Assembly: System.Configuration.dll

See Also

QueryCell Members | System.Configuration Namespace


QueryCell Members

Public:

Constructor

QueryCell Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Operator | A QueryCellOp indicating how filtering should be performed.
PropertyIndex | The numeric index of the property by which the query is to filter.
Value | The value against which to compare the property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

QueryCell Class | System.Configuration Namespace


QueryCell Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public QueryCell();
[C++]
public: QueryCell();
[JScript]
public function QueryCell();

See Also

QueryCell Class | QueryCell Members | System.Configuration Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

QueryCell Fields

The fields of the QueryCell class are listed below. For a complete list of QueryCell class members, see the QueryCell Members topic.

Public:

Operator | A QueryCellOp indicating how filtering should be performed.
PropertyIndex | The numeric index of the property by which the query is to filter.
Value | The value against which to compare the property.

See Also

QueryCell Class | System.Configuration Namespace


QueryCell.Operator

A QueryCellOp indicating how filtering should be performed.

[Visual Basic]
Public Operator As QueryCellOp
[C#]
public QueryCellOp Operator;
[C++]
public: QueryCellOp Operator;
[JScript]
public var Operator : QueryCellOp;

See Also

QueryCell Class | QueryCell Members | System.Configuration Namespace


QueryCell.PropertyIndex

The numeric index of the property by which the query is to filter.

[Visual Basic]
Public PropertyIndex As Integer
[C#]
public int PropertyIndex;
[C++]
public: int PropertyIndex;
[JScript]
public var PropertyIndex : int;

See Also

QueryCell Class | QueryCell Members | System.Configuration Namespace


QueryCell.Value

The value against which to compare the property.

[Visual Basic]
Public Value As Object
[C#]
public object Value;
[C++]
public: Object* Value;
[JScript]
public var Value : Object;

See Also

QueryCell Class | QueryCell Members | System.Configuration Namespace


QueryCellOp Enumeration

Indicates how filtering should be performed.

[Visual Basic]
Public Enum QueryCellOp
[C#]
public enum QueryCellOp
[C++]
public enum QueryCellOp

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Equal | Compares the property value for equality.
NotEqual | Not supported in the PDC release.

Requirements

Namespace: System.Configuration

Assembly: System.Configuration.dll

See Also

System.Configuration Namespace


Selector Class

Selectors indicates the storage location of configuration information. The configuration system defines several selector classes which all derive from the abstract Selector base class.

Selectors are modeled after URLs. The configuration system itself uses the URL protocol prefix to determine the kind of storage location (file, web server file, query etc.). The individual selector classes determine the semantics of the remainder of the URL.

Object
Selector

[Visual Basic]
MustInherit Public Class Selector
[C#]
public abstract class Selector
[C++]
public __gc __abstract class Selector
[JScript]
public abstract class Selector

Remarks

If multiple configuration types are to be requested for the same selector, your application can reduce parsing overhead by creating the selector object once (using GetSelectorFromString or by directly creating a new selector instance of the appropriate class), and reusing it for calls to the ConfigManager.

Requirements

Namespace: System.Configuration

Assembly: System.Configuration.dll

See Also

Selector Members | System.Configuration Namespace | FileSelector | AppDomainSelector | LocalMachineSelector | HttpSelector


Selector Members

Public:

Constructor

Selector Constructor [To be supplied.]

Properties

Prefix Returns the prefix of the selector string.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Returns a string representation of the selector. The string representation is a URL the form <prefix>://<argument>.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Selector Class | System.Configuration Namespace


Selector Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public Selector();
[C++]
public: Selector();
[JScript]
public function Selector();

See Also

Selector Class | Selector Members | System.Configuration Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Selector Properties

The properties of the Selector class are listed below. For a complete list of Selector class members, see the Selector Members topic.

Public:

Prefix Returns the prefix of the selector string.

See Also

Selector Class | System.Configuration Namespace


Selector.Prefix

Returns the prefix of the selector string.

[Visual Basic]
MustOverride Public ReadOnly Property Prefix As String
[C#]
public string Prefix {abstract get;}
[C++]
public: __property virtual String* get_Prefix() = 0;
[JScript]
public abstract function get Prefix() : String;

See Also

Selector Class | Selector Members | System.Configuration Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Selector Methods

The methods of the Selector class are listed below. For a complete list of Selector class members, see the Selector Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Returns a string representation of the selector. The string representation is a URL the form <prefix>://<argument>.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Selector Class | System.Configuration Namespace


Selector.ToString

Returns a string representation of the selector. The string representation is a URL the form <prefix>://<argument>.

[Visual Basic]
MustOverride Public Function ToString() As String
[C#]
public abstract string ToString();
[C++]
public: virtual String* ToString() = 0;
[JScript]
public abstract function ToString() : String;

See Also

Selector Class | Selector Members | System.Configuration Namespace


System.Configuration.Assemblies

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Configuration.Assemblies Namespace

Structures

Structure | Description
AssemblyHash | Represents a hash of an assembly's contents. Assembly hashes are used throughout the NGWS runtime to detect a change in the contents of an assembly.

Enumerations

Enumeration | Description
AssemblyHashAlgorithm An enumeration of all the hash algorithms used for hashing files and for generating the strong name.

A hash function H is a transformation that takes an input m and returns a fixed-size string, which is called the hash value h (that is, h = H (m)). Hash functions with just this property have a variety of general computational uses, but when employed in cryptography, the hash functions are usually chosen to have some additional properties.

The basic requirements for a cryptographic hash function are:

  • the input can be of any length
  • the output has a fixed length
  • H (x) is relatively easy to compute for any given x
  • H (x) is one-way
  • H (x) is collision-free

The hash value represents concisely the longer message or document from which it was computed; this value is called the message digest. One can think of a message digest as a "digital fingerprint" of the larger document. Examples of well-known hash functions are MD2 and and SHA.
AssemblyVersionCompatibility Defines the different flavors of assembly version compatibility. The AssemblyVersionCompatibility defines the compatibility of an assembly with other versions of the same assembly, indicating if it cannot execute side-by-side with other versions (e.g., due to conflicts over a device driver).

If no compatibility is specified, an assembly is side-by-side compatible in all scopes.

An assembly cannot be more specific with regard to exactly which previous versions it is not side-by-side compatible with. Hence, if the AssemblyVersionCompatibility is specified, it means the assembly is non side-by-side with all know versions. If not specified, it means it is side-by-side with all known versions.
ProcessorID | Defines identification numbers for supported processors.


AssemblyHash Structure

Represents a hash of an assembly's contents. Assembly hashes are used throughout the NGWS runtime to detect a change in the contents of an assembly.

Object
ValueType
AssemblyHash

[Visual Basic]
Public Structure AssemblyHash
   Implements ICloneable
[C#]
public struct AssemblyHash : ICloneable
[C++]
public __value struct AssemblyHash : public ICloneable

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Configuration.Assemblies

Assembly: mscorlib.dll

See Also

AssemblyHash Members | System.Configuration.Assemblies Namespace


AssemblyHash Members

Public:

Constructor

AssemblyHash Constructor Overloaded. Initializes a new AssemblyHash.

Properties

Algorithm Gets and set the hash algorithm. See AssemblyHashAlgorithm.

Methods

Clone | Clones this object.
Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | Returns the hash value.
SetValue | Sets the hash value.
ToString (inherited from ValueType) | Returns the name of the type.

Fields

Empty An empty AssemblyHash object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyHash Structure | System.Configuration.Assemblies Namespace


AssemblyHash Constructor

Initializes a new AssemblyHash.

Overload List

Initializes a new AssemblyHash given a hash value. The hash algorithm defaults to SHA1.

[Visual Basic] Overloads Public Sub New(Byte())
[C#] public AssemblyHash(byte[]);
[C++] public: AssemblyHash(unsigned char*[]);
[JScript] public function AssemblyHash(Byte[]);

Initializes a new AssemblyHash given the hash algorithm and the hash value.

[Visual Basic] Overloads Public Sub New(AssemblyHashAlgorithm, Byte())
[C#] public AssemblyHash(AssemblyHashAlgorithm, byte[]);
[C++] public: AssemblyHash(AssemblyHashAlgorithm, unsigned char[]);
[JScript] public function AssemblyHash(AssemblyHashAlgorithm, Byte[]);

See Also

AssemblyHash Structure | AssemblyHash Members | System.Configuration.Assemblies Namespace


AssemblyHash Constructor (Byte[])

Initializes a new AssemblyHash given a hash value. The hash algorithm defaults to SHA1.

[Visual Basic]
Overloads Public Sub New( _
   ByVal value() As Byte _
)
[C#]
public AssemblyHash(
   byte[] value
);
[C++]
public: AssemblyHash(
   unsigned char* value[]
);
[JScript]
public function AssemblyHash(
   value : Byte[]
);

Parameters

value
The hash value.

See Also

AssemblyHash Structure | AssemblyHash Members | System.Configuration.Assemblies Namespace | AssemblyHash Constructor Overload List


AssemblyHash Constructor (AssemblyHashAlgorithm, Byte[])

Initializes a new AssemblyHash given the hash algorithm and the hash value.

[Visual Basic]
Overloads Public Sub New( _
   ByVal algorithm As AssemblyHashAlgorithm, _
   ByVal value() As Byte _
)
[C#]
public AssemblyHash(
   AssemblyHashAlgorithm algorithm,
   byte[] value
);
[C++]
public: AssemblyHash(
   AssemblyHashAlgorithm algorithm,
   unsigned char* value[]
);
[JScript]
public function AssemblyHash(
   algorithm : AssemblyHashAlgorithm,
   value : Byte[]
);

Parameters

algorithm
The algorithm used to generate the hash. This values for this parameter come from the AssemblyHashAlgorithm enumeration.
value
The hash value.

See Also

AssemblyHash Structure | AssemblyHash Members | System.Configuration.Assemblies Namespace | AssemblyHash Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AssemblyHash Properties

The properties of the AssemblyHash structure are listed below. For a complete list of AssemblyHash structure members, see the AssemblyHash Members topic.

Public:

Algorithm Gets and set the hash algorithm. See AssemblyHashAlgorithm.

See Also

AssemblyHash Structure | System.Configuration.Assemblies Namespace


AssemblyHash.Algorithm

Gets and set the hash algorithm. See AssemblyHashAlgorithm.

[Visual Basic]
Public Property Algorithm As AssemblyHashAlgorithm
[C#]
public AssemblyHashAlgorithm Algorithm {get; set;}
[C++]
public: __property AssemblyHashAlgorithm get_Algorithm();
public: __property void set_Algorithm(AssemblyHashAlgorithm);
[JScript]
public function get Algorithm() : AssemblyHashAlgorithm;
public function set Algorithm(AssemblyHashAlgorithm);

Property Value

An assembly hash algorithm.

See Also

AssemblyHash Structure | AssemblyHash Members | System.Configuration.Assemblies Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AssemblyHash Methods

The methods of the AssemblyHash structure are listed below. For a complete list of AssemblyHash structure members, see the AssemblyHash Members topic.

Public:

Clone | Clones this object.
Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | Returns the hash value.
SetValue | Sets the hash value.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyHash Structure | System.Configuration.Assemblies Namespace


AssemblyHash.Clone

Clones this object.

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

Return Value

An exact copy of this object.

See Also

AssemblyHash Structure | AssemblyHash Members | System.Configuration.Assemblies Namespace


AssemblyHash.GetValue

Returns the hash value.

[Visual Basic]
Public Function GetValue() As Byte ()
[C#]
public byte[] GetValue();
[C++]
public: unsigned char* GetValue() [];
[JScript]
public function GetValue() : Byte[];

Return Value

The hash value.

See Also

AssemblyHash Structure | AssemblyHash Members | System.Configuration.Assemblies Namespace


AssemblyHash.SetValue

Sets the hash value.

[Visual Basic]
Public Sub SetValue( _
   ByVal value() As Byte _
)
[C#]
public void SetValue(
   byte[] value
);
[C++]
public: void SetValue(
   unsigned char* value[]
);
[JScript]
public function SetValue(
   value : Byte[]
);

Parameters

value
The hash value.

See Also

AssemblyHash Structure | AssemblyHash Members | System.Configuration.Assemblies Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AssemblyHash Fields

The fields of the AssemblyHash structure are listed below. For a complete list of AssemblyHash structure members, see the AssemblyHash Members topic.

Public:

Empty An empty AssemblyHash object.

See Also

AssemblyHash Structure | System.Configuration.Assemblies Namespace


AssemblyHash.Empty

An empty AssemblyHash object.

[Visual Basic]
Public Shared ReadOnly Empty As AssemblyHash
[C#]
public static readonly AssemblyHash Empty;
[C++]
public: static readonly AssemblyHash Empty;
[JScript]
public static var Empty : AssemblyHash;

See Also

AssemblyHash Structure | AssemblyHash Members | System.Configuration.Assemblies Namespace


AssemblyHashAlgorithm Enumeration

An enumeration of all the hash algorithms used for hashing files and for generating the strong name.

A hash function H is a transformation that takes an input m and returns a fixed-size string, which is called the hash value h (that is, h = H (m)). Hash functions with just this property have a variety of general computational uses, but when employed in cryptography, the hash functions are usually chosen to have some additional properties.

The basic requirements for a cryptographic hash function are:

  • the input can be of any length
  • the output has a fixed length
  • H (x) is relatively easy to compute for any given x
  • H (x) is one-way
  • H (x) is collision-free

The hash value represents concisely the longer message or document from which it was computed; this value is called the message digest. One can think of a message digest as a "digital fingerprint" of the larger document. Examples of well-known hash functions are MD2 and and SHA.

[Visual Basic]
Public Enum AssemblyHashAlgorithm
[C#]
public enum AssemblyHashAlgorithm
[C++]
public enum AssemblyHashAlgorithm

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
MD5 | The MD5 message-digest algorithm. MD5 was developed by Rivest in 1991. It is basically MD4 with "safety-belts" and while it is slightly slower than MD4, it is more secure. The algorithm consists of four distinct rounds, which has a slightly different design from that of MD4. Message-digest size, as well as padding requirements, remain the same.
None | No hash algorithm.
SHA1 | A revision of the Secure Hash Algorithm that corrects an unpublished flaw in SHA.

Requirements

Namespace: System.Configuration.Assemblies

Assembly: mscorlib.dll

See Also

System.Configuration.Assemblies Namespace


AssemblyVersionCompatibility Enumeration

Defines the different flavors of assembly version compatibility. The AssemblyVersionCompatibility defines the compatibility of an assembly with other versions of the same assembly, indicating if it cannot execute side-by-side with other versions (e.g., due to conflicts over a device driver).

If no compatibility is specified, an assembly is side-by-side compatible in all scopes.

An assembly cannot be more specific with regard to exactly which previous versions it is not side-by-side compatible with. Hence, if the AssemblyVersionCompatibility is specified, it means the assembly is non side-by-side with all know versions. If not specified, it means it is side-by-side with all known versions.

[Visual Basic]
Public Enum AssemblyVersionCompatibility
[C#]
public enum AssemblyVersionCompatibility
[C++]
public enum AssemblyVersionCompatibility

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
SameDomain | The assembly cannot execute with other versions if they executing in the same application domain.
SameMachine | The assembly cannot execute with other versions if they are executing in the same process.
SameProcess | The assembly cannot execute with other versions if they are executing in the same process.

Requirements

Namespace: System.Configuration.Assemblies

Assembly: mscorlib.dll

See Also

System.Configuration.Assemblies Namespace


ProcessorID Enumeration

Defines identification numbers for supported processors.

[Visual Basic]
Public Enum ProcessorID
[C#]
public enum ProcessorID
[C++]
public enum ProcessorID

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
ALPHA_21064 | Alpha 21064 processor.
ARM720 | ARM 720 processor.
ARM820 | ARM 820 processor.
ARM920 | ARM 920 processor.
ARM_7TDMI | ARM 7TDMI processor.
HITACHI_SH3 | Hitachi SH3 processor.
HITACHI_SH3E | Hitachi SH3E processor.
HITACHI_SH4 | Hitachi SH4 processor.
INTEL_386 | Intel 386 or later and compatible processor.
INTEL_486 | Intel 486 or later and compatible processor.
INTEL_PENTIUM | Intel Pentium or later and compatible processor.
MIPS_R4000 | MIPS R4000 Little-Endian processor.
MOTOROLA_821 | Motoroloa 821 processor.
PPC_601 | PPC 601 processor.
PPC_603 | PPC 603 processor.
PPC_604 | PPC 604 processor.
PPC_620 | PPC 620 processor.
SHx_SH3 | SHX SH3 Little-Endian processor.
SHx_SH4 | SHX SH4 Little-Endian processor.
STRONGARM | STRONGARM Little-Endian processor.

Requirements

Namespace: System.Configuration.Assemblies

Assembly: mscorlib.dll

See Also

System.Configuration.Assemblies Namespace


System.Configuration.Core

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Configuration.Core Namespace

Classes

Class | Description
BindingPolicy | [To be supplied.]


BindingPolicy Class

[To be supplied.]

Object
BaseConfigItem
BindingPolicy

[Visual Basic]
Public Class BindingPolicy
   Inherits BaseConfigItem
[C#]
public class BindingPolicy : BaseConfigItem
[C++]
public __gc class BindingPolicy : public BaseConfigItem
[JScript]
public class BindingPolicy extends BaseConfigItem

Remarks

[To be supplied.]

Requirements

Namespace: System.Configuration.Core

Assembly: System.Configuration.Objects.dll

See Also

BindingPolicy Members | System.Configuration.Core Namespace


BindingPolicy Members

Public:

Constructor

BindingPolicy Constructor [To be supplied.]

Properties

Collection (inherited from BaseConfigItem) | [To be supplied.]
ConfigType (inherited from BaseConfigItem) | [To be supplied.]
Count (inherited from BaseConfigItem) | [To be supplied.]
IsFrozen (inherited from BaseConfigItem) | [To be supplied.]
IsReadOnly (inherited from BaseConfigItem) | [To be supplied.]
IsSynchronized (inherited from BaseConfigItem) | [To be supplied.]
Item (inherited from BaseConfigItem) | Overloaded. [To be supplied.] In C#, this member is the indexer for the BindingPolicy class.
Name | [To be supplied.]

See Also

BindingPolicy Class | System.Configuration.Core Namespace


BindingPolicy Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public BindingPolicy();
[C++]
public: BindingPolicy();
[JScript]
public function BindingPolicy();

See Also

BindingPolicy Class | BindingPolicy Members | System.Configuration.Core Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

BindingPolicy Properties

The properties of the BindingPolicy class are listed below. For a complete list of BindingPolicy class members, see the BindingPolicy Members topic.

Public:

Collection (inherited from BaseConfigItem) | [To be supplied.]
ConfigType (inherited from BaseConfigItem) | [To be supplied.]
Count (inherited from BaseConfigItem) | [To be supplied.]
IsFrozen (inherited from BaseConfigItem) | [To be supplied.]
IsReadOnly (inherited from BaseConfigItem) | [To be supplied.]
IsSynchronized (inherited from BaseConfigItem) | [To be supplied.]
Item (inherited from BaseConfigItem) | Overloaded. [To be supplied.] In C#, this member is the indexer for the BindingPolicy class.
Name | [To be supplied.]

See Also

BindingPolicy Class | System.Configuration.Core Namespace


BindingPolicy.Name

[To be supplied.]

[C#]
public string Name {get; set;}
[C++]
public: __property String* get_Name();
public: __property void set_Name(

See Also

BindingPolicy Class | BindingPolicy Members | System.Configuration.Core Namespace


System.Configuration.Install

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Configuration.Install Namespace

Classes

Class | Description
AssemblyInstaller | Loads an assembly, finds all installers in it, and runs them.
ComponentInstaller | [To be supplied.]
InstallContext | Contains information about the current installation.
Installer | Provides a basic framework for doing installations.
InstallerCollection | Contains a collection of installers to be run during an installation.
InstallEventArgs | Provides data for the OnBeforeInstall, OnAfterInstall, OnBeforeCommit, OnAfterCommit, OnBeforeRollback, OnAfterRollback, OnBeforeUninstall, and OnAfterUninstall events.
InstallException | [To be supplied.]
TransactedInstaller | A transacted install will either completely succeed or fail and leave the machine in its initial state. To run installers in a transaction, add them to the Installers collection of this class.
WfcInstallContext | Provides context information for installations invoked through installutil.exe.

Delegates

Delegate | Description
InstallEventHandler | Represents the method that will handle the OnBeforeInstall event, or the OnAfterInstall event, or the OnBeforeCommit event, or the OnAfterCommit event, or the OnBeforeRollback event, or the OnAfterRollback event, or the OnBeforeUninstall event, or the OnAfterUninstall event of the Installer.

Enumerations

Enumeration | Description
UninstallAction | An enum of what an installer can do at uninstall time. It can either remove the resource it created, restore the resource to its state before Install, or do nothing (leaving the resource as installed).


AssemblyInstaller Class

Loads an assembly, finds all installers in it, and runs them.

Object
Component
Installer
AssemblyInstaller

[Visual Basic]
Public Class AssemblyInstaller
   Inherits Installer
[C#]
public class AssemblyInstaller : Installer
[C++]
public __gc class AssemblyInstaller : public Installer
[JScript]
public class AssemblyInstaller extends Installer

Remarks

[To be supplied.]

Requirements

Namespace: System.Configuration.Install

Assembly: System.Configuration.Install.dll

See Also

AssemblyInstaller Members | System.Configuration.Install Namespace


AssemblyInstaller Members

Public:

Constructor

AssemblyInstaller Constructor Overloaded. [To be supplied.]

Properties

CommandLine | The command line to use when creating a new context for the assembly's install.
Context (inherited from Installer) | Gets or sets information about the current installation.
HelpText | [To be supplied.]
Installers (inherited from Installer) | Gets the collection of Installer objects contained in this Installer instance.
Parent (inherited from Installer) | Gets or sets the Installer whose InstallerCollection contains this Installer instance.
Path | The path to the assembly to install
Site (inherited from Component) | Gets or sets the site of the Component.
UseNewContext | If true, creates a new InstallContext object for the assembly's install.

Methods

CheckIfInstallable | Finds the installers in the specified assembly, creates a new instance of AssemblyInstaller, and adds the installers to its installer collection.
Commit | [To be supplied.]
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Install | [To be supplied.]
Rollback | [To be supplied.]
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
Uninstall | [To be supplied.]

Events

AfterCommit (inherited from Installer) | Occurs after the installations handled by the installers in the InstallerCollection of this instance are committed.
AfterInstall (inherited from Installer) | Occurs after the Install methods of all the installers in the InstallerCollection of this instance have run.
AfterRollback (inherited from Installer) | Occurs after the installations handled by the installers in the InstallerCollection of this instance are rolled back.
AfterUninstall (inherited from Installer) | Occurs after the installations handled by the installers in the InstallerCollection of this instance are uninstalled.
BeforeCommit (inherited from Installer) | Occurs before the installations handled by the installers in the InstallerCollection of this instance are committed.
BeforeInstall (inherited from Installer) | Occurs before the installers in the InstallerCollection of this instance are run.
BeforeRollback (inherited from Installer) | Occurs before the installations handled by the installers in the InstallerCollection of this instance are rolled back.
BeforeUninstall (inherited from Installer) | Occurs before the installations handled by the installers in the InstallerCollection of this instance are uninstalled.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCommit (inherited from Installer) | Raises the OnAfterCommit event.
OnAfterInstall (inherited from Installer) | Raises the OnAfterInstall event.
OnAfterRollback (inherited from Installer) | Raises the OnAfterRollback event.
OnAfterUninstall (inherited from Installer) | Raises the OnAfterUninstall event.
OnBeforeCommit (inherited from Installer) | Raises the OnBeforeCommit event.
OnBeforeInstall (inherited from Installer) | Raises the OnBeforeInstall event.
OnBeforeRollback (inherited from Installer) | Raises the OnBeforeRollback event.
OnBeforeUninstall (inherited from Installer) | Raises the OnBeforeUninstall event.

Event Hookup:

Methods

AddOnAfterCommit (inherited from Installer) | [To be supplied.]
AddOnAfterInstall (inherited from Installer) | [To be supplied.]
AddOnAfterRollback (inherited from Installer) | [To be supplied.]
AddOnAfterUninstall (inherited from Installer) | [To be supplied.]
AddOnBeforeCommit (inherited from Installer) | [To be supplied.]
AddOnBeforeInstall (inherited from Installer) | [To be supplied.]
AddOnBeforeRollback (inherited from Installer) | [To be supplied.]
AddOnBeforeUninstall (inherited from Installer) | [To be supplied.]
RemoveOnAfterCommit (inherited from Installer) | [To be supplied.]
RemoveOnAfterInstall (inherited from Installer) | [To be supplied.]
RemoveOnAfterRollback (inherited from Installer) | [To be supplied.]
RemoveOnAfterUninstall (inherited from Installer) | [To be supplied.]
RemoveOnBeforeCommit (inherited from Installer) | [To be supplied.]
RemoveOnBeforeInstall (inherited from Installer) | [To be supplied.]
RemoveOnBeforeRollback (inherited from Installer) | [To be supplied.]
RemoveOnBeforeUninstall (inherited from Installer) | [To be supplied.]

See Also

AssemblyInstaller Class | System.Configuration.Install Namespace


AssemblyInstaller Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public AssemblyInstaller();
[C++] public: AssemblyInstaller();
[JScript] public function AssemblyInstaller();

Creates a new AssemblyInstaller for the given assembly and passes the given command line arguments to its Context object.

[Visual Basic] Overloads Public Sub New(String, String())
[C#] public AssemblyInstaller(String, String[]);
[C++] public: AssemblyInstaller(String*, String*[]);
[JScript] public function AssemblyInstaller(String, String[]);

See Also

AssemblyInstaller Class | AssemblyInstaller Members | System.Configuration.Install Namespace


AssemblyInstaller Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public AssemblyInstaller();
[C++]
public: AssemblyInstaller();
[JScript]
public function AssemblyInstaller();

See Also

AssemblyInstaller Class | AssemblyInstaller Members | System.Configuration.Install Namespace | AssemblyInstaller Constructor Overload List


AssemblyInstaller Constructor (String, String[])

Creates a new AssemblyInstaller for the given assembly and passes the given command line arguments to its Context object.

[Visual Basic]
Overloads Public Sub New( _
   ByVal filename As String, _
   ByVal commandLine() As String _
)
[C#]
public AssemblyInstaller(
   string filename,
   string[] commandLine
);
[C++]
public: AssemblyInstaller(
   String* filename,
   String* commandLine[]
);
[JScript]
public function AssemblyInstaller(
   filename : String,
   commandLine : String[]
);

Parameters

filename
the filename of the assembly to install
commandLine
the command line to use when creating a new InstallContext object for the assembly's install.

See Also

AssemblyInstaller Class | AssemblyInstaller Members | System.Configuration.Install Namespace | AssemblyInstaller Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AssemblyInstaller Properties

The properties of the AssemblyInstaller class are listed below. For a complete list of AssemblyInstaller class members, see the AssemblyInstaller Members topic.

Public:

CommandLine | The command line to use when creating a new context for the assembly's install.
Context (inherited from Installer) | Gets or sets information about the current installation.
HelpText | [To be supplied.]
Installers (inherited from Installer) | Gets the collection of Installer objects contained in this Installer instance.
Parent (inherited from Installer) | Gets or sets the Installer whose InstallerCollection contains this Installer instance.
Path | The path to the assembly to install
Site (inherited from Component) | Gets or sets the site of the Component.
UseNewContext | If true, creates a new InstallContext object for the assembly's install.

See Also

AssemblyInstaller Class | System.Configuration.Install Namespace


AssemblyInstaller.CommandLine

The command line to use when creating a new context for the assembly's install.

[Visual Basic]
Overridable Public Property CommandLine As String ()
[C#]
public string[] CommandLine {virtual get; virtual set;}
[C++]
public: __property virtual String* get_CommandLine();
public: __property virtual void set_CommandLine(String*[]);
[JScript]
public function get CommandLine() : String[];
public function set CommandLine(String[]);

See Also

AssemblyInstaller Class | AssemblyInstaller Members | System.Configuration.Install Namespace


AssemblyInstaller.HelpText

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property HelpText As String
[C#]
public string HelpText {override get;}
[C++]
public: __property virtual String* get_HelpText();
[JScript]
public function get HelpText() : String;

See Also

AssemblyInstaller Class | AssemblyInstaller Members | System.Configuration.Install Namespace


AssemblyInstaller.Path

The path to the assembly to install

[Visual Basic]
Overridable Public Property Path As String
[C#]
public string Path {virtual get; virtual set;}
[C++]
public: __property virtual String* get_Path();
public: __property virtual void set_Path(String*);
[JScript]
public function get Path() : String;
public function set Path(String);

See Also

AssemblyInstaller Class | AssemblyInstaller Members | System.Configuration.Install Namespace


AssemblyInstaller.UseNewContext

If true, creates a new InstallContext object for the assembly's install.

[Visual Basic]
Overridable Public Property UseNewContext As Boolean
[C#]
public bool UseNewContext {virtual get; virtual set;}
[C++]
public: __property virtual bool get_UseNewContext();
public: __property virtual void set_UseNewContext(bool);
[JScript]
public function get UseNewContext() : Boolean;
public function set UseNewContext(Boolean);

See Also

AssemblyInstaller Class | AssemblyInstaller Members | System.Configuration.Install Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AssemblyInstaller Methods

The methods of the AssemblyInstaller class are listed below. For a complete list of AssemblyInstaller class members, see the AssemblyInstaller Members topic.

Public:

CheckIfInstallable | Finds the installers in the specified assembly, creates a new instance of AssemblyInstaller, and adds the installers to its installer collection.
Commit | [To be supplied.]
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Install | [To be supplied.]
Rollback | [To be supplied.]
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
Uninstall | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCommit (inherited from Installer) | Raises the OnAfterCommit event.
OnAfterInstall (inherited from Installer) | Raises the OnAfterInstall event.
OnAfterRollback (inherited from Installer) | Raises the OnAfterRollback event.
OnAfterUninstall (inherited from Installer) | Raises the OnAfterUninstall event.
OnBeforeCommit (inherited from Installer) | Raises the OnBeforeCommit event.
OnBeforeInstall (inherited from Installer) | Raises the OnBeforeInstall event.
OnBeforeRollback (inherited from Installer) | Raises the OnBeforeRollback event.
OnBeforeUninstall (inherited from Installer) | Raises the OnBeforeUninstall event.

Event Hookup:

AddOnAfterCommit (inherited from Installer) | [To be supplied.]
AddOnAfterInstall (inherited from Installer) | [To be supplied.]
AddOnAfterRollback (inherited from Installer) | [To be supplied.]
AddOnAfterUninstall (inherited from Installer) | [To be supplied.]
AddOnBeforeCommit (inherited from Installer) | [To be supplied.]
AddOnBeforeInstall (inherited from Installer) | [To be supplied.]
AddOnBeforeRollback (inherited from Installer) | [To be supplied.]
AddOnBeforeUninstall (inherited from Installer) | [To be supplied.]
RemoveOnAfterCommit (inherited from Installer) | [To be supplied.]
RemoveOnAfterInstall (inherited from Installer) | [To be supplied.]
RemoveOnAfterRollback (inherited from Installer) | [To be supplied.]
RemoveOnAfterUninstall (inherited from Installer) | [To be supplied.]
RemoveOnBeforeCommit (inherited from Installer) | [To be supplied.]
RemoveOnBeforeInstall (inherited from Installer) | [To be supplied.]
RemoveOnBeforeRollback (inherited from Installer) | [To be supplied.]
RemoveOnBeforeUninstall (inherited from Installer) | [To be supplied.]

See Also

AssemblyInstaller Class | System.Configuration.Install Namespace


AssemblyInstaller.CheckIfInstallable

Finds the installers in the specified assembly, creates a new instance of AssemblyInstaller, and adds the installers to its installer collection.

[Visual Basic]
Public Shared Sub CheckIfInstallable( _
   ByVal assemblyName As String _
)
[C#]
public static void CheckIfInstallable(
   string assemblyName
);
[C++]
public: static void CheckIfInstallable(
   String* assemblyName
);
[JScript]
public static function CheckIfInstallable(
   assemblyName : String
);

Parameters

assemblyName
[To be supplied.]

Exceptions

Exception Type | Condition
Exception | This assembly can not be installed.

Remarks

This method determines whether the specified assembly can be installed. An exception will be thrown if it can not be installed. Checks to make sure the given assembly can be installed. If the file does not meet the following criteria, and exception will be thrown. 1. The file exists 2. The file is a NGWS runtime assembly 3. The public types can be read from the file 4. There is at least one public, non-abstract class extending Installer with the RunInstallerAttribute.Yes attrtibute. 5. All such installers can be instantiated Note that if the assembly is valid but contains no installers, an exception will be thrown. This is different from the behavior at install time, when it is not an error to install an empty assembly.

See Also

AssemblyInstaller Class | AssemblyInstaller Members | System.Configuration.Install Namespace


AssemblyInstaller.Commit

[To be supplied.]

[Visual Basic]
Overrides Public Sub Commit( _
   ByVal savedState As IDictionary _
)
[C#]
public override void Commit(
   IDictionary savedState
);
[C++]
public: override void Commit(
   IDictionary* savedState
);
[JScript]
public override function Commit(
   savedState : IDictionary
);

Parameters

savedState
[To be supplied.]

See Also

AssemblyInstaller Class | AssemblyInstaller Members | System.Configuration.Install Namespace


AssemblyInstaller.Install

[To be supplied.]

[Visual Basic]
Overrides Public Sub Install( _
   ByVal savedState As IDictionary _
)
[C#]
public override void Install(
   IDictionary savedState
);
[C++]
public: override void Install(
   IDictionary* savedState
);
[JScript]
public override function Install(
   savedState : IDictionary
);

Parameters

savedState
[To be supplied.]

See Also

AssemblyInstaller Class | AssemblyInstaller Members | System.Configuration.Install Namespace


AssemblyInstaller.Rollback

[To be supplied.]

[Visual Basic]
Overrides Public Sub Rollback( _
   ByVal savedState As IDictionary _
)
[C#]
public override void Rollback(
   IDictionary savedState
);
[C++]
public: override void Rollback(
   IDictionary* savedState
);
[JScript]
public override function Rollback(
   savedState : IDictionary
);

Parameters

savedState
[To be supplied.]

See Also

AssemblyInstaller Class | AssemblyInstaller Members | System.Configuration.Install Namespace


AssemblyInstaller.Uninstall

[To be supplied.]

[Visual Basic]
Overrides Public Sub Uninstall( _
   ByVal savedState As IDictionary _
)
[C#]
public override void Uninstall(
   IDictionary savedState
);
[C++]
public: override void Uninstall(
   IDictionary* savedState
);
[JScript]
public override function Uninstall(
   savedState : IDictionary
);

Parameters

savedState
[To be supplied.]

See Also

AssemblyInstaller Class | AssemblyInstaller Members | System.Configuration.Install Namespace


ComponentInstaller Class

[To be supplied.]

Object
Component
Installer
ComponentInstaller

[Visual Basic]
MustInherit Public Class ComponentInstaller
   Inherits Installer
[C#]
public abstract class ComponentInstaller : Installer
[C++]
public __gc __abstract class ComponentInstaller : public Installer
[JScript]
public abstract class ComponentInstaller extends Installer

Remarks

[To be supplied.]

Requirements

Namespace: System.Configuration.Install

Assembly: System.Configuration.Install.dll

See Also

ComponentInstaller Members | System.Configuration.Install Namespace


ComponentInstaller Members

Public:

Constructor

ComponentInstaller Constructor [To be supplied.]

Properties

Context (inherited from Installer) | Gets or sets information about the current installation.
HelpText (inherited from Installer) | Gets the help text for all of the Installer objects contained in the Installers collection of this installer instance.
Installers (inherited from Installer) | Gets the collection of Installer objects contained in this Installer instance.
Parent (inherited from Installer) | Gets or sets the Installer whose InstallerCollection contains this Installer instance.
Site (inherited from Component) | Gets or sets the site of the Component.

Methods

Commit (inherited from Installer) | Completes the install transaction.
CopyFromComponent | Copies properties from the given component to this installer. This method will be called at design-time when the user clicks 'Add Installer' on a component that has specified this class as its installer. The installer should take all information it can from the live component and store it to be used at install time.
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Install (inherited from Installer) | Performs the installation.
Rollback (inherited from Installer) | Restores the machine to the state it was in before the Install method was called.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
Uninstall (inherited from Installer) | Removes an installation.

Events

AfterCommit (inherited from Installer) | Occurs after the installations handled by the installers in the InstallerCollection of this instance are committed.
AfterInstall (inherited from Installer) | Occurs after the Install methods of all the installers in the InstallerCollection of this instance have run.
AfterRollback (inherited from Installer) | Occurs after the installations handled by the installers in the InstallerCollection of this instance are rolled back.
AfterUninstall (inherited from Installer) | Occurs after the installations handled by the installers in the InstallerCollection of this instance are uninstalled.
BeforeCommit (inherited from Installer) | Occurs before the installations handled by the installers in the InstallerCollection of this instance are committed.
BeforeInstall (inherited from Installer) | Occurs before the installers in the InstallerCollection of this instance are run.
BeforeRollback (inherited from Installer) | Occurs before the installations handled by the installers in the InstallerCollection of this instance are rolled back.
BeforeUninstall (inherited from Installer) | Occurs before the installations handled by the installers in the InstallerCollection of this instance are uninstalled.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCommit (inherited from Installer) | Raises the OnAfterCommit event.
OnAfterInstall (inherited from Installer) | Raises the OnAfterInstall event.
OnAfterRollback (inherited from Installer) | Raises the OnAfterRollback event.
OnAfterUninstall (inherited from Installer) | Raises the OnAfterUninstall event.
OnBeforeCommit (inherited from Installer) | Raises the OnBeforeCommit event.
OnBeforeInstall (inherited from Installer) | Raises the OnBeforeInstall event.
OnBeforeRollback (inherited from Installer) | Raises the OnBeforeRollback event.
OnBeforeUninstall (inherited from Installer) | Raises the OnBeforeUninstall event.

Event Hookup:

Methods

AddOnAfterCommit (inherited from Installer) | [To be supplied.]
AddOnAfterInstall (inherited from Installer) | [To be supplied.]
AddOnAfterRollback (inherited from Installer) | [To be supplied.]
AddOnAfterUninstall (inherited from Installer) | [To be supplied.]
AddOnBeforeCommit (inherited from Installer) | [To be supplied.]
AddOnBeforeInstall (inherited from Installer) | [To be supplied.]
AddOnBeforeRollback (inherited from Installer) | [To be supplied.]
AddOnBeforeUninstall (inherited from Installer) | [To be supplied.]
RemoveOnAfterCommit (inherited from Installer) | [To be supplied.]
RemoveOnAfterInstall (inherited from Installer) | [To be supplied.]
RemoveOnAfterRollback (inherited from Installer) | [To be supplied.]
RemoveOnAfterUninstall (inherited from Installer) | [To be supplied.]
RemoveOnBeforeCommit (inherited from Installer) | [To be supplied.]
RemoveOnBeforeInstall (inherited from Installer) | [To be supplied.]
RemoveOnBeforeRollback (inherited from Installer) | [To be supplied.]
RemoveOnBeforeUninstall (inherited from Installer) | [To be supplied.]

See Also

ComponentInstaller Class | System.Configuration.Install Namespace


ComponentInstaller Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ComponentInstaller();
[C++]
public: ComponentInstaller();
[JScript]
public function ComponentInstaller();

See Also

ComponentInstaller Class | ComponentInstaller Members | System.Configuration.Install Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ComponentInstaller Methods

The methods of the ComponentInstaller class are listed below. For a complete list of ComponentInstaller class members, see the ComponentInstaller Members topic.

Public:

Commit (inherited from Installer) | Completes the install transaction.
CopyFromComponent | Copies properties from the given component to this installer. This method will be called at design-time when the user clicks 'Add Installer' on a component that has specified this class as its installer. The installer should take all information it can from the live component and store it to be used at install time.
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Install (inherited from Installer) | Performs the installation.
Rollback (inherited from Installer) | Restores the machine to the state it was in before the Install method was called.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
Uninstall (inherited from Installer) | Removes an installation.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCommit (inherited from Installer) | Raises the OnAfterCommit event.
OnAfterInstall (inherited from Installer) | Raises the OnAfterInstall event.
OnAfterRollback (inherited from Installer) | Raises the OnAfterRollback event.
OnAfterUninstall (inherited from Installer) | Raises the OnAfterUninstall event.
OnBeforeCommit (inherited from Installer) | Raises the OnBeforeCommit event.
OnBeforeInstall (inherited from Installer) | Raises the OnBeforeInstall event.
OnBeforeRollback (inherited from Installer) | Raises the OnBeforeRollback event.
OnBeforeUninstall (inherited from Installer) | Raises the OnBeforeUninstall event.

Event Hookup:

AddOnAfterCommit (inherited from Installer) | [To be supplied.]
AddOnAfterInstall (inherited from Installer) | [To be supplied.]
AddOnAfterRollback (inherited from Installer) | [To be supplied.]
AddOnAfterUninstall (inherited from Installer) | [To be supplied.]
AddOnBeforeCommit (inherited from Installer) | [To be supplied.]
AddOnBeforeInstall (inherited from Installer) | [To be supplied.]
AddOnBeforeRollback (inherited from Installer) | [To be supplied.]
AddOnBeforeUninstall (inherited from Installer) | [To be supplied.]
RemoveOnAfterCommit (inherited from Installer) | [To be supplied.]
RemoveOnAfterInstall (inherited from Installer) | [To be supplied.]
RemoveOnAfterRollback (inherited from Installer) | [To be supplied.]
RemoveOnAfterUninstall (inherited from Installer) | [To be supplied.]
RemoveOnBeforeCommit (inherited from Installer) | [To be supplied.]
RemoveOnBeforeInstall (inherited from Installer) | [To be supplied.]
RemoveOnBeforeRollback (inherited from Installer) | [To be supplied.]
RemoveOnBeforeUninstall (inherited from Installer) | [To be supplied.]

See Also

ComponentInstaller Class | System.Configuration.Install Namespace


ComponentInstaller.CopyFromComponent

Copies properties from the given component to this installer. This method will be called at design-time when the user clicks 'Add Installer' on a component that has specified this class as its installer. The installer should take all information it can from the live component and store it to be used at install time.

[Visual Basic]
MustOverride Public Sub CopyFromComponent( _
   ByVal component As IComponent _
)
[C#]
public abstract void CopyFromComponent(
   IComponent component
);
[C++]
public: virtual void CopyFromComponent(
   IComponent* component
) = 0;
[JScript]
public abstract function CopyFromComponent(
   component : IComponent
);

Parameters

component
[To be supplied.]

See Also

ComponentInstaller Class | ComponentInstaller Members | System.Configuration.Install Namespace


InstallContext Class

Contains information about the current installation.

Object
InstallContext

[Visual Basic]
Public Class InstallContext
[C#]
public class InstallContext
[C++]
public __gc class InstallContext
[JScript]
public class InstallContext

Remarks

InstallContext contains information used by classes that do installations. This includes Installer and classes that inherit from it, such as AssemblyInstaller and TransactedInstaller.

Typically, an InstallContext is created by an installation executable that is run to install an assembly or assemblies, or a project. The installation program invokes the InstallContext constructor and passes in the default log file path, logFilePath, and the command line parameters, commandLine.

The installation program sets the InstallContext into the Context property of an Installer prior to calling its Install, Commit, Rollback, or Uninstall methods. An Installer that contains an InstallerCollection sets the Context property of each contained installer before calling these methods.

The Parameters property is a parsed version of the command line that is entered when the installation executable is run. It contains information such as the path to a log file, whether to display log information on the console, and whether to show a user interface during the installation. Call IsParameterTrue to find out whether a command line parameter is true.

Call the LogMessage method to write status messages to the installation log file and to the console.

Requirements

Namespace: System.Configuration.Install

Assembly: System.Configuration.Install.dll

See Also

InstallContext Members | System.Configuration.Install Namespace | Installer | TransactedInstaller | AssemblyInstaller


InstallContext Members

Public:

Constructor

InstallContext Constructor Overloaded. Initializes a new instance of the InstallContext class.

Properties

Host | Gets an object giving you access to the Microsoft Installation (MSI) setup object model.
Parameters | Gets the command-line arguments that were entered when the installation executable was run.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsParameterTrue | Determines whether the specified command line parameter is true.
LogMessage | Writes the message to the log file for the installation and to the console.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize | Closes the log file, if one was created for the installation.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseCommandLine | Parses the command line arguments into a StringDictionary.

See Also

InstallContext Class | System.Configuration.Install Namespace


InstallContext Constructor

Initializes a new instance of the InstallContext class.

Overload List

Initializes a new instance of the InstallContext class; a log file for the installation is not created.

[Visual Basic] Overloads Public Sub New()
[C#] public InstallContext();
[C++] public: InstallContext();
[JScript] public function InstallContext();

Initializes a new instance of the InstallContext class and creates a log file for the installation.

[Visual Basic] Overloads Public Sub New(String, String())
[C#] public InstallContext(String, String[]);
[C++] public: InstallContext(String*, String*[]);
[JScript] public function InstallContext(String, String[]);

See Also

InstallContext Class | InstallContext Members | System.Configuration.Install Namespace


InstallContext Constructor ()

Initializes a new instance of the InstallContext class; a log file for the installation is not created.

[Visual Basic]
Overloads Public Sub New()
[C#]
public InstallContext();
[C++]
public: InstallContext();
[JScript]
public function InstallContext();

See Also

InstallContext Class | InstallContext Members | System.Configuration.Install Namespace | InstallContext Constructor Overload List


InstallContext Constructor (String, String[])

Initializes a new instance of the InstallContext class and creates a log file for the installation.

[Visual Basic]
Overloads Public Sub New( _
   ByVal logFilePath As String, _
   ByVal commandLine() As String _
)
[C#]
public InstallContext(
   string logFilePath,
   string[] commandLine
);
[C++]
public: InstallContext(
   String* logFilePath,
   String* commandLine[]
);
[JScript]
public function InstallContext(
   logFilePath : String,
   commandLine : String[]
);

Parameters

logFilePath
The path to the log file for this installation, or a null reference (in Visual Basic Nothing).
commandLine
The command line parameters entered when the installation program was run, or a null reference (Nothing) if none were entered.

Remarks

This constructor creates a log file over the specified path, and parses the array of command line parameters into the Parameters property. If a log file path is specified in the command line parameters, "/logfile= somepath", this path is used to create the file. If the logfile argument is not specified in the command line, the default path for the installation, as specified by the logFilePath parameter, is used. If a command line argument of "/logfile= " is passed, no logfile is created; do this to suppress creation of a log file.

Notes to Callers: Pass your default log file path in the logFilePath parameter when you call this constructor. This is the path over which the log file will be created, unless the/logfile command line argument is usedwhen the installation executable is run.

See Also

InstallContext Class | InstallContext Members | System.Configuration.Install Namespace | InstallContext Constructor Overload List | Parameters | LogMessage


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

InstallContext Properties

The properties of the InstallContext class are listed below. For a complete list of InstallContext class members, see the InstallContext Members topic.

Public:

Host | Gets an object giving you access to the Microsoft Installation (MSI) setup object model.
Parameters | Gets the command-line arguments that were entered when the installation executable was run.

See Also

InstallContext Class | System.Configuration.Install Namespace


InstallContext.Host

Gets an object giving you access to the Microsoft Installation (MSI) setup object model.

[Visual Basic]
Overridable Public ReadOnly Property Host As Object
[C#]
public object Host {virtual get;}
[C++]
public: __property virtual Object* get_Host();
[JScript]
public function get Host() : Object;

Property Value

An object giving you access to the MSI setup object model, or a null reference (in Visual Basic Nothing).

Remarks

An object giving you access to the MSI setup object model. This property is always a null reference (Nothing).

See Also

InstallContext Class | InstallContext Members | System.Configuration.Install Namespace


InstallContext.Parameters

Gets the command-line arguments that were entered when the installation executable was run.

[Visual Basic]
Overridable Public ReadOnly Property Parameters As StringDictionary
[C#]
public StringDictionary Parameters {virtual get;}
[C++]
public: __property virtual StringDictionary* get_Parameters();
[JScript]
public function get Parameters() : StringDictionary;

Property Value

A StringDictionary representing the command-line arguments that were entered when the installation executable was run.

Remarks

When a new InstallContext is created, the command-line arguments are parsed into the StringDictionary. Both the key and the value of the arguments are of type string. StringDictionary is not case sensitive.

See Also

InstallContext Class | InstallContext Members | System.Configuration.Install Namespace | StringDictionary


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

InstallContext Methods

The methods of the InstallContext class are listed below. For a complete list of InstallContext class members, see the InstallContext Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsParameterTrue | Determines whether the specified command line parameter is true.
LogMessage | Writes the message to the log file for the installation and to the console.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize | Closes the log file, if one was created for the installation.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseCommandLine | Parses the command line arguments into a StringDictionary.

See Also

InstallContext Class | System.Configuration.Install Namespace


InstallContext.Finalize

Closes the log file, if one was created for the installation.

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

InstallContext Class | InstallContext Members | System.Configuration.Install Namespace


InstallContext.IsParameterTrue

Determines whether the specified command line parameter is true.

[Visual Basic]
Overridable Public Function IsParameterTrue( _
   ByVal paramName As String _
) As Boolean
[C#]
public virtual bool IsParameterTrue(
   string paramName
);
[C++]
public: virtual bool IsParameterTrue(
   String* paramName
);
[JScript]
public function IsParameterTrue(
   paramName : String
) : Boolean;

Parameters

paramName
The name of the command line parameter to check for.

Return Value

true if the given parameter is set to "yes", "true", "1", or an empty string (""); otherwise, false.

Remarks

This method accesses the Parameters property, which contains a parsed version of the command line arguments, to determine whether the given parameter is true.

See Also

InstallContext Class | InstallContext Members | System.Configuration.Install Namespace | Parameters


InstallContext.LogMessage

Writes the message to the log file for the installation and to the console.

[Visual Basic]
Overridable Public Sub LogMessage( _
   ByVal message As String _
)
[C#]
public virtual void LogMessage(
   string message
);
[C++]
public: virtual void LogMessage(
   String* message
);
[JScript]
public function LogMessage(
   message : String
);

Parameters

message
The message to be written to the log file.

Remarks

An installer can call this method to write progress or other status to the log file. If the command line arguments specify displaying a user interface, an installer should show message boxes or make queries in addition to calling LogMessage to write status. Text written to the log file will not be seen by the user unless InstallUtil.exe is used to run the installation and "/LogToConsole= true" is specified in the command line.

See Also

InstallContext Class | InstallContext Members | System.Configuration.Install Namespace | Parameters


InstallContext.ParseCommandLine

Parses the command line arguments into a StringDictionary.

[Visual Basic]
Protected Shared Function ParseCommandLine( _
   ByVal args() As String _
) As StringDictionary
[C#]
protected static StringDictionary ParseCommandLine(
   string[] args
);
[C++]
protected: static StringDictionary* ParseCommandLine(
   String* args[]
);
[JScript]
protected static function ParseCommandLine(
   args : String[]
) : StringDictionary;

Parameters

args
An array containing the command-line arguments.

Return Value

A StringDictionary containing the parsed command-line arguments.

Remarks

This method parses the command line parameters that are entered when the installation executable is run. The parameters and their values are parsed into StringDictionary, a case-insensitive hashtable of parameter names and values of type string. Each array entry in args contains a parameter in one of the following formats: "/parametername= value", or "-parametername= value". The command-line parameter "/LogToConsole= true" would be parsed into the StringDictionary with the key = "logtoconsole" and the value = "true".

See Also

InstallContext Class | InstallContext Members | System.Configuration.Install Namespace | Parameters | IsParameterTrue


Installer Class

Provides a basic framework for doing installations.

Object
Component
Installer

[Visual Basic]
Public Class Installer
   Inherits Component
[C#]
public class Installer : Component
[C++]
public __gc class Installer : public Component
[JScript]
public class Installer extends Component

Remarks

This class provides a basic framework for doing an installation. It is the base class for all custom installers in Visual Studio. Installer contains a collection of installers, named Installers, and has methods and properties to run the installers in the collection.

When you call Install, Commit, Rollback, or Uninstall, on this instance, the corresponding method in each of the contained Installer objects is invoked.

If this Installer instance is part of an installer collection, Parent is the Installer instance that contains the collection. See AssemblyInstaller for an example of the use of the Installers collection.

Context contains information about the installation, including the command line that was entered when the installation executable was run. This property contains information about the location of the log file for the installation, the location of the file to save information required by the Uninstall method, and other information needed by the specific installation being run.

The Install, Commit, Rollback, and Uninstall methods will never be called on the same instance. A new instance is created for each of these operations. Each method is passed an IDictionary, that will be preserved across calls, to share information between methods. Generally, the information you put in this state saver dictionary is what you need later to perform a rollback, commit, or uninstall operation.

The following are examples of situations where you might want to save information in the state saver IDictionary:

  • If an installer sets a registry key, it should first save the current value of that key in the state saver dictionary. Then, if the installation is rolled back, the old value can be restored.
  • If the installer is replacing an existing file, it should move the old file to a temporary directory and store the location of the old file in the state saver dictionary. Then, if the installation is rolled back, the new file can be deleted and the old one moved back to its original place. Otherwise, if the installation is committed, the old file can be deleted from its temporary location.

Requirements

Namespace: System.Configuration.Install

Assembly: System.Configuration.Install.dll

See Also

Installer Members | System.Configuration.Install Namespace | InstallerCollection | ComponentInstaller | AssemblyInstaller | TransactedInstaller


Installer Members

Public:

Constructor

Installer Constructor [To be supplied.]

Properties

Context | Gets or sets information about the current installation.
HelpText | Gets the help text for all of the Installer objects contained in the Installers collection of this installer instance.
Installers | Gets the collection of Installer objects contained in this Installer instance.
Parent | Gets or sets the Installer whose InstallerCollection contains this Installer instance.
Site (inherited from Component) | Gets or sets the site of the Component.

Methods

Commit | Completes the install transaction.
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Install | Performs the installation.
Rollback | Restores the machine to the state it was in before the Install method was called.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
Uninstall | Removes an installation.

Events

AfterCommit | Occurs after the installations handled by the installers in the InstallerCollection of this instance are committed.
AfterInstall | Occurs after the Install methods of all the installers in the InstallerCollection of this instance have run.
AfterRollback | Occurs after the installations handled by the installers in the InstallerCollection of this instance are rolled back.
AfterUninstall | Occurs after the installations handled by the installers in the InstallerCollection of this instance are uninstalled.
BeforeCommit | Occurs before the installations handled by the installers in the InstallerCollection of this instance are committed.
BeforeInstall | Occurs before the installers in the InstallerCollection of this instance are run.
BeforeRollback | Occurs before the installations handled by the installers in the InstallerCollection of this instance are rolled back.
BeforeUninstall | Occurs before the installations handled by the installers in the InstallerCollection of this instance are uninstalled.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCommit | Raises the OnAfterCommit event.
OnAfterInstall | Raises the OnAfterInstall event.
OnAfterRollback | Raises the OnAfterRollback event.
OnAfterUninstall | Raises the OnAfterUninstall event.
OnBeforeCommit | Raises the OnBeforeCommit event.
OnBeforeInstall | Raises the OnBeforeInstall event.
OnBeforeRollback | Raises the OnBeforeRollback event.
OnBeforeUninstall | Raises the OnBeforeUninstall event.

Event Hookup:

Methods

AddOnAfterCommit | [To be supplied.]
AddOnAfterInstall | [To be supplied.]
AddOnAfterRollback | [To be supplied.]
AddOnAfterUninstall | [To be supplied.]
AddOnBeforeCommit | [To be supplied.]
AddOnBeforeInstall | [To be supplied.]
AddOnBeforeRollback | [To be supplied.]
AddOnBeforeUninstall | [To be supplied.]
RemoveOnAfterCommit | [To be supplied.]
RemoveOnAfterInstall | [To be supplied.]
RemoveOnAfterRollback | [To be supplied.]
RemoveOnAfterUninstall | [To be supplied.]
RemoveOnBeforeCommit | [To be supplied.]
RemoveOnBeforeInstall | [To be supplied.]
RemoveOnBeforeRollback | [To be supplied.]
RemoveOnBeforeUninstall | [To be supplied.]

See Also

Installer Class | System.Configuration.Install Namespace


Installer Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public Installer();
[C++]
public: Installer();
[JScript]
public function Installer();

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Installer Properties

The properties of the Installer class are listed below. For a complete list of Installer class members, see the Installer Members topic.

Public:

Context | Gets or sets information about the current installation.
HelpText | Gets the help text for all of the Installer objects contained in the Installers collection of this installer instance.
Installers | Gets the collection of Installer objects contained in this Installer instance.
Parent | Gets or sets the Installer whose InstallerCollection contains this Installer instance.
Site (inherited from Component) | Gets or sets the site of the Component.

See Also

Installer Class | System.Configuration.Install Namespace


Installer.Context

Gets or sets information about the current installation.

[Visual Basic]
Overridable Public Property Context As InstallContext
[C#]
public InstallContext Context {virtual get; virtual set;}
[C++]
public: __property virtual InstallContext* get_Context();
public: __property virtual void set_Context(InstallContext*);
[JScript]
public function get Context() : InstallContext;
public function set Context(InstallContext);

Property Value

An InstallContext that contains information about the current installation.

Remarks

This property contains information that is used by the Install, Commit, Rollback, and Uninstall methods of this instance; it is set by the program that calls these methods. If an installer is contained in an installer collection, the Parent installer sets the Context property before calling one of these methods.

An InstallContext contains a parsed version of the command line that was entered when the installation executable was run. It contains information such as the path to a log file, whether to display log information on the console, and whether to show a user interface during the installation.

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace | Parent | Install | Commit | Rollback | Uninstall


Installer.HelpText

Gets the help text for all of the Installer objects contained in the Installers collection of this installer instance.

[Visual Basic]
Overridable Public ReadOnly Property HelpText As String
[C#]
public string HelpText {virtual get;}
[C++]
public: __property virtual String* get_HelpText();
[JScript]
public function get HelpText() : String;

Property Value

The help text for all of the Installer objects contained in the Installers collection of this installer instance.

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace | Installers | Parent


Installer.Installers

Gets the collection of Installer objects contained in this Installer instance.

[Visual Basic]
Overridable Public ReadOnly Property Installers As _
   InstallerCollection
[C#]
public InstallerCollection Installers {virtual get;}
[C++]
public: __property virtual InstallerCollection* get_Installers();
[JScript]
public function get Installers() : InstallerCollection;

Property Value

An InstallerCollection representing the collection of installers contained in this Installer instance.

Remarks

The Install, Commit, Rollback, and Uninstall methods of this Installer instance call the respective Install, Commit, Rollback, and Uninstall methods of each Installer contained in this collection. For examples of the usage of an installer collection see AssemblyInstaller or TransactedInstaller.

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace | Parent | AssemblyInstaller | TransactedInstaller | ComponentInstaller


Installer.Parent

Gets or sets the Installer whose InstallerCollection contains this Installer instance.

[Visual Basic]
Overridable Public Property Parent As Installer
[C#]
public Installer Parent {virtual get; virtual set;}
[C++]
public: __property virtual Installer* get_Parent();
public: __property virtual void set_Parent(Installer*);
[JScript]
public function get Parent() : Installer;
public function set Parent(Installer);

Property Value

An Installer that represents the installer whose InstallerCollection contains this instance. This property will be a null reference (in Visual Basic Nothing) if the installer is not part of an installer collection.

Remarks

This Installer instance is part of the Installers collection in the Parent Installer. The parent installer calls the Install, Commit, Rollback, and Uninstall methods of the installers contained within its InstallerCollection.

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace | Installers | InstallerCollection | Install | Commit | Rollback | Uninstall


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Installer Methods

The methods of the Installer class are listed below. For a complete list of Installer class members, see the Installer Members topic.

Public:

Commit | Completes the install transaction.
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Install | Performs the installation.
Rollback | Restores the machine to the state it was in before the Install method was called.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
Uninstall | Removes an installation.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCommit | Raises the OnAfterCommit event.
OnAfterInstall | Raises the OnAfterInstall event.
OnAfterRollback | Raises the OnAfterRollback event.
OnAfterUninstall | Raises the OnAfterUninstall event.
OnBeforeCommit | Raises the OnBeforeCommit event.
OnBeforeInstall | Raises the OnBeforeInstall event.
OnBeforeRollback | Raises the OnBeforeRollback event.
OnBeforeUninstall | Raises the OnBeforeUninstall event.

Event Hookup:

AddOnAfterCommit | [To be supplied.]
AddOnAfterInstall | [To be supplied.]
AddOnAfterRollback | [To be supplied.]
AddOnAfterUninstall | [To be supplied.]
AddOnBeforeCommit | [To be supplied.]
AddOnBeforeInstall | [To be supplied.]
AddOnBeforeRollback | [To be supplied.]
AddOnBeforeUninstall | [To be supplied.]
RemoveOnAfterCommit | [To be supplied.]
RemoveOnAfterInstall | [To be supplied.]
RemoveOnAfterRollback | [To be supplied.]
RemoveOnAfterUninstall | [To be supplied.]
RemoveOnBeforeCommit | [To be supplied.]
RemoveOnBeforeInstall | [To be supplied.]
RemoveOnBeforeRollback | [To be supplied.]
RemoveOnBeforeUninstall | [To be supplied.]

See Also

Installer Class | System.Configuration.Install Namespace


Installer.AddOnAfterCommit

[To be supplied.]

[Visual Basic]
Overridable Public Sub AddOnAfterCommit( _
   ByVal handler As InstallEventHandler _
)
[C#]
public virtual void AddOnAfterCommit(
   InstallEventHandler handler
);
[C++]
public: virtual void AddOnAfterCommit(
   InstallEventHandler* handler
);
[JScript]
public function AddOnAfterCommit(
   handler : InstallEventHandler
);

Parameters

handler
[To be supplied.]

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace


Installer.AddOnAfterInstall

[To be supplied.]

[Visual Basic]
Overridable Public Sub AddOnAfterInstall( _
   ByVal handler As InstallEventHandler _
)
[C#]
public virtual void AddOnAfterInstall(
   InstallEventHandler handler
);
[C++]
public: virtual void AddOnAfterInstall(
   InstallEventHandler* handler
);
[JScript]
public function AddOnAfterInstall(
   handler : InstallEventHandler
);

Parameters

handler
[To be supplied.]

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace


Installer.AddOnAfterRollback

[To be supplied.]

[Visual Basic]
Overridable Public Sub AddOnAfterRollback( _
   ByVal handler As InstallEventHandler _
)
[C#]
public virtual void AddOnAfterRollback(
   InstallEventHandler handler
);
[C++]
public: virtual void AddOnAfterRollback(
   InstallEventHandler* handler
);
[JScript]
public function AddOnAfterRollback(
   handler : InstallEventHandler
);

Parameters

handler
[To be supplied.]

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace


Installer.AddOnAfterUninstall

[To be supplied.]

[Visual Basic]
Overridable Public Sub AddOnAfterUninstall( _
   ByVal handler As InstallEventHandler _
)
[C#]
public virtual void AddOnAfterUninstall(
   InstallEventHandler handler
);
[C++]
public: virtual void AddOnAfterUninstall(
   InstallEventHandler* handler
);
[JScript]
public function AddOnAfterUninstall(
   handler : InstallEventHandler
);

Parameters

handler
[To be supplied.]

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace


Installer.AddOnBeforeCommit

[To be supplied.]

[Visual Basic]
Overridable Public Sub AddOnBeforeCommit( _
   ByVal handler As InstallEventHandler _
)
[C#]
public virtual void AddOnBeforeCommit(
   InstallEventHandler handler
);
[C++]
public: virtual void AddOnBeforeCommit(
   InstallEventHandler* handler
);
[JScript]
public function AddOnBeforeCommit(
   handler : InstallEventHandler
);

Parameters

handler
[To be supplied.]

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace


Installer.AddOnBeforeInstall

[To be supplied.]

[Visual Basic]
Overridable Public Sub AddOnBeforeInstall( _
   ByVal handler As InstallEventHandler _
)
[C#]
public virtual void AddOnBeforeInstall(
   InstallEventHandler handler
);
[C++]
public: virtual void AddOnBeforeInstall(
   InstallEventHandler* handler
);
[JScript]
public function AddOnBeforeInstall(
   handler : InstallEventHandler
);

Parameters

handler
[To be supplied.]

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace


Installer.AddOnBeforeRollback

[To be supplied.]

[Visual Basic]
Overridable Public Sub AddOnBeforeRollback( _
   ByVal handler As InstallEventHandler _
)
[C#]
public virtual void AddOnBeforeRollback(
   InstallEventHandler handler
);
[C++]
public: virtual void AddOnBeforeRollback(
   InstallEventHandler* handler
);
[JScript]
public function AddOnBeforeRollback(
   handler : InstallEventHandler
);

Parameters

handler
[To be supplied.]

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace


Installer.AddOnBeforeUninstall

[To be supplied.]

[Visual Basic]
Overridable Public Sub AddOnBeforeUninstall( _
   ByVal handler As InstallEventHandler _
)
[C#]
public virtual void AddOnBeforeUninstall(
   InstallEventHandler handler
);
[C++]
public: virtual void AddOnBeforeUninstall(
   InstallEventHandler* handler
);
[JScript]
public function AddOnBeforeUninstall(
   handler : InstallEventHandler
);

Parameters

handler
[To be supplied.]

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace


Installer.Commit

Completes the install transaction.

[Visual Basic]
Overridable Public Sub Commit( _
   ByVal savedState As IDictionary _
)
[C#]
public virtual void Commit(
   IDictionary savedState
);
[C++]
public: virtual void Commit(
   IDictionary* savedState
);
[JScript]
public function Commit(
   savedState : IDictionary
);

Parameters

savedState
An IDictionary that contains the state of the machine after all of the installers in this instance's InstallerCollection have run. This information is used to perform the Commit operation. Also, you can store any information you might need to do a correct Uninstall.

Exceptions

Exception Type | Condition
ArgumentException | savedState is a null reference (in Visual Basic Nothing) -or- The saved state IDictionary may have been corrupted.

Remarks

This method will be called only if the Install methods of all installers in this instance's InstallerCollection succeed. It calls the Commit method of each installer in the collection.

Notes to Inheritors: If you override the Commit method in a derived class, be sure to call the base class's Commit method.

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace | Install | Uninstall | Rollback | InstallerCollection | Installers


Installer.Install

Performs the installation.

[Visual Basic]
Overridable Public Sub Install( _
   ByVal stateSaver As IDictionary _
)
[C#]
public virtual void Install(
   IDictionary stateSaver
);
[C++]
public: virtual void Install(
   IDictionary* stateSaver
);
[JScript]
public function Install(
   stateSaver : IDictionary
);

Parameters

stateSaver
An IDictionary used to save information needed to perform a commit, rollback, or uninstall operation. It is used by the Commit, Rollback, and Uninstall methods.

Exceptions

Exception Type | Condition
ArgumentException | stateSaver is a null reference (in Visual Basic Nothing)
Exception | An exception occurred in the OnBeforeInstall event-handling method. -or- An exception occurred in the OnAfterInstall event-handling method.

Remarks

This method does the bulk of the work for the installation. It calls the Install methods of the Installer objects contained in the InstallerCollection of this instance. stateSaver is updated to reflect the status of the installation after the contained installers have been run. If all of the Install methods succeed, the Commit method of this instance will be called. Otherwise (that is, if it throws an exception), the Rollback method of this instance will be called.

Notes to Callers: The stateSaver IDictionary should be empty when passed to Install.

Notes to Inheritors: If you override the Install method in a derived class, be sure to call the base class's Install method.

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace | Commit | Uninstall | Rollback | InstallerCollection | Installers


Installer.OnAfterCommit

Raises the OnAfterCommit event.

[Visual Basic]
Overridable Protected Sub OnAfterCommit( _
   ByVal savedState As IDictionary _
)
[C#]
protected virtual void OnAfterCommit(
   IDictionary savedState
);
[C++]
protected: virtual void OnAfterCommit(
   IDictionary* savedState
);
[JScript]
protected function OnAfterCommit(
   savedState : IDictionary
);

Parameters

savedState
An IDictionary that represents the state of the machine after the installations handled by the installers in this instance's InstallerCollection have been committed.

Remarks

This method is called after the Commit methods of all the installers contained in this instance's InstallerCollection have run.

Raising the event invokes an event-handling method through a delegate. For an overview, see EventTopicTBD.

Notes to Inheritors: When overriding OnAfterCommit in a derived class, be sure to call the base class's OnAfterCommit method.

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace | OnAfterInstall | OnAfterRollback | OnAfterUninstall | OnBeforeCommit | OnBeforeInstall | OnBeforeRollback | OnBeforeUninstall


Installer.OnAfterInstall

Raises the OnAfterInstall event.

[Visual Basic]
Overridable Protected Sub OnAfterInstall( _
   ByVal savedState As IDictionary _
)
[C#]
protected virtual void OnAfterInstall(
   IDictionary savedState
);
[C++]
protected: virtual void OnAfterInstall(
   IDictionary* savedState
);
[JScript]
protected function OnAfterInstall(
   savedState : IDictionary
);

Parameters

savedState
An IDictionary that represents the state of the machine after the installations handled by the installers in this instance's InstallerCollection have been done.

Remarks

This method is called after the Install methods of all the installers in this instance's InstallerCollection have run.

Raising the event invokes an event-handling method through a delegate. For an overview, see EventTopicTBD.

Notes to Inheritors: When overriding OnAfterInstall in a derived class, be sure to call the base class's OnAfterInstall method.

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace | OnAfterCommit | OnAfterRollback | OnAfterUninstall | OnBeforeCommit | OnBeforeInstall | OnBeforeRollback | OnBeforeUninstall


Installer.OnAfterRollback

Raises the OnAfterRollback event.

[Visual Basic]
Overridable Protected Sub OnAfterRollback( _
   ByVal savedState As IDictionary _
)
[C#]
protected virtual void OnAfterRollback(
   IDictionary savedState
);
[C++]
protected: virtual void OnAfterRollback(
   IDictionary* savedState
);
[JScript]
protected function OnAfterRollback(
   savedState : IDictionary
);

Parameters

savedState
An IDictionary that represents the state of the machine after the installations handled by the installers in this instance's InstallerCollection have been rolled back.

Remarks

This method is called after the Rollback methods of all the installers in this instance's InstallerCollection have run.

Raising the event invokes an event-handling method through a delegate. For an overview, see EventTopicTBD.

Notes to Inheritors: When overriding OnAfterRollback in a derived class, be sure to call the base class's OnAfterRollback method.

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace | OnAfterInstall | OnAfterCommit | OnAfterUninstall | OnBeforeCommit | OnBeforeInstall | OnBeforeRollback | OnBeforeUninstall


Installer.OnAfterUninstall

Raises the OnAfterUninstall event.

[Visual Basic]
Overridable Protected Sub OnAfterUninstall( _
   ByVal savedState As IDictionary _
)
[C#]
protected virtual void OnAfterUninstall(
   IDictionary savedState
);
[C++]
protected: virtual void OnAfterUninstall(
   IDictionary* savedState
);
[JScript]
protected function OnAfterUninstall(
   savedState : IDictionary
);

Parameters

savedState
An IDictionary that represents the state of the machine after the installations handled by the installers in this instance's InstallerCollection have been removed.

Remarks

This method is called after the installations done by the installers in this instance's InstallerCollection have been removed.

Raising the event invokes an event-handling method through a delegate. For an overview, see EventTopicTBD.

Notes to Inheritors: When overriding OnBeforeInstall in a derived class, be sure to call the base class's OnAfterUninstall method.

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace | OnAfterInstall | OnAfterRollback | OnAfterRollback | OnBeforeCommit | OnBeforeInstall | OnBeforeRollback | OnBeforeUninstall


Installer.OnBeforeCommit

Raises the OnBeforeCommit event.

[Visual Basic]
Overridable Protected Sub OnBeforeCommit( _
   ByVal savedState As IDictionary _
)
[C#]
protected virtual void OnBeforeCommit(
   IDictionary savedState
);
[C++]
protected: virtual void OnBeforeCommit(
   IDictionary* savedState
);
[JScript]
protected function OnBeforeCommit(
   savedState : IDictionary
);

Parameters

savedState
An IDictionary that represents the state of the machine before the installations handled by the installers in this instance's InstallerCollection have been committed.

Remarks

This method is called before any of the Commit methods of the installers contained in this instance's InstallerCollection are run.

Raising the event invokes an event-handling method through a delegate. For an overview, see EventTopicTBD.

Notes to Inheritors: When overriding OnBeforeCommit in a derived class, be sure to call the base class's OnBeforeCommit method.

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace | OnAfterInstall | OnAfterRollback | OnAfterUninstall | OnAfterCommit | OnBeforeInstall | OnBeforeRollback | OnBeforeUninstall


Installer.OnBeforeInstall

Raises the OnBeforeInstall event.

[Visual Basic]
Overridable Protected Sub OnBeforeInstall( _
   ByVal savedState As IDictionary _
)
[C#]
protected virtual void OnBeforeInstall(
   IDictionary savedState
);
[C++]
protected: virtual void OnBeforeInstall(
   IDictionary* savedState
);
[JScript]
protected function OnBeforeInstall(
   savedState : IDictionary
);

Parameters

savedState
An IDictionary that represents the state of the machine during installations handled by the installers in this instance's InstallerCollection; it is empty at this point in the process.

Remarks

This method is called before the Install methods of the installers in this instance's InstallerCollection are called.

Raising the event invokes an event-handling method through a delegate. For an overview, see EventTopicTBD.

Notes to Inheritors: When overriding OnBeforeInstall in a derived class, be sure to call the base class's OnBeforeInstall method.

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace | OnAfterInstall | OnAfterRollback | OnAfterUninstall | OnBeforeCommit | OnAfterCommit | OnBeforeRollback | OnBeforeUninstall


Installer.OnBeforeRollback

Raises the OnBeforeRollback event.

[Visual Basic]
Overridable Protected Sub OnBeforeRollback( _
   ByVal savedState As IDictionary _
)
[C#]
protected virtual void OnBeforeRollback(
   IDictionary savedState
);
[C++]
protected: virtual void OnBeforeRollback(
   IDictionary* savedState
);
[JScript]
protected function OnBeforeRollback(
   savedState : IDictionary
);

Parameters

savedState
An IDictionary that represents the state of the machine before the installations handled by the installers in this instance's InstallerCollection have been rolled back.

Remarks

This method is called before rolling back the installations that were done by the installers in this instance's InstallerCollection.

Raising the event invokes an event-handling method through a delegate. For an overview, see EventTopicTBD.

Notes to Inheritors: When overriding OnBeforeInstall in a derived class, be sure to call the base class's OnBeforeRollback method.

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace | OnAfterInstall | OnAfterRollback | OnAfterUninstall | OnBeforeCommit | OnBeforeInstall | OnAfterCommit | OnBeforeUninstall


Installer.OnBeforeUninstall

Raises the OnBeforeUninstall event.

[Visual Basic]
Overridable Protected Sub OnBeforeUninstall( _
   ByVal savedState As IDictionary _
)
[C#]
protected virtual void OnBeforeUninstall(
   IDictionary savedState
);
[C++]
protected: virtual void OnBeforeUninstall(
   IDictionary* savedState
);
[JScript]
protected function OnBeforeUninstall(
   savedState : IDictionary
);

Parameters

savedState
An IDictionary that represents the state of the machine before the installations handled by the installers in this instance's InstallerCollection of have been removed.

Remarks

This method is called before removing the installations that were done by the installers in this instance's InstallerCollection.

Raising the event invokes an event-handling method through a delegate. For an overview, see EventTopicTBD.

Notes to Inheritors: When overriding OnBeforeInstall in a derived class, be sure to call the base class's OnBeforeInstall method.

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace | OnAfterInstall | OnAfterRollback | OnAfterUninstall | OnBeforeCommit | OnBeforeInstall | OnBeforeRollback | OnAfterCommit


Installer.RemoveOnAfterCommit

[To be supplied.]

[Visual Basic]
Overridable Public Sub RemoveOnAfterCommit( _
   ByVal handler As InstallEventHandler _
)
[C#]
public virtual void RemoveOnAfterCommit(
   InstallEventHandler handler
);
[C++]
public: virtual void RemoveOnAfterCommit(
   InstallEventHandler* handler
);
[JScript]
public function RemoveOnAfterCommit(
   handler : InstallEventHandler
);

Parameters

handler
[To be supplied.]

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace


Installer.RemoveOnAfterInstall

[To be supplied.]

[Visual Basic]
Overridable Public Sub RemoveOnAfterInstall( _
   ByVal handler As InstallEventHandler _
)
[C#]
public virtual void RemoveOnAfterInstall(
   InstallEventHandler handler
);
[C++]
public: virtual void RemoveOnAfterInstall(
   InstallEventHandler* handler
);
[JScript]
public function RemoveOnAfterInstall(
   handler : InstallEventHandler
);

Parameters

handler
[To be supplied.]

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace


Installer.RemoveOnAfterRollback

[To be supplied.]

[Visual Basic]
Overridable Public Sub RemoveOnAfterRollback( _
   ByVal handler As InstallEventHandler _
)
[C#]
public virtual void RemoveOnAfterRollback(
   InstallEventHandler handler
);
[C++]
public: virtual void RemoveOnAfterRollback(
   InstallEventHandler* handler
);
[JScript]
public function RemoveOnAfterRollback(
   handler : InstallEventHandler
);

Parameters

handler
[To be supplied.]

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace


Installer.RemoveOnAfterUninstall

[To be supplied.]

[Visual Basic]
Overridable Public Sub RemoveOnAfterUninstall( _
   ByVal handler As InstallEventHandler _
)
[C#]
public virtual void RemoveOnAfterUninstall(
   InstallEventHandler handler
);
[C++]
public: virtual void RemoveOnAfterUninstall(
   InstallEventHandler* handler
);
[JScript]
public function RemoveOnAfterUninstall(
   handler : InstallEventHandler
);

Parameters

handler
[To be supplied.]

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace


Installer.RemoveOnBeforeCommit

[To be supplied.]

[Visual Basic]
Overridable Public Sub RemoveOnBeforeCommit( _
   ByVal handler As InstallEventHandler _
)
[C#]
public virtual void RemoveOnBeforeCommit(
   InstallEventHandler handler
);
[C++]
public: virtual void RemoveOnBeforeCommit(
   InstallEventHandler* handler
);
[JScript]
public function RemoveOnBeforeCommit(
   handler : InstallEventHandler
);

Parameters

handler
[To be supplied.]

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace


Installer.RemoveOnBeforeInstall

[To be supplied.]

[Visual Basic]
Overridable Public Sub RemoveOnBeforeInstall( _
   ByVal handler As InstallEventHandler _
)
[C#]
public virtual void RemoveOnBeforeInstall(
   InstallEventHandler handler
);
[C++]
public: virtual void RemoveOnBeforeInstall(
   InstallEventHandler* handler
);
[JScript]
public function RemoveOnBeforeInstall(
   handler : InstallEventHandler
);

Parameters

handler
[To be supplied.]

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace


Installer.RemoveOnBeforeRollback

[To be supplied.]

[Visual Basic]
Overridable Public Sub RemoveOnBeforeRollback( _
   ByVal handler As InstallEventHandler _
)
[C#]
public virtual void RemoveOnBeforeRollback(
   InstallEventHandler handler
);
[C++]
public: virtual void RemoveOnBeforeRollback(
   InstallEventHandler* handler
);
[JScript]
public function RemoveOnBeforeRollback(
   handler : InstallEventHandler
);

Parameters

handler
[To be supplied.]

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace


Installer.RemoveOnBeforeUninstall

[To be supplied.]

[Visual Basic]
Overridable Public Sub RemoveOnBeforeUninstall( _
   ByVal handler As InstallEventHandler _
)
[C#]
public virtual void RemoveOnBeforeUninstall(
   InstallEventHandler handler
);
[C++]
public: virtual void RemoveOnBeforeUninstall(
   InstallEventHandler* handler
);
[JScript]
public function RemoveOnBeforeUninstall(
   handler : InstallEventHandler
);

Parameters

handler
[To be supplied.]

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace


Installer.Rollback

Restores the machine to the state it was in before the Install method was called.

[Visual Basic]
Overridable Public Sub Rollback( _
   ByVal savedState As IDictionary _
)
[C#]
public virtual void Rollback(
   IDictionary savedState
);
[C++]
public: virtual void Rollback(
   IDictionary* savedState
);
[JScript]
public function Rollback(
   savedState : IDictionary
);

Parameters

savedState
A IDictionary representing the state of the installation that was saved by the Install method.

Exceptions

Exception Type | Condition
ArgumentException | The savedState parameter is null. -or- The saved state IDictionary may have been corrupted.

Remarks

Rollback is called to restore the machine to the state it was in before the Install method was called. This method will be called if the Install method of any installer in this instance's InstallerCollection fails to run correctly. Rollback will also be called if the Install method on this instance fails, so it must be able to handle a failed install. Any exceptions generated by calling the Rollback methods of the installers in the collection will be ignored and the rollback of other installers will continue.

Notes to Inheritors: If you override the Rollback method in a derived class, be sure to call the base class's Rollback method.

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace | Commit | Uninstall | Install | InstallerCollection | Installers


Installer.Uninstall

Removes an installation.

[Visual Basic]
Overridable Public Sub Uninstall( _
   ByVal savedState As IDictionary _
)
[C#]
public virtual void Uninstall(
   IDictionary savedState
);
[C++]
public: virtual void Uninstall(
   IDictionary* savedState
);
[JScript]
public function Uninstall(
   savedState : IDictionary
);

Parameters

savedState
A IDictionary representing the state saved when the installation was done, or a null reference (in Visual Basic Nothing) if the file containing the saved state was deleted after the installation was completed.

Exceptions

Exception Type | Condition
ArgumentException | The saved state IDictionary is in an inconsistent state.

Remarks

Call this method to remove a previously completed installation. Uninstalls are not done in a transaction. If the Uninstall method fails for one of the installers in the installer collection, the Uninstall method will still be called on the other installers in the collection. A failed uninstall procedure will not be rolled back.

Note Although the Install and Commit methods that were called to do this installation saved the state of the installation, the file containing the savedState IDictionary may have been deleted some time after the installation was completed. Uninstall should be able to handle the case of a a null reference (Nothing) saved state parameter.

Notes to Inheritors: If you override the Uninstall method in a derived class, be sure to call the base class's Uninstall method.

See Also

Installer Class | Installer Members | System.Configuration.Install Namespace | Install | Commit | Rollback | InstallerCollection | Installers


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Installer Events

The events of the Installer class are listed below. For a complete list of Installer class members, see the Installer Members topic.

Public:

AfterCommit | Occurs after the installations handled by the installers in the InstallerCollection of this instance are committed.
AfterInstall | Occurs after the Install methods of all the installers in the InstallerCollection of this instance have run.
AfterRollback | Occurs after the installations handled by the installers in the InstallerCollection of this instance are rolled back.
AfterUninstall | Occurs after the installations handled by the installers in the InstallerCollection of this instance are uninstalled.
BeforeCommit | Occurs before the installations handled by the installers in the InstallerCollection of this instance are committed.
BeforeInstall | Occurs before the installers in the InstallerCollection of this instance are run.
BeforeRollback | Occurs before the installations handled by the installers in the InstallerCollection of this instance are rolled back.
BeforeUninstall | Occurs before the installations handled by the installers in the InstallerCollection of this instance are uninstalled.

See Also

Installer Class | System.Configuration.Install Namespace


Installer AfterCommit Event

Occurs after the installations handled by the installers in the InstallerCollection of this instance are committed.

The following declaration shows the syntax for a method that handles the AfterCommit event.

[Visual Basic]
Private Sub InstallerName_AfterCommit( _
   ByVal sender As Object, _
   ByVal e As InstallEventArgs _
)
[C#]
private void InstallerName_AfterCommit(
   object sender,
   InstallEventArgs e
);
[C++]
private: void InstallerName_AfterCommit(
   Object* sender,
   InstallEventArgs* e
);
[JScript]
private InstallerName_AfterCommit(
   sender : Object,
   e : InstallEventArgs
);

Parameters

sender
The source of the event.
e
An InstallEventArgs that contains the event data.

Remarks

This event is raised after all of the installations handled by this instance's InstallerCollection have been committed. Attach event-handling methods that need to run after the Commit methods have completed to this event.

See Also

Installer Class | Installer MembersTopic | System.Configuration.Install Namespace | Installer.OnAfterInstall | Installer.OnAfterRollback | Installer.OnAfterUninstall | Installer.OnBeforeCommit | Installer.OnBeforeInstall | Installer.OnBeforeRollback | Installer.OnBeforeUninstall


Installer AfterInstall Event

Occurs after the Install methods of all the installers in the InstallerCollection of this instance have run.

The following declaration shows the syntax for a method that handles the AfterInstall event.

[Visual Basic]
Private Sub InstallerName_AfterInstall( _
   ByVal sender As Object, _
   ByVal e As InstallEventArgs _
)
[C#]
private void InstallerName_AfterInstall(
   object sender,
   InstallEventArgs e
);
[C++]
private: void InstallerName_AfterInstall(
   Object* sender,
   InstallEventArgs* e
);
[JScript]
private InstallerName_AfterInstall(
   sender : Object,
   e : InstallEventArgs
);

Parameters

sender
The source of the event.
e
An InstallEventArgs that contains the event data.

Remarks

This event is raised after the Install methods all of the installers contained in this instance's InstallerCollection have run. Attach event-handling methods that need to run after the Install methods have completed to this event.

See Also

Installer Class | Installer MembersTopic | System.Configuration.Install Namespace | Installer.OnAfterCommit | Installer.OnAfterRollback | Installer.OnAfterUninstall | Installer.OnBeforeCommit | Installer.OnBeforeInstall | Installer.OnBeforeRollback | Installer.OnBeforeUninstall


Installer AfterRollback Event

Occurs after the installations handled by the installers in the InstallerCollection of this instance are rolled back.

The following declaration shows the syntax for a method that handles the AfterRollback event.

[Visual Basic]
Private Sub InstallerName_AfterRollback( _
   ByVal sender As Object, _
   ByVal e As InstallEventArgs _
)
[C#]
private void InstallerName_AfterRollback(
   object sender,
   InstallEventArgs e
);
[C++]
private: void InstallerName_AfterRollback(
   Object* sender,
   InstallEventArgs* e
);
[JScript]
private InstallerName_AfterRollback(
   sender : Object,
   e : InstallEventArgs
);

Parameters

sender
The source of the event.
e
An InstallEventArgs that contains the event data.

Remarks

This event is raised after all of the installations handled by the installers in this instance's InstallerCollection have been rolled back. Attach event-handling methods that need to run after the Rollback methods have completed to this event.

See Also

Installer Class | Installer MembersTopic | System.Configuration.Install Namespace | Installer.OnAfterInstall | Installer.OnAfterCommit | Installer.OnAfterUninstall | Installer.OnBeforeCommit | Installer.OnBeforeInstall | Installer.OnBeforeRollback | Installer.OnBeforeUninstall


Installer AfterUninstall Event

Occurs after the installations handled by the installers in the InstallerCollection of this instance are uninstalled.

The following declaration shows the syntax for a method that handles the AfterUninstall event.

[Visual Basic]
Private Sub InstallerName_AfterUninstall( _
   ByVal sender As Object, _
   ByVal e As InstallEventArgs _
)
[C#]
private void InstallerName_AfterUninstall(
   object sender,
   InstallEventArgs e
);
[C++]
private: void InstallerName_AfterUninstall(
   Object* sender,
   InstallEventArgs* e
);
[JScript]
private InstallerName_AfterUninstall(
   sender : Object,
   e : InstallEventArgs
);

Parameters

sender
The source of the event.
e
An InstallEventArgs that contains the event data.

Remarks

This event is raised after all of the installations handled by the installers in this instance's InstallerCollection have been uninstalled. Attach event-handling methods that need to run after the Uninstall methods have completed to this event.

See Also

Installer Class | Installer MembersTopic | System.Configuration.Install Namespace | Installer.OnAfterInstall | Installer.OnAfterRollback | Installer.OnAfterCommit | Installer.OnBeforeCommit | Installer.OnBeforeInstall | Installer.OnBeforeRollback | Installer.OnBeforeUninstall


Installer BeforeCommit Event

Occurs before the installations handled by the installers in the InstallerCollection of this instance are committed.

The following declaration shows the syntax for a method that handles the BeforeCommit event.

[Visual Basic]
Private Sub InstallerName_BeforeCommit( _
   ByVal sender As Object, _
   ByVal e As InstallEventArgs _
)
[C#]
private void InstallerName_BeforeCommit(
   object sender,
   InstallEventArgs e
);
[C++]
private: void InstallerName_BeforeCommit(
   Object* sender,
   InstallEventArgs* e
);
[JScript]
private InstallerName_BeforeCommit(
   sender : Object,
   e : InstallEventArgs
);

Parameters

sender
The source of the event.
e
An InstallEventArgs that contains the event data.

Remarks

This event is raised before any of the installers contained in this instance's InstallerCollection are committed. Attach event-handling methods that need to run before the Commit methods are called to this event.

See Also

Installer Class | Installer MembersTopic | System.Configuration.Install Namespace | Installer.OnAfterInstall | Installer.OnAfterRollback | Installer.OnAfterUninstall | Installer.OnAfterCommit | Installer.OnBeforeInstall | Installer.OnBeforeRollback | Installer.OnBeforeUninstall


Installer BeforeInstall Event

Occurs before the installers in the InstallerCollection of this instance are run.

The following declaration shows the syntax for a method that handles the BeforeInstall event.

[Visual Basic]
Private Sub InstallerName_BeforeInstall( _
   ByVal sender As Object, _
   ByVal e As InstallEventArgs _
)
[C#]
private void InstallerName_BeforeInstall(
   object sender,
   InstallEventArgs e
);
[C++]
private: void InstallerName_BeforeInstall(
   Object* sender,
   InstallEventArgs* e
);
[JScript]
private InstallerName_BeforeInstall(
   sender : Object,
   e : InstallEventArgs
);

Parameters

sender
The source of the event.
e
An InstallEventArgs that contains the event data.

Remarks

This event is raised before the installers contained in this instance's InstallerCollection are run. Attach event-handling methods that need to run before the Install methods are called to this event.

See Also

Installer Class | Installer MembersTopic | System.Configuration.Install Namespace | Installer.OnAfterInstall | Installer.OnAfterRollback | Installer.OnAfterUninstall | Installer.OnBeforeCommit | Installer.OnAfterInstall | Installer.OnBeforeRollback | Installer.OnBeforeUninstall


Installer BeforeRollback Event

Occurs before the installations handled by the installers in the InstallerCollection of this instance are rolled back.

The following declaration shows the syntax for a method that handles the BeforeRollback event.

[Visual Basic]
Private Sub InstallerName_BeforeRollback( _
   ByVal sender As Object, _
   ByVal e As InstallEventArgs _
)
[C#]
private void InstallerName_BeforeRollback(
   object sender,
   InstallEventArgs e
);
[C++]
private: void InstallerName_BeforeRollback(
   Object* sender,
   InstallEventArgs* e
);
[JScript]
private InstallerName_BeforeRollback(
   sender : Object,
   e : InstallEventArgs
);

Parameters

sender
The source of the event.
e
An InstallEventArgs that contains the event data.

Remarks

This event is raised before the installations handled by the installers contained in this instance's InstallerCollection are rolled back. Attach event-handling methods that need to run before the Rollback methods are called to this event.

See Also

Installer Class | Installer MembersTopic | System.Configuration.Install Namespace | Installer.OnAfterInstall | Installer.OnAfterRollback | Installer.OnAfterUninstall | Installer.OnBeforeCommit | Installer.OnBeforeInstall | Installer.OnAfterCommit | Installer.OnBeforeUninstall


Installer BeforeUninstall Event

Occurs before the installations handled by the installers in the InstallerCollection of this instance are uninstalled.

The following declaration shows the syntax for a method that handles the BeforeUninstall event.

[Visual Basic]
Private Sub InstallerName_BeforeUninstall( _
   ByVal sender As Object, _
   ByVal e As InstallEventArgs _
)
[C#]
private void InstallerName_BeforeUninstall(
   object sender,
   InstallEventArgs e
);
[C++]
private: void InstallerName_BeforeUninstall(
   Object* sender,
   InstallEventArgs* e
);
[JScript]
private InstallerName_BeforeUninstall(
   sender : Object,
   e : InstallEventArgs
);

Parameters

sender
The source of the event.
e
An InstallEventArgs that contains the event data.

Remarks

This event is raised before the installations handled by installers contained in this instance's InstallerCollection are uninstalled. Attach event-handling methods that need to run before the Uninstall methods are called to this event.

See Also

Installer Class | Installer MembersTopic | System.Configuration.Install Namespace | Installer.OnAfterInstall | Installer.OnAfterRollback | Installer.OnAfterUninstall | Installer.OnBeforeCommit | Installer.OnBeforeInstall | Installer.OnBeforeRollback | Installer.OnAfterCommit


InstallerCollection Class

Contains a collection of installers to be run during an installation.

Object
InstallerCollection

[Visual Basic]
Public Class InstallerCollection
   Implements ICollection, IEnumerable
[C#]
public class InstallerCollection : ICollection, IEnumerable
[C++]
public __gc class InstallerCollection : public ICollection,
   IEnumerable
[JScript]
public class InstallerCollection implements ICollection,
   IEnumerable

Remarks

InstallerCollection provides methods and properties to manage a collection of Installer objects. Call Add or AddRange to add installers to the collection. Call Remove or RemoveRange to remove installers from the collection. Call Contains, to determine whether an installer is in the collection. Call GetEnumerator to get an enumerator containing the installers in the collection.

The installers in a collection are run when the installer containing the collection, as specified by the Parent property, calls their Install, Commit, Rollback, or Uninstall methods.

For examples of the usage of an installer collection, see AssemblyInstaller or TransactedInstaller.

Requirements

Namespace: System.Configuration.Install

Assembly: System.Configuration.Install.dll

See Also

InstallerCollection Members | System.Configuration.Install Namespace | Installer | Install | Commit | Rollback | Uninstall | AssemblyInstaller | TransactedInstaller


InstallerCollection Members

Public:

Properties

All | Gets or sets an array of all the Installer objects in this InstallerCollection.
Capacity | Gets or sets a value that specifies the maximum number of Installer objects that can be stored in this InstallerCollection.
Count | Gets a value that specifies how many Installer objects are stored in this InstallerCollection.
Item | Gets or sets an installer at the specified index. In C#, this member is the indexer for the InstallerCollection class.

Methods

Add | Adds the specified installer to this collection of installers.
AddRange | Adds the specified installers to this installer collection.
Contains | Determines whether the specified installer is included in this InstallerCollection.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Returns an IEnumerator that represents the contents of the installer collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Remove | Overloaded. Removes an installer from the collection.
RemoveRange | Removes the specified range of installers from the installer collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InstallerCollection Class | System.Configuration.Install Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

InstallerCollection Properties

The properties of the InstallerCollection class are listed below. For a complete list of InstallerCollection class members, see the InstallerCollection Members topic.

Public:

All | Gets or sets an array of all the Installer objects in this InstallerCollection.
Capacity | Gets or sets a value that specifies the maximum number of Installer objects that can be stored in this InstallerCollection.
Count | Gets a value that specifies how many Installer objects are stored in this InstallerCollection.
Item | Gets or sets an installer at the specified index. In C#, this member is the indexer for the InstallerCollection class.

See Also

InstallerCollection Class | System.Configuration.Install Namespace


InstallerCollection.All

Gets or sets an array of all the Installer objects in this InstallerCollection.

[Visual Basic]
Public Property All As Installer ()
[C#]
public Installer[] All {get; set;}
[C++]
public: __property Installer* get_All();
public: __property void set_All(Installer*[]);
[JScript]
public function get All() : Installer[];
public function set All(Installer[]);

Property Value

An array containing all of the Installer objects in this InstallerCollection.

Remarks

The collection is cleared before the array of Installer objects is set into the collection. When the installer array is set into the collection, the Parent property of each Installer in the array is set to the Installer that contains the collection.

Note Call Add or AddRange respectively to add an installer or a range of installers to the collection.

See Also

InstallerCollection Class | InstallerCollection Members | System.Configuration.Install Namespace | Add | AddRange | Remove | RemoveRange


InstallerCollection.Capacity

Gets or sets a value that specifies the maximum number of Installer objects that can be stored in this InstallerCollection.

[Visual Basic]
Overridable Public Property Capacity As Integer
[C#]
public int Capacity {virtual get; virtual set;}
[C++]
public: __property virtual int get_Capacity();
public: __property virtual void set_Capacity(int);
[JScript]
public function get Capacity() : int;
public function set Capacity(int);

Property Value

A value that specifies the maximum number of Installer objects that can be stored in this InstallerCollection.

See Also

InstallerCollection Class | InstallerCollection Members | System.Configuration.Install Namespace


InstallerCollection.Count

Gets a value that specifies how many Installer objects are stored in this InstallerCollection.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

Property Value

A value that specifies how many Installer objects are stored in this InstallerCollection.

See Also

InstallerCollection Class | InstallerCollection Members | System.Configuration.Install Namespace


InstallerCollection.Item

Gets or sets an installer at the specified index.

[C#] In C#, this member is the indexer for the InstallerCollection class.

[Visual Basic]
Overridable Public Default Property Item( _
   ByVal index As Integer _
) As Installer
[C#]
public Installer this[
   int index
] {virtual get; virtual set;}
[C++]
public: __property virtual Installer* get_Item(
   int index
);
public: __property virtual void set_Item(
   int index,
   Installer*
);
[JScript]
returnValue = InstallerCollectionObject.Item(index);
InstallerCollectionObject.Item(index) = returnValue;
-or-
returnValue = InstallerCollectionObject(index);
InstallerCollectionObject(index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
The zero-based index of the item to retrieve.

Parameters [Visual Basic, C#, C++]

index
The zero-based index of the item to retrieve.

Property Value

An Installer that represents the installer specified by index.

Remarks

When the specified Installer is set into the InstallerCollection, its Parent property is set to specify the Installer that contains the collection.

See Also

InstallerCollection Class | InstallerCollection Members | System.Configuration.Install Namespace | Installer


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

InstallerCollection Methods

The methods of the InstallerCollection class are listed below. For a complete list of InstallerCollection class members, see the InstallerCollection Members topic.

Public:

Add | Adds the specified installer to this collection of installers.
AddRange | Adds the specified installers to this installer collection.
Contains | Determines whether the specified installer is included in this InstallerCollection.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Returns an IEnumerator that represents the contents of the installer collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Remove | Overloaded. Removes an installer from the collection.
RemoveRange | Removes the specified range of installers from the installer collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InstallerCollection Class | System.Configuration.Install Namespace


InstallerCollection.Add

Adds the specified installer to this collection of installers.

[Visual Basic]
Overridable Public Sub Add( _
   ByVal installer As Installer _
)
[C#]
public virtual void Add(
   Installer installer
);
[C++]
public: virtual void Add(
   Installer* installer
);
[JScript]
public function Add(
   installer : Installer
);

Parameters

installer
An Installer representing the installer to add to the collection.

Remarks

The Parent property of the added Installer is set to specify the Installer containing this collection.

See Also

InstallerCollection Class | InstallerCollection Members | System.Configuration.Install Namespace | All | AddRange | Remove | RemoveRange | Installer


InstallerCollection.AddRange

Adds the specified installers to this installer collection.

[Visual Basic]
Overridable Public Sub AddRange( _
   ByVal range As InstallerCollection _
)
[C#]
public virtual void AddRange(
   InstallerCollection range
);
[C++]
public: virtual void AddRange(
   InstallerCollection* range
);
[JScript]
public function AddRange(
   range : InstallerCollection
);

Parameters

range
An InstallerCollection representing the installers to be added to this installer collection.

Remarks

The Parent property of each added Installer is set to the Installer containing this collection.

See Also

InstallerCollection Class | InstallerCollection Members | System.Configuration.Install Namespace | Add | All | Remove | RemoveRange | Installer


InstallerCollection.Contains

Determines whether the specified installer is included in this InstallerCollection.

[Visual Basic]
Overridable Public Function Contains( _
   ByVal item As Installer _
) As Boolean
[C#]
public virtual bool Contains(
   Installer item
);
[C++]
public: virtual bool Contains(
   Installer* item
);
[JScript]
public function Contains(
   item : Installer
) : Boolean;

Parameters

item
An Installer representing the installer to look for.

Return Value

true if the specified installer is in this collection; otherwise, false.

See Also

InstallerCollection Class | InstallerCollection Members | System.Configuration.Install Namespace | Add | AddRange | Remove | RemoveRange | Installer


InstallerCollection.GetEnumerator

Returns an IEnumerator that represents the contents of the installer collection.

[Visual Basic]
Public Function GetEnumerator() As IEnumerator
[C#]
public IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

Return Value

An IEnumerator that represents the contents of the installer collection.

See Also

InstallerCollection Class | InstallerCollection Members | System.Configuration.Install Namespace | IEnumerator | Installer | Installer | Installers | Parent


InstallerCollection.Remove

Removes an installer from the collection.

Overload List

Removes the installer specified by its index value from the collection.

[Visual Basic] Overloads Overridable Public Sub Remove(Integer)
[C#] public virtual void Remove(int);
[C++] public: virtual void Remove(int);
[JScript] public function Remove(int);

Removes the specified Installer from the collection.

[Visual Basic] Overloads Overridable Public Sub Remove(Installer)
[C#] public virtual void Remove(Installer);
[C++] public: virtual void Remove(Installer*);
[JScript] public function Remove(Installer);

See Also

InstallerCollection Class | InstallerCollection Members | System.Configuration.Install Namespace


InstallerCollection.Remove (Int32)

Removes the installer specified by its index value from the collection.

[Visual Basic]
Overloads Overridable Public Sub Remove( _
   ByVal index As Integer _
)
[C#]
public virtual void Remove(
   int index
);
[C++]
public: virtual void Remove(
   int index
);
[JScript]
public function Remove(
   index : int
);

Parameters

index
A zero-based index that specifies the Installer to remove.

Remarks

The Parent property of the removed Installer is set to a null reference (in Visual Basic Nothing).

See Also

InstallerCollection Class | InstallerCollection Members | System.Configuration.Install Namespace | InstallerCollection.Remove Overload List | Add | AddRange | All | RemoveRange | Installer | Parent


InstallerCollection.Remove (Installer)

Removes the specified Installer from the collection.

[Visual Basic]
Overloads Overridable Public Sub Remove( _
   ByVal installer As Installer _
)
[C#]
public virtual void Remove(
   Installer installer
);
[C++]
public: virtual void Remove(
   Installer* installer
);
[JScript]
public function Remove(
   installer : Installer
);

Parameters

installer
An Installer representing the installer to remove.

Remarks

The Parent property of the removed Installer is set to a null reference (in Visual Basic Nothing).

See Also

InstallerCollection Class | InstallerCollection Members | System.Configuration.Install Namespace | InstallerCollection.Remove Overload List | Add | AddRange | All | RemoveRange | Installer | Parent


InstallerCollection.RemoveRange

Removes the specified range of installers from the installer collection.

[Visual Basic]
Overridable Public Sub RemoveRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
[C#]
public virtual void RemoveRange(
   int index,
   int count
);
[C++]
public: virtual void RemoveRange(
   int index,
   int count
);
[JScript]
public function RemoveRange(
   index : int,
   count : int
);

Parameters

index
A zero-based index that specifies the beginning of the range of Installers to remove.
count
A value specifying how many Installers to remove, starting with the zero-based index.

See Also

InstallerCollection Class | InstallerCollection Members | System.Configuration.Install Namespace | Add | AddRange | Remove | All | Installer | Parent


InstallEventArgs Class

Provides data for the OnBeforeInstall, OnAfterInstall, OnBeforeCommit, OnAfterCommit, OnBeforeRollback, OnAfterRollback, OnBeforeUninstall, and OnAfterUninstall events.

Object
EventArgs
InstallEventArgs

[Visual Basic]
Public Class InstallEventArgs
   Inherits EventArgs
[C#]
public class InstallEventArgs : EventArgs
[C++]
public __gc class InstallEventArgs : public EventArgs
[JScript]
public class InstallEventArgs extends EventArgs

Remarks

InstallEventArgs contains an IDictionary with information about the current state of the installation. This information is used by the event-handling methods of the OnBeforeInstall, OnAfterInstall, OnBeforeCommit, OnAfterCommit, OnBeforeRollback, OnAfterRollback, OnBeforeUninstall, and OnAfterInstall events.

Requirements

Namespace: System.Configuration.Install

Assembly: System.Configuration.Install.dll

See Also

InstallEventArgs Members | System.Configuration.Install Namespace | InstallEventHandler | Installer | OnBeforeInstall | OnAfterInstall | OnBeforeCommit | OnAfterCommit | OnBeforeRollback | OnAfterRollback | OnBeforeUninstall | OnAfterUninstall | Install | Commit | Rollback | Uninstall


InstallEventArgs Members

Public:

Constructor

InstallEventArgs Constructor Overloaded. Initializes a new instance of the InstallEventArgs class.

Properties

ExtendedInfo (inherited from EventArgs) Holds a reference to an object that manages the event's state.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

SavedState An IDictionary that represents the current state of the installation.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InstallEventArgs Class | System.Configuration.Install Namespace


InstallEventArgs Constructor

Initializes a new instance of the InstallEventArgs class.

Overload List

Initializes a new instance of the InstallEventArgs class, leaving the savedState field empty.

[Visual Basic] Overloads Public Sub New()
[C#] public InstallEventArgs();
[C++] public: InstallEventArgs();
[JScript] public function InstallEventArgs();

Initializes a new instance of the InstallEventArgs class, with the saved state parameter.

[Visual Basic] Overloads Public Sub New(IDictionary)
[C#] public InstallEventArgs(IDictionary);
[C++] public: InstallEventArgs(IDictionary*);
[JScript] public function InstallEventArgs(IDictionary);

See Also

InstallEventArgs Class | InstallEventArgs Members | System.Configuration.Install Namespace


InstallEventArgs Constructor ()

Initializes a new instance of the InstallEventArgs class, leaving the savedState field empty.

[Visual Basic]
Overloads Public Sub New()
[C#]
public InstallEventArgs();
[C++]
public: InstallEventArgs();
[JScript]
public function InstallEventArgs();

See Also

InstallEventArgs Class | InstallEventArgs Members | System.Configuration.Install Namespace | InstallEventArgs Constructor Overload List


InstallEventArgs Constructor (IDictionary)

Initializes a new instance of the InstallEventArgs class, with the saved state parameter.

[Visual Basic]
Overloads Public Sub New( _
   ByVal savedState As IDictionary _
)
[C#]
public InstallEventArgs(
   IDictionary savedState
);
[C++]
public: InstallEventArgs(
   IDictionary* savedState
);
[JScript]
public function InstallEventArgs(
   savedState : IDictionary
);

Parameters

savedState
An IDictionary that represents the current state of the installation.

See Also

InstallEventArgs Class | InstallEventArgs Members | System.Configuration.Install Namespace | InstallEventArgs Constructor Overload List


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

InstallEventArgs Fields

The fields of the InstallEventArgs class are listed below. For a complete list of InstallEventArgs class members, see the InstallEventArgs Members topic.

Public:

SavedState An IDictionary that represents the current state of the installation.

See Also

InstallEventArgs Class | System.Configuration.Install Namespace


InstallEventArgs.SavedState

An IDictionary that represents the current state of the installation.

[Visual Basic]
Public SavedState As IDictionary
[C#]
public IDictionary SavedState;
[C++]
public: IDictionary* SavedState;
[JScript]
public var SavedState : IDictionary;

See Also

InstallEventArgs Class | InstallEventArgs Members | System.Configuration.Install Namespace


InstallEventHandler Delegate

Represents the method that will handle the OnBeforeInstall event, or the OnAfterInstall event, or the OnBeforeCommit event, or the OnAfterCommit event, or the OnBeforeRollback event, or the OnAfterRollback event, or the OnBeforeUninstall event, or the OnAfterUninstall event of the Installer.

[Visual Basic]
Public Delegate Sub InstallEventHandler( _
   ByVal sender As Object, _
   ByVal e As InstallEventArgs _
)
[C#]
public delegate void InstallEventHandler(
   object sender,
   InstallEventArgs e
);
[C++]
public __gc __delegate void InstallEventHandler(
   Object* sender,
   InstallEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the InstallEventHandler delegate declaration.

sender
The source of the event.
e
An InstallEventArgs that contains the event data.

Remarks

When you create an InstallEventHandler delegate, you identify the method that will handle the event. To associate the event with your event-handling method, add an instance of the delegate to the event. The event-handling method is called whenever the event occurs, until you remove the delegate. For more information about delegates, see DelegateTopicTBD.

Requirements

Namespace: System.Configuration.Install

Assembly: System.Configuration.Install.dll

See Also

System.Configuration.Install Namespace | InstallEventArgs | Installer | OnBeforeInstall | OnAfterInstall | OnBeforeCommit | OnAfterCommit | OnBeforeRollback | OnAfterRollback | OnBeforeUninstall | OnAfterUninstall | Install | Commit | Rollback | Uninstall


InstallException Class

[To be supplied.]

Object
Exception
InstallException

[Visual Basic]
Public Class InstallException
   Inherits Exception
[C#]
public class InstallException : Exception
[C++]
public __gc class InstallException : public Exception
[JScript]
public class InstallException extends Exception

Remarks

[To be supplied.]

Requirements

Namespace: System.Configuration.Install

Assembly: System.Configuration.Install.dll

See Also

InstallException Members | System.Configuration.Install Namespace


InstallException Members

Public:

Constructor

InstallException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

InstallException Class | System.Configuration.Install Namespace


InstallException Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public InstallException();
[C++] public: InstallException();
[JScript] public function InstallException();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public InstallException(String);
[C++] public: InstallException(String*);
[JScript] public function InstallException(String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public InstallException(String, Exception);
[C++] public: InstallException(String*, Exception);
[JScript] public function InstallException(String, Exception);

See Also

InstallException Class | InstallException Members | System.Configuration.Install Namespace


InstallException Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public InstallException();
[C++]
public: InstallException();
[JScript]
public function InstallException();

See Also

InstallException Class | InstallException Members | System.Configuration.Install Namespace | InstallException Constructor Overload List


InstallException Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public InstallException(
   string message
);
[C++]
public: InstallException(
   String* message
);
[JScript]
public function InstallException(
   message : String
);

Parameters

message
[To be supplied.]

See Also

InstallException Class | InstallException Members | System.Configuration.Install Namespace | InstallException Constructor Overload List


InstallException Constructor (String, Exception)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InstallException(
   string message,
   Exception innerException
);
[C++]
public: InstallException(
   String* message,
   Exception* innerException
);
[JScript]
public function InstallException(
   message : String,
   innerException : Exception
);

Parameters

message
[To be supplied.]
innerException
[To be supplied.]

See Also

InstallException Class | InstallException Members | System.Configuration.Install Namespace | InstallException Constructor Overload List


TransactedInstaller Class

A transacted install will either completely succeed or fail and leave the machine in its initial state. To run installers in a transaction, add them to the Installers collection of this class.

Object
Component
Installer
TransactedInstaller

[Visual Basic]
Public Class TransactedInstaller
   Inherits Installer
[C#]
public class TransactedInstaller : Installer
[C++]
public __gc class TransactedInstaller : public Installer
[JScript]
public class TransactedInstaller extends Installer

Remarks

[To be supplied.]

Requirements

Namespace: System.Configuration.Install

Assembly: System.Configuration.Install.dll

See Also

TransactedInstaller Members | System.Configuration.Install Namespace


TransactedInstaller Members

Public:

Constructor

TransactedInstaller Constructor [To be supplied.]

Properties

Context (inherited from Installer) | Gets or sets information about the current installation.
HelpText (inherited from Installer) | Gets the help text for all of the Installer objects contained in the Installers collection of this installer instance.
Installers (inherited from Installer) | Gets the collection of Installer objects contained in this Installer instance.
Parent (inherited from Installer) | Gets or sets the Installer whose InstallerCollection contains this Installer instance.
Site (inherited from Component) | Gets or sets the site of the Component.

Methods

Commit (inherited from Installer) | Completes the install transaction.
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Install | [To be supplied.]
Rollback (inherited from Installer) | Restores the machine to the state it was in before the Install method was called.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
Uninstall | [To be supplied.]

Events

AfterCommit (inherited from Installer) | Occurs after the installations handled by the installers in the InstallerCollection of this instance are committed.
AfterInstall (inherited from Installer) | Occurs after the Install methods of all the installers in the InstallerCollection of this instance have run.
AfterRollback (inherited from Installer) | Occurs after the installations handled by the installers in the InstallerCollection of this instance are rolled back.
AfterUninstall (inherited from Installer) | Occurs after the installations handled by the installers in the InstallerCollection of this instance are uninstalled.
BeforeCommit (inherited from Installer) | Occurs before the installations handled by the installers in the InstallerCollection of this instance are committed.
BeforeInstall (inherited from Installer) | Occurs before the installers in the InstallerCollection of this instance are run.
BeforeRollback (inherited from Installer) | Occurs before the installations handled by the installers in the InstallerCollection of this instance are rolled back.
BeforeUninstall (inherited from Installer) | Occurs before the installations handled by the installers in the InstallerCollection of this instance are uninstalled.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCommit (inherited from Installer) | Raises the OnAfterCommit event.
OnAfterInstall (inherited from Installer) | Raises the OnAfterInstall event.
OnAfterRollback (inherited from Installer) | Raises the OnAfterRollback event.
OnAfterUninstall (inherited from Installer) | Raises the OnAfterUninstall event.
OnBeforeCommit (inherited from Installer) | Raises the OnBeforeCommit event.
OnBeforeInstall (inherited from Installer) | Raises the OnBeforeInstall event.
OnBeforeRollback (inherited from Installer) | Raises the OnBeforeRollback event.
OnBeforeUninstall (inherited from Installer) | Raises the OnBeforeUninstall event.

Event Hookup:

Methods

AddOnAfterCommit (inherited from Installer) | [To be supplied.]
AddOnAfterInstall (inherited from Installer) | [To be supplied.]
AddOnAfterRollback (inherited from Installer) | [To be supplied.]
AddOnAfterUninstall (inherited from Installer) | [To be supplied.]
AddOnBeforeCommit (inherited from Installer) | [To be supplied.]
AddOnBeforeInstall (inherited from Installer) | [To be supplied.]
AddOnBeforeRollback (inherited from Installer) | [To be supplied.]
AddOnBeforeUninstall (inherited from Installer) | [To be supplied.]
RemoveOnAfterCommit (inherited from Installer) | [To be supplied.]
RemoveOnAfterInstall (inherited from Installer) | [To be supplied.]
RemoveOnAfterRollback (inherited from Installer) | [To be supplied.]
RemoveOnAfterUninstall (inherited from Installer) | [To be supplied.]
RemoveOnBeforeCommit (inherited from Installer) | [To be supplied.]
RemoveOnBeforeInstall (inherited from Installer) | [To be supplied.]
RemoveOnBeforeRollback (inherited from Installer) | [To be supplied.]
RemoveOnBeforeUninstall (inherited from Installer) | [To be supplied.]

See Also

TransactedInstaller Class | System.Configuration.Install Namespace


TransactedInstaller Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public TransactedInstaller();
[C++]
public: TransactedInstaller();
[JScript]
public function TransactedInstaller();

See Also

TransactedInstaller Class | TransactedInstaller Members | System.Configuration.Install Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TransactedInstaller Methods

The methods of the TransactedInstaller class are listed below. For a complete list of TransactedInstaller class members, see the TransactedInstaller Members topic.

Public:

Commit (inherited from Installer) | Completes the install transaction.
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Install | [To be supplied.]
Rollback (inherited from Installer) | Restores the machine to the state it was in before the Install method was called.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
Uninstall | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCommit (inherited from Installer) | Raises the OnAfterCommit event.
OnAfterInstall (inherited from Installer) | Raises the OnAfterInstall event.
OnAfterRollback (inherited from Installer) | Raises the OnAfterRollback event.
OnAfterUninstall (inherited from Installer) | Raises the OnAfterUninstall event.
OnBeforeCommit (inherited from Installer) | Raises the OnBeforeCommit event.
OnBeforeInstall (inherited from Installer) | Raises the OnBeforeInstall event.
OnBeforeRollback (inherited from Installer) | Raises the OnBeforeRollback event.
OnBeforeUninstall (inherited from Installer) | Raises the OnBeforeUninstall event.

Event Hookup:

AddOnAfterCommit (inherited from Installer) | [To be supplied.]
AddOnAfterInstall (inherited from Installer) | [To be supplied.]
AddOnAfterRollback (inherited from Installer) | [To be supplied.]
AddOnAfterUninstall (inherited from Installer) | [To be supplied.]
AddOnBeforeCommit (inherited from Installer) | [To be supplied.]
AddOnBeforeInstall (inherited from Installer) | [To be supplied.]
AddOnBeforeRollback (inherited from Installer) | [To be supplied.]
AddOnBeforeUninstall (inherited from Installer) | [To be supplied.]
RemoveOnAfterCommit (inherited from Installer) | [To be supplied.]
RemoveOnAfterInstall (inherited from Installer) | [To be supplied.]
RemoveOnAfterRollback (inherited from Installer) | [To be supplied.]
RemoveOnAfterUninstall (inherited from Installer) | [To be supplied.]
RemoveOnBeforeCommit (inherited from Installer) | [To be supplied.]
RemoveOnBeforeInstall (inherited from Installer) | [To be supplied.]
RemoveOnBeforeRollback (inherited from Installer) | [To be supplied.]
RemoveOnBeforeUninstall (inherited from Installer) | [To be supplied.]

See Also

TransactedInstaller Class | System.Configuration.Install Namespace


TransactedInstaller.Install

[To be supplied.]

[Visual Basic]
Overrides Public Sub Install( _
   ByVal savedState As IDictionary _
)
[C#]
public override void Install(
   IDictionary savedState
);
[C++]
public: override void Install(
   IDictionary* savedState
);
[JScript]
public override function Install(
   savedState : IDictionary
);

Parameters

savedState
[To be supplied.]

See Also

TransactedInstaller Class | TransactedInstaller Members | System.Configuration.Install Namespace


TransactedInstaller.Uninstall

[To be supplied.]

[Visual Basic]
Overrides Public Sub Uninstall( _
   ByVal savedState As IDictionary _
)
[C#]
public override void Uninstall(
   IDictionary savedState
);
[C++]
public: override void Uninstall(
   IDictionary* savedState
);
[JScript]
public override function Uninstall(
   savedState : IDictionary
);

Parameters

savedState
[To be supplied.]

See Also

TransactedInstaller Class | TransactedInstaller Members | System.Configuration.Install Namespace


UninstallAction Enumeration

An enum of what an installer can do at uninstall time. It can either remove the resource it created, restore the resource to its state before Install, or do nothing (leaving the resource as installed).

[Visual Basic]
Public Enum UninstallAction
[C#]
public enum UninstallAction
[C++]
public enum UninstallAction

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
NoAction | [To be supplied.]
Remove | [To be supplied.]

Requirements

Namespace: System.Configuration.Install

Assembly: System.Configuration.Install.dll

See Also

System.Configuration.Install Namespace


WfcInstallContext Class

Provides context information for installations invoked through WFCInstall.exe.

Object
InstallContext
WfcInstallContext

[Visual Basic]
Public Class WfcInstallContext
   Inherits InstallContext
[C#]
public class WfcInstallContext : InstallContext
[C++]
public __gc class WfcInstallContext : public InstallContext
[JScript]
public class WfcInstallContext extends InstallContext

Remarks

[To be supplied.]

Requirements

Namespace: System.Configuration.Install

Assembly: System.Configuration.Install.dll

See Also

WfcInstallContext Members | System.Configuration.Install Namespace


WfcInstallContext Members

Public:

Constructor

WfcInstallContext Constructor Initializes a new instance of the WfcInstallContext class.

Properties

Host | [To be supplied.]
Parameters | Contains command-line arguments passed to the TBD that is using this WfcInstallContext.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsParameterTrue (inherited from InstallContext) | Determines whether the specified command line parameter is true.
LogMessage | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WfcInstallContext Class | System.Configuration.Install Namespace


WfcInstallContext Constructor

Initializes a new instance of the WfcInstallContext class.

[Visual Basic]
Public Sub New( _
   ByVal logFilePath As String, _
   ByVal commandLine() As String _
)
[C#]
public WfcInstallContext(
   string logFilePath,
   string[] commandLine
);
[C++]
public: WfcInstallContext(
   String* logFilePath,
   String* commandLine[]
);
[JScript]
public function WfcInstallContext(
   logFilePath : String,
   commandLine : String[]
);

Parameters

logFilePath
The path to the log file for this installation, or a null reference (in Visual Basic Nothing).
commandLine
The command line parameters entered when WfcInstall.exe was run.

Remarks

A log file is created over the given path, andis parsed into Parameters. Typically, a WfcInstallContext would be created by WfcInstall.exe. No log file is created if a command line argument of "/logfile=" is passed

See Also

WfcInstallContext Class | WfcInstallContext Members | System.Configuration.Install Namespace | Parameters


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

WfcInstallContext Properties

The properties of the WfcInstallContext class are listed below. For a complete list of WfcInstallContext class members, see the WfcInstallContext Members topic.

Public:

Host | [To be supplied.]
Parameters | Contains command-line arguments passed to the TBD that is using this WfcInstallContext.

See Also

WfcInstallContext Class | System.Configuration.Install Namespace


WfcInstallContext.Host

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Host As Object
[C#]
public object Host {override get;}
[C++]
public: __property virtual Object* get_Host();
[JScript]
public function get Host() : Object;

See Also

WfcInstallContext Class | WfcInstallContext Members | System.Configuration.Install Namespace


WfcInstallContext.Parameters

Contains command-line arguments passed to the TBD that is using this WfcInstallContext.

[Visual Basic]
Overridable Public ReadOnly Property Parameters As StringDictionary
[C#]
public StringDictionary Parameters {override get;}
[C++]
public: __property virtual StringDictionary* get_Parameters();
[JScript]
public function get Parameters() : StringDictionary;

Remarks

Key is of type string, Value also of type string

See Also

WfcInstallContext Class | WfcInstallContext Members | System.Configuration.Install Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

WfcInstallContext Methods

The methods of the WfcInstallContext class are listed below. For a complete list of WfcInstallContext class members, see the WfcInstallContext Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsParameterTrue (inherited from InstallContext) | Determines whether the specified command line parameter is true.
LogMessage | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WfcInstallContext Class | System.Configuration.Install Namespace


WfcInstallContext.Finalize

[To be supplied.]

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

WfcInstallContext Class | WfcInstallContext Members | System.Configuration.Install Namespace


WfcInstallContext.LogMessage

[To be supplied.]

[Visual Basic]
Overrides Public Sub LogMessage( _
   ByVal message As String _
)
[C#]
public override void LogMessage(
   string message
);
[C++]
public: override void LogMessage(
   String* message
);
[JScript]
public override function LogMessage(
   message : String
);

Parameters

message
[To be supplied.]

See Also

WfcInstallContext Class | WfcInstallContext Members | System.Configuration.Install Namespace


System.Configuration.Interceptors

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Configuration.Interceptors Namespace

Classes

Class | Description
HttpFileSelector | A selector that represents a pair of HttpSelector and FileSelector. Used together with Interceptors.ListSelector for configuration file hierarchy computations (see Interceptors.IConfigTransformer for details/examples).
ListAppend | Used by the configuration system to merge configuration information from multiple configuration files by appending the configuration info from the child file after the information from the parent file.
ListMerge | Used by the configuration system to merge configuration information from multiple configuration files by replacing any matching configuration info from the parent file with information from the child file.
ListPrepend | Used by the configuration system to merge configuration information from multiple configuration files by inserting the configuration info from the child file before the information from the parent file.
ListSelector | A selector that represents a list of Interceptors.HttpFileSelector. Used for configuration file hierarchy computations (see Interceptors.IConfigTransformer for details/examples).
NativeCatalogInterceptor | Reads and writes XML configuration files. Used internally by the configuration system.
PropertyOverride | Used by the configuration system to merge configuration information from multiple configuration files by changing a single configuration info to carry the properties from the innermost configuration file. This effectively implements configuration inheritance from parent to child.

Interfaces

Interface | Description
IConfigMerger | Implemented by platform and application developers that need to define their own merging logic when computing merges across a configuration file hierarchy.
IConfigReader | Implemented by platform and application developers that need to store their configuration information in their own configuration store.
IConfigTransformer | Implemented by platform and application developers that need to define their own configuration file hierarchy.

Structures

Structure | Description
RequestParams | Used in Interceptors.IConfigTransformer to capture the modified set of parameters.

Enumerations

Enumeration | Description
ListMergeDirective | Defines the set of directives interpreted by the Interceptors.ListMerge interceptor.


HttpFileSelector Class

A selector that represents a pair of HttpSelector and FileSelector. Used together with Interceptors.ListSelector for configuration file hierarchy computations (see Interceptors.IConfigTransformer for details/examples).

Object
Selector
HttpFileSelector

[Visual Basic]
Public Class HttpFileSelector
   Inherits Selector
[C#]
public class HttpFileSelector : Selector
[C++]
public __gc class HttpFileSelector : public Selector
[JScript]
public class HttpFileSelector extends Selector

Remarks

The HttpSelector usually represents the logical name for a configuration file (or node in the hierarchy), while the FileSelector represents the physical location of the configuration file for a node in the hierarchy).

Requirements

Namespace: System.Configuration.Interceptors

Assembly: System.Configuration.dll

See Also

HttpFileSelector Members | System.Configuration.Interceptors Namespace


HttpFileSelector Members

Public:

Constructor

HttpFileSelector Constructor [To be supplied.]

Properties

FileSelector | [To be supplied.]
HttpSelector | [To be supplied.]
Prefix | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HttpFileSelector Class | System.Configuration.Interceptors Namespace


HttpFileSelector Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal url As HttpSelector, _
   ByVal unc As FileSelector _
)
[C#]
public HttpFileSelector(
   HttpSelector url,
   FileSelector unc
);
[C++]
public: HttpFileSelector(
   HttpSelector* url,
   FileSelector* unc
);
[JScript]
public function HttpFileSelector(
   url : HttpSelector,
   unc : FileSelector
);

Parameters

url
[To be supplied.]
unc
[To be supplied.]

See Also

HttpFileSelector Class | HttpFileSelector Members | System.Configuration.Interceptors Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

HttpFileSelector Properties

The properties of the HttpFileSelector class are listed below. For a complete list of HttpFileSelector class members, see the HttpFileSelector Members topic.

Public:

FileSelector | [To be supplied.]
HttpSelector | [To be supplied.]
Prefix | [To be supplied.]

See Also

HttpFileSelector Class | System.Configuration.Interceptors Namespace


HttpFileSelector.FileSelector

[To be supplied.]

[Visual Basic]
Public Property FileSelector As FileSelector
[C#]
public FileSelector FileSelector {get; set;}
[C++]
public: __property FileSelector* get_FileSelector();
public: __property void set_FileSelector(FileSelector*);
[JScript]
public function get FileSelector() : FileSelector;
public function set FileSelector(FileSelector);

See Also

HttpFileSelector Class | HttpFileSelector Members | System.Configuration.Interceptors Namespace


HttpFileSelector.HttpSelector

[To be supplied.]

[Visual Basic]
Public Property HttpSelector As HttpSelector
[C#]
public HttpSelector HttpSelector {get; set;}
[C++]
public: __property HttpSelector* get_HttpSelector();
public: __property void set_HttpSelector(HttpSelector*);
[JScript]
public function get HttpSelector() : HttpSelector;
public function set HttpSelector(HttpSelector);

See Also

HttpFileSelector Class | HttpFileSelector Members | System.Configuration.Interceptors Namespace


HttpFileSelector.Prefix

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Prefix As String
[C#]
public string Prefix {override get;}
[C++]
public: __property virtual String* get_Prefix();
[JScript]
public function get Prefix() : String;

See Also

HttpFileSelector Class | HttpFileSelector Members | System.Configuration.Interceptors Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

HttpFileSelector Methods

The methods of the HttpFileSelector class are listed below. For a complete list of HttpFileSelector class members, see the HttpFileSelector Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HttpFileSelector Class | System.Configuration.Interceptors Namespace


HttpFileSelector.ToString

[To be supplied.]

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

HttpFileSelector Class | HttpFileSelector Members | System.Configuration.Interceptors Namespace


IConfigMerger Interface

Implemented by platform and application developers that need to define their own merging logic when computing merges across a configuration file hierarchy.

IConfigMerger

[Visual Basic]
Public Interface IConfigMerger
[C#]
public interface IConfigMerger
[C++]
public __gc __interface IConfigMerger

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IConfigMerger

Class | Description
Interceptors.ListAppend | Used by the configuration system to merge configuration information from multiple configuration files by appending the configuration info from the child file after the information from the parent file.
Interceptors.ListMerge | Used by the configuration system to merge configuration information from multiple configuration files by replacing any matching configuration info from the parent file with information from the child file.
Interceptors.ListPrepend | Used by the configuration system to merge configuration information from multiple configuration files by inserting the configuration info from the child file before the information from the parent file.
Interceptors.PropertyOverride | Used by the configuration system to merge configuration information from multiple configuration files by changing a single configuration info to carry the properties from the innermost configuration file. This effectively implements configuration inheritance from parent to child.

Remarks

Merges configuration information for a parent node with configuration information from a child node.

The ConfigManager invokes a merge interceptor (based on declarations in mwiring.xml) repeatedly for each pair of configuration files in the configuration file hierarchy.

A typical merge interceptor

  • Clones the parent collection.
  • Adds/merges configuration items from the child collection to the cloned parent collection.
  • Returns the cloned collection.

The Configuration System provides a set of commonly used merge interceptors (Interceptors.PropertyOverride, Interceptors.ListMerge, Interceptors.ListAppend, Interceptors.ListPrepend) that can be used to merge custom configuration information.

Refer to Interceptors.IConfigTransformer for an example of declaring a merge interceptor in conjunction with a hierarchy interceptor.

Requirements

Namespace: System.Configuration.Interceptors

Assembly: System.Configuration.dll

See Also

IConfigMerger Members | System.Configuration.Interceptors Namespace


IConfigMerger Members

Methods

Merger [To be supplied.]

See Also

IConfigMerger Interface | System.Configuration.Interceptors Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IConfigMerger Methods

The methods of the IConfigMerger interface are listed below. For a complete list of IConfigMerger interface members, see the IConfigMerger Members topic.

Merger [To be supplied.]

See Also

IConfigMerger Interface | System.Configuration.Interceptors Namespace


IConfigMerger.Merger

[To be supplied.]

[Visual Basic]
Function Merger( _
   ByVal parent As Object, _
   ByVal child As Object, _
   ByVal ConfigType As String, _
   ByVal selector As Selector, _
   ByVal los As Integer _
) As Object
[C#]
object Merger(
   object parent,
   object child,
   string ConfigType,
   Selector selector,
   int los
);
[C++]
Object* Merger(
   Object* parent,
   Object* child,
   String* ConfigType,
   Selector* selector,
   int los
) = 0;
[JScript]
function Merger(
   parent : Object,
   child : Object,
   ConfigType : String,
   selector : Selector,
   los : int
) : Object;

Parameters

parent
Configuration information from any parent files. Typically implements IConfigCollection.
child
[To be supplied.]
ConfigType
[To be supplied.]
selector
[To be supplied.]
los
[To be supplied.]

See Also

IConfigMerger Interface | IConfigMerger Members | System.Configuration.Interceptors Namespace


IConfigReader Interface

Implemented by platform and application developers that need to store their configuration information in their own configuration store.

IConfigReader

[Visual Basic]
Public Interface IConfigReader
[C#]
public interface IConfigReader
[C++]
public __gc __interface IConfigReader

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IConfigReader

Class | Description
Interceptors.NativeCatalogInterceptor | Reads and writes XML configuration files. Used internally by the configuration system.

Remarks

Reads configuration information from a configuration store.

A typical configuration read interceptor

  • creates an empty configuration collection by invoking GetEmptyConfigCollection.
  • creates an empty configuration item for each piece of configuration information by invoking GetEmptyConfigItem.
  • writes the data into the configuration item using IConfigItem methods.
  • adds the item to the configuration collection using Add.
  • returns the configuration collection.

Configuration interceptors must be declared in the MWIRING.XML file in the machine configuration directory. Refer to Interceptors.IConfigTransformer for an example.

Requirements

Namespace: System.Configuration.Interceptors

Assembly: System.Configuration.dll

See Also

IConfigReader Members | System.Configuration.Interceptors Namespace


IConfigReader Members

Methods

Read [To be supplied.]

See Also

IConfigReader Interface | System.Configuration.Interceptors Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IConfigReader Methods

The methods of the IConfigReader interface are listed below. For a complete list of IConfigReader interface members, see the IConfigReader Members topic.

Read [To be supplied.]

See Also

IConfigReader Interface | System.Configuration.Interceptors Namespace


IConfigReader.Read

[To be supplied.]

[Visual Basic]
Function Read( _
   ByVal configType As String, _
   ByVal selector As Selector, _
   ByVal los As Integer, _
   ByVal currentObject As Object _
) As Object
[C#]
object Read(
   string configType,
   Selector selector,
   int los,
   object currentObject
);
[C++]
Object* Read(
   String* configType,
   Selector* selector,
   int los,
   Object* currentObject
) = 0;
[JScript]
function Read(
   configType : String,
   selector : Selector,
   los : int,
   currentObject : Object
) : Object;

Parameters

configType
[To be supplied.]
selector
[To be supplied.]
los
[To be supplied.]
currentObject
[To be supplied.]

See Also

IConfigReader Interface | IConfigReader Members | System.Configuration.Interceptors Namespace


IConfigTransformer Interface

Implemented by platform and application developers that need to define their own configuration file hierarchy.

IConfigTransformer

[Visual Basic]
Public Interface IConfigTransformer
[C#]
public interface IConfigTransformer
[C++]
public __gc __interface IConfigTransformer

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

Transforms a request for configuration information into any other configuration request.

A use for transformer interceptors is a simple mapping of logical names (Selectors) to physical names.

Another common use for transformer interceptors is the computation of a hierarchy of configuration files: the interceptor receives the request for a simple selector (i.e. a FileSelector or HttpSelector) and turns it into a Interceptors.ListSelector. The ListSelector contains an ordered list of other Selector instances, that represent the result of the hierarchy computation. When the ConfigManager receives a ListSelector, it retrieves the configuration information (IConfigCollection) for each of the selectors in the list, and then invokes an Interceptors.IConfigMerger on pairs of configuration collections.

In order for the ConfigManager to be able to invoke interceptors, they must be declared in the MWIRING.XML file in the machine configuration directory. The MWIRING.XML file contains mappings of ConfigType and selector prefix to one or more interceptors to invoke for this combination.

Requirements

Namespace: System.Configuration.Interceptors

Assembly: System.Configuration.dll

Example [C#]

This example Web Server hierarchy interceptor computes the location of config.web files across the hierarchy of a URL, using IIS metabase information to perform URL to file name mapping:

[C#]

namespace Microsoft.Configuration.Samples {

using System;
using System.Configuration;
using System.Configuration.Interceptors;
using System.Configuration.Internal;
using System.DirectoryServices;
using System.Web;

using Microsoft.Configuration.Samples;

public class WebHierarchyInterceptor : IConfigTransformer {

    public RequestParams Transform(String configType, Selector selector, int los){

HttpFileSelector urlunc = null;

RequestParams reqparam = new RequestParams();
reqparam.configType = configType;
reqparam.selector   = new ListSelector();
reqparam.los        = los;

String url = ((HttpSelector)selector).ToString();

String[] Urls = IISAdminHelper.GetParentUrlsForUrl(url);
String[] UNCs = IISAdminHelper.GetParentPathsForUrl(url);

// Add the machine config file location
urlunc = new HttpFileSelector(
    new HttpSelector(Urls[0]),
    new FileSelector("file://"+ConfigManagerHelper.GetMachineConfigDirectory() +"..\\config.web"));

Console.WriteLine("Adding: "+urlunc);
((ListSelector)(reqparam.selector)).Add(urlunc);

for (int i=0; i<Urls.Length; i++) {
    urlunc = new HttpFileSelector(new HttpSelector(Urls[i]), new FileSelector("file://"+UNCs[i]+"\\config.web"));
    Console.WriteLine("Adding: "+urlunc);
    ((ListSelector)(reqparam.selector)).Add(urlunc);
}

return reqparam;

        } // Transform

    } // class Hierarchy Interceptor

}

namespace Microsoft.Configuration.Samples {

using System;
using System.Configuration.Internal;
using System.DirectoryServices;
using System.Web;

/// <summary>
///    <para>
///       This class facilitates access to the IIS Metabase
///    </para>
/// </summary>
public class IISAdminHelper {

    /// <summary>
    ///    <para>
    ///      Returns the SiteID for a URL
    ///    </para>
    /// </summary>
    public static int GetSiteIDForUrl(String Url) {
        // TODO: Look up ServerBindings to get other than the default Site
        return 1;
    }

    /// <summary>
    ///    <para>
    ///      Returns the physical path for a URL based on IIS metabase configuration
    ///    </para>
    /// </summary>
    public static String GetPathForUrl(String Url) {
        String relUrl= new HttpUrl(Url).Path;
        String relPath="";
        String LastVDIR = null;
        int lastPathElement = 0;

        String MBRootPath = "IIS://LocalHost/W3SVC/"+GetSiteIDForUrl(Url)+"/ROOT";

        DirectoryEntry d = new DirectoryEntry();

        while (true) {

d.Path=MBRootPath;
if (relUrl!="/") d.Path=d.Path+relUrl;

LastVDIR = null;
try {
    LastVDIR = (String) d.Properties["Path"].Value;
}
catch {
    LastVDIR= null;
}

if (LastVDIR != null) {
    if (LastVDIR.EndsWith("\\")) {
        return LastVDIR + relPath.Substring(1);
    }
    return LastVDIR + relPath;
}

lastPathElement=relUrl.LastIndexOf('/');
if (lastPathElement>=0) {
    relPath="\\"+relUrl.Substring(lastPathElement+1)+relPath;
    relUrl=relUrl.Substring(0,lastPathElement);
}
else
{
    throw(new ApplicationException("No physical directory defined for Url " + Url));
}
        }
    }

    /// <summary>
    ///    <para>
    ///      Returns the machince configuration file, the physical paths for all parent nodes of a Url and the URL itself
    ///    </para>
    /// </summary>
    public static String[] GetParentPathsForUrl(String Url) {

        String[] parentUrls = GetParentUrlsForUrl(Url);

        String[] parentPaths = new String[parentUrls.Length];

        for (int i=0; i<parentUrls.Length; i++) {
parentPaths[i]=GetPathForUrl(parentUrls[i]);
        }
        return parentPaths;
    }

    /// <summary>
    ///    <para>
    ///      Returns the parent URLs for a URL.
    ///    </para>
    ///    <example>
    ///      Example:
    ///        GetParentUrlsForUrl("http://foo/bar/zee"), returns an array containing "http://foo", "http://foo/bar", "http://foo/bar/zee".
    ///    </example>
    /// </summary>
    public static String[] GetParentUrlsForUrl(String Url) {
        int i=0;
        HttpUrl parsedUrl = null;
        HttpUrl nextUrl = null;
        String pathToParse=null;
        String pathEaten="";
        int firstPathElement=0;

        // BUGBUG make this work for arbitrary URLs...
        String[] Urls = new String[100];

        parsedUrl = new HttpUrl(Url);
        pathToParse = parsedUrl.Path;

        i=0;

        //pathToParse=pathToParse.Substring(1); // skip initial "/"
        nextUrl = new HttpUrl(parsedUrl.Protocol, parsedUrl.Host, parsedUrl.Port, pathEaten, null, null);
        Urls[i]=nextUrl.ToString();
        i++;

        if (pathToParse!="/") {
while (pathToParse!=null) {

    firstPathElement=pathToParse.IndexOf('/',1);
    Console.WriteLine(":"+pathToParse+":"+pathEaten+":"+firstPathElement);
    if (firstPathElement>=0) {
        pathEaten=pathEaten+pathToParse.Substring(0, firstPathElement);
        pathToParse=pathToParse.Substring(firstPathElement);
    }
    else
    {
        pathEaten=pathEaten+pathToParse;
        pathToParse=null;
    }
    nextUrl = new HttpUrl(parsedUrl.Protocol, parsedUrl.Host, parsedUrl.Port, pathEaten, null, null);
    Urls[i]=nextUrl.ToString();
    i++;
}
        }

        String[] urlresult = new String[i];
        //BUGBUG use
        // Copy(urlresult, Urls, i) as soon as it becomes available
        for (int j=0; j<i; j++) {
urlresult[j]=Urls[j];
        }
        return urlresult;
    }
}

}

MWIRING.XML entries:

<?xml version="1.0"?>
<configuration xmlns="x-schema:catalog.xms">

    <ManagedWiring>

        <Intercept  ConfigType="httphandlers" Protocol="http" Order="1"
        InterceptorClass="Microsoft.Configuration.Samples.WebHierarchyInterceptor"
        InterceptorType="Transformer" />
        <Intercept  ConfigType="httphandlers" Protocol="list" Order="2"
        InterceptorClass="System.Configuration.Interceptors.ListMerge"
        InterceptorType="Merger" />

    </ManagedWiring>

</configuration>

Place config.web files into the root directory of the default web site (typically c:\inetpub\wwwroot\config.web) and any subdirectories:

<configuration>

    <httphandlers>
        <remove verb="DEBUG" path="*" />
        <remove verb="*" path="trace.axd" />
    </httphandlers>

</configuration>

You can now run the following code to retrieve the httphandlers for a specific URL node, even when not running within an ASP+ request:

[C#]

using System.Configuration;
using System.Configuration.Core;

IConfigCollection httphandlers= ConfigManager.Get("httphandlers", "http://localhost");
foreach (System.Configuration.Web.HttpHandler handler in httphandlers)
{
  Console.WriteLine(handler.verb + handler.path + handler.type);
}

See Also

IConfigTransformer Members | System.Configuration.Interceptors Namespace


IConfigTransformer Members

Methods

Transform [To be supplied.]

See Also

IConfigTransformer Interface | System.Configuration.Interceptors Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IConfigTransformer Methods

The methods of the IConfigTransformer interface are listed below. For a complete list of IConfigTransformer interface members, see the IConfigTransformer Members topic.

Transform [To be supplied.]

See Also

IConfigTransformer Interface | System.Configuration.Interceptors Namespace


IConfigTransformer.Transform

[To be supplied.]

[Visual Basic]
Function Transform( _
   ByVal configType As String, _
   ByVal selector As Selector, _
   ByVal los As Integer _
) As RequestParams
[C#]
RequestParams Transform(
   string configType,
   Selector selector,
   int los
);
[C++]
RequestParams Transform(
   String* configType,
   Selector* selector,
   int los
) = 0;
[JScript]
function Transform(
   configType : String,
   selector : Selector,
   los : int
) : RequestParams;

Parameters

configType
[To be supplied.]
selector
[To be supplied.]
los
[To be supplied.]

See Also

IConfigTransformer Interface | IConfigTransformer Members | System.Configuration.Interceptors Namespace


ListAppend Class

Used by the configuration system to merge configuration information from multiple configuration files by appending the configuration info from the child file after the information from the parent file.

Object
ListAppend

[Visual Basic]
Public Class ListAppend
   Implements IConfigMerger
[C#]
public class ListAppend : IConfigMerger
[C++]
public __gc class ListAppend : public IConfigMerger
[JScript]
public class ListAppend implements IConfigMerger

Remarks

Refer to Interceptors.IConfigMerger for more information.

Requirements

Namespace: System.Configuration.Interceptors

Assembly: System.Configuration.dll

See Also

ListAppend Members | System.Configuration.Interceptors Namespace


ListAppend Members

Public:

Constructor

ListAppend Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Merger | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ListAppend Class | System.Configuration.Interceptors Namespace


ListAppend Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ListAppend();
[C++]
public: ListAppend();
[JScript]
public function ListAppend();

See Also

ListAppend Class | ListAppend Members | System.Configuration.Interceptors Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ListAppend Methods

The methods of the ListAppend class are listed below. For a complete list of ListAppend class members, see the ListAppend Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Merger | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ListAppend Class | System.Configuration.Interceptors Namespace


ListAppend.Merger

[To be supplied.]

[Visual Basic]
Overridable Public Function Merger( _
   ByVal parent As Object, _
   ByVal child As Object, _
   ByVal configType As String, _
   ByVal selector As Selector, _
   ByVal los As Integer _
) As Object
[C#]
public virtual object Merger(
   object parent,
   object child,
   string configType,
   Selector selector,
   int los
);
[C++]
public: virtual Object* Merger(
   Object* parent,
   Object* child,
   String* configType,
   Selector* selector,
   int los
);
[JScript]
public function Merger(
   parent : Object,
   child : Object,
   configType : String,
   selector : Selector,
   los : int
) : Object;

Parameters

parent
[To be supplied.]
child
[To be supplied.]
configType
[To be supplied.]
selector
[To be supplied.]
los
[To be supplied.]

See Also

ListAppend Class | ListAppend Members | System.Configuration.Interceptors Namespace


ListMerge Class

Used by the configuration system to merge configuration information from multiple configuration files by replacing any matching configuration info from the parent file with information from the child file.

Object
ListMerge

[Visual Basic]
Public Class ListMerge
   Implements IConfigMerger
[C#]
public class ListMerge : IConfigMerger
[C++]
public __gc class ListMerge : public IConfigMerger
[JScript]
public class ListMerge implements IConfigMerger

Remarks

It uses the primary key definition in the ConfigType's schema to determine matches of configuration items. All primary key properties must be contiguous and start with property index 0.

The ListMerge interceptor optionally processes directives as declared in Interceptors.ListMergeDirective. The directive property must be the first property in the ConfigType (must have property index 0) and it must be declared as a primary key property for the ConfigType: it must be tagged with the MetaFlags="DIRECTIVE PRIMARYKEY" in the schema definition file for the ConfigType. The directive property must have Type="int32" and enumeration tags (<enum>) must be declared to match the values of Interceptors.ListMergeDirective.

Refer to Interceptors.IConfigMerger for more information on how to use merge interceptors with your own configuration information.

Requirements

Namespace: System.Configuration.Interceptors

Assembly: System.Configuration.dll

See Also

ListMerge Members | System.Configuration.Interceptors Namespace


ListMerge Members

Public:

Constructor

ListMerge Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Merger | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ListMerge Class | System.Configuration.Interceptors Namespace


ListMerge Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ListMerge();
[C++]
public: ListMerge();
[JScript]
public function ListMerge();

See Also

ListMerge Class | ListMerge Members | System.Configuration.Interceptors Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ListMerge Methods

The methods of the ListMerge class are listed below. For a complete list of ListMerge class members, see the ListMerge Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Merger | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ListMerge Class | System.Configuration.Interceptors Namespace


ListMerge.Merger

[To be supplied.]

[Visual Basic]
Overridable Public Function Merger( _
   ByVal parent As Object, _
   ByVal child As Object, _
   ByVal configType As String, _
   ByVal selector As Selector, _
   ByVal los As Integer _
) As Object
[C#]
public virtual object Merger(
   object parent,
   object child,
   string configType,
   Selector selector,
   int los
);
[C++]
public: virtual Object* Merger(
   Object* parent,
   Object* child,
   String* configType,
   Selector* selector,
   int los
);
[JScript]
public function Merger(
   parent : Object,
   child : Object,
   configType : String,
   selector : Selector,
   los : int
) : Object;

Parameters

parent
[To be supplied.]
child
[To be supplied.]
configType
[To be supplied.]
selector
[To be supplied.]
los
[To be supplied.]

See Also

ListMerge Class | ListMerge Members | System.Configuration.Interceptors Namespace


ListMergeDirective Enumeration

Defines the set of directives interpreted by the Interceptors.ListMerge interceptor.

[Visual Basic]
Public Enum ListMergeDirective
[C#]
public enum ListMergeDirective
[C++]
public enum ListMergeDirective

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Add | Adds this configuration item to the parent collection during merge. Replaces any configuration item with a matching primary key.
AddFinal | Adds a configuration item and enforces that child configuration files can not change any property in this item, not remove the item.
Append | Appends a configuration item at the end of the collection without performing any primary key matches.
Clear | Removes all configuration items in the configuration collection.
Final | Enforces that the entire configuration collection can not be changes by child configuration files.
Prepend | Inserts a configuration item at the beginning of the configuration collection without performing any primary key matching.
Remove | Removes a configuration item with a matching primary key from the configuration collection.
RemoveFinal | Not supported in the PDC release.
RemoveMultiple | Removes all configuration item with a matching primary key.

Requirements

Namespace: System.Configuration.Interceptors

Assembly: System.Configuration.dll

See Also

System.Configuration.Interceptors Namespace


ListPrepend Class

Used by the configuration system to merge configuration information from multiple configuration files by inserting the configuration info from the child file before the information from the parent file.

Object
ListPrepend

[Visual Basic]
Public Class ListPrepend
   Implements IConfigMerger
[C#]
public class ListPrepend : IConfigMerger
[C++]
public __gc class ListPrepend : public IConfigMerger
[JScript]
public class ListPrepend implements IConfigMerger

Remarks

Refer to Interceptors.IConfigMerger for more information.

Requirements

Namespace: System.Configuration.Interceptors

Assembly: System.Configuration.dll

See Also

ListPrepend Members | System.Configuration.Interceptors Namespace


ListPrepend Members

Public:

Constructor

ListPrepend Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Merger | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ListPrepend Class | System.Configuration.Interceptors Namespace


ListPrepend Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ListPrepend();
[C++]
public: ListPrepend();
[JScript]
public function ListPrepend();

See Also

ListPrepend Class | ListPrepend Members | System.Configuration.Interceptors Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ListPrepend Methods

The methods of the ListPrepend class are listed below. For a complete list of ListPrepend class members, see the ListPrepend Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Merger | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ListPrepend Class | System.Configuration.Interceptors Namespace


ListPrepend.Merger

[To be supplied.]

[Visual Basic]
Overridable Public Function Merger( _
   ByVal parent As Object, _
   ByVal child As Object, _
   ByVal configType As String, _
   ByVal selector As Selector, _
   ByVal los As Integer _
) As Object
[C#]
public virtual object Merger(
   object parent,
   object child,
   string configType,
   Selector selector,
   int los
);
[C++]
public: virtual Object* Merger(
   Object* parent,
   Object* child,
   String* configType,
   Selector* selector,
   int los
);
[JScript]
public function Merger(
   parent : Object,
   child : Object,
   configType : String,
   selector : Selector,
   los : int
) : Object;

Parameters

parent
[To be supplied.]
child
[To be supplied.]
configType
[To be supplied.]
selector
[To be supplied.]
los
[To be supplied.]

See Also

ListPrepend Class | ListPrepend Members | System.Configuration.Interceptors Namespace


ListSelector Class

A selector that represents a list of Interceptors.HttpFileSelector. Used for configuration file hierarchy computations (see Interceptors.IConfigTransformer for details/examples).

Object
Selector
ListSelector

[Visual Basic]
Public Class ListSelector
   Inherits Selector
[C#]
public class ListSelector : Selector
[C++]
public __gc class ListSelector : public Selector
[JScript]
public class ListSelector extends Selector

Remarks

The ListSelector usually a hierarchy of configuration files, where each selector in the list is in turn a Interceptors.HttpFileSelector (logical/physical name of the node). The ConfigManager processes a ListSelector by (conceptually):

  • Reading the configuration information for the first node using the FileSelector part of the first Interceptors.HttpFileSelector in the list.
  • Reading the configuration information for the next node (again using the FileSelector part).
  • Merging the parent configuration collection with the child configuration collection using the Interceptors.IConfigMerger declared (in MWIRING.XML) for this ConfigType.

Requirements

Namespace: System.Configuration.Interceptors

Assembly: System.Configuration.dll

See Also

ListSelector Members | System.Configuration.Interceptors Namespace


ListSelector Members

Public:

Constructor

ListSelector Constructor [To be supplied.]

Properties

Count | [To be supplied.]
Item | [To be supplied.] In C#, this member is the indexer for the ListSelector class.
Prefix | [To be supplied.]

Methods

Add | [To be supplied.]
Clear | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | [To be supplied.]
Insert | [To be supplied.]
Remove | [To be supplied.]
ToString | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ListSelector Class | System.Configuration.Interceptors Namespace


ListSelector Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ListSelector();
[C++]
public: ListSelector();
[JScript]
public function ListSelector();

See Also

ListSelector Class | ListSelector Members | System.Configuration.Interceptors Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ListSelector Properties

The properties of the ListSelector class are listed below. For a complete list of ListSelector class members, see the ListSelector Members topic.

Public:

Count | [To be supplied.]
Item | [To be supplied.] In C#, this member is the indexer for the ListSelector class.
Prefix | [To be supplied.]

See Also

ListSelector Class | System.Configuration.Interceptors Namespace


ListSelector.Count

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

See Also

ListSelector Class | ListSelector Members | System.Configuration.Interceptors Namespace


ListSelector.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the ListSelector class.

[Visual Basic]
Public Default Property Item( _
   ByVal Index As Integer _
) As HttpFileSelector
[C#]
public HttpFileSelector this[
   int Index
] {get; set;}
[C++]
public: __property HttpFileSelector* get_Item(
   int Index
);
public: __property void set_Item(
   int Index,
   HttpFileSelector*
);
[JScript]
returnValue = ListSelectorObject.Item(Index);
ListSelectorObject.Item(Index) = returnValue;
-or-
returnValue = ListSelectorObject(Index);
ListSelectorObject(Index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

Index
[To be supplied.]

Parameters [Visual Basic, C#, C++]

Index
[To be supplied.]

See Also

ListSelector Class | ListSelector Members | System.Configuration.Interceptors Namespace


ListSelector.Prefix

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Prefix As String
[C#]
public string Prefix {override get;}
[C++]
public: __property virtual String* get_Prefix();
[JScript]
public function get Prefix() : String;

See Also

ListSelector Class | ListSelector Members | System.Configuration.Interceptors Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ListSelector Methods

The methods of the ListSelector class are listed below. For a complete list of ListSelector class members, see the ListSelector Members topic.

Public:

Add | [To be supplied.]
Clear | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | [To be supplied.]
Insert | [To be supplied.]
Remove | [To be supplied.]
ToString | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ListSelector Class | System.Configuration.Interceptors Namespace


ListSelector.Add

[To be supplied.]

[Visual Basic]
Public Sub Add( _
   ByVal Item As HttpFileSelector _
)
[C#]
public void Add(
   HttpFileSelector Item
);
[C++]
public: void Add(
   HttpFileSelector* Item
);
[JScript]
public function Add(
   Item : HttpFileSelector
);

Parameters

Item
[To be supplied.]

See Also

ListSelector Class | ListSelector Members | System.Configuration.Interceptors Namespace


ListSelector.Clear

[To be supplied.]

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[JScript]
public function Clear();

See Also

ListSelector Class | ListSelector Members | System.Configuration.Interceptors Namespace


ListSelector.IndexOf

[To be supplied.]

[Visual Basic]
Public Function IndexOf( _
   ByVal Item As HttpFileSelector _
) As Integer
[C#]
public int IndexOf(
   HttpFileSelector Item
);
[C++]
public: int IndexOf(
   HttpFileSelector* Item
);
[JScript]
public function IndexOf(
   Item : HttpFileSelector
) : int;

Parameters

Item
[To be supplied.]

See Also

ListSelector Class | ListSelector Members | System.Configuration.Interceptors Namespace


ListSelector.Insert

[To be supplied.]

[Visual Basic]
Public Sub Insert( _
   ByVal Index As Integer, _
   ByVal Item As HttpFileSelector _
)
[C#]
public void Insert(
   int Index,
   HttpFileSelector Item
);
[C++]
public: void Insert(
   int Index,
   HttpFileSelector* Item
);
[JScript]
public function Insert(
   Index : int,
   Item : HttpFileSelector
);

Parameters

Index
[To be supplied.]
Item
[To be supplied.]

See Also

ListSelector Class | ListSelector Members | System.Configuration.Interceptors Namespace


ListSelector.Remove

[To be supplied.]

[Visual Basic]
Public Sub Remove( _
   ByVal Index As Integer _
)
[C#]
public void Remove(
   int Index
);
[C++]
public: void Remove(
   int Index
);
[JScript]
public function Remove(
   Index : int
);

Parameters

Index
[To be supplied.]

See Also

ListSelector Class | ListSelector Members | System.Configuration.Interceptors Namespace


ListSelector.ToString

[To be supplied.]

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

ListSelector Class | ListSelector Members | System.Configuration.Interceptors Namespace


NativeCatalogInterceptor Class

Reads and writes XML configuration files. Used internally by the configuration system.

Object
NativeCatalogInterceptor

[Visual Basic]
Public Class NativeCatalogInterceptor
   Implements IConfigReader
[C#]
public class NativeCatalogInterceptor : IConfigReader
[C++]
public __gc class NativeCatalogInterceptor : public IConfigReader
[JScript]
public class NativeCatalogInterceptor implements IConfigReader

Remarks

[To be supplied.]

Requirements

Namespace: System.Configuration.Interceptors

Assembly: System.Configuration.dll

See Also

NativeCatalogInterceptor Members | System.Configuration.Interceptors Namespace


NativeCatalogInterceptor Members

Public:

Constructor

NativeCatalogInterceptor Constructor [To be supplied.]

Methods

DeleteByQuery | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Read | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteCollection | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NativeCatalogInterceptor Class | System.Configuration.Interceptors Namespace


NativeCatalogInterceptor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public NativeCatalogInterceptor();
[C++]
public: NativeCatalogInterceptor();
[JScript]
public function NativeCatalogInterceptor();

See Also

NativeCatalogInterceptor Class | NativeCatalogInterceptor Members | System.Configuration.Interceptors Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

NativeCatalogInterceptor Methods

The methods of the NativeCatalogInterceptor class are listed below. For a complete list of NativeCatalogInterceptor class members, see the NativeCatalogInterceptor Members topic.

Public:

DeleteByQuery | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Read | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteCollection | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NativeCatalogInterceptor Class | System.Configuration.Interceptors Namespace


NativeCatalogInterceptor.DeleteByQuery

[To be supplied.]

[Visual Basic]
Public Sub DeleteByQuery( _
   ByVal ConfigType As String, _
   ByVal selector As Selector _
)
[C#]
public void DeleteByQuery(
   string ConfigType,
   Selector selector
);
[C++]
public: void DeleteByQuery(
   String* ConfigType,
   Selector* selector
);
[JScript]
public function DeleteByQuery(
   ConfigType : String,
   selector : Selector
);

Parameters

ConfigType
[To be supplied.]
selector
[To be supplied.]

See Also

NativeCatalogInterceptor Class | NativeCatalogInterceptor Members | System.Configuration.Interceptors Namespace


NativeCatalogInterceptor.Read

[To be supplied.]

[Visual Basic]
Overridable Public Function Read( _
   ByVal ConfigType As String, _
   ByVal selector As Selector, _
   ByVal los As Integer, _
   ByVal currentObject As Object _
) As Object
[C#]
public virtual object Read(
   string ConfigType,
   Selector selector,
   int los,
   object currentObject
);
[C++]
public: virtual Object* Read(
   String* ConfigType,
   Selector* selector,
   int los,
   Object* currentObject
);
[JScript]
public function Read(
   ConfigType : String,
   selector : Selector,
   los : int,
   currentObject : Object
) : Object;

Parameters

ConfigType
[To be supplied.]
selector
[To be supplied.]
los
[To be supplied.]
currentObject
[To be supplied.]

See Also

NativeCatalogInterceptor Class | NativeCatalogInterceptor Members | System.Configuration.Interceptors Namespace


NativeCatalogInterceptor.WriteCollection

[To be supplied.]

[Visual Basic]
Public Sub WriteCollection( _
   ByVal cc As IConfigCollection, _
   ByVal Flags As Integer _
)
[C#]
public void WriteCollection(
   IConfigCollection cc,
   int Flags
);
[C++]
public: void WriteCollection(
   IConfigCollection* cc,
   int Flags
);
[JScript]
public function WriteCollection(
   cc : IConfigCollection,
   Flags : int
);

Parameters

cc
[To be supplied.]
Flags
[To be supplied.]

See Also

NativeCatalogInterceptor Class | NativeCatalogInterceptor Members | System.Configuration.Interceptors Namespace


PropertyOverride Class

Used by the configuration system to merge configuration information from multiple configuration files by changing a single configuration info to carry the properties from the innermost configuration file. This effectively implements configuration inheritance from parent to child.

Object
PropertyOverride

[Visual Basic]
Public Class PropertyOverride
   Implements IConfigMerger
[C#]
public class PropertyOverride : IConfigMerger
[C++]
public __gc class PropertyOverride : public IConfigMerger
[JScript]
public class PropertyOverride implements IConfigMerger

Remarks

Only works for singleton configuration items.

Refer to Interceptors.IConfigMerger for more information.

Requirements

Namespace: System.Configuration.Interceptors

Assembly: System.Configuration.dll

See Also

PropertyOverride Members | System.Configuration.Interceptors Namespace


PropertyOverride Members

Public:

Constructor

PropertyOverride Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Merger | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyOverride Class | System.Configuration.Interceptors Namespace


PropertyOverride Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public PropertyOverride();
[C++]
public: PropertyOverride();
[JScript]
public function PropertyOverride();

See Also

PropertyOverride Class | PropertyOverride Members | System.Configuration.Interceptors Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PropertyOverride Methods

The methods of the PropertyOverride class are listed below. For a complete list of PropertyOverride class members, see the PropertyOverride Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Merger | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyOverride Class | System.Configuration.Interceptors Namespace


PropertyOverride.Merger

[To be supplied.]

[Visual Basic]
Overridable Public Function Merger( _
   ByVal parent As Object, _
   ByVal child As Object, _
   ByVal configType As String, _
   ByVal selector As Selector, _
   ByVal los As Integer _
) As Object
[C#]
public virtual object Merger(
   object parent,
   object child,
   string configType,
   Selector selector,
   int los
);
[C++]
public: virtual Object* Merger(
   Object* parent,
   Object* child,
   String* configType,
   Selector* selector,
   int los
);
[JScript]
public function Merger(
   parent : Object,
   child : Object,
   configType : String,
   selector : Selector,
   los : int
) : Object;

Parameters

parent
[To be supplied.]
child
[To be supplied.]
configType
[To be supplied.]
selector
[To be supplied.]
los
[To be supplied.]

See Also

PropertyOverride Class | PropertyOverride Members | System.Configuration.Interceptors Namespace


RequestParams Structure

Used in Interceptors.IConfigTransformer to capture the modified set of parameters.

Object
ValueType
RequestParams

[Visual Basic]
Public Structure RequestParams
[C#]
public struct RequestParams
[C++]
public __value struct RequestParams

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Configuration.Interceptors

Assembly: System.Configuration.dll

See Also

RequestParams Members | System.Configuration.Interceptors Namespace


RequestParams Members

Public:

Methods

Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Fields

configType | [To be supplied.]
los | [To be supplied.]
selector | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RequestParams Structure | System.Configuration.Interceptors Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RequestParams Fields

The fields of the RequestParams structure are listed below. For a complete list of RequestParams structure members, see the RequestParams Members topic.

Public:

configType | [To be supplied.]
los | [To be supplied.]
selector | [To be supplied.]

See Also

RequestParams Structure | System.Configuration.Interceptors Namespace


RequestParams.configType

[To be supplied.]

[Visual Basic]
Public configType As String
[C#]
public string configType;
[C++]
public: String* configType;
[JScript]
public var configType : String;

See Also

RequestParams Structure | RequestParams Members | System.Configuration.Interceptors Namespace


RequestParams.los

[To be supplied.]

[Visual Basic]
Public los As Integer
[C#]
public int los;
[C++]
public: int los;
[JScript]
public var los : int;

See Also

RequestParams Structure | RequestParams Members | System.Configuration.Interceptors Namespace


RequestParams.selector

[To be supplied.]

[Visual Basic]
Public selector As Selector
[C#]
public Selector selector;
[C++]
public: Selector* selector;
[JScript]
public var selector : Selector;

See Also

RequestParams Structure | RequestParams Members | System.Configuration.Interceptors Namespace


System.Configuration.Schema

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Configuration.Schema Namespace

Classes

Class | Description
QueryMeta | [To be supplied.]


QueryMeta Class

[To be supplied.]

Object
BaseConfigItem
QueryMeta

[Visual Basic]
Public Class QueryMeta
   Inherits BaseConfigItem
[C#]
public class QueryMeta : BaseConfigItem
[C++]
public __gc class QueryMeta : public BaseConfigItem
[JScript]
public class QueryMeta extends BaseConfigItem

Remarks

[To be supplied.]

Requirements

Namespace: System.Configuration.Schema

Assembly: System.Configuration.Objects.dll

See Also

QueryMeta Members | System.Configuration.Schema Namespace


QueryMeta Members

Public:

Constructor

QueryMeta Constructor [To be supplied.]

Properties

CellName [To be supplied.]

See Also

QueryMeta Class | System.Configuration.Schema Namespace


QueryMeta Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public QueryMeta();
[C++]
public: QueryMeta();
[JScript]
public function QueryMeta();

See Also

QueryMeta Class | QueryMeta Members | System.Configuration.Schema Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

QueryMeta Properties

The properties of the QueryMeta class are listed below. For a complete list of QueryMeta class members, see the QueryMeta Members topic.

Public:

CellName [To be supplied.]

See Also

QueryMeta Class | System.Configuration.Schema Namespace


QueryMeta.CellName

[To be supplied.]

[C#]
public string CellName {get; set;}
[C++]
public: __property String* get_CellName();
public: __property void set_CellName(

See Also

QueryMeta Class | QueryMeta Members | System.Configuration.Schema Namespace


System.Configuration.Web

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Configuration.Web Namespace

Classes

Class | Description
MimeImporterType | [To be supplied.]


MimeImporterType Class

[To be supplied.]

Object
BaseConfigItem
MimeImporterType

[Visual Basic]
Public Class MimeImporterType
   Inherits BaseConfigItem
[C#]
public class MimeImporterType : BaseConfigItem
[C++]
public __gc class MimeImporterType : public BaseConfigItem
[JScript]
public class MimeImporterType extends BaseConfigItem

Remarks

[To be supplied.]

Requirements

Namespace: System.Configuration.Web

Assembly: System.Configuration.Objects.dll

See Also

MimeImporterType Members | System.Configuration.Web Namespace


MimeImporterType Members

Public:

Constructor

MimeImporterType Constructor [To be supplied.]

Properties

app [To be supplied.]

See Also

MimeImporterType Class | System.Configuration.Web Namespace


MimeImporterType Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public MimeImporterType();
[C++]
public: MimeImporterType();
[JScript]
public function MimeImporterType();

See Also

MimeImporterType Class | MimeImporterType Members | System.Configuration.Web Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MimeImporterType Properties

The properties of the MimeImporterType class are listed below. For a complete list of MimeImporterType class members, see the MimeImporterType Members topic.

Public:

app [To be supplied.]

See Also

MimeImporterType Class | System.Configuration.Web Namespace


MimeImporterType.app

[To be supplied.]

[C#]
public string app {get; set;}
[C++]
public: __property String* get_app();
public: __property void set_app(

See Also

MimeImporterType Class | MimeImporterType Members | System.Configuration.Web Namespace


System.Core

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Core Namespace

Classes

Class | Description
NativeMethods.PROCESS_INFORMATION | [To be supplied.]
NativeMethods.SECURITY_ATTRIBUTES | [To be supplied.]
NativeMethods.STARTUPINFO | [To be supplied.]
NativeMethods.TEXTMETRIC | [To be supplied.]
NativeMethods.WNDCLASS | [To be supplied.]
PowerModeChangedEventArgs | A session ended event is raised when the user is loging off or shutting down the system.
SessionEndedEventArgs | A session ended event is raised when the user is loging off or shutting down the system.
SessionEndingEventArgs | A session ending event is raised when the user is trying to log off or shutdown the system.
SystemEvents | The SystemEvents class provides a set of global system events to callers. System events are such things as shutdown notifications and changes to user preferences. When a system event is raised it will call back the corresponding delegate from a different thread. You should be prepared for this, and make the call thread-safe. You should not do time-consuming processing in a system event notification because it may prevent other applications from functioning.
TimerElapsedEventArgs | A timer ellapsed event is raised when a windows timer interval has expired.
UNDONE | [To be supplied.]
UserPreferenceChangedEventArgs | A user preference changed event, which occurs when a user preference has changed.

Interfaces

Interface | Description
IIndexedCollection | [To be supplied.]

Structures

Structure | Description
NativeMethods.MSG | [To be supplied.]

Delegates

Delegate | Description
NativeMethods.ConHndlr | [To be supplied.]
NativeMethods.WndProc | [To be supplied.]
PowerModeChangedEventHandler | Represents the method that will handle the OnPowerModeChanged event.
SessionEndedEventHandler | Represents the method that will handle the OnSessionEnded event.
SessionEndingEventHandler | Represents the method that will handle the OnSessionEnding event.
TimerElapsedEventHandler | Represents the method that will handle the OnTimerElapsed event.
UserPreferenceChangedEventHandler | Represents the method that will handle the OnUserPreferenceChanged event.

Enumerations

Enumeration | Description
NativeMethods.StructFormat | [To be supplied.]
NativeMethods.StructFormatEnum | [To be supplied.]
PowerModes | This enum provides the various power mode changes a system may undergo.
SessionEndReasons | This enum provides reasons the current logon session may be ending.
UserPreferenceCategories | This enum identifies areas of user preferences that have changed.


IIndexedCollection Interface

[To be supplied.]

[Visual Basic]
Public Interface IIndexedCollection
   Implements ICollection, IEnumerable
[C#]
public interface IIndexedCollection : ICollection, IEnumerable
[C++]
public __gc __interface IIndexedCollection : public ICollection,
   IEnumerable

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Core

Assembly: System.dll

See Also

IIndexedCollection Members | System.Core Namespace


IIndexedCollection Members

Properties

Item [To be supplied.]

In C#, this member is the indexer for the IIndexedCollection class.

See Also

IIndexedCollection Interface | System.Core Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IIndexedCollection Properties

The properties of the IIndexedCollection interface are listed below. For a complete list of IIndexedCollection interface members, see the IIndexedCollection Members topic.

Item [To be supplied.]

In C#, this member is the indexer for the IIndexedCollection class.

See Also

IIndexedCollection Interface | System.Core Namespace


IIndexedCollection.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the IIndexedCollection class.

[Visual Basic]
Default ReadOnly Property Item( _
   ByVal index As Integer _
) As Object
[C#]
object this[
   int index
] {get;}
[C++]
Object* get_Item(
   int index
) = 0;
[JScript]
abstract returnValue = IIndexedCollectionObject.Item(index);
-or-
abstract returnValue = IIndexedCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
[To be supplied.]

Parameters [Visual Basic, C#, C++]

index
[To be supplied.]

See Also

IIndexedCollection Interface | IIndexedCollection Members | System.Core Namespace


NativeMethods.ConHndlr Delegate

[To be supplied.]

[Visual Basic]
Public Delegate Sub NativeMethods.ConHndlr( _
   ByVal signalType As Integer _
) As Integer
[C#]
public delegate int NativeMethods.ConHndlr(
   int signalType
);
[C++]
public __gc __delegate int NativeMethods.ConHndlr(
   int signalType
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the NativeMethods.ConHndlr delegate declaration.

Remarks

[To be supplied.]

Requirements

Namespace: System.Core

Assembly: System.dll

See Also

System.Core Namespace


NativeMethods.MSG Structure

[To be supplied.]

Object
ValueType
NativeMethods.MSG

[Visual Basic]
Public Structure NativeMethods.MSG
[C#]
public struct NativeMethods.MSG
[C++]
public __value struct NativeMethods.MSG

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Core

Assembly: System.dll

See Also

NativeMethods.MSG Members | System.Core Namespace


NativeMethods.MSG Members

Public:

Methods

Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Fields

hwnd | [To be supplied.]
lParam | [To be supplied.]
message | [To be supplied.]
pt_x | [To be supplied.]
pt_y | [To be supplied.]
time | [To be supplied.]
wParam | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NativeMethods.MSG Structure | System.Core Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

NativeMethods.MSG Fields

The fields of the NativeMethods.MSG structure are listed below. For a complete list of NativeMethods.MSG structure members, see the NativeMethods.MSG Members topic.

Public:

hwnd | [To be supplied.]
lParam | [To be supplied.]
message | [To be supplied.]
pt_x | [To be supplied.]
pt_y | [To be supplied.]
time | [To be supplied.]
wParam | [To be supplied.]

See Also

NativeMethods.MSG Structure | System.Core Namespace


NativeMethods.MSG.hwnd

[To be supplied.]

[Visual Basic]
Public hwnd As Integer
[C#]
public int hwnd;
[C++]
public: int hwnd;
[JScript]
public var hwnd : int;

See Also

NativeMethods.MSG Structure | NativeMethods.MSG Members | System.Core Namespace


NativeMethods.MSG.lParam

[To be supplied.]

[Visual Basic]
Public lParam As Integer
[C#]
public int lParam;
[C++]
public: int lParam;
[JScript]
public var lParam : int;

See Also

NativeMethods.MSG Structure | NativeMethods.MSG Members | System.Core Namespace


NativeMethods.MSG.message

[To be supplied.]

[Visual Basic]
Public message As Integer
[C#]
public int message;
[C++]
public: int message;
[JScript]
public var message : int;

See Also

NativeMethods.MSG Structure | NativeMethods.MSG Members | System.Core Namespace


NativeMethods.MSG.pt_x

[To be supplied.]

[Visual Basic]
Public pt_x As Integer
[C#]
public int pt_x;
[C++]
public: int pt_x;
[JScript]
public var pt_x : int;

See Also

NativeMethods.MSG Structure | NativeMethods.MSG Members | System.Core Namespace


NativeMethods.MSG.pt_y

[To be supplied.]

[Visual Basic]
Public pt_y As Integer
[C#]
public int pt_y;
[C++]
public: int pt_y;
[JScript]
public var pt_y : int;

See Also

NativeMethods.MSG Structure | NativeMethods.MSG Members | System.Core Namespace


NativeMethods.MSG.time

[To be supplied.]

[Visual Basic]
Public time As Integer
[C#]
public int time;
[C++]
public: int time;
[JScript]
public var time : int;

See Also

NativeMethods.MSG Structure | NativeMethods.MSG Members | System.Core Namespace


NativeMethods.MSG.wParam

[To be supplied.]

[Visual Basic]
Public wParam As Integer
[C#]
public int wParam;
[C++]
public: int wParam;
[JScript]
public var wParam : int;

See Also

NativeMethods.MSG Structure | NativeMethods.MSG Members | System.Core Namespace


NativeMethods.PROCESS_INFORMATION Class

[To be supplied.]

Object
NativeMethods.PROCESS_INFORMATION

[Visual Basic]
Public Class NativeMethods.PROCESS_INFORMATION
[C#]
public class NativeMethods.PROCESS_INFORMATION
[C++]
public __gc class NativeMethods.PROCESS_INFORMATION
[JScript]
public class NativeMethods.PROCESS_INFORMATION

Remarks

[To be supplied.]

Requirements

Namespace: System.Core

Assembly: System.dll

See Also

NativeMethods.PROCESS_INFORMATION Members | System.Core Namespace


NativeMethods.PROCESS_INFORMATION Members

Public:

Constructor

NativeMethodsPROCESS_INFORMATION Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

dwProcessId | [To be supplied.]
dwThreadId | [To be supplied.]
hProcess | [To be supplied.]
hThread | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NativeMethods.PROCESS_INFORMATION Class | System.Core Namespace


NativeMethods.PROCESS_INFORMATION Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public NativeMethods.PROCESS_INFORMATION();
[C++]
public: NativeMethods.PROCESS_INFORMATION();
[JScript]
public function NativeMethods.PROCESS_INFORMATION();

See Also

NativeMethods.PROCESS_INFORMATION Class | NativeMethods.PROCESS_INFORMATION Members | System.Core Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

NativeMethods.PROCESS_INFORMATION Fields

The fields of the NativeMethods.PROCESS_INFORMATION class are listed below. For a complete list of NativeMethods.PROCESS_INFORMATION class members, see the NativeMethods.PROCESS_INFORMATION Members topic.

Public:

dwProcessId | [To be supplied.]
dwThreadId | [To be supplied.]
hProcess | [To be supplied.]
hThread | [To be supplied.]

See Also

NativeMethods.PROCESS_INFORMATION Class | System.Core Namespace


NativeMethods.PROCESS_INFORMATION.dwProcessId

[To be supplied.]

[Visual Basic]
Public dwProcessId As Integer
[C#]
public int dwProcessId;
[C++]
public: int dwProcessId;
[JScript]
public var dwProcessId : int;

See Also

NativeMethods.PROCESS_INFORMATION Class | NativeMethods.PROCESS_INFORMATION Members | System.Core Namespace


NativeMethods.PROCESS_INFORMATION.dwThreadId

[To be supplied.]

[Visual Basic]
Public dwThreadId As Integer
[C#]
public int dwThreadId;
[C++]
public: int dwThreadId;
[JScript]
public var dwThreadId : int;

See Also

NativeMethods.PROCESS_INFORMATION Class | NativeMethods.PROCESS_INFORMATION Members | System.Core Namespace


NativeMethods.PROCESS_INFORMATION.hProcess

[To be supplied.]

[Visual Basic]
Public hProcess As Integer
[C#]
public int hProcess;
[C++]
public: int hProcess;
[JScript]
public var hProcess : int;

See Also

NativeMethods.PROCESS_INFORMATION Class | NativeMethods.PROCESS_INFORMATION Members | System.Core Namespace


NativeMethods.PROCESS_INFORMATION.hThread

[To be supplied.]

[Visual Basic]
Public hThread As Integer
[C#]
public int hThread;
[C++]
public: int hThread;
[JScript]
public var hThread : int;

See Also

NativeMethods.PROCESS_INFORMATION Class | NativeMethods.PROCESS_INFORMATION Members | System.Core Namespace


NativeMethods.SECURITY_ATTRIBUTES Class

[To be supplied.]

Object
NativeMethods.SECURITY_ATTRIBUTES

[Visual Basic]
Public Class NativeMethods.SECURITY_ATTRIBUTES
[C#]
public class NativeMethods.SECURITY_ATTRIBUTES
[C++]
public __gc class NativeMethods.SECURITY_ATTRIBUTES
[JScript]
public class NativeMethods.SECURITY_ATTRIBUTES

Remarks

[To be supplied.]

Requirements

Namespace: System.Core

Assembly: System.dll

See Also

NativeMethods.SECURITY_ATTRIBUTES Members | System.Core Namespace


NativeMethods.SECURITY_ATTRIBUTES Members

Public:

Constructor

NativeMethodsSECURITY_ATTRIBUTES Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

bInheritHandle | [To be supplied.]
lpSecurityDescriptor | [To be supplied.]
nLength | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NativeMethods.SECURITY_ATTRIBUTES Class | System.Core Namespace


NativeMethods.SECURITY_ATTRIBUTES Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public NativeMethods.SECURITY_ATTRIBUTES();
[C++]
public: NativeMethods.SECURITY_ATTRIBUTES();
[JScript]
public function NativeMethods.SECURITY_ATTRIBUTES();

See Also

NativeMethods.SECURITY_ATTRIBUTES Class | NativeMethods.SECURITY_ATTRIBUTES Members | System.Core Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

NativeMethods.SECURITY_ATTRIBUTES Fields

The fields of the NativeMethods.SECURITY_ATTRIBUTES class are listed below. For a complete list of NativeMethods.SECURITY_ATTRIBUTES class members, see the NativeMethods.SECURITY_ATTRIBUTES Members topic.

Public:

bInheritHandle | [To be supplied.]
lpSecurityDescriptor | [To be supplied.]
nLength | [To be supplied.]

See Also

NativeMethods.SECURITY_ATTRIBUTES Class | System.Core Namespace


NativeMethods.SECURITY_ATTRIBUTES.bInheritHandle

[To be supplied.]

[Visual Basic]
Public bInheritHandle As Boolean
[C#]
public bool bInheritHandle;
[C++]
public: bool bInheritHandle;
[JScript]
public var bInheritHandle : Boolean;

See Also

NativeMethods.SECURITY_ATTRIBUTES Class | NativeMethods.SECURITY_ATTRIBUTES Members | System.Core Namespace


NativeMethods.SECURITY_ATTRIBUTES.lpSecurityDescriptor

[To be supplied.]

[Visual Basic]
Public lpSecurityDescriptor As Integer
[C#]
public int lpSecurityDescriptor;
[C++]
public: int lpSecurityDescriptor;
[JScript]
public var lpSecurityDescriptor : int;

See Also

NativeMethods.SECURITY_ATTRIBUTES Class | NativeMethods.SECURITY_ATTRIBUTES Members | System.Core Namespace


NativeMethods.SECURITY_ATTRIBUTES.nLength

[To be supplied.]

[Visual Basic]
Public nLength As Integer
[C#]
public int nLength;
[C++]
public: int nLength;
[JScript]
public var nLength : int;

See Also

NativeMethods.SECURITY_ATTRIBUTES Class | NativeMethods.SECURITY_ATTRIBUTES Members | System.Core Namespace


NativeMethods.STARTUPINFO Class

[To be supplied.]

Object
NativeMethods.STARTUPINFO

[Visual Basic]
Public Class NativeMethods.STARTUPINFO
[C#]
public class NativeMethods.STARTUPINFO
[C++]
public __gc class NativeMethods.STARTUPINFO
[JScript]
public class NativeMethods.STARTUPINFO

Remarks

[To be supplied.]

Requirements

Namespace: System.Core

Assembly: System.dll

See Also

NativeMethods.STARTUPINFO Members | System.Core Namespace


NativeMethods.STARTUPINFO Members

Public:

Constructor

NativeMethodsSTARTUPINFO Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

cb | [To be supplied.]
cbReserved2 | [To be supplied.]
dwFillAttribute | [To be supplied.]
dwFlags | [To be supplied.]
dwX | [To be supplied.]
dwXCountChars | [To be supplied.]
dwXSize | [To be supplied.]
dwY | [To be supplied.]
dwYCountChars | [To be supplied.]
dwYSize | [To be supplied.]
hStdError | [To be supplied.]
hStdInput | [To be supplied.]
hStdOutput | [To be supplied.]
lpDesktop | [To be supplied.]
lpReserved | [To be supplied.]
lpReserved2 | [To be supplied.]
lpTitle | [To be supplied.]
wShowWindow | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NativeMethods.STARTUPINFO Class | System.Core Namespace


NativeMethods.STARTUPINFO Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public NativeMethods.STARTUPINFO();
[C++]
public: NativeMethods.STARTUPINFO();
[JScript]
public function NativeMethods.STARTUPINFO();

See Also

NativeMethods.STARTUPINFO Class | NativeMethods.STARTUPINFO Members | System.Core Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

NativeMethods.STARTUPINFO Fields

The fields of the NativeMethods.STARTUPINFO class are listed below. For a complete list of NativeMethods.STARTUPINFO class members, see the NativeMethods.STARTUPINFO Members topic.

Public:

cb | [To be supplied.]
cbReserved2 | [To be supplied.]
dwFillAttribute | [To be supplied.]
dwFlags | [To be supplied.]
dwX | [To be supplied.]
dwXCountChars | [To be supplied.]
dwXSize | [To be supplied.]
dwY | [To be supplied.]
dwYCountChars | [To be supplied.]
dwYSize | [To be supplied.]
hStdError | [To be supplied.]
hStdInput | [To be supplied.]
hStdOutput | [To be supplied.]
lpDesktop | [To be supplied.]
lpReserved | [To be supplied.]
lpReserved2 | [To be supplied.]
lpTitle | [To be supplied.]
wShowWindow | [To be supplied.]

See Also

NativeMethods.STARTUPINFO Class | System.Core Namespace


NativeMethods.STARTUPINFO.cb

[To be supplied.]

[Visual Basic]
Public cb As Integer
[C#]
public int cb;
[C++]
public: int cb;
[JScript]
public var cb : int;

See Also

NativeMethods.STARTUPINFO Class | NativeMethods.STARTUPINFO Members | System.Core Namespace


NativeMethods.STARTUPINFO.cbReserved2

[To be supplied.]

[Visual Basic]
Public cbReserved2 As Short
[C#]
public short cbReserved2;
[C++]
public: short cbReserved2;
[JScript]
public var cbReserved2 : Int16;

See Also

NativeMethods.STARTUPINFO Class | NativeMethods.STARTUPINFO Members | System.Core Namespace


NativeMethods.STARTUPINFO.dwFillAttribute

[To be supplied.]

[Visual Basic]
Public dwFillAttribute As Integer
[C#]
public int dwFillAttribute;
[C++]
public: int dwFillAttribute;
[JScript]
public var dwFillAttribute : int;

See Also

NativeMethods.STARTUPINFO Class | NativeMethods.STARTUPINFO Members | System.Core Namespace


NativeMethods.STARTUPINFO.dwFlags

[To be supplied.]

[Visual Basic]
Public dwFlags As Integer
[C#]
public int dwFlags;
[C++]
public: int dwFlags;
[JScript]
public var dwFlags : int;

See Also

NativeMethods.STARTUPINFO Class | NativeMethods.STARTUPINFO Members | System.Core Namespace


NativeMethods.STARTUPINFO.dwX

[To be supplied.]

[Visual Basic]
Public dwX As Integer
[C#]
public int dwX;
[C++]
public: int dwX;
[JScript]
public var dwX : int;

See Also

NativeMethods.STARTUPINFO Class | NativeMethods.STARTUPINFO Members | System.Core Namespace


NativeMethods.STARTUPINFO.dwXCountChars

[To be supplied.]

[Visual Basic]
Public dwXCountChars As Integer
[C#]
public int dwXCountChars;
[C++]
public: int dwXCountChars;
[JScript]
public var dwXCountChars : int;

See Also

NativeMethods.STARTUPINFO Class | NativeMethods.STARTUPINFO Members | System.Core Namespace


NativeMethods.STARTUPINFO.dwXSize

[To be supplied.]

[Visual Basic]
Public dwXSize As Integer
[C#]
public int dwXSize;
[C++]
public: int dwXSize;
[JScript]
public var dwXSize : int;

See Also

NativeMethods.STARTUPINFO Class | NativeMethods.STARTUPINFO Members | System.Core Namespace


NativeMethods.STARTUPINFO.dwY

[To be supplied.]

[Visual Basic]
Public dwY As Integer
[C#]
public int dwY;
[C++]
public: int dwY;
[JScript]
public var dwY : int;

See Also

NativeMethods.STARTUPINFO Class | NativeMethods.STARTUPINFO Members | System.Core Namespace


NativeMethods.STARTUPINFO.dwYCountChars

[To be supplied.]

[Visual Basic]
Public dwYCountChars As Integer
[C#]
public int dwYCountChars;
[C++]
public: int dwYCountChars;
[JScript]
public var dwYCountChars : int;

See Also

NativeMethods.STARTUPINFO Class | NativeMethods.STARTUPINFO Members | System.Core Namespace


NativeMethods.STARTUPINFO.dwYSize

[To be supplied.]

[Visual Basic]
Public dwYSize As Integer
[C#]
public int dwYSize;
[C++]
public: int dwYSize;
[JScript]
public var dwYSize : int;

See Also

NativeMethods.STARTUPINFO Class | NativeMethods.STARTUPINFO Members | System.Core Namespace


NativeMethods.STARTUPINFO.hStdError

[To be supplied.]

[Visual Basic]
Public hStdError As Integer
[C#]
public int hStdError;
[C++]
public: int hStdError;
[JScript]
public var hStdError : int;

See Also

NativeMethods.STARTUPINFO Class | NativeMethods.STARTUPINFO Members | System.Core Namespace


NativeMethods.STARTUPINFO.hStdInput

[To be supplied.]

[Visual Basic]
Public hStdInput As Integer
[C#]
public int hStdInput;
[C++]
public: int hStdInput;
[JScript]
public var hStdInput : int;

See Also

NativeMethods.STARTUPINFO Class | NativeMethods.STARTUPINFO Members | System.Core Namespace


NativeMethods.STARTUPINFO.hStdOutput

[To be supplied.]

[Visual Basic]
Public hStdOutput As Integer
[C#]
public int hStdOutput;
[C++]
public: int hStdOutput;
[JScript]
public var hStdOutput : int;

See Also

NativeMethods.STARTUPINFO Class | NativeMethods.STARTUPINFO Members | System.Core Namespace


NativeMethods.STARTUPINFO.lpDesktop

[To be supplied.]

[Visual Basic]
Public lpDesktop As Integer
[C#]
public int lpDesktop;
[C++]
public: int lpDesktop;
[JScript]
public var lpDesktop : int;

See Also

NativeMethods.STARTUPINFO Class | NativeMethods.STARTUPINFO Members | System.Core Namespace


NativeMethods.STARTUPINFO.lpReserved

[To be supplied.]

[Visual Basic]
Public lpReserved As Integer
[C#]
public int lpReserved;
[C++]
public: int lpReserved;
[JScript]
public var lpReserved : int;

See Also

NativeMethods.STARTUPINFO Class | NativeMethods.STARTUPINFO Members | System.Core Namespace


NativeMethods.STARTUPINFO.lpReserved2

[To be supplied.]

[Visual Basic]
Public lpReserved2 As Integer
[C#]
public int lpReserved2;
[C++]
public: int lpReserved2;
[JScript]
public var lpReserved2 : int;

See Also

NativeMethods.STARTUPINFO Class | NativeMethods.STARTUPINFO Members | System.Core Namespace


NativeMethods.STARTUPINFO.lpTitle

[To be supplied.]

[Visual Basic]
Public lpTitle As Integer
[C#]
public int lpTitle;
[C++]
public: int lpTitle;
[JScript]
public var lpTitle : int;

See Also

NativeMethods.STARTUPINFO Class | NativeMethods.STARTUPINFO Members | System.Core Namespace


NativeMethods.STARTUPINFO.wShowWindow

[To be supplied.]

[Visual Basic]
Public wShowWindow As Short
[C#]
public short wShowWindow;
[C++]
public: short wShowWindow;
[JScript]
public var wShowWindow : Int16;

See Also

NativeMethods.STARTUPINFO Class | NativeMethods.STARTUPINFO Members | System.Core Namespace


NativeMethods.StructFormat Enumeration

[To be supplied.]

[Visual Basic]
Public Enum NativeMethods.StructFormat
[C#]
public enum NativeMethods.StructFormat
[C++]
public enum NativeMethods.StructFormat

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Ansi | [To be supplied.]
Auto | [To be supplied.]
Unicode | [To be supplied.]

Requirements

Namespace: System.Core

Assembly: System.dll

See Also

System.Core Namespace


NativeMethods.StructFormatEnum Enumeration

[To be supplied.]

[Visual Basic]
Public Enum NativeMethods.StructFormatEnum
[C#]
public enum NativeMethods.StructFormatEnum
[C++]
public enum NativeMethods.StructFormatEnum

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Ansi | [To be supplied.]
Auto | [To be supplied.]
Unicode | [To be supplied.]

Requirements

Namespace: System.Core

Assembly: System.dll

See Also

System.Core Namespace


NativeMethods.TEXTMETRIC Class

[To be supplied.]

Object
NativeMethods.TEXTMETRIC

[Visual Basic]
Public Class NativeMethods.TEXTMETRIC
[C#]
public class NativeMethods.TEXTMETRIC
[C++]
public __gc class NativeMethods.TEXTMETRIC
[JScript]
public class NativeMethods.TEXTMETRIC

Remarks

[To be supplied.]

Requirements

Namespace: System.Core

Assembly: System.dll

See Also

NativeMethods.TEXTMETRIC Members | System.Core Namespace


NativeMethods.TEXTMETRIC Members

Public:

Constructor

NativeMethodsTEXTMETRIC Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

tmAscent | [To be supplied.]
tmAveCharWidth | [To be supplied.]
tmBreakChar | [To be supplied.]
tmCharSet | [To be supplied.]
tmDefaultChar | [To be supplied.]
tmDescent | [To be supplied.]
tmDigitizedAspectX | [To be supplied.]
tmDigitizedAspectY | [To be supplied.]
tmExternalLeading | [To be supplied.]
tmFirstChar | [To be supplied.]
tmHeight | [To be supplied.]
tmInternalLeading | [To be supplied.]
tmItalic | [To be supplied.]
tmLastChar | [To be supplied.]
tmMaxCharWidth | [To be supplied.]
tmOverhang | [To be supplied.]
tmPitchAndFamily | [To be supplied.]
tmStruckOut | [To be supplied.]
tmUnderlined | [To be supplied.]
tmWeight | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NativeMethods.TEXTMETRIC Class | System.Core Namespace


NativeMethods.TEXTMETRIC Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public NativeMethods.TEXTMETRIC();
[C++]
public: NativeMethods.TEXTMETRIC();
[JScript]
public function NativeMethods.TEXTMETRIC();

See Also

NativeMethods.TEXTMETRIC Class | NativeMethods.TEXTMETRIC Members | System.Core Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

NativeMethods.TEXTMETRIC Fields

The fields of the NativeMethods.TEXTMETRIC class are listed below. For a complete list of NativeMethods.TEXTMETRIC class members, see the NativeMethods.TEXTMETRIC Members topic.

Public:

tmAscent | [To be supplied.]
tmAveCharWidth | [To be supplied.]
tmBreakChar | [To be supplied.]
tmCharSet | [To be supplied.]
tmDefaultChar | [To be supplied.]
tmDescent | [To be supplied.]
tmDigitizedAspectX | [To be supplied.]
tmDigitizedAspectY | [To be supplied.]
tmExternalLeading | [To be supplied.]
tmFirstChar | [To be supplied.]
tmHeight | [To be supplied.]
tmInternalLeading | [To be supplied.]
tmItalic | [To be supplied.]
tmLastChar | [To be supplied.]
tmMaxCharWidth | [To be supplied.]
tmOverhang | [To be supplied.]
tmPitchAndFamily | [To be supplied.]
tmStruckOut | [To be supplied.]
tmUnderlined | [To be supplied.]
tmWeight | [To be supplied.]

See Also

NativeMethods.TEXTMETRIC Class | System.Core Namespace


NativeMethods.TEXTMETRIC.tmAscent

[To be supplied.]

[Visual Basic]
Public tmAscent As Integer
[C#]
public int tmAscent;
[C++]
public: int tmAscent;
[JScript]
public var tmAscent : int;

See Also

NativeMethods.TEXTMETRIC Class | NativeMethods.TEXTMETRIC Members | System.Core Namespace


NativeMethods.TEXTMETRIC.tmAveCharWidth

[To be supplied.]

[Visual Basic]
Public tmAveCharWidth As Integer
[C#]
public int tmAveCharWidth;
[C++]
public: int tmAveCharWidth;
[JScript]
public var tmAveCharWidth : int;

See Also

NativeMethods.TEXTMETRIC Class | NativeMethods.TEXTMETRIC Members | System.Core Namespace


NativeMethods.TEXTMETRIC.tmBreakChar

[To be supplied.]

[Visual Basic]
Public tmBreakChar As Char
[C#]
public char tmBreakChar;
[C++]
public: __wchar_t tmBreakChar;
[JScript]
public var tmBreakChar : Char;

See Also

NativeMethods.TEXTMETRIC Class | NativeMethods.TEXTMETRIC Members | System.Core Namespace


NativeMethods.TEXTMETRIC.tmCharSet

[To be supplied.]

[Visual Basic]
Public tmCharSet As Byte
[C#]
public byte tmCharSet;
[C++]
public: unsigned char tmCharSet;
[JScript]
public var tmCharSet : Byte;

See Also

NativeMethods.TEXTMETRIC Class | NativeMethods.TEXTMETRIC Members | System.Core Namespace


NativeMethods.TEXTMETRIC.tmDefaultChar

[To be supplied.]

[Visual Basic]
Public tmDefaultChar As Char
[C#]
public char tmDefaultChar;
[C++]
public: __wchar_t tmDefaultChar;
[JScript]
public var tmDefaultChar : Char;

See Also

NativeMethods.TEXTMETRIC Class | NativeMethods.TEXTMETRIC Members | System.Core Namespace


NativeMethods.TEXTMETRIC.tmDescent

[To be supplied.]

[Visual Basic]
Public tmDescent As Integer
[C#]
public int tmDescent;
[C++]
public: int tmDescent;
[JScript]
public var tmDescent : int;

See Also

NativeMethods.TEXTMETRIC Class | NativeMethods.TEXTMETRIC Members | System.Core Namespace


NativeMethods.TEXTMETRIC.tmDigitizedAspectX

[To be supplied.]

[Visual Basic]
Public tmDigitizedAspectX As Integer
[C#]
public int tmDigitizedAspectX;
[C++]
public: int tmDigitizedAspectX;
[JScript]
public var tmDigitizedAspectX : int;

See Also

NativeMethods.TEXTMETRIC Class | NativeMethods.TEXTMETRIC Members | System.Core Namespace


NativeMethods.TEXTMETRIC.tmDigitizedAspectY

[To be supplied.]

[Visual Basic]
Public tmDigitizedAspectY As Integer
[C#]
public int tmDigitizedAspectY;
[C++]
public: int tmDigitizedAspectY;
[JScript]
public var tmDigitizedAspectY : int;

See Also

NativeMethods.TEXTMETRIC Class | NativeMethods.TEXTMETRIC Members | System.Core Namespace


NativeMethods.TEXTMETRIC.tmExternalLeading

[To be supplied.]

[Visual Basic]
Public tmExternalLeading As Integer
[C#]
public int tmExternalLeading;
[C++]
public: int tmExternalLeading;
[JScript]
public var tmExternalLeading : int;

See Also

NativeMethods.TEXTMETRIC Class | NativeMethods.TEXTMETRIC Members | System.Core Namespace


NativeMethods.TEXTMETRIC.tmFirstChar

[To be supplied.]

[Visual Basic]
Public tmFirstChar As Char
[C#]
public char tmFirstChar;
[C++]
public: __wchar_t tmFirstChar;
[JScript]
public var tmFirstChar : Char;

See Also

NativeMethods.TEXTMETRIC Class | NativeMethods.TEXTMETRIC Members | System.Core Namespace


NativeMethods.TEXTMETRIC.tmHeight

[To be supplied.]

[Visual Basic]
Public tmHeight As Integer
[C#]
public int tmHeight;
[C++]
public: int tmHeight;
[JScript]
public var tmHeight : int;

See Also

NativeMethods.TEXTMETRIC Class | NativeMethods.TEXTMETRIC Members | System.Core Namespace


NativeMethods.TEXTMETRIC.tmInternalLeading

[To be supplied.]

[Visual Basic]
Public tmInternalLeading As Integer
[C#]
public int tmInternalLeading;
[C++]
public: int tmInternalLeading;
[JScript]
public var tmInternalLeading : int;

See Also

NativeMethods.TEXTMETRIC Class | NativeMethods.TEXTMETRIC Members | System.Core Namespace


NativeMethods.TEXTMETRIC.tmItalic

[To be supplied.]

[Visual Basic]
Public tmItalic As Byte
[C#]
public byte tmItalic;
[C++]
public: unsigned char tmItalic;
[JScript]
public var tmItalic : Byte;

See Also

NativeMethods.TEXTMETRIC Class | NativeMethods.TEXTMETRIC Members | System.Core Namespace


NativeMethods.TEXTMETRIC.tmLastChar

[To be supplied.]

[Visual Basic]
Public tmLastChar As Char
[C#]
public char tmLastChar;
[C++]
public: __wchar_t tmLastChar;
[JScript]
public var tmLastChar : Char;

See Also

NativeMethods.TEXTMETRIC Class | NativeMethods.TEXTMETRIC Members | System.Core Namespace


NativeMethods.TEXTMETRIC.tmMaxCharWidth

[To be supplied.]

[Visual Basic]
Public tmMaxCharWidth As Integer
[C#]
public int tmMaxCharWidth;
[C++]
public: int tmMaxCharWidth;
[JScript]
public var tmMaxCharWidth : int;

See Also

NativeMethods.TEXTMETRIC Class | NativeMethods.TEXTMETRIC Members | System.Core Namespace


NativeMethods.TEXTMETRIC.tmOverhang

[To be supplied.]

[Visual Basic]
Public tmOverhang As Integer
[C#]
public int tmOverhang;
[C++]
public: int tmOverhang;
[JScript]
public var tmOverhang : int;

See Also

NativeMethods.TEXTMETRIC Class | NativeMethods.TEXTMETRIC Members | System.Core Namespace


NativeMethods.TEXTMETRIC.tmPitchAndFamily

[To be supplied.]

[Visual Basic]
Public tmPitchAndFamily As Byte
[C#]
public byte tmPitchAndFamily;
[C++]
public: unsigned char tmPitchAndFamily;
[JScript]
public var tmPitchAndFamily : Byte;

See Also

NativeMethods.TEXTMETRIC Class | NativeMethods.TEXTMETRIC Members | System.Core Namespace


NativeMethods.TEXTMETRIC.tmStruckOut

[To be supplied.]

[Visual Basic]
Public tmStruckOut As Byte
[C#]
public byte tmStruckOut;
[C++]
public: unsigned char tmStruckOut;
[JScript]
public var tmStruckOut : Byte;

See Also

NativeMethods.TEXTMETRIC Class | NativeMethods.TEXTMETRIC Members | System.Core Namespace


NativeMethods.TEXTMETRIC.tmUnderlined

[To be supplied.]

[Visual Basic]
Public tmUnderlined As Byte
[C#]
public byte tmUnderlined;
[C++]
public: unsigned char tmUnderlined;
[JScript]
public var tmUnderlined : Byte;

See Also

NativeMethods.TEXTMETRIC Class | NativeMethods.TEXTMETRIC Members | System.Core Namespace


NativeMethods.TEXTMETRIC.tmWeight

[To be supplied.]

[Visual Basic]
Public tmWeight As Integer
[C#]
public int tmWeight;
[C++]
public: int tmWeight;
[JScript]
public var tmWeight : int;

See Also

NativeMethods.TEXTMETRIC Class | NativeMethods.TEXTMETRIC Members | System.Core Namespace


NativeMethods.WNDCLASS Class

[To be supplied.]

Object
NativeMethods.WNDCLASS

[Visual Basic]
Public Class NativeMethods.WNDCLASS
[C#]
public class NativeMethods.WNDCLASS
[C++]
public __gc class NativeMethods.WNDCLASS
[JScript]
public class NativeMethods.WNDCLASS

Remarks

[To be supplied.]

Requirements

Namespace: System.Core

Assembly: System.dll

See Also

NativeMethods.WNDCLASS Members | System.Core Namespace


NativeMethods.WNDCLASS Members

Public:

Constructor

NativeMethodsWNDCLASS Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

cbClsExtra | [To be supplied.]
cbWndExtra | [To be supplied.]
hbrBackground | [To be supplied.]
hCursor | [To be supplied.]
hIcon | [To be supplied.]
hInstance | [To be supplied.]
lpfnWndProc | [To be supplied.]
lpszClassName | [To be supplied.]
lpszMenuName | [To be supplied.]
style | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NativeMethods.WNDCLASS Class | System.Core Namespace


NativeMethods.WNDCLASS Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public NativeMethods.WNDCLASS();
[C++]
public: NativeMethods.WNDCLASS();
[JScript]
public function NativeMethods.WNDCLASS();

See Also

NativeMethods.WNDCLASS Class | NativeMethods.WNDCLASS Members | System.Core Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

NativeMethods.WNDCLASS Fields

The fields of the NativeMethods.WNDCLASS class are listed below. For a complete list of NativeMethods.WNDCLASS class members, see the NativeMethods.WNDCLASS Members topic.

Public:

cbClsExtra | [To be supplied.]
cbWndExtra | [To be supplied.]
hbrBackground | [To be supplied.]
hCursor | [To be supplied.]
hIcon | [To be supplied.]
hInstance | [To be supplied.]
lpfnWndProc | [To be supplied.]
lpszClassName | [To be supplied.]
lpszMenuName | [To be supplied.]
style | [To be supplied.]

See Also

NativeMethods.WNDCLASS Class | System.Core Namespace


NativeMethods.WNDCLASS.cbClsExtra

[To be supplied.]

[Visual Basic]
Public cbClsExtra As Integer
[C#]
public int cbClsExtra;
[C++]
public: int cbClsExtra;
[JScript]
public var cbClsExtra : int;

See Also

NativeMethods.WNDCLASS Class | NativeMethods.WNDCLASS Members | System.Core Namespace


NativeMethods.WNDCLASS.cbWndExtra

[To be supplied.]

[Visual Basic]
Public cbWndExtra As Integer
[C#]
public int cbWndExtra;
[C++]
public: int cbWndExtra;
[JScript]
public var cbWndExtra : int;

See Also

NativeMethods.WNDCLASS Class | NativeMethods.WNDCLASS Members | System.Core Namespace


NativeMethods.WNDCLASS.hbrBackground

[To be supplied.]

[Visual Basic]
Public hbrBackground As Integer
[C#]
public int hbrBackground;
[C++]
public: int hbrBackground;
[JScript]
public var hbrBackground : int;

See Also

NativeMethods.WNDCLASS Class | NativeMethods.WNDCLASS Members | System.Core Namespace


NativeMethods.WNDCLASS.hCursor

[To be supplied.]

[Visual Basic]
Public hCursor As Integer
[C#]
public int hCursor;
[C++]
public: int hCursor;
[JScript]
public var hCursor : int;

See Also

NativeMethods.WNDCLASS Class | NativeMethods.WNDCLASS Members | System.Core Namespace


NativeMethods.WNDCLASS.hIcon

[To be supplied.]

[Visual Basic]
Public hIcon As Integer
[C#]
public int hIcon;
[C++]
public: int hIcon;
[JScript]
public var hIcon : int;

See Also

NativeMethods.WNDCLASS Class | NativeMethods.WNDCLASS Members | System.Core Namespace


NativeMethods.WNDCLASS.hInstance

[To be supplied.]

[Visual Basic]
Public hInstance As Integer
[C#]
public int hInstance;
[C++]
public: int hInstance;
[JScript]
public var hInstance : int;

See Also

NativeMethods.WNDCLASS Class | NativeMethods.WNDCLASS Members | System.Core Namespace


NativeMethods.WNDCLASS.lpfnWndProc

[To be supplied.]

[Visual Basic]
Public lpfnWndProc As NativeMethods.WndProc
[C#]
public NativeMethods.WndProc lpfnWndProc;
[C++]
public: NativeMethods.WndProc* lpfnWndProc;
[JScript]
public var lpfnWndProc : NativeMethods.WndProc;

See Also

NativeMethods.WNDCLASS Class | NativeMethods.WNDCLASS Members | System.Core Namespace


NativeMethods.WNDCLASS.lpszClassName

[To be supplied.]

[Visual Basic]
Public lpszClassName As String
[C#]
public string lpszClassName;
[C++]
public: String* lpszClassName;
[JScript]
public var lpszClassName : String;

See Also

NativeMethods.WNDCLASS Class | NativeMethods.WNDCLASS Members | System.Core Namespace


NativeMethods.WNDCLASS.lpszMenuName

[To be supplied.]

[Visual Basic]
Public lpszMenuName As String
[C#]
public string lpszMenuName;
[C++]
public: String* lpszMenuName;
[JScript]
public var lpszMenuName : String;

See Also

NativeMethods.WNDCLASS Class | NativeMethods.WNDCLASS Members | System.Core Namespace


NativeMethods.WNDCLASS.style

[To be supplied.]

[Visual Basic]
Public style As Integer
[C#]
public int style;
[C++]
public: int style;
[JScript]
public var style : int;

See Also

NativeMethods.WNDCLASS Class | NativeMethods.WNDCLASS Members | System.Core Namespace


NativeMethods.WndProc Delegate

[To be supplied.]

[Visual Basic]
Public Delegate Sub NativeMethods.WndProc( _
   ByVal hWnd As Integer, _
   ByVal msg As Integer, _
   ByVal wParam As Integer, _
   ByVal lParam As Integer _
) As Integer
[C#]
public delegate int NativeMethods.WndProc(
   int hWnd,
   int msg,
   int wParam,
   int lParam
);
[C++]
public __gc __delegate int NativeMethods.WndProc(
   int hWnd,
   int msg,
   int wParam,
   int lParam
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the NativeMethods.WndProc delegate declaration.

Remarks

[To be supplied.]

Requirements

Namespace: System.Core

Assembly: System.dll

See Also

System.Core Namespace


PowerModeChangedEventArgs Class

A session ended event is raised when the user is loging off or shutting down the system.

Object
EventArgs
PowerModeChangedEventArgs

[Visual Basic]
Public Class PowerModeChangedEventArgs
   Inherits EventArgs
[C#]
public class PowerModeChangedEventArgs : EventArgs
[C++]
public __gc class PowerModeChangedEventArgs : public EventArgs
[JScript]
public class PowerModeChangedEventArgs extends EventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.Core

Assembly: System.dll

See Also

PowerModeChangedEventArgs Members | System.Core Namespace


PowerModeChangedEventArgs Members

Public:

Constructor

PowerModeChangedEventArgs Constructor Creates a new PowerModeChangedEvent.

Properties

ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
Mode | The new power mode.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PowerModeChangedEventArgs Class | System.Core Namespace


PowerModeChangedEventArgs Constructor

Creates a new PowerModeChangedEvent.

[Visual Basic]
Public Sub New( _
   ByVal mode As PowerModes _
)
[C#]
public PowerModeChangedEventArgs(
   PowerModes mode
);
[C++]
public: PowerModeChangedEventArgs(
   PowerModes mode
);
[JScript]
public function PowerModeChangedEventArgs(
   mode : PowerModes
);

Parameters

mode
The new power mode.

See Also

PowerModeChangedEventArgs Class | PowerModeChangedEventArgs Members | System.Core Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PowerModeChangedEventArgs Properties

The properties of the PowerModeChangedEventArgs class are listed below. For a complete list of PowerModeChangedEventArgs class members, see the PowerModeChangedEventArgs Members topic.

Public:

ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
Mode | The new power mode.

See Also

PowerModeChangedEventArgs Class | System.Core Namespace


PowerModeChangedEventArgs.Mode

The new power mode.

[Visual Basic]
Public ReadOnly Property Mode As PowerModes
[C#]
public PowerModes Mode {get;}
[C++]
public: __property PowerModes get_Mode();
[JScript]
public function get Mode() : PowerModes;

See Also

PowerModeChangedEventArgs Class | PowerModeChangedEventArgs Members | System.Core Namespace


PowerModeChangedEventHandler Delegate

Represents the method that will handle the OnPowerModeChanged event.

[Visual Basic]
Public Delegate Sub PowerModeChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As PowerModeChangedEventArgs _
)
[C#]
public delegate void PowerModeChangedEventHandler(
   object sender,
   PowerModeChangedEventArgs e
);
[C++]
public __gc __delegate void PowerModeChangedEventHandler(
   Object* sender,
   PowerModeChangedEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the PowerModeChangedEventHandler delegate declaration.

sender
The source of the event. Since power mode notifications are global, this is always a null reference (in Visual Basic Nothing).
e
A PowerModeChangedEventArgs that contains the event data.

Remarks

When you create a PowerModeChangedEventHandler delegate, you identify the method that will handle the event. To associate the event with your event-handling method, add an instance of the delegate to the event. The event-handling method is called whenever the event occurs, unless you remove the delegate. For more information about event handler delegates, see TBD.

Requirements

Namespace: System.Core

Assembly: System.dll

See Also

System.Core Namespace


PowerModes Enumeration

This enum provides the various power mode changes a system may undergo.

[Visual Basic]
Public Enum PowerModes
[C#]
public enum PowerModes
[C++]
public enum PowerModes

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Resume | The system is about to be resumed.
StatusChange | The power mode status has changed. This may indicate a weak or charging battery, a transition from AC power from battery, or other change in the status of the system power supply.
Suspend | The system is about to be suspended.

Requirements

Namespace: System.Core

Assembly: System.dll

See Also

System.Core Namespace


SessionEndedEventArgs Class

A session ended event is raised when the user is loging off or shutting down the system.

Object
EventArgs
SessionEndedEventArgs

[Visual Basic]
Public Class SessionEndedEventArgs
   Inherits EventArgs
[C#]
public class SessionEndedEventArgs : EventArgs
[C++]
public __gc class SessionEndedEventArgs : public EventArgs
[JScript]
public class SessionEndedEventArgs extends EventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.Core

Assembly: System.dll

See Also

SessionEndedEventArgs Members | System.Core Namespace


SessionEndedEventArgs Members

Public:

Constructor

SessionEndedEventArgs Constructor Creates a new SessionEndedEvent.

Properties

ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
Reason | The reason for this event.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SessionEndedEventArgs Class | System.Core Namespace


SessionEndedEventArgs Constructor

Creates a new SessionEndedEvent.

[Visual Basic]
Public Sub New( _
   ByVal reason As SessionEndReasons _
)
[C#]
public SessionEndedEventArgs(
   SessionEndReasons reason
);
[C++]
public: SessionEndedEventArgs(
   SessionEndReasons reason
);
[JScript]
public function SessionEndedEventArgs(
   reason : SessionEndReasons
);

Parameters

reason
The reason the session has ended.

See Also

SessionEndedEventArgs Class | SessionEndedEventArgs Members | System.Core Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SessionEndedEventArgs Properties

The properties of the SessionEndedEventArgs class are listed below. For a complete list of SessionEndedEventArgs class members, see the SessionEndedEventArgs Members topic.

Public:

ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
Reason | The reason for this event.

See Also

SessionEndedEventArgs Class | System.Core Namespace


SessionEndedEventArgs.Reason

The reason for this event.

[Visual Basic]
Public ReadOnly Property Reason As SessionEndReasons
[C#]
public SessionEndReasons Reason {get;}
[C++]
public: __property SessionEndReasons get_Reason();
[JScript]
public function get Reason() : SessionEndReasons;

See Also

SessionEndedEventArgs Class | SessionEndedEventArgs Members | System.Core Namespace


SessionEndedEventHandler Delegate

Represents the method that will handle the OnSessionEnded event.

[Visual Basic]
Public Delegate Sub SessionEndedEventHandler( _
   ByVal sender As Object, _
   ByVal e As SessionEndedEventArgs _
)
[C#]
public delegate void SessionEndedEventHandler(
   object sender,
   SessionEndedEventArgs e
);
[C++]
public __gc __delegate void SessionEndedEventHandler(
   Object* sender,
   SessionEndedEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the SessionEndedEventHandler delegate declaration.

sender
The source of the event. Since session end notifications are global, this object is always a null reference (in Visual Basic Nothing).
e
A SessionEndedEventArgs that contains the event data.

Remarks

When you create a SessionEndedEventHandler delegate, you identify the method that will handle the event. To associate the event with your event-handling method, add an instance of the delegate to the event. The event-handling method is called whenever the event occurs, unless you remove the delegate. For more information about event handler delegates, see TBD.

Requirements

Namespace: System.Core

Assembly: System.dll

See Also

System.Core Namespace


SessionEndingEventArgs Class

A session ending event is raised when the user is trying to log off or shutdown the system.

Object
EventArgs
SessionEndingEventArgs

[Visual Basic]
Public Class SessionEndingEventArgs
   Inherits EventArgs
[C#]
public class SessionEndingEventArgs : EventArgs
[C++]
public __gc class SessionEndingEventArgs : public EventArgs
[JScript]
public class SessionEndingEventArgs extends EventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.Core

Assembly: System.dll

See Also

SessionEndingEventArgs Members | System.Core Namespace


SessionEndingEventArgs Members

Public:

Constructor

SessionEndingEventArgs Constructor Creates a new SessionEndingEvent.

Properties

Cancel | You may set this property to true to cancel the user request to end the session. This is no guarantee that the session won't end, it is just a request to keep it running.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
Reason | The reason for this event.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SessionEndingEventArgs Class | System.Core Namespace


SessionEndingEventArgs Constructor

Creates a new SessionEndingEvent.

[Visual Basic]
Public Sub New( _
   ByVal reason As SessionEndReasons _
)
[C#]
public SessionEndingEventArgs(
   SessionEndReasons reason
);
[C++]
public: SessionEndingEventArgs(
   SessionEndReasons reason
);
[JScript]
public function SessionEndingEventArgs(
   reason : SessionEndReasons
);

Parameters

reason
The reason the session is ending.

See Also

SessionEndingEventArgs Class | SessionEndingEventArgs Members | System.Core Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SessionEndingEventArgs Properties

The properties of the SessionEndingEventArgs class are listed below. For a complete list of SessionEndingEventArgs class members, see the SessionEndingEventArgs Members topic.

Public:

Cancel | You may set this property to true to cancel the user request to end the session. This is no guarantee that the session won't end, it is just a request to keep it running.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
Reason | The reason for this event.

See Also

SessionEndingEventArgs Class | System.Core Namespace


SessionEndingEventArgs.Cancel

You may set this property to true to cancel the user request to end the session. This is no guarantee that the session won't end, it is just a request to keep it running.

[Visual Basic]
Public Property Cancel As Boolean
[C#]
public bool Cancel {get; set;}
[C++]
public: __property bool get_Cancel();
public: __property void set_Cancel(bool);
[JScript]
public function get Cancel() : Boolean;
public function set Cancel(Boolean);

See Also

SessionEndingEventArgs Class | SessionEndingEventArgs Members | System.Core Namespace


SessionEndingEventArgs.Reason

The reason for this event.

[Visual Basic]
Public ReadOnly Property Reason As SessionEndReasons
[C#]
public SessionEndReasons Reason {get;}
[C++]
public: __property SessionEndReasons get_Reason();
[JScript]
public function get Reason() : SessionEndReasons;

See Also

SessionEndingEventArgs Class | SessionEndingEventArgs Members | System.Core Namespace


SessionEndingEventHandler Delegate

Represents the method that will handle the OnSessionEnding event.

[Visual Basic]
Public Delegate Sub SessionEndingEventHandler( _
   ByVal sender As Object, _
   ByVal e As SessionEndingEventArgs _
)
[C#]
public delegate void SessionEndingEventHandler(
   object sender,
   SessionEndingEventArgs e
);
[C++]
public __gc __delegate void SessionEndingEventHandler(
   Object* sender,
   SessionEndingEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the SessionEndingEventHandler delegate declaration.

sender
The source of the event. Since session end notifications are global, this object is always a null reference (in Visual Basic Nothing).
e
A SessionEndingEventArgs that contains the event data.

Remarks

When you create a SessionEndingEventHandler delegate, you identify the method that will handle the event. To associate the event with your event-handling method, add an instance of the delegate to the event. The event-handling method is called whenever the event occurs, unless you remove the delegate. For more information about event handler delegates, see TBD.

Requirements

Namespace: System.Core

Assembly: System.dll

See Also

System.Core Namespace


SessionEndReasons Enumeration

This enum provides reasons the current logon session may be ending.

[Visual Basic]
Public Enum SessionEndReasons
[C#]
public enum SessionEndReasons
[C++]
public enum SessionEndReasons

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Logoff | The user is logging off. The system may continue running but the user who started this application is logging off.
SystemShutdown | The system is shutting down.

Requirements

Namespace: System.Core

Assembly: System.dll

See Also

System.Core Namespace


SystemEvents Class

The SystemEvents class provides a set of global system events to callers. System events are such things as shutdown notifications and changes to user preferences. When a system event is raised it will call back the corresponding delegate from a different thread. You should be prepared for this, and make the call thread-safe. You should not do time-consuming processing in a system event notification because it may prevent other applications from functioning.

Object
SystemEvents

[Visual Basic]
NotInheritable Public Class SystemEvents
[C#]
public sealed class SystemEvents
[C++]
public __gc __sealed class SystemEvents
[JScript]
public class SystemEvents

Remarks

[To be supplied.]

Requirements

Namespace: System.Core

Assembly: System.dll

See Also

SystemEvents Members | System.Core Namespace


SystemEvents Members

Public:

Methods

CreateTimer | Creates a new window timer asociated with the system events window.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
KillTimer | Kills the timer specified by the given id.
ToString (inherited from Object) | Returns a String that represents the current Object.

Events

DisplaySettingsChanged | [To be supplied.]
InstalledFontsChanged | [To be supplied.]
LowMemory | [To be supplied.]
PaletteChanged | [To be supplied.]
PowerModeChanged | [To be supplied.]
SessionEnded | [To be supplied.]
SessionEnding | [To be supplied.]
TimeChanged | [To be supplied.]
TimerElapsed | [To be supplied.]
UserPreferenceChanged | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Event Hookup:

Methods

AddOnDisplaySettingsChanged | Adds an event handler that will be called when the display settings change. This event occurs when the display resolution or color depth changes, or a monitor is added or removed.
AddOnInstalledFontsChanged | Adds an event handler that will be called a new font is added or removed from the set of installed system fonts.
AddOnLowMemory | Adds an event handler that will be called when the memory of the system is low. Different operating systems may raise this event for different reasons, but it usually indicates that the system is having trouble finding enough available memory to operate. On Windows 2000 systems, for example, this event will be raised when the system is spending more than 50% of its processor time locating memory than running user code.
AddOnPaletteChanged | Adds an event handler that will be called when the color palette changes.
AddOnPowerModeChanged | Adds an event handler that will be called when the power mode of the system has changed. This event may fire when the system goes into a sleep or low power mode, or when it wakes up from such a mode.
AddOnSessionEnded | Adds an event handler that will be called when the current logon session is about to end.
AddOnSessionEnding | Adds an event handler that will be called when the current logon session is ending. You may cancel this by setting Cancel in the event args to true. If you do not cancel, all applications will be closed and the user will be logged off. Generally, a SessionEnded event will occur after this, but it is not guaranteed.
AddOnTimeChanged | Adds an event handler that will be called when the time or date has changed. This can occur through user action or when the system adjusts for daylight savings time.
AddOnTimerElapsed | Adds an event handler that will be called when a windows timer interval expires.
AddOnUserPreferenceChanged | Adds an event handler that will be called when the user preferences have changed. User preferences are things such as keyboard settings, color choices, and font sizes. Operating systems may allow customization of these items, and this event provides a way for objects to know when when a particular item has changed. Event handlers may be called in any order-- your handler may even run before System.Drawing.Color is told that the system colors have changed! For this reason, you should do as little as possible inside your handler-- consider invalidating objects rather than regenerating them.
RemoveOnDisplaySettingsChanged | Removes a previously added event handler.
RemoveOnInstalledFontsChanged | Removes a previously added event handler.
RemoveOnLowMemory | Removes a previously added event handler.
RemoveOnPaletteChanged | Removes a previously added event handler.
RemoveOnPowerModeChanged | Removes a previously added event handler.
RemoveOnSessionEnded | Removes a previously added event handler.
RemoveOnSessionEnding | Removes a previously added event handler.
RemoveOnTimeChanged | Removes a previously added event handler.
RemoveOnTimerElapsed | Removes a previously added event handler.
RemoveOnUserPreferenceChanged | Removes a previously added event handler.

See Also

SystemEvents Class | System.Core Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SystemEvents Methods

The methods of the SystemEvents class are listed below. For a complete list of SystemEvents class members, see the SystemEvents Members topic.

Public:

CreateTimer | Creates a new window timer asociated with the system events window.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
KillTimer | Kills the timer specified by the given id.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Event Hookup:

AddOnDisplaySettingsChanged | Adds an event handler that will be called when the display settings change. This event occurs when the display resolution or color depth changes, or a monitor is added or removed.
AddOnInstalledFontsChanged | Adds an event handler that will be called a new font is added or removed from the set of installed system fonts.
AddOnLowMemory | Adds an event handler that will be called when the memory of the system is low. Different operating systems may raise this event for different reasons, but it usually indicates that the system is having trouble finding enough available memory to operate. On Windows 2000 systems, for example, this event will be raised when the system is spending more than 50% of its processor time locating memory than running user code.
AddOnPaletteChanged | Adds an event handler that will be called when the color palette changes.
AddOnPowerModeChanged | Adds an event handler that will be called when the power mode of the system has changed. This event may fire when the system goes into a sleep or low power mode, or when it wakes up from such a mode.
AddOnSessionEnded | Adds an event handler that will be called when the current logon session is about to end.
AddOnSessionEnding | Adds an event handler that will be called when the current logon session is ending. You may cancel this by setting Cancel in the event args to true. If you do not cancel, all applications will be closed and the user will be logged off. Generally, a SessionEnded event will occur after this, but it is not guaranteed.
AddOnTimeChanged | Adds an event handler that will be called when the time or date has changed. This can occur through user action or when the system adjusts for daylight savings time.
AddOnTimerElapsed | Adds an event handler that will be called when a windows timer interval expires.
AddOnUserPreferenceChanged | Adds an event handler that will be called when the user preferences have changed. User preferences are things such as keyboard settings, color choices, and font sizes. Operating systems may allow customization of these items, and this event provides a way for objects to know when when a particular item has changed. Event handlers may be called in any order-- your handler may even run before System.Drawing.Color is told that the system colors have changed! For this reason, you should do as little as possible inside your handler-- consider invalidating objects rather than regenerating them.
RemoveOnDisplaySettingsChanged | Removes a previously added event handler.
RemoveOnInstalledFontsChanged | Removes a previously added event handler.
RemoveOnLowMemory | Removes a previously added event handler.
RemoveOnPaletteChanged | Removes a previously added event handler.
RemoveOnPowerModeChanged | Removes a previously added event handler.
RemoveOnSessionEnded | Removes a previously added event handler.
RemoveOnSessionEnding | Removes a previously added event handler.
RemoveOnTimeChanged | Removes a previously added event handler.
RemoveOnTimerElapsed | Removes a previously added event handler.
RemoveOnUserPreferenceChanged | Removes a previously added event handler.

See Also

SystemEvents Class | System.Core Namespace


SystemEvents.AddOnDisplaySettingsChanged

Adds an event handler that will be called when the display settings change. This event occurs when the display resolution or color depth changes, or a monitor is added or removed.

[Visual Basic]
Public Shared Sub AddOnDisplaySettingsChanged( _
   ByVal handler As EventHandler _
)
[C#]
public static void AddOnDisplaySettingsChanged(
   EventHandler handler
);
[C++]
public: static void AddOnDisplaySettingsChanged(
   EventHandler* handler
);
[JScript]
public static function AddOnDisplaySettingsChanged(
   handler : EventHandler
);

Parameters

handler
The event handler to be added.

See Also

SystemEvents Class | SystemEvents Members | System.Core Namespace | TBD


SystemEvents.AddOnInstalledFontsChanged

Adds an event handler that will be called a new font is added or removed from the set of installed system fonts.

[Visual Basic]
Public Shared Sub AddOnInstalledFontsChanged( _
   ByVal handler As EventHandler _
)
[C#]
public static void AddOnInstalledFontsChanged(
   EventHandler handler
);
[C++]
public: static void AddOnInstalledFontsChanged(
   EventHandler* handler
);
[JScript]
public static function AddOnInstalledFontsChanged(
   handler : EventHandler
);

Parameters

handler
The event handler to be added.

See Also

SystemEvents Class | SystemEvents Members | System.Core Namespace | TBD


SystemEvents.AddOnLowMemory

Adds an event handler that will be called when the memory of the system is low. Different operating systems may raise this event for different reasons, but it usually indicates that the system is having trouble finding enough available memory to operate. On Windows 2000 systems, for example, this event will be raised when the system is spending more than 50% of its processor time locating memory than running user code.

[Visual Basic]
Public Shared Sub AddOnLowMemory( _
   ByVal handler As EventHandler _
)
[C#]
public static void AddOnLowMemory(
   EventHandler handler
);
[C++]
public: static void AddOnLowMemory(
   EventHandler* handler
);
[JScript]
public static function AddOnLowMemory(
   handler : EventHandler
);

Parameters

handler
The event handler to be added.

See Also

SystemEvents Class | SystemEvents Members | System.Core Namespace | TBD


SystemEvents.AddOnPaletteChanged

Adds an event handler that will be called when the color palette changes.

[Visual Basic]
Public Shared Sub AddOnPaletteChanged( _
   ByVal handler As EventHandler _
)
[C#]
public static void AddOnPaletteChanged(
   EventHandler handler
);
[C++]
public: static void AddOnPaletteChanged(
   EventHandler* handler
);
[JScript]
public static function AddOnPaletteChanged(
   handler : EventHandler
);

Parameters

handler
The event handler to be added.

See Also

SystemEvents Class | SystemEvents Members | System.Core Namespace | TBD


SystemEvents.AddOnPowerModeChanged

Adds an event handler that will be called when the power mode of the system has changed. This event may fire when the system goes into a sleep or low power mode, or when it wakes up from such a mode.

[Visual Basic]
Public Shared Sub AddOnPowerModeChanged( _
   ByVal handler As PowerModeChangedEventHandler _
)
[C#]
public static void AddOnPowerModeChanged(
   PowerModeChangedEventHandler handler
);
[C++]
public: static void AddOnPowerModeChanged(
   PowerModeChangedEventHandler* handler
);
[JScript]
public static function AddOnPowerModeChanged(
   handler : PowerModeChangedEventHandler
);

Parameters

handler
The event handler to be added.

See Also

SystemEvents Class | SystemEvents Members | System.Core Namespace | TBD


SystemEvents.AddOnSessionEnded

Adds an event handler that will be called when the current logon session is about to end.

[Visual Basic]
Public Shared Sub AddOnSessionEnded( _
   ByVal handler As SessionEndedEventHandler _
)
[C#]
public static void AddOnSessionEnded(
   SessionEndedEventHandler handler
);
[C++]
public: static void AddOnSessionEnded(
   SessionEndedEventHandler* handler
);
[JScript]
public static function AddOnSessionEnded(
   handler : SessionEndedEventHandler
);

Parameters

handler
The event handler to be added.

See Also

SystemEvents Class | SystemEvents Members | System.Core Namespace | TBD


SystemEvents.AddOnSessionEnding

Adds an event handler that will be called when the current logon session is ending. You may cancel this by setting Cancel in the event args to true. If you do not cancel, all applications will be closed and the user will be logged off. Generally, a SessionEnded event will occur after this, but it is not guaranteed.

[Visual Basic]
Public Shared Sub AddOnSessionEnding( _
   ByVal handler As SessionEndingEventHandler _
)
[C#]
public static void AddOnSessionEnding(
   SessionEndingEventHandler handler
);
[C++]
public: static void AddOnSessionEnding(
   SessionEndingEventHandler* handler
);
[JScript]
public static function AddOnSessionEnding(
   handler : SessionEndingEventHandler
);

Parameters

handler
The event handler to be added.

See Also

SystemEvents Class | SystemEvents Members | System.Core Namespace | TBD


SystemEvents.AddOnTimeChanged

Adds an event handler that will be called when the time or date has changed. This can occur through user action or when the system adjusts for daylight savings time.

[Visual Basic]
Public Shared Sub AddOnTimeChanged( _
   ByVal handler As EventHandler _
)
[C#]
public static void AddOnTimeChanged(
   EventHandler handler
);
[C++]
public: static void AddOnTimeChanged(
   EventHandler* handler
);
[JScript]
public static function AddOnTimeChanged(
   handler : EventHandler
);

Parameters

handler
The event handler to be added.

See Also

SystemEvents Class | SystemEvents Members | System.Core Namespace | TBD


SystemEvents.AddOnTimerElapsed

Adds an event handler that will be called when a windows timer interval expires.

[Visual Basic]
Public Shared Sub AddOnTimerElapsed( _
   ByVal handler As TimerElapsedEventHandler _
)
[C#]
public static void AddOnTimerElapsed(
   TimerElapsedEventHandler handler
);
[C++]
public: static void AddOnTimerElapsed(
   TimerElapsedEventHandler* handler
);
[JScript]
public static function AddOnTimerElapsed(
   handler : TimerElapsedEventHandler
);

Parameters

handler
The event handler to be added.

See Also

SystemEvents Class | SystemEvents Members | System.Core Namespace | TBD


SystemEvents.AddOnUserPreferenceChanged

Adds an event handler that will be called when the user preferences have changed. User preferences are things such as keyboard settings, color choices, and font sizes. Operating systems may allow customization of these items, and this event provides a way for objects to know when when a particular item has changed.

Event handlers may be called in any order-- your handler may even run before System.Drawing.Color is told that the system colors have changed! For this reason, you should do as little as possible inside your handler-- consider invalidating objects rather than regenerating them.

[Visual Basic]
Public Shared Sub AddOnUserPreferenceChanged( _
   ByVal handler As UserPreferenceChangedEventHandler _
)
[C#]
public static void AddOnUserPreferenceChanged(
   UserPreferenceChangedEventHandler handler
);
[C++]
public: static void AddOnUserPreferenceChanged(
   UserPreferenceChangedEventHandler* handler
);
[JScript]
public static function AddOnUserPreferenceChanged(
   handler : UserPreferenceChangedEventHandler
);

Parameters

handler
The event handler to be added.

See Also

SystemEvents Class | SystemEvents Members | System.Core Namespace | TBD


SystemEvents.CreateTimer

Creates a new window timer asociated with the system events window.

[Visual Basic]
Public Shared Function CreateTimer( _
   ByVal interval As Integer _
) As Integer
[C#]
public static int CreateTimer(
   int interval
);
[C++]
public: static int CreateTimer(
   int interval
);
[JScript]
public static function CreateTimer(
   interval : int
) : int;

Parameters

interval
Specifies the interval between timer notifications.

Return Value

The id of the timer created.

See Also

SystemEvents Class | SystemEvents Members | System.Core Namespace


SystemEvents.KillTimer

Kills the timer specified by the given id.

[Visual Basic]
Public Shared Sub KillTimer( _
   ByVal timerId As Integer _
)
[C#]
public static void KillTimer(
   int timerId
);
[C++]
public: static void KillTimer(
   int timerId
);
[JScript]
public static function KillTimer(
   timerId : int
);

Parameters

timerId
The id for the timer to kill.

See Also

SystemEvents Class | SystemEvents Members | System.Core Namespace


SystemEvents.RemoveOnDisplaySettingsChanged

Removes a previously added event handler.

[Visual Basic]
Public Shared Sub RemoveOnDisplaySettingsChanged( _
   ByVal handler As EventHandler _
)
[C#]
public static void RemoveOnDisplaySettingsChanged(
   EventHandler handler
);
[C++]
public: static void RemoveOnDisplaySettingsChanged(
   EventHandler* handler
);
[JScript]
public static function RemoveOnDisplaySettingsChanged(
   handler : EventHandler
);

Parameters

handler
The event handler to be removed.

See Also

SystemEvents Class | SystemEvents Members | System.Core Namespace | TBD


SystemEvents.RemoveOnInstalledFontsChanged

Removes a previously added event handler.

[Visual Basic]
Public Shared Sub RemoveOnInstalledFontsChanged( _
   ByVal handler As EventHandler _
)
[C#]
public static void RemoveOnInstalledFontsChanged(
   EventHandler handler
);
[C++]
public: static void RemoveOnInstalledFontsChanged(
   EventHandler* handler
);
[JScript]
public static function RemoveOnInstalledFontsChanged(
   handler : EventHandler
);

Parameters

handler
The event handler to be removed.

See Also

SystemEvents Class | SystemEvents Members | System.Core Namespace | TBD


SystemEvents.RemoveOnLowMemory

Removes a previously added event handler.

[Visual Basic]
Public Shared Sub RemoveOnLowMemory( _
   ByVal handler As EventHandler _
)
[C#]
public static void RemoveOnLowMemory(
   EventHandler handler
);
[C++]
public: static void RemoveOnLowMemory(
   EventHandler* handler
);
[JScript]
public static function RemoveOnLowMemory(
   handler : EventHandler
);

Parameters

handler
The event handler to be removed.

See Also

SystemEvents Class | SystemEvents Members | System.Core Namespace | TBD


SystemEvents.RemoveOnPaletteChanged

Removes a previously added event handler.

[Visual Basic]
Public Shared Sub RemoveOnPaletteChanged( _
   ByVal handler As EventHandler _
)
[C#]
public static void RemoveOnPaletteChanged(
   EventHandler handler
);
[C++]
public: static void RemoveOnPaletteChanged(
   EventHandler* handler
);
[JScript]
public static function RemoveOnPaletteChanged(
   handler : EventHandler
);

Parameters

handler
The event handler to be removed.

See Also

SystemEvents Class | SystemEvents Members | System.Core Namespace | TBD


SystemEvents.RemoveOnPowerModeChanged

Removes a previously added event handler.

[Visual Basic]
Public Shared Sub RemoveOnPowerModeChanged( _
   ByVal handler As PowerModeChangedEventHandler _
)
[C#]
public static void RemoveOnPowerModeChanged(
   PowerModeChangedEventHandler handler
);
[C++]
public: static void RemoveOnPowerModeChanged(
   PowerModeChangedEventHandler* handler
);
[JScript]
public static function RemoveOnPowerModeChanged(
   handler : PowerModeChangedEventHandler
);

Parameters

handler
The event handler to be removed.

See Also

SystemEvents Class | SystemEvents Members | System.Core Namespace | TBD


SystemEvents.RemoveOnSessionEnded

Removes a previously added event handler.

[Visual Basic]
Public Shared Sub RemoveOnSessionEnded( _
   ByVal handler As SessionEndedEventHandler _
)
[C#]
public static void RemoveOnSessionEnded(
   SessionEndedEventHandler handler
);
[C++]
public: static void RemoveOnSessionEnded(
   SessionEndedEventHandler* handler
);
[JScript]
public static function RemoveOnSessionEnded(
   handler : SessionEndedEventHandler
);

Parameters

handler
The event handler to be removed.

See Also

SystemEvents Class | SystemEvents Members | System.Core Namespace | TBD


SystemEvents.RemoveOnSessionEnding

Removes a previously added event handler.

[Visual Basic]
Public Shared Sub RemoveOnSessionEnding( _
   ByVal handler As SessionEndingEventHandler _
)
[C#]
public static void RemoveOnSessionEnding(
   SessionEndingEventHandler handler
);
[C++]
public: static void RemoveOnSessionEnding(
   SessionEndingEventHandler* handler
);
[JScript]
public static function RemoveOnSessionEnding(
   handler : SessionEndingEventHandler
);

Parameters

handler
The event handler to be removed.

See Also

SystemEvents Class | SystemEvents Members | System.Core Namespace | TBD


SystemEvents.RemoveOnTimeChanged

Removes a previously added event handler.

[Visual Basic]
Public Shared Sub RemoveOnTimeChanged( _
   ByVal handler As EventHandler _
)
[C#]
public static void RemoveOnTimeChanged(
   EventHandler handler
);
[C++]
public: static void RemoveOnTimeChanged(
   EventHandler* handler
);
[JScript]
public static function RemoveOnTimeChanged(
   handler : EventHandler
);

Parameters

handler
The event handler to be removed.

See Also

SystemEvents Class | SystemEvents Members | System.Core Namespace | TBD


SystemEvents.RemoveOnTimerElapsed

Removes a previously added event handler.

[Visual Basic]
Public Shared Sub RemoveOnTimerElapsed( _
   ByVal handler As TimerElapsedEventHandler _
)
[C#]
public static void RemoveOnTimerElapsed(
   TimerElapsedEventHandler handler
);
[C++]
public: static void RemoveOnTimerElapsed(
   TimerElapsedEventHandler* handler
);
[JScript]
public static function RemoveOnTimerElapsed(
   handler : TimerElapsedEventHandler
);

Parameters

handler
The event handler to be removed.

See Also

SystemEvents Class | SystemEvents Members | System.Core Namespace | TBD


SystemEvents.RemoveOnUserPreferenceChanged

Removes a previously added event handler.

[Visual Basic]
Public Shared Sub RemoveOnUserPreferenceChanged( _
   ByVal handler As UserPreferenceChangedEventHandler _
)
[C#]
public static void RemoveOnUserPreferenceChanged(
   UserPreferenceChangedEventHandler handler
);
[C++]
public: static void RemoveOnUserPreferenceChanged(
   UserPreferenceChangedEventHandler* handler
);
[JScript]
public static function RemoveOnUserPreferenceChanged(
   handler : UserPreferenceChangedEventHandler
);

Parameters

handler
The event handler to be removed.

See Also

SystemEvents Class | SystemEvents Members | System.Core Namespace | TBD


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SystemEvents Events

The events of the SystemEvents class are listed below. For a complete list of SystemEvents class members, see the SystemEvents Members topic.

Public:

DisplaySettingsChanged | [To be supplied.]
InstalledFontsChanged | [To be supplied.]
LowMemory | [To be supplied.]
PaletteChanged | [To be supplied.]
PowerModeChanged | [To be supplied.]
SessionEnded | [To be supplied.]
SessionEnding | [To be supplied.]
TimeChanged | [To be supplied.]
TimerElapsed | [To be supplied.]
UserPreferenceChanged | [To be supplied.]

See Also

SystemEvents Class | System.Core Namespace


SystemEvents DisplaySettingsChanged Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the DisplaySettingsChanged event.

[Visual Basic]
Private Sub SystemEventsName_DisplaySettingsChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
private void SystemEventsName_DisplaySettingsChanged(
   object sender,
   EventArgs e
);
[C++]
private: void SystemEventsName_DisplaySettingsChanged(
   Object* sender,
   EventArgs* e
);
[JScript]
private SystemEventsName_DisplaySettingsChanged(
   sender : Object,
   e : EventArgs
);

Parameters

sender
The source of the event.
e
An EventArgs that contains the event data. The following EventArgs properties provide information specific to this event.
Property Description
ExtendedInfo
Holds a reference to an object that manages the event's state.

See Also

SystemEvents Class | SystemEvents MembersTopic | System.Core Namespace


SystemEvents InstalledFontsChanged Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the InstalledFontsChanged event.

[Visual Basic]
Private Sub SystemEventsName_InstalledFontsChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
private void SystemEventsName_InstalledFontsChanged(
   object sender,
   EventArgs e
);
[C++]
private: void SystemEventsName_InstalledFontsChanged(
   Object* sender,
   EventArgs* e
);
[JScript]
private SystemEventsName_InstalledFontsChanged(
   sender : Object,
   e : EventArgs
);

Parameters

sender
The source of the event.
e
An EventArgs that contains the event data. The following EventArgs properties provide information specific to this event.
Property Description
ExtendedInfo
Holds a reference to an object that manages the event's state.

See Also

SystemEvents Class | SystemEvents MembersTopic | System.Core Namespace


SystemEvents LowMemory Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the LowMemory event.

[Visual Basic]
Private Sub SystemEventsName_LowMemory( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
private void SystemEventsName_LowMemory(
   object sender,
   EventArgs e
);
[C++]
private: void SystemEventsName_LowMemory(
   Object* sender,
   EventArgs* e
);
[JScript]
private SystemEventsName_LowMemory(
   sender : Object,
   e : EventArgs
);

Parameters

sender
The source of the event.
e
An EventArgs that contains the event data. The following EventArgs properties provide information specific to this event.
Property Description
ExtendedInfo
Holds a reference to an object that manages the event's state.

See Also

SystemEvents Class | SystemEvents MembersTopic | System.Core Namespace


SystemEvents PaletteChanged Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the PaletteChanged event.

[Visual Basic]
Private Sub SystemEventsName_PaletteChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
private void SystemEventsName_PaletteChanged(
   object sender,
   EventArgs e
);
[C++]
private: void SystemEventsName_PaletteChanged(
   Object* sender,
   EventArgs* e
);
[JScript]
private SystemEventsName_PaletteChanged(
   sender : Object,
   e : EventArgs
);

Parameters

sender
The source of the event.
e
An EventArgs that contains the event data. The following EventArgs properties provide information specific to this event.
Property Description
ExtendedInfo
Holds a reference to an object that manages the event's state.

See Also

SystemEvents Class | SystemEvents MembersTopic | System.Core Namespace


SystemEvents PowerModeChanged Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the PowerModeChanged event.

[Visual Basic]
Private Sub SystemEventsName_PowerModeChanged( _
   ByVal sender As Object, _
   ByVal e As PowerModeChangedEventArgs _
)
[C#]
private void SystemEventsName_PowerModeChanged(
   object sender,
   PowerModeChangedEventArgs e
);
[C++]
private: void SystemEventsName_PowerModeChanged(
   Object* sender,
   PowerModeChangedEventArgs* e
);
[JScript]
private SystemEventsName_PowerModeChanged(
   sender : Object,
   e : PowerModeChangedEventArgs
);

Parameters

sender
The source of the event.
e
A PowerModeChangedEventArgs that contains the event data. The following PowerModeChangedEventArgs properties provide information specific to this event.
Property Description
Mode
The new power mode.

See Also

SystemEvents Class | SystemEvents MembersTopic | System.Core Namespace


SystemEvents SessionEnded Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the SessionEnded event.

[Visual Basic]
Private Sub SystemEventsName_SessionEnded( _
   ByVal sender As Object, _
   ByVal e As SessionEndedEventArgs _
)
[C#]
private void SystemEventsName_SessionEnded(
   object sender,
   SessionEndedEventArgs e
);
[C++]
private: void SystemEventsName_SessionEnded(
   Object* sender,
   SessionEndedEventArgs* e
);
[JScript]
private SystemEventsName_SessionEnded(
   sender : Object,
   e : SessionEndedEventArgs
);

Parameters

sender
The source of the event.
e
A SessionEndedEventArgs that contains the event data. The following SessionEndedEventArgs properties provide information specific to this event.
Property Description
Reason
The reason for this event.

See Also

SystemEvents Class | SystemEvents MembersTopic | System.Core Namespace


SystemEvents SessionEnding Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the SessionEnding event.

[Visual Basic]
Private Sub SystemEventsName_SessionEnding( _
   ByVal sender As Object, _
   ByVal e As SessionEndingEventArgs _
)
[C#]
private void SystemEventsName_SessionEnding(
   object sender,
   SessionEndingEventArgs e
);
[C++]
private: void SystemEventsName_SessionEnding(
   Object* sender,
   SessionEndingEventArgs* e
);
[JScript]
private SystemEventsName_SessionEnding(
   sender : Object,
   e : SessionEndingEventArgs
);

Parameters

sender
The source of the event.
e
A SessionEndingEventArgs that contains the event data. The following SessionEndingEventArgs properties provide information specific to this event.
Property Description
Cancel
You may set this property to true to cancel the user request to end the session. This is no guarantee that the session won't end, it is just a request to keep it running.
Reason
The reason for this event.

See Also

SystemEvents Class | SystemEvents MembersTopic | System.Core Namespace


SystemEvents TimeChanged Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the TimeChanged event.

[Visual Basic]
Private Sub SystemEventsName_TimeChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
private void SystemEventsName_TimeChanged(
   object sender,
   EventArgs e
);
[C++]
private: void SystemEventsName_TimeChanged(
   Object* sender,
   EventArgs* e
);
[JScript]
private SystemEventsName_TimeChanged(
   sender : Object,
   e : EventArgs
);

Parameters

sender
The source of the event.
e
An EventArgs that contains the event data. The following EventArgs properties provide information specific to this event.
Property Description
ExtendedInfo
Holds a reference to an object that manages the event's state.

See Also

SystemEvents Class | SystemEvents MembersTopic | System.Core Namespace


SystemEvents TimerElapsed Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the TimerElapsed event.

[Visual Basic]
Private Sub SystemEventsName_TimerElapsed( _
   ByVal sender As Object, _
   ByVal e As TimerElapsedEventArgs _
)
[C#]
private void SystemEventsName_TimerElapsed(
   object sender,
   TimerElapsedEventArgs e
);
[C++]
private: void SystemEventsName_TimerElapsed(
   Object* sender,
   TimerElapsedEventArgs* e
);
[JScript]
private SystemEventsName_TimerElapsed(
   sender : Object,
   e : TimerElapsedEventArgs
);

Parameters

sender
The source of the event.
e
A TimerElapsedEventArgs that contains the event data. The following TimerElapsedEventArgs properties provide information specific to this event.
Property Description
TimerId
The new timer id.

See Also

SystemEvents Class | SystemEvents MembersTopic | System.Core Namespace


SystemEvents UserPreferenceChanged Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the UserPreferenceChanged event.

[Visual Basic]
Private Sub SystemEventsName_UserPreferenceChanged( _
   ByVal sender As Object, _
   ByVal e As UserPreferenceChangedEventArgs _
)
[C#]
private void SystemEventsName_UserPreferenceChanged(
   object sender,
   UserPreferenceChangedEventArgs e
);
[C++]
private: void SystemEventsName_UserPreferenceChanged(
   Object* sender,
   UserPreferenceChangedEventArgs* e
);
[JScript]
private SystemEventsName_UserPreferenceChanged(
   sender : Object,
   e : UserPreferenceChangedEventArgs
);

Parameters

sender
The source of the event.
e
An UserPreferenceChangedEventArgs that contains the event data. The following UserPreferenceChangedEventArgs properties provide information specific to this event.
Property Description
Category
The category of user preferences that have changed.

See Also

SystemEvents Class | SystemEvents MembersTopic | System.Core Namespace


TimerElapsedEventArgs Class

A timer ellapsed event is raised when a windows timer interval has expired.

Object
EventArgs
TimerElapsedEventArgs

[Visual Basic]
Public Class TimerElapsedEventArgs
   Inherits EventArgs
[C#]
public class TimerElapsedEventArgs : EventArgs
[C++]
public __gc class TimerElapsedEventArgs : public EventArgs
[JScript]
public class TimerElapsedEventArgs extends EventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.Core

Assembly: System.dll

See Also

TimerElapsedEventArgs Members | System.Core Namespace


TimerElapsedEventArgs Members

Public:

Constructor

TimerElapsedEventArgs Constructor Creates a new TimerElapsedEvent.

Properties

ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
TimerId | The new timer id.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimerElapsedEventArgs Class | System.Core Namespace


TimerElapsedEventArgs Constructor

Creates a new TimerElapsedEvent.

[Visual Basic]
Public Sub New( _
   ByVal timerId As Integer _
)
[C#]
public TimerElapsedEventArgs(
   int timerId
);
[C++]
public: TimerElapsedEventArgs(
   int timerId
);
[JScript]
public function TimerElapsedEventArgs(
   timerId : int
);

Parameters

timerId
[To be supplied.]

See Also

TimerElapsedEventArgs Class | TimerElapsedEventArgs Members | System.Core Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TimerElapsedEventArgs Properties

The properties of the TimerElapsedEventArgs class are listed below. For a complete list of TimerElapsedEventArgs class members, see the TimerElapsedEventArgs Members topic.

Public:

ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
TimerId | The new timer id.

See Also

TimerElapsedEventArgs Class | System.Core Namespace


TimerElapsedEventArgs.TimerId

The new timer id.

[Visual Basic]
Public ReadOnly Property TimerId As Integer
[C#]
public int TimerId {get;}
[C++]
public: __property int get_TimerId();
[JScript]
public function get TimerId() : int;

See Also

TimerElapsedEventArgs Class | TimerElapsedEventArgs Members | System.Core Namespace


TimerElapsedEventHandler Delegate

Represents the method that will handle the OnTimerElapsed event.

[Visual Basic]
Public Delegate Sub TimerElapsedEventHandler( _
   ByVal sender As Object, _
   ByVal e As TimerElapsedEventArgs _
)
[C#]
public delegate void TimerElapsedEventHandler(
   object sender,
   TimerElapsedEventArgs e
);
[C++]
public __gc __delegate void TimerElapsedEventHandler(
   Object* sender,
   TimerElapsedEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the TimerElapsedEventHandler delegate declaration.

sender
The source of the event. Since timer interval changes are global changes, this object is always a null reference (in Visual Basic Nothing).
e
A TimerElapsedEventArgs that contains the event data.

Remarks

When you create a TimerElapsedEventHandler delegate, you identify the method that will handle the event. To associate the event with your event-handling method, add an instance of the delegate to the event. The event-handling method is called whenever the event occurs, unless you remove the delegate. For more information about event handler delegates, see TBD.

Requirements

Namespace: System.Core

Assembly: System.dll

See Also

System.Core Namespace


UNDONE Class

[To be supplied.]

Object
UNDONE

[Visual Basic]
Public Class UNDONE
[C#]
public class UNDONE
[C++]
public __gc class UNDONE
[JScript]
public class UNDONE

Remarks

[To be supplied.]

Requirements

Namespace: System.Core

Assembly: System.dll

See Also

UNDONE Members | System.Core Namespace


UNDONE Members

Public:

Constructor

UNDONE Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SortIList | [To be supplied.]
StripURL | Strips the URL file syntax off of a filename.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UNDONE Class | System.Core Namespace


UNDONE Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public UNDONE();
[C++]
public: UNDONE();
[JScript]
public function UNDONE();

See Also

UNDONE Class | UNDONE Members | System.Core Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UNDONE Methods

The methods of the UNDONE class are listed below. For a complete list of UNDONE class members, see the UNDONE Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SortIList | [To be supplied.]
StripURL | Strips the URL file syntax off of a filename.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UNDONE Class | System.Core Namespace


UNDONE.SortIList

[To be supplied.]

[Visual Basic]
Public Shared Sub SortIList( _
   ByVal toSort As IList, _
   ByVal comparer As IComparer _
)
[C#]
public static void SortIList(
   IList toSort,
   IComparer comparer
);
[C++]
public: static void SortIList(
   IList* toSort,
   IComparer* comparer
);
[JScript]
public static function SortIList(
   toSort : IList,
   comparer : IComparer
);

Parameters

toSort
[To be supplied.]
comparer
[To be supplied.]

See Also

UNDONE Class | UNDONE Members | System.Core Namespace


UNDONE.StripURL

Strips the URL file syntax off of a filename.

[Visual Basic]
Public Shared Function StripURL( _
   ByVal url As String _
) As String
[C#]
public static string StripURL(
   string url
);
[C++]
public: static String* StripURL(
   String* url
);
[JScript]
public static function StripURL(
   url : String
) : String;

Parameters

url
[To be supplied.]

See Also

UNDONE Class | UNDONE Members | System.Core Namespace


UserPreferenceCategories Enumeration

This enum identifies areas of user preferences that have changed.

[Visual Basic]
Public Enum UserPreferenceCategories
[C#]
public enum UserPreferenceCategories
[C++]
public enum UserPreferenceCategories

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Accessibility | The accessibility category contains user preferences associated with accessibility of the system for users with disabilities.
Color | The color category contains user preferences associated with system colors, such as the default color of windows or menus.
Desktop | The desktop category contains user preferences associated with the system desktop. This may reflect a change in desktop background images, or desktop layout.
General | The general category contains user preferences that are not associated with any other category.
Icon | The icon category contains user preferences for icon settings. This includes icon height and spacing, for example.
Keyboard | The keyboard category contains user preferences for keyboard settings. This may include such things as keyboard repeat rate.
Menu | The menu category contains user preferences for menu settings, such as meny delays and text alignment.
Mouse | The mouse category contains user preferences for mouse settings, such as double click time and mouse sensitivity.
Policy | The policy category contains user preferences for policy settings, such as user rights and access levels.
Power | The power category contains user preferences for system power settings. An example of a power setting is the time required for the system to automatically enter low power mode.
Screensaver | The screensaver category contains user preferences associated with the screensaver.
Window | The window category contains user preferences associated with the dimensions and characteristics of windows on the system.

Requirements

Namespace: System.Core

Assembly: System.dll

See Also

System.Core Namespace


UserPreferenceChangedEventArgs Class

A user preference changed event, which occurs when a user preference has changed.

Object
EventArgs
UserPreferenceChangedEventArgs

[Visual Basic]
Public Class UserPreferenceChangedEventArgs
   Inherits EventArgs
[C#]
public class UserPreferenceChangedEventArgs : EventArgs
[C++]
public __gc class UserPreferenceChangedEventArgs : public EventArgs
[JScript]
public class UserPreferenceChangedEventArgs extends EventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.Core

Assembly: System.dll

See Also

UserPreferenceChangedEventArgs Members | System.Core Namespace


UserPreferenceChangedEventArgs Members

Public:

Constructor

UserPreferenceChangedEventArgs Constructor Creates a new UserPreferenceChangedEventArgs.

Properties

Category | The category of user preferences that have changed.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UserPreferenceChangedEventArgs Class | System.Core Namespace


UserPreferenceChangedEventArgs Constructor

Creates a new UserPreferenceChangedEventArgs.

[Visual Basic]
Public Sub New( _
   ByVal category As UserPreferenceCategories _
)
[C#]
public UserPreferenceChangedEventArgs(
   UserPreferenceCategories category
);
[C++]
public: UserPreferenceChangedEventArgs(
   UserPreferenceCategories category
);
[JScript]
public function UserPreferenceChangedEventArgs(
   category : UserPreferenceCategories
);

Parameters

category
The user preference category of this event.

See Also

UserPreferenceChangedEventArgs Class | UserPreferenceChangedEventArgs Members | System.Core Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UserPreferenceChangedEventArgs Properties

The properties of the UserPreferenceChangedEventArgs class are listed below. For a complete list of UserPreferenceChangedEventArgs class members, see the UserPreferenceChangedEventArgs Members topic.

Public:

Category | The category of user preferences that have changed.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.

See Also

UserPreferenceChangedEventArgs Class | System.Core Namespace


UserPreferenceChangedEventArgs.Category

The category of user preferences that have changed.

[Visual Basic]
Public ReadOnly Property Category As UserPreferenceCategories
[C#]
public UserPreferenceCategories Category {get;}
[C++]
public: __property UserPreferenceCategories get_Category();
[JScript]
public function get Category() : UserPreferenceCategories;

See Also

UserPreferenceChangedEventArgs Class | UserPreferenceChangedEventArgs Members | System.Core Namespace


UserPreferenceChangedEventHandler Delegate

Represents the method that will handle the OnUserPreferenceChanged event.

[Visual Basic]
Public Delegate Sub UserPreferenceChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As UserPreferenceChangedEventArgs _
)
[C#]
public delegate void UserPreferenceChangedEventHandler(
   object sender,
   UserPreferenceChangedEventArgs e
);
[C++]
public __gc __delegate void UserPreferenceChangedEventHandler(
   Object* sender,
   UserPreferenceChangedEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the UserPreferenceChangedEventHandler delegate declaration.

sender
The source of the event. Since user preference changes are global changes, this object is always a null reference (in Visual Basic Nothing).
e
A UserPreferenceChangedEventArgs that contains the event data.

Remarks

When you create a UserPreferenceChangedEventHandler delegate, you identify the method that will handle the event. To associate the event with your event-handling method, add an instance of the delegate to the event. The event-handling method is called whenever the event occurs, unless you remove the delegate. For more information about event handler delegates, see TBD.

Requirements

Namespace: System.Core

Assembly: System.dll

See Also

System.Core Namespace


System.Data

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Data Namespace

Classes

Class | Description
AdapterDesignerAttribute | A DataDesignerAttribute is an attribute that can be placed on a class to identify the class used to implement design time services.
BaseCollection | [To be supplied.]
ColumnsCollection | Represents a collection of DataColumn objects for a DataTable.
Constraint | Represents a constraint that can be enforced on one or more DataColumn objects.
ConstraintException | [To be supplied.]
ConstraintsCollection | ConstraintsCollection is a collection of constraints for a DataTable. It has Add/Remove capabilities, as well as an All array property, enumeration, etc.
ConvertEventArgs | [To be supplied.]
CurrentRowChangingEventArgs | [To be supplied.]
DataColumn | Represents one column of data in a DataTable.
DataColumnChangeEventArgs | Provides data for the ColumnChanging event.
DataError | Represents an custom error that can be associated with a DataRow.
DataException | [To be supplied.]
DataExpression | [To be supplied.]
DataFilter | [To be supplied.]
DataKey | [To be supplied.]
DataRelation | Represents a parent/child relationship between two tables.
DataRow | Represents a row of data in a DataTable.
DataRowChangeEventArgs | Provides data for the RowChanged, RowChanging, OnRowDeleting, and OnRowDeleted events.
DataRowView | Represents a customized view of a DataRow.
DataRowViewColumnDescriptor | [To be supplied.]
DataRowViewRelationDescriptor | [To be supplied.]
DataRowViewTypeDescriptor | [To be supplied.]
DataSet | Represents an in-memory cache of data.
DataSetView | Represents a view of a DataSet with individual filters automatically set on each of its tables.
DataSetViewListItem | [To be supplied.]
DataSetViewListItemTableDescriptor | [To be supplied.]
DataSetViewListItemTypeDescriptor | [To be supplied.]
DataSysDescriptionAttribute | DescriptionAttribute marks a property, event, or extender with a description. Visual designers can display this description when referencing the member.
DataTable | Represents one table of in-memory data.
DataUtil | [To be supplied.]
DataView | Represents a databindable, customized view of a DataTable for sorting, filtering, searching, editing, and navigation.
DeletedRowInaccessibleException | Represents the exception that is thrown when an action is attempted on a DataRow that has been deleted.
DuplicateConstraintException | [To be supplied.]
DuplicateNameException | [To be supplied.]
EmptyDataSourceException | [To be supplied.]
EnforceConstraintException | [To be supplied.]
EvaluateException | [To be supplied.]
ForeignKeyConstraint | Represents an action restriction enforced on a set of columns in a child/parent relationship when a value or row is either deleted or updated.
IndexEventArgs | [To be supplied.]
InRowChangingEventException | [To be supplied.]
InvalidBindingException | [To be supplied.]
InvalidConstraintException | [To be supplied.]
InvalidExpressionException | [To be supplied.]
InvalidRowsException | [To be supplied.]
ListChangedEventArgs | [To be supplied.]
MergeFailedEventArgs | [To be supplied.]
MissingPrimaryKeyException | [To be supplied.]
NoNullAllowedException | [To be supplied.]
ObjectStoreColumn | [To be supplied.]
ObjectStoreTable | [To be supplied.]
OriginalDataUneditableException | [To be supplied.]
PositionChangingEventArgs | [To be supplied.]
PropertiesCollection | [To be supplied.]
ReadOnlyException | [To be supplied.]
RelatedView | [To be supplied.]
RelationsCollection | Represents the collection of relations, each of which allows navigation between related parent/child tables.
RowNotInTableException | [To be supplied.]
RowsCollection | Represents a collection of rows for a DataTable.
StateChangeEventArgs | [To be supplied.]
StreamFormats | [To be supplied.]
SyntaxErrorException | [To be supplied.]
TablesCollection | Represents the collection of tables for the DataSet.
TableSetting | Defines the custom settings used to view a DataTable in a DataSetView.
TableSettingsCollection | Represents the collection of custom table settings for a DataSetView.
UniqueConstraint | Represents a restriction on a set of columns in which all values must be unique.
UriResolver | [To be supplied.]
VersionNotFoundException | [To be supplied.]

Interfaces

Interface | Description
ICollectionInfo | [To be supplied.]
IColumnMapping | [To be supplied.]
IColumnMappings | [To be supplied.]
ICurrencyList | [To be supplied.]
IDataBuffer | [To be supplied.]
IDataEditor | [To be supplied.]
IDataErrorInfo | [To be supplied.]
IDataList | [To be supplied.]
IDataNavigator | [To be supplied.]
IDataParameter | Allows an object to create a data parameter to a command and its mapping to DataSet columns.
IDataReader | [To be supplied.]
IDataRecord | [To be supplied.]
IDataSetCommand | Allows an object to create a data set command, which represents a set of data commands and a database connection which are used to fill the DataSet and update the data source. At any time, the object refers to only a single record within the current data set.
IDataWriter | [To be supplied.]
IEditableList | [To be supplied.]
IEditableObject | [To be supplied.]
IFilter | [To be supplied.]
IIndexedList | [To be supplied.]
IListSource | [To be supplied.]
ILiveList | [To be supplied.]
INameTable | [To be supplied.]
IPresentedProperties | [To be supplied.]
IPropertyDescriptor | [To be supplied.]
ISortedList | [To be supplied.]
ITableMapping | [To be supplied.]
ITableMappings | [To be supplied.]
ITypedElements | [To be supplied.]
ITypedList | [To be supplied.]
ITypedObject | [To be supplied.]
IUriResolver | [To be supplied.]

Structures

Structure | Description
Range | [To be supplied.]

Delegates

Delegate | Description
ConvertEventHandler | [To be supplied.]
CurrentRowChangingEventHandler | [To be supplied.]
DataColumnChangeEventHandler | Provides data for the ColumnChanging event.
DataRowChangeEventHandler | Represents the method that will handle the OnRowChanging, OnRowChanged, OnRowDeleting, and OnRowDeleted events of a DataTable.
ListChangedEventHandler | [To be supplied.]
MergeFailedEventHandler | [To be supplied.]
PositionChangingEventHandler | [To be supplied.]
StateChangeEventHandler | [To be supplied.]

Enumerations

Enumeration | Description
AcceptRejectRule | Determines the action that occurs when the AcceptChanges method is invoked on a DataTable with a ForeignKeyConstraint.
AggregateTypes | [To be supplied.]
CascadeAction | [To be supplied.]
CommandType | [To be supplied.]
DataCursorRowState | [To be supplied.]
DataCursorSort | [To be supplied.]
DataRowAction | Describes the action taken on a DataRow.
DataRowState | Describes the current state of a DataRow.
DataRowVersion | Describes the version of a DataRow.
DataViewRowState | Describes the version of data in a DataRow.
DBCommandBehavior | [To be supplied.]
DBObjectState | [To be supplied.]
EnforceConstraintsRule | [To be supplied.]
IsolationLevel | [To be supplied.]
ListChangedType | [To be supplied.]
MissingMappingAction | Determines that action that will occur when a DataColumn is is missing.
MissingSchemaAction | Specifies the action to take during a merge of tables whose schemas are incompatible.
ParameterDirection | [To be supplied.]
PropertyAttributes | [To be supplied.]
ReadState | [To be supplied.]
Rule | Indicates the action that occurs when a ForeignKeyConstraint is enforced.
SchemaType | [To be supplied.]
SortDirection | [To be supplied.]
SortOrder | [To be supplied.]
TreePosition | [To be supplied.]
UpdateRowSource | [To be supplied.]
UpdateStatus | [To be supplied.]
XmlContent | [To be supplied.]
XmlOrder | [To be supplied.]


AcceptRejectRule Enumeration

Determines the action that occurs when the AcceptChanges method is invoked on a DataTable with a ForeignKeyConstraint.

[Visual Basic]
Public Enum AcceptRejectRule
[C#]
public enum AcceptRejectRule
[C++]
public enum AcceptRejectRule

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Cascade | Changes are cascaded across the relationship.
Default | Default action occurs.
None | No action occurs.

Requirements

Namespace: System.Data

Assembly: System.Data.dll

Example [Visual Basic]

The following example creates a ForeignKeyConstraint, sets various of its properties, including the AcceptRejectRule, and adds it to a DataTable object's ConstraintsCollection.

[Visual Basic]

' The next line goes into the Declarations section of the module:
' SuppliersProducts is a class derived from DataSet.
Private myDataSet As SuppliersProducts

Private Sub CreateConstraint()
   ' Declare parent column and child column variables.
   Dim pCol As DataColumn
   Dim cCol As DataColumn
   Dim myFKC As ForeignKeyConstraint
   ' Set parent and child column variables.
   pCol = MyDataSet.Tables("Suppliers").Columns("SupplierID")
   cCol = MyDataSet.Tables("Products").Columns("SupplieriD")
   myFKC = New ForeignKeyConstraint("SuppierFKConstraint", pCol, cCol)
   ' Set null values when a value is deleted.
   myFKC.DeleteRule = Rule.SetNull
   myFKC.UpdateRule = Rule.Cascade
   myFKC.AcceptRejectRule = AcceptRejectRule.Cascade
   ' Add the constraint, and set EnforceConstraints to true.
   myDataSet.Tables("Suppliers").Constraints.Add myFKC
   myDataSet.EnforceConstraints = True
End Sub

See Also

System.Data Namespace | DataTable | UniqueConstraint | ForeignKeyConstraint | AcceptRejectRule


AdapterDesignerAttribute Class

A DataDesignerAttribute is an attribute that can be placed on a class to identify the class used to implement design time services.

Object
Attribute
MemberAttribute
AdapterDesignerAttribute

[Visual Basic]
Public Class AdapterDesignerAttribute
   Inherits MemberAttribute
[C#]
public class AdapterDesignerAttribute : MemberAttribute
[C++]
public __gc class AdapterDesignerAttribute : public MemberAttribute
[JScript]
public class AdapterDesignerAttribute extends MemberAttribute

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

AdapterDesignerAttribute Members | System.Data Namespace | MemberAttribute


AdapterDesignerAttribute Members

Public:

Constructor

AdapterDesignerAttribute Constructor Creates a new designer attribute.

Properties

DesignerTypeName | Retrieves the designer type name associated with this designer attribute.
TypeId (inherited from MemberAttribute) | Gets a unique ID for this MemberAttribute.

Methods

Equals (inherited from MemberAttribute) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsDefaultAttribute (inherited from MemberAttribute) | When overridden in a derived class, specifies whether this MemberAttribute is the default attribute for the class.
Match (inherited from MemberAttribute) | Determines whether one attribute matches another.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AdapterDesignerAttribute Class | System.Data Namespace


AdapterDesignerAttribute Constructor

Creates a new designer attribute.

[Visual Basic]
Public Sub New( _
   ByVal designerTypeName As String _
)
[C#]
public AdapterDesignerAttribute(
   string designerTypeName
);
[C++]
public: AdapterDesignerAttribute(
   String* designerTypeName
);
[JScript]
public function AdapterDesignerAttribute(
   designerTypeName : String
);

Parameters

designerTypeName
The fully qualified name of the type that will be used to provide design-time services for the component this attribute is describing. This type must implement IDesigner.

See Also

AdapterDesignerAttribute Class | AdapterDesignerAttribute Members | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AdapterDesignerAttribute Properties

The properties of the AdapterDesignerAttribute class are listed below. For a complete list of AdapterDesignerAttribute class members, see the AdapterDesignerAttribute Members topic.

Public:

DesignerTypeName | Retrieves the designer type name associated with this designer attribute.
TypeId (inherited from MemberAttribute) | Gets a unique ID for this MemberAttribute.

See Also

AdapterDesignerAttribute Class | System.Data Namespace


AdapterDesignerAttribute.DesignerTypeName

Retrieves the designer type name associated with this designer attribute.

[Visual Basic]
Overridable Public ReadOnly Property DesignerTypeName As String
[C#]
public string DesignerTypeName {virtual get;}
[C++]
public: __property virtual String* get_DesignerTypeName();
[JScript]
public function get DesignerTypeName() : String;

See Also

AdapterDesignerAttribute Class | AdapterDesignerAttribute Members | System.Data Namespace


AggregateTypes Enumeration

[To be supplied.]

[Visual Basic]
Public Enum AggregateTypes
[C#]
public enum AggregateTypes
[C++]
public enum AggregateTypes

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Count | [To be supplied.]
First | [To be supplied.]
Max | [To be supplied.]
Mean | [To be supplied.]
Min | [To be supplied.]
None | [To be supplied.]
StDev | [To be supplied.]
Sum | [To be supplied.]
Var | [To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace


BaseCollection Class

[To be supplied.]

Object
BaseCollection

[Visual Basic]
Public Class BaseCollection
   Implements ICollection, IEnumerable
[C#]
public class BaseCollection : ICollection, IEnumerable
[C++]
public __gc class BaseCollection : public ICollection, IEnumerable
[JScript]
public class BaseCollection implements ICollection, IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

BaseCollection Members | System.Data Namespace


BaseCollection Members

Public:

Constructor

BaseCollection Constructor [To be supplied.]

Properties

Count | [To be supplied.]
IsReadOnly | [To be supplied.]
IsSynchronized | [To be supplied.]
SyncRoot | [To be supplied.]

Methods

CopyTo | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

List [To be supplied.]

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseCollection Class | System.Data Namespace


BaseCollection Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public BaseCollection();
[C++]
public: BaseCollection();
[JScript]
public function BaseCollection();

See Also

BaseCollection Class | BaseCollection Members | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

BaseCollection Properties

The properties of the BaseCollection class are listed below. For a complete list of BaseCollection class members, see the BaseCollection Members topic.

Public:

Count | [To be supplied.]
IsReadOnly | [To be supplied.]
IsSynchronized | [To be supplied.]
SyncRoot | [To be supplied.]

Protected:

List [To be supplied.]

See Also

BaseCollection Class | System.Data Namespace


BaseCollection.Count

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Count As Integer
[C#]
public int Count {virtual get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;

See Also

BaseCollection Class | BaseCollection Members | System.Data Namespace


BaseCollection.IsReadOnly

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {virtual get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;

See Also

BaseCollection Class | BaseCollection Members | System.Data Namespace


BaseCollection.IsSynchronized

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsSynchronized As Boolean
[C#]
public bool IsSynchronized {virtual get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;

See Also

BaseCollection Class | BaseCollection Members | System.Data Namespace


BaseCollection.List

[To be supplied.]

[Visual Basic]
Overridable Protected ReadOnly Property List As ObjectList
[C#]
protected ObjectList List {virtual get;}
[C++]
protected: __property virtual ObjectList* get_List();
[JScript]
protected function get List() : ObjectList;

See Also

BaseCollection Class | BaseCollection Members | System.Data Namespace


BaseCollection.SyncRoot

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property SyncRoot As Object
[C#]
public object SyncRoot {virtual get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;

See Also

BaseCollection Class | BaseCollection Members | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

BaseCollection Methods

The methods of the BaseCollection class are listed below. For a complete list of BaseCollection class members, see the BaseCollection Members topic.

Public:

CopyTo | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseCollection Class | System.Data Namespace


BaseCollection.CopyTo

[To be supplied.]

[Visual Basic]
Overridable Public Sub CopyTo( _
   ByVal ar As Array, _
   ByVal index As Integer _
)
[C#]
public virtual void CopyTo(
   Array ar,
   int index
);
[C++]
public: virtual void CopyTo(
   Array* ar,
   int index
);
[JScript]
public function CopyTo(
   ar : Array,
   index : int
);

Parameters

ar
[To be supplied.]
index
[To be supplied.]

See Also

BaseCollection Class | BaseCollection Members | System.Data Namespace


BaseCollection.GetEnumerator

[To be supplied.]

[Visual Basic]
Overridable Public Function GetEnumerator() As IEnumerator
[C#]
public virtual IEnumerator GetEnumerator();
[C++]
public: virtual IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

See Also

BaseCollection Class | BaseCollection Members | System.Data Namespace


CascadeAction Enumeration

[To be supplied.]

[Visual Basic]
Public Enum CascadeAction
[C#]
public enum CascadeAction
[C++]
public enum CascadeAction

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
AcceptReject | [To be supplied.]
All | [To be supplied.]
Default | [To be supplied.]
Deletes | [To be supplied.]
None | [To be supplied.]
Updates | [To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace


ColumnsCollection Class

Represents a collection of DataColumn objects for a DataTable.

Object
BaseCollection
ColumnsCollection

[Visual Basic]
Public Class ColumnsCollection
   Inherits BaseCollection
[C#]
public class ColumnsCollection : BaseCollection
[C++]
public __gc class ColumnsCollection : public BaseCollection
[JScript]
public class ColumnsCollection extends BaseCollection

Remarks

The ColumnsCollection is a major component of a DataTable. Accessed through the Columns property, the collection of columns defines the table's schema and thus determines what kind of data can be contained by a DataTable.

The ColumnsCollection contains is accessed through the Columns property of the DataTable.

The ColumnsCollection uses the standard collection methods, such as Add, Remove, Clear, and All. To determine the number of elements in the collection, use the Count property.

The Contains method verifies that a specified index or column name exists in the collection.

Requirements

Namespace: System.Data

Assembly: System.Data.dll

Example [Visual Basic]

The following example iterates through a collection of DataColumn objects and prints various properties of each column in the collection.

[Visual Basic]

Private Sub PrintDataTableColumnInfo(myTable As DataTable)
   Dim cols As ColumnsCollection
   ' Use a DataTable object's ColumnsCollection:
   cols = myTable.Columns
   ' Get all of the columns using a For Each statement:
   Dim col As DataColumn
   For Each col in cols
      Console.WriteLine(col.ColumnName)
      Console.WriteLine(col.DataType.ToString)
      Console.WriteLine(col.DefaultValue)
   Next
End Sub

See Also

ColumnsCollection Members | System.Data Namespace | Columns | DataColumn | DataTable | DataRelation | DataRow | DataSet


ColumnsCollection Members

Public:

Properties

All | Gets or sets all the columns of the columns collection.
Count (inherited from BaseCollection) | [To be supplied.]
IsReadOnly (inherited from BaseCollection) | [To be supplied.]
IsSynchronized (inherited from BaseCollection) | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the ColumnsCollection class.
SyncRoot (inherited from BaseCollection) | [To be supplied.]

Methods

Add | Overloaded. Adds a DataColumn to the columns collection.
CanRemove | Checks if a given column can be removed from the collection.
Clear | Clears the collection of any columns.
Contains | Overloaded. Checks whether the collection contains a specified column.
CopyTo (inherited from BaseCollection) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from BaseCollection) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | Returns the index of a column specified by name.
Remove | Overloaded. Removes a column from the collection.
ShouldPersistAll | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Events

CollectionChanged Occurs when the columns collection changes, either by adding or removing a column.

Protected:

Properties

List Gets the elements of the collection as an object.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnCollectionChanged | Raises the OnCollectionChanged event.

Event Hookup:

Methods

AddOnCollectionChanged | Adds an event handler for the OnCollectionChanged event.
RemoveOnCollectionChanged | Removes an event handler that has been associated with the OnCollectionChanged event.

See Also

ColumnsCollection Class | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ColumnsCollection Properties

The properties of the ColumnsCollection class are listed below. For a complete list of ColumnsCollection class members, see the ColumnsCollection Members topic.

Public:

All | Gets or sets all the columns of the columns collection.
Count (inherited from BaseCollection) | [To be supplied.]
IsReadOnly (inherited from BaseCollection) | [To be supplied.]
IsSynchronized (inherited from BaseCollection) | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the ColumnsCollection class.
SyncRoot (inherited from BaseCollection) | [To be supplied.]

Protected:

List Gets the elements of the collection as an object.

See Also

ColumnsCollection Class | System.Data Namespace


ColumnsCollection.All

Gets or sets all the columns of the columns collection.

[Visual Basic]
Overridable Public Property All As DataColumn ()
[C#]
public DataColumn[] All {virtual get; virtual set;}
[C++]
public: __property virtual DataColumn* get_All();
public: __property virtual void set_All(DataColumn*[]);
[JScript]
public function get All() : DataColumn[];
public function set All(DataColumn[]);

Property Value

An array of DataColumn objects.

Exceptions

Exception Type | Condition
ArgumentException | A column that is added shouldn't be added and/or a column that is removed shouldn't be removed.

Remarks

If an exception is thrown, the collection returns to its original state.If the collection is succesfully changed by adding or removing columns, the OnCollectionChanged event occurs.

Example [Visual Basic]

The following examples show how to set and get arrays of columns using the All method.

[Visual Basic]

Private Sub GetAllCols()
   Dim cols As ColumnsCollection
   ' Get the ColumnsCollection from a DataTable in a DataSet.
   cols = DataSet1.Tables("Orders").Columns
   ' Create the array and populate it with the All property.
   Dim arrCols() As DataColumn
   arrCols = cols.All
   Dim i As Integer
   For i = 0 To UBound(arrCols) - 1
      Console.WriteLine(arrCols(i).ColumnName)
   Next
End Sub

Private SetAllCols()
   Dim colArray(1) As DataColumn
   Dim cols As New ColumnsCollection
   Dim myCol As DataColumn
   myCol = New DataColumn
   myCol.DataType = Type.GetTpe("System.Int16")
   myCol.ColumnName = "Column 1"
   colArray(0) = myCol
   myCol = New DataColumn
   myCol.DataType = Type.GetTpe("System.String")
   myCol.ColumnName = "Column 2"
   colArray(1) = myCol
   cols.All = colArray
End Sub

See Also

ColumnsCollection Class | ColumnsCollection Members | System.Data Namespace | Add | Clear | Remove


ColumnsCollection.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the ColumnsCollection class.

Overload List

Gets the column from the collection at the specified index.

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(Integer) As DataColumn
[C#] public DataColumn this[int] {virtual get;}
[C++] public: __property virtual DataColumn* get_Item(int);
[JScript] ColumnsCollection.Item (int)

Gets the column from the collection with the specified name.

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(String) As DataColumn
[C#] public DataColumn this[String] {virtual get;}
[C++] public: __property virtual DataColumn* get_Item(String*);
[JScript] ColumnsCollection.Item (String)

Example [Visual Basic]

The following example uses the Item property (ColumnsCollection indexer) to print the DataType value of a DataColumn object specified by index.

Note This example shows how to use one of the overloaded versions of the Item property (ColumnsCollection indexer). For other examples that may be available, see the individual overload topics.

[Visual Basic]

Dim cols As DataColumns
' Get the ColumnsCollection from a DataTable in a DataSet.
cols = DataSet1.Tables("Orders").Columns
' Print the DataType of the column named "id."
Console.WriteLine(cols("id").DataType.ToString)

See Also

ColumnsCollection Class | ColumnsCollection Members | System.Data Namespace


ColumnsCollection.Item (Int32)

Gets the column from the collection at the specified index.

[C#] In C#, this member is the indexer for the ColumnsCollection class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal index As Integer _
) As DataColumn
[C#]
public DataColumn this[
   int index
] {virtual get;}
[C++]
public: __property virtual DataColumn* get_Item(
   int index
);
[JScript]
returnValue = ColumnsCollectionObject.Item(index);
-or-
returnValue = ColumnsCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
The zero-based index of the column to return.

Parameters [Visual Basic, C#, C++]

index
The zero-based index of the column to return.

Property Value

The DataColumn at the specified index.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | The collection doesn't have a column at this index.

Remarks

The Contains method can be used to test for the existence of a column, which is useful before attempting to use Item property (ColumnsCollection indexer).

Example [Visual Basic]

The following example uses the Item property (ColumnsCollection indexer) to print the ColumnName value of a DataColumn object specified by index. The example uses the DataTable contained by a System.WinForms.DataGrid control.

[Visual Basic]

Private Sub PrintColumnNamesByIndex()
   Dim cols As DataColumns
   Dim i As Integer
   ' Get the ColumnsCollection from a DataTable in a DataSet.
   cols = DataSet1.Tables("Orders").Columns
   ' Print each column's name using the Index.
   For i = 0 to cols.Count - 1
      Console.WriteLine(cols(i))
   Next i
End Sub

See Also

ColumnsCollection Class | ColumnsCollection Members | System.Data Namespace | ColumnsCollection.Item Overload List | ColumnName | Contains | DataColumn


ColumnsCollection.Item (String)

Gets the column from the collection with the specified name.

[C#] In C#, this member is the indexer for the ColumnsCollection class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal name As String _
) As DataColumn
[C#]
public DataColumn this[
   string name
] {virtual get;}
[C++]
public: __property virtual DataColumn* get_Item(
   String* name
);
[JScript]
returnValue = ColumnsCollectionObject.Item(name);
-or-
returnValue = ColumnsCollectionObject(name);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
The ColumnName of the column to return.

Parameters [Visual Basic, C#, C++]

name
The ColumnName of the column to return.

Property Value

The DataColumn in the collection with the specified ColumnName.

Exceptions

Exception Type | Condition
IndexOutOfRange(System.String) | The collection doesn't have a column with this name.

Remarks

Item is case-sensitive when searching for column names. Therefore, if two columns exist, such as "Fname" and "fname," Item property (ColumnsCollection indexer)will find the specific column you name.

Example [Visual Basic]

The following example uses the Item property (ColumnsCollection indexer) to print the DataType value of a DataColumn object specified by index.

[Visual Basic]

Dim cols As DataColumns
' Get the ColumnsCollection from a DataTable in a DataSet.
cols = DataSet1.Tables("Orders").Columns
' Print the DataType of the column named "id."
Console.WriteLine(cols("id").DataType.ToString)

See Also

ColumnsCollection Class | ColumnsCollection Members | System.Data Namespace | ColumnsCollection.Item Overload List | ColumnName | Contains | DataColumn


ColumnsCollection.List

Gets the elements of the collection as an object.

[Visual Basic]
Overridable Protected ReadOnly Property List As ObjectList
[C#]
protected ObjectList List {override get;}
[C++]
protected: __property virtual ObjectList* get_List();
[JScript]
protected function get List() : ObjectList;

Property Value

An ObjectList that represents the collection items.

See Also

ColumnsCollection Class | ColumnsCollection Members | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ColumnsCollection Methods

The methods of the ColumnsCollection class are listed below. For a complete list of ColumnsCollection class members, see the ColumnsCollection Members topic.

Public:

Add | Overloaded. Adds a DataColumn to the columns collection.
CanRemove | Checks if a given column can be removed from the collection.
Clear | Clears the collection of any columns.
Contains | Overloaded. Checks whether the collection contains a specified column.
CopyTo (inherited from BaseCollection) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from BaseCollection) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | Returns the index of a column specified by name.
Remove | Overloaded. Removes a column from the collection.
ShouldPersistAll | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnCollectionChanged | Raises the OnCollectionChanged event.

Event Hookup:

AddOnCollectionChanged | Adds an event handler for the OnCollectionChanged event.
RemoveOnCollectionChanged | Removes an event handler that has been associated with the OnCollectionChanged event.

See Also

ColumnsCollection Class | System.Data Namespace


ColumnsCollection.Add

Adds a DataColumn to the columns collection.

Overload List

Creates and adds a DataColumn with the specified name and type to the columns collection.

[Visual Basic] Overloads Public Function Add(String, Type) As DataColumn
[C#] public DataColumn Add(String, Type);
[C++] public: DataColumn* Add(String*, Type);
[JScript] public function Add(String, Type) : DataColumn;

Creates and adds a DataColumn with the specified name, type, and compute expression to the columns collection.

[Visual Basic] Overloads Public Function Add(String, Type, String) As DataColumn
[C#] public DataColumn Add(String, Type, String);
[C++] public: DataColumn* Add(String*, Type, String*);
[JScript] public function Add(String, Type, String) : DataColumn;

Adds the specified DataColumn to the columns collection.

[Visual Basic] Overloads Public Sub Add(DataColumn)
[C#] public void Add(DataColumn);
[C++] public: void Add(DataColumn*);
[JScript] public function Add(DataColumn);

Creates and adds a DataColumn with the specified name and storage to the collection.

[Visual Basic] Overloads Public Function Add(String, DataStorage) As DataColumn
[C#] public DataColumn Add(String, DataStorage);
[C++] public: DataColumn* Add(String*, DataStorage);
[JScript] public function Add(String, DataStorage) : DataColumn;

Creates and adds a DataColumn to a columns collection.

[Visual Basic] Overloads Public Function Add() As DataColumn
[C#] public DataColumn Add();
[C++] public: DataColumn* Add();
[JScript] public function Add() : DataColumn;

Creates and adds a DataColumn with the specified name to the columns collection.

[Visual Basic] Overloads Public Function Add(String) As DataColumn
[C#] public DataColumn Add(String);
[C++] public: DataColumn* Add(String*);
[JScript] public function Add(String) : DataColumn;

Example [Visual Basic]

The following example creates and adds a new DataColumn to a ColumnsCollection of a DataTable.

Note This example shows how to use one of the overloaded versions of Add. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub AddColumn()
   Dim cols As ColumnsCollection
   Dim myCol As DataColumn
   ' Get the ColumnsCollection from a table in a DataSet.
   cols = New DataSet1.Tables("Prices").Columns
   myCol = cols.Add("Total")
   With myCol
      .DataType = System.Type.GetType("System.Currency")
      .ReadOnly = True
      .Expression = "UnitPrice * Quantity"
      .Unique = False
   End With
End Sub

See Also

ColumnsCollection Class | ColumnsCollection Members | System.Data Namespace


ColumnsCollection.Add (String, Type)

Creates and adds a DataColumn with the specified name and type to the columns collection.

[Visual Basic]
Overloads Public Function Add( _
   ByVal columnName As String, _
   ByVal type As Type _
) As DataColumn
[C#]
public DataColumn Add(
   string columnName,
   Type type
);
[C++]
public: DataColumn* Add(
   String* columnName,
   Type* type
);
[JScript]
public function Add(
   columnName : String,
   type : Type
) : DataColumn;

Parameters

columnName
The ColumnName to create the column with.
type
The column's DataType.

Return Value

The newly created DataColumn.

Exceptions

Exception Type | Condition
DuplicateNameException | The collection already has a column with the same name (the comparison is not case-sensitive).
InvalidExpressionException | The column has a compute expression and it can't be bound.

Remarks

If a null reference (in Visual Basic Nothing) or an empty string ("") is passed in for the name, a default name ("Column1", "Column2", etc.) is given to the column.

The Contains method determine whether a column with the proposed name already exists in the collection.

If the collection is succesfully changed by adding or removing columns, the OnCollectionChanged event occurs.

Example [Visual Basic]

The following example creates and adds a new DataColumn to a ColumnsCollection of a DataTable.

[Visual Basic]

Private Sub AddColumn()
   Dim cols As ColumnsCollection
   Dim myCol As DataColumn
   cols = New DataSet1.Tables("Orders").Columns

   ' Add a new column and return it.
   myCol = cols.Add("Total", System.Type.GetType("System.Currency"))
   myCol.ReadOnly = True
   myCol.Unique = False
End Sub

See Also

ColumnsCollection Class | ColumnsCollection Members | System.Data Namespace | ColumnsCollection.Add Overload List | ColumnName | DataType | Expression


ColumnsCollection.Add (String, Type, String)

Creates and adds a DataColumn with the specified name, type, and compute expression to the columns collection.

[Visual Basic]
Overloads Public Function Add( _
   ByVal columnName As String, _
   ByVal type As Type, _
   ByVal expression As String _
) As DataColumn
[C#]
public DataColumn Add(
   string columnName,
   Type type,
   string expression
);
[C++]
public: DataColumn* Add(
   String* columnName,
   Type* type,
   String* expression
);
[JScript]
public function Add(
   columnName : String,
   type : Type,
   expression : String
) : DataColumn;

Parameters

columnName
The ColumnName to create the column with.
type
The DataType of the column.
expression
The compute expression to assign to the Expression property.

Return Value

The newly created DataColumn.

Exceptions

Exception Type | Condition
DuplicateNameException | The collection already has a column with the same name (the comparison is not case-sensitive).
InvalidExpressionException | The expression can't be bound.

Remarks

If a null reference (in Visual Basic Nothing) or an empty string ("") is passed in for the name, a default name ("Column1", "Column2", etc.) is given to the column.

The Contains method determine whether a column with the proposed name already exists in the collection.

If the collection is succesfully changed by adding or removing columns, the OnCollectionChanged event occurs.

Example [Visual Basic]

The following example creates and adds a new DataColumn to a ColumnsCollection of a DataTable.

[Visual Basic]

Private Sub AddColumn()
   Dim cols As ColumnsCollection
   Dim myCol As DataColumn
   ' Get the ColumnsCollection of a table in a DataSet.
   cols = DataSet1.Tables("Orders").Columns
   ' Add a new column and return it.
   myCol = cols.Add("Total", System.Type.GetType("System.Currency"), _
   "Price + Tax")
   myCol.ReadOnly = True
   myCol.Unique = False
End Sub

See Also

ColumnsCollection Class | ColumnsCollection Members | System.Data Namespace | ColumnsCollection.Add Overload List | ColumnName | Contains | DataType | Expression


ColumnsCollection.Add (DataColumn)

Adds the specified DataColumn to the columns collection.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal column As DataColumn _
)
[C#]
public void Add(
   DataColumn column
);
[C++]
public: void Add(
   DataColumn* column
);
[JScript]
public function Add(
   column : DataColumn
);

Parameters

column
The DataColumn to add.

Exceptions

Exception Type | Condition
ArgumentNullException | The column parameter is a null reference (in Visual Basic Nothing).
ArgumentException | The column already belongs to this collection, or to another collection.
DuplicateNameException | The collection already has a column with the same name (the comparison is not case-sensitive).
InvalidExpressionException | The column has a compute expression and it can't be bound.

Remarks

If the collection is succesfully changed by adding or removing columns, the OnCollectionChanged event occurs.

Example [Visual Basic]

The following example adds a DataColumn to a ColumnsCollection.

[Visual Basic]

Private Sub AddDataColumn()
   ' Get the ColumnsCollection from a DataTable in a DataSet.
   cols = DataSet1.Tables("Orders").Columns

   Dim myCol As DataColumn = New DataColumn
   With myCol
      .DataType = System.Type.GetType("System.Currency")
      .ColumnName = "ItemPrice"
      .Caption = "Price"
      .ReadOnly = False
      .Unique = False
      .DefaultValue = 0
   End With

   cols.Add(myCol)
End Sub

See Also

ColumnsCollection Class | ColumnsCollection Members | System.Data Namespace | ColumnsCollection.Add Overload List | ColumnName | Contains | DataType | Expression


ColumnsCollection.Add (String, DataStorage)

Creates and adds a DataColumn with the specified name and storage to the collection.

[Visual Basic]
Overloads Public Function Add( _
   ByVal columnName As String, _
   ByVal storage As DataStorage _
) As DataColumn
[C#]
public DataColumn Add(
   string columnName,
   DataStorage storage
);
[C++]
public: DataColumn* Add(
   String* columnName,
   DataStorage* storage
);
[JScript]
public function Add(
   columnName : String,
   storage : DataStorage
) : DataColumn;

Parameters

columnName
The name to create the column with.
storage
The DataStorage for this column.

Return Value

The newly created DataColumn.

Exceptions

Exception Type | Condition
DuplicateNameException | The collection already has a column with the same name (the comparison is not case-sensitive).
InvalidExpressionException | The column has a compute expression and can't be bound.

Remarks

If a null reference (in Visual Basic Nothing) or an empty string ("") is passed in for the name, a default name ("Column1", "Column2", etc.) is given to the column.

The Contains method determine whether a column with the proposed name already exists in the collection.

If the collection is succesfully changed by adding or removing columns, the OnCollectionChanged event occurs.

Example [Visual Basic]

The following example creates and adds a new DataColumn to a ColumnsCollection of a DataTable.

[Visual Basic]

Private Sub AddColumn()
   Dim cols As ColumnsCollection
   Dim myCol As DataColumn
   ' Get the ColumnsCollection from a table in a DataSet.
   cols = New DataSet1.Tables("Prices").Columns
   Dim myStorage As CurrencyStorage
   myStorage = New CurrencyStorage(System.Type.GetType("System.Currency")
   myCol = cols.Add("Total", myStorage)
   myCol.ReadOnly = True
   myCol.Unique = False
End Sub

See Also

ColumnsCollection Class | ColumnsCollection Members | System.Data Namespace | ColumnsCollection.Add Overload List


ColumnsCollection.Add ()

Creates and adds a DataColumn to a columns collection.

[Visual Basic]
Overloads Public Function Add() As DataColumn
[C#]
public DataColumn Add();
[C++]
public: DataColumn* Add();
[JScript]
public function Add() : DataColumn;

Return Value

The newly created DataColumn.

Remarks

A default name ("Column1", "Column2", etc.) is given to the column.

Example [Visual Basic]

The following example creates and adds a new DataColumn to a ColumnsCollection of a DataTable.

[Visual Basic]

Private Sub AddColumn()
   Dim cols As ColumnsCollection
   Dim myCol As DataColumn
   ' Get the ColumnsCollection from a table in a DataSet.
   cols = New DataSet1.Tables("Prices").Columns
   myCol = cols.Add()
   With myCol
      .DataType = System.Type.GetType("System.Currency")
      .ColumnName = "Total"
      .Expression = "UnitPrice * Quantity"
      .ReadOnly = True
      .Unique = False
      .Add(myCol)
   End With
End Sub

See Also

ColumnsCollection Class | ColumnsCollection Members | System.Data Namespace | ColumnsCollection.Add Overload List | ColumnName | Contains | DataType | Expression


ColumnsCollection.Add (String)

Creates and adds a DataColumn with the specified name to the columns collection.

[Visual Basic]
Overloads Public Function Add( _
   ByVal columnName As String _
) As DataColumn
[C#]
public DataColumn Add(
   string columnName
);
[C++]
public: DataColumn* Add(
   String* columnName
);
[JScript]
public function Add(
   columnName : String
) : DataColumn;

Parameters

columnName
The ColumnName to create the column with.

Return Value

The newly created DataColumn.

Exceptions

Exception Type | Condition
DuplicateNameException | The collection already has a column with the same name (the comparison is not case-sensitive).

Remarks

By default, the column's DataType is string.

If a null reference (in Visual Basic Nothing) or an empty string ("") is passed in for the name, a default name ("Column1", "Column2", etc.) is given to the column.

The Contains method determine whether a column with the proposed name already exists in the collection.

Example [Visual Basic]

The following example creates and adds a new DataColumn to a ColumnsCollection of a DataTable.

[Visual Basic]

Private Sub AddColumn()
   Dim cols As ColumnsCollection
   Dim myCol As DataColumn
   ' Get the ColumnsCollection from a table in a DataSet.
   cols = New DataSet1.Tables("Prices").Columns
   myCol = cols.Add("Total")
   With myCol
      .DataType = System.Type.GetType("System.Currency")
      .ReadOnly = True
      .Expression = "UnitPrice * Quantity"
      .Unique = False
   End With
End Sub

See Also

ColumnsCollection Class | ColumnsCollection Members | System.Data Namespace | ColumnsCollection.Add Overload List | ColumnName | Contains | DataType | Expression


ColumnsCollection.AddOnCollectionChanged

Adds an event handler for the OnCollectionChanged event.

[Visual Basic]
Public Sub AddOnCollectionChanged( _
   ByVal handler As CollectionChangeEventHandler _
)
[C#]
public void AddOnCollectionChanged(
   CollectionChangeEventHandler handler
);
[C++]
public: void AddOnCollectionChanged(
   CollectionChangeEventHandler* handler
);
[JScript]
public function AddOnCollectionChanged(
   handler : CollectionChangeEventHandler
);

Parameters

handler
A CollectionChangeEventHandler delegate that represents the method that will handle the OnCollectionChanged event.

See Also

ColumnsCollection Class | ColumnsCollection Members | System.Data Namespace | RemoveOnCollectionChanged


ColumnsCollection.CanRemove

Checks if a given column can be removed from the collection.

[Visual Basic]
Public Function CanRemove( _
   ByVal column As DataColumn _
) As Boolean
[C#]
public bool CanRemove(
   DataColumn column
);
[C++]
public: bool CanRemove(
   DataColumn* column
);
[JScript]
public function CanRemove(
   column : DataColumn
) : Boolean;

Parameters

column
A DataColumn in the collection.

Return Value

true if no exception occurs and the column can be removed; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentNullException | The column parameter is a null reference (in Visual Basic Nothing).
ArgumentException | The column doesn't belong to this collection. -Or- The column is part of a relationship. -Or- Another column's compute expression depends on this column.

Remarks

The CanRemove method performs several checks before returning a true or false including the following: whether the column exists, belongs to the table, is involved in a constraint or relation.

Use the CanRemove method before attempting to remove any column from a collection. You can also use the Contains method to determine if a particular column exists before attempting to reference it.

Example [Visual Basic]

The following example first uses the Contains method to determine if a particular column is found in the collection. If found, the CanRemove method tests whether the column can be removed. If so, the column is removed with the Remove method.

[Visual Basic]

Dim cols As ColumnsCollection
' Get the ColumnsCollection from a DataTable in a DataSet.
cols = DataSet1.Tables("Orders").Columns

If cols.Contains(2) Then
   If cols.CanRemove(cols(2)) Then
      cols.Remove 2
   End If
End If

See Also

ColumnsCollection Class | ColumnsCollection Members | System.Data Namespace | Contains | Remove


ColumnsCollection.Clear

Clears the collection of any columns.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[JScript]
public function Clear();

Remarks

If the collection is succesfully changed by adding or removing columns, the OnCollectionChanged event occurs.

Example [Visual Basic]

The following example clears the columns collection.

[Visual Basic]

Dim cols As ColumnsCollection
' Get the ColumnsCollection from a DataTable in a DataSet.
cols = DataSet1.Tables("Orders").Columns
cols.Clear

See Also

ColumnsCollection Class | ColumnsCollection Members | System.Data Namespace


ColumnsCollection.Contains

Checks whether the collection contains a specified column.

Overload List

Checks whether the collection contains a column with the specified name.

[Visual Basic] Overloads Public Function Contains(String) As Boolean
[C#] public bool Contains(String);
[C++] public: bool Contains(String*);
[JScript] public function Contains(String) : Boolean;

Checks whether the collection has a column at the specified index.

[Visual Basic] Overloads Public Function Contains(Integer) As Boolean
[C#] public bool Contains(int);
[C++] public: bool Contains(int);
[JScript] public function Contains(int) : Boolean;

Example [Visual Basic]

The following example uses the Contains method and the CanRemove method to determine whether the column can be removed. If so, the column is removed.

Note This example shows how to use one of the overloaded versions of Contains. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Dim cols As ColumnsCollection
' Get the ColumnsCollection from a DataTable in a DataSet.
cols = DataSet1.Tables("Orders").Columns
If cols.Contains(2) And cols.CanRemove(cols(2)) Then
   cols.Remove 2
End If

See Also

ColumnsCollection Class | ColumnsCollection Members | System.Data Namespace


ColumnsCollection.Contains (String)

Checks whether the collection contains a column with the specified name.

[Visual Basic]
Overloads Public Function Contains( _
   ByVal name As String _
) As Boolean
[C#]
public bool Contains(
   string name
);
[C++]
public: bool Contains(
   String* name
);
[JScript]
public function Contains(
   name : String
) : Boolean;

Parameters

name
The ColumnName of the column.

Return Value

true if a column exists with this name; otherwise, false.

Remarks

The Contains method can confirm the existence of a column before performing further operations on the column.

Example [Visual Basic]

The following example uses the Contains method and the CanRemove method to determine whether the column can be removed. If so, the column is removed.

[Visual Basic]

Dim cols As ColumnsCollection
' Get the ColumnsCollection from a DataTable in a DataSet.
cols = DataSet1.Tables("Orders").Columns

If cols.Contains("Total") And cols.CanRemove(cols("Total")) Then
   cols.Remove "Total"
End If

See Also

ColumnsCollection Class | ColumnsCollection Members | System.Data Namespace | ColumnsCollection.Contains Overload List | CanRemove | IndexOf


ColumnsCollection.Contains (Int32)

Checks whether the collection has a column at the specified index.

[Visual Basic]
Overloads Public Function Contains( _
   ByVal index As Integer _
) As Boolean
[C#]
public bool Contains(
   int index
);
[C++]
public: bool Contains(
   int index
);
[JScript]
public function Contains(
   index : int
) : Boolean;

Parameters

index
The index of the column.

Return Value

true if a column exists at this index; otherwise, false.

Remarks

The Contains method can confirm the existence of a column before performing further operations on the column.

Example [Visual Basic]

The following example uses the Contains method and the CanRemove method to determine whether the column can be removed. If so, the column is removed.

[Visual Basic]

Dim cols As ColumnsCollection
' Get the ColumnsCollection from a DataTable in a DataSet.
cols = DataSet1.Tables("Orders").Columns
If cols.Contains(2) And cols.CanRemove(cols(2)) Then
   cols.Remove 2
End If

See Also

ColumnsCollection Class | ColumnsCollection Members | System.Data Namespace | ColumnsCollection.Contains Overload List | CanRemove | IndexOf


ColumnsCollection.IndexOf

Returns the index of a column specified by name.

[Visual Basic]
Public Function IndexOf( _
   ByVal columnName As String _
) As Integer
[C#]
public int IndexOf(
   string columnName
);
[C++]
public: int IndexOf(
   String* columnName
);
[JScript]
public function IndexOf(
   columnName : String
) : int;

Parameters

columnName
The name of the column to return.

Return Value

The index of the column specified by columnName; otherwise,-1 if the column cannot be found.

Remarks

The IndexOf method is not case-sensitive.

Example [Visual Basic]

The following example uses the Contains method to determine if a specified column exists in a columns collection. If so, the IndexOf method returns the index of the column.

[Visual Basic]

Dim iCol As Integer
Dim cols As ColumnsCollection
' Get the ColumnsCollection from a DataTable in a DataSet.
cols = DataSet1.Tables("Orders").Columns

If cols.Contains("id") Then
     iCol = cols.IndexOf("id")
     Console.WriteLine(iCol, cols(iCol).DataType.ToString)
End If

See Also

ColumnsCollection Class | ColumnsCollection Members | System.Data Namespace


ColumnsCollection.OnCollectionChanged

Raises the OnCollectionChanged event.

[Visual Basic]
Overridable Protected Sub OnCollectionChanged( _
   ByVal ccevent As CollectionChangeEventArgs _
)
[C#]
protected virtual void OnCollectionChanged(
   CollectionChangeEventArgs ccevent
);
[C++]
protected: virtual void OnCollectionChanged(
   CollectionChangeEventArgs* ccevent
);
[JScript]
protected function OnCollectionChanged(
   ccevent : CollectionChangeEventArgs
);

Parameters

ccevent
A CollectionChangeEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see TBD.

Notes to Inheritors: When overriding OnCollectionChanged in an inheriting class, be sure to call the base class's OnCollectionChanged method.

See Also

ColumnsCollection Class | ColumnsCollection Members | System.Data Namespace


ColumnsCollection.Remove

Removes a column from the collection.

Overload List

Removes the column at the specified index from the collection.

[Visual Basic] Overloads Public Sub Remove(Integer)
[C#] public void Remove(int);
[C++] public: void Remove(int);
[JScript] public function Remove(int);

Removes the column with the specified name from the collection.

[Visual Basic] Overloads Public Sub Remove(String)
[C#] public void Remove(String);
[C++] public: void Remove(String*);
[JScript] public function Remove(String);

Removes the specified DataColumn from the collection.

[Visual Basic] Overloads Public Sub Remove(DataColumn)
[C#] public void Remove(DataColumn);
[C++] public: void Remove(DataColumn*);
[JScript] public function Remove(DataColumn);

Example [Visual Basic]

The following example uses the Contains method to determine if a named column exists. If so, the Item property (ColumnsCollection indexer) returns the column. The CanRemove method then checks whether the column can be removed; if so, the Remove method removes it.

Note This example shows how to use one of the overloaded versions of Remove. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub TestAndRemove(removedCol As DataColumn)
   Dim cols As ColumnsCollection
   ' Get the ColumnsCollection from a DataTable in a DataSet.
   cols = DataSet1.Tables("Orders").Columns

   If cols.Contains(removedCol.ColumnName) Then
      cols.Remove(removedCol)
   End If
End Sub

If cols.CanRemove(removedCol) Then
   cols.Remove(removedCol)
End If
    DataGrid1.PopulateColumns

See Also

ColumnsCollection Class | ColumnsCollection Members | System.Data Namespace


ColumnsCollection.Remove (Int32)

Removes the column at the specified index from the collection.

[Visual Basic]
Overloads Public Sub Remove( _
   ByVal index As Integer _
)
[C#]
public void Remove(
   int index
);
[C++]
public: void Remove(
   int index
);
[JScript]
public function Remove(
   index : int
);

Parameters

index
The index of the column to remove.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | The collection doesn't have a column at this index.

Remarks

If the collection is succesfully changed by adding or removing columns, the OnCollectionChanged event occurs.

Example [Visual Basic]

The following example first uses the Contains method to determine if a particular column is found in the collection. If it is found, the CanRemove method tests whether the column can be removed. If so, the column is removed with the Remove method.

[Visual Basic]

Private Sub RemoveColumnAtIndex(thisIndex As Integer)
   Dim cols As ColumnsCollection
   ' Get the ColumnsCollection from a DataTable in a DataSet.
   cols = DataSet1.Tables("Orders").Columns
   If cols.Contains(thisIndex) Then
      If cols.CanRemove(cols(thisIndex)) Then cols.Remove(thisIndex)
   End If
End If

See Also

ColumnsCollection Class | ColumnsCollection Members | System.Data Namespace | ColumnsCollection.Remove Overload List | IndexOf | Contains | CanRemove


ColumnsCollection.Remove (String)

Removes the column with the specified name from the collection.

[Visual Basic]
Overloads Public Sub Remove( _
   ByVal name As String _
)
[C#]
public void Remove(
   string name
);
[C++]
public: void Remove(
   String* name
);
[JScript]
public function Remove(
   name : String
);

Parameters

name
The name of the column to remove.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | The collection doesn't have a column with the specified name.

Remarks

If the collection is succesfully changed by adding or removing columns, the OnCollectionChanged event occurs.

Example [Visual Basic]

The following example first uses the Contains method to determine if a particular column is found in the collection. If it is found, the CanRemove method tests whether the column can be removed. If so, the column is removed with the Remove method.

[Visual Basic]

Private Sub RemoveColumnByName(colName As String)
   Dim cols As ColumnsCollection
   ' Get the ColumnsCollection from a DataTable in a DataSet.
   cols = DataSet1.Tables("Orders").Columns
   If cols.Contains(colName) Then
      If cols.CanRemove(cols(colName)) Then cols.Remove(colName)
   End If
End If

See Also

ColumnsCollection Class | ColumnsCollection Members | System.Data Namespace | ColumnsCollection.Remove Overload List | Contains


ColumnsCollection.Remove (DataColumn)

Removes the specified DataColumn from the collection.

[Visual Basic]
Overloads Public Sub Remove( _
   ByVal column As DataColumn _
)
[C#]
public void Remove(
   DataColumn column
);
[C++]
public: void Remove(
   DataColumn* column
);
[JScript]
public function Remove(
   column : DataColumn
);

Parameters

column
The DataColumn to remove.

Exceptions

Exception Type | Condition
ArgumentNullException | The column parameter is a null reference (in Visual Basic Nothing).
ArgumentException | The column doesn't belong to this collection. -Or- The column is part of a relationship. -Or- Another column's compute expression depends on this column.

Remarks

If the collection is succesfully changed by adding or removing columns, the OnCollectionChanged event occurs.

Example [Visual Basic]

The following example uses the Contains method to determine if a named column exists. If so, the Item property (ColumnsCollection indexer) returns the column. The CanRemove method then checks whether the column can be removed; if so, the Remove method removes it.

[Visual Basic]

Private Sub TestAndRemove(removedCol As DataColumn)
   Dim cols As ColumnsCollection
   ' Get the ColumnsCollection from a DataTable in a DataSet.
   cols = DataSet1.Tables("Orders").Columns

   If cols.Contains(removedCol.ColumnName) Then
      cols.Remove(removedCol)
   End If
End Sub

If cols.CanRemove(removedCol) Then
   cols.Remove(removedCol)
End If
    DataGrid1.PopulateColumns

See Also

ColumnsCollection Class | ColumnsCollection Members | System.Data Namespace | ColumnsCollection.Remove Overload List | Contains | CanRemove | Item


ColumnsCollection.RemoveOnCollectionChanged

Removes an event handler that has been associated with the OnCollectionChanged event.

[Visual Basic]
Public Sub RemoveOnCollectionChanged( _
   ByVal handler As CollectionChangeEventHandler _
)
[C#]
public void RemoveOnCollectionChanged(
   CollectionChangeEventHandler handler
);
[C++]
public: void RemoveOnCollectionChanged(
   CollectionChangeEventHandler* handler
);
[JScript]
public function RemoveOnCollectionChanged(
   handler : CollectionChangeEventHandler
);

Parameters

handler
The CollectionChangeEventHandler delegate to remove.

See Also

ColumnsCollection Class | ColumnsCollection Members | System.Data Namespace | Add | AddOnCollectionChanged | Remove


ColumnsCollection.ShouldPersistAll

[To be supplied.]

[Visual Basic]
Public Function ShouldPersistAll() As Boolean
[C#]
public bool ShouldPersistAll();
[C++]
public: bool ShouldPersistAll();
[JScript]
public function ShouldPersistAll() : Boolean;

See Also

ColumnsCollection Class | ColumnsCollection Members | System.Data Namespace


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ColumnsCollection Events

The events of the ColumnsCollection class are listed below. For a complete list of ColumnsCollection class members, see the ColumnsCollection Members topic.

Public:

CollectionChanged Occurs when the columns collection changes, either by adding or removing a column.

See Also

ColumnsCollection Class | System.Data Namespace


ColumnsCollection CollectionChanged Event

Occurs when the columns collection changes, either by adding or removing a column.

The following declaration shows the syntax for a method that handles the CollectionChanged event.

[Visual Basic]
Private Sub ColumnsCollectionName_CollectionChanged( _
   ByVal sender As Object, _
   ByVal e As CollectionChangeEventArgs _
)
[C#]
private void ColumnsCollectionName_CollectionChanged(
   object sender,
   CollectionChangeEventArgs e
);
[C++]
private: void ColumnsCollectionName_CollectionChanged(
   Object* sender,
   CollectionChangeEventArgs* e
);
[JScript]
private ColumnsCollectionName_CollectionChanged(
   sender : Object,
   e : CollectionChangeEventArgs
);

Parameters

sender
The source of the event.
e
A System.ComponentModel.CollectionChangeEventArgs that contains the event data.

Remarks

The Contains and CanRemove methods can be used to determine if a column exists and can be removed.

See Also

ColumnsCollection Class | ColumnsCollection MembersTopic | System.Data Namespace


CommandType Enumeration

[To be supplied.]

[Visual Basic]
Public Enum CommandType
[C#]
public enum CommandType
[C++]
public enum CommandType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
StoredProcedure | [To be supplied.]
TableDirect | [To be supplied.]
Text | [To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace


Constraint Class

Represents a constraint that can be enforced on one or more DataColumn objects.

Object
Constraint

[Visual Basic]
MustInherit Public Class Constraint
[C#]
public abstract class Constraint
[C++]
public __gc __abstract class Constraint
[JScript]
public abstract class Constraint

Remarks

A constraint is an automatic rule that determines the course of action when the value of a DataColumn is somehow altered. For example, when a value is deleted and the value is also used in one or more related tables, a ForeignKeyConstraint determines whether the values in the related tables are also deleted, set to null values, set to default values, or whether no action occurs. A UniqueConstraint, on the other hand, simply ensures that values in a table are unique.

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

Constraint Members | System.Data Namespace


Constraint Members

Public:

Constructor

Constraint Constructor [To be supplied.]

Properties

ConstraintName | The name of this constraint within the ConstraintsCollection. An ArgumentException is thrown if setting the name to null or empty string and the column belongs to a collection. A DuplicateNameException is thrown if this column belongs to a collection and it already has a column with the same name (case insensitive).
DataSet | Gets the DataSet to which this constraint belongs.
IsPrimaryKey | Gets a value indicating whether the constraint is on a primary key column.
Table | Gets the DataTable to which the constraint applies.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

_DataSet Gets the DataSet to which this constraint belongs.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDataSet | Sets the constraint's DataSet.

See Also

Constraint Class | System.Data Namespace


Constraint Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public Constraint();
[C++]
public: Constraint();
[JScript]
public function Constraint();

See Also

Constraint Class | Constraint Members | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Constraint Properties

The properties of the Constraint class are listed below. For a complete list of Constraint class members, see the Constraint Members topic.

Public:

ConstraintName | The name of this constraint within the ConstraintsCollection. An ArgumentException is thrown if setting the name to null or empty string and the column belongs to a collection. A DuplicateNameException is thrown if this column belongs to a collection and it already has a column with the same name (case insensitive).
DataSet | Gets the DataSet to which this constraint belongs.
IsPrimaryKey | Gets a value indicating whether the constraint is on a primary key column.
Table | Gets the DataTable to which the constraint applies.

Protected:

_DataSet Gets the DataSet to which this constraint belongs.

See Also

Constraint Class | System.Data Namespace


Constraint.ConstraintName

The name of this constraint within the ConstraintsCollection. An ArgumentException is thrown if setting the name to null or empty string and the column belongs to a collection. A DuplicateNameException is thrown if this column belongs to a collection and it already has a column with the same name (case insensitive).

[Visual Basic]
Overridable Public Property ConstraintName As String
[C#]
public string ConstraintName {virtual get; virtual set;}
[C++]
public: __property virtual String* get_ConstraintName();
public: __property virtual void set_ConstraintName(String*);
[JScript]
public function get ConstraintName() : String;
public function set ConstraintName(String);

See Also

Constraint Class | Constraint Members | System.Data Namespace


Constraint.DataSet

Gets the DataSet to which this constraint belongs.

[Visual Basic]
Overridable Public ReadOnly Property DataSet As DataSet
[C#]
public DataSet DataSet {virtual get;}
[C++]
public: __property virtual DataSet* get_DataSet();
[JScript]
public function get DataSet() : DataSet;

Property Value

The DataSet to which this constraint belongs.

See Also

Constraint Class | Constraint Members | System.Data Namespace


Constraint.IsPrimaryKey

Gets a value indicating whether the constraint is on a primary key column.

[Visual Basic]
Overridable Public ReadOnly Property IsPrimaryKey As Boolean
[C#]
public bool IsPrimaryKey {virtual get;}
[C++]
public: __property virtual bool get_IsPrimaryKey();
[JScript]
public function get IsPrimaryKey() : Boolean;

Property Value

true, if the columns is a primary key; otherwise, false.

See Also

Constraint Class | Constraint Members | System.Data Namespace


Constraint.Table

Gets the DataTable to which the constraint applies.

[Visual Basic]
MustOverride Public ReadOnly Property Table As DataTable
[C#]
public DataTable Table {abstract get;}
[C++]
public: __property virtual DataTable* get_Table() = 0;
[JScript]
public abstract function get Table() : DataTable;

Property Value

A DataTable to which the constraint applies.

See Also

Constraint Class | Constraint Members | System.Data Namespace


Constraint._DataSet

Gets the DataSet to which this constraint belongs.

[Visual Basic]
Overridable Protected ReadOnly Property _DataSet As DataSet
[C#]
protected DataSet _DataSet {virtual get;}
[C++]
protected: __property virtual DataSet* get__DataSet();
[JScript]
protected function get _DataSet() : DataSet;

See Also

Constraint Class | Constraint Members | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Constraint Methods

The methods of the Constraint class are listed below. For a complete list of Constraint class members, see the Constraint Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDataSet | Sets the constraint's DataSet.

See Also

Constraint Class | System.Data Namespace


Constraint.SetDataSet

Sets the constraint's DataSet.

[Visual Basic]
Protected Sub SetDataSet( _
   ByVal dataSet As DataSet _
)
[C#]
protected void SetDataSet(
   DataSet dataSet
);
[C++]
protected: void SetDataSet(
   DataSet* dataSet
);
[JScript]
protected function SetDataSet(
   dataSet : DataSet
);

Parameters

dataSet
The DataSet to which this constraint will belong.

See Also

Constraint Class | Constraint Members | System.Data Namespace


ConstraintException Class

[To be supplied.]

Object
Exception
SystemException
ConstraintException

[Visual Basic]
Public Class ConstraintException
   Inherits SystemException
[C#]
public class ConstraintException : SystemException
[C++]
public __gc class ConstraintException : public SystemException
[JScript]
public class ConstraintException extends SystemException

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

ConstraintException Members | System.Data Namespace


ConstraintException Members

Public:

Constructor

ConstraintException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

ConstraintException Class | System.Data Namespace


ConstraintException Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public ConstraintException();
[C++] public: ConstraintException();
[JScript] public function ConstraintException();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public ConstraintException(String);
[C++] public: ConstraintException(String*);
[JScript] public function ConstraintException(String);

See Also

ConstraintException Class | ConstraintException Members | System.Data Namespace


ConstraintException Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public ConstraintException();
[C++]
public: ConstraintException();
[JScript]
public function ConstraintException();

See Also

ConstraintException Class | ConstraintException Members | System.Data Namespace | ConstraintException Constructor Overload List


ConstraintException Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal s As String _
)
[C#]
public ConstraintException(
   string s
);
[C++]
public: ConstraintException(
   String* s
);
[JScript]
public function ConstraintException(
   s : String
);

Parameters

s
[To be supplied.]

See Also

ConstraintException Class | ConstraintException Members | System.Data Namespace | ConstraintException Constructor Overload List


ConstraintsCollection Class

ConstraintsCollection is a collection of constraints for a DataTable. It has Add/Remove capabilities, as well as an All array property, enumeration, etc.

Object
BaseCollection
ConstraintsCollection

[Visual Basic]
Public Class ConstraintsCollection
   Inherits BaseCollection
[C#]
public class ConstraintsCollection : BaseCollection
[C++]
public __gc class ConstraintsCollection : public BaseCollection
[JScript]
public class ConstraintsCollection extends BaseCollection

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

ConstraintsCollection Members | System.Data Namespace


ConstraintsCollection Members

Public:

Properties

All | Gets/sets all of the constraints that this collection holds. This throws an exception if any column that ultimately gets added shouldn't be added an if any column that ultimately gets removed shouldn't be removed. If an exception is thrown, the collection returns to it's original state. The CollectionChanged event is fired if it succeeds.
Count (inherited from BaseCollection) | [To be supplied.]
IsReadOnly (inherited from BaseCollection) | [To be supplied.]
IsSynchronized (inherited from BaseCollection) | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the ConstraintsCollection class.
SyncRoot (inherited from BaseCollection) | [To be supplied.]

Methods

Add | Overloaded. [To be supplied.]
CanRemoveConstraint | Throws an exception if constraint can't be removed from collection. Otherwise it returns whether or not the constraint needs to be removed from the collection.
Clear | Clears the collection of any constraints. Fires the CollectionChangeEvent.
Contains | Overloaded. [To be supplied.]
CopyTo (inherited from BaseCollection) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from BaseCollection) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | Overloaded. [To be supplied.]
Remove | Overloaded. [To be supplied.]
ShouldPersistAll | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Events

CollectionChanged [To be supplied.]

Protected:

Properties

List [To be supplied.]

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
IndexOf | Overloaded. [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnCollectionChanged | This method is called whenever the collection changes. Overriders of this method should call the base implementation of this method.

Event Hookup:

Methods

AddOnCollectionChanged | Registers the handler to get events whenever this collection changes.
RemoveOnCollectionChanged | Unregisters the handler from getting events whenever this collection changes.

See Also

ConstraintsCollection Class | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ConstraintsCollection Properties

The properties of the ConstraintsCollection class are listed below. For a complete list of ConstraintsCollection class members, see the ConstraintsCollection Members topic.

Public:

All | Gets/sets all of the constraints that this collection holds. This throws an exception if any column that ultimately gets added shouldn't be added an if any column that ultimately gets removed shouldn't be removed. If an exception is thrown, the collection returns to it's original state. The CollectionChanged event is fired if it succeeds.
Count (inherited from BaseCollection) | [To be supplied.]
IsReadOnly (inherited from BaseCollection) | [To be supplied.]
IsSynchronized (inherited from BaseCollection) | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the ConstraintsCollection class.
SyncRoot (inherited from BaseCollection) | [To be supplied.]

Protected:

List [To be supplied.]

See Also

ConstraintsCollection Class | System.Data Namespace


ConstraintsCollection.All

Gets/sets all of the constraints that this collection holds. This throws an exception if any column that ultimately gets added shouldn't be added an if any column that ultimately gets removed shouldn't be removed. If an exception is thrown, the collection returns to it's original state. The CollectionChanged event is fired if it succeeds.

[Visual Basic]
Overridable Public Property All As Constraint ()
[C#]
public Constraint[] All {virtual get; virtual set;}
[C++]
public: __property virtual Constraint* get_All();
public: __property virtual void set_All(Constraint*[]);
[JScript]
public function get All() : Constraint[];
public function set All(Constraint[]);

See Also

ConstraintsCollection Class | ConstraintsCollection Members | System.Data Namespace


ConstraintsCollection.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the ConstraintsCollection class.

Overload List

Gets the constraint in the collection with the given name (case insensitive). Throws an IndexOutOfRange exception if the collection doesn't have a constraint with this name.

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(String) As Constraint
[C#] public Constraint this[String] {virtual get;}
[C++] public: __property virtual Constraint* get_Item(String*);
[JScript] ConstraintsCollection.Item (String)

Gets the index'th constraint in the collection, in order. Throws an IndexOutOfRange exception if the collection doesn't have a constraint at this index.

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(Integer) As Constraint
[C#] public Constraint this[int] {virtual get;}
[C++] public: __property virtual Constraint* get_Item(int);
[JScript] ConstraintsCollection.Item (int)

See Also

ConstraintsCollection Class | ConstraintsCollection Members | System.Data Namespace


ConstraintsCollection.Item (String)

Gets the constraint in the collection with the given name (case insensitive). Throws an IndexOutOfRange exception if the collection doesn't have a constraint with this name.

[C#] In C#, this member is the indexer for the ConstraintsCollection class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal name As String _
) As Constraint
[C#]
public Constraint this[
   string name
] {virtual get;}
[C++]
public: __property virtual Constraint* get_Item(
   String* name
);
[JScript]
returnValue = ConstraintsCollectionObject.Item(name);
-or-
returnValue = ConstraintsCollectionObject(name);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
the name with which to find a column.

Parameters [Visual Basic, C#, C++]

name
the name with which to find a column.

See Also

ConstraintsCollection Class | ConstraintsCollection Members | System.Data Namespace | ConstraintsCollection.Item Overload List


ConstraintsCollection.Item (Int32)

Gets the index'th constraint in the collection, in order. Throws an IndexOutOfRange exception if the collection doesn't have a constraint at this index.

[C#] In C#, this member is the indexer for the ConstraintsCollection class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal index As Integer _
) As Constraint
[C#]
public Constraint this[
   int index
] {virtual get;}
[C++]
public: __property virtual Constraint* get_Item(
   int index
);
[JScript]
returnValue = ConstraintsCollectionObject.Item(index);
-or-
returnValue = ConstraintsCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
the index to find.

Parameters [Visual Basic, C#, C++]

index
the index to find.

See Also

ConstraintsCollection Class | ConstraintsCollection Members | System.Data Namespace | ConstraintsCollection.Item Overload List


ConstraintsCollection.List

[To be supplied.]

[Visual Basic]
Overridable Protected ReadOnly Property List As ObjectList
[C#]
protected ObjectList List {override get;}
[C++]
protected: __property virtual ObjectList* get_List();
[JScript]
protected function get List() : ObjectList;

See Also

ConstraintsCollection Class | ConstraintsCollection Members | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ConstraintsCollection Methods

The methods of the ConstraintsCollection class are listed below. For a complete list of ConstraintsCollection class members, see the ConstraintsCollection Members topic.

Public:

Add | Overloaded. [To be supplied.]
CanRemoveConstraint | Throws an exception if constraint can't be removed from collection. Otherwise it returns whether or not the constraint needs to be removed from the collection.
Clear | Clears the collection of any constraints. Fires the CollectionChangeEvent.
Contains | Overloaded. [To be supplied.]
CopyTo (inherited from BaseCollection) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from BaseCollection) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | Overloaded. [To be supplied.]
Remove | Overloaded. [To be supplied.]
ShouldPersistAll | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
IndexOf | Overloaded. [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnCollectionChanged | This method is called whenever the collection changes. Overriders of this method should call the base implementation of this method.

Event Hookup:

AddOnCollectionChanged | Registers the handler to get events whenever this collection changes.
RemoveOnCollectionChanged | Unregisters the handler from getting events whenever this collection changes.

See Also

ConstraintsCollection Class | System.Data Namespace


ConstraintsCollection.Add

[To be supplied.]

Overload List

Constructs a new ForeignKeyConstraint, and adds the constraint to the collection. An ArgumentException is thrown if this constraint already belongs to this collection, or belongs to another collection. A DuplicateNameException is thrown if this collection already has a constraint with the same name (case insensitive). The CollectionChanged event is fired if it succeeds.

[Visual Basic] Overloads Public Sub Add(String, DataColumn, DataColumn)
[C#] public void Add(String, DataColumn, DataColumn);
[C++] public: void Add(String*, DataColumn, DataColumn);
[JScript] public function Add(String, DataColumn, DataColumn);

Constructs a new ForeignKeyConstraint, and adds the constraint to the collection. An ArgumentException is thrown if this constraint already belongs to this collection, or belongs to another collection. A DuplicateNameException is thrown if this collection already has a constraint with the same name (case insensitive). The CollectionChanged event is fired if it succeeds.

[Visual Basic] Overloads Public Sub Add(String, DataColumn(), DataColumn())
[C#] public void Add(String, DataColumn[], DataColumn[]);
[C++] public: void Add(String*, DataColumn[], DataColumn[]);
[JScript] public function Add(String, DataColumn[], DataColumn[]);

Constructs a new UniqueConstraint, and adds the constraint to the collection. An ArgumentException is thrown if this constraint already belongs to this collection, or belongs to another collection. A DuplicateNameException is thrown if this collection already has a constraint with the same name (case insensitive). The CollectionChanged event is fired if it succeeds.

[Visual Basic] Overloads Public Sub Add(String, DataColumn, Boolean)
[C#] public void Add(String, DataColumn, bool);
[C++] public: void Add(String*, DataColumn, bool);
[JScript] public function Add(String, DataColumn, Boolean);

Adds the constraint to the collection. An ArgumentNullException is thrown if this column is null. An ArgumentException is thrown if this constraint already belongs to this collection, or belongs to another collection. A DuplicateNameException is thrown if this collection already has a constraint with the same name (case insensitive). The CollectionChanged event is fired if it succeeds.

[Visual Basic] Overloads Public Sub Add(Constraint)
[C#] public void Add(Constraint);
[C++] public: void Add(Constraint*);
[JScript] public function Add(Constraint);

Constructs a new UniqueConstraint, and adds the constraint to the collection. An ArgumentException is thrown if this constraint already belongs to this collection, or belongs to another collection. A DuplicateNameException is thrown if this collection already has a constraint with the same name (case insensitive). The CollectionChanged event is fired if it succeeds.

[Visual Basic] Overloads Public Sub Add(String, DataColumn(), Boolean)
[C#] public void Add(String, DataColumn[], bool);
[C++] public: void Add(String*, DataColumn[], bool);
[JScript] public function Add(String, DataColumn[], Boolean);

See Also

ConstraintsCollection Class | ConstraintsCollection Members | System.Data Namespace


ConstraintsCollection.Add (String, DataColumn, DataColumn)

Constructs a new ForeignKeyConstraint, and adds the constraint to the collection. An ArgumentException is thrown if this constraint already belongs to this collection, or belongs to another collection. A DuplicateNameException is thrown if this collection already has a constraint with the same name (case insensitive). The CollectionChanged event is fired if it succeeds.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal name As String, _
   ByVal primaryKeyColumn As DataColumn, _
   ByVal foreignKeyColumn As DataColumn _
)
[C#]
public void Add(
   string name,
   DataColumn primaryKeyColumn,
   DataColumn foreignKeyColumn
);
[C++]
public: void Add(
   String* name,
   DataColumn* primaryKeyColumn,
   DataColumn* foreignKeyColumn
);
[JScript]
public function Add(
   name : String,
   primaryKeyColumn : DataColumn,
   foreignKeyColumn : DataColumn
);

Parameters

name
[To be supplied.]
primaryKeyColumn
[To be supplied.]
foreignKeyColumn
[To be supplied.]

See Also

ConstraintsCollection Class | ConstraintsCollection Members | System.Data Namespace | ConstraintsCollection.Add Overload List


ConstraintsCollection.Add (String, DataColumn[], DataColumn[])

Constructs a new ForeignKeyConstraint, and adds the constraint to the collection. An ArgumentException is thrown if this constraint already belongs to this collection, or belongs to another collection. A DuplicateNameException is thrown if this collection already has a constraint with the same name (case insensitive). The CollectionChanged event is fired if it succeeds.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal name As String, _
   ByVal primaryKeyColumns() As DataColumn, _
   ByVal foreignKeyColumns() As DataColumn _
)
[C#]
public void Add(
   string name,
   DataColumn[] primaryKeyColumns,
   DataColumn[] foreignKeyColumns
);
[C++]
public: void Add(
   String* name,
   DataColumn* primaryKeyColumns[],
   DataColumn* foreignKeyColumns[]
);
[JScript]
public function Add(
   name : String,
   primaryKeyColumns : DataColumn[],
   foreignKeyColumns : DataColumn[]
);

Parameters

name
[To be supplied.]
primaryKeyColumns
[To be supplied.]
foreignKeyColumns
[To be supplied.]

See Also

ConstraintsCollection Class | ConstraintsCollection Members | System.Data Namespace | ConstraintsCollection.Add Overload List


ConstraintsCollection.Add (String, DataColumn, Boolean)

Constructs a new UniqueConstraint, and adds the constraint to the collection. An ArgumentException is thrown if this constraint already belongs to this collection, or belongs to another collection. A DuplicateNameException is thrown if this collection already has a constraint with the same name (case insensitive). The CollectionChanged event is fired if it succeeds.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal name As String, _
   ByVal column As DataColumn, _
   ByVal primaryKey As Boolean _
)
[C#]
public void Add(
   string name,
   DataColumn column,
   bool primaryKey
);
[C++]
public: void Add(
   String* name,
   DataColumn* column,
   bool primaryKey
);
[JScript]
public function Add(
   name : String,
   column : DataColumn,
   primaryKey : Boolean
);

Parameters

name
[To be supplied.]
column
[To be supplied.]
primaryKey
[To be supplied.]

See Also

ConstraintsCollection Class | ConstraintsCollection Members | System.Data Namespace | ConstraintsCollection.Add Overload List


ConstraintsCollection.Add (Constraint)

Adds the constraint to the collection. An ArgumentNullException is thrown if this column is null. An ArgumentException is thrown if this constraint already belongs to this collection, or belongs to another collection. A DuplicateNameException is thrown if this collection already has a constraint with the same name (case insensitive). The CollectionChanged event is fired if it succeeds.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal constraint As Constraint _
)
[C#]
public void Add(
   Constraint constraint
);
[C++]
public: void Add(
   Constraint* constraint
);
[JScript]
public function Add(
   constraint : Constraint
);

Parameters

constraint
The Constraint to add.

See Also

ConstraintsCollection Class | ConstraintsCollection Members | System.Data Namespace | ConstraintsCollection.Add Overload List


ConstraintsCollection.Add (String, DataColumn[], Boolean)

Constructs a new UniqueConstraint, and adds the constraint to the collection. An ArgumentException is thrown if this constraint already belongs to this collection, or belongs to another collection. A DuplicateNameException is thrown if this collection already has a constraint with the same name (case insensitive). The CollectionChanged event is fired if it succeeds.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal name As String, _
   ByVal columns() As DataColumn, _
   ByVal primaryKey As Boolean _
)
[C#]
public void Add(
   string name,
   DataColumn[] columns,
   bool primaryKey
);
[C++]
public: void Add(
   String* name,
   DataColumn* columns[],
   bool primaryKey
);
[JScript]
public function Add(
   name : String,
   columns : DataColumn[],
   primaryKey : Boolean
);

Parameters

name
[To be supplied.]
columns
[To be supplied.]
primaryKey
[To be supplied.]

See Also

ConstraintsCollection Class | ConstraintsCollection Members | System.Data Namespace | ConstraintsCollection.Add Overload List


ConstraintsCollection.AddOnCollectionChanged

Registers the handler to get events whenever this collection changes.

[Visual Basic]
Public Sub AddOnCollectionChanged( _
   ByVal handler As CollectionChangeEventHandler _
)
[C#]
public void AddOnCollectionChanged(
   CollectionChangeEventHandler handler
);
[C++]
public: void AddOnCollectionChanged(
   CollectionChangeEventHandler* handler
);
[JScript]
public function AddOnCollectionChanged(
   handler : CollectionChangeEventHandler
);

Parameters

handler
The event hook

See Also

ConstraintsCollection Class | ConstraintsCollection Members | System.Data Namespace


ConstraintsCollection.CanRemoveConstraint

Throws an exception if constraint can't be removed from collection. Otherwise it returns whether or not the constraint needs to be removed from the collection.

[Visual Basic]
Public Function CanRemoveConstraint( _
   ByVal constraint As Constraint _
) As Boolean
[C#]
public bool CanRemoveConstraint(
   Constraint constraint
);
[C++]
public: bool CanRemoveConstraint(
   Constraint* constraint
);
[JScript]
public function CanRemoveConstraint(
   constraint : Constraint
) : Boolean;

Parameters

constraint
[To be supplied.]

See Also

ConstraintsCollection Class | ConstraintsCollection Members | System.Data Namespace


ConstraintsCollection.Clear

Clears the collection of any constraints. Fires the CollectionChangeEvent.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[JScript]
public function Clear();

See Also

ConstraintsCollection Class | ConstraintsCollection Members | System.Data Namespace


ConstraintsCollection.Contains

[To be supplied.]

Overload List

Returns true if this collection has a column at this index, false otherwise.

[Visual Basic] Overloads Public Function Contains(Integer) As Boolean
[C#] public bool Contains(int);
[C++] public: bool Contains(int);
[JScript] public function Contains(int) : Boolean;

Returns true if this collection has a constraint with the given name (case insensitive), false otherwise.

[Visual Basic] Overloads Public Function Contains(String) As Boolean
[C#] public bool Contains(String);
[C++] public: bool Contains(String*);
[JScript] public function Contains(String) : Boolean;

See Also

ConstraintsCollection Class | ConstraintsCollection Members | System.Data Namespace


ConstraintsCollection.Contains (Int32)

Returns true if this collection has a column at this index, false otherwise.

[Visual Basic]
Overloads Public Function Contains( _
   ByVal index As Integer _
) As Boolean
[C#]
public bool Contains(
   int index
);
[C++]
public: bool Contains(
   int index
);
[JScript]
public function Contains(
   index : int
) : Boolean;

Parameters

index
index to test.

Return Value

Whether a constraint exists at this index.

See Also

ConstraintsCollection Class | ConstraintsCollection Members | System.Data Namespace | ConstraintsCollection.Contains Overload List


ConstraintsCollection.Contains (String)

Returns true if this collection has a constraint with the given name (case insensitive), false otherwise.

[Visual Basic]
Overloads Public Function Contains( _
   ByVal name As String _
) As Boolean
[C#]
public bool Contains(
   string name
);
[C++]
public: bool Contains(
   String* name
);
[JScript]
public function Contains(
   name : String
) : Boolean;

Parameters

name
name to test.

Return Value

Whether a constraint exists with this name.

See Also

ConstraintsCollection Class | ConstraintsCollection Members | System.Data Namespace | ConstraintsCollection.Contains Overload List


ConstraintsCollection.IndexOf

[To be supplied.]

Overload List

Returns the index of the constraint with the given name (case insensitive),-1 if it isn't contained.

[Visual Basic] Overloads Public Function IndexOf(String) As Integer
[C#] public int IndexOf(String);
[C++] public: int IndexOf(String*);
[JScript] public function IndexOf(String) : int;

Returns the index of the constraint or-1 if it isn't contained.

[Visual Basic] Overloads Protected Function IndexOf(Constraint) As Integer
[C#] protected int IndexOf(Constraint);
[C++] protected: int IndexOf(Constraint*);
[JScript] protected function IndexOf(Constraint) : int;

See Also

ConstraintsCollection Class | ConstraintsCollection Members | System.Data Namespace


ConstraintsCollection.IndexOf (String)

Returns the index of the constraint with the given name (case insensitive),-1 if it isn't contained.

[Visual Basic]
Overloads Public Function IndexOf( _
   ByVal constraintName As String _
) As Integer
[C#]
public int IndexOf(
   string constraintName
);
[C++]
public: int IndexOf(
   String* constraintName
);
[JScript]
public function IndexOf(
   constraintName : String
) : int;

Parameters

constraintName
the name to look for.

Return Value

index of the constraint with the name or-1.

See Also

ConstraintsCollection Class | ConstraintsCollection Members | System.Data Namespace | ConstraintsCollection.IndexOf Overload List


ConstraintsCollection.IndexOf (Constraint)

Returns the index of the constraint or-1 if it isn't contained.

[Visual Basic]
Overloads Protected Function IndexOf( _
   ByVal constraint As Constraint _
) As Integer
[C#]
protected int IndexOf(
   Constraint constraint
);
[C++]
protected: int IndexOf(
   Constraint* constraint
);
[JScript]
protected function IndexOf(
   constraint : Constraint
) : int;

Parameters

constraint
the Constraintto look for.

Return Value

index of the Constriant or-1.

See Also

ConstraintsCollection Class | ConstraintsCollection Members | System.Data Namespace | ConstraintsCollection.IndexOf Overload List


ConstraintsCollection.OnCollectionChanged

This method is called whenever the collection changes. Overriders of this method should call the base implementation of this method.

[Visual Basic]
Overridable Protected Sub OnCollectionChanged( _
   ByVal ccevent As CollectionChangeEventArgs _
)
[C#]
protected virtual void OnCollectionChanged(
   CollectionChangeEventArgs ccevent
);
[C++]
protected: virtual void OnCollectionChanged(
   CollectionChangeEventArgs* ccevent
);
[JScript]
protected function OnCollectionChanged(
   ccevent : CollectionChangeEventArgs
);

Parameters

ccevent
The event information.

See Also

ConstraintsCollection Class | ConstraintsCollection Members | System.Data Namespace


ConstraintsCollection.Remove

[To be supplied.]

Overload List

Removes the constraint with the given name from the collection. An IndexOutOfRangeException is thrown if this collection doesn't have a constraint with the given name. The CollectionChanged event is fired if it succeeds.

[Visual Basic] Overloads Public Sub Remove(String)
[C#] public void Remove(String);
[C++] public: void Remove(String*);
[JScript] public function Remove(String);

Removes the constraint at the given index from the collection. An IndexOutOfRangeException is thrown if this collection doesn't have a constraint at this index. The CollectionChanged event is fired if it succeeds.

[Visual Basic] Overloads Public Sub Remove(Integer)
[C#] public void Remove(int);
[C++] public: void Remove(int);
[JScript] public function Remove(int);

Removes the given column from the collection. An ArgumentNullException is thrown if this constraint is null. An ArgumentException is thrown if this constraint doesn't belong to this collection.. The CollectionChanged event is fired if it succeeds.

[Visual Basic] Overloads Public Sub Remove(Constraint)
[C#] public void Remove(Constraint);
[C++] public: void Remove(Constraint*);
[JScript] public function Remove(Constraint);

See Also

ConstraintsCollection Class | ConstraintsCollection Members | System.Data Namespace


ConstraintsCollection.Remove (String)

Removes the constraint with the given name from the collection. An IndexOutOfRangeException is thrown if this collection doesn't have a constraint with the given name. The CollectionChanged event is fired if it succeeds.

[Visual Basic]
Overloads Public Sub Remove( _
   ByVal name As String _
)
[C#]
public void Remove(
   string name
);
[C++]
public: void Remove(
   String* name
);
[JScript]
public function Remove(
   name : String
);

Parameters

name
The name of the column to remove.

See Also

ConstraintsCollection Class | ConstraintsCollection Members | System.Data Namespace | ConstraintsCollection.Remove Overload List


ConstraintsCollection.Remove (Int32)

Removes the constraint at the given index from the collection. An IndexOutOfRangeException is thrown if this collection doesn't have a constraint at this index. The CollectionChanged event is fired if it succeeds.

[Visual Basic]
Overloads Public Sub Remove( _
   ByVal index As Integer _
)
[C#]
public void Remove(
   int index
);
[C++]
public: void Remove(
   int index
);
[JScript]
public function Remove(
   index : int
);

Parameters

index
The index at which to remove a constraint.

See Also

ConstraintsCollection Class | ConstraintsCollection Members | System.Data Namespace | ConstraintsCollection.Remove Overload List


ConstraintsCollection.Remove (Constraint)

Removes the given column from the collection. An ArgumentNullException is thrown if this constraint is null. An ArgumentException is thrown if this constraint doesn't belong to this collection.. The CollectionChanged event is fired if it succeeds.

[Visual Basic]
Overloads Public Sub Remove( _
   ByVal constraint As Constraint _
)
[C#]
public void Remove(
   Constraint constraint
);
[C++]
public: void Remove(
   Constraint* constraint
);
[JScript]
public function Remove(
   constraint : Constraint
);

Parameters

constraint
The column to remove.

See Also

ConstraintsCollection Class | ConstraintsCollection Members | System.Data Namespace | ConstraintsCollection.Remove Overload List


ConstraintsCollection.RemoveOnCollectionChanged

Unregisters the handler from getting events whenever this collection changes.

[Visual Basic]
Public Sub RemoveOnCollectionChanged( _
   ByVal handler As CollectionChangeEventHandler _
)
[C#]
public void RemoveOnCollectionChanged(
   CollectionChangeEventHandler handler
);
[C++]
public: void RemoveOnCollectionChanged(
   CollectionChangeEventHandler* handler
);
[JScript]
public function RemoveOnCollectionChanged(
   handler : CollectionChangeEventHandler
);

Parameters

handler
The event hook

See Also

ConstraintsCollection Class | ConstraintsCollection Members | System.Data Namespace


ConstraintsCollection.ShouldPersistAll

[To be supplied.]

[Visual Basic]
Public Function ShouldPersistAll() As Boolean
[C#]
public bool ShouldPersistAll();
[C++]
public: bool ShouldPersistAll();
[JScript]
public function ShouldPersistAll() : Boolean;

See Also

ConstraintsCollection Class | ConstraintsCollection Members | System.Data Namespace


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ConstraintsCollection Events

The events of the ConstraintsCollection class are listed below. For a complete list of ConstraintsCollection class members, see the ConstraintsCollection Members topic.

Public:

CollectionChanged [To be supplied.]

See Also

ConstraintsCollection Class | System.Data Namespace


ConstraintsCollection CollectionChanged Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the CollectionChanged event.

[Visual Basic]
Private Sub ConstraintsCollectionName_CollectionChanged( _
   ByVal sender As Object, _
   ByVal e As CollectionChangeEventArgs _
)
[C#]
private void ConstraintsCollectionName_CollectionChanged(
   object sender,
   CollectionChangeEventArgs e
);
[C++]
private: void ConstraintsCollectionName_CollectionChanged(
   Object* sender,
   CollectionChangeEventArgs* e
);
[JScript]
private ConstraintsCollectionName_CollectionChanged(
   sender : Object,
   e : CollectionChangeEventArgs
);

Parameters

sender
The source of the event.
e
A System.ComponentModel.CollectionChangeEventArgs that contains the event data.

See Also

ConstraintsCollection Class | ConstraintsCollection MembersTopic | System.Data Namespace


ConvertEventArgs Class

[To be supplied.]

Object
EventArgs
ConvertEventArgs

[Visual Basic]
Public Class ConvertEventArgs
   Inherits EventArgs
[C#]
public class ConvertEventArgs : EventArgs
[C++]
public __gc class ConvertEventArgs : public EventArgs
[JScript]
public class ConvertEventArgs extends EventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

ConvertEventArgs Members | System.Data Namespace


ConvertEventArgs Members

Public:

Constructor

ConvertEventArgs Constructor [To be supplied.]

Properties

DesiredType | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
Value | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConvertEventArgs Class | System.Data Namespace


ConvertEventArgs Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal value As Object, _
   ByVal desiredType As Type _
)
[C#]
public ConvertEventArgs(
   object value,
   Type desiredType
);
[C++]
public: ConvertEventArgs(
   Object* value,
   Type* desiredType
);
[JScript]
public function ConvertEventArgs(
   value : Object,
   desiredType : Type
);

Parameters

value
[To be supplied.]
desiredType
[To be supplied.]

See Also

ConvertEventArgs Class | ConvertEventArgs Members | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ConvertEventArgs Properties

The properties of the ConvertEventArgs class are listed below. For a complete list of ConvertEventArgs class members, see the ConvertEventArgs Members topic.

Public:

DesiredType | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
Value | [To be supplied.]

See Also

ConvertEventArgs Class | System.Data Namespace


ConvertEventArgs.DesiredType

[To be supplied.]

[Visual Basic]
Public Property DesiredType As Type
[C#]
public Type DesiredType {get; set;}
[C++]
public: __property Type* get_DesiredType();
public: __property void set_DesiredType(Type*);
[JScript]
public function get DesiredType() : Type;
public function set DesiredType(Type);

See Also

ConvertEventArgs Class | ConvertEventArgs Members | System.Data Namespace


ConvertEventArgs.Value

[To be supplied.]

[Visual Basic]
Public Property Value As Object
[C#]
public object Value {get; set;}
[C++]
public: __property Object* get_Value();
public: __property void set_Value(Object*);
[JScript]
public function get Value() : Object;
public function set Value(Object);

See Also

ConvertEventArgs Class | ConvertEventArgs Members | System.Data Namespace


ConvertEventHandler Delegate

[To be supplied.]

[Visual Basic]
Public Delegate Sub ConvertEventHandler( _
   ByVal sender As Object, _
   ByVal e As ConvertEventArgs _
)
[C#]
public delegate void ConvertEventHandler(
   object sender,
   ConvertEventArgs e
);
[C++]
public __gc __delegate void ConvertEventHandler(
   Object* sender,
   ConvertEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the ConvertEventHandler delegate declaration.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace


CurrentRowChangingEventArgs Class

[To be supplied.]

Object
EventArgs
CurrentRowChangingEventArgs

[Visual Basic]
Public Class CurrentRowChangingEventArgs
   Inherits EventArgs
[C#]
public class CurrentRowChangingEventArgs : EventArgs
[C++]
public __gc class CurrentRowChangingEventArgs : public EventArgs
[JScript]
public class CurrentRowChangingEventArgs extends EventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

CurrentRowChangingEventArgs Members | System.Data Namespace


CurrentRowChangingEventArgs Members

Public:

Properties

Cancelable | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CurrentRowChangingEventArgs Class | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CurrentRowChangingEventArgs Properties

The properties of the CurrentRowChangingEventArgs class are listed below. For a complete list of CurrentRowChangingEventArgs class members, see the CurrentRowChangingEventArgs Members topic.

Public:

Cancelable | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.

See Also

CurrentRowChangingEventArgs Class | System.Data Namespace


CurrentRowChangingEventArgs.Cancelable

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Cancelable As Boolean
[C#]
public bool Cancelable {get;}
[C++]
public: __property bool get_Cancelable();
[JScript]
public function get Cancelable() : Boolean;

See Also

CurrentRowChangingEventArgs Class | CurrentRowChangingEventArgs Members | System.Data Namespace


CurrentRowChangingEventHandler Delegate

[To be supplied.]

[Visual Basic]
Public Delegate Sub CurrentRowChangingEventHandler( _
   ByVal sender As Object, _
   ByVal e As CurrentRowChangingEventArgs _
)
[C#]
public delegate void CurrentRowChangingEventHandler(
   object sender,
   CurrentRowChangingEventArgs e
);
[C++]
public __gc __delegate void CurrentRowChangingEventHandler(
   Object* sender,
   CurrentRowChangingEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the CurrentRowChangingEventHandler delegate declaration.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace


DataColumn Class

Represents one column of data in a DataTable.

Object
Component
DataColumn

[Visual Basic]
Public Class DataColumn
   Inherits Component
[C#]
public class DataColumn : Component
[C++]
public __gc class DataColumn : public Component
[JScript]
public class DataColumn extends Component

Remarks

The DataColumn is the fundamental building block for creating the schema of a DataTable. The schema defines the columns in a table, and thus determines what kind of data can be entered into the table. You might think of the schema as an empty mold which holds the shape of the data table. When you finally "pour" the data into the mold, the table attains its unique shape. The first step in creating that shape, however, is to build the schema by adding one DataColumn at a time to the ColumnsCollection.

Each DataColumn object has a DataType property that determines the kind of data the column holds. For example, you may restrict the data type to integers, or strings, or currency. Since data contained by the DataTable is usually merged back into a pre-existing database, such as SQLServer, the data type of any column must be matched to the native data base system's data type.

Properties such as AllowNull, Unique, and ReadOnly place restrictions on the entry and updating of data, thereby helping to protect the data's integrity. You can also use the AutoIncrement, AutoIncrementSeed, and AutoIncrementStep properties to control automatic data generation.

You can also ensure unique values in a column by creating a UniqueConstraint and adding it to the ConstraintsCollection for the DataTable to which the column belongs.

A feature of the DataColumn is its ability to run regular expressions using the Expression property. By using the built-in operators, computed columns can be created as needed. [NOTE to Editor: We should make sure we have a good definition for "computed column."]

Once a DataColumn object has been created, it can be added to the DataTable object's columns collection, as represented by the ColumnsCollection class.

Requirements

Namespace: System.Data

Assembly: System.Data.dll

Example [Visual Basic]

The following example creates several columns setting several different properties. The columns are added to a DataTable object's ColumnsCollection; a DataView object is then created and its Table property set to the DataTable object. Finally, the code sets a System.WinForms.DataGrid control's DataSource property to the DataView object.

[Visual Basic]

Private Sub MakeTable()
   Dim t As New DataTable
   ' Make columns using functions defined below.
   Dim c As DataColumn
   ' Create a new column.
   c = MakeIDCol
   ' Add the column to the Columns collection.
   t.Columns.Add(c)
   ' Make 3 other columns and add them to the collection.
   c = MakeStringCol()
   t.Columns.Add(c)
   c = MakeCurrencyCol()
   t.Columns.Add(c)
   c = MakeTaxCol()
   t.Columns.Add(c)
   c = MakeTotalCol()
   t.Columns.Add(c)
   ' Create A DataView to bind the control to.
   Dim dView As DataView
   dView = New DataView(t)
   dView.Open
   DataGrid1.DataSource = dView
   DataGrid1.PopulateColumns

   ' Add new rows to the table.
   Dim i As Integer
   Dim r As DataRow
   For i = 0 To 3
      r = t.NewRow
      ' Put a random value into the currency column.
      r(2) = rnd(.314) * 100
      ' Add the DataRow to the collection.
      t.Rows.Add r
   Next
End Sub

Private Function MakeIDCol() As DataColumn
   ' This column is set to a integer data type.
   ' The column also has AutoIncrement implemented.
   Dim dc As DataColumn
   dc = New DataColumn
   dc.DataType = System.Type.GetType("System.Int16")
   With dc
      .AllowNull = False
      .AutoIncrement = True
      .AutoIncrementSeed = 1
      .AutoIncrementStep = 1
      .Caption = "id"
      .ColumnName = "id"
   End With
   ' Return the DataColumn object to the caller.
   MakeIDCol = dc
End Function

Private Function MakeStringCol() As DataColumn
   ' This creates a simple string type column.
   Dim dc As DataColumn
   dc = New DataColumn
   dc.DataType = System.Type.GetType("System.String")
   With dc
      .AllowNull = False
      .AutoIncrement = False
      .Caption = "Item"
      .ColumnName = "Item"
      .DefaultValue = "Item"
      .ReadOnly = False
      .Unique = False
   End With
   MakeStringCol = dc
End Function

Private Function MakeCurrencyCol() As DataColumn
   ' This function creates a currency column.
   Dim dc As DataColumn
   dc = New DataColumn
   dc.DataType = System.Type.GetType("System.Currency")
   dc.AllowNull = False
   dc.Caption = "Price"
   dc.ColumnName = "Price"
   dc.DefaultValue = 25
   MakeCurrencyCol = dc
End Function

Private Function MakeTaxCol() As DataColumn
   ' Create a column that calculates tax on the Price column.
   Dim dc As DataColumn
   dc = New DataColumn
   dc.DataType = System.Type.GetType("System.Currency")
   dc.ColumnName = "Tax"
   dc.caption = "Tax @ " & CStr(taxRate)
   dc.Expression = "Price * " & .0862
   MakeTaxCol = dc
End Function

Private Function MakeTotalCol() As DataColumn
   ' Create a calculated column that adds price plus tax.
   Dim dc As DataColumn
   dc = New DataColumn
   dc.DataType = System.Type.GetType("System.Currency")
   dc.Expression = "Price + Tax"
   MakeTotalCol = dc
End Function

See Also

DataColumn Members | System.Data Namespace | Add | ColumnsCollection | Constraints | ConstraintsCollection | DataRow | DataTable | NewRow | RowsCollection | UniqueConstraint


DataColumn Members

Public:

Constructor

DataColumn Constructor Overloaded. Initializes a new instance of the DataColumn class.

Properties

AllowNull | Gets or sets a value indicating whether null values are allowed in this column for rows belonging to the table.
Attribute | Gets or sets a value indicating whether the column is an attribute column.
AutoIncrement | Gets or sets a value indicating whether the column automatically increments the value of the column for new rows added to the table.
AutoIncrementSeed | Gets or sets the starting value for a column that has its AutoIncrement property set to true.
AutoIncrementStep | Gets or sets the increment used by a column with its AutoIncrement property set to true.
AutoIncrementSupported | Gets a value indicating whether AutoIncrement is supported.
Caption | Gets or sets the caption for this column.
ColumnName | Gets or sets the name of the column within the ColumnsCollection.
DataType | The type of data stored in thecolumn.
DefaultValue | Gets or sets the default value for the column when creating new rows.
Expression | Gets or sets the expresssion used to either filter rows, calculate the column's value, or create an aggregate column.
ExtendedProperties | Gets the collection of custom user information.
Namespace | [To be supplied.]
Ordinal | Gets the position of the column in the ColumnsCollection collection.
ReadOnly | Gets or sets a value indicating whether the column allows changes once a row has been added to the table.
Site (inherited from Component) | Gets or sets the site of the Component.
Sparse | Gets or sets a value indicating whether the column should store data in a fashion optimized for sparse data patterns.
Table | Gets the DataTable to which the column belongs to.
Unique | Gets or sets a value indicating whether the values in each row of the column must be unique.

Methods

Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FindParentRelation | Finds a relation that this column is the sole child of or null.
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
ResetCaption | Resets the Caption property to its previous value, or to a null reference (in Visual Basic Nothing).
ResetNamespace | [To be supplied.]
ShouldPersistCaption | Gets a value indicating whether the Caption has been explicitly set.
ShouldPersistNamespace | [To be supplied.]
ToString | Returns the Expression of the column, if one exists.

Events

PropertyChanged Occurs whenever a property value of the DataColumn changes.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanged | Raises the OnPropertyChanged event.
RaisePropertyChanged | Raises the OnPropertyChanged event.
VerifyUnique | Gets a value verifying whether a value is unique.

Event Hookup:

Methods

AddOnPropertyChanged | Adds an event handler for the OnPropertyChanged event.
RemoveOnPropertyChanged | Removes the event handler that has been associated with the OnPropertyChanged event.

See Also

DataColumn Class | System.Data Namespace


DataColumn Constructor

Initializes a new instance of the DataColumn class.

Overload List

Initializes a new instance of a DataColumn class.

[Visual Basic] Overloads Public Sub New()
[C#] public DataColumn();
[C++] public: DataColumn();
[JScript] public function DataColumn();

Inititalizes a new instance of the DataColumn class using the specified column name.

[Visual Basic] Overloads Public Sub New(String)
[C#] public DataColumn(String);
[C++] public: DataColumn(String*);
[JScript] public function DataColumn(String);

Inititalizes a new instance of the DataColumn class using the specified column name and data type.

[Visual Basic] Overloads Public Sub New(String, Type)
[C#] public DataColumn(String, Type);
[C++] public: DataColumn(String*, Type);
[JScript] public function DataColumn(String, Type);

Initializes a new instance of the DataColumn class using the specified name, data type, and expression.

[Visual Basic] Overloads Public Sub New(String, Type, String)
[C#] public DataColumn(String, Type, String);
[C++] public: DataColumn(String*, Type, String*);
[JScript] public function DataColumn(String, Type, String);

Initializes a new instance of the DataColumn class using the specified name, data type, expression, and value that determines whether the column is an attribute.

[Visual Basic] Overloads Public Sub New(String, Type, String, Boolean)
[C#] public DataColumn(String, Type, String, bool);
[C++] public: DataColumn(String*, Type, String*, bool);
[JScript] public function DataColumn(String, Type, String, Boolean);

Example [Visual Basic]

The following example constructs a computed column.

Note This example shows how to use one of the overloaded version of the DataColumn constructor. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub CreateComputedColumn()
   Dim myColumn As DataColumn
   Dim dt As System.Type
   Dim strExpr As String
   dt = System.Type.GetType("System.Currency")
   strExpr = "Price * Quantity"
   myColumn = New DataColumn("Total", dt, strExpr, False)
   ' Add the column to a DataTable object's ColumnsCollection
   Dim myTable As DataTable
   myTable = DataSet1.Tables("OrderDetails").Columns.Add(myColumn)

End Sub

See Also

DataColumn Class | DataColumn Members | System.Data Namespace


DataColumn Constructor ()

Initializes a new instance of a DataColumn class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public DataColumn();
[C++]
public: DataColumn();
[JScript]
public function DataColumn();

Remarks

When created, a new DataColumn object has no default ColumnName or Caption. When added to a ColumnsCollection, however, a default name ("Column1", "Column2", etc.) is given to the column.

Example [Visual Basic]

The following example creates a new DataColumn, sets various properties, and adds it to a DataTable object's ColumnsCollection.

[Visual Basic]

Private Sub AddDataColumn()
   Dim myColumn As DataColumn
   myColumn = New DataColumn()
   ' Set various properties.
   With myColumn
      .ColumnName = "id"
      .DataType = System.Type.GetType("System.Int32")
      .Unique = True
      .AutoIncrement = True
      .AutoIncrementSeed = 1
      .AutoIncrementStep = 1
      .ReadOnly = True
    End With
   ' Add to Columns collection.
   myTable.Columns.Add myColumn
End Sub

See Also

DataColumn Class | DataColumn Members | System.Data Namespace | DataColumn Constructor Overload List | ColumnName | Caption | DefaultValue | DataTable | DataType


DataColumn Constructor (String)

Inititalizes a new instance of the DataColumn class using the specified column name.

[Visual Basic]
Overloads Public Sub New( _
   ByVal columnName As String _
)
[C#]
public DataColumn(
   string columnName
);
[C++]
public: DataColumn(
   String* columnName
);
[JScript]
public function DataColumn(
   columnName : String
);

Parameters

columnName
A string that represents the name of the column to be created. If set to a null reference (in Visual Basic Nothing) or an empty string (""), a default name will be given when added to the columns collection.

Remarks

By default, the name given to a column becomes the Caption property value.

Example [Visual Basic]

The following example creates a new DataColumn with a specified ColumnName.

[Visual Basic]

Private Sub AddDataColumn()
   Dim myColumn As DataColumn
   myColumn = New DataColumn("id")
   ' Set various properties.
   With myColumn
      .DataType = System.Type.GetType("System.Int32")
      .Unique = True
      .AutoIncrement = True
      .AutoIncrementSeed = 1
      .AutoIncrementStep = 1
      .ReadOnly = True
    End With
   ' Add to Columns collection.
   myTable.Columns.Add myColumn
End Sub

See Also

DataColumn Class | DataColumn Members | System.Data Namespace | DataColumn Constructor Overload List | ColumnName | Caption | DefaultValue | DataTable | DataType


DataColumn Constructor (String, Type)

Inititalizes a new instance of the DataColumn class using the specified column name and data type.

[Visual Basic]
Overloads Public Sub New( _
   ByVal columnName As String, _
   ByVal dataType As Type _
)
[C#]
public DataColumn(
   string columnName,
   Type dataType
);
[C++]
public: DataColumn(
   String* columnName,
   Type* dataType
);
[JScript]
public function DataColumn(
   columnName : String,
   dataType : Type
);

Parameters

columnName
A string that represents the name of the column to be created. If set to a null reference (in Visual Basic Nothing) or an empty string (""), a default name will be given when added to the columns collection.
dataType
A supported DataType.

Exceptions

Exception Type | Condition
ArgumentNull(System.String) | The dataType is null.

Example [Visual Basic]

The following example creates a new DataColumn with a specified ColumnName and DataType.

[Visual Basic]

Private Sub AddDataColumn()
   Dim myColumn As DataColumn
   Dim dt As System.Type
   dt = New System.Type.GetType("System.Int32")
   myColumn = New DataColumn("id", dt)
   ' Set various properties.
   With myColumn
      .Unique = True
      .AutoIncrement = True
      .AutoIncrementSeed = 1
      .AutoIncrementStep = 1
      .ReadOnly = True
    End With
   ' Add to Columns collection.
   myTable.Columns.Add myColumn
End Sub

See Also

DataColumn Class | DataColumn Members | System.Data Namespace | DataColumn Constructor Overload List | DefaultValue | ColumnName | Caption | DataTable | DataType


DataColumn Constructor (String, Type, String)

Initializes a new instance of the DataColumn class using the specified name, data type, and expression.

[Visual Basic]
Overloads Public Sub New( _
   ByVal columnName As String, _
   ByVal dataType As Type, _
   ByVal expr As String _
)
[C#]
public DataColumn(
   string columnName,
   Type dataType,
   string expr
);
[C++]
public: DataColumn(
   String* columnName,
   Type* dataType,
   String* expr
);
[JScript]
public function DataColumn(
   columnName : String,
   dataType : Type,
   expr : String
);

Parameters

columnName
A string that represents the name of the column to be created. If set to a null reference (in Visual Basic Nothing) or an empty string (""), a default name will be given when added to the columns collection.
dataType
A supported DataType.
expr
The expression used to create this column. For more details, see the Expression property.

Exceptions

Exception Type | Condition
ArgumentNullException | No dataType was specified.

Example [Visual Basic]

The following example creates a computed column.

[Visual Basic]

Private Sub AddDataColumn()
   Dim myColumn As DataColumn
   Dim dt As System.Type

   dt = New System.Type.GetType("System.Currency")
   myColumn = New DataColumn("Tax", dt, "UnitPrice * .0862")
   ' Set various properties.
   With myColumn
      .Unique = False
      .AutoIncrement = False
      .ReadOnly = True
   End With
   ' Add to Columns collection.
   myTable.Columns.Add myColumn
End Sub

See Also

DataColumn Class | DataColumn Members | System.Data Namespace | DataColumn Constructor Overload List | DefaultValue | ColumnName | Caption | DataTable | DataType | Expression


DataColumn Constructor (String, Type, String, Boolean)

Initializes a new instance of the DataColumn class using the specified name, data type, expression, and value that determines whether the column is an attribute.

[Visual Basic]
Overloads Public Sub New( _
   ByVal columnName As String, _
   ByVal dataType As Type, _
   ByVal expr As String, _
   ByVal isAttribute As Boolean _
)
[C#]
public DataColumn(
   string columnName,
   Type dataType,
   string expr,
   bool isAttribute
);
[C++]
public: DataColumn(
   String* columnName,
   Type* dataType,
   String* expr,
   bool isAttribute
);
[JScript]
public function DataColumn(
   columnName : String,
   dataType : Type,
   expr : String,
   isAttribute : Boolean
);

Parameters

columnName
A string that represents the name of the column to be created. If set to a null reference (in Visual Basic Nothing) or an empty string (""), a default name will be given when added to the columns collection.
dataType
A supported DataType.
expr
The expression used to create this column. For more details, see the Expression property.
isAttribute
[To be supplied.]

Example [Visual Basic]

The following example constructs a computed column.

[Visual Basic]

Private Sub CreateComputedColumn()
   Dim myColumn As DataColumn
   Dim dt As System.Type
   Dim strExpr As String
   dt = System.Type.GetType("System.Currency")
   strExpr = "Price * Quantity"
   myColumn = New DataColumn("Total", dt, strExpr, False)
   ' Add the column to a DataTable object's ColumnsCollection
   Dim myTable As DataTable
   myTable = DataSet1.Tables("OrderDetails").Columns.Add(myColumn)

End Sub

See Also

DataColumn Class | DataColumn Members | System.Data Namespace | DataColumn Constructor Overload List | ColumnName | Caption | DefaultValue | DataTable | DataType


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataColumn Properties

The properties of the DataColumn class are listed below. For a complete list of DataColumn class members, see the DataColumn Members topic.

Public:

AllowNull | Gets or sets a value indicating whether null values are allowed in this column for rows belonging to the table.
Attribute | Gets or sets a value indicating whether the column is an attribute column.
AutoIncrement | Gets or sets a value indicating whether the column automatically increments the value of the column for new rows added to the table.
AutoIncrementSeed | Gets or sets the starting value for a column that has its AutoIncrement property set to true.
AutoIncrementStep | Gets or sets the increment used by a column with its AutoIncrement property set to true.
AutoIncrementSupported | Gets a value indicating whether AutoIncrement is supported.
Caption | Gets or sets the caption for this column.
ColumnName | Gets or sets the name of the column within the ColumnsCollection.
DataType | The type of data stored in thecolumn.
DefaultValue | Gets or sets the default value for the column when creating new rows.
Expression | Gets or sets the expresssion used to either filter rows, calculate the column's value, or create an aggregate column.
ExtendedProperties | Gets the collection of custom user information.
Namespace | [To be supplied.]
Ordinal | Gets the position of the column in the ColumnsCollection collection.
ReadOnly | Gets or sets a value indicating whether the column allows changes once a row has been added to the table.
Site (inherited from Component) | Gets or sets the site of the Component.
Sparse | Gets or sets a value indicating whether the column should store data in a fashion optimized for sparse data patterns.
Table | Gets the DataTable to which the column belongs to.
Unique | Gets or sets a value indicating whether the values in each row of the column must be unique.

See Also

DataColumn Class | System.Data Namespace


DataColumn.AllowNull

Gets or sets a value indicating whether null values are allowed in this column for rows belonging to the table.

[Visual Basic]
Public Property AllowNull As Boolean
[C#]
public bool AllowNull {get; set;}
[C++]
public: __property bool get_AllowNull();
public: __property void set_AllowNull(bool);
[JScript]
public function get AllowNull() : Boolean;
public function set AllowNull(Boolean);

Property Value

true if null values values are allowed; otherwise, false. The default is true.

Remarks

If the Unique property is true, then one null value is allowed.

The OnPropertyChanged [member, System.Data.DataColumn] occurs when the change is successful.

Example [Visual Basic]

The following example creates a new DataColumn and sets its AllowNull property to true.

[Visual Basic]

Private Sub AddNullAllowedColumn()
   Dim myColumn As DataColumn
   myColumn = New DataColumn("classID", System.Type.GetType("System.Int32"))
   myColumn.AllowNull = True
   ' Add the column to a new DataTable
   Dim myTable As DataTable
   myTable = New DataTable
   myTable.Columns.Add(myColumn)
End Sub

See Also

DataColumn Class | DataColumn Members | System.Data Namespace | Unique | OnPropertyChanged


DataColumn.Attribute

Gets or sets a value indicating whether the column is an attribute column.

[Visual Basic]
Overridable Public Property Attribute As Boolean
[C#]
public bool Attribute {virtual get; virtual set;}
[C++]
public: __property virtual bool get_Attribute();
public: __property virtual void set_Attribute(bool);
[JScript]
public function get Attribute() : Boolean;
public function set Attribute(Boolean);

Property Value

true, if the column is an attribute column; otherwise, false.

Remarks

The Attribute property specifies whether a DataColumn becomes an HTML attribute when a DataSet is transformed into an XML document. For example, if the Attribute property is set to true, and the column is named "fName," and the value it contains is "Bob," the XML element would be:

<Name fName = 'Bob'/>

See Also

DataColumn Class | DataColumn Members | System.Data Namespace


DataColumn.AutoIncrement

Gets or sets a value indicating whether the column automatically increments the value of the column for new rows added to the table.

[Visual Basic]
Public Property AutoIncrement As Boolean
[C#]
public bool AutoIncrement {get; set;}
[C++]
public: __property bool get_AutoIncrement();
public: __property void set_AutoIncrement(bool);
[JScript]
public function get AutoIncrement() : Boolean;
public function set AutoIncrement(Boolean);

Property Value

true if the value of the column increments automatically; otherwise, false. The default is false.

Exceptions

Exception Type | Condition
ArgumentException | The column is a computed column.

Remarks

If the type of this column is not Int16, Int32, or Int64 when this property is set, the DataType property is coerced to Int32. An exception is thrown if this is a computed column (that is, the Expression property is set.) The incremented value is used only if the row's value for this column, when added to the columns collection, is equal to the default value.

You can create a new row using the DataRow class's ItemArray property and passing the method an array of values. This is a potential problem for a column with its AutoIncrement set to true, because its value is generated automatically. To use the ItemArray property, place a null reference (in Visual Basic Nothing) in the column's position in the array. For more details, see the DataRow class's ItemArray property.

Example [Visual Basic]

The following example checks the AutoIncrementSupported property before setting the AutoIncrement, AutoIncrementSeed, and AutoIncrementStep properties.

[Visual Basic]

Private Sub AddAutoIncrementColumn()
   Dim myColumn As DataColumn = New DataColumn
   myColumn.DataType = System.Type.GetType("System.Int32")
   If myColumn.AutoIncrementSupported Then
      With MyColumn
         .AutoIncrement = True
         .AutoIncrementSeed = 1000
         .AutoIncrementStep = 10
      End With
   End If
   ' Add the column to a new DataTable
   Dim myTable As DataTable
   myTable = New DataTable
   myTable.Columns.Add(myColumn)
End Sub

See Also

DataColumn Class | DataColumn Members | System.Data Namespace | AutoIncrementSeed | AutoIncrementStep | AutoIncrementSupported | DataRow | Expression | ItemArray | NewRow


DataColumn.AutoIncrementSeed

Gets or sets the starting value for a column that has its AutoIncrement property set to true.

[Visual Basic]
Public Property AutoIncrementSeed As Integer
[C#]
public int AutoIncrementSeed {get; set;}
[C++]
public: __property int get_AutoIncrementSeed();
public: __property void set_AutoIncrementSeed(int);
[JScript]
public function get AutoIncrementSeed() : int;
public function set AutoIncrementSeed(int);

Property Value

The starting value for the AutoIncrement feature.

Example [Visual Basic]

The following example checks the AutoIncrementSupported property before setting the AutoIncrement, AutoIncrementSeed, and AutoIncrementStep properties.

[Visual Basic]

Private Sub AddAutoIncrementColumn()
   Dim myColumn As DataColumn = New DataColumn
   myColumn.DataType = System.Type.GetType("System.Int32")
   If myColumn.AutoIncrementSupported Then
      With MyColumn
         .AutoIncrement = True
         .AutoIncrementSeed = 1000
         .AutoIncrementStep = 10
      End With
   End If
   ' Add the column to a new DataTable
   Dim myTable As DataTable
   myTable = New DataTable
   myTable.Columns.Add(myColumn)
End Sub

See Also

DataColumn Class | DataColumn Members | System.Data Namespace | AutoIncrement | AutoIncrementStep | AutoIncrementSupported | Expression | ItemArray


DataColumn.AutoIncrementStep

Gets or sets the increment used by a column with its AutoIncrement property set to true.

[Visual Basic]
Public Property AutoIncrementStep As Integer
[C#]
public int AutoIncrementStep {get; set;}
[C++]
public: __property int get_AutoIncrementStep();
public: __property void set_AutoIncrementStep(int);
[JScript]
public function get AutoIncrementStep() : int;
public function set AutoIncrementStep(int);

Property Value

The number by which the value of the column is automatically incremented. The default is 1.

Exceptions

Exception Type | Condition
ArgumentException | The value set is zero.

Example [Visual Basic]

The following example checks the AutoIncrementSupported property before setting the AutoIncrement, AutoIncrementSeed, and AutoIncrementStep properties.

[Visual Basic]

Private Sub AddAutoIncrementColumn()
   Dim myColumn As DataColumn = New DataColumn
   myColumn.DataType = System.Type.GetType("System.Int32")
   If myColumn.AutoIncrementSupported Then
      With MyColumn
         .AutoIncrement = True
         .AutoIncrementSeed = 1000
         .AutoIncrementStep = 10
      End With
   End If
   ' Add the column to a new DataTable
   Dim myTable As DataTable
   myTable = New DataTable
   myTable.Columns.Add(myColumn)
End Sub

See Also

DataColumn Class | DataColumn Members | System.Data Namespace | AutoIncrement | AutoIncrementSeed | AutoIncrementSupported | Expression | ItemArray


DataColumn.AutoIncrementSupported

Gets a value indicating whether AutoIncrement is supported.

[Visual Basic]
Public ReadOnly Property AutoIncrementSupported As Boolean
[C#]
public bool AutoIncrementSupported {get;}
[C++]
public: __property bool get_AutoIncrementSupported();
[JScript]
public function get AutoIncrementSupported() : Boolean;

Property Value

true if AutoIncrement is supported; otherwise, false.

Remarks

UNDONE: Not in spec, used by MarkAsh. Investigate.

Example [Visual Basic]

The following example checks the AutoIncrementSupported property before setting the AutoIncrement, AutoIncrementSeed, and AutoIncrementStep properties.

[Visual Basic]

Private Sub AddAutoIncrementColumn()
   Dim myColumn As DataColumn = New DataColumn
   myColumn.DataType = System.Type.GetType("System.Int32")
   If myColumn.AutoIncrementSupported Then
      With MyColumn
         .AutoIncrement = True
         .AutoIncrementSeed = 1000
         .AutoIncrementStep = 10
      End With
   End If
   ' Add the column to a new DataTable
   Dim myTable As DataTable
   myTable = New DataTable
   myTable.Columns.Add(myColumn)
End Sub

See Also

DataColumn Class | DataColumn Members | System.Data Namespace | AutoIncrement | AutoIncrementSeed | AutoIncrementStep | Expression | ItemArray


DataColumn.Caption

Gets or sets the caption for this column.

[Visual Basic]
Public Property Caption As String
[C#]
public string Caption {get; set;}
[C++]
public: __property String* get_Caption();
public: __property void set_Caption(String*);
[JScript]
public function get Caption() : String;
public function set Caption(String);

Property Value

The caption of the column. If not set, returns the ColumnName value.

Remarks

The Caption value becomes visible in controls that support its display. For example, the System.WinForms.DataGrid control is capable of displaying captions for each column.

The OnPropertyChanged event occurs when the property is successfully changed.

Example [Visual Basic]

The following example creates a new DataColumn and adds it to a ColumnsCollection.

[Visual Basic]

Dim myColumn As DataColumn = DataColumn
myColumn = New DataColumn("fName")
' Set a different Caption.
myColumn.ColumnName = "First Name"

See Also

DataColumn Class | DataColumn Members | System.Data Namespace | ColumnName


DataColumn.ColumnName

Gets or sets the name of the column within the ColumnsCollection.

[Visual Basic]
Public Property ColumnName As String
[C#]
public string ColumnName {get; set;}
[C++]
public: __property String* get_ColumnName();
public: __property void set_ColumnName(String*);
[JScript]
public function get ColumnName() : String;
public function set ColumnName(String);

Property Value

The name of the column.

Exceptions

Exception Type | Condition
ArgumentException | The property is set to a null reference (in Visual Basic Nothing) or an empty string and the column belongs to a collection.
DuplicateNameException | A column with the same name already exists in the collection. The name comparison is not case sensitive.

Remarks

When a DataColumn is created, it has no ColumnName value. When the DataColumn is added to a DataTable object's ColumnsCollection, however, it is given a default name ("Column1", "Column2", etc.).

The Caption value is set to the ColumnName value by default.

Example [Visual Basic]

The following examples gets the ColumnName for every column in every table in a DataSet. The example also shows how to create a DataColumn with a new ColumnName.

[Visual Basic]

Private Sub PrintColumnNames(ds As DataSet)
   Dim t As DataTable
   Dim dc As DataColumn
   ' For each table in the DataSet, print the ColumnName.
   For Each t in ds.Tables
      For Each dc in t.Columns
         Console.WriteLine(dc.ColumnName)
      Next
    Next
End Sub

Private Sub AddColumn(myTable As DataTable)
   Dim dc As DataColumn
   dc = New DataColumn("SupplierID")
   With dc
      .DataType = System.Type.GetType("System.String")
      .Unique = True
      .AutoIncrement = False
      .Caption = "SupplierID"
      .ReadOnly = False
      .Sparse = True
   End With
   ' Add the column to the table's columns collection.
   myTable.Columns.Add(dc)
End Sub

See Also

DataColumn Class | DataColumn Members | System.Data Namespace | Caption


DataColumn.DataType

The type of data stored in thecolumn.

[Visual Basic]
Public Property DataType As Type
[C#]
public Type DataType {get; set;}
[C++]
public: __property Type* get_DataType();
public: __property void set_DataType(Type*);
[JScript]
public function get DataType() : Type;
public function set DataType(Type);

Property Value

A Type object that represents the column's data type.

Exceptions

Exception Type | Condition
ArgumentException | The column already has data stored.
ArgumentException | AutoIncrement is true, but the value is set to a type a unsupported by AutoIncrement.

Remarks

Setting the DataType value is critical to ensuring the correct creation and updating of data in a DBMS.

The DataType property supports the base data types shown below:

  • Boolean
  • Byte
  • Char
  • Currency
  • DateTime
  • Decimal
  • Double
  • Guid
  • Int16
  • Int32
  • Int64
  • Object
  • SByte
  • Single
  • String
  • TimeSpan
  • UInt16
  • UInt32
  • UInt64
Note The following types are not supported by Visual Basic: DateTime, UInt16, UInt32, UInt64, and TimeSpan.

An exception is thrown when changing this property after the column has begun storing data.

If AutoIncrement is set to true before setting the DataType property, and you attempt to set the type to anything except an integer type, an exception will be thrown.

Example [Visual Basic]

The following example adds columns of several data types to a DataTable, then adds one row to the table.

[Visual Basic]

Public Function MakeDataTable() As DataTable
   Dim myTable As DataTable
   Dim row As DataRow
   Dim r As Integer
   Dim c As Integer
   myTable = New DataTable("My Table")
   myTable.Columns.Add New DataColumn("StringCol", System.Type.GetType("System.String"))
   myTable.Columns.Add New DataColumn("ByteCol", System.Type.GetType("System.Byte"))
   myTable.Columns.Add New DataColumn("Int16Col", System.Type.GetType("System.Int16"))
   myTable.Columns.Add New DataColumn("Int32Col", System.Type.GetType("System.Int32"))
   myTable.Columns.Add New DataColumn("BooleanCol", System.Type.GetType("System.Boolean"))
   myTable.Columns.Add New DataColumn("TimeSpanCol", System.Type.GetType("System.TimeSpan"))
   myTable.Columns.Add New DataColumn("DateTimeCol", System.Type.GetType("System.DateTime"))
   myTable.Columns.Add New DataColumn("CurrencyCol", System.Type.GetType("System.Currency"))
   ' Populate one row with values.
   row = myTable.NewRow
   row(0) = "Item Name"
   ' Can't do column1 because it takes a byte.
   row(2) = 32767
   row(3) = 2147483647
   row(4) = True
   row(5) = "10675199.02:48:05.477"
   row(6) = now
   row(7) = 64000
   myTable.Rows.Add row
   MakeDataTable = myTable
nd Function

See Also

DataColumn Class | DataColumn Members | System.Data Namespace | Type | GetType


DataColumn.DefaultValue

Gets or sets the default value for the column when creating new rows.

[Visual Basic]
Public Property DefaultValue As Object
[C#]
public object DefaultValue {get; set;}
[C++]
public: __property Object* get_DefaultValue();
public: __property void set_DefaultValue(Object*);
[JScript]
public function get DefaultValue() : Object;
public function set DefaultValue(Object);

Property Value

A value appropriate to the column's DataType.

Exceptions

Exception Type | Condition
InvalidCastException | When adding a row, the default value is not an instance of the column's data type.

Remarks

A default value is the value that is automatically assigned to the column when a DataRow is created. By setting a default value, you can give the user an idea of what information to input. On the other hand, you can use the DefaultValue property to automatically insert a value that shouldn't be touched by the user; for example, the current date and time of the row's creation.

When AutoIncrement is set to true, there can be no default value.

You can create a new row using the DataRow class's ItemArray property and passing the method an array of values. This is a potential problem for a column with a default value because its value is generated automatically. To use the ItemArray property with such a column, place a null reference (in Visual Basic Nothing) in the column's position in the array. For more details, see the ItemArray property.

The OnPropertyChanged event occurs when the property is successfully changed.

Example [Visual Basic]

The following example creates several DataColumn objects with different data types, and sets appropriate default values to each column.

[Visual Basic]

Private Sub CreateColumns()
   Dim myCol As DataColumn
   Dim myTable As New DataTable

   myCol = New DataColumn
   With myCol
      .DataType = System.Type.GetType("System.String")
      .DefaultValue = "Address"
      .Unique = False
   End With
   myTable.Columns.Add(myCol)

   myCol = New DataColumn
   With myCol
      .DataType = System.Type.GetType("System.Int32")
      .DefaultValue = 100
   End With
   myTable.Columns.Add(myCol)

   myCol = New DataColumn
   With myCol
      .DataType = System.Type.GetType("System.DateTime")
      .DefaultValue = "1/1/2001"
   End With
   myTable.Columns.Add(myCol)

   Dim myRow As DataRow
   ' Add one row. Since it has default values, no need to set values yet.
   myRow = myTable.NewRow

   myTable.Rows.Add(myRow)
End Sub

See Also

DataColumn Class | DataColumn Members | System.Data Namespace | DataType | ItemArray | AutoIncrement | UniqueConstraint


DataColumn.Expression

Gets or sets the expresssion used to either filter rows, calculate the column's value, or create an aggregate column.

[Visual Basic]
Public Property Expression As String
[C#]
public string Expression {get; set;}
[C++]
public: __property String* get_Expression();
public: __property void set_Expression(String*);
[JScript]
public function get Expression() : String;
public function set Expression(String);

Property Value

An expression to calculate the column's value, or create an aggregate column.

Exceptions

Exception Type | Condition
ArgumentException | The AutoIncrement or Unique property is set to true.

Remarks

One use of the Expression property is to create calculated columns. For example, to calculate a tax value, the unit price is multiplied by a tax rate of a given region. Since tax rates vary from region to region, it would be impossible to put a single tax rate in a column; instead, the value is calculated using the Expression property, as shown in the Visual Basic code below:

DataSet1.Tables("Products).Columns("tax").Expression = "UnitPrice * 0.086"

A second use is to create an aggregate column. Similar to a calculated value, an aggregate performs an operation based on the entire set of rows in the DataTable. A simple example is to count the number of rows returned in the set, which is the method you would use to count thenumber of transactions compelted by a particular salesperson, as shown in this Visual Basic code:

DataSet1.Tables("Orders").Columns("OrderCount").Expression = "Count(OrderID)"

Finally, you can create row filters using the Expression. For example, to limit the displayed rows to only those people whose last name is "Smith," use the following expression:

DataSet1.Tables("Customers").Columns("LastName").Expression = "LastName = 'Smith'"

EXPRESSION SYNTAX

When creating an expression, use the ColumnName property to refer to columns. For example, if the ColumnName for one column is "UnitPrice," and another "Quantity, the expression would be:

"UnitPrice * Quantity"

When creating an expression for a filter, enclose strings with single quotes:

"LastName = 'Jones'"

The following characters are special characters and must escaped (explained below) if they are to be used in a column name:

\n (newline)

\t (tab)

\r (carriage return)

~

(

)

#

\

/

=

>

<

+

-

*

%

&

|

^

'

"

[

]

If a column name contains one of the above characters, the name must be wrapped in brackets. For example to use a column named "Column#" in an expression, you would write "[Column#]":

Total * [Column#]

Because brackets are special characters, you must use a slash ("\") to escape the bracket, if it is part of a column name. For example, a column named "Column[]" would be written:

Total * [Column[\]]

(Only the second bracket must be escaped.)

USER-DEFINED VALUES

User-defined values may be used within expressions to be compared against column values. String values should be enclosed within single quotes. Date values should be enclosed within pound signs (#). Decimals and scientific notation are permissible for numeric values. For example:

"FirstName = 'John'"

"Price <= 50.00"

"Birthdate < #1/31/82#"

OPERATORS

Concatenation is allowed using Boolean AND, OR, and NOT operators. You can use parentheses to group clauses and force precedence. The AND operator has recedence over other operators. For example:

(LastName = 'Smith' OR LastName = 'Jones') AND FirstName = 'John'

When creating comparison expressions, the following operators are allowed:

<

>

<=

>=

<>

=

IN

LIKE

The following arithmetic operators are also supported in expressions:

+ (addition)

- (subtraction)

* (multiplication)

/ (division)

% (modulus)

STRING OPERATORS

To concatenate a string, use the + character. Whether string comparisons are case-sensitive or not is determined by the value of the DataSet class's CaseSensitive property. However, you can override that valuew with the DataTable class's CaseSensitive property.

WILDCARD CHARACTERS

Both the * and % can be used interchangeably for wildcards in a LIKE comparison. If the string in a LIKE clauses contains a * or %, those characters should be escaped in brackets ([]). If a bracket is in the clause, the bracket characters should be escaped in brackets (e.g. [[] or []]). A wildcards is allowed at the beginning and end of a pattern, or at the end of a pattern, or at the beginning of a pattern. For example:

"ItemName LIKE '*product*'"

"ItemName LIKE '*product'"

"ItemName LIKE 'product*'"

Wildcards are not allowed in the middle of a string. For example, 'te*xt' is not allowed.

PARENT/CHILD RELATION REFERENCING

A column in a child table may be referenced in an expresion by prepending the column name with "Child." For example, "Child.Price" would reference the column named Price in the child table.

If a table has more than one child, the syntax is: Child(RelationName)For example, if a table has two child tables named Employee and Titles, and the DataRelation objects are named "Publishers2Employee: and "Publishers2Titles," the reference would be:

Child(Publishers2Employee).fname

Child(Publishers2Titles).title

A parent table may be referenced in an expression by prepending the column name with "Parent." For example, the "Parent.Price" references the parent table's column named "Price."

AGGREGATES

The following aggregate types are supported:

Sum (Sum)

Avg (Average)

Min (Minimum)

Max (Maximum)

Count (Count)

StDev (Statistical standard deviation)

Var (Statistical variance).

Aggregates are usually performed along relationships. Create an aggregate expression by using one of the functions listed above and a child table column as detailed in PARENT/CHILD RELATION REFERENCING above. For example:

Avg(Child.Price)

Avg(Child(Orders2Details).Price)

An aggregate can also be performed on a single table. For example, to create a summary of figures in a column named "Price":

Sum(Price)

Note If you use a single table to create an aggregate, there would be no group-by functionality. Instead, all rows would display the same value in the column.

If a table has no rows, the aggregate functions will return a null reference (in Visual Basic Nothing).

Data types can always be determined by examining the DataType property of a column. You can also convert data types using the Convert function. The syntax for the function is:

FUNCTIONS

The following functions are also supported:

CONVERT

Description | Converts given expression to a specified Type.
Syntax | Convert(expression, type)
Arguments | expression type -- A NGWS type.FullName representing the type to which the value will be converted.

LEN

Description | Returns the length of a string
Syntax | LEN(expression)
Arguments | expression -- The string to be evaluated.

ISNULL

Description | Checks and expression and either returns a null or a replacement value.
Syntax | ISNULL(expression, replacementvalue)
Arguments | expression-- The expression to check. replacementvalue-- If expression is null, replacementvalue is returned.

IIF

Description | Returns one of two values depending on the result of a logical expression.
Syntax | IIF(expr, truepart, falsepart)
Arguments | expr -- The expression to evaluate. truepart-- The value to return if the expression is true. falsepart-- The value to return if the expression is false.

Example [Visual Basic]

The following example creates three coumns in a DataTable. The second and third columns contain expressions; the second calculates tax using a variable tax rate, and the third adds the result of the calculation to the value of the first column. The resulting table is displayed in a System.WinForms.DataGrid control.

[Visual Basic]

Private Sub CalcColumns()
    Dim cPrice As DataColumn
    Dim cTax As DataColumn
    Dim cTotal As DataColumn
    Dim rate As Single
    rate = .0862
    dim t as DataTable = new DataTable

    ' Create the first column.
    cPrice = New DataColumn
    With cPrice
        .DataType = System.Type.GetType("System.Currency")
        .ColumnName = "price"
        .DefaultValue = 50
    End With

    ' Create the second, calculated, column.
    cTax = New DataColumn
    With cTax
        .DataType = System.Type.GetType("System.Currency")
        .ColumnName = "tax"
        .Expression = "price * 0.0862"
    End With

   ' Create third column
    cTotal = New DataColumn
    With cTotal
        .DataType = System.Type.GetType("System.Currency")
        .ColumnName = "total"
        .Expression = "price + tax"
    End With

    ' Add columns to DataTable
    With t.Columns
        .Add(cPrice)
        .Add(cTax)
        .Add(cTotal)
    End With

    Dim r As DataRow
    r = t.NewRow
    t.Rows.Add(r)
    Dim dView As New DataView
    Set dView.Table = t
    dView.Open
    Set DataGrid1.DataSource = dView
    dataGrid1.PopulateColumns
End Sub

See Also

DataColumn Class | DataColumn Members | System.Data Namespace | RowFilter | Sort | TableSetting | Add


DataColumn.ExtendedProperties

Gets the collection of custom user information.

[Visual Basic]
Public ReadOnly Property ExtendedProperties As PropertiesCollection
[C#]
public PropertiesCollection ExtendedProperties {get;}
[C++]
public: __property PropertiesCollection* get_ExtendedProperties();
[JScript]
public function get ExtendedProperties() : PropertiesCollection;

Property Value

A PropertiesCollection of custom information.

Example [Visual Basic]

[Visual Basic]

Dim c As DataColumn = New DataColumn
Dim ExPro As PropertiesCollection
Set ExPro = c.ExtendedProperties

See Also

DataColumn Class | DataColumn Members | System.Data Namespace


DataColumn.Namespace

[To be supplied.]

[Visual Basic]
Public Property Namespace As String
[C#]
public string Namespace {get; set;}
[C++]
public: __property String* get_Namespace();
public: __property void set_Namespace(String*);
[JScript]
public function get Namespace() : String;
public function set Namespace(String);

See Also

DataColumn Class | DataColumn Members | System.Data Namespace


DataColumn.Ordinal

Gets the position of the column in the ColumnsCollection collection.

[Visual Basic]
Public ReadOnly Property Ordinal As Integer
[C#]
public int Ordinal {get;}
[C++]
public: __property int get_Ordinal();
[JScript]
public function get Ordinal() : int;

Property Value

The position of the column. Returns-1 if the column is not a member of a collection.

Remarks

The OnPropertyChanged event occurs when the property value is successfully changed.

Example

The following example returns the ordinal of a clicked column. The example uses the System.WinForms.DataGrid control to determine which column is clicked.

' Place this code in the Click event of a DataGrid control
' to return the ordinal of the clicked column.
Dim currCol As DataColumn
Dim myTable As DataTable
myTable = DataGrid1.DataGridTable.DataTable
currCol = myTable.Columns(DataGrid1.CurrentCell.ColumnNumber)
Console.WriteLine(currCol.Ordinal)

See Also

DataColumn Class | DataColumn Members | System.Data Namespace


DataColumn.ReadOnly

Gets or sets a value indicating whether the column allows changes once a row has been added to the table.

[Visual Basic]
Public Property ReadOnly As Boolean
[C#]
public bool ReadOnly {get; set;}
[C++]
public: __property bool get_ReadOnly();
public: __property void set_ReadOnly(bool);
[JScript]
public function get ReadOnly() : Boolean;
public function set ReadOnly(Boolean);

Property Value

true if the column is read only; otherwise, false. The default is false.

Exceptions

Exception Type | Condition
ArgumentException | The property is set to false on a computed column.

Remarks

The OnPropertyChanged event occurs when the property value is successfully changed.

Example [Visual Basic]

The following example creates a DataColumn and sets its ReadOnly property true.

[Visual Basic]

Private Sub AddColumn()
   Dim cols As ColumnsCollection
   Dim myCol As DataColumn
   Dim myTable As New DataSet1.Tables("Prices")
   cols = myTable.Columns

   myCol = cols.Add("Total")
   With myCol
      .DataType = System.Type.GetType("System.Currency")
      .ReadOnly = True
      .Expression = "UnitPrice * Quantity"
      .Unique = False
   End With

End Sub

See Also

DataColumn Class | DataColumn Members | System.Data Namespace | Unique | AutoIncrement


DataColumn.Sparse

Gets or sets a value indicating whether the column should store data in a fashion optimized for sparse data patterns.

[Visual Basic]
Public Property Sparse As Boolean
[C#]
public bool Sparse {get; set;}
[C++]
public: __property bool get_Sparse();
public: __property void set_Sparse(bool);
[JScript]
public function get Sparse() : Boolean;
public function set Sparse(Boolean);

Property Value

true if the column is marked as a sparse column; otherwise, false. The default is false.

Exceptions

Exception Type | Condition
ArgumentException | The column already has data stored.

Remarks

This property is useful for irregular data. Setting the property to true indicates that the column is not always there, allowing the system to handle memory and performance better.

The OnPropertyChanged event occurs when the property value is successfully changed.

Example [Visual Basic]

The following example creates a new DataColumn and sets the Sparse property to true.

[Visual Basic]

Private Sub AddColumn()
   Dim cols As ColumnsCollection
   Dim myCol As DataColumn
   Dim myTable As New DataSet1.Tables("Prices")
   cols = myTable.Columns

   myCol = cols.Add("Total")
   With myCol
      .DataType = System.Type.GetType("System.Currency")
      .ReadOnly = True
      .Expression = "UnitPrice * Quantity"
      .Unique = False
      .Sparse = True
   End With

End Sub

See Also

DataColumn Class | DataColumn Members | System.Data Namespace


DataColumn.Table

Gets the DataTable to which the column belongs to.

[Visual Basic]
Public ReadOnly Property Table As DataTable
[C#]
public DataTable Table {get;}
[C++]
public: __property DataTable* get_Table();
[JScript]
public function get Table() : DataTable;

Property Value

The DataTable that DataColumn belongs to.

Example [Visual Basic]

The following example returns the parent table of a DataColumn through its Table property.

[Visual Basic]

Private Sub GetTable()

   Dim myTable As DataTable
   Dim myColumn As DataColumn
   myTable = DataSet1.Tables("Suppliers").Columns("CompanyName")
   Console.WriteLine("columns", myTable.Columns.Count)
   Console.WriteLine("rows", myTable.Rows.Count)
End Sub

See Also

DataColumn Class | DataColumn Members | System.Data Namespace | DataTable


DataColumn.Unique

Gets or sets a value indicating whether the values in each row of the column must be unique.

[Visual Basic]
Public Property Unique As Boolean
[C#]
public bool Unique {get; set;}
[C++]
public: __property bool get_Unique();
public: __property void set_Unique(bool);
[JScript]
public function get Unique() : Boolean;
public function set Unique(Boolean);

Property Value

true if the value must be unique; otherwise, false. The default is false.

Exceptions

Exception Type | Condition
ArgumentException | The column is a calculated column.

Remarks

The OnPropertyChanged event occurs when the property change is successful.

You can also add a UniqueConstraint to the DataTable to which this column belongs to ensure the values are unique.

Example [Visual Basic]

The following example creates a new DataColumn and sets its Unique property to true.

[Visual Basic]

Private Sub MakeUniqueColumn()
   Dim myColumn As DataColumn
   Dim myTable As New DataTable
   myColumn = New DataColumn
   myTable = New DataTable
   ' Set the Unique property of the DataColumn.
   myColumn.Unique = True
   ' Add the column to the table.
   myTable.Columns.Add myColumn
   ' Add the Table to a DataSet.
   DataSet1.Tables.Add(myTable)
End Sub

See Also

DataColumn Class | DataColumn Members | System.Data Namespace | AllowNull | UniqueConstraint | Constraints


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataColumn Methods

The methods of the DataColumn class are listed below. For a complete list of DataColumn class members, see the DataColumn Members topic.

Public:

Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FindParentRelation | Finds a relation that this column is the sole child of or null.
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
ResetCaption | Resets the Caption property to its previous value, or to a null reference (in Visual Basic Nothing).
ResetNamespace | [To be supplied.]
ShouldPersistCaption | Gets a value indicating whether the Caption has been explicitly set.
ShouldPersistNamespace | [To be supplied.]
ToString | Returns the Expression of the column, if one exists.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanged | Raises the OnPropertyChanged event.
RaisePropertyChanged | Raises the OnPropertyChanged event.
VerifyUnique | Gets a value verifying whether a value is unique.

Event Hookup:

AddOnPropertyChanged | Adds an event handler for the OnPropertyChanged event.
RemoveOnPropertyChanged | Removes the event handler that has been associated with the OnPropertyChanged event.

See Also

DataColumn Class | System.Data Namespace


DataColumn.AddOnPropertyChanged

Adds an event handler for the OnPropertyChanged event.

[Visual Basic]
Public Sub AddOnPropertyChanged( _
   ByVal handler As PropertyChangedEventHandler _
)
[C#]
public void AddOnPropertyChanged(
   PropertyChangedEventHandler handler
);
[C++]
public: void AddOnPropertyChanged(
   PropertyChangedEventHandler* handler
);
[JScript]
public function AddOnPropertyChanged(
   handler : PropertyChangedEventHandler
);

Parameters

handler
A PropertyChangedEventHandler delegate that represents the method that will handle the OnPropertyChanged event.

See Also

DataColumn Class | DataColumn Members | System.Data Namespace | AddOnPropertyChanged


DataColumn.FindParentRelation

Finds a relation that this column is the sole child of or null.

[Visual Basic]
Public Function FindParentRelation() As DataRelation
[C#]
public DataRelation FindParentRelation();
[C++]
public: DataRelation* FindParentRelation();
[JScript]
public function FindParentRelation() : DataRelation;

Return Value

A DataRelation, if one is found.

Example [Visual Basic]

The following example uses the FindParentRelation method to return a DataRelation, the relation's name, and the name of the relation's parent column.

[Visual Basic]

Private Sub GetParent()
   Dim parentRel As DataRelation
   ' Get a column from a DataSet
   Dim myCol As DataColumn
   Dim parentCols() As DataColumn
   myCol = DataSet1.Tables("OrderDetails").Columns("OrderID")
   parentRel = myCol.FindParentRelation
   Console.WriteLine(parentRel.RelationName)
   ' Get the ParentColumn of the relation
   parentCols = parentRel.ParentColumns
   Dim i As Integer
   For i = 0 to UBound(parentCols)
      Console.WriteLine(parentCols(i).ColumnName, parentCols(i).ToString)
   Next i
End Sub

See Also

DataColumn Class | DataColumn Members | System.Data Namespace | ChildRelations | DataRelation | ParentRelations | RelationsCollection


DataColumn.OnPropertyChanged

Raises the OnPropertyChanged event.

[Visual Basic]
Overridable Protected Sub OnPropertyChanged( _
   ByVal pcevent As PropertyChangedEventArgs _
)
[C#]
protected virtual void OnPropertyChanged(
   PropertyChangedEventArgs pcevent
);
[C++]
protected: virtual void OnPropertyChanged(
   PropertyChangedEventArgs* pcevent
);
[JScript]
protected function OnPropertyChanged(
   pcevent : PropertyChangedEventArgs
);

Parameters

pcevent
A PropertyChangedEventArgs that contains data about the event.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see TBD.

Notes to Inheritors: When overriding OnPropertyChanged in a derived class, be sure to call the base class's OnPropertyChanged method.

See Also

DataColumn Class | DataColumn Members | System.Data Namespace | AddOnPropertyChanged | RemoveOnPropertyChanged


DataColumn.RaisePropertyChanged

Raises the OnPropertyChanged event.

[Visual Basic]
Protected Sub RaisePropertyChanged( _
   ByVal name As String _
)
[C#]
protected void RaisePropertyChanged(
   string name
);
[C++]
protected: void RaisePropertyChanged(
   String* name
);
[JScript]
protected function RaisePropertyChanged(
   name : String
);

Parameters

name
The name of the changed property.

Remarks

The method creates the needed event data and then calls OnPropertyChanged.

See Also

DataColumn Class | DataColumn Members | System.Data Namespace


DataColumn.RemoveOnPropertyChanged

Removes the event handler that has been associated with the OnPropertyChanged event.

[Visual Basic]
Public Sub RemoveOnPropertyChanged( _
   ByVal handler As PropertyChangedEventHandler _
)
[C#]
public void RemoveOnPropertyChanged(
   PropertyChangedEventHandler handler
);
[C++]
public: void RemoveOnPropertyChanged(
   PropertyChangedEventHandler* handler
);
[JScript]
public function RemoveOnPropertyChanged(
   handler : PropertyChangedEventHandler
);

Parameters

handler
The PropertyChangedEventHandler delegate to remove.

See Also

DataColumn Class | DataColumn Members | System.Data Namespace | RemoveOnPropertyChanged


DataColumn.ResetCaption

Resets the Caption property to its previous value, or to a null reference (in Visual Basic Nothing).

[Visual Basic]
Public Sub ResetCaption()
[C#]
public void ResetCaption();
[C++]
public: void ResetCaption();
[JScript]
public function ResetCaption();

Remarks

The OnPropertyChanged event is raised when the method succeeds.

Example [Visual Basic]

The following example checks the value of an argument, and invokes the ResetCaption method if nothing is found. Otherwise, it sets the column's caption to the argument value.

[Visual Basic]

Private Sub ColCaption(ByVal col As DataColumn, Optional newCap As String)
   If newCap = "" Then
      col.ResetCaption
   Else
      col.Caption = newCap
End Sub

See Also

DataColumn Class | DataColumn Members | System.Data Namespace


DataColumn.ResetNamespace

[To be supplied.]

[Visual Basic]
Public Sub ResetNamespace()
[C#]
public void ResetNamespace();
[C++]
public: void ResetNamespace();
[JScript]
public function ResetNamespace();

See Also

DataColumn Class | DataColumn Members | System.Data Namespace


DataColumn.ShouldPersistCaption

Gets a value indicating whether the Caption has been explicitly set.

[Visual Basic]
Public Function ShouldPersistCaption() As Boolean
[C#]
public bool ShouldPersistCaption();
[C++]
public: bool ShouldPersistCaption();
[JScript]
public function ShouldPersistCaption() : Boolean;

Return Value

true if the property value has been changed from its default; otherwise, false.

Example [Visual Basic]

[Visual Basic]

Dim myColumn As DataColumn = New DataColumn
' ShouldPersistCaption returns false by default.
MessageBox.Show "ShouldPersistCaption=" & myColumn.ShouldPersistCaption
' Explicitly setting Caption changes ShouldPersistCaption to true.
myColumn.Caption = "New Caption"
MessageBox.Show "ShouldPersistCaption=" & myColumn.ShouldPersistCaption

See Also

DataColumn Class | DataColumn Members | System.Data Namespace


DataColumn.ShouldPersistNamespace

[To be supplied.]

[Visual Basic]
Public Function ShouldPersistNamespace() As Boolean
[C#]
public bool ShouldPersistNamespace();
[C++]
public: bool ShouldPersistNamespace();
[JScript]
public function ShouldPersistNamespace() : Boolean;

See Also

DataColumn Class | DataColumn Members | System.Data Namespace


DataColumn.ToString

Returns the Expression of the column, if one exists.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

The Expression value, if the property is set; otherwise, the ColumnName property.

Example [Visual Basic]

The following example uses the ToString property to return the default string of each member of a collection of DataColumn objects.

[Visual Basic]

Private Sub PrintColumns(myTable As DataTable)
   Dim dc As DataColumn
   For Each c In myTable.Columns
      Console.WriteLine(c.Ordinal, c.ToString)
   Next
End Sub

See Also

DataColumn Class | DataColumn Members | System.Data Namespace | Expression | ColumnName


DataColumn.VerifyUnique

Gets a value verifying whether a value is unique.

[Visual Basic]
Protected Function VerifyUnique( _
   ByVal value As Object _
) As Boolean
[C#]
protected bool VerifyUnique(
   object value
);
[C++]
protected: bool VerifyUnique(
   Object* value
);
[JScript]
protected function VerifyUnique(
   value : Object
) : Boolean;

Parameters

value
The value, typed as Object, to verify.

Return Value

true, if the value is unique; otherwise, false.

See Also

DataColumn Class | DataColumn Members | System.Data Namespace


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataColumn Events

The events of the DataColumn class are listed below. For a complete list of DataColumn class members, see the DataColumn Members topic.

Public:

PropertyChanged Occurs whenever a property value of the DataColumn changes.

See Also

DataColumn Class | System.Data Namespace


DataColumn PropertyChanged Event

Occurs whenever a property value of the DataColumn changes.

The following declaration shows the syntax for a method that handles the PropertyChanged event.

[Visual Basic]
Private Sub DataColumnName_PropertyChanged( _
   ByVal sender As Object, _
   ByVal e As PropertyChangedEventArgs _
)
[C#]
private void DataColumnName_PropertyChanged(
   object sender,
   PropertyChangedEventArgs e
);
[C++]
private: void DataColumnName_PropertyChanged(
   Object* sender,
   PropertyChangedEventArgs* e
);
[JScript]
private DataColumnName_PropertyChanged(
   sender : Object,
   e : PropertyChangedEventArgs
);

Parameters

sender
The source of the event.
e
A PropertyChangedEventArgs that contains the event data. The following PropertyChangedEventArgs properties provide information specific to this event.
Property Description
PropertyName
Gets the name of the property that changed.

Remarks

The event occurs when the values of the DataColumn properties change.

See Also

DataColumn Class | DataColumn MembersTopic | System.Data Namespace


DataColumnChangeEventArgs Class

Provides data for the ColumnChanging event.

Object
EventArgs
DataColumnChangeEventArgs

[Visual Basic]
Public Class DataColumnChangeEventArgs
   Inherits EventArgs
[C#]
public class DataColumnChangeEventArgs : EventArgs
[C++]
public __gc class DataColumnChangeEventArgs : public EventArgs
[JScript]
public class DataColumnChangeEventArgs extends EventArgs

Remarks

The ColumnChanging event occurs when a change is made to a column's value in the DataTable.

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

DataColumnChangeEventArgs Members | System.Data Namespace | ColumnChanging | DataColumn | DataColumnChangeEventHandler | DataTable


DataColumnChangeEventArgs Members

Public:

Constructor

DataColumnChangeEventArgs Constructor Initializes a new instance of the DataColumnChangeEventArgs class.

Properties

Column | Gets the column whose value is changing.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
ProposedValue | Gets or sets the proposed value.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataColumnChangeEventArgs Class | System.Data Namespace


DataColumnChangeEventArgs Constructor

Initializes a new instance of the DataColumnChangeEventArgs class.

[Visual Basic]
Public Sub New( _
   ByVal column As DataColumn, _
   ByVal value As Object _
)
[C#]
public DataColumnChangeEventArgs(
   DataColumn column,
   object value
);
[C++]
public: DataColumnChangeEventArgs(
   DataColumn* column,
   Object* value
);
[JScript]
public function DataColumnChangeEventArgs(
   column : DataColumn,
   value : Object
);

Parameters

column
The DataColumn with the changing value.
value
[To be supplied.]

See Also

DataColumnChangeEventArgs Class | DataColumnChangeEventArgs Members | System.Data Namespace | ColumnChanging | DataColumn | DataColumnChangeEventHandler | DataTable


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataColumnChangeEventArgs Properties

The properties of the DataColumnChangeEventArgs class are listed below. For a complete list of DataColumnChangeEventArgs class members, see the DataColumnChangeEventArgs Members topic.

Public:

Column | Gets the column whose value is changing.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
ProposedValue | Gets or sets the proposed value.

See Also

DataColumnChangeEventArgs Class | System.Data Namespace


DataColumnChangeEventArgs.Column

Gets the column whose value is changing.

[Visual Basic]
Public ReadOnly Property Column As DataColumn
[C#]
public DataColumn Column {get;}
[C++]
public: __property DataColumn* get_Column();
[JScript]
public function get Column() : DataColumn;

Property Value

A DataColumn whose value is changing.

See Also

DataColumnChangeEventArgs Class | DataColumnChangeEventArgs Members | System.Data Namespace | ColumnChanging | DataColumn | DataColumnChangeEventHandler | DataTable


DataColumnChangeEventArgs.ProposedValue

Gets or sets the proposed value.

[Visual Basic]
Public Property ProposedValue As Object
[C#]
public object ProposedValue {get; set;}
[C++]
public: __property Object* get_ProposedValue();
public: __property void set_ProposedValue(Object*);
[JScript]
public function get ProposedValue() : Object;
public function set ProposedValue(Object);

Property Value

The proposed value, of type Object.

See Also

DataColumnChangeEventArgs Class | DataColumnChangeEventArgs Members | System.Data Namespace | ColumnChanging | DataColumn | DataColumnChangeEventHandler | DataTable


DataColumnChangeEventHandler Delegate

Provides data for the ColumnChanging event.

[Visual Basic]
Public Delegate Sub DataColumnChangeEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataColumnChangeEventArgs _
)
[C#]
public delegate void DataColumnChangeEventHandler(
   object sender,
   DataColumnChangeEventArgs e
);
[C++]
public __gc __delegate void DataColumnChangeEventHandler(
   Object* sender,
   DataColumnChangeEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the DataColumnChangeEventHandler delegate declaration.

The source of the event.
A DataColumnChangeEventArgs that contains the event data.

Remarks

When you create a DataColumnChangeEventHandler delegate, you identify the method that will handle the vent. To associate the event with your event-handling method, add an instance of the delegate to the event. The event-handling method is called whenever the event occurs, until you remove the delegate. For more information about delegates, see TBD

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace


DataCursorRowState Enumeration

[To be supplied.]

[Visual Basic]
Public Enum DataCursorRowState
[C#]
public enum DataCursorRowState
[C++]
public enum DataCursorRowState

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
CurrentRows | [To be supplied.]
Deleted | [To be supplied.]
ModifiedCurrent | [To be supplied.]
ModifiedOriginal | [To be supplied.]
New | [To be supplied.]
None | [To be supplied.]
OriginalRows | [To be supplied.]
Unchanged | [To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace


DataCursorSort Enumeration

[To be supplied.]

[Visual Basic]
Public Enum DataCursorSort
[C#]
public enum DataCursorSort
[C++]
public enum DataCursorSort

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
COLUMN | [To be supplied.]
DESCENDING | [To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace


DataError Class

Represents an custom error that can be associated with a DataRow.

Object
DataError

[Visual Basic]
Public Class DataError
[C#]
public class DataError
[C++]
public __gc class DataError
[JScript]
public class DataError

Remarks

Custom error messages allow you to give your end users a non-technical error message for each row in a table. For example, you can use the GetColumnsInError to determine exactly which column has an error, and insert the information into the DataError. In a System.WinForms.DataGrid control, any rows that have an error is marked with a red exclamation mark, allowing the user to scan for errors quickly.

To set custom error text, create a DataError, and assign the object to the Error property of a DataRow.

Use the DataSet object's HasErrors property to check if any table has an error. If so, retrieve the DataError for each DataRow through the RowError property.

Requirements

Namespace: System.Data

Assembly: System.Data.dll

Example [Visual Basic]

The following example sets DataError objects for ten rows in a table; the example also prints each error out.

[Visual Basic]

Private Sub SetErrors()
   Dim t As DataTable
   ' Get the DataTable of a DataGrid control.
   Set t = DataGrid1.DataGridTable.DataTable
   Dim i As Integer
   Dim de As DataError
   ' Create 10 DataError objects and assign to ten rows. Insert column 1 value into error.
   For i = 1 To 10
      Set de = New DataError("ERROR: " & t.rows(i)(1))
      Set t.Rows(i).Error = de
   Next
   Dim ds As DataSet
   Set ds = t.DataSet
   Dim tempT As DataTable
    ' Test for errors. If DataSet has errors, test each table.
   If Not ds.HasErrors Then
       ' If you have no errors, you can merge the DataSet with it's clone.
       ' DataSet1.Merge DataSetClone
   Else
      For Each tempT In ds.Tables
          ' If the table has errors, then print them.
         If tempT.HasErrors Then printRowErrs tempT
      Next
   End If
   ' Refresh the DataGrid to see the error-marked rows.
   DataGrid1.Refresh
End Sub

Private Sub PrintRowErrs(t As DataTable)
   Dim r As DataRow
   For Each r In t.Rows
      If r.HasErrors Then
         Debug.Print r.RowError
      End If
   Next
End Sub

See Also

DataError Members | System.Data Namespace


DataError Members

Public:

Constructor

DataError Constructor Overloaded. Initializes a new instance of the DataError class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetText | Sets the error message for the DataError.

See Also

DataError Class | System.Data Namespace


DataError Constructor

Initializes a new instance of the DataError class.

Overload List

Initializes a new instance of the DataError class.

[Visual Basic] Overloads Public Sub New()
[C#] public DataError();
[C++] public: DataError();
[JScript] public function DataError();

Initializes a new instance of the DataError class using the specified error text.

[Visual Basic] Overloads Public Sub New(String)
[C#] public DataError(String);
[C++] public: DataError(String*);
[JScript] public function DataError(String);

Example [Visual Basic]

Note This example shows how to use one of the overloaded version of the DataError constructor. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub SetErrors()
   Dim t As DataTable
   ' Get table 0 of a DataSet.
   t = DataSet1.Tables(0)
   Dim i As Integer
   ' Declare temporary DataError variable.
   Dim de As DataError

   ' Set DataError objects for 10 rows.
   For i = 1 To 10
      de = New DataError("Row Error: " & t.rows(i)(1))
      t.Rows(i).Error = de
   Next
End Sub

See Also

DataError Class | DataError Members | System.Data Namespace


DataError Constructor ()

Initializes a new instance of the DataError class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public DataError();
[C++]
public: DataError();
[JScript]
public function DataError();

Example [Visual Basic]

The following example constructs 10 DataError objects, and assigns each to the Error property of a DataRow.

[Visual Basic]

Private Sub SetErrors()
   Dim t As DataTable
   ' Get table 0 of a DataSet.
   t = DataSet1.Tables(0)
   Dim i As Integer
   ' Declare temporary DataError variable.
   Dim de As DataError

   ' Set DataError objects for 10 rows.
   For i = 1 To 10
      de = New DataError
      de.SetText t.rows(i)(1) & " Row Error"
      t.Rows(i).Error = de
   Next
 End Sub

See Also

DataError Class | DataError Members | System.Data Namespace | DataError Constructor Overload List


DataError Constructor (String)

Initializes a new instance of the DataError class using the specified error text.

[Visual Basic]
Overloads Public Sub New( _
   ByVal rowError As String _
)
[C#]
public DataError(
   string rowError
);
[C++]
public: DataError(
   String* rowError
);
[JScript]
public function DataError(
   rowError : String
);

Parameters

rowError
The error messsage for the DataError.

Example [Visual Basic]

[Visual Basic]

Private Sub SetErrors()
   Dim t As DataTable
   ' Get table 0 of a DataSet.
   t = DataSet1.Tables(0)
   Dim i As Integer
   ' Declare temporary DataError variable.
   Dim de As DataError

   ' Set DataError objects for 10 rows.
   For i = 1 To 10
      de = New DataError("Row Error: " & t.rows(i)(1))
      t.Rows(i).Error = de
   Next
End Sub

See Also

DataError Class | DataError Members | System.Data Namespace | DataError Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataError Methods

The methods of the DataError class are listed below. For a complete list of DataError class members, see the DataError Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetText | Sets the error message for the DataError.

See Also

DataError Class | System.Data Namespace


DataError.SetText

Sets the error message for the DataError.

[Visual Basic]
Protected Sub SetText( _
   ByVal errorText As String _
)
[C#]
protected void SetText(
   string errorText
);
[C++]
protected: void SetText(
   String* errorText
);
[JScript]
protected function SetText(
   errorText : String
);

Parameters

errorText
The error message for the DataError.

See Also

DataError Class | DataError Members | System.Data Namespace


DataException Class

[To be supplied.]

Object
Exception
SystemException
DataException

[Visual Basic]
Public Class DataException
   Inherits SystemException
[C#]
public class DataException : SystemException
[C++]
public __gc class DataException : public SystemException
[JScript]
public class DataException extends SystemException

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

DataException Members | System.Data Namespace


DataException Members

Public:

Constructor

DataException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

DataException Class | System.Data Namespace


DataException Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public DataException();
[C++] public: DataException();
[JScript] public function DataException();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public DataException(String);
[C++] public: DataException(String*);
[JScript] public function DataException(String);

See Also

DataException Class | DataException Members | System.Data Namespace


DataException Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public DataException();
[C++]
public: DataException();
[JScript]
public function DataException();

See Also

DataException Class | DataException Members | System.Data Namespace | DataException Constructor Overload List


DataException Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal s As String _
)
[C#]
public DataException(
   string s
);
[C++]
public: DataException(
   String* s
);
[JScript]
public function DataException(
   s : String
);

Parameters

s
[To be supplied.]

See Also

DataException Class | DataException Members | System.Data Namespace | DataException Constructor Overload List


DataExpression Class

[To be supplied.]

Object
DataExpression

[Visual Basic]
Public Class DataExpression
[C#]
public class DataExpression
[C++]
public __gc class DataExpression
[JScript]
public class DataExpression

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

DataExpression Members | System.Data Namespace


DataExpression Members

Public:

Constructor

DataExpression Constructor Overloaded. [To be supplied.]

Properties

Expression [To be supplied.]

Methods

Bind | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Evaluate | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataExpression Class | System.Data Namespace


DataExpression Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public DataExpression();
[C++] public: DataExpression();
[JScript] public function DataExpression();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, DataTable)
[C#] public DataExpression(String, DataTable);
[C++] public: DataExpression(String*, DataTable);
[JScript] public function DataExpression(String, DataTable);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, DataTable, Type)
[C#] public DataExpression(String, DataTable, Type);
[C++] public: DataExpression(String*, DataTable, Type);
[JScript] public function DataExpression(String, DataTable, Type);

See Also

DataExpression Class | DataExpression Members | System.Data Namespace


DataExpression Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public DataExpression();
[C++]
public: DataExpression();
[JScript]
public function DataExpression();

See Also

DataExpression Class | DataExpression Members | System.Data Namespace | DataExpression Constructor Overload List


DataExpression Constructor (String, DataTable)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal expression As String, _
   ByVal table As DataTable _
)
[C#]
public DataExpression(
   string expression,
   DataTable table
);
[C++]
public: DataExpression(
   String* expression,
   DataTable* table
);
[JScript]
public function DataExpression(
   expression : String,
   table : DataTable
);

Parameters

expression
[To be supplied.]
table
[To be supplied.]

See Also

DataExpression Class | DataExpression Members | System.Data Namespace | DataExpression Constructor Overload List


DataExpression Constructor (String, DataTable, Type)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal expression As String, _
   ByVal table As DataTable, _
   ByVal type As Type _
)
[C#]
public DataExpression(
   string expression,
   DataTable table,
   Type type
);
[C++]
public: DataExpression(
   String* expression,
   DataTable* table,
   Type* type
);
[JScript]
public function DataExpression(
   expression : String,
   table : DataTable,
   type : Type
);

Parameters

expression
[To be supplied.]
table
[To be supplied.]
type
[To be supplied.]

See Also

DataExpression Class | DataExpression Members | System.Data Namespace | DataExpression Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataExpression Properties

The properties of the DataExpression class are listed below. For a complete list of DataExpression class members, see the DataExpression Members topic.

Public:

Expression [To be supplied.]

See Also

DataExpression Class | System.Data Namespace


DataExpression.Expression

[To be supplied.]

[Visual Basic]
Overridable Public Property Expression As String
[C#]
public string Expression {virtual get; virtual set;}
[C++]
public: __property virtual String* get_Expression();
public: __property virtual void set_Expression(String*);
[JScript]
public function get Expression() : String;
public function set Expression(String);

See Also

DataExpression Class | DataExpression Members | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataExpression Methods

The methods of the DataExpression class are listed below. For a complete list of DataExpression class members, see the DataExpression Members topic.

Public:

Bind | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Evaluate | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataExpression Class | System.Data Namespace


DataExpression.Bind

[To be supplied.]

[Visual Basic]
Overridable Public Sub Bind( _
   ByVal table As DataTable _
)
[C#]
public virtual void Bind(
   DataTable table
);
[C++]
public: virtual void Bind(
   DataTable* table
);
[JScript]
public function Bind(
   table : DataTable
);

Parameters

table
[To be supplied.]

See Also

DataExpression Class | DataExpression Members | System.Data Namespace


DataExpression.Evaluate

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Evaluate(DataRow, DataRowVersion) As Object
[C#] public virtual object Evaluate(DataRow, DataRowVersion);
[C++] public: virtual Object* Evaluate(DataRow*, DataRowVersion);
[JScript] public function Evaluate(DataRow, DataRowVersion) : Object;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Evaluate(DataRow()) As Object
[C#] public virtual object Evaluate(DataRow[]);
[C++] public: virtual Object* Evaluate(DataRow*[]);
[JScript] public function Evaluate(DataRow[]) : Object;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Evaluate(DataRow(), DataRowVersion) As Object
[C#] public virtual object Evaluate(DataRow[], DataRowVersion);
[C++] public: virtual Object* Evaluate(DataRow*[], DataRowVersion);
[JScript] public function Evaluate(DataRow[], DataRowVersion) : Object;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Evaluate() As Object
[C#] public virtual object Evaluate();
[C++] public: virtual Object* Evaluate();
[JScript] public function Evaluate() : Object;

See Also

DataExpression Class | DataExpression Members | System.Data Namespace


DataExpression.Evaluate (DataRow, DataRowVersion)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Evaluate( _
   ByVal row As DataRow, _
   ByVal version As DataRowVersion _
) As Object
[C#]
public virtual object Evaluate(
   DataRow row,
   DataRowVersion version
);
[C++]
public: virtual Object* Evaluate(
   DataRow* row,
   DataRowVersion version
);
[JScript]
public function Evaluate(
   row : DataRow,
   version : DataRowVersion
) : Object;

Parameters

row
[To be supplied.]
version
[To be supplied.]

See Also

DataExpression Class | DataExpression Members | System.Data Namespace | DataExpression.Evaluate Overload List


DataExpression.Evaluate (DataRow[])

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Evaluate( _
   ByVal rows() As DataRow _
) As Object
[C#]
public virtual object Evaluate(
   DataRow[] rows
);
[C++]
public: virtual Object* Evaluate(
   DataRow* rows[]
);
[JScript]
public function Evaluate(
   rows : DataRow[]
) : Object;

Parameters

rows
[To be supplied.]

See Also

DataExpression Class | DataExpression Members | System.Data Namespace | DataExpression.Evaluate Overload List


DataExpression.Evaluate (DataRow[], DataRowVersion)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Evaluate( _
   ByVal rows() As DataRow, _
   ByVal version As DataRowVersion _
) As Object
[C#]
public virtual object Evaluate(
   DataRow[] rows,
   DataRowVersion version
);
[C++]
public: virtual Object* Evaluate(
   DataRow* rows[],
   DataRowVersion version
);
[JScript]
public function Evaluate(
   rows : DataRow[],
   version : DataRowVersion
) : Object;

Parameters

rows
[To be supplied.]
version
[To be supplied.]

See Also

DataExpression Class | DataExpression Members | System.Data Namespace | DataExpression.Evaluate Overload List


DataExpression.Evaluate ()

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Evaluate() As Object
[C#]
public virtual object Evaluate();
[C++]
public: virtual Object* Evaluate();
[JScript]
public function Evaluate() : Object;

See Also

DataExpression Class | DataExpression Members | System.Data Namespace | DataExpression.Evaluate Overload List


DataExpression.ToString

[To be supplied.]

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

DataExpression Class | DataExpression Members | System.Data Namespace


DataFilter Class

[To be supplied.]

Object
DataExpression
DataFilter

[Visual Basic]
Public Class DataFilter
   Inherits DataExpression
   Implements IFilter
[C#]
public class DataFilter : DataExpression, IFilter
[C++]
public __gc class DataFilter : public DataExpression, IFilter
[JScript]
public class DataFilter extends DataExpression, IFilter

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

DataFilter Members | System.Data Namespace


DataFilter Members

Public:

Constructor

DataFilter Constructor Overloaded. [To be supplied.]

Properties

Expression (inherited from DataExpression) [To be supplied.]

Methods

Bind (inherited from DataExpression) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Evaluate (inherited from DataExpression) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Invoke | Overloaded. [To be supplied.]
ToString (inherited from DataExpression) | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataFilter Class | System.Data Namespace


DataFilter Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public DataFilter();
[C++] public: DataFilter();
[JScript] public function DataFilter();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, DataTable)
[C#] public DataFilter(String, DataTable);
[C++] public: DataFilter(String*, DataTable);
[JScript] public function DataFilter(String, DataTable);

See Also

DataFilter Class | DataFilter Members | System.Data Namespace


DataFilter Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public DataFilter();
[C++]
public: DataFilter();
[JScript]
public function DataFilter();

See Also

DataFilter Class | DataFilter Members | System.Data Namespace | DataFilter Constructor Overload List


DataFilter Constructor (String, DataTable)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal expression As String, _
   ByVal table As DataTable _
)
[C#]
public DataFilter(
   string expression,
   DataTable table
);
[C++]
public: DataFilter(
   String* expression,
   DataTable* table
);
[JScript]
public function DataFilter(
   expression : String,
   table : DataTable
);

Parameters

expression
[To be supplied.]
table
[To be supplied.]

See Also

DataFilter Class | DataFilter Members | System.Data Namespace | DataFilter Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataFilter Methods

The methods of the DataFilter class are listed below. For a complete list of DataFilter class members, see the DataFilter Members topic.

Public:

Bind (inherited from DataExpression) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Evaluate (inherited from DataExpression) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Invoke | Overloaded. [To be supplied.]
ToString (inherited from DataExpression) | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataFilter Class | System.Data Namespace


DataFilter.Invoke

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Invoke() As Boolean
[C#] public virtual bool Invoke();
[C++] public: virtual bool Invoke();
[JScript] public function Invoke() : Boolean;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Invoke(DataRow) As Boolean
[C#] public virtual bool Invoke(DataRow);
[C++] public: virtual bool Invoke(DataRow*);
[JScript] public function Invoke(DataRow) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Invoke(DataRow, DataRowVersion) As Boolean
[C#] public virtual bool Invoke(DataRow, DataRowVersion);
[C++] public: virtual bool Invoke(DataRow*, DataRowVersion);
[JScript] public function Invoke(DataRow, DataRowVersion) : Boolean;

See Also

DataFilter Class | DataFilter Members | System.Data Namespace


DataFilter.Invoke ()

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Invoke() As Boolean
[C#]
public virtual bool Invoke();
[C++]
public: virtual bool Invoke();
[JScript]
public function Invoke() : Boolean;

See Also

DataFilter Class | DataFilter Members | System.Data Namespace | DataFilter.Invoke Overload List


DataFilter.Invoke (DataRow)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Invoke( _
   ByVal row As DataRow _
) As Boolean
[C#]
public virtual bool Invoke(
   DataRow row
);
[C++]
public: virtual bool Invoke(
   DataRow* row
);
[JScript]
public function Invoke(
   row : DataRow
) : Boolean;

Parameters

row
[To be supplied.]

See Also

DataFilter Class | DataFilter Members | System.Data Namespace | DataFilter.Invoke Overload List


DataFilter.Invoke (DataRow, DataRowVersion)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Invoke( _
   ByVal row As DataRow, _
   ByVal version As DataRowVersion _
) As Boolean
[C#]
public virtual bool Invoke(
   DataRow row,
   DataRowVersion version
);
[C++]
public: virtual bool Invoke(
   DataRow* row,
   DataRowVersion version
);
[JScript]
public function Invoke(
   row : DataRow,
   version : DataRowVersion
) : Boolean;

Parameters

row
[To be supplied.]
version
[To be supplied.]

See Also

DataFilter Class | DataFilter Members | System.Data Namespace | DataFilter.Invoke Overload List


DataKey Class

[To be supplied.]

Object
DataKey

[Visual Basic]
Public Class DataKey
[C#]
public class DataKey
[C++]
public __gc class DataKey
[JScript]
public class DataKey

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

DataKey Members | System.Data Namespace


DataKey Members

Public:

Constructor

DataKey Constructor Overloaded. [To be supplied.]

Properties

Columns | [To be supplied.]
Name | [To be supplied.]
SortOrder | [To be supplied.]
Table | [To be supplied.]

Methods

ColumnsEqual | [To be supplied.]
ContainsColumn | [To be supplied.]
Equals | [To be supplied.]
GetDebugString | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSortString | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
RecordsEqual | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataKey Class | System.Data Namespace


DataKey Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(DataColumn)
[C#] public DataKey(DataColumn);
[C++] public: DataKey(DataColumn*);
[JScript] public function DataKey(DataColumn);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(DataColumn, SortOrder)
[C#] public DataKey(DataColumn, SortOrder);
[C++] public: DataKey(DataColumn*, SortOrder);
[JScript] public function DataKey(DataColumn, SortOrder);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(DataColumn())
[C#] public DataKey(DataColumn[]);
[C++] public: DataKey(DataColumn*[]);
[JScript] public function DataKey(DataColumn[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(DataColumn(), Integer())
[C#] public DataKey(DataColumn[], int[]);
[C++] public: DataKey(DataColumn*[], int[]);
[JScript] public function DataKey(DataColumn[], int[]);

See Also

DataKey Class | DataKey Members | System.Data Namespace


DataKey Constructor (DataColumn)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal column As DataColumn _
)
[C#]
public DataKey(
   DataColumn column
);
[C++]
public: DataKey(
   DataColumn* column
);
[JScript]
public function DataKey(
   column : DataColumn
);

Parameters

column
[To be supplied.]

See Also

DataKey Class | DataKey Members | System.Data Namespace | DataKey Constructor Overload List


DataKey Constructor (DataColumn, SortOrder)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal column As DataColumn, _
   ByVal sortOrder As SortOrder _
)
[C#]
public DataKey(
   DataColumn column,
   SortOrder sortOrder
);
[C++]
public: DataKey(
   DataColumn* column,
   SortOrder sortOrder
);
[JScript]
public function DataKey(
   column : DataColumn,
   sortOrder : SortOrder
);

Parameters

column
[To be supplied.]
sortOrder
[To be supplied.]

See Also

DataKey Class | DataKey Members | System.Data Namespace | DataKey Constructor Overload List


DataKey Constructor (DataColumn[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal columns() As DataColumn _
)
[C#]
public DataKey(
   DataColumn[] columns
);
[C++]
public: DataKey(
   DataColumn* columns[]
);
[JScript]
public function DataKey(
   columns : DataColumn[]
);

Parameters

columns
[To be supplied.]

See Also

DataKey Class | DataKey Members | System.Data Namespace | DataKey Constructor Overload List


DataKey Constructor (DataColumn[], Int32[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal columns() As DataColumn, _
   ByVal sortOrders() As Integer _
)
[C#]
public DataKey(
   DataColumn[] columns,
   int[] sortOrders
);
[C++]
public: DataKey(
   DataColumn* columns[],
   int* sortOrders[]
);
[JScript]
public function DataKey(
   columns : DataColumn[],
   sortOrders : int[]
);

Parameters

columns
[To be supplied.]
sortOrders
[To be supplied.]

See Also

DataKey Class | DataKey Members | System.Data Namespace | DataKey Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataKey Properties

The properties of the DataKey class are listed below. For a complete list of DataKey class members, see the DataKey Members topic.

Public:

Columns | [To be supplied.]
Name | [To be supplied.]
SortOrder | [To be supplied.]
Table | [To be supplied.]

See Also

DataKey Class | System.Data Namespace


DataKey.Columns

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Columns As DataColumn ()
[C#]
public DataColumn[] Columns {virtual get;}
[C++]
public: __property virtual DataColumn* get_Columns();
[JScript]
public function get Columns() : DataColumn[];

See Also

DataKey Class | DataKey Members | System.Data Namespace


DataKey.Name

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {virtual get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

See Also

DataKey Class | DataKey Members | System.Data Namespace


DataKey.SortOrder

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property SortOrder As Integer ()
[C#]
public int[] SortOrder {virtual get;}
[C++]
public: __property virtual int* get_SortOrder();
[JScript]
public function get SortOrder() : int[];

See Also

DataKey Class | DataKey Members | System.Data Namespace


DataKey.Table

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Table As DataTable
[C#]
public DataTable Table {virtual get;}
[C++]
public: __property virtual DataTable* get_Table();
[JScript]
public function get Table() : DataTable;

See Also

DataKey Class | DataKey Members | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataKey Methods

The methods of the DataKey class are listed below. For a complete list of DataKey class members, see the DataKey Members topic.

Public:

ColumnsEqual | [To be supplied.]
ContainsColumn | [To be supplied.]
Equals | [To be supplied.]
GetDebugString | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSortString | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
RecordsEqual | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataKey Class | System.Data Namespace


DataKey.ColumnsEqual

[To be supplied.]

[Visual Basic]
Overridable Public Function ColumnsEqual( _
   ByVal key As DataKey _
) As Boolean
[C#]
public virtual bool ColumnsEqual(
   DataKey key
);
[C++]
public: virtual bool ColumnsEqual(
   DataKey* key
);
[JScript]
public function ColumnsEqual(
   key : DataKey
) : Boolean;

Parameters

key
[To be supplied.]

See Also

DataKey Class | DataKey Members | System.Data Namespace


DataKey.ContainsColumn

[To be supplied.]

[Visual Basic]
Overridable Public Function ContainsColumn( _
   ByVal column As DataColumn _
) As Boolean
[C#]
public virtual bool ContainsColumn(
   DataColumn column
);
[C++]
public: virtual bool ContainsColumn(
   DataColumn* column
);
[JScript]
public function ContainsColumn(
   column : DataColumn
) : Boolean;

Parameters

column
[To be supplied.]

See Also

DataKey Class | DataKey Members | System.Data Namespace


DataKey.Equals

[To be supplied.]

[Visual Basic]
Overrides Public Function Equals( _
   ByVal key2 As Object _
) As Boolean
[C#]
public override bool Equals(
   object key2
);
[C++]
public: override bool Equals(
   Object* key2
);
[JScript]
public override function Equals(
   key2 : Object
) : Boolean;

Parameters

key2
[To be supplied.]

See Also

DataKey Class | DataKey Members | System.Data Namespace


DataKey.GetDebugString

[To be supplied.]

[Visual Basic]
Public Function GetDebugString() As String
[C#]
public string GetDebugString();
[C++]
public: String* GetDebugString();
[JScript]
public function GetDebugString() : String;

See Also

DataKey Class | DataKey Members | System.Data Namespace


DataKey.GetSortString

[To be supplied.]

[Visual Basic]
Public Function GetSortString() As String
[C#]
public string GetSortString();
[C++]
public: String* GetSortString();
[JScript]
public function GetSortString() : String;

See Also

DataKey Class | DataKey Members | System.Data Namespace


DataKey.RecordsEqual

[To be supplied.]

[Visual Basic]
Overridable Public Function RecordsEqual( _
   ByVal record1 As Integer, _
   ByVal record2 As Integer _
) As Boolean
[C#]
public virtual bool RecordsEqual(
   int record1,
   int record2
);
[C++]
public: virtual bool RecordsEqual(
   int record1,
   int record2
);
[JScript]
public function RecordsEqual(
   record1 : int,
   record2 : int
) : Boolean;

Parameters

record1
[To be supplied.]
record2
[To be supplied.]

See Also

DataKey Class | DataKey Members | System.Data Namespace


DataRelation Class

Represents a parent/child relationship between two tables.

Object
DataRelation

[Visual Basic]
Public Class DataRelation
[C#]
public class DataRelation
[C++]
public __gc class DataRelation
[JScript]
public class DataRelation

Remarks

A DataRelation is used to relate two DataTable objects to each other through DataColumn objects. For example, in a Customer/Orders relationship, the Customers table is the parent and the Orders table is the child of the relationship.

Relationships are created between matching columns in the parent and child tables. That is, the DataType value for both columns must be identical.

Relationships can also cascade various changes to the parent row down to it's child rows. To control how values are changed in child rows, add a ForeignKeyConstraint to the DataTable class's ConstraintsCollection, which determines what happens when a value in a parent table is deleted or updated.

When a DataRelation is created, it verifies that the relationship can be established. Once it is added to the Relations collection, this is maintained by disallowing any changes that would invalidate this relation. However, before it is added to the Relations collection, this can change. So, every access of the object between construction and collection add verifies that the state is still valid, and throws an exception if it is no longer a viable relation.

DataRelation objects are contained in a RelationsCollection, and both the DataSet and the DataTable classes have properties to access the collection. the DataSet class's Relations property, and the DataTable class's ChildRelations and ParentRelations properties all access different RelationsCollection objects.

Requirements

Namespace: System.Data

Assembly: System.Data.dll

Example [Visual Basic]

The following example creates a new DataRelation and adds it to a DataSet object's RelationsCollection.

[Visual Basic]

Private Sub CreateRelation()
   ' Get the DataColumn objects from two DataTable objects in a DataSet.
   Dim parentCol As DataColumn
   Dim childCol As DataColumn
   ' Code to get the DataSet not shown here.
   parentCol = DataSet1.Tables("Customers").Columns("CustID")
   childCol = DataSet1.Tables("Orders").Columns("CustID")
   ' Create DataRelation.
   Dim relCustOrder As DataRelation
   CustOrderRel = New DataRelation("CustomersOrders", parentCol, childCol)
   ' Add the relation to the DataSet.
   DataSet1.Relations.Add(CustOrderRel)
End Sub

See Also

DataRelation Members | System.Data Namespace | ChildRelations | DataColumn | DataSet | ForeignKeyConstraint | RelationsCollection | UniqueConstraint | ParentRelations


DataRelation Members

Public:

Constructor

DataRelation Constructor Overloaded. Initializes a new instance of the DataRelation class.

Properties

ChildColumns | Gets the child columns of this relation.
ChildKeyConstraint | Gets the ForeignKeyConstraint for the relation.
ChildTable | Gets the child table of this relation.
DataSet | Gets the DataSet to which the relations' collection belongs to.
Nested | Gets or sets a value indicating whether relations are nested.
ParentColumns | Gets the parent columns of this relation.
ParentKeyConstraint | Gets the constraint which ensures values in a column are unique.
ParentTable | Gets the parent table of this relation.
RelationName | Gets or sets the name used to look up this relation in the parent data set's RelationsCollection.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SetParentRow | Sets the parent row for the child row across this relation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Events

PropertyChanged Occurs whenever a property value of the DataRelation changes.

Protected:

Methods

CheckStateForProperty | Checks to ensure the DataRelation is a valid object, even if it doesn't belong to a DataSet.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanged | Raises the OnPropertyChanged event.
RaisePropertyChanged | Raises the OnPropertyChanged event.

Event Hookup:

Methods

AddOnPropertyChanged | Adds an event handler for the OnPropertyChanged event.
RemoveOnPropertyChanged | Removes an event handler that has been associated with the OnPropertyChanged event.

See Also

DataRelation Class | System.Data Namespace


DataRelation Constructor

Initializes a new instance of the DataRelation class.

Overload List

Initializes a new instance of the DataRelation class using the specified name, parent, and child columns.

[Visual Basic] Overloads Public Sub New(String, DataColumn, DataColumn)
[C#] public DataRelation(String, DataColumn, DataColumn);
[C++] public: DataRelation(String*, DataColumn, DataColumn);
[JScript] public function DataRelation(String, DataColumn, DataColumn);

Initializes a new instance of the DataRelation class using the specified name, parent, and child columns, and value to create constraints.

[Visual Basic] Overloads Public Sub New(String, DataColumn, DataColumn, Boolean)
[C#] public DataRelation(String, DataColumn, DataColumn, bool);
[C++] public: DataRelation(String*, DataColumn, DataColumn, bool);
[JScript] public function DataRelation(String, DataColumn, DataColumn, Boolean);

Initializes a new instance of the DataRelation class using the specified name and matched arrays of parent and child columns.

[Visual Basic] Overloads Public Sub New(String, DataColumn(), DataColumn())
[C#] public DataRelation(String, DataColumn[], DataColumn[]);
[C++] public: DataRelation(String*, DataColumn[], DataColumn[]);
[JScript] public function DataRelation(String, DataColumn[], DataColumn[]);

Initializes a new instance of the DataRelation class using the specified name, matched arrays of parent and child columns, and value to create constraints.

[Visual Basic] Overloads Public Sub New(String, DataColumn(), DataColumn(), Boolean)
[C#] public DataRelation(String, DataColumn[], DataColumn[], bool);
[C++] public: DataRelation(String*, DataColumn[], DataColumn[], bool);
[JScript] public function DataRelation(String, DataColumn[], DataColumn[], Boolean);

Example [Visual Basic]

The following example creates a new DataRelation and adds it to a DataSet object's RelationsCollection.

Note This example shows how to use one of the overloaded version of the DataRelation constructor. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub CreateRelation()
   ' Get the DataColumn objects from two DataTable objects in a DataSet.
   Dim parentCols() As DataColumn
   Dim childCols() As DataColumn
   ' Code to get the DataSet not shown here.
   Set parentCols(0) = DataSet1.Tables("Customers").Columns("CustID")
   Set parentCols(1) = DataSet1.Tables("Customers").Columns("OrdID")

   Set childCols(0) = DataSet1.Tables("Orders").Columns("CustID")
   Set childCols(1) = DataSet1.Tables("Orders").Columns("OrdID")

   Dim bConstraints As Boolean
   bConstraints = True
   ' Create DataRelation.
   Dim relCustOrder As DataRelation
   Set CustOrderRel = New DataRelation("CustomersOrders", parentCols, childCols, bConstraints)
   ' Add the relation to the DataSet.
   DataSet1.Relations.Add(CustOrderRel)
End Sub

See Also

DataRelation Class | DataRelation Members | System.Data Namespace


DataRelation Constructor (String, DataColumn, DataColumn)

Initializes a new instance of the DataRelation class using the specified name, parent, and child columns.

[Visual Basic]
Overloads Public Sub New( _
   ByVal relationName As String, _
   ByVal parentColumn As DataColumn, _
   ByVal childColumn As DataColumn _
)
[C#]
public DataRelation(
   string relationName,
   DataColumn parentColumn,
   DataColumn childColumn
);
[C++]
public: DataRelation(
   String* relationName,
   DataColumn* parentColumn,
   DataColumn* childColumn
);
[JScript]
public function DataRelation(
   relationName : String,
   parentColumn : DataColumn,
   childColumn : DataColumn
);

Parameters

relationName
The name of the relation. If a null reference (in Visual Basic Nothing) or an empty string (""), a default name will be given when the created object is added to the RelationsCollection.
parentColumn
The parent DataColumn in the relation.
childColumn
The child DataColumn in the relation.

Exceptions

Exception Type | Condition
ArgumentNullException | Either one or both of the DataColumns is a a null reference (Nothing).
InvalidConstraintException | The columns have differing data types -Or- The tables don't belong to the same DataSet.

Example [Visual Basic]

The following example creates a new DataRelation and adds it to a DataSet object's RelationsCollection.

[Visual Basic]

Private Sub CreateRelation()
   ' Get the DataColumn objects from two DataTable objects in a DataSet.
   Dim parentCol As DataColumn
   Dim childCol As DataColumn
   ' Code to get the DataSet not shown here.
   parentCol = DataSet1.Tables("Customers").Columns("CustID")
   childCol = DataSet1.Tables("Orders").Columns("CustID")
   ' Create DataRelation.
   Dim relCustOrder As DataRelation
   CustOrderRel = New DataRelation("CustomersOrders", parentCol, childCol)
   ' Add the relation to the DataSet.
   DataSet1.Relations.Add(CustOrderRel)
End Sub

See Also

DataRelation Class | DataRelation Members | System.Data Namespace | DataRelation Constructor Overload List | DataColumn | RelationName


DataRelation Constructor (String, DataColumn, DataColumn, Boolean)

Initializes a new instance of the DataRelation class using the specified name, parent, and child columns, and value to create constraints.

[Visual Basic]
Overloads Public Sub New( _
   ByVal relationName As String, _
   ByVal parentColumn As DataColumn, _
   ByVal childColumn As DataColumn, _
   ByVal createConstraints As Boolean _
)
[C#]
public DataRelation(
   string relationName,
   DataColumn parentColumn,
   DataColumn childColumn,
   bool createConstraints
);
[C++]
public: DataRelation(
   String* relationName,
   DataColumn* parentColumn,
   DataColumn* childColumn,
   bool createConstraints
);
[JScript]
public function DataRelation(
   relationName : String,
   parentColumn : DataColumn,
   childColumn : DataColumn,
   createConstraints : Boolean
);

Parameters

relationName
The name of the relation. If a null reference (in Visual Basic Nothing) or an empty string (""), a default name will be given when the created object is added to the RelationsCollection.
parentColumn
The parent DataColumn in the relation.
childColumn
The child DataColumn in the relation.
createConstraints
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentNullException | Either one or both of the DataColumns is a a null reference (Nothing).
InvalidConstraintException | The columns have differing data types -Or- The tables don't belong to the same DataSet.

Example [Visual Basic]

The following example creates a new DataRelation and adds it to a DataSet object's RelationsCollection.

[Visual Basic]

Private Sub CreateRelation()
   ' Get the DataColumn objects from two DataTable objects in a DataSet.
   Dim parentCol As DataColumn
   Dim childCol As DataColumn
   ' Code to get the DataSet not shown here.
   parentCol = DataSet1.Tables("Customers").Columns("CustID")
   childCol = DataSet1.Tables("Orders").Columns("CustID")
   Dim bConstraints As Boolean
   bConstraints = True
   ' Create DataRelation.
   Dim relCustOrder As DataRelation
   CustOrderRel = New DataRelation("CustomersOrders", parentCol, childCol, bConstraints)
   ' Add the relation to the DataSet.
   DataSet1.Relations.Add(CustOrderRel)
End Sub

See Also

DataRelation Class | DataRelation Members | System.Data Namespace | DataRelation Constructor Overload List | DataColumn | ForeignKeyConstraint | RelationName


DataRelation Constructor (String, DataColumn[], DataColumn[])

Initializes a new instance of the DataRelation class using the specified name and matched arrays of parent and child columns.

[Visual Basic]
Overloads Public Sub New( _
   ByVal relationName As String, _
   ByVal parentColumns() As DataColumn, _
   ByVal childColumns() As DataColumn _
)
[C#]
public DataRelation(
   string relationName,
   DataColumn[] parentColumns,
   DataColumn[] childColumns
);
[C++]
public: DataRelation(
   String* relationName,
   DataColumn* parentColumns[],
   DataColumn* childColumns[]
);
[JScript]
public function DataRelation(
   relationName : String,
   parentColumns : DataColumn[],
   childColumns : DataColumn[]
);

Parameters

relationName
The name of the relation. If a null reference (in Visual Basic Nothing) or an empty string (""), a default name will be given when the created object is added to the RelationsCollection.
parentColumns
An array of parent DataColumn objects.
childColumns
An array of child DataColumn objects.

Exceptions

Exception Type | Condition
ArgumentNullException | Either one or both of the DataColumns is a a null reference (Nothing).
InvalidConstraintException | The columns have differing data types -Or- One or both of the arrays are not composed of distinct columns from the same table. -Or- The tables don't belong to the same DataSet

Example [Visual Basic]

The following example creates a new DataRelation and adds it to a DataSet object's RelationsCollection.

[Visual Basic]

Private Sub CreateRelation()
   ' Get the DataColumn objects from two DataTable objects in a DataSet.
   Dim parentCols() As DataColumn
   Dim childCols() As DataColumn
   ' Code to get the DataSet not shown here.
   parentCols(0) = DataSet1.Tables("Customers").Columns("CustID")
   parentCols(1) = DataSet1.Tables("Customers").Columns("OrdID")

   childCols(0) = DataSet1.Tables("Orders").Columns("CustID")
   childCols(1) = DataSet1.Tables("Orders").Columns("OrdID")
   ' Create DataRelation.
   Dim relCustOrder As DataRelation
   CustOrderRel = New DataRelation("CustomersOrders", parentCols, childCols)
   ' Add the relation to the DataSet.
   DataSet1.Relations.Add(CustOrderRel)
End Sub

See Also

DataRelation Class | DataRelation Members | System.Data Namespace | DataRelation Constructor Overload List | DataColumn | ForeignKeyConstraint | RelationName


DataRelation Constructor (String, DataColumn[], DataColumn[], Boolean)

Initializes a new instance of the DataRelation class using the specified name, matched arrays of parent and child columns, and value to create constraints.

[Visual Basic]
Overloads Public Sub New( _
   ByVal relationName As String, _
   ByVal parentColumns() As DataColumn, _
   ByVal childColumns() As DataColumn, _
   ByVal createConstraints As Boolean _
)
[C#]
public DataRelation(
   string relationName,
   DataColumn[] parentColumns,
   DataColumn[] childColumns,
   bool createConstraints
);
[C++]
public: DataRelation(
   String* relationName,
   DataColumn* parentColumns[],
   DataColumn* childColumns[],
   bool createConstraints
);
[JScript]
public function DataRelation(
   relationName : String,
   parentColumns : DataColumn[],
   childColumns : DataColumn[],
   createConstraints : Boolean
);

Parameters

relationName
The name of the relation. If a null reference (in Visual Basic Nothing) or an empty string (""), a default name will be given when the created object is added to the RelationsCollection.
parentColumns
An array of parent DataColumn objects.
childColumns
An array of child DataColumn objects.
createConstraints
A value indicating whether constraints are created. true, if constraints are created, otherwise, false.

Exceptions

Exception Type | Condition
ArgumentNullException | Either one or both of the DataColumn objects is a null reference (Nothing).
InvalidConstraintException | The columns have differing data types -Or- The tables don't belong to the same DataSet.

Example [Visual Basic]

The following example creates a new DataRelation and adds it to a DataSet object's RelationsCollection.

[Visual Basic]

Private Sub CreateRelation()
   ' Get the DataColumn objects from two DataTable objects in a DataSet.
   Dim parentCols() As DataColumn
   Dim childCols() As DataColumn
   ' Code to get the DataSet not shown here.
   Set parentCols(0) = DataSet1.Tables("Customers").Columns("CustID")
   Set parentCols(1) = DataSet1.Tables("Customers").Columns("OrdID")

   Set childCols(0) = DataSet1.Tables("Orders").Columns("CustID")
   Set childCols(1) = DataSet1.Tables("Orders").Columns("OrdID")

   Dim bConstraints As Boolean
   bConstraints = True
   ' Create DataRelation.
   Dim relCustOrder As DataRelation
   Set CustOrderRel = New DataRelation("CustomersOrders", parentCols, childCols, bConstraints)
   ' Add the relation to the DataSet.
   DataSet1.Relations.Add(CustOrderRel)
End Sub

See Also

DataRelation Class | DataRelation Members | System.Data Namespace | DataRelation Constructor Overload List | DataColumn | ForeignKeyConstraint | RelationName


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataRelation Properties

The properties of the DataRelation class are listed below. For a complete list of DataRelation class members, see the DataRelation Members topic.

Public:

ChildColumns | Gets the child columns of this relation.
ChildKeyConstraint | Gets the ForeignKeyConstraint for the relation.
ChildTable | Gets the child table of this relation.
DataSet | Gets the DataSet to which the relations' collection belongs to.
Nested | Gets or sets a value indicating whether relations are nested.
ParentColumns | Gets the parent columns of this relation.
ParentKeyConstraint | Gets the constraint which ensures values in a column are unique.
ParentTable | Gets the parent table of this relation.
RelationName | Gets or sets the name used to look up this relation in the parent data set's RelationsCollection.

See Also

DataRelation Class | System.Data Namespace


DataRelation.ChildColumns

Gets the child columns of this relation.

[Visual Basic]
Overridable Public ReadOnly Property ChildColumns As DataColumn ()
[C#]
public DataColumn[] ChildColumns {virtual get;}
[C++]
public: __property virtual DataColumn* get_ChildColumns();
[JScript]
public function get ChildColumns() : DataColumn[];

Property Value

An array of DataColumn objects.

Example [Visual Basic]

The following example gets the child columns or a DataRelation.

[Visual Basic]

Private Sub GetChildCols()
   Dim ChildArr() As DataColumn
   ' Get the DataRelation of a DataSet.
   Dim dr As DataRelation
   dr = DataSet1.Relations("CustomerOrders")
   ' Get the child columns.
   ChildArr = dr.ChildColumns
   ' Print the ColumnName of each column.
   Dim i As Integer
   For i = 0 to Ubound(ChildArr)
      Debug.Print ChildArr(i).ColumnName
   Next i
End Sub

See Also

DataRelation Class | DataRelation Members | System.Data Namespace | DataColumn | ParentColumns


DataRelation.ChildKeyConstraint

Gets the ForeignKeyConstraint for the relation.

[Visual Basic]
Overridable Public ReadOnly Property ChildKeyConstraint As _
   ForeignKeyConstraint
[C#]
public ForeignKeyConstraint ChildKeyConstraint {virtual get;}
[C++]
public: __property virtual ForeignKeyConstraint*
   get_ChildKeyConstraint();
[JScript]
public function get ChildKeyConstraint() : ForeignKeyConstraint;

Property Value

A ForeignKeyConstraint.

Example [Visual Basic]

The following example create a new ForeignKeyConstraint and assigns it to the ChildKeyConstraint property.

[Visual Basic]

Private Sub SetChildKeyConstraint()
   Dim dr As DataRelation
   Dim cCol As DataColumn
   Dim pCol As DataColumn
   ' Set child and parent columns.
   pCol = DataSet1.Tables("Suppliers").Columns("SupplierID")
   cCol = DataSet1.Tables("Products").Columns("SupplierID")
   dr = New DataRelation("SuppliersConstraint", pCol, cCol)
   ' Create ForeignKeyConstraint using the function below.
   Dim fk As ForeignKeyConstraint
   fk = CreateConstraint(pCol, cCol)
   ' Assign the constraint to the ChildKeyConstraint property
   dr.ChildKeyConstraint = fk
End Sub

Private Function CreateConstraint(pCol As DataColumn, cCol As DataColumn) _
   As ForeignKeyConstraint

   Dim myFKC As ForeignKeyConstraint
   myFKC = New ForeignKeyConstraint(pCol, cCol)
   ' Set null values when a value is deleted.
   myFKC.DeleteRule = Rule.SetNull
   myFKC.UpdateRule = Rule.Cascade
   myFKC.AcceptRejectRule = AcceptRejectRule.Cascade
   CreateConstraint = myFKC
End Function

See Also

DataRelation Class | DataRelation Members | System.Data Namespace | AcceptRejectRule | ParentKeyConstraint | Rule


DataRelation.ChildTable

Gets the child table of this relation.

[Visual Basic]
Overridable Public ReadOnly Property ChildTable As DataTable
[C#]
public DataTable ChildTable {virtual get;}
[C++]
public: __property virtual DataTable* get_ChildTable();
[JScript]
public function get ChildTable() : DataTable;

Property Value

A DataTable that is the child table of the relation.

Example [Visual Basic]

The following example gets the child DataTable of a DataRelation.

[Visual Basic]

Private Sub GetChildTable()
   Dim t As DataTable
   Dim dr As DataRelation
   ' Get a DataRelation of a DataSet.
   dr = DataSet1.Relations("CustomerOrders")
   ' Get the child DataTable of the relation.
   t = dr.ChildTable
   ' Print the name and number of rows of the child table.
   Debug.Print t.TableName, t.Rows.Count
End Sub

See Also

DataRelation Class | DataRelation Members | System.Data Namespace | DataTable | ParentTable


DataRelation.DataSet

Gets the DataSet to which the relations' collection belongs to.

[Visual Basic]
Overridable Public ReadOnly Property DataSet As DataSet
[C#]
public DataSet DataSet {virtual get;}
[C++]
public: __property virtual DataSet* get_DataSet();
[JScript]
public function get DataSet() : DataSet;

Property Value

A DataSet to which the RelationsCollection belongs.

Remarks

The RelationsCollection that belongs to a DataSet is accessed through the Relations property.

Example [Visual Basic]

The following example gets the DataSet of a DataRelation.

[Visual Basic]

Private Sub GetRelDataSet(myRelation As DataRelation)
   ' Get the DataSet of the passed in DataRelation.
   ds As DataSet
   ds = myRelation.DataSet
   ' Print the table names of each table in the DataSet.
   Dim t As DataTable
   For Each t In ds.Tables
       Debug.Print t.TableName
   Next
End Sub

See Also

DataRelation Class | DataRelation Members | System.Data Namespace | DataSet | Relations | RelationsCollection


DataRelation.Nested

Gets or sets a value indicating whether relations are nested.

[Visual Basic]
Overridable Public Property Nested As Boolean
[C#]
public bool Nested {virtual get; virtual set;}
[C++]
public: __property virtual bool get_Nested();
public: __property virtual void set_Nested(bool);
[JScript]
public function get Nested() : Boolean;
public function set Nested(Boolean);

Property Value

true, if relations are nested; otherwise, false.

See Also

DataRelation Class | DataRelation Members | System.Data Namespace


DataRelation.ParentColumns

Gets the parent columns of this relation.

[Visual Basic]
Overridable Public ReadOnly Property ParentColumns As DataColumn ()
[C#]
public DataColumn[] ParentColumns {virtual get;}
[C++]
public: __property virtual DataColumn* get_ParentColumns();
[JScript]
public function get ParentColumns() : DataColumn[];

Property Value

An array of DataColumn objects.

Example [Visual Basic]

The following example gets the array of DataColumn objects that function as parent columns for the relation.

[Visual Basic]

Private Sub GetChildCols()
   Dim ParentArr() As DataColumn
   ' Get the DataRelation of a DataSet.
   Dim dr As DataRelation
   dr = DataSet1.Relations("CustomerOrders")
   ' Get the child columns.
   ParentArr= dr.ParentColumns
   ' Print the ColumnName of each column.
   Dim i As Integer
   For i = 0 to Ubound(ParentArr)
      Debug.Print ParentArr(i).ColumnName
   Next i
End Sub

See Also

DataRelation Class | DataRelation Members | System.Data Namespace | DataColumn | ChildColumns


DataRelation.ParentKeyConstraint

Gets the constraint which ensures values in a column are unique.

[Visual Basic]
Overridable Public ReadOnly Property ParentKeyConstraint As _
   UniqueConstraint
[C#]
public UniqueConstraint ParentKeyConstraint {virtual get;}
[C++]
public: __property virtual UniqueConstraint*
   get_ParentKeyConstraint();
[JScript]
public function get ParentKeyConstraint() : UniqueConstraint;

Property Value

A UniqueConstraint.

Example [Visual Basic]

The following example gets the ParentKeyConstraint of a DataRelation object.

[Visual Basic]

Private Sub GetParentKeyConstraint()
   Dim pkCstrt As UniqueConstraint
   ' Get a DataRelation from a DataSet.
   Dim rel As DataRelation
   rel = DataSet1.Relations("CustomerOrders")
   ' Get the relations parent key constraint.
   pkCstrt = rel.ParentKeyConstraint
   ' Get the constraint's DataColumns
   Dim cstrtCols() As DataColumn
   cstrtCols = pkCstrt.Columns
   ' Print the column names.
   Dim i As Integer
   For i = 0 to Ubound(cstrtCols)
      Debug.Print cstrtCols(i).ColumnName
   Next i
End Sub

See Also

DataRelation Class | DataRelation Members | System.Data Namespace | ChildKeyConstraint | UniqueConstraint


DataRelation.ParentTable

Gets the parent table of this relation.

[Visual Basic]
Overridable Public ReadOnly Property ParentTable As DataTable
[C#]
public DataTable ParentTable {virtual get;}
[C++]
public: __property virtual DataTable* get_ParentTable();
[JScript]
public function get ParentTable() : DataTable;

Property Value

A DataTable that is the parent table of this relation.

Example [Visual Basic]

The following example gets the parent DataTable of a DataRelation.

[Visual Basic]

Private Sub GetParentTable()
   Dim t As DataTable
   Dim r As DataRelation
   ' Get a DataRelation of a DataSet.
   r = DataSet1.Relations("CustomerOrders")
   ' Get the parent DataTable of the relation.
   t = r.ParentTable
   ' Print the name and number of rows of the parent table.
   Debug.Print t.TableName
   Debug.Print t.Rows.Count
End Sub

See Also

DataRelation Class | DataRelation Members | System.Data Namespace | DataTable | ChildTable


DataRelation.RelationName

Gets or sets the name used to look up this relation in the parent data set's RelationsCollection.

[Visual Basic]
Overridable Public Property RelationName As String
[C#]
public string RelationName {virtual get; virtual set;}
[C++]
public: __property virtual String* get_RelationName();
public: __property virtual void set_RelationName(String*);
[JScript]
public function get RelationName() : String;
public function set RelationName(String);

Property Value

The name of the relation.

Exceptions

Exception Type | Condition
ArgumentException | A null or empty string ("") was passed in and the relation belongs to a collection.
DuplicateNameException | The relation belongs to a collection that contains a relation of the same name. The string comparison is not case-sensitive.

Remarks

The RelationName is used to look up this relation in the parent DataSet object's RelationsCollection.

Example [Visual Basic]

The following example retrieves a named relation from a RelationsCollection.

[Visual Basic]

Private Sub GetRelation()
   Dim dRels As RelationsCollection
   ' Get the collection of a DataSet
   dRels = DataSet1.Relations
   ' Add a relation named CustomerOrders
   Dim myRel As DataRelation
   myRel = dRels("CustomerOrders")
   ' Just to make sure, print the RelationName.
   Debugl.Print myRel.RelationName

End Sub

See Also

DataRelation Class | DataRelation Members | System.Data Namespace | DataSet | RelationsCollection | Item


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataRelation Methods

The methods of the DataRelation class are listed below. For a complete list of DataRelation class members, see the DataRelation Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SetParentRow | Sets the parent row for the child row across this relation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

CheckStateForProperty | Checks to ensure the DataRelation is a valid object, even if it doesn't belong to a DataSet.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanged | Raises the OnPropertyChanged event.
RaisePropertyChanged | Raises the OnPropertyChanged event.

Event Hookup:

AddOnPropertyChanged | Adds an event handler for the OnPropertyChanged event.
RemoveOnPropertyChanged | Removes an event handler that has been associated with the OnPropertyChanged event.

See Also

DataRelation Class | System.Data Namespace


DataRelation.AddOnPropertyChanged

Adds an event handler for the OnPropertyChanged event.

[Visual Basic]
Public Sub AddOnPropertyChanged( _
   ByVal handler As PropertyChangedEventHandler _
)
[C#]
public void AddOnPropertyChanged(
   PropertyChangedEventHandler handler
);
[C++]
public: void AddOnPropertyChanged(
   PropertyChangedEventHandler* handler
);
[JScript]
public function AddOnPropertyChanged(
   handler : PropertyChangedEventHandler
);

Parameters

handler
A PropertyChangedEventHandler delegate that represents the method that will handle the OnPropertyChanged event.

See Also

DataRelation Class | DataRelation Members | System.Data Namespace | RemoveOnPropertyChanged


DataRelation.CheckStateForProperty

Checks to ensure the DataRelation is a valid object, even if it doesn't belong to a DataSet.

[Visual Basic]
Protected Sub CheckStateForProperty()
[C#]
protected void CheckStateForProperty();
[C++]
protected: void CheckStateForProperty();
[JScript]
protected function CheckStateForProperty();

Exceptions

Exception Type | Condition
DataException.RelationDataSetMismatch | The parent table and the child table belong to different DataSet objects.
DataException.ColumnsTypeMismatch | One or more pairs of parent and child columns have mismatched data types.
DataException.KeyColumnsIdentical | The parent column and the child column are identical.

Remarks

Exceptions are thrown if the DataRelation is not valid.

See Also

DataRelation Class | DataRelation Members | System.Data Namespace


DataRelation.OnPropertyChanged

Raises the OnPropertyChanged event.

[Visual Basic]
Overridable Protected Sub OnPropertyChanged( _
   ByVal pcevent As PropertyChangedEventArgs _
)
[C#]
protected virtual void OnPropertyChanged(
   PropertyChangedEventArgs pcevent
);
[C++]
protected: virtual void OnPropertyChanged(
   PropertyChangedEventArgs* pcevent
);
[JScript]
protected function OnPropertyChanged(
   pcevent : PropertyChangedEventArgs
);

Parameters

pcevent
A PropertyChangedEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see TBD.

Notes to Inheritors: When overriding OnPropertyChanged in a derived class, be sure to call the base class's OnPropertyChanged method.

See Also

DataRelation Class | DataRelation Members | System.Data Namespace | AddOnPropertyChanged | RemoveOnPropertyChanged


DataRelation.RaisePropertyChanged

Raises the OnPropertyChanged event.

[Visual Basic]
Protected Sub RaisePropertyChanged( _
   ByVal name As String _
)
[C#]
protected void RaisePropertyChanged(
   string name
);
[C++]
protected: void RaisePropertyChanged(
   String* name
);
[JScript]
protected function RaisePropertyChanged(
   name : String
);

Parameters

name
The name of the changed property.

Remarks

This creates the needed event data and then calls OnPropertyChanged.

See Also

DataRelation Class | DataRelation Members | System.Data Namespace


DataRelation.RemoveOnPropertyChanged

Removes an event handler that has been associated with the OnPropertyChanged event.

[Visual Basic]
Public Sub RemoveOnPropertyChanged( _
   ByVal handler As PropertyChangedEventHandler _
)
[C#]
public void RemoveOnPropertyChanged(
   PropertyChangedEventHandler handler
);
[C++]
public: void RemoveOnPropertyChanged(
   PropertyChangedEventHandler* handler
);
[JScript]
public function RemoveOnPropertyChanged(
   handler : PropertyChangedEventHandler
);

Parameters

handler
The PropertyChangedEventHandler delegate to remove.

See Also

DataRelation Class | DataRelation Members | System.Data Namespace | AddOnPropertyChanged


DataRelation.SetParentRow

Sets the parent row for the child row across this relation.

[Visual Basic]
Public Sub SetParentRow( _
   ByVal childRow As DataRow, _
   ByVal parentRow As DataRow _
)
[C#]
public void SetParentRow(
   DataRow childRow,
   DataRow parentRow
);
[C++]
public: void SetParentRow(
   DataRow* childRow,
   DataRow* parentRow
);
[JScript]
public function SetParentRow(
   childRow : DataRow,
   parentRow : DataRow
);

Parameters

childRow
The child DataRow to use.
parentRow
The new parent DataRow.

Exceptions

Exception Type | Condition
RowNotInTableException | One of the rows doesn't belong to a table
ArgumentNullException | One of the rows is a null reference (in Visual Basic Nothing).
ArgumentException | The relation doesn't belong to the DataSet object's RelationsCollection.
InvalidConstraintException | The relation's child DataTable isn't the table this row belongs to.

Remarks

[Need explanation of why we do this.]

Example [Visual Basic]

The following example sets the parent row of a given child row.

[Visual Basic]

Private Sub SetParent()
   Dim childRow As DataRow
   Dim parentRow As DataRow
   ' Get a ParentRow and a ChildRow from a DataSet.
   childRow = DataSet1.Tables("Orders").Rows(1)
   parentRow = DataSet1.Tables("Customers").Rows(20)
   ' Set the parent row of a DataRelation.
   DataSet1.Relations("CustomerOrders").SetParentRow(childRow, parentRow)
End Sub

See Also

DataRelation Class | DataRelation Members | System.Data Namespace


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataRelation Events

The events of the DataRelation class are listed below. For a complete list of DataRelation class members, see the DataRelation Members topic.

Public:

PropertyChanged Occurs whenever a property value of the DataRelation changes.

See Also

DataRelation Class | System.Data Namespace


DataRelation PropertyChanged Event

Occurs whenever a property value of the DataRelation changes.

The following declaration shows the syntax for a method that handles the PropertyChanged event.

[Visual Basic]
Private Sub DataRelationName_PropertyChanged( _
   ByVal sender As Object, _
   ByVal e As PropertyChangedEventArgs _
)
[C#]
private void DataRelationName_PropertyChanged(
   object sender,
   PropertyChangedEventArgs e
);
[C++]
private: void DataRelationName_PropertyChanged(
   Object* sender,
   PropertyChangedEventArgs* e
);
[JScript]
private DataRelationName_PropertyChanged(
   sender : Object,
   e : PropertyChangedEventArgs
);

Parameters

sender
The source of the event.
e
A PropertyChangedEventArgs that contains the event data. The following PropertyChangedEventArgs properties provide information specific to this event.
Property Description
PropertyName
Gets the name of the property that changed.

See Also

DataRelation Class | DataRelation MembersTopic | System.Data Namespace


DataRow Class

Represents a row of data in a DataTable.

Object
DataRow

[Visual Basic]
Public Class DataRow
[C#]
public class DataRow
[C++]
public __gc class DataRow
[JScript]
public class DataRow

Remarks

The DataRow, along with the DataColumn, is a primary component of a DataTable. Whereas a collection of DataColumn objects describes the schema of a table, the DataRow collection represents the actual data contained in the table. Use the DataRow class and its properties and methods to retrieve, evaluate, and manipulate the values in the table.

The overloaded Item property (DataRow indexer) returns or sets the value of any specified column.

Properties such as HasVersion and IsNull allow you to determine the status of a particular column. Additionally, the RowState property describes the state of the row in its relationship to its parent DataTable.

To create a new DataRow, use the DataTable class's NewRow method. That method uses the schema of the table, as determined by the RowsCollection, to create a new DataRow. After creating a new row, use the RowsCollection class's Add method to add the new object to the collection. Finally, call the DataTable class's AcceptChanges method to substantiate the addition.

Requirements

Namespace: System.Data

Assembly: System.Data.dll

Example [Visual Basic]

The following example creates a new DataRow through the DataTable object's NewRow method.

[Visual Basic]

Private Sub CreateNewDataRow()
   ' Use the MakeTable function below to create a new table.
   Dim myTable As DataTable
   myTable = MakeTable()
   ' Once a table has been created, use the NewRow to create a DataRow.
   Dim myRow As DataRow
   myRow = myTable.NewRow
   ' Then add the new row to the collection.
   myTable.Rows.Add(myRow)
   ' Accept Changes on the Table.
   myTable.AcceptChanges
End Sub

Private Function MakeNamesTable() As DataTable
   Dim t As DataTable
   t = New DataTable
   Dim c As DataColumn
   c = New DataColumn
   c.DataType = System.Type.GetType("System.Int32")
   c.ColumnName = "id"
   c.AutoIncrement = True
   t.Columns.Add c
   c = New DataColumn
   c.DataType = System.Type.GetType("System.String")
   c.ColumnName = "Fname"
   c.DefaultValue = "Fname"
   t.Columns.Add(c)
   c = New DataColumn
   c.DataType = System.Type.GetType("System.String")
   c.ColumnName = "LName"
   t.Columns.Add(c)
   Dim keys(0) As DataColumn
   keys(0) = t.Columns(0)
   t.PrimaryKey = keys
   ' Return Table
   MakeNamesTable = t
End Function

See Also

DataRow Members | System.Data Namespace | AcceptChanges | Add | ColumnsCollection | DataColumn | DataRowView | DataTable | HasVersion | IsNull | Item | NewRow | RowsCollection


DataRow Members

Public:

Properties

HasErrors | Gets a value indicating whether there are errors in a columns collection.
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the DataRow class.
ItemArray | Gets or sets all of the values for this row through an array.
RowError | Gets or sets the custom error description for a row.
RowState | Gets the current state of the row in regards to its relationship to the table.
Table | Gets the DataTable for which this row has a schema.

Methods

AcceptChanges | Commits all the changes made to this row since the last time AcceptChanges was called.
BeginEdit | Begins an edit operation on a DataRow object.
CancelEdit | Cancels the current edit on the row.
ClearErrors | Clears the errors for the row.
Delete | Deletes the row.
EndEdit | Ends the edit occurring on the row.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetChildRows | Overloaded. Gets the child rows of this DataRow using the specified DataRelation.
GetColumnError | Overloaded. Gets the error description for a column.
GetColumnsInError | Gets an array of columns that have errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParentRow | Overloaded. Gets the parent row of this DataRow using the specified DataRelation.
GetParentRows | Overloaded. Gets the parent rows of this DataRow using the specified DataRelation.
GetType (inherited from Object) | Gets the Type of the Object.
HasVersion | Gets a value indicating whether a specified version exists.
IsNull | Overloaded. Gets a value indicating whether the specified column contains a null value.
RejectChanges | Rejects all changes made to the row since AcceptChanges was last called.
SetColumnError | Overloaded. Sets the error description for a column.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetNull | Sets the specified column's value to a null value.

See Also

DataRow Class | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataRow Properties

The properties of the DataRow class are listed below. For a complete list of DataRow class members, see the DataRow Members topic.

Public:

HasErrors | Gets a value indicating whether there are errors in a columns collection.
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the DataRow class.
ItemArray | Gets or sets all of the values for this row through an array.
RowError | Gets or sets the custom error description for a row.
RowState | Gets the current state of the row in regards to its relationship to the table.
Table | Gets the DataTable for which this row has a schema.

See Also

DataRow Class | System.Data Namespace


DataRow.HasErrors

Gets a value indicating whether there are errors in a columns collection.

[Visual Basic]
Public ReadOnly Property HasErrors As Boolean
[C#]
public bool HasErrors {get;}
[C++]
public: __property bool get_HasErrors();
[JScript]
public function get HasErrors() : Boolean;

Property Value

true if any column in the collection contains an error; otherwise, false.

Remarks

Use SetColumnError and GetColumnError to set and return errors for individual columns.

The ClearErrors method clears all errors for the columns collection.

Example [Visual Basic]

The following example uses the HasErrors and ClearError methods to clear all errors of a DataRow object found in a System.WinForms.DataGrid control's DataTable.

[Visual Basic]

Private Sub PrintAllErrs()
   Dim rowsInError() As DataRow
   Dim t As DataTable
   Dim ds As DataSet
   Dim i As Integer
   Dim c As DataColumn
   ds = DataSet1

   For Each t in ds.Tables
      ' Test if the table has errors. If not, skip it.
      If t.HasErrors Then
         ' Get an array of all rows with errors.
         rowsInError = t.GetErrors
         ' Print the error of each column in each row.
For i = 0 To UBound(rowsInError)
   For Each c In t.Columns
      Console.WriteLine(c.ColumnName, rowsInError(i).GetColumnError(c))
   Next c
   ' Clear the row errors
   rowsInError(i).ClearErrors
Next i
      End If
   Next t
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace | ClearErrors | ColumnsCollection | GetColumnError | GetColumnsInError | SetColumnError


DataRow.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the DataRow class.

Overload List

Gets the data stored at the column, specified by index and version of the data to retrieve.

[Visual Basic] Overloads Public Default ReadOnly Property Item(Integer, DataRowVersion) As Object
[C#] public object this[int, DataRowVersion] {get;}
[C++] public: __property Object* get_Item(int, DataRowVersion);
[JScript] DataRow.Item (int, DataRowVersion)

Gets or sets the data stored at the DataColumn for this row.

[Visual Basic] Overloads Public Default Property Item(DataColumn) As Object
[C#] public object this[DataColumn] {get; set;}
[C++] public: __property Object* get_Item(DataColumn*);
public: __property void set_Item(DataColumn*, Object*);
[JScript] DataRow.Item (DataColumn)

Gets the data stored at the column; the column is specified by passing a DataColumn to the property. Additionally, you can specify which version of the data to retrieve.

[Visual Basic] Overloads Public Default ReadOnly Property Item(DataColumn, DataRowVersion) As Object
[C#] public object this[DataColumn, DataRowVersion] {get;}
[C++] public: __property Object* get_Item(DataColumn*, DataRowVersion);
[JScript] DataRow.Item (DataColumn, DataRowVersion)

Gets the data stored at the column; the column is specified by name. Additionally, you can specify which version of the data to retrieve.

[Visual Basic] Overloads Public Default ReadOnly Property Item(String, DataRowVersion) As Object
[C#] public object this[String, DataRowVersion] {get;}
[C++] public: __property Object* get_Item(String*, DataRowVersion);
[JScript] DataRow.Item (String, DataRowVersion)

Gets or sets the data stored at the specified column index.

[Visual Basic] Overloads Public Default Property Item(Integer) As Object
[C#] public object this[int] {get; set;}
[C++] public: __property Object* get_Item(int);
public: __property void set_Item(int, Object*);
[JScript] DataRow.Item (int)

Gets or sets the data stored at the named column.

[Visual Basic] Overloads Public Default Property Item(String) As Object
[C#] public object this[String] {get; set;}
[C++] public: __property Object* get_Item(String*);
public: __property void set_Item(String*, Object*);
[JScript] DataRow.Item (String)

Example [Visual Basic]

The following examples demonstrate the use of the Item property (DataRow indexer) to get and set the value of a given column index. The first example gets the value of the first column in any row that a user clicks in a System.WinForms.DataGrid control. The second sets a value passed as an argument to the method.

Note This example shows how to use one of the overloaded versions of the Item property (DataRow indexer). For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub DataGrid1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
   Dim currRow As DataRow
   ' Set the current row using the RowNumber property of the CurrentCell.
   currRow = DataGrid1.DataGridTable.DataTable. _
      Rows(DataGrid1.CurrentCell.RowNumber)
   ' Get the value of the column 1 in the DataTable.
   label1.Text = CurrRow("FirstName")
End Sub
Private Sub SetDataRowValue(ByVal myGrid As DataGrid, ByVal newVal As Object)
   ' Set the value of a column in the last row of a DataGrid.
   Dim t As DataTable
   t = mygrid.DataGridTable.DataTable
   Dim myRow As DataRow
   myRow = t.Rows(t.Rows.Count - 1)
   myRow("FirstName") = newVal
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace


DataRow.Item (Int32, DataRowVersion)

Gets the data stored at the column, specified by index and version of the data to retrieve.

[C#] In C#, this member is the indexer for the DataRow class.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
   ByVal columnIndex As Integer, _
   ByVal version As DataRowVersion _
) As Object
[C#]
public object this[
   int columnIndex,
   DataRowVersion version
] {get;}
[C++]
public: __property Object* get_Item(
   int columnIndex,
   DataRowVersion version
);
[JScript]
returnValue = DataRowObject.Item(columnIndex, version);
-or-
returnValue = DataRowObject(columnIndex, version);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

columnIndex
The zero-based index of the column.
version
One of the DataRowVersion values that specifies the desired row version. Possible values are Default, Original, Current, and Proposed.

Parameters [Visual Basic, C#, C++]

columnIndex
The zero-based index of the column.
version
One of the DataRowVersion values that specifies the desired row version. Possible values are Default, Original, Current, and Proposed.

Property Value

An Object that contains the data.

Exceptions

Exception Type | Condition
VersionNotFoundException | The row doesn't have this version of data.
IndexOutOfRangeException | The columnIndex argument is out of range.
InvalidCastException | The data types of the value and the column don't match.
DeletedRowInaccessibleException | An attempt was made to set a value on a deleted row.

Remarks

You can only create or update a row after calling the BeginEdit method; similarly, the EndEdit method must be called to commit the edit. After calling the EndEdit method, and before calling the AcceptChanges method, internal representations of the original and new proposed values are stored. Therefore, until you call the AcceptChanges, you can use the version argument to specify which version of a column's value you need, either the DataRowVersion.Original or DataRowVersion.Proposed. Once you call the AcceptChanges method, however, the version of the column reverts to DataRowVersion.Original. If the row is new, you can also pass DataRowVersion.Default for the parameter to retrieve the column's default value. When passing DataRowVersion.Current, the property will return the current value, whatever its version may be.

Note The BeginEdit method is called implicitly when you change the value of a databound control or when a DataRow object is added to the RowsCollection; the EndEdit method is called implicitly when calling the following methods: the DataRow object's AcceptChanges method, the DataTable object's AcceptChanges method, or the CancelEdit method.

By contrast, the DataRowVersion enumeration Current returns the version of the data after the EndEdit method has been called.

The version argument shouldn't be confused with the RowState property. The version argument describes the state of the data contained by the column in relation to the column's original value. The RowState property describes the state of the entire row in relation to its parent DataTable.

When setting the property, an exception will be thrown if an exception occurs in the ColumnChanging event.

If this is an immediate edit, see EndEdit for the exceptions that can be thrown.

Example [Visual Basic]

The following example gets the current value of a column through the DataRow object's Item property (DataRow indexer).

[Visual Basic]

Private Sub DataGrid1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
   Dim currRow As DataRow
   ' Set the current row using the RowNumber property of the CurrentCell.
   currRow = DataGrid1.DataGridTable.DataTable. _
      Rows(DataGrid1.CurrentCell.RowNumber)
   ' Get the value of the column 1 in the DataTable.
   label1.Text = CurrRow(1, DataRowVersion.Current)
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace | DataRow.Item Overload List


DataRow.Item (DataColumn)

Gets or sets the data stored at the DataColumn for this row.

[C#] In C#, this member is the indexer for the DataRow class.

[Visual Basic]
Overloads Public Default Property Item( _
   ByVal column As DataColumn _
) As Object
[C#]
public object this[
   DataColumn column
] {get; set;}
[C++]
public: __property Object* get_Item(
   DataColumn* column
);
public: __property void set_Item(
   DataColumn* column,
   Object*
);
[JScript]
returnValue = DataRowObject.Item(column);
DataRowObject.Item(column) = returnValue;
-or-
returnValue = DataRowObject(column);
DataRowObject(column) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

column
A DataColumn that contains the data.

Parameters [Visual Basic, C#, C++]

column
A DataColumn that contains the data.

Property Value

An Object that contains the data.

Exceptions

Exception Type | Condition
ArgumentNullException | The column is null.
ArgumentException | The column doesn't belong to this table.
InvalidCastException | The data types of the value and the column don't match.
DeletedRowInaccessibleException | An attempt was made to set a value on a deleted row.

Remarks

When setting the property, an exception will be thrown if an exception occurs in the ColumnChanging event.

If this is an immediate edit, see EndEdit for the exceptions that can be thrown.

Example [Visual Basic]

The following examples demonstrate the use of the Item property (DataRow indexer) to get and set the value of a given column index. The first example gets the value of the first column in any row that a user clicks in a System.WinForms.DataGrid control. The second sets a value passed as an argument to the method.

[Visual Basic]

Private Sub DataGrid1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
   Dim currRow As DataRow
   ' Set the current row using the RowNumber property of the CurrentCell.
   currRow = DataGrid1.DataGridTable.DataTable. _
      Rows(DataGrid1.CurrentCell.RowNumber)
   Dim myCol As DataColumn
   myCol = DataGrid1.DataGridTable.DataTable.Columns(1)
   ' Get the value of the column 1 in the DataTable.
   label1.Text = CurrRow(myCol)
End Sub
Private Sub SetDataRowValue(ByVal myGrid As DataGrid, ByVal newVal As Object)
   ' Set the value of a column in the last row of a DataGrid.
   Dim t As DataTable
   t = mygrid.DataGridTable.DataTable
   Dim myRow As DataRow
   myRow = t.Rows(t.Rows.Count - 1)
   Dim myCol As DataColumn
   myCol = t.Columns("FirstName")
   myRow(myCol)= newVal
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace | DataRow.Item Overload List


DataRow.Item (DataColumn, DataRowVersion)

Gets the data stored at the column; the column is specified by passing a DataColumn to the property. Additionally, you can specify which version of the data to retrieve.

[C#] In C#, this member is the indexer for the DataRow class.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
   ByVal column As DataColumn, _
   ByVal version As DataRowVersion _
) As Object
[C#]
public object this[
   DataColumn column,
   DataRowVersion version
] {get;}
[C++]
public: __property Object* get_Item(
   DataColumn* column,
   DataRowVersion version
);
[JScript]
returnValue = DataRowObject.Item(column, version);
-or-
returnValue = DataRowObject(column, version);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

column
A DataColumn that contains information about the column.
version
One of the DataRowVersion values that specifies the desired row version. Possible values are Default, Original, Current, and Proposed.

Parameters [Visual Basic, C#, C++]

column
A DataColumn that contains information about the column.
version
One of the DataRowVersion values that specifies the desired row version. Possible values are Default, Original, Current, and Proposed.

Property Value

An Object that contains the data.

Exceptions

Exception Type | Condition
ArgumentNullException | The column argument contains null.
ArgumentException | The column doesn't belong to the table.
VersionNotFoundException | The row doesn't have this version of data.

Remarks

The version shouldn't be confused with the RowState property. The version argument describes the state of the data contained by the column in relation to the column's original value.

When setting the property, an exception will be thrown if an exception occurs in the ColumnChanging event.

If this is an immediate edit, see EndEdit for the exceptions that can be thrown.

Example [Visual Basic]

The following example gets the current value of a clicked cell in the System.WinForms.DataGrid control.

[Visual Basic]

Private Sub DataGrid1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
   Dim currRow As DataRow
   Dim c As DataColumn
   ' Set the current row using the RowNumber property of the CurrentCell.
   currRow = DataGrid1.DataGridTable.DataTable. _
      Rows(DataGrid1.CurrentCell.RowNumber)
   c = DataGrid1.DataGridTable.DataTable.Columns(1)
   ' Get the value of the column 1 in the DataTable.
   label1.Text = CurrRow(c, DataRowVersion.Current)
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace | DataRow.Item Overload List | DataRowVersion


DataRow.Item (String, DataRowVersion)

Gets the data stored at the column; the column is specified by name. Additionally, you can specify which version of the data to retrieve.

[C#] In C#, this member is the indexer for the DataRow class.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
   ByVal columnName As String, _
   ByVal version As DataRowVersion _
) As Object
[C#]
public object this[
   string columnName,
   DataRowVersion version
] {get;}
[C++]
public: __property Object* get_Item(
   String* columnName,
   DataRowVersion version
);
[JScript]
returnValue = DataRowObject.Item(columnName, version);
-or-
returnValue = DataRowObject(columnName, version);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

columnName
The name of the column.
version
One of the DataRowVersion values that specifies the desired row version. Possible values are Default, Original, Current, and Proposed.

Parameters [Visual Basic, C#, C++]

columnName
The name of the column.
version
One of the DataRowVersion values that specifies the desired row version. Possible values are Default, Original, Current, and Proposed.

Property Value

An Object that contains the data.

Exceptions

Exception Type | Condition
VersionNotFoundException | The row doesn't have this version of data.
IndexOutOfRangeException | The column specified by columnName can't be found.
InvalidCastException | The data types of the value and the column don't match.
DeletedRowInaccessibleException | The row was deleted.

Remarks

The version shouldn't be confused with the RowState property. The version argument describes the state of the data contained by the column in relation to the column's original value. The RowState property describes the state of the entire row in relation to its parent DataTable.

When setting the property, an exception will be thrown if an exception occurs in the ColumnChanging event.

If this is an immediate edit, see EndEdit for the exceptions that can be thrown.

Example [Visual Basic]

The following examples gets the current version of data at a clicked cell of a System.WinForms.DataGrid control.

[Visual Basic]

Private Sub DataGrid1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
   Dim currRow As DataRow
   ' Set the current row using the RowNumber property of the CurrentCell.
   currRow = DataGrid1.DataGridTable.DataTable. _
      Rows(DataGrid1.CurrentCell.RowNumber)
   ' Get the current value of the column named "FirstName."
   label1.Text = CurrRow("FirstName", DataRowVersion.Current)
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace | DataRow.Item Overload List | DataRowVersion


DataRow.Item (Int32)

Gets or sets the data stored at the specified column index.

[C#] In C#, this member is the indexer for the DataRow class.

[Visual Basic]
Overloads Public Default Property Item( _
   ByVal columnIndex As Integer _
) As Object
[C#]
public object this[
   int columnIndex
] {get; set;}
[C++]
public: __property Object* get_Item(
   int columnIndex
);
public: __property void set_Item(
   int columnIndex,
   Object*
);
[JScript]
returnValue = DataRowObject.Item(columnIndex);
DataRowObject.Item(columnIndex) = returnValue;
-or-
returnValue = DataRowObject(columnIndex);
DataRowObject(columnIndex) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

columnIndex
The zero-based index of the column

Parameters [Visual Basic, C#, C++]

columnIndex
The zero-based index of the column

Property Value

An Object that contains the data.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | The columnIndex argument is out of range.
InvalidCastException | Occurs when setting the value and the new value's Type doesn't match DataType.
DeletedRowInaccessibleException | Occurs when attempting to set a value on a deleted row.

Remarks

When setting the property, an exception will be thrown if an exception occurs in the ColumnChanging event.

If this is an immediate edit, see EndEdit for the exceptions that can be thrown.

Example [Visual Basic]

The following examples demonstrate the use of the Item property (DataRow indexer) to get and set the value of a given column index. The first example gets the value of the first column in any row that a user clicks in a System.WinForms.DataGrid control.

[Visual Basic]

Private Sub DataGrid1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
   Dim currRow As DataRow
   ' Set the current row using the RowNumber property of the CurrentCell.
   ' Assuming the DataGrid is bound to a DataTable.
   Dim t As DataTable
   t = DataGrid1.DataSource
   currRow = t.Rows(DataGrid1.CurrentCell.RowNumber)
   ' Get the value of the column 1 in the DataTable.
   Console.WriteLine(currRow(1))
End Sub

Private Sub SetDataRowValue(ByVal myGrid As DataGrid, ByVal newVal As Object)
   ' Set the value of the last column in the last row of a DataGrid
   Dim t As DataTable
   t = mygrid.DataSource.DataTable
   Dim myRow As DataRow
   myRow = t.Rows(t.Rows.Count - 1)
   myRow(t.Columns - 1) = newVal
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace | DataRow.Item Overload List


DataRow.Item (String)

Gets or sets the data stored at the named column.

[C#] In C#, this member is the indexer for the DataRow class.

[Visual Basic]
Overloads Public Default Property Item( _
   ByVal columnName As String _
) As Object
[C#]
public object this[
   string columnName
] {get; set;}
[C++]
public: __property Object* get_Item(
   String* columnName
);
public: __property void set_Item(
   String* columnName,
   Object*
);
[JScript]
returnValue = DataRowObject.Item(columnName);
DataRowObject.Item(columnName) = returnValue;
-or-
returnValue = DataRowObject(columnName);
DataRowObject(columnName) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

columnName
The name of the column.

Parameters [Visual Basic, C#, C++]

columnName
The name of the column.

Property Value

An Object that contains the data.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | The column specified by columnName can't be found.
InvalidCastException | Occurs when setting a value and its Type doesn't match DataType.
DeletedRowInaccessibleException | Occurs when attempting to set a value on a deleted row.

Remarks

When setting the property, an exception will be thrown if an exception occurs in the ColumnChanging event.If this is an immediate edit, see EndEdit for the exceptions that can be thrown.

Example [Visual Basic]

The following examples demonstrate the use of the Item property (DataRow indexer) to get and set the value of a given column index. The first example gets the value of the first column in any row that a user clicks in a System.WinForms.DataGrid control. The second sets a value passed as an argument to the method.

[Visual Basic]

Private Sub DataGrid1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
   Dim currRow As DataRow
   ' Set the current row using the RowNumber property of the CurrentCell.
   currRow = DataGrid1.DataGridTable.DataTable. _
      Rows(DataGrid1.CurrentCell.RowNumber)
   ' Get the value of the column 1 in the DataTable.
   label1.Text = CurrRow("FirstName")
End Sub
Private Sub SetDataRowValue(ByVal myGrid As DataGrid, ByVal newVal As Object)
   ' Set the value of a column in the last row of a DataGrid.
   Dim t As DataTable
   t = mygrid.DataGridTable.DataTable
   Dim myRow As DataRow
   myRow = t.Rows(t.Rows.Count - 1)
   myRow("FirstName") = newVal
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace | DataRow.Item Overload List


DataRow.ItemArray

Gets or sets all of the values for this row through an array.

[Visual Basic]
Public Property ItemArray As Object ()
[C#]
public object[] ItemArray {get; set;}
[C++]
public: __property Object* get_ItemArray();
public: __property void set_ItemArray(Object*[]);
[JScript]
public function get ItemArray() : Object[];
public function set ItemArray(Object[]);

Property Value

An array of type Object.

Exceptions

Exception Type | Condition
ArgumentException | The array is larger than the number of columns in the table.
InvalidCastException | A value in the array doesn't match its DataType in its respective DataColumn.
ConstraintException | An edit broke a constraint.
ReadOnlyException | An edit tried to change the value of a read-only column.
NoNullAllowedException | An edit tried to put a null value in a column where the DataColumn object's AllowNull is false.
DeletedRowInaccessibleException | The row has been deleted.

Remarks

If a DataColumn has its DefaultValue property set, pass a a null reference (in Visual Basic Nothing) in the array to set the default value for that column. Similarly, if a column has its AutoIncrement property set to true, pass the a null reference (Nothing) in the array to set the automatically generated value for the row.

An exception can occur if a user throws an exception in the ColumnChanging event, or the RowChanging event.

Example [Visual Basic]

The following examples show how to get and set values using the ItemArray property.

[Visual Basic]

Private Sub GetArray()
   Dim currRow As DataRow
   currRow = DataGrid1.DataGridTable.DataTable.Rows(DataGrid1.CurrentCell.RowNumber)

   Dim myArray() As Object
   myArray = currRow.ItemArray
   Dim i As Integer
   Dim strTemp As String
   For i = 0 To UBound(myarray)
      strTemp &= myArray(i) & vbcrlf
   Next
   label1.Text = strtemp
End Sub

Private Sub SetArray()
   Dim myArray(1) As Object
   ' Use Object.Empty to set the default value of a column.
   myArray(0) = null
   myArray(1) = "Item 1"
   Dim currRow As DataRow
   currRow = DataGrid1.DataGridTable.DataTable.Rows(DataGrid1.CurrentCell.RowNumber)
   currRow.ItemArray = myarray
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace | AcceptChanges | AutoIncrement | DataColumn


DataRow.RowError

Gets or sets the custom error description for a row.

[Visual Basic]
Public Property RowError As String
[C#]
public string RowError {get; set;}
[C++]
public: __property String* get_RowError();
public: __property void set_RowError(String*);
[JScript]
public function get RowError() : String;
public function set RowError(String);

Property Value

The text describing an error.

Remarks

Uset the HasErrors property to first determine if a DataRow contains errors.

Example [Visual Basic]

[Visual Basic]

Private Sub SetError()
   Dim myError As String
   myError = "Replace this text."
   Dim myRow As DataRow
   ' Create a new row using a DataGrid control's DataTable.
   myRow = DataGrid1.DataGridTable.DataTable.NewRow
   ' Set error description.
   myRow.RowError = myError
End Sub
Private Sub DataGrid1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
   Dim currRow As DataRow
   ' Set the current row using the RowNumber property of the CurrentCell.
   currRow = DataGrid1.DataGridTable.DataTable. _
      Rows(DataGrid1.CurrentCell.RowNumber)
   ' Display the row error.
   label1.Text = currRow.RowError
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace | SetColumnError | Error


DataRow.RowState

Gets the current state of the row in regards to its relationship to the table.

[Visual Basic]
Public ReadOnly Property RowState As DataRowState
[C#]
public DataRowState RowState {get;}
[C++]
public: __property DataRowState get_RowState();
[JScript]
public function get RowState() : DataRowState;

Property Value

One of the DataRowState values. Possible values include: Detached, Unchanged, New, Deleted, and Modified.

Remarks

The RowState property is used in conjunction with the GetChanges and HasChanges methods of the DataSet.

The value of the RowState depends on two factors: (1) the kind of operation has been performed on the row, and (2) whether or not AcceptChanges has been called on the DataRow. The table below summarizes possible values according to the changes:

State | Description
Detached | The row has been deleted, but AcceptChanges has not been called. Or the row has been created, but not added to the rows collection.
Unchanged | No changes have been made since the last time AcceptChanges was called.
New | The row has been added to the rows collection, but AcceptChanges hasn't been called. After calling AcceptChanges, the RowState becomes Unchanged.
Deleted | The row has been deleted from the table using the Delete method.
Modified | The row has been modified, and AcceptChanges hasn't been called. After calling AcceptChanges, the RowState Unchanged.

Example [Visual Basic]

The following example prints the current RowState of a row when the user clicks a cell in a DataGrid control.

[Visual Basic]

Private Sub DataGrid1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
   Dim currRow As DataRow
   ' Set the current row using the RowNumber property of the CurrentCell.
   currRow = DataGrid1.DataSource.DataTable. _
   Rows(DataGrid1.CurrentCell.RowNumber)
   Console.WriteLine(GetState(CurrRow.RowState))
End Sub

Private Function GetState(myRowState As DataRowState) As String
   Select Case myRowState
      Case Deleted
         GetState = "Deleted"
      Case Detached
         GetState = "Detached"
      Case Modified
         GetState = "Modified"
      Case Unchanged
         GetState = "UnChanged"
      Case New
         GetState = "New"
      Case Else
         GetState = "Unknown"
   End Select
End Function

See Also

DataRow Class | DataRow Members | System.Data Namespace | AcceptChanges | BeginEdit | Add | CancelEdit | DataTable | DataRowView | Delete | EndEdit | NewRow


DataRow.Table

Gets the DataTable for which this row has a schema.

[Visual Basic]
Public ReadOnly Property Table As DataTable
[C#]
public DataTable Table {get;}
[C++]
public: __property DataTable* get_Table();
[JScript]
public function get Table() : DataTable;

Property Value

The DataTable to which this row belongs.

Remarks

Note The row does not necessarily belong to the table's collection of rows. This occurs when the DataRow has been created but not added to the RowsCollection. If the RowState property returns DataRowState.Proposed, the row is not in the collection.

Example [Visual Basic]

The following example uses the Table property to return a reference to the columns collection of the DataTable.

[Visual Basic]

Private Sub GetTable()
   Dim myRow As DataRow
   Dim tempTable as DataTable
   ' Use a DataGrid control's DataTable to create a new row.
   myRow = DataGrid1.DataSource.DataTable.NewRow
   ' Use the Table property to get the DataTable and then the columns.
   tempTable = myRow.Table

End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace | ColumnsCollection | DataTable


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataRow Methods

The methods of the DataRow class are listed below. For a complete list of DataRow class members, see the DataRow Members topic.

Public:

AcceptChanges | Commits all the changes made to this row since the last time AcceptChanges was called.
BeginEdit | Begins an edit operation on a DataRow object.
CancelEdit | Cancels the current edit on the row.
ClearErrors | Clears the errors for the row.
Delete | Deletes the row.
EndEdit | Ends the edit occurring on the row.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetChildRows | Overloaded. Gets the child rows of this DataRow using the specified DataRelation.
GetColumnError | Overloaded. Gets the error description for a column.
GetColumnsInError | Gets an array of columns that have errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParentRow | Overloaded. Gets the parent row of this DataRow using the specified DataRelation.
GetParentRows | Overloaded. Gets the parent rows of this DataRow using the specified DataRelation.
GetType (inherited from Object) | Gets the Type of the Object.
HasVersion | Gets a value indicating whether a specified version exists.
IsNull | Overloaded. Gets a value indicating whether the specified column contains a null value.
RejectChanges | Rejects all changes made to the row since AcceptChanges was last called.
SetColumnError | Overloaded. Sets the error description for a column.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetNull | Sets the specified column's value to a null value.

See Also

DataRow Class | System.Data Namespace


DataRow.AcceptChanges

Commits all the changes made to this row since the last time AcceptChanges was called.

[Visual Basic]
Public Sub AcceptChanges()
[C#]
public void AcceptChanges();
[C++]
public: void AcceptChanges();
[JScript]
public function AcceptChanges();

Exceptions

Exception Type | Condition
RowNotInTableException | The row doesn't belong to the table.

Remarks

When invoking AcceptChanges, the EndEdit method is implicitly called to end any edits. If the RowState of the row was New or Modified, the RowState becomes Unchanged. If the RowState was Deleted, the row is removed.

See the BeginEdit method for more details.

The DataTable class also has an AcceptChanges method which affects changes made to the entire table.

Example [Visual Basic]

The following example edits the value of one column in the last row of a System.WinForms.DataGrid control. The example uses the BeginEdit, EndEdit, and AcceptChanges methods to programmatically edit the column's value and commit the change to the row, and finally to the table itself.

[Visual Basic]

Private Sub EditAndAccept()
   Dim t As DataTable
   t = DataGrid1.DataSource.DataTable

   Dim myrow As DataRow
   myRow = t.Rows(t.Rows.Count - 1)

   myrow.BeginEdit
   myrow(1) = Edit1.Text

   myrow.EndEdit
   myrow.AcceptChanges
   t.AcceptChanges
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace | AcceptChanges | BeginEdit | CancelEdit | DataViewRowState | DataTable | EndEdit | HasVersion | Item | RowState


DataRow.BeginEdit

Begins an edit operation on a DataRow object.

[Visual Basic]
Public Sub BeginEdit()
[C#]
public void BeginEdit();
[C++]
public: void BeginEdit();
[JScript]
public function BeginEdit();

Exceptions

Exception Type | Condition
InRowChangingEventException | The method was called inside the RowChanging event.
DeletedRowInaccessibleException | The method was called upon a deleted row.

Remarks

You can only create or update a row after calling the BeginEdit method; similarly, the EndEdit method must be called to commit the edit. (The BeginEdit method is called implicitly when the user changes the value of a databound control; the EndEdit method is called implicitly when you invoke the DataTable object's AcceptChanges method.) While in this edit mode, the DataRow stores representations of the original and new proposed values Therefore, as long as the EndEdit method has not been called, you can retrieve either the original or proposed version by passing either DataRowVersion.Original or DataRowVersion.Proposed for the version parameter of the Item property (DataRow indexer). You can also cancel any edits at this time by invoking the CancelEdit method.

To see if the row contains an original or proposed value, call the HasVersion method.

Example [Visual Basic]

The following example edits the value of one column in the last row of a System.WinForms.DataGrid control. The example uses the BeginEdit, EndEdit, and AcceptChanges methods to programmatically edit the column's value and commit the change to the row, and finally to the table itself.

[Visual Basic]

Private Sub EditAndAccept()
   Dim t As DataTable
   t = DataGrid1.DataGridTable.DataTable

   Dim myrow As DataRow
   myRow = t.Rows(t.Rows.Count - 1)

   myrow.BeginEdit
   myrow(1) = Edit1.Text

   myrow.EndEdit
   myrow.AcceptChanges
   t.AcceptChanges
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace | AcceptChanges | CancelEdit | EndEdit | HasVersion | Item | RowState


DataRow.CancelEdit

Cancels the current edit on the row.

[Visual Basic]
Public Sub CancelEdit()
[C#]
public void CancelEdit();
[C++]
public: void CancelEdit();
[JScript]
public function CancelEdit();

Exceptions

Exception Type | Condition
InRowChangingEventException | The method was called inside the RowChanging event.

Remarks

See the BeginEdit method for more details.

Example [Visual Basic]

The following example edits the value of one column in the last row of a System.WinForms.DataGrid control. The example uses the BeginEdit, EndEdit, and AcceptChanges methods to programmatically edit the column's value and commit the change to the row, and finally to the table itself.

[Visual Basic]

Private Sub EditAndAccept()
   Dim t As DataTable
   t = DataSet1.Tables(0)

   Dim myrow As DataRow
   myRow = t.Rows(t.Rows.Count - 1)

   myrow.BeginEdit
   myrow(1) = Edit1.Text

   myrow.EndEdit
   myrow.AcceptChanges
   t.AcceptChanges
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace | AcceptChanges | BeginEdit | DataViewRowState | EndEdit | HasVersion | Item | RowState


DataRow.ClearErrors

Clears the errors for the row.

[Visual Basic]
Public Sub ClearErrors()
[C#]
public void ClearErrors();
[C++]
public: void ClearErrors();
[JScript]
public function ClearErrors();

Remarks

Use SetColumnError and GetColumnError to set and return errors for individual columns.

To determine if any errors exist for the columns collection, use the HasErrors method. Consequently, you can use the GetColumnsInError method to retrieve all of the columns with errors.

Example [Visual Basic]

The following example gets the error description for each column in each DataTable of a DataSet. After printing each for each row, the ClearErrors method is called.

[Visual Basic]

Private Sub PrintAllErrs()
   Dim rowsInError() As DataRow
   Dim t As DataTable
   Dim ds As DataSet
   Dim i As Integer
   Dim c As DataColumn
   ds = DataSet1

   For Each t in ds.Tables
      ' Test if the table has errors. If not, skip it.
      If t.HasErrors Then
         ' Get an array of all rows with errors.
         rowsInError = t.GetErrors
         ' Print the error of each column in each row.
For i = 0 To UBound(rowsInError)
   For Each c In t.Columns
      Console.WriteLine(c.ColumnName, rowsInError(i).GetColumnError(c))
   Next c
   ' Clear the row errors
   rowsInError(i).ClearErrors
Next i
      End If
   Next t
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace | ColumnsCollection | GetColumnError | GetColumnsInError | HasErrors | SetColumnError


DataRow.Delete

Deletes the row.

[Visual Basic]
Public Sub Delete()
[C#]
public void Delete();
[C++]
public: void Delete();
[JScript]
public function Delete();

Exceptions

Exception Type | Condition
RowNotInTableException | The row doesn't belong to the table.
DeletedRowInaccessibleException | The row has already been deleted.

Remarks

If the RowState of the row is New, the row will be removed from the table.

The DataViewRowState becomes Deleted after using the Delete method.

Example [Visual Basic]

The following example deletes the row in a System.WinForms.DataGrid control with the focus.

[Visual Basic]

Private Sub DeleteRow()
   Dim t As DataTable
   t = DataSet1.Tables(0)
   Dim row As DataRow
   row = t.Rows(DataGrid1.CurrentCell.RowNumber)
   row.Delete
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace


DataRow.EndEdit

Ends the edit occurring on the row.

[Visual Basic]
Public Sub EndEdit()
[C#]
public void EndEdit();
[C++]
public: void EndEdit();
[JScript]
public function EndEdit();

Exceptions

Exception Type | Condition
InRowChangingEventException | The method was called inside the RowChanging event.
ConstraintException | The edit broke a constraint.
ReadOnlyException | The row belongs to the table and the edit tried to change the value of a read-only column.
NoNullAllowedException | The edit tried to put a null value into a column where AllowNull is false.

Remarks

When setting the property, an exception will be thrown if an exception occurs in the RowChanging event.

Example [Visual Basic]

The following example edits the value of one column in the last row of a System.WinForms.DataGrid control. The example uses the BeginEdit, EndEdit, and AcceptChanges methods to programmatically edit the column's value and commit the change to the row, and finally to the table itself.

[Visual Basic]

Private Sub EditAndAccept()
   Dim t As DataTable
   t = DataSet1.Tables(0)
   Dim myrow As DataRow
   ' Set the variable to the last row in the table.
   myRow = t.Rows(t.Rows.Count - 1)
   myrow.BeginEdit
   ' Set the value to the Text property of an Edit control.
   myrow(1) = Edit1.Text

   ' End the edit operation.
   myrow.EndEdit
   ' Accept changes on the row.
   myrow.AcceptChanges
   ' Accept changes on the table.
   t.AcceptChanges
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace | AcceptChanges | AllowNull | BeginEdit | CancelEdit | HasVersion | Item | RowState


DataRow.GetChildRows

Gets the child rows of this DataRow using the specified DataRelation.

Overload List

Gets the child rows of this DataRow using the specified DataRelation.

[Visual Basic] Overloads Public Function GetChildRows(DataRelation) As DataRow ()
[C#] public DataRow[] GetChildRows(DataRelation);
[C++] public: DataRow* GetChildRows(DataRelation*) [];
[JScript] public function GetChildRows(DataRelation) : DataRow[];

Gets the child rows of this DataRow using the specified DataRelation and the specified DataRowVersion

[Visual Basic] Overloads Public Function GetChildRows(DataRelation, DataRowVersion) As DataRow ()
[C#] public DataRow[] GetChildRows(DataRelation, DataRowVersion);
[C++] public: DataRow* GetChildRows(DataRelation*, DataRowVersion) [];
[JScript] public function GetChildRows(DataRelation, DataRowVersion) : DataRow[];

Example [Visual Basic]

The following example uses the GetChildRows to return the child DataRow objects for every child DataRelation in a DataTable. The value of each column in the row is then printed.

Note This example shows how to use one of the overloaded versions of GetChildRows. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub GetChildRowsFromDataRelation(myTable As DataTable, ver As DataRowVersion)
   Dim dr As DataRelation
   Dim arrRows() As DataRow
   Dim r As DataRow
   Dim i As Integer
   Dim dc As DataColumn

   For Each dr In myTable.ChildRelations
     For Each r In myTable.Rows
         arrRows = r.GetChildRows(dr, ver)
         ' Print values of rows.
         For i = 0 To UBound(arrRows)
For Each dc In myTable.Columns
   Console.WriteLine(arrRows(i)(dc))
Next dc
         Next i
      Next r
   Next dr
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace


DataRow.GetChildRows (DataRelation)

Gets the child rows of this DataRow using the specified DataRelation.

[Visual Basic]
Overloads Public Function GetChildRows( _
   ByVal relation As DataRelation _
) As DataRow ()
[C#]
public DataRow[] GetChildRows(
   DataRelation relation
);
[C++]
public: DataRow* GetChildRows(
   DataRelation* relation
) [];
[JScript]
public function GetChildRows(
   relation : DataRelation
) : DataRow[];

Parameters

relation
The DataRelation to use.

Return Value

An array of DataRow objects (or an array of length zero).

Exceptions

Exception Type | Condition
RowNotInTableException | The row doesn't belong to the table.
ArgumentNullException | The relation is a null reference (in Visual Basic Nothing).
ArgumentException | The relation and row don't belong to the same table.
VersionNotFoundException | The row doesn't have this version of data.

Remarks

In a DataSet, the collection of all DataRelation objects for the data set is returned by the GetChildRelations method.

The DataTable also contains a collection of DataRelation objects, also returned by the ChildRelations property.

Example [Visual Basic]

The following example uses the GetChildRows to return the child DataRow objects for every child DataRelation in a DataTable. The value of each column in the row is then printed.

[Visual Basic]

Private Sub GetChildRowsFromDataRelation(myTable As DataTable)
   Dim dr As DataRelation
   Dim arrRows() As DataRow
   Dim r As DataRow
   Dim i As Integer
   Dim dc As DataColumn

   For Each dr In myTable.ChildRelations
     For Each r In myTable.Rows
         arrRows = r.GetChildRows(dr)
         ' Print values of rows.
         For i = 0 To UBound(arrRows)
For Each dc in myTable.Columns
   Console.WriteLine(arrRows(i)(dc))
Next dc
         Next i
      Next r
   Next dr
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace | DataRow.GetChildRows Overload List | ChildRelations | DataRelation | GetParentRows | Relations


DataRow.GetChildRows (DataRelation, DataRowVersion)

Gets the child rows of this DataRow using the specified DataRelation and the specified DataRowVersion

[Visual Basic]
Overloads Public Function GetChildRows( _
   ByVal relation As DataRelation, _
   ByVal version As DataRowVersion _
) As DataRow ()
[C#]
public DataRow[] GetChildRows(
   DataRelation relation,
   DataRowVersion version
);
[C++]
public: DataRow* GetChildRows(
   DataRelation* relation,
   DataRowVersion version
) [];
[JScript]
public function GetChildRows(
   relation : DataRelation,
   version : DataRowVersion
) : DataRow[];

Parameters

relation
The DataRelation to use.
version
One of the DataRowVersion values specifying the version of the data to get.

Return Value

An array of DataRow objects.

Exceptions

Exception Type | Condition
RowNotInTableException | The row doesn't belong to the table.
ArgumentNullException | The relation is a null reference (in Visual Basic Nothing).
ArgumentException | The relation and row don't belong to the same table.
VersionNotFoundException | The row doesn't have the requested DataRowVersion.

Remarks

In a DataSet, the collection of all DataRelation objects for the data set is returned by the GetChildRelations method.

The DataTable also contains a collection of DataRelation objects, also returned by the ChildRelations property.

Use the HasVersion property to determine if the desired DataRowVersion exists.

Example [Visual Basic]

The following example uses the GetChildRows to return the child DataRow objects for every child DataRelation in a DataTable. The value of each column in the row is then printed.

[Visual Basic]

Private Sub GetChildRowsFromDataRelation(myTable As DataTable, ver As DataRowVersion)
   Dim dr As DataRelation
   Dim arrRows() As DataRow
   Dim r As DataRow
   Dim i As Integer
   Dim dc As DataColumn

   For Each dr In myTable.ChildRelations
     For Each r In myTable.Rows
         arrRows = r.GetChildRows(dr, ver)
         ' Print values of rows.
         For i = 0 To UBound(arrRows)
For Each dc In myTable.Columns
   Console.WriteLine(arrRows(i)(dc))
Next dc
         Next i
      Next r
   Next dr
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace | DataRow.GetChildRows Overload List | ChildRelations | DataRelation | DataRowVersion | GetParentRow | GetParentRows | Relations


DataRow.GetColumnError

Gets the error description for a column.

Overload List

Gets the error description for the column specified by index.

[Visual Basic] Overloads Public Function GetColumnError(Integer) As String
[C#] public string GetColumnError(int);
[C++] public: String* GetColumnError(int);
[JScript] public function GetColumnError(int) : String;

Gets the error description of the specified DataColumn.

[Visual Basic] Overloads Public Function GetColumnError(DataColumn) As String
[C#] public string GetColumnError(DataColumn);
[C++] public: String* GetColumnError(DataColumn*);
[JScript] public function GetColumnError(DataColumn) : String;

Gets the error description for a column, specified by name.

[Visual Basic] Overloads Public Function GetColumnError(String) As String
[C#] public string GetColumnError(String);
[C++] public: String* GetColumnError(String*);
[JScript] public function GetColumnError(String) : String;

Example [Visual Basic]

The following example sets and gets the error description for a new column in an existing System.WinForms.DataGrid control's DataTable.

Note This example shows how to use one of the overloaded versions of GetColumnError. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Dim myRow As DataRow
Dim t As DataTable
t = DataGrid1.DataSource.DataTable
myRow = t.NewRow
Dim ErrorString As String
ErrorString = "Replace this text."
' Use DataColumn.Contains to ensure the column exists
If myRow.DataTable.Columns.Contains("id") Then
   myRow.SetColumnError "id", ErrorString
   Console.WriteLineDebug(myRow.GetColumnError("id"))
   ' Add the row
   t.Rows.Add(myRow)
End If

See Also

DataRow Class | DataRow Members | System.Data Namespace


DataRow.GetColumnError (Int32)

Gets the error description for the column specified by index.

[Visual Basic]
Overloads Public Function GetColumnError( _
   ByVal columnIndex As Integer _
) As String
[C#]
public string GetColumnError(
   int columnIndex
);
[C++]
public: String* GetColumnError(
   int columnIndex
);
[JScript]
public function GetColumnError(
   columnIndex : int
) : String;

Parameters

columnIndex
The zero-based index of the column.

Return Value

The text of the error description.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | The columnIndex argument is out of range.

Remarks

Use the SetColumnError method to set column errors.

To determine if any errors exist for the columns collection, use the HasErrors method. Consequently, you can use the GetColumnsInError method to retrieve all of the columns with errors.

To clear all errors for the columns collection, use the ClearErrors method.

Example [Visual Basic]

The following example sets and gets the error description for a new column in an existing System.WinForms.DataGrid control's DataTable.

[Visual Basic]

Dim myRow As DataRow
Dim t As DataTable
t = DataGrid1.DataSource.DataTable
myRow = t.NewRow
Dim ErrorString As String
ErrorString = "Replace this text."
' Use DataColumn.Contains to ensure the column exists
If myRow.DataTable.Columns.Contains(1) Then
   myRow.SetColumnError(1, ErrorString)
   Console.WriteLine(myRow.GetColumnError(1))
   ' Add the row
   t.Rows.Add(myRow)
End If

See Also

DataRow Class | DataRow Members | System.Data Namespace | DataRow.GetColumnError Overload List | ClearErrors | ColumnsCollection | Contains | DataColumn | Error | GetColumnsInError | HasErrors | RowError | SetColumnError


DataRow.GetColumnError (DataColumn)

Gets the error description of the specified DataColumn.

[Visual Basic]
Overloads Public Function GetColumnError( _
   ByVal column As DataColumn _
) As String
[C#]
public string GetColumnError(
   DataColumn column
);
[C++]
public: String* GetColumnError(
   DataColumn* column
);
[JScript]
public function GetColumnError(
   column : DataColumn
) : String;

Parameters

column
A DataColumn.

Return Value

The text of the error description.

Remarks

Use the SetColumnError method to set column errors.

To determine if any errors exist for the columns collection, use the HasErrors method. Consequently, you can use the GetColumnsInError method to retrieve all of the columns with errors. Alternatively, the GetErrors method of the DataTable returns all rows with errors.

To clear all errors for the columns collection, use the ClearErrors method.

Example [Visual Basic]

The following example gets the error description for each column in each DataTable of a DataSet.

[Visual Basic]

Private Sub PrintAllErrs()
   Dim rowsInError() As DataRow
   Dim t As DataTable
   Dim ds As DataSet
   Dim i As Integer
   Dim c As DataColumn
   ds = DataSet1

   For Each t in ds.Tables
      ' Test if the table has errors. If not, skip it.
      If t.HasErrors Then
         ' Get an array of all rows with errors.
         rowsInError = t.GetErrors
         ' Print the error of each column in each row.
For i = 0 To UBound(rowsInError)
   For Each c In t.Columns
      Console.WriteLine(c.ColumnName, rowsInError(i).GetColumnError(c))
   Next c
   ' Clear the row errors
   rowsInError(i).ClearErrors
Next i
      End If
   Next t
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace | DataRow.GetColumnError Overload List | ClearErrors | ColumnsCollection | Contains | DataColumn | Error | GetColumnsInError | GetErrors | HasErrors | RowError | SetColumnError


DataRow.GetColumnError (String)

Gets the error description for a column, specified by name.

[Visual Basic]
Overloads Public Function GetColumnError( _
   ByVal columnName As String _
) As String
[C#]
public string GetColumnError(
   string columnName
);
[C++]
public: String* GetColumnError(
   String* columnName
);
[JScript]
public function GetColumnError(
   columnName : String
) : String;

Parameters

columnName
The name of the column.

Return Value

The text of the error description.

Remarks

Use the SetColumnError method to set column errors.

To determine if any errors exist for the columns collection, use the HasErrors method. Consequently, you can use the GetColumnsInError method to retrieve all of the columns with errors.

To clear all errors for the columns collection, use the ClearErrors method.

Example [Visual Basic]

The following example sets and gets the error description for a new column in an existing System.WinForms.DataGrid control's DataTable.

[Visual Basic]

Dim myRow As DataRow
Dim t As DataTable
t = DataGrid1.DataSource.DataTable
myRow = t.NewRow
Dim ErrorString As String
ErrorString = "Replace this text."
' Use DataColumn.Contains to ensure the column exists
If myRow.DataTable.Columns.Contains("id") Then
   myRow.SetColumnError "id", ErrorString
   Console.WriteLineDebug(myRow.GetColumnError("id"))
   ' Add the row
   t.Rows.Add(myRow)
End If

See Also

DataRow Class | DataRow Members | System.Data Namespace | DataRow.GetColumnError Overload List | ClearErrors | ColumnsCollection | Contains | DataColumn | Error | GetColumnsInError | HasErrors | RowError | SetColumnError


DataRow.GetColumnsInError

Gets an array of columns that have errors.

[Visual Basic]
Public Function GetColumnsInError() As DataColumn ()
[C#]
public DataColumn[] GetColumnsInError();
[C++]
public: DataColumn* GetColumnsInError() [];
[JScript]
public function GetColumnsInError() : DataColumn[];

Return Value

An array of DataColumn objects that contain errors.

Example [Visual Basic]

The following example uses the GetColumnsInError method to retrieve all DataColumn objects that have errors.

[Visual Basic]

Private Sub GetAllErrs()
   Dim ds As DataSet
   Dim colArr() As DataColumn
   Dim r As DataRow
   Dim c As DataColumn
   Dim cols as ColumnsCollection
   Dim t As DataTable
   Dim i As Integer
   ds = DataSet1
   For Each t in ds.Tables
      If t.HasErrors Then
         For Each r in t.Rows
If r.HasErrors Then
   colArr = r.GetColumnsInError
   For i = 0 To UBound(colArr)
      Console.WriteLine(r.GetColumnError(colArr(i)))
   Next i
End If
         Next r
      End If
   Next t
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace | ClearErrors | Error | GetColumnError | GetErrors | HasErrors | RowError | SetColumnError


DataRow.GetParentRow

Gets the parent row of this DataRow using the specified DataRelation.

Overload List

Gets the parent row of this DataRow using the specified DataRelation and DataRowVersion.

[Visual Basic] Overloads Public Function GetParentRow(DataRelation, DataRowVersion) As DataRow
[C#] public DataRow GetParentRow(DataRelation, DataRowVersion);
[C++] public: DataRow* GetParentRow(DataRelation*, DataRowVersion);
[JScript] public function GetParentRow(DataRelation, DataRowVersion) : DataRow;

Gets the parent row of this DataRow using the specified DataRelation.

[Visual Basic] Overloads Public Function GetParentRow(DataRelation) As DataRow
[C#] public DataRow GetParentRow(DataRelation);
[C++] public: DataRow* GetParentRow(DataRelation*);
[JScript] public function GetParentRow(DataRelation) : DataRow;

Example [Visual Basic]

The following example uses the GetParentRow to return the child DataRow objects for every child DataRelation in a DataTable. The value of each column in the row is then printed.

Note This example shows how to use one of the overloaded versions of GetParentRow. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub GetChildRowsFromDataRelation(myTable As DataTable)
   Dim dr As DataRelation
   Dim myRow As DataRow
   Dim r As DataRow
   Dim i As Integer
   Dim dc As DataColumn

   For Each dr In myTable.ParentRelations
     For Each r In myTable.Rows
         myRow = r.GetParentRow(dr)
         ' Print values of the row.
         For Each dc in myTable.Columns
Console.WriteLine(myRow(dc))
         Next dc
      Next r
   Next dr
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace


DataRow.GetParentRow (DataRelation, DataRowVersion)

Gets the parent row of this DataRow using the specified DataRelation and DataRowVersion.

[Visual Basic]
Overloads Public Function GetParentRow( _
   ByVal relation As DataRelation, _
   ByVal version As DataRowVersion _
) As DataRow
[C#]
public DataRow GetParentRow(
   DataRelation relation,
   DataRowVersion version
);
[C++]
public: DataRow* GetParentRow(
   DataRelation* relation,
   DataRowVersion version
);
[JScript]
public function GetParentRow(
   relation : DataRelation,
   version : DataRowVersion
) : DataRow;

Parameters

relation
The DataRelation to use.
version
One of the DataRowVersion values specifying the version of the data to get.

Exceptions

Exception Type | Condition
RowNotInTableException | The row doesn't belong to a table.
ArgumentNullException | The row is a null reference (in Visual Basic Nothing). The relation doesn't belong to this table's parent relations.
VersionNotFoundException | The row doesn't have this version of data.
InvalidConstraintException | The relations's child table isn't the table the row belongs to.

Example [Visual Basic]

The following example uses the GetParentRow to return the child DataRow objects for every child DataRelation in a DataTable. The value of each column in the row is then printed.

[Visual Basic]

Private Sub GetChildRowsFromDataRelation(myTable As DataTable, ver As DataRowVersion)
   Dim dr As DataRelation
   Dim myRow As DataRow
   Dim r As DataRow
   Dim i As Integer
   Dim dc As DataColumn

   For Each dr In myTable.ParentRelations
     For Each r In myTable.Rows
         myRow = r.GetParentRow(dr, ver)
         ' Print values of the row.
         For Each dc in myTable.Columns
Console.WriteLine(myRow(dc))
         Next dc
      Next r
   Next dr
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace | DataRow.GetParentRow Overload List | ChildRelations | DataRelation | DataRowVersion | GetChildRows | GetParentRow | Relations


DataRow.GetParentRow (DataRelation)

Gets the parent row of this DataRow using the specified DataRelation.

[Visual Basic]
Overloads Public Function GetParentRow( _
   ByVal relation As DataRelation _
) As DataRow
[C#]
public DataRow GetParentRow(
   DataRelation relation
);
[C++]
public: DataRow* GetParentRow(
   DataRelation* relation
);
[JScript]
public function GetParentRow(
   relation : DataRelation
) : DataRow;

Parameters

relation
The DataRelation to use.

Return Value

The row's parent DataRow.

Exceptions

Exception Type | Condition
RowNotInTableException | The row doesn't belong to a table.
ArgumentNullException | The relation doen't belong to the DataTable. The row is a null reference (in Visual Basic Nothing).
InvalidConstraintException | This row doesn't belong to the DataRelation object's child table.

Example [Visual Basic]

The following example uses the GetParentRow to return the child DataRow objects for every child DataRelation in a DataTable. The value of each column in the row is then printed.

[Visual Basic]

Private Sub GetChildRowsFromDataRelation(myTable As DataTable)
   Dim dr As DataRelation
   Dim myRow As DataRow
   Dim r As DataRow
   Dim i As Integer
   Dim dc As DataColumn

   For Each dr In myTable.ParentRelations
     For Each r In myTable.Rows
         myRow = r.GetParentRow(dr)
         ' Print values of the row.
         For Each dc in myTable.Columns
Console.WriteLine(myRow(dc))
         Next dc
      Next r
   Next dr
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace | DataRow.GetParentRow Overload List | ChildRelations | DataRelation | GetChildRows | GetParentRow | Relations


DataRow.GetParentRows

Gets the parent rows of this DataRow using the specified DataRelation.

Overload List

Gets the parent rows of this DataRow using the specified DataRelation.

[Visual Basic] Overloads Public Function GetParentRows(DataRelation) As DataRow ()
[C#] public DataRow[] GetParentRows(DataRelation);
[C++] public: DataRow* GetParentRows(DataRelation*) [];
[JScript] public function GetParentRows(DataRelation) : DataRow[];

Gets the parent rows of this DataRow using the specified DataRelation.

[Visual Basic] Overloads Public Function GetParentRows(DataRelation, DataRowVersion) As DataRow ()
[C#] public DataRow[] GetParentRows(DataRelation, DataRowVersion);
[C++] public: DataRow* GetParentRows(DataRelation*, DataRowVersion) [];
[JScript] public function GetParentRows(DataRelation, DataRowVersion) : DataRow[];

Example [Visual Basic]

The following example uses the GetParentRows to return the child DataRow objects for every child DataRelation in a DataTable. The value of each column in the row is then printed.

Note This example shows how to use one of the overloaded versions of GetParentRows. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub GetChildRowsFromDataRelation(myTable As DataTable, ver As DataRowVersion)
   Dim dr As DataRelation
   Dim arrRows() As DataRow
   Dim r As DataRow
   Dim i As Integer
   Dim dc As DataColumn

   For Each dr In myTable.ParentRelations
     For Each r In myTable.Rows
         arrRows = r.GetParentRows(dr, ver)
         ' Print values of rows.
         For i = 0 To UBound(arrRows)
For Each dc in myTable.Columns
   Console.WriteLine(arrRows(i)(dc.ColumnName))
Next dc
         Next i
      Next r
   Next dr
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace


DataRow.GetParentRows (DataRelation)

Gets the parent rows of this DataRow using the specified DataRelation.

[Visual Basic]
Overloads Public Function GetParentRows( _
   ByVal relation As DataRelation _
) As DataRow ()
[C#]
public DataRow[] GetParentRows(
   DataRelation relation
);
[C++]
public: DataRow* GetParentRows(
   DataRelation* relation
) [];
[JScript]
public function GetParentRows(
   relation : DataRelation
) : DataRow[];

Parameters

relation
The DataRelation to use.

Exceptions

Exception Type | Condition
RowNotInTableException | The row doesn't belong to a DataTable.
ArgumentNullException | The row is a null reference (in Visual Basic Nothing).
ArgumentException | The DataRelation doesn't belong to this row's DataSet.
InvalidConstraintException | The relation's child table isn't the table the row belongs to.

Remarks

In a DataSet, the collection of all parent DataRelation objects for the data set is returned by the GetParentRelations method.

The DataTable also contains a collection of DataRelation objects, returned by the ParentRelations property.

Example [Visual Basic]

The following example uses the GetParentRows to return the child DataRow objects for every child DataRelation in a DataTable. The value of each column in the row is then printed.

[Visual Basic]

Private Sub GetChildRowsFromDataRelation(myTable As DataTable)
   Dim dr As DataRelation
   Dim arrRows() As DataRow
   Dim r As DataRow
   Dim i As Integer
   Dim dc As DataColumn

   For Each dr In myTable.ParentRelations
     For Each r In myTable.Rows
         arrRows = r.GetParentRows(dr)
         ' Print values of rows.
         For i = 0 To UBound(arrRows)
For Each dc in myTable.Columns
   Console.WriteLine(arrRows(i)(dc.ColumnName))
Next dc
         Next i
      Next r
   Next dr
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace | DataRow.GetParentRows Overload List | ChildRelations | DataRelation | GetChildRows | GetParentRow | Relations


DataRow.GetParentRows (DataRelation, DataRowVersion)

Gets the parent rows of this DataRow using the specified DataRelation.

[Visual Basic]
Overloads Public Function GetParentRows( _
   ByVal relation As DataRelation, _
   ByVal version As DataRowVersion _
) As DataRow ()
[C#]
public DataRow[] GetParentRows(
   DataRelation relation,
   DataRowVersion version
);
[C++]
public: DataRow* GetParentRows(
   DataRelation* relation,
   DataRowVersion version
) [];
[JScript]
public function GetParentRows(
   relation : DataRelation,
   version : DataRowVersion
) : DataRow[];

Parameters

relation
The DataRelation to use.
version
One of the DataRowVersion values specifying the version of the data to get.

Exceptions

Exception Type | Condition
RowNotInTableException | The row doesn't belong to a DataTable.
ArgumentNullException | The row is a null reference (in Visual Basic Nothing).
ArgumentException | The DataRelation doesn't belong to this row's DataSet.
VersionNotFoundException | The row doesn't have the requested DataRowVersion.
InvalidConstraintException | The relation's child table isn't the table the row belongs to.

Remarks

In a DataSet, the collection of all parent DataRelation objects for the data set is returned by the GetParentRelations method.

The DataTable also contains a collection of DataRelation objects, returned by the ParentRelations property.

Use the HasVersion property to determine if the desired DataRowVersion exists.

Example [Visual Basic]

The following example uses the GetParentRows to return the child DataRow objects for every child DataRelation in a DataTable. The value of each column in the row is then printed.

[Visual Basic]

Private Sub GetChildRowsFromDataRelation(myTable As DataTable, ver As DataRowVersion)
   Dim dr As DataRelation
   Dim arrRows() As DataRow
   Dim r As DataRow
   Dim i As Integer
   Dim dc As DataColumn

   For Each dr In myTable.ParentRelations
     For Each r In myTable.Rows
         arrRows = r.GetParentRows(dr, ver)
         ' Print values of rows.
         For i = 0 To UBound(arrRows)
For Each dc in myTable.Columns
   Console.WriteLine(arrRows(i)(dc.ColumnName))
Next dc
         Next i
      Next r
   Next dr
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace | DataRow.GetParentRows Overload List | ChildRelations | DataRelation | GetChildRows | GetParentRow | Relations


DataRow.HasVersion

Gets a value indicating whether a specified version exists.

[Visual Basic]
Public Function HasVersion( _
   ByVal version As DataRowVersion _
) As Boolean
[C#]
public bool HasVersion(
   DataRowVersion version
);
[C++]
public: bool HasVersion(
   DataRowVersion version
);
[JScript]
public function HasVersion(
   version : DataRowVersion
) : Boolean;

Parameters

version
One of the DataRowVersion values that specifies the row version. Possible values are Default, Original, Current, and Proposed.

Return Value

true if the version exists; otherwise, false.

Remarks

See the BeginEdit method for more details.

Example [Visual Basic]

The following example uses the HasVersion method to determine if the current value of a column and the proposed value are the same. If so, the edit is cancelled. Otherwise, the AcceptChanges method is called to end the edit.

[Visual Basic]

Private Sub CheckVersionBeforeAccept()
   Dim r As DataRow
   Dim t As DataTable
   ' Assuming the DataGrid is bound to a DataTable.
   t = DataGrid1.DataSource
   r = t.Rows(DataGrid1.CurrentCell.RowNumber)
   r.BeginEdit
   r(1) = Edit1.Text
   If r.HasVersion(datarowversion.Proposed) Then
      If r(1, DataRowVersion.Current) = r(1, DataRowversion.Proposed) Then
         MessageBox.Show "The original and the proposed are the same"
         r.CancelEdit
         Exit Sub
      Else
         r.AcceptChanges
      End If
   Else
      MessageBox.Show "No new values proposed"
   End If
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace | AcceptChanges | BeginEdit | CancelEdit | Item | GetChildRows | GetParentRows | EndEdit | RowState


DataRow.IsNull

Gets a value indicating whether the specified column contains a null value.

Overload List

Gets a value indicating whether the column at the specified index contains a null value.

[Visual Basic] Overloads Public Function IsNull(Integer) As Boolean
[C#] public bool IsNull(int);
[C++] public: bool IsNull(int);
[JScript] public function IsNull(int) : Boolean;

Gets a value indicating whether the named column contains a null value.

[Visual Basic] Overloads Public Function IsNull(String) As Boolean
[C#] public bool IsNull(String);
[C++] public: bool IsNull(String*);
[JScript] public function IsNull(String) : Boolean;

Gets a value indicating whether the specified DataColumn contains a null value.

[Visual Basic] Overloads Public Function IsNull(DataColumn) As Boolean
[C#] public bool IsNull(DataColumn);
[C++] public: bool IsNull(DataColumn*);
[JScript] public function IsNull(DataColumn) : Boolean;

Example [Visual Basic]

The following example prints each column of each row in each table of a DataSet. If the row is set to a null value, the value is not printed.

Note This example shows how to use one of the overloaded versions of IsNull. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub PrintRows(ds As DataSet)
   Dim t As DataTable
   Dim dc As DataColumn
   Dim r As DataRow
   For Each t In ds.Tables
      For Each r In t.Rows
         For Each c In t.Columns
If Not r.IsNull(c) Then Console.WriteLine(r(c)).ToString
         Next c
      Next r
    Next t
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace


DataRow.IsNull (Int32)

Gets a value indicating whether the column at the specified index contains a null value.

[Visual Basic]
Overloads Public Function IsNull( _
   ByVal columnIndex As Integer _
) As Boolean
[C#]
public bool IsNull(
   int columnIndex
);
[C++]
public: bool IsNull(
   int columnIndex
);
[JScript]
public function IsNull(
   columnIndex : int
) : Boolean;

Parameters

columnIndex
[To be supplied.]

Return Value

true if the column contains a null value; otherwise, false.

Example [Visual Basic]

The following example changes the value of a column to a null value, then uses the IsNull method to determine if the value is null.

[Visual Basic]

Private Sub IsValNull()
   Dim t As DataTable
   ' Assuming the DataGrid is bound to a DataTable.
   t = DataGrid1.DataSource
   Dim r As DataRow
   r = t.Rows(datagrid1.CurrentCell.RowNumber)
   r.BeginEdit
   r(1) = dbNull
   r.EndEdit
   r.AcceptChanges
   Console.WriteLine(r.IsNull(1))
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace | DataRow.IsNull Overload List


DataRow.IsNull (String)

Gets a value indicating whether the named column contains a null value.

[Visual Basic]
Overloads Public Function IsNull( _
   ByVal columnName As String _
) As Boolean
[C#]
public bool IsNull(
   string columnName
);
[C++]
public: bool IsNull(
   String* columnName
);
[JScript]
public function IsNull(
   columnName : String
) : Boolean;

Parameters

columnName
[To be supplied.]

Return Value

true if the column contains a null value; otherwise, false.

Example [Visual Basic]

The following example changes the value of a column to a null value, then uses the IsNull method to determine if the value is null.

[Visual Basic]

Private Sub IsValNull()
   Dim t As DataTable
   Dim r As DataRow
   ' Assuming the DataGrid is bound to a DataTable.
   t = DataGrid1.DataSource

   r = t.Rows(datagrid1.CurrentCell.RowNumber)
   r.BeginEdit
   r("FirstName") = Null
   r.EndEdit
   r.AcceptChanges
   Console.WriteLine(r.IsNull("FirstName"))
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace | DataRow.IsNull Overload List


DataRow.IsNull (DataColumn)

Gets a value indicating whether the specified DataColumn contains a null value.

[Visual Basic]
Overloads Public Function IsNull( _
   ByVal column As DataColumn _
) As Boolean
[C#]
public bool IsNull(
   DataColumn column
);
[C++]
public: bool IsNull(
   DataColumn* column
);
[JScript]
public function IsNull(
   column : DataColumn
) : Boolean;

Parameters

column
[To be supplied.]

Return Value

true if the column contains a null value; otherwise, false.

Example [Visual Basic]

The following example prints each column of each row in each table of a DataSet. If the row is set to a null value, the value is not printed.

[Visual Basic]

Private Sub PrintRows(ds As DataSet)
   Dim t As DataTable
   Dim dc As DataColumn
   Dim r As DataRow
   For Each t In ds.Tables
      For Each r In t.Rows
         For Each c In t.Columns
If Not r.IsNull(c) Then Console.WriteLine(r(c)).ToString
         Next c
      Next r
    Next t
End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace | DataRow.IsNull Overload List


DataRow.RejectChanges

Rejects all changes made to the row since AcceptChanges was last called.

[Visual Basic]
Public Sub RejectChanges()
[C#]
public void RejectChanges();
[C++]
public: void RejectChanges();
[JScript]
public function RejectChanges();

Exceptions

Exception Type | Condition
RowNotInTableException | The row doesn't belong to the table.

Remarks

When calling the RejectChanges method, the CancelEdit method is implicitly called to cancel any edits. If RowState is Deleted or Modified, the row reverts to its previous values, and RowState becomes Unchanged. If the RowState is New, the row is removed.

Example [Visual Basic]

The following example uses the IsNull method to check if a column is set to a null value. If so, the RejectChanges method is called.

[Visual Basic]

Private Sub IsValNull()
   Dim t As DataTable
   ' Assuming the DataGrid is bound to a DataTable.
   t = DataGrid1.DataSource

   Dim r As DataRow
   r = t.Rows(datagrid1.CurrentCell.RowNumber)
   r.BeginEdit
   r(1) = Null
   r.EndEdit
   If r.IsNull(1) Then
      r.RejectChanges
   r.AcceptChanges
   Else
      r.AcceptChanges
   End If
   End Sub

See Also

DataRow Class | DataRow Members | System.Data Namespace | AcceptChanges | IsNull


DataRow.SetColumnError

Sets the error description for a column.

Overload List

Sets the error description for a column specified by name.

[Visual Basic] Overloads Public Sub SetColumnError(String, String)
[C#] public void SetColumnError(String, String);
[C++] public: void SetColumnError(String*, String*);
[JScript] public function SetColumnError(String, String);

Sets the error description for a column specified as a DataColumn.

[Visual Basic] Overloads Public Sub SetColumnError(DataColumn, String)
[C#] public void SetColumnError(DataColumn, String);
[C++] public: void SetColumnError(DataColumn*, String);
[JScript] public function SetColumnError(DataColumn, String);

Sets the error description for a column specified by index.

[Visual Basic] Overloads Public Sub SetColumnError(Integer, String)
[C#] public void SetColumnError(int, String);
[C++] public: void SetColumnError(int, String);
[JScript] public function SetColumnError(int, String);

Example [Visual Basic]

The following example sets and gets the error description for a new column in an existing System.WinForms.DataGrid control's DataTable.

Note This example shows how to use one of the overloaded versions of SetColumnError. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Dim myRow As DataRow
Dim t As DataTable
t = DataGrid1.DataSource
myRow = t.NewRow
Dim ErrorString As String
ErrorString = "Replace this text."
' Use DataColumn.Contains to ensure the column exists
If myRow.DataTable.Columns.Contains(1) Then
   myRow.SetColumnError(1, ErrorString)
   Console.WriteLine(myRow.GetColumnError(1))
   ' Add the row
   t.Rows.Add(myRow)
End If

See Also

DataRow Class | DataRow Members | System.Data Namespace


DataRow.SetColumnError (String, String)

Sets the error description for a column specified by name.

[Visual Basic]
Overloads Public Sub SetColumnError( _
   ByVal columnName As String, _
   ByVal error As String _
)
[C#]
public void SetColumnError(
   string columnName,
   string error
);
[C++]
public: void SetColumnError(
   String* columnName,
   String* error
);
[JScript]
public function SetColumnError(
   columnName : String,
   error : String
);

Parameters

columnName
The name of the column.
error
The error description.

Remarks

The name of a column is set with the DataColumn class's ColumnName property.

To examine error descriptions, use the GetColumnError method.

To determine if any errors exist for the columns collection, use the HasErrors method. Consequently, you can use the GetColumnsInError method to retrieve all of the columns with errors.

To set a custom error description on the whole row, use the RowError property.

To determine if any errors exist for the columns collection, use the HasErrors method.

To clear all errors for the columns collection, use the ClearErrors method.

Example [Visual Basic]

The following example sets and gets the error description for a new column in an existing System.WinForms.DataGrid control's DataTable.

[Visual Basic]

Dim myRow As DataRow
Dim t As DataTable
t = DataGrid1.DataGridTable.DataTable
myRow = t.NewRow
Dim ErrorString As String
ErrorString = "Replace this text."
' Use DataColumn.Contains to ensure the column exists
If myRow.DataTable.Columns.Contains("id") Then
   myRow.SetColumnError "id", ErrorString
   Console.WriteLine(myRow.GetColumnError("id"))
   ' Add the row
   t.Rows.Add(myRow)
End If

See Also

DataRow Class | DataRow Members | System.Data Namespace | DataRow.SetColumnError Overload List | ClearErrors | ColumnsCollection | Contains | DataColumn | Error | GetColumnsInError | HasErrors | RowError


DataRow.SetColumnError (DataColumn, String)

Sets the error description for a column specified as a DataColumn.

[Visual Basic]
Overloads Public Sub SetColumnError( _
   ByVal column As DataColumn, _
   ByVal error As String _
)
[C#]
public void SetColumnError(
   DataColumn column,
   string error
);
[C++]
public: void SetColumnError(
   DataColumn* column,
   String* error
);
[JScript]
public function SetColumnError(
   column : DataColumn,
   error : String
);

Parameters

column
The DataColumn to set the error description for.
error
The error description.

Remarks

To examine error descriptions, use the GetColumnError method.

To determine if any errors exist for the columns collection, use the HasErrors method. Consequently, you can use the GetColumnsInError method to retrieve all of the columns with errors.

To set a custom error description on the whole row, use the RowError property.

To determine if any errors exist for the columns collection, use the HasErrors method.

To clear all errors for the columns collection, use the ClearErrors method.

Example [Visual Basic]

The following example sets and gets the error description for a new column in an existing System.WinForms.DataGrid control's DataTable.

[Visual Basic]

Dim myRow As DataRow
Dim t As DataTable
Dim c As DataColumn
t = DataGrid1.DataGridTable.DataTable
' Get the column from the existing column collection.
c = t.Columns(0)
myRow = t.NewRow
Dim ErrorString As String
ErrorString = "Replace this text."
' Use DataColumn.Contains to ensure the column exists
If myRow.DataTable.Columns.Contains(c.ColumnName) Then
   myRow.SetColumnError c, ErrorString
   Console.WriteLine(myRow.GetColumnError(c))
   ' Add the row
   t.Rows.Add(myRow)
End If

See Also

DataRow Class | DataRow Members | System.Data Namespace | DataRow.SetColumnError Overload List | ClearErrors | ColumnsCollection | Contains | DataColumn | Error | GetColumnsInError | HasErrors | RowError


DataRow.SetColumnError (Int32, String)

Sets the error description for a column specified by index.

[Visual Basic]
Overloads Public Sub SetColumnError( _
   ByVal columnIndex As Integer, _
   ByVal error As String _
)
[C#]
public void SetColumnError(
   int columnIndex,
   string error
);
[C++]
public: void SetColumnError(
   int columnIndex,
   String* error
);
[JScript]
public function SetColumnError(
   columnIndex : int,
   error : String
);

Parameters

columnIndex
The zero-based index of the column.
error
The error description.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | The columnIndex argument is out of range

Remarks

The method is used to set custom error descriptions on specified columns. You can use the ErrorProvider control to display the text of the error, or through by other reporting mechanisms.

To examine error descriptions, use the GetColumnError method.

To determine if any errors exist for the columns collection, use the HasErrors method. Consequently, you can use the GetColumnsInError method to retrieve all of the columns with errors.

To set a custom error description on the whole row, use the RowError property.

To clear all errors for the columns collection, use the ClearErrors method.

Example [Visual Basic]

The following example sets and gets the error description for a new column in an existing System.WinForms.DataGrid control's DataTable.

[Visual Basic]

Dim myRow As DataRow
Dim t As DataTable
t = DataGrid1.DataSource
myRow = t.NewRow
Dim ErrorString As String
ErrorString = "Replace this text."
' Use DataColumn.Contains to ensure the column exists
If myRow.DataTable.Columns.Contains(1) Then
   myRow.SetColumnError(1, ErrorString)
   Console.WriteLine(myRow.GetColumnError(1))
   ' Add the row
   t.Rows.Add(myRow)
End If

See Also

DataRow Class | DataRow Members | System.Data Namespace | DataRow.SetColumnError Overload List | ClearErrors | ColumnsCollection | Contains | DataColumn | Error | GetColumnsInError | HasErrors | RowError


DataRow.SetNull

Sets the specified column's value to a null value.

[Visual Basic]
Protected Sub SetNull( _
   ByVal column As DataColumn _
)
[C#]
protected void SetNull(
   DataColumn column
);
[C++]
protected: void SetNull(
   DataColumn* column
);
[JScript]
protected function SetNull(
   column : DataColumn
);

Parameters

column
A DataColumn.

Remarks

Use the IsNull method to determine if a column contains a null value.

See Also

DataRow Class | DataRow Members | System.Data Namespace


DataRowAction Enumeration

Describes the action taken on a DataRow.

[Visual Basic]
Public Enum DataRowAction
[C#]
public enum DataRowAction
[C++]
public enum DataRowAction

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

Use the members of this enumeration to determine the action that has occurred on a DataRow with respect to the DataTable it belongs to.

Members

Member Name | Description
Add | The row has been added to the table.
Change | The row was changed.
Commit | The row has been committed.
Delete | The row was deleted from the table.
Nothing | No change.
Rollback | The change has been rolled back.

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace | DataRow | DataTable


DataRowChangeEventArgs Class

Provides data for the RowChanged, RowChanging, OnRowDeleting, and OnRowDeleted events.

Object
EventArgs
DataRowChangeEventArgs

[Visual Basic]
Public Class DataRowChangeEventArgs
   Inherits EventArgs
[C#]
public class DataRowChangeEventArgs : EventArgs
[C++]
public __gc class DataRowChangeEventArgs : public EventArgs
[JScript]
public class DataRowChangeEventArgs extends EventArgs

Remarks

The RowChanged, RowChanged, RowChanged, and RowChanged events occur when an action is performed on a DataRow.

Requirements

Namespace: System.Data

Assembly: System.Data.dll

Example [Visual Basic]

The following example adds a DataRowChangeEventHandler and the procedure to handle the event when a row is changed.

[Visual Basic]

Private myTable As DataTable

Private Sub AddHandler()
   Set myTable = datagrid1.DataGridTable.DataTable
   myTable.AddOnRowChanged New System.Data.DataRowChangeEventHandler(AddressOf Me.myDataTable_Changed)
End Sub

Private Sub myDataTable_Changed(ByVal sender As System.Object, ByVal e As System.Data.DataRowChangeEventArgs)
   Debug.Print "Row Changed", e.Action, e.Row.Item(datagrid1.CurrentCell.ColumnNumber)
End Sub

See Also

DataRowChangeEventArgs Members | System.Data Namespace | OnRowChanged | OnRowChanging | OnRowDeleting | DataRow | DataRowAction | DataRowChangeEventHandler | OnRowDeleted | DataTable


DataRowChangeEventArgs Members

Public:

Constructor

DataRowChangeEventArgs Constructor Initializes a new instance of the DataRowChangeEventArgs class.

Properties

Action | Gets the action that has occurred on a DataRow.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
Row | Gets the row upon which an action has occurred.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataRowChangeEventArgs Class | System.Data Namespace


DataRowChangeEventArgs Constructor

Initializes a new instance of the DataRowChangeEventArgs class.

[Visual Basic]
Public Sub New( _
   ByVal row As DataRow, _
   ByVal action As DataRowAction _
)
[C#]
public DataRowChangeEventArgs(
   DataRow row,
   DataRowAction action
);
[C++]
public: DataRowChangeEventArgs(
   DataRow* row,
   DataRowAction action
);
[JScript]
public function DataRowChangeEventArgs(
   row : DataRow,
   action : DataRowAction
);

Parameters

row
The DataRow upon which an action is occuring.
action
[To be supplied.]

Example [Visual Basic]

The following example adds a DataRowChangeEventHandler and the procedure to handle the event when a row is changed.

[Visual Basic]

Private myTable As DataTable

Private Sub AddHandler()
   Set myTable = datagrid1.DataGridTable.DataTable
   myTable.AddOnRowChanged New System.Data.DataRowChangeEventHandler(AddressOf Me.myDataTable_Changed)
End Sub

Private Sub myDataTable_Changed(ByVal sender As System.Object, ByVal e As System.Data.DataRowChangeEventArgs)
   Debug.Print "Row Changed", e.Action, e.Row.Item(datagrid1.CurrentCell.ColumnNumber)
End Sub

See Also

DataRowChangeEventArgs Class | DataRowChangeEventArgs Members | System.Data Namespace | OnRowChanged | OnRowChanging | OnRowDeleting | DataRow | DataRowAction | DataRowChangeEventHandler | OnRowDeleted | DataTable


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataRowChangeEventArgs Properties

The properties of the DataRowChangeEventArgs class are listed below. For a complete list of DataRowChangeEventArgs class members, see the DataRowChangeEventArgs Members topic.

Public:

Action | Gets the action that has occurred on a DataRow.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
Row | Gets the row upon which an action has occurred.

See Also

DataRowChangeEventArgs Class | System.Data Namespace


DataRowChangeEventArgs.Action

Gets the action that has occurred on a DataRow.

[Visual Basic]
Public ReadOnly Property Action As DataRowAction
[C#]
public DataRowAction Action {get;}
[C++]
public: __property DataRowAction get_Action();
[JScript]
public function get Action() : DataRowAction;

Property Value

One of the DataRowAction values.

Example [Visual Basic]

The following example adds a DataRowChangeEventHandler and the procedure to handle the event when a row is changed.

[Visual Basic]

Private myTable As DataTable

Private Sub AddHandler()
   Set myTable = datagrid1.DataGridTable.DataTable
   myTable.AddOnRowChanged New System.Data.DataRowChangeEventHandler(AddressOf Me.myDataTable_Changed)
End Sub

Private Sub myDataTable_Changed(ByVal sender As System.Object, ByVal e As System.Data.DataRowChangeEventArgs)
   Debug.Print "Row Changed", e.Action, e.Row.Item(datagrid1.CurrentCell.ColumnNumber)
End Sub

See Also

DataRowChangeEventArgs Class | DataRowChangeEventArgs Members | System.Data Namespace | OnRowChanged | OnRowChanging | OnRowDeleting | DataRow | DataRowAction | DataRowChangeEventHandler | OnRowDeleted | DataTable


DataRowChangeEventArgs.Row

Gets the row upon which an action has occurred.

[Visual Basic]
Public ReadOnly Property Row As DataRow
[C#]
public DataRow Row {get;}
[C++]
public: __property DataRow* get_Row();
[JScript]
public function get Row() : DataRow;

Property Value

The DataRow upon which an action has occurred.

Example [Visual Basic]

The following example adds a DataRowChangeEventHandler and the procedure to handle the event when a row is changed.

[Visual Basic]

Private myTable As DataTable

Private Sub AddHandler()
   Set myTable = datagrid1.DataGridTable.DataTable
   myTable.AddOnRowChanged New System.Data.DataRowChangeEventHandler(AddressOf Me.myDataTable_Changed)
End Sub

Private Sub myDataTable_Changed(ByVal sender As System.Object, ByVal e As System.Data.DataRowChangeEventArgs)
   Debug.Print "Row Changed", e.Action, e.Row.Item(datagrid1.CurrentCell.ColumnNumber)
End Sub

See Also

DataRowChangeEventArgs Class | DataRowChangeEventArgs Members | System.Data Namespace | OnRowChanged | OnRowChanging | OnRowDeleting | DataRow | DataRowAction | DataRowChangeEventHandler | OnRowDeleted | DataTable


DataRowChangeEventHandler Delegate

Represents the method that will handle the OnRowChanging, OnRowChanged, OnRowDeleting, and OnRowDeleted events of a DataTable.

[Visual Basic]
Public Delegate Sub DataRowChangeEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataRowChangeEventArgs _
)
[C#]
public delegate void DataRowChangeEventHandler(
   object sender,
   DataRowChangeEventArgs e
);
[C++]
public __gc __delegate void DataRowChangeEventHandler(
   Object* sender,
   DataRowChangeEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the DataRowChangeEventHandler delegate declaration.

The source of the event.
A DataRowChangeEventArgs that contains the event data.

Remarks

When you create a DataRowChangeEventHandler delegate, you identify the method that will handle the vent. To associate the event with your event-handling method, add an instance of the delegate to the event. The event-handling method is called whenever the event occurs, until you remove the delegate. For more information about delegates, see <DelegateTopicTBD>.

Requirements

Namespace: System.Data

Assembly: System.Data.dll

Example [Visual Basic]

The following example adds a DataRowChangeEventHandler and the procedure to handle the event when a row is changed. The procedure prints the action and value of the changed row.

[Visual Basic]

Private myTable As DataTable

Private Sub AddHandler()
   Set myTable = datagrid1.DataGridTable.DataTable
   myTable.AddOnRowChanged New System.Data.DataRowChangeEventHandler(AddressOf Me.myDataTable_Changed)
End Sub

Private Sub myDataTable_Changed(ByVal sender As System.Object, ByVal e As System.Data.DataRowChangeEventArgs)
   Debug.Print "Row Changed", e.Action, e.Row.Item(datagrid1.CurrentCell.ColumnNumber)
End Sub

See Also

System.Data Namespace | DataRow | DataTable | DataRowChangeEventArgs


DataRowState Enumeration

Describes the current state of a DataRow.

[Visual Basic]
Public Enum DataRowState
[C#]
public enum DataRowState
[C++]
public enum DataRowState

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

DataRowState values are used when getting the DataRow class's TBD property.

Use the members of this enumeration to determine the state of a DataRow in a DataTable.

The table below lists each of these states:

Item | Description
Detached | The DataRow does not belong to any DataTable object's RowsCollection.
Unchanged | No changes have been made to the DataRow. since the last time either the TBD or TBD method was called.
New | The DataRow is new.
Deleted | The DataRow has been deleted from the DataTable.
Modified | The DataRow has been modified.

Members

Member Name | Description
Deleted | The row was deleted after AcceptChanges was last called.
Detached | The row has been created, but does not belong to a table.
Modified | The row was modified after AcceptChanges was last called.
New | The row was added after AcceptChanges was last called.
Unchanged | The row has not changed since AcceptChanges was last called.

Requirements

Namespace: System.Data

Assembly: System.Data.dll

Example [Visual Basic]

The following example adds a DataRowChangeEventHandler and the procedure to handle the event when a row is changed. The DataRowState is printed whenever a row changes.

[Visual Basic]

Private myTable As DataTable

Private Sub AddHandler()
   Set myTable = datagrid1.DataGridTable.DataTable
   myTable.AddOnRowChanged New System.Data.DataRowChangeEventHandler(AddressOf Me.myDataTable_Changed)
End Sub

Private Sub myDataTable_Changed(ByVal sender As System.Object, ByVal e As System.Data.DataRowChangeEventArgs)
   Debug.Print "Row Changed", e.Action, e.Row.Item(datagrid1.CurrentCell.ColumnNumber)
End Sub

See Also

System.Data Namespace | TBD | TBD | BeginEdit | DataRowChangeEventArgs | DataRowChangeEventHandler | RowState


DataRowVersion Enumeration

Describes the version of a DataRow.

[Visual Basic]
Public Enum DataRowVersion
[C#]
public enum DataRowVersion
[C++]
public enum DataRowVersion

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

The DataRowVersion values are used when retrieving the value found in a DataRow using the DataRow object's Item property (DataRow indexer)or the GetChildRows

The DataRowVersion informs you what version of a DataRow exists. Versions change under the following circumstances:

  • After calling the DataRow object's BeginEdit method, if you change the value, the Current and Proposed values become available.
  • After calling the DataRow object's CancelEdit method, the Proposed value is deleted.
  • After calling the DataRow object's EndEdit method, the Current and Original values become the Proposed value. The Proposed value is deleted.
  • After calling the DataRow object's AcceptChanges method, the Current value is now the former Proposed value; the Original value persists.
  • After calling the DataTable object's AcceptChanges method, the Original value becomes identical to the Current value.
  • After calling the DataRow object's RejectChanges,

Members

Member Name | Description
Current | The row contains current values.
Default | The row contains its default values.
Original | The row contains its original values.
Proposed | The row contains a proposed value.

Requirements

Namespace: System.Data

Assembly: System.Data.dll

Example [Visual Basic]

The following example checks the DataRowVersion of a DataRow before invoking the AcceptChanges method.

[Visual Basic]

Private Sub CheckVersionBeforeAccept()
   Dim r As DataRow
   Dim t As DataTable
   Set t = DataGrid1.DataGridTable.DataTable
   ' The user must click a cell to edit in the DataGrid control.
   Set r = t.Rows(DataGrid1.CurrentCell.RowNumber)
   r.BeginEdit
   ' Change the value of column 1 in the row.
   r(1) = Edit1.Text
   ' Compare the proposed version with the current.
   If r.HasVersion(datarowversion.Proposed) Then
      If r(1, DataRowVersion.Current) = r(1, DataRowversion.Proposed) Then
         MessageBox.Show "The original and the proposed are the same"
         r.CancelEdit
         Exit Sub
      Else
         r.AcceptChanges
         ' Print the original
      End If
   Else
      MessageBox.Show "No new values proposed"
   End If
End Sub

See Also

System.Data Namespace | AcceptChanges | BeginEdit | EndEdit | Item | RejectChanges


DataRowView Class

Represents a customized view of a DataRow.

Object
DataRowViewTypeDescriptor
DataRowView

[Visual Basic]
Public Class DataRowView
   Inherits DataRowViewTypeDescriptor
   Implements ITypedObject, IEditableObject, IDataErrorInfo
[C#]
public class DataRowView : DataRowViewTypeDescriptor, ITypedObject,
   IEditableObject, IDataErrorInfo
[C++]
public __gc class DataRowView : public DataRowViewTypeDescriptor,
   ITypedObject, IEditableObject, IDataErrorInfo
[JScript]
public class DataRowView extends DataRowViewTypeDescriptor,
   ITypedObject, IEditableObject, IDataErrorInfo

Remarks

A DataRow can have one of four different version states: Default, Original, Current, and Proposed.When reconciling data, it's important to have as much information as possible. Use the DataRowView to view only those versions which are of interest.

The DataRowView is related to the DataView. Where a DataView is a customized "view" of a table, with a custom sort,

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

DataRowView Members | System.Data Namespace | DataRow


DataRowView Members

Public:

Properties

Item | Gets or sets a specified DataRowView. In C#, this member is the indexer for the DataRowView class.
Row | Gets the row being viewed.
RowVersion | Gets the current version description of the DataRow.

Methods

BeginEdit | Begins an edit procedure.
CancelEdit | Cancels an edit procedure.
EndEdit | Ends an edit procedure.
Equals | Gets a value indicating whether the current DataRowView is identical to the specified object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataRowView Class | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataRowView Properties

The properties of the DataRowView class are listed below. For a complete list of DataRowView class members, see the DataRowView Members topic.

Public:

Item | Gets or sets a specified DataRowView. In C#, this member is the indexer for the DataRowView class.
Row | Gets the row being viewed.
RowVersion | Gets the current version description of the DataRow.

See Also

DataRowView Class | System.Data Namespace


DataRowView.Item

Gets or sets a specified DataRowView.

[C#] In C#, this member is the indexer for the DataRowView class.

[Visual Basic]
Overridable Public Default Property Item( _
   ByVal property As String _
) As Object
[C#]
public object this[
   string property
] {virtual get; virtual set;}
[C++]
public: __property virtual Object* get_Item(
   String* property
);
public: __property virtual void set_Item(
   String* property,
   Object*
);
[JScript]
returnValue = DataRowViewObject.Item(property);
DataRowViewObject.Item(property) = returnValue;
-or-
returnValue = DataRowViewObject(property);
DataRowViewObject(property) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

property
A value to be found in the desired DataRowView.

Parameters [Visual Basic, C#, C++]

property
A value to be found in the desired DataRowView.

Property Value

A DataRowView, typed as Object.

See Also

DataRowView Class | DataRowView Members | System.Data Namespace


DataRowView.Row

Gets the row being viewed.

[Visual Basic]
Public ReadOnly Property Row As DataRow
[C#]
public DataRow Row {get;}
[C++]
public: __property DataRow* get_Row();
[JScript]
public function get Row() : DataRow;

Property Value

The DataRow being viewed by the DataRowView.

See Also

DataRowView Class | DataRowView Members | System.Data Namespace | DataRowView | DataRow


DataRowView.RowVersion

Gets the current version description of the DataRow.

[Visual Basic]
Public ReadOnly Property RowVersion As DataRowVersion
[C#]
public DataRowVersion RowVersion {get;}
[C++]
public: __property DataRowVersion get_RowVersion();
[JScript]
public function get RowVersion() : DataRowVersion;

Property Value

One of the DataRowVersion values.

Remarks

Possible values for the RowVersion property are: Default, Original, Current, and Proposed. For more details, see DataRowVersion.

Example [Visual Basic]

The following example uses the RowVersion property to determine the state of a row in the DataRowView.

[Visual Basic]

Private Sub ShowVersions(dv As DataView)

See Also

DataRowView Class | DataRowView Members | System.Data Namespace | AcceptChanges | BeginEdit | DataRowVersion | EndEdit


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataRowView Methods

The methods of the DataRowView class are listed below. For a complete list of DataRowView class members, see the DataRowView Members topic.

Public:

BeginEdit | Begins an edit procedure.
CancelEdit | Cancels an edit procedure.
EndEdit | Ends an edit procedure.
Equals | Gets a value indicating whether the current DataRowView is identical to the specified object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataRowView Class | System.Data Namespace


DataRowView.BeginEdit

Begins an edit procedure.

[Visual Basic]
Overridable Public Sub BeginEdit()
[C#]
public virtual void BeginEdit();
[C++]
public: virtual void BeginEdit();
[JScript]
public function BeginEdit();

Remarks

When invoked, the BeginEdit method places the DataRow into a state in which both the original version of the data exists along with the current data. If you invoke CancelEdit, the changes are rejected, and the original data reinstated. If you invoke EndEdit, the state changes

Example [Visual Basic]

The following example edits a row in a DataView. calling the BeginEdit before, and EndEdit afterwards.

[Visual Basic]

Private Sub EditRow(dv As DataView)
   dv.AllowEdit = True
   dv(0).BeginEdit
   dv(0)("FirstName") = "Mary"
   dv(0)("LastName") = "Jones"
   dv(0).EndEdit
End Sub

See Also

DataRowView Class | DataRowView Members | System.Data Namespace | AcceptChanges | AllowDelete | AllowEdit | AllowNew | CancelEdit | DataRow | EndEdit


DataRowView.CancelEdit

Cancels an edit procedure.

[Visual Basic]
Overridable Public Sub CancelEdit()
[C#]
public virtual void CancelEdit();
[C++]
public: virtual void CancelEdit();
[JScript]
public function CancelEdit();

Example [Visual Basic]

The following example edits a row in a DataView. The CancelEdit method is called to cancel the changes.

[Visual Basic]

Private Sub EditRow(dv As DataView)
   dv.AllowEdit = True
   dv(0).BeginEdit
   dv(0)("FirstName") = "Mary"
   dv(0)("LastName") = "Jones"
   ' Cancel the edit.
   dv(0).CancelEdit
End Sub

See Also

DataRowView Class | DataRowView Members | System.Data Namespace | AcceptChanges | AllowDelete | AllowEdit | AllowNew | BeginEdit | DataRow | EndEdit


DataRowView.EndEdit

Ends an edit procedure.

[Visual Basic]
Overridable Public Sub EndEdit()
[C#]
public virtual void EndEdit();
[C++]
public: virtual void EndEdit();
[JScript]
public function EndEdit();

Example [Visual Basic]

The following example edits a row in a DataView. calling the BeginEdit before, and EndEdit afterwards.

[Visual Basic]

Private Sub EditRow(dv As DataView)
   dv.AllowEdit = True
   dv(0).BeginEdit
   dv(0)("FirstName") = "Mary"
   dv(0)("LastName") = "Jones"
   dv(0).EndEdit
End Sub

See Also

DataRowView Class | DataRowView Members | System.Data Namespace | AcceptChanges | AllowDelete | AllowEdit | AllowNew | CancelEdit | DataRow | BeginEdit


DataRowView.Equals

Gets a value indicating whether the current DataRowView is identical to the specified object.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal other As Object _
) As Boolean
[C#]
public override bool Equals(
   object other
);
[C++]
public: override bool Equals(
   Object* other
);
[JScript]
public override function Equals(
   other : Object
) : Boolean;

Parameters

other
An Object to be compared.

Return Value

true, if object is a DataRowView and it returns the same row as the current DataRowView; otherwise, false.

Example [Visual Basic]

[Visual Basic]

Private Sub TestRowView()
   Dim drv As DataRowView

See Also

DataRowView Class | DataRowView Members | System.Data Namespace


DataRowViewColumnDescriptor Class

[To be supplied.]

Object
MemberDescriptor
PropertyDescriptor
DataRowViewColumnDescriptor

[Visual Basic]
Public Class DataRowViewColumnDescriptor
   Inherits PropertyDescriptor
[C#]
public class DataRowViewColumnDescriptor : PropertyDescriptor
[C++]
public __gc class DataRowViewColumnDescriptor : public
   PropertyDescriptor
[JScript]
public class DataRowViewColumnDescriptor extends PropertyDescriptor

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

DataRowViewColumnDescriptor Members | System.Data Namespace


DataRowViewColumnDescriptor Members

Public:

Properties

Attributes (inherited from MemberDescriptor) | Gets the collection of attributes for this member.
Category (inherited from MemberDescriptor) | Gets the name of the category that the member belongs to, as specified in the CategoryAttribute.
Column | [To be supplied.]
ComponentType | [To be supplied.]
Converter (inherited from PropertyDescriptor) | Gets the type converter for this property.
Description (inherited from MemberDescriptor) | Gets the description of the member as specified in the DescriptionAttribute.
IsBrowsable (inherited from MemberDescriptor) | Gets a value indicating whether the member is browsable as specified in the BrowsableAttribute.
IsLocalizable (inherited from PropertyDescriptor) | Gets a value indicating whether this property should be localized, as specified in the LocalizableAttribute.
IsReadOnly | [To be supplied.]
IsRealProperty | [To be supplied.]
Name (inherited from MemberDescriptor) | Gets the name of the member.
PersistableSupport (inherited from PropertyDescriptor) | Gets a value indicating whether this property should be persisted as specified in the PersistableAttribute.
PropertyType | [To be supplied.]

Methods

CanResetValue | [To be supplied.]
Equals | [To be supplied.]
GetDesignTimeOnly (inherited from MemberDescriptor) | Determines whether this member should be set only at design time as specified in the DesignOnlyAttribute.
GetDisplayName (inherited from MemberDescriptor) | Gets the name that can be displayed in a window like a property browser.
GetEditor (inherited from PropertyDescriptor) | Gets an editor of the specified type.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHelpTopic (inherited from MemberDescriptor) | Gets the name of the Help topic specified in the HelpAttribute.
GetHelpURL (inherited from MemberDescriptor) | Gets the URL for the Help file specified in the HelpAttribute.
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | [To be supplied.]
ResetValue | [To be supplied.]
SetValue | [To be supplied.]
ShouldPersistValue | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

AttributeArray (inherited from MemberDescriptor) | Gets or sets an array of attributes.
NameHashCode (inherited from MemberDescriptor) | Gets the hash code for the name of the member as specified in GetHashCode.

Methods

CreateAttributeCollection (inherited from MemberDescriptor) | Creates a collection of attributes using the array of attributes that you passed to the constructor.
CreateInstance (inherited from PropertyDescriptor) | Creates an instance of the specified type.
FillAttributes (inherited from MemberDescriptor) | In an inheriting class, adds the attributes of the inheriting class to the specified list of attributes in the parent class.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataRowViewColumnDescriptor Class | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataRowViewColumnDescriptor Properties

The properties of the DataRowViewColumnDescriptor class are listed below. For a complete list of DataRowViewColumnDescriptor class members, see the DataRowViewColumnDescriptor Members topic.

Public:

Attributes (inherited from MemberDescriptor) | Gets the collection of attributes for this member.
Category (inherited from MemberDescriptor) | Gets the name of the category that the member belongs to, as specified in the CategoryAttribute.
Column | [To be supplied.]
ComponentType | [To be supplied.]
Converter (inherited from PropertyDescriptor) | Gets the type converter for this property.
Description (inherited from MemberDescriptor) | Gets the description of the member as specified in the DescriptionAttribute.
IsBrowsable (inherited from MemberDescriptor) | Gets a value indicating whether the member is browsable as specified in the BrowsableAttribute.
IsLocalizable (inherited from PropertyDescriptor) | Gets a value indicating whether this property should be localized, as specified in the LocalizableAttribute.
IsReadOnly | [To be supplied.]
IsRealProperty | [To be supplied.]
Name (inherited from MemberDescriptor) | Gets the name of the member.
PersistableSupport (inherited from PropertyDescriptor) | Gets a value indicating whether this property should be persisted as specified in the PersistableAttribute.
PropertyType | [To be supplied.]

Protected:

AttributeArray (inherited from MemberDescriptor) | Gets or sets an array of attributes.
NameHashCode (inherited from MemberDescriptor) | Gets the hash code for the name of the member as specified in GetHashCode.

See Also

DataRowViewColumnDescriptor Class | System.Data Namespace


DataRowViewColumnDescriptor.Column

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Column As DataColumn
[C#]
public DataColumn Column {get;}
[C++]
public: __property DataColumn* get_Column();
[JScript]
public function get Column() : DataColumn;

See Also

DataRowViewColumnDescriptor Class | DataRowViewColumnDescriptor Members | System.Data Namespace


DataRowViewColumnDescriptor.ComponentType

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property ComponentType As Type
[C#]
public Type ComponentType {override get;}
[C++]
public: __property virtual Type* get_ComponentType();
[JScript]
public function get ComponentType() : Type;

See Also

DataRowViewColumnDescriptor Class | DataRowViewColumnDescriptor Members | System.Data Namespace


DataRowViewColumnDescriptor.IsReadOnly

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {override get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;

See Also

DataRowViewColumnDescriptor Class | DataRowViewColumnDescriptor Members | System.Data Namespace


DataRowViewColumnDescriptor.IsRealProperty

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsRealProperty As Boolean
[C#]
public bool IsRealProperty {override get;}
[C++]
public: __property virtual bool get_IsRealProperty();
[JScript]
public function get IsRealProperty() : Boolean;

See Also

DataRowViewColumnDescriptor Class | DataRowViewColumnDescriptor Members | System.Data Namespace


DataRowViewColumnDescriptor.PropertyType

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property PropertyType As Type
[C#]
public Type PropertyType {override get;}
[C++]
public: __property virtual Type* get_PropertyType();
[JScript]
public function get PropertyType() : Type;

See Also

DataRowViewColumnDescriptor Class | DataRowViewColumnDescriptor Members | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataRowViewColumnDescriptor Methods

The methods of the DataRowViewColumnDescriptor class are listed below. For a complete list of DataRowViewColumnDescriptor class members, see the DataRowViewColumnDescriptor Members topic.

Public:

CanResetValue | [To be supplied.]
Equals | [To be supplied.]
GetDesignTimeOnly (inherited from MemberDescriptor) | Determines whether this member should be set only at design time as specified in the DesignOnlyAttribute.
GetDisplayName (inherited from MemberDescriptor) | Gets the name that can be displayed in a window like a property browser.
GetEditor (inherited from PropertyDescriptor) | Gets an editor of the specified type.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHelpTopic (inherited from MemberDescriptor) | Gets the name of the Help topic specified in the HelpAttribute.
GetHelpURL (inherited from MemberDescriptor) | Gets the URL for the Help file specified in the HelpAttribute.
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | [To be supplied.]
ResetValue | [To be supplied.]
SetValue | [To be supplied.]
ShouldPersistValue | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

CreateAttributeCollection (inherited from MemberDescriptor) | Creates a collection of attributes using the array of attributes that you passed to the constructor.
CreateInstance (inherited from PropertyDescriptor) | Creates an instance of the specified type.
FillAttributes (inherited from MemberDescriptor) | In an inheriting class, adds the attributes of the inheriting class to the specified list of attributes in the parent class.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataRowViewColumnDescriptor Class | System.Data Namespace


DataRowViewColumnDescriptor.CanResetValue

[To be supplied.]

[Visual Basic]
Overrides Public Function CanResetValue( _
   ByVal component As Object _
) As Boolean
[C#]
public override bool CanResetValue(
   object component
);
[C++]
public: override bool CanResetValue(
   Object* component
);
[JScript]
public override function CanResetValue(
   component : Object
) : Boolean;

Parameters

component
[To be supplied.]

See Also

DataRowViewColumnDescriptor Class | DataRowViewColumnDescriptor Members | System.Data Namespace


DataRowViewColumnDescriptor.Equals

[To be supplied.]

[Visual Basic]
Overrides Public Function Equals( _
   ByVal other As Object _
) As Boolean
[C#]
public override bool Equals(
   object other
);
[C++]
public: override bool Equals(
   Object* other
);
[JScript]
public override function Equals(
   other : Object
) : Boolean;

Parameters

other
[To be supplied.]

See Also

DataRowViewColumnDescriptor Class | DataRowViewColumnDescriptor Members | System.Data Namespace


DataRowViewColumnDescriptor.GetValue

[To be supplied.]

[Visual Basic]
Overrides Public Function GetValue( _
   ByVal component As Object _
) As Object
[C#]
public override object GetValue(
   object component
);
[C++]
public: override Object* GetValue(
   Object* component
);
[JScript]
public override function GetValue(
   component : Object
) : Object;

Parameters

component
[To be supplied.]

See Also

DataRowViewColumnDescriptor Class | DataRowViewColumnDescriptor Members | System.Data Namespace


DataRowViewColumnDescriptor.ResetValue

[To be supplied.]

[Visual Basic]
Overrides Public Sub ResetValue( _
   ByVal component As Object _
)
[C#]
public override void ResetValue(
   object component
);
[C++]
public: override void ResetValue(
   Object* component
);
[JScript]
public override function ResetValue(
   component : Object
);

Parameters

component
[To be supplied.]

See Also

DataRowViewColumnDescriptor Class | DataRowViewColumnDescriptor Members | System.Data Namespace


DataRowViewColumnDescriptor.SetValue

[To be supplied.]

[Visual Basic]
Overrides Public Sub SetValue( _
   ByVal component As Object, _
   ByVal value As Object _
)
[C#]
public override void SetValue(
   object component,
   object value
);
[C++]
public: override void SetValue(
   Object* component,
   Object* value
);
[JScript]
public override function SetValue(
   component : Object,
   value : Object
);

Parameters

component
[To be supplied.]
value
[To be supplied.]

See Also

DataRowViewColumnDescriptor Class | DataRowViewColumnDescriptor Members | System.Data Namespace


DataRowViewColumnDescriptor.ShouldPersistValue

[To be supplied.]

[Visual Basic]
Overrides Public Function ShouldPersistValue( _
   ByVal component As Object _
) As Boolean
[C#]
public override bool ShouldPersistValue(
   object component
);
[C++]
public: override bool ShouldPersistValue(
   Object* component
);
[JScript]
public override function ShouldPersistValue(
   component : Object
) : Boolean;

Parameters

component
[To be supplied.]

See Also

DataRowViewColumnDescriptor Class | DataRowViewColumnDescriptor Members | System.Data Namespace


DataRowViewRelationDescriptor Class

[To be supplied.]

Object
MemberDescriptor
PropertyDescriptor
DataRowViewRelationDescriptor

[Visual Basic]
Public Class DataRowViewRelationDescriptor
   Inherits PropertyDescriptor
[C#]
public class DataRowViewRelationDescriptor : PropertyDescriptor
[C++]
public __gc class DataRowViewRelationDescriptor : public
   PropertyDescriptor
[JScript]
public class DataRowViewRelationDescriptor extends
   PropertyDescriptor

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

DataRowViewRelationDescriptor Members | System.Data Namespace


DataRowViewRelationDescriptor Members

Public:

Properties

Attributes (inherited from MemberDescriptor) | Gets the collection of attributes for this member.
Category (inherited from MemberDescriptor) | Gets the name of the category that the member belongs to, as specified in the CategoryAttribute.
ComponentType | [To be supplied.]
Converter (inherited from PropertyDescriptor) | Gets the type converter for this property.
Description (inherited from MemberDescriptor) | Gets the description of the member as specified in the DescriptionAttribute.
IsBrowsable (inherited from MemberDescriptor) | Gets a value indicating whether the member is browsable as specified in the BrowsableAttribute.
IsLocalizable (inherited from PropertyDescriptor) | Gets a value indicating whether this property should be localized, as specified in the LocalizableAttribute.
IsReadOnly | [To be supplied.]
IsRealProperty | [To be supplied.]
Name (inherited from MemberDescriptor) | Gets the name of the member.
PersistableSupport (inherited from PropertyDescriptor) | Gets a value indicating whether this property should be persisted as specified in the PersistableAttribute.
PropertyType | [To be supplied.]
Relation | [To be supplied.]

Methods

CanResetValue | [To be supplied.]
Equals | [To be supplied.]
GetDesignTimeOnly (inherited from MemberDescriptor) | Determines whether this member should be set only at design time as specified in the DesignOnlyAttribute.
GetDisplayName (inherited from MemberDescriptor) | Gets the name that can be displayed in a window like a property browser.
GetEditor (inherited from PropertyDescriptor) | Gets an editor of the specified type.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHelpTopic (inherited from MemberDescriptor) | Gets the name of the Help topic specified in the HelpAttribute.
GetHelpURL (inherited from MemberDescriptor) | Gets the URL for the Help file specified in the HelpAttribute.
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | [To be supplied.]
ResetValue | [To be supplied.]
SetValue | [To be supplied.]
ShouldPersistValue | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

AttributeArray (inherited from MemberDescriptor) | Gets or sets an array of attributes.
NameHashCode (inherited from MemberDescriptor) | Gets the hash code for the name of the member as specified in GetHashCode.

Methods

CreateAttributeCollection (inherited from MemberDescriptor) | Creates a collection of attributes using the array of attributes that you passed to the constructor.
CreateInstance (inherited from PropertyDescriptor) | Creates an instance of the specified type.
FillAttributes (inherited from MemberDescriptor) | In an inheriting class, adds the attributes of the inheriting class to the specified list of attributes in the parent class.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataRowViewRelationDescriptor Class | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataRowViewRelationDescriptor Properties

The properties of the DataRowViewRelationDescriptor class are listed below. For a complete list of DataRowViewRelationDescriptor class members, see the DataRowViewRelationDescriptor Members topic.

Public:

Attributes (inherited from MemberDescriptor) | Gets the collection of attributes for this member.
Category (inherited from MemberDescriptor) | Gets the name of the category that the member belongs to, as specified in the CategoryAttribute.
ComponentType | [To be supplied.]
Converter (inherited from PropertyDescriptor) | Gets the type converter for this property.
Description (inherited from MemberDescriptor) | Gets the description of the member as specified in the DescriptionAttribute.
IsBrowsable (inherited from MemberDescriptor) | Gets a value indicating whether the member is browsable as specified in the BrowsableAttribute.
IsLocalizable (inherited from PropertyDescriptor) | Gets a value indicating whether this property should be localized, as specified in the LocalizableAttribute.
IsReadOnly | [To be supplied.]
IsRealProperty | [To be supplied.]
Name (inherited from MemberDescriptor) | Gets the name of the member.
PersistableSupport (inherited from PropertyDescriptor) | Gets a value indicating whether this property should be persisted as specified in the PersistableAttribute.
PropertyType | [To be supplied.]
Relation | [To be supplied.]

Protected:

AttributeArray (inherited from MemberDescriptor) | Gets or sets an array of attributes.
NameHashCode (inherited from MemberDescriptor) | Gets the hash code for the name of the member as specified in GetHashCode.

See Also

DataRowViewRelationDescriptor Class | System.Data Namespace


DataRowViewRelationDescriptor.ComponentType

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property ComponentType As Type
[C#]
public Type ComponentType {override get;}
[C++]
public: __property virtual Type* get_ComponentType();
[JScript]
public function get ComponentType() : Type;

See Also

DataRowViewRelationDescriptor Class | DataRowViewRelationDescriptor Members | System.Data Namespace


DataRowViewRelationDescriptor.IsReadOnly

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {override get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;

See Also

DataRowViewRelationDescriptor Class | DataRowViewRelationDescriptor Members | System.Data Namespace


DataRowViewRelationDescriptor.IsRealProperty

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsRealProperty As Boolean
[C#]
public bool IsRealProperty {override get;}
[C++]
public: __property virtual bool get_IsRealProperty();
[JScript]
public function get IsRealProperty() : Boolean;

See Also

DataRowViewRelationDescriptor Class | DataRowViewRelationDescriptor Members | System.Data Namespace


DataRowViewRelationDescriptor.PropertyType

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property PropertyType As Type
[C#]
public Type PropertyType {override get;}
[C++]
public: __property virtual Type* get_PropertyType();
[JScript]
public function get PropertyType() : Type;

See Also

DataRowViewRelationDescriptor Class | DataRowViewRelationDescriptor Members | System.Data Namespace


DataRowViewRelationDescriptor.Relation

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Relation As DataRelation
[C#]
public DataRelation Relation {get;}
[C++]
public: __property DataRelation* get_Relation();
[JScript]
public function get Relation() : DataRelation;

See Also

DataRowViewRelationDescriptor Class | DataRowViewRelationDescriptor Members | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataRowViewRelationDescriptor Methods

The methods of the DataRowViewRelationDescriptor class are listed below. For a complete list of DataRowViewRelationDescriptor class members, see the DataRowViewRelationDescriptor Members topic.

Public:

CanResetValue | [To be supplied.]
Equals | [To be supplied.]
GetDesignTimeOnly (inherited from MemberDescriptor) | Determines whether this member should be set only at design time as specified in the DesignOnlyAttribute.
GetDisplayName (inherited from MemberDescriptor) | Gets the name that can be displayed in a window like a property browser.
GetEditor (inherited from PropertyDescriptor) | Gets an editor of the specified type.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHelpTopic (inherited from MemberDescriptor) | Gets the name of the Help topic specified in the HelpAttribute.
GetHelpURL (inherited from MemberDescriptor) | Gets the URL for the Help file specified in the HelpAttribute.
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | [To be supplied.]
ResetValue | [To be supplied.]
SetValue | [To be supplied.]
ShouldPersistValue | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

CreateAttributeCollection (inherited from MemberDescriptor) | Creates a collection of attributes using the array of attributes that you passed to the constructor.
CreateInstance (inherited from PropertyDescriptor) | Creates an instance of the specified type.
FillAttributes (inherited from MemberDescriptor) | In an inheriting class, adds the attributes of the inheriting class to the specified list of attributes in the parent class.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataRowViewRelationDescriptor Class | System.Data Namespace


DataRowViewRelationDescriptor.CanResetValue

[To be supplied.]

[Visual Basic]
Overrides Public Function CanResetValue( _
   ByVal component As Object _
) As Boolean
[C#]
public override bool CanResetValue(
   object component
);
[C++]
public: override bool CanResetValue(
   Object* component
);
[JScript]
public override function CanResetValue(
   component : Object
) : Boolean;

Parameters

component
[To be supplied.]

See Also

DataRowViewRelationDescriptor Class | DataRowViewRelationDescriptor Members | System.Data Namespace


DataRowViewRelationDescriptor.Equals

[To be supplied.]

[Visual Basic]
Overrides Public Function Equals( _
   ByVal other As Object _
) As Boolean
[C#]
public override bool Equals(
   object other
);
[C++]
public: override bool Equals(
   Object* other
);
[JScript]
public override function Equals(
   other : Object
) : Boolean;

Parameters

other
[To be supplied.]

See Also

DataRowViewRelationDescriptor Class | DataRowViewRelationDescriptor Members | System.Data Namespace


DataRowViewRelationDescriptor.GetValue

[To be supplied.]

[Visual Basic]
Overrides Public Function GetValue( _
   ByVal component As Object _
) As Object
[C#]
public override object GetValue(
   object component
);
[C++]
public: override Object* GetValue(
   Object* component
);
[JScript]
public override function GetValue(
   component : Object
) : Object;

Parameters

component
[To be supplied.]

See Also

DataRowViewRelationDescriptor Class | DataRowViewRelationDescriptor Members | System.Data Namespace


DataRowViewRelationDescriptor.ResetValue

[To be supplied.]

[Visual Basic]
Overrides Public Sub ResetValue( _
   ByVal component As Object _
)
[C#]
public override void ResetValue(
   object component
);
[C++]
public: override void ResetValue(
   Object* component
);
[JScript]
public override function ResetValue(
   component : Object
);

Parameters

component
[To be supplied.]

See Also

DataRowViewRelationDescriptor Class | DataRowViewRelationDescriptor Members | System.Data Namespace


DataRowViewRelationDescriptor.SetValue

[To be supplied.]

[Visual Basic]
Overrides Public Sub SetValue( _
   ByVal component As Object, _
   ByVal value As Object _
)
[C#]
public override void SetValue(
   object component,
   object value
);
[C++]
public: override void SetValue(
   Object* component,
   Object* value
);
[JScript]
public override function SetValue(
   component : Object,
   value : Object
);

Parameters

component
[To be supplied.]
value
[To be supplied.]

See Also

DataRowViewRelationDescriptor Class | DataRowViewRelationDescriptor Members | System.Data Namespace


DataRowViewRelationDescriptor.ShouldPersistValue

[To be supplied.]

[Visual Basic]
Overrides Public Function ShouldPersistValue( _
   ByVal component As Object _
) As Boolean
[C#]
public override bool ShouldPersistValue(
   object component
);
[C++]
public: override bool ShouldPersistValue(
   Object* component
);
[JScript]
public override function ShouldPersistValue(
   component : Object
) : Boolean;

Parameters

component
[To be supplied.]

See Also

DataRowViewRelationDescriptor Class | DataRowViewRelationDescriptor Members | System.Data Namespace


DataRowViewTypeDescriptor Class

[To be supplied.]

Object
DataRowViewTypeDescriptor

[Visual Basic]
Public Class DataRowViewTypeDescriptor
   Implements ICustomTypeDescriptor
[C#]
public class DataRowViewTypeDescriptor : ICustomTypeDescriptor
[C++]
public __gc class DataRowViewTypeDescriptor : public
   ICustomTypeDescriptor
[JScript]
public class DataRowViewTypeDescriptor implements
   ICustomTypeDescriptor

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

DataRowViewTypeDescriptor Members | System.Data Namespace


DataRowViewTypeDescriptor Members

Public:

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataRowViewTypeDescriptor Class | System.Data Namespace


DataSet Class

Represents an in-memory cache of data.

Object
Component
DataSet

[Visual Basic]
Public Class DataSet
   Inherits Component
   Implements IListSource
[C#]
public class DataSet : Component, IListSource
[C++]
public __gc class DataSet : public Component, IListSource
[JScript]
public class DataSet extends Component, IListSource

Remarks

The DataSet is a major component of the ADO+ architecture. It can be helpful to consider it an in-memory cache of data retrieved from a database. The DataSet consists of a collection of tables, relationships, and constraints. DataTable objects can be related to each other through DataRelation objects. UniqueConstraint and ForeignKeyConstraint objects ensure data integrity by enforcing data-specific rules.

In a stereotypical implementation, the steps would proceed in this manner:

  1. Build and fill each table in a DataSet with data from a DBMS using a SQLDataSetCommand or ADODataSetCommand.
  2. Change the data in individual DataTable objects by adding, updating, or deleting DataRow objects.
  3. Invoke the GetChanges method to create a second DataSet that features only the changes to the data.
  4. Check for errors in the second DataSet by examining its HasErrors property which informs you if any table in the set has errors.
  5. If errors are present, check the HasErrors property of each DataTable. If the table has errors, invoke the DataTable class's GetErrors method to return an array of DataRow objects with errors.
  6. On each DataRow examine the RowError property for specific data.
  7. Reconcile the errors, if possible.
  8. Invoke the Merge method to merge the changes from the second DataSet into the first.
  9. Call the System.Data.DBDataSetCommand.Update method of the System.Data.SQLDataSetCommand (or System.Data.ADODataSetCommand), passing the merged DataSet as an argument.
  10. Invoke the AcceptChanges on the DataSet. Alternatively, invoke RejectChanges to cancel the changes.

While DataTable objects contain the actual data, the RelationsCollection allows you to navigate though the table hierarchy. The tables are contained in a TablesCollection accessed through the Tables property.

A DataSet persists and depersists data as XML documents. Because of this, the data can be transported across HTTP and used by any application, on any platform, that is XML-enabled.

In an application where more than one view of a DataSet is needed, create a DataSetView with customized TableSetting objects. To customize the view of the current DataSet, add TableSetting objects to the DataSetView returned by the DefaultView property.

If you use the Visual Studio Class Designer, classes are automatically created that derive from DataSet, DataTable, and DataRow. With such a set of derived classes, the methods and properties are retained, but custom methods are generated to help you easily navigate through the tables of the DataSet.

For example, the generic Visual Basic code below:

' Get the DataTable named Customers.
Dim myTable As DataTable
myTable = DataSet1.Tables("Customers")

becomes

' A class named Customers, derived from DataTable.
Dim CustTable As Customers
CustTable = DataSet1.Customers

Methods are also created for adding new rows. For example, to add a row with a generic DataSet:

Dim myNewRow As DataRow
myNewRow = DataSet1.Tables("Customers").NewRow
myNewRow("fName") = "John"
myNewRow("lName")= "Smith"
DataSet1.Tables("Customers").Rows.Add(myNewRow)

With a derived class:

DataSet1.Customers.AddCustomerRow("John", "Smith")

The a FindRow method is also created. In a generic DataSet, this code:

Dim foundRow As DataRow
foundRow = DataSet1.Tables("Customers").FindRows("Name","Bob")

becomes

Dim foundRow As DataRow
foundRow = DataSet1.Customers.FindByName("Bob")

Requirements

Namespace: System.Data

Assembly: System.Data.dll

Example [Visual Basic]

The following example consists of several methods that work together to create and fill a DataSet from the Northwind database installed as a sample database with SQLServer 7.

[Visual Basic]

Private Sub GetSupplierProducts()
   ' 1 Create the connection using a function named CreateConnection.
   Dim cn As SQL.SQLConnection = CreateConnection _
   ("Provider=SQLOLEDB.1;Persist Security Info = False;" & _
   "Initial Catalog = Northwind;Data Source = corp;User ID = sa;")
   ' NOTE: you can also use an ADO.ADOConnection to create a connection.

    ' 2 Create a DataSet.
   Dim myDS As New DataSet
   myDS.DataSetName = "SuppliersProducts"

   ' 3 Create a SQL Command. Set ActiveConnection and CommandText.
   Dim CmdText As String
   SQLCommand = "SELECT * FROM Suppliers"
   Dim SQLcmd As SQL.SQLCommand = CreateCommand(cn, SQLCommand)

   ' 4 Create and configure SQLDataSetCommand.
   Dim SQLdsCmd As SQL.SQLDataSetCommand = New SQL.SQLDataSetCommand
   SQLdsCmd.SelectCommand = SQLcmd
   ' Add a DataTableMapping to ADODataSetCommand.
   SQLdsCmd.TableMappings.Add "Table", "Suppliers"
   ' Invoke FillDataSet
   dscmd.FillDataSet myDS

   ' Get second table.
   Dim c2 As ADO.ADOCommand = New ADO.ADOCommand
   Dim dsCmd2 As ADO.ADODataSetCommand = New ADO.ADODataSetCommand
   ' Use the same connection.
   c2.ActiveConnection = cn
   c2.CommandText = "SELECT * FROM Products"
   dscmd2.SelectCommand = c2

   dscmd2.TableMappings.Add("Table", "Products")
   dscmd2.FillDataSet myDS

   ' Create a relation
   Dim r As DataRelation
   r = New DataRelation("suppliers2products", myDS.Tables("Suppliers").Columns("SupplierID"), myDS.Tables("Products").Columns("SupplierID"))
   myDS.Relations.Add(r)

   ' Create DataView
   Dim dv As DataView
   dv = New DataView(myds.Tables(0))
   Dim t As DataTable
   t = dv.Table

   dv.Begin
  ' Bind DataGrid to DataSource and invoke PopulateColumns.
   DataGrid1.DataSource = dv
   DataGrid1.Text = "Suppliers And Products"
   DataGrid1.PopulateColumns
End Sub

Private Function CreateConnection(cnStg) As SQL.SQLConnection
   ' 1 Create the connection.
   Dim connString As String
   connString = cnStg
   Dim cn As SQL.SQLConnection = New SQL.SQLConnection(connString)
   cn.Open ' Open the connection.
   CreateConnection = cn
End Function

Private Function CreateCommand(cn As SQL.SQLConnection, selString As String) As SQL.SQLCommand
    Dim c As SQL.SQLCommand = New SQL.SQLCommand
    c.ActiveConnection = cn
    c.CommandText = selString
    CreateCommand = c
End Function

See Also

DataSet Members | System.Data Namespace | ADODataSetCommand | DataTable | DataRelation | DataRow | DataSetView | DataView | SQLDataSetCommand | ForeignKeyConstraint | UniqueConstraint


DataSet Members

Public:

Constructor

DataSet Constructor Overloaded. Initializes a new instance of the DataSet class.

Properties

CaseSensitive | Gets or sets a value indicating whether string comparisons within DataTable objects are case-sensitive.
DataSetName | Gets or sets the name of this DataSet.
DefaultView | Gets a custom "view" of the data contained by the DataSet, one that allows filtering, searching, and navigating through the custom data view.
EnforceConstraints | Gets or sets a value indicating whether constraint rules are followed when attempting any update operation.
ExtendedProperties | Gets the collection of custom user information.
HasErrors | Gets a value indicating whether there are errors in any of the rows in any of the tables of this DataSet.
Locale | Gets or sets the locale information used to compare strings within the table.
Relations | Get the collection of relations that link tables, and allow navigation from parent tables to child tables.
Site (inherited from Component) | Gets or sets the site of the Component.
Tables | Gets the collection of tables contained in the DataSet.
Xml | Gets or sets the XML data for the DataSet.
XmlData | Gets or sets the XML data for the DataSet.
XmlDocument | Gets the XML document for the DataSet.
XmlSchema | Gets or sets the XML schema of the DataSet.

Methods

AcceptChanges | Commits all the changes made to this DataSet since it was loaded or the last time AcceptChanges was called.
Clear | Clears the DataSet of any data by removing all rows in all tables.
Clone | Clones the structure of the DataSet, including all DataTable schemas, relations, and constraints.
Copy | Copies both the structure and data for this DataSet.
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetChanges | Overloaded. Returns a copy of the DataSet containing all changes made to it since it was last loaded, or since AcceptChanges was called.
GetChildRelations | Gets the collection of child relations which belong to a specified table.
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParentRelations | Gets the collection of parent relations which belong to a specified table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
HasChanges | Overloaded. Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows.
InferSchema | Overloaded. Instructs the DataSet to infer a schema from a source.
LoadDiffGram | Loads a specially formatted XML document that includes all changes, including before and after data, from a IDataReader.
Merge | Overloaded. Merges this DataSet into a specified DataSet.
ReadDiffGram | Overloaded. Reads a specially formatted XML document that includes all changes, including before and after data.
RejectChanges | This method rolls back all the changes to have been made to this DataSet since it was loaded or the last time AcceptChanges was called. Any rows still in edit-mode cancel their edits. New rows get removed. Modified and Deleted rows return back to their original state.
ResetLocale | Resets the Locale property to the current system locale.
ResetRelations | Clears the collection of relations.
ResetTables | [To be supplied.]
SaveDiffGram | Saves a specially formatted XML document that includes all changes, including before and after data, to a specified TextWriter.
ShouldPersistLocale | Indicates whether the locale property should be persisted. This is true if the user ever explicitly sets the locale property and doesn't call ResetLocale.
ShouldPersistRelations | [To be supplied.]
ShouldPersistTables | [To be supplied.]
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
WriteDiffGram | Writes a specially formatted XML document that includes all changes, including before and after data, into the specfied XmlWriter.

Events

MergeFailed | Occurs when attempting to merge schemas for two tables with the same name.
PropertyChanged | Occurs when a property value changes.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanged | Raises the PropertyChanged event.
OnRemoveRelation | This method should be overriden by subclasses to restrict tables being removed.
OnRemoveTable | This method should be overriden by subclasses to restrict tables being removed.
RaisePropertyChanged | Raises the property changed event. This creates the needed event data and then calls OnPropertyChanged.

Event Hookup:

Methods

AddOnMergeFailed | Adds an event handler for the MergeFailed event.
AddOnPropertyChanged | Adds an event handler for the OnPropertyChanged event.
RemoveOnMergeFailed | Removes an event handler for the merge failed event. This event occurs when Merge failed for any reason.
RemoveOnPropertyChanged | Removes an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.

See Also

DataSet Class | System.Data Namespace


DataSet Constructor

Initializes a new instance of the DataSet class.

Overload List

Initializes a new instance of the DataSet class.

[Visual Basic] Overloads Public Sub New()
[C#] public DataSet();
[C++] public: DataSet();
[JScript] public function DataSet();

Initializes a new instance of a DataSet class with the given name.

[Visual Basic] Overloads Public Sub New(String)
[C#] public DataSet(String);
[C++] public: DataSet(String*);
[JScript] public function DataSet(String);

Example [Visual Basic]

The following example creates a new DataSet, to which is added two DataTable objects.

Note This example shows how to use one of the overloaded version of the DataSet constructor. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub CreateDataSet()
   Dim ds As DataSet
   ds = New DataSet("aNewDataSet")
   ' Create two DataTable objects using a function.
   Dim t1 As DataTable = MakeTable("idTable1", "thing1")
   Dim t2 As DataTable = MakeTable("idTable2", "thing2")
   ds.Tables.Add(t1)
   ds.Tables.Add(t2)
   Console.WriteLine(ds.DataSetName, ds.Tables.Count)
End Sub

Private Function MakeTable(c1Name As String, c2Name As String) As DataTable
   Dim t As New DataTable
   Dim col As DataColumn
   ' Add two DataColumns
   col = New DataColumn(c1Name, System.Type.GetType("System.Integer"))
   t.Columns.Add col
   col = New DataCOlumn(c2Name, System.Type.GetType("System.String"))
   MakeTable = t
End Function

See Also

DataSet Class | DataSet Members | System.Data Namespace


DataSet Constructor ()

Initializes a new instance of the DataSet class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public DataSet();
[C++]
public: DataSet();
[JScript]
public function DataSet();

Example [Visual Basic]

The following example creates a new DataSet, to which is added two DataTable objects.

[Visual Basic]

Private Sub CreateDataSet()
   Dim ds As DataSet
   ds = New DataSet
   ' Create two DataTable objects using a function.
   Dim t1 As DataTable = MakeTable("idTable1", "thing1")
   Dim t2 As DataTable = MakeTable("idTable2", "thing2")
   ds.Tables.Add(t1)
   ds.Tables.Add(t2)
   Console.WriteLine(ds.Tables.Count)
End Sub

Private Function MakeTable(c1Name As String, c2Name As String) As DataTable
   Dim t As New DataTable
   Dim col As DataColumn
   ' Add two DataColumns
   col = New DataColumn(c1Name, System.Type.GetType("System.Integer"))
   t.Columns.Add col
   col = New DataCOlumn(c2Name, System.Type.GetType("System.String"))
   MakeTable = t
End Function

See Also

DataSet Class | DataSet Members | System.Data Namespace | DataSet Constructor Overload List | DataTable | TablesCollection


DataSet Constructor (String)

Initializes a new instance of a DataSet class with the given name.

[Visual Basic]
Overloads Public Sub New( _
   ByVal dataSetName As String _
)
[C#]
public DataSet(
   string dataSetName
);
[C++]
public: DataSet(
   String* dataSetName
);
[JScript]
public function DataSet(
   dataSetName : String
);

Parameters

dataSetName
The name of the DataSet.

Example [Visual Basic]

The following example creates a new DataSet, to which is added two DataTable objects.

[Visual Basic]

Private Sub CreateDataSet()
   Dim ds As DataSet
   ds = New DataSet("aNewDataSet")
   ' Create two DataTable objects using a function.
   Dim t1 As DataTable = MakeTable("idTable1", "thing1")
   Dim t2 As DataTable = MakeTable("idTable2", "thing2")
   ds.Tables.Add(t1)
   ds.Tables.Add(t2)
   Console.WriteLine(ds.DataSetName, ds.Tables.Count)
End Sub

Private Function MakeTable(c1Name As String, c2Name As String) As DataTable
   Dim t As New DataTable
   Dim col As DataColumn
   ' Add two DataColumns
   col = New DataColumn(c1Name, System.Type.GetType("System.Integer"))
   t.Columns.Add col
   col = New DataCOlumn(c2Name, System.Type.GetType("System.String"))
   MakeTable = t
End Function

See Also

DataSet Class | DataSet Members | System.Data Namespace | DataSet Constructor Overload List | DataSetName | DataTable | TablesCollection


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataSet Properties

The properties of the DataSet class are listed below. For a complete list of DataSet class members, see the DataSet Members topic.

Public:

CaseSensitive | Gets or sets a value indicating whether string comparisons within DataTable objects are case-sensitive.
DataSetName | Gets or sets the name of this DataSet.
DefaultView | Gets a custom "view" of the data contained by the DataSet, one that allows filtering, searching, and navigating through the custom data view.
EnforceConstraints | Gets or sets a value indicating whether constraint rules are followed when attempting any update operation.
ExtendedProperties | Gets the collection of custom user information.
HasErrors | Gets a value indicating whether there are errors in any of the rows in any of the tables of this DataSet.
Locale | Gets or sets the locale information used to compare strings within the table.
Relations | Get the collection of relations that link tables, and allow navigation from parent tables to child tables.
Site (inherited from Component) | Gets or sets the site of the Component.
Tables | Gets the collection of tables contained in the DataSet.
Xml | Gets or sets the XML data for the DataSet.
XmlData | Gets or sets the XML data for the DataSet.
XmlDocument | Gets the XML document for the DataSet.
XmlSchema | Gets or sets the XML schema of the DataSet.

See Also

DataSet Class | System.Data Namespace


DataSet.CaseSensitive

Gets or sets a value indicating whether string comparisons within DataTable objects are case-sensitive.

[Visual Basic]
Public Property CaseSensitive As Boolean
[C#]
public bool CaseSensitive {get; set;}
[C++]
public: __property bool get_CaseSensitive();
public: __property void set_CaseSensitive(bool);
[JScript]
public function get CaseSensitive() : Boolean;
public function set CaseSensitive(Boolean);

Property Value

true if string comparisons are case-sensitive; otherwise, false. The default is false.

Remarks

The CaseSensitive property affects the following operations of each DataTable contained in a DataSet: sorting, searching, and filtering.

By default, setting the CaseSensitive for a DataSet also sets each of its constituent DataTable objects' CaseSensitive properties to the same value.

Example [Visual Basic]

The following example toggles the CaseSensitive property.

[Visual Basic]

DataSet1.CaseSensitive = DataSet1.CaseSensitve Xor True

See Also

DataSet Class | DataSet Members | System.Data Namespace | CaseSensitive


DataSet.DataSetName

Gets or sets the name of this DataSet.

[Visual Basic]
Public Property DataSetName As String
[C#]
public string DataSetName {get; set;}
[C++]
public: __property String* get_DataSetName();
public: __property void set_DataSetName(String*);
[JScript]
public function get DataSetName() : String;
public function set DataSetName(String);

Property Value

The name of the DataSet.

Example [Visual Basic]

The following example creates a new DataSet with the given DataSetName.

[Visual Basic]

Private Sub CreateDataSet()
   ds As DataSet
   ds = New DataSet("SuppliersProducts")
   Console.WriteLine ds.DataSetName
End Sub

See Also

DataSet Class | DataSet Members | System.Data Namespace | DataSet


DataSet.DefaultView

Gets a custom "view" of the data contained by the DataSet, one that allows filtering, searching, and navigating through the custom data view.

[Visual Basic]
Public ReadOnly Property DefaultView As DataSetView
[C#]
public DataSetView DefaultView {get;}
[C++]
public: __property DataSetView* get_DefaultView();
[JScript]
public function get DefaultView() : DataSetView;

Property Value

A DataSetView.

Remarks

The DataSetView returned by the property allows you to create custom settings for each DataTable in the DataSet. By adding TableSetting objects to the TableSettingsCollection, each table is automatically configured to display rows according to desired sort, expression, and DataViewRowState values.

Example [Visual Basic]

The following example gets the default DataSetView for a DataSet, and adds a TableSetting to the TableSettings collection.

[Visual Basic]

Private Sub GetDefaultView()
   Dim dsv As DataSetView
   ' Get a DataSet object's DefaultView.
   dsv = DataSet1.DefaultView
   ' Add a TableSetting to the TableSettings collection.
   Dim ts As TableSetting
   ts = New TableSetting(DataSet1.Tables(0), "CompanyName", _
   "CompanyName < 'J'", DataViewRowState.
   dsv.TableSettings.Add ts
End Sub

See Also

DataSet Class | DataSet Members | System.Data Namespace | TableSetting | TableSettingsCollection | DataViewRowState


DataSet.EnforceConstraints

Gets or sets a value indicating whether constraint rules are followed when attempting any update operation.

[Visual Basic]
Public Property EnforceConstraints As Boolean
[C#]
public bool EnforceConstraints {get; set;}
[C++]
public: __property bool get_EnforceConstraints();
public: __property void set_EnforceConstraints(bool);
[JScript]
public function get EnforceConstraints() : Boolean;
public function set EnforceConstraints(Boolean);

Property Value

true, if rules are enforced; otherwise, false.

Exceptions

Exception Type | Condition
InvalidConstraintException | A constraint isn't applicable.

Remarks

See the Constraints property for more details.

Example [Visual Basic]

The following example sets the EnforceConstraints property to true if any DataTable in a DataSet has at least one constraint.

[Visual Basic]

Private Sub EnforceIfNeeded()
   Dim t As DataTable
   Dim ds As DataSet = New DataSet
   ' Not shown: code to fill the DataSet.
   For Each t in ds.Tables
      If t.Constraints.Count > 0 Then ds.EnforceConstraints = True
   Next
End Sub

See Also

DataSet Class | DataSet Members | System.Data Namespace | Constraints | UniqueConstraint | ForeignKeyConstraint | DataTable


DataSet.ExtendedProperties

Gets the collection of custom user information.

[Visual Basic]
Public ReadOnly Property ExtendedProperties As PropertiesCollection
[C#]
public PropertiesCollection ExtendedProperties {get;}
[C++]
public: __property PropertiesCollection* get_ExtendedProperties();
[JScript]
public function get ExtendedProperties() : PropertiesCollection;

Property Value

A PropertiesCollection with all custom user information.

See Also

DataSet Class | DataSet Members | System.Data Namespace


DataSet.HasErrors

Gets a value indicating whether there are errors in any of the rows in any of the tables of this DataSet.

[Visual Basic]
Public ReadOnly Property HasErrors As Boolean
[C#]
public bool HasErrors {get;}
[C++]
public: __property bool get_HasErrors();
[JScript]
public function get HasErrors() : Boolean;

Property Value

true if any table has errors;otherwise, false.

Remarks

The HasErrors property is usually consulted after attempting to update a DataSet through the Update method.

Each DataTable in a DataSet also has a HasErrors property. Use the DataSet object's HasErrors to determine if any table has errors before checking individual DataTable objects. If a DataTable has errors, the GetErrors method returns an array of DataRow objects that have errors.

Example [Visual Basic]

The following example uses the HasErrors property to determine whether a DataSet object contains errors. If so, the errors for each DataRow in each DataTable is printed.

[Visual Basic]

Private Sub CheckForErrors()
   If Not DataSet1.HasErrors Then
       DataSet1.Merge DataSet2
   Else
      PrintErrors DataSet1
   End If
End Sub

Private Sub PrintRowErrs(ds As DataSet)
   Dim r As DataRow
   Dim e As DataError
   Dim t As DataTable
   Dim cols() As DataColumn
   For Each t In ds.Tables
      For Each r In t.Rows
         If r.HasErrors Then
Console.WriteLine(r.RowError)
         End If
      Next
   Next
End Sub

See Also

DataSet Class | DataSet Members | System.Data Namespace | GetChanges


DataSet.Locale

Gets or sets the locale information used to compare strings within the table.

[Visual Basic]
Public Property Locale As CultureInfo
[C#]
public CultureInfo Locale {get; set;}
[C++]
public: __property CultureInfo* get_Locale();
public: __property void set_Locale(CultureInfo*);
[JScript]
public function get Locale() : CultureInfo;
public function set Locale(CultureInfo);

Property Value

A CultureInfo that contains data about the user's machine locale. The default is a null reference (in Visual Basic Nothing).

Remarks

By default, setting the Locale for a DataSet also sets each of its constituent DataTable objects' Locale properties to the same value.

Example [Visual Basic]

The following example gets the CultureInfo for a DataSet and prints the DisplayName and EnglishName properties.

[Visual Basic]

Private Sub GetCultureInfo()
   Dim ci As System.Globalization.CultureInfo
   ci = DataSet1.Locale
   Console.WriteLine(ci.DisplayName, ci.EnglishName)
End Sub

See Also

DataSet Class | DataSet Members | System.Data Namespace | CultureInfo


DataSet.Relations

Get the collection of relations that link tables, and allow navigation from parent tables to child tables.

[Visual Basic]
Public ReadOnly Property Relations As RelationsCollection
[C#]
public RelationsCollection Relations {get;}
[C++]
public: __property RelationsCollection* get_Relations();
[JScript]
public function get Relations() : RelationsCollection;

Property Value

A RelationsCollection that contains a collection of DataRelation objects.

Example [Visual Basic]

The following example prints the column name of all child tables through the Relations property.

[Visual Basic]

Private Sub PrintChildRelationRows()
   ' Declare variable to hold the row values.
   Dim strRowVals As String
   Dim myDataSet As DataSet
   ' Get the DataSet of a DataGrid that is displaying data of at least two tables.
   myTable = DataGrid1.DataSource
   ' Navigate using the Relations.
   Dim myRel As DataRelation
   Dim row As DataRow
   Dim col As DataColumn
   ' Print the names of each column in each table through the Relations.
   For Each myRel In myDataSet.Relations
      For Each col in myRel.ChildTable.Columns
          strRowVals &= col.ColumnName & vbcrlf
      Next
    Next
    ' Display results.
    Console.WriteLine(strRowVals)
   End Sub

See Also

DataSet Class | DataSet Members | System.Data Namespace | DataRelation | DataTable | RelationsCollection


DataSet.Tables

Gets the collection of tables contained in the DataSet.

[Visual Basic]
Public ReadOnly Property Tables As TablesCollection
[C#]
public TablesCollection Tables {get;}
[C++]
public: __property TablesCollection* get_Tables();
[JScript]
public function get Tables() : TablesCollection;

Property Value

The TablesCollection contained by this DataSet.

Remarks

To add tables to the collection, use the TablesCollection class's Add method. To remove tables, use the Remove method.

Example [Visual Basic]

The following example returns the DataSet object's TablesCollection, and prints the columns and rows in each table.

[Visual Basic]

Private Sub PrintRows()
   Dim t As DataTable
   Dim r As DataRow
   Dim c As DataColumn
   For Each t in DataSet1.Tables
      For Each r In t.Rows
         For c in t.Columns
Console.WriteLine(r(c.ColumnName))
         Next c
      Next r
   Next t
End Sub

See Also

DataSet Class | DataSet Members | System.Data Namespace | DataTable | TablesCollection


DataSet.Xml

Gets or sets the XML data for the DataSet.

[Visual Basic]
Public Property Xml As String
[C#]
public string Xml {get; set;}
[C++]
public: __property String* get_Xml();
public: __property void set_Xml(String*);
[JScript]
public function get Xml() : String;
public function set Xml(String);

Property Value

The XML code that defines the DataSet including its relationships, table schemas, and data.

Remarks

The code returned by the Xml property may have both schema and instance data. To return just the XML schema, use the XmlSchema property. To return just the XML data, use the XmlData property.

Example [Visual Basic]

The following example prints the XML data for a DataSet using the XML property.

[Visual Basic]

Private ds As DataSet

Private Sub PrintToFile()
   ds =New DataSet
   ' Not shown: code to fill the DataSet with tables and data.

   ' Open a file for XML data.
   Open "\\myFileDirectory\Temp\Nwind.xml" For Output As #1
   Print #1, myDS.Xml
   Close
End Sub

See Also

DataSet Class | DataSet Members | System.Data Namespace


DataSet.XmlData

Gets or sets the XML data for the DataSet.

[Visual Basic]
Public Property XmlData As String
[C#]
public string XmlData {get; set;}
[C++]
public: __property String* get_XmlData();
public: __property void set_XmlData(String*);
[JScript]
public function get XmlData() : String;
public function set XmlData(String);

Property Value

The data formatted as XML.

Remarks

Te XML schema defines the tags for the data found in an XML document. The XmlSchema property returns only the tags, and not the data for the DataSet. To return the data, use the XmlData property. Use the Xml property to return both schema and data together.

Example [Visual Basic]

The following example prints out the XmlSchema and XmlData for a DataSet.

[Visual Basic]

Private Sub PrintXML()
   ' Presuming a DataGrid control is displaying tables from a DataSet.
   Dim myDS As DataSet
   myDS = DataGrid1.DataSource
   ' Print XmlSchema and XmlData.
   Console.WriteLine(myDS.XmlSchema)
   Console.WriteLine(myDS.XmlData)
End Sub

See Also

DataSet Class | DataSet Members | System.Data Namespace | XmlSchema


DataSet.XmlDocument

Gets the XML document for the DataSet.

[Visual Basic]
Public ReadOnly Property XmlDocument As XmlDocument
[C#]
public XmlDocument XmlDocument {get;}
[C++]
public: __property XmlDocument* get_XmlDocument();
[JScript]
public function get XmlDocument() : XmlDocument;

Property Value

An XmlDocument.

Remarks

The XmlDocument provides an interface to save and load the information contained in a DataSet as an XML document. Through the property, you can access other methods of the XmlDocument.

Example [Visual Basic]

The following example returns the XML document for a DataSet associated with a System.WinForms.DataGrid control.

[Visual Basic]

Private Sub GetXMLDocument()
   Dim ds As DataSet
   ' Presuming the DataGrid is bound to a DataSet.
   ds = DataGrid1.DataSource
   Dim myDoc As xml.XmlDocument
   myDoc = ds.XmlDocument
   Console.WriteLine(mydoc.Xml)
End Sub

See Also

DataSet Class | DataSet Members | System.Data Namespace | XmlDocument


DataSet.XmlSchema

Gets or sets the XML schema of the DataSet.

[Visual Basic]
Public Property XmlSchema As String
[C#]
public string XmlSchema {get; set;}
[C++]
public: __property String* get_XmlSchema();
public: __property void set_XmlSchema(String*);
[JScript]
public function get XmlSchema() : String;
public function set XmlSchema(String);

Property Value

The XML schema for the DataSet.

Remarks

Te XML schema defines the tags for the data found in an XML document. The XmlSchema property returns only the tags, and not the data for the DataSet. To return the data, use the XmlData property. Use the Xml property to return both schema and data together.

Example [Visual Basic]

The following example prints out the XmlSchema and XmlData for a DataSet.

[Visual Basic]

Private Sub PrintXML()
   ' Presuming a DataGrid control is displaying tables from a DataSet.
   Dim myDS As DataSet
   myDS = DataGrid1.DataSource
   ' Print XmlSchema and XmlData.
   Console.WriteLine(myDS.XmlSchema)
   Console.WriteLine(myDS.XmlData)
End Sub

See Also

DataSet Class | DataSet Members | System.Data Namespace | XmlData


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataSet Methods

The methods of the DataSet class are listed below. For a complete list of DataSet class members, see the DataSet Members topic.

Public:

AcceptChanges | Commits all the changes made to this DataSet since it was loaded or the last time AcceptChanges was called.
Clear | Clears the DataSet of any data by removing all rows in all tables.
Clone | Clones the structure of the DataSet, including all DataTable schemas, relations, and constraints.
Copy | Copies both the structure and data for this DataSet.
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetChanges | Overloaded. Returns a copy of the DataSet containing all changes made to it since it was last loaded, or since AcceptChanges was called.
GetChildRelations | Gets the collection of child relations which belong to a specified table.
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParentRelations | Gets the collection of parent relations which belong to a specified table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
HasChanges | Overloaded. Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows.
InferSchema | Overloaded. Instructs the DataSet to infer a schema from a source.
LoadDiffGram | Loads a specially formatted XML document that includes all changes, including before and after data, from a IDataReader.
Merge | Overloaded. Merges this DataSet into a specified DataSet.
ReadDiffGram | Overloaded. Reads a specially formatted XML document that includes all changes, including before and after data.
RejectChanges | This method rolls back all the changes to have been made to this DataSet since it was loaded or the last time AcceptChanges was called. Any rows still in edit-mode cancel their edits. New rows get removed. Modified and Deleted rows return back to their original state.
ResetLocale | Resets the Locale property to the current system locale.
ResetRelations | Clears the collection of relations.
ResetTables | [To be supplied.]
SaveDiffGram | Saves a specially formatted XML document that includes all changes, including before and after data, to a specified TextWriter.
ShouldPersistLocale | Indicates whether the locale property should be persisted. This is true if the user ever explicitly sets the locale property and doesn't call ResetLocale.
ShouldPersistRelations | [To be supplied.]
ShouldPersistTables | [To be supplied.]
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
WriteDiffGram | Writes a specially formatted XML document that includes all changes, including before and after data, into the specfied XmlWriter.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanged | Raises the PropertyChanged event.
OnRemoveRelation | This method should be overriden by subclasses to restrict tables being removed.
OnRemoveTable | This method should be overriden by subclasses to restrict tables being removed.
RaisePropertyChanged | Raises the property changed event. This creates the needed event data and then calls OnPropertyChanged.

Event Hookup:

AddOnMergeFailed | Adds an event handler for the MergeFailed event.
AddOnPropertyChanged | Adds an event handler for the OnPropertyChanged event.
RemoveOnMergeFailed | Removes an event handler for the merge failed event. This event occurs when Merge failed for any reason.
RemoveOnPropertyChanged | Removes an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.

See Also

DataSet Class | System.Data Namespace


DataSet.AcceptChanges

Commits all the changes made to this DataSet since it was loaded or the last time AcceptChanges was called.

[Visual Basic]
Public Sub AcceptChanges()
[C#]
public void AcceptChanges();
[C++]
public: void AcceptChanges();
[JScript]
public function AcceptChanges();

Remarks

Both the DataRow and DataTable classes also have AcceptChanges methods. Invoking AcceptChanges on the DataSet causes AcceptChanges to be called on each table in a DataSet. Consequently, calling AcceptChanges on each DataTable causes each DataRow object's AcceptChanges method to be called. In this manner, you have multiple levels at which the method can be invoked. Calling the DataSet class's AcceptChanges, however, allows you to invoke the method all subordinate objects (tables and rows) with one call.

The AcceptChanges method is called after you have called the BeginEdit method of a DataRow object (or objects). Thus you can have several rows in edit state where changes are arbitarily made, and no constraints are applied.

Any DataRow objects still in edit-mode successfully end their edits. The RowState property of each DataRow also changes; New and Modified rows become Unchanged, and Deleted rows are removed.

If the DataSet contains ForeignKeyConstraint objects, invoking the AcceptChanges method also causes the AcceptRejectRule to be enforced.

Example [Visual Basic]

[Visual Basic]

Private Sub AcceptChanges()
   Dim myDataSet As DataSet
   ' The SuppliersProducts class derives from DataSet.
   myDataSet = New SuppliersProducts
   ' Not shown: methods to fill the DataSet with data.
   Dim t As DataTable
   t = myDataSet.Tables("Suppliers")
   ' Add a DataRow to a table.
   Dim myRow As DataRow
   myRow = t.NewRow
   myRow("CompanyID") = "NWTRADECO"
   myRow("CompanyName") = "NortWest Trade Company"
   ' Begin edit and add the row.
   t.BeginEdit
   t.Rows.Add(myRow)
   ' Calling AcceptChanges on the DataSet causes AcceptChanges to be
   ' called on all subordinate objects.
   t.EndEdit
   myDataSet.AcceptChanges
End Sub

See Also

DataSet Class | DataSet Members | System.Data Namespace | AcceptChanges | AcceptRejectRule | BeginEdit | DataRow | ForeignKeyConstraint


DataSet.AddOnMergeFailed

Adds an event handler for the MergeFailed event.

[Visual Basic]
Public Sub AddOnMergeFailed( _
   ByVal handler As MergeFailedEventHandler _
)
[C#]
public void AddOnMergeFailed(
   MergeFailedEventHandler handler
);
[C++]
public: void AddOnMergeFailed(
   MergeFailedEventHandler* handler
);
[JScript]
public function AddOnMergeFailed(
   handler : MergeFailedEventHandler
);

Parameters

handler
New handler to install for this event

See Also

DataSet Class | DataSet Members | System.Data Namespace | RemoveOnMergeFailed


DataSet.AddOnPropertyChanged

Adds an event handler for the OnPropertyChanged event.

[Visual Basic]
Public Sub AddOnPropertyChanged( _
   ByVal handler As PropertyChangedEventHandler _
)
[C#]
public void AddOnPropertyChanged(
   PropertyChangedEventHandler handler
);
[C++]
public: void AddOnPropertyChanged(
   PropertyChangedEventHandler* handler
);
[JScript]
public function AddOnPropertyChanged(
   handler : PropertyChangedEventHandler
);

Parameters

handler
A PropertyChangedEventHandler delegate that represents the method that will handle the OnPropertyChanged event.

See Also

DataSet Class | DataSet Members | System.Data Namespace | RemoveOnPropertyChanged


DataSet.Clear

Clears the DataSet of any data by removing all rows in all tables.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[JScript]
public function Clear();

See Also

DataSet Class | DataSet Members | System.Data Namespace


DataSet.Clone

Clones the structure of the DataSet, including all DataTable schemas, relations, and constraints.

[Visual Basic]
Public Function Clone() As DataSet
[C#]
public DataSet Clone();
[C++]
public: DataSet* Clone();
[JScript]
public function Clone() : DataSet;

Return Value

A new DataSet with the same schema as the current DataSet.

Remarks

Note If these classes have been subclassed, the clone will also be of the same subclasses.

Example [Visual Basic]

The following example creates a clone of a DataSet object's schema.

[Visual Basic]

Private Sub Get Clone()
   Dim myDataView As DataView
   myDataView = DataSet1.DefautView
   Dim ds2 As DataSet
   ds2.DefaultView
End Sub

See Also

DataSet Class | DataSet Members | System.Data Namespace | Copy


DataSet.Copy

Copies both the structure and data for this DataSet.

[Visual Basic]
Public Function Copy() As DataSet
[C#]
public DataSet Copy();
[C++]
public: DataSet* Copy();
[JScript]
public function Copy() : DataSet;

Return Value

A new DataSet with the same structure (table schemas, relations, and constraints) and data as this DataSet.

Note If these classes have been subclassed, the copy will also be of the same subclasses.

See Also

DataSet Class | DataSet Members | System.Data Namespace | Clone


DataSet.GetChanges

Returns a copy of the DataSet containing all changes made to it since it was last loaded, or since AcceptChanges was called.

Overload List

Returns a copy of the DataSet that contains all changes made to it since it was loaded or AcceptChanges was last called.

[Visual Basic] Overloads Public Function GetChanges() As DataSet
[C#] public DataSet GetChanges();
[C++] public: DataSet* GetChanges();
[JScript] public function GetChanges() : DataSet;

Returns a copy of the DataSet containing all changes made to it since it was last loaded, or since AcceptChanges was called, filtered by DataRowState.

[Visual Basic] Overloads Public Function GetChanges(DataRowState) As DataSet
[C#] public DataSet GetChanges(DataRowState);
[C++] public: DataSet* GetChanges(DataRowState);
[JScript] public function GetChanges(DataRowState) : DataSet;

See Also

DataSet Class | DataSet Members | System.Data Namespace


DataSet.GetChanges ()

Returns a copy of the DataSet that contains all changes made to it since it was loaded or AcceptChanges was last called.

[Visual Basic]
Overloads Public Function GetChanges() As DataSet
[C#]
public DataSet GetChanges();
[C++]
public: DataSet* GetChanges();
[JScript]
public function GetChanges() : DataSet;

Return Value

A copy of the changes from this dataSet that can have actions performed on it and subsequently be merged back in using Merge, or null if none are found.

Remarks

Gets a copy of the DataSet that contains all changes made to it since it was loaded or AcceptChanges was last called. This copy is particularly designed so that it can be merged back in to this original dataSet. Relationship constraints may cause Unchanged parent rows to be included. If no rows of these rowStates are found, this method returns null.

See Also

DataSet Class | DataSet Members | System.Data Namespace | DataSet.GetChanges Overload List


DataSet.GetChanges (DataRowState)

Returns a copy of the DataSet containing all changes made to it since it was last loaded, or since AcceptChanges was called, filtered by DataRowState.

[Visual Basic]
Overloads Public Function GetChanges( _
   ByVal rowStates As DataRowState _
) As DataSet
[C#]
public DataSet GetChanges(
   DataRowState rowStates
);
[C++]
public: DataSet* GetChanges(
   DataRowState rowStates
);
[JScript]
public function GetChanges(
   rowStates : DataRowState
) : DataSet;

Parameters

rowStates
One of the DataRowState values: Detached, Unchanged, New, Deleted, and Modified.

Return Value

A filtered copy of the DataSet that can have actions performed on it, and subsequently be merged back in using Merge. If no rows of the desired DataRowState are found, the method returns a null reference (in Visual Basic Nothing).

Remarks

This copy is particularly designed so that it can be merged back in to this original dataSet. Relationship constraints may cause parent rows not of the indicated rowState to also be included.

This returned copy is designed to be merged back in to this original DataSet. Relationship constraints may cause parent rows marked Unchanged to be included. If no rows of the desired DataRowState are found, the GetChanges method returns null.

See Also

DataSet Class | DataSet Members | System.Data Namespace | DataSet.GetChanges Overload List


DataSet.GetChildRelations

Gets the collection of child relations which belong to a specified table.

[Visual Basic]
Public Function GetChildRelations( _
   ByVal table As DataTable _
) As RelationsCollection
[C#]
public RelationsCollection GetChildRelations(
   DataTable table
);
[C++]
public: RelationsCollection* GetChildRelations(
   DataTable* table
);
[JScript]
public function GetChildRelations(
   table : DataTable
) : RelationsCollection;

Parameters

table
The DataTable whose child RelationsCollection is returned.

Return Value

The child RelationsCollection that belongs to the DataTable.

Example [Visual Basic]

In the following example, for each DataTable in the specified DataSet, the GetChildRelations method returns all child DataRelation objects. Each DataRelation is then used as an argument to the DataRow class's GetChildRows method to return any child DataRow objects. The value of each column in the array is then printed.

[Visual Basic]

Private Sub GetChildRowsFromDataRelation(myDataSet As DataSet)
   Dim t As DataTable
   Dim rels As RelationsCollection
   Dim dr As DataRelation
   Dim arrRows() As DataRow
   Dim r As DataRow
   Dim i As Integer
   Dim dc As DataColumn

   For Each t in myDataSet.Tables
      rels = myDataSet.GetChildRelations(t)
         For Each dr In rels
For Each r In t.Rows
   arrRows = r.GetChildRows(dr)
   ' Print out the value of each column in the row.
   For i = 0 To UBound(arrRows)
      For Each dc In t.Columns
         Console.WriteLine(arrRows(i)(c))
      Next dc
   Next i
Next r
         Next dr
   Next t
End Sub

See Also

DataSet Class | DataSet Members | System.Data Namespace | DataRelation | Relations


DataSet.GetParentRelations

Gets the collection of parent relations which belong to a specified table.

[Visual Basic]
Public Function GetParentRelations( _
   ByVal table As DataTable _
) As RelationsCollection
[C#]
public RelationsCollection GetParentRelations(
   DataTable table
);
[C++]
public: RelationsCollection* GetParentRelations(
   DataTable* table
);
[JScript]
public function GetParentRelations(
   table : DataTable
) : RelationsCollection;

Parameters

table
The DataTable whose parent RelationsCollection is returned.

Return Value

The parent RelationsCollection that belongs to the DataTable.

See Also

DataSet Class | DataSet Members | System.Data Namespace


DataSet.HasChanges

Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows.

Overload List

Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows.

[Visual Basic] Overloads Public Function HasChanges() As Boolean
[C#] public bool HasChanges();
[C++] public: bool HasChanges();
[JScript] public function HasChanges() : Boolean;

Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows, filtered by DataRowState.

[Visual Basic] Overloads Public Function HasChanges(DataRowState) As Boolean
[C#] public bool HasChanges(DataRowState);
[C++] public: bool HasChanges(DataRowState);
[JScript] public function HasChanges(DataRowState) : Boolean;

See Also

DataSet Class | DataSet Members | System.Data Namespace


DataSet.HasChanges ()

Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows.

[Visual Basic]
Overloads Public Function HasChanges() As Boolean
[C#]
public bool HasChanges();
[C++]
public: bool HasChanges();
[JScript]
public function HasChanges() : Boolean;

Return Value

true, if the DataSet has changes; otherwise, false.

See Also

DataSet Class | DataSet Members | System.Data Namespace | DataSet.HasChanges Overload List


DataSet.HasChanges (DataRowState)

Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows, filtered by DataRowState.

[Visual Basic]
Overloads Public Function HasChanges( _
   ByVal rowStates As DataRowState _
) As Boolean
[C#]
public bool HasChanges(
   DataRowState rowStates
);
[C++]
public: bool HasChanges(
   DataRowState rowStates
);
[JScript]
public function HasChanges(
   rowStates : DataRowState
) : Boolean;

Parameters

rowStates
One of the DataRowState values: Detached, Unchanged, New, Deleted, and Modified.

Return Value

true, if the DataSet has changes; otherwise, false.

Remarks

Examine the HasChanges property after invoking GetChanges method.

See Also

DataSet Class | DataSet Members | System.Data Namespace | DataSet.HasChanges Overload List


DataSet.InferSchema

Instructs the DataSet to infer a schema from a source.

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub InferSchema(String)
[C#] public void InferSchema(String);
[C++] public: void InferSchema(String*);
[JScript] public function InferSchema(String);

Instructs the DataSet to infer a schema from a document.

[Visual Basic] Overloads Public Sub InferSchema(TextReader)
[C#] public void InferSchema(TextReader);
[C++] public: void InferSchema(TextReader*);
[JScript] public function InferSchema(TextReader);

Instructs the DataSet to infer a schema from the specified Stream.

[Visual Basic] Overloads Public Sub InferSchema(Stream)
[C#] public void InferSchema(Stream);
[C++] public: void InferSchema(Stream*);
[JScript] public function InferSchema(Stream);

See Also

DataSet Class | DataSet Members | System.Data Namespace


DataSet.InferSchema (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub InferSchema( _
   ByVal data As String _
)
[C#]
public void InferSchema(
   string data
);
[C++]
public: void InferSchema(
   String* data
);
[JScript]
public function InferSchema(
   data : String
);

Parameters

data
[To be supplied.]

See Also

DataSet Class | DataSet Members | System.Data Namespace | DataSet.InferSchema Overload List


DataSet.InferSchema (TextReader)

Instructs the DataSet to infer a schema from a document.

[Visual Basic]
Overloads Public Sub InferSchema( _
   ByVal reader As TextReader _
)
[C#]
public void InferSchema(
   TextReader reader
);
[C++]
public: void InferSchema(
   TextReader* reader
);
[JScript]
public function InferSchema(
   reader : TextReader
);

Parameters

reader
A TextReader that contains the document from which to infer a schema.

See Also

DataSet Class | DataSet Members | System.Data Namespace | DataSet.InferSchema Overload List


DataSet.InferSchema (Stream)

Instructs the DataSet to infer a schema from the specified Stream.

[Visual Basic]
Overloads Public Sub InferSchema( _
   ByVal stream As Stream _
)
[C#]
public void InferSchema(
   Stream stream
);
[C++]
public: void InferSchema(
   Stream* stream
);
[JScript]
public function InferSchema(
   stream : Stream
);

Parameters

stream
[To be supplied.]

See Also

DataSet Class | DataSet Members | System.Data Namespace | DataSet.InferSchema Overload List


DataSet.LoadDiffGram

Loads a specially formatted XML document that includes all changes, including before and after data, from a IDataReader.

[Visual Basic]
Public Sub LoadDiffGram( _
   ByVal reader As IDataReader _
)
[C#]
public void LoadDiffGram(
   IDataReader reader
);
[C++]
public: void LoadDiffGram(
   IDataReader* reader
);
[JScript]
public function LoadDiffGram(
   reader : IDataReader
);

Parameters

reader
The IDataReader to load.

See Also

DataSet Class | DataSet Members | System.Data Namespace


DataSet.Merge

Merges this DataSet into a specified DataSet.

Overload List

Merges this DataTable into a specified DataTable. with a value to preserve changes made to the target, and a value to deal with missing schemas.

[Visual Basic] Overloads Public Sub Merge(DataTable, Boolean, MissingSchemaAction)
[C#] public void Merge(DataTable, bool, MissingSchemaAction);
[C++] public: void Merge(DataTable*, bool, MissingSchemaAction);
[JScript] public function Merge(DataTable, Boolean, MissingSchemaAction);

[To be supplied.]

[Visual Basic] Overloads Public Sub Merge(DataRow())
[C#] public void Merge(DataRow[]);
[C++] public: void Merge(DataRow*[]);
[JScript] public function Merge(DataRow[]);

Merges this DataTable into a specified DataTable.

[Visual Basic] Overloads Public Sub Merge(DataTable)
[C#] public void Merge(DataTable);
[C++] public: void Merge(DataTable*);
[JScript] public function Merge(DataTable);

Merges this DataSet into a specified DataSet preserving changes according to the specified argument.

[Visual Basic] Overloads Public Sub Merge(DataSet, Boolean)
[C#] public void Merge(DataSet, bool);
[C++] public: void Merge(DataSet*, bool);
[JScript] public function Merge(DataSet, Boolean);

Merges this DataSet into a specified DataSet preserving changes according to the specified argument, and handling an incompatible schema according to the specified argument.

[Visual Basic] Overloads Public Sub Merge(DataSet, Boolean, MissingSchemaAction)
[C#] public void Merge(DataSet, bool, MissingSchemaAction);
[C++] public: void Merge(DataSet*, bool, MissingSchemaAction);
[JScript] public function Merge(DataSet, Boolean, MissingSchemaAction);

Merges this DataSet into a specified DataSet.

[Visual Basic] Overloads Public Sub Merge(DataSet)
[C#] public void Merge(DataSet);
[C++] public: void Merge(DataSet*);
[JScript] public function Merge(DataSet);

[To be supplied.]

[Visual Basic] Overloads Public Sub Merge(DataRow(), Boolean, MissingSchemaAction)
[C#] public void Merge(DataRow[], bool, MissingSchemaAction);
[C++] public: void Merge(DataRow*[], bool, MissingSchemaAction);
[JScript] public function Merge(DataRow[], Boolean, MissingSchemaAction);

See Also

DataSet Class | DataSet Members | System.Data Namespace


DataSet.Merge (DataTable, Boolean, MissingSchemaAction)

Merges this DataTable into a specified DataTable. with a value to preserve changes made to the target, and a value to deal with missing schemas.

[Visual Basic]
Overloads Public Sub Merge( _
   ByVal table As DataTable, _
   ByVal preserveChanges As Boolean, _
   ByVal missingSchemaAction As MissingSchemaAction _
)
[C#]
public void Merge(
   DataTable table,
   bool preserveChanges,
   MissingSchemaAction missingSchemaAction
);
[C++]
public: void Merge(
   DataTable* table,
   bool preserveChanges,
   MissingSchemaAction missingSchemaAction
);
[JScript]
public function Merge(
   table : DataTable,
   preserveChanges : Boolean,
   missingSchemaAction : MissingSchemaAction
);

Parameters

table
The DataSet whose data and schema will be merged.
preserveChanges
Whether changes in the current (target) DataSet should be maintained.
missingSchemaAction
One of the MissingSchemaAction values that specify what to do with an incompatible schema. Possible values include Add (for example, add a column), Ignore, or Error.

Exceptions

Exception Type | Condition
ArgumentNullException | The dataSet is a null reference (in Visual Basic Nothing).

Remarks

Merges the specified DataTable (the source) into the current DataSet (the target). An attempt is made to locate the source DataTable in this DataSet.

If missingSchemaAction is set to Add, and the source table is missing in the target it will be added. If set to Ignore, source data from the missing table is ignored. If set to Error, an error will be thrown.

When the Merge method is called, the schemas of the two DataSet objects are compared. If the source DataSet contains schema elements that are missing in the target, the schema elements are added to the target. The data is then merged. When merging rows that have a DataRowState value of Unchanged, Modified, or Deleted source rows, the source's primary key is used to search for target rows that have the same primary key values. When merging New source rows, the new primary key value is used to search for target rows that are also New and have matching new primary keys.

See Also

DataSet Class | DataSet Members | System.Data Namespace | DataSet.Merge Overload List


DataSet.Merge (DataRow[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub Merge( _
   ByVal rows() As DataRow _
)
[C#]
public void Merge(
   DataRow[] rows
);
[C++]
public: void Merge(
   DataRow* rows[]
);
[JScript]
public function Merge(
   rows : DataRow[]
);

Parameters

rows
[To be supplied.]

See Also

DataSet Class | DataSet Members | System.Data Namespace | DataSet.Merge Overload List


DataSet.Merge (DataTable)

Merges this DataTable into a specified DataTable.

[Visual Basic]
Overloads Public Sub Merge( _
   ByVal table As DataTable _
)
[C#]
public void Merge(
   DataTable table
);
[C++]
public: void Merge(
   DataTable* table
);
[JScript]
public function Merge(
   table : DataTable
);

Parameters

table
The DataTable whose data and schema will be merged.

Exceptions

Exception Type | Condition
ArgumentNullException | The dataSet is a null reference (in Visual Basic Nothing).

Remarks

Merges the specified DataTable (the source) into the current DataSet (the target). An attempt is made to locate the source DataTable in this DataSet. If the schemas of the two tables are incompatible, the missing columns will be added.

When the Merge method is called, the schemas of the two DataSet objects are compared. If the source DataSet contains schema elements that are missing in the target, the schema elements are added to the target. The data is then merged. When merging rows that have a DataRowState value of Unchanged, Modified, or Deleted source rows, the source's primary key is used to search for target rows that have the same primary key values. When merging New source rows, the new primary key value is used to search for target rows that are also New and have matching new primary keys.

See Also

DataSet Class | DataSet Members | System.Data Namespace | DataSet.Merge Overload List


DataSet.Merge (DataSet, Boolean)

Merges this DataSet into a specified DataSet preserving changes according to the specified argument.

[Visual Basic]
Overloads Public Sub Merge( _
   ByVal dataSet As DataSet, _
   ByVal preserveChanges As Boolean _
)
[C#]
public void Merge(
   DataSet dataSet,
   bool preserveChanges
);
[C++]
public: void Merge(
   DataSet* dataSet,
   bool preserveChanges
);
[JScript]
public function Merge(
   dataSet : DataSet,
   preserveChanges : Boolean
);

Parameters

dataSet
The DataSet whose data and schema will be merged.
preserveChanges
A value indicating whether changes in the current DataSet should be maintained. true, if changes should be maintained; otherwise, false.

Remarks

The Merge method is typically called after invoking the GetChanges method, which returns a DataSet optimized for merging.

To facilitate explanation of the Merge method, we use "target" to signify the current DataSet, and "source" to name the second (parameter) DataSet.

When the Merge method is called, the schemas of the two DataSet objects are compared. If the source DataSet contains schema elements that are missing in the target, the schema elements are added to the target. The data is then merged. When merging rows that have a DataRowState value of Unchanged, Modified, or Deleted source rows, the source's primary key is used to search for target rows that have the same primary key values. When merging New source rows, the new primary key value is used to search for target rows that are also New and have matching new primary keys.

If the source DataSet originated from a call to GetChanges on the target DataSet, a different matching procedure is employed. The source DataSet rows are matched up with the target rows they were cloned from. Once a match is found, original values in the target rows are updated with values from the source rows, while the changed values remain the same.

During a merge, constraints are disabled. If any constraints can't be enabled at the end of merge, an InvalidConstraintException is thrown and the data is kept with the constraints disabled.

See Also

DataSet Class | DataSet Members | System.Data Namespace | DataSet.Merge Overload List | ForeignKeyConstraint | UniqueConstraint


DataSet.Merge (DataSet, Boolean, MissingSchemaAction)

Merges this DataSet into a specified DataSet preserving changes according to the specified argument, and handling an incompatible schema according to the specified argument.

[Visual Basic]
Overloads Public Sub Merge( _
   ByVal dataSet As DataSet, _
   ByVal preserveChanges As Boolean, _
   ByVal missingSchemaAction As MissingSchemaAction _
)
[C#]
public void Merge(
   DataSet dataSet,
   bool preserveChanges,
   MissingSchemaAction missingSchemaAction
);
[C++]
public: void Merge(
   DataSet* dataSet,
   bool preserveChanges,
   MissingSchemaAction missingSchemaAction
);
[JScript]
public function Merge(
   dataSet : DataSet,
   preserveChanges : Boolean,
   missingSchemaAction : MissingSchemaAction
);

Parameters

dataSet
The DataSet whose data and schema will be merged.
preserveChanges
A value indicating whether changes in the current (target) DataSet should be maintained. true, if changes should be maintained; otherwise, false.
missingSchemaAction
One of the MissingSchemaAction values that specify what to do with an incompatible schema. Possible values include Add (for example, add a column), Ignore, or Error.

Exceptions

Exception Type | Condition
ArgumentNullException | The dataSet is a null reference (in Visual Basic Nothing).

Remarks

The Merge method is typically called after invoking the GetChanges method, which returns a DataSet optimized for merging.

To facilitate explanation of the Merge method, we use "target" to signify the current DataSet, and "source" to name the second (parameter) DataSet.

When the Merge method is called, the schemas of the two DataSet objects are compared. If the source DataSet contains schema elements that are missing in the target, the schema elements are added to the target. The data is then merged. When merging rows that have a DataRowState value of Unchanged, Modified, or Deleted source rows, the source's primary key is used to search for target rows that have the same primary key values. When merging New source rows, the new primary key value is used to search for target rows that are also New and have matching new primary keys.

If the source DataSet originated from a call to GetChanges on the target DataSet, a different matching procedure is employed. The source DataSet rows are matched up with the target rows they were cloned from. Once a match is found, original values in the target rows are updated with values from the source rows, while the changed values remain the same.

During a merge, constraints are disabled. If any constraints can't be enabled at the end of merge, an InvalidConstraintException is thrown and the data is kept with the constraints disabled.

See Also

DataSet Class | DataSet Members | System.Data Namespace | DataSet.Merge Overload List


DataSet.Merge (DataSet)

Merges this DataSet into a specified DataSet.

[Visual Basic]
Overloads Public Sub Merge( _
   ByVal dataSet As DataSet _
)
[C#]
public void Merge(
   DataSet dataSet
);
[C++]
public: void Merge(
   DataSet* dataSet
);
[JScript]
public function Merge(
   dataSet : DataSet
);

Parameters

dataSet
The DataSet whose data and schema will be merged.

Exceptions

Exception Type | Condition
InvalidConstraintException | One or more constraints cannot be enabled.
ArgumentNullException | The dataSet is a null reference (in Visual Basic Nothing).

Remarks

The Merge method is typically called after invoking the GetChanges method, which returns a DataSet optimized for merging.

To facilitate explanation of the Merge method, we use "target" to signify the current DataSet, and "source" to name the second (parameter) DataSet.

When the Merge method is called, the schemas of the two DataSet objects are compared. If the source DataSet contains schema elements that are missing in the target, the schema elements are added to the target. The data is then merged. When merging rows that have a DataRowState value of Unchanged, Modified, or Deleted source rows, the source's primary key is used to search for target rows that have the same primary key values. When merging New source rows, the new primary key value is used to search for target rows that are also New and have matching new primary keys.

If the source DataSet originated from a call to GetChanges on the target DataSet, a different matching procedure is employed. The source DataSet rows are matched up with the target rows they were cloned from. Once a match is found, original values in the target rows are updated with values from the source rows, while the changed values remain the same.

During a merge, constraints are disabled. If any constraints can't be enabled at the end of merge, an InvalidConstraintException is thrown and the data is kept with the constraints disabled.

See Also

DataSet Class | DataSet Members | System.Data Namespace | DataSet.Merge Overload List | ForeignKeyConstraint | UniqueConstraint


DataSet.Merge (DataRow[], Boolean, MissingSchemaAction)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Merge( _
   ByVal rows() As DataRow, _
   ByVal preserveChanges As Boolean, _
   ByVal missingSchemaAction As MissingSchemaAction _
)
[C#]
public void Merge(
   DataRow[] rows,
   bool preserveChanges,
   MissingSchemaAction missingSchemaAction
);
[C++]
public: void Merge(
   DataRow* rows[],
   bool preserveChanges,
   MissingSchemaAction missingSchemaAction
);
[JScript]
public function Merge(
   rows : DataRow[],
   preserveChanges : Boolean,
   missingSchemaAction : MissingSchemaAction
);

Parameters

rows
[To be supplied.]
preserveChanges
[To be supplied.]
missingSchemaAction
[To be supplied.]

See Also

DataSet Class | DataSet Members | System.Data Namespace | DataSet.Merge Overload List


DataSet.OnPropertyChanged

Raises the PropertyChanged event.

[Visual Basic]
Overridable Protected Sub OnPropertyChanged( _
   ByVal pcevent As PropertyChangedEventArgs _
)
[C#]
protected virtual void OnPropertyChanged(
   PropertyChangedEventArgs pcevent
);
[C++]
protected: virtual void OnPropertyChanged(
   PropertyChangedEventArgs* pcevent
);
[JScript]
protected function OnPropertyChanged(
   pcevent : PropertyChangedEventArgs
);

Parameters

pcevent
event

See Also

DataSet Class | DataSet Members | System.Data Namespace | AddOnPropertyChanged | RemoveOnPropertyChanged


DataSet.OnRemoveRelation

This method should be overriden by subclasses to restrict tables being removed.

[Visual Basic]
Overridable Protected Sub OnRemoveRelation( _
   ByVal relation As DataRelation _
)
[C#]
protected virtual void OnRemoveRelation(
   DataRelation relation
);
[C++]
protected: virtual void OnRemoveRelation(
   DataRelation* relation
);
[JScript]
protected function OnRemoveRelation(
   relation : DataRelation
);

Parameters

relation
[To be supplied.]

See Also

DataSet Class | DataSet Members | System.Data Namespace


DataSet.OnRemoveTable

This method should be overriden by subclasses to restrict tables being removed.

[Visual Basic]
Overridable Protected Sub OnRemoveTable( _
   ByVal table As DataTable _
)
[C#]
protected virtual void OnRemoveTable(
   DataTable table
);
[C++]
protected: virtual void OnRemoveTable(
   DataTable* table
);
[JScript]
protected function OnRemoveTable(
   table : DataTable
);

Parameters

table
The table to test.

See Also

DataSet Class | DataSet Members | System.Data Namespace


DataSet.RaisePropertyChanged

Raises the property changed event. This creates the needed event data and then calls OnPropertyChanged.

[Visual Basic]
Protected Sub RaisePropertyChanged( _
   ByVal name As String _
)
[C#]
protected void RaisePropertyChanged(
   string name
);
[C++]
protected: void RaisePropertyChanged(
   String* name
);
[JScript]
protected function RaisePropertyChanged(
   name : String
);

Parameters

name
Name of the changed property.

See Also

DataSet Class | DataSet Members | System.Data Namespace


DataSet.ReadDiffGram

Reads a specially formatted XML document that includes all changes, including before and after data.

Overload List

Reads a specially formatted XML document that includes all changes, including before and after data, from string.

[Visual Basic] Overloads Public Sub ReadDiffGram(String)
[C#] public void ReadDiffGram(String);
[C++] public: void ReadDiffGram(String*);
[JScript] public function ReadDiffGram(String);

Reads a specially formatted XML document that includes all changes, including before and after data, from a XmlReader.

[Visual Basic] Overloads Public Sub ReadDiffGram(XmlReader)
[C#] public void ReadDiffGram(XmlReader);
[C++] public: void ReadDiffGram(XmlReader*);
[JScript] public function ReadDiffGram(XmlReader);

Reads a specially formatted XML document that includes all changes, including before and after data, from a TextReader.

[Visual Basic] Overloads Public Sub ReadDiffGram(TextReader)
[C#] public void ReadDiffGram(TextReader);
[C++] public: void ReadDiffGram(TextReader*);
[JScript] public function ReadDiffGram(TextReader);

Reads a specially formatted XML document that includes all changes, including before and after data, from a Stream.

[Visual Basic] Overloads Public Sub ReadDiffGram(Stream)
[C#] public void ReadDiffGram(Stream);
[C++] public: void ReadDiffGram(Stream*);
[JScript] public function ReadDiffGram(Stream);

See Also

DataSet Class | DataSet Members | System.Data Namespace


DataSet.ReadDiffGram (String)

Reads a specially formatted XML document that includes all changes, including before and after data, from string.

[Visual Basic]
Overloads Public Sub ReadDiffGram( _
   ByVal str As String _
)
[C#]
public void ReadDiffGram(
   string str
);
[C++]
public: void ReadDiffGram(
   String* str
);
[JScript]
public function ReadDiffGram(
   str : String
);

Parameters

str
The string to read from.

See Also

DataSet Class | DataSet Members | System.Data Namespace | DataSet.ReadDiffGram Overload List


DataSet.ReadDiffGram (XmlReader)

Reads a specially formatted XML document that includes all changes, including before and after data, from a XmlReader.

[Visual Basic]
Overloads Public Sub ReadDiffGram( _
   ByVal reader As XmlReader _
)
[C#]
public void ReadDiffGram(
   XmlReader reader
);
[C++]
public: void ReadDiffGram(
   XmlReader* reader
);
[JScript]
public function ReadDiffGram(
   reader : XmlReader
);

Parameters

reader
The XmlReader to read from.

See Also

DataSet Class | DataSet Members | System.Data Namespace | DataSet.ReadDiffGram Overload List


DataSet.ReadDiffGram (TextReader)

Reads a specially formatted XML document that includes all changes, including before and after data, from a TextReader.

[Visual Basic]
Overloads Public Sub ReadDiffGram( _
   ByVal reader As TextReader _
)
[C#]
public void ReadDiffGram(
   TextReader reader
);
[C++]
public: void ReadDiffGram(
   TextReader* reader
);
[JScript]
public function ReadDiffGram(
   reader : TextReader
);

Parameters

reader
The TextReader to read from.

See Also

DataSet Class | DataSet Members | System.Data Namespace | DataSet.ReadDiffGram Overload List


DataSet.ReadDiffGram (Stream)

Reads a specially formatted XML document that includes all changes, including before and after data, from a Stream.

[Visual Basic]
Overloads Public Sub ReadDiffGram( _
   ByVal stream As Stream _
)
[C#]
public void ReadDiffGram(
   Stream stream
);
[C++]
public: void ReadDiffGram(
   Stream* stream
);
[JScript]
public function ReadDiffGram(
   stream : Stream
);

Parameters

stream
The Stream to read from.

Remarks

The XML document (or "diffgram") can be read by SQLServer. An example of the format is shown below. The document can convey the before and after versions of data that has been added, modified, or deleted.

<DocumentElement xmlns:msdata="urn:schemas-microsoft-com:xml-msdata" xmlns:sql="urn:schemas-microsoft-com:xml-sql">
   <sql:ssync>
   <!-- Deleted -->

   <sql:before>
      <Teachers sql:id="1">
         <ID>0</ID>
         <Name>Mr Apple</Name>
      </Teachers>
   </sql:before>
   <sql:after></sql:after>

   <!-- Unchanged -->

   <sql:before>
      <Teachers sql:id="2">
         <ID>1</ID>
         <Name>Mrs Blue</Name>
      </Teachers>
   </sql:before>
   <sql:after>
   <Teachers sql:id="2"></Teachers>
   </sql:after>

   <!-- New -->

   <sql:before></sql:before>
   <sql:after>
      <Courses sql:id="7">
         <ID>6</ID>
         <Name>Home Ec 200</Name>
         </Courses>
         </sql:after>

   <!-- Modified -->

      <sql:before>
      <Students sql:id="1">
         <ID>0</ID>
         <Name>Abe</Name>
      </Students>
      </sql:before>
      <sql:after>
      <Students sql:id="1">
         <ID>0</ID>
         <Name>Abby</Name>
      </Students>
      </sql:after>

      <!-- Removed -->

      <sql:before>
         <Students sql:id="2"></Students>
         </sql:before>
         <sql:after>
         </sql:after>
    </sql:ssync>
</DocumentElement>

See Also

DataSet Class | DataSet Members | System.Data Namespace | DataSet.ReadDiffGram Overload List | WriteDiffGram


DataSet.RejectChanges

This method rolls back all the changes to have been made to this DataSet since it was loaded or the last time AcceptChanges was called. Any rows still in edit-mode cancel their edits. New rows get removed. Modified and Deleted rows return back to their original state.

[Visual Basic]
Overridable Public Sub RejectChanges()
[C#]
public virtual void RejectChanges();
[C++]
public: virtual void RejectChanges();
[JScript]
public function RejectChanges();

See Also

DataSet Class | DataSet Members | System.Data Namespace


DataSet.RemoveOnMergeFailed

Removes an event handler for the merge failed event. This event occurs when Merge failed for any reason.

[Visual Basic]
Public Sub RemoveOnMergeFailed( _
   ByVal handler As MergeFailedEventHandler _
)
[C#]
public void RemoveOnMergeFailed(
   MergeFailedEventHandler handler
);
[C++]
public: void RemoveOnMergeFailed(
   MergeFailedEventHandler* handler
);
[JScript]
public function RemoveOnMergeFailed(
   handler : MergeFailedEventHandler
);

Parameters

handler
handler to remove for this event

See Also

DataSet Class | DataSet Members | System.Data Namespace | AddOnMergeFailed


DataSet.RemoveOnPropertyChanged

Removes an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.

[Visual Basic]
Public Sub RemoveOnPropertyChanged( _
   ByVal handler As PropertyChangedEventHandler _
)
[C#]
public void RemoveOnPropertyChanged(
   PropertyChangedEventHandler handler
);
[C++]
public: void RemoveOnPropertyChanged(
   PropertyChangedEventHandler* handler
);
[JScript]
public function RemoveOnPropertyChanged(
   handler : PropertyChangedEventHandler
);

Parameters

handler
handler to remove for this event

See Also

DataSet Class | DataSet Members | System.Data Namespace | AddOnPropertyChanged


DataSet.ResetLocale

Resets the Locale property to the current system locale.

[Visual Basic]
Public Sub ResetLocale()
[C#]
public void ResetLocale();
[C++]
public: void ResetLocale();
[JScript]
public function ResetLocale();

See Also

DataSet Class | DataSet Members | System.Data Namespace


DataSet.ResetRelations

Clears the collection of relations.

[Visual Basic]
Overridable Public Sub ResetRelations()
[C#]
public virtual void ResetRelations();
[C++]
public: virtual void ResetRelations();
[JScript]
public function ResetRelations();

See Also

DataSet Class | DataSet Members | System.Data Namespace


DataSet.ResetTables

[To be supplied.]

[Visual Basic]
Overridable Public Sub ResetTables()
[C#]
public virtual void ResetTables();
[C++]
public: virtual void ResetTables();
[JScript]
public function ResetTables();

See Also

DataSet Class | DataSet Members | System.Data Namespace


DataSet.SaveDiffGram

Saves a specially formatted XML document that includes all changes, including before and after data, to a specified TextWriter.

[Visual Basic]
Public Sub SaveDiffGram( _
   ByVal writer As TextWriter _
)
[C#]
public void SaveDiffGram(
   TextWriter writer
);
[C++]
public: void SaveDiffGram(
   TextWriter* writer
);
[JScript]
public function SaveDiffGram(
   writer : TextWriter
);

Parameters

writer
The TextWriter to save to.

See Also

DataSet Class | DataSet Members | System.Data Namespace


DataSet.ShouldPersistLocale

Indicates whether the locale property should be persisted. This is true if the user ever explicitly sets the locale property and doesn't call ResetLocale.

[Visual Basic]
Public Function ShouldPersistLocale() As Boolean
[C#]
public bool ShouldPersistLocale();
[C++]
public: bool ShouldPersistLocale();
[JScript]
public function ShouldPersistLocale() : Boolean;

Return Value

Whether to persist the locale.

See Also

DataSet Class | DataSet Members | System.Data Namespace


DataSet.ShouldPersistRelations

[To be supplied.]

[Visual Basic]
Overridable Public Function ShouldPersistRelations() As Boolean
[C#]
public virtual bool ShouldPersistRelations();
[C++]
public: virtual bool ShouldPersistRelations();
[JScript]
public function ShouldPersistRelations() : Boolean;

See Also

DataSet Class | DataSet Members | System.Data Namespace


DataSet.ShouldPersistTables

[To be supplied.]

[Visual Basic]
Overridable Public Function ShouldPersistTables() As Boolean
[C#]
public virtual bool ShouldPersistTables();
[C++]
public: virtual bool ShouldPersistTables();
[JScript]
public function ShouldPersistTables() : Boolean;

See Also

DataSet Class | DataSet Members | System.Data Namespace


DataSet.WriteDiffGram

Writes a specially formatted XML document that includes all changes, including before and after data, into the specfied XmlWriter.

[Visual Basic]
Public Sub WriteDiffGram( _
   ByVal writer As XmlWriter _
)
[C#]
public void WriteDiffGram(
   XmlWriter writer
);
[C++]
public: void WriteDiffGram(
   XmlWriter* writer
);
[JScript]
public function WriteDiffGram(
   writer : XmlWriter
);

Parameters

writer
The XmlWriter to write to.

See Also

DataSet Class | DataSet Members | System.Data Namespace | ReadDiffGram


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataSet Events

The events of the DataSet class are listed below. For a complete list of DataSet class members, see the DataSet Members topic.

Public:

MergeFailed | Occurs when attempting to merge schemas for two tables with the same name.
PropertyChanged | Occurs when a property value changes.

See Also

DataSet Class | System.Data Namespace


DataSet MergeFailed Event

Occurs when attempting to merge schemas for two tables with the same name.

The following declaration shows the syntax for a method that handles the MergeFailed event.

[Visual Basic]
Private Sub DataSetName_MergeFailed( _
   ByVal sender As Object, _
   ByVal e As MergeFailedEventArgs _
)
[C#]
private void DataSetName_MergeFailed(
   object sender,
   MergeFailedEventArgs e
);
[C++]
private: void DataSetName_MergeFailed(
   Object* sender,
   MergeFailedEventArgs* e
);
[JScript]
private DataSetName_MergeFailed(
   sender : Object,
   e : MergeFailedEventArgs
);

Parameters

sender
The source of the event.
e
A MergeFailedEventArgs that contains the event data. The following MergeFailedEventArgs properties provide information specific to this event.
Property Description
Conflict
[To be supplied.]
Table
[To be supplied.]

See Also

DataSet Class | DataSet MembersTopic | System.Data Namespace


DataSet PropertyChanged Event

Occurs when a property value changes.

The following declaration shows the syntax for a method that handles the PropertyChanged event.

[Visual Basic]
Private Sub DataSetName_PropertyChanged( _
   ByVal sender As Object, _
   ByVal e As PropertyChangedEventArgs _
)
[C#]
private void DataSetName_PropertyChanged(
   object sender,
   PropertyChangedEventArgs e
);
[C++]
private: void DataSetName_PropertyChanged(
   Object* sender,
   PropertyChangedEventArgs* e
);
[JScript]
private DataSetName_PropertyChanged(
   sender : Object,
   e : PropertyChangedEventArgs
);

Parameters

sender
The source of the event.
e
A PropertyChangedEventArgs that contains the event data. The following PropertyChangedEventArgs properties provide information specific to this event.
Property Description
PropertyName
Gets the name of the property that changed.

See Also

DataSet Class | DataSet MembersTopic | System.Data Namespace


DataSetView Class

Represents a view of a DataSet with individual filters automatically set on each of its tables.

Object
Component
DataSetView

[Visual Basic]
Public Class DataSetView
   Inherits Component
   Implements IList, ICollection, IEnumerable, ITypedList
[C#]
public class DataSetView : Component, IList, ICollection,
   IEnumerable, ITypedList
[C++]
public __gc class DataSetView : public Component, IList,
   ICollection, IEnumerable, ITypedList
[JScript]
public class DataSetView extends Component, IList, ICollection,
   IEnumerable, ITypedList

Remarks

The DataSetView is an advanced feature of ADO+ that allows you to create multiple views of the same DataSet. This functionality allows you to create complex views of related tables where each table has a different filter, sort, state, and row state. For example, imagine a master/details view of a customers/orders relationship. The customers table is set to display only those customers whose names are "Smith." The orders table, on the other hand, shows only the orders (of the customers named "Smith") that have not yet shipped.

The steps to creating this scenario are as follows:

  1. Create and populate a DataSet.
  2. Create the DataSetView, passing the DataSet as an argument to the DataSetView.
  3. Add TableSetting objects to the TableSettingsCollection collection, one for each table in the DataSet.
  4. Bind the tables to appropriate controls (such as a ComboBox or a DataGrid control).

To bind a control to a DataSetView, determine if the control uses simple binding or complex binding. For example, a TextBox control can only be simple bound; a ComboBox, on the other hand, is complex bound.

To simple bind a TextBox control, access its BindingsCollection through its RichControl.Bindings property, and add a ListBinding to the collection.

To complex bind a ComboBox control, set its DataSource property to the DataSetView, and set the DisplayMember property to the DataTable and DataColumn to bind to. Use DataRelation objects to navigate from the parent table to its child table.

Requirements

Namespace: System.Data

Assembly: System.Data.dll

Example [Visual Basic]

The following example creates a DataSetView with a given DataSet, and adds two TableSetting objects to the TableSettingsCollection collection. A ComboBox and a DataGrid control are then bound to the DataSetView.

[Visual Basic]

' The next two lines go into the Declarations section of the module:
Private myDataSetView As DataSetView
' SuppliersProducts is a class derived from DataSet.
Private myDataSet As SuppliersProducts

Private Sub CreateDataSetView()
   ' Not shown: SuppliersProducts is already configured with tables, relations, constraints.
   myDataSet = New SuppliersProducts
   myDataSetView = New DataSetView(myDataSet)
End Sub

Private Sub AddTableSettings()
   ' Create TableSetting and add it to TableSettingsCollection.
   Dim ts As TableSetting

   ts = New TableSetting(myDataSet.Tables("Suppliers"), "CompanyName", _
   "CompanyName < Z" & Combo1.Text, DataRowState.ModifiedCurrent)
   myDataSetView.TableSettings.Add(ts)

   ' Create and add second TableSetting.
   ts = New TableSetting(myDataSet.Tables("Products"), "ProductName", _
   "Discontinued = 'True'", DataRowState.CurrentRows)
   myDataSetView.TableSettings.Add(ts)
End Sub

Private Sub BindControls()
   ComboBox1.DataSource = myDataSetView
   ' Specify the table name and column name in the DisplayMember.
   ComboBox1.DisplayMember = "Suppliers.CompanyName"
   DataGrid1.DataSource = myDataSetView
   ' Specify the table to be viewed in the DataMember.
   DataGrid1.DataMember = "Products"
End Sub

See Also

DataSetView Members | System.Data Namespace | DataRelation | DataSet | DataView | TableSettingsCollection | TableSetting | BindingManager | BindingsCollection | ListBinding


DataSetView Members

Public:

Constructor

DataSetView Constructor Overloaded. Initializes a new instance of the DataSetView class.

Properties

DataSet | Gets or sets the DataSet to be viewed.
Site (inherited from Component) | Gets or sets the site of the Component.
TableSettings | [To be supplied.]

Methods

CreateDataView | [To be supplied.]
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanged | Raises the OnPropertyChanged event.

See Also

DataSetView Class | System.Data Namespace


DataSetView Constructor

Initializes a new instance of the DataSetView class.

Overload List

Initializes a new instance of the DataSetView class.

[Visual Basic] Overloads Public Sub New()
[C#] public DataSetView();
[C++] public: DataSetView();
[JScript] public function DataSetView();

Initializes a new instance of the DataSetView class using the specified DataSet.

[Visual Basic] Overloads Public Sub New(DataSet)
[C#] public DataSetView(DataSet);
[C++] public: DataSetView(DataSet*);
[JScript] public function DataSetView(DataSet);

Example [Visual Basic]

The following example creates a new DataSetView using a given DataSet.

Note This example shows how to use one of the overloaded version of the DataSetView constructor. For other examples that may be available, see the individual overload topics.

[Visual Basic]

' The next two lines go into the Declarations section of the module:
Private myDataSetView As DataSetView
' SuppliersProducts is a class derived from DataSet.
Private myDataSet As SuppliersProducts

Private Sub CreateDataSetView()
   ' Not shown: SuppliersProducts is already configured with tables, relations, constraints.
   Set myDataSet = New SuppliersProducts
   Set myDataSetView = New DataSetView(myDataSet)
End Sub

Private Sub AddTableSettings()
   ' Create TableSetting and add it to TableSettingsCollection.
   Dim ts As TableSetting
   Set ts = New TableSetting(myDataSet.Tables("Suppliers"), "CompanyName", _
   "CompanyName < Z" & Combo1.Text, DataRowState.ModifiedCurrent)
   myDataSetView.TableSettings.Add(ts)

   ' Create and add second TableSetting.
   Set ts = New TableSetting(myDataSet.Tables("Products"), "ProductName", _
   "Discontinued = 'True'", DataRowState.CurrentRows)
   myDataSetView.TableSettings.Add(ts)
End Sub

See Also

DataSetView Class | DataSetView Members | System.Data Namespace


DataSetView Constructor ()

Initializes a new instance of the DataSetView class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public DataSetView();
[C++]
public: DataSetView();
[JScript]
public function DataSetView();

Example [Visual Basic]

The following example creates a DataSetView based on a given DataSet.

[Visual Basic]

' The next two lines go into the Declarations section of the module:
Private myDataSetView As DataSetView
' SuppliersProducts is a class derived from DataSet.
Private myDataSet As SuppliersProducts

Private Sub CreateDataSetView()
   myDataSet = New SuppliersProducts
   myDataSetView = New DataSetView()
   myDataSetView.DataSet = myDataSet
   ' Add Settings.
End Sub

Private Sub AddTableSettings()
   ' Create TableSetting and add it to TableSettingsCollection.
   Dim ts As TableSetting
   Set ts = New TableSetting(myDataSet.Tables("Suppliers"), "CompanyName", _
   "CompanyName < Z" & Combo1.Text, DataRowState.ModifiedCurrent)
   myDataSetView.TableSettings.Add(ts)

   ' Create and add second TableSetting.
   Set ts = New TableSetting(myDataSet.Tables("Products"), "ProductName", _
   "Discontinued = 'True'", DataRowState.CurrentRows)
   myDataSetView.TableSettings.Add(ts)
End Sub

See Also

DataSetView Class | DataSetView Members | System.Data Namespace | DataSetView Constructor Overload List


DataSetView Constructor (DataSet)

Initializes a new instance of the DataSetView class using the specified DataSet.

[Visual Basic]
Overloads Public Sub New( _
   ByVal dataSet As DataSet _
)
[C#]
public DataSetView(
   DataSet dataSet
);
[C++]
public: DataSetView(
   DataSet* dataSet
);
[JScript]
public function DataSetView(
   dataSet : DataSet
);

Parameters

dataSet
The DataSet to be viewed/

Example [Visual Basic]

The following example creates a new DataSetView using a given DataSet.

[Visual Basic]

' The next two lines go into the Declarations section of the module:
Private myDataSetView As DataSetView
' SuppliersProducts is a class derived from DataSet.
Private myDataSet As SuppliersProducts

Private Sub CreateDataSetView()
   ' Not shown: SuppliersProducts is already configured with tables, relations, constraints.
   Set myDataSet = New SuppliersProducts
   Set myDataSetView = New DataSetView(myDataSet)
End Sub

Private Sub AddTableSettings()
   ' Create TableSetting and add it to TableSettingsCollection.
   Dim ts As TableSetting
   Set ts = New TableSetting(myDataSet.Tables("Suppliers"), "CompanyName", _
   "CompanyName < Z" & Combo1.Text, DataRowState.ModifiedCurrent)
   myDataSetView.TableSettings.Add(ts)

   ' Create and add second TableSetting.
   Set ts = New TableSetting(myDataSet.Tables("Products"), "ProductName", _
   "Discontinued = 'True'", DataRowState.CurrentRows)
   myDataSetView.TableSettings.Add(ts)
End Sub

See Also

DataSetView Class | DataSetView Members | System.Data Namespace | DataSetView Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataSetView Properties

The properties of the DataSetView class are listed below. For a complete list of DataSetView class members, see the DataSetView Members topic.

Public:

DataSet | Gets or sets the DataSet to be viewed.
Site (inherited from Component) | Gets or sets the site of the Component.
TableSettings | [To be supplied.]

See Also

DataSetView Class | System.Data Namespace


DataSetView.DataSet

Gets or sets the DataSet to be viewed.

[Visual Basic]
Public Property DataSet As DataSet
[C#]
public DataSet DataSet {get; set;}
[C++]
public: __property DataSet* get_DataSet();
public: __property void set_DataSet(DataSet*);
[JScript]
public function get DataSet() : DataSet;
public function set DataSet(DataSet);

Property Value

A DataSet to be viewed.

Exceptions

Exception Type | Condition
Exception | The DataSet for this DataSetView is already set to the DefaultView of a DataSet.

Example [Visual Basic]

The following example creates a new DataSetView and sets the DataSet property.

[Visual Basic]

' The next two lines go into the Declarations section of the module:
Private myDataSetView As DataSetView
' SuppliersProducts is a class derived from DataSet.
Private myDataSet As SuppliersProducts

Private Sub CreateDataSetView()
   myDataSet = New SuppliersProducts
   myDataSetView = New DataSetView()
   myDataSetView.DataSet = myDataSet
   ' Add Settings.

End Sub

See Also

DataSetView Class | DataSetView Members | System.Data Namespace | DataSet


DataSetView.TableSettings

[To be supplied.]

[Visual Basic]
Public ReadOnly Property TableSettings As TableSettingsCollection
[C#]
public TableSettingsCollection TableSettings {get;}
[C++]
public: __property TableSettingsCollection* get_TableSettings();
[JScript]
public function get TableSettings() : TableSettingsCollection;

See Also

DataSetView Class | DataSetView Members | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataSetView Methods

The methods of the DataSetView class are listed below. For a complete list of DataSetView class members, see the DataSetView Members topic.

Public:

CreateDataView | [To be supplied.]
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanged | Raises the OnPropertyChanged event.

See Also

DataSetView Class | System.Data Namespace


DataSetView.CreateDataView

[To be supplied.]

[Visual Basic]
Public Function CreateDataView( _
   ByVal table As DataTable _
) As DataView
[C#]
public DataView CreateDataView(
   DataTable table
);
[C++]
public: DataView* CreateDataView(
   DataTable* table
);
[JScript]
public function CreateDataView(
   table : DataTable
) : DataView;

Parameters

table
[To be supplied.]

See Also

DataSetView Class | DataSetView Members | System.Data Namespace


DataSetView.OnPropertyChanged

Raises the OnPropertyChanged event.

[Visual Basic]
Overridable Protected Sub OnPropertyChanged( _
   ByVal e As PropertyChangedEventArgs _
)
[C#]
protected virtual void OnPropertyChanged(
   PropertyChangedEventArgs e
);
[C++]
protected: virtual void OnPropertyChanged(
   PropertyChangedEventArgs* e
);
[JScript]
protected function OnPropertyChanged(
   e : PropertyChangedEventArgs
);

Parameters

e
A PropertyChangedEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see TBD.

Notes to Inheritors: When overriding OnPropertyChanged in a derived class, be sure to call the base class's OnPropertyChanged method.

See Also

DataSetView Class | DataSetView Members | System.Data Namespace


DataSetViewListItem Class

[To be supplied.]

Object
DataSetViewListItemTypeDescriptor
DataSetViewListItem

[Visual Basic]
Public Class DataSetViewListItem
   Inherits DataSetViewListItemTypeDescriptor
[C#]
public class DataSetViewListItem :
   DataSetViewListItemTypeDescriptor
[C++]
public __gc class DataSetViewListItem : public
   DataSetViewListItemTypeDescriptor
[JScript]
public class DataSetViewListItem extends
   DataSetViewListItemTypeDescriptor

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

DataSetViewListItem Members | System.Data Namespace


DataSetViewListItem Members

Public:

Constructor

DataSetViewListItem Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataSetViewListItem Class | System.Data Namespace


DataSetViewListItem Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal dataSetView As DataSetView _
)
[C#]
public DataSetViewListItem(
   DataSetView dataSetView
);
[C++]
public: DataSetViewListItem(
   DataSetView* dataSetView
);
[JScript]
public function DataSetViewListItem(
   dataSetView : DataSetView
);

Parameters

dataSetView
[To be supplied.]

See Also

DataSetViewListItem Class | DataSetViewListItem Members | System.Data Namespace


DataSetViewListItemTableDescriptor Class

[To be supplied.]

Object
MemberDescriptor
PropertyDescriptor
DataSetViewListItemTableDescriptor

[Visual Basic]
Public Class DataSetViewListItemTableDescriptor
   Inherits PropertyDescriptor
[C#]
public class DataSetViewListItemTableDescriptor :
   PropertyDescriptor
[C++]
public __gc class DataSetViewListItemTableDescriptor : public
   PropertyDescriptor
[JScript]
public class DataSetViewListItemTableDescriptor extends
   PropertyDescriptor

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

DataSetViewListItemTableDescriptor Members | System.Data Namespace


DataSetViewListItemTableDescriptor Members

Public:

Properties

Attributes (inherited from MemberDescriptor) | Gets the collection of attributes for this member.
Category (inherited from MemberDescriptor) | Gets the name of the category that the member belongs to, as specified in the CategoryAttribute.
ComponentType | [To be supplied.]
Converter (inherited from PropertyDescriptor) | Gets the type converter for this property.
Description (inherited from MemberDescriptor) | Gets the description of the member as specified in the DescriptionAttribute.
IsBrowsable (inherited from MemberDescriptor) | Gets a value indicating whether the member is browsable as specified in the BrowsableAttribute.
IsLocalizable (inherited from PropertyDescriptor) | Gets a value indicating whether this property should be localized, as specified in the LocalizableAttribute.
IsReadOnly | [To be supplied.]
IsRealProperty | [To be supplied.]
Name (inherited from MemberDescriptor) | Gets the name of the member.
PersistableSupport (inherited from PropertyDescriptor) | Gets a value indicating whether this property should be persisted as specified in the PersistableAttribute.
PropertyType | [To be supplied.]
Table | [To be supplied.]

Methods

CanResetValue | [To be supplied.]
Equals | [To be supplied.]
GetDesignTimeOnly (inherited from MemberDescriptor) | Determines whether this member should be set only at design time as specified in the DesignOnlyAttribute.
GetDisplayName (inherited from MemberDescriptor) | Gets the name that can be displayed in a window like a property browser.
GetEditor (inherited from PropertyDescriptor) | Gets an editor of the specified type.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHelpTopic (inherited from MemberDescriptor) | Gets the name of the Help topic specified in the HelpAttribute.
GetHelpURL (inherited from MemberDescriptor) | Gets the URL for the Help file specified in the HelpAttribute.
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | [To be supplied.]
ResetValue | [To be supplied.]
SetValue | [To be supplied.]
ShouldPersistValue | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

AttributeArray (inherited from MemberDescriptor) | Gets or sets an array of attributes.
NameHashCode (inherited from MemberDescriptor) | Gets the hash code for the name of the member as specified in GetHashCode.

Methods

CreateAttributeCollection (inherited from MemberDescriptor) | Creates a collection of attributes using the array of attributes that you passed to the constructor.
CreateInstance (inherited from PropertyDescriptor) | Creates an instance of the specified type.
FillAttributes (inherited from MemberDescriptor) | In an inheriting class, adds the attributes of the inheriting class to the specified list of attributes in the parent class.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataSetViewListItemTableDescriptor Class | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataSetViewListItemTableDescriptor Properties

The properties of the DataSetViewListItemTableDescriptor class are listed below. For a complete list of DataSetViewListItemTableDescriptor class members, see the DataSetViewListItemTableDescriptor Members topic.

Public:

Attributes (inherited from MemberDescriptor) | Gets the collection of attributes for this member.
Category (inherited from MemberDescriptor) | Gets the name of the category that the member belongs to, as specified in the CategoryAttribute.
ComponentType | [To be supplied.]
Converter (inherited from PropertyDescriptor) | Gets the type converter for this property.
Description (inherited from MemberDescriptor) | Gets the description of the member as specified in the DescriptionAttribute.
IsBrowsable (inherited from MemberDescriptor) | Gets a value indicating whether the member is browsable as specified in the BrowsableAttribute.
IsLocalizable (inherited from PropertyDescriptor) | Gets a value indicating whether this property should be localized, as specified in the LocalizableAttribute.
IsReadOnly | [To be supplied.]
IsRealProperty | [To be supplied.]
Name (inherited from MemberDescriptor) | Gets the name of the member.
PersistableSupport (inherited from PropertyDescriptor) | Gets a value indicating whether this property should be persisted as specified in the PersistableAttribute.
PropertyType | [To be supplied.]
Table | [To be supplied.]

Protected:

AttributeArray (inherited from MemberDescriptor) | Gets or sets an array of attributes.
NameHashCode (inherited from MemberDescriptor) | Gets the hash code for the name of the member as specified in GetHashCode.

See Also

DataSetViewListItemTableDescriptor Class | System.Data Namespace


DataSetViewListItemTableDescriptor.ComponentType

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property ComponentType As Type
[C#]
public Type ComponentType {override get;}
[C++]
public: __property virtual Type* get_ComponentType();
[JScript]
public function get ComponentType() : Type;

See Also

DataSetViewListItemTableDescriptor Class | DataSetViewListItemTableDescriptor Members | System.Data Namespace


DataSetViewListItemTableDescriptor.IsReadOnly

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {override get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;

See Also

DataSetViewListItemTableDescriptor Class | DataSetViewListItemTableDescriptor Members | System.Data Namespace


DataSetViewListItemTableDescriptor.IsRealProperty

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsRealProperty As Boolean
[C#]
public bool IsRealProperty {override get;}
[C++]
public: __property virtual bool get_IsRealProperty();
[JScript]
public function get IsRealProperty() : Boolean;

See Also

DataSetViewListItemTableDescriptor Class | DataSetViewListItemTableDescriptor Members | System.Data Namespace


DataSetViewListItemTableDescriptor.PropertyType

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property PropertyType As Type
[C#]
public Type PropertyType {override get;}
[C++]
public: __property virtual Type* get_PropertyType();
[JScript]
public function get PropertyType() : Type;

See Also

DataSetViewListItemTableDescriptor Class | DataSetViewListItemTableDescriptor Members | System.Data Namespace


DataSetViewListItemTableDescriptor.Table

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Table As DataTable
[C#]
public DataTable Table {get;}
[C++]
public: __property DataTable* get_Table();
[JScript]
public function get Table() : DataTable;

See Also

DataSetViewListItemTableDescriptor Class | DataSetViewListItemTableDescriptor Members | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataSetViewListItemTableDescriptor Methods

The methods of the DataSetViewListItemTableDescriptor class are listed below. For a complete list of DataSetViewListItemTableDescriptor class members, see the DataSetViewListItemTableDescriptor Members topic.

Public:

CanResetValue | [To be supplied.]
Equals | [To be supplied.]
GetDesignTimeOnly (inherited from MemberDescriptor) | Determines whether this member should be set only at design time as specified in the DesignOnlyAttribute.
GetDisplayName (inherited from MemberDescriptor) | Gets the name that can be displayed in a window like a property browser.
GetEditor (inherited from PropertyDescriptor) | Gets an editor of the specified type.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHelpTopic (inherited from MemberDescriptor) | Gets the name of the Help topic specified in the HelpAttribute.
GetHelpURL (inherited from MemberDescriptor) | Gets the URL for the Help file specified in the HelpAttribute.
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | [To be supplied.]
ResetValue | [To be supplied.]
SetValue | [To be supplied.]
ShouldPersistValue | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

CreateAttributeCollection (inherited from MemberDescriptor) | Creates a collection of attributes using the array of attributes that you passed to the constructor.
CreateInstance (inherited from PropertyDescriptor) | Creates an instance of the specified type.
FillAttributes (inherited from MemberDescriptor) | In an inheriting class, adds the attributes of the inheriting class to the specified list of attributes in the parent class.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataSetViewListItemTableDescriptor Class | System.Data Namespace


DataSetViewListItemTableDescriptor.CanResetValue

[To be supplied.]

[Visual Basic]
Overrides Public Function CanResetValue( _
   ByVal component As Object _
) As Boolean
[C#]
public override bool CanResetValue(
   object component
);
[C++]
public: override bool CanResetValue(
   Object* component
);
[JScript]
public override function CanResetValue(
   component : Object
) : Boolean;

Parameters

component
[To be supplied.]

See Also

DataSetViewListItemTableDescriptor Class | DataSetViewListItemTableDescriptor Members | System.Data Namespace


DataSetViewListItemTableDescriptor.Equals

[To be supplied.]

[Visual Basic]
Overrides Public Function Equals( _
   ByVal other As Object _
) As Boolean
[C#]
public override bool Equals(
   object other
);
[C++]
public: override bool Equals(
   Object* other
);
[JScript]
public override function Equals(
   other : Object
) : Boolean;

Parameters

other
[To be supplied.]

See Also

DataSetViewListItemTableDescriptor Class | DataSetViewListItemTableDescriptor Members | System.Data Namespace


DataSetViewListItemTableDescriptor.GetValue

[To be supplied.]

[Visual Basic]
Overrides Public Function GetValue( _
   ByVal component As Object _
) As Object
[C#]
public override object GetValue(
   object component
);
[C++]
public: override Object* GetValue(
   Object* component
);
[JScript]
public override function GetValue(
   component : Object
) : Object;

Parameters

component
[To be supplied.]

See Also

DataSetViewListItemTableDescriptor Class | DataSetViewListItemTableDescriptor Members | System.Data Namespace


DataSetViewListItemTableDescriptor.ResetValue

[To be supplied.]

[Visual Basic]
Overrides Public Sub ResetValue( _
   ByVal component As Object _
)
[C#]
public override void ResetValue(
   object component
);
[C++]
public: override void ResetValue(
   Object* component
);
[JScript]
public override function ResetValue(
   component : Object
);

Parameters

component
[To be supplied.]

See Also

DataSetViewListItemTableDescriptor Class | DataSetViewListItemTableDescriptor Members | System.Data Namespace


DataSetViewListItemTableDescriptor.SetValue

[To be supplied.]

[Visual Basic]
Overrides Public Sub SetValue( _
   ByVal component As Object, _
   ByVal value As Object _
)
[C#]
public override void SetValue(
   object component,
   object value
);
[C++]
public: override void SetValue(
   Object* component,
   Object* value
);
[JScript]
public override function SetValue(
   component : Object,
   value : Object
);

Parameters

component
[To be supplied.]
value
[To be supplied.]

See Also

DataSetViewListItemTableDescriptor Class | DataSetViewListItemTableDescriptor Members | System.Data Namespace


DataSetViewListItemTableDescriptor.ShouldPersistValue

[To be supplied.]

[Visual Basic]
Overrides Public Function ShouldPersistValue( _
   ByVal component As Object _
) As Boolean
[C#]
public override bool ShouldPersistValue(
   object component
);
[C++]
public: override bool ShouldPersistValue(
   Object* component
);
[JScript]
public override function ShouldPersistValue(
   component : Object
) : Boolean;

Parameters

component
[To be supplied.]

See Also

DataSetViewListItemTableDescriptor Class | DataSetViewListItemTableDescriptor Members | System.Data Namespace


DataSetViewListItemTypeDescriptor Class

[To be supplied.]

Object
DataSetViewListItemTypeDescriptor

[Visual Basic]
Public Class DataSetViewListItemTypeDescriptor
   Implements ICustomTypeDescriptor
[C#]
public class DataSetViewListItemTypeDescriptor :
   ICustomTypeDescriptor
[C++]
public __gc class DataSetViewListItemTypeDescriptor : public
   ICustomTypeDescriptor
[JScript]
public class DataSetViewListItemTypeDescriptor implements
   ICustomTypeDescriptor

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

DataSetViewListItemTypeDescriptor Members | System.Data Namespace


DataSetViewListItemTypeDescriptor Members

Public:

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataSetViewListItemTypeDescriptor Class | System.Data Namespace


DataSysDescriptionAttribute Class

DescriptionAttribute marks a property, event, or extender with a description. Visual designers can display this description when referencing the member.

Object
Attribute
MemberAttribute
DescriptionAttribute
DataSysDescriptionAttribute

[Visual Basic]
Public Class DataSysDescriptionAttribute
   Inherits DescriptionAttribute
[C#]
public class DataSysDescriptionAttribute : DescriptionAttribute
[C++]
public __gc class DataSysDescriptionAttribute : public
   DescriptionAttribute
[JScript]
public class DataSysDescriptionAttribute extends
   DescriptionAttribute

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

DataSysDescriptionAttribute Members | System.Data Namespace | MemberAttribute | PropertyDescriptor | EventDescriptor | PropertyDescriptor | ExtendedPropertyDescriptor


DataSysDescriptionAttribute Members

Public:

Constructor

DataSysDescriptionAttribute Constructor Constructs a new sys description.

Properties

TypeId (inherited from MemberAttribute) Gets a unique ID for this MemberAttribute.

Methods

Equals (inherited from MemberAttribute) | [To be supplied.]
GetDescription | Retrieves the description text.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsDefaultAttribute (inherited from MemberAttribute) | When overridden in a derived class, specifies whether this MemberAttribute is the default attribute for the class.
Match (inherited from MemberAttribute) | Determines whether one attribute matches another.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

description (inherited from DescriptionAttribute) This is the description.

See Also

DataSysDescriptionAttribute Class | System.Data Namespace


DataSysDescriptionAttribute Constructor

Constructs a new sys description.

[Visual Basic]
Public Sub New( _
   ByVal description As String _
)
[C#]
public DataSysDescriptionAttribute(
   string description
);
[C++]
public: DataSysDescriptionAttribute(
   String* description
);
[JScript]
public function DataSysDescriptionAttribute(
   description : String
);

Parameters

description
description text.

See Also

DataSysDescriptionAttribute Class | DataSysDescriptionAttribute Members | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataSysDescriptionAttribute Methods

The methods of the DataSysDescriptionAttribute class are listed below. For a complete list of DataSysDescriptionAttribute class members, see the DataSysDescriptionAttribute Members topic.

Public:

Equals (inherited from MemberAttribute) | [To be supplied.]
GetDescription | Retrieves the description text.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsDefaultAttribute (inherited from MemberAttribute) | When overridden in a derived class, specifies whether this MemberAttribute is the default attribute for the class.
Match (inherited from MemberAttribute) | Determines whether one attribute matches another.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataSysDescriptionAttribute Class | System.Data Namespace


DataSysDescriptionAttribute.GetDescription

Retrieves the description text.

[Visual Basic]
Overrides Public Function GetDescription() As String
[C#]
public override string GetDescription();
[C++]
public: override String* GetDescription();
[JScript]
public override function GetDescription() : String;

Return Value

description

See Also

DataSysDescriptionAttribute Class | DataSysDescriptionAttribute Members | System.Data Namespace


DataTable Class

Represents one table of in-memory data.

Object
Component
DataTable

[Visual Basic]
Public Class DataTable
   Inherits Component
   Implements IListSource
[C#]
public class DataTable : Component, IListSource
[C++]
public __gc class DataTable : public Component, IListSource
[JScript]
public class DataTable extends Component, IListSource

Remarks

The DataTable is a central object in the ADO+ library. Other objects which use the DataTable include the DataSet and the DataView.

If you are creating a DataTable programmatically, you must first define its schema by adding DataColumn objects to the ColumnsCollection (accessed through the Columns property). Only after all columns have been added can you then begin to add DataRow objects to the RowsCollection (accessed through the Rows property).

Note To add rows to a table, you must first use the NewRow method to return a new DataRow object. The NewRow method returns a row with the table's schema, as it is defined by the table's columns.

The schema of a table is defined by the ColumnsCollection, the collection of DataColumn objects. The ColumnsCollection is accessed through the Columns property. A DataTable must have at least one column to qualify as a table. See the DataColumn and ColumnsCollection for more information about defining a schema for the table.

The DataTable contains a collection of Constraint objects that can be used to ensure the integrity of the data.

The System.WinForms.DataGrid control can display one table at a time. The DataTable of the currently displayed table can be accessed through the System.WinForms.DataGrid.DataGridTable property.

When an instance of DataTable is created, some of the read/write properties are set to initial values. For a list of these values, see the DataTable constructor.

Requirements

Namespace: System.Data

Assembly: System.Data.dll

Example [Visual Basic]

The following example creates two DataTable objects, two DataRelation objects, and adds the new objects to a DataSet.

[Visual Basic]

' Put the next lines into the Declarations section.
Private myDataSet As DataSet
Private parentTable As DataTable
Private childTable As DataTable

Private Sub MakeDataSet()
   MakeParentTable
   MakeChildTable
   MakeDataRelation
End Sub

Private Sub MakeParentDataTable()
   ' Create a new DataTable.
   Dim myDataTable As New DataTable
   Dim myDataColumn As DataColumn
   Dim myDataRow As DataRow

   ' Create new DataColumn, set DataType, ColumnName and add to DataTable.
   myDataColumn = New DataColumn
   With myDataColumn
      .DataType = System.Type.GetType("System.Int32")
      .ColumnName = "id"
      .AutoIncrement = True
      .AutoIncrementSeed = 1
      .AutoIncrementStep = 1
      .Caption = "ID"
      .ReadOnly = True
      .Unique = True
   End With

   ' Add the Column to the ColumnsCollection.
   myDataTable.Columns.Add(myDataColumn)

   ' Make the ID column the primary key column.
   Dim cols() As DataColumn
   cols(0) = myDataColumn
   myDataTable.PrimaryKey = cols

   ' Create second column.
   myDataColumn = New DataColumn
   With myDataColumn
      .DataType = System.Type.GetType("System.String")
      .ColumnName = "Item"
      .AutoIncrement = False
      .Caption = "Item"
      .ReadOnly = False
      .Unique = False
   End With
   myDataTable.Columns.Add(myDataColumn)
   ' Create new DataRow objects and add to DataTable.
   Dim i As Integer

   For i = 0 To 4
      myDataRow = myDataTable.NewRow
      myDataRow("id") = i
      myDataRow("Item") = "Item " & i
      myDataTable.Rows.Add myDataRow
   Next i

   myDataSet = New DataSet
   myDataSet.Tables.Add(myDataTable)
End Sub

Private Sub MakeChildDataTable()
   ' Create a new DataTable.
   Dim myDataTable As New DataTable
   Dim myDataColumn As DataColumn
   Dim myDataRow As DataRow

   ' Create new DataColumn, set DataType, ColumnName and add to DataTable.
   myDataColumn = New DataColumn
   With myDataColumn
      .DataType = System.Type.GetType("System.Int32")
      .ColumnName = "ChildID"
      .AutoIncrement = True
      .AutoIncrementSeed = 1
      .AutoIncrementStep = 1
      .Caption = "ID"
      .ReadOnly = True
      .Unique = True
   End With

   ' Add the Column to the ColumnsCollection.
   myDataTable.Columns.Add(myDataColumn)

   ' Make the ID column the primary key column.
   Dim cols() As DataColumn
   cols(0) = myDataColumn
   myDataTable.PrimaryKey = cols

   ' Create second column.
   myDataColumn = New DataColumn
   With myDataColumn
      .DataType = System.Type.GetType("System.String")
      .ColumnName = "ChildItem"
      .AutoIncrement = False
      .Caption = "ChildItem"
      .ReadOnly = False
      .Unique = False
   End With

   myDataTable.Columns.Add(myDataColumn)

   ' Create third column.
   myDataColumn = New DataColumn
   With myDataColumn
      .DataType = System.Type.GetType("System.Int32")
      .ColumnName = "ParentID"
      .AutoIncrement = False
      .Caption = "ParentID"
      .ReadOnly = False
      .Unique = False
   End With

   myDataTable.Columns.Add(myDataColumn)

   ' Create new DataRow objects and add to DataTable.
   Dim i As Integer
   Dim j As Integer
   For i = 0 To 20
      myDataRow = myDataTable.NewRow
      myDataRow("childID") = i
      myDataRow("Item") = "Item " & i
      myDataTable.Rows.Add(myDataRow)

   Next i
   ' Instantiate the DataSet and add the new DataTable.
   myDataSet = New DataSet
   myDataSet.Tables.Add(myDataTable)
End Sub

See Also

DataTable Members | System.Data Namespace | ColumnsCollection | DataColumn | DataRow | DataSet | DataView | RowsCollection


DataTable Members

Public:

Constructor

DataTable Constructor Overloaded. Initializes a new instance of the DataTable class.

Properties

CaseSensitive | Indicates whether string comparisons within the table are case-sensitive.
ChildRelations | Gets the collection of child relations for this DataTable.
Columns | Gets the collection of columns that belong to this table.
Constraints | Gets the collection of constraints maintained by this table.
DataSet | Gets the DataSet that this table belongs to.
DefaultView | Gets a customized view of the table which may include a filtered view, or a cursor position.
DisplayExpression | Gets or sets the expression that will return a value used to represent this row in UI.
ExtendedProperties | Gets the collection of customized user information.
HasErrors | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs.
Locale | Gets or sets the locale information used to compare strings within the table.
MinimumCapacity | Gets or sets the initial starting size for this table.
Namespace | Gets or sets the namespace for the DataTable.
ParentRelations | Gets the collection of parent relations for this DataTable.
PrimaryKey | Gets or sets an array of columns that function as primary keys for the data table.
Rows | Gets the collection of rows that belong to this table.
Site (inherited from Component) | Gets or sets the site of the Component.
TableName | Gets or sets the name of the table.

Methods

AcceptChanges | Commits all the changes made to this table since the last time AcceptChanges was called.
Clear | Clears the table of any data. All rows in all tables are removed. An exception is thrown if the table has any enforced child relations that would cause child rows to be stranded.
Compute | Computes the given expression on the current rows that pass the filter criteria.
CreateColumnArray | Overloaded. Creates the collection of DataColumn objects for the table.
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetErrors | Returns an array of DataRow objects that contain errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
NewRow | Creates a new DataRow with the same schema as the table.
RejectChanges | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges was called.
Reset | Resets the table back to its original state.
ResetCaseSensitive | Resets the CaseSensitive property to its default state.
ResetColumns | [To be supplied.]
ResetConstraints | [To be supplied.]
ResetLocale | Resets the Locale property to its default state.
ResetNamespace | Resets the Namespace property to its default state.
ResetPrimaryKey | Resets the PrimaryKey property to its default state.
Select | Overloaded. Returns an array of DataRow objects.
ShouldPersistCaseSensitive | Indicates whether the CaseSensitive property should be persisted.
ShouldPersistColumns | [To be supplied.]
ShouldPersistConstraints | [To be supplied.]
ShouldPersistLocale | Indicates whether the Locale property should be persisted.
ShouldPersistNamespace | Indicates whether the Namespace property should be persisted.
ShouldPersistPrimaryKey | Indicates whether the PrimaryKey property should be persisted.
ToString | Returns the TableName and DisplayExpression, if there is one as a concatenated string.

Events

ColumnChanging | Occurs when a value has been submitted for this column.
PropertyChanged | This event occurs when any property on the control has been changed for any reason.
RowChanged | Occurs after a row in the table has been successfully edited.
RowChanging | Occurs when the DataRow is changing.
RowDeleted | Occurs after a row in the table has been deleted.
RowDeleting | Occurs before a row in the table is about to be deleted.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
FindRow | Overloaded. Finds and returns a specific DataRow.
FindRows | Overloaded. Finds and returns an array of DataRow objects.
HasSchemaChanged | Gets a value indicating whether the column count has changed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnColumnChanging | Raises the ColumnChanging event.
OnPropertyChanged | Raises the OnPropertyChanged event.
OnRemoveColumn | Notifies the DataTable that a DataColumn is being removed.
OnRowChanged | Raises the RowChanged event.
OnRowChanging | Raises the RowChanging event.
OnRowDeleted | Raises the OnRowDeleted event.
OnRowDeleting | Raises the OnRowDeleting event.

Event Hookup:

Methods

AddOnColumnChanging | Adds an event handler for the ColumnChanging event.
AddOnPropertyChanged | Adds an event handler for the OnPropertyChanged event.
AddOnRowChanged | Adds an event handler for the RowChanged event.
AddOnRowChanging | Adds an event handler for the RowChanging event.
AddOnRowDeleted | Adds an event handler for the OnRowDeleted event.
AddOnRowDeleting | Adds an event handler for the OnRowDeleting event.
RemoveOnColumnChanging | Removes the event handler that has been associated with the OnColumnChanging event.
RemoveOnPropertyChanged | Removes an event handler that has been associated with the OnPropertyChanged event.
RemoveOnRowChanged | Removes an event handler for the row changed event. Occurs after a row in the table has been successfully edited.
RemoveOnRowChanging | Removes an event handler for the row changing event. Occurs when a row in the table has proposed edits. The user can modify values in the row and should throw an exception to cancel the edit.
RemoveOnRowDeleted | Removes an event handler for the row deleting event. Occurs after a row in the table was deleted.
RemoveOnRowDeleting | Removes an event handler for the row deleting event. Occurs after a row in the table is about to be deleted.

See Also

DataTable Class | System.Data Namespace


DataTable Constructor

Initializes a new instance of the DataTable class.

Overload List

Initializes a new instance of the DataTable class with no arguments.

[Visual Basic] Overloads Public Sub New()
[C#] public DataTable();
[C++] public: DataTable();
[JScript] public function DataTable();

Intitalizes a new instance of the DataTable class with the specified table name.

[Visual Basic] Overloads Public Sub New(String)
[C#] public DataTable(String);
[C++] public: DataTable(String*);
[JScript] public function DataTable(String);

Example [Visual Basic]

The following example creates a System.WinForms.DataGridTable and displays it in a System.WinForms.DataGrid control.

Note This example shows how to use one of the overloaded version of the DataTable constructor. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub MakeDataTableAndDisplay()
   ' Create new DataTable and DataSource objects.
   Dim myDataTable As DataTable
   myDataTable = New DataTable("SampleDataTable")
   Dim myDataSource As New DataSource

   ' Declare DataColumn and DataRow variables.
   Dim myDataColumn As DataColumn
   Dim myDataRow As DataRow

   ' Create new DataColumn, set DataType, ColumnName and add to DataTable.
   myDataColumn = New DataColumn
   myDataColumn.DataType = System.Type.GetType("System.Int32")
   myDataColumn.ColumnName = "id"
   myDataTable.Columns.Add myDataColumn

   ' Create second column.
   myDataColumn = New DataColumn
   myDataColumn.DataType = Type.GetType("System.String")
   myDataColumn.ColumnName = "thing"
   myDataTable.Columns.Add myDataColumn

   ' Create new DataRow objects and add to DataTable.
   Dim i As Integer
   For i = 0 To 10
      myDataRow = myDataTable.NewRow
      myDataRow(0) = i
      myDataRow(1) = "thing " & i
      myDataTable.Rows.Add myDataRow
   Next i

   ' Configure DataSource and set to DataGrid.DataSource property.
   myDataSource.Table = myDataTable
   myDataSource.Begin
   dataGrid1.DataSource = myDataSource
   DataGrid1.PopulateColumns
End Sub

See Also

DataTable Class | DataTable Members | System.Data Namespace


DataTable Constructor ()

Initializes a new instance of the DataTable class with no arguments.

[Visual Basic]
Overloads Public Sub New()
[C#]
public DataTable();
[C++]
public: DataTable();
[JScript]
public function DataTable();

Remarks

The constructor sets initial values for all properties of the DataTable object. The following table shows the properties and their default values. When an instance DataTable is created, the following read/write properties are set to initial values.

Property | Default Value
CaseSensitive | Same as the parent DataSet, if it belongs to one. Otherwise, false.
DisplayExpression | Empty String ("")
Locale | Same as the parent DataSet object's CultureInfo (returned by the Locale property); if no parent exists, the default is the current system CultureInfo.
MinimumCapacity | 25 rows.

You can change the value for any of these properties through a separate call to the property.

Example [Visual Basic]

The following example creates a new DataTable with DataColumn and DataRow, and displays it in a System.WinForms.DataGrid control.

[Visual Basic]

Private Sub MakeDataTableAndDisplay()
   ' Create new DataTable and DataSource objects.
   Dim myDataTable As New DataTable
   Dim myDataSource As New DataSource

   ' Declare DataColumn and DataRow variables.
   Dim myDataColumn As DataColumn
   Dim myDataRow As DataRow

   ' Create new DataColumn, set DataType, ColumnName and add to DataTable.
   myDataColumn = New DataColumn
   myDataColumn.DataType = System.Type.GetType("System.Int32")
   myDataColumn.ColumnName = "id"
   myDataTable.Columns.Add(myDataColumn)

   ' Create second column.
   myDataColumn = New DataColumn
   myDataColumn.DataType = Type.GetType("System.String")
   myDataColumn.ColumnName = "thing"
   myDataTable.Columns.Add myDataColumn

   ' Create new DataRow objects and add to DataTable.
   Dim i As Integer
   For i = 0 To 10
      myDataRow = myDataTable.NewRow
      myDataRow(0) = i
      myDataRow(1) = "thing " & i
      myDataTable.Rows.Add myDataRow
   Next i

   ' Configure DataSource and set to DataGrid.DataSource property.
   myDataSource.Table = myDataTable
   myDataSource.Begin
   DataGrid1.DataSource = myDataSource
   DataGrid1.PopulateColumns
End Sub

See Also

DataTable Class | DataTable Members | System.Data Namespace | DataTable Constructor Overload List | DataColumn | DataRow | DataView


DataTable Constructor (String)

Intitalizes a new instance of the DataTable class with the specified table name.

[Visual Basic]
Overloads Public Sub New( _
   ByVal tableName As String _
)
[C#]
public DataTable(
   string tableName
);
[C++]
public: DataTable(
   String* tableName
);
[JScript]
public function DataTable(
   tableName : String
);

Parameters

tableName
The name to give the table. If a null reference (in Visual Basic Nothing) or an empty string, a default name will be given when added to the TablesCollection.

Example [Visual Basic]

The following example creates a System.WinForms.DataGridTable and displays it in a System.WinForms.DataGrid control.

[Visual Basic]

Private Sub MakeDataTableAndDisplay()
   ' Create new DataTable and DataSource objects.
   Dim myDataTable As DataTable
   myDataTable = New DataTable("SampleDataTable")
   Dim myDataSource As New DataSource

   ' Declare DataColumn and DataRow variables.
   Dim myDataColumn As DataColumn
   Dim myDataRow As DataRow

   ' Create new DataColumn, set DataType, ColumnName and add to DataTable.
   myDataColumn = New DataColumn
   myDataColumn.DataType = System.Type.GetType("System.Int32")
   myDataColumn.ColumnName = "id"
   myDataTable.Columns.Add myDataColumn

   ' Create second column.
   myDataColumn = New DataColumn
   myDataColumn.DataType = Type.GetType("System.String")
   myDataColumn.ColumnName = "thing"
   myDataTable.Columns.Add myDataColumn

   ' Create new DataRow objects and add to DataTable.
   Dim i As Integer
   For i = 0 To 10
      myDataRow = myDataTable.NewRow
      myDataRow(0) = i
      myDataRow(1) = "thing " & i
      myDataTable.Rows.Add myDataRow
   Next i

   ' Configure DataSource and set to DataGrid.DataSource property.
   myDataSource.Table = myDataTable
   myDataSource.Begin
   dataGrid1.DataSource = myDataSource
   DataGrid1.PopulateColumns
End Sub

See Also

DataTable Class | DataTable Members | System.Data Namespace | DataTable Constructor Overload List | DataColumn | DataRow | DataView


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataTable Properties

The properties of the DataTable class are listed below. For a complete list of DataTable class members, see the DataTable Members topic.

Public:

CaseSensitive | Indicates whether string comparisons within the table are case-sensitive.
ChildRelations | Gets the collection of child relations for this DataTable.
Columns | Gets the collection of columns that belong to this table.
Constraints | Gets the collection of constraints maintained by this table.
DataSet | Gets the DataSet that this table belongs to.
DefaultView | Gets a customized view of the table which may include a filtered view, or a cursor position.
DisplayExpression | Gets or sets the expression that will return a value used to represent this row in UI.
ExtendedProperties | Gets the collection of customized user information.
HasErrors | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs.
Locale | Gets or sets the locale information used to compare strings within the table.
MinimumCapacity | Gets or sets the initial starting size for this table.
Namespace | Gets or sets the namespace for the DataTable.
ParentRelations | Gets the collection of parent relations for this DataTable.
PrimaryKey | Gets or sets an array of columns that function as primary keys for the data table.
Rows | Gets the collection of rows that belong to this table.
Site (inherited from Component) | Gets or sets the site of the Component.
TableName | Gets or sets the name of the table.

See Also

DataTable Class | System.Data Namespace


DataTable.CaseSensitive

Indicates whether string comparisons within the table are case-sensitive.

[Visual Basic]
Public Property CaseSensitive As Boolean
[C#]
public bool CaseSensitive {get; set;}
[C++]
public: __property bool get_CaseSensitive();
public: __property void set_CaseSensitive(bool);
[JScript]
public function get CaseSensitive() : Boolean;
public function set CaseSensitive(Boolean);

Property Value

true if the comparison is case-sensitive; otherwise, false. The default is set to the parent DataSet object's CaseSensitive property, or false if the DataTable was created independently of a DataSet.

Remarks

The CaseSensitive property affects string comparisons in sorting, searching, and filtering.

Example [Visual Basic]

The following example calls the Select method twice on a DataTable. The first time, the CaseSensitive property is set to true, the second, to false.

[Visual Basic]

Private Sub ToggleCaseSensitive()

   Dim r As DataRow
   Dim t As DataTable
   Dim foundRows() As DataRow
   t = datagrid1.DataGridTable.DataTable

   t.CaseSensitive = False
   Console.WriteLine("CaseSensitive = False")
   ' Presuming the DataTable has a column named 'id'
   foundRows = t.Select("id = 'abc'")
   Dim i As Integer
   ' Print out DataRow values. Presumes row 0 contains the value we're looking for.
   For i = 0 To UBound(foundRows)
      Console.WriteLine(foundRows(0)(0))
   Next

   Console.WriteLineDebug("CaseSensitive = True")
   t.CaseSensitive = True
   foundRows = t.Select("id = 'abc'")

   For i = 0 To UBound(foundRows)
      Console.WriteLine(foundRows(0)(0))
   Next
End Sub

See Also

DataTable Class | DataTable Members | System.Data Namespace | Select


DataTable.ChildRelations

Gets the collection of child relations for this DataTable.

[Visual Basic]
Public ReadOnly Property ChildRelations As RelationsCollection
[C#]
public RelationsCollection ChildRelations {get;}
[C++]
public: __property RelationsCollection* get_ChildRelations();
[JScript]
public function get ChildRelations() : RelationsCollection;

Property Value

A RelationsCollection that contains the child relations for the table.

Remarks

A DataRelation defines the relationship between two tables. Typically, two tables are linked through a single field that contains the same data. For example, a table which contains address data may have a single field containing codes that represent countries. A second table that contains country data will have a single field that contains the code that identifies the country, and it is this code which is inserted into the corresponding field in the first table. A DataRelation, then, contains at least four pieces of information: (1) the name of the first table, (2) the column name in the first table, (3) the name of the second table, and (4) the column name in the second table.

Example [Visual Basic]

The following example uses the ChildRelations property to return each child DataRelation in a DataTable. Each relation is then used as an argument in the GetChildRows method of the DataRow to return an array of rows. The value of each column in the row is then printed.

[Visual Basic]

Private Sub GetChildRowsFromDataRelation(myTable As DataTable)
   Dim dr As DataRelation
   Dim arrRows() As DataRow
   Dim r As DataRow
   Dim i As Integer
   Dim dc As DataColumn

   For Each dr In myTable.ChildRelations
     For Each r In myTable.Rows
         arrRows = r.GetChildRows(dr)
         ' Print values of rows.
         For i = 0 To UBound(arrRows)
For Each dc in myTable.Columns
   Console.WriteLine(arrRows(i)(dc.ColumnName))
Next dc
         Next i
      Next r
   Next dr
End Sub

See Also

DataTable Class | DataTable Members | System.Data Namespace | ParentRelations | DataRelation | GetParentRows | GetChildRows | CreateChildView


DataTable.Columns

Gets the collection of columns that belong to this table.

[Visual Basic]
Public ReadOnly Property Columns As ColumnsCollection
[C#]
public ColumnsCollection Columns {get;}
[C++]
public: __property ColumnsCollection* get_Columns();
[JScript]
public function get Columns() : ColumnsCollection;

Property Value

A ColumnsCollection which contains the collection of DataColumn objects for the table.

See Also

DataTable Class | DataTable Members | System.Data Namespace


DataTable.Constraints

Gets the collection of constraints maintained by this table.

[Visual Basic]
Public ReadOnly Property Constraints As ConstraintsCollection
[C#]
public ConstraintsCollection Constraints {get;}
[C++]
public: __property ConstraintsCollection* get_Constraints();
[JScript]
public function get Constraints() : ConstraintsCollection;

Property Value

A ConstraintsCollection that contains the collection of Constraint objects for the table.

Remarks

A ForeignKeyConstraint restricts the action performed when a value in a column (or columns) is either deleted or updated. Such a constraint is intended to be used with primary key columns. In a parent/child relationship between two tables, deleting a value from the parent table can affect the child rows in one of the following ways.

  • The child rows can also be deleted (a cascading action).
  • The values in the child column (or columns) can be set to null values.
  • The values in the child column (or columns) can be set to default values.
  • An exception can be thrown.

A UniqueConstraint becomes active when attempting to set a value in a primary key to a non-unique value.

Example [Visual Basic]

The following example adds a ForeignKeyConstraint to the collection of constraints.

[Visual Basic]

' The next line goes into the Declarations section of the module:
' SuppliersProducts is a class derived from DataSet.
Private myDataSet As SuppliersProducts

Private Sub CreateConstraint()
   Dim myFKC As ForeignKeyConstraint
   myFKC = New ForeignKeyConstraint _
      (myDataSet.Tables("Suppliers"), _
      myDataSet.Tables("Suppliers").Columns("CompanyID"), _
      myDataSet.Tables("Products"), _
      myDataSet.Tables("Products").Columns("CompanyID"))
   ' Set null values when a value is deleted.
   myFKC.DeleteRule = Rule.SetNull
   myFKC.UpdateRule = Rule.Cascade
   myFKC.AcceptRejectRule = AcceptRejectRule.Cascade

   myDataSet.Tables("Suppliers").Constraints.Add myFKC
   myDataSet.EnforceConstraints = True

End Sub

See Also

DataTable Class | DataTable Members | System.Data Namespace | AcceptRejectRule | ForeignKeyConstraint | UniqueConstraint | Rule


DataTable.DataSet

Gets the DataSet that this table belongs to.

[Visual Basic]
Public ReadOnly Property DataSet As DataSet
[C#]
public DataSet DataSet {get;}
[C++]
public: __property DataSet* get_DataSet();
[JScript]
public function get DataSet() : DataSet;

Property Value

The DataSet that this table belongs to.

Example [Visual Basic]

The following example returns the parent DataSet of a given table through the DataSet property.

[Visual Basic]

Private Sub GetDataSetFromTables()
   Dim t As DataTable
   ' Get the DataTabe of a DataGrid
   t = DataGrid1.DataSource
   ' Get the DataSet
   Dim dset As DataSet
   dset = t.DataSet
End Sub

See Also

DataTable Class | DataTable Members | System.Data Namespace | DataSet


DataTable.DefaultView

Gets a customized view of the table which may include a filtered view, or a cursor position.

[Visual Basic]
Public ReadOnly Property DefaultView As DataView
[C#]
public DataView DefaultView {get;}
[C++]
public: __property DataView* get_DefaultView();
[JScript]
public function get DefaultView() : DataView;

Property Value

The DataView associated with the DataTable.

Remarks

Use the DataView to sort, filter, and search a DataTable. The DataView can also be used to navigate from one DataTable to another through the relations between the tables.

See Also

DataTable Class | DataTable Members | System.Data Namespace


DataTable.DisplayExpression

Gets or sets the expression that will return a value used to represent this row in UI.

[Visual Basic]
Public Property DisplayExpression As String
[C#]
public string DisplayExpression {get; set;}
[C++]
public: __property String* get_DisplayExpression();
public: __property void set_DisplayExpression(String*);
[JScript]
public function get DisplayExpression() : String;
public function set DisplayExpression(String);

Property Value

An expression string.

Remarks

The DisplayExpression can be used to create dynamic text from the current data contents. For example,

See Also

DataTable Class | DataTable Members | System.Data Namespace


DataTable.ExtendedProperties

Gets the collection of customized user information.

[Visual Basic]
Public ReadOnly Property ExtendedProperties As PropertiesCollection
[C#]
public PropertiesCollection ExtendedProperties {get;}
[C++]
public: __property PropertiesCollection* get_ExtendedProperties();
[JScript]
public function get ExtendedProperties() : PropertiesCollection;

Property Value

A PropertiesCollection that contains custom user information.

See Also

DataTable Class | DataTable Members | System.Data Namespace


DataTable.HasErrors

Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs.

[Visual Basic]
Public ReadOnly Property HasErrors As Boolean
[C#]
public bool HasErrors {get;}
[C++]
public: __property bool get_HasErrors();
[JScript]
public function get HasErrors() : Boolean;

Property Value

true if errors exist, otherwise, false.

See Also

DataTable Class | DataTable Members | System.Data Namespace | GetErrors


DataTable.Locale

Gets or sets the locale information used to compare strings within the table.

[Visual Basic]
Public Property Locale As CultureInfo
[C#]
public CultureInfo Locale {get; set;}
[C++]
public: __property CultureInfo* get_Locale();
public: __property void set_Locale(CultureInfo*);
[JScript]
public function get Locale() : CultureInfo;
public function set Locale(CultureInfo);

Property Value

A CultureInfo that contains data about the user's machine locale. The default is the DataSet object's CultureInfo (returned by the Locale property) to which the DataTable belongs; if the table doesn't belong to a DataSet, the default is the current system CultureInfo.

Remarks

A CultureInfo represents the software preferences of a particular culture or community.When used for string comparisons, the CultureInfo affects sorting, comparisons, and filterings.

See Also

DataTable Class | DataTable Members | System.Data Namespace


DataTable.MinimumCapacity

Gets or sets the initial starting size for this table.

[Visual Basic]
Public Property MinimumCapacity As Integer
[C#]
public int MinimumCapacity {get; set;}
[C++]
public: __property int get_MinimumCapacity();
public: __property void set_MinimumCapacity(int);
[JScript]
public function get MinimumCapacity() : int;
public function set MinimumCapacity(int);

Property Value

The initial starting size in rows of this table. The default is 25.

Remarks

The MinimumCapacity allows the system to create an appropriate set of resources before fetching data. In a situation when performance is critical, setting this property can optimize performance.

Example

The following example sets the MinimumCapacity of a DataTable.

See Also

DataTable Class | DataTable Members | System.Data Namespace


DataTable.Namespace

Gets or sets the namespace for the DataTable.

[Visual Basic]
Public Property Namespace As String
[C#]
public string Namespace {get; set;}
[C++]
public: __property String* get_Namespace();
public: __property void set_Namespace(String*);
[JScript]
public function get Namespace() : String;
public function set Namespace(String);

Property Value

The namespace of the DataTable.

See Also

DataTable Class | DataTable Members | System.Data Namespace


DataTable.ParentRelations

Gets the collection of parent relations for this DataTable.

[Visual Basic]
Public ReadOnly Property ParentRelations As RelationsCollection
[C#]
public RelationsCollection ParentRelations {get;}
[C++]
public: __property RelationsCollection* get_ParentRelations();
[JScript]
public function get ParentRelations() : RelationsCollection;

Property Value

A RelationsCollection that contains the parent relations for the table.

Example [Visual Basic]

The following example uses the ParentRelations property to return each parent DataRelation in a DataTable. Each relation is then used as an argument in the GetParentRows method of the DataRow to return an array of rows. The value of each column in the row is then printed.

[Visual Basic]

Private Sub GetChildRowsFromDataRelation(myTable As DataTable)
   Dim dr As DataRelation
   Dim arrRows() As DataRow
   Dim r As DataRow
   Dim i As Integer
   Dim dc As DataColumn

   For Each dr In myTable.ParentRelations
     For Each r In myTable.Rows
         arrRows = r.GetParentRows(dr)
         ' Print values of rows.
         For i = 0 To UBound(arrRows)
For Each dc in myTable.Columns
   Console.WriteLine(arrRows(i)(dc))
Next dc
         Next i
      Next r
   Next dr
End Sub

See Also

DataTable Class | DataTable Members | System.Data Namespace | ChildRelations


DataTable.PrimaryKey

Gets or sets an array of columns that function as primary keys for the data table.

[Visual Basic]
Public Property PrimaryKey As DataColumn ()
[C#]
public DataColumn[] PrimaryKey {get; set;}
[C++]
public: __property DataColumn* get_PrimaryKey();
public: __property void set_PrimaryKey(DataColumn*[]);
[JScript]
public function get PrimaryKey() : DataColumn[];
public function set PrimaryKey(DataColumn[]);

Property Value

An array of DataColumn objects.

Exceptions

Exception Type | Condition
DataException | The key is a foreign key.

Remarks

The primary key of a table must be unique to identify the record in the table. It's also possible to have a table with a primary key made up of two or more columns. This occurs when a single column can't contain enough unique values. For example, a two column primary key might consist of a "FirstName" and "LastName" column. Because primary keys can be made up of more than one column, the PrimaryKey property consists of an array of DataColumn objects.

Example [Visual Basic]

The following example first shows how to return the primary key columns for a DataTable displayed in a System.WinForms.DataGrid. The second example demonstrates how to set the primary key columns for a DataTable.

[Visual Basic]

Private Sub GetPrimaryKeys()
   Dim colArr() As DataColumn
   Dim t As DataTable
   Dim i As Integer

   t = DataGrid1.DataGridTable.DataTable
   colArr = t.PrimaryKey
   ' Use the Ubound method to determine the number in the array.
   Console.WriteLine("Column Count", UBound(colArr))
   For i = 0 To UBound(colArr) - 1
      Console.WriteLine(colArr(i).ColumnName, colArr(i).DataType.ToString)
   Next
End Sub

Private Sub SetPrimaryKeys()
   ' Create a new DataTable and set two DataColumn objects as primary keys..
   Dim t As DataTable = New DataTable
   Dim keys(1) As DataColumn
   Dim dc As DataColumn
   ' Create column 1.
   dc = New DataColumn
   dc.DataType = System.Type.GetType("System.String")
   dc.ColumnName= "FirstName"
   ' Add the column to the DataTable.Columns collection.
   t.Columns.Add(dc)
   ' Add the column to the array.
   keys(0) = dc

   ' Create column 2 and add it to the array.
   dc = New DataColumn
   dc.DataType = System.Type.GetType("System.String")
   dc.ColumnName="LastName"
   keys(1) = dc
   t.Columns.Add dc
   ' Set the PrimaryKeys property to the array.
   t.PrimaryKey = keys

End Sub

See Also

DataTable Class | DataTable Members | System.Data Namespace | DataColumn | PrimaryKey | ColumnsCollection


DataTable.Rows

Gets the collection of rows that belong to this table.

[Visual Basic]
Public ReadOnly Property Rows As RowsCollection
[C#]
public RowsCollection Rows {get;}
[C++]
public: __property RowsCollection* get_Rows();
[JScript]
public function get Rows() : RowsCollection;

Property Value

A RowsCollection that contains DataRow objects.

Remarks

To create a new DataRow, you must use the NewRow method to return a new object. Such an object is automatically configured with according to the schema defined for the DataTable through its collection of DataColumn objects. After creating a new row and setting the values for each column in the row, add the row to the RowsCollection using the Add method.

Each DataRow in the collection represents a row of data in the table. To commit a change to the value of a column in the row, you must invoke the AcceptChanges method.

Example [Visual Basic]

The following shows two examples of returning and setting rows. The first example uses the the Rows property and prints the value of each column for every row. The second example uses the DataTable object's NewRow method to create a new DataRow object with the schema of the DataTable. After setting the row values, the row is added to the RowsCollection through the Add method.

[Visual Basic]

Private Sub GetRows(ds As DataSet)
   Dim myRows As RowsCollection
   Dim t As DataTable
   Dim r As DataRow
   Dim c As DataColumn
   ' For each table in the DataSet, print the values of each row.

   For Each t In ds.Tables
      ' For each row, print the values of each column.
      For Each r In t.Rows
         For Each c in t.Columns
Console.WriteLine(r(c))
         Next
       Next
   Next
End Sub

Private Sub AddARow(ds As DataSet)
   Dim t As DataTable
   t = ds.Tables("Suppliers)
   ' Use the NewRow method to create a DataRow with the table's schema.
   Dim newRow As DataRow
   newRow = t.NewRow
   ' Set values in the columns:
   newRow("CompanyID") = "NewCompanyID"
   newRow("CompanyName") = "NewCompanyName"
   ' Add the row to the rows collection.
   t.Rows.Add(newRow)
End Sub

See Also

DataTable Class | DataTable Members | System.Data Namespace | AcceptChanges | DataRow | RowsCollection | NewRow


DataTable.TableName

Gets or sets the name of the table.

[Visual Basic]
Public Property TableName As String
[C#]
public string TableName {get; set;}
[C++]
public: __property String* get_TableName();
public: __property void set_TableName(String*);
[JScript]
public function get TableName() : String;
public function set TableName(String);

Property Value

The name of the table.

Exceptions

Exception Type | Condition
ArgumentException | A a null reference (in Visual Basic Nothing) or empty string ("") is passed in and this table belongs to a collection.
DuplicateNameException | The table belongs to a collection that already has a table with the same name (and the comparison is not case-sensitive).

Remarks

The TableName is used to return this table from the parent DataSet object's TablesCollection (returned by the Tables property).

Example [Visual Basic]

The following example prints the TableName for each table in a collection of DataTable objects.

[Visual Basic]

Private Sub GetTableNames()
   Dim t As DataTable
   Dim cols As TablesCollection
   ' Set cols to a DataSet object's Tables collection.
   cols = myDataSet.Tables
   ' Print each table's TableName.
   For Each t in cols
      Console.WriteLine(t.TableName)
   Next
End Sub

See Also

DataTable Class | DataTable Members | System.Data Namespace | DataSet | Tables


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataTable Methods

The methods of the DataTable class are listed below. For a complete list of DataTable class members, see the DataTable Members topic.

Public:

AcceptChanges | Commits all the changes made to this table since the last time AcceptChanges was called.
Clear | Clears the table of any data. All rows in all tables are removed. An exception is thrown if the table has any enforced child relations that would cause child rows to be stranded.
Compute | Computes the given expression on the current rows that pass the filter criteria.
CreateColumnArray | Overloaded. Creates the collection of DataColumn objects for the table.
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetErrors | Returns an array of DataRow objects that contain errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
NewRow | Creates a new DataRow with the same schema as the table.
RejectChanges | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges was called.
Reset | Resets the table back to its original state.
ResetCaseSensitive | Resets the CaseSensitive property to its default state.
ResetColumns | [To be supplied.]
ResetConstraints | [To be supplied.]
ResetLocale | Resets the Locale property to its default state.
ResetNamespace | Resets the Namespace property to its default state.
ResetPrimaryKey | Resets the PrimaryKey property to its default state.
Select | Overloaded. Returns an array of DataRow objects.
ShouldPersistCaseSensitive | Indicates whether the CaseSensitive property should be persisted.
ShouldPersistColumns | [To be supplied.]
ShouldPersistConstraints | [To be supplied.]
ShouldPersistLocale | Indicates whether the Locale property should be persisted.
ShouldPersistNamespace | Indicates whether the Namespace property should be persisted.
ShouldPersistPrimaryKey | Indicates whether the PrimaryKey property should be persisted.
ToString | Returns the TableName and DisplayExpression, if there is one as a concatenated string.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
FindRow | Overloaded. Finds and returns a specific DataRow.
FindRows | Overloaded. Finds and returns an array of DataRow objects.
HasSchemaChanged | Gets a value indicating whether the column count has changed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnColumnChanging | Raises the ColumnChanging event.
OnPropertyChanged | Raises the OnPropertyChanged event.
OnRemoveColumn | Notifies the DataTable that a DataColumn is being removed.
OnRowChanged | Raises the RowChanged event.
OnRowChanging | Raises the RowChanging event.
OnRowDeleted | Raises the OnRowDeleted event.
OnRowDeleting | Raises the OnRowDeleting event.

Event Hookup:

AddOnColumnChanging | Adds an event handler for the ColumnChanging event.
AddOnPropertyChanged | Adds an event handler for the OnPropertyChanged event.
AddOnRowChanged | Adds an event handler for the RowChanged event.
AddOnRowChanging | Adds an event handler for the RowChanging event.
AddOnRowDeleted | Adds an event handler for the OnRowDeleted event.
AddOnRowDeleting | Adds an event handler for the OnRowDeleting event.
RemoveOnColumnChanging | Removes the event handler that has been associated with the OnColumnChanging event.
RemoveOnPropertyChanged | Removes an event handler that has been associated with the OnPropertyChanged event.
RemoveOnRowChanged | Removes an event handler for the row changed event. Occurs after a row in the table has been successfully edited.
RemoveOnRowChanging | Removes an event handler for the row changing event. Occurs when a row in the table has proposed edits. The user can modify values in the row and should throw an exception to cancel the edit.
RemoveOnRowDeleted | Removes an event handler for the row deleting event. Occurs after a row in the table was deleted.
RemoveOnRowDeleting | Removes an event handler for the row deleting event. Occurs after a row in the table is about to be deleted.

See Also

DataTable Class | System.Data Namespace


DataTable.AcceptChanges

Commits all the changes made to this table since the last time AcceptChanges was called.

[Visual Basic]
Public Sub AcceptChanges()
[C#]
public void AcceptChanges();
[C++]
public: void AcceptChanges();
[JScript]
public function AcceptChanges();

Remarks

When AcceptChanges is called, any DataRow object still in edit-mode successfully ends its edits. The DataRowState also changes: all New and Modified rows become Unchanged; Deleted rows are removed.

CAUTION The AcceptChanges method should never be called on a DataTable until after you attempt to update the DataSet using the TBD method. When you invoke AcceptChanges, all rows marked as New, Modified, or Deleted will then become marked Original. In that case, the DataSet has no way of knowing which rows must be propagated to the database management system.

Example [Visual Basic]

The following example edits the value of one column in the last row of a System.WinForms.DataGrid control. The example uses the BeginEdit, EndEdit, and AcceptChanges methods to programmatically edit the column's value and commit the change to the row, and finally to the table itself.

[Visual Basic]

Private Sub EditAndAccept()
   Dim t As DataTable
   t = DataGrid1.DataSource

   Dim myRow As DataRow
   myRow = t.Rows(t.Rows.Count - 1)

   myrow.BeginEdit
   myrow(1) = "New Text"

   myrow.EndEdit
   myrow.AcceptChanges
   t.AcceptChanges
End Sub

See Also

DataTable Class | DataTable Members | System.Data Namespace | AcceptChanges | BeginEdit | DataRowState | EndEdit | RejectChanges


DataTable.AddOnColumnChanging

Adds an event handler for the ColumnChanging event.

[Visual Basic]
Public Sub AddOnColumnChanging( _
   ByVal handler As DataColumnChangeEventHandler _
)
[C#]
public void AddOnColumnChanging(
   DataColumnChangeEventHandler handler
);
[C++]
public: void AddOnColumnChanging(
   DataColumnChangeEventHandler* handler
);
[JScript]
public function AddOnColumnChanging(
   handler : DataColumnChangeEventHandler
);

Parameters

handler
A DataColumnChangeEventHandler delegate that represents the method that will handle the ColumnChanging event.

Remarks

The user can modify the proposed value and should throw an exception to cancel the edit.

See Also

DataTable Class | DataTable Members | System.Data Namespace | RemoveOnColumnChanging


DataTable.AddOnPropertyChanged

Adds an event handler for the OnPropertyChanged event.

[Visual Basic]
Public Sub AddOnPropertyChanged( _
   ByVal handler As PropertyChangedEventHandler _
)
[C#]
public void AddOnPropertyChanged(
   PropertyChangedEventHandler handler
);
[C++]
public: void AddOnPropertyChanged(
   PropertyChangedEventHandler* handler
);
[JScript]
public function AddOnPropertyChanged(
   handler : PropertyChangedEventHandler
);

Parameters

handler
A PropertyChangedEventHandler delegate that represents the method that will handle the OnPropertyChanged event.

See Also

DataTable Class | DataTable Members | System.Data Namespace | RemoveOnPropertyChanged


DataTable.AddOnRowChanged

Adds an event handler for the RowChanged event.

[Visual Basic]
Public Sub AddOnRowChanged( _
   ByVal handler As DataRowChangeEventHandler _
)
[C#]
public void AddOnRowChanged(
   DataRowChangeEventHandler handler
);
[C++]
public: void AddOnRowChanged(
   DataRowChangeEventHandler* handler
);
[JScript]
public function AddOnRowChanged(
   handler : DataRowChangeEventHandler
);

Parameters

handler
A DataRowChangeEventHandler delegate that represents the method that will handle the RowChanged event.

See Also

DataTable Class | DataTable Members | System.Data Namespace | RemoveOnRowChanged


DataTable.AddOnRowChanging

Adds an event handler for the RowChanging event.

[Visual Basic]
Public Sub AddOnRowChanging( _
   ByVal handler As DataRowChangeEventHandler _
)
[C#]
public void AddOnRowChanging(
   DataRowChangeEventHandler handler
);
[C++]
public: void AddOnRowChanging(
   DataRowChangeEventHandler* handler
);
[JScript]
public function AddOnRowChanging(
   handler : DataRowChangeEventHandler
);

Parameters

handler
A DataRowChangeEventHandler delegate that represents the method that will handle the RowChanging event.

Return Value

The user can modify values in the row and should throw an exception to cancel the edit.

See Also

DataTable Class | DataTable Members | System.Data Namespace | RemoveOnRowChanging


DataTable.AddOnRowDeleted

Adds an event handler for the OnRowDeleted event.

[Visual Basic]
Public Sub AddOnRowDeleted( _
   ByVal handler As DataRowChangeEventHandler _
)
[C#]
public void AddOnRowDeleted(
   DataRowChangeEventHandler handler
);
[C++]
public: void AddOnRowDeleted(
   DataRowChangeEventHandler* handler
);
[JScript]
public function AddOnRowDeleted(
   handler : DataRowChangeEventHandler
);

Parameters

handler
A DataRowChangeEventHandler delegate that represents the method that will handle the OnRowDeleted event.

See Also

DataTable Class | DataTable Members | System.Data Namespace | RemoveOnRowDeleted


DataTable.AddOnRowDeleting

Adds an event handler for the OnRowDeleting event.

[Visual Basic]
Public Sub AddOnRowDeleting( _
   ByVal handler As DataRowChangeEventHandler _
)
[C#]
public void AddOnRowDeleting(
   DataRowChangeEventHandler handler
);
[C++]
public: void AddOnRowDeleting(
   DataRowChangeEventHandler* handler
);
[JScript]
public function AddOnRowDeleting(
   handler : DataRowChangeEventHandler
);

Parameters

handler
A DataRowChangeEventHandler delegate that represents the method that will handle the OnRowDeleting event.

See Also

DataTable Class | DataTable Members | System.Data Namespace | RemoveOnRowDeleting


DataTable.Clear

Clears the table of any data. All rows in all tables are removed. An exception is thrown if the table has any enforced child relations that would cause child rows to be stranded.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[JScript]
public function Clear();

See Also

DataTable Class | DataTable Members | System.Data Namespace


DataTable.Compute

Computes the given expression on the current rows that pass the filter criteria.

[Visual Basic]
Public Function Compute( _
   ByVal expression As String, _
   ByVal filter As String _
) As Object
[C#]
public object Compute(
   string expression,
   string filter
);
[C++]
public: Object* Compute(
   String* expression,
   String* filter
);
[JScript]
public function Compute(
   expression : String,
   filter : String
) : Object;

Parameters

expression
The expression to compute.
filter
The filter to limit the rows that evaluate in the expression.

Return Value

An Object, set to the result of the computation.

Remarks

The expression parameter requires an aggregate function. For example, the following is a legal expression:

Count(Quantity)

But this expression is not:

Sum (Quantity * UnitPrice)

If you must perform an operation on two or more columns, you should create a DataColumn, set its Expression property to an appropriate expression, and use an aggregate expression on the resulting column. In that case, given a DataColumn with the name "total," and the Expression property set to:

"Quantity * UnitPrice"

The expression argument for the Compute method would then be:

Sum(total)

The second parameter filter determines which rows are used in the expression. For example, if the table contains a date column named "colDate", you could limit the rows with the following expression:

colDate > 1/1/99 AND colDate < 17/1/99

For rules on creating expressions for both parameters, see the Expression property of the DataColumn class.

Example [Visual Basic]

The following example sums the values of a column named "Total," for the saleperson whose identification number is 5.

[Visual Basic]

Private Sub ComputeBySalesSalesID()
   ' Presumes a DataTable named "Orders" that has a column named "Total"
   Dim t As DataTable
   t = DataSet1.Tables("Orders")
   ' Declare an object variable.
   Dim objSum As Object
   objSum = t.Compute("Sum(Total)", "EmpID = 5")
End Sub

See Also

DataTable Class | DataTable Members | System.Data Namespace


DataTable.CreateColumnArray

Creates the collection of DataColumn objects for the table.

Overload List

Helper that creates a column array based on the column arguments.

[Visual Basic] Overloads Public Shared Function CreateColumnArray(DataColumn, DataColumn, DataColumn) As DataColumn ()
[C#] public static DataColumn[] CreateColumnArray(DataColumn, DataColumn, DataColumn);
[C++] public: static DataColumn* CreateColumnArray(DataColumn*, DataColumn*, DataColumn*) [];
[JScript] public static function CreateColumnArray(DataColumn, DataColumn, DataColumn) : DataColumn[];

Helper that creates a column array based on the column arguments.

[Visual Basic] Overloads Public Shared Function CreateColumnArray(DataColumn, DataColumn, DataColumn, DataColumn, DataColumn) As DataColumn ()
[C#] public static DataColumn[] CreateColumnArray(DataColumn, DataColumn, DataColumn, DataColumn, DataColumn);
[C++] public: static DataColumn* CreateColumnArray(DataColumn*, DataColumn*, DataColumn*, DataColumn*, DataColumn*) [];
[JScript] public static function CreateColumnArray(DataColumn, DataColumn, DataColumn, DataColumn, DataColumn) : DataColumn[];

Helper that creates a column array based on the column arguments.

[Visual Basic] Overloads Public Shared Function CreateColumnArray(DataColumn, DataColumn, DataColumn, DataColumn, DataColumn, DataColumn) As DataColumn ()
[C#] public static DataColumn[] CreateColumnArray(DataColumn, DataColumn, DataColumn, DataColumn, DataColumn, DataColumn);
[C++] public: static DataColumn* CreateColumnArray(DataColumn*, DataColumn*, DataColumn*, DataColumn*, DataColumn*, DataColumn*) [];
[JScript] public static function CreateColumnArray(DataColumn, DataColumn, DataColumn, DataColumn, DataColumn, DataColumn) : DataColumn[];

Helper that creates a column array based on the column arguments.

[Visual Basic] Overloads Public Shared Function CreateColumnArray(DataColumn, DataColumn, DataColumn, DataColumn) As DataColumn ()
[C#] public static DataColumn[] CreateColumnArray(DataColumn, DataColumn, DataColumn, DataColumn);
[C++] public: static DataColumn* CreateColumnArray(DataColumn*, DataColumn*, DataColumn*, DataColumn*) [];
[JScript] public static function CreateColumnArray(DataColumn, DataColumn, DataColumn, DataColumn) : DataColumn[];

Helper that creates a column array based on the column arguments.

[Visual Basic] Overloads Public Shared Function CreateColumnArray(DataColumn, DataColumn) As DataColumn ()
[C#] public static DataColumn[] CreateColumnArray(DataColumn, DataColumn);
[C++] public: static DataColumn* CreateColumnArray(DataColumn*, DataColumn*) [];
[JScript] public static function CreateColumnArray(DataColumn, DataColumn) : DataColumn[];

Helper that creates a column array based on the column arguments.

[Visual Basic] Overloads Public Shared Function CreateColumnArray(DataColumn) As DataColumn ()
[C#] public static DataColumn[] CreateColumnArray(DataColumn);
[C++] public: static DataColumn* CreateColumnArray(DataColumn*) [];
[JScript] public static function CreateColumnArray(DataColumn) : DataColumn[];

See Also

DataTable Class | DataTable Members | System.Data Namespace


DataTable.CreateColumnArray (DataColumn, DataColumn, DataColumn)

Helper that creates a column array based on the column arguments.

[Visual Basic]
Overloads Public Shared Function CreateColumnArray( _
   ByVal column1 As DataColumn, _
   ByVal column2 As DataColumn, _
   ByVal column3 As DataColumn _
) As DataColumn ()
[C#]
public static DataColumn[] CreateColumnArray(
   DataColumn column1,
   DataColumn column2,
   DataColumn column3
);
[C++]
public: static DataColumn* CreateColumnArray(
   DataColumn* column1,
   DataColumn* column2,
   DataColumn* column3
) [];
[JScript]
public static function CreateColumnArray(
   column1 : DataColumn,
   column2 : DataColumn,
   column3 : DataColumn
) : DataColumn[];

Parameters

column1
[To be supplied.]
column2
[To be supplied.]
column3
[To be supplied.]

Return Value

The array.

See Also

DataTable Class | DataTable Members | System.Data Namespace | DataTable.CreateColumnArray Overload List


DataTable.CreateColumnArray (DataColumn, DataColumn, DataColumn, DataColumn, DataColumn)

Helper that creates a column array based on the column arguments.

[Visual Basic]
Overloads Public Shared Function CreateColumnArray( _
   ByVal column1 As DataColumn, _
   ByVal column2 As DataColumn, _
   ByVal column3 As DataColumn, _
   ByVal column4 As DataColumn, _
   ByVal column5 As DataColumn _
) As DataColumn ()
[C#]
public static DataColumn[] CreateColumnArray(
   DataColumn column1,
   DataColumn column2,
   DataColumn column3,
   DataColumn column4,
   DataColumn column5
);
[C++]
public: static DataColumn* CreateColumnArray(
   DataColumn* column1,
   DataColumn* column2,
   DataColumn* column3,
   DataColumn* column4,
   DataColumn* column5
) [];
[JScript]
public static function CreateColumnArray(
   column1 : DataColumn,
   column2 : DataColumn,
   column3 : DataColumn,
   column4 : DataColumn,
   column5 : DataColumn
) : DataColumn[];

Parameters

column1
[To be supplied.]
column2
[To be supplied.]
column3
[To be supplied.]
column4
[To be supplied.]
column5
[To be supplied.]

Return Value

The array.

See Also

DataTable Class | DataTable Members | System.Data Namespace | DataTable.CreateColumnArray Overload List


DataTable.CreateColumnArray (DataColumn, DataColumn, DataColumn, DataColumn, DataColumn, DataColumn)

Helper that creates a column array based on the column arguments.

[Visual Basic]
Overloads Public Shared Function CreateColumnArray( _
   ByVal column1 As DataColumn, _
   ByVal column2 As DataColumn, _
   ByVal column3 As DataColumn, _
   ByVal column4 As DataColumn, _
   ByVal column5 As DataColumn, _
   ByVal column6 As DataColumn _
) As DataColumn ()
[C#]
public static DataColumn[] CreateColumnArray(
   DataColumn column1,
   DataColumn column2,
   DataColumn column3,
   DataColumn column4,
   DataColumn column5,
   DataColumn column6
);
[C++]
public: static DataColumn* CreateColumnArray(
   DataColumn* column1,
   DataColumn* column2,
   DataColumn* column3,
   DataColumn* column4,
   DataColumn* column5,
   DataColumn* column6
) [];
[JScript]
public static function CreateColumnArray(
   column1 : DataColumn,
   column2 : DataColumn,
   column3 : DataColumn,
   column4 : DataColumn,
   column5 : DataColumn,
   column6 : DataColumn
) : DataColumn[];

Parameters

column1
[To be supplied.]
column2
[To be supplied.]
column3
[To be supplied.]
column4
[To be supplied.]
column5
[To be supplied.]
column6
[To be supplied.]

Return Value

The array.

See Also

DataTable Class | DataTable Members | System.Data Namespace | DataTable.CreateColumnArray Overload List


DataTable.CreateColumnArray (DataColumn, DataColumn, DataColumn, DataColumn)

Helper that creates a column array based on the column arguments.

[Visual Basic]
Overloads Public Shared Function CreateColumnArray( _
   ByVal column1 As DataColumn, _
   ByVal column2 As DataColumn, _
   ByVal column3 As DataColumn, _
   ByVal column4 As DataColumn _
) As DataColumn ()
[C#]
public static DataColumn[] CreateColumnArray(
   DataColumn column1,
   DataColumn column2,
   DataColumn column3,
   DataColumn column4
);
[C++]
public: static DataColumn* CreateColumnArray(
   DataColumn* column1,
   DataColumn* column2,
   DataColumn* column3,
   DataColumn* column4
) [];
[JScript]
public static function CreateColumnArray(
   column1 : DataColumn,
   column2 : DataColumn,
   column3 : DataColumn,
   column4 : DataColumn
) : DataColumn[];

Parameters

column1
[To be supplied.]
column2
[To be supplied.]
column3
[To be supplied.]
column4
[To be supplied.]

Return Value

The array.

See Also

DataTable Class | DataTable Members | System.Data Namespace | DataTable.CreateColumnArray Overload List


DataTable.CreateColumnArray (DataColumn, DataColumn)

Helper that creates a column array based on the column arguments.

[Visual Basic]
Overloads Public Shared Function CreateColumnArray( _
   ByVal column1 As DataColumn, _
   ByVal column2 As DataColumn _
) As DataColumn ()
[C#]
public static DataColumn[] CreateColumnArray(
   DataColumn column1,
   DataColumn column2
);
[C++]
public: static DataColumn* CreateColumnArray(
   DataColumn* column1,
   DataColumn* column2
) [];
[JScript]
public static function CreateColumnArray(
   column1 : DataColumn,
   column2 : DataColumn
) : DataColumn[];

Parameters

column1
[To be supplied.]
column2
[To be supplied.]

Return Value

The array.

See Also

DataTable Class | DataTable Members | System.Data Namespace | DataTable.CreateColumnArray Overload List


DataTable.CreateColumnArray (DataColumn)

Helper that creates a column array based on the column arguments.

[Visual Basic]
Overloads Public Shared Function CreateColumnArray( _
   ByVal column1 As DataColumn _
) As DataColumn ()
[C#]
public static DataColumn[] CreateColumnArray(
   DataColumn column1
);
[C++]
public: static DataColumn* CreateColumnArray(
   DataColumn* column1
) [];
[JScript]
public static function CreateColumnArray(
   column1 : DataColumn
) : DataColumn[];

Parameters

column1
[To be supplied.]

See Also

DataTable Class | DataTable Members | System.Data Namespace | DataTable.CreateColumnArray Overload List


DataTable.FindRow

Finds and returns a specific DataRow.

Overload List

Finds and returns a DataRow with the specified value in the specified column.

[Visual Basic] Overloads Protected Function FindRow(DataColumn, Object) As DataRow
[C#] protected DataRow FindRow(DataColumn, Object);
[C++] protected: DataRow* FindRow(DataColumn*, Object);
[JScript] protected function FindRow(DataColumn, Object) : DataRow;

Finds and returns a DataRow with the specified values in the specified columns.

[Visual Basic] Overloads Protected Function FindRow(DataColumn(), Object()) As DataRow
[C#] protected DataRow FindRow(DataColumn[], Object[]);
[C++] protected: DataRow* FindRow(DataColumn*[], Object[]);
[JScript] protected function FindRow(DataColumn[], Object[]) : DataRow;

Example [Visual Basic]

The following example finds a single DataRow through the FindRow method.

Note This example shows how to use one of the overloaded versions of FindRow. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub FindThisRow()
   Dim arrCols(1) As DataColumn
   Dim arrVals(1) As Object
   Dim foundRow As DataRow
   Dim t As DataTable
   ' Use the DataTable of a DataGrid control.
   t = DataGrid1.DataGridTable.DataTable
   ' Get two columns from the table.
   arrCols(0) = t.Columns("SupplierID")
   arrCols(1) = t.Columns("CompanyName")
   ' Set the values to find, one for each column.
   arrVals(0) = 25
   arrVals(1) = "Ma Maison"

   foundRow = t.FindRows(arrCols, arrVals)
   Console.WriteLine(foundRow(1))
End Sub

See Also

DataTable Class | DataTable Members | System.Data Namespace


DataTable.FindRow (DataColumn, Object)

Finds and returns a DataRow with the specified value in the specified column.

[Visual Basic]
Overloads Protected Function FindRow( _
   ByVal column As DataColumn, _
   ByVal value As Object _
) As DataRow
[C#]
protected DataRow FindRow(
   DataColumn column,
   object value
);
[C++]
protected: DataRow* FindRow(
   DataColumn* column,
   Object* value
);
[JScript]
protected function FindRow(
   column : DataColumn,
   value : Object
) : DataRow;

Parameters

column
A DataColumn that specifies the column to search in.
value
An value that is to be found in the named column.

Return Value

A DataRow whose column values match those specified in the method.

Remarks

You can also use Select method to find a specific row in the DataTable. Furthermore, the Find and Contains methods of the RowsCollection also return specific rows or values in rows.

Example [Visual Basic]

The following example uses the FindRows method to return a DataRow containing the specified value.

[Visual Basic]

Private Sub FindThisRow()
   Dim findInThisCol As DataColumn
   Dim findThisVal As Object
   Dim foundRow As DataRow
   Dim t As DataTable
   ' Use the DataTable of a DataGrid control.
   t = DataGrid1.DataGridTable.DataTable
   ' Get two columns from the table.
   findInThisCol = t.Columns("SupplierID")
   ' Set the value to find.
   findThisVal = 25

   foundRow = t.FindRows(findInThisCol, findThisVal)
   Console.WriteLine(foundRow(1))
End Sub

See Also

DataTable Class | DataTable Members | System.Data Namespace | DataTable.FindRow Overload List | DataRow | Contains | Find


DataTable.FindRow (DataColumn[], Object[])

Finds and returns a DataRow with the specified values in the specified columns.

[Visual Basic]
Overloads Protected Function FindRow( _
   ByVal columns() As DataColumn, _
   ByVal values() As Object _
) As DataRow
[C#]
protected DataRow FindRow(
   DataColumn[] columns,
   object[] values
);
[C++]
protected: DataRow* FindRow(
   DataColumn* columns[],
   Object* values[]
);
[JScript]
protected function FindRow(
   columns : DataColumn[],
   values : Object[]
) : DataRow;

Parameters

columns
An array of DataColumn objects that specify the columns to search in.
values
[To be supplied.]

Return Value

A DataRow whose column values match those specified in the method.

Remarks

You can also use the Find and Contains methods of the RowsCollection to find specific rows or values in rows.

Example [Visual Basic]

The following example finds a single DataRow through the FindRow method.

[Visual Basic]

Private Sub FindThisRow()
   Dim arrCols(1) As DataColumn
   Dim arrVals(1) As Object
   Dim foundRow As DataRow
   Dim t As DataTable
   ' Use the DataTable of a DataGrid control.
   t = DataGrid1.DataGridTable.DataTable
   ' Get two columns from the table.
   arrCols(0) = t.Columns("SupplierID")
   arrCols(1) = t.Columns("CompanyName")
   ' Set the values to find, one for each column.
   arrVals(0) = 25
   arrVals(1) = "Ma Maison"

   foundRow = t.FindRows(arrCols, arrVals)
   Console.WriteLine(foundRow(1))
End Sub

See Also

DataTable Class | DataTable Members | System.Data Namespace | DataTable.FindRow Overload List | DataRow | Contains | Find


DataTable.FindRows

Finds and returns an array of DataRow objects.

Overload List

Finds and returns an array of DataRow objects using the specified columns and values.

[Visual Basic] Overloads Protected Function FindRows(DataColumn(), Object()) As DataRow ()
[C#] protected DataRow[] FindRows(DataColumn[], Object[]);
[C++] protected: DataRow* FindRows(DataColumn*[], Object[]) [];
[JScript] protected function FindRows(DataColumn[], Object[]) : DataRow[];

Finds and returns an array of DataRow objects with the specified value in the specified column.

[Visual Basic] Overloads Protected Function FindRows(DataColumn, Object) As DataRow ()
[C#] protected DataRow[] FindRows(DataColumn, Object);
[C++] protected: DataRow* FindRows(DataColumn*, Object) [];
[JScript] protected function FindRows(DataColumn, Object) : DataRow[];

Finds and returns an array of DataRow objects using the specified DataKey and values.

[Visual Basic] Overloads Protected Function FindRows(DataKey, Object()) As DataRow ()
[C#] protected DataRow[] FindRows(DataKey, Object[]);
[C++] protected: DataRow* FindRows(DataKey*, Object[]) [];
[JScript] protected function FindRows(DataKey, Object[]) : DataRow[];

Example [Visual Basic]

The following example sets the DataKey to the columns of a DataTable, and returns an array of DataRow objects that contain the specified values.

Note This example shows how to use one of the overloaded versions of FindRows. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub FindInDataKey()
   Dim keyCols() As DataColumn
   Dim t As DataTable
   t = DataGrid1.DataSource
   keyCols = t.PrimaryKey
   Dim arrVals(1) As Object
   ' Search for two values, the first is an index, the second a date.
   arrVals(0) = 1
   arrVals(1) = "12/2/99"
   Dim foundCols() As DataColumn
   foundCols = t.FindRows(keyCols, arrVals)
End Sub

See Also

DataTable Class | DataTable Members | System.Data Namespace


DataTable.FindRows (DataColumn[], Object[])

Finds and returns an array of DataRow objects using the specified columns and values.

[Visual Basic]
Overloads Protected Function FindRows( _
   ByVal columns() As DataColumn, _
   ByVal values() As Object _
) As DataRow ()
[C#]
protected DataRow[] FindRows(
   DataColumn[] columns,
   object[] values
);
[C++]
protected: DataRow* FindRows(
   DataColumn* columns[],
   Object* values[]
) [];
[JScript]
protected function FindRows(
   columns : DataColumn[],
   values : Object[]
) : DataRow[];

Parameters

columns
An array of DataColumn objects.
values
[To be supplied.]

Return Value

An array of DataColumn objects.

Example

The following example uses the FindRows method to return an array of DataRow objects that contain the specified values.

See Also

DataTable Class | DataTable Members | System.Data Namespace | DataTable.FindRows Overload List | DataRow | Contains | Find


DataTable.FindRows (DataColumn, Object)

Finds and returns an array of DataRow objects with the specified value in the specified column.

[Visual Basic]
Overloads Protected Function FindRows( _
   ByVal column As DataColumn, _
   ByVal value As Object _
) As DataRow ()
[C#]
protected DataRow[] FindRows(
   DataColumn column,
   object value
);
[C++]
protected: DataRow* FindRows(
   DataColumn* column,
   Object* value
) [];
[JScript]
protected function FindRows(
   column : DataColumn,
   value : Object
) : DataRow[];

Parameters

column
The DataColumn to search in.
value
[To be supplied.]

Return Value

An array of DataRow objects containing the specified value.

Remarks

You can also use Select method to find a specific row in the DataTable. Furthermore, the Find and Contains methods of the RowsCollection also return specific rows or values in rows.

See Also

DataTable Class | DataTable Members | System.Data Namespace | DataTable.FindRows Overload List


DataTable.FindRows (DataKey, Object[])

Finds and returns an array of DataRow objects using the specified DataKey and values.

[Visual Basic]
Overloads Protected Function FindRows( _
   ByVal key As DataKey, _
   ByVal values() As Object _
) As DataRow ()
[C#]
protected DataRow[] FindRows(
   DataKey key,
   object[] values
);
[C++]
protected: DataRow* FindRows(
   DataKey* key,
   Object* values[]
) [];
[JScript]
protected function FindRows(
   key : DataKey,
   values : Object[]
) : DataRow[];

Parameters

key
A DataKey that specifies the DataColumn objects which comprise the tables primary key or keys.
values
[To be supplied.]

Return Value

A DataRow that contains the specified values.

Example [Visual Basic]

The following example sets the DataKey to the columns of a DataTable, and returns an array of DataRow objects that contain the specified values.

[Visual Basic]

Private Sub FindInDataKey()
   Dim keyCols() As DataColumn
   Dim t As DataTable
   t = DataGrid1.DataSource
   keyCols = t.PrimaryKey
   Dim arrVals(1) As Object
   ' Search for two values, the first is an index, the second a date.
   arrVals(0) = 1
   arrVals(1) = "12/2/99"
   Dim foundCols() As DataColumn
   foundCols = t.FindRows(keyCols, arrVals)
End Sub

See Also

DataTable Class | DataTable Members | System.Data Namespace | DataTable.FindRows Overload List | Select


DataTable.GetErrors

Returns an array of DataRow objects that contain errors.

[Visual Basic]
Public Function GetErrors() As DataRow ()
[C#]
public DataRow[] GetErrors();
[C++]
public: DataRow* GetErrors() [];
[JScript]
public function GetErrors() : DataRow[];

Return Value

An array of DataRow objects that have errors.

Remarks

Invoke GetErrors after invoking the DataSet class's Update method. Also, be sure you don't invoke the AcceptChanges on the DataTable until after all errors have been succesfully resolved, and the DataSet re-submitted for updating.

Example [Visual Basic]

The following example uses the GetErrors method to return an array of DataRow objects that have errors.

[Visual Basic]

Private Sub PrintAllErrs()
   Dim rowsInError() As DataRow
   Dim t As DataTable
   Dim ds As DataSet
   Dim i As Integer
   Dim c As DataColumn
   ds = DataSet1

   For Each t in ds.Tables
      ' Test if the table has errors. If not, skip it.
      If t.HasErrors Then
         ' Get an array of all rows with errors.
         rowsInError = t.GetErrors
         ' Print the error of each column in each row.
For i = 0 To UBound(rowsInError)
   For Each c In t.Columns
      Console.WriteLine(c.ColumnName, rowsInError(i).GetColumnError(c))
   Next c
   ' Clear the row errors
   rowsInError(i).ClearErrors
Next i
      End If
   Next t
End Sub

See Also

DataTable Class | DataTable Members | System.Data Namespace | AcceptChanges | HasErrors


DataTable.HasSchemaChanged

Gets a value indicating whether the column count has changed.

[Visual Basic]
Overridable Protected Function HasSchemaChanged() As Boolean
[C#]
protected virtual bool HasSchemaChanged();
[C++]
protected: virtual bool HasSchemaChanged();
[JScript]
protected function HasSchemaChanged() : Boolean;

Return Value

true if the column count is not 0; otherwise, false.

See Also

DataTable Class | DataTable Members | System.Data Namespace


DataTable.NewRow

Creates a new DataRow with the same schema as the table.

[Visual Basic]
Public Function NewRow() As DataRow
[C#]
public DataRow NewRow();
[C++]
public: DataRow* NewRow();
[JScript]
public function NewRow() : DataRow;

Return Value

A DataRow with the same schema as the DataTable.

Remarks

You must use the NewRow method to create new DataRow objects with the same schema as the DataTable. After creating a DataRow, you can add it to the RowsCollection, through the DataTable object's Rows property.

Example [Visual Basic]

The following example creates a DataTable, adds two DataColumn objects that determine the table's schema, and creates several new DataRow objects using the NewRow method. Those DataRow objects are then added to the RowsCollection using the Add method.

[Visual Basic]

Private Sub MakeDataTableAndDisplay()
   ' Create new DataTable and DataSource objects.
   Dim myDataTable As New DataTable

   ' Declare DataColumn and DataRow variables.
   Dim myDataColumn As DataColumn
   Dim myDataRow As DataRow
   Dim dv As DataView
   ' Create new DataColumn, set DataType, ColumnName and add to DataTable.
   myDataColumn = New DataColumn
   myDataColumn.DataType = System.Type.GetType("System.Int32")
   myDataColumn.ColumnName = "id"
   myDataTable.Columns.Add(myDataColumn)

   ' Create second column.
   myDataColumn = New DataColumn
   myDataColumn.DataType = Type.GetType("System.String")
   myDataColumn.ColumnName = "thing"
   myDataTable.Columns.Add(myDataColumn)

   ' Create new DataRow objects and add to DataTable.
   Dim i As Integer
   For i = 0 To 10
      myDataRow = myDataTable.NewRow
      myDataRow(0) = i
      myDataRow(1) = "thing " & i
      myDataTable.Rows.Add(myDataRow)
   Next i

   ' Configure DataSource and set to DataGrid.DataSource property.
   dv = New DataView(myDataTable)
   dv.Begin
   DataGrid1.DataSource = dv
   DataGrid1.PopulateColumns
End Sub

See Also

DataTable Class | DataTable Members | System.Data Namespace | AcceptChanges | Add | ColumnsCollection | DataColumn | RowsCollection


DataTable.OnColumnChanging

Raises the ColumnChanging event.

[Visual Basic]
Overridable Protected Sub OnColumnChanging( _
   ByVal e As DataColumnChangeEventArgs _
)
[C#]
protected virtual void OnColumnChanging(
   DataColumnChangeEventArgs e
);
[C++]
protected: virtual void OnColumnChanging(
   DataColumnChangeEventArgs* e
);
[JScript]
protected function OnColumnChanging(
   e : DataColumnChangeEventArgs
);

Parameters

e
A DataColumnChangeEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see TBD.

Notes to Inheritors: When overriding OnColumnChanging in a derived class, be sure to call the base class's OnColumnChanging method.

See Also

DataTable Class | DataTable Members | System.Data Namespace | AddOnColumnChanging | RemoveOnColumnChanging


DataTable.OnPropertyChanged

Raises the OnPropertyChanged event.

[Visual Basic]
Overridable Protected Sub OnPropertyChanged( _
   ByVal pcevent As PropertyChangedEventArgs _
)
[C#]
protected virtual void OnPropertyChanged(
   PropertyChangedEventArgs pcevent
);
[C++]
protected: virtual void OnPropertyChanged(
   PropertyChangedEventArgs* pcevent
);
[JScript]
protected function OnPropertyChanged(
   pcevent : PropertyChangedEventArgs
);

Parameters

pcevent
A PropertyChangedEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see TBD.

Notes to Inheritors: When overriding OnPropertyChanged in a derived class, be sure to call the base class's OnPropertyChanged method.

See Also

DataTable Class | DataTable Members | System.Data Namespace | AddOnPropertyChanged | RemoveOnPropertyChanged


DataTable.OnRemoveColumn

Notifies the DataTable that a DataColumn is being removed.

[Visual Basic]
Overridable Protected Sub OnRemoveColumn( _
   ByVal column As DataColumn _
)
[C#]
protected virtual void OnRemoveColumn(
   DataColumn column
);
[C++]
protected: virtual void OnRemoveColumn(
   DataColumn* column
);
[JScript]
protected function OnRemoveColumn(
   column : DataColumn
);

Parameters

column
The DataColumn being removed.

See Also

DataTable Class | DataTable Members | System.Data Namespace


DataTable.OnRowChanged

Raises the RowChanged event.

[Visual Basic]
Overridable Protected Sub OnRowChanged( _
   ByVal e As DataRowChangeEventArgs _
)
[C#]
protected virtual void OnRowChanged(
   DataRowChangeEventArgs e
);
[C++]
protected: virtual void OnRowChanged(
   DataRowChangeEventArgs* e
);
[JScript]
protected function OnRowChanged(
   e : DataRowChangeEventArgs
);

Parameters

e
A DataRowChangeEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see TBD\.

Notes to Inheritors: When overriding OnRowChanged in a derived class, be sure to call the base class's OnRowChanged method.

See Also

DataTable Class | DataTable Members | System.Data Namespace | AddOnRowChanged | RemoveOnRowChanged


DataTable.OnRowChanging

Raises the RowChanging event.

[Visual Basic]
Overridable Protected Sub OnRowChanging( _
   ByVal e As DataRowChangeEventArgs _
)
[C#]
protected virtual void OnRowChanging(
   DataRowChangeEventArgs e
);
[C++]
protected: virtual void OnRowChanging(
   DataRowChangeEventArgs* e
);
[JScript]
protected function OnRowChanging(
   e : DataRowChangeEventArgs
);

Parameters

e
A DataRowChangeEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see TBD.

Notes to Inheritors: When overriding OnRowChanging in a derived class, be sure to call the base class's OnRowChanging method.

See Also

DataTable Class | DataTable Members | System.Data Namespace | AddOnRowChanging | RemoveOnRowChanging


DataTable.OnRowDeleted

Raises the OnRowDeleted event.

[Visual Basic]
Overridable Protected Sub OnRowDeleted( _
   ByVal e As DataRowChangeEventArgs _
)
[C#]
protected virtual void OnRowDeleted(
   DataRowChangeEventArgs e
);
[C++]
protected: virtual void OnRowDeleted(
   DataRowChangeEventArgs* e
);
[JScript]
protected function OnRowDeleted(
   e : DataRowChangeEventArgs
);

Parameters

e
A DataRowChangeEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see TBD.

Notes to Inheritors: When overriding OnRowDeleted in a derived class, be sure to call the base class's OnRowDeleted method.

See Also

DataTable Class | DataTable Members | System.Data Namespace | AddOnRowDeleted | RemoveOnRowDeleted


DataTable.OnRowDeleting

Raises the OnRowDeleting event.

[Visual Basic]
Overridable Protected Sub OnRowDeleting( _
   ByVal e As DataRowChangeEventArgs _
)
[C#]
protected virtual void OnRowDeleting(
   DataRowChangeEventArgs e
);
[C++]
protected: virtual void OnRowDeleting(
   DataRowChangeEventArgs* e
);
[JScript]
protected function OnRowDeleting(
   e : DataRowChangeEventArgs
);

Parameters

e
A DataRowChangeEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see TBD.

Notes to Inheritors: When overriding OnRowDeleting in a derived class, be sure to call the base class's OnRowDeleting method.

See Also

DataTable Class | DataTable Members | System.Data Namespace | AddOnRowDeleting | RemoveOnRowDeleting


DataTable.RejectChanges

Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges was called.

[Visual Basic]
Public Sub RejectChanges()
[C#]
public void RejectChanges();
[C++]
public: void RejectChanges();
[JScript]
public function RejectChanges();

Remarks

When RejectChanges is called, any DataRow objects that are still in edit-mode cancel their edits. New rows are removed. Rows with the DataRowState set to Modified or Deleted return back to their original state.

See Also

DataTable Class | DataTable Members | System.Data Namespace | AcceptChanges | BeginEdit | DataRow | DataRowState | DataRowVersion | EndEdit


DataTable.RemoveOnColumnChanging

Removes the event handler that has been associated with the OnColumnChanging event.

[Visual Basic]
Public Sub RemoveOnColumnChanging( _
   ByVal handler As DataColumnChangeEventHandler _
)
[C#]
public void RemoveOnColumnChanging(
   DataColumnChangeEventHandler handler
);
[C++]
public: void RemoveOnColumnChanging(
   DataColumnChangeEventHandler* handler
);
[JScript]
public function RemoveOnColumnChanging(
   handler : DataColumnChangeEventHandler
);

Parameters

handler
handler to remove for this event

See Also

DataTable Class | DataTable Members | System.Data Namespace | AddOnColumnChanging


DataTable.RemoveOnPropertyChanged

Removes an event handler that has been associated with the OnPropertyChanged event.

[Visual Basic]
Public Sub RemoveOnPropertyChanged( _
   ByVal handler As PropertyChangedEventHandler _
)
[C#]
public void RemoveOnPropertyChanged(
   PropertyChangedEventHandler handler
);
[C++]
public: void RemoveOnPropertyChanged(
   PropertyChangedEventHandler* handler
);
[JScript]
public function RemoveOnPropertyChanged(
   handler : PropertyChangedEventHandler
);

Parameters

handler
The PropertyChangedEventHandler delegate to remove.

See Also

DataTable Class | DataTable Members | System.Data Namespace | AddOnPropertyChanged


DataTable.RemoveOnRowChanged

Removes an event handler for the row changed event. Occurs after a row in the table has been successfully edited.

[Visual Basic]
Public Sub RemoveOnRowChanged( _
   ByVal handler As DataRowChangeEventHandler _
)
[C#]
public void RemoveOnRowChanged(
   DataRowChangeEventHandler handler
);
[C++]
public: void RemoveOnRowChanged(
   DataRowChangeEventHandler* handler
);
[JScript]
public function RemoveOnRowChanged(
   handler : DataRowChangeEventHandler
);

Parameters

handler
handler to remove for this event

See Also

DataTable Class | DataTable Members | System.Data Namespace | AddOnRowChanged


DataTable.RemoveOnRowChanging

Removes an event handler for the row changing event. Occurs when a row in the table has proposed edits. The user can modify values in the row and should throw an exception to cancel the edit.

[Visual Basic]
Public Sub RemoveOnRowChanging( _
   ByVal handler As DataRowChangeEventHandler _
)
[C#]
public void RemoveOnRowChanging(
   DataRowChangeEventHandler handler
);
[C++]
public: void RemoveOnRowChanging(
   DataRowChangeEventHandler* handler
);
[JScript]
public function RemoveOnRowChanging(
   handler : DataRowChangeEventHandler
);

Parameters

handler
handler to remove for this event

See Also

DataTable Class | DataTable Members | System.Data Namespace | AddOnRowChanging


DataTable.RemoveOnRowDeleted

Removes an event handler for the row deleting event. Occurs after a row in the table was deleted.

[Visual Basic]
Public Sub RemoveOnRowDeleted( _
   ByVal handler As DataRowChangeEventHandler _
)
[C#]
public void RemoveOnRowDeleted(
   DataRowChangeEventHandler handler
);
[C++]
public: void RemoveOnRowDeleted(
   DataRowChangeEventHandler* handler
);
[JScript]
public function RemoveOnRowDeleted(
   handler : DataRowChangeEventHandler
);

Parameters

handler
handler to remove for this event

See Also

DataTable Class | DataTable Members | System.Data Namespace | AddOnRowDeleted


DataTable.RemoveOnRowDeleting

Removes an event handler for the row deleting event. Occurs after a row in the table is about to be deleted.

[Visual Basic]
Public Sub RemoveOnRowDeleting( _
   ByVal handler As DataRowChangeEventHandler _
)
[C#]
public void RemoveOnRowDeleting(
   DataRowChangeEventHandler handler
);
[C++]
public: void RemoveOnRowDeleting(
   DataRowChangeEventHandler* handler
);
[JScript]
public function RemoveOnRowDeleting(
   handler : DataRowChangeEventHandler
);

Parameters

handler
handler to remove for this event

See Also

DataTable Class | DataTable Members | System.Data Namespace | AddOnRowDeleting


DataTable.Reset

Resets the table back to its original state.

[Visual Basic]
Overridable Public Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();

Remarks

Subclasses should override to restore back to it's original state. UNDONE: Not in spec. Either DCR or rip.

See Also

DataTable Class | DataTable Members | System.Data Namespace


DataTable.ResetCaseSensitive

Resets the CaseSensitive property to its default state.

[Visual Basic]
Public Sub ResetCaseSensitive()
[C#]
public void ResetCaseSensitive();
[C++]
public: void ResetCaseSensitive();
[JScript]
public function ResetCaseSensitive();

See Also

DataTable Class | DataTable Members | System.Data Namespace


DataTable.ResetColumns

[To be supplied.]

[Visual Basic]
Overridable Public Sub ResetColumns()
[C#]
public virtual void ResetColumns();
[C++]
public: virtual void ResetColumns();
[JScript]
public function ResetColumns();

See Also

DataTable Class | DataTable Members | System.Data Namespace


DataTable.ResetConstraints

[To be supplied.]

[Visual Basic]
Overridable Public Sub ResetConstraints()
[C#]
public virtual void ResetConstraints();
[C++]
public: virtual void ResetConstraints();
[JScript]
public function ResetConstraints();

See Also

DataTable Class | DataTable Members | System.Data Namespace


DataTable.ResetLocale

Resets the Locale property to its default state.

[Visual Basic]
Public Sub ResetLocale()
[C#]
public void ResetLocale();
[C++]
public: void ResetLocale();
[JScript]
public function ResetLocale();

See Also

DataTable Class | DataTable Members | System.Data Namespace


DataTable.ResetNamespace

Resets the Namespace property to its default state.

[Visual Basic]
Public Sub ResetNamespace()
[C#]
public void ResetNamespace();
[C++]
public: void ResetNamespace();
[JScript]
public function ResetNamespace();

See Also

DataTable Class | DataTable Members | System.Data Namespace


DataTable.ResetPrimaryKey

Resets the PrimaryKey property to its default state.

[Visual Basic]
Overridable Public Sub ResetPrimaryKey()
[C#]
public virtual void ResetPrimaryKey();
[C++]
public: virtual void ResetPrimaryKey();
[JScript]
public function ResetPrimaryKey();

See Also

DataTable Class | DataTable Members | System.Data Namespace


DataTable.Select

Returns an array of DataRow objects.

Overload List

Returns an array of all DataRow objects.

[Visual Basic] Overloads Public Function Select() As DataRow ()
[C#] public DataRow[] Select();
[C++] public: DataRow* Select() [];
[JScript] public function Select() : DataRow[];

Returns an array of all DataRow objects that match the filter in the order of the sort, that match the specified state.

[Visual Basic] Overloads Public Function Select(String, String, DataViewRowState) As DataRow ()
[C#] public DataRow[] Select(String, String, DataViewRowState);
[C++] public: DataRow* Select(String*, String*, DataViewRowState) [];
[JScript] public function Select(String, String, DataViewRowState) : DataRow[];

Returns an array of all DataRow objects that match the filter criteria, in the the specified sort order.

[Visual Basic] Overloads Public Function Select(String, String) As DataRow ()
[C#] public DataRow[] Select(String, String);
[C++] public: DataRow* Select(String*, String*) [];
[JScript] public function Select(String, String) : DataRow[];

Returns an array of all DataRow objects that match the filter criteria in order of primary key (or lacking one, order of addition.)

[Visual Basic] Overloads Public Function Select(String) As DataRow ()
[C#] public DataRow[] Select(String);
[C++] public: DataRow* Select(String*) [];
[JScript] public function Select(String) : DataRow[];

Example [Visual Basic]

The following example uses a filter expression to return an array of DataRow objects.

Note This example shows how to use one of the overloaded versions of Select. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub GetRowsByFilter()
   Dim t As DataTable
   t = DataSet1.Tables("Orders")
   ' Presuming the DataTable has a column named Date.
   Dim strExpr As String
   strExpr = "Date > '1/1/00'"
   Dim foundRows() As DataRow
   ' Use the Select method to find all rows matching the filter.
   foundRows = t.Select(strExpr)
   Dim i As Integer
   ' Print column 0 of each returned row.
   For i = 0 to Ubound(foundRows)
      Console.WriteLine(foundRows(i)(0))
   Next i
End Sub

See Also

DataTable Class | DataTable Members | System.Data Namespace


DataTable.Select ()

Returns an array of all DataRow objects.

[Visual Basic]
Overloads Public Function Select() As DataRow ()
[C#]
public DataRow[] Select();
[C++]
public: DataRow* Select() [];
[JScript]
public function Select() : DataRow[];

Return Value

An array of DataRow objects.

Remarks

The method returns the current rows in order of primary key (or lacking one, order of addition.)

Example [Visual Basic]

The following example returns an array of DataRow objects through the Select method.

[Visual Basic]

Private Sub GetRows()
   Dim myRows() As DataRow
   Dim t As DataTable
   ' Get the DataTable of a DataSet.
   t = DataSet1.Tables("Suppliers")
   myRows = t.Select()
   Dim i As Integer
   ' Print the value one column of each DataRow.
   For i = 0 to UBound(myRows)
      Console.WriteLine(myRows(i)("CompanyName"))
   Next i
End Sub

See Also

DataTable Class | DataTable Members | System.Data Namespace | DataTable.Select Overload List | CaseSensitive | DataRow


DataTable.Select (String, String, DataViewRowState)

Returns an array of all DataRow objects that match the filter in the order of the sort, that match the specified state.

[Visual Basic]
Overloads Public Function Select( _
   ByVal filterExpression As String, _
   ByVal sort As String, _
   ByVal recordStates As DataViewRowState _
) As DataRow ()
[C#]
public DataRow[] Select(
   string filterExpression,
   string sort,
   DataViewRowState recordStates
);
[C++]
public: DataRow* Select(
   String* filterExpression,
   String* sort,
   DataViewRowState recordStates
) [];
[JScript]
public function Select(
   filterExpression : String,
   sort : String,
   recordStates : DataViewRowState
) : DataRow[];

Parameters

filterExpression
The criteria to use to filter the rows.
sort
A string specifying the column and sort direction.
recordStates
One of the DataViewRowState values.

Return Value

An array of DataRow objects.

Remarks

To form the filterExpression argument, use the same rules for creating the DataColumn class's Expression property value. The Sort argument also uses the same rules for creating class's Expression strings.

Example [Visual Basic]

The following example uses a filter expression and record state to return an array of DataRow objects.

[Visual Basic]

Private Sub GetRowsByFilter()
   Dim t As DataTable
   t = DataSet1.Tables("Orders")
   ' Presuming the DataTable has a column named Date.
   Dim strExpr As String
   Dim strSort As String
   strExpr = "Date > 1/1/00"
   Dim recState As DataViewRowState
   '
   strSort = "CompanyName DESC"
   recState = DataViewRowState.New
   Dim foundRows() As DataRow
   ' Use the Select method to find all rows matching the filter.
   foundRows = t.Select(strExpr, strSort, recState)
   Dim i As Integer
   ' Print column 0 of each returned row.
   For i = 0 to Ubound(foundRows)
      Console.WriteLine(foundRows(i)(0))
   Next i
End Sub

See Also

DataTable Class | DataTable Members | System.Data Namespace | DataTable.Select Overload List | CaseSensitive | DataRow | DataView | DataViewRowState | Expression


DataTable.Select (String, String)

Returns an array of all DataRow objects that match the filter criteria, in the the specified sort order.

[Visual Basic]
Overloads Public Function Select( _
   ByVal filterExpression As String, _
   ByVal sort As String _
) As DataRow ()
[C#]
public DataRow[] Select(
   string filterExpression,
   string sort
);
[C++]
public: DataRow* Select(
   String* filterExpression,
   String* sort
) [];
[JScript]
public function Select(
   filterExpression : String,
   sort : String
) : DataRow[];

Parameters

filterExpression
The criteria to use to filter the rows.
sort
A string specifying the column and sort direction.

Return Value

An array of DataRow objects matching the filter expression.

Remarks

To form the filterExpression argument, use the same rules for creating the DataColumn class's Expression property value. The Sort argument also uses the same rules for creating class's Expression strings.

Example [Visual Basic]

The following example uses a filter expression to return an array of DataRow objects.

[Visual Basic]

Private Sub GetRowsByFilter()
   Dim t As DataTable
   t = DataSet1.Tables(0)
   ' Presuming the DataTable has a column named Date.
   Dim strExpr As String
   Dim strSort As String
   strExpr = "Date > 1/1/00"

   strSort = "CompanyName DESC"
   Dim foundRows() As DataRow
   ' Use the Select method to find all rows matching the filter.
   foundRows = t.Select(strExpr, strSort)
   Dim i As Integer
   ' Print column 0 of each returned row.
   For i = 0 to Ubound(foundRows)
      Console.WriteLine(foundRows(i)(0))
   Next i
End Sub

See Also

DataTable Class | DataTable Members | System.Data Namespace | DataTable.Select Overload List | CaseSensitive | Expression | DataRow


DataTable.Select (String)

Returns an array of all DataRow objects that match the filter criteria in order of primary key (or lacking one, order of addition.)

[Visual Basic]
Overloads Public Function Select( _
   ByVal filterExpression As String _
) As DataRow ()
[C#]
public DataRow[] Select(
   string filterExpression
);
[C++]
public: DataRow* Select(
   String* filterExpression
) [];
[JScript]
public function Select(
   filterExpression : String
) : DataRow[];

Parameters

filterExpression
The criteria to use to filter the rows.

Return Value

An array of DataRow objects.

Remarks

To create the filterExpression argument, use the same rules that apply to the DataColumn class's Expression property value.

Example [Visual Basic]

The following example uses a filter expression to return an array of DataRow objects.

[Visual Basic]

Private Sub GetRowsByFilter()
   Dim t As DataTable
   t = DataSet1.Tables("Orders")
   ' Presuming the DataTable has a column named Date.
   Dim strExpr As String
   strExpr = "Date > '1/1/00'"
   Dim foundRows() As DataRow
   ' Use the Select method to find all rows matching the filter.
   foundRows = t.Select(strExpr)
   Dim i As Integer
   ' Print column 0 of each returned row.
   For i = 0 to Ubound(foundRows)
      Console.WriteLine(foundRows(i)(0))
   Next i
End Sub

See Also

DataTable Class | DataTable Members | System.Data Namespace | DataTable.Select Overload List | CaseSensitive | Expression | DataRow


DataTable.ShouldPersistCaseSensitive

Indicates whether the CaseSensitive property should be persisted.

[Visual Basic]
Public Function ShouldPersistCaseSensitive() As Boolean
[C#]
public bool ShouldPersistCaseSensitive();
[C++]
public: bool ShouldPersistCaseSensitive();
[JScript]
public function ShouldPersistCaseSensitive() : Boolean;

Return Value

true if the property value has been changed from its default; otherwise, false.

Remarks

You typically use this method only if you are either creating a designer for the DataTable, or creating your own control incorporating the DataTable.

See Also

DataTable Class | DataTable Members | System.Data Namespace


DataTable.ShouldPersistColumns

[To be supplied.]

[Visual Basic]
Overridable Public Function ShouldPersistColumns() As Boolean
[C#]
public virtual bool ShouldPersistColumns();
[C++]
public: virtual bool ShouldPersistColumns();
[JScript]
public function ShouldPersistColumns() : Boolean;

See Also

DataTable Class | DataTable Members | System.Data Namespace


DataTable.ShouldPersistConstraints

[To be supplied.]

[Visual Basic]
Overridable Public Function ShouldPersistConstraints() As Boolean
[C#]
public virtual bool ShouldPersistConstraints();
[C++]
public: virtual bool ShouldPersistConstraints();
[JScript]
public function ShouldPersistConstraints() : Boolean;

See Also

DataTable Class | DataTable Members | System.Data Namespace


DataTable.ShouldPersistLocale

Indicates whether the Locale property should be persisted.

[Visual Basic]
Public Function ShouldPersistLocale() As Boolean
[C#]
public bool ShouldPersistLocale();
[C++]
public: bool ShouldPersistLocale();
[JScript]
public function ShouldPersistLocale() : Boolean;

Return Value

true if the property value has been changed from its default; otherwise, false.

Remarks

You typically use this method only if you are either creating a designer for the DataTable, or creating your own control incorporating the DataTable.

See Also

DataTable Class | DataTable Members | System.Data Namespace


DataTable.ShouldPersistNamespace

Indicates whether the Namespace property should be persisted.

[Visual Basic]
Public Function ShouldPersistNamespace() As Boolean
[C#]
public bool ShouldPersistNamespace();
[C++]
public: bool ShouldPersistNamespace();
[JScript]
public function ShouldPersistNamespace() : Boolean;

Return Value

true if the property value has been changed from its default; otherwise, false.

Remarks

You typically use this method only if you are either creating a designer for the DataTable, or creating your own control incorporating the DataTable.

See Also

DataTable Class | DataTable Members | System.Data Namespace


DataTable.ShouldPersistPrimaryKey

Indicates whether the PrimaryKey property should be persisted.

[Visual Basic]
Overridable Public Function ShouldPersistPrimaryKey() As Boolean
[C#]
public virtual bool ShouldPersistPrimaryKey();
[C++]
public: virtual bool ShouldPersistPrimaryKey();
[JScript]
public function ShouldPersistPrimaryKey() : Boolean;

Return Value

true if the property value has been changed from its default; otherwise, false.

Remarks

You typically use this method only if you are either creating a designer for the DataTable, or creating your own control incorporating the DataTable.

See Also

DataTable Class | DataTable Members | System.Data Namespace | ResetPrimaryKey


DataTable.ToString

Returns the TableName and DisplayExpression, if there is one as a concatenated string.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

A string consisting of the TableName and the DisplayExpression values.

Remarks

Returns the TableName and DisplayExpression for the DataTable.

Example [Visual Basic]

The following example returns the TableName and DisplayExpression using the ToString method.

[Visual Basic]

Private Sub PrintToString(ds As DataSet)
   Dim t As DataTable
   For Each t In ds.Tables
      Debug.Print t.ToString
   Next
End Sub

See Also

DataTable Class | DataTable Members | System.Data Namespace | DisplayExpression | TableName


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataTable Events

The events of the DataTable class are listed below. For a complete list of DataTable class members, see the DataTable Members topic.

Public:

ColumnChanging | Occurs when a value has been submitted for this column.
PropertyChanged | This event occurs when any property on the control has been changed for any reason.
RowChanged | Occurs after a row in the table has been successfully edited.
RowChanging | Occurs when the DataRow is changing.
RowDeleted | Occurs after a row in the table has been deleted.
RowDeleting | Occurs before a row in the table is about to be deleted.

See Also

DataTable Class | System.Data Namespace


DataTable ColumnChanging Event

Occurs when a value has been submitted for this column.

The following declaration shows the syntax for a method that handles the ColumnChanging event.

[Visual Basic]
Private Sub DataTableName_ColumnChanging( _
   ByVal sender As Object, _
   ByVal e As DataColumnChangeEventArgs _
)
[C#]
private void DataTableName_ColumnChanging(
   object sender,
   DataColumnChangeEventArgs e
);
[C++]
private: void DataTableName_ColumnChanging(
   Object* sender,
   DataColumnChangeEventArgs* e
);
[JScript]
private DataTableName_ColumnChanging(
   sender : Object,
   e : DataColumnChangeEventArgs
);

Parameters

sender
The source of the event.
e
A DataColumnChangeEventArgs that contains the event data. The following DataColumnChangeEventArgs properties provide information specific to this event.
Property Description
Column
Gets the column whose value is changing.
ProposedValue
Gets or sets the proposed value.

See Also

DataTable Class | DataTable MembersTopic | System.Data Namespace


DataTable PropertyChanged Event

This event occurs when any property on the control has been changed for any reason.

The following declaration shows the syntax for a method that handles the PropertyChanged event.

[Visual Basic]
Private Sub DataTableName_PropertyChanged( _
   ByVal sender As Object, _
   ByVal e As PropertyChangedEventArgs _
)
[C#]
private void DataTableName_PropertyChanged(
   object sender,
   PropertyChangedEventArgs e
);
[C++]
private: void DataTableName_PropertyChanged(
   Object* sender,
   PropertyChangedEventArgs* e
);
[JScript]
private DataTableName_PropertyChanged(
   sender : Object,
   e : PropertyChangedEventArgs
);

Parameters

sender
The source of the event.
e
A PropertyChangedEventArgs that contains the event data. The following PropertyChangedEventArgs properties provide information specific to this event.
Property Description
PropertyName
Gets the name of the property that changed.

See Also

DataTable Class | DataTable MembersTopic | System.Data Namespace


DataTable RowChanged Event

Occurs after a row in the table has been successfully edited.

The following declaration shows the syntax for a method that handles the RowChanged event.

[Visual Basic]
Private Sub DataTableName_RowChanged( _
   ByVal sender As Object, _
   ByVal e As DataRowChangeEventArgs _
)
[C#]
private void DataTableName_RowChanged(
   object sender,
   DataRowChangeEventArgs e
);
[C++]
private: void DataTableName_RowChanged(
   Object* sender,
   DataRowChangeEventArgs* e
);
[JScript]
private DataTableName_RowChanged(
   sender : Object,
   e : DataRowChangeEventArgs
);

Parameters

sender
The source of the event.
e
A DataRowChangeEventArgs that contains the event data. The following DataRowChangeEventArgs properties provide information specific to this event.
Property Description
Action
Gets the action that has occurred on a DataRow.
Row
Gets the row upon which an action has occurred.

See Also

DataTable Class | DataTable MembersTopic | System.Data Namespace


DataTable RowChanging Event

Occurs when the DataRow is changing.

The following declaration shows the syntax for a method that handles the RowChanging event.

[Visual Basic]
Private Sub DataTableName_RowChanging( _
   ByVal sender As Object, _
   ByVal e As DataRowChangeEventArgs _
)
[C#]
private void DataTableName_RowChanging(
   object sender,
   DataRowChangeEventArgs e
);
[C++]
private: void DataTableName_RowChanging(
   Object* sender,
   DataRowChangeEventArgs* e
);
[JScript]
private DataTableName_RowChanging(
   sender : Object,
   e : DataRowChangeEventArgs
);

Parameters

sender
The source of the event.
e
A DataRowChangeEventArgs that contains the event data. The following DataRowChangeEventArgs properties provide information specific to this event.
Property Description
Action
Gets the action that has occurred on a DataRow.
Row
Gets the row upon which an action has occurred.

See Also

DataTable Class | DataTable MembersTopic | System.Data Namespace


DataTable RowDeleted Event

Occurs after a row in the table has been deleted.

The following declaration shows the syntax for a method that handles the RowDeleted event.

[Visual Basic]
Private Sub DataTableName_RowDeleted( _
   ByVal sender As Object, _
   ByVal e As DataRowChangeEventArgs _
)
[C#]
private void DataTableName_RowDeleted(
   object sender,
   DataRowChangeEventArgs e
);
[C++]
private: void DataTableName_RowDeleted(
   Object* sender,
   DataRowChangeEventArgs* e
);
[JScript]
private DataTableName_RowDeleted(
   sender : Object,
   e : DataRowChangeEventArgs
);

Parameters

sender
The source of the event.
e
A DataRowChangeEventArgs that contains the event data. The following DataRowChangeEventArgs properties provide information specific to this event.
Property Description
Action
Gets the action that has occurred on a DataRow.
Row
Gets the row upon which an action has occurred.

See Also

DataTable Class | DataTable MembersTopic | System.Data Namespace


DataTable RowDeleting Event

Occurs before a row in the table is about to be deleted.

The following declaration shows the syntax for a method that handles the RowDeleting event.

[Visual Basic]
Private Sub DataTableName_RowDeleting( _
   ByVal sender As Object, _
   ByVal e As DataRowChangeEventArgs _
)
[C#]
private void DataTableName_RowDeleting(
   object sender,
   DataRowChangeEventArgs e
);
[C++]
private: void DataTableName_RowDeleting(
   Object* sender,
   DataRowChangeEventArgs* e
);
[JScript]
private DataTableName_RowDeleting(
   sender : Object,
   e : DataRowChangeEventArgs
);

Parameters

sender
The source of the event.
e
A DataRowChangeEventArgs that contains the event data. The following DataRowChangeEventArgs properties provide information specific to this event.
Property Description
Action
Gets the action that has occurred on a DataRow.
Row
Gets the row upon which an action has occurred.

See Also

DataTable Class | DataTable MembersTopic | System.Data Namespace


DataUtil Class

[To be supplied.]

Object
DataUtil

[Visual Basic]
Public Class DataUtil
[C#]
public class DataUtil
[C++]
public __gc class DataUtil
[JScript]
public class DataUtil

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

DataUtil Members | System.Data Namespace


DataUtil Members

Public:

Constructor

DataUtil Constructor [To be supplied.]

Methods

CheckName | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataUtil Class | System.Data Namespace


DataUtil Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public DataUtil();
[C++]
public: DataUtil();
[JScript]
public function DataUtil();

See Also

DataUtil Class | DataUtil Members | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataUtil Methods

The methods of the DataUtil class are listed below. For a complete list of DataUtil class members, see the DataUtil Members topic.

Public:

CheckName | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataUtil Class | System.Data Namespace


DataUtil.CheckName

[To be supplied.]

[Visual Basic]
Public Shared Sub CheckName( _
   ByVal name As String _
)
[C#]
public static void CheckName(
   string name
);
[C++]
public: static void CheckName(
   String* name
);
[JScript]
public static function CheckName(
   name : String
);

Parameters

name
[To be supplied.]

See Also

DataUtil Class | DataUtil Members | System.Data Namespace


DataView Class

Represents a databindable, customized view of a DataTable for sorting, filtering, searching, editing, and navigation.

Object
Component
DataView

[Visual Basic]
Public Class DataView
   Inherits Component
   Implements ILiveList, IList, ICollection, IEnumerable, _
   ISortedList, IIndexedList, ITypedList
[C#]
public class DataView : Component, ILiveList, IList, ICollection,
   IEnumerable, ISortedList, IIndexedList, ITypedList
[C++]
public __gc class DataView : public Component, ILiveList, IList,
   ICollection, IEnumerable, ISortedList, IIndexedList, ITypedList
[JScript]
public class DataView extends Component, ILiveList, IList,
   ICollection, IEnumerable, ISortedList, IIndexedList, ITypedList

Remarks

A major function of the DataView is to allow data binding on both Win Forms and Web Forms.

Additionally, a DataView can be customized to present a subset of data from the DataTable. This capability allows you to have two controls bound to the same DataTable, but showing different versions of the data. For example, one control may be bound to a DataView showing all of the rows in the table, while a second may be configured to display only the rows that have been deleted from the DataTable. The DataTable also has a DefaultView property which returns the default DataView for the table. For example, if you wish to create a custom view on the table, set the RowFilter on the DataView returned by the DefaultView.

To create a filtered and sorted view of data, set the RowFilter and Sort properties. Then use the Item property (DataView indexer) to return a single DataRowView.

You can also add and delete from the set of rows using the AddNew and Delete methods. When you use those methods, the RowStateFilter property can set to specify that only deleted rows or new rows be displayed by the DataView.

Requirements

Namespace: System.Data

Assembly: System.Data.dll

Example [Visual Basic]

The following example creates a new DataView with and binds a control to it.

[Visual Basic]

Private Sub CreateDataView()
   Dim t As DataTable
   Set t = New DataTable
   ' Not shown: code to populate the DataTable with data.
   Dim dv As DataView
   ' Create the DataView using the table.
   dv = New DataView(t)
   ' Set properties of the DataView assuming a table named Orders,
   ' with fields for customer ID, date, ship date, and order total.
   With dv
      .RowFilter = "CustID = 'ANTON'"
      .Sort = "Date"
      .RowStateFilter = DataViewRowState.ModifiedCurrent
      .AllowDelete = True
      .AllowEdit = True
      .AllowNew = False
    End With

   ' Bind to a DataGrid control.
   DataGrid1.DataSource = dv
   DataGrid1.PopulateColumns
End Sub

Private Sub AddToDataView()
   ' Get the DataView from the DataGrid.
   Dim dv As DataView
   dv = CType(DataGrid1.DataSource, DataView)
   ' Add a new row.
   dv.AllowNew = True
   Dim drv As DataRowView
   drv = dv.AddNew()
   ' Set a value in one field of the row.
   drv("CompanyID") = 9877
End Sub

Private Sub DeleteRow()
   ' Get the DataView from the DataGrid.
   Dim dv As DataView
   dv = CType(DataGrid1.DataSource, DataView)
   dv.AllowDelete = True
   ' Delete the first row of the DataView
   dv.Delete(0)
   ' Print the count of deleted rows.
   dv.RowStateFilter = Deleted

See Also

DataView Members | System.Data Namespace | DataSet | DataTable | DataSetView


DataView Members

Public:

Constructor

DataView Constructor Overloaded. Initializes a new instance of the DataView class.

Properties

AllowDelete | Sets or gets a value indicating whether deletes are allowed.
AllowEdit | Gets or sets a value indicating whether edits are allowed.
AllowNew | Gets or sets a value indicating whether the new rows can be added using the AddNew method.
ApplyDefaultSort | [To be supplied.]
DataSetView | Gets the DataSetView associated with this DataView.
Item | Gets a row of data from a specified table. In C#, this member is the indexer for the DataView class.
RowFilter | Gets or sets the expression used to filter which rows are viewed in the DataView.
RowStateFilter | Gets or sets the row state filter used in the DataView.
Site (inherited from Component) | Gets or sets the site of the Component.
Sort | Gets or sets the sort column or columns, and sort order for the table.
Table | Gets or sets the source DataTable.

Methods

AddNew | Adds a new row of data.
Delete | Deletes a row.
Dispose | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Find | Overloaded. Finds a row in the DataView.
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetEnumerator | Gets an enumerator for this DataView.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Index_ListChanged | [To be supplied.]
ResetSort | Resets the Sort property to its default state.
ShouldPersistSort | Indicates whether the Sort property should be persisted.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Events

ListChanged | Occurs when the list managed by the DataView changes.
PropertyChanged | Occurs when a property value changes.

Protected:

Properties

IsOpen Gets a value indicating whether the data source is currently open and projecting views of data on the DataTable.

Methods

Close | Closes the DataView.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetFilter | Gets the filter for the DataView.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnListChanged | Raises the System.Data.DataView.ListChanged event.
OnPropertyChanged | Raises the System.Data.DataView.PropertyChanged event.
Open | Opens a DataView.
RaisePropertyChanged | Raises the OnPropertyChanged event.
Reset | [To be supplied.]
SetIndex | [To be supplied.]
UpdateIndex | Overloaded. [To be supplied.]

Event Hookup:

Methods

AddOnListChanged | Adds an event handler for the System.Data.DataView.ListChanged event.
AddOnPropertyChanged | Adds an event handler for the System.Data.DataView.PropertyChanged event.
RemoveOnListChanged | Removes the event handler that has been associated with the OnListChanged event.
RemoveOnPropertyChanged | Removes an event handler that has been associated with the OnPropertyChanged event.

See Also

DataView Class | System.Data Namespace


DataView Constructor

Initializes a new instance of the DataView class.

Overload List

Initializes a new instance of the DataView class.

[Visual Basic] Overloads Public Sub New()
[C#] public DataView();
[C++] public: DataView();
[JScript] public function DataView();

Initializes a new instance of the DataView class with the specified DataTable.

[Visual Basic] Overloads Public Sub New(DataTable)
[C#] public DataView(DataTable);
[C++] public: DataView(DataTable*);
[JScript] public function DataView(DataTable);

Example [Visual Basic]

The following example creates a new DataView with a given DataTable.

Note This example shows how to use one of the overloaded version of the DataView constructor. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub MakeDataView()
   Dim dv As DataView
   dv = New DataView(DataSet1.Tables("Suppliers")
   ' Bind a ComboBox control to the DataView.
   Combo1.DataSource = dv
   Combo1.DisplayMember = "Suppliers.CompanyName"
End Sub

See Also

DataView Class | DataView Members | System.Data Namespace


DataView Constructor ()

Initializes a new instance of the DataView class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public DataView();
[C++]
public: DataView();
[JScript]
public function DataView();

Example

The following example creates a new DataView.

' The code below  goes into the Declarations section of the form.
[VB]
Private Sub MakeDataView()
   Dim dv As DataView
   dv = New DataView
   With dv
      .Table = DataSet1.Tables("Suppliers")
      .AllowDelete = True
      .AllowEdit = True
      .AllowNew = True
      .RowFilter = "City = 'Berlin'"
      .RowStateFilter = DataViewRowState.ModifiedCurrent
      .Sort = "CompanyName DESC"
   End With

   ' Simple bind to a TextBox control
   Text1.Bindings.Add("Text", dv, "CompanyName")
End Sub

See Also

DataView Class | DataView Members | System.Data Namespace | DataView Constructor Overload List | DataTable | DataSetView


DataView Constructor (DataTable)

Initializes a new instance of the DataView class with the specified DataTable.

[Visual Basic]
Overloads Public Sub New( _
   ByVal table As DataTable _
)
[C#]
public DataView(
   DataTable table
);
[C++]
public: DataView(
   DataTable* table
);
[JScript]
public function DataView(
   table : DataTable
);

Parameters

table
[To be supplied.]

Example [Visual Basic]

The following example creates a new DataView with a given DataTable.

[Visual Basic]

Private Sub MakeDataView()
   Dim dv As DataView
   dv = New DataView(DataSet1.Tables("Suppliers")
   ' Bind a ComboBox control to the DataView.
   Combo1.DataSource = dv
   Combo1.DisplayMember = "Suppliers.CompanyName"
End Sub

See Also

DataView Class | DataView Members | System.Data Namespace | DataView Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataView Properties

The properties of the DataView class are listed below. For a complete list of DataView class members, see the DataView Members topic.

Public:

AllowDelete | Sets or gets a value indicating whether deletes are allowed.
AllowEdit | Gets or sets a value indicating whether edits are allowed.
AllowNew | Gets or sets a value indicating whether the new rows can be added using the AddNew method.
ApplyDefaultSort | [To be supplied.]
DataSetView | Gets the DataSetView associated with this DataView.
Item | Gets a row of data from a specified table. In C#, this member is the indexer for the DataView class.
RowFilter | Gets or sets the expression used to filter which rows are viewed in the DataView.
RowStateFilter | Gets or sets the row state filter used in the DataView.
Site (inherited from Component) | Gets or sets the site of the Component.
Sort | Gets or sets the sort column or columns, and sort order for the table.
Table | Gets or sets the source DataTable.

Protected:

IsOpen Gets a value indicating whether the data source is currently open and projecting views of data on the DataTable.

See Also

DataView Class | System.Data Namespace


DataView.AllowDelete

Sets or gets a value indicating whether deletes are allowed.

[Visual Basic]
Public Property AllowDelete As Boolean
[C#]
public bool AllowDelete {get; set;}
[C++]
public: __property bool get_AllowDelete();
public: __property void set_AllowDelete(bool);
[JScript]
public function get AllowDelete() : Boolean;
public function set AllowDelete(Boolean);

Property Value

true, if deletes are allowed; otherwise, false.

Example [Visual Basic]

The following example checks the AllowDelete property before deleting a DataRow from a DataView.

[Visual Basic]

Private Sub CheckAllowDelete(rowToDelete As DataRow)
   Dim dv As DataView
   dv = New DataView(DataSet1.Tables("Suppliers")
   If dv.AllowDelete Then
      Rows(rowToDelete).Delete
   End If
End Sub

See Also

DataView Class | DataView Members | System.Data Namespace


DataView.AllowEdit

Gets or sets a value indicating whether edits are allowed.

[Visual Basic]
Public Property AllowEdit As Boolean
[C#]
public bool AllowEdit {get; set;}
[C++]
public: __property bool get_AllowEdit();
public: __property void set_AllowEdit(bool);
[JScript]
public function get AllowEdit() : Boolean;
public function set AllowEdit(Boolean);

Property Value

true, if edits are allowed; otherwise, false.

Example [Visual Basic]

The following example invokes the AllowEdit method before editing a row in a DataView.

[Visual Basic]

Private Sub EditRow(dv As DataView)
   dv.AllowEdit = True
   dv(0).BeginEdit
   dv(0)("FirstName") = "Mary"
   dv(0)("LastName") = "Jones"
   dv(0).EndEdit
End Sub

See Also

DataView Class | DataView Members | System.Data Namespace | AllowDelete | AllowNew | BeginEdit


DataView.AllowNew

Gets or sets a value indicating whether the new rows can be added using the AddNew method.

[Visual Basic]
Public Property AllowNew As Boolean
[C#]
public bool AllowNew {get; set;}
[C++]
public: __property bool get_AllowNew();
public: __property void set_AllowNew(bool);
[JScript]
public function get AllowNew() : Boolean;
public function set AllowNew(Boolean);

Property Value

true, if new rows can be added; otherwise, false.

Example [Visual Basic]

The following example sets the AllowNew property to true before adding a new row with the AddNew method.

[Visual Basic]

Private Sub AddNew()
   Dim myTable As DataTable
   myTable = New DataTable
   ' Not shown: code to populate DataTable.
   Dim dv As DataView
   dv = New DataView(myTable)
   dv.AllowNew = True
   Dim drv As DataRowView
   drv = dv.AddNew
   drv("ProductName") = "New Product Name"
End Sub

See Also

DataView Class | DataView Members | System.Data Namespace | AddNew | DataRowView


DataView.ApplyDefaultSort

[To be supplied.]

[Visual Basic]
Public Property ApplyDefaultSort As Boolean
[C#]
public bool ApplyDefaultSort {get; set;}
[C++]
public: __property bool get_ApplyDefaultSort();
public: __property void set_ApplyDefaultSort(bool);
[JScript]
public function get ApplyDefaultSort() : Boolean;
public function set ApplyDefaultSort(Boolean);

See Also

DataView Class | DataView Members | System.Data Namespace


DataView.DataSetView

Gets the DataSetView associated with this DataView.

[Visual Basic]
Public ReadOnly Property DataSetView As DataSetView
[C#]
public DataSetView DataSetView {get;}
[C++]
public: __property DataSetView* get_DataSetView();
[JScript]
public function get DataSetView() : DataSetView;

Property Value

The DataSetView that created this DataView. If no such DataSetView exists, a null reference (in Visual Basic Nothing).

See Also

DataView Class | DataView Members | System.Data Namespace


DataView.IsOpen

Gets a value indicating whether the data source is currently open and projecting views of data on the DataTable.

[Visual Basic]
Protected ReadOnly Property IsOpen As Boolean
[C#]
protected bool IsOpen {get;}
[C++]
protected: __property bool get_IsOpen();
[JScript]
protected function get IsOpen() : Boolean;

Property Value

true, if the source is open; otherwise, false.

Remarks

A DataView is a "view" on a DataTable because it provides custom sorting and filtering of the data. The IsOpen property can be queried to determine if a DataView has been opened using the Open method.

See Also

DataView Class | DataView Members | System.Data Namespace | Open


DataView.Item

Gets a row of data from a specified table.

[C#] In C#, this member is the indexer for the DataView class.

[Visual Basic]
Public Default ReadOnly Property Item( _
   ByVal recordIndex As Integer _
) As DataRowView
[C#]
public DataRowView this[
   int recordIndex
] {get;}
[C++]
public: __property DataRowView* get_Item(
   int recordIndex
);
[JScript]
returnValue = DataViewObject.Item(recordIndex);
-or-
returnValue = DataViewObject(recordIndex);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

recordIndex
The index of a record in the DataTable.

Parameters [Visual Basic, C#, C++]

recordIndex
The index of a record in the DataTable.

Property Value

A DataRowView of the desired row.

See Also

DataView Class | DataView Members | System.Data Namespace


DataView.RowFilter

Gets or sets the expression used to filter which rows are viewed in the DataView.

[Visual Basic]
Public Property RowFilter As String
[C#]
public string RowFilter {get; virtual set;}
[C++]
public: __property String* get_RowFilter();
public: __property virtual void set_RowFilter(String*);
[JScript]
public function get RowFilter() : String;
public function set RowFilter(String);

Property Value

A string that specifies how rows are to be filtered. For more details, see the Remarks below.

Remarks

To form a RowFilter value, specify the name of a column followed by an operator and a value to filter on. The value must be in quotes. For example:

"LastName = 'Smith'"

See the DataColumn class's Expression property for more information.

To return only those columns with null values, use the following expression:

"Isnull(Col1,'Null Column') = 'Null Column'"

Example [Visual Basic]

The following example creates a DataView and sets its RowFilter property.

[Visual Basic]

Private Sub MakeDataView()
   Dim dv As DataView
   dv = New DataView
   With dv
      .Table = DataSet1.Tables("Suppliers")
      .AllowDelete = True
      .AllowEdit = True
      .AllowNew = True
      .RowFilter = "City = 'Berlin'"
      .RowStateFilter = DataViewRowState.ModifiedCurrent
      .Sort = "CompanyName DESC"
   End With

   ' Simple bind to a TextBox control
   Text1.Bindings.Add("Text", dv, "CompanyName")
End Sub

See Also

DataView Class | DataView Members | System.Data Namespace | Expression | Sort


DataView.RowStateFilter

Gets or sets the row state filter used in the DataView.

[Visual Basic]
Public Property RowStateFilter As DataViewRowState
[C#]
public DataViewRowState RowStateFilter {get; set;}
[C++]
public: __property DataViewRowState get_RowStateFilter();
public: __property void set_RowStateFilter(DataViewRowState);
[JScript]
public function get RowStateFilter() : DataViewRowState;
public function set RowStateFilter(DataViewRowState);

Property Value

One of the DataViewRowState values. Possible values include: None, Unchanged, New, Deleted, ModifiedCurrent, ModifiedOriginal, OriginalRows, and CurrentRows. The default is CurrentRows.

Remarks

Only rows that have been deleted using the Delete method will have their RowStateFilter value set to Deleted. Those rows added using the AddNew method will similarly have the property set to New.

Note Using the Remove method of the RowsCollection class does not mean that a row will be marked as Deleted. Use the Delete method instead to ensure such rows can be viewed in the DataView.

New rows will also be visible when the RowStateFilter is set to ModifiedCurrent or CurrentRows.

Deleted rows will also be visible when the RowStateFilter is set to ModifiedOriginal and OriginalRows.

Example [Visual Basic]

The following example creates a DataView and sets its RowFilter property.

[Visual Basic]

Private Sub MakeDataView()
   Dim dv As DataView
   dv = New DataView
   With dv
      .Table = DataSet1.Tables("Suppliers")
      .AllowDelete = True
      .AllowEdit = True
      .AllowNew = True
      .RowFilter = "City = 'Berlin'"
      .RowStateFilter = DataViewRowState.ModifiedCurrent
      .Sort = "CompanyName DESC"
   End With

   ' Simple bind to a TextBox control
   Text1.Bindings.Add("Text", dv, "CompanyName")
End Sub

See Also

DataView Class | DataView Members | System.Data Namespace | DataViewRowState | AddNew | Delete


DataView.Sort

Gets or sets the sort column or columns, and sort order for the table.

[Visual Basic]
Public Property Sort As String
[C#]
public string Sort {get; set;}
[C++]
public: __property String* get_Sort();
public: __property void set_Sort(String*);
[JScript]
public function get Sort() : String;
public function set Sort(String);

Property Value

A string containing the column name followed by "ASC" (ascending) or "DESC" (descening). Columns are sorted asending by default. Multiple columns can be separated by commas.

Remarks

See the Expression property of DataColumn for more details on forming a Sort expression.

Example [Visual Basic]

The following example instructs the DataView to sort the table by two columns.

[Visual Basic]

Private Sub SortByTwoColumns()
   ' Get the DefaultView of a DataSet.
   Dim myDataView As DataView
   myDataView = DataSet1.DefaultView
   ' By default, the first column sorted ascending.
   myDataView.Sort = "State, ZipCode DESC"
End Sub

See Also

DataView Class | DataView Members | System.Data Namespace | RowFilter | Expression


DataView.Table

Gets or sets the source DataTable.

[Visual Basic]
Public Property Table As DataTable
[C#]
public DataTable Table {get; set;}
[C++]
public: __property DataTable* get_Table();
public: __property void set_Table(DataTable*);
[JScript]
public function get Table() : DataTable;
public function set Table(DataTable);

Property Value

A DataTable that provides the data for this view.

Remarks

The DataTable also has a DefaultView property which returns the default DataView for the table. For example, if you wish to create a custom view on the table, set the RowFilter on the DataView returned by the DefaultView.

Example [Visual Basic]

The following example gets the DataTable of the current DataView.

[Visual Basic]

Private Sub GetDataTableFromDataView()
   ' Get the DataTable from the DataView bound to a DataGrid.
   Dim dv As DataView
   dv = CType(DataGrid1.DataSource, DataView)
   Dim t As DataTable
   t = dv.Table
   Dim r As DataRow
   Dim c As DataColumn
   For Each r in t.Rows
      For Each c in t.Columns
         Console.WriteLine(r(c)).ToString
      Next c
    Next r
ENd Sub

See Also

DataView Class | DataView Members | System.Data Namespace | DataTable


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataView Methods

The methods of the DataView class are listed below. For a complete list of DataView class members, see the DataView Members topic.

Public:

AddNew | Adds a new row of data.
Delete | Deletes a row.
Dispose | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Find | Overloaded. Finds a row in the DataView.
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetEnumerator | Gets an enumerator for this DataView.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Index_ListChanged | [To be supplied.]
ResetSort | Resets the Sort property to its default state.
ShouldPersistSort | Indicates whether the Sort property should be persisted.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Protected:

Close | Closes the DataView.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetFilter | Gets the filter for the DataView.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnListChanged | Raises the System.Data.DataView.ListChanged event.
OnPropertyChanged | Raises the System.Data.DataView.PropertyChanged event.
Open | Opens a DataView.
RaisePropertyChanged | Raises the OnPropertyChanged event.
Reset | [To be supplied.]
SetIndex | [To be supplied.]
UpdateIndex | Overloaded. [To be supplied.]

Event Hookup:

AddOnListChanged | Adds an event handler for the System.Data.DataView.ListChanged event.
AddOnPropertyChanged | Adds an event handler for the System.Data.DataView.PropertyChanged event.
RemoveOnListChanged | Removes the event handler that has been associated with the OnListChanged event.
RemoveOnPropertyChanged | Removes an event handler that has been associated with the OnPropertyChanged event.

See Also

DataView Class | System.Data Namespace


DataView.AddNew

Adds a new row of data.

[Visual Basic]
Overridable Public Function AddNew() As DataRowView
[C#]
public virtual DataRowView AddNew();
[C++]
public: virtual DataRowView* AddNew();
[JScript]
public function AddNew() : DataRowView;

Return Value

A DataRowView.

Example [Visual Basic]

The following example uses the AddNew method to return a new DataRowView that has been added to the DataTable.

[Visual Basic]

Private Sub AddNewDataRowView(dv As DataView)
   Dim drv As DataRowView
   drv = dv.AddNew
   ' Change values in the DataRow.
   drv(0) = "New value"
End Sub

See Also

DataView Class | DataView Members | System.Data Namespace | AllowNew | DataRowView


DataView.AddOnListChanged

Adds an event handler for the System.Data.DataView.ListChanged event.

[Visual Basic]
Overridable Public Sub AddOnListChanged( _
   ByVal handler As ListChangedEventHandler _
)
[C#]
public virtual void AddOnListChanged(
   ListChangedEventHandler handler
);
[C++]
public: virtual void AddOnListChanged(
   ListChangedEventHandler* handler
);
[JScript]
public function AddOnListChanged(
   handler : ListChangedEventHandler
);

Parameters

handler
A ListChangedEventHandler delegate that represents the method that will handle the OnListChanged event.

See Also

DataView Class | DataView Members | System.Data Namespace


DataView.AddOnPropertyChanged

Adds an event handler for the System.Data.DataView.PropertyChanged event.

[Visual Basic]
Public Sub AddOnPropertyChanged( _
   ByVal handler As PropertyChangedEventHandler _
)
[C#]
public void AddOnPropertyChanged(
   PropertyChangedEventHandler handler
);
[C++]
public: void AddOnPropertyChanged(
   PropertyChangedEventHandler* handler
);
[JScript]
public function AddOnPropertyChanged(
   handler : PropertyChangedEventHandler
);

Parameters

handler
A PropertyChangedEventHandler delegate that represents the method that will handle the OnListChanged event.

See Also

DataView Class | DataView Members | System.Data Namespace | RemoveOnPropertyChanged


DataView.Close

Closes the DataView.

[Visual Basic]
Protected Sub Close()
[C#]
protected void Close();
[C++]
protected: void Close();
[JScript]
protected function Close();

Remarks

The method allows you to manually close the DataView in derived classes. Use the corresponding Open method to open the DataView.

Example

The following example invokes the Close method.

See Also

DataView Class | DataView Members | System.Data Namespace | Open


DataView.Delete

Deletes a row.

[Visual Basic]
Public Sub Delete( _
   ByVal index As Integer _
)
[C#]
public void Delete(
   int index
);
[C++]
public: void Delete(
   int index
);
[JScript]
public function Delete(
   index : int
);

Parameters

index
The index of the row to delete.

Remarks

After deleting a DataRow, its state changes to DataViewRowState.Deleted.

Example [Visual Basic]

The following example uses the Delete method to delete a row.

[Visual Basic]

Private Sub DeleteRow(dv As DataView, val As String)
   ' Find the given value in the DataView and delete the row.
   Dim i As Integer
   i = dv.Find(val)
   If i = -1 Then
      ' The value wasn't found
      MessageBox.Show("Value not found in primary key column")
      Exit Sub
   Else
      dv.Delete(i)
   End If
End Sub

See Also

DataView Class | DataView Members | System.Data Namespace | DataViewRowState | Find


DataView.Dispose

[To be supplied.]

[Visual Basic]
Overrides Public Sub Dispose()
[C#]
public override void Dispose();
[C++]
public: override void Dispose();
[JScript]
public override function Dispose();

See Also

DataView Class | DataView Members | System.Data Namespace


DataView.Find

Finds a row in the DataView.

Overload List

Finds a row in the DataView by the specified primary key value.

[Visual Basic] Overloads Public Function Find(Object) As Integer
[C#] public int Find(Object);
[C++] public: int Find(Object*);
[JScript] public function Find(Object) : int;

Finds a row in the DataView by the specified primary key values.

[Visual Basic] Overloads Public Function Find(Object()) As Integer
[C#] public int Find(Object[]);
[C++] public: int Find(Object*[]);
[JScript] public function Find(Object[]) : int;

Example [Visual Basic]

The following example uses the Find method to return the index of a row that contains specified values in its primary key columns.

Note This example shows how to use one of the overloaded versions of Find. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub FindValueInDataView(t As DataTable)
   Dim dv As DataView
   Dim i As Integer
   Dim vals(1) As Object
   dv = New DataView(t)
   dv.Sort = "Cusomers"
   ' Find the customer named "John Smith".
   vals(0)= "John"
   vals(1) = "Smith"
   i = dv.Find(vals)
   Console.WriteLine(dv(i))
End Sub

See Also

DataView Class | DataView Members | System.Data Namespace


DataView.Find (Object)

Finds a row in the DataView by the specified primary key value.

[Visual Basic]
Overloads Public Function Find( _
   ByVal key As Object _
) As Integer
[C#]
public int Find(
   object key
);
[C++]
public: int Find(
   Object* key
);
[JScript]
public function Find(
   key : Object
) : int;

Parameters

key
[To be supplied.]

Return Value

The index of the row in the DataView.

Example [Visual Basic]

The following example uses the Find method to return the index of the row containing the desired value in the primary key column.

[Visual Basic]

Private Sub FindValueInDataView(t As DataTable)
   Dim dv As DataView
   Dim i As Integer
   dv = New DataView(t)
   dv.Sort = "CusomerID"
   ' Find the customer named "DUMON" in the primary key column
   i = dv.Find("DUMON")
   Console.WriteLine(dv(i))
End Sub

See Also

DataView Class | DataView Members | System.Data Namespace | DataView.Find Overload List | Delete


DataView.Find (Object[])

Finds a row in the DataView by the specified primary key values.

[Visual Basic]
Overloads Public Function Find( _
   ByVal key() As Object _
) As Integer
[C#]
public int Find(
   object[] key
);
[C++]
public: int Find(
   Object* key[]
);
[JScript]
public function Find(
   key : Object[]
) : int;

Parameters

key
An array of values, typed as Object.

Return Value

The index of the found row.

Example [Visual Basic]

The following example uses the Find method to return the index of a row that contains specified values in its primary key columns.

[Visual Basic]

Private Sub FindValueInDataView(t As DataTable)
   Dim dv As DataView
   Dim i As Integer
   Dim vals(1) As Object
   dv = New DataView(t)
   dv.Sort = "Cusomers"
   ' Find the customer named "John Smith".
   vals(0)= "John"
   vals(1) = "Smith"
   i = dv.Find(vals)
   Console.WriteLine(dv(i))
End Sub

See Also

DataView Class | DataView Members | System.Data Namespace | DataView.Find Overload List


DataView.GetEnumerator

Gets an enumerator for this DataView.

[Visual Basic]
Overridable Public Function GetEnumerator() As IEnumerator
[C#]
public virtual IEnumerator GetEnumerator();
[C++]
public: virtual IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

Return Value

An IEnumerator for navigating through the list.

See Also

DataView Class | DataView Members | System.Data Namespace


DataView.GetFilter

Gets the filter for the DataView.

[Visual Basic]
Overridable Protected Function GetFilter() As IFilter
[C#]
protected virtual IFilter GetFilter();
[C++]
protected: virtual IFilter* GetFilter();
[JScript]
protected function GetFilter() : IFilter;

Return Value

An IFilter interface.

See Also

DataView Class | DataView Members | System.Data Namespace


DataView.Index_ListChanged

[To be supplied.]

[Visual Basic]
Overridable Public Sub Index_ListChanged( _
   ByVal sender As Object, _
   ByVal e As ListChangedEventArgs _
)
[C#]
public virtual void Index_ListChanged(
   object sender,
   ListChangedEventArgs e
);
[C++]
public: virtual void Index_ListChanged(
   Object* sender,
   ListChangedEventArgs* e
);
[JScript]
public function Index_ListChanged(
   sender : Object,
   e : ListChangedEventArgs
);

Parameters

sender
[To be supplied.]
e
[To be supplied.]

See Also

DataView Class | DataView Members | System.Data Namespace


DataView.OnListChanged

Raises the System.Data.DataView.ListChanged event.

[Visual Basic]
Overridable Protected Sub OnListChanged( _
   ByVal e As ListChangedEventArgs _
)
[C#]
protected virtual void OnListChanged(
   ListChangedEventArgs e
);
[C++]
protected: virtual void OnListChanged(
   ListChangedEventArgs* e
);
[JScript]
protected function OnListChanged(
   e : ListChangedEventArgs
);

Parameters

e
A ListChangedEventArgs that contains the event data.

See Also

DataView Class | DataView Members | System.Data Namespace


DataView.OnPropertyChanged

Raises the System.Data.DataView.PropertyChanged event.

[Visual Basic]
Overridable Protected Sub OnPropertyChanged( _
   ByVal pcevent As PropertyChangedEventArgs _
)
[C#]
protected virtual void OnPropertyChanged(
   PropertyChangedEventArgs pcevent
);
[C++]
protected: virtual void OnPropertyChanged(
   PropertyChangedEventArgs* pcevent
);
[JScript]
protected function OnPropertyChanged(
   pcevent : PropertyChangedEventArgs
);

Parameters

pcevent
A PropertyChangedEventArgs that contains the event data.

See Also

DataView Class | DataView Members | System.Data Namespace | AddOnPropertyChanged | RemoveOnPropertyChanged


DataView.Open

Opens a DataView.

[Visual Basic]
Protected Sub Open()
[C#]
protected void Open();
[C++]
protected: void Open();
[JScript]
protected function Open();

Remarks

The method allows you to manually open the DataView in derived classes. Use the corresponding Close method to close the DataView.

Example [Visual Basic]

The following example checks the IsOpen property before invoking the Open method.

[Visual Basic]

Private Sub OpenDataView(ByRef dv As DataView)
   If dv.IsOpen Then Exit Sub
   dv.Open
End Sub

See Also

DataView Class | DataView Members | System.Data Namespace


DataView.RaisePropertyChanged

Raises the OnPropertyChanged event.

[Visual Basic]
Protected Sub RaisePropertyChanged( _
   ByVal name As String _
)
[C#]
protected void RaisePropertyChanged(
   string name
);
[C++]
protected: void RaisePropertyChanged(
   String* name
);
[JScript]
protected function RaisePropertyChanged(
   name : String
);

Parameters

name
Name of the changed property.

See Also

DataView Class | DataView Members | System.Data Namespace


DataView.RemoveOnListChanged

Removes the event handler that has been associated with the OnListChanged event.

[Visual Basic]
Overridable Public Sub RemoveOnListChanged( _
   ByVal handler As ListChangedEventHandler _
)
[C#]
public virtual void RemoveOnListChanged(
   ListChangedEventHandler handler
);
[C++]
public: virtual void RemoveOnListChanged(
   ListChangedEventHandler* handler
);
[JScript]
public function RemoveOnListChanged(
   handler : ListChangedEventHandler
);

Parameters

handler
The ListChangedEventHandler delegate to remove.

See Also

DataView Class | DataView Members | System.Data Namespace


DataView.RemoveOnPropertyChanged

Removes an event handler that has been associated with the OnPropertyChanged event.

[Visual Basic]
Public Sub RemoveOnPropertyChanged( _
   ByVal handler As PropertyChangedEventHandler _
)
[C#]
public void RemoveOnPropertyChanged(
   PropertyChangedEventHandler handler
);
[C++]
public: void RemoveOnPropertyChanged(
   PropertyChangedEventHandler* handler
);
[JScript]
public function RemoveOnPropertyChanged(
   handler : PropertyChangedEventHandler
);

Parameters

handler
The PropertyChangedEventHandler to remove,

See Also

DataView Class | DataView Members | System.Data Namespace | RemoveOnPropertyChanged


DataView.Reset

[To be supplied.]

[Visual Basic]
Protected Sub Reset()
[C#]
protected void Reset();
[C++]
protected: void Reset();
[JScript]
protected function Reset();

See Also

DataView Class | DataView Members | System.Data Namespace


DataView.ResetSort

Resets the Sort property to its default state.

[Visual Basic]
Public Sub ResetSort()
[C#]
public void ResetSort();
[C++]
public: void ResetSort();
[JScript]
public function ResetSort();

See Also

DataView Class | DataView Members | System.Data Namespace | Sort


DataView.SetIndex

[To be supplied.]

[Visual Basic]
Overridable Protected Sub SetIndex( _
   ByVal newSort As String, _
   ByVal newRowStates As DataViewRowState, _
   ByVal newRowFilter As DataFilter _
)
[C#]
protected virtual void SetIndex(
   string newSort,
   DataViewRowState newRowStates,
   DataFilter newRowFilter
);
[C++]
protected: virtual void SetIndex(
   String* newSort,
   DataViewRowState newRowStates,
   DataFilter* newRowFilter
);
[JScript]
protected function SetIndex(
   newSort : String,
   newRowStates : DataViewRowState,
   newRowFilter : DataFilter
);

Parameters

newSort
[To be supplied.]
newRowStates
[To be supplied.]
newRowFilter
[To be supplied.]

See Also

DataView Class | DataView Members | System.Data Namespace


DataView.ShouldPersistSort

Indicates whether the Sort property should be persisted.

[Visual Basic]
Public Function ShouldPersistSort() As Boolean
[C#]
public bool ShouldPersistSort();
[C++]
public: bool ShouldPersistSort();
[JScript]
public function ShouldPersistSort() : Boolean;

Return Value

true if the property value has been changed from its default; otherwise, false.

Remarks

You typically use this method only if you are either creating a designer for the DataView, or creating your own control incorporating the DataView.

See Also

DataView Class | DataView Members | System.Data Namespace


DataView.UpdateIndex

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Protected Sub UpdateIndex(Boolean)
[C#] protected virtual void UpdateIndex(bool);
[C++] protected: virtual void UpdateIndex(bool);
[JScript] protected function UpdateIndex(Boolean);

[To be supplied.]

[Visual Basic] Overloads Protected Sub UpdateIndex()
[C#] protected void UpdateIndex();
[C++] protected: void UpdateIndex();
[JScript] protected function UpdateIndex();

See Also

DataView Class | DataView Members | System.Data Namespace


DataView.UpdateIndex (Boolean)

[To be supplied.]

[Visual Basic]
Overloads Overridable Protected Sub UpdateIndex( _
   ByVal force As Boolean _
)
[C#]
protected virtual void UpdateIndex(
   bool force
);
[C++]
protected: virtual void UpdateIndex(
   bool force
);
[JScript]
protected function UpdateIndex(
   force : Boolean
);

Parameters

force
[To be supplied.]

See Also

DataView Class | DataView Members | System.Data Namespace | DataView.UpdateIndex Overload List


DataView.UpdateIndex ()

[To be supplied.]

[Visual Basic]
Overloads Protected Sub UpdateIndex()
[C#]
protected void UpdateIndex();
[C++]
protected: void UpdateIndex();
[JScript]
protected function UpdateIndex();

See Also

DataView Class | DataView Members | System.Data Namespace | DataView.UpdateIndex Overload List


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataView Events

The events of the DataView class are listed below. For a complete list of DataView class members, see the DataView Members topic.

Public:

ListChanged | Occurs when the list managed by the DataView changes.
PropertyChanged | Occurs when a property value changes.

See Also

DataView Class | System.Data Namespace


DataView ListChanged Event

Occurs when the list managed by the DataView changes.

The following declaration shows the syntax for a method that handles the ListChanged event.

[Visual Basic]
Private Sub DataViewName_ListChanged( _
   ByVal sender As Object, _
   ByVal e As ListChangedEventArgs _
)
[C#]
private void DataViewName_ListChanged(
   object sender,
   ListChangedEventArgs e
);
[C++]
private: void DataViewName_ListChanged(
   Object* sender,
   ListChangedEventArgs* e
);
[JScript]
private DataViewName_ListChanged(
   sender : Object,
   e : ListChangedEventArgs
);

Parameters

sender
The source of the event.
e
A ListChangedEventArgs that contains the event data. The following ListChangedEventArgs properties provide information specific to this event.
Property Description
ListChangedType
[To be supplied.]
NewIndex
[To be supplied.]
OldIndex
[To be supplied.]

See Also

DataView Class | DataView MembersTopic | System.Data Namespace


DataView PropertyChanged Event

Occurs when a property value changes.

The following declaration shows the syntax for a method that handles the PropertyChanged event.

[Visual Basic]
Private Sub DataViewName_PropertyChanged( _
   ByVal sender As Object, _
   ByVal e As PropertyChangedEventArgs _
)
[C#]
private void DataViewName_PropertyChanged(
   object sender,
   PropertyChangedEventArgs e
);
[C++]
private: void DataViewName_PropertyChanged(
   Object* sender,
   PropertyChangedEventArgs* e
);
[JScript]
private DataViewName_PropertyChanged(
   sender : Object,
   e : PropertyChangedEventArgs
);

Parameters

sender
The source of the event.
e
A PropertyChangedEventArgs that contains the event data. The following PropertyChangedEventArgs properties provide information specific to this event.
Property Description
PropertyName
Gets the name of the property that changed.

See Also

DataView Class | DataView MembersTopic | System.Data Namespace


DataViewRowState Enumeration

Describes the version of data in a DataRow.

[Visual Basic]
Public Enum DataViewRowState
[C#]
public enum DataViewRowState
[C++]
public enum DataViewRowState

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

The DataViewRowState values are used either to retrieve a particular version of data in a DataRow, or to determine what versions exist.

Set the RowStateFilter property of the DataView to specify which version or versions of the data you want to view.

You can use the Boolean operator Or with the values to get more than one version.

The DataTable uses DataViewRowState in the Select method.

Members

Member Name | Description
CurrentRows | Current rows, including unchanged, new, and modified rows.
Deleted | Deleted row.
ModifiedCurrent | Current version, which is a modified version of original data (see ModifiedOriginal).
ModifiedOriginal | The original version (although it has since been modified and is available as ModifiedCurrent).
New | New row.
None | None.
OriginalRows | Original rows, including unchanged and deleted rows.
Unchanged | Unchanged row.

Requirements

Namespace: System.Data

Assembly: System.Data.dll

Example [Visual Basic]

The following example sets the RowStateFilter to new and modified current rows.

[Visual Basic]

Private Sub GetNewAndCurrent()
   Dim dv As DataView
   Set dv = DataSet1.DefaultView
   dv.RowStateFilter = DataViewRowState.New Or _
   DataViewRowState.ModifiedCurrent
End Sub

See Also

System.Data Namespace | DataRow | DataSetView | DataView | Select | TableSetting | TableSettingsCollection


DBCommandBehavior Enumeration

[To be supplied.]

[Visual Basic]
Public Enum DBCommandBehavior
[C#]
public enum DBCommandBehavior
[C++]
public enum DBCommandBehavior

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
KeyInfo | [To be supplied.]
SchemaOnly | [To be supplied.]
SingleResult | [To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace


DBObjectState Enumeration

[To be supplied.]

[Visual Basic]
Public Enum DBObjectState
[C#]
public enum DBObjectState
[C++]
public enum DBObjectState

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Broken | [To be supplied.]
Closed | [To be supplied.]
Connecting | [To be supplied.]
Executing | [To be supplied.]
Fetching | [To be supplied.]
InTransaction | [To be supplied.]
Open | [To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace


DeletedRowInaccessibleException Class

Represents the exception that is thrown when an action is attempted on a DataRow that has been deleted.

Object
Exception
SystemException
DeletedRowInaccessibleException

[Visual Basic]
Public Class DeletedRowInaccessibleException
   Inherits SystemException
[C#]
public class DeletedRowInaccessibleException : SystemException
[C++]
public __gc class DeletedRowInaccessibleException : public
   SystemException
[JScript]
public class DeletedRowInaccessibleException extends
   SystemException

Remarks

To delete a DataRow, use the DataRow class's Delete method. Once you have deleted a row with the method, any attempts to manipulate it will generate the DeletedRowInaccessibleException.

The DeletedRowInaccessibleException is thrown when using one of the following properties or methods that attempt to get or set the value of a deleted DataRow:

  • Item property (DataRow indexer)
  • ItemArray property
  • BeginEdit method

Use the DataRow class's RowState to determine if a row has been deleted.

Requirements

Namespace: System.Data

Assembly: System.Data.dll

Example [Visual Basic]

The following example deletes a DataRow from a DataTable. A subsequent attempt to read a value from the deleted row causes the DeletedRowInaccessibleException to be thrown.

[Visual Basic]

Private Sub DeleteRow()
   ' Create DataTable with one DataColumn.
   Dim t As New DataTable
   Dim dc As New DataColumn
   Set dc.DataType = system.Type.GetType("System.Int32")
   t.Columns.Add dc
   Dim i As Integer
   ' Add 10 rows.
   Dim r As DataRow
   For i = 0 To 9
      Set r = t.NewRow
      r(0) = i
      t.Rows.Add r
   Next
   t.AcceptChanges
   Try
      Dim removedRow As DataRow
      Set removedRow = t.Rows(9)
      removedRow.Delete
      Debug.Print removedRow.RowState
      Debug.Print removedRow(0)
      removedRow.AcceptChanges
      Catch delRowErr As System.Data.DeletedRowInaccessibleException
      Debug.Print "DeletedRowInaccessibleException", delRowErr.Message
    Finally
      Debug.Print "finished"
    End Try
End Sub

See Also

DeletedRowInaccessibleException Members | System.Data Namespace | BeginEdit | DataRow | DataRowState | Delete | Item | ItemArray | RowState


DeletedRowInaccessibleException Members

Public:

Constructor

DeletedRowInaccessibleException Constructor Overloaded. Initializes a new instance of the DeletedRowInaccessibleException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

DeletedRowInaccessibleException Class | System.Data Namespace


DeletedRowInaccessibleException Constructor

Initializes a new instance of the DeletedRowInaccessibleException class.

Overload List

Initializes a new instance of the DeletedRowInaccessibleException class.

[Visual Basic] Overloads Public Sub New()
[C#] public DeletedRowInaccessibleException();
[C++] public: DeletedRowInaccessibleException();
[JScript] public function DeletedRowInaccessibleException();

Initializes a new instance of the DeletedRowInaccessibleException class with the specified string.

[Visual Basic] Overloads Public Sub New(String)
[C#] public DeletedRowInaccessibleException(String);
[C++] public: DeletedRowInaccessibleException(String*);
[JScript] public function DeletedRowInaccessibleException(String);

Example [Visual Basic]

The following example shows a simple procedure that raises the DeletedRowInaccessibleException if a DataRow object's RowState property equals Deleted.

Note This example shows how to use one of the overloaded version of the DeletedRowInaccessibleException constructor. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub ChangeRows(myRow As DataRow)
   Select Case myRow.RowState
   Case DataRowState.Deleted
      err.RaiseException New DeletedRowInaccessibleException("The row was deleted")
   ' Other cases not shown
   End Select
   Catch delRowExc As DeletedRowInaccessibleException
      MessageBox.Show delRowExc.Message
End Sub

End Sub

See Also

DeletedRowInaccessibleException Class | DeletedRowInaccessibleException Members | System.Data Namespace


DeletedRowInaccessibleException Constructor ()

Initializes a new instance of the DeletedRowInaccessibleException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public DeletedRowInaccessibleException();
[C++]
public: DeletedRowInaccessibleException();
[JScript]
public function DeletedRowInaccessibleException();

Remarks

Use the DataRow class's RowState to determine if a row has been deleted.

Example [Visual Basic]

The following example shows a simple procedure that raises the DeletedRowInaccessibleException if a DataRow object's RowState property equals Deleted.

[Visual Basic]

Private Sub ChangeRows(myRow As DataRow)
   Select Case myRow.RowState
   Case DataRowState.Deleted
      err.RaiseException New DeletedRowInaccessibleException
   ' Other cases not shown
   End Select
   Catch delRowExc As DeletedRowInaccessibleException
      MessageBox.Show delRowExc.Message
End Sub

See Also

DeletedRowInaccessibleException Class | DeletedRowInaccessibleException Members | System.Data Namespace | DeletedRowInaccessibleException Constructor Overload List | BeginEdit | DataRow | DataRowState | Item | ItemArray | RowState


DeletedRowInaccessibleException Constructor (String)

Initializes a new instance of the DeletedRowInaccessibleException class with the specified string.

[Visual Basic]
Overloads Public Sub New( _
   ByVal s As String _
)
[C#]
public DeletedRowInaccessibleException(
   string s
);
[C++]
public: DeletedRowInaccessibleException(
   String* s
);
[JScript]
public function DeletedRowInaccessibleException(
   s : String
);

Parameters

s
A string that can be printed with the ToString property.

Remarks

Use the DataRow class's RowState to determine if a row has been deleted.

Example [Visual Basic]

The following example shows a simple procedure that raises the DeletedRowInaccessibleException if a DataRow object's RowState property equals Deleted.

[Visual Basic]

Private Sub ChangeRows(myRow As DataRow)
   Select Case myRow.RowState
   Case DataRowState.Deleted
      err.RaiseException New DeletedRowInaccessibleException("The row was deleted")
   ' Other cases not shown
   End Select
   Catch delRowExc As DeletedRowInaccessibleException
      MessageBox.Show delRowExc.Message
End Sub

End Sub

See Also

DeletedRowInaccessibleException Class | DeletedRowInaccessibleException Members | System.Data Namespace | DeletedRowInaccessibleException Constructor Overload List | BeginEdit | DataRow | DataRowState | Item | ItemArray | RowState


DuplicateConstraintException Class

[To be supplied.]

Object
Exception
SystemException
DuplicateConstraintException

[Visual Basic]
Public Class DuplicateConstraintException
   Inherits SystemException
[C#]
public class DuplicateConstraintException : SystemException
[C++]
public __gc class DuplicateConstraintException : public
   SystemException
[JScript]
public class DuplicateConstraintException extends SystemException

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

DuplicateConstraintException Members | System.Data Namespace


DuplicateConstraintException Members

Public:

Constructor

DuplicateConstraintException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

DuplicateConstraintException Class | System.Data Namespace


DuplicateConstraintException Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public DuplicateConstraintException();
[C++] public: DuplicateConstraintException();
[JScript] public function DuplicateConstraintException();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public DuplicateConstraintException(String);
[C++] public: DuplicateConstraintException(String*);
[JScript] public function DuplicateConstraintException(String);

See Also

DuplicateConstraintException Class | DuplicateConstraintException Members | System.Data Namespace


DuplicateConstraintException Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public DuplicateConstraintException();
[C++]
public: DuplicateConstraintException();
[JScript]
public function DuplicateConstraintException();

See Also

DuplicateConstraintException Class | DuplicateConstraintException Members | System.Data Namespace | DuplicateConstraintException Constructor Overload List


DuplicateConstraintException Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal s As String _
)
[C#]
public DuplicateConstraintException(
   string s
);
[C++]
public: DuplicateConstraintException(
   String* s
);
[JScript]
public function DuplicateConstraintException(
   s : String
);

Parameters

s
[To be supplied.]

See Also

DuplicateConstraintException Class | DuplicateConstraintException Members | System.Data Namespace | DuplicateConstraintException Constructor Overload List


DuplicateNameException Class

[To be supplied.]

Object
Exception
SystemException
DuplicateNameException

[Visual Basic]
Public Class DuplicateNameException
   Inherits SystemException
[C#]
public class DuplicateNameException : SystemException
[C++]
public __gc class DuplicateNameException : public SystemException
[JScript]
public class DuplicateNameException extends SystemException

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

DuplicateNameException Members | System.Data Namespace


DuplicateNameException Members

Public:

Constructor

DuplicateNameException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

DuplicateNameException Class | System.Data Namespace


DuplicateNameException Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public DuplicateNameException();
[C++] public: DuplicateNameException();
[JScript] public function DuplicateNameException();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public DuplicateNameException(String);
[C++] public: DuplicateNameException(String*);
[JScript] public function DuplicateNameException(String);

See Also

DuplicateNameException Class | DuplicateNameException Members | System.Data Namespace


DuplicateNameException Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public DuplicateNameException();
[C++]
public: DuplicateNameException();
[JScript]
public function DuplicateNameException();

See Also

DuplicateNameException Class | DuplicateNameException Members | System.Data Namespace | DuplicateNameException Constructor Overload List


DuplicateNameException Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal s As String _
)
[C#]
public DuplicateNameException(
   string s
);
[C++]
public: DuplicateNameException(
   String* s
);
[JScript]
public function DuplicateNameException(
   s : String
);

Parameters

s
[To be supplied.]

See Also

DuplicateNameException Class | DuplicateNameException Members | System.Data Namespace | DuplicateNameException Constructor Overload List


EmptyDataSourceException Class

[To be supplied.]

Object
Exception
SystemException
EmptyDataSourceException

[Visual Basic]
Public Class EmptyDataSourceException
   Inherits SystemException
[C#]
public class EmptyDataSourceException : SystemException
[C++]
public __gc class EmptyDataSourceException : public SystemException
[JScript]
public class EmptyDataSourceException extends SystemException

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

EmptyDataSourceException Members | System.Data Namespace


EmptyDataSourceException Members

Public:

Constructor

EmptyDataSourceException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

EmptyDataSourceException Class | System.Data Namespace


EmptyDataSourceException Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public EmptyDataSourceException();
[C++] public: EmptyDataSourceException();
[JScript] public function EmptyDataSourceException();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public EmptyDataSourceException(String);
[C++] public: EmptyDataSourceException(String*);
[JScript] public function EmptyDataSourceException(String);

See Also

EmptyDataSourceException Class | EmptyDataSourceException Members | System.Data Namespace


EmptyDataSourceException Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public EmptyDataSourceException();
[C++]
public: EmptyDataSourceException();
[JScript]
public function EmptyDataSourceException();

See Also

EmptyDataSourceException Class | EmptyDataSourceException Members | System.Data Namespace | EmptyDataSourceException Constructor Overload List


EmptyDataSourceException Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal s As String _
)
[C#]
public EmptyDataSourceException(
   string s
);
[C++]
public: EmptyDataSourceException(
   String* s
);
[JScript]
public function EmptyDataSourceException(
   s : String
);

Parameters

s
[To be supplied.]

See Also

EmptyDataSourceException Class | EmptyDataSourceException Members | System.Data Namespace | EmptyDataSourceException Constructor Overload List


EnforceConstraintException Class

[To be supplied.]

Object
Exception
SystemException
DataException
EnforceConstraintException

[Visual Basic]
Public Class EnforceConstraintException
   Inherits DataException
[C#]
public class EnforceConstraintException : DataException
[C++]
public __gc class EnforceConstraintException : public DataException
[JScript]
public class EnforceConstraintException extends DataException

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

EnforceConstraintException Members | System.Data Namespace


EnforceConstraintException Members

Public:

Constructor

EnforceConstraintException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

EnforceConstraintException Class | System.Data Namespace


EnforceConstraintException Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public EnforceConstraintException();
[C++] public: EnforceConstraintException();
[JScript] public function EnforceConstraintException();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public EnforceConstraintException(String);
[C++] public: EnforceConstraintException(String*);
[JScript] public function EnforceConstraintException(String);

See Also

EnforceConstraintException Class | EnforceConstraintException Members | System.Data Namespace


EnforceConstraintException Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public EnforceConstraintException();
[C++]
public: EnforceConstraintException();
[JScript]
public function EnforceConstraintException();

See Also

EnforceConstraintException Class | EnforceConstraintException Members | System.Data Namespace | EnforceConstraintException Constructor Overload List


EnforceConstraintException Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal s As String _
)
[C#]
public EnforceConstraintException(
   string s
);
[C++]
public: EnforceConstraintException(
   String* s
);
[JScript]
public function EnforceConstraintException(
   s : String
);

Parameters

s
[To be supplied.]

See Also

EnforceConstraintException Class | EnforceConstraintException Members | System.Data Namespace | EnforceConstraintException Constructor Overload List


EnforceConstraintsRule Enumeration

[To be supplied.]

[Visual Basic]
Public Enum EnforceConstraintsRule
[C#]
public enum EnforceConstraintsRule
[C++]
public enum EnforceConstraintsRule

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Default | [To be supplied.]
EnforceConstraint | [To be supplied.]
RelaxConstraint | [To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace


EvaluateException Class

[To be supplied.]

Object
Exception
SystemException
DataException
EvaluateException

[Visual Basic]
Public Class EvaluateException
   Inherits DataException
[C#]
public class EvaluateException : DataException
[C++]
public __gc class EvaluateException : public DataException
[JScript]
public class EvaluateException extends DataException

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

EvaluateException Members | System.Data Namespace


EvaluateException Members

Public:

Constructor

EvaluateException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

EvaluateException Class | System.Data Namespace


EvaluateException Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public EvaluateException();
[C++] public: EvaluateException();
[JScript] public function EvaluateException();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public EvaluateException(String);
[C++] public: EvaluateException(String*);
[JScript] public function EvaluateException(String);

See Also

EvaluateException Class | EvaluateException Members | System.Data Namespace


EvaluateException Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public EvaluateException();
[C++]
public: EvaluateException();
[JScript]
public function EvaluateException();

See Also

EvaluateException Class | EvaluateException Members | System.Data Namespace | EvaluateException Constructor Overload List


EvaluateException Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal s As String _
)
[C#]
public EvaluateException(
   string s
);
[C++]
public: EvaluateException(
   String* s
);
[JScript]
public function EvaluateException(
   s : String
);

Parameters

s
[To be supplied.]

See Also

EvaluateException Class | EvaluateException Members | System.Data Namespace | EvaluateException Constructor Overload List


ForeignKeyConstraint Class

Represents an action restriction enforced on a set of columns in a child/parent relationship when a value or row is either deleted or updated.

Object
Constraint
ForeignKeyConstraint

[Visual Basic]
Public Class ForeignKeyConstraint
   Inherits Constraint
[C#]
public class ForeignKeyConstraint : Constraint
[C++]
public __gc class ForeignKeyConstraint : public Constraint
[JScript]
public class ForeignKeyConstraint extends Constraint

Remarks

A ForeignKeyConstraint restricts the action performed when a value in a column (or columns) is either deleted or updated. Such a constraint is intended to be used with primary key columns. In a parent/child relationship between two tables, deleting a value from the parent table can affect the child rows in one of the following ways.

  • The child rows can also be deleted (a cascading action).
  • The values in the child column (or columns) can be set to null values.
  • The values in the child column (or columns) can be set to default values.
  • An exception can be thrown.

ForeignKeyConstraint objects are contained in the ConstraintsCollection of a DataTable, which is accessed through the Constraints property.

Constraints are not enforced unless the EnforceConstraints property is set to true.

The AcceptRejectRule is enforced whenever a DataTable object's AcceptChanges method is invoked.

Requirements

Namespace: System.Data

Assembly: System.Data.dll

Example [Visual Basic]

The following example creates a ForeignKeyConstraint, sets various of its properties, and adds it to a DataTable object's ConstraintsCollection.

[Visual Basic]

' The next line goes into the Declarations section of the module:
' SuppliersProducts is a class derived from DataSet.
Private myDataSet As SuppliersProducts

Private Sub CreateConstraint()
   ' Declare parent column and child column variables.
   Dim pCol As DataColumn
   Dim cCol As DataColumn
   Dim myFKC As ForeignKeyConstraint
   ' Set parent and child column variables.
   pCol = MyDataSet.Tables("Suppliers").Columns("SupplierID")
   cCol = MyDataSet.Tables("Products").Columns("SupplieriD")
   myFKC = New ForeignKeyConstraint("SuppierFKConstraint", pCol, cCol)
   ' Set null values when a value is deleted.
   myFKC.DeleteRule = Rule.SetNull
   myFKC.UpdateRule = Rule.Cascade
   myFKC.AcceptRejectRule = AcceptRejectRule.Cascade
   ' Add the constraint, and set EnforceConstraints to true.
   myDataSet.Tables("Suppliers").Constraints.Add myFKC
   myDataSet.EnforceConstraints = True
End Sub

See Also

ForeignKeyConstraint Members | System.Data Namespace | AcceptRejectRule | DataTable | ConstraintsCollection | Rule


ForeignKeyConstraint Members

Public:

Constructor

ForeignKeyConstraint Constructor Overloaded. Initializes a new instance of the ForeignKeyConstraint class.

Properties

AcceptRejectRule | Indicates what kind of action should take place across this constraint when AcceptChanges is invoked.
Columns | Gets the child columns of this constraint.
ConstraintName (inherited from Constraint) | The name of this constraint within the ConstraintsCollection. An ArgumentException is thrown if setting the name to null or empty string and the column belongs to a collection. A DuplicateNameException is thrown if this column belongs to a collection and it already has a column with the same name (case insensitive).
DataSet | Gets the DataSet to which this ForeignKeyConstraint belongs.
DeleteRule | Gets or sets the action that occurs across this constraint on when a row is deleted.
IsPrimaryKey (inherited from Constraint) | Gets a value indicating whether the constraint is on a primary key column.
RelatedColumns | The parent columns of this constraint.
RelatedTable | Gets the parent table of this constraint.
Table | Gets the child table of this constraint.
UpdateRule | Gets or sets the action that occurs across this constraint on when a row is deleted.

Methods

Equals | Gets a value indicating whether the current ForeignKeyConstraint is identical to the specified object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

_DataSet (inherited from Constraint) Gets the DataSet to which this constraint belongs.

Methods

CheckStateForProperty (inherited from Constraint) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanged | Inheriting classes should override this method to handle this event. Call base.OnPropertyChanged to send this event to any registered event listeners.
RaisePropertyChanged | Raises the property changed event. This creates the needed event data and then calls OnPropertyChanged.
SetDataSet (inherited from Constraint) | Sets the constraint's DataSet.

Events

PropertyChanged [To be supplied.]

Event Hookup:

Methods

RemoveOnPropertyChanged | Removes an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.
AddOnPropertyChanged | Adds an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.

See Also

ForeignKeyConstraint Class | System.Data Namespace


ForeignKeyConstraint Constructor

Initializes a new instance of the ForeignKeyConstraint class.

Overload List

Initializes a new instance of the ForeignKeyConstraint class with the specified parent and child DataColumn objects.

[Visual Basic] Overloads Public Sub New(DataColumn, DataColumn)
[C#] public ForeignKeyConstraint(DataColumn, DataColumn);
[C++] public: ForeignKeyConstraint(DataColumn*, DataColumn*);
[JScript] public function ForeignKeyConstraint(DataColumn, DataColumn);

Initializes a new instance of the ForeignKeyConstraint class with the specified name, parent and child DataColumn objects.

[Visual Basic] Overloads Public Sub New(String, DataColumn, DataColumn)
[C#] public ForeignKeyConstraint(String, DataColumn, DataColumn);
[C++] public: ForeignKeyConstraint(String*, DataColumn, DataColumn);
[JScript] public function ForeignKeyConstraint(String, DataColumn, DataColumn);

Initializes a new instance of the ForeignKeyConstraint class with the specified arrays of parent and child DataColumn objects.

[Visual Basic] Overloads Public Sub New(DataColumn(), DataColumn())
[C#] public ForeignKeyConstraint(DataColumn[], DataColumn[]);
[C++] public: ForeignKeyConstraint(DataColumn*[], DataColumn*[]);
[JScript] public function ForeignKeyConstraint(DataColumn[], DataColumn[]);

Initializes a new instance of the ForeignKeyConstraint class with the specified name, and arrays of parent and child DataColumn objects.

[Visual Basic] Overloads Public Sub New(String, DataColumn(), DataColumn())
[C#] public ForeignKeyConstraint(String, DataColumn[], DataColumn[]);
[C++] public: ForeignKeyConstraint(String*, DataColumn[], DataColumn[]);
[JScript] public function ForeignKeyConstraint(String, DataColumn[], DataColumn[]);

Example [Visual Basic]

Note This example shows how to use one of the overloaded version of the ForeignKeyConstraint constructor. For other examples that may be available, see the individual overload topics.

[Visual Basic]

' The next line goes into the Declarations section of the module:
' SuppliersProducts is a class derived from DataSet.
Private myDataSet As SuppliersProducts

Private Sub CreateConstraint()
   ' Declare parent column and child column variables.
   Dim pCols(1) As DataColumn
   Dim cCols(1) As DataColumn
   Dim myFKC As ForeignKeyConstraint
   ' Set parent and child column variables.
   pCols(0) = MyDataSet.Tables("OrderDetails").Columns("OrderID")
   pCols(1) = MyDataSet.Tables("OrderDetails").Columns("ProductID")
   cCols(0) = MyDataSet.Tables("Sales").Columns("OrderID")
   cCols(1) = MyDataSet.Tables("Sales").Columns("ProductID")
   myFKC = New ForeignKeyConstraint("ProductSalesOrders", pCols, cCols)
   ' Set various properties of the constraint.
   With myFKC
      .DeleteRule = Rule.SetDefault
      .UpdateRule = Rule.Cascade
      .AcceptRejectRule = AcceptRejectRule.Cascade
   End With
   ' Add the constraint, and set EnforceConstraints to true.
   myDataSet.Tables("OrderDetails").Constraints.Add myFKC
   myDataSet.EnforceConstraints = True
End Sub

See Also

ForeignKeyConstraint Class | ForeignKeyConstraint Members | System.Data Namespace


ForeignKeyConstraint Constructor (DataColumn, DataColumn)

Initializes a new instance of the ForeignKeyConstraint class with the specified parent and child DataColumn objects.

[Visual Basic]
Overloads Public Sub New( _
   ByVal parentColumn As DataColumn, _
   ByVal childColumn As DataColumn _
)
[C#]
public ForeignKeyConstraint(
   DataColumn parentColumn,
   DataColumn childColumn
);
[C++]
public: ForeignKeyConstraint(
   DataColumn* parentColumn,
   DataColumn* childColumn
);
[JScript]
public function ForeignKeyConstraint(
   parentColumn : DataColumn,
   childColumn : DataColumn
);

Parameters

parentColumn
The parent DataColumn in the constraint.
childColumn
The child DataColumn in the constraint.

Exceptions

Exception Type | Condition
ArgumentNullException | One or both of the columns is a null reference (in Visual Basic Nothing).
InvalidConstraintException | The columns have different data types. -Or- The tables don't belong to the same DataSet.

Example [Visual Basic]

The following example creates a new ForeignKeyConstraint, sets various of its properties, and adds it to a DataTable object's ConstraintsCollection.

[Visual Basic]

' The next line goes into the Declarations section of the module:
' SuppliersProducts is a class derived from DataSet.
Private myDataSet As SuppliersProducts

Private Sub CreateConstraint()
   ' Declare parent column and child column variables.
   Dim pCol As DataColumn
   Dim cCol As DataColumn
   Dim myFKC As ForeignKeyConstraint
   ' Set parent and child column variables.
   pCol = MyDataSet.Tables("Suppliers").Columns("SupplierID")
   cCol = MyDataSet.Tables("Products").Columns("SupplieriD")
   myFKC = New ForeignKeyConstraint(pCol, cCol)
   ' Set various properties of the constraint.
   With myFKC
      .RelationName = "SuppierFKConstraint"
      .DeleteRule = Rule.SetNull
      .UpdateRule = Rule.Cascade
      .AcceptRejectRule = AcceptRejectRule.Cascade
   End With
   ' Add the constraint, and set EnforceConstraints to true.
   myDataSet.Tables("Suppliers").Constraints.Add myFKC
   myDataSet.EnforceConstraints = True
End Sub

See Also

ForeignKeyConstraint Class | ForeignKeyConstraint Members | System.Data Namespace | ForeignKeyConstraint Constructor Overload List


ForeignKeyConstraint Constructor (String, DataColumn, DataColumn)

Initializes a new instance of the ForeignKeyConstraint class with the specified name, parent and child DataColumn objects.

[Visual Basic]
Overloads Public Sub New( _
   ByVal constraintName As String, _
   ByVal parentColumn As DataColumn, _
   ByVal childColumn As DataColumn _
)
[C#]
public ForeignKeyConstraint(
   string constraintName,
   DataColumn parentColumn,
   DataColumn childColumn
);
[C++]
public: ForeignKeyConstraint(
   String* constraintName,
   DataColumn* parentColumn,
   DataColumn* childColumn
);
[JScript]
public function ForeignKeyConstraint(
   constraintName : String,
   parentColumn : DataColumn,
   childColumn : DataColumn
);

Parameters

constraintName
[To be supplied.]
parentColumn
The parent DataColumn in the constraint.
childColumn
The child DataColumn in the constraint.

Exceptions

Exception Type | Condition
ArgumentNullException | One or both of the columns is a null reference (in Visual Basic Nothing).
InvalidConstraintException | The columns have different data types. -Or- The tables don't belong to the same DataSet.

Example [Visual Basic]

[Visual Basic]

' The next line goes into the Declarations section of the module:
' SuppliersProducts is a class derived from DataSet.
Private myDataSet As SuppliersProducts

Private Sub CreateConstraint()
   ' Declare parent column and child column variables.
   Dim pCol As DataColumn
   Dim cCol As DataColumn
   Dim myFKC As ForeignKeyConstraint
   ' Set parent and child column variables.
   pCol = MyDataSet.Tables("Suppliers").Columns("SupplierID")
   cCol = MyDataSet.Tables("Products").Columns("SupplieriD")
   myFKC = New ForeignKeyConstraint("SuppierFKConstraint", pCol, cCol)
   ' Set various properties of the constraint.
   With myFKC
      .DeleteRule = Rule.SetNull
      .UpdateRule = Rule.Cascade
      .AcceptRejectRule = AcceptRejectRule.Cascade
   End With
   ' Add the constraint, and set EnforceConstraints to true.
   myDataSet.Tables("Suppliers").Constraints.Add myFKC
   myDataSet.EnforceConstraints = True
End Sub

See Also

ForeignKeyConstraint Class | ForeignKeyConstraint Members | System.Data Namespace | ForeignKeyConstraint Constructor Overload List


ForeignKeyConstraint Constructor (DataColumn[], DataColumn[])

Initializes a new instance of the ForeignKeyConstraint class with the specified arrays of parent and child DataColumn objects.

[Visual Basic]
Overloads Public Sub New( _
   ByVal parentColumns() As DataColumn, _
   ByVal childColumns() As DataColumn _
)
[C#]
public ForeignKeyConstraint(
   DataColumn[] parentColumns,
   DataColumn[] childColumns
);
[C++]
public: ForeignKeyConstraint(
   DataColumn* parentColumns[],
   DataColumn* childColumns[]
);
[JScript]
public function ForeignKeyConstraint(
   parentColumns : DataColumn[],
   childColumns : DataColumn[]
);

Parameters

parentColumns
An array of parent DataColumn in the constraint.
childColumns
An array of child DataColumn in the constraint.

Exceptions

Exception Type | Condition
ArgumentNullException | One or both of the columns is a null reference (in Visual Basic Nothing).
InvalidConstraintException | The columns have different data types. -Or- The tables don't belong to the same DataSet.

Example [Visual Basic]

The following example creates a new ForeignKeyConstraint, sets various of its properties, and adds it to a DataTable object's ConstraintsCollection.

[Visual Basic]

' The next line goes into the Declarations section of the module:
' SuppliersProducts is a class derived from DataSet.
Private myDataSet As SuppliersProducts

Private Sub CreateConstraint()
   ' Declare parent column and child column variables.
   Dim pCols(1) As DataColumn
   Dim cCols(1) As DataColumn
   Dim myFKC As ForeignKeyConstraint
   ' Set parent and child column variables.
   pCols(0) = MyDataSet.Tables("OrderDetails").Columns("OrderID")
   pCols(1) = MyDataSet.Tables("OrderDetails").Columns("ProductID")
   cCols(0) = MyDataSet.Tables("Sales").Columns("OrderID")
   cCols(1) = MyDataSet.Tables("Sales").Columns("ProductID")
   myFKC = New ForeignKeyConstraint(pCols, cCols)
   ' Set various properties of the constraint.
   With myFKC
      .RelationName = "ProductSalesOrders"
      .DeleteRule = Rule.SetDefault
      .UpdateRule = Rule.Cascade
      .AcceptRejectRule = AcceptRejectRule.Cascade
   End With
   ' Add the constraint, and set EnforceConstraints to true.
   myDataSet.Tables("OrderDetails").Constraints.Add myFKC
   myDataSet.EnforceConstraints = True
End Sub

See Also

ForeignKeyConstraint Class | ForeignKeyConstraint Members | System.Data Namespace | ForeignKeyConstraint Constructor Overload List


ForeignKeyConstraint Constructor (String, DataColumn[], DataColumn[])

Initializes a new instance of the ForeignKeyConstraint class with the specified name, and arrays of parent and child DataColumn objects.

[Visual Basic]
Overloads Public Sub New( _
   ByVal constraintName As String, _
   ByVal parentColumns() As DataColumn, _
   ByVal childColumns() As DataColumn _
)
[C#]
public ForeignKeyConstraint(
   string constraintName,
   DataColumn[] parentColumns,
   DataColumn[] childColumns
);
[C++]
public: ForeignKeyConstraint(
   String* constraintName,
   DataColumn* parentColumns[],
   DataColumn* childColumns[]
);
[JScript]
public function ForeignKeyConstraint(
   constraintName : String,
   parentColumns : DataColumn[],
   childColumns : DataColumn[]
);

Parameters

constraintName
The name of the ForeignKeyConstraint. If a null reference (in Visual Basic Nothing) or empty string, a default name will be given when added to the constraints collection.
parentColumns
An array of parent DataColumn in the constraint.
childColumns
An array of child DataColumn in the constraint.

Exceptions

Exception Type | Condition
ArgumentNullException | One or both of the columns is a null reference (Nothing).
InvalidConstraintException | The columns have different data types. -Or- The tables don't belong to the same DataSet.

Example [Visual Basic]

[Visual Basic]

' The next line goes into the Declarations section of the module:
' SuppliersProducts is a class derived from DataSet.
Private myDataSet As SuppliersProducts

Private Sub CreateConstraint()
   ' Declare parent column and child column variables.
   Dim pCols(1) As DataColumn
   Dim cCols(1) As DataColumn
   Dim myFKC As ForeignKeyConstraint
   ' Set parent and child column variables.
   pCols(0) = MyDataSet.Tables("OrderDetails").Columns("OrderID")
   pCols(1) = MyDataSet.Tables("OrderDetails").Columns("ProductID")
   cCols(0) = MyDataSet.Tables("Sales").Columns("OrderID")
   cCols(1) = MyDataSet.Tables("Sales").Columns("ProductID")
   myFKC = New ForeignKeyConstraint("ProductSalesOrders", pCols, cCols)
   ' Set various properties of the constraint.
   With myFKC
      .DeleteRule = Rule.SetDefault
      .UpdateRule = Rule.Cascade
      .AcceptRejectRule = AcceptRejectRule.Cascade
   End With
   ' Add the constraint, and set EnforceConstraints to true.
   myDataSet.Tables("OrderDetails").Constraints.Add myFKC
   myDataSet.EnforceConstraints = True
End Sub

See Also

ForeignKeyConstraint Class | ForeignKeyConstraint Members | System.Data Namespace | ForeignKeyConstraint Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ForeignKeyConstraint Properties

The properties of the ForeignKeyConstraint class are listed below. For a complete list of ForeignKeyConstraint class members, see the ForeignKeyConstraint Members topic.

Public:

AcceptRejectRule | Indicates what kind of action should take place across this constraint when AcceptChanges is invoked.
Columns | Gets the child columns of this constraint.
ConstraintName (inherited from Constraint) | The name of this constraint within the ConstraintsCollection. An ArgumentException is thrown if setting the name to null or empty string and the column belongs to a collection. A DuplicateNameException is thrown if this column belongs to a collection and it already has a column with the same name (case insensitive).
DataSet | Gets the DataSet to which this ForeignKeyConstraint belongs.
DeleteRule | Gets or sets the action that occurs across this constraint on when a row is deleted.
IsPrimaryKey (inherited from Constraint) | Gets a value indicating whether the constraint is on a primary key column.
RelatedColumns | The parent columns of this constraint.
RelatedTable | Gets the parent table of this constraint.
Table | Gets the child table of this constraint.
UpdateRule | Gets or sets the action that occurs across this constraint on when a row is deleted.

Protected:

_DataSet (inherited from Constraint) Gets the DataSet to which this constraint belongs.

See Also

ForeignKeyConstraint Class | System.Data Namespace


ForeignKeyConstraint.AcceptRejectRule

Indicates what kind of action should take place across this constraint when AcceptChanges is invoked.

[Visual Basic]
Overridable Public Property AcceptRejectRule As AcceptRejectRule
[C#]
public AcceptRejectRule AcceptRejectRule {virtual get; virtual
   set;}
[C++]
public: __property virtual AcceptRejectRule get_AcceptRejectRule();
public: __property virtual void set_AcceptRejectRule(AcceptRejectRule);
[JScript]
public function get AcceptRejectRule() : AcceptRejectRule;
public function set AcceptRejectRule(AcceptRejectRule);

Property Value

One of the AcceptRejectRule values. Possible values include None, Cascade, and Default.

Remarks

Changes to a DataRow or DataTable are not final until the Accept method is invoked. At that point, the AcceptRejectRule will determine the course of action on any values that have been changed or deleted.

Example [Visual Basic]

The following example creates a ForeignKeyConstraint, sets its AcceptRejectRule, and adds the constraint to a DataTable object's ConstraintsCollection.

[Visual Basic]

' The next line goes into the Declarations section of the module:
' SuppliersProducts is a class derived from DataSet.
Private myDataSet As SuppliersProducts

Private Sub CreateConstraint()
   ' Declare parent column and child column variables.
   Dim pCol As DataColumn
   Dim cCol As DataColumn
   Dim myFKC As ForeignKeyConstraint
   ' Set parent and child column variables.
   pCol = MyDataSet.Tables("Suppliers).Columns("SupplierID")
   cCol = MyDataSet.Tables("Products").Columns("SupplieriD")
   myFKC = New ForeignKeyConstraint("SuppierFKConstraint", pCol, cCol)
   ' Set null values when a value is deleted.
   myFKC.DeleteRule = Rule.SetNull
   myFKC.UpdateRule = Rule.Cascade
   myFKC.AcceptRejectRule = AcceptRejectRule.Cascade
   ' Add the constraint, and set EnforceConstraints to true.
   myDataSet.Tables("Suppliers").Constraints.Add myFKC
   myDataSet.EnforceConstraints = True
End Sub

See Also

ForeignKeyConstraint Class | ForeignKeyConstraint Members | System.Data Namespace | AcceptRejectRule


ForeignKeyConstraint.Columns

Gets the child columns of this constraint.

[Visual Basic]
Overridable Public ReadOnly Property Columns As DataColumn ()
[C#]
public DataColumn[] Columns {virtual get;}
[C++]
public: __property virtual DataColumn* get_Columns();
[JScript]
public function get Columns() : DataColumn[];

Property Value

An array of DataColumn objects that are the child columns of the constraint.

Example [Visual Basic]

The following example returns an array of DataColumn objects through the Columns property.

[Visual Basic]

Private GetColumns()
   Dim cols() As DataColumn
   Dim dr As DataRelation
   Dim i As Integer
   ' Get the DataRelation from a DataSet.
   For Each dr In DataSet1.Relations
      If dr.GetType.ToString = "System.Data.ForeignKeyConstraint" Then
        cols = dr.RelatedColumns
           For i = 0 To Ubound(cols)
  Debug.Print cols(i).ColumnName
           Next i
      End If
   Next
End Sub

See Also

ForeignKeyConstraint Class | ForeignKeyConstraint Members | System.Data Namespace | Table | DataTable | RelatedTable | RelatedColumns


ForeignKeyConstraint.DataSet

Gets the DataSet to which this ForeignKeyConstraint belongs.

[Visual Basic]
Overridable Public ReadOnly Property DataSet As DataSet
[C#]
public DataSet DataSet {override get;}
[C++]
public: __property virtual DataSet* get_DataSet();
[JScript]
public function get DataSet() : DataSet;

Property Value

The DataSet to which this ForeignKeyConstraint belongs.

See Also

ForeignKeyConstraint Class | ForeignKeyConstraint Members | System.Data Namespace


ForeignKeyConstraint.DeleteRule

Gets or sets the action that occurs across this constraint on when a row is deleted.

[Visual Basic]
Overridable Public Property DeleteRule As Rule
[C#]
public Rule DeleteRule {virtual get; virtual set;}
[C++]
public: __property virtual Rule get_DeleteRule();
public: __property virtual void set_DeleteRule(Rule);
[JScript]
public function get DeleteRule() : Rule;
public function set DeleteRule(Rule);

Property Value

One of the Rule values. The default is Cascade. Possible values include: None, Cascade, SetNull, SetDefault, and Default.

Remarks

When a row is deleted from a parent table, the DeleteRule determines what will happen in the columns of the child table (or tables). If the rule is set to Cascade, child rows will be deleted.

If set to SetNull, a DBnull will be placed in the appropriate columns of the affected rows. Depending on your DBMS, a null value may or may not be permitted in a column. For example, SQLServer allows multiple null values to be found in a primary key column, even if they are not unique. In a DataTable, however, if a DataColumn object's Unique property is set to true, multiple null values are not allowed in primary key columns.

If set to Default, the default value for the column is assigned.

Example [Visual Basic]

The following example creates a ForeignKeyConstraint, sets various of its properties, and adds it to a DataTable object's ConstraintsCollection.

[Visual Basic]

' The next line goes into the Declarations section of the module:
' SuppliersProducts is a class derived from DataSet.
Private myDataSet As SuppliersProducts

Private Sub CreateConstraint()
   ' Declare parent column and child column variables.
   Dim pCol As DataColumn
   Dim cCol As DataColumn
   Dim myFKC As ForeignKeyConstraint
   ' Set parent and child column variables.
   pCol = MyDataSet.Tables("Suppliers).Columns("SupplierID")
   cCol = MyDataSet.Tables("Products").Columns("SupplieriD")
   myFKC = New ForeignKeyConstraint("SuppierFKConstraint", pCol, cCol)
   ' Set null values when a value is deleted.
   myFKC.DeleteRule = Rule.SetNull
   myFKC.UpdateRule = Rule.Cascade
   myFKC.AcceptRejectRule = AcceptRejectRule.Cascade
   ' Add the constraint, and set EnforceConstraints to true.
   myDataSet.Tables("Suppliers").Constraints.Add myFKC
   myDataSet.EnforceConstraints = True
End Sub

See Also

ForeignKeyConstraint Class | ForeignKeyConstraint Members | System.Data Namespace


ForeignKeyConstraint.RelatedColumns

The parent columns of this constraint.

[Visual Basic]
Overridable Public ReadOnly Property RelatedColumns As DataColumn ()
[C#]
public DataColumn[] RelatedColumns {virtual get;}
[C++]
public: __property virtual DataColumn* get_RelatedColumns();
[JScript]
public function get RelatedColumns() : DataColumn[];

Property Value

An array of DataColumn objects that are the parent columns of the constraint.

Example [Visual Basic]

The following example returns an array of DataColumn objects through the RelatedColumns property.

[Visual Basic]

Private GetRelatedColumns()
   Dim relCols() As DataColumn
   Dim dr As DataRelation
   Dim i As Integer
   ' Get the DataRelation from a DataSet.
   For Each dr In DataSet1.Relations
      If dr.GetType.ToString = "System.Data.ForeignKeyConstraint" Then
        relCols = dr.RelatedColumns
           For i = 0 To Ubound(relCols)
  Debug.Print relCols(i).ColumnName
           Next i
      End If
   Next
End Sub

See Also

ForeignKeyConstraint Class | ForeignKeyConstraint Members | System.Data Namespace | Columns | DataColumn | DataTable | Table | RelatedTable


ForeignKeyConstraint.RelatedTable

Gets the parent table of this constraint.

[Visual Basic]
Overridable Public ReadOnly Property RelatedTable As DataTable
[C#]
public DataTable RelatedTable {virtual get;}
[C++]
public: __property virtual DataTable* get_RelatedTable();
[JScript]
public function get RelatedTable() : DataTable;

Property Value

The parent DataTable of this constraint.

Example [Visual Basic]

The following example gets the related DataTable for each ForeignKeyConstraint in a DataSet.

[Visual Basic]

Private GetRelatedTables()
   Dim dr As DataRelation
   Dim t As DataTable

   ' Get the DataRelation from a DataSet.
   For Each dr In DataSet1.Relations
      If dr.GetType.ToString = "System.Data.ForeignKeyConstraint" Then
        t = dr.RelatedTable
        Debug.Print t.TableName, t.Columns.Count, t.Rows.Count
     End If
     Next
End

See Also

ForeignKeyConstraint Class | ForeignKeyConstraint Members | System.Data Namespace | Columns | DataTable | Table | RelatedColumns


ForeignKeyConstraint.Table

Gets the child table of this constraint.

[Visual Basic]
Overridable Public ReadOnly Property Table As DataTable
[C#]
public DataTable Table {override get;}
[C++]
public: __property virtual DataTable* get_Table();
[JScript]
public function get Table() : DataTable;

Property Value

A DataTable that is the child table in the constraint.

Example [Visual Basic]

[Visual Basic]

Private GetRelatedTables()
   Dim dr As DataRelation
   Dim t As DataTable

   ' Get the DataRelation from a DataSet.
   For Each dr In DataSet1.Relations
      If dr.GetType.ToString = "System.Data.ForeignKeyConstraint" Then
        t = dr.Table
        Debug.Print t.TableName, t.Columns.Count, t.Rows.Count
     End If
     Next
End

See Also

ForeignKeyConstraint Class | ForeignKeyConstraint Members | System.Data Namespace | Columns | DataTable | RelatedTable | RelatedColumns


ForeignKeyConstraint.UpdateRule

Gets or sets the action that occurs across this constraint on when a row is deleted.

[Visual Basic]
Overridable Public Property UpdateRule As Rule
[C#]
public Rule UpdateRule {virtual get; virtual set;}
[C++]
public: __property virtual Rule get_UpdateRule();
public: __property virtual void set_UpdateRule(Rule);
[JScript]
public function get UpdateRule() : Rule;
public function set UpdateRule(Rule);

Property Value

One of the Rule values. The default is Cascade.

Example [Visual Basic]

The following example creates a ForeignKeyConstraint, sets various of its properties, and adds it to a DataTable object's ConstraintsCollection.

[Visual Basic]

' The next line goes into the Declarations section of the module:
' SuppliersProducts is a class derived from DataSet.
Private myDataSet As SuppliersProducts

Private Sub CreateConstraint()
   ' Declare parent column and child column variables.
   Dim pCol As DataColumn
   Dim cCol As DataColumn
   Dim myFKC As ForeignKeyConstraint
   ' Set parent and child column variables.
   pCol = MyDataSet.Tables("Suppliers).Columns("SupplierID")
   cCol = MyDataSet.Tables("Products").Columns("SupplieriD")
   myFKC = New ForeignKeyConstraint("SuppierFKConstraint", pCol, cCol)
   ' Set null values when a value is deleted.
   myFKC.DeleteRule = Rule.SetNull
   myFKC.UpdateRule = Rule.Cascade
   myFKC.AcceptRejectRule = AcceptRejectRule.Cascade
   ' Add the constraint, and set EnforceConstraints to true.
   myDataSet.Tables("Suppliers").Constraints.Add myFKC
   myDataSet.EnforceConstraints = True
End Sub

See Also

ForeignKeyConstraint Class | ForeignKeyConstraint Members | System.Data Namespace | AcceptRejectRule | Rule


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ForeignKeyConstraint Methods

The methods of the ForeignKeyConstraint class are listed below. For a complete list of ForeignKeyConstraint class members, see the ForeignKeyConstraint Members topic.

Public:

Equals | Gets a value indicating whether the current ForeignKeyConstraint is identical to the specified object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

CheckStateForProperty (inherited from Constraint) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanged | Inheriting classes should override this method to handle this event. Call base.OnPropertyChanged to send this event to any registered event listeners.
RaisePropertyChanged | Raises the property changed event. This creates the needed event data and then calls OnPropertyChanged.
SetDataSet (inherited from Constraint) | Sets the constraint's DataSet.

Event Hookup:

RemoveOnPropertyChanged | Removes an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.
AddOnPropertyChanged | Adds an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.

See Also

ForeignKeyConstraint Class | System.Data Namespace


ForeignKeyConstraint.AddOnPropertyChanged

Adds an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.

[Visual Basic]
Overridable Protected Sub AddOnPropertyChanged( _
   ByVal handler As PropertyChangedEventHandler _
)
[C#]
protected virtual void AddOnPropertyChanged(
   PropertyChangedEventHandler handler
);
[C++]
protected: virtual void AddOnPropertyChanged(
   PropertyChangedEventHandler* handler
);
[JScript]
protected function AddOnPropertyChanged(
   handler : PropertyChangedEventHandler
);

Parameters

handler
handler to add for this event

See Also

ForeignKeyConstraint Class | ForeignKeyConstraint Members | System.Data Namespace | RemoveOnPropertyChanged


ForeignKeyConstraint.Equals

Gets a value indicating whether the current ForeignKeyConstraint is identical to the specified object.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal key As Object _
) As Boolean
[C#]
public override bool Equals(
   object key
);
[C++]
public: override bool Equals(
   Object* key
);
[JScript]
public override function Equals(
   key : Object
) : Boolean;

Parameters

key
The object to which this ForeignKeyConstraint is compared. Two ForeignKeyConstraint are equal if they constrain the same columns.

Return Value

true, if the objects are identical; otherwise, false.

See Also

ForeignKeyConstraint Class | ForeignKeyConstraint Members | System.Data Namespace


ForeignKeyConstraint.OnPropertyChanged

Inheriting classes should override this method to handle this event. Call base.OnPropertyChanged to send this event to any registered event listeners.

[Visual Basic]
Overridable Protected Sub OnPropertyChanged( _
   ByVal pcevent As PropertyChangedEventArgs _
)
[C#]
protected virtual void OnPropertyChanged(
   PropertyChangedEventArgs pcevent
);
[C++]
protected: virtual void OnPropertyChanged(
   PropertyChangedEventArgs* pcevent
);
[JScript]
protected function OnPropertyChanged(
   pcevent : PropertyChangedEventArgs
);

Parameters

pcevent
event

See Also

ForeignKeyConstraint Class | ForeignKeyConstraint Members | System.Data Namespace | AddOnPropertyChanged | RemoveOnPropertyChanged


ForeignKeyConstraint.RaisePropertyChanged

Raises the property changed event. This creates the needed event data and then calls OnPropertyChanged.

[Visual Basic]
Protected Sub RaisePropertyChanged( _
   ByVal name As String _
)
[C#]
protected void RaisePropertyChanged(
   string name
);
[C++]
protected: void RaisePropertyChanged(
   String* name
);
[JScript]
protected function RaisePropertyChanged(
   name : String
);

Parameters

name
Name of the changed property.

See Also

ForeignKeyConstraint Class | ForeignKeyConstraint Members | System.Data Namespace


ForeignKeyConstraint.RemoveOnPropertyChanged

Removes an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.

[Visual Basic]
Public Sub RemoveOnPropertyChanged( _
   ByVal handler As PropertyChangedEventHandler _
)
[C#]
public void RemoveOnPropertyChanged(
   PropertyChangedEventHandler handler
);
[C++]
public: void RemoveOnPropertyChanged(
   PropertyChangedEventHandler* handler
);
[JScript]
public function RemoveOnPropertyChanged(
   handler : PropertyChangedEventHandler
);

Parameters

handler
handler to remove for this event

See Also

ForeignKeyConstraint Class | ForeignKeyConstraint Members | System.Data Namespace | AddOnPropertyChanged


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ForeignKeyConstraint Events

The events of the ForeignKeyConstraint class are listed below. For a complete list of ForeignKeyConstraint class members, see the ForeignKeyConstraint Members topic.

Protected:

PropertyChanged [To be supplied.]

See Also

ForeignKeyConstraint Class | System.Data Namespace


ForeignKeyConstraint PropertyChanged Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the PropertyChanged event.

[Visual Basic]
Private Sub ForeignKeyConstraintName_PropertyChanged( _
   ByVal sender As Object, _
   ByVal e As PropertyChangedEventArgs _
)
[C#]
private void ForeignKeyConstraintName_PropertyChanged(
   object sender,
   PropertyChangedEventArgs e
);
[C++]
private: void ForeignKeyConstraintName_PropertyChanged(
   Object* sender,
   PropertyChangedEventArgs* e
);
[JScript]
private ForeignKeyConstraintName_PropertyChanged(
   sender : Object,
   e : PropertyChangedEventArgs
);

Parameters

sender
The source of the event.
e
A PropertyChangedEventArgs that contains the event data. The following PropertyChangedEventArgs properties provide information specific to this event.
Property Description
PropertyName
Gets the name of the property that changed.

See Also

ForeignKeyConstraint Class | ForeignKeyConstraint MembersTopic | System.Data Namespace


ICollectionInfo Interface

[To be supplied.]

ICollectionInfo

[Visual Basic]
Public Interface ICollectionInfo
[C#]
public interface ICollectionInfo
[C++]
public __gc __interface ICollectionInfo

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

ICollectionInfo Members | System.Data Namespace


ICollectionInfo Members

Methods

GetFieldAccessors | [To be supplied.]
GetFieldCaption | [To be supplied.]
GetFieldType | [To be supplied.]

See Also

ICollectionInfo Interface | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICollectionInfo Methods

The methods of the ICollectionInfo interface are listed below. For a complete list of ICollectionInfo interface members, see the ICollectionInfo Members topic.

GetFieldAccessors | [To be supplied.]
GetFieldCaption | [To be supplied.]
GetFieldType | [To be supplied.]

See Also

ICollectionInfo Interface | System.Data Namespace


ICollectionInfo.GetFieldAccessors

[To be supplied.]

[Visual Basic]
Function GetFieldAccessors( _
   ByVal elementName As String _
) As String ()
[C#]
string[] GetFieldAccessors(
   string elementName
);
[C++]
String* GetFieldAccessors(
   String* elementName
) [] = 0;
[JScript]
function GetFieldAccessors(
   elementName : String
) : String[];

Parameters

elementName
[To be supplied.]

See Also

ICollectionInfo Interface | ICollectionInfo Members | System.Data Namespace


ICollectionInfo.GetFieldCaption

[To be supplied.]

[Visual Basic]
Function GetFieldCaption( _
   ByVal elementName As String _
) As String
[C#]
string GetFieldCaption(
   string elementName
);
[C++]
String* GetFieldCaption(
   String* elementName
) = 0;
[JScript]
function GetFieldCaption(
   elementName : String
) : String;

Parameters

elementName
[To be supplied.]

See Also

ICollectionInfo Interface | ICollectionInfo Members | System.Data Namespace


ICollectionInfo.GetFieldType

[To be supplied.]

[Visual Basic]
Function GetFieldType( _
   ByVal elementName As String _
) As Type
[C#]
Type GetFieldType(
   string elementName
);
[C++]
Type* GetFieldType(
   String* elementName
) = 0;
[JScript]
function GetFieldType(
   elementName : String
) : Type;

Parameters

elementName
[To be supplied.]

See Also

ICollectionInfo Interface | ICollectionInfo Members | System.Data Namespace


IColumnMapping Interface

[To be supplied.]

IColumnMapping

[Visual Basic]
Public Interface IColumnMapping
[C#]
public interface IColumnMapping
[C++]
public __gc __interface IColumnMapping

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IColumnMapping

Class | Description
DataColumnMapping | generic column mapping

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

IColumnMapping Members | System.Data Namespace


IColumnMapping Members

Properties

DataSetColumn | [To be supplied.]
Parent | [To be supplied.]
SourceColumn | [To be supplied.]

See Also

IColumnMapping Interface | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IColumnMapping Properties

The properties of the IColumnMapping interface are listed below. For a complete list of IColumnMapping interface members, see the IColumnMapping Members topic.

DataSetColumn | [To be supplied.]
Parent | [To be supplied.]
SourceColumn | [To be supplied.]

See Also

IColumnMapping Interface | System.Data Namespace


IColumnMapping.DataSetColumn

[To be supplied.]

[Visual Basic]
Property DataSetColumn As String
[C#]
string DataSetColumn {get; set;}
[C++]
String* get_DataSetColumn() = 0;void set_DataSetColumn(String*) = 0;
[JScript]
abstract function get DataSetColumn() : String;
public abstract function set DataSetColumn(String);

See Also

IColumnMapping Interface | IColumnMapping Members | System.Data Namespace


IColumnMapping.Parent

[To be supplied.]

[Visual Basic]
ReadOnly Property Parent As Object
[C#]
object Parent {get;}
[C++]
Object* get_Parent() = 0;
[JScript]
abstract function get Parent() : Object;

See Also

IColumnMapping Interface | IColumnMapping Members | System.Data Namespace


IColumnMapping.SourceColumn

[To be supplied.]

[Visual Basic]
Property SourceColumn As String
[C#]
string SourceColumn {get; set;}
[C++]
String* get_SourceColumn() = 0;void set_SourceColumn(String*) = 0;
[JScript]
abstract function get SourceColumn() : String;
public abstract function set SourceColumn(String);

See Also

IColumnMapping Interface | IColumnMapping Members | System.Data Namespace


IColumnMappings Interface

[To be supplied.]

[Visual Basic]
Public Interface IColumnMappings
   Implements IList, ICollection, IEnumerable
[C#]
public interface IColumnMappings : IList, ICollection, IEnumerable
[C++]
public __gc __interface IColumnMappings : public IList,
   ICollection, IEnumerable

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IColumnMappings

Class | Description
DataColumnMappings | column mapping collection

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

IColumnMappings Members | System.Data Namespace


IColumnMappings Members

Properties

All | [To be supplied.]
Item | [To be supplied.] In C#, this member is the indexer for the IColumnMappings class.
Parent | [To be supplied.]

Methods

Add | [To be supplied.]
Contains | [To be supplied.]
GetByDataSetColumn | [To be supplied.]
IndexOf | [To be supplied.]
RemoveAt | [To be supplied.]

See Also

IColumnMappings Interface | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IColumnMappings Properties

The properties of the IColumnMappings interface are listed below. For a complete list of IColumnMappings interface members, see the IColumnMappings Members topic.

All | [To be supplied.]
Item | [To be supplied.] In C#, this member is the indexer for the IColumnMappings class.
Parent | [To be supplied.]

See Also

IColumnMappings Interface | System.Data Namespace


IColumnMappings.All

[To be supplied.]

[Visual Basic]
Property All As IColumnMapping ()
[C#]
IColumnMapping[] All {get; set;}
[C++]
IColumnMapping* get_All() = 0;void set_All(IColumnMapping*[]) = 0;
[JScript]
abstract function get All() : IColumnMapping[];
public abstract function set All(IColumnMapping[]);

See Also

IColumnMappings Interface | IColumnMappings Members | System.Data Namespace


IColumnMappings.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the IColumnMappings class.

[Visual Basic]
Default Property Item( _
   ByVal index As String _
) As Object
[C#]
object this[
   string index
] {get; set;}
[C++]
Object* get_Item(
   String* index
) = 0;void set_Item(
   String* index,
   Object*
) = 0;
[JScript]
abstract returnValue = IColumnMappingsObject.Item(index);
IColumnMappingsObject.Item(index) = returnValue;
-or-
abstract returnValue = IColumnMappingsObject(index);
IColumnMappingsObject(index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
[To be supplied.]

Parameters [Visual Basic, C#, C++]

index
[To be supplied.]

See Also

IColumnMappings Interface | IColumnMappings Members | System.Data Namespace


IColumnMappings.Parent

[To be supplied.]

[Visual Basic]
ReadOnly Property Parent As Object
[C#]
object Parent {get;}
[C++]
Object* get_Parent() = 0;
[JScript]
abstract function get Parent() : Object;

See Also

IColumnMappings Interface | IColumnMappings Members | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IColumnMappings Methods

The methods of the IColumnMappings interface are listed below. For a complete list of IColumnMappings interface members, see the IColumnMappings Members topic.

Add | [To be supplied.]
Contains | [To be supplied.]
GetByDataSetColumn | [To be supplied.]
IndexOf | [To be supplied.]
RemoveAt | [To be supplied.]

See Also

IColumnMappings Interface | System.Data Namespace


IColumnMappings.Add

[To be supplied.]

[Visual Basic]
Function Add( _
   ByVal sourceColumnName As String, _
   ByVal dataSetColumnName As String _
) As IColumnMapping
[C#]
IColumnMapping Add(
   string sourceColumnName,
   string dataSetColumnName
);
[C++]
IColumnMapping* Add(
   String* sourceColumnName,
   String* dataSetColumnName
) = 0;
[JScript]
function Add(
   sourceColumnName : String,
   dataSetColumnName : String
) : IColumnMapping;

Parameters

sourceColumnName
Case-Sensitive
dataSetColumnName
Case-Insensitive

See Also

IColumnMappings Interface | IColumnMappings Members | System.Data Namespace


IColumnMappings.Contains

[To be supplied.]

[Visual Basic]
Function Contains( _
   ByVal sourceColumnName As String _
) As Boolean
[C#]
bool Contains(
   string sourceColumnName
);
[C++]
bool Contains(
   String* sourceColumnName
) = 0;
[JScript]
function Contains(
   sourceColumnName : String
) : Boolean;

Parameters

sourceColumnName
Case-Sensitive

See Also

IColumnMappings Interface | IColumnMappings Members | System.Data Namespace


IColumnMappings.GetByDataSetColumn

[To be supplied.]

[Visual Basic]
Function GetByDataSetColumn( _
   ByVal dataSetColumnName As String _
) As IColumnMapping
[C#]
IColumnMapping GetByDataSetColumn(
   string dataSetColumnName
);
[C++]
IColumnMapping* GetByDataSetColumn(
   String* dataSetColumnName
) = 0;
[JScript]
function GetByDataSetColumn(
   dataSetColumnName : String
) : IColumnMapping;

Parameters

dataSetColumnName
Case-Insensitive

See Also

IColumnMappings Interface | IColumnMappings Members | System.Data Namespace


IColumnMappings.IndexOf

[To be supplied.]

[Visual Basic]
Function IndexOf( _
   ByVal sourceColumnName As String _
) As Integer
[C#]
int IndexOf(
   string sourceColumnName
);
[C++]
int IndexOf(
   String* sourceColumnName
) = 0;
[JScript]
function IndexOf(
   sourceColumnName : String
) : int;

Parameters

sourceColumnName
Case-Sensitive

See Also

IColumnMappings Interface | IColumnMappings Members | System.Data Namespace


IColumnMappings.RemoveAt

[To be supplied.]

[Visual Basic]
Sub RemoveAt( _
   ByVal sourceColumnName As String _
)
[C#]
void RemoveAt(
   string sourceColumnName
);
[C++]
void RemoveAt(
   String* sourceColumnName
) = 0;
[JScript]
function RemoveAt(
   sourceColumnName : String
);

Parameters

sourceColumnName
Case-Sensitive

See Also

IColumnMappings Interface | IColumnMappings Members | System.Data Namespace


ICurrencyList Interface

[To be supplied.]

[Visual Basic]
Public Interface ICurrencyList
   Implements IDataList, ICollection, IEnumerable
[C#]
public interface ICurrencyList : IDataList, ICollection,
   IEnumerable
[C++]
public __gc __interface ICurrencyList : public IDataList,
   ICollection, IEnumerable

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

ICurrencyList Members | System.Data Namespace


ICurrencyList Members

Properties

Current | [To be supplied.]
Position | [To be supplied.]

Events

PositionChanged [To be supplied.]

Event Hookup:

Methods

AddOnPositionChanged | [To be supplied.]
RemoveOnPositionChanged | [To be supplied.]

See Also

ICurrencyList Interface | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICurrencyList Properties

The properties of the ICurrencyList interface are listed below. For a complete list of ICurrencyList interface members, see the ICurrencyList Members topic.

Current | [To be supplied.]
Position | [To be supplied.]

See Also

ICurrencyList Interface | System.Data Namespace


ICurrencyList.Current

[To be supplied.]

[Visual Basic]
ReadOnly Property Current As Object
[C#]
object Current {get;}
[C++]
Object* get_Current() = 0;
[JScript]
abstract function get Current() : Object;

See Also

ICurrencyList Interface | ICurrencyList Members | System.Data Namespace


ICurrencyList.Position

[To be supplied.]

[Visual Basic]
Property Position As Integer
[C#]
int Position {get; set;}
[C++]
int get_Position() = 0;void set_Position(int) = 0;
[JScript]
abstract function get Position() : int;
public abstract function set Position(int);

See Also

ICurrencyList Interface | ICurrencyList Members | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICurrencyList Methods

The methods of the ICurrencyList interface are listed below. For a complete list of ICurrencyList interface members, see the ICurrencyList Members topic.

Event Hookup:

AddOnPositionChanged | [To be supplied.]
RemoveOnPositionChanged | [To be supplied.]

See Also

ICurrencyList Interface | System.Data Namespace


ICurrencyList.AddOnPositionChanged

[To be supplied.]

[Visual Basic]
Sub AddOnPositionChanged( _
   ByVal handler As EventHandler _
)
[C#]
void AddOnPositionChanged(
   EventHandler handler
);
[C++]
void AddOnPositionChanged(
   EventHandler* handler
) = 0;
[JScript]
function AddOnPositionChanged(
   handler : EventHandler
);

Parameters

handler
[To be supplied.]

See Also

ICurrencyList Interface | ICurrencyList Members | System.Data Namespace


ICurrencyList.RemoveOnPositionChanged

[To be supplied.]

[Visual Basic]
Sub RemoveOnPositionChanged( _
   ByVal handler As EventHandler _
)
[C#]
void RemoveOnPositionChanged(
   EventHandler handler
);
[C++]
void RemoveOnPositionChanged(
   EventHandler* handler
) = 0;
[JScript]
function RemoveOnPositionChanged(
   handler : EventHandler
);

Parameters

handler
[To be supplied.]

See Also

ICurrencyList Interface | ICurrencyList Members | System.Data Namespace


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICurrencyList Events

The events of the ICurrencyList interface are listed below. For a complete list of ICurrencyList interface members, see the ICurrencyList Members topic.

PositionChanged [To be supplied.]

See Also

ICurrencyList Interface | System.Data Namespace


ICurrencyList PositionChanged Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the PositionChanged event.

[Visual Basic]
Private Sub ICurrencyListName_PositionChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
private void ICurrencyListName_PositionChanged(
   object sender,
   EventArgs e
);
[C++]
private: void ICurrencyListName_PositionChanged(
   Object* sender,
   EventArgs* e
);
[JScript]
private ICurrencyListName_PositionChanged(
   sender : Object,
   e : EventArgs
);

Parameters

sender
The source of the event.
e
An EventArgs that contains the event data. The following EventArgs properties provide information specific to this event.
Property Description
ExtendedInfo
Holds a reference to an object that manages the event's state.

See Also

ICurrencyList Interface | ICurrencyList MembersTopic | System.Data Namespace


IDataBuffer Interface

[To be supplied.]

IDataBuffer

[Visual Basic]
Public Interface IDataBuffer
[C#]
public interface IDataBuffer
[C++]
public __gc __interface IDataBuffer

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IDataBuffer

Class | Description
DocumentEditor | [To be supplied.]
XmlWriter | [To be supplied.]

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

IDataBuffer Members | System.Data Namespace


IDataBuffer Members

Properties

DataTypeName | [To be supplied.]
DataTypeNamespace | [To be supplied.]
Empty | [To be supplied.]
FieldCount | [To be supplied.]
HasValue | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the IDataBuffer class.
Name | [To be supplied.]
Namespace | [To be supplied.]
NameTable | [To be supplied.]
NodeType | [To be supplied.]
Prefix | [To be supplied.]

Methods

Clear | [To be supplied.]
GetBoolean | [To be supplied.]
GetByte | [To be supplied.]
GetBytes | [To be supplied.]
GetChar | [To be supplied.]
GetChars | [To be supplied.]
GetCurrency | [To be supplied.]
GetData | [To be supplied.]
GetDataTypeName | [To be supplied.]
GetDataTypeNamespace | [To be supplied.]
GetDateTime | [To be supplied.]
GetDecimal | [To be supplied.]
GetDouble | [To be supplied.]
GetFieldType | [To be supplied.]
GetFloat | [To be supplied.]
GetInt16 | [To be supplied.]
GetInt32 | [To be supplied.]
GetInt64 | [To be supplied.]
GetName | [To be supplied.]
GetNamespace | [To be supplied.]
GetOrdinal | Overloaded. [To be supplied.]
GetPrefix | [To be supplied.]
GetRaw | [To be supplied.]
GetStream | [To be supplied.]
GetString | [To be supplied.]
GetTimeSpan | [To be supplied.]
GetValue | [To be supplied.]
GetValues | [To be supplied.]
IsNull | [To be supplied.]
SetBoolean | [To be supplied.]
SetByte | [To be supplied.]
SetBytes | [To be supplied.]
SetChar | [To be supplied.]
SetChars | [To be supplied.]
SetCurrency | [To be supplied.]
SetData | [To be supplied.]
SetDateTime | [To be supplied.]
SetDecimal | [To be supplied.]
SetDouble | [To be supplied.]
SetFloat | [To be supplied.]
SetInt16 | [To be supplied.]
SetInt32 | [To be supplied.]
SetInt64 | [To be supplied.]
SetName | [To be supplied.]
SetNamespace | [To be supplied.]
SetNull | [To be supplied.]
SetPrefix | [To be supplied.]
SetRaw | [To be supplied.]
SetStream | [To be supplied.]
SetString | [To be supplied.]
SetTimeSpan | [To be supplied.]
SetValue | [To be supplied.]
SetValues | [To be supplied.]

See Also

IDataBuffer Interface | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDataBuffer Properties

The properties of the IDataBuffer interface are listed below. For a complete list of IDataBuffer interface members, see the IDataBuffer Members topic.

DataTypeName | [To be supplied.]
DataTypeNamespace | [To be supplied.]
Empty | [To be supplied.]
FieldCount | [To be supplied.]
HasValue | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the IDataBuffer class.
Name | [To be supplied.]
Namespace | [To be supplied.]
NameTable | [To be supplied.]
NodeType | [To be supplied.]
Prefix | [To be supplied.]

See Also

IDataBuffer Interface | System.Data Namespace


IDataBuffer.DataTypeName

[To be supplied.]

[Visual Basic]
ReadOnly Property DataTypeName As String
[C#]
string DataTypeName {get;}
[C++]
String* get_DataTypeName() = 0;
[JScript]
abstract function get DataTypeName() : String;

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.DataTypeNamespace

[To be supplied.]

[Visual Basic]
ReadOnly Property DataTypeNamespace As String
[C#]
string DataTypeNamespace {get;}
[C++]
String* get_DataTypeNamespace() = 0;
[JScript]
abstract function get DataTypeNamespace() : String;

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.Empty

[To be supplied.]

[Visual Basic]
Property Empty As Boolean
[C#]
bool Empty {get; set;}
[C++]
bool get_Empty() = 0;void set_Empty(bool) = 0;
[JScript]
abstract function get Empty() : Boolean;
public abstract function set Empty(Boolean);

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.FieldCount

[To be supplied.]

[Visual Basic]
ReadOnly Property FieldCount As Integer
[C#]
int FieldCount {get;}
[C++]
int get_FieldCount() = 0;
[JScript]
abstract function get FieldCount() : int;

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.HasValue

[To be supplied.]

[Visual Basic]
ReadOnly Property HasValue As Boolean
[C#]
bool HasValue {get;}
[C++]
bool get_HasValue() = 0;
[JScript]
abstract function get HasValue() : Boolean;

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the IDataBuffer class.

Overload List

[To be supplied.]

[Visual Basic] Overloads Default Property Item(String) As Object
[C#] object this[String] {get; set;}
[C++] Object* get_Item(String*) = 0;
void set_Item(String*, Object*) = 0;
[JScript] IDataBuffer.Item (String)

[To be supplied.]

[Visual Basic] Overloads Default Property Item(Integer) As Object
[C#] object this[int] {get; set;}
[C++] Object* get_Item(int) = 0;
void set_Item(int, Object*) = 0;
[JScript] IDataBuffer.Item (int)

[To be supplied.]

[Visual Basic] Overloads Default Property Item(String, String) As Object
[C#] object this[String, String] {get; set;}
[C++] Object* get_Item(String*, String*) = 0;
void set_Item(String*, String*, Object*) = 0;
[JScript] IDataBuffer.Item (String, String)

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.Item (String)

[To be supplied.]

[C#] In C#, this member is the indexer for the IDataBuffer class.

[Visual Basic]
Overloads Default Property Item( _
   ByVal name As String _
) As Object
[C#]
object this[
   string name
] {get; set;}
[C++]
Object* get_Item(
   String* name
) = 0;void set_Item(
   String* name,
   Object*
) = 0;
[JScript]
abstract returnValue = IDataBufferObject.Item(name);
IDataBufferObject.Item(name) = returnValue;
-or-
abstract returnValue = IDataBufferObject(name);
IDataBufferObject(name) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
[To be supplied.]

Parameters [Visual Basic, C#, C++]

name
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace | IDataBuffer.Item Overload List


IDataBuffer.Item (Int32)

[To be supplied.]

[C#] In C#, this member is the indexer for the IDataBuffer class.

[Visual Basic]
Overloads Default Property Item( _
   ByVal i As Integer _
) As Object
[C#]
object this[
   int i
] {get; set;}
[C++]
Object* get_Item(
   int i
) = 0;void set_Item(
   int i,
   Object*
) = 0;
[JScript]
abstract returnValue = IDataBufferObject.Item(i);
IDataBufferObject.Item(i) = returnValue;
-or-
abstract returnValue = IDataBufferObject(i);
IDataBufferObject(i) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

i
[To be supplied.]

Parameters [Visual Basic, C#, C++]

i
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace | IDataBuffer.Item Overload List


IDataBuffer.Item (String, String)

[To be supplied.]

[C#] In C#, this member is the indexer for the IDataBuffer class.

[Visual Basic]
Overloads Default Property Item( _
   ByVal name As String, _
   ByVal namespaceURI As String _
) As Object
[C#]
object this[
   string name,
   string namespaceURI
] {get; set;}
[C++]
Object* get_Item(
   String* name,
   String* namespaceURI
) = 0;void set_Item(
   String* name,
   String* namespaceURI,
   Object*
) = 0;
[JScript]
abstract returnValue = IDataBufferObject.Item(name, namespaceURI);
IDataBufferObject.Item(name, namespaceURI) = returnValue;
-or-
abstract returnValue = IDataBufferObject(name, namespaceURI);
IDataBufferObject(name, namespaceURI) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
[To be supplied.]
namespaceURI
[To be supplied.]

Parameters [Visual Basic, C#, C++]

name
[To be supplied.]
namespaceURI
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace | IDataBuffer.Item Overload List


IDataBuffer.Name

[To be supplied.]

[Visual Basic]
Property Name As String
[C#]
string Name {get; set;}
[C++]
String* get_Name() = 0;void set_Name(String*) = 0;
[JScript]
abstract function get Name() : String;
public abstract function set Name(String);

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.Namespace

[To be supplied.]

[Visual Basic]
Property Namespace As String
[C#]
string Namespace {get; set;}
[C++]
String* get_Namespace() = 0;void set_Namespace(String*) = 0;
[JScript]
abstract function get Namespace() : String;
public abstract function set Namespace(String);

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.NameTable

[To be supplied.]

[Visual Basic]
ReadOnly Property NameTable As INameTable
[C#]
INameTable NameTable {get;}
[C++]
INameTable* get_NameTable() = 0;
[JScript]
abstract function get NameTable() : INameTable;

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.NodeType

[To be supplied.]

[Visual Basic]
Property NodeType As XmlNodeType
[C#]
XmlNodeType NodeType {get; set;}
[C++]
XmlNodeType get_NodeType() = 0;void set_NodeType(XmlNodeType) = 0;
[JScript]
abstract function get NodeType() : XmlNodeType;
public abstract function set NodeType(XmlNodeType);

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.Prefix

[To be supplied.]

[Visual Basic]
Property Prefix As String
[C#]
string Prefix {get; set;}
[C++]
String* get_Prefix() = 0;void set_Prefix(String*) = 0;
[JScript]
abstract function get Prefix() : String;
public abstract function set Prefix(String);

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDataBuffer Methods

The methods of the IDataBuffer interface are listed below. For a complete list of IDataBuffer interface members, see the IDataBuffer Members topic.

Clear | [To be supplied.]
GetBoolean | [To be supplied.]
GetByte | [To be supplied.]
GetBytes | [To be supplied.]
GetChar | [To be supplied.]
GetChars | [To be supplied.]
GetCurrency | [To be supplied.]
GetData | [To be supplied.]
GetDataTypeName | [To be supplied.]
GetDataTypeNamespace | [To be supplied.]
GetDateTime | [To be supplied.]
GetDecimal | [To be supplied.]
GetDouble | [To be supplied.]
GetFieldType | [To be supplied.]
GetFloat | [To be supplied.]
GetInt16 | [To be supplied.]
GetInt32 | [To be supplied.]
GetInt64 | [To be supplied.]
GetName | [To be supplied.]
GetNamespace | [To be supplied.]
GetOrdinal | Overloaded. [To be supplied.]
GetPrefix | [To be supplied.]
GetRaw | [To be supplied.]
GetStream | [To be supplied.]
GetString | [To be supplied.]
GetTimeSpan | [To be supplied.]
GetValue | [To be supplied.]
GetValues | [To be supplied.]
IsNull | [To be supplied.]
SetBoolean | [To be supplied.]
SetByte | [To be supplied.]
SetBytes | [To be supplied.]
SetChar | [To be supplied.]
SetChars | [To be supplied.]
SetCurrency | [To be supplied.]
SetData | [To be supplied.]
SetDateTime | [To be supplied.]
SetDecimal | [To be supplied.]
SetDouble | [To be supplied.]
SetFloat | [To be supplied.]
SetInt16 | [To be supplied.]
SetInt32 | [To be supplied.]
SetInt64 | [To be supplied.]
SetName | [To be supplied.]
SetNamespace | [To be supplied.]
SetNull | [To be supplied.]
SetPrefix | [To be supplied.]
SetRaw | [To be supplied.]
SetStream | [To be supplied.]
SetString | [To be supplied.]
SetTimeSpan | [To be supplied.]
SetValue | [To be supplied.]
SetValues | [To be supplied.]

See Also

IDataBuffer Interface | System.Data Namespace


IDataBuffer.Clear

[To be supplied.]

[Visual Basic]
Sub Clear()
[C#]
void Clear();
[C++]
void Clear() = 0;
[JScript]
function Clear();

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.GetBoolean

[To be supplied.]

[Visual Basic]
Function GetBoolean( _
   ByVal i As Integer _
) As Boolean
[C#]
bool GetBoolean(
   int i
);
[C++]
bool GetBoolean(
   int i
) = 0;
[JScript]
function GetBoolean(
   i : int
) : Boolean;

Parameters

i
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.GetByte

[To be supplied.]

[Visual Basic]
Function GetByte( _
   ByVal i As Integer _
) As Byte
[C#]
byte GetByte(
   int i
);
[C++]
unsigned char GetByte(
   int i
) = 0;
[JScript]
function GetByte(
   i : int
) : Byte;

Parameters

i
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.GetBytes

[To be supplied.]

[Visual Basic]
Function GetBytes( _
   ByVal i As Integer, _
   ByVal buffer() As Byte, _
   ByVal length As Integer, _
   ByVal bufferoffset As Integer, _
   ByVal fieldoffset As Integer _
) As Integer
[C#]
int GetBytes(
   int i,
   byte[] buffer,
   int length,
   int bufferoffset,
   int fieldoffset
);
[C++]
int GetBytes(
   int i,
   unsigned char* buffer[],
   int length,
   int bufferoffset,
   int fieldoffset
) = 0;
[JScript]
function GetBytes(
   i : int,
   buffer : Byte[],
   length : int,
   bufferoffset : int,
   fieldoffset : int
) : int;

Parameters

i
[To be supplied.]
buffer
[To be supplied.]
length
[To be supplied.]
bufferoffset
[To be supplied.]
fieldoffset
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.GetChar

[To be supplied.]

[Visual Basic]
Function GetChar( _
   ByVal i As Integer _
) As Char
[C#]
char GetChar(
   int i
);
[C++]
__wchar_t GetChar(
   int i
) = 0;
[JScript]
function GetChar(
   i : int
) : Char;

Parameters

i
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.GetChars

[To be supplied.]

[Visual Basic]
Function GetChars( _
   ByVal i As Integer, _
   ByVal buffer() As Char, _
   ByVal length As Integer, _
   ByVal bufferoffset As Integer, _
   ByVal fieldoffset As Integer _
) As Integer
[C#]
int GetChars(
   int i,
   char[] buffer,
   int length,
   int bufferoffset,
   int fieldoffset
);
[C++]
int GetChars(
   int i,
   __wchar_t* buffer[],
   int length,
   int bufferoffset,
   int fieldoffset
) = 0;
[JScript]
function GetChars(
   i : int,
   buffer : Char[],
   length : int,
   bufferoffset : int,
   fieldoffset : int
) : int;

Parameters

i
[To be supplied.]
buffer
[To be supplied.]
length
[To be supplied.]
bufferoffset
[To be supplied.]
fieldoffset
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.GetCurrency

[To be supplied.]

[Visual Basic]
Function GetCurrency( _
   ByVal i As Integer _
) As Currency
[C#]
Currency GetCurrency(
   int i
);
[C++]
Currency GetCurrency(
   int i
) = 0;
[JScript]
function GetCurrency(
   i : int
) : Currency;

Parameters

i
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.GetData

[To be supplied.]

[Visual Basic]
Function GetData( _
   ByVal i As Integer _
) As IDataReader
[C#]
IDataReader GetData(
   int i
);
[C++]
IDataReader* GetData(
   int i
) = 0;
[JScript]
function GetData(
   i : int
) : IDataReader;

Parameters

i
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.GetDataTypeName

[To be supplied.]

[Visual Basic]
Function GetDataTypeName( _
   ByVal i As Integer _
) As String
[C#]
string GetDataTypeName(
   int i
);
[C++]
String* GetDataTypeName(
   int i
) = 0;
[JScript]
function GetDataTypeName(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.GetDataTypeNamespace

[To be supplied.]

[Visual Basic]
Function GetDataTypeNamespace( _
   ByVal i As Integer _
) As String
[C#]
string GetDataTypeNamespace(
   int i
);
[C++]
String* GetDataTypeNamespace(
   int i
) = 0;
[JScript]
function GetDataTypeNamespace(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.GetDateTime

[To be supplied.]

[Visual Basic]
Function GetDateTime( _
   ByVal i As Integer _
) As DateTime
[C#]
DateTime GetDateTime(
   int i
);
[C++]
DateTime GetDateTime(
   int i
) = 0;
[JScript]
function GetDateTime(
   i : int
) : DateTime;

Parameters

i
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.GetDecimal

[To be supplied.]

[Visual Basic]
Function GetDecimal( _
   ByVal i As Integer _
) As Decimal
[C#]
Decimal GetDecimal(
   int i
);
[C++]
Decimal GetDecimal(
   int i
) = 0;
[JScript]
function GetDecimal(
   i : int
) : Decimal;

Parameters

i
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.GetDouble

[To be supplied.]

[Visual Basic]
Function GetDouble( _
   ByVal i As Integer _
) As Double
[C#]
double GetDouble(
   int i
);
[C++]
double GetDouble(
   int i
) = 0;
[JScript]
function GetDouble(
   i : int
) : double;

Parameters

i
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.GetFieldType

[To be supplied.]

[Visual Basic]
Function GetFieldType( _
   ByVal i As Integer _
) As Type
[C#]
Type GetFieldType(
   int i
);
[C++]
Type* GetFieldType(
   int i
) = 0;
[JScript]
function GetFieldType(
   i : int
) : Type;

Parameters

i
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.GetFloat

[To be supplied.]

[Visual Basic]
Function GetFloat( _
   ByVal i As Integer _
) As Single
[C#]
float GetFloat(
   int i
);
[C++]
float GetFloat(
   int i
) = 0;
[JScript]
function GetFloat(
   i : int
) : float;

Parameters

i
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.GetInt16

[To be supplied.]

[Visual Basic]
Function GetInt16( _
   ByVal i As Integer _
) As Short
[C#]
short GetInt16(
   int i
);
[C++]
short GetInt16(
   int i
) = 0;
[JScript]
function GetInt16(
   i : int
) : Int16;

Parameters

i
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.GetInt32

[To be supplied.]

[Visual Basic]
Function GetInt32( _
   ByVal i As Integer _
) As Integer
[C#]
int GetInt32(
   int i
);
[C++]
int GetInt32(
   int i
) = 0;
[JScript]
function GetInt32(
   i : int
) : int;

Parameters

i
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.GetInt64

[To be supplied.]

[Visual Basic]
Function GetInt64( _
   ByVal i As Integer _
) As Long
[C#]
long GetInt64(
   int i
);
[C++]
__int64 GetInt64(
   int i
) = 0;
[JScript]
function GetInt64(
   i : int
) : long;

Parameters

i
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.GetName

[To be supplied.]

[Visual Basic]
Function GetName( _
   ByVal i As Integer _
) As String
[C#]
string GetName(
   int i
);
[C++]
String* GetName(
   int i
) = 0;
[JScript]
function GetName(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.GetNamespace

[To be supplied.]

[Visual Basic]
Function GetNamespace( _
   ByVal i As Integer _
) As String
[C#]
string GetNamespace(
   int i
);
[C++]
String* GetNamespace(
   int i
) = 0;
[JScript]
function GetNamespace(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.GetOrdinal

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Function GetOrdinal(String, String) As Integer
[C#] int GetOrdinal(String, String);
[C++] int GetOrdinal(String*, String*) = 0;
[JScript] function GetOrdinal(String, String) : int;

[To be supplied.]

[Visual Basic] Overloads Function GetOrdinal(String) As Integer
[C#] int GetOrdinal(String);
[C++] int GetOrdinal(String*) = 0;
[JScript] function GetOrdinal(String) : int;

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.GetOrdinal (String, String)

[To be supplied.]

[Visual Basic]
Overloads Function GetOrdinal( _
   ByVal name As String, _
   ByVal namespaceURI As String _
) As Integer
[C#]
int GetOrdinal(
   string name,
   string namespaceURI
);
[C++]
int GetOrdinal(
   String* name,
   String* namespaceURI
) = 0;
[JScript]
function GetOrdinal(
   name : String,
   namespaceURI : String
) : int;

Parameters

name
[To be supplied.]
namespaceURI
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace | IDataBuffer.GetOrdinal Overload List


IDataBuffer.GetOrdinal (String)

[To be supplied.]

[Visual Basic]
Overloads Function GetOrdinal( _
   ByVal name As String _
) As Integer
[C#]
int GetOrdinal(
   string name
);
[C++]
int GetOrdinal(
   String* name
) = 0;
[JScript]
function GetOrdinal(
   name : String
) : int;

Parameters

name
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace | IDataBuffer.GetOrdinal Overload List


IDataBuffer.GetPrefix

[To be supplied.]

[Visual Basic]
Function GetPrefix( _
   ByVal i As Integer _
) As String
[C#]
string GetPrefix(
   int i
);
[C++]
String* GetPrefix(
   int i
) = 0;
[JScript]
function GetPrefix(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.GetRaw

[To be supplied.]

[Visual Basic]
Function GetRaw( _
   ByVal i As Integer _
) As String
[C#]
string GetRaw(
   int i
);
[C++]
String* GetRaw(
   int i
) = 0;
[JScript]
function GetRaw(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.GetStream

[To be supplied.]

[Visual Basic]
Function GetStream( _
   ByVal i As Integer _
) As Stream
[C#]
Stream GetStream(
   int i
);
[C++]
Stream* GetStream(
   int i
) = 0;
[JScript]
function GetStream(
   i : int
) : Stream;

Parameters

i
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.GetString

[To be supplied.]

[Visual Basic]
Function GetString( _
   ByVal i As Integer _
) As String
[C#]
string GetString(
   int i
);
[C++]
String* GetString(
   int i
) = 0;
[JScript]
function GetString(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.GetTimeSpan

[To be supplied.]

[Visual Basic]
Function GetTimeSpan( _
   ByVal i As Integer _
) As TimeSpan
[C#]
TimeSpan GetTimeSpan(
   int i
);
[C++]
TimeSpan GetTimeSpan(
   int i
) = 0;
[JScript]
function GetTimeSpan(
   i : int
) : TimeSpan;

Parameters

i
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.GetValue

[To be supplied.]

[Visual Basic]
Sub GetValue( _
   ByVal i As Integer, _
   ByRef value As Object _
)
[C#]
void GetValue(
   int i,
   ref object value
);
[C++]
void GetValue(
   int i,
   Object** value
) = 0;
[JScript]
function GetValue(
   i : int,
   value : Object
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.GetValues

[To be supplied.]

[Visual Basic]
Function GetValues( _
   ByVal values() As Object _
) As Integer
[C#]
int GetValues(
   object[] values
);
[C++]
int GetValues(
   Object* values[]
) = 0;
[JScript]
function GetValues(
   values : Object[]
) : int;

Parameters

values
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.IsNull

[To be supplied.]

[Visual Basic]
Function IsNull( _
   ByVal i As Integer _
) As Boolean
[C#]
bool IsNull(
   int i
);
[C++]
bool IsNull(
   int i
) = 0;
[JScript]
function IsNull(
   i : int
) : Boolean;

Parameters

i
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.SetBoolean

[To be supplied.]

[Visual Basic]
Sub SetBoolean( _
   ByVal i As Integer, _
   ByVal value As Boolean _
)
[C#]
void SetBoolean(
   int i,
   bool value
);
[C++]
void SetBoolean(
   int i,
   bool value
) = 0;
[JScript]
function SetBoolean(
   i : int,
   value : Boolean
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.SetByte

[To be supplied.]

[Visual Basic]
Sub SetByte( _
   ByVal i As Integer, _
   ByVal value As Byte _
)
[C#]
void SetByte(
   int i,
   byte value
);
[C++]
void SetByte(
   int i,
   unsigned char value
) = 0;
[JScript]
function SetByte(
   i : int,
   value : Byte
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.SetBytes

[To be supplied.]

[Visual Basic]
Sub SetBytes( _
   ByVal i As Integer, _
   ByVal buffer() As Byte, _
   ByVal length As Integer, _
   ByVal bufferoffset As Integer, _
   ByVal fieldoffset As Integer _
)
[C#]
void SetBytes(
   int i,
   byte[] buffer,
   int length,
   int bufferoffset,
   int fieldoffset
);
[C++]
void SetBytes(
   int i,
   unsigned char* buffer[],
   int length,
   int bufferoffset,
   int fieldoffset
) = 0;
[JScript]
function SetBytes(
   i : int,
   buffer : Byte[],
   length : int,
   bufferoffset : int,
   fieldoffset : int
);

Parameters

i
[To be supplied.]
buffer
[To be supplied.]
length
[To be supplied.]
bufferoffset
[To be supplied.]
fieldoffset
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.SetChar

[To be supplied.]

[Visual Basic]
Sub SetChar( _
   ByVal i As Integer, _
   ByVal value As Char _
)
[C#]
void SetChar(
   int i,
   char value
);
[C++]
void SetChar(
   int i,
   __wchar_t value
) = 0;
[JScript]
function SetChar(
   i : int,
   value : Char
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.SetChars

[To be supplied.]

[Visual Basic]
Sub SetChars( _
   ByVal i As Integer, _
   ByVal buffer() As Char, _
   ByVal length As Integer, _
   ByVal bufferoffset As Integer, _
   ByVal fieldoffset As Integer _
)
[C#]
void SetChars(
   int i,
   char[] buffer,
   int length,
   int bufferoffset,
   int fieldoffset
);
[C++]
void SetChars(
   int i,
   __wchar_t* buffer[],
   int length,
   int bufferoffset,
   int fieldoffset
) = 0;
[JScript]
function SetChars(
   i : int,
   buffer : Char[],
   length : int,
   bufferoffset : int,
   fieldoffset : int
);

Parameters

i
[To be supplied.]
buffer
[To be supplied.]
length
[To be supplied.]
bufferoffset
[To be supplied.]
fieldoffset
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.SetCurrency

[To be supplied.]

[Visual Basic]
Sub SetCurrency( _
   ByVal i As Integer, _
   ByVal value As Currency _
)
[C#]
void SetCurrency(
   int i,
   Currency value
);
[C++]
void SetCurrency(
   int i,
   Currency value
) = 0;
[JScript]
function SetCurrency(
   i : int,
   value : Currency
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.SetData

[To be supplied.]

[Visual Basic]
Sub SetData( _
   ByVal i As Integer, _
   ByVal stm As IDataReader _
)
[C#]
void SetData(
   int i,
   IDataReader stm
);
[C++]
void SetData(
   int i,
   IDataReader* stm
) = 0;
[JScript]
function SetData(
   i : int,
   stm : IDataReader
);

Parameters

i
[To be supplied.]
stm
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.SetDateTime

[To be supplied.]

[Visual Basic]
Sub SetDateTime( _
   ByVal i As Integer, _
   ByVal value As DateTime _
)
[C#]
void SetDateTime(
   int i,
   DateTime value
);
[C++]
void SetDateTime(
   int i,
   DateTime value
) = 0;
[JScript]
function SetDateTime(
   i : int,
   value : DateTime
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.SetDecimal

[To be supplied.]

[Visual Basic]
Sub SetDecimal( _
   ByVal i As Integer, _
   ByVal value As Decimal _
)
[C#]
void SetDecimal(
   int i,
   Decimal value
);
[C++]
void SetDecimal(
   int i,
   Decimal value
) = 0;
[JScript]
function SetDecimal(
   i : int,
   value : Decimal
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.SetDouble

[To be supplied.]

[Visual Basic]
Sub SetDouble( _
   ByVal i As Integer, _
   ByVal value As Double _
)
[C#]
void SetDouble(
   int i,
   double value
);
[C++]
void SetDouble(
   int i,
   double value
) = 0;
[JScript]
function SetDouble(
   i : int,
   value : double
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.SetFloat

[To be supplied.]

[Visual Basic]
Sub SetFloat( _
   ByVal i As Integer, _
   ByVal value As Single _
)
[C#]
void SetFloat(
   int i,
   float value
);
[C++]
void SetFloat(
   int i,
   float value
) = 0;
[JScript]
function SetFloat(
   i : int,
   value : float
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.SetInt16

[To be supplied.]

[Visual Basic]
Sub SetInt16( _
   ByVal i As Integer, _
   ByVal value As Short _
)
[C#]
void SetInt16(
   int i,
   short value
);
[C++]
void SetInt16(
   int i,
   short value
) = 0;
[JScript]
function SetInt16(
   i : int,
   value : Int16
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.SetInt32

[To be supplied.]

[Visual Basic]
Sub SetInt32( _
   ByVal i As Integer, _
   ByVal value As Integer _
)
[C#]
void SetInt32(
   int i,
   int value
);
[C++]
void SetInt32(
   int i,
   int value
) = 0;
[JScript]
function SetInt32(
   i : int,
   value : int
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.SetInt64

[To be supplied.]

[Visual Basic]
Sub SetInt64( _
   ByVal i As Integer, _
   ByVal value As Long _
)
[C#]
void SetInt64(
   int i,
   long value
);
[C++]
void SetInt64(
   int i,
   __int64 value
) = 0;
[JScript]
function SetInt64(
   i : int,
   value : long
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.SetName

[To be supplied.]

[Visual Basic]
Sub SetName( _
   ByVal i As Integer, _
   ByVal value As String _
)
[C#]
void SetName(
   int i,
   string value
);
[C++]
void SetName(
   int i,
   String* value
) = 0;
[JScript]
function SetName(
   i : int,
   value : String
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.SetNamespace

[To be supplied.]

[Visual Basic]
Sub SetNamespace( _
   ByVal i As Integer, _
   ByVal value As String _
)
[C#]
void SetNamespace(
   int i,
   string value
);
[C++]
void SetNamespace(
   int i,
   String* value
) = 0;
[JScript]
function SetNamespace(
   i : int,
   value : String
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.SetNull

[To be supplied.]

[Visual Basic]
Sub SetNull( _
   ByVal i As Integer _
)
[C#]
void SetNull(
   int i
);
[C++]
void SetNull(
   int i
) = 0;
[JScript]
function SetNull(
   i : int
);

Parameters

i
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.SetPrefix

[To be supplied.]

[Visual Basic]
Sub SetPrefix( _
   ByVal i As Integer, _
   ByVal value As String _
)
[C#]
void SetPrefix(
   int i,
   string value
);
[C++]
void SetPrefix(
   int i,
   String* value
) = 0;
[JScript]
function SetPrefix(
   i : int,
   value : String
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.SetRaw

[To be supplied.]

[Visual Basic]
Sub SetRaw( _
   ByVal i As Integer, _
   ByVal raw As String _
)
[C#]
void SetRaw(
   int i,
   string raw
);
[C++]
void SetRaw(
   int i,
   String* raw
) = 0;
[JScript]
function SetRaw(
   i : int,
   raw : String
);

Parameters

i
[To be supplied.]
raw
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.SetStream

[To be supplied.]

[Visual Basic]
Sub SetStream( _
   ByVal i As Integer, _
   ByVal stm As Stream _
)
[C#]
void SetStream(
   int i,
   Stream stm
);
[C++]
void SetStream(
   int i,
   Stream* stm
) = 0;
[JScript]
function SetStream(
   i : int,
   stm : Stream
);

Parameters

i
[To be supplied.]
stm
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.SetString

[To be supplied.]

[Visual Basic]
Sub SetString( _
   ByVal i As Integer, _
   ByVal value As String _
)
[C#]
void SetString(
   int i,
   string value
);
[C++]
void SetString(
   int i,
   String* value
) = 0;
[JScript]
function SetString(
   i : int,
   value : String
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.SetTimeSpan

[To be supplied.]

[Visual Basic]
Sub SetTimeSpan( _
   ByVal i As Integer, _
   ByVal value As TimeSpan _
)
[C#]
void SetTimeSpan(
   int i,
   TimeSpan value
);
[C++]
void SetTimeSpan(
   int i,
   TimeSpan value
) = 0;
[JScript]
function SetTimeSpan(
   i : int,
   value : TimeSpan
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.SetValue

[To be supplied.]

[Visual Basic]
Sub SetValue( _
   ByVal i As Integer, _
   ByVal value As Object _
)
[C#]
void SetValue(
   int i,
   object value
);
[C++]
void SetValue(
   int i,
   Object* value
) = 0;
[JScript]
function SetValue(
   i : int,
   value : Object
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataBuffer.SetValues

[To be supplied.]

[Visual Basic]
Function SetValues( _
   ByVal values() As Object _
) As Integer
[C#]
int SetValues(
   object[] values
);
[C++]
int SetValues(
   Object* values[]
) = 0;
[JScript]
function SetValues(
   values : Object[]
) : int;

Parameters

values
[To be supplied.]

See Also

IDataBuffer Interface | IDataBuffer Members | System.Data Namespace


IDataEditor Interface

[To be supplied.]

[Visual Basic]
Public Interface IDataEditor
   Implements IDataNavigator, IDataRecord, IDataBuffer
[C#]
public interface IDataEditor : IDataNavigator, IDataRecord,
   IDataBuffer
[C++]
public __gc __interface IDataEditor : public IDataNavigator,
   IDataRecord, IDataBuffer

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IDataEditor

Class | Description
DocumentEditor | [To be supplied.]

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

IDataEditor Members | System.Data Namespace


IDataEditor Members

Methods

CopyChildren | [To be supplied.]
CopySelected | [To be supplied.]
Insert | Overloaded. [To be supplied.]
Move | [To be supplied.]
MoveChildren | [To be supplied.]
MoveSelected | [To be supplied.]
Remove | Overloaded. [To be supplied.]
RemoveSelected | [To be supplied.]

See Also

IDataEditor Interface | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDataEditor Methods

The methods of the IDataEditor interface are listed below. For a complete list of IDataEditor interface members, see the IDataEditor Members topic.

CopyChildren | [To be supplied.]
CopySelected | [To be supplied.]
Insert | Overloaded. [To be supplied.]
Move | [To be supplied.]
MoveChildren | [To be supplied.]
MoveSelected | [To be supplied.]
Remove | Overloaded. [To be supplied.]
RemoveSelected | [To be supplied.]

See Also

IDataEditor Interface | System.Data Namespace


IDataEditor.CopyChildren

[To be supplied.]

[Visual Basic]
Sub CopyChildren( _
   ByVal p As TreePosition, _
   ByVal other As IDataNavigator _
)
[C#]
void CopyChildren(
   TreePosition p,
   IDataNavigator other
);
[C++]
void CopyChildren(
   TreePosition p,
   IDataNavigator* other
) = 0;
[JScript]
function CopyChildren(
   p : TreePosition,
   other : IDataNavigator
);

Parameters

p
[To be supplied.]
other
[To be supplied.]

See Also

IDataEditor Interface | IDataEditor Members | System.Data Namespace


IDataEditor.CopySelected

[To be supplied.]

[Visual Basic]
Sub CopySelected( _
   ByVal p As TreePosition, _
   ByVal other As IDataNavigator _
)
[C#]
void CopySelected(
   TreePosition p,
   IDataNavigator other
);
[C++]
void CopySelected(
   TreePosition p,
   IDataNavigator* other
) = 0;
[JScript]
function CopySelected(
   p : TreePosition,
   other : IDataNavigator
);

Parameters

p
[To be supplied.]
other
[To be supplied.]

See Also

IDataEditor Interface | IDataEditor Members | System.Data Namespace


IDataEditor.Insert

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Sub Insert(TreePosition, XmlNodeType, String, String, String)
[C#] void Insert(TreePosition, XmlNodeType, String, String, String);
[C++] void Insert(TreePosition, XmlNodeType, String, String, String) = 0;
[JScript] function Insert(TreePosition, XmlNodeType, String, String, String);

[To be supplied.]

[Visual Basic] Overloads Sub Insert(TreePosition, Object, Type)
[C#] void Insert(TreePosition, Object, Type);
[C++] void Insert(TreePosition, Object, Type) = 0;
[JScript] function Insert(TreePosition, Object, Type);

See Also

IDataEditor Interface | IDataEditor Members | System.Data Namespace


IDataEditor.Insert (TreePosition, XmlNodeType, String, String, String)

[To be supplied.]

[Visual Basic]
Overloads Sub Insert( _
   ByVal p As TreePosition, _
   ByVal NodeType As XmlNodeType, _
   ByVal name As String, _
   ByVal namespaceURI As String, _
   ByVal prefix As String _
)
[C#]
void Insert(
   TreePosition p,
   XmlNodeType NodeType,
   string name,
   string namespaceURI,
   string prefix
);
[C++]
void Insert(
   TreePosition p,
   XmlNodeType NodeType,
   String* name,
   String* namespaceURI,
   String* prefix
) = 0;
[JScript]
function Insert(
   p : TreePosition,
   NodeType : XmlNodeType,
   name : String,
   namespaceURI : String,
   prefix : String
);

Parameters

p
[To be supplied.]
NodeType
[To be supplied.]
name
[To be supplied.]
namespaceURI
[To be supplied.]
prefix
[To be supplied.]

See Also

IDataEditor Interface | IDataEditor Members | System.Data Namespace | IDataEditor.Insert Overload List


IDataEditor.Insert (TreePosition, Object, Type)

[To be supplied.]

[Visual Basic]
Overloads Sub Insert( _
   ByVal p As TreePosition, _
   ByVal obj As Object, _
   ByVal type As Type _
)
[C#]
void Insert(
   TreePosition p,
   object obj,
   Type type
);
[C++]
void Insert(
   TreePosition p,
   Object* obj,
   Type* type
) = 0;
[JScript]
function Insert(
   p : TreePosition,
   obj : Object,
   type : Type
);

Parameters

p
[To be supplied.]
obj
[To be supplied.]
type
[To be supplied.]

See Also

IDataEditor Interface | IDataEditor Members | System.Data Namespace | IDataEditor.Insert Overload List


IDataEditor.Move

[To be supplied.]

[Visual Basic]
Sub Move( _
   ByVal p As TreePosition, _
   ByVal other As IDataEditor _
)
[C#]
void Move(
   TreePosition p,
   IDataEditor other
);
[C++]
void Move(
   TreePosition p,
   IDataEditor* other
) = 0;
[JScript]
function Move(
   p : TreePosition,
   other : IDataEditor
);

Parameters

p
[To be supplied.]
other
[To be supplied.]

See Also

IDataEditor Interface | IDataEditor Members | System.Data Namespace


IDataEditor.MoveChildren

[To be supplied.]

[Visual Basic]
Sub MoveChildren( _
   ByVal p As TreePosition, _
   ByVal other As IDataEditor _
)
[C#]
void MoveChildren(
   TreePosition p,
   IDataEditor other
);
[C++]
void MoveChildren(
   TreePosition p,
   IDataEditor* other
) = 0;
[JScript]
function MoveChildren(
   p : TreePosition,
   other : IDataEditor
);

Parameters

p
[To be supplied.]
other
[To be supplied.]

See Also

IDataEditor Interface | IDataEditor Members | System.Data Namespace


IDataEditor.MoveSelected

[To be supplied.]

[Visual Basic]
Sub MoveSelected( _
   ByVal p As TreePosition, _
   ByVal other As IDataEditor _
)
[C#]
void MoveSelected(
   TreePosition p,
   IDataEditor other
);
[C++]
void MoveSelected(
   TreePosition p,
   IDataEditor* other
) = 0;
[JScript]
function MoveSelected(
   p : TreePosition,
   other : IDataEditor
);

Parameters

p
[To be supplied.]
other
[To be supplied.]

See Also

IDataEditor Interface | IDataEditor Members | System.Data Namespace


IDataEditor.Remove

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Sub Remove(TreePosition)
[C#] void Remove(TreePosition);
[C++] void Remove(TreePosition) = 0;
[JScript] function Remove(TreePosition);

[To be supplied.]

[Visual Basic] Overloads Sub Remove()
[C#] void Remove();
[C++] void Remove() = 0;
[JScript] function Remove();

See Also

IDataEditor Interface | IDataEditor Members | System.Data Namespace


IDataEditor.Remove (TreePosition)

[To be supplied.]

[Visual Basic]
Overloads Sub Remove( _
   ByVal p As TreePosition _
)
[C#]
void Remove(
   TreePosition p
);
[C++]
void Remove(
   TreePosition p
) = 0;
[JScript]
function Remove(
   p : TreePosition
);

Parameters

p
[To be supplied.]

See Also

IDataEditor Interface | IDataEditor Members | System.Data Namespace | IDataEditor.Remove Overload List


IDataEditor.Remove ()

[To be supplied.]

[Visual Basic]
Overloads Sub Remove()
[C#]
void Remove();
[C++]
void Remove() = 0;
[JScript]
function Remove();

See Also

IDataEditor Interface | IDataEditor Members | System.Data Namespace | IDataEditor.Remove Overload List


IDataEditor.RemoveSelected

[To be supplied.]

[Visual Basic]
Sub RemoveSelected()
[C#]
void RemoveSelected();
[C++]
void RemoveSelected() = 0;
[JScript]
function RemoveSelected();

See Also

IDataEditor Interface | IDataEditor Members | System.Data Namespace


IDataErrorInfo Interface

[To be supplied.]

IDataErrorInfo

[Visual Basic]
Public Interface IDataErrorInfo
[C#]
public interface IDataErrorInfo
[C++]
public __gc __interface IDataErrorInfo

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IDataErrorInfo

Class | Description
DataRowView | Represents a customized view of a DataRow.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

IDataErrorInfo Members | System.Data Namespace


IDataErrorInfo Members

Properties

Error | [To be supplied.]
Item | [To be supplied.] In C#, this member is the indexer for the IDataErrorInfo class.

See Also

IDataErrorInfo Interface | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDataErrorInfo Properties

The properties of the IDataErrorInfo interface are listed below. For a complete list of IDataErrorInfo interface members, see the IDataErrorInfo Members topic.

Error | [To be supplied.]
Item | [To be supplied.] In C#, this member is the indexer for the IDataErrorInfo class.

See Also

IDataErrorInfo Interface | System.Data Namespace


IDataErrorInfo.Error

[To be supplied.]

[Visual Basic]
ReadOnly Property Error As String
[C#]
string Error {get;}
[C++]
String* get_Error() = 0;
[JScript]
abstract function get Error() : String;

See Also

IDataErrorInfo Interface | IDataErrorInfo Members | System.Data Namespace


IDataErrorInfo.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the IDataErrorInfo class.

[Visual Basic]
Default ReadOnly Property Item( _
   ByVal columnName As String _
) As String
[C#]
string this[
   string columnName
] {get;}
[C++]
String* get_Item(
   String* columnName
) = 0;
[JScript]
abstract returnValue = IDataErrorInfoObject.Item(columnName);
-or-
abstract returnValue = IDataErrorInfoObject(columnName);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

columnName
[To be supplied.]

Parameters [Visual Basic, C#, C++]

columnName
[To be supplied.]

See Also

IDataErrorInfo Interface | IDataErrorInfo Members | System.Data Namespace


IDataList Interface

[To be supplied.]

[Visual Basic]
Public Interface IDataList
   Implements ICollection, IEnumerable
[C#]
public interface IDataList : ICollection, IEnumerable
[C++]
public __gc __interface IDataList : public ICollection, IEnumerable

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

IDataList Members | System.Data Namespace


IDataList Members

Properties

ElementType [To be supplied.]

Methods

GetElement [To be supplied.]

See Also

IDataList Interface | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDataList Properties

The properties of the IDataList interface are listed below. For a complete list of IDataList interface members, see the IDataList Members topic.

ElementType [To be supplied.]

See Also

IDataList Interface | System.Data Namespace


IDataList.ElementType

[To be supplied.]

[Visual Basic]
ReadOnly Property ElementType As Type
[C#]
Type ElementType {get;}
[C++]
Type* get_ElementType() = 0;
[JScript]
abstract function get ElementType() : Type;

See Also

IDataList Interface | IDataList Members | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDataList Methods

The methods of the IDataList interface are listed below. For a complete list of IDataList interface members, see the IDataList Members topic.

GetElement [To be supplied.]

See Also

IDataList Interface | System.Data Namespace


IDataList.GetElement

[To be supplied.]

[Visual Basic]
Function GetElement( _
   ByVal index As Integer _
) As Object
[C#]
object GetElement(
   int index
);
[C++]
Object* GetElement(
   int index
) = 0;
[JScript]
function GetElement(
   index : int
) : Object;

Parameters

index
[To be supplied.]

See Also

IDataList Interface | IDataList Members | System.Data Namespace


IDataNavigator Interface

[To be supplied.]

IDataNavigator

[Visual Basic]
Public Interface IDataNavigator
   Implements IDataRecord
[C#]
public interface IDataNavigator : IDataRecord
[C++]
public __gc __interface IDataNavigator : public IDataRecord

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IDataNavigator

Class | Description
DocumentEditor | [To be supplied.]
DocumentNavigator | [To be supplied.]

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

IDataNavigator Members | System.Data Namespace


IDataNavigator Members

Properties

ChildCount | [To be supplied.]
HasChildren | [To be supplied.]
IndexInParent | [To be supplied.]
LoadState | [To be supplied.]
ReadOnly | [To be supplied.]

Methods

Clone | [To be supplied.]
CompareOrder | [To be supplied.]
Compile | [To be supplied.]
Evaluate | Overloaded. [To be supplied.]
GetEnumerator | [To be supplied.]
IsSame | [To be supplied.]
Matches | Overloaded. [To be supplied.]
MoveFirst | [To be supplied.]
MoveFirstSelected | [To be supplied.]
MoveLast | [To be supplied.]
MoveLastSelected | [To be supplied.]
MoveNext | [To be supplied.]
MoveNextSelected | [To be supplied.]
MovePrevious | [To be supplied.]
MovePreviousSelected | [To be supplied.]
MoveTo | [To be supplied.]
MoveToChild | [To be supplied.]
MoveToField | [To be supplied.]
MoveToFirstChild | [To be supplied.]
MoveToId | [To be supplied.]
MoveToLastChild | [To be supplied.]
MoveToNull | [To be supplied.]
MoveToParent | [To be supplied.]
MoveToRoot | [To be supplied.]
PopPosition | [To be supplied.]
PushPosition | [To be supplied.]
Select | Overloaded. [To be supplied.]

See Also

IDataNavigator Interface | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDataNavigator Properties

The properties of the IDataNavigator interface are listed below. For a complete list of IDataNavigator interface members, see the IDataNavigator Members topic.

ChildCount | [To be supplied.]
HasChildren | [To be supplied.]
IndexInParent | [To be supplied.]
LoadState | [To be supplied.]
ReadOnly | [To be supplied.]

See Also

IDataNavigator Interface | System.Data Namespace


IDataNavigator.ChildCount

[To be supplied.]

[Visual Basic]
ReadOnly Property ChildCount As Integer
[C#]
int ChildCount {get;}
[C++]
int get_ChildCount() = 0;
[JScript]
abstract function get ChildCount() : int;

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.HasChildren

[To be supplied.]

[Visual Basic]
ReadOnly Property HasChildren As Boolean
[C#]
bool HasChildren {get;}
[C++]
bool get_HasChildren() = 0;
[JScript]
abstract function get HasChildren() : Boolean;

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.IndexInParent

[To be supplied.]

[Visual Basic]
ReadOnly Property IndexInParent As Integer
[C#]
int IndexInParent {get;}
[C++]
int get_IndexInParent() = 0;
[JScript]
abstract function get IndexInParent() : int;

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.LoadState

[To be supplied.]

[Visual Basic]
ReadOnly Property LoadState As Integer
[C#]
int LoadState {get;}
[C++]
int get_LoadState() = 0;
[JScript]
abstract function get LoadState() : int;

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.ReadOnly

[To be supplied.]

[Visual Basic]
ReadOnly Property ReadOnly As Boolean
[C#]
bool ReadOnly {get;}
[C++]
bool get_ReadOnly() = 0;
[JScript]
abstract function get ReadOnly() : Boolean;

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDataNavigator Methods

The methods of the IDataNavigator interface are listed below. For a complete list of IDataNavigator interface members, see the IDataNavigator Members topic.

Clone | [To be supplied.]
CompareOrder | [To be supplied.]
Compile | [To be supplied.]
Evaluate | Overloaded. [To be supplied.]
GetEnumerator | [To be supplied.]
IsSame | [To be supplied.]
Matches | Overloaded. [To be supplied.]
MoveFirst | [To be supplied.]
MoveFirstSelected | [To be supplied.]
MoveLast | [To be supplied.]
MoveLastSelected | [To be supplied.]
MoveNext | [To be supplied.]
MoveNextSelected | [To be supplied.]
MovePrevious | [To be supplied.]
MovePreviousSelected | [To be supplied.]
MoveTo | [To be supplied.]
MoveToChild | [To be supplied.]
MoveToField | [To be supplied.]
MoveToFirstChild | [To be supplied.]
MoveToId | [To be supplied.]
MoveToLastChild | [To be supplied.]
MoveToNull | [To be supplied.]
MoveToParent | [To be supplied.]
MoveToRoot | [To be supplied.]
PopPosition | [To be supplied.]
PushPosition | [To be supplied.]
Select | Overloaded. [To be supplied.]

See Also

IDataNavigator Interface | System.Data Namespace


IDataNavigator.Clone

[To be supplied.]

[Visual Basic]
Function Clone() As IDataNavigator
[C#]
IDataNavigator Clone();
[C++]
IDataNavigator* Clone() = 0;
[JScript]
function Clone() : IDataNavigator;

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.CompareOrder

[To be supplied.]

[Visual Basic]
Function CompareOrder( _
   ByVal rightoperand As IDataNavigator _
) As Integer
[C#]
int CompareOrder(
   IDataNavigator rightoperand
);
[C++]
int CompareOrder(
   IDataNavigator* rightoperand
) = 0;
[JScript]
function CompareOrder(
   rightoperand : IDataNavigator
) : int;

Parameters

rightoperand
[To be supplied.]

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.Compile

[To be supplied.]

[Visual Basic]
Function Compile( _
   ByVal xpathexpr As String _
) As Object
[C#]
object Compile(
   string xpathexpr
);
[C++]
Object* Compile(
   String* xpathexpr
) = 0;
[JScript]
function Compile(
   xpathexpr : String
) : Object;

Parameters

xpathexpr
[To be supplied.]

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.Evaluate

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Function Evaluate(String) As Object
[C#] object Evaluate(String);
[C++] Object* Evaluate(String*) = 0;
[JScript] function Evaluate(String) : Object;

[To be supplied.]

[Visual Basic] Overloads Function Evaluate(Object) As Object
[C#] object Evaluate(Object);
[C++] Object* Evaluate(Object*) = 0;
[JScript] function Evaluate(Object) : Object;

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.Evaluate (String)

[To be supplied.]

[Visual Basic]
Overloads Function Evaluate( _
   ByVal xpathexpr As String _
) As Object
[C#]
object Evaluate(
   string xpathexpr
);
[C++]
Object* Evaluate(
   String* xpathexpr
) = 0;
[JScript]
function Evaluate(
   xpathexpr : String
) : Object;

Parameters

xpathexpr
[To be supplied.]

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace | IDataNavigator.Evaluate Overload List


IDataNavigator.Evaluate (Object)

[To be supplied.]

[Visual Basic]
Overloads Function Evaluate( _
   ByVal xpathexpr As Object _
) As Object
[C#]
object Evaluate(
   object xpathexpr
);
[C++]
Object* Evaluate(
   Object* xpathexpr
) = 0;
[JScript]
function Evaluate(
   xpathexpr : Object
) : Object;

Parameters

xpathexpr
[To be supplied.]

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace | IDataNavigator.Evaluate Overload List


IDataNavigator.GetEnumerator

[To be supplied.]

[Visual Basic]
Function GetEnumerator() As IEnumerator
[C#]
IEnumerator GetEnumerator();
[C++]
IEnumerator* GetEnumerator() = 0;
[JScript]
function GetEnumerator() : IEnumerator;

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.IsSame

[To be supplied.]

[Visual Basic]
Function IsSame( _
   ByVal pos As IDataNavigator _
) As Boolean
[C#]
bool IsSame(
   IDataNavigator pos
);
[C++]
bool IsSame(
   IDataNavigator* pos
) = 0;
[JScript]
function IsSame(
   pos : IDataNavigator
) : Boolean;

Parameters

pos
[To be supplied.]

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.Matches

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Function Matches(Object) As Boolean
[C#] bool Matches(Object);
[C++] bool Matches(Object*) = 0;
[JScript] function Matches(Object) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Function Matches(String) As Boolean
[C#] bool Matches(String);
[C++] bool Matches(String*) = 0;
[JScript] function Matches(String) : Boolean;

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.Matches (Object)

[To be supplied.]

[Visual Basic]
Overloads Function Matches( _
   ByVal xpathexpr As Object _
) As Boolean
[C#]
bool Matches(
   object xpathexpr
);
[C++]
bool Matches(
   Object* xpathexpr
) = 0;
[JScript]
function Matches(
   xpathexpr : Object
) : Boolean;

Parameters

xpathexpr
[To be supplied.]

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace | IDataNavigator.Matches Overload List


IDataNavigator.Matches (String)

[To be supplied.]

[Visual Basic]
Overloads Function Matches( _
   ByVal xpathexpr As String _
) As Boolean
[C#]
bool Matches(
   string xpathexpr
);
[C++]
bool Matches(
   String* xpathexpr
) = 0;
[JScript]
function Matches(
   xpathexpr : String
) : Boolean;

Parameters

xpathexpr
[To be supplied.]

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace | IDataNavigator.Matches Overload List


IDataNavigator.MoveFirst

[To be supplied.]

[Visual Basic]
Function MoveFirst() As Boolean
[C#]
bool MoveFirst();
[C++]
bool MoveFirst() = 0;
[JScript]
function MoveFirst() : Boolean;

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.MoveFirstSelected

[To be supplied.]

[Visual Basic]
Function MoveFirstSelected() As Boolean
[C#]
bool MoveFirstSelected();
[C++]
bool MoveFirstSelected() = 0;
[JScript]
function MoveFirstSelected() : Boolean;

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.MoveLast

[To be supplied.]

[Visual Basic]
Function MoveLast() As Boolean
[C#]
bool MoveLast();
[C++]
bool MoveLast() = 0;
[JScript]
function MoveLast() : Boolean;

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.MoveLastSelected

[To be supplied.]

[Visual Basic]
Function MoveLastSelected() As Boolean
[C#]
bool MoveLastSelected();
[C++]
bool MoveLastSelected() = 0;
[JScript]
function MoveLastSelected() : Boolean;

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.MoveNext

[To be supplied.]

[Visual Basic]
Function MoveNext() As Boolean
[C#]
bool MoveNext();
[C++]
bool MoveNext() = 0;
[JScript]
function MoveNext() : Boolean;

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.MoveNextSelected

[To be supplied.]

[Visual Basic]
Function MoveNextSelected() As Boolean
[C#]
bool MoveNextSelected();
[C++]
bool MoveNextSelected() = 0;
[JScript]
function MoveNextSelected() : Boolean;

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.MovePrevious

[To be supplied.]

[Visual Basic]
Function MovePrevious() As Boolean
[C#]
bool MovePrevious();
[C++]
bool MovePrevious() = 0;
[JScript]
function MovePrevious() : Boolean;

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.MovePreviousSelected

[To be supplied.]

[Visual Basic]
Function MovePreviousSelected() As Boolean
[C#]
bool MovePreviousSelected();
[C++]
bool MovePreviousSelected() = 0;
[JScript]
function MovePreviousSelected() : Boolean;

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.MoveTo

[To be supplied.]

[Visual Basic]
Function MoveTo( _
   ByVal pos As IDataNavigator _
) As Boolean
[C#]
bool MoveTo(
   IDataNavigator pos
);
[C++]
bool MoveTo(
   IDataNavigator* pos
) = 0;
[JScript]
function MoveTo(
   pos : IDataNavigator
) : Boolean;

Parameters

pos
[To be supplied.]

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.MoveToChild

[To be supplied.]

[Visual Basic]
Function MoveToChild( _
   ByVal i As Integer _
) As Boolean
[C#]
bool MoveToChild(
   int i
);
[C++]
bool MoveToChild(
   int i
) = 0;
[JScript]
function MoveToChild(
   i : int
) : Boolean;

Parameters

i
[To be supplied.]

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.MoveToField

[To be supplied.]

[Visual Basic]
Function MoveToField( _
   ByVal i As Integer _
) As Boolean
[C#]
bool MoveToField(
   int i
);
[C++]
bool MoveToField(
   int i
) = 0;
[JScript]
function MoveToField(
   i : int
) : Boolean;

Parameters

i
[To be supplied.]

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.MoveToFirstChild

[To be supplied.]

[Visual Basic]
Function MoveToFirstChild() As Boolean
[C#]
bool MoveToFirstChild();
[C++]
bool MoveToFirstChild() = 0;
[JScript]
function MoveToFirstChild() : Boolean;

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.MoveToId

[To be supplied.]

[Visual Basic]
Function MoveToId( _
   ByVal id As String _
) As Boolean
[C#]
bool MoveToId(
   string id
);
[C++]
bool MoveToId(
   String* id
) = 0;
[JScript]
function MoveToId(
   id : String
) : Boolean;

Parameters

id
[To be supplied.]

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.MoveToLastChild

[To be supplied.]

[Visual Basic]
Function MoveToLastChild() As Boolean
[C#]
bool MoveToLastChild();
[C++]
bool MoveToLastChild() = 0;
[JScript]
function MoveToLastChild() : Boolean;

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.MoveToNull

[To be supplied.]

[Visual Basic]
Sub MoveToNull()
[C#]
void MoveToNull();
[C++]
void MoveToNull() = 0;
[JScript]
function MoveToNull();

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.MoveToParent

[To be supplied.]

[Visual Basic]
Function MoveToParent() As Boolean
[C#]
bool MoveToParent();
[C++]
bool MoveToParent() = 0;
[JScript]
function MoveToParent() : Boolean;

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.MoveToRoot

[To be supplied.]

[Visual Basic]
Function MoveToRoot() As Boolean
[C#]
bool MoveToRoot();
[C++]
bool MoveToRoot() = 0;
[JScript]
function MoveToRoot() : Boolean;

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.PopPosition

[To be supplied.]

[Visual Basic]
Function PopPosition() As Boolean
[C#]
bool PopPosition();
[C++]
bool PopPosition() = 0;
[JScript]
function PopPosition() : Boolean;

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.PushPosition

[To be supplied.]

[Visual Basic]
Sub PushPosition()
[C#]
void PushPosition();
[C++]
void PushPosition() = 0;
[JScript]
function PushPosition();

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.Select

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Sub Select(Object)
[C#] void Select(Object);
[C++] void Select(Object*) = 0;
[JScript] function Select(Object);

[To be supplied.]

[Visual Basic] Overloads Sub Select(String)
[C#] void Select(String);
[C++] void Select(String*) = 0;
[JScript] function Select(String);

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace


IDataNavigator.Select (Object)

[To be supplied.]

[Visual Basic]
Overloads Sub Select( _
   ByVal xpathexpr As Object _
)
[C#]
void Select(
   object xpathexpr
);
[C++]
void Select(
   Object* xpathexpr
) = 0;
[JScript]
function Select(
   xpathexpr : Object
);

Parameters

xpathexpr
[To be supplied.]

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace | IDataNavigator.Select Overload List


IDataNavigator.Select (String)

[To be supplied.]

[Visual Basic]
Overloads Sub Select( _
   ByVal xpathexpr As String _
)
[C#]
void Select(
   string xpathexpr
);
[C++]
void Select(
   String* xpathexpr
) = 0;
[JScript]
function Select(
   xpathexpr : String
);

Parameters

xpathexpr
[To be supplied.]

See Also

IDataNavigator Interface | IDataNavigator Members | System.Data Namespace | IDataNavigator.Select Overload List


IDataParameter Interface

Allows an object to create a data parameter to a command and its mapping to DataSet columns.

IDataParameter

[Visual Basic]
Public Interface IDataParameter
[C#]
public interface IDataParameter
[C++]
public __gc __interface IDataParameter

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IDataParameter

Class | Description
ADOParameter | Represents a parameter to an ADOCommand and, optionally, its mapping to DataSet columns.
SQLParameter | Represents a parameter to an SQLCommand and, optionally, its mapping to DataSet columns.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

IDataParameter Members | System.Data Namespace


IDataParameter Members

Properties

DataType | Gets or sets the Type of the parameter.
Direction | Gets or sets whether the parameter is input-only, output-only, or bidirectional.
IsNullable | Gets or sets whether the parameter accepts nulls.
ParameterName | Gets or sets the name of the ADOParameter.
SourceColumn | Gets or sets the name of the source column mapped to the DataSet and used for loading or returning the Value.
SourceVersion | Gets or sets the DataRowVersion to use when loading Value.
Value | Gets or sets the value of the parameter.

See Also

IDataParameter Interface | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDataParameter Properties

The properties of the IDataParameter interface are listed below. For a complete list of IDataParameter interface members, see the IDataParameter Members topic.

DataType | Gets or sets the Type of the parameter.
Direction | Gets or sets whether the parameter is input-only, output-only, or bidirectional.
IsNullable | Gets or sets whether the parameter accepts nulls.
ParameterName | Gets or sets the name of the ADOParameter.
SourceColumn | Gets or sets the name of the source column mapped to the DataSet and used for loading or returning the Value.
SourceVersion | Gets or sets the DataRowVersion to use when loading Value.
Value | Gets or sets the value of the parameter.

See Also

IDataParameter Interface | System.Data Namespace


IDataParameter.DataType

Gets or sets the Type of the parameter.

[Visual Basic]
ReadOnly Property DataType As Type
[C#]
Type DataType {get;}
[C++]
Type* get_DataType() = 0;
[JScript]
abstract function get DataType() : Type;

Property Value

The Type of the parameter.

See Also

IDataParameter Interface | IDataParameter Members | System.Data Namespace


IDataParameter.Direction

Gets or sets whether the parameter is input-only, output-only, or bidirectional.

[Visual Basic]
ReadOnly Property Direction As ParameterDirection
[C#]
ParameterDirection Direction {get;}
[C++]
ParameterDirection get_Direction() = 0;
[JScript]
abstract function get Direction() : ParameterDirection;

Property Value

One of the ParameterDirection values. The default is Input.

See Also

IDataParameter Interface | IDataParameter Members | System.Data Namespace


IDataParameter.IsNullable

Gets or sets whether the parameter accepts nulls.

[Visual Basic]
ReadOnly Property IsNullable As Boolean
[C#]
bool IsNullable {get;}
[C++]
bool get_IsNullable() = 0;
[JScript]
abstract function get IsNullable() : Boolean;

Property Value

true if nulls are accepted, otherwise false. The default is false.

See Also

IDataParameter Interface | IDataParameter Members | System.Data Namespace


IDataParameter.ParameterName

Gets or sets the name of the ADOParameter.

[Visual Basic]
ReadOnly Property ParameterName As String
[C#]
string ParameterName {get;}
[C++]
String* get_ParameterName() = 0;
[JScript]
abstract function get ParameterName() : String;

Property Value

The name the ADOParameter.

See Also

IDataParameter Interface | IDataParameter Members | System.Data Namespace


IDataParameter.SourceColumn

Gets or sets the name of the source column mapped to the DataSet and used for loading or returning the Value.

[Visual Basic]
Property SourceColumn As String
[C#]
string SourceColumn {get; set;}
[C++]
String* get_SourceColumn() = 0;void set_SourceColumn(String*) = 0;
[JScript]
abstract function get SourceColumn() : String;
public abstract function set SourceColumn(String);

Property Value

The name of the source column mapped to the DataSet and used for loading or returning the Value.

See Also

IDataParameter Interface | IDataParameter Members | System.Data Namespace


IDataParameter.SourceVersion

Gets or sets the DataRowVersion to use when loading Value.

[Visual Basic]
Property SourceVersion As DataRowVersion
[C#]
DataRowVersion SourceVersion {get; set;}
[C++]
DataRowVersion get_SourceVersion() = 0;void set_SourceVersion(DataRowVersion) = 0;
[JScript]
abstract function get SourceVersion() : DataRowVersion;
public abstract function set SourceVersion(DataRowVersion);

Property Value

One of the DataRowVersion values. The default is Current.

See Also

IDataParameter Interface | IDataParameter Members | System.Data Namespace


IDataParameter.Value

Gets or sets the value of the parameter.

[Visual Basic]
Property Value As Object
[C#]
object Value {get; set;}
[C++]
Object* get_Value() = 0;void set_Value(Object*) = 0;
[JScript]
abstract function get Value() : Object;
public abstract function set Value(Object);

Property Value

An Object that is the value of the parameter.

See Also

IDataParameter Interface | IDataParameter Members | System.Data Namespace


IDataReader Interface

[To be supplied.]

IDataReader

[Visual Basic]
Public Interface IDataReader
   Implements IDataRecord
[C#]
public interface IDataReader : IDataRecord
[C++]
public __gc __interface IDataReader : public IDataRecord

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IDataReader

Class | Description
ADODataReader | [To be supplied.]
CoreXmlReader | [To be supplied.]
DocumentReader | [To be supplied.]
SQLDataReader | [To be supplied.]

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

IDataReader Members | System.Data Namespace


IDataReader Members

Properties

Depth | [To be supplied.]
EOF | [To be supplied.]
Filter | [To be supplied.]
Format | [To be supplied.]
ReadState | [To be supplied.]

Methods

Close | [To be supplied.]
Read | [To be supplied.]

See Also

IDataReader Interface | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDataReader Properties

The properties of the IDataReader interface are listed below. For a complete list of IDataReader interface members, see the IDataReader Members topic.

Depth | [To be supplied.]
EOF | [To be supplied.]
Filter | [To be supplied.]
Format | [To be supplied.]
ReadState | [To be supplied.]

See Also

IDataReader Interface | System.Data Namespace


IDataReader.Depth

[To be supplied.]

[Visual Basic]
ReadOnly Property Depth As Integer
[C#]
int Depth {get;}
[C++]
int get_Depth() = 0;
[JScript]
abstract function get Depth() : int;

See Also

IDataReader Interface | IDataReader Members | System.Data Namespace


IDataReader.EOF

[To be supplied.]

[Visual Basic]
ReadOnly Property EOF As Boolean
[C#]
bool EOF {get;}
[C++]
bool get_EOF() = 0;
[JScript]
abstract function get EOF() : Boolean;

See Also

IDataReader Interface | IDataReader Members | System.Data Namespace


IDataReader.Filter

[To be supplied.]

[Visual Basic]
Property Filter As String
[C#]
string Filter {get; set;}
[C++]
String* get_Filter() = 0;void set_Filter(String*) = 0;
[JScript]
abstract function get Filter() : String;
public abstract function set Filter(String);

See Also

IDataReader Interface | IDataReader Members | System.Data Namespace


IDataReader.Format

[To be supplied.]

[Visual Basic]
ReadOnly Property Format As String
[C#]
string Format {get;}
[C++]
String* get_Format() = 0;
[JScript]
abstract function get Format() : String;

See Also

IDataReader Interface | IDataReader Members | System.Data Namespace


IDataReader.ReadState

[To be supplied.]

[Visual Basic]
ReadOnly Property ReadState As Integer
[C#]
int ReadState {get;}
[C++]
int get_ReadState() = 0;
[JScript]
abstract function get ReadState() : int;

See Also

IDataReader Interface | IDataReader Members | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDataReader Methods

The methods of the IDataReader interface are listed below. For a complete list of IDataReader interface members, see the IDataReader Members topic.

Close | [To be supplied.]
Read | [To be supplied.]

See Also

IDataReader Interface | System.Data Namespace


IDataReader.Close

[To be supplied.]

[Visual Basic]
Sub Close()
[C#]
void Close();
[C++]
void Close() = 0;
[JScript]
function Close();

See Also

IDataReader Interface | IDataReader Members | System.Data Namespace


IDataReader.Read

[To be supplied.]

[Visual Basic]
Function Read() As Boolean
[C#]
bool Read();
[C++]
bool Read() = 0;
[JScript]
function Read() : Boolean;

See Also

IDataReader Interface | IDataReader Members | System.Data Namespace


IDataRecord Interface

[To be supplied.]

IDataRecord

[Visual Basic]
Public Interface IDataRecord
[C#]
public interface IDataRecord
[C++]
public __gc __interface IDataRecord

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IDataRecord

Class | Description
ADODataReader | [To be supplied.]
CoreXmlReader | [To be supplied.]
DocumentEditor | [To be supplied.]
DocumentNavigator | [To be supplied.]
DocumentReader | [To be supplied.]
SQLDataReader | [To be supplied.]

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

IDataRecord Members | System.Data Namespace


IDataRecord Members

Properties

DataTypeName | [To be supplied.]
DataTypeNamespace | [To be supplied.]
Empty | [To be supplied.]
FieldCount | [To be supplied.]
HasValue | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the IDataRecord class.
Name | [To be supplied.]
Namespace | [To be supplied.]
NameTable | [To be supplied.]
NodeType | [To be supplied.]
Prefix | [To be supplied.]

Methods

GetBoolean | [To be supplied.]
GetByte | [To be supplied.]
GetBytes | [To be supplied.]
GetChar | [To be supplied.]
GetChars | [To be supplied.]
GetCurrency | [To be supplied.]
GetData | [To be supplied.]
GetDataTypeName | [To be supplied.]
GetDataTypeNamespace | [To be supplied.]
GetDateTime | [To be supplied.]
GetDecimal | [To be supplied.]
GetDouble | [To be supplied.]
GetFieldType | [To be supplied.]
GetFloat | [To be supplied.]
GetInt16 | [To be supplied.]
GetInt32 | [To be supplied.]
GetInt64 | [To be supplied.]
GetName | [To be supplied.]
GetNamespace | [To be supplied.]
GetOrdinal | Overloaded. [To be supplied.]
GetPrefix | [To be supplied.]
GetRaw | [To be supplied.]
GetStream | [To be supplied.]
GetString | [To be supplied.]
GetTimeSpan | [To be supplied.]
GetValue | [To be supplied.]
GetValues | [To be supplied.]
IsNull | [To be supplied.]

See Also

IDataRecord Interface | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDataRecord Properties

The properties of the IDataRecord interface are listed below. For a complete list of IDataRecord interface members, see the IDataRecord Members topic.

DataTypeName | [To be supplied.]
DataTypeNamespace | [To be supplied.]
Empty | [To be supplied.]
FieldCount | [To be supplied.]
HasValue | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the IDataRecord class.
Name | [To be supplied.]
Namespace | [To be supplied.]
NameTable | [To be supplied.]
NodeType | [To be supplied.]
Prefix | [To be supplied.]

See Also

IDataRecord Interface | System.Data Namespace


IDataRecord.DataTypeName

[To be supplied.]

[Visual Basic]
ReadOnly Property DataTypeName As String
[C#]
string DataTypeName {get;}
[C++]
String* get_DataTypeName() = 0;
[JScript]
abstract function get DataTypeName() : String;

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.DataTypeNamespace

[To be supplied.]

[Visual Basic]
ReadOnly Property DataTypeNamespace As String
[C#]
string DataTypeNamespace {get;}
[C++]
String* get_DataTypeNamespace() = 0;
[JScript]
abstract function get DataTypeNamespace() : String;

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.Empty

[To be supplied.]

[Visual Basic]
ReadOnly Property Empty As Boolean
[C#]
bool Empty {get;}
[C++]
bool get_Empty() = 0;
[JScript]
abstract function get Empty() : Boolean;

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.FieldCount

[To be supplied.]

[Visual Basic]
ReadOnly Property FieldCount As Integer
[C#]
int FieldCount {get;}
[C++]
int get_FieldCount() = 0;
[JScript]
abstract function get FieldCount() : int;

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.HasValue

[To be supplied.]

[Visual Basic]
ReadOnly Property HasValue As Boolean
[C#]
bool HasValue {get;}
[C++]
bool get_HasValue() = 0;
[JScript]
abstract function get HasValue() : Boolean;

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the IDataRecord class.

Overload List

[To be supplied.]

[Visual Basic] Overloads Default ReadOnly Property Item(Integer) As Object
[C#] object this[int] {get;}
[C++] Object* get_Item(int) = 0;
[JScript] IDataRecord.Item (int)

[To be supplied.]

[Visual Basic] Overloads Default ReadOnly Property Item(String) As Object
[C#] object this[String] {get;}
[C++] Object* get_Item(String*) = 0;
[JScript] IDataRecord.Item (String)

[To be supplied.]

[Visual Basic] Overloads Default ReadOnly Property Item(String, String) As Object
[C#] object this[String, String] {get;}
[C++] Object* get_Item(String*, String*) = 0;
[JScript] IDataRecord.Item (String, String)

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.Item (Int32)

[To be supplied.]

[C#] In C#, this member is the indexer for the IDataRecord class.

[Visual Basic]
Overloads Default ReadOnly Property Item( _
   ByVal i As Integer _
) As Object
[C#]
object this[
   int i
] {get;}
[C++]
Object* get_Item(
   int i
) = 0;
[JScript]
abstract returnValue = IDataRecordObject.Item(i);
-or-
abstract returnValue = IDataRecordObject(i);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

i
[To be supplied.]

Parameters [Visual Basic, C#, C++]

i
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace | IDataRecord.Item Overload List


IDataRecord.Item (String)

[To be supplied.]

[C#] In C#, this member is the indexer for the IDataRecord class.

[Visual Basic]
Overloads Default ReadOnly Property Item( _
   ByVal name As String _
) As Object
[C#]
object this[
   string name
] {get;}
[C++]
Object* get_Item(
   String* name
) = 0;
[JScript]
abstract returnValue = IDataRecordObject.Item(name);
-or-
abstract returnValue = IDataRecordObject(name);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
[To be supplied.]

Parameters [Visual Basic, C#, C++]

name
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace | IDataRecord.Item Overload List


IDataRecord.Item (String, String)

[To be supplied.]

[C#] In C#, this member is the indexer for the IDataRecord class.

[Visual Basic]
Overloads Default ReadOnly Property Item( _
   ByVal name As String, _
   ByVal namespaceURI As String _
) As Object
[C#]
object this[
   string name,
   string namespaceURI
] {get;}
[C++]
Object* get_Item(
   String* name,
   String* namespaceURI
) = 0;
[JScript]
abstract returnValue = IDataRecordObject.Item(name, namespaceURI);
-or-
abstract returnValue = IDataRecordObject(name, namespaceURI);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
[To be supplied.]
namespaceURI
[To be supplied.]

Parameters [Visual Basic, C#, C++]

name
[To be supplied.]
namespaceURI
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace | IDataRecord.Item Overload List


IDataRecord.Name

[To be supplied.]

[Visual Basic]
ReadOnly Property Name As String
[C#]
string Name {get;}
[C++]
String* get_Name() = 0;
[JScript]
abstract function get Name() : String;

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.Namespace

[To be supplied.]

[Visual Basic]
ReadOnly Property Namespace As String
[C#]
string Namespace {get;}
[C++]
String* get_Namespace() = 0;
[JScript]
abstract function get Namespace() : String;

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.NameTable

[To be supplied.]

[Visual Basic]
ReadOnly Property NameTable As INameTable
[C#]
INameTable NameTable {get;}
[C++]
INameTable* get_NameTable() = 0;
[JScript]
abstract function get NameTable() : INameTable;

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.NodeType

[To be supplied.]

[Visual Basic]
ReadOnly Property NodeType As XmlNodeType
[C#]
XmlNodeType NodeType {get;}
[C++]
XmlNodeType get_NodeType() = 0;
[JScript]
abstract function get NodeType() : XmlNodeType;

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.Prefix

[To be supplied.]

[Visual Basic]
ReadOnly Property Prefix As String
[C#]
string Prefix {get;}
[C++]
String* get_Prefix() = 0;
[JScript]
abstract function get Prefix() : String;

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDataRecord Methods

The methods of the IDataRecord interface are listed below. For a complete list of IDataRecord interface members, see the IDataRecord Members topic.

GetBoolean | [To be supplied.]
GetByte | [To be supplied.]
GetBytes | [To be supplied.]
GetChar | [To be supplied.]
GetChars | [To be supplied.]
GetCurrency | [To be supplied.]
GetData | [To be supplied.]
GetDataTypeName | [To be supplied.]
GetDataTypeNamespace | [To be supplied.]
GetDateTime | [To be supplied.]
GetDecimal | [To be supplied.]
GetDouble | [To be supplied.]
GetFieldType | [To be supplied.]
GetFloat | [To be supplied.]
GetInt16 | [To be supplied.]
GetInt32 | [To be supplied.]
GetInt64 | [To be supplied.]
GetName | [To be supplied.]
GetNamespace | [To be supplied.]
GetOrdinal | Overloaded. [To be supplied.]
GetPrefix | [To be supplied.]
GetRaw | [To be supplied.]
GetStream | [To be supplied.]
GetString | [To be supplied.]
GetTimeSpan | [To be supplied.]
GetValue | [To be supplied.]
GetValues | [To be supplied.]
IsNull | [To be supplied.]

See Also

IDataRecord Interface | System.Data Namespace


IDataRecord.GetBoolean

[To be supplied.]

[Visual Basic]
Function GetBoolean( _
   ByVal i As Integer _
) As Boolean
[C#]
bool GetBoolean(
   int i
);
[C++]
bool GetBoolean(
   int i
) = 0;
[JScript]
function GetBoolean(
   i : int
) : Boolean;

Parameters

i
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.GetByte

[To be supplied.]

[Visual Basic]
Function GetByte( _
   ByVal i As Integer _
) As Byte
[C#]
byte GetByte(
   int i
);
[C++]
unsigned char GetByte(
   int i
) = 0;
[JScript]
function GetByte(
   i : int
) : Byte;

Parameters

i
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.GetBytes

[To be supplied.]

[Visual Basic]
Function GetBytes( _
   ByVal i As Integer, _
   ByVal buffer() As Byte, _
   ByVal length As Integer, _
   ByVal bufferoffset As Integer, _
   ByVal fieldoffset As Integer _
) As Integer
[C#]
int GetBytes(
   int i,
   byte[] buffer,
   int length,
   int bufferoffset,
   int fieldoffset
);
[C++]
int GetBytes(
   int i,
   unsigned char* buffer[],
   int length,
   int bufferoffset,
   int fieldoffset
) = 0;
[JScript]
function GetBytes(
   i : int,
   buffer : Byte[],
   length : int,
   bufferoffset : int,
   fieldoffset : int
) : int;

Parameters

i
[To be supplied.]
buffer
[To be supplied.]
length
[To be supplied.]
bufferoffset
[To be supplied.]
fieldoffset
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.GetChar

[To be supplied.]

[Visual Basic]
Function GetChar( _
   ByVal i As Integer _
) As Char
[C#]
char GetChar(
   int i
);
[C++]
__wchar_t GetChar(
   int i
) = 0;
[JScript]
function GetChar(
   i : int
) : Char;

Parameters

i
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.GetChars

[To be supplied.]

[Visual Basic]
Function GetChars( _
   ByVal i As Integer, _
   ByVal buffer() As Char, _
   ByVal length As Integer, _
   ByVal bufferoffset As Integer, _
   ByVal fieldoffset As Integer _
) As Integer
[C#]
int GetChars(
   int i,
   char[] buffer,
   int length,
   int bufferoffset,
   int fieldoffset
);
[C++]
int GetChars(
   int i,
   __wchar_t* buffer[],
   int length,
   int bufferoffset,
   int fieldoffset
) = 0;
[JScript]
function GetChars(
   i : int,
   buffer : Char[],
   length : int,
   bufferoffset : int,
   fieldoffset : int
) : int;

Parameters

i
[To be supplied.]
buffer
[To be supplied.]
length
[To be supplied.]
bufferoffset
[To be supplied.]
fieldoffset
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.GetCurrency

[To be supplied.]

[Visual Basic]
Function GetCurrency( _
   ByVal i As Integer _
) As Currency
[C#]
Currency GetCurrency(
   int i
);
[C++]
Currency GetCurrency(
   int i
) = 0;
[JScript]
function GetCurrency(
   i : int
) : Currency;

Parameters

i
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.GetData

[To be supplied.]

[Visual Basic]
Function GetData( _
   ByVal i As Integer _
) As IDataReader
[C#]
IDataReader GetData(
   int i
);
[C++]
IDataReader* GetData(
   int i
) = 0;
[JScript]
function GetData(
   i : int
) : IDataReader;

Parameters

i
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.GetDataTypeName

[To be supplied.]

[Visual Basic]
Function GetDataTypeName( _
   ByVal i As Integer _
) As String
[C#]
string GetDataTypeName(
   int i
);
[C++]
String* GetDataTypeName(
   int i
) = 0;
[JScript]
function GetDataTypeName(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.GetDataTypeNamespace

[To be supplied.]

[Visual Basic]
Function GetDataTypeNamespace( _
   ByVal i As Integer _
) As String
[C#]
string GetDataTypeNamespace(
   int i
);
[C++]
String* GetDataTypeNamespace(
   int i
) = 0;
[JScript]
function GetDataTypeNamespace(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.GetDateTime

[To be supplied.]

[Visual Basic]
Function GetDateTime( _
   ByVal i As Integer _
) As DateTime
[C#]
DateTime GetDateTime(
   int i
);
[C++]
DateTime GetDateTime(
   int i
) = 0;
[JScript]
function GetDateTime(
   i : int
) : DateTime;

Parameters

i
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.GetDecimal

[To be supplied.]

[Visual Basic]
Function GetDecimal( _
   ByVal i As Integer _
) As Decimal
[C#]
Decimal GetDecimal(
   int i
);
[C++]
Decimal GetDecimal(
   int i
) = 0;
[JScript]
function GetDecimal(
   i : int
) : Decimal;

Parameters

i
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.GetDouble

[To be supplied.]

[Visual Basic]
Function GetDouble( _
   ByVal i As Integer _
) As Double
[C#]
double GetDouble(
   int i
);
[C++]
double GetDouble(
   int i
) = 0;
[JScript]
function GetDouble(
   i : int
) : double;

Parameters

i
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.GetFieldType

[To be supplied.]

[Visual Basic]
Function GetFieldType( _
   ByVal i As Integer _
) As Type
[C#]
Type GetFieldType(
   int i
);
[C++]
Type* GetFieldType(
   int i
) = 0;
[JScript]
function GetFieldType(
   i : int
) : Type;

Parameters

i
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.GetFloat

[To be supplied.]

[Visual Basic]
Function GetFloat( _
   ByVal i As Integer _
) As Single
[C#]
float GetFloat(
   int i
);
[C++]
float GetFloat(
   int i
) = 0;
[JScript]
function GetFloat(
   i : int
) : float;

Parameters

i
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.GetInt16

[To be supplied.]

[Visual Basic]
Function GetInt16( _
   ByVal i As Integer _
) As Short
[C#]
short GetInt16(
   int i
);
[C++]
short GetInt16(
   int i
) = 0;
[JScript]
function GetInt16(
   i : int
) : Int16;

Parameters

i
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.GetInt32

[To be supplied.]

[Visual Basic]
Function GetInt32( _
   ByVal i As Integer _
) As Integer
[C#]
int GetInt32(
   int i
);
[C++]
int GetInt32(
   int i
) = 0;
[JScript]
function GetInt32(
   i : int
) : int;

Parameters

i
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.GetInt64

[To be supplied.]

[Visual Basic]
Function GetInt64( _
   ByVal i As Integer _
) As Long
[C#]
long GetInt64(
   int i
);
[C++]
__int64 GetInt64(
   int i
) = 0;
[JScript]
function GetInt64(
   i : int
) : long;

Parameters

i
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.GetName

[To be supplied.]

[Visual Basic]
Function GetName( _
   ByVal i As Integer _
) As String
[C#]
string GetName(
   int i
);
[C++]
String* GetName(
   int i
) = 0;
[JScript]
function GetName(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.GetNamespace

[To be supplied.]

[Visual Basic]
Function GetNamespace( _
   ByVal i As Integer _
) As String
[C#]
string GetNamespace(
   int i
);
[C++]
String* GetNamespace(
   int i
) = 0;
[JScript]
function GetNamespace(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.GetOrdinal

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Function GetOrdinal(String) As Integer
[C#] int GetOrdinal(String);
[C++] int GetOrdinal(String*) = 0;
[JScript] function GetOrdinal(String) : int;

[To be supplied.]

[Visual Basic] Overloads Function GetOrdinal(String, String) As Integer
[C#] int GetOrdinal(String, String);
[C++] int GetOrdinal(String*, String*) = 0;
[JScript] function GetOrdinal(String, String) : int;

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.GetOrdinal (String)

[To be supplied.]

[Visual Basic]
Overloads Function GetOrdinal( _
   ByVal name As String _
) As Integer
[C#]
int GetOrdinal(
   string name
);
[C++]
int GetOrdinal(
   String* name
) = 0;
[JScript]
function GetOrdinal(
   name : String
) : int;

Parameters

name
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace | IDataRecord.GetOrdinal Overload List


IDataRecord.GetOrdinal (String, String)

[To be supplied.]

[Visual Basic]
Overloads Function GetOrdinal( _
   ByVal name As String, _
   ByVal namespaceURI As String _
) As Integer
[C#]
int GetOrdinal(
   string name,
   string namespaceURI
);
[C++]
int GetOrdinal(
   String* name,
   String* namespaceURI
) = 0;
[JScript]
function GetOrdinal(
   name : String,
   namespaceURI : String
) : int;

Parameters

name
[To be supplied.]
namespaceURI
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace | IDataRecord.GetOrdinal Overload List


IDataRecord.GetPrefix

[To be supplied.]

[Visual Basic]
Function GetPrefix( _
   ByVal i As Integer _
) As String
[C#]
string GetPrefix(
   int i
);
[C++]
String* GetPrefix(
   int i
) = 0;
[JScript]
function GetPrefix(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.GetRaw

[To be supplied.]

[Visual Basic]
Function GetRaw( _
   ByVal i As Integer _
) As String
[C#]
string GetRaw(
   int i
);
[C++]
String* GetRaw(
   int i
) = 0;
[JScript]
function GetRaw(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.GetStream

[To be supplied.]

[Visual Basic]
Function GetStream( _
   ByVal i As Integer _
) As Stream
[C#]
Stream GetStream(
   int i
);
[C++]
Stream* GetStream(
   int i
) = 0;
[JScript]
function GetStream(
   i : int
) : Stream;

Parameters

i
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.GetString

[To be supplied.]

[Visual Basic]
Function GetString( _
   ByVal i As Integer _
) As String
[C#]
string GetString(
   int i
);
[C++]
String* GetString(
   int i
) = 0;
[JScript]
function GetString(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.GetTimeSpan

[To be supplied.]

[Visual Basic]
Function GetTimeSpan( _
   ByVal i As Integer _
) As TimeSpan
[C#]
TimeSpan GetTimeSpan(
   int i
);
[C++]
TimeSpan GetTimeSpan(
   int i
) = 0;
[JScript]
function GetTimeSpan(
   i : int
) : TimeSpan;

Parameters

i
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.GetValue

[To be supplied.]

[Visual Basic]
Sub GetValue( _
   ByVal i As Integer, _
   ByRef value As Object _
)
[C#]
void GetValue(
   int i,
   ref object value
);
[C++]
void GetValue(
   int i,
   Object** value
) = 0;
[JScript]
function GetValue(
   i : int,
   value : Object
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.GetValues

[To be supplied.]

[Visual Basic]
Function GetValues( _
   ByVal values() As Object _
) As Integer
[C#]
int GetValues(
   object[] values
);
[C++]
int GetValues(
   Object* values[]
) = 0;
[JScript]
function GetValues(
   values : Object[]
) : int;

Parameters

values
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataRecord.IsNull

[To be supplied.]

[Visual Basic]
Function IsNull( _
   ByVal i As Integer _
) As Boolean
[C#]
bool IsNull(
   int i
);
[C++]
bool IsNull(
   int i
) = 0;
[JScript]
function IsNull(
   i : int
) : Boolean;

Parameters

i
[To be supplied.]

See Also

IDataRecord Interface | IDataRecord Members | System.Data Namespace


IDataSetCommand Interface

Allows an object to create a data set command, which represents a set of data commands and a database connection which are used to fill the DataSet and update the data source. At any time, the object refers to only a single record within the current data set.

IDataSetCommand

[Visual Basic]
Public Interface IDataSetCommand
[C#]
public interface IDataSetCommand
[C++]
public __gc __interface IDataSetCommand

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IDataSetCommand

Class | Description
DataSetCommand | Represents a set of data commands and a database connection which are used to fill the DataSet and update the data source. At any time, the object refers to only a single record within the current data set.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

IDataSetCommand Members | System.Data Namespace


IDataSetCommand Members

Properties

MissingMappingAction | Gets or sets whether unmapped source tables or columns are to be passed with their source names to be filtered, or to cause an error to be raised.
MissingSchemaAction | Gets or sets whether missing source tables, columns, and their relationships are to be added to the data set schema, to be ignored, or to cause an error to be raised.
TableMappings | Gets how a source table is to be mapped to a data set table.

Methods

FillDataSet | Changes the data in the DataSet to match the data in the data source.
FillDataSetSchema | Fills the DataSet with only the schema based upon the chosen SchemaType.
GetFillDataSetParameters | Returns an array of IDataParameter objects used to fill the DataSet with records from the data source.
Update | Changes the data in the data source to match the data in the DataSet.

See Also

IDataSetCommand Interface | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDataSetCommand Properties

The properties of the IDataSetCommand interface are listed below. For a complete list of IDataSetCommand interface members, see the IDataSetCommand Members topic.

MissingMappingAction | Gets or sets whether unmapped source tables or columns are to be passed with their source names to be filtered, or to cause an error to be raised.
MissingSchemaAction | Gets or sets whether missing source tables, columns, and their relationships are to be added to the data set schema, to be ignored, or to cause an error to be raised.
TableMappings | Gets how a source table is to be mapped to a data set table.

See Also

IDataSetCommand Interface | System.Data Namespace


IDataSetCommand.MissingMappingAction

Gets or sets whether unmapped source tables or columns are to be passed with their source names to be filtered, or to cause an error to be raised.

[Visual Basic]
Property MissingMappingAction As MissingMappingAction
[C#]
MissingMappingAction MissingMappingAction {get; set;}
[C++]
MissingMappingAction get_MissingMappingAction() = 0;void set_MissingMappingAction(MissingMappingAction) = 0;
[JScript]
abstract function get MissingMappingAction() : MissingMappingAction;
public abstract function set MissingMappingAction(MissingMappingAction);

Property Value

One of the MissingMappingAction values. The default is Passthrough.

Exceptions

Exception Type | Condition
InvalidMappingAction(System.Int32) | The value set is not one of the MissingMappingAction values.

Remarks

The TableMappings property provides the master mapping between the returned records and the DataSet.

Example [Visual Basic]

The following example shows how to set the MissingMappingAction property.

[Visual Basic]

Sub SetMissingMappingAction ()
    Dim adoDataSetComm As ADODataSetCommand
    adoDataSetComm = New ADODataSetCommand
    'Set action to Ignore when table or column is missing from table
    adoDataSetComm.MissingMappingAction = MissingMappingAction.Ignore
End Sub

See Also

IDataSetCommand Interface | IDataSetCommand Members | System.Data Namespace | MissingSchemaAction


IDataSetCommand.MissingSchemaAction

Gets or sets whether missing source tables, columns, and their relationships are to be added to the data set schema, to be ignored, or to cause an error to be raised.

[Visual Basic]
Property MissingSchemaAction As MissingSchemaAction
[C#]
MissingSchemaAction MissingSchemaAction {get; set;}
[C++]
MissingSchemaAction get_MissingSchemaAction() = 0;void set_MissingSchemaAction(MissingSchemaAction) = 0;
[JScript]
abstract function get MissingSchemaAction() : MissingSchemaAction;
public abstract function set MissingSchemaAction(MissingSchemaAction);

Property Value

One of the MissingSchemaAction values. The default is Add.

Exceptions

Exception Type | Condition
InvalidSchemaAction(System.Int32) | The value set is not one of the MissingSchemaAction values.

Example [Visual Basic]

The following example shows how to set the MissingSchemaAction property.

[Visual Basic]

Sub SetMissingSchemaAction ()
     Dim adoDataSetComm As ADODataSetCommand
     adoDataSetComm = New ADODataSetCommand
     ' Set the action to Error when a table or column is missing
     adoDataSetComm.MissingSchemaAction = MissingSchemaAction.Error
End Sub

See Also

IDataSetCommand Interface | IDataSetCommand Members | System.Data Namespace | MissingMappingAction


IDataSetCommand.TableMappings

Gets how a source table is to be mapped to a data set table.

[Visual Basic]
ReadOnly Property TableMappings As ITableMappings
[C#]
ITableMappings TableMappings {get;}
[C++]
ITableMappings* get_TableMappings() = 0;
[JScript]
abstract function get TableMappings() : ITableMappings;

Property Value

A collection that provides the master mapping between the returned records and the DataSet. The default value is an empty collection.

Remarks

The IDataSetCommand uses only the mappings for the source table named "Table". All select, insert, delete, and update commands returning data must do so using consistent column naming. The column names returned in the records must be unique, otherwise columns with duplicate names overwrites previous data. On Update only the table mapped to the source table named "Table" will have its changes reconciled.

See Also

IDataSetCommand Interface | IDataSetCommand Members | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDataSetCommand Methods

The methods of the IDataSetCommand interface are listed below. For a complete list of IDataSetCommand interface members, see the IDataSetCommand Members topic.

FillDataSet | Changes the data in the DataSet to match the data in the data source.
FillDataSetSchema | Fills the DataSet with only the schema based upon the chosen SchemaType.
GetFillDataSetParameters | Returns an array of IDataParameter objects used to fill the DataSet with records from the data source.
Update | Changes the data in the data source to match the data in the DataSet.

See Also

IDataSetCommand Interface | System.Data Namespace


IDataSetCommand.FillDataSet

Changes the data in the DataSet to match the data in the data source.

[Visual Basic]
Function FillDataSet( _
   ByVal dataSet As DataSet _
) As Integer
[C#]
int FillDataSet(
   DataSet dataSet
);
[C++]
int FillDataSet(
   DataSet* dataSet
) = 0;
[JScript]
function FillDataSet(
   dataSet : DataSet
) : int;

Parameters

dataSet
A DataSet to fill with records and schema.

Exceptions

Exception Type | Condition
FillDataSetRequiresSourceTable(System.String) | The source table was invalid.

Remarks

Fills the DataSet with both data and the schema.

TableMappings is required to be mapped for this method to operate. The default source table is named "Table".

Example [C#]

The following example uses the ADODataSetCommand class, which implements the IDataSetCommand class, to FillDataSet with records from an Access data source. The DataSet is then used to Update a SQL Server data source.

[C#]

private DataSet InitializeMyDataSet() {
   // creates the table and its columns for the DataSet
   DataSet newData = new DataSet();
   DataTable newTable = newData.Tables.Add("Catagories");

   // add Columns to table
   newTable.Columns.Add("CategoryID",typeof(Int32));
   newTable.Columns.Add("CategoryName", typeof(String));
   newTable.Columns.Add("Description", typeof(String));
   newTable.Columns.Add("Picture",typeof(Byte[]));
   return newData;
}

public void AccessToSQLServer() {
   // set Access connection and select strings
   const string strAccessConn = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=NWIND_RW.MDB";
   const string strAccessSelect = "SELECT * FROM Categories ORDER BY CategoryID";
   // set SQL Server connection and insert strings
   const string strSQLServerConn = "Data Source=VBsql7;Initial Catalog=Northwind;User ID=sa;Password=;"
   const string strSQLServerInsert = "INSERT INTO Categories(CategoryName, Description, Picture) Values(@CategoryName,@Description,@Picture)";
   // create my DataSet
   DataSet myDataSet = InitializeMyDataSet();
   // create my Access objects
   ADOConnection myAccessConn = new ADOConnection(strAccessConn);
   ADODataSetCommand myAccessDataSetCmd = new ADODataSetCommand();
   myAccessDataSetCmd.SelectCommand = new ADOCommand(strAccessSelect,myAccessConn);
   // create my SQL Server objects
   SQLConnection mySQLConn = new SQLConnection(strSQLServerConn);
   SQLDataSetCommand mySQLDataSetCmd = new SQLDataSetCommand();
   mySQLDataSetCmd.InsertCommand = new SQLCommand(strSQLServerInsert,mySQLConn);
   // fill myDataSet with data from Access
   myAccessConn.Open();
   try {
      myAccessDataSetCmd.FillDataSet(myDataSet);
   }
   finally {
      myAccessConn.Close();
   }

   // do ugly work to turn original rows into new rows

   // update SQL Server with data from the DataSet
   mySQLConn.Open();
   try {
      mySQLDataSetCmd.InsertCommand.Parameters[0].SourceColumn = "CategoryName";
      mySQLDataSetCmd.InsertCommand.Parameters[1].SourceColumn = "Description";
      mySQLDataSetCmd.InsertCommand.Parameters[2].SourceColumn = "Picture";
      mySQLDataSetCmd.Update(myDataSet);
   }
   finally {
      mySQLConn.Close();
   }
}

See Also

IDataSetCommand Interface | IDataSetCommand Members | System.Data Namespace


IDataSetCommand.FillDataSetSchema

Fills the DataSet with only the schema based upon the chosen SchemaType.

[Visual Basic]
Function FillDataSetSchema( _
   ByVal dataSet As DataSet, _
   ByVal schemaType As SchemaType _
) As DataTable ()
[C#]
DataTable[] FillDataSetSchema(
   DataSet dataSet,
   SchemaType schemaType
);
[C++]
DataTable* FillDataSetSchema(
   DataSet* dataSet,
   SchemaType schemaType
) [] = 0;
[JScript]
function FillDataSetSchema(
   dataSet : DataSet,
   schemaType : SchemaType
) : DataTable[];

Parameters

dataSet
The DataSet to be filled with the schema from the data source.
schemaType
One of the SchemaType values.

Return Value

An array of DataTable objects that contain data returned from the data source.

Exceptions

Exception Type | Condition
FillDataSetSchemaRequiresSourceTable(System.String) | A source table could not be found to get the schema from.

Remarks

TableMappings is required to be mapped for this method to operate. The default source table is named "Table".

See Also

IDataSetCommand Interface | IDataSetCommand Members | System.Data Namespace


IDataSetCommand.GetFillDataSetParameters

Returns an array of IDataParameter objects used to fill the DataSet with records from the data source.

[Visual Basic]
Function GetFillDataSetParameters() As IDataParameter ()
[C#]
IDataParameter[] GetFillDataSetParameters();
[C++]
IDataParameter* GetFillDataSetParameters() [] = 0;
[JScript]
function GetFillDataSetParameters() : IDataParameter[];

Return Value

An array of IDataParameter objects.

See Also

IDataSetCommand Interface | IDataSetCommand Members | System.Data Namespace


IDataSetCommand.Update

Changes the data in the data source to match the data in the DataSet.

[Visual Basic]
Function Update( _
   ByVal dataSet As DataSet _
) As Integer
[C#]
int Update(
   DataSet dataSet
);
[C++]
int Update(
   DataSet* dataSet
) = 0;
[JScript]
function Update(
   dataSet : DataSet
) : int;

Parameters

dataSet
The DataSet to update the data source with.

Exceptions

Exception Type | Condition
UpdateRequiresSourceTable(System.String) | A source table could not be found.

Remarks

TableMappings are required to be mapped for this method to operate. The default source table is named "Table".

This method pulls rows from the table listed in the first mapping before running an update. The adapter will clone the insert, update, or delete command appropriate for the row. Then the OnRowUpdating event is raised, allowing the user to inspect the DataSet row, modify the cloned command, or cancel the default processing. The cloned command is then executed against the data source. If the cloned command is configured incorrectly, an error will be raised. The data set command then will refresh the row according to UpdatedRowSource property of the command. Any additional rows returned will be ignored. After any data is loaded back into the DataSet, the OnRowUpdated event is raised, allowing the user to inspect the reconciled DataSet row and any output parameters returned by the command. When the OnRowUpdated event returns, the data set command releases the cloned copy of the command and any changes made to it between the events are lost. After a row updates successfully, the changes to that row will have been accepted. If the connection was closed prior to Update, the adapter will close the connection.

When using Update, there are two events that occur per data row updated. The order of execution is as follows:

1) The values in the DataRow are moved to the parameter values.

2) The OnRowUpdating event is raised.

3) The command executes.

4) If the command is set to FirstReturnedRecord, then the first returned result is placed in the DataRow

5) If there are output parameters, they are placed in the DataRow

6) The OnRowUpdated event is raised.

7) AcceptChanges is called.

Example [C#]

The following example uses the SQLDataSetCommand class, which implements the IDataSetCommand class, to Update a SQL Server data source with new records from an Access data source.

[C#]

private DataSet InitializeMyDataSet() {
   // creates the table and its columns for the DataSet
   DataSet newData = new DataSet();
   DataTable newTable = newData.Tables.Add("Catagories");

   // add Columns to table
   newTable.Columns.Add("CategoryID",typeof(Int32));
   newTable.Columns.Add("CategoryName", typeof(String));
   newTable.Columns.Add("Description", typeof(String));
   newTable.Columns.Add("Picture",typeof(Byte[]));
   return newData;
}

public void AccessToSQLServer() {
   // set Access connection and select strings
   const string strAccessConn = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=NWIND_RW.MDB";
   const string strAccessSelect = "SELECT * FROM Categories ORDER BY CategoryID";
   // set SQL Server connection and insert strings
   const string strSQLServerConn = "Data Source=VBsql7;Initial Catalog=Northwind;User ID=sa;Password=;"
   const string strSQLServerInsert = "INSERT INTO Categories(CategoryName, Description, Picture) Values(@CategoryName,@Description,@Picture)";
   // create my DataSet
   DataSet myDataSet = InitializeMyDataSet();
   // create my Access objects
   ADOConnection myAccessConn = new ADOConnection(strAccessConn);
   ADODataSetCommand myAccessDataSetCmd = new ADODataSetCommand();
   myAccessDataSetCmd.SelectCommand = new ADOCommand(strAccessSelect,myAccessConn);
   // create my SQL Server objects
   SQLConnection mySQLConn = new SQLConnection(strSQLServerConn);
   SQLDataSetCommand mySQLDataSetCmd = new SQLDataSetCommand();
   mySQLDataSetCmd.InsertCommand = new SQLCommand(strSQLServerInsert,mySQLConn);
   // fill myDataSet with data from Access
   myAccessConn.Open();
   try {
      myAccessDataSetCmd.FillDataSet(myDataSet);
   }
   finally {
      myAccessConn.Close();
   }

   // do ugly work to turn original rows into new rows

   // update SQL Server with data from the DataSet
   mySQLConn.Open();
   try {
      mySQLDataSetCmd.InsertCommand.Parameters[0].SourceColumn = "CategoryName";
      mySQLDataSetCmd.InsertCommand.Parameters[1].SourceColumn = "Description";
      mySQLDataSetCmd.InsertCommand.Parameters[2].SourceColumn = "Picture";
      mySQLDataSetCmd.Update(myDataSet);
   }
   finally {
      mySQLConn.Close();
   }
}

See Also

IDataSetCommand Interface | IDataSetCommand Members | System.Data Namespace


IDataWriter Interface

[To be supplied.]

IDataWriter

[Visual Basic]
Public Interface IDataWriter
   Implements IDataBuffer
[C#]
public interface IDataWriter : IDataBuffer
[C++]
public __gc __interface IDataWriter : public IDataBuffer

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IDataWriter

Class | Description
XmlWriter | [To be supplied.]

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

IDataWriter Members | System.Data Namespace


IDataWriter Members

Properties

Depth | [To be supplied.]
WriteState | [To be supplied.]

Methods

Close | [To be supplied.]
Write | [To be supplied.]

See Also

IDataWriter Interface | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDataWriter Properties

The properties of the IDataWriter interface are listed below. For a complete list of IDataWriter interface members, see the IDataWriter Members topic.

Depth | [To be supplied.]
WriteState | [To be supplied.]

See Also

IDataWriter Interface | System.Data Namespace


IDataWriter.Depth

[To be supplied.]

[Visual Basic]
Property Depth As Integer
[C#]
int Depth {get; set;}
[C++]
int get_Depth() = 0;void set_Depth(int) = 0;
[JScript]
abstract function get Depth() : int;
public abstract function set Depth(int);

See Also

IDataWriter Interface | IDataWriter Members | System.Data Namespace


IDataWriter.WriteState

[To be supplied.]

[Visual Basic]
ReadOnly Property WriteState As Integer
[C#]
int WriteState {get;}
[C++]
int get_WriteState() = 0;
[JScript]
abstract function get WriteState() : int;

See Also

IDataWriter Interface | IDataWriter Members | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDataWriter Methods

The methods of the IDataWriter interface are listed below. For a complete list of IDataWriter interface members, see the IDataWriter Members topic.

Close | [To be supplied.]
Write | [To be supplied.]

See Also

IDataWriter Interface | System.Data Namespace


IDataWriter.Close

[To be supplied.]

[Visual Basic]
Sub Close()
[C#]
void Close();
[C++]
void Close() = 0;
[JScript]
function Close();

See Also

IDataWriter Interface | IDataWriter Members | System.Data Namespace


IDataWriter.Write

[To be supplied.]

[Visual Basic]
Function Write() As Boolean
[C#]
bool Write();
[C++]
bool Write() = 0;
[JScript]
function Write() : Boolean;

See Also

IDataWriter Interface | IDataWriter Members | System.Data Namespace


IEditableList Interface

[To be supplied.]

[Visual Basic]
Public Interface IEditableList
   Implements IDataList, ICollection, IEnumerable
[C#]
public interface IEditableList : IDataList, ICollection,
   IEnumerable
[C++]
public __gc __interface IEditableList : public IDataList,
   ICollection, IEnumerable

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

IEditableList Members | System.Data Namespace


IEditableList Members

Methods

RemoveIndex [To be supplied.]

See Also

IEditableList Interface | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IEditableList Methods

The methods of the IEditableList interface are listed below. For a complete list of IEditableList interface members, see the IEditableList Members topic.

RemoveIndex [To be supplied.]

See Also

IEditableList Interface | System.Data Namespace


IEditableList.RemoveIndex

[To be supplied.]

[Visual Basic]
Sub RemoveIndex( _
   ByVal index As Integer _
)
[C#]
void RemoveIndex(
   int index
);
[C++]
void RemoveIndex(
   int index
) = 0;
[JScript]
function RemoveIndex(
   index : int
);

Parameters

index
[To be supplied.]

See Also

IEditableList Interface | IEditableList Members | System.Data Namespace


IEditableObject Interface

[To be supplied.]

IEditableObject

[Visual Basic]
Public Interface IEditableObject
[C#]
public interface IEditableObject
[C++]
public __gc __interface IEditableObject

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IEditableObject

Class | Description
DataRowView | Represents a customized view of a DataRow.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

IEditableObject Members | System.Data Namespace


IEditableObject Members

Methods

BeginEdit | [To be supplied.]
CancelEdit | [To be supplied.]
EndEdit | [To be supplied.]

See Also

IEditableObject Interface | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IEditableObject Methods

The methods of the IEditableObject interface are listed below. For a complete list of IEditableObject interface members, see the IEditableObject Members topic.

BeginEdit | [To be supplied.]
CancelEdit | [To be supplied.]
EndEdit | [To be supplied.]

See Also

IEditableObject Interface | System.Data Namespace


IEditableObject.BeginEdit

[To be supplied.]

[Visual Basic]
Sub BeginEdit()
[C#]
void BeginEdit();
[C++]
void BeginEdit() = 0;
[JScript]
function BeginEdit();

See Also

IEditableObject Interface | IEditableObject Members | System.Data Namespace


IEditableObject.CancelEdit

[To be supplied.]

[Visual Basic]
Sub CancelEdit()
[C#]
void CancelEdit();
[C++]
void CancelEdit() = 0;
[JScript]
function CancelEdit();

See Also

IEditableObject Interface | IEditableObject Members | System.Data Namespace


IEditableObject.EndEdit

[To be supplied.]

[Visual Basic]
Sub EndEdit()
[C#]
void EndEdit();
[C++]
void EndEdit() = 0;
[JScript]
function EndEdit();

See Also

IEditableObject Interface | IEditableObject Members | System.Data Namespace


IFilter Interface

[To be supplied.]

IFilter

[Visual Basic]
Public Interface IFilter
[C#]
public interface IFilter
[C++]
public __gc __interface IFilter

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IFilter

Class | Description
DataFilter | [To be supplied.]
RelatedView | [To be supplied.]

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

IFilter Members | System.Data Namespace


IFilter Members

Methods

Invoke [To be supplied.]

See Also

IFilter Interface | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IFilter Methods

The methods of the IFilter interface are listed below. For a complete list of IFilter interface members, see the IFilter Members topic.

Invoke [To be supplied.]

See Also

IFilter Interface | System.Data Namespace


IFilter.Invoke

[To be supplied.]

[Visual Basic]
Function Invoke( _
   ByVal row As DataRow, _
   ByVal version As DataRowVersion _
) As Boolean
[C#]
bool Invoke(
   DataRow row,
   DataRowVersion version
);
[C++]
bool Invoke(
   DataRow* row,
   DataRowVersion version
) = 0;
[JScript]
function Invoke(
   row : DataRow,
   version : DataRowVersion
) : Boolean;

Parameters

row
[To be supplied.]
version
[To be supplied.]

See Also

IFilter Interface | IFilter Members | System.Data Namespace


IIndexedList Interface

[To be supplied.]

[Visual Basic]
Public Interface IIndexedList
   Implements IList, ICollection, IEnumerable
[C#]
public interface IIndexedList : IList, ICollection, IEnumerable
[C++]
public __gc __interface IIndexedList : public IList, ICollection,
   IEnumerable

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IIndexedList

Class | Description
DataView | Represents a databindable, customized view of a DataTable for sorting, filtering, searching, editing, and navigation.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

IIndexedList Members | System.Data Namespace


IIndexedList Members

Methods

Find [To be supplied.]

See Also

IIndexedList Interface | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IIndexedList Methods

The methods of the IIndexedList interface are listed below. For a complete list of IIndexedList interface members, see the IIndexedList Members topic.

Find [To be supplied.]

See Also

IIndexedList Interface | System.Data Namespace


IIndexedList.Find

[To be supplied.]

[Visual Basic]
Function Find( _
   ByVal property As PropertyDescriptor, _
   ByVal key As Object, _
   ByVal keepIndex As Boolean _
) As Integer
[C#]
int Find(
   PropertyDescriptor property,
   object key,
   bool keepIndex
);
[C++]
int Find(
   PropertyDescriptor* property,
   Object* key,
   bool keepIndex
) = 0;
[JScript]
function Find(
   property : PropertyDescriptor,
   key : Object,
   keepIndex : Boolean
) : int;

Parameters

property
[To be supplied.]
key
[To be supplied.]
keepIndex
[To be supplied.]

See Also

IIndexedList Interface | IIndexedList Members | System.Data Namespace


IListSource Interface

[To be supplied.]

IListSource

[Visual Basic]
Public Interface IListSource
[C#]
public interface IListSource
[C++]
public __gc __interface IListSource

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IListSource

Class | Description
DataSet | Represents an in-memory cache of data.
DataTable | Represents one table of in-memory data.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

IListSource Members | System.Data Namespace


IListSource Members

Methods

GetList [To be supplied.]

See Also

IListSource Interface | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IListSource Methods

The methods of the IListSource interface are listed below. For a complete list of IListSource interface members, see the IListSource Members topic.

GetList [To be supplied.]

See Also

IListSource Interface | System.Data Namespace


IListSource.GetList

[To be supplied.]

[Visual Basic]
Function GetList() As IList
[C#]
IList GetList();
[C++]
IList* GetList() = 0;
[JScript]
function GetList() : IList;

See Also

IListSource Interface | IListSource Members | System.Data Namespace


ILiveList Interface

[To be supplied.]

[Visual Basic]
Public Interface ILiveList
   Implements IList, ICollection, IEnumerable
[C#]
public interface ILiveList : IList, ICollection, IEnumerable
[C++]
public __gc __interface ILiveList : public IList, ICollection,
   IEnumerable

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement ILiveList

Class | Description
DataView | Represents a databindable, customized view of a DataTable for sorting, filtering, searching, editing, and navigation.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

ILiveList Members | System.Data Namespace


ILiveList Members

Properties

AllowAdd | [To be supplied.]
AllowEdit | [To be supplied.]
AllowRemove | [To be supplied.]

Events

ListChanged [To be supplied.]

Event Hookup:

Methods

AddOnListChanged | [To be supplied.]
RemoveOnListChanged | [To be supplied.]

See Also

ILiveList Interface | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ILiveList Properties

The properties of the ILiveList interface are listed below. For a complete list of ILiveList interface members, see the ILiveList Members topic.

AllowAdd | [To be supplied.]
AllowEdit | [To be supplied.]
AllowRemove | [To be supplied.]

See Also

ILiveList Interface | System.Data Namespace


ILiveList.AllowAdd

[To be supplied.]

[Visual Basic]
ReadOnly Property AllowAdd As Boolean
[C#]
bool AllowAdd {get;}
[C++]
bool get_AllowAdd() = 0;
[JScript]
abstract function get AllowAdd() : Boolean;

See Also

ILiveList Interface | ILiveList Members | System.Data Namespace


ILiveList.AllowEdit

[To be supplied.]

[Visual Basic]
ReadOnly Property AllowEdit As Boolean
[C#]
bool AllowEdit {get;}
[C++]
bool get_AllowEdit() = 0;
[JScript]
abstract function get AllowEdit() : Boolean;

See Also

ILiveList Interface | ILiveList Members | System.Data Namespace


ILiveList.AllowRemove

[To be supplied.]

[Visual Basic]
ReadOnly Property AllowRemove As Boolean
[C#]
bool AllowRemove {get;}
[C++]
bool get_AllowRemove() = 0;
[JScript]
abstract function get AllowRemove() : Boolean;

See Also

ILiveList Interface | ILiveList Members | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ILiveList Methods

The methods of the ILiveList interface are listed below. For a complete list of ILiveList interface members, see the ILiveList Members topic.

Event Hookup:

AddOnListChanged | [To be supplied.]
RemoveOnListChanged | [To be supplied.]

See Also

ILiveList Interface | System.Data Namespace


ILiveList.AddOnListChanged

[To be supplied.]

[Visual Basic]
Sub AddOnListChanged( _
   ByVal handler As ListChangedEventHandler _
)
[C#]
void AddOnListChanged(
   ListChangedEventHandler handler
);
[C++]
void AddOnListChanged(
   ListChangedEventHandler* handler
) = 0;
[JScript]
function AddOnListChanged(
   handler : ListChangedEventHandler
);

Parameters

handler
[To be supplied.]

See Also

ILiveList Interface | ILiveList Members | System.Data Namespace


ILiveList.RemoveOnListChanged

[To be supplied.]

[Visual Basic]
Sub RemoveOnListChanged( _
   ByVal handler As ListChangedEventHandler _
)
[C#]
void RemoveOnListChanged(
   ListChangedEventHandler handler
);
[C++]
void RemoveOnListChanged(
   ListChangedEventHandler* handler
) = 0;
[JScript]
function RemoveOnListChanged(
   handler : ListChangedEventHandler
);

Parameters

handler
[To be supplied.]

See Also

ILiveList Interface | ILiveList Members | System.Data Namespace


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ILiveList Events

The events of the ILiveList interface are listed below. For a complete list of ILiveList interface members, see the ILiveList Members topic.

ListChanged [To be supplied.]

See Also

ILiveList Interface | System.Data Namespace


ILiveList ListChanged Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the ListChanged event.

[Visual Basic]
Private Sub ILiveListName_ListChanged( _
   ByVal sender As Object, _
   ByVal e As ListChangedEventArgs _
)
[C#]
private void ILiveListName_ListChanged(
   object sender,
   ListChangedEventArgs e
);
[C++]
private: void ILiveListName_ListChanged(
   Object* sender,
   ListChangedEventArgs* e
);
[JScript]
private ILiveListName_ListChanged(
   sender : Object,
   e : ListChangedEventArgs
);

Parameters

sender
The source of the event.
e
A ListChangedEventArgs that contains the event data. The following ListChangedEventArgs properties provide information specific to this event.
Property Description
ListChangedType
[To be supplied.]
NewIndex
[To be supplied.]
OldIndex
[To be supplied.]

See Also

ILiveList Interface | ILiveList MembersTopic | System.Data Namespace


INameTable Interface

[To be supplied.]

INameTable

[Visual Basic]
Public Interface INameTable
[C#]
public interface INameTable
[C++]
public __gc __interface INameTable

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement INameTable

Class | Description
DocumentNavigator | [To be supplied.]
DocumentReader | [To be supplied.]
MTNameTable | [To be supplied.]
NameTable | INameTable implemented as a simple hash table.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

INameTable Members | System.Data Namespace


INameTable Members

Methods

Add | Overloaded. [To be supplied.]
Get | Overloaded. [To be supplied.]

See Also

INameTable Interface | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

INameTable Methods

The methods of the INameTable interface are listed below. For a complete list of INameTable interface members, see the INameTable Members topic.

Add | Overloaded. [To be supplied.]
Get | Overloaded. [To be supplied.]

See Also

INameTable Interface | System.Data Namespace


INameTable.Add

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Function Add(Char(), Integer, Integer) As String
[C#] string Add(char[], int, int);
[C++] String* Add(__wchar_t*[], int, int) = 0;
[JScript] function Add(Char[], int, int) : String;

[To be supplied.]

[Visual Basic] Overloads Function Add(String) As String
[C#] string Add(String);
[C++] String* Add(String*) = 0;
[JScript] function Add(String) : String;

See Also

INameTable Interface | INameTable Members | System.Data Namespace


INameTable.Add (Char[], Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Function Add( _
   ByVal array() As Char, _
   ByVal offset As Integer, _
   ByVal length As Integer _
) As String
[C#]
string Add(
   char[] array,
   int offset,
   int length
);
[C++]
String* Add(
   __wchar_t* array[],
   int offset,
   int length
) = 0;
[JScript]
function Add(
   array : Char[],
   offset : int,
   length : int
) : String;

Parameters

array
[To be supplied.]
offset
[To be supplied.]
length
[To be supplied.]

See Also

INameTable Interface | INameTable Members | System.Data Namespace | INameTable.Add Overload List


INameTable.Add (String)

[To be supplied.]

[Visual Basic]
Overloads Function Add( _
   ByVal array As String _
) As String
[C#]
string Add(
   string array
);
[C++]
String* Add(
   String* array
) = 0;
[JScript]
function Add(
   array : String
) : String;

Parameters

array
[To be supplied.]

See Also

INameTable Interface | INameTable Members | System.Data Namespace | INameTable.Add Overload List


INameTable.Get

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Function Get(Char(), Integer, Integer) As String
[C#] string Get(char[], int, int);
[C++] String* Get(__wchar_t*[], int, int) = 0;
[JScript] function Get(Char[], int, int) : String;

[To be supplied.]

[Visual Basic] Overloads Function Get(String) As String
[C#] string Get(String);
[C++] String* Get(String*) = 0;
[JScript] function Get(String) : String;

See Also

INameTable Interface | INameTable Members | System.Data Namespace


INameTable.Get (Char[], Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Function Get( _
   ByVal array() As Char, _
   ByVal offset As Integer, _
   ByVal length As Integer _
) As String
[C#]
string Get(
   char[] array,
   int offset,
   int length
);
[C++]
String* Get(
   __wchar_t* array[],
   int offset,
   int length
) = 0;
[JScript]
function Get(
   array : Char[],
   offset : int,
   length : int
) : String;

Parameters

array
[To be supplied.]
offset
[To be supplied.]
length
[To be supplied.]

See Also

INameTable Interface | INameTable Members | System.Data Namespace | INameTable.Get Overload List


INameTable.Get (String)

[To be supplied.]

[Visual Basic]
Overloads Function Get( _
   ByVal array As String _
) As String
[C#]
string Get(
   string array
);
[C++]
String* Get(
   String* array
) = 0;
[JScript]
function Get(
   array : String
) : String;

Parameters

array
[To be supplied.]

See Also

INameTable Interface | INameTable Members | System.Data Namespace | INameTable.Get Overload List


IndexEventArgs Class

[To be supplied.]

Object
EventArgs
IndexEventArgs

[Visual Basic]
Public Class IndexEventArgs
   Inherits EventArgs
[C#]
public class IndexEventArgs : EventArgs
[C++]
public __gc class IndexEventArgs : public EventArgs
[JScript]
public class IndexEventArgs extends EventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

IndexEventArgs Members | System.Data Namespace


IndexEventArgs Members

Public:

Constructor

IndexEventArgs Constructor [To be supplied.]

Properties

ExtendedInfo (inherited from EventArgs) Holds a reference to an object that manages the event's state.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

index | [To be supplied.]
type | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IndexEventArgs Class | System.Data Namespace


IndexEventArgs Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal type As Integer, _
   ByVal index As Integer _
)
[C#]
public IndexEventArgs(
   int type,
   int index
);
[C++]
public: IndexEventArgs(
   int type,
   int index
);
[JScript]
public function IndexEventArgs(
   type : int,
   index : int
);

Parameters

type
[To be supplied.]
index
[To be supplied.]

See Also

IndexEventArgs Class | IndexEventArgs Members | System.Data Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IndexEventArgs Fields

The fields of the IndexEventArgs class are listed below. For a complete list of IndexEventArgs class members, see the IndexEventArgs Members topic.

Public:

index | [To be supplied.]
type | [To be supplied.]

See Also

IndexEventArgs Class | System.Data Namespace


IndexEventArgs.index

[To be supplied.]

[Visual Basic]
Public ReadOnly index As Integer
[C#]
public readonly int index;
[C++]
public: readonly int index;
[JScript]
public var index : int;

See Also

IndexEventArgs Class | IndexEventArgs Members | System.Data Namespace


IndexEventArgs.type

[To be supplied.]

[Visual Basic]
Public ReadOnly type As Integer
[C#]
public readonly int type;
[C++]
public: readonly int type;
[JScript]
public var type : int;

See Also

IndexEventArgs Class | IndexEventArgs Members | System.Data Namespace


InRowChangingEventException Class

[To be supplied.]

Object
Exception
SystemException
InRowChangingEventException

[Visual Basic]
Public Class InRowChangingEventException
   Inherits SystemException
[C#]
public class InRowChangingEventException : SystemException
[C++]
public __gc class InRowChangingEventException : public
   SystemException
[JScript]
public class InRowChangingEventException extends SystemException

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

InRowChangingEventException Members | System.Data Namespace


InRowChangingEventException Members

Public:

Constructor

InRowChangingEventException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

InRowChangingEventException Class | System.Data Namespace


InRowChangingEventException Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public InRowChangingEventException();
[C++] public: InRowChangingEventException();
[JScript] public function InRowChangingEventException();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public InRowChangingEventException(String);
[C++] public: InRowChangingEventException(String*);
[JScript] public function InRowChangingEventException(String);

See Also

InRowChangingEventException Class | InRowChangingEventException Members | System.Data Namespace


InRowChangingEventException Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public InRowChangingEventException();
[C++]
public: InRowChangingEventException();
[JScript]
public function InRowChangingEventException();

See Also

InRowChangingEventException Class | InRowChangingEventException Members | System.Data Namespace | InRowChangingEventException Constructor Overload List


InRowChangingEventException Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal s As String _
)
[C#]
public InRowChangingEventException(
   string s
);
[C++]
public: InRowChangingEventException(
   String* s
);
[JScript]
public function InRowChangingEventException(
   s : String
);

Parameters

s
[To be supplied.]

See Also

InRowChangingEventException Class | InRowChangingEventException Members | System.Data Namespace | InRowChangingEventException Constructor Overload List


InvalidBindingException Class

[To be supplied.]

Object
Exception
SystemException
InvalidBindingException

[Visual Basic]
Public Class InvalidBindingException
   Inherits SystemException
[C#]
public class InvalidBindingException : SystemException
[C++]
public __gc class InvalidBindingException : public SystemException
[JScript]
public class InvalidBindingException extends SystemException

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

InvalidBindingException Members | System.Data Namespace


InvalidBindingException Members

Public:

Constructor

InvalidBindingException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

InvalidBindingException Class | System.Data Namespace


InvalidBindingException Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public InvalidBindingException();
[C++] public: InvalidBindingException();
[JScript] public function InvalidBindingException();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public InvalidBindingException(String);
[C++] public: InvalidBindingException(String*);
[JScript] public function InvalidBindingException(String);

See Also

InvalidBindingException Class | InvalidBindingException Members | System.Data Namespace


InvalidBindingException Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public InvalidBindingException();
[C++]
public: InvalidBindingException();
[JScript]
public function InvalidBindingException();

See Also

InvalidBindingException Class | InvalidBindingException Members | System.Data Namespace | InvalidBindingException Constructor Overload List


InvalidBindingException Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal s As String _
)
[C#]
public InvalidBindingException(
   string s
);
[C++]
public: InvalidBindingException(
   String* s
);
[JScript]
public function InvalidBindingException(
   s : String
);

Parameters

s
[To be supplied.]

See Also

InvalidBindingException Class | InvalidBindingException Members | System.Data Namespace | InvalidBindingException Constructor Overload List


InvalidConstraintException Class

[To be supplied.]

Object
Exception
SystemException
InvalidConstraintException

[Visual Basic]
Public Class InvalidConstraintException
   Inherits SystemException
[C#]
public class InvalidConstraintException : SystemException
[C++]
public __gc class InvalidConstraintException : public
   SystemException
[JScript]
public class InvalidConstraintException extends SystemException

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

InvalidConstraintException Members | System.Data Namespace


InvalidConstraintException Members

Public:

Constructor

InvalidConstraintException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

InvalidConstraintException Class | System.Data Namespace


InvalidConstraintException Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public InvalidConstraintException();
[C++] public: InvalidConstraintException();
[JScript] public function InvalidConstraintException();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public InvalidConstraintException(String);
[C++] public: InvalidConstraintException(String*);
[JScript] public function InvalidConstraintException(String);

See Also

InvalidConstraintException Class | InvalidConstraintException Members | System.Data Namespace


InvalidConstraintException Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public InvalidConstraintException();
[C++]
public: InvalidConstraintException();
[JScript]
public function InvalidConstraintException();

See Also

InvalidConstraintException Class | InvalidConstraintException Members | System.Data Namespace | InvalidConstraintException Constructor Overload List


InvalidConstraintException Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal s As String _
)
[C#]
public InvalidConstraintException(
   string s
);
[C++]
public: InvalidConstraintException(
   String* s
);
[JScript]
public function InvalidConstraintException(
   s : String
);

Parameters

s
[To be supplied.]

See Also

InvalidConstraintException Class | InvalidConstraintException Members | System.Data Namespace | InvalidConstraintException Constructor Overload List


InvalidExpressionException Class

[To be supplied.]

Object
Exception
SystemException
DataException
InvalidExpressionException

[Visual Basic]
Public Class InvalidExpressionException
   Inherits DataException
[C#]
public class InvalidExpressionException : DataException
[C++]
public __gc class InvalidExpressionException : public DataException
[JScript]
public class InvalidExpressionException extends DataException

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

InvalidExpressionException Members | System.Data Namespace


InvalidExpressionException Members

Public:

Constructor

InvalidExpressionException Constructor [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

InvalidExpressionException Class | System.Data Namespace


InvalidExpressionException Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public InvalidExpressionException();
[C++]
public: InvalidExpressionException();
[JScript]
public function InvalidExpressionException();

See Also

InvalidExpressionException Class | InvalidExpressionException Members | System.Data Namespace


InvalidRowsException Class

[To be supplied.]

Object
Exception
InvalidRowsException

[Visual Basic]
Public Class InvalidRowsException
   Inherits Exception
[C#]
public class InvalidRowsException : Exception
[C++]
public __gc class InvalidRowsException : public Exception
[JScript]
public class InvalidRowsException extends Exception

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

InvalidRowsException Members | System.Data Namespace


InvalidRowsException Members

Public:

Constructor

InvalidRowsException Constructor [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Rows | [To be supplied.]
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

InvalidRowsException Class | System.Data Namespace


InvalidRowsException Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal rows() As DataRow, _
   ByVal exceptionMessage As String _
)
[C#]
public InvalidRowsException(
   DataRow[] rows,
   string exceptionMessage
);
[C++]
public: InvalidRowsException(
   DataRow* rows[],
   String* exceptionMessage
);
[JScript]
public function InvalidRowsException(
   rows : DataRow[],
   exceptionMessage : String
);

Parameters

rows
[To be supplied.]
exceptionMessage
[To be supplied.]

See Also

InvalidRowsException Class | InvalidRowsException Members | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

InvalidRowsException Properties

The properties of the InvalidRowsException class are listed below. For a complete list of InvalidRowsException class members, see the InvalidRowsException Members topic.

Public:

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Rows | [To be supplied.]
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

See Also

InvalidRowsException Class | System.Data Namespace


InvalidRowsException.Rows

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Rows As DataRow ()
[C#]
public DataRow[] Rows {get;}
[C++]
public: __property DataRow* get_Rows();
[JScript]
public function get Rows() : DataRow[];

See Also

InvalidRowsException Class | InvalidRowsException Members | System.Data Namespace


IPresentedProperties Interface

[To be supplied.]

IPresentedProperties

[Visual Basic]
Public Interface IPresentedProperties
[C#]
public interface IPresentedProperties
[C++]
public __gc __interface IPresentedProperties

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

IPresentedProperties Members | System.Data Namespace


IPresentedProperties Members

Methods

GetPresentedIPropertyDescriptor | [To be supplied.]
GetPresentedIPropertyDescriptors | [To be supplied.]
GetPresentedProperty | [To be supplied.]
SetPresentedProperty | [To be supplied.]

See Also

IPresentedProperties Interface | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IPresentedProperties Methods

The methods of the IPresentedProperties interface are listed below. For a complete list of IPresentedProperties interface members, see the IPresentedProperties Members topic.

GetPresentedIPropertyDescriptor | [To be supplied.]
GetPresentedIPropertyDescriptors | [To be supplied.]
GetPresentedProperty | [To be supplied.]
SetPresentedProperty | [To be supplied.]

See Also

IPresentedProperties Interface | System.Data Namespace


IPresentedProperties.GetPresentedIPropertyDescriptor

[To be supplied.]

[Visual Basic]
Function GetPresentedIPropertyDescriptor( _
   ByVal property As String _
) As IPropertyDescriptor
[C#]
IPropertyDescriptor GetPresentedIPropertyDescriptor(
   string property
);
[C++]
IPropertyDescriptor* GetPresentedIPropertyDescriptor(
   String* property
) = 0;
[JScript]
function GetPresentedIPropertyDescriptor(
   property : String
) : IPropertyDescriptor;

Parameters

property
[To be supplied.]

See Also

IPresentedProperties Interface | IPresentedProperties Members | System.Data Namespace


IPresentedProperties.GetPresentedIPropertyDescriptors

[To be supplied.]

[Visual Basic]
Function GetPresentedIPropertyDescriptors() As IPropertyDescriptor ()
[C#]
IPropertyDescriptor[] GetPresentedIPropertyDescriptors();
[C++]
IPropertyDescriptor* GetPresentedIPropertyDescriptors() [] = 0;
[JScript]
function GetPresentedIPropertyDescriptors() : IPropertyDescriptor[];

See Also

IPresentedProperties Interface | IPresentedProperties Members | System.Data Namespace


IPresentedProperties.GetPresentedProperty

[To be supplied.]

[Visual Basic]
Function GetPresentedProperty( _
   ByVal property As String _
) As Object
[C#]
object GetPresentedProperty(
   string property
);
[C++]
Object* GetPresentedProperty(
   String* property
) = 0;
[JScript]
function GetPresentedProperty(
   property : String
) : Object;

Parameters

property
[To be supplied.]

See Also

IPresentedProperties Interface | IPresentedProperties Members | System.Data Namespace


IPresentedProperties.SetPresentedProperty

[To be supplied.]

[Visual Basic]
Sub SetPresentedProperty( _
   ByVal property As String, _
   ByVal value As Object _
)
[C#]
void SetPresentedProperty(
   string property,
   object value
);
[C++]
void SetPresentedProperty(
   String* property,
   Object* value
) = 0;
[JScript]
function SetPresentedProperty(
   property : String,
   value : Object
);

Parameters

property
[To be supplied.]
value
[To be supplied.]

See Also

IPresentedProperties Interface | IPresentedProperties Members | System.Data Namespace


IPropertyDescriptor Interface

[To be supplied.]

IPropertyDescriptor

[Visual Basic]
Public Interface IPropertyDescriptor
[C#]
public interface IPropertyDescriptor
[C++]
public __gc __interface IPropertyDescriptor

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IPropertyDescriptor

Class | Description
FieldDescriptor | [To be supplied.]

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

IPropertyDescriptor Members | System.Data Namespace


IPropertyDescriptor Members

Properties

DisplayName | [To be supplied.]
IsReadOnly | [To be supplied.]
MappableType | [To be supplied.]
Name | [To be supplied.]
PropertyType | [To be supplied.]

See Also

IPropertyDescriptor Interface | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IPropertyDescriptor Properties

The properties of the IPropertyDescriptor interface are listed below. For a complete list of IPropertyDescriptor interface members, see the IPropertyDescriptor Members topic.

DisplayName | [To be supplied.]
IsReadOnly | [To be supplied.]
MappableType | [To be supplied.]
Name | [To be supplied.]
PropertyType | [To be supplied.]

See Also

IPropertyDescriptor Interface | System.Data Namespace


IPropertyDescriptor.DisplayName

[To be supplied.]

[Visual Basic]
ReadOnly Property DisplayName As String
[C#]
string DisplayName {get;}
[C++]
String* get_DisplayName() = 0;
[JScript]
abstract function get DisplayName() : String;

See Also

IPropertyDescriptor Interface | IPropertyDescriptor Members | System.Data Namespace


IPropertyDescriptor.IsReadOnly

[To be supplied.]

[Visual Basic]
ReadOnly Property IsReadOnly As Boolean
[C#]
bool IsReadOnly {get;}
[C++]
bool get_IsReadOnly() = 0;
[JScript]
abstract function get IsReadOnly() : Boolean;

See Also

IPropertyDescriptor Interface | IPropertyDescriptor Members | System.Data Namespace


IPropertyDescriptor.MappableType

[To be supplied.]

[Visual Basic]
ReadOnly Property MappableType As Object
[C#]
object MappableType {get;}
[C++]
Object* get_MappableType() = 0;
[JScript]
abstract function get MappableType() : Object;

See Also

IPropertyDescriptor Interface | IPropertyDescriptor Members | System.Data Namespace


IPropertyDescriptor.Name

[To be supplied.]

[Visual Basic]
ReadOnly Property Name As String
[C#]
string Name {get;}
[C++]
String* get_Name() = 0;
[JScript]
abstract function get Name() : String;

See Also

IPropertyDescriptor Interface | IPropertyDescriptor Members | System.Data Namespace


IPropertyDescriptor.PropertyType

[To be supplied.]

[Visual Basic]
ReadOnly Property PropertyType As Type
[C#]
Type PropertyType {get;}
[C++]
Type* get_PropertyType() = 0;
[JScript]
abstract function get PropertyType() : Type;

See Also

IPropertyDescriptor Interface | IPropertyDescriptor Members | System.Data Namespace


IsolationLevel Enumeration

[To be supplied.]

[Visual Basic]
Public Enum IsolationLevel
[C#]
public enum IsolationLevel
[C++]
public enum IsolationLevel

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Chaos | [To be supplied.]
ReadCommitted | [To be supplied.]
ReadUncommitted | [To be supplied.]
RepeatableRead | [To be supplied.]
Serializable | [To be supplied.]
Unspecified | [To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace


ISortedList Interface

[To be supplied.]

[Visual Basic]
Public Interface ISortedList
   Implements IList, ICollection, IEnumerable
[C#]
public interface ISortedList : IList, ICollection, IEnumerable
[C++]
public __gc __interface ISortedList : public IList, ICollection,
   IEnumerable

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement ISortedList

Class | Description
DataView | Represents a databindable, customized view of a DataTable for sorting, filtering, searching, editing, and navigation.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

ISortedList Members | System.Data Namespace


ISortedList Members

Methods

GetSortDirection | [To be supplied.]
GetSortProperty | [To be supplied.]
SetSort | [To be supplied.]

See Also

ISortedList Interface | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ISortedList Methods

The methods of the ISortedList interface are listed below. For a complete list of ISortedList interface members, see the ISortedList Members topic.

GetSortDirection | [To be supplied.]
GetSortProperty | [To be supplied.]
SetSort | [To be supplied.]

See Also

ISortedList Interface | System.Data Namespace


ISortedList.GetSortDirection

[To be supplied.]

[Visual Basic]
Function GetSortDirection() As SortDirection
[C#]
SortDirection GetSortDirection();
[C++]
SortDirection GetSortDirection() = 0;
[JScript]
function GetSortDirection() : SortDirection;

See Also

ISortedList Interface | ISortedList Members | System.Data Namespace


ISortedList.GetSortProperty

[To be supplied.]

[Visual Basic]
Function GetSortProperty() As PropertyDescriptor
[C#]
PropertyDescriptor GetSortProperty();
[C++]
PropertyDescriptor* GetSortProperty() = 0;
[JScript]
function GetSortProperty() : PropertyDescriptor;

See Also

ISortedList Interface | ISortedList Members | System.Data Namespace


ISortedList.SetSort

[To be supplied.]

[Visual Basic]
Sub SetSort( _
   ByVal property As PropertyDescriptor, _
   ByVal direction As SortDirection _
)
[C#]
void SetSort(
   PropertyDescriptor property,
   SortDirection direction
);
[C++]
void SetSort(
   PropertyDescriptor* property,
   SortDirection direction
) = 0;
[JScript]
function SetSort(
   property : PropertyDescriptor,
   direction : SortDirection
);

Parameters

property
[To be supplied.]
direction
[To be supplied.]

See Also

ISortedList Interface | ISortedList Members | System.Data Namespace


ITableMapping Interface

[To be supplied.]

ITableMapping

[Visual Basic]
Public Interface ITableMapping
[C#]
public interface ITableMapping
[C++]
public __gc __interface ITableMapping

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement ITableMapping

Class | Description
DataTableMapping | [To be supplied.]

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

ITableMapping Members | System.Data Namespace


ITableMapping Members

Properties

ColumnMappings | [To be supplied.]
DataSetTable | Case-Insensitive
Parent | [To be supplied.]
SourceTable | Case-Sensitive

See Also

ITableMapping Interface | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ITableMapping Properties

The properties of the ITableMapping interface are listed below. For a complete list of ITableMapping interface members, see the ITableMapping Members topic.

ColumnMappings | [To be supplied.]
DataSetTable | Case-Insensitive
Parent | [To be supplied.]
SourceTable | Case-Sensitive

See Also

ITableMapping Interface | System.Data Namespace


ITableMapping.ColumnMappings

[To be supplied.]

[Visual Basic]
ReadOnly Property ColumnMappings As IColumnMappings
[C#]
IColumnMappings ColumnMappings {get;}
[C++]
IColumnMappings* get_ColumnMappings() = 0;
[JScript]
abstract function get ColumnMappings() : IColumnMappings;

See Also

ITableMapping Interface | ITableMapping Members | System.Data Namespace


ITableMapping.DataSetTable

Case-Insensitive

[Visual Basic]
Property DataSetTable As String
[C#]
string DataSetTable {get; set;}
[C++]
String* get_DataSetTable() = 0;void set_DataSetTable(String*) = 0;
[JScript]
abstract function get DataSetTable() : String;
public abstract function set DataSetTable(String);

See Also

ITableMapping Interface | ITableMapping Members | System.Data Namespace


ITableMapping.Parent

[To be supplied.]

[Visual Basic]
ReadOnly Property Parent As Object
[C#]
object Parent {get;}
[C++]
Object* get_Parent() = 0;
[JScript]
abstract function get Parent() : Object;

See Also

ITableMapping Interface | ITableMapping Members | System.Data Namespace


ITableMapping.SourceTable

Case-Sensitive

[Visual Basic]
Property SourceTable As String
[C#]
string SourceTable {get; set;}
[C++]
String* get_SourceTable() = 0;void set_SourceTable(String*) = 0;
[JScript]
abstract function get SourceTable() : String;
public abstract function set SourceTable(String);

See Also

ITableMapping Interface | ITableMapping Members | System.Data Namespace


ITableMappings Interface

[To be supplied.]

[Visual Basic]
Public Interface ITableMappings
   Implements IList, ICollection, IEnumerable
[C#]
public interface ITableMappings : IList, ICollection, IEnumerable
[C++]
public __gc __interface ITableMappings : public IList, ICollection,
   IEnumerable

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement ITableMappings

Class | Description
DataTableMappings | table mapping collection

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

ITableMappings Members | System.Data Namespace


ITableMappings Members

Properties

All | [To be supplied.]
Item | [To be supplied.] In C#, this member is the indexer for the ITableMappings class.
Parent | [To be supplied.]

Methods

Add | [To be supplied.]
Contains | [To be supplied.]
GetByDataSetTable | [To be supplied.]
IndexOf | [To be supplied.]
RemoveAt | [To be supplied.]

See Also

ITableMappings Interface | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ITableMappings Properties

The properties of the ITableMappings interface are listed below. For a complete list of ITableMappings interface members, see the ITableMappings Members topic.

All | [To be supplied.]
Item | [To be supplied.] In C#, this member is the indexer for the ITableMappings class.
Parent | [To be supplied.]

See Also

ITableMappings Interface | System.Data Namespace


ITableMappings.All

[To be supplied.]

[Visual Basic]
Property All As ITableMapping ()
[C#]
ITableMapping[] All {get; set;}
[C++]
ITableMapping* get_All() = 0;void set_All(ITableMapping*[]) = 0;
[JScript]
abstract function get All() : ITableMapping[];
public abstract function set All(ITableMapping[]);

See Also

ITableMappings Interface | ITableMappings Members | System.Data Namespace


ITableMappings.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the ITableMappings class.

[Visual Basic]
Default Property Item( _
   ByVal index As String _
) As Object
[C#]
object this[
   string index
] {get; set;}
[C++]
Object* get_Item(
   String* index
) = 0;void set_Item(
   String* index,
   Object*
) = 0;
[JScript]
abstract returnValue = ITableMappingsObject.Item(index);
ITableMappingsObject.Item(index) = returnValue;
-or-
abstract returnValue = ITableMappingsObject(index);
ITableMappingsObject(index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
[To be supplied.]

Parameters [Visual Basic, C#, C++]

index
[To be supplied.]

See Also

ITableMappings Interface | ITableMappings Members | System.Data Namespace


ITableMappings.Parent

[To be supplied.]

[Visual Basic]
ReadOnly Property Parent As Object
[C#]
object Parent {get;}
[C++]
Object* get_Parent() = 0;
[JScript]
abstract function get Parent() : Object;

See Also

ITableMappings Interface | ITableMappings Members | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ITableMappings Methods

The methods of the ITableMappings interface are listed below. For a complete list of ITableMappings interface members, see the ITableMappings Members topic.

Add | [To be supplied.]
Contains | [To be supplied.]
GetByDataSetTable | [To be supplied.]
IndexOf | [To be supplied.]
RemoveAt | [To be supplied.]

See Also

ITableMappings Interface | System.Data Namespace


ITableMappings.Add

[To be supplied.]

[Visual Basic]
Function Add( _
   ByVal sourceTableName As String, _
   ByVal dataSetTableName As String _
) As ITableMapping
[C#]
ITableMapping Add(
   string sourceTableName,
   string dataSetTableName
);
[C++]
ITableMapping* Add(
   String* sourceTableName,
   String* dataSetTableName
) = 0;
[JScript]
function Add(
   sourceTableName : String,
   dataSetTableName : String
) : ITableMapping;

Parameters

sourceTableName
Case-Sensitive
dataSetTableName
Case-Insensitive

See Also

ITableMappings Interface | ITableMappings Members | System.Data Namespace


ITableMappings.Contains

[To be supplied.]

[Visual Basic]
Function Contains( _
   ByVal sourceTableName As String _
) As Boolean
[C#]
bool Contains(
   string sourceTableName
);
[C++]
bool Contains(
   String* sourceTableName
) = 0;
[JScript]
function Contains(
   sourceTableName : String
) : Boolean;

Parameters

sourceTableName
Case-Sensitive

See Also

ITableMappings Interface | ITableMappings Members | System.Data Namespace


ITableMappings.GetByDataSetTable

[To be supplied.]

[Visual Basic]
Function GetByDataSetTable( _
   ByVal dataSetTableName As String _
) As ITableMapping
[C#]
ITableMapping GetByDataSetTable(
   string dataSetTableName
);
[C++]
ITableMapping* GetByDataSetTable(
   String* dataSetTableName
) = 0;
[JScript]
function GetByDataSetTable(
   dataSetTableName : String
) : ITableMapping;

Parameters

dataSetTableName
Case-Insensitive

See Also

ITableMappings Interface | ITableMappings Members | System.Data Namespace


ITableMappings.IndexOf

[To be supplied.]

[Visual Basic]
Function IndexOf( _
   ByVal sourceTableName As String _
) As Integer
[C#]
int IndexOf(
   string sourceTableName
);
[C++]
int IndexOf(
   String* sourceTableName
) = 0;
[JScript]
function IndexOf(
   sourceTableName : String
) : int;

Parameters

sourceTableName
Case-Sensitive

See Also

ITableMappings Interface | ITableMappings Members | System.Data Namespace


ITableMappings.RemoveAt

[To be supplied.]

[Visual Basic]
Sub RemoveAt( _
   ByVal sourceTableName As String _
)
[C#]
void RemoveAt(
   string sourceTableName
);
[C++]
void RemoveAt(
   String* sourceTableName
) = 0;
[JScript]
function RemoveAt(
   sourceTableName : String
);

Parameters

sourceTableName
Case-Sensitive

See Also

ITableMappings Interface | ITableMappings Members | System.Data Namespace


ITypedElements Interface

[To be supplied.]

ITypedElements

[Visual Basic]
Public Interface ITypedElements
[C#]
public interface ITypedElements
[C++]
public __gc __interface ITypedElements

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

ITypedElements Members | System.Data Namespace


ITypedElements Members

Methods

GetElementProperties [To be supplied.]

See Also

ITypedElements Interface | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ITypedElements Methods

The methods of the ITypedElements interface are listed below. For a complete list of ITypedElements interface members, see the ITypedElements Members topic.

GetElementProperties [To be supplied.]

See Also

ITypedElements Interface | System.Data Namespace


ITypedElements.GetElementProperties

[To be supplied.]

[Visual Basic]
Function GetElementProperties() As IPropertyDescriptor ()
[C#]
IPropertyDescriptor[] GetElementProperties();
[C++]
IPropertyDescriptor* GetElementProperties() [] = 0;
[JScript]
function GetElementProperties() : IPropertyDescriptor[];

See Also

ITypedElements Interface | ITypedElements Members | System.Data Namespace


ITypedList Interface

[To be supplied.]

ITypedList

[Visual Basic]
Public Interface ITypedList
[C#]
public interface ITypedList
[C++]
public __gc __interface ITypedList

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement ITypedList

Class | Description
DataSetView | Represents a view of a DataSet with individual filters automatically set on each of its tables.
DataView | Represents a databindable, customized view of a DataTable for sorting, filtering, searching, editing, and navigation.
PagedDataSource | This class provides a wrapper over an ICollection datasource to implement paging semantics or 'paged views' on top of the underlying datasource. It uses the best available interface to enumerate over the data belonging to the current page. If the underlying datasource supports indexed access (like Array and IList), this wrapper uses it. Otherwise it falls back on IEnumerable.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

ITypedList Members | System.Data Namespace


ITypedList Members

Methods

GetItemProperties | [To be supplied.]
GetListName | [To be supplied.]

See Also

ITypedList Interface | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ITypedList Methods

The methods of the ITypedList interface are listed below. For a complete list of ITypedList interface members, see the ITypedList Members topic.

GetItemProperties | [To be supplied.]
GetListName | [To be supplied.]

See Also

ITypedList Interface | System.Data Namespace


ITypedList.GetItemProperties

[To be supplied.]

[Visual Basic]
Function GetItemProperties( _
   ByVal listAccessors() As PropertyDescriptor _
) As PropertyDescriptorCollection
[C#]
PropertyDescriptorCollection GetItemProperties(
   PropertyDescriptor[] listAccessors
);
[C++]
PropertyDescriptorCollection* GetItemProperties(
   PropertyDescriptor* listAccessors[]
) = 0;
[JScript]
function GetItemProperties(
   listAccessors : PropertyDescriptor[]
) : PropertyDescriptorCollection;

Parameters

listAccessors
[To be supplied.]

See Also

ITypedList Interface | ITypedList Members | System.Data Namespace


ITypedList.GetListName

[To be supplied.]

[Visual Basic]
Function GetListName( _
   ByVal listAccessors() As PropertyDescriptor _
) As String
[C#]
string GetListName(
   PropertyDescriptor[] listAccessors
);
[C++]
String* GetListName(
   PropertyDescriptor* listAccessors[]
) = 0;
[JScript]
function GetListName(
   listAccessors : PropertyDescriptor[]
) : String;

Parameters

listAccessors
[To be supplied.]

See Also

ITypedList Interface | ITypedList Members | System.Data Namespace


ITypedObject Interface

[To be supplied.]

ITypedObject

[Visual Basic]
Public Interface ITypedObject
[C#]
public interface ITypedObject
[C++]
public __gc __interface ITypedObject

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement ITypedObject

Class | Description
DataRowView | Represents a customized view of a DataRow.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

ITypedObject Members | System.Data Namespace


ITypedObject Members

Properties

Item [To be supplied.]

In C#, this member is the indexer for the ITypedObject class.

See Also

ITypedObject Interface | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ITypedObject Properties

The properties of the ITypedObject interface are listed below. For a complete list of ITypedObject interface members, see the ITypedObject Members topic.

Item [To be supplied.]

In C#, this member is the indexer for the ITypedObject class.

See Also

ITypedObject Interface | System.Data Namespace


ITypedObject.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the ITypedObject class.

[Visual Basic]
Default Property Item( _
   ByVal propertyName As String _
) As Object
[C#]
object this[
   string propertyName
] {get; set;}
[C++]
Object* get_Item(
   String* propertyName
) = 0;void set_Item(
   String* propertyName,
   Object*
) = 0;
[JScript]
abstract returnValue = ITypedObjectObject.Item(propertyName);
ITypedObjectObject.Item(propertyName) = returnValue;
-or-
abstract returnValue = ITypedObjectObject(propertyName);
ITypedObjectObject(propertyName) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

propertyName
[To be supplied.]

Parameters [Visual Basic, C#, C++]

propertyName
[To be supplied.]

See Also

ITypedObject Interface | ITypedObject Members | System.Data Namespace


IUriResolver Interface

[To be supplied.]

IUriResolver

[Visual Basic]
Public Interface IUriResolver
[C#]
public interface IUriResolver
[C++]
public __gc __interface IUriResolver

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IUriResolver

Class | Description
UriResolver | [To be supplied.]

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

IUriResolver Members | System.Data Namespace


IUriResolver Members

Methods

GetResource [To be supplied.]

See Also

IUriResolver Interface | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IUriResolver Methods

The methods of the IUriResolver interface are listed below. For a complete list of IUriResolver interface members, see the IUriResolver Members topic.

GetResource [To be supplied.]

See Also

IUriResolver Interface | System.Data Namespace


IUriResolver.GetResource

[To be supplied.]

[Visual Basic]
Function GetResource( _
   ByVal baseUri As String, _
   ByVal relativeUri As String, _
   ByVal role As String, _
   ByVal type As Type, _
   ByRef resolvedUri As String _
) As Object
[C#]
object GetResource(
   string baseUri,
   string relativeUri,
   string role,
   Type type,
   ref string resolvedUri
);
[C++]
Object* GetResource(
   String* baseUri,
   String* relativeUri,
   String* role,
   Type* type,
   String** resolvedUri
) = 0;
[JScript]
function GetResource(
   baseUri : String,
   relativeUri : String,
   role : String,
   type : Type,
   resolvedUri : String
) : Object;

Parameters

baseUri
[To be supplied.]
relativeUri
[To be supplied.]
role
[To be supplied.]
type
[To be supplied.]
resolvedUri
[To be supplied.]

See Also

IUriResolver Interface | IUriResolver Members | System.Data Namespace


ListChangedEventArgs Class

[To be supplied.]

Object
EventArgs
ListChangedEventArgs

[Visual Basic]
Public Class ListChangedEventArgs
   Inherits EventArgs
[C#]
public class ListChangedEventArgs : EventArgs
[C++]
public __gc class ListChangedEventArgs : public EventArgs
[JScript]
public class ListChangedEventArgs extends EventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

ListChangedEventArgs Members | System.Data Namespace


ListChangedEventArgs Members

Public:

Constructor

ListChangedEventArgs Constructor Overloaded. [To be supplied.]

Properties

ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
ListChangedType | [To be supplied.]
NewIndex | [To be supplied.]
OldIndex | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ListChangedEventArgs Class | System.Data Namespace


ListChangedEventArgs Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(ListChangedType, Integer)
[C#] public ListChangedEventArgs(ListChangedType, int);
[C++] public: ListChangedEventArgs(ListChangedType, int);
[JScript] public function ListChangedEventArgs(ListChangedType, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(ListChangedType, Integer, Integer)
[C#] public ListChangedEventArgs(ListChangedType, int, int);
[C++] public: ListChangedEventArgs(ListChangedType, int, int);
[JScript] public function ListChangedEventArgs(ListChangedType, int, int);

See Also

ListChangedEventArgs Class | ListChangedEventArgs Members | System.Data Namespace


ListChangedEventArgs Constructor (ListChangedType, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal listChangedType As ListChangedType, _
   ByVal newIndex As Integer _
)
[C#]
public ListChangedEventArgs(
   ListChangedType listChangedType,
   int newIndex
);
[C++]
public: ListChangedEventArgs(
   ListChangedType listChangedType,
   int newIndex
);
[JScript]
public function ListChangedEventArgs(
   listChangedType : ListChangedType,
   newIndex : int
);

Parameters

listChangedType
[To be supplied.]
newIndex
[To be supplied.]

See Also

ListChangedEventArgs Class | ListChangedEventArgs Members | System.Data Namespace | ListChangedEventArgs Constructor Overload List


ListChangedEventArgs Constructor (ListChangedType, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal listChangedType As ListChangedType, _
   ByVal newIndex As Integer, _
   ByVal oldIndex As Integer _
)
[C#]
public ListChangedEventArgs(
   ListChangedType listChangedType,
   int newIndex,
   int oldIndex
);
[C++]
public: ListChangedEventArgs(
   ListChangedType listChangedType,
   int newIndex,
   int oldIndex
);
[JScript]
public function ListChangedEventArgs(
   listChangedType : ListChangedType,
   newIndex : int,
   oldIndex : int
);

Parameters

listChangedType
[To be supplied.]
newIndex
[To be supplied.]
oldIndex
[To be supplied.]

See Also

ListChangedEventArgs Class | ListChangedEventArgs Members | System.Data Namespace | ListChangedEventArgs Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ListChangedEventArgs Properties

The properties of the ListChangedEventArgs class are listed below. For a complete list of ListChangedEventArgs class members, see the ListChangedEventArgs Members topic.

Public:

ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
ListChangedType | [To be supplied.]
NewIndex | [To be supplied.]
OldIndex | [To be supplied.]

See Also

ListChangedEventArgs Class | System.Data Namespace


ListChangedEventArgs.ListChangedType

[To be supplied.]

[Visual Basic]
Public ReadOnly Property ListChangedType As ListChangedType
[C#]
public ListChangedType ListChangedType {get;}
[C++]
public: __property ListChangedType get_ListChangedType();
[JScript]
public function get ListChangedType() : ListChangedType;

See Also

ListChangedEventArgs Class | ListChangedEventArgs Members | System.Data Namespace


ListChangedEventArgs.NewIndex

[To be supplied.]

[Visual Basic]
Public ReadOnly Property NewIndex As Integer
[C#]
public int NewIndex {get;}
[C++]
public: __property int get_NewIndex();
[JScript]
public function get NewIndex() : int;

See Also

ListChangedEventArgs Class | ListChangedEventArgs Members | System.Data Namespace


ListChangedEventArgs.OldIndex

[To be supplied.]

[Visual Basic]
Public ReadOnly Property OldIndex As Integer
[C#]
public int OldIndex {get;}
[C++]
public: __property int get_OldIndex();
[JScript]
public function get OldIndex() : int;

See Also

ListChangedEventArgs Class | ListChangedEventArgs Members | System.Data Namespace


ListChangedEventHandler Delegate

[To be supplied.]

[Visual Basic]
Public Delegate Sub ListChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As ListChangedEventArgs _
)
[C#]
public delegate void ListChangedEventHandler(
   object sender,
   ListChangedEventArgs e
);
[C++]
public __gc __delegate void ListChangedEventHandler(
   Object* sender,
   ListChangedEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the ListChangedEventHandler delegate declaration.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace


ListChangedType Enumeration

[To be supplied.]

[Visual Basic]
Public Enum ListChangedType
[C#]
public enum ListChangedType
[C++]
public enum ListChangedType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
ItemAdded | [To be supplied.]
ItemChanged | [To be supplied.]
ItemDeleted | [To be supplied.]
ItemMoved | [To be supplied.]
Reset | [To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace


MergeFailedEventArgs Class

[To be supplied.]

Object
EventArgs
MergeFailedEventArgs

[Visual Basic]
Public Class MergeFailedEventArgs
   Inherits EventArgs
[C#]
public class MergeFailedEventArgs : EventArgs
[C++]
public __gc class MergeFailedEventArgs : public EventArgs
[JScript]
public class MergeFailedEventArgs extends EventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

MergeFailedEventArgs Members | System.Data Namespace


MergeFailedEventArgs Members

Public:

Constructor

MergeFailedEventArgs Constructor [To be supplied.]

Properties

Conflict | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
Table | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MergeFailedEventArgs Class | System.Data Namespace


MergeFailedEventArgs Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal table As DataTable, _
   ByVal conflict As String _
)
[C#]
public MergeFailedEventArgs(
   DataTable table,
   string conflict
);
[C++]
public: MergeFailedEventArgs(
   DataTable* table,
   String* conflict
);
[JScript]
public function MergeFailedEventArgs(
   table : DataTable,
   conflict : String
);

Parameters

table
[To be supplied.]
conflict
[To be supplied.]

See Also

MergeFailedEventArgs Class | MergeFailedEventArgs Members | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MergeFailedEventArgs Properties

The properties of the MergeFailedEventArgs class are listed below. For a complete list of MergeFailedEventArgs class members, see the MergeFailedEventArgs Members topic.

Public:

Conflict | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
Table | [To be supplied.]

See Also

MergeFailedEventArgs Class | System.Data Namespace


MergeFailedEventArgs.Conflict

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Conflict As String
[C#]
public string Conflict {get;}
[C++]
public: __property String* get_Conflict();
[JScript]
public function get Conflict() : String;

See Also

MergeFailedEventArgs Class | MergeFailedEventArgs Members | System.Data Namespace


MergeFailedEventArgs.Table

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Table As DataTable
[C#]
public DataTable Table {get;}
[C++]
public: __property DataTable* get_Table();
[JScript]
public function get Table() : DataTable;

See Also

MergeFailedEventArgs Class | MergeFailedEventArgs Members | System.Data Namespace


MergeFailedEventHandler Delegate

[To be supplied.]

[Visual Basic]
Public Delegate Sub MergeFailedEventHandler( _
   ByVal sender As Object, _
   ByVal e As MergeFailedEventArgs _
)
[C#]
public delegate void MergeFailedEventHandler(
   object sender,
   MergeFailedEventArgs e
);
[C++]
public __gc __delegate void MergeFailedEventHandler(
   Object* sender,
   MergeFailedEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the MergeFailedEventHandler delegate declaration.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace


MissingMappingAction Enumeration

Determines that action that will occur when a DataColumn is is missing.

[Visual Basic]
Public Enum MissingMappingAction
[C#]
public enum MissingMappingAction
[C++]
public enum MissingMappingAction

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

The MissingMappingAction values are used as arguments in the GetDataColumnBySchemaAction method, and the GetTableMappingsBySchema method.

Members

Member Name | Description
Error | [To be supplied.]
Ignore | [To be supplied.]
Passthrough | [To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace


MissingPrimaryKeyException Class

[To be supplied.]

Object
Exception
SystemException
MissingPrimaryKeyException

[Visual Basic]
Public Class MissingPrimaryKeyException
   Inherits SystemException
[C#]
public class MissingPrimaryKeyException : SystemException
[C++]
public __gc class MissingPrimaryKeyException : public
   SystemException
[JScript]
public class MissingPrimaryKeyException extends SystemException

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

MissingPrimaryKeyException Members | System.Data Namespace


MissingPrimaryKeyException Members

Public:

Constructor

MissingPrimaryKeyException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

MissingPrimaryKeyException Class | System.Data Namespace


MissingPrimaryKeyException Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public MissingPrimaryKeyException();
[C++] public: MissingPrimaryKeyException();
[JScript] public function MissingPrimaryKeyException();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public MissingPrimaryKeyException(String);
[C++] public: MissingPrimaryKeyException(String*);
[JScript] public function MissingPrimaryKeyException(String);

See Also

MissingPrimaryKeyException Class | MissingPrimaryKeyException Members | System.Data Namespace


MissingPrimaryKeyException Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public MissingPrimaryKeyException();
[C++]
public: MissingPrimaryKeyException();
[JScript]
public function MissingPrimaryKeyException();

See Also

MissingPrimaryKeyException Class | MissingPrimaryKeyException Members | System.Data Namespace | MissingPrimaryKeyException Constructor Overload List


MissingPrimaryKeyException Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal s As String _
)
[C#]
public MissingPrimaryKeyException(
   string s
);
[C++]
public: MissingPrimaryKeyException(
   String* s
);
[JScript]
public function MissingPrimaryKeyException(
   s : String
);

Parameters

s
[To be supplied.]

See Also

MissingPrimaryKeyException Class | MissingPrimaryKeyException Members | System.Data Namespace | MissingPrimaryKeyException Constructor Overload List


MissingSchemaAction Enumeration

Specifies the action to take during a merge of tables whose schemas are incompatible.

[Visual Basic]
Public Enum MissingSchemaAction
[C#]
public enum MissingSchemaAction
[C++]
public enum MissingSchemaAction

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

The MissingSchemaAction is specified as an argument for the DataSet class's Add method.

Members

Member Name | Description
Add | Adds the necessary columns to complete the schema.
Error | An exception is thown.
Ignore | Ignores the extra columns.

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace


NoNullAllowedException Class

[To be supplied.]

Object
Exception
SystemException
NoNullAllowedException

[Visual Basic]
Public Class NoNullAllowedException
   Inherits SystemException
[C#]
public class NoNullAllowedException : SystemException
[C++]
public __gc class NoNullAllowedException : public SystemException
[JScript]
public class NoNullAllowedException extends SystemException

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

NoNullAllowedException Members | System.Data Namespace


NoNullAllowedException Members

Public:

Constructor

NoNullAllowedException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

NoNullAllowedException Class | System.Data Namespace


NoNullAllowedException Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public NoNullAllowedException();
[C++] public: NoNullAllowedException();
[JScript] public function NoNullAllowedException();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public NoNullAllowedException(String);
[C++] public: NoNullAllowedException(String*);
[JScript] public function NoNullAllowedException(String);

See Also

NoNullAllowedException Class | NoNullAllowedException Members | System.Data Namespace


NoNullAllowedException Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public NoNullAllowedException();
[C++]
public: NoNullAllowedException();
[JScript]
public function NoNullAllowedException();

See Also

NoNullAllowedException Class | NoNullAllowedException Members | System.Data Namespace | NoNullAllowedException Constructor Overload List


NoNullAllowedException Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal s As String _
)
[C#]
public NoNullAllowedException(
   string s
);
[C++]
public: NoNullAllowedException(
   String* s
);
[JScript]
public function NoNullAllowedException(
   s : String
);

Parameters

s
[To be supplied.]

See Also

NoNullAllowedException Class | NoNullAllowedException Members | System.Data Namespace | NoNullAllowedException Constructor Overload List


ObjectStoreColumn Class

[To be supplied.]

Object
Component
DataColumn
ObjectStoreColumn

[Visual Basic]
Public Class ObjectStoreColumn
   Inherits DataColumn
[C#]
public class ObjectStoreColumn : DataColumn
[C++]
public __gc class ObjectStoreColumn : public DataColumn
[JScript]
public class ObjectStoreColumn extends DataColumn

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

ObjectStoreColumn Members | System.Data Namespace


ObjectStoreColumn Members

Public:

Constructor

ObjectStoreColumn Constructor [To be supplied.]

Properties

AllowNull (inherited from DataColumn) | Gets or sets a value indicating whether null values are allowed in this column for rows belonging to the table.
Attribute (inherited from DataColumn) | Gets or sets a value indicating whether the column is an attribute column.
AutoIncrement (inherited from DataColumn) | Gets or sets a value indicating whether the column automatically increments the value of the column for new rows added to the table.
AutoIncrementSeed (inherited from DataColumn) | Gets or sets the starting value for a column that has its AutoIncrement property set to true.
AutoIncrementStep (inherited from DataColumn) | Gets or sets the increment used by a column with its AutoIncrement property set to true.
AutoIncrementSupported (inherited from DataColumn) | Gets a value indicating whether AutoIncrement is supported.
Caption (inherited from DataColumn) | Gets or sets the caption for this column.
ColumnName (inherited from DataColumn) | Gets or sets the name of the column within the ColumnsCollection.
DataType (inherited from DataColumn) | The type of data stored in thecolumn.
DataValueEditorType (inherited from DataColumn) | Gets or sets the type of value editor used to edit the data of this column.
DefaultValue (inherited from DataColumn) | Gets or sets the default value for the column when creating new rows.
Expression (inherited from DataColumn) | Gets or sets the expresssion used to either filter rows, calculate the column's value, or create an aggregate column.
ExtendedProperties (inherited from DataColumn) | Gets the collection of custom user information.
Namespace (inherited from DataColumn) | [To be supplied.]
Ordinal (inherited from DataColumn) | Gets the position of the column in the ColumnsCollection collection.
ReadOnly (inherited from DataColumn) | Gets or sets a value indicating whether the column allows changes once a row has been added to the table.
Site (inherited from Component) | Gets or sets the site of the Component.
Sparse (inherited from DataColumn) | Gets or sets a value indicating whether the column should store data in a fashion optimized for sparse data patterns.
Table (inherited from DataColumn) | Gets the DataTable to which the column belongs to.
Unique (inherited from DataColumn) | Gets or sets a value indicating whether the values in each row of the column must be unique.

Methods

Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FindParentRelation (inherited from DataColumn) | Finds a relation that this column is the sole child of or null.
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
ResetCaption (inherited from DataColumn) | Resets the Caption property to its previous value, or to a null reference (in Visual Basic Nothing).
ResetNamespace (inherited from DataColumn) | [To be supplied.]
ShouldPersistCaption (inherited from DataColumn) | Gets a value indicating whether the Caption has been explicitly set.
ShouldPersistDefaultValue (inherited from DataColumn) | [To be supplied.]
ShouldPersistNamespace (inherited from DataColumn) | [To be supplied.]
ToString (inherited from DataColumn) | Returns the Expression of the column, if one exists.

Events

PropertyChanged (inherited from DataColumn) Occurs whenever a property value of the DataColumn changes.

Protected:

Methods

CheckNotAllowNull (inherited from DataColumn) | [To be supplied.]
CheckUnique (inherited from DataColumn) | Throws an exception and the name of any column if its Unique property set to True and non-unique values are found in the column.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanged (inherited from DataColumn) | Raises the OnPropertyChanged event.
RaisePropertyChanged (inherited from DataColumn) | Raises the OnPropertyChanged event.
VerifyUnique (inherited from DataColumn) | Gets a value verifying whether a value is unique.

Event Hookup:

Methods

AddOnPropertyChanged (inherited from DataColumn) | Adds an event handler for the OnPropertyChanged event.
RemoveOnPropertyChanged (inherited from DataColumn) | Removes the event handler that has been associated with the OnPropertyChanged event.

See Also

ObjectStoreColumn Class | System.Data Namespace


ObjectStoreColumn Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal baseColumn As DataColumn, _
   ByVal propInfo As PropertyDescriptor _
)
[C#]
public ObjectStoreColumn(
   DataColumn baseColumn,
   PropertyDescriptor propInfo
);
[C++]
public: ObjectStoreColumn(
   DataColumn* baseColumn,
   PropertyDescriptor* propInfo
);
[JScript]
public function ObjectStoreColumn(
   baseColumn : DataColumn,
   propInfo : PropertyDescriptor
);

Parameters

baseColumn
[To be supplied.]
propInfo
[To be supplied.]

See Also

ObjectStoreColumn Class | ObjectStoreColumn Members | System.Data Namespace


ObjectStoreTable Class

[To be supplied.]

Object
Component
DataTable
ObjectStoreTable

[Visual Basic]
Public Class ObjectStoreTable
   Inherits DataTable
[C#]
public class ObjectStoreTable : DataTable
[C++]
public __gc class ObjectStoreTable : public DataTable
[JScript]
public class ObjectStoreTable extends DataTable

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

ObjectStoreTable Members | System.Data Namespace


ObjectStoreTable Members

Public:

Constructor

ObjectStoreTable Constructor Overloaded. [To be supplied.]

Properties

CaseSensitive (inherited from DataTable) | Indicates whether string comparisons within the table are case-sensitive.
ChildRelations (inherited from DataTable) | Gets the collection of child relations for this DataTable.
Columns (inherited from DataTable) | Gets the collection of columns that belong to this table.
Constraints (inherited from DataTable) | Gets the collection of constraints maintained by this table.
DataSet (inherited from DataTable) | Gets the DataSet that this table belongs to.
DefaultView (inherited from DataTable) | Gets a customized view of the table which may include a filtered view, or a cursor position.
DisplayExpression (inherited from DataTable) | Gets or sets the expression that will return a value used to represent this row in UI.
ExtendedProperties (inherited from DataTable) | Gets the collection of customized user information.
HasErrors (inherited from DataTable) | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs.
Locale (inherited from DataTable) | Gets or sets the locale information used to compare strings within the table.
MinimumCapacity (inherited from DataTable) | Gets or sets the initial starting size for this table.
Namespace (inherited from DataTable) | Gets or sets the namespace for the DataTable.
ParentRelations (inherited from DataTable) | Gets the collection of parent relations for this DataTable.
PrimaryKey (inherited from DataTable) | Gets or sets an array of columns that function as primary keys for the data table.
Rows (inherited from DataTable) | Gets the collection of rows that belong to this table.
Site (inherited from Component) | Gets or sets the site of the Component.
TableName (inherited from DataTable) | Gets or sets the name of the table.
TypedRowName (inherited from DataTable) | Gets the typed row name of the current table.
TypedTableName (inherited from DataTable) | Gets the name of the table.

Methods

AcceptChanges (inherited from DataTable) | Commits all the changes made to this table since the last time AcceptChanges was called.
Clear (inherited from DataTable) | Clears the table of any data. All rows in all tables are removed. An exception is thrown if the table has any enforced child relations that would cause child rows to be stranded.
Compute (inherited from DataTable) | Computes the given expression on the current rows that pass the filter criteria.
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetErrors (inherited from DataTable) | Returns an array of DataRow objects that contain errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
LoadObjects | [To be supplied.]
NewRow (inherited from DataTable) | Creates a new DataRow with the same schema as the table.
RejectChanges (inherited from DataTable) | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges was called.
Reset (inherited from DataTable) | Resets the table back to its original state.
ResetCaseSensitive (inherited from DataTable) | Resets the CaseSensitive property to its default state.
ResetColumns (inherited from DataTable) | [To be supplied.]
ResetConstraints (inherited from DataTable) | [To be supplied.]
ResetLocale (inherited from DataTable) | Resets the Locale property to its default state.
ResetNamespace (inherited from DataTable) | Resets the Namespace property to its default state.
ResetPrimaryKey (inherited from DataTable) | Resets the PrimaryKey property to its default state.
Select (inherited from DataTable) | Overloaded. Returns an array of DataRow objects.
ShouldPersistCaseSensitive (inherited from DataTable) | Indicates whether the CaseSensitive property should be persisted.
ShouldPersistColumns (inherited from DataTable) | [To be supplied.]
ShouldPersistConstraints (inherited from DataTable) | [To be supplied.]
ShouldPersistLocale (inherited from DataTable) | Indicates whether the Locale property should be persisted.
ShouldPersistNamespace (inherited from DataTable) | Indicates whether the Namespace property should be persisted.
ShouldPersistPrimaryKey (inherited from DataTable) | Indicates whether the PrimaryKey property should be persisted.
ToString (inherited from DataTable) | Returns the TableName and DisplayExpression, if there is one as a concatenated string.

Events

ColumnChanging (inherited from DataTable) | Occurs when a value has been submitted for this column.
PropertyChanged (inherited from DataTable) | This event occurs when any property on the control has been changed for any reason.
RowChanged (inherited from DataTable) | Occurs after a row in the table has been successfully edited.
RowChanging (inherited from DataTable) | Occurs when the DataRow is changing.
RowDeleted (inherited from DataTable) | Occurs after a row in the table has been deleted.
RowDeleting (inherited from DataTable) | Occurs before a row in the table is about to be deleted.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
FindRow (inherited from DataTable) | Overloaded. Finds and returns a specific DataRow.
FindRows (inherited from DataTable) | Overloaded. Finds and returns an array of DataRow objects.
HasSchemaChanged (inherited from DataTable) | Gets a value indicating whether the column count has changed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NewRowFromBuilder (inherited from DataTable) | This is what a subclassed dataSet overrides to create a new row.
OnColumnChanging (inherited from DataTable) | Raises the ColumnChanging event.
OnPropertyChanged (inherited from DataTable) | Raises the OnPropertyChanged event.
OnRemoveColumn (inherited from DataTable) | Notifies the DataTable that a DataColumn is being removed.
OnRowChanged (inherited from DataTable) | Raises the RowChanged event.
OnRowChanging (inherited from DataTable) | Raises the RowChanging event.
OnRowDeleted (inherited from DataTable) | Raises the OnRowDeleted event.
OnRowDeleting (inherited from DataTable) | Raises the OnRowDeleting event.

Event Hookup:

Methods

AddOnColumnChanging (inherited from DataTable) | Adds an event handler for the ColumnChanging event.
AddOnPropertyChanged (inherited from DataTable) | Adds an event handler for the OnPropertyChanged event.
AddOnRowChanged (inherited from DataTable) | Adds an event handler for the RowChanged event.
AddOnRowChanging (inherited from DataTable) | Adds an event handler for the RowChanging event.
AddOnRowDeleted (inherited from DataTable) | Adds an event handler for the OnRowDeleted event.
AddOnRowDeleting (inherited from DataTable) | Adds an event handler for the OnRowDeleting event.
RemoveOnColumnChanging (inherited from DataTable) | Removes the event handler that has been associated with the OnColumnChanging event.
RemoveOnPropertyChanged (inherited from DataTable) | Removes an event handler that has been associated with the OnPropertyChanged event.
RemoveOnRowChanged (inherited from DataTable) | Removes an event handler for the row changed event. Occurs after a row in the table has been successfully edited.
RemoveOnRowChanging (inherited from DataTable) | Removes an event handler for the row changing event. Occurs when a row in the table has proposed edits. The user can modify values in the row and should throw an exception to cancel the edit.
RemoveOnRowDeleted (inherited from DataTable) | Removes an event handler for the row deleting event. Occurs after a row in the table was deleted.
RemoveOnRowDeleting (inherited from DataTable) | Removes an event handler for the row deleting event. Occurs after a row in the table is about to be deleted.

See Also

ObjectStoreTable Class | System.Data Namespace


ObjectStoreTable Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public ObjectStoreTable();
[C++] public: ObjectStoreTable();
[JScript] public function ObjectStoreTable();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Object())
[C#] public ObjectStoreTable(Object[]);
[C++] public: ObjectStoreTable(Object*[]);
[JScript] public function ObjectStoreTable(Object[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Object(), String)
[C#] public ObjectStoreTable(Object[], String);
[C++] public: ObjectStoreTable(Object*[], String);
[JScript] public function ObjectStoreTable(Object[], String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Object(), Type, String)
[C#] public ObjectStoreTable(Object[], Type, String);
[C++] public: ObjectStoreTable(Object*[], Type, String);
[JScript] public function ObjectStoreTable(Object[], Type, String);

See Also

ObjectStoreTable Class | ObjectStoreTable Members | System.Data Namespace


ObjectStoreTable Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public ObjectStoreTable();
[C++]
public: ObjectStoreTable();
[JScript]
public function ObjectStoreTable();

See Also

ObjectStoreTable Class | ObjectStoreTable Members | System.Data Namespace | ObjectStoreTable Constructor Overload List


ObjectStoreTable Constructor (Object[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal values() As Object _
)
[C#]
public ObjectStoreTable(
   object[] values
);
[C++]
public: ObjectStoreTable(
   Object* values[]
);
[JScript]
public function ObjectStoreTable(
   values : Object[]
);

Parameters

values
[To be supplied.]

See Also

ObjectStoreTable Class | ObjectStoreTable Members | System.Data Namespace | ObjectStoreTable Constructor Overload List


ObjectStoreTable Constructor (Object[], String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal values() As Object, _
   ByVal name As String _
)
[C#]
public ObjectStoreTable(
   object[] values,
   string name
);
[C++]
public: ObjectStoreTable(
   Object* values[],
   String* name
);
[JScript]
public function ObjectStoreTable(
   values : Object[],
   name : String
);

Parameters

values
[To be supplied.]
name
[To be supplied.]

See Also

ObjectStoreTable Class | ObjectStoreTable Members | System.Data Namespace | ObjectStoreTable Constructor Overload List


ObjectStoreTable Constructor (Object[], Type, String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal values() As Object, _
   ByVal valuesType As Type, _
   ByVal name As String _
)
[C#]
public ObjectStoreTable(
   object[] values,
   Type valuesType,
   string name
);
[C++]
public: ObjectStoreTable(
   Object* values[],
   Type* valuesType,
   String* name
);
[JScript]
public function ObjectStoreTable(
   values : Object[],
   valuesType : Type,
   name : String
);

Parameters

values
[To be supplied.]
valuesType
[To be supplied.]
name
[To be supplied.]

See Also

ObjectStoreTable Class | ObjectStoreTable Members | System.Data Namespace | ObjectStoreTable Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ObjectStoreTable Methods

The methods of the ObjectStoreTable class are listed below. For a complete list of ObjectStoreTable class members, see the ObjectStoreTable Members topic.

Public:

AcceptChanges (inherited from DataTable) | Commits all the changes made to this table since the last time AcceptChanges was called.
Clear (inherited from DataTable) | Clears the table of any data. All rows in all tables are removed. An exception is thrown if the table has any enforced child relations that would cause child rows to be stranded.
Compute (inherited from DataTable) | Computes the given expression on the current rows that pass the filter criteria.
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetErrors (inherited from DataTable) | Returns an array of DataRow objects that contain errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
LoadObjects | [To be supplied.]
NewRow (inherited from DataTable) | Creates a new DataRow with the same schema as the table.
RejectChanges (inherited from DataTable) | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges was called.
Reset (inherited from DataTable) | Resets the table back to its original state.
ResetCaseSensitive (inherited from DataTable) | Resets the CaseSensitive property to its default state.
ResetColumns (inherited from DataTable) | [To be supplied.]
ResetConstraints (inherited from DataTable) | [To be supplied.]
ResetLocale (inherited from DataTable) | Resets the Locale property to its default state.
ResetNamespace (inherited from DataTable) | Resets the Namespace property to its default state.
ResetPrimaryKey (inherited from DataTable) | Resets the PrimaryKey property to its default state.
Select (inherited from DataTable) | Overloaded. Returns an array of DataRow objects.
ShouldPersistCaseSensitive (inherited from DataTable) | Indicates whether the CaseSensitive property should be persisted.
ShouldPersistColumns (inherited from DataTable) | [To be supplied.]
ShouldPersistConstraints (inherited from DataTable) | [To be supplied.]
ShouldPersistLocale (inherited from DataTable) | Indicates whether the Locale property should be persisted.
ShouldPersistNamespace (inherited from DataTable) | Indicates whether the Namespace property should be persisted.
ShouldPersistPrimaryKey (inherited from DataTable) | Indicates whether the PrimaryKey property should be persisted.
ToString (inherited from DataTable) | Returns the TableName and DisplayExpression, if there is one as a concatenated string.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
FindRow (inherited from DataTable) | Overloaded. Finds and returns a specific DataRow.
FindRows (inherited from DataTable) | Overloaded. Finds and returns an array of DataRow objects.
HasSchemaChanged (inherited from DataTable) | Gets a value indicating whether the column count has changed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NewRowFromBuilder (inherited from DataTable) | This is what a subclassed dataSet overrides to create a new row.
OnColumnChanging (inherited from DataTable) | Raises the ColumnChanging event.
OnPropertyChanged (inherited from DataTable) | Raises the OnPropertyChanged event.
OnRemoveColumn (inherited from DataTable) | Notifies the DataTable that a DataColumn is being removed.
OnRowChanged (inherited from DataTable) | Raises the RowChanged event.
OnRowChanging (inherited from DataTable) | Raises the RowChanging event.
OnRowDeleted (inherited from DataTable) | Raises the OnRowDeleted event.
OnRowDeleting (inherited from DataTable) | Raises the OnRowDeleting event.

Event Hookup:

AddOnColumnChanging (inherited from DataTable) | Adds an event handler for the ColumnChanging event.
AddOnPropertyChanged (inherited from DataTable) | Adds an event handler for the OnPropertyChanged event.
AddOnRowChanged (inherited from DataTable) | Adds an event handler for the RowChanged event.
AddOnRowChanging (inherited from DataTable) | Adds an event handler for the RowChanging event.
AddOnRowDeleted (inherited from DataTable) | Adds an event handler for the OnRowDeleted event.
AddOnRowDeleting (inherited from DataTable) | Adds an event handler for the OnRowDeleting event.
RemoveOnColumnChanging (inherited from DataTable) | Removes the event handler that has been associated with the OnColumnChanging event.
RemoveOnPropertyChanged (inherited from DataTable) | Removes an event handler that has been associated with the OnPropertyChanged event.
RemoveOnRowChanged (inherited from DataTable) | Removes an event handler for the row changed event. Occurs after a row in the table has been successfully edited.
RemoveOnRowChanging (inherited from DataTable) | Removes an event handler for the row changing event. Occurs when a row in the table has proposed edits. The user can modify values in the row and should throw an exception to cancel the edit.
RemoveOnRowDeleted (inherited from DataTable) | Removes an event handler for the row deleting event. Occurs after a row in the table was deleted.
RemoveOnRowDeleting (inherited from DataTable) | Removes an event handler for the row deleting event. Occurs after a row in the table is about to be deleted.

See Also

ObjectStoreTable Class | System.Data Namespace


ObjectStoreTable.LoadObjects

[To be supplied.]

[Visual Basic]
Overridable Public Sub LoadObjects( _
   ByVal values() As Object, _
   ByVal arrayType As Type _
)
[C#]
public virtual void LoadObjects(
   object[] values,
   Type arrayType
);
[C++]
public: virtual void LoadObjects(
   Object* values[],
   Type* arrayType
);
[JScript]
public function LoadObjects(
   values : Object[],
   arrayType : Type
);

Parameters

values
[To be supplied.]
arrayType
[To be supplied.]

See Also

ObjectStoreTable Class | ObjectStoreTable Members | System.Data Namespace


OriginalDataUneditableException Class

[To be supplied.]

Object
Exception
SystemException
OriginalDataUneditableException

[Visual Basic]
Public Class OriginalDataUneditableException
   Inherits SystemException
[C#]
public class OriginalDataUneditableException : SystemException
[C++]
public __gc class OriginalDataUneditableException : public
   SystemException
[JScript]
public class OriginalDataUneditableException extends
   SystemException

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

OriginalDataUneditableException Members | System.Data Namespace


OriginalDataUneditableException Members

Public:

Constructor

OriginalDataUneditableException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

OriginalDataUneditableException Class | System.Data Namespace


OriginalDataUneditableException Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public OriginalDataUneditableException();
[C++] public: OriginalDataUneditableException();
[JScript] public function OriginalDataUneditableException();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public OriginalDataUneditableException(String);
[C++] public: OriginalDataUneditableException(String*);
[JScript] public function OriginalDataUneditableException(String);

See Also

OriginalDataUneditableException Class | OriginalDataUneditableException Members | System.Data Namespace


OriginalDataUneditableException Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public OriginalDataUneditableException();
[C++]
public: OriginalDataUneditableException();
[JScript]
public function OriginalDataUneditableException();

See Also

OriginalDataUneditableException Class | OriginalDataUneditableException Members | System.Data Namespace | OriginalDataUneditableException Constructor Overload List


OriginalDataUneditableException Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal s As String _
)
[C#]
public OriginalDataUneditableException(
   string s
);
[C++]
public: OriginalDataUneditableException(
   String* s
);
[JScript]
public function OriginalDataUneditableException(
   s : String
);

Parameters

s
[To be supplied.]

See Also

OriginalDataUneditableException Class | OriginalDataUneditableException Members | System.Data Namespace | OriginalDataUneditableException Constructor Overload List


ParameterDirection Enumeration

[To be supplied.]

[Visual Basic]
Public Enum ParameterDirection
[C#]
public enum ParameterDirection
[C++]
public enum ParameterDirection

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Input | [To be supplied.]
InputOutput | [To be supplied.]
Output | [To be supplied.]
ReturnValue | [To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace


PositionChangingEventArgs Class

[To be supplied.]

Object
EventArgs
PositionChangingEventArgs

[Visual Basic]
Public Class PositionChangingEventArgs
   Inherits EventArgs
[C#]
public class PositionChangingEventArgs : EventArgs
[C++]
public __gc class PositionChangingEventArgs : public EventArgs
[JScript]
public class PositionChangingEventArgs extends EventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

PositionChangingEventArgs Members | System.Data Namespace


PositionChangingEventArgs Members

Public:

Properties

ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
NewPosition | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PositionChangingEventArgs Class | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PositionChangingEventArgs Properties

The properties of the PositionChangingEventArgs class are listed below. For a complete list of PositionChangingEventArgs class members, see the PositionChangingEventArgs Members topic.

Public:

ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
NewPosition | [To be supplied.]

See Also

PositionChangingEventArgs Class | System.Data Namespace


PositionChangingEventArgs.NewPosition

[To be supplied.]

[Visual Basic]
Public ReadOnly Property NewPosition As Integer
[C#]
public int NewPosition {get;}
[C++]
public: __property int get_NewPosition();
[JScript]
public function get NewPosition() : int;

See Also

PositionChangingEventArgs Class | PositionChangingEventArgs Members | System.Data Namespace


PositionChangingEventHandler Delegate

[To be supplied.]

[Visual Basic]
Public Delegate Sub PositionChangingEventHandler( _
   ByVal sender As Object, _
   ByVal e As PositionChangingEventArgs _
)
[C#]
public delegate void PositionChangingEventHandler(
   object sender,
   PositionChangingEventArgs e
);
[C++]
public __gc __delegate void PositionChangingEventHandler(
   Object* sender,
   PositionChangingEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the PositionChangingEventHandler delegate declaration.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace


PropertiesCollection Class

[To be supplied.]

Object
Hashtable
PropertiesCollection

[Visual Basic]
Public Class PropertiesCollection
   Inherits Hashtable
[C#]
public class PropertiesCollection : Hashtable
[C++]
public __gc class PropertiesCollection : public Hashtable
[JScript]
public class PropertiesCollection extends Hashtable

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

PropertiesCollection Members | System.Data Namespace


PropertiesCollection Members

Public:

Constructor

PropertiesCollection Constructor [To be supplied.]

Properties

Count (inherited from Hashtable) | Gets the number of key-and-value pairs in the Hashtable.
IsReadOnly (inherited from Hashtable) | Gets a value indicating whether the Hashtable is read-only.
IsSynchronized (inherited from Hashtable) | Gets a value indicating whether access to the Hashtable is synchronized (thread-safe).
Item (inherited from Hashtable) | Gets or sets the value associated with the specified key. In C#, this member is the indexer for the PropertiesCollection class.
Keys (inherited from Hashtable) | Gets an ICollection containing the keys in the Hashtable.
SyncRoot (inherited from Hashtable) | Gets an object that can be used to synchronize access to the Hashtable.
Values (inherited from Hashtable) | Gets an ICollection containing the values in the Hashtable.

Methods

Add (inherited from Hashtable) | Adds an entry with the specified key and value into the Hashtable.
Clear (inherited from Hashtable) | Removes all entries from the Hashtable.
Clone (inherited from Hashtable) | Creates a shallow copy of the Hashtable.
Contains (inherited from Hashtable) | Determines if the Hashtable contains a specific key.
ContainsKey (inherited from Hashtable) | Determines if the Hashtable contains a specific key.
ContainsValue (inherited from Hashtable) | Determines if the Hashtable contains a specific value.
CopyTo (inherited from Hashtable) | Copies the Hashtable values into a one-dimensional Array instance at the specified index.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from Hashtable) | Returns an enumerator which can be used to iterate through the Hashtable.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Hashtable) | Implements the ISerializable interface and returns the data needed to serialize the Hashtable.
GetType (inherited from Object) | Gets the Type of the Object.
OnDeserialization (inherited from Hashtable) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from Hashtable) | Removes the entry with the specified key from the Hashtable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetHash (inherited from Hashtable) | Returns the hash code for the specified key.
KeyEquals (inherited from Hashtable) | Compares a specific Object with a specific key in the Hashtable.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

comparer (inherited from Hashtable) | Represents the comparer to use for the Hashtable.
hcp (inherited from Hashtable) | Represents the object that can dispense hash codes.

See Also

PropertiesCollection Class | System.Data Namespace


PropertiesCollection Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public PropertiesCollection();
[C++]
public: PropertiesCollection();
[JScript]
public function PropertiesCollection();

See Also

PropertiesCollection Class | PropertiesCollection Members | System.Data Namespace


PropertyAttributes Enumeration

[To be supplied.]

[Visual Basic]
Public Enum PropertyAttributes
[C#]
public enum PropertyAttributes
[C++]
public enum PropertyAttributes

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
NotSupported | [To be supplied.]
Optional | [To be supplied.]
Read | [To be supplied.]
Required | [To be supplied.]
Write | [To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace


Range Structure

[To be supplied.]

Object
ValueType
Range

[Visual Basic]
Public Structure Range
[C#]
public struct Range
[C++]
public __value struct Range

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

Range Members | System.Data Namespace


Range Members

Public:

Constructor

Range Constructor [To be supplied.]

Properties

Count | [To be supplied.]
Difference | [To be supplied.]
IsNull | [To be supplied.]
Max | [To be supplied.]
Min | [To be supplied.]

Methods

Equals | [To be supplied.]
GetHashCode | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
Intersection | [To be supplied.]
Offset | [To be supplied.]
operatorEquals | [To be supplied.]
Resize | [To be supplied.]
ToString | [To be supplied.]

Fields

Null [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Range Structure | System.Data Namespace


Range Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal min As Integer, _
   ByVal max As Integer _
)
[C#]
public Range(
   int min,
   int max
);
[C++]
public: Range(
   int min,
   int max
);
[JScript]
public function Range(
   min : int,
   max : int
);

Parameters

min
[To be supplied.]
max
[To be supplied.]

See Also

Range Structure | Range Members | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Range Properties

The properties of the Range structure are listed below. For a complete list of Range structure members, see the Range Members topic.

Public:

Count | [To be supplied.]
Difference | [To be supplied.]
IsNull | [To be supplied.]
Max | [To be supplied.]
Min | [To be supplied.]

See Also

Range Structure | System.Data Namespace


Range.Count

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

See Also

Range Structure | Range Members | System.Data Namespace


Range.Difference

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Difference As Integer
[C#]
public int Difference {get;}
[C++]
public: __property int get_Difference();
[JScript]
public function get Difference() : int;

See Also

Range Structure | Range Members | System.Data Namespace


Range.IsNull

[To be supplied.]

[Visual Basic]
Public ReadOnly Property IsNull As Boolean
[C#]
public bool IsNull {get;}
[C++]
public: __property bool get_IsNull();
[JScript]
public function get IsNull() : Boolean;

See Also

Range Structure | Range Members | System.Data Namespace


Range.Max

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Max As Integer
[C#]
public int Max {get;}
[C++]
public: __property int get_Max();
[JScript]
public function get Max() : int;

See Also

Range Structure | Range Members | System.Data Namespace


Range.Min

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Min As Integer
[C#]
public int Min {get;}
[C++]
public: __property int get_Min();
[JScript]
public function get Min() : int;

See Also

Range Structure | Range Members | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Range Methods

The methods of the Range structure are listed below. For a complete list of Range structure members, see the Range Members topic.

Public:

Equals | [To be supplied.]
GetHashCode | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
Intersection | [To be supplied.]
Offset | [To be supplied.]
operatorEquals | [To be supplied.]
Resize | [To be supplied.]
ToString | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Range Structure | System.Data Namespace


Range.Equals

[To be supplied.]

[Visual Basic]
Overrides Public Function Equals( _
   ByVal o As Object _
) As Boolean
[C#]
public override bool Equals(
   object o
);
[C++]
public: override bool Equals(
   Object* o
);
[JScript]
public override function Equals(
   o : Object
) : Boolean;

Parameters

o
[To be supplied.]

See Also

Range Structure | Range Members | System.Data Namespace


Range.GetHashCode

[To be supplied.]

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

See Also

Range Structure | Range Members | System.Data Namespace


Range.Intersection

[To be supplied.]

[Visual Basic]
Public Shared Function Intersection( _
   ByVal range1 As Range, _
   ByVal range2 As Range _
) As Range
[C#]
public static Range Intersection(
   Range range1,
   Range range2
);
[C++]
public: static Range Intersection(
   Range range1,
   Range range2
);
[JScript]
public static function Intersection(
   range1 : Range,
   range2 : Range
) : Range;

Parameters

range1
[To be supplied.]
range2
[To be supplied.]

See Also

Range Structure | Range Members | System.Data Namespace


Range.Offset

[To be supplied.]

[Visual Basic]
Public Function Offset( _
   ByVal offset As Integer _
) As Range
[C#]
public Range Offset(
   int offset
);
[C++]
public: Range Offset(
   int offset
);
[JScript]
public function Offset(
   offset : int
) : Range;

Parameters

offset
[To be supplied.]

See Also

Range Structure | Range Members | System.Data Namespace


Range.operatorEquals

[To be supplied.]

[Visual Basic]
Public Shared Function operatorEquals( _
   ByVal range1 As Range, _
   ByVal range2 As Range _
) As Boolean
[C#]
public static bool operatorEquals(
   Range range1,
   Range range2
);
[C++]
public: static bool operatorEquals(
   Range range1,
   Range range2
);
[JScript]
public static function operatorEquals(
   range1 : Range,
   range2 : Range
) : Boolean;

Parameters

range1
[To be supplied.]
range2
[To be supplied.]

See Also

Range Structure | Range Members | System.Data Namespace


Range.Resize

[To be supplied.]

[Visual Basic]
Public Function Resize( _
   ByVal xoffset As Integer, _
   ByVal yoffset As Integer _
) As Range
[C#]
public Range Resize(
   int xoffset,
   int yoffset
);
[C++]
public: Range Resize(
   int xoffset,
   int yoffset
);
[JScript]
public function Resize(
   xoffset : int,
   yoffset : int
) : Range;

Parameters

xoffset
[To be supplied.]
yoffset
[To be supplied.]

See Also

Range Structure | Range Members | System.Data Namespace


Range.ToString

[To be supplied.]

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

Range Structure | Range Members | System.Data Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Range Fields

The fields of the Range structure are listed below. For a complete list of Range structure members, see the Range Members topic.

Public:

Null [To be supplied.]

See Also

Range Structure | System.Data Namespace


Range.Null

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Null As Range
[C#]
public static readonly Range Null;
[C++]
public: static readonly Range Null;
[JScript]
public static var Null : Range;

See Also

Range Structure | Range Members | System.Data Namespace


ReadOnlyException Class

[To be supplied.]

Object
Exception
SystemException
ReadOnlyException

[Visual Basic]
Public Class ReadOnlyException
   Inherits SystemException
[C#]
public class ReadOnlyException : SystemException
[C++]
public __gc class ReadOnlyException : public SystemException
[JScript]
public class ReadOnlyException extends SystemException

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

ReadOnlyException Members | System.Data Namespace


ReadOnlyException Members

Public:

Constructor

ReadOnlyException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

ReadOnlyException Class | System.Data Namespace


ReadOnlyException Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public ReadOnlyException();
[C++] public: ReadOnlyException();
[JScript] public function ReadOnlyException();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public ReadOnlyException(String);
[C++] public: ReadOnlyException(String*);
[JScript] public function ReadOnlyException(String);

See Also

ReadOnlyException Class | ReadOnlyException Members | System.Data Namespace


ReadOnlyException Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public ReadOnlyException();
[C++]
public: ReadOnlyException();
[JScript]
public function ReadOnlyException();

See Also

ReadOnlyException Class | ReadOnlyException Members | System.Data Namespace | ReadOnlyException Constructor Overload List


ReadOnlyException Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal s As String _
)
[C#]
public ReadOnlyException(
   string s
);
[C++]
public: ReadOnlyException(
   String* s
);
[JScript]
public function ReadOnlyException(
   s : String
);

Parameters

s
[To be supplied.]

See Also

ReadOnlyException Class | ReadOnlyException Members | System.Data Namespace | ReadOnlyException Constructor Overload List


ReadState Enumeration

[To be supplied.]

[Visual Basic]
Public Enum ReadState
[C#]
public enum ReadState
[C++]
public enum ReadState

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Complete | [To be supplied.]
Error | [To be supplied.]
Initial | [To be supplied.]
Interactive | [To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace


RelatedView Class

[To be supplied.]

Object
Component
DataView
RelatedView

[Visual Basic]
Public Class RelatedView
   Inherits DataView
   Implements IFilter
[C#]
public class RelatedView : DataView, IFilter
[C++]
public __gc class RelatedView : public DataView, IFilter
[JScript]
public class RelatedView extends DataView, IFilter

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

RelatedView Members | System.Data Namespace


RelatedView Members

Public:

Constructor

RelatedView Constructor [To be supplied.]

Properties

AllowDelete (inherited from DataView) | Sets or gets a value indicating whether deletes are allowed.
AllowEdit (inherited from DataView) | Gets or sets a value indicating whether edits are allowed.
AllowNew (inherited from DataView) | Gets or sets a value indicating whether the new rows can be added using the AddNew method.
ApplyDefaultSort (inherited from DataView) | [To be supplied.]
Count (inherited from DataView) | Gets the number of records in the DataView.
DataSetView (inherited from DataView) | Gets the DataSetView associated with this DataView.
Item (inherited from DataView) | Gets a row of data from a specified table. In C#, this member is the indexer for the RelatedView class.
RowFilter (inherited from DataView) | Gets or sets the expression used to filter which rows are viewed in the DataView.
RowStateFilter (inherited from DataView) | Gets or sets the row state filter used in the DataView.
Site (inherited from Component) | Gets or sets the site of the Component.
Sort (inherited from DataView) | Gets or sets the sort column or columns, and sort order for the table.
Table (inherited from DataView) | Gets or sets the source DataTable.

Methods

AddNew | [To be supplied.]
CopyTo (inherited from DataView) | copies items into array. Only for Web Forms Interfaces.
Delete (inherited from DataView) | Deletes a row.
Dispose (inherited from DataView) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Find (inherited from DataView) | Overloaded. Finds a row in the DataView.
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetEnumerator (inherited from DataView) | Gets an enumerator for this DataView.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Index_ListChanged (inherited from DataView) | [To be supplied.]
Invoke | [To be supplied.]
ResetSort (inherited from DataView) | Resets the Sort property to its default state.
ShouldPersistSort (inherited from DataView) | Indicates whether the Sort property should be persisted.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Events

ListChanged (inherited from DataView) | Occurs when the list managed by the DataView changes.
PropertyChanged (inherited from DataView) | Occurs when a property value changes.

Protected:

Properties

IsOpen (inherited from DataView) Gets a value indicating whether the data source is currently open and projecting views of data on the DataTable.

Methods

Close (inherited from DataView) | Closes the DataView.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetFilter | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnListChanged (inherited from DataView) | Raises the System.Data.DataView.ListChanged event.
OnPropertyChanged (inherited from DataView) | Raises the System.Data.DataView.PropertyChanged event.
Open (inherited from DataView) | Opens a DataView.
RaisePropertyChanged (inherited from DataView) | Raises the OnPropertyChanged event.
Reset (inherited from DataView) | [To be supplied.]
SetIndex | [To be supplied.]
UpdateIndex | Overloaded. [To be supplied.]

Event Hookup:

Methods

AddOnListChanged (inherited from DataView) | Adds an event handler for the System.Data.DataView.ListChanged event.
AddOnPropertyChanged (inherited from DataView) | Adds an event handler for the System.Data.DataView.PropertyChanged event.
RemoveOnListChanged (inherited from DataView) | Removes the event handler that has been associated with the OnListChanged event.
RemoveOnPropertyChanged (inherited from DataView) | Removes an event handler that has been associated with the OnPropertyChanged event.

See Also

RelatedView Class | System.Data Namespace


RelatedView Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal columns() As DataColumn, _
   ByVal values() As Object _
)
[C#]
public RelatedView(
   DataColumn[] columns,
   object[] values
);
[C++]
public: RelatedView(
   DataColumn* columns[],
   Object* values[]
);
[JScript]
public function RelatedView(
   columns : DataColumn[],
   values : Object[]
);

Parameters

columns
[To be supplied.]
values
[To be supplied.]

See Also

RelatedView Class | RelatedView Members | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RelatedView Methods

The methods of the RelatedView class are listed below. For a complete list of RelatedView class members, see the RelatedView Members topic.

Public:

AddNew | [To be supplied.]
CopyTo (inherited from DataView) | copies items into array. Only for Web Forms Interfaces.
Delete (inherited from DataView) | Deletes a row.
Dispose (inherited from DataView) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Find (inherited from DataView) | Overloaded. Finds a row in the DataView.
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetEnumerator (inherited from DataView) | Gets an enumerator for this DataView.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Index_ListChanged (inherited from DataView) | [To be supplied.]
Invoke | [To be supplied.]
ResetSort (inherited from DataView) | Resets the Sort property to its default state.
ShouldPersistSort (inherited from DataView) | Indicates whether the Sort property should be persisted.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Protected:

Close (inherited from DataView) | Closes the DataView.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetFilter | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnListChanged (inherited from DataView) | Raises the System.Data.DataView.ListChanged event.
OnPropertyChanged (inherited from DataView) | Raises the System.Data.DataView.PropertyChanged event.
Open (inherited from DataView) | Opens a DataView.
RaisePropertyChanged (inherited from DataView) | Raises the OnPropertyChanged event.
Reset (inherited from DataView) | [To be supplied.]
SetIndex | [To be supplied.]
UpdateIndex | Overloaded. [To be supplied.]

Event Hookup:

AddOnListChanged (inherited from DataView) | Adds an event handler for the System.Data.DataView.ListChanged event.
AddOnPropertyChanged (inherited from DataView) | Adds an event handler for the System.Data.DataView.PropertyChanged event.
RemoveOnListChanged (inherited from DataView) | Removes the event handler that has been associated with the OnListChanged event.
RemoveOnPropertyChanged (inherited from DataView) | Removes an event handler that has been associated with the OnPropertyChanged event.

See Also

RelatedView Class | System.Data Namespace


RelatedView.AddNew

[To be supplied.]

[Visual Basic]
Overrides Public Function AddNew() As DataRowView
[C#]
public override DataRowView AddNew();
[C++]
public: override DataRowView* AddNew();
[JScript]
public override function AddNew() : DataRowView;

See Also

RelatedView Class | RelatedView Members | System.Data Namespace


RelatedView.GetFilter

[To be supplied.]

[Visual Basic]
Overrides Protected Function GetFilter() As IFilter
[C#]
protected override IFilter GetFilter();
[C++]
protected: override IFilter* GetFilter();
[JScript]
protected override function GetFilter() : IFilter;

See Also

RelatedView Class | RelatedView Members | System.Data Namespace


RelatedView.Invoke

[To be supplied.]

[Visual Basic]
Overridable Public Function Invoke( _
   ByVal row As DataRow, _
   ByVal version As DataRowVersion _
) As Boolean
[C#]
public virtual bool Invoke(
   DataRow row,
   DataRowVersion version
);
[C++]
public: virtual bool Invoke(
   DataRow* row,
   DataRowVersion version
);
[JScript]
public function Invoke(
   row : DataRow,
   version : DataRowVersion
) : Boolean;

Parameters

row
[To be supplied.]
version
[To be supplied.]

See Also

RelatedView Class | RelatedView Members | System.Data Namespace


RelatedView.SetIndex

[To be supplied.]

[Visual Basic]
Overrides Protected Sub SetIndex( _
   ByVal newSort As String, _
   ByVal newRowStates As DataViewRowState, _
   ByVal newRowFilter As DataFilter _
)
[C#]
protected override void SetIndex(
   string newSort,
   DataViewRowState newRowStates,
   DataFilter newRowFilter
);
[C++]
protected: override void SetIndex(
   String* newSort,
   DataViewRowState newRowStates,
   DataFilter* newRowFilter
);
[JScript]
protected override function SetIndex(
   newSort : String,
   newRowStates : DataViewRowState,
   newRowFilter : DataFilter
);

Parameters

newSort
[To be supplied.]
newRowStates
[To be supplied.]
newRowFilter
[To be supplied.]

See Also

RelatedView Class | RelatedView Members | System.Data Namespace


RelatedView.UpdateIndex

[To be supplied.]

[Visual Basic]
Overrides Protected Sub UpdateIndex( _
   ByVal force As Boolean _
)
[C#]
protected override void UpdateIndex(
   bool force
);
[C++]
protected: override void UpdateIndex(
   bool force
);
[JScript]
protected override function UpdateIndex(
   force : Boolean
);

Parameters

force
[To be supplied.]

See Also

RelatedView Class | RelatedView Members | System.Data Namespace


RelationsCollection Class

Represents the collection of relations, each of which allows navigation between related parent/child tables.

Object
BaseCollection
RelationsCollection

[Visual Basic]
MustInherit Public Class RelationsCollection
   Inherits BaseCollection
[C#]
public abstract class RelationsCollection : BaseCollection
[C++]
public __gc __abstract class RelationsCollection : public
   BaseCollection
[JScript]
public abstract class RelationsCollection extends BaseCollection

Remarks

The RelationsCollection contains all of the DataRelation objects for a DataSet. To access the collection, use the Relations property.

The RelationsCollection has the standard collection methods Add, Clear, and Remove as well as an All method to return the collection as an array.

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

RelationsCollection Members | System.Data Namespace | Add | DataSet | Relations | DataRelation | Remove


RelationsCollection Members

Public:

Constructor

RelationsCollection Constructor [To be supplied.]

Properties

All | Gets or sets all of the relations in the collection.
Count (inherited from BaseCollection) | [To be supplied.]
IsReadOnly (inherited from BaseCollection) | [To be supplied.]
IsSynchronized (inherited from BaseCollection) | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the RelationsCollection class.
SyncRoot (inherited from BaseCollection) | [To be supplied.]

Methods

Add | Overloaded. Adds a relation to the collection.
Clear | Clears the collection of any relations.
Contains | Overloaded. [To be supplied.]
CopyTo (inherited from BaseCollection) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from BaseCollection) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Remove | Overloaded. [To be supplied.]
ShouldPersistAll | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Events

CollectionChanged [To be supplied.]

Protected:

Properties

List (inherited from BaseCollection) [To be supplied.]

Methods

AddCore | Does verification on the table. An ArgumentNullException is thrown if this relation is null. An ArgumentException is thrown if this relation already belongs to this collection, belongs to another collection. A DuplicateNameException is thrown if this collection already has a relation with the same name (case insensitive).
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetDataSet | Gets the dataSet for this collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnCollectionChanged | This method is called whenever the collection changes. Overriders of this method should call the base implementation of this method.
RemoveCore | Does verification on the relation. An ArgumentNullException is thrown if this relation is null. An ArgumentException is thrown if this relation doesn't belong to this collection.

Event Hookup:

Methods

AddOnCollectionChanged | Registers the handler to get events whenever this collection changes.
RemoveOnCollectionChanged | Unregisters the handler from getting events whenever this collection changes.

See Also

RelationsCollection Class | System.Data Namespace


RelationsCollection Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public RelationsCollection();
[C++]
public: RelationsCollection();
[JScript]
public function RelationsCollection();

See Also

RelationsCollection Class | RelationsCollection Members | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RelationsCollection Properties

The properties of the RelationsCollection class are listed below. For a complete list of RelationsCollection class members, see the RelationsCollection Members topic.

Public:

All | Gets or sets all of the relations in the collection.
Count (inherited from BaseCollection) | [To be supplied.]
IsReadOnly (inherited from BaseCollection) | [To be supplied.]
IsSynchronized (inherited from BaseCollection) | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the RelationsCollection class.
SyncRoot (inherited from BaseCollection) | [To be supplied.]

Protected:

List (inherited from BaseCollection) [To be supplied.]

See Also

RelationsCollection Class | System.Data Namespace


RelationsCollection.All

Gets or sets all of the relations in the collection.

[Visual Basic]
MustOverride Public Property All As DataRelation ()
[C#]
public DataRelation[] All {abstract get; abstract set;}
[C++]
public: __property virtual DataRelation* get_All() = 0;public: __property virtual void set_All(DataRelation*[]) = 0;
[JScript]
public abstract function get All() : DataRelation[];
public abstract function set All(DataRelation[]);

Property Value

An array of DataRelation objects.

Remarks

The All method throws an exception if any relation that is added shouldn't be added and if any relation is removed shouldn't be removed. If an exception is thrown, the collection returns to its original state.

The OnCollectionChanged event occurs if setting the property to a new values succeeds.

See Also

RelationsCollection Class | RelationsCollection Members | System.Data Namespace | Add | Remove


RelationsCollection.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the RelationsCollection class.

Overload List

Gets the relation specified by index.

[Visual Basic] Overloads MustOverride Public Default ReadOnly Property Item(Integer) As DataRelation
[C#] public DataRelation this[int] {abstract get;}
[C++] public: __property virtual DataRelation* get_Item(int) = 0;
[JScript] RelationsCollection.Item (int)

Gets the relation specified by name.

[Visual Basic] Overloads MustOverride Public Default ReadOnly Property Item(String) As DataRelation
[C#] public DataRelation this[String] {abstract get;}
[C++] public: __property virtual DataRelation* get_Item(String*) = 0;
[JScript] RelationsCollection.Item (String)

See Also

RelationsCollection Class | RelationsCollection Members | System.Data Namespace


RelationsCollection.Item (Int32)

Gets the relation specified by index.

[C#] In C#, this member is the indexer for the RelationsCollection class.

[Visual Basic]
Overloads MustOverride Public Default ReadOnly Property Item( _
   ByVal index As Integer _
) As DataRelation
[C#]
public DataRelation this[
   int index
] {abstract get;}
[C++]
public: __property virtual DataRelation* get_Item(
   int index
) = 0;
[JScript]
abstract returnValue = RelationsCollectionObject.Item(index);
-or-
abstract returnValue = RelationsCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
The zero-based index to find.

Parameters [Visual Basic, C#, C++]

index
The zero-based index to find.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | The collection doesn't have a member at this index.

See Also

RelationsCollection Class | RelationsCollection Members | System.Data Namespace | RelationsCollection.Item Overload List


RelationsCollection.Item (String)

Gets the relation specified by name.

[C#] In C#, this member is the indexer for the RelationsCollection class.

[Visual Basic]
Overloads MustOverride Public Default ReadOnly Property Item( _
   ByVal name As String _
) As DataRelation
[C#]
public DataRelation this[
   string name
] {abstract get;}
[C++]
public: __property virtual DataRelation* get_Item(
   String* name
) = 0;
[JScript]
abstract returnValue = RelationsCollectionObject.Item(name);
-or-
abstract returnValue = RelationsCollectionObject(name);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
The name of the relation to find.

Parameters [Visual Basic, C#, C++]

name
The name of the relation to find.

See Also

RelationsCollection Class | RelationsCollection Members | System.Data Namespace | RelationsCollection.Item Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RelationsCollection Methods

The methods of the RelationsCollection class are listed below. For a complete list of RelationsCollection class members, see the RelationsCollection Members topic.

Public:

Add | Overloaded. Adds a relation to the collection.
Clear | Clears the collection of any relations.
Contains | Overloaded. [To be supplied.]
CopyTo (inherited from BaseCollection) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from BaseCollection) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Remove | Overloaded. [To be supplied.]
ShouldPersistAll | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

AddCore | Does verification on the table. An ArgumentNullException is thrown if this relation is null. An ArgumentException is thrown if this relation already belongs to this collection, belongs to another collection. A DuplicateNameException is thrown if this collection already has a relation with the same name (case insensitive).
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetDataSet | Gets the dataSet for this collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnCollectionChanged | This method is called whenever the collection changes. Overriders of this method should call the base implementation of this method.
RemoveCore | Does verification on the relation. An ArgumentNullException is thrown if this relation is null. An ArgumentException is thrown if this relation doesn't belong to this collection.

Event Hookup:

AddOnCollectionChanged | Registers the handler to get events whenever this collection changes.
RemoveOnCollectionChanged | Unregisters the handler from getting events whenever this collection changes.

See Also

RelationsCollection Class | System.Data Namespace


RelationsCollection.Add

Adds a relation to the collection.

Overload List

Creates a relation given the parameters and adds it to the collection. An ArgumentException is thrown if this relation already belongs to this collection or belongs to another collection. A DuplicateNameException is thrown if this collection already has a relation with the same name (case insensitive). An InvalidConstraintException is thrown if the relation can't be created based on the parameters. The CollectionChanged event is fired if it succeeds.

[Visual Basic] Overloads Overridable Public Function Add(String, DataColumn, DataColumn) As DataRelation
[C#] public virtual DataRelation Add(String, DataColumn, DataColumn);
[C++] public: virtual DataRelation* Add(String*, DataColumn, DataColumn);
[JScript] public function Add(String, DataColumn, DataColumn) : DataRelation;

Creates a relation given the parameters and adds it to the collection. An ArgumentException is thrown if this relation already belongs to this collection or belongs to another collection. A DuplicateNameException is thrown if this collection already has a relation with the same name (case insensitive). An InvalidConstraintException is thrown if the relation can't be created based on the parameters. The CollectionChanged event is fired if it succeeds.

[Visual Basic] Overloads Overridable Public Function Add(String, DataColumn, DataColumn, Boolean) As DataRelation
[C#] public virtual DataRelation Add(String, DataColumn, DataColumn, bool);
[C++] public: virtual DataRelation* Add(String*, DataColumn, DataColumn, bool);
[JScript] public function Add(String, DataColumn, DataColumn, Boolean) : DataRelation;

Creates a relation given the parameters and adds it to the collection. The name is defaulted. An ArgumentException is thrown if this relation already belongs to this collection or belongs to another collection. An InvalidConstraintException is thrown if the relation can't be created based on the parameters. The CollectionChanged event is fired if it succeeds.

[Visual Basic] Overloads Overridable Public Function Add(DataColumn, DataColumn) As DataRelation
[C#] public virtual DataRelation Add(DataColumn, DataColumn);
[C++] public: virtual DataRelation* Add(DataColumn*, DataColumn*);
[JScript] public function Add(DataColumn, DataColumn) : DataRelation;

Creates a relation given the parameters and adds it to the collection. An ArgumentNullException is thrown if this relation is null. An ArgumentException is thrown if this relation already belongs to this collection, belongs to another collection, or if this collection already has a relation with the same name (case insensitive). An InvalidRelationException is thrown if the relation can't be created based on the parameters. The CollectionChanged event is fired if it succeeds.

[Visual Basic] Overloads Overridable Public Function Add(String, DataColumn(), DataColumn()) As DataRelation
[C#] public virtual DataRelation Add(String, DataColumn[], DataColumn[]);
[C++] public: virtual DataRelation* Add(String*, DataColumn[], DataColumn[]);
[JScript] public function Add(String, DataColumn[], DataColumn[]) : DataRelation;

Creates a relation given the parameters and adds it to the collection. An ArgumentNullException is thrown if this relation is null. An ArgumentException is thrown if this relation already belongs to this collection, belongs to another collection, or if this collection already has a relation with the same name (case insensitive). An InvalidRelationException is thrown if the relation can't be created based on the parameters. The CollectionChanged event is fired if it succeeds.

[Visual Basic] Overloads Overridable Public Function Add(String, DataColumn(), DataColumn(), Boolean) As DataRelation
[C#] public virtual DataRelation Add(String, DataColumn[], DataColumn[], bool);
[C++] public: virtual DataRelation* Add(String*, DataColumn[], DataColumn[], bool);
[JScript] public function Add(String, DataColumn[], DataColumn[], Boolean) : DataRelation;

Creates a relation given the parameters and adds it to the collection. The name is defaulted. An ArgumentException is thrown if this relation already belongs to this collection or belongs to another collection. An InvalidConstraintException is thrown if the relation can't be created based on the parameters. The CollectionChanged event is fired if it succeeds.

[Visual Basic] Overloads Overridable Public Function Add(DataColumn(), DataColumn()) As DataRelation
[C#] public virtual DataRelation Add(DataColumn[], DataColumn[]);
[C++] public: virtual DataRelation* Add(DataColumn*[], DataColumn*[]);
[JScript] public function Add(DataColumn[], DataColumn[]) : DataRelation;

Adds the relation to the collection. An ArgumentNullException is thrown if this relation is null. An ArgumentException is thrown if this relation already belongs to this collection or belongs to another collection A DuplicateNameException is thrown if this collection already has a relation with the same name (case insensitive). An InvalidConstraintException is thrown if the relation has entered an invalid state since it's been created. The CollectionChanged event is fired if it succeeds.

[Visual Basic] Overloads Public Sub Add(DataRelation)
[C#] public void Add(DataRelation);
[C++] public: void Add(DataRelation*);
[JScript] public function Add(DataRelation);

See Also

RelationsCollection Class | RelationsCollection Members | System.Data Namespace


RelationsCollection.Add (String, DataColumn, DataColumn)

Creates a relation given the parameters and adds it to the collection. An ArgumentException is thrown if this relation already belongs to this collection or belongs to another collection. A DuplicateNameException is thrown if this collection already has a relation with the same name (case insensitive). An InvalidConstraintException is thrown if the relation can't be created based on the parameters. The CollectionChanged event is fired if it succeeds.

[Visual Basic]
Overloads Overridable Public Function Add( _
   ByVal name As String, _
   ByVal parentColumn As DataColumn, _
   ByVal childColumn As DataColumn _
) As DataRelation
[C#]
public virtual DataRelation Add(
   string name,
   DataColumn parentColumn,
   DataColumn childColumn
);
[C++]
public: virtual DataRelation* Add(
   String* name,
   DataColumn* parentColumn,
   DataColumn* childColumn
);
[JScript]
public function Add(
   name : String,
   parentColumn : DataColumn,
   childColumn : DataColumn
) : DataRelation;

Parameters

name
The name of the relation.
parentColumn
parent column of relation.
childColumn
child column of relation.

Return Value

The created relation.

See Also

RelationsCollection Class | RelationsCollection Members | System.Data Namespace | RelationsCollection.Add Overload List


RelationsCollection.Add (String, DataColumn, DataColumn, Boolean)

Creates a relation given the parameters and adds it to the collection. An ArgumentException is thrown if this relation already belongs to this collection or belongs to another collection. A DuplicateNameException is thrown if this collection already has a relation with the same name (case insensitive). An InvalidConstraintException is thrown if the relation can't be created based on the parameters. The CollectionChanged event is fired if it succeeds.

[Visual Basic]
Overloads Overridable Public Function Add( _
   ByVal name As String, _
   ByVal parentColumn As DataColumn, _
   ByVal childColumn As DataColumn, _
   ByVal createConstraints As Boolean _
) As DataRelation
[C#]
public virtual DataRelation Add(
   string name,
   DataColumn parentColumn,
   DataColumn childColumn,
   bool createConstraints
);
[C++]
public: virtual DataRelation* Add(
   String* name,
   DataColumn* parentColumn,
   DataColumn* childColumn,
   bool createConstraints
);
[JScript]
public function Add(
   name : String,
   parentColumn : DataColumn,
   childColumn : DataColumn,
   createConstraints : Boolean
) : DataRelation;

Parameters

name
The name of the relation.
parentColumn
parent column of relation.
childColumn
child column of relation.
createConstraints
whether to create a constraints

Return Value

The created relation.

See Also

RelationsCollection Class | RelationsCollection Members | System.Data Namespace | RelationsCollection.Add Overload List


RelationsCollection.Add (DataColumn, DataColumn)

Creates a relation given the parameters and adds it to the collection. The name is defaulted. An ArgumentException is thrown if this relation already belongs to this collection or belongs to another collection. An InvalidConstraintException is thrown if the relation can't be created based on the parameters. The CollectionChanged event is fired if it succeeds.

[Visual Basic]
Overloads Overridable Public Function Add( _
   ByVal parentColumn As DataColumn, _
   ByVal childColumn As DataColumn _
) As DataRelation
[C#]
public virtual DataRelation Add(
   DataColumn parentColumn,
   DataColumn childColumn
);
[C++]
public: virtual DataRelation* Add(
   DataColumn* parentColumn,
   DataColumn* childColumn
);
[JScript]
public function Add(
   parentColumn : DataColumn,
   childColumn : DataColumn
) : DataRelation;

Parameters

parentColumn
parent column of relation.
childColumn
child column of relation.

Return Value

The created relation.

See Also

RelationsCollection Class | RelationsCollection Members | System.Data Namespace | RelationsCollection.Add Overload List


RelationsCollection.Add (String, DataColumn[], DataColumn[])

Creates a relation given the parameters and adds it to the collection. An ArgumentNullException is thrown if this relation is null. An ArgumentException is thrown if this relation already belongs to this collection, belongs to another collection, or if this collection already has a relation with the same name (case insensitive). An InvalidRelationException is thrown if the relation can't be created based on the parameters. The CollectionChanged event is fired if it succeeds.

[Visual Basic]
Overloads Overridable Public Function Add( _
   ByVal name As String, _
   ByVal parentColumns() As DataColumn, _
   ByVal childColumns() As DataColumn _
) As DataRelation
[C#]
public virtual DataRelation Add(
   string name,
   DataColumn[] parentColumns,
   DataColumn[] childColumns
);
[C++]
public: virtual DataRelation* Add(
   String* name,
   DataColumn* parentColumns[],
   DataColumn* childColumns[]
);
[JScript]
public function Add(
   name : String,
   parentColumns : DataColumn[],
   childColumns : DataColumn[]
) : DataRelation;

Parameters

name
The name of the relation.
parentColumns
parent columns of relation.
childColumns
child columns of relation.

Return Value

The created relation.

See Also

RelationsCollection Class | RelationsCollection Members | System.Data Namespace | RelationsCollection.Add Overload List


RelationsCollection.Add (String, DataColumn[], DataColumn[], Boolean)

Creates a relation given the parameters and adds it to the collection. An ArgumentNullException is thrown if this relation is null. An ArgumentException is thrown if this relation already belongs to this collection, belongs to another collection, or if this collection already has a relation with the same name (case insensitive). An InvalidRelationException is thrown if the relation can't be created based on the parameters. The CollectionChanged event is fired if it succeeds.

[Visual Basic]
Overloads Overridable Public Function Add( _
   ByVal name As String, _
   ByVal parentColumns() As DataColumn, _
   ByVal childColumns() As DataColumn, _
   ByVal createConstraints As Boolean _
) As DataRelation
[C#]
public virtual DataRelation Add(
   string name,
   DataColumn[] parentColumns,
   DataColumn[] childColumns,
   bool createConstraints
);
[C++]
public: virtual DataRelation* Add(
   String* name,
   DataColumn* parentColumns[],
   DataColumn* childColumns[],
   bool createConstraints
);
[JScript]
public function Add(
   name : String,
   parentColumns : DataColumn[],
   childColumns : DataColumn[],
   createConstraints : Boolean
) : DataRelation;

Parameters

name
The name of the relation.
parentColumns
parent columns of relation.
childColumns
child columns of relation.
createConstraints
whether to create a constraints

Return Value

The created relation.

See Also

RelationsCollection Class | RelationsCollection Members | System.Data Namespace | RelationsCollection.Add Overload List


RelationsCollection.Add (DataColumn[], DataColumn[])

Creates a relation given the parameters and adds it to the collection. The name is defaulted. An ArgumentException is thrown if this relation already belongs to this collection or belongs to another collection. An InvalidConstraintException is thrown if the relation can't be created based on the parameters. The CollectionChanged event is fired if it succeeds.

[Visual Basic]
Overloads Overridable Public Function Add( _
   ByVal parentColumns() As DataColumn, _
   ByVal childColumns() As DataColumn _
) As DataRelation
[C#]
public virtual DataRelation Add(
   DataColumn[] parentColumns,
   DataColumn[] childColumns
);
[C++]
public: virtual DataRelation* Add(
   DataColumn* parentColumns[],
   DataColumn* childColumns[]
);
[JScript]
public function Add(
   parentColumns : DataColumn[],
   childColumns : DataColumn[]
) : DataRelation;

Parameters

parentColumns
parent columns of relation.
childColumns
child columns of relation.

Return Value

The created relation.

See Also

RelationsCollection Class | RelationsCollection Members | System.Data Namespace | RelationsCollection.Add Overload List


RelationsCollection.Add (DataRelation)

Adds the relation to the collection. An ArgumentNullException is thrown if this relation is null. An ArgumentException is thrown if this relation already belongs to this collection or belongs to another collection A DuplicateNameException is thrown if this collection already has a relation with the same name (case insensitive). An InvalidConstraintException is thrown if the relation has entered an invalid state since it's been created. The CollectionChanged event is fired if it succeeds.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal relation As DataRelation _
)
[C#]
public void Add(
   DataRelation relation
);
[C++]
public: void Add(
   DataRelation* relation
);
[JScript]
public function Add(
   relation : DataRelation
);

Parameters

relation
The relation to add.

See Also

RelationsCollection Class | RelationsCollection Members | System.Data Namespace | RelationsCollection.Add Overload List


RelationsCollection.AddCore

Does verification on the table. An ArgumentNullException is thrown if this relation is null. An ArgumentException is thrown if this relation already belongs to this collection, belongs to another collection. A DuplicateNameException is thrown if this collection already has a relation with the same name (case insensitive).

[Visual Basic]
Overridable Protected Sub AddCore( _
   ByVal relation As DataRelation _
)
[C#]
protected virtual void AddCore(
   DataRelation relation
);
[C++]
protected: virtual void AddCore(
   DataRelation* relation
);
[JScript]
protected function AddCore(
   relation : DataRelation
);

Parameters

relation
The relation to check.

See Also

RelationsCollection Class | RelationsCollection Members | System.Data Namespace


RelationsCollection.AddOnCollectionChanged

Registers the handler to get events whenever this collection changes.

[Visual Basic]
Public Sub AddOnCollectionChanged( _
   ByVal handler As CollectionChangeEventHandler _
)
[C#]
public void AddOnCollectionChanged(
   CollectionChangeEventHandler handler
);
[C++]
public: void AddOnCollectionChanged(
   CollectionChangeEventHandler* handler
);
[JScript]
public function AddOnCollectionChanged(
   handler : CollectionChangeEventHandler
);

Parameters

handler
The event hook

See Also

RelationsCollection Class | RelationsCollection Members | System.Data Namespace


RelationsCollection.Clear

Clears the collection of any relations.

[Visual Basic]
Overridable Public Sub Clear()
[C#]
public virtual void Clear();
[C++]
public: virtual void Clear();
[JScript]
public function Clear();

See Also

RelationsCollection Class | RelationsCollection Members | System.Data Namespace


RelationsCollection.Contains

[To be supplied.]

Overload List

Returns true if this collection has a relation with the given name (case insensitive), false otherwise.

[Visual Basic] Overloads Overridable Public Function Contains(String) As Boolean
[C#] public virtual bool Contains(String);
[C++] public: virtual bool Contains(String*);
[JScript] public function Contains(String) : Boolean;

Returns true if this collection has a relation at this index, false otherwise.

[Visual Basic] Overloads Overridable Public Function Contains(Integer) As Boolean
[C#] public virtual bool Contains(int);
[C++] public: virtual bool Contains(int);
[JScript] public function Contains(int) : Boolean;

See Also

RelationsCollection Class | RelationsCollection Members | System.Data Namespace


RelationsCollection.Contains (String)

Returns true if this collection has a relation with the given name (case insensitive), false otherwise.

[Visual Basic]
Overloads Overridable Public Function Contains( _
   ByVal name As String _
) As Boolean
[C#]
public virtual bool Contains(
   string name
);
[C++]
public: virtual bool Contains(
   String* name
);
[JScript]
public function Contains(
   name : String
) : Boolean;

Parameters

name
name to test.

Return Value

Whether a relation exists with this name.

See Also

RelationsCollection Class | RelationsCollection Members | System.Data Namespace | RelationsCollection.Contains Overload List


RelationsCollection.Contains (Int32)

Returns true if this collection has a relation at this index, false otherwise.

[Visual Basic]
Overloads Overridable Public Function Contains( _
   ByVal index As Integer _
) As Boolean
[C#]
public virtual bool Contains(
   int index
);
[C++]
public: virtual bool Contains(
   int index
);
[JScript]
public function Contains(
   index : int
) : Boolean;

Parameters

index
index to test.

Return Value

Whether a relation exists at this index.

See Also

RelationsCollection Class | RelationsCollection Members | System.Data Namespace | RelationsCollection.Contains Overload List


RelationsCollection.GetDataSet

Gets the dataSet for this collection.

[Visual Basic]
MustOverride Protected Function GetDataSet() As DataSet
[C#]
protected abstract DataSet GetDataSet();
[C++]
protected: virtual DataSet* GetDataSet() = 0;
[JScript]
protected abstract function GetDataSet() : DataSet;

Return Value

the dataSet.

See Also

RelationsCollection Class | RelationsCollection Members | System.Data Namespace


RelationsCollection.OnCollectionChanged

This method is called whenever the collection changes. Overriders of this method should call the base implementation of this method.

[Visual Basic]
Overridable Protected Sub OnCollectionChanged( _
   ByVal ccevent As CollectionChangeEventArgs _
)
[C#]
protected virtual void OnCollectionChanged(
   CollectionChangeEventArgs ccevent
);
[C++]
protected: virtual void OnCollectionChanged(
   CollectionChangeEventArgs* ccevent
);
[JScript]
protected function OnCollectionChanged(
   ccevent : CollectionChangeEventArgs
);

Parameters

ccevent
The event information.

See Also

RelationsCollection Class | RelationsCollection Members | System.Data Namespace


RelationsCollection.Remove

[To be supplied.]

Overload List

Removes the relation at the given index from the collection. An IndexOutOfRangeException is thrown if this collection doesn't have a relation at this index. The CollectionChanged event is fired if it succeeds.

[Visual Basic] Overloads Public Sub Remove(Integer)
[C#] public void Remove(int);
[C++] public: void Remove(int);
[JScript] public function Remove(int);

Removes the relation with the given name from the collection. An IndexOutOfRangeException is thrown if this collection doesn't have a relation with that name The CollectionChanged event is fired if it succeeds.

[Visual Basic] Overloads Public Sub Remove(String)
[C#] public void Remove(String);
[C++] public: void Remove(String*);
[JScript] public function Remove(String);

Removes the given relation from the collection. An ArgumentNullException is thrown if this relation is null. An ArgumentException is thrown if this relation doesn't belong to this collection. The CollectionChanged event is fired if it succeeds.

[Visual Basic] Overloads Public Sub Remove(DataRelation)
[C#] public void Remove(DataRelation);
[C++] public: void Remove(DataRelation*);
[JScript] public function Remove(DataRelation);

See Also

RelationsCollection Class | RelationsCollection Members | System.Data Namespace


RelationsCollection.Remove (Int32)

Removes the relation at the given index from the collection. An IndexOutOfRangeException is thrown if this collection doesn't have a relation at this index. The CollectionChanged event is fired if it succeeds.

[Visual Basic]
Overloads Public Sub Remove( _
   ByVal index As Integer _
)
[C#]
public void Remove(
   int index
);
[C++]
public: void Remove(
   int index
);
[JScript]
public function Remove(
   index : int
);

Parameters

index
The index at which to remove a relation.

See Also

RelationsCollection Class | RelationsCollection Members | System.Data Namespace | RelationsCollection.Remove Overload List


RelationsCollection.Remove (String)

Removes the relation with the given name from the collection. An IndexOutOfRangeException is thrown if this collection doesn't have a relation with that name The CollectionChanged event is fired if it succeeds.

[Visual Basic]
Overloads Public Sub Remove( _
   ByVal name As String _
)
[C#]
public void Remove(
   string name
);
[C++]
public: void Remove(
   String* name
);
[JScript]
public function Remove(
   name : String
);

Parameters

name
The name of the relation to remove.

See Also

RelationsCollection Class | RelationsCollection Members | System.Data Namespace | RelationsCollection.Remove Overload List


RelationsCollection.Remove (DataRelation)

Removes the given relation from the collection. An ArgumentNullException is thrown if this relation is null. An ArgumentException is thrown if this relation doesn't belong to this collection. The CollectionChanged event is fired if it succeeds.

[Visual Basic]
Overloads Public Sub Remove( _
   ByVal relation As DataRelation _
)
[C#]
public void Remove(
   DataRelation relation
);
[C++]
public: void Remove(
   DataRelation* relation
);
[JScript]
public function Remove(
   relation : DataRelation
);

Parameters

relation
The relation to remove.

See Also

RelationsCollection Class | RelationsCollection Members | System.Data Namespace | RelationsCollection.Remove Overload List


RelationsCollection.RemoveCore

Does verification on the relation. An ArgumentNullException is thrown if this relation is null. An ArgumentException is thrown if this relation doesn't belong to this collection.

[Visual Basic]
Overridable Protected Sub RemoveCore( _
   ByVal relation As DataRelation _
)
[C#]
protected virtual void RemoveCore(
   DataRelation relation
);
[C++]
protected: virtual void RemoveCore(
   DataRelation* relation
);
[JScript]
protected function RemoveCore(
   relation : DataRelation
);

Parameters

relation
The relation to check.

See Also

RelationsCollection Class | RelationsCollection Members | System.Data Namespace


RelationsCollection.RemoveOnCollectionChanged

Unregisters the handler from getting events whenever this collection changes.

[Visual Basic]
Public Sub RemoveOnCollectionChanged( _
   ByVal handler As CollectionChangeEventHandler _
)
[C#]
public void RemoveOnCollectionChanged(
   CollectionChangeEventHandler handler
);
[C++]
public: void RemoveOnCollectionChanged(
   CollectionChangeEventHandler* handler
);
[JScript]
public function RemoveOnCollectionChanged(
   handler : CollectionChangeEventHandler
);

Parameters

handler
The event hook

See Also

RelationsCollection Class | RelationsCollection Members | System.Data Namespace


RelationsCollection.ShouldPersistAll

[To be supplied.]

[Visual Basic]
Public Function ShouldPersistAll() As Boolean
[C#]
public bool ShouldPersistAll();
[C++]
public: bool ShouldPersistAll();
[JScript]
public function ShouldPersistAll() : Boolean;

See Also

RelationsCollection Class | RelationsCollection Members | System.Data Namespace


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RelationsCollection Events

The events of the RelationsCollection class are listed below. For a complete list of RelationsCollection class members, see the RelationsCollection Members topic.

Public:

CollectionChanged [To be supplied.]

See Also

RelationsCollection Class | System.Data Namespace


RelationsCollection CollectionChanged Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the CollectionChanged event.

[Visual Basic]
Private Sub RelationsCollectionName_CollectionChanged( _
   ByVal sender As Object, _
   ByVal e As CollectionChangeEventArgs _
)
[C#]
private void RelationsCollectionName_CollectionChanged(
   object sender,
   CollectionChangeEventArgs e
);
[C++]
private: void RelationsCollectionName_CollectionChanged(
   Object* sender,
   CollectionChangeEventArgs* e
);
[JScript]
private RelationsCollectionName_CollectionChanged(
   sender : Object,
   e : CollectionChangeEventArgs
);

Parameters

sender
The source of the event.
e
A System.ComponentModel.CollectionChangeEventArgs that contains the event data.

See Also

RelationsCollection Class | RelationsCollection MembersTopic | System.Data Namespace


RowNotInTableException Class

[To be supplied.]

Object
Exception
SystemException
RowNotInTableException

[Visual Basic]
Public Class RowNotInTableException
   Inherits SystemException
[C#]
public class RowNotInTableException : SystemException
[C++]
public __gc class RowNotInTableException : public SystemException
[JScript]
public class RowNotInTableException extends SystemException

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

RowNotInTableException Members | System.Data Namespace


RowNotInTableException Members

Public:

Constructor

RowNotInTableException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

RowNotInTableException Class | System.Data Namespace


RowNotInTableException Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public RowNotInTableException();
[C++] public: RowNotInTableException();
[JScript] public function RowNotInTableException();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public RowNotInTableException(String);
[C++] public: RowNotInTableException(String*);
[JScript] public function RowNotInTableException(String);

See Also

RowNotInTableException Class | RowNotInTableException Members | System.Data Namespace


RowNotInTableException Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public RowNotInTableException();
[C++]
public: RowNotInTableException();
[JScript]
public function RowNotInTableException();

See Also

RowNotInTableException Class | RowNotInTableException Members | System.Data Namespace | RowNotInTableException Constructor Overload List


RowNotInTableException Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal s As String _
)
[C#]
public RowNotInTableException(
   string s
);
[C++]
public: RowNotInTableException(
   String* s
);
[JScript]
public function RowNotInTableException(
   s : String
);

Parameters

s
[To be supplied.]

See Also

RowNotInTableException Class | RowNotInTableException Members | System.Data Namespace | RowNotInTableException Constructor Overload List


RowsCollection Class

Represents a collection of rows for a DataTable.

Object
BaseCollection
RowsCollection

[Visual Basic]
Public Class RowsCollection
   Inherits BaseCollection
[C#]
public class RowsCollection : BaseCollection
[C++]
public __gc class RowsCollection : public BaseCollection
[JScript]
public class RowsCollection extends BaseCollection

Remarks

The RowsCollection is a major component of the DataTable. While the ColumnsCollection defines the schema of the table, the RowsCollection contains the actual data for the table, where each DataRow in the RowsCollection represents a single row.

A RowsCollection object contains all of the DataRow objects for a given DataTable object.

The RowsCollection class uses standard Add and Remove methods, as well as an All method which returns all rows in the collection.

The RowsCollection class also contains the Find method that allow you to search the collection for rows containing specific values. You can also use the Contains method to determine if any row contains specific data.

Requirements

Namespace: System.Data

Assembly: System.Data.dll

Example [Visual Basic]

The following example creates a RowsCollection object from a DataTable returned from a System.WinForms.DataGrid control. The code then prints the count of all the elements in the collection as well as columns 1 and 2 of each item in the collection.

[Visual Basic]

Private Sub GetCollectionFromDataGrid()
   Dim rc As RowsCollection
   Set rc = DataGrid1.DataGridTable.DataTable.Rows
   Console.WriteLine(rc.Count)
   Dim tempRow As DataRow
   For Each tempRow In rc
       Console.WriteLine(tempRow.Item(1), tempRow.Item(2))
   Next
End Sub

See Also

RowsCollection Members | System.Data Namespace | DataRow | NewRow


RowsCollection Members

Public:

Properties

All | Gets all of the rows in the table, in order of addition.
Count | Gets the count of the rows in RowsCollection.
IsReadOnly (inherited from BaseCollection) | [To be supplied.]
IsSynchronized (inherited from BaseCollection) | [To be supplied.]
Item | Gets the row at the specified index. In C#, this member is the indexer for the RowsCollection class.
SyncRoot (inherited from BaseCollection) | [To be supplied.]

Methods

Add | Overloaded. Adds a DataRow to the RowsCollection.
AddUpdate | Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
Clear | Clears the collection of all rows.
Contains | Overloaded. Gets a value indicating whether any row in the collection contains a specified value in the primary key or keys column.
CopyTo (inherited from BaseCollection) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Find | Overloaded. Gets a specified DataRow.
GetEnumerator (inherited from BaseCollection) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Remove | Overloaded. Removes a specific row from the RowsCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

List Gets the rows in the collection as an object.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RowsCollection Class | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RowsCollection Properties

The properties of the RowsCollection class are listed below. For a complete list of RowsCollection class members, see the RowsCollection Members topic.

Public:

All | Gets all of the rows in the table, in order of addition.
Count | Gets the count of the rows in RowsCollection.
IsReadOnly (inherited from BaseCollection) | [To be supplied.]
IsSynchronized (inherited from BaseCollection) | [To be supplied.]
Item | Gets the row at the specified index. In C#, this member is the indexer for the RowsCollection class.
SyncRoot (inherited from BaseCollection) | [To be supplied.]

Protected:

List Gets the rows in the collection as an object.

See Also

RowsCollection Class | System.Data Namespace


RowsCollection.All

Gets all of the rows in the table, in order of addition.

[Visual Basic]
Public ReadOnly Property All As DataRow ()
[C#]
public DataRow[] All {get;}
[C++]
public: __property DataRow* get_All();
[JScript]
public function get All() : DataRow[];

Property Value

A DataRow array.

Remarks

If you are using the All method to set the rows for a DataTable, be sure to use the DataTable object's NewRow method to create each DataRow. See the example below.

Example [Visual Basic]

The following example gets and sets the All property.

[Visual Basic]

Private Sub SetRows()
   Dim arrRows() As DataRow
   Dim t As DataTable
   ' Get the DataTable of a DataGrid control.
   Set t = DataGrid1.DataGridTable.DataTable
   ' Create 10 new DataRow objects
   Dim i As Integer
   For i = 0 To 9
      Set arrRows(i) = t.NewRow
      ' Code to set values not show.

   Next i
   Dim rows As New RowsCollection
   Set rows.All = arrRows
End Sub

Private Sub GetRows()
   Dim arrRows() As DataRow
   ' Get the DataTable of a DataGrid control.
   Dim t As DataTable
   Set t = DataGrid1.DataGridTable.DataTable
   Set arrRows = t.Rows.All
   ' Iterate though the array to get values.
   Dim i As Integer
   For i = 0 to Ubound(arrRows)
      Console.WriteLine(arrRows(i)(0))
   Next i
End Sub

See Also

RowsCollection Class | RowsCollection Members | System.Data Namespace | Add | DataRow | DataTable | NewRow


RowsCollection.Count

Gets the count of the rows in RowsCollection.

[Visual Basic]
Overridable Public ReadOnly Property Count As Integer
[C#]
public int Count {override get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;

Example [Visual Basic]

The following example stores the values of a single column in a temporary string variable. To iterate through the collection of DataRow objects, the example uses the Count property to specify the loop limit.

[Visual Basic]

Private Sub GetAllRows()
   ' Declare an array variable for DataRow objects.
   Dim myArray() As DataRow
   Dim t As DataTable
   Dim rc As RowsCollection
   ' Declare variables for a counter and temporary string.
   Dim i As Integer
   Dim sTemp As String
   ' Set the DataTable variable to a DataGrid control's table.
   Set t = DataGrid1.DataGridTable.DataTable
   ' Set the RowsCollection variable to the table's collection.
   Set rc = t.Rows
   For i = 0 To rc.Count - 1
      sTemp &= rc(i).Item(1) & vbcrlf
   Next
   label1.Text = sTemp
End Sub

See Also

RowsCollection Class | RowsCollection Members | System.Data Namespace


RowsCollection.Item

Gets the row at the specified index.

[C#] In C#, this member is the indexer for the RowsCollection class.

[Visual Basic]
Public Default ReadOnly Property Item( _
   ByVal index As Integer _
) As DataRow
[C#]
public DataRow this[
   int index
] {get;}
[C++]
public: __property DataRow* get_Item(
   int index
);
[JScript]
returnValue = RowsCollectionObject.Item(index);
-or-
returnValue = RowsCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
The zero-based index of the row to return.

Parameters [Visual Basic, C#, C++]

index
The zero-based index of the row to return.

Property Value

The specified DataRow.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | There is no row at the specified index.

Remarks

The Contains method is used determine if any rows in the collection contains a specified value.

Example [Visual Basic]

The following example prints the value of column 1 in a DataRow object. The example uses the RowsCollection object's Item property (RowsCollection indexer) to specify which row to print.

[Visual Basic]

Private Sub GetRowAtIndex(i As Integer)
   Dim rc As RowsCollection
   Set rc = DataGrid1.DataGridTable.DataTable.Rows
   Dim row As DataRow
   Set row = rc(DataGrid1.CurrentCell.RowNumber)
   edit1.Text = row(i)
End Sub

See Also

RowsCollection Class | RowsCollection Members | System.Data Namespace | Contains


RowsCollection.List

Gets the rows in the collection as an object.

[Visual Basic]
Overridable Protected ReadOnly Property List As ObjectList
[C#]
protected ObjectList List {override get;}
[C++]
protected: __property virtual ObjectList* get_List();
[JScript]
protected function get List() : ObjectList;

Property Value

An ObjectList that contains all of the rows.

See Also

RowsCollection Class | RowsCollection Members | System.Data Namespace | ObjectList


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RowsCollection Methods

The methods of the RowsCollection class are listed below. For a complete list of RowsCollection class members, see the RowsCollection Members topic.

Public:

Add | Overloaded. Adds a DataRow to the RowsCollection.
AddUpdate | Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
Clear | Clears the collection of all rows.
Contains | Overloaded. Gets a value indicating whether any row in the collection contains a specified value in the primary key or keys column.
CopyTo (inherited from BaseCollection) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Find | Overloaded. Gets a specified DataRow.
GetEnumerator (inherited from BaseCollection) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Remove | Overloaded. Removes a specific row from the RowsCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RowsCollection Class | System.Data Namespace


RowsCollection.Add

Adds a DataRow to the RowsCollection.

Overload List

Adds the specified DataRow to the RowsCollection object.

[Visual Basic] Overloads Public Sub Add(DataRow)
[C#] public void Add(DataRow);
[C++] public: void Add(DataRow*);
[JScript] public function Add(DataRow);

Creates a row using specified values and adds it to the RowsCollection.

[Visual Basic] Overloads Overridable Public Function Add(Object()) As DataRow
[C#] public virtual DataRow Add(Object[]);
[C++] public: virtual DataRow* Add(Object*[]);
[JScript] public function Add(Object[]) : DataRow;

Example [Visual Basic]

The following example uses the Add method to create and add a new DataRow object to a RowsCollection object.

Note This example shows how to use one of the overloaded versions of Add. For other examples that may be available, see the individual overload topics.

[Visual Basic]

' The example presumes a DataTable with three columns. The first
' DataColumn object has its AutoIncrement property set to true
' necessitating that the first value of the array be set to
' System.Object.Empty.
Private Sub AddRowByValues()
   Dim t As DataTable
   Dim rc As RowsCollection
   Dim myRow As DataRow
   Dim rowVals(2) As Object
   Set t = DataGrid1.DataGridTable.DataTable
   Set rc = t.Rows
   rowVals(0) = System.Object.Empty
   rowVals(1) = "hello"
   rowVals(2) = "world"
   Set myRow = rc.Add(rowVals)
End Sub

See Also

RowsCollection Class | RowsCollection Members | System.Data Namespace


RowsCollection.Add (DataRow)

Adds the specified DataRow to the RowsCollection object.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal row As DataRow _
)
[C#]
public void Add(
   DataRow row
);
[C++]
public: void Add(
   DataRow* row
);
[JScript]
public function Add(
   row : DataRow
);

Parameters

row
The DataRow to add.

Exceptions

Exception Type | Condition
ArgumentNullException | The row is null.
ArgumentException | The row either belongs to another table or already belongs to this table.
ConstraintException | The addition invalidates a constraint.
NoNullAllowedException | The addition tries to put a null in a DataColumn where AllowNull is false

Remarks

To create a new DataRow, you must use the DataTable class's NewRow method. When you use the NewRow method, a new DataRow object is returned using the schema of parent DataTable. After you create the DataRow object and set the values for each of its columns, use the Add method to add the object to the collection.

Throws an exception if the user throws an exception in the RowChanging event. If an exception occurs, the row is not added to the table.

Example [Visual Basic]

The following example uses the Add method to add a new DataRow to a RowsCollection object.

[Visual Basic]

Private Sub AddDataRow()
   Dim t As DataTable
   Dim rc As RowsCollection
   Dim r As DataRow
   Set t = DataGrid1.DataGridTable.DataTable
   Set rc = t.Rows
   Set r = t.NewRow
   r(0) = "hello"
   r(1) = "world"
   rc.Add(r)
End Sub

See Also

RowsCollection Class | RowsCollection Members | System.Data Namespace | RowsCollection.Add Overload List | All | Clear | DataTable | DataRow | NewRow | Remove


RowsCollection.Add (Object[])

Creates a row using specified values and adds it to the RowsCollection.

[Visual Basic]
Overloads Overridable Public Function Add( _
   ByVal values() As Object _
) As DataRow
[C#]
public virtual DataRow Add(
   object[] values
);
[C++]
public: virtual DataRow* Add(
   Object* values[]
);
[JScript]
public function Add(
   values : Object[]
) : DataRow;

Parameters

values
The array of values that are used to create the new row.

Return Value

The new DataRow.

Exceptions

Exception Type | Condition
ArgumentException | The array is larger than the number of columns in the table.
InvalidCastException | A value doesn't match its respective column type.
ConstraintException | Adding the row invalidates a constraint.
NoNullAllowedException | Attempting to put a null in a column where AllowNull is false.

Remarks

If a DataColumn object has its AutoIncrement set to True, System.Object.Empty should be passed to get the default value for that column.

Exceptions can also occur if you throw an exception during either a ColumnChanging or RowChanging event. If an exception occurs, the row is not added to the table.

Example [Visual Basic]

The following example uses the Add method to create and add a new DataRow object to a RowsCollection object.

[Visual Basic]

' The example presumes a DataTable with three columns. The first
' DataColumn object has its AutoIncrement property set to true
' necessitating that the first value of the array be set to
' System.Object.Empty.
Private Sub AddRowByValues()
   Dim t As DataTable
   Dim rc As RowsCollection
   Dim myRow As DataRow
   Dim rowVals(2) As Object
   Set t = DataGrid1.DataGridTable.DataTable
   Set rc = t.Rows
   rowVals(0) = System.Object.Empty
   rowVals(1) = "hello"
   rowVals(2) = "world"
   Set myRow = rc.Add(rowVals)
End Sub

See Also

RowsCollection Class | RowsCollection Members | System.Data Namespace | RowsCollection.Add Overload List | All | Clear | DataTable | DataRow | NewRow | Remove


RowsCollection.AddUpdate

Finds and updates a specific row. If no matching row is found, a new row is created using the given values.

[Visual Basic]
Public Function AddUpdate( _
   ByVal values() As Object _
) As DataRow
[C#]
public DataRow AddUpdate(
   object[] values
);
[C++]
public: DataRow* AddUpdate(
   Object* values[]
);
[JScript]
public function AddUpdate(
   values : Object[]
) : DataRow;

Parameters

values
An array of values used to create the new row.

Return Value

The new DataRow.

Exceptions

Exception Type | Condition
ArgumentException | The array is larger than the number of columns in the table.
InvalidCastException | A value doesn't match its respective column type.
ConstraintException | Adding the row invalidates a constraint.
NoNullAllowedException | Attempting to put a null in a column where AllowNull is false.

Remarks

The AddUpdate method takes an array of values and finds the matching value(s) in the primary key column(s).

If a column has a default value, pass a System.Object.Empty in the array to set the default value for that column. Similarly, if a column has its AutoIncrement property set to true, pass the System.Object.Empty in the array to set the automatically generated value for the row.

Exceptions can also occur during either a ColumnChanging or RowChanging event. If an exception occurs, the row is not added to the table.

Example [Visual Basic]

The following example creates a new row

[Visual Basic]

Private Sub MyAddUpdate()
    Dim t As DataTable
    Dim rc As RowsCollection
    ' Create an array for the values.
    Dim newRow(2) As Object
    ' Get the DataTable of a DataGrid control.
    Set t = DataGrid1.DataGridTable.DataTable
    ' Get the table's RowsCollection.
    Set rc = t.Rows
   ' Set the values of the array.
    newRow(0) = "Hello"
    newRow(1) = "World"
    newRow(2) = "Hello"
    Dim myRow As DataRow
    ' Add the new row to the rows collection.
    Set myRow = rc.AddUpdate(newRow)
    ' To test, print out the values of each column in the row.
    Console.WriteLine(myRow(0), myRow(1), myRow(2))
End Sub

See Also

RowsCollection Class | RowsCollection Members | System.Data Namespace


RowsCollection.Clear

Clears the collection of all rows.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[JScript]
public function Clear();

Example [Visual Basic]

The following example clears a RowsCollection of all items.

[Visual Basic]

Private Sub ClearTable()
   Dim t As DataTable
   Dim rc As RowsCollection
   Set t = DataGrid1.DataGridTable.DataTable
   Set rc = t.Rows
   ' Clear all rows.
   rc.Clear
End Sub

See Also

RowsCollection Class | RowsCollection Members | System.Data Namespace | Add | Remove


RowsCollection.Contains

Gets a value indicating whether any row in the collection contains a specified value in the primary key or keys column.

Overload List

Gets a value indicating if the DataRow with the specified primary key values exists.

[Visual Basic] Overloads Public Function Contains(Object()) As Boolean
[C#] public bool Contains(Object[]);
[C++] public: bool Contains(Object*[]);
[JScript] public function Contains(Object[]) : Boolean;

Gets a value indicating whether the primary key of any row in the collection contains the specified value.

[Visual Basic] Overloads Public Function Contains(Object) As Boolean
[C#] public bool Contains(Object);
[C++] public: bool Contains(Object*);
[JScript] public function Contains(Object) : Boolean;

Example [Visual Basic]

The following example uses the Contains method to determine if a RowsCollection object contains a specific value.

Note This example shows how to use one of the overloaded versions of Contains. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub ColContains()
   Dim t As DataTable
   Dim rc As RowsCollection
   Set t = DataGrid1.DataGridTable.DataTable
   Set rc = t.Rows
   If rc.Contains(Edit1.Text) Then
      Label1.Text = "At least one row contains " & Edit1.Text
   Else
      Label1.Text = "No row contains the value in its primary key field"
   End If
End Sub

See Also

RowsCollection Class | RowsCollection Members | System.Data Namespace


RowsCollection.Contains (Object[])

Gets a value indicating if the DataRow with the specified primary key values exists.

[Visual Basic]
Overloads Public Function Contains( _
   ByVal keys() As Object _
) As Boolean
[C#]
public bool Contains(
   object[] keys
);
[C++]
public: bool Contains(
   Object* keys[]
);
[JScript]
public function Contains(
   keys : Object[]
) : Boolean;

Parameters

keys
An array of primary key values to test for.

Return Value

true if the RowsCollection contains a DataRow with the specified key values; otherwise, false.

Exceptions

Exception Type | Condition
MissingPrimaryKeyException | The table doesn't have a primary key.

Remarks

To use the Contains method with an array of values, the DataTable object to which the RowsCollection object belongs must have at an array of columns designated as a primary keys. See the PrimaryKey property for details on creating an array of primary key columns. The number of array elements must correspond to the number of primary key columns in the DataTable.

Once you have determined that a row contains the specified value, you can use the Find method to return the specific DataRow object with the value.

Example [Visual Basic]

The following example uses the Contains method to find a particular row in a RowsCollection object. The example creates an array of values, one element for each primary key in the table, then passes the array to the method to return a true or false.

[Visual Basic]

Private Sub ContainsArray()
' This example assumes that the DataTable object contains at two
' DataColumn objects designated as primary keys.
   Dim t As DataTable
   Dim rc As RowsCollection
   ' The table has two primary key columns.
   Dim arrKeyVals(1) As Object
   Set t = DataGrid1.DataGridTable.DataTable
   Set rc = t.Rows
   arrKeyVals(0) = "Hello"
   arrKeyVals(1) = "World"
   label1.Text = rc.Contains(arrKeyVals)
End Sub

See Also

RowsCollection Class | RowsCollection Members | System.Data Namespace | RowsCollection.Contains Overload List | PrimaryKey | Find


RowsCollection.Contains (Object)

Gets a value indicating whether the primary key of any row in the collection contains the specified value.

[Visual Basic]
Overloads Public Function Contains( _
   ByVal key As Object _
) As Boolean
[C#]
public bool Contains(
   object key
);
[C++]
public: bool Contains(
   Object* key
);
[JScript]
public function Contains(
   key : Object
) : Boolean;

Parameters

key
The value of the primary key to test for.

Return Value

true if the collection contains a DataRow with the specified primary key value; otherwise, false.

Exceptions

Exception Type | Condition
MissingPrimaryKeyException | The table doesn't have a primary key.

Remarks

To use the Contains method, the DataTable object to which the RowsCollection object belongs to must have at least one column designated as a primary key column. See the PrimaryKey property for details on creating a primary key column.

Once you have determined that a row contains the specified value, you can use the Find method to return the specific DataRow object with the value.

Example [Visual Basic]

The following example uses the Contains method to determine if a RowsCollection object contains a specific value.

[Visual Basic]

Private Sub ColContains()
   Dim t As DataTable
   Dim rc As RowsCollection
   Set t = DataGrid1.DataGridTable.DataTable
   Set rc = t.Rows
   If rc.Contains(Edit1.Text) Then
      Label1.Text = "At least one row contains " & Edit1.Text
   Else
      Label1.Text = "No row contains the value in its primary key field"
   End If
End Sub

See Also

RowsCollection Class | RowsCollection Members | System.Data Namespace | RowsCollection.Contains Overload List | PrimaryKey | Find


RowsCollection.Find

Gets a specified DataRow.

Overload List

Gets the row containing the specified primary key values.

[Visual Basic] Overloads Public Function Find(Object()) As DataRow
[C#] public DataRow Find(Object[]);
[C++] public: DataRow* Find(Object*[]);
[JScript] public function Find(Object[]) : DataRow;

Gets the row specified by the primary key value.

[Visual Basic] Overloads Public Function Find(Object) As DataRow
[C#] public DataRow Find(Object);
[C++] public: DataRow* Find(Object*);
[JScript] public function Find(Object) : DataRow;

Example [Visual Basic]

The following example uses the Find method to find the primary key value "2" in a collection of DataRow objects. The method returns the specific DataRow object allowing you to change its values, as needed.

Note This example shows how to use one of the overloaded versions of Find. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub FindInPKey()
   Dim t As DataTable
   Dim foundRow As DataRow
   Dim rc As RowsCollection
   Set t = DataGrid1.DataGridTable.DataTable
   Set rc = t.Rows
   ' Find the number 2 in the primary key column of the table.
   Set foundRow = rc.Find(2)
   ' Display the value of column 1 in a Label control.
   Label1.Text = foundRow.Item(1)
End Sub

See Also

RowsCollection Class | RowsCollection Members | System.Data Namespace


RowsCollection.Find (Object[])

Gets the row containing the specified primary key values.

[Visual Basic]
Overloads Public Function Find( _
   ByVal keys() As Object _
) As DataRow
[C#]
public DataRow Find(
   object[] keys
);
[C++]
public: DataRow* Find(
   Object* keys[]
);
[JScript]
public function Find(
   keys : Object[]
) : DataRow;

Parameters

keys
An array of primary key values to find. The type of the array is Object.

Return Value

The found DataRow.

Exceptions

Exception Type | Condition
MissingPrimaryKeyException | The table doesn't have a primary key.
IndexOutOfRangeException | No row corresponds to that index value.

Remarks

To use the Find method, the DataTable object to which the RowsCollection object belongs to must have at least one column designated as a Primary Key column. See the PrimaryKey property for details on creating a PrimaryKey column, or an array of DataColumn objects when the table has more than one primary key.

Example [Visual Basic]

The following example uses the values of an array to find a specific row in a collection of DataRow objects. The method presumes a DataTable exists with three primary key columns. After creating an array of the values, the code uses the Find method with the array to get the particular object desired.

[Visual Basic]

Private Sub FindInMultiPKey()
   Dim foundRow As DataRow
   Dim rc As RowsCollection
   ' Create an array for the key values to find.
   Dim findTheseVals(2) As Object
   ' Set the values of the keys to find.
   findTheseVals(0) = "John"
   findTheseVals(1) = "Smith"
   findTheseVals(2) = "5 Main St."
   Set rc = DataGrid1.DataGridTable.DataTable.Rows
   Set foundRow = rc.Find(findTheseVals)
   ' Display column 1 of the found row.
   Label1.Text = foundRow(1)
End Sub

See Also

RowsCollection Class | RowsCollection Members | System.Data Namespace | RowsCollection.Find Overload List | DataTable | PrimaryKey | Contains


RowsCollection.Find (Object)

Gets the row specified by the primary key value.

[Visual Basic]
Overloads Public Function Find( _
   ByVal key As Object _
) As DataRow
[C#]
public DataRow Find(
   object key
);
[C++]
public: DataRow* Find(
   Object* key
);
[JScript]
public function Find(
   key : Object
) : DataRow;

Parameters

key
The primary key value of the DataRow to find.

Return Value

A DataRow containing the primary key value specified.

Exceptions

Exception Type | Condition
MissingPrimaryKeyException | The table doesn't have a primary key.
IndexOutOfRangeException | No row corresponds to the given value.

Remarks

To use the Contains method, the DataTable object to which the RowsCollection object belongs to must have at least one column designated as a primary key column. See the PrimaryKey property for details on creating a primary key column.

Example [Visual Basic]

The following example uses the Find method to find the primary key value "2" in a collection of DataRow objects. The method returns the specific DataRow object allowing you to change its values, as needed.

[Visual Basic]

Private Sub FindInPKey()
   Dim t As DataTable
   Dim foundRow As DataRow
   Dim rc As RowsCollection
   Set t = DataGrid1.DataGridTable.DataTable
   Set rc = t.Rows
   ' Find the number 2 in the primary key column of the table.
   Set foundRow = rc.Find(2)
   ' Display the value of column 1 in a Label control.
   Label1.Text = foundRow.Item(1)
End Sub

See Also

RowsCollection Class | RowsCollection Members | System.Data Namespace | RowsCollection.Find Overload List | DataTable | PrimaryKey | Contains


RowsCollection.Remove

Removes a specific row from the RowsCollection.

Overload List

Removes the row with the specified index from the collection.

[Visual Basic] Overloads Public Sub Remove(Integer)
[C#] public void Remove(int);
[C++] public: void Remove(int);
[JScript] public function Remove(int);

Removes the specified DataRow from the collection.

[Visual Basic] Overloads Public Sub Remove(DataRow)
[C#] public void Remove(DataRow);
[C++] public: void Remove(DataRow*);
[JScript] public function Remove(DataRow);

Example [Visual Basic]

The following example uses the Remove method to delete a found row in a RowsCollection object. The example first uses the Contains method to determine if the rows collection contains a row. If so, the Find method is used to find the specific row, and the Remove method is then used to remove the row.

Note This example shows how to use one of the overloaded versions of Remove. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub RemoveFoundRow()
   Dim t As DataTable
   Dim rc As RowsCollection
   Dim foundRow As DataRow
   Set t = DataGrid1.DataGridTable.DataTable
   Set rc = t.Rows
   ' Test to see if the collection contains the value.
   If rc.Contains(Edit1.Text) Then
      Set foundRow = rc.Find(Edit1.Text)
      rc.Remove foundRow
      Label1.Text= "Row deleted."
   Else
      Label1.Text = "No such row found."
   End If
End Sub

See Also

RowsCollection Class | RowsCollection Members | System.Data Namespace


RowsCollection.Remove (Int32)

Removes the row with the specified index from the collection.

[Visual Basic]
Overloads Public Sub Remove( _
   ByVal index As Integer _
)
[C#]
public void Remove(
   int index
);
[C++]
public: void Remove(
   int index
);
[JScript]
public function Remove(
   index : int
);

Parameters

index
The index of the row to remove.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | No row corresponds to the given value.

Remarks

When a row is removed, data in that row is lost.

You can also use the Clear method to remove all members of the collection at once.

Example [Visual Basic]

The following example removes the last row in a RowsCollection by calling the Remove method.

[Visual Basic]

Private Sub RemoveRowByIndex()
   Dim t As DataTable
   Dim rc As RowsCollection
   Dim foundRow As DataRow
   Set t = DataGrid1.DataGridTable.DataTable
   Set rc = t.Rows
   If rc.Count = 0 Then Exit Sub
   rc.Remove rc.Count - 1
End Sub

See Also

RowsCollection Class | RowsCollection Members | System.Data Namespace | RowsCollection.Remove Overload List | Clear | Add


RowsCollection.Remove (DataRow)

Removes the specified DataRow from the collection.

[Visual Basic]
Overloads Public Sub Remove( _
   ByVal row As DataRow _
)
[C#]
public void Remove(
   DataRow row
);
[C++]
public: void Remove(
   DataRow* row
);
[JScript]
public function Remove(
   row : DataRow
);

Parameters

row
The DataRow to remove.

Remarks

When a row is removed, data in that row is lost.

You can also use the Clear method to remove all members of the collection at once.

Example [Visual Basic]

The following example uses the Remove method to delete a found row in a RowsCollection object. The example first uses the Contains method to determine if the rows collection contains a row. If so, the Find method is used to find the specific row, and the Remove method is then used to remove the row.

[Visual Basic]

Private Sub RemoveFoundRow()
   Dim t As DataTable
   Dim rc As RowsCollection
   Dim foundRow As DataRow
   Set t = DataGrid1.DataGridTable.DataTable
   Set rc = t.Rows
   ' Test to see if the collection contains the value.
   If rc.Contains(Edit1.Text) Then
      Set foundRow = rc.Find(Edit1.Text)
      rc.Remove foundRow
      Label1.Text= "Row deleted."
   Else
      Label1.Text = "No such row found."
   End If
End Sub

See Also

RowsCollection Class | RowsCollection Members | System.Data Namespace | RowsCollection.Remove Overload List | Add | Clear | Contains | Find


Rule Enumeration

Indicates the action that occurs when a ForeignKeyConstraint is enforced.

[Visual Basic]
Public Enum Rule
[C#]
public enum Rule
[C++]
public enum Rule

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

The Rule values are set to the UpdateRule and the DeleteRule properties of a ForeignKeyConstraint object found in a DataTable object's ConstraintsCollection.

The Rule values determine the action that occurs when a value in a column is either deleted or updated. Of the two, deleting a value is the more critical and demanding of attention when setting a rule.

In the case where a value is deleted, Cascade specifies that all rows containing that value are also deleted. SetNull specifies that values in all child columns are set to null values. SetDefault specifies that all child columns be set to the default value for the column. None specifies that no action will occur, but exceptions will be thrown.

In the case where a value is updated, Cascade specifies that all child columns are likewise updated with the new value. SetNull specifies that all child columns be set to null values. SetDefault specifies that all child column values be set to the default value. None specifies that no action be taken, but exceptions will be thrown.

Constraints on a DataSet are not enforced unless the EnforceConstraints property is true.

When the AcceptChanges method is called, the AcceptRejectRule further determines what action occurs.

Members

Member Name | Description
Cascade | Changes are cascaded through the relationship.
Default | [reviewers?]
None | No action occurs.
SetDefault | Default values are set in the rows affected by the deletion.
SetNull | Null values are set in the rows affected by the deletion.

Requirements

Namespace: System.Data

Assembly: System.Data.dll

Example [Visual Basic]

[Visual Basic]

' The next line goes into the Declarations section of the module:
' SuppliersProducts is a class derived from DataSet.
Private myDataSet As SuppliersProducts

Private Sub CreateConstraint()
   ' Declare parent column and child column variables.
   Dim pCol As DataColumn
   Dim cCol As DataColumn
   Dim myFKC As ForeignKeyConstraint
   ' Set parent and child column variables.
   pCol = MyDataSet.Tables("Suppliers").Columns("SupplierID")
   cCol = MyDataSet.Tables("Products").Columns("SupplieriD")
   myFKC = New ForeignKeyConstraint("SuppierFKConstraint", pCol, cCol)
   ' Set null values when a value is deleted.
   myFKC.DeleteRule = Rule.SetNull
   myFKC.UpdateRule = Rule.Cascade
   myFKC.AcceptRejectRule = AcceptRejectRule.Cascade
   ' Add the constraint, and set EnforceConstraints to true.
   myDataSet.Tables("Suppliers").Constraints.Add myFKC
   myDataSet.EnforceConstraints = True
End Sub

See Also

System.Data Namespace


SchemaType Enumeration

[To be supplied.]

[Visual Basic]
Public Enum SchemaType
[C#]
public enum SchemaType
[C++]
public enum SchemaType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Mapped | [To be supplied.]
Source | [To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace


SortDirection Enumeration

[To be supplied.]

[Visual Basic]
Public Enum SortDirection
[C#]
public enum SortDirection
[C++]
public enum SortDirection

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Ascending | [To be supplied.]
Descending | [To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace


SortOrder Enumeration

[To be supplied.]

[Visual Basic]
Public Enum SortOrder
[C#]
public enum SortOrder
[C++]
public enum SortOrder

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Ascending | [To be supplied.]
Descending | [To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace


StateChangeEventArgs Class

[To be supplied.]

Object
EventArgs
StateChangeEventArgs

[Visual Basic]
Public Class StateChangeEventArgs
   Inherits EventArgs
[C#]
public class StateChangeEventArgs : EventArgs
[C++]
public __gc class StateChangeEventArgs : public EventArgs
[JScript]
public class StateChangeEventArgs extends EventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

StateChangeEventArgs Members | System.Data Namespace


StateChangeEventArgs Members

Public:

Constructor

StateChangeEventArgs Constructor [To be supplied.]

Properties

CurrentState | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
OriginalState | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StateChangeEventArgs Class | System.Data Namespace


StateChangeEventArgs Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal connection As DBConnection, _
   ByVal originalState As DBObjectState _
)
[C#]
public StateChangeEventArgs(
   DBConnection connection,
   DBObjectState originalState
);
[C++]
public: StateChangeEventArgs(
   DBConnection* connection,
   DBObjectState originalState
);
[JScript]
public function StateChangeEventArgs(
   connection : DBConnection,
   originalState : DBObjectState
);

Parameters

connection
[To be supplied.]
originalState
[To be supplied.]

See Also

StateChangeEventArgs Class | StateChangeEventArgs Members | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StateChangeEventArgs Properties

The properties of the StateChangeEventArgs class are listed below. For a complete list of StateChangeEventArgs class members, see the StateChangeEventArgs Members topic.

Public:

CurrentState | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
OriginalState | [To be supplied.]

See Also

StateChangeEventArgs Class | System.Data Namespace


StateChangeEventArgs.CurrentState

[To be supplied.]

[Visual Basic]
Public ReadOnly Property CurrentState As DBObjectState
[C#]
public DBObjectState CurrentState {get;}
[C++]
public: __property DBObjectState get_CurrentState();
[JScript]
public function get CurrentState() : DBObjectState;

See Also

StateChangeEventArgs Class | StateChangeEventArgs Members | System.Data Namespace


StateChangeEventArgs.OriginalState

[To be supplied.]

[Visual Basic]
Public ReadOnly Property OriginalState As DBObjectState
[C#]
public DBObjectState OriginalState {get;}
[C++]
public: __property DBObjectState get_OriginalState();
[JScript]
public function get OriginalState() : DBObjectState;

See Also

StateChangeEventArgs Class | StateChangeEventArgs Members | System.Data Namespace


StateChangeEventHandler Delegate

[To be supplied.]

[Visual Basic]
Public Delegate Sub StateChangeEventHandler( _
   ByVal sender As Object, _
   ByVal e As StateChangeEventArgs _
)
[C#]
public delegate void StateChangeEventHandler(
   object sender,
   StateChangeEventArgs e
);
[C++]
public __gc __delegate void StateChangeEventHandler(
   Object* sender,
   StateChangeEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the StateChangeEventHandler delegate declaration.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace


StreamFormats Class

[To be supplied.]

Object
StreamFormats

[Visual Basic]
Public Class StreamFormats
[C#]
public class StreamFormats
[C++]
public __gc class StreamFormats
[JScript]
public class StreamFormats

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

StreamFormats Members | System.Data Namespace


StreamFormats Members

Public:

Constructor

StreamFormats Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

DataRecords | [To be supplied.]
XmlRecords | [To be supplied.]
XmlTokens | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StreamFormats Class | System.Data Namespace


StreamFormats Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public StreamFormats();
[C++]
public: StreamFormats();
[JScript]
public function StreamFormats();

See Also

StreamFormats Class | StreamFormats Members | System.Data Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StreamFormats Fields

The fields of the StreamFormats class are listed below. For a complete list of StreamFormats class members, see the StreamFormats Members topic.

Public:

DataRecords | [To be supplied.]
XmlRecords | [To be supplied.]
XmlTokens | [To be supplied.]

See Also

StreamFormats Class | System.Data Namespace


StreamFormats.DataRecords

[To be supplied.]

[Visual Basic]
Public Shared DataRecords As String
[C#]
public static string DataRecords;
[C++]
public: static String* DataRecords;
[JScript]
public static var DataRecords : String;

See Also

StreamFormats Class | StreamFormats Members | System.Data Namespace


StreamFormats.XmlRecords

[To be supplied.]

[Visual Basic]
Public Shared XmlRecords As String
[C#]
public static string XmlRecords;
[C++]
public: static String* XmlRecords;
[JScript]
public static var XmlRecords : String;

See Also

StreamFormats Class | StreamFormats Members | System.Data Namespace


StreamFormats.XmlTokens

[To be supplied.]

[Visual Basic]
Public Shared XmlTokens As String
[C#]
public static string XmlTokens;
[C++]
public: static String* XmlTokens;
[JScript]
public static var XmlTokens : String;

See Also

StreamFormats Class | StreamFormats Members | System.Data Namespace


SyntaxErrorException Class

[To be supplied.]

Object
Exception
SystemException
DataException
SyntaxErrorException

[Visual Basic]
Public Class SyntaxErrorException
   Inherits DataException
[C#]
public class SyntaxErrorException : DataException
[C++]
public __gc class SyntaxErrorException : public DataException
[JScript]
public class SyntaxErrorException extends DataException

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

SyntaxErrorException Members | System.Data Namespace


SyntaxErrorException Members

Public:

Constructor

SyntaxErrorException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

SyntaxErrorException Class | System.Data Namespace


SyntaxErrorException Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public SyntaxErrorException();
[C++] public: SyntaxErrorException();
[JScript] public function SyntaxErrorException();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public SyntaxErrorException(String);
[C++] public: SyntaxErrorException(String*);
[JScript] public function SyntaxErrorException(String);

See Also

SyntaxErrorException Class | SyntaxErrorException Members | System.Data Namespace


SyntaxErrorException Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public SyntaxErrorException();
[C++]
public: SyntaxErrorException();
[JScript]
public function SyntaxErrorException();

See Also

SyntaxErrorException Class | SyntaxErrorException Members | System.Data Namespace | SyntaxErrorException Constructor Overload List


SyntaxErrorException Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal s As String _
)
[C#]
public SyntaxErrorException(
   string s
);
[C++]
public: SyntaxErrorException(
   String* s
);
[JScript]
public function SyntaxErrorException(
   s : String
);

Parameters

s
[To be supplied.]

See Also

SyntaxErrorException Class | SyntaxErrorException Members | System.Data Namespace | SyntaxErrorException Constructor Overload List


TablesCollection Class

Represents the collection of tables for the DataSet.

Object
BaseCollection
TablesCollection

[Visual Basic]
Public Class TablesCollection
   Inherits BaseCollection
[C#]
public class TablesCollection : BaseCollection
[C++]
public __gc class TablesCollection : public BaseCollection
[JScript]
public class TablesCollection extends BaseCollection

Remarks

The TablesCollection contains all of the DataTable objects for a DataSet. To access the TablesCollection of a DataSet, use the Tables property.

The TablesCollection has the standard collection methods Add, Clear, and Remove as well as an All method to return the collection as an array.

To determine if a particular table (specified by either index or name) is in the collection, the Contains method returns a boolean value.

To navigate from one table to another, use the DataTable class's ChildRelations or ParentRelations properties to access the table's collection of DataRelation objects. You can also navigate through the DataSet class's collection using the Relations property.

Requirements

Namespace: System.Data

Assembly: System.Data.dll

Example [Visual Basic]

The first example below retrieves the TablesCollection of a DataSet and prints the value of each column, in each row, of each table. The second example creates a new DataTable with two columns, and adds it to the TablesCollection.

[Visual Basic]

Private Sub GetTables()
   Dim ds As DataSet
   ' Assuming a DataGrid bound to a DataSet.
   ds = DataGrid1.DataSource
   ' Get Each DataTable in the TablesCollection and print each row value.
   Dim t As DataTable
   Dim r As DataRow
   Dim c As DataColumn
   For Each t In ds.Tables
      For Each r In t.Rows
         For Each c in t.Columns
If Not IsNull(r(c)) Then Console.WriteLine r(c)
         Next
      Next
   Next
End Sub

See Also

TablesCollection Members | System.Data Namespace | DataColumn | DataRow | DataTable | DataSet


TablesCollection Members

Public:

Properties

All | Gets or sets all of the tables in this collection.
Count (inherited from BaseCollection) | [To be supplied.]
IsReadOnly (inherited from BaseCollection) | [To be supplied.]
IsSynchronized (inherited from BaseCollection) | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the TablesCollection class.
SyncRoot (inherited from BaseCollection) | [To be supplied.]

Methods

Add | Overloaded. Adds a table to the collection.
CanRemove | Verifies if a given table can be removed from the collection.
Clear | Clears the collection of any tables.
Contains | Overloaded. Verifies whether the collection contains a specific table.
CopyTo (inherited from BaseCollection) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from BaseCollection) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | Overloaded. Returns the index of a specified table.
Remove | Overloaded. Removes a table from the collection.
ShouldPersistAll | Indicates whether changes to the collection (returned by the All method) should be persisted.
ToString (inherited from Object) | Returns a String that represents the current Object.

Events

CollectionChanged Occurs when the collection is changed.

Protected:

Properties

List Gets the tables in the collection as an object.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnCollectionChanged | Raises the OnCollectionChanged event.

Event Hookup:

Methods

AddOnCollectionChanged | Registers the handler to get events whenever this collection changes.
RemoveOnCollectionChanged | Unregisters the handler from getting events whenever this collection changes.

See Also

TablesCollection Class | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TablesCollection Properties

The properties of the TablesCollection class are listed below. For a complete list of TablesCollection class members, see the TablesCollection Members topic.

Public:

All | Gets or sets all of the tables in this collection.
Count (inherited from BaseCollection) | [To be supplied.]
IsReadOnly (inherited from BaseCollection) | [To be supplied.]
IsSynchronized (inherited from BaseCollection) | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the TablesCollection class.
SyncRoot (inherited from BaseCollection) | [To be supplied.]

Protected:

List Gets the tables in the collection as an object.

See Also

TablesCollection Class | System.Data Namespace


TablesCollection.All

Gets or sets all of the tables in this collection.

[Visual Basic]
Public Property All As DataTable ()
[C#]
public DataTable[] All {get; set;}
[C++]
public: __property DataTable* get_All();
public: __property void set_All(DataTable*[]);
[JScript]
public function get All() : DataTable[];
public function set All(DataTable[]);

Property Value

An array of DataTable objects.

Remarks

The All method throws an exception if any table that is added shouldn't be added and if any table is removed shouldn't be removed. If an exception is thrown, the collection returns to its original state.

The OnCollectionChanged event occurs if setting the property to a new values succeeds.

Example [Visual Basic]

The following example returns an array of DataTable objects for a DataSet.

[Visual Basic]

Private Sub GetAllTables()
   Dim tableCol As TablesCollection
   Dim dSet As DataSet
   ' Presuming a DataGrid is displaying more than one table, get its DataSet.
   Set dSet = DataGrid1.DataGridTable.DataTable.DataSet
   ' Get the TablesCollection variable.
   Set tableCol = dSet.Tables
   ' Declare an array for DataTable objects.
   Dim tables() As DataTable
   ' Set the array using the All method.
   Set tables = tableCol.All
   Dim i As Integer
   For i = 0 To UBound(tables)
      Console.WriteLine(tables(i).TableName)
   Next

End Sub

See Also

TablesCollection Class | TablesCollection Members | System.Data Namespace | Tables | DataTable | Add | Remove


TablesCollection.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the TablesCollection class.

Overload List

Gets the table specified by its index.

[Visual Basic] Overloads Public Default ReadOnly Property Item(Integer) As DataTable
[C#] public DataTable this[int] {get;}
[C++] public: __property DataTable* get_Item(int);
[JScript] TablesCollection.Item (int)

Gets the table in the collection with the given name (not case-sensitive).

[Visual Basic] Overloads Public Default ReadOnly Property Item(String) As DataTable
[C#] public DataTable this[String] {get;}
[C++] public: __property DataTable* get_Item(String*);
[JScript] TablesCollection.Item (String)

Example [Visual Basic]

The following example retrieves a single table by name from the TablesCollection.

Note This example shows how to use one of the overloaded versions of the Item property (TablesCollection indexer). For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub GetTableByName()
   Dim tablesCol As TablesCollection
   Dim dSet As DataSet
   Dim t As DataTable
   ' Presuming a DataGrid is displaying more than one table, get its DataSet.
   Set dSet = DataGrid1.DataGridTable.DataTable.DataSet
   ' Get the TablesCollection.
   Set tablesCol = dSet.Tables
   ' Get a specific table by name.
   Set t = tablesCol("Suppliers")
   Console.WriteLine(t.TableName)
End Sub

See Also

TablesCollection Class | TablesCollection Members | System.Data Namespace


TablesCollection.Item (Int32)

Gets the table specified by its index.

[C#] In C#, this member is the indexer for the TablesCollection class.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
   ByVal index As Integer _
) As DataTable
[C#]
public DataTable this[
   int index
] {get;}
[C++]
public: __property DataTable* get_Item(
   int index
);
[JScript]
returnValue = TablesCollectionObject.Item(index);
-or-
returnValue = TablesCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
The zero-based index of the DataTable being sought.

Parameters [Visual Basic, C#, C++]

index
The zero-based index of the DataTable being sought.

Property Value

A DataTable.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | The index doesn't exist in the collection.

Remarks

The Contains method can be used to determine if a table with a specified index exists.

If you have the name of a table, but not its index, use the IndexOf method to return the table's index.

Example [Visual Basic]

The following example retrieves a DataTable by its index.

[Visual Basic]

Private Sub GetDataTableByIndex()
   Dim tablesCol As TablesCollection
   Dim dSet As DataSet
   ' Presuming a DataGrid is displaying more than one table, get its DataSet.
   Set dSet = DataGrid1.DataGridTable.DataTable.DataSet
   ' Get the TablesCollection.
   Set tablesCol = dSet.Tables
   ' Iterate through the collection to get each table name.
   Dim i As Integer
   For i = 0 To tablesCol.Count - 1
      Console.WriteLine(TableCol(i).TableName)
   Next
End Sub

See Also

TablesCollection Class | TablesCollection Members | System.Data Namespace | TablesCollection.Item Overload List | Contains | IndexOf | DataTable


TablesCollection.Item (String)

Gets the table in the collection with the given name (not case-sensitive).

[C#] In C#, this member is the indexer for the TablesCollection class.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
   ByVal name As String _
) As DataTable
[C#]
public DataTable this[
   string name
] {get;}
[C++]
public: __property DataTable* get_Item(
   String* name
);
[JScript]
returnValue = TablesCollectionObject.Item(name);
-or-
returnValue = TablesCollectionObject(name);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
The name of the table to find.

Parameters [Visual Basic, C#, C++]

name
The name of the table to find.

Property Value

A DataTable with the specified name.

Exceptions

Exception Type | Condition
TableOutOfRange(System.Int32) | The table name does not exist in the collection.

Remarks

The Contains method can be used to determine if a table with a specified name or index exists.

Example [Visual Basic]

The following example retrieves a single table by name from the TablesCollection.

[Visual Basic]

Private Sub GetTableByName()
   Dim tablesCol As TablesCollection
   Dim dSet As DataSet
   Dim t As DataTable
   ' Presuming a DataGrid is displaying more than one table, get its DataSet.
   Set dSet = DataGrid1.DataGridTable.DataTable.DataSet
   ' Get the TablesCollection.
   Set tablesCol = dSet.Tables
   ' Get a specific table by name.
   Set t = tablesCol("Suppliers")
   Console.WriteLine(t.TableName)
End Sub

See Also

TablesCollection Class | TablesCollection Members | System.Data Namespace | TablesCollection.Item Overload List


TablesCollection.List

Gets the tables in the collection as an object.

[Visual Basic]
Overridable Protected ReadOnly Property List As ObjectList
[C#]
protected ObjectList List {override get;}
[C++]
protected: __property virtual ObjectList* get_List();
[JScript]
protected function get List() : ObjectList;

Property Value

An ObjectList that contains all of tables.

Example [Visual Basic]

The following example uses the List property of a TablesCollection to return an ObjectList.

[Visual Basic]

Private Sub GetObjectList()
   Dim objL As ObjectList
   Dim dSet As DataSet
   ' Get the DataSet from a DataGrid control
   Set dSet As DataGrid1.DataGridTable.DataTable.DataSet
   ' Get the TablesCollection as an ObjectList of the DataSet
   Set objL = dSet.List
   ' Not shown: Use properties and methods of the ObjectList to manipulate the list.
End Sub

See Also

TablesCollection Class | TablesCollection Members | System.Data Namespace | ObjectList


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TablesCollection Methods

The methods of the TablesCollection class are listed below. For a complete list of TablesCollection class members, see the TablesCollection Members topic.

Public:

Add | Overloaded. Adds a table to the collection.
CanRemove | Verifies if a given table can be removed from the collection.
Clear | Clears the collection of any tables.
Contains | Overloaded. Verifies whether the collection contains a specific table.
CopyTo (inherited from BaseCollection) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from BaseCollection) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | Overloaded. Returns the index of a specified table.
Remove | Overloaded. Removes a table from the collection.
ShouldPersistAll | Indicates whether changes to the collection (returned by the All method) should be persisted.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnCollectionChanged | Raises the OnCollectionChanged event.

Event Hookup:

AddOnCollectionChanged | Registers the handler to get events whenever this collection changes.
RemoveOnCollectionChanged | Unregisters the handler from getting events whenever this collection changes.

See Also

TablesCollection Class | System.Data Namespace


TablesCollection.Add

Adds a table to the collection.

Overload List

Creates a new table with a default name and adds it to the collection.

[Visual Basic] Overloads Overridable Public Function Add() As DataTable
[C#] public virtual DataTable Add();
[C++] public: virtual DataTable* Add();
[JScript] public function Add() : DataTable;

Creates a table with the given name and adds it to the collection.

[Visual Basic] Overloads Overridable Public Function Add(String) As DataTable
[C#] public virtual DataTable Add(String);
[C++] public: virtual DataTable* Add(String*);
[JScript] public function Add(String) : DataTable;

Adds the specified table to the collection.

[Visual Basic] Overloads Overridable Public Sub Add(DataTable)
[C#] public virtual void Add(DataTable);
[C++] public: virtual void Add(DataTable*);
[JScript] public function Add(DataTable);

Example [Visual Basic]

The following example creates a DataTable and adds it to the TablesCollection of a DataSet.

Note This example shows how to use one of the overloaded versions of Add. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub AddDataTable()
   Dim tablesCol As TablesCollection
   ' Get the TablesCollection of a DataGrid control's DataSet.
   Set tabelesCol = DataGrid1.DataGridTable.DataTable.DataSet.Tables
   ' Create a new DataTable.
   Dim myTable As DataTable = New DataTable
   ' Code to add columns and rows not shown here.

   ' Add the table to the TablesCollection.
   tablesCol.Add myTable
End Sub

See Also

TablesCollection Class | TablesCollection Members | System.Data Namespace


TablesCollection.Add ()

Creates a new table with a default name and adds it to the collection.

[Visual Basic]
Overloads Overridable Public Function Add() As DataTable
[C#]
public virtual DataTable Add();
[C++]
public: virtual DataTable* Add();
[JScript]
public function Add() : DataTable;

Return Value

The newly created DataTable.

Remarks

Because no name is specified, the table is created with a default name, relative to its order of addition. The default name is "Table<i>" where i = a new 1-based index.

The OnCollectionChanged event occurs when a table is successfully added to the collection.

Example [Visual Basic]

The following example adds three new DataTable objects to the TablesCollection using the Add method with no arguments.

[Visual Basic]

Private Sub AddTables()
   Dim t As DataTable
   Dim dSet As DataSet
   ' Presuming a DataGrid is displaying more than one table, get its DataSet.
   Set dSet = DataGrid1.DataGridTable.DataTable.DataSet
   Dim i As Integer
   For i = 0 to 2
      dSet.Tables.Add
   Next i
   MessageBox.Show dSet.Tables.Count & " tables"
   For Each t In dSet.Tables
      MessageBox.Show t.TableName
   Next
End Sub

See Also

TablesCollection Class | TablesCollection Members | System.Data Namespace | TablesCollection.Add Overload List | DataTable | Remove | Clear


TablesCollection.Add (String)

Creates a table with the given name and adds it to the collection.

[Visual Basic]
Overloads Overridable Public Function Add( _
   ByVal name As String _
) As DataTable
[C#]
public virtual DataTable Add(
   string name
);
[C++]
public: virtual DataTable* Add(
   String* name
);
[JScript]
public function Add(
   name : String
) : DataTable;

Parameters

name
The name to give the created DataTable.

Return Value

The newly created DataTable.

Exceptions

Exception Type | Condition
DuplicateNameException | A table in the collection has the same name. The comparison is not case-sensitive.

Remarks

If either a a null reference (in Visual Basic Nothing) or an empty string ("") is passed in, a default name is given to the newly created DataTable.

The OnCollectionChanged event occurs if the table is succesfully added.

Example [Visual Basic]

The following example adds a DataTable with the given name to the TablesCollection.

[Visual Basic]

Private Sub GetTableByName()
   Dim dSet As DataSet
   Dim dt As DataTable
   ' Presuming a DataGrid is displaying more than one table, get its DataSet.
   Set dSet = DataGrid1.DataGridTable.DataTable.DataSet
   ' Use the Add method to add a new table with a given name.
   Set dt = dSet.Tables.Add("myNewTable")
   ' Code to add columns and rows not shown here.
   MessageBox.Show dt.TableName
   MessageBox.Show dSet.Tables.Count
End Sub

See Also

TablesCollection Class | TablesCollection Members | System.Data Namespace | TablesCollection.Add Overload List | DataTable | Remove | Clear


TablesCollection.Add (DataTable)

Adds the specified table to the collection.

[Visual Basic]
Overloads Overridable Public Sub Add( _
   ByVal table As DataTable _
)
[C#]
public virtual void Add(
   DataTable table
);
[C++]
public: virtual void Add(
   DataTable* table
);
[JScript]
public function Add(
   table : DataTable
);

Parameters

table
The DataTable to add.

Exceptions

Exception Type | Condition
ArgumentNullException | The table is a null reference (in Visual Basic Nothing).
ArgumentException | The table already belongs to this collection, or belongs to another collection.
DuplicateNameException | A table in the collection has the same name. The comparison is not case-sensitive.

Remarks

The OnCollectionChanged event occurs when a table is succefully added.

Example [Visual Basic]

The following example creates a DataTable and adds it to the TablesCollection of a DataSet.

[Visual Basic]

Private Sub AddDataTable()
   Dim tablesCol As TablesCollection
   ' Get the TablesCollection of a DataGrid control's DataSet.
   Set tabelesCol = DataGrid1.DataGridTable.DataTable.DataSet.Tables
   ' Create a new DataTable.
   Dim myTable As DataTable = New DataTable
   ' Code to add columns and rows not shown here.

   ' Add the table to the TablesCollection.
   tablesCol.Add myTable
End Sub

See Also

TablesCollection Class | TablesCollection Members | System.Data Namespace | TablesCollection.Add Overload List | DataTable | Remove | Clear


TablesCollection.AddOnCollectionChanged

Registers the handler to get events whenever this collection changes.

[Visual Basic]
Public Sub AddOnCollectionChanged( _
   ByVal handler As CollectionChangeEventHandler _
)
[C#]
public void AddOnCollectionChanged(
   CollectionChangeEventHandler handler
);
[C++]
public: void AddOnCollectionChanged(
   CollectionChangeEventHandler* handler
);
[JScript]
public function AddOnCollectionChanged(
   handler : CollectionChangeEventHandler
);

Parameters

handler
A CollectionChangeEventHandler delegate that represents the method that will handle the OnCollectionChanged event.

See Also

TablesCollection Class | TablesCollection Members | System.Data Namespace


TablesCollection.CanRemove

Verifies if a given table can be removed from the collection.

[Visual Basic]
Public Function CanRemove( _
   ByVal table As DataTable _
) As Boolean
[C#]
public bool CanRemove(
   DataTable table
);
[C++]
public: bool CanRemove(
   DataTable* table
);
[JScript]
public function CanRemove(
   table : DataTable
) : Boolean;

Parameters

table
[To be supplied.]

Return Value

true if the table can be removed; otherwise, false.

Example [Visual Basic]

The following example uses the CanRemove to test whether each table can be removed from a DataSet. If so, the Remove method is called to remove the table.

[Visual Basic]

Private Sub RemoveTables()
   Dim t As DataTable
   Dim dSet As DataSet
   ' Presuming a DataGrid is displaying more than one table, get its DataSet.
   Set dSet = DataGrid1.DataGridTable.DataTable.DataSet
   For each t in dSet.Tables
     If dSet.CanRemove t Then dSet.Remove t
   Next
End If

See Also

TablesCollection Class | TablesCollection Members | System.Data Namespace | Item | IndexOf | Remove


TablesCollection.Clear

Clears the collection of any tables.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[JScript]
public function Clear();

Example [Visual Basic]

The following example gets the TablesCollection of a DataSet, then clears the collection of all tables.

[Visual Basic]

Private Sub ClearTables()
  Dim myDataSet As DataSet
  Dim tablesCol As TablesCollection
  ' Get the DataSet of a DataGrid control.
  Set myDataSet = DataGrid1.DataGridTable.DataTable.DataSet
  Set TablesCol = myDataSet.Tables
  ' Clear the collection.
  TablesCol.Clear
End Sub

See Also

TablesCollection Class | TablesCollection Members | System.Data Namespace


TablesCollection.Contains

Verifies whether the collection contains a specific table.

Overload List

Checks if a table, specified by name, exists in the collection.

[Visual Basic] Overloads Public Function Contains(String) As Boolean
[C#] public bool Contains(String);
[C++] public: bool Contains(String*);
[JScript] public function Contains(String) : Boolean;

Verifies whether a table, specified by index, exists in the collection.

[Visual Basic] Overloads Public Function Contains(Integer) As Boolean
[C#] public bool Contains(int);
[C++] public: bool Contains(int);
[JScript] public function Contains(int) : Boolean;

Example [Visual Basic]

The following example tests whether a table with the index 10 exists in the TablesCollection.

Note This example shows how to use one of the overloaded versions of Contains. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub TestForTableByIndex()
   Dim dSet As DataSet
   ' Get the DataSet of a DataGrid.
   Set dSet = DataGrid1.DataGridTable.DataTable.DataSet
   ' Get the TablesCollection through the Tables property.
   Dim tablesCol As TablesCollection
   Set tablesCol = dSet.Tables
   ' Check if a table with the index 10 exists.
   If tablesCol.Contains(10) Then
      MessageBox "Table with index 10 exists"
   Ene If
End Sub

See Also

TablesCollection Class | TablesCollection Members | System.Data Namespace


TablesCollection.Contains (String)

Checks if a table, specified by name, exists in the collection.

[Visual Basic]
Overloads Public Function Contains( _
   ByVal name As String _
) As Boolean
[C#]
public bool Contains(
   string name
);
[C++]
public: bool Contains(
   String* name
);
[JScript]
public function Contains(
   name : String
) : Boolean;

Parameters

name
The table name to check for.

Return Value

true if the specified table exists; otherwise, false.

Remarks

The DataTable object's name is specified by the TableName property. If you add a DataTable to the TablesCollection with the Add method, passing no arguments, the table is given a default name such as Table1, Table2, and so on.

To get the index of a DataTable, use the IndexOf method.

Example [Visual Basic]

The following example tests whether a table with the name "Suppliers" exists in the TablesCollection.

[Visual Basic]

Private Sub TestForTableName()
   Dim dSet As DataSet
   ' Get the DataSet of a DataGrid.
   Set dSet = DataGrid1.DataGridTable.DataTable.DataSet
   ' Get the TablesCollection through the Tables property.
   Dim tablesCol As TablesCollection
   Set tablesCol = dSet.Tables
   ' Check if the named table exists.
   If tablesCol.Contains("Suppliiers") Then
      MessageBox "Table named Suppliers exists"
   Ene If
End Sub

See Also

TablesCollection Class | TablesCollection Members | System.Data Namespace | TablesCollection.Contains Overload List | Item | IndexOf | Remove | CanRemove


TablesCollection.Contains (Int32)

Verifies whether a table, specified by index, exists in the collection.

[Visual Basic]
Overloads Public Function Contains( _
   ByVal index As Integer _
) As Boolean
[C#]
public bool Contains(
   int index
);
[C++]
public: bool Contains(
   int index
);
[JScript]
public function Contains(
   index : int
) : Boolean;

Parameters

index
The 0-based index to check for.

Return Value

true if the specified table exists; otherwise, false.

Example [Visual Basic]

The following example tests whether a table with the index 10 exists in the TablesCollection.

[Visual Basic]

Private Sub TestForTableByIndex()
   Dim dSet As DataSet
   ' Get the DataSet of a DataGrid.
   Set dSet = DataGrid1.DataGridTable.DataTable.DataSet
   ' Get the TablesCollection through the Tables property.
   Dim tablesCol As TablesCollection
   Set tablesCol = dSet.Tables
   ' Check if a table with the index 10 exists.
   If tablesCol.Contains(10) Then
      MessageBox "Table with index 10 exists"
   Ene If
End Sub

See Also

TablesCollection Class | TablesCollection Members | System.Data Namespace | TablesCollection.Contains Overload List | Item | IndexOf | Remove | CanRemove


TablesCollection.IndexOf

Returns the index of a specified table.

Overload List

Returns the index of the table with the given name (case insensitive), or-1 if the table doesn't exist in the collection.

[Visual Basic] Overloads Overridable Public Function IndexOf(String) As Integer
[C#] public virtual int IndexOf(String);
[C++] public: virtual int IndexOf(String*);
[JScript] public function IndexOf(String) : int;

Returns the index of a specified DataTable.

[Visual Basic] Overloads Overridable Public Function IndexOf(DataTable) As Integer
[C#] public virtual int IndexOf(DataTable);
[C++] public: virtual int IndexOf(DataTable*);
[JScript] public function IndexOf(DataTable) : int;

Example [Visual Basic]

The following example returns the index of each table in the TablesCollection.

Note This example shows how to use one of the overloaded versions of IndexOf. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub GetIndexes()
   Dim dSet As DataSet
   Dim tablesCol As TablesCollection
   ' Get the DataSet of a DataGrid.
   Set dSet = DataGrid1.DataGridTable.DataTable
   ' Get the TablesCollection through the Tables property.
   Set tablesCol = dSet.Tables
   Dim t As DataTable
   ' Get the index of each table in the collection.
   For Each t In tablesCol
      Debug.Print tablesCol.IndexOf(t)
   Next
End Sub

See Also

TablesCollection Class | TablesCollection Members | System.Data Namespace


TablesCollection.IndexOf (String)

Returns the index of the table with the given name (case insensitive), or-1 if the table doesn't exist in the collection.

[Visual Basic]
Overloads Overridable Public Function IndexOf( _
   ByVal tableName As String _
) As Integer
[C#]
public virtual int IndexOf(
   string tableName
);
[C++]
public: virtual int IndexOf(
   String* tableName
);
[JScript]
public function IndexOf(
   tableName : String
) : int;

Parameters

tableName
The name to look for.

Return Value

The index of the table with the name, or-1 if the table doesn't exist in the collection.

Remarks

The name of a DataTable is set with the TableName property.

Example [Visual Basic]

The following example returns the index of a named table in the TablesCollection.

[Visual Basic]

Private Sub GetIndexes()
   Dim dSet As DataSet
   Dim tablesCol As TablesCollection
   ' Get the DataSet of a DataGrid.
   Set dSet = DataGrid1.DataGridTable.DataTable
   ' Get the TablesCollection through the Tables property.
   Set tablesCol = dSet.Tables
   ' Get the index of the table named "Authors", if it exists.
   If tablesCol.Contains("Authors") Then
      Debug.Print tablesCol.IndexOf("Authors")
   End If
End Sub

See Also

TablesCollection Class | TablesCollection Members | System.Data Namespace | TablesCollection.IndexOf Overload List | IndexOf | TableName | Remove


TablesCollection.IndexOf (DataTable)

Returns the index of a specified DataTable.

[Visual Basic]
Overloads Overridable Public Function IndexOf( _
   ByVal table As DataTable _
) As Integer
[C#]
public virtual int IndexOf(
   DataTable table
);
[C++]
public: virtual int IndexOf(
   DataTable* table
);
[JScript]
public function IndexOf(
   table : DataTable
) : int;

Parameters

table
The DataTable to search for.

Return Value

The 0-based index of the table, or-1 if the table isn't found in the collection.

Remarks

Use the IndexOf method when it's necessary to know the exact index of a given table.

Before calling IndexOf, you can test for the existence of a table (specified by either index or name) using the Contains method.

Example [Visual Basic]

The following example returns the index of each table in the TablesCollection.

[Visual Basic]

Private Sub GetIndexes()
   Dim dSet As DataSet
   Dim tablesCol As TablesCollection
   ' Get the DataSet of a DataGrid.
   Set dSet = DataGrid1.DataGridTable.DataTable
   ' Get the TablesCollection through the Tables property.
   Set tablesCol = dSet.Tables
   Dim t As DataTable
   ' Get the index of each table in the collection.
   For Each t In tablesCol
      Debug.Print tablesCol.IndexOf(t)
   Next
End Sub

See Also

TablesCollection Class | TablesCollection Members | System.Data Namespace | TablesCollection.IndexOf Overload List | IndexOf | TableName | Remove


TablesCollection.OnCollectionChanged

Raises the OnCollectionChanged event.

[Visual Basic]
Overridable Protected Sub OnCollectionChanged( _
   ByVal ccevent As CollectionChangeEventArgs _
)
[C#]
protected virtual void OnCollectionChanged(
   CollectionChangeEventArgs ccevent
);
[C++]
protected: virtual void OnCollectionChanged(
   CollectionChangeEventArgs* ccevent
);
[JScript]
protected function OnCollectionChanged(
   ccevent : CollectionChangeEventArgs
);

Parameters

ccevent
A CollectionChangeEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see TBD.

Notes to Inheritors: When overriding OnCollectionChanged in an inheriting class, be sure to call the base class's OnCollectionChanged method.

See Also

TablesCollection Class | TablesCollection Members | System.Data Namespace


TablesCollection.Remove

Removes a table from the collection.

Overload List

Removes the table at the given index from the collection

[Visual Basic] Overloads Public Sub Remove(Integer)
[C#] public void Remove(int);
[C++] public: void Remove(int);
[JScript] public function Remove(int);

Removes the table with a specified name from the collection.

[Visual Basic] Overloads Public Sub Remove(String)
[C#] public void Remove(String);
[C++] public: void Remove(String*);
[JScript] public function Remove(String);

Removes the specified table from the collection.

[Visual Basic] Overloads Public Sub Remove(DataTable)
[C#] public void Remove(DataTable);
[C++] public: void Remove(DataTable*);
[JScript] public function Remove(DataTable);

Example [Visual Basic]

The following example uses the CanRemove to test whether each table can be removed from a DataSet. If so, the Remove method is called to remove the table.

Note This example shows how to use one of the overloaded versions of Remove. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub RemoveTables()
   Dim t As DataTable
   Dim dSet As DataSet
   ' Presuming a DataGrid is displaying more than one table, get its DataSet.
   Set dSet = DataGrid1.DataGridTable.DataTable.DataSet
   For each t in dSet.Tables
     If dSet.CanRemove t Then dSet.Remove t
   Next
End Sub

See Also

TablesCollection Class | TablesCollection Members | System.Data Namespace


TablesCollection.Remove (Int32)

Removes the table at the given index from the collection

[Visual Basic]
Overloads Public Sub Remove( _
   ByVal index As Integer _
)
[C#]
public void Remove(
   int index
);
[C++]
public: void Remove(
   int index
);
[JScript]
public function Remove(
   index : int
);

Parameters

index
The index at which to remove a table.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | The collection doesn't have a table at this index.

Remarks

The OnCollectionChanged event occurs when a table is succesfully removed.

To determine if a given table exists and can be removed before invoking Remove, use the Contains and the CanRemove methods.

Example [Visual Basic]

The following example uses the Contains and CanRemove to test whether a table with the index 10 exists and can be removed. If so, the Remove method is called to remove the table.

[Visual Basic]

Private Sub RemoveTables()
   Dim tablesCol As TablesCollection
   Dim dSet As DataSet
   ' Set the index of the table to test for and remove.
   Dim tblIndex As Integer: tblIndex = 10
   ' Presuming a DataGrid is displaying more than one table, get its DataSet.
   Set dSet = DataGrid1.DataGridTable.DataTable.DataSet
   Set tablesCol = dSet.Tables
   If tablesCol.Contains(tblIndex) And tablesCol.CanRemove(tblIndex) Then
      tablesCol.Remove tblIndex
   End If
End Sub

See Also

TablesCollection Class | TablesCollection Members | System.Data Namespace | TablesCollection.Remove Overload List | IndexOf | Contains


TablesCollection.Remove (String)

Removes the table with a specified name from the collection.

[Visual Basic]
Overloads Public Sub Remove( _
   ByVal name As String _
)
[C#]
public void Remove(
   string name
);
[C++]
public: void Remove(
   String* name
);
[JScript]
public function Remove(
   name : String
);

Parameters

name
The name of the DataTable to remove.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | The collection doesn't have a table at this index.

Remarks

The OnCollectionChanged event occurs when a table is succesfully removed.

To determine if a given table exists and can be removed before invoking Remove, use the Contains and the CanRemove methods.

Example [Visual Basic]

The following example uses the Contains and CanRemove to test whether a named table exists and can be removed. If so, the Remove method is called to remove the table.

[Visual Basic]

Private Sub RemoveTables()
   Dim tablesCol As TablesCollection
   Dim dSet As DataSet
   ' Set the name of the table to test for and remove.
   Dim strName As Integer: strName = "Suppliers"
   ' Presuming a DataGrid is displaying more than one table, get its DataSet.
   Set dSet = DataGrid1.DataGridTable.DataTable.DataSet
   Set tablesCol = dSet.Tables
   If tablesCol.Contains(strName) And tablesCol.CanRemove(strName) Then
      tablesCol.Remove strName
   End If
End Sub

See Also

TablesCollection Class | TablesCollection Members | System.Data Namespace | TablesCollection.Remove Overload List | IndexOf | Contains


TablesCollection.Remove (DataTable)

Removes the specified table from the collection.

[Visual Basic]
Overloads Public Sub Remove( _
   ByVal table As DataTable _
)
[C#]
public void Remove(
   DataTable table
);
[C++]
public: void Remove(
   DataTable* table
);
[JScript]
public function Remove(
   table : DataTable
);

Parameters

table
The DataTable to remove.

Exceptions

Exception Type | Condition
ArgumentNullException | The table is a null reference (in Visual Basic Nothing).
ArgumentException | The table doesn't belong to this collection. -Or- The table is part of a relationship.

Remarks

The OnCollectionChanged event occurs when a table is succesfully removed.

To determine if a given table exists and can be removed before invoking Remove, use the Contains and the CanRemove methods.

Example [Visual Basic]

The following example uses the CanRemove to test whether each table can be removed from a DataSet. If so, the Remove method is called to remove the table.

[Visual Basic]

Private Sub RemoveTables()
   Dim t As DataTable
   Dim dSet As DataSet
   ' Presuming a DataGrid is displaying more than one table, get its DataSet.
   Set dSet = DataGrid1.DataGridTable.DataTable.DataSet
   For each t in dSet.Tables
     If dSet.CanRemove t Then dSet.Remove t
   Next
End Sub

See Also

TablesCollection Class | TablesCollection Members | System.Data Namespace | TablesCollection.Remove Overload List | IndexOf | Contains


TablesCollection.RemoveOnCollectionChanged

Unregisters the handler from getting events whenever this collection changes.

[Visual Basic]
Public Sub RemoveOnCollectionChanged( _
   ByVal handler As CollectionChangeEventHandler _
)
[C#]
public void RemoveOnCollectionChanged(
   CollectionChangeEventHandler handler
);
[C++]
public: void RemoveOnCollectionChanged(
   CollectionChangeEventHandler* handler
);
[JScript]
public function RemoveOnCollectionChanged(
   handler : CollectionChangeEventHandler
);

Parameters

handler
The event hook

See Also

TablesCollection Class | TablesCollection Members | System.Data Namespace


TablesCollection.ShouldPersistAll

Indicates whether changes to the collection (returned by the All method) should be persisted.

[Visual Basic]
Public Function ShouldPersistAll() As Boolean
[C#]
public bool ShouldPersistAll();
[C++]
public: bool ShouldPersistAll();
[JScript]
public function ShouldPersistAll() : Boolean;

Return Value

true if the property value has been changed from its default; otherwise, false.

Remarks

You typically use this method only if you are either creating a designer for the TablesCollection, or creating your own control incorporating the TablesCollection.

See Also

TablesCollection Class | TablesCollection Members | System.Data Namespace


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TablesCollection Events

The events of the TablesCollection class are listed below. For a complete list of TablesCollection class members, see the TablesCollection Members topic.

Public:

CollectionChanged Occurs when the collection is changed.

See Also

TablesCollection Class | System.Data Namespace


TablesCollection CollectionChanged Event

Occurs when the collection is changed.

The following declaration shows the syntax for a method that handles the CollectionChanged event.

[Visual Basic]
Private Sub TablesCollectionName_CollectionChanged( _
   ByVal sender As Object, _
   ByVal e As CollectionChangeEventArgs _
)
[C#]
private void TablesCollectionName_CollectionChanged(
   object sender,
   CollectionChangeEventArgs e
);
[C++]
private: void TablesCollectionName_CollectionChanged(
   Object* sender,
   CollectionChangeEventArgs* e
);
[JScript]
private TablesCollectionName_CollectionChanged(
   sender : Object,
   e : CollectionChangeEventArgs
);

Parameters

sender
The source of the event.
e
A System.ComponentModel.CollectionChangeEventArgs that contains the event data.

See Also

TablesCollection Class | TablesCollection MembersTopic | System.Data Namespace


TableSetting Class

Defines the custom settings used to view a DataTable in a DataSetView.

Object
TableSetting

[Visual Basic]
Public Class TableSetting
[C#]
public class TableSetting
[C++]
public __gc class TableSetting
[JScript]
public class TableSetting

Remarks

A TableSetting is a customized "view" of a DataTable that is used in a DataSetView. The TableSetting allows automatic filtering, sorting, and row state filtering of any table in a DataSet. A DataSet contains a collection of linked DataTable objects, you can view several tables at once, but through the TableSetting feature, each table will have it's own view of a table.

For example, imagine a master/details view of a two tables "Customer" and "Orders") in a relationship. The customers table is set to display only those customers whose names are "Smith." The orders table, on the other hand, shows only the orders (of the customers named "Smith") that have not yet shipped. To accomplish this, add TableSetting objects to the TableSettingsCollection (collection) that belongs to the DataSetView through the TableSettings property. For the first TableSetting object, the RowFilter property would be set to an expression like:

LName = 'Smith'

A second TableSetting object might be created for the Orders table with this RowFilter expression:

"IsNull(ShipDate,'Null Column') = 'Null Column'"

For details on creating expressions for the RowFilter property, see Expression.

Requirements

Namespace: System.Data

Assembly: System.Data.dll

Example [Visual Basic]

The following example creates a DataSetView and adds two TableSetting objects to the TableSettingsCollection.

[Visual Basic]

' The next two lines go into the Declarations section of the module:
Private myDataSetView As DataSetView
' SuppliersProducts is a class derived from DataSet.
Private myDataSet As SuppliersProducts

Private Sub CreateDataSetView()
   ' Not shown: SuppliersProducts is already configured with tables, relations, constraints.
   myDataSet = New SuppliersProducts
   myDataSetView = New DataSetView(myDataSet)
End Sub

Private Sub AddTableSettings()
   ' Create TableSetting and add it to TableSettingsCollection.
   Dim ts As TableSetting
   ts = New TableSetting(myDataSet.Tables("Suppliers"), "CompanyName", _
   "CompanyName < Z" & Combo1.Text, DataRowState.ModifiedCurrent)
   myDataSetView.TableSettings.Add(ts)

   ' Create and add second TableSetting.
   ts = New TableSetting(myDataSet.Tables("Products"), "ProductName", _
   "Discontinued = 'True'", DataRowState.CurrentRows)
   myDataSetView.TableSettings.Add(ts)
End Sub

See Also

TableSetting Members | System.Data Namespace | DataTable | DataSetView | TableSettingsCollection | RowFilter


TableSetting Members

Public:

Constructor

TableSetting Constructor Initializes a new instance of the TableSetting class.

Properties

ApplyDefaultSort | [To be supplied.]
DataSetView | Gets the DataSetView to which this table setting belongs.
RowFilter | Gets or sets the filter used on this table.
RowStateFilter | Gets or sets the row state of the table.
Sort | Gets or sets the sort column or columns, and sort order for the table.
Table | Gets or sets the DataTable to which the settings apply.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanged | Raises the PropertyChanged event.

See Also

TableSetting Class | System.Data Namespace


TableSetting Constructor

Initializes a new instance of the TableSetting class.

[Visual Basic]
Public Sub New( _
   ByVal table As DataTable, _
   ByVal sort As String, _
   ByVal rowFilter As String, _
   ByVal rowStateFilter As DataViewRowState _
)
[C#]
public TableSetting(
   DataTable table,
   string sort,
   string rowFilter,
   DataViewRowState rowStateFilter
);
[C++]
public: TableSetting(
   DataTable* table,
   String* sort,
   String* rowFilter,
   DataViewRowState rowStateFilter
);
[JScript]
public function TableSetting(
   table : DataTable,
   sort : String,
   rowFilter : String,
   rowStateFilter : DataViewRowState
);

Parameters

table
The DataTable to view.
sort
[To be supplied.]
rowFilter
[To be supplied.]
rowStateFilter
[To be supplied.]

Remarks

See DataSetView for more details on using a TableSetting.

See Sort for details on creating the sort expression.

See RowFilter for details on creating the rowFilter expression.

Example [Visual Basic]

The following example creates a DataSetView and adds two TableSetting objects to the TableSettingsCollection.

[Visual Basic]

' The next two lines go into the Declarations section of the module:
Private myDataSetView As DataSetView
' SuppliersProducts is a class derived from DataSet.
Private myDataSet As SuppliersProducts

Private Sub CreateDataSetView()
   ' Not shown: SuppliersProducts is already configured with tables, relations, constraints.
   myDataSet = New SuppliersProducts
   myDataSetView = New DataSetView(myDataSet)
End Sub

Private Sub AddTableSettings()
   ' Create TableSetting and add it to TableSettingsCollection.
   Dim ts As TableSetting
   ts = New TableSetting(myDataSet.Tables("Suppliers"), "CompanyName", _
   "CompanyName < Z" & Combo1.Text, DataRowState.ModifiedCurrent)
   myDataSetView.TableSettings.Add(ts)

   ' Create and add second TableSetting.
   ts = New TableSetting(myDataSet.Tables("Products"), "ProductName", _
   "Discontinued = 'True'", DataRowState.CurrentRows)
   myDataSetView.TableSettings.Add(ts)
End Sub

See Also

TableSetting Class | TableSetting Members | System.Data Namespace | Add | DataTable | Sort | DataViewRowState | RowFilter | TableSettingsCollection


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TableSetting Properties

The properties of the TableSetting class are listed below. For a complete list of TableSetting class members, see the TableSetting Members topic.

Public:

ApplyDefaultSort | [To be supplied.]
DataSetView | Gets the DataSetView to which this table setting belongs.
RowFilter | Gets or sets the filter used on this table.
RowStateFilter | Gets or sets the row state of the table.
Sort | Gets or sets the sort column or columns, and sort order for the table.
Table | Gets or sets the DataTable to which the settings apply.

See Also

TableSetting Class | System.Data Namespace


TableSetting.ApplyDefaultSort

[To be supplied.]

[Visual Basic]
Public Property ApplyDefaultSort As Boolean
[C#]
public bool ApplyDefaultSort {get; set;}
[C++]
public: __property bool get_ApplyDefaultSort();
public: __property void set_ApplyDefaultSort(bool);
[JScript]
public function get ApplyDefaultSort() : Boolean;
public function set ApplyDefaultSort(Boolean);

See Also

TableSetting Class | TableSetting Members | System.Data Namespace


TableSetting.DataSetView

Gets the DataSetView to which this table setting belongs.

[Visual Basic]
Public ReadOnly Property DataSetView As DataSetView
[C#]
public DataSetView DataSetView {get;}
[C++]
public: __property DataSetView* get_DataSetView();
[JScript]
public function get DataSetView() : DataSetView;

Property Value

The DataSetView to which this table setting belongs.

See Also

TableSetting Class | TableSetting Members | System.Data Namespace


TableSetting.RowFilter

Gets or sets the filter used on this table.

[Visual Basic]
Public Property RowFilter As String
[C#]
public string RowFilter {get; set;}
[C++]
public: __property String* get_RowFilter();
public: __property void set_RowFilter(String*);
[JScript]
public function get RowFilter() : String;
public function set RowFilter(String);

Property Value

A filter expression that includes a column name, Boolean operator, and value to filter the table on.

Remarks

See the Expression property of the DataColumn for details on forming the filter expression.

Example [Visual Basic]

The following example creates a DataSetView and adds two TableSetting objects to the TableSettingsCollection. The first TableSetting sorts according to the CompanyName column and filters out all rows except for those named like "Smith." The second table sorts according to the OrderDate column, and filters out all non-null columns.

[Visual Basic]

' The next two lines go into the Declarations section of the module:
Private myDataSetView As DataSetView
' CustomerOrders is a class derived from DataSet.
Private CustOrders As CustomerOrders

Private Sub CreateDataSetView()
   ' Not shown: CustomerOrders is already configured with tables, relations, constraints.
   myDataSet = New CustomerOrders
   myDataSetView = New DataSetView(myDataSet)
End Sub

Private Sub AddTableSettings()
   ' Create TableSetting and add it to TableSettingsCollection.
   Dim ts As TableSetting
   Dim srt As String
   Dim flt As String

   ' Sort by CompanyName column.' Filter out all rows except for rows where CustomerID = 'Smith'

   srt = "CompanyName"
   flt = "CustomerID = 'SMITH'"
   ts = New TableSetting(myDataSet.Tables("Suppliers"),srt, flt, DataViewRowState.CurrentRows)
   myDataSetView.TableSettings.Add(ts)

   ' Create and add second TableSetting.

   ts = New TableSetting(myDataSet.Tables("Orders"))
   ts.Sort = "OrderDate"
   ts.RowFilter = "IsNull(ShippedDate, 'null') = 'null'"
   myDataSetView.TableSettings.Add(ts)
End Sub

See Also

TableSetting Class | TableSetting Members | System.Data Namespace | Expression | Sort | TableSetting


TableSetting.RowStateFilter

Gets or sets the row state of the table.

[Visual Basic]
Public Property RowStateFilter As DataViewRowState
[C#]
public DataViewRowState RowStateFilter {get; set;}
[C++]
public: __property DataViewRowState get_RowStateFilter();
public: __property void set_RowStateFilter(DataViewRowState);
[JScript]
public function get RowStateFilter() : DataViewRowState;
public function set RowStateFilter(DataViewRowState);

Property Value

One of the DataViewRowState values. The default is CurrentRows.

Example [Visual Basic]

The following example creates a DataSetView and adds two TableSetting objects to the TableSettingsCollection. The first TableSetting sorts according to the CompanyName column and filters out all rows except for those named like "Smith." The second table sorts according to the OrderDate column, and filters out all non-null columns.

[Visual Basic]

' The next two lines go into the Declarations section of the module:
Private myDataSetView As DataSetView
' CustomerOrders is a class derived from DataSet.
Private CustOrders As CustomerOrders

Private Sub CreateDataSetView()
   ' Not shown: CustomerOrders is already configured with tables, relations, constraints.
   myDataSet = New CustomerOrders
   myDataSetView = New DataSetView(myDataSet)
End Sub

Private Sub AddTableSettings()
   ' Create TableSetting and add it to TableSettingsCollection.
   Dim ts As TableSetting
   Dim srt As String
   Dim flt As String

   ' Sort by CompanyName column.' Filter out all rows except for rows where CustomerID = 'Smith'

   srt = "CompanyName"
   flt = "CustomerID = 'SMITH'"
   ts = New TableSetting(myDataSet.Tables("Suppliers"),srt, flt, DataViewRowState.CurrentRows)
   myDataSetView.TableSettings.Add(ts)

   ' Create and add second TableSetting.

   ts = New TableSetting(myDataSet.Tables("Orders"))
   ts.Sort = "OrderDate"
   ts.RowFilter = "IsNull(ShippedDate, 'null') = 'null'"
   myDataSetView.TableSettings.Add(ts)
End Sub

See Also

TableSetting Class | TableSetting Members | System.Data Namespace | Table | Expression | Sort | TableSetting


TableSetting.Sort

Gets or sets the sort column or columns, and sort order for the table.

[Visual Basic]
Public Property Sort As String
[C#]
public string Sort {get; set;}
[C++]
public: __property String* get_Sort();
public: __property void set_Sort(String*);
[JScript]
public function get Sort() : String;
public function set Sort(String);

Property Value

A string containing the column name followed by "ASC" (ascending) or "DESC" (descening). Columns are sorted asending by default. Multiple columns can be separated by commas.

Remarks

See the Expression property of DataColumn for more details on forming a Sort expression.

Example [Visual Basic]

The following example prints the Sort property of a given TableSetting object.

[Visual Basic]

Private Sub GetTableSetting(dsv As DataSetView)
   Dim t As DataTable
   t = DataSet1.Tables("Customers")
   ' Get the TableSetting from a given DataSetView
   Dim ts As TableSetting
   ts = dsv.TableSettings(t)
   Debug.Print ts.Sort
End Sub

See Also

TableSetting Class | TableSetting Members | System.Data Namespace | RowFilter


TableSetting.Table

Gets or sets the DataTable to which the settings apply.

[Visual Basic]
Public Property Table As DataTable
[C#]
public DataTable Table {get; set;}
[C++]
public: __property DataTable* get_Table();
public: __property void set_Table(DataTable*);
[JScript]
public function get Table() : DataTable;
public function set Table(DataTable);

Property Value

A DataTable.

Example [Visual Basic]

The following example uses the DataTable returned by the Table property and prints all values in the table.

[Visual Basic]

Private Sub PrintDataViewTableValues(dv As DataView)
   Dim t As DataTable
   Dim c As DataColumn
   Dim r As DataRow
   t = dv.Table
   For Each r In t.Rows
      For Each c In t.Columns
         Console.WriteLine(c.ColumnName, r(c))
      Next c
   Next r
End Sub

See Also

TableSetting Class | TableSetting Members | System.Data Namespace | Expression | RowStateFilter | Sort | TableSetting


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TableSetting Methods

The methods of the TableSetting class are listed below. For a complete list of TableSetting class members, see the TableSetting Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanged | Raises the PropertyChanged event.

See Also

TableSetting Class | System.Data Namespace


TableSetting.OnPropertyChanged

Raises the PropertyChanged event.

[Visual Basic]
Overridable Protected Sub OnPropertyChanged( _
   ByVal e As PropertyChangedEventArgs _
)
[C#]
protected virtual void OnPropertyChanged(
   PropertyChangedEventArgs e
);
[C++]
protected: virtual void OnPropertyChanged(
   PropertyChangedEventArgs* e
);
[JScript]
protected function OnPropertyChanged(
   e : PropertyChangedEventArgs
);

Parameters

e
A PropertyChangedEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see TBD.

Notes to Inheritors: When overriding OnPropertyChanged in a derived class, be sure to call the base class's OnPropertyChanged method.

See Also

TableSetting Class | TableSetting Members | System.Data Namespace


TableSettingsCollection Class

Represents the collection of custom table settings for a DataSetView.

Object
BaseCollection
TableSettingsCollection

[Visual Basic]
Public Class TableSettingsCollection
   Inherits BaseCollection
[C#]
public class TableSettingsCollection : BaseCollection
[C++]
public __gc class TableSettingsCollection : public BaseCollection
[JScript]
public class TableSettingsCollection extends BaseCollection

Remarks

The TableSettingsCollection is returned by the TableSettings property of the DataSetView.

Requirements

Namespace: System.Data

Assembly: System.Data.dll

Example [Visual Basic]

The following example creates a DataSetView and adds two TableSetting objects to the TableSettingsCollection.

[Visual Basic]

' The next two lines go into the Declarations section of the module:
' The next two lines go into the Declarations section of the module:
Private myDataSetView As DataSetView
' SuppliersProducts is a class derived from DataSet.
Private myDataSet As SuppliersProducts

Private Sub CreateDataSetView()
   ' Not shown: SuppliersProducts is already configured with tables, relations, constraints.
   myDataSet = New SuppliersProducts
   myDataSetView = New DataSetView(myDataSet)
End Sub

Private Sub AddTableSettings()
   ' Create TableSetting and add it to TableSettingsCollection.
   Dim ts As TableSetting
   ts = MyDataSetView.TableSettings.Add(myDataSet.Tables("Suppliers"), _
   "CompanyName", "CompanyName < Z" & Combo1.Text, DataRowState.ModifiedCurrent)
   myDataSetView.TableSettings.Add ts

   ' Create and add second TableSetting.
   ts = MyDataSetView.TableSettings.Add(myDataSet.Tables("Products"), _
   "ProductName", "Discontinued = 'True'", DataRowState.CurrentRows)
   myDataSetView.TableSettings.Add ts
End Sub

See Also

TableSettingsCollection Members | System.Data Namespace


TableSettingsCollection Members

Public:

Properties

All | Gets or sets all of the TableSetting objects of collection.
Count (inherited from BaseCollection) | [To be supplied.]
IsReadOnly (inherited from BaseCollection) | [To be supplied.]
IsSynchronized (inherited from BaseCollection) | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the TableSettingsCollection class.
SyncRoot (inherited from BaseCollection) | [To be supplied.]

Methods

Add | Overloaded. Adds a TableSetting to the collection.
Clear | Clears the collection of any objects.
Contains | Overloaded. Gets a value indicating whether the collection contains a specific TableSetting.
CopyTo (inherited from BaseCollection) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from BaseCollection) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | Overloaded. Gets the index of a specified TableSetting.
Remove | Overloaded. Removes a TableSetting from the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Events

CollectionChanged Occurs when the TableSettingsCollection changes, either by adding or removing a TableSetting.

Protected:

Properties

List [To be supplied.]

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnCollectionChanged | This method is called whenever the collection changes. Overriders of this method should call the base implementation of this method.

Event Hookup:

Methods

AddOnCollectionChanged | Registers the handler to get events whenever this collection changes.
RemoveOnCollectionChanged | Unregisters the handler from getting events whenever this collection changes.

See Also

TableSettingsCollection Class | System.Data Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TableSettingsCollection Properties

The properties of the TableSettingsCollection class are listed below. For a complete list of TableSettingsCollection class members, see the TableSettingsCollection Members topic.

Public:

All | Gets or sets all of the TableSetting objects of collection.
Count (inherited from BaseCollection) | [To be supplied.]
IsReadOnly (inherited from BaseCollection) | [To be supplied.]
IsSynchronized (inherited from BaseCollection) | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the TableSettingsCollection class.
SyncRoot (inherited from BaseCollection) | [To be supplied.]

Protected:

List [To be supplied.]

See Also

TableSettingsCollection Class | System.Data Namespace


TableSettingsCollection.All

Gets or sets all of the TableSetting objects of collection.

[Visual Basic]
Overridable Public Property All As TableSetting ()
[C#]
public TableSetting[] All {virtual get; virtual set;}
[C++]
public: __property virtual TableSetting* get_All();
public: __property virtual void set_All(TableSetting*[]);
[JScript]
public function get All() : TableSetting[];
public function set All(TableSetting[]);

Property Value

An array of TableSetting objects.

An array of TableSetting objects.

Exceptions

Exception Type | Condition
ArgumentException | A tableSetting that is added shouldn't be added and and/or a tableSetting that is removed shouldn't be removed.

Remarks

If an exception is thrown, the collection returns to it's original state. The CollectionChanged event occurs if it succeeds.

Example [Visual Basic]

[Visual Basic]

' The next two lines go into the Declarations section of the module:
Private myDataSetView As DataSetView
' SuppliersProducts is a class derived from DataSet.
Private myDataSet As SuppliersProducts

Private Sub GetAll()
   Dim arrTS() As TableSetting
   ' Presuming myDataSetView has been created.
   arrTS = myDataSetView.TableSettings.All
End Sub

See Also

TableSettingsCollection Class | TableSettingsCollection Members | System.Data Namespace


TableSettingsCollection.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the TableSettingsCollection class.

Overload List

Gets the TableSetting in the collection associated with the specified DataTable.

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(DataTable) As TableSetting
[C#] public TableSetting this[DataTable] {virtual get;}
[C++] public: __property virtual TableSetting* get_Item(DataTable*);
[JScript] TableSettingsCollection.Item (DataTable)

Gets the TableSetting in the collection at the specified index.

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(Integer) As TableSetting
[C#] public TableSetting this[int] {virtual get;}
[C++] public: __property virtual TableSetting* get_Item(int);
[JScript] TableSettingsCollection.Item (int)

Gets the TableSetting in the collection with the specified name (not case-sensitive).

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(String) As TableSetting
[C#] public TableSetting this[String] {virtual get;}
[C++] public: __property virtual TableSetting* get_Item(String*);
[JScript] TableSettingsCollection.Item (String)

Example [Visual Basic]

The following example gets a TableSetting using a specified index.

Note This example shows how to use one of the overloaded versions of the Item property (TableSettingsCollection indexer). For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub GetTableSettingByIndex()
   Dim ts As TableSetting
   ts = myDataSetView.TableSettings(3)
   Debug.Print ts.RowFilter
End Sub

See Also

TableSettingsCollection Class | TableSettingsCollection Members | System.Data Namespace


TableSettingsCollection.Item (DataTable)

Gets the TableSetting in the collection associated with the specified DataTable.

[C#] In C#, this member is the indexer for the TableSettingsCollection class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal table As DataTable _
) As TableSetting
[C#]
public TableSetting this[
   DataTable table
] {virtual get;}
[C++]
public: __property virtual TableSetting* get_Item(
   DataTable* table
);
[JScript]
returnValue = TableSettingsCollectionObject.Item(table);
-or-
returnValue = TableSettingsCollectionObject(table);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

table
The DataTable associated with the desired TableSetting.

Parameters [Visual Basic, C#, C++]

table
The DataTable associated with the desired TableSetting.

Example [Visual Basic]

The following example gets the TableSetting associated with the given DataTable.

[Visual Basic]

Private Sub GetTableSetting(dsv As DataSetView)
   Dim t As DataTable
   t = DataSet1.Tables("Customers")
   ' Get the TableSetting from a given DataSetView
   Dim ts As TableSetting
   ts = dsv.TableSettings(t)
   Debug.Print ts.RowFilter
End Sub

See Also

TableSettingsCollection Class | TableSettingsCollection Members | System.Data Namespace | TableSettingsCollection.Item Overload List


TableSettingsCollection.Item (Int32)

Gets the TableSetting in the collection at the specified index.

[C#] In C#, this member is the indexer for the TableSettingsCollection class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal index As Integer _
) As TableSetting
[C#]
public TableSetting this[
   int index
] {virtual get;}
[C++]
public: __property virtual TableSetting* get_Item(
   int index
);
[JScript]
returnValue = TableSettingsCollectionObject.Item(index);
-or-
returnValue = TableSettingsCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
The zero-based index of the TableSetting to return.

Parameters [Visual Basic, C#, C++]

index
The zero-based index of the TableSetting to return.

Property Value

The TableSetting at the specified index.

Exceptions

Exception Type | Condition
IndexOutOfRange(System.String) | The collection doesn't have a TableSetting at this index.

Example [Visual Basic]

The following example gets a TableSetting using a specified index.

[Visual Basic]

Private Sub GetTableSettingByIndex()
   Dim ts As TableSetting
   ts = myDataSetView.TableSettings(3)
   Debug.Print ts.RowFilter
End Sub

See Also

TableSettingsCollection Class | TableSettingsCollection Members | System.Data Namespace | TableSettingsCollection.Item Overload List


TableSettingsCollection.Item (String)

Gets the TableSetting in the collection with the specified name (not case-sensitive).

[C#] In C#, this member is the indexer for the TableSettingsCollection class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal tableName As String _
) As TableSetting
[C#]
public TableSetting this[
   string tableName
] {virtual get;}
[C++]
public: __property virtual TableSetting* get_Item(
   String* tableName
);
[JScript]
returnValue = TableSettingsCollectionObject.Item(tableName);
-or-
returnValue = TableSettingsCollectionObject(tableName);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

tableName
The name of the TableSetting to return.

Parameters [Visual Basic, C#, C++]

tableName
The name of the TableSetting to return.

Property Value

A TableSetting.

Exceptions

Exception Type | Condition
IndexOutOfRange(System.String) | The collection doesn't have a TableSetting at this index.

See Also

TableSettingsCollection Class | TableSettingsCollection Members | System.Data Namespace | TableSettingsCollection.Item Overload List


TableSettingsCollection.List

[To be supplied.]

[Visual Basic]
Overridable Protected ReadOnly Property List As ObjectList
[C#]
protected ObjectList List {override get;}
[C++]
protected: __property virtual ObjectList* get_List();
[JScript]
protected function get List() : ObjectList;

See Also

TableSettingsCollection Class | TableSettingsCollection Members | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TableSettingsCollection Methods

The methods of the TableSettingsCollection class are listed below. For a complete list of TableSettingsCollection class members, see the TableSettingsCollection Members topic.

Public:

Add | Overloaded. Adds a TableSetting to the collection.
Clear | Clears the collection of any objects.
Contains | Overloaded. Gets a value indicating whether the collection contains a specific TableSetting.
CopyTo (inherited from BaseCollection) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from BaseCollection) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | Overloaded. Gets the index of a specified TableSetting.
Remove | Overloaded. Removes a TableSetting from the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnCollectionChanged | This method is called whenever the collection changes. Overriders of this method should call the base implementation of this method.

Event Hookup:

AddOnCollectionChanged | Registers the handler to get events whenever this collection changes.
RemoveOnCollectionChanged | Unregisters the handler from getting events whenever this collection changes.

See Also

TableSettingsCollection Class | System.Data Namespace


TableSettingsCollection.Add

Adds a TableSetting to the collection.

Overload List

Creates and adds a TableSetting with the specified name, sort, filter, and row state filter to the collection.

[Visual Basic] Overloads Public Function Add(DataTable, String, String, DataViewRowState) As TableSetting
[C#] public TableSetting Add(DataTable, String, String, DataViewRowState);
[C++] public: TableSetting* Add(DataTable*, String, String, DataViewRowState);
[JScript] public function Add(DataTable, String, String, DataViewRowState) : TableSetting;

Adds the specified TableSetting to the collection.

[Visual Basic] Overloads Public Sub Add(TableSetting)
[C#] public void Add(TableSetting);
[C++] public: void Add(TableSetting*);
[JScript] public function Add(TableSetting);

Example

The following example creates a DataSetView and adds two TableSetting objects to the TableSettingsCollection.

Note This example shows how to use one of the overloaded versions of Add. For other examples that may be available, see the individual overload topics.
' The next two lines go into the Declarations section of the module:
' The next two lines go into the Declarations section of the module:
Private myDataSetView As DataSetView
' SuppliersProducts is a class derived from DataSet.
Private myDataSet As SuppliersProducts

Private Sub CreateDataSetView()
   ' Not shown: SuppliersProducts is already configured with tables, relations, constraints.
   myDataSet = New SuppliersProducts
   myDataSetView = New DataSetView(myDataSet)
End Sub

Private Sub AddTableSettings()
   ' Create TableSetting and add it to TableSettingsCollection.
   Dim ts As TableSetting
   ts = New TableSetting(myDataSet.Tables("Suppliers"), "CompanyName", _
   "CompanyName < Z" & Combo1.Text, DataRowState.ModifiedCurrent)
   myDataSetView.TableSettings.Add(ts)

   ' Create and add second TableSetting.
   ts = New TableSetting(myDataSet.Tables("Products"), "ProductName", _
   "Discontinued = 'True'", DataRowState.CurrentRows)
   myDataSetView.TableSettings.Add(ts)
End Sub

See Also

TableSettingsCollection Class | TableSettingsCollection Members | System.Data Namespace


TableSettingsCollection.Add (DataTable, String, String, DataViewRowState)

Creates and adds a TableSetting with the specified name, sort, filter, and row state filter to the collection.

[Visual Basic]
Overloads Public Function Add( _
   ByVal table As DataTable, _
   ByVal sort As String, _
   ByVal rowFilter As String, _
   ByVal rowStateFilter As DataViewRowState _
) As TableSetting
[C#]
public TableSetting Add(
   DataTable table,
   string sort,
   string rowFilter,
   DataViewRowState rowStateFilter
);
[C++]
public: TableSetting* Add(
   DataTable* table,
   String* sort,
   String* rowFilter,
   DataViewRowState rowStateFilter
);
[JScript]
public function Add(
   table : DataTable,
   sort : String,
   rowFilter : String,
   rowStateFilter : DataViewRowState
) : TableSetting;

Parameters

table
The DataTable to create the TableSetting with.
sort
The sort expression consisting of a column name and optional sort direction. See Remarks for details.
rowFilter
A filter expression. See the Expression property of the DataColumn for details on forming a valid expression.
rowStateFilter
One of the DataViewRowState values.

Return Value

The newly created TableSetting.

Exceptions

Exception Type | Condition
ArgumentException | The collection already has a tableSetting for this table.

Remarks

If a null or empty string is passed in for the name, a default name is given.

The CollectionChanged event occurs if the method succeeds.

Example [Visual Basic]

The following example creates a DataSetView and adds two TableSetting objects to the TableSettingsCollection.

[Visual Basic]

' The next two lines go into the Declarations section of the module:
' The next two lines go into the Declarations section of the module:
Private myDataSetView As DataSetView
' SuppliersProducts is a class derived from DataSet.
Private myDataSet As SuppliersProducts

Private Sub CreateDataSetView()
   ' Not shown: SuppliersProducts is already configured with tables, relations, constraints.
   myDataSet = New SuppliersProducts
   myDataSetView = New DataSetView(myDataSet)
End Sub

Private Sub AddTableSettings()
   ' Create TableSetting and add it to TableSettingsCollection.
   Dim ts As TableSetting
   ts = MyDataSetView.TableSettings.Add(myDataSet.Tables("Suppliers"), _
   "CompanyName", "CompanyName < Z" & Combo1.Text, DataRowState.ModifiedCurrent)
   myDataSetView.TableSettings.Add(ts)

   ' Create and add second TableSetting.
   ts = MyDataSetView.TableSettings.Add(myDataSet.Tables("Products"), _
   "ProductName", "Discontinued = 'True'", DataRowState.CurrentRows)
   myDataSetView.TableSettings.Add(ts)
End Sub

See Also

TableSettingsCollection Class | TableSettingsCollection Members | System.Data Namespace | TableSettingsCollection.Add Overload List | DataTable | DataSetView | Expression | DataViewRowState


TableSettingsCollection.Add (TableSetting)

Adds the specified TableSetting to the collection.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal tableSetting As TableSetting _
)
[C#]
public void Add(
   TableSetting tableSetting
);
[C++]
public: void Add(
   TableSetting* tableSetting
);
[JScript]
public function Add(
   tableSetting : TableSetting
);

Parameters

tableSetting
The TableSetting to add.

Exceptions

Exception Type | Condition
ArgumentNullException | The tableSetting parameter is a null reference (in Visual Basic Nothing).
ArgumentException | The tableSetting already belongs to this collection, or another collection.
DuplicateNameException | The collection already has a TableSetting with the same name (not case-sensitive).
InvalidExpressionException | The TableSetting has a compute expression and it can't be bound.

Remarks

The OnCollectionChanged event occurs if the method succeeds.

Example

The following example creates a DataSetView and adds two TableSetting objects to the TableSettingsCollection.

' The next two lines go into the Declarations section of the module:
' The next two lines go into the Declarations section of the module:
Private myDataSetView As DataSetView
' SuppliersProducts is a class derived from DataSet.
Private myDataSet As SuppliersProducts

Private Sub CreateDataSetView()
   ' Not shown: SuppliersProducts is already configured with tables, relations, constraints.
   myDataSet = New SuppliersProducts
   myDataSetView = New DataSetView(myDataSet)
End Sub

Private Sub AddTableSettings()
   ' Create TableSetting and add it to TableSettingsCollection.
   Dim ts As TableSetting
   ts = New TableSetting(myDataSet.Tables("Suppliers"), "CompanyName", _
   "CompanyName < Z" & Combo1.Text, DataRowState.ModifiedCurrent)
   myDataSetView.TableSettings.Add(ts)

   ' Create and add second TableSetting.
   ts = New TableSetting(myDataSet.Tables("Products"), "ProductName", _
   "Discontinued = 'True'", DataRowState.CurrentRows)
   myDataSetView.TableSettings.Add(ts)
End Sub

See Also

TableSettingsCollection Class | TableSettingsCollection Members | System.Data Namespace | TableSettingsCollection.Add Overload List | DataSetView | TableSetting


TableSettingsCollection.AddOnCollectionChanged

Registers the handler to get events whenever this collection changes.

[Visual Basic]
Public Sub AddOnCollectionChanged( _
   ByVal handler As CollectionChangeEventHandler _
)
[C#]
public void AddOnCollectionChanged(
   CollectionChangeEventHandler handler
);
[C++]
public: void AddOnCollectionChanged(
   CollectionChangeEventHandler* handler
);
[JScript]
public function AddOnCollectionChanged(
   handler : CollectionChangeEventHandler
);

Parameters

handler
The event hook

See Also

TableSettingsCollection Class | TableSettingsCollection Members | System.Data Namespace | RemoveOnCollectionChanged


TableSettingsCollection.Clear

Clears the collection of any objects.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[JScript]
public function Clear();

Remarks

This method raises the OnCollectionChanged event.

See Also

TableSettingsCollection Class | TableSettingsCollection Members | System.Data Namespace


TableSettingsCollection.Contains

Gets a value indicating whether the collection contains a specific TableSetting.

Overload List

Gets a value indicating whether the collection contains a TableSetting associated with the specified DataTable.

[Visual Basic] Overloads Public Function Contains(DataTable) As Boolean
[C#] public bool Contains(DataTable);
[C++] public: bool Contains(DataTable*);
[JScript] public function Contains(DataTable) : Boolean;

Gets a value indicating whether the collection contains the TableSetting associated with the DataTable specified by name.

[Visual Basic] Overloads Public Function Contains(String) As Boolean
[C#] public bool Contains(String);
[C++] public: bool Contains(String*);
[JScript] public function Contains(String) : Boolean;

Gets a value indicating whether the collection contains the specified TableSetting.

[Visual Basic] Overloads Public Function Contains(TableSetting) As Boolean
[C#] public bool Contains(TableSetting);
[C++] public: bool Contains(TableSetting*);
[JScript] public function Contains(TableSetting) : Boolean;

See Also

TableSettingsCollection Class | TableSettingsCollection Members | System.Data Namespace


TableSettingsCollection.Contains (DataTable)

Gets a value indicating whether the collection contains a TableSetting associated with the specified DataTable.

[Visual Basic]
Overloads Public Function Contains( _
   ByVal table As DataTable _
) As Boolean
[C#]
public bool Contains(
   DataTable table
);
[C++]
public: bool Contains(
   DataTable* table
);
[JScript]
public function Contains(
   table : DataTable
) : Boolean;

Parameters

table
The DataTable of the TableSetting you are interested in.

Return Value

true if a TableSetting associated with the specified DataTable exists; otherwise, false.

See Also

TableSettingsCollection Class | TableSettingsCollection Members | System.Data Namespace | TableSettingsCollection.Contains Overload List


TableSettingsCollection.Contains (String)

Gets a value indicating whether the collection contains the TableSetting associated with the DataTable specified by name.

[Visual Basic]
Overloads Public Function Contains( _
   ByVal tableName As String _
) As Boolean
[C#]
public bool Contains(
   string tableName
);
[C++]
public: bool Contains(
   String* tableName
);
[JScript]
public function Contains(
   tableName : String
) : Boolean;

Parameters

tableName
[To be supplied.]

Return Value

true if a DataTable with this name, associated with a TableSetting, exists; otherwise, false.

See Also

TableSettingsCollection Class | TableSettingsCollection Members | System.Data Namespace | TableSettingsCollection.Contains Overload List | IndexOf


TableSettingsCollection.Contains (TableSetting)

Gets a value indicating whether the collection contains the specified TableSetting.

[Visual Basic]
Overloads Public Function Contains( _
   ByVal tableSetting As TableSetting _
) As Boolean
[C#]
public bool Contains(
   TableSetting tableSetting
);
[C++]
public: bool Contains(
   TableSetting* tableSetting
);
[JScript]
public function Contains(
   tableSetting : TableSetting
) : Boolean;

Parameters

tableSetting
A TableSetting which may or may not belong to this collection.

Return Value

true, if the specified TableSetting belongs to this collection; otherwise, false.

See Also

TableSettingsCollection Class | TableSettingsCollection Members | System.Data Namespace | TableSettingsCollection.Contains Overload List


TableSettingsCollection.IndexOf

Gets the index of a specified TableSetting.

Overload List

Gets the index of a TableSetting associated with the specified TableSetting.

[Visual Basic] Overloads Public Function IndexOf(TableSetting) As Integer
[C#] public int IndexOf(TableSetting);
[C++] public: int IndexOf(TableSetting*);
[JScript] public function IndexOf(TableSetting) : int;

Gets the index of a TableSetting associated with the specified DataTable.

[Visual Basic] Overloads Public Function IndexOf(DataTable) As Integer
[C#] public int IndexOf(DataTable);
[C++] public: int IndexOf(DataTable*);
[JScript] public function IndexOf(DataTable) : int;

The index of a TableSetting associated with the named DataTable (not case-sensitive).

[Visual Basic] Overloads Public Function IndexOf(String) As Integer
[C#] public int IndexOf(String);
[C++] public: int IndexOf(String*);
[JScript] public function IndexOf(String) : int;

See Also

TableSettingsCollection Class | TableSettingsCollection Members | System.Data Namespace


TableSettingsCollection.IndexOf (TableSetting)

Gets the index of a TableSetting associated with the specified TableSetting.

[Visual Basic]
Overloads Public Function IndexOf( _
   ByVal tableSetting As TableSetting _
) As Integer
[C#]
public int IndexOf(
   TableSetting tableSetting
);
[C++]
public: int IndexOf(
   TableSetting* tableSetting
);
[JScript]
public function IndexOf(
   tableSetting : TableSetting
) : int;

Parameters

tableSetting
The TableSetting whose index you want.

Return Value

The index of the specified TableSetting.

See Also

TableSettingsCollection Class | TableSettingsCollection Members | System.Data Namespace | TableSettingsCollection.IndexOf Overload List


TableSettingsCollection.IndexOf (DataTable)

Gets the index of a TableSetting associated with the specified DataTable.

[Visual Basic]
Overloads Public Function IndexOf( _
   ByVal table As DataTable _
) As Integer
[C#]
public int IndexOf(
   DataTable table
);
[C++]
public: int IndexOf(
   DataTable* table
);
[JScript]
public function IndexOf(
   table : DataTable
) : int;

Parameters

table
The DataTable associated with the TableSetting you want.

Return Value

The index of a TableSetting associated with the specified DataTable (not case-sensitive).

See Also

TableSettingsCollection Class | TableSettingsCollection Members | System.Data Namespace | TableSettingsCollection.IndexOf Overload List


TableSettingsCollection.IndexOf (String)

The index of a TableSetting associated with the named DataTable (not case-sensitive).

[Visual Basic]
Overloads Public Function IndexOf( _
   ByVal tableSettingName As String _
) As Integer
[C#]
public int IndexOf(
   string tableSettingName
);
[C++]
public: int IndexOf(
   String* tableSettingName
);
[JScript]
public function IndexOf(
   tableSettingName : String
) : int;

Parameters

tableSettingName
The TableName of the DataTable associated with the TableSetting whose index you want.

Return Value

The index of the found TableSetting; otherwise,-1 if the TableSetting cannot be found.

See Also

TableSettingsCollection Class | TableSettingsCollection Members | System.Data Namespace | TableSettingsCollection.IndexOf Overload List | Contains


TableSettingsCollection.OnCollectionChanged

This method is called whenever the collection changes. Overriders of this method should call the base implementation of this method.

[Visual Basic]
Overridable Protected Sub OnCollectionChanged( _
   ByVal ccevent As CollectionChangeEventArgs _
)
[C#]
protected virtual void OnCollectionChanged(
   CollectionChangeEventArgs ccevent
);
[C++]
protected: virtual void OnCollectionChanged(
   CollectionChangeEventArgs* ccevent
);
[JScript]
protected function OnCollectionChanged(
   ccevent : CollectionChangeEventArgs
);

Parameters

ccevent
The event information.

See Also

TableSettingsCollection Class | TableSettingsCollection Members | System.Data Namespace


TableSettingsCollection.Remove

Removes a TableSetting from the collection.

Overload List

Removes the the TableSetting associated with the DataTable specified by name.

[Visual Basic] Overloads Public Sub Remove(String)
[C#] public void Remove(String);
[C++] public: void Remove(String*);
[JScript] public function Remove(String);

Removes the TableSetting at the specified index from the collection.

[Visual Basic] Overloads Public Sub Remove(Integer)
[C#] public void Remove(int);
[C++] public: void Remove(int);
[JScript] public function Remove(int);

Removes the specified TableSetting from the collection.

[Visual Basic] Overloads Public Sub Remove(TableSetting)
[C#] public void Remove(TableSetting);
[C++] public: void Remove(TableSetting*);
[JScript] public function Remove(TableSetting);

See Also

TableSettingsCollection Class | TableSettingsCollection Members | System.Data Namespace


TableSettingsCollection.Remove (String)

Removes the the TableSetting associated with the DataTable specified by name.

[Visual Basic]
Overloads Public Sub Remove( _
   ByVal name As String _
)
[C#]
public void Remove(
   string name
);
[C++]
public: void Remove(
   String* name
);
[JScript]
public function Remove(
   name : String
);

Parameters

name
The TableName of the DataTable associated with the TableSetting to remove.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | The collection doesn't have a tableSetting with the specified name.

Remarks

The OnCollectionChanged event occurs if the collection is successfully changed.

See Also

TableSettingsCollection Class | TableSettingsCollection Members | System.Data Namespace | TableSettingsCollection.Remove Overload List


TableSettingsCollection.Remove (Int32)

Removes the TableSetting at the specified index from the collection.

[Visual Basic]
Overloads Public Sub Remove( _
   ByVal index As Integer _
)
[C#]
public void Remove(
   int index
);
[C++]
public: void Remove(
   int index
);
[JScript]
public function Remove(
   index : int
);

Parameters

index
The index of the TableSetting to remove.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | The collection doesn't have a TableSetting at this index.

Remarks

The OnCollectionChanged event occurs if the collection is successfully changed.

See Also

TableSettingsCollection Class | TableSettingsCollection Members | System.Data Namespace | TableSettingsCollection.Remove Overload List


TableSettingsCollection.Remove (TableSetting)

Removes the specified TableSetting from the collection.

[Visual Basic]
Overloads Public Sub Remove( _
   ByVal tableSetting As TableSetting _
)
[C#]
public void Remove(
   TableSetting tableSetting
);
[C++]
public: void Remove(
   TableSetting* tableSetting
);
[JScript]
public function Remove(
   tableSetting : TableSetting
);

Parameters

tableSetting
The TableSetting to remove.

Exceptions

Exception Type | Condition
ArgumentNullException | The tableSetting parameter is a null reference (in Visual Basic Nothing).
ArgumentException | The TableSetting doesn't belong to this collection. -Or- The TableSetting is part of a relationship. -Or- Another TableSetting object's compute expression depends on this TableSetting.

Remarks

The OnCollectionChanged event occurs if the collection is successfully changed.

See Also

TableSettingsCollection Class | TableSettingsCollection Members | System.Data Namespace | TableSettingsCollection.Remove Overload List


TableSettingsCollection.RemoveOnCollectionChanged

Unregisters the handler from getting events whenever this collection changes.

[Visual Basic]
Public Sub RemoveOnCollectionChanged( _
   ByVal handler As CollectionChangeEventHandler _
)
[C#]
public void RemoveOnCollectionChanged(
   CollectionChangeEventHandler handler
);
[C++]
public: void RemoveOnCollectionChanged(
   CollectionChangeEventHandler* handler
);
[JScript]
public function RemoveOnCollectionChanged(
   handler : CollectionChangeEventHandler
);

Parameters

handler
The event hook

See Also

TableSettingsCollection Class | TableSettingsCollection Members | System.Data Namespace | AddOnCollectionChanged


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TableSettingsCollection Events

The events of the TableSettingsCollection class are listed below. For a complete list of TableSettingsCollection class members, see the TableSettingsCollection Members topic.

Public:

CollectionChanged Occurs when the TableSettingsCollection changes, either by adding or removing a TableSetting.

See Also

TableSettingsCollection Class | System.Data Namespace


TableSettingsCollection CollectionChanged Event

Occurs when the TableSettingsCollection changes, either by adding or removing a TableSetting.

The following declaration shows the syntax for a method that handles the CollectionChanged event.

[Visual Basic]
Private Sub TableSettingsCollectionName_CollectionChanged( _
   ByVal sender As Object, _
   ByVal e As CollectionChangeEventArgs _
)
[C#]
private void TableSettingsCollectionName_CollectionChanged(
   object sender,
   CollectionChangeEventArgs e
);
[C++]
private: void TableSettingsCollectionName_CollectionChanged(
   Object* sender,
   CollectionChangeEventArgs* e
);
[JScript]
private TableSettingsCollectionName_CollectionChanged(
   sender : Object,
   e : CollectionChangeEventArgs
);

Parameters

sender
The source of the event.
e
A System.ComponentModel.CollectionChangeEventArgs that contains the event data.

See Also

TableSettingsCollection Class | TableSettingsCollection MembersTopic | System.Data Namespace


TreePosition Enumeration

[To be supplied.]

[Visual Basic]
Public Enum TreePosition
[C#]
public enum TreePosition
[C++]
public enum TreePosition

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
After | [To be supplied.]
Before | [To be supplied.]
FirstChild | [To be supplied.]
FirstField | [To be supplied.]
LastChild | [To be supplied.]
LastField | [To be supplied.]
None | [To be supplied.]
Parent | [To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace


UniqueConstraint Class

Represents a restriction on a set of columns in which all values must be unique.

Object
Constraint
UniqueConstraint

[Visual Basic]
Public Class UniqueConstraint
   Inherits Constraint
[C#]
public class UniqueConstraint : Constraint
[C++]
public __gc class UniqueConstraint : public Constraint
[JScript]
public class UniqueConstraint extends Constraint

Remarks

The UniqueConstraint is enforced on a single column (or columns) to ensure that a primary key value is unique.

Constraints are not enforced unless the EnforceConstraints property is set to true.

When the a DataSet is merged with a second DataSet, constraints are not enforced until all merges are completed.

Requirements

Namespace: System.Data

Assembly: System.Data.dll

Example [Visual Basic]

The following example adds a UniqueConstraint to a DataSet and sets the EnforceConstraints property to true.

[Visual Basic]

' The next line goes into the Declarations section of the module:
' SuppliersProducts is a class derived from DataSet.
Private myDataSet As SuppliersProducts

Private Sub CreateUniqueConstraint()
   Dim myUC As UniqueConstraint
   myUC  = New UniqueConstraint _
      (myDataSet.Tables("Suppliers"), _
      myDataSet.Tables("Suppliers").Columns("CompanyID"))
End Sub

See Also

UniqueConstraint Members | System.Data Namespace | Constraint | ForeignKeyConstraint | DataRelation | AddKeyConstraint | Constraints


UniqueConstraint Members

Public:

Constructor

UniqueConstraint Constructor Overloaded. Initializes a new instance of the UniqueConstraint.

Properties

Columns | Gets the array of columns that this constraint constrains.
ConstraintName (inherited from Constraint) | The name of this constraint within the ConstraintsCollection. An ArgumentException is thrown if setting the name to null or empty string and the column belongs to a collection. A DuplicateNameException is thrown if this column belongs to a collection and it already has a column with the same name (case insensitive).
DataSet | Gets the DataSet to which this constraint belongs.
IsPrimaryKey | Gets a value indicating whether or not the constraint is on a primary key.
Table | Gets the table to which this constraint belongs.

Methods

Equals | Compares twhis constraint to a second to determine if both are identical.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

_DataSet (inherited from Constraint) Gets the DataSet to which this constraint belongs.

Methods

CheckStateForProperty (inherited from Constraint) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDataSet (inherited from Constraint) | Sets the constraint's DataSet.

See Also

UniqueConstraint Class | System.Data Namespace


UniqueConstraint Constructor

Initializes a new instance of the UniqueConstraint.

Overload List

Initializes a new instance of the UniqueConstraint with the specified name and DataColumn.

[Visual Basic] Overloads Public Sub New(String, DataColumn)
[C#] public UniqueConstraint(String, DataColumn);
[C++] public: UniqueConstraint(String*, DataColumn);
[JScript] public function UniqueConstraint(String, DataColumn);

Initializes a new instance of the UniqueConstraint with the specified DataColumn.

[Visual Basic] Overloads Public Sub New(DataColumn)
[C#] public UniqueConstraint(DataColumn);
[C++] public: UniqueConstraint(DataColumn*);
[JScript] public function UniqueConstraint(DataColumn);

Initializes a new instance of the UniqueConstraint with the specified name and array of DataColumn objects.

[Visual Basic] Overloads Public Sub New(String, DataColumn())
[C#] public UniqueConstraint(String, DataColumn[]);
[C++] public: UniqueConstraint(String*, DataColumn[]);
[JScript] public function UniqueConstraint(String, DataColumn[]);

Initializes a new instance of the UniqueConstraint with the given array of DataColumn objects.

[Visual Basic] Overloads Public Sub New(DataColumn())
[C#] public UniqueConstraint(DataColumn[]);
[C++] public: UniqueConstraint(DataColumn*[]);
[JScript] public function UniqueConstraint(DataColumn[]);

Example [Visual Basic]

The following example creates a new UniqueConstraint and assigns it to the ParentKeyConstraint property of a DataRelation.

Note This example shows how to use one of the overloaded version of the UniqueConstraint constructor. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub CreateUniqueConstraint
   Dim cstrt As UniqueConstraint
   ' Get the DataColumn of a table in a DataSet.
   Dim dc As DataColumn
   Set dc = DataSet1.Tables("Suppliers").Columns("SupplierID")
   ' Create the constraint.
   Set cstrt = New UniqueConstraint(dc)
   ' Add the constraint to a DataRelation of the DataSet.
   DataSet1.Relations.Add cstrt
End Sub

See Also

UniqueConstraint Class | UniqueConstraint Members | System.Data Namespace


UniqueConstraint Constructor (String, DataColumn)

Initializes a new instance of the UniqueConstraint with the specified name and DataColumn.

[Visual Basic]
Overloads Public Sub New( _
   ByVal name As String, _
   ByVal column As DataColumn _
)
[C#]
public UniqueConstraint(
   string name,
   DataColumn column
);
[C++]
public: UniqueConstraint(
   String* name,
   DataColumn* column
);
[JScript]
public function UniqueConstraint(
   name : String,
   column : DataColumn
);

Parameters

name
The name of the constraint.
column
The DataColumn to constrain.

Example [Visual Basic]

The following example creates a new UniqueConstraint and assigns it to the ParentKeyConstraint property of a DataRelation.

[Visual Basic]

Private Sub CreateUniqueConstraint
   Dim cstrt As UniqueConstraint
   ' Get the DataColumn of a table in a DataSet.
   Dim dc As DataColumn
   Set dc = DataSet1.Tables("Suppliers").Columns("SupplierID")
   ' Create the constraint.
   Set cstrt = New UniqueConstraint("supplierIDcstrt", dc)
   ' Add the constraint to a DataRelation of the DataSet.
   DataSet1.Relations.Add cstrt
End Sub

See Also

UniqueConstraint Class | UniqueConstraint Members | System.Data Namespace | UniqueConstraint Constructor Overload List | DataRelation | ParentKeyConstraint


UniqueConstraint Constructor (DataColumn)

Initializes a new instance of the UniqueConstraint with the specified DataColumn.

[Visual Basic]
Overloads Public Sub New( _
   ByVal column As DataColumn _
)
[C#]
public UniqueConstraint(
   DataColumn column
);
[C++]
public: UniqueConstraint(
   DataColumn* column
);
[JScript]
public function UniqueConstraint(
   column : DataColumn
);

Parameters

column
The DataColumn to constrain

Example [Visual Basic]

The following example creates a new UniqueConstraint and assigns it to the ParentKeyConstraint property of a DataRelation.

[Visual Basic]

Private Sub CreateUniqueConstraint
   Dim cstrt As UniqueConstraint
   ' Get the DataColumn of a table in a DataSet.
   Dim dc As DataColumn
   Set dc = DataSet1.Tables("Suppliers").Columns("SupplierID")
   ' Create the constraint.
   Set cstrt = New UniqueConstraint(dc)
   ' Add the constraint to a DataRelation of the DataSet.
   DataSet1.Relations.Add cstrt
End Sub

See Also

UniqueConstraint Class | UniqueConstraint Members | System.Data Namespace | UniqueConstraint Constructor Overload List


UniqueConstraint Constructor (String, DataColumn[])

Initializes a new instance of the UniqueConstraint with the specified name and array of DataColumn objects.

[Visual Basic]
Overloads Public Sub New( _
   ByVal name As String, _
   ByVal columns() As DataColumn _
)
[C#]
public UniqueConstraint(
   string name,
   DataColumn[] columns
);
[C++]
public: UniqueConstraint(
   String* name,
   DataColumn* columns[]
);
[JScript]
public function UniqueConstraint(
   name : String,
   columns : DataColumn[]
);

Parameters

name
The name of the constraint.
columns
The array of DataColumn objects to constrain.

See Also

UniqueConstraint Class | UniqueConstraint Members | System.Data Namespace | UniqueConstraint Constructor Overload List


UniqueConstraint Constructor (DataColumn[])

Initializes a new instance of the UniqueConstraint with the given array of DataColumn objects.

[Visual Basic]
Overloads Public Sub New( _
   ByVal columns() As DataColumn _
)
[C#]
public UniqueConstraint(
   DataColumn[] columns
);
[C++]
public: UniqueConstraint(
   DataColumn* columns[]
);
[JScript]
public function UniqueConstraint(
   columns : DataColumn[]
);

Parameters

columns
The array of DataColumn objects to constrain.

See Also

UniqueConstraint Class | UniqueConstraint Members | System.Data Namespace | UniqueConstraint Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UniqueConstraint Properties

The properties of the UniqueConstraint class are listed below. For a complete list of UniqueConstraint class members, see the UniqueConstraint Members topic.

Public:

Columns | Gets the array of columns that this constraint constrains.
ConstraintName (inherited from Constraint) | The name of this constraint within the ConstraintsCollection. An ArgumentException is thrown if setting the name to null or empty string and the column belongs to a collection. A DuplicateNameException is thrown if this column belongs to a collection and it already has a column with the same name (case insensitive).
DataSet | Gets the DataSet to which this constraint belongs.
IsPrimaryKey | Gets a value indicating whether or not the constraint is on a primary key.
Table | Gets the table to which this constraint belongs.

Protected:

_DataSet (inherited from Constraint) Gets the DataSet to which this constraint belongs.

See Also

UniqueConstraint Class | System.Data Namespace


UniqueConstraint.Columns

Gets the array of columns that this constraint constrains.

[Visual Basic]
Overridable Public ReadOnly Property Columns As DataColumn ()
[C#]
public DataColumn[] Columns {virtual get;}
[C++]
public: __property virtual DataColumn* get_Columns();
[JScript]
public function get Columns() : DataColumn[];

Property Value

An array of DataColumn objects.

Example [Visual Basic]

The following example returns the DataColumn objects that the UniqueConstraint constrains.

[Visual Basic]

Private Sub GetColsFromConstraint()
   Dim dCols() As DataColumn
   ' Get a named relation from a DataSet.
   Dim rel As DataRelation
   Set rel = DataSet1.Relations("CustomerOrders")
   ' Get the ParentKeyConstraint
   Dim cstrt As UniqueConstraint
   Set cstrt= rel.ParentKeyConstraint
   ' Get the DataColumn objects being constrained.
   Set dCols = cstrt.Columns
   ' Print the column name of each column.
   Dim i As Integer
   For i = 0 to Ubound(dCols)
      Debug.Print dCols(i).ColumnName
   Next i
End Sub

See Also

UniqueConstraint Class | UniqueConstraint Members | System.Data Namespace


UniqueConstraint.DataSet

Gets the DataSet to which this constraint belongs.

[Visual Basic]
Overridable Public ReadOnly Property DataSet As DataSet
[C#]
public DataSet DataSet {override get;}
[C++]
public: __property virtual DataSet* get_DataSet();
[JScript]
public function get DataSet() : DataSet;

Property Value

The DataSet to which this constraint belongs.

Example [Visual Basic]

The following example returns the DataSet that a UniqueConstraint belongs to.

[Visual Basic]

Private Sub GetDataSetFromConstraint(t As DataTable)
   Dim ds As DataSet
   ' Get a UniqueConstraint from the parameter DataTable
   Dim cstrt As UniqueConstraint
   Set cstrt = t.Constaints(0)
   ' Get the DataTable.
   Set ds = cstrt.DataSet
End Sub

See Also

UniqueConstraint Class | UniqueConstraint Members | System.Data Namespace


UniqueConstraint.IsPrimaryKey

Gets a value indicating whether or not the constraint is on a primary key.

[Visual Basic]
Overridable Public ReadOnly Property IsPrimaryKey As Boolean
[C#]
public bool IsPrimaryKey {override get;}
[C++]
public: __property virtual bool get_IsPrimaryKey();
[JScript]
public function get IsPrimaryKey() : Boolean;

Property Value

true, if the constraint is on a primary key; otherwise, false.

Example [Visual Basic]

The following example checks the IsPrimaryKey property.

[Visual Basic]

Private Sub GetPrimaryKey()
   Dim rel As DataRelation
   Dim cstrt As UniqueConstraint
   ' Get a DataRelation from a DataSet.
   Set rel = DataSet1.Relations("CustomerOrders")
   ' Get the ParentKeyConstraint.
   Set cstrt = rel.ParentKeyConstraint
   ' Test if the IsPrimaryKey is true.
   If cstrt.IsPrimaryKey Then
      ' Do something
   End If
End Sub

See Also

UniqueConstraint Class | UniqueConstraint Members | System.Data Namespace


UniqueConstraint.Table

Gets the table to which this constraint belongs.

[Visual Basic]
Overridable Public ReadOnly Property Table As DataTable
[C#]
public DataTable Table {override get;}
[C++]
public: __property virtual DataTable* get_Table();
[JScript]
public function get Table() : DataTable;

Property Value

The DataTable to which the constraint belongs.

Example [Visual Basic]

The following example returns a UniqueConstraint object's DataTable.

[Visual Basic]

Private Sub GetTableFromConstraint()
   Dim t As DataTable
   ' Get a UniqueConstraint.
   Dim cstrt As UniqueConstraint
   Set cstrt = MyDataSet.Tables("Suppliers").Constraints(0)
   ' Get the DataTable.
   Set t = cstrt.DataTable
End Sub

See Also

UniqueConstraint Class | UniqueConstraint Members | System.Data Namespace | ParentKeyConstraint


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UniqueConstraint Methods

The methods of the UniqueConstraint class are listed below. For a complete list of UniqueConstraint class members, see the UniqueConstraint Members topic.

Public:

Equals | Compares twhis constraint to a second to determine if both are identical.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

CheckStateForProperty (inherited from Constraint) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDataSet (inherited from Constraint) | Sets the constraint's DataSet.

See Also

UniqueConstraint Class | System.Data Namespace


UniqueConstraint.Equals

Compares twhis constraint to a second to determine if both are identical.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal key2 As Object _
) As Boolean
[C#]
public override bool Equals(
   object key2
);
[C++]
public: override bool Equals(
   Object* key2
);
[JScript]
public override function Equals(
   key2 : Object
) : Boolean;

Parameters

key2
The object to which this UniqueConstraint is compared.

Return Value

true, if the contraints are equal; otherwise, false.

Remarks

Two constraints are "equal" if they constrain the same columns.

Example [Visual Basic]

The following example compares two UiqueConstraint objects.

[Visual Basic]

Private Sub CompareConstraints()
   Dim cstr1 As UniqueConstraint
   dim cstr2 As UniqueConstraint
   ' Get a DataRelation from a DataSet.
   Dim rel1 As DataRelation
   Dim rel2 As DataRelation
   Set rel1 = DataSet1.Relations("CustomerOrders")
   '  Get a constraint.
   Set cstr1 = rel1.ParentKeyConstraint
   ' Get a second relation and constraint.
   Set rel2 = DataSet1.Relations("OrderDetails")
   Set cstr2 = rel2.ParentKeyConstraint
   ' Compare the two.
   Debug.Print cstr1.Equals cstr2
End Sub

See Also

UniqueConstraint Class | UniqueConstraint Members | System.Data Namespace | ParentKeyConstraint


UpdateRowSource Enumeration

[To be supplied.]

[Visual Basic]
Public Enum UpdateRowSource
[C#]
public enum UpdateRowSource
[C++]
public enum UpdateRowSource

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Both | [To be supplied.]
FirstReturnedRecord | [To be supplied.]
None | [To be supplied.]
OutputParameters | [To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace


UpdateStatus Enumeration

[To be supplied.]

[Visual Basic]
Public Enum UpdateStatus
[C#]
public enum UpdateStatus
[C++]
public enum UpdateStatus

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Continue | [To be supplied.]
ErrorsOccured | [To be supplied.]
SkipAllRemainingRows | [To be supplied.]
SkipCurrentRow | [To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace


UriResolver Class

[To be supplied.]

Object
UriResolver

[Visual Basic]
Public Class UriResolver
   Implements IUriResolver
[C#]
public class UriResolver : IUriResolver
[C++]
public __gc class UriResolver : public IUriResolver
[JScript]
public class UriResolver implements IUriResolver

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

UriResolver Members | System.Data Namespace


UriResolver Members

Public:

Constructor

UriResolver Constructor Overloaded. [To be supplied.]

Properties

BaseUri [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetResource | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UriResolver Class | System.Data Namespace


UriResolver Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public UriResolver();
[C++] public: UriResolver();
[JScript] public function UriResolver();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public UriResolver(String);
[C++] public: UriResolver(String*);
[JScript] public function UriResolver(String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(XmlSchemaCollection)
[C#] public UriResolver(XmlSchemaCollection);
[C++] public: UriResolver(XmlSchemaCollection*);
[JScript] public function UriResolver(XmlSchemaCollection);

See Also

UriResolver Class | UriResolver Members | System.Data Namespace


UriResolver Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public UriResolver();
[C++]
public: UriResolver();
[JScript]
public function UriResolver();

See Also

UriResolver Class | UriResolver Members | System.Data Namespace | UriResolver Constructor Overload List


UriResolver Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal baseURI As String _
)
[C#]
public UriResolver(
   string baseURI
);
[C++]
public: UriResolver(
   String* baseURI
);
[JScript]
public function UriResolver(
   baseURI : String
);

Parameters

baseURI
[To be supplied.]

See Also

UriResolver Class | UriResolver Members | System.Data Namespace | UriResolver Constructor Overload List


UriResolver Constructor (XmlSchemaCollection)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal collection As XmlSchemaCollection _
)
[C#]
public UriResolver(
   XmlSchemaCollection collection
);
[C++]
public: UriResolver(
   XmlSchemaCollection* collection
);
[JScript]
public function UriResolver(
   collection : XmlSchemaCollection
);

Parameters

collection
[To be supplied.]

See Also

UriResolver Class | UriResolver Members | System.Data Namespace | UriResolver Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UriResolver Properties

The properties of the UriResolver class are listed below. For a complete list of UriResolver class members, see the UriResolver Members topic.

Public:

BaseUri [To be supplied.]

See Also

UriResolver Class | System.Data Namespace


UriResolver.BaseUri

[To be supplied.]

[Visual Basic]
Public Property BaseUri As String
[C#]
public string BaseUri {get; set;}
[C++]
public: __property String* get_BaseUri();
public: __property void set_BaseUri(String*);
[JScript]
public function get BaseUri() : String;
public function set BaseUri(String);

See Also

UriResolver Class | UriResolver Members | System.Data Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UriResolver Methods

The methods of the UriResolver class are listed below. For a complete list of UriResolver class members, see the UriResolver Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetResource | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UriResolver Class | System.Data Namespace


UriResolver.GetResource

[To be supplied.]

[Visual Basic]
Overridable Public Function GetResource( _
   ByVal baseUri As String, _
   ByVal relativeUri As String, _
   ByVal role As String, _
   ByVal t As Type, _
   ByRef resolvedUri As String _
) As Object
[C#]
public virtual object GetResource(
   string baseUri,
   string relativeUri,
   string role,
   Type t,
   ref string resolvedUri
);
[C++]
public: virtual Object* GetResource(
   String* baseUri,
   String* relativeUri,
   String* role,
   Type* t,
   String** resolvedUri
);
[JScript]
public function GetResource(
   baseUri : String,
   relativeUri : String,
   role : String,
   t : Type,
   resolvedUri : String
) : Object;

Parameters

baseUri
[To be supplied.]
relativeUri
[To be supplied.]
role
[To be supplied.]
t
[To be supplied.]
resolvedUri
[To be supplied.]

See Also

UriResolver Class | UriResolver Members | System.Data Namespace


VersionNotFoundException Class

[To be supplied.]

Object
Exception
SystemException
VersionNotFoundException

[Visual Basic]
Public Class VersionNotFoundException
   Inherits SystemException
[C#]
public class VersionNotFoundException : SystemException
[C++]
public __gc class VersionNotFoundException : public SystemException
[JScript]
public class VersionNotFoundException extends SystemException

Remarks

[To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

VersionNotFoundException Members | System.Data Namespace


VersionNotFoundException Members

Public:

Constructor

VersionNotFoundException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

VersionNotFoundException Class | System.Data Namespace


VersionNotFoundException Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public VersionNotFoundException();
[C++] public: VersionNotFoundException();
[JScript] public function VersionNotFoundException();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public VersionNotFoundException(String);
[C++] public: VersionNotFoundException(String*);
[JScript] public function VersionNotFoundException(String);

See Also

VersionNotFoundException Class | VersionNotFoundException Members | System.Data Namespace


VersionNotFoundException Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public VersionNotFoundException();
[C++]
public: VersionNotFoundException();
[JScript]
public function VersionNotFoundException();

See Also

VersionNotFoundException Class | VersionNotFoundException Members | System.Data Namespace | VersionNotFoundException Constructor Overload List


VersionNotFoundException Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal s As String _
)
[C#]
public VersionNotFoundException(
   string s
);
[C++]
public: VersionNotFoundException(
   String* s
);
[JScript]
public function VersionNotFoundException(
   s : String
);

Parameters

s
[To be supplied.]

See Also

VersionNotFoundException Class | VersionNotFoundException Members | System.Data Namespace | VersionNotFoundException Constructor Overload List


XmlContent Enumeration

[To be supplied.]

[Visual Basic]
Public Enum XmlContent
[C#]
public enum XmlContent
[C++]
public enum XmlContent

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
EltOnly | [To be supplied.]
Empty | [To be supplied.]
Mixed | [To be supplied.]
None | [To be supplied.]
TextOnly | [To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace


XmlOrder Enumeration

[To be supplied.]

[Visual Basic]
Public Enum XmlOrder
[C#]
public enum XmlOrder
[C++]
public enum XmlOrder

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
many | [To be supplied.]
none | [To be supplied.]
one | [To be supplied.]
seq | [To be supplied.]

Requirements

Namespace: System.Data

Assembly: System.Data.dll

See Also

System.Data Namespace


System.Data.ADO

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Data.ADO Namespace

Classes

Class | Description
ADOCommand | Represents a query command to be made to a data source.
ADOCommandConverter | [To be supplied.]
ADOConnection | Represents an open connection to a data source.
ADODataReader | [To be supplied.]
ADODataSetCommand | Represents a set of data commands and a database connection which are used to fill the DataSet and update the data source. At any time, the object refers to only a single record within the current data set.
ADOError | Collects information relevant to a warning or error returned by the data source.
ADOErrors | Collects all errors generated by the adapter.
ADOException | Thrown whenever an error from the adapter is encountered.
ADOInfoMessageEventArgs | [To be supplied.]
ADOParameter | Represents a parameter to an ADOCommand and, optionally, its mapping to DataSet columns.
ADOParameterConverter | [To be supplied.]
ADOParameters | Collects all parameters relevant to an ADOCommand and their mappings to DataSet columns.
ADOProperties | [To be supplied.]
ADOProperty | [To be supplied.]
ADORowUpdatedEventArgs | [To be supplied.]
ADORowUpdatingEventArgs | [To be supplied.]
ADOSchemaMappingEventArgs | [To be supplied.]

Delegates

Delegate | Description
ADOInfoMessageEventHandler | [To be supplied.]
ADORowUpdatedEventHandler | [To be supplied.]
ADORowUpdatingEventHandler | [To be supplied.]
ADOSchemaMappingEventHandler | [To be supplied.]

Enumerations

Enumeration | Description
ADODBType | [To be supplied.]


ADOCommand Class

Represents a query command to be made to a data source.

Object
DBCommand
ADOCommand

[Visual Basic]
Public Class ADOCommand
   Inherits DBCommand
[C#]
public class ADOCommand : DBCommand
[C++]
public __gc class ADOCommand : public DBCommand
[JScript]
public class ADOCommand extends DBCommand

Remarks

When an instance of ADOCommand is created, the read/write properties are set to initial values. For a list of these values, see the ADOCommand constructor.

Requirements

Namespace: System.Data.ADO

Assembly: System.Data.dll

Example [C#]

The following example uses the ADOCommand, along ADODataSetCommand and ADOConnection, to select records from an Access data source. The DataSet is then used to insert new records in a SQL Server data source.

[C#]

private DataSet InitializeMyDataSet() {
   // creates the table and its columns for the DataSet
   DataSet newData = new DataSet();
   DataTable newTable = newData.Tables.Add("Catagories");

   // add Columns to table
   newTable.Columns.Add("CategoryID",typeof(Int32));
   newTable.Columns.Add("CategoryName", typeof(String));
   newTable.Columns.Add("Description", typeof(String));
   newTable.Columns.Add("Picture",typeof(Byte[]));
   return newData;
}

public void AccessToSQLServer() {
   // set Access connection and select strings
   const string strAccessConn = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=NWIND_RW.MDB";
   const string strAccessSelect = "SELECT * FROM Categories ORDER BY CategoryID";
   // set SQL Server connection and insert strings
   const string strSQLServerConn = "Data Source=VBsql7;Initial Catalog=Northwind;User ID=sa;Password=;";
   const string strSQLServerInsert = "INSERT INTO Categories(CategoryName, Description, Picture) Values(@CategoryName,@Description,@Picture)";
   // create my DataSet
   DataSet myDataSet = InitializeMyDataSet();
   // create my Access objects
   ADOConnection myAccessConn = new ADOConnection(strAccessConn);
   ADODataSetCommand myAccessDataSetCmd = new ADODataSetCommand();
   myAccessDataSetCmd.SelectCommand = new ADOCommand(strAccessSelect,myAccessConn);
   // create my SQL Server objects
   SQLConnection mySQLConn = new SQLConnection(strSQLServerConn);
   SQLDataSetCommand mySQLDataSetCmd = new SQLDataSetCommand();
   mySQLDataSetCmd.InsertCommand = new SQLCommand(strSQLServerInsert,mySQLConn);
   // fill myDataSet with data from Access
   myAccessConn.Open();
   try {
      myAccessDataSetCmd.FillDataSet(myDataSet,"table");
   }
   finally {
      myAccessConn.Close();
   }

   // do ugly work to turn original rows into new rows

   // update SQL Server with data from the DataSet
   mySQLConn.Open();
   try {
      mySQLDataSetCmd.InsertCommand.Parameters.Add("CategoryName", typeof(String));
      mySQLDataSetCmd.InsertCommand.Parameters.Add("Description", typeof(String));
      mySQLDataSetCmd.InsertCommand.Parameters.Add("Picture", typeof(Byte[]));
      mySQLDataSetCmd.InsertCommand.Parameters[0].SourceColumn = "CategoryName";
      mySQLDataSetCmd.InsertCommand.Parameters[1].SourceColumn = "Description";
      mySQLDataSetCmd.InsertCommand.Parameters[2].SourceColumn = "Picture";
      mySQLDataSetCmd.Update(myDataSet,"table");
   }
   finally {
      mySQLConn.Close();
   }
}

See Also

ADOCommand Members | System.Data.ADO Namespace | ADODataSetCommand | ADOConnection


ADOCommand Members

Public:

Constructor

ADOCommand Constructor Overloaded. Initializes a new instance of the ADOCommand class.

Properties

ActiveConnection | Gets or sets the ADOConnection used by this instance of the ADOCommand.
CommandBehavior | Gets or sets the behavior the ADOCommand is to exhibit when executed.
CommandText | Gets or sets the SQL command text to run against the data source.
CommandTimeout | Gets or sets the time to wait while executing the command before terminating the attempt and generating an error.
CommandType (inherited from DBCommand) | Gets or sets how the CommandText property is to be interpreted.
NamedParameters | Gets or sets whether named parameters are being used.
Parameters | Gets the collection of ADOParameters.
Properties | Gets the collection of ADOProperties.
RowFetchCount | Gets or sets how many rows of data to fetch at a time.
UpdatedRowSource (inherited from DBCommand) | Gets or sets how command results are to be applied to the current DataRow, when used by the Update method of a DBDataSetCommand.

Methods

Cancel | [To be supplied.]
Clone | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Execute (inherited from DBCommand) | Overloaded. Executes the command against the data source.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Prepare | Creates a prepared (or compiled) version of the command on the data source.
ResetCommandTimeout | Resets the CommandTimeout property to the default value.
ResetParameters | Refreshes the collection of Parameters for the command.
ResetProperties | Resets all ADOCommand properties to their defaults.
ShouldPersist (inherited from DBCommand) | When overridden in a derived class, returns whether the settings of the properties should be persisted.
ShouldPersistCommandTimeout | Determines whether the CommandTimeout should be persisted.
ToString (inherited from Object) | Returns a String that represents the current Object.

Events

SchemaChanged (inherited from DBCommand) | Occurs when the DataSet schema has been changed to match the schema change of the data source.
SchemaChanging (inherited from DBCommand) | Occurs when the DataSet schema is to be changed to match the schema change of the data source.

Protected:

Methods

Close | [To be supplied.]
CreateNewActiveConnection | [To be supplied.]
CreateNewParameters | [To be supplied.]
CreateNewProperties | [To be supplied.]
CreateNewSchemaChangedEvent (inherited from DBCommand) | [To be supplied.]
CreateNewSchemaChangingEvent (inherited from DBCommand) | [To be supplied.]
Finalize | [To be supplied.]
ForceExpandCommandText | [To be supplied.]
GetActiveConnectionObject | [To be supplied.]
GetParametersObject | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnSchemaChanged (inherited from DBCommand) | Overloaded. [To be supplied.]
OnSchemaChanging (inherited from DBCommand) | Overloaded. [To be supplied.]
SetActiveConnectionObject | [To be supplied.]

Fields

cmdText (inherited from DBCommand) | The default string to be used by the CommandText when the DBCommand is initialized.
cmdType (inherited from DBCommand) | The default CommandType to be used by CommandType property when the DBCommand is initialized.

Event Hookup:

Methods

AddOnSchemaChanged (inherited from DBCommand) | [To be supplied.]
AddOnSchemaChanging (inherited from DBCommand) | [To be supplied.]
RemoveOnSchemaChanged (inherited from DBCommand) | [To be supplied.]
RemoveOnSchemaChanging (inherited from DBCommand) | [To be supplied.]

See Also

ADOCommand Class | System.Data.ADO Namespace


ADOCommand Constructor

Initializes a new instance of the ADOCommand class.

Overload List

Initializes a new instance of the ADOCommand class with no parameters.

[Visual Basic] Overloads Public Sub New()
[C#] public ADOCommand();
[C++] public: ADOCommand();
[JScript] public function ADOCommand();

Initializes a new instance of the ADOCommand class with the query command text.

[Visual Basic] Overloads Public Sub New(String)
[C#] public ADOCommand(String);
[C++] public: ADOCommand(String*);
[JScript] public function ADOCommand(String);

Initializes a new instance of the ADOCommand class with the query command text and a connection string.

[Visual Basic] Overloads Public Sub New(String, String)
[C#] public ADOCommand(String, String);
[C++] public: ADOCommand(String*, String*);
[JScript] public function ADOCommand(String, String);

Initializes a new instance of the ADOCommand class with the query command text and an ADOConnection.

[Visual Basic] Overloads Public Sub New(String, ADOConnection)
[C#] public ADOCommand(String, ADOConnection);
[C++] public: ADOCommand(String*, ADOConnection);
[JScript] public function ADOCommand(String, ADOConnection);

Initializes a new instance of the ADOCommand class with an ADOConnection, the query command text, a specific CommandType, a parameter array, and a UpdateRowSource value.

[Visual Basic] Overloads Public Sub New(ADOConnection, String, CommandType, Boolean, ADOParameter(), UpdateRowSource)
[C#] public ADOCommand(ADOConnection, String, CommandType, bool, ADOParameter[], UpdateRowSource);
[C++] public: ADOCommand(ADOConnection*, String, CommandType, bool, ADOParameter[], UpdateRowSource);
[JScript] public function ADOCommand(ADOConnection, String, CommandType, Boolean, ADOParameter[], UpdateRowSource);

Example

The following example creates an ADOCommand and sets some of its properties.

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace


ADOCommand Constructor ()

Initializes a new instance of the ADOCommand class with no parameters.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ADOCommand();
[C++]
public: ADOCommand();
[JScript]
public function ADOCommand();

Remarks

When an instance of ADOCommand is created, the following read/write properties are set to initial values.

Properties | Initial Value
CommandText | empty string ("")
CommandTimeout | 30
CommandType | CommandType.Text
ActiveConnection | null
RowFetchCount | 1
NamedParameters | false
CommandBehavior | 0

You can change the value for any of these properties through a separate call to the property.

Example

The following example creates an ADOCommand and sets some of its properties.

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace | ADOCommand Constructor Overload List


ADOCommand Constructor (String)

Initializes a new instance of the ADOCommand class with the query command text.

[Visual Basic]
Overloads Public Sub New( _
   ByVal cmdText As String _
)
[C#]
public ADOCommand(
   string cmdText
);
[C++]
public: ADOCommand(
   String* cmdText
);
[JScript]
public function ADOCommand(
   cmdText : String
);

Parameters

cmdText
The text of the query command.

Remarks

When an instance of ADOCommand is created, the following read/write properties are set to initial values.

Properties | Initial Value
CommandText | cmdText
CommandTimeout | 30
CommandType | CommandType.Text
ActiveConnection | null
RowFetchCount | 1
NamedParameters | false
CommandBehavior | 0

You can change the value for any of these properties through a separate call to the property.

Example

The following example creates an ADOCommand and sets some of its properties.

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace | ADOCommand Constructor Overload List


ADOCommand Constructor (String, String)

Initializes a new instance of the ADOCommand class with the query command text and a connection string.

[Visual Basic]
Overloads Public Sub New( _
   ByVal cmdText As String, _
   ByVal connectionString As String _
)
[C#]
public ADOCommand(
   string cmdText,
   string connectionString
);
[C++]
public: ADOCommand(
   String* cmdText,
   String* connectionString
);
[JScript]
public function ADOCommand(
   cmdText : String,
   connectionString : String
);

Parameters

cmdText
The text of the query command.
connectionString
The text of the connection string.

Remarks

When an instance of ADOCommand is created, the following read/write properties are set to initial values.

Properties | Initial Value
CommandText | cmdText
CommandTimeout | 30
CommandType | CommandType.Text
ActiveConnection | A new ADOConnection created using connectionString.
RowFetchCount | 1
NamedParameters | false
CommandBehavior | 0

You can change the value for any of these properties through a separate call to the property.

Example

The following example creates an ADOCommand and sets some of its properties.

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace | ADOCommand Constructor Overload List


ADOCommand Constructor (String, ADOConnection)

Initializes a new instance of the ADOCommand class with the query command text and an ADOConnection.

[Visual Basic]
Overloads Public Sub New( _
   ByVal cmdText As String, _
   ByVal connection As ADOConnection _
)
[C#]
public ADOCommand(
   string cmdText,
   ADOConnection connection
);
[C++]
public: ADOCommand(
   String* cmdText,
   ADOConnection* connection
);
[JScript]
public function ADOCommand(
   cmdText : String,
   connection : ADOConnection
);

Parameters

cmdText
The text of the query command.
connection
An ADOConnection that represents the connection.

Remarks

When an instance of ADOCommand is created, the following read/write properties are set to initial values.

Properties | Initial Value
CommandText | cmdText
CommandTimeout | 30
CommandType | CommandType.Text
ActiveConnection | A new ADOConnection that is connection.
RowFetchCount | 1
NamedParameters | false
CommandBehavior | 0

You can change the value for any of these properties through a separate call to the property.

Example

The following example creates an ADOCommand and sets some of its properties.

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace | ADOCommand Constructor Overload List


ADOCommand Constructor (ADOConnection, String, CommandType, Boolean, ADOParameter[], UpdateRowSource)

Initializes a new instance of the ADOCommand class with an ADOConnection, the query command text, a specific CommandType, a parameter array, and a UpdateRowSource value.

[Visual Basic]
Overloads Public Sub New( _
   ByVal activeConnection As ADOConnection, _
   ByVal cmdText As String, _
   ByVal cmdType As CommandType, _
   ByVal namedParameters As Boolean, _
   ByVal parameters() As ADOParameter, _
   ByVal updatedRowSource As UpdateRowSource _
)
[C#]
public ADOCommand(
   ADOConnection activeConnection,
   string cmdText,
   CommandType cmdType,
   bool namedParameters,
   ADOParameter[] parameters,
   UpdateRowSource updatedRowSource
);
[C++]
public: ADOCommand(
   ADOConnection* activeConnection,
   String* cmdText,
   CommandType cmdType,
   bool namedParameters,
   ADOParameter* parameters[],
   UpdateRowSource updatedRowSource
);
[JScript]
public function ADOCommand(
   activeConnection : ADOConnection,
   cmdText : String,
   cmdType : CommandType,
   namedParameters : Boolean,
   parameters : ADOParameter[],
   updatedRowSource : UpdateRowSource
);

Parameters

activeConnection
An ADOConnection that represents the connection.
cmdText
The text of the query command.
cmdType
A value that is one of the CommandType values.
namedParameters
true if named parameters are being used, otherwise false.
parameters
An array of ADOParameter objects.
updatedRowSource
A value that is one of the UpdateRowSource values.

Remarks

When an instance of ADOCommand is created, the following read/write properties are set to initial values.

Properties | Initial Value
CommandText | cmdText
CommandTimeout | 30
CommandType | cmdType
ActiveConnection | activeConnection
RowFetchCount | 1
NamedParameters | false
CommandBehavior | 0

You can change the value for any of these properties through a separate call to the property.

Example

The following example creates an ADOCommand and sets some of its properties.

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace | ADOCommand Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ADOCommand Properties

The properties of the ADOCommand class are listed below. For a complete list of ADOCommand class members, see the ADOCommand Members topic.

Public:

ActiveConnection | Gets or sets the ADOConnection used by this instance of the ADOCommand.
CommandBehavior | Gets or sets the behavior the ADOCommand is to exhibit when executed.
CommandText | Gets or sets the SQL command text to run against the data source.
CommandTimeout | Gets or sets the time to wait while executing the command before terminating the attempt and generating an error.
CommandType (inherited from DBCommand) | Gets or sets how the CommandText property is to be interpreted.
NamedParameters | Gets or sets whether named parameters are being used.
Parameters | Gets the collection of ADOParameters.
Properties | Gets the collection of ADOProperties.
RowFetchCount | Gets or sets how many rows of data to fetch at a time.
UpdatedRowSource (inherited from DBCommand) | Gets or sets how command results are to be applied to the current DataRow, when used by the Update method of a DBDataSetCommand.

See Also

ADOCommand Class | System.Data.ADO Namespace


ADOCommand.ActiveConnection

Gets or sets the ADOConnection used by this instance of the ADOCommand.

[Visual Basic]
Public Property ActiveConnection As ADOConnection
[C#]
public ADOConnection ActiveConnection {get; set;}
[C++]
public: __property ADOConnection* get_ActiveConnection();
public: __property void set_ActiveConnection(ADOConnection*);
[JScript]
public function get ActiveConnection() : ADOConnection;
public function set ActiveConnection(ADOConnection);

Property Value

The connection to the data source.

Remarks

This property is not cloned, but copied. If the current ActiveConnection is not equal to the new connection, then a OnSchemaChanging event is raised. The connection properties are reset every time a new connection is assigned.

Example

The following example creates an ADOCommand and sets some of its properties.

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace | CommandText | CommandTimeout | CommandType | RowFetchCount | CommandBehavior | NamedParameters


ADOCommand.CommandBehavior

Gets or sets the behavior the ADOCommand is to exhibit when executed.

[Visual Basic]
Overridable Public Property CommandBehavior As DBCommandBehavior
[C#]
public DBCommandBehavior CommandBehavior {override get; override
   set;}
[C++]
public: __property virtual DBCommandBehavior get_CommandBehavior();
public: __property virtual void set_CommandBehavior(DBCommandBehavior);
[JScript]
public function get CommandBehavior() : DBCommandBehavior;
public function set CommandBehavior(DBCommandBehavior);

Property Value

One of the DBCommandBehavior values. The default is 0.

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace | CommandText | CommandTimeout | CommandType | RowFetchCount | ActiveConnection | NamedParameters


ADOCommand.CommandText

Gets or sets the SQL command text to run against the data source.

[Visual Basic]
Overridable Public Property CommandText As String
[C#]
public string CommandText {override get; override set;}
[C++]
public: __property virtual String* get_CommandText();
public: __property virtual void set_CommandText(String*);
[JScript]
public function get CommandText() : String;
public function set CommandText(String);

Property Value

The SQL command text to execute. The default value is the empty string ("").

Remarks

If the assigned string is not the current string, a OnSchemaChanging event is raised and the new value set. then, a OnSchemaChanged event is raised.

Example

The following example creates an ADOCommand and sets some of its properties.

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace | ActiveConnection | CommandTimeout | CommandType | RowFetchCount | CommandBehavior | NamedParameters


ADOCommand.CommandTimeout

Gets or sets the time to wait while executing the command before terminating the attempt and generating an error.

[Visual Basic]
Public Property CommandTimeout As Integer
[C#]
public int CommandTimeout {get; set;}
[C++]
public: __property int get_CommandTimeout();
public: __property void set_CommandTimeout(int);
[JScript]
public function get CommandTimeout() : int;
public function set CommandTimeout(int);

Property Value

The time (in seconds) to wait for the command to execute. The default value is 30 seconds.

Example

The following example creates an ADOCommand and sets some of its properties.

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace | ActiveConnection | CommandText | CommandType | RowFetchCount | CommandBehavior | NamedParameters | DefaultCommandTimeout


ADOCommand.NamedParameters

Gets or sets whether named parameters are being used.

[Visual Basic]
Public Property NamedParameters As Boolean
[C#]
public bool NamedParameters {get; set;}
[C++]
public: __property bool get_NamedParameters();
public: __property void set_NamedParameters(bool);
[JScript]
public function get NamedParameters() : Boolean;
public function set NamedParameters(Boolean);

Property Value

true if named parameters are being used, otherwise false. The default value is false.

Remarks

If the value is false, then the Parameters are to be accessed by ordinal value, which is their position in the collection.

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace | ActiveConnection | CommandTimeout | CommandType | CommandText | RowFetchCount | CommandBehavior


ADOCommand.Parameters

Gets the collection of ADOParameters.

[Visual Basic]
Public ReadOnly Property Parameters As ADOParameters
[C#]
public ADOParameters Parameters {get;}
[C++]
public: __property ADOParameters* get_Parameters();
[JScript]
public function get Parameters() : ADOParameters;

Property Value

The ADO parameters for the command.

Example

The following example creates an ADOCommand and displays some of its read-only properties.

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace | ADOParameter


ADOCommand.Properties

Gets the collection of ADOProperties.

[Visual Basic]
Public ReadOnly Property Properties As ADOProperties
[C#]
public ADOProperties Properties {get;}
[C++]
public: __property ADOProperties* get_Properties();
[JScript]
public function get Properties() : ADOProperties;

Property Value

The ADO property settings for the command.

Remarks

Use this property only after the connection is open.

Example

The following example creates a command and displays some of its read-only properties.

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace | ADOProperty


ADOCommand.RowFetchCount

Gets or sets how many rows of data to fetch at a time.

[Visual Basic]
Public Property RowFetchCount As Integer
[C#]
public int RowFetchCount {get; set;}
[C++]
public: __property int get_RowFetchCount();
public: __property void set_RowFetchCount(int);
[JScript]
public function get RowFetchCount() : int;
public function set RowFetchCount(int);

Property Value

The number of data rows to be fetched. The default is 1.

Exceptions

Exception Type | Condition
InvalidRowFetchCount(System.Int32) | The value is set to a value less than 1.

Example

The following example creates an ADOCommand and sets some of its properties.

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace | CommandText | CommandTimeout | CommandType | ActiveConnection | CommandBehavior | UpdatedRowSource | NamedParameters


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ADOCommand Methods

The methods of the ADOCommand class are listed below. For a complete list of ADOCommand class members, see the ADOCommand Members topic.

Public:

Cancel | [To be supplied.]
Clone | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Execute (inherited from DBCommand) | Overloaded. Executes the command against the data source.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Prepare | Creates a prepared (or compiled) version of the command on the data source.
ResetCommandTimeout | Resets the CommandTimeout property to the default value.
ResetParameters | Refreshes the collection of Parameters for the command.
ResetProperties | Resets all ADOCommand properties to their defaults.
ShouldPersist (inherited from DBCommand) | When overridden in a derived class, returns whether the settings of the properties should be persisted.
ShouldPersistCommandTimeout | Determines whether the CommandTimeout should be persisted.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Close | [To be supplied.]
CreateNewActiveConnection | [To be supplied.]
CreateNewParameters | [To be supplied.]
CreateNewProperties | [To be supplied.]
CreateNewSchemaChangedEvent (inherited from DBCommand) | [To be supplied.]
CreateNewSchemaChangingEvent (inherited from DBCommand) | [To be supplied.]
Finalize | [To be supplied.]
ForceExpandCommandText | [To be supplied.]
GetActiveConnectionObject | [To be supplied.]
GetParametersObject | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnSchemaChanged (inherited from DBCommand) | Overloaded. [To be supplied.]
OnSchemaChanging (inherited from DBCommand) | Overloaded. [To be supplied.]
SetActiveConnectionObject | [To be supplied.]

Event Hookup:

AddOnSchemaChanged (inherited from DBCommand) | [To be supplied.]
AddOnSchemaChanging (inherited from DBCommand) | [To be supplied.]
RemoveOnSchemaChanged (inherited from DBCommand) | [To be supplied.]
RemoveOnSchemaChanging (inherited from DBCommand) | [To be supplied.]

See Also

ADOCommand Class | System.Data.ADO Namespace


ADOCommand.Cancel

[To be supplied.]

[Visual Basic]
Overridable Public Sub Cancel()
[C#]
public virtual void Cancel();
[C++]
public: virtual void Cancel();
[JScript]
public function Cancel();

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace


ADOCommand.Clone

[To be supplied.]

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
public: override Object* Clone();
[JScript]
public override function Clone() : Object;

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace


ADOCommand.Close

[To be supplied.]

[Visual Basic]
Protected Sub Close()
[C#]
protected void Close();
[C++]
protected: void Close();
[JScript]
protected function Close();

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace


ADOCommand.CreateNewActiveConnection

[To be supplied.]

[Visual Basic]
Overridable Protected Function CreateNewActiveConnection( _
   ByVal connectionString As String _
) As ADOConnection
[C#]
protected virtual ADOConnection CreateNewActiveConnection(
   string connectionString
);
[C++]
protected: virtual ADOConnection* CreateNewActiveConnection(
   String* connectionString
);
[JScript]
protected function CreateNewActiveConnection(
   connectionString : String
) : ADOConnection;

Parameters

connectionString
[To be supplied.]

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace


ADOCommand.CreateNewParameters

[To be supplied.]

[Visual Basic]
Overridable Protected Function CreateNewParameters() As _
   ADOParameters
[C#]
protected virtual ADOParameters CreateNewParameters();
[C++]
protected: virtual ADOParameters* CreateNewParameters();
[JScript]
protected function CreateNewParameters() : ADOParameters;

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace


ADOCommand.CreateNewProperties

[To be supplied.]

[Visual Basic]
Overridable Protected Function CreateNewProperties() As _
   ADOProperties
[C#]
protected virtual ADOProperties CreateNewProperties();
[C++]
protected: virtual ADOProperties* CreateNewProperties();
[JScript]
protected function CreateNewProperties() : ADOProperties;

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace


ADOCommand.Execute

Executes the CommandText against the ActiveConnection and builds an object capable of forward-only data reads.

Overload List

Executes the CommandText against the ActiveConnection and builds an ADODataReader.

[Visual Basic] Overloads Overridable Public Sub Execute(ADODataReader)
[C#] public virtual void Execute(ADODataReader);
[C++] public: virtual void Execute(ADODataReader*);
[JScript] public function Execute(ADODataReader);

Executes the CommandText against the ActiveConnection and builds an IDataReader.

[Visual Basic] Overloads Overrides Public Sub Execute(IDataReader)
[C#] public override void Execute(IDataReader);
[C++] public: override void Execute(IDataReader*);
[JScript] public override function Execute(IDataReader);

Example

The following example creates an ADOCommand, clones it, executes it, then cancels the execution.

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace


ADOCommand.Execute (ADODataReader)

Executes the CommandText against the ActiveConnection and builds an ADODataReader.

[Visual Basic]
Overloads Overridable Public Sub Execute( _
   ByRef dataReader As ADODataReader _
)
[C#]
public virtual void Execute(
   ref ADODataReader dataReader
);
[C++]
public: virtual void Execute(
   ADODataReader** dataReader
);
[JScript]
public function Execute(
   dataReader : ADODataReader
);

Parameters

dataReader
This will contain a valid ADODataReader on return from this method. If a valid ADODataReader cannot be granted, this will be set to null.

Remarks

The caller must call Open method of the ActiveConnection property.

Example

The following example creates an ADOCommand, clones it, executes it, then cancels the execution.

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace | ADOCommand.Execute Overload List


ADOCommand.Execute (IDataReader)

Executes the CommandText against the ActiveConnection and builds an IDataReader.

[Visual Basic]
Overloads Overrides Public Sub Execute( _
   ByRef dataReader As IDataReader _
)
[C#]
public override void Execute(
   ref IDataReader dataReader
);
[C++]
public: override void Execute(
   IDataReader** dataReader
);
[JScript]
public override function Execute(
   dataReader : IDataReader
);

Parameters

dataReader
This will contain a valid IDataReader on return from this method. If a valid IDataReader cannot be granted, this will be set to null.

Remarks

The caller must call Open method of the ActiveConnection property.

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace | ADOCommand.Execute Overload List


ADOCommand.Finalize

[To be supplied.]

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace


ADOCommand.ForceExpandCommandText

[To be supplied.]

[Visual Basic]
Overridable Protected Function ForceExpandCommandText() As String
[C#]
protected virtual string ForceExpandCommandText();
[C++]
protected: virtual String* ForceExpandCommandText();
[JScript]
protected function ForceExpandCommandText() : String;

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace


ADOCommand.GetActiveConnectionObject

[To be supplied.]

[Visual Basic]
Overrides Protected Function GetActiveConnectionObject() As _
   DBConnection
[C#]
protected override DBConnection GetActiveConnectionObject();
[C++]
protected: override DBConnection* GetActiveConnectionObject();
[JScript]
protected override function GetActiveConnectionObject() :
   DBConnection;

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace


ADOCommand.GetParametersObject

[To be supplied.]

[Visual Basic]
Overrides Protected Function GetParametersObject() As _
   IDataParameters
[C#]
protected override IDataParameters GetParametersObject();
[C++]
protected: override IDataParameters* GetParametersObject();
[JScript]
protected override function GetParametersObject() : IDataParameters;

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace


ADOCommand.OnSchemaChanging

[To be supplied.]

[Visual Basic]
Overrides Protected Sub OnSchemaChanging( _
   ByVal scevent As SchemaChangingEventArgs _
)
[C#]
protected override void OnSchemaChanging(
   SchemaChangingEventArgs scevent
);
[C++]
protected: override void OnSchemaChanging(
   SchemaChangingEventArgs* scevent
);
[JScript]
protected override function OnSchemaChanging(
   scevent : SchemaChangingEventArgs
);

Parameters

scevent
[To be supplied.]

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace


ADOCommand.Prepare

Creates a prepared (or compiled) version of the command on the data source.

[Visual Basic]
Public Sub Prepare()
[C#]
public void Prepare();
[C++]
public: void Prepare();
[JScript]
public function Prepare();

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace


ADOCommand.ResetCommandTimeout

Resets the CommandTimeout property to the default value.

[Visual Basic]
Public Sub ResetCommandTimeout()
[C#]
public void ResetCommandTimeout();
[C++]
public: void ResetCommandTimeout();
[JScript]
public function ResetCommandTimeout();

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace


ADOCommand.ResetParameters

Refreshes the collection of Parameters for the command.

[Visual Basic]
Overrides Public Sub ResetParameters()
[C#]
public override void ResetParameters();
[C++]
public: override void ResetParameters();
[JScript]
public override function ResetParameters();

Remarks

The caller must call Open method of the ActiveConnection property.

Example

The following example creates an ADOCommand, clones it, executes it, then cancels the execution.

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace


ADOCommand.ResetProperties

Resets all ADOCommand properties to their defaults.

[Visual Basic]
Overridable Public Sub ResetProperties()
[C#]
public virtual void ResetProperties();
[C++]
public: virtual void ResetProperties();
[JScript]
public function ResetProperties();

Remarks

This method will reset the collection, but not its values.

Example

The following example uses this method within a derived class.

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace


ADOCommand.SetActiveConnectionObject

[To be supplied.]

[Visual Basic]
Overrides Protected Sub SetActiveConnectionObject( _
   ByVal value As DBConnection _
)
[C#]
protected override void SetActiveConnectionObject(
   DBConnection value
);
[C++]
protected: override void SetActiveConnectionObject(
   DBConnection* value
);
[JScript]
protected override function SetActiveConnectionObject(
   value : DBConnection
);

Parameters

value
[To be supplied.]

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace


ADOCommand.ShouldPersistCommandTimeout

Determines whether the CommandTimeout should be persisted.

[Visual Basic]
Public Function ShouldPersistCommandTimeout() As Boolean
[C#]
public bool ShouldPersistCommandTimeout();
[C++]
public: bool ShouldPersistCommandTimeout();
[JScript]
public function ShouldPersistCommandTimeout() : Boolean;

Return Value

true if CommandTimeout is not set to its default, otherwise false.

See Also

ADOCommand Class | ADOCommand Members | System.Data.ADO Namespace


ADOCommandConverter Class

[To be supplied.]

Object
TypeConverter
ADOCommandConverter

[Visual Basic]
NotInheritable Public Class ADOCommandConverter
   Inherits TypeConverter
[C#]
public sealed class ADOCommandConverter : TypeConverter
[C++]
public __gc __sealed class ADOCommandConverter : public
   TypeConverter
[JScript]
public class ADOCommandConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.ADO

Assembly: System.Data.dll

See Also

ADOCommandConverter Members | System.Data.ADO Namespace


ADOCommandConverter Members

Public:

Constructor

ADOCommandConverter Constructor [To be supplied.]

Methods

CanConvertFrom (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the converter's native type.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text into an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given object to another type.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetProperties (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValues (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid (inherited from TypeConverter) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

ADOCommandConverter Class | System.Data.ADO Namespace


ADOCommandConverter Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ADOCommandConverter();
[C++]
public: ADOCommandConverter();
[JScript]
public function ADOCommandConverter();

See Also

ADOCommandConverter Class | ADOCommandConverter Members | System.Data.ADO Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ADOCommandConverter Methods

The methods of the ADOCommandConverter class are listed below. For a complete list of ADOCommandConverter class members, see the ADOCommandConverter Members topic.

Public:

CanConvertFrom (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the converter's native type.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text into an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given object to another type.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetProperties (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValues (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid (inherited from TypeConverter) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

ADOCommandConverter Class | System.Data.ADO Namespace


ADOCommandConverter.GetPersistInfo

[To be supplied.]

[Visual Basic]
Overrides Public Function GetPersistInfo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal obj As Object _
) As PersistInfo
[C#]
public override PersistInfo GetPersistInfo(
   ITypeDescriptorContext context,
   object obj
);
[C++]
public: override PersistInfo* GetPersistInfo(
   ITypeDescriptorContext* context,
   Object* obj
);
[JScript]
public override function GetPersistInfo(
   context : ITypeDescriptorContext,
   obj : Object
) : PersistInfo;

Parameters

context
[To be supplied.]
obj
[To be supplied.]

See Also

ADOCommandConverter Class | ADOCommandConverter Members | System.Data.ADO Namespace


ADOCommandConverter.GetProperties

Retrieves the set of properties for this type. By default, a type has does not return any properties. An easy implementation of this method can just call TypeDescriptor.GetProperties for the correct data type.

[Visual Basic]
Overrides Public Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal attributes() As MemberAttribute _
) As PropertyDescriptorCollection
[C#]
public override PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value,
   MemberAttribute[] attributes
);
[C++]
public: override PropertyDescriptorCollection* GetProperties(
   ITypeDescriptorContext* context,
   Object* value,
   MemberAttribute* attributes[]
);
[JScript]
public override function GetProperties(
   context : ITypeDescriptorContext,
   value : Object,
   attributes : MemberAttribute[]
) : PropertyDescriptorCollection;

Parameters

context
A type descriptor through which additional context may be provided.
value
The value of the object to get the properties for.
attributes
[To be supplied.]

Return Value

The set of properties that should be exposed for this data type. If no properties should be exposed, thsi may return null. The default implementation always returns null.

See Also

ADOCommandConverter Class | ADOCommandConverter Members | System.Data.ADO Namespace


ADOCommandConverter.GetPropertiesSupported

Determines if this object supports properties. By default, this is false.

[Visual Basic]
Overrides Public Function GetPropertiesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
[C#]
public override bool GetPropertiesSupported(
   ITypeDescriptorContext context
);
[C++]
public: override bool GetPropertiesSupported(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetPropertiesSupported(
   context : ITypeDescriptorContext
) : Boolean;

Parameters

context
A type descriptor through which additional context may be provided.

Return Value

Returns true if GetProperties should be called to find the properties of this object.

See Also

ADOCommandConverter Class | ADOCommandConverter Members | System.Data.ADO Namespace


ADOConnection Class

Represents an open connection to a data source.

Object
Component
DBConnection
ADOConnection

[Visual Basic]
Public Class ADOConnection
   Inherits DBConnection
[C#]
public class ADOConnection : DBConnection
[C++]
public __gc class ADOConnection : public DBConnection
[JScript]
public class ADOConnection extends DBConnection

Remarks

An ADOConnection object represents a unique session with a data source. In the case of a client/server database system, it may be equivalent to a network connection to the server. Depending on the functionality supported by the provider, some collections, methods, or properties of an ADOConnection object may not be available.

When an instance of ADOConnection is created, the read/write properties are set to initial values. For a list of these values, see the ADOConnection constructor.

Requirements

Namespace: System.Data.ADO

Assembly: System.Data.dll

Example [C#]

The following example uses the ADOCommand, along ADODataSetCommand and ADOConnection, to select records from an Access data source. The DataSet is then used to insert new records in a SQL Server data source. This example can be modified to migrate an Access database to a SQL Server database.

[C#]

private DataSet InitializeMyDataSet() {
   // creates the table and its columns for the DataSet
   DataSet newData = new DataSet();
   DataTable newTable = newData.Tables.Add("Catagories");

   // add Columns to table
   newTable.Columns.Add("CategoryID",typeof(Int32));
   newTable.Columns.Add("CategoryName", typeof(String));
   newTable.Columns.Add("Description", typeof(String));
   newTable.Columns.Add("Picture",typeof(Byte[]));
   return newData;
}

public void AccessToSQLServer() {
   // set Access connection and select strings
   const string strAccessConn = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=NWIND_RW.MDB";
   const string strAccessSelect = "SELECT * FROM Categories ORDER BY CategoryID";
   // set SQL Server connection and insert strings
   const string strSQLServerConn = "Data Source=VBsql7;Initial Catalog=Northwind;User ID=sa;Password=;";
   const string strSQLServerInsert = "INSERT INTO Categories(CategoryName, Description, Picture) Values(@CategoryName,@Description,@Picture)";
   // create my DataSet
   DataSet myDataSet = InitializeMyDataSet();
   // create my Access objects
   ADOConnection myAccessConn = new ADOConnection(strAccessConn);
   ADODataSetCommand myAccessDataSetCmd = new ADODataSetCommand();
   myAccessDataSetCmd.SelectCommand = new ADOCommand(strAccessSelect,myAccessConn);
   // create my SQL Server objects
   SQLConnection mySQLConn = new SQLConnection(strSQLServerConn);
   SQLDataSetCommand mySQLDataSetCmd = new SQLDataSetCommand();
   mySQLDataSetCmd.InsertCommand = new SQLCommand(strSQLServerInsert,mySQLConn);
   // fill myDataSet with data from Access
   myAccessConn.Open();
   try {
      myAccessDataSetCmd.FillDataSet(myDataSet,"table");
   }
   finally {
      myAccessConn.Close();
   }

   // do ugly work to turn original rows into new rows

   // update SQL Server with data from the DataSet
   mySQLConn.Open();
   try {
      mySQLDataSetCmd.InsertCommand.Parameters.Add("CategoryName", typeof(String));
      mySQLDataSetCmd.InsertCommand.Parameters.Add("Description", typeof(String));
      mySQLDataSetCmd.InsertCommand.Parameters.Add("Picture", typeof(Byte[]));
      mySQLDataSetCmd.InsertCommand.Parameters[0].SourceColumn = "CategoryName";
      mySQLDataSetCmd.InsertCommand.Parameters[1].SourceColumn = "Description";
      mySQLDataSetCmd.InsertCommand.Parameters[2].SourceColumn = "Picture";
      mySQLDataSetCmd.Update(myDataSet,"table");
   }
   finally {
      mySQLConn.Close();
   }
}

See Also

ADOConnection Members | System.Data.ADO Namespace | ADODataSetCommand | ADOCommand


ADOConnection Members

Public:

Constructor

ADOConnection Constructor Overloaded. Initializes a new instance of the ADOConnection class.

Properties

ConnectionString | Gets or sets the string used to open a data store.
ConnectionTimeout | Gets or sets the time to wait while establishing a connection before terminating the attempt and generating an error.
Database | Gets or sets the name of the current database or the database to be used once a connection is open.
DataSource | Gets or sets the name of the database to connect to.
IsolationLevel | Gets or sets the isolation level used for any transaction. Set only after the connection is open.
Password | Gets or sets the password to use when connecting.
Properties | Gets the initialization and authorization properties when the connection is closed. Gets the session and data source information when the connection is open.
Provider | Gets the name of the provider.
Site (inherited from Component) | Gets or sets the site of the Component.
State (inherited from DBConnection) | Gets the current state of the connection.
UserID | Gets or sets the user ID to use when connecting.

Methods

BeginTransaction | Begins a database transaction with the current IsolationLevel value.
Clone | Creates a clone of this insatce of ADOConnection.
Close | Overloaded. Closes the connection to the data source.
CommitTransaction | Commits the database transaction.
Dispose | Disposes of this ADOConnection object.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Open | Opens a database connection with the current property settings.
ResetConnectionTimeout | Resets the ConnectionTimeout property to its default.
ResetDatabase | Resets the Database property to its default.
ResetDataSource | Resets the DataSource property to its default.
ResetIsolationLevel | Resets the IsolationLevel property to its default.
ResetPassword | Resets the Password property to its default.
ResetProperties | Resets the connection properties collection from the provider.
ResetUserID | Resets the UserID property to its default.
RollbackTransaction | Rolls back a transaction from being applied to the database.
ShouldPersistConnectionTimeout | Determines whether the ConnectionTimeout should be persisted.
ShouldPersistDatabase | Determines whether the Database should be persisted.
ShouldPersistDataSource | Determines whether the DataSource should be persisted.
ShouldPersistIsolationLevel | Determines whether the IsolationLevel should be persisted.
ShouldPersistPassword | Determines whether the Password should be persisted.
ShouldPersistUserID | Determines whether the UserID should be persisted.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Events

InfoMessage | Occurs when an informational message is added.
StateChange (inherited from DBConnection) | Occurs whenever the state of the connection changes.

Protected:

Methods

Close | Overloaded. Closes the connection to the data source.
CreateNewProperties | [To be supplied.]
CreateNewStateChangeEvent (inherited from DBConnection) | [To be supplied.]
Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnInfoMessage | Raises the ADOInfoMessageEventArgs event.
OnStateChange (inherited from DBConnection) | Raises the StateChangeEventArgs event.
OpenDesignMode | [To be supplied.]
SetObjectState (inherited from DBConnection) | Sets the State to one of the DBObjectState values.

Fields

objectState (inherited from DBConnection) [To be supplied.]

Event Hookup:

Methods

AddOnInfoMessage | Use to add an information message event handler.
AddOnStateChange (inherited from DBConnection) | Use to add a connection state change event handler.
RemoveOnStateChange (inherited from DBConnection) | Use to remove a connection state change event handler.

See Also

ADOConnection Class | System.Data.ADO Namespace


ADOConnection Constructor

Initializes a new instance of the ADOConnection class.

Overload List

Initializes a new instance of the ADOConnection class with no parameters.

[Visual Basic] Overloads Public Sub New()
[C#] public ADOConnection();
[C++] public: ADOConnection();
[JScript] public function ADOConnection();

Initializes a new instance of the ADOConnection class with the specified connection string.

[Visual Basic] Overloads Public Sub New(String)
[C#] public ADOConnection(String);
[C++] public: ADOConnection(String*);
[JScript] public function ADOConnection(String);

Example

The following example creates a connection and fills a DataSet.

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace


ADOConnection Constructor ()

Initializes a new instance of the ADOConnection class with no parameters.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ADOConnection();
[C++]
public: ADOConnection();
[JScript]
public function ADOConnection();

Remarks

When an instance of ADOConnection is created, the following read/write properties are set to initial values.

Properties | Initial Value
ConnectionString | empty string ("")
ConnectionTimeout | 15
Database | empty string ("")
IsolationLevel | IsolationLevel.Unspecified
DataSource | empty string ("")
UserID | empty string ("")
Password | empty string ("")

You can change the value for any of these properties through a separate call to the property.

Example

The following example creates a connection and fills a DataSet.

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace | ADOConnection Constructor Overload List


ADOConnection Constructor (String)

Initializes a new instance of the ADOConnection class with the specified connection string.

[Visual Basic]
Overloads Public Sub New( _
   ByVal connectionString As String _
)
[C#]
public ADOConnection(
   string connectionString
);
[C++]
public: ADOConnection(
   String* connectionString
);
[JScript]
public function ADOConnection(
   connectionString : String
);

Parameters

connectionString
The connection used to open the data store.

Remarks

When an instance of ADOConnection is created, the following read/write properties are set to initial values.

Properties | Initial Value
ConnectionString | connectionString
ConnectionTimeout | 15
Database | empty string ("")
IsolationLevel | IsolationLevel.Unspecified
DataSource | empty string ("")
UserID | empty string ("")
Password | empty string ("")

You can change the value for any of these properties through a separate call to the property.

Example

The following example creates a connection and fills a DataSet.

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace | ADOConnection Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ADOConnection Properties

The properties of the ADOConnection class are listed below. For a complete list of ADOConnection class members, see the ADOConnection Members topic.

Public:

ConnectionString | Gets or sets the string used to open a data store.
ConnectionTimeout | Gets or sets the time to wait while establishing a connection before terminating the attempt and generating an error.
Database | Gets or sets the name of the current database or the database to be used once a connection is open.
DataSource | Gets or sets the name of the database to connect to.
IsolationLevel | Gets or sets the isolation level used for any transaction. Set only after the connection is open.
Password | Gets or sets the password to use when connecting.
Properties | Gets the initialization and authorization properties when the connection is closed. Gets the session and data source information when the connection is open.
Provider | Gets the name of the provider.
Site (inherited from Component) | Gets or sets the site of the Component.
State (inherited from DBConnection) | Gets the current state of the connection.
UserID | Gets or sets the user ID to use when connecting.

See Also

ADOConnection Class | System.Data.ADO Namespace


ADOConnection.ConnectionString

Gets or sets the string used to open a data store.

[Visual Basic]
Overridable Public Property ConnectionString As String
[C#]
public string ConnectionString {override get; override set;}
[C++]
public: __property virtual String* get_ConnectionString();
public: __property virtual void set_ConnectionString(String*);
[JScript]
public function get ConnectionString() : String;
public function set ConnectionString(String);

Property Value

The OLEDB provider connection string, when the connection is open. The user connection string, when the connection is closed. The default value is an empty string.

Remarks

The string can only be set when the connection state is closed.

Example

The following example shows how to create a connection and set many of its properties.

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace | ConnectionTimeout | Database | IsolationLevel | DataSource | UserID | Password


ADOConnection.ConnectionTimeout

Gets or sets the time to wait while establishing a connection before terminating the attempt and generating an error.

[Visual Basic]
Public Property ConnectionTimeout As Integer
[C#]
public int ConnectionTimeout {get; set;}
[C++]
public: __property int get_ConnectionTimeout();
public: __property void set_ConnectionTimeout(int);
[JScript]
public function get ConnectionTimeout() : int;
public function set ConnectionTimeout(int);

Property Value

The time (in seconds) to wait for a connection to open. The default value is 15 seconds.

Exceptions

Exception Type | Condition
InvalidConnectionTimeout | The value set is less than 0.
OpenConnectionPropertySet | The connection is Open. Close the connection.

Remarks

A value of 0 indicates no limit (i.e. the connection will wait indefinitely). The ConnectionTimeout property overwrites the cooresponding property within the connection string.

Note This property is read-only while the connection is open.

Example

The following example shows how to create a connection and set many of its properties.

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace | ConnectionString | Database | IsolationLevel | DataSource | UserID | Password


ADOConnection.Database

Gets or sets the name of the current database or the database to be used once a connection is open.

[Visual Basic]
Public Property Database As String
[C#]
public string Database {get; set;}
[C++]
public: __property String* get_Database();
public: __property void set_Database(String*);
[JScript]
public function get Database() : String;
public function set Database(String);

Property Value

The name of the current database or the name of the database to be used once a connection is open. The default value is an empty string.

Exceptions

Exception Type | Condition
OpenConnectionPropertySet | The connection is Open. Close the connection.

Remarks

If the Database property is set when the connection is open, it will set the provider's current catalog property. If this property is set when the connection is closed, it will set the provider's initial catalog property.

Note This is the only property other than IsolationLevel that can be set when the connection is open.

Example

The following example shows how to create a connection and set many of its properties.

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace | ConnectionTimeout | ConnectionString | IsolationLevel | DataSource | UserID | Password


ADOConnection.DataSource

Gets or sets the name of the database to connect to.

[Visual Basic]
Public Property DataSource As String
[C#]
public string DataSource {get; set;}
[C++]
public: __property String* get_DataSource();
public: __property void set_DataSource(String*);
[JScript]
public function get DataSource() : String;
public function set DataSource(String);

Property Value

The name of the database to connect to. The default value is an empty string.

Exceptions

Exception Type | Condition
OpenConnectionPropertySet | The connection is Open. Close the connection.

Remarks

The DataSource property overwrites the cooresponding property within the connection string.

Note This property is read-only while the connection is open.

Example

The following example shows how to create a connection and set many of its properties.

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace | ConnectionTimeout | Database | IsolationLevel | ConnectionString | UserID | Password


ADOConnection.IsolationLevel

Gets or sets the isolation level used for any transaction. Set only after the connection is open.

[Visual Basic]
Public Property IsolationLevel As IsolationLevel
[C#]
public IsolationLevel IsolationLevel {get; set;}
[C++]
public: __property IsolationLevel get_IsolationLevel();
public: __property void set_IsolationLevel(IsolationLevel);
[JScript]
public function get IsolationLevel() : IsolationLevel;
public function set IsolationLevel(IsolationLevel);

Property Value

One of the IsolationLevel values. The default value is Unspecified.

Exceptions

Exception Type | Condition
InvalidIsolationLevel | The value set is not one of the IsolationLevel values.

Remarks

If the connection is closed, the IsolationLevel property is set to Unspecified.

Note This is the only property other than Database that can be set when the connection is open.

Example

The following example shows how to create a connection and set many of its properties.

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace | ConnectionTimeout | Database | ConnectionString | DataSource | UserID | Password


ADOConnection.Password

Gets or sets the password to use when connecting.

[Visual Basic]
Public Property Password As String
[C#]
public string Password {get; set;}
[C++]
public: __property String* get_Password();
public: __property void set_Password(String*);
[JScript]
public function get Password() : String;
public function set Password(String);

Property Value

The password to use when connecting. The default value is an empty string.

Exceptions

Exception Type | Condition
OpenConnectionPropertySet | The connection is Open. Close the connection.

Remarks

The Password property overwrites the cooresponding property within the connection string.

Note This property is read-only while the connection is open.

Example

The following example shows how to create a connection and set many of its properties.

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace | ConnectionTimeout | Database | IsolationLevel | DataSource | UserID | ConnectionString


ADOConnection.Properties

Gets the initialization and authorization properties when the connection is closed. Gets the session and data source information when the connection is open.

[Visual Basic]
Public ReadOnly Property Properties As ADOProperties
[C#]
public ADOProperties Properties {get;}
[C++]
public: __property ADOProperties* get_Properties();
[JScript]
public function get Properties() : ADOProperties;

Property Value

The ADO property settings for the connection.

Remarks

The property settings in this collection override the cooresponding property settings in the connection string and will change any matching, strongly-typed properties in the connection object. However, the ConnectionString property is not modified by the changes made to the Properties collection. If the connection is closed, the available properties are enumerated before a physical connection to the database is established. This property does not support persistance.

Example

The following example shows how to create a connection and displays some of its read-only properties.

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace


ADOConnection.Provider

Gets the name of the provider.

[Visual Basic]
Public ReadOnly Property Provider As String
[C#]
public string Provider {get;}
[C++]
public: __property String* get_Provider();
[JScript]
public function get Provider() : String;

Property Value

The name of the provider.

Example

The following example shows how to create a connection and displays some of its read-only properties.

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace


ADOConnection.UserID

Gets or sets the user ID to use when connecting.

[Visual Basic]
Public Property UserID As String
[C#]
public string UserID {get; set;}
[C++]
public: __property String* get_UserID();
public: __property void set_UserID(String*);
[JScript]
public function get UserID() : String;
public function set UserID(String);

Property Value

The user ID to use when connecting. The default value is an empty string.

Exceptions

Exception Type | Condition
OpenConnectionPropertySet | The connection is Open. Close the connection.

Remarks

The UserID property overwrites the cooresponding property within the connection string.

Note This property is read-only while the connection is open.

Example

The following example shows how to create a connection and set many of its properties.

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace | ConnectionString | ConnectionTimeout | Database | IsolationLevel | DataSource | Password


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ADOConnection Methods

The methods of the ADOConnection class are listed below. For a complete list of ADOConnection class members, see the ADOConnection Members topic.

Public:

BeginTransaction | Begins a database transaction with the current IsolationLevel value.
Clone | Creates a clone of this insatce of ADOConnection.
Close | Overloaded. Closes the connection to the data source.
CommitTransaction | Commits the database transaction.
Dispose | Disposes of this ADOConnection object.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Open | Opens a database connection with the current property settings.
ResetConnectionTimeout | Resets the ConnectionTimeout property to its default.
ResetDatabase | Resets the Database property to its default.
ResetDataSource | Resets the DataSource property to its default.
ResetIsolationLevel | Resets the IsolationLevel property to its default.
ResetPassword | Resets the Password property to its default.
ResetProperties | Resets the connection properties collection from the provider.
ResetUserID | Resets the UserID property to its default.
RollbackTransaction | Rolls back a transaction from being applied to the database.
ShouldPersistConnectionTimeout | Determines whether the ConnectionTimeout should be persisted.
ShouldPersistDatabase | Determines whether the Database should be persisted.
ShouldPersistDataSource | Determines whether the DataSource should be persisted.
ShouldPersistIsolationLevel | Determines whether the IsolationLevel should be persisted.
ShouldPersistPassword | Determines whether the Password should be persisted.
ShouldPersistUserID | Determines whether the UserID should be persisted.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Protected:

Close | Overloaded. Closes the connection to the data source.
CreateNewProperties | [To be supplied.]
CreateNewStateChangeEvent (inherited from DBConnection) | [To be supplied.]
Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnInfoMessage | Raises the ADOInfoMessageEventArgs event.
OnStateChange (inherited from DBConnection) | Raises the StateChangeEventArgs event.
OpenDesignMode | [To be supplied.]
SetObjectState (inherited from DBConnection) | Sets the State to one of the DBObjectState values.

Event Hookup:

AddOnInfoMessage | Use to add an information message event handler.
AddOnStateChange (inherited from DBConnection) | Use to add a connection state change event handler.
RemoveOnStateChange (inherited from DBConnection) | Use to remove a connection state change event handler.

See Also

ADOConnection Class | System.Data.ADO Namespace


ADOConnection.AddOnInfoMessage

Use to add an information message event handler.

[Visual Basic]
Overridable Public Sub AddOnInfoMessage( _
   ByVal handler As ADOInfoMessageEventHandler _
)
[C#]
public virtual void AddOnInfoMessage(
   ADOInfoMessageEventHandler handler
);
[C++]
public: virtual void AddOnInfoMessage(
   ADOInfoMessageEventHandler* handler
);
[JScript]
public function AddOnInfoMessage(
   handler : ADOInfoMessageEventHandler
);

Parameters

handler
An ADOInfoMessageEventHandler delegate that represents the method that will handle the ADOInfoMessageEventArgs event.

Remarks

Adds an event handler for the ADOInfoMessageEventArgs event.

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace | RemoveOnInfoMessage


ADOConnection.BeginTransaction

Begins a database transaction with the current IsolationLevel value.

[Visual Basic]
Overrides Public Function BeginTransaction() As Integer
[C#]
public override int BeginTransaction();
[C++]
public: override int BeginTransaction();
[JScript]
public override function BeginTransaction() : int;

Example

The following example creates a connection, opens it, begins a transaction, commits the transaction, rollsback the transaction, then closes the connection.

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace | CommitTransaction | RollbackTransaction


ADOConnection.Clone

Creates a clone of this insatce of ADOConnection.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
public: override Object* Clone();
[JScript]
public override function Clone() : Object;

Return Value

An ADOConnection that is a clone of this instance.

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace


ADOConnection.Close

Closes the connection to the data source.

Overload List

Closes the connection to the data source. This is the preferred method.

[Visual Basic] Overloads Overrides Public Sub Close()
[C#] public override void Close();
[C++] public: override void Close();
[JScript] public override function Close();

Closes the connection to the data source with a boolean that indicates a forced closure.

[Visual Basic] Overloads Protected Sub Close(Boolean)
[C#] protected void Close(bool);
[C++] protected: void Close(bool);
[JScript] protected function Close(Boolean);

Example

The following example creates a connection, opens it, begins a transaction, commits the transaction, rollsback the transaction, then closes the connection.

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace


ADOConnection.Close ()

Closes the connection to the data source. This is the preferred method.

[Visual Basic]
Overloads Overrides Public Sub Close()
[C#]
public override void Close();
[C++]
public: override void Close();
[JScript]
public override function Close();

Exceptions

Exception Type | Condition
ConnectionAlreadyClosed | The connection was already in a closed state.
ConnectionTooBusyToClose | A transaction is still being processed.

Remarks

This method tries to close the connection nicely by waiting for all transactions to clear first.

Example

The following example creates a connection, opens it, begins a transaction, commits the transaction, rollsback the transaction, then closes the connection.

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace | ADOConnection.Close Overload List | Open


ADOConnection.Close (Boolean)

Closes the connection to the data source with a boolean that indicates a forced closure.

[Visual Basic]
Overloads Protected Sub Close( _
   ByVal hardClose As Boolean _
)
[C#]
protected void Close(
   bool hardClose
);
[C++]
protected: void Close(
   bool hardClose
);
[JScript]
protected function Close(
   hardClose : Boolean
);

Parameters

hardClose
true if closure is forced, otherwise false.

Exceptions

Exception Type | Condition
ConnectionAlreadyClosed | The connection was already in a closed state.
ConnectionTooBusyToClose | A transaction is still being processed.

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace | ADOConnection.Close Overload List


ADOConnection.CommitTransaction

Commits the database transaction.

[Visual Basic]
Overrides Public Sub CommitTransaction()
[C#]
public override void CommitTransaction();
[C++]
public: override void CommitTransaction();
[JScript]
public override function CommitTransaction();

Remarks

Notes to Inheritors: When overriding CommitTransaction in a derived class, be sure to call the base class's CommitTransaction method.

Example

The following example creates a connection, opens it, begins a transaction, commits the transaction, rollsback the transaction, then closes the connection.

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace | BeginTransaction | RollbackTransaction


ADOConnection.CreateNewProperties

[To be supplied.]

[Visual Basic]
Overridable Protected Function CreateNewProperties() As _
   ADOProperties
[C#]
protected virtual ADOProperties CreateNewProperties();
[C++]
protected: virtual ADOProperties* CreateNewProperties();
[JScript]
protected function CreateNewProperties() : ADOProperties;

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace


ADOConnection.Dispose

Disposes of this ADOConnection object.

[Visual Basic]
Overrides Public Sub Dispose()
[C#]
public override void Dispose();
[C++]
public: override void Dispose();
[JScript]
public override function Dispose();

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace


ADOConnection.Finalize

[To be supplied.]

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace


ADOConnection.OnInfoMessage

Raises the ADOInfoMessageEventArgs event.

[Visual Basic]
Overridable Protected Sub OnInfoMessage( _
   ByVal imevent As ADOInfoMessageEventArgs _
)
[C#]
protected virtual void OnInfoMessage(
   ADOInfoMessageEventArgs imevent
);
[C++]
protected: virtual void OnInfoMessage(
   ADOInfoMessageEventArgs* imevent
);
[JScript]
protected function OnInfoMessage(
   imevent : ADOInfoMessageEventArgs
);

Parameters

imevent
An ADOInfoMessageEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see <Delegates/EventModelTopic>.

Notes to Inheritors: When overriding OnInfoMessage in a derived class, be sure to call the base class's OnInfoMessage method.

Example

The following example uses this method within a derived class.

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace | OnStateChange


ADOConnection.Open

Opens a database connection with the current property settings.

[Visual Basic]
Overrides Public Sub Open()
[C#]
public override void Open();
[C++]
public: override void Open();
[JScript]
public override function Open();

Exceptions

Exception Type | Condition
ConnectionAlreadyOpen | The connection is already open.

Remarks

Notes to Inheritors: When overriding Open in a derived class, be sure to call the base class's Open method.

Example

The following example creates a connection, opens it, begins a transaction, commits the transaction, rollsback the transaction, then closes the connection.

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace | Close


ADOConnection.OpenDesignMode

[To be supplied.]

[Visual Basic]
Overrides Protected Sub OpenDesignMode()
[C#]
protected override void OpenDesignMode();
[C++]
protected: override void OpenDesignMode();
[JScript]
protected override function OpenDesignMode();

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace


ADOConnection.ResetConnectionTimeout

Resets the ConnectionTimeout property to its default.

[Visual Basic]
Public Sub ResetConnectionTimeout()
[C#]
public void ResetConnectionTimeout();
[C++]
public: void ResetConnectionTimeout();
[JScript]
public function ResetConnectionTimeout();

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace | ResetDatabase | ResetDataSource | ResetIsolationLevel | ResetPassword | ResetUserID


ADOConnection.ResetDatabase

Resets the Database property to its default.

[Visual Basic]
Public Sub ResetDatabase()
[C#]
public void ResetDatabase();
[C++]
public: void ResetDatabase();
[JScript]
public function ResetDatabase();

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace | ResetConnectionTimeout | ResetDataSource | ResetIsolationLevel | ResetPassword | ResetUserID


ADOConnection.ResetDataSource

Resets the DataSource property to its default.

[Visual Basic]
Public Sub ResetDataSource()
[C#]
public void ResetDataSource();
[C++]
public: void ResetDataSource();
[JScript]
public function ResetDataSource();

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace | ResetDatabase | ResetConnectionTimeout | ResetIsolationLevel | ResetPassword | ResetUserID


ADOConnection.ResetIsolationLevel

Resets the IsolationLevel property to its default.

[Visual Basic]
Public Sub ResetIsolationLevel()
[C#]
public void ResetIsolationLevel();
[C++]
public: void ResetIsolationLevel();
[JScript]
public function ResetIsolationLevel();

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace | ResetDatabase | ResetDataSource | ResetConnectionTimeout | ResetPassword | ResetUserID


ADOConnection.ResetPassword

Resets the Password property to its default.

[Visual Basic]
Public Sub ResetPassword()
[C#]
public void ResetPassword();
[C++]
public: void ResetPassword();
[JScript]
public function ResetPassword();

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace | ResetDatabase | ResetDataSource | ResetIsolationLevel | ResetConnectionTimeout | ResetUserID


ADOConnection.ResetProperties

Resets the connection properties collection from the provider.

[Visual Basic]
Overridable Public Sub ResetProperties()
[C#]
public virtual void ResetProperties();
[C++]
public: virtual void ResetProperties();
[JScript]
public function ResetProperties();

Remarks

Notes to Inheritors: When overriding ResetProperties in a derived class, be sure to call the base class's ResetProperties method.

Example

The following example creates a connection, set some of its properties, clones it, then resets the properties of the original instance.

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace | Properties


ADOConnection.ResetUserID

Resets the UserID property to its default.

[Visual Basic]
Public Sub ResetUserID()
[C#]
public void ResetUserID();
[C++]
public: void ResetUserID();
[JScript]
public function ResetUserID();

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace | ResetDatabase | ResetDataSource | ResetIsolationLevel | ResetPassword | ResetConnectionTimeout


ADOConnection.RollbackTransaction

Rolls back a transaction from being applied to the database.

[Visual Basic]
Overrides Public Sub RollbackTransaction()
[C#]
public override void RollbackTransaction();
[C++]
public: override void RollbackTransaction();
[JScript]
public override function RollbackTransaction();

Remarks

Notes to Inheritors: When overriding RollbackTransaction in a derived class, be sure to call the base class's RollbackTransaction method.

Example

The following example creates a connection, opens it, begins a transaction, commits the transaction, rollsback the transaction, then closes the connection.

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace | BeginTransaction | CommitTransaction


ADOConnection.ShouldPersistConnectionTimeout

Determines whether the ConnectionTimeout should be persisted.

[Visual Basic]
Public Function ShouldPersistConnectionTimeout() As Boolean
[C#]
public bool ShouldPersistConnectionTimeout();
[C++]
public: bool ShouldPersistConnectionTimeout();
[JScript]
public function ShouldPersistConnectionTimeout() : Boolean;

Return Value

true if ConnectionTimeout is not set to its default, otherwise false.

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace | ShouldPersistDatabase | ShouldPersistDataSource | ShouldPersistIsolationLevel | ShouldPersistPassword | ShouldPersistUserID


ADOConnection.ShouldPersistDatabase

Determines whether the Database should be persisted.

[Visual Basic]
Public Function ShouldPersistDatabase() As Boolean
[C#]
public bool ShouldPersistDatabase();
[C++]
public: bool ShouldPersistDatabase();
[JScript]
public function ShouldPersistDatabase() : Boolean;

Return Value

true if Database is not set to its default, otherwise false.

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace | ShouldPersistConnectionTimeout | ShouldPersistDataSource | ShouldPersistIsolationLevel | ShouldPersistPassword | ShouldPersistUserID


ADOConnection.ShouldPersistDataSource

Determines whether the DataSource should be persisted.

[Visual Basic]
Public Function ShouldPersistDataSource() As Boolean
[C#]
public bool ShouldPersistDataSource();
[C++]
public: bool ShouldPersistDataSource();
[JScript]
public function ShouldPersistDataSource() : Boolean;

Return Value

true if DataSource is not set to its default, otherwise false.

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace | ShouldPersistDatabase | ShouldPersistConnectionTimeout | ShouldPersistIsolationLevel | ShouldPersistPassword | ShouldPersistUserID


ADOConnection.ShouldPersistIsolationLevel

Determines whether the IsolationLevel should be persisted.

[Visual Basic]
Public Function ShouldPersistIsolationLevel() As Boolean
[C#]
public bool ShouldPersistIsolationLevel();
[C++]
public: bool ShouldPersistIsolationLevel();
[JScript]
public function ShouldPersistIsolationLevel() : Boolean;

Return Value

true if IsolationLevel is not set to its default, otherwise false.

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace | ShouldPersistDatabase | ShouldPersistDataSource | ShouldPersistConnectionTimeout | ShouldPersistPassword | ShouldPersistUserID


ADOConnection.ShouldPersistPassword

Determines whether the Password should be persisted.

[Visual Basic]
Public Function ShouldPersistPassword() As Boolean
[C#]
public bool ShouldPersistPassword();
[C++]
public: bool ShouldPersistPassword();
[JScript]
public function ShouldPersistPassword() : Boolean;

Return Value

true if Password is not set to its default, otherwise false.

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace | ShouldPersistDatabase | ShouldPersistDataSource | ShouldPersistIsolationLevel | ShouldPersistConnectionTimeout | ShouldPersistUserID


ADOConnection.ShouldPersistUserID

Determines whether the UserID should be persisted.

[Visual Basic]
Public Function ShouldPersistUserID() As Boolean
[C#]
public bool ShouldPersistUserID();
[C++]
public: bool ShouldPersistUserID();
[JScript]
public function ShouldPersistUserID() : Boolean;

Return Value

true if UserID is not set to its default, otherwise false.

See Also

ADOConnection Class | ADOConnection Members | System.Data.ADO Namespace | ShouldPersistDatabase | ShouldPersistDataSource | ShouldPersistIsolationLevel | ShouldPersistPassword | ShouldPersistConnectionTimeout


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ADOConnection Events

The events of the ADOConnection class are listed below. For a complete list of ADOConnection class members, see the ADOConnection Members topic.

Public:

InfoMessage | Occurs when an informational message is added.
StateChange (inherited from DBConnection) | Occurs whenever the state of the connection changes.

See Also

ADOConnection Class | System.Data.ADO Namespace


ADOConnection InfoMessage Event

Occurs when an informational message is added.

The following declaration shows the syntax for a method that handles the InfoMessage event.

[Visual Basic]
Private Sub ADOConnectionName_InfoMessage( _
   ByVal sender As Object, _
   ByVal e As ADOInfoMessageEventArgs _
)
[C#]
private void ADOConnectionName_InfoMessage(
   object sender,
   ADOInfoMessageEventArgs e
);
[C++]
private: void ADOConnectionName_InfoMessage(
   Object* sender,
   ADOInfoMessageEventArgs* e
);
[JScript]
private ADOConnectionName_InfoMessage(
   sender : Object,
   e : ADOInfoMessageEventArgs
);

Parameters

sender
The source of the event.
e
An ADOInfoMessageEventArgs that contains the event data. The following ADOInfoMessageEventArgs properties provide information specific to this event.
Property Description
ErrorCode
[To be supplied.]
Errors
[To be supplied.]
FullMessage
[To be supplied.]
Message
[To be supplied.]
Source
[To be supplied.]

See Also

ADOConnection Class | ADOConnection MembersTopic | System.Data.ADO Namespace


ADODataReader Class

[To be supplied.]

Object
DBDataReader
ADODataReader

[Visual Basic]
NotInheritable Public Class ADODataReader
   Inherits DBDataReader
   Implements IDBDataReader, IDataReader, IDataRecord
[C#]
public sealed class ADODataReader : DBDataReader, IDBDataReader,
   IDataReader, IDataRecord
[C++]
public __gc __sealed class ADODataReader : public DBDataReader,
   IDBDataReader, IDataReader, IDataRecord
[JScript]
public class ADODataReader extends DBDataReader, IDBDataReader,
   IDataReader, IDataRecord

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.ADO

Assembly: System.Data.dll

See Also

ADODataReader Members | System.Data.ADO Namespace


ADODataReader Members

Public:

Properties

DataTypeName | [To be supplied.]
DataTypeNamespace | [To be supplied.]
Depth (inherited from DBDataReader) | [To be supplied.]
Empty (inherited from DBDataReader) | [To be supplied.]
EOF | [To be supplied.]
FieldCount | [To be supplied.]
Filter | [To be supplied.]
Format (inherited from DBDataReader) | [To be supplied.]
HasValue | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the ADODataReader class.
Name | [To be supplied.]
Namespace (inherited from DBDataReader) | [To be supplied.]
NameTable (inherited from DBDataReader) | [To be supplied.]
NodeType (inherited from DBDataReader) | [To be supplied.]
Prefix (inherited from DBDataReader) | [To be supplied.]
ReadState (inherited from DBDataReader) | [To be supplied.]
RecordsAffected | [To be supplied.]
SchemaTable | [To be supplied.]

Methods

Close | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBoolean | [To be supplied.]
GetByte | [To be supplied.]
GetBytes | [To be supplied.]
GetChar | [To be supplied.]
GetChars | [To be supplied.]
GetCurrency | [To be supplied.]
GetData | [To be supplied.]
GetDataTypeName | [To be supplied.]
GetDataTypeNamespace | [To be supplied.]
GetDateTime | [To be supplied.]
GetDecimal | [To be supplied.]
GetDouble | [To be supplied.]
GetFieldType | [To be supplied.]
GetFloat | [To be supplied.]
GetGuid | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInt16 | [To be supplied.]
GetInt32 | [To be supplied.]
GetInt64 | [To be supplied.]
GetName | [To be supplied.]
GetNamespace | [To be supplied.]
GetOrdinal | Overloaded. [To be supplied.]
GetPrefix | [To be supplied.]
GetRaw | [To be supplied.]
GetSByte | [To be supplied.]
GetStream | [To be supplied.]
GetString | [To be supplied.]
GetTimeSpan | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetUInt16 | [To be supplied.]
GetUInt32 | [To be supplied.]
GetUInt64 | [To be supplied.]
GetValue | Overloaded. [To be supplied.]
GetValues | [To be supplied.]
IsNull | [To be supplied.]
Read | [To be supplied.]
SetRowBuffer | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Events

DataSchemaChanged (inherited from DBDataReader) [To be supplied.]

Protected:

Methods

CreateNewSchemaTable (inherited from DBDataReader) | [To be supplied.]
Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnDataSchemaChangedEvent (inherited from DBDataReader) | [To be supplied.]

Fields

dataValues (inherited from DBDataReader) | [To be supplied.]
dbSchemaTable (inherited from DBDataReader) | [To be supplied.]
inDataSchemaChanged (inherited from DBDataReader) | [To be supplied.]
indexMap (inherited from DBDataReader) | [To be supplied.]
pendingEvent (inherited from DBDataReader) | [To be supplied.]
readingState (inherited from DBDataReader) | [To be supplied.]

Event Hookup:

Methods

AddOnDataSchemaChanged (inherited from DBDataReader) | [To be supplied.]
RemoveOnDataSchemaChanged (inherited from DBDataReader) | [To be supplied.]

See Also

ADODataReader Class | System.Data.ADO Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ADODataReader Properties

The properties of the ADODataReader class are listed below. For a complete list of ADODataReader class members, see the ADODataReader Members topic.

Public:

DataTypeName | [To be supplied.]
DataTypeNamespace | [To be supplied.]
Depth (inherited from DBDataReader) | [To be supplied.]
Empty (inherited from DBDataReader) | [To be supplied.]
EOF | [To be supplied.]
FieldCount | [To be supplied.]
Filter | [To be supplied.]
Format (inherited from DBDataReader) | [To be supplied.]
HasValue | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the ADODataReader class.
Name | [To be supplied.]
Namespace (inherited from DBDataReader) | [To be supplied.]
NameTable (inherited from DBDataReader) | [To be supplied.]
NodeType (inherited from DBDataReader) | [To be supplied.]
Prefix (inherited from DBDataReader) | [To be supplied.]
ReadState (inherited from DBDataReader) | [To be supplied.]
RecordsAffected | [To be supplied.]
SchemaTable | [To be supplied.]

See Also

ADODataReader Class | System.Data.ADO Namespace


ADODataReader.DataTypeName

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DataTypeName As String
[C#]
public string DataTypeName {virtual get;}
[C++]
public: __property virtual String* get_DataTypeName();
[JScript]
public function get DataTypeName() : String;

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.DataTypeNamespace

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DataTypeNamespace As String
[C#]
public string DataTypeNamespace {virtual get;}
[C++]
public: __property virtual String* get_DataTypeNamespace();
[JScript]
public function get DataTypeNamespace() : String;

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.EOF

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property EOF As Boolean
[C#]
public bool EOF {override get;}
[C++]
public: __property virtual bool get_EOF();
[JScript]
public function get EOF() : Boolean;

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.FieldCount

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property FieldCount As Integer
[C#]
public int FieldCount {virtual get;}
[C++]
public: __property virtual int get_FieldCount();
[JScript]
public function get FieldCount() : int;

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.Filter

[To be supplied.]

[Visual Basic]
Overridable Public Property Filter As String
[C#]
public string Filter {virtual get; virtual set;}
[C++]
public: __property virtual String* get_Filter();
public: __property virtual void set_Filter(String*);
[JScript]
public function get Filter() : String;
public function set Filter(String);

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.HasValue

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property HasValue As Boolean
[C#]
public bool HasValue {virtual get;}
[C++]
public: __property virtual bool get_HasValue();
[JScript]
public function get HasValue() : Boolean;

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the ADODataReader class.

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(String, String) As Object
[C#] public object this[String, String] {virtual get;}
[C++] public: __property virtual Object* get_Item(String*, String*);
[JScript] ADODataReader.Item (String, String)

[To be supplied.]

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(Integer) As Object
[C#] public object this[int] {virtual get;}
[C++] public: __property virtual Object* get_Item(int);
[JScript] ADODataReader.Item (int)

[To be supplied.]

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(String) As Object
[C#] public object this[String] {virtual get;}
[C++] public: __property virtual Object* get_Item(String*);
[JScript] ADODataReader.Item (String)

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.Item (String, String)

[To be supplied.]

[C#] In C#, this member is the indexer for the ADODataReader class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal name As String, _
   ByVal namespaceURI As String _
) As Object
[C#]
public object this[
   string name,
   string namespaceURI
] {virtual get;}
[C++]
public: __property virtual Object* get_Item(
   String* name,
   String* namespaceURI
);
[JScript]
returnValue = ADODataReaderObject.Item(name, namespaceURI);
-or-
returnValue = ADODataReaderObject(name, namespaceURI);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
[To be supplied.]
namespaceURI
[To be supplied.]

Parameters [Visual Basic, C#, C++]

name
[To be supplied.]
namespaceURI
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace | ADODataReader.Item Overload List


ADODataReader.Item (Int32)

[To be supplied.]

[C#] In C#, this member is the indexer for the ADODataReader class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal index As Integer _
) As Object
[C#]
public object this[
   int index
] {virtual get;}
[C++]
public: __property virtual Object* get_Item(
   int index
);
[JScript]
returnValue = ADODataReaderObject.Item(index);
-or-
returnValue = ADODataReaderObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
[To be supplied.]

Parameters [Visual Basic, C#, C++]

index
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace | ADODataReader.Item Overload List


ADODataReader.Item (String)

[To be supplied.]

[C#] In C#, this member is the indexer for the ADODataReader class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal name As String _
) As Object
[C#]
public object this[
   string name
] {virtual get;}
[C++]
public: __property virtual Object* get_Item(
   String* name
);
[JScript]
returnValue = ADODataReaderObject.Item(name);
-or-
returnValue = ADODataReaderObject(name);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
[To be supplied.]

Parameters [Visual Basic, C#, C++]

name
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace | ADODataReader.Item Overload List


ADODataReader.Name

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {virtual get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.RecordsAffected

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property RecordsAffected As Integer
[C#]
public int RecordsAffected {virtual get;}
[C++]
public: __property virtual int get_RecordsAffected();
[JScript]
public function get RecordsAffected() : int;

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.SchemaTable

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property SchemaTable As DataTable
[C#]
public DataTable SchemaTable {virtual get;}
[C++]
public: __property virtual DataTable* get_SchemaTable();
[JScript]
public function get SchemaTable() : DataTable;

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ADODataReader Methods

The methods of the ADODataReader class are listed below. For a complete list of ADODataReader class members, see the ADODataReader Members topic.

Public:

Close | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBoolean | [To be supplied.]
GetByte | [To be supplied.]
GetBytes | [To be supplied.]
GetChar | [To be supplied.]
GetChars | [To be supplied.]
GetCurrency | [To be supplied.]
GetData | [To be supplied.]
GetDataTypeName | [To be supplied.]
GetDataTypeNamespace | [To be supplied.]
GetDateTime | [To be supplied.]
GetDecimal | [To be supplied.]
GetDouble | [To be supplied.]
GetFieldType | [To be supplied.]
GetFloat | [To be supplied.]
GetGuid | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInt16 | [To be supplied.]
GetInt32 | [To be supplied.]
GetInt64 | [To be supplied.]
GetName | [To be supplied.]
GetNamespace | [To be supplied.]
GetOrdinal | Overloaded. [To be supplied.]
GetPrefix | [To be supplied.]
GetRaw | [To be supplied.]
GetSByte | [To be supplied.]
GetStream | [To be supplied.]
GetString | [To be supplied.]
GetTimeSpan | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetUInt16 | [To be supplied.]
GetUInt32 | [To be supplied.]
GetUInt64 | [To be supplied.]
GetValue | Overloaded. [To be supplied.]
GetValues | [To be supplied.]
IsNull | [To be supplied.]
Read | [To be supplied.]
SetRowBuffer | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

CreateNewSchemaTable (inherited from DBDataReader) | [To be supplied.]
Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnDataSchemaChangedEvent (inherited from DBDataReader) | [To be supplied.]

Event Hookup:

AddOnDataSchemaChanged (inherited from DBDataReader) | [To be supplied.]
RemoveOnDataSchemaChanged (inherited from DBDataReader) | [To be supplied.]

See Also

ADODataReader Class | System.Data.ADO Namespace


ADODataReader.Close

[To be supplied.]

[Visual Basic]
Overridable Public Sub Close()
[C#]
public virtual void Close();
[C++]
public: virtual void Close();
[JScript]
public function Close();

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.Finalize

[To be supplied.]

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetBoolean

[To be supplied.]

[Visual Basic]
Overridable Public Function GetBoolean( _
   ByVal ordinal As Integer _
) As Boolean
[C#]
public virtual bool GetBoolean(
   int ordinal
);
[C++]
public: virtual bool GetBoolean(
   int ordinal
);
[JScript]
public function GetBoolean(
   ordinal : int
) : Boolean;

Parameters

ordinal
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetByte

[To be supplied.]

[Visual Basic]
Overridable Public Function GetByte( _
   ByVal ordinal As Integer _
) As Byte
[C#]
public virtual byte GetByte(
   int ordinal
);
[C++]
public: virtual unsigned char GetByte(
   int ordinal
);
[JScript]
public function GetByte(
   ordinal : int
) : Byte;

Parameters

ordinal
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetBytes

[To be supplied.]

[Visual Basic]
Overridable Public Function GetBytes( _
   ByVal ordinal As Integer, _
   ByVal buffer() As Byte, _
   ByVal length As Integer, _
   ByVal bufferIndex As Integer, _
   ByVal dataIndex As Integer _
) As Integer
[C#]
public virtual int GetBytes(
   int ordinal,
   byte[] buffer,
   int length,
   int bufferIndex,
   int dataIndex
);
[C++]
public: virtual int GetBytes(
   int ordinal,
   unsigned char* buffer[],
   int length,
   int bufferIndex,
   int dataIndex
);
[JScript]
public function GetBytes(
   ordinal : int,
   buffer : Byte[],
   length : int,
   bufferIndex : int,
   dataIndex : int
) : int;

Parameters

ordinal
[To be supplied.]
buffer
[To be supplied.]
length
[To be supplied.]
bufferIndex
[To be supplied.]
dataIndex
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetChar

[To be supplied.]

[Visual Basic]
Overridable Public Function GetChar( _
   ByVal ordinal As Integer _
) As Char
[C#]
public virtual char GetChar(
   int ordinal
);
[C++]
public: virtual __wchar_t GetChar(
   int ordinal
);
[JScript]
public function GetChar(
   ordinal : int
) : Char;

Parameters

ordinal
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetChars

[To be supplied.]

[Visual Basic]
Overridable Public Function GetChars( _
   ByVal ordinal As Integer, _
   ByVal buffer() As Char, _
   ByVal length As Integer, _
   ByVal bufferIndex As Integer, _
   ByVal dataIndex As Integer _
) As Integer
[C#]
public virtual int GetChars(
   int ordinal,
   char[] buffer,
   int length,
   int bufferIndex,
   int dataIndex
);
[C++]
public: virtual int GetChars(
   int ordinal,
   __wchar_t* buffer[],
   int length,
   int bufferIndex,
   int dataIndex
);
[JScript]
public function GetChars(
   ordinal : int,
   buffer : Char[],
   length : int,
   bufferIndex : int,
   dataIndex : int
) : int;

Parameters

ordinal
[To be supplied.]
buffer
[To be supplied.]
length
[To be supplied.]
bufferIndex
[To be supplied.]
dataIndex
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetCurrency

[To be supplied.]

[Visual Basic]
Overridable Public Function GetCurrency( _
   ByVal ordinal As Integer _
) As Currency
[C#]
public virtual Currency GetCurrency(
   int ordinal
);
[C++]
public: virtual Currency GetCurrency(
   int ordinal
);
[JScript]
public function GetCurrency(
   ordinal : int
) : Currency;

Parameters

ordinal
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetData

[To be supplied.]

[Visual Basic]
Overridable Public Function GetData( _
   ByVal ordinal As Integer _
) As IDataReader
[C#]
public virtual IDataReader GetData(
   int ordinal
);
[C++]
public: virtual IDataReader* GetData(
   int ordinal
);
[JScript]
public function GetData(
   ordinal : int
) : IDataReader;

Parameters

ordinal
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetDataTypeName

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDataTypeName( _
   ByVal index As Integer _
) As String
[C#]
public virtual string GetDataTypeName(
   int index
);
[C++]
public: virtual String* GetDataTypeName(
   int index
);
[JScript]
public function GetDataTypeName(
   index : int
) : String;

Parameters

index
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetDataTypeNamespace

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDataTypeNamespace( _
   ByVal index As Integer _
) As String
[C#]
public virtual string GetDataTypeNamespace(
   int index
);
[C++]
public: virtual String* GetDataTypeNamespace(
   int index
);
[JScript]
public function GetDataTypeNamespace(
   index : int
) : String;

Parameters

index
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetDateTime

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDateTime( _
   ByVal ordinal As Integer _
) As DateTime
[C#]
public virtual DateTime GetDateTime(
   int ordinal
);
[C++]
public: virtual DateTime GetDateTime(
   int ordinal
);
[JScript]
public function GetDateTime(
   ordinal : int
) : DateTime;

Parameters

ordinal
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetDecimal

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDecimal( _
   ByVal ordinal As Integer _
) As Decimal
[C#]
public virtual Decimal GetDecimal(
   int ordinal
);
[C++]
public: virtual Decimal GetDecimal(
   int ordinal
);
[JScript]
public function GetDecimal(
   ordinal : int
) : Decimal;

Parameters

ordinal
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetDouble

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDouble( _
   ByVal ordinal As Integer _
) As Double
[C#]
public virtual double GetDouble(
   int ordinal
);
[C++]
public: virtual double GetDouble(
   int ordinal
);
[JScript]
public function GetDouble(
   ordinal : int
) : double;

Parameters

ordinal
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetFieldType

[To be supplied.]

[Visual Basic]
Overridable Public Function GetFieldType( _
   ByVal index As Integer _
) As Type
[C#]
public virtual Type GetFieldType(
   int index
);
[C++]
public: virtual Type* GetFieldType(
   int index
);
[JScript]
public function GetFieldType(
   index : int
) : Type;

Parameters

index
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetFloat

[To be supplied.]

[Visual Basic]
Overridable Public Function GetFloat( _
   ByVal ordinal As Integer _
) As Single
[C#]
public virtual float GetFloat(
   int ordinal
);
[C++]
public: virtual float GetFloat(
   int ordinal
);
[JScript]
public function GetFloat(
   ordinal : int
) : float;

Parameters

ordinal
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetGuid

[To be supplied.]

[Visual Basic]
Public Function GetGuid( _
   ByVal ordinal As Integer _
) As Guid
[C#]
public Guid GetGuid(
   int ordinal
);
[C++]
public: Guid GetGuid(
   int ordinal
);
[JScript]
public function GetGuid(
   ordinal : int
) : Guid;

Parameters

ordinal
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetInt16

[To be supplied.]

[Visual Basic]
Overridable Public Function GetInt16( _
   ByVal ordinal As Integer _
) As Short
[C#]
public virtual short GetInt16(
   int ordinal
);
[C++]
public: virtual short GetInt16(
   int ordinal
);
[JScript]
public function GetInt16(
   ordinal : int
) : Int16;

Parameters

ordinal
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetInt32

[To be supplied.]

[Visual Basic]
Overridable Public Function GetInt32( _
   ByVal ordinal As Integer _
) As Integer
[C#]
public virtual int GetInt32(
   int ordinal
);
[C++]
public: virtual int GetInt32(
   int ordinal
);
[JScript]
public function GetInt32(
   ordinal : int
) : int;

Parameters

ordinal
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetInt64

[To be supplied.]

[Visual Basic]
Overridable Public Function GetInt64( _
   ByVal ordinal As Integer _
) As Long
[C#]
public virtual long GetInt64(
   int ordinal
);
[C++]
public: virtual __int64 GetInt64(
   int ordinal
);
[JScript]
public function GetInt64(
   ordinal : int
) : long;

Parameters

ordinal
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetName

[To be supplied.]

[Visual Basic]
Overridable Public Function GetName( _
   ByVal index As Integer _
) As String
[C#]
public virtual string GetName(
   int index
);
[C++]
public: virtual String* GetName(
   int index
);
[JScript]
public function GetName(
   index : int
) : String;

Parameters

index
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetNamespace

[To be supplied.]

[Visual Basic]
Overridable Public Function GetNamespace( _
   ByVal index As Integer _
) As String
[C#]
public virtual string GetNamespace(
   int index
);
[C++]
public: virtual String* GetNamespace(
   int index
);
[JScript]
public function GetNamespace(
   index : int
) : String;

Parameters

index
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetOrdinal

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function GetOrdinal(Integer) As Integer
[C#] public int GetOrdinal(int);
[C++] public: int GetOrdinal(int);
[JScript] public function GetOrdinal(int) : int;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function GetOrdinal(String) As Integer
[C#] public virtual int GetOrdinal(String);
[C++] public: virtual int GetOrdinal(String*);
[JScript] public function GetOrdinal(String) : int;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function GetOrdinal(String, String) As Integer
[C#] public virtual int GetOrdinal(String, String);
[C++] public: virtual int GetOrdinal(String*, String*);
[JScript] public function GetOrdinal(String, String) : int;

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetOrdinal (Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Function GetOrdinal( _
   ByVal index As Integer _
) As Integer
[C#]
public int GetOrdinal(
   int index
);
[C++]
public: int GetOrdinal(
   int index
);
[JScript]
public function GetOrdinal(
   index : int
) : int;

Parameters

index
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace | ADODataReader.GetOrdinal Overload List


ADODataReader.GetOrdinal (String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function GetOrdinal( _
   ByVal name As String _
) As Integer
[C#]
public virtual int GetOrdinal(
   string name
);
[C++]
public: virtual int GetOrdinal(
   String* name
);
[JScript]
public function GetOrdinal(
   name : String
) : int;

Parameters

name
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace | ADODataReader.GetOrdinal Overload List


ADODataReader.GetOrdinal (String, String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function GetOrdinal( _
   ByVal name As String, _
   ByVal namespaceURI As String _
) As Integer
[C#]
public virtual int GetOrdinal(
   string name,
   string namespaceURI
);
[C++]
public: virtual int GetOrdinal(
   String* name,
   String* namespaceURI
);
[JScript]
public function GetOrdinal(
   name : String,
   namespaceURI : String
) : int;

Parameters

name
[To be supplied.]
namespaceURI
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace | ADODataReader.GetOrdinal Overload List


ADODataReader.GetPrefix

[To be supplied.]

[Visual Basic]
Overridable Public Function GetPrefix( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetPrefix(
   int i
);
[C++]
public: virtual String* GetPrefix(
   int i
);
[JScript]
public function GetPrefix(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetRaw

[To be supplied.]

[Visual Basic]
Overridable Public Function GetRaw( _
   ByVal ordinal As Integer _
) As String
[C#]
public virtual string GetRaw(
   int ordinal
);
[C++]
public: virtual String* GetRaw(
   int ordinal
);
[JScript]
public function GetRaw(
   ordinal : int
) : String;

Parameters

ordinal
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetSByte

[To be supplied.]

[Visual Basic]
Public Function GetSByte( _
   ByVal ordinal As Integer _
) As SByte
[C#]
public sbyte GetSByte(
   int ordinal
);
[C++]
public: char GetSByte(
   int ordinal
);
[JScript]
public function GetSByte(
   ordinal : int
) : SByte;

Parameters

ordinal
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetStream

[To be supplied.]

[Visual Basic]
Overridable Public Function GetStream( _
   ByVal ordinal As Integer _
) As Stream
[C#]
public virtual Stream GetStream(
   int ordinal
);
[C++]
public: virtual Stream* GetStream(
   int ordinal
);
[JScript]
public function GetStream(
   ordinal : int
) : Stream;

Parameters

ordinal
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetString

[To be supplied.]

[Visual Basic]
Overridable Public Function GetString( _
   ByVal ordinal As Integer _
) As String
[C#]
public virtual string GetString(
   int ordinal
);
[C++]
public: virtual String* GetString(
   int ordinal
);
[JScript]
public function GetString(
   ordinal : int
) : String;

Parameters

ordinal
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetTimeSpan

[To be supplied.]

[Visual Basic]
Overridable Public Function GetTimeSpan( _
   ByVal ordinal As Integer _
) As TimeSpan
[C#]
public virtual TimeSpan GetTimeSpan(
   int ordinal
);
[C++]
public: virtual TimeSpan GetTimeSpan(
   int ordinal
);
[JScript]
public function GetTimeSpan(
   ordinal : int
) : TimeSpan;

Parameters

ordinal
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetUInt16

[To be supplied.]

[Visual Basic]
Public Function GetUInt16( _
   ByVal ordinal As Integer _
) As UInt16
[C#]
public ushort GetUInt16(
   int ordinal
);
[C++]
public: unsigned short GetUInt16(
   int ordinal
);
[JScript]
public function GetUInt16(
   ordinal : int
) : UInt16;

Parameters

ordinal
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetUInt32

[To be supplied.]

[Visual Basic]
Public Function GetUInt32( _
   ByVal ordinal As Integer _
) As UInt32
[C#]
public uint GetUInt32(
   int ordinal
);
[C++]
public: unsigned int GetUInt32(
   int ordinal
);
[JScript]
public function GetUInt32(
   ordinal : int
) : UInt32;

Parameters

ordinal
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetUInt64

[To be supplied.]

[Visual Basic]
Public Function GetUInt64( _
   ByVal ordinal As Integer _
) As UInt64
[C#]
public ulong GetUInt64(
   int ordinal
);
[C++]
public: unsigned __int64 GetUInt64(
   int ordinal
);
[JScript]
public function GetUInt64(
   ordinal : int
) : UInt64;

Parameters

ordinal
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetValue

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function GetValue(Integer) As Object
[C#] public object GetValue(int);
[C++] public: Object* GetValue(int);
[JScript] public function GetValue(int) : Object;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Sub GetValue(Integer, Object)
[C#] public virtual void GetValue(int, Object);
[C++] public: virtual void GetValue(int, Object);
[JScript] public function GetValue(int, Object);

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.GetValue (Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Function GetValue( _
   ByVal index As Integer _
) As Object
[C#]
public object GetValue(
   int index
);
[C++]
public: Object* GetValue(
   int index
);
[JScript]
public function GetValue(
   index : int
) : Object;

Parameters

index
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace | ADODataReader.GetValue Overload List


ADODataReader.GetValue (Int32, Object)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Sub GetValue( _
   ByVal index As Integer, _
   ByRef value As Object _
)
[C#]
public virtual void GetValue(
   int index,
   ref object value
);
[C++]
public: virtual void GetValue(
   int index,
   Object** value
);
[JScript]
public function GetValue(
   index : int,
   value : Object
);

Parameters

index
[To be supplied.]
value
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace | ADODataReader.GetValue Overload List


ADODataReader.GetValues

[To be supplied.]

[Visual Basic]
Overridable Public Function GetValues( _
   ByVal values() As Object _
) As Integer
[C#]
public virtual int GetValues(
   object[] values
);
[C++]
public: virtual int GetValues(
   Object* values[]
);
[JScript]
public function GetValues(
   values : Object[]
) : int;

Parameters

values
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.IsNull

[To be supplied.]

[Visual Basic]
Overridable Public Function IsNull( _
   ByVal ordinal As Integer _
) As Boolean
[C#]
public virtual bool IsNull(
   int ordinal
);
[C++]
public: virtual bool IsNull(
   int ordinal
);
[JScript]
public function IsNull(
   ordinal : int
) : Boolean;

Parameters

ordinal
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.Read

[To be supplied.]

[Visual Basic]
Overridable Public Function Read() As Boolean
[C#]
public virtual bool Read();
[C++]
public: virtual bool Read();
[JScript]
public function Read() : Boolean;

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataReader.SetRowBuffer

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetRowBuffer( _
   ByVal dataValues() As Object, _
   ByVal indexMap() As Integer _
)
[C#]
public virtual void SetRowBuffer(
   object[] dataValues,
   int[] indexMap
);
[C++]
public: virtual void SetRowBuffer(
   Object* dataValues[],
   int* indexMap[]
);
[JScript]
public function SetRowBuffer(
   dataValues : Object[],
   indexMap : int[]
);

Parameters

dataValues
[To be supplied.]
indexMap
[To be supplied.]

See Also

ADODataReader Class | ADODataReader Members | System.Data.ADO Namespace


ADODataSetCommand Class

Represents a set of data commands and a database connection which are used to fill the DataSet and update the data source. At any time, the object refers to only a single record within the current data set.

Object
Component
DataSetCommand
DBDataSetCommand
ADODataSetCommand

[Visual Basic]
Public Class ADODataSetCommand
   Inherits DBDataSetCommand
[C#]
public class ADODataSetCommand : DBDataSetCommand
[C++]
public __gc class ADODataSetCommand : public DBDataSetCommand
[JScript]
public class ADODataSetCommand extends DBDataSetCommand

Remarks

In the past, data processing has been primarily connection-based. Now, in an effort to make multi-tiered applications more efficient, data processing is turning to a message-based approach that revolves around chunks of information. At the center of this approach is the ADODataSetCommand, which provides a bridge to retrieve and save data between a DataSet and its source data store. The ADODataSetCommand provides this bridge by mapping FillDataSet, which changes the data in the DataSet to match the data in the data source, and Update, which changes the data in the data source to match the data in the DataSet, requests to the appropriate SQL commands against the data store.

If you are connecting to a Microsoft SQL Server database, you may wish to increase your overall performance by using the SQLDataSetCommand along with its associated SQLCommand and SQLConnection.

Useful properties include: SelectCommand, InsertCommand, DeleteCommand, UpdateCommand, and TableMappings.

When you create an instance of ADODataSetCommand, the read/write properties are set to initial values. For a list of these values, see the ADODataSetCommand constructor.

Requirements

Namespace: System.Data.ADO

Assembly: System.Data.dll

Example [C#]

The following example uses the ADOCommand, along ADODataSetCommand and ADOConnection, to select records from an Access data source. The DataSet is then used to insert new records in a SQL Server data source. This example can be modified to migrate an Access database to a SQL Server database.

[C#]

private DataSet InitializeMyDataSet() {
   // creates the table and its columns for the DataSet
   DataSet newData = new DataSet();
   DataTable newTable = newData.Tables.Add("Catagories");

   // add Columns to table
   newTable.Columns.Add("CategoryID",typeof(Int32));
   newTable.Columns.Add("CategoryName", typeof(String));
   newTable.Columns.Add("Description", typeof(String));
   newTable.Columns.Add("Picture",typeof(Byte[]));
   return newData;
}

public void AccessToSQLServer() {
   // set Access connection and select strings
   const string strAccessConn = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=NWIND_RW.MDB";
   const string strAccessSelect = "SELECT * FROM Categories ORDER BY CategoryID";
   // set SQL Server connection and insert strings
   const string strSQLServerConn = "Data Source=VBsql7;Initial Catalog=Northwind;User ID=sa;Password=;";
   const string strSQLServerInsert = "INSERT INTO Categories(CategoryName, Description, Picture) Values(@CategoryName,@Description,@Picture)";
   // create my DataSet
   DataSet myDataSet = InitializeMyDataSet();
   // create my Access objects
   ADOConnection myAccessConn = new ADOConnection(strAccessConn);
   ADODataSetCommand myAccessDataSetCmd = new ADODataSetCommand();
   myAccessDataSetCmd.SelectCommand = new ADOCommand(strAccessSelect,myAccessConn);
   // create my SQL Server objects
   SQLConnection mySQLConn = new SQLConnection(strSQLServerConn);
   SQLDataSetCommand mySQLDataSetCmd = new SQLDataSetCommand();
   mySQLDataSetCmd.InsertCommand = new SQLCommand(strSQLServerInsert,mySQLConn);
   // fill myDataSet with data from Access
   myAccessConn.Open();
   try {
      myAccessDataSetCmd.FillDataSet(myDataSet,"table");
   }
   finally {
      myAccessConn.Close();
   }

   // update SQL Server with data from the DataSet
   mySQLConn.Open();
   try {
      mySQLDataSetCmd.InsertCommand.Parameters.Add("CategoryName", typeof(String));
      mySQLDataSetCmd.InsertCommand.Parameters.Add("Description", typeof(String));
      mySQLDataSetCmd.InsertCommand.Parameters.Add("Picture", typeof(Byte[]));
      mySQLDataSetCmd.InsertCommand.Parameters[0].SourceColumn = "CategoryName";
      mySQLDataSetCmd.InsertCommand.Parameters[1].SourceColumn = "Description";
      mySQLDataSetCmd.InsertCommand.Parameters[2].SourceColumn = "Picture";
      mySQLDataSetCmd.Update(myDataSet,"table");
   }
   finally {
      mySQLConn.Close();
   }
}

See Also

ADODataSetCommand Members | System.Data.ADO Namespace | ADOConnection | ADOCommand | DataSet | DataTable


ADODataSetCommand Members

Public:

Constructor

ADODataSetCommand Constructor Overloaded. Initializes a new instance of the ADODataSetCommand class.

Properties

DeleteCommand | Gets or sets a command for deleting records from the data set.
InsertCommand | Gets or sets a command used to insert new records into the data source.
MissingMappingAction (inherited from DataSetCommand) | Gets or sets whether unmapped source tables or columns are to be passed with their source names to be filtered, or to cause an error to be raised.
MissingSchemaAction (inherited from DataSetCommand) | Gets or sets whether missing source tables, columns, and their relationships are to be added to the data set schema, to be ignored, or to cause an error to be raised.
SelectCommand | Gets or sets a command used to select records in the data source.
Site (inherited from Component) | Gets or sets the site of the Component.
TableMappings (inherited from DataSetCommand) | Gets how a source table is to be mapped to a data set table.
UpdateCommand | Gets or sets a command used to update records in the data source.

Methods

Clone (inherited from DBDataSetCommand) | Creates a new instance of this ADODataSetCommand object.
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FillDataSet (inherited from DBDataSetCommand) | Overloaded. Fills the data set with records and schema.
FillDataSetSchema (inherited from DBDataSetCommand) | Overloaded. Fills the data set with the schema.
GenerateUpdateCommands (inherited from DBDataSetCommand) | Generates the insert, update, or delete commands when each is in a default state.
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetFillDataSetParameters (inherited from DBDataSetCommand) | Returns all parameters used when performing the select command.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
Update (inherited from DBDataSetCommand) | Overloaded. Calls the respective insert, update, or delete commands on the connection, for each inserted, updated, or deleted rows in the data set.

Events

RowUpdated | Occurs during Update after a command is executed against the data source. The attempt to update is made, so the event fires.
RowUpdating | Occurs during Update before a command is executed against the data source. The attempt to update is made, so the event fires.
SchemaChanged (inherited from DataSetCommand) | Occurs during Update after a command is executed against the data source when the schema may be potentially different due to a property change.
SchemaChanging (inherited from DataSetCommand) | Occurs during Update before a command is executed against the data source when the schema may be potentially different due to a property change.
SchemaMapping | Occurs after the schema is mapped from the data source to the data set but before the tables and columns are added to the data set.

Protected:

Methods

CanGenerateUpdateCommands (inherited from DBDataSetCommand) | [To be supplied.]
CreateNewConnection | Creates a new connection to a data source.
CreateNewDeleteCommand | Creates a new command used during Update when deleting records in a data source for deleted rows in the data set.
CreateNewInsertCommand | Creates a new command used during Update when inserting records in a data source as new rows in the data set.
CreateNewRowUpdatedEvent | [To be supplied.]
CreateNewRowUpdatingEvent | [To be supplied.]
CreateNewSchemaChangedEvent (inherited from DataSetCommand) | [To be supplied.]
CreateNewSchemaChangingEvent (inherited from DataSetCommand) | [To be supplied.]
CreateNewSchemaMappingEvent | [To be supplied.]
CreateNewSelectCommand | Creates a new command used during Update to select records from a data source for inclusion into the data set.
CreateNewTableMappings (inherited from DataSetCommand) | [To be supplied.]
CreateNewUpdateCommand | Creates a new command used during Update when updating records in a data source for modified rows in the data set.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
FixupDataCommand (inherited from DBDataSetCommand) | [To be supplied.]
ForceGenerateUpdateCommand | [To be supplied.]
GetDeleteCommandObject (inherited from DBDataSetCommand) | [To be supplied.]
GetInsertCommandObject (inherited from DBDataSetCommand) | [To be supplied.]
GetSelectCommandObject (inherited from DBDataSetCommand) | [To be supplied.]
GetUpdateCommandObject (inherited from DBDataSetCommand) | [To be supplied.]
IsValidDataCommand | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnRowUpdated | Overloaded. [To be supplied.]
OnRowUpdating | Overloaded. [To be supplied.]
OnSchemaChanged (inherited from DataSetCommand) | Raises the OnSchemaChanged event.
OnSchemaChanging (inherited from DataSetCommand) | Raises the OnSchemaChanged event.
OnSchemaMapping | Overloaded. [To be supplied.]
ParameterOutput (inherited from DBDataSetCommand) | [To be supplied.]
SetDeleteCommandObject (inherited from DBDataSetCommand) | [To be supplied.]
SetInsertCommandObject (inherited from DBDataSetCommand) | [To be supplied.]
SetSelectCommandObject (inherited from DBDataSetCommand) | [To be supplied.]
SetUpdateCommandObject (inherited from DBDataSetCommand) | [To be supplied.]

Fields

commands (inherited from DBDataSetCommand) [To be supplied.]

Event Hookup:

Methods

AddOnRowUpdated | [To be supplied.]
AddOnRowUpdating | [To be supplied.]
AddOnSchemaChanged (inherited from DataSetCommand) | [To be supplied.]
AddOnSchemaChanging (inherited from DataSetCommand) | [To be supplied.]
AddOnSchemaMapping | [To be supplied.]
RemoveOnSchemaChanged (inherited from DataSetCommand) | [To be supplied.]
RemoveOnSchemaChanging (inherited from DataSetCommand) | [To be supplied.]

See Also

ADODataSetCommand Class | System.Data.ADO Namespace


ADODataSetCommand Constructor

Initializes a new instance of the ADODataSetCommand class.

Overload List

Initializes a new instance of the ADODataSetCommand class. This is the default constructor.

[Visual Basic] Overloads Public Sub New()
[C#] public ADODataSetCommand();
[C++] public: ADODataSetCommand();
[JScript] public function ADODataSetCommand();

Initializes a new instance of the ADODataSetCommand class with the specified select command.

[Visual Basic] Overloads Public Sub New(ADOCommand)
[C#] public ADODataSetCommand(ADOCommand);
[C++] public: ADODataSetCommand(ADOCommand*);
[JScript] public function ADODataSetCommand(ADOCommand);

Initializes a new instance of the ADODataSetCommand class with a select command string and a connection string.

[Visual Basic] Overloads Public Sub New(String, String)
[C#] public ADODataSetCommand(String, String);
[C++] public: ADODataSetCommand(String*, String*);
[JScript] public function ADODataSetCommand(String, String);

Inintialize a new instance of the ADODataSetCommand class with a select command and a connection.

[Visual Basic] Overloads Public Sub New(String, ADOConnection)
[C#] public ADODataSetCommand(String, ADOConnection);
[C++] public: ADODataSetCommand(String*, ADOConnection);
[JScript] public function ADODataSetCommand(String, ADOConnection);

Example [Visual Basic]

The following example shows how to create the ADODataSetCommand with a select command and an ADOConnection as parameters.

Note This example shows how to use one of the overloaded version of the ADODataSetCommand constructor. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Sub CreateDataSetCommand ()
   Dim adoDataSetComm As ADODataSetCommand
   Dim mySelectComm As String
   Dim myConnection As String
   Dim myADOConnect As ADOConnection
   ' Set myConnection to the connection text
   myConnection = "Provider=SQLADO.1;User ID=sa;PASSWORD=;" _
    + "Initial Catalog=Northwind;Data Source=vbsql7;"
   ' Set mySelectComm to the select command text
   mySelectComm = "SELECT intID, vchFirstName, vchLastName " _
    + "FROM Customers"
   ' Initialize myADOConnect as a new object
   myADOConnect = New ADOConnection myConnection
   ' Initialize adoDataSetComm as a new object
   adoDataSetComm = new ADODataSetObject mySelectComm, myADOConnect
   ' Set the action to take when a table or column is missing
   adoDataSetComm.MissingSchemaAction = MissingSchemaAction.Add
End Sub

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace


ADODataSetCommand Constructor ()

Initializes a new instance of the ADODataSetCommand class. This is the default constructor.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ADODataSetCommand();
[C++]
public: ADODataSetCommand();
[JScript]
public function ADODataSetCommand();

Remarks

When you create an instance of ADODataSetCommand, the following read/write properties are set to initial values.

Properties | Initial Value
SelectCommand | A new ADOCommand.
InsertCommand | A new ADOCommand.
DeleteCommand | A new ADOCommand.
UpdateCommand | A new ADOCommand.
MissingMappingAction | MissingMappingAction.Passthrough
MissingSchemaAction | MissingSchemaAction.Add

You can change the value of any of these properties through a separate call to the property.

Example [Visual Basic]

The following example shows how to create the ADODataSetCommand.

[Visual Basic]

Sub CreateDataSetCommand ()
    Dim adoDataSetComm As ADODataSetCommand
    Dim myInsertComm As String
    Dim mySelectComm As String
    ' Initialize adoDataSetComm as a new object
    adoDataSetComm = New ADODataSetCommand
    ' Set mySelectComm to the text of the select command
    mySelectComm = "SELECT intID, vchFirstName, vchLastName " _
     + "FROM Customers"
    ' Set the adoDataSetComm Select Command text
    adoDataSetComm.SelectCommand.CommandText = mySelectComm
    ' Set myInsertComm to the text of the insert command
    myInsertComm = "INSERT INTO tblCustomer (vchFirstName, " _
     + "vchLastName) VALUES (?, ?)"
    ' Set the adoDataSetComm Insert Command text
    adoDataSetComm.InsertCommand.CommandText = myInsertComm
    ' Set the action to take when a table or column is missing
    adoDataSetComm.MissingSchemaAction = MissingSchemaAction.Add
End Sub

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace | ADODataSetCommand Constructor Overload List | MissingMappingAction | MissingSchemaAction


ADODataSetCommand Constructor (ADOCommand)

Initializes a new instance of the ADODataSetCommand class with the specified select command.

[Visual Basic]
Overloads Public Sub New( _
   ByVal selectCommand As ADOCommand _
)
[C#]
public ADODataSetCommand(
   ADOCommand selectCommand
);
[C++]
public: ADODataSetCommand(
   ADOCommand* selectCommand
);
[JScript]
public function ADODataSetCommand(
   selectCommand : ADOCommand
);

Parameters

selectCommand
An ADOCommand that is a select command.

Remarks

When you create an instance of ADODataSetCommand, the following read/write properties are set to initial values.

Properties | Initial Value
SelectCommand | A new ADOCommand that is a copy of selectCommand.
InsertCommand | A new ADOCommand.
DeleteCommand | A new ADOCommand.
UpdateCommand | A new ADOCommand.
MissingMappingAction | MissingMappingAction.Passthrough
MissingSchemaAction | MissingSchemaAction.Add

You can change the value of any of these properties through a separate call to the property.

Example [Visual Basic]

The following example shows how to create the ADODataSetCommand with an ADOCommand that is a select command as a parameter.

[Visual Basic]

Sub CreateDataSetCommand ()
    Dim adoDataSetComm As ADODataSetCommand
    Dim myConnection As String
    Dim mySelectComm As String
    Dim myADOSelect As ADOCommand
    ' Set myConnection to the connection string text
    myConnection = "Provider=SQLADO.1;User ID=sa;PASSWORD=;" _
     + "Initial Catalog=Northwind;Data Source=vbsql7;"
    ' Set mySelectComm to the text of the select command
    mySelectComm = "SELECT intID, vchFirstName, vchLastName " _
     + "FROM Customers"
    ' Initialize myADOSelect command as a new object
    myADOSelect = New ADOCommand mySelectComm myConnection
    ' Initialize adoDataSetComm as a new object
    adoDataSetComm = New ADODataSetCommand myADOSelect
End Sub

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace | ADODataSetCommand Constructor Overload List | MissingMappingAction | MissingSchemaAction


ADODataSetCommand Constructor (String, String)

Initializes a new instance of the ADODataSetCommand class with a select command string and a connection string.

[Visual Basic]
Overloads Public Sub New( _
   ByVal selectCommandText As String, _
   ByVal selectConnectionString As String _
)
[C#]
public ADODataSetCommand(
   string selectCommandText,
   string selectConnectionString
);
[C++]
public: ADODataSetCommand(
   String* selectCommandText,
   String* selectConnectionString
);
[JScript]
public function ADODataSetCommand(
   selectCommandText : String,
   selectConnectionString : String
);

Parameters

selectCommandText
The select command string.
selectConnectionString
The connection string.

Remarks

When you create an instance of ADODataSetCommand, the following read/write properties are set to initial values.

Properties | Initial Value
SelectCommand | A new ADOCommand that has selectConnectionString as its connection text and selectCommandText as its command text.
InsertCommand | A new ADOCommand that has selectConnectionString as its connection text.
DeleteCommand | A new ADOCommand that has selectConnectionString as its connection text.
UpdateCommand | A new ADOCommand that has selectConnectionString as its connection text.
MissingMappingAction | MissingMappingAction.Passthrough
MissingSchemaAction | MissingSchemaAction.Add

You can change the value of any of these properties through a separate call to the property.

Example [Visual Basic]

The following example shows how to create the ADODataSetCommand with a select command string and a connection string as parameters.

[Visual Basic]

Sub CreateDataSetCommand ()
    Dim adoDataSetComm As ADODataSetCommand
    Dim mySelectComm As String
    Dim myConnection As String
    ' Set myConnection to the connection text
    myConnection = "Provider=SQLADO.1;User ID=sa;PASSWORD=;" _
     + "Initial Catalog=Northwind;Data Source=vbsql7;"
    ' Set mySelectComm to the select command text
    mySelectComm = "SELECT intID, vchFirstName, vchLastName " _
     + "FROM Customers"
    ' Initialize adoDataSetComm as a new object
    adoDataSetComm = new ADODataSetObject mySelectComm, myConnection
End Sub

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace | ADODataSetCommand Constructor Overload List | MissingMappingAction | MissingSchemaAction


ADODataSetCommand Constructor (String, ADOConnection)

Inintialize a new instance of the ADODataSetCommand class with a select command and a connection.

[Visual Basic]
Overloads Public Sub New( _
   ByVal selectCommandText As String, _
   ByVal selectConnection As ADOConnection _
)
[C#]
public ADODataSetCommand(
   string selectCommandText,
   ADOConnection selectConnection
);
[C++]
public: ADODataSetCommand(
   String* selectCommandText,
   ADOConnection* selectConnection
);
[JScript]
public function ADODataSetCommand(
   selectCommandText : String,
   selectConnection : ADOConnection
);

Parameters

selectCommandText
The select command string.
selectConnection
An ADOConnection that represents the connection.

Remarks

When you create an instance of ADODataSetCommand, the following read/write properties are set to initial values.

Properties | Initial Value
SelectCommand | A new ADOCommand that has selectConnection as its connection and selectCommandText as its command text.
InsertCommand | A new ADOCommand that has selectConnection as its connection.
DeleteCommand | A new ADOCommand that has selectConnection as its connection.
UpdateCommand | A new ADOCommand that has selectConnection as its connection.
MissingMappingAction | MissingMappingAction.Passthrough
MissingSchemaAction | MissingSchemaAction.Add

You can change the value of any of these properties through a separate call to the property.

Example [Visual Basic]

The following example shows how to create the ADODataSetCommand with a select command and an ADOConnection as parameters.

[Visual Basic]

Sub CreateDataSetCommand ()
   Dim adoDataSetComm As ADODataSetCommand
   Dim mySelectComm As String
   Dim myConnection As String
   Dim myADOConnect As ADOConnection
   ' Set myConnection to the connection text
   myConnection = "Provider=SQLADO.1;User ID=sa;PASSWORD=;" _
    + "Initial Catalog=Northwind;Data Source=vbsql7;"
   ' Set mySelectComm to the select command text
   mySelectComm = "SELECT intID, vchFirstName, vchLastName " _
    + "FROM Customers"
   ' Initialize myADOConnect as a new object
   myADOConnect = New ADOConnection myConnection
   ' Initialize adoDataSetComm as a new object
   adoDataSetComm = new ADODataSetObject mySelectComm, myADOConnect
   ' Set the action to take when a table or column is missing
   adoDataSetComm.MissingSchemaAction = MissingSchemaAction.Add
End Sub

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace | ADODataSetCommand Constructor Overload List | MissingMappingAction | MissingSchemaAction


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ADODataSetCommand Properties

The properties of the ADODataSetCommand class are listed below. For a complete list of ADODataSetCommand class members, see the ADODataSetCommand Members topic.

Public:

DeleteCommand | Gets or sets a command for deleting records from the data set.
InsertCommand | Gets or sets a command used to insert new records into the data source.
MissingMappingAction (inherited from DataSetCommand) | Gets or sets whether unmapped source tables or columns are to be passed with their source names to be filtered, or to cause an error to be raised.
MissingSchemaAction (inherited from DataSetCommand) | Gets or sets whether missing source tables, columns, and their relationships are to be added to the data set schema, to be ignored, or to cause an error to be raised.
SelectCommand | Gets or sets a command used to select records in the data source.
Site (inherited from Component) | Gets or sets the site of the Component.
TableMappings (inherited from DataSetCommand) | Gets how a source table is to be mapped to a data set table.
UpdateCommand | Gets or sets a command used to update records in the data source.

See Also

ADODataSetCommand Class | System.Data.ADO Namespace


ADODataSetCommand.DeleteCommand

Gets or sets a command for deleting records from the data set.

[Visual Basic]
Public Property DeleteCommand As ADOCommand
[C#]
public ADOCommand DeleteCommand {get; set;}
[C++]
public: __property ADOCommand* get_DeleteCommand();
public: __property void set_DeleteCommand(ADOCommand*);
[JScript]
public function get DeleteCommand() : ADOCommand;
public function set DeleteCommand(ADOCommand);

Property Value

An ADOCommand used during Update to delete records in the data source for deleted rows in the data set.

Example [Visual Basic]

The following example creates an ADOCommand used to set the DeleteCommand property for use by the ADODataSetCommand.

[Visual Basic]

Sub AssignDeleteCommand ()
   Dim myConnection As ADOConnection
   Dim adoDataSetComm As ADODataSetCommand
   Dim myConnectStr As String
   Dim myDelComm As String
   ' Initialize the ADODataSetCommand
   adoDatSetComm = New ADODataSetCommand
   ' Assign myConnectStr to the connection string
   myConnectStr = "Provider=SQLADO.1;User ID=sa;PASSWORD=;" _
    + "Initial Catalog=Northwind;Data Source=vbsql7;"
   ' Initialize the ADOConnection
   myConnection = New ADOConnection myConnectStr
   ' Assign myDelComm to the text of my delete command
   myDelComm = "DELETE FROM tblCustomer WHERE intID = ?"
   ' Assign the DeleteCommand to myDelComm
   adoDataSetComm.DeleteCommand.CommandText = myDelComm
   ' Set the command's connection to the current connection
   Set adoDataSetComm.DeleteCommand.ActiveConnection = myConnection
End Sub

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace | InsertCommand | SelectCommand | UpdateCommand


ADODataSetCommand.InsertCommand

Gets or sets a command used to insert new records into the data source.

[Visual Basic]
Public Property InsertCommand As ADOCommand
[C#]
public ADOCommand InsertCommand {get; set;}
[C++]
public: __property ADOCommand* get_InsertCommand();
public: __property void set_InsertCommand(ADOCommand*);
[JScript]
public function get InsertCommand() : ADOCommand;
public function set InsertCommand(ADOCommand);

Property Value

An ADOCommand used during Update to insert records in the data source for new rows in the data set.

Example [Visual Basic]

The following example creates an ADOCommand used to set the InsertCommand property for use by the ADODataSetCommand.

[Visual Basic]

Sub AssignInsertCommand ()
   Dim myConnection As ADOConnection
   Dim adoDataSetComm As ADODataSetCommand
   Dim myConnectStr As String
   Dim myInsComm As String
   ' Initialize the ADODatSetCommand
   adoDataSetComm = New ADODataSetCommand
   ' Assign myConnectStr to the connection string
   myConnectStr = "Provider=SQLADO.1;User ID=sa;PASSWORD=;" _
    + "Initial Catalog=Northwind;Data Source=vbsql7;"
   ' Initialize the ADOConnection
   myConnection = New ADOConnection myConnectStr
   ' Assign myInsComm to the text of my insert command
   myInsComm = "INSERT INTO tblCustomer (vchFirstName, " _
 + "vchLastName, chState) VALUES (?, ?, ?)"
   ' Assign the InsertCommand to myInsComm
   adoDataSetComm.InsertCommand.CommandText = myInsComm
   ' Set the command's connection to the current connection
   Set adoDataSetComm.InsertCommand.ActiveConnection = myConnection
End Sub

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace | DeleteCommand | SelectCommand | UpdateCommand


ADODataSetCommand.SelectCommand

Gets or sets a command used to select records in the data source.

[Visual Basic]
Public Property SelectCommand As ADOCommand
[C#]
public ADOCommand SelectCommand {get; set;}
[C++]
public: __property ADOCommand* get_SelectCommand();
public: __property void set_SelectCommand(ADOCommand*);
[JScript]
public function get SelectCommand() : ADOCommand;
public function set SelectCommand(ADOCommand);

Property Value

An ADOCommand that is used during Update to select records from data source for placement in the data set.

Example [Visual Basic]

The following example creates an ADOCommand used to set the SelectCommand property for use by the ADODataSetCommand.

[Visual Basic]

Sub AssignSelectCommand ()
   Dim myConnection As ADOConnection
   Dim myConnectStr As String
   Dim mySelectComm As String
   Dim adoDataSetComm As ADODataSetCommand
   ' Initialize the ADODataSetCommand
   adoDataSetComm = New ADODataSetCommand
   ' Assign myConnectStr to the connection string
   myConnectStr = "Provider=SQLADO.1;User ID=sa;PASSWORD=;" _
    + "Initial Catalog=Northwind;Data Source=vbsql7;"
   ' Initialize the ADOConnection
   myConnection = New ADOConnection myConnectStr
   ' Assign mySelectComm to the text of my select command
   mySelectComm = "SELECT intID, vchFirstName, vchLastName, " _
    + "chState FROM Customers WHERE chState = 'CA'"
   ' Assign the DeleteCommand to myDelComm
   adoDataSetComm.SelectCommand.CommandText = mySelectComm
   ' Set the command's connection to the current connection
   Set adoDataSetComm.SelectCommand.ActiveConnection = myConnection
End Sub

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace | DeleteCommand | InsertCommand | UpdateCommand


ADODataSetCommand.UpdateCommand

Gets or sets a command used to update records in the data source.

[Visual Basic]
Public Property UpdateCommand As ADOCommand
[C#]
public ADOCommand UpdateCommand {get; set;}
[C++]
public: __property ADOCommand* get_UpdateCommand();
public: __property void set_UpdateCommand(ADOCommand*);
[JScript]
public function get UpdateCommand() : ADOCommand;
public function set UpdateCommand(ADOCommand);

Property Value

An ADOCommand used during Update to update records in the data source for modified rows in the data set.

Example [Visual Basic]

The following example creates an ADOCommand used to set the UpdateCommand property for use by the ADODataSetCommand.

[Visual Basic]

Sub AssignUpdateCommand ()
   Dim myConnection As ADOConnection
   Dim myConnectStr As String
   Dim myUpdateComm As String
   Dim adoDataSetComm As ADODataSetCommand
   ' Initialize the ADODataSetCommand
   adoDataSetComm = New ADODataSetCommand
   ' Assign myConnectStr to the connection string
   myConnectStr = "Provider=SQLADO.1;User ID=sa;PASSWORD=;" _
    + "Initial Catalog=Northwind;Data Source=vbsql7;"
   ' Initialize the ADOConnection
   myConnection = New ADOConnection myConnectStr
   ' Assign myUpdateComm to the text of my update command
   myUpdateComm = "DELETE FROM tblCustomer WHERE intID = ?"
   ' Assign the UpdateCommand to myUpdateComm
   adoDataSetComm.UpdateCommand.CommandText = myUpdateComm
   ' Set the command's connection to the current connection
   Set adoDataSetComm.UpdateCommand.ActiveConnection = myConnection
End Sub

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace | DeleteCommand | InsertCommand | SelectCommand


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ADODataSetCommand Methods

The methods of the ADODataSetCommand class are listed below. For a complete list of ADODataSetCommand class members, see the ADODataSetCommand Members topic.

Public:

Clone (inherited from DBDataSetCommand) | Creates a new instance of this ADODataSetCommand object.
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FillDataSet (inherited from DBDataSetCommand) | Overloaded. Fills the data set with records and schema.
FillDataSetSchema (inherited from DBDataSetCommand) | Overloaded. Fills the data set with the schema.
GenerateUpdateCommands (inherited from DBDataSetCommand) | Generates the insert, update, or delete commands when each is in a default state.
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetFillDataSetParameters (inherited from DBDataSetCommand) | Returns all parameters used when performing the select command.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
Update (inherited from DBDataSetCommand) | Overloaded. Calls the respective insert, update, or delete commands on the connection, for each inserted, updated, or deleted rows in the data set.

Protected:

CanGenerateUpdateCommands (inherited from DBDataSetCommand) | [To be supplied.]
CreateNewConnection | Creates a new connection to a data source.
CreateNewDeleteCommand | Creates a new command used during Update when deleting records in a data source for deleted rows in the data set.
CreateNewInsertCommand | Creates a new command used during Update when inserting records in a data source as new rows in the data set.
CreateNewRowUpdatedEvent | [To be supplied.]
CreateNewRowUpdatingEvent | [To be supplied.]
CreateNewSchemaChangedEvent (inherited from DataSetCommand) | [To be supplied.]
CreateNewSchemaChangingEvent (inherited from DataSetCommand) | [To be supplied.]
CreateNewSchemaMappingEvent | [To be supplied.]
CreateNewSelectCommand | Creates a new command used during Update to select records from a data source for inclusion into the data set.
CreateNewTableMappings (inherited from DataSetCommand) | [To be supplied.]
CreateNewUpdateCommand | Creates a new command used during Update when updating records in a data source for modified rows in the data set.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
FixupDataCommand (inherited from DBDataSetCommand) | [To be supplied.]
ForceGenerateUpdateCommand | [To be supplied.]
GetDeleteCommandObject (inherited from DBDataSetCommand) | [To be supplied.]
GetInsertCommandObject (inherited from DBDataSetCommand) | [To be supplied.]
GetSelectCommandObject (inherited from DBDataSetCommand) | [To be supplied.]
GetUpdateCommandObject (inherited from DBDataSetCommand) | [To be supplied.]
IsValidDataCommand | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnRowUpdated | Overloaded. [To be supplied.]
OnRowUpdating | Overloaded. [To be supplied.]
OnSchemaChanged (inherited from DataSetCommand) | Raises the OnSchemaChanged event.
OnSchemaChanging (inherited from DataSetCommand) | Raises the OnSchemaChanged event.
OnSchemaMapping | Overloaded. [To be supplied.]
ParameterOutput (inherited from DBDataSetCommand) | [To be supplied.]
SetDeleteCommandObject (inherited from DBDataSetCommand) | [To be supplied.]
SetInsertCommandObject (inherited from DBDataSetCommand) | [To be supplied.]
SetSelectCommandObject (inherited from DBDataSetCommand) | [To be supplied.]
SetUpdateCommandObject (inherited from DBDataSetCommand) | [To be supplied.]

Event Hookup:

AddOnRowUpdated | [To be supplied.]
AddOnRowUpdating | [To be supplied.]
AddOnSchemaChanged (inherited from DataSetCommand) | [To be supplied.]
AddOnSchemaChanging (inherited from DataSetCommand) | [To be supplied.]
AddOnSchemaMapping | [To be supplied.]
RemoveOnSchemaChanged (inherited from DataSetCommand) | [To be supplied.]
RemoveOnSchemaChanging (inherited from DataSetCommand) | [To be supplied.]

See Also

ADODataSetCommand Class | System.Data.ADO Namespace


ADODataSetCommand.AddOnRowUpdated

[To be supplied.]

[Visual Basic]
Overridable Public Sub AddOnRowUpdated( _
   ByVal handler As ADORowUpdatedEventHandler _
)
[C#]
public virtual void AddOnRowUpdated(
   ADORowUpdatedEventHandler handler
);
[C++]
public: virtual void AddOnRowUpdated(
   ADORowUpdatedEventHandler* handler
);
[JScript]
public function AddOnRowUpdated(
   handler : ADORowUpdatedEventHandler
);

Parameters

handler
A ADORowUpdatedEventHandler to manage the event.

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace


ADODataSetCommand.AddOnRowUpdating

[To be supplied.]

[Visual Basic]
Overridable Public Sub AddOnRowUpdating( _
   ByVal handler As ADORowUpdatingEventHandler _
)
[C#]
public virtual void AddOnRowUpdating(
   ADORowUpdatingEventHandler handler
);
[C++]
public: virtual void AddOnRowUpdating(
   ADORowUpdatingEventHandler* handler
);
[JScript]
public function AddOnRowUpdating(
   handler : ADORowUpdatingEventHandler
);

Parameters

handler
A SchemaChangedEventHandler that manages the event.

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace


ADODataSetCommand.AddOnSchemaMapping

[To be supplied.]

[Visual Basic]
Overridable Public Sub AddOnSchemaMapping( _
   ByVal handler As ADOSchemaMappingEventHandler _
)
[C#]
public virtual void AddOnSchemaMapping(
   ADOSchemaMappingEventHandler handler
);
[C++]
public: virtual void AddOnSchemaMapping(
   ADOSchemaMappingEventHandler* handler
);
[JScript]
public function AddOnSchemaMapping(
   handler : ADOSchemaMappingEventHandler
);

Parameters

handler
A ADOSchemaMappingEventHandler that manages the event.

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace


ADODataSetCommand.CreateNewConnection

Creates a new connection to a data source.

[Visual Basic]
Overridable Protected Function CreateNewConnection( _
   ByVal connectionString As String _
) As ADOConnection
[C#]
protected virtual ADOConnection CreateNewConnection(
   string connectionString
);
[C++]
protected: virtual ADOConnection* CreateNewConnection(
   String* connectionString
);
[JScript]
protected function CreateNewConnection(
   connectionString : String
) : ADOConnection;

Parameters

connectionString
A string used to open the data source.

Return Value

An ADOConnection that contains the data connection information.

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace


ADODataSetCommand.CreateNewDeleteCommand

Creates a new command used during Update when deleting records in a data source for deleted rows in the data set.

[Visual Basic]
Overrides Protected Function CreateNewDeleteCommand() As DBCommand
[C#]
protected override DBCommand CreateNewDeleteCommand();
[C++]
protected: override DBCommand* CreateNewDeleteCommand();
[JScript]
protected override function CreateNewDeleteCommand() : DBCommand;

Return Value

An ADOCommand that contains the delete command information.

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace


ADODataSetCommand.CreateNewInsertCommand

Creates a new command used during Update when inserting records in a data source as new rows in the data set.

[Visual Basic]
Overrides Protected Function CreateNewInsertCommand() As DBCommand
[C#]
protected override DBCommand CreateNewInsertCommand();
[C++]
protected: override DBCommand* CreateNewInsertCommand();
[JScript]
protected override function CreateNewInsertCommand() : DBCommand;

Return Value

An ADOCommand that contains the insert command information.

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace


ADODataSetCommand.CreateNewRowUpdatedEvent

[To be supplied.]

[Visual Basic]
Overrides Protected Function CreateNewRowUpdatedEvent( _
   ByVal dataRow As DataRow, _
   ByVal command As DBCommand, _
   ByVal commandType As String _
) As RowUpdatedEventArgs
[C#]
protected override RowUpdatedEventArgs CreateNewRowUpdatedEvent(
   DataRow dataRow,
   DBCommand command,
   string commandType
);
[C++]
protected: override RowUpdatedEventArgs* CreateNewRowUpdatedEvent(
   DataRow* dataRow,
   DBCommand* command,
   String* commandType
);
[JScript]
protected override function CreateNewRowUpdatedEvent(
   dataRow : DataRow,
   command : DBCommand,
   commandType : String
) : RowUpdatedEventArgs;

Parameters

dataRow
[To be supplied.]
command
[To be supplied.]
commandType
[To be supplied.]

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace


ADODataSetCommand.CreateNewRowUpdatingEvent

[To be supplied.]

[Visual Basic]
Overrides Protected Function CreateNewRowUpdatingEvent( _
   ByVal dataRow As DataRow, _
   ByVal command As DBCommand, _
   ByVal commandType As String _
) As RowUpdatingEventArgs
[C#]
protected override RowUpdatingEventArgs CreateNewRowUpdatingEvent(
   DataRow dataRow,
   DBCommand command,
   string commandType
);
[C++]
protected: override RowUpdatingEventArgs* CreateNewRowUpdatingEvent(
   DataRow* dataRow,
   DBCommand* command,
   String* commandType
);
[JScript]
protected override function CreateNewRowUpdatingEvent(
   dataRow : DataRow,
   command : DBCommand,
   commandType : String
) : RowUpdatingEventArgs;

Parameters

dataRow
[To be supplied.]
command
[To be supplied.]
commandType
[To be supplied.]

Example [Visual Basic]

The following example fills a DataSet with the schema only, while filling a DataTable with records, when provided a source table.

[Visual Basic]

Public Sub MyFillDataTableAndSet(myDataTable   As DataTable, _
         myDataSet     As DataSet, _
         myDataSetComm As ADODataSetCommand,
         mySrcTable    As String)
   ' Create a MessageBox to show the contents of myDataTable in
   Dim myMsgBox As MessageBox
   ' Populate myDataTable with records and myDataSet with schema
   myDataTable = myDataSetComm.FillDataSetSchema myDataSet, _
      SchemaType.Source, mySrcTable
   ' Display the contents of myDataTable
   myMsgBox myDataTable.ToString
End Sub

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace


ADODataSetCommand.CreateNewSchemaMappingEvent

[To be supplied.]

[Visual Basic]
Overrides Protected Function CreateNewSchemaMappingEvent( _
   ByVal command As DBCommand, _
   ByVal dataSet As DataSet, _
   ByVal schemaTable As DataTable _
) As SchemaMappingEventArgs
[C#]
protected override SchemaMappingEventArgs CreateNewSchemaMappingEvent(
   DBCommand command,
   DataSet dataSet,
   DataTable schemaTable
);
[C++]
protected: override SchemaMappingEventArgs* CreateNewSchemaMappingEvent(
   DBCommand* command,
   DataSet* dataSet,
   DataTable* schemaTable
);
[JScript]
protected override function CreateNewSchemaMappingEvent(
   command : DBCommand,
   dataSet : DataSet,
   schemaTable : DataTable
) : SchemaMappingEventArgs;

Parameters

command
[To be supplied.]
dataSet
[To be supplied.]
schemaTable
[To be supplied.]

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace


ADODataSetCommand.CreateNewSelectCommand

Creates a new command used during Update to select records from a data source for inclusion into the data set.

[Visual Basic]
Overrides Protected Function CreateNewSelectCommand() As DBCommand
[C#]
protected override DBCommand CreateNewSelectCommand();
[C++]
protected: override DBCommand* CreateNewSelectCommand();
[JScript]
protected override function CreateNewSelectCommand() : DBCommand;

Return Value

An ADOCommand that contains the select information.

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace


ADODataSetCommand.CreateNewUpdateCommand

Creates a new command used during Update when updating records in a data source for modified rows in the data set.

[Visual Basic]
Overrides Protected Function CreateNewUpdateCommand() As DBCommand
[C#]
protected override DBCommand CreateNewUpdateCommand();
[C++]
protected: override DBCommand* CreateNewUpdateCommand();
[JScript]
protected override function CreateNewUpdateCommand() : DBCommand;

Return Value

An ADOCommand that contains the update information.

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace


ADODataSetCommand.ForceGenerateUpdateCommand

[To be supplied.]

[Visual Basic]
Overrides Protected Sub ForceGenerateUpdateCommand( _
   ByVal updateType As Integer, _
   ByVal optimisticQueries As Boolean, _
   ByVal refreshStatement As Boolean, _
   ByVal forStoredProcedure As Boolean, _
   ByRef sessionState As Object _
)
[C#]
protected override void ForceGenerateUpdateCommand(
   int updateType,
   bool optimisticQueries,
   bool refreshStatement,
   bool forStoredProcedure,
   ref object sessionState
);
[C++]
protected: override void ForceGenerateUpdateCommand(
   int updateType,
   bool optimisticQueries,
   bool refreshStatement,
   bool forStoredProcedure,
   Object** sessionState
);
[JScript]
protected override function ForceGenerateUpdateCommand(
   updateType : int,
   optimisticQueries : Boolean,
   refreshStatement : Boolean,
   forStoredProcedure : Boolean,
   sessionState : Object
);

Parameters

updateType
[To be supplied.]
optimisticQueries
[To be supplied.]
refreshStatement
[To be supplied.]
forStoredProcedure
[To be supplied.]
sessionState
[To be supplied.]

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace


ADODataSetCommand.IsValidDataCommand

[To be supplied.]

[Visual Basic]
Overrides Protected Function IsValidDataCommand( _
   ByVal value As DBCommand _
) As Boolean
[C#]
protected override bool IsValidDataCommand(
   DBCommand value
);
[C++]
protected: override bool IsValidDataCommand(
   DBCommand* value
);
[JScript]
protected override function IsValidDataCommand(
   value : DBCommand
) : Boolean;

Parameters

value
[To be supplied.]

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace


ADODataSetCommand.OnRowUpdated

[To be supplied.]

Overload List

Raises the OnRowUpdated event.

[Visual Basic] Overloads Overrides Protected Sub OnRowUpdated(RowUpdatedEventArgs)
[C#] protected override void OnRowUpdated(RowUpdatedEventArgs);
[C++] protected: override void OnRowUpdated(RowUpdatedEventArgs*);
[JScript] protected override function OnRowUpdated(RowUpdatedEventArgs);

Raises the OnRowUpdated event.

[Visual Basic] Overloads Overridable Protected Sub OnRowUpdated(ADORowUpdatedEventArgs)
[C#] protected virtual void OnRowUpdated(ADORowUpdatedEventArgs);
[C++] protected: virtual void OnRowUpdated(ADORowUpdatedEventArgs*);
[JScript] protected function OnRowUpdated(ADORowUpdatedEventArgs);

Example [Visual Basic]

The following example uses this method within a derived class.

Note This example shows how to use one of the overloaded versions of OnRowUpdated. For other examples that may be available, see the individual overload topics.

[Visual Basic]

' MyDataSetCommand.class derived from ADODataSetCommand
Inherits ADODataSetCommand
' create the method for row updated
Public Sub OnRowUpdated(event As RowUpdatedEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row has been updated."
   '  call the base class method
   MyBase.OnRowUpdated event
End Sub
' create the method for row updating
Public Sub OnRowUpdating(event As RowUpdatingEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row is being updated ..."
   '  call the base class method
   MyBase.OnRowUpdating event
End Sub
' create the method for the schema changing
Public Sub OnSchemaChanging(event As SchemaChangingEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is changing ..."
   '  call the base class method
   MyBase.OnSchemaChanging event
End Sub
' create the method for the schema changed
Public Sub OnSchemaChanged(event As SchemaChangedEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema has changed"
   '  call the base class method
   MyBase.OnSchemaChanged event
End Sub
' create the method for the schema being mapped
Public Sub OnSchemaMapping(event As SchemaMappingEventArgs)
   ' show a message box telling the user of schema map
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is currently being mapped ..."
   ' call the base class method
   MyBase.OnSchemaMapping event
End Sub

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace


ADODataSetCommand.OnRowUpdated (RowUpdatedEventArgs)

Raises the OnRowUpdated event.

[Visual Basic]
Overloads Overrides Protected Sub OnRowUpdated( _
   ByVal ruevent As RowUpdatedEventArgs _
)
[C#]
protected override void OnRowUpdated(
   RowUpdatedEventArgs ruevent
);
[C++]
protected: override void OnRowUpdated(
   RowUpdatedEventArgs* ruevent
);
[JScript]
protected override function OnRowUpdated(
   ruevent : RowUpdatedEventArgs
);

Parameters

ruevent
A ADORowUpdatedEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see TBD.

Notes to Inheritors: When overriding OnRowUpdated in a derived class, be sure to call the base class's OnRowUpdated method.

Example [Visual Basic]

The following example uses this method within a derived class.

[Visual Basic]

' MyDataSetCommand.class derived from ADODataSetCommand
Inherits ADODataSetCommand
' create the method for row updated
Public Sub OnRowUpdated(event As RowUpdatedEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row has been updated."
   '  call the base class method
   MyBase.OnRowUpdated event
End Sub
' create the method for row updating
Public Sub OnRowUpdating(event As RowUpdatingEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row is being updated ..."
   '  call the base class method
   MyBase.OnRowUpdating event
End Sub
' create the method for the schema changing
Public Sub OnSchemaChanging(event As SchemaChangingEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is changing ..."
   '  call the base class method
   MyBase.OnSchemaChanging event
End Sub
' create the method for the schema changed
Public Sub OnSchemaChanged(event As SchemaChangedEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema has changed"
   '  call the base class method
   MyBase.OnSchemaChanged event
End Sub
' create the method for the schema being mapped
Public Sub OnSchemaMapping(event As SchemaMappingEventArgs)
   ' show a message box telling the user of schema map
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is currently being mapped ..."
   ' call the base class method
   MyBase.OnSchemaMapping event
End Sub

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace | ADODataSetCommand.OnRowUpdated Overload List | OnRowUpdating


ADODataSetCommand.OnRowUpdated (ADORowUpdatedEventArgs)

Raises the OnRowUpdated event.

[Visual Basic]
Overloads Overridable Protected Sub OnRowUpdated( _
   ByVal ruevent As ADORowUpdatedEventArgs _
)
[C#]
protected virtual void OnRowUpdated(
   ADORowUpdatedEventArgs ruevent
);
[C++]
protected: virtual void OnRowUpdated(
   ADORowUpdatedEventArgs* ruevent
);
[JScript]
protected function OnRowUpdated(
   ruevent : ADORowUpdatedEventArgs
);

Parameters

ruevent
A ADORowUpdatedEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see TBD.

Notes to Inheritors: When overriding OnRowUpdated in a derived class, be sure to call the base class's OnRowUpdated method.

Example [Visual Basic]

The following example uses this method within a derived class.

[Visual Basic]

' MyDataSetCommand.class derived from ADODataSetCommand
Inherits ADODataSetCommand
' create the method for row updated
Public Sub OnRowUpdated(event As RowUpdatedEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row has been updated."
   '  call the base class method
   MyBase.OnRowUpdated event
End Sub
' create the method for row updating
Public Sub OnRowUpdating(event As RowUpdatingEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row is being updated ..."
   '  call the base class method
   MyBase.OnRowUpdating event
End Sub
' create the method for the schema changing
Public Sub OnSchemaChanging(event As SchemaChangingEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is changing ..."
   '  call the base class method
   MyBase.OnSchemaChanging event
End Sub
' create the method for the schema changed
Public Sub OnSchemaChanged(event As SchemaChangedEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema has changed"
   '  call the base class method
   MyBase.OnSchemaChanged event
End Sub
' create the method for the schema being mapped
Public Sub OnSchemaMapping(event As SchemaMappingEventArgs)
   ' show a message box telling the user of schema map
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is currently being mapped ..."
   ' call the base class method
   MyBase.OnSchemaMapping event
End Sub

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace | ADODataSetCommand.OnRowUpdated Overload List | OnRowUpdating


ADODataSetCommand.OnRowUpdating

[To be supplied.]

Overload List

Raises the OnRowUpdating event.

[Visual Basic] Overloads Overridable Protected Sub OnRowUpdating(ADORowUpdatingEventArgs)
[C#] protected virtual void OnRowUpdating(ADORowUpdatingEventArgs);
[C++] protected: virtual void OnRowUpdating(ADORowUpdatingEventArgs*);
[JScript] protected function OnRowUpdating(ADORowUpdatingEventArgs);

Raises the OnRowUpdating event.

[Visual Basic] Overloads Overrides Protected Sub OnRowUpdating(RowUpdatingEventArgs)
[C#] protected override void OnRowUpdating(RowUpdatingEventArgs);
[C++] protected: override void OnRowUpdating(RowUpdatingEventArgs*);
[JScript] protected override function OnRowUpdating(RowUpdatingEventArgs);

Example [Visual Basic]

The following example uses this method within a derived class.

Note This example shows how to use one of the overloaded versions of OnRowUpdating. For other examples that may be available, see the individual overload topics.

[Visual Basic]

' MyDataSetCommand.class derived from ADODataSetCommand
Inherits ADODataSetCommand
' create the method for row updated
Public Sub OnRowUpdated(event As RowUpdatedEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row has been updated."
   '  call the base class method
   MyBase.OnRowUpdated event
End Sub
' create the method for row updating
Public Sub OnRowUpdating(event As RowUpdatingEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row is being updated ..."
   '  call the base class method
   MyBase.OnRowUpdating event
End Sub
' create the method for the schema changing
Public Sub OnSchemaChanging(event As SchemaChangingEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is changing ..."
   '  call the base class method
   MyBase.OnSchemaChanging event
End Sub
' create the method for the schema changed
Public Sub OnSchemaChanged(event As SchemaChangedEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema has changed"
   '  call the base class method
   MyBase.OnSchemaChanged event
End Sub
' create the method for the schema being mapped
Public Sub OnSchemaMapping(event As SchemaMappingEventArgs)
   ' show a message box telling the user of schema map
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is currently being mapped ..."
   ' call the base class method
   MyBase.OnSchemaMapping event
End Sub

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace


ADODataSetCommand.OnRowUpdating (ADORowUpdatingEventArgs)

Raises the OnRowUpdating event.

[Visual Basic]
Overloads Overridable Protected Sub OnRowUpdating( _
   ByVal ruevent As ADORowUpdatingEventArgs _
)
[C#]
protected virtual void OnRowUpdating(
   ADORowUpdatingEventArgs ruevent
);
[C++]
protected: virtual void OnRowUpdating(
   ADORowUpdatingEventArgs* ruevent
);
[JScript]
protected function OnRowUpdating(
   ruevent : ADORowUpdatingEventArgs
);

Parameters

ruevent
A ADORowUpdatingEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see TBD.

Notes to Inheritors: When overriding OnRowUpdating in a derived class, be sure to call the bases class's OnRowUpdating method.

Example [Visual Basic]

The following example uses this method within a derived class.

[Visual Basic]

' MyDataSetCommand.class derived from ADODataSetCommand
Inherits ADODataSetCommand
' create the method for row updated
Public Sub OnRowUpdated(event As RowUpdatedEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row has been updated."
   '  call the base class method
   MyBase.OnRowUpdated event
End Sub
' create the method for row updating
Public Sub OnRowUpdating(event As RowUpdatingEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row is being updated ..."
   '  call the base class method
   MyBase.OnRowUpdating event
End Sub
' create the method for the schema changing
Public Sub OnSchemaChanging(event As SchemaChangingEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is changing ..."
   '  call the base class method
   MyBase.OnSchemaChanging event
End Sub
' create the method for the schema changed
Public Sub OnSchemaChanged(event As SchemaChangedEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema has changed"
   '  call the base class method
   MyBase.OnSchemaChanged event
End Sub
' create the method for the schema being mapped
Public Sub OnSchemaMapping(event As SchemaMappingEventArgs)
   ' show a message box telling the user of schema map
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is currently being mapped ..."
   ' call the base class method
   MyBase.OnSchemaMapping event
End Sub

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace | ADODataSetCommand.OnRowUpdating Overload List | OnRowUpdated


ADODataSetCommand.OnRowUpdating (RowUpdatingEventArgs)

Raises the OnRowUpdating event.

[Visual Basic]
Overloads Overrides Protected Sub OnRowUpdating( _
   ByVal ruevent As RowUpdatingEventArgs _
)
[C#]
protected override void OnRowUpdating(
   RowUpdatingEventArgs ruevent
);
[C++]
protected: override void OnRowUpdating(
   RowUpdatingEventArgs* ruevent
);
[JScript]
protected override function OnRowUpdating(
   ruevent : RowUpdatingEventArgs
);

Parameters

ruevent
A ADORowUpdatingEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see TBD.

Notes to Inheritors: When overriding OnRowUpdating in a derived class, be sure to call the bases class's OnRowUpdating method.

Example [Visual Basic]

The following example uses this method within a derived class.

[Visual Basic]

' MyDataSetCommand.class derived from ADODataSetCommand
Inherits ADODataSetCommand
' create the method for row updated
Public Sub OnRowUpdated(event As RowUpdatedEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row has been updated."
   '  call the base class method
   MyBase.OnRowUpdated event
End Sub
' create the method for row updating
Public Sub OnRowUpdating(event As RowUpdatingEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row is being updated ..."
   '  call the base class method
   MyBase.OnRowUpdating event
End Sub
' create the method for the schema changing
Public Sub OnSchemaChanging(event As SchemaChangingEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is changing ..."
   '  call the base class method
   MyBase.OnSchemaChanging event
End Sub
' create the method for the schema changed
Public Sub OnSchemaChanged(event As SchemaChangedEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema has changed"
   '  call the base class method
   MyBase.OnSchemaChanged event
End Sub
' create the method for the schema being mapped
Public Sub OnSchemaMapping(event As SchemaMappingEventArgs)
   ' show a message box telling the user of schema map
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is currently being mapped ..."
   ' call the base class method
   MyBase.OnSchemaMapping event
End Sub

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace | ADODataSetCommand.OnRowUpdating Overload List | OnRowUpdated


ADODataSetCommand.OnSchemaMapping

[To be supplied.]

Overload List

Raises the OnSchemaMapping event.

[Visual Basic] Overloads Overrides Protected Sub OnSchemaMapping(SchemaMappingEventArgs)
[C#] protected override void OnSchemaMapping(SchemaMappingEventArgs);
[C++] protected: override void OnSchemaMapping(SchemaMappingEventArgs*);
[JScript] protected override function OnSchemaMapping(SchemaMappingEventArgs);

Raises the OnSchemaMapping event.

[Visual Basic] Overloads Overridable Protected Sub OnSchemaMapping(ADOSchemaMappingEventArgs)
[C#] protected virtual void OnSchemaMapping(ADOSchemaMappingEventArgs);
[C++] protected: virtual void OnSchemaMapping(ADOSchemaMappingEventArgs*);
[JScript] protected function OnSchemaMapping(ADOSchemaMappingEventArgs);

Example [Visual Basic]

The following example uses this method within a derived class.

Note This example shows how to use one of the overloaded versions of OnSchemaMapping. For other examples that may be available, see the individual overload topics.

[Visual Basic]

' MyDataSetCommand.class derived from ADODataSetCommand
Inherits ADODataSetCommand
' create the method for row updated
Public Sub OnRowUpdated(event As RowUpdatedEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row has been updated."
   '  call the base class method
   MyBase.OnRowUpdated event
End Sub
' create the method for row updating
Public Sub OnRowUpdating(event As RowUpdatingEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row is being updated ..."
   '  call the base class method
   MyBase.OnRowUpdating event
End Sub
' create the method for the schema changing
Public Sub OnSchemaChanging(event As SchemaChangingEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is changing ..."
   '  call the base class method
   MyBase.OnSchemaChanging event
End Sub
' create the method for the schema changed
Public Sub OnSchemaChanged(event As SchemaChangedEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema has changed"
   '  call the base class method
   MyBase.OnSchemaChanged event
End Sub
' create the method for the schema being mapped
Public Sub OnSchemaMapping(event As SchemaMappingEventArgs)
   ' show a message box telling the user of schema map
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is currently being mapped ..."
   ' call the base class method
   MyBase.OnSchemaMapping event
End Sub

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace


ADODataSetCommand.OnSchemaMapping (SchemaMappingEventArgs)

Raises the OnSchemaMapping event.

[Visual Basic]
Overloads Overrides Protected Sub OnSchemaMapping( _
   ByVal scevent As SchemaMappingEventArgs _
)
[C#]
protected override void OnSchemaMapping(
   SchemaMappingEventArgs scevent
);
[C++]
protected: override void OnSchemaMapping(
   SchemaMappingEventArgs* scevent
);
[JScript]
protected override function OnSchemaMapping(
   scevent : SchemaMappingEventArgs
);

Parameters

scevent
A ADOSchemaMappingEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see TBD.

Notes to Inheritors: When overriding OnSchemaMapping in a derived class, be sure to call the bases class's OnSchemaMapping method.

Example [Visual Basic]

The following example uses this method within a derived class.

[Visual Basic]

' MyDataSetCommand.class derived from ADODataSetCommand
Inherits ADODataSetCommand
' create the method for row updated
Public Sub OnRowUpdated(event As RowUpdatedEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row has been updated."
   '  call the base class method
   MyBase.OnRowUpdated event
End Sub
' create the method for row updating
Public Sub OnRowUpdating(event As RowUpdatingEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row is being updated ..."
   '  call the base class method
   MyBase.OnRowUpdating event
End Sub
' create the method for the schema changing
Public Sub OnSchemaChanging(event As SchemaChangingEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is changing ..."
   '  call the base class method
   MyBase.OnSchemaChanging event
End Sub
' create the method for the schema changed
Public Sub OnSchemaChanged(event As SchemaChangedEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema has changed"
   '  call the base class method
   MyBase.OnSchemaChanged event
End Sub
' create the method for the schema being mapped
Public Sub OnSchemaMapping(event As SchemaMappingEventArgs)
   ' show a message box telling the user of schema map
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is currently being mapped ..."
   ' call the base class method
   MyBase.OnSchemaMapping event
End Sub

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace | ADODataSetCommand.OnSchemaMapping Overload List


ADODataSetCommand.OnSchemaMapping (ADOSchemaMappingEventArgs)

Raises the OnSchemaMapping event.

[Visual Basic]
Overloads Overridable Protected Sub OnSchemaMapping( _
   ByVal scevent As ADOSchemaMappingEventArgs _
)
[C#]
protected virtual void OnSchemaMapping(
   ADOSchemaMappingEventArgs scevent
);
[C++]
protected: virtual void OnSchemaMapping(
   ADOSchemaMappingEventArgs* scevent
);
[JScript]
protected function OnSchemaMapping(
   scevent : ADOSchemaMappingEventArgs
);

Parameters

scevent
A ADOSchemaMappingEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see TBD.

Notes to Inheritors: When overriding OnSchemaMapping in a derived class, be sure to call the bases class's OnSchemaMapping method.

Example [Visual Basic]

The following example uses this method within a derived class.

[Visual Basic]

' MyDataSetCommand.class derived from ADODataSetCommand
Inherits ADODataSetCommand
' create the method for row updated
Public Sub OnRowUpdated(event As RowUpdatedEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row has been updated."
   '  call the base class method
   MyBase.OnRowUpdated event
End Sub
' create the method for row updating
Public Sub OnRowUpdating(event As RowUpdatingEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row is being updated ..."
   '  call the base class method
   MyBase.OnRowUpdating event
End Sub
' create the method for the schema changing
Public Sub OnSchemaChanging(event As SchemaChangingEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is changing ..."
   '  call the base class method
   MyBase.OnSchemaChanging event
End Sub
' create the method for the schema changed
Public Sub OnSchemaChanged(event As SchemaChangedEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema has changed"
   '  call the base class method
   MyBase.OnSchemaChanged event
End Sub
' create the method for the schema being mapped
Public Sub OnSchemaMapping(event As SchemaMappingEventArgs)
   ' show a message box telling the user of schema map
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is currently being mapped ..."
   ' call the base class method
   MyBase.OnSchemaMapping event
End Sub

See Also

ADODataSetCommand Class | ADODataSetCommand Members | System.Data.ADO Namespace | ADODataSetCommand.OnSchemaMapping Overload List


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ADODataSetCommand Events

The events of the ADODataSetCommand class are listed below. For a complete list of ADODataSetCommand class members, see the ADODataSetCommand Members topic.

Public:

RowUpdated | Occurs during Update after a command is executed against the data source. The attempt to update is made, so the event fires.
RowUpdating | Occurs during Update before a command is executed against the data source. The attempt to update is made, so the event fires.
SchemaChanged (inherited from DataSetCommand) | Occurs during Update after a command is executed against the data source when the schema may be potentially different due to a property change.
SchemaChanging (inherited from DataSetCommand) | Occurs during Update before a command is executed against the data source when the schema may be potentially different due to a property change.
SchemaMapping | Occurs after the schema is mapped from the data source to the data set but before the tables and columns are added to the data set.

See Also

ADODataSetCommand Class | System.Data.ADO Namespace


ADODataSetCommand RowUpdated Event

Occurs during Update after a command is executed against the data source. The attempt to update is made, so the event fires.

The following declaration shows the syntax for a method that handles the RowUpdated event.

[Visual Basic]
Private Sub ADODataSetCommandName_RowUpdated( _
   ByVal sender As Object, _
   ByVal e As ADORowUpdatedEventArgs _
)
[C#]
private void ADODataSetCommandName_RowUpdated(
   object sender,
   ADORowUpdatedEventArgs e
);
[C++]
private: void ADODataSetCommandName_RowUpdated(
   Object* sender,
   ADORowUpdatedEventArgs* e
);
[JScript]
private ADODataSetCommandName_RowUpdated(
   sender : Object,
   e : ADORowUpdatedEventArgs
);

Parameters

sender
The source of the event.
e
An ADORowUpdatedEventArgs that contains the event data. The following ADORowUpdatedEventArgs properties provide information specific to this event.
Property Description
Command
[To be supplied.]

Remarks

When using Update, there are two events that occur per data row updated. The order of execution is as follows:

1) The values in the DataRow are moved to the parameter values

2) The OnRowUpdating event fires

3) The command executes

4) if the command is set to FirstReturnedRecord, then the first ruturned result is placed in the DataRow

5) if there are output parameters, they are placed in the DataRow

6) The OnRowUpdated event fires.

7) AcceptChanges is called.

See Also

ADODataSetCommand Class | ADODataSetCommand MembersTopic | System.Data.ADO Namespace


ADODataSetCommand RowUpdating Event

Occurs during Update before a command is executed against the data source. The attempt to update is made, so the event fires.

The following declaration shows the syntax for a method that handles the RowUpdating event.

[Visual Basic]
Private Sub ADODataSetCommandName_RowUpdating( _
   ByVal sender As Object, _
   ByVal e As ADORowUpdatingEventArgs _
)
[C#]
private void ADODataSetCommandName_RowUpdating(
   object sender,
   ADORowUpdatingEventArgs e
);
[C++]
private: void ADODataSetCommandName_RowUpdating(
   Object* sender,
   ADORowUpdatingEventArgs* e
);
[JScript]
private ADODataSetCommandName_RowUpdating(
   sender : Object,
   e : ADORowUpdatingEventArgs
);

Parameters

sender
The source of the event.
e
An ADORowUpdatingEventArgs that contains the event data. The following ADORowUpdatingEventArgs properties provide information specific to this event.
Property Description
Command
[To be supplied.]

Remarks

When using Update, there are two events that occur per data row updated. The order of execution is as follows:

1) The values in the DataRow are moved to the parameter values

2) The OnRowUpdating event fires

3) The command executes

4) if the command is set to FirstReturnedRecord, then the first ruturned result is placed in the DataRow

5) if there are output parameters, they are placed in the DataRow

6) The OnRowUpdated event fires.

7) AcceptChanges is called.

See Also

ADODataSetCommand Class | ADODataSetCommand MembersTopic | System.Data.ADO Namespace


ADODataSetCommand SchemaMapping Event

Occurs after the schema is mapped from the data source to the data set but before the tables and columns are added to the data set.

The following declaration shows the syntax for a method that handles the SchemaMapping event.

[Visual Basic]
Private Sub ADODataSetCommandName_SchemaMapping( _
   ByVal sender As Object, _
   ByVal e As ADOSchemaMappingEventArgs _
)
[C#]
private void ADODataSetCommandName_SchemaMapping(
   object sender,
   ADOSchemaMappingEventArgs e
);
[C++]
private: void ADODataSetCommandName_SchemaMapping(
   Object* sender,
   ADOSchemaMappingEventArgs* e
);
[JScript]
private ADODataSetCommandName_SchemaMapping(
   sender : Object,
   e : ADOSchemaMappingEventArgs
);

Parameters

sender
The source of the event.
e
An ADOSchemaMappingEventArgs that contains the event data. The following ADOSchemaMappingEventArgs properties provide information specific to this event.
Property Description
Command
[To be supplied.]

See Also

ADODataSetCommand Class | ADODataSetCommand MembersTopic | System.Data.ADO Namespace


ADODBType Enumeration

[To be supplied.]

[Visual Basic]
Public Enum ADODBType
[C#]
public enum ADODBType
[C++]
public enum ADODBType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
BigInt | [To be supplied.]
Binary | [To be supplied.]
Boolean | [To be supplied.]
BSTR | [To be supplied.]
Char | [To be supplied.]
Currency | [To be supplied.]
Date | [To be supplied.]
DBDate | [To be supplied.]
DBFiletime | [To be supplied.]
DBTime | [To be supplied.]
DBTimeStamp | [To be supplied.]
Decimal | [To be supplied.]
Double | [To be supplied.]
Empty | [To be supplied.]
Error | [To be supplied.]
Filetime | [To be supplied.]
Guid | [To be supplied.]
IDispatch | [To be supplied.]
Integer | [To be supplied.]
IUnknown | [To be supplied.]
LongVarBinary | [To be supplied.]
LongVarChar | [To be supplied.]
LongVarWChar | [To be supplied.]
Numeric | [To be supplied.]
PropVariant | [To be supplied.]
Single | [To be supplied.]
SmallInt | [To be supplied.]
TinyInt | [To be supplied.]
UnsignedBigInt | [To be supplied.]
UnsignedInt | [To be supplied.]
UnsignedSmallInt | [To be supplied.]
UnsignedTinyInt | [To be supplied.]
VarBinary | [To be supplied.]
VarChar | [To be supplied.]
Variant | [To be supplied.]
VarNumeric | [To be supplied.]
VarWChar | [To be supplied.]
WChar | [To be supplied.]

Requirements

Namespace: System.Data.ADO

Assembly: System.Data.dll

See Also

System.Data.ADO Namespace


ADOError Class

Collects information relevant to a warning or error returned by the data source.

Object
ADOError

[Visual Basic]
NotInheritable Public Class ADOError
[C#]
public sealed class ADOError
[C++]
public __gc __sealed class ADOError
[JScript]
public class ADOError

Remarks

This class is created by the adapter when an error occurs. An instance of ADOError is created and managed by the ADOErrors class, which in turn is created by the ADOException class.

Requirements

Namespace: System.Data.ADO

Assembly: System.Data.dll

See Also

ADOError Members | System.Data.ADO Namespace | ADOErrors | ADOException


ADOError Members

Public:

Properties

Message | Gets a short description of the error.
NativeError | Gets the database-specific error information.
Source | Gets the name of the object that generated the error.
SQLState | Gets the five-character error code following the ANSI SQL standard for the database.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ADOError Class | System.Data.ADO Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ADOError Properties

The properties of the ADOError class are listed below. For a complete list of ADOError class members, see the ADOError Members topic.

Public:

Message | Gets a short description of the error.
NativeError | Gets the database-specific error information.
Source | Gets the name of the object that generated the error.
SQLState | Gets the five-character error code following the ANSI SQL standard for the database.

See Also

ADOError Class | System.Data.ADO Namespace


ADOError.Message

Gets a short description of the error.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property String* get_Message();
[JScript]
public function get Message() : String;

Property Value

A short description of the error.

See Also

ADOError Class | ADOError Members | System.Data.ADO Namespace


ADOError.NativeError

Gets the database-specific error information.

[Visual Basic]
Public ReadOnly Property NativeError As Integer
[C#]
public int NativeError {get;}
[C++]
public: __property int get_NativeError();
[JScript]
public function get NativeError() : int;

Property Value

The database-specific error information.

See Also

ADOError Class | ADOError Members | System.Data.ADO Namespace


ADOError.Source

Gets the name of the object that generated the error.

[Visual Basic]
Public ReadOnly Property Source As String
[C#]
public string Source {get;}
[C++]
public: __property String* get_Source();
[JScript]
public function get Source() : String;

Property Value

The name of the object that generated the error.

See Also

ADOError Class | ADOError Members | System.Data.ADO Namespace


ADOError.SQLState

Gets the five-character error code following the ANSI SQL standard for the database.

[Visual Basic]
Public ReadOnly Property SQLState As String
[C#]
public string SQLState {get;}
[C++]
public: __property String* get_SQLState();
[JScript]
public function get SQLState() : String;

Property Value

The five-character error code, which identifies the source from which the error was issued (if the error can be issued from more than one place).

See Also

ADOError Class | ADOError Members | System.Data.ADO Namespace


ADOErrors Class

Collects all errors generated by the adapter.

Object
ADOErrors

[Visual Basic]
NotInheritable Public Class ADOErrors
   Implements ICollection, IEnumerable
[C#]
public sealed class ADOErrors : ICollection, IEnumerable
[C++]
public __gc __sealed class ADOErrors : public ICollection,
   IEnumerable
[JScript]
public class ADOErrors implements ICollection, IEnumerable

Remarks

This class is created by ADOException to collect instances of the ADOError class. ADOErrors always contains at least one instance of the ADOError class.

Requirements

Namespace: System.Data.ADO

Assembly: System.Data.dll

See Also

ADOErrors Members | System.Data.ADO Namespace | ADOError | ADOException


ADOErrors Members

Public:

Properties

All | Gets all of the adapter errors collected.
Count | Gets the number of errors in the collection.
Item | Gets the error at the specified index. In C#, this member is the indexer for the ADOErrors class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ADOErrors Class | System.Data.ADO Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ADOErrors Properties

The properties of the ADOErrors class are listed below. For a complete list of ADOErrors class members, see the ADOErrors Members topic.

Public:

All | Gets all of the adapter errors collected.
Count | Gets the number of errors in the collection.
Item | Gets the error at the specified index. In C#, this member is the indexer for the ADOErrors class.

See Also

ADOErrors Class | System.Data.ADO Namespace


ADOErrors.All

Gets all of the adapter errors collected.

[Visual Basic]
Public ReadOnly Property All As ADOError ()
[C#]
public ADOError[] All {get;}
[C++]
public: __property ADOError* get_All();
[JScript]
public function get All() : ADOError[];

Property Value

All instances of ADOError collected.

See Also

ADOErrors Class | ADOErrors Members | System.Data.ADO Namespace


ADOErrors.Count

Gets the number of errors in the collection.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

Property Value

The total number of errors in the collection.

See Also

ADOErrors Class | ADOErrors Members | System.Data.ADO Namespace


ADOErrors.Item

Gets the error at the specified index.

[C#] In C#, this member is the indexer for the ADOErrors class.

[Visual Basic]
Public Default ReadOnly Property Item( _
   ByVal index As Integer _
) As ADOError
[C#]
public ADOError this[
   int index
] {get;}
[C++]
public: __property ADOError* get_Item(
   int index
);
[JScript]
returnValue = ADOErrorsObject.Item(index);
-or-
returnValue = ADOErrorsObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
the zero-based index of the error to retrieve.

Parameters [Visual Basic, C#, C++]

index
the zero-based index of the error to retrieve.

Property Value

A ADOError that contains the error at the specified index.

See Also

ADOErrors Class | ADOErrors Members | System.Data.ADO Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ADOErrors Methods

The methods of the ADOErrors class are listed below. For a complete list of ADOErrors class members, see the ADOErrors Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ADOErrors Class | System.Data.ADO Namespace


ADOErrors.GetEnumerator

[To be supplied.]

[Visual Basic]
Overridable Public Function GetEnumerator() As IEnumerator
[C#]
public virtual IEnumerator GetEnumerator();
[C++]
public: virtual IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

See Also

ADOErrors Class | ADOErrors Members | System.Data.ADO Namespace


ADOException Class

Thrown whenever an error from the adapter is encountered.

Object
Exception
SystemException
ExternalException
ADOException

[Visual Basic]
NotInheritable Public Class ADOException
   Inherits ExternalException
[C#]
public sealed class ADOException : ExternalException
[C++]
public __gc __sealed class ADOException : public ExternalException
[JScript]
public class ADOException extends ExternalException

Remarks

This class is created whenever the adapter encounters a situation that it cannot handle. It always contains at least one instance of ADOError.

Requirements

Namespace: System.Data.ADO

Assembly: System.Data.dll

See Also

ADOException Members | System.Data.ADO Namespace | ADOError | ADOErrors


ADOException Members

Public:

Properties

ErrorCode (inherited from ExternalException) | [To be supplied.]
Errors | Gets all errors generated by adapter.
FullMessage | Gets the database-specific error information.
HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message | Gets a short description of the error.
Source | Gets the name of the object that generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

ADOException Class | System.Data.ADO Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ADOException Properties

The properties of the ADOException class are listed below. For a complete list of ADOException class members, see the ADOException Members topic.

Public:

ErrorCode (inherited from ExternalException) | [To be supplied.]
Errors | Gets all errors generated by adapter.
FullMessage | Gets the database-specific error information.
HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message | Gets a short description of the error.
Source | Gets the name of the object that generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

See Also

ADOException Class | System.Data.ADO Namespace


ADOException.Errors

Gets all errors generated by adapter.

[Visual Basic]
Public ReadOnly Property Errors As ADOErrors
[C#]
public ADOErrors Errors {get;}
[C++]
public: __property ADOErrors* get_Errors();
[JScript]
public function get Errors() : ADOErrors;

Property Value

The collected instances of the ADOError class. The ADOErrors class always contains at least one instance of the ADOError class.

Remarks

This is a wrapper for ADOErrors.

See Also

ADOException Class | ADOException Members | System.Data.ADO Namespace


ADOException.FullMessage

Gets the database-specific error information.

[Visual Basic]
Public ReadOnly Property FullMessage As String
[C#]
public string FullMessage {get;}
[C++]
public: __property String* get_FullMessage();
[JScript]
public function get FullMessage() : String;

Property Value

The database-specific error information.

Remarks

This is a wrapper for the NativeError property of the first ADOError in the Errors property.

See Also

ADOException Class | ADOException Members | System.Data.ADO Namespace


ADOException.Message

Gets a short description of the error.

[Visual Basic]
Overridable Public ReadOnly Property Message As String
[C#]
public string Message {override get;}
[C++]
public: __property virtual String* get_Message();
[JScript]
public function get Message() : String;

Property Value

A short description of the error.

Remarks

This is a wrapper for the Message property of the first ADOError in the Errors property.

See Also

ADOException Class | ADOException Members | System.Data.ADO Namespace


ADOException.Source

Gets the name of the object that generated the error.

[Visual Basic]
Overridable Public ReadOnly Property Source As String
[C#]
public string Source {override get;}
[C++]
public: __property virtual String* get_Source();
[JScript]
public function get Source() : String;

Property Value

The name of the object that generated the error.

Remarks

This is a wrapper for the Source property of the first ADOError in the Errors property.

See Also

ADOException Class | ADOException Members | System.Data.ADO Namespace


ADOInfoMessageEventArgs Class

[To be supplied.]

Object
EventArgs
ADOInfoMessageEventArgs

[Visual Basic]
Public Class ADOInfoMessageEventArgs
   Inherits EventArgs
[C#]
public class ADOInfoMessageEventArgs : EventArgs
[C++]
public __gc class ADOInfoMessageEventArgs : public EventArgs
[JScript]
public class ADOInfoMessageEventArgs extends EventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.ADO

Assembly: System.Data.dll

See Also

ADOInfoMessageEventArgs Members | System.Data.ADO Namespace


ADOInfoMessageEventArgs Members

Public:

Properties

ErrorCode | [To be supplied.]
Errors | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
FullMessage | [To be supplied.]
Message | [To be supplied.]
Source | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ADOInfoMessageEventArgs Class | System.Data.ADO Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ADOInfoMessageEventArgs Properties

The properties of the ADOInfoMessageEventArgs class are listed below. For a complete list of ADOInfoMessageEventArgs class members, see the ADOInfoMessageEventArgs Members topic.

Public:

ErrorCode | [To be supplied.]
Errors | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
FullMessage | [To be supplied.]
Message | [To be supplied.]
Source | [To be supplied.]

See Also

ADOInfoMessageEventArgs Class | System.Data.ADO Namespace


ADOInfoMessageEventArgs.ErrorCode

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property ErrorCode As Integer
[C#]
public int ErrorCode {virtual get;}
[C++]
public: __property virtual int get_ErrorCode();
[JScript]
public function get ErrorCode() : int;

See Also

ADOInfoMessageEventArgs Class | ADOInfoMessageEventArgs Members | System.Data.ADO Namespace


ADOInfoMessageEventArgs.Errors

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Errors As ADOErrors
[C#]
public ADOErrors Errors {get;}
[C++]
public: __property ADOErrors* get_Errors();
[JScript]
public function get Errors() : ADOErrors;

See Also

ADOInfoMessageEventArgs Class | ADOInfoMessageEventArgs Members | System.Data.ADO Namespace


ADOInfoMessageEventArgs.FullMessage

[To be supplied.]

[Visual Basic]
Public ReadOnly Property FullMessage As String
[C#]
public string FullMessage {get;}
[C++]
public: __property String* get_FullMessage();
[JScript]
public function get FullMessage() : String;

See Also

ADOInfoMessageEventArgs Class | ADOInfoMessageEventArgs Members | System.Data.ADO Namespace


ADOInfoMessageEventArgs.Message

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Message As String
[C#]
public string Message {virtual get;}
[C++]
public: __property virtual String* get_Message();
[JScript]
public function get Message() : String;

See Also

ADOInfoMessageEventArgs Class | ADOInfoMessageEventArgs Members | System.Data.ADO Namespace


ADOInfoMessageEventArgs.Source

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Source As String
[C#]
public string Source {virtual get;}
[C++]
public: __property virtual String* get_Source();
[JScript]
public function get Source() : String;

See Also

ADOInfoMessageEventArgs Class | ADOInfoMessageEventArgs Members | System.Data.ADO Namespace


ADOInfoMessageEventHandler Delegate

[To be supplied.]

[Visual Basic]
Public Delegate Sub ADOInfoMessageEventHandler( _
   ByVal sender As Object, _
   ByVal e As ADOInfoMessageEventArgs _
)
[C#]
public delegate void ADOInfoMessageEventHandler(
   object sender,
   ADOInfoMessageEventArgs e
);
[C++]
public __gc __delegate void ADOInfoMessageEventHandler(
   Object* sender,
   ADOInfoMessageEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the ADOInfoMessageEventHandler delegate declaration.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.ADO

Assembly: System.Data.dll

See Also

System.Data.ADO Namespace


ADOParameter Class

Represents a parameter to an ADOCommand and, optionally, its mapping to DataSet columns.

Object
ADOParameter

[Visual Basic]
Public Class ADOParameter
   Implements IDataParameter, ICloneable
[C#]
public class ADOParameter : IDataParameter, ICloneable
[C++]
public __gc class ADOParameter : public IDataParameter, ICloneable
[JScript]
public class ADOParameter implements IDataParameter, ICloneable

Remarks

Parameter names are case-insensitive.

Requirements

Namespace: System.Data.ADO

Assembly: System.Data.dll

See Also

ADOParameter Members | System.Data.ADO Namespace


ADOParameter Members

Public:

Constructor

ADOParameter Constructor Overloaded. Initializes a new instance of the ADOParameter class.

Properties

DataType | Gets or sets the Type of the parameter.
DBType | Gets or sets the native data type.
Direction | Gets or sets whether the parameter is input-only, output-only, or bidirectional.
IsNullable | Gets or sets whether the parameter accepts nulls.
ParameterName | Gets or sets the name of the ADOParameter.
Parent | Gets the reference to the ADOParameters collection that is the parent of this instance.
Precision | Gets or sets the maximum number of digits used to represent the Value.
Scale | Gets or sets the number of decimal places to which Value is resolved.
Size | Gets or sets the maximum size of the field.
SourceColumn | Gets or sets the name of the source column mapped to the DataSet and used for loading or returning the Value.
SourceVersion | Gets or sets the DataRowVersion to use when loading Value.
Value | Gets or sets the value of the parameter.

Methods

Clone | Creates a new instance of this ADOParameter object.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Returns a string containing the ParameterName.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ADOParameter Class | System.Data.ADO Namespace


ADOParameter Constructor

Initializes a new instance of the ADOParameter class.

Overload List

Initializes a new instance of the ADOParameter class. This is the default constructor.

[Visual Basic] Overloads Public Sub New()
[C#] public ADOParameter();
[C++] public: ADOParameter();
[JScript] public function ADOParameter();

Initializes a new instance of the ADOParameter class with the column name and column data type.

[Visual Basic] Overloads Public Sub New(String, ADODBType)
[C#] public ADOParameter(String, ADODBType);
[C++] public: ADOParameter(String*, ADODBType);
[JScript] public function ADOParameter(String, ADODBType);

Initializes a new instance of the ADOParameter class with the column name, column data type and the column width.

[Visual Basic] Overloads Public Sub New(String, ADODBType, Integer)
[C#] public ADOParameter(String, ADODBType, int);
[C++] public: ADOParameter(String*, ADODBType, int);
[JScript] public function ADOParameter(String, ADODBType, int);

Initializes a new instance of the ADOParameter class with the column name, column data type, the column width and source column name.

[Visual Basic] Overloads Public Sub New(String, ADODBType, Integer, String)
[C#] public ADOParameter(String, ADODBType, int, String);
[C++] public: ADOParameter(String*, ADODBType, int, String*);
[JScript] public function ADOParameter(String, ADODBType, int, String);

Initializes a new instance of the ADOParameter class with the column name, column data type, the column width, source column name, the parameter direction, the precision, and other properties.

[Visual Basic] Overloads Public Sub New(String, ADODBType, Integer, ParameterDirection, Boolean, Byte, Byte, String, DataRowVersion, Object)
[C#] public ADOParameter(String, ADODBType, int, ParameterDirection, bool, byte, byte, String, DataRowVersion, Object);
[C++] public: ADOParameter(String*, ADODBType, int, ParameterDirection, bool, unsigned char, unsigned char, String*, DataRowVersion, Object);
[JScript] public function ADOParameter(String, ADODBType, int, ParameterDirection, Boolean, Byte, Byte, String, DataRowVersion, Object);

See Also

ADOParameter Class | ADOParameter Members | System.Data.ADO Namespace


ADOParameter Constructor ()

Initializes a new instance of the ADOParameter class. This is the default constructor.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ADOParameter();
[C++]
public: ADOParameter();
[JScript]
public function ADOParameter();

See Also

ADOParameter Class | ADOParameter Members | System.Data.ADO Namespace | ADOParameter Constructor Overload List


ADOParameter Constructor (String, ADODBType)

Initializes a new instance of the ADOParameter class with the column name and column data type.

[Visual Basic]
Overloads Public Sub New( _
   ByVal name As String, _
   ByVal dataType As ADODBType _
)
[C#]
public ADOParameter(
   string name,
   ADODBType dataType
);
[C++]
public: ADOParameter(
   String* name,
   ADODBType dataType
);
[JScript]
public function ADOParameter(
   name : String,
   dataType : ADODBType
);

Parameters

name
The name of the column to map.
dataType
One of the ADODBType values.

Remarks

The Size and Precision are inferred from the ADODBType parameter.

See Also

ADOParameter Class | ADOParameter Members | System.Data.ADO Namespace | ADOParameter Constructor Overload List


ADOParameter Constructor (String, ADODBType, Int32)

Initializes a new instance of the ADOParameter class with the column name, column data type and the column width.

[Visual Basic]
Overloads Public Sub New( _
   ByVal name As String, _
   ByVal dataType As ADODBType, _
   ByVal size As Integer _
)
[C#]
public ADOParameter(
   string name,
   ADODBType dataType,
   int size
);
[C++]
public: ADOParameter(
   String* name,
   ADODBType dataType,
   int size
);
[JScript]
public function ADOParameter(
   name : String,
   dataType : ADODBType,
   size : int
);

Parameters

name
The name of the column to map.
dataType
One of the ADODBType values.
size
The width of the column.

Remarks

The Precision is inferred from the ADODBType parameter.

See Also

ADOParameter Class | ADOParameter Members | System.Data.ADO Namespace | ADOParameter Constructor Overload List


ADOParameter Constructor (String, ADODBType, Int32, String)

Initializes a new instance of the ADOParameter class with the column name, column data type, the column width and source column name.

[Visual Basic]
Overloads Public Sub New( _
   ByVal name As String, _
   ByVal dataType As ADODBType, _
   ByVal size As Integer, _
   ByVal srcColumn As String _
)
[C#]
public ADOParameter(
   string name,
   ADODBType dataType,
   int size,
   string srcColumn
);
[C++]
public: ADOParameter(
   String* name,
   ADODBType dataType,
   int size,
   String* srcColumn
);
[JScript]
public function ADOParameter(
   name : String,
   dataType : ADODBType,
   size : int,
   srcColumn : String
);

Parameters

name
The name of the column to map.
dataType
One of the ADODBType values.
size
The width of the column.
srcColumn
The name of the source column.

Remarks

The Precision is inferred from the ADODBType parameter.

See Also

ADOParameter Class | ADOParameter Members | System.Data.ADO Namespace | ADOParameter Constructor Overload List


ADOParameter Constructor (String, ADODBType, Int32, ParameterDirection, Boolean, Byte, Byte, String, DataRowVersion, Object)

Initializes a new instance of the ADOParameter class with the column name, column data type, the column width, source column name, the parameter direction, the precision, and other properties.

[Visual Basic]
Overloads Public Sub New( _
   ByVal parameterName As String, _
   ByVal dbType As ADODBType, _
   ByVal size As Integer, _
   ByVal direction As ParameterDirection, _
   ByVal isNullable As Boolean, _
   ByVal precision As Byte, _
   ByVal scale As Byte, _
   ByVal srcColumn As String, _
   ByVal srcVersion As DataRowVersion, _
   ByVal value As Object _
)
[C#]
public ADOParameter(
   string parameterName,
   ADODBType dbType,
   int size,
   ParameterDirection direction,
   bool isNullable,
   byte precision,
   byte scale,
   string srcColumn,
   DataRowVersion srcVersion,
   object value
);
[C++]
public: ADOParameter(
   String* parameterName,
   ADODBType dbType,
   int size,
   ParameterDirection direction,
   bool isNullable,
   unsigned char precision,
   unsigned char scale,
   String* srcColumn,
   DataRowVersion srcVersion,
   Object* value
);
[JScript]
public function ADOParameter(
   parameterName : String,
   dbType : ADODBType,
   size : int,
   direction : ParameterDirection,
   isNullable : Boolean,
   precision : Byte,
   scale : Byte,
   srcColumn : String,
   srcVersion : DataRowVersion,
   value : Object
);

Parameters

parameterName
The name of the column to map.
dbType
[To be supplied.]
size
[To be supplied.]
direction
[To be supplied.]
isNullable
[To be supplied.]
precision
[To be supplied.]
scale
[To be supplied.]
srcColumn
[To be supplied.]
srcVersion
[To be supplied.]
value
[To be supplied.]

See Also

ADOParameter Class | ADOParameter Members | System.Data.ADO Namespace | ADOParameter Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ADOParameter Properties

The properties of the ADOParameter class are listed below. For a complete list of ADOParameter class members, see the ADOParameter Members topic.

Public:

DataType | Gets or sets the Type of the parameter.
DBType | Gets or sets the native data type.
Direction | Gets or sets whether the parameter is input-only, output-only, or bidirectional.
IsNullable | Gets or sets whether the parameter accepts nulls.
ParameterName | Gets or sets the name of the ADOParameter.
Parent | Gets the reference to the ADOParameters collection that is the parent of this instance.
Precision | Gets or sets the maximum number of digits used to represent the Value.
Scale | Gets or sets the number of decimal places to which Value is resolved.
Size | Gets or sets the maximum size of the field.
SourceColumn | Gets or sets the name of the source column mapped to the DataSet and used for loading or returning the Value.
SourceVersion | Gets or sets the DataRowVersion to use when loading Value.
Value | Gets or sets the value of the parameter.

See Also

ADOParameter Class | System.Data.ADO Namespace


ADOParameter.DataType

Gets or sets the Type of the parameter.

[Visual Basic]
Overridable Public Property DataType As Type
[C#]
public Type DataType {virtual get; set;}
[C++]
public: __property virtual Type* get_DataType();
public: __property void set_DataType(Type*);
[JScript]
public function get DataType() : Type;
public function set DataType(Type);

Property Value

The Type of the parameter.

See Also

ADOParameter Class | ADOParameter Members | System.Data.ADO Namespace


ADOParameter.DBType

Gets or sets the native data type.

[Visual Basic]
Public Property DBType As ADODBType
[C#]
public ADODBType DBType {get; set;}
[C++]
public: __property ADODBType get_DBType();
public: __property void set_DBType(ADODBType);
[JScript]
public function get DBType() : ADODBType;
public function set DBType(ADODBType);

Property Value

One of the ADODBType values. The default is Empty.

Exceptions

Exception Type | Condition
InvalidADODBType | The property was not set to a valid ADODBType.

See Also

ADOParameter Class | ADOParameter Members | System.Data.ADO Namespace


ADOParameter.Direction

Gets or sets whether the parameter is input-only, output-only, or bidirectional.

[Visual Basic]
Overridable Public Property Direction As ParameterDirection
[C#]
public ParameterDirection Direction {virtual get; set;}
[C++]
public: __property virtual ParameterDirection get_Direction();
public: __property void set_Direction(ParameterDirection);
[JScript]
public function get Direction() : ParameterDirection;
public function set Direction(ParameterDirection);

Property Value

One of the ParameterDirection values. The default is Input.

Exceptions

Exception Type | Condition
InvalidParameterDirection | The property was not set to a valid ParameterDirection.

See Also

ADOParameter Class | ADOParameter Members | System.Data.ADO Namespace


ADOParameter.IsNullable

Gets or sets whether the parameter accepts nulls.

[Visual Basic]
Overridable Public Property IsNullable As Boolean
[C#]
public bool IsNullable {virtual get; set;}
[C++]
public: __property virtual bool get_IsNullable();
public: __property void set_IsNullable(bool);
[JScript]
public function get IsNullable() : Boolean;
public function set IsNullable(Boolean);

Property Value

true if nulls are accepted, otherwise false. The default is false.

See Also

ADOParameter Class | ADOParameter Members | System.Data.ADO Namespace


ADOParameter.ParameterName

Gets or sets the name of the ADOParameter.

[Visual Basic]
Overridable Public Property ParameterName As String
[C#]
public string ParameterName {virtual get; set;}
[C++]
public: __property virtual String* get_ParameterName();
public: __property void set_ParameterName(String*);
[JScript]
public function get ParameterName() : String;
public function set ParameterName(String);

Property Value

The name the ADOParameter.

See Also

ADOParameter Class | ADOParameter Members | System.Data.ADO Namespace


ADOParameter.Parent

Gets the reference to the ADOParameters collection that is the parent of this instance.

[Visual Basic]
Public ReadOnly Property Parent As ADOParameters
[C#]
public ADOParameters Parent {get;}
[C++]
public: __property ADOParameters* get_Parent();
[JScript]
public function get Parent() : ADOParameters;

Property Value

The reference to the ADOParameters collection that is the parent of this instance.

See Also

ADOParameter Class | ADOParameter Members | System.Data.ADO Namespace


ADOParameter.Precision

Gets or sets the maximum number of digits used to represent the Value.

[Visual Basic]
Public Property Precision As Byte
[C#]
public byte Precision {get; set;}
[C++]
public: __property unsigned char get_Precision();
public: __property void set_Precision(unsigned char);
[JScript]
public function get Precision() : Byte;
public function set Precision(Byte);

Property Value

The maximum number of digits used to represent the Value. The default value is 0.

Remarks

This property is only used for decimal and numeric input parameters.

See Also

ADOParameter Class | ADOParameter Members | System.Data.ADO Namespace | Scale | Size


ADOParameter.Scale

Gets or sets the number of decimal places to which Value is resolved.

[Visual Basic]
Public Property Scale As Byte
[C#]
public byte Scale {get; set;}
[C++]
public: __property unsigned char get_Scale();
public: __property void set_Scale(unsigned char);
[JScript]
public function get Scale() : Byte;
public function set Scale(Byte);

Property Value

The number of decimal places to which Value is resolved. The default is 0.

Remarks

This property is only used for decimal and numeric input parameters.

See Also

ADOParameter Class | ADOParameter Members | System.Data.ADO Namespace | Precision | Size


ADOParameter.Size

Gets or sets the maximum size of the field.

[Visual Basic]
Public Property Size As Integer
[C#]
public int Size {get; set;}
[C++]
public: __property int get_Size();
public: __property void set_Size(int);
[JScript]
public function get Size() : int;
public function set Size(int);

Property Value

The maximum size of the field.

Remarks

This property is only used for variable length input parameters. For unicode strings, use character count. For ansi strings and binary data, use byte count.

See Also

ADOParameter Class | ADOParameter Members | System.Data.ADO Namespace


ADOParameter.SourceColumn

Gets or sets the name of the source column mapped to the DataSet and used for loading or returning the Value.

[Visual Basic]
Overridable Public Property SourceColumn As String
[C#]
public string SourceColumn {virtual get; virtual set;}
[C++]
public: __property virtual String* get_SourceColumn();
public: __property virtual void set_SourceColumn(String*);
[JScript]
public function get SourceColumn() : String;
public function set SourceColumn(String);

Property Value

The name of the source column mapped to the DataSet and used for loading or returning the Value.

See Also

ADOParameter Class | ADOParameter Members | System.Data.ADO Namespace


ADOParameter.SourceVersion

Gets or sets the DataRowVersion to use when loading Value.

[Visual Basic]
Overridable Public Property SourceVersion As DataRowVersion
[C#]
public DataRowVersion SourceVersion {virtual get; virtual set;}
[C++]
public: __property virtual DataRowVersion get_SourceVersion();
public: __property virtual void set_SourceVersion(DataRowVersion);
[JScript]
public function get SourceVersion() : DataRowVersion;
public function set SourceVersion(DataRowVersion);

Property Value

One of the DataRowVersion values. The default is Current.

Exceptions

Exception Type | Condition
InvalidDataRowVersion | The property was not set to a valid DataRowVersion value.

Remarks

When used by UpdateCommand during Update to determine if the original or current value is used for a parameter value. This allows primary keys to be updated. This property is ignored by the InsertCommand or DeleteCommand. This property is set to the version of the DataRow used.

See Also

ADOParameter Class | ADOParameter Members | System.Data.ADO Namespace


ADOParameter.Value

Gets or sets the value of the parameter.

[Visual Basic]
Overridable Public Property Value As Object
[C#]
public object Value {virtual get; virtual set;}
[C++]
public: __property virtual Object* get_Value();
public: __property virtual void set_Value(Object*);
[JScript]
public function get Value() : Object;
public function set Value(Object);

Property Value

An Object that is the value of the parameter.

See Also

ADOParameter Class | ADOParameter Members | System.Data.ADO Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ADOParameter Methods

The methods of the ADOParameter class are listed below. For a complete list of ADOParameter class members, see the ADOParameter Members topic.

Public:

Clone | Creates a new instance of this ADOParameter object.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Returns a string containing the ParameterName.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ADOParameter Class | System.Data.ADO Namespace


ADOParameter.Clone

Creates a new instance of this ADOParameter object.

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

Return Value

A new ADOParameter that is a copy of this instance.

Remarks

Notes to Inheritors: When overridding Clone in a derived class, be sure to call the base class's Clone method.

See Also

ADOParameter Class | ADOParameter Members | System.Data.ADO Namespace


ADOParameter.ToString

Returns a string containing the ParameterName.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

A string containing the ParameterName.

See Also

ADOParameter Class | ADOParameter Members | System.Data.ADO Namespace


ADOParameterConverter Class

[To be supplied.]

Object
TypeConverter
ADOParameterConverter

[Visual Basic]
NotInheritable Public Class ADOParameterConverter
   Inherits TypeConverter
[C#]
public sealed class ADOParameterConverter : TypeConverter
[C++]
public __gc __sealed class ADOParameterConverter : public
   TypeConverter
[JScript]
public class ADOParameterConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.ADO

Assembly: System.Data.dll

See Also

ADOParameterConverter Members | System.Data.ADO Namespace


ADOParameterConverter Members

Public:

Constructor

ADOParameterConverter Constructor [To be supplied.]

Methods

CanConvertFrom (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the converter's native type.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text into an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given object to another type.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetProperties (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValues (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid (inherited from TypeConverter) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

ADOParameterConverter Class | System.Data.ADO Namespace


ADOParameterConverter Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ADOParameterConverter();
[C++]
public: ADOParameterConverter();
[JScript]
public function ADOParameterConverter();

See Also

ADOParameterConverter Class | ADOParameterConverter Members | System.Data.ADO Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ADOParameterConverter Methods

The methods of the ADOParameterConverter class are listed below. For a complete list of ADOParameterConverter class members, see the ADOParameterConverter Members topic.

Public:

CanConvertFrom (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the converter's native type.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text into an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given object to another type.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetProperties (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValues (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid (inherited from TypeConverter) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

ADOParameterConverter Class | System.Data.ADO Namespace


ADOParameterConverter.GetPersistInfo

[To be supplied.]

[Visual Basic]
Overrides Public Function GetPersistInfo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal obj As Object _
) As PersistInfo
[C#]
public override PersistInfo GetPersistInfo(
   ITypeDescriptorContext context,
   object obj
);
[C++]
public: override PersistInfo* GetPersistInfo(
   ITypeDescriptorContext* context,
   Object* obj
);
[JScript]
public override function GetPersistInfo(
   context : ITypeDescriptorContext,
   obj : Object
) : PersistInfo;

Parameters

context
[To be supplied.]
obj
[To be supplied.]

See Also

ADOParameterConverter Class | ADOParameterConverter Members | System.Data.ADO Namespace


ADOParameterConverter.GetProperties

Retrieves the set of properties for this type. By default, a type has does not return any properties. An easy implementation of this method can just call TypeDescriptor.GetProperties for the correct data type.

[Visual Basic]
Overrides Public Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal attributes() As MemberAttribute _
) As PropertyDescriptorCollection
[C#]
public override PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value,
   MemberAttribute[] attributes
);
[C++]
public: override PropertyDescriptorCollection* GetProperties(
   ITypeDescriptorContext* context,
   Object* value,
   MemberAttribute* attributes[]
);
[JScript]
public override function GetProperties(
   context : ITypeDescriptorContext,
   value : Object,
   attributes : MemberAttribute[]
) : PropertyDescriptorCollection;

Parameters

context
A type descriptor through which additional context may be provided.
value
The value of the object to get the properties for.
attributes
[To be supplied.]

Return Value

The set of properties that should be exposed for this data type. If no properties should be exposed, thsi may return null. The default implementation always returns null.

See Also

ADOParameterConverter Class | ADOParameterConverter Members | System.Data.ADO Namespace


ADOParameterConverter.GetPropertiesSupported

Determines if this object supports properties. By default, this is false.

[Visual Basic]
Overrides Public Function GetPropertiesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
[C#]
public override bool GetPropertiesSupported(
   ITypeDescriptorContext context
);
[C++]
public: override bool GetPropertiesSupported(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetPropertiesSupported(
   context : ITypeDescriptorContext
) : Boolean;

Parameters

context
A type descriptor through which additional context may be provided.

Return Value

Returns true if GetProperties should be called to find the properties of this object.

See Also

ADOParameterConverter Class | ADOParameterConverter Members | System.Data.ADO Namespace


ADOParameters Class

Collects all parameters relevant to an ADOCommand and their mappings to DataSet columns.

Object
ADOParameters

[Visual Basic]
Public Class ADOParameters
   Implements IDataParameters, IList, ICollection, IEnumerable
[C#]
public class ADOParameters : IDataParameters, IList, ICollection,
   IEnumerable
[C++]
public __gc class ADOParameters : public IDataParameters, IList,
   ICollection, IEnumerable
[JScript]
public class ADOParameters implements IDataParameters, IList,
   ICollection, IEnumerable

Remarks

The number of the parameters in the collection must be equal to the number of parameter placeholders within the command text or the provider will raise an error.

Requirements

Namespace: System.Data.ADO

Assembly: System.Data.dll

See Also

ADOParameters Members | System.Data.ADO Namespace


ADOParameters Members

Public:

Constructor

ADOParameters Constructor [To be supplied.]

Properties

All | Gets all instances of ADOParameter objects collected.
Count | Gets the number of ADOParameter objects in the collection.
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the ADOParameters class.
Parent | Gets the reference to the ADOCommand that is the parent of this instance.

Methods

Add | Overloaded. Adds an ADOParameter to the ADOCommand.
Clear | Removes all items from the collection.
Contains | Overloaded. Indicates whether an ADOParameter is in the collection.
CopyTo | Copies the entire collection to an array.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | Overloaded. Returns the location of the ADOParameter within the collection.
Remove | Removes the ADOParameter from the collection given the value.
RemoveAt | Overloaded. Removes the ADOParameter from the collection.
ShouldPersistAll | Indicates whether parameters are persisting.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Add | Overloaded. Adds an ADOParameter to the ADOCommand.
CreateNewItem | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ADOParameters Class | System.Data.ADO Namespace


ADOParameters Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ADOParameters();
[C++]
public: ADOParameters();
[JScript]
public function ADOParameters();

See Also

ADOParameters Class | ADOParameters Members | System.Data.ADO Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ADOParameters Properties

The properties of the ADOParameters class are listed below. For a complete list of ADOParameters class members, see the ADOParameters Members topic.

Public:

All | Gets all instances of ADOParameter objects collected.
Count | Gets the number of ADOParameter objects in the collection.
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the ADOParameters class.
Parent | Gets the reference to the ADOCommand that is the parent of this instance.

See Also

ADOParameters Class | System.Data.ADO Namespace


ADOParameters.All

Gets all instances of ADOParameter objects collected.

[Visual Basic]
Overridable Public Property All As ADOParameter ()
[C#]
public ADOParameter[] All {virtual get; virtual set;}
[C++]
public: __property virtual ADOParameter* get_All();
public: __property virtual void set_All(ADOParameter*[]);
[JScript]
public function get All() : ADOParameter[];
public function set All(ADOParameter[]);

Property Value

All instances of ADOParameter objects collected.

See Also

ADOParameters Class | ADOParameters Members | System.Data.ADO Namespace


ADOParameters.Count

Gets the number of ADOParameter objects in the collection.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

Property Value

The number of ADOParameter objects in the collection.

See Also

ADOParameters Class | ADOParameters Members | System.Data.ADO Namespace


ADOParameters.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the ADOParameters class.

Overload List

Gets the ADOParameter at the specified index.

[Visual Basic] Overloads Overridable Public Default Property Item(Integer) As ADOParameter
[C#] public ADOParameter this[int] {virtual get; virtual set;}
[C++] public: __property virtual ADOParameter* get_Item(int);
public: __property virtual void set_Item(int, ADOParameter*);
[JScript] ADOParameters.Item (int)

Gets the ADOParameter with the specified name.

[Visual Basic] Overloads Overridable Public Default Property Item(String) As ADOParameter
[C#] public ADOParameter this[String] {virtual get; virtual set;}
[C++] public: __property virtual ADOParameter* get_Item(String*);
public: __property virtual void set_Item(String*, ADOParameter*);
[JScript] ADOParameters.Item (String)

See Also

ADOParameters Class | ADOParameters Members | System.Data.ADO Namespace


ADOParameters.Item (Int32)

Gets the ADOParameter at the specified index.

[C#] In C#, this member is the indexer for the ADOParameters class.

[Visual Basic]
Overloads Overridable Public Default Property Item( _
   ByVal index As Integer _
) As ADOParameter
[C#]
public ADOParameter this[
   int index
] {virtual get; virtual set;}
[C++]
public: __property virtual ADOParameter* get_Item(
   int index
);
public: __property virtual void set_Item(
   int index,
   ADOParameter*
);
[JScript]
returnValue = ADOParametersObject.Item(index);
ADOParametersObject.Item(index) = returnValue;
-or-
returnValue = ADOParametersObject(index);
ADOParametersObject(index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
The zero-based index of the parameter to retrieve.

Parameters [Visual Basic, C#, C++]

index
The zero-based index of the parameter to retrieve.

Property Value

The ADOParameter at the specified index.

Exceptions

Exception Type | Condition
ParametersMappingIndex | The index specified does not exist.

See Also

ADOParameters Class | ADOParameters Members | System.Data.ADO Namespace | ADOParameters.Item Overload List


ADOParameters.Item (String)

Gets the ADOParameter with the specified name.

[C#] In C#, this member is the indexer for the ADOParameters class.

[Visual Basic]
Overloads Overridable Public Default Property Item( _
   ByVal parameterName As String _
) As ADOParameter
[C#]
public ADOParameter this[
   string parameterName
] {virtual get; virtual set;}
[C++]
public: __property virtual ADOParameter* get_Item(
   String* parameterName
);
public: __property virtual void set_Item(
   String* parameterName,
   ADOParameter*
);
[JScript]
returnValue = ADOParametersObject.Item(parameterName);
ADOParametersObject.Item(parameterName) = returnValue;
-or-
returnValue = ADOParametersObject(parameterName);
ADOParametersObject(parameterName) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

parameterName
The name of the parameter to retrieve.

Parameters [Visual Basic, C#, C++]

parameterName
The name of the parameter to retrieve.

Property Value

The ADOParameter with the specified name.

Exceptions

Exception Type | Condition
ParametersSourceIndex | The name specified does not exist.

See Also

ADOParameters Class | ADOParameters Members | System.Data.ADO Namespace | ADOParameters.Item Overload List


ADOParameters.Parent

Gets the reference to the ADOCommand that is the parent of this instance.

[Visual Basic]
Public ReadOnly Property Parent As ADOCommand
[C#]
public ADOCommand Parent {get;}
[C++]
public: __property ADOCommand* get_Parent();
[JScript]
public function get Parent() : ADOCommand;

Property Value

The reference to the ADOCommand that is the parent of this instance.

See Also

ADOParameters Class | ADOParameters Members | System.Data.ADO Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ADOParameters Methods

The methods of the ADOParameters class are listed below. For a complete list of ADOParameters class members, see the ADOParameters Members topic.

Public:

Add | Overloaded. Adds an ADOParameter to the ADOCommand.
Clear | Removes all items from the collection.
Contains | Overloaded. Indicates whether an ADOParameter is in the collection.
CopyTo | Copies the entire collection to an array.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | Overloaded. Returns the location of the ADOParameter within the collection.
Remove | Removes the ADOParameter from the collection given the value.
RemoveAt | Overloaded. Removes the ADOParameter from the collection.
ShouldPersistAll | Indicates whether parameters are persisting.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Add | Overloaded. Adds an ADOParameter to the ADOCommand.
CreateNewItem | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ADOParameters Class | System.Data.ADO Namespace


ADOParameters.Add

Adds an ADOParameter to the ADOCommand.

Overload List

Adds an ADOParameter to the ADOCommand when given the parameter name and the data type.

[Visual Basic] Overloads Public Function Add(String, ADODBType) As ADOParameter
[C#] public ADOParameter Add(String, ADODBType);
[C++] public: ADOParameter* Add(String*, ADODBType);
[JScript] public function Add(String, ADODBType) : ADOParameter;

[To be supplied.]

[Visual Basic] Overloads Overridable Protected Sub Add(ADOParameter)
[C#] protected virtual void Add(ADOParameter);
[C++] protected: virtual void Add(ADOParameter*);
[JScript] protected function Add(ADOParameter);

Adds an ADOParameter to the ADOCommand when given the parameter name, the data type, size, and a source column.

[Visual Basic] Overloads Public Function Add(String, ADODBType, Integer, String) As ADOParameter
[C#] public ADOParameter Add(String, ADODBType, int, String);
[C++] public: ADOParameter* Add(String*, ADODBType, int, String*);
[JScript] public function Add(String, ADODBType, int, String) : ADOParameter;

Adds an ADOParameter to the ADOCommand when given the parameter name, the data type, and size.

[Visual Basic] Overloads Public Function Add(String, ADODBType, Integer) As ADOParameter
[C#] public ADOParameter Add(String, ADODBType, int);
[C++] public: ADOParameter* Add(String*, ADODBType, int);
[JScript] public function Add(String, ADODBType, int) : ADOParameter;

Adds an ADOParameter to the ADOCommand when given an Object.

[Visual Basic] Overloads Overridable Public Function Add(Object) As Integer
[C#] public virtual int Add(Object);
[C++] public: virtual int Add(Object*);
[JScript] public function Add(Object) : int;

See Also

ADOParameters Class | ADOParameters Members | System.Data.ADO Namespace


ADOParameters.Add (String, ADODBType)

Adds an ADOParameter to the ADOCommand when given the parameter name and the data type.

[Visual Basic]
Overloads Public Function Add( _
   ByVal name As String, _
   ByVal dbType As ADODBType _
) As ADOParameter
[C#]
public ADOParameter Add(
   string name,
   ADODBType dbType
);
[C++]
public: ADOParameter* Add(
   String* name,
   ADODBType dbType
);
[JScript]
public function Add(
   name : String,
   dbType : ADODBType
) : ADOParameter;

Parameters

name
The name of the parameter.
dbType
One of the ADODBType values.

Return Value

A reference to the new ADOParameter object.

Exceptions

Exception Type | Condition
NotAnAdapterParameter | The parameter passed was not an ADOParameter.

See Also

ADOParameters Class | ADOParameters Members | System.Data.ADO Namespace | ADOParameters.Add Overload List


ADOParameters.Add (ADOParameter)

[To be supplied.]

[Visual Basic]
Overloads Overridable Protected Sub Add( _
   ByVal value As ADOParameter _
)
[C#]
protected virtual void Add(
   ADOParameter value
);
[C++]
protected: virtual void Add(
   ADOParameter* value
);
[JScript]
protected function Add(
   value : ADOParameter
);

Parameters

value
[To be supplied.]

See Also

ADOParameters Class | ADOParameters Members | System.Data.ADO Namespace | ADOParameters.Add Overload List


ADOParameters.Add (String, ADODBType, Int32, String)

Adds an ADOParameter to the ADOCommand when given the parameter name, the data type, size, and a source column.

[Visual Basic]
Overloads Public Function Add( _
   ByVal name As String, _
   ByVal dbType As ADODBType, _
   ByVal size As Integer, _
   ByVal sourceColumn As String _
) As ADOParameter
[C#]
public ADOParameter Add(
   string name,
   ADODBType dbType,
   int size,
   string sourceColumn
);
[C++]
public: ADOParameter* Add(
   String* name,
   ADODBType dbType,
   int size,
   String* sourceColumn
);
[JScript]
public function Add(
   name : String,
   dbType : ADODBType,
   size : int,
   sourceColumn : String
) : ADOParameter;

Parameters

name
The name of the parameter.
dbType
One of the ADODBType values.
size
The width of the column.
sourceColumn
The name of the source column.

Return Value

A reference to the new ADOParameter object.

Exceptions

Exception Type | Condition
NotAnAdapterParameter | The parameter passed was not an ADOParameter.

See Also

ADOParameters Class | ADOParameters Members | System.Data.ADO Namespace | ADOParameters.Add Overload List


ADOParameters.Add (String, ADODBType, Int32)

Adds an ADOParameter to the ADOCommand when given the parameter name, the data type, and size.

[Visual Basic]
Overloads Public Function Add( _
   ByVal name As String, _
   ByVal dbType As ADODBType, _
   ByVal size As Integer _
) As ADOParameter
[C#]
public ADOParameter Add(
   string name,
   ADODBType dbType,
   int size
);
[C++]
public: ADOParameter* Add(
   String* name,
   ADODBType dbType,
   int size
);
[JScript]
public function Add(
   name : String,
   dbType : ADODBType,
   size : int
) : ADOParameter;

Parameters

name
The name of the parameter.
dbType
One of the ADODBType values.
size
The width of the column.

Return Value

A reference to the new ADOParameter object.

Exceptions

Exception Type | Condition
NotAnAdapterParameter | The parameter passed was not an ADOParameter.

See Also

ADOParameters Class | ADOParameters Members | System.Data.ADO Namespace | ADOParameters.Add Overload List


ADOParameters.Add (Object)

Adds an ADOParameter to the ADOCommand when given an Object.

[Visual Basic]
Overloads Overridable Public Function Add( _
   ByVal value As Object _
) As Integer
[C#]
public virtual int Add(
   object value
);
[C++]
public: virtual int Add(
   Object* value
);
[JScript]
public function Add(
   value : Object
) : int;

Parameters

value
An Object that is the Value of the parameter.

Exceptions

Exception Type | Condition
NotAnAdapterParameter | The parameter passed was not an ADOParameter.

See Also

ADOParameters Class | ADOParameters Members | System.Data.ADO Namespace | ADOParameters.Add Overload List


ADOParameters.Clear

Removes all items from the collection.

[Visual Basic]
Overridable Public Sub Clear()
[C#]
public virtual void Clear();
[C++]
public: virtual void Clear();
[JScript]
public function Clear();

See Also

ADOParameters Class | ADOParameters Members | System.Data.ADO Namespace


ADOParameters.Contains

Indicates whether an ADOParameter is in the collection.

Overload List

Indicates whether an ADOParameter is in the collection with a specified value.

[Visual Basic] Overloads Public Function Contains(Object) As Boolean
[C#] public bool Contains(Object);
[C++] public: bool Contains(Object*);
[JScript] public function Contains(Object) : Boolean;

Indicates whether an ADOParameter is in the collection at a specified index.

[Visual Basic] Overloads Public Function Contains(Integer) As Boolean
[C#] public bool Contains(int);
[C++] public: bool Contains(int);
[JScript] public function Contains(int) : Boolean;

Indicates whether an ADOParameter is in the collection with a specified parameter name.

[Visual Basic] Overloads Public Function Contains(String) As Boolean
[C#] public bool Contains(String);
[C++] public: bool Contains(String*);
[JScript] public function Contains(String) : Boolean;

See Also

ADOParameters Class | ADOParameters Members | System.Data.ADO Namespace


ADOParameters.Contains (Object)

Indicates whether an ADOParameter is in the collection with a specified value.

[Visual Basic]
Overloads Public Function Contains( _
   ByVal value As Object _
) As Boolean
[C#]
public bool Contains(
   object value
);
[C++]
public: bool Contains(
   Object* value
);
[JScript]
public function Contains(
   value : Object
) : Boolean;

Parameters

value
An Object that is the Value of the parameter.

Return Value

true if the collection contains the parameter, otherwise false.

See Also

ADOParameters Class | ADOParameters Members | System.Data.ADO Namespace | ADOParameters.Contains Overload List


ADOParameters.Contains (Int32)

Indicates whether an ADOParameter is in the collection at a specified index.

[Visual Basic]
Overloads Public Function Contains( _
   ByVal index As Integer _
) As Boolean
[C#]
public bool Contains(
   int index
);
[C++]
public: bool Contains(
   int index
);
[JScript]
public function Contains(
   index : int
) : Boolean;

Parameters

index
The zero-based index of the parameter.

Return Value

true if the collection contains the parameter, otherwise false.

See Also

ADOParameters Class | ADOParameters Members | System.Data.ADO Namespace | ADOParameters.Contains Overload List


ADOParameters.Contains (String)

Indicates whether an ADOParameter is in the collection with a specified parameter name.

[Visual Basic]
Overloads Public Function Contains( _
   ByVal value As String _
) As Boolean
[C#]
public bool Contains(
   string value
);
[C++]
public: bool Contains(
   String* value
);
[JScript]
public function Contains(
   value : String
) : Boolean;

Parameters

value
The name of the parameter.

Return Value

true if the collection contains the parameter, otherwise false.

See Also

ADOParameters Class | ADOParameters Members | System.Data.ADO Namespace | ADOParameters.Contains Overload List


ADOParameters.CopyTo

Copies the entire collection to an array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   Array array,
   int index
);
[C++]
public: void CopyTo(
   Array* array,
   int index
);
[JScript]
public function CopyTo(
   array : Array,
   index : int
);

Parameters

array
An Array to copy all instances of ADOParameter to.
index
The index of the created array.

See Also

ADOParameters Class | ADOParameters Members | System.Data.ADO Namespace


ADOParameters.CreateNewItem

[To be supplied.]

[Visual Basic]
Overridable Protected Function CreateNewItem() As ADOParameter
[C#]
protected virtual ADOParameter CreateNewItem();
[C++]
protected: virtual ADOParameter* CreateNewItem();
[JScript]
protected function CreateNewItem() : ADOParameter;

See Also

ADOParameters Class | ADOParameters Members | System.Data.ADO Namespace


ADOParameters.GetEnumerator

[To be supplied.]

[Visual Basic]
Overridable Public Function GetEnumerator() As IEnumerator
[C#]
public virtual IEnumerator GetEnumerator();
[C++]
public: virtual IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

See Also

ADOParameters Class | ADOParameters Members | System.Data.ADO Namespace


ADOParameters.IndexOf

Returns the location of the ADOParameter within the collection.

Overload List

Returns the location of the ADOParameter within the collection given the parameter value.

[Visual Basic] Overloads Public Function IndexOf(Object) As Integer
[C#] public int IndexOf(Object);
[C++] public: int IndexOf(Object*);
[JScript] public function IndexOf(Object) : int;

Returns the location of the ADOParameter within the collection given a parameter name.

[Visual Basic] Overloads Public Function IndexOf(String) As Integer
[C#] public int IndexOf(String);
[C++] public: int IndexOf(String*);
[JScript] public function IndexOf(String) : int;

See Also

ADOParameters Class | ADOParameters Members | System.Data.ADO Namespace


ADOParameters.IndexOf (Object)

Returns the location of the ADOParameter within the collection given the parameter value.

[Visual Basic]
Overloads Public Function IndexOf( _
   ByVal value As Object _
) As Integer
[C#]
public int IndexOf(
   object value
);
[C++]
public: int IndexOf(
   Object* value
);
[JScript]
public function IndexOf(
   value : Object
) : int;

Parameters

value
An Object that is the Value of the parameter.

Return Value

The location of the ADOParameter within the collection.

See Also

ADOParameters Class | ADOParameters Members | System.Data.ADO Namespace | ADOParameters.IndexOf Overload List


ADOParameters.IndexOf (String)

Returns the location of the ADOParameter within the collection given a parameter name.

[Visual Basic]
Overloads Public Function IndexOf( _
   ByVal value As String _
) As Integer
[C#]
public int IndexOf(
   string value
);
[C++]
public: int IndexOf(
   String* value
);
[JScript]
public function IndexOf(
   value : String
) : int;

Parameters

value
The name of the parameter.

See Also

ADOParameters Class | ADOParameters Members | System.Data.ADO Namespace | ADOParameters.IndexOf Overload List


ADOParameters.Remove

Removes the ADOParameter from the collection given the value.

[Visual Basic]
Public Sub Remove( _
   ByVal value As Object _
)
[C#]
public void Remove(
   object value
);
[C++]
public: void Remove(
   Object* value
);
[JScript]
public function Remove(
   value : Object
);

Parameters

value
An Object that is the Value of the parameter.

Exceptions

Exception Type | Condition
ObjectNotInCollectionToRemove | The parameter does not exist.
NotAnAdapterParameter | The parameter is not an ADOParameter.

See Also

ADOParameters Class | ADOParameters Members | System.Data.ADO Namespace


ADOParameters.RemoveAt

Removes the ADOParameter from the collection.

Overload List

Removes the ADOParameter from the collection given the specific index.

[Visual Basic] Overloads Overridable Public Sub RemoveAt(Integer)
[C#] public virtual void RemoveAt(int);
[C++] public: virtual void RemoveAt(int);
[JScript] public function RemoveAt(int);

Removes the ADOParameter from the collection given the parameter name.

[Visual Basic] Overloads Public Sub RemoveAt(String)
[C#] public void RemoveAt(String);
[C++] public: void RemoveAt(String*);
[JScript] public function RemoveAt(String);

See Also

ADOParameters Class | ADOParameters Members | System.Data.ADO Namespace


ADOParameters.RemoveAt (Int32)

Removes the ADOParameter from the collection given the specific index.

[Visual Basic]
Overloads Overridable Public Sub RemoveAt( _
   ByVal index As Integer _
)
[C#]
public virtual void RemoveAt(
   int index
);
[C++]
public: virtual void RemoveAt(
   int index
);
[JScript]
public function RemoveAt(
   index : int
);

Parameters

index
The zero-based index of the parameter.

Exceptions

Exception Type | Condition
ParametersMappingIndex | The index specified does not exist.

Remarks

Notes to Inheritors: When overriding RemoveAt in a derived class, be sure to call the base class's RemoveAt method.

See Also

ADOParameters Class | ADOParameters Members | System.Data.ADO Namespace | ADOParameters.RemoveAt Overload List


ADOParameters.RemoveAt (String)

Removes the ADOParameter from the collection given the parameter name.

[Visual Basic]
Overloads Public Sub RemoveAt( _
   ByVal value As String _
)
[C#]
public void RemoveAt(
   string value
);
[C++]
public: void RemoveAt(
   String* value
);
[JScript]
public function RemoveAt(
   value : String
);

Parameters

value
The name of the parameter.

Exceptions

Exception Type | Condition
ParametersIndex | A parameter does not exist with the specified name.

See Also

ADOParameters Class | ADOParameters Members | System.Data.ADO Namespace | ADOParameters.RemoveAt Overload List


ADOParameters.ShouldPersistAll

Indicates whether parameters are persisting.

[Visual Basic]
Public Function ShouldPersistAll() As Boolean
[C#]
public bool ShouldPersistAll();
[C++]
public: bool ShouldPersistAll();
[JScript]
public function ShouldPersistAll() : Boolean;

Return Value

true if the parameters are persisting, otherwise false.

Remarks

If an ADOParameter exists within the collection, it will be persisted until removed or the collection is destroyed.

See Also

ADOParameters Class | ADOParameters Members | System.Data.ADO Namespace


ADOProperties Class

[To be supplied.]

Object
ADOProperties

[Visual Basic]
NotInheritable Public Class ADOProperties
   Implements IProperties, ICollection, IEnumerable
[C#]
public sealed class ADOProperties : IProperties, ICollection,
   IEnumerable
[C++]
public __gc __sealed class ADOProperties : public IProperties,
   ICollection, IEnumerable
[JScript]
public class ADOProperties implements IProperties, ICollection,
   IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.ADO

Assembly: System.Data.dll

See Also

ADOProperties Members | System.Data.ADO Namespace


ADOProperties Members

Public:

Properties

All | [To be supplied.]
Count | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the ADOProperties class.
Parent | [To be supplied.]

Methods

Contains | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ADOProperties Class | System.Data.ADO Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ADOProperties Properties

The properties of the ADOProperties class are listed below. For a complete list of ADOProperties class members, see the ADOProperties Members topic.

Public:

All | [To be supplied.]
Count | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the ADOProperties class.
Parent | [To be supplied.]

See Also

ADOProperties Class | System.Data.ADO Namespace


ADOProperties.All

[To be supplied.]

[Visual Basic]
Public ReadOnly Property All As ADOProperty ()
[C#]
public ADOProperty[] All {get;}
[C++]
public: __property ADOProperty* get_All();
[JScript]
public function get All() : ADOProperty[];

See Also

ADOProperties Class | ADOProperties Members | System.Data.ADO Namespace


ADOProperties.Count

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

See Also

ADOProperties Class | ADOProperties Members | System.Data.ADO Namespace


ADOProperties.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the ADOProperties class.

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Default ReadOnly Property Item(Integer) As ADOProperty
[C#] public ADOProperty this[int] {get;}
[C++] public: __property ADOProperty* get_Item(int);
[JScript] ADOProperties.Item (int)

[To be supplied.]

[Visual Basic] Overloads Public Default ReadOnly Property Item(String) As ADOProperty
[C#] public ADOProperty this[String] {get;}
[C++] public: __property ADOProperty* get_Item(String*);
[JScript] ADOProperties.Item (String)

See Also

ADOProperties Class | ADOProperties Members | System.Data.ADO Namespace


ADOProperties.Item (Int32)

[To be supplied.]

[C#] In C#, this member is the indexer for the ADOProperties class.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
   ByVal index As Integer _
) As ADOProperty
[C#]
public ADOProperty this[
   int index
] {get;}
[C++]
public: __property ADOProperty* get_Item(
   int index
);
[JScript]
returnValue = ADOPropertiesObject.Item(index);
-or-
returnValue = ADOPropertiesObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
[To be supplied.]

Parameters [Visual Basic, C#, C++]

index
[To be supplied.]

See Also

ADOProperties Class | ADOProperties Members | System.Data.ADO Namespace | ADOProperties.Item Overload List


ADOProperties.Item (String)

[To be supplied.]

[C#] In C#, this member is the indexer for the ADOProperties class.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
   ByVal propertyName As String _
) As ADOProperty
[C#]
public ADOProperty this[
   string propertyName
] {get;}
[C++]
public: __property ADOProperty* get_Item(
   String* propertyName
);
[JScript]
returnValue = ADOPropertiesObject.Item(propertyName);
-or-
returnValue = ADOPropertiesObject(propertyName);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

propertyName
[To be supplied.]

Parameters [Visual Basic, C#, C++]

propertyName
[To be supplied.]

See Also

ADOProperties Class | ADOProperties Members | System.Data.ADO Namespace | ADOProperties.Item Overload List


ADOProperties.Parent

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Parent As Object
[C#]
public object Parent {get;}
[C++]
public: __property Object* get_Parent();
[JScript]
public function get Parent() : Object;

See Also

ADOProperties Class | ADOProperties Members | System.Data.ADO Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ADOProperties Methods

The methods of the ADOProperties class are listed below. For a complete list of ADOProperties class members, see the ADOProperties Members topic.

Public:

Contains | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ADOProperties Class | System.Data.ADO Namespace


ADOProperties.Contains

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function Contains(Object) As Boolean
[C#] public bool Contains(Object);
[C++] public: bool Contains(Object*);
[JScript] public function Contains(Object) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function Contains(String) As Boolean
[C#] public bool Contains(String);
[C++] public: bool Contains(String*);
[JScript] public function Contains(String) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function Contains(Integer) As Boolean
[C#] public bool Contains(int);
[C++] public: bool Contains(int);
[JScript] public function Contains(int) : Boolean;

See Also

ADOProperties Class | ADOProperties Members | System.Data.ADO Namespace


ADOProperties.Contains (Object)

[To be supplied.]

[Visual Basic]
Overloads Public Function Contains( _
   ByVal value As Object _
) As Boolean
[C#]
public bool Contains(
   object value
);
[C++]
public: bool Contains(
   Object* value
);
[JScript]
public function Contains(
   value : Object
) : Boolean;

Parameters

value
[To be supplied.]

See Also

ADOProperties Class | ADOProperties Members | System.Data.ADO Namespace | ADOProperties.Contains Overload List


ADOProperties.Contains (String)

[To be supplied.]

[Visual Basic]
Overloads Public Function Contains( _
   ByVal value As String _
) As Boolean
[C#]
public bool Contains(
   string value
);
[C++]
public: bool Contains(
   String* value
);
[JScript]
public function Contains(
   value : String
) : Boolean;

Parameters

value
[To be supplied.]

See Also

ADOProperties Class | ADOProperties Members | System.Data.ADO Namespace | ADOProperties.Contains Overload List


ADOProperties.Contains (Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Function Contains( _
   ByVal value As Integer _
) As Boolean
[C#]
public bool Contains(
   int value
);
[C++]
public: bool Contains(
   int value
);
[JScript]
public function Contains(
   value : int
) : Boolean;

Parameters

value
[To be supplied.]

See Also

ADOProperties Class | ADOProperties Members | System.Data.ADO Namespace | ADOProperties.Contains Overload List


ADOProperties.GetEnumerator

[To be supplied.]

[Visual Basic]
Overridable Public Function GetEnumerator() As IEnumerator
[C#]
public virtual IEnumerator GetEnumerator();
[C++]
public: virtual IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

See Also

ADOProperties Class | ADOProperties Members | System.Data.ADO Namespace


ADOProperties.IndexOf

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function IndexOf(Object) As Integer
[C#] public int IndexOf(Object);
[C++] public: int IndexOf(Object*);
[JScript] public function IndexOf(Object) : int;

[To be supplied.]

[Visual Basic] Overloads Public Function IndexOf(String) As Integer
[C#] public int IndexOf(String);
[C++] public: int IndexOf(String*);
[JScript] public function IndexOf(String) : int;

See Also

ADOProperties Class | ADOProperties Members | System.Data.ADO Namespace


ADOProperties.IndexOf (Object)

[To be supplied.]

[Visual Basic]
Overloads Public Function IndexOf( _
   ByVal value As Object _
) As Integer
[C#]
public int IndexOf(
   object value
);
[C++]
public: int IndexOf(
   Object* value
);
[JScript]
public function IndexOf(
   value : Object
) : int;

Parameters

value
[To be supplied.]

See Also

ADOProperties Class | ADOProperties Members | System.Data.ADO Namespace | ADOProperties.IndexOf Overload List


ADOProperties.IndexOf (String)

[To be supplied.]

[Visual Basic]
Overloads Public Function IndexOf( _
   ByVal value As String _
) As Integer
[C#]
public int IndexOf(
   string value
);
[C++]
public: int IndexOf(
   String* value
);
[JScript]
public function IndexOf(
   value : String
) : int;

Parameters

value
[To be supplied.]

See Also

ADOProperties Class | ADOProperties Members | System.Data.ADO Namespace | ADOProperties.IndexOf Overload List


ADOProperty Class

[To be supplied.]

Object
ADOProperty

[Visual Basic]
NotInheritable Public Class ADOProperty
   Implements IProperty
[C#]
public sealed class ADOProperty : IProperty
[C++]
public __gc __sealed class ADOProperty : public IProperty
[JScript]
public class ADOProperty implements IProperty

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.ADO

Assembly: System.Data.dll

See Also

ADOProperty Members | System.Data.ADO Namespace


ADOProperty Members

Public:

Properties

Attributes | [To be supplied.]
DataType | [To be supplied.]
Parent | [To be supplied.]
PropertyName | [To be supplied.]
Value | property values are applied immediately to OLE DB

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ADOProperty Class | System.Data.ADO Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ADOProperty Properties

The properties of the ADOProperty class are listed below. For a complete list of ADOProperty class members, see the ADOProperty Members topic.

Public:

Attributes | [To be supplied.]
DataType | [To be supplied.]
Parent | [To be supplied.]
PropertyName | [To be supplied.]
Value | property values are applied immediately to OLE DB

See Also

ADOProperty Class | System.Data.ADO Namespace


ADOProperty.Attributes

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Attributes As _
   PropertyAttributes
[C#]
public PropertyAttributes Attributes {virtual get;}
[C++]
public: __property virtual PropertyAttributes get_Attributes();
[JScript]
public function get Attributes() : PropertyAttributes;

See Also

ADOProperty Class | ADOProperty Members | System.Data.ADO Namespace


ADOProperty.DataType

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DataType As Type
[C#]
public Type DataType {virtual get;}
[C++]
public: __property virtual Type* get_DataType();
[JScript]
public function get DataType() : Type;

See Also

ADOProperty Class | ADOProperty Members | System.Data.ADO Namespace


ADOProperty.Parent

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Parent As Object
[C#]
public object Parent {virtual get;}
[C++]
public: __property virtual Object* get_Parent();
[JScript]
public function get Parent() : Object;

See Also

ADOProperty Class | ADOProperty Members | System.Data.ADO Namespace


ADOProperty.PropertyName

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property PropertyName As String
[C#]
public string PropertyName {virtual get;}
[C++]
public: __property virtual String* get_PropertyName();
[JScript]
public function get PropertyName() : String;

See Also

ADOProperty Class | ADOProperty Members | System.Data.ADO Namespace


ADOProperty.Value

property values are applied immediately to OLE DB

[Visual Basic]
Overridable Public Property Value As Object
[C#]
public object Value {virtual get; virtual set;}
[C++]
public: __property virtual Object* get_Value();
public: __property virtual void set_Value(Object*);
[JScript]
public function get Value() : Object;
public function set Value(Object);

See Also

ADOProperty Class | ADOProperty Members | System.Data.ADO Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ADOProperty Methods

The methods of the ADOProperty class are listed below. For a complete list of ADOProperty class members, see the ADOProperty Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ADOProperty Class | System.Data.ADO Namespace


ADOProperty.ToString

[To be supplied.]

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

ADOProperty Class | ADOProperty Members | System.Data.ADO Namespace


ADORowUpdatedEventArgs Class

[To be supplied.]

Object
EventArgs
RowUpdatedEventArgs
ADORowUpdatedEventArgs

[Visual Basic]
Public Class ADORowUpdatedEventArgs
   Inherits RowUpdatedEventArgs
[C#]
public class ADORowUpdatedEventArgs : RowUpdatedEventArgs
[C++]
public __gc class ADORowUpdatedEventArgs : public
   RowUpdatedEventArgs
[JScript]
public class ADORowUpdatedEventArgs extends RowUpdatedEventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.ADO

Assembly: System.Data.dll

See Also

ADORowUpdatedEventArgs Members | System.Data.ADO Namespace


ADORowUpdatedEventArgs Members

Public:

Constructor

ADORowUpdatedEventArgs Constructor [To be supplied.]

Properties

Command (inherited from RowUpdatedEventArgs) | [To be supplied.]
CommandType (inherited from RowUpdatedEventArgs) | [To be supplied.]
Errors (inherited from RowUpdatedEventArgs) | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
RecordsAffected (inherited from RowUpdatedEventArgs) | [To be supplied.]
Row (inherited from RowUpdatedEventArgs) | [To be supplied.]
Status (inherited from RowUpdatedEventArgs) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ADORowUpdatedEventArgs Class | System.Data.ADO Namespace


ADORowUpdatedEventArgs Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal dataRow As DataRow, _
   ByVal command As DBCommand, _
   ByVal commandType As String _
)
[C#]
public ADORowUpdatedEventArgs(
   DataRow dataRow,
   DBCommand command,
   string commandType
);
[C++]
public: ADORowUpdatedEventArgs(
   DataRow* dataRow,
   DBCommand* command,
   String* commandType
);
[JScript]
public function ADORowUpdatedEventArgs(
   dataRow : DataRow,
   command : DBCommand,
   commandType : String
);

Parameters

dataRow
[To be supplied.]
command
[To be supplied.]
commandType
[To be supplied.]

See Also

ADORowUpdatedEventArgs Class | ADORowUpdatedEventArgs Members | System.Data.ADO Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ADORowUpdatedEventArgs Properties

The properties of the ADORowUpdatedEventArgs class are listed below. For a complete list of ADORowUpdatedEventArgs class members, see the ADORowUpdatedEventArgs Members topic.

Public:

Command (inherited from RowUpdatedEventArgs) | [To be supplied.]
CommandType (inherited from RowUpdatedEventArgs) | [To be supplied.]
Errors (inherited from RowUpdatedEventArgs) | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
RecordsAffected (inherited from RowUpdatedEventArgs) | [To be supplied.]
Row (inherited from RowUpdatedEventArgs) | [To be supplied.]
Status (inherited from RowUpdatedEventArgs) | [To be supplied.]

See Also

ADORowUpdatedEventArgs Class | System.Data.ADO Namespace


ADORowUpdatedEventArgs.Command

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Command As ADOCommand
[C#]
public ADOCommand Command {new get;}
[C++]
public: __property ADOCommand* get_Command();
[JScript]
public function get Command() : ADOCommand;

See Also

ADORowUpdatedEventArgs Class | ADORowUpdatedEventArgs Members | System.Data.ADO Namespace


ADORowUpdatedEventHandler Delegate

[To be supplied.]

[Visual Basic]
Public Delegate Sub ADORowUpdatedEventHandler( _
   ByVal sender As Object, _
   ByVal e As ADORowUpdatedEventArgs _
)
[C#]
public delegate void ADORowUpdatedEventHandler(
   object sender,
   ADORowUpdatedEventArgs e
);
[C++]
public __gc __delegate void ADORowUpdatedEventHandler(
   Object* sender,
   ADORowUpdatedEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the ADORowUpdatedEventHandler delegate declaration.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.ADO

Assembly: System.Data.dll

See Also

System.Data.ADO Namespace


ADORowUpdatingEventArgs Class

[To be supplied.]

Object
EventArgs
RowUpdatingEventArgs
ADORowUpdatingEventArgs

[Visual Basic]
Public Class ADORowUpdatingEventArgs
   Inherits RowUpdatingEventArgs
[C#]
public class ADORowUpdatingEventArgs : RowUpdatingEventArgs
[C++]
public __gc class ADORowUpdatingEventArgs : public
   RowUpdatingEventArgs
[JScript]
public class ADORowUpdatingEventArgs extends RowUpdatingEventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.ADO

Assembly: System.Data.dll

See Also

ADORowUpdatingEventArgs Members | System.Data.ADO Namespace


ADORowUpdatingEventArgs Members

Public:

Constructor

ADORowUpdatingEventArgs Constructor [To be supplied.]

Properties

Command (inherited from RowUpdatingEventArgs) | [To be supplied.]
CommandType (inherited from RowUpdatingEventArgs) | [To be supplied.]
Errors (inherited from RowUpdatingEventArgs) | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
Row (inherited from RowUpdatingEventArgs) | [To be supplied.]
Status (inherited from RowUpdatingEventArgs) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ADORowUpdatingEventArgs Class | System.Data.ADO Namespace


ADORowUpdatingEventArgs Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal dataRow As DataRow, _
   ByVal command As DBCommand, _
   ByVal commandType As String _
)
[C#]
public ADORowUpdatingEventArgs(
   DataRow dataRow,
   DBCommand command,
   string commandType
);
[C++]
public: ADORowUpdatingEventArgs(
   DataRow* dataRow,
   DBCommand* command,
   String* commandType
);
[JScript]
public function ADORowUpdatingEventArgs(
   dataRow : DataRow,
   command : DBCommand,
   commandType : String
);

Parameters

dataRow
[To be supplied.]
command
[To be supplied.]
commandType
[To be supplied.]

See Also

ADORowUpdatingEventArgs Class | ADORowUpdatingEventArgs Members | System.Data.ADO Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ADORowUpdatingEventArgs Properties

The properties of the ADORowUpdatingEventArgs class are listed below. For a complete list of ADORowUpdatingEventArgs class members, see the ADORowUpdatingEventArgs Members topic.

Public:

Command (inherited from RowUpdatingEventArgs) | [To be supplied.]
CommandType (inherited from RowUpdatingEventArgs) | [To be supplied.]
Errors (inherited from RowUpdatingEventArgs) | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
Row (inherited from RowUpdatingEventArgs) | [To be supplied.]
Status (inherited from RowUpdatingEventArgs) | [To be supplied.]

See Also

ADORowUpdatingEventArgs Class | System.Data.ADO Namespace


ADORowUpdatingEventArgs.Command

[To be supplied.]

[Visual Basic]
Public Property Command As ADOCommand
[C#]
public ADOCommand Command {new get; new set;}
[C++]
public: __property ADOCommand* get_Command();
public: __property void set_Command(ADOCommand*);
[JScript]
public function get Command() : ADOCommand;
public function set Command(ADOCommand);

See Also

ADORowUpdatingEventArgs Class | ADORowUpdatingEventArgs Members | System.Data.ADO Namespace


ADORowUpdatingEventHandler Delegate

[To be supplied.]

[Visual Basic]
Public Delegate Sub ADORowUpdatingEventHandler( _
   ByVal sender As Object, _
   ByVal e As ADORowUpdatingEventArgs _
)
[C#]
public delegate void ADORowUpdatingEventHandler(
   object sender,
   ADORowUpdatingEventArgs e
);
[C++]
public __gc __delegate void ADORowUpdatingEventHandler(
   Object* sender,
   ADORowUpdatingEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the ADORowUpdatingEventHandler delegate declaration.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.ADO

Assembly: System.Data.dll

See Also

System.Data.ADO Namespace


ADOSchemaMappingEventArgs Class

[To be supplied.]

Object
EventArgs
SchemaMappingEventArgs
ADOSchemaMappingEventArgs

[Visual Basic]
Public Class ADOSchemaMappingEventArgs
   Inherits SchemaMappingEventArgs
[C#]
public class ADOSchemaMappingEventArgs : SchemaMappingEventArgs
[C++]
public __gc class ADOSchemaMappingEventArgs : public
   SchemaMappingEventArgs
[JScript]
public class ADOSchemaMappingEventArgs extends
   SchemaMappingEventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.ADO

Assembly: System.Data.dll

See Also

ADOSchemaMappingEventArgs Members | System.Data.ADO Namespace


ADOSchemaMappingEventArgs Members

Public:

Properties

Command (inherited from SchemaMappingEventArgs) | [To be supplied.]
DataSet (inherited from SchemaMappingEventArgs) | [To be supplied.]
DataTable (inherited from SchemaMappingEventArgs) | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
PrimaryKey (inherited from SchemaMappingEventArgs) | [To be supplied.]
SchemaTable (inherited from SchemaMappingEventArgs) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ADOSchemaMappingEventArgs Class | System.Data.ADO Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ADOSchemaMappingEventArgs Properties

The properties of the ADOSchemaMappingEventArgs class are listed below. For a complete list of ADOSchemaMappingEventArgs class members, see the ADOSchemaMappingEventArgs Members topic.

Public:

Command (inherited from SchemaMappingEventArgs) | [To be supplied.]
DataSet (inherited from SchemaMappingEventArgs) | [To be supplied.]
DataTable (inherited from SchemaMappingEventArgs) | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
PrimaryKey (inherited from SchemaMappingEventArgs) | [To be supplied.]
SchemaTable (inherited from SchemaMappingEventArgs) | [To be supplied.]

See Also

ADOSchemaMappingEventArgs Class | System.Data.ADO Namespace


ADOSchemaMappingEventArgs.Command

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Command As ADOCommand
[C#]
public ADOCommand Command {new get;}
[C++]
public: __property ADOCommand* get_Command();
[JScript]
public function get Command() : ADOCommand;

See Also

ADOSchemaMappingEventArgs Class | ADOSchemaMappingEventArgs Members | System.Data.ADO Namespace


ADOSchemaMappingEventHandler Delegate

[To be supplied.]

[Visual Basic]
Public Delegate Sub ADOSchemaMappingEventHandler( _
   ByVal sender As Object, _
   ByVal e As ADOSchemaMappingEventArgs _
)
[C#]
public delegate void ADOSchemaMappingEventHandler(
   object sender,
   ADOSchemaMappingEventArgs e
);
[C++]
public __gc __delegate void ADOSchemaMappingEventHandler(
   Object* sender,
   ADOSchemaMappingEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the ADOSchemaMappingEventHandler delegate declaration.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.ADO

Assembly: System.Data.dll

See Also

System.Data.ADO Namespace


System.Data.Design

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Data.Design Namespace

Classes

Class | Description
AdapterDesignUtil | [To be supplied.]
ADPM | [To be supplied.]
ADPMessage | [To be supplied.]
BitMaskSelector | [To be supplied.]
CascadeValueEditor | [To be supplied.]
ColumnsCollectionEditor | Collection ValueEditor for ColumsCollection
ColumnTypeEditor | [To be supplied.]
ConstraintsCollectionEditor | Collection ValueEditor for ConstraintsCollection
DataSourceDesigner | [To be supplied.]
DataSourceValueEditor | [To be supplied.]
DataTableValueEditor | [To be supplied.]
DataViewRowStateEditor | [To be supplied.]
DBConnectionEditor | [To be supplied.]
DBParametersEditor | CollectionEditor for IDataParameters property
ParentRelationValueEditor | [To be supplied.]
PrimaryKeyValueEditor | [To be supplied.]
RelationsCollectionEditor | [To be supplied.]
RowStateEditor | RowStateEditor value editor for DataBinder's RowStateFilter property.
TablesCollectionEditor | Collection ValueEditor for TablesCollection
UICreationHelper | [To be supplied.]


AdapterDesignUtil Class

[To be supplied.]

Object
AdapterDesignUtil

[Visual Basic]
Public Class AdapterDesignUtil
[C#]
public class AdapterDesignUtil
[C++]
public __gc class AdapterDesignUtil
[JScript]
public class AdapterDesignUtil

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Design

Assembly: System.Data.Design.dll

See Also

AdapterDesignUtil Members | System.Data.Design Namespace


AdapterDesignUtil Members

Public:

Constructor

AdapterDesignUtil Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ISEmpty | Do not use, will become internal when the NGWS runtime supprts assemblies determines if a string is non-null and non-empty.
MakeErrorString | [To be supplied.]
NotEmpty | Do not use, will become internal when the NGWS runtime supprts assemblies determines if a string is non-null and non-empty.
ReportError | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AdapterDesignUtil Class | System.Data.Design Namespace


AdapterDesignUtil Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public AdapterDesignUtil();
[C++]
public: AdapterDesignUtil();
[JScript]
public function AdapterDesignUtil();

See Also

AdapterDesignUtil Class | AdapterDesignUtil Members | System.Data.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AdapterDesignUtil Methods

The methods of the AdapterDesignUtil class are listed below. For a complete list of AdapterDesignUtil class members, see the AdapterDesignUtil Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ISEmpty | Do not use, will become internal when the NGWS runtime supprts assemblies determines if a string is non-null and non-empty.
MakeErrorString | [To be supplied.]
NotEmpty | Do not use, will become internal when the NGWS runtime supprts assemblies determines if a string is non-null and non-empty.
ReportError | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AdapterDesignUtil Class | System.Data.Design Namespace


AdapterDesignUtil.ISEmpty

Do not use, will become internal when the NGWS runtime supprts assemblies determines if a string is non-null and non-empty.

[Visual Basic]
Public Shared Function ISEmpty( _
   ByVal str As String _
) As Boolean
[C#]
public static bool ISEmpty(
   string str
);
[C++]
public: static bool ISEmpty(
   String* str
);
[JScript]
public static function ISEmpty(
   str : String
) : Boolean;

Parameters

str
[To be supplied.]

See Also

AdapterDesignUtil Class | AdapterDesignUtil Members | System.Data.Design Namespace


AdapterDesignUtil.MakeErrorString

[To be supplied.]

[Visual Basic]
Public Shared Function MakeErrorString( _
   ByVal str1 As String, _
   ByVal e As Exception _
) As String
[C#]
public static string MakeErrorString(
   string str1,
   Exception e
);
[C++]
public: static String* MakeErrorString(
   String* str1,
   Exception* e
);
[JScript]
public static function MakeErrorString(
   str1 : String,
   e : Exception
) : String;

Parameters

str1
[To be supplied.]
e
[To be supplied.]

See Also

AdapterDesignUtil Class | AdapterDesignUtil Members | System.Data.Design Namespace


AdapterDesignUtil.NotEmpty

Do not use, will become internal when the NGWS runtime supprts assemblies determines if a string is non-null and non-empty.

[Visual Basic]
Public Shared Function NotEmpty( _
   ByVal str As String _
) As Boolean
[C#]
public static bool NotEmpty(
   string str
);
[C++]
public: static bool NotEmpty(
   String* str
);
[JScript]
public static function NotEmpty(
   str : String
) : Boolean;

Parameters

str
[To be supplied.]

See Also

AdapterDesignUtil Class | AdapterDesignUtil Members | System.Data.Design Namespace


AdapterDesignUtil.ReportError

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Shared Sub ReportError(String)
[C#] public static void ReportError(String);
[C++] public: static void ReportError(String*);
[JScript] public static function ReportError(String);

Report error in a standard way

[Visual Basic] Overloads Public Shared Sub ReportError(String, String, Integer)
[C#] public static void ReportError(String, String, int);
[C++] public: static void ReportError(String*, String*, int);
[JScript] public static function ReportError(String, String, int);

See Also

AdapterDesignUtil Class | AdapterDesignUtil Members | System.Data.Design Namespace


AdapterDesignUtil.ReportError (String)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Sub ReportError( _
   ByVal errString As String _
)
[C#]
public static void ReportError(
   string errString
);
[C++]
public: static void ReportError(
   String* errString
);
[JScript]
public static function ReportError(
   errString : String
);

Parameters

errString
[To be supplied.]

See Also

AdapterDesignUtil Class | AdapterDesignUtil Members | System.Data.Design Namespace | AdapterDesignUtil.ReportError Overload List


AdapterDesignUtil.ReportError (String, String, Int32)

Report error in a standard way

[Visual Basic]
Overloads Public Shared Sub ReportError( _
   ByVal errString As String, _
   ByVal title As String, _
   ByVal iconInformation As Integer _
)
[C#]
public static void ReportError(
   string errString,
   string title,
   int iconInformation
);
[C++]
public: static void ReportError(
   String* errString,
   String* title,
   int iconInformation
);
[JScript]
public static function ReportError(
   errString : String,
   title : String,
   iconInformation : int
);

Parameters

errString
[To be supplied.]
title
[To be supplied.]
iconInformation
[To be supplied.]

See Also

AdapterDesignUtil Class | AdapterDesignUtil Members | System.Data.Design Namespace | AdapterDesignUtil.ReportError Overload List


ADPM Class

[To be supplied.]

Object
ADPM

[Visual Basic]
Public Class ADPM
[C#]
public class ADPM
[C++]
public __gc class ADPM
[JScript]
public class ADPM

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Design

Assembly: System.Data.Design.dll

See Also

ADPM Members | System.Data.Design Namespace


ADPM Members

Public:

Constructor

ADPM Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GenerateMidTierCode | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
NotDerivedFromBaseDataSetAdapter | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ADPM Class | System.Data.Design Namespace


ADPM Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ADPM();
[C++]
public: ADPM();
[JScript]
public function ADPM();

See Also

ADPM Class | ADPM Members | System.Data.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ADPM Methods

The methods of the ADPM class are listed below. For a complete list of ADPM class members, see the ADPM Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GenerateMidTierCode | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
NotDerivedFromBaseDataSetAdapter | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ADPM Class | System.Data.Design Namespace


ADPM.GenerateMidTierCode

[To be supplied.]

[Visual Basic]
Public Shared Function GenerateMidTierCode() As Exception
[C#]
public static Exception GenerateMidTierCode();
[C++]
public: static Exception* GenerateMidTierCode();
[JScript]
public static function GenerateMidTierCode() : Exception;

See Also

ADPM Class | ADPM Members | System.Data.Design Namespace


ADPM.NotDerivedFromBaseDataSetAdapter

[To be supplied.]

[Visual Basic]
Public Shared Function NotDerivedFromBaseDataSetAdapter() As _
   Exception
[C#]
public static Exception NotDerivedFromBaseDataSetAdapter();
[C++]
public: static Exception* NotDerivedFromBaseDataSetAdapter();
[JScript]
public static function NotDerivedFromBaseDataSetAdapter() :
   Exception;

See Also

ADPM Class | ADPM Members | System.Data.Design Namespace


ADPMessage Class

[To be supplied.]

Object
ADPMessage

[Visual Basic]
Public Class ADPMessage
[C#]
public class ADPMessage
[C++]
public __gc class ADPMessage
[JScript]
public class ADPMessage

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Design

Assembly: System.Data.Design.dll

See Also

ADPMessage Members | System.Data.Design Namespace


ADPMessage Members

Public:

Constructor

ADPMessage Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
MidTierMsgTitle | [To be supplied.]
MissingCodeSourceFile | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ADPMessage Class | System.Data.Design Namespace


ADPMessage Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ADPMessage();
[C++]
public: ADPMessage();
[JScript]
public function ADPMessage();

See Also

ADPMessage Class | ADPMessage Members | System.Data.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ADPMessage Methods

The methods of the ADPMessage class are listed below. For a complete list of ADPMessage class members, see the ADPMessage Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
MidTierMsgTitle | [To be supplied.]
MissingCodeSourceFile | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ADPMessage Class | System.Data.Design Namespace


ADPMessage.MidTierMsgTitle

[To be supplied.]

[Visual Basic]
Public Shared Function MidTierMsgTitle() As String
[C#]
public static string MidTierMsgTitle();
[C++]
public: static String* MidTierMsgTitle();
[JScript]
public static function MidTierMsgTitle() : String;

See Also

ADPMessage Class | ADPMessage Members | System.Data.Design Namespace


ADPMessage.MissingCodeSourceFile

[To be supplied.]

[Visual Basic]
Public Shared Function MissingCodeSourceFile() As String
[C#]
public static string MissingCodeSourceFile();
[C++]
public: static String* MissingCodeSourceFile();
[JScript]
public static function MissingCodeSourceFile() : String;

See Also

ADPMessage Class | ADPMessage Members | System.Data.Design Namespace


BitMaskSelector Class

[To be supplied.]

Object
MarshalByRefObject
MarshalByRefComponent
Control
RichControl
TreeView
BitMaskSelector

[Visual Basic]
Public Class BitMaskSelector
   Inherits TreeView
[C#]
public class BitMaskSelector : TreeView
[C++]
public __gc class BitMaskSelector : public TreeView
[JScript]
public class BitMaskSelector extends TreeView

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Design

Assembly: System.Data.Design.dll

See Also

BitMaskSelector Members | System.Data.Design Namespace


BitMaskSelector Members

Public:

Constructor

BitMaskSelector Constructor labels- strings to be shown in BitMaskSelector bitmasks- int valaues correspond with labels.

Properties

AccessibilityObject (inherited from RichControl) | The Accessibility Object for this RichControl
AccessibleDefaultActionDescription (inherited from RichControl) | The default action description of the control
AccessibleDescription (inherited from RichControl) | The accessible description of the control
AccessibleHelpProvider (inherited from RichControl) | The help provider for this RichControl
AccessibleName (inherited from RichControl) | The accessible name of the control
AccessibleRole (inherited from RichControl) | The accessible role of the control
AllowDrop (inherited from RichControl) | The allowDrop property. If allowDrop is set to true then this control will allow drag and drop operations and events to be used.
AllowTransparency (inherited from RichControl) | Determines if the control should be allowed to have the opacity adjusted. This is primarily a performance optimization, in that you can always set the opacity to any value, and that will force AllowTransparency to true. However, setting the opacity to any given value will switch the control into layered mode. By setting the AllowTransparency property to false the control will actually switch out of layered mode, which provides better performance if you don't intend to adjust the opacity.
Anchor (inherited from RichControl) | The current value of the anchor property. The anchor property determines which edges of the control are anchored to the container's edges.
BackColor (inherited from TreeView) | The background color for this control. Specifying null for this parameter sets the control's background color to its parent's background color.
BackgroundImage (inherited from TreeView) | [To be supplied.]
BindingManager (inherited from RichControl) | [To be supplied.]
Bindings (inherited from RichControl) | Retrieves the bindings for this control.
BorderStyle (inherited from TreeView) | The border style of the window.
Bottom (inherited from Control) | The bottom coordinate of this control.
Bounds (inherited from Control) | The bounds of this control. This is the window coordinates of the control in parent client coordinates.
CanFocus (inherited from Control) | Checks if this control can receive focus. The result is true if the control has a handle and if it and all of its parent controls are both visible and enabled.
CanSelect (inherited from Control) | Checks if this control can be selected. The result is true if the control is contained in a form and if all of its parent controls are both visible and enabled.
Capture (inherited from Control) | If this control has captured the mouse then this will return true.
CausesValidation (inherited from Control) | Indicates whether entering this control causes validation on the controls requiring validation. This is set to false usually for things like the Help button, etc...
CheckBoxes (inherited from TreeView) | The value of the CheckBoxes property. The CheckBoxes property determines if check boxes are shown next to node in the tree view.
ClientRectangle (inherited from Control) | The client rect of the control.
ClientSize (inherited from Control) | The size of the clientRect.
CompanyName (inherited from RichControl) | Retrieves the company name of this specific component.
ContainsFocus (inherited from Control) | Indicates whether the control or one of its children currently has the system focus.
ContextMenu (inherited from RichControl) | The contextMenu associated with this control. The contextMenu will be shown when the user right clicks the mouse on the control.
Controls (inherited from Control) | Collection of child controls.
Created (inherited from Control) | Returns true if the control has been created.
Cursor (inherited from RichControl) | Retrieves the cursor that will be displayed when the mouse is over this control.
DisplayRectangle (inherited from Control) | Returns the client rect of the display area of the control. For the base control class, this is identical to getClientRect. However, inheriting controls may want to change this if their client area differs from their display area.
Disposed (inherited from Control) | Indicates that the control has been disposed, and is no longer a valid Windows control even though the object instance is still alive.
Disposing (inherited from Control) | Indicates that the control is in the process of being beendisposed, and is no longer a valid Windows control even though the object instance is still alive.
Dock (inherited from RichControl) | The dock property. The dock property controls to which edge of the container this control is docked to. For example, when docked to the top of the container, the control will be displayed flush at the top of the container, extending the length of the container.
Enabled (inherited from Control) | The current enabled state of this control.
Focused (inherited from Control) | Returns true if this control has focus.
Font (inherited from RichControl) | Retrieves the current font for this control. This will be the font used by default for painting and text in the control.
ForeColor (inherited from TreeView) | The current foreground color for this control, which is the color the control uses to draw its text.
FullRowSelect (inherited from TreeView) | Determines whether the selection highlight spans across the width of the TreeView.
Handle (inherited from Control) | The HWND handle that this control is bound to. If the handle has not yet been created, this will force handle creation.
HandleCreated (inherited from Control) | Whether or not this control has a handle associated with it.
Height (inherited from Control) | The height of this control
HideSelection (inherited from TreeView) | The hideSelection property specifies whether the selected node will be highlighted even when the TreeView loses focus.
HotTracking (inherited from TreeView) | The value of the HotTracking property. The HotTracking property determines if nodes are highlighted as the mousepointer passes over them.
ImageIndex (inherited from TreeView) | The default image index for nodes in the tree view.
ImageList (inherited from TreeView) | Returns the image list control that is bound to the tree view.
IMEMode (inherited from RichControl) | Specifies a value that determines the IME (Input Method Editor) status of the object when that object is selected.
Indent (inherited from TreeView) | The indentation level in pixels.
InvokeRequired (inherited from RichControl) | Determines if the caller must call invoke when making method calls to this control. Controls in WinForms are bound to a specific thread, and are not thread safe. Therefore, if you are calling a control's method from a different thread, you must use the control's invoke method to marshal the call to the proper thread. This function can be used to determine if you must call invoke, which can be handy if you don't know what thread owns a control. There are five functions on a control that are safe to call from any thread: GetInvokeRequired, Invoke, BeginInvoke, EndInvoke and CreateGraphics. For all other metohd calls, you should use one of the invoke methods.
IsAccessible (inherited from RichControl) | Indicates whether or not this control is an accessible control i.e. whether it should be visible to accessibility applications.
ItemHeight (inherited from TreeView) | The height of every item in the tree view, in pixels.
LabelEdit (inherited from TreeView) | The LabelEdit property determines if the label text of nodes in the tree view is editable.
Left (inherited from Control) | The left coordinate of this control.
Location (inherited from Control) | The location of this control.
Nodes (inherited from TreeView) | The collection of nodes associated with this TreeView control
Opacity (inherited from RichControl) | Determines the opacity of the control. This can only be set on top level controls. Opacity requires Windows 2000 or later, and is ignored on earlier operating systems.
Parent (inherited from Control) | The parent of this control.
PathSeparator (inherited from TreeView) | The delimeter string used by TreeNode.getFullPath().
ProductName (inherited from RichControl) | Retrieves the product name of this specific component.
ProductVersion (inherited from RichControl) | Retrieves the product version of this specific component.
RecreatingHandle (inherited from Control) | This is true if the control is currently recreating its handle.
Region (inherited from RichControl) | The Region associated with this control. (defines the outline/silhouette/boundary of control)
Right (inherited from Control) | The right coordinate of this control.
RightToLeft (inherited from RichControl) | This is used for international applications where the language is written from RightToLeft. When this property is true, control placement and text will be from right to left.
Scrollable (inherited from TreeView) | [To be supplied.]
SelectedBitMask | [To be supplied.]
SelectedImageIndex (inherited from TreeView) | The image index that a node will display when selected. The index applies to the ImageList referred to by the imageList property,
SelectedNode (inherited from TreeView) | The currently selected tree node.
ShowLines (inherited from TreeView) | The ShowLines property determines if lines are drawn between nodes in the tree view.
ShowPlusMinus (inherited from TreeView) | The ShowPlusMinus property determines if the "plus/minus" expand button is shown next to tree nodes that have children.
ShowRootLines (inherited from TreeView) | Determines if lines are draw between nodes at the root of the tree view.
Site (inherited from MarshalByRefComponent) | Gets or sets the site of the component.
Size (inherited from Control) | The size of this control.
Sorted (inherited from TreeView) | The Sorted property determines if nodes in the tree view are sorted.
TabIndex (inherited from Control) | The tab index of this control. A tab index may consist of any valid integer number greater than or equal to zero. If more than one control on the same parent control has the same tab index, the z-order of the controls will be used to determine the order to pick the controls.
TabStop (inherited from Control) | A boolean value indicating whether the user can give the focus to this control using the TAB key.
Text (inherited from TreeView) | [To be supplied.]
Top (inherited from Control) | Top coordinate of this control.
TopLevel (inherited from Control) | true if this control is a top level window, meaning that it has no parent.
TopLevelControl (inherited from Control) | The top level control that contains this control. This doesn't have to be the same as the value returned from getForm since forms can be parented to other controls.
TopNode (inherited from TreeView) | The first visible node in the TreeView. Initially the first root node is at the top of the TreeView, but if the contents have been scrolled another node may be at the top.
Visible (inherited from Control) | Controls whether the control is visible.
VisibleCount (inherited from TreeView) | The count of fully visible nodes in the tree view. This number may be greater than the number of nodes in the control. The control calculates this value by dividing the height of the client window by the height of an item
Width (inherited from Control) | The width of this control.
WindowTarget (inherited from Control) | The target of Win32 window messages.

Methods

BeginInvoke (inherited from RichControl) | Overloaded. [To be supplied.]
BeginUpdate (inherited from TreeView) | Disables redrawing of the tree view. A call to beginUpdate() must be balanced by a following call to endUpdate(). Following a call to beginUpdate(), any redrawing caused by operations performed on the tree view is deferred until the call to endUpdate().
BringToFront (inherited from Control) | Brings this control to the front of the zorder.
CallWndProc (inherited from Control) | Dispatch the method to this window's wndProc directly.
CollapseAll (inherited from TreeView) | Collapses all nodes at the root level.
Contains (inherited from Control) | Checks if a control is a child of this control.
CreateControl (inherited from Control) | Forces the creation of the control. This includes the creation of the handle, and any child controls.
CreateGraphics (inherited from RichControl) | Overloaded. [To be supplied.]
CreateWindowGraphics (inherited from RichControl) | Creates a Graphics for the entire window of the control rather than just it's client area. The controls foreground color and background color become the default values for the Graphics. The returned Graphics must be disposed through a call to its dispose() method when it is no longer needed. The Graphics Object is only valid for the duration of the current window's message.
Dispose (inherited from TreeView) | [To be supplied.]
DoDragDrop (inherited from RichControl) | Begins a drag operation. The allowedEffects determine which drag operations can occur. If the drag operation needs to interop with applications in another process, data should either be a base managed class (String, Bitmap, or Metafile) or some Object that implements System.ComponentModel.IPersistable. data can also be any Object that implements System.WinForms.IDataObject.
EndInvoke (inherited from RichControl) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult interface passed. If the async operation has not been completed, this function will block until the result is available.
EndUpdate (inherited from TreeView) | Reenables redrawing of the tree view. A call to beginUpdate() must be balanced by a following call to endUpdate(). Following a call to beginUpdate(), any redrawing caused by operations performed on the combo box is deferred until the call to endUpdate().
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
ExpandAll (inherited from TreeView) | Expands all nodes at the root level.
FindForm (inherited from RichControl) | Retrieves the form that this control is on. The control's parent may not be the same as the form.
Focus (inherited from Control) | Attempts to set focus to this control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified client coordinates.
GetContainer (inherited from MarshalByRefComponent) | Returns the component's container.
GetContainerControl (inherited from Control) | Returns the closest ContainerControl in the control's chain of parent controls and forms.
GetDesignMode (inherited from MarshalByRefComponent) | Determines whether the component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetNextControl (inherited from Control) | Retrieves the next control in the tab order of child controls.
GetNodeAt (inherited from TreeView) | Overloaded. [To be supplied.]
GetNodeCount (inherited from TreeView) | Returns count of nodes at root, optionally including all subtrees.
GetServiceObject (inherited from MarshalByRefComponent) | The implementation of IServiceObjectProvider
GetType (inherited from Object) | Gets the Type of the Object.
Hide (inherited from Control) | Hides the control by setting the visible property to false;
InitializeLifetimeService (inherited from MarshalByRefObject)
Invalidate (inherited from Control) | Overloaded. [To be supplied.]
Invoke (inherited from RichControl) | Overloaded. [To be supplied.]
PerformLayout (inherited from Control) | Overloaded. [To be supplied.]
PointToClient (inherited from Control) | Computes the location of the screen point p in client coords.
PointToScreen (inherited from Control) | Computes the location of the client point p in screen coords.
PreProcessMessage (inherited from Control) | This method is called by the application's message loop to pre-process input messages before they are dispatched. Possible values for the msg.message field are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR. If this method processes the message it must return true, in which case the message loop will not dispatch the message. For WM_KEYDOWN and WM_SYSKEYDOWN messages, preProcessMessage() first calls processCmdKey() to check for command keys such as accelerators and menu shortcuts. If processCmdKey() doesn't process the message, then isInputKey() is called to check whether the key message represents an input key for the control. Finally, if isInputKey() indicates that the control isn't interested in the key message, then processDialogKey() is called to check for dialog keys such as TAB, arrow keys, and mnemonics. For WM_CHAR messages, preProcessMessage() first calls isInputChar() to check whether the character message represents an input character for the control. If isInputChar() indicates that the control isn't interested in the character message, then processDialogChar() is called to check for dialog characters such as mnemonics. For WM_SYSCHAR messages, preProcessMessage() calls processDialogChar() to check for dialog characters such as mnemonics. When overriding preProcessMessage(), a control should return true to indicate that it has processed the message. For messages that aren't processed by the control, the result of "base.preProcessMessage()" should be returned. Controls will typically override one of the more specialized methods (isInputChar(), isInputKey(), processCmdKey(), processDialogChar(), or processDialogKey()) instead of overriding preProcessMessage().
RectangleToClient (inherited from Control) | Computes the location of the screen rectangle r in client coords.
RectangleToScreen (inherited from Control) | Computes the location of the client rectangle r in screen coords.
Refresh (inherited from Control) | Forces the control to invalidate and immediately repaint itself and any children.
ResetBackColor (inherited from RichControl) | Resets the back color to be based on the parent's back color.
ResetBindings (inherited from RichControl) | [To be supplied.]
ResetCursor (inherited from RichControl) | [To be supplied.]
ResetFont (inherited from RichControl) | Resets the font to be based on the parent's font.
ResetForeColor (inherited from RichControl) | Resets the fore color to be based on the parent's fore color.
ResetIndent (inherited from TreeView) | This resets the indentation to the system default.
ResetRightToLeft (inherited from RichControl) | Resets the RightToLeft to be the default.
ResetText (inherited from Control) | Resets the text to it's default value.
ResumeLayout (inherited from Control) | Overloaded. [To be supplied.]
Scale (inherited from Control) | Overloaded. [To be supplied.]
Select (inherited from Control) | Activates this control.
SelectNextControl (inherited from Control) | Selects the next control following ctl.
SendMessage (inherited from Control) | Overloaded. [To be supplied.]
SendToBack (inherited from Control) | sends this control to the back of the z-order
SetBounds (inherited from Control) | Overloaded. [To be supplied.]
SetClientSize (inherited from Control) | Sets the height and width of the client area of the control.
SetLocation (inherited from Control) | Sets the location of this control.
SetNewControls (inherited from Control) | Performs the work of setting the array of the child controls contained in this control.
SetSize (inherited from Control) | Sets the size of this control.
ShouldPersistBackColor (inherited from TreeView) | Returns true if the backColor should be persisted in code gen.
ShouldPersistBindings (inherited from RichControl) | [To be supplied.]
ShouldPersistCursor (inherited from RichControl) | Returns true if the cursor should be persisted in code gen.
ShouldPersistFont (inherited from RichControl) | Returns true if the font should be persisted in code gen.
ShouldPersistForeColor (inherited from TreeView) | [To be supplied.]
ShouldPersistIndent (inherited from TreeView) | Retrieves true if the indent should be persisted in code gen.
ShouldPersistItemHeight (inherited from TreeView) | Retrieves true if the itemHeight should be persisted in code gen.
ShouldPersistLocation (inherited from Control) | Determines if the Location property needs to be persisted.
ShouldPersistRightToLeft (inherited from RichControl) | Returns true if the RightToLeft should be persisted in code gen.
ShouldPersistSize (inherited from Control) | Determines if the Size property needs to be persisted.
ShouldPersistText (inherited from Control) | Determines if the Text property needs to be persisted.
Show (inherited from Control) | Makes the control display by setting the visible property to true
SuspendLayout (inherited from Control) | Suspends the layout logic for the control.
ToString (inherited from TreeView) | Returns a string representation for this control.
Update (inherited from Control) | Forces the control to paint any currently invalid areas.

Events

AfterCheck (inherited from TreeView) | [To be supplied.]
AfterCollapse (inherited from TreeView) | [To be supplied.]
AfterExpand (inherited from TreeView) | [To be supplied.]
AfterLabelEdit (inherited from TreeView) | [To be supplied.]
AfterSelect (inherited from TreeView) | [To be supplied.]
BeforeCheck (inherited from TreeView) | [To be supplied.]
BeforeCollapse (inherited from TreeView) | [To be supplied.]
BeforeExpand (inherited from TreeView) | [To be supplied.]
BeforeLabelEdit (inherited from TreeView) | [To be supplied.]
BeforeSelect (inherited from TreeView) | [To be supplied.]
Click (inherited from Control) | [To be supplied.]
ControlAdded (inherited from Control) | [To be supplied.]
ControlRemoved (inherited from Control) | [To be supplied.]
CreateHandle (inherited from Control) | [To be supplied.]
DestroyHandle (inherited from Control) | [To be supplied.]
DoubleClick (inherited from Control) | [To be supplied.]
DragDrop (inherited from RichControl) | [To be supplied.]
DragEnter (inherited from RichControl) | [To be supplied.]
DragLeave (inherited from RichControl) | [To be supplied.]
DragOver (inherited from RichControl) | [To be supplied.]
Enter (inherited from Control) | [To be supplied.]
GiveFeedback (inherited from RichControl) | [To be supplied.]
GotFocus (inherited from Control) | [To be supplied.]
Help (inherited from RichControl) | [To be supplied.]
Invalidate (inherited from RichControl) | [To be supplied.]
ItemDrag (inherited from TreeView) | [To be supplied.]
KeyDown (inherited from Control) | [To be supplied.]
KeyPress (inherited from Control) | [To be supplied.]
KeyUp (inherited from Control) | [To be supplied.]
Layout (inherited from Control) | [To be supplied.]
Leave (inherited from Control) | [To be supplied.]
LostFocus (inherited from Control) | [To be supplied.]
MouseDown (inherited from Control) | [To be supplied.]
MouseEnter (inherited from Control) | [To be supplied.]
MouseHover (inherited from Control) | [To be supplied.]
MouseLeave (inherited from Control) | [To be supplied.]
MouseMove (inherited from Control) | [To be supplied.]
MouseUp (inherited from Control) | [To be supplied.]
MouseWheel (inherited from Control) | [To be supplied.]
Move (inherited from Control) | [To be supplied.]
Paint (inherited from RichControl) | [To be supplied.]
PropertyChanged (inherited from Control) | [To be supplied.]
QueryContinueDrag (inherited from RichControl) | [To be supplied.]
Resize (inherited from Control) | [To be supplied.]
Validated (inherited from Control) | [To be supplied.]
Validating (inherited from Control) | [To be supplied.]

Protected:

Properties

CreateParams (inherited from TreeView) | [To be supplied.]
CreateThreadId (inherited from Control) | Retrieves the Win32 thread ID of the thread that created the handle for this control. If the control's handle hasn't been created yet, this method will return the current thread's ID.
FontHeight (inherited from RichControl) | [To be supplied.]
InternalHandle (inherited from Control) | Returns the current value of the handle. This may be zero if the handle has not been created.
ParkingFormHandle (inherited from RichControl) | [To be supplied.]
RenderRightToLeft (inherited from RichControl) | [To be supplied.]
RichParent (inherited from RichControl) | [To be supplied.]
WindowText (inherited from Control) | The current text of the Window; if the window has not yet been created, stores it in the control. If the window has been created, stores the text in the underlying win32 control. This property should be used whenever you want to get at the win32 control's text. For all other cases, use the Text property- but note that this is overridable, and any of your code that uses it will use the overridden version in controls that subclass your own.

Methods

AddEventHandler (inherited from Control) | [To be supplied.]
AssignParent (inherited from RichControl) | Assigns a new parent control. Sends out the appropriate property change notifications for properties that are affected by the change of parent.
ChildGotFocus (inherited from Control) | [To be supplied.]
CreateAccessibilityInstance (inherited from RichControl) | Constructs the new instance of the accessibility object for this control. Subclasses should not call base.CreateAccessibilityObject.
CreateControlsInstance (inherited from RichControl) | Constructs the new instance of the Controls collection objects. Subclasses should not call base.CreateControlsInstance.
CreateHandle (inherited from TreeView) | [To be supplied.]
DefWndProc (inherited from Control) | Sends the message to the default window proc.
DestroyHandle (inherited from RichControl) | [To be supplied.]
Finalize (inherited from Control) | [To be supplied.]
GetEventHandler (inherited from RichControl) | RichControl overrides the default implementation of this for AX sourcing. ActiveX controls can "freeze" their events, and we implement this by returning null here if events are frozen.
GetItemRenderStyles (inherited from TreeView) | Generates colors for each item. This can be overridden to provide colors on a per state/per node basis, rather than using the ForeColor/BackColor/NodeFont properties on TreeNode.
GetStyle (inherited from Control) | Retrieves the current value of the specified bit in the control's style. NOTE: This is control style, not the Win32 style of the hwnd.
InitLayout (inherited from RichControl) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | [To be supplied.]
InvokeLostFocus (inherited from Control) | [To be supplied.]
InvokeOnClick (inherited from Control) | [To be supplied.]
InvokePaint (inherited from RichControl) | [To be supplied.]
InvokePaintBackground (inherited from RichControl) | [To be supplied.]
IsInputChar (inherited from Control) | Determines if charCode is an input character that the control wants. This method is called during window message pre-processing to determine whether the given input character should be pre-processed or sent directly to the control. If isInputChar returns true, the given character is sent directly to the control. If isInputChar returns false, the character is pre-processed and only sent to the control if it is not consumed by the pre-processing phase. The pre-processing of a character includes checking whether the character is a mnemonic of another control.
IsInputKey (inherited from Control) | Determines if keyData is an input key that the control wants. This method is called during window message pre-processing to determine whether the given input key should be pre-processed or sent directly to the control. If isInputKey returns true, the given key is sent directly to the control. If isInputKey returns false, the key is pre-processed and only sent to the control if it is not consumed by the pre-processing phase. Keys that are pre-processed include TAB, RETURN, ESCAPE, and arrow keys.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from RichControl) | [To be supplied.]
OnAfterCheck (inherited from TreeView) | Fires the afterCheck event.
OnAfterCollapse (inherited from TreeView) | Fires the afterCollapse event.
OnAfterExpand (inherited from TreeView) | Fires the afterExpand event.
OnAfterLabelEdit (inherited from TreeView) | Fires the afterLabelEdit event.
OnAfterSelect (inherited from TreeView) | Fires the afterSelect event.
OnBeforeCheck (inherited from TreeView) | Fires the beforeCheck event.
OnBeforeCollapse (inherited from TreeView) | Fires the beforeCollapse event.
OnBeforeExpand (inherited from TreeView) | Fires the beforeExpand event.
OnBeforeLabelEdit (inherited from TreeView) | Fires the beforeLabelEdit event.
OnBeforeSelect (inherited from TreeView) | Fires the beforeSelect event.
OnClick (inherited from Control) | This method actually raises the Click event. Inheriting classes should override this if they wish to be notified of a Click event. (This is far preferable to actually adding an event handler.) They should not, however, forget to call base.onClick(e); before exiting, to ensure that other recipients do actually get the event.
OnControlAdded (inherited from Control) | Called when a child control is added to this control.
OnControlRemoved (inherited from Control) | Called when a child control is removed from this control.
OnCreateControl (inherited from Control) | Called when the control is first created.
OnCreateHandle (inherited from TreeView) | [To be supplied.]
OnDestroyHandle (inherited from RichControl) | Inheriting classes should override this method to find out when the handle is about to be destroyed. Call base.onDestroyHandle last.
OnDoubleClick (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onDoubleClick to send this event to any registered event listeners.
OnDragDrop (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragDrop to send this event to any registered event listeners.
OnDragEnter (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragEnter to send this event to any registered event listeners.
OnDragLeave (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragLeave to send this event to any registered event listeners.
OnDragOver (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragOver to send this event to any registered event listeners.
OnEnter (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onEnter to send this event to any registered event listeners.
OnGiveFeedback (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onGiveFeedback to send this event to any registered event listeners.
OnGotFocus (inherited from RichControl) | [To be supplied.]
OnHelp (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onHelp to send this event to any registered event listeners.
OnInvalidate (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.OnInvalidate to send this event to any registered event listeners.
OnItemDrag (inherited from TreeView) | Fires the ItemDrag event.
OnKeyDown | [To be supplied.]
OnKeyPress (inherited from TreeView) | Handles the OnBeforeCheck/ OnAfterCheck for keyboard clicks
OnKeyUp (inherited from TreeView) | Handles the OnBeforeCheck/ OnAfterCheck for keyboard clicks
OnLayout (inherited from RichControl) | Core layout logic. Inheriting controls should override this function to do any custom layout logic. It is not neccessary to call base.layoutCore, however for normal docking and anchoring functions to work, base.layoutCore must be called.
OnLeave (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onLeave to send this event to any registered event listeners.
OnLostFocus (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onLostFocus to send this event to any registered event listeners.
OnMouseDown (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseDown to send this event to any registered event listeners.
OnMouseEnter (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseEnter to send this event to any registered event listeners.
OnMouseHover (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseHover to send this event to any registered event listeners.
OnMouseLeave (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseLeave to send this event to any registered event listeners.
OnMouseMove (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseMove to send this event to any registered event listeners.
OnMouseUp (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseUp to send this event to any registered event listeners.
OnMouseWheel (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseWheel to send this event to any registered event listeners.
OnMove (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMove to send this event to any registered event listeners.
OnPaint (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onPaint to send this event to any registered event listeners.
OnPaintBackground (inherited from RichControl) | Inheriting classes should override this method to handle the erase background request from windows. It is not necessary to call base.onPaintBackground, however if you do not want the default Windows behavior you must set event.handled to true.
OnParentPropertyChanged (inherited from RichControl) | This method is called by the parent control when any property changes on the parent. This can be overriden by inheriting classes, however they must call base.OnParentPropertyChanged.
OnPropertyChanged (inherited from RichControl) | [To be supplied.]
OnQueryContinueDrag (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onQueryContinueDrag to send this event to any registered event listeners.
OnResize (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onResize to send this event to any registered event listeners.
OnValidated (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onResize to send this event to any registered event listeners.
OnValidating (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onResize to send this event to any registered event listeners.
ParentChanged (inherited from Control) | Called by the framework after a control's parent changes. This allows (for example) child controls to automatically hook events on their parent, giving better encapsulation.
ProcessCmdKey (inherited from RichControl) | [To be supplied.]
ProcessDialogChar (inherited from Control) | Processes a dialog character. This method is called during message pre-processing to handle dialog characters, such as control mnemonics. This method is called only if the isInputChar() method indicates that the control isn't interested in the character. processDialogChar() simply sends the character to the parent's processDialogChar() method, or returns false if the control has no parent. The Form class overrides this method to perform actual processing of dialog characters. When overriding processDialogChar(), a control should return true to indicate that it has processed the character. For characters that aren't processed by the control, the result of "base.processDialogChar()" should be returned. Controls will seldom, if ever, need to override this method.
ProcessDialogKey (inherited from Control) | Processes a dialog key. This method is called during message pre-processing to handle dialog characters, such as TAB, RETURN, ESCAPE, and arrow keys. This method is called only if the isInputKey() method indicates that the control isn't interested in the key. processDialogKey() simply sends the character to the parent's processDialogKey() method, or returns false if the control has no parent. The Form class overrides this method to perform actual processing of dialog keys. When overriding processDialogKey(), a control should return true to indicate that it has processed the key. For keys that aren't processed by the control, the result of "base.processDialogChar()" should be returned. Controls will seldom, if ever, need to override this method.
ProcessKeyEventArgs (inherited from Control) | Processes a key message. This method is called when a control receives a keyboard message. The method is responsible for generating the appropriate key events for the message by calling OnKeyPress(), onKeyDown(), or onKeyUp(). The m parameter contains the window message that must be processed. Possible values for the m.msg field are WM_CHAR, WM_KEYDOWN, WM_SYSKEYDOWN, WM_KEYUP, WM_SYSKEYUP, and WM_IMECHAR. When overriding processKeyEventArgs(), a control should return true to indicate that it has processed the key. For keys that aren't processed by the control, the result of "base.processKeyEventArgs()" should be returned. Controls will seldom, if ever, need to override this method.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message. This method is called by a child control when the child control receives a keyboard message. The child control calls this method before generating any keyboard events for the message. If this method returns true, the child control considers the message consumed and does not generate any keyboard events. The m parameter contains the window message to preview. Possible values for the m.msg field are WM_CHAR, WM_KEYDOWN, WM_SYSKEYDOWN, WM_KEYUP, and WM_SYSKEYUP. processKeyPreview() simply sends the character to the parent's processKeyPreview() method, or returns false if the control has no parent. The Form class overrides this method to perform actual processing of dialog keys. When overriding processKeyPreview(), a control should return true to indicate that it has processed the key. For keys that aren't processed by the control, the result of "base.processKeyEventArgs()" should be returned.
ProcessMnemonic (inherited from Control) Processes a mnemonic character. This method is called to give a control the opportunity to process a mnemonic character. The method should check if the control is in a state to process mnemonics and if the given character represents a mnemonic. If so, the method should perform the action associated with the mnemonic and return true. If not, the method should return false. Implementations of this method often use the isMnemonic() method to check if the given character matches a mnemonic in the control's text, for example:
if (canSelect() && isMnemonic(charCode, getText()) {
    // perform action associated with mnemonic
    }

This default implementation of processMnemonic() simply returns false to indicate that the control has no mnemonic.
RaiseDragEventArgs (inherited from RichControl) | Raises the event associated with key with the event data of e and a sender of this control.
RaiseEvent (inherited from Control) | [To be supplied.]
RaiseKeyEventArgs (inherited from Control) | Raises the event associated with key with the event data of e and a sender of this control.
RaiseMouseEventArgs (inherited from Control) | Raises the event associated with key with the event data of e and a sender of this control.
RaisePaintEventArgs (inherited from RichControl) | Raises the event associated with key with the event data of e and a sender of this control.
RaisePropertyChangedEvent (inherited from Control) | Raises the property changed event. This creates the needed event data and then calls OnPropertyChanged.
RecreateHandle (inherited from Control) | Forces the recreation of the handle for this control. Inheriting controls must call base.recreateHandle.
RemoveEventHandler (inherited from Control) | [To be supplied.]
RemoveEventHandlers (inherited from Control) | [To be supplied.]
ResetMouseEventArgs (inherited from Control) | Resets the mouse leave listeners.
ResumeLayout (inherited from Control) | Overloaded. [To be supplied.]
RTLTranslateAlignment (inherited from RichControl) | Overloaded. [To be supplied.]
RTLTranslateContent (inherited from RichControl) | [To be supplied.]
RTLTranslateHorizontal (inherited from RichControl) | [To be supplied.]
RTLTranslateLeftRight (inherited from RichControl) | [To be supplied.]
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
SendMessage (inherited from Control) | Overloaded. [To be supplied.]
SetBoundsCore (inherited from RichControl) | [To be supplied.]
SetClientSizeCore (inherited from Control) | Performs the work of setting the size of the client area of the control.
SetStyle (inherited from Control) | Sets the current value of the specified bit in the control's style. NOTE: This is control style, not the Win32 style of the hwnd.
UpdateBounds (inherited from Control) | Overloaded. [To be supplied.]
UpdateStyles (inherited from Control) | Forces styles to be reapplied to the handle. This function will call CreateParams to get the styles to apply.
UpdateZOrder (inherited from Control) | Updates this control in it's parent's zorder.
WmSysColorChange (inherited from Control) | Handles the WM_SYSCOLORCHANGE message
WndProc (inherited from TreeView) | [To be supplied.]
WndProcException (inherited from RichControl) | [To be supplied.]

Event Hookup:

Methods

AddOnAfterCheck (inherited from TreeView) | Adds an event handler for the "afterCheck" event notification.
AddOnAfterCollapse (inherited from TreeView) | Adds an event handler for the "afterCollapse" event notification. The afterCollapse event is fired after the user has successfully collapsed a node. Collapsing a node hides all child nodes of that node from view.
AddOnAfterExpand (inherited from TreeView) | Adds an event handler for the "afterExpand" event notification. The afterExpand event is fired after the user has successfully expanded a node. Expanding a node causes its child nodes to be displayed.
AddOnAfterLabelEdit (inherited from TreeView) | Adds an event handler for the "afterLabelEdit" event notification. The afterLabelEdit event is fired when the user finishes editing the text of a node in the TreeView. The labelEdit property of the TreeView must be true to enable the user to do this. The string to which the user changed the text is passed to the event, and the event handler is given the opportunity to reject the change, in which case the text will revert back to what it was before the user started the change.
AddOnAfterSelect (inherited from TreeView) | Adds an event handler for the "afterSelect" event notification. The onAfterSelect event is fired after the user has selected a node.
AddOnBeforeCheck (inherited from TreeView) | Adds an event handler for the "beforeCheck" event notification.
AddOnBeforeCollapse (inherited from TreeView) | Adds an event handler for the "beforeCollapse" event notification. The beforeCollapse event is fired when the user attempts to collapse a node. Collapsing a node hides all child nodes of that node from view. The event can be cancelled by the handler, in which case the node won't collapse.
AddOnBeforeExpand (inherited from TreeView) | Adds an event handler for the "beforeExpand" event notification. The beforeExpand event is fired when the user attempts to expand a node. Expanding a node causes its child nodes to be displayed. The event can be cancelled by the handler, in which case the node won't expand.
AddOnBeforeLabelEdit (inherited from TreeView) | Adds an event handler for the "beforeLabelEdit" event notification. The beforeLabelEdit event is fired when the user attempts to begin changing the text of a node in the TreeView. The event handler can cancel this event, in which case the user won't be allowed to edit the text. This event can be used to prevent the user from editing specific nodes in the TreeView. If the labelEdit property of the TreeView is false, this event will not be fired, and all user attempts to edit node labels will be automatically rejected.
AddOnBeforeSelect (inherited from TreeView) | Adds an event handler for the "beforeSelect" event notification. The onBeforeSelect event is fired when the user attempts to select a node. The event can be cancelled by the handler, in which case the node won't be selected.
AddOnClick (inherited from Control) | Adds an event handler for the click event. The click event occurs when the user clicks in the client area of the control.
AddOnControlAdded (inherited from Control) | Adds an event handler for the ControlAdded event. This event is raised after a control is added as a child to this control.
AddOnControlRemoved (inherited from Control) | Adds an event handler for the ControlRemoved event. This event is raised after a child control is removed from this control.
AddOnCreateHandle (inherited from Control) | Adds an event handler for the createHandle event. The createHandle event occurs immediately after the control's handle is created.
AddOnDestroyHandle (inherited from Control) | Adds an event handler for the destroyHandle event. The destroyHandle event occurs immediately before the control's handle is destroyed.
AddOnDoubleClick (inherited from Control) | Adds an event handler for the doubleClick event. The doubleClick event occurs when the user double clicks in the client area of the control.
AddOnDragDrop (inherited from RichControl) | Adds an event handler for the dragDrop event. The dragDrop evnet occurs when the user releases the mouse button while dragging some Object over the control.
AddOnDragEnter (inherited from RichControl) | Adds an event handler for the dragEnter event. The drawEnter event occurs when the user first moves the mouse over the control while dragging some Object.
AddOnDragLeave (inherited from RichControl) | Adds an event handler for the dragLeave event. The dragLeave event occurs when the user first moves the mouse out of the control while dragging some Object.
AddOnDragOver (inherited from RichControl) | Adds an event handler for the dragOver event. The dragOver event occurs whenever the user moves the mouse over the control while draggin some Object.
AddOnEnter (inherited from Control) | Adds an event handler for the enter event. The enter event occurs when focus enters this control. This doesn't imply that this control has focus, but rather that this control or some child control of this control has gotten focus.
AddOnGiveFeedback (inherited from RichControl) | Adds an event handler for the giveFeedback event. The giveFeedback event occurs during a drag operation. This allows the source of a drag event to modify the mouse pointer to give the user visual feedback as to what would happen if they droped.
AddOnGotFocus (inherited from Control) | Adds an event handler for the gotFocus event. The gotFocus event occurs when the this control gains focus.
AddOnHelp (inherited from RichControl) | Adds an event handler for the help event. The help event occurs when the user requests help for this control. This may be caused by the user pressing F1, or used "Whats This Help".
AddOnInvalidate (inherited from RichControl) | Adds an event handler for the invalidate event. The invalidate event occurs when the Invalidate method is called on some part of the control's client area. This event may be used to identify when the contents of a window have changed.
AddOnItemDrag (inherited from TreeView) | Adds an event handler for the "itemDrag" event notification The itemDrag event is fired when the user presses the left or right mouse button over a node and begins to move the mouse. A typical response to this event would be to call doDragDrop.
AddOnKeyDown (inherited from Control) | Adds an event handler for the keyDown event. The keyDown event occurs when the user presses a key down.
AddOnKeyPress (inherited from Control) | Adds an event handler for the keyPress event. The keyPress event occurs when the user presses a key.
AddOnKeyUp (inherited from Control) | Adds an event handler for the keyUp event. The keyUp event occurs when the user releases a key.
AddOnLayout (inherited from Control) | Adds an event handler for the layout event. The layout event occurs when any event occurs that would cause the control to layout child controls. These events include; resize, show/hide child controls, add/remove child controls. This event should be used to perform any custom layout logic.
AddOnLeave (inherited from Control) | Adds an event handler for the leave event. The leave event occurs when focus leaves this control. This doesn't imply that this control lost focus, but rather that focus has been moved out of this control and any child controls.
AddOnLostFocus (inherited from Control) | Adds an event handler for the lostFocus event. The lostFocus event occurs when this control looses focus.
AddOnMouseDown (inherited from Control) | Adds an event handler for the mouseDown event. The mouseDown event occurs when the user presses the mouseDown over this control.
AddOnMouseEnter (inherited from Control) | Adds an event handler for the mouseEnter event. The mouseEnter event occurs when the mouse first moves over this control.
AddOnMouseHover (inherited from Control) | Adds an event handler for the mouseHover event. The mouseHover event occurs after the mouse is inside a control for an amount.
AddOnMouseLeave (inherited from Control) | Adds an event handler for the mouseLeave event. The mouseLeave event occurs when the mouse first moves out of this control.
AddOnMouseMove (inherited from Control) | Adds an event handler for the mouseMove event. The mouseMove event occurs whenever the user moves the mouse over this control.
AddOnMouseUp (inherited from Control) | Adds an event handler for the mouseUp event. The mouseUp event occurs when the user releases a mouse button inside the control.
AddOnMouseWheel (inherited from Control) | Adds an event handler for the mouseWheel event. The mouseWheel event occurs when the user scrolls the mouse wheel up or down. The delta value in the event data indicates the amount that the mouse wheel has moved. The Microsoft standards indicate that the view should scroll by System.WinForms.SystemInformation.getMouseWheelScrollLines() when the delta value has reach win.WHEEL_DELTA. If a mouseWheel event occurs with a value less that WHEEL_DELTA, the control should either increment a stored value and wait until the total delta is an increment of WHEEL_DELTA, or scroll the view a percentage of MouseWheelScrollLines. NOTE: A press of the mouseWheel will generate a mouseDown event with the middle button pressed.
AddOnMove (inherited from Control) | Adds an event handler for the move event. The move event occurs when the controls location changes.
AddOnPaint (inherited from RichControl) | Adds an event handler for the paint event. The paint event occurs when the control needs to paint some part of it's client area.
AddOnPropertyChanged (inherited from Control) | Adds an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.
AddOnQueryContinueDrag (inherited from RichControl) | Adds an event handler for the queryContinueDrag event. The queryContinueDrag event occurs during a drag operation. This allows the drag source to determine if the drag operation should be canceled.
AddOnResize (inherited from Control) | Adds an event handler for the resize event. The resize event occurs when the bounds of the control change. This event may be fired from the constructor of base controls.
AddOnValidated (inherited from Control) | Adds an event handler for the validated event. The validated event occurs when a control was successfully validated.
AddOnValidating (inherited from Control) | Adds an event handler for the validating event. The validating event occurs when the control loses focus and a control that causes validation gains focus. This is where users can write code to validate the current values of the control.
RemoveOnAfterCheck (inherited from TreeView) | Removes the given handler from the "afterCheck" event. If there are duplicate entries, all are removed.
RemoveOnAfterCollapse (inherited from TreeView) | Removes the given handler from the "afterCollapse" event. If there are duplicate entries, all are removed.
RemoveOnAfterExpand (inherited from TreeView) | Removes the given handler from the "afterExpand" event. If there are duplicate entries, all are removed.
RemoveOnAfterLabelEdit (inherited from TreeView) | Removes the given handler from the "afterLabelEdit" event. If there are duplicate entries, all are removed.
RemoveOnAfterSelect (inherited from TreeView) | Removes the given handler from the "afterSelect" event. If there are duplicate entries, all are removed.
RemoveOnBeforeCheck (inherited from TreeView) | Removes the given handler from the "beforeCheck" event. If there are duplicate entries, all are removed.
RemoveOnBeforeCollapse (inherited from TreeView) | Removes the given handler from the "beforeCollapse" event. If there are duplicate entries, all are removed.
RemoveOnBeforeExpand (inherited from TreeView) | Removes the given handler from the "beforeExpand" event. If there are duplicate entries, all are removed.
RemoveOnBeforeLabelEdit (inherited from TreeView) | Removes the given handler from the "beforeLabelEdit" event. If there are duplicate entries, all are removed.
RemoveOnBeforeSelect (inherited from TreeView) | Removes the given handler from the "beforeSelect" event. If there are duplicate entries, all are removed.
RemoveOnClick (inherited from Control) | Removes the given handler for the "OnClick" event. If there are duplicate entries, ALL are removed.
RemoveOnControlAdded (inherited from Control) | Removes the given handler for the "ControlAdded" event. If there are duplicate entries, ALL are removed.
RemoveOnControlRemoved (inherited from Control) | Removes the given handler for the "ControlRemoved" event. If there are duplicate entries, ALL are removed.
RemoveOnCreateHandle (inherited from Control) | Removes the given handler for the "createHandle" event. If there are duplicate entries, ALL are removed.
RemoveOnDestroyHandle (inherited from Control) | Removes the given handler for the "destroyHandle" event. If there are duplicate entries, ALL are removed.
RemoveOnDoubleClick (inherited from Control) | Removes the given handler for the "OnDoubleClick" event. If there are duplicate entries, ALL are removed.
RemoveOnDragDrop (inherited from RichControl) | Removes the given handler for the "dragDrop" event. If there are duplicate entries, ALL are removed.
RemoveOnDragEnter (inherited from RichControl) | Removes the given handler for the "OnDragEnter" event. If there are duplicate entries, ALL are removed.
RemoveOnDragLeave (inherited from RichControl) | Removes the given handler for the "OnDragLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnDragOver (inherited from RichControl) | f final Removes the given handler for the "OnDragOver" event. If there are duplicate entries, ALL are removed.
RemoveOnEnter (inherited from Control) | Removes the given handler for the "OnEnter" event. If there are dfinal uplicate entries, ALL are removed.
RemoveOnGiveFeedback (inherited from RichControl) | Removes the given handler for the "OnGiveFeedback" event. If there are duplicate entries, ALL are removed.
RemoveOnGotFocus (inherited from Control) | Removes the given handler for the "OnGotFocus" event. If there are duplicate entries, ALL are removed.
RemoveOnHelp (inherited from RichControl) | Removes the given handler for the "OnHelp" event. If there are duplicate entries, ALL are removed.
RemoveOnInvalidate (inherited from RichControl) | Removes the given handler for the "OnInvalidate" event. If there are duplicate entries, ALL are removed.
RemoveOnItemDrag (inherited from TreeView) | Removes the given handler from the "itemDrag" event. If there are duplicate entries, all are removed.
RemoveOnKeyDown (inherited from Control) | Removes the given handler for the "OnKeyDown" event. If there are duplicate entries, ALL are removed.
RemoveOnKeyPress (inherited from Control) | Removes the given handler for the "OnKeyPress" event. If there are duplicate entries, ALL are removed.
RemoveOnKeyUp (inherited from Control) | Removes the given handler for the "OnKeyUp" event. If there are duplicate entries, ALL are removed.
RemoveOnLayout (inherited from Control) | Removes the given handler for the layout event. If there are duplicate entries, ALL are removed.
RemoveOnLeave (inherited from Control) | Removes the given handler for the "OnLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnLostFocus (inherited from Control) | Removes the given handler for the "OnLostFocus" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseDown (inherited from Control) | Removes the given handler for the "OnMouseDown" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseEnter (inherited from Control) | Removes the given handler for the "OnMouseEnter" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseHover (inherited from Control) | Removes the given handler for the "OnMouseHover" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseLeave (inherited from Control) | Removes the given handler for the "OnMouseLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseMove (inherited from Control) | Removes the given handler for the "OnMouseMove" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseUp (inherited from Control) | Removes the given handler for the "OnMouseUp" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseWheel (inherited from Control) | Removes the given handler for the "OnMouseWheel" event. If there are duplicate entries, ALL are removed.
RemoveOnMove (inherited from Control) | Removes the given handler for the "OnMove" event. If there are duplicate entries, ALL are removed.
RemoveOnPaint (inherited from RichControl) | Removes the given handler for the "OnPaint" event. If there are duplicate entries, ALL are removed.
RemoveOnPropertyChanged (inherited from Control) | Removes an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.
RemoveOnQueryContinueDrag (inherited from RichControl) | Removes the given handler for the "OnQueryContinueDrag" event. If there are duplicate entries, ALL are removed.
RemoveOnResize (inherited from Control) | Removes the given handler for the "OnResize" event. If there are duplicate entries, ALL are removed.
RemoveOnValidated (inherited from Control) | Removes an event handler for the validated event. The validated event occurs when a control was successfully validated.
RemoveOnValidating (inherited from Control) | Removes an event handler for the validating event. The validating event occurs when the control loses focus and a control that causes validation gains focus. This is where users can write code to validate the current values of the control.

See Also

BitMaskSelector Class | System.Data.Design Namespace


BitMaskSelector Constructor

labels- strings to be shown in BitMaskSelector bitmasks- int valaues correspond with labels.

[Visual Basic]
Public Sub New( _
   ByVal labels() As String, _
   ByVal bitmasks() As Integer, _
   ByVal defBitMask As Integer _
)
[C#]
public BitMaskSelector(
   string[] labels,
   int[] bitmasks,
   int defBitMask
);
[C++]
public: BitMaskSelector(
   String* labels[],
   int* bitmasks[],
   int defBitMask
);
[JScript]
public function BitMaskSelector(
   labels : String[],
   bitmasks : int[],
   defBitMask : int
);

Parameters

labels
[To be supplied.]
bitmasks
[To be supplied.]
defBitMask
[To be supplied.]

See Also

BitMaskSelector Class | BitMaskSelector Members | System.Data.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

BitMaskSelector Properties

The properties of the BitMaskSelector class are listed below. For a complete list of BitMaskSelector class members, see the BitMaskSelector Members topic.

Public:

AccessibilityObject (inherited from RichControl) | The Accessibility Object for this RichControl
AccessibleDefaultActionDescription (inherited from RichControl) | The default action description of the control
AccessibleDescription (inherited from RichControl) | The accessible description of the control
AccessibleHelpProvider (inherited from RichControl) | The help provider for this RichControl
AccessibleName (inherited from RichControl) | The accessible name of the control
AccessibleRole (inherited from RichControl) | The accessible role of the control
AllowDrop (inherited from RichControl) | The allowDrop property. If allowDrop is set to true then this control will allow drag and drop operations and events to be used.
AllowTransparency (inherited from RichControl) | Determines if the control should be allowed to have the opacity adjusted. This is primarily a performance optimization, in that you can always set the opacity to any value, and that will force AllowTransparency to true. However, setting the opacity to any given value will switch the control into layered mode. By setting the AllowTransparency property to false the control will actually switch out of layered mode, which provides better performance if you don't intend to adjust the opacity.
Anchor (inherited from RichControl) | The current value of the anchor property. The anchor property determines which edges of the control are anchored to the container's edges.
BackColor (inherited from TreeView) | The background color for this control. Specifying null for this parameter sets the control's background color to its parent's background color.
BackgroundImage (inherited from TreeView) | [To be supplied.]
BindingManager (inherited from RichControl) | [To be supplied.]
Bindings (inherited from RichControl) | Retrieves the bindings for this control.
BorderStyle (inherited from TreeView) | The border style of the window.
Bottom (inherited from Control) | The bottom coordinate of this control.
Bounds (inherited from Control) | The bounds of this control. This is the window coordinates of the control in parent client coordinates.
CanFocus (inherited from Control) | Checks if this control can receive focus. The result is true if the control has a handle and if it and all of its parent controls are both visible and enabled.
CanSelect (inherited from Control) | Checks if this control can be selected. The result is true if the control is contained in a form and if all of its parent controls are both visible and enabled.
Capture (inherited from Control) | If this control has captured the mouse then this will return true.
CausesValidation (inherited from Control) | Indicates whether entering this control causes validation on the controls requiring validation. This is set to false usually for things like the Help button, etc...
CheckBoxes (inherited from TreeView) | The value of the CheckBoxes property. The CheckBoxes property determines if check boxes are shown next to node in the tree view.
ClientRectangle (inherited from Control) | The client rect of the control.
ClientSize (inherited from Control) | The size of the clientRect.
CompanyName (inherited from RichControl) | Retrieves the company name of this specific component.
ContainsFocus (inherited from Control) | Indicates whether the control or one of its children currently has the system focus.
ContextMenu (inherited from RichControl) | The contextMenu associated with this control. The contextMenu will be shown when the user right clicks the mouse on the control.
Controls (inherited from Control) | Collection of child controls.
Created (inherited from Control) | Returns true if the control has been created.
Cursor (inherited from RichControl) | Retrieves the cursor that will be displayed when the mouse is over this control.
DisplayRectangle (inherited from Control) | Returns the client rect of the display area of the control. For the base control class, this is identical to getClientRect. However, inheriting controls may want to change this if their client area differs from their display area.
Disposed (inherited from Control) | Indicates that the control has been disposed, and is no longer a valid Windows control even though the object instance is still alive.
Disposing (inherited from Control) | Indicates that the control is in the process of being beendisposed, and is no longer a valid Windows control even though the object instance is still alive.
Dock (inherited from RichControl) | The dock property. The dock property controls to which edge of the container this control is docked to. For example, when docked to the top of the container, the control will be displayed flush at the top of the container, extending the length of the container.
Enabled (inherited from Control) | The current enabled state of this control.
Focused (inherited from Control) | Returns true if this control has focus.
Font (inherited from RichControl) | Retrieves the current font for this control. This will be the font used by default for painting and text in the control.
ForeColor (inherited from TreeView) | The current foreground color for this control, which is the color the control uses to draw its text.
FullRowSelect (inherited from TreeView) | Determines whether the selection highlight spans across the width of the TreeView.
Handle (inherited from Control) | The HWND handle that this control is bound to. If the handle has not yet been created, this will force handle creation.
HandleCreated (inherited from Control) | Whether or not this control has a handle associated with it.
Height (inherited from Control) | The height of this control
HideSelection (inherited from TreeView) | The hideSelection property specifies whether the selected node will be highlighted even when the TreeView loses focus.
HotTracking (inherited from TreeView) | The value of the HotTracking property. The HotTracking property determines if nodes are highlighted as the mousepointer passes over them.
ImageIndex (inherited from TreeView) | The default image index for nodes in the tree view.
ImageList (inherited from TreeView) | Returns the image list control that is bound to the tree view.
IMEMode (inherited from RichControl) | Specifies a value that determines the IME (Input Method Editor) status of the object when that object is selected.
Indent (inherited from TreeView) | The indentation level in pixels.
InvokeRequired (inherited from RichControl) | Determines if the caller must call invoke when making method calls to this control. Controls in WinForms are bound to a specific thread, and are not thread safe. Therefore, if you are calling a control's method from a different thread, you must use the control's invoke method to marshal the call to the proper thread. This function can be used to determine if you must call invoke, which can be handy if you don't know what thread owns a control. There are five functions on a control that are safe to call from any thread: GetInvokeRequired, Invoke, BeginInvoke, EndInvoke and CreateGraphics. For all other metohd calls, you should use one of the invoke methods.
IsAccessible (inherited from RichControl) | Indicates whether or not this control is an accessible control i.e. whether it should be visible to accessibility applications.
ItemHeight (inherited from TreeView) | The height of every item in the tree view, in pixels.
LabelEdit (inherited from TreeView) | The LabelEdit property determines if the label text of nodes in the tree view is editable.
Left (inherited from Control) | The left coordinate of this control.
Location (inherited from Control) | The location of this control.
Nodes (inherited from TreeView) | The collection of nodes associated with this TreeView control
Opacity (inherited from RichControl) | Determines the opacity of the control. This can only be set on top level controls. Opacity requires Windows 2000 or later, and is ignored on earlier operating systems.
Parent (inherited from Control) | The parent of this control.
PathSeparator (inherited from TreeView) | The delimeter string used by TreeNode.getFullPath().
ProductName (inherited from RichControl) | Retrieves the product name of this specific component.
ProductVersion (inherited from RichControl) | Retrieves the product version of this specific component.
RecreatingHandle (inherited from Control) | This is true if the control is currently recreating its handle.
Region (inherited from RichControl) | The Region associated with this control. (defines the outline/silhouette/boundary of control)
Right (inherited from Control) | The right coordinate of this control.
RightToLeft (inherited from RichControl) | This is used for international applications where the language is written from RightToLeft. When this property is true, control placement and text will be from right to left.
Scrollable (inherited from TreeView) | [To be supplied.]
SelectedBitMask | [To be supplied.]
SelectedImageIndex (inherited from TreeView) | The image index that a node will display when selected. The index applies to the ImageList referred to by the imageList property,
SelectedNode (inherited from TreeView) | The currently selected tree node.
ShowLines (inherited from TreeView) | The ShowLines property determines if lines are drawn between nodes in the tree view.
ShowPlusMinus (inherited from TreeView) | The ShowPlusMinus property determines if the "plus/minus" expand button is shown next to tree nodes that have children.
ShowRootLines (inherited from TreeView) | Determines if lines are draw between nodes at the root of the tree view.
Site (inherited from MarshalByRefComponent) | Gets or sets the site of the component.
Size (inherited from Control) | The size of this control.
Sorted (inherited from TreeView) | The Sorted property determines if nodes in the tree view are sorted.
TabIndex (inherited from Control) | The tab index of this control. A tab index may consist of any valid integer number greater than or equal to zero. If more than one control on the same parent control has the same tab index, the z-order of the controls will be used to determine the order to pick the controls.
TabStop (inherited from Control) | A boolean value indicating whether the user can give the focus to this control using the TAB key.
Text (inherited from TreeView) | [To be supplied.]
Top (inherited from Control) | Top coordinate of this control.
TopLevel (inherited from Control) | true if this control is a top level window, meaning that it has no parent.
TopLevelControl (inherited from Control) | The top level control that contains this control. This doesn't have to be the same as the value returned from getForm since forms can be parented to other controls.
TopNode (inherited from TreeView) | The first visible node in the TreeView. Initially the first root node is at the top of the TreeView, but if the contents have been scrolled another node may be at the top.
Visible (inherited from Control) | Controls whether the control is visible.
VisibleCount (inherited from TreeView) | The count of fully visible nodes in the tree view. This number may be greater than the number of nodes in the control. The control calculates this value by dividing the height of the client window by the height of an item
Width (inherited from Control) | The width of this control.
WindowTarget (inherited from Control) | The target of Win32 window messages.

Protected:

CreateParams (inherited from TreeView) | [To be supplied.]
CreateThreadId (inherited from Control) | Retrieves the Win32 thread ID of the thread that created the handle for this control. If the control's handle hasn't been created yet, this method will return the current thread's ID.
FontHeight (inherited from RichControl) | [To be supplied.]
InternalHandle (inherited from Control) | Returns the current value of the handle. This may be zero if the handle has not been created.
ParkingFormHandle (inherited from RichControl) | [To be supplied.]
RenderRightToLeft (inherited from RichControl) | [To be supplied.]
RichParent (inherited from RichControl) | [To be supplied.]
WindowText (inherited from Control) | The current text of the Window; if the window has not yet been created, stores it in the control. If the window has been created, stores the text in the underlying win32 control. This property should be used whenever you want to get at the win32 control's text. For all other cases, use the Text property- but note that this is overridable, and any of your code that uses it will use the overridden version in controls that subclass your own.

See Also

BitMaskSelector Class | System.Data.Design Namespace


BitMaskSelector.SelectedBitMask

[To be supplied.]

[Visual Basic]
Public Property SelectedBitMask As Integer
[C#]
public int SelectedBitMask {get; set;}
[C++]
public: __property int get_SelectedBitMask();
public: __property void set_SelectedBitMask(int);
[JScript]
public function get SelectedBitMask() : int;
public function set SelectedBitMask(int);

See Also

BitMaskSelector Class | BitMaskSelector Members | System.Data.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

BitMaskSelector Methods

The methods of the BitMaskSelector class are listed below. For a complete list of BitMaskSelector class members, see the BitMaskSelector Members topic.

Public:

BeginInvoke (inherited from RichControl) | Overloaded. [To be supplied.]
BeginUpdate (inherited from TreeView) | Disables redrawing of the tree view. A call to beginUpdate() must be balanced by a following call to endUpdate(). Following a call to beginUpdate(), any redrawing caused by operations performed on the tree view is deferred until the call to endUpdate().
BringToFront (inherited from Control) | Brings this control to the front of the zorder.
CallWndProc (inherited from Control) | Dispatch the method to this window's wndProc directly.
CollapseAll (inherited from TreeView) | Collapses all nodes at the root level.
Contains (inherited from Control) | Checks if a control is a child of this control.
CreateControl (inherited from Control) | Forces the creation of the control. This includes the creation of the handle, and any child controls.
CreateGraphics (inherited from RichControl) | Overloaded. [To be supplied.]
CreateWindowGraphics (inherited from RichControl) | Creates a Graphics for the entire window of the control rather than just it's client area. The controls foreground color and background color become the default values for the Graphics. The returned Graphics must be disposed through a call to its dispose() method when it is no longer needed. The Graphics Object is only valid for the duration of the current window's message.
Dispose (inherited from TreeView) | [To be supplied.]
DoDragDrop (inherited from RichControl) | Begins a drag operation. The allowedEffects determine which drag operations can occur. If the drag operation needs to interop with applications in another process, data should either be a base managed class (String, Bitmap, or Metafile) or some Object that implements System.ComponentModel.IPersistable. data can also be any Object that implements System.WinForms.IDataObject.
EndInvoke (inherited from RichControl) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult interface passed. If the async operation has not been completed, this function will block until the result is available.
EndUpdate (inherited from TreeView) | Reenables redrawing of the tree view. A call to beginUpdate() must be balanced by a following call to endUpdate(). Following a call to beginUpdate(), any redrawing caused by operations performed on the combo box is deferred until the call to endUpdate().
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
ExpandAll (inherited from TreeView) | Expands all nodes at the root level.
FindForm (inherited from RichControl) | Retrieves the form that this control is on. The control's parent may not be the same as the form.
Focus (inherited from Control) | Attempts to set focus to this control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified client coordinates.
GetContainer (inherited from MarshalByRefComponent) | Returns the component's container.
GetContainerControl (inherited from Control) | Returns the closest ContainerControl in the control's chain of parent controls and forms.
GetDesignMode (inherited from MarshalByRefComponent) | Determines whether the component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetNextControl (inherited from Control) | Retrieves the next control in the tab order of child controls.
GetNodeAt (inherited from TreeView) | Overloaded. [To be supplied.]
GetNodeCount (inherited from TreeView) | Returns count of nodes at root, optionally including all subtrees.
GetServiceObject (inherited from MarshalByRefComponent) | The implementation of IServiceObjectProvider
GetType (inherited from Object) | Gets the Type of the Object.
Hide (inherited from Control) | Hides the control by setting the visible property to false;
InitializeLifetimeService (inherited from MarshalByRefObject)
Invalidate (inherited from Control) | Overloaded. [To be supplied.]
Invoke (inherited from RichControl) | Overloaded. [To be supplied.]
PerformLayout (inherited from Control) | Overloaded. [To be supplied.]
PointToClient (inherited from Control) | Computes the location of the screen point p in client coords.
PointToScreen (inherited from Control) | Computes the location of the client point p in screen coords.
PreProcessMessage (inherited from Control) | This method is called by the application's message loop to pre-process input messages before they are dispatched. Possible values for the msg.message field are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR. If this method processes the message it must return true, in which case the message loop will not dispatch the message. For WM_KEYDOWN and WM_SYSKEYDOWN messages, preProcessMessage() first calls processCmdKey() to check for command keys such as accelerators and menu shortcuts. If processCmdKey() doesn't process the message, then isInputKey() is called to check whether the key message represents an input key for the control. Finally, if isInputKey() indicates that the control isn't interested in the key message, then processDialogKey() is called to check for dialog keys such as TAB, arrow keys, and mnemonics. For WM_CHAR messages, preProcessMessage() first calls isInputChar() to check whether the character message represents an input character for the control. If isInputChar() indicates that the control isn't interested in the character message, then processDialogChar() is called to check for dialog characters such as mnemonics. For WM_SYSCHAR messages, preProcessMessage() calls processDialogChar() to check for dialog characters such as mnemonics. When overriding preProcessMessage(), a control should return true to indicate that it has processed the message. For messages that aren't processed by the control, the result of "base.preProcessMessage()" should be returned. Controls will typically override one of the more specialized methods (isInputChar(), isInputKey(), processCmdKey(), processDialogChar(), or processDialogKey()) instead of overriding preProcessMessage().
RectangleToClient (inherited from Control) | Computes the location of the screen rectangle r in client coords.
RectangleToScreen (inherited from Control) | Computes the location of the client rectangle r in screen coords.
Refresh (inherited from Control) | Forces the control to invalidate and immediately repaint itself and any children.
ResetBackColor (inherited from RichControl) | Resets the back color to be based on the parent's back color.
ResetBindings (inherited from RichControl) | [To be supplied.]
ResetCursor (inherited from RichControl) | [To be supplied.]
ResetFont (inherited from RichControl) | Resets the font to be based on the parent's font.
ResetForeColor (inherited from RichControl) | Resets the fore color to be based on the parent's fore color.
ResetIndent (inherited from TreeView) | This resets the indentation to the system default.
ResetRightToLeft (inherited from RichControl) | Resets the RightToLeft to be the default.
ResetText (inherited from Control) | Resets the text to it's default value.
ResumeLayout (inherited from Control) | Overloaded. [To be supplied.]
Scale (inherited from Control) | Overloaded. [To be supplied.]
Select (inherited from Control) | Activates this control.
SelectNextControl (inherited from Control) | Selects the next control following ctl.
SendMessage (inherited from Control) | Overloaded. [To be supplied.]
SendToBack (inherited from Control) | sends this control to the back of the z-order
SetBounds (inherited from Control) | Overloaded. [To be supplied.]
SetClientSize (inherited from Control) | Sets the height and width of the client area of the control.
SetLocation (inherited from Control) | Sets the location of this control.
SetNewControls (inherited from Control) | Performs the work of setting the array of the child controls contained in this control.
SetSize (inherited from Control) | Sets the size of this control.
ShouldPersistBackColor (inherited from TreeView) | Returns true if the backColor should be persisted in code gen.
ShouldPersistBindings (inherited from RichControl) | [To be supplied.]
ShouldPersistCursor (inherited from RichControl) | Returns true if the cursor should be persisted in code gen.
ShouldPersistFont (inherited from RichControl) | Returns true if the font should be persisted in code gen.
ShouldPersistForeColor (inherited from TreeView) | [To be supplied.]
ShouldPersistIndent (inherited from TreeView) | Retrieves true if the indent should be persisted in code gen.
ShouldPersistItemHeight (inherited from TreeView) | Retrieves true if the itemHeight should be persisted in code gen.
ShouldPersistLocation (inherited from Control) | Determines if the Location property needs to be persisted.
ShouldPersistRightToLeft (inherited from RichControl) | Returns true if the RightToLeft should be persisted in code gen.
ShouldPersistSize (inherited from Control) | Determines if the Size property needs to be persisted.
ShouldPersistText (inherited from Control) | Determines if the Text property needs to be persisted.
Show (inherited from Control) | Makes the control display by setting the visible property to true
SuspendLayout (inherited from Control) | Suspends the layout logic for the control.
ToString (inherited from TreeView) | Returns a string representation for this control.
Update (inherited from Control) | Forces the control to paint any currently invalid areas.

Protected:

AddEventHandler (inherited from Control) | [To be supplied.]
AssignParent (inherited from RichControl) | Assigns a new parent control. Sends out the appropriate property change notifications for properties that are affected by the change of parent.
ChildGotFocus (inherited from Control) | [To be supplied.]
CreateAccessibilityInstance (inherited from RichControl) | Constructs the new instance of the accessibility object for this control. Subclasses should not call base.CreateAccessibilityObject.
CreateControlsInstance (inherited from RichControl) | Constructs the new instance of the Controls collection objects. Subclasses should not call base.CreateControlsInstance.
CreateHandle (inherited from TreeView) | [To be supplied.]
DefWndProc (inherited from Control) | Sends the message to the default window proc.
DestroyHandle (inherited from RichControl) | [To be supplied.]
Finalize (inherited from Control) | [To be supplied.]
GetEventHandler (inherited from RichControl) | RichControl overrides the default implementation of this for AX sourcing. ActiveX controls can "freeze" their events, and we implement this by returning null here if events are frozen.
GetItemRenderStyles (inherited from TreeView) | Generates colors for each item. This can be overridden to provide colors on a per state/per node basis, rather than using the ForeColor/BackColor/NodeFont properties on TreeNode.
GetStyle (inherited from Control) | Retrieves the current value of the specified bit in the control's style. NOTE: This is control style, not the Win32 style of the hwnd.
InitLayout (inherited from RichControl) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | [To be supplied.]
InvokeLostFocus (inherited from Control) | [To be supplied.]
InvokeOnClick (inherited from Control) | [To be supplied.]
InvokePaint (inherited from RichControl) | [To be supplied.]
InvokePaintBackground (inherited from RichControl) | [To be supplied.]
IsInputChar (inherited from Control) | Determines if charCode is an input character that the control wants. This method is called during window message pre-processing to determine whether the given input character should be pre-processed or sent directly to the control. If isInputChar returns true, the given character is sent directly to the control. If isInputChar returns false, the character is pre-processed and only sent to the control if it is not consumed by the pre-processing phase. The pre-processing of a character includes checking whether the character is a mnemonic of another control.
IsInputKey (inherited from Control) | Determines if keyData is an input key that the control wants. This method is called during window message pre-processing to determine whether the given input key should be pre-processed or sent directly to the control. If isInputKey returns true, the given key is sent directly to the control. If isInputKey returns false, the key is pre-processed and only sent to the control if it is not consumed by the pre-processing phase. Keys that are pre-processed include TAB, RETURN, ESCAPE, and arrow keys.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from RichControl) | [To be supplied.]
OnAfterCheck (inherited from TreeView) | Fires the afterCheck event.
OnAfterCollapse (inherited from TreeView) | Fires the afterCollapse event.
OnAfterExpand (inherited from TreeView) | Fires the afterExpand event.
OnAfterLabelEdit (inherited from TreeView) | Fires the afterLabelEdit event.
OnAfterSelect (inherited from TreeView) | Fires the afterSelect event.
OnBeforeCheck (inherited from TreeView) | Fires the beforeCheck event.
OnBeforeCollapse (inherited from TreeView) | Fires the beforeCollapse event.
OnBeforeExpand (inherited from TreeView) | Fires the beforeExpand event.
OnBeforeLabelEdit (inherited from TreeView) | Fires the beforeLabelEdit event.
OnBeforeSelect (inherited from TreeView) | Fires the beforeSelect event.
OnClick (inherited from Control) | This method actually raises the Click event. Inheriting classes should override this if they wish to be notified of a Click event. (This is far preferable to actually adding an event handler.) They should not, however, forget to call base.onClick(e); before exiting, to ensure that other recipients do actually get the event.
OnControlAdded (inherited from Control) | Called when a child control is added to this control.
OnControlRemoved (inherited from Control) | Called when a child control is removed from this control.
OnCreateControl (inherited from Control) | Called when the control is first created.
OnCreateHandle (inherited from TreeView) | [To be supplied.]
OnDestroyHandle (inherited from RichControl) | Inheriting classes should override this method to find out when the handle is about to be destroyed. Call base.onDestroyHandle last.
OnDoubleClick (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onDoubleClick to send this event to any registered event listeners.
OnDragDrop (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragDrop to send this event to any registered event listeners.
OnDragEnter (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragEnter to send this event to any registered event listeners.
OnDragLeave (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragLeave to send this event to any registered event listeners.
OnDragOver (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onDragOver to send this event to any registered event listeners.
OnEnter (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onEnter to send this event to any registered event listeners.
OnGiveFeedback (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onGiveFeedback to send this event to any registered event listeners.
OnGotFocus (inherited from RichControl) | [To be supplied.]
OnHelp (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onHelp to send this event to any registered event listeners.
OnInvalidate (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.OnInvalidate to send this event to any registered event listeners.
OnItemDrag (inherited from TreeView) | Fires the ItemDrag event.
OnKeyDown | [To be supplied.]
OnKeyPress (inherited from TreeView) | Handles the OnBeforeCheck/ OnAfterCheck for keyboard clicks
OnKeyUp (inherited from TreeView) | Handles the OnBeforeCheck/ OnAfterCheck for keyboard clicks
OnLayout (inherited from RichControl) | Core layout logic. Inheriting controls should override this function to do any custom layout logic. It is not neccessary to call base.layoutCore, however for normal docking and anchoring functions to work, base.layoutCore must be called.
OnLeave (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onLeave to send this event to any registered event listeners.
OnLostFocus (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onLostFocus to send this event to any registered event listeners.
OnMouseDown (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseDown to send this event to any registered event listeners.
OnMouseEnter (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseEnter to send this event to any registered event listeners.
OnMouseHover (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseHover to send this event to any registered event listeners.
OnMouseLeave (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseLeave to send this event to any registered event listeners.
OnMouseMove (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseMove to send this event to any registered event listeners.
OnMouseUp (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseUp to send this event to any registered event listeners.
OnMouseWheel (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMouseWheel to send this event to any registered event listeners.
OnMove (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onMove to send this event to any registered event listeners.
OnPaint (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onPaint to send this event to any registered event listeners.
OnPaintBackground (inherited from RichControl) | Inheriting classes should override this method to handle the erase background request from windows. It is not necessary to call base.onPaintBackground, however if you do not want the default Windows behavior you must set event.handled to true.
OnParentPropertyChanged (inherited from RichControl) | This method is called by the parent control when any property changes on the parent. This can be overriden by inheriting classes, however they must call base.OnParentPropertyChanged.
OnPropertyChanged (inherited from RichControl) | [To be supplied.]
OnQueryContinueDrag (inherited from RichControl) | Inheriting classes should override this method to handle this event. Call base.onQueryContinueDrag to send this event to any registered event listeners.
OnResize (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onResize to send this event to any registered event listeners.
OnValidated (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onResize to send this event to any registered event listeners.
OnValidating (inherited from Control) | Inheriting classes should override this method to handle this event. Call base.onResize to send this event to any registered event listeners.
ParentChanged (inherited from Control) | Called by the framework after a control's parent changes. This allows (for example) child controls to automatically hook events on their parent, giving better encapsulation.
ProcessCmdKey (inherited from RichControl) | [To be supplied.]
ProcessDialogChar (inherited from Control) | Processes a dialog character. This method is called during message pre-processing to handle dialog characters, such as control mnemonics. This method is called only if the isInputChar() method indicates that the control isn't interested in the character. processDialogChar() simply sends the character to the parent's processDialogChar() method, or returns false if the control has no parent. The Form class overrides this method to perform actual processing of dialog characters. When overriding processDialogChar(), a control should return true to indicate that it has processed the character. For characters that aren't processed by the control, the result of "base.processDialogChar()" should be returned. Controls will seldom, if ever, need to override this method.
ProcessDialogKey (inherited from Control) | Processes a dialog key. This method is called during message pre-processing to handle dialog characters, such as TAB, RETURN, ESCAPE, and arrow keys. This method is called only if the isInputKey() method indicates that the control isn't interested in the key. processDialogKey() simply sends the character to the parent's processDialogKey() method, or returns false if the control has no parent. The Form class overrides this method to perform actual processing of dialog keys. When overriding processDialogKey(), a control should return true to indicate that it has processed the key. For keys that aren't processed by the control, the result of "base.processDialogChar()" should be returned. Controls will seldom, if ever, need to override this method.
ProcessKeyEventArgs (inherited from Control) | Processes a key message. This method is called when a control receives a keyboard message. The method is responsible for generating the appropriate key events for the message by calling OnKeyPress(), onKeyDown(), or onKeyUp(). The m parameter contains the window message that must be processed. Possible values for the m.msg field are WM_CHAR, WM_KEYDOWN, WM_SYSKEYDOWN, WM_KEYUP, WM_SYSKEYUP, and WM_IMECHAR. When overriding processKeyEventArgs(), a control should return true to indicate that it has processed the key. For keys that aren't processed by the control, the result of "base.processKeyEventArgs()" should be returned. Controls will seldom, if ever, need to override this method.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message. This method is called by a child control when the child control receives a keyboard message. The child control calls this method before generating any keyboard events for the message. If this method returns true, the child control considers the message consumed and does not generate any keyboard events. The m parameter contains the window message to preview. Possible values for the m.msg field are WM_CHAR, WM_KEYDOWN, WM_SYSKEYDOWN, WM_KEYUP, and WM_SYSKEYUP. processKeyPreview() simply sends the character to the parent's processKeyPreview() method, or returns false if the control has no parent. The Form class overrides this method to perform actual processing of dialog keys. When overriding processKeyPreview(), a control should return true to indicate that it has processed the key. For keys that aren't processed by the control, the result of "base.processKeyEventArgs()" should be returned.
ProcessMnemonic (inherited from Control) Processes a mnemonic character. This method is called to give a control the opportunity to process a mnemonic character. The method should check if the control is in a state to process mnemonics and if the given character represents a mnemonic. If so, the method should perform the action associated with the mnemonic and return true. If not, the method should return false. Implementations of this method often use the isMnemonic() method to check if the given character matches a mnemonic in the control's text, for example:
if (canSelect() && isMnemonic(charCode, getText()) {
    // perform action associated with mnemonic
    }

This default implementation of processMnemonic() simply returns false to indicate that the control has no mnemonic.
RaiseDragEventArgs (inherited from RichControl) | Raises the event associated with key with the event data of e and a sender of this control.
RaiseEvent (inherited from Control) | [To be supplied.]
RaiseKeyEventArgs (inherited from Control) | Raises the event associated with key with the event data of e and a sender of this control.
RaiseMouseEventArgs (inherited from Control) | Raises the event associated with key with the event data of e and a sender of this control.
RaisePaintEventArgs (inherited from RichControl) | Raises the event associated with key with the event data of e and a sender of this control.
RaisePropertyChangedEvent (inherited from Control) | Raises the property changed event. This creates the needed event data and then calls OnPropertyChanged.
RecreateHandle (inherited from Control) | Forces the recreation of the handle for this control. Inheriting controls must call base.recreateHandle.
RemoveEventHandler (inherited from Control) | [To be supplied.]
RemoveEventHandlers (inherited from Control) | [To be supplied.]
ResetMouseEventArgs (inherited from Control) | Resets the mouse leave listeners.
ResumeLayout (inherited from Control) | Overloaded. [To be supplied.]
RTLTranslateAlignment (inherited from RichControl) | Overloaded. [To be supplied.]
RTLTranslateContent (inherited from RichControl) | [To be supplied.]
RTLTranslateHorizontal (inherited from RichControl) | [To be supplied.]
RTLTranslateLeftRight (inherited from RichControl) | [To be supplied.]
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
SendMessage (inherited from Control) | Overloaded. [To be supplied.]
SetBoundsCore (inherited from RichControl) | [To be supplied.]
SetClientSizeCore (inherited from Control) | Performs the work of setting the size of the client area of the control.
SetStyle (inherited from Control) | Sets the current value of the specified bit in the control's style. NOTE: This is control style, not the Win32 style of the hwnd.
UpdateBounds (inherited from Control) | Overloaded. [To be supplied.]
UpdateStyles (inherited from Control) | Forces styles to be reapplied to the handle. This function will call CreateParams to get the styles to apply.
UpdateZOrder (inherited from Control) | Updates this control in it's parent's zorder.
WmSysColorChange (inherited from Control) | Handles the WM_SYSCOLORCHANGE message
WndProc (inherited from TreeView) | [To be supplied.]
WndProcException (inherited from RichControl) | [To be supplied.]

Event Hookup:

AddOnAfterCheck (inherited from TreeView) | Adds an event handler for the "afterCheck" event notification.
AddOnAfterCollapse (inherited from TreeView) | Adds an event handler for the "afterCollapse" event notification. The afterCollapse event is fired after the user has successfully collapsed a node. Collapsing a node hides all child nodes of that node from view.
AddOnAfterExpand (inherited from TreeView) | Adds an event handler for the "afterExpand" event notification. The afterExpand event is fired after the user has successfully expanded a node. Expanding a node causes its child nodes to be displayed.
AddOnAfterLabelEdit (inherited from TreeView) | Adds an event handler for the "afterLabelEdit" event notification. The afterLabelEdit event is fired when the user finishes editing the text of a node in the TreeView. The labelEdit property of the TreeView must be true to enable the user to do this. The string to which the user changed the text is passed to the event, and the event handler is given the opportunity to reject the change, in which case the text will revert back to what it was before the user started the change.
AddOnAfterSelect (inherited from TreeView) | Adds an event handler for the "afterSelect" event notification. The onAfterSelect event is fired after the user has selected a node.
AddOnBeforeCheck (inherited from TreeView) | Adds an event handler for the "beforeCheck" event notification.
AddOnBeforeCollapse (inherited from TreeView) | Adds an event handler for the "beforeCollapse" event notification. The beforeCollapse event is fired when the user attempts to collapse a node. Collapsing a node hides all child nodes of that node from view. The event can be cancelled by the handler, in which case the node won't collapse.
AddOnBeforeExpand (inherited from TreeView) | Adds an event handler for the "beforeExpand" event notification. The beforeExpand event is fired when the user attempts to expand a node. Expanding a node causes its child nodes to be displayed. The event can be cancelled by the handler, in which case the node won't expand.
AddOnBeforeLabelEdit (inherited from TreeView) | Adds an event handler for the "beforeLabelEdit" event notification. The beforeLabelEdit event is fired when the user attempts to begin changing the text of a node in the TreeView. The event handler can cancel this event, in which case the user won't be allowed to edit the text. This event can be used to prevent the user from editing specific nodes in the TreeView. If the labelEdit property of the TreeView is false, this event will not be fired, and all user attempts to edit node labels will be automatically rejected.
AddOnBeforeSelect (inherited from TreeView) | Adds an event handler for the "beforeSelect" event notification. The onBeforeSelect event is fired when the user attempts to select a node. The event can be cancelled by the handler, in which case the node won't be selected.
AddOnClick (inherited from Control) | Adds an event handler for the click event. The click event occurs when the user clicks in the client area of the control.
AddOnControlAdded (inherited from Control) | Adds an event handler for the ControlAdded event. This event is raised after a control is added as a child to this control.
AddOnControlRemoved (inherited from Control) | Adds an event handler for the ControlRemoved event. This event is raised after a child control is removed from this control.
AddOnCreateHandle (inherited from Control) | Adds an event handler for the createHandle event. The createHandle event occurs immediately after the control's handle is created.
AddOnDestroyHandle (inherited from Control) | Adds an event handler for the destroyHandle event. The destroyHandle event occurs immediately before the control's handle is destroyed.
AddOnDoubleClick (inherited from Control) | Adds an event handler for the doubleClick event. The doubleClick event occurs when the user double clicks in the client area of the control.
AddOnDragDrop (inherited from RichControl) | Adds an event handler for the dragDrop event. The dragDrop evnet occurs when the user releases the mouse button while dragging some Object over the control.
AddOnDragEnter (inherited from RichControl) | Adds an event handler for the dragEnter event. The drawEnter event occurs when the user first moves the mouse over the control while dragging some Object.
AddOnDragLeave (inherited from RichControl) | Adds an event handler for the dragLeave event. The dragLeave event occurs when the user first moves the mouse out of the control while dragging some Object.
AddOnDragOver (inherited from RichControl) | Adds an event handler for the dragOver event. The dragOver event occurs whenever the user moves the mouse over the control while draggin some Object.
AddOnEnter (inherited from Control) | Adds an event handler for the enter event. The enter event occurs when focus enters this control. This doesn't imply that this control has focus, but rather that this control or some child control of this control has gotten focus.
AddOnGiveFeedback (inherited from RichControl) | Adds an event handler for the giveFeedback event. The giveFeedback event occurs during a drag operation. This allows the source of a drag event to modify the mouse pointer to give the user visual feedback as to what would happen if they droped.
AddOnGotFocus (inherited from Control) | Adds an event handler for the gotFocus event. The gotFocus event occurs when the this control gains focus.
AddOnHelp (inherited from RichControl) | Adds an event handler for the help event. The help event occurs when the user requests help for this control. This may be caused by the user pressing F1, or used "Whats This Help".
AddOnInvalidate (inherited from RichControl) | Adds an event handler for the invalidate event. The invalidate event occurs when the Invalidate method is called on some part of the control's client area. This event may be used to identify when the contents of a window have changed.
AddOnItemDrag (inherited from TreeView) | Adds an event handler for the "itemDrag" event notification The itemDrag event is fired when the user presses the left or right mouse button over a node and begins to move the mouse. A typical response to this event would be to call doDragDrop.
AddOnKeyDown (inherited from Control) | Adds an event handler for the keyDown event. The keyDown event occurs when the user presses a key down.
AddOnKeyPress (inherited from Control) | Adds an event handler for the keyPress event. The keyPress event occurs when the user presses a key.
AddOnKeyUp (inherited from Control) | Adds an event handler for the keyUp event. The keyUp event occurs when the user releases a key.
AddOnLayout (inherited from Control) | Adds an event handler for the layout event. The layout event occurs when any event occurs that would cause the control to layout child controls. These events include; resize, show/hide child controls, add/remove child controls. This event should be used to perform any custom layout logic.
AddOnLeave (inherited from Control) | Adds an event handler for the leave event. The leave event occurs when focus leaves this control. This doesn't imply that this control lost focus, but rather that focus has been moved out of this control and any child controls.
AddOnLostFocus (inherited from Control) | Adds an event handler for the lostFocus event. The lostFocus event occurs when this control looses focus.
AddOnMouseDown (inherited from Control) | Adds an event handler for the mouseDown event. The mouseDown event occurs when the user presses the mouseDown over this control.
AddOnMouseEnter (inherited from Control) | Adds an event handler for the mouseEnter event. The mouseEnter event occurs when the mouse first moves over this control.
AddOnMouseHover (inherited from Control) | Adds an event handler for the mouseHover event. The mouseHover event occurs after the mouse is inside a control for an amount.
AddOnMouseLeave (inherited from Control) | Adds an event handler for the mouseLeave event. The mouseLeave event occurs when the mouse first moves out of this control.
AddOnMouseMove (inherited from Control) | Adds an event handler for the mouseMove event. The mouseMove event occurs whenever the user moves the mouse over this control.
AddOnMouseUp (inherited from Control) | Adds an event handler for the mouseUp event. The mouseUp event occurs when the user releases a mouse button inside the control.
AddOnMouseWheel (inherited from Control) | Adds an event handler for the mouseWheel event. The mouseWheel event occurs when the user scrolls the mouse wheel up or down. The delta value in the event data indicates the amount that the mouse wheel has moved. The Microsoft standards indicate that the view should scroll by System.WinForms.SystemInformation.getMouseWheelScrollLines() when the delta value has reach win.WHEEL_DELTA. If a mouseWheel event occurs with a value less that WHEEL_DELTA, the control should either increment a stored value and wait until the total delta is an increment of WHEEL_DELTA, or scroll the view a percentage of MouseWheelScrollLines. NOTE: A press of the mouseWheel will generate a mouseDown event with the middle button pressed.
AddOnMove (inherited from Control) | Adds an event handler for the move event. The move event occurs when the controls location changes.
AddOnPaint (inherited from RichControl) | Adds an event handler for the paint event. The paint event occurs when the control needs to paint some part of it's client area.
AddOnPropertyChanged (inherited from Control) | Adds an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.
AddOnQueryContinueDrag (inherited from RichControl) | Adds an event handler for the queryContinueDrag event. The queryContinueDrag event occurs during a drag operation. This allows the drag source to determine if the drag operation should be canceled.
AddOnResize (inherited from Control) | Adds an event handler for the resize event. The resize event occurs when the bounds of the control change. This event may be fired from the constructor of base controls.
AddOnValidated (inherited from Control) | Adds an event handler for the validated event. The validated event occurs when a control was successfully validated.
AddOnValidating (inherited from Control) | Adds an event handler for the validating event. The validating event occurs when the control loses focus and a control that causes validation gains focus. This is where users can write code to validate the current values of the control.
RemoveOnAfterCheck (inherited from TreeView) | Removes the given handler from the "afterCheck" event. If there are duplicate entries, all are removed.
RemoveOnAfterCollapse (inherited from TreeView) | Removes the given handler from the "afterCollapse" event. If there are duplicate entries, all are removed.
RemoveOnAfterExpand (inherited from TreeView) | Removes the given handler from the "afterExpand" event. If there are duplicate entries, all are removed.
RemoveOnAfterLabelEdit (inherited from TreeView) | Removes the given handler from the "afterLabelEdit" event. If there are duplicate entries, all are removed.
RemoveOnAfterSelect (inherited from TreeView) | Removes the given handler from the "afterSelect" event. If there are duplicate entries, all are removed.
RemoveOnBeforeCheck (inherited from TreeView) | Removes the given handler from the "beforeCheck" event. If there are duplicate entries, all are removed.
RemoveOnBeforeCollapse (inherited from TreeView) | Removes the given handler from the "beforeCollapse" event. If there are duplicate entries, all are removed.
RemoveOnBeforeExpand (inherited from TreeView) | Removes the given handler from the "beforeExpand" event. If there are duplicate entries, all are removed.
RemoveOnBeforeLabelEdit (inherited from TreeView) | Removes the given handler from the "beforeLabelEdit" event. If there are duplicate entries, all are removed.
RemoveOnBeforeSelect (inherited from TreeView) | Removes the given handler from the "beforeSelect" event. If there are duplicate entries, all are removed.
RemoveOnClick (inherited from Control) | Removes the given handler for the "OnClick" event. If there are duplicate entries, ALL are removed.
RemoveOnControlAdded (inherited from Control) | Removes the given handler for the "ControlAdded" event. If there are duplicate entries, ALL are removed.
RemoveOnControlRemoved (inherited from Control) | Removes the given handler for the "ControlRemoved" event. If there are duplicate entries, ALL are removed.
RemoveOnCreateHandle (inherited from Control) | Removes the given handler for the "createHandle" event. If there are duplicate entries, ALL are removed.
RemoveOnDestroyHandle (inherited from Control) | Removes the given handler for the "destroyHandle" event. If there are duplicate entries, ALL are removed.
RemoveOnDoubleClick (inherited from Control) | Removes the given handler for the "OnDoubleClick" event. If there are duplicate entries, ALL are removed.
RemoveOnDragDrop (inherited from RichControl) | Removes the given handler for the "dragDrop" event. If there are duplicate entries, ALL are removed.
RemoveOnDragEnter (inherited from RichControl) | Removes the given handler for the "OnDragEnter" event. If there are duplicate entries, ALL are removed.
RemoveOnDragLeave (inherited from RichControl) | Removes the given handler for the "OnDragLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnDragOver (inherited from RichControl) | f final Removes the given handler for the "OnDragOver" event. If there are duplicate entries, ALL are removed.
RemoveOnEnter (inherited from Control) | Removes the given handler for the "OnEnter" event. If there are dfinal uplicate entries, ALL are removed.
RemoveOnGiveFeedback (inherited from RichControl) | Removes the given handler for the "OnGiveFeedback" event. If there are duplicate entries, ALL are removed.
RemoveOnGotFocus (inherited from Control) | Removes the given handler for the "OnGotFocus" event. If there are duplicate entries, ALL are removed.
RemoveOnHelp (inherited from RichControl) | Removes the given handler for the "OnHelp" event. If there are duplicate entries, ALL are removed.
RemoveOnInvalidate (inherited from RichControl) | Removes the given handler for the "OnInvalidate" event. If there are duplicate entries, ALL are removed.
RemoveOnItemDrag (inherited from TreeView) | Removes the given handler from the "itemDrag" event. If there are duplicate entries, all are removed.
RemoveOnKeyDown (inherited from Control) | Removes the given handler for the "OnKeyDown" event. If there are duplicate entries, ALL are removed.
RemoveOnKeyPress (inherited from Control) | Removes the given handler for the "OnKeyPress" event. If there are duplicate entries, ALL are removed.
RemoveOnKeyUp (inherited from Control) | Removes the given handler for the "OnKeyUp" event. If there are duplicate entries, ALL are removed.
RemoveOnLayout (inherited from Control) | Removes the given handler for the layout event. If there are duplicate entries, ALL are removed.
RemoveOnLeave (inherited from Control) | Removes the given handler for the "OnLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnLostFocus (inherited from Control) | Removes the given handler for the "OnLostFocus" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseDown (inherited from Control) | Removes the given handler for the "OnMouseDown" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseEnter (inherited from Control) | Removes the given handler for the "OnMouseEnter" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseHover (inherited from Control) | Removes the given handler for the "OnMouseHover" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseLeave (inherited from Control) | Removes the given handler for the "OnMouseLeave" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseMove (inherited from Control) | Removes the given handler for the "OnMouseMove" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseUp (inherited from Control) | Removes the given handler for the "OnMouseUp" event. If there are duplicate entries, ALL are removed.
RemoveOnMouseWheel (inherited from Control) | Removes the given handler for the "OnMouseWheel" event. If there are duplicate entries, ALL are removed.
RemoveOnMove (inherited from Control) | Removes the given handler for the "OnMove" event. If there are duplicate entries, ALL are removed.
RemoveOnPaint (inherited from RichControl) | Removes the given handler for the "OnPaint" event. If there are duplicate entries, ALL are removed.
RemoveOnPropertyChanged (inherited from Control) | Removes an event handler for the property changed event. This event occurs when any property on the control has been changed for any reason.
RemoveOnQueryContinueDrag (inherited from RichControl) | Removes the given handler for the "OnQueryContinueDrag" event. If there are duplicate entries, ALL are removed.
RemoveOnResize (inherited from Control) | Removes the given handler for the "OnResize" event. If there are duplicate entries, ALL are removed.
RemoveOnValidated (inherited from Control) | Removes an event handler for the validated event. The validated event occurs when a control was successfully validated.
RemoveOnValidating (inherited from Control) | Removes an event handler for the validating event. The validating event occurs when the control loses focus and a control that causes validation gains focus. This is where users can write code to validate the current values of the control.

See Also

BitMaskSelector Class | System.Data.Design Namespace


BitMaskSelector.OnKeyDown

[To be supplied.]

[Visual Basic]
Overrides Protected Sub OnKeyDown( _
   ByVal e As KeyEventArgs _
)
[C#]
protected override void OnKeyDown(
   KeyEventArgs e
);
[C++]
protected: override void OnKeyDown(
   KeyEventArgs* e
);
[JScript]
protected override function OnKeyDown(
   e : KeyEventArgs
);

Parameters

e
[To be supplied.]

See Also

BitMaskSelector Class | BitMaskSelector Members | System.Data.Design Namespace


CascadeValueEditor Class

[To be supplied.]

Object
UITypeEditor
CascadeValueEditor

[Visual Basic]
Public Class CascadeValueEditor
   Inherits UITypeEditor
[C#]
public class CascadeValueEditor : UITypeEditor
[C++]
public __gc class CascadeValueEditor : public UITypeEditor
[JScript]
public class CascadeValueEditor extends UITypeEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Design

Assembly: System.Data.Design.dll

See Also

CascadeValueEditor Members | System.Data.Design Namespace


CascadeValueEditor Members

Public:

Constructor

CascadeValueEditor Constructor [To be supplied.]

Methods

EditValue | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEditStyle (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CascadeValueEditor Class | System.Data.Design Namespace


CascadeValueEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CascadeValueEditor();
[C++]
public: CascadeValueEditor();
[JScript]
public function CascadeValueEditor();

See Also

CascadeValueEditor Class | CascadeValueEditor Members | System.Data.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CascadeValueEditor Methods

The methods of the CascadeValueEditor class are listed below. For a complete list of CascadeValueEditor class members, see the CascadeValueEditor Members topic.

Public:

EditValue | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEditStyle (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CascadeValueEditor Class | System.Data.Design Namespace


CascadeValueEditor.EditValue

[To be supplied.]

[Visual Basic]
Overrides Public Function EditValue( _
   ByVal context As ITypeDescriptorContext, _
   ByVal provider As IServiceObjectProvider, _
   ByVal value As Object _
) As Object
[C#]
public override object EditValue(
   ITypeDescriptorContext context,
   IServiceObjectProvider provider,
   object value
);
[C++]
public: override Object* EditValue(
   ITypeDescriptorContext* context,
   IServiceObjectProvider* provider,
   Object* value
);
[JScript]
public override function EditValue(
   context : ITypeDescriptorContext,
   provider : IServiceObjectProvider,
   value : Object
) : Object;

Parameters

context
[To be supplied.]
provider
[To be supplied.]
value
[To be supplied.]

See Also

CascadeValueEditor Class | CascadeValueEditor Members | System.Data.Design Namespace


CascadeValueEditor.GetEditStyle

[To be supplied.]

[Visual Basic]
Overrides Public Function GetEditStyle( _
   ByVal context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
[C#]
public override UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext context
);
[C++]
public: override UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetEditStyle(
   context : ITypeDescriptorContext
) : UITypeEditorEditStyle;

Parameters

context
[To be supplied.]

See Also

CascadeValueEditor Class | CascadeValueEditor Members | System.Data.Design Namespace


ColumnsCollectionEditor Class

Collection ValueEditor for ColumsCollection

Object
UITypeEditor
CollectionEditor
ColumnsCollectionEditor

[Visual Basic]
NotInheritable Public Class ColumnsCollectionEditor
   Inherits CollectionEditor
[C#]
public sealed class ColumnsCollectionEditor : CollectionEditor
[C++]
public __gc __sealed class ColumnsCollectionEditor : public
   CollectionEditor
[JScript]
public class ColumnsCollectionEditor extends CollectionEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Design

Assembly: System.Data.Design.dll

See Also

ColumnsCollectionEditor Members | System.Data.Design Namespace


ColumnsCollectionEditor Members

Public:

Constructor

ColumnsCollectionEditor Constructor [To be supplied.]

Methods

EditValue | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEditStyle (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

CollectionItemType (inherited from CollectionEditor) | The data type of each item in the collection.
CollectionType (inherited from CollectionEditor) | Retrieves the data type of the collection we are editing.
Context (inherited from CollectionEditor) | The type descriptor context that is currently in use, or null if no context is available.
NewItemTypes (inherited from CollectionEditor) | The available item types that can be created for this collection. This defaults to a single type of CollectionItemType. If more than one type is returned the collection editor will provide a way to choose which item to create.

Methods

CanRemoveInstance | Here we check to see if it is OK to remove this instance from the collection.
CreateCollectionForm (inherited from CollectionEditor) | Creates a new form to show the current collection. You may inherit from CollectionForm to provide your own form.
CreateCollectionItemType (inherited from CollectionEditor) | Retrieves the data type this collection contains. The default implementation looks inside of the collection for the Item property and returns the returning datatype of the item. Do not call this method directly. Instead, use the CollectionItemType property. Use this method to override the default implementation.
CreateInstance | We add new instance of DataColumn to parentCollection, so new instance has valid parent property, and valid names.
CreateNewItemTypes (inherited from CollectionEditor) | Retrieves the data types this collection editor can create. The default implementation looks inside of the collection for the Item property and returns the returning datatype of the item. Do not call this method directly. Instead, use the NewItemTypes property. Use this method to override the default implementation.
DestroyInstance | We have to remove inctances that were created by CreateNewInctance this called in case Cancel button was hit.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetItems (inherited from CollectionEditor) | Converts the given collection into an array of objects. This is used by the editing dialog to manipulate the individual collection.
GetServiceObject (inherited from CollectionEditor) | Retrieves the requested service, if it is available.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetItems (inherited from CollectionEditor) | Sets the given collection to have the given array of items. If setting requires that a new object be created, the new object should be returned. Otherwise, editValue should be returned.

See Also

ColumnsCollectionEditor Class | System.Data.Design Namespace


ColumnsCollectionEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal type As Type _
)
[C#]
public ColumnsCollectionEditor(
   Type type
);
[C++]
public: ColumnsCollectionEditor(
   Type* type
);
[JScript]
public function ColumnsCollectionEditor(
   type : Type
);

Parameters

type
[To be supplied.]

See Also

ColumnsCollectionEditor Class | ColumnsCollectionEditor Members | System.Data.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ColumnsCollectionEditor Methods

The methods of the ColumnsCollectionEditor class are listed below. For a complete list of ColumnsCollectionEditor class members, see the ColumnsCollectionEditor Members topic.

Public:

EditValue | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEditStyle (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

CanRemoveInstance | Here we check to see if it is OK to remove this instance from the collection.
CreateCollectionForm (inherited from CollectionEditor) | Creates a new form to show the current collection. You may inherit from CollectionForm to provide your own form.
CreateCollectionItemType (inherited from CollectionEditor) | Retrieves the data type this collection contains. The default implementation looks inside of the collection for the Item property and returns the returning datatype of the item. Do not call this method directly. Instead, use the CollectionItemType property. Use this method to override the default implementation.
CreateInstance | We add new instance of DataColumn to parentCollection, so new instance has valid parent property, and valid names.
CreateNewItemTypes (inherited from CollectionEditor) | Retrieves the data types this collection editor can create. The default implementation looks inside of the collection for the Item property and returns the returning datatype of the item. Do not call this method directly. Instead, use the NewItemTypes property. Use this method to override the default implementation.
DestroyInstance | We have to remove inctances that were created by CreateNewInctance this called in case Cancel button was hit.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetItems (inherited from CollectionEditor) | Converts the given collection into an array of objects. This is used by the editing dialog to manipulate the individual collection.
GetServiceObject (inherited from CollectionEditor) | Retrieves the requested service, if it is available.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetItems (inherited from CollectionEditor) | Sets the given collection to have the given array of items. If setting requires that a new object be created, the new object should be returned. Otherwise, editValue should be returned.

See Also

ColumnsCollectionEditor Class | System.Data.Design Namespace


ColumnsCollectionEditor.CanRemoveInstance

Here we check to see if it is OK to remove this instance from the collection.

[Visual Basic]
Overrides Protected Function CanRemoveInstance( _
   ByVal value As Object _
) As Boolean
[C#]
protected override bool CanRemoveInstance(
   object value
);
[C++]
protected: override bool CanRemoveInstance(
   Object* value
);
[JScript]
protected override function CanRemoveInstance(
   value : Object
) : Boolean;

Parameters

value
[To be supplied.]

See Also

ColumnsCollectionEditor Class | ColumnsCollectionEditor Members | System.Data.Design Namespace


ColumnsCollectionEditor.CreateInstance

We add new instance of DataColumn to parentCollection, so new instance has valid parent property, and valid names.

[Visual Basic]
Overrides Protected Function CreateInstance( _
   ByVal type As Type _
) As Object
[C#]
protected override object CreateInstance(
   Type type
);
[C++]
protected: override Object* CreateInstance(
   Type* type
);
[JScript]
protected override function CreateInstance(
   type : Type
) : Object;

Parameters

type
[To be supplied.]

See Also

ColumnsCollectionEditor Class | ColumnsCollectionEditor Members | System.Data.Design Namespace


ColumnsCollectionEditor.DestroyInstance

We have to remove inctances that were created by CreateNewInctance this called in case Cancel button was hit.

[Visual Basic]
Overrides Protected Sub DestroyInstance( _
   ByVal value As Object _
)
[C#]
protected override void DestroyInstance(
   object value
);
[C++]
protected: override void DestroyInstance(
   Object* value
);
[JScript]
protected override function DestroyInstance(
   value : Object
);

Parameters

value
[To be supplied.]

See Also

ColumnsCollectionEditor Class | ColumnsCollectionEditor Members | System.Data.Design Namespace


ColumnsCollectionEditor.EditValue

Edits the given object value using the editor style provided by GetEditorStyle. A service provider is provided so that any required editing services can be obtained.

[Visual Basic]
Overrides Public Function EditValue( _
   ByVal context As ITypeDescriptorContext, _
   ByVal provider As IServiceObjectProvider, _
   ByVal value As Object _
) As Object
[C#]
public override object EditValue(
   ITypeDescriptorContext context,
   IServiceObjectProvider provider,
   object value
);
[C++]
public: override Object* EditValue(
   ITypeDescriptorContext* context,
   IServiceObjectProvider* provider,
   Object* value
);
[JScript]
public override function EditValue(
   context : ITypeDescriptorContext,
   provider : IServiceObjectProvider,
   value : Object
) : Object;

Parameters

context
A type descriptor context that can be used to provide additional context information.
provider
A service provider object through which editing services may be obtained.
value
An instance of the value being edited.

Return Value

The new value of the object. If the value of the object hasn't changed, this should return the same object it was passed.

See Also

ColumnsCollectionEditor Class | ColumnsCollectionEditor Members | System.Data.Design Namespace


ColumnTypeEditor Class

[To be supplied.]

Object
ValueEditor
TypeListEditor
ColumnTypeEditor

[Visual Basic]
Public Class ColumnTypeEditor
   Inherits TypeListEditor
[C#]
public class ColumnTypeEditor : TypeListEditor
[C++]
public __gc class ColumnTypeEditor : public TypeListEditor
[JScript]
public class ColumnTypeEditor extends TypeListEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Design

Assembly: System.Data.Design.dll

See Also

ColumnTypeEditor Members | System.Data.Design Namespace


ColumnTypeEditor Members

Public:

Constructor

ColumnTypeEditor Constructor [To be supplied.]

Properties

Style (inherited from TypeListEditor) | [To be supplied.]
Values (inherited from TypeListEditor) | [To be supplied.]

Methods

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from TypeListEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue (inherited from TypeListEditor) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from TypeListEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

DataTypes [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ColumnTypeEditor Class | System.Data.Design Namespace


ColumnTypeEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ColumnTypeEditor();
[C++]
public: ColumnTypeEditor();
[JScript]
public function ColumnTypeEditor();

See Also

ColumnTypeEditor Class | ColumnTypeEditor Members | System.Data.Design Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ColumnTypeEditor Fields

The fields of the ColumnTypeEditor class are listed below. For a complete list of ColumnTypeEditor class members, see the ColumnTypeEditor Members topic.

Public:

DataTypes [To be supplied.]

See Also

ColumnTypeEditor Class | System.Data.Design Namespace


ColumnTypeEditor.DataTypes

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly DataTypes() As Type
[C#]
public static readonly Type[] DataTypes;
[C++]
public: static readonly Type* DataTypes[];
[JScript]
public static var DataTypes : Type[];

See Also

ColumnTypeEditor Class | ColumnTypeEditor Members | System.Data.Design Namespace


ConstraintsCollectionEditor Class

Collection ValueEditor for ConstraintsCollection

Object
UITypeEditor
CollectionEditor
ConstraintsCollectionEditor

[Visual Basic]
NotInheritable Public Class ConstraintsCollectionEditor
   Inherits CollectionEditor
[C#]
public sealed class ConstraintsCollectionEditor : CollectionEditor
[C++]
public __gc __sealed class ConstraintsCollectionEditor : public
   CollectionEditor
[JScript]
public class ConstraintsCollectionEditor extends CollectionEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Design

Assembly: System.Data.Design.dll

See Also

ConstraintsCollectionEditor Members | System.Data.Design Namespace


ConstraintsCollectionEditor Members

Public:

Constructor

ConstraintsCollectionEditor Constructor [To be supplied.]

Methods

EditValue | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEditStyle (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

CollectionItemType (inherited from CollectionEditor) | The data type of each item in the collection.
CollectionType (inherited from CollectionEditor) | Retrieves the data type of the collection we are editing.
Context (inherited from CollectionEditor) | The type descriptor context that is currently in use, or null if no context is available.
NewItemTypes (inherited from CollectionEditor) | The available item types that can be created for this collection. This defaults to a single type of CollectionItemType. If more than one type is returned the collection editor will provide a way to choose which item to create.

Methods

CanRemoveInstance | Here we check to see if it is OK to remove this instance from the collection.
CreateCollectionForm (inherited from CollectionEditor) | Creates a new form to show the current collection. You may inherit from CollectionForm to provide your own form.
CreateCollectionItemType (inherited from CollectionEditor) | Retrieves the data type this collection contains. The default implementation looks inside of the collection for the Item property and returns the returning datatype of the item. Do not call this method directly. Instead, use the CollectionItemType property. Use this method to override the default implementation.
CreateInstance (inherited from CollectionEditor) | Creates a new instance of the given collection item type.
CreateNewItemTypes | Retrieves the data types this collection can contain. The default implementation looks inside of the collection for the Item property and returns the returning datatype of the item. Do not call this method directly. Instead, use the ItemTypes property. Use this method to override the default implementation.
DestroyInstance (inherited from CollectionEditor) | Destroys the given instance of the object.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetItems (inherited from CollectionEditor) | Converts the given collection into an array of objects. This is used by the editing dialog to manipulate the individual collection.
GetServiceObject (inherited from CollectionEditor) | Retrieves the requested service, if it is available.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetItems (inherited from CollectionEditor) | Sets the given collection to have the given array of items. If setting requires that a new object be created, the new object should be returned. Otherwise, editValue should be returned.

See Also

ConstraintsCollectionEditor Class | System.Data.Design Namespace


ConstraintsCollectionEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal type As Type _
)
[C#]
public ConstraintsCollectionEditor(
   Type type
);
[C++]
public: ConstraintsCollectionEditor(
   Type* type
);
[JScript]
public function ConstraintsCollectionEditor(
   type : Type
);

Parameters

type
[To be supplied.]

See Also

ConstraintsCollectionEditor Class | ConstraintsCollectionEditor Members | System.Data.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ConstraintsCollectionEditor Methods

The methods of the ConstraintsCollectionEditor class are listed below. For a complete list of ConstraintsCollectionEditor class members, see the ConstraintsCollectionEditor Members topic.

Public:

EditValue | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEditStyle (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

CanRemoveInstance | Here we check to see if it is OK to remove this instance from the collection.
CreateCollectionForm (inherited from CollectionEditor) | Creates a new form to show the current collection. You may inherit from CollectionForm to provide your own form.
CreateCollectionItemType (inherited from CollectionEditor) | Retrieves the data type this collection contains. The default implementation looks inside of the collection for the Item property and returns the returning datatype of the item. Do not call this method directly. Instead, use the CollectionItemType property. Use this method to override the default implementation.
CreateInstance (inherited from CollectionEditor) | Creates a new instance of the given collection item type.
CreateNewItemTypes | Retrieves the data types this collection can contain. The default implementation looks inside of the collection for the Item property and returns the returning datatype of the item. Do not call this method directly. Instead, use the ItemTypes property. Use this method to override the default implementation.
DestroyInstance (inherited from CollectionEditor) | Destroys the given instance of the object.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetItems (inherited from CollectionEditor) | Converts the given collection into an array of objects. This is used by the editing dialog to manipulate the individual collection.
GetServiceObject (inherited from CollectionEditor) | Retrieves the requested service, if it is available.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetItems (inherited from CollectionEditor) | Sets the given collection to have the given array of items. If setting requires that a new object be created, the new object should be returned. Otherwise, editValue should be returned.

See Also

ConstraintsCollectionEditor Class | System.Data.Design Namespace


ConstraintsCollectionEditor.CanRemoveInstance

Here we check to see if it is OK to remove this instance from the collection.

[Visual Basic]
Overrides Protected Function CanRemoveInstance( _
   ByVal value As Object _
) As Boolean
[C#]
protected override bool CanRemoveInstance(
   object value
);
[C++]
protected: override bool CanRemoveInstance(
   Object* value
);
[JScript]
protected override function CanRemoveInstance(
   value : Object
) : Boolean;

Parameters

value
[To be supplied.]

See Also

ConstraintsCollectionEditor Class | ConstraintsCollectionEditor Members | System.Data.Design Namespace


ConstraintsCollectionEditor.CreateNewItemTypes

Retrieves the data types this collection can contain. The default implementation looks inside of the collection for the Item property and returns the returning datatype of the item. Do not call this method directly. Instead, use the ItemTypes property. Use this method to override the default implementation.

[Visual Basic]
Overrides Protected Function CreateNewItemTypes() As Type ()
[C#]
protected override Type[] CreateNewItemTypes();
[C++]
protected: override Type* CreateNewItemTypes() [];
[JScript]
protected override function CreateNewItemTypes() : Type[];

Return Value

An array of types this collection can contain.

See Also

ConstraintsCollectionEditor Class | ConstraintsCollectionEditor Members | System.Data.Design Namespace


ConstraintsCollectionEditor.EditValue

Edits the given object value using the editor style provided by GetEditorStyle. A service provider is provided so that any required editing services can be obtained.

[Visual Basic]
Overrides Public Function EditValue( _
   ByVal context As ITypeDescriptorContext, _
   ByVal provider As IServiceObjectProvider, _
   ByVal value As Object _
) As Object
[C#]
public override object EditValue(
   ITypeDescriptorContext context,
   IServiceObjectProvider provider,
   object value
);
[C++]
public: override Object* EditValue(
   ITypeDescriptorContext* context,
   IServiceObjectProvider* provider,
   Object* value
);
[JScript]
public override function EditValue(
   context : ITypeDescriptorContext,
   provider : IServiceObjectProvider,
   value : Object
) : Object;

Parameters

context
A type descriptor context that can be used to provide additional context information.
provider
A service provider object through which editing services may be obtained.
value
An instance of the value being edited.

Return Value

The new value of the object. If the value of the object hasn't changed, this should return the same object it was passed.

See Also

ConstraintsCollectionEditor Class | ConstraintsCollectionEditor Members | System.Data.Design Namespace


DataSourceDesigner Class

[To be supplied.]

Object
ComponentDesigner
DataSourceDesigner

[Visual Basic]
Public Class DataSourceDesigner
   Inherits ComponentDesigner
[C#]
public class DataSourceDesigner : ComponentDesigner
[C++]
public __gc class DataSourceDesigner : public ComponentDesigner
[JScript]
public class DataSourceDesigner extends ComponentDesigner

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Design

Assembly: System.Data.Design.dll

See Also

DataSourceDesigner Members | System.Data.Design Namespace


DataSourceDesigner Members

Public:

Constructor

DataSourceDesigner Constructor [To be supplied.]

Properties

Component (inherited from ComponentDesigner) | Gets or sets the component this designer is designing.
Verbs | [To be supplied.]

Methods

Dispose (inherited from ComponentDesigner) | Disposes of the resources (other than memory) used by the ComponentDesigner.
DoDefaultAction (inherited from ComponentDesigner) | This creates a method signature in the source code file for the default event on the component and navigates the user's cursor to that location.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Initialize (inherited from ComponentDesigner) | Establishes the component for this designer. The designer host will set this when it is ready for the designer to be used.
OnSetComponentDefaults (inherited from ComponentDesigner) | Called when the designer is intialized. This allows the designer to provide some meaningful default values in the component. The default implementation of this sets the components's default property to it's name, if that property is a string.
PostFilterAttributes (inherited from ComponentDesigner) | Allows a designer to filter the set of member attributes the component it is designing will expose through the TypeDescriptor object. This method is called immediately after its corresponding "Pre" method. If you are overriding this method you should call the the base implementation after you perform your own filtering.
PostFilterEvents (inherited from ComponentDesigner) | Allows a designer to filter the set of events the component it is designing will expose through the TypeDescriptor object. This method is called immediately after its corresponding "Pre" method. If you are overriding this method you should call the the base implementation after you perform your own filtering.
PostFilterProperties (inherited from ComponentDesigner) | Allows a designer to filter the set of properties the component it is designing will expose through the TypeDescriptor object. This method is called immediately after its corresponding "Pre" method. If you are overriding this method you should call the the base implementation after you perform your own filtering.
PreFilterAttributes (inherited from ComponentDesigner) | Allows a designer to filter the set of member attributes the component it is designing will expose through the TypeDescriptor object. This method is called immediately before its corresponding "Post" method. If you are overriding this method you should call the base implementation before you perform your own filtering.
PreFilterEvents (inherited from ComponentDesigner) | Allows a designer to filter the set of events the component it is designing will expose through the TypeDescriptor object. This method is called immediately before its corresponding "Post" method. If you are overriding this method you should call the base implementation before you perform your own filtering.
PreFilterProperties (inherited from ComponentDesigner) | Allows a designer to filter the set of properties the component it is designing will expose through the TypeDescriptor object. This method is called immediately before its corresponding "Post" method. If you are overriding this method you should call the base implementation before you perform your own filtering.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

InheritanceAttribute (inherited from ComponentDesigner) | Gets or sets the inheritance attribute for this component.
Inherited (inherited from ComponentDesigner) | Gets whether or not this component is being inherited.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetDefaultValue (inherited from ComponentDesigner) | Retrieves the default value for the given property. If there is no default value attribute, this will assume that comp already contains the default value and request the value directly from it.
GetServiceObject (inherited from ComponentDesigner) | Provides a way for a designer to get services from the hosting environment. The default implementation of this requests the service from the compoent's site.
InvokeGetInheritanceAttribute (inherited from ComponentDesigner) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnInitializeShadowProperties (inherited from ComponentDesigner) | Called when the designer is intialized. This allows the designer to initialize the values of any shadow properties it has.
RaiseComponentChanged (inherited from ComponentDesigner) | Notifies the IComponentChangeService that this component has been changed. You only need to call this when you are affecting component properties directly and not through the MemberDescriptor's accessors.
RaiseComponentChanging (inherited from ComponentDesigner) | Notifies the IComponentChangeService that this component is about to be changed. You only need to call this when you are affecting component properties directly and not through the MemberDescriptor's accessors.
SetPropertyWithUndo (inherited from ComponentDesigner) | Overloaded. [To be supplied.]

Fields

designerVerbs [To be supplied.]

See Also

DataSourceDesigner Class | System.Data.Design Namespace


DataSourceDesigner Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public DataSourceDesigner();
[C++]
public: DataSourceDesigner();
[JScript]
public function DataSourceDesigner();

See Also

DataSourceDesigner Class | DataSourceDesigner Members | System.Data.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataSourceDesigner Properties

The properties of the DataSourceDesigner class are listed below. For a complete list of DataSourceDesigner class members, see the DataSourceDesigner Members topic.

Public:

Component (inherited from ComponentDesigner) | Gets or sets the component this designer is designing.
Verbs | [To be supplied.]

Protected:

InheritanceAttribute (inherited from ComponentDesigner) | Gets or sets the inheritance attribute for this component.
Inherited (inherited from ComponentDesigner) | Gets whether or not this component is being inherited.

See Also

DataSourceDesigner Class | System.Data.Design Namespace


DataSourceDesigner.Verbs

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Verbs As DesignerVerb ()
[C#]
public DesignerVerb[] Verbs {override get;}
[C++]
public: __property virtual DesignerVerb* get_Verbs();
[JScript]
public function get Verbs() : DesignerVerb[];

See Also

DataSourceDesigner Class | DataSourceDesigner Members | System.Data.Design Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataSourceDesigner Fields

The fields of the DataSourceDesigner class are listed below. For a complete list of DataSourceDesigner class members, see the DataSourceDesigner Members topic.

Protected:

designerVerbs [To be supplied.]

See Also

DataSourceDesigner Class | System.Data.Design Namespace


DataSourceDesigner.designerVerbs

[To be supplied.]

[Visual Basic]
Protected designerVerbs() As DesignerVerb
[C#]
protected DesignerVerb[] designerVerbs;
[C++]
protected: DesignerVerb* designerVerbs[];
[JScript]
protected var designerVerbs : DesignerVerb[];

See Also

DataSourceDesigner Class | DataSourceDesigner Members | System.Data.Design Namespace


DataSourceValueEditor Class

[To be supplied.]

Object
UITypeEditor
ObjectSelectorEditor
DataSourceValueEditor

[Visual Basic]
Public Class DataSourceValueEditor
   Inherits ObjectSelectorEditor
[C#]
public class DataSourceValueEditor : ObjectSelectorEditor
[C++]
public __gc class DataSourceValueEditor : public
   ObjectSelectorEditor
[JScript]
public class DataSourceValueEditor extends ObjectSelectorEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Design

Assembly: System.Data.Design.dll

See Also

DataSourceValueEditor Members | System.Data.Design Namespace


DataSourceValueEditor Members

Public:

Constructor

DataSourceValueEditor Constructor [To be supplied.]

Methods

EditValue (inherited from ObjectSelectorEditor) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
EqualsToValue (inherited from ObjectSelectorEditor) | [To be supplied.]
GetEditStyle (inherited from ObjectSelectorEditor) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
SetValue | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

subObjectSelector (inherited from ObjectSelectorEditor) [To be supplied.]

Protected:

Methods

FillTreeWithData | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

currValue (inherited from ObjectSelectorEditor) | [To be supplied.]
prevValue (inherited from ObjectSelectorEditor) | [To be supplied.]

See Also

DataSourceValueEditor Class | System.Data.Design Namespace


DataSourceValueEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public DataSourceValueEditor();
[C++]
public: DataSourceValueEditor();
[JScript]
public function DataSourceValueEditor();

See Also

DataSourceValueEditor Class | DataSourceValueEditor Members | System.Data.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataSourceValueEditor Methods

The methods of the DataSourceValueEditor class are listed below. For a complete list of DataSourceValueEditor class members, see the DataSourceValueEditor Members topic.

Public:

EditValue (inherited from ObjectSelectorEditor) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
EqualsToValue (inherited from ObjectSelectorEditor) | [To be supplied.]
GetEditStyle (inherited from ObjectSelectorEditor) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
SetValue | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

FillTreeWithData | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataSourceValueEditor Class | System.Data.Design Namespace


DataSourceValueEditor.FillTreeWithData

[To be supplied.]

[Visual Basic]
Overrides Protected Sub FillTreeWithData( _
   ByVal selector As ObjectSelectorEditor.Selector, _
   ByVal context As ITypeDescriptorContext, _
   ByVal provider As IServiceObjectProvider _
)
[C#]
protected override void FillTreeWithData(
   ObjectSelectorEditor.Selector selector,
   ITypeDescriptorContext context,
   IServiceObjectProvider provider
);
[C++]
protected: override void FillTreeWithData(
   ObjectSelectorEditor.Selector* selector,
   ITypeDescriptorContext* context,
   IServiceObjectProvider* provider
);
[JScript]
protected override function FillTreeWithData(
   selector : ObjectSelectorEditor.Selector,
   context : ITypeDescriptorContext,
   provider : IServiceObjectProvider
);

Parameters

selector
[To be supplied.]
context
[To be supplied.]
provider
[To be supplied.]

See Also

DataSourceValueEditor Class | DataSourceValueEditor Members | System.Data.Design Namespace


DataSourceValueEditor.SetValue

[To be supplied.]

[Visual Basic]
Overrides Public Sub SetValue( _
   ByVal value As Object _
)
[C#]
public override void SetValue(
   object value
);
[C++]
public: override void SetValue(
   Object* value
);
[JScript]
public override function SetValue(
   value : Object
);

Parameters

value
[To be supplied.]

See Also

DataSourceValueEditor Class | DataSourceValueEditor Members | System.Data.Design Namespace


DataTableValueEditor Class

[To be supplied.]

Object
UITypeEditor
ObjectSelectorEditor
DataTableValueEditor

[Visual Basic]
Public Class DataTableValueEditor
   Inherits ObjectSelectorEditor
[C#]
public class DataTableValueEditor : ObjectSelectorEditor
[C++]
public __gc class DataTableValueEditor : public
   ObjectSelectorEditor
[JScript]
public class DataTableValueEditor extends ObjectSelectorEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Design

Assembly: System.Data.Design.dll

See Also

DataTableValueEditor Members | System.Data.Design Namespace


DataTableValueEditor Members

Public:

Constructor

DataTableValueEditor Constructor [To be supplied.]

Methods

EditValue (inherited from ObjectSelectorEditor) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
EqualsToValue (inherited from ObjectSelectorEditor) | [To be supplied.]
GetEditStyle (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
SetValue | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

subObjectSelector (inherited from ObjectSelectorEditor) [To be supplied.]

Protected:

Methods

FillTreeWithData | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

currValue (inherited from ObjectSelectorEditor) | [To be supplied.]
prevValue (inherited from ObjectSelectorEditor) | [To be supplied.]

See Also

DataTableValueEditor Class | System.Data.Design Namespace


DataTableValueEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public DataTableValueEditor();
[C++]
public: DataTableValueEditor();
[JScript]
public function DataTableValueEditor();

See Also

DataTableValueEditor Class | DataTableValueEditor Members | System.Data.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataTableValueEditor Methods

The methods of the DataTableValueEditor class are listed below. For a complete list of DataTableValueEditor class members, see the DataTableValueEditor Members topic.

Public:

EditValue (inherited from ObjectSelectorEditor) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
EqualsToValue (inherited from ObjectSelectorEditor) | [To be supplied.]
GetEditStyle (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
SetValue | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

FillTreeWithData | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataTableValueEditor Class | System.Data.Design Namespace


DataTableValueEditor.FillTreeWithData

[To be supplied.]

[Visual Basic]
Overrides Protected Sub FillTreeWithData( _
   ByVal selector As ObjectSelectorEditor.Selector, _
   ByVal context As ITypeDescriptorContext, _
   ByVal provider As IServiceObjectProvider _
)
[C#]
protected override void FillTreeWithData(
   ObjectSelectorEditor.Selector selector,
   ITypeDescriptorContext context,
   IServiceObjectProvider provider
);
[C++]
protected: override void FillTreeWithData(
   ObjectSelectorEditor.Selector* selector,
   ITypeDescriptorContext* context,
   IServiceObjectProvider* provider
);
[JScript]
protected override function FillTreeWithData(
   selector : ObjectSelectorEditor.Selector,
   context : ITypeDescriptorContext,
   provider : IServiceObjectProvider
);

Parameters

selector
[To be supplied.]
context
[To be supplied.]
provider
[To be supplied.]

See Also

DataTableValueEditor Class | DataTableValueEditor Members | System.Data.Design Namespace


DataTableValueEditor.SetValue

[To be supplied.]

[Visual Basic]
Overrides Public Sub SetValue( _
   ByVal value As Object _
)
[C#]
public override void SetValue(
   object value
);
[C++]
public: override void SetValue(
   Object* value
);
[JScript]
public override function SetValue(
   value : Object
);

Parameters

value
[To be supplied.]

See Also

DataTableValueEditor Class | DataTableValueEditor Members | System.Data.Design Namespace


DataViewRowStateEditor Class

[To be supplied.]

Object
UITypeEditor
DataViewRowStateEditor

[Visual Basic]
Public Class DataViewRowStateEditor
   Inherits UITypeEditor
[C#]
public class DataViewRowStateEditor : UITypeEditor
[C++]
public __gc class DataViewRowStateEditor : public UITypeEditor
[JScript]
public class DataViewRowStateEditor extends UITypeEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Design

Assembly: System.Data.Design.dll

See Also

DataViewRowStateEditor Members | System.Data.Design Namespace


DataViewRowStateEditor Members

Public:

Constructor

DataViewRowStateEditor Constructor [To be supplied.]

Methods

EditValue | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEditStyle (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataViewRowStateEditor Class | System.Data.Design Namespace


DataViewRowStateEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public DataViewRowStateEditor();
[C++]
public: DataViewRowStateEditor();
[JScript]
public function DataViewRowStateEditor();

See Also

DataViewRowStateEditor Class | DataViewRowStateEditor Members | System.Data.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataViewRowStateEditor Methods

The methods of the DataViewRowStateEditor class are listed below. For a complete list of DataViewRowStateEditor class members, see the DataViewRowStateEditor Members topic.

Public:

EditValue | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEditStyle (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataViewRowStateEditor Class | System.Data.Design Namespace


DataViewRowStateEditor.EditValue

[To be supplied.]

[Visual Basic]
Overrides Public Function EditValue( _
   ByVal context As ITypeDescriptorContext, _
   ByVal provider As IServiceObjectProvider, _
   ByVal value As Object _
) As Object
[C#]
public override object EditValue(
   ITypeDescriptorContext context,
   IServiceObjectProvider provider,
   object value
);
[C++]
public: override Object* EditValue(
   ITypeDescriptorContext* context,
   IServiceObjectProvider* provider,
   Object* value
);
[JScript]
public override function EditValue(
   context : ITypeDescriptorContext,
   provider : IServiceObjectProvider,
   value : Object
) : Object;

Parameters

context
[To be supplied.]
provider
[To be supplied.]
value
[To be supplied.]

See Also

DataViewRowStateEditor Class | DataViewRowStateEditor Members | System.Data.Design Namespace


DataViewRowStateEditor.GetEditStyle

[To be supplied.]

[Visual Basic]
Overrides Public Function GetEditStyle( _
   ByVal context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
[C#]
public override UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext context
);
[C++]
public: override UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetEditStyle(
   context : ITypeDescriptorContext
) : UITypeEditorEditStyle;

Parameters

context
[To be supplied.]

See Also

DataViewRowStateEditor Class | DataViewRowStateEditor Members | System.Data.Design Namespace


DBConnectionEditor Class

[To be supplied.]

Object
UITypeEditor
ObjectSelectorEditor
DBConnectionEditor

[Visual Basic]
NotInheritable Public Class DBConnectionEditor
   Inherits ObjectSelectorEditor
[C#]
public sealed class DBConnectionEditor : ObjectSelectorEditor
[C++]
public __gc __sealed class DBConnectionEditor : public
   ObjectSelectorEditor
[JScript]
public class DBConnectionEditor extends ObjectSelectorEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Design

Assembly: System.Data.Design.dll

See Also

DBConnectionEditor Members | System.Data.Design Namespace


DBConnectionEditor Members

Public:

Constructor

DBConnectionEditor Constructor [To be supplied.]

Methods

EditValue (inherited from ObjectSelectorEditor) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
EqualsToValue (inherited from ObjectSelectorEditor) | [To be supplied.]
GetEditStyle (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
SetValue | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

subObjectSelector (inherited from ObjectSelectorEditor) [To be supplied.]

Protected:

Methods

FillTreeWithData | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

currValue (inherited from ObjectSelectorEditor) | [To be supplied.]
prevValue (inherited from ObjectSelectorEditor) | [To be supplied.]

See Also

DBConnectionEditor Class | System.Data.Design Namespace


DBConnectionEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public DBConnectionEditor();
[C++]
public: DBConnectionEditor();
[JScript]
public function DBConnectionEditor();

See Also

DBConnectionEditor Class | DBConnectionEditor Members | System.Data.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DBConnectionEditor Methods

The methods of the DBConnectionEditor class are listed below. For a complete list of DBConnectionEditor class members, see the DBConnectionEditor Members topic.

Public:

EditValue (inherited from ObjectSelectorEditor) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
EqualsToValue (inherited from ObjectSelectorEditor) | [To be supplied.]
GetEditStyle (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
SetValue | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

FillTreeWithData | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DBConnectionEditor Class | System.Data.Design Namespace


DBConnectionEditor.FillTreeWithData

[To be supplied.]

[Visual Basic]
Overrides Protected Sub FillTreeWithData( _
   ByVal selector As ObjectSelectorEditor.Selector, _
   ByVal context As ITypeDescriptorContext, _
   ByVal provider As IServiceObjectProvider _
)
[C#]
protected override void FillTreeWithData(
   ObjectSelectorEditor.Selector selector,
   ITypeDescriptorContext context,
   IServiceObjectProvider provider
);
[C++]
protected: override void FillTreeWithData(
   ObjectSelectorEditor.Selector* selector,
   ITypeDescriptorContext* context,
   IServiceObjectProvider* provider
);
[JScript]
protected override function FillTreeWithData(
   selector : ObjectSelectorEditor.Selector,
   context : ITypeDescriptorContext,
   provider : IServiceObjectProvider
);

Parameters

selector
[To be supplied.]
context
[To be supplied.]
provider
[To be supplied.]

See Also

DBConnectionEditor Class | DBConnectionEditor Members | System.Data.Design Namespace


DBConnectionEditor.SetValue

[To be supplied.]

[Visual Basic]
Overrides Public Sub SetValue( _
   ByVal value As Object _
)
[C#]
public override void SetValue(
   object value
);
[C++]
public: override void SetValue(
   Object* value
);
[JScript]
public override function SetValue(
   value : Object
);

Parameters

value
[To be supplied.]

See Also

DBConnectionEditor Class | DBConnectionEditor Members | System.Data.Design Namespace


DBParametersEditor Class

CollectionEditor for IDataParameters property

Object
UITypeEditor
CollectionEditor
DBParametersEditor

[Visual Basic]
NotInheritable Public Class DBParametersEditor
   Inherits CollectionEditor
[C#]
public sealed class DBParametersEditor : CollectionEditor
[C++]
public __gc __sealed class DBParametersEditor : public
   CollectionEditor
[JScript]
public class DBParametersEditor extends CollectionEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Design

Assembly: System.Data.Design.dll

See Also

DBParametersEditor Members | System.Data.Design Namespace


DBParametersEditor Members

Public:

Constructor

DBParametersEditor Constructor [To be supplied.]

Methods

EditValue | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEditStyle (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

CollectionItemType (inherited from CollectionEditor) | The data type of each item in the collection.
CollectionType (inherited from CollectionEditor) | Retrieves the data type of the collection we are editing.
Context (inherited from CollectionEditor) | The type descriptor context that is currently in use, or null if no context is available.
NewItemTypes (inherited from CollectionEditor) | The available item types that can be created for this collection. This defaults to a single type of CollectionItemType. If more than one type is returned the collection editor will provide a way to choose which item to create.

Methods

CanRemoveInstance (inherited from CollectionEditor) | This will be called when the user tries to remove an instance from the collection that is an original member of the collection. It will not be called when removing instances that were added in this editing session since they are not yet part of the collection.
CreateCollectionForm (inherited from CollectionEditor) | Creates a new form to show the current collection. You may inherit from CollectionForm to provide your own form.
CreateCollectionItemType (inherited from CollectionEditor) | Retrieves the data type this collection contains. The default implementation looks inside of the collection for the Item property and returns the returning datatype of the item. Do not call this method directly. Instead, use the CollectionItemType property. Use this method to override the default implementation.
CreateInstance | We add new instance of DataColumn to parentCollection, so new instance has valid parent property, and valid names.
CreateNewItemTypes (inherited from CollectionEditor) | Retrieves the data types this collection editor can create. The default implementation looks inside of the collection for the Item property and returns the returning datatype of the item. Do not call this method directly. Instead, use the NewItemTypes property. Use this method to override the default implementation.
DestroyInstance | We have to remove inctances that were created by CreateNewInctance this called in case Cancel button was hit.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetItems (inherited from CollectionEditor) | Converts the given collection into an array of objects. This is used by the editing dialog to manipulate the individual collection.
GetServiceObject (inherited from CollectionEditor) | Retrieves the requested service, if it is available.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetItems (inherited from CollectionEditor) | Sets the given collection to have the given array of items. If setting requires that a new object be created, the new object should be returned. Otherwise, editValue should be returned.

See Also

DBParametersEditor Class | System.Data.Design Namespace


DBParametersEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal type As Type _
)
[C#]
public DBParametersEditor(
   Type type
);
[C++]
public: DBParametersEditor(
   Type* type
);
[JScript]
public function DBParametersEditor(
   type : Type
);

Parameters

type
[To be supplied.]

See Also

DBParametersEditor Class | DBParametersEditor Members | System.Data.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DBParametersEditor Methods

The methods of the DBParametersEditor class are listed below. For a complete list of DBParametersEditor class members, see the DBParametersEditor Members topic.

Public:

EditValue | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEditStyle (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

CanRemoveInstance (inherited from CollectionEditor) | This will be called when the user tries to remove an instance from the collection that is an original member of the collection. It will not be called when removing instances that were added in this editing session since they are not yet part of the collection.
CreateCollectionForm (inherited from CollectionEditor) | Creates a new form to show the current collection. You may inherit from CollectionForm to provide your own form.
CreateCollectionItemType (inherited from CollectionEditor) | Retrieves the data type this collection contains. The default implementation looks inside of the collection for the Item property and returns the returning datatype of the item. Do not call this method directly. Instead, use the CollectionItemType property. Use this method to override the default implementation.
CreateInstance | We add new instance of DataColumn to parentCollection, so new instance has valid parent property, and valid names.
CreateNewItemTypes (inherited from CollectionEditor) | Retrieves the data types this collection editor can create. The default implementation looks inside of the collection for the Item property and returns the returning datatype of the item. Do not call this method directly. Instead, use the NewItemTypes property. Use this method to override the default implementation.
DestroyInstance | We have to remove inctances that were created by CreateNewInctance this called in case Cancel button was hit.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetItems (inherited from CollectionEditor) | Converts the given collection into an array of objects. This is used by the editing dialog to manipulate the individual collection.
GetServiceObject (inherited from CollectionEditor) | Retrieves the requested service, if it is available.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetItems (inherited from CollectionEditor) | Sets the given collection to have the given array of items. If setting requires that a new object be created, the new object should be returned. Otherwise, editValue should be returned.

See Also

DBParametersEditor Class | System.Data.Design Namespace


DBParametersEditor.CreateInstance

We add new instance of DataColumn to parentCollection, so new instance has valid parent property, and valid names.

[Visual Basic]
Overrides Protected Function CreateInstance( _
   ByVal type As Type _
) As Object
[C#]
protected override object CreateInstance(
   Type type
);
[C++]
protected: override Object* CreateInstance(
   Type* type
);
[JScript]
protected override function CreateInstance(
   type : Type
) : Object;

Parameters

type
[To be supplied.]

See Also

DBParametersEditor Class | DBParametersEditor Members | System.Data.Design Namespace


DBParametersEditor.DestroyInstance

We have to remove inctances that were created by CreateNewInctance this called in case Cancel button was hit.

[Visual Basic]
Overrides Protected Sub DestroyInstance( _
   ByVal value As Object _
)
[C#]
protected override void DestroyInstance(
   object value
);
[C++]
protected: override void DestroyInstance(
   Object* value
);
[JScript]
protected override function DestroyInstance(
   value : Object
);

Parameters

value
[To be supplied.]

See Also

DBParametersEditor Class | DBParametersEditor Members | System.Data.Design Namespace


DBParametersEditor.EditValue

[To be supplied.]

[Visual Basic]
Overrides Public Function EditValue( _
   ByVal context As ITypeDescriptorContext, _
   ByVal provider As IServiceObjectProvider, _
   ByVal value As Object _
) As Object
[C#]
public override object EditValue(
   ITypeDescriptorContext context,
   IServiceObjectProvider provider,
   object value
);
[C++]
public: override Object* EditValue(
   ITypeDescriptorContext* context,
   IServiceObjectProvider* provider,
   Object* value
);
[JScript]
public override function EditValue(
   context : ITypeDescriptorContext,
   provider : IServiceObjectProvider,
   value : Object
) : Object;

Parameters

context
[To be supplied.]
provider
[To be supplied.]
value
[To be supplied.]

See Also

DBParametersEditor Class | DBParametersEditor Members | System.Data.Design Namespace


ParentRelationValueEditor Class

[To be supplied.]

Object
UITypeEditor
ObjectSelectorEditor
ParentRelationValueEditor

[Visual Basic]
Public Class ParentRelationValueEditor
   Inherits ObjectSelectorEditor
[C#]
public class ParentRelationValueEditor : ObjectSelectorEditor
[C++]
public __gc class ParentRelationValueEditor : public
   ObjectSelectorEditor
[JScript]
public class ParentRelationValueEditor extends ObjectSelectorEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Design

Assembly: System.Data.Design.dll

See Also

ParentRelationValueEditor Members | System.Data.Design Namespace


ParentRelationValueEditor Members

Public:

Constructor

ParentRelationValueEditor Constructor [To be supplied.]

Methods

EditValue (inherited from ObjectSelectorEditor) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
EqualsToValue (inherited from ObjectSelectorEditor) | [To be supplied.]
GetEditStyle (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
SetValue | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

subObjectSelector (inherited from ObjectSelectorEditor) [To be supplied.]

Protected:

Methods

FillTreeWithData | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

currValue (inherited from ObjectSelectorEditor) | [To be supplied.]
prevValue (inherited from ObjectSelectorEditor) | [To be supplied.]

See Also

ParentRelationValueEditor Class | System.Data.Design Namespace


ParentRelationValueEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ParentRelationValueEditor();
[C++]
public: ParentRelationValueEditor();
[JScript]
public function ParentRelationValueEditor();

See Also

ParentRelationValueEditor Class | ParentRelationValueEditor Members | System.Data.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ParentRelationValueEditor Methods

The methods of the ParentRelationValueEditor class are listed below. For a complete list of ParentRelationValueEditor class members, see the ParentRelationValueEditor Members topic.

Public:

EditValue (inherited from ObjectSelectorEditor) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
EqualsToValue (inherited from ObjectSelectorEditor) | [To be supplied.]
GetEditStyle (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
SetValue | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

FillTreeWithData | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ParentRelationValueEditor Class | System.Data.Design Namespace


ParentRelationValueEditor.FillTreeWithData

[To be supplied.]

[Visual Basic]
Overrides Protected Sub FillTreeWithData( _
   ByVal selector As ObjectSelectorEditor.Selector, _
   ByVal context As ITypeDescriptorContext, _
   ByVal provider As IServiceObjectProvider _
)
[C#]
protected override void FillTreeWithData(
   ObjectSelectorEditor.Selector selector,
   ITypeDescriptorContext context,
   IServiceObjectProvider provider
);
[C++]
protected: override void FillTreeWithData(
   ObjectSelectorEditor.Selector* selector,
   ITypeDescriptorContext* context,
   IServiceObjectProvider* provider
);
[JScript]
protected override function FillTreeWithData(
   selector : ObjectSelectorEditor.Selector,
   context : ITypeDescriptorContext,
   provider : IServiceObjectProvider
);

Parameters

selector
[To be supplied.]
context
[To be supplied.]
provider
[To be supplied.]

See Also

ParentRelationValueEditor Class | ParentRelationValueEditor Members | System.Data.Design Namespace


ParentRelationValueEditor.SetValue

[To be supplied.]

[Visual Basic]
Overrides Public Sub SetValue( _
   ByVal value As Object _
)
[C#]
public override void SetValue(
   object value
);
[C++]
public: override void SetValue(
   Object* value
);
[JScript]
public override function SetValue(
   value : Object
);

Parameters

value
[To be supplied.]

See Also

ParentRelationValueEditor Class | ParentRelationValueEditor Members | System.Data.Design Namespace


PrimaryKeyValueEditor Class

[To be supplied.]

Object
UITypeEditor
PrimaryKeyValueEditor

[Visual Basic]
Public Class PrimaryKeyValueEditor
   Inherits UITypeEditor
[C#]
public class PrimaryKeyValueEditor : UITypeEditor
[C++]
public __gc class PrimaryKeyValueEditor : public UITypeEditor
[JScript]
public class PrimaryKeyValueEditor extends UITypeEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Design

Assembly: System.Data.Design.dll

See Also

PrimaryKeyValueEditor Members | System.Data.Design Namespace


PrimaryKeyValueEditor Members

Public:

Constructor

PrimaryKeyValueEditor Constructor [To be supplied.]

Methods

EditValue | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEditStyle | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PrimaryKeyValueEditor Class | System.Data.Design Namespace


PrimaryKeyValueEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public PrimaryKeyValueEditor();
[C++]
public: PrimaryKeyValueEditor();
[JScript]
public function PrimaryKeyValueEditor();

See Also

PrimaryKeyValueEditor Class | PrimaryKeyValueEditor Members | System.Data.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PrimaryKeyValueEditor Methods

The methods of the PrimaryKeyValueEditor class are listed below. For a complete list of PrimaryKeyValueEditor class members, see the PrimaryKeyValueEditor Members topic.

Public:

EditValue | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEditStyle | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PrimaryKeyValueEditor Class | System.Data.Design Namespace


PrimaryKeyValueEditor.EditValue

[To be supplied.]

[Visual Basic]
Overrides Public Function EditValue( _
   ByVal context As ITypeDescriptorContext, _
   ByVal provider As IServiceObjectProvider, _
   ByVal value As Object _
) As Object
[C#]
public override object EditValue(
   ITypeDescriptorContext context,
   IServiceObjectProvider provider,
   object value
);
[C++]
public: override Object* EditValue(
   ITypeDescriptorContext* context,
   IServiceObjectProvider* provider,
   Object* value
);
[JScript]
public override function EditValue(
   context : ITypeDescriptorContext,
   provider : IServiceObjectProvider,
   value : Object
) : Object;

Parameters

context
[To be supplied.]
provider
[To be supplied.]
value
[To be supplied.]

See Also

PrimaryKeyValueEditor Class | PrimaryKeyValueEditor Members | System.Data.Design Namespace


PrimaryKeyValueEditor.GetEditStyle

[To be supplied.]

[Visual Basic]
Overrides Public Function GetEditStyle( _
   ByVal context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
[C#]
public override UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext context
);
[C++]
public: override UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetEditStyle(
   context : ITypeDescriptorContext
) : UITypeEditorEditStyle;

Parameters

context
[To be supplied.]

See Also

PrimaryKeyValueEditor Class | PrimaryKeyValueEditor Members | System.Data.Design Namespace


RelationsCollectionEditor Class

[To be supplied.]

Object
ValueEditor
OldCollectionEditor
RelationsCollectionEditor

[Visual Basic]
NotInheritable Public Class RelationsCollectionEditor
   Inherits OldCollectionEditor
[C#]
public sealed class RelationsCollectionEditor : OldCollectionEditor
[C++]
public __gc __sealed class RelationsCollectionEditor : public
   OldCollectionEditor
[JScript]
public class RelationsCollectionEditor extends OldCollectionEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Design

Assembly: System.Data.Design.dll

See Also

RelationsCollectionEditor Members | System.Data.Design Namespace


RelationsCollectionEditor Members

Public:

Constructor

RelationsCollectionEditor Constructor Overloaded. [To be supplied.]

Properties

Style (inherited from OldCollectionEditor) | Returns the style flags for the value editor. The returned value must be a combination of the STYLE_XXX bit masks defined in this interface.
Values (inherited from ValueEditor) | [To be supplied.]

Methods

EditValue | Takes the value returned from valueAccess.getValue() and modifies or replaces the value, passing the result into valueAccess.setValue(). This is where an editor can launch a modal dialog or create a drop down editor to allow the user to modify the value. Host assistance in presenting UI to the user can be found through the valueAccess.getService function.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from ValueEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue (inherited from OldCollectionEditor) | Converts the given value to a text string. The return value may be null if the value cannot be converted to a text string.
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from ValueEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

AddTypes (inherited from OldCollectionEditor) [To be supplied.]

Methods

CreateNewInstance | [To be supplied.]
DestroyNewInstance (inherited from OldCollectionEditor) | [To be supplied.]
DestroyOldInstance (inherited from OldCollectionEditor) | Called every time user clicks Remove button for the item which existed in initial Collection. Supposed to check if the item can be removed from collection. If item cannot be removed ArgumentException(<reasonString>) should be thrown.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RelationsCollectionEditor Class | System.Data.Design Namespace


RelationsCollectionEditor Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public RelationsCollectionEditor();
[C++] public: RelationsCollectionEditor();
[JScript] public function RelationsCollectionEditor();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(IEditorSite)
[C#] public RelationsCollectionEditor(IEditorSite);
[C++] public: RelationsCollectionEditor(IEditorSite*);
[JScript] public function RelationsCollectionEditor(IEditorSite);

See Also

RelationsCollectionEditor Class | RelationsCollectionEditor Members | System.Data.Design Namespace


RelationsCollectionEditor Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public RelationsCollectionEditor();
[C++]
public: RelationsCollectionEditor();
[JScript]
public function RelationsCollectionEditor();

See Also

RelationsCollectionEditor Class | RelationsCollectionEditor Members | System.Data.Design Namespace | RelationsCollectionEditor Constructor Overload List


RelationsCollectionEditor Constructor (IEditorSite)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal site As IEditorSite _
)
[C#]
public RelationsCollectionEditor(
   IEditorSite site
);
[C++]
public: RelationsCollectionEditor(
   IEditorSite* site
);
[JScript]
public function RelationsCollectionEditor(
   site : IEditorSite
);

Parameters

site
[To be supplied.]

See Also

RelationsCollectionEditor Class | RelationsCollectionEditor Members | System.Data.Design Namespace | RelationsCollectionEditor Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RelationsCollectionEditor Methods

The methods of the RelationsCollectionEditor class are listed below. For a complete list of RelationsCollectionEditor class members, see the RelationsCollectionEditor Members topic.

Public:

EditValue | Takes the value returned from valueAccess.getValue() and modifies or replaces the value, passing the result into valueAccess.setValue(). This is where an editor can launch a modal dialog or create a drop down editor to allow the user to modify the value. Host assistance in presenting UI to the user can be found through the valueAccess.getService function.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from ValueEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue (inherited from OldCollectionEditor) | Converts the given value to a text string. The return value may be null if the value cannot be converted to a text string.
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from ValueEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

CreateNewInstance | [To be supplied.]
DestroyNewInstance (inherited from OldCollectionEditor) | [To be supplied.]
DestroyOldInstance (inherited from OldCollectionEditor) | Called every time user clicks Remove button for the item which existed in initial Collection. Supposed to check if the item can be removed from collection. If item cannot be removed ArgumentException(<reasonString>) should be thrown.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RelationsCollectionEditor Class | System.Data.Design Namespace


RelationsCollectionEditor.CreateNewInstance

[To be supplied.]

[Visual Basic]
Overrides Protected Function CreateNewInstance( _
   ByVal valueAccess As IValueAccess, _
   ByVal type As Type _
) As Object
[C#]
protected override object CreateNewInstance(
   IValueAccess valueAccess,
   Type type
);
[C++]
protected: override Object* CreateNewInstance(
   IValueAccess* valueAccess,
   Type* type
);
[JScript]
protected override function CreateNewInstance(
   valueAccess : IValueAccess,
   type : Type
) : Object;

Parameters

valueAccess
[To be supplied.]
type
[To be supplied.]

See Also

RelationsCollectionEditor Class | RelationsCollectionEditor Members | System.Data.Design Namespace


RelationsCollectionEditor.EditValue

Takes the value returned from valueAccess.getValue() and modifies or replaces the value, passing the result into valueAccess.setValue(). This is where an editor can launch a modal dialog or create a drop down editor to allow the user to modify the value. Host assistance in presenting UI to the user can be found through the valueAccess.getService function.

[Visual Basic]
Overrides Public Sub EditValue( _
   ByVal valueAccess As IValueAccess _
)
[C#]
public override void EditValue(
   IValueAccess valueAccess
);
[C++]
public: override void EditValue(
   IValueAccess* valueAccess
);
[JScript]
public override function EditValue(
   valueAccess : IValueAccess
);

Parameters

valueAccess
The way that editValue accesses and modifies a given value.

See Also

RelationsCollectionEditor Class | RelationsCollectionEditor Members | System.Data.Design Namespace | IValueAccess


RowStateEditor Class

RowStateEditor value editor for DataBinder's RowStateFilter property.

Object
UITypeEditor
RowStateEditor

[Visual Basic]
Public Class RowStateEditor
   Inherits UITypeEditor
[C#]
public class RowStateEditor : UITypeEditor
[C++]
public __gc class RowStateEditor : public UITypeEditor
[JScript]
public class RowStateEditor extends UITypeEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Design

Assembly: System.Data.Design.dll

See Also

RowStateEditor Members | System.Data.Design Namespace


RowStateEditor Members

Public:

Constructor

RowStateEditor Constructor [To be supplied.]

Methods

EditValue | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEditStyle (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RowStateEditor Class | System.Data.Design Namespace


RowStateEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public RowStateEditor();
[C++]
public: RowStateEditor();
[JScript]
public function RowStateEditor();

See Also

RowStateEditor Class | RowStateEditor Members | System.Data.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RowStateEditor Methods

The methods of the RowStateEditor class are listed below. For a complete list of RowStateEditor class members, see the RowStateEditor Members topic.

Public:

EditValue | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEditStyle (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RowStateEditor Class | System.Data.Design Namespace


RowStateEditor.EditValue

[To be supplied.]

[Visual Basic]
Overrides Public Function EditValue( _
   ByVal context As ITypeDescriptorContext, _
   ByVal provider As IServiceObjectProvider, _
   ByVal value As Object _
) As Object
[C#]
public override object EditValue(
   ITypeDescriptorContext context,
   IServiceObjectProvider provider,
   object value
);
[C++]
public: override Object* EditValue(
   ITypeDescriptorContext* context,
   IServiceObjectProvider* provider,
   Object* value
);
[JScript]
public override function EditValue(
   context : ITypeDescriptorContext,
   provider : IServiceObjectProvider,
   value : Object
) : Object;

Parameters

context
[To be supplied.]
provider
[To be supplied.]
value
[To be supplied.]

See Also

RowStateEditor Class | RowStateEditor Members | System.Data.Design Namespace


RowStateEditor.GetEditStyle

[To be supplied.]

[Visual Basic]
Overrides Public Function GetEditStyle( _
   ByVal context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
[C#]
public override UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext context
);
[C++]
public: override UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetEditStyle(
   context : ITypeDescriptorContext
) : UITypeEditorEditStyle;

Parameters

context
[To be supplied.]

See Also

RowStateEditor Class | RowStateEditor Members | System.Data.Design Namespace


TablesCollectionEditor Class

Collection ValueEditor for TablesCollection

Object
UITypeEditor
CollectionEditor
TablesCollectionEditor

[Visual Basic]
NotInheritable Public Class TablesCollectionEditor
   Inherits CollectionEditor
[C#]
public sealed class TablesCollectionEditor : CollectionEditor
[C++]
public __gc __sealed class TablesCollectionEditor : public
   CollectionEditor
[JScript]
public class TablesCollectionEditor extends CollectionEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Design

Assembly: System.Data.Design.dll

See Also

TablesCollectionEditor Members | System.Data.Design Namespace


TablesCollectionEditor Members

Public:

Constructor

TablesCollectionEditor Constructor [To be supplied.]

Methods

EditValue | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEditStyle (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

CollectionItemType (inherited from CollectionEditor) | The data type of each item in the collection.
CollectionType (inherited from CollectionEditor) | Retrieves the data type of the collection we are editing.
Context (inherited from CollectionEditor) | The type descriptor context that is currently in use, or null if no context is available.
NewItemTypes (inherited from CollectionEditor) | The available item types that can be created for this collection. This defaults to a single type of CollectionItemType. If more than one type is returned the collection editor will provide a way to choose which item to create.

Methods

CanRemoveInstance | Here we check to see if it is OK to remove this instance from the collection.
CreateCollectionForm (inherited from CollectionEditor) | Creates a new form to show the current collection. You may inherit from CollectionForm to provide your own form.
CreateCollectionItemType (inherited from CollectionEditor) | Retrieves the data type this collection contains. The default implementation looks inside of the collection for the Item property and returns the returning datatype of the item. Do not call this method directly. Instead, use the CollectionItemType property. Use this method to override the default implementation.
CreateInstance | We add new instance of DataColumn to parentCollection, so new instance has valid parent property, and valid names.
CreateNewItemTypes (inherited from CollectionEditor) | Retrieves the data types this collection editor can create. The default implementation looks inside of the collection for the Item property and returns the returning datatype of the item. Do not call this method directly. Instead, use the NewItemTypes property. Use this method to override the default implementation.
DestroyInstance | We have to remove inctances that were created by CreateNewInctance this called in case Cancel button was hit.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetItems (inherited from CollectionEditor) | Converts the given collection into an array of objects. This is used by the editing dialog to manipulate the individual collection.
GetServiceObject (inherited from CollectionEditor) | Retrieves the requested service, if it is available.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetItems (inherited from CollectionEditor) | Sets the given collection to have the given array of items. If setting requires that a new object be created, the new object should be returned. Otherwise, editValue should be returned.

See Also

TablesCollectionEditor Class | System.Data.Design Namespace


TablesCollectionEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal type As Type _
)
[C#]
public TablesCollectionEditor(
   Type type
);
[C++]
public: TablesCollectionEditor(
   Type* type
);
[JScript]
public function TablesCollectionEditor(
   type : Type
);

Parameters

type
[To be supplied.]

See Also

TablesCollectionEditor Class | TablesCollectionEditor Members | System.Data.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TablesCollectionEditor Methods

The methods of the TablesCollectionEditor class are listed below. For a complete list of TablesCollectionEditor class members, see the TablesCollectionEditor Members topic.

Public:

EditValue | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEditStyle (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue (inherited from UITypeEditor) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

CanRemoveInstance | Here we check to see if it is OK to remove this instance from the collection.
CreateCollectionForm (inherited from CollectionEditor) | Creates a new form to show the current collection. You may inherit from CollectionForm to provide your own form.
CreateCollectionItemType (inherited from CollectionEditor) | Retrieves the data type this collection contains. The default implementation looks inside of the collection for the Item property and returns the returning datatype of the item. Do not call this method directly. Instead, use the CollectionItemType property. Use this method to override the default implementation.
CreateInstance | We add new instance of DataColumn to parentCollection, so new instance has valid parent property, and valid names.
CreateNewItemTypes (inherited from CollectionEditor) | Retrieves the data types this collection editor can create. The default implementation looks inside of the collection for the Item property and returns the returning datatype of the item. Do not call this method directly. Instead, use the NewItemTypes property. Use this method to override the default implementation.
DestroyInstance | We have to remove inctances that were created by CreateNewInctance this called in case Cancel button was hit.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetItems (inherited from CollectionEditor) | Converts the given collection into an array of objects. This is used by the editing dialog to manipulate the individual collection.
GetServiceObject (inherited from CollectionEditor) | Retrieves the requested service, if it is available.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetItems (inherited from CollectionEditor) | Sets the given collection to have the given array of items. If setting requires that a new object be created, the new object should be returned. Otherwise, editValue should be returned.

See Also

TablesCollectionEditor Class | System.Data.Design Namespace


TablesCollectionEditor.CanRemoveInstance

Here we check to see if it is OK to remove this instance from the collection.

[Visual Basic]
Overrides Protected Function CanRemoveInstance( _
   ByVal value As Object _
) As Boolean
[C#]
protected override bool CanRemoveInstance(
   object value
);
[C++]
protected: override bool CanRemoveInstance(
   Object* value
);
[JScript]
protected override function CanRemoveInstance(
   value : Object
) : Boolean;

Parameters

value
[To be supplied.]

See Also

TablesCollectionEditor Class | TablesCollectionEditor Members | System.Data.Design Namespace


TablesCollectionEditor.CreateInstance

We add new instance of DataColumn to parentCollection, so new instance has valid parent property, and valid names.

[Visual Basic]
Overrides Protected Function CreateInstance( _
   ByVal type As Type _
) As Object
[C#]
protected override object CreateInstance(
   Type type
);
[C++]
protected: override Object* CreateInstance(
   Type* type
);
[JScript]
protected override function CreateInstance(
   type : Type
) : Object;

Parameters

type
[To be supplied.]

See Also

TablesCollectionEditor Class | TablesCollectionEditor Members | System.Data.Design Namespace


TablesCollectionEditor.DestroyInstance

We have to remove inctances that were created by CreateNewInctance this called in case Cancel button was hit.

[Visual Basic]
Overrides Protected Sub DestroyInstance( _
   ByVal value As Object _
)
[C#]
protected override void DestroyInstance(
   object value
);
[C++]
protected: override void DestroyInstance(
   Object* value
);
[JScript]
protected override function DestroyInstance(
   value : Object
);

Parameters

value
[To be supplied.]

See Also

TablesCollectionEditor Class | TablesCollectionEditor Members | System.Data.Design Namespace


TablesCollectionEditor.EditValue

Edits the given object value using the editor style provided by GetEditorStyle. A service provider is provided so that any required editing services can be obtained.

[Visual Basic]
Overrides Public Function EditValue( _
   ByVal context As ITypeDescriptorContext, _
   ByVal provider As IServiceObjectProvider, _
   ByVal value As Object _
) As Object
[C#]
public override object EditValue(
   ITypeDescriptorContext context,
   IServiceObjectProvider provider,
   object value
);
[C++]
public: override Object* EditValue(
   ITypeDescriptorContext* context,
   IServiceObjectProvider* provider,
   Object* value
);
[JScript]
public override function EditValue(
   context : ITypeDescriptorContext,
   provider : IServiceObjectProvider,
   value : Object
) : Object;

Parameters

context
A type descriptor context that can be used to provide additional context information.
provider
A service provider object through which editing services may be obtained.
value
An instance of the value being edited.

Return Value

The new value of the object. If the value of the object hasn't changed, this should return the same object it was passed.

See Also

TablesCollectionEditor Class | TablesCollectionEditor Members | System.Data.Design Namespace


UICreationHelper Class

[To be supplied.]

Object
UICreationHelper

[Visual Basic]
Public Class UICreationHelper
[C#]
public class UICreationHelper
[C++]
public __gc class UICreationHelper
[JScript]
public class UICreationHelper

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Design

Assembly: System.Data.Design.dll

See Also

UICreationHelper Members | System.Data.Design Namespace


UICreationHelper Members

Public:

Constructor

UICreationHelper Constructor [To be supplied.]

Methods

CreateButton | [To be supplied.]
CreateControl | [To be supplied.]
CreateLabeledControl | Creates pair of controls, Label with Text = labelText and IComponent of type componentType Locates them in one raw in order (label, component) Except the case: componentType == typeof(CheckBox) in this case one CheckBox control created with the Text property set to labelText.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FinishUICreation | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
GetUnusedLocation | [To be supplied.]
GetUsedSize | [To be supplied.]
SelectNewComponents | Selects all newly created controls on the form
SetOverlapFormSize | Sets Form.Size so that all new controls within Form borders.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UICreationHelper Class | System.Data.Design Namespace


UICreationHelper Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal designerHost As IDesignerHost _
)
[C#]
public UICreationHelper(
   IDesignerHost designerHost
);
[C++]
public: UICreationHelper(
   IDesignerHost* designerHost
);
[JScript]
public function UICreationHelper(
   designerHost : IDesignerHost
);

Parameters

designerHost
[To be supplied.]

See Also

UICreationHelper Class | UICreationHelper Members | System.Data.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UICreationHelper Methods

The methods of the UICreationHelper class are listed below. For a complete list of UICreationHelper class members, see the UICreationHelper Members topic.

Public:

CreateButton | [To be supplied.]
CreateControl | [To be supplied.]
CreateLabeledControl | Creates pair of controls, Label with Text = labelText and IComponent of type componentType Locates them in one raw in order (label, component) Except the case: componentType == typeof(CheckBox) in this case one CheckBox control created with the Text property set to labelText.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FinishUICreation | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
GetUnusedLocation | [To be supplied.]
GetUsedSize | [To be supplied.]
SelectNewComponents | Selects all newly created controls on the form
SetOverlapFormSize | Sets Form.Size so that all new controls within Form borders.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UICreationHelper Class | System.Data.Design Namespace


UICreationHelper.CreateButton

[To be supplied.]

[Visual Basic]
Public Function CreateButton( _
   ByVal text As String _
) As Button
[C#]
public Button CreateButton(
   string text
);
[C++]
public: Button* CreateButton(
   String* text
);
[JScript]
public function CreateButton(
   text : String
) : Button;

Parameters

text
[To be supplied.]

See Also

UICreationHelper Class | UICreationHelper Members | System.Data.Design Namespace


UICreationHelper.CreateControl

[To be supplied.]

[Visual Basic]
Public Function CreateControl( _
   ByVal controlType As Type _
) As Control
[C#]
public Control CreateControl(
   Type controlType
);
[C++]
public: Control* CreateControl(
   Type* controlType
);
[JScript]
public function CreateControl(
   controlType : Type
) : Control;

Parameters

controlType
[To be supplied.]

See Also

UICreationHelper Class | UICreationHelper Members | System.Data.Design Namespace


UICreationHelper.CreateLabeledControl

Creates pair of controls, Label with Text = labelText and IComponent of type componentType Locates them in one raw in order (label, component) Except the case: componentType == typeof(CheckBox) in this case one CheckBox control created with the Text property set to labelText.

[Visual Basic]
Public Function CreateLabeledControl( _
   ByVal controlType As Type, _
   ByVal labelText As String, _
   ByVal controlName As String _
) As Control
[C#]
public Control CreateLabeledControl(
   Type controlType,
   string labelText,
   string controlName
);
[C++]
public: Control* CreateLabeledControl(
   Type* controlType,
   String* labelText,
   String* controlName
);
[JScript]
public function CreateLabeledControl(
   controlType : Type,
   labelText : String,
   controlName : String
) : Control;

Parameters

controlType
[To be supplied.]
labelText
[To be supplied.]
controlName
[To be supplied.]

See Also

UICreationHelper Class | UICreationHelper Members | System.Data.Design Namespace


UICreationHelper.FinishUICreation

[To be supplied.]

[Visual Basic]
Public Sub FinishUICreation( _
   ByVal selectNewComponents As Boolean, _
   ByVal extendFormSize As Boolean _
)
[C#]
public void FinishUICreation(
   bool selectNewComponents,
   bool extendFormSize
);
[C++]
public: void FinishUICreation(
   bool selectNewComponents,
   bool extendFormSize
);
[JScript]
public function FinishUICreation(
   selectNewComponents : Boolean,
   extendFormSize : Boolean
);

Parameters

selectNewComponents
[To be supplied.]
extendFormSize
[To be supplied.]

See Also

UICreationHelper Class | UICreationHelper Members | System.Data.Design Namespace


UICreationHelper.GetUnusedLocation

[To be supplied.]

[Visual Basic]
Public Function GetUnusedLocation() As Point
[C#]
public Point GetUnusedLocation();
[C++]
public: Point GetUnusedLocation();
[JScript]
public function GetUnusedLocation() : Point;

See Also

UICreationHelper Class | UICreationHelper Members | System.Data.Design Namespace


UICreationHelper.GetUsedSize

[To be supplied.]

[Visual Basic]
Public Function GetUsedSize( _
   ByVal components() As IComponent _
) As Size
[C#]
public Size GetUsedSize(
   IComponent[] components
);
[C++]
public: Size GetUsedSize(
   IComponent* components[]
);
[JScript]
public function GetUsedSize(
   components : IComponent[]
) : Size;

Parameters

components
[To be supplied.]

See Also

UICreationHelper Class | UICreationHelper Members | System.Data.Design Namespace


UICreationHelper.SelectNewComponents

Selects all newly created controls on the form

[Visual Basic]
Public Sub SelectNewComponents()
[C#]
public void SelectNewComponents();
[C++]
public: void SelectNewComponents();
[JScript]
public function SelectNewComponents();

See Also

UICreationHelper Class | UICreationHelper Members | System.Data.Design Namespace


UICreationHelper.SetOverlapFormSize

Sets Form.Size so that all new controls within Form borders.

[Visual Basic]
Public Sub SetOverlapFormSize()
[C#]
public void SetOverlapFormSize();
[C++]
public: void SetOverlapFormSize();
[JScript]
public function SetOverlapFormSize();

See Also

UICreationHelper Class | UICreationHelper Members | System.Data.Design Namespace


System.Data.Internal

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Data.Internal Namespace

Classes

Class | Description
BooleanStorage | [To be supplied.]
ByteStorage | [To be supplied.]
CharStorage | [To be supplied.]
CurrencyStorage | [To be supplied.]
DataColumnMapping | generic column mapping
DataColumnMappingConverter | [To be supplied.]
DataColumnMappings | column mapping collection
DataSchemaChangedEvent | [To be supplied.]
DataSetCommand | Represents a set of data commands and a database connection which are used to fill the DataSet and update the data source. At any time, the object refers to only a single record within the current data set.
DataStorage | [To be supplied.]
DataTableMapping | [To be supplied.]
DataTableMappingConverter | [To be supplied.]
DataTableMappings | table mapping collection
DateTimeStorage | [To be supplied.]
DBCommand | Represents a query command used when connecting to a data source.
DBConnection | Represents a database connection for use by DBCommand.
DBDataReader | [To be supplied.]
DBDataSetCommand | Implementation of DataSetCommand designed for relational data sources like databases.
DecimalStorage | [To be supplied.]
DoubleStorage | [To be supplied.]
InfoMessageEventArgs | [To be supplied.]
Int16Storage | [To be supplied.]
Int32Storage | [To be supplied.]
Int64Storage | [To be supplied.]
ObjectStorage | [To be supplied.]
RowUpdatedEventArgs | [To be supplied.]
RowUpdatingEventArgs | [To be supplied.]
SByteStorage | [To be supplied.]
SchemaChangedEventArgs | [To be supplied.]
SchemaChangingEventArgs | [To be supplied.]
SchemaMappingEventArgs | [To be supplied.]
SingleStorage | [To be supplied.]
SparseStorage | [To be supplied.]
StringStorage | [To be supplied.]
TimeSpanStorage | [To be supplied.]
UInt16Storage | [To be supplied.]
UInt32Storage | [To be supplied.]
UInt64Storage | [To be supplied.]

Interfaces

Interface | Description
IDataParameters | Collects all parameters relevant to the command and their mappings to DataSet columns.
IDBDataReader | [To be supplied.]
IProperties | [To be supplied.]
IProperty | [To be supplied.]

Delegates

Delegate | Description
DataSchemaChangedEventHandler | [To be supplied.]
SchemaChangedEventHandler | [To be supplied.]
SchemaChangingEventHandler | [To be supplied.]


BooleanStorage Class

[To be supplied.]

Object
DataStorage
BooleanStorage

[Visual Basic]
Public Class BooleanStorage
   Inherits DataStorage
[C#]
public class BooleanStorage : DataStorage
[C++]
public __gc class BooleanStorage : public DataStorage
[JScript]
public class BooleanStorage extends DataStorage

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

BooleanStorage Members | System.Data.Internal Namespace


BooleanStorage Members

Public:

Constructor

BooleanStorage Constructor [To be supplied.]

Properties

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

Methods

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

BooleanStorage Class | System.Data.Internal Namespace


BooleanStorage Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public BooleanStorage();
[C++]
public: BooleanStorage();
[JScript]
public function BooleanStorage();

See Also

BooleanStorage Class | BooleanStorage Members | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

BooleanStorage Properties

The properties of the BooleanStorage class are listed below. For a complete list of BooleanStorage class members, see the BooleanStorage Members topic.

Public:

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

See Also

BooleanStorage Class | System.Data.Internal Namespace


BooleanStorage.DefaultValue

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DefaultValue As Object
[C#]
public object DefaultValue {override get;}
[C++]
public: __property virtual Object* get_DefaultValue();
[JScript]
public function get DefaultValue() : Object;

See Also

BooleanStorage Class | BooleanStorage Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

BooleanStorage Methods

The methods of the BooleanStorage class are listed below. For a complete list of BooleanStorage class members, see the BooleanStorage Members topic.

Public:

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

BooleanStorage Class | System.Data.Internal Namespace


BooleanStorage.Aggregate

[To be supplied.]

[Visual Basic]
Overrides Public Function Aggregate( _
   ByVal records() As Integer, _
   ByVal kind As AggregateTypes _
) As Object
[C#]
public override object Aggregate(
   int[] records,
   AggregateTypes kind
);
[C++]
public: override Object* Aggregate(
   int* records[],
   AggregateTypes kind
);
[JScript]
public override function Aggregate(
   records : int[],
   kind : AggregateTypes
) : Object;

Parameters

records
[To be supplied.]
kind
[To be supplied.]

See Also

BooleanStorage Class | BooleanStorage Members | System.Data.Internal Namespace


BooleanStorage.Compare

[To be supplied.]

[Visual Basic]
Overrides Public Function Compare( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
) As Integer
[C#]
public override int Compare(
   int recordNo1,
   int recordNo2
);
[C++]
public: override int Compare(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Compare(
   recordNo1 : int,
   recordNo2 : int
) : int;

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

BooleanStorage Class | BooleanStorage Members | System.Data.Internal Namespace


BooleanStorage.CompareToValue

[To be supplied.]

[Visual Basic]
Overrides Public Function CompareToValue( _
   ByVal recordNo As Integer, _
   ByVal value As Object _
) As Integer
[C#]
public override int CompareToValue(
   int recordNo,
   object value
);
[C++]
public: override int CompareToValue(
   int recordNo,
   Object* value
);
[JScript]
public override function CompareToValue(
   recordNo : int,
   value : Object
) : int;

Parameters

recordNo
[To be supplied.]
value
[To be supplied.]

See Also

BooleanStorage Class | BooleanStorage Members | System.Data.Internal Namespace


BooleanStorage.Copy

[To be supplied.]

[Visual Basic]
Overrides Public Sub Copy( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
)
[C#]
public override void Copy(
   int recordNo1,
   int recordNo2
);
[C++]
public: override void Copy(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Copy(
   recordNo1 : int,
   recordNo2 : int
);

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

BooleanStorage Class | BooleanStorage Members | System.Data.Internal Namespace


BooleanStorage.Get

[To be supplied.]

[Visual Basic]
Overrides Public Function Get( _
   ByVal record As Integer _
) As Object
[C#]
public override object Get(
   int record
);
[C++]
public: override Object* Get(
   int record
);
[JScript]
public override function Get(
   record : int
) : Object;

Parameters

record
[To be supplied.]

See Also

BooleanStorage Class | BooleanStorage Members | System.Data.Internal Namespace


BooleanStorage.Set

[To be supplied.]

[Visual Basic]
Overrides Public Sub Set( _
   ByVal record As Integer, _
   ByVal value As Object _
)
[C#]
public override void Set(
   int record,
   object value
);
[C++]
public: override void Set(
   int record,
   Object* value
);
[JScript]
public override function Set(
   record : int,
   value : Object
);

Parameters

record
[To be supplied.]
value
[To be supplied.]

See Also

BooleanStorage Class | BooleanStorage Members | System.Data.Internal Namespace


BooleanStorage.SetCapacity

[To be supplied.]

[Visual Basic]
Overrides Public Sub SetCapacity( _
   ByVal capacity As Integer _
)
[C#]
public override void SetCapacity(
   int capacity
);
[C++]
public: override void SetCapacity(
   int capacity
);
[JScript]
public override function SetCapacity(
   capacity : int
);

Parameters

capacity
[To be supplied.]

See Also

BooleanStorage Class | BooleanStorage Members | System.Data.Internal Namespace


BooleanStorage.ShiftByOffset

[To be supplied.]

[Visual Basic]
Overrides Public Sub ShiftByOffset( _
   ByVal index As Integer, _
   ByVal length As Integer, _
   ByVal offset As Integer _
)
[C#]
public override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[C++]
public: override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[JScript]
public override function ShiftByOffset(
   index : int,
   length : int,
   offset : int
);

Parameters

index
[To be supplied.]
length
[To be supplied.]
offset
[To be supplied.]

See Also

BooleanStorage Class | BooleanStorage Members | System.Data.Internal Namespace


ByteStorage Class

[To be supplied.]

Object
DataStorage
ByteStorage

[Visual Basic]
Public Class ByteStorage
   Inherits DataStorage
[C#]
public class ByteStorage : DataStorage
[C++]
public __gc class ByteStorage : public DataStorage
[JScript]
public class ByteStorage extends DataStorage

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

ByteStorage Members | System.Data.Internal Namespace


ByteStorage Members

Public:

Constructor

ByteStorage Constructor [To be supplied.]

Properties

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

Methods

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

ByteStorage Class | System.Data.Internal Namespace


ByteStorage Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ByteStorage();
[C++]
public: ByteStorage();
[JScript]
public function ByteStorage();

See Also

ByteStorage Class | ByteStorage Members | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ByteStorage Properties

The properties of the ByteStorage class are listed below. For a complete list of ByteStorage class members, see the ByteStorage Members topic.

Public:

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

See Also

ByteStorage Class | System.Data.Internal Namespace


ByteStorage.DefaultValue

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DefaultValue As Object
[C#]
public object DefaultValue {override get;}
[C++]
public: __property virtual Object* get_DefaultValue();
[JScript]
public function get DefaultValue() : Object;

See Also

ByteStorage Class | ByteStorage Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ByteStorage Methods

The methods of the ByteStorage class are listed below. For a complete list of ByteStorage class members, see the ByteStorage Members topic.

Public:

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

ByteStorage Class | System.Data.Internal Namespace


ByteStorage.Aggregate

[To be supplied.]

[Visual Basic]
Overrides Public Function Aggregate( _
   ByVal records() As Integer, _
   ByVal kind As AggregateTypes _
) As Object
[C#]
public override object Aggregate(
   int[] records,
   AggregateTypes kind
);
[C++]
public: override Object* Aggregate(
   int* records[],
   AggregateTypes kind
);
[JScript]
public override function Aggregate(
   records : int[],
   kind : AggregateTypes
) : Object;

Parameters

records
[To be supplied.]
kind
[To be supplied.]

See Also

ByteStorage Class | ByteStorage Members | System.Data.Internal Namespace


ByteStorage.Compare

[To be supplied.]

[Visual Basic]
Overrides Public Function Compare( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
) As Integer
[C#]
public override int Compare(
   int recordNo1,
   int recordNo2
);
[C++]
public: override int Compare(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Compare(
   recordNo1 : int,
   recordNo2 : int
) : int;

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

ByteStorage Class | ByteStorage Members | System.Data.Internal Namespace


ByteStorage.CompareToValue

[To be supplied.]

[Visual Basic]
Overrides Public Function CompareToValue( _
   ByVal recordNo As Integer, _
   ByVal value As Object _
) As Integer
[C#]
public override int CompareToValue(
   int recordNo,
   object value
);
[C++]
public: override int CompareToValue(
   int recordNo,
   Object* value
);
[JScript]
public override function CompareToValue(
   recordNo : int,
   value : Object
) : int;

Parameters

recordNo
[To be supplied.]
value
[To be supplied.]

See Also

ByteStorage Class | ByteStorage Members | System.Data.Internal Namespace


ByteStorage.Copy

[To be supplied.]

[Visual Basic]
Overrides Public Sub Copy( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
)
[C#]
public override void Copy(
   int recordNo1,
   int recordNo2
);
[C++]
public: override void Copy(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Copy(
   recordNo1 : int,
   recordNo2 : int
);

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

ByteStorage Class | ByteStorage Members | System.Data.Internal Namespace


ByteStorage.Get

[To be supplied.]

[Visual Basic]
Overrides Public Function Get( _
   ByVal record As Integer _
) As Object
[C#]
public override object Get(
   int record
);
[C++]
public: override Object* Get(
   int record
);
[JScript]
public override function Get(
   record : int
) : Object;

Parameters

record
[To be supplied.]

See Also

ByteStorage Class | ByteStorage Members | System.Data.Internal Namespace


ByteStorage.Set

[To be supplied.]

[Visual Basic]
Overrides Public Sub Set( _
   ByVal record As Integer, _
   ByVal value As Object _
)
[C#]
public override void Set(
   int record,
   object value
);
[C++]
public: override void Set(
   int record,
   Object* value
);
[JScript]
public override function Set(
   record : int,
   value : Object
);

Parameters

record
[To be supplied.]
value
[To be supplied.]

See Also

ByteStorage Class | ByteStorage Members | System.Data.Internal Namespace


ByteStorage.SetCapacity

[To be supplied.]

[Visual Basic]
Overrides Public Sub SetCapacity( _
   ByVal capacity As Integer _
)
[C#]
public override void SetCapacity(
   int capacity
);
[C++]
public: override void SetCapacity(
   int capacity
);
[JScript]
public override function SetCapacity(
   capacity : int
);

Parameters

capacity
[To be supplied.]

See Also

ByteStorage Class | ByteStorage Members | System.Data.Internal Namespace


ByteStorage.ShiftByOffset

[To be supplied.]

[Visual Basic]
Overrides Public Sub ShiftByOffset( _
   ByVal index As Integer, _
   ByVal length As Integer, _
   ByVal offset As Integer _
)
[C#]
public override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[C++]
public: override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[JScript]
public override function ShiftByOffset(
   index : int,
   length : int,
   offset : int
);

Parameters

index
[To be supplied.]
length
[To be supplied.]
offset
[To be supplied.]

See Also

ByteStorage Class | ByteStorage Members | System.Data.Internal Namespace


CharStorage Class

[To be supplied.]

Object
DataStorage
CharStorage

[Visual Basic]
Public Class CharStorage
   Inherits DataStorage
[C#]
public class CharStorage : DataStorage
[C++]
public __gc class CharStorage : public DataStorage
[JScript]
public class CharStorage extends DataStorage

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

CharStorage Members | System.Data.Internal Namespace


CharStorage Members

Public:

Constructor

CharStorage Constructor [To be supplied.]

Properties

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

Methods

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

CharStorage Class | System.Data.Internal Namespace


CharStorage Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CharStorage();
[C++]
public: CharStorage();
[JScript]
public function CharStorage();

See Also

CharStorage Class | CharStorage Members | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CharStorage Properties

The properties of the CharStorage class are listed below. For a complete list of CharStorage class members, see the CharStorage Members topic.

Public:

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

See Also

CharStorage Class | System.Data.Internal Namespace


CharStorage.DefaultValue

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DefaultValue As Object
[C#]
public object DefaultValue {override get;}
[C++]
public: __property virtual Object* get_DefaultValue();
[JScript]
public function get DefaultValue() : Object;

See Also

CharStorage Class | CharStorage Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CharStorage Methods

The methods of the CharStorage class are listed below. For a complete list of CharStorage class members, see the CharStorage Members topic.

Public:

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

CharStorage Class | System.Data.Internal Namespace


CharStorage.Aggregate

[To be supplied.]

[Visual Basic]
Overrides Public Function Aggregate( _
   ByVal records() As Integer, _
   ByVal kind As AggregateTypes _
) As Object
[C#]
public override object Aggregate(
   int[] records,
   AggregateTypes kind
);
[C++]
public: override Object* Aggregate(
   int* records[],
   AggregateTypes kind
);
[JScript]
public override function Aggregate(
   records : int[],
   kind : AggregateTypes
) : Object;

Parameters

records
[To be supplied.]
kind
[To be supplied.]

See Also

CharStorage Class | CharStorage Members | System.Data.Internal Namespace


CharStorage.Compare

[To be supplied.]

[Visual Basic]
Overrides Public Function Compare( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
) As Integer
[C#]
public override int Compare(
   int recordNo1,
   int recordNo2
);
[C++]
public: override int Compare(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Compare(
   recordNo1 : int,
   recordNo2 : int
) : int;

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

CharStorage Class | CharStorage Members | System.Data.Internal Namespace


CharStorage.CompareToValue

[To be supplied.]

[Visual Basic]
Overrides Public Function CompareToValue( _
   ByVal recordNo As Integer, _
   ByVal value As Object _
) As Integer
[C#]
public override int CompareToValue(
   int recordNo,
   object value
);
[C++]
public: override int CompareToValue(
   int recordNo,
   Object* value
);
[JScript]
public override function CompareToValue(
   recordNo : int,
   value : Object
) : int;

Parameters

recordNo
[To be supplied.]
value
[To be supplied.]

See Also

CharStorage Class | CharStorage Members | System.Data.Internal Namespace


CharStorage.Copy

[To be supplied.]

[Visual Basic]
Overrides Public Sub Copy( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
)
[C#]
public override void Copy(
   int recordNo1,
   int recordNo2
);
[C++]
public: override void Copy(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Copy(
   recordNo1 : int,
   recordNo2 : int
);

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

CharStorage Class | CharStorage Members | System.Data.Internal Namespace


CharStorage.Get

[To be supplied.]

[Visual Basic]
Overrides Public Function Get( _
   ByVal record As Integer _
) As Object
[C#]
public override object Get(
   int record
);
[C++]
public: override Object* Get(
   int record
);
[JScript]
public override function Get(
   record : int
) : Object;

Parameters

record
[To be supplied.]

See Also

CharStorage Class | CharStorage Members | System.Data.Internal Namespace


CharStorage.Set

[To be supplied.]

[Visual Basic]
Overrides Public Sub Set( _
   ByVal record As Integer, _
   ByVal value As Object _
)
[C#]
public override void Set(
   int record,
   object value
);
[C++]
public: override void Set(
   int record,
   Object* value
);
[JScript]
public override function Set(
   record : int,
   value : Object
);

Parameters

record
[To be supplied.]
value
[To be supplied.]

See Also

CharStorage Class | CharStorage Members | System.Data.Internal Namespace


CharStorage.SetCapacity

[To be supplied.]

[Visual Basic]
Overrides Public Sub SetCapacity( _
   ByVal capacity As Integer _
)
[C#]
public override void SetCapacity(
   int capacity
);
[C++]
public: override void SetCapacity(
   int capacity
);
[JScript]
public override function SetCapacity(
   capacity : int
);

Parameters

capacity
[To be supplied.]

See Also

CharStorage Class | CharStorage Members | System.Data.Internal Namespace


CharStorage.ShiftByOffset

[To be supplied.]

[Visual Basic]
Overrides Public Sub ShiftByOffset( _
   ByVal index As Integer, _
   ByVal length As Integer, _
   ByVal offset As Integer _
)
[C#]
public override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[C++]
public: override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[JScript]
public override function ShiftByOffset(
   index : int,
   length : int,
   offset : int
);

Parameters

index
[To be supplied.]
length
[To be supplied.]
offset
[To be supplied.]

See Also

CharStorage Class | CharStorage Members | System.Data.Internal Namespace


CurrencyStorage Class

[To be supplied.]

Object
DataStorage
CurrencyStorage

[Visual Basic]
Public Class CurrencyStorage
   Inherits DataStorage
[C#]
public class CurrencyStorage : DataStorage
[C++]
public __gc class CurrencyStorage : public DataStorage
[JScript]
public class CurrencyStorage extends DataStorage

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

CurrencyStorage Members | System.Data.Internal Namespace


CurrencyStorage Members

Public:

Constructor

CurrencyStorage Constructor [To be supplied.]

Properties

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

Methods

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

CurrencyStorage Class | System.Data.Internal Namespace


CurrencyStorage Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CurrencyStorage();
[C++]
public: CurrencyStorage();
[JScript]
public function CurrencyStorage();

See Also

CurrencyStorage Class | CurrencyStorage Members | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CurrencyStorage Properties

The properties of the CurrencyStorage class are listed below. For a complete list of CurrencyStorage class members, see the CurrencyStorage Members topic.

Public:

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

See Also

CurrencyStorage Class | System.Data.Internal Namespace


CurrencyStorage.DefaultValue

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DefaultValue As Object
[C#]
public object DefaultValue {override get;}
[C++]
public: __property virtual Object* get_DefaultValue();
[JScript]
public function get DefaultValue() : Object;

See Also

CurrencyStorage Class | CurrencyStorage Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CurrencyStorage Methods

The methods of the CurrencyStorage class are listed below. For a complete list of CurrencyStorage class members, see the CurrencyStorage Members topic.

Public:

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

CurrencyStorage Class | System.Data.Internal Namespace


CurrencyStorage.Aggregate

[To be supplied.]

[Visual Basic]
Overrides Public Function Aggregate( _
   ByVal records() As Integer, _
   ByVal kind As AggregateTypes _
) As Object
[C#]
public override object Aggregate(
   int[] records,
   AggregateTypes kind
);
[C++]
public: override Object* Aggregate(
   int* records[],
   AggregateTypes kind
);
[JScript]
public override function Aggregate(
   records : int[],
   kind : AggregateTypes
) : Object;

Parameters

records
[To be supplied.]
kind
[To be supplied.]

See Also

CurrencyStorage Class | CurrencyStorage Members | System.Data.Internal Namespace


CurrencyStorage.Compare

[To be supplied.]

[Visual Basic]
Overrides Public Function Compare( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
) As Integer
[C#]
public override int Compare(
   int recordNo1,
   int recordNo2
);
[C++]
public: override int Compare(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Compare(
   recordNo1 : int,
   recordNo2 : int
) : int;

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

CurrencyStorage Class | CurrencyStorage Members | System.Data.Internal Namespace


CurrencyStorage.CompareToValue

[To be supplied.]

[Visual Basic]
Overrides Public Function CompareToValue( _
   ByVal recordNo As Integer, _
   ByVal value As Object _
) As Integer
[C#]
public override int CompareToValue(
   int recordNo,
   object value
);
[C++]
public: override int CompareToValue(
   int recordNo,
   Object* value
);
[JScript]
public override function CompareToValue(
   recordNo : int,
   value : Object
) : int;

Parameters

recordNo
[To be supplied.]
value
[To be supplied.]

See Also

CurrencyStorage Class | CurrencyStorage Members | System.Data.Internal Namespace


CurrencyStorage.Copy

[To be supplied.]

[Visual Basic]
Overrides Public Sub Copy( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
)
[C#]
public override void Copy(
   int recordNo1,
   int recordNo2
);
[C++]
public: override void Copy(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Copy(
   recordNo1 : int,
   recordNo2 : int
);

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

CurrencyStorage Class | CurrencyStorage Members | System.Data.Internal Namespace


CurrencyStorage.Get

[To be supplied.]

[Visual Basic]
Overrides Public Function Get( _
   ByVal record As Integer _
) As Object
[C#]
public override object Get(
   int record
);
[C++]
public: override Object* Get(
   int record
);
[JScript]
public override function Get(
   record : int
) : Object;

Parameters

record
[To be supplied.]

See Also

CurrencyStorage Class | CurrencyStorage Members | System.Data.Internal Namespace


CurrencyStorage.Set

[To be supplied.]

[Visual Basic]
Overrides Public Sub Set( _
   ByVal record As Integer, _
   ByVal value As Object _
)
[C#]
public override void Set(
   int record,
   object value
);
[C++]
public: override void Set(
   int record,
   Object* value
);
[JScript]
public override function Set(
   record : int,
   value : Object
);

Parameters

record
[To be supplied.]
value
[To be supplied.]

See Also

CurrencyStorage Class | CurrencyStorage Members | System.Data.Internal Namespace


CurrencyStorage.SetCapacity

[To be supplied.]

[Visual Basic]
Overrides Public Sub SetCapacity( _
   ByVal capacity As Integer _
)
[C#]
public override void SetCapacity(
   int capacity
);
[C++]
public: override void SetCapacity(
   int capacity
);
[JScript]
public override function SetCapacity(
   capacity : int
);

Parameters

capacity
[To be supplied.]

See Also

CurrencyStorage Class | CurrencyStorage Members | System.Data.Internal Namespace


CurrencyStorage.ShiftByOffset

[To be supplied.]

[Visual Basic]
Overrides Public Sub ShiftByOffset( _
   ByVal index As Integer, _
   ByVal length As Integer, _
   ByVal offset As Integer _
)
[C#]
public override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[C++]
public: override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[JScript]
public override function ShiftByOffset(
   index : int,
   length : int,
   offset : int
);

Parameters

index
[To be supplied.]
length
[To be supplied.]
offset
[To be supplied.]

See Also

CurrencyStorage Class | CurrencyStorage Members | System.Data.Internal Namespace


DataColumnMapping Class

generic column mapping

Object
DataColumnMapping

[Visual Basic]
NotInheritable Public Class DataColumnMapping
   Implements IColumnMapping, ICloneable
[C#]
public sealed class DataColumnMapping : IColumnMapping, ICloneable
[C++]
public __gc __sealed class DataColumnMapping : public
   IColumnMapping, ICloneable
[JScript]
public class DataColumnMapping implements IColumnMapping,
   ICloneable

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

DataColumnMapping Members | System.Data.Internal Namespace


DataColumnMapping Members

Public:

Constructor

DataColumnMapping Constructor Overloaded. [To be supplied.]

Properties

DataSetColumn | Case-Insensitive
Parent | get the paret column mappings collection
SourceColumn | Case-Sensitive

Methods

Clone | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDataColumnBySchemaAction | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataColumnMapping Class | System.Data.Internal Namespace


DataColumnMapping Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public DataColumnMapping();
[C++] public: DataColumnMapping();
[JScript] public function DataColumnMapping();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, String)
[C#] public DataColumnMapping(String, String);
[C++] public: DataColumnMapping(String*, String*);
[JScript] public function DataColumnMapping(String, String);

See Also

DataColumnMapping Class | DataColumnMapping Members | System.Data.Internal Namespace


DataColumnMapping Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public DataColumnMapping();
[C++]
public: DataColumnMapping();
[JScript]
public function DataColumnMapping();

See Also

DataColumnMapping Class | DataColumnMapping Members | System.Data.Internal Namespace | DataColumnMapping Constructor Overload List


DataColumnMapping Constructor (String, String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal sourceColumn As String, _
   ByVal dataSetColumn As String _
)
[C#]
public DataColumnMapping(
   string sourceColumn,
   string dataSetColumn
);
[C++]
public: DataColumnMapping(
   String* sourceColumn,
   String* dataSetColumn
);
[JScript]
public function DataColumnMapping(
   sourceColumn : String,
   dataSetColumn : String
);

Parameters

sourceColumn
[To be supplied.]
dataSetColumn
[To be supplied.]

See Also

DataColumnMapping Class | DataColumnMapping Members | System.Data.Internal Namespace | DataColumnMapping Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataColumnMapping Properties

The properties of the DataColumnMapping class are listed below. For a complete list of DataColumnMapping class members, see the DataColumnMapping Members topic.

Public:

DataSetColumn | Case-Insensitive
Parent | get the paret column mappings collection
SourceColumn | Case-Sensitive

See Also

DataColumnMapping Class | System.Data.Internal Namespace


DataColumnMapping.DataSetColumn

Case-Insensitive

[Visual Basic]
Public Property DataSetColumn As String
[C#]
public string DataSetColumn {get; set;}
[C++]
public: __property String* get_DataSetColumn();
public: __property void set_DataSetColumn(String*);
[JScript]
public function get DataSetColumn() : String;
public function set DataSetColumn(String);

See Also

DataColumnMapping Class | DataColumnMapping Members | System.Data.Internal Namespace


DataColumnMapping.Parent

get the paret column mappings collection

[Visual Basic]
Public ReadOnly Property Parent As DataColumnMappings
[C#]
public DataColumnMappings Parent {get;}
[C++]
public: __property DataColumnMappings* get_Parent();
[JScript]
public function get Parent() : DataColumnMappings;

See Also

DataColumnMapping Class | DataColumnMapping Members | System.Data.Internal Namespace


DataColumnMapping.SourceColumn

Case-Sensitive

[Visual Basic]
Public Property SourceColumn As String
[C#]
public string SourceColumn {get; set;}
[C++]
public: __property String* get_SourceColumn();
public: __property void set_SourceColumn(String*);
[JScript]
public function get SourceColumn() : String;
public function set SourceColumn(String);

See Also

DataColumnMapping Class | DataColumnMapping Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataColumnMapping Methods

The methods of the DataColumnMapping class are listed below. For a complete list of DataColumnMapping class members, see the DataColumnMapping Members topic.

Public:

Clone | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDataColumnBySchemaAction | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataColumnMapping Class | System.Data.Internal Namespace


DataColumnMapping.Clone

[To be supplied.]

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

See Also

DataColumnMapping Class | DataColumnMapping Members | System.Data.Internal Namespace


DataColumnMapping.GetDataColumnBySchemaAction

[To be supplied.]

[Visual Basic]
Public Function GetDataColumnBySchemaAction( _
   ByVal dataTable As DataTable, _
   ByVal dataType As Type, _
   ByVal dataStorage As DataStorage, _
   ByVal schemaAction As MissingSchemaAction _
) As DataColumn
[C#]
public DataColumn GetDataColumnBySchemaAction(
   DataTable dataTable,
   Type dataType,
   DataStorage dataStorage,
   MissingSchemaAction schemaAction
);
[C++]
public: DataColumn* GetDataColumnBySchemaAction(
   DataTable* dataTable,
   Type* dataType,
   DataStorage* dataStorage,
   MissingSchemaAction schemaAction
);
[JScript]
public function GetDataColumnBySchemaAction(
   dataTable : DataTable,
   dataType : Type,
   dataStorage : DataStorage,
   schemaAction : MissingSchemaAction
) : DataColumn;

Parameters

dataTable
[To be supplied.]
dataType
[To be supplied.]
dataStorage
[To be supplied.]
schemaAction
[To be supplied.]

See Also

DataColumnMapping Class | DataColumnMapping Members | System.Data.Internal Namespace


DataColumnMapping.ToString

[To be supplied.]

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

DataColumnMapping Class | DataColumnMapping Members | System.Data.Internal Namespace


DataColumnMappingConverter Class

[To be supplied.]

Object
TypeConverter
DataColumnMappingConverter

[Visual Basic]
NotInheritable Public Class DataColumnMappingConverter
   Inherits TypeConverter
[C#]
public sealed class DataColumnMappingConverter : TypeConverter
[C++]
public __gc __sealed class DataColumnMappingConverter : public
   TypeConverter
[JScript]
public class DataColumnMappingConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

DataColumnMappingConverter Members | System.Data.Internal Namespace


DataColumnMappingConverter Members

Public:

Constructor

DataColumnMappingConverter Constructor [To be supplied.]

Methods

CanConvertFrom (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the converter's native type.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text into an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given object to another type.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetProperties (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValues (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid (inherited from TypeConverter) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

DataColumnMappingConverter Class | System.Data.Internal Namespace


DataColumnMappingConverter Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public DataColumnMappingConverter();
[C++]
public: DataColumnMappingConverter();
[JScript]
public function DataColumnMappingConverter();

See Also

DataColumnMappingConverter Class | DataColumnMappingConverter Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataColumnMappingConverter Methods

The methods of the DataColumnMappingConverter class are listed below. For a complete list of DataColumnMappingConverter class members, see the DataColumnMappingConverter Members topic.

Public:

CanConvertFrom (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the converter's native type.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text into an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given object to another type.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetProperties (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValues (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid (inherited from TypeConverter) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

DataColumnMappingConverter Class | System.Data.Internal Namespace


DataColumnMappingConverter.GetPersistInfo

[To be supplied.]

[Visual Basic]
Overrides Public Function GetPersistInfo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal obj As Object _
) As PersistInfo
[C#]
public override PersistInfo GetPersistInfo(
   ITypeDescriptorContext context,
   object obj
);
[C++]
public: override PersistInfo* GetPersistInfo(
   ITypeDescriptorContext* context,
   Object* obj
);
[JScript]
public override function GetPersistInfo(
   context : ITypeDescriptorContext,
   obj : Object
) : PersistInfo;

Parameters

context
[To be supplied.]
obj
[To be supplied.]

See Also

DataColumnMappingConverter Class | DataColumnMappingConverter Members | System.Data.Internal Namespace


DataColumnMappingConverter.GetProperties

Retrieves the set of properties for this type. By default, a type has does not return any properties. An easy implementation of this method can just call TypeDescriptor.GetProperties for the correct data type.

[Visual Basic]
Overrides Public Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal attributes() As MemberAttribute _
) As PropertyDescriptorCollection
[C#]
public override PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value,
   MemberAttribute[] attributes
);
[C++]
public: override PropertyDescriptorCollection* GetProperties(
   ITypeDescriptorContext* context,
   Object* value,
   MemberAttribute* attributes[]
);
[JScript]
public override function GetProperties(
   context : ITypeDescriptorContext,
   value : Object,
   attributes : MemberAttribute[]
) : PropertyDescriptorCollection;

Parameters

context
A type descriptor through which additional context may be provided.
value
The value of the object to get the properties for.
attributes
[To be supplied.]

Return Value

The set of properties that should be exposed for this data type. If no properties should be exposed, thsi may return null. The default implementation always returns null.

See Also

DataColumnMappingConverter Class | DataColumnMappingConverter Members | System.Data.Internal Namespace


DataColumnMappingConverter.GetPropertiesSupported

Determines if this object supports properties. By default, this is false.

[Visual Basic]
Overrides Public Function GetPropertiesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
[C#]
public override bool GetPropertiesSupported(
   ITypeDescriptorContext context
);
[C++]
public: override bool GetPropertiesSupported(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetPropertiesSupported(
   context : ITypeDescriptorContext
) : Boolean;

Parameters

context
A type descriptor through which additional context may be provided.

Return Value

Returns true if GetProperties should be called to find the properties of this object.

See Also

DataColumnMappingConverter Class | DataColumnMappingConverter Members | System.Data.Internal Namespace


DataColumnMappings Class

column mapping collection

Object
DataColumnMappings

[Visual Basic]
NotInheritable Public Class DataColumnMappings
   Implements IColumnMappings, IList, ICollection, IEnumerable
[C#]
public sealed class DataColumnMappings : IColumnMappings, IList,
   ICollection, IEnumerable
[C++]
public __gc __sealed class DataColumnMappings : public
   IColumnMappings, IList, ICollection, IEnumerable
[JScript]
public class DataColumnMappings implements IColumnMappings, IList,
   ICollection, IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

DataColumnMappings Members | System.Data.Internal Namespace


DataColumnMappings Members

Public:

Constructor

DataColumnMappings Constructor [To be supplied.]

Properties

All | [To be supplied.]
Count | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the DataColumnMappings class.
Parent | [To be supplied.]

Methods

Add | Overloaded. [To be supplied.]
Clear | remove all the items from the collection
Contains | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetByDataSetColumn | [To be supplied.]
GetColumnMappingBySchemaAction | [To be supplied.]
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | Overloaded. [To be supplied.]
IndexOfDataSetColumn | [To be supplied.]
Remove | [To be supplied.]
RemoveAt | Overloaded. [To be supplied.]
ShouldPersistAll | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataColumnMappings Class | System.Data.Internal Namespace


DataColumnMappings Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public DataColumnMappings();
[C++]
public: DataColumnMappings();
[JScript]
public function DataColumnMappings();

See Also

DataColumnMappings Class | DataColumnMappings Members | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataColumnMappings Properties

The properties of the DataColumnMappings class are listed below. For a complete list of DataColumnMappings class members, see the DataColumnMappings Members topic.

Public:

All | [To be supplied.]
Count | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the DataColumnMappings class.
Parent | [To be supplied.]

See Also

DataColumnMappings Class | System.Data.Internal Namespace


DataColumnMappings.All

[To be supplied.]

[Visual Basic]
Public Property All As DataColumnMapping ()
[C#]
public DataColumnMapping[] All {get; set;}
[C++]
public: __property DataColumnMapping* get_All();
public: __property void set_All(DataColumnMapping*[]);
[JScript]
public function get All() : DataColumnMapping[];
public function set All(DataColumnMapping[]);

See Also

DataColumnMappings Class | DataColumnMappings Members | System.Data.Internal Namespace


DataColumnMappings.Count

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

See Also

DataColumnMappings Class | DataColumnMappings Members | System.Data.Internal Namespace


DataColumnMappings.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the DataColumnMappings class.

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Default Property Item(Integer) As DataColumnMapping
[C#] public DataColumnMapping this[int] {get; set;}
[C++] public: __property DataColumnMapping* get_Item(int);
public: __property void set_Item(int, DataColumnMapping*);
[JScript] DataColumnMappings.Item (int)

[To be supplied.]

[Visual Basic] Overloads Public Default Property Item(String) As DataColumnMapping
[C#] public DataColumnMapping this[String] {get; set;}
[C++] public: __property DataColumnMapping* get_Item(String*);
public: __property void set_Item(String*, DataColumnMapping*);
[JScript] DataColumnMappings.Item (String)

See Also

DataColumnMappings Class | DataColumnMappings Members | System.Data.Internal Namespace


DataColumnMappings.Item (Int32)

[To be supplied.]

[C#] In C#, this member is the indexer for the DataColumnMappings class.

[Visual Basic]
Overloads Public Default Property Item( _
   ByVal index As Integer _
) As DataColumnMapping
[C#]
public DataColumnMapping this[
   int index
] {get; set;}
[C++]
public: __property DataColumnMapping* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   DataColumnMapping*
);
[JScript]
returnValue = DataColumnMappingsObject.Item(index);
DataColumnMappingsObject.Item(index) = returnValue;
-or-
returnValue = DataColumnMappingsObject(index);
DataColumnMappingsObject(index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
0-based

Parameters [Visual Basic, C#, C++]

index
0-based

See Also

DataColumnMappings Class | DataColumnMappings Members | System.Data.Internal Namespace | DataColumnMappings.Item Overload List


DataColumnMappings.Item (String)

[To be supplied.]

[C#] In C#, this member is the indexer for the DataColumnMappings class.

[Visual Basic]
Overloads Public Default Property Item( _
   ByVal sourceColumn As String _
) As DataColumnMapping
[C#]
public DataColumnMapping this[
   string sourceColumn
] {get; set;}
[C++]
public: __property DataColumnMapping* get_Item(
   String* sourceColumn
);
public: __property void set_Item(
   String* sourceColumn,
   DataColumnMapping*
);
[JScript]
returnValue = DataColumnMappingsObject.Item(sourceColumn);
DataColumnMappingsObject.Item(sourceColumn) = returnValue;
-or-
returnValue = DataColumnMappingsObject(sourceColumn);
DataColumnMappingsObject(sourceColumn) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

sourceColumn
Case-Sensitive

Parameters [Visual Basic, C#, C++]

sourceColumn
Case-Sensitive

See Also

DataColumnMappings Class | DataColumnMappings Members | System.Data.Internal Namespace | DataColumnMappings.Item Overload List


DataColumnMappings.Parent

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Parent As DataTableMapping
[C#]
public DataTableMapping Parent {get;}
[C++]
public: __property DataTableMapping* get_Parent();
[JScript]
public function get Parent() : DataTableMapping;

See Also

DataColumnMappings Class | DataColumnMappings Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataColumnMappings Methods

The methods of the DataColumnMappings class are listed below. For a complete list of DataColumnMappings class members, see the DataColumnMappings Members topic.

Public:

Add | Overloaded. [To be supplied.]
Clear | remove all the items from the collection
Contains | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetByDataSetColumn | [To be supplied.]
GetColumnMappingBySchemaAction | [To be supplied.]
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | Overloaded. [To be supplied.]
IndexOfDataSetColumn | [To be supplied.]
Remove | [To be supplied.]
RemoveAt | Overloaded. [To be supplied.]
ShouldPersistAll | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataColumnMappings Class | System.Data.Internal Namespace


DataColumnMappings.Add

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function Add(String, String) As DataColumnMapping
[C#] public DataColumnMapping Add(String, String);
[C++] public: DataColumnMapping* Add(String*, String*);
[JScript] public function Add(String, String) : DataColumnMapping;

[To be supplied.]

[Visual Basic] Overloads Public Function Add(Object) As Integer
[C#] public int Add(Object);
[C++] public: int Add(Object*);
[JScript] public function Add(Object) : int;

See Also

DataColumnMappings Class | DataColumnMappings Members | System.Data.Internal Namespace


DataColumnMappings.Add (String, String)

[To be supplied.]

[Visual Basic]
Overloads Public Function Add( _
   ByVal sourceColumn As String, _
   ByVal dataSetColumn As String _
) As DataColumnMapping
[C#]
public DataColumnMapping Add(
   string sourceColumn,
   string dataSetColumn
);
[C++]
public: DataColumnMapping* Add(
   String* sourceColumn,
   String* dataSetColumn
);
[JScript]
public function Add(
   sourceColumn : String,
   dataSetColumn : String
) : DataColumnMapping;

Parameters

sourceColumn
Case-Sensitive
dataSetColumn
Case-Insensitive

See Also

DataColumnMappings Class | DataColumnMappings Members | System.Data.Internal Namespace | DataColumnMappings.Add Overload List


DataColumnMappings.Add (Object)

[To be supplied.]

[Visual Basic]
Overloads Public Function Add( _
   ByVal value As Object _
) As Integer
[C#]
public int Add(
   object value
);
[C++]
public: int Add(
   Object* value
);
[JScript]
public function Add(
   value : Object
) : int;

Parameters

value
[To be supplied.]

See Also

DataColumnMappings Class | DataColumnMappings Members | System.Data.Internal Namespace | DataColumnMappings.Add Overload List


DataColumnMappings.Clear

remove all the items from the collection

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[JScript]
public function Clear();

See Also

DataColumnMappings Class | DataColumnMappings Members | System.Data.Internal Namespace


DataColumnMappings.Contains

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function Contains(Object) As Boolean
[C#] public bool Contains(Object);
[C++] public: bool Contains(Object*);
[JScript] public function Contains(Object) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function Contains(String) As Boolean
[C#] public bool Contains(String);
[C++] public: bool Contains(String*);
[JScript] public function Contains(String) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function Contains(Integer) As Boolean
[C#] public bool Contains(int);
[C++] public: bool Contains(int);
[JScript] public function Contains(int) : Boolean;

See Also

DataColumnMappings Class | DataColumnMappings Members | System.Data.Internal Namespace


DataColumnMappings.Contains (Object)

[To be supplied.]

[Visual Basic]
Overloads Public Function Contains( _
   ByVal value As Object _
) As Boolean
[C#]
public bool Contains(
   object value
);
[C++]
public: bool Contains(
   Object* value
);
[JScript]
public function Contains(
   value : Object
) : Boolean;

Parameters

value
[To be supplied.]

See Also

DataColumnMappings Class | DataColumnMappings Members | System.Data.Internal Namespace | DataColumnMappings.Contains Overload List


DataColumnMappings.Contains (String)

[To be supplied.]

[Visual Basic]
Overloads Public Function Contains( _
   ByVal value As String _
) As Boolean
[C#]
public bool Contains(
   string value
);
[C++]
public: bool Contains(
   String* value
);
[JScript]
public function Contains(
   value : String
) : Boolean;

Parameters

value
Case-Sensitive SourceColumn

See Also

DataColumnMappings Class | DataColumnMappings Members | System.Data.Internal Namespace | DataColumnMappings.Contains Overload List


DataColumnMappings.Contains (Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Function Contains( _
   ByVal index As Integer _
) As Boolean
[C#]
public bool Contains(
   int index
);
[C++]
public: bool Contains(
   int index
);
[JScript]
public function Contains(
   index : int
) : Boolean;

Parameters

index
[To be supplied.]

See Also

DataColumnMappings Class | DataColumnMappings Members | System.Data.Internal Namespace | DataColumnMappings.Contains Overload List


DataColumnMappings.GetByDataSetColumn

[To be supplied.]

[Visual Basic]
Public Function GetByDataSetColumn( _
   ByVal value As String _
) As DataColumnMapping
[C#]
public DataColumnMapping GetByDataSetColumn(
   string value
);
[C++]
public: DataColumnMapping* GetByDataSetColumn(
   String* value
);
[JScript]
public function GetByDataSetColumn(
   value : String
) : DataColumnMapping;

Parameters

value
Case-Insensitive

See Also

DataColumnMappings Class | DataColumnMappings Members | System.Data.Internal Namespace


DataColumnMappings.GetColumnMappingBySchemaAction

[To be supplied.]

[Visual Basic]
Public Function GetColumnMappingBySchemaAction( _
   ByVal sourceColumn As String, _
   ByVal mappingAction As MissingMappingAction _
) As DataColumnMapping
[C#]
public DataColumnMapping GetColumnMappingBySchemaAction(
   string sourceColumn,
   MissingMappingAction mappingAction
);
[C++]
public: DataColumnMapping* GetColumnMappingBySchemaAction(
   String* sourceColumn,
   MissingMappingAction mappingAction
);
[JScript]
public function GetColumnMappingBySchemaAction(
   sourceColumn : String,
   mappingAction : MissingMappingAction
) : DataColumnMapping;

Parameters

sourceColumn
[To be supplied.]
mappingAction
[To be supplied.]

See Also

DataColumnMappings Class | DataColumnMappings Members | System.Data.Internal Namespace


DataColumnMappings.GetEnumerator

[To be supplied.]

[Visual Basic]
Overridable Public Function GetEnumerator() As IEnumerator
[C#]
public virtual IEnumerator GetEnumerator();
[C++]
public: virtual IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

See Also

DataColumnMappings Class | DataColumnMappings Members | System.Data.Internal Namespace


DataColumnMappings.IndexOf

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function IndexOf(Object) As Integer
[C#] public int IndexOf(Object);
[C++] public: int IndexOf(Object*);
[JScript] public function IndexOf(Object) : int;

[To be supplied.]

[Visual Basic] Overloads Public Function IndexOf(String) As Integer
[C#] public int IndexOf(String);
[C++] public: int IndexOf(String*);
[JScript] public function IndexOf(String) : int;

See Also

DataColumnMappings Class | DataColumnMappings Members | System.Data.Internal Namespace


DataColumnMappings.IndexOf (Object)

[To be supplied.]

[Visual Basic]
Overloads Public Function IndexOf( _
   ByVal value As Object _
) As Integer
[C#]
public int IndexOf(
   object value
);
[C++]
public: int IndexOf(
   Object* value
);
[JScript]
public function IndexOf(
   value : Object
) : int;

Parameters

value
[To be supplied.]

See Also

DataColumnMappings Class | DataColumnMappings Members | System.Data.Internal Namespace | DataColumnMappings.IndexOf Overload List


DataColumnMappings.IndexOf (String)

[To be supplied.]

[Visual Basic]
Overloads Public Function IndexOf( _
   ByVal sourceColumn As String _
) As Integer
[C#]
public int IndexOf(
   string sourceColumn
);
[C++]
public: int IndexOf(
   String* sourceColumn
);
[JScript]
public function IndexOf(
   sourceColumn : String
) : int;

Parameters

sourceColumn
Case-Sensitive

See Also

DataColumnMappings Class | DataColumnMappings Members | System.Data.Internal Namespace | DataColumnMappings.IndexOf Overload List


DataColumnMappings.IndexOfDataSetColumn

[To be supplied.]

[Visual Basic]
Public Function IndexOfDataSetColumn( _
   ByVal dataSetColumn As String _
) As Integer
[C#]
public int IndexOfDataSetColumn(
   string dataSetColumn
);
[C++]
public: int IndexOfDataSetColumn(
   String* dataSetColumn
);
[JScript]
public function IndexOfDataSetColumn(
   dataSetColumn : String
) : int;

Parameters

dataSetColumn
Case-Insensitive

See Also

DataColumnMappings Class | DataColumnMappings Members | System.Data.Internal Namespace


DataColumnMappings.Remove

[To be supplied.]

[Visual Basic]
Public Sub Remove( _
   ByVal value As Object _
)
[C#]
public void Remove(
   object value
);
[C++]
public: void Remove(
   Object* value
);
[JScript]
public function Remove(
   value : Object
);

Parameters

value
[To be supplied.]

See Also

DataColumnMappings Class | DataColumnMappings Members | System.Data.Internal Namespace


DataColumnMappings.RemoveAt

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub RemoveAt(String)
[C#] public void RemoveAt(String);
[C++] public: void RemoveAt(String*);
[JScript] public function RemoveAt(String);

[To be supplied.]

[Visual Basic] Overloads Public Sub RemoveAt(Integer)
[C#] public void RemoveAt(int);
[C++] public: void RemoveAt(int);
[JScript] public function RemoveAt(int);

See Also

DataColumnMappings Class | DataColumnMappings Members | System.Data.Internal Namespace


DataColumnMappings.RemoveAt (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub RemoveAt( _
   ByVal sourceColumn As String _
)
[C#]
public void RemoveAt(
   string sourceColumn
);
[C++]
public: void RemoveAt(
   String* sourceColumn
);
[JScript]
public function RemoveAt(
   sourceColumn : String
);

Parameters

sourceColumn
Case-Sensitive

See Also

DataColumnMappings Class | DataColumnMappings Members | System.Data.Internal Namespace | DataColumnMappings.RemoveAt Overload List


DataColumnMappings.RemoveAt (Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub RemoveAt( _
   ByVal index As Integer _
)
[C#]
public void RemoveAt(
   int index
);
[C++]
public: void RemoveAt(
   int index
);
[JScript]
public function RemoveAt(
   index : int
);

Parameters

index
0-based

See Also

DataColumnMappings Class | DataColumnMappings Members | System.Data.Internal Namespace | DataColumnMappings.RemoveAt Overload List


DataColumnMappings.ShouldPersistAll

[To be supplied.]

[Visual Basic]
Public Function ShouldPersistAll() As Boolean
[C#]
public bool ShouldPersistAll();
[C++]
public: bool ShouldPersistAll();
[JScript]
public function ShouldPersistAll() : Boolean;

See Also

DataColumnMappings Class | DataColumnMappings Members | System.Data.Internal Namespace


DataSchemaChangedEvent Class

[To be supplied.]

Object
EventArgs
DataSchemaChangedEvent

[Visual Basic]
Public Class DataSchemaChangedEvent
   Inherits EventArgs
[C#]
public class DataSchemaChangedEvent : EventArgs
[C++]
public __gc class DataSchemaChangedEvent : public EventArgs
[JScript]
public class DataSchemaChangedEvent extends EventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

DataSchemaChangedEvent Members | System.Data.Internal Namespace


DataSchemaChangedEvent Members

Public:

Properties

ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
RecordsAffected | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataSchemaChangedEvent Class | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataSchemaChangedEvent Properties

The properties of the DataSchemaChangedEvent class are listed below. For a complete list of DataSchemaChangedEvent class members, see the DataSchemaChangedEvent Members topic.

Public:

ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
RecordsAffected | [To be supplied.]

See Also

DataSchemaChangedEvent Class | System.Data.Internal Namespace


DataSchemaChangedEvent.RecordsAffected

[To be supplied.]

[Visual Basic]
Public ReadOnly Property RecordsAffected As Integer
[C#]
public int RecordsAffected {get;}
[C++]
public: __property int get_RecordsAffected();
[JScript]
public function get RecordsAffected() : int;

See Also

DataSchemaChangedEvent Class | DataSchemaChangedEvent Members | System.Data.Internal Namespace


DataSchemaChangedEventHandler Delegate

[To be supplied.]

[Visual Basic]
Public Delegate Sub DataSchemaChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataSchemaChangedEvent _
)
[C#]
public delegate void DataSchemaChangedEventHandler(
   object sender,
   DataSchemaChangedEvent e
);
[C++]
public __gc __delegate void DataSchemaChangedEventHandler(
   Object* sender,
   DataSchemaChangedEvent* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the DataSchemaChangedEventHandler delegate declaration.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

System.Data.Internal Namespace


DataSetCommand Class

Represents a set of data commands and a database connection which are used to fill the DataSet and update the data source. At any time, the object refers to only a single record within the current data set.

Object
Component
DataSetCommand

[Visual Basic]
MustInherit Public Class DataSetCommand
   Inherits Component
   Implements ICloneable, IDataSetCommand
[C#]
public abstract class DataSetCommand : Component, ICloneable,
   IDataSetCommand
[C++]
public __gc __abstract class DataSetCommand : public Component,
   ICloneable, IDataSetCommand
[JScript]
public abstract class DataSetCommand extends Component, ICloneable,
   IDataSetCommand

Remarks

In the past, data processing has been primarily connection-based. Now, in an effort to make multi-tiered applications more efficient, data processing is turning to a message-based approach that revolves around selections of information. At the center of this approach is the DataSetCommand, which provides a bridge to retrieve and save data between a DataSet and its source data store. The DataSetCommand provides this bridge by mapping FillDataSet, which changes the data in the DataSet to match the data in the data source, and Update, which changes the data in the data source to match the data in the DataSet.

If you are connecting to a Microsoft SQL Server database, you may wish to increase your overall performance by using the SQLDataSetCommand along with its associated SQLCommand and SQLConnection. For all other OLEDB-supported databases, it is probably better that you use DataSetCommand along with its associated DBCommand and ADOConnection.

When an instance of DataSetCommand is created, the read/write properties are set to initial values. For a list of these values, see the DataSetCommand constructor.

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

Example [C#]

The following example uses the derived classes ADODataSetCommand and SQLDataSetCommand to select records from an Access data source and insert them in a SQL Server data source. This example can be modified to migrate an Access database to a SQL Server database.

[C#]

private DataSet InitializeMyDataSet() {
   // creates the table and its columns for the DataSet
   DataSet newData = new DataSet();
   DataTable newTable = newData.Tables.Add("Catagories");

   // add Columns to table
   newTable.Columns.Add("CategoryID",typeof(Int32));
   newTable.Columns.Add("CategoryName", typeof(String));
   newTable.Columns.Add("Description", typeof(String));
   newTable.Columns.Add("Picture",typeof(Byte[]));
   return newData;
}

public void AccessToSQLServer() {
   // set Access connection and select strings
   const string strAccessConn = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=NWIND_RW.MDB";
   const string strAccessSelect = "SELECT * FROM Categories ORDER BY CategoryID";
   // set SQL Server connection and insert strings
   const string strSQLServerConn = "Data Source=VBsql7;Initial Catalog=Northwind;User ID=sa;Password=;";
   const string strSQLServerInsert = "INSERT INTO Categories(CategoryName, Description, Picture) Values(@CategoryName,@Description,@Picture)";
   // create my DataSet
   DataSet myDataSet = InitializeMyDataSet();
   // create my Access objects
   ADOConnection myAccessConn = new ADOConnection(strAccessConn);
   ADODataSetCommand myAccessDataSetCmd = new ADODataSetCommand();
   myAccessDataSetCmd.SelectCommand = new ADOCommand(strAccessSelect,myAccessConn);
   // create my SQL Server objects
   SQLConnection mySQLConn = new SQLConnection(strSQLServerConn);
   SQLDataSetCommand mySQLDataSetCmd = new SQLDataSetCommand();
   mySQLDataSetCmd.InsertCommand = new SQLCommand(strSQLServerInsert,mySQLConn);
   // fill myDataSet with data from Access
   myAccessConn.Open();
   try {
      myAccessDataSetCmd.FillDataSet(myDataSet,"table");
   }
   finally {
      myAccessConn.Close();
   }

   // do ugly work to turn original rows into new rows

   // update SQL Server with data from the DataSet
   mySQLConn.Open();
   try {
      mySQLDataSetCmd.InsertCommand.Parameters.Add("CategoryName", typeof(String));
      mySQLDataSetCmd.InsertCommand.Parameters.Add("Description", typeof(String));
      mySQLDataSetCmd.InsertCommand.Parameters.Add("Picture", typeof(Byte[]));
      mySQLDataSetCmd.InsertCommand.Parameters[0].SourceColumn = "CategoryName";
      mySQLDataSetCmd.InsertCommand.Parameters[1].SourceColumn = "Description";
      mySQLDataSetCmd.InsertCommand.Parameters[2].SourceColumn = "Picture";
      mySQLDataSetCmd.Update(myDataSet,"table");
   }
   finally {
      mySQLConn.Close();
   }
}

See Also

DataSetCommand Members | System.Data.Internal Namespace


DataSetCommand Members

Public:

Properties

MissingMappingAction | Gets or sets whether unmapped source tables or columns are to be passed with their source names to be filtered, or to cause an error to be raised.
MissingSchemaAction | Gets or sets whether missing source tables, columns, and their relationships are to be added to the data set schema, to be ignored, or to cause an error to be raised.
Site (inherited from Component) | Gets or sets the site of the Component.
TableMappings | Gets how a source table is to be mapped to a data set table.

Methods

Clone | Creates a clone of this instance of DataSetCommand.
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FillDataSet | Changes the data in the DataSet to match the data in the data source.
FillDataSetSchema | Fills the DataSet with only the schema based upon the chosen SchemaType.
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetFillDataSetParameters | Returns an array of IDataParameter objects used to fill the DataSet with records from the data source.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
Update | Changes the data in the data source to match the data in the DataSet.

Events

SchemaChanged | Occurs during Update after a command is executed against the data source when the schema may be potentially different due to a property change.
SchemaChanging | Occurs during Update before a command is executed against the data source when the schema may be potentially different due to a property change.

Protected:

Constructor

DataSetCommand Constructor Initializes a new instance of the DataSetCommand class.

Methods

CreateNewSchemaChangedEvent | [To be supplied.]
CreateNewSchemaChangingEvent | [To be supplied.]
CreateNewTableMappings | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnSchemaChanged | Raises the OnSchemaChanged event.
OnSchemaChanging | Raises the OnSchemaChanged event.

Event Hookup:

Methods

AddOnSchemaChanged | [To be supplied.]
AddOnSchemaChanging | [To be supplied.]

See Also

DataSetCommand Class | System.Data.Internal Namespace


DataSetCommand Constructor

Initializes a new instance of the DataSetCommand class.

[Visual Basic]
Protected Sub New()
[C#]
protected DataSetCommand();
[C++]
protected: DataSetCommand();
[JScript]
protected function DataSetCommand();

Remarks

When an instance of DataSetCommand is created, the following read/write properties are set to initial values.

Properties | Initial Value
MissingMappingAction | MissingMappingAction.Passthrough
MissingSchemaAction | MissingSchemaAction.Add
TableMappings | An array of DataTableMapping objects.

You can change the value of any of these properties through a separate call to the property.

See Also

DataSetCommand Class | DataSetCommand Members | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataSetCommand Properties

The properties of the DataSetCommand class are listed below. For a complete list of DataSetCommand class members, see the DataSetCommand Members topic.

Public:

MissingMappingAction | Gets or sets whether unmapped source tables or columns are to be passed with their source names to be filtered, or to cause an error to be raised.
MissingSchemaAction | Gets or sets whether missing source tables, columns, and their relationships are to be added to the data set schema, to be ignored, or to cause an error to be raised.
Site (inherited from Component) | Gets or sets the site of the Component.
TableMappings | Gets how a source table is to be mapped to a data set table.

See Also

DataSetCommand Class | System.Data.Internal Namespace


DataSetCommand.MissingMappingAction

Gets or sets whether unmapped source tables or columns are to be passed with their source names to be filtered, or to cause an error to be raised.

[Visual Basic]
Public Property MissingMappingAction As MissingMappingAction
[C#]
public MissingMappingAction MissingMappingAction {get; set;}
[C++]
public: __property MissingMappingAction get_MissingMappingAction();
public: __property void set_MissingMappingAction(MissingMappingAction);
[JScript]
public function get MissingMappingAction() : MissingMappingAction;
public function set MissingMappingAction(MissingMappingAction);

Property Value

One of the MissingMappingAction values. The default is Passthrough.

Exceptions

Exception Type | Condition
InvalidMappingAction | The value set is not one of the MissingMappingAction values.

Remarks

The TableMappings property provides the master mapping between the returned records and the DataSet.

Example [Visual Basic]

The following example shows how to set the MissingMappingAction property.

[Visual Basic]

Sub SetMissingMappingAction ()
    Dim adoDataSetComm As ADODataSetCommand
    adoDataSetComm = New ADODataSetCommand
    'Set action to Ignore when table or column is missing from table
    adoDataSetComm.MissingMappingAction = MissingMappingAction.Ignore
End Sub

See Also

DataSetCommand Class | DataSetCommand Members | System.Data.Internal Namespace | MissingSchemaAction


DataSetCommand.MissingSchemaAction

Gets or sets whether missing source tables, columns, and their relationships are to be added to the data set schema, to be ignored, or to cause an error to be raised.

[Visual Basic]
Public Property MissingSchemaAction As MissingSchemaAction
[C#]
public MissingSchemaAction MissingSchemaAction {get; set;}
[C++]
public: __property MissingSchemaAction get_MissingSchemaAction();
public: __property void set_MissingSchemaAction(MissingSchemaAction);
[JScript]
public function get MissingSchemaAction() : MissingSchemaAction;
public function set MissingSchemaAction(MissingSchemaAction);

Property Value

One of the MissingSchemaAction values. The default is Add.

Exceptions

Exception Type | Condition
InvalidSchemaAction | The value set is not one of the MissingSchemaAction values.

Example [Visual Basic]

The following example shows how to set the MissingSchemaAction property.

[Visual Basic]

Sub SetMissingSchemaAction ()
     Dim adoDataSetComm As ADODataSetCommand
     adoDataSetComm = New ADODataSetCommand
     ' Set the action to Error when a table or column is missing
     adoDataSetComm.MissingSchemaAction = MissingSchemaAction.Error
End Sub

See Also

DataSetCommand Class | DataSetCommand Members | System.Data.Internal Namespace | MissingMappingAction


DataSetCommand.TableMappings

Gets how a source table is to be mapped to a data set table.

[Visual Basic]
Public ReadOnly Property TableMappings As DataTableMappings
[C#]
public DataTableMappings TableMappings {get;}
[C++]
public: __property DataTableMappings* get_TableMappings();
[JScript]
public function get TableMappings() : DataTableMappings;

Property Value

A collection that provides the master mapping between the returned records and the DataSet. The default value is an empty collection.

Remarks

The DataSetCommand uses only the mappings for the source table named "Table". All select, insert, delete, and update commands returning data must do so using consistent column naming. The column names returned in the records must be unique, otherwise columns with duplicate names overwrites previous data. On Update only the table mapped to the source table named "Table" will have its changes reconciled.

Example [Visual Basic]

The following example shows how a source table is to be mapped to a data set table.

[Visual Basic]

Public Sub MyShowTableMap()
   Dim myDataSetComm As ADODataSetCommand
   ' Initialize the ADODataSetCommand
   myDataSetComm = New ADODataSetCommand
   ' Create an array of DataTableMapping
   Dim myTableMapArray() As DataTableMapping
   ' Create temporary table map for concatention loop
   Dim tmpTableMap As DataTableMapping
   ' Create string to concatenate mappings to
   Dim myTableMapString As String
   ' Create MessageBox to show table mappings in
   Dim myMsgBox As MessageBox
   ' get table mapping
   myTableMapArray = myDataSetComm.TableMappings.All
   ' initialize myTableMapString
   myTableMapString = ""
   ' loop to concatenate all mappings into string
   For Each tmpTableMap In myTableMapArray
       myTableMapString += tmpTableMap.ToString + "  "
   Next
   ' display all mappings in MessageBox
   myMsgBox.Show myTableMapString, "Current Table Mappings"
End Sub

See Also

DataSetCommand Class | DataSetCommand Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataSetCommand Methods

The methods of the DataSetCommand class are listed below. For a complete list of DataSetCommand class members, see the DataSetCommand Members topic.

Public:

Clone | Creates a clone of this instance of DataSetCommand.
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FillDataSet | Changes the data in the DataSet to match the data in the data source.
FillDataSetSchema | Fills the DataSet with only the schema based upon the chosen SchemaType.
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetFillDataSetParameters | Returns an array of IDataParameter objects used to fill the DataSet with records from the data source.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
Update | Changes the data in the data source to match the data in the DataSet.

Protected:

CreateNewSchemaChangedEvent | [To be supplied.]
CreateNewSchemaChangingEvent | [To be supplied.]
CreateNewTableMappings | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnSchemaChanged | Raises the OnSchemaChanged event.
OnSchemaChanging | Raises the OnSchemaChanged event.

Event Hookup:

AddOnSchemaChanged | [To be supplied.]
AddOnSchemaChanging | [To be supplied.]

See Also

DataSetCommand Class | System.Data.Internal Namespace


DataSetCommand.AddOnSchemaChanged

[To be supplied.]

[Visual Basic]
Overridable Public Sub AddOnSchemaChanged( _
   ByVal handler As SchemaChangedEventHandler _
)
[C#]
public virtual void AddOnSchemaChanged(
   SchemaChangedEventHandler handler
);
[C++]
public: virtual void AddOnSchemaChanged(
   SchemaChangedEventHandler* handler
);
[JScript]
public function AddOnSchemaChanged(
   handler : SchemaChangedEventHandler
);

Parameters

handler
A SchemaChangedEventHandler that manages the event.

See Also

DataSetCommand Class | DataSetCommand Members | System.Data.Internal Namespace


DataSetCommand.AddOnSchemaChanging

[To be supplied.]

[Visual Basic]
Overridable Public Sub AddOnSchemaChanging( _
   ByVal handler As SchemaChangingEventHandler _
)
[C#]
public virtual void AddOnSchemaChanging(
   SchemaChangingEventHandler handler
);
[C++]
public: virtual void AddOnSchemaChanging(
   SchemaChangingEventHandler* handler
);
[JScript]
public function AddOnSchemaChanging(
   handler : SchemaChangingEventHandler
);

Parameters

handler
A SchemaChangedEventHandler that manages the event.

See Also

DataSetCommand Class | DataSetCommand Members | System.Data.Internal Namespace


DataSetCommand.Clone

Creates a clone of this instance of DataSetCommand.

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

Return Value

The cloned instance of DataSetCommand.

Remarks

Notes to Inheritors: When overriding Clone in a derived class, be sure to call the base class's Clone method.

See Also

DataSetCommand Class | DataSetCommand Members | System.Data.Internal Namespace


DataSetCommand.CreateNewSchemaChangedEvent

[To be supplied.]

[Visual Basic]
Overridable Protected Function CreateNewSchemaChangedEvent( _
   ByVal schemaType As SchemaType, _
   ByVal source As Object _
) As SchemaChangedEventArgs
[C#]
protected virtual SchemaChangedEventArgs CreateNewSchemaChangedEvent(
   SchemaType schemaType,
   object source
);
[C++]
protected: virtual SchemaChangedEventArgs* CreateNewSchemaChangedEvent(
   SchemaType schemaType,
   Object* source
);
[JScript]
protected function CreateNewSchemaChangedEvent(
   schemaType : SchemaType,
   source : Object
) : SchemaChangedEventArgs;

Parameters

schemaType
[To be supplied.]
source
[To be supplied.]

See Also

DataSetCommand Class | DataSetCommand Members | System.Data.Internal Namespace


DataSetCommand.CreateNewSchemaChangingEvent

[To be supplied.]

[Visual Basic]
Overridable Protected Function CreateNewSchemaChangingEvent( _
   ByVal schemaType As SchemaType, _
   ByVal source As Object _
) As SchemaChangingEventArgs
[C#]
protected virtual SchemaChangingEventArgs CreateNewSchemaChangingEvent(
   SchemaType schemaType,
   object source
);
[C++]
protected: virtual SchemaChangingEventArgs* CreateNewSchemaChangingEvent(
   SchemaType schemaType,
   Object* source
);
[JScript]
protected function CreateNewSchemaChangingEvent(
   schemaType : SchemaType,
   source : Object
) : SchemaChangingEventArgs;

Parameters

schemaType
[To be supplied.]
source
[To be supplied.]

See Also

DataSetCommand Class | DataSetCommand Members | System.Data.Internal Namespace


DataSetCommand.CreateNewTableMappings

[To be supplied.]

[Visual Basic]
Overridable Protected Function CreateNewTableMappings() As _
   DataTableMappings
[C#]
protected virtual DataTableMappings CreateNewTableMappings();
[C++]
protected: virtual DataTableMappings* CreateNewTableMappings();
[JScript]
protected function CreateNewTableMappings() : DataTableMappings;

See Also

DataSetCommand Class | DataSetCommand Members | System.Data.Internal Namespace


DataSetCommand.FillDataSet

Changes the data in the DataSet to match the data in the data source.

[Visual Basic]
Overridable Public Function FillDataSet( _
   ByVal dataSet As DataSet _
) As Integer
[C#]
public virtual int FillDataSet(
   DataSet dataSet
);
[C++]
public: virtual int FillDataSet(
   DataSet* dataSet
);
[JScript]
public function FillDataSet(
   dataSet : DataSet
) : int;

Parameters

dataSet
The DataSet to update with data and schema from the data source.

Remarks

Fills the DataSet with both data and the schema.

TableMappings are required to be mapped for this method to operate. The default source table is named "Table".

Notes to Inheritors: When overriding FillDataSet in a derived class, be sure to call the base class's FillDataSet method.

See Also

DataSetCommand Class | DataSetCommand Members | System.Data.Internal Namespace


DataSetCommand.FillDataSetSchema

Fills the DataSet with only the schema based upon the chosen SchemaType.

[Visual Basic]
Overridable Public Function FillDataSetSchema( _
   ByVal dataSet As DataSet, _
   ByVal schemaType As SchemaType _
) As DataTable ()
[C#]
public virtual DataTable[] FillDataSetSchema(
   DataSet dataSet,
   SchemaType schemaType
);
[C++]
public: virtual DataTable* FillDataSetSchema(
   DataSet* dataSet,
   SchemaType schemaType
) [];
[JScript]
public function FillDataSetSchema(
   dataSet : DataSet,
   schemaType : SchemaType
) : DataTable[];

Parameters

dataSet
The DataSet to be filled with the schema from the data source.
schemaType
One of the SchemaType values.

Return Value

An array of DataTable objects that contain data returned from the data source.

Remarks

TableMappings is required to be mapped for this method to operate. The default source table is named "Table".

Notes to Inheritors: When overriding FillDataSetSchema in a derived class, be sure to call the base class's FillDataSetSchema method.

See Also

DataSetCommand Class | DataSetCommand Members | System.Data.Internal Namespace


DataSetCommand.GetFillDataSetParameters

Returns an array of IDataParameter objects used to fill the DataSet with records from the data source.

[Visual Basic]
Overridable Public Function GetFillDataSetParameters() As _
   IDataParameter ()
[C#]
public virtual IDataParameter[] GetFillDataSetParameters();
[C++]
public: virtual IDataParameter* GetFillDataSetParameters() [];
[JScript]
public function GetFillDataSetParameters() : IDataParameter[];

Return Value

An array of IDataParameter objects.

Remarks

Notes to Inheritors: When overriding GetFillDataSetParameters in a derived class, be sure to call the base class's GetFillDataSetParameters method.

See Also

DataSetCommand Class | DataSetCommand Members | System.Data.Internal Namespace


DataSetCommand.OnSchemaChanged

Raises the OnSchemaChanged event.

[Visual Basic]
Overridable Protected Sub OnSchemaChanged( _
   ByVal scevent As SchemaChangedEventArgs _
)
[C#]
protected virtual void OnSchemaChanged(
   SchemaChangedEventArgs scevent
);
[C++]
protected: virtual void OnSchemaChanged(
   SchemaChangedEventArgs* scevent
);
[JScript]
protected function OnSchemaChanged(
   scevent : SchemaChangedEventArgs
);

Parameters

scevent
A SchemaChangedEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see TBD.

Notes to Inheritors: When overriding OnSchemaChanged in a derived class, be sure to call the bases class's OnSchemaChanged method.

Example [Visual Basic]

The following example uses this method within a derived class.

[Visual Basic]

' MyDataSetCommand.class derived from ADODataSetCommand
Inherits ADODataSetCommand
' create the method for row updated
Public Sub OnRowUpdated(event As RowUpdatedEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row has been updated."
   '  call the base class method
   MyBase.OnRowUpdated event
End Sub
' create the method for row updating
Public Sub OnRowUpdating(event As RowUpdatingEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row is being updated ..."
   '  call the base class method
   MyBase.OnRowUpdating event
End Sub
' create the method for the schema changing
Public Sub OnSchemaChanging(event As SchemaChangingEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is changing ..."
   '  call the base class method
   MyBase.OnSchemaChanging event
End Sub
' create the method for the schema changed
Public Sub OnSchemaChanged(event As SchemaChangedEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema has changed"
   '  call the base class method
   MyBase.OnSchemaChanged event
End Sub
' create the method for the schema being mapped
Public Sub OnSchemaMapping(event As SchemaMappingEventArgs)
   ' show a message box telling the user of schema map
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is currently being mapped ..."
   ' call the base class method
   MyBase.OnSchemaMapping event
End Sub

See Also

DataSetCommand Class | DataSetCommand Members | System.Data.Internal Namespace | OnSchemaChanging


DataSetCommand.OnSchemaChanging

Raises the OnSchemaChanged event.

[Visual Basic]
Overridable Protected Sub OnSchemaChanging( _
   ByVal scevent As SchemaChangingEventArgs _
)
[C#]
protected virtual void OnSchemaChanging(
   SchemaChangingEventArgs scevent
);
[C++]
protected: virtual void OnSchemaChanging(
   SchemaChangingEventArgs* scevent
);
[JScript]
protected function OnSchemaChanging(
   scevent : SchemaChangingEventArgs
);

Parameters

scevent
A SchemaChangedEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see TBD.

Notes to Inheritors: When overriding OnSchemaChanged in a derived class, be sure to call the bases class's OnSchemaChanged method.

Example [Visual Basic]

The following example uses this method within a derived class.

[Visual Basic]

' MyDataSetCommand.class derived from ADODataSetCommand
Inherits ADODataSetCommand
' create the method for row updated
Public Sub OnRowUpdated(event As RowUpdatedEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row has been updated."
   '  call the base class method
   MyBase.OnRowUpdated event
End Sub
' create the method for row updating
Public Sub OnRowUpdating(event As RowUpdatingEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row is being updated ..."
   '  call the base class method
   MyBase.OnRowUpdating event
End Sub
' create the method for the schema changing
Public Sub OnSchemaChanging(event As SchemaChangingEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is changing ..."
   '  call the base class method
   MyBase.OnSchemaChanging event
End Sub
' create the method for the schema changed
Public Sub OnSchemaChanged(event As SchemaChangedEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema has changed"
   '  call the base class method
   MyBase.OnSchemaChanged event
End Sub
' create the method for the schema being mapped
Public Sub OnSchemaMapping(event As SchemaMappingEventArgs)
   ' show a message box telling the user of schema map
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is currently being mapped ..."
   ' call the base class method
   MyBase.OnSchemaMapping event
End Sub

See Also

DataSetCommand Class | DataSetCommand Members | System.Data.Internal Namespace | OnSchemaChanging


DataSetCommand.Update

Changes the data in the data source to match the data in the DataSet.

[Visual Basic]
Overridable Public Function Update( _
   ByVal dataSet As DataSet _
) As Integer
[C#]
public virtual int Update(
   DataSet dataSet
);
[C++]
public: virtual int Update(
   DataSet* dataSet
);
[JScript]
public function Update(
   dataSet : DataSet
) : int;

Parameters

dataSet
The DataSet to update the data source with.

Remarks

TableMappings are required to be mapped for this method to operate. The default source table is named "Table".

When using Update, there are two events that occur per data row updated. The order of execution is as follows:

1) The values in the DataRow are moved to the parameter values.

2) The OnRowUpdating event is raised.

3) The command executes.

4) If the command is set to FirstReturnedRecord, then the first returned result is placed in the DataRow

5) If there are output parameters, they are placed in the DataRow

6) The OnRowUpdated event is raised.

7) AcceptChanges is called.

Notes to Inheritors: When overriding Update in a derived class, be sure to call the base class's Update method.

See Also

DataSetCommand Class | DataSetCommand Members | System.Data.Internal Namespace


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataSetCommand Events

The events of the DataSetCommand class are listed below. For a complete list of DataSetCommand class members, see the DataSetCommand Members topic.

Public:

SchemaChanged | Occurs during Update after a command is executed against the data source when the schema may be potentially different due to a property change.
SchemaChanging | Occurs during Update before a command is executed against the data source when the schema may be potentially different due to a property change.

See Also

DataSetCommand Class | System.Data.Internal Namespace


DataSetCommand SchemaChanged Event

Occurs during Update after a command is executed against the data source when the schema may be potentially different due to a property change.

The following declaration shows the syntax for a method that handles the SchemaChanged event.

[Visual Basic]
Private Sub DataSetCommandName_SchemaChanged( _
   ByVal sender As Object, _
   ByVal e As SchemaChangedEventArgs _
)
[C#]
private void DataSetCommandName_SchemaChanged(
   object sender,
   SchemaChangedEventArgs e
);
[C++]
private: void DataSetCommandName_SchemaChanged(
   Object* sender,
   SchemaChangedEventArgs* e
);
[JScript]
private DataSetCommandName_SchemaChanged(
   sender : Object,
   e : SchemaChangedEventArgs
);

Parameters

sender
The source of the event.
e
A SchemaChangedEventArgs that contains the event data. The following SchemaChangedEventArgs properties provide information specific to this event.
Property Description
SchemaType
[To be supplied.]
Source
[To be supplied.]

See Also

DataSetCommand Class | DataSetCommand MembersTopic | System.Data.Internal Namespace


DataSetCommand SchemaChanging Event

Occurs during Update before a command is executed against the data source when the schema may be potentially different due to a property change.

The following declaration shows the syntax for a method that handles the SchemaChanging event.

[Visual Basic]
Private Sub DataSetCommandName_SchemaChanging( _
   ByVal sender As Object, _
   ByVal e As SchemaChangingEventArgs _
)
[C#]
private void DataSetCommandName_SchemaChanging(
   object sender,
   SchemaChangingEventArgs e
);
[C++]
private: void DataSetCommandName_SchemaChanging(
   Object* sender,
   SchemaChangingEventArgs* e
);
[JScript]
private DataSetCommandName_SchemaChanging(
   sender : Object,
   e : SchemaChangingEventArgs
);

Parameters

sender
The source of the event.
e
A SchemaChangingEventArgs that contains the event data. The following SchemaChangingEventArgs properties provide information specific to this event.
Property Description
SchemaType
[To be supplied.]
Source
[To be supplied.]

See Also

DataSetCommand Class | DataSetCommand MembersTopic | System.Data.Internal Namespace


DataStorage Class

[To be supplied.]

Object
DataStorage

[Visual Basic]
MustInherit Public Class DataStorage
[C#]
public abstract class DataStorage
[C++]
public __gc __abstract class DataStorage
[JScript]
public abstract class DataStorage

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

DataStorage Members | System.Data.Internal Namespace


DataStorage Members

Public:

Constructor

DataStorage Constructor [To be supplied.]

Properties

DataType | [To be supplied.]
DefaultValue | [To be supplied.]
Table | [To be supplied.]

Methods

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
CreateStorage | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

ClearBits | [To be supplied.]
CompareBits | [To be supplied.]
CopyBits | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits | [To be supplied.]

See Also

DataStorage Class | System.Data.Internal Namespace


DataStorage Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal type As Type _
)
[C#]
public DataStorage(
   Type type
);
[C++]
public: DataStorage(
   Type* type
);
[JScript]
public function DataStorage(
   type : Type
);

Parameters

type
[To be supplied.]

See Also

DataStorage Class | DataStorage Members | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataStorage Properties

The properties of the DataStorage class are listed below. For a complete list of DataStorage class members, see the DataStorage Members topic.

Public:

DataType | [To be supplied.]
DefaultValue | [To be supplied.]
Table | [To be supplied.]

See Also

DataStorage Class | System.Data.Internal Namespace


DataStorage.DataType

[To be supplied.]

[Visual Basic]
Public ReadOnly Property DataType As Type
[C#]
public Type DataType {get;}
[C++]
public: __property Type* get_DataType();
[JScript]
public function get DataType() : Type;

See Also

DataStorage Class | DataStorage Members | System.Data.Internal Namespace


DataStorage.DefaultValue

[To be supplied.]

[Visual Basic]
MustOverride Public ReadOnly Property DefaultValue As Object
[C#]
public object DefaultValue {abstract get;}
[C++]
public: __property virtual Object* get_DefaultValue() = 0;
[JScript]
public abstract function get DefaultValue() : Object;

See Also

DataStorage Class | DataStorage Members | System.Data.Internal Namespace


DataStorage.Table

[To be supplied.]

[Visual Basic]
Public Property Table As DataTable
[C#]
public DataTable Table {get; set;}
[C++]
public: __property DataTable* get_Table();
public: __property void set_Table(DataTable*);
[JScript]
public function get Table() : DataTable;
public function set Table(DataTable);

See Also

DataStorage Class | DataStorage Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataStorage Methods

The methods of the DataStorage class are listed below. For a complete list of DataStorage class members, see the DataStorage Members topic.

Public:

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
CreateStorage | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

ClearBits | [To be supplied.]
CompareBits | [To be supplied.]
CopyBits | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits | [To be supplied.]

See Also

DataStorage Class | System.Data.Internal Namespace


DataStorage.Aggregate

[To be supplied.]

[Visual Basic]
Overridable Public Function Aggregate( _
   ByVal recordNos() As Integer, _
   ByVal kind As AggregateTypes _
) As Object
[C#]
public virtual object Aggregate(
   int[] recordNos,
   AggregateTypes kind
);
[C++]
public: virtual Object* Aggregate(
   int* recordNos[],
   AggregateTypes kind
);
[JScript]
public function Aggregate(
   recordNos : int[],
   kind : AggregateTypes
) : Object;

Parameters

recordNos
[To be supplied.]
kind
[To be supplied.]

See Also

DataStorage Class | DataStorage Members | System.Data.Internal Namespace


DataStorage.ClearBits

[To be supplied.]

[Visual Basic]
Protected Sub ClearBits( _
   ByVal recordNo As Integer _
)
[C#]
protected void ClearBits(
   int recordNo
);
[C++]
protected: void ClearBits(
   int recordNo
);
[JScript]
protected function ClearBits(
   recordNo : int
);

Parameters

recordNo
[To be supplied.]

See Also

DataStorage Class | DataStorage Members | System.Data.Internal Namespace


DataStorage.Compare

[To be supplied.]

[Visual Basic]
Overridable Public Function Compare( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
) As Integer
[C#]
public virtual int Compare(
   int recordNo1,
   int recordNo2
);
[C++]
public: virtual int Compare(
   int recordNo1,
   int recordNo2
);
[JScript]
public function Compare(
   recordNo1 : int,
   recordNo2 : int
) : int;

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

DataStorage Class | DataStorage Members | System.Data.Internal Namespace


DataStorage.CompareBits

[To be supplied.]

[Visual Basic]
Protected Function CompareBits( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
) As Integer
[C#]
protected int CompareBits(
   int recordNo1,
   int recordNo2
);
[C++]
protected: int CompareBits(
   int recordNo1,
   int recordNo2
);
[JScript]
protected function CompareBits(
   recordNo1 : int,
   recordNo2 : int
) : int;

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

DataStorage Class | DataStorage Members | System.Data.Internal Namespace


DataStorage.CompareToValue

[To be supplied.]

[Visual Basic]
Overridable Public Function CompareToValue( _
   ByVal recordNo1 As Integer, _
   ByVal value As Object _
) As Integer
[C#]
public virtual int CompareToValue(
   int recordNo1,
   object value
);
[C++]
public: virtual int CompareToValue(
   int recordNo1,
   Object* value
);
[JScript]
public function CompareToValue(
   recordNo1 : int,
   value : Object
) : int;

Parameters

recordNo1
[To be supplied.]
value
[To be supplied.]

See Also

DataStorage Class | DataStorage Members | System.Data.Internal Namespace


DataStorage.Copy

[To be supplied.]

[Visual Basic]
Overridable Public Sub Copy( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
)
[C#]
public virtual void Copy(
   int recordNo1,
   int recordNo2
);
[C++]
public: virtual void Copy(
   int recordNo1,
   int recordNo2
);
[JScript]
public function Copy(
   recordNo1 : int,
   recordNo2 : int
);

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

DataStorage Class | DataStorage Members | System.Data.Internal Namespace


DataStorage.CopyBits

[To be supplied.]

[Visual Basic]
Protected Sub CopyBits( _
   ByVal srcRecordNo As Integer, _
   ByVal dstRecordNo As Integer _
)
[C#]
protected void CopyBits(
   int srcRecordNo,
   int dstRecordNo
);
[C++]
protected: void CopyBits(
   int srcRecordNo,
   int dstRecordNo
);
[JScript]
protected function CopyBits(
   srcRecordNo : int,
   dstRecordNo : int
);

Parameters

srcRecordNo
[To be supplied.]
dstRecordNo
[To be supplied.]

See Also

DataStorage Class | DataStorage Members | System.Data.Internal Namespace


DataStorage.CreateStorage

[To be supplied.]

[Visual Basic]
Public Shared Function CreateStorage( _
   ByVal dataType As Type _
) As DataStorage
[C#]
public static DataStorage CreateStorage(
   Type dataType
);
[C++]
public: static DataStorage* CreateStorage(
   Type* dataType
);
[JScript]
public static function CreateStorage(
   dataType : Type
) : DataStorage;

Parameters

dataType
[To be supplied.]

See Also

DataStorage Class | DataStorage Members | System.Data.Internal Namespace


DataStorage.Get

[To be supplied.]

[Visual Basic]
MustOverride Public Function Get( _
   ByVal recordNo As Integer _
) As Object
[C#]
public abstract object Get(
   int recordNo
);
[C++]
public: virtual Object* Get(
   int recordNo
) = 0;
[JScript]
public abstract function Get(
   recordNo : int
) : Object;

Parameters

recordNo
[To be supplied.]

See Also

DataStorage Class | DataStorage Members | System.Data.Internal Namespace


DataStorage.GetBits

[To be supplied.]

[Visual Basic]
Protected Function GetBits( _
   ByVal recordNo As Integer _
) As Object
[C#]
protected object GetBits(
   int recordNo
);
[C++]
protected: Object* GetBits(
   int recordNo
);
[JScript]
protected function GetBits(
   recordNo : int
) : Object;

Parameters

recordNo
[To be supplied.]

See Also

DataStorage Class | DataStorage Members | System.Data.Internal Namespace


DataStorage.IsNull

[To be supplied.]

[Visual Basic]
Public Function IsNull( _
   ByVal recordNo As Integer _
) As Boolean
[C#]
public bool IsNull(
   int recordNo
);
[C++]
public: bool IsNull(
   int recordNo
);
[JScript]
public function IsNull(
   recordNo : int
) : Boolean;

Parameters

recordNo
[To be supplied.]

See Also

DataStorage Class | DataStorage Members | System.Data.Internal Namespace


DataStorage.Set

[To be supplied.]

[Visual Basic]
MustOverride Public Sub Set( _
   ByVal recordNo As Integer, _
   ByVal value As Object _
)
[C#]
public abstract void Set(
   int recordNo,
   object value
);
[C++]
public: virtual void Set(
   int recordNo,
   Object* value
) = 0;
[JScript]
public abstract function Set(
   recordNo : int,
   value : Object
);

Parameters

recordNo
[To be supplied.]
value
[To be supplied.]

See Also

DataStorage Class | DataStorage Members | System.Data.Internal Namespace


DataStorage.SetBits

[To be supplied.]

[Visual Basic]
Protected Function SetBits( _
   ByVal recordNo As Integer, _
   ByVal value As Object _
) As Boolean
[C#]
protected bool SetBits(
   int recordNo,
   object value
);
[C++]
protected: bool SetBits(
   int recordNo,
   Object* value
);
[JScript]
protected function SetBits(
   recordNo : int,
   value : Object
) : Boolean;

Parameters

recordNo
[To be supplied.]
value
[To be supplied.]

See Also

DataStorage Class | DataStorage Members | System.Data.Internal Namespace


DataStorage.SetCapacity

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetCapacity( _
   ByVal capacity As Integer _
)
[C#]
public virtual void SetCapacity(
   int capacity
);
[C++]
public: virtual void SetCapacity(
   int capacity
);
[JScript]
public function SetCapacity(
   capacity : int
);

Parameters

capacity
[To be supplied.]

See Also

DataStorage Class | DataStorage Members | System.Data.Internal Namespace


DataStorage.SetNull

[To be supplied.]

[Visual Basic]
Public Sub SetNull( _
   ByVal recordNo As Integer _
)
[C#]
public void SetNull(
   int recordNo
);
[C++]
public: void SetNull(
   int recordNo
);
[JScript]
public function SetNull(
   recordNo : int
);

Parameters

recordNo
[To be supplied.]

See Also

DataStorage Class | DataStorage Members | System.Data.Internal Namespace


DataStorage.ShiftByOffset

[To be supplied.]

[Visual Basic]
MustOverride Public Sub ShiftByOffset( _
   ByVal index As Integer, _
   ByVal length As Integer, _
   ByVal offset As Integer _
)
[C#]
public abstract void ShiftByOffset(
   int index,
   int length,
   int offset
);
[C++]
public: virtual void ShiftByOffset(
   int index,
   int length,
   int offset
) = 0;
[JScript]
public abstract function ShiftByOffset(
   index : int,
   length : int,
   offset : int
);

Parameters

index
[To be supplied.]
length
[To be supplied.]
offset
[To be supplied.]

See Also

DataStorage Class | DataStorage Members | System.Data.Internal Namespace


DataTableMapping Class

[To be supplied.]

Object
DataTableMapping

[Visual Basic]
NotInheritable Public Class DataTableMapping
   Implements ITableMapping, ICloneable
[C#]
public sealed class DataTableMapping : ITableMapping, ICloneable
[C++]
public __gc __sealed class DataTableMapping : public ITableMapping,
   ICloneable
[JScript]
public class DataTableMapping implements ITableMapping, ICloneable

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

DataTableMapping Members | System.Data.Internal Namespace


DataTableMapping Members

Public:

Constructor

DataTableMapping Constructor Overloaded. [To be supplied.]

Properties

ColumnMappings | [To be supplied.]
DataSetTable | Case-Insensitive
Parent | [get] the parent TableMapping collection
SourceTable | [get] SourceTable name

Methods

Clone | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDataTableBySchemaAction | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataTableMapping Class | System.Data.Internal Namespace


DataTableMapping Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public DataTableMapping();
[C++] public: DataTableMapping();
[JScript] public function DataTableMapping();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, String)
[C#] public DataTableMapping(String, String);
[C++] public: DataTableMapping(String*, String*);
[JScript] public function DataTableMapping(String, String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, String, DataColumnMapping())
[C#] public DataTableMapping(String, String, DataColumnMapping[]);
[C++] public: DataTableMapping(String*, String*, DataColumnMapping[]);
[JScript] public function DataTableMapping(String, String, DataColumnMapping[]);

See Also

DataTableMapping Class | DataTableMapping Members | System.Data.Internal Namespace


DataTableMapping Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public DataTableMapping();
[C++]
public: DataTableMapping();
[JScript]
public function DataTableMapping();

See Also

DataTableMapping Class | DataTableMapping Members | System.Data.Internal Namespace | DataTableMapping Constructor Overload List


DataTableMapping Constructor (String, String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal sourceTable As String, _
   ByVal dataSetTable As String _
)
[C#]
public DataTableMapping(
   string sourceTable,
   string dataSetTable
);
[C++]
public: DataTableMapping(
   String* sourceTable,
   String* dataSetTable
);
[JScript]
public function DataTableMapping(
   sourceTable : String,
   dataSetTable : String
);

Parameters

sourceTable
[To be supplied.]
dataSetTable
[To be supplied.]

See Also

DataTableMapping Class | DataTableMapping Members | System.Data.Internal Namespace | DataTableMapping Constructor Overload List


DataTableMapping Constructor (String, String, DataColumnMapping[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal sourceTable As String, _
   ByVal dataSetTable As String, _
   ByVal columnMappings() As DataColumnMapping _
)
[C#]
public DataTableMapping(
   string sourceTable,
   string dataSetTable,
   DataColumnMapping[] columnMappings
);
[C++]
public: DataTableMapping(
   String* sourceTable,
   String* dataSetTable,
   DataColumnMapping* columnMappings[]
);
[JScript]
public function DataTableMapping(
   sourceTable : String,
   dataSetTable : String,
   columnMappings : DataColumnMapping[]
);

Parameters

sourceTable
[To be supplied.]
dataSetTable
[To be supplied.]
columnMappings
[To be supplied.]

See Also

DataTableMapping Class | DataTableMapping Members | System.Data.Internal Namespace | DataTableMapping Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataTableMapping Properties

The properties of the DataTableMapping class are listed below. For a complete list of DataTableMapping class members, see the DataTableMapping Members topic.

Public:

ColumnMappings | [To be supplied.]
DataSetTable | Case-Insensitive
Parent | [get] the parent TableMapping collection
SourceTable | [get] SourceTable name

See Also

DataTableMapping Class | System.Data.Internal Namespace


DataTableMapping.ColumnMappings

[To be supplied.]

[Visual Basic]
Public ReadOnly Property ColumnMappings As DataColumnMappings
[C#]
public DataColumnMappings ColumnMappings {get;}
[C++]
public: __property DataColumnMappings* get_ColumnMappings();
[JScript]
public function get ColumnMappings() : DataColumnMappings;

See Also

DataTableMapping Class | DataTableMapping Members | System.Data.Internal Namespace


DataTableMapping.DataSetTable

Case-Insensitive

[Visual Basic]
Public Property DataSetTable As String
[C#]
public string DataSetTable {get; set;}
[C++]
public: __property String* get_DataSetTable();
public: __property void set_DataSetTable(String*);
[JScript]
public function get DataSetTable() : String;
public function set DataSetTable(String);

See Also

DataTableMapping Class | DataTableMapping Members | System.Data.Internal Namespace


DataTableMapping.Parent

[get] the parent TableMapping collection

[Visual Basic]
Public ReadOnly Property Parent As DataTableMappings
[C#]
public DataTableMappings Parent {get;}
[C++]
public: __property DataTableMappings* get_Parent();
[JScript]
public function get Parent() : DataTableMappings;

Property Value

get the parent TableMapping collection

See Also

DataTableMapping Class | DataTableMapping Members | System.Data.Internal Namespace


DataTableMapping.SourceTable

[get] SourceTable name

[Visual Basic]
Public Property SourceTable As String
[C#]
public string SourceTable {get; set;}
[C++]
public: __property String* get_SourceTable();
public: __property void set_SourceTable(String*);
[JScript]
public function get SourceTable() : String;
public function set SourceTable(String);

Exceptions

Exception Type | Condition
ArgumentException | non-unique SourceTable name

See Also

DataTableMapping Class | DataTableMapping Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataTableMapping Methods

The methods of the DataTableMapping class are listed below. For a complete list of DataTableMapping class members, see the DataTableMapping Members topic.

Public:

Clone | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDataTableBySchemaAction | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataTableMapping Class | System.Data.Internal Namespace


DataTableMapping.Clone

[To be supplied.]

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

See Also

DataTableMapping Class | DataTableMapping Members | System.Data.Internal Namespace


DataTableMapping.GetDataTableBySchemaAction

[To be supplied.]

[Visual Basic]
Public Function GetDataTableBySchemaAction( _
   ByVal dataSet As DataSet, _
   ByVal schemaAction As MissingSchemaAction _
) As DataTable
[C#]
public DataTable GetDataTableBySchemaAction(
   DataSet dataSet,
   MissingSchemaAction schemaAction
);
[C++]
public: DataTable* GetDataTableBySchemaAction(
   DataSet* dataSet,
   MissingSchemaAction schemaAction
);
[JScript]
public function GetDataTableBySchemaAction(
   dataSet : DataSet,
   schemaAction : MissingSchemaAction
) : DataTable;

Parameters

dataSet
[To be supplied.]
schemaAction
[To be supplied.]

See Also

DataTableMapping Class | DataTableMapping Members | System.Data.Internal Namespace


DataTableMapping.ToString

[To be supplied.]

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

DataTableMapping Class | DataTableMapping Members | System.Data.Internal Namespace


DataTableMappingConverter Class

[To be supplied.]

Object
TypeConverter
DataTableMappingConverter

[Visual Basic]
NotInheritable Public Class DataTableMappingConverter
   Inherits TypeConverter
[C#]
public sealed class DataTableMappingConverter : TypeConverter
[C++]
public __gc __sealed class DataTableMappingConverter : public
   TypeConverter
[JScript]
public class DataTableMappingConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

DataTableMappingConverter Members | System.Data.Internal Namespace


DataTableMappingConverter Members

Public:

Constructor

DataTableMappingConverter Constructor [To be supplied.]

Methods

CanConvertFrom (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the converter's native type.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text into an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given object to another type.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetProperties (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValues (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid (inherited from TypeConverter) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

DataTableMappingConverter Class | System.Data.Internal Namespace


DataTableMappingConverter Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public DataTableMappingConverter();
[C++]
public: DataTableMappingConverter();
[JScript]
public function DataTableMappingConverter();

See Also

DataTableMappingConverter Class | DataTableMappingConverter Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataTableMappingConverter Methods

The methods of the DataTableMappingConverter class are listed below. For a complete list of DataTableMappingConverter class members, see the DataTableMappingConverter Members topic.

Public:

CanConvertFrom (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the converter's native type.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text into an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given object to another type.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetProperties (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValues (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid (inherited from TypeConverter) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

DataTableMappingConverter Class | System.Data.Internal Namespace


DataTableMappingConverter.GetPersistInfo

[To be supplied.]

[Visual Basic]
Overrides Public Function GetPersistInfo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal obj As Object _
) As PersistInfo
[C#]
public override PersistInfo GetPersistInfo(
   ITypeDescriptorContext context,
   object obj
);
[C++]
public: override PersistInfo* GetPersistInfo(
   ITypeDescriptorContext* context,
   Object* obj
);
[JScript]
public override function GetPersistInfo(
   context : ITypeDescriptorContext,
   obj : Object
) : PersistInfo;

Parameters

context
[To be supplied.]
obj
[To be supplied.]

See Also

DataTableMappingConverter Class | DataTableMappingConverter Members | System.Data.Internal Namespace


DataTableMappingConverter.GetProperties

Retrieves the set of properties for this type. By default, a type has does not return any properties. An easy implementation of this method can just call TypeDescriptor.GetProperties for the correct data type.

[Visual Basic]
Overrides Public Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal attributes() As MemberAttribute _
) As PropertyDescriptorCollection
[C#]
public override PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value,
   MemberAttribute[] attributes
);
[C++]
public: override PropertyDescriptorCollection* GetProperties(
   ITypeDescriptorContext* context,
   Object* value,
   MemberAttribute* attributes[]
);
[JScript]
public override function GetProperties(
   context : ITypeDescriptorContext,
   value : Object,
   attributes : MemberAttribute[]
) : PropertyDescriptorCollection;

Parameters

context
A type descriptor through which additional context may be provided.
value
The value of the object to get the properties for.
attributes
[To be supplied.]

Return Value

The set of properties that should be exposed for this data type. If no properties should be exposed, thsi may return null. The default implementation always returns null.

See Also

DataTableMappingConverter Class | DataTableMappingConverter Members | System.Data.Internal Namespace


DataTableMappingConverter.GetPropertiesSupported

Determines if this object supports properties. By default, this is false.

[Visual Basic]
Overrides Public Function GetPropertiesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
[C#]
public override bool GetPropertiesSupported(
   ITypeDescriptorContext context
);
[C++]
public: override bool GetPropertiesSupported(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetPropertiesSupported(
   context : ITypeDescriptorContext
) : Boolean;

Parameters

context
A type descriptor through which additional context may be provided.

Return Value

Returns true if GetProperties should be called to find the properties of this object.

See Also

DataTableMappingConverter Class | DataTableMappingConverter Members | System.Data.Internal Namespace


DataTableMappings Class

table mapping collection

Object
DataTableMappings

[Visual Basic]
NotInheritable Public Class DataTableMappings
   Implements ITableMappings, IList, ICollection, IEnumerable
[C#]
public sealed class DataTableMappings : ITableMappings, IList,
   ICollection, IEnumerable
[C++]
public __gc __sealed class DataTableMappings : public
   ITableMappings, IList, ICollection, IEnumerable
[JScript]
public class DataTableMappings implements ITableMappings, IList,
   ICollection, IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

DataTableMappings Members | System.Data.Internal Namespace


DataTableMappings Members

Public:

Constructor

DataTableMappings Constructor [To be supplied.]

Properties

All | [To be supplied.]
Count | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the DataTableMappings class.
Parent | [To be supplied.]

Methods

Add | Overloaded. [To be supplied.]
Clear | remove all the items from the collection
Contains | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetByDataSetTable | [To be supplied.]
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetTableMappingBySchemaAction | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | Overloaded. [To be supplied.]
IndexOfDataSetTable | [To be supplied.]
Remove | [To be supplied.]
RemoveAt | Overloaded. [To be supplied.]
ShouldPersistAll | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataTableMappings Class | System.Data.Internal Namespace


DataTableMappings Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public DataTableMappings();
[C++]
public: DataTableMappings();
[JScript]
public function DataTableMappings();

See Also

DataTableMappings Class | DataTableMappings Members | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataTableMappings Properties

The properties of the DataTableMappings class are listed below. For a complete list of DataTableMappings class members, see the DataTableMappings Members topic.

Public:

All | [To be supplied.]
Count | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the DataTableMappings class.
Parent | [To be supplied.]

See Also

DataTableMappings Class | System.Data.Internal Namespace


DataTableMappings.All

[To be supplied.]

[Visual Basic]
Public Property All As DataTableMapping ()
[C#]
public DataTableMapping[] All {get; set;}
[C++]
public: __property DataTableMapping* get_All();
public: __property void set_All(DataTableMapping*[]);
[JScript]
public function get All() : DataTableMapping[];
public function set All(DataTableMapping[]);

See Also

DataTableMappings Class | DataTableMappings Members | System.Data.Internal Namespace


DataTableMappings.Count

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

See Also

DataTableMappings Class | DataTableMappings Members | System.Data.Internal Namespace


DataTableMappings.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the DataTableMappings class.

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Default Property Item(Integer) As DataTableMapping
[C#] public DataTableMapping this[int] {get; set;}
[C++] public: __property DataTableMapping* get_Item(int);
public: __property void set_Item(int, DataTableMapping*);
[JScript] DataTableMappings.Item (int)

[To be supplied.]

[Visual Basic] Overloads Public Default Property Item(String) As DataTableMapping
[C#] public DataTableMapping this[String] {get; set;}
[C++] public: __property DataTableMapping* get_Item(String*);
public: __property void set_Item(String*, DataTableMapping*);
[JScript] DataTableMappings.Item (String)

See Also

DataTableMappings Class | DataTableMappings Members | System.Data.Internal Namespace


DataTableMappings.Item (Int32)

[To be supplied.]

[C#] In C#, this member is the indexer for the DataTableMappings class.

[Visual Basic]
Overloads Public Default Property Item( _
   ByVal index As Integer _
) As DataTableMapping
[C#]
public DataTableMapping this[
   int index
] {get; set;}
[C++]
public: __property DataTableMapping* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   DataTableMapping*
);
[JScript]
returnValue = DataTableMappingsObject.Item(index);
DataTableMappingsObject.Item(index) = returnValue;
-or-
returnValue = DataTableMappingsObject(index);
DataTableMappingsObject(index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
[To be supplied.]

Parameters [Visual Basic, C#, C++]

index
[To be supplied.]

See Also

DataTableMappings Class | DataTableMappings Members | System.Data.Internal Namespace | DataTableMappings.Item Overload List


DataTableMappings.Item (String)

[To be supplied.]

[C#] In C#, this member is the indexer for the DataTableMappings class.

[Visual Basic]
Overloads Public Default Property Item( _
   ByVal sourceTable As String _
) As DataTableMapping
[C#]
public DataTableMapping this[
   string sourceTable
] {get; set;}
[C++]
public: __property DataTableMapping* get_Item(
   String* sourceTable
);
public: __property void set_Item(
   String* sourceTable,
   DataTableMapping*
);
[JScript]
returnValue = DataTableMappingsObject.Item(sourceTable);
DataTableMappingsObject.Item(sourceTable) = returnValue;
-or-
returnValue = DataTableMappingsObject(sourceTable);
DataTableMappingsObject(sourceTable) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

sourceTable
Case-Sensitive

Parameters [Visual Basic, C#, C++]

sourceTable
Case-Sensitive

See Also

DataTableMappings Class | DataTableMappings Members | System.Data.Internal Namespace | DataTableMappings.Item Overload List


DataTableMappings.Parent

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Parent As DataSetCommand
[C#]
public DataSetCommand Parent {get;}
[C++]
public: __property DataSetCommand* get_Parent();
[JScript]
public function get Parent() : DataSetCommand;

See Also

DataTableMappings Class | DataTableMappings Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataTableMappings Methods

The methods of the DataTableMappings class are listed below. For a complete list of DataTableMappings class members, see the DataTableMappings Members topic.

Public:

Add | Overloaded. [To be supplied.]
Clear | remove all the items from the collection
Contains | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetByDataSetTable | [To be supplied.]
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetTableMappingBySchemaAction | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | Overloaded. [To be supplied.]
IndexOfDataSetTable | [To be supplied.]
Remove | [To be supplied.]
RemoveAt | Overloaded. [To be supplied.]
ShouldPersistAll | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataTableMappings Class | System.Data.Internal Namespace


DataTableMappings.Add

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function Add(String, String) As DataTableMapping
[C#] public DataTableMapping Add(String, String);
[C++] public: DataTableMapping* Add(String*, String*);
[JScript] public function Add(String, String) : DataTableMapping;

[To be supplied.]

[Visual Basic] Overloads Public Function Add(Object) As Integer
[C#] public int Add(Object);
[C++] public: int Add(Object*);
[JScript] public function Add(Object) : int;

See Also

DataTableMappings Class | DataTableMappings Members | System.Data.Internal Namespace


DataTableMappings.Add (String, String)

[To be supplied.]

[Visual Basic]
Overloads Public Function Add( _
   ByVal sourceTable As String, _
   ByVal dataSetTable As String _
) As DataTableMapping
[C#]
public DataTableMapping Add(
   string sourceTable,
   string dataSetTable
);
[C++]
public: DataTableMapping* Add(
   String* sourceTable,
   String* dataSetTable
);
[JScript]
public function Add(
   sourceTable : String,
   dataSetTable : String
) : DataTableMapping;

Parameters

sourceTable
Case-Sensitive
dataSetTable
Case-Insensitive

See Also

DataTableMappings Class | DataTableMappings Members | System.Data.Internal Namespace | DataTableMappings.Add Overload List


DataTableMappings.Add (Object)

[To be supplied.]

[Visual Basic]
Overloads Public Function Add( _
   ByVal value As Object _
) As Integer
[C#]
public int Add(
   object value
);
[C++]
public: int Add(
   Object* value
);
[JScript]
public function Add(
   value : Object
) : int;

Parameters

value
[To be supplied.]

See Also

DataTableMappings Class | DataTableMappings Members | System.Data.Internal Namespace | DataTableMappings.Add Overload List


DataTableMappings.Clear

remove all the items from the collection

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[JScript]
public function Clear();

See Also

DataTableMappings Class | DataTableMappings Members | System.Data.Internal Namespace


DataTableMappings.Contains

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function Contains(Object) As Boolean
[C#] public bool Contains(Object);
[C++] public: bool Contains(Object*);
[JScript] public function Contains(Object) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function Contains(String) As Boolean
[C#] public bool Contains(String);
[C++] public: bool Contains(String*);
[JScript] public function Contains(String) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function Contains(Integer) As Boolean
[C#] public bool Contains(int);
[C++] public: bool Contains(int);
[JScript] public function Contains(int) : Boolean;

See Also

DataTableMappings Class | DataTableMappings Members | System.Data.Internal Namespace


DataTableMappings.Contains (Object)

[To be supplied.]

[Visual Basic]
Overloads Public Function Contains( _
   ByVal value As Object _
) As Boolean
[C#]
public bool Contains(
   object value
);
[C++]
public: bool Contains(
   Object* value
);
[JScript]
public function Contains(
   value : Object
) : Boolean;

Parameters

value
[To be supplied.]

See Also

DataTableMappings Class | DataTableMappings Members | System.Data.Internal Namespace | DataTableMappings.Contains Overload List


DataTableMappings.Contains (String)

[To be supplied.]

[Visual Basic]
Overloads Public Function Contains( _
   ByVal value As String _
) As Boolean
[C#]
public bool Contains(
   string value
);
[C++]
public: bool Contains(
   String* value
);
[JScript]
public function Contains(
   value : String
) : Boolean;

Parameters

value
Case-Sensitive SourceTable

See Also

DataTableMappings Class | DataTableMappings Members | System.Data.Internal Namespace | DataTableMappings.Contains Overload List


DataTableMappings.Contains (Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Function Contains( _
   ByVal index As Integer _
) As Boolean
[C#]
public bool Contains(
   int index
);
[C++]
public: bool Contains(
   int index
);
[JScript]
public function Contains(
   index : int
) : Boolean;

Parameters

index
[To be supplied.]

See Also

DataTableMappings Class | DataTableMappings Members | System.Data.Internal Namespace | DataTableMappings.Contains Overload List


DataTableMappings.GetByDataSetTable

[To be supplied.]

[Visual Basic]
Public Function GetByDataSetTable( _
   ByVal dataSetTable As String _
) As DataTableMapping
[C#]
public DataTableMapping GetByDataSetTable(
   string dataSetTable
);
[C++]
public: DataTableMapping* GetByDataSetTable(
   String* dataSetTable
);
[JScript]
public function GetByDataSetTable(
   dataSetTable : String
) : DataTableMapping;

Parameters

dataSetTable
[To be supplied.]

See Also

DataTableMappings Class | DataTableMappings Members | System.Data.Internal Namespace


DataTableMappings.GetEnumerator

[To be supplied.]

[Visual Basic]
Overridable Public Function GetEnumerator() As IEnumerator
[C#]
public virtual IEnumerator GetEnumerator();
[C++]
public: virtual IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

See Also

DataTableMappings Class | DataTableMappings Members | System.Data.Internal Namespace


DataTableMappings.GetTableMappingBySchemaAction

[To be supplied.]

[Visual Basic]
Public Function GetTableMappingBySchemaAction( _
   ByVal sourceTable As String, _
   ByVal dataSetTable As String, _
   ByVal mappingAction As MissingMappingAction _
) As DataTableMapping
[C#]
public DataTableMapping GetTableMappingBySchemaAction(
   string sourceTable,
   string dataSetTable,
   MissingMappingAction mappingAction
);
[C++]
public: DataTableMapping* GetTableMappingBySchemaAction(
   String* sourceTable,
   String* dataSetTable,
   MissingMappingAction mappingAction
);
[JScript]
public function GetTableMappingBySchemaAction(
   sourceTable : String,
   dataSetTable : String,
   mappingAction : MissingMappingAction
) : DataTableMapping;

Parameters

sourceTable
which SourceTable to match
dataSetTable
if SourceTable doesn't exist and MissingAction is Passthrough and DataSet is not null then SourceTable append with an increasing number, i.e. Table, Table1, Table2, Table3 is used until a unique table name is found in the dataset for the DataSetTable name if null then the SourceTable name is used as is
mappingAction
the mapping action to apply if the SourceTable isn't found in the collection .Passthrough: create a new TableMapping, see param term 'DataSet' .Ignore: return null .Error: throw an exception

See Also

DataTableMappings Class | DataTableMappings Members | System.Data.Internal Namespace


DataTableMappings.IndexOf

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function IndexOf(Object) As Integer
[C#] public int IndexOf(Object);
[C++] public: int IndexOf(Object*);
[JScript] public function IndexOf(Object) : int;

[To be supplied.]

[Visual Basic] Overloads Public Function IndexOf(String) As Integer
[C#] public int IndexOf(String);
[C++] public: int IndexOf(String*);
[JScript] public function IndexOf(String) : int;

See Also

DataTableMappings Class | DataTableMappings Members | System.Data.Internal Namespace


DataTableMappings.IndexOf (Object)

[To be supplied.]

[Visual Basic]
Overloads Public Function IndexOf( _
   ByVal value As Object _
) As Integer
[C#]
public int IndexOf(
   object value
);
[C++]
public: int IndexOf(
   Object* value
);
[JScript]
public function IndexOf(
   value : Object
) : int;

Parameters

value
[To be supplied.]

See Also

DataTableMappings Class | DataTableMappings Members | System.Data.Internal Namespace | DataTableMappings.IndexOf Overload List


DataTableMappings.IndexOf (String)

[To be supplied.]

[Visual Basic]
Overloads Public Function IndexOf( _
   ByVal sourceTable As String _
) As Integer
[C#]
public int IndexOf(
   string sourceTable
);
[C++]
public: int IndexOf(
   String* sourceTable
);
[JScript]
public function IndexOf(
   sourceTable : String
) : int;

Parameters

sourceTable
[To be supplied.]

See Also

DataTableMappings Class | DataTableMappings Members | System.Data.Internal Namespace | DataTableMappings.IndexOf Overload List


DataTableMappings.IndexOfDataSetTable

[To be supplied.]

[Visual Basic]
Public Function IndexOfDataSetTable( _
   ByVal dataSetTable As String _
) As Integer
[C#]
public int IndexOfDataSetTable(
   string dataSetTable
);
[C++]
public: int IndexOfDataSetTable(
   String* dataSetTable
);
[JScript]
public function IndexOfDataSetTable(
   dataSetTable : String
) : int;

Parameters

dataSetTable
[To be supplied.]

See Also

DataTableMappings Class | DataTableMappings Members | System.Data.Internal Namespace


DataTableMappings.Remove

[To be supplied.]

[Visual Basic]
Public Sub Remove( _
   ByVal value As Object _
)
[C#]
public void Remove(
   object value
);
[C++]
public: void Remove(
   Object* value
);
[JScript]
public function Remove(
   value : Object
);

Parameters

value
[To be supplied.]

See Also

DataTableMappings Class | DataTableMappings Members | System.Data.Internal Namespace


DataTableMappings.RemoveAt

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub RemoveAt(String)
[C#] public void RemoveAt(String);
[C++] public: void RemoveAt(String*);
[JScript] public function RemoveAt(String);

[To be supplied.]

[Visual Basic] Overloads Public Sub RemoveAt(Integer)
[C#] public void RemoveAt(int);
[C++] public: void RemoveAt(int);
[JScript] public function RemoveAt(int);

See Also

DataTableMappings Class | DataTableMappings Members | System.Data.Internal Namespace


DataTableMappings.RemoveAt (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub RemoveAt( _
   ByVal sourceTable As String _
)
[C#]
public void RemoveAt(
   string sourceTable
);
[C++]
public: void RemoveAt(
   String* sourceTable
);
[JScript]
public function RemoveAt(
   sourceTable : String
);

Parameters

sourceTable
Case-Sensitive

See Also

DataTableMappings Class | DataTableMappings Members | System.Data.Internal Namespace | DataTableMappings.RemoveAt Overload List


DataTableMappings.RemoveAt (Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub RemoveAt( _
   ByVal index As Integer _
)
[C#]
public void RemoveAt(
   int index
);
[C++]
public: void RemoveAt(
   int index
);
[JScript]
public function RemoveAt(
   index : int
);

Parameters

index
0-based

See Also

DataTableMappings Class | DataTableMappings Members | System.Data.Internal Namespace | DataTableMappings.RemoveAt Overload List


DataTableMappings.ShouldPersistAll

[To be supplied.]

[Visual Basic]
Public Function ShouldPersistAll() As Boolean
[C#]
public bool ShouldPersistAll();
[C++]
public: bool ShouldPersistAll();
[JScript]
public function ShouldPersistAll() : Boolean;

See Also

DataTableMappings Class | DataTableMappings Members | System.Data.Internal Namespace


DateTimeStorage Class

[To be supplied.]

Object
DataStorage
DateTimeStorage

[Visual Basic]
Public Class DateTimeStorage
   Inherits DataStorage
[C#]
public class DateTimeStorage : DataStorage
[C++]
public __gc class DateTimeStorage : public DataStorage
[JScript]
public class DateTimeStorage extends DataStorage

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

DateTimeStorage Members | System.Data.Internal Namespace


DateTimeStorage Members

Public:

Constructor

DateTimeStorage Constructor [To be supplied.]

Properties

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

Methods

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

DateTimeStorage Class | System.Data.Internal Namespace


DateTimeStorage Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public DateTimeStorage();
[C++]
public: DateTimeStorage();
[JScript]
public function DateTimeStorage();

See Also

DateTimeStorage Class | DateTimeStorage Members | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DateTimeStorage Properties

The properties of the DateTimeStorage class are listed below. For a complete list of DateTimeStorage class members, see the DateTimeStorage Members topic.

Public:

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

See Also

DateTimeStorage Class | System.Data.Internal Namespace


DateTimeStorage.DefaultValue

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DefaultValue As Object
[C#]
public object DefaultValue {override get;}
[C++]
public: __property virtual Object* get_DefaultValue();
[JScript]
public function get DefaultValue() : Object;

See Also

DateTimeStorage Class | DateTimeStorage Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DateTimeStorage Methods

The methods of the DateTimeStorage class are listed below. For a complete list of DateTimeStorage class members, see the DateTimeStorage Members topic.

Public:

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

DateTimeStorage Class | System.Data.Internal Namespace


DateTimeStorage.Aggregate

[To be supplied.]

[Visual Basic]
Overrides Public Function Aggregate( _
   ByVal records() As Integer, _
   ByVal kind As AggregateTypes _
) As Object
[C#]
public override object Aggregate(
   int[] records,
   AggregateTypes kind
);
[C++]
public: override Object* Aggregate(
   int* records[],
   AggregateTypes kind
);
[JScript]
public override function Aggregate(
   records : int[],
   kind : AggregateTypes
) : Object;

Parameters

records
[To be supplied.]
kind
[To be supplied.]

See Also

DateTimeStorage Class | DateTimeStorage Members | System.Data.Internal Namespace


DateTimeStorage.Compare

[To be supplied.]

[Visual Basic]
Overrides Public Function Compare( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
) As Integer
[C#]
public override int Compare(
   int recordNo1,
   int recordNo2
);
[C++]
public: override int Compare(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Compare(
   recordNo1 : int,
   recordNo2 : int
) : int;

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

DateTimeStorage Class | DateTimeStorage Members | System.Data.Internal Namespace


DateTimeStorage.CompareToValue

[To be supplied.]

[Visual Basic]
Overrides Public Function CompareToValue( _
   ByVal recordNo As Integer, _
   ByVal value As Object _
) As Integer
[C#]
public override int CompareToValue(
   int recordNo,
   object value
);
[C++]
public: override int CompareToValue(
   int recordNo,
   Object* value
);
[JScript]
public override function CompareToValue(
   recordNo : int,
   value : Object
) : int;

Parameters

recordNo
[To be supplied.]
value
[To be supplied.]

See Also

DateTimeStorage Class | DateTimeStorage Members | System.Data.Internal Namespace


DateTimeStorage.Copy

[To be supplied.]

[Visual Basic]
Overrides Public Sub Copy( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
)
[C#]
public override void Copy(
   int recordNo1,
   int recordNo2
);
[C++]
public: override void Copy(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Copy(
   recordNo1 : int,
   recordNo2 : int
);

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

DateTimeStorage Class | DateTimeStorage Members | System.Data.Internal Namespace


DateTimeStorage.Get

[To be supplied.]

[Visual Basic]
Overrides Public Function Get( _
   ByVal record As Integer _
) As Object
[C#]
public override object Get(
   int record
);
[C++]
public: override Object* Get(
   int record
);
[JScript]
public override function Get(
   record : int
) : Object;

Parameters

record
[To be supplied.]

See Also

DateTimeStorage Class | DateTimeStorage Members | System.Data.Internal Namespace


DateTimeStorage.Set

[To be supplied.]

[Visual Basic]
Overrides Public Sub Set( _
   ByVal record As Integer, _
   ByVal value As Object _
)
[C#]
public override void Set(
   int record,
   object value
);
[C++]
public: override void Set(
   int record,
   Object* value
);
[JScript]
public override function Set(
   record : int,
   value : Object
);

Parameters

record
[To be supplied.]
value
[To be supplied.]

See Also

DateTimeStorage Class | DateTimeStorage Members | System.Data.Internal Namespace


DateTimeStorage.SetCapacity

[To be supplied.]

[Visual Basic]
Overrides Public Sub SetCapacity( _
   ByVal capacity As Integer _
)
[C#]
public override void SetCapacity(
   int capacity
);
[C++]
public: override void SetCapacity(
   int capacity
);
[JScript]
public override function SetCapacity(
   capacity : int
);

Parameters

capacity
[To be supplied.]

See Also

DateTimeStorage Class | DateTimeStorage Members | System.Data.Internal Namespace


DateTimeStorage.ShiftByOffset

[To be supplied.]

[Visual Basic]
Overrides Public Sub ShiftByOffset( _
   ByVal index As Integer, _
   ByVal length As Integer, _
   ByVal offset As Integer _
)
[C#]
public override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[C++]
public: override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[JScript]
public override function ShiftByOffset(
   index : int,
   length : int,
   offset : int
);

Parameters

index
[To be supplied.]
length
[To be supplied.]
offset
[To be supplied.]

See Also

DateTimeStorage Class | DateTimeStorage Members | System.Data.Internal Namespace


DBCommand Class

Represents a query command used when connecting to a data source.

Object
DBCommand

[Visual Basic]
MustInherit Public Class DBCommand
   Implements ICloneable
[C#]
public abstract class DBCommand : ICloneable
[C++]
public __gc __abstract class DBCommand : public ICloneable
[JScript]
public abstract class DBCommand implements ICloneable

Remarks

When an instance of DBCommand is created, the read/write properties are set to initial values. For a list of these values, see the DBCommand constructor.

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

Example [C#]

The following example uses the derived classes ADOCommand and SQLCommand to select records from an Access data source and insert them in a SQL Server data source. This example can be modified to migrate an Access database to a SQL Server database.

[C#]

private DataSet InitializeMyDataSet() {
   // creates the table and its columns for the DataSet
   DataSet newData = new DataSet();
   DataTable newTable = newData.Tables.Add("Catagories");

   // add Columns to table
   newTable.Columns.Add("CategoryID",typeof(Int32));
   newTable.Columns.Add("CategoryName", typeof(String));
   newTable.Columns.Add("Description", typeof(String));
   newTable.Columns.Add("Picture",typeof(Byte[]));
   return newData;
}

public void AccessToSQLServer() {
   // set Access connection and select strings
   const string strAccessConn = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=NWIND_RW.MDB";
   const string strAccessSelect = "SELECT * FROM Categories ORDER BY CategoryID";
   // set SQL Server connection and insert strings
   const string strSQLServerConn = "Data Source=VBsql7;Initial Catalog=Northwind;User ID=sa;Password=;";
   const string strSQLServerInsert = "INSERT INTO Categories(CategoryName, Description, Picture) Values(@CategoryName,@Description,@Picture)";
   // create my DataSet
   DataSet myDataSet = InitializeMyDataSet();
   // create my Access objects
   ADOConnection myAccessConn = new ADOConnection(strAccessConn);
   ADODataSetCommand myAccessDataSetCmd = new ADODataSetCommand();
   myAccessDataSetCmd.SelectCommand = new ADOCommand(strAccessSelect,myAccessConn);
   // create my SQL Server objects
   SQLConnection mySQLConn = new SQLConnection(strSQLServerConn);
   SQLDataSetCommand mySQLDataSetCmd = new SQLDataSetCommand();
   mySQLDataSetCmd.InsertCommand = new SQLCommand(strSQLServerInsert,mySQLConn);
   // fill myDataSet with data from Access
   myAccessConn.Open();
   try {
      myAccessDataSetCmd.FillDataSet(myDataSet,"table");
   }
   finally {
      myAccessConn.Close();
   }

   // do ugly work to turn original rows into new rows

   // update SQL Server with data from the DataSet
   mySQLConn.Open();
   try {
      mySQLDataSetCmd.InsertCommand.Parameters.Add("CategoryName", typeof(String));
      mySQLDataSetCmd.InsertCommand.Parameters.Add("Description", typeof(String));
      mySQLDataSetCmd.InsertCommand.Parameters.Add("Picture", typeof(Byte[]));
      mySQLDataSetCmd.InsertCommand.Parameters[0].SourceColumn = "CategoryName";
      mySQLDataSetCmd.InsertCommand.Parameters[1].SourceColumn = "Description";
      mySQLDataSetCmd.InsertCommand.Parameters[2].SourceColumn = "Picture";
      mySQLDataSetCmd.Update(myDataSet,"table");
   }
   finally {
      mySQLConn.Close();
   }
}

See Also

DBCommand Members | System.Data.Internal Namespace | DBDataSetCommand | DBConnection | ADOCommand | SQLCommand


DBCommand Members

Public:

Constructor

DBCommand Constructor [To be supplied.]

Properties

CommandBehavior | Gets or sets the behavior the DBCommand is to exhibit when executed.
CommandText | Gets or sets the text command to run against the data source.
CommandType | Gets or sets how the CommandText property is to be interpreted.
UpdatedRowSource | Gets or sets how command results are to be applied to the current DataRow, when used by the Update method of a DBDataSetCommand.

Methods

Clone | When overridden in a derived class, creates a clone of this instance of DBCommand.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Execute | Overloaded. Executes the command against the data source.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ResetParameters | When overridden in a derived class, resets the parameters within the parameters collection.
ShouldPersist | When overridden in a derived class, returns whether the settings of the properties should be persisted.
ToString (inherited from Object) | Returns a String that represents the current Object.

Events

SchemaChanged | Occurs when the DataSet schema has been changed to match the schema change of the data source.
SchemaChanging | Occurs when the DataSet schema is to be changed to match the schema change of the data source.

Protected:

Methods

CreateNewSchemaChangedEvent | [To be supplied.]
CreateNewSchemaChangingEvent | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetActiveConnectionObject | [To be supplied.]
GetParametersObject | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnSchemaChanged | Overloaded. [To be supplied.]
OnSchemaChanging | Overloaded. [To be supplied.]
SetActiveConnectionObject | [To be supplied.]

Fields

cmdText | The default string to be used by the CommandText when the DBCommand is initialized.
cmdType | The default CommandType to be used by CommandType property when the DBCommand is initialized.
DefaultCommandTimeout | The default timeout value to be used when the DBCommand is initialized.

Event Hookup:

Methods

AddOnSchemaChanged | [To be supplied.]
AddOnSchemaChanging | [To be supplied.]

See Also

DBCommand Class | System.Data.Internal Namespace


DBCommand Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public DBCommand();
[C++]
public: DBCommand();
[JScript]
public function DBCommand();

See Also

DBCommand Class | DBCommand Members | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DBCommand Properties

The properties of the DBCommand class are listed below. For a complete list of DBCommand class members, see the DBCommand Members topic.

Public:

CommandBehavior | Gets or sets the behavior the DBCommand is to exhibit when executed.
CommandText | Gets or sets the text command to run against the data source.
CommandType | Gets or sets how the CommandText property is to be interpreted.
UpdatedRowSource | Gets or sets how command results are to be applied to the current DataRow, when used by the Update method of a DBDataSetCommand.

See Also

DBCommand Class | System.Data.Internal Namespace


DBCommand.CommandBehavior

Gets or sets the behavior the DBCommand is to exhibit when executed.

[Visual Basic]
MustOverride Public Property CommandBehavior As DBCommandBehavior
[C#]
public DBCommandBehavior CommandBehavior {abstract get; abstract
   set;}
[C++]
public: __property virtual DBCommandBehavior get_CommandBehavior() = 0;public: __property virtual void set_CommandBehavior(DBCommandBehavior) = 0;
[JScript]
public abstract function get CommandBehavior() : DBCommandBehavior;
public abstract function set CommandBehavior(DBCommandBehavior);

Property Value

One of the DBCommandBehavior values. The default is 0.

See Also

DBCommand Class | DBCommand Members | System.Data.Internal Namespace


DBCommand.CommandText

Gets or sets the text command to run against the data source.

[Visual Basic]
Overridable Public Property CommandText As String
[C#]
public string CommandText {virtual get; virtual set;}
[C++]
public: __property virtual String* get_CommandText();
public: __property virtual void set_CommandText(String*);
[JScript]
public function get CommandText() : String;
public function set CommandText(String);

Property Value

The text command to execute. The default value is the empty string ("").

Remarks

If the string being assigned is not the current string, a OnSchemaChanging event will be raised and the new value set. After, a OnSchemaChanged event will be raised.

Example

The following example creates an DBCommand and sets some of its properties.

See Also

DBCommand Class | DBCommand Members | System.Data.Internal Namespace | CommandType | UpdatedRowSource


DBCommand.CommandType

Gets or sets how the CommandText property is to be interpreted.

[Visual Basic]
Overridable Public Property CommandType As CommandType
[C#]
public CommandType CommandType {virtual get; virtual set;}
[C++]
public: __property virtual CommandType get_CommandType();
public: __property virtual void set_CommandType(CommandType);
[JScript]
public function get CommandType() : CommandType;
public function set CommandType(CommandType);

Property Value

One of the CommandType values. The default is Text.

Exceptions

Exception Type | Condition
InvalidCommandType | The value was not one of the CommandType values.

See Also

DBCommand Class | DBCommand Members | System.Data.Internal Namespace | CommandText | UpdatedRowSource


DBCommand.UpdatedRowSource

Gets or sets how command results are to be applied to the current DataRow, when used by the Update method of a DBDataSetCommand.

[Visual Basic]
Overridable Public Property UpdatedRowSource As UpdateRowSource
[C#]
public UpdateRowSource UpdatedRowSource {virtual get; virtual set;}
[C++]
public: __property virtual UpdateRowSource get_UpdatedRowSource();
public: __property virtual void set_UpdatedRowSource(UpdateRowSource);
[JScript]
public function get UpdatedRowSource() : UpdateRowSource;
public function set UpdatedRowSource(UpdateRowSource);

Property Value

One of the UpdateRowSource values. The default is Both.

Exceptions

Exception Type | Condition
InvalidUpdateRowSource | The value entered was not one of the UpdateRowSource values.

See Also

DBCommand Class | DBCommand Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DBCommand Methods

The methods of the DBCommand class are listed below. For a complete list of DBCommand class members, see the DBCommand Members topic.

Public:

Clone | When overridden in a derived class, creates a clone of this instance of DBCommand.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Execute | Overloaded. Executes the command against the data source.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ResetParameters | When overridden in a derived class, resets the parameters within the parameters collection.
ShouldPersist | When overridden in a derived class, returns whether the settings of the properties should be persisted.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

CreateNewSchemaChangedEvent | [To be supplied.]
CreateNewSchemaChangingEvent | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetActiveConnectionObject | [To be supplied.]
GetParametersObject | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnSchemaChanged | Overloaded. [To be supplied.]
OnSchemaChanging | Overloaded. [To be supplied.]
SetActiveConnectionObject | [To be supplied.]

Event Hookup:

AddOnSchemaChanged | [To be supplied.]
AddOnSchemaChanging | [To be supplied.]

See Also

DBCommand Class | System.Data.Internal Namespace


DBCommand.AddOnSchemaChanged

[To be supplied.]

[Visual Basic]
Overridable Public Sub AddOnSchemaChanged( _
   ByVal handler As SchemaChangedEventHandler _
)
[C#]
public virtual void AddOnSchemaChanged(
   SchemaChangedEventHandler handler
);
[C++]
public: virtual void AddOnSchemaChanged(
   SchemaChangedEventHandler* handler
);
[JScript]
public function AddOnSchemaChanged(
   handler : SchemaChangedEventHandler
);

Parameters

handler
[To be supplied.]

See Also

DBCommand Class | DBCommand Members | System.Data.Internal Namespace


DBCommand.AddOnSchemaChanging

[To be supplied.]

[Visual Basic]
Overridable Public Sub AddOnSchemaChanging( _
   ByVal handler As SchemaChangingEventHandler _
)
[C#]
public virtual void AddOnSchemaChanging(
   SchemaChangingEventHandler handler
);
[C++]
public: virtual void AddOnSchemaChanging(
   SchemaChangingEventHandler* handler
);
[JScript]
public function AddOnSchemaChanging(
   handler : SchemaChangingEventHandler
);

Parameters

handler
[To be supplied.]

See Also

DBCommand Class | DBCommand Members | System.Data.Internal Namespace


DBCommand.Clone

When overridden in a derived class, creates a clone of this instance of DBCommand.

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

Remarks

The System.Data.Internal.DBCommand.ActiveConnection, the System.Data.Internal.DBCommand.CommandTimeout, and the System.Data.Internal.DBCommand.Properties collection are shared, not cloned.

Notes to Inheritors: When overriding Clone in a derived class, be sure to call the base class's Clone method.

See Also

DBCommand Class | DBCommand Members | System.Data.Internal Namespace


DBCommand.CreateNewSchemaChangedEvent

[To be supplied.]

[Visual Basic]
Overridable Protected Function CreateNewSchemaChangedEvent( _
   ByVal schemaType As SchemaType, _
   ByVal src As Object _
) As SchemaChangedEventArgs
[C#]
protected virtual SchemaChangedEventArgs CreateNewSchemaChangedEvent(
   SchemaType schemaType,
   object src
);
[C++]
protected: virtual SchemaChangedEventArgs* CreateNewSchemaChangedEvent(
   SchemaType schemaType,
   Object* src
);
[JScript]
protected function CreateNewSchemaChangedEvent(
   schemaType : SchemaType,
   src : Object
) : SchemaChangedEventArgs;

Parameters

schemaType
[To be supplied.]
src
[To be supplied.]

See Also

DBCommand Class | DBCommand Members | System.Data.Internal Namespace


DBCommand.CreateNewSchemaChangingEvent

[To be supplied.]

[Visual Basic]
Overridable Protected Function CreateNewSchemaChangingEvent( _
   ByVal schemaType As SchemaType, _
   ByVal src As Object _
) As SchemaChangingEventArgs
[C#]
protected virtual SchemaChangingEventArgs CreateNewSchemaChangingEvent(
   SchemaType schemaType,
   object src
);
[C++]
protected: virtual SchemaChangingEventArgs* CreateNewSchemaChangingEvent(
   SchemaType schemaType,
   Object* src
);
[JScript]
protected function CreateNewSchemaChangingEvent(
   schemaType : SchemaType,
   src : Object
) : SchemaChangingEventArgs;

Parameters

schemaType
[To be supplied.]
src
[To be supplied.]

See Also

DBCommand Class | DBCommand Members | System.Data.Internal Namespace


DBCommand.Execute

Executes the command against the data source.

Overload List

When overridden in a derived class, executes the command against the data source.

[Visual Basic] Overloads MustOverride Public Sub Execute(IDataReader)
[C#] public abstract void Execute(IDataReader);
[C++] public: virtual void Execute(IDataReader*) = 0;
[JScript] public abstract function Execute(IDataReader);

Executes the command against the data source. This is the default method.

[Visual Basic] Overloads Overridable Public Function Execute() As Integer
[C#] public virtual int Execute();
[C++] public: virtual int Execute();
[JScript] public function Execute() : int;

See Also

DBCommand Class | DBCommand Members | System.Data.Internal Namespace


DBCommand.Execute (IDataReader)

When overridden in a derived class, executes the command against the data source.

[Visual Basic]
Overloads MustOverride Public Sub Execute( _
   ByRef dataReader As IDataReader _
)
[C#]
public abstract void Execute(
   ref IDataReader dataReader
);
[C++]
public: virtual void Execute(
   IDataReader** dataReader
) = 0;
[JScript]
public abstract function Execute(
   dataReader : IDataReader
);

Parameters

dataReader
The IDataReader to execute against the data source.

Remarks

Notes to Inheritors: When overridden Execute in a derived class, executes the command against the data source.

See Also

DBCommand Class | DBCommand Members | System.Data.Internal Namespace | DBCommand.Execute Overload List


DBCommand.Execute ()

Executes the command against the data source. This is the default method.

[Visual Basic]
Overloads Overridable Public Function Execute() As Integer
[C#]
public virtual int Execute();
[C++]
public: virtual int Execute();
[JScript]
public function Execute() : int;

Exceptions

Exception Type | Condition
ExecuteRequiresConnection | The connection does not exist.
ExecuteRequiresOpenConnection | The connection is not open.

Remarks

Notes to Inheritors: When overriding Execute in a derived class, be sure to call the base class's Execute method.

See Also

DBCommand Class | DBCommand Members | System.Data.Internal Namespace | DBCommand.Execute Overload List


DBCommand.GetActiveConnectionObject

[To be supplied.]

[Visual Basic]
MustOverride Protected Function GetActiveConnectionObject() As _
   DBConnection
[C#]
protected abstract DBConnection GetActiveConnectionObject();
[C++]
protected: virtual DBConnection* GetActiveConnectionObject() = 0;
[JScript]
protected abstract function GetActiveConnectionObject() :
   DBConnection;

See Also

DBCommand Class | DBCommand Members | System.Data.Internal Namespace


DBCommand.GetParametersObject

[To be supplied.]

[Visual Basic]
MustOverride Protected Function GetParametersObject() As _
   IDataParameters
[C#]
protected abstract IDataParameters GetParametersObject();
[C++]
protected: virtual IDataParameters* GetParametersObject() = 0;
[JScript]
protected abstract function GetParametersObject() : IDataParameters;

See Also

DBCommand Class | DBCommand Members | System.Data.Internal Namespace


DBCommand.OnSchemaChanged

[To be supplied.]

Overload List

Raises the SchemaChanged event.

[Visual Basic] Overloads Protected Sub OnSchemaChanged()
[C#] protected void OnSchemaChanged();
[C++] protected: void OnSchemaChanged();
[JScript] protected function OnSchemaChanged();

Raises the OnSchemaChanged event.

[Visual Basic] Overloads Overridable Protected Sub OnSchemaChanged(SchemaChangedEventArgs)
[C#] protected virtual void OnSchemaChanged(SchemaChangedEventArgs);
[C++] protected: virtual void OnSchemaChanged(SchemaChangedEventArgs*);
[JScript] protected function OnSchemaChanged(SchemaChangedEventArgs);

Example

The following example uses this method within a derived class.

See Also

DBCommand Class | DBCommand Members | System.Data.Internal Namespace


DBCommand.OnSchemaChanged ()

Raises the SchemaChanged event.

[Visual Basic]
Overloads Protected Sub OnSchemaChanged()
[C#]
protected void OnSchemaChanged();
[C++]
protected: void OnSchemaChanged();
[JScript]
protected function OnSchemaChanged();

See Also

DBCommand Class | DBCommand Members | System.Data.Internal Namespace | DBCommand.OnSchemaChanged Overload List


DBCommand.OnSchemaChanged (SchemaChangedEventArgs)

Raises the OnSchemaChanged event.

[Visual Basic]
Overloads Overridable Protected Sub OnSchemaChanged( _
   ByVal scevent As SchemaChangedEventArgs _
)
[C#]
protected virtual void OnSchemaChanged(
   SchemaChangedEventArgs scevent
);
[C++]
protected: virtual void OnSchemaChanged(
   SchemaChangedEventArgs* scevent
);
[JScript]
protected function OnSchemaChanged(
   scevent : SchemaChangedEventArgs
);

Parameters

scevent
A SchemaChangedEventArgs event that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see TBD.

Notes to Inheritors: When overriding OnSchemaChanged in a derived class, be sure to call the base class's OnSchemaChanged method.

Example

The following example uses this method within a derived class.

See Also

DBCommand Class | DBCommand Members | System.Data.Internal Namespace | DBCommand.OnSchemaChanged Overload List


DBCommand.OnSchemaChanging

[To be supplied.]

Overload List

Raises the SchemaChanging event.

[Visual Basic] Overloads Protected Sub OnSchemaChanging()
[C#] protected void OnSchemaChanging();
[C++] protected: void OnSchemaChanging();
[JScript] protected function OnSchemaChanging();

An implicit listener resets the command parameters for SchemaType.Source events when in design mode

[Visual Basic] Overloads Overridable Protected Sub OnSchemaChanging(SchemaChangingEventArgs)
[C#] protected virtual void OnSchemaChanging(SchemaChangingEventArgs);
[C++] protected: virtual void OnSchemaChanging(SchemaChangingEventArgs*);
[JScript] protected function OnSchemaChanging(SchemaChangingEventArgs);

See Also

DBCommand Class | DBCommand Members | System.Data.Internal Namespace


DBCommand.OnSchemaChanging ()

Raises the SchemaChanging event.

[Visual Basic]
Overloads Protected Sub OnSchemaChanging()
[C#]
protected void OnSchemaChanging();
[C++]
protected: void OnSchemaChanging();
[JScript]
protected function OnSchemaChanging();

See Also

DBCommand Class | DBCommand Members | System.Data.Internal Namespace | DBCommand.OnSchemaChanging Overload List


DBCommand.OnSchemaChanging (SchemaChangingEventArgs)

An implicit listener resets the command parameters for SchemaType.Source events when in design mode

[Visual Basic]
Overloads Overridable Protected Sub OnSchemaChanging( _
   ByVal scevent As SchemaChangingEventArgs _
)
[C#]
protected virtual void OnSchemaChanging(
   SchemaChangingEventArgs scevent
);
[C++]
protected: virtual void OnSchemaChanging(
   SchemaChangingEventArgs* scevent
);
[JScript]
protected function OnSchemaChanging(
   scevent : SchemaChangingEventArgs
);

Parameters

scevent
[To be supplied.]

See Also

DBCommand Class | DBCommand Members | System.Data.Internal Namespace | DBCommand.OnSchemaChanging Overload List


DBCommand.ResetParameters

When overridden in a derived class, resets the parameters within the parameters collection.

[Visual Basic]
Overridable Public Sub ResetParameters()
[C#]
public virtual void ResetParameters();
[C++]
public: virtual void ResetParameters();
[JScript]
public function ResetParameters();

Remarks

Notes to Inheritors: When overriding ResetParameters in a derived class, be sure to call the base class's ResetParameters method.

See Also

DBCommand Class | DBCommand Members | System.Data.Internal Namespace


DBCommand.SetActiveConnectionObject

[To be supplied.]

[Visual Basic]
MustOverride Protected Sub SetActiveConnectionObject( _
   ByVal value As DBConnection _
)
[C#]
protected abstract void SetActiveConnectionObject(
   DBConnection value
);
[C++]
protected: virtual void SetActiveConnectionObject(
   DBConnection* value
) = 0;
[JScript]
protected abstract function SetActiveConnectionObject(
   value : DBConnection
);

Parameters

value
[To be supplied.]

See Also

DBCommand Class | DBCommand Members | System.Data.Internal Namespace


DBCommand.ShouldPersist

When overridden in a derived class, returns whether the settings of the properties should be persisted.

[Visual Basic]
Overridable Public Function ShouldPersist() As Boolean
[C#]
public virtual bool ShouldPersist();
[C++]
public: virtual bool ShouldPersist();
[JScript]
public function ShouldPersist() : Boolean;

Remarks

Notes to Inheritors: When overriding ShouldPersist in a derived class, be sure to call the base class's ShouldPersist method.

See Also

DBCommand Class | DBCommand Members | System.Data.Internal Namespace


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DBCommand Events

The events of the DBCommand class are listed below. For a complete list of DBCommand class members, see the DBCommand Members topic.

Public:

SchemaChanged | Occurs when the DataSet schema has been changed to match the schema change of the data source.
SchemaChanging | Occurs when the DataSet schema is to be changed to match the schema change of the data source.

See Also

DBCommand Class | System.Data.Internal Namespace


DBCommand SchemaChanged Event

Occurs when the DataSet schema has been changed to match the schema change of the data source.

The following declaration shows the syntax for a method that handles the SchemaChanged event.

[Visual Basic]
Private Sub DBCommandName_SchemaChanged( _
   ByVal sender As Object, _
   ByVal e As SchemaChangedEventArgs _
)
[C#]
private void DBCommandName_SchemaChanged(
   object sender,
   SchemaChangedEventArgs e
);
[C++]
private: void DBCommandName_SchemaChanged(
   Object* sender,
   SchemaChangedEventArgs* e
);
[JScript]
private DBCommandName_SchemaChanged(
   sender : Object,
   e : SchemaChangedEventArgs
);

Parameters

sender
The source of the event.
e
A SchemaChangedEventArgs that contains the event data. The following SchemaChangedEventArgs properties provide information specific to this event.
Property Description
SchemaType
[To be supplied.]
Source
[To be supplied.]

See Also

DBCommand Class | DBCommand MembersTopic | System.Data.Internal Namespace


DBCommand SchemaChanging Event

Occurs when the DataSet schema is to be changed to match the schema change of the data source.

The following declaration shows the syntax for a method that handles the SchemaChanging event.

[Visual Basic]
Private Sub DBCommandName_SchemaChanging( _
   ByVal sender As Object, _
   ByVal e As SchemaChangingEventArgs _
)
[C#]
private void DBCommandName_SchemaChanging(
   object sender,
   SchemaChangingEventArgs e
);
[C++]
private: void DBCommandName_SchemaChanging(
   Object* sender,
   SchemaChangingEventArgs* e
);
[JScript]
private DBCommandName_SchemaChanging(
   sender : Object,
   e : SchemaChangingEventArgs
);

Parameters

sender
The source of the event.
e
A SchemaChangingEventArgs that contains the event data. The following SchemaChangingEventArgs properties provide information specific to this event.
Property Description
SchemaType
[To be supplied.]
Source
[To be supplied.]

See Also

DBCommand Class | DBCommand MembersTopic | System.Data.Internal Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DBCommand Fields

The fields of the DBCommand class are listed below. For a complete list of DBCommand class members, see the DBCommand Members topic.

Protected:

cmdText | The default string to be used by the CommandText when the DBCommand is initialized.
cmdType | The default CommandType to be used by CommandType property when the DBCommand is initialized.
DefaultCommandTimeout | The default timeout value to be used when the DBCommand is initialized.

See Also

DBCommand Class | System.Data.Internal Namespace


DBCommand.cmdText

The default string to be used by the CommandText when the DBCommand is initialized.

[Visual Basic]
Protected cmdText As String
[C#]
protected string cmdText;
[C++]
protected: String* cmdText;
[JScript]
protected var cmdText : String;

See Also

DBCommand Class | DBCommand Members | System.Data.Internal Namespace


DBCommand.cmdType

The default CommandType to be used by CommandType property when the DBCommand is initialized.

[Visual Basic]
Protected cmdType As CommandType
[C#]
protected CommandType cmdType;
[C++]
protected: CommandType cmdType;
[JScript]
protected var cmdType : CommandType;

See Also

DBCommand Class | DBCommand Members | System.Data.Internal Namespace


DBCommand.DefaultCommandTimeout

The default timeout value to be used when the DBCommand is initialized.

[Visual Basic]
Protected Const DefaultCommandTimeout As Integer
[C#]
protected const int DefaultCommandTimeout;
[C++]
protected: const int DefaultCommandTimeout;
[JScript]
protected var DefaultCommandTimeout : int;

See Also

DBCommand Class | DBCommand Members | System.Data.Internal Namespace


DBConnection Class

Represents a database connection for use by DBCommand.

Object
Component
DBConnection

[Visual Basic]
MustInherit Public Class DBConnection
   Inherits Component
   Implements ICloneable
[C#]
public abstract class DBConnection : Component, ICloneable
[C++]
public __gc __abstract class DBConnection : public Component,
   ICloneable
[JScript]
public abstract class DBConnection extends Component, ICloneable

Remarks

An DBConnection object represents a unique session with a data source. In the case of a client/server database system, it may be equivalent to a network connection to the server. Depending on the functionality supported by the provider, some collections, methods, or properties of an DBConnection object may not be available.

When an instance of DBConnection is created, the read/write properties are set to initial values. For a list of these values, see the DBConnection constructor.

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

Example [C#]

The following example uses the derived classes ADOConnection and SQLConnection to select records from an Access data source and insert them in a SQL Server data source. This example can be modified to migrate an Access database to a SQL Server database.

[C#]

private DataSet InitializeMyDataSet() {
   // creates the table and its columns for the DataSet
   DataSet newData = new DataSet();
   DataTable newTable = newData.Tables.Add("Catagories");

   // add Columns to table
   newTable.Columns.Add("CategoryID",typeof(Int32));
   newTable.Columns.Add("CategoryName", typeof(String));
   newTable.Columns.Add("Description", typeof(String));
   newTable.Columns.Add("Picture",typeof(Byte[]));
   return newData;
}

public void AccessToSQLServer() {
   // set Access connection and select strings
   const string strAccessConn = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=NWIND_RW.MDB";
   const string strAccessSelect = "SELECT * FROM Categories ORDER BY CategoryID";
   // set SQL Server connection and insert strings
   const string strSQLServerConn = "Data Source=VBsql7;Initial Catalog=Northwind;User ID=sa;Password=;";
   const string strSQLServerInsert = "INSERT INTO Categories(CategoryName, Description, Picture) Values(@CategoryName,@Description,@Picture)";
   // create my DataSet
   DataSet myDataSet = InitializeMyDataSet();
   // create my Access objects
   ADOConnection myAccessConn = new ADOConnection(strAccessConn);
   ADODataSetCommand myAccessDataSetCmd = new ADODataSetCommand();
   myAccessDataSetCmd.SelectCommand = new ADOCommand(strAccessSelect,myAccessConn);
   // create my SQL Server objects
   SQLConnection mySQLConn = new SQLConnection(strSQLServerConn);
   SQLDataSetCommand mySQLDataSetCmd = new SQLDataSetCommand();
   mySQLDataSetCmd.InsertCommand = new SQLCommand(strSQLServerInsert,mySQLConn);
   // fill myDataSet with data from Access
   myAccessConn.Open();
   try {
      myAccessDataSetCmd.FillDataSet(myDataSet,"table");
   }
   finally {
      myAccessConn.Close();
   }

   // do ugly work to turn original rows into new rows

   // update SQL Server with data from the DataSet
   mySQLConn.Open();
   try {
      mySQLDataSetCmd.InsertCommand.Parameters.Add("CategoryName", typeof(String));
      mySQLDataSetCmd.InsertCommand.Parameters.Add("Description", typeof(String));
      mySQLDataSetCmd.InsertCommand.Parameters.Add("Picture", typeof(Byte[]));
      mySQLDataSetCmd.InsertCommand.Parameters[0].SourceColumn = "CategoryName";
      mySQLDataSetCmd.InsertCommand.Parameters[1].SourceColumn = "Description";
      mySQLDataSetCmd.InsertCommand.Parameters[2].SourceColumn = "Picture";
      mySQLDataSetCmd.Update(myDataSet,"table");
   }
   finally {
      mySQLConn.Close();
   }
}

See Also

DBConnection Members | System.Data.Internal Namespace


DBConnection Members

Public:

Constructor

DBConnection Constructor [To be supplied.]

Properties

ConnectionString | Gets or sets the string used to open a data store.
Site (inherited from Component) | Gets or sets the site of the Component.
State | Gets the current state of the connection.

Methods

BeginTransaction | Begins a database transaction.
Clone | Creates a new instance of the object initialized with the current connection string.
Close | Closes the connection to the database.
CommitTransaction | Commits the database transaction.
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Open | Opens a connection to the database.
RollbackTransaction | Rolls back the database transaction.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Events

StateChange Occurs whenever the state of the connection changes.

Protected:

Methods

CreateNewStateChangeEvent | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStateChange | Raises the StateChangeEventArgs event.
OpenDesignMode | [To be supplied.]
SetObjectState | Sets the State to one of the DBObjectState values.

Fields

DefaultConnectionTimeout The default timeout value to use when attempting to connect to the data source.

Event Hookup:

Methods

AddOnStateChange Use to add a connection state change event handler.

See Also

DBConnection Class | System.Data.Internal Namespace


DBConnection Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public DBConnection();
[C++]
public: DBConnection();
[JScript]
public function DBConnection();

See Also

DBConnection Class | DBConnection Members | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DBConnection Properties

The properties of the DBConnection class are listed below. For a complete list of DBConnection class members, see the DBConnection Members topic.

Public:

ConnectionString | Gets or sets the string used to open a data store.
Site (inherited from Component) | Gets or sets the site of the Component.
State | Gets the current state of the connection.

See Also

DBConnection Class | System.Data.Internal Namespace


DBConnection.ConnectionString

Gets or sets the string used to open a data store.

[Visual Basic]
Overridable Public Property ConnectionString As String
[C#]
public string ConnectionString {virtual get; virtual set;}
[C++]
public: __property virtual String* get_ConnectionString();
public: __property virtual void set_ConnectionString(String*);
[JScript]
public function get ConnectionString() : String;
public function set ConnectionString(String);

Remarks

The string can only be set when the connection state is closed.

See Also

DBConnection Class | DBConnection Members | System.Data.Internal Namespace


DBConnection.State

Gets the current state of the connection.

[Visual Basic]
Overridable Public ReadOnly Property State As DBObjectState
[C#]
public DBObjectState State {virtual get;}
[C++]
public: __property virtual DBObjectState get_State();
[JScript]
public function get State() : DBObjectState;

Property Value

One of the DBObjectState values.

Remarks

DBObjectState values may be OR'ed together.

Example

The following example shows how to create a connection and displays some of its read-only properties.

See Also

DBConnection Class | DBConnection Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DBConnection Methods

The methods of the DBConnection class are listed below. For a complete list of DBConnection class members, see the DBConnection Members topic.

Public:

BeginTransaction | Begins a database transaction.
Clone | Creates a new instance of the object initialized with the current connection string.
Close | Closes the connection to the database.
CommitTransaction | Commits the database transaction.
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Open | Opens a connection to the database.
RollbackTransaction | Rolls back the database transaction.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Protected:

CreateNewStateChangeEvent | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStateChange | Raises the StateChangeEventArgs event.
OpenDesignMode | [To be supplied.]
SetObjectState | Sets the State to one of the DBObjectState values.

Event Hookup:

AddOnStateChange Use to add a connection state change event handler.

See Also

DBConnection Class | System.Data.Internal Namespace


DBConnection.AddOnStateChange

Use to add a connection state change event handler.

[Visual Basic]
Overridable Public Sub AddOnStateChange( _
   ByVal handler As StateChangeEventHandler _
)
[C#]
public virtual void AddOnStateChange(
   StateChangeEventHandler handler
);
[C++]
public: virtual void AddOnStateChange(
   StateChangeEventHandler* handler
);
[JScript]
public function AddOnStateChange(
   handler : StateChangeEventHandler
);

Parameters

handler
A StateChangeEventHandler delegate that represents the method that will handle the StateChangeEventArgs event.

Remarks

Adds an event handler for the StateChangeEventArgs event.

See Also

DBConnection Class | DBConnection Members | System.Data.Internal Namespace | RemoveOnStateChange


DBConnection.BeginTransaction

Begins a database transaction.

[Visual Basic]
MustOverride Public Function BeginTransaction() As Integer
[C#]
public abstract int BeginTransaction();
[C++]
public: virtual int BeginTransaction() = 0;
[JScript]
public abstract function BeginTransaction() : int;

Remarks

Notes to Inheritors: When overridden, BeginTransaction should begin the transaction processing.

See Also

DBConnection Class | DBConnection Members | System.Data.Internal Namespace


DBConnection.Clone

Creates a new instance of the object initialized with the current connection string.

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

Remarks

The new instance will be in a closed state.

Notes to Inheritors: When overriding Clone in a derived class, be sure to call the base class's Clone method.

Example

The following example creates a connection, set some of its properties, clones it, then resets the properties of the original instance.

See Also

DBConnection Class | DBConnection Members | System.Data.Internal Namespace


DBConnection.Close

Closes the connection to the database.

[Visual Basic]
MustOverride Public Sub Close()
[C#]
public abstract void Close();
[C++]
public: virtual void Close() = 0;
[JScript]
public abstract function Close();

Exceptions

Exception Type | Condition
ADP.ConnectionAlreadyClosed | The connection was already in a closed state.
Data.DBObjectState) | A transaction is still being processed.

Remarks

Notes to Inheritors: When overridden, Close will close the connection to the data source.

Example

The following example creates a connection, opens it, begins a transaction, commits the transaction, rollsback the transaction, then closes the connection.

See Also

DBConnection Class | DBConnection Members | System.Data.Internal Namespace | Open


DBConnection.CommitTransaction

Commits the database transaction.

[Visual Basic]
MustOverride Public Sub CommitTransaction()
[C#]
public abstract void CommitTransaction();
[C++]
public: virtual void CommitTransaction() = 0;
[JScript]
public abstract function CommitTransaction();

Remarks

Notes to Inheritors: When overridden Clone in a derived class, commits the transaction.

See Also

DBConnection Class | DBConnection Members | System.Data.Internal Namespace


DBConnection.CreateNewStateChangeEvent

[To be supplied.]

[Visual Basic]
Overridable Protected Function CreateNewStateChangeEvent( _
   ByVal originalState As DBObjectState _
) As StateChangeEventArgs
[C#]
protected virtual StateChangeEventArgs CreateNewStateChangeEvent(
   DBObjectState originalState
);
[C++]
protected: virtual StateChangeEventArgs* CreateNewStateChangeEvent(
   DBObjectState originalState
);
[JScript]
protected function CreateNewStateChangeEvent(
   originalState : DBObjectState
) : StateChangeEventArgs;

Parameters

originalState
[To be supplied.]

See Also

DBConnection Class | DBConnection Members | System.Data.Internal Namespace


DBConnection.OnStateChange

Raises the StateChangeEventArgs event.

[Visual Basic]
Overridable Protected Sub OnStateChange( _
   ByVal scevent As StateChangeEventArgs _
)
[C#]
protected virtual void OnStateChange(
   StateChangeEventArgs scevent
);
[C++]
protected: virtual void OnStateChange(
   StateChangeEventArgs* scevent
);
[JScript]
protected function OnStateChange(
   scevent : StateChangeEventArgs
);

Parameters

scevent
A StateChangeEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through the delegate. For an overview, see TBD.

Notes to Inheritors: When overriding OnStateChange in a derived class, be sure to call the base class's OnStateChange method.

Example

The following example uses this method within a derived class.

See Also

DBConnection Class | DBConnection Members | System.Data.Internal Namespace | OnInfoMessage


DBConnection.Open

Opens a connection to the database.

[Visual Basic]
MustOverride Public Sub Open()
[C#]
public abstract void Open();
[C++]
public: virtual void Open() = 0;
[JScript]
public abstract function Open();

Remarks

Notes to Inheritors: When overridden Open in a derived class, opens a connection to the data source.

See Also

DBConnection Class | DBConnection Members | System.Data.Internal Namespace


DBConnection.OpenDesignMode

[To be supplied.]

[Visual Basic]
Overridable Protected Sub OpenDesignMode()
[C#]
protected virtual void OpenDesignMode();
[C++]
protected: virtual void OpenDesignMode();
[JScript]
protected function OpenDesignMode();

See Also

DBConnection Class | DBConnection Members | System.Data.Internal Namespace


DBConnection.RollbackTransaction

Rolls back the database transaction.

[Visual Basic]
MustOverride Public Sub RollbackTransaction()
[C#]
public abstract void RollbackTransaction();
[C++]
public: virtual void RollbackTransaction() = 0;
[JScript]
public abstract function RollbackTransaction();

Remarks

Notes to Inheritors: When overriding Clone in a derived class, rolls back the transaction.

See Also

DBConnection Class | DBConnection Members | System.Data.Internal Namespace


DBConnection.SetObjectState

Sets the State to one of the DBObjectState values.

[Visual Basic]
Protected Sub SetObjectState( _
   ByVal state As DBObjectState _
)
[C#]
protected void SetObjectState(
   DBObjectState state
);
[C++]
protected: void SetObjectState(
   DBObjectState state
);
[JScript]
protected function SetObjectState(
   state : DBObjectState
);

Parameters

state
[To be supplied.]

See Also

DBConnection Class | DBConnection Members | System.Data.Internal Namespace


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DBConnection Events

The events of the DBConnection class are listed below. For a complete list of DBConnection class members, see the DBConnection Members topic.

Public:

StateChange Occurs whenever the state of the connection changes.

See Also

DBConnection Class | System.Data.Internal Namespace


DBConnection StateChange Event

Occurs whenever the state of the connection changes.

The following declaration shows the syntax for a method that handles the StateChange event.

[Visual Basic]
Private Sub DBConnectionName_StateChange( _
   ByVal sender As Object, _
   ByVal e As StateChangeEventArgs _
)
[C#]
private void DBConnectionName_StateChange(
   object sender,
   StateChangeEventArgs e
);
[C++]
private: void DBConnectionName_StateChange(
   Object* sender,
   StateChangeEventArgs* e
);
[JScript]
private DBConnectionName_StateChange(
   sender : Object,
   e : StateChangeEventArgs
);

Parameters

sender
The source of the event.
e
A StateChangeEventArgs that contains the event data. The following StateChangeEventArgs properties provide information specific to this event.
Property Description
CurrentState
[To be supplied.]
OriginalState
[To be supplied.]

See Also

DBConnection Class | DBConnection MembersTopic | System.Data.Internal Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DBConnection Fields

The fields of the DBConnection class are listed below. For a complete list of DBConnection class members, see the DBConnection Members topic.

Protected:

DefaultConnectionTimeout The default timeout value to use when attempting to connect to the data source.

See Also

DBConnection Class | System.Data.Internal Namespace


DBConnection.DefaultConnectionTimeout

The default timeout value to use when attempting to connect to the data source.

[Visual Basic]
Protected Const DefaultConnectionTimeout As Integer
[C#]
protected const int DefaultConnectionTimeout;
[C++]
protected: const int DefaultConnectionTimeout;
[JScript]
protected var DefaultConnectionTimeout : int;

See Also

DBConnection Class | DBConnection Members | System.Data.Internal Namespace


DBDataReader Class

[To be supplied.]

Object
DBDataReader

[Visual Basic]
MustInherit Public Class DBDataReader
[C#]
public abstract class DBDataReader
[C++]
public __gc __abstract class DBDataReader
[JScript]
public abstract class DBDataReader

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

DBDataReader Members | System.Data.Internal Namespace


DBDataReader Members

Public:

Constructor

DBDataReader Constructor [To be supplied.]

Properties

Depth | [To be supplied.]
Empty | [To be supplied.]
EOF | [To be supplied.]
Format | [To be supplied.]
Namespace | [To be supplied.]
NameTable | [To be supplied.]
NodeType | [To be supplied.]
Prefix | [To be supplied.]
ReadState | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Events

DataSchemaChanged [To be supplied.]

Protected:

Methods

CreateNewSchemaTable | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnDataSchemaChangedEvent | [To be supplied.]

Fields

dataValues | [To be supplied.]
dbSchemaTable | [To be supplied.]
inDataSchemaChanged | [To be supplied.]
indexMap | [To be supplied.]
pendingEvent | [To be supplied.]
readingState | [To be supplied.]

Event Hookup:

Methods

AddOnDataSchemaChanged | [To be supplied.]
RemoveOnDataSchemaChanged | [To be supplied.]

See Also

DBDataReader Class | System.Data.Internal Namespace


DBDataReader Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public DBDataReader();
[C++]
public: DBDataReader();
[JScript]
public function DBDataReader();

See Also

DBDataReader Class | DBDataReader Members | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DBDataReader Properties

The properties of the DBDataReader class are listed below. For a complete list of DBDataReader class members, see the DBDataReader Members topic.

Public:

Depth | [To be supplied.]
Empty | [To be supplied.]
EOF | [To be supplied.]
Format | [To be supplied.]
Namespace | [To be supplied.]
NameTable | [To be supplied.]
NodeType | [To be supplied.]
Prefix | [To be supplied.]
ReadState | [To be supplied.]

See Also

DBDataReader Class | System.Data.Internal Namespace


DBDataReader.Depth

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Depth As Integer
[C#]
public int Depth {virtual get;}
[C++]
public: __property virtual int get_Depth();
[JScript]
public function get Depth() : int;

See Also

DBDataReader Class | DBDataReader Members | System.Data.Internal Namespace


DBDataReader.Empty

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Empty As Boolean
[C#]
public bool Empty {virtual get;}
[C++]
public: __property virtual bool get_Empty();
[JScript]
public function get Empty() : Boolean;

See Also

DBDataReader Class | DBDataReader Members | System.Data.Internal Namespace


DBDataReader.EOF

[To be supplied.]

[Visual Basic]
MustOverride Public ReadOnly Property EOF As Boolean
[C#]
public bool EOF {abstract get;}
[C++]
public: __property virtual bool get_EOF() = 0;
[JScript]
public abstract function get EOF() : Boolean;

See Also

DBDataReader Class | DBDataReader Members | System.Data.Internal Namespace


DBDataReader.Format

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Format As String
[C#]
public string Format {virtual get;}
[C++]
public: __property virtual String* get_Format();
[JScript]
public function get Format() : String;

See Also

DBDataReader Class | DBDataReader Members | System.Data.Internal Namespace


DBDataReader.Namespace

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Namespace As String
[C#]
public string Namespace {virtual get;}
[C++]
public: __property virtual String* get_Namespace();
[JScript]
public function get Namespace() : String;

See Also

DBDataReader Class | DBDataReader Members | System.Data.Internal Namespace


DBDataReader.NameTable

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property NameTable As INameTable
[C#]
public INameTable NameTable {virtual get;}
[C++]
public: __property virtual INameTable* get_NameTable();
[JScript]
public function get NameTable() : INameTable;

See Also

DBDataReader Class | DBDataReader Members | System.Data.Internal Namespace


DBDataReader.NodeType

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property NodeType As XmlNodeType
[C#]
public XmlNodeType NodeType {virtual get;}
[C++]
public: __property virtual XmlNodeType get_NodeType();
[JScript]
public function get NodeType() : XmlNodeType;

See Also

DBDataReader Class | DBDataReader Members | System.Data.Internal Namespace


DBDataReader.Prefix

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Prefix As String
[C#]
public string Prefix {virtual get;}
[C++]
public: __property virtual String* get_Prefix();
[JScript]
public function get Prefix() : String;

See Also

DBDataReader Class | DBDataReader Members | System.Data.Internal Namespace


DBDataReader.ReadState

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property ReadState As Integer
[C#]
public int ReadState {virtual get;}
[C++]
public: __property virtual int get_ReadState();
[JScript]
public function get ReadState() : int;

See Also

DBDataReader Class | DBDataReader Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DBDataReader Methods

The methods of the DBDataReader class are listed below. For a complete list of DBDataReader class members, see the DBDataReader Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

CreateNewSchemaTable | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnDataSchemaChangedEvent | [To be supplied.]

Event Hookup:

AddOnDataSchemaChanged | [To be supplied.]
RemoveOnDataSchemaChanged | [To be supplied.]

See Also

DBDataReader Class | System.Data.Internal Namespace


DBDataReader.AddOnDataSchemaChanged

[To be supplied.]

[Visual Basic]
Overridable Public Sub AddOnDataSchemaChanged( _
   ByVal handler As DataSchemaChangedEventHandler _
)
[C#]
public virtual void AddOnDataSchemaChanged(
   DataSchemaChangedEventHandler handler
);
[C++]
public: virtual void AddOnDataSchemaChanged(
   DataSchemaChangedEventHandler* handler
);
[JScript]
public function AddOnDataSchemaChanged(
   handler : DataSchemaChangedEventHandler
);

Parameters

handler
[To be supplied.]

See Also

DBDataReader Class | DBDataReader Members | System.Data.Internal Namespace


DBDataReader.CreateNewSchemaTable

[To be supplied.]

[Visual Basic]
Overridable Protected Function CreateNewSchemaTable( _
   ByVal capacity As Integer _
) As DataTable
[C#]
protected virtual DataTable CreateNewSchemaTable(
   int capacity
);
[C++]
protected: virtual DataTable* CreateNewSchemaTable(
   int capacity
);
[JScript]
protected function CreateNewSchemaTable(
   capacity : int
) : DataTable;

Parameters

capacity
[To be supplied.]

See Also

DBDataReader Class | DBDataReader Members | System.Data.Internal Namespace


DBDataReader.OnDataSchemaChangedEvent

[To be supplied.]

[Visual Basic]
Overridable Protected Sub OnDataSchemaChangedEvent( _
   ByVal dscevent As DataSchemaChangedEvent _
)
[C#]
protected virtual void OnDataSchemaChangedEvent(
   DataSchemaChangedEvent dscevent
);
[C++]
protected: virtual void OnDataSchemaChangedEvent(
   DataSchemaChangedEvent* dscevent
);
[JScript]
protected function OnDataSchemaChangedEvent(
   dscevent : DataSchemaChangedEvent
);

Parameters

dscevent
[To be supplied.]

See Also

DBDataReader Class | DBDataReader Members | System.Data.Internal Namespace


DBDataReader.RemoveOnDataSchemaChanged

[To be supplied.]

[Visual Basic]
Overridable Public Sub RemoveOnDataSchemaChanged( _
   ByVal handler As DataSchemaChangedEventHandler _
)
[C#]
public virtual void RemoveOnDataSchemaChanged(
   DataSchemaChangedEventHandler handler
);
[C++]
public: virtual void RemoveOnDataSchemaChanged(
   DataSchemaChangedEventHandler* handler
);
[JScript]
public function RemoveOnDataSchemaChanged(
   handler : DataSchemaChangedEventHandler
);

Parameters

handler
[To be supplied.]

See Also

DBDataReader Class | DBDataReader Members | System.Data.Internal Namespace


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DBDataReader Events

The events of the DBDataReader class are listed below. For a complete list of DBDataReader class members, see the DBDataReader Members topic.

Public:

DataSchemaChanged [To be supplied.]

See Also

DBDataReader Class | System.Data.Internal Namespace


DBDataReader DataSchemaChanged Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the DataSchemaChanged event.

[Visual Basic]
Private Sub DBDataReaderName_DataSchemaChanged( _
   ByVal sender As Object, _
   ByVal e As DataSchemaChangedEventArgs _
)
[C#]
private void DBDataReaderName_DataSchemaChanged(
   object sender,
   DataSchemaChangedEventArgs e
);
[C++]
private: void DBDataReaderName_DataSchemaChanged(
   Object* sender,
   DataSchemaChangedEventArgs* e
);
[JScript]
private DBDataReaderName_DataSchemaChanged(
   sender : Object,
   e : DataSchemaChangedEventArgs
);

Parameters

sender
The source of the event.
e
A DataSchemaChangedEventArgs that contains the event data.

See Also

DBDataReader Class | DBDataReader MembersTopic | System.Data.Internal Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DBDataReader Fields

The fields of the DBDataReader class are listed below. For a complete list of DBDataReader class members, see the DBDataReader Members topic.

Protected:

dataValues | [To be supplied.]
dbSchemaTable | [To be supplied.]
inDataSchemaChanged | [To be supplied.]
indexMap | [To be supplied.]
pendingEvent | [To be supplied.]
readingState | [To be supplied.]

See Also

DBDataReader Class | System.Data.Internal Namespace


DBDataReader.dataValues

[To be supplied.]

[Visual Basic]
Protected dataValues() As Object
[C#]
protected object[] dataValues;
[C++]
protected: Object* dataValues[];
[JScript]
protected var dataValues : Object[];

See Also

DBDataReader Class | DBDataReader Members | System.Data.Internal Namespace


DBDataReader.dbSchemaTable

[To be supplied.]

[Visual Basic]
Protected dbSchemaTable As DataTable
[C#]
protected DataTable dbSchemaTable;
[C++]
protected: DataTable* dbSchemaTable;
[JScript]
protected var dbSchemaTable : DataTable;

See Also

DBDataReader Class | DBDataReader Members | System.Data.Internal Namespace


DBDataReader.inDataSchemaChanged

[To be supplied.]

[Visual Basic]
Protected inDataSchemaChanged As Integer
[C#]
protected int inDataSchemaChanged;
[C++]
protected: int inDataSchemaChanged;
[JScript]
protected var inDataSchemaChanged : int;

See Also

DBDataReader Class | DBDataReader Members | System.Data.Internal Namespace


DBDataReader.indexMap

[To be supplied.]

[Visual Basic]
Protected indexMap() As Integer
[C#]
protected int[] indexMap;
[C++]
protected: int* indexMap[];
[JScript]
protected var indexMap : int[];

See Also

DBDataReader Class | DBDataReader Members | System.Data.Internal Namespace


DBDataReader.pendingEvent

[To be supplied.]

[Visual Basic]
Protected pendingEvent As DataSchemaChangedEvent
[C#]
protected DataSchemaChangedEvent pendingEvent;
[C++]
protected: DataSchemaChangedEvent* pendingEvent;
[JScript]
protected var pendingEvent : DataSchemaChangedEvent;

See Also

DBDataReader Class | DBDataReader Members | System.Data.Internal Namespace


DBDataReader.readingState

[To be supplied.]

[Visual Basic]
Protected readingState As ReadState
[C#]
protected ReadState readingState;
[C++]
protected: ReadState readingState;
[JScript]
protected var readingState : ReadState;

See Also

DBDataReader Class | DBDataReader Members | System.Data.Internal Namespace


DBDataSetCommand Class

Implementation of DataSetCommand designed for relational data sources like databases.

Object
Component
DataSetCommand
DBDataSetCommand

[Visual Basic]
MustInherit Public Class DBDataSetCommand
   Inherits DataSetCommand
[C#]
public abstract class DBDataSetCommand : DataSetCommand
[C++]
public __gc __abstract class DBDataSetCommand : public
   DataSetCommand
[JScript]
public abstract class DBDataSetCommand extends DataSetCommand

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

Example [C#]

The following example uses the derived classes ADODataSetCommand and SQLDataSetCommand to select records from an Access data source and insert them in a SQL Server data source. This example can be modified to migrate an Access database to a SQL Server database.

[C#]

private DataSet InitializeMyDataSet() {
   // creates the table and its columns for the DataSet
   DataSet newData = new DataSet();
   DataTable newTable = newData.Tables.Add("Catagories");

   // add Columns to table
   newTable.Columns.Add("CategoryID",typeof(Int32));
   newTable.Columns.Add("CategoryName", typeof(String));
   newTable.Columns.Add("Description", typeof(String));
   newTable.Columns.Add("Picture",typeof(Byte[]));
   return newData;
}

public void AccessToSQLServer() {
   // set Access connection and select strings
   const string strAccessConn = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=NWIND_RW.MDB";
   const string strAccessSelect = "SELECT * FROM Categories ORDER BY CategoryID";
   // set SQL Server connection and insert strings
   const string strSQLServerConn = "Data Source=VBsql7;Initial Catalog=Northwind;User ID=sa;Password=;";
   const string strSQLServerInsert = "INSERT INTO Categories(CategoryName, Description, Picture) Values(@CategoryName,@Description,@Picture)";
   // create my DataSet
   DataSet myDataSet = InitializeMyDataSet();
   // create my Access objects
   ADOConnection myAccessConn = new ADOConnection(strAccessConn);
   ADODataSetCommand myAccessDataSetCmd = new ADODataSetCommand();
   myAccessDataSetCmd.SelectCommand = new ADOCommand(strAccessSelect,myAccessConn);
   // create my SQL Server objects
   SQLConnection mySQLConn = new SQLConnection(strSQLServerConn);
   SQLDataSetCommand mySQLDataSetCmd = new SQLDataSetCommand();
   mySQLDataSetCmd.InsertCommand = new SQLCommand(strSQLServerInsert,mySQLConn);
   // fill myDataSet with data from Access
   myAccessConn.Open();
   try {
      myAccessDataSetCmd.FillDataSet(myDataSet,"table");
   }
   finally {
      myAccessConn.Close();
   }

   // do ugly work to turn original rows into new rows

   // update SQL Server with data from the DataSet
   mySQLConn.Open();
   try {
      mySQLDataSetCmd.InsertCommand.Parameters.Add("CategoryName", typeof(String));
      mySQLDataSetCmd.InsertCommand.Parameters.Add("Description", typeof(String));
      mySQLDataSetCmd.InsertCommand.Parameters.Add("Picture", typeof(Byte[]));
      mySQLDataSetCmd.InsertCommand.Parameters[0].SourceColumn = "CategoryName";
      mySQLDataSetCmd.InsertCommand.Parameters[1].SourceColumn = "Description";
      mySQLDataSetCmd.InsertCommand.Parameters[2].SourceColumn = "Picture";
      mySQLDataSetCmd.Update(myDataSet,"table");
   }
   finally {
      mySQLConn.Close();
   }
}

See Also

DBDataSetCommand Members | System.Data.Internal Namespace | DataSetCommand | DBCommand | DBConnection


DBDataSetCommand Members

Public:

Properties

MissingMappingAction (inherited from DataSetCommand) | Gets or sets whether unmapped source tables or columns are to be passed with their source names to be filtered, or to cause an error to be raised.
MissingSchemaAction (inherited from DataSetCommand) | Gets or sets whether missing source tables, columns, and their relationships are to be added to the data set schema, to be ignored, or to cause an error to be raised.
Site (inherited from Component) | Gets or sets the site of the Component.
TableMappings (inherited from DataSetCommand) | Gets how a source table is to be mapped to a data set table.

Methods

Clone | Creates a new instance of this ADODataSetCommand object.
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FillDataSet | Overloaded. Fills the data set with records and schema.
FillDataSetSchema | Overloaded. Fills the data set with the schema.
GenerateUpdateCommands | Generates the insert, update, or delete commands when each is in a default state.
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetFillDataSetParameters | Returns all parameters used when performing the select command.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
Update | Overloaded. Calls the respective insert, update, or delete commands on the connection, for each inserted, updated, or deleted rows in the data set.

Events

SchemaChanged (inherited from DataSetCommand) | Occurs during Update after a command is executed against the data source when the schema may be potentially different due to a property change.
SchemaChanging (inherited from DataSetCommand) | Occurs during Update before a command is executed against the data source when the schema may be potentially different due to a property change.

Fields

DefaultSourceTableName The default name for source tables to be used when the DBDataSetCommand is initialized.

Protected:

Constructor

DBDataSetCommand Constructor Initializes a new instance of the DBDataSetCommand class.

Methods

CanGenerateUpdateCommands | [To be supplied.]
CreateNewDeleteCommand | [To be supplied.]
CreateNewInsertCommand | [To be supplied.]
CreateNewRowUpdatedEvent | [To be supplied.]
CreateNewRowUpdatingEvent | [To be supplied.]
CreateNewSchemaChangedEvent (inherited from DataSetCommand) | [To be supplied.]
CreateNewSchemaChangingEvent (inherited from DataSetCommand) | [To be supplied.]
CreateNewSchemaMappingEvent | [To be supplied.]
CreateNewSelectCommand | [To be supplied.]
CreateNewTableMappings (inherited from DataSetCommand) | [To be supplied.]
CreateNewUpdateCommand | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
FixupDataCommand | [To be supplied.]
ForceGenerateUpdateCommand | Force the generation of the insert, update, or delete commands from the select command.
GetDeleteCommandObject | [To be supplied.]
GetInsertCommandObject | [To be supplied.]
GetSelectCommandObject | [To be supplied.]
GetUpdateCommandObject | [To be supplied.]
IsValidDataCommand | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnRowUpdated | Raises the OnRowUpdated event.
OnRowUpdating | Raises the OnRowUpdating event.
OnSchemaChanged (inherited from DataSetCommand) | Raises the OnSchemaChanged event.
OnSchemaChanging (inherited from DataSetCommand) | Raises the OnSchemaChanged event.
OnSchemaMapping | Raises the OnSchemaMapping event.
ParameterOutput | [To be supplied.]
SetDeleteCommandObject | [To be supplied.]
SetInsertCommandObject | [To be supplied.]
SetSelectCommandObject | [To be supplied.]
SetUpdateCommandObject | [To be supplied.]

Fields

commands | [To be supplied.]
DELETE_INDEX | [To be supplied.]
INSERT_INDEX | [To be supplied.]
SELECT_INDEX | [To be supplied.]
UPDATE_INDEX | [To be supplied.]

Event Hookup:

Methods

AddOnSchemaChanged (inherited from DataSetCommand) | [To be supplied.]
AddOnSchemaChanging (inherited from DataSetCommand) | [To be supplied.]
RemoveOnSchemaChanged (inherited from DataSetCommand) | [To be supplied.]
RemoveOnSchemaChanging (inherited from DataSetCommand) | [To be supplied.]

See Also

DBDataSetCommand Class | System.Data.Internal Namespace


DBDataSetCommand Constructor

Initializes a new instance of the DBDataSetCommand class.

[Visual Basic]
Protected Sub New()
[C#]
protected DBDataSetCommand();
[C++]
protected: DBDataSetCommand();
[JScript]
protected function DBDataSetCommand();

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DBDataSetCommand Methods

The methods of the DBDataSetCommand class are listed below. For a complete list of DBDataSetCommand class members, see the DBDataSetCommand Members topic.

Public:

Clone | Creates a new instance of this ADODataSetCommand object.
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FillDataSet | Overloaded. Fills the data set with records and schema.
FillDataSetSchema | Overloaded. Fills the data set with the schema.
GenerateUpdateCommands | Generates the insert, update, or delete commands when each is in a default state.
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetFillDataSetParameters | Returns all parameters used when performing the select command.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
Update | Overloaded. Calls the respective insert, update, or delete commands on the connection, for each inserted, updated, or deleted rows in the data set.

Protected:

CanGenerateUpdateCommands | [To be supplied.]
CreateNewDeleteCommand | [To be supplied.]
CreateNewInsertCommand | [To be supplied.]
CreateNewRowUpdatedEvent | [To be supplied.]
CreateNewRowUpdatingEvent | [To be supplied.]
CreateNewSchemaChangedEvent (inherited from DataSetCommand) | [To be supplied.]
CreateNewSchemaChangingEvent (inherited from DataSetCommand) | [To be supplied.]
CreateNewSchemaMappingEvent | [To be supplied.]
CreateNewSelectCommand | [To be supplied.]
CreateNewTableMappings (inherited from DataSetCommand) | [To be supplied.]
CreateNewUpdateCommand | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
FixupDataCommand | [To be supplied.]
ForceGenerateUpdateCommand | Force the generation of the insert, update, or delete commands from the select command.
GetDeleteCommandObject | [To be supplied.]
GetInsertCommandObject | [To be supplied.]
GetSelectCommandObject | [To be supplied.]
GetUpdateCommandObject | [To be supplied.]
IsValidDataCommand | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnRowUpdated | Raises the OnRowUpdated event.
OnRowUpdating | Raises the OnRowUpdating event.
OnSchemaChanged (inherited from DataSetCommand) | Raises the OnSchemaChanged event.
OnSchemaChanging (inherited from DataSetCommand) | Raises the OnSchemaChanged event.
OnSchemaMapping | Raises the OnSchemaMapping event.
ParameterOutput | [To be supplied.]
SetDeleteCommandObject | [To be supplied.]
SetInsertCommandObject | [To be supplied.]
SetSelectCommandObject | [To be supplied.]
SetUpdateCommandObject | [To be supplied.]

Event Hookup:

AddOnSchemaChanged (inherited from DataSetCommand) | [To be supplied.]
AddOnSchemaChanging (inherited from DataSetCommand) | [To be supplied.]
RemoveOnSchemaChanged (inherited from DataSetCommand) | [To be supplied.]
RemoveOnSchemaChanging (inherited from DataSetCommand) | [To be supplied.]

See Also

DBDataSetCommand Class | System.Data.Internal Namespace


DBDataSetCommand.CanGenerateUpdateCommands

[To be supplied.]

[Visual Basic]
Protected Function CanGenerateUpdateCommands() As Boolean
[C#]
protected bool CanGenerateUpdateCommands();
[C++]
protected: bool CanGenerateUpdateCommands();
[JScript]
protected function CanGenerateUpdateCommands() : Boolean;

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DBDataSetCommand.Clone

Creates a new instance of this ADODataSetCommand object.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
public: override Object* Clone();
[JScript]
public override function Clone() : Object;

Remarks

The new instance of the object will contain all insert, update, delete, and select commands; table mappings; the missing schema action; and the missing mapping action.

Example [Visual Basic]

The following example uses an ADODataSetCommand that attempts to resolve discrepancies between the data set and the data source. This example then creates an ADODataSetCommand that throws an error any time a discrepancy occurs.

[Visual Basic]

Sub CreateClonedDataSetComm (mySelectComm As String, _
      myConnection As String)
    ' Create an ADODataSetCommand to resolve discrepancies
    Dim optDataSetComm As ADODataSetCommand
    ' Create an ADODataSetCommand to error on all discrepancies
    Dim pesDataSetComm As ADODataSetCommand
    ' Initialize the optimistic data set command
    optDataSetComm = New ADODataSetCommand mySelectComm, myConnection
    ' Set missing schema and mapping actions to optimistic view
    optDataSetComm.MissingMappingAction = MissingMappingAction.Passthrough
    optDataSetComm.MissingMappingSchema = MissingMappingSchema.Add
    ' Initialize the pessimistic data set command
    pesDataSetComm = New ADODataSetCommand
    ' Clone the data set command
    pesDataSetComm = optDataSetCommand.Clone
    ' Set missing schema and mapping actions to pessimistic view
    pesDataSetComm.MissingMappingAction = MissingMappingAction.Error
    pesDataSetComm.MissingSchemaAction = MissingSchemaAction.Error
 End Sub

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace | InsertCommand | DeleteCommand | SelectCommand | UpdateCommand | TableMappings | MissingSchemaAction | MissingMappingAction


DBDataSetCommand.CreateNewDeleteCommand

[To be supplied.]

[Visual Basic]
MustOverride Protected Function CreateNewDeleteCommand() As _
   DBCommand
[C#]
protected abstract DBCommand CreateNewDeleteCommand();
[C++]
protected: virtual DBCommand* CreateNewDeleteCommand() = 0;
[JScript]
protected abstract function CreateNewDeleteCommand() : DBCommand;

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DBDataSetCommand.CreateNewInsertCommand

[To be supplied.]

[Visual Basic]
MustOverride Protected Function CreateNewInsertCommand() As _
   DBCommand
[C#]
protected abstract DBCommand CreateNewInsertCommand();
[C++]
protected: virtual DBCommand* CreateNewInsertCommand() = 0;
[JScript]
protected abstract function CreateNewInsertCommand() : DBCommand;

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DBDataSetCommand.CreateNewRowUpdatedEvent

[To be supplied.]

[Visual Basic]
MustOverride Protected Function CreateNewRowUpdatedEvent( _
   ByVal dataRow As DataRow, _
   ByVal command As DBCommand, _
   ByVal commandType As String _
) As RowUpdatedEventArgs
[C#]
protected abstract RowUpdatedEventArgs CreateNewRowUpdatedEvent(
   DataRow dataRow,
   DBCommand command,
   string commandType
);
[C++]
protected: virtual RowUpdatedEventArgs* CreateNewRowUpdatedEvent(
   DataRow* dataRow,
   DBCommand* command,
   String* commandType
) = 0;
[JScript]
protected abstract function CreateNewRowUpdatedEvent(
   dataRow : DataRow,
   command : DBCommand,
   commandType : String
) : RowUpdatedEventArgs;

Parameters

dataRow
[To be supplied.]
command
[To be supplied.]
commandType
[To be supplied.]

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DBDataSetCommand.CreateNewRowUpdatingEvent

[To be supplied.]

[Visual Basic]
MustOverride Protected Function CreateNewRowUpdatingEvent( _
   ByVal dataRow As DataRow, _
   ByVal command As DBCommand, _
   ByVal commandType As String _
) As RowUpdatingEventArgs
[C#]
protected abstract RowUpdatingEventArgs CreateNewRowUpdatingEvent(
   DataRow dataRow,
   DBCommand command,
   string commandType
);
[C++]
protected: virtual RowUpdatingEventArgs* CreateNewRowUpdatingEvent(
   DataRow* dataRow,
   DBCommand* command,
   String* commandType
) = 0;
[JScript]
protected abstract function CreateNewRowUpdatingEvent(
   dataRow : DataRow,
   command : DBCommand,
   commandType : String
) : RowUpdatingEventArgs;

Parameters

dataRow
[To be supplied.]
command
[To be supplied.]
commandType
[To be supplied.]

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DBDataSetCommand.CreateNewSchemaMappingEvent

[To be supplied.]

[Visual Basic]
MustOverride Protected Function CreateNewSchemaMappingEvent( _
   ByVal command As DBCommand, _
   ByVal dataSet As DataSet, _
   ByVal schemaTable As DataTable _
) As SchemaMappingEventArgs
[C#]
protected abstract SchemaMappingEventArgs CreateNewSchemaMappingEvent(
   DBCommand command,
   DataSet dataSet,
   DataTable schemaTable
);
[C++]
protected: virtual SchemaMappingEventArgs* CreateNewSchemaMappingEvent(
   DBCommand* command,
   DataSet* dataSet,
   DataTable* schemaTable
) = 0;
[JScript]
protected abstract function CreateNewSchemaMappingEvent(
   command : DBCommand,
   dataSet : DataSet,
   schemaTable : DataTable
) : SchemaMappingEventArgs;

Parameters

command
[To be supplied.]
dataSet
[To be supplied.]
schemaTable
[To be supplied.]

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DBDataSetCommand.CreateNewSelectCommand

[To be supplied.]

[Visual Basic]
MustOverride Protected Function CreateNewSelectCommand() As _
   DBCommand
[C#]
protected abstract DBCommand CreateNewSelectCommand();
[C++]
protected: virtual DBCommand* CreateNewSelectCommand() = 0;
[JScript]
protected abstract function CreateNewSelectCommand() : DBCommand;

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DBDataSetCommand.CreateNewUpdateCommand

[To be supplied.]

[Visual Basic]
MustOverride Protected Function CreateNewUpdateCommand() As _
   DBCommand
[C#]
protected abstract DBCommand CreateNewUpdateCommand();
[C++]
protected: virtual DBCommand* CreateNewUpdateCommand() = 0;
[JScript]
protected abstract function CreateNewUpdateCommand() : DBCommand;

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DBDataSetCommand.FillDataSet

Fills the data set with records and schema.

Overload List

Fills the data set with records and schema using the DataSet given.

[Visual Basic] Overloads Overrides Public Function FillDataSet(DataSet) As Integer
[C#] public override int FillDataSet(DataSet);
[C++] public: override int FillDataSet(DataSet*);
[JScript] public override function FillDataSet(DataSet) : int;

Fills the data set with records and schema from a given source table.

[Visual Basic] Overloads Overridable Public Function FillDataSet(DataSet, String) As Integer
[C#] public virtual int FillDataSet(DataSet, String);
[C++] public: virtual int FillDataSet(DataSet*, String);
[JScript] public function FillDataSet(DataSet, String) : int;

Fills the data set with records from between the given bounds and schema from a given source table.

[Visual Basic] Overloads Overridable Public Function FillDataSet(DataSet, String, Integer, Integer) As Integer
[C#] public virtual int FillDataSet(DataSet, String, int, int);
[C++] public: virtual int FillDataSet(DataSet*, String, int, int);
[JScript] public function FillDataSet(DataSet, String, int, int) : int;

Example [Visual Basic]

The following example fills a previously created DataSet with the schema and only records 10 through 20 provided the source table exists.

Note This example shows how to use one of the overloaded versions of FillDataSet. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Function MyTwixtTenAndTwenty(myDataSet As DataSet, srcTable As String) As DataSet
    ' fill the data set
    FillDataSet myDataSet, srcTable, 10, 20
    ' return the data set (or will this only return the schema?)
    MyFillData = myDataSet.Clone
End Function

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DBDataSetCommand.FillDataSet (DataSet)

Fills the data set with records and schema using the DataSet given.

[Visual Basic]
Overloads Overrides Public Function FillDataSet( _
   ByVal dataSet As DataSet _
) As Integer
[C#]
public override int FillDataSet(
   DataSet dataSet
);
[C++]
public: override int FillDataSet(
   DataSet* dataSet
);
[JScript]
public override function FillDataSet(
   dataSet : DataSet
) : int;

Parameters

dataSet
A DataSet to fill with records and schema.

Exceptions

Exception Type | Condition
FillDataSetRequiresSourceTable | The source table was invalid.

Example [Visual Basic]

The following example shows how to fill a previously created DataSet with data and the schema.

[Visual Basic]

Function MyFillData(myDataSet As DataSet) As DataSet
    ' fill the data set
    FillDataSet myDataSet
    ' return the data set (or will this only return the schema?)
    MyFillData = myDataSet.Clone
End Function

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace | DBDataSetCommand.FillDataSet Overload List


DBDataSetCommand.FillDataSet (DataSet, String)

Fills the data set with records and schema from a given source table.

[Visual Basic]
Overloads Overridable Public Function FillDataSet( _
   ByVal dataSet As DataSet, _
   ByVal srcTable As String _
) As Integer
[C#]
public virtual int FillDataSet(
   DataSet dataSet,
   string srcTable
);
[C++]
public: virtual int FillDataSet(
   DataSet* dataSet,
   String* srcTable
);
[JScript]
public function FillDataSet(
   dataSet : DataSet,
   srcTable : String
) : int;

Parameters

dataSet
A DataSet to fill with records and schema.
srcTable
The name of the source table used for the table mappings.

Exceptions

Exception Type | Condition
FillDataSetRequiresSourceTable | The source table was invalid.

Remarks

Notes to Inheritors: When overriding FillDataSet in a derived class, be sure to call the base class's FillDataSet method.

Example [Visual Basic]

The following example shows how to fill a previously created DataSet with data and the schema when providing a source table.

[Visual Basic]

Function MyFillData(myDataSet As DataSet, sourceTable As String) As DataSet
    ' fill the data set
    FillDataSet myDataSet, sourceTable
    ' return the data set (or will this only return the schema?)
    MyFillData = myDataSet.Clone
End Function

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace | DBDataSetCommand.FillDataSet Overload List


DBDataSetCommand.FillDataSet (DataSet, String, Int32, Int32)

Fills the data set with records from between the given bounds and schema from a given source table.

[Visual Basic]
Overloads Overridable Public Function FillDataSet( _
   ByVal dataSet As DataSet, _
   ByVal srcTable As String, _
   ByVal startRecord As Integer, _
   ByVal maxRecords As Integer _
) As Integer
[C#]
public virtual int FillDataSet(
   DataSet dataSet,
   string srcTable,
   int startRecord,
   int maxRecords
);
[C++]
public: virtual int FillDataSet(
   DataSet* dataSet,
   String* srcTable,
   int startRecord,
   int maxRecords
);
[JScript]
public function FillDataSet(
   dataSet : DataSet,
   srcTable : String,
   startRecord : int,
   maxRecords : int
) : int;

Parameters

dataSet
A DataSet to fill with records.
srcTable
The name of the source table used for the table mappings.
startRecord
The zero-based record number to start on.
maxRecords
The maximum number of records to retrieve.

Exceptions

Exception Type | Condition
FillDataSetRequiresDataSet | The DataSet was invalid.
FillDataSetRequiresSourceTable | The source table was invalid.
NotAnAdapterCommand | The ADOConnection could not be found.
InvalidStartRecord | The startRecord parameter was less than 0.
InvalidMaxRecords | The maxRecords parameter was a value less than 0.
FillDataSetRequiresConnection | The ADOConnection was invalid.

Remarks

A maxRecords value of 0 gets all records found after the start record.

Notes to Inheritors: When overriding FillDataSet in a derived class, be sure to call the base class's FillDataSet method.

Example [Visual Basic]

The following example fills a previously created DataSet with the schema and only records 10 through 20 provided the source table exists.

[Visual Basic]

Function MyTwixtTenAndTwenty(myDataSet As DataSet, srcTable As String) As DataSet
    ' fill the data set
    FillDataSet myDataSet, srcTable, 10, 20
    ' return the data set (or will this only return the schema?)
    MyFillData = myDataSet.Clone
End Function

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace | DBDataSetCommand.FillDataSet Overload List


DBDataSetCommand.FillDataSetSchema

Fills the data set with the schema.

Overload List

Fills the data set with the schema based upon the chosen SchemaType and a given source table.

[Visual Basic] Overloads Overridable Public Function FillDataSetSchema(DataSet, SchemaType, String) As DataTable ()
[C#] public virtual DataTable[] FillDataSetSchema(DataSet, SchemaType, String);
[C++] public: virtual DataTable* FillDataSetSchema(DataSet*, SchemaType, String) [];
[JScript] public function FillDataSetSchema(DataSet, SchemaType, String) : DataTable[];

Fills the data set with the schema based upon the chosen SchemaType.

[Visual Basic] Overloads Overrides Public Function FillDataSetSchema(DataSet, SchemaType) As DataTable ()
[C#] public override DataTable[] FillDataSetSchema(DataSet, SchemaType);
[C++] public: override DataTable* FillDataSetSchema(DataSet*, SchemaType) [];
[JScript] public override function FillDataSetSchema(DataSet, SchemaType) : DataTable[];

Example [Visual Basic]

The following example fills a DataSet with the schema only, while filling a DataTable with records.

Note This example shows how to use one of the overloaded versions of FillDataSetSchema. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Public Sub MyFillDataTableAndSet(myDataTable   As DataTable, _
         myDataSet     As DataSet, _
         myDataSetComm As ADODataSetCommand)
   ' Create a MessageBox to show the contents of myDataTable in
   Dim myMsgBox As MessageBox
   ' Populate myDataTable with records and myDataSet with schema
   myDataTable = myDataSetComm.FillDataSetSchema myDataSet, _
       SchemaType.Mapped
   ' Display the contents of myDataTable
   myMsgBox myDataTable.ToString
End Sub

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DBDataSetCommand.FillDataSetSchema (DataSet, SchemaType, String)

Fills the data set with the schema based upon the chosen SchemaType and a given source table.

[Visual Basic]
Overloads Overridable Public Function FillDataSetSchema( _
   ByVal dataSet As DataSet, _
   ByVal schemaType As SchemaType, _
   ByVal srcTable As String _
) As DataTable ()
[C#]
public virtual DataTable[] FillDataSetSchema(
   DataSet dataSet,
   SchemaType schemaType,
   string srcTable
);
[C++]
public: virtual DataTable* FillDataSetSchema(
   DataSet* dataSet,
   SchemaType schemaType,
   String* srcTable
) [];
[JScript]
public function FillDataSetSchema(
   dataSet : DataSet,
   schemaType : SchemaType,
   srcTable : String
) : DataTable[];

Parameters

dataSet
A DataSet to insert the schema into.
schemaType
One of the SchemaType values that specify how to insert the schema.
srcTable
The name of the source table to be used for table mapping.

Return Value

A DataTable filled with records from the DataSet.

Exceptions

Exception Type | Condition
FillDataSetSchemaRequiresSourceTable | A source table could not be found to get the schema from.

Remarks

Notes to Inheritors: When overriding FillDataSetSchema in a derived class, be sure to call the base class's FillDataSetSchema method.

Example [Visual Basic]

The following example fills a DataSet with the schema only, while filling a DataTable with records, when provided a source table.

[Visual Basic]

Public Sub MyFillDataTableAndSet(myDataTable   As DataTable, _
         myDataSet     As DataSet, _
         myDataSetComm As ADODataSetCommand,
         mySrcTable    As String)
   ' Create a MessageBox to show the contents of myDataTable in
   Dim myMsgBox As MessageBox
   ' Populate myDataTable with records and myDataSet with schema
   myDataTable = myDataSetComm.FillDataSetSchema myDataSet, _
      SchemaType.Source, mySrcTable
   ' Display the contents of myDataTable
   myMsgBox myDataTable.ToString
End Sub

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace | DBDataSetCommand.FillDataSetSchema Overload List


DBDataSetCommand.FillDataSetSchema (DataSet, SchemaType)

Fills the data set with the schema based upon the chosen SchemaType.

[Visual Basic]
Overloads Overrides Public Function FillDataSetSchema( _
   ByVal dataSet As DataSet, _
   ByVal schemaType As SchemaType _
) As DataTable ()
[C#]
public override DataTable[] FillDataSetSchema(
   DataSet dataSet,
   SchemaType schemaType
);
[C++]
public: override DataTable* FillDataSetSchema(
   DataSet* dataSet,
   SchemaType schemaType
) [];
[JScript]
public override function FillDataSetSchema(
   dataSet : DataSet,
   schemaType : SchemaType
) : DataTable[];

Parameters

dataSet
A DataSet to insert the schema into.
schemaType
One of the SchemaType values that specify how to insert the schema.

Return Value

A DataTable filled with records from the DataSet.

Exceptions

Exception Type | Condition
FillDataSetSchemaRequiresSourceTable | A source table could not be found to get the schema from.

Example [Visual Basic]

The following example fills a DataSet with the schema only, while filling a DataTable with records.

[Visual Basic]

Public Sub MyFillDataTableAndSet(myDataTable   As DataTable, _
         myDataSet     As DataSet, _
         myDataSetComm As ADODataSetCommand)
   ' Create a MessageBox to show the contents of myDataTable in
   Dim myMsgBox As MessageBox
   ' Populate myDataTable with records and myDataSet with schema
   myDataTable = myDataSetComm.FillDataSetSchema myDataSet, _
       SchemaType.Mapped
   ' Display the contents of myDataTable
   myMsgBox myDataTable.ToString
End Sub

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace | DBDataSetCommand.FillDataSetSchema Overload List


DBDataSetCommand.FixupDataCommand

[To be supplied.]

[Visual Basic]
Overridable Protected Sub FixupDataCommand( _
   ByVal command As DBCommand, _
   ByVal updateType As Integer, _
   ByVal row As DataRow, _
   ByVal mappings As DataColumnMappings _
)
[C#]
protected virtual void FixupDataCommand(
   DBCommand command,
   int updateType,
   DataRow row,
   DataColumnMappings mappings
);
[C++]
protected: virtual void FixupDataCommand(
   DBCommand* command,
   int updateType,
   DataRow* row,
   DataColumnMappings* mappings
);
[JScript]
protected function FixupDataCommand(
   command : DBCommand,
   updateType : int,
   row : DataRow,
   mappings : DataColumnMappings
);

Parameters

command
[To be supplied.]
updateType
[To be supplied.]
row
[To be supplied.]
mappings
[To be supplied.]

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DBDataSetCommand.ForceGenerateUpdateCommand

Force the generation of the insert, update, or delete commands from the select command.

[Visual Basic]
MustOverride Protected Sub ForceGenerateUpdateCommand( _
   ByVal updateType As Integer, _
   ByVal optimisticQueries As Boolean, _
   ByVal refreshStatement As Boolean, _
   ByVal forStoredProcedure As Boolean, _
   ByRef sessionState As Object _
)
[C#]
protected abstract void ForceGenerateUpdateCommand(
   int updateType,
   bool optimisticQueries,
   bool refreshStatement,
   bool forStoredProcedure,
   ref object sessionState
);
[C++]
protected: virtual void ForceGenerateUpdateCommand(
   int updateType,
   bool optimisticQueries,
   bool refreshStatement,
   bool forStoredProcedure,
   Object** sessionState
) = 0;
[JScript]
protected abstract function ForceGenerateUpdateCommand(
   updateType : int,
   optimisticQueries : Boolean,
   refreshStatement : Boolean,
   forStoredProcedure : Boolean,
   sessionState : Object
);

Parameters

updateType
[To be supplied.]
optimisticQueries
true to make optimistic queries; otherwise, false.
refreshStatement
true to refresh the query statement; otherwise, false.
forStoredProcedure
true to use the query statement to when generating a stored procedure; otherwise, false.
sessionState
[To be supplied.]

Exceptions

Exception Type | Condition
ADP.ExecuteRequiresConnection | The SelectCommand or its ActiveConnection has not been initialized.

Example [Visual Basic]

The following example will force the generation of the insert, delete and update commands using optimistic queries, refresh statements, and no stored procedures.

[Visual Basic]

Sub CreateCommAndForceUpdate ()
    Dim myConnectText As String
    Dim mySelect As String
    Dim myConnect As ADOConnection
    Dim myDataSetComm As ADODataSetCommand
    ' Initialize the data set command
    myDataSetComm = New ADODataSetCommand
    ' Set my connection text
    myConnectText = "Provider=SQLADO.1;User ID=sa;PASSWORD=;" _
  + "Initial Catalog=Northwind;Data Source=vbsql7;"
    ' Inititalize my connection object
    myConnect = New ADOConnection myConnectText
    ' Set my select command text
    mySelect = "SELECT intID, vchFirstName, vchLastName, " _
 + "chState FROM Customers"
    ' Set the select command
    Set myDataSetComm.SelectCommand.CommandText = mySelect
    ' Set the connection for select command to use
    Set myDataSetComm.SelectCommand.ActiveConnection = myConnect
    ' force generation of delete, insert, and update commands
    Try
       ' make optimistic queries, refresh statements, no stored procedures
       myDatSetComm.ForceGenerateUpdateCommands true, true, false
    Catch e As ExecuteRequiresConnection
       ' No connection to a data store found
       Dim msgBox As MessageBox
       msgBox.Show "The Select command or its active connection have" _
     + " not been initialized ..."
    End Try
 End Sub

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace | InsertCommand | UpdateCommand | DeleteCommand | SelectCommand


DBDataSetCommand.GenerateUpdateCommands

Generates the insert, update, or delete commands when each is in a default state.

[Visual Basic]
Public Sub GenerateUpdateCommands( _
   ByVal optimisticQueries As Boolean, _
   ByVal refreshStatement As Boolean, _
   ByVal forStoredProcedure As Boolean _
)
[C#]
public void GenerateUpdateCommands(
   bool optimisticQueries,
   bool refreshStatement,
   bool forStoredProcedure
);
[C++]
public: void GenerateUpdateCommands(
   bool optimisticQueries,
   bool refreshStatement,
   bool forStoredProcedure
);
[JScript]
public function GenerateUpdateCommands(
   optimisticQueries : Boolean,
   refreshStatement : Boolean,
   forStoredProcedure : Boolean
);

Parameters

optimisticQueries
true to make optimistic queries; otherwise, false.
refreshStatement
true to refresh the query statement; otherwise, false.
forStoredProcedure
true to use the query statement to when generating a stored procedure; otherwise, false.

Exceptions

Exception Type | Condition
ExecuteRequiresConnection | The connection does not exist.

Example [Visual Basic]

The following example generates the insert, delete, and update commands using optimistic queries, refresh statements and stored procedures.

[Visual Basic]

Sub CreateCommAndUpdate ()
    Dim myConnectText As String
    Dim mySelect As String
    Dim myConnect As ADOConnection
    Dim myDataSetComm As ADODataSetCommand
    ' Initialize the data set command
    myDataSetComm = New ADODataSetCommand
    ' Set my connection text
    myConnectText = "Provider=SQLADO.1;User ID=sa;PASSWORD=;" _
  + "Initial Catalog=Northwind;Data Source=vbsql7;"
    ' Inititalize my connection object
    myConnect = New ADOConnection myConnectText
    ' Set my select command text
    mySelect = "SELECT intID, vchFirstName, vchLastName, " _
 + "chState FROM Customers"
    ' Set the select command
    Set myDataSetComm.SelectCommand.CommandText = mySelect
    ' Set the connection for select command to use
    Set myDataSetComm.SelectCommand.ActiveConnection = myConnect
    ' generate commands with optimistic queries, refreshed statements, and stored procedures
    myDatSetComm.GenerateUpdateCommands true, true, true
 End Sub

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DBDataSetCommand.GetDeleteCommandObject

[To be supplied.]

[Visual Basic]
Protected Function GetDeleteCommandObject() As DBCommand
[C#]
protected DBCommand GetDeleteCommandObject();
[C++]
protected: DBCommand* GetDeleteCommandObject();
[JScript]
protected function GetDeleteCommandObject() : DBCommand;

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DBDataSetCommand.GetFillDataSetParameters

Returns all parameters used when performing the select command.

[Visual Basic]
Overrides Public Function GetFillDataSetParameters() As _
   IDataParameter ()
[C#]
public override IDataParameter[] GetFillDataSetParameters();
[C++]
public: override IDataParameter* GetFillDataSetParameters() [];
[JScript]
public override function GetFillDataSetParameters() :
   IDataParameter
   ;

Return Value

A collection of IDataParameter objects that contain all the parameters used by the SelectCommand.

Example [Visual Basic]

The following example creates an array of IDataParameter and sets it to all the select command parameters.

[Visual Basic]

Sub ShowAllDataParams()
    Dim myDataSetComm As ADODataSetCommand
    ' Initialize the ADODataSetCommand
    myDataSetComm = New ADODataSetCommand
    ' Create array to place data parameters in
    Dim myParams() As IDataParameter
    ' Create temporary parameter for loop
    Dim tempParam As IDataParameter
    ' Create message box to display parameters
    Dim myMsgBox As MessageBox
    ' Create the string for the message box
    Dim myMessage As String
    ' Return all parameters to myParams
    myParams = myDataSetComm.GetFillDataSetParameters
    ' Initialize myMessage
    myMessage = ""
    ' loop through all parameters extracting name, column, and value
    For Each tempParam In myParams
       myMessage += "Name: " + tempParam.ParameterName + "  Column: " _
     + tempParam.SourceColumn + "\n"
    Next
    ' Display the list of parameter names
    myMsgBox.Show myMessage

 End Sub

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DBDataSetCommand.GetInsertCommandObject

[To be supplied.]

[Visual Basic]
Protected Function GetInsertCommandObject() As DBCommand
[C#]
protected DBCommand GetInsertCommandObject();
[C++]
protected: DBCommand* GetInsertCommandObject();
[JScript]
protected function GetInsertCommandObject() : DBCommand;

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DBDataSetCommand.GetSelectCommandObject

[To be supplied.]

[Visual Basic]
Protected Function GetSelectCommandObject() As DBCommand
[C#]
protected DBCommand GetSelectCommandObject();
[C++]
protected: DBCommand* GetSelectCommandObject();
[JScript]
protected function GetSelectCommandObject() : DBCommand;

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DBDataSetCommand.GetUpdateCommandObject

[To be supplied.]

[Visual Basic]
Protected Function GetUpdateCommandObject() As DBCommand
[C#]
protected DBCommand GetUpdateCommandObject();
[C++]
protected: DBCommand* GetUpdateCommandObject();
[JScript]
protected function GetUpdateCommandObject() : DBCommand;

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DBDataSetCommand.IsValidDataCommand

[To be supplied.]

[Visual Basic]
MustOverride Protected Function IsValidDataCommand( _
   ByVal value As DBCommand _
) As Boolean
[C#]
protected abstract bool IsValidDataCommand(
   DBCommand value
);
[C++]
protected: virtual bool IsValidDataCommand(
   DBCommand* value
) = 0;
[JScript]
protected abstract function IsValidDataCommand(
   value : DBCommand
) : Boolean;

Parameters

value
[To be supplied.]

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DBDataSetCommand.OnRowUpdated

Raises the OnRowUpdated event.

[Visual Basic]
MustOverride Protected Sub OnRowUpdated( _
   ByVal ruevent As RowUpdatedEventArgs _
)
[C#]
protected abstract void OnRowUpdated(
   RowUpdatedEventArgs ruevent
);
[C++]
protected: virtual void OnRowUpdated(
   RowUpdatedEventArgs* ruevent
) = 0;
[JScript]
protected abstract function OnRowUpdated(
   ruevent : RowUpdatedEventArgs
);

Parameters

ruevent
A ADORowUpdatedEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see TBD.

Notes to Inheritors: When overriding OnRowUpdated in a derived class, be sure to call the base class's OnRowUpdated method.

Example [Visual Basic]

The following example uses this method within a derived class.

[Visual Basic]

' MyDataSetCommand.class derived from ADODataSetCommand
Inherits ADODataSetCommand
' create the method for row updated
Public Sub OnRowUpdated(event As RowUpdatedEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row has been updated."
   '  call the base class method
   MyBase.OnRowUpdated event
End Sub
' create the method for row updating
Public Sub OnRowUpdating(event As RowUpdatingEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row is being updated ..."
   '  call the base class method
   MyBase.OnRowUpdating event
End Sub
' create the method for the schema changing
Public Sub OnSchemaChanging(event As SchemaChangingEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is changing ..."
   '  call the base class method
   MyBase.OnSchemaChanging event
End Sub
' create the method for the schema changed
Public Sub OnSchemaChanged(event As SchemaChangedEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema has changed"
   '  call the base class method
   MyBase.OnSchemaChanged event
End Sub
' create the method for the schema being mapped
Public Sub OnSchemaMapping(event As SchemaMappingEventArgs)
   ' show a message box telling the user of schema map
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is currently being mapped ..."
   ' call the base class method
   MyBase.OnSchemaMapping event
End Sub

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace | OnRowUpdating


DBDataSetCommand.OnRowUpdating

Raises the OnRowUpdating event.

[Visual Basic]
MustOverride Protected Sub OnRowUpdating( _
   ByVal ruevent As RowUpdatingEventArgs _
)
[C#]
protected abstract void OnRowUpdating(
   RowUpdatingEventArgs ruevent
);
[C++]
protected: virtual void OnRowUpdating(
   RowUpdatingEventArgs* ruevent
) = 0;
[JScript]
protected abstract function OnRowUpdating(
   ruevent : RowUpdatingEventArgs
);

Parameters

ruevent
A ADORowUpdatingEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see TBD.

Notes to Inheritors: When overriding OnRowUpdating in a derived class, be sure to call the bases class's OnRowUpdating method.

Example [Visual Basic]

The following example uses this method within a derived class.

[Visual Basic]

' MyDataSetCommand.class derived from ADODataSetCommand
Inherits ADODataSetCommand
' create the method for row updated
Public Sub OnRowUpdated(event As RowUpdatedEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row has been updated."
   '  call the base class method
   MyBase.OnRowUpdated event
End Sub
' create the method for row updating
Public Sub OnRowUpdating(event As RowUpdatingEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row is being updated ..."
   '  call the base class method
   MyBase.OnRowUpdating event
End Sub
' create the method for the schema changing
Public Sub OnSchemaChanging(event As SchemaChangingEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is changing ..."
   '  call the base class method
   MyBase.OnSchemaChanging event
End Sub
' create the method for the schema changed
Public Sub OnSchemaChanged(event As SchemaChangedEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema has changed"
   '  call the base class method
   MyBase.OnSchemaChanged event
End Sub
' create the method for the schema being mapped
Public Sub OnSchemaMapping(event As SchemaMappingEventArgs)
   ' show a message box telling the user of schema map
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is currently being mapped ..."
   ' call the base class method
   MyBase.OnSchemaMapping event
End Sub

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace | OnRowUpdated


DBDataSetCommand.OnSchemaMapping

Raises the OnSchemaMapping event.

[Visual Basic]
MustOverride Protected Sub OnSchemaMapping( _
   ByVal scevent As SchemaMappingEventArgs _
)
[C#]
protected abstract void OnSchemaMapping(
   SchemaMappingEventArgs scevent
);
[C++]
protected: virtual void OnSchemaMapping(
   SchemaMappingEventArgs* scevent
) = 0;
[JScript]
protected abstract function OnSchemaMapping(
   scevent : SchemaMappingEventArgs
);

Parameters

scevent
A ADOSchemaMappingEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see TBD.

Notes to Inheritors: When overriding OnSchemaMapping in a derived class, be sure to call the bases class's OnSchemaMapping method.

Example [Visual Basic]

The following example uses this method within a derived class.

[Visual Basic]

' MyDataSetCommand.class derived from ADODataSetCommand
Inherits ADODataSetCommand
' create the method for row updated
Public Sub OnRowUpdated(event As RowUpdatedEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row has been updated."
   '  call the base class method
   MyBase.OnRowUpdated event
End Sub
' create the method for row updating
Public Sub OnRowUpdating(event As RowUpdatingEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row is being updated ..."
   '  call the base class method
   MyBase.OnRowUpdating event
End Sub
' create the method for the schema changing
Public Sub OnSchemaChanging(event As SchemaChangingEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is changing ..."
   '  call the base class method
   MyBase.OnSchemaChanging event
End Sub
' create the method for the schema changed
Public Sub OnSchemaChanged(event As SchemaChangedEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema has changed"
   '  call the base class method
   MyBase.OnSchemaChanged event
End Sub
' create the method for the schema being mapped
Public Sub OnSchemaMapping(event As SchemaMappingEventArgs)
   ' show a message box telling the user of schema map
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is currently being mapped ..."
   ' call the base class method
   MyBase.OnSchemaMapping event
End Sub

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DBDataSetCommand.ParameterOutput

[To be supplied.]

[Visual Basic]
Protected Sub ParameterOutput( _
   ByVal parameters As IDataParameters, _
   ByVal row As DataRow, _
   ByVal mappings As DataColumnMappings _
)
[C#]
protected void ParameterOutput(
   IDataParameters parameters,
   DataRow row,
   DataColumnMappings mappings
);
[C++]
protected: void ParameterOutput(
   IDataParameters* parameters,
   DataRow* row,
   DataColumnMappings* mappings
);
[JScript]
protected function ParameterOutput(
   parameters : IDataParameters,
   row : DataRow,
   mappings : DataColumnMappings
);

Parameters

parameters
[To be supplied.]
row
[To be supplied.]
mappings
[To be supplied.]

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DBDataSetCommand.SetDeleteCommandObject

[To be supplied.]

[Visual Basic]
Protected Sub SetDeleteCommandObject( _
   ByVal value As DBCommand _
)
[C#]
protected void SetDeleteCommandObject(
   DBCommand value
);
[C++]
protected: void SetDeleteCommandObject(
   DBCommand* value
);
[JScript]
protected function SetDeleteCommandObject(
   value : DBCommand
);

Parameters

value
[To be supplied.]

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DBDataSetCommand.SetInsertCommandObject

[To be supplied.]

[Visual Basic]
Protected Sub SetInsertCommandObject( _
   ByVal value As DBCommand _
)
[C#]
protected void SetInsertCommandObject(
   DBCommand value
);
[C++]
protected: void SetInsertCommandObject(
   DBCommand* value
);
[JScript]
protected function SetInsertCommandObject(
   value : DBCommand
);

Parameters

value
[To be supplied.]

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DBDataSetCommand.SetSelectCommandObject

[To be supplied.]

[Visual Basic]
Protected Sub SetSelectCommandObject( _
   ByVal value As DBCommand _
)
[C#]
protected void SetSelectCommandObject(
   DBCommand value
);
[C++]
protected: void SetSelectCommandObject(
   DBCommand* value
);
[JScript]
protected function SetSelectCommandObject(
   value : DBCommand
);

Parameters

value
[To be supplied.]

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DBDataSetCommand.SetUpdateCommandObject

[To be supplied.]

[Visual Basic]
Protected Sub SetUpdateCommandObject( _
   ByVal value As DBCommand _
)
[C#]
protected void SetUpdateCommandObject(
   DBCommand value
);
[C++]
protected: void SetUpdateCommandObject(
   DBCommand* value
);
[JScript]
protected function SetUpdateCommandObject(
   value : DBCommand
);

Parameters

value
[To be supplied.]

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DBDataSetCommand.Update

Calls the respective insert, update, or delete commands on the connection, for each inserted, updated, or deleted rows in the data set.

Overload List

Calls the respective insert, update, or delete commands on the connection, for each inserted, updated, or deleted rows in the data set for a given source table.

[Visual Basic] Overloads Overridable Public Function Update(DataRow()) As Integer
[C#] public virtual int Update(DataRow[]);
[C++] public: virtual int Update(DataRow*[]);
[JScript] public function Update(DataRow[]) : int;

Calls the respective insert, update, or delete commands on the connection, for each inserted, updated, or deleted rows in the data set for a given source table.

[Visual Basic] Overloads Overridable Public Function Update(DataSet, String) As Integer
[C#] public virtual int Update(DataSet, String);
[C++] public: virtual int Update(DataSet*, String);
[JScript] public function Update(DataSet, String) : int;

Calls the respective insert, update, or delete commands on the connection for each inserted, updated, or deleted row in the data set for the given DataSet.

[Visual Basic] Overloads Overrides Public Function Update(DataSet) As Integer
[C#] public override int Update(DataSet);
[C++] public: override int Update(DataSet*);
[JScript] public override function Update(DataSet) : int;

Example [Visual Basic]

The following example creates and initializes a DataSet and an ADODataSetCommand. The example then uses the Update method to update the DataSet and the data source.

Note This example shows how to use one of the overloaded versions of Update. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Sub CreateAndUpdateDataSet()
     Const strConnection = "Provider=SQLADO.1;User ID=sa;PASSWORD=;" _
         + "Initial Catalog=Northwind;Data Source=vbsql7;"
     Const strSelectCommand = "SELECT intID, vchFirstName, vchLastName, " _
+ "chState FROM Customers WHERE chState = 'CA'"
     Const strUpdateCommand = "UPDATE tblCustomer SET vchFirstName = ?, " _
+ "vchLastName = ?, chState = ? WHERE intID = ?"
     Dim dataSet        As DataSet
     Dim adoConnection  As ADOConnection
     Dim adoDataSetComm As ADODataSetCommand
     Dim adoParam       As ADOParameter
     ' Initialize the DataSet
     Set dataSet = New DataSet
     ' Initialize the connection
     Set adoConnection = New ADOConnection(strConnection)
     ' Initialize the new ADODataSetCommand object
     Set adoDataSetComm = New ADODataSetCommand
     ' Set the table that the ADODataSetCommand is to map to
     adoDataSetComm.TableMappings.Add "Customers", "Customer"
     ' Set the select command
     Set adoDataSetComm.SelectCommand.CommandText = strSelectCommand
     ' Set the active connection for our ADODataSetCommand
     Set adoDataSetComm.SelectCommand.ActiveConnection = adoConnection
     ' Populate the DataSet
     adoDataSetComm.FillDataSet dataSet, "Customers"
     ' Set the command text to the text of the query
     adoDataSetComm.UpdateCommand.CommandText = strUpdateCommand
     ' Set the command's connection to the current connection
     Set adoDataSetComm.UpdateCommand.ActiveConnection = adoConnection
     ' Set any parameters for this command
     Set adoParam = adoDataSetComm.UpdateCommand.parameters.Add( _
 "vchFirstName", ADODBType.VarChar, 50)
     adoParam.SourceColumn = "vchFirstName"
     Set adoParam = adoDataSetComm.UpdateCommand.parameters.Add( _
  "vchLastName", ADODBType.VarChar, 50)
     adoParam.SourceColumn = "vchLastName"
     Set adoParam = adoDataSetComm.UpdateCommand.parameters.Add( _
  "chState", ADODBType.Char, 2)
     adoParam.SourceColumn = "chState"
     Set adoParam = adoDataSetComm.UpdateCommand.parameters.Add( _
  "intID", ADODBType.Integer)
     adoParam.SourceColumn = "intID"

     ' this uses the UPDATE statement above
     adoConnection.BeginTransaction
     Try
         ' Update the data source with changes made in dataSet
         adoDataSetComm.Update dataSet
         adoConnection.CommitTransaction
     Catch e As Exception
         Dim displayBox As New MessageBox
         displayBox.Show "Error while updating data source - rolling back transaction..."
         adoConnection.RollbackTransaction
     End Try
     adoConnection.close
 End Sub

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DBDataSetCommand.Update (DataRow[])

Calls the respective insert, update, or delete commands on the connection, for each inserted, updated, or deleted rows in the data set for a given source table.

[Visual Basic]
Overloads Overridable Public Function Update( _
   ByVal dataRows() As DataRow _
) As Integer
[C#]
public virtual int Update(
   DataRow[] dataRows
);
[C++]
public: virtual int Update(
   DataRow* dataRows[]
);
[JScript]
public function Update(
   dataRows : DataRow[]
) : int;

Parameters

dataRows
An array of DataRow objects to update.

Exceptions

Exception Type | Condition
UpdateRequiresDataSet | The DataSet is invalid.
UpdateRequiresSourceTable | The source table is invalid.
UpdateNullRows | No DataRow exists to update.
UpdateNullRowTable | No DataTable exists to update.
UpdateNullRowTableDataSet | No DataSet exists to use as a source.

Remarks

All the elements in the array of DataRow objects must come from the same DataTable.

This method pulls rows from the table listed in the first mapping before running an update. The adapter will clone the insert, update, or delete command appropriate for the row. Then the OnRowUpdating event is raised, allowing the user to inspect the DataSet row, modify the cloned DBCommand, or cancel the default processing. The cloned command is then executed against the data source. If the cloned command is configured incorrectly, an error will be raised. The adapter then will refresh the row according to UpdateRowSource property of the DBCommand. Any additional rows returned will be ignored. After any data is loaded back into the DataSet, the OnRowUpdated event is raised, allowing the user to inspect the reconciled DataSet row and any output parameters returned by the DBCommand. When the OnRowUpdated event returns, the adapter releases the cloned copy of the command and any changes made to it between the events are lost. After a row updates successfully, the changes to that row will have been accepted. If the connection was closed prior to Update, the adapter will close the DBConnection.

Notes to Inheritors: When overriding Update in a derived class, be sure to call the base class's Update method.

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace | DBDataSetCommand.Update Overload List


DBDataSetCommand.Update (DataSet, String)

Calls the respective insert, update, or delete commands on the connection, for each inserted, updated, or deleted rows in the data set for a given source table.

[Visual Basic]
Overloads Overridable Public Function Update( _
   ByVal dataSet As DataSet, _
   ByVal srcTable As String _
) As Integer
[C#]
public virtual int Update(
   DataSet dataSet,
   string srcTable
);
[C++]
public: virtual int Update(
   DataSet* dataSet,
   String* srcTable
);
[JScript]
public function Update(
   dataSet : DataSet,
   srcTable : String
) : int;

Parameters

dataSet
The DataSet to update.
srcTable
The source table used for the table mappings.

Exceptions

Exception Type | Condition
UpdateRequiresDataSet | The DataSet is invalid.
UpdateRequiresSourceTable | The source table is invalid.

Remarks

This method pulls rows from the table listed in the first mapping before running an update. The adapter will clone the insert, update, or delete command appropriate for the row. Then the OnRowUpdating event is raised, allowing the user to inspect the DataSet row, modify the cloned DBCommand, or cancel the default processing. The cloned command is then executed against the data source. If the cloned command is configured incorrectly, an error will be raised. The adapter then will refresh the row according to UpdateRowSource property of the DBCommand. Any additional rows returned will be ignored. After any data is loaded back into the DataSet, the OnRowUpdated event is raised, allowing the user to inspect the reconciled DataSet row and any output parameters returned by the DBCommand. When the OnRowUpdated event returns, the adapter releases the cloned copy of the command and any changes made to it between the events are lost. After a row updates successfully, the changes to that row will have been accepted. If the connection was closed prior to Update, the adapter will close the DBConnection.

Notes to Inheritors: When overriding Update in a derived class, be sure to call the base class's Update method.

Example [Visual Basic]

The following example creates and initializes a DataSet and an ADODataSetCommand. The example then uses the Update method to update the DataSet and the data source.

[Visual Basic]

Sub CreateAndUpdateDataSet()
     Const strConnection = "Provider=SQLADO.1;User ID=sa;PASSWORD=;" _
         + "Initial Catalog=Northwind;Data Source=vbsql7;"
     Const strSelectCommand = "SELECT intID, vchFirstName, vchLastName, " _
+ "chState FROM Customers WHERE chState = 'CA'"
     Const strUpdateCommand = "UPDATE tblCustomer SET vchFirstName = ?, " _
+ "vchLastName = ?, chState = ? WHERE intID = ?"
     Dim dataSet        As DataSet
     Dim adoConnection  As ADOConnection
     Dim adoDataSetComm As ADODataSetCommand
     Dim adoParam       As ADOParameter
     ' Initialize the DataSet
     Set dataSet = New DataSet
     ' Initialize the connection
     Set adoConnection = New ADOConnection(strConnection)
     ' Initialize the new ADODataSetCommand object
     Set adoDataSetComm = New ADODataSetCommand
     ' Set the table that the ADODataSetCommand is to map to
     adoDataSetComm.TableMappings.Add "Customers", "Customer"
     ' Set the select command
     Set adoDataSetComm.SelectCommand.CommandText = strSelectCommand
     ' Set the active connection for our ADODataSetCommand
     Set adoDataSetComm.SelectCommand.ActiveConnection = adoConnection
     ' Populate the DataSet
     adoDataSetComm.FillDataSet dataSet, "Customers"
     ' Set the command text to the text of the query
     adoDataSetComm.UpdateCommand.CommandText = strUpdateCommand
     ' Set the command's connection to the current connection
     Set adoDataSetComm.UpdateCommand.ActiveConnection = adoConnection
     ' Set any parameters for this command
     Set adoParam = adoDataSetComm.UpdateCommand.parameters.Add( _
 "vchFirstName", ADODBType.VarChar, 50)
     adoParam.SourceColumn = "vchFirstName"
     Set adoParam = adoDataSetComm.UpdateCommand.parameters.Add( _
  "vchLastName", ADODBType.VarChar, 50)
     adoParam.SourceColumn = "vchLastName"
     Set adoParam = adoDataSetComm.UpdateCommand.parameters.Add( _
  "chState", ADODBType.Char, 2)
     adoParam.SourceColumn = "chState"
     Set adoParam = adoDataSetComm.UpdateCommand.parameters.Add( _
  "intID", ADODBType.Integer)
     adoParam.SourceColumn = "intID"

     ' this uses the UPDATE statement above
     adoConnection.BeginTransaction
     Try
         ' Update the data source with changes made in dataSet
         adoDataSetComm.Update dataSet, "Customers"
         adoConnection.CommitTransaction
     Catch e As Exception
         Dim displayBox As New MessageBox
         displayBox.Show "Error while updating data source - rolling back transaction..."
         adoConnection.RollbackTransaction
     End Try
     adoConnection.close
 End Sub

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace | DBDataSetCommand.Update Overload List | DBCommand | DBConnection


DBDataSetCommand.Update (DataSet)

Calls the respective insert, update, or delete commands on the connection for each inserted, updated, or deleted row in the data set for the given DataSet.

[Visual Basic]
Overloads Overrides Public Function Update( _
   ByVal dataSet As DataSet _
) As Integer
[C#]
public override int Update(
   DataSet dataSet
);
[C++]
public: override int Update(
   DataSet* dataSet
);
[JScript]
public override function Update(
   dataSet : DataSet
) : int;

Parameters

dataSet
The DataSet to update.

Exceptions

Exception Type | Condition
UpdateRequiresSourceTable | A source table could not be found.

Remarks

This method pulls rows from the table listed in the first mapping before running an update. The adapter will clone the insert, update, or delete command appropriate for the row. Then the OnRowUpdating event is raised, allowing the user to inspect the DataSet row, modify the cloned ADOCommand, or cancel the default processing. The cloned command is then executed against the data source. If the cloned command is configured incorrectly, an error will be raised. The adapter then will refresh the row according to UpdateRowSource property of the ADOCommand. Any additional rows returned will be ignored. After any data is loaded back into the DataSet, the OnRowUpdated event is raised, allowing the user to inspect the reconciled DataSet row and any output parameters returned by the ADOCommand. When the OnRowUpdated event returns, the adapter releases the cloned copy of the command and any changes made to it between the events are lost. After a row updates successfully, the changes to that row will have been accepted. If the connection was closed prior to Update, the adapter will close the ADOConnection.

Example [Visual Basic]

The following example creates and initializes a DataSet and an ADODataSetCommand. The example then uses the Update method to update the DataSet and the data source.

[Visual Basic]

Sub CreateAndUpdateDataSet()
     Const strConnection = "Provider=SQLADO.1;User ID=sa;PASSWORD=;" _
         + "Initial Catalog=Northwind;Data Source=vbsql7;"
     Const strSelectCommand = "SELECT intID, vchFirstName, vchLastName, " _
+ "chState FROM Customers WHERE chState = 'CA'"
     Const strUpdateCommand = "UPDATE tblCustomer SET vchFirstName = ?, " _
+ "vchLastName = ?, chState = ? WHERE intID = ?"
     Dim dataSet        As DataSet
     Dim adoConnection  As ADOConnection
     Dim adoDataSetComm As ADODataSetCommand
     Dim adoParam       As ADOParameter
     ' Initialize the DataSet
     Set dataSet = New DataSet
     ' Initialize the connection
     Set adoConnection = New ADOConnection(strConnection)
     ' Initialize the new ADODataSetCommand object
     Set adoDataSetComm = New ADODataSetCommand
     ' Set the table that the ADODataSetCommand is to map to
     adoDataSetComm.TableMappings.Add "Customers", "Customer"
     ' Set the select command
     Set adoDataSetComm.SelectCommand.CommandText = strSelectCommand
     ' Set the active connection for our ADODataSetCommand
     Set adoDataSetComm.SelectCommand.ActiveConnection = adoConnection
     ' Populate the DataSet
     adoDataSetComm.FillDataSet dataSet, "Customers"
     ' Set the command text to the text of the query
     adoDataSetComm.UpdateCommand.CommandText = strUpdateCommand
     ' Set the command's connection to the current connection
     Set adoDataSetComm.UpdateCommand.ActiveConnection = adoConnection
     ' Set any parameters for this command
     Set adoParam = adoDataSetComm.UpdateCommand.parameters.Add( _
 "vchFirstName", ADODBType.VarChar, 50)
     adoParam.SourceColumn = "vchFirstName"
     Set adoParam = adoDataSetComm.UpdateCommand.parameters.Add( _
  "vchLastName", ADODBType.VarChar, 50)
     adoParam.SourceColumn = "vchLastName"
     Set adoParam = adoDataSetComm.UpdateCommand.parameters.Add( _
  "chState", ADODBType.Char, 2)
     adoParam.SourceColumn = "chState"
     Set adoParam = adoDataSetComm.UpdateCommand.parameters.Add( _
  "intID", ADODBType.Integer)
     adoParam.SourceColumn = "intID"

     ' this uses the UPDATE statement above
     adoConnection.BeginTransaction
     Try
         ' Update the data source with changes made in dataSet
         adoDataSetComm.Update dataSet
         adoConnection.CommitTransaction
     Catch e As Exception
         Dim displayBox As New MessageBox
         displayBox.Show "Error while updating data source - rolling back transaction..."
         adoConnection.RollbackTransaction
     End Try
     adoConnection.close
 End Sub

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace | DBDataSetCommand.Update Overload List | ADOCommand | ADOConnection


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DBDataSetCommand Fields

The fields of the DBDataSetCommand class are listed below. For a complete list of DBDataSetCommand class members, see the DBDataSetCommand Members topic.

Public:

DefaultSourceTableName The default name for source tables to be used when the DBDataSetCommand is initialized.

Protected:

commands | [To be supplied.]
DELETE_INDEX | [To be supplied.]
INSERT_INDEX | [To be supplied.]
SELECT_INDEX | [To be supplied.]
UPDATE_INDEX | [To be supplied.]

See Also

DBDataSetCommand Class | System.Data.Internal Namespace


DBDataSetCommand.commands

[To be supplied.]

[Visual Basic]
Protected commands() As DBCommand
[C#]
protected DBCommand[] commands;
[C++]
protected: DBCommand* commands[];
[JScript]
protected var commands : DBCommand[];

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DBDataSetCommand.DefaultSourceTableName

The default name for source tables to be used when the DBDataSetCommand is initialized.

[Visual Basic]
Public Const DefaultSourceTableName As String
[C#]
public const string DefaultSourceTableName;
[C++]
public: const String* DefaultSourceTableName;
[JScript]
public var DefaultSourceTableName : String;

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DBDataSetCommand.DELETE_INDEX

[To be supplied.]

[Visual Basic]
Protected Const DELETE_INDEX As Integer
[C#]
protected const int DELETE_INDEX;
[C++]
protected: const int DELETE_INDEX;
[JScript]
protected var DELETE_INDEX : int;

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DBDataSetCommand.INSERT_INDEX

[To be supplied.]

[Visual Basic]
Protected Const INSERT_INDEX As Integer
[C#]
protected const int INSERT_INDEX;
[C++]
protected: const int INSERT_INDEX;
[JScript]
protected var INSERT_INDEX : int;

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DBDataSetCommand.SELECT_INDEX

[To be supplied.]

[Visual Basic]
Protected Const SELECT_INDEX As Integer
[C#]
protected const int SELECT_INDEX;
[C++]
protected: const int SELECT_INDEX;
[JScript]
protected var SELECT_INDEX : int;

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DBDataSetCommand.UPDATE_INDEX

[To be supplied.]

[Visual Basic]
Protected Const UPDATE_INDEX As Integer
[C#]
protected const int UPDATE_INDEX;
[C++]
protected: const int UPDATE_INDEX;
[JScript]
protected var UPDATE_INDEX : int;

See Also

DBDataSetCommand Class | DBDataSetCommand Members | System.Data.Internal Namespace


DecimalStorage Class

[To be supplied.]

Object
DataStorage
DecimalStorage

[Visual Basic]
Public Class DecimalStorage
   Inherits DataStorage
[C#]
public class DecimalStorage : DataStorage
[C++]
public __gc class DecimalStorage : public DataStorage
[JScript]
public class DecimalStorage extends DataStorage

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

DecimalStorage Members | System.Data.Internal Namespace


DecimalStorage Members

Public:

Constructor

DecimalStorage Constructor [To be supplied.]

Properties

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

Methods

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

DecimalStorage Class | System.Data.Internal Namespace


DecimalStorage Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public DecimalStorage();
[C++]
public: DecimalStorage();
[JScript]
public function DecimalStorage();

See Also

DecimalStorage Class | DecimalStorage Members | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DecimalStorage Properties

The properties of the DecimalStorage class are listed below. For a complete list of DecimalStorage class members, see the DecimalStorage Members topic.

Public:

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

See Also

DecimalStorage Class | System.Data.Internal Namespace


DecimalStorage.DefaultValue

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DefaultValue As Object
[C#]
public object DefaultValue {override get;}
[C++]
public: __property virtual Object* get_DefaultValue();
[JScript]
public function get DefaultValue() : Object;

See Also

DecimalStorage Class | DecimalStorage Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DecimalStorage Methods

The methods of the DecimalStorage class are listed below. For a complete list of DecimalStorage class members, see the DecimalStorage Members topic.

Public:

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

DecimalStorage Class | System.Data.Internal Namespace


DecimalStorage.Aggregate

[To be supplied.]

[Visual Basic]
Overrides Public Function Aggregate( _
   ByVal records() As Integer, _
   ByVal kind As AggregateTypes _
) As Object
[C#]
public override object Aggregate(
   int[] records,
   AggregateTypes kind
);
[C++]
public: override Object* Aggregate(
   int* records[],
   AggregateTypes kind
);
[JScript]
public override function Aggregate(
   records : int[],
   kind : AggregateTypes
) : Object;

Parameters

records
[To be supplied.]
kind
[To be supplied.]

See Also

DecimalStorage Class | DecimalStorage Members | System.Data.Internal Namespace


DecimalStorage.Compare

[To be supplied.]

[Visual Basic]
Overrides Public Function Compare( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
) As Integer
[C#]
public override int Compare(
   int recordNo1,
   int recordNo2
);
[C++]
public: override int Compare(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Compare(
   recordNo1 : int,
   recordNo2 : int
) : int;

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

DecimalStorage Class | DecimalStorage Members | System.Data.Internal Namespace


DecimalStorage.CompareToValue

[To be supplied.]

[Visual Basic]
Overrides Public Function CompareToValue( _
   ByVal recordNo As Integer, _
   ByVal value As Object _
) As Integer
[C#]
public override int CompareToValue(
   int recordNo,
   object value
);
[C++]
public: override int CompareToValue(
   int recordNo,
   Object* value
);
[JScript]
public override function CompareToValue(
   recordNo : int,
   value : Object
) : int;

Parameters

recordNo
[To be supplied.]
value
[To be supplied.]

See Also

DecimalStorage Class | DecimalStorage Members | System.Data.Internal Namespace


DecimalStorage.Copy

[To be supplied.]

[Visual Basic]
Overrides Public Sub Copy( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
)
[C#]
public override void Copy(
   int recordNo1,
   int recordNo2
);
[C++]
public: override void Copy(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Copy(
   recordNo1 : int,
   recordNo2 : int
);

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

DecimalStorage Class | DecimalStorage Members | System.Data.Internal Namespace


DecimalStorage.Get

[To be supplied.]

[Visual Basic]
Overrides Public Function Get( _
   ByVal record As Integer _
) As Object
[C#]
public override object Get(
   int record
);
[C++]
public: override Object* Get(
   int record
);
[JScript]
public override function Get(
   record : int
) : Object;

Parameters

record
[To be supplied.]

See Also

DecimalStorage Class | DecimalStorage Members | System.Data.Internal Namespace


DecimalStorage.Set

[To be supplied.]

[Visual Basic]
Overrides Public Sub Set( _
   ByVal record As Integer, _
   ByVal value As Object _
)
[C#]
public override void Set(
   int record,
   object value
);
[C++]
public: override void Set(
   int record,
   Object* value
);
[JScript]
public override function Set(
   record : int,
   value : Object
);

Parameters

record
[To be supplied.]
value
[To be supplied.]

See Also

DecimalStorage Class | DecimalStorage Members | System.Data.Internal Namespace


DecimalStorage.SetCapacity

[To be supplied.]

[Visual Basic]
Overrides Public Sub SetCapacity( _
   ByVal capacity As Integer _
)
[C#]
public override void SetCapacity(
   int capacity
);
[C++]
public: override void SetCapacity(
   int capacity
);
[JScript]
public override function SetCapacity(
   capacity : int
);

Parameters

capacity
[To be supplied.]

See Also

DecimalStorage Class | DecimalStorage Members | System.Data.Internal Namespace


DecimalStorage.ShiftByOffset

[To be supplied.]

[Visual Basic]
Overrides Public Sub ShiftByOffset( _
   ByVal index As Integer, _
   ByVal length As Integer, _
   ByVal offset As Integer _
)
[C#]
public override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[C++]
public: override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[JScript]
public override function ShiftByOffset(
   index : int,
   length : int,
   offset : int
);

Parameters

index
[To be supplied.]
length
[To be supplied.]
offset
[To be supplied.]

See Also

DecimalStorage Class | DecimalStorage Members | System.Data.Internal Namespace


DoubleStorage Class

[To be supplied.]

Object
DataStorage
DoubleStorage

[Visual Basic]
Public Class DoubleStorage
   Inherits DataStorage
[C#]
public class DoubleStorage : DataStorage
[C++]
public __gc class DoubleStorage : public DataStorage
[JScript]
public class DoubleStorage extends DataStorage

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

DoubleStorage Members | System.Data.Internal Namespace


DoubleStorage Members

Public:

Constructor

DoubleStorage Constructor [To be supplied.]

Properties

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

Methods

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

DoubleStorage Class | System.Data.Internal Namespace


DoubleStorage Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public DoubleStorage();
[C++]
public: DoubleStorage();
[JScript]
public function DoubleStorage();

See Also

DoubleStorage Class | DoubleStorage Members | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DoubleStorage Properties

The properties of the DoubleStorage class are listed below. For a complete list of DoubleStorage class members, see the DoubleStorage Members topic.

Public:

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

See Also

DoubleStorage Class | System.Data.Internal Namespace


DoubleStorage.DefaultValue

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DefaultValue As Object
[C#]
public object DefaultValue {override get;}
[C++]
public: __property virtual Object* get_DefaultValue();
[JScript]
public function get DefaultValue() : Object;

See Also

DoubleStorage Class | DoubleStorage Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DoubleStorage Methods

The methods of the DoubleStorage class are listed below. For a complete list of DoubleStorage class members, see the DoubleStorage Members topic.

Public:

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

DoubleStorage Class | System.Data.Internal Namespace


DoubleStorage.Aggregate

[To be supplied.]

[Visual Basic]
Overrides Public Function Aggregate( _
   ByVal records() As Integer, _
   ByVal kind As AggregateTypes _
) As Object
[C#]
public override object Aggregate(
   int[] records,
   AggregateTypes kind
);
[C++]
public: override Object* Aggregate(
   int* records[],
   AggregateTypes kind
);
[JScript]
public override function Aggregate(
   records : int[],
   kind : AggregateTypes
) : Object;

Parameters

records
[To be supplied.]
kind
[To be supplied.]

See Also

DoubleStorage Class | DoubleStorage Members | System.Data.Internal Namespace


DoubleStorage.Compare

[To be supplied.]

[Visual Basic]
Overrides Public Function Compare( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
) As Integer
[C#]
public override int Compare(
   int recordNo1,
   int recordNo2
);
[C++]
public: override int Compare(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Compare(
   recordNo1 : int,
   recordNo2 : int
) : int;

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

DoubleStorage Class | DoubleStorage Members | System.Data.Internal Namespace


DoubleStorage.CompareToValue

[To be supplied.]

[Visual Basic]
Overrides Public Function CompareToValue( _
   ByVal recordNo As Integer, _
   ByVal value As Object _
) As Integer
[C#]
public override int CompareToValue(
   int recordNo,
   object value
);
[C++]
public: override int CompareToValue(
   int recordNo,
   Object* value
);
[JScript]
public override function CompareToValue(
   recordNo : int,
   value : Object
) : int;

Parameters

recordNo
[To be supplied.]
value
[To be supplied.]

See Also

DoubleStorage Class | DoubleStorage Members | System.Data.Internal Namespace


DoubleStorage.Copy

[To be supplied.]

[Visual Basic]
Overrides Public Sub Copy( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
)
[C#]
public override void Copy(
   int recordNo1,
   int recordNo2
);
[C++]
public: override void Copy(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Copy(
   recordNo1 : int,
   recordNo2 : int
);

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

DoubleStorage Class | DoubleStorage Members | System.Data.Internal Namespace


DoubleStorage.Get

[To be supplied.]

[Visual Basic]
Overrides Public Function Get( _
   ByVal record As Integer _
) As Object
[C#]
public override object Get(
   int record
);
[C++]
public: override Object* Get(
   int record
);
[JScript]
public override function Get(
   record : int
) : Object;

Parameters

record
[To be supplied.]

See Also

DoubleStorage Class | DoubleStorage Members | System.Data.Internal Namespace


DoubleStorage.Set

[To be supplied.]

[Visual Basic]
Overrides Public Sub Set( _
   ByVal record As Integer, _
   ByVal value As Object _
)
[C#]
public override void Set(
   int record,
   object value
);
[C++]
public: override void Set(
   int record,
   Object* value
);
[JScript]
public override function Set(
   record : int,
   value : Object
);

Parameters

record
[To be supplied.]
value
[To be supplied.]

See Also

DoubleStorage Class | DoubleStorage Members | System.Data.Internal Namespace


DoubleStorage.SetCapacity

[To be supplied.]

[Visual Basic]
Overrides Public Sub SetCapacity( _
   ByVal capacity As Integer _
)
[C#]
public override void SetCapacity(
   int capacity
);
[C++]
public: override void SetCapacity(
   int capacity
);
[JScript]
public override function SetCapacity(
   capacity : int
);

Parameters

capacity
[To be supplied.]

See Also

DoubleStorage Class | DoubleStorage Members | System.Data.Internal Namespace


DoubleStorage.ShiftByOffset

[To be supplied.]

[Visual Basic]
Overrides Public Sub ShiftByOffset( _
   ByVal index As Integer, _
   ByVal length As Integer, _
   ByVal offset As Integer _
)
[C#]
public override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[C++]
public: override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[JScript]
public override function ShiftByOffset(
   index : int,
   length : int,
   offset : int
);

Parameters

index
[To be supplied.]
length
[To be supplied.]
offset
[To be supplied.]

See Also

DoubleStorage Class | DoubleStorage Members | System.Data.Internal Namespace


IDataParameters Interface

Collects all parameters relevant to the command and their mappings to DataSet columns.

[Visual Basic]
Public Interface IDataParameters
   Implements IList, ICollection, IEnumerable
[C#]
public interface IDataParameters : IList, ICollection, IEnumerable
[C++]
public __gc __interface IDataParameters : public IList,
   ICollection, IEnumerable

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IDataParameters

Class | Description
ADOParameters | Collects all parameters relevant to an ADOCommand and their mappings to DataSet columns.
SQLParameters | Collects all parameters relevant to a SQLCommand and their mappings to DataSet columns.

Remarks

The number of the parameters in the collection must be equal to the number of parameter placeholders within the command text or the provider will raise an error.

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

IDataParameters Members | System.Data.Internal Namespace


IDataParameters Members

Properties

All | Gets all instances of IDataParameter objects collected.
Item | Gets the parameter at the specified index. In C#, this member is the indexer for the IDataParameters class.
Parent | Gets the reference to the Object that is the parent of this instance.

Methods

Contains | Indicates whether a parameter is in the collection with the specified source table name.
IndexOf | Returns the location of the IDataParameter within the collection.
RemoveAt | Removes the IDataParameter from the collection.

See Also

IDataParameters Interface | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDataParameters Properties

The properties of the IDataParameters interface are listed below. For a complete list of IDataParameters interface members, see the IDataParameters Members topic.

All | Gets all instances of IDataParameter objects collected.
Item | Gets the parameter at the specified index. In C#, this member is the indexer for the IDataParameters class.
Parent | Gets the reference to the Object that is the parent of this instance.

See Also

IDataParameters Interface | System.Data.Internal Namespace


IDataParameters.All

Gets all instances of IDataParameter objects collected.

[Visual Basic]
Property All As IDataParameter ()
[C#]
IDataParameter[] All {get; set;}
[C++]
IDataParameter* get_All() = 0;void set_All(IDataParameter*[]) = 0;
[JScript]
abstract function get All() : IDataParameter[];
public abstract function set All(IDataParameter[]);

Property Value

All instances of IDataParameter objects collected.

See Also

IDataParameters Interface | IDataParameters Members | System.Data.Internal Namespace


IDataParameters.Item

Gets the parameter at the specified index.

[C#] In C#, this member is the indexer for the IDataParameters class.

[Visual Basic]
Default Property Item( _
   ByVal index As String _
) As Object
[C#]
object this[
   string index
] {get; set;}
[C++]
Object* get_Item(
   String* index
) = 0;void set_Item(
   String* index,
   Object*
) = 0;
[JScript]
abstract returnValue = IDataParametersObject.Item(index);
IDataParametersObject.Item(index) = returnValue;
-or-
abstract returnValue = IDataParametersObject(index);
IDataParametersObject(index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
The zero-based index of the parameter to retrieve.

Parameters [Visual Basic, C#, C++]

index
The zero-based index of the parameter to retrieve.

Property Value

An Object at the specified index.

See Also

IDataParameters Interface | IDataParameters Members | System.Data.Internal Namespace


IDataParameters.Parent

Gets the reference to the Object that is the parent of this instance.

[Visual Basic]
ReadOnly Property Parent As Object
[C#]
object Parent {get;}
[C++]
Object* get_Parent() = 0;
[JScript]
abstract function get Parent() : Object;

Property Value

The reference to the Object that is the parent of this instance.

See Also

IDataParameters Interface | IDataParameters Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDataParameters Methods

The methods of the IDataParameters interface are listed below. For a complete list of IDataParameters interface members, see the IDataParameters Members topic.

Contains | Indicates whether a parameter is in the collection with the specified source table name.
IndexOf | Returns the location of the IDataParameter within the collection.
RemoveAt | Removes the IDataParameter from the collection.

See Also

IDataParameters Interface | System.Data.Internal Namespace


IDataParameters.Contains

Indicates whether a parameter is in the collection with the specified source table name.

[Visual Basic]
Function Contains( _
   ByVal sourceTableName As String _
) As Boolean
[C#]
bool Contains(
   string sourceTableName
);
[C++]
bool Contains(
   String* sourceTableName
) = 0;
[JScript]
function Contains(
   sourceTableName : String
) : Boolean;

Parameters

sourceTableName
The case-sensitive name of the source table.

Return Value

true if the collection contains the parameter, otherwise false.

See Also

IDataParameters Interface | IDataParameters Members | System.Data.Internal Namespace


IDataParameters.IndexOf

Returns the location of the IDataParameter within the collection.

[Visual Basic]
Function IndexOf( _
   ByVal sourceTableName As String _
) As Integer
[C#]
int IndexOf(
   string sourceTableName
);
[C++]
int IndexOf(
   String* sourceTableName
) = 0;
[JScript]
function IndexOf(
   sourceTableName : String
) : int;

Parameters

sourceTableName
The case-sensitive name of the source table.

Return Value

The location of the IDataParameter within the collection.

See Also

IDataParameters Interface | IDataParameters Members | System.Data.Internal Namespace


IDataParameters.RemoveAt

Removes the IDataParameter from the collection.

[Visual Basic]
Sub RemoveAt( _
   ByVal sourceTableMapping As String _
)
[C#]
void RemoveAt(
   string sourceTableMapping
);
[C++]
void RemoveAt(
   String* sourceTableMapping
) = 0;
[JScript]
function RemoveAt(
   sourceTableMapping : String
);

Parameters

sourceTableMapping
The case-sensitive name of the source table.

See Also

IDataParameters Interface | IDataParameters Members | System.Data.Internal Namespace


IDBDataReader Interface

[To be supplied.]

[Visual Basic]
Public Interface IDBDataReader
   Implements IDataReader, IDataRecord
[C#]
public interface IDBDataReader : IDataReader, IDataRecord
[C++]
public __gc __interface IDBDataReader : public IDataReader,
   IDataRecord

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IDBDataReader

Class | Description
ADODataReader | [To be supplied.]
SQLDataReader | [To be supplied.]

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

IDBDataReader Members | System.Data.Internal Namespace


IDBDataReader Members

Properties

RecordsAffected | [To be supplied.]
SchemaTable | [To be supplied.]

Methods

SetRowBuffer [To be supplied.]

Events

DataSchemaChanged [To be supplied.]

Event Hookup:

Methods

AddOnDataSchemaChanged | [To be supplied.]
RemoveOnDataSchemaChanged | [To be supplied.]

See Also

IDBDataReader Interface | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDBDataReader Properties

The properties of the IDBDataReader interface are listed below. For a complete list of IDBDataReader interface members, see the IDBDataReader Members topic.

RecordsAffected | [To be supplied.]
SchemaTable | [To be supplied.]

See Also

IDBDataReader Interface | System.Data.Internal Namespace


IDBDataReader.RecordsAffected

[To be supplied.]

[Visual Basic]
ReadOnly Property RecordsAffected As Integer
[C#]
int RecordsAffected {get;}
[C++]
int get_RecordsAffected() = 0;
[JScript]
abstract function get RecordsAffected() : int;

See Also

IDBDataReader Interface | IDBDataReader Members | System.Data.Internal Namespace


IDBDataReader.SchemaTable

[To be supplied.]

[Visual Basic]
ReadOnly Property SchemaTable As DataTable
[C#]
DataTable SchemaTable {get;}
[C++]
DataTable* get_SchemaTable() = 0;
[JScript]
abstract function get SchemaTable() : DataTable;

See Also

IDBDataReader Interface | IDBDataReader Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDBDataReader Methods

The methods of the IDBDataReader interface are listed below. For a complete list of IDBDataReader interface members, see the IDBDataReader Members topic.

SetRowBuffer [To be supplied.]

Event Hookup:

AddOnDataSchemaChanged | [To be supplied.]
RemoveOnDataSchemaChanged | [To be supplied.]

See Also

IDBDataReader Interface | System.Data.Internal Namespace


IDBDataReader.AddOnDataSchemaChanged

[To be supplied.]

[Visual Basic]
Sub AddOnDataSchemaChanged( _
   ByVal handler As DataSchemaChangedEventHandler _
)
[C#]
void AddOnDataSchemaChanged(
   DataSchemaChangedEventHandler handler
);
[C++]
void AddOnDataSchemaChanged(
   DataSchemaChangedEventHandler* handler
) = 0;
[JScript]
function AddOnDataSchemaChanged(
   handler : DataSchemaChangedEventHandler
);

Parameters

handler
[To be supplied.]

See Also

IDBDataReader Interface | IDBDataReader Members | System.Data.Internal Namespace


IDBDataReader.RemoveOnDataSchemaChanged

[To be supplied.]

[Visual Basic]
Sub RemoveOnDataSchemaChanged( _
   ByVal handler As DataSchemaChangedEventHandler _
)
[C#]
void RemoveOnDataSchemaChanged(
   DataSchemaChangedEventHandler handler
);
[C++]
void RemoveOnDataSchemaChanged(
   DataSchemaChangedEventHandler* handler
) = 0;
[JScript]
function RemoveOnDataSchemaChanged(
   handler : DataSchemaChangedEventHandler
);

Parameters

handler
[To be supplied.]

See Also

IDBDataReader Interface | IDBDataReader Members | System.Data.Internal Namespace


IDBDataReader.SetRowBuffer

[To be supplied.]

[Visual Basic]
Sub SetRowBuffer( _
   ByVal dataValues() As Object, _
   ByVal indexMap() As Integer _
)
[C#]
void SetRowBuffer(
   object[] dataValues,
   int[] indexMap
);
[C++]
void SetRowBuffer(
   Object* dataValues[],
   int* indexMap[]
) = 0;
[JScript]
function SetRowBuffer(
   dataValues : Object[],
   indexMap : int[]
);

Parameters

dataValues
[To be supplied.]
indexMap
[To be supplied.]

See Also

IDBDataReader Interface | IDBDataReader Members | System.Data.Internal Namespace


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDBDataReader Events

The events of the IDBDataReader interface are listed below. For a complete list of IDBDataReader interface members, see the IDBDataReader Members topic.

DataSchemaChanged [To be supplied.]

See Also

IDBDataReader Interface | System.Data.Internal Namespace


IDBDataReader DataSchemaChanged Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the DataSchemaChanged event.

[Visual Basic]
Private Sub IDBDataReaderName_DataSchemaChanged( _
   ByVal sender As Object, _
   ByVal e As DataSchemaChangedEventArgs _
)
[C#]
private void IDBDataReaderName_DataSchemaChanged(
   object sender,
   DataSchemaChangedEventArgs e
);
[C++]
private: void IDBDataReaderName_DataSchemaChanged(
   Object* sender,
   DataSchemaChangedEventArgs* e
);
[JScript]
private IDBDataReaderName_DataSchemaChanged(
   sender : Object,
   e : DataSchemaChangedEventArgs
);

Parameters

sender
The source of the event.
e
A DataSchemaChangedEventArgs that contains the event data.

See Also

IDBDataReader Interface | IDBDataReader MembersTopic | System.Data.Internal Namespace


InfoMessageEventArgs Class

[To be supplied.]

Object
EventArgs
InfoMessageEventArgs

[Visual Basic]
MustInherit Public Class InfoMessageEventArgs
   Inherits EventArgs
[C#]
public abstract class InfoMessageEventArgs : EventArgs
[C++]
public __gc __abstract class InfoMessageEventArgs : public
   EventArgs
[JScript]
public abstract class InfoMessageEventArgs extends EventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

InfoMessageEventArgs Members | System.Data.Internal Namespace


InfoMessageEventArgs Members

Public:

Constructor

InfoMessageEventArgs Constructor [To be supplied.]

Properties

ExtendedInfo (inherited from EventArgs) Holds a reference to an object that manages the event's state.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InfoMessageEventArgs Class | System.Data.Internal Namespace


InfoMessageEventArgs Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public InfoMessageEventArgs();
[C++]
public: InfoMessageEventArgs();
[JScript]
public function InfoMessageEventArgs();

See Also

InfoMessageEventArgs Class | InfoMessageEventArgs Members | System.Data.Internal Namespace


Int16Storage Class

[To be supplied.]

Object
DataStorage
Int16Storage

[Visual Basic]
Public Class Int16Storage
   Inherits DataStorage
[C#]
public class Int16Storage : DataStorage
[C++]
public __gc class Int16Storage : public DataStorage
[JScript]
public class Int16Storage extends DataStorage

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

Int16Storage Members | System.Data.Internal Namespace


Int16Storage Members

Public:

Constructor

Int16Storage Constructor [To be supplied.]

Properties

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

Methods

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

Int16Storage Class | System.Data.Internal Namespace


Int16Storage Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public Int16Storage();
[C++]
public: Int16Storage();
[JScript]
public function Int16Storage();

See Also

Int16Storage Class | Int16Storage Members | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Int16Storage Properties

The properties of the Int16Storage class are listed below. For a complete list of Int16Storage class members, see the Int16Storage Members topic.

Public:

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

See Also

Int16Storage Class | System.Data.Internal Namespace


Int16Storage.DefaultValue

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DefaultValue As Object
[C#]
public object DefaultValue {override get;}
[C++]
public: __property virtual Object* get_DefaultValue();
[JScript]
public function get DefaultValue() : Object;

See Also

Int16Storage Class | Int16Storage Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Int16Storage Methods

The methods of the Int16Storage class are listed below. For a complete list of Int16Storage class members, see the Int16Storage Members topic.

Public:

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

Int16Storage Class | System.Data.Internal Namespace


Int16Storage.Aggregate

[To be supplied.]

[Visual Basic]
Overrides Public Function Aggregate( _
   ByVal records() As Integer, _
   ByVal kind As AggregateTypes _
) As Object
[C#]
public override object Aggregate(
   int[] records,
   AggregateTypes kind
);
[C++]
public: override Object* Aggregate(
   int* records[],
   AggregateTypes kind
);
[JScript]
public override function Aggregate(
   records : int[],
   kind : AggregateTypes
) : Object;

Parameters

records
[To be supplied.]
kind
[To be supplied.]

See Also

Int16Storage Class | Int16Storage Members | System.Data.Internal Namespace


Int16Storage.Compare

[To be supplied.]

[Visual Basic]
Overrides Public Function Compare( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
) As Integer
[C#]
public override int Compare(
   int recordNo1,
   int recordNo2
);
[C++]
public: override int Compare(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Compare(
   recordNo1 : int,
   recordNo2 : int
) : int;

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

Int16Storage Class | Int16Storage Members | System.Data.Internal Namespace


Int16Storage.CompareToValue

[To be supplied.]

[Visual Basic]
Overrides Public Function CompareToValue( _
   ByVal recordNo As Integer, _
   ByVal value As Object _
) As Integer
[C#]
public override int CompareToValue(
   int recordNo,
   object value
);
[C++]
public: override int CompareToValue(
   int recordNo,
   Object* value
);
[JScript]
public override function CompareToValue(
   recordNo : int,
   value : Object
) : int;

Parameters

recordNo
[To be supplied.]
value
[To be supplied.]

See Also

Int16Storage Class | Int16Storage Members | System.Data.Internal Namespace


Int16Storage.Copy

[To be supplied.]

[Visual Basic]
Overrides Public Sub Copy( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
)
[C#]
public override void Copy(
   int recordNo1,
   int recordNo2
);
[C++]
public: override void Copy(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Copy(
   recordNo1 : int,
   recordNo2 : int
);

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

Int16Storage Class | Int16Storage Members | System.Data.Internal Namespace


Int16Storage.Get

[To be supplied.]

[Visual Basic]
Overrides Public Function Get( _
   ByVal record As Integer _
) As Object
[C#]
public override object Get(
   int record
);
[C++]
public: override Object* Get(
   int record
);
[JScript]
public override function Get(
   record : int
) : Object;

Parameters

record
[To be supplied.]

See Also

Int16Storage Class | Int16Storage Members | System.Data.Internal Namespace


Int16Storage.Set

[To be supplied.]

[Visual Basic]
Overrides Public Sub Set( _
   ByVal record As Integer, _
   ByVal value As Object _
)
[C#]
public override void Set(
   int record,
   object value
);
[C++]
public: override void Set(
   int record,
   Object* value
);
[JScript]
public override function Set(
   record : int,
   value : Object
);

Parameters

record
[To be supplied.]
value
[To be supplied.]

See Also

Int16Storage Class | Int16Storage Members | System.Data.Internal Namespace


Int16Storage.SetCapacity

[To be supplied.]

[Visual Basic]
Overrides Public Sub SetCapacity( _
   ByVal capacity As Integer _
)
[C#]
public override void SetCapacity(
   int capacity
);
[C++]
public: override void SetCapacity(
   int capacity
);
[JScript]
public override function SetCapacity(
   capacity : int
);

Parameters

capacity
[To be supplied.]

See Also

Int16Storage Class | Int16Storage Members | System.Data.Internal Namespace


Int16Storage.ShiftByOffset

[To be supplied.]

[Visual Basic]
Overrides Public Sub ShiftByOffset( _
   ByVal index As Integer, _
   ByVal length As Integer, _
   ByVal offset As Integer _
)
[C#]
public override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[C++]
public: override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[JScript]
public override function ShiftByOffset(
   index : int,
   length : int,
   offset : int
);

Parameters

index
[To be supplied.]
length
[To be supplied.]
offset
[To be supplied.]

See Also

Int16Storage Class | Int16Storage Members | System.Data.Internal Namespace


Int32Storage Class

[To be supplied.]

Object
DataStorage
Int32Storage

[Visual Basic]
Public Class Int32Storage
   Inherits DataStorage
[C#]
public class Int32Storage : DataStorage
[C++]
public __gc class Int32Storage : public DataStorage
[JScript]
public class Int32Storage extends DataStorage

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

Int32Storage Members | System.Data.Internal Namespace


Int32Storage Members

Public:

Constructor

Int32Storage Constructor [To be supplied.]

Properties

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

Methods

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

Int32Storage Class | System.Data.Internal Namespace


Int32Storage Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public Int32Storage();
[C++]
public: Int32Storage();
[JScript]
public function Int32Storage();

See Also

Int32Storage Class | Int32Storage Members | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Int32Storage Properties

The properties of the Int32Storage class are listed below. For a complete list of Int32Storage class members, see the Int32Storage Members topic.

Public:

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

See Also

Int32Storage Class | System.Data.Internal Namespace


Int32Storage.DefaultValue

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DefaultValue As Object
[C#]
public object DefaultValue {override get;}
[C++]
public: __property virtual Object* get_DefaultValue();
[JScript]
public function get DefaultValue() : Object;

See Also

Int32Storage Class | Int32Storage Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Int32Storage Methods

The methods of the Int32Storage class are listed below. For a complete list of Int32Storage class members, see the Int32Storage Members topic.

Public:

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

Int32Storage Class | System.Data.Internal Namespace


Int32Storage.Aggregate

[To be supplied.]

[Visual Basic]
Overrides Public Function Aggregate( _
   ByVal records() As Integer, _
   ByVal kind As AggregateTypes _
) As Object
[C#]
public override object Aggregate(
   int[] records,
   AggregateTypes kind
);
[C++]
public: override Object* Aggregate(
   int* records[],
   AggregateTypes kind
);
[JScript]
public override function Aggregate(
   records : int[],
   kind : AggregateTypes
) : Object;

Parameters

records
[To be supplied.]
kind
[To be supplied.]

See Also

Int32Storage Class | Int32Storage Members | System.Data.Internal Namespace


Int32Storage.Compare

[To be supplied.]

[Visual Basic]
Overrides Public Function Compare( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
) As Integer
[C#]
public override int Compare(
   int recordNo1,
   int recordNo2
);
[C++]
public: override int Compare(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Compare(
   recordNo1 : int,
   recordNo2 : int
) : int;

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

Int32Storage Class | Int32Storage Members | System.Data.Internal Namespace


Int32Storage.CompareToValue

[To be supplied.]

[Visual Basic]
Overrides Public Function CompareToValue( _
   ByVal recordNo As Integer, _
   ByVal value As Object _
) As Integer
[C#]
public override int CompareToValue(
   int recordNo,
   object value
);
[C++]
public: override int CompareToValue(
   int recordNo,
   Object* value
);
[JScript]
public override function CompareToValue(
   recordNo : int,
   value : Object
) : int;

Parameters

recordNo
[To be supplied.]
value
[To be supplied.]

See Also

Int32Storage Class | Int32Storage Members | System.Data.Internal Namespace


Int32Storage.Copy

[To be supplied.]

[Visual Basic]
Overrides Public Sub Copy( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
)
[C#]
public override void Copy(
   int recordNo1,
   int recordNo2
);
[C++]
public: override void Copy(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Copy(
   recordNo1 : int,
   recordNo2 : int
);

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

Int32Storage Class | Int32Storage Members | System.Data.Internal Namespace


Int32Storage.Get

[To be supplied.]

[Visual Basic]
Overrides Public Function Get( _
   ByVal record As Integer _
) As Object
[C#]
public override object Get(
   int record
);
[C++]
public: override Object* Get(
   int record
);
[JScript]
public override function Get(
   record : int
) : Object;

Parameters

record
[To be supplied.]

See Also

Int32Storage Class | Int32Storage Members | System.Data.Internal Namespace


Int32Storage.Set

[To be supplied.]

[Visual Basic]
Overrides Public Sub Set( _
   ByVal record As Integer, _
   ByVal value As Object _
)
[C#]
public override void Set(
   int record,
   object value
);
[C++]
public: override void Set(
   int record,
   Object* value
);
[JScript]
public override function Set(
   record : int,
   value : Object
);

Parameters

record
[To be supplied.]
value
[To be supplied.]

See Also

Int32Storage Class | Int32Storage Members | System.Data.Internal Namespace


Int32Storage.SetCapacity

[To be supplied.]

[Visual Basic]
Overrides Public Sub SetCapacity( _
   ByVal capacity As Integer _
)
[C#]
public override void SetCapacity(
   int capacity
);
[C++]
public: override void SetCapacity(
   int capacity
);
[JScript]
public override function SetCapacity(
   capacity : int
);

Parameters

capacity
[To be supplied.]

See Also

Int32Storage Class | Int32Storage Members | System.Data.Internal Namespace


Int32Storage.ShiftByOffset

[To be supplied.]

[Visual Basic]
Overrides Public Sub ShiftByOffset( _
   ByVal index As Integer, _
   ByVal length As Integer, _
   ByVal offset As Integer _
)
[C#]
public override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[C++]
public: override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[JScript]
public override function ShiftByOffset(
   index : int,
   length : int,
   offset : int
);

Parameters

index
[To be supplied.]
length
[To be supplied.]
offset
[To be supplied.]

See Also

Int32Storage Class | Int32Storage Members | System.Data.Internal Namespace


Int64Storage Class

[To be supplied.]

Object
DataStorage
Int64Storage

[Visual Basic]
Public Class Int64Storage
   Inherits DataStorage
[C#]
public class Int64Storage : DataStorage
[C++]
public __gc class Int64Storage : public DataStorage
[JScript]
public class Int64Storage extends DataStorage

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

Int64Storage Members | System.Data.Internal Namespace


Int64Storage Members

Public:

Constructor

Int64Storage Constructor [To be supplied.]

Properties

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

Methods

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

Int64Storage Class | System.Data.Internal Namespace


Int64Storage Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public Int64Storage();
[C++]
public: Int64Storage();
[JScript]
public function Int64Storage();

See Also

Int64Storage Class | Int64Storage Members | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Int64Storage Properties

The properties of the Int64Storage class are listed below. For a complete list of Int64Storage class members, see the Int64Storage Members topic.

Public:

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

See Also

Int64Storage Class | System.Data.Internal Namespace


Int64Storage.DefaultValue

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DefaultValue As Object
[C#]
public object DefaultValue {override get;}
[C++]
public: __property virtual Object* get_DefaultValue();
[JScript]
public function get DefaultValue() : Object;

See Also

Int64Storage Class | Int64Storage Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Int64Storage Methods

The methods of the Int64Storage class are listed below. For a complete list of Int64Storage class members, see the Int64Storage Members topic.

Public:

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

Int64Storage Class | System.Data.Internal Namespace


Int64Storage.Aggregate

[To be supplied.]

[Visual Basic]
Overrides Public Function Aggregate( _
   ByVal records() As Integer, _
   ByVal kind As AggregateTypes _
) As Object
[C#]
public override object Aggregate(
   int[] records,
   AggregateTypes kind
);
[C++]
public: override Object* Aggregate(
   int* records[],
   AggregateTypes kind
);
[JScript]
public override function Aggregate(
   records : int[],
   kind : AggregateTypes
) : Object;

Parameters

records
[To be supplied.]
kind
[To be supplied.]

See Also

Int64Storage Class | Int64Storage Members | System.Data.Internal Namespace


Int64Storage.Compare

[To be supplied.]

[Visual Basic]
Overrides Public Function Compare( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
) As Integer
[C#]
public override int Compare(
   int recordNo1,
   int recordNo2
);
[C++]
public: override int Compare(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Compare(
   recordNo1 : int,
   recordNo2 : int
) : int;

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

Int64Storage Class | Int64Storage Members | System.Data.Internal Namespace


Int64Storage.CompareToValue

[To be supplied.]

[Visual Basic]
Overrides Public Function CompareToValue( _
   ByVal recordNo As Integer, _
   ByVal value As Object _
) As Integer
[C#]
public override int CompareToValue(
   int recordNo,
   object value
);
[C++]
public: override int CompareToValue(
   int recordNo,
   Object* value
);
[JScript]
public override function CompareToValue(
   recordNo : int,
   value : Object
) : int;

Parameters

recordNo
[To be supplied.]
value
[To be supplied.]

See Also

Int64Storage Class | Int64Storage Members | System.Data.Internal Namespace


Int64Storage.Copy

[To be supplied.]

[Visual Basic]
Overrides Public Sub Copy( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
)
[C#]
public override void Copy(
   int recordNo1,
   int recordNo2
);
[C++]
public: override void Copy(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Copy(
   recordNo1 : int,
   recordNo2 : int
);

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

Int64Storage Class | Int64Storage Members | System.Data.Internal Namespace


Int64Storage.Get

[To be supplied.]

[Visual Basic]
Overrides Public Function Get( _
   ByVal record As Integer _
) As Object
[C#]
public override object Get(
   int record
);
[C++]
public: override Object* Get(
   int record
);
[JScript]
public override function Get(
   record : int
) : Object;

Parameters

record
[To be supplied.]

See Also

Int64Storage Class | Int64Storage Members | System.Data.Internal Namespace


Int64Storage.Set

[To be supplied.]

[Visual Basic]
Overrides Public Sub Set( _
   ByVal record As Integer, _
   ByVal value As Object _
)
[C#]
public override void Set(
   int record,
   object value
);
[C++]
public: override void Set(
   int record,
   Object* value
);
[JScript]
public override function Set(
   record : int,
   value : Object
);

Parameters

record
[To be supplied.]
value
[To be supplied.]

See Also

Int64Storage Class | Int64Storage Members | System.Data.Internal Namespace


Int64Storage.SetCapacity

[To be supplied.]

[Visual Basic]
Overrides Public Sub SetCapacity( _
   ByVal capacity As Integer _
)
[C#]
public override void SetCapacity(
   int capacity
);
[C++]
public: override void SetCapacity(
   int capacity
);
[JScript]
public override function SetCapacity(
   capacity : int
);

Parameters

capacity
[To be supplied.]

See Also

Int64Storage Class | Int64Storage Members | System.Data.Internal Namespace


Int64Storage.ShiftByOffset

[To be supplied.]

[Visual Basic]
Overrides Public Sub ShiftByOffset( _
   ByVal index As Integer, _
   ByVal length As Integer, _
   ByVal offset As Integer _
)
[C#]
public override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[C++]
public: override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[JScript]
public override function ShiftByOffset(
   index : int,
   length : int,
   offset : int
);

Parameters

index
[To be supplied.]
length
[To be supplied.]
offset
[To be supplied.]

See Also

Int64Storage Class | Int64Storage Members | System.Data.Internal Namespace


IProperties Interface

[To be supplied.]

[Visual Basic]
Public Interface IProperties
   Implements ICollection, IEnumerable
[C#]
public interface IProperties : ICollection, IEnumerable
[C++]
public __gc __interface IProperties : public ICollection,
   IEnumerable

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IProperties

Class | Description
ADOProperties | [To be supplied.]

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

IProperties Members | System.Data.Internal Namespace


IProperties Members

Properties

All | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the IProperties class.
Parent | [To be supplied.]

Methods

Contains | Overloaded. [To be supplied.]
IndexOf | Overloaded. [To be supplied.]

See Also

IProperties Interface | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IProperties Properties

The properties of the IProperties interface are listed below. For a complete list of IProperties interface members, see the IProperties Members topic.

All | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the IProperties class.
Parent | [To be supplied.]

See Also

IProperties Interface | System.Data.Internal Namespace


IProperties.All

[To be supplied.]

[Visual Basic]
ReadOnly Property All As IProperty ()
[C#]
IProperty[] All {get;}
[C++]
IProperty* get_All() = 0;
[JScript]
abstract function get All() : IProperty[];

See Also

IProperties Interface | IProperties Members | System.Data.Internal Namespace


IProperties.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the IProperties class.

Overload List

[To be supplied.]

[Visual Basic] Overloads Default ReadOnly Property Item(Integer) As Object
[C#] object this[int] {get;}
[C++] Object* get_Item(int) = 0;
[JScript] IProperties.Item (int)

[To be supplied.]

[Visual Basic] Overloads Default ReadOnly Property Item(String) As Object
[C#] object this[String] {get;}
[C++] Object* get_Item(String*) = 0;
[JScript] IProperties.Item (String)

See Also

IProperties Interface | IProperties Members | System.Data.Internal Namespace


IProperties.Item (Int32)

[To be supplied.]

[C#] In C#, this member is the indexer for the IProperties class.

[Visual Basic]
Overloads Default ReadOnly Property Item( _
   ByVal index As Integer _
) As Object
[C#]
object this[
   int index
] {get;}
[C++]
Object* get_Item(
   int index
) = 0;
[JScript]
abstract returnValue = IPropertiesObject.Item(index);
-or-
abstract returnValue = IPropertiesObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
[To be supplied.]

Parameters [Visual Basic, C#, C++]

index
[To be supplied.]

See Also

IProperties Interface | IProperties Members | System.Data.Internal Namespace | IProperties.Item Overload List


IProperties.Item (String)

[To be supplied.]

[C#] In C#, this member is the indexer for the IProperties class.

[Visual Basic]
Overloads Default ReadOnly Property Item( _
   ByVal index As String _
) As Object
[C#]
object this[
   string index
] {get;}
[C++]
Object* get_Item(
   String* index
) = 0;
[JScript]
abstract returnValue = IPropertiesObject.Item(index);
-or-
abstract returnValue = IPropertiesObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
[To be supplied.]

Parameters [Visual Basic, C#, C++]

index
[To be supplied.]

See Also

IProperties Interface | IProperties Members | System.Data.Internal Namespace | IProperties.Item Overload List


IProperties.Parent

[To be supplied.]

[Visual Basic]
ReadOnly Property Parent As Object
[C#]
object Parent {get;}
[C++]
Object* get_Parent() = 0;
[JScript]
abstract function get Parent() : Object;

See Also

IProperties Interface | IProperties Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IProperties Methods

The methods of the IProperties interface are listed below. For a complete list of IProperties interface members, see the IProperties Members topic.

Contains | Overloaded. [To be supplied.]
IndexOf | Overloaded. [To be supplied.]

See Also

IProperties Interface | System.Data.Internal Namespace


IProperties.Contains

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Function Contains(Object) As Boolean
[C#] bool Contains(Object);
[C++] bool Contains(Object*) = 0;
[JScript] function Contains(Object) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Function Contains(String) As Boolean
[C#] bool Contains(String);
[C++] bool Contains(String*) = 0;
[JScript] function Contains(String) : Boolean;

See Also

IProperties Interface | IProperties Members | System.Data.Internal Namespace


IProperties.Contains (Object)

[To be supplied.]

[Visual Basic]
Overloads Function Contains( _
   ByVal value As Object _
) As Boolean
[C#]
bool Contains(
   object value
);
[C++]
bool Contains(
   Object* value
) = 0;
[JScript]
function Contains(
   value : Object
) : Boolean;

Parameters

value
[To be supplied.]

See Also

IProperties Interface | IProperties Members | System.Data.Internal Namespace | IProperties.Contains Overload List


IProperties.Contains (String)

[To be supplied.]

[Visual Basic]
Overloads Function Contains( _
   ByVal value As String _
) As Boolean
[C#]
bool Contains(
   string value
);
[C++]
bool Contains(
   String* value
) = 0;
[JScript]
function Contains(
   value : String
) : Boolean;

Parameters

value
[To be supplied.]

See Also

IProperties Interface | IProperties Members | System.Data.Internal Namespace | IProperties.Contains Overload List


IProperties.IndexOf

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Function IndexOf(String) As Integer
[C#] int IndexOf(String);
[C++] int IndexOf(String*) = 0;
[JScript] function IndexOf(String) : int;

[To be supplied.]

[Visual Basic] Overloads Function IndexOf(Object) As Integer
[C#] int IndexOf(Object);
[C++] int IndexOf(Object*) = 0;
[JScript] function IndexOf(Object) : int;

See Also

IProperties Interface | IProperties Members | System.Data.Internal Namespace


IProperties.IndexOf (String)

[To be supplied.]

[Visual Basic]
Overloads Function IndexOf( _
   ByVal value As String _
) As Integer
[C#]
int IndexOf(
   string value
);
[C++]
int IndexOf(
   String* value
) = 0;
[JScript]
function IndexOf(
   value : String
) : int;

Parameters

value
[To be supplied.]

See Also

IProperties Interface | IProperties Members | System.Data.Internal Namespace | IProperties.IndexOf Overload List


IProperties.IndexOf (Object)

[To be supplied.]

[Visual Basic]
Overloads Function IndexOf( _
   ByVal value As Object _
) As Integer
[C#]
int IndexOf(
   object value
);
[C++]
int IndexOf(
   Object* value
) = 0;
[JScript]
function IndexOf(
   value : Object
) : int;

Parameters

value
[To be supplied.]

See Also

IProperties Interface | IProperties Members | System.Data.Internal Namespace | IProperties.IndexOf Overload List


IProperty Interface

[To be supplied.]

IProperty

[Visual Basic]
Public Interface IProperty
[C#]
public interface IProperty
[C++]
public __gc __interface IProperty

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IProperty

Class | Description
ADOProperty | [To be supplied.]

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

IProperty Members | System.Data.Internal Namespace


IProperty Members

Properties

Attributes | [To be supplied.]
DataType | [To be supplied.]
Parent | [To be supplied.]
PropertyName | [To be supplied.]
Value | property values are applied immediately to OLE DB

See Also

IProperty Interface | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IProperty Properties

The properties of the IProperty interface are listed below. For a complete list of IProperty interface members, see the IProperty Members topic.

Attributes | [To be supplied.]
DataType | [To be supplied.]
Parent | [To be supplied.]
PropertyName | [To be supplied.]
Value | property values are applied immediately to OLE DB

See Also

IProperty Interface | System.Data.Internal Namespace


IProperty.Attributes

[To be supplied.]

[Visual Basic]
ReadOnly Property Attributes As PropertyAttributes
[C#]
PropertyAttributes Attributes {get;}
[C++]
PropertyAttributes get_Attributes() = 0;
[JScript]
abstract function get Attributes() : PropertyAttributes;

See Also

IProperty Interface | IProperty Members | System.Data.Internal Namespace


IProperty.DataType

[To be supplied.]

[Visual Basic]
ReadOnly Property DataType As Type
[C#]
Type DataType {get;}
[C++]
Type* get_DataType() = 0;
[JScript]
abstract function get DataType() : Type;

See Also

IProperty Interface | IProperty Members | System.Data.Internal Namespace


IProperty.Parent

[To be supplied.]

[Visual Basic]
ReadOnly Property Parent As Object
[C#]
object Parent {get;}
[C++]
Object* get_Parent() = 0;
[JScript]
abstract function get Parent() : Object;

See Also

IProperty Interface | IProperty Members | System.Data.Internal Namespace


IProperty.PropertyName

[To be supplied.]

[Visual Basic]
ReadOnly Property PropertyName As String
[C#]
string PropertyName {get;}
[C++]
String* get_PropertyName() = 0;
[JScript]
abstract function get PropertyName() : String;

See Also

IProperty Interface | IProperty Members | System.Data.Internal Namespace


IProperty.Value

property values are applied immediately to OLE DB

[Visual Basic]
Property Value As Object
[C#]
object Value {get; set;}
[C++]
Object* get_Value() = 0;void set_Value(Object*) = 0;
[JScript]
abstract function get Value() : Object;
public abstract function set Value(Object);

See Also

IProperty Interface | IProperty Members | System.Data.Internal Namespace


ObjectStorage Class

[To be supplied.]

Object
DataStorage
ObjectStorage

[Visual Basic]
Public Class ObjectStorage
   Inherits DataStorage
[C#]
public class ObjectStorage : DataStorage
[C++]
public __gc class ObjectStorage : public DataStorage
[JScript]
public class ObjectStorage extends DataStorage

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

ObjectStorage Members | System.Data.Internal Namespace


ObjectStorage Members

Public:

Constructor

ObjectStorage Constructor [To be supplied.]

Properties

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

Methods

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue (inherited from DataStorage) | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

ObjectStorage Class | System.Data.Internal Namespace


ObjectStorage Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal type As Type _
)
[C#]
public ObjectStorage(
   Type type
);
[C++]
public: ObjectStorage(
   Type* type
);
[JScript]
public function ObjectStorage(
   type : Type
);

Parameters

type
[To be supplied.]

See Also

ObjectStorage Class | ObjectStorage Members | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ObjectStorage Properties

The properties of the ObjectStorage class are listed below. For a complete list of ObjectStorage class members, see the ObjectStorage Members topic.

Public:

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

See Also

ObjectStorage Class | System.Data.Internal Namespace


ObjectStorage.DefaultValue

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DefaultValue As Object
[C#]
public object DefaultValue {override get;}
[C++]
public: __property virtual Object* get_DefaultValue();
[JScript]
public function get DefaultValue() : Object;

See Also

ObjectStorage Class | ObjectStorage Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ObjectStorage Methods

The methods of the ObjectStorage class are listed below. For a complete list of ObjectStorage class members, see the ObjectStorage Members topic.

Public:

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue (inherited from DataStorage) | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

ObjectStorage Class | System.Data.Internal Namespace


ObjectStorage.Aggregate

[To be supplied.]

[Visual Basic]
Overrides Public Function Aggregate( _
   ByVal records() As Integer, _
   ByVal kind As AggregateTypes _
) As Object
[C#]
public override object Aggregate(
   int[] records,
   AggregateTypes kind
);
[C++]
public: override Object* Aggregate(
   int* records[],
   AggregateTypes kind
);
[JScript]
public override function Aggregate(
   records : int[],
   kind : AggregateTypes
) : Object;

Parameters

records
[To be supplied.]
kind
[To be supplied.]

See Also

ObjectStorage Class | ObjectStorage Members | System.Data.Internal Namespace


ObjectStorage.Compare

[To be supplied.]

[Visual Basic]
Overrides Public Function Compare( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
) As Integer
[C#]
public override int Compare(
   int recordNo1,
   int recordNo2
);
[C++]
public: override int Compare(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Compare(
   recordNo1 : int,
   recordNo2 : int
) : int;

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

ObjectStorage Class | ObjectStorage Members | System.Data.Internal Namespace


ObjectStorage.Copy

[To be supplied.]

[Visual Basic]
Overrides Public Sub Copy( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
)
[C#]
public override void Copy(
   int recordNo1,
   int recordNo2
);
[C++]
public: override void Copy(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Copy(
   recordNo1 : int,
   recordNo2 : int
);

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

ObjectStorage Class | ObjectStorage Members | System.Data.Internal Namespace


ObjectStorage.Get

[To be supplied.]

[Visual Basic]
Overrides Public Function Get( _
   ByVal recordNo As Integer _
) As Object
[C#]
public override object Get(
   int recordNo
);
[C++]
public: override Object* Get(
   int recordNo
);
[JScript]
public override function Get(
   recordNo : int
) : Object;

Parameters

recordNo
[To be supplied.]

See Also

ObjectStorage Class | ObjectStorage Members | System.Data.Internal Namespace


ObjectStorage.Set

[To be supplied.]

[Visual Basic]
Overrides Public Sub Set( _
   ByVal recordNo As Integer, _
   ByVal value As Object _
)
[C#]
public override void Set(
   int recordNo,
   object value
);
[C++]
public: override void Set(
   int recordNo,
   Object* value
);
[JScript]
public override function Set(
   recordNo : int,
   value : Object
);

Parameters

recordNo
[To be supplied.]
value
[To be supplied.]

See Also

ObjectStorage Class | ObjectStorage Members | System.Data.Internal Namespace


ObjectStorage.SetCapacity

[To be supplied.]

[Visual Basic]
Overrides Public Sub SetCapacity( _
   ByVal capacity As Integer _
)
[C#]
public override void SetCapacity(
   int capacity
);
[C++]
public: override void SetCapacity(
   int capacity
);
[JScript]
public override function SetCapacity(
   capacity : int
);

Parameters

capacity
[To be supplied.]

See Also

ObjectStorage Class | ObjectStorage Members | System.Data.Internal Namespace


ObjectStorage.ShiftByOffset

[To be supplied.]

[Visual Basic]
Overrides Public Sub ShiftByOffset( _
   ByVal index As Integer, _
   ByVal length As Integer, _
   ByVal offset As Integer _
)
[C#]
public override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[C++]
public: override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[JScript]
public override function ShiftByOffset(
   index : int,
   length : int,
   offset : int
);

Parameters

index
[To be supplied.]
length
[To be supplied.]
offset
[To be supplied.]

See Also

ObjectStorage Class | ObjectStorage Members | System.Data.Internal Namespace


RowUpdatedEventArgs Class

[To be supplied.]

Object
EventArgs
RowUpdatedEventArgs

[Visual Basic]
MustInherit Public Class RowUpdatedEventArgs
   Inherits EventArgs
[C#]
public abstract class RowUpdatedEventArgs : EventArgs
[C++]
public __gc __abstract class RowUpdatedEventArgs : public EventArgs
[JScript]
public abstract class RowUpdatedEventArgs extends EventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

RowUpdatedEventArgs Members | System.Data.Internal Namespace


RowUpdatedEventArgs Members

Public:

Constructor

RowUpdatedEventArgs Constructor [To be supplied.]

Properties

Command | [To be supplied.]
CommandType | [To be supplied.]
Errors | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
RecordsAffected | [To be supplied.]
Row | [To be supplied.]
Status | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RowUpdatedEventArgs Class | System.Data.Internal Namespace


RowUpdatedEventArgs Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal dataRow As DataRow, _
   ByVal command As DBCommand, _
   ByVal commandType As String _
)
[C#]
public RowUpdatedEventArgs(
   DataRow dataRow,
   DBCommand command,
   string commandType
);
[C++]
public: RowUpdatedEventArgs(
   DataRow* dataRow,
   DBCommand* command,
   String* commandType
);
[JScript]
public function RowUpdatedEventArgs(
   dataRow : DataRow,
   command : DBCommand,
   commandType : String
);

Parameters

dataRow
[To be supplied.]
command
[To be supplied.]
commandType
[To be supplied.]

See Also

RowUpdatedEventArgs Class | RowUpdatedEventArgs Members | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RowUpdatedEventArgs Properties

The properties of the RowUpdatedEventArgs class are listed below. For a complete list of RowUpdatedEventArgs class members, see the RowUpdatedEventArgs Members topic.

Public:

Command | [To be supplied.]
CommandType | [To be supplied.]
Errors | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
RecordsAffected | [To be supplied.]
Row | [To be supplied.]
Status | [To be supplied.]

See Also

RowUpdatedEventArgs Class | System.Data.Internal Namespace


RowUpdatedEventArgs.Command

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Command As DBCommand
[C#]
public DBCommand Command {get;}
[C++]
public: __property DBCommand* get_Command();
[JScript]
public function get Command() : DBCommand;

See Also

RowUpdatedEventArgs Class | RowUpdatedEventArgs Members | System.Data.Internal Namespace


RowUpdatedEventArgs.CommandType

[To be supplied.]

[Visual Basic]
Public ReadOnly Property CommandType As String
[C#]
public string CommandType {get;}
[C++]
public: __property String* get_CommandType();
[JScript]
public function get CommandType() : String;

See Also

RowUpdatedEventArgs Class | RowUpdatedEventArgs Members | System.Data.Internal Namespace


RowUpdatedEventArgs.Errors

[To be supplied.]

[Visual Basic]
Public Property Errors As Exception
[C#]
public Exception Errors {get; set;}
[C++]
public: __property Exception* get_Errors();
public: __property void set_Errors(Exception*);
[JScript]
public function get Errors() : Exception;
public function set Errors(Exception);

See Also

RowUpdatedEventArgs Class | RowUpdatedEventArgs Members | System.Data.Internal Namespace


RowUpdatedEventArgs.RecordsAffected

[To be supplied.]

[Visual Basic]
Public Property RecordsAffected As Integer
[C#]
public int RecordsAffected {get; set;}
[C++]
public: __property int get_RecordsAffected();
public: __property void set_RecordsAffected(int);
[JScript]
public function get RecordsAffected() : int;
public function set RecordsAffected(int);

See Also

RowUpdatedEventArgs Class | RowUpdatedEventArgs Members | System.Data.Internal Namespace


RowUpdatedEventArgs.Row

[To be supplied.]

[Visual Basic]
Public Property Row As DataRow
[C#]
public DataRow Row {get; set;}
[C++]
public: __property DataRow* get_Row();
public: __property void set_Row(DataRow*);
[JScript]
public function get Row() : DataRow;
public function set Row(DataRow);

See Also

RowUpdatedEventArgs Class | RowUpdatedEventArgs Members | System.Data.Internal Namespace


RowUpdatedEventArgs.Status

[To be supplied.]

[Visual Basic]
Public Property Status As UpdateStatus
[C#]
public UpdateStatus Status {get; set;}
[C++]
public: __property UpdateStatus get_Status();
public: __property void set_Status(UpdateStatus);
[JScript]
public function get Status() : UpdateStatus;
public function set Status(UpdateStatus);

See Also

RowUpdatedEventArgs Class | RowUpdatedEventArgs Members | System.Data.Internal Namespace


RowUpdatingEventArgs Class

[To be supplied.]

Object
EventArgs
RowUpdatingEventArgs

[Visual Basic]
MustInherit Public Class RowUpdatingEventArgs
   Inherits EventArgs
[C#]
public abstract class RowUpdatingEventArgs : EventArgs
[C++]
public __gc __abstract class RowUpdatingEventArgs : public
   EventArgs
[JScript]
public abstract class RowUpdatingEventArgs extends EventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

RowUpdatingEventArgs Members | System.Data.Internal Namespace


RowUpdatingEventArgs Members

Public:

Constructor

RowUpdatingEventArgs Constructor [To be supplied.]

Properties

Command | [To be supplied.]
CommandType | [To be supplied.]
Errors | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
Row | [To be supplied.]
Status | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RowUpdatingEventArgs Class | System.Data.Internal Namespace


RowUpdatingEventArgs Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal dataRow As DataRow, _
   ByVal command As DBCommand, _
   ByVal commandType As String _
)
[C#]
public RowUpdatingEventArgs(
   DataRow dataRow,
   DBCommand command,
   string commandType
);
[C++]
public: RowUpdatingEventArgs(
   DataRow* dataRow,
   DBCommand* command,
   String* commandType
);
[JScript]
public function RowUpdatingEventArgs(
   dataRow : DataRow,
   command : DBCommand,
   commandType : String
);

Parameters

dataRow
[To be supplied.]
command
[To be supplied.]
commandType
[To be supplied.]

See Also

RowUpdatingEventArgs Class | RowUpdatingEventArgs Members | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RowUpdatingEventArgs Properties

The properties of the RowUpdatingEventArgs class are listed below. For a complete list of RowUpdatingEventArgs class members, see the RowUpdatingEventArgs Members topic.

Public:

Command | [To be supplied.]
CommandType | [To be supplied.]
Errors | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
Row | [To be supplied.]
Status | [To be supplied.]

See Also

RowUpdatingEventArgs Class | System.Data.Internal Namespace


RowUpdatingEventArgs.Command

[To be supplied.]

[Visual Basic]
Public Property Command As DBCommand
[C#]
public DBCommand Command {get; set;}
[C++]
public: __property DBCommand* get_Command();
public: __property void set_Command(DBCommand*);
[JScript]
public function get Command() : DBCommand;
public function set Command(DBCommand);

See Also

RowUpdatingEventArgs Class | RowUpdatingEventArgs Members | System.Data.Internal Namespace


RowUpdatingEventArgs.CommandType

[To be supplied.]

[Visual Basic]
Public ReadOnly Property CommandType As String
[C#]
public string CommandType {get;}
[C++]
public: __property String* get_CommandType();
[JScript]
public function get CommandType() : String;

See Also

RowUpdatingEventArgs Class | RowUpdatingEventArgs Members | System.Data.Internal Namespace


RowUpdatingEventArgs.Errors

[To be supplied.]

[Visual Basic]
Public Property Errors As Exception
[C#]
public Exception Errors {get; set;}
[C++]
public: __property Exception* get_Errors();
public: __property void set_Errors(Exception*);
[JScript]
public function get Errors() : Exception;
public function set Errors(Exception);

See Also

RowUpdatingEventArgs Class | RowUpdatingEventArgs Members | System.Data.Internal Namespace


RowUpdatingEventArgs.Row

[To be supplied.]

[Visual Basic]
Public Property Row As DataRow
[C#]
public DataRow Row {get; set;}
[C++]
public: __property DataRow* get_Row();
public: __property void set_Row(DataRow*);
[JScript]
public function get Row() : DataRow;
public function set Row(DataRow);

See Also

RowUpdatingEventArgs Class | RowUpdatingEventArgs Members | System.Data.Internal Namespace


RowUpdatingEventArgs.Status

[To be supplied.]

[Visual Basic]
Public Property Status As UpdateStatus
[C#]
public UpdateStatus Status {get; set;}
[C++]
public: __property UpdateStatus get_Status();
public: __property void set_Status(UpdateStatus);
[JScript]
public function get Status() : UpdateStatus;
public function set Status(UpdateStatus);

See Also

RowUpdatingEventArgs Class | RowUpdatingEventArgs Members | System.Data.Internal Namespace


SByteStorage Class

[To be supplied.]

Object
DataStorage
SByteStorage

[Visual Basic]
Public Class SByteStorage
   Inherits DataStorage
[C#]
public class SByteStorage : DataStorage
[C++]
public __gc class SByteStorage : public DataStorage
[JScript]
public class SByteStorage extends DataStorage

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

SByteStorage Members | System.Data.Internal Namespace


SByteStorage Members

Public:

Constructor

SByteStorage Constructor [To be supplied.]

Properties

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

Methods

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

SByteStorage Class | System.Data.Internal Namespace


SByteStorage Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public SByteStorage();
[C++]
public: SByteStorage();
[JScript]
public function SByteStorage();

See Also

SByteStorage Class | SByteStorage Members | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SByteStorage Properties

The properties of the SByteStorage class are listed below. For a complete list of SByteStorage class members, see the SByteStorage Members topic.

Public:

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

See Also

SByteStorage Class | System.Data.Internal Namespace


SByteStorage.DefaultValue

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DefaultValue As Object
[C#]
public object DefaultValue {override get;}
[C++]
public: __property virtual Object* get_DefaultValue();
[JScript]
public function get DefaultValue() : Object;

See Also

SByteStorage Class | SByteStorage Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SByteStorage Methods

The methods of the SByteStorage class are listed below. For a complete list of SByteStorage class members, see the SByteStorage Members topic.

Public:

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

SByteStorage Class | System.Data.Internal Namespace


SByteStorage.Aggregate

[To be supplied.]

[Visual Basic]
Overrides Public Function Aggregate( _
   ByVal records() As Integer, _
   ByVal kind As AggregateTypes _
) As Object
[C#]
public override object Aggregate(
   int[] records,
   AggregateTypes kind
);
[C++]
public: override Object* Aggregate(
   int* records[],
   AggregateTypes kind
);
[JScript]
public override function Aggregate(
   records : int[],
   kind : AggregateTypes
) : Object;

Parameters

records
[To be supplied.]
kind
[To be supplied.]

See Also

SByteStorage Class | SByteStorage Members | System.Data.Internal Namespace


SByteStorage.Compare

[To be supplied.]

[Visual Basic]
Overrides Public Function Compare( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
) As Integer
[C#]
public override int Compare(
   int recordNo1,
   int recordNo2
);
[C++]
public: override int Compare(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Compare(
   recordNo1 : int,
   recordNo2 : int
) : int;

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

SByteStorage Class | SByteStorage Members | System.Data.Internal Namespace


SByteStorage.CompareToValue

[To be supplied.]

[Visual Basic]
Overrides Public Function CompareToValue( _
   ByVal recordNo As Integer, _
   ByVal value As Object _
) As Integer
[C#]
public override int CompareToValue(
   int recordNo,
   object value
);
[C++]
public: override int CompareToValue(
   int recordNo,
   Object* value
);
[JScript]
public override function CompareToValue(
   recordNo : int,
   value : Object
) : int;

Parameters

recordNo
[To be supplied.]
value
[To be supplied.]

See Also

SByteStorage Class | SByteStorage Members | System.Data.Internal Namespace


SByteStorage.Copy

[To be supplied.]

[Visual Basic]
Overrides Public Sub Copy( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
)
[C#]
public override void Copy(
   int recordNo1,
   int recordNo2
);
[C++]
public: override void Copy(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Copy(
   recordNo1 : int,
   recordNo2 : int
);

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

SByteStorage Class | SByteStorage Members | System.Data.Internal Namespace


SByteStorage.Get

[To be supplied.]

[Visual Basic]
Overrides Public Function Get( _
   ByVal record As Integer _
) As Object
[C#]
public override object Get(
   int record
);
[C++]
public: override Object* Get(
   int record
);
[JScript]
public override function Get(
   record : int
) : Object;

Parameters

record
[To be supplied.]

See Also

SByteStorage Class | SByteStorage Members | System.Data.Internal Namespace


SByteStorage.Set

[To be supplied.]

[Visual Basic]
Overrides Public Sub Set( _
   ByVal record As Integer, _
   ByVal value As Object _
)
[C#]
public override void Set(
   int record,
   object value
);
[C++]
public: override void Set(
   int record,
   Object* value
);
[JScript]
public override function Set(
   record : int,
   value : Object
);

Parameters

record
[To be supplied.]
value
[To be supplied.]

See Also

SByteStorage Class | SByteStorage Members | System.Data.Internal Namespace


SByteStorage.SetCapacity

[To be supplied.]

[Visual Basic]
Overrides Public Sub SetCapacity( _
   ByVal capacity As Integer _
)
[C#]
public override void SetCapacity(
   int capacity
);
[C++]
public: override void SetCapacity(
   int capacity
);
[JScript]
public override function SetCapacity(
   capacity : int
);

Parameters

capacity
[To be supplied.]

See Also

SByteStorage Class | SByteStorage Members | System.Data.Internal Namespace


SByteStorage.ShiftByOffset

[To be supplied.]

[Visual Basic]
Overrides Public Sub ShiftByOffset( _
   ByVal index As Integer, _
   ByVal length As Integer, _
   ByVal offset As Integer _
)
[C#]
public override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[C++]
public: override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[JScript]
public override function ShiftByOffset(
   index : int,
   length : int,
   offset : int
);

Parameters

index
[To be supplied.]
length
[To be supplied.]
offset
[To be supplied.]

See Also

SByteStorage Class | SByteStorage Members | System.Data.Internal Namespace


SchemaChangedEventArgs Class

[To be supplied.]

Object
EventArgs
SchemaChangedEventArgs

[Visual Basic]
Public Class SchemaChangedEventArgs
   Inherits EventArgs
[C#]
public class SchemaChangedEventArgs : EventArgs
[C++]
public __gc class SchemaChangedEventArgs : public EventArgs
[JScript]
public class SchemaChangedEventArgs extends EventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

SchemaChangedEventArgs Members | System.Data.Internal Namespace


SchemaChangedEventArgs Members

Public:

Constructor

SchemaChangedEventArgs Constructor Overloaded. [To be supplied.]

Properties

ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
SchemaType | [To be supplied.]
Source | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SchemaChangedEventArgs Class | System.Data.Internal Namespace


SchemaChangedEventArgs Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public SchemaChangedEventArgs();
[C++] public: SchemaChangedEventArgs();
[JScript] public function SchemaChangedEventArgs();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(SchemaType)
[C#] public SchemaChangedEventArgs(SchemaType);
[C++] public: SchemaChangedEventArgs(SchemaType);
[JScript] public function SchemaChangedEventArgs(SchemaType);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(SchemaType, Object)
[C#] public SchemaChangedEventArgs(SchemaType, Object);
[C++] public: SchemaChangedEventArgs(SchemaType, Object);
[JScript] public function SchemaChangedEventArgs(SchemaType, Object);

See Also

SchemaChangedEventArgs Class | SchemaChangedEventArgs Members | System.Data.Internal Namespace


SchemaChangedEventArgs Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public SchemaChangedEventArgs();
[C++]
public: SchemaChangedEventArgs();
[JScript]
public function SchemaChangedEventArgs();

See Also

SchemaChangedEventArgs Class | SchemaChangedEventArgs Members | System.Data.Internal Namespace | SchemaChangedEventArgs Constructor Overload List


SchemaChangedEventArgs Constructor (SchemaType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal schemaType As SchemaType _
)
[C#]
public SchemaChangedEventArgs(
   SchemaType schemaType
);
[C++]
public: SchemaChangedEventArgs(
   SchemaType schemaType
);
[JScript]
public function SchemaChangedEventArgs(
   schemaType : SchemaType
);

Parameters

schemaType
[To be supplied.]

See Also

SchemaChangedEventArgs Class | SchemaChangedEventArgs Members | System.Data.Internal Namespace | SchemaChangedEventArgs Constructor Overload List


SchemaChangedEventArgs Constructor (SchemaType, Object)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal schemaType As SchemaType, _
   ByVal source As Object _
)
[C#]
public SchemaChangedEventArgs(
   SchemaType schemaType,
   object source
);
[C++]
public: SchemaChangedEventArgs(
   SchemaType schemaType,
   Object* source
);
[JScript]
public function SchemaChangedEventArgs(
   schemaType : SchemaType,
   source : Object
);

Parameters

schemaType
[To be supplied.]
source
[To be supplied.]

See Also

SchemaChangedEventArgs Class | SchemaChangedEventArgs Members | System.Data.Internal Namespace | SchemaChangedEventArgs Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SchemaChangedEventArgs Properties

The properties of the SchemaChangedEventArgs class are listed below. For a complete list of SchemaChangedEventArgs class members, see the SchemaChangedEventArgs Members topic.

Public:

ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
SchemaType | [To be supplied.]
Source | [To be supplied.]

See Also

SchemaChangedEventArgs Class | System.Data.Internal Namespace


SchemaChangedEventArgs.SchemaType

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property SchemaType As SchemaType
[C#]
public SchemaType SchemaType {virtual get;}
[C++]
public: __property virtual SchemaType get_SchemaType();
[JScript]
public function get SchemaType() : SchemaType;

See Also

SchemaChangedEventArgs Class | SchemaChangedEventArgs Members | System.Data.Internal Namespace


SchemaChangedEventArgs.Source

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Source As Object
[C#]
public object Source {virtual get;}
[C++]
public: __property virtual Object* get_Source();
[JScript]
public function get Source() : Object;

See Also

SchemaChangedEventArgs Class | SchemaChangedEventArgs Members | System.Data.Internal Namespace


SchemaChangedEventHandler Delegate

[To be supplied.]

[Visual Basic]
Public Delegate Sub SchemaChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As SchemaChangedEventArgs _
)
[C#]
public delegate void SchemaChangedEventHandler(
   object sender,
   SchemaChangedEventArgs e
);
[C++]
public __gc __delegate void SchemaChangedEventHandler(
   Object* sender,
   SchemaChangedEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the SchemaChangedEventHandler delegate declaration.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

System.Data.Internal Namespace


SchemaChangingEventArgs Class

[To be supplied.]

Object
EventArgs
SchemaChangingEventArgs

[Visual Basic]
Public Class SchemaChangingEventArgs
   Inherits EventArgs
[C#]
public class SchemaChangingEventArgs : EventArgs
[C++]
public __gc class SchemaChangingEventArgs : public EventArgs
[JScript]
public class SchemaChangingEventArgs extends EventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

SchemaChangingEventArgs Members | System.Data.Internal Namespace


SchemaChangingEventArgs Members

Public:

Constructor

SchemaChangingEventArgs Constructor Overloaded. [To be supplied.]

Properties

ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
SchemaType | [To be supplied.]
Source | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SchemaChangingEventArgs Class | System.Data.Internal Namespace


SchemaChangingEventArgs Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public SchemaChangingEventArgs();
[C++] public: SchemaChangingEventArgs();
[JScript] public function SchemaChangingEventArgs();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(SchemaType)
[C#] public SchemaChangingEventArgs(SchemaType);
[C++] public: SchemaChangingEventArgs(SchemaType);
[JScript] public function SchemaChangingEventArgs(SchemaType);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(SchemaType, Object)
[C#] public SchemaChangingEventArgs(SchemaType, Object);
[C++] public: SchemaChangingEventArgs(SchemaType, Object);
[JScript] public function SchemaChangingEventArgs(SchemaType, Object);

See Also

SchemaChangingEventArgs Class | SchemaChangingEventArgs Members | System.Data.Internal Namespace


SchemaChangingEventArgs Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public SchemaChangingEventArgs();
[C++]
public: SchemaChangingEventArgs();
[JScript]
public function SchemaChangingEventArgs();

See Also

SchemaChangingEventArgs Class | SchemaChangingEventArgs Members | System.Data.Internal Namespace | SchemaChangingEventArgs Constructor Overload List


SchemaChangingEventArgs Constructor (SchemaType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal schemaType As SchemaType _
)
[C#]
public SchemaChangingEventArgs(
   SchemaType schemaType
);
[C++]
public: SchemaChangingEventArgs(
   SchemaType schemaType
);
[JScript]
public function SchemaChangingEventArgs(
   schemaType : SchemaType
);

Parameters

schemaType
[To be supplied.]

See Also

SchemaChangingEventArgs Class | SchemaChangingEventArgs Members | System.Data.Internal Namespace | SchemaChangingEventArgs Constructor Overload List


SchemaChangingEventArgs Constructor (SchemaType, Object)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal schemaType As SchemaType, _
   ByVal source As Object _
)
[C#]
public SchemaChangingEventArgs(
   SchemaType schemaType,
   object source
);
[C++]
public: SchemaChangingEventArgs(
   SchemaType schemaType,
   Object* source
);
[JScript]
public function SchemaChangingEventArgs(
   schemaType : SchemaType,
   source : Object
);

Parameters

schemaType
[To be supplied.]
source
[To be supplied.]

See Also

SchemaChangingEventArgs Class | SchemaChangingEventArgs Members | System.Data.Internal Namespace | SchemaChangingEventArgs Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SchemaChangingEventArgs Properties

The properties of the SchemaChangingEventArgs class are listed below. For a complete list of SchemaChangingEventArgs class members, see the SchemaChangingEventArgs Members topic.

Public:

ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
SchemaType | [To be supplied.]
Source | [To be supplied.]

See Also

SchemaChangingEventArgs Class | System.Data.Internal Namespace


SchemaChangingEventArgs.SchemaType

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property SchemaType As SchemaType
[C#]
public SchemaType SchemaType {virtual get;}
[C++]
public: __property virtual SchemaType get_SchemaType();
[JScript]
public function get SchemaType() : SchemaType;

See Also

SchemaChangingEventArgs Class | SchemaChangingEventArgs Members | System.Data.Internal Namespace


SchemaChangingEventArgs.Source

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Source As Object
[C#]
public object Source {virtual get;}
[C++]
public: __property virtual Object* get_Source();
[JScript]
public function get Source() : Object;

See Also

SchemaChangingEventArgs Class | SchemaChangingEventArgs Members | System.Data.Internal Namespace


SchemaChangingEventHandler Delegate

[To be supplied.]

[Visual Basic]
Public Delegate Sub SchemaChangingEventHandler( _
   ByVal sender As Object, _
   ByVal e As SchemaChangingEventArgs _
)
[C#]
public delegate void SchemaChangingEventHandler(
   object sender,
   SchemaChangingEventArgs e
);
[C++]
public __gc __delegate void SchemaChangingEventHandler(
   Object* sender,
   SchemaChangingEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the SchemaChangingEventHandler delegate declaration.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

System.Data.Internal Namespace


SchemaMappingEventArgs Class

[To be supplied.]

Object
EventArgs
SchemaMappingEventArgs

[Visual Basic]
MustInherit Public Class SchemaMappingEventArgs
   Inherits EventArgs
[C#]
public abstract class SchemaMappingEventArgs : EventArgs
[C++]
public __gc __abstract class SchemaMappingEventArgs : public
   EventArgs
[JScript]
public abstract class SchemaMappingEventArgs extends EventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

SchemaMappingEventArgs Members | System.Data.Internal Namespace


SchemaMappingEventArgs Members

Public:

Properties

Command | [To be supplied.]
DataSet | [To be supplied.]
DataTable | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
PrimaryKey | [To be supplied.]
SchemaTable | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SchemaMappingEventArgs Class | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SchemaMappingEventArgs Properties

The properties of the SchemaMappingEventArgs class are listed below. For a complete list of SchemaMappingEventArgs class members, see the SchemaMappingEventArgs Members topic.

Public:

Command | [To be supplied.]
DataSet | [To be supplied.]
DataTable | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
PrimaryKey | [To be supplied.]
SchemaTable | [To be supplied.]

See Also

SchemaMappingEventArgs Class | System.Data.Internal Namespace


SchemaMappingEventArgs.Command

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Command As DBCommand
[C#]
public DBCommand Command {get;}
[C++]
public: __property DBCommand* get_Command();
[JScript]
public function get Command() : DBCommand;

See Also

SchemaMappingEventArgs Class | SchemaMappingEventArgs Members | System.Data.Internal Namespace


SchemaMappingEventArgs.DataSet

[To be supplied.]

[Visual Basic]
Public ReadOnly Property DataSet As DataSet
[C#]
public DataSet DataSet {get;}
[C++]
public: __property DataSet* get_DataSet();
[JScript]
public function get DataSet() : DataSet;

See Also

SchemaMappingEventArgs Class | SchemaMappingEventArgs Members | System.Data.Internal Namespace


SchemaMappingEventArgs.DataTable

[To be supplied.]

[Visual Basic]
Public Property DataTable As DataTable
[C#]
public DataTable DataTable {get; set;}
[C++]
public: __property DataTable* get_DataTable();
public: __property void set_DataTable(DataTable*);
[JScript]
public function get DataTable() : DataTable;
public function set DataTable(DataTable);

See Also

SchemaMappingEventArgs Class | SchemaMappingEventArgs Members | System.Data.Internal Namespace


SchemaMappingEventArgs.PrimaryKey

[To be supplied.]

[Visual Basic]
Public Property PrimaryKey As DataColumn ()
[C#]
public DataColumn[] PrimaryKey {get; set;}
[C++]
public: __property DataColumn* get_PrimaryKey();
public: __property void set_PrimaryKey(DataColumn*[]);
[JScript]
public function get PrimaryKey() : DataColumn[];
public function set PrimaryKey(DataColumn[]);

See Also

SchemaMappingEventArgs Class | SchemaMappingEventArgs Members | System.Data.Internal Namespace


SchemaMappingEventArgs.SchemaTable

[To be supplied.]

[Visual Basic]
Public ReadOnly Property SchemaTable As DataTable
[C#]
public DataTable SchemaTable {get;}
[C++]
public: __property DataTable* get_SchemaTable();
[JScript]
public function get SchemaTable() : DataTable;

See Also

SchemaMappingEventArgs Class | SchemaMappingEventArgs Members | System.Data.Internal Namespace


SingleStorage Class

[To be supplied.]

Object
DataStorage
SingleStorage

[Visual Basic]
Public Class SingleStorage
   Inherits DataStorage
[C#]
public class SingleStorage : DataStorage
[C++]
public __gc class SingleStorage : public DataStorage
[JScript]
public class SingleStorage extends DataStorage

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

SingleStorage Members | System.Data.Internal Namespace


SingleStorage Members

Public:

Constructor

SingleStorage Constructor [To be supplied.]

Properties

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

Methods

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

SingleStorage Class | System.Data.Internal Namespace


SingleStorage Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public SingleStorage();
[C++]
public: SingleStorage();
[JScript]
public function SingleStorage();

See Also

SingleStorage Class | SingleStorage Members | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SingleStorage Properties

The properties of the SingleStorage class are listed below. For a complete list of SingleStorage class members, see the SingleStorage Members topic.

Public:

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

See Also

SingleStorage Class | System.Data.Internal Namespace


SingleStorage.DefaultValue

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DefaultValue As Object
[C#]
public object DefaultValue {override get;}
[C++]
public: __property virtual Object* get_DefaultValue();
[JScript]
public function get DefaultValue() : Object;

See Also

SingleStorage Class | SingleStorage Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SingleStorage Methods

The methods of the SingleStorage class are listed below. For a complete list of SingleStorage class members, see the SingleStorage Members topic.

Public:

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

SingleStorage Class | System.Data.Internal Namespace


SingleStorage.Aggregate

[To be supplied.]

[Visual Basic]
Overrides Public Function Aggregate( _
   ByVal records() As Integer, _
   ByVal kind As AggregateTypes _
) As Object
[C#]
public override object Aggregate(
   int[] records,
   AggregateTypes kind
);
[C++]
public: override Object* Aggregate(
   int* records[],
   AggregateTypes kind
);
[JScript]
public override function Aggregate(
   records : int[],
   kind : AggregateTypes
) : Object;

Parameters

records
[To be supplied.]
kind
[To be supplied.]

See Also

SingleStorage Class | SingleStorage Members | System.Data.Internal Namespace


SingleStorage.Compare

[To be supplied.]

[Visual Basic]
Overrides Public Function Compare( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
) As Integer
[C#]
public override int Compare(
   int recordNo1,
   int recordNo2
);
[C++]
public: override int Compare(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Compare(
   recordNo1 : int,
   recordNo2 : int
) : int;

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

SingleStorage Class | SingleStorage Members | System.Data.Internal Namespace


SingleStorage.CompareToValue

[To be supplied.]

[Visual Basic]
Overrides Public Function CompareToValue( _
   ByVal recordNo As Integer, _
   ByVal value As Object _
) As Integer
[C#]
public override int CompareToValue(
   int recordNo,
   object value
);
[C++]
public: override int CompareToValue(
   int recordNo,
   Object* value
);
[JScript]
public override function CompareToValue(
   recordNo : int,
   value : Object
) : int;

Parameters

recordNo
[To be supplied.]
value
[To be supplied.]

See Also

SingleStorage Class | SingleStorage Members | System.Data.Internal Namespace


SingleStorage.Copy

[To be supplied.]

[Visual Basic]
Overrides Public Sub Copy( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
)
[C#]
public override void Copy(
   int recordNo1,
   int recordNo2
);
[C++]
public: override void Copy(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Copy(
   recordNo1 : int,
   recordNo2 : int
);

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

SingleStorage Class | SingleStorage Members | System.Data.Internal Namespace


SingleStorage.Get

[To be supplied.]

[Visual Basic]
Overrides Public Function Get( _
   ByVal record As Integer _
) As Object
[C#]
public override object Get(
   int record
);
[C++]
public: override Object* Get(
   int record
);
[JScript]
public override function Get(
   record : int
) : Object;

Parameters

record
[To be supplied.]

See Also

SingleStorage Class | SingleStorage Members | System.Data.Internal Namespace


SingleStorage.Set

[To be supplied.]

[Visual Basic]
Overrides Public Sub Set( _
   ByVal record As Integer, _
   ByVal value As Object _
)
[C#]
public override void Set(
   int record,
   object value
);
[C++]
public: override void Set(
   int record,
   Object* value
);
[JScript]
public override function Set(
   record : int,
   value : Object
);

Parameters

record
[To be supplied.]
value
[To be supplied.]

See Also

SingleStorage Class | SingleStorage Members | System.Data.Internal Namespace


SingleStorage.SetCapacity

[To be supplied.]

[Visual Basic]
Overrides Public Sub SetCapacity( _
   ByVal capacity As Integer _
)
[C#]
public override void SetCapacity(
   int capacity
);
[C++]
public: override void SetCapacity(
   int capacity
);
[JScript]
public override function SetCapacity(
   capacity : int
);

Parameters

capacity
[To be supplied.]

See Also

SingleStorage Class | SingleStorage Members | System.Data.Internal Namespace


SingleStorage.ShiftByOffset

[To be supplied.]

[Visual Basic]
Overrides Public Sub ShiftByOffset( _
   ByVal index As Integer, _
   ByVal length As Integer, _
   ByVal offset As Integer _
)
[C#]
public override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[C++]
public: override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[JScript]
public override function ShiftByOffset(
   index : int,
   length : int,
   offset : int
);

Parameters

index
[To be supplied.]
length
[To be supplied.]
offset
[To be supplied.]

See Also

SingleStorage Class | SingleStorage Members | System.Data.Internal Namespace


SparseStorage Class

[To be supplied.]

Object
DataStorage
SparseStorage

[Visual Basic]
Public Class SparseStorage
   Inherits DataStorage
[C#]
public class SparseStorage : DataStorage
[C++]
public __gc class SparseStorage : public DataStorage
[JScript]
public class SparseStorage extends DataStorage

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

SparseStorage Members | System.Data.Internal Namespace


SparseStorage Members

Public:

Constructor

SparseStorage Constructor [To be supplied.]

Properties

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

Methods

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue (inherited from DataStorage) | [To be supplied.]
Copy (inherited from DataStorage) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

SparseStorage Class | System.Data.Internal Namespace


SparseStorage Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal type As Type _
)
[C#]
public SparseStorage(
   Type type
);
[C++]
public: SparseStorage(
   Type* type
);
[JScript]
public function SparseStorage(
   type : Type
);

Parameters

type
[To be supplied.]

See Also

SparseStorage Class | SparseStorage Members | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SparseStorage Properties

The properties of the SparseStorage class are listed below. For a complete list of SparseStorage class members, see the SparseStorage Members topic.

Public:

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

See Also

SparseStorage Class | System.Data.Internal Namespace


SparseStorage.DefaultValue

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DefaultValue As Object
[C#]
public object DefaultValue {override get;}
[C++]
public: __property virtual Object* get_DefaultValue();
[JScript]
public function get DefaultValue() : Object;

See Also

SparseStorage Class | SparseStorage Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SparseStorage Methods

The methods of the SparseStorage class are listed below. For a complete list of SparseStorage class members, see the SparseStorage Members topic.

Public:

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue (inherited from DataStorage) | [To be supplied.]
Copy (inherited from DataStorage) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

SparseStorage Class | System.Data.Internal Namespace


SparseStorage.Aggregate

[To be supplied.]

[Visual Basic]
Overrides Public Function Aggregate( _
   ByVal recordNos() As Integer, _
   ByVal kind As AggregateTypes _
) As Object
[C#]
public override object Aggregate(
   int[] recordNos,
   AggregateTypes kind
);
[C++]
public: override Object* Aggregate(
   int* recordNos[],
   AggregateTypes kind
);
[JScript]
public override function Aggregate(
   recordNos : int[],
   kind : AggregateTypes
) : Object;

Parameters

recordNos
[To be supplied.]
kind
[To be supplied.]

See Also

SparseStorage Class | SparseStorage Members | System.Data.Internal Namespace


SparseStorage.Compare

[To be supplied.]

[Visual Basic]
Overrides Public Function Compare( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
) As Integer
[C#]
public override int Compare(
   int recordNo1,
   int recordNo2
);
[C++]
public: override int Compare(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Compare(
   recordNo1 : int,
   recordNo2 : int
) : int;

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

SparseStorage Class | SparseStorage Members | System.Data.Internal Namespace


SparseStorage.Get

[To be supplied.]

[Visual Basic]
Overrides Public Function Get( _
   ByVal recordNo As Integer _
) As Object
[C#]
public override object Get(
   int recordNo
);
[C++]
public: override Object* Get(
   int recordNo
);
[JScript]
public override function Get(
   recordNo : int
) : Object;

Parameters

recordNo
[To be supplied.]

See Also

SparseStorage Class | SparseStorage Members | System.Data.Internal Namespace


SparseStorage.Set

[To be supplied.]

[Visual Basic]
Overrides Public Sub Set( _
   ByVal recordNo As Integer, _
   ByVal value As Object _
)
[C#]
public override void Set(
   int recordNo,
   object value
);
[C++]
public: override void Set(
   int recordNo,
   Object* value
);
[JScript]
public override function Set(
   recordNo : int,
   value : Object
);

Parameters

recordNo
[To be supplied.]
value
[To be supplied.]

See Also

SparseStorage Class | SparseStorage Members | System.Data.Internal Namespace


SparseStorage.SetCapacity

[To be supplied.]

[Visual Basic]
Overrides Public Sub SetCapacity( _
   ByVal capacity As Integer _
)
[C#]
public override void SetCapacity(
   int capacity
);
[C++]
public: override void SetCapacity(
   int capacity
);
[JScript]
public override function SetCapacity(
   capacity : int
);

Parameters

capacity
[To be supplied.]

See Also

SparseStorage Class | SparseStorage Members | System.Data.Internal Namespace


SparseStorage.ShiftByOffset

[To be supplied.]

[Visual Basic]
Overrides Public Sub ShiftByOffset( _
   ByVal index As Integer, _
   ByVal length As Integer, _
   ByVal offset As Integer _
)
[C#]
public override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[C++]
public: override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[JScript]
public override function ShiftByOffset(
   index : int,
   length : int,
   offset : int
);

Parameters

index
[To be supplied.]
length
[To be supplied.]
offset
[To be supplied.]

See Also

SparseStorage Class | SparseStorage Members | System.Data.Internal Namespace


StringStorage Class

[To be supplied.]

Object
DataStorage
StringStorage

[Visual Basic]
Public Class StringStorage
   Inherits DataStorage
[C#]
public class StringStorage : DataStorage
[C++]
public __gc class StringStorage : public DataStorage
[JScript]
public class StringStorage extends DataStorage

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

StringStorage Members | System.Data.Internal Namespace


StringStorage Members

Public:

Constructor

StringStorage Constructor [To be supplied.]

Properties

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

Methods

Aggregate | [To be supplied.]
Compare | Overloaded. [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

StringStorage Class | System.Data.Internal Namespace


StringStorage Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public StringStorage();
[C++]
public: StringStorage();
[JScript]
public function StringStorage();

See Also

StringStorage Class | StringStorage Members | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StringStorage Properties

The properties of the StringStorage class are listed below. For a complete list of StringStorage class members, see the StringStorage Members topic.

Public:

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

See Also

StringStorage Class | System.Data.Internal Namespace


StringStorage.DefaultValue

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DefaultValue As Object
[C#]
public object DefaultValue {override get;}
[C++]
public: __property virtual Object* get_DefaultValue();
[JScript]
public function get DefaultValue() : Object;

See Also

StringStorage Class | StringStorage Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StringStorage Methods

The methods of the StringStorage class are listed below. For a complete list of StringStorage class members, see the StringStorage Members topic.

Public:

Aggregate | [To be supplied.]
Compare | Overloaded. [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

StringStorage Class | System.Data.Internal Namespace


StringStorage.Aggregate

[To be supplied.]

[Visual Basic]
Overrides Public Function Aggregate( _
   ByVal recordNos() As Integer, _
   ByVal kind As AggregateTypes _
) As Object
[C#]
public override object Aggregate(
   int[] recordNos,
   AggregateTypes kind
);
[C++]
public: override Object* Aggregate(
   int* recordNos[],
   AggregateTypes kind
);
[JScript]
public override function Aggregate(
   recordNos : int[],
   kind : AggregateTypes
) : Object;

Parameters

recordNos
[To be supplied.]
kind
[To be supplied.]

See Also

StringStorage Class | StringStorage Members | System.Data.Internal Namespace


StringStorage.Compare

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overrides Public Function Compare(Integer, Integer) As Integer
[C#] public override int Compare(int, int);
[C++] public: override int Compare(int, int);
[JScript] public override function Compare(int, int) : int;

[To be supplied.]

[Visual Basic] Overloads Public Function Compare(String, String) As Integer
[C#] public int Compare(String, String);
[C++] public: int Compare(String*, String*);
[JScript] public function Compare(String, String) : int;

See Also

StringStorage Class | StringStorage Members | System.Data.Internal Namespace


StringStorage.Compare (Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Function Compare( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
) As Integer
[C#]
public override int Compare(
   int recordNo1,
   int recordNo2
);
[C++]
public: override int Compare(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Compare(
   recordNo1 : int,
   recordNo2 : int
) : int;

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

StringStorage Class | StringStorage Members | System.Data.Internal Namespace | StringStorage.Compare Overload List


StringStorage.Compare (String, String)

[To be supplied.]

[Visual Basic]
Overloads Public Function Compare( _
   ByVal s1 As String, _
   ByVal s2 As String _
) As Integer
[C#]
public int Compare(
   string s1,
   string s2
);
[C++]
public: int Compare(
   String* s1,
   String* s2
);
[JScript]
public function Compare(
   s1 : String,
   s2 : String
) : int;

Parameters

s1
[To be supplied.]
s2
[To be supplied.]

See Also

StringStorage Class | StringStorage Members | System.Data.Internal Namespace | StringStorage.Compare Overload List


StringStorage.CompareToValue

[To be supplied.]

[Visual Basic]
Overrides Public Function CompareToValue( _
   ByVal recordNo As Integer, _
   ByVal value As Object _
) As Integer
[C#]
public override int CompareToValue(
   int recordNo,
   object value
);
[C++]
public: override int CompareToValue(
   int recordNo,
   Object* value
);
[JScript]
public override function CompareToValue(
   recordNo : int,
   value : Object
) : int;

Parameters

recordNo
[To be supplied.]
value
[To be supplied.]

See Also

StringStorage Class | StringStorage Members | System.Data.Internal Namespace


StringStorage.Copy

[To be supplied.]

[Visual Basic]
Overrides Public Sub Copy( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
)
[C#]
public override void Copy(
   int recordNo1,
   int recordNo2
);
[C++]
public: override void Copy(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Copy(
   recordNo1 : int,
   recordNo2 : int
);

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

StringStorage Class | StringStorage Members | System.Data.Internal Namespace


StringStorage.Get

[To be supplied.]

[Visual Basic]
Overrides Public Function Get( _
   ByVal recordNo As Integer _
) As Object
[C#]
public override object Get(
   int recordNo
);
[C++]
public: override Object* Get(
   int recordNo
);
[JScript]
public override function Get(
   recordNo : int
) : Object;

Parameters

recordNo
[To be supplied.]

See Also

StringStorage Class | StringStorage Members | System.Data.Internal Namespace


StringStorage.Set

[To be supplied.]

[Visual Basic]
Overrides Public Sub Set( _
   ByVal recordNo As Integer, _
   ByVal value As Object _
)
[C#]
public override void Set(
   int recordNo,
   object value
);
[C++]
public: override void Set(
   int recordNo,
   Object* value
);
[JScript]
public override function Set(
   recordNo : int,
   value : Object
);

Parameters

recordNo
[To be supplied.]
value
[To be supplied.]

See Also

StringStorage Class | StringStorage Members | System.Data.Internal Namespace


StringStorage.SetCapacity

[To be supplied.]

[Visual Basic]
Overrides Public Sub SetCapacity( _
   ByVal capacity As Integer _
)
[C#]
public override void SetCapacity(
   int capacity
);
[C++]
public: override void SetCapacity(
   int capacity
);
[JScript]
public override function SetCapacity(
   capacity : int
);

Parameters

capacity
[To be supplied.]

See Also

StringStorage Class | StringStorage Members | System.Data.Internal Namespace


StringStorage.ShiftByOffset

[To be supplied.]

[Visual Basic]
Overrides Public Sub ShiftByOffset( _
   ByVal index As Integer, _
   ByVal length As Integer, _
   ByVal offset As Integer _
)
[C#]
public override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[C++]
public: override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[JScript]
public override function ShiftByOffset(
   index : int,
   length : int,
   offset : int
);

Parameters

index
[To be supplied.]
length
[To be supplied.]
offset
[To be supplied.]

See Also

StringStorage Class | StringStorage Members | System.Data.Internal Namespace


TimeSpanStorage Class

[To be supplied.]

Object
DataStorage
TimeSpanStorage

[Visual Basic]
Public Class TimeSpanStorage
   Inherits DataStorage
[C#]
public class TimeSpanStorage : DataStorage
[C++]
public __gc class TimeSpanStorage : public DataStorage
[JScript]
public class TimeSpanStorage extends DataStorage

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

TimeSpanStorage Members | System.Data.Internal Namespace


TimeSpanStorage Members

Public:

Constructor

TimeSpanStorage Constructor [To be supplied.]

Properties

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

Methods

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

TimeSpanStorage Class | System.Data.Internal Namespace


TimeSpanStorage Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public TimeSpanStorage();
[C++]
public: TimeSpanStorage();
[JScript]
public function TimeSpanStorage();

See Also

TimeSpanStorage Class | TimeSpanStorage Members | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TimeSpanStorage Properties

The properties of the TimeSpanStorage class are listed below. For a complete list of TimeSpanStorage class members, see the TimeSpanStorage Members topic.

Public:

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

See Also

TimeSpanStorage Class | System.Data.Internal Namespace


TimeSpanStorage.DefaultValue

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DefaultValue As Object
[C#]
public object DefaultValue {override get;}
[C++]
public: __property virtual Object* get_DefaultValue();
[JScript]
public function get DefaultValue() : Object;

See Also

TimeSpanStorage Class | TimeSpanStorage Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TimeSpanStorage Methods

The methods of the TimeSpanStorage class are listed below. For a complete list of TimeSpanStorage class members, see the TimeSpanStorage Members topic.

Public:

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

TimeSpanStorage Class | System.Data.Internal Namespace


TimeSpanStorage.Aggregate

[To be supplied.]

[Visual Basic]
Overrides Public Function Aggregate( _
   ByVal records() As Integer, _
   ByVal kind As AggregateTypes _
) As Object
[C#]
public override object Aggregate(
   int[] records,
   AggregateTypes kind
);
[C++]
public: override Object* Aggregate(
   int* records[],
   AggregateTypes kind
);
[JScript]
public override function Aggregate(
   records : int[],
   kind : AggregateTypes
) : Object;

Parameters

records
[To be supplied.]
kind
[To be supplied.]

See Also

TimeSpanStorage Class | TimeSpanStorage Members | System.Data.Internal Namespace


TimeSpanStorage.Compare

[To be supplied.]

[Visual Basic]
Overrides Public Function Compare( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
) As Integer
[C#]
public override int Compare(
   int recordNo1,
   int recordNo2
);
[C++]
public: override int Compare(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Compare(
   recordNo1 : int,
   recordNo2 : int
) : int;

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

TimeSpanStorage Class | TimeSpanStorage Members | System.Data.Internal Namespace


TimeSpanStorage.CompareToValue

[To be supplied.]

[Visual Basic]
Overrides Public Function CompareToValue( _
   ByVal recordNo As Integer, _
   ByVal value As Object _
) As Integer
[C#]
public override int CompareToValue(
   int recordNo,
   object value
);
[C++]
public: override int CompareToValue(
   int recordNo,
   Object* value
);
[JScript]
public override function CompareToValue(
   recordNo : int,
   value : Object
) : int;

Parameters

recordNo
[To be supplied.]
value
[To be supplied.]

See Also

TimeSpanStorage Class | TimeSpanStorage Members | System.Data.Internal Namespace


TimeSpanStorage.Copy

[To be supplied.]

[Visual Basic]
Overrides Public Sub Copy( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
)
[C#]
public override void Copy(
   int recordNo1,
   int recordNo2
);
[C++]
public: override void Copy(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Copy(
   recordNo1 : int,
   recordNo2 : int
);

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

TimeSpanStorage Class | TimeSpanStorage Members | System.Data.Internal Namespace


TimeSpanStorage.Get

[To be supplied.]

[Visual Basic]
Overrides Public Function Get( _
   ByVal record As Integer _
) As Object
[C#]
public override object Get(
   int record
);
[C++]
public: override Object* Get(
   int record
);
[JScript]
public override function Get(
   record : int
) : Object;

Parameters

record
[To be supplied.]

See Also

TimeSpanStorage Class | TimeSpanStorage Members | System.Data.Internal Namespace


TimeSpanStorage.Set

[To be supplied.]

[Visual Basic]
Overrides Public Sub Set( _
   ByVal record As Integer, _
   ByVal value As Object _
)
[C#]
public override void Set(
   int record,
   object value
);
[C++]
public: override void Set(
   int record,
   Object* value
);
[JScript]
public override function Set(
   record : int,
   value : Object
);

Parameters

record
[To be supplied.]
value
[To be supplied.]

See Also

TimeSpanStorage Class | TimeSpanStorage Members | System.Data.Internal Namespace


TimeSpanStorage.SetCapacity

[To be supplied.]

[Visual Basic]
Overrides Public Sub SetCapacity( _
   ByVal capacity As Integer _
)
[C#]
public override void SetCapacity(
   int capacity
);
[C++]
public: override void SetCapacity(
   int capacity
);
[JScript]
public override function SetCapacity(
   capacity : int
);

Parameters

capacity
[To be supplied.]

See Also

TimeSpanStorage Class | TimeSpanStorage Members | System.Data.Internal Namespace


TimeSpanStorage.ShiftByOffset

[To be supplied.]

[Visual Basic]
Overrides Public Sub ShiftByOffset( _
   ByVal index As Integer, _
   ByVal length As Integer, _
   ByVal offset As Integer _
)
[C#]
public override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[C++]
public: override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[JScript]
public override function ShiftByOffset(
   index : int,
   length : int,
   offset : int
);

Parameters

index
[To be supplied.]
length
[To be supplied.]
offset
[To be supplied.]

See Also

TimeSpanStorage Class | TimeSpanStorage Members | System.Data.Internal Namespace


UInt16Storage Class

[To be supplied.]

Object
DataStorage
UInt16Storage

[Visual Basic]
Public Class UInt16Storage
   Inherits DataStorage
[C#]
public class UInt16Storage : DataStorage
[C++]
public __gc class UInt16Storage : public DataStorage
[JScript]
public class UInt16Storage extends DataStorage

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

UInt16Storage Members | System.Data.Internal Namespace


UInt16Storage Members

Public:

Constructor

UInt16Storage Constructor [To be supplied.]

Properties

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

Methods

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

UInt16Storage Class | System.Data.Internal Namespace


UInt16Storage Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public UInt16Storage();
[C++]
public: UInt16Storage();
[JScript]
public function UInt16Storage();

See Also

UInt16Storage Class | UInt16Storage Members | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UInt16Storage Properties

The properties of the UInt16Storage class are listed below. For a complete list of UInt16Storage class members, see the UInt16Storage Members topic.

Public:

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

See Also

UInt16Storage Class | System.Data.Internal Namespace


UInt16Storage.DefaultValue

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DefaultValue As Object
[C#]
public object DefaultValue {override get;}
[C++]
public: __property virtual Object* get_DefaultValue();
[JScript]
public function get DefaultValue() : Object;

See Also

UInt16Storage Class | UInt16Storage Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UInt16Storage Methods

The methods of the UInt16Storage class are listed below. For a complete list of UInt16Storage class members, see the UInt16Storage Members topic.

Public:

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

UInt16Storage Class | System.Data.Internal Namespace


UInt16Storage.Aggregate

[To be supplied.]

[Visual Basic]
Overrides Public Function Aggregate( _
   ByVal records() As Integer, _
   ByVal kind As AggregateTypes _
) As Object
[C#]
public override object Aggregate(
   int[] records,
   AggregateTypes kind
);
[C++]
public: override Object* Aggregate(
   int* records[],
   AggregateTypes kind
);
[JScript]
public override function Aggregate(
   records : int[],
   kind : AggregateTypes
) : Object;

Parameters

records
[To be supplied.]
kind
[To be supplied.]

See Also

UInt16Storage Class | UInt16Storage Members | System.Data.Internal Namespace


UInt16Storage.Compare

[To be supplied.]

[Visual Basic]
Overrides Public Function Compare( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
) As Integer
[C#]
public override int Compare(
   int recordNo1,
   int recordNo2
);
[C++]
public: override int Compare(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Compare(
   recordNo1 : int,
   recordNo2 : int
) : int;

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

UInt16Storage Class | UInt16Storage Members | System.Data.Internal Namespace


UInt16Storage.CompareToValue

[To be supplied.]

[Visual Basic]
Overrides Public Function CompareToValue( _
   ByVal recordNo As Integer, _
   ByVal value As Object _
) As Integer
[C#]
public override int CompareToValue(
   int recordNo,
   object value
);
[C++]
public: override int CompareToValue(
   int recordNo,
   Object* value
);
[JScript]
public override function CompareToValue(
   recordNo : int,
   value : Object
) : int;

Parameters

recordNo
[To be supplied.]
value
[To be supplied.]

See Also

UInt16Storage Class | UInt16Storage Members | System.Data.Internal Namespace


UInt16Storage.Copy

[To be supplied.]

[Visual Basic]
Overrides Public Sub Copy( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
)
[C#]
public override void Copy(
   int recordNo1,
   int recordNo2
);
[C++]
public: override void Copy(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Copy(
   recordNo1 : int,
   recordNo2 : int
);

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

UInt16Storage Class | UInt16Storage Members | System.Data.Internal Namespace


UInt16Storage.Get

[To be supplied.]

[Visual Basic]
Overrides Public Function Get( _
   ByVal record As Integer _
) As Object
[C#]
public override object Get(
   int record
);
[C++]
public: override Object* Get(
   int record
);
[JScript]
public override function Get(
   record : int
) : Object;

Parameters

record
[To be supplied.]

See Also

UInt16Storage Class | UInt16Storage Members | System.Data.Internal Namespace


UInt16Storage.Set

[To be supplied.]

[Visual Basic]
Overrides Public Sub Set( _
   ByVal record As Integer, _
   ByVal value As Object _
)
[C#]
public override void Set(
   int record,
   object value
);
[C++]
public: override void Set(
   int record,
   Object* value
);
[JScript]
public override function Set(
   record : int,
   value : Object
);

Parameters

record
[To be supplied.]
value
[To be supplied.]

See Also

UInt16Storage Class | UInt16Storage Members | System.Data.Internal Namespace


UInt16Storage.SetCapacity

[To be supplied.]

[Visual Basic]
Overrides Public Sub SetCapacity( _
   ByVal capacity As Integer _
)
[C#]
public override void SetCapacity(
   int capacity
);
[C++]
public: override void SetCapacity(
   int capacity
);
[JScript]
public override function SetCapacity(
   capacity : int
);

Parameters

capacity
[To be supplied.]

See Also

UInt16Storage Class | UInt16Storage Members | System.Data.Internal Namespace


UInt16Storage.ShiftByOffset

[To be supplied.]

[Visual Basic]
Overrides Public Sub ShiftByOffset( _
   ByVal index As Integer, _
   ByVal length As Integer, _
   ByVal offset As Integer _
)
[C#]
public override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[C++]
public: override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[JScript]
public override function ShiftByOffset(
   index : int,
   length : int,
   offset : int
);

Parameters

index
[To be supplied.]
length
[To be supplied.]
offset
[To be supplied.]

See Also

UInt16Storage Class | UInt16Storage Members | System.Data.Internal Namespace


UInt32Storage Class

[To be supplied.]

Object
DataStorage
UInt32Storage

[Visual Basic]
Public Class UInt32Storage
   Inherits DataStorage
[C#]
public class UInt32Storage : DataStorage
[C++]
public __gc class UInt32Storage : public DataStorage
[JScript]
public class UInt32Storage extends DataStorage

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

UInt32Storage Members | System.Data.Internal Namespace


UInt32Storage Members

Public:

Constructor

UInt32Storage Constructor [To be supplied.]

Properties

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

Methods

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

UInt32Storage Class | System.Data.Internal Namespace


UInt32Storage Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public UInt32Storage();
[C++]
public: UInt32Storage();
[JScript]
public function UInt32Storage();

See Also

UInt32Storage Class | UInt32Storage Members | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UInt32Storage Properties

The properties of the UInt32Storage class are listed below. For a complete list of UInt32Storage class members, see the UInt32Storage Members topic.

Public:

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

See Also

UInt32Storage Class | System.Data.Internal Namespace


UInt32Storage.DefaultValue

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DefaultValue As Object
[C#]
public object DefaultValue {override get;}
[C++]
public: __property virtual Object* get_DefaultValue();
[JScript]
public function get DefaultValue() : Object;

See Also

UInt32Storage Class | UInt32Storage Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UInt32Storage Methods

The methods of the UInt32Storage class are listed below. For a complete list of UInt32Storage class members, see the UInt32Storage Members topic.

Public:

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

UInt32Storage Class | System.Data.Internal Namespace


UInt32Storage.Aggregate

[To be supplied.]

[Visual Basic]
Overrides Public Function Aggregate( _
   ByVal records() As Integer, _
   ByVal kind As AggregateTypes _
) As Object
[C#]
public override object Aggregate(
   int[] records,
   AggregateTypes kind
);
[C++]
public: override Object* Aggregate(
   int* records[],
   AggregateTypes kind
);
[JScript]
public override function Aggregate(
   records : int[],
   kind : AggregateTypes
) : Object;

Parameters

records
[To be supplied.]
kind
[To be supplied.]

See Also

UInt32Storage Class | UInt32Storage Members | System.Data.Internal Namespace


UInt32Storage.Compare

[To be supplied.]

[Visual Basic]
Overrides Public Function Compare( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
) As Integer
[C#]
public override int Compare(
   int recordNo1,
   int recordNo2
);
[C++]
public: override int Compare(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Compare(
   recordNo1 : int,
   recordNo2 : int
) : int;

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

UInt32Storage Class | UInt32Storage Members | System.Data.Internal Namespace


UInt32Storage.CompareToValue

[To be supplied.]

[Visual Basic]
Overrides Public Function CompareToValue( _
   ByVal recordNo As Integer, _
   ByVal value As Object _
) As Integer
[C#]
public override int CompareToValue(
   int recordNo,
   object value
);
[C++]
public: override int CompareToValue(
   int recordNo,
   Object* value
);
[JScript]
public override function CompareToValue(
   recordNo : int,
   value : Object
) : int;

Parameters

recordNo
[To be supplied.]
value
[To be supplied.]

See Also

UInt32Storage Class | UInt32Storage Members | System.Data.Internal Namespace


UInt32Storage.Copy

[To be supplied.]

[Visual Basic]
Overrides Public Sub Copy( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
)
[C#]
public override void Copy(
   int recordNo1,
   int recordNo2
);
[C++]
public: override void Copy(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Copy(
   recordNo1 : int,
   recordNo2 : int
);

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

UInt32Storage Class | UInt32Storage Members | System.Data.Internal Namespace


UInt32Storage.Get

[To be supplied.]

[Visual Basic]
Overrides Public Function Get( _
   ByVal record As Integer _
) As Object
[C#]
public override object Get(
   int record
);
[C++]
public: override Object* Get(
   int record
);
[JScript]
public override function Get(
   record : int
) : Object;

Parameters

record
[To be supplied.]

See Also

UInt32Storage Class | UInt32Storage Members | System.Data.Internal Namespace


UInt32Storage.Set

[To be supplied.]

[Visual Basic]
Overrides Public Sub Set( _
   ByVal record As Integer, _
   ByVal value As Object _
)
[C#]
public override void Set(
   int record,
   object value
);
[C++]
public: override void Set(
   int record,
   Object* value
);
[JScript]
public override function Set(
   record : int,
   value : Object
);

Parameters

record
[To be supplied.]
value
[To be supplied.]

See Also

UInt32Storage Class | UInt32Storage Members | System.Data.Internal Namespace


UInt32Storage.SetCapacity

[To be supplied.]

[Visual Basic]
Overrides Public Sub SetCapacity( _
   ByVal capacity As Integer _
)
[C#]
public override void SetCapacity(
   int capacity
);
[C++]
public: override void SetCapacity(
   int capacity
);
[JScript]
public override function SetCapacity(
   capacity : int
);

Parameters

capacity
[To be supplied.]

See Also

UInt32Storage Class | UInt32Storage Members | System.Data.Internal Namespace


UInt32Storage.ShiftByOffset

[To be supplied.]

[Visual Basic]
Overrides Public Sub ShiftByOffset( _
   ByVal index As Integer, _
   ByVal length As Integer, _
   ByVal offset As Integer _
)
[C#]
public override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[C++]
public: override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[JScript]
public override function ShiftByOffset(
   index : int,
   length : int,
   offset : int
);

Parameters

index
[To be supplied.]
length
[To be supplied.]
offset
[To be supplied.]

See Also

UInt32Storage Class | UInt32Storage Members | System.Data.Internal Namespace


UInt64Storage Class

[To be supplied.]

Object
DataStorage
UInt64Storage

[Visual Basic]
Public Class UInt64Storage
   Inherits DataStorage
[C#]
public class UInt64Storage : DataStorage
[C++]
public __gc class UInt64Storage : public DataStorage
[JScript]
public class UInt64Storage extends DataStorage

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.Internal

Assembly: System.Data.dll

See Also

UInt64Storage Members | System.Data.Internal Namespace


UInt64Storage Members

Public:

Constructor

UInt64Storage Constructor [To be supplied.]

Properties

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

Methods

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

UInt64Storage Class | System.Data.Internal Namespace


UInt64Storage Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public UInt64Storage();
[C++]
public: UInt64Storage();
[JScript]
public function UInt64Storage();

See Also

UInt64Storage Class | UInt64Storage Members | System.Data.Internal Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UInt64Storage Properties

The properties of the UInt64Storage class are listed below. For a complete list of UInt64Storage class members, see the UInt64Storage Members topic.

Public:

DataType (inherited from DataStorage) | [To be supplied.]
DefaultValue | [To be supplied.]
Table (inherited from DataStorage) | [To be supplied.]

See Also

UInt64Storage Class | System.Data.Internal Namespace


UInt64Storage.DefaultValue

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DefaultValue As Object
[C#]
public object DefaultValue {override get;}
[C++]
public: __property virtual Object* get_DefaultValue();
[JScript]
public function get DefaultValue() : Object;

See Also

UInt64Storage Class | UInt64Storage Members | System.Data.Internal Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UInt64Storage Methods

The methods of the UInt64Storage class are listed below. For a complete list of UInt64Storage class members, see the UInt64Storage Members topic.

Public:

Aggregate | [To be supplied.]
Compare | [To be supplied.]
CompareToValue | [To be supplied.]
Copy | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsNull (inherited from DataStorage) | [To be supplied.]
Set | [To be supplied.]
SetCapacity | [To be supplied.]
SetNull (inherited from DataStorage) | [To be supplied.]
ShiftByOffset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

ClearBits (inherited from DataStorage) | [To be supplied.]
CompareBits (inherited from DataStorage) | [To be supplied.]
CopyBits (inherited from DataStorage) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetBits (inherited from DataStorage) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetBits (inherited from DataStorage) | [To be supplied.]

See Also

UInt64Storage Class | System.Data.Internal Namespace


UInt64Storage.Aggregate

[To be supplied.]

[Visual Basic]
Overrides Public Function Aggregate( _
   ByVal records() As Integer, _
   ByVal kind As AggregateTypes _
) As Object
[C#]
public override object Aggregate(
   int[] records,
   AggregateTypes kind
);
[C++]
public: override Object* Aggregate(
   int* records[],
   AggregateTypes kind
);
[JScript]
public override function Aggregate(
   records : int[],
   kind : AggregateTypes
) : Object;

Parameters

records
[To be supplied.]
kind
[To be supplied.]

See Also

UInt64Storage Class | UInt64Storage Members | System.Data.Internal Namespace


UInt64Storage.Compare

[To be supplied.]

[Visual Basic]
Overrides Public Function Compare( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
) As Integer
[C#]
public override int Compare(
   int recordNo1,
   int recordNo2
);
[C++]
public: override int Compare(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Compare(
   recordNo1 : int,
   recordNo2 : int
) : int;

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

UInt64Storage Class | UInt64Storage Members | System.Data.Internal Namespace


UInt64Storage.CompareToValue

[To be supplied.]

[Visual Basic]
Overrides Public Function CompareToValue( _
   ByVal recordNo As Integer, _
   ByVal value As Object _
) As Integer
[C#]
public override int CompareToValue(
   int recordNo,
   object value
);
[C++]
public: override int CompareToValue(
   int recordNo,
   Object* value
);
[JScript]
public override function CompareToValue(
   recordNo : int,
   value : Object
) : int;

Parameters

recordNo
[To be supplied.]
value
[To be supplied.]

See Also

UInt64Storage Class | UInt64Storage Members | System.Data.Internal Namespace


UInt64Storage.Copy

[To be supplied.]

[Visual Basic]
Overrides Public Sub Copy( _
   ByVal recordNo1 As Integer, _
   ByVal recordNo2 As Integer _
)
[C#]
public override void Copy(
   int recordNo1,
   int recordNo2
);
[C++]
public: override void Copy(
   int recordNo1,
   int recordNo2
);
[JScript]
public override function Copy(
   recordNo1 : int,
   recordNo2 : int
);

Parameters

recordNo1
[To be supplied.]
recordNo2
[To be supplied.]

See Also

UInt64Storage Class | UInt64Storage Members | System.Data.Internal Namespace


UInt64Storage.Get

[To be supplied.]

[Visual Basic]
Overrides Public Function Get( _
   ByVal record As Integer _
) As Object
[C#]
public override object Get(
   int record
);
[C++]
public: override Object* Get(
   int record
);
[JScript]
public override function Get(
   record : int
) : Object;

Parameters

record
[To be supplied.]

See Also

UInt64Storage Class | UInt64Storage Members | System.Data.Internal Namespace


UInt64Storage.Set

[To be supplied.]

[Visual Basic]
Overrides Public Sub Set( _
   ByVal record As Integer, _
   ByVal value As Object _
)
[C#]
public override void Set(
   int record,
   object value
);
[C++]
public: override void Set(
   int record,
   Object* value
);
[JScript]
public override function Set(
   record : int,
   value : Object
);

Parameters

record
[To be supplied.]
value
[To be supplied.]

See Also

UInt64Storage Class | UInt64Storage Members | System.Data.Internal Namespace


UInt64Storage.SetCapacity

[To be supplied.]

[Visual Basic]
Overrides Public Sub SetCapacity( _
   ByVal capacity As Integer _
)
[C#]
public override void SetCapacity(
   int capacity
);
[C++]
public: override void SetCapacity(
   int capacity
);
[JScript]
public override function SetCapacity(
   capacity : int
);

Parameters

capacity
[To be supplied.]

See Also

UInt64Storage Class | UInt64Storage Members | System.Data.Internal Namespace


UInt64Storage.ShiftByOffset

[To be supplied.]

[Visual Basic]
Overrides Public Sub ShiftByOffset( _
   ByVal index As Integer, _
   ByVal length As Integer, _
   ByVal offset As Integer _
)
[C#]
public override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[C++]
public: override void ShiftByOffset(
   int index,
   int length,
   int offset
);
[JScript]
public override function ShiftByOffset(
   index : int,
   length : int,
   offset : int
);

Parameters

index
[To be supplied.]
length
[To be supplied.]
offset
[To be supplied.]

See Also

UInt64Storage Class | UInt64Storage Members | System.Data.Internal Namespace


System.Data.SQL

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Data.SQL Namespace

Classes

Class | Description
ConnectionHolder | [To be supplied.]
SQLCommand | Represents a SQL query command to be made to a data source within SQL Server.
SQLCommandConverter | [To be supplied.]
SQLConnection | Represents an open connection to a SQL Server data source.
SQLDataReader | [To be supplied.]
SQLDataSetCommand | Represents a set of data commands and a database connection which are used to fill the DataSet and update the data source. At any time, the object refers to only a single record within the current data set.
SQLError | Collects information relevant to a warning or error returned by SQL Server.
SQLErrors | Collects all errors generated by the SQL Server adapter.
SQLException | Thrown whenever an error from the SQL Server adapter is encountered.
SQLInfoMessageEventArgs | [To be supplied.]
SQLParameter | Represents a parameter to an SQLCommand and, optionally, its mapping to DataSet columns.
SQLParameterConverter | [To be supplied.]
SQLParameters | Collects all parameters relevant to a SQLCommand and their mappings to DataSet columns.
SQLRowUpdatedEventArgs | [To be supplied.]
SQLRowUpdatingEventArgs | [To be supplied.]
SQLSchemaMappingEventArgs | [To be supplied.]

Interfaces

Interface | Description
IGetDispenser | [To be supplied.]
IObjectControl | [To be supplied.]
ISQLConnection | [To be supplied.]
ISQLDataReader | [To be supplied.]
ISQLDataRecord | [To be supplied.]
ITransaction | [To be supplied.]
ITransactionExport | [To be supplied.]
ITransactionExportFactory | [To be supplied.]

Delegates

Delegate | Description
InfoMessageEventHandler | [To be supplied.]
SQLRowUpdatedEventHandler | [To be supplied.]
SQLRowUpdatingEventHandler | [To be supplied.]
SQLSchemaMappingEventHandler | [To be supplied.]

Enumerations

Enumeration | Description
SQLDataType | [To be supplied.]


ConnectionHolder Class

[To be supplied.]

Object
ConnectionHolder

[Visual Basic]
Public Class ConnectionHolder
[C#]
public class ConnectionHolder
[C++]
public __gc class ConnectionHolder
[JScript]
public class ConnectionHolder

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQL

Assembly: System.Data.dll

See Also

ConnectionHolder Members | System.Data.SQL Namespace


ConnectionHolder Members

Public:

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Connection [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConnectionHolder Class | System.Data.SQL Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ConnectionHolder Fields

The fields of the ConnectionHolder class are listed below. For a complete list of ConnectionHolder class members, see the ConnectionHolder Members topic.

Public:

Connection [To be supplied.]

See Also

ConnectionHolder Class | System.Data.SQL Namespace


ConnectionHolder.Connection

[To be supplied.]

[Visual Basic]
Public Connection As SQLConnection
[C#]
public SQLConnection Connection;
[C++]
public: SQLConnection* Connection;
[JScript]
public var Connection : SQLConnection;

See Also

ConnectionHolder Class | ConnectionHolder Members | System.Data.SQL Namespace


IGetDispenser Interface

[To be supplied.]

IGetDispenser

[Visual Basic]
Public Interface IGetDispenser
[C#]
public interface IGetDispenser
[C++]
public __gc __interface IGetDispenser

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQL

Assembly: System.Data.dll

See Also

IGetDispenser Members | System.Data.SQL Namespace


IGetDispenser Members

Methods

GetDispenser [To be supplied.]

See Also

IGetDispenser Interface | System.Data.SQL Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IGetDispenser Methods

The methods of the IGetDispenser interface are listed below. For a complete list of IGetDispenser interface members, see the IGetDispenser Members topic.

GetDispenser [To be supplied.]

See Also

IGetDispenser Interface | System.Data.SQL Namespace


IGetDispenser.GetDispenser

[To be supplied.]

[Visual Basic]
Sub GetDispenser( _
   ByRef iid As Guid, _
   ByRef Object As Object _
)
[C#]
void GetDispenser(
   ref Guid iid,
   ref object Object
);
[C++]
void GetDispenser(
   Guid** iid,
   Object** Object
) = 0;
[JScript]
function GetDispenser(
   iid : Guid,
   Object : Object
);

Parameters

iid
[To be supplied.]
Object
[To be supplied.]

See Also

IGetDispenser Interface | IGetDispenser Members | System.Data.SQL Namespace


InfoMessageEventHandler Delegate

[To be supplied.]

[Visual Basic]
Public Delegate Sub InfoMessageEventHandler( _
   ByVal sender As Object, _
   ByVal e As SQLInfoMessageEventArgs _
)
[C#]
public delegate void InfoMessageEventHandler(
   object sender,
   SQLInfoMessageEventArgs e
);
[C++]
public __gc __delegate void InfoMessageEventHandler(
   Object* sender,
   SQLInfoMessageEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the InfoMessageEventHandler delegate declaration.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQL

Assembly: System.Data.dll

See Also

System.Data.SQL Namespace


IObjectControl Interface

[To be supplied.]

IObjectControl

[Visual Basic]
Public Interface IObjectControl
[C#]
public interface IObjectControl
[C++]
public __gc __interface IObjectControl

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IObjectControl

Class | Description
SQLConnection | Represents an open connection to a SQL Server data source.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQL

Assembly: System.Data.dll

See Also

IObjectControl Members | System.Data.SQL Namespace


IObjectControl Members

Methods

Activate | [To be supplied.]
CanBePooled | [To be supplied.]
Deactivate | [To be supplied.]

See Also

IObjectControl Interface | System.Data.SQL Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IObjectControl Methods

The methods of the IObjectControl interface are listed below. For a complete list of IObjectControl interface members, see the IObjectControl Members topic.

Activate | [To be supplied.]
CanBePooled | [To be supplied.]
Deactivate | [To be supplied.]

See Also

IObjectControl Interface | System.Data.SQL Namespace


IObjectControl.Activate

[To be supplied.]

[Visual Basic]
Sub Activate()
[C#]
void Activate();
[C++]
void Activate() = 0;
[JScript]
function Activate();

See Also

IObjectControl Interface | IObjectControl Members | System.Data.SQL Namespace


IObjectControl.CanBePooled

[To be supplied.]

[Visual Basic]
Function CanBePooled() As Integer
[C#]
int CanBePooled();
[C++]
int CanBePooled() = 0;
[JScript]
function CanBePooled() : int;

See Also

IObjectControl Interface | IObjectControl Members | System.Data.SQL Namespace


IObjectControl.Deactivate

[To be supplied.]

[Visual Basic]
Sub Deactivate()
[C#]
void Deactivate();
[C++]
void Deactivate() = 0;
[JScript]
function Deactivate();

See Also

IObjectControl Interface | IObjectControl Members | System.Data.SQL Namespace


ISQLConnection Interface

[To be supplied.]

ISQLConnection

[Visual Basic]
Public Interface ISQLConnection
[C#]
public interface ISQLConnection
[C++]
public __gc __interface ISQLConnection

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement ISQLConnection

Class | Description
SQLConnection | Represents an open connection to a SQL Server data source.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQL

Assembly: System.Data.dll

See Also

ISQLConnection Members | System.Data.SQL Namespace


ISQLConnection Members

Methods

GetConnectionHolder [To be supplied.]

See Also

ISQLConnection Interface | System.Data.SQL Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ISQLConnection Methods

The methods of the ISQLConnection interface are listed below. For a complete list of ISQLConnection interface members, see the ISQLConnection Members topic.

GetConnectionHolder [To be supplied.]

See Also

ISQLConnection Interface | System.Data.SQL Namespace


ISQLConnection.GetConnectionHolder

[To be supplied.]

[Visual Basic]
Function GetConnectionHolder() As ConnectionHolder
[C#]
ConnectionHolder GetConnectionHolder();
[C++]
ConnectionHolder* GetConnectionHolder() = 0;
[JScript]
function GetConnectionHolder() : ConnectionHolder;

See Also

ISQLConnection Interface | ISQLConnection Members | System.Data.SQL Namespace


ISQLDataReader Interface

[To be supplied.]

ISQLDataReader

[Visual Basic]
Public Interface ISQLDataReader
   Implements ISQLDataRecord
[C#]
public interface ISQLDataReader : ISQLDataRecord
[C++]
public __gc __interface ISQLDataReader : public ISQLDataRecord

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement ISQLDataReader

Class | Description
SQLDataReader | [To be supplied.]

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQL

Assembly: System.Data.dll

See Also

ISQLDataReader Members | System.Data.SQL Namespace


NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ISQLDataReader Members

See Also

ISQLDataReader Interface | System.Data.SQL Namespace


ISQLDataRecord Interface

[To be supplied.]

ISQLDataRecord

[Visual Basic]
Public Interface ISQLDataRecord
[C#]
public interface ISQLDataRecord
[C++]
public __gc __interface ISQLDataRecord

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement ISQLDataRecord

Class | Description
SQLDataReader | [To be supplied.]

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQL

Assembly: System.Data.dll

See Also

ISQLDataRecord Members | System.Data.SQL Namespace


ISQLDataRecord Members

Methods

GetSQLBit | [To be supplied.]
GetSQLByte | [To be supplied.]
GetSQLDateTime | [To be supplied.]
GetSQLDouble | [To be supplied.]
GetSQLGuid | [To be supplied.]
GetSQLInt16 | [To be supplied.]
GetSQLInt32 | [To be supplied.]
GetSQLInt64 | [To be supplied.]
GetSQLMoney | [To be supplied.]
GetSQLNumeric | [To be supplied.]
GetSQLSingle | [To be supplied.]
GetSQLString | [To be supplied.]
GetSQLVariant | [To be supplied.]

See Also

ISQLDataRecord Interface | System.Data.SQL Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ISQLDataRecord Methods

The methods of the ISQLDataRecord interface are listed below. For a complete list of ISQLDataRecord interface members, see the ISQLDataRecord Members topic.

GetSQLBit | [To be supplied.]
GetSQLByte | [To be supplied.]
GetSQLDateTime | [To be supplied.]
GetSQLDouble | [To be supplied.]
GetSQLGuid | [To be supplied.]
GetSQLInt16 | [To be supplied.]
GetSQLInt32 | [To be supplied.]
GetSQLInt64 | [To be supplied.]
GetSQLMoney | [To be supplied.]
GetSQLNumeric | [To be supplied.]
GetSQLSingle | [To be supplied.]
GetSQLString | [To be supplied.]
GetSQLVariant | [To be supplied.]

See Also

ISQLDataRecord Interface | System.Data.SQL Namespace


ISQLDataRecord.GetSQLBit

[To be supplied.]

[Visual Basic]
Function GetSQLBit( _
   ByVal i As Integer _
) As SQLBit
[C#]
SQLBit GetSQLBit(
   int i
);
[C++]
SQLBit GetSQLBit(
   int i
) = 0;
[JScript]
function GetSQLBit(
   i : int
) : SQLBit;

Parameters

i
[To be supplied.]

See Also

ISQLDataRecord Interface | ISQLDataRecord Members | System.Data.SQL Namespace


ISQLDataRecord.GetSQLByte

[To be supplied.]

[Visual Basic]
Function GetSQLByte( _
   ByVal i As Integer _
) As SQLByte
[C#]
SQLByte GetSQLByte(
   int i
);
[C++]
SQLByte GetSQLByte(
   int i
) = 0;
[JScript]
function GetSQLByte(
   i : int
) : SQLByte;

Parameters

i
[To be supplied.]

See Also

ISQLDataRecord Interface | ISQLDataRecord Members | System.Data.SQL Namespace


ISQLDataRecord.GetSQLDateTime

[To be supplied.]

[Visual Basic]
Function GetSQLDateTime( _
   ByVal i As Integer _
) As SQLDateTime
[C#]
SQLDateTime GetSQLDateTime(
   int i
);
[C++]
SQLDateTime GetSQLDateTime(
   int i
) = 0;
[JScript]
function GetSQLDateTime(
   i : int
) : SQLDateTime;

Parameters

i
[To be supplied.]

See Also

ISQLDataRecord Interface | ISQLDataRecord Members | System.Data.SQL Namespace


ISQLDataRecord.GetSQLDouble

[To be supplied.]

[Visual Basic]
Function GetSQLDouble( _
   ByVal i As Integer _
) As SQLDouble
[C#]
SQLDouble GetSQLDouble(
   int i
);
[C++]
SQLDouble GetSQLDouble(
   int i
) = 0;
[JScript]
function GetSQLDouble(
   i : int
) : SQLDouble;

Parameters

i
[To be supplied.]

See Also

ISQLDataRecord Interface | ISQLDataRecord Members | System.Data.SQL Namespace


ISQLDataRecord.GetSQLGuid

[To be supplied.]

[Visual Basic]
Function GetSQLGuid( _
   ByVal i As Integer _
) As SQLGuid
[C#]
SQLGuid GetSQLGuid(
   int i
);
[C++]
SQLGuid GetSQLGuid(
   int i
) = 0;
[JScript]
function GetSQLGuid(
   i : int
) : SQLGuid;

Parameters

i
[To be supplied.]

See Also

ISQLDataRecord Interface | ISQLDataRecord Members | System.Data.SQL Namespace


ISQLDataRecord.GetSQLInt16

[To be supplied.]

[Visual Basic]
Function GetSQLInt16( _
   ByVal i As Integer _
) As SQLInt16
[C#]
SQLInt16 GetSQLInt16(
   int i
);
[C++]
SQLInt16 GetSQLInt16(
   int i
) = 0;
[JScript]
function GetSQLInt16(
   i : int
) : SQLInt16;

Parameters

i
[To be supplied.]

See Also

ISQLDataRecord Interface | ISQLDataRecord Members | System.Data.SQL Namespace


ISQLDataRecord.GetSQLInt32

[To be supplied.]

[Visual Basic]
Function GetSQLInt32( _
   ByVal i As Integer _
) As SQLInt32
[C#]
SQLInt32 GetSQLInt32(
   int i
);
[C++]
SQLInt32 GetSQLInt32(
   int i
) = 0;
[JScript]
function GetSQLInt32(
   i : int
) : SQLInt32;

Parameters

i
[To be supplied.]

See Also

ISQLDataRecord Interface | ISQLDataRecord Members | System.Data.SQL Namespace


ISQLDataRecord.GetSQLInt64

[To be supplied.]

[Visual Basic]
Function GetSQLInt64( _
   ByVal i As Integer _
) As SQLInt64
[C#]
SQLInt64 GetSQLInt64(
   int i
);
[C++]
SQLInt64 GetSQLInt64(
   int i
) = 0;
[JScript]
function GetSQLInt64(
   i : int
) : SQLInt64;

Parameters

i
[To be supplied.]

See Also

ISQLDataRecord Interface | ISQLDataRecord Members | System.Data.SQL Namespace


ISQLDataRecord.GetSQLMoney

[To be supplied.]

[Visual Basic]
Function GetSQLMoney( _
   ByVal i As Integer _
) As SQLMoney
[C#]
SQLMoney GetSQLMoney(
   int i
);
[C++]
SQLMoney GetSQLMoney(
   int i
) = 0;
[JScript]
function GetSQLMoney(
   i : int
) : SQLMoney;

Parameters

i
[To be supplied.]

See Also

ISQLDataRecord Interface | ISQLDataRecord Members | System.Data.SQL Namespace


ISQLDataRecord.GetSQLNumeric

[To be supplied.]

[Visual Basic]
Function GetSQLNumeric( _
   ByVal i As Integer _
) As SQLNumeric
[C#]
SQLNumeric GetSQLNumeric(
   int i
);
[C++]
SQLNumeric GetSQLNumeric(
   int i
) = 0;
[JScript]
function GetSQLNumeric(
   i : int
) : SQLNumeric;

Parameters

i
[To be supplied.]

See Also

ISQLDataRecord Interface | ISQLDataRecord Members | System.Data.SQL Namespace


ISQLDataRecord.GetSQLSingle

[To be supplied.]

[Visual Basic]
Function GetSQLSingle( _
   ByVal i As Integer _
) As SQLSingle
[C#]
SQLSingle GetSQLSingle(
   int i
);
[C++]
SQLSingle GetSQLSingle(
   int i
) = 0;
[JScript]
function GetSQLSingle(
   i : int
) : SQLSingle;

Parameters

i
[To be supplied.]

See Also

ISQLDataRecord Interface | ISQLDataRecord Members | System.Data.SQL Namespace


ISQLDataRecord.GetSQLString

[To be supplied.]

[Visual Basic]
Function GetSQLString( _
   ByVal i As Integer _
) As SQLString
[C#]
SQLString GetSQLString(
   int i
);
[C++]
SQLString* GetSQLString(
   int i
) = 0;
[JScript]
function GetSQLString(
   i : int
) : SQLString;

Parameters

i
[To be supplied.]

See Also

ISQLDataRecord Interface | ISQLDataRecord Members | System.Data.SQL Namespace


ISQLDataRecord.GetSQLVariant

[To be supplied.]

[Visual Basic]
Function GetSQLVariant( _
   ByVal i As Integer _
) As Object
[C#]
object GetSQLVariant(
   int i
);
[C++]
Object* GetSQLVariant(
   int i
) = 0;
[JScript]
function GetSQLVariant(
   i : int
) : Object;

Parameters

i
[To be supplied.]

See Also

ISQLDataRecord Interface | ISQLDataRecord Members | System.Data.SQL Namespace


ITransaction Interface

[To be supplied.]

ITransaction

[Visual Basic]
Public Interface ITransaction
[C#]
public interface ITransaction
[C++]
public __gc __interface ITransaction

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQL

Assembly: System.Data.dll

See Also

ITransaction Members | System.Data.SQL Namespace


ITransaction Members

Methods

Abort | [To be supplied.]
Commit | [To be supplied.]
GetTransactionInfo | [To be supplied.]

See Also

ITransaction Interface | System.Data.SQL Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ITransaction Methods

The methods of the ITransaction interface are listed below. For a complete list of ITransaction interface members, see the ITransaction Members topic.

Abort | [To be supplied.]
Commit | [To be supplied.]
GetTransactionInfo | [To be supplied.]

See Also

ITransaction Interface | System.Data.SQL Namespace


ITransaction.Abort

[To be supplied.]

[Visual Basic]
Sub Abort( _
   ByRef boidReason As Object, _
   ByVal fRetaining As Boolean, _
   ByVal fAsync As Boolean _
)
[C#]
void Abort(
   ref object boidReason,
   bool fRetaining,
   bool fAsync
);
[C++]
void Abort(
   Object** boidReason,
   bool fRetaining,
   bool fAsync
) = 0;
[JScript]
function Abort(
   boidReason : Object,
   fRetaining : Boolean,
   fAsync : Boolean
);

Parameters

boidReason
[To be supplied.]
fRetaining
[To be supplied.]
fAsync
[To be supplied.]

See Also

ITransaction Interface | ITransaction Members | System.Data.SQL Namespace


ITransaction.Commit

[To be supplied.]

[Visual Basic]
Sub Commit( _
   ByVal fRetaining As Boolean, _
   ByVal grfTC As Integer, _
   ByVal grfRM As Integer _
)
[C#]
void Commit(
   bool fRetaining,
   int grfTC,
   int grfRM
);
[C++]
void Commit(
   bool fRetaining,
   int grfTC,
   int grfRM
) = 0;
[JScript]
function Commit(
   fRetaining : Boolean,
   grfTC : int,
   grfRM : int
);

Parameters

fRetaining
[To be supplied.]
grfTC
[To be supplied.]
grfRM
[To be supplied.]

See Also

ITransaction Interface | ITransaction Members | System.Data.SQL Namespace


ITransaction.GetTransactionInfo

[To be supplied.]

[Visual Basic]
Sub GetTransactionInfo( _
   ByVal info As Object _
)
[C#]
void GetTransactionInfo(
   object info
);
[C++]
void GetTransactionInfo(
   Object* info
) = 0;
[JScript]
function GetTransactionInfo(
   info : Object
);

Parameters

info
[To be supplied.]

See Also

ITransaction Interface | ITransaction Members | System.Data.SQL Namespace


ITransactionExport Interface

[To be supplied.]

ITransactionExport

[Visual Basic]
Public Interface ITransactionExport
[C#]
public interface ITransactionExport
[C++]
public __gc __interface ITransactionExport

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQL

Assembly: System.Data.dll

See Also

ITransactionExport Members | System.Data.SQL Namespace


ITransactionExport Members

Methods

Export | [To be supplied.]
GetTransactionCookie | [To be supplied.]
RemoteGetTransactionCookie | [To be supplied.]

See Also

ITransactionExport Interface | System.Data.SQL Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ITransactionExport Methods

The methods of the ITransactionExport interface are listed below. For a complete list of ITransactionExport interface members, see the ITransactionExport Members topic.

Export | [To be supplied.]
GetTransactionCookie | [To be supplied.]
RemoteGetTransactionCookie | [To be supplied.]

See Also

ITransactionExport Interface | System.Data.SQL Namespace


ITransactionExport.Export

[To be supplied.]

[Visual Basic]
Sub Export( _
   ByVal transaction As Object, _
   ByRef transactionCookie As UInt32 _
)
[C#]
void Export(
   object transaction,
   ref uint transactionCookie
);
[C++]
void Export(
   Object* transaction,
   unsigned int** transactionCookie
) = 0;
[JScript]
function Export(
   transaction : Object,
   transactionCookie : UInt32
);

Parameters

transaction
[To be supplied.]
transactionCookie
[To be supplied.]

See Also

ITransactionExport Interface | ITransactionExport Members | System.Data.SQL Namespace


ITransactionExport.GetTransactionCookie

[To be supplied.]

[Visual Basic]
Sub GetTransactionCookie( _
   ByVal transaction As Object, _
   ByVal transactionCookieLength As UInt32, _
   ByVal transactionCookie() As Byte, _
   ByRef pTransactionCookieLength As UInt32 _
)
[C#]
void GetTransactionCookie(
   object transaction,
   uint transactionCookieLength,
   byte[] transactionCookie,
   ref uint pTransactionCookieLength
);
[C++]
void GetTransactionCookie(
   Object* transaction,
   unsigned int transactionCookieLength,
   unsigned char* transactionCookie[],
   unsigned int** pTransactionCookieLength
) = 0;
[JScript]
function GetTransactionCookie(
   transaction : Object,
   transactionCookieLength : UInt32,
   transactionCookie : Byte[],
   pTransactionCookieLength : UInt32
);

Parameters

transaction
[To be supplied.]
transactionCookieLength
[To be supplied.]
transactionCookie
[To be supplied.]
pTransactionCookieLength
[To be supplied.]

See Also

ITransactionExport Interface | ITransactionExport Members | System.Data.SQL Namespace


ITransactionExport.RemoteGetTransactionCookie

[To be supplied.]

[Visual Basic]
Sub RemoteGetTransactionCookie( _
   ByVal transaction As Object, _
   ByRef transactionCookieLength As UInt32, _
   ByVal pTransactionCookieLength As UInt32, _
   ByVal transactionCookie() As Byte _
)
[C#]
void RemoteGetTransactionCookie(
   object transaction,
   ref uint transactionCookieLength,
   uint pTransactionCookieLength,
   byte[] transactionCookie
);
[C++]
void RemoteGetTransactionCookie(
   Object* transaction,
   unsigned int** transactionCookieLength,
   unsigned int pTransactionCookieLength,
   unsigned char* transactionCookie[]
) = 0;
[JScript]
function RemoteGetTransactionCookie(
   transaction : Object,
   transactionCookieLength : UInt32,
   pTransactionCookieLength : UInt32,
   transactionCookie : Byte[]
);

Parameters

transaction
[To be supplied.]
transactionCookieLength
[To be supplied.]
pTransactionCookieLength
[To be supplied.]
transactionCookie
[To be supplied.]

See Also

ITransactionExport Interface | ITransactionExport Members | System.Data.SQL Namespace


ITransactionExportFactory Interface

[To be supplied.]

ITransactionExportFactory

[Visual Basic]
Public Interface ITransactionExportFactory
[C#]
public interface ITransactionExportFactory
[C++]
public __gc __interface ITransactionExportFactory

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQL

Assembly: System.Data.dll

See Also

ITransactionExportFactory Members | System.Data.SQL Namespace


ITransactionExportFactory Members

Methods

Create | [To be supplied.]
GetRemoteClassId | [To be supplied.]

See Also

ITransactionExportFactory Interface | System.Data.SQL Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ITransactionExportFactory Methods

The methods of the ITransactionExportFactory interface are listed below. For a complete list of ITransactionExportFactory interface members, see the ITransactionExportFactory Members topic.

Create | [To be supplied.]
GetRemoteClassId | [To be supplied.]

See Also

ITransactionExportFactory Interface | System.Data.SQL Namespace


ITransactionExportFactory.Create

[To be supplied.]

[Visual Basic]
Sub Create( _
   ByVal DTCLength As UInt32, _
   ByVal DTCAddr() As Byte, _
   ByRef export As ITransactionExport _
)
[C#]
void Create(
   uint DTCLength,
   byte[] DTCAddr,
   ref ITransactionExport export
);
[C++]
void Create(
   unsigned int DTCLength,
   unsigned char* DTCAddr[],
   ITransactionExport** export
) = 0;
[JScript]
function Create(
   DTCLength : UInt32,
   DTCAddr : Byte[],
   export : ITransactionExport
);

Parameters

DTCLength
[To be supplied.]
DTCAddr
[To be supplied.]
export
[To be supplied.]

See Also

ITransactionExportFactory Interface | ITransactionExportFactory Members | System.Data.SQL Namespace


ITransactionExportFactory.GetRemoteClassId

[To be supplied.]

[Visual Basic]
Sub GetRemoteClassId( _
   ByVal clsid As Guid _
)
[C#]
void GetRemoteClassId(
   Guid clsid
);
[C++]
void GetRemoteClassId(
   Guid clsid
) = 0;
[JScript]
function GetRemoteClassId(
   clsid : Guid
);

Parameters

clsid
[To be supplied.]

See Also

ITransactionExportFactory Interface | ITransactionExportFactory Members | System.Data.SQL Namespace


SQLCommand Class

Represents a SQL query command to be made to a data source within SQL Server.

Object
DBCommand
SQLCommand

[Visual Basic]
Public Class SQLCommand
   Inherits DBCommand
[C#]
public class SQLCommand : DBCommand
[C++]
public __gc class SQLCommand : public DBCommand
[JScript]
public class SQLCommand extends DBCommand

Remarks

When an instance of SQLCommand is created, the read/write properties are set to initial values. For a list of these values, see the SQLCommand constructor.

Requirements

Namespace: System.Data.SQL

Assembly: System.Data.dll

Example [C#]

The following example selects records from an Access data source. The DataSet then uses SQLDataSetCommand, along with SQLCommand and SQLConnection, to insert new records in a SQL Server data source. This example can be modified to migrate an Access database to a SQL Server database.

[C#]

private DataSet InitializeMyDataSet() {
   // creates the table and its columns for the DataSet
   DataSet newData = new DataSet();
   DataTable newTable = newData.Tables.Add("Catagories");

   // add Columns to table
   newTable.Columns.Add("CategoryID",typeof(Int32));
   newTable.Columns.Add("CategoryName", typeof(String));
   newTable.Columns.Add("Description", typeof(String));
   newTable.Columns.Add("Picture",typeof(Byte[]));
   return newData;
}

public void AccessToSQLServer() {
   // set Access connection and select strings
   const string strAccessConn = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=NWIND_RW.MDB";
   const string strAccessSelect = "SELECT * FROM Categories ORDER BY CategoryID";
   // set SQL Server connection and insert strings
   const string strSQLServerConn = "Data Source=VBsql7;Initial Catalog=Northwind;User ID=sa;Password=;";
   const string strSQLServerInsert = "INSERT INTO Categories(CategoryName, Description, Picture) Values(@CategoryName,@Description,@Picture)";
   // create my DataSet
   DataSet myDataSet = InitializeMyDataSet();
   // create my Access objects
   ADOConnection myAccessConn = new ADOConnection(strAccessConn);
   ADODataSetCommand myAccessDataSetCmd = new ADODataSetCommand();
   myAccessDataSetCmd.SelectCommand = new ADOCommand(strAccessSelect,myAccessConn);
   // create my SQL Server objects
   SQLConnection mySQLConn = new SQLConnection(strSQLServerConn);
   SQLDataSetCommand mySQLDataSetCmd = new SQLDataSetCommand();
   mySQLDataSetCmd.InsertCommand = new SQLCommand(strSQLServerInsert,mySQLConn);
   // fill myDataSet with data from Access
   myAccessConn.Open();
   try {
      myAccessDataSetCmd.FillDataSet(myDataSet,"table");
   }
   finally {
      myAccessConn.Close();
   }

   // update SQL Server with data from the DataSet
   mySQLConn.Open();
   try {
      mySQLDataSetCmd.InsertCommand.Parameters.Add("CategoryName", typeof(String));
      mySQLDataSetCmd.InsertCommand.Parameters.Add("Description", typeof(String));
      mySQLDataSetCmd.InsertCommand.Parameters.Add("Picture", typeof(Byte[]));
      mySQLDataSetCmd.InsertCommand.Parameters[0].SourceColumn = "CategoryName";
      mySQLDataSetCmd.InsertCommand.Parameters[1].SourceColumn = "Description";
      mySQLDataSetCmd.InsertCommand.Parameters[2].SourceColumn = "Picture";
      mySQLDataSetCmd.Update(myDataSet,"table");
   }
   finally {
      mySQLConn.Close();
   }
}

See Also

SQLCommand Members | System.Data.SQL Namespace | SQLDataSetCommand | SQLConnection


SQLCommand Members

Public:

Constructor

SQLCommand Constructor Overloaded. Initializes a new instance of the SQLCommand class.

Properties

ActiveConnection | Gets or sets the SQLConnection used by this instance of the SQLCommand.
CommandBehavior | Gets or sets the behavior the SQLCommand is to exhibit when executed.
CommandText | Gets or sets the SQL text command to run against the data source.
CommandTimeout | Gets or sets the wait time before terminating the attempt to connect and generating an error.
CommandType | Gets or sets how the CommandText property is to be interpreted.
Parameters | Gets the collection of SQLParameters.
UpdatedRowSource (inherited from DBCommand) | Gets or sets how command results are to be applied to the current DataRow, when used by the Update method of a DBDataSetCommand.

Methods

Clone (inherited from DBCommand) | When overridden in a derived class, creates a clone of this instance of DBCommand.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Execute | Overloaded. Executes the CommandText against the ActiveConnection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ResetParameters (inherited from DBCommand) | When overridden in a derived class, resets the parameters within the parameters collection.
ShouldPersist (inherited from DBCommand) | When overridden in a derived class, returns whether the settings of the properties should be persisted.
ToString (inherited from Object) | Returns a String that represents the current Object.

Events

SchemaChanged (inherited from DBCommand) | Occurs when the DataSet schema has been changed to match the schema change of the data source.
SchemaChanging (inherited from DBCommand) | Occurs when the DataSet schema is to be changed to match the schema change of the data source.

Protected:

Methods

CreateNewSchemaChangedEvent (inherited from DBCommand) | [To be supplied.]
CreateNewSchemaChangingEvent (inherited from DBCommand) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetActiveConnectionObject | [To be supplied.]
GetParametersObject | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnSchemaChanged (inherited from DBCommand) | Overloaded. [To be supplied.]
OnSchemaChanging (inherited from DBCommand) | Overloaded. [To be supplied.]
SetActiveConnectionObject | [To be supplied.]

Fields

cmdText (inherited from DBCommand) | The default string to be used by the CommandText when the DBCommand is initialized.
cmdType (inherited from DBCommand) | The default CommandType to be used by CommandType property when the DBCommand is initialized.

Event Hookup:

Methods

AddOnSchemaChanged (inherited from DBCommand) | [To be supplied.]
AddOnSchemaChanging (inherited from DBCommand) | [To be supplied.]
RemoveOnSchemaChanged (inherited from DBCommand) | [To be supplied.]
RemoveOnSchemaChanging (inherited from DBCommand) | [To be supplied.]

See Also

SQLCommand Class | System.Data.SQL Namespace


SQLCommand Constructor

Initializes a new instance of the SQLCommand class.

Overload List

Initializes a new instance of the SQLCommand class without any parameters.

[Visual Basic] Overloads Public Sub New()
[C#] public SQLCommand();
[C++] public: SQLCommand();
[JScript] public function SQLCommand();

Initializes a new instance of the SQLCommand class with the given command text.

[Visual Basic] Overloads Public Sub New(String)
[C#] public SQLCommand(String);
[C++] public: SQLCommand(String*);
[JScript] public function SQLCommand(String);

Initializes a new instance of the SQLCommand class with the given command text and a connection string.

[Visual Basic] Overloads Public Sub New(String, String)
[C#] public SQLCommand(String, String);
[C++] public: SQLCommand(String*, String*);
[JScript] public function SQLCommand(String, String);

Initializes a new instance of the SQLCommand class with the given command text and a SQLConnection.

[Visual Basic] Overloads Public Sub New(String, SQLConnection)
[C#] public SQLCommand(String, SQLConnection);
[C++] public: SQLCommand(String*, SQLConnection);
[JScript] public function SQLCommand(String, SQLConnection);

Initializes a new instance of the SQLCommand class with a SQLConnection, the command text, a CommandType, and parameters.

[Visual Basic] Overloads Public Sub New(SQLConnection, String, CommandType, SQLParameter())
[C#] public SQLCommand(SQLConnection, String, CommandType, SQLParameter[]);
[C++] public: SQLCommand(SQLConnection*, String, CommandType, SQLParameter[]);
[JScript] public function SQLCommand(SQLConnection, String, CommandType, SQLParameter[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(SQLConnection, String, CommandType, SQLParameter(), UpdateRowSource)
[C#] public SQLCommand(SQLConnection, String, CommandType, SQLParameter[], UpdateRowSource);
[C++] public: SQLCommand(SQLConnection*, String, CommandType, SQLParameter[], UpdateRowSource);
[JScript] public function SQLCommand(SQLConnection, String, CommandType, SQLParameter[], UpdateRowSource);

Example

The following example creates a SQLCommand and sets some of its properties.

See Also

SQLCommand Class | SQLCommand Members | System.Data.SQL Namespace


SQLCommand Constructor ()

Initializes a new instance of the SQLCommand class without any parameters.

[Visual Basic]
Overloads Public Sub New()
[C#]
public SQLCommand();
[C++]
public: SQLCommand();
[JScript]
public function SQLCommand();

Remarks

When an instance of SQLCommand is created, the following read/write properties are set to initial values.

Properties | Initial Value
CommandText | empty string ("")
CommandTimeout | 30
CommandType | System.Data.SQL.SQLCommand.CommandType.Text
ActiveConnection | null
CommandBehavior | 0

You can change the value for any of these properties through a separate call to the property.

Example

The following example creates a SQLCommand and sets some of its properties.

See Also

SQLCommand Class | SQLCommand Members | System.Data.SQL Namespace | SQLCommand Constructor Overload List


SQLCommand Constructor (String)

Initializes a new instance of the SQLCommand class with the given command text.

[Visual Basic]
Overloads Public Sub New( _
   ByVal cmdText As String _
)
[C#]
public SQLCommand(
   string cmdText
);
[C++]
public: SQLCommand(
   String* cmdText
);
[JScript]
public function SQLCommand(
   cmdText : String
);

Parameters

cmdText
The text of the query command.

Remarks

When an instance of SQLCommand is created, the following read/write properties are set to initial values.

Properties | Initial Value
CommandText | cmdText
CommandTimeout | 30
CommandType | CommandType.Text
ActiveConnection | null
CommandBehavior | 0

You can change the value for any of these properties through a separate call to the property.

Example

The following example creates a SQLCommand and sets some of its properties.

See Also

SQLCommand Class | SQLCommand Members | System.Data.SQL Namespace | SQLCommand Constructor Overload List


SQLCommand Constructor (String, String)

Initializes a new instance of the SQLCommand class with the given command text and a connection string.

[Visual Basic]
Overloads Public Sub New( _
   ByVal cmdText As String, _
   ByVal connectionString As String _
)
[C#]
public SQLCommand(
   string cmdText,
   string connectionString
);
[C++]
public: SQLCommand(
   String* cmdText,
   String* connectionString
);
[JScript]
public function SQLCommand(
   cmdText : String,
   connectionString : String
);

Parameters

cmdText
The text of the query command.
connectionString
The text of the connection string.

Remarks

When an instance of SQLCommand is created, the following read/write properties are set to initial values.

Properties | Initial Value
CommandText | cmdText
CommandTimeout | 30
CommandType | CommandType.Text
ActiveConnection | A new SQLConnection created using connectionString.
CommandBehavior | 0

You can change the value for any of these properties through a separate call to the property.

Example

The following example creates a SQLCommand and sets some of its properties.

See Also

SQLCommand Class | SQLCommand Members | System.Data.SQL Namespace | SQLCommand Constructor Overload List


SQLCommand Constructor (String, SQLConnection)

Initializes a new instance of the SQLCommand class with the given command text and a SQLConnection.

[Visual Basic]
Overloads Public Sub New( _
   ByVal cmdText As String, _
   ByVal connection As SQLConnection _
)
[C#]
public SQLCommand(
   string cmdText,
   SQLConnection connection
);
[C++]
public: SQLCommand(
   String* cmdText,
   SQLConnection* connection
);
[JScript]
public function SQLCommand(
   cmdText : String,
   connection : SQLConnection
);

Parameters

cmdText
The text of the query command.
connection
An SQLConnection that represents the connection.

Remarks

When an instance of SQLCommand is created, the following read/write properties are set to initial values.

Properties | Initial Value
CommandText | cmdText
CommandTimeout | 30
CommandType | CommandType.Text
ActiveConnection | A new SQLConnection that is connection.
CommandBehavior | 0

You can change the value for any of these properties through a separate call to the property.

Example

The following example creates a SQLCommand and sets some of its properties.

See Also

SQLCommand Class | SQLCommand Members | System.Data.SQL Namespace | SQLCommand Constructor Overload List


SQLCommand Constructor (SQLConnection, String, CommandType, SQLParameter[])

Initializes a new instance of the SQLCommand class with a SQLConnection, the command text, a CommandType, and parameters.

[Visual Basic]
Overloads Public Sub New( _
   ByVal activeConnection As SQLConnection, _
   ByVal cmdText As String, _
   ByVal cmdType As CommandType, _
   ByVal parameters() As SQLParameter _
)
[C#]
public SQLCommand(
   SQLConnection activeConnection,
   string cmdText,
   CommandType cmdType,
   SQLParameter[] parameters
);
[C++]
public: SQLCommand(
   SQLConnection* activeConnection,
   String* cmdText,
   CommandType cmdType,
   SQLParameter* parameters[]
);
[JScript]
public function SQLCommand(
   activeConnection : SQLConnection,
   cmdText : String,
   cmdType : CommandType,
   parameters : SQLParameter[]
);

Parameters

activeConnection
An SQLConnection that represents the connection.
cmdText
The text of the query command.
cmdType
One of the CommandType values.
parameters
An array of SQLParameter objects.

Remarks

When an instance of SQLCommand is created, the following read/write properties are set to initial values.

Properties | Initial Value
CommandText | cmdText
CommandTimeout | 30
CommandType | cmdType
ActiveConnection | A new SQLConnection that is activeConnection.
CommandBehavior | 0

You can change the value for any of these properties through a separate call to the property.

Example

The following example creates a SQLCommand and sets some of its properties.

See Also

SQLCommand Class | SQLCommand Members | System.Data.SQL Namespace | SQLCommand Constructor Overload List


SQLCommand Constructor (SQLConnection, String, CommandType, SQLParameter[], UpdateRowSource)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal activeConnection As SQLConnection, _
   ByVal cmdText As String, _
   ByVal cmdType As CommandType, _
   ByVal parameters() As SQLParameter, _
   ByVal rowSrc As UpdateRowSource _
)
[C#]
public SQLCommand(
   SQLConnection activeConnection,
   string cmdText,
   CommandType cmdType,
   SQLParameter[] parameters,
   UpdateRowSource rowSrc
);
[C++]
public: SQLCommand(
   SQLConnection* activeConnection,
   String* cmdText,
   CommandType cmdType,
   SQLParameter* parameters[],
   UpdateRowSource rowSrc
);
[JScript]
public function SQLCommand(
   activeConnection : SQLConnection,
   cmdText : String,
   cmdType : CommandType,
   parameters : SQLParameter[],
   rowSrc : UpdateRowSource
);

Parameters

activeConnection
[To be supplied.]
cmdText
[To be supplied.]
cmdType
[To be supplied.]
parameters
[To be supplied.]
rowSrc
[To be supplied.]

See Also

SQLCommand Class | SQLCommand Members | System.Data.SQL Namespace | SQLCommand Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLCommand Properties

The properties of the SQLCommand class are listed below. For a complete list of SQLCommand class members, see the SQLCommand Members topic.

Public:

ActiveConnection | Gets or sets the SQLConnection used by this instance of the SQLCommand.
CommandBehavior | Gets or sets the behavior the SQLCommand is to exhibit when executed.
CommandText | Gets or sets the SQL text command to run against the data source.
CommandTimeout | Gets or sets the wait time before terminating the attempt to connect and generating an error.
CommandType | Gets or sets how the CommandText property is to be interpreted.
Parameters | Gets the collection of SQLParameters.
UpdatedRowSource (inherited from DBCommand) | Gets or sets how command results are to be applied to the current DataRow, when used by the Update method of a DBDataSetCommand.

See Also

SQLCommand Class | System.Data.SQL Namespace


SQLCommand.ActiveConnection

Gets or sets the SQLConnection used by this instance of the SQLCommand.

[Visual Basic]
Public Property ActiveConnection As SQLConnection
[C#]
public SQLConnection ActiveConnection {get; set;}
[C++]
public: __property SQLConnection* get_ActiveConnection();
public: __property void set_ActiveConnection(SQLConnection*);
[JScript]
public function get ActiveConnection() : SQLConnection;
public function set ActiveConnection(SQLConnection);

Property Value

The connection to a data source. The default value is a null reference (in Visual Basic Nothing).

Remarks

This property is not cloned, but copied. The connection properties are reset every time a new connection is assigned.

Example

The following example creates a SQLCommand and sets some of its properties.

See Also

SQLCommand Class | SQLCommand Members | System.Data.SQL Namespace | CommandText | CommandTimeout | CommandType | CommandBehavior


SQLCommand.CommandBehavior

Gets or sets the behavior the SQLCommand is to exhibit when executed.

[Visual Basic]
Overridable Public Property CommandBehavior As DBCommandBehavior
[C#]
public DBCommandBehavior CommandBehavior {override get; override
   set;}
[C++]
public: __property virtual DBCommandBehavior get_CommandBehavior();
public: __property virtual void set_CommandBehavior(DBCommandBehavior);
[JScript]
public function get CommandBehavior() : DBCommandBehavior;
public function set CommandBehavior(DBCommandBehavior);

Property Value

One of the DBCommandBehavior values. The default is 0.

See Also

SQLCommand Class | SQLCommand Members | System.Data.SQL Namespace | CommandText | CommandTimeout | CommandType | ActiveConnection


SQLCommand.CommandText

Gets or sets the SQL text command to run against the data source.

[Visual Basic]
Overridable Public Property CommandText As String
[C#]
public string CommandText {override get; override set;}
[C++]
public: __property virtual String* get_CommandText();
public: __property virtual void set_CommandText(String*);
[JScript]
public function get CommandText() : String;
public function set CommandText(String);

Property Value

The SQL text command to execute.

Remarks

If the assigned string is not the current string, CommandText is set to the new value. Then, a OnSchemaChanged event is raised.

Example

The following example creates a SQLCommand and sets some of its properties.

See Also

SQLCommand Class | SQLCommand Members | System.Data.SQL Namespace | ActiveConnection | CommandTimeout | CommandType | CommandBehavior


SQLCommand.CommandTimeout

Gets or sets the wait time before terminating the attempt to connect and generating an error.

[Visual Basic]
Public Property CommandTimeout As Integer
[C#]
public int CommandTimeout {get; set;}
[C++]
public: __property int get_CommandTimeout();
public: __property void set_CommandTimeout(int);
[JScript]
public function get CommandTimeout() : int;
public function set CommandTimeout(int);

Property Value

The time (in seconds) to wait for the command to execute. The default value is 30 seconds.

Exceptions

Exception Type | Condition
InvalidCommandTimeout | The property is assigned a value less than 0.

Remarks

Use this property only after the connection is open.

Example

The following example creates a SQLCommand and sets some of its properties.

See Also

SQLCommand Class | SQLCommand Members | System.Data.SQL Namespace | CommandText | ActiveConnection | CommandType | CommandBehavior | DefaultCommandTimeout


SQLCommand.CommandType

Gets or sets how the CommandText property is to be interpreted.

[Visual Basic]
Overridable Public Property CommandType As CommandType
[C#]
public CommandType CommandType {override get; override set;}
[C++]
public: __property virtual CommandType get_CommandType();
public: __property virtual void set_CommandType(CommandType);
[JScript]
public function get CommandType() : CommandType;
public function set CommandType(CommandType);

Property Value

One of the CommandType values. The default is Text.

Exceptions

Exception Type | Condition
TableDirectNotSupported | The CommandType value of TableDirect is not supported by SQLCommand.

Remarks

After the new value is set, a OnSchemaChanged event is raised.

Example

The following example creates a SQLCommand and sets some of its properties.

See Also

SQLCommand Class | SQLCommand Members | System.Data.SQL Namespace | CommandText | CommandTimeout | ActiveConnection | CommandBehavior


SQLCommand.Parameters

Gets the collection of SQLParameters.

[Visual Basic]
Public ReadOnly Property Parameters As SQLParameters
[C#]
public SQLParameters Parameters {get;}
[C++]
public: __property SQLParameters* get_Parameters();
[JScript]
public function get Parameters() : SQLParameters;

Property Value

The SQL parameters for the command.

Example

The following example refreshes the Parameters collection for the command.

See Also

SQLCommand Class | SQLCommand Members | System.Data.SQL Namespace | SQLParameter


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLCommand Methods

The methods of the SQLCommand class are listed below. For a complete list of SQLCommand class members, see the SQLCommand Members topic.

Public:

Clone (inherited from DBCommand) | When overridden in a derived class, creates a clone of this instance of DBCommand.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Execute | Overloaded. Executes the CommandText against the ActiveConnection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ResetParameters (inherited from DBCommand) | When overridden in a derived class, resets the parameters within the parameters collection.
ShouldPersist (inherited from DBCommand) | When overridden in a derived class, returns whether the settings of the properties should be persisted.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

CreateNewSchemaChangedEvent (inherited from DBCommand) | [To be supplied.]
CreateNewSchemaChangingEvent (inherited from DBCommand) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetActiveConnectionObject | [To be supplied.]
GetParametersObject | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnSchemaChanged (inherited from DBCommand) | Overloaded. [To be supplied.]
OnSchemaChanging (inherited from DBCommand) | Overloaded. [To be supplied.]
SetActiveConnectionObject | [To be supplied.]

Event Hookup:

AddOnSchemaChanged (inherited from DBCommand) | [To be supplied.]
AddOnSchemaChanging (inherited from DBCommand) | [To be supplied.]
RemoveOnSchemaChanged (inherited from DBCommand) | [To be supplied.]
RemoveOnSchemaChanging (inherited from DBCommand) | [To be supplied.]

See Also

SQLCommand Class | System.Data.SQL Namespace


SQLCommand.Execute

Executes the CommandText against the ActiveConnection.

Overload List

Executes the CommandText against the ActiveConnection and returns a result Object.

[Visual Basic] Overloads Public Sub Execute(Object)
[C#] public void Execute(Object);
[C++] public: void Execute(Object*);
[JScript] public function Execute(Object);

Executes the CommandText against the ActiveConnection and builds a SQLDataReader.

[Visual Basic] Overloads Shadows Public Sub Execute(SQLDataReader)
[C#] public new void Execute(SQLDataReader);
[C++] public: new void Execute(SQLDataReader*);
[JScript] public new function Execute(SQLDataReader);

Executes the CommandText against the ActiveConnection and builds an IDataReader.

[Visual Basic] Overloads Overrides Public Sub Execute(IDataReader)
[C#] public override void Execute(IDataReader);
[C++] public: override void Execute(IDataReader*);
[JScript] public override function Execute(IDataReader);

Executes the CommandText against the ActiveConnection. This is the default method.

[Visual Basic] Overloads Overrides Public Function Execute() As Integer
[C#] public override int Execute();
[C++] public: override int Execute();
[JScript] public override function Execute() : int;

Example

The following example refreshes the Parameters collection for the command.

See Also

SQLCommand Class | SQLCommand Members | System.Data.SQL Namespace


SQLCommand.Execute (Object)

Executes the CommandText against the ActiveConnection and returns a result Object.

[Visual Basic]
Overloads Public Sub Execute( _
   ByRef retResult As Object _
)
[C#]
public void Execute(
   ref object retResult
);
[C++]
public: void Execute(
   Object** retResult
);
[JScript]
public function Execute(
   retResult : Object
);

Parameters

retResult
This will contain a valid Object on return from this method. If a valid Object cannot be granted, this will be set to null.

Remarks

Does not return a data stream.

Example

The following example refreshes the Parameters collection for the command.

See Also

SQLCommand Class | SQLCommand Members | System.Data.SQL Namespace | SQLCommand.Execute Overload List


SQLCommand.Execute (SQLDataReader)

Executes the CommandText against the ActiveConnection and builds a SQLDataReader.

[Visual Basic]
Overloads Shadows Public Sub Execute( _
   ByRef reader As SQLDataReader _
)
[C#]
public new void Execute(
   ref SQLDataReader reader
);
[C++]
public: new void Execute(
   SQLDataReader** reader
);
[JScript]
public new function Execute(
   reader : SQLDataReader
);

Parameters

reader
This will contain a valid SQLDataReader on return from this method. If a valid SQLDataReader cannot be granted, this will be set to null.

See Also

SQLCommand Class | SQLCommand Members | System.Data.SQL Namespace | SQLCommand.Execute Overload List


SQLCommand.Execute (IDataReader)

Executes the CommandText against the ActiveConnection and builds an IDataReader.

[Visual Basic]
Overloads Overrides Public Sub Execute( _
   ByRef reader As IDataReader _
)
[C#]
public override void Execute(
   ref IDataReader reader
);
[C++]
public: override void Execute(
   IDataReader** reader
);
[JScript]
public override function Execute(
   reader : IDataReader
);

Parameters

reader
This will contain a valid IDataReader on return from this method. If a valid IDataReader cannot be granted, this will be set to null.

Exceptions

Exception Type | Condition
Exception | The command could not be executed.

See Also

SQLCommand Class | SQLCommand Members | System.Data.SQL Namespace | SQLCommand.Execute Overload List


SQLCommand.Execute ()

Executes the CommandText against the ActiveConnection. This is the default method.

[Visual Basic]
Overloads Overrides Public Function Execute() As Integer
[C#]
public override int Execute();
[C++]
public: override int Execute();
[JScript]
public override function Execute() : int;

See Also

SQLCommand Class | SQLCommand Members | System.Data.SQL Namespace | SQLCommand.Execute Overload List


SQLCommand.GetActiveConnectionObject

[To be supplied.]

[Visual Basic]
Overrides Protected Function GetActiveConnectionObject() As _
   DBConnection
[C#]
protected override DBConnection GetActiveConnectionObject();
[C++]
protected: override DBConnection* GetActiveConnectionObject();
[JScript]
protected override function GetActiveConnectionObject() :
   DBConnection;

See Also

SQLCommand Class | SQLCommand Members | System.Data.SQL Namespace


SQLCommand.GetParametersObject

[To be supplied.]

[Visual Basic]
Overrides Protected Function GetParametersObject() As _
   IDataParameters
[C#]
protected override IDataParameters GetParametersObject();
[C++]
protected: override IDataParameters* GetParametersObject();
[JScript]
protected override function GetParametersObject() : IDataParameters;

See Also

SQLCommand Class | SQLCommand Members | System.Data.SQL Namespace


SQLCommand.OnSchemaChanging

[To be supplied.]

[Visual Basic]
Overrides Protected Sub OnSchemaChanging( _
   ByVal scevent As SchemaChangingEventArgs _
)
[C#]
protected override void OnSchemaChanging(
   SchemaChangingEventArgs scevent
);
[C++]
protected: override void OnSchemaChanging(
   SchemaChangingEventArgs* scevent
);
[JScript]
protected override function OnSchemaChanging(
   scevent : SchemaChangingEventArgs
);

Parameters

scevent
[To be supplied.]

See Also

SQLCommand Class | SQLCommand Members | System.Data.SQL Namespace


SQLCommand.SetActiveConnectionObject

[To be supplied.]

[Visual Basic]
Overrides Protected Sub SetActiveConnectionObject( _
   ByVal value As DBConnection _
)
[C#]
protected override void SetActiveConnectionObject(
   DBConnection value
);
[C++]
protected: override void SetActiveConnectionObject(
   DBConnection* value
);
[JScript]
protected override function SetActiveConnectionObject(
   value : DBConnection
);

Parameters

value
[To be supplied.]

See Also

SQLCommand Class | SQLCommand Members | System.Data.SQL Namespace


SQLCommandConverter Class

[To be supplied.]

Object
TypeConverter
SQLCommandConverter

[Visual Basic]
NotInheritable Public Class SQLCommandConverter
   Inherits TypeConverter
[C#]
public sealed class SQLCommandConverter : TypeConverter
[C++]
public __gc __sealed class SQLCommandConverter : public
   TypeConverter
[JScript]
public class SQLCommandConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQL

Assembly: System.Data.dll

See Also

SQLCommandConverter Members | System.Data.SQL Namespace


SQLCommandConverter Members

Public:

Constructor

SQLCommandConverter Constructor [To be supplied.]

Methods

CanConvertFrom (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the converter's native type.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text into an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given object to another type.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetProperties (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValues (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid (inherited from TypeConverter) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

SQLCommandConverter Class | System.Data.SQL Namespace


SQLCommandConverter Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public SQLCommandConverter();
[C++]
public: SQLCommandConverter();
[JScript]
public function SQLCommandConverter();

See Also

SQLCommandConverter Class | SQLCommandConverter Members | System.Data.SQL Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLCommandConverter Methods

The methods of the SQLCommandConverter class are listed below. For a complete list of SQLCommandConverter class members, see the SQLCommandConverter Members topic.

Public:

CanConvertFrom (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the converter's native type.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text into an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given object to another type.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetProperties (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValues (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid (inherited from TypeConverter) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

SQLCommandConverter Class | System.Data.SQL Namespace


SQLCommandConverter.GetPersistInfo

[To be supplied.]

[Visual Basic]
Overrides Public Function GetPersistInfo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal obj As Object _
) As PersistInfo
[C#]
public override PersistInfo GetPersistInfo(
   ITypeDescriptorContext context,
   object obj
);
[C++]
public: override PersistInfo* GetPersistInfo(
   ITypeDescriptorContext* context,
   Object* obj
);
[JScript]
public override function GetPersistInfo(
   context : ITypeDescriptorContext,
   obj : Object
) : PersistInfo;

Parameters

context
[To be supplied.]
obj
[To be supplied.]

See Also

SQLCommandConverter Class | SQLCommandConverter Members | System.Data.SQL Namespace


SQLCommandConverter.GetProperties

Retrieves the set of properties for this type. By default, a type has does not return any properties. An easy implementation of this method can just call TypeDescriptor.GetProperties for the correct data type.

[Visual Basic]
Overrides Public Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal attributes() As MemberAttribute _
) As PropertyDescriptorCollection
[C#]
public override PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value,
   MemberAttribute[] attributes
);
[C++]
public: override PropertyDescriptorCollection* GetProperties(
   ITypeDescriptorContext* context,
   Object* value,
   MemberAttribute* attributes[]
);
[JScript]
public override function GetProperties(
   context : ITypeDescriptorContext,
   value : Object,
   attributes : MemberAttribute[]
) : PropertyDescriptorCollection;

Parameters

context
A type descriptor through which additional context may be provided.
value
The value of the object to get the properties for.
attributes
[To be supplied.]

Return Value

The set of properties that should be exposed for this data type. If no properties should be exposed, thsi may return null. The default implementation always returns null.

See Also

SQLCommandConverter Class | SQLCommandConverter Members | System.Data.SQL Namespace


SQLCommandConverter.GetPropertiesSupported

Determines if this object supports properties. By default, this is false.

[Visual Basic]
Overrides Public Function GetPropertiesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
[C#]
public override bool GetPropertiesSupported(
   ITypeDescriptorContext context
);
[C++]
public: override bool GetPropertiesSupported(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetPropertiesSupported(
   context : ITypeDescriptorContext
) : Boolean;

Parameters

context
A type descriptor through which additional context may be provided.

Return Value

Returns true if GetProperties should be called to find the properties of this object.

See Also

SQLCommandConverter Class | SQLCommandConverter Members | System.Data.SQL Namespace


SQLConnection Class

Represents an open connection to a SQL Server data source.

Object
Component
DBConnection
SQLConnection

[Visual Basic]
Public Class SQLConnection
   Inherits DBConnection
   Implements ISQLConnection, IObjectControl
[C#]
public class SQLConnection : DBConnection, ISQLConnection,
   IObjectControl
[C++]
public __gc class SQLConnection : public DBConnection,
   ISQLConnection, IObjectControl
[JScript]
public class SQLConnection extends DBConnection, ISQLConnection,
   IObjectControl

Remarks

An SQLConnection object represents a unique session with a data source within SQL Server. In the case of a client/server database system, it may be equivalent to a network connection to the server. SQLConnection is used in conjunction with SQLDataSetCommand and SQLCommand to increase performance when connecting to a Micrsoft SQL Server database. For all third party SQL server products, as well as other OLEDB-supported databases, it is probably best that you use ADOConnection

When an instance of SQLConnection is created, the read/write properties are set to initial values. For a list of these values, see the SQLConnection constructor.

Requirements

Namespace: System.Data.SQL

Assembly: System.Data.dll

Example [C#]

The following example selects records from an Access data source. The DataSet then uses SQLDataSetCommand, along with SQLCommand and SQLConnection, to insert new records in a SQL Server data source. This example can be modified to migrate an Access database to a SQL Server database.

[C#]

private DataSet InitializeMyDataSet() {
   // creates the table and its columns for the DataSet
   DataSet newData = new DataSet();
   DataTable newTable = newData.Tables.Add("Catagories");

   // add Columns to table
   newTable.Columns.Add("CategoryID",typeof(Int32));
   newTable.Columns.Add("CategoryName", typeof(String));
   newTable.Columns.Add("Description", typeof(String));
   newTable.Columns.Add("Picture",typeof(Byte[]));
   return newData;
}

public void AccessToSQLServer() {
   // set Access connection and select strings
   const string strAccessConn = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=NWIND_RW.MDB";
   const string strAccessSelect = "SELECT * FROM Categories ORDER BY CategoryID";
   // set SQL Server connection and insert strings
   const string strSQLServerConn = "Data Source=VBsql7;Initial Catalog=Northwind;User ID=sa;Password=;";
   const string strSQLServerInsert = "INSERT INTO Categories(CategoryName, Description, Picture) Values(@CategoryName,@Description,@Picture)";
   // create my DataSet
   DataSet myDataSet = InitializeMyDataSet();
   // create my Access objects
   ADOConnection myAccessConn = new ADOConnection(strAccessConn);
   ADODataSetCommand myAccessDataSetCmd = new ADODataSetCommand();
   myAccessDataSetCmd.SelectCommand = new ADOCommand(strAccessSelect,myAccessConn);
   // create my SQL Server objects
   SQLConnection mySQLConn = new SQLConnection(strSQLServerConn);
   SQLDataSetCommand mySQLDataSetCmd = new SQLDataSetCommand();
   mySQLDataSetCmd.InsertCommand = new SQLCommand(strSQLServerInsert,mySQLConn);
   // fill myDataSet with data from Access
   myAccessConn.Open();
   try {
      myAccessDataSetCmd.FillDataSet(myDataSet,"table");
   }
   finally {
      myAccessConn.Close();
   }

   // update SQL Server with data from the DataSet
   mySQLConn.Open();
   try {
      mySQLDataSetCmd.InsertCommand.Parameters.Add("CategoryName", typeof(String));
      mySQLDataSetCmd.InsertCommand.Parameters.Add("Description", typeof(String));
      mySQLDataSetCmd.InsertCommand.Parameters.Add("Picture", typeof(Byte[]));
      mySQLDataSetCmd.InsertCommand.Parameters[0].SourceColumn = "CategoryName";
      mySQLDataSetCmd.InsertCommand.Parameters[1].SourceColumn = "Description";
      mySQLDataSetCmd.InsertCommand.Parameters[2].SourceColumn = "Picture";
      mySQLDataSetCmd.Update(myDataSet,"table");
   }
   finally {
      mySQLConn.Close();
   }
}

See Also

SQLConnection Members | System.Data.SQL Namespace | SQLDataSetCommand | SQLCommand


SQLConnection Members

Public:

Constructor

SQLConnection Constructor Overloaded. Initializes a new instance of the SQLConnection class.

Properties

ConnectionString | Gets or sets the string used to open a data store in SQL Server.
ConnectionTimeout | Gets or sets the time to wait while establishing a connection before terminating the attempt and generating an error.
Database | Gets or sets the name of the current database or the database to be used once a connection is open.
DataSource | Gets or sets the name of the database to connect to.
IsolationLevel | Gets or sets the isolation level used for any transaction. Initialize only after the connection is open.
Password | Gets or sets the password to use when connecting.
ServerVersion | Gets a string containing the version of the connected SQL Server.
Site (inherited from Component) | Gets or sets the site of the Component.
State | Gets the current state of the connection.
TransactionLevel | Gets the transaction level.
UserID | Gets or sets the user ID to use when connecting.
Version | Gets a string that contains the SQL adapter version.

Methods

Activate | [To be supplied.]
BeginTransaction | Overloaded. Begins a database transaction.
CanBePooled | [To be supplied.]
Clone | Creates a new instance of the object initialized with the current connection string.
Close | Closes the connection to the database.
CommitTransaction | Commits the database transaction.
Deactivate | [To be supplied.]
Dispose (inherited from DBConnection) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetConnectionHolder | Returns the ConnectionHolder for the current connection.
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Open | Opens a database connection with the current property settings.
RollbackTransaction | Overloaded. Rolls back a database transaction.
SaveTransaction | Saves a transaction for later reuse.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Events

InfoMessage | Occurs when an informational message is added.
StateChange (inherited from DBConnection) | Occurs whenever the state of the connection changes.

Protected:

Methods

CreateNewStateChangeEvent (inherited from DBConnection) | [To be supplied.]
Finalize | Performs any final actions, then disposes of the object.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnInfoMessage | Raises the SQLInfoMessageEventArgs event.
OnStateChange (inherited from DBConnection) | Raises the StateChangeEventArgs event.
OpenDesignMode (inherited from DBConnection) | [To be supplied.]
SetObjectState (inherited from DBConnection) | Sets the State to one of the DBObjectState values.

Fields

objectState (inherited from DBConnection) [To be supplied.]

Event Hookup:

Methods

AddOnInfoMessage | add a InfoMessage event handler
AddOnStateChange (inherited from DBConnection) | Use to add a connection state change event handler.
RemoveOnInfoMessage | remove a InfoMessage event handler
RemoveOnStateChange (inherited from DBConnection) | Use to remove a connection state change event handler.

See Also

SQLConnection Class | System.Data.SQL Namespace


SQLConnection Constructor

Initializes a new instance of the SQLConnection class.

Overload List

Initializes a new instance of the SQLConnection class with no parameters.

[Visual Basic] Overloads Public Sub New()
[C#] public SQLConnection();
[C++] public: SQLConnection();
[JScript] public function SQLConnection();

Initializes a new instance of the SQLConnection class when given a string containing the connection text.

[Visual Basic] Overloads Public Sub New(String)
[C#] public SQLConnection(String);
[C++] public: SQLConnection(String*);
[JScript] public function SQLConnection(String);

Initializes a new instance of the SQLConnection class when given a server, a password and a user ID.

[Visual Basic] Overloads Public Sub New(String, String, String)
[C#] public SQLConnection(String, String, String);
[C++] public: SQLConnection(String*, String*, String*);
[JScript] public function SQLConnection(String, String, String);

Initializes a new instance of the SQLConnection class when given a server, a password, an user ID, and a database to connect to.

[Visual Basic] Overloads Public Sub New(String, String, String, String)
[C#] public SQLConnection(String, String, String, String);
[C++] public: SQLConnection(String*, String*, String*, String*);
[JScript] public function SQLConnection(String, String, String, String);

Example

The following example creates a SQLConnection and sets some of its properties.

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace


SQLConnection Constructor ()

Initializes a new instance of the SQLConnection class with no parameters.

[Visual Basic]
Overloads Public Sub New()
[C#]
public SQLConnection();
[C++]
public: SQLConnection();
[JScript]
public function SQLConnection();

Exceptions

Exception Type | Condition
Exception | The connection could not be mapped.

Remarks

When an instance of SQLConnection is created, the following read/write properties are set to initial values.

Properties | Initial Value
ConnectionString | empty string ("")
ConnectionTimeout | 15
Database | empty string ("")
IsolationLevel | Unspecified
DataSource | empty string ("")
UserID | empty string ("")
Password | empty string ("")

You can change the value for any of these properties through a separate call to the property.

Example

The following example creates a SQLConnection and sets some of its properties.

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace | SQLConnection Constructor Overload List


SQLConnection Constructor (String)

Initializes a new instance of the SQLConnection class when given a string containing the connection text.

[Visual Basic]
Overloads Public Sub New( _
   ByVal connectionString As String _
)
[C#]
public SQLConnection(
   string connectionString
);
[C++]
public: SQLConnection(
   String* connectionString
);
[JScript]
public function SQLConnection(
   connectionString : String
);

Parameters

connectionString
The connection used to open the SQL Server data store.

Exceptions

Exception Type | Condition
Exception | The connection could not be mapped.

Remarks

When an instance of SQLConnection is created, the following read/write properties are set to initial values.

Properties | Initial Value
ConnectionString | connectionString
ConnectionTimeout | 15
Database | empty string ("")
IsolationLevel | Unspecified
DataSource | empty string ("")
UserID | empty string ("")
Password | empty string ("")

You can change the value for any of these properties through a separate call to the property.

Example

The following example creates a SQLConnection and sets some of its properties.

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace | SQLConnection Constructor Overload List


SQLConnection Constructor (String, String, String)

Initializes a new instance of the SQLConnection class when given a server, a password and a user ID.

[Visual Basic]
Overloads Public Sub New( _
   ByVal dataSource As String, _
   ByVal userID As String, _
   ByVal password As String _
)
[C#]
public SQLConnection(
   string dataSource,
   string userID,
   string password
);
[C++]
public: SQLConnection(
   String* dataSource,
   String* userID,
   String* password
);
[JScript]
public function SQLConnection(
   dataSource : String,
   userID : String,
   password : String
);

Parameters

dataSource
The name of the server that SQL Server resides on.
userID
The user identification for SQL Server.
password
The user password for SQL Server.

Exceptions

Exception Type | Condition
Exception | The connection could not be mapped properly. An improper argument was passed or argument was missing.

Remarks

When an instance of SQLConnection is created, the following read/write properties are set to initial values.

Properties | Initial Value
ConnectionString | empty string ("")
ConnectionTimeout | 15
Database | empty string ("")
IsolationLevel | Unspecified
DataSource | dataSource
UserID | userID
Password | password

You can change the value for any of these properties through a separate call to the property.

Example

The following example creates a SQLConnection and sets some of its properties.

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace | SQLConnection Constructor Overload List


SQLConnection Constructor (String, String, String, String)

Initializes a new instance of the SQLConnection class when given a server, a password, an user ID, and a database to connect to.

[Visual Basic]
Overloads Public Sub New( _
   ByVal dataSource As String, _
   ByVal userID As String, _
   ByVal password As String, _
   ByVal database As String _
)
[C#]
public SQLConnection(
   string dataSource,
   string userID,
   string password,
   string database
);
[C++]
public: SQLConnection(
   String* dataSource,
   String* userID,
   String* password,
   String* database
);
[JScript]
public function SQLConnection(
   dataSource : String,
   userID : String,
   password : String,
   database : String
);

Parameters

dataSource
The name of the server that SQL Server resides on.
userID
The user identification for SQL Server.
password
The user password for SQL Server.
database
The name of the database in SQL Server to connect to.

Exceptions

Exception Type | Condition
Exception | The connection could not be mapped properly. -or- An improper argument was passed or an argument was missing.

Remarks

When an instance of SQLConnection is created, the following read/write properties are set to initial values.

Properties | Initial Value
ConnectionString | empty string ("")
ConnectionTimeout | 15
Database | database
IsolationLevel | Unspecified
DataSource | dataSource
UserID | userID
Password | password

You can change the value for any of these properties through a separate call to the property.

Example

The following example creates a SQLConnection and sets some of its properties.

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace | SQLConnection Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLConnection Properties

The properties of the SQLConnection class are listed below. For a complete list of SQLConnection class members, see the SQLConnection Members topic.

Public:

ConnectionString | Gets or sets the string used to open a data store in SQL Server.
ConnectionTimeout | Gets or sets the time to wait while establishing a connection before terminating the attempt and generating an error.
Database | Gets or sets the name of the current database or the database to be used once a connection is open.
DataSource | Gets or sets the name of the database to connect to.
IsolationLevel | Gets or sets the isolation level used for any transaction. Initialize only after the connection is open.
Password | Gets or sets the password to use when connecting.
ServerVersion | Gets a string containing the version of the connected SQL Server.
Site (inherited from Component) | Gets or sets the site of the Component.
State | Gets the current state of the connection.
TransactionLevel | Gets the transaction level.
UserID | Gets or sets the user ID to use when connecting.
Version | Gets a string that contains the SQL adapter version.

See Also

SQLConnection Class | System.Data.SQL Namespace


SQLConnection.ConnectionString

Gets or sets the string used to open a data store in SQL Server.

[Visual Basic]
Overridable Public Property ConnectionString As String
[C#]
public string ConnectionString {override get; override set;}
[C++]
public: __property virtual String* get_ConnectionString();
public: __property virtual void set_ConnectionString(String*);
[JScript]
public function get ConnectionString() : String;
public function set ConnectionString(String);

Property Value

The connection string used to indicate the source database and other information used in establishing the initial connection. The default value is an empty string.

Remarks

The string can only be set when the state of the connection is closed.

Example

The following example creates a SQLConnection and sets some of its properties.

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace | ConnectionTimeout | Database | DataSource | UserID | Password | IsolationLevel


SQLConnection.ConnectionTimeout

Gets or sets the time to wait while establishing a connection before terminating the attempt and generating an error.

[Visual Basic]
Public Property ConnectionTimeout As Integer
[C#]
public int ConnectionTimeout {get; set;}
[C++]
public: __property int get_ConnectionTimeout();
public: __property void set_ConnectionTimeout(int);
[JScript]
public function get ConnectionTimeout() : int;
public function set ConnectionTimeout(int);

Property Value

The time (in seconds) to wait for a connection to open. The default value is 15 seconds.

Exceptions

Exception Type | Condition
BrokenConError | The connection is broken.
InvalidConnectionTimeout | The property is set to a value less than 0.

Remarks

This property overwrites the matching property in the connection string.

Note This property is read-only while the connection is open.

Example

The following example creates a SQLConnection and sets some of its properties.

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace | ConnectionString | Database | DataSource | UserID | Password | IsolationLevel


SQLConnection.Database

Gets or sets the name of the current database or the database to be used once a connection is open.

[Visual Basic]
Public Property Database As String
[C#]
public string Database {get; set;}
[C++]
public: __property String* get_Database();
public: __property void set_Database(String*);
[JScript]
public function get Database() : String;
public function set Database(String);

Property Value

The name of the current database or the name of the database to be used once a connection is open. The default value is an empty string.

Exceptions

Exception Type | Condition
BrokenConError | The connection is broken.

Remarks

If the Database property is set when the connection is open, it will set the provider's current catalog property. If this property is set when the connection is closed, it will set the provider's initial catalog property.

Note This is the only property other then IsolationLevel that can be set when the connection is open.

Example

The following example creates a SQLConnection and sets some of its properties.

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace | ConnectionString | ConnectionTimeout | DataSource | UserID | Password | IsolationLevel


SQLConnection.DataSource

Gets or sets the name of the database to connect to.

[Visual Basic]
Public Property DataSource As String
[C#]
public string DataSource {get; set;}
[C++]
public: __property String* get_DataSource();
public: __property void set_DataSource(String*);
[JScript]
public function get DataSource() : String;
public function set DataSource(String);

Property Value

The name of the database to connect to. The default value is an empty string.

Exceptions

Exception Type | Condition
OpenConVariable | The connection is open. You must first close the connection.
BrokenConError | The connection is broken.

Remarks

The DataSource property overwrites the cooresponding property within the connection string.

Note This property is read-only while the connection is open.

Example

The following example creates a SQLConnection and sets some of its properties.

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace | ConnectionString | ConnectionTimeout | Database | UserID | Password | IsolationLevel


SQLConnection.IsolationLevel

Gets or sets the isolation level used for any transaction. Initialize only after the connection is open.

[Visual Basic]
Public Property IsolationLevel As IsolationLevel
[C#]
public IsolationLevel IsolationLevel {get; set;}
[C++]
public: __property IsolationLevel get_IsolationLevel();
public: __property void set_IsolationLevel(IsolationLevel);
[JScript]
public function get IsolationLevel() : IsolationLevel;
public function set IsolationLevel(IsolationLevel);

Property Value

One of the IsolationLevel values.

Exceptions

Exception Type | Condition
BrokenConError | The connection is broken.

Remarks

If the connetion is closed the IsolationLevel property is set to Unspecified.

Note This is the only property other then Database that can be set when the connection is open.

Example

The following example creates a SQLConnection and sets some of its properties.

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace | Database | ConnectionString | ConnectionTimeout | DataSource | Password | UserID


SQLConnection.Password

Gets or sets the password to use when connecting.

[Visual Basic]
Public Property Password As String
[C#]
public string Password {get; set;}
[C++]
public: __property String* get_Password();
public: __property void set_Password(String*);
[JScript]
public function get Password() : String;
public function set Password(String);

Property Value

The password to use when connecting. The default value is an empty string.

Exceptions

Exception Type | Condition
BrokenConError | The connection is broken.
OpenConVariable | The connection is open. You must first close the connection.

Remarks

The Password property overwrites the cooresponding property within the connection string.

Note This property is read-only while the connection is open.

Example

The following example creates a SQLConnection and sets some of its properties.

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace | ConnectionString | ConnectionTimeout | Database | DataSource | UserID | IsolationLevel


SQLConnection.ServerVersion

Gets a string containing the version of the connected SQL Server.

[Visual Basic]
Public ReadOnly Property ServerVersion As String
[C#]
public string ServerVersion {get;}
[C++]
public: __property String* get_ServerVersion();
[JScript]
public function get ServerVersion() : String;

Property Value

The version of SQL Server currently connected.

Exceptions

Exception Type | Condition
ClosedConError | The connection is closed.

Example

The following example shows how to create a connection and displays some of its read-only properties.

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace | Version


SQLConnection.State

Gets the current state of the connection.

[Visual Basic]
Overridable Public ReadOnly Property State As DBObjectState
[C#]
public DBObjectState State {override get;}
[C++]
public: __property virtual DBObjectState get_State();
[JScript]
public function get State() : DBObjectState;

Property Value

One of the DBObjectState values.

Remarks

DBObjectState values may be OR'ed together.

Example

The following example shows how to create a connection and displays some of its read-only properties.

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace


SQLConnection.TransactionLevel

Gets the transaction level.

[Visual Basic]
Public ReadOnly Property TransactionLevel As Integer
[C#]
public int TransactionLevel {get;}
[C++]
public: __property int get_TransactionLevel();
[JScript]
public function get TransactionLevel() : int;

Property Value

A value representing the level of the transaction.

Example

The following example shows how to create a connection and displays some of its read-only properties.

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace


SQLConnection.UserID

Gets or sets the user ID to use when connecting.

[Visual Basic]
Public Property UserID As String
[C#]
public string UserID {get; set;}
[C++]
public: __property String* get_UserID();
public: __property void set_UserID(String*);
[JScript]
public function get UserID() : String;
public function set UserID(String);

Property Value

The user ID to use when connecting. The default value is an empty string.

Exceptions

Exception Type | Condition
OpenConVariable | The connection is open. You must first close the connection.
BrokenConError | The connection is broken.

Remarks

The UserID property overwrites the cooresponding property within the connection string.

Note This property is read-only while the connection is open.

Example

The following example creates a SQLConnection and sets some of its properties.

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace | ConnectionString | ConnectionTimeout | Database | DataSource | Password | IsolationLevel


SQLConnection.Version

Gets a string that contains the SQL adapter version.

[Visual Basic]
Public ReadOnly Property Version As String
[C#]
public string Version {get;}
[C++]
public: __property String* get_Version();
[JScript]
public function get Version() : String;

Property Value

The version of the SQL adapter.

Example

The following example shows how to create a connection and displays some of its read-only properties.

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace | ServerVersion


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLConnection Methods

The methods of the SQLConnection class are listed below. For a complete list of SQLConnection class members, see the SQLConnection Members topic.

Public:

Activate | [To be supplied.]
BeginTransaction | Overloaded. Begins a database transaction.
CanBePooled | [To be supplied.]
Clone | Creates a new instance of the object initialized with the current connection string.
Close | Closes the connection to the database.
CommitTransaction | Commits the database transaction.
Deactivate | [To be supplied.]
Dispose (inherited from DBConnection) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetConnectionHolder | Returns the ConnectionHolder for the current connection.
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Open | Opens a database connection with the current property settings.
RollbackTransaction | Overloaded. Rolls back a database transaction.
SaveTransaction | Saves a transaction for later reuse.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Protected:

CreateNewStateChangeEvent (inherited from DBConnection) | [To be supplied.]
Finalize | Performs any final actions, then disposes of the object.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnInfoMessage | Raises the SQLInfoMessageEventArgs event.
OnStateChange (inherited from DBConnection) | Raises the StateChangeEventArgs event.
OpenDesignMode (inherited from DBConnection) | [To be supplied.]
SetObjectState (inherited from DBConnection) | Sets the State to one of the DBObjectState values.

Event Hookup:

AddOnInfoMessage | add a InfoMessage event handler
AddOnStateChange (inherited from DBConnection) | Use to add a connection state change event handler.
RemoveOnInfoMessage | remove a InfoMessage event handler
RemoveOnStateChange (inherited from DBConnection) | Use to remove a connection state change event handler.

See Also

SQLConnection Class | System.Data.SQL Namespace


SQLConnection.Activate

[To be supplied.]

[Visual Basic]
Overridable Public Sub Activate()
[C#]
public virtual void Activate();
[C++]
public: virtual void Activate();
[JScript]
public function Activate();

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace


SQLConnection.AddOnInfoMessage

add a InfoMessage event handler

[Visual Basic]
Overridable Public Sub AddOnInfoMessage( _
   ByVal handler As InfoMessageEventHandler _
)
[C#]
public virtual void AddOnInfoMessage(
   InfoMessageEventHandler handler
);
[C++]
public: virtual void AddOnInfoMessage(
   InfoMessageEventHandler* handler
);
[JScript]
public function AddOnInfoMessage(
   handler : InfoMessageEventHandler
);

Parameters

handler
[To be supplied.]

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace


SQLConnection.BeginTransaction

Begins a database transaction.

Overload List

Begins a database transaction without any parameters.

[Visual Basic] Overloads Overrides Public Function BeginTransaction() As Integer
[C#] public override int BeginTransaction();
[C++] public: override int BeginTransaction();
[JScript] public override function BeginTransaction() : int;

Begins a database transaction with the transaction name.

[Visual Basic] Overloads Public Function BeginTransaction(String) As Integer
[C#] public int BeginTransaction(String);
[C++] public: int BeginTransaction(String*);
[JScript] public function BeginTransaction(String) : int;

Example

The following example creates a connection, opens it, begins a transaction, saves the transaction, commits the transaction, rolls back the transaction, then closes the connection.

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace


SQLConnection.BeginTransaction ()

Begins a database transaction without any parameters.

[Visual Basic]
Overloads Overrides Public Function BeginTransaction() As Integer
[C#]
public override int BeginTransaction();
[C++]
public: override int BeginTransaction();
[JScript]
public override function BeginTransaction() : int;

Exceptions

Exception Type | Condition
Exception | An error occured while trying to execute the transaction.

Remarks

Notes to Inheritors: When overriding BeginTransaction in a derived class, be sure to call the base class's BeginTransaction method.

Example

The following example creates a connection, opens it, begins a transaction, saves the transaction, commits the transaction, rollsback the transaction, then closes the connection.

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace | SQLConnection.BeginTransaction Overload List | CommitTransaction | SaveTransaction | RollbackTransaction


SQLConnection.BeginTransaction (String)

Begins a database transaction with the transaction name.

[Visual Basic]
Overloads Public Function BeginTransaction( _
   ByVal transactionName As String _
) As Integer
[C#]
public int BeginTransaction(
   string transactionName
);
[C++]
public: int BeginTransaction(
   String* transactionName
);
[JScript]
public function BeginTransaction(
   transactionName : String
) : int;

Parameters

transactionName
The name of the transaction.

Exceptions

Exception Type | Condition
NullEmptyTransactionName | A transaction name must be specified.

Example

The following example creates a connection, opens it, begins a transaction, saves the transaction, commits the transaction, rolls back the transaction, then closes the connection.

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace | SQLConnection.BeginTransaction Overload List | CommitTransaction | SaveTransaction | RollbackTransaction


SQLConnection.CanBePooled

[To be supplied.]

[Visual Basic]
Overridable Public Function CanBePooled() As Integer
[C#]
public virtual int CanBePooled();
[C++]
public: virtual int CanBePooled();
[JScript]
public function CanBePooled() : int;

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace


SQLConnection.Clone

Creates a new instance of the object initialized with the current connection string.

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
public: override Object* Clone();
[JScript]
public override function Clone() : Object;

Remarks

The new instance will be in a closed state.

Example

The following example uses this method within a derived class.

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace


SQLConnection.Close

Closes the connection to the database.

[Visual Basic]
Overrides Public Sub Close()
[C#]
public override void Close();
[C++]
public: override void Close();
[JScript]
public override function Close();

Exceptions

Exception Type | Condition
ConnectionAlreadyClosed | The connection is already closed.
PendingTransaction | A transaction is still processing.
Exception | The connection could not be closed.

Example

The following example creates a connection, opens it, begins a transaction, saves the transaction, commits the transaction, rollsback the transaction, then closes the connection.

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace | Open


SQLConnection.CommitTransaction

Commits the database transaction.

[Visual Basic]
Overrides Public Sub CommitTransaction()
[C#]
public override void CommitTransaction();
[C++]
public: override void CommitTransaction();
[JScript]
public override function CommitTransaction();

Exceptions

Exception Type | Condition
Exception | An error occured while trying to execute the transaction.

Remarks

Notes to Inheritors: When overriding CommitTransaction in a derived class, be sure to call the base class's CommitTransaction method.

Example

The following example creates a connection, opens it, begins a transaction, saves the transaction, commits the transaction, rollsback the transaction, then closes the connection.

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace | BeginTransaction | SaveTransaction | RollbackTransaction


SQLConnection.Deactivate

[To be supplied.]

[Visual Basic]
Overridable Public Sub Deactivate()
[C#]
public virtual void Deactivate();
[C++]
public: virtual void Deactivate();
[JScript]
public function Deactivate();

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace


SQLConnection.Finalize

Performs any final actions, then disposes of the object.

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

Remarks

Notes to Inheritors: When overriding Finalize in a derived class, be sure to call the base class's Finalize method.

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace


SQLConnection.GetConnectionHolder

Returns the ConnectionHolder for the current connection.

[Visual Basic]
Overridable Public Function GetConnectionHolder() As _
   ConnectionHolder
[C#]
public virtual ConnectionHolder GetConnectionHolder();
[C++]
public: virtual ConnectionHolder* GetConnectionHolder();
[JScript]
public function GetConnectionHolder() : ConnectionHolder;

Return Value

The ConnectionHolder for the current connection.

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace


SQLConnection.OnInfoMessage

Raises the SQLInfoMessageEventArgs event.

[Visual Basic]
Overridable Protected Sub OnInfoMessage( _
   ByVal imevent As SQLInfoMessageEventArgs _
)
[C#]
protected virtual void OnInfoMessage(
   SQLInfoMessageEventArgs imevent
);
[C++]
protected: virtual void OnInfoMessage(
   SQLInfoMessageEventArgs* imevent
);
[JScript]
protected function OnInfoMessage(
   imevent : SQLInfoMessageEventArgs
);

Parameters

imevent
An SQLInfoMessageEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see TBD.

Notes to Inheritors: When overriding OnInfoMessage in a derived class, be sure to call the base class's OnInfoMessage method.

Example

The following example uses this method within a derived class.

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace


SQLConnection.Open

Opens a database connection with the current property settings.

[Visual Basic]
Overrides Public Sub Open()
[C#]
public override void Open();
[C++]
public: override void Open();
[JScript]
public override function Open();

Exceptions

Exception Type | Condition
Exception | The dataSource property was not set or was set incorrectly.
BrokenConError | The connection is broken.
ConnectionAlreadyOpen | The connection is already open.

Example

The following example creates a connection, opens it, begins a transaction, saves the transaction, commits the transaction, rollsback the transaction, then closes the connection.

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace | Close


SQLConnection.RemoveOnInfoMessage

remove a InfoMessage event handler

[Visual Basic]
Overridable Public Sub RemoveOnInfoMessage( _
   ByVal handler As InfoMessageEventHandler _
)
[C#]
public virtual void RemoveOnInfoMessage(
   InfoMessageEventHandler handler
);
[C++]
public: virtual void RemoveOnInfoMessage(
   InfoMessageEventHandler* handler
);
[JScript]
public function RemoveOnInfoMessage(
   handler : InfoMessageEventHandler
);

Parameters

handler
[To be supplied.]

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace


SQLConnection.RollbackTransaction

Rolls back a database transaction.

Overload List

Rolls back a transaction from being applied to the database with no parameters.

[Visual Basic] Overloads Overrides Public Sub RollbackTransaction()
[C#] public override void RollbackTransaction();
[C++] public: override void RollbackTransaction();
[JScript] public override function RollbackTransaction();

Rolls back a database transaction with the transaction name.

[Visual Basic] Overloads Public Sub RollbackTransaction(String)
[C#] public void RollbackTransaction(String);
[C++] public: void RollbackTransaction(String*);
[JScript] public function RollbackTransaction(String);

Example

The following example creates a connection, opens it, begins a transaction, saves the transaction, commits the transaction, rolls back the transaction, then closes the connection.

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace


SQLConnection.RollbackTransaction ()

Rolls back a transaction from being applied to the database with no parameters.

[Visual Basic]
Overloads Overrides Public Sub RollbackTransaction()
[C#]
public override void RollbackTransaction();
[C++]
public: override void RollbackTransaction();
[JScript]
public override function RollbackTransaction();

Exceptions

Exception Type | Condition
Exception | An error occured while trying to execute the transaction.

Remarks

Notes to Inheritors: When overriding RollbackTransaction in a derived class, be sure to call the base class's RollbackTransaction method.

Example

The following example creates a connection, opens it, begins a transaction, saves the transaction, commits the transaction, rollsback the transaction, then closes the connection.

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace | SQLConnection.RollbackTransaction Overload List | CommitTransaction | SaveTransaction | BeginTransaction


SQLConnection.RollbackTransaction (String)

Rolls back a database transaction with the transaction name.

[Visual Basic]
Overloads Public Sub RollbackTransaction( _
   ByVal transactionName As String _
)
[C#]
public void RollbackTransaction(
   string transactionName
);
[C++]
public: void RollbackTransaction(
   String* transactionName
);
[JScript]
public function RollbackTransaction(
   transactionName : String
);

Parameters

transactionName
The name of the transaction to rollback.

Exceptions

Exception Type | Condition
NullEmptyTransactionName | A transaction name must be specified.

Example

The following example creates a connection, opens it, begins a transaction, saves the transaction, commits the transaction, rolls back the transaction, then closes the connection.

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace | SQLConnection.RollbackTransaction Overload List | CommitTransaction | SaveTransaction | BeginTransaction


SQLConnection.SaveTransaction

Saves a transaction for later reuse.

[Visual Basic]
Public Sub SaveTransaction( _
   ByVal savePointName As String _
)
[C#]
public void SaveTransaction(
   string savePointName
);
[C++]
public: void SaveTransaction(
   String* savePointName
);
[JScript]
public function SaveTransaction(
   savePointName : String
);

Parameters

savePointName
A name for the transaction to be saved.

Exceptions

Exception Type | Condition
NullEmptyTransactionName | A transaction name must be specified.

Example

The following example creates a connection, opens it, begins a transaction, saves the transaction, commits the transaction, rolls back the transaction, then closes the connection.

See Also

SQLConnection Class | SQLConnection Members | System.Data.SQL Namespace | CommitTransaction | RollbackTransaction | BeginTransaction


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLConnection Events

The events of the SQLConnection class are listed below. For a complete list of SQLConnection class members, see the SQLConnection Members topic.

Public:

InfoMessage | Occurs when an informational message is added.
StateChange (inherited from DBConnection) | Occurs whenever the state of the connection changes.

See Also

SQLConnection Class | System.Data.SQL Namespace


SQLConnection InfoMessage Event

Occurs when an informational message is added.

The following declaration shows the syntax for a method that handles the InfoMessage event.

[Visual Basic]
Private Sub SQLConnectionName_InfoMessage( _
   ByVal sender As Object, _
   ByVal e As InfoMessageEventArgs _
)
[C#]
private void SQLConnectionName_InfoMessage(
   object sender,
   InfoMessageEventArgs e
);
[C++]
private: void SQLConnectionName_InfoMessage(
   Object* sender,
   InfoMessageEventArgs* e
);
[JScript]
private SQLConnectionName_InfoMessage(
   sender : Object,
   e : InfoMessageEventArgs
);

Parameters

sender
The source of the event.
e
An InfoMessageEventArgs that contains the event data.

See Also

SQLConnection Class | SQLConnection MembersTopic | System.Data.SQL Namespace


SQLDataReader Class

[To be supplied.]

Object
DBDataReader
SQLDataReader

[Visual Basic]
NotInheritable Public Class SQLDataReader
   Inherits DBDataReader
   Implements IDBDataReader, IDataReader, IDataRecord, _
   ISQLDataReader, ISQLDataRecord
[C#]
public sealed class SQLDataReader : DBDataReader, IDBDataReader,
   IDataReader, IDataRecord, ISQLDataReader, ISQLDataRecord
[C++]
public __gc __sealed class SQLDataReader : public DBDataReader,
   IDBDataReader, IDataReader, IDataRecord, ISQLDataReader,
   ISQLDataRecord
[JScript]
public class SQLDataReader extends DBDataReader, IDBDataReader,
   IDataReader, IDataRecord, ISQLDataReader, ISQLDataRecord

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQL

Assembly: System.Data.dll

See Also

SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader Members

Public:

Properties

DataTypeName | [To be supplied.]
DataTypeNamespace | [To be supplied.]
Depth (inherited from DBDataReader) | [To be supplied.]
Empty (inherited from DBDataReader) | [To be supplied.]
EOF | [To be supplied.]
FieldCount | [To be supplied.]
Filter | [To be supplied.]
Format (inherited from DBDataReader) | [To be supplied.]
HasValue | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the SQLDataReader class.
Name | [To be supplied.]
Namespace (inherited from DBDataReader) | [To be supplied.]
NameTable (inherited from DBDataReader) | [To be supplied.]
NodeType (inherited from DBDataReader) | [To be supplied.]
Prefix (inherited from DBDataReader) | [To be supplied.]
ReadState (inherited from DBDataReader) | [To be supplied.]
RecordsAffected | [To be supplied.]
SchemaTable | [To be supplied.]

Methods

Close | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBoolean | [To be supplied.]
GetByte | [To be supplied.]
GetBytes | [To be supplied.]
GetChar | [To be supplied.]
GetChars | [To be supplied.]
GetCurrency | [To be supplied.]
GetData | [To be supplied.]
GetDataTypeName | [To be supplied.]
GetDataTypeNamespace | [To be supplied.]
GetDateTime | [To be supplied.]
GetDecimal | [To be supplied.]
GetDouble | [To be supplied.]
GetFieldType | [To be supplied.]
GetFloat | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInt16 | [To be supplied.]
GetInt32 | [To be supplied.]
GetInt64 | [To be supplied.]
GetName | [To be supplied.]
GetNamespace | [To be supplied.]
GetOrdinal | Overloaded. [To be supplied.]
GetPrefix | [To be supplied.]
GetRaw | [To be supplied.]
GetSQLBit | [To be supplied.]
GetSQLByte | [To be supplied.]
GetSQLDateTime | [To be supplied.]
GetSQLDouble | [To be supplied.]
GetSQLGuid | [To be supplied.]
GetSQLInt16 | [To be supplied.]
GetSQLInt32 | [To be supplied.]
GetSQLInt64 | [To be supplied.]
GetSQLMoney | [To be supplied.]
GetSQLNumeric | [To be supplied.]
GetSQLSingle | [To be supplied.]
GetSQLString | [To be supplied.]
GetSQLVariant | [To be supplied.]
GetStream | [To be supplied.]
GetString | [To be supplied.]
GetTimeSpan | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | [To be supplied.]
GetValues | [To be supplied.]
IsNull | [To be supplied.]
Read | [To be supplied.]
SetRowBuffer | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Events

DataSchemaChanged (inherited from DBDataReader) [To be supplied.]

Protected:

Methods

CreateNewSchemaTable (inherited from DBDataReader) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnDataSchemaChangedEvent (inherited from DBDataReader) | [To be supplied.]

Fields

dataValues (inherited from DBDataReader) | [To be supplied.]
dbSchemaTable (inherited from DBDataReader) | [To be supplied.]
inDataSchemaChanged (inherited from DBDataReader) | [To be supplied.]
indexMap (inherited from DBDataReader) | [To be supplied.]
pendingEvent (inherited from DBDataReader) | [To be supplied.]
readingState (inherited from DBDataReader) | [To be supplied.]

Event Hookup:

Methods

AddOnDataSchemaChanged (inherited from DBDataReader) | [To be supplied.]
RemoveOnDataSchemaChanged (inherited from DBDataReader) | [To be supplied.]

See Also

SQLDataReader Class | System.Data.SQL Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLDataReader Properties

The properties of the SQLDataReader class are listed below. For a complete list of SQLDataReader class members, see the SQLDataReader Members topic.

Public:

DataTypeName | [To be supplied.]
DataTypeNamespace | [To be supplied.]
Depth (inherited from DBDataReader) | [To be supplied.]
Empty (inherited from DBDataReader) | [To be supplied.]
EOF | [To be supplied.]
FieldCount | [To be supplied.]
Filter | [To be supplied.]
Format (inherited from DBDataReader) | [To be supplied.]
HasValue | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the SQLDataReader class.
Name | [To be supplied.]
Namespace (inherited from DBDataReader) | [To be supplied.]
NameTable (inherited from DBDataReader) | [To be supplied.]
NodeType (inherited from DBDataReader) | [To be supplied.]
Prefix (inherited from DBDataReader) | [To be supplied.]
ReadState (inherited from DBDataReader) | [To be supplied.]
RecordsAffected | [To be supplied.]
SchemaTable | [To be supplied.]

See Also

SQLDataReader Class | System.Data.SQL Namespace


SQLDataReader.DataTypeName

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DataTypeName As String
[C#]
public string DataTypeName {virtual get;}
[C++]
public: __property virtual String* get_DataTypeName();
[JScript]
public function get DataTypeName() : String;

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.DataTypeNamespace

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DataTypeNamespace As String
[C#]
public string DataTypeNamespace {virtual get;}
[C++]
public: __property virtual String* get_DataTypeNamespace();
[JScript]
public function get DataTypeNamespace() : String;

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.EOF

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property EOF As Boolean
[C#]
public bool EOF {override get;}
[C++]
public: __property virtual bool get_EOF();
[JScript]
public function get EOF() : Boolean;

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.FieldCount

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property FieldCount As Integer
[C#]
public int FieldCount {virtual get;}
[C++]
public: __property virtual int get_FieldCount();
[JScript]
public function get FieldCount() : int;

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.Filter

[To be supplied.]

[Visual Basic]
Overridable Public Property Filter As String
[C#]
public string Filter {virtual get; virtual set;}
[C++]
public: __property virtual String* get_Filter();
public: __property virtual void set_Filter(String*);
[JScript]
public function get Filter() : String;
public function set Filter(String);

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.HasValue

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property HasValue As Boolean
[C#]
public bool HasValue {virtual get;}
[C++]
public: __property virtual bool get_HasValue();
[JScript]
public function get HasValue() : Boolean;

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the SQLDataReader class.

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(String, String) As Object
[C#] public object this[String, String] {virtual get;}
[C++] public: __property virtual Object* get_Item(String*, String*);
[JScript] SQLDataReader.Item (String, String)

[To be supplied.]

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(String) As Object
[C#] public object this[String] {virtual get;}
[C++] public: __property virtual Object* get_Item(String*);
[JScript] SQLDataReader.Item (String)

[To be supplied.]

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(Integer) As Object
[C#] public object this[int] {virtual get;}
[C++] public: __property virtual Object* get_Item(int);
[JScript] SQLDataReader.Item (int)

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.Item (String, String)

[To be supplied.]

[C#] In C#, this member is the indexer for the SQLDataReader class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal name As String, _
   ByVal namespaceURI As String _
) As Object
[C#]
public object this[
   string name,
   string namespaceURI
] {virtual get;}
[C++]
public: __property virtual Object* get_Item(
   String* name,
   String* namespaceURI
);
[JScript]
returnValue = SQLDataReaderObject.Item(name, namespaceURI);
-or-
returnValue = SQLDataReaderObject(name, namespaceURI);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
[To be supplied.]
namespaceURI
[To be supplied.]

Parameters [Visual Basic, C#, C++]

name
[To be supplied.]
namespaceURI
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace | SQLDataReader.Item Overload List


SQLDataReader.Item (String)

[To be supplied.]

[C#] In C#, this member is the indexer for the SQLDataReader class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal name As String _
) As Object
[C#]
public object this[
   string name
] {virtual get;}
[C++]
public: __property virtual Object* get_Item(
   String* name
);
[JScript]
returnValue = SQLDataReaderObject.Item(name);
-or-
returnValue = SQLDataReaderObject(name);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
[To be supplied.]

Parameters [Visual Basic, C#, C++]

name
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace | SQLDataReader.Item Overload List


SQLDataReader.Item (Int32)

[To be supplied.]

[C#] In C#, this member is the indexer for the SQLDataReader class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal i As Integer _
) As Object
[C#]
public object this[
   int i
] {virtual get;}
[C++]
public: __property virtual Object* get_Item(
   int i
);
[JScript]
returnValue = SQLDataReaderObject.Item(i);
-or-
returnValue = SQLDataReaderObject(i);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

i
[To be supplied.]

Parameters [Visual Basic, C#, C++]

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace | SQLDataReader.Item Overload List


SQLDataReader.Name

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {virtual get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.RecordsAffected

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property RecordsAffected As Integer
[C#]
public int RecordsAffected {virtual get;}
[C++]
public: __property virtual int get_RecordsAffected();
[JScript]
public function get RecordsAffected() : int;

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.SchemaTable

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property SchemaTable As DataTable
[C#]
public DataTable SchemaTable {virtual get;}
[C++]
public: __property virtual DataTable* get_SchemaTable();
[JScript]
public function get SchemaTable() : DataTable;

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLDataReader Methods

The methods of the SQLDataReader class are listed below. For a complete list of SQLDataReader class members, see the SQLDataReader Members topic.

Public:

Close | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBoolean | [To be supplied.]
GetByte | [To be supplied.]
GetBytes | [To be supplied.]
GetChar | [To be supplied.]
GetChars | [To be supplied.]
GetCurrency | [To be supplied.]
GetData | [To be supplied.]
GetDataTypeName | [To be supplied.]
GetDataTypeNamespace | [To be supplied.]
GetDateTime | [To be supplied.]
GetDecimal | [To be supplied.]
GetDouble | [To be supplied.]
GetFieldType | [To be supplied.]
GetFloat | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInt16 | [To be supplied.]
GetInt32 | [To be supplied.]
GetInt64 | [To be supplied.]
GetName | [To be supplied.]
GetNamespace | [To be supplied.]
GetOrdinal | Overloaded. [To be supplied.]
GetPrefix | [To be supplied.]
GetRaw | [To be supplied.]
GetSQLBit | [To be supplied.]
GetSQLByte | [To be supplied.]
GetSQLDateTime | [To be supplied.]
GetSQLDouble | [To be supplied.]
GetSQLGuid | [To be supplied.]
GetSQLInt16 | [To be supplied.]
GetSQLInt32 | [To be supplied.]
GetSQLInt64 | [To be supplied.]
GetSQLMoney | [To be supplied.]
GetSQLNumeric | [To be supplied.]
GetSQLSingle | [To be supplied.]
GetSQLString | [To be supplied.]
GetSQLVariant | [To be supplied.]
GetStream | [To be supplied.]
GetString | [To be supplied.]
GetTimeSpan | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | [To be supplied.]
GetValues | [To be supplied.]
IsNull | [To be supplied.]
Read | [To be supplied.]
SetRowBuffer | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

CreateNewSchemaTable (inherited from DBDataReader) | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnDataSchemaChangedEvent (inherited from DBDataReader) | [To be supplied.]

Event Hookup:

AddOnDataSchemaChanged (inherited from DBDataReader) | [To be supplied.]
RemoveOnDataSchemaChanged (inherited from DBDataReader) | [To be supplied.]

See Also

SQLDataReader Class | System.Data.SQL Namespace


SQLDataReader.Close

[To be supplied.]

[Visual Basic]
Overridable Public Sub Close()
[C#]
public virtual void Close();
[C++]
public: virtual void Close();
[JScript]
public function Close();

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetBoolean

[To be supplied.]

[Visual Basic]
Overridable Public Function GetBoolean( _
   ByVal i As Integer _
) As Boolean
[C#]
public virtual bool GetBoolean(
   int i
);
[C++]
public: virtual bool GetBoolean(
   int i
);
[JScript]
public function GetBoolean(
   i : int
) : Boolean;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetByte

[To be supplied.]

[Visual Basic]
Overridable Public Function GetByte( _
   ByVal i As Integer _
) As Byte
[C#]
public virtual byte GetByte(
   int i
);
[C++]
public: virtual unsigned char GetByte(
   int i
);
[JScript]
public function GetByte(
   i : int
) : Byte;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetBytes

[To be supplied.]

[Visual Basic]
Overridable Public Function GetBytes( _
   ByVal i As Integer, _
   ByVal buffer() As Byte, _
   ByVal length As Integer, _
   ByVal bufferIndex As Integer, _
   ByVal dataIndex As Integer _
) As Integer
[C#]
public virtual int GetBytes(
   int i,
   byte[] buffer,
   int length,
   int bufferIndex,
   int dataIndex
);
[C++]
public: virtual int GetBytes(
   int i,
   unsigned char* buffer[],
   int length,
   int bufferIndex,
   int dataIndex
);
[JScript]
public function GetBytes(
   i : int,
   buffer : Byte[],
   length : int,
   bufferIndex : int,
   dataIndex : int
) : int;

Parameters

i
[To be supplied.]
buffer
[To be supplied.]
length
[To be supplied.]
bufferIndex
[To be supplied.]
dataIndex
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetChar

[To be supplied.]

[Visual Basic]
Overridable Public Function GetChar( _
   ByVal i As Integer _
) As Char
[C#]
public virtual char GetChar(
   int i
);
[C++]
public: virtual __wchar_t GetChar(
   int i
);
[JScript]
public function GetChar(
   i : int
) : Char;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetChars

[To be supplied.]

[Visual Basic]
Overridable Public Function GetChars( _
   ByVal i As Integer, _
   ByVal buffer() As Char, _
   ByVal length As Integer, _
   ByVal bufferIndex As Integer, _
   ByVal dataIndex As Integer _
) As Integer
[C#]
public virtual int GetChars(
   int i,
   char[] buffer,
   int length,
   int bufferIndex,
   int dataIndex
);
[C++]
public: virtual int GetChars(
   int i,
   __wchar_t* buffer[],
   int length,
   int bufferIndex,
   int dataIndex
);
[JScript]
public function GetChars(
   i : int,
   buffer : Char[],
   length : int,
   bufferIndex : int,
   dataIndex : int
) : int;

Parameters

i
[To be supplied.]
buffer
[To be supplied.]
length
[To be supplied.]
bufferIndex
[To be supplied.]
dataIndex
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetCurrency

[To be supplied.]

[Visual Basic]
Overridable Public Function GetCurrency( _
   ByVal i As Integer _
) As Currency
[C#]
public virtual Currency GetCurrency(
   int i
);
[C++]
public: virtual Currency GetCurrency(
   int i
);
[JScript]
public function GetCurrency(
   i : int
) : Currency;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetData

[To be supplied.]

[Visual Basic]
Overridable Public Function GetData( _
   ByVal i As Integer _
) As IDataReader
[C#]
public virtual IDataReader GetData(
   int i
);
[C++]
public: virtual IDataReader* GetData(
   int i
);
[JScript]
public function GetData(
   i : int
) : IDataReader;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetDataTypeName

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDataTypeName( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetDataTypeName(
   int i
);
[C++]
public: virtual String* GetDataTypeName(
   int i
);
[JScript]
public function GetDataTypeName(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetDataTypeNamespace

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDataTypeNamespace( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetDataTypeNamespace(
   int i
);
[C++]
public: virtual String* GetDataTypeNamespace(
   int i
);
[JScript]
public function GetDataTypeNamespace(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetDateTime

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDateTime( _
   ByVal i As Integer _
) As DateTime
[C#]
public virtual DateTime GetDateTime(
   int i
);
[C++]
public: virtual DateTime GetDateTime(
   int i
);
[JScript]
public function GetDateTime(
   i : int
) : DateTime;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetDecimal

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDecimal( _
   ByVal i As Integer _
) As Decimal
[C#]
public virtual Decimal GetDecimal(
   int i
);
[C++]
public: virtual Decimal GetDecimal(
   int i
);
[JScript]
public function GetDecimal(
   i : int
) : Decimal;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetDouble

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDouble( _
   ByVal i As Integer _
) As Double
[C#]
public virtual double GetDouble(
   int i
);
[C++]
public: virtual double GetDouble(
   int i
);
[JScript]
public function GetDouble(
   i : int
) : double;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetFieldType

[To be supplied.]

[Visual Basic]
Overridable Public Function GetFieldType( _
   ByVal i As Integer _
) As Type
[C#]
public virtual Type GetFieldType(
   int i
);
[C++]
public: virtual Type* GetFieldType(
   int i
);
[JScript]
public function GetFieldType(
   i : int
) : Type;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetFloat

[To be supplied.]

[Visual Basic]
Overridable Public Function GetFloat( _
   ByVal i As Integer _
) As Single
[C#]
public virtual float GetFloat(
   int i
);
[C++]
public: virtual float GetFloat(
   int i
);
[JScript]
public function GetFloat(
   i : int
) : float;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetInt16

[To be supplied.]

[Visual Basic]
Overridable Public Function GetInt16( _
   ByVal i As Integer _
) As Short
[C#]
public virtual short GetInt16(
   int i
);
[C++]
public: virtual short GetInt16(
   int i
);
[JScript]
public function GetInt16(
   i : int
) : Int16;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetInt32

[To be supplied.]

[Visual Basic]
Overridable Public Function GetInt32( _
   ByVal i As Integer _
) As Integer
[C#]
public virtual int GetInt32(
   int i
);
[C++]
public: virtual int GetInt32(
   int i
);
[JScript]
public function GetInt32(
   i : int
) : int;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetInt64

[To be supplied.]

[Visual Basic]
Overridable Public Function GetInt64( _
   ByVal i As Integer _
) As Long
[C#]
public virtual long GetInt64(
   int i
);
[C++]
public: virtual __int64 GetInt64(
   int i
);
[JScript]
public function GetInt64(
   i : int
) : long;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetName

[To be supplied.]

[Visual Basic]
Overridable Public Function GetName( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetName(
   int i
);
[C++]
public: virtual String* GetName(
   int i
);
[JScript]
public function GetName(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetNamespace

[To be supplied.]

[Visual Basic]
Overridable Public Function GetNamespace( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetNamespace(
   int i
);
[C++]
public: virtual String* GetNamespace(
   int i
);
[JScript]
public function GetNamespace(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetOrdinal

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function GetOrdinal(String, String) As Integer
[C#] public virtual int GetOrdinal(String, String);
[C++] public: virtual int GetOrdinal(String*, String*);
[JScript] public function GetOrdinal(String, String) : int;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function GetOrdinal(String) As Integer
[C#] public virtual int GetOrdinal(String);
[C++] public: virtual int GetOrdinal(String*);
[JScript] public function GetOrdinal(String) : int;

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetOrdinal (String, String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function GetOrdinal( _
   ByVal name As String, _
   ByVal namespaceURI As String _
) As Integer
[C#]
public virtual int GetOrdinal(
   string name,
   string namespaceURI
);
[C++]
public: virtual int GetOrdinal(
   String* name,
   String* namespaceURI
);
[JScript]
public function GetOrdinal(
   name : String,
   namespaceURI : String
) : int;

Parameters

name
[To be supplied.]
namespaceURI
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace | SQLDataReader.GetOrdinal Overload List


SQLDataReader.GetOrdinal (String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function GetOrdinal( _
   ByVal name As String _
) As Integer
[C#]
public virtual int GetOrdinal(
   string name
);
[C++]
public: virtual int GetOrdinal(
   String* name
);
[JScript]
public function GetOrdinal(
   name : String
) : int;

Parameters

name
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace | SQLDataReader.GetOrdinal Overload List


SQLDataReader.GetPrefix

[To be supplied.]

[Visual Basic]
Overridable Public Function GetPrefix( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetPrefix(
   int i
);
[C++]
public: virtual String* GetPrefix(
   int i
);
[JScript]
public function GetPrefix(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetRaw

[To be supplied.]

[Visual Basic]
Overridable Public Function GetRaw( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetRaw(
   int i
);
[C++]
public: virtual String* GetRaw(
   int i
);
[JScript]
public function GetRaw(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetSQLBit

[To be supplied.]

[Visual Basic]
Overridable Public Function GetSQLBit( _
   ByVal i As Integer _
) As SQLBit
[C#]
public virtual SQLBit GetSQLBit(
   int i
);
[C++]
public: virtual SQLBit GetSQLBit(
   int i
);
[JScript]
public function GetSQLBit(
   i : int
) : SQLBit;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetSQLByte

[To be supplied.]

[Visual Basic]
Overridable Public Function GetSQLByte( _
   ByVal i As Integer _
) As SQLByte
[C#]
public virtual SQLByte GetSQLByte(
   int i
);
[C++]
public: virtual SQLByte GetSQLByte(
   int i
);
[JScript]
public function GetSQLByte(
   i : int
) : SQLByte;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetSQLDateTime

[To be supplied.]

[Visual Basic]
Overridable Public Function GetSQLDateTime( _
   ByVal i As Integer _
) As SQLDateTime
[C#]
public virtual SQLDateTime GetSQLDateTime(
   int i
);
[C++]
public: virtual SQLDateTime GetSQLDateTime(
   int i
);
[JScript]
public function GetSQLDateTime(
   i : int
) : SQLDateTime;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetSQLDouble

[To be supplied.]

[Visual Basic]
Overridable Public Function GetSQLDouble( _
   ByVal i As Integer _
) As SQLDouble
[C#]
public virtual SQLDouble GetSQLDouble(
   int i
);
[C++]
public: virtual SQLDouble GetSQLDouble(
   int i
);
[JScript]
public function GetSQLDouble(
   i : int
) : SQLDouble;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetSQLGuid

[To be supplied.]

[Visual Basic]
Overridable Public Function GetSQLGuid( _
   ByVal i As Integer _
) As SQLGuid
[C#]
public virtual SQLGuid GetSQLGuid(
   int i
);
[C++]
public: virtual SQLGuid GetSQLGuid(
   int i
);
[JScript]
public function GetSQLGuid(
   i : int
) : SQLGuid;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetSQLInt16

[To be supplied.]

[Visual Basic]
Overridable Public Function GetSQLInt16( _
   ByVal i As Integer _
) As SQLInt16
[C#]
public virtual SQLInt16 GetSQLInt16(
   int i
);
[C++]
public: virtual SQLInt16 GetSQLInt16(
   int i
);
[JScript]
public function GetSQLInt16(
   i : int
) : SQLInt16;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetSQLInt32

[To be supplied.]

[Visual Basic]
Overridable Public Function GetSQLInt32( _
   ByVal i As Integer _
) As SQLInt32
[C#]
public virtual SQLInt32 GetSQLInt32(
   int i
);
[C++]
public: virtual SQLInt32 GetSQLInt32(
   int i
);
[JScript]
public function GetSQLInt32(
   i : int
) : SQLInt32;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetSQLInt64

[To be supplied.]

[Visual Basic]
Overridable Public Function GetSQLInt64( _
   ByVal i As Integer _
) As SQLInt64
[C#]
public virtual SQLInt64 GetSQLInt64(
   int i
);
[C++]
public: virtual SQLInt64 GetSQLInt64(
   int i
);
[JScript]
public function GetSQLInt64(
   i : int
) : SQLInt64;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetSQLMoney

[To be supplied.]

[Visual Basic]
Overridable Public Function GetSQLMoney( _
   ByVal i As Integer _
) As SQLMoney
[C#]
public virtual SQLMoney GetSQLMoney(
   int i
);
[C++]
public: virtual SQLMoney GetSQLMoney(
   int i
);
[JScript]
public function GetSQLMoney(
   i : int
) : SQLMoney;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetSQLNumeric

[To be supplied.]

[Visual Basic]
Overridable Public Function GetSQLNumeric( _
   ByVal i As Integer _
) As SQLNumeric
[C#]
public virtual SQLNumeric GetSQLNumeric(
   int i
);
[C++]
public: virtual SQLNumeric GetSQLNumeric(
   int i
);
[JScript]
public function GetSQLNumeric(
   i : int
) : SQLNumeric;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetSQLSingle

[To be supplied.]

[Visual Basic]
Overridable Public Function GetSQLSingle( _
   ByVal i As Integer _
) As SQLSingle
[C#]
public virtual SQLSingle GetSQLSingle(
   int i
);
[C++]
public: virtual SQLSingle GetSQLSingle(
   int i
);
[JScript]
public function GetSQLSingle(
   i : int
) : SQLSingle;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetSQLString

[To be supplied.]

[Visual Basic]
Overridable Public Function GetSQLString( _
   ByVal i As Integer _
) As SQLString
[C#]
public virtual SQLString GetSQLString(
   int i
);
[C++]
public: virtual SQLString* GetSQLString(
   int i
);
[JScript]
public function GetSQLString(
   i : int
) : SQLString;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetSQLVariant

[To be supplied.]

[Visual Basic]
Overridable Public Function GetSQLVariant( _
   ByVal i As Integer _
) As Object
[C#]
public virtual object GetSQLVariant(
   int i
);
[C++]
public: virtual Object* GetSQLVariant(
   int i
);
[JScript]
public function GetSQLVariant(
   i : int
) : Object;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetStream

[To be supplied.]

[Visual Basic]
Overridable Public Function GetStream( _
   ByVal i As Integer _
) As Stream
[C#]
public virtual Stream GetStream(
   int i
);
[C++]
public: virtual Stream* GetStream(
   int i
);
[JScript]
public function GetStream(
   i : int
) : Stream;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetString

[To be supplied.]

[Visual Basic]
Overridable Public Function GetString( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetString(
   int i
);
[C++]
public: virtual String* GetString(
   int i
);
[JScript]
public function GetString(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetTimeSpan

[To be supplied.]

[Visual Basic]
Overridable Public Function GetTimeSpan( _
   ByVal i As Integer _
) As TimeSpan
[C#]
public virtual TimeSpan GetTimeSpan(
   int i
);
[C++]
public: virtual TimeSpan GetTimeSpan(
   int i
);
[JScript]
public function GetTimeSpan(
   i : int
) : TimeSpan;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetValue

[To be supplied.]

[Visual Basic]
Overridable Public Sub GetValue( _
   ByVal i As Integer, _
   ByRef value As Object _
)
[C#]
public virtual void GetValue(
   int i,
   ref object value
);
[C++]
public: virtual void GetValue(
   int i,
   Object** value
);
[JScript]
public function GetValue(
   i : int,
   value : Object
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.GetValues

[To be supplied.]

[Visual Basic]
Overridable Public Function GetValues( _
   ByVal values() As Object _
) As Integer
[C#]
public virtual int GetValues(
   object[] values
);
[C++]
public: virtual int GetValues(
   Object* values[]
);
[JScript]
public function GetValues(
   values : Object[]
) : int;

Parameters

values
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.IsNull

[To be supplied.]

[Visual Basic]
Overridable Public Function IsNull( _
   ByVal i As Integer _
) As Boolean
[C#]
public virtual bool IsNull(
   int i
);
[C++]
public: virtual bool IsNull(
   int i
);
[JScript]
public function IsNull(
   i : int
) : Boolean;

Parameters

i
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.Read

[To be supplied.]

[Visual Basic]
Overridable Public Function Read() As Boolean
[C#]
public virtual bool Read();
[C++]
public: virtual bool Read();
[JScript]
public function Read() : Boolean;

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataReader.SetRowBuffer

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetRowBuffer( _
   ByVal dataValues() As Object, _
   ByVal indexMap() As Integer _
)
[C#]
public virtual void SetRowBuffer(
   object[] dataValues,
   int[] indexMap
);
[C++]
public: virtual void SetRowBuffer(
   Object* dataValues[],
   int* indexMap[]
);
[JScript]
public function SetRowBuffer(
   dataValues : Object[],
   indexMap : int[]
);

Parameters

dataValues
[To be supplied.]
indexMap
[To be supplied.]

See Also

SQLDataReader Class | SQLDataReader Members | System.Data.SQL Namespace


SQLDataSetCommand Class

Represents a set of data commands and a database connection which are used to fill the DataSet and update the data source. At any time, the object refers to only a single record within the current data set.

Object
Component
DataSetCommand
DBDataSetCommand
SQLDataSetCommand

[Visual Basic]
Public Class SQLDataSetCommand
   Inherits DBDataSetCommand
[C#]
public class SQLDataSetCommand : DBDataSetCommand
[C++]
public __gc class SQLDataSetCommand : public DBDataSetCommand
[JScript]
public class SQLDataSetCommand extends DBDataSetCommand

Remarks

In the past, data processing has been primarily connection-based. Now, in an effort to make multi-tiered applications more efficient, data processing is turning to a message-based approach that revolves around chunks of information. At the center of this approach is the SQLDataSetCommand, which provides a bridge to retrieve and save data between a SQLDataSetCommand and its source data store. The SQLDataSetCommand provides this bridge by mapping FillDataSet, which changes the data in the DataSet to match the data in the data source, and Update, which changes the data in the data source to match the data in the DataSet, requests to the appropriate SQL commands against the data store.

SQLDataSetCommand is used in conjunction with SQLConnection and SQLCommand to increase performance when connecting to a Micrsoft SQL Server database. For all third party SQL server products, as well as other OLEDB-supported databases, it is probably better that you use DataSetCommand along with its associated DBCommand and ADOConnection.

Useful properties include: SelectCommand, InsertCommand, DeleteCommand, UpdateCommand, and TableMappings.

When an instance of SQLDataSetCommand is created, the read/write properties are set to initial values. For a list of these values, see the SQLDataSetCommand constructor.

Requirements

Namespace: System.Data.SQL

Assembly: System.Data.dll

Example [C#]

The following example selects records from an Access data source. The DataSet then uses SQLDataSetCommand, along with SQLCommand and SQLConnection, to insert new records in a SQL Server data source. This example can be modified to migrate an Access database to a SQL Server database.

[C#]

private DataSet InitializeMyDataSet() {
   // creates the table and its columns for the DataSet
   DataSet newData = new DataSet();
   DataTable newTable = newData.Tables.Add("Catagories");

   // add Columns to table
   newTable.Columns.Add("CategoryID",typeof(Int32));
   newTable.Columns.Add("CategoryName", typeof(String));
   newTable.Columns.Add("Description", typeof(String));
   newTable.Columns.Add("Picture",typeof(Byte[]));
   return newData;
}

public void AccessToSQLServer() {
   // set Access connection and select strings
   const string strAccessConn = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=NWIND_RW.MDB";
   const string strAccessSelect = "SELECT * FROM Categories ORDER BY CategoryID";
   // set SQL Server connection and insert strings
   const string strSQLServerConn = "Data Source=VBsql7;Initial Catalog=Northwind;User ID=sa;Password=;";
   const string strSQLServerInsert = "INSERT INTO Categories(CategoryName, Description, Picture) Values(@CategoryName,@Description,@Picture)";
   // create my DataSet
   DataSet myDataSet = InitializeMyDataSet();
   // create my Access objects
   ADOConnection myAccessConn = new ADOConnection(strAccessConn);
   ADODataSetCommand myAccessDataSetCmd = new ADODataSetCommand();
   myAccessDataSetCmd.SelectCommand = new ADOCommand(strAccessSelect,myAccessConn);
   // create my SQL Server objects
   SQLConnection mySQLConn = new SQLConnection(strSQLServerConn);
   SQLDataSetCommand mySQLDataSetCmd = new SQLDataSetCommand();
   mySQLDataSetCmd.InsertCommand = new SQLCommand(strSQLServerInsert,mySQLConn);
   // fill myDataSet with data from Access
   myAccessConn.Open();
   try {
      myAccessDataSetCmd.FillDataSet(myDataSet,"table");
   }
   finally {
      myAccessConn.Close();
   }

   // update SQL Server with data from the DataSet
   mySQLConn.Open();
   try {
      mySQLDataSetCmd.InsertCommand.Parameters.Add("CategoryName", typeof(String));
      mySQLDataSetCmd.InsertCommand.Parameters.Add("Description", typeof(String));
      mySQLDataSetCmd.InsertCommand.Parameters.Add("Picture", typeof(Byte[]));
      mySQLDataSetCmd.InsertCommand.Parameters[0].SourceColumn = "CategoryName";
      mySQLDataSetCmd.InsertCommand.Parameters[1].SourceColumn = "Description";
      mySQLDataSetCmd.InsertCommand.Parameters[2].SourceColumn = "Picture";
      mySQLDataSetCmd.Update(myDataSet,"table");
   }
   finally {
      mySQLConn.Close();
   }
}

See Also

SQLDataSetCommand Members | System.Data.SQL Namespace | SQLConnection | SQLCommand | DataSet | DataTable


SQLDataSetCommand Members

Public:

Constructor

SQLDataSetCommand Constructor Overloaded. Initializes a new instance of the SQLDataSetCommand class.

Properties

DeleteCommand | Gets or sets a command to delete records from the data set.
InsertCommand | Gets or sets a command to insert new records into the data source.
MissingMappingAction (inherited from DataSetCommand) | Gets or sets whether unmapped source tables or columns are to be passed with their source names to be filtered, or to cause an error to be raised.
MissingSchemaAction (inherited from DataSetCommand) | Gets or sets whether missing source tables, columns, and their relationships are to be added to the data set schema, to be ignored, or to cause an error to be raised.
SelectCommand | Gets or sets a command used to select records in the data source.
Site (inherited from Component) | Gets or sets the site of the Component.
TableMappings (inherited from DataSetCommand) | Gets how a source table is to be mapped to a data set table.
UpdateCommand | Gets or sets a command used to update records in the data source.

Methods

Clone (inherited from DBDataSetCommand) | Creates a new instance of this ADODataSetCommand object.
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FillDataSet (inherited from DBDataSetCommand) | Overloaded. Fills the data set with records and schema.
FillDataSetSchema (inherited from DBDataSetCommand) | Overloaded. Fills the data set with the schema.
GenerateUpdateCommands (inherited from DBDataSetCommand) | Generates the insert, update, or delete commands when each is in a default state.
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetFillDataSetParameters (inherited from DBDataSetCommand) | Returns all parameters used when performing the select command.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
Update (inherited from DBDataSetCommand) | Overloaded. Calls the respective insert, update, or delete commands on the connection, for each inserted, updated, or deleted rows in the data set.

Events

RowUpdated | Occurs during Update after a command is executed against the data source. The attempt to update is made, so the event fires.
RowUpdating | Occurs during Update before a command is executed against the data source. The attempt to update is made, so the event fires.
SchemaChanged (inherited from DataSetCommand) | Occurs during Update after a command is executed against the data source when the schema may be potentially different due to a property change.
SchemaChanging (inherited from DataSetCommand) | Occurs during Update before a command is executed against the data source when the schema may be potentially different due to a property change.
SchemaMapping | Occurs after the schema is mapped from the data source to the data set but before the tables and columns are added to the data set.

Protected:

Methods

CanGenerateUpdateCommands (inherited from DBDataSetCommand) | [To be supplied.]
CreateNewConnection | Creates a new connection to a data source.
CreateNewDeleteCommand | Creates a new command used during Update when deleting records in a data source for deleted rows in the data set.
CreateNewInsertCommand | Creates a new command used during Update when inserting records in a data source as new rows in the data set.
CreateNewRowUpdatedEvent | [To be supplied.]
CreateNewRowUpdatingEvent | [To be supplied.]
CreateNewSchemaChangedEvent (inherited from DataSetCommand) | [To be supplied.]
CreateNewSchemaChangingEvent (inherited from DataSetCommand) | [To be supplied.]
CreateNewSchemaMappingEvent | [To be supplied.]
CreateNewSelectCommand | Creates a new command used during Update to select records from a data source for inclusion into the data set.
CreateNewTableMappings (inherited from DataSetCommand) | [To be supplied.]
CreateNewUpdateCommand | Creates a new command used during Update when updating records in a data source for modified rows in the data set.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
FixupDataCommand | [To be supplied.]
ForceGenerateUpdateCommand | [To be supplied.]
GetDeleteCommandObject (inherited from DBDataSetCommand) | [To be supplied.]
GetInsertCommandObject (inherited from DBDataSetCommand) | [To be supplied.]
GetSelectCommandObject (inherited from DBDataSetCommand) | [To be supplied.]
GetUpdateCommandObject (inherited from DBDataSetCommand) | [To be supplied.]
IsValidDataCommand | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnRowUpdated | Overloaded. [To be supplied.]
OnRowUpdating | Overloaded. [To be supplied.]
OnSchemaChanged (inherited from DataSetCommand) | Raises the OnSchemaChanged event.
OnSchemaChanging (inherited from DataSetCommand) | Raises the OnSchemaChanged event.
OnSchemaMapping | Overloaded. [To be supplied.]
ParameterOutput (inherited from DBDataSetCommand) | [To be supplied.]
SetDeleteCommandObject (inherited from DBDataSetCommand) | [To be supplied.]
SetInsertCommandObject (inherited from DBDataSetCommand) | [To be supplied.]
SetSelectCommandObject (inherited from DBDataSetCommand) | [To be supplied.]
SetUpdateCommandObject (inherited from DBDataSetCommand) | [To be supplied.]

Fields

commands (inherited from DBDataSetCommand) [To be supplied.]

Event Hookup:

Methods

AddOnRowUpdated | [To be supplied.]
AddOnRowUpdating | [To be supplied.]
AddOnSchemaChanged (inherited from DataSetCommand) | [To be supplied.]
AddOnSchemaChanging (inherited from DataSetCommand) | [To be supplied.]
AddOnSchemaMapping | [To be supplied.]
RemoveOnRowUpdated | [To be supplied.]
RemoveOnRowUpdating | [To be supplied.]
RemoveOnSchemaChanged (inherited from DataSetCommand) | [To be supplied.]
RemoveOnSchemaChanging (inherited from DataSetCommand) | [To be supplied.]
RemoveOnSchemaMapping | [To be supplied.]

See Also

SQLDataSetCommand Class | System.Data.SQL Namespace


SQLDataSetCommand Constructor

Initializes a new instance of the SQLDataSetCommand class.

Overload List

Initializes a new instance of the SQLDataSetCommand class. This is the default constructor.

[Visual Basic] Overloads Public Sub New()
[C#] public SQLDataSetCommand();
[C++] public: SQLDataSetCommand();
[JScript] public function SQLDataSetCommand();

Initializes a new instance of the SQLDataSetCommand class with the specified select command.

[Visual Basic] Overloads Public Sub New(SQLCommand)
[C#] public SQLDataSetCommand(SQLCommand);
[C++] public: SQLDataSetCommand(SQLCommand*);
[JScript] public function SQLDataSetCommand(SQLCommand);

Initializes a new instance of the SQLDataSetCommand class with a select command string and a connection string.

[Visual Basic] Overloads Public Sub New(String, String)
[C#] public SQLDataSetCommand(String, String);
[C++] public: SQLDataSetCommand(String*, String*);
[JScript] public function SQLDataSetCommand(String, String);

Inintializes a new instance of the SQLDataSetCommand class with a select command string and a SQLConnection object.

[Visual Basic] Overloads Public Sub New(String, SQLConnection)
[C#] public SQLDataSetCommand(String, SQLConnection);
[C++] public: SQLDataSetCommand(String*, SQLConnection);
[JScript] public function SQLDataSetCommand(String, SQLConnection);

Example [Visual Basic]

The following example creates a SQLDataSetCommand with a select command string and a SQLConnection as parameters.

Note This example shows how to use one of the overloaded version of the SQLDataSetCommand constructor. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Sub CreateDataSetCommand ()
   Dim sqlDataSetComm As SQLDataSetCommand
   Dim mySelectComm As String
   Dim myConnection As String
   Dim mySQLConnect As SQLConnection
   ' Set myConnection to the connection text
   myConnection = "Provider=SQLSQL.1;User ID=sa;PASSWORD=;" _
    + "Initial Catalog=Northwind;Data Source=vbsql7;"
   ' Set mySelectComm to the select command text
   mySelectComm = "SELECT intID, vchFirstName, vchLastName " _
    + "FROM Customers"
   ' Initialize mySQLConnect as a new object
   mySQLConnect = New SQLConnection myConnection
   ' Initialize sqlDataSetComm as a new object
   sqlDataSetComm = new SQLDataSetObject mySelectComm, mySQLConnect
   ' Set the action to take when a table or column is missing
   sqlDataSetComm.MissingSchemaAction = MissingSchemaAction.Add
End Sub

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace


SQLDataSetCommand Constructor ()

Initializes a new instance of the SQLDataSetCommand class. This is the default constructor.

[Visual Basic]
Overloads Public Sub New()
[C#]
public SQLDataSetCommand();
[C++]
public: SQLDataSetCommand();
[JScript]
public function SQLDataSetCommand();

Remarks

When an instance of SQLDataSetCommand is created, the following read/write properties are set to initial values.

Properties | Initial Value
SelectCommand | A new SQLCommand.
InsertCommand | A new SQLCommand.
DeleteCommand | A new SQLCommand.
UpdateCommand | A new SQLCommand.
MissingMappingAction | MissingMappingAction.Passthrough
MissingSchemaAction | MissingSchemaAction.Add

You can change the value of any of these properties through a separate call to the property.

Example [Visual Basic]

The following example creates a SQLDataSetCommand.

[Visual Basic]

Sub CreateDataSetCommand ()
    Dim sqlDataSetComm As SQLDataSetCommand
    Dim myInsertComm As String
    Dim mySelectComm As String
    ' Initialize sqlDataSetComm as a new object
    sqlDataSetComm = New SQLDataSetCommand
    ' Set mySelectComm to the text of the select command
    mySelectComm = "SELECT intID, vchFirstName, vchLastName " _
     + "FROM Customers"
    ' Set the sqlDataSetComm Select Command text
    sqlDataSetComm.SelectCommand.CommandText = mySelectComm
    ' Set myInsertComm to the text of the insert command
    myInsertComm = "INSERT INTO tblCustomer (vchFirstName, " _
     + "vchLastName) VALUES (?, ?)"
    ' Set the sqlDataSetComm Insert Command text
    sqlDataSetComm.InsertCommand.CommandText = myInsertComm
    ' Set the action to take when a table or column is missing
    sqlDataSetComm.MissingSchemaAction = MissingSchemaAction.Add
End Sub

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace | SQLDataSetCommand Constructor Overload List | MissingMappingAction | MissingSchemaAction


SQLDataSetCommand Constructor (SQLCommand)

Initializes a new instance of the SQLDataSetCommand class with the specified select command.

[Visual Basic]
Overloads Public Sub New( _
   ByVal selectCommand As SQLCommand _
)
[C#]
public SQLDataSetCommand(
   SQLCommand selectCommand
);
[C++]
public: SQLDataSetCommand(
   SQLCommand* selectCommand
);
[JScript]
public function SQLDataSetCommand(
   selectCommand : SQLCommand
);

Parameters

selectCommand
An SQLCommand that is a select command.

Remarks

When an instance of SQLDataSetCommand is created, the following read/write properties are set to initial values.

Properties | Initial Value
SelectCommand | A new SQLCommand that is a copy of selectCommand.
InsertCommand | A new SQLCommand.
DeleteCommand | A new SQLCommand.
UpdateCommand | A new SQLCommand.
MissingMappingAction | MissingMappingAction.Passthrough
MissingSchemaAction | MissingSchemaAction.Add

You can change the value of any of these properties through a separate call to the property.

Example [Visual Basic]

The following example creates a SQLDataSetCommand with an SQLCommand that is a select command as a parameter.

[Visual Basic]

Sub CreateDataSetCommand ()
    Dim sqlDataSetComm As SQLDataSetCommand
    Dim myConnection As String
    Dim mySelectComm As String
    Dim mySQLSelect As SQLCommand
    ' Set myConnection to the connection string text
    myConnection = "Provider=SQLSQL.1;User ID=sa;PASSWORD=;" _
     + "Initial Catalog=Northwind;Data Source=vbsql7;"
    ' Set mySelectComm to the text of the select command
    mySelectComm = "SELECT intID, vchFirstName, vchLastName " _
     + "FROM Customers"
    ' Initialize mySQLSelect command as a new object
    mySQLSelect = New SQLCommand mySelectComm myConnection
    ' Initialize sqlDataSetComm as a new object
    sqlDataSetComm = New SQLDataSetCommand mySQLSelect
End Sub

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace | SQLDataSetCommand Constructor Overload List | MissingMappingAction | MissingSchemaAction


SQLDataSetCommand Constructor (String, String)

Initializes a new instance of the SQLDataSetCommand class with a select command string and a connection string.

[Visual Basic]
Overloads Public Sub New( _
   ByVal selectCommandText As String, _
   ByVal selectConnectionString As String _
)
[C#]
public SQLDataSetCommand(
   string selectCommandText,
   string selectConnectionString
);
[C++]
public: SQLDataSetCommand(
   String* selectCommandText,
   String* selectConnectionString
);
[JScript]
public function SQLDataSetCommand(
   selectCommandText : String,
   selectConnectionString : String
);

Parameters

selectCommandText
The select command string.
selectConnectionString
The connection string.

Remarks

When an instance of SQLDataSetCommand is created, the following read/write properties are set to initial values.

Properties | Initial Value
SelectCommand | A new SQLCommand that has selectConnectionString as its connection text and selectCommandText as its command text.
InsertCommand | A new SQLCommand that has selectConnectionString as its connection text.
DeleteCommand | A new SQLCommand that has selectConnectionString as its connection text.
UpdateCommand | A new SQLCommand that has selectConnectionString as its connection text.
MissingMappingAction | MissingMappingAction.Passthrough
MissingSchemaAction | MissingSchemaAction.Add

You can change the value of any of these properties through a separate call to the property.

Example [Visual Basic]

The following example creates a SQLDataSetCommand with a select command string and a connection string as parameters.

[Visual Basic]

Sub CreateDataSetCommand ()
    Dim sqlDataSetComm As SQLDataSetCommand
    Dim mySelectComm As String
    Dim myConnection As String
    ' Set myConnection to the connection text
    myConnection = "Provider=SQLSQL.1;User ID=sa;PASSWORD=;" _
     + "Initial Catalog=Northwind;Data Source=vbsql7;"
    ' Set mySelectComm to the select command text
    mySelectComm = "SELECT intID, vchFirstName, vchLastName " _
     + "FROM Customers"
    ' Initialize sqlDataSetComm as a new object
    sqlDataSetComm = new SQLDataSetObject mySelectComm, myConnection
End Sub

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace | SQLDataSetCommand Constructor Overload List | MissingMappingAction | MissingSchemaAction


SQLDataSetCommand Constructor (String, SQLConnection)

Inintializes a new instance of the SQLDataSetCommand class with a select command string and a SQLConnection object.

[Visual Basic]
Overloads Public Sub New( _
   ByVal selectCommandText As String, _
   ByVal selectConnection As SQLConnection _
)
[C#]
public SQLDataSetCommand(
   string selectCommandText,
   SQLConnection selectConnection
);
[C++]
public: SQLDataSetCommand(
   String* selectCommandText,
   SQLConnection* selectConnection
);
[JScript]
public function SQLDataSetCommand(
   selectCommandText : String,
   selectConnection : SQLConnection
);

Parameters

selectCommandText
The select command string.
selectConnection
An SQLConnection that represents the connection.

Remarks

When an instance of SQLDataSetCommand is created, the following read/write properties are set to initial values.

Properties | Initial Value
SelectCommand | A new SQLCommand that has selectConnection as its connection and selectCommandText as its command text.
InsertCommand | A new SQLCommand that has selectConnection as its connection.
DeleteCommand | A new SQLCommand that has selectConnection as its connection.
UpdateCommand | A new SQLCommand that has selectConnection as its connection.
MissingMappingAction | MissingMappingAction.Passthrough
MissingSchemaAction | MissingSchemaAction.Add

You can change the value of any of these properties through a separate call to the property.

Example [Visual Basic]

The following example creates a SQLDataSetCommand with a select command string and a SQLConnection as parameters.

[Visual Basic]

Sub CreateDataSetCommand ()
   Dim sqlDataSetComm As SQLDataSetCommand
   Dim mySelectComm As String
   Dim myConnection As String
   Dim mySQLConnect As SQLConnection
   ' Set myConnection to the connection text
   myConnection = "Provider=SQLSQL.1;User ID=sa;PASSWORD=;" _
    + "Initial Catalog=Northwind;Data Source=vbsql7;"
   ' Set mySelectComm to the select command text
   mySelectComm = "SELECT intID, vchFirstName, vchLastName " _
    + "FROM Customers"
   ' Initialize mySQLConnect as a new object
   mySQLConnect = New SQLConnection myConnection
   ' Initialize sqlDataSetComm as a new object
   sqlDataSetComm = new SQLDataSetObject mySelectComm, mySQLConnect
   ' Set the action to take when a table or column is missing
   sqlDataSetComm.MissingSchemaAction = MissingSchemaAction.Add
End Sub

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace | SQLDataSetCommand Constructor Overload List | MissingMappingAction | MissingSchemaAction


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLDataSetCommand Properties

The properties of the SQLDataSetCommand class are listed below. For a complete list of SQLDataSetCommand class members, see the SQLDataSetCommand Members topic.

Public:

DeleteCommand | Gets or sets a command to delete records from the data set.
InsertCommand | Gets or sets a command to insert new records into the data source.
MissingMappingAction (inherited from DataSetCommand) | Gets or sets whether unmapped source tables or columns are to be passed with their source names to be filtered, or to cause an error to be raised.
MissingSchemaAction (inherited from DataSetCommand) | Gets or sets whether missing source tables, columns, and their relationships are to be added to the data set schema, to be ignored, or to cause an error to be raised.
SelectCommand | Gets or sets a command used to select records in the data source.
Site (inherited from Component) | Gets or sets the site of the Component.
TableMappings (inherited from DataSetCommand) | Gets how a source table is to be mapped to a data set table.
UpdateCommand | Gets or sets a command used to update records in the data source.

See Also

SQLDataSetCommand Class | System.Data.SQL Namespace


SQLDataSetCommand.DeleteCommand

Gets or sets a command to delete records from the data set.

[Visual Basic]
Public Property DeleteCommand As SQLCommand
[C#]
public SQLCommand DeleteCommand {get; set;}
[C++]
public: __property SQLCommand* get_DeleteCommand();
public: __property void set_DeleteCommand(SQLCommand*);
[JScript]
public function get DeleteCommand() : SQLCommand;
public function set DeleteCommand(SQLCommand);

Property Value

A SQLCommand used during Update to delete records in the data source of deleted rows in the data set.

Example [Visual Basic]

The following example creates a SQLCommand used to set the DeleteCommand property to be used by the SQLDataSetCommand.

[Visual Basic]

Sub AssignDeleteCommand ()
   Dim myConnection As SQLConnection
   Dim sqlDataSetComm As SQLDataSetCommand
   Dim myConnectStr As String
   Dim myDelComm As String
   ' Initialize the SQLDataSetCommand
   sqlDatSetComm = New SQLDataSetCommand
   ' Assign myConnectStr to the connection string
   myConnectStr = "Provider=SQLSQL.1;User ID=sa;PASSWORD=;" _
    + "Initial Catalog=Northwind;Data Source=vbsql7;"
   ' Initialize the SQLConnection
   myConnection = New SQLConnection myConnectStr
   ' Assign myDelComm to the text of my delete command
   myDelComm = "DELETE FROM tblCustomer WHERE intID = ?"
   ' Assign the DeleteCommand to myDelComm
   sqlDataSetComm.DeleteCommand.CommandText = myDelComm
   ' Set the command's connection to the current connection
   Set sqlDataSetComm.DeleteCommand.ActiveConnection = myConnection
End Sub

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace | InsertCommand | SelectCommand | UpdateCommand


SQLDataSetCommand.InsertCommand

Gets or sets a command to insert new records into the data source.

[Visual Basic]
Public Property InsertCommand As SQLCommand
[C#]
public SQLCommand InsertCommand {get; set;}
[C++]
public: __property SQLCommand* get_InsertCommand();
public: __property void set_InsertCommand(SQLCommand*);
[JScript]
public function get InsertCommand() : SQLCommand;
public function set InsertCommand(SQLCommand);

Property Value

A SQLCommand used during Update to insert records into the data source to reflect the new rows in the data set.

Example [Visual Basic]

The following example creates a SQLCommand used to set the InsertCommand property to be used by the SQLDataSetCommand.

[Visual Basic]

Sub AssignInsertCommand ()
   Dim myConnection As SQLConnection
   Dim sqlDataSetComm As SQLDataSetCommand
   Dim myConnectStr As String
   Dim myInsComm As String
   ' Initialize the SQLDatSetCommand
   sqlDataSetComm = New SQLDataSetCommand
   ' Assign myConnectStr to the connection string
   myConnectStr = "Provider=SQLSQL.1;User ID=sa;PASSWORD=;" _
    + "Initial Catalog=Northwind;Data Source=vbsql7;"
   ' Initialize the SQLConnection
   myConnection = New SQLConnection myConnectStr
   ' Assign myInsComm to the text of my insert command
   myInsComm = "INSERT INTO tblCustomer (vchFirstName, " _
 + "vchLastName, chState) VALUES (?, ?, ?)"
   ' Assign the InsertCommand to myInsComm
   sqlDataSetComm.InsertCommand.CommandText = myInsComm
   ' Set the command's connection to the current connection
   Set sqlDataSetComm.InsertCommand.ActiveConnection = myConnection
End Sub

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace | DeleteCommand | SelectCommand | UpdateCommand


SQLDataSetCommand.SelectCommand

Gets or sets a command used to select records in the data source.

[Visual Basic]
Public Property SelectCommand As SQLCommand
[C#]
public SQLCommand SelectCommand {get; set;}
[C++]
public: __property SQLCommand* get_SelectCommand();
public: __property void set_SelectCommand(SQLCommand*);
[JScript]
public function get SelectCommand() : SQLCommand;
public function set SelectCommand(SQLCommand);

Property Value

An SQLCommand used during Update to select records from the data source to be used by the data set.

Example [Visual Basic]

The following example creates a SQLCommand used to set the SelectCommand property to be used by the SQLDataSetCommand.

[Visual Basic]

Sub AssignSelectCommand ()
   Dim myConnection As SQLConnection
   Dim myConnectStr As String
   Dim mySelectComm As String
   Dim sqlDataSetComm As SQLDataSetCommand
   ' Initialize the SQLDataSetCommand
   sqlDataSetComm = New SQLDataSetCommand
   ' Assign myConnectStr to the connection string
   myConnectStr = "Provider=SQLSQL.1;User ID=sa;PASSWORD=;" _
    + "Initial Catalog=Northwind;Data Source=vbsql7;"
   ' Initialize the SQLConnection
   myConnection = New SQLConnection myConnectStr
   ' Assign mySelectComm to the text of my select command
   mySelectComm = "SELECT intID, vchFirstName, vchLastName, " _
    + "chState FROM Customers WHERE chState = 'CA'"
   ' Assign the DeleteCommand to myDelComm
   sqlDataSetComm.SelectCommand.CommandText = mySelectComm
   ' Set the command's connection to the current connection
   Set sqlDataSetComm.SelectCommand.ActiveConnection = myConnection
End Sub

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace | DeleteCommand | InsertCommand | UpdateCommand


SQLDataSetCommand.UpdateCommand

Gets or sets a command used to update records in the data source.

[Visual Basic]
Public Property UpdateCommand As SQLCommand
[C#]
public SQLCommand UpdateCommand {get; set;}
[C++]
public: __property SQLCommand* get_UpdateCommand();
public: __property void set_UpdateCommand(SQLCommand*);
[JScript]
public function get UpdateCommand() : SQLCommand;
public function set UpdateCommand(SQLCommand);

Property Value

An SQLCommand used during Update to update records in the data source to reflect modified rows in the data set.

Example [Visual Basic]

The following example creates a SQLCommand used to set the UpdateCommand property to be used by the SQLDataSetCommand.

[Visual Basic]

Sub AssignUpdateCommand ()
   Dim myConnection As SQLConnection
   Dim myConnectStr As String
   Dim myUpdateComm As String
   Dim sqlDataSetComm As SQLDataSetCommand
   ' Initialize the SQLDataSetCommand
   sqlDataSetComm = New SQLDataSetCommand
   ' Assign myConnectStr to the connection string
   myConnectStr = "Provider=SQLSQL.1;User ID=sa;PASSWORD=;" _
    + "Initial Catalog=Northwind;Data Source=vbsql7;"
   ' Initialize the SQLConnection
   myConnection = New SQLConnection myConnectStr
   ' Assign myUpdateComm to the text of my update command
   myUpdateComm = "DELETE FROM tblCustomer WHERE intID = ?"
   ' Assign the UpdateCommand to myUpdateComm
   sqlDataSetComm.UpdateCommand.CommandText = myUpdateComm
   ' Set the command's connection to the current connection
   Set sqlDataSetComm.UpdateCommand.ActiveConnection = myConnection
End Sub

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace | DeleteCommand | InsertCommand | SelectCommand


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLDataSetCommand Methods

The methods of the SQLDataSetCommand class are listed below. For a complete list of SQLDataSetCommand class members, see the SQLDataSetCommand Members topic.

Public:

Clone (inherited from DBDataSetCommand) | Creates a new instance of this ADODataSetCommand object.
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FillDataSet (inherited from DBDataSetCommand) | Overloaded. Fills the data set with records and schema.
FillDataSetSchema (inherited from DBDataSetCommand) | Overloaded. Fills the data set with the schema.
GenerateUpdateCommands (inherited from DBDataSetCommand) | Generates the insert, update, or delete commands when each is in a default state.
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetFillDataSetParameters (inherited from DBDataSetCommand) | Returns all parameters used when performing the select command.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
Update (inherited from DBDataSetCommand) | Overloaded. Calls the respective insert, update, or delete commands on the connection, for each inserted, updated, or deleted rows in the data set.

Protected:

CanGenerateUpdateCommands (inherited from DBDataSetCommand) | [To be supplied.]
CreateNewConnection | Creates a new connection to a data source.
CreateNewDeleteCommand | Creates a new command used during Update when deleting records in a data source for deleted rows in the data set.
CreateNewInsertCommand | Creates a new command used during Update when inserting records in a data source as new rows in the data set.
CreateNewRowUpdatedEvent | [To be supplied.]
CreateNewRowUpdatingEvent | [To be supplied.]
CreateNewSchemaChangedEvent (inherited from DataSetCommand) | [To be supplied.]
CreateNewSchemaChangingEvent (inherited from DataSetCommand) | [To be supplied.]
CreateNewSchemaMappingEvent | [To be supplied.]
CreateNewSelectCommand | Creates a new command used during Update to select records from a data source for inclusion into the data set.
CreateNewTableMappings (inherited from DataSetCommand) | [To be supplied.]
CreateNewUpdateCommand | Creates a new command used during Update when updating records in a data source for modified rows in the data set.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
FixupDataCommand | [To be supplied.]
ForceGenerateUpdateCommand | [To be supplied.]
GetDeleteCommandObject (inherited from DBDataSetCommand) | [To be supplied.]
GetInsertCommandObject (inherited from DBDataSetCommand) | [To be supplied.]
GetSelectCommandObject (inherited from DBDataSetCommand) | [To be supplied.]
GetUpdateCommandObject (inherited from DBDataSetCommand) | [To be supplied.]
IsValidDataCommand | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnRowUpdated | Overloaded. [To be supplied.]
OnRowUpdating | Overloaded. [To be supplied.]
OnSchemaChanged (inherited from DataSetCommand) | Raises the OnSchemaChanged event.
OnSchemaChanging (inherited from DataSetCommand) | Raises the OnSchemaChanged event.
OnSchemaMapping | Overloaded. [To be supplied.]
ParameterOutput (inherited from DBDataSetCommand) | [To be supplied.]
SetDeleteCommandObject (inherited from DBDataSetCommand) | [To be supplied.]
SetInsertCommandObject (inherited from DBDataSetCommand) | [To be supplied.]
SetSelectCommandObject (inherited from DBDataSetCommand) | [To be supplied.]
SetUpdateCommandObject (inherited from DBDataSetCommand) | [To be supplied.]

Event Hookup:

AddOnRowUpdated | [To be supplied.]
AddOnRowUpdating | [To be supplied.]
AddOnSchemaChanged (inherited from DataSetCommand) | [To be supplied.]
AddOnSchemaChanging (inherited from DataSetCommand) | [To be supplied.]
AddOnSchemaMapping | [To be supplied.]
RemoveOnRowUpdated | [To be supplied.]
RemoveOnRowUpdating | [To be supplied.]
RemoveOnSchemaChanged (inherited from DataSetCommand) | [To be supplied.]
RemoveOnSchemaChanging (inherited from DataSetCommand) | [To be supplied.]
RemoveOnSchemaMapping | [To be supplied.]

See Also

SQLDataSetCommand Class | System.Data.SQL Namespace


SQLDataSetCommand.AddOnRowUpdated

[To be supplied.]

[Visual Basic]
Overridable Public Sub AddOnRowUpdated( _
   ByVal handler As SQLRowUpdatedEventHandler _
)
[C#]
public virtual void AddOnRowUpdated(
   SQLRowUpdatedEventHandler handler
);
[C++]
public: virtual void AddOnRowUpdated(
   SQLRowUpdatedEventHandler* handler
);
[JScript]
public function AddOnRowUpdated(
   handler : SQLRowUpdatedEventHandler
);

Parameters

handler
A SQLRowUpdatedEventHandler to manage the event.

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace


SQLDataSetCommand.AddOnRowUpdating

[To be supplied.]

[Visual Basic]
Overridable Public Sub AddOnRowUpdating( _
   ByVal handler As SQLRowUpdatingEventHandler _
)
[C#]
public virtual void AddOnRowUpdating(
   SQLRowUpdatingEventHandler handler
);
[C++]
public: virtual void AddOnRowUpdating(
   SQLRowUpdatingEventHandler* handler
);
[JScript]
public function AddOnRowUpdating(
   handler : SQLRowUpdatingEventHandler
);

Parameters

handler
A SchemaChangedEventHandler that manages the event.

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace


SQLDataSetCommand.AddOnSchemaMapping

[To be supplied.]

[Visual Basic]
Overridable Public Sub AddOnSchemaMapping( _
   ByVal handler As SQLSchemaMappingEventHandler _
)
[C#]
public virtual void AddOnSchemaMapping(
   SQLSchemaMappingEventHandler handler
);
[C++]
public: virtual void AddOnSchemaMapping(
   SQLSchemaMappingEventHandler* handler
);
[JScript]
public function AddOnSchemaMapping(
   handler : SQLSchemaMappingEventHandler
);

Parameters

handler
A SQLSchemaMappingEventHandler that manages the event.

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace


SQLDataSetCommand.CreateNewConnection

Creates a new connection to a data source.

[Visual Basic]
Overridable Protected Function CreateNewConnection( _
   ByVal connectionString As String _
) As SQLConnection
[C#]
protected virtual SQLConnection CreateNewConnection(
   string connectionString
);
[C++]
protected: virtual SQLConnection* CreateNewConnection(
   String* connectionString
);
[JScript]
protected function CreateNewConnection(
   connectionString : String
) : SQLConnection;

Parameters

connectionString
A string used to open the data source.

Return Value

An SQLConnection that contains the data connection information.

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace


SQLDataSetCommand.CreateNewDeleteCommand

Creates a new command used during Update when deleting records in a data source for deleted rows in the data set.

[Visual Basic]
Overrides Protected Function CreateNewDeleteCommand() As DBCommand
[C#]
protected override DBCommand CreateNewDeleteCommand();
[C++]
protected: override DBCommand* CreateNewDeleteCommand();
[JScript]
protected override function CreateNewDeleteCommand() : DBCommand;

Return Value

An SQLCommand that contains the delete command information.

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace


SQLDataSetCommand.CreateNewInsertCommand

Creates a new command used during Update when inserting records in a data source as new rows in the data set.

[Visual Basic]
Overrides Protected Function CreateNewInsertCommand() As DBCommand
[C#]
protected override DBCommand CreateNewInsertCommand();
[C++]
protected: override DBCommand* CreateNewInsertCommand();
[JScript]
protected override function CreateNewInsertCommand() : DBCommand;

Return Value

An SQLCommand that contains the insert command information.

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace


SQLDataSetCommand.CreateNewRowUpdatedEvent

[To be supplied.]

[Visual Basic]
Overrides Protected Function CreateNewRowUpdatedEvent( _
   ByVal dataRow As DataRow, _
   ByVal command As DBCommand, _
   ByVal commandType As String _
) As RowUpdatedEventArgs
[C#]
protected override RowUpdatedEventArgs CreateNewRowUpdatedEvent(
   DataRow dataRow,
   DBCommand command,
   string commandType
);
[C++]
protected: override RowUpdatedEventArgs* CreateNewRowUpdatedEvent(
   DataRow* dataRow,
   DBCommand* command,
   String* commandType
);
[JScript]
protected override function CreateNewRowUpdatedEvent(
   dataRow : DataRow,
   command : DBCommand,
   commandType : String
) : RowUpdatedEventArgs;

Parameters

dataRow
[To be supplied.]
command
[To be supplied.]
commandType
[To be supplied.]

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace


SQLDataSetCommand.CreateNewRowUpdatingEvent

[To be supplied.]

[Visual Basic]
Overrides Protected Function CreateNewRowUpdatingEvent( _
   ByVal dataRow As DataRow, _
   ByVal command As DBCommand, _
   ByVal commandType As String _
) As RowUpdatingEventArgs
[C#]
protected override RowUpdatingEventArgs CreateNewRowUpdatingEvent(
   DataRow dataRow,
   DBCommand command,
   string commandType
);
[C++]
protected: override RowUpdatingEventArgs* CreateNewRowUpdatingEvent(
   DataRow* dataRow,
   DBCommand* command,
   String* commandType
);
[JScript]
protected override function CreateNewRowUpdatingEvent(
   dataRow : DataRow,
   command : DBCommand,
   commandType : String
) : RowUpdatingEventArgs;

Parameters

dataRow
[To be supplied.]
command
[To be supplied.]
commandType
[To be supplied.]

Example [Visual Basic]

The following example fills a DataSet with the schema only, while filling a DataTable with records, when provided a source table.

[Visual Basic]

Public Sub MyFillDataTableAndSet(myDataTable   As DataTable, _
         myDataSet     As DataSet, _
         myDataSetComm As SQLDataSetCommand,
         mySrcTable    As String)
   ' Create a MessageBox to show the contents of myDataTable in
   Dim myMsgBox As MessageBox
   ' Populate myDataTable with records and myDataSet with schema
   myDataTable = myDataSetComm.FillDataSetSchema myDataSet, _
      SchemaType.Source, mySrcTable
   ' Display the contents of myDataTable
   myMsgBox myDataTable.ToString
End Sub

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace


SQLDataSetCommand.CreateNewSchemaMappingEvent

[To be supplied.]

[Visual Basic]
Overrides Protected Function CreateNewSchemaMappingEvent( _
   ByVal command As DBCommand, _
   ByVal dataSet As DataSet, _
   ByVal schemaTable As DataTable _
) As SchemaMappingEventArgs
[C#]
protected override SchemaMappingEventArgs CreateNewSchemaMappingEvent(
   DBCommand command,
   DataSet dataSet,
   DataTable schemaTable
);
[C++]
protected: override SchemaMappingEventArgs* CreateNewSchemaMappingEvent(
   DBCommand* command,
   DataSet* dataSet,
   DataTable* schemaTable
);
[JScript]
protected override function CreateNewSchemaMappingEvent(
   command : DBCommand,
   dataSet : DataSet,
   schemaTable : DataTable
) : SchemaMappingEventArgs;

Parameters

command
[To be supplied.]
dataSet
[To be supplied.]
schemaTable
[To be supplied.]

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace


SQLDataSetCommand.CreateNewSelectCommand

Creates a new command used during Update to select records from a data source for inclusion into the data set.

[Visual Basic]
Overrides Protected Function CreateNewSelectCommand() As DBCommand
[C#]
protected override DBCommand CreateNewSelectCommand();
[C++]
protected: override DBCommand* CreateNewSelectCommand();
[JScript]
protected override function CreateNewSelectCommand() : DBCommand;

Return Value

An SQLCommand that contains the select information.

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace


SQLDataSetCommand.CreateNewUpdateCommand

Creates a new command used during Update when updating records in a data source for modified rows in the data set.

[Visual Basic]
Overrides Protected Function CreateNewUpdateCommand() As DBCommand
[C#]
protected override DBCommand CreateNewUpdateCommand();
[C++]
protected: override DBCommand* CreateNewUpdateCommand();
[JScript]
protected override function CreateNewUpdateCommand() : DBCommand;

Return Value

An SQLCommand that contains the update information.

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace


SQLDataSetCommand.FixupDataCommand

[To be supplied.]

[Visual Basic]
Overrides Protected Sub FixupDataCommand( _
   ByVal command As DBCommand, _
   ByVal updateType As Integer, _
   ByVal row As DataRow, _
   ByVal mappings As DataColumnMappings _
)
[C#]
protected override void FixupDataCommand(
   DBCommand command,
   int updateType,
   DataRow row,
   DataColumnMappings mappings
);
[C++]
protected: override void FixupDataCommand(
   DBCommand* command,
   int updateType,
   DataRow* row,
   DataColumnMappings* mappings
);
[JScript]
protected override function FixupDataCommand(
   command : DBCommand,
   updateType : int,
   row : DataRow,
   mappings : DataColumnMappings
);

Parameters

command
[To be supplied.]
updateType
[To be supplied.]
row
[To be supplied.]
mappings
[To be supplied.]

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace


SQLDataSetCommand.ForceGenerateUpdateCommand

[To be supplied.]

[Visual Basic]
Overrides Protected Sub ForceGenerateUpdateCommand( _
   ByVal updateType As Integer, _
   ByVal optimisticQueries As Boolean, _
   ByVal refreshStatement As Boolean, _
   ByVal forStoredProcedure As Boolean, _
   ByRef sessionState As Object _
)
[C#]
protected override void ForceGenerateUpdateCommand(
   int updateType,
   bool optimisticQueries,
   bool refreshStatement,
   bool forStoredProcedure,
   ref object sessionState
);
[C++]
protected: override void ForceGenerateUpdateCommand(
   int updateType,
   bool optimisticQueries,
   bool refreshStatement,
   bool forStoredProcedure,
   Object** sessionState
);
[JScript]
protected override function ForceGenerateUpdateCommand(
   updateType : int,
   optimisticQueries : Boolean,
   refreshStatement : Boolean,
   forStoredProcedure : Boolean,
   sessionState : Object
);

Parameters

updateType
[To be supplied.]
optimisticQueries
[To be supplied.]
refreshStatement
[To be supplied.]
forStoredProcedure
[To be supplied.]
sessionState
[To be supplied.]

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace


SQLDataSetCommand.IsValidDataCommand

[To be supplied.]

[Visual Basic]
Overrides Protected Function IsValidDataCommand( _
   ByVal value As DBCommand _
) As Boolean
[C#]
protected override bool IsValidDataCommand(
   DBCommand value
);
[C++]
protected: override bool IsValidDataCommand(
   DBCommand* value
);
[JScript]
protected override function IsValidDataCommand(
   value : DBCommand
) : Boolean;

Parameters

value
[To be supplied.]

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace


SQLDataSetCommand.OnRowUpdated

[To be supplied.]

Overload List

Raises the OnRowUpdated event.

[Visual Basic] Overloads Overridable Protected Sub OnRowUpdated(SQLRowUpdatedEventArgs)
[C#] protected virtual void OnRowUpdated(SQLRowUpdatedEventArgs);
[C++] protected: virtual void OnRowUpdated(SQLRowUpdatedEventArgs*);
[JScript] protected function OnRowUpdated(SQLRowUpdatedEventArgs);

Raises the OnRowUpdated event.

[Visual Basic] Overloads Overrides Protected Sub OnRowUpdated(RowUpdatedEventArgs)
[C#] protected override void OnRowUpdated(RowUpdatedEventArgs);
[C++] protected: override void OnRowUpdated(RowUpdatedEventArgs*);
[JScript] protected override function OnRowUpdated(RowUpdatedEventArgs);

Example [Visual Basic]

The following example uses this method within a derived class.

Note This example shows how to use one of the overloaded versions of OnRowUpdated. For other examples that may be available, see the individual overload topics.

[Visual Basic]

' MyDataSetCommand.class derived from SQLDataSetCommand
Inherits SQLDataSetCommand
' create the method for row updated
Public Sub OnRowUpdated(event As RowUpdatedEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row has been updated."
   '  call the base class method
   MyBase.OnRowUpdated event
End Sub
' create the method for row updating
Public Sub OnRowUpdating(event As RowUpdatingEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row is being updated ..."
   '  call the base class method
   MyBase.OnRowUpdating event
End Sub
' create the method for the schema changing
Public Sub OnSchemaChanging(event As SchemaChangingEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is changing ..."
   '  call the base class method
   MyBase.OnSchemaChanging event
End Sub
' create the method for the schema changed
Public Sub OnSchemaChanged(event As SchemaChangedEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema has changed"
   '  call the base class method
   MyBase.OnSchemaChanged event
End Sub
' create the method for the schema being mapped
Public Sub OnSchemaMapping(event As SchemaMappingEventArgs)
   ' show a message box telling the user of schema map
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is currently being mapped ..."
   ' call the base class method
   MyBase.OnSchemaMapping event
End Sub

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace


SQLDataSetCommand.OnRowUpdated (SQLRowUpdatedEventArgs)

Raises the OnRowUpdated event.

[Visual Basic]
Overloads Overridable Protected Sub OnRowUpdated( _
   ByVal ruevent As SQLRowUpdatedEventArgs _
)
[C#]
protected virtual void OnRowUpdated(
   SQLRowUpdatedEventArgs ruevent
);
[C++]
protected: virtual void OnRowUpdated(
   SQLRowUpdatedEventArgs* ruevent
);
[JScript]
protected function OnRowUpdated(
   ruevent : SQLRowUpdatedEventArgs
);

Parameters

ruevent
A SQLRowUpdatedEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see TBD.

Notes to Inheritors: When overriding OnRowUpdated in a derived class, be sure to call the base class's OnRowUpdated method.

Example [Visual Basic]

The following example uses this method within a derived class.

[Visual Basic]

' MyDataSetCommand.class derived from SQLDataSetCommand
Inherits SQLDataSetCommand
' create the method for row updated
Public Sub OnRowUpdated(event As RowUpdatedEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row has been updated."
   '  call the base class method
   MyBase.OnRowUpdated event
End Sub
' create the method for row updating
Public Sub OnRowUpdating(event As RowUpdatingEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row is being updated ..."
   '  call the base class method
   MyBase.OnRowUpdating event
End Sub
' create the method for the schema changing
Public Sub OnSchemaChanging(event As SchemaChangingEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is changing ..."
   '  call the base class method
   MyBase.OnSchemaChanging event
End Sub
' create the method for the schema changed
Public Sub OnSchemaChanged(event As SchemaChangedEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema has changed"
   '  call the base class method
   MyBase.OnSchemaChanged event
End Sub
' create the method for the schema being mapped
Public Sub OnSchemaMapping(event As SchemaMappingEventArgs)
   ' show a message box telling the user of schema map
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is currently being mapped ..."
   ' call the base class method
   MyBase.OnSchemaMapping event
End Sub

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace | SQLDataSetCommand.OnRowUpdated Overload List | OnRowUpdating


SQLDataSetCommand.OnRowUpdated (RowUpdatedEventArgs)

Raises the OnRowUpdated event.

[Visual Basic]
Overloads Overrides Protected Sub OnRowUpdated( _
   ByVal ruevent As RowUpdatedEventArgs _
)
[C#]
protected override void OnRowUpdated(
   RowUpdatedEventArgs ruevent
);
[C++]
protected: override void OnRowUpdated(
   RowUpdatedEventArgs* ruevent
);
[JScript]
protected override function OnRowUpdated(
   ruevent : RowUpdatedEventArgs
);

Parameters

ruevent
A SQLRowUpdatedEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see <Delegates/EventModelTopic>.

Notes to Inheritors: When overriding OnRowUpdated in a derived class, be sure to call the base class's OnRowUpdated method.

Example [Visual Basic]

The following example uses this method within a derived class.

[Visual Basic]

' MyDataSetCommand.class derived from SQLDataSetCommand
Inherits SQLDataSetCommand
' create the method for row updated
Public Sub OnRowUpdated(event As RowUpdatedEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row has been updated."
   '  call the base class method
   MyBase.OnRowUpdated event
End Sub
' create the method for row updating
Public Sub OnRowUpdating(event As RowUpdatingEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row is being updated ..."
   '  call the base class method
   MyBase.OnRowUpdating event
End Sub
' create the method for the schema changing
Public Sub OnSchemaChanging(event As SchemaChangingEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is changing ..."
   '  call the base class method
   MyBase.OnSchemaChanging event
End Sub
' create the method for the schema changed
Public Sub OnSchemaChanged(event As SchemaChangedEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema has changed"
   '  call the base class method
   MyBase.OnSchemaChanged event
End Sub
' create the method for the schema being mapped
Public Sub OnSchemaMapping(event As SchemaMappingEventArgs)
   ' show a message box telling the user of schema map
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is currently being mapped ..."
   ' call the base class method
   MyBase.OnSchemaMapping event
End Sub

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace | SQLDataSetCommand.OnRowUpdated Overload List | OnRowUpdating


SQLDataSetCommand.OnRowUpdating

[To be supplied.]

Overload List

Raises the OnRowUpdating event.

[Visual Basic] Overloads Overridable Protected Sub OnRowUpdating(SQLRowUpdatingEventArgs)
[C#] protected virtual void OnRowUpdating(SQLRowUpdatingEventArgs);
[C++] protected: virtual void OnRowUpdating(SQLRowUpdatingEventArgs*);
[JScript] protected function OnRowUpdating(SQLRowUpdatingEventArgs);

Raises the OnRowUpdating event.

[Visual Basic] Overloads Overrides Protected Sub OnRowUpdating(RowUpdatingEventArgs)
[C#] protected override void OnRowUpdating(RowUpdatingEventArgs);
[C++] protected: override void OnRowUpdating(RowUpdatingEventArgs*);
[JScript] protected override function OnRowUpdating(RowUpdatingEventArgs);

Example [Visual Basic]

The following example uses this method within a derived class.

Note This example shows how to use one of the overloaded versions of OnRowUpdating. For other examples that may be available, see the individual overload topics.

[Visual Basic]

' MyDataSetCommand.class derived from SQLDataSetCommand
Inherits SQLDataSetCommand
' create the method for row updated
Public Sub OnRowUpdated(event As RowUpdatedEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row has been updated."
   '  call the base class method
   MyBase.OnRowUpdated event
End Sub
' create the method for row updating
Public Sub OnRowUpdating(event As RowUpdatingEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row is being updated ..."
   '  call the base class method
   MyBase.OnRowUpdating event
End Sub
' create the method for the schema changing
Public Sub OnSchemaChanging(event As SchemaChangingEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is changing ..."
   '  call the base class method
   MyBase.OnSchemaChanging event
End Sub
' create the method for the schema changed
Public Sub OnSchemaChanged(event As SchemaChangedEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema has changed"
   '  call the base class method
   MyBase.OnSchemaChanged event
End Sub
' create the method for the schema being mapped
Public Sub OnSchemaMapping(event As SchemaMappingEventArgs)
   ' show a message box telling the user of schema map
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is currently being mapped ..."
   ' call the base class method
   MyBase.OnSchemaMapping event
End Sub

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace


SQLDataSetCommand.OnRowUpdating (SQLRowUpdatingEventArgs)

Raises the OnRowUpdating event.

[Visual Basic]
Overloads Overridable Protected Sub OnRowUpdating( _
   ByVal ruevent As SQLRowUpdatingEventArgs _
)
[C#]
protected virtual void OnRowUpdating(
   SQLRowUpdatingEventArgs ruevent
);
[C++]
protected: virtual void OnRowUpdating(
   SQLRowUpdatingEventArgs* ruevent
);
[JScript]
protected function OnRowUpdating(
   ruevent : SQLRowUpdatingEventArgs
);

Parameters

ruevent
A SQLRowUpdatingEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see <Delegate/EventModelTopic>.

Notes to Inheritors: When overriding OnRowUpdating in a derived class, be sure to call the bases class's OnRowUpdating method.

Example [Visual Basic]

The following example uses this method within a derived class.

[Visual Basic]

' MyDataSetCommand.class derived from SQLDataSetCommand
Inherits SQLDataSetCommand
' create the method for row updated
Public Sub OnRowUpdated(event As RowUpdatedEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row has been updated."
   '  call the base class method
   MyBase.OnRowUpdated event
End Sub
' create the method for row updating
Public Sub OnRowUpdating(event As RowUpdatingEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row is being updated ..."
   '  call the base class method
   MyBase.OnRowUpdating event
End Sub
' create the method for the schema changing
Public Sub OnSchemaChanging(event As SchemaChangingEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is changing ..."
   '  call the base class method
   MyBase.OnSchemaChanging event
End Sub
' create the method for the schema changed
Public Sub OnSchemaChanged(event As SchemaChangedEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema has changed"
   '  call the base class method
   MyBase.OnSchemaChanged event
End Sub
' create the method for the schema being mapped
Public Sub OnSchemaMapping(event As SchemaMappingEventArgs)
   ' show a message box telling the user of schema map
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is currently being mapped ..."
   ' call the base class method
   MyBase.OnSchemaMapping event
End Sub

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace | SQLDataSetCommand.OnRowUpdating Overload List | OnRowUpdated


SQLDataSetCommand.OnRowUpdating (RowUpdatingEventArgs)

Raises the OnRowUpdating event.

[Visual Basic]
Overloads Overrides Protected Sub OnRowUpdating( _
   ByVal ruevent As RowUpdatingEventArgs _
)
[C#]
protected override void OnRowUpdating(
   RowUpdatingEventArgs ruevent
);
[C++]
protected: override void OnRowUpdating(
   RowUpdatingEventArgs* ruevent
);
[JScript]
protected override function OnRowUpdating(
   ruevent : RowUpdatingEventArgs
);

Parameters

ruevent
A SQLRowUpdatingEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see <Delegate/EventModelTopic>.

Notes to Inheritors: When overriding OnRowUpdating in a derived class, be sure to call the bases class's OnRowUpdating method.

Example [Visual Basic]

The following example uses this method within a derived class.

[Visual Basic]

' MyDataSetCommand.class derived from SQLDataSetCommand
Inherits SQLDataSetCommand
' create the method for row updated
Public Sub OnRowUpdated(event As RowUpdatedEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row has been updated."
   '  call the base class method
   MyBase.OnRowUpdated event
End Sub
' create the method for row updating
Public Sub OnRowUpdating(event As RowUpdatingEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row is being updated ..."
   '  call the base class method
   MyBase.OnRowUpdating event
End Sub
' create the method for the schema changing
Public Sub OnSchemaChanging(event As SchemaChangingEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is changing ..."
   '  call the base class method
   MyBase.OnSchemaChanging event
End Sub
' create the method for the schema changed
Public Sub OnSchemaChanged(event As SchemaChangedEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema has changed"
   '  call the base class method
   MyBase.OnSchemaChanged event
End Sub
' create the method for the schema being mapped
Public Sub OnSchemaMapping(event As SchemaMappingEventArgs)
   ' show a message box telling the user of schema map
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is currently being mapped ..."
   ' call the base class method
   MyBase.OnSchemaMapping event
End Sub

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace | SQLDataSetCommand.OnRowUpdating Overload List | OnRowUpdated


SQLDataSetCommand.OnSchemaMapping

[To be supplied.]

Overload List

Raises the OnSchemaMapping event.

[Visual Basic] Overloads Overrides Protected Sub OnSchemaMapping(SchemaMappingEventArgs)
[C#] protected override void OnSchemaMapping(SchemaMappingEventArgs);
[C++] protected: override void OnSchemaMapping(SchemaMappingEventArgs*);
[JScript] protected override function OnSchemaMapping(SchemaMappingEventArgs);

Raises the OnSchemaMapping event.

[Visual Basic] Overloads Overridable Protected Sub OnSchemaMapping(SQLSchemaMappingEventArgs)
[C#] protected virtual void OnSchemaMapping(SQLSchemaMappingEventArgs);
[C++] protected: virtual void OnSchemaMapping(SQLSchemaMappingEventArgs*);
[JScript] protected function OnSchemaMapping(SQLSchemaMappingEventArgs);

Example [Visual Basic]

The following example uses this method within a derived class.

Note This example shows how to use one of the overloaded versions of OnSchemaMapping. For other examples that may be available, see the individual overload topics.

[Visual Basic]

' MyDataSetCommand.class derived from SQLDataSetCommand
Inherits SQLDataSetCommand
' create the method for row updated
Public Sub OnRowUpdated(event As RowUpdatedEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row has been updated."
   '  call the base class method
   MyBase.OnRowUpdated event
End Sub
' create the method for row updating
Public Sub OnRowUpdating(event As RowUpdatingEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row is being updated ..."
   '  call the base class method
   MyBase.OnRowUpdating event
End Sub
' create the method for the schema changing
Public Sub OnSchemaChanging(event As SchemaChangingEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is changing ..."
   '  call the base class method
   MyBase.OnSchemaChanging event
End Sub
' create the method for the schema changed
Public Sub OnSchemaChanged(event As SchemaChangedEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema has changed"
   '  call the base class method
   MyBase.OnSchemaChanged event
End Sub
' create the method for the schema being mapped
Public Sub OnSchemaMapping(event As SchemaMappingEventArgs)
   ' show a message box telling the user of schema map
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is currently being mapped ..."
   ' call the base class method
   MyBase.OnSchemaMapping event
End Sub

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace


SQLDataSetCommand.OnSchemaMapping (SchemaMappingEventArgs)

Raises the OnSchemaMapping event.

[Visual Basic]
Overloads Overrides Protected Sub OnSchemaMapping( _
   ByVal scevent As SchemaMappingEventArgs _
)
[C#]
protected override void OnSchemaMapping(
   SchemaMappingEventArgs scevent
);
[C++]
protected: override void OnSchemaMapping(
   SchemaMappingEventArgs* scevent
);
[JScript]
protected override function OnSchemaMapping(
   scevent : SchemaMappingEventArgs
);

Parameters

scevent
A SQLSchemaMappingEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see <Delegate/EventModelTopic>.

Notes to Inheritors: When overriding OnSchemaMapping in a derived class, be sure to call the bases class's OnSchemaMapping method.

Example [Visual Basic]

The following example uses this method within a derived class.

[Visual Basic]

' MyDataSetCommand.class derived from SQLDataSetCommand
Inherits SQLDataSetCommand
' create the method for row updated
Public Sub OnRowUpdated(event As RowUpdatedEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row has been updated."
   '  call the base class method
   MyBase.OnRowUpdated event
End Sub
' create the method for row updating
Public Sub OnRowUpdating(event As RowUpdatingEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row is being updated ..."
   '  call the base class method
   MyBase.OnRowUpdating event
End Sub
' create the method for the schema changing
Public Sub OnSchemaChanging(event As SchemaChangingEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is changing ..."
   '  call the base class method
   MyBase.OnSchemaChanging event
End Sub
' create the method for the schema changed
Public Sub OnSchemaChanged(event As SchemaChangedEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema has changed"
   '  call the base class method
   MyBase.OnSchemaChanged event
End Sub
' create the method for the schema being mapped
Public Sub OnSchemaMapping(event As SchemaMappingEventArgs)
   ' show a message box telling the user of schema map
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is currently being mapped ..."
   ' call the base class method
   MyBase.OnSchemaMapping event
End Sub

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace | SQLDataSetCommand.OnSchemaMapping Overload List


SQLDataSetCommand.OnSchemaMapping (SQLSchemaMappingEventArgs)

Raises the OnSchemaMapping event.

[Visual Basic]
Overloads Overridable Protected Sub OnSchemaMapping( _
   ByVal scevent As SQLSchemaMappingEventArgs _
)
[C#]
protected virtual void OnSchemaMapping(
   SQLSchemaMappingEventArgs scevent
);
[C++]
protected: virtual void OnSchemaMapping(
   SQLSchemaMappingEventArgs* scevent
);
[JScript]
protected function OnSchemaMapping(
   scevent : SQLSchemaMappingEventArgs
);

Parameters

scevent
A SQLSchemaMappingEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview, see <Delegate/EventModelTopic>.

Notes to Inheritors: When overriding OnSchemaMapping in a derived class, be sure to call the bases class's OnSchemaMapping method.

Example [Visual Basic]

The following example uses this method within a derived class.

[Visual Basic]

' MyDataSetCommand.class derived from SQLDataSetCommand
Inherits SQLDataSetCommand
' create the method for row updated
Public Sub OnRowUpdated(event As RowUpdatedEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row has been updated."
   '  call the base class method
   MyBase.OnRowUpdated event
End Sub
' create the method for row updating
Public Sub OnRowUpdating(event As RowUpdatingEventArgs)
   ' show a message box telling user of row update
   Dim myMsgBox As MessageBox
   myMsgBox.Show "A row is being updated ..."
   '  call the base class method
   MyBase.OnRowUpdating event
End Sub
' create the method for the schema changing
Public Sub OnSchemaChanging(event As SchemaChangingEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is changing ..."
   '  call the base class method
   MyBase.OnSchemaChanging event
End Sub
' create the method for the schema changed
Public Sub OnSchemaChanged(event As SchemaChangedEventArgs)
   ' show a message box telling user of schema change
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema has changed"
   '  call the base class method
   MyBase.OnSchemaChanged event
End Sub
' create the method for the schema being mapped
Public Sub OnSchemaMapping(event As SchemaMappingEventArgs)
   ' show a message box telling the user of schema map
   Dim myMsgBox As MessageBox
   myMsgBox.Show "The schema is currently being mapped ..."
   ' call the base class method
   MyBase.OnSchemaMapping event
End Sub

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace | SQLDataSetCommand.OnSchemaMapping Overload List


SQLDataSetCommand.RemoveOnRowUpdated

[To be supplied.]

[Visual Basic]
Overridable Public Sub RemoveOnRowUpdated( _
   ByVal handler As SQLRowUpdatedEventHandler _
)
[C#]
public virtual void RemoveOnRowUpdated(
   SQLRowUpdatedEventHandler handler
);
[C++]
public: virtual void RemoveOnRowUpdated(
   SQLRowUpdatedEventHandler* handler
);
[JScript]
public function RemoveOnRowUpdated(
   handler : SQLRowUpdatedEventHandler
);

Parameters

handler
[To be supplied.]

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace


SQLDataSetCommand.RemoveOnRowUpdating

[To be supplied.]

[Visual Basic]
Overridable Public Sub RemoveOnRowUpdating( _
   ByVal handler As SQLRowUpdatingEventHandler _
)
[C#]
public virtual void RemoveOnRowUpdating(
   SQLRowUpdatingEventHandler handler
);
[C++]
public: virtual void RemoveOnRowUpdating(
   SQLRowUpdatingEventHandler* handler
);
[JScript]
public function RemoveOnRowUpdating(
   handler : SQLRowUpdatingEventHandler
);

Parameters

handler
[To be supplied.]

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace


SQLDataSetCommand.RemoveOnSchemaMapping

[To be supplied.]

[Visual Basic]
Overridable Public Sub RemoveOnSchemaMapping( _
   ByVal handler As SQLSchemaMappingEventHandler _
)
[C#]
public virtual void RemoveOnSchemaMapping(
   SQLSchemaMappingEventHandler handler
);
[C++]
public: virtual void RemoveOnSchemaMapping(
   SQLSchemaMappingEventHandler* handler
);
[JScript]
public function RemoveOnSchemaMapping(
   handler : SQLSchemaMappingEventHandler
);

Parameters

handler
[To be supplied.]

See Also

SQLDataSetCommand Class | SQLDataSetCommand Members | System.Data.SQL Namespace


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLDataSetCommand Events

The events of the SQLDataSetCommand class are listed below. For a complete list of SQLDataSetCommand class members, see the SQLDataSetCommand Members topic.

Public:

RowUpdated | Occurs during Update after a command is executed against the data source. The attempt to update is made, so the event fires.
RowUpdating | Occurs during Update before a command is executed against the data source. The attempt to update is made, so the event fires.
SchemaChanged (inherited from DataSetCommand) | Occurs during Update after a command is executed against the data source when the schema may be potentially different due to a property change.
SchemaChanging (inherited from DataSetCommand) | Occurs during Update before a command is executed against the data source when the schema may be potentially different due to a property change.
SchemaMapping | Occurs after the schema is mapped from the data source to the data set but before the tables and columns are added to the data set.

See Also

SQLDataSetCommand Class | System.Data.SQL Namespace


SQLDataSetCommand RowUpdated Event

Occurs during Update after a command is executed against the data source. The attempt to update is made, so the event fires.

The following declaration shows the syntax for a method that handles the RowUpdated event.

[Visual Basic]
Private Sub SQLDataSetCommandName_RowUpdated( _
   ByVal sender As Object, _
   ByVal e As SQLRowUpdatedEventArgs _
)
[C#]
private void SQLDataSetCommandName_RowUpdated(
   object sender,
   SQLRowUpdatedEventArgs e
);
[C++]
private: void SQLDataSetCommandName_RowUpdated(
   Object* sender,
   SQLRowUpdatedEventArgs* e
);
[JScript]
private SQLDataSetCommandName_RowUpdated(
   sender : Object,
   e : SQLRowUpdatedEventArgs
);

Parameters

sender
The source of the event.
e
A SQLRowUpdatedEventArgs that contains the event data. The following SQLRowUpdatedEventArgs properties provide information specific to this event.
Property Description
Command
[To be supplied.]

Remarks

When using Update, there are two events that occur per data row updated. The order of execution is as follows:

1) The values in the DataRow are moved to the parameter values

2) The OnRowUpdating event fires

3) The command executes

4) if the command is set to FirstReturnedRecord, then the first ruturned result is placed in the DataRow

5) if there are output parameters, they are placed in the DataRow

6) The OnRowUpdated event fires.

7) AcceptChanges is called.

See Also

SQLDataSetCommand Class | SQLDataSetCommand MembersTopic | System.Data.SQL Namespace


SQLDataSetCommand RowUpdating Event

Occurs during Update before a command is executed against the data source. The attempt to update is made, so the event fires.

The following declaration shows the syntax for a method that handles the RowUpdating event.

[Visual Basic]
Private Sub SQLDataSetCommandName_RowUpdating( _
   ByVal sender As Object, _
   ByVal e As SQLRowUpdatingEventArgs _
)
[C#]
private void SQLDataSetCommandName_RowUpdating(
   object sender,
   SQLRowUpdatingEventArgs e
);
[C++]
private: void SQLDataSetCommandName_RowUpdating(
   Object* sender,
   SQLRowUpdatingEventArgs* e
);
[JScript]
private SQLDataSetCommandName_RowUpdating(
   sender : Object,
   e : SQLRowUpdatingEventArgs
);

Parameters

sender
The source of the event.
e
A SQLRowUpdatingEventArgs that contains the event data. The following SQLRowUpdatingEventArgs properties provide information specific to this event.
Property Description
Command
[To be supplied.]

Remarks

When using Update, there are two events that occur per data row updated. The order of execution is as follows:

1) The values in the DataRow are moved to the parameter values

2) The OnRowUpdating event fires

3) The command executes

4) if the command is set to FirstReturnedRecord, then the first ruturned result is placed in the DataRow

5) if there are output parameters, they are placed in the DataRow

6) The OnRowUpdated event fires.

7) AcceptChanges is called.

See Also

SQLDataSetCommand Class | SQLDataSetCommand MembersTopic | System.Data.SQL Namespace


SQLDataSetCommand SchemaMapping Event

Occurs after the schema is mapped from the data source to the data set but before the tables and columns are added to the data set.

The following declaration shows the syntax for a method that handles the SchemaMapping event.

[Visual Basic]
Private Sub SQLDataSetCommandName_SchemaMapping( _
   ByVal sender As Object, _
   ByVal e As SQLSchemaMappingEventArgs _
)
[C#]
private void SQLDataSetCommandName_SchemaMapping(
   object sender,
   SQLSchemaMappingEventArgs e
);
[C++]
private: void SQLDataSetCommandName_SchemaMapping(
   Object* sender,
   SQLSchemaMappingEventArgs* e
);
[JScript]
private SQLDataSetCommandName_SchemaMapping(
   sender : Object,
   e : SQLSchemaMappingEventArgs
);

Parameters

sender
The source of the event.
e
A SQLSchemaMappingEventArgs that contains the event data. The following SQLSchemaMappingEventArgs properties provide information specific to this event.
Property Description
Command
[To be supplied.]

See Also

SQLDataSetCommand Class | SQLDataSetCommand MembersTopic | System.Data.SQL Namespace


SQLDataType Enumeration

[To be supplied.]

[Visual Basic]
Public Enum SQLDataType
[C#]
public enum SQLDataType
[C++]
public enum SQLDataType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
BigInt | [To be supplied.]
Binary | [To be supplied.]
Bit | [To be supplied.]
Char | [To be supplied.]
DateTime | [To be supplied.]
Decimal | [To be supplied.]
Float | [To be supplied.]
Image | [To be supplied.]
Int | [To be supplied.]
Money | [To be supplied.]
NChar | [To be supplied.]
NText | [To be supplied.]
NVarChar | [To be supplied.]
Real | [To be supplied.]
SmallDateTime | [To be supplied.]
SmallInt | [To be supplied.]
SmallMoney | [To be supplied.]
Text | [To be supplied.]
TinyInt | [To be supplied.]
UniqueId | [To be supplied.]
VarBinary | [To be supplied.]
VarChar | [To be supplied.]
Variant | [To be supplied.]

Requirements

Namespace: System.Data.SQL

Assembly: System.Data.dll

See Also

System.Data.SQL Namespace


SQLError Class

Collects information relevant to a warning or error returned by SQL Server.

Object
SQLError

[Visual Basic]
Public Class SQLError
[C#]
public class SQLError
[C++]
public __gc class SQLError
[JScript]
public class SQLError

Remarks

This class is created by the adapter when an error occurs. An instance of SQLError is created and managed by the SQLErrors class, which in turn is created by the SQLException class.

Requirements

Namespace: System.Data.SQL

Assembly: System.Data.dll

Example [Visual Basic]

The following example displays the values of some of the SQLError properties in a window.

[Visual Basic]

Private Sub ShowAllSqlErrors()
   Dim myConnection As String
   Dim mySelect As String
   Dim dataSet As New DataSet
   Dim sqlDataSetComm As New SQLDataSetCommand
   myConnection = "user id=sa;password=;database=northwind;" _
       & "server=mySQL;"
   mySelect = "SELECT * FROM Categories ORDER BY CategoryID"
   Try
      Set sqlDataSetComm = SQLDataSetCommand(mySelect, myConnection)
      sqlDataSetComm.FillDataSet(dataSet)
   Catch (SQLException SQLExcept)
      Dim SQLErr As New SQLError
      For Each SQLErr In SQLExcept.Errors
         ShowSQLError(SQLErr)
      Next
   End Try
End Sub
Private Sub ShowSQLError(sqlServerErr2 As SQLServerError)
   Dim myMessage As String
   Dim myTitle As String
   Dim myMsgBox As MessageBox
   myMessage = "Error " + sqlServerErr2.Number _
   + " on Server " + sqlServerErr2.Server + ": " _
   + sqlServerErr2.Message + " on Line " _
   + sqlServerErr2.LineNumber
   myTitle  = "SQL Server Error"
   myMsgBox.Show myMessage, myTitle
End Sub

See Also

SQLError Members | System.Data.SQL Namespace | SQLErrors | SQLException


SQLError Members

Public:

Properties

Class | Gets the severity level of the error returned from the SQL Server adapter.
LineNumber | Gets the line number that the SQL Server error occurred on.
Message | Gets the error message that was generated from the SQL Server adapter.
Number | Gets the error code returned from the SQL Server adapter.
Procedure | Gets the name of the procedure that the SQL Server error occurred in.
Server | Gets the name of the database server the error occurred on.
Source | Gets the line of source code that generated the error.
State | Gets the error state number returned from the SQL Server adapter.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Returns the entire text of the SQLError.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLError Class | System.Data.SQL Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLError Properties

The properties of the SQLError class are listed below. For a complete list of SQLError class members, see the SQLError Members topic.

Public:

Class | Gets the severity level of the error returned from the SQL Server adapter.
LineNumber | Gets the line number that the SQL Server error occurred on.
Message | Gets the error message that was generated from the SQL Server adapter.
Number | Gets the error code returned from the SQL Server adapter.
Procedure | Gets the name of the procedure that the SQL Server error occurred in.
Server | Gets the name of the database server the error occurred on.
Source | Gets the line of source code that generated the error.
State | Gets the error state number returned from the SQL Server adapter.

See Also

SQLError Class | System.Data.SQL Namespace


SQLError.Class

Gets the severity level of the error returned from the SQL Server adapter.

[Visual Basic]
Public ReadOnly Property Class As Byte
[C#]
public byte Class {get;}
[C++]
public: __property unsigned char get_Class();
[JScript]
public function get Class() : Byte;

Property Value

The severity of the error.

Example [Visual Basic]

The following example returns the severity of the error.

[Visual Basic]

Function GetErrorClass(sqlErr As SQLError) As Byte
   GetErrorClass = sqlErr.Class
End Function

See Also

SQLError Class | SQLError Members | System.Data.SQL Namespace | Number | State | Server | Source | Message | Procedure | LineNumber


SQLError.LineNumber

Gets the line number that the SQL Server error occurred on.

[Visual Basic]
Public ReadOnly Property LineNumber As Integer
[C#]
public int LineNumber {get;}
[C++]
public: __property int get_LineNumber();
[JScript]
public function get LineNumber() : int;

Property Value

The line number.

Example [Visual Basic]

The following example returns the line the error occurred on.

[Visual Basic]

Function GetErrorLineNumber(sqlErr As SQLError) As Integer
   GetErrorLineNumber = sqlErr.LineNumber
End Function

See Also

SQLError Class | SQLError Members | System.Data.SQL Namespace | Source | Number | State | Class | Server | Message | Procedure


SQLError.Message

Gets the error message that was generated from the SQL Server adapter.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property String* get_Message();
[JScript]
public function get Message() : String;

Property Value

The generated error message.

Example [Visual Basic]

The following example returns the error message.

[Visual Basic]

Function GetErrorMessage(sqlErr As SQLError) As String
   GetErrorMessage = sqlErr.Message
End Function

See Also

SQLError Class | SQLError Members | System.Data.SQL Namespace | Number | State | Source | Class | Server | Procedure | LineNumber


SQLError.Number

Gets the error code returned from the SQL Server adapter.

[Visual Basic]
Public ReadOnly Property Number As Integer
[C#]
public int Number {get;}
[C++]
public: __property int get_Number();
[JScript]
public function get Number() : int;

Property Value

The error code.

Example [Visual Basic]

The following example returns the value of the error code.

[Visual Basic]

Function GetErrorCode(sqlErr As SQLError) As Integer
   GetErrorCode = sqlErr.Number
End Function

See Also

SQLError Class | SQLError Members | System.Data.SQL Namespace | State | Class | Source | Server | Message | Procedure | LineNumber


SQLError.Procedure

Gets the name of the procedure that the SQL Server error occurred in.

[Visual Basic]
Public ReadOnly Property Procedure As String
[C#]
public string Procedure {get;}
[C++]
public: __property String* get_Procedure();
[JScript]
public function get Procedure() : String;

Property Value

The name of the procedure.

Example [Visual Basic]

The following example returns the procedure name that the error occurred in.

[Visual Basic]

Function GetErrorProcedure(sqlErr As SQLError) As String
   GetErrorProcedure = sqlErr.Procedure
End Function

See Also

SQLError Class | SQLError Members | System.Data.SQL Namespace | Number | Source | State | Class | Server | Message | LineNumber


SQLError.Server

Gets the name of the database server the error occurred on.

[Visual Basic]
Public ReadOnly Property Server As String
[C#]
public string Server {get;}
[C++]
public: __property String* get_Server();
[JScript]
public function get Server() : String;

Property Value

The name of the database server.

Example [Visual Basic]

The following example returns the name of the database server.

[Visual Basic]

Function GetErrorServer(sqlErr As SQLError) As String
   GetErrorServer = sqlErr.Server
End Function

See Also

SQLError Class | SQLError Members | System.Data.SQL Namespace | Number | State | Class | Source | Message | Procedure | LineNumber


SQLError.Source

Gets the line of source code that generated the error.

[Visual Basic]
Public ReadOnly Property Source As String
[C#]
public string Source {get;}
[C++]
public: __property String* get_Source();
[JScript]
public function get Source() : String;

Property Value

The line of source code that generated the error.

Example [Visual Basic]

The following example returns the line of source code that caused the SQLError.

[Visual Basic]

Function GetErrorSource(sqlErr As SQLError) As String
   GetErrorMessage = sqlErr.Source
End Function

See Also

SQLError Class | SQLError Members | System.Data.SQL Namespace | Number | State | Class | Server | Message | Procedure | LineNumber


SQLError.State

Gets the error state number returned from the SQL Server adapter.

[Visual Basic]
Public ReadOnly Property State As Byte
[C#]
public byte State {get;}
[C++]
public: __property unsigned char get_State();
[JScript]
public function get State() : Byte;

Property Value

The error state, which identifies the source from which the error was issued (if the error can be issued from more than one place).

Example [Visual Basic]

The following example returns the error state.

[Visual Basic]

Function GetErrorState(sqlErr As SQLError) As Byte
   GetErrorState = sqlErr.State
End Function

See Also

SQLError Class | SQLError Members | System.Data.SQL Namespace | Number | Source | Class | Server | Message | Procedure | LineNumber


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLError Methods

The methods of the SQLError class are listed below. For a complete list of SQLError class members, see the SQLError Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Returns the entire text of the SQLError.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLError Class | System.Data.SQL Namespace


SQLError.ToString

Returns the entire text of the SQLError.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

The text of the error.

Remarks

The string will be in the format of "SQLError:", followed by the Message, and the stack trace. For example:

SQLError:UserID or Password not valid. <stack trace>

See Also

SQLError Class | SQLError Members | System.Data.SQL Namespace


SQLErrors Class

Collects all errors generated by the SQL Server adapter.

Object
SQLErrors

[Visual Basic]
Public Class SQLErrors
   Implements ICollection, IEnumerable
[C#]
public class SQLErrors : ICollection, IEnumerable
[C++]
public __gc class SQLErrors : public ICollection, IEnumerable
[JScript]
public class SQLErrors implements ICollection, IEnumerable

Remarks

This class is created by SQLException to collect instances of the SQLError class. SQLErrors always contains at least one instance of the SQLError class.

Requirements

Namespace: System.Data.SQL

Assembly: System.Data.dll

Example [Visual Basic]

The following example displays the values of some of the properties of the SQLError instances created and managed by the SQLErrors class.

[Visual Basic]

Private Sub GetSQLErrors()
   Dim myConnection As String
   Dim mySelect As String
   Dim dataSet As New DataSet
   Dim sqlDataSetComm As New SQLDataSetCommand
   myConnection = "user id=sa;password=;database=northwind;" _
       + "server=mySQL;"
   mySelect = "SELECT * FROM Categories ORDER BY CategoryID"
   Try
      Set sqlDataSetComm = SQLDataSetCommand(mySelect, myConnection)
      sqlDataSetComm.FillDataSet(dataSet)
   Catch (SQLException SQLExcept)
      ShowSQLErrors(SQLExcept.Errors)
   End Try
End Sub
Private Sub ShowSQLErrors(sqlServerErrColl As SQLServerErrors)
   Dim myMessage As String
   Dim myTitle As String
   Dim myMsgBox As MessageBox
   Dim sqlServerErr As New SQLServerError
   myTitle  = "SQL Server Error"
   For Each sqlServerErr In sqlServerErrColl
      myMessage = "Error " + sqlServerErr.Number _
   + " on Server " + sqlServerErr.Server + ": " _
   + sqlServerErr.Message + " on Line " _
   + sqlServerErr.LineNumber
      myMsgBox.Show myMessage, myTitle
   Next
End Sub

See Also

SQLErrors Members | System.Data.SQL Namespace | SQLError | SQLException


SQLErrors Members

Public:

Properties

All | Gets all of the SQL adapter errors collected.
Count | Gets the number of errors in the collection.
IsReadOnly | Gets a boolean indicating whether the collection is read-only.
IsSynchronized | Gets a boolean that indicating whether the collection is sychonized with the data source.
Item | Gets the error at the specified index. In C#, this member is the indexer for the SQLErrors class.
SyncRoot | What purpose does this property serve?

Methods

CopyTo | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLErrors Class | System.Data.SQL Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLErrors Properties

The properties of the SQLErrors class are listed below. For a complete list of SQLErrors class members, see the SQLErrors Members topic.

Public:

All | Gets all of the SQL adapter errors collected.
Count | Gets the number of errors in the collection.
IsReadOnly | Gets a boolean indicating whether the collection is read-only.
IsSynchronized | Gets a boolean that indicating whether the collection is sychonized with the data source.
Item | Gets the error at the specified index. In C#, this member is the indexer for the SQLErrors class.
SyncRoot | What purpose does this property serve?

See Also

SQLErrors Class | System.Data.SQL Namespace


SQLErrors.All

Gets all of the SQL adapter errors collected.

[Visual Basic]
Public ReadOnly Property All As SQLError ()
[C#]
public SQLError[] All {get;}
[C++]
public: __property SQLError* get_All();
[JScript]
public function get All() : SQLError[];

Property Value

All instances of SQLError collected.

Example [Visual Basic]

The following example displays an array of all SQLError.

[Visual Basic]

Public Sub DumpAllErrors(sqlErrCollect As SQLErrors)
   Dim myTitle As String
   Dim myMsgBox As MessageBox
   Dim myErrors() As SQLError
   myTitle  = "Dump of all SQL Server Errors"
   myErrors = sqlErrCollect.All
   myMsgBox.Show myErrors, myTitle
End Sub

See Also

SQLErrors Class | SQLErrors Members | System.Data.SQL Namespace


SQLErrors.Count

Gets the number of errors in the collection.

[Visual Basic]
Overridable Public ReadOnly Property Count As Integer
[C#]
public int Count {virtual get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;

Property Value

The total number of errors in the collection.

Example [Visual Basic]

The following example uses the property to get the last error from the collection.

[Visual Basic]

Function GetLastSQLError(sqlErrCollect As SQLErrors) As SQLError
   GetLastSQLError = sqlErrCollect[sqlErrCollect.Count - 1]
End Function

See Also

SQLErrors Class | SQLErrors Members | System.Data.SQL Namespace


SQLErrors.IsReadOnly

Gets a boolean indicating whether the collection is read-only.

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {virtual get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;

Property Value

true if the collection is read-only, otherwise false.

Remarks

IsReadOnly is always true.

See Also

SQLErrors Class | SQLErrors Members | System.Data.SQL Namespace


SQLErrors.IsSynchronized

Gets a boolean that indicating whether the collection is sychonized with the data source.

[Visual Basic]
Overridable Public ReadOnly Property IsSynchronized As Boolean
[C#]
public bool IsSynchronized {virtual get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;

Property Value

true if the collection is synchonized with the data source, otherwise false.

Remarks

IsSynchronized is always false.

See Also

SQLErrors Class | SQLErrors Members | System.Data.SQL Namespace


SQLErrors.Item

Gets the error at the specified index.

[C#] In C#, this member is the indexer for the SQLErrors class.

[Visual Basic]
Public Default ReadOnly Property Item( _
   ByVal index As Integer _
) As SQLError
[C#]
public SQLError this[
   int index
] {get;}
[C++]
public: __property SQLError* get_Item(
   int index
);
[JScript]
returnValue = SQLErrorsObject.Item(index);
-or-
returnValue = SQLErrorsObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
the zero-based index of the error to retrieve.

Parameters [Visual Basic, C#, C++]

index
the zero-based index of the error to retrieve.

Property Value

A SQLError that contains the error at the specified index.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | index parameter outside of array bounds

Example [Visual Basic]

The following example uses the property to get the last error from the collection.

[Visual Basic]

Function GetLastSQLError(sqlErrCollect As SQLErrors) As SQLError
   GetLastSQLError = sqlErrCollect[sqlErrCollect.Count - 1]
End Function

See Also

SQLErrors Class | SQLErrors Members | System.Data.SQL Namespace | Count


SQLErrors.SyncRoot

What purpose does this property serve?

[Visual Basic]
Overridable Public ReadOnly Property SyncRoot As Object
[C#]
public object SyncRoot {virtual get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;

See Also

SQLErrors Class | SQLErrors Members | System.Data.SQL Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLErrors Methods

The methods of the SQLErrors class are listed below. For a complete list of SQLErrors class members, see the SQLErrors Members topic.

Public:

CopyTo | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLErrors Class | System.Data.SQL Namespace


SQLErrors.CopyTo

[To be supplied.]

[Visual Basic]
Overridable Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
[C#]
public virtual void CopyTo(
   Array array,
   int index
);
[C++]
public: virtual void CopyTo(
   Array* array,
   int index
);
[JScript]
public function CopyTo(
   array : Array,
   index : int
);

Parameters

array
[To be supplied.]
index
[To be supplied.]

Example [Visual Basic]

The following example displays an array of all SQLError.

[Visual Basic]

Public Sub DumpAllErrors(sqlErrCollect As SQLErrors)
   Dim myTitle As String
   Dim myMsgBox As MessageBox
   Dim myErrors() As SQLError
   myTitle  = "Dump of all SQL Server Errors"
   myErrors = sqlErrCollect.All
   myMsgBox.Show myErrors, myTitle
End Sub

See Also

SQLErrors Class | SQLErrors Members | System.Data.SQL Namespace


SQLException Class

Thrown whenever an error from the SQL Server adapter is encountered.

Object
Exception
SystemException
SQLException

[Visual Basic]
Public Class SQLException
   Inherits SystemException
[C#]
public class SQLException : SystemException
[C++]
public __gc class SQLException : public SystemException
[JScript]
public class SQLException extends SystemException

Remarks

This class is created whenever the SQL Server adapter encounters a situation that it cannot handle. It always contains at least one instance of SQLError.

Requirements

Namespace: System.Data.SQL

Assembly: System.Data.dll

Example [Visual Basic]

The following example displays some of the values of each error collected in a window.

[Visual Basic]

Private Sub ShowAllSQLErrors()
   Dim myConnection As String
   Dim mySelect As String
   Dim dataSet As New DataSet
   Dim sqlDataSetComm As New SQLDataSetCommand
   myConnection = "user id=sa;password=;database=northwind;" _
       + "server=mySQL;"
   mySelect = "SELECT * FROM Categories ORDER BY CategoryID"
   Try
      Set sqlDataSetComm = SQLDataSetCommand(mySelect, myConnection)
      sqlDataSetComm.FillDataSet(dataSet)
   Catch (SQLException SQLExcept)
      Dim SQLErr As New SQLError
      For Each SQLErr In SQLExcept.Errors
         ShowSQLError(SQLErr)
      Next
   End Try
End Sub
Private Sub ShowSQLError(sqlServerErr2 As SQLServerError)
   Dim myMessage As String
   Dim myTitle As String
   Dim myMsgBox As MessageBox
   myMessage = "Error " + sqlServerErr2.Number _
   + " on Server " + sqlServerErr2.Server + ": " _
   + sqlServerErr2.Message + " on Line " _
   + sqlServerErr2.LineNumber
   myTitle  = "SQL Server Error"
   myMsgBox.Show myMessage, myTitle
End Sub

See Also

SQLException Members | System.Data.SQL Namespace | SQLError | SQLErrors


SQLException Members

Public:

Properties

Class | Gets the severity level of the error returned from the SQL Server adapter.
Errors | Gets all errors generated by the SQL Server adapter.
HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
LineNumber | Gets the line number that the SQL Server error occurred on.
Message | Gets the error message that was generated from the SQL Server adapter.
Number | Gets the error code returned from the SQL Server adapter.
Procedure | Gets the name of the procedure that the SQL Server error occurred in.
Server | Gets the name of the database server the error occurred on.
Source | Gets the line of source that generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
State | Gets the error state number returned from the SQL Server adapter.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

SQLException Class | System.Data.SQL Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLException Properties

The properties of the SQLException class are listed below. For a complete list of SQLException class members, see the SQLException Members topic.

Public:

Class | Gets the severity level of the error returned from the SQL Server adapter.
Errors | Gets all errors generated by the SQL Server adapter.
HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
LineNumber | Gets the line number that the SQL Server error occurred on.
Message | Gets the error message that was generated from the SQL Server adapter.
Number | Gets the error code returned from the SQL Server adapter.
Procedure | Gets the name of the procedure that the SQL Server error occurred in.
Server | Gets the name of the database server the error occurred on.
Source | Gets the line of source that generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
State | Gets the error state number returned from the SQL Server adapter.
TargetSite (inherited from Exception) | [To be supplied.]

See Also

SQLException Class | System.Data.SQL Namespace


SQLException.Class

Gets the severity level of the error returned from the SQL Server adapter.

[Visual Basic]
Public ReadOnly Property Class As Byte
[C#]
public byte Class {get;}
[C++]
public: __property unsigned char get_Class();
[JScript]
public function get Class() : Byte;

Property Value

The severity of the error.

Remarks

This is a wrapper for the Class property of the first SQLError in the Errors property.

See Also

SQLException Class | SQLException Members | System.Data.SQL Namespace | Number | Source | State | Server | Message | Procedure | LineNumber


SQLException.Errors

Gets all errors generated by the SQL Server adapter.

[Visual Basic]
Public ReadOnly Property Errors As SQLErrors
[C#]
public SQLErrors Errors {get;}
[C++]
public: __property SQLErrors* get_Errors();
[JScript]
public function get Errors() : SQLErrors;

Property Value

The collected instances of the SQLError class. The SQLErrors class always contains at least one instance of the SQLError class.

Remarks

This is a wrapper for SQLErrors.

See Also

SQLException Class | SQLException Members | System.Data.SQL Namespace | SQLErrors | SQLError


SQLException.LineNumber

Gets the line number that the SQL Server error occurred on.

[Visual Basic]
Public ReadOnly Property LineNumber As Integer
[C#]
public int LineNumber {get;}
[C++]
public: __property int get_LineNumber();
[JScript]
public function get LineNumber() : int;

Property Value

The line number.

Remarks

This is a wrapper for the LineNumber property of the first SQLError in the Errors property.

See Also

SQLException Class | SQLException Members | System.Data.SQL Namespace | Number | Source | State | Class | Server | Message | Procedure


SQLException.Message

Gets the error message that was generated from the SQL Server adapter.

[Visual Basic]
Overridable Public ReadOnly Property Message As String
[C#]
public string Message {override get;}
[C++]
public: __property virtual String* get_Message();
[JScript]
public function get Message() : String;

Property Value

The generated error message.

Remarks

This is a wrapper for the Message property of the first SQLError in the Errors property.

See Also

SQLException Class | SQLException Members | System.Data.SQL Namespace | Number | State | Source | Class | Server | Procedure | LineNumber


SQLException.Number

Gets the error code returned from the SQL Server adapter.

[Visual Basic]
Public ReadOnly Property Number As Integer
[C#]
public int Number {get;}
[C++]
public: __property int get_Number();
[JScript]
public function get Number() : int;

Property Value

The error code.

Remarks

This is a wrapper for the Number property of the first SQLError in the Errors property.

See Also

SQLException Class | SQLException Members | System.Data.SQL Namespace | State | Class | Source | Server | Message | Procedure | LineNumber


SQLException.Procedure

Gets the name of the procedure that the SQL Server error occurred in.

[Visual Basic]
Public ReadOnly Property Procedure As String
[C#]
public string Procedure {get;}
[C++]
public: __property String* get_Procedure();
[JScript]
public function get Procedure() : String;

Property Value

The name of the procedure.

Remarks

This is a wrapper for the Procedure property of the first SQLError in the Errors property.

See Also

SQLException Class | SQLException Members | System.Data.SQL Namespace | Number | State | Class | Server | Source | Message | LineNumber


SQLException.Server

Gets the name of the database server the error occurred on.

[Visual Basic]
Public ReadOnly Property Server As String
[C#]
public string Server {get;}
[C++]
public: __property String* get_Server();
[JScript]
public function get Server() : String;

Property Value

The name of the database server.

Remarks

This is a wrapper for the Server property of the first SQLError in the Errors property.

See Also

SQLException Class | SQLException Members | System.Data.SQL Namespace | Number | State | Source | Class | Message | Procedure | LineNumber


SQLException.Source

Gets the line of source that generated the error.

[Visual Basic]
Overridable Public ReadOnly Property Source As String
[C#]
public string Source {override get;}
[C++]
public: __property virtual String* get_Source();
[JScript]
public function get Source() : String;

Property Value

The line of source that generated the error.

Remarks

This is a wrapper for the Source property of the first SQLError in the Errors property.

See Also

SQLException Class | SQLException Members | System.Data.SQL Namespace | Number | State | Class | Server | Message | Procedure | LineNumber


SQLException.State

Gets the error state number returned from the SQL Server adapter.

[Visual Basic]
Public ReadOnly Property State As Byte
[C#]
public byte State {get;}
[C++]
public: __property unsigned char get_State();
[JScript]
public function get State() : Byte;

Property Value

The error state, which identifies the source from which the error was issued (if the error can be issued from more than one place).

Remarks

This is a wrapper for the State property of the first SQLError in the Errors property.

See Also

SQLException Class | SQLException Members | System.Data.SQL Namespace | Number | Class | Source | Server | Message | Procedure | LineNumber


SQLInfoMessageEventArgs Class

[To be supplied.]

Object
EventArgs
SQLInfoMessageEventArgs

[Visual Basic]
Public Class SQLInfoMessageEventArgs
   Inherits EventArgs
[C#]
public class SQLInfoMessageEventArgs : EventArgs
[C++]
public __gc class SQLInfoMessageEventArgs : public EventArgs
[JScript]
public class SQLInfoMessageEventArgs extends EventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQL

Assembly: System.Data.dll

See Also

SQLInfoMessageEventArgs Members | System.Data.SQL Namespace


SQLInfoMessageEventArgs Members

Public:

Properties

Errors | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLInfoMessageEventArgs Class | System.Data.SQL Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLInfoMessageEventArgs Properties

The properties of the SQLInfoMessageEventArgs class are listed below. For a complete list of SQLInfoMessageEventArgs class members, see the SQLInfoMessageEventArgs Members topic.

Public:

Errors | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.

See Also

SQLInfoMessageEventArgs Class | System.Data.SQL Namespace


SQLInfoMessageEventArgs.Errors

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Errors As SQLErrors
[C#]
public SQLErrors Errors {get;}
[C++]
public: __property SQLErrors* get_Errors();
[JScript]
public function get Errors() : SQLErrors;

See Also

SQLInfoMessageEventArgs Class | SQLInfoMessageEventArgs Members | System.Data.SQL Namespace


SQLParameter Class

Represents a parameter to an SQLCommand and, optionally, its mapping to DataSet columns.

Object
SQLParameter

[Visual Basic]
Public Class SQLParameter
   Implements IDataParameter, ICloneable
[C#]
public class SQLParameter : IDataParameter, ICloneable
[C++]
public __gc class SQLParameter : public IDataParameter, ICloneable
[JScript]
public class SQLParameter implements IDataParameter, ICloneable

Remarks

Parameter names are case-insensitive.

Requirements

Namespace: System.Data.SQL

Assembly: System.Data.dll

Example [C#]

The following example sets multiple instances of SQLParameter through the SQLParameters collection within the SQLDataSetCommand. These parameters are used to map the data within the DataSet to columns within the data source.

[C#]

private DataSet InitializeMyDataSet() {
   // creates the table and its columns for the DataSet
   DataSet newData = new DataSet();
   DataTable newTable = newData.Tables.Add("Catagories");

   // add Columns to table
   newTable.Columns.Add("CategoryID",typeof(Int32));
   newTable.Columns.Add("CategoryName", typeof(String));
   newTable.Columns.Add("Description", typeof(String));
   newTable.Columns.Add("Picture",typeof(Byte[]));
   return newData;
}

public void AccessToSQLServer() {
   // set Access connection and select strings
   const string strAccessConn = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=NWIND_RW.MDB";
   const string strAccessSelect = "SELECT * FROM Categories ORDER BY CategoryID";
   // set SQL Server connection and insert strings
   const string strSQLServerConn = "Data Source=VBsql7;Initial Catalog=Northwind;User ID=sa;Password=;";
   const string strSQLServerInsert = "INSERT INTO Categories(CategoryName, Description, Picture) Values(@CategoryName,@Description,@Picture)";
   // create my DataSet
   DataSet myDataSet = InitializeMyDataSet();
   // create my Access objects
   ADOConnection myAccessConn = new ADOConnection(strAccessConn);
   ADODataSetCommand myAccessDataSetCmd = new ADODataSetCommand();
   myAccessDataSetCmd.SelectCommand = new ADOCommand(strAccessSelect,myAccessConn);
   // create my SQL Server objects
   SQLConnection mySQLConn = new SQLConnection(strSQLServerConn);
   SQLDataSetCommand mySQLDataSetCmd = new SQLDataSetCommand();
   mySQLDataSetCmd.InsertCommand = new SQLCommand(strSQLServerInsert,mySQLConn);
   // fill myDataSet with data from Access
   myAccessConn.Open();
   try {
      myAccessDataSetCmd.FillDataSet(myDataSet,"table");
   }
   finally {
      myAccessConn.Close();
   }

   // update SQL Server with data from the DataSet
   mySQLConn.Open();
   try {
      mySQLDataSetCmd.InsertCommand.Parameters.Add("CategoryName", typeof(String));
      mySQLDataSetCmd.InsertCommand.Parameters.Add("Description", typeof(String));
      mySQLDataSetCmd.InsertCommand.Parameters.Add("Picture", typeof(Byte[]));
      mySQLDataSetCmd.InsertCommand.Parameters[0].SourceColumn = "CategoryName";
      mySQLDataSetCmd.InsertCommand.Parameters[1].SourceColumn = "Description";
      mySQLDataSetCmd.InsertCommand.Parameters[2].SourceColumn = "Picture";
      mySQLDataSetCmd.Update(myDataSet,"table");
   }
   finally {
      mySQLConn.Close();
   }
}

See Also

SQLParameter Members | System.Data.SQL Namespace


SQLParameter Members

Public:

Constructor

SQLParameter Constructor Overloaded. Initializes a new instance of the SQLParameter class.

Properties

DatabaseType | Gets or sets the native data type.
DataType | Gets or sets the Type of the parameter.
Direction | Gets or sets whether the parameter is input-only, output-only, or bidirectional.
IsNullable | Gets or sets whether the parameter accepts nulls.
Offset | Gets or sets the offset to the Value.
ParameterName | Gets or sets the name of the SQLParameter.
Parent | Gets the reference to the SQLParameters collection that is the parent of this instance.
Precision | Gets or sets the maximum number of digits used to represent the Value.
Scale | Gets or sets the number of decimal places to which Value is resolved.
Size | Gets or sets the maximum size of the field.
SourceColumn | Gets or sets the name of the source column mapped to the DataSet and used for loading or returning the Value.
SourceVersion | Gets or sets the DataRowVersion to use when loading Value.
Value | Gets or sets the value of the parameter.

Methods

Clone | Creates a new instance of this SQLParameter object.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Returns a string containing the ParameterName.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLParameter Class | System.Data.SQL Namespace


SQLParameter Constructor

Initializes a new instance of the SQLParameter class.

Overload List

Initializes a new instance of the SQLParameter class. This is the default constructor.

[Visual Basic] Overloads Public Sub New()
[C#] public SQLParameter();
[C++] public: SQLParameter();
[JScript] public function SQLParameter();

Initializes a new instance of the SQLParameter class.

[Visual Basic] Overloads Public Sub New(String, SQLDataType, Integer, ParameterDirection, Byte, Byte, String, DataRowVersion, Object)
[C#] public SQLParameter(String, SQLDataType, int, ParameterDirection, byte, byte, String, DataRowVersion, Object);
[C++] public: SQLParameter(String*, SQLDataType, int, ParameterDirection, unsigned char, unsigned char, String*, DataRowVersion, Object);
[JScript] public function SQLParameter(String, SQLDataType, int, ParameterDirection, Byte, Byte, String, DataRowVersion, Object);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, SQLDataType, Integer, ParameterDirection, Boolean, Byte, Byte, String, DataRowVersion, Object)
[C#] public SQLParameter(String, SQLDataType, int, ParameterDirection, bool, byte, byte, String, DataRowVersion, Object);
[C++] public: SQLParameter(String*, SQLDataType, int, ParameterDirection, bool, unsigned char, unsigned char, String*, DataRowVersion, Object);
[JScript] public function SQLParameter(String, SQLDataType, int, ParameterDirection, Boolean, Byte, Byte, String, DataRowVersion, Object);

Initializes a new instance of the SQLParameter class.

[Visual Basic] Overloads Public Sub New(String, Type)
[C#] public SQLParameter(String, Type);
[C++] public: SQLParameter(String*, Type);
[JScript] public function SQLParameter(String, Type);

Initializes a new instance of the SQLParameter class.

[Visual Basic] Overloads Public Sub New(String, Type, Integer)
[C#] public SQLParameter(String, Type, int);
[C++] public: SQLParameter(String*, Type, int);
[JScript] public function SQLParameter(String, Type, int);

Initializes a new instance of the SQLParameter class.

[Visual Basic] Overloads Public Sub New(String, Type, Integer, String, DataRowVersion)
[C#] public SQLParameter(String, Type, int, String, DataRowVersion);
[C++] public: SQLParameter(String*, Type, int, String*, DataRowVersion);
[JScript] public function SQLParameter(String, Type, int, String, DataRowVersion);

Initializes a new instance of the SQLParameter class.

[Visual Basic] Overloads Public Sub New(String, SQLDataType)
[C#] public SQLParameter(String, SQLDataType);
[C++] public: SQLParameter(String*, SQLDataType);
[JScript] public function SQLParameter(String, SQLDataType);

Initializes a new instance of the SQLParameter class.

[Visual Basic] Overloads Public Sub New(String, SQLDataType, Integer)
[C#] public SQLParameter(String, SQLDataType, int);
[C++] public: SQLParameter(String*, SQLDataType, int);
[JScript] public function SQLParameter(String, SQLDataType, int);

Initializes a new instance of the SQLParameter class.

[Visual Basic] Overloads Public Sub New(String, SQLDataType, Integer, String, DataRowVersion)
[C#] public SQLParameter(String, SQLDataType, int, String, DataRowVersion);
[C++] public: SQLParameter(String*, SQLDataType, int, String*, DataRowVersion);
[JScript] public function SQLParameter(String, SQLDataType, int, String, DataRowVersion);

See Also

SQLParameter Class | SQLParameter Members | System.Data.SQL Namespace


SQLParameter Constructor ()

Initializes a new instance of the SQLParameter class. This is the default constructor.

[Visual Basic]
Overloads Public Sub New()
[C#]
public SQLParameter();
[C++]
public: SQLParameter();
[JScript]
public function SQLParameter();

See Also

SQLParameter Class | SQLParameter Members | System.Data.SQL Namespace | SQLParameter Constructor Overload List


SQLParameter Constructor (String, SQLDataType, Int32, ParameterDirection, Byte, Byte, String, DataRowVersion, Object)

Initializes a new instance of the SQLParameter class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal parameterName As String, _
   ByVal dbType As SQLDataType, _
   ByVal size As Integer, _
   ByVal direction As ParameterDirection, _
   ByVal precision As Byte, _
   ByVal scale As Byte, _
   ByVal sourceColumn As String, _
   ByVal sourceVersion As DataRowVersion, _
   ByVal value As Object _
)
[C#]
public SQLParameter(
   string parameterName,
   SQLDataType dbType,
   int size,
   ParameterDirection direction,
   byte precision,
   byte scale,
   string sourceColumn,
   DataRowVersion sourceVersion,
   object value
);
[C++]
public: SQLParameter(
   String* parameterName,
   SQLDataType dbType,
   int size,
   ParameterDirection direction,
   unsigned char precision,
   unsigned char scale,
   String* sourceColumn,
   DataRowVersion sourceVersion,
   Object* value
);
[JScript]
public function SQLParameter(
   parameterName : String,
   dbType : SQLDataType,
   size : int,
   direction : ParameterDirection,
   precision : Byte,
   scale : Byte,
   sourceColumn : String,
   sourceVersion : DataRowVersion,
   value : Object
);

Parameters

parameterName
The name of the column to map.
dbType
[To be supplied.]
size
[To be supplied.]
direction
[To be supplied.]
precision
[To be supplied.]
scale
[To be supplied.]
sourceColumn
[To be supplied.]
sourceVersion
[To be supplied.]
value
[To be supplied.]

See Also

SQLParameter Class | SQLParameter Members | System.Data.SQL Namespace | SQLParameter Constructor Overload List


SQLParameter Constructor (String, SQLDataType, Int32, ParameterDirection, Boolean, Byte, Byte, String, DataRowVersion, Object)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal parameterName As String, _
   ByVal dbType As SQLDataType, _
   ByVal size As Integer, _
   ByVal direction As ParameterDirection, _
   ByVal isNullable As Boolean, _
   ByVal precision As Byte, _
   ByVal scale As Byte, _
   ByVal sourceColumn As String, _
   ByVal sourceVersion As DataRowVersion, _
   ByVal value As Object _
)
[C#]
public SQLParameter(
   string parameterName,
   SQLDataType dbType,
   int size,
   ParameterDirection direction,
   bool isNullable,
   byte precision,
   byte scale,
   string sourceColumn,
   DataRowVersion sourceVersion,
   object value
);
[C++]
public: SQLParameter(
   String* parameterName,
   SQLDataType dbType,
   int size,
   ParameterDirection direction,
   bool isNullable,
   unsigned char precision,
   unsigned char scale,
   String* sourceColumn,
   DataRowVersion sourceVersion,
   Object* value
);
[JScript]
public function SQLParameter(
   parameterName : String,
   dbType : SQLDataType,
   size : int,
   direction : ParameterDirection,
   isNullable : Boolean,
   precision : Byte,
   scale : Byte,
   sourceColumn : String,
   sourceVersion : DataRowVersion,
   value : Object
);

Parameters

parameterName
[To be supplied.]
dbType
[To be supplied.]
size
[To be supplied.]
direction
[To be supplied.]
isNullable
[To be supplied.]
precision
[To be supplied.]
scale
[To be supplied.]
sourceColumn
[To be supplied.]
sourceVersion
[To be supplied.]
value
[To be supplied.]

See Also

SQLParameter Class | SQLParameter Members | System.Data.SQL Namespace | SQLParameter Constructor Overload List


SQLParameter Constructor (String, Type)

Initializes a new instance of the SQLParameter class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal parameterName As String, _
   ByVal type As Type _
)
[C#]
public SQLParameter(
   string parameterName,
   Type type
);
[C++]
public: SQLParameter(
   String* parameterName,
   Type* type
);
[JScript]
public function SQLParameter(
   parameterName : String,
   type : Type
);

Parameters

parameterName
The name of the column to map.
type
The Type of the parameter.

Exceptions

Exception Type | Condition
ParameterReqFixedSize | A fixed Size is required for this Type of parameter.

Remarks

The size is inferred from the value.

See Also

SQLParameter Class | SQLParameter Members | System.Data.SQL Namespace | SQLParameter Constructor Overload List


SQLParameter Constructor (String, Type, Int32)

Initializes a new instance of the SQLParameter class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal parameterName As String, _
   ByVal type As Type, _
   ByVal size As Integer _
)
[C#]
public SQLParameter(
   string parameterName,
   Type type,
   int size
);
[C++]
public: SQLParameter(
   String* parameterName,
   Type* type,
   int size
);
[JScript]
public function SQLParameter(
   parameterName : String,
   type : Type,
   size : int
);

Parameters

parameterName
The name of the column to map.
type
The Type of the parameter.
size
The width of the column.

See Also

SQLParameter Class | SQLParameter Members | System.Data.SQL Namespace | SQLParameter Constructor Overload List


SQLParameter Constructor (String, Type, Int32, String, DataRowVersion)

Initializes a new instance of the SQLParameter class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal parameterName As String, _
   ByVal type As Type, _
   ByVal size As Integer, _
   ByVal sourceColumn As String, _
   ByVal sourceVersion As DataRowVersion _
)
[C#]
public SQLParameter(
   string parameterName,
   Type type,
   int size,
   string sourceColumn,
   DataRowVersion sourceVersion
);
[C++]
public: SQLParameter(
   String* parameterName,
   Type* type,
   int size,
   String* sourceColumn,
   DataRowVersion sourceVersion
);
[JScript]
public function SQLParameter(
   parameterName : String,
   type : Type,
   size : int,
   sourceColumn : String,
   sourceVersion : DataRowVersion
);

Parameters

parameterName
The name of the column to map.
type
The Type of the parameter.
size
The width of the column.
sourceColumn
The name of the source column.
sourceVersion
One of the DataRowVersion values.

See Also

SQLParameter Class | SQLParameter Members | System.Data.SQL Namespace | SQLParameter Constructor Overload List


SQLParameter Constructor (String, SQLDataType)

Initializes a new instance of the SQLParameter class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal parameterName As String, _
   ByVal dbType As SQLDataType _
)
[C#]
public SQLParameter(
   string parameterName,
   SQLDataType dbType
);
[C++]
public: SQLParameter(
   String* parameterName,
   SQLDataType dbType
);
[JScript]
public function SQLParameter(
   parameterName : String,
   dbType : SQLDataType
);

Parameters

parameterName
The name of the column to map.
dbType
One of the SQLDataType values.

Exceptions

Exception Type | Condition
ParameterReqFixedSize | A fixed Size is required for this Type of parameter.

Remarks

The type and size are inferred from the value.

See Also

SQLParameter Class | SQLParameter Members | System.Data.SQL Namespace | SQLParameter Constructor Overload List


SQLParameter Constructor (String, SQLDataType, Int32)

Initializes a new instance of the SQLParameter class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal parameterName As String, _
   ByVal dbType As SQLDataType, _
   ByVal size As Integer _
)
[C#]
public SQLParameter(
   string parameterName,
   SQLDataType dbType,
   int size
);
[C++]
public: SQLParameter(
   String* parameterName,
   SQLDataType dbType,
   int size
);
[JScript]
public function SQLParameter(
   parameterName : String,
   dbType : SQLDataType,
   size : int
);

Parameters

parameterName
The name of the column to map.
dbType
One of the SQLDataType values.
size
The width of the column.

Remarks

The type is inferred from the value.

See Also

SQLParameter Class | SQLParameter Members | System.Data.SQL Namespace | SQLParameter Constructor Overload List


SQLParameter Constructor (String, SQLDataType, Int32, String, DataRowVersion)

Initializes a new instance of the SQLParameter class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal parameterName As String, _
   ByVal dbType As SQLDataType, _
   ByVal size As Integer, _
   ByVal sourceColumn As String, _
   ByVal sourceVersion As DataRowVersion _
)
[C#]
public SQLParameter(
   string parameterName,
   SQLDataType dbType,
   int size,
   string sourceColumn,
   DataRowVersion sourceVersion
);
[C++]
public: SQLParameter(
   String* parameterName,
   SQLDataType dbType,
   int size,
   String* sourceColumn,
   DataRowVersion sourceVersion
);
[JScript]
public function SQLParameter(
   parameterName : String,
   dbType : SQLDataType,
   size : int,
   sourceColumn : String,
   sourceVersion : DataRowVersion
);

Parameters

parameterName
The name of the column to map.
dbType
One of the SQLDataType values.
size
The width of the column.
sourceColumn
The name of the source column.
sourceVersion
One of the DataRowVersion values.

Remarks

The type is inferred from the value.

See Also

SQLParameter Class | SQLParameter Members | System.Data.SQL Namespace | SQLParameter Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLParameter Properties

The properties of the SQLParameter class are listed below. For a complete list of SQLParameter class members, see the SQLParameter Members topic.

Public:

DatabaseType | Gets or sets the native data type.
DataType | Gets or sets the Type of the parameter.
Direction | Gets or sets whether the parameter is input-only, output-only, or bidirectional.
IsNullable | Gets or sets whether the parameter accepts nulls.
Offset | Gets or sets the offset to the Value.
ParameterName | Gets or sets the name of the SQLParameter.
Parent | Gets the reference to the SQLParameters collection that is the parent of this instance.
Precision | Gets or sets the maximum number of digits used to represent the Value.
Scale | Gets or sets the number of decimal places to which Value is resolved.
Size | Gets or sets the maximum size of the field.
SourceColumn | Gets or sets the name of the source column mapped to the DataSet and used for loading or returning the Value.
SourceVersion | Gets or sets the DataRowVersion to use when loading Value.
Value | Gets or sets the value of the parameter.

See Also

SQLParameter Class | System.Data.SQL Namespace


SQLParameter.DatabaseType

Gets or sets the native data type.

[Visual Basic]
Public Property DatabaseType As SQLDataType
[C#]
public SQLDataType DatabaseType {get; set;}
[C++]
public: __property SQLDataType get_DatabaseType();
public: __property void set_DatabaseType(SQLDataType);
[JScript]
public function get DatabaseType() : SQLDataType;
public function set DatabaseType(SQLDataType);

Property Value

One of the SQLDataType values. The default is VarChar.

See Also

SQLParameter Class | SQLParameter Members | System.Data.SQL Namespace


SQLParameter.DataType

Gets or sets the Type of the parameter.

[Visual Basic]
Overridable Public Property DataType As Type
[C#]
public Type DataType {virtual get; set;}
[C++]
public: __property virtual Type* get_DataType();
public: __property void set_DataType(Type*);
[JScript]
public function get DataType() : Type;
public function set DataType(Type);

Property Value

The Type of the parameter.

See Also

SQLParameter Class | SQLParameter Members | System.Data.SQL Namespace


SQLParameter.Direction

Gets or sets whether the parameter is input-only, output-only, or bidirectional.

[Visual Basic]
Overridable Public Property Direction As ParameterDirection
[C#]
public ParameterDirection Direction {virtual get; set;}
[C++]
public: __property virtual ParameterDirection get_Direction();
public: __property void set_Direction(ParameterDirection);
[JScript]
public function get Direction() : ParameterDirection;
public function set Direction(ParameterDirection);

Property Value

One of the ParameterDirection values. The default is Input.

Exceptions

Exception Type | Condition
InvalidParameterDirection | The value set is not one of the ParameterDirection values.

See Also

SQLParameter Class | SQLParameter Members | System.Data.SQL Namespace


SQLParameter.IsNullable

Gets or sets whether the parameter accepts nulls.

[Visual Basic]
Overridable Public Property IsNullable As Boolean
[C#]
public bool IsNullable {virtual get; set;}
[C++]
public: __property virtual bool get_IsNullable();
public: __property void set_IsNullable(bool);
[JScript]
public function get IsNullable() : Boolean;
public function set IsNullable(Boolean);

Property Value

true if nulls are accepted, otherwise false. The default is false.

See Also

SQLParameter Class | SQLParameter Members | System.Data.SQL Namespace


SQLParameter.Offset

Gets or sets the offset to the Value.

[Visual Basic]
Public Property Offset As Integer
[C#]
public int Offset {get; set;}
[C++]
public: __property int get_Offset();
public: __property void set_Offset(int);
[JScript]
public function get Offset() : int;
public function set Offset(int);

Property Value

The offset to the Value.

Remarks

This property is used for binary, string, and varnumeric types. Count in bytes for binary, non-Unicode strings, and varnumeric types. Count in characters for unicode strings. The count does not include null terminating character for strings.

See Also

SQLParameter Class | SQLParameter Members | System.Data.SQL Namespace


SQLParameter.ParameterName

Gets or sets the name of the SQLParameter.

[Visual Basic]
Overridable Public Property ParameterName As String
[C#]
public string ParameterName {virtual get; set;}
[C++]
public: __property virtual String* get_ParameterName();
public: __property void set_ParameterName(String*);
[JScript]
public function get ParameterName() : String;
public function set ParameterName(String);

Property Value

The name the SQLParameter.

See Also

SQLParameter Class | SQLParameter Members | System.Data.SQL Namespace


SQLParameter.Parent

Gets the reference to the SQLParameters collection that is the parent of this instance.

[Visual Basic]
Public ReadOnly Property Parent As SQLParameters
[C#]
public SQLParameters Parent {get;}
[C++]
public: __property SQLParameters* get_Parent();
[JScript]
public function get Parent() : SQLParameters;

Property Value

The reference to the SQLParameters collection that is the parent of this instance.

See Also

SQLParameter Class | SQLParameter Members | System.Data.SQL Namespace


SQLParameter.Precision

Gets or sets the maximum number of digits used to represent the Value.

[Visual Basic]
Public Property Precision As Byte
[C#]
public byte Precision {get; set;}
[C++]
public: __property unsigned char get_Precision();
public: __property void set_Precision(unsigned char);
[JScript]
public function get Precision() : Byte;
public function set Precision(Byte);

Property Value

The maximum number of digits used to represent the Value. The default value is 0.

Remarks

used for VarNumeric fields.

See Also

SQLParameter Class | SQLParameter Members | System.Data.SQL Namespace


SQLParameter.Scale

Gets or sets the number of decimal places to which Value is resolved.

[Visual Basic]
Public Property Scale As Byte
[C#]
public byte Scale {get; set;}
[C++]
public: __property unsigned char get_Scale();
public: __property void set_Scale(unsigned char);
[JScript]
public function get Scale() : Byte;
public function set Scale(Byte);

Property Value

The number of decimal places to which Value is resolved. The default is 0.

Remarks

used for VarNumeric fields

See Also

SQLParameter Class | SQLParameter Members | System.Data.SQL Namespace


SQLParameter.Size

Gets or sets the maximum size of the field.

[Visual Basic]
Public Property Size As Integer
[C#]
public int Size {get; set;}
[C++]
public: __property int get_Size();
public: __property void set_Size(int);
[JScript]
public function get Size() : int;
public function set Size(int);

Property Value

The maximum size of the field.

Remarks

This property is used for binary, string, and varnumeric types. Count in bytes for binary, non-Unicode strings, and varnumeric types. Count in characters for unicode strings. The count does not include null terminating character for strings.

See Also

SQLParameter Class | SQLParameter Members | System.Data.SQL Namespace


SQLParameter.SourceColumn

Gets or sets the name of the source column mapped to the DataSet and used for loading or returning the Value.

[Visual Basic]
Overridable Public Property SourceColumn As String
[C#]
public string SourceColumn {virtual get; virtual set;}
[C++]
public: __property virtual String* get_SourceColumn();
public: __property virtual void set_SourceColumn(String*);
[JScript]
public function get SourceColumn() : String;
public function set SourceColumn(String);

Property Value

The name of the source column mapped to the DataSet and used for loading or returning the Value.

See Also

SQLParameter Class | SQLParameter Members | System.Data.SQL Namespace


SQLParameter.SourceVersion

Gets or sets the DataRowVersion to use when loading Value.

[Visual Basic]
Overridable Public Property SourceVersion As DataRowVersion
[C#]
public DataRowVersion SourceVersion {virtual get; virtual set;}
[C++]
public: __property virtual DataRowVersion get_SourceVersion();
public: __property virtual void set_SourceVersion(DataRowVersion);
[JScript]
public function get SourceVersion() : DataRowVersion;
public function set SourceVersion(DataRowVersion);

Property Value

One of the DataRowVersion values. The default is Current.

Exceptions

Exception Type | Condition
InvalidDataRowVersion | The value set is not one of the DataRowVersion values.

Remarks

This property is used by the UpdateCommand during the Update to determine if the original or current value is used for a parameter value. This allows primary keys to be updated. This property is ignored by the InsertCommand or DeleteCommand.

See Also

SQLParameter Class | SQLParameter Members | System.Data.SQL Namespace


SQLParameter.Value

Gets or sets the value of the parameter.

[Visual Basic]
Overridable Public Property Value As Object
[C#]
public object Value {virtual get; virtual set;}
[C++]
public: __property virtual Object* get_Value();
public: __property virtual void set_Value(Object*);
[JScript]
public function get Value() : Object;
public function set Value(Object);

Property Value

An Object that is the value of the parameter.

Remarks

This property is overwritten by Update. If IsInput is true and this SQLParameter has a DataSetColumn, the Value is queried by the Update method. if IsOuput is true and this SQLParameter has a DataSetColumn, use Convert.DBNull to pass a SQL NULL or use null to pass a SQL DEFAULT.

See Also

SQLParameter Class | SQLParameter Members | System.Data.SQL Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLParameter Methods

The methods of the SQLParameter class are listed below. For a complete list of SQLParameter class members, see the SQLParameter Members topic.

Public:

Clone | Creates a new instance of this SQLParameter object.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Returns a string containing the ParameterName.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLParameter Class | System.Data.SQL Namespace


SQLParameter.Clone

Creates a new instance of this SQLParameter object.

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

Return Value

A new SQLParameter that is a copy of this instance.

Remarks

Notes to Inheritors: When overriding Clone in a derived class, be sure to call the base class's Clone method.

See Also

SQLParameter Class | SQLParameter Members | System.Data.SQL Namespace


SQLParameter.ToString

Returns a string containing the ParameterName.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

A string containing the ParameterName.

See Also

SQLParameter Class | SQLParameter Members | System.Data.SQL Namespace


SQLParameterConverter Class

[To be supplied.]

Object
TypeConverter
SQLParameterConverter

[Visual Basic]
NotInheritable Public Class SQLParameterConverter
   Inherits TypeConverter
[C#]
public sealed class SQLParameterConverter : TypeConverter
[C++]
public __gc __sealed class SQLParameterConverter : public
   TypeConverter
[JScript]
public class SQLParameterConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQL

Assembly: System.Data.dll

See Also

SQLParameterConverter Members | System.Data.SQL Namespace


SQLParameterConverter Members

Public:

Constructor

SQLParameterConverter Constructor [To be supplied.]

Methods

CanConvertFrom (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the converter's native type.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text into an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given object to another type.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetProperties (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValues (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid (inherited from TypeConverter) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

SQLParameterConverter Class | System.Data.SQL Namespace


SQLParameterConverter Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public SQLParameterConverter();
[C++]
public: SQLParameterConverter();
[JScript]
public function SQLParameterConverter();

See Also

SQLParameterConverter Class | SQLParameterConverter Members | System.Data.SQL Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLParameterConverter Methods

The methods of the SQLParameterConverter class are listed below. For a complete list of SQLParameterConverter class members, see the SQLParameterConverter Members topic.

Public:

CanConvertFrom (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the converter's native type.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text into an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given object to another type.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetProperties (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValues (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid (inherited from TypeConverter) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

SQLParameterConverter Class | System.Data.SQL Namespace


SQLParameterConverter.GetPersistInfo

[To be supplied.]

[Visual Basic]
Overrides Public Function GetPersistInfo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal obj As Object _
) As PersistInfo
[C#]
public override PersistInfo GetPersistInfo(
   ITypeDescriptorContext context,
   object obj
);
[C++]
public: override PersistInfo* GetPersistInfo(
   ITypeDescriptorContext* context,
   Object* obj
);
[JScript]
public override function GetPersistInfo(
   context : ITypeDescriptorContext,
   obj : Object
) : PersistInfo;

Parameters

context
[To be supplied.]
obj
[To be supplied.]

See Also

SQLParameterConverter Class | SQLParameterConverter Members | System.Data.SQL Namespace


SQLParameterConverter.GetProperties

Retrieves the set of properties for this type. By default, a type has does not return any properties. An easy implementation of this method can just call TypeDescriptor.GetProperties for the correct data type.

[Visual Basic]
Overrides Public Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal attributes() As MemberAttribute _
) As PropertyDescriptorCollection
[C#]
public override PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value,
   MemberAttribute[] attributes
);
[C++]
public: override PropertyDescriptorCollection* GetProperties(
   ITypeDescriptorContext* context,
   Object* value,
   MemberAttribute* attributes[]
);
[JScript]
public override function GetProperties(
   context : ITypeDescriptorContext,
   value : Object,
   attributes : MemberAttribute[]
) : PropertyDescriptorCollection;

Parameters

context
A type descriptor through which additional context may be provided.
value
The value of the object to get the properties for.
attributes
[To be supplied.]

Return Value

The set of properties that should be exposed for this data type. If no properties should be exposed, thsi may return null. The default implementation always returns null.

See Also

SQLParameterConverter Class | SQLParameterConverter Members | System.Data.SQL Namespace


SQLParameterConverter.GetPropertiesSupported

Determines if this object supports properties. By default, this is false.

[Visual Basic]
Overrides Public Function GetPropertiesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
[C#]
public override bool GetPropertiesSupported(
   ITypeDescriptorContext context
);
[C++]
public: override bool GetPropertiesSupported(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetPropertiesSupported(
   context : ITypeDescriptorContext
) : Boolean;

Parameters

context
A type descriptor through which additional context may be provided.

Return Value

Returns true if GetProperties should be called to find the properties of this object.

See Also

SQLParameterConverter Class | SQLParameterConverter Members | System.Data.SQL Namespace


SQLParameters Class

Collects all parameters relevant to a SQLCommand and their mappings to DataSet columns.

Object
SQLParameters

[Visual Basic]
Public Class SQLParameters
   Implements IDataParameters, IList, ICollection, IEnumerable
[C#]
public class SQLParameters : IDataParameters, IList, ICollection,
   IEnumerable
[C++]
public __gc class SQLParameters : public IDataParameters, IList,
   ICollection, IEnumerable
[JScript]
public class SQLParameters implements IDataParameters, IList,
   ICollection, IEnumerable

Remarks

The number of the parameters in the collection must be equal to the number of placeholders within the command text or SQL Server will raise an error.

Requirements

Namespace: System.Data.SQL

Assembly: System.Data.dll

See Also

SQLParameters Members | System.Data.SQL Namespace


SQLParameters Members

Public:

Properties

All | Gets all instances of SQLParameter objects collected.
Count | Gets the number of parameters in the collection.
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the SQLParameters class.
Parent | Gets the reference to the SQLCommand that is the parent of this instance.

Methods

Add | Adds a SQLParameter to the SQLCommand when given the parameter.
Clear | Removes all items from the collection.
Contains | Overloaded. Indicates whether a parameter is in the collection.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | Overloaded. Returns the location of the SQLParameter within the collection.
Remove | Removes the SQLParameter from the collection given the value.
RemoveAt | Overloaded. Removes the SQLParameter from the collection.
ShouldPersistAll | Indicates whether parameters are persisting.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLParameters Class | System.Data.SQL Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLParameters Properties

The properties of the SQLParameters class are listed below. For a complete list of SQLParameters class members, see the SQLParameters Members topic.

Public:

All | Gets all instances of SQLParameter objects collected.
Count | Gets the number of parameters in the collection.
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the SQLParameters class.
Parent | Gets the reference to the SQLCommand that is the parent of this instance.

See Also

SQLParameters Class | System.Data.SQL Namespace


SQLParameters.All

Gets all instances of SQLParameter objects collected.

[Visual Basic]
Public Property All As SQLParameter ()
[C#]
public SQLParameter[] All {get; set;}
[C++]
public: __property SQLParameter* get_All();
public: __property void set_All(SQLParameter*[]);
[JScript]
public function get All() : SQLParameter[];
public function set All(SQLParameter[]);

Property Value

All instances of SQLParameter objects collected.

See Also

SQLParameters Class | SQLParameters Members | System.Data.SQL Namespace


SQLParameters.Count

Gets the number of parameters in the collection.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

Property Value

The number of parameters in the collection.

See Also

SQLParameters Class | SQLParameters Members | System.Data.SQL Namespace


SQLParameters.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the SQLParameters class.

Overload List

Gets the SQLParameter at the specified index.

[Visual Basic] Overloads Public Default Property Item(Integer) As SQLParameter
[C#] public SQLParameter this[int] {get; set;}
[C++] public: __property SQLParameter* get_Item(int);
public: __property void set_Item(int, SQLParameter*);
[JScript] SQLParameters.Item (int)

Gets the SQLParameter with the specified name.

[Visual Basic] Overloads Public Default Property Item(String) As SQLParameter
[C#] public SQLParameter this[String] {get; set;}
[C++] public: __property SQLParameter* get_Item(String*);
public: __property void set_Item(String*, SQLParameter*);
[JScript] SQLParameters.Item (String)

See Also

SQLParameters Class | SQLParameters Members | System.Data.SQL Namespace


SQLParameters.Item (Int32)

Gets the SQLParameter at the specified index.

[C#] In C#, this member is the indexer for the SQLParameters class.

[Visual Basic]
Overloads Public Default Property Item( _
   ByVal index As Integer _
) As SQLParameter
[C#]
public SQLParameter this[
   int index
] {get; set;}
[C++]
public: __property SQLParameter* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   SQLParameter*
);
[JScript]
returnValue = SQLParametersObject.Item(index);
SQLParametersObject.Item(index) = returnValue;
-or-
returnValue = SQLParametersObject(index);
SQLParametersObject(index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
The zero-based index of the parameter to retrieve.

Parameters [Visual Basic, C#, C++]

index
The zero-based index of the parameter to retrieve.

Property Value

The SQLParameter at the specified index.

Exceptions

Exception Type | Condition
ParametersMappingIndex | The specified index does not exist.

See Also

SQLParameters Class | SQLParameters Members | System.Data.SQL Namespace | SQLParameters.Item Overload List


SQLParameters.Item (String)

Gets the SQLParameter with the specified name.

[C#] In C#, this member is the indexer for the SQLParameters class.

[Visual Basic]
Overloads Public Default Property Item( _
   ByVal parameterName As String _
) As SQLParameter
[C#]
public SQLParameter this[
   string parameterName
] {get; set;}
[C++]
public: __property SQLParameter* get_Item(
   String* parameterName
);
public: __property void set_Item(
   String* parameterName,
   SQLParameter*
);
[JScript]
returnValue = SQLParametersObject.Item(parameterName);
SQLParametersObject.Item(parameterName) = returnValue;
-or-
returnValue = SQLParametersObject(parameterName);
SQLParametersObject(parameterName) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

parameterName
The name of the parameter to retrieve.

Parameters [Visual Basic, C#, C++]

parameterName
The name of the parameter to retrieve.

Property Value

The SQLParameter with the specified name or null if the parameter is not found.

Exceptions

Exception Type | Condition
ParametersSourceIndex | The specified name does not exist.

See Also

SQLParameters Class | SQLParameters Members | System.Data.SQL Namespace | SQLParameters.Item Overload List


SQLParameters.Parent

Gets the reference to the SQLCommand that is the parent of this instance.

[Visual Basic]
Public ReadOnly Property Parent As SQLCommand
[C#]
public SQLCommand Parent {get;}
[C++]
public: __property SQLCommand* get_Parent();
[JScript]
public function get Parent() : SQLCommand;

Property Value

The reference to the SQLCommand that is the parent of this instance.

See Also

SQLParameters Class | SQLParameters Members | System.Data.SQL Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLParameters Methods

The methods of the SQLParameters class are listed below. For a complete list of SQLParameters class members, see the SQLParameters Members topic.

Public:

Add | Adds a SQLParameter to the SQLCommand when given the parameter.
Clear | Removes all items from the collection.
Contains | Overloaded. Indicates whether a parameter is in the collection.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | Overloaded. Returns the location of the SQLParameter within the collection.
Remove | Removes the SQLParameter from the collection given the value.
RemoveAt | Overloaded. Removes the SQLParameter from the collection.
ShouldPersistAll | Indicates whether parameters are persisting.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLParameters Class | System.Data.SQL Namespace


SQLParameters.Add

Adds a SQLParameter to the SQLCommand when given the parameter.

[Visual Basic]
Public Function Add( _
   ByVal value As SQLParameter _
) As SQLParameter
[C#]
public SQLParameter Add(
   SQLParameter value
);
[C++]
public: SQLParameter* Add(
   SQLParameter* value
);
[JScript]
public function Add(
   value : SQLParameter
) : SQLParameter;

Parameters

value
The SQLParameter to be added.

Return Value

A reference to the new SQLParameter object.

Remarks

Notes to Inheritors: When overriding Add in a derived class, be sure to call the base class's Add method.

See Also

SQLParameters Class | SQLParameters Members | System.Data.SQL Namespace


SQLParameters.Clear

Removes all items from the collection.

[Visual Basic]
Overridable Public Sub Clear()
[C#]
public virtual void Clear();
[C++]
public: virtual void Clear();
[JScript]
public function Clear();

Remarks

Notes to Inheritors: When overriding Clear in a derived class, be sure to call the base class's Clear method.

See Also

SQLParameters Class | SQLParameters Members | System.Data.SQL Namespace


SQLParameters.Contains

Indicates whether a parameter is in the collection.

Overload List

Indicates whether a parameter is in the collection with a specified value.

[Visual Basic] Overloads Public Function Contains(Object) As Boolean
[C#] public bool Contains(Object);
[C++] public: bool Contains(Object*);
[JScript] public function Contains(Object) : Boolean;

Indicates whether a parameter is in the collection with a specified parameter name.

[Visual Basic] Overloads Public Function Contains(String) As Boolean
[C#] public bool Contains(String);
[C++] public: bool Contains(String*);
[JScript] public function Contains(String) : Boolean;

Indicates whether a parameter is in the collection at a specified index.

[Visual Basic] Overloads Public Function Contains(Integer) As Boolean
[C#] public bool Contains(int);
[C++] public: bool Contains(int);
[JScript] public function Contains(int) : Boolean;

See Also

SQLParameters Class | SQLParameters Members | System.Data.SQL Namespace


SQLParameters.Contains (Object)

Indicates whether a parameter is in the collection with a specified value.

[Visual Basic]
Overloads Public Function Contains( _
   ByVal value As Object _
) As Boolean
[C#]
public bool Contains(
   object value
);
[C++]
public: bool Contains(
   Object* value
);
[JScript]
public function Contains(
   value : Object
) : Boolean;

Parameters

value
An Object that is the Value of the parameter.

Return Value

true if the collection contains the parameter, otherwise false.

See Also

SQLParameters Class | SQLParameters Members | System.Data.SQL Namespace | SQLParameters.Contains Overload List


SQLParameters.Contains (String)

Indicates whether a parameter is in the collection with a specified parameter name.

[Visual Basic]
Overloads Public Function Contains( _
   ByVal value As String _
) As Boolean
[C#]
public bool Contains(
   string value
);
[C++]
public: bool Contains(
   String* value
);
[JScript]
public function Contains(
   value : String
) : Boolean;

Parameters

value
The name of the parameter to retrieve.

Return Value

true if the collection contains the parameter, otherwise false.

See Also

SQLParameters Class | SQLParameters Members | System.Data.SQL Namespace | SQLParameters.Contains Overload List


SQLParameters.Contains (Int32)

Indicates whether a parameter is in the collection at a specified index.

[Visual Basic]
Overloads Public Function Contains( _
   ByVal index As Integer _
) As Boolean
[C#]
public bool Contains(
   int index
);
[C++]
public: bool Contains(
   int index
);
[JScript]
public function Contains(
   index : int
) : Boolean;

Parameters

index
The zero-based index of the parameter.

Return Value

true if the collection contains the parameter, otherwise false.

See Also

SQLParameters Class | SQLParameters Members | System.Data.SQL Namespace | SQLParameters.Contains Overload List


SQLParameters.IndexOf

Returns the location of the SQLParameter within the collection.

Overload List

Returns the location of the SQLParameter within the collection given the value.

[Visual Basic] Overloads Public Function IndexOf(Object) As Integer
[C#] public int IndexOf(Object);
[C++] public: int IndexOf(Object*);
[JScript] public function IndexOf(Object) : int;

Returns the location of the SQLParameter within the collection given a specific parameter name.

[Visual Basic] Overloads Public Function IndexOf(String) As Integer
[C#] public int IndexOf(String);
[C++] public: int IndexOf(String*);
[JScript] public function IndexOf(String) : int;

See Also

SQLParameters Class | SQLParameters Members | System.Data.SQL Namespace


SQLParameters.IndexOf (Object)

Returns the location of the SQLParameter within the collection given the value.

[Visual Basic]
Overloads Public Function IndexOf( _
   ByVal parameter As Object _
) As Integer
[C#]
public int IndexOf(
   object parameter
);
[C++]
public: int IndexOf(
   Object* parameter
);
[JScript]
public function IndexOf(
   parameter : Object
) : int;

Parameters

parameter
An Object that is the Value of the parameter.

Return Value

The location of the SQLParameter within the collection.

See Also

SQLParameters Class | SQLParameters Members | System.Data.SQL Namespace | SQLParameters.IndexOf Overload List


SQLParameters.IndexOf (String)

Returns the location of the SQLParameter within the collection given a specific parameter name.

[Visual Basic]
Overloads Public Function IndexOf( _
   ByVal parameterName As String _
) As Integer
[C#]
public int IndexOf(
   string parameterName
);
[C++]
public: int IndexOf(
   String* parameterName
);
[JScript]
public function IndexOf(
   parameterName : String
) : int;

Parameters

parameterName
The name of the parameter to retrieve.

Return Value

The location of the SQLParameter within the collection.

See Also

SQLParameters Class | SQLParameters Members | System.Data.SQL Namespace | SQLParameters.IndexOf Overload List


SQLParameters.Remove

Removes the SQLParameter from the collection given the value.

[Visual Basic]
Public Sub Remove( _
   ByVal value As Object _
)
[C#]
public void Remove(
   object value
);
[C++]
public: void Remove(
   Object* value
);
[JScript]
public function Remove(
   value : Object
);

Parameters

value
An Object that is the Value of the parameter.

Exceptions

Exception Type | Condition
NotAnAdapterParameter | The parameter is not a SQLParameter.
ObjectNotInCollectionToRemove | The parameter does not exist.

See Also

SQLParameters Class | SQLParameters Members | System.Data.SQL Namespace


SQLParameters.RemoveAt

Removes the SQLParameter from the collection.

Overload List

Removes the SQLParameter from the collection given the parameter name.

[Visual Basic] Overloads Public Sub RemoveAt(String)
[C#] public void RemoveAt(String);
[C++] public: void RemoveAt(String*);
[JScript] public function RemoveAt(String);

Removes the SQLParameter from the collection given the specific index.

[Visual Basic] Overloads Overridable Public Sub RemoveAt(Integer)
[C#] public virtual void RemoveAt(int);
[C++] public: virtual void RemoveAt(int);
[JScript] public function RemoveAt(int);

See Also

SQLParameters Class | SQLParameters Members | System.Data.SQL Namespace


SQLParameters.RemoveAt (String)

Removes the SQLParameter from the collection given the parameter name.

[Visual Basic]
Overloads Public Sub RemoveAt( _
   ByVal value As String _
)
[C#]
public void RemoveAt(
   string value
);
[C++]
public: void RemoveAt(
   String* value
);
[JScript]
public function RemoveAt(
   value : String
);

Parameters

value
The name of the parameter to retrieve.

Exceptions

Exception Type | Condition
ParametersIndex | The specified value does not exist.

See Also

SQLParameters Class | SQLParameters Members | System.Data.SQL Namespace | SQLParameters.RemoveAt Overload List


SQLParameters.RemoveAt (Int32)

Removes the SQLParameter from the collection given the specific index.

[Visual Basic]
Overloads Overridable Public Sub RemoveAt( _
   ByVal index As Integer _
)
[C#]
public virtual void RemoveAt(
   int index
);
[C++]
public: virtual void RemoveAt(
   int index
);
[JScript]
public function RemoveAt(
   index : int
);

Parameters

index
The zero-based index of the parameter.

Return Value

(true if parameter was actually removed, else false)

Exceptions

Exception Type | Condition
ParametersMappingIndex | The specified index does not exist.

Remarks

Notes to Inheritors: When overriding RemoveAt in a derived class, be sure to call the base class's RemoveAt method.

See Also

SQLParameters Class | SQLParameters Members | System.Data.SQL Namespace | SQLParameters.RemoveAt Overload List


SQLParameters.ShouldPersistAll

Indicates whether parameters are persisting.

[Visual Basic]
Public Function ShouldPersistAll() As Boolean
[C#]
public bool ShouldPersistAll();
[C++]
public: bool ShouldPersistAll();
[JScript]
public function ShouldPersistAll() : Boolean;

Return Value

true if the parameters are persisting, otherwise false.

Remarks

If an SQLParameter exists within the collection, it will be persisted until removed or the collection is destroyed.

See Also

SQLParameters Class | SQLParameters Members | System.Data.SQL Namespace


SQLRowUpdatedEventArgs Class

[To be supplied.]

Object
EventArgs
RowUpdatedEventArgs
SQLRowUpdatedEventArgs

[Visual Basic]
Public Class SQLRowUpdatedEventArgs
   Inherits RowUpdatedEventArgs
[C#]
public class SQLRowUpdatedEventArgs : RowUpdatedEventArgs
[C++]
public __gc class SQLRowUpdatedEventArgs : public
   RowUpdatedEventArgs
[JScript]
public class SQLRowUpdatedEventArgs extends RowUpdatedEventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQL

Assembly: System.Data.dll

See Also

SQLRowUpdatedEventArgs Members | System.Data.SQL Namespace


SQLRowUpdatedEventArgs Members

Public:

Constructor

SQLRowUpdatedEventArgs Constructor [To be supplied.]

Properties

Command (inherited from RowUpdatedEventArgs) | [To be supplied.]
CommandType (inherited from RowUpdatedEventArgs) | [To be supplied.]
Errors (inherited from RowUpdatedEventArgs) | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
RecordsAffected (inherited from RowUpdatedEventArgs) | [To be supplied.]
Row (inherited from RowUpdatedEventArgs) | [To be supplied.]
Status (inherited from RowUpdatedEventArgs) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLRowUpdatedEventArgs Class | System.Data.SQL Namespace


SQLRowUpdatedEventArgs Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal row As DataRow, _
   ByVal command As DBCommand, _
   ByVal commandType As String _
)
[C#]
public SQLRowUpdatedEventArgs(
   DataRow row,
   DBCommand command,
   string commandType
);
[C++]
public: SQLRowUpdatedEventArgs(
   DataRow* row,
   DBCommand* command,
   String* commandType
);
[JScript]
public function SQLRowUpdatedEventArgs(
   row : DataRow,
   command : DBCommand,
   commandType : String
);

Parameters

row
[To be supplied.]
command
[To be supplied.]
commandType
[To be supplied.]

See Also

SQLRowUpdatedEventArgs Class | SQLRowUpdatedEventArgs Members | System.Data.SQL Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLRowUpdatedEventArgs Properties

The properties of the SQLRowUpdatedEventArgs class are listed below. For a complete list of SQLRowUpdatedEventArgs class members, see the SQLRowUpdatedEventArgs Members topic.

Public:

Command (inherited from RowUpdatedEventArgs) | [To be supplied.]
CommandType (inherited from RowUpdatedEventArgs) | [To be supplied.]
Errors (inherited from RowUpdatedEventArgs) | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
RecordsAffected (inherited from RowUpdatedEventArgs) | [To be supplied.]
Row (inherited from RowUpdatedEventArgs) | [To be supplied.]
Status (inherited from RowUpdatedEventArgs) | [To be supplied.]

See Also

SQLRowUpdatedEventArgs Class | System.Data.SQL Namespace


SQLRowUpdatedEventArgs.Command

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Command As SQLCommand
[C#]
public SQLCommand Command {new get;}
[C++]
public: __property SQLCommand* get_Command();
[JScript]
public function get Command() : SQLCommand;

See Also

SQLRowUpdatedEventArgs Class | SQLRowUpdatedEventArgs Members | System.Data.SQL Namespace


SQLRowUpdatedEventHandler Delegate

[To be supplied.]

[Visual Basic]
Public Delegate Sub SQLRowUpdatedEventHandler( _
   ByVal sender As Object, _
   ByVal e As SQLRowUpdatedEventArgs _
)
[C#]
public delegate void SQLRowUpdatedEventHandler(
   object sender,
   SQLRowUpdatedEventArgs e
);
[C++]
public __gc __delegate void SQLRowUpdatedEventHandler(
   Object* sender,
   SQLRowUpdatedEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the SQLRowUpdatedEventHandler delegate declaration.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQL

Assembly: System.Data.dll

See Also

System.Data.SQL Namespace


SQLRowUpdatingEventArgs Class

[To be supplied.]

Object
EventArgs
RowUpdatingEventArgs
SQLRowUpdatingEventArgs

[Visual Basic]
Public Class SQLRowUpdatingEventArgs
   Inherits RowUpdatingEventArgs
[C#]
public class SQLRowUpdatingEventArgs : RowUpdatingEventArgs
[C++]
public __gc class SQLRowUpdatingEventArgs : public
   RowUpdatingEventArgs
[JScript]
public class SQLRowUpdatingEventArgs extends RowUpdatingEventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQL

Assembly: System.Data.dll

See Also

SQLRowUpdatingEventArgs Members | System.Data.SQL Namespace


SQLRowUpdatingEventArgs Members

Public:

Constructor

SQLRowUpdatingEventArgs Constructor [To be supplied.]

Properties

Command (inherited from RowUpdatingEventArgs) | [To be supplied.]
CommandType (inherited from RowUpdatingEventArgs) | [To be supplied.]
Errors (inherited from RowUpdatingEventArgs) | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
Row (inherited from RowUpdatingEventArgs) | [To be supplied.]
Status (inherited from RowUpdatingEventArgs) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLRowUpdatingEventArgs Class | System.Data.SQL Namespace


SQLRowUpdatingEventArgs Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal row As DataRow, _
   ByVal command As DBCommand, _
   ByVal commandType As String _
)
[C#]
public SQLRowUpdatingEventArgs(
   DataRow row,
   DBCommand command,
   string commandType
);
[C++]
public: SQLRowUpdatingEventArgs(
   DataRow* row,
   DBCommand* command,
   String* commandType
);
[JScript]
public function SQLRowUpdatingEventArgs(
   row : DataRow,
   command : DBCommand,
   commandType : String
);

Parameters

row
[To be supplied.]
command
[To be supplied.]
commandType
[To be supplied.]

See Also

SQLRowUpdatingEventArgs Class | SQLRowUpdatingEventArgs Members | System.Data.SQL Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLRowUpdatingEventArgs Properties

The properties of the SQLRowUpdatingEventArgs class are listed below. For a complete list of SQLRowUpdatingEventArgs class members, see the SQLRowUpdatingEventArgs Members topic.

Public:

Command (inherited from RowUpdatingEventArgs) | [To be supplied.]
CommandType (inherited from RowUpdatingEventArgs) | [To be supplied.]
Errors (inherited from RowUpdatingEventArgs) | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
Row (inherited from RowUpdatingEventArgs) | [To be supplied.]
Status (inherited from RowUpdatingEventArgs) | [To be supplied.]

See Also

SQLRowUpdatingEventArgs Class | System.Data.SQL Namespace


SQLRowUpdatingEventArgs.Command

[To be supplied.]

[Visual Basic]
Public Property Command As SQLCommand
[C#]
public SQLCommand Command {new get; new set;}
[C++]
public: __property SQLCommand* get_Command();
public: __property void set_Command(SQLCommand*);
[JScript]
public function get Command() : SQLCommand;
public function set Command(SQLCommand);

See Also

SQLRowUpdatingEventArgs Class | SQLRowUpdatingEventArgs Members | System.Data.SQL Namespace


SQLRowUpdatingEventHandler Delegate

[To be supplied.]

[Visual Basic]
Public Delegate Sub SQLRowUpdatingEventHandler( _
   ByVal sender As Object, _
   ByVal e As SQLRowUpdatingEventArgs _
)
[C#]
public delegate void SQLRowUpdatingEventHandler(
   object sender,
   SQLRowUpdatingEventArgs e
);
[C++]
public __gc __delegate void SQLRowUpdatingEventHandler(
   Object* sender,
   SQLRowUpdatingEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the SQLRowUpdatingEventHandler delegate declaration.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQL

Assembly: System.Data.dll

See Also

System.Data.SQL Namespace


SQLSchemaMappingEventArgs Class

[To be supplied.]

Object
EventArgs
SchemaMappingEventArgs
SQLSchemaMappingEventArgs

[Visual Basic]
Public Class SQLSchemaMappingEventArgs
   Inherits SchemaMappingEventArgs
[C#]
public class SQLSchemaMappingEventArgs : SchemaMappingEventArgs
[C++]
public __gc class SQLSchemaMappingEventArgs : public
   SchemaMappingEventArgs
[JScript]
public class SQLSchemaMappingEventArgs extends
   SchemaMappingEventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQL

Assembly: System.Data.dll

See Also

SQLSchemaMappingEventArgs Members | System.Data.SQL Namespace


SQLSchemaMappingEventArgs Members

Public:

Properties

Command (inherited from SchemaMappingEventArgs) | [To be supplied.]
DataSet (inherited from SchemaMappingEventArgs) | [To be supplied.]
DataTable (inherited from SchemaMappingEventArgs) | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
PrimaryKey (inherited from SchemaMappingEventArgs) | [To be supplied.]
SchemaTable (inherited from SchemaMappingEventArgs) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLSchemaMappingEventArgs Class | System.Data.SQL Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLSchemaMappingEventArgs Properties

The properties of the SQLSchemaMappingEventArgs class are listed below. For a complete list of SQLSchemaMappingEventArgs class members, see the SQLSchemaMappingEventArgs Members topic.

Public:

Command (inherited from SchemaMappingEventArgs) | [To be supplied.]
DataSet (inherited from SchemaMappingEventArgs) | [To be supplied.]
DataTable (inherited from SchemaMappingEventArgs) | [To be supplied.]
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
PrimaryKey (inherited from SchemaMappingEventArgs) | [To be supplied.]
SchemaTable (inherited from SchemaMappingEventArgs) | [To be supplied.]

See Also

SQLSchemaMappingEventArgs Class | System.Data.SQL Namespace


SQLSchemaMappingEventArgs.Command

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Command As SQLCommand
[C#]
public SQLCommand Command {new get;}
[C++]
public: __property SQLCommand* get_Command();
[JScript]
public function get Command() : SQLCommand;

See Also

SQLSchemaMappingEventArgs Class | SQLSchemaMappingEventArgs Members | System.Data.SQL Namespace


SQLSchemaMappingEventHandler Delegate

[To be supplied.]

[Visual Basic]
Public Delegate Sub SQLSchemaMappingEventHandler( _
   ByVal sender As Object, _
   ByVal e As SQLSchemaMappingEventArgs _
)
[C#]
public delegate void SQLSchemaMappingEventHandler(
   object sender,
   SQLSchemaMappingEventArgs e
);
[C++]
public __gc __delegate void SQLSchemaMappingEventHandler(
   Object* sender,
   SQLSchemaMappingEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the SQLSchemaMappingEventHandler delegate declaration.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQL

Assembly: System.Data.dll

See Also

System.Data.SQL Namespace


System.Data.SQLTypes

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Data.SQLTypes Namespace

Classes

Class | Description
SQLBinary | Represents a binary object being stored in or retrieved from the database.
SQLException | [To be supplied.]
SQLNullValueException | [To be supplied.]
SQLString | Represents a string to be stored in or retrieved from the database.
SQLTruncateException | [To be supplied.]

Interfaces

Interface | Description
INullable | [To be supplied.]

Structures

Structure | Description
SQLBit | [To be supplied.]
SQLBoolean | Represents a boolean stored in or retrieved from a database.
SQLByte | [To be supplied.]
SQLDateTime | [To be supplied.]
SQLDouble | [To be supplied.]
SQLGuid | [To be supplied.]
SQLInt16 | [To be supplied.]
SQLInt32 | [To be supplied.]
SQLInt64 | [To be supplied.]
SQLMoney | Represents an amount of currency to be stored in or retrieved from a database.
SQLNumeric | [To be supplied.]
SQLSingle | [To be supplied.]

Enumerations

Enumeration | Description
EBoolean | [To be supplied.]


EBoolean Enumeration

[To be supplied.]

[Visual Basic]
Public Enum EBoolean
[C#]
public enum EBoolean
[C++]
public enum EBoolean

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
False | [To be supplied.]
True | [To be supplied.]
Unknown | [To be supplied.]

Requirements

Namespace: System.Data.SQLTypes

Assembly: System.Data.dll

See Also

System.Data.SQLTypes Namespace


INullable Interface

[To be supplied.]

INullable

[Visual Basic]
Public Interface INullable
[C#]
public interface INullable
[C++]
public __gc __interface INullable

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement INullable

Class | Description
SQLBinary | Represents a binary object being stored in or retrieved from the database.
SQLString | Represents a string to be stored in or retrieved from the database.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQLTypes

Assembly: System.Data.dll

See Also

INullable Members | System.Data.SQLTypes Namespace


INullable Members

Properties

IsNull [To be supplied.]

See Also

INullable Interface | System.Data.SQLTypes Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

INullable Properties

The properties of the INullable interface are listed below. For a complete list of INullable interface members, see the INullable Members topic.

IsNull [To be supplied.]

See Also

INullable Interface | System.Data.SQLTypes Namespace


INullable.IsNull

[To be supplied.]

[Visual Basic]
ReadOnly Property IsNull As Boolean
[C#]
bool IsNull {get;}
[C++]
bool get_IsNull() = 0;
[JScript]
abstract function get IsNull() : Boolean;

See Also

INullable Interface | INullable Members | System.Data.SQLTypes Namespace


SQLBinary Class

Represents a binary object being stored in or retrieved from the database.

Object
SQLBinary

[Visual Basic]
Public Class SQLBinary
   Implements INullable
[C#]
public class SQLBinary : INullable
[C++]
public __gc class SQLBinary : public INullable
[JScript]
public class SQLBinary implements INullable

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQLTypes

Assembly: System.Data.dll

See Also

SQLBinary Members | System.Data.SQLTypes Namespace


SQLBinary Members

Public:

Constructor

SQLBinary Constructor Overloaded. [To be supplied.]

Properties

Count | Gets the length in bytes of Value.
IsNull | Gets whether or not Value is null.
Value | Gets or sets the value of the SQL binary object retrieved.

Methods

EQ | Compares two instances of SQLBinary for equality.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GE | Compares the first SQLBinary for being greater than or equal the second SQLBinary.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
GT | Compares the first SQLBinary for being greater than the second SQLBinary.
LE | Compares the first SQLBinary for being less than or equal to the second SQLBinary.
LT | Compares the first SQLBinary for being less than the second SQLBinary.
NE | Compares two instances of SQLBinary for equality.
ToString | Overloaded. Converts a SQLBinary to a string.

Operators and Type Conversions

Addition Operator | Adds two instances of SQLBinary together.
Equality Operator | [To be supplied.]
Greater Than Operator | [To be supplied.]
Greater Than Or Equal Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Less Than Operator | [To be supplied.]
Less Than Or Equal Operator | [To be supplied.]
SQLGuid to SQLBinary Conversion | [To be supplied.]
SQLBinary to Byte[] Conversion | [To be supplied.]
Byte[] to SQLBinary Conversion | [To be supplied.]

Fields

Null Represents a null value that can be assigned to the Value property of an instance of the SQLBinary class.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLBinary Class | System.Data.SQLTypes Namespace


SQLBinary Constructor

[To be supplied.]

Overload List

Initializes a new instance of the SQLBinary class with a binary object to be stored.

[Visual Basic] Overloads Public Sub New(Byte())
[C#] public SQLBinary(byte[]);
[C++] public: SQLBinary(unsigned char*[]);
[JScript] public function SQLBinary(Byte[]);

Initializes a new instance of the SQLBinary class with a binary object to store, a boolean indicating whether or not to initialize as null, and boolean indicating whether or not to create a new binary array.

[Visual Basic] Overloads Public Sub New(Byte(), Boolean)
[C#] public SQLBinary(byte[], bool);
[C++] public: SQLBinary(unsigned char*[], bool);
[JScript] public function SQLBinary(Byte[], Boolean);

See Also

SQLBinary Class | SQLBinary Members | System.Data.SQLTypes Namespace


SQLBinary Constructor (Byte[])

Initializes a new instance of the SQLBinary class with a binary object to be stored.

[Visual Basic]
Overloads Public Sub New( _
   ByVal value() As Byte _
)
[C#]
public SQLBinary(
   byte[] value
);
[C++]
public: SQLBinary(
   unsigned char* value[]
);
[JScript]
public function SQLBinary(
   value : Byte[]
);

Parameters

value
The binary object to be stored or retrieved.

See Also

SQLBinary Class | SQLBinary Members | System.Data.SQLTypes Namespace | SQLBinary Constructor Overload List


SQLBinary Constructor (Byte[], Boolean)

Initializes a new instance of the SQLBinary class with a binary object to store, a boolean indicating whether or not to initialize as null, and boolean indicating whether or not to create a new binary array.

[Visual Basic]
Overloads Public Sub New( _
   ByVal value() As Byte, _
   ByVal fNewCopy As Boolean _
)
[C#]
public SQLBinary(
   byte[] value,
   bool fNewCopy
);
[C++]
public: SQLBinary(
   unsigned char* value[],
   bool fNewCopy
);
[JScript]
public function SQLBinary(
   value : Byte[],
   fNewCopy : Boolean
);

Parameters

value
The binary object to be stored or retrieved.
fNewCopy
true if creating a new binary array, otherwise false.

See Also

SQLBinary Class | SQLBinary Members | System.Data.SQLTypes Namespace | SQLBinary Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLBinary Properties

The properties of the SQLBinary class are listed below. For a complete list of SQLBinary class members, see the SQLBinary Members topic.

Public:

Count | Gets the length in bytes of Value.
IsNull | Gets whether or not Value is null.
Value | Gets or sets the value of the SQL binary object retrieved.

See Also

SQLBinary Class | System.Data.SQLTypes Namespace


SQLBinary.Count

Gets the length in bytes of Value.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

Property Value

The length of the binary.

Exceptions

Exception Type | Condition
SQLNullValueException | The property is set to null.

See Also

SQLBinary Class | SQLBinary Members | System.Data.SQLTypes Namespace


SQLBinary.IsNull

Gets whether or not Value is null.

[Visual Basic]
Overridable Public ReadOnly Property IsNull As Boolean
[C#]
public bool IsNull {virtual get;}
[C++]
public: __property virtual bool get_IsNull();
[JScript]
public function get IsNull() : Boolean;

Property Value

true if Value is null, otherwise false.

See Also

SQLBinary Class | SQLBinary Members | System.Data.SQLTypes Namespace


SQLBinary.Value

Gets or sets the value of the SQL binary object retrieved.

[Visual Basic]
Public ReadOnly Property Value As Byte ()
[C#]
public byte[] Value {get;}
[C++]
public: __property unsigned char* get_Value();
[JScript]
public function get Value() : Byte[];

Property Value

The value of the binary object.

Exceptions

Exception Type | Condition
SQLNullValueException | The property is set to null.

See Also

SQLBinary Class | SQLBinary Members | System.Data.SQLTypes Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLBinary Methods

The methods of the SQLBinary class are listed below. For a complete list of SQLBinary class members, see the SQLBinary Members topic.

Public:

EQ | Compares two instances of SQLBinary for equality.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GE | Compares the first SQLBinary for being greater than or equal the second SQLBinary.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
GT | Compares the first SQLBinary for being greater than the second SQLBinary.
LE | Compares the first SQLBinary for being less than or equal to the second SQLBinary.
LT | Compares the first SQLBinary for being less than the second SQLBinary.
NE | Compares two instances of SQLBinary for equality.
ToString | Overloaded. Converts a SQLBinary to a string.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLBinary Class | System.Data.SQLTypes Namespace


SQLBinary.EQ

Compares two instances of SQLBinary for equality.

[Visual Basic]
Public Shared Function EQ( _
   ByVal x As SQLBinary, _
   ByVal y As SQLBinary _
) As SQLBoolean
[C#]
public static SQLBoolean EQ(
   SQLBinary x,
   SQLBinary y
);
[C++]
public: static SQLBoolean EQ(
   SQLBinary* x,
   SQLBinary* y
);
[JScript]
public static function EQ(
   x : SQLBinary,
   y : SQLBinary
) : SQLBoolean;

Parameters

x
A SQLBinary.
y
A SQLBinary.

Return Value

A SQLBoolean that is True if the two instances are equal or False if the two instances are not equal. If either instance of SQLBinary is null, the Value of the SQLBoolean will be Null.

See Also

SQLBinary Class | SQLBinary Members | System.Data.SQLTypes Namespace | NE | LT | LE | GT | GE


SQLBinary.GE

Compares the first SQLBinary for being greater than or equal the second SQLBinary.

[Visual Basic]
Public Shared Function GE( _
   ByVal x As SQLBinary, _
   ByVal y As SQLBinary _
) As SQLBoolean
[C#]
public static SQLBoolean GE(
   SQLBinary x,
   SQLBinary y
);
[C++]
public: static SQLBoolean GE(
   SQLBinary* x,
   SQLBinary* y
);
[JScript]
public static function GE(
   x : SQLBinary,
   y : SQLBinary
) : SQLBoolean;

Parameters

x
A SQLBinary.
y
A SQLBinary.

Return Value

A SQLBoolean that is True if the first instance is greaater than or equal to the second instance, otherwise False. If either instance of SQLBinary is null, the Value of the SQLBoolean will be Null.

See Also

SQLBinary Class | SQLBinary Members | System.Data.SQLTypes Namespace | NE | LT | LE | GT | EQ


SQLBinary.GT

Compares the first SQLBinary for being greater than the second SQLBinary.

[Visual Basic]
Public Shared Function GT( _
   ByVal x As SQLBinary, _
   ByVal y As SQLBinary _
) As SQLBoolean
[C#]
public static SQLBoolean GT(
   SQLBinary x,
   SQLBinary y
);
[C++]
public: static SQLBoolean GT(
   SQLBinary* x,
   SQLBinary* y
);
[JScript]
public static function GT(
   x : SQLBinary,
   y : SQLBinary
) : SQLBoolean;

Parameters

x
A SQLBinary.
y
A SQLBinary.

Return Value

A SQLBoolean that is True if the first instance is greater than the second instance, otherwise False. If either instance of SQLBinary is null, the Value of the SQLBoolean will be Null.

See Also

SQLBinary Class | SQLBinary Members | System.Data.SQLTypes Namespace | NE | LT | LE | EQ | GE


SQLBinary.LE

Compares the first SQLBinary for being less than or equal to the second SQLBinary.

[Visual Basic]
Public Shared Function LE( _
   ByVal x As SQLBinary, _
   ByVal y As SQLBinary _
) As SQLBoolean
[C#]
public static SQLBoolean LE(
   SQLBinary x,
   SQLBinary y
);
[C++]
public: static SQLBoolean LE(
   SQLBinary* x,
   SQLBinary* y
);
[JScript]
public static function LE(
   x : SQLBinary,
   y : SQLBinary
) : SQLBoolean;

Parameters

x
A SQLBinary.
y
A SQLBinary.

Return Value

A SQLBoolean that is True if the first instance is less than or equal to the second instance, otherwise False. If either instance of SQLBinary is null, the Value of the SQLBoolean will be Null.

See Also

SQLBinary Class | SQLBinary Members | System.Data.SQLTypes Namespace | NE | LT | EQ | GT | GE


SQLBinary.LT

Compares the first SQLBinary for being less than the second SQLBinary.

[Visual Basic]
Public Shared Function LT( _
   ByVal x As SQLBinary, _
   ByVal y As SQLBinary _
) As SQLBoolean
[C#]
public static SQLBoolean LT(
   SQLBinary x,
   SQLBinary y
);
[C++]
public: static SQLBoolean LT(
   SQLBinary* x,
   SQLBinary* y
);
[JScript]
public static function LT(
   x : SQLBinary,
   y : SQLBinary
) : SQLBoolean;

Parameters

x
A SQLBinary.
y
A SQLBinary.

Return Value

A SQLBoolean that is True if the first instance is less than the second instance, otherwise False. If either instance of SQLBinary is null, the Value of the SQLBoolean will be Null.

See Also

SQLBinary Class | SQLBinary Members | System.Data.SQLTypes Namespace | NE | EQ | LE | GT | GE


SQLBinary.NE

Compares two instances of SQLBinary for equality.

[Visual Basic]
Public Shared Function NE( _
   ByVal x As SQLBinary, _
   ByVal y As SQLBinary _
) As SQLBoolean
[C#]
public static SQLBoolean NE(
   SQLBinary x,
   SQLBinary y
);
[C++]
public: static SQLBoolean NE(
   SQLBinary* x,
   SQLBinary* y
);
[JScript]
public static function NE(
   x : SQLBinary,
   y : SQLBinary
) : SQLBoolean;

Parameters

x
A SQLBinary.
y
A SQLBinary.

Return Value

A SQLBoolean that is True if the two instances are not equal or False if the two instances are equal. If either instance of SQLBinary is null, the Value of the SQLBoolean will be Null.

See Also

SQLBinary Class | SQLBinary Members | System.Data.SQLTypes Namespace | EQ | LT | LE | GT | GE


SQLBinary.ToString

Converts a SQLBinary to a string.

Overload List

Converts the SQLBinary parameter to a string.

[Visual Basic] Overloads Public Shared Function ToString(SQLBinary) As String
[C#] public static string ToString(SQLBinary);
[C++] public: static String* ToString(SQLBinary*);
[JScript] public static function ToString(SQLBinary) : String;

Converts this SQLBinary object to a string.

[Visual Basic] Overloads Overrides Public Function ToString() As String
[C#] public override string ToString();
[C++] public: override String* ToString();
[JScript] public override function ToString() : String;

See Also

SQLBinary Class | SQLBinary Members | System.Data.SQLTypes Namespace


SQLBinary.ToString (SQLBinary)

Converts the SQLBinary parameter to a string.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As SQLBinary _
) As String
[C#]
public static string ToString(
   SQLBinary value
);
[C++]
public: static String* ToString(
   SQLBinary* value
);
[JScript]
public static function ToString(
   value : SQLBinary
) : String;

Parameters

value
A SQLBinary.

Return Value

A string containing the Value of the SQLBinary. If the Value is null the string will contain "null".

See Also

SQLBinary Class | SQLBinary Members | System.Data.SQLTypes Namespace | SQLBinary.ToString Overload List


SQLBinary.ToString ()

Converts this SQLBinary object to a string.

[Visual Basic]
Overloads Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

A string containing the Value of the SQLBinary. If the Value is null the string will contain "null".

See Also

SQLBinary Class | SQLBinary Members | System.Data.SQLTypes Namespace | SQLBinary.ToString Overload List


Operators and Type Conversions

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLBinary Operators and Type Conversions

The operators and type conversions of the SQLBinary class are listed below. For a complete list of SQLBinary class members, see the SQLBinary Members topic.

Public:

Addition Operator | Adds two instances of SQLBinary together.
Equality Operator | [To be supplied.]
Greater Than Operator | [To be supplied.]
Greater Than Or Equal Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Less Than Operator | [To be supplied.]
Less Than Or Equal Operator | [To be supplied.]
SQLGuid to SQLBinary Conversion | [To be supplied.]
SQLBinary to Byte[] Conversion | [To be supplied.]
Byte[] to SQLBinary Conversion | [To be supplied.]

See Also

SQLBinary Class | System.Data.SQLTypes Namespace


SQLBinary Addition Operator

Adds two instances of SQLBinary together.

[C#]
public static SQLBinary operator +(
   SQLBinary x,
   SQLBinary y
);
[C++]
public: static SQLBinary* operator op_Addition(
   SQLBinary* x,
   SQLBinary* y
);
[JScript]
returnValue = x + y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
A SQLBinary.
y
A SQLBinary.

Parameters [C#, C++]

x
A SQLBinary.
y
A SQLBinary.

Return Value [C#, C++, JScript]

A new SQLBinary. If either arguement is Null, the new Value will be Null.

Remarks [C#, C++, JScript]

will appear first in the resulting SQLBinary, followed by.

See Also

SQLBinary Class | SQLBinary Members | System.Data.SQLTypes Namespace


SQLBinary Equality Operator

[To be supplied.]

[C#]
public static SQLBoolean operator ==(
   SQLBinary x,
   SQLBinary y
);
[C++]
public: static SQLBoolean operator op_Equality(
   SQLBinary* x,
   SQLBinary* y
);
[JScript]
returnValue = x == y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLBinary Class | SQLBinary Members | System.Data.SQLTypes Namespace


SQLBinary Greater Than Operator

[To be supplied.]

[C#]
public static SQLBoolean operator >(
   SQLBinary x,
   SQLBinary y
);
[C++]
public: static SQLBoolean operator op_GreaterThan(
   SQLBinary* x,
   SQLBinary* y
);
[JScript]
returnValue = x > y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLBinary Class | SQLBinary Members | System.Data.SQLTypes Namespace


SQLBinary Greater Than Or Equal Operator

[To be supplied.]

[C#]
public static SQLBoolean operator >=(
   SQLBinary x,
   SQLBinary y
);
[C++]
public: static SQLBoolean operator op_GreaterThanOrEqual(
   SQLBinary* x,
   SQLBinary* y
);
[JScript]
returnValue = x >= y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLBinary Class | SQLBinary Members | System.Data.SQLTypes Namespace


SQLBinary Inequality Operator

[To be supplied.]

[C#]
public static SQLBoolean operator !=(
   SQLBinary x,
   SQLBinary y
);
[C++]
public: static SQLBoolean operator op_Inequality(
   SQLBinary* x,
   SQLBinary* y
);
[JScript]
returnValue = x ! = y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLBinary Class | SQLBinary Members | System.Data.SQLTypes Namespace


SQLBinary Less Than Operator

[To be supplied.]

[C#]
public static SQLBoolean operator <(
   SQLBinary x,
   SQLBinary y
);
[C++]
public: static SQLBoolean operator op_LessThan(
   SQLBinary* x,
   SQLBinary* y
);
[JScript]
returnValue = x < y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLBinary Class | SQLBinary Members | System.Data.SQLTypes Namespace


SQLBinary Less Than Or Equal Operator

[To be supplied.]

[C#]
public static SQLBoolean operator <=(
   SQLBinary x,
   SQLBinary y
);
[C++]
public: static SQLBoolean operator op_LessThanOrEqual(
   SQLBinary* x,
   SQLBinary* y
);
[JScript]
returnValue = x <= y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLBinary Class | SQLBinary Members | System.Data.SQLTypes Namespace


SQLGuid to SQLBinary Conversion

[To be supplied.]

[C#]
public static explicit operator SQLBinary(
   SQLGuid x
);
[C++]
public: static SQLBinary* op_Explicit(
   SQLGuid x
);
[JScript]
returnValue = SQLBinary(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLBinary Class | SQLBinary Members | System.Data.SQLTypes Namespace


SQLBinary to Byte Conversion

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLBinary to Byte[] Conversion

[To be supplied.]

[C#]
public static explicit operator byte[](
   SQLBinary x
);
[C++]
public: operator unsigned char*();
[JScript]
returnValue = Byte[](x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#]

x
[To be supplied.]

See Also

SQLBinary Class | SQLBinary Members | System.Data.SQLTypes Namespace


Byte to SQLBinary Conversion

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Byte[] to SQLBinary Conversion

[To be supplied.]

[C#]
public static implicit operator SQLBinary(
   byte[] x
);
[C++]
public: static SQLBinary* op_Implicit(
   unsigned char* x[]
);
[JScript]
returnValue = x;

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLBinary Class | SQLBinary Members | System.Data.SQLTypes Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLBinary Fields

The fields of the SQLBinary class are listed below. For a complete list of SQLBinary class members, see the SQLBinary Members topic.

Public:

Null Represents a null value that can be assigned to the Value property of an instance of the SQLBinary class.

See Also

SQLBinary Class | System.Data.SQLTypes Namespace


SQLBinary.Null

Represents a null value that can be assigned to the Value property of an instance of the SQLBinary class.

[Visual Basic]
Public Shared ReadOnly Null As SQLBinary
[C#]
public static readonly SQLBinary Null;
[C++]
public: static readonly SQLBinary* Null;
[JScript]
public static var Null : SQLBinary;

Remarks

Null functions as a constant for the SQLBinary class.

See Also

SQLBinary Class | SQLBinary Members | System.Data.SQLTypes Namespace | IsNull


SQLBit Structure

[To be supplied.]

Object
ValueType
SQLBit

[Visual Basic]
Public Structure SQLBit
   Implements INullable
[C#]
public struct SQLBit : INullable
[C++]
public __value struct SQLBit : public INullable

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQLTypes

Assembly: System.Data.dll

See Also

SQLBit Members | System.Data.SQLTypes Namespace


SQLBit Members

Public:

Constructor

SQLBit Constructor Overloaded. [To be supplied.]

Properties

BoolValue | [To be supplied.]
ByteValue | [To be supplied.]
IsNull | [To be supplied.]

Methods

EQ | [To be supplied.]
Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
FromString | [To be supplied.]
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
NE | [To be supplied.]
ToString | Overloaded. [To be supplied.]

Operators and Type Conversions

Bitwise And Operator | [To be supplied.]
Bitwise Or Operator | [To be supplied.]
Equality Operator | [To be supplied.]
Exclusive Or Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Ones Complement Operator | [To be supplied.]
SQLDouble to SQLBit Conversion | [To be supplied.]
SQLInt64 to SQLBit Conversion | [To be supplied.]
SQLInt32 to SQLBit Conversion | [To be supplied.]
SQLMoney to SQLBit Conversion | [To be supplied.]
SQLString to SQLBit Conversion | [To be supplied.]
SQLSingle to SQLBit Conversion | [To be supplied.]
SQLBit to Byte Conversion | [To be supplied.]
SQLBit to Boolean Conversion | [To be supplied.]
SQLInt16 to SQLBit Conversion | [To be supplied.]
SQLByte to SQLBit Conversion | [To be supplied.]
Byte to SQLBit Conversion | Overloaded. [To be supplied.]

Fields

Null | [To be supplied.]
One | [To be supplied.]
Zero | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLBit Structure | System.Data.SQLTypes Namespace


SQLBit Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Boolean)
[C#] public SQLBit(bool);
[C++] public: SQLBit(bool);
[JScript] public function SQLBit(Boolean);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Byte)
[C#] public SQLBit(byte);
[C++] public: SQLBit(unsigned char);
[JScript] public function SQLBit(Byte);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public SQLBit(int);
[C++] public: SQLBit(int);
[JScript] public function SQLBit(int);

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace


SQLBit Constructor (Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As Boolean _
)
[C#]
public SQLBit(
   bool value
);
[C++]
public: SQLBit(
   bool value
);
[JScript]
public function SQLBit(
   value : Boolean
);

Parameters

value
[To be supplied.]

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace | SQLBit Constructor Overload List


SQLBit Constructor (Byte)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As Byte _
)
[C#]
public SQLBit(
   byte value
);
[C++]
public: SQLBit(
   unsigned char value
);
[JScript]
public function SQLBit(
   value : Byte
);

Parameters

value
[To be supplied.]

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace | SQLBit Constructor Overload List


SQLBit Constructor (Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As Integer _
)
[C#]
public SQLBit(
   int value
);
[C++]
public: SQLBit(
   int value
);
[JScript]
public function SQLBit(
   value : int
);

Parameters

value
[To be supplied.]

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace | SQLBit Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLBit Properties

The properties of the SQLBit structure are listed below. For a complete list of SQLBit structure members, see the SQLBit Members topic.

Public:

BoolValue | [To be supplied.]
ByteValue | [To be supplied.]
IsNull | [To be supplied.]

See Also

SQLBit Structure | System.Data.SQLTypes Namespace


SQLBit.BoolValue

[To be supplied.]

[Visual Basic]
Public ReadOnly Property BoolValue As Boolean
[C#]
public bool BoolValue {get;}
[C++]
public: __property bool get_BoolValue();
[JScript]
public function get BoolValue() : Boolean;

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace


SQLBit.ByteValue

[To be supplied.]

[Visual Basic]
Public ReadOnly Property ByteValue As Byte
[C#]
public byte ByteValue {get;}
[C++]
public: __property unsigned char get_ByteValue();
[JScript]
public function get ByteValue() : Byte;

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace


SQLBit.IsNull

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsNull As Boolean
[C#]
public bool IsNull {virtual get;}
[C++]
public: __property virtual bool get_IsNull();
[JScript]
public function get IsNull() : Boolean;

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLBit Methods

The methods of the SQLBit structure are listed below. For a complete list of SQLBit structure members, see the SQLBit Members topic.

Public:

EQ | [To be supplied.]
Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
FromString | [To be supplied.]
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
NE | [To be supplied.]
ToString | Overloaded. [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLBit Structure | System.Data.SQLTypes Namespace


SQLBit.EQ

[To be supplied.]

[Visual Basic]
Public Shared Function EQ( _
   ByVal x As SQLBit, _
   ByVal y As SQLBit _
) As SQLBoolean
[C#]
public static SQLBoolean EQ(
   SQLBit x,
   SQLBit y
);
[C++]
public: static SQLBoolean EQ(
   SQLBit x,
   SQLBit y
);
[JScript]
public static function EQ(
   x : SQLBit,
   y : SQLBit
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace


SQLBit.FromString

[To be supplied.]

[Visual Basic]
Public Shared Function FromString( _
   ByVal s As String _
) As SQLBit
[C#]
public static SQLBit FromString(
   string s
);
[C++]
public: static SQLBit FromString(
   String* s
);
[JScript]
public static function FromString(
   s : String
) : SQLBit;

Parameters

s
[To be supplied.]

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace


SQLBit.NE

[To be supplied.]

[Visual Basic]
Public Shared Function NE( _
   ByVal x As SQLBit, _
   ByVal y As SQLBit _
) As SQLBoolean
[C#]
public static SQLBoolean NE(
   SQLBit x,
   SQLBit y
);
[C++]
public: static SQLBoolean NE(
   SQLBit x,
   SQLBit y
);
[JScript]
public static function NE(
   x : SQLBit,
   y : SQLBit
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace


SQLBit.ToString

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overrides Public Function ToString() As String
[C#] public override string ToString();
[C++] public: override String* ToString();
[JScript] public override function ToString() : String;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToString(SQLBit) As String
[C#] public static string ToString(SQLBit);
[C++] public: static String* ToString(SQLBit);
[JScript] public static function ToString(SQLBit) : String;

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace


SQLBit.ToString ()

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace | SQLBit.ToString Overload List


SQLBit.ToString (SQLBit)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As SQLBit _
) As String
[C#]
public static string ToString(
   SQLBit value
);
[C++]
public: static String* ToString(
   SQLBit value
);
[JScript]
public static function ToString(
   value : SQLBit
) : String;

Parameters

value
[To be supplied.]

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace | SQLBit.ToString Overload List


Operators and Type Conversions

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLBit Operators and Type Conversions

The operators and type conversions of the SQLBit structure are listed below. For a complete list of SQLBit structure members, see the SQLBit Members topic.

Public:

Bitwise And Operator | [To be supplied.]
Bitwise Or Operator | [To be supplied.]
Equality Operator | [To be supplied.]
Exclusive Or Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Ones Complement Operator | [To be supplied.]
SQLDouble to SQLBit Conversion | [To be supplied.]
SQLInt64 to SQLBit Conversion | [To be supplied.]
SQLInt32 to SQLBit Conversion | [To be supplied.]
SQLMoney to SQLBit Conversion | [To be supplied.]
SQLString to SQLBit Conversion | [To be supplied.]
SQLSingle to SQLBit Conversion | [To be supplied.]
SQLBit to Byte Conversion | [To be supplied.]
SQLBit to Boolean Conversion | [To be supplied.]
SQLInt16 to SQLBit Conversion | [To be supplied.]
SQLByte to SQLBit Conversion | [To be supplied.]
Byte to SQLBit Conversion | Overloaded. [To be supplied.]

See Also

SQLBit Structure | System.Data.SQLTypes Namespace


SQLBit Bitwise And Operator

[To be supplied.]

[C#]
public static SQLBit operator &(
   SQLBit x,
   SQLBit y
);
[C++]
public: static SQLBit operator op_BitwiseAnd(
   SQLBit x,
   SQLBit y
);
[JScript]
returnValue = x & y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace


SQLBit Bitwise Or Operator

[To be supplied.]

[C#]
public static SQLBit operator |(
   SQLBit x,
   SQLBit y
);
[C++]
public: static SQLBit operator op_BitwiseOr(
   SQLBit x,
   SQLBit y
);
[JScript]
returnValue = x | y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace


SQLBit Equality Operator

[To be supplied.]

[C#]
public static SQLBoolean operator ==(
   SQLBit x,
   SQLBit y
);
[C++]
public: static SQLBoolean operator op_Equality(
   SQLBit x,
   SQLBit y
);
[JScript]
returnValue = x == y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace


SQLBit Exclusive Or Operator

[To be supplied.]

[C#]
public static SQLBit operator ^(
   SQLBit x,
   SQLBit y
);
[C++]
public: static SQLBit operator op_ExclusiveOr(
   SQLBit x,
   SQLBit y
);
[JScript]
returnValue = x ^ y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace


SQLBit Inequality Operator

[To be supplied.]

[C#]
public static SQLBoolean operator !=(
   SQLBit x,
   SQLBit y
);
[C++]
public: static SQLBoolean operator op_Inequality(
   SQLBit x,
   SQLBit y
);
[JScript]
returnValue = x ! = y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace


SQLBit Ones Complement Operator

[To be supplied.]

[C#]
public static SQLBit operator ~(
   SQLBit x
);
[C++]
public: static SQLBit operator op_OnesComplement(
   SQLBit x
);
[JScript]
returnValue = ~x;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace


SQLDouble to SQLBit Conversion

[To be supplied.]

[C#]
public static explicit operator SQLBit(
   SQLDouble x
);
[C++]
public: static SQLBit op_Explicit(
   SQLDouble x
);
[JScript]
returnValue = SQLBit(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace


SQLInt64 to SQLBit Conversion

[To be supplied.]

[C#]
public static explicit operator SQLBit(
   SQLInt64 x
);
[C++]
public: static SQLBit op_Explicit(
   SQLInt64 x
);
[JScript]
returnValue = SQLBit(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace


SQLInt32 to SQLBit Conversion

[To be supplied.]

[C#]
public static explicit operator SQLBit(
   SQLInt32 x
);
[C++]
public: static SQLBit op_Explicit(
   SQLInt32 x
);
[JScript]
returnValue = SQLBit(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace


SQLMoney to SQLBit Conversion

[To be supplied.]

[C#]
public static explicit operator SQLBit(
   SQLMoney x
);
[C++]
public: static SQLBit op_Explicit(
   SQLMoney x
);
[JScript]
returnValue = SQLBit(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace


SQLString to SQLBit Conversion

[To be supplied.]

[C#]
public static explicit operator SQLBit(
   SQLString x
);
[C++]
public: static SQLBit op_Explicit(
   SQLString* x
);
[JScript]
returnValue = SQLBit(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace


SQLSingle to SQLBit Conversion

[To be supplied.]

[C#]
public static explicit operator SQLBit(
   SQLSingle x
);
[C++]
public: static SQLBit op_Explicit(
   SQLSingle x
);
[JScript]
returnValue = SQLBit(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace


SQLBit to Byte Conversion

[To be supplied.]

[C#]
public static explicit operator byte(
   SQLBit x
);
[C++]
public: operator unsigned char();
[JScript]
returnValue = Byte(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#]

x
[To be supplied.]

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace


SQLBit to Boolean Conversion

[To be supplied.]

[C#]
public static explicit operator bool(
   SQLBit x
);
[C++]
public: operator bool();
[JScript]
returnValue = Boolean(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#]

x
[To be supplied.]

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace


SQLInt16 to SQLBit Conversion

[To be supplied.]

[C#]
public static explicit operator SQLBit(
   SQLInt16 x
);
[C++]
public: static SQLBit op_Explicit(
   SQLInt16 x
);
[JScript]
returnValue = SQLBit(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace


SQLByte to SQLBit Conversion

[To be supplied.]

[C#]
public static explicit operator SQLBit(
   SQLByte x
);
[C++]
public: static SQLBit op_Explicit(
   SQLByte x
);
[JScript]
returnValue = SQLBit(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace


NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Byte to SQLBit Conversion

Build number 1812.

© 2000 Microsoft Corporation. All rights reserved.


Byte to SQLBit Conversion

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Byte to SQLBit Conversion (Byte)

[To be supplied.]

[C#]
public static implicit operator SQLBit(
   byte x
);
[C++]
public: static SQLBit op_Implicit(
   unsigned char x
);
[JScript]
returnValue = x;

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace | SQLBit to Conversion Overload List


Boolean to SQLBit Conversion

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Boolean to SQLBit Conversion (Boolean)

[To be supplied.]

[C#]
public static implicit operator SQLBit(
   bool x
);
[C++]
public: static SQLBit op_Implicit(
   bool x
);
[JScript]
returnValue = x;

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace | SQLBit to Conversion Overload List


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLBit Fields

The fields of the SQLBit structure are listed below. For a complete list of SQLBit structure members, see the SQLBit Members topic.

Public:

Null | [To be supplied.]
One | [To be supplied.]
Zero | [To be supplied.]

See Also

SQLBit Structure | System.Data.SQLTypes Namespace


SQLBit.Null

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Null As SQLBit
[C#]
public static readonly SQLBit Null;
[C++]
public: static readonly SQLBit Null;
[JScript]
public static var Null : SQLBit;

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace


SQLBit.One

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly One As SQLBit
[C#]
public static readonly SQLBit One;
[C++]
public: static readonly SQLBit One;
[JScript]
public static var One : SQLBit;

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace


SQLBit.Zero

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Zero As SQLBit
[C#]
public static readonly SQLBit Zero;
[C++]
public: static readonly SQLBit Zero;
[JScript]
public static var Zero : SQLBit;

See Also

SQLBit Structure | SQLBit Members | System.Data.SQLTypes Namespace


SQLBoolean Structure

Represents a boolean stored in or retrieved from a database.

Object
ValueType
SQLBoolean

[Visual Basic]
Public Structure SQLBoolean
   Implements INullable
[C#]
public struct SQLBoolean : INullable
[C++]
public __value struct SQLBoolean : public INullable

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

The actual value of the boolean is stored in Value and can be set to any of the following True, False, or Null.

Requirements

Namespace: System.Data.SQLTypes

Assembly: System.Data.dll

See Also

SQLBoolean Members | System.Data.SQLTypes Namespace


SQLBoolean Members

Public:

Constructor

SQLBoolean Constructor Initializes a new instance of the SQLBoolean class.

Properties

IsFalse | Gets whether the current Value is False.
IsNull | Gets whether the current Value is Null.
IsTrue | Gets whether the current Value is True.
Value | Gets or sets the SQLBoolean to be true or false.

Methods

Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Converts the current Value to a string.

Operators and Type Conversions

Bitwise And Operator | Performs a bitwise AND operation on two instances of SQLBoolean.
Bitwise Or Operator | Performs a bitwise OR operation on two instances of a SQLBoolean.
False Operator | [To be supplied.]
Negation Operator | Performs a NOT operation on a SQLBoolean.
True Operator | [To be supplied.]
SQLBoolean to Boolean Conversion | [To be supplied.]
Boolean to SQLBoolean Conversion | [To be supplied.]

Fields

False | Represents a false value that can be assigned to the Value property of an instance of the SQLBoolean class.
Null | Represents a null value that can be assigned to the Value property of an instance of the SQLBoolean class.
True | Represents a true value that can be assigned to the Value property of an instance of the SQLBoolean class.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLBoolean Structure | System.Data.SQLTypes Namespace


SQLBoolean Constructor

Initializes a new instance of the SQLBoolean class.

[Visual Basic]
Public Sub New( _
   ByVal value As Boolean _
)
[C#]
public SQLBoolean(
   bool value
);
[C++]
public: SQLBoolean(
   bool value
);
[JScript]
public function SQLBoolean(
   value : Boolean
);

Parameters

value
Either true or false.

See Also

SQLBoolean Structure | SQLBoolean Members | System.Data.SQLTypes Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLBoolean Properties

The properties of the SQLBoolean structure are listed below. For a complete list of SQLBoolean structure members, see the SQLBoolean Members topic.

Public:

IsFalse | Gets whether the current Value is False.
IsNull | Gets whether the current Value is Null.
IsTrue | Gets whether the current Value is True.
Value | Gets or sets the SQLBoolean to be true or false.

See Also

SQLBoolean Structure | System.Data.SQLTypes Namespace


SQLBoolean.IsFalse

Gets whether the current Value is False.

[Visual Basic]
Public ReadOnly Property IsFalse As Boolean
[C#]
public bool IsFalse {get;}
[C++]
public: __property bool get_IsFalse();
[JScript]
public function get IsFalse() : Boolean;

Property Value

true if Value is False, otherwise false.

Remarks

If the Value is Null, this property still will be false.

See Also

SQLBoolean Structure | SQLBoolean Members | System.Data.SQLTypes Namespace | IsTrue | True | IsNull


SQLBoolean.IsNull

Gets whether the current Value is Null.

[Visual Basic]
Overridable Public ReadOnly Property IsNull As Boolean
[C#]
public bool IsNull {virtual get;}
[C++]
public: __property virtual bool get_IsNull();
[JScript]
public function get IsNull() : Boolean;

Property Value

true if Value is Null, otherwise false.

See Also

SQLBoolean Structure | SQLBoolean Members | System.Data.SQLTypes Namespace | IsTrue | IsFalse


SQLBoolean.IsTrue

Gets whether the current Value is True.

[Visual Basic]
Public ReadOnly Property IsTrue As Boolean
[C#]
public bool IsTrue {get;}
[C++]
public: __property bool get_IsTrue();
[JScript]
public function get IsTrue() : Boolean;

Property Value

true if Value is True, otherwise false.

Remarks

If the Value is Null, this property still will be false.

See Also

SQLBoolean Structure | SQLBoolean Members | System.Data.SQLTypes Namespace | IsFalse | False | IsNull


SQLBoolean.Value

Gets or sets the SQLBoolean to be true or false.

[Visual Basic]
Public ReadOnly Property Value As Boolean
[C#]
public bool Value {get;}
[C++]
public: __property bool get_Value();
[JScript]
public function get Value() : Boolean;

Property Value

true if SQLBoolean is True, otherwise false.

Exceptions

Exception Type | Condition
SQLNullValueException | The property is set to null.

See Also

SQLBoolean Structure | SQLBoolean Members | System.Data.SQLTypes Namespace | False | IsTrue | IsFalse | IsNull


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLBoolean Methods

The methods of the SQLBoolean structure are listed below. For a complete list of SQLBoolean structure members, see the SQLBoolean Members topic.

Public:

Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Converts the current Value to a string.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLBoolean Structure | System.Data.SQLTypes Namespace


SQLBoolean.ToString

Converts the current Value to a string.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

A string containing "true" if true, "null" if null, otherwise "false".

See Also

SQLBoolean Structure | SQLBoolean Members | System.Data.SQLTypes Namespace


Operators and Type Conversions

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLBoolean Operators and Type Conversions

The operators and type conversions of the SQLBoolean structure are listed below. For a complete list of SQLBoolean structure members, see the SQLBoolean Members topic.

Public:

Bitwise And Operator | Performs a bitwise AND operation on two instances of SQLBoolean.
Bitwise Or Operator | Performs a bitwise OR operation on two instances of a SQLBoolean.
False Operator | [To be supplied.]
Negation Operator | Performs a NOT operation on a SQLBoolean.
True Operator | [To be supplied.]
SQLBoolean to Boolean Conversion | [To be supplied.]
Boolean to SQLBoolean Conversion | [To be supplied.]

See Also

SQLBoolean Structure | System.Data.SQLTypes Namespace


SQLBoolean Bitwise And Operator

Performs a bitwise AND operation on two instances of SQLBoolean.

[C#]
public static SQLBoolean operator &(
   SQLBoolean x,
   SQLBoolean y
);
[C++]
public: static SQLBoolean operator op_BitwiseAnd(
   SQLBoolean x,
   SQLBoolean y
);
[JScript]
returnValue = x & y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
A SQLBoolean.
y
A SQLBoolean.

Parameters [C#, C++]

x
A SQLBoolean.
y
A SQLBoolean.

Return Value [C#, C++, JScript]

A new SQLBoolean that is the result of combiningand.

See Also

SQLBoolean Structure | SQLBoolean Members | System.Data.SQLTypes Namespace


SQLBoolean Bitwise Or Operator

Performs a bitwise OR operation on two instances of a SQLBoolean.

[C#]
public static SQLBoolean operator |(
   SQLBoolean x,
   SQLBoolean y
);
[C++]
public: static SQLBoolean operator op_BitwiseOr(
   SQLBoolean x,
   SQLBoolean y
);
[JScript]
returnValue = x | y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
A SQLBoolean.
y
A SQLBoolean.

Parameters [C#, C++]

x
A SQLBoolean.
y
A SQLBoolean.

Return Value [C#, C++, JScript]

A new SQLBoolean that is the result of combiningand.

See Also

SQLBoolean Structure | SQLBoolean Members | System.Data.SQLTypes Namespace


SQLBoolean False Operator

[To be supplied.]

[C#]
public static bool operator false(
   SQLBoolean x
);
[C++]
public: static bool operator op_False(
   SQLBoolean x
);

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLBoolean Structure | SQLBoolean Members | System.Data.SQLTypes Namespace


SQLBoolean Negation Operator

Performs a NOT operation on a SQLBoolean.

[C#]
public static SQLBoolean operator !(
   SQLBoolean x
);
[C++]
public: static SQLBoolean operator op_Negation(
   SQLBoolean x
);
[JScript]
returnValue = !x;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
A SQLBoolean.

Parameters [C#, C++]

x
A SQLBoolean.

Return Value [C#, C++, JScript]

A SQLBoolean with the Value True if argument was true, Null if argument was null, and False otherwise.

See Also

SQLBoolean Structure | SQLBoolean Members | System.Data.SQLTypes Namespace


SQLBoolean True Operator

[To be supplied.]

[C#]
public static bool operator true(
   SQLBoolean x
);
[C++]
public: static bool operator op_True(
   SQLBoolean x
);

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLBoolean Structure | SQLBoolean Members | System.Data.SQLTypes Namespace


SQLBoolean to Boolean Conversion

[To be supplied.]

[C#]
public static explicit operator bool(
   SQLBoolean x
);
[C++]
public: operator bool();
[JScript]
returnValue = Boolean(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#]

x
[To be supplied.]

See Also

SQLBoolean Structure | SQLBoolean Members | System.Data.SQLTypes Namespace


Boolean to SQLBoolean Conversion

[To be supplied.]

[C#]
public static implicit operator SQLBoolean(
   bool x
);
[C++]
public: static SQLBoolean op_Implicit(
   bool x
);
[JScript]
returnValue = x;

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLBoolean Structure | SQLBoolean Members | System.Data.SQLTypes Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLBoolean Fields

The fields of the SQLBoolean structure are listed below. For a complete list of SQLBoolean structure members, see the SQLBoolean Members topic.

Public:

False | Represents a false value that can be assigned to the Value property of an instance of the SQLBoolean class.
Null | Represents a null value that can be assigned to the Value property of an instance of the SQLBoolean class.
True | Represents a true value that can be assigned to the Value property of an instance of the SQLBoolean class.

See Also

SQLBoolean Structure | System.Data.SQLTypes Namespace


SQLBoolean.False

Represents a false value that can be assigned to the Value property of an instance of the SQLBoolean class.

[Visual Basic]
Public Shared ReadOnly False As SQLBoolean
[C#]
public static readonly SQLBoolean False;
[C++]
public: static readonly SQLBoolean False;
[JScript]
public static var False : SQLBoolean;

Remarks

The False field is a constant for the SQLBoolean class.

See Also

SQLBoolean Structure | SQLBoolean Members | System.Data.SQLTypes Namespace | True | IsFalse | IsTrue | Null


SQLBoolean.Null

Represents a null value that can be assigned to the Value property of an instance of the SQLBoolean class.

[Visual Basic]
Public Shared ReadOnly Null As SQLBoolean
[C#]
public static readonly SQLBoolean Null;
[C++]
public: static readonly SQLBoolean Null;
[JScript]
public static var Null : SQLBoolean;

Remarks

The Null field is a constant for the SQLBoolean class.

See Also

SQLBoolean Structure | SQLBoolean Members | System.Data.SQLTypes Namespace | IsNull | True | False


SQLBoolean.True

Represents a true value that can be assigned to the Value property of an instance of the SQLBoolean class.

[Visual Basic]
Public Shared ReadOnly True As SQLBoolean
[C#]
public static readonly SQLBoolean True;
[C++]
public: static readonly SQLBoolean True;
[JScript]
public static var True : SQLBoolean;

Remarks

The True field is a constant for the SQLBoolean class.

See Also

SQLBoolean Structure | SQLBoolean Members | System.Data.SQLTypes Namespace | False | IsTrue | IsFalse | Null


SQLByte Structure

[To be supplied.]

Object
ValueType
SQLByte

[Visual Basic]
Public Structure SQLByte
   Implements INullable
[C#]
public struct SQLByte : INullable
[C++]
public __value struct SQLByte : public INullable

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQLTypes

Assembly: System.Data.dll

See Also

SQLByte Members | System.Data.SQLTypes Namespace


SQLByte Members

Public:

Constructor

SQLByte Constructor [To be supplied.]

Properties

IsNull | [To be supplied.]
Value | [To be supplied.]

Methods

EQ | [To be supplied.]
Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
FromString | [To be supplied.]
GE | [To be supplied.]
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
GT | [To be supplied.]
LE | [To be supplied.]
LT | [To be supplied.]
NE | [To be supplied.]
ToString | Overloaded. [To be supplied.]

Operators and Type Conversions

Addition Operator | [To be supplied.]
Bitwise And Operator | [To be supplied.]
Bitwise Or Operator | [To be supplied.]
Division Operator | [To be supplied.]
Equality Operator | [To be supplied.]
Exclusive Or Operator | [To be supplied.]
Greater Than Operator | [To be supplied.]
Greater Than Or Equal Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Less Than Operator | [To be supplied.]
Less Than Or Equal Operator | [To be supplied.]
Modulus Operator | [To be supplied.]
Multiplication Operator | [To be supplied.]
Ones Complement Operator | [To be supplied.]
Subtraction Operator | [To be supplied.]
SQLSingle to SQLByte Conversion | [To be supplied.]
SQLInt32 to SQLByte Conversion | [To be supplied.]
SQLInt64 to SQLByte Conversion | [To be supplied.]
SQLByte to Byte Conversion | [To be supplied.]
SQLString to SQLByte Conversion | [To be supplied.]
SQLDouble to SQLByte Conversion | [To be supplied.]
SQLInt16 to SQLByte Conversion | [To be supplied.]
SQLMoney to SQLByte Conversion | [To be supplied.]
SQLBit to SQLByte Conversion | Overloaded. [To be supplied.]

Fields

MaxValue | [To be supplied.]
MinValue | [To be supplied.]
Null | [To be supplied.]
Zero | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLByte Structure | System.Data.SQLTypes Namespace


SQLByte Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal value As Byte _
)
[C#]
public SQLByte(
   byte value
);
[C++]
public: SQLByte(
   unsigned char value
);
[JScript]
public function SQLByte(
   value : Byte
);

Parameters

value
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLByte Properties

The properties of the SQLByte structure are listed below. For a complete list of SQLByte structure members, see the SQLByte Members topic.

Public:

IsNull | [To be supplied.]
Value | [To be supplied.]

See Also

SQLByte Structure | System.Data.SQLTypes Namespace


SQLByte.IsNull

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsNull As Boolean
[C#]
public bool IsNull {virtual get;}
[C++]
public: __property virtual bool get_IsNull();
[JScript]
public function get IsNull() : Boolean;

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLByte.Value

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Value As Byte
[C#]
public byte Value {get;}
[C++]
public: __property unsigned char get_Value();
[JScript]
public function get Value() : Byte;

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLByte Methods

The methods of the SQLByte structure are listed below. For a complete list of SQLByte structure members, see the SQLByte Members topic.

Public:

EQ | [To be supplied.]
Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
FromString | [To be supplied.]
GE | [To be supplied.]
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
GT | [To be supplied.]
LE | [To be supplied.]
LT | [To be supplied.]
NE | [To be supplied.]
ToString | Overloaded. [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLByte Structure | System.Data.SQLTypes Namespace


SQLByte.EQ

[To be supplied.]

[Visual Basic]
Public Shared Function EQ( _
   ByVal x As SQLByte, _
   ByVal y As SQLByte _
) As SQLBoolean
[C#]
public static SQLBoolean EQ(
   SQLByte x,
   SQLByte y
);
[C++]
public: static SQLBoolean EQ(
   SQLByte x,
   SQLByte y
);
[JScript]
public static function EQ(
   x : SQLByte,
   y : SQLByte
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLByte.FromString

[To be supplied.]

[Visual Basic]
Public Shared Function FromString( _
   ByVal s As String _
) As SQLByte
[C#]
public static SQLByte FromString(
   string s
);
[C++]
public: static SQLByte FromString(
   String* s
);
[JScript]
public static function FromString(
   s : String
) : SQLByte;

Parameters

s
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLByte.GE

[To be supplied.]

[Visual Basic]
Public Shared Function GE( _
   ByVal x As SQLByte, _
   ByVal y As SQLByte _
) As SQLBoolean
[C#]
public static SQLBoolean GE(
   SQLByte x,
   SQLByte y
);
[C++]
public: static SQLBoolean GE(
   SQLByte x,
   SQLByte y
);
[JScript]
public static function GE(
   x : SQLByte,
   y : SQLByte
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLByte.GT

[To be supplied.]

[Visual Basic]
Public Shared Function GT( _
   ByVal x As SQLByte, _
   ByVal y As SQLByte _
) As SQLBoolean
[C#]
public static SQLBoolean GT(
   SQLByte x,
   SQLByte y
);
[C++]
public: static SQLBoolean GT(
   SQLByte x,
   SQLByte y
);
[JScript]
public static function GT(
   x : SQLByte,
   y : SQLByte
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLByte.LE

[To be supplied.]

[Visual Basic]
Public Shared Function LE( _
   ByVal x As SQLByte, _
   ByVal y As SQLByte _
) As SQLBoolean
[C#]
public static SQLBoolean LE(
   SQLByte x,
   SQLByte y
);
[C++]
public: static SQLBoolean LE(
   SQLByte x,
   SQLByte y
);
[JScript]
public static function LE(
   x : SQLByte,
   y : SQLByte
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLByte.LT

[To be supplied.]

[Visual Basic]
Public Shared Function LT( _
   ByVal x As SQLByte, _
   ByVal y As SQLByte _
) As SQLBoolean
[C#]
public static SQLBoolean LT(
   SQLByte x,
   SQLByte y
);
[C++]
public: static SQLBoolean LT(
   SQLByte x,
   SQLByte y
);
[JScript]
public static function LT(
   x : SQLByte,
   y : SQLByte
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLByte.NE

[To be supplied.]

[Visual Basic]
Public Shared Function NE( _
   ByVal x As SQLByte, _
   ByVal y As SQLByte _
) As SQLBoolean
[C#]
public static SQLBoolean NE(
   SQLByte x,
   SQLByte y
);
[C++]
public: static SQLBoolean NE(
   SQLByte x,
   SQLByte y
);
[JScript]
public static function NE(
   x : SQLByte,
   y : SQLByte
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLByte.ToString

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overrides Public Function ToString() As String
[C#] public override string ToString();
[C++] public: override String* ToString();
[JScript] public override function ToString() : String;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToString(SQLByte) As String
[C#] public static string ToString(SQLByte);
[C++] public: static String* ToString(SQLByte);
[JScript] public static function ToString(SQLByte) : String;

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLByte.ToString ()

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace | SQLByte.ToString Overload List


SQLByte.ToString (SQLByte)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As SQLByte _
) As String
[C#]
public static string ToString(
   SQLByte value
);
[C++]
public: static String* ToString(
   SQLByte value
);
[JScript]
public static function ToString(
   value : SQLByte
) : String;

Parameters

value
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace | SQLByte.ToString Overload List


Operators and Type Conversions

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLByte Operators and Type Conversions

The operators and type conversions of the SQLByte structure are listed below. For a complete list of SQLByte structure members, see the SQLByte Members topic.

Public:

Addition Operator | [To be supplied.]
Bitwise And Operator | [To be supplied.]
Bitwise Or Operator | [To be supplied.]
Division Operator | [To be supplied.]
Equality Operator | [To be supplied.]
Exclusive Or Operator | [To be supplied.]
Greater Than Operator | [To be supplied.]
Greater Than Or Equal Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Less Than Operator | [To be supplied.]
Less Than Or Equal Operator | [To be supplied.]
Modulus Operator | [To be supplied.]
Multiplication Operator | [To be supplied.]
Ones Complement Operator | [To be supplied.]
Subtraction Operator | [To be supplied.]
SQLSingle to SQLByte Conversion | [To be supplied.]
SQLInt32 to SQLByte Conversion | [To be supplied.]
SQLInt64 to SQLByte Conversion | [To be supplied.]
SQLByte to Byte Conversion | [To be supplied.]
SQLString to SQLByte Conversion | [To be supplied.]
SQLDouble to SQLByte Conversion | [To be supplied.]
SQLInt16 to SQLByte Conversion | [To be supplied.]
SQLMoney to SQLByte Conversion | [To be supplied.]
SQLBit to SQLByte Conversion | Overloaded. [To be supplied.]

See Also

SQLByte Structure | System.Data.SQLTypes Namespace


SQLByte Addition Operator

[To be supplied.]

[C#]
public static SQLByte operator +(
   SQLByte x,
   SQLByte y
);
[C++]
public: static SQLByte operator op_Addition(
   SQLByte x,
   SQLByte y
);
[JScript]
returnValue = x + y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLByte Bitwise And Operator

[To be supplied.]

[C#]
public static SQLByte operator &(
   SQLByte x,
   SQLByte y
);
[C++]
public: static SQLByte operator op_BitwiseAnd(
   SQLByte x,
   SQLByte y
);
[JScript]
returnValue = x & y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLByte Bitwise Or Operator

[To be supplied.]

[C#]
public static SQLByte operator |(
   SQLByte x,
   SQLByte y
);
[C++]
public: static SQLByte operator op_BitwiseOr(
   SQLByte x,
   SQLByte y
);
[JScript]
returnValue = x | y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLByte Division Operator

[To be supplied.]

[C#]
public static SQLByte operator /(
   SQLByte x,
   SQLByte y
);
[C++]
public: static SQLByte operator op_Division(
   SQLByte x,
   SQLByte y
);
[JScript]
returnValue = x / y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLByte Equality Operator

[To be supplied.]

[C#]
public static SQLBoolean operator ==(
   SQLByte x,
   SQLByte y
);
[C++]
public: static SQLBoolean operator op_Equality(
   SQLByte x,
   SQLByte y
);
[JScript]
returnValue = x == y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLByte Exclusive Or Operator

[To be supplied.]

[C#]
public static SQLByte operator ^(
   SQLByte x,
   SQLByte y
);
[C++]
public: static SQLByte operator op_ExclusiveOr(
   SQLByte x,
   SQLByte y
);
[JScript]
returnValue = x ^ y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLByte Greater Than Operator

[To be supplied.]

[C#]
public static SQLBoolean operator >(
   SQLByte x,
   SQLByte y
);
[C++]
public: static SQLBoolean operator op_GreaterThan(
   SQLByte x,
   SQLByte y
);
[JScript]
returnValue = x > y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLByte Greater Than Or Equal Operator

[To be supplied.]

[C#]
public static SQLBoolean operator >=(
   SQLByte x,
   SQLByte y
);
[C++]
public: static SQLBoolean operator op_GreaterThanOrEqual(
   SQLByte x,
   SQLByte y
);
[JScript]
returnValue = x >= y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLByte Inequality Operator

[To be supplied.]

[C#]
public static SQLBoolean operator !=(
   SQLByte x,
   SQLByte y
);
[C++]
public: static SQLBoolean operator op_Inequality(
   SQLByte x,
   SQLByte y
);
[JScript]
returnValue = x ! = y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLByte Less Than Operator

[To be supplied.]

[C#]
public static SQLBoolean operator <(
   SQLByte x,
   SQLByte y
);
[C++]
public: static SQLBoolean operator op_LessThan(
   SQLByte x,
   SQLByte y
);
[JScript]
returnValue = x < y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLByte Less Than Or Equal Operator

[To be supplied.]

[C#]
public static SQLBoolean operator <=(
   SQLByte x,
   SQLByte y
);
[C++]
public: static SQLBoolean operator op_LessThanOrEqual(
   SQLByte x,
   SQLByte y
);
[JScript]
returnValue = x <= y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLByte Modulus Operator

[To be supplied.]

[C#]
public static SQLByte operator %(
   SQLByte x,
   SQLByte y
);
[C++]
public: static SQLByte operator op_Modulus(
   SQLByte x,
   SQLByte y
);
[JScript]
returnValue = x % y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLByte Multiplication Operator

[To be supplied.]

[C#]
public static SQLByte operator *(
   SQLByte x,
   SQLByte y
);
[C++]
public: static SQLByte operator op_Multiply(
   SQLByte x,
   SQLByte y
);
[JScript]
returnValue = x * y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLByte Ones Complement Operator

[To be supplied.]

[C#]
public static SQLByte operator ~(
   SQLByte x
);
[C++]
public: static SQLByte operator op_OnesComplement(
   SQLByte x
);
[JScript]
returnValue = ~x;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLByte Subtraction Operator

[To be supplied.]

[C#]
public static SQLByte operator -(
   SQLByte x,
   SQLByte y
);
[C++]
public: static SQLByte operator op_Subtraction(
   SQLByte x,
   SQLByte y
);
[JScript]
returnValue = x - y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLSingle to SQLByte Conversion

[To be supplied.]

[C#]
public static explicit operator SQLByte(
   SQLSingle x
);
[C++]
public: static SQLByte op_Explicit(
   SQLSingle x
);
[JScript]
returnValue = SQLByte(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLInt32 to SQLByte Conversion

[To be supplied.]

[C#]
public static explicit operator SQLByte(
   SQLInt32 x
);
[C++]
public: static SQLByte op_Explicit(
   SQLInt32 x
);
[JScript]
returnValue = SQLByte(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLInt64 to SQLByte Conversion

[To be supplied.]

[C#]
public static explicit operator SQLByte(
   SQLInt64 x
);
[C++]
public: static SQLByte op_Explicit(
   SQLInt64 x
);
[JScript]
returnValue = SQLByte(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLByte to Byte Conversion

[To be supplied.]

[C#]
public static explicit operator byte(
   SQLByte x
);
[C++]
public: operator unsigned char();
[JScript]
returnValue = Byte(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#]

x
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLString to SQLByte Conversion

[To be supplied.]

[C#]
public static explicit operator SQLByte(
   SQLString x
);
[C++]
public: static SQLByte op_Explicit(
   SQLString* x
);
[JScript]
returnValue = SQLByte(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLDouble to SQLByte Conversion

[To be supplied.]

[C#]
public static explicit operator SQLByte(
   SQLDouble x
);
[C++]
public: static SQLByte op_Explicit(
   SQLDouble x
);
[JScript]
returnValue = SQLByte(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLInt16 to SQLByte Conversion

[To be supplied.]

[C#]
public static explicit operator SQLByte(
   SQLInt16 x
);
[C++]
public: static SQLByte op_Explicit(
   SQLInt16 x
);
[JScript]
returnValue = SQLByte(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLMoney to SQLByte Conversion

[To be supplied.]

[C#]
public static explicit operator SQLByte(
   SQLMoney x
);
[C++]
public: static SQLByte op_Explicit(
   SQLMoney x
);
[JScript]
returnValue = SQLByte(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLBit to SQLByte Conversion

Build number 1812.

© 2000 Microsoft Corporation. All rights reserved.


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLByte Fields

The fields of the SQLByte structure are listed below. For a complete list of SQLByte structure members, see the SQLByte Members topic.

Public:

MaxValue | [To be supplied.]
MinValue | [To be supplied.]
Null | [To be supplied.]
Zero | [To be supplied.]

See Also

SQLByte Structure | System.Data.SQLTypes Namespace


SQLByte.MaxValue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly MaxValue As SQLByte
[C#]
public static readonly SQLByte MaxValue;
[C++]
public: static readonly SQLByte MaxValue;
[JScript]
public static var MaxValue : SQLByte;

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLByte.MinValue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly MinValue As SQLByte
[C#]
public static readonly SQLByte MinValue;
[C++]
public: static readonly SQLByte MinValue;
[JScript]
public static var MinValue : SQLByte;

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLByte.Null

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Null As SQLByte
[C#]
public static readonly SQLByte Null;
[C++]
public: static readonly SQLByte Null;
[JScript]
public static var Null : SQLByte;

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLByte.Zero

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Zero As SQLByte
[C#]
public static readonly SQLByte Zero;
[C++]
public: static readonly SQLByte Zero;
[JScript]
public static var Zero : SQLByte;

See Also

SQLByte Structure | SQLByte Members | System.Data.SQLTypes Namespace


SQLDateTime Structure

[To be supplied.]

Object
ValueType
SQLDateTime

[Visual Basic]
Public Structure SQLDateTime
   Implements INullable
[C#]
public struct SQLDateTime : INullable
[C++]
public __value struct SQLDateTime : public INullable

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQLTypes

Assembly: System.Data.dll

See Also

SQLDateTime Members | System.Data.SQLTypes Namespace


SQLDateTime Members

Public:

Constructor

SQLDateTime Constructor Overloaded. [To be supplied.]

Properties

DayTicks | [To be supplied.]
IsNull | [To be supplied.]
TimeTicks | [To be supplied.]
Value | [To be supplied.]

Methods

Day | [To be supplied.]
EQ | [To be supplied.]
Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
FromString | [To be supplied.]
GE | [To be supplied.]
GetDate | [To be supplied.]
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
GT | [To be supplied.]
LE | [To be supplied.]
LT | [To be supplied.]
Month | [To be supplied.]
NE | [To be supplied.]
ToString | Overloaded. [To be supplied.]
Year | [To be supplied.]

Operators and Type Conversions

Addition Operator | [To be supplied.]
Equality Operator | [To be supplied.]
Greater Than Operator | [To be supplied.]
Greater Than Or Equal Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Less Than Operator | [To be supplied.]
Less Than Or Equal Operator | [To be supplied.]
Subtraction Operator | [To be supplied.]
SQLDateTime to DateTime Conversion | [To be supplied.]
DateTime to SQLDateTime Conversion | [To be supplied.]

Fields

MaxValue | [To be supplied.]
MinValue | [To be supplied.]
Null | [To be supplied.]
SQLTicksPerHour | [To be supplied.]
SQLTicksPerMinute | [To be supplied.]
SQLTicksPerSecond | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLDateTime Structure | System.Data.SQLTypes Namespace


SQLDateTime Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(DateTime)
[C#] public SQLDateTime(DateTime);
[C++] public: SQLDateTime(DateTime);
[JScript] public function SQLDateTime(DateTime);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer, Integer, Integer)
[C#] public SQLDateTime(int, int, int);
[C++] public: SQLDateTime(int, int, int);
[JScript] public function SQLDateTime(int, int, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer, Integer, Integer, Integer, Integer, Integer)
[C#] public SQLDateTime(int, int, int, int, int, int);
[C++] public: SQLDateTime(int, int, int, int, int, int);
[JScript] public function SQLDateTime(int, int, int, int, int, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer, Integer, Integer, Integer, Integer, Integer, Double)
[C#] public SQLDateTime(int, int, int, int, int, int, double);
[C++] public: SQLDateTime(int, int, int, int, int, int, double);
[JScript] public function SQLDateTime(int, int, int, int, int, int, double);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer, Integer, Integer, Integer, Integer, Integer, Integer)
[C#] public SQLDateTime(int, int, int, int, int, int, int);
[C++] public: SQLDateTime(int, int, int, int, int, int, int);
[JScript] public function SQLDateTime(int, int, int, int, int, int, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer, Integer)
[C#] public SQLDateTime(int, int);
[C++] public: SQLDateTime(int, int);
[JScript] public function SQLDateTime(int, int);

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


SQLDateTime Constructor (DateTime)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As DateTime _
)
[C#]
public SQLDateTime(
   DateTime value
);
[C++]
public: SQLDateTime(
   DateTime value
);
[JScript]
public function SQLDateTime(
   value : DateTime
);

Parameters

value
[To be supplied.]

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace | SQLDateTime Constructor Overload List


SQLDateTime Constructor (Int32, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer _
)
[C#]
public SQLDateTime(
   int year,
   int month,
   int day
);
[C++]
public: SQLDateTime(
   int year,
   int month,
   int day
);
[JScript]
public function SQLDateTime(
   year : int,
   month : int,
   day : int
);

Parameters

year
[To be supplied.]
month
[To be supplied.]
day
[To be supplied.]

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace | SQLDateTime Constructor Overload List


SQLDateTime Constructor (Int32, Int32, Int32, Int32, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal hour As Integer, _
   ByVal minute As Integer, _
   ByVal second As Integer _
)
[C#]
public SQLDateTime(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second
);
[C++]
public: SQLDateTime(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second
);
[JScript]
public function SQLDateTime(
   year : int,
   month : int,
   day : int,
   hour : int,
   minute : int,
   second : int
);

Parameters

year
[To be supplied.]
month
[To be supplied.]
day
[To be supplied.]
hour
[To be supplied.]
minute
[To be supplied.]
second
[To be supplied.]

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace | SQLDateTime Constructor Overload List


SQLDateTime Constructor (Int32, Int32, Int32, Int32, Int32, Int32, Double)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal hour As Integer, _
   ByVal minute As Integer, _
   ByVal second As Integer, _
   ByVal millisecond As Double _
)
[C#]
public SQLDateTime(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   double millisecond
);
[C++]
public: SQLDateTime(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   double millisecond
);
[JScript]
public function SQLDateTime(
   year : int,
   month : int,
   day : int,
   hour : int,
   minute : int,
   second : int,
   millisecond : double
);

Parameters

year
[To be supplied.]
month
[To be supplied.]
day
[To be supplied.]
hour
[To be supplied.]
minute
[To be supplied.]
second
[To be supplied.]
millisecond
[To be supplied.]

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace | SQLDateTime Constructor Overload List


SQLDateTime Constructor (Int32, Int32, Int32, Int32, Int32, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal hour As Integer, _
   ByVal minute As Integer, _
   ByVal second As Integer, _
   ByVal bilisecond As Integer _
)
[C#]
public SQLDateTime(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   int bilisecond
);
[C++]
public: SQLDateTime(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   int bilisecond
);
[JScript]
public function SQLDateTime(
   year : int,
   month : int,
   day : int,
   hour : int,
   minute : int,
   second : int,
   bilisecond : int
);

Parameters

year
[To be supplied.]
month
[To be supplied.]
day
[To be supplied.]
hour
[To be supplied.]
minute
[To be supplied.]
second
[To be supplied.]
bilisecond
[To be supplied.]

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace | SQLDateTime Constructor Overload List


SQLDateTime Constructor (Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal dayTicks As Integer, _
   ByVal timeTicks As Integer _
)
[C#]
public SQLDateTime(
   int dayTicks,
   int timeTicks
);
[C++]
public: SQLDateTime(
   int dayTicks,
   int timeTicks
);
[JScript]
public function SQLDateTime(
   dayTicks : int,
   timeTicks : int
);

Parameters

dayTicks
[To be supplied.]
timeTicks
[To be supplied.]

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace | SQLDateTime Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLDateTime Properties

The properties of the SQLDateTime structure are listed below. For a complete list of SQLDateTime structure members, see the SQLDateTime Members topic.

Public:

DayTicks | [To be supplied.]
IsNull | [To be supplied.]
TimeTicks | [To be supplied.]
Value | [To be supplied.]

See Also

SQLDateTime Structure | System.Data.SQLTypes Namespace


SQLDateTime.DayTicks

[To be supplied.]

[Visual Basic]
Public ReadOnly Property DayTicks As Integer
[C#]
public int DayTicks {get;}
[C++]
public: __property int get_DayTicks();
[JScript]
public function get DayTicks() : int;

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


SQLDateTime.IsNull

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsNull As Boolean
[C#]
public bool IsNull {virtual get;}
[C++]
public: __property virtual bool get_IsNull();
[JScript]
public function get IsNull() : Boolean;

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


SQLDateTime.TimeTicks

[To be supplied.]

[Visual Basic]
Public ReadOnly Property TimeTicks As Integer
[C#]
public int TimeTicks {get;}
[C++]
public: __property int get_TimeTicks();
[JScript]
public function get TimeTicks() : int;

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


SQLDateTime.Value

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Value As DateTime
[C#]
public DateTime Value {get;}
[C++]
public: __property DateTime get_Value();
[JScript]
public function get Value() : DateTime;

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLDateTime Methods

The methods of the SQLDateTime structure are listed below. For a complete list of SQLDateTime structure members, see the SQLDateTime Members topic.

Public:

Day | [To be supplied.]
EQ | [To be supplied.]
Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
FromString | [To be supplied.]
GE | [To be supplied.]
GetDate | [To be supplied.]
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
GT | [To be supplied.]
LE | [To be supplied.]
LT | [To be supplied.]
Month | [To be supplied.]
NE | [To be supplied.]
ToString | Overloaded. [To be supplied.]
Year | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLDateTime Structure | System.Data.SQLTypes Namespace


SQLDateTime.Day

[To be supplied.]

[Visual Basic]
Public Function Day() As SQLInt32
[C#]
public SQLInt32 Day();
[C++]
public: SQLInt32 Day();
[JScript]
public function Day() : SQLInt32;

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


SQLDateTime.EQ

[To be supplied.]

[Visual Basic]
Public Shared Function EQ( _
   ByVal x As SQLDateTime, _
   ByVal y As SQLDateTime _
) As SQLBoolean
[C#]
public static SQLBoolean EQ(
   SQLDateTime x,
   SQLDateTime y
);
[C++]
public: static SQLBoolean EQ(
   SQLDateTime x,
   SQLDateTime y
);
[JScript]
public static function EQ(
   x : SQLDateTime,
   y : SQLDateTime
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


SQLDateTime.FromString

[To be supplied.]

[Visual Basic]
Public Shared Function FromString( _
   ByVal s As String _
) As SQLDateTime
[C#]
public static SQLDateTime FromString(
   string s
);
[C++]
public: static SQLDateTime FromString(
   String* s
);
[JScript]
public static function FromString(
   s : String
) : SQLDateTime;

Parameters

s
[To be supplied.]

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


SQLDateTime.GE

[To be supplied.]

[Visual Basic]
Public Shared Function GE( _
   ByVal x As SQLDateTime, _
   ByVal y As SQLDateTime _
) As SQLBoolean
[C#]
public static SQLBoolean GE(
   SQLDateTime x,
   SQLDateTime y
);
[C++]
public: static SQLBoolean GE(
   SQLDateTime x,
   SQLDateTime y
);
[JScript]
public static function GE(
   x : SQLDateTime,
   y : SQLDateTime
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


SQLDateTime.GetDate

[To be supplied.]

[Visual Basic]
Public Shared Function GetDate() As SQLDateTime
[C#]
public static SQLDateTime GetDate();
[C++]
public: static SQLDateTime GetDate();
[JScript]
public static function GetDate() : SQLDateTime;

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


SQLDateTime.GT

[To be supplied.]

[Visual Basic]
Public Shared Function GT( _
   ByVal x As SQLDateTime, _
   ByVal y As SQLDateTime _
) As SQLBoolean
[C#]
public static SQLBoolean GT(
   SQLDateTime x,
   SQLDateTime y
);
[C++]
public: static SQLBoolean GT(
   SQLDateTime x,
   SQLDateTime y
);
[JScript]
public static function GT(
   x : SQLDateTime,
   y : SQLDateTime
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


SQLDateTime.LE

[To be supplied.]

[Visual Basic]
Public Shared Function LE( _
   ByVal x As SQLDateTime, _
   ByVal y As SQLDateTime _
) As SQLBoolean
[C#]
public static SQLBoolean LE(
   SQLDateTime x,
   SQLDateTime y
);
[C++]
public: static SQLBoolean LE(
   SQLDateTime x,
   SQLDateTime y
);
[JScript]
public static function LE(
   x : SQLDateTime,
   y : SQLDateTime
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


SQLDateTime.LT

[To be supplied.]

[Visual Basic]
Public Shared Function LT( _
   ByVal x As SQLDateTime, _
   ByVal y As SQLDateTime _
) As SQLBoolean
[C#]
public static SQLBoolean LT(
   SQLDateTime x,
   SQLDateTime y
);
[C++]
public: static SQLBoolean LT(
   SQLDateTime x,
   SQLDateTime y
);
[JScript]
public static function LT(
   x : SQLDateTime,
   y : SQLDateTime
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


SQLDateTime.Month

[To be supplied.]

[Visual Basic]
Public Function Month() As SQLInt32
[C#]
public SQLInt32 Month();
[C++]
public: SQLInt32 Month();
[JScript]
public function Month() : SQLInt32;

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


SQLDateTime.NE

[To be supplied.]

[Visual Basic]
Public Shared Function NE( _
   ByVal x As SQLDateTime, _
   ByVal y As SQLDateTime _
) As SQLBoolean
[C#]
public static SQLBoolean NE(
   SQLDateTime x,
   SQLDateTime y
);
[C++]
public: static SQLBoolean NE(
   SQLDateTime x,
   SQLDateTime y
);
[JScript]
public static function NE(
   x : SQLDateTime,
   y : SQLDateTime
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


SQLDateTime.ToString

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overrides Public Function ToString() As String
[C#] public override string ToString();
[C++] public: override String* ToString();
[JScript] public override function ToString() : String;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToString(SQLDateTime) As String
[C#] public static string ToString(SQLDateTime);
[C++] public: static String* ToString(SQLDateTime);
[JScript] public static function ToString(SQLDateTime) : String;

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


SQLDateTime.ToString ()

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace | SQLDateTime.ToString Overload List


SQLDateTime.ToString (SQLDateTime)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As SQLDateTime _
) As String
[C#]
public static string ToString(
   SQLDateTime value
);
[C++]
public: static String* ToString(
   SQLDateTime value
);
[JScript]
public static function ToString(
   value : SQLDateTime
) : String;

Parameters

value
[To be supplied.]

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace | SQLDateTime.ToString Overload List


SQLDateTime.Year

[To be supplied.]

[Visual Basic]
Public Function Year() As SQLInt32
[C#]
public SQLInt32 Year();
[C++]
public: SQLInt32 Year();
[JScript]
public function Year() : SQLInt32;

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


Operators and Type Conversions

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLDateTime Operators and Type Conversions

The operators and type conversions of the SQLDateTime structure are listed below. For a complete list of SQLDateTime structure members, see the SQLDateTime Members topic.

Public:

Addition Operator | [To be supplied.]
Equality Operator | [To be supplied.]
Greater Than Operator | [To be supplied.]
Greater Than Or Equal Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Less Than Operator | [To be supplied.]
Less Than Or Equal Operator | [To be supplied.]
Subtraction Operator | [To be supplied.]
SQLDateTime to DateTime Conversion | [To be supplied.]
DateTime to SQLDateTime Conversion | [To be supplied.]

See Also

SQLDateTime Structure | System.Data.SQLTypes Namespace


SQLDateTime Addition Operator

[To be supplied.]

[C#]
public static SQLDateTime operator +(
   SQLDateTime x,
   SQLDateTime y
);
[C++]
public: static SQLDateTime operator op_Addition(
   SQLDateTime x,
   SQLDateTime y
);
[JScript]
returnValue = x + y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


SQLDateTime Equality Operator

[To be supplied.]

[C#]
public static SQLBoolean operator ==(
   SQLDateTime x,
   SQLDateTime y
);
[C++]
public: static SQLBoolean operator op_Equality(
   SQLDateTime x,
   SQLDateTime y
);
[JScript]
returnValue = x == y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


SQLDateTime Greater Than Operator

[To be supplied.]

[C#]
public static SQLBoolean operator >(
   SQLDateTime x,
   SQLDateTime y
);
[C++]
public: static SQLBoolean operator op_GreaterThan(
   SQLDateTime x,
   SQLDateTime y
);
[JScript]
returnValue = x > y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


SQLDateTime Greater Than Or Equal Operator

[To be supplied.]

[C#]
public static SQLBoolean operator >=(
   SQLDateTime x,
   SQLDateTime y
);
[C++]
public: static SQLBoolean operator op_GreaterThanOrEqual(
   SQLDateTime x,
   SQLDateTime y
);
[JScript]
returnValue = x >= y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


SQLDateTime Inequality Operator

[To be supplied.]

[C#]
public static SQLBoolean operator !=(
   SQLDateTime x,
   SQLDateTime y
);
[C++]
public: static SQLBoolean operator op_Inequality(
   SQLDateTime x,
   SQLDateTime y
);
[JScript]
returnValue = x ! = y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


SQLDateTime Less Than Operator

[To be supplied.]

[C#]
public static SQLBoolean operator <(
   SQLDateTime x,
   SQLDateTime y
);
[C++]
public: static SQLBoolean operator op_LessThan(
   SQLDateTime x,
   SQLDateTime y
);
[JScript]
returnValue = x < y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


SQLDateTime Less Than Or Equal Operator

[To be supplied.]

[C#]
public static SQLBoolean operator <=(
   SQLDateTime x,
   SQLDateTime y
);
[C++]
public: static SQLBoolean operator op_LessThanOrEqual(
   SQLDateTime x,
   SQLDateTime y
);
[JScript]
returnValue = x <= y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


SQLDateTime Subtraction Operator

[To be supplied.]

[C#]
public static SQLDateTime operator -(
   SQLDateTime x,
   SQLDateTime y
);
[C++]
public: static SQLDateTime operator op_Subtraction(
   SQLDateTime x,
   SQLDateTime y
);
[JScript]
returnValue = x - y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


SQLDateTime to DateTime Conversion

[To be supplied.]

[C#]
public static explicit operator DateTime(
   SQLDateTime x
);
[C++]
public: operator DateTime();
[JScript]
returnValue = DateTime(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#]

x
[To be supplied.]

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


DateTime to SQLDateTime Conversion

[To be supplied.]

[C#]
public static implicit operator SQLDateTime(
   DateTime value
);
[C++]
public: static SQLDateTime op_Implicit(
   DateTime value
);
[JScript]
returnValue = value;

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#, C++]

value
[To be supplied.]

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLDateTime Fields

The fields of the SQLDateTime structure are listed below. For a complete list of SQLDateTime structure members, see the SQLDateTime Members topic.

Public:

MaxValue | [To be supplied.]
MinValue | [To be supplied.]
Null | [To be supplied.]
SQLTicksPerHour | [To be supplied.]
SQLTicksPerMinute | [To be supplied.]
SQLTicksPerSecond | [To be supplied.]

See Also

SQLDateTime Structure | System.Data.SQLTypes Namespace


SQLDateTime.MaxValue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly MaxValue As SQLDateTime
[C#]
public static readonly SQLDateTime MaxValue;
[C++]
public: static readonly SQLDateTime MaxValue;
[JScript]
public static var MaxValue : SQLDateTime;

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


SQLDateTime.MinValue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly MinValue As SQLDateTime
[C#]
public static readonly SQLDateTime MinValue;
[C++]
public: static readonly SQLDateTime MinValue;
[JScript]
public static var MinValue : SQLDateTime;

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


SQLDateTime.Null

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Null As SQLDateTime
[C#]
public static readonly SQLDateTime Null;
[C++]
public: static readonly SQLDateTime Null;
[JScript]
public static var Null : SQLDateTime;

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


SQLDateTime.SQLTicksPerHour

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly SQLTicksPerHour As Integer
[C#]
public static readonly int SQLTicksPerHour;
[C++]
public: static readonly int SQLTicksPerHour;
[JScript]
public static var SQLTicksPerHour : int;

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


SQLDateTime.SQLTicksPerMinute

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly SQLTicksPerMinute As Integer
[C#]
public static readonly int SQLTicksPerMinute;
[C++]
public: static readonly int SQLTicksPerMinute;
[JScript]
public static var SQLTicksPerMinute : int;

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


SQLDateTime.SQLTicksPerSecond

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly SQLTicksPerSecond As Integer
[C#]
public static readonly int SQLTicksPerSecond;
[C++]
public: static readonly int SQLTicksPerSecond;
[JScript]
public static var SQLTicksPerSecond : int;

See Also

SQLDateTime Structure | SQLDateTime Members | System.Data.SQLTypes Namespace


SQLDouble Structure

[To be supplied.]

Object
ValueType
SQLDouble

[Visual Basic]
Public Structure SQLDouble
   Implements INullable
[C#]
public struct SQLDouble : INullable
[C++]
public __value struct SQLDouble : public INullable

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQLTypes

Assembly: System.Data.dll

See Also

SQLDouble Members | System.Data.SQLTypes Namespace


SQLDouble Members

Public:

Constructor

SQLDouble Constructor [To be supplied.]

Properties

IsNull | [To be supplied.]
Value | [To be supplied.]

Methods

EQ | [To be supplied.]
Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
FromString | [To be supplied.]
GE | [To be supplied.]
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
GT | [To be supplied.]
LE | [To be supplied.]
LT | [To be supplied.]
NE | [To be supplied.]
ToString | Overloaded. [To be supplied.]

Operators and Type Conversions

Addition Operator | [To be supplied.]
Division Operator | [To be supplied.]
Equality Operator | [To be supplied.]
Greater Than Operator | [To be supplied.]
Greater Than Or Equal Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Less Than Operator | [To be supplied.]
Less Than Or Equal Operator | [To be supplied.]
Modulus Operator | [To be supplied.]
Multiplication Operator | [To be supplied.]
Subtraction Operator | [To be supplied.]
Unary Negation Operator | [To be supplied.]
SQLDouble to Double Conversion | [To be supplied.]
SQLString to SQLDouble Conversion | [To be supplied.]
SQLDouble to SQLNumeric Conversion | [To be supplied.]
SQLMoney to SQLDouble Conversion | Overloaded. [To be supplied.]

Fields

MaxValue | [To be supplied.]
MinValue | [To be supplied.]
Null | [To be supplied.]
Zero | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLDouble Structure | System.Data.SQLTypes Namespace


SQLDouble Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal value As Double _
)
[C#]
public SQLDouble(
   double value
);
[C++]
public: SQLDouble(
   double value
);
[JScript]
public function SQLDouble(
   value : double
);

Parameters

value
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLDouble Properties

The properties of the SQLDouble structure are listed below. For a complete list of SQLDouble structure members, see the SQLDouble Members topic.

Public:

IsNull | [To be supplied.]
Value | [To be supplied.]

See Also

SQLDouble Structure | System.Data.SQLTypes Namespace


SQLDouble.IsNull

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsNull As Boolean
[C#]
public bool IsNull {virtual get;}
[C++]
public: __property virtual bool get_IsNull();
[JScript]
public function get IsNull() : Boolean;

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace


SQLDouble.Value

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Value As Double
[C#]
public double Value {get;}
[C++]
public: __property double get_Value();
[JScript]
public function get Value() : double;

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLDouble Methods

The methods of the SQLDouble structure are listed below. For a complete list of SQLDouble structure members, see the SQLDouble Members topic.

Public:

EQ | [To be supplied.]
Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
FromString | [To be supplied.]
GE | [To be supplied.]
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
GT | [To be supplied.]
LE | [To be supplied.]
LT | [To be supplied.]
NE | [To be supplied.]
ToString | Overloaded. [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLDouble Structure | System.Data.SQLTypes Namespace


SQLDouble.EQ

[To be supplied.]

[Visual Basic]
Public Shared Function EQ( _
   ByVal x As SQLDouble, _
   ByVal y As SQLDouble _
) As SQLBoolean
[C#]
public static SQLBoolean EQ(
   SQLDouble x,
   SQLDouble y
);
[C++]
public: static SQLBoolean EQ(
   SQLDouble x,
   SQLDouble y
);
[JScript]
public static function EQ(
   x : SQLDouble,
   y : SQLDouble
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace


SQLDouble.FromString

[To be supplied.]

[Visual Basic]
Public Shared Function FromString( _
   ByVal s As String _
) As SQLDouble
[C#]
public static SQLDouble FromString(
   string s
);
[C++]
public: static SQLDouble FromString(
   String* s
);
[JScript]
public static function FromString(
   s : String
) : SQLDouble;

Parameters

s
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace


SQLDouble.GE

[To be supplied.]

[Visual Basic]
Public Shared Function GE( _
   ByVal x As SQLDouble, _
   ByVal y As SQLDouble _
) As SQLBoolean
[C#]
public static SQLBoolean GE(
   SQLDouble x,
   SQLDouble y
);
[C++]
public: static SQLBoolean GE(
   SQLDouble x,
   SQLDouble y
);
[JScript]
public static function GE(
   x : SQLDouble,
   y : SQLDouble
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace


SQLDouble.GT

[To be supplied.]

[Visual Basic]
Public Shared Function GT( _
   ByVal x As SQLDouble, _
   ByVal y As SQLDouble _
) As SQLBoolean
[C#]
public static SQLBoolean GT(
   SQLDouble x,
   SQLDouble y
);
[C++]
public: static SQLBoolean GT(
   SQLDouble x,
   SQLDouble y
);
[JScript]
public static function GT(
   x : SQLDouble,
   y : SQLDouble
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace


SQLDouble.LE

[To be supplied.]

[Visual Basic]
Public Shared Function LE( _
   ByVal x As SQLDouble, _
   ByVal y As SQLDouble _
) As SQLBoolean
[C#]
public static SQLBoolean LE(
   SQLDouble x,
   SQLDouble y
);
[C++]
public: static SQLBoolean LE(
   SQLDouble x,
   SQLDouble y
);
[JScript]
public static function LE(
   x : SQLDouble,
   y : SQLDouble
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace


SQLDouble.LT

[To be supplied.]

[Visual Basic]
Public Shared Function LT( _
   ByVal x As SQLDouble, _
   ByVal y As SQLDouble _
) As SQLBoolean
[C#]
public static SQLBoolean LT(
   SQLDouble x,
   SQLDouble y
);
[C++]
public: static SQLBoolean LT(
   SQLDouble x,
   SQLDouble y
);
[JScript]
public static function LT(
   x : SQLDouble,
   y : SQLDouble
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace


SQLDouble.NE

[To be supplied.]

[Visual Basic]
Public Shared Function NE( _
   ByVal x As SQLDouble, _
   ByVal y As SQLDouble _
) As SQLBoolean
[C#]
public static SQLBoolean NE(
   SQLDouble x,
   SQLDouble y
);
[C++]
public: static SQLBoolean NE(
   SQLDouble x,
   SQLDouble y
);
[JScript]
public static function NE(
   x : SQLDouble,
   y : SQLDouble
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace


SQLDouble.ToString

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToString(SQLDouble) As String
[C#] public static string ToString(SQLDouble);
[C++] public: static String* ToString(SQLDouble);
[JScript] public static function ToString(SQLDouble) : String;

[To be supplied.]

[Visual Basic] Overloads Overrides Public Function ToString() As String
[C#] public override string ToString();
[C++] public: override String* ToString();
[JScript] public override function ToString() : String;

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace


SQLDouble.ToString (SQLDouble)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As SQLDouble _
) As String
[C#]
public static string ToString(
   SQLDouble value
);
[C++]
public: static String* ToString(
   SQLDouble value
);
[JScript]
public static function ToString(
   value : SQLDouble
) : String;

Parameters

value
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace | SQLDouble.ToString Overload List


SQLDouble.ToString ()

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace | SQLDouble.ToString Overload List


Operators and Type Conversions

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLDouble Operators and Type Conversions

The operators and type conversions of the SQLDouble structure are listed below. For a complete list of SQLDouble structure members, see the SQLDouble Members topic.

Public:

Addition Operator | [To be supplied.]
Division Operator | [To be supplied.]
Equality Operator | [To be supplied.]
Greater Than Operator | [To be supplied.]
Greater Than Or Equal Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Less Than Operator | [To be supplied.]
Less Than Or Equal Operator | [To be supplied.]
Modulus Operator | [To be supplied.]
Multiplication Operator | [To be supplied.]
Subtraction Operator | [To be supplied.]
Unary Negation Operator | [To be supplied.]
SQLDouble to Double Conversion | [To be supplied.]
SQLString to SQLDouble Conversion | [To be supplied.]
SQLDouble to SQLNumeric Conversion | [To be supplied.]
SQLMoney to SQLDouble Conversion | Overloaded. [To be supplied.]

See Also

SQLDouble Structure | System.Data.SQLTypes Namespace


SQLDouble Addition Operator

[To be supplied.]

[C#]
public static SQLDouble operator +(
   SQLDouble x,
   SQLDouble y
);
[C++]
public: static SQLDouble operator op_Addition(
   SQLDouble x,
   SQLDouble y
);
[JScript]
returnValue = x + y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace


SQLDouble Division Operator

[To be supplied.]

[C#]
public static SQLDouble operator /(
   SQLDouble x,
   SQLDouble y
);
[C++]
public: static SQLDouble operator op_Division(
   SQLDouble x,
   SQLDouble y
);
[JScript]
returnValue = x / y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace


SQLDouble Equality Operator

[To be supplied.]

[C#]
public static SQLBoolean operator ==(
   SQLDouble x,
   SQLDouble y
);
[C++]
public: static SQLBoolean operator op_Equality(
   SQLDouble x,
   SQLDouble y
);
[JScript]
returnValue = x == y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace


SQLDouble Greater Than Operator

[To be supplied.]

[C#]
public static SQLBoolean operator >(
   SQLDouble x,
   SQLDouble y
);
[C++]
public: static SQLBoolean operator op_GreaterThan(
   SQLDouble x,
   SQLDouble y
);
[JScript]
returnValue = x > y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace


SQLDouble Greater Than Or Equal Operator

[To be supplied.]

[C#]
public static SQLBoolean operator >=(
   SQLDouble x,
   SQLDouble y
);
[C++]
public: static SQLBoolean operator op_GreaterThanOrEqual(
   SQLDouble x,
   SQLDouble y
);
[JScript]
returnValue = x >= y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace


SQLDouble Inequality Operator

[To be supplied.]

[C#]
public static SQLBoolean operator !=(
   SQLDouble x,
   SQLDouble y
);
[C++]
public: static SQLBoolean operator op_Inequality(
   SQLDouble x,
   SQLDouble y
);
[JScript]
returnValue = x ! = y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace


SQLDouble Less Than Operator

[To be supplied.]

[C#]
public static SQLBoolean operator <(
   SQLDouble x,
   SQLDouble y
);
[C++]
public: static SQLBoolean operator op_LessThan(
   SQLDouble x,
   SQLDouble y
);
[JScript]
returnValue = x < y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace


SQLDouble Less Than Or Equal Operator

[To be supplied.]

[C#]
public static SQLBoolean operator <=(
   SQLDouble x,
   SQLDouble y
);
[C++]
public: static SQLBoolean operator op_LessThanOrEqual(
   SQLDouble x,
   SQLDouble y
);
[JScript]
returnValue = x <= y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace


SQLDouble Modulus Operator

[To be supplied.]

[C#]
public static SQLDouble operator %(
   SQLDouble x,
   SQLDouble y
);
[C++]
public: static SQLDouble operator op_Modulus(
   SQLDouble x,
   SQLDouble y
);
[JScript]
returnValue = x % y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace


SQLDouble Multiplication Operator

[To be supplied.]

[C#]
public static SQLDouble operator *(
   SQLDouble x,
   SQLDouble y
);
[C++]
public: static SQLDouble operator op_Multiply(
   SQLDouble x,
   SQLDouble y
);
[JScript]
returnValue = x * y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace


SQLDouble Subtraction Operator

[To be supplied.]

[C#]
public static SQLDouble operator -(
   SQLDouble x,
   SQLDouble y
);
[C++]
public: static SQLDouble operator op_Subtraction(
   SQLDouble x,
   SQLDouble y
);
[JScript]
returnValue = x - y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace


SQLDouble Unary Negation Operator

[To be supplied.]

[C#]
public static SQLDouble operator -(
   SQLDouble x
);
[C++]
public: static SQLDouble operator op_UnaryNegation(
   SQLDouble x
);
[JScript]
returnValue = -x;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace


SQLDouble to Double Conversion

[To be supplied.]

[C#]
public static explicit operator double(
   SQLDouble x
);
[C++]
public: operator double();
[JScript]
returnValue = Double(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#]

x
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace


SQLString to SQLDouble Conversion

[To be supplied.]

[C#]
public static explicit operator SQLDouble(
   SQLString x
);
[C++]
public: static SQLDouble op_Explicit(
   SQLString* x
);
[JScript]
returnValue = SQLDouble(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace


SQLDouble to SQLNumeric Conversion

[To be supplied.]

[C#]
public static explicit operator SQLNumeric(
   SQLDouble x
);
[C++]
public: operator SQLNumeric();
[JScript]
returnValue = SQLNumeric(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#]

x
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace


NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLMoney to SQLDouble Conversion

Build number 1812.

© 2000 Microsoft Corporation. All rights reserved.


Double to SQLDouble Conversion

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Double to SQLDouble Conversion (Double)

[To be supplied.]

[C#]
public static implicit operator SQLDouble(
   double x
);
[C++]
public: static SQLDouble op_Implicit(
   double x
);
[JScript]
returnValue = x;

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace | SQLDouble to Conversion Overload List


SQLNumeric to SQLDouble Conversion

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLNumeric to SQLDouble Conversion (SQLNumeric)

[To be supplied.]

[C#]
public static implicit operator SQLDouble(
   SQLNumeric x
);
[C++]
public: static SQLDouble op_Implicit(
   SQLNumeric x
);
[JScript]
returnValue = x;

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace | SQLDouble to Conversion Overload List


SQLByte to SQLDouble Conversion

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLByte to SQLDouble Conversion (SQLByte)

[To be supplied.]

[C#]
public static implicit operator SQLDouble(
   SQLByte x
);
[C++]
public: static SQLDouble op_Implicit(
   SQLByte x
);
[JScript]
returnValue = x;

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace | SQLDouble to Conversion Overload List


SQLBit to SQLDouble Conversion

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLBit to SQLDouble Conversion (SQLBit)

[To be supplied.]

[C#]
public static implicit operator SQLDouble(
   SQLBit x
);
[C++]
public: static SQLDouble op_Implicit(
   SQLBit x
);
[JScript]
returnValue = x;

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace | SQLDouble to Conversion Overload List


SQLInt16 to SQLDouble Conversion

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLInt16 to SQLDouble Conversion (SQLInt16)

[To be supplied.]

[C#]
public static implicit operator SQLDouble(
   SQLInt16 x
);
[C++]
public: static SQLDouble op_Implicit(
   SQLInt16 x
);
[JScript]
returnValue = x;

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace | SQLDouble to Conversion Overload List


SQLInt64 to SQLDouble Conversion

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLInt64 to SQLDouble Conversion (SQLInt64)

[To be supplied.]

[C#]
public static implicit operator SQLDouble(
   SQLInt64 x
);
[C++]
public: static SQLDouble op_Implicit(
   SQLInt64 x
);
[JScript]
returnValue = x;

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace | SQLDouble to Conversion Overload List


SQLInt32 to SQLDouble Conversion

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLInt32 to SQLDouble Conversion (SQLInt32)

[To be supplied.]

[C#]
public static implicit operator SQLDouble(
   SQLInt32 x
);
[C++]
public: static SQLDouble op_Implicit(
   SQLInt32 x
);
[JScript]
returnValue = x;

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace | SQLDouble to Conversion Overload List


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLDouble Fields

The fields of the SQLDouble structure are listed below. For a complete list of SQLDouble structure members, see the SQLDouble Members topic.

Public:

MaxValue | [To be supplied.]
MinValue | [To be supplied.]
Null | [To be supplied.]
Zero | [To be supplied.]

See Also

SQLDouble Structure | System.Data.SQLTypes Namespace


SQLDouble.MaxValue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly MaxValue As SQLDouble
[C#]
public static readonly SQLDouble MaxValue;
[C++]
public: static readonly SQLDouble MaxValue;
[JScript]
public static var MaxValue : SQLDouble;

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace


SQLDouble.MinValue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly MinValue As SQLDouble
[C#]
public static readonly SQLDouble MinValue;
[C++]
public: static readonly SQLDouble MinValue;
[JScript]
public static var MinValue : SQLDouble;

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace


SQLDouble.Null

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Null As SQLDouble
[C#]
public static readonly SQLDouble Null;
[C++]
public: static readonly SQLDouble Null;
[JScript]
public static var Null : SQLDouble;

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace


SQLDouble.Zero

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Zero As SQLDouble
[C#]
public static readonly SQLDouble Zero;
[C++]
public: static readonly SQLDouble Zero;
[JScript]
public static var Zero : SQLDouble;

See Also

SQLDouble Structure | SQLDouble Members | System.Data.SQLTypes Namespace


SQLException Class

[To be supplied.]

Object
Exception
SQLException

[Visual Basic]
Public Class SQLException
   Inherits Exception
[C#]
public class SQLException : Exception
[C++]
public __gc class SQLException : public Exception
[JScript]
public class SQLException extends Exception

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQLTypes

Assembly: System.Data.dll

See Also

SQLException Members | System.Data.SQLTypes Namespace


SQLException Members

Public:

Constructor

SQLException Constructor [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

SQLException Class | System.Data.SQLTypes Namespace


SQLException Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal message As String _
)
[C#]
public SQLException(
   string message
);
[C++]
public: SQLException(
   String* message
);
[JScript]
public function SQLException(
   message : String
);

Parameters

message
[To be supplied.]

See Also

SQLException Class | SQLException Members | System.Data.SQLTypes Namespace


SQLGuid Structure

[To be supplied.]

Object
ValueType
SQLGuid

[Visual Basic]
Public Structure SQLGuid
   Implements INullable
[C#]
public struct SQLGuid : INullable
[C++]
public __value struct SQLGuid : public INullable

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQLTypes

Assembly: System.Data.dll

See Also

SQLGuid Members | System.Data.SQLTypes Namespace


SQLGuid Members

Public:

Constructor

SQLGuid Constructor Overloaded. [To be supplied.]

Properties

IsNull | [To be supplied.]
Value | [To be supplied.]

Methods

EQ | [To be supplied.]
Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
FromString | [To be supplied.]
GE | [To be supplied.]
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
GT | [To be supplied.]
LE | [To be supplied.]
LT | [To be supplied.]
NE | [To be supplied.]
ToByteArray | [To be supplied.]
ToString | Overloaded. [To be supplied.]

Operators and Type Conversions

Equality Operator | [To be supplied.]
Greater Than Operator | [To be supplied.]
Greater Than Or Equal Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Less Than Operator | [To be supplied.]
Less Than Or Equal Operator | [To be supplied.]
SQLString to SQLGuid Conversion | [To be supplied.]
SQLBinary to SQLGuid Conversion | [To be supplied.]
SQLGuid to Guid Conversion | [To be supplied.]
Guid to SQLGuid Conversion | [To be supplied.]

Fields

Null [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLGuid Structure | System.Data.SQLTypes Namespace


SQLGuid Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Byte())
[C#] public SQLGuid(byte[]);
[C++] public: SQLGuid(unsigned char*[]);
[JScript] public function SQLGuid(Byte[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public SQLGuid(String);
[C++] public: SQLGuid(String*);
[JScript] public function SQLGuid(String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Guid)
[C#] public SQLGuid(Guid);
[C++] public: SQLGuid(Guid);
[JScript] public function SQLGuid(Guid);

See Also

SQLGuid Structure | SQLGuid Members | System.Data.SQLTypes Namespace


SQLGuid Constructor (Byte[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal value() As Byte _
)
[C#]
public SQLGuid(
   byte[] value
);
[C++]
public: SQLGuid(
   unsigned char* value[]
);
[JScript]
public function SQLGuid(
   value : Byte[]
);

Parameters

value
[To be supplied.]

See Also

SQLGuid Structure | SQLGuid Members | System.Data.SQLTypes Namespace | SQLGuid Constructor Overload List


SQLGuid Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal s As String _
)
[C#]
public SQLGuid(
   string s
);
[C++]
public: SQLGuid(
   String* s
);
[JScript]
public function SQLGuid(
   s : String
);

Parameters

s
[To be supplied.]

See Also

SQLGuid Structure | SQLGuid Members | System.Data.SQLTypes Namespace | SQLGuid Constructor Overload List


SQLGuid Constructor (Guid)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal g As Guid _
)
[C#]
public SQLGuid(
   Guid g
);
[C++]
public: SQLGuid(
   Guid g
);
[JScript]
public function SQLGuid(
   g : Guid
);

Parameters

g
[To be supplied.]

See Also

SQLGuid Structure | SQLGuid Members | System.Data.SQLTypes Namespace | SQLGuid Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLGuid Properties

The properties of the SQLGuid structure are listed below. For a complete list of SQLGuid structure members, see the SQLGuid Members topic.

Public:

IsNull | [To be supplied.]
Value | [To be supplied.]

See Also

SQLGuid Structure | System.Data.SQLTypes Namespace


SQLGuid.IsNull

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsNull As Boolean
[C#]
public bool IsNull {virtual get;}
[C++]
public: __property virtual bool get_IsNull();
[JScript]
public function get IsNull() : Boolean;

See Also

SQLGuid Structure | SQLGuid Members | System.Data.SQLTypes Namespace


SQLGuid.Value

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Value As Guid
[C#]
public Guid Value {get;}
[C++]
public: __property Guid get_Value();
[JScript]
public function get Value() : Guid;

See Also

SQLGuid Structure | SQLGuid Members | System.Data.SQLTypes Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLGuid Methods

The methods of the SQLGuid structure are listed below. For a complete list of SQLGuid structure members, see the SQLGuid Members topic.

Public:

EQ | [To be supplied.]
Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
FromString | [To be supplied.]
GE | [To be supplied.]
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
GT | [To be supplied.]
LE | [To be supplied.]
LT | [To be supplied.]
NE | [To be supplied.]
ToByteArray | [To be supplied.]
ToString | Overloaded. [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLGuid Structure | System.Data.SQLTypes Namespace


SQLGuid.EQ

[To be supplied.]

[Visual Basic]
Public Shared Function EQ( _
   ByVal x As SQLGuid, _
   ByVal y As SQLGuid _
) As SQLBoolean
[C#]
public static SQLBoolean EQ(
   SQLGuid x,
   SQLGuid y
);
[C++]
public: static SQLBoolean EQ(
   SQLGuid x,
   SQLGuid y
);
[JScript]
public static function EQ(
   x : SQLGuid,
   y : SQLGuid
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLGuid Structure | SQLGuid Members | System.Data.SQLTypes Namespace


SQLGuid.FromString

[To be supplied.]

[Visual Basic]
Public Shared Function FromString( _
   ByVal s As String _
) As SQLGuid
[C#]
public static SQLGuid FromString(
   string s
);
[C++]
public: static SQLGuid FromString(
   String* s
);
[JScript]
public static function FromString(
   s : String
) : SQLGuid;

Parameters

s
[To be supplied.]

See Also

SQLGuid Structure | SQLGuid Members | System.Data.SQLTypes Namespace


SQLGuid.GE

[To be supplied.]

[Visual Basic]
Public Shared Function GE( _
   ByVal x As SQLGuid, _
   ByVal y As SQLGuid _
) As SQLBoolean
[C#]
public static SQLBoolean GE(
   SQLGuid x,
   SQLGuid y
);
[C++]
public: static SQLBoolean GE(
   SQLGuid x,
   SQLGuid y
);
[JScript]
public static function GE(
   x : SQLGuid,
   y : SQLGuid
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLGuid Structure | SQLGuid Members | System.Data.SQLTypes Namespace


SQLGuid.GT

[To be supplied.]

[Visual Basic]
Public Shared Function GT( _
   ByVal x As SQLGuid, _
   ByVal y As SQLGuid _
) As SQLBoolean
[C#]
public static SQLBoolean GT(
   SQLGuid x,
   SQLGuid y
);
[C++]
public: static SQLBoolean GT(
   SQLGuid x,
   SQLGuid y
);
[JScript]
public static function GT(
   x : SQLGuid,
   y : SQLGuid
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLGuid Structure | SQLGuid Members | System.Data.SQLTypes Namespace


SQLGuid.LE

[To be supplied.]

[Visual Basic]
Public Shared Function LE( _
   ByVal x As SQLGuid, _
   ByVal y As SQLGuid _
) As SQLBoolean
[C#]
public static SQLBoolean LE(
   SQLGuid x,
   SQLGuid y
);
[C++]
public: static SQLBoolean LE(
   SQLGuid x,
   SQLGuid y
);
[JScript]
public static function LE(
   x : SQLGuid,
   y : SQLGuid
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLGuid Structure | SQLGuid Members | System.Data.SQLTypes Namespace


SQLGuid.LT

[To be supplied.]

[Visual Basic]
Public Shared Function LT( _
   ByVal x As SQLGuid, _
   ByVal y As SQLGuid _
) As SQLBoolean
[C#]
public static SQLBoolean LT(
   SQLGuid x,
   SQLGuid y
);
[C++]
public: static SQLBoolean LT(
   SQLGuid x,
   SQLGuid y
);
[JScript]
public static function LT(
   x : SQLGuid,
   y : SQLGuid
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLGuid Structure | SQLGuid Members | System.Data.SQLTypes Namespace


SQLGuid.NE

[To be supplied.]

[Visual Basic]
Public Shared Function NE( _
   ByVal x As SQLGuid, _
   ByVal y As SQLGuid _
) As SQLBoolean
[C#]
public static SQLBoolean NE(
   SQLGuid x,
   SQLGuid y
);
[C++]
public: static SQLBoolean NE(
   SQLGuid x,
   SQLGuid y
);
[JScript]
public static function NE(
   x : SQLGuid,
   y : SQLGuid
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLGuid Structure | SQLGuid Members | System.Data.SQLTypes Namespace


SQLGuid.ToByteArray

[To be supplied.]

[Visual Basic]
Public Function ToByteArray() As Byte ()
[C#]
public byte[] ToByteArray();
[C++]
public: unsigned char* ToByteArray() [];
[JScript]
public function ToByteArray() : Byte[];

See Also

SQLGuid Structure | SQLGuid Members | System.Data.SQLTypes Namespace


SQLGuid.ToString

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overrides Public Function ToString() As String
[C#] public override string ToString();
[C++] public: override String* ToString();
[JScript] public override function ToString() : String;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToString(SQLGuid) As String
[C#] public static string ToString(SQLGuid);
[C++] public: static String* ToString(SQLGuid);
[JScript] public static function ToString(SQLGuid) : String;

See Also

SQLGuid Structure | SQLGuid Members | System.Data.SQLTypes Namespace


SQLGuid.ToString ()

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

SQLGuid Structure | SQLGuid Members | System.Data.SQLTypes Namespace | SQLGuid.ToString Overload List


SQLGuid.ToString (SQLGuid)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As SQLGuid _
) As String
[C#]
public static string ToString(
   SQLGuid value
);
[C++]
public: static String* ToString(
   SQLGuid value
);
[JScript]
public static function ToString(
   value : SQLGuid
) : String;

Parameters

value
[To be supplied.]

See Also

SQLGuid Structure | SQLGuid Members | System.Data.SQLTypes Namespace | SQLGuid.ToString Overload List


Operators and Type Conversions

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLGuid Operators and Type Conversions

The operators and type conversions of the SQLGuid structure are listed below. For a complete list of SQLGuid structure members, see the SQLGuid Members topic.

Public:

Equality Operator | [To be supplied.]
Greater Than Operator | [To be supplied.]
Greater Than Or Equal Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Less Than Operator | [To be supplied.]
Less Than Or Equal Operator | [To be supplied.]
SQLString to SQLGuid Conversion | [To be supplied.]
SQLBinary to SQLGuid Conversion | [To be supplied.]
SQLGuid to Guid Conversion | [To be supplied.]
Guid to SQLGuid Conversion | [To be supplied.]

See Also

SQLGuid Structure | System.Data.SQLTypes Namespace


SQLGuid Equality Operator

[To be supplied.]

[C#]
public static SQLBoolean operator ==(
   SQLGuid x,
   SQLGuid y
);
[C++]
public: static SQLBoolean operator op_Equality(
   SQLGuid x,
   SQLGuid y
);
[JScript]
returnValue = x == y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLGuid Structure | SQLGuid Members | System.Data.SQLTypes Namespace


SQLGuid Greater Than Operator

[To be supplied.]

[C#]
public static SQLBoolean operator >(
   SQLGuid x,
   SQLGuid y
);
[C++]
public: static SQLBoolean operator op_GreaterThan(
   SQLGuid x,
   SQLGuid y
);
[JScript]
returnValue = x > y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLGuid Structure | SQLGuid Members | System.Data.SQLTypes Namespace


SQLGuid Greater Than Or Equal Operator

[To be supplied.]

[C#]
public static SQLBoolean operator >=(
   SQLGuid x,
   SQLGuid y
);
[C++]
public: static SQLBoolean operator op_GreaterThanOrEqual(
   SQLGuid x,
   SQLGuid y
);
[JScript]
returnValue = x >= y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLGuid Structure | SQLGuid Members | System.Data.SQLTypes Namespace


SQLGuid Inequality Operator

[To be supplied.]

[C#]
public static SQLBoolean operator !=(
   SQLGuid x,
   SQLGuid y
);
[C++]
public: static SQLBoolean operator op_Inequality(
   SQLGuid x,
   SQLGuid y
);
[JScript]
returnValue = x ! = y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLGuid Structure | SQLGuid Members | System.Data.SQLTypes Namespace


SQLGuid Less Than Operator

[To be supplied.]

[C#]
public static SQLBoolean operator <(
   SQLGuid x,
   SQLGuid y
);
[C++]
public: static SQLBoolean operator op_LessThan(
   SQLGuid x,
   SQLGuid y
);
[JScript]
returnValue = x < y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLGuid Structure | SQLGuid Members | System.Data.SQLTypes Namespace


SQLGuid Less Than Or Equal Operator

[To be supplied.]

[C#]
public static SQLBoolean operator <=(
   SQLGuid x,
   SQLGuid y
);
[C++]
public: static SQLBoolean operator op_LessThanOrEqual(
   SQLGuid x,
   SQLGuid y
);
[JScript]
returnValue = x <= y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLGuid Structure | SQLGuid Members | System.Data.SQLTypes Namespace


SQLString to SQLGuid Conversion

[To be supplied.]

[C#]
public static explicit operator SQLGuid(
   SQLString x
);
[C++]
public: static SQLGuid op_Explicit(
   SQLString* x
);
[JScript]
returnValue = SQLGuid(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLGuid Structure | SQLGuid Members | System.Data.SQLTypes Namespace


SQLBinary to SQLGuid Conversion

[To be supplied.]

[C#]
public static explicit operator SQLGuid(
   SQLBinary x
);
[C++]
public: static SQLGuid op_Explicit(
   SQLBinary* x
);
[JScript]
returnValue = SQLGuid(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLGuid Structure | SQLGuid Members | System.Data.SQLTypes Namespace


SQLGuid to Guid Conversion

[To be supplied.]

[C#]
public static explicit operator Guid(
   SQLGuid x
);
[C++]
public: operator Guid();
[JScript]
returnValue = Guid(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#]

x
[To be supplied.]

See Also

SQLGuid Structure | SQLGuid Members | System.Data.SQLTypes Namespace


Guid to SQLGuid Conversion

[To be supplied.]

[C#]
public static implicit operator SQLGuid(
   Guid x
);
[C++]
public: static SQLGuid op_Implicit(
   Guid x
);
[JScript]
returnValue = x;

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLGuid Structure | SQLGuid Members | System.Data.SQLTypes Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLGuid Fields

The fields of the SQLGuid structure are listed below. For a complete list of SQLGuid structure members, see the SQLGuid Members topic.

Public:

Null [To be supplied.]

See Also

SQLGuid Structure | System.Data.SQLTypes Namespace


SQLGuid.Null

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Null As SQLGuid
[C#]
public static readonly SQLGuid Null;
[C++]
public: static readonly SQLGuid Null;
[JScript]
public static var Null : SQLGuid;

See Also

SQLGuid Structure | SQLGuid Members | System.Data.SQLTypes Namespace


SQLInt16 Structure

[To be supplied.]

Object
ValueType
SQLInt16

[Visual Basic]
Public Structure SQLInt16
   Implements INullable
[C#]
public struct SQLInt16 : INullable
[C++]
public __value struct SQLInt16 : public INullable

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQLTypes

Assembly: System.Data.dll

See Also

SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt16 Members

Public:

Constructor

SQLInt16 Constructor [To be supplied.]

Properties

IsNull | [To be supplied.]
Value | [To be supplied.]

Methods

EQ | [To be supplied.]
Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
FromString | [To be supplied.]
GE | [To be supplied.]
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
GT | [To be supplied.]
LE | [To be supplied.]
LT | [To be supplied.]
NE | [To be supplied.]
ToString | Overloaded. [To be supplied.]

Operators and Type Conversions

Addition Operator | [To be supplied.]
Bitwise And Operator | [To be supplied.]
Bitwise Or Operator | [To be supplied.]
Division Operator | [To be supplied.]
Equality Operator | [To be supplied.]
Exclusive Or Operator | [To be supplied.]
Greater Than Operator | [To be supplied.]
Greater Than Or Equal Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Less Than Operator | [To be supplied.]
Less Than Or Equal Operator | [To be supplied.]
Modulus Operator | [To be supplied.]
Multiplication Operator | [To be supplied.]
Ones Complement Operator | [To be supplied.]
Subtraction Operator | [To be supplied.]
Unary Negation Operator | [To be supplied.]
SQLDouble to SQLInt16 Conversion | [To be supplied.]
SQLInt64 to SQLInt16 Conversion | [To be supplied.]
SQLSingle to SQLInt16 Conversion | [To be supplied.]
SQLDateTime to SQLInt16 Conversion | [To be supplied.]
SQLInt16 to Int16 Conversion | [To be supplied.]
SQLString to SQLInt16 Conversion | [To be supplied.]
SQLMoney to SQLInt16 Conversion | [To be supplied.]
SQLInt32 to SQLInt16 Conversion | [To be supplied.]
SQLByte to SQLInt16 Conversion | Overloaded. [To be supplied.]

Fields

MaxValue | [To be supplied.]
MinValue | [To be supplied.]
Null | [To be supplied.]
Zero | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLInt16 Structure | System.Data.SQLTypes Namespace


SQLInt16 Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal value As Short _
)
[C#]
public SQLInt16(
   short value
);
[C++]
public: SQLInt16(
   short value
);
[JScript]
public function SQLInt16(
   value : Int16
);

Parameters

value
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLInt16 Properties

The properties of the SQLInt16 structure are listed below. For a complete list of SQLInt16 structure members, see the SQLInt16 Members topic.

Public:

IsNull | [To be supplied.]
Value | [To be supplied.]

See Also

SQLInt16 Structure | System.Data.SQLTypes Namespace


SQLInt16.IsNull

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsNull As Boolean
[C#]
public bool IsNull {virtual get;}
[C++]
public: __property virtual bool get_IsNull();
[JScript]
public function get IsNull() : Boolean;

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt16.Value

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Value As Short
[C#]
public short Value {get;}
[C++]
public: __property short get_Value();
[JScript]
public function get Value() : Int16;

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLInt16 Methods

The methods of the SQLInt16 structure are listed below. For a complete list of SQLInt16 structure members, see the SQLInt16 Members topic.

Public:

EQ | [To be supplied.]
Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
FromString | [To be supplied.]
GE | [To be supplied.]
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
GT | [To be supplied.]
LE | [To be supplied.]
LT | [To be supplied.]
NE | [To be supplied.]
ToString | Overloaded. [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLInt16 Structure | System.Data.SQLTypes Namespace


SQLInt16.EQ

[To be supplied.]

[Visual Basic]
Public Shared Function EQ( _
   ByVal x As SQLInt16, _
   ByVal y As SQLInt16 _
) As SQLBoolean
[C#]
public static SQLBoolean EQ(
   SQLInt16 x,
   SQLInt16 y
);
[C++]
public: static SQLBoolean EQ(
   SQLInt16 x,
   SQLInt16 y
);
[JScript]
public static function EQ(
   x : SQLInt16,
   y : SQLInt16
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt16.FromString

[To be supplied.]

[Visual Basic]
Public Shared Function FromString( _
   ByVal s As String _
) As SQLInt16
[C#]
public static SQLInt16 FromString(
   string s
);
[C++]
public: static SQLInt16 FromString(
   String* s
);
[JScript]
public static function FromString(
   s : String
) : SQLInt16;

Parameters

s
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt16.GE

[To be supplied.]

[Visual Basic]
Public Shared Function GE( _
   ByVal x As SQLInt16, _
   ByVal y As SQLInt16 _
) As SQLBoolean
[C#]
public static SQLBoolean GE(
   SQLInt16 x,
   SQLInt16 y
);
[C++]
public: static SQLBoolean GE(
   SQLInt16 x,
   SQLInt16 y
);
[JScript]
public static function GE(
   x : SQLInt16,
   y : SQLInt16
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt16.GT

[To be supplied.]

[Visual Basic]
Public Shared Function GT( _
   ByVal x As SQLInt16, _
   ByVal y As SQLInt16 _
) As SQLBoolean
[C#]
public static SQLBoolean GT(
   SQLInt16 x,
   SQLInt16 y
);
[C++]
public: static SQLBoolean GT(
   SQLInt16 x,
   SQLInt16 y
);
[JScript]
public static function GT(
   x : SQLInt16,
   y : SQLInt16
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt16.LE

[To be supplied.]

[Visual Basic]
Public Shared Function LE( _
   ByVal x As SQLInt16, _
   ByVal y As SQLInt16 _
) As SQLBoolean
[C#]
public static SQLBoolean LE(
   SQLInt16 x,
   SQLInt16 y
);
[C++]
public: static SQLBoolean LE(
   SQLInt16 x,
   SQLInt16 y
);
[JScript]
public static function LE(
   x : SQLInt16,
   y : SQLInt16
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt16.LT

[To be supplied.]

[Visual Basic]
Public Shared Function LT( _
   ByVal x As SQLInt16, _
   ByVal y As SQLInt16 _
) As SQLBoolean
[C#]
public static SQLBoolean LT(
   SQLInt16 x,
   SQLInt16 y
);
[C++]
public: static SQLBoolean LT(
   SQLInt16 x,
   SQLInt16 y
);
[JScript]
public static function LT(
   x : SQLInt16,
   y : SQLInt16
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt16.NE

[To be supplied.]

[Visual Basic]
Public Shared Function NE( _
   ByVal x As SQLInt16, _
   ByVal y As SQLInt16 _
) As SQLBoolean
[C#]
public static SQLBoolean NE(
   SQLInt16 x,
   SQLInt16 y
);
[C++]
public: static SQLBoolean NE(
   SQLInt16 x,
   SQLInt16 y
);
[JScript]
public static function NE(
   x : SQLInt16,
   y : SQLInt16
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt16.ToString

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overrides Public Function ToString() As String
[C#] public override string ToString();
[C++] public: override String* ToString();
[JScript] public override function ToString() : String;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToString(SQLInt16) As String
[C#] public static string ToString(SQLInt16);
[C++] public: static String* ToString(SQLInt16);
[JScript] public static function ToString(SQLInt16) : String;

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt16.ToString ()

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace | SQLInt16.ToString Overload List


SQLInt16.ToString (SQLInt16)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As SQLInt16 _
) As String
[C#]
public static string ToString(
   SQLInt16 value
);
[C++]
public: static String* ToString(
   SQLInt16 value
);
[JScript]
public static function ToString(
   value : SQLInt16
) : String;

Parameters

value
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace | SQLInt16.ToString Overload List


Operators and Type Conversions

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLInt16 Operators and Type Conversions

The operators and type conversions of the SQLInt16 structure are listed below. For a complete list of SQLInt16 structure members, see the SQLInt16 Members topic.

Public:

Addition Operator | [To be supplied.]
Bitwise And Operator | [To be supplied.]
Bitwise Or Operator | [To be supplied.]
Division Operator | [To be supplied.]
Equality Operator | [To be supplied.]
Exclusive Or Operator | [To be supplied.]
Greater Than Operator | [To be supplied.]
Greater Than Or Equal Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Less Than Operator | [To be supplied.]
Less Than Or Equal Operator | [To be supplied.]
Modulus Operator | [To be supplied.]
Multiplication Operator | [To be supplied.]
Ones Complement Operator | [To be supplied.]
Subtraction Operator | [To be supplied.]
Unary Negation Operator | [To be supplied.]
SQLDouble to SQLInt16 Conversion | [To be supplied.]
SQLInt64 to SQLInt16 Conversion | [To be supplied.]
SQLSingle to SQLInt16 Conversion | [To be supplied.]
SQLDateTime to SQLInt16 Conversion | [To be supplied.]
SQLInt16 to Int16 Conversion | [To be supplied.]
SQLString to SQLInt16 Conversion | [To be supplied.]
SQLMoney to SQLInt16 Conversion | [To be supplied.]
SQLInt32 to SQLInt16 Conversion | [To be supplied.]
SQLByte to SQLInt16 Conversion | Overloaded. [To be supplied.]

See Also

SQLInt16 Structure | System.Data.SQLTypes Namespace


SQLInt16 Addition Operator

[To be supplied.]

[C#]
public static SQLInt16 operator +(
   SQLInt16 x,
   SQLInt16 y
);
[C++]
public: static SQLInt16 operator op_Addition(
   SQLInt16 x,
   SQLInt16 y
);
[JScript]
returnValue = x + y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt16 Bitwise And Operator

[To be supplied.]

[C#]
public static SQLInt16 operator &(
   SQLInt16 x,
   SQLInt16 y
);
[C++]
public: static SQLInt16 operator op_BitwiseAnd(
   SQLInt16 x,
   SQLInt16 y
);
[JScript]
returnValue = x & y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt16 Bitwise Or Operator

[To be supplied.]

[C#]
public static SQLInt16 operator |(
   SQLInt16 x,
   SQLInt16 y
);
[C++]
public: static SQLInt16 operator op_BitwiseOr(
   SQLInt16 x,
   SQLInt16 y
);
[JScript]
returnValue = x | y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt16 Division Operator

[To be supplied.]

[C#]
public static SQLInt16 operator /(
   SQLInt16 x,
   SQLInt16 y
);
[C++]
public: static SQLInt16 operator op_Division(
   SQLInt16 x,
   SQLInt16 y
);
[JScript]
returnValue = x / y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt16 Equality Operator

[To be supplied.]

[C#]
public static SQLBoolean operator ==(
   SQLInt16 x,
   SQLInt16 y
);
[C++]
public: static SQLBoolean operator op_Equality(
   SQLInt16 x,
   SQLInt16 y
);
[JScript]
returnValue = x == y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt16 Exclusive Or Operator

[To be supplied.]

[C#]
public static SQLInt16 operator ^(
   SQLInt16 x,
   SQLInt16 y
);
[C++]
public: static SQLInt16 operator op_ExclusiveOr(
   SQLInt16 x,
   SQLInt16 y
);
[JScript]
returnValue = x ^ y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt16 Greater Than Operator

[To be supplied.]

[C#]
public static SQLBoolean operator >(
   SQLInt16 x,
   SQLInt16 y
);
[C++]
public: static SQLBoolean operator op_GreaterThan(
   SQLInt16 x,
   SQLInt16 y
);
[JScript]
returnValue = x > y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt16 Greater Than Or Equal Operator

[To be supplied.]

[C#]
public static SQLBoolean operator >=(
   SQLInt16 x,
   SQLInt16 y
);
[C++]
public: static SQLBoolean operator op_GreaterThanOrEqual(
   SQLInt16 x,
   SQLInt16 y
);
[JScript]
returnValue = x >= y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt16 Inequality Operator

[To be supplied.]

[C#]
public static SQLBoolean operator !=(
   SQLInt16 x,
   SQLInt16 y
);
[C++]
public: static SQLBoolean operator op_Inequality(
   SQLInt16 x,
   SQLInt16 y
);
[JScript]
returnValue = x ! = y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt16 Less Than Operator

[To be supplied.]

[C#]
public static SQLBoolean operator <(
   SQLInt16 x,
   SQLInt16 y
);
[C++]
public: static SQLBoolean operator op_LessThan(
   SQLInt16 x,
   SQLInt16 y
);
[JScript]
returnValue = x < y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt16 Less Than Or Equal Operator

[To be supplied.]

[C#]
public static SQLBoolean operator <=(
   SQLInt16 x,
   SQLInt16 y
);
[C++]
public: static SQLBoolean operator op_LessThanOrEqual(
   SQLInt16 x,
   SQLInt16 y
);
[JScript]
returnValue = x <= y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt16 Modulus Operator

[To be supplied.]

[C#]
public static SQLInt16 operator %(
   SQLInt16 x,
   SQLInt16 y
);
[C++]
public: static SQLInt16 operator op_Modulus(
   SQLInt16 x,
   SQLInt16 y
);
[JScript]
returnValue = x % y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt16 Multiplication Operator

[To be supplied.]

[C#]
public static SQLInt16 operator *(
   SQLInt16 x,
   SQLInt16 y
);
[C++]
public: static SQLInt16 operator op_Multiply(
   SQLInt16 x,
   SQLInt16 y
);
[JScript]
returnValue = x * y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt16 Ones Complement Operator

[To be supplied.]

[C#]
public static SQLInt16 operator ~(
   SQLInt16 x
);
[C++]
public: static SQLInt16 operator op_OnesComplement(
   SQLInt16 x
);
[JScript]
returnValue = ~x;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt16 Subtraction Operator

[To be supplied.]

[C#]
public static SQLInt16 operator -(
   SQLInt16 x,
   SQLInt16 y
);
[C++]
public: static SQLInt16 operator op_Subtraction(
   SQLInt16 x,
   SQLInt16 y
);
[JScript]
returnValue = x - y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt16 Unary Negation Operator

[To be supplied.]

[C#]
public static SQLInt16 operator -(
   SQLInt16 x
);
[C++]
public: static SQLInt16 operator op_UnaryNegation(
   SQLInt16 x
);
[JScript]
returnValue = -x;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLDouble to SQLInt16 Conversion

[To be supplied.]

[C#]
public static explicit operator SQLInt16(
   SQLDouble x
);
[C++]
public: static SQLInt16 op_Explicit(
   SQLDouble x
);
[JScript]
returnValue = SQLInt16(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt64 to SQLInt16 Conversion

[To be supplied.]

[C#]
public static explicit operator SQLInt16(
   SQLInt64 x
);
[C++]
public: static SQLInt16 op_Explicit(
   SQLInt64 x
);
[JScript]
returnValue = SQLInt16(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLSingle to SQLInt16 Conversion

[To be supplied.]

[C#]
public static explicit operator SQLInt16(
   SQLSingle x
);
[C++]
public: static SQLInt16 op_Explicit(
   SQLSingle x
);
[JScript]
returnValue = SQLInt16(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLDateTime to SQLInt16 Conversion

[To be supplied.]

[C#]
public static explicit operator SQLInt16(
   SQLDateTime x
);
[C++]
public: static SQLInt16 op_Explicit(
   SQLDateTime x
);
[JScript]
returnValue = SQLInt16(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt16 to Int16 Conversion

[To be supplied.]

[C#]
public static explicit operator short(
   SQLInt16 x
);
[C++]
public: operator short();
[JScript]
returnValue = Int16(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#]

x
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLString to SQLInt16 Conversion

[To be supplied.]

[C#]
public static explicit operator SQLInt16(
   SQLString x
);
[C++]
public: static SQLInt16 op_Explicit(
   SQLString* x
);
[JScript]
returnValue = SQLInt16(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLMoney to SQLInt16 Conversion

[To be supplied.]

[C#]
public static explicit operator SQLInt16(
   SQLMoney x
);
[C++]
public: static SQLInt16 op_Explicit(
   SQLMoney x
);
[JScript]
returnValue = SQLInt16(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt32 to SQLInt16 Conversion

[To be supplied.]

[C#]
public static explicit operator SQLInt16(
   SQLInt32 x
);
[C++]
public: static SQLInt16 op_Explicit(
   SQLInt32 x
);
[JScript]
returnValue = SQLInt16(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLByte to SQLInt16 Conversion

Build number 1812.

© 2000 Microsoft Corporation. All rights reserved.


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLInt16 Fields

The fields of the SQLInt16 structure are listed below. For a complete list of SQLInt16 structure members, see the SQLInt16 Members topic.

Public:

MaxValue | [To be supplied.]
MinValue | [To be supplied.]
Null | [To be supplied.]
Zero | [To be supplied.]

See Also

SQLInt16 Structure | System.Data.SQLTypes Namespace


SQLInt16.MaxValue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly MaxValue As SQLInt16
[C#]
public static readonly SQLInt16 MaxValue;
[C++]
public: static readonly SQLInt16 MaxValue;
[JScript]
public static var MaxValue : SQLInt16;

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt16.MinValue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly MinValue As SQLInt16
[C#]
public static readonly SQLInt16 MinValue;
[C++]
public: static readonly SQLInt16 MinValue;
[JScript]
public static var MinValue : SQLInt16;

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt16.Null

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Null As SQLInt16
[C#]
public static readonly SQLInt16 Null;
[C++]
public: static readonly SQLInt16 Null;
[JScript]
public static var Null : SQLInt16;

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt16.Zero

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Zero As SQLInt16
[C#]
public static readonly SQLInt16 Zero;
[C++]
public: static readonly SQLInt16 Zero;
[JScript]
public static var Zero : SQLInt16;

See Also

SQLInt16 Structure | SQLInt16 Members | System.Data.SQLTypes Namespace


SQLInt32 Structure

[To be supplied.]

Object
ValueType
SQLInt32

[Visual Basic]
Public Structure SQLInt32
   Implements INullable
[C#]
public struct SQLInt32 : INullable
[C++]
public __value struct SQLInt32 : public INullable

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQLTypes

Assembly: System.Data.dll

See Also

SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt32 Members

Public:

Constructor

SQLInt32 Constructor [To be supplied.]

Properties

IsNull | [To be supplied.]
Value | [To be supplied.]

Methods

EQ | [To be supplied.]
Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
FromString | [To be supplied.]
GE | [To be supplied.]
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
GT | [To be supplied.]
LE | [To be supplied.]
LT | [To be supplied.]
NE | [To be supplied.]
ToString | Overloaded. [To be supplied.]

Operators and Type Conversions

Addition Operator | [To be supplied.]
Bitwise And Operator | [To be supplied.]
Bitwise Or Operator | [To be supplied.]
Division Operator | [To be supplied.]
Equality Operator | [To be supplied.]
Exclusive Or Operator | [To be supplied.]
Greater Than Operator | [To be supplied.]
Greater Than Or Equal Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Less Than Operator | [To be supplied.]
Less Than Or Equal Operator | [To be supplied.]
Modulus Operator | [To be supplied.]
Multiplication Operator | [To be supplied.]
Ones Complement Operator | [To be supplied.]
Subtraction Operator | [To be supplied.]
Unary Negation Operator | [To be supplied.]
SQLDouble to SQLInt32 Conversion | [To be supplied.]
SQLInt64 to SQLInt32 Conversion | [To be supplied.]
SQLSingle to SQLInt32 Conversion | [To be supplied.]
SQLInt32 to Int32 Conversion | [To be supplied.]
SQLString to SQLInt32 Conversion | [To be supplied.]
SQLMoney to SQLInt32 Conversion | [To be supplied.]
Int32 to SQLInt32 Conversion | Overloaded. [To be supplied.]

Fields

MaxValue | [To be supplied.]
MinValue | [To be supplied.]
Null | [To be supplied.]
Zero | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLInt32 Structure | System.Data.SQLTypes Namespace


SQLInt32 Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal value As Integer _
)
[C#]
public SQLInt32(
   int value
);
[C++]
public: SQLInt32(
   int value
);
[JScript]
public function SQLInt32(
   value : int
);

Parameters

value
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLInt32 Properties

The properties of the SQLInt32 structure are listed below. For a complete list of SQLInt32 structure members, see the SQLInt32 Members topic.

Public:

IsNull | [To be supplied.]
Value | [To be supplied.]

See Also

SQLInt32 Structure | System.Data.SQLTypes Namespace


SQLInt32.IsNull

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsNull As Boolean
[C#]
public bool IsNull {virtual get;}
[C++]
public: __property virtual bool get_IsNull();
[JScript]
public function get IsNull() : Boolean;

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt32.Value

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Value As Integer
[C#]
public int Value {get;}
[C++]
public: __property int get_Value();
[JScript]
public function get Value() : int;

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLInt32 Methods

The methods of the SQLInt32 structure are listed below. For a complete list of SQLInt32 structure members, see the SQLInt32 Members topic.

Public:

EQ | [To be supplied.]
Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
FromString | [To be supplied.]
GE | [To be supplied.]
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
GT | [To be supplied.]
LE | [To be supplied.]
LT | [To be supplied.]
NE | [To be supplied.]
ToString | Overloaded. [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLInt32 Structure | System.Data.SQLTypes Namespace


SQLInt32.EQ

[To be supplied.]

[Visual Basic]
Public Shared Function EQ( _
   ByVal x As SQLInt32, _
   ByVal y As SQLInt32 _
) As SQLBoolean
[C#]
public static SQLBoolean EQ(
   SQLInt32 x,
   SQLInt32 y
);
[C++]
public: static SQLBoolean EQ(
   SQLInt32 x,
   SQLInt32 y
);
[JScript]
public static function EQ(
   x : SQLInt32,
   y : SQLInt32
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt32.FromString

[To be supplied.]

[Visual Basic]
Public Shared Function FromString( _
   ByVal s As String _
) As SQLInt32
[C#]
public static SQLInt32 FromString(
   string s
);
[C++]
public: static SQLInt32 FromString(
   String* s
);
[JScript]
public static function FromString(
   s : String
) : SQLInt32;

Parameters

s
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt32.GE

[To be supplied.]

[Visual Basic]
Public Shared Function GE( _
   ByVal x As SQLInt32, _
   ByVal y As SQLInt32 _
) As SQLBoolean
[C#]
public static SQLBoolean GE(
   SQLInt32 x,
   SQLInt32 y
);
[C++]
public: static SQLBoolean GE(
   SQLInt32 x,
   SQLInt32 y
);
[JScript]
public static function GE(
   x : SQLInt32,
   y : SQLInt32
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt32.GT

[To be supplied.]

[Visual Basic]
Public Shared Function GT( _
   ByVal x As SQLInt32, _
   ByVal y As SQLInt32 _
) As SQLBoolean
[C#]
public static SQLBoolean GT(
   SQLInt32 x,
   SQLInt32 y
);
[C++]
public: static SQLBoolean GT(
   SQLInt32 x,
   SQLInt32 y
);
[JScript]
public static function GT(
   x : SQLInt32,
   y : SQLInt32
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt32.LE

[To be supplied.]

[Visual Basic]
Public Shared Function LE( _
   ByVal x As SQLInt32, _
   ByVal y As SQLInt32 _
) As SQLBoolean
[C#]
public static SQLBoolean LE(
   SQLInt32 x,
   SQLInt32 y
);
[C++]
public: static SQLBoolean LE(
   SQLInt32 x,
   SQLInt32 y
);
[JScript]
public static function LE(
   x : SQLInt32,
   y : SQLInt32
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt32.LT

[To be supplied.]

[Visual Basic]
Public Shared Function LT( _
   ByVal x As SQLInt32, _
   ByVal y As SQLInt32 _
) As SQLBoolean
[C#]
public static SQLBoolean LT(
   SQLInt32 x,
   SQLInt32 y
);
[C++]
public: static SQLBoolean LT(
   SQLInt32 x,
   SQLInt32 y
);
[JScript]
public static function LT(
   x : SQLInt32,
   y : SQLInt32
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt32.NE

[To be supplied.]

[Visual Basic]
Public Shared Function NE( _
   ByVal x As SQLInt32, _
   ByVal y As SQLInt32 _
) As SQLBoolean
[C#]
public static SQLBoolean NE(
   SQLInt32 x,
   SQLInt32 y
);
[C++]
public: static SQLBoolean NE(
   SQLInt32 x,
   SQLInt32 y
);
[JScript]
public static function NE(
   x : SQLInt32,
   y : SQLInt32
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt32.ToString

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overrides Public Function ToString() As String
[C#] public override string ToString();
[C++] public: override String* ToString();
[JScript] public override function ToString() : String;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToString(SQLInt32) As String
[C#] public static string ToString(SQLInt32);
[C++] public: static String* ToString(SQLInt32);
[JScript] public static function ToString(SQLInt32) : String;

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt32.ToString ()

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace | SQLInt32.ToString Overload List


SQLInt32.ToString (SQLInt32)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As SQLInt32 _
) As String
[C#]
public static string ToString(
   SQLInt32 value
);
[C++]
public: static String* ToString(
   SQLInt32 value
);
[JScript]
public static function ToString(
   value : SQLInt32
) : String;

Parameters

value
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace | SQLInt32.ToString Overload List


Operators and Type Conversions

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLInt32 Operators and Type Conversions

The operators and type conversions of the SQLInt32 structure are listed below. For a complete list of SQLInt32 structure members, see the SQLInt32 Members topic.

Public:

Addition Operator | [To be supplied.]
Bitwise And Operator | [To be supplied.]
Bitwise Or Operator | [To be supplied.]
Division Operator | [To be supplied.]
Equality Operator | [To be supplied.]
Exclusive Or Operator | [To be supplied.]
Greater Than Operator | [To be supplied.]
Greater Than Or Equal Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Less Than Operator | [To be supplied.]
Less Than Or Equal Operator | [To be supplied.]
Modulus Operator | [To be supplied.]
Multiplication Operator | [To be supplied.]
Ones Complement Operator | [To be supplied.]
Subtraction Operator | [To be supplied.]
Unary Negation Operator | [To be supplied.]
SQLDouble to SQLInt32 Conversion | [To be supplied.]
SQLInt64 to SQLInt32 Conversion | [To be supplied.]
SQLSingle to SQLInt32 Conversion | [To be supplied.]
SQLInt32 to Int32 Conversion | [To be supplied.]
SQLString to SQLInt32 Conversion | [To be supplied.]
SQLMoney to SQLInt32 Conversion | [To be supplied.]
Int32 to SQLInt32 Conversion | Overloaded. [To be supplied.]

See Also

SQLInt32 Structure | System.Data.SQLTypes Namespace


SQLInt32 Addition Operator

[To be supplied.]

[C#]
public static SQLInt32 operator +(
   SQLInt32 x,
   SQLInt32 y
);
[C++]
public: static SQLInt32 operator op_Addition(
   SQLInt32 x,
   SQLInt32 y
);
[JScript]
returnValue = x + y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt32 Bitwise And Operator

[To be supplied.]

[C#]
public static SQLInt32 operator &(
   SQLInt32 x,
   SQLInt32 y
);
[C++]
public: static SQLInt32 operator op_BitwiseAnd(
   SQLInt32 x,
   SQLInt32 y
);
[JScript]
returnValue = x & y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt32 Bitwise Or Operator

[To be supplied.]

[C#]
public static SQLInt32 operator |(
   SQLInt32 x,
   SQLInt32 y
);
[C++]
public: static SQLInt32 operator op_BitwiseOr(
   SQLInt32 x,
   SQLInt32 y
);
[JScript]
returnValue = x | y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt32 Division Operator

[To be supplied.]

[C#]
public static SQLInt32 operator /(
   SQLInt32 x,
   SQLInt32 y
);
[C++]
public: static SQLInt32 operator op_Division(
   SQLInt32 x,
   SQLInt32 y
);
[JScript]
returnValue = x / y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt32 Equality Operator

[To be supplied.]

[C#]
public static SQLBoolean operator ==(
   SQLInt32 x,
   SQLInt32 y
);
[C++]
public: static SQLBoolean operator op_Equality(
   SQLInt32 x,
   SQLInt32 y
);
[JScript]
returnValue = x == y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt32 Exclusive Or Operator

[To be supplied.]

[C#]
public static SQLInt32 operator ^(
   SQLInt32 x,
   SQLInt32 y
);
[C++]
public: static SQLInt32 operator op_ExclusiveOr(
   SQLInt32 x,
   SQLInt32 y
);
[JScript]
returnValue = x ^ y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt32 Greater Than Operator

[To be supplied.]

[C#]
public static SQLBoolean operator >(
   SQLInt32 x,
   SQLInt32 y
);
[C++]
public: static SQLBoolean operator op_GreaterThan(
   SQLInt32 x,
   SQLInt32 y
);
[JScript]
returnValue = x > y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt32 Greater Than Or Equal Operator

[To be supplied.]

[C#]
public static SQLBoolean operator >=(
   SQLInt32 x,
   SQLInt32 y
);
[C++]
public: static SQLBoolean operator op_GreaterThanOrEqual(
   SQLInt32 x,
   SQLInt32 y
);
[JScript]
returnValue = x >= y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt32 Inequality Operator

[To be supplied.]

[C#]
public static SQLBoolean operator !=(
   SQLInt32 x,
   SQLInt32 y
);
[C++]
public: static SQLBoolean operator op_Inequality(
   SQLInt32 x,
   SQLInt32 y
);
[JScript]
returnValue = x ! = y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt32 Less Than Operator

[To be supplied.]

[C#]
public static SQLBoolean operator <(
   SQLInt32 x,
   SQLInt32 y
);
[C++]
public: static SQLBoolean operator op_LessThan(
   SQLInt32 x,
   SQLInt32 y
);
[JScript]
returnValue = x < y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt32 Less Than Or Equal Operator

[To be supplied.]

[C#]
public static SQLBoolean operator <=(
   SQLInt32 x,
   SQLInt32 y
);
[C++]
public: static SQLBoolean operator op_LessThanOrEqual(
   SQLInt32 x,
   SQLInt32 y
);
[JScript]
returnValue = x <= y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt32 Modulus Operator

[To be supplied.]

[C#]
public static SQLInt32 operator %(
   SQLInt32 x,
   SQLInt32 y
);
[C++]
public: static SQLInt32 operator op_Modulus(
   SQLInt32 x,
   SQLInt32 y
);
[JScript]
returnValue = x % y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt32 Multiplication Operator

[To be supplied.]

[C#]
public static SQLInt32 operator *(
   SQLInt32 x,
   SQLInt32 y
);
[C++]
public: static SQLInt32 operator op_Multiply(
   SQLInt32 x,
   SQLInt32 y
);
[JScript]
returnValue = x * y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt32 Ones Complement Operator

[To be supplied.]

[C#]
public static SQLInt32 operator ~(
   SQLInt32 x
);
[C++]
public: static SQLInt32 operator op_OnesComplement(
   SQLInt32 x
);
[JScript]
returnValue = ~x;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt32 Subtraction Operator

[To be supplied.]

[C#]
public static SQLInt32 operator -(
   SQLInt32 x,
   SQLInt32 y
);
[C++]
public: static SQLInt32 operator op_Subtraction(
   SQLInt32 x,
   SQLInt32 y
);
[JScript]
returnValue = x - y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt32 Unary Negation Operator

[To be supplied.]

[C#]
public static SQLInt32 operator -(
   SQLInt32 x
);
[C++]
public: static SQLInt32 operator op_UnaryNegation(
   SQLInt32 x
);
[JScript]
returnValue = -x;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLDouble to SQLInt32 Conversion

[To be supplied.]

[C#]
public static explicit operator SQLInt32(
   SQLDouble x
);
[C++]
public: static SQLInt32 op_Explicit(
   SQLDouble x
);
[JScript]
returnValue = SQLInt32(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt64 to SQLInt32 Conversion

[To be supplied.]

[C#]
public static explicit operator SQLInt32(
   SQLInt64 x
);
[C++]
public: static SQLInt32 op_Explicit(
   SQLInt64 x
);
[JScript]
returnValue = SQLInt32(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLSingle to SQLInt32 Conversion

[To be supplied.]

[C#]
public static explicit operator SQLInt32(
   SQLSingle x
);
[C++]
public: static SQLInt32 op_Explicit(
   SQLSingle x
);
[JScript]
returnValue = SQLInt32(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt32 to Int32 Conversion

[To be supplied.]

[C#]
public static explicit operator int(
   SQLInt32 x
);
[C++]
public: operator int();
[JScript]
returnValue = Int32(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#]

x
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLString to SQLInt32 Conversion

[To be supplied.]

[C#]
public static explicit operator SQLInt32(
   SQLString x
);
[C++]
public: static SQLInt32 op_Explicit(
   SQLString* x
);
[JScript]
returnValue = SQLInt32(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLMoney to SQLInt32 Conversion

[To be supplied.]

[C#]
public static explicit operator SQLInt32(
   SQLMoney x
);
[C++]
public: static SQLInt32 op_Explicit(
   SQLMoney x
);
[JScript]
returnValue = SQLInt32(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Int32 to SQLInt32 Conversion

Build number 1812.

© 2000 Microsoft Corporation. All rights reserved.


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLInt32 Fields

The fields of the SQLInt32 structure are listed below. For a complete list of SQLInt32 structure members, see the SQLInt32 Members topic.

Public:

MaxValue | [To be supplied.]
MinValue | [To be supplied.]
Null | [To be supplied.]
Zero | [To be supplied.]

See Also

SQLInt32 Structure | System.Data.SQLTypes Namespace


SQLInt32.MaxValue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly MaxValue As SQLInt32
[C#]
public static readonly SQLInt32 MaxValue;
[C++]
public: static readonly SQLInt32 MaxValue;
[JScript]
public static var MaxValue : SQLInt32;

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt32.MinValue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly MinValue As SQLInt32
[C#]
public static readonly SQLInt32 MinValue;
[C++]
public: static readonly SQLInt32 MinValue;
[JScript]
public static var MinValue : SQLInt32;

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt32.Null

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Null As SQLInt32
[C#]
public static readonly SQLInt32 Null;
[C++]
public: static readonly SQLInt32 Null;
[JScript]
public static var Null : SQLInt32;

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt32.Zero

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Zero As SQLInt32
[C#]
public static readonly SQLInt32 Zero;
[C++]
public: static readonly SQLInt32 Zero;
[JScript]
public static var Zero : SQLInt32;

See Also

SQLInt32 Structure | SQLInt32 Members | System.Data.SQLTypes Namespace


SQLInt64 Structure

[To be supplied.]

Object
ValueType
SQLInt64

[Visual Basic]
Public Structure SQLInt64
   Implements INullable
[C#]
public struct SQLInt64 : INullable
[C++]
public __value struct SQLInt64 : public INullable

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQLTypes

Assembly: System.Data.dll

See Also

SQLInt64 Members | System.Data.SQLTypes Namespace


SQLInt64 Members

Public:

Constructor

SQLInt64 Constructor [To be supplied.]

Properties

IsNull | [To be supplied.]
Value | [To be supplied.]

Methods

EQ | [To be supplied.]
Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
FromString | [To be supplied.]
GE | [To be supplied.]
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
GT | [To be supplied.]
LE | [To be supplied.]
LT | [To be supplied.]
NE | [To be supplied.]
ToString | Overloaded. [To be supplied.]

Operators and Type Conversions

Addition Operator | [To be supplied.]
Bitwise And Operator | [To be supplied.]
Bitwise Or Operator | [To be supplied.]
Division Operator | [To be supplied.]
Equality Operator | [To be supplied.]
Exclusive Or Operator | [To be supplied.]
Greater Than Operator | [To be supplied.]
Greater Than Or Equal Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Less Than Operator | [To be supplied.]
Less Than Or Equal Operator | [To be supplied.]
Modulus Operator | [To be supplied.]
Multiplication Operator | [To be supplied.]
Ones Complement Operator | [To be supplied.]
Subtraction Operator | [To be supplied.]
Unary Negation Operator | [To be supplied.]
SQLString to SQLInt64 Conversion | [To be supplied.]
SQLInt64 to Int64 Conversion | [To be supplied.]
SQLSingle to SQLInt64 Conversion | [To be supplied.]
SQLDouble to SQLInt64 Conversion | [To be supplied.]
SQLMoney to SQLInt64 Conversion | [To be supplied.]
Int64 to SQLInt64 Conversion | Overloaded. [To be supplied.]

Fields

MaxValue | [To be supplied.]
MinValue | [To be supplied.]
Null | [To be supplied.]
Zero | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLInt64 Structure | System.Data.SQLTypes Namespace


SQLInt64 Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal value As Long _
)
[C#]
public SQLInt64(
   long value
);
[C++]
public: SQLInt64(
   __int64 value
);
[JScript]
public function SQLInt64(
   value : long
);

Parameters

value
[To be supplied.]

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLInt64 Properties

The properties of the SQLInt64 structure are listed below. For a complete list of SQLInt64 structure members, see the SQLInt64 Members topic.

Public:

IsNull | [To be supplied.]
Value | [To be supplied.]

See Also

SQLInt64 Structure | System.Data.SQLTypes Namespace


SQLInt64.IsNull

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsNull As Boolean
[C#]
public bool IsNull {virtual get;}
[C++]
public: __property virtual bool get_IsNull();
[JScript]
public function get IsNull() : Boolean;

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLInt64.Value

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Value As Long
[C#]
public long Value {get;}
[C++]
public: __property __int64 get_Value();
[JScript]
public function get Value() : long;

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLInt64 Methods

The methods of the SQLInt64 structure are listed below. For a complete list of SQLInt64 structure members, see the SQLInt64 Members topic.

Public:

EQ | [To be supplied.]
Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
FromString | [To be supplied.]
GE | [To be supplied.]
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
GT | [To be supplied.]
LE | [To be supplied.]
LT | [To be supplied.]
NE | [To be supplied.]
ToString | Overloaded. [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLInt64 Structure | System.Data.SQLTypes Namespace


SQLInt64.EQ

[To be supplied.]

[Visual Basic]
Public Shared Function EQ( _
   ByVal x As SQLInt64, _
   ByVal y As SQLInt64 _
) As SQLBoolean
[C#]
public static SQLBoolean EQ(
   SQLInt64 x,
   SQLInt64 y
);
[C++]
public: static SQLBoolean EQ(
   SQLInt64 x,
   SQLInt64 y
);
[JScript]
public static function EQ(
   x : SQLInt64,
   y : SQLInt64
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLInt64.FromString

[To be supplied.]

[Visual Basic]
Public Shared Function FromString( _
   ByVal s As String _
) As SQLInt64
[C#]
public static SQLInt64 FromString(
   string s
);
[C++]
public: static SQLInt64 FromString(
   String* s
);
[JScript]
public static function FromString(
   s : String
) : SQLInt64;

Parameters

s
[To be supplied.]

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLInt64.GE

[To be supplied.]

[Visual Basic]
Public Shared Function GE( _
   ByVal x As SQLInt64, _
   ByVal y As SQLInt64 _
) As SQLBoolean
[C#]
public static SQLBoolean GE(
   SQLInt64 x,
   SQLInt64 y
);
[C++]
public: static SQLBoolean GE(
   SQLInt64 x,
   SQLInt64 y
);
[JScript]
public static function GE(
   x : SQLInt64,
   y : SQLInt64
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLInt64.GT

[To be supplied.]

[Visual Basic]
Public Shared Function GT( _
   ByVal x As SQLInt64, _
   ByVal y As SQLInt64 _
) As SQLBoolean
[C#]
public static SQLBoolean GT(
   SQLInt64 x,
   SQLInt64 y
);
[C++]
public: static SQLBoolean GT(
   SQLInt64 x,
   SQLInt64 y
);
[JScript]
public static function GT(
   x : SQLInt64,
   y : SQLInt64
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLInt64.LE

[To be supplied.]

[Visual Basic]
Public Shared Function LE( _
   ByVal x As SQLInt64, _
   ByVal y As SQLInt64 _
) As SQLBoolean
[C#]
public static SQLBoolean LE(
   SQLInt64 x,
   SQLInt64 y
);
[C++]
public: static SQLBoolean LE(
   SQLInt64 x,
   SQLInt64 y
);
[JScript]
public static function LE(
   x : SQLInt64,
   y : SQLInt64
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLInt64.LT

[To be supplied.]

[Visual Basic]
Public Shared Function LT( _
   ByVal x As SQLInt64, _
   ByVal y As SQLInt64 _
) As SQLBoolean
[C#]
public static SQLBoolean LT(
   SQLInt64 x,
   SQLInt64 y
);
[C++]
public: static SQLBoolean LT(
   SQLInt64 x,
   SQLInt64 y
);
[JScript]
public static function LT(
   x : SQLInt64,
   y : SQLInt64
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLInt64.NE

[To be supplied.]

[Visual Basic]
Public Shared Function NE( _
   ByVal x As SQLInt64, _
   ByVal y As SQLInt64 _
) As SQLBoolean
[C#]
public static SQLBoolean NE(
   SQLInt64 x,
   SQLInt64 y
);
[C++]
public: static SQLBoolean NE(
   SQLInt64 x,
   SQLInt64 y
);
[JScript]
public static function NE(
   x : SQLInt64,
   y : SQLInt64
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLInt64.ToString

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overrides Public Function ToString() As String
[C#] public override string ToString();
[C++] public: override String* ToString();
[JScript] public override function ToString() : String;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToString(SQLInt64) As String
[C#] public static string ToString(SQLInt64);
[C++] public: static String* ToString(SQLInt64);
[JScript] public static function ToString(SQLInt64) : String;

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLInt64.ToString ()

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace | SQLInt64.ToString Overload List


SQLInt64.ToString (SQLInt64)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As SQLInt64 _
) As String
[C#]
public static string ToString(
   SQLInt64 value
);
[C++]
public: static String* ToString(
   SQLInt64 value
);
[JScript]
public static function ToString(
   value : SQLInt64
) : String;

Parameters

value
[To be supplied.]

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace | SQLInt64.ToString Overload List


Operators and Type Conversions

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLInt64 Operators and Type Conversions

The operators and type conversions of the SQLInt64 structure are listed below. For a complete list of SQLInt64 structure members, see the SQLInt64 Members topic.

Public:

Addition Operator | [To be supplied.]
Bitwise And Operator | [To be supplied.]
Bitwise Or Operator | [To be supplied.]
Division Operator | [To be supplied.]
Equality Operator | [To be supplied.]
Exclusive Or Operator | [To be supplied.]
Greater Than Operator | [To be supplied.]
Greater Than Or Equal Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Less Than Operator | [To be supplied.]
Less Than Or Equal Operator | [To be supplied.]
Modulus Operator | [To be supplied.]
Multiplication Operator | [To be supplied.]
Ones Complement Operator | [To be supplied.]
Subtraction Operator | [To be supplied.]
Unary Negation Operator | [To be supplied.]
SQLString to SQLInt64 Conversion | [To be supplied.]
SQLInt64 to Int64 Conversion | [To be supplied.]
SQLSingle to SQLInt64 Conversion | [To be supplied.]
SQLDouble to SQLInt64 Conversion | [To be supplied.]
SQLMoney to SQLInt64 Conversion | [To be supplied.]
Int64 to SQLInt64 Conversion | Overloaded. [To be supplied.]

See Also

SQLInt64 Structure | System.Data.SQLTypes Namespace


SQLInt64 Addition Operator

[To be supplied.]

[C#]
public static SQLInt64 operator +(
   SQLInt64 x,
   SQLInt64 y
);
[C++]
public: static SQLInt64 operator op_Addition(
   SQLInt64 x,
   SQLInt64 y
);
[JScript]
returnValue = x + y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLInt64 Bitwise And Operator

[To be supplied.]

[C#]
public static SQLInt64 operator &(
   SQLInt64 x,
   SQLInt64 y
);
[C++]
public: static SQLInt64 operator op_BitwiseAnd(
   SQLInt64 x,
   SQLInt64 y
);
[JScript]
returnValue = x & y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLInt64 Bitwise Or Operator

[To be supplied.]

[C#]
public static SQLInt64 operator |(
   SQLInt64 x,
   SQLInt64 y
);
[C++]
public: static SQLInt64 operator op_BitwiseOr(
   SQLInt64 x,
   SQLInt64 y
);
[JScript]
returnValue = x | y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLInt64 Division Operator

[To be supplied.]

[C#]
public static SQLInt64 operator /(
   SQLInt64 x,
   SQLInt64 y
);
[C++]
public: static SQLInt64 operator op_Division(
   SQLInt64 x,
   SQLInt64 y
);
[JScript]
returnValue = x / y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLInt64 Equality Operator

[To be supplied.]

[C#]
public static SQLBoolean operator ==(
   SQLInt64 x,
   SQLInt64 y
);
[C++]
public: static SQLBoolean operator op_Equality(
   SQLInt64 x,
   SQLInt64 y
);
[JScript]
returnValue = x == y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLInt64 Exclusive Or Operator

[To be supplied.]

[C#]
public static SQLInt64 operator ^(
   SQLInt64 x,
   SQLInt64 y
);
[C++]
public: static SQLInt64 operator op_ExclusiveOr(
   SQLInt64 x,
   SQLInt64 y
);
[JScript]
returnValue = x ^ y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLInt64 Greater Than Operator

[To be supplied.]

[C#]
public static SQLBoolean operator >(
   SQLInt64 x,
   SQLInt64 y
);
[C++]
public: static SQLBoolean operator op_GreaterThan(
   SQLInt64 x,
   SQLInt64 y
);
[JScript]
returnValue = x > y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLInt64 Greater Than Or Equal Operator

[To be supplied.]

[C#]
public static SQLBoolean operator >=(
   SQLInt64 x,
   SQLInt64 y
);
[C++]
public: static SQLBoolean operator op_GreaterThanOrEqual(
   SQLInt64 x,
   SQLInt64 y
);
[JScript]
returnValue = x >= y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLInt64 Inequality Operator

[To be supplied.]

[C#]
public static SQLBoolean operator !=(
   SQLInt64 x,
   SQLInt64 y
);
[C++]
public: static SQLBoolean operator op_Inequality(
   SQLInt64 x,
   SQLInt64 y
);
[JScript]
returnValue = x ! = y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLInt64 Less Than Operator

[To be supplied.]

[C#]
public static SQLBoolean operator <(
   SQLInt64 x,
   SQLInt64 y
);
[C++]
public: static SQLBoolean operator op_LessThan(
   SQLInt64 x,
   SQLInt64 y
);
[JScript]
returnValue = x < y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLInt64 Less Than Or Equal Operator

[To be supplied.]

[C#]
public static SQLBoolean operator <=(
   SQLInt64 x,
   SQLInt64 y
);
[C++]
public: static SQLBoolean operator op_LessThanOrEqual(
   SQLInt64 x,
   SQLInt64 y
);
[JScript]
returnValue = x <= y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLInt64 Modulus Operator

[To be supplied.]

[C#]
public static SQLInt64 operator %(
   SQLInt64 x,
   SQLInt64 y
);
[C++]
public: static SQLInt64 operator op_Modulus(
   SQLInt64 x,
   SQLInt64 y
);
[JScript]
returnValue = x % y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLInt64 Multiplication Operator

[To be supplied.]

[C#]
public static SQLInt64 operator *(
   SQLInt64 x,
   SQLInt64 y
);
[C++]
public: static SQLInt64 operator op_Multiply(
   SQLInt64 x,
   SQLInt64 y
);
[JScript]
returnValue = x * y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLInt64 Ones Complement Operator

[To be supplied.]

[C#]
public static SQLInt64 operator ~(
   SQLInt64 x
);
[C++]
public: static SQLInt64 operator op_OnesComplement(
   SQLInt64 x
);
[JScript]
returnValue = ~x;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLInt64 Subtraction Operator

[To be supplied.]

[C#]
public static SQLInt64 operator -(
   SQLInt64 x,
   SQLInt64 y
);
[C++]
public: static SQLInt64 operator op_Subtraction(
   SQLInt64 x,
   SQLInt64 y
);
[JScript]
returnValue = x - y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLInt64 Unary Negation Operator

[To be supplied.]

[C#]
public static SQLInt64 operator -(
   SQLInt64 x
);
[C++]
public: static SQLInt64 operator op_UnaryNegation(
   SQLInt64 x
);
[JScript]
returnValue = -x;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLString to SQLInt64 Conversion

[To be supplied.]

[C#]
public static explicit operator SQLInt64(
   SQLString x
);
[C++]
public: static SQLInt64 op_Explicit(
   SQLString* x
);
[JScript]
returnValue = SQLInt64(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLInt64 to Int64 Conversion

[To be supplied.]

[C#]
public static explicit operator long(
   SQLInt64 x
);
[C++]
public: operator __int64();
[JScript]
returnValue = Int64(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#]

x
[To be supplied.]

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLSingle to SQLInt64 Conversion

[To be supplied.]

[C#]
public static explicit operator SQLInt64(
   SQLSingle x
);
[C++]
public: static SQLInt64 op_Explicit(
   SQLSingle x
);
[JScript]
returnValue = SQLInt64(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLDouble to SQLInt64 Conversion

[To be supplied.]

[C#]
public static explicit operator SQLInt64(
   SQLDouble x
);
[C++]
public: static SQLInt64 op_Explicit(
   SQLDouble x
);
[JScript]
returnValue = SQLInt64(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLMoney to SQLInt64 Conversion

[To be supplied.]

[C#]
public static explicit operator SQLInt64(
   SQLMoney x
);
[C++]
public: static SQLInt64 op_Explicit(
   SQLMoney x
);
[JScript]
returnValue = SQLInt64(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Int64 to SQLInt64 Conversion

Build number 1812.

© 2000 Microsoft Corporation. All rights reserved.


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLInt64 Fields

The fields of the SQLInt64 structure are listed below. For a complete list of SQLInt64 structure members, see the SQLInt64 Members topic.

Public:

MaxValue | [To be supplied.]
MinValue | [To be supplied.]
Null | [To be supplied.]
Zero | [To be supplied.]

See Also

SQLInt64 Structure | System.Data.SQLTypes Namespace


SQLInt64.MaxValue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly MaxValue As SQLInt64
[C#]
public static readonly SQLInt64 MaxValue;
[C++]
public: static readonly SQLInt64 MaxValue;
[JScript]
public static var MaxValue : SQLInt64;

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLInt64.MinValue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly MinValue As SQLInt64
[C#]
public static readonly SQLInt64 MinValue;
[C++]
public: static readonly SQLInt64 MinValue;
[JScript]
public static var MinValue : SQLInt64;

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLInt64.Null

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Null As SQLInt64
[C#]
public static readonly SQLInt64 Null;
[C++]
public: static readonly SQLInt64 Null;
[JScript]
public static var Null : SQLInt64;

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLInt64.Zero

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Zero As SQLInt64
[C#]
public static readonly SQLInt64 Zero;
[C++]
public: static readonly SQLInt64 Zero;
[JScript]
public static var Zero : SQLInt64;

See Also

SQLInt64 Structure | SQLInt64 Members | System.Data.SQLTypes Namespace


SQLMoney Structure

Represents an amount of currency to be stored in or retrieved from a database.

Object
ValueType
SQLMoney

[Visual Basic]
Public Structure SQLMoney
   Implements INullable
[C#]
public struct SQLMoney : INullable
[C++]
public __value struct SQLMoney : public INullable

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

The actual value of the SQLMoney object is stored in Value.

Requirements

Namespace: System.Data.SQLTypes

Assembly: System.Data.dll

See Also

SQLMoney Members | System.Data.SQLTypes Namespace


SQLMoney Members

Public:

Constructor

SQLMoney Constructor Overloaded. [To be supplied.]

Properties

IsNull | Gets a value indicating whether the Value property is assigned to null.
Value | Gets or sets the monetary value of an instance of the SQLMoney class.

Methods

EQ | [To be supplied.]
Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
FromString | [To be supplied.]
GE | [To be supplied.]
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
GT | [To be supplied.]
LE | [To be supplied.]
LT | [To be supplied.]
NE | [To be supplied.]
ToString | Overloaded. [To be supplied.]

Operators and Type Conversions

Addition Operator | [To be supplied.]
Division Operator | [To be supplied.]
Equality Operator | [To be supplied.]
Greater Than Operator | [To be supplied.]
Greater Than Or Equal Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Less Than Operator | [To be supplied.]
Less Than Or Equal Operator | [To be supplied.]
Multiplication Operator | [To be supplied.]
Subtraction Operator | [To be supplied.]
Unary Negation Operator | [To be supplied.]
SQLMoney to Currency Conversion | [To be supplied.]
SQLString to SQLMoney Conversion | [To be supplied.]
SQLSingle to SQLMoney Conversion | [To be supplied.]
SQLDouble to SQLMoney Conversion | [To be supplied.]
Currency to SQLMoney Conversion | Overloaded. [To be supplied.]

Fields

MaxValue | Represents the maximum value that can be assigned to the Value property of an instance of the SQLMoney class.
MinValue | Represents the minimum value that can be assigned to Value property of an instance of the SQLMoney class.
Null | Represents a null value that can be assigned to the Value property of an instance of the SQLMoney class.
Zero | Represents the zero value that can be assigned to the Value property of an instance of the SQLMoney class.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLMoney Structure | System.Data.SQLTypes Namespace


SQLMoney Constructor

[To be supplied.]

Overload List

Initializes a new instance of the SQLMoney class with the given Currency.

[Visual Basic] Overloads Public Sub New(Currency)
[C#] public SQLMoney(Currency);
[C++] public: SQLMoney(Currency);
[JScript] public function SQLMoney(Currency);

Initializes a new instance of the SQLMoney class with the value given.

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public SQLMoney(int);
[C++] public: SQLMoney(int);
[JScript] public function SQLMoney(int);

Initializes a new instance of the SQLMoney class with the given number of ticks.

[Visual Basic] Overloads Public Sub New(Long)
[C#] public SQLMoney(long);
[C++] public: SQLMoney(__int64);
[JScript] public function SQLMoney(long);

Initializes a new instance of the SQLMoney class with the value given.

[Visual Basic] Overloads Public Sub New(Decimal)
[C#] public SQLMoney(Decimal);
[C++] public: SQLMoney(Decimal);
[JScript] public function SQLMoney(Decimal);

Initializes a new instance of the SQLMoney class with the value given.

[Visual Basic] Overloads Public Sub New(Double)
[C#] public SQLMoney(double);
[C++] public: SQLMoney(double);
[JScript] public function SQLMoney(double);

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


SQLMoney Constructor (Currency)

Initializes a new instance of the SQLMoney class with the given Currency.

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As Currency _
)
[C#]
public SQLMoney(
   Currency value
);
[C++]
public: SQLMoney(
   Currency value
);
[JScript]
public function SQLMoney(
   value : Currency
);

Parameters

value
A Currency value.

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace | SQLMoney Constructor Overload List


SQLMoney Constructor (Int32)

Initializes a new instance of the SQLMoney class with the value given.

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As Integer _
)
[C#]
public SQLMoney(
   int value
);
[C++]
public: SQLMoney(
   int value
);
[JScript]
public function SQLMoney(
   value : int
);

Parameters

value
The monetary value to initialize.

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace | SQLMoney Constructor Overload List


SQLMoney Constructor (Int64)

Initializes a new instance of the SQLMoney class with the given number of ticks.

[Visual Basic]
Overloads Public Sub New( _
   ByVal ticks As Long _
)
[C#]
public SQLMoney(
   long ticks
);
[C++]
public: SQLMoney(
   __int64 ticks
);
[JScript]
public function SQLMoney(
   ticks : long
);

Parameters

ticks
The number of ticks.

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace | SQLMoney Constructor Overload List


SQLMoney Constructor (Decimal)

Initializes a new instance of the SQLMoney class with the value given.

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As Decimal _
)
[C#]
public SQLMoney(
   Decimal value
);
[C++]
public: SQLMoney(
   Decimal value
);
[JScript]
public function SQLMoney(
   value : Decimal
);

Parameters

value
The monetary value to initialize.

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace | SQLMoney Constructor Overload List


SQLMoney Constructor (Double)

Initializes a new instance of the SQLMoney class with the value given.

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As Double _
)
[C#]
public SQLMoney(
   double value
);
[C++]
public: SQLMoney(
   double value
);
[JScript]
public function SQLMoney(
   value : double
);

Parameters

value
The monetary value to initialize.

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace | SQLMoney Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLMoney Properties

The properties of the SQLMoney structure are listed below. For a complete list of SQLMoney structure members, see the SQLMoney Members topic.

Public:

IsNull | Gets a value indicating whether the Value property is assigned to null.
Value | Gets or sets the monetary value of an instance of the SQLMoney class.

See Also

SQLMoney Structure | System.Data.SQLTypes Namespace


SQLMoney.IsNull

Gets a value indicating whether the Value property is assigned to null.

[Visual Basic]
Overridable Public ReadOnly Property IsNull As Boolean
[C#]
public bool IsNull {virtual get;}
[C++]
public: __property virtual bool get_IsNull();
[JScript]
public function get IsNull() : Boolean;

Property Value

true if the Value is assigned to null, otherwise false.

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


SQLMoney.Value

Gets or sets the monetary value of an instance of the SQLMoney class.

[Visual Basic]
Public ReadOnly Property Value As Currency
[C#]
public Currency Value {get;}
[C++]
public: __property Currency get_Value();
[JScript]
public function get Value() : Currency;

Property Value

The monetary value of an instance of the SQLMoney class.

Exceptions

Exception Type | Condition
SQLNullValueException | The property is set to null.

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLMoney Methods

The methods of the SQLMoney structure are listed below. For a complete list of SQLMoney structure members, see the SQLMoney Members topic.

Public:

EQ | [To be supplied.]
Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
FromString | [To be supplied.]
GE | [To be supplied.]
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
GT | [To be supplied.]
LE | [To be supplied.]
LT | [To be supplied.]
NE | [To be supplied.]
ToString | Overloaded. [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLMoney Structure | System.Data.SQLTypes Namespace


SQLMoney.EQ

[To be supplied.]

[Visual Basic]
Public Shared Function EQ( _
   ByVal x As SQLMoney, _
   ByVal y As SQLMoney _
) As SQLBoolean
[C#]
public static SQLBoolean EQ(
   SQLMoney x,
   SQLMoney y
);
[C++]
public: static SQLBoolean EQ(
   SQLMoney x,
   SQLMoney y
);
[JScript]
public static function EQ(
   x : SQLMoney,
   y : SQLMoney
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


SQLMoney.Equals

[To be supplied.]

[Visual Basic]
Shadows Public Function Equals( _
   ByVal x As SQLMoney _
) As SQLBoolean
[C#]
public new SQLBoolean Equals(
   SQLMoney x
);
[C++]
public: new SQLBoolean Equals(
   SQLMoney x
);
[JScript]
public new function Equals(
   x : SQLMoney
) : SQLBoolean;

Parameters

x
[To be supplied.]

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


SQLMoney.FromString

[To be supplied.]

[Visual Basic]
Public Shared Function FromString( _
   ByVal s As String _
) As SQLMoney
[C#]
public static SQLMoney FromString(
   string s
);
[C++]
public: static SQLMoney FromString(
   String* s
);
[JScript]
public static function FromString(
   s : String
) : SQLMoney;

Parameters

s
[To be supplied.]

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


SQLMoney.GE

[To be supplied.]

[Visual Basic]
Public Shared Function GE( _
   ByVal x As SQLMoney, _
   ByVal y As SQLMoney _
) As SQLBoolean
[C#]
public static SQLBoolean GE(
   SQLMoney x,
   SQLMoney y
);
[C++]
public: static SQLBoolean GE(
   SQLMoney x,
   SQLMoney y
);
[JScript]
public static function GE(
   x : SQLMoney,
   y : SQLMoney
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


SQLMoney.GT

[To be supplied.]

[Visual Basic]
Public Shared Function GT( _
   ByVal x As SQLMoney, _
   ByVal y As SQLMoney _
) As SQLBoolean
[C#]
public static SQLBoolean GT(
   SQLMoney x,
   SQLMoney y
);
[C++]
public: static SQLBoolean GT(
   SQLMoney x,
   SQLMoney y
);
[JScript]
public static function GT(
   x : SQLMoney,
   y : SQLMoney
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


SQLMoney.LE

[To be supplied.]

[Visual Basic]
Public Shared Function LE( _
   ByVal x As SQLMoney, _
   ByVal y As SQLMoney _
) As SQLBoolean
[C#]
public static SQLBoolean LE(
   SQLMoney x,
   SQLMoney y
);
[C++]
public: static SQLBoolean LE(
   SQLMoney x,
   SQLMoney y
);
[JScript]
public static function LE(
   x : SQLMoney,
   y : SQLMoney
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


SQLMoney.LT

[To be supplied.]

[Visual Basic]
Public Shared Function LT( _
   ByVal x As SQLMoney, _
   ByVal y As SQLMoney _
) As SQLBoolean
[C#]
public static SQLBoolean LT(
   SQLMoney x,
   SQLMoney y
);
[C++]
public: static SQLBoolean LT(
   SQLMoney x,
   SQLMoney y
);
[JScript]
public static function LT(
   x : SQLMoney,
   y : SQLMoney
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


SQLMoney.NE

[To be supplied.]

[Visual Basic]
Public Shared Function NE( _
   ByVal x As SQLMoney, _
   ByVal y As SQLMoney _
) As SQLBoolean
[C#]
public static SQLBoolean NE(
   SQLMoney x,
   SQLMoney y
);
[C++]
public: static SQLBoolean NE(
   SQLMoney x,
   SQLMoney y
);
[JScript]
public static function NE(
   x : SQLMoney,
   y : SQLMoney
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


SQLMoney.ToString

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overrides Public Function ToString() As String
[C#] public override string ToString();
[C++] public: override String* ToString();
[JScript] public override function ToString() : String;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToString(SQLMoney) As String
[C#] public static string ToString(SQLMoney);
[C++] public: static String* ToString(SQLMoney);
[JScript] public static function ToString(SQLMoney) : String;

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


SQLMoney.ToString ()

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace | SQLMoney.ToString Overload List


SQLMoney.ToString (SQLMoney)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As SQLMoney _
) As String
[C#]
public static string ToString(
   SQLMoney value
);
[C++]
public: static String* ToString(
   SQLMoney value
);
[JScript]
public static function ToString(
   value : SQLMoney
) : String;

Parameters

value
[To be supplied.]

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace | SQLMoney.ToString Overload List


Operators and Type Conversions

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLMoney Operators and Type Conversions

The operators and type conversions of the SQLMoney structure are listed below. For a complete list of SQLMoney structure members, see the SQLMoney Members topic.

Public:

Addition Operator | [To be supplied.]
Division Operator | [To be supplied.]
Equality Operator | [To be supplied.]
Greater Than Operator | [To be supplied.]
Greater Than Or Equal Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Less Than Operator | [To be supplied.]
Less Than Or Equal Operator | [To be supplied.]
Multiplication Operator | [To be supplied.]
Subtraction Operator | [To be supplied.]
Unary Negation Operator | [To be supplied.]
SQLMoney to Currency Conversion | [To be supplied.]
SQLString to SQLMoney Conversion | [To be supplied.]
SQLSingle to SQLMoney Conversion | [To be supplied.]
SQLDouble to SQLMoney Conversion | [To be supplied.]
Currency to SQLMoney Conversion | Overloaded. [To be supplied.]

See Also

SQLMoney Structure | System.Data.SQLTypes Namespace


SQLMoney Addition Operator

[To be supplied.]

[C#]
public static SQLMoney operator +(
   SQLMoney x,
   SQLMoney y
);
[C++]
public: static SQLMoney operator op_Addition(
   SQLMoney x,
   SQLMoney y
);
[JScript]
returnValue = x + y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


SQLMoney Division Operator

[To be supplied.]

[C#]
public static SQLMoney operator /(
   SQLMoney x,
   SQLMoney y
);
[C++]
public: static SQLMoney operator op_Division(
   SQLMoney x,
   SQLMoney y
);
[JScript]
returnValue = x / y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


SQLMoney Equality Operator

[To be supplied.]

[C#]
public static SQLBoolean operator ==(
   SQLMoney x,
   SQLMoney y
);
[C++]
public: static SQLBoolean operator op_Equality(
   SQLMoney x,
   SQLMoney y
);
[JScript]
returnValue = x == y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


SQLMoney Greater Than Operator

[To be supplied.]

[C#]
public static SQLBoolean operator >(
   SQLMoney x,
   SQLMoney y
);
[C++]
public: static SQLBoolean operator op_GreaterThan(
   SQLMoney x,
   SQLMoney y
);
[JScript]
returnValue = x > y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


SQLMoney Greater Than Or Equal Operator

[To be supplied.]

[C#]
public static SQLBoolean operator >=(
   SQLMoney x,
   SQLMoney y
);
[C++]
public: static SQLBoolean operator op_GreaterThanOrEqual(
   SQLMoney x,
   SQLMoney y
);
[JScript]
returnValue = x >= y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


SQLMoney Inequality Operator

[To be supplied.]

[C#]
public static SQLBoolean operator !=(
   SQLMoney x,
   SQLMoney y
);
[C++]
public: static SQLBoolean operator op_Inequality(
   SQLMoney x,
   SQLMoney y
);
[JScript]
returnValue = x ! = y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


SQLMoney Less Than Operator

[To be supplied.]

[C#]
public static SQLBoolean operator <(
   SQLMoney x,
   SQLMoney y
);
[C++]
public: static SQLBoolean operator op_LessThan(
   SQLMoney x,
   SQLMoney y
);
[JScript]
returnValue = x < y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


SQLMoney Less Than Or Equal Operator

[To be supplied.]

[C#]
public static SQLBoolean operator <=(
   SQLMoney x,
   SQLMoney y
);
[C++]
public: static SQLBoolean operator op_LessThanOrEqual(
   SQLMoney x,
   SQLMoney y
);
[JScript]
returnValue = x <= y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


SQLMoney Multiplication Operator

[To be supplied.]

[C#]
public static SQLMoney operator *(
   SQLMoney x,
   SQLMoney y
);
[C++]
public: static SQLMoney operator op_Multiply(
   SQLMoney x,
   SQLMoney y
);
[JScript]
returnValue = x * y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


SQLMoney Subtraction Operator

[To be supplied.]

[C#]
public static SQLMoney operator -(
   SQLMoney x,
   SQLMoney y
);
[C++]
public: static SQLMoney operator op_Subtraction(
   SQLMoney x,
   SQLMoney y
);
[JScript]
returnValue = x - y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


SQLMoney Unary Negation Operator

[To be supplied.]

[C#]
public static SQLMoney operator -(
   SQLMoney x
);
[C++]
public: static SQLMoney operator op_UnaryNegation(
   SQLMoney x
);
[JScript]
returnValue = -x;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


SQLMoney to Currency Conversion

[To be supplied.]

[C#]
public static explicit operator Currency(
   SQLMoney x
);
[C++]
public: operator Currency();
[JScript]
returnValue = Currency(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#]

x
[To be supplied.]

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


SQLString to SQLMoney Conversion

[To be supplied.]

[C#]
public static explicit operator SQLMoney(
   SQLString x
);
[C++]
public: static SQLMoney op_Explicit(
   SQLString* x
);
[JScript]
returnValue = SQLMoney(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


SQLSingle to SQLMoney Conversion

[To be supplied.]

[C#]
public static explicit operator SQLMoney(
   SQLSingle x
);
[C++]
public: static SQLMoney op_Explicit(
   SQLSingle x
);
[JScript]
returnValue = SQLMoney(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


SQLDouble to SQLMoney Conversion

[To be supplied.]

[C#]
public static explicit operator SQLMoney(
   SQLDouble x
);
[C++]
public: static SQLMoney op_Explicit(
   SQLDouble x
);
[JScript]
returnValue = SQLMoney(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Currency to SQLMoney Conversion

Build number 1812.

© 2000 Microsoft Corporation. All rights reserved.


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLMoney Fields

The fields of the SQLMoney structure are listed below. For a complete list of SQLMoney structure members, see the SQLMoney Members topic.

Public:

MaxValue | Represents the maximum value that can be assigned to the Value property of an instance of the SQLMoney class.
MinValue | Represents the minimum value that can be assigned to Value property of an instance of the SQLMoney class.
Null | Represents a null value that can be assigned to the Value property of an instance of the SQLMoney class.
Zero | Represents the zero value that can be assigned to the Value property of an instance of the SQLMoney class.

See Also

SQLMoney Structure | System.Data.SQLTypes Namespace


SQLMoney.MaxValue

Represents the maximum value that can be assigned to the Value property of an instance of the SQLMoney class.

[Visual Basic]
Public Shared ReadOnly MaxValue As SQLMoney
[C#]
public static readonly SQLMoney MaxValue;
[C++]
public: static readonly SQLMoney MaxValue;
[JScript]
public static var MaxValue : SQLMoney;

Remarks

MaxValue functions as a constant for the SQLMoney class.

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


SQLMoney.MinValue

Represents the minimum value that can be assigned to Value property of an instance of the SQLMoney class.

[Visual Basic]
Public Shared ReadOnly MinValue As SQLMoney
[C#]
public static readonly SQLMoney MinValue;
[C++]
public: static readonly SQLMoney MinValue;
[JScript]
public static var MinValue : SQLMoney;

Remarks

MinValue functions as a constant for the SQLMoney class.

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


SQLMoney.Null

Represents a null value that can be assigned to the Value property of an instance of the SQLMoney class.

[Visual Basic]
Public Shared ReadOnly Null As SQLMoney
[C#]
public static readonly SQLMoney Null;
[C++]
public: static readonly SQLMoney Null;
[JScript]
public static var Null : SQLMoney;

Remarks

Null functions as a constant for the SQLMoney class.

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


SQLMoney.Zero

Represents the zero value that can be assigned to the Value property of an instance of the SQLMoney class.

[Visual Basic]
Public Shared ReadOnly Zero As SQLMoney
[C#]
public static readonly SQLMoney Zero;
[C++]
public: static readonly SQLMoney Zero;
[JScript]
public static var Zero : SQLMoney;

Remarks

Zero functions as a constant for the SQLMoney class.

See Also

SQLMoney Structure | SQLMoney Members | System.Data.SQLTypes Namespace


SQLNullValueException Class

[To be supplied.]

Object
Exception
SQLException
SQLNullValueException

[Visual Basic]
Public Class SQLNullValueException
   Inherits SQLException
[C#]
public class SQLNullValueException : SQLException
[C++]
public __gc class SQLNullValueException : public SQLException
[JScript]
public class SQLNullValueException extends SQLException

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQLTypes

Assembly: System.Data.dll

See Also

SQLNullValueException Members | System.Data.SQLTypes Namespace


SQLNullValueException Members

Public:

Constructor

SQLNullValueException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

SQLNullValueException Class | System.Data.SQLTypes Namespace


SQLNullValueException Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public SQLNullValueException();
[C++] public: SQLNullValueException();
[JScript] public function SQLNullValueException();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public SQLNullValueException(String);
[C++] public: SQLNullValueException(String*);
[JScript] public function SQLNullValueException(String);

See Also

SQLNullValueException Class | SQLNullValueException Members | System.Data.SQLTypes Namespace


SQLNullValueException Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public SQLNullValueException();
[C++]
public: SQLNullValueException();
[JScript]
public function SQLNullValueException();

See Also

SQLNullValueException Class | SQLNullValueException Members | System.Data.SQLTypes Namespace | SQLNullValueException Constructor Overload List


SQLNullValueException Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public SQLNullValueException(
   string message
);
[C++]
public: SQLNullValueException(
   String* message
);
[JScript]
public function SQLNullValueException(
   message : String
);

Parameters

message
[To be supplied.]

See Also

SQLNullValueException Class | SQLNullValueException Members | System.Data.SQLTypes Namespace | SQLNullValueException Constructor Overload List


SQLNumeric Structure

[To be supplied.]

Object
ValueType
SQLNumeric

[Visual Basic]
Public Structure SQLNumeric
   Implements INullable
[C#]
public struct SQLNumeric : INullable
[C++]
public __value struct SQLNumeric : public INullable

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQLTypes

Assembly: System.Data.dll

See Also

SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric Members

Public:

Constructor

SQLNumeric Constructor Overloaded. [To be supplied.]

Properties

BinData | [To be supplied.]
Data | [To be supplied.]
IsNull | [To be supplied.]
IsPositive | [To be supplied.]
Precision | [To be supplied.]
Scale | [To be supplied.]
Value | [To be supplied.]

Methods

EQ | [To be supplied.]
Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
FromString | [To be supplied.]
GE | [To be supplied.]
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
GT | [To be supplied.]
LE | [To be supplied.]
LT | [To be supplied.]
NE | [To be supplied.]
ToDouble | [To be supplied.]
ToString | Overloaded. [To be supplied.]

Operators and Type Conversions

Addition Operator | [To be supplied.]
Division Operator | [To be supplied.]
Equality Operator | [To be supplied.]
Greater Than Operator | [To be supplied.]
Greater Than Or Equal Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Less Than Operator | [To be supplied.]
Less Than Or Equal Operator | [To be supplied.]
Multiplication Operator | [To be supplied.]
Subtraction Operator | [To be supplied.]
Unary Negation Operator | [To be supplied.]
SQLNumeric to SQLByte Conversion | [To be supplied.]
SQLNumeric to SQLInt16 Conversion | [To be supplied.]
SQLNumeric to SQLInt32 Conversion | [To be supplied.]
SQLNumeric to Decimal Conversion | [To be supplied.]
SQLNumeric to SQLBit Conversion | [To be supplied.]
SQLNumeric to SQLInt64 Conversion | [To be supplied.]
SQLNumeric to SQLMoney Conversion | [To be supplied.]
SQLByte to SQLNumeric Conversion | Overloaded. [To be supplied.]

Fields

MaxPrecision | [To be supplied.]
MaxScale | [To be supplied.]
Null | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLNumeric Structure | System.Data.SQLTypes Namespace


SQLNumeric Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Decimal)
[C#] public SQLNumeric(Decimal);
[C++] public: SQLNumeric(Decimal);
[JScript] public function SQLNumeric(Decimal);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public SQLNumeric(int);
[C++] public: SQLNumeric(int);
[JScript] public function SQLNumeric(int);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Long)
[C#] public SQLNumeric(long);
[C++] public: SQLNumeric(__int64);
[JScript] public function SQLNumeric(long);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Byte, Byte, Boolean, Integer())
[C#] public SQLNumeric(byte, byte, bool, int[]);
[C++] public: SQLNumeric(unsigned char, unsigned char, bool, int[]);
[JScript] public function SQLNumeric(Byte, Byte, Boolean, int[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Byte, Byte, Boolean, Integer, Integer, Integer, Integer)
[C#] public SQLNumeric(byte, byte, bool, int, int, int, int);
[C++] public: SQLNumeric(unsigned char, unsigned char, bool, int, int, int, int);
[JScript] public function SQLNumeric(Byte, Byte, Boolean, int, int, int, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Double)
[C#] public SQLNumeric(double);
[C++] public: SQLNumeric(double);
[JScript] public function SQLNumeric(double);

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric Constructor (Decimal)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As Decimal _
)
[C#]
public SQLNumeric(
   Decimal value
);
[C++]
public: SQLNumeric(
   Decimal value
);
[JScript]
public function SQLNumeric(
   value : Decimal
);

Parameters

value
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace | SQLNumeric Constructor Overload List


SQLNumeric Constructor (Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As Integer _
)
[C#]
public SQLNumeric(
   int value
);
[C++]
public: SQLNumeric(
   int value
);
[JScript]
public function SQLNumeric(
   value : int
);

Parameters

value
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace | SQLNumeric Constructor Overload List


SQLNumeric Constructor (Int64)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As Long _
)
[C#]
public SQLNumeric(
   long value
);
[C++]
public: SQLNumeric(
   __int64 value
);
[JScript]
public function SQLNumeric(
   value : long
);

Parameters

value
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace | SQLNumeric Constructor Overload List


SQLNumeric Constructor (Byte, Byte, Boolean, Int32[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal bPrecision As Byte, _
   ByVal bScale As Byte, _
   ByVal fPositive As Boolean, _
   ByVal rgiData() As Integer _
)
[C#]
public SQLNumeric(
   byte bPrecision,
   byte bScale,
   bool fPositive,
   int[] rgiData
);
[C++]
public: SQLNumeric(
   unsigned char bPrecision,
   unsigned char bScale,
   bool fPositive,
   int* rgiData[]
);
[JScript]
public function SQLNumeric(
   bPrecision : Byte,
   bScale : Byte,
   fPositive : Boolean,
   rgiData : int[]
);

Parameters

bPrecision
[To be supplied.]
bScale
[To be supplied.]
fPositive
[To be supplied.]
rgiData
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace | SQLNumeric Constructor Overload List


SQLNumeric Constructor (Byte, Byte, Boolean, Int32, Int32, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal bPrec As Byte, _
   ByVal bScale As Byte, _
   ByVal fPositive As Boolean, _
   ByVal data1 As Integer, _
   ByVal data2 As Integer, _
   ByVal data3 As Integer, _
   ByVal data4 As Integer _
)
[C#]
public SQLNumeric(
   byte bPrec,
   byte bScale,
   bool fPositive,
   int data1,
   int data2,
   int data3,
   int data4
);
[C++]
public: SQLNumeric(
   unsigned char bPrec,
   unsigned char bScale,
   bool fPositive,
   int data1,
   int data2,
   int data3,
   int data4
);
[JScript]
public function SQLNumeric(
   bPrec : Byte,
   bScale : Byte,
   fPositive : Boolean,
   data1 : int,
   data2 : int,
   data3 : int,
   data4 : int
);

Parameters

bPrec
[To be supplied.]
bScale
[To be supplied.]
fPositive
[To be supplied.]
data1
[To be supplied.]
data2
[To be supplied.]
data3
[To be supplied.]
data4
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace | SQLNumeric Constructor Overload List


SQLNumeric Constructor (Double)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal dVal As Double _
)
[C#]
public SQLNumeric(
   double dVal
);
[C++]
public: SQLNumeric(
   double dVal
);
[JScript]
public function SQLNumeric(
   dVal : double
);

Parameters

dVal
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace | SQLNumeric Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLNumeric Properties

The properties of the SQLNumeric structure are listed below. For a complete list of SQLNumeric structure members, see the SQLNumeric Members topic.

Public:

BinData | [To be supplied.]
Data | [To be supplied.]
IsNull | [To be supplied.]
IsPositive | [To be supplied.]
Precision | [To be supplied.]
Scale | [To be supplied.]
Value | [To be supplied.]

See Also

SQLNumeric Structure | System.Data.SQLTypes Namespace


SQLNumeric.BinData

[To be supplied.]

[Visual Basic]
Public ReadOnly Property BinData As Byte ()
[C#]
public byte[] BinData {get;}
[C++]
public: __property unsigned char* get_BinData();
[JScript]
public function get BinData() : Byte[];

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric.Data

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Data As Integer ()
[C#]
public int[] Data {get;}
[C++]
public: __property int* get_Data();
[JScript]
public function get Data() : int[];

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric.IsNull

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsNull As Boolean
[C#]
public bool IsNull {virtual get;}
[C++]
public: __property virtual bool get_IsNull();
[JScript]
public function get IsNull() : Boolean;

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric.IsPositive

[To be supplied.]

[Visual Basic]
Public ReadOnly Property IsPositive As Boolean
[C#]
public bool IsPositive {get;}
[C++]
public: __property bool get_IsPositive();
[JScript]
public function get IsPositive() : Boolean;

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric.Precision

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Precision As Byte
[C#]
public byte Precision {get;}
[C++]
public: __property unsigned char get_Precision();
[JScript]
public function get Precision() : Byte;

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric.Scale

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Scale As Byte
[C#]
public byte Scale {get;}
[C++]
public: __property unsigned char get_Scale();
[JScript]
public function get Scale() : Byte;

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric.Value

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Value As Decimal
[C#]
public Decimal Value {get;}
[C++]
public: __property Decimal get_Value();
[JScript]
public function get Value() : Decimal;

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLNumeric Methods

The methods of the SQLNumeric structure are listed below. For a complete list of SQLNumeric structure members, see the SQLNumeric Members topic.

Public:

EQ | [To be supplied.]
Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
FromString | [To be supplied.]
GE | [To be supplied.]
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
GT | [To be supplied.]
LE | [To be supplied.]
LT | [To be supplied.]
NE | [To be supplied.]
ToDouble | [To be supplied.]
ToString | Overloaded. [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLNumeric Structure | System.Data.SQLTypes Namespace


SQLNumeric.EQ

[To be supplied.]

[Visual Basic]
Public Shared Function EQ( _
   ByVal x As SQLNumeric, _
   ByVal y As SQLNumeric _
) As SQLBoolean
[C#]
public static SQLBoolean EQ(
   SQLNumeric x,
   SQLNumeric y
);
[C++]
public: static SQLBoolean EQ(
   SQLNumeric x,
   SQLNumeric y
);
[JScript]
public static function EQ(
   x : SQLNumeric,
   y : SQLNumeric
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric.FromString

[To be supplied.]

[Visual Basic]
Public Shared Function FromString( _
   ByVal s As String _
) As SQLNumeric
[C#]
public static SQLNumeric FromString(
   string s
);
[C++]
public: static SQLNumeric FromString(
   String* s
);
[JScript]
public static function FromString(
   s : String
) : SQLNumeric;

Parameters

s
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric.GE

[To be supplied.]

[Visual Basic]
Public Shared Function GE( _
   ByVal x As SQLNumeric, _
   ByVal y As SQLNumeric _
) As SQLBoolean
[C#]
public static SQLBoolean GE(
   SQLNumeric x,
   SQLNumeric y
);
[C++]
public: static SQLBoolean GE(
   SQLNumeric x,
   SQLNumeric y
);
[JScript]
public static function GE(
   x : SQLNumeric,
   y : SQLNumeric
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric.GT

[To be supplied.]

[Visual Basic]
Public Shared Function GT( _
   ByVal x As SQLNumeric, _
   ByVal y As SQLNumeric _
) As SQLBoolean
[C#]
public static SQLBoolean GT(
   SQLNumeric x,
   SQLNumeric y
);
[C++]
public: static SQLBoolean GT(
   SQLNumeric x,
   SQLNumeric y
);
[JScript]
public static function GT(
   x : SQLNumeric,
   y : SQLNumeric
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric.LE

[To be supplied.]

[Visual Basic]
Public Shared Function LE( _
   ByVal x As SQLNumeric, _
   ByVal y As SQLNumeric _
) As SQLBoolean
[C#]
public static SQLBoolean LE(
   SQLNumeric x,
   SQLNumeric y
);
[C++]
public: static SQLBoolean LE(
   SQLNumeric x,
   SQLNumeric y
);
[JScript]
public static function LE(
   x : SQLNumeric,
   y : SQLNumeric
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric.LT

[To be supplied.]

[Visual Basic]
Public Shared Function LT( _
   ByVal x As SQLNumeric, _
   ByVal y As SQLNumeric _
) As SQLBoolean
[C#]
public static SQLBoolean LT(
   SQLNumeric x,
   SQLNumeric y
);
[C++]
public: static SQLBoolean LT(
   SQLNumeric x,
   SQLNumeric y
);
[JScript]
public static function LT(
   x : SQLNumeric,
   y : SQLNumeric
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric.NE

[To be supplied.]

[Visual Basic]
Public Shared Function NE( _
   ByVal x As SQLNumeric, _
   ByVal y As SQLNumeric _
) As SQLBoolean
[C#]
public static SQLBoolean NE(
   SQLNumeric x,
   SQLNumeric y
);
[C++]
public: static SQLBoolean NE(
   SQLNumeric x,
   SQLNumeric y
);
[JScript]
public static function NE(
   x : SQLNumeric,
   y : SQLNumeric
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric.ToDouble

[To be supplied.]

[Visual Basic]
Public Function ToDouble() As Double
[C#]
public double ToDouble();
[C++]
public: double ToDouble();
[JScript]
public function ToDouble() : double;

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric.ToString

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToString(SQLNumeric) As String
[C#] public static string ToString(SQLNumeric);
[C++] public: static String* ToString(SQLNumeric);
[JScript] public static function ToString(SQLNumeric) : String;

[To be supplied.]

[Visual Basic] Overloads Overrides Public Function ToString() As String
[C#] public override string ToString();
[C++] public: override String* ToString();
[JScript] public override function ToString() : String;

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric.ToString (SQLNumeric)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As SQLNumeric _
) As String
[C#]
public static string ToString(
   SQLNumeric value
);
[C++]
public: static String* ToString(
   SQLNumeric value
);
[JScript]
public static function ToString(
   value : SQLNumeric
) : String;

Parameters

value
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace | SQLNumeric.ToString Overload List


SQLNumeric.ToString ()

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace | SQLNumeric.ToString Overload List


Operators and Type Conversions

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLNumeric Operators and Type Conversions

The operators and type conversions of the SQLNumeric structure are listed below. For a complete list of SQLNumeric structure members, see the SQLNumeric Members topic.

Public:

Addition Operator | [To be supplied.]
Division Operator | [To be supplied.]
Equality Operator | [To be supplied.]
Greater Than Operator | [To be supplied.]
Greater Than Or Equal Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Less Than Operator | [To be supplied.]
Less Than Or Equal Operator | [To be supplied.]
Multiplication Operator | [To be supplied.]
Subtraction Operator | [To be supplied.]
Unary Negation Operator | [To be supplied.]
SQLNumeric to SQLByte Conversion | [To be supplied.]
SQLNumeric to SQLInt16 Conversion | [To be supplied.]
SQLNumeric to SQLInt32 Conversion | [To be supplied.]
SQLNumeric to Decimal Conversion | [To be supplied.]
SQLNumeric to SQLBit Conversion | [To be supplied.]
SQLNumeric to SQLInt64 Conversion | [To be supplied.]
SQLNumeric to SQLMoney Conversion | [To be supplied.]
SQLByte to SQLNumeric Conversion | Overloaded. [To be supplied.]

See Also

SQLNumeric Structure | System.Data.SQLTypes Namespace


SQLNumeric Addition Operator

[To be supplied.]

[C#]
public static SQLNumeric operator +(
   SQLNumeric x,
   SQLNumeric y
);
[C++]
public: static SQLNumeric operator op_Addition(
   SQLNumeric x,
   SQLNumeric y
);
[JScript]
returnValue = x + y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric Division Operator

[To be supplied.]

[C#]
public static SQLNumeric operator /(
   SQLNumeric x,
   SQLNumeric y
);
[C++]
public: static SQLNumeric operator op_Division(
   SQLNumeric x,
   SQLNumeric y
);
[JScript]
returnValue = x / y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric Equality Operator

[To be supplied.]

[C#]
public static SQLBoolean operator ==(
   SQLNumeric x,
   SQLNumeric y
);
[C++]
public: static SQLBoolean operator op_Equality(
   SQLNumeric x,
   SQLNumeric y
);
[JScript]
returnValue = x == y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric Greater Than Operator

[To be supplied.]

[C#]
public static SQLBoolean operator >(
   SQLNumeric x,
   SQLNumeric y
);
[C++]
public: static SQLBoolean operator op_GreaterThan(
   SQLNumeric x,
   SQLNumeric y
);
[JScript]
returnValue = x > y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric Greater Than Or Equal Operator

[To be supplied.]

[C#]
public static SQLBoolean operator >=(
   SQLNumeric x,
   SQLNumeric y
);
[C++]
public: static SQLBoolean operator op_GreaterThanOrEqual(
   SQLNumeric x,
   SQLNumeric y
);
[JScript]
returnValue = x >= y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric Inequality Operator

[To be supplied.]

[C#]
public static SQLBoolean operator !=(
   SQLNumeric x,
   SQLNumeric y
);
[C++]
public: static SQLBoolean operator op_Inequality(
   SQLNumeric x,
   SQLNumeric y
);
[JScript]
returnValue = x ! = y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric Less Than Operator

[To be supplied.]

[C#]
public static SQLBoolean operator <(
   SQLNumeric x,
   SQLNumeric y
);
[C++]
public: static SQLBoolean operator op_LessThan(
   SQLNumeric x,
   SQLNumeric y
);
[JScript]
returnValue = x < y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric Less Than Or Equal Operator

[To be supplied.]

[C#]
public static SQLBoolean operator <=(
   SQLNumeric x,
   SQLNumeric y
);
[C++]
public: static SQLBoolean operator op_LessThanOrEqual(
   SQLNumeric x,
   SQLNumeric y
);
[JScript]
returnValue = x <= y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric Multiplication Operator

[To be supplied.]

[C#]
public static SQLNumeric operator *(
   SQLNumeric x,
   SQLNumeric y
);
[C++]
public: static SQLNumeric operator op_Multiply(
   SQLNumeric x,
   SQLNumeric y
);
[JScript]
returnValue = x * y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric Subtraction Operator

[To be supplied.]

[C#]
public static SQLNumeric operator -(
   SQLNumeric x,
   SQLNumeric y
);
[C++]
public: static SQLNumeric operator op_Subtraction(
   SQLNumeric x,
   SQLNumeric y
);
[JScript]
returnValue = x - y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric Unary Negation Operator

[To be supplied.]

[C#]
public static SQLNumeric operator -(
   SQLNumeric x
);
[C++]
public: static SQLNumeric operator op_UnaryNegation(
   SQLNumeric x
);
[JScript]
returnValue = -x;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric to SQLByte Conversion

[To be supplied.]

[C#]
public static explicit operator SQLByte(
   SQLNumeric x
);
[C++]
public: operator SQLByte();
[JScript]
returnValue = SQLByte(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#]

x
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric to SQLInt16 Conversion

[To be supplied.]

[C#]
public static explicit operator SQLInt16(
   SQLNumeric x
);
[C++]
public: operator SQLInt16();
[JScript]
returnValue = SQLInt16(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#]

x
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric to SQLInt32 Conversion

[To be supplied.]

[C#]
public static explicit operator SQLInt32(
   SQLNumeric x
);
[C++]
public: operator SQLInt32();
[JScript]
returnValue = SQLInt32(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#]

x
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric to Decimal Conversion

[To be supplied.]

[C#]
public static explicit operator Decimal(
   SQLNumeric x
);
[C++]
public: operator Decimal();
[JScript]
returnValue = Decimal(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#]

x
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric to SQLBit Conversion

[To be supplied.]

[C#]
public static explicit operator SQLBit(
   SQLNumeric x
);
[C++]
public: operator SQLBit();
[JScript]
returnValue = SQLBit(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#]

x
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric to SQLInt64 Conversion

[To be supplied.]

[C#]
public static explicit operator SQLInt64(
   SQLNumeric x
);
[C++]
public: operator SQLInt64();
[JScript]
returnValue = SQLInt64(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#]

x
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric to SQLMoney Conversion

[To be supplied.]

[C#]
public static explicit operator SQLMoney(
   SQLNumeric x
);
[C++]
public: operator SQLMoney();
[JScript]
returnValue = SQLMoney(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#]

x
[To be supplied.]

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLByte to SQLNumeric Conversion

Build number 1812.

© 2000 Microsoft Corporation. All rights reserved.


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLNumeric Fields

The fields of the SQLNumeric structure are listed below. For a complete list of SQLNumeric structure members, see the SQLNumeric Members topic.

Public:

MaxPrecision | [To be supplied.]
MaxScale | [To be supplied.]
Null | [To be supplied.]

See Also

SQLNumeric Structure | System.Data.SQLTypes Namespace


SQLNumeric.MaxPrecision

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly MaxPrecision As Byte
[C#]
public static readonly byte MaxPrecision;
[C++]
public: static readonly unsigned char MaxPrecision;
[JScript]
public static var MaxPrecision : Byte;

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric.MaxScale

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly MaxScale As Byte
[C#]
public static readonly byte MaxScale;
[C++]
public: static readonly unsigned char MaxScale;
[JScript]
public static var MaxScale : Byte;

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLNumeric.Null

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Null As SQLNumeric
[C#]
public static readonly SQLNumeric Null;
[C++]
public: static readonly SQLNumeric Null;
[JScript]
public static var Null : SQLNumeric;

See Also

SQLNumeric Structure | SQLNumeric Members | System.Data.SQLTypes Namespace


SQLSingle Structure

[To be supplied.]

Object
ValueType
SQLSingle

[Visual Basic]
Public Structure SQLSingle
   Implements INullable
[C#]
public struct SQLSingle : INullable
[C++]
public __value struct SQLSingle : public INullable

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQLTypes

Assembly: System.Data.dll

See Also

SQLSingle Members | System.Data.SQLTypes Namespace


SQLSingle Members

Public:

Constructor

SQLSingle Constructor Overloaded. [To be supplied.]

Properties

IsNull | [To be supplied.]
Value | [To be supplied.]

Methods

EQ | [To be supplied.]
Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
FromString | [To be supplied.]
GE | [To be supplied.]
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
GT | [To be supplied.]
LE | [To be supplied.]
LT | [To be supplied.]
NE | [To be supplied.]
ToString | Overloaded. [To be supplied.]

Operators and Type Conversions

Addition Operator | [To be supplied.]
Division Operator | [To be supplied.]
Equality Operator | [To be supplied.]
Greater Than Operator | [To be supplied.]
Greater Than Or Equal Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Less Than Operator | [To be supplied.]
Less Than Or Equal Operator | [To be supplied.]
Multiplication Operator | [To be supplied.]
Subtraction Operator | [To be supplied.]
Unary Negation Operator | [To be supplied.]
SQLString to SQLSingle Conversion | [To be supplied.]
SQLSingle to SQLNumeric Conversion | [To be supplied.]
SQLDouble to SQLSingle Conversion | [To be supplied.]
SQLSingle to Single Conversion | [To be supplied.]
SQLNumeric to SQLSingle Conversion | Overloaded. [To be supplied.]

Fields

MaxValue | [To be supplied.]
MinValue | [To be supplied.]
Null | [To be supplied.]
Zero | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLSingle Structure | System.Data.SQLTypes Namespace


SQLSingle Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Single)
[C#] public SQLSingle(float);
[C++] public: SQLSingle(float);
[JScript] public function SQLSingle(float);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Double)
[C#] public SQLSingle(double);
[C++] public: SQLSingle(double);
[JScript] public function SQLSingle(double);

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace


SQLSingle Constructor (Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As Single _
)
[C#]
public SQLSingle(
   float value
);
[C++]
public: SQLSingle(
   float value
);
[JScript]
public function SQLSingle(
   value : float
);

Parameters

value
[To be supplied.]

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace | SQLSingle Constructor Overload List


SQLSingle Constructor (Double)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal value As Double _
)
[C#]
public SQLSingle(
   double value
);
[C++]
public: SQLSingle(
   double value
);
[JScript]
public function SQLSingle(
   value : double
);

Parameters

value
[To be supplied.]

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace | SQLSingle Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLSingle Properties

The properties of the SQLSingle structure are listed below. For a complete list of SQLSingle structure members, see the SQLSingle Members topic.

Public:

IsNull | [To be supplied.]
Value | [To be supplied.]

See Also

SQLSingle Structure | System.Data.SQLTypes Namespace


SQLSingle.IsNull

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsNull As Boolean
[C#]
public bool IsNull {virtual get;}
[C++]
public: __property virtual bool get_IsNull();
[JScript]
public function get IsNull() : Boolean;

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace


SQLSingle.Value

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Value As Single
[C#]
public float Value {get;}
[C++]
public: __property float get_Value();
[JScript]
public function get Value() : float;

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLSingle Methods

The methods of the SQLSingle structure are listed below. For a complete list of SQLSingle structure members, see the SQLSingle Members topic.

Public:

EQ | [To be supplied.]
Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
FromString | [To be supplied.]
GE | [To be supplied.]
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
GT | [To be supplied.]
LE | [To be supplied.]
LT | [To be supplied.]
NE | [To be supplied.]
ToString | Overloaded. [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLSingle Structure | System.Data.SQLTypes Namespace


SQLSingle.EQ

[To be supplied.]

[Visual Basic]
Public Shared Function EQ( _
   ByVal x As SQLSingle, _
   ByVal y As SQLSingle _
) As SQLBoolean
[C#]
public static SQLBoolean EQ(
   SQLSingle x,
   SQLSingle y
);
[C++]
public: static SQLBoolean EQ(
   SQLSingle x,
   SQLSingle y
);
[JScript]
public static function EQ(
   x : SQLSingle,
   y : SQLSingle
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace


SQLSingle.FromString

[To be supplied.]

[Visual Basic]
Public Shared Function FromString( _
   ByVal s As String _
) As SQLSingle
[C#]
public static SQLSingle FromString(
   string s
);
[C++]
public: static SQLSingle FromString(
   String* s
);
[JScript]
public static function FromString(
   s : String
) : SQLSingle;

Parameters

s
[To be supplied.]

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace


SQLSingle.GE

[To be supplied.]

[Visual Basic]
Public Shared Function GE( _
   ByVal x As SQLSingle, _
   ByVal y As SQLSingle _
) As SQLBoolean
[C#]
public static SQLBoolean GE(
   SQLSingle x,
   SQLSingle y
);
[C++]
public: static SQLBoolean GE(
   SQLSingle x,
   SQLSingle y
);
[JScript]
public static function GE(
   x : SQLSingle,
   y : SQLSingle
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace


SQLSingle.GT

[To be supplied.]

[Visual Basic]
Public Shared Function GT( _
   ByVal x As SQLSingle, _
   ByVal y As SQLSingle _
) As SQLBoolean
[C#]
public static SQLBoolean GT(
   SQLSingle x,
   SQLSingle y
);
[C++]
public: static SQLBoolean GT(
   SQLSingle x,
   SQLSingle y
);
[JScript]
public static function GT(
   x : SQLSingle,
   y : SQLSingle
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace


SQLSingle.LE

[To be supplied.]

[Visual Basic]
Public Shared Function LE( _
   ByVal x As SQLSingle, _
   ByVal y As SQLSingle _
) As SQLBoolean
[C#]
public static SQLBoolean LE(
   SQLSingle x,
   SQLSingle y
);
[C++]
public: static SQLBoolean LE(
   SQLSingle x,
   SQLSingle y
);
[JScript]
public static function LE(
   x : SQLSingle,
   y : SQLSingle
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace


SQLSingle.LT

[To be supplied.]

[Visual Basic]
Public Shared Function LT( _
   ByVal x As SQLSingle, _
   ByVal y As SQLSingle _
) As SQLBoolean
[C#]
public static SQLBoolean LT(
   SQLSingle x,
   SQLSingle y
);
[C++]
public: static SQLBoolean LT(
   SQLSingle x,
   SQLSingle y
);
[JScript]
public static function LT(
   x : SQLSingle,
   y : SQLSingle
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace


SQLSingle.NE

[To be supplied.]

[Visual Basic]
Public Shared Function NE( _
   ByVal x As SQLSingle, _
   ByVal y As SQLSingle _
) As SQLBoolean
[C#]
public static SQLBoolean NE(
   SQLSingle x,
   SQLSingle y
);
[C++]
public: static SQLBoolean NE(
   SQLSingle x,
   SQLSingle y
);
[JScript]
public static function NE(
   x : SQLSingle,
   y : SQLSingle
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace


SQLSingle.ToString

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Shared Function ToString(SQLSingle) As String
[C#] public static string ToString(SQLSingle);
[C++] public: static String* ToString(SQLSingle);
[JScript] public static function ToString(SQLSingle) : String;

[To be supplied.]

[Visual Basic] Overloads Overrides Public Function ToString() As String
[C#] public override string ToString();
[C++] public: override String* ToString();
[JScript] public override function ToString() : String;

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace


SQLSingle.ToString (SQLSingle)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As SQLSingle _
) As String
[C#]
public static string ToString(
   SQLSingle value
);
[C++]
public: static String* ToString(
   SQLSingle value
);
[JScript]
public static function ToString(
   value : SQLSingle
) : String;

Parameters

value
[To be supplied.]

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace | SQLSingle.ToString Overload List


SQLSingle.ToString ()

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace | SQLSingle.ToString Overload List


Operators and Type Conversions

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLSingle Operators and Type Conversions

The operators and type conversions of the SQLSingle structure are listed below. For a complete list of SQLSingle structure members, see the SQLSingle Members topic.

Public:

Addition Operator | [To be supplied.]
Division Operator | [To be supplied.]
Equality Operator | [To be supplied.]
Greater Than Operator | [To be supplied.]
Greater Than Or Equal Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Less Than Operator | [To be supplied.]
Less Than Or Equal Operator | [To be supplied.]
Multiplication Operator | [To be supplied.]
Subtraction Operator | [To be supplied.]
Unary Negation Operator | [To be supplied.]
SQLString to SQLSingle Conversion | [To be supplied.]
SQLSingle to SQLNumeric Conversion | [To be supplied.]
SQLDouble to SQLSingle Conversion | [To be supplied.]
SQLSingle to Single Conversion | [To be supplied.]
SQLNumeric to SQLSingle Conversion | Overloaded. [To be supplied.]

See Also

SQLSingle Structure | System.Data.SQLTypes Namespace


SQLSingle Addition Operator

[To be supplied.]

[C#]
public static SQLSingle operator +(
   SQLSingle x,
   SQLSingle y
);
[C++]
public: static SQLSingle operator op_Addition(
   SQLSingle x,
   SQLSingle y
);
[JScript]
returnValue = x + y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace


SQLSingle Division Operator

[To be supplied.]

[C#]
public static SQLSingle operator /(
   SQLSingle x,
   SQLSingle y
);
[C++]
public: static SQLSingle operator op_Division(
   SQLSingle x,
   SQLSingle y
);
[JScript]
returnValue = x / y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace


SQLSingle Equality Operator

[To be supplied.]

[C#]
public static SQLBoolean operator ==(
   SQLSingle x,
   SQLSingle y
);
[C++]
public: static SQLBoolean operator op_Equality(
   SQLSingle x,
   SQLSingle y
);
[JScript]
returnValue = x == y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace


SQLSingle Greater Than Operator

[To be supplied.]

[C#]
public static SQLBoolean operator >(
   SQLSingle x,
   SQLSingle y
);
[C++]
public: static SQLBoolean operator op_GreaterThan(
   SQLSingle x,
   SQLSingle y
);
[JScript]
returnValue = x > y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace


SQLSingle Greater Than Or Equal Operator

[To be supplied.]

[C#]
public static SQLBoolean operator >=(
   SQLSingle x,
   SQLSingle y
);
[C++]
public: static SQLBoolean operator op_GreaterThanOrEqual(
   SQLSingle x,
   SQLSingle y
);
[JScript]
returnValue = x >= y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace


SQLSingle Inequality Operator

[To be supplied.]

[C#]
public static SQLBoolean operator !=(
   SQLSingle x,
   SQLSingle y
);
[C++]
public: static SQLBoolean operator op_Inequality(
   SQLSingle x,
   SQLSingle y
);
[JScript]
returnValue = x ! = y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace


SQLSingle Less Than Operator

[To be supplied.]

[C#]
public static SQLBoolean operator <(
   SQLSingle x,
   SQLSingle y
);
[C++]
public: static SQLBoolean operator op_LessThan(
   SQLSingle x,
   SQLSingle y
);
[JScript]
returnValue = x < y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace


SQLSingle Less Than Or Equal Operator

[To be supplied.]

[C#]
public static SQLBoolean operator <=(
   SQLSingle x,
   SQLSingle y
);
[C++]
public: static SQLBoolean operator op_LessThanOrEqual(
   SQLSingle x,
   SQLSingle y
);
[JScript]
returnValue = x <= y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace


SQLSingle Multiplication Operator

[To be supplied.]

[C#]
public static SQLSingle operator *(
   SQLSingle x,
   SQLSingle y
);
[C++]
public: static SQLSingle operator op_Multiply(
   SQLSingle x,
   SQLSingle y
);
[JScript]
returnValue = x * y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace


SQLSingle Subtraction Operator

[To be supplied.]

[C#]
public static SQLSingle operator -(
   SQLSingle x,
   SQLSingle y
);
[C++]
public: static SQLSingle operator op_Subtraction(
   SQLSingle x,
   SQLSingle y
);
[JScript]
returnValue = x - y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace


SQLSingle Unary Negation Operator

[To be supplied.]

[C#]
public static SQLSingle operator -(
   SQLSingle x
);
[C++]
public: static SQLSingle operator op_UnaryNegation(
   SQLSingle x
);
[JScript]
returnValue = -x;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace


SQLString to SQLSingle Conversion

[To be supplied.]

[C#]
public static explicit operator SQLSingle(
   SQLString x
);
[C++]
public: static SQLSingle op_Explicit(
   SQLString* x
);
[JScript]
returnValue = SQLSingle(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace


SQLSingle to SQLNumeric Conversion

[To be supplied.]

[C#]
public static explicit operator SQLNumeric(
   SQLSingle x
);
[C++]
public: operator SQLNumeric();
[JScript]
returnValue = SQLNumeric(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#]

x
[To be supplied.]

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace


SQLDouble to SQLSingle Conversion

[To be supplied.]

[C#]
public static explicit operator SQLSingle(
   SQLDouble x
);
[C++]
public: static SQLSingle op_Explicit(
   SQLDouble x
);
[JScript]
returnValue = SQLSingle(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace


SQLSingle to Single Conversion

[To be supplied.]

[C#]
public static explicit operator float(
   SQLSingle x
);
[C++]
public: operator float();
[JScript]
returnValue = Single(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#]

x
[To be supplied.]

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace


NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLNumeric to SQLSingle Conversion

Build number 1812.

© 2000 Microsoft Corporation. All rights reserved.


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLSingle Fields

The fields of the SQLSingle structure are listed below. For a complete list of SQLSingle structure members, see the SQLSingle Members topic.

Public:

MaxValue | [To be supplied.]
MinValue | [To be supplied.]
Null | [To be supplied.]
Zero | [To be supplied.]

See Also

SQLSingle Structure | System.Data.SQLTypes Namespace


SQLSingle.MaxValue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly MaxValue As SQLSingle
[C#]
public static readonly SQLSingle MaxValue;
[C++]
public: static readonly SQLSingle MaxValue;
[JScript]
public static var MaxValue : SQLSingle;

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace


SQLSingle.MinValue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly MinValue As SQLSingle
[C#]
public static readonly SQLSingle MinValue;
[C++]
public: static readonly SQLSingle MinValue;
[JScript]
public static var MinValue : SQLSingle;

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace


SQLSingle.Null

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Null As SQLSingle
[C#]
public static readonly SQLSingle Null;
[C++]
public: static readonly SQLSingle Null;
[JScript]
public static var Null : SQLSingle;

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace


SQLSingle.Zero

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Zero As SQLSingle
[C#]
public static readonly SQLSingle Zero;
[C++]
public: static readonly SQLSingle Zero;
[JScript]
public static var Zero : SQLSingle;

See Also

SQLSingle Structure | SQLSingle Members | System.Data.SQLTypes Namespace


SQLString Class

Represents a string to be stored in or retrieved from the database.

Object
SQLString

[Visual Basic]
Public Class SQLString
   Implements INullable
[C#]
public class SQLString : INullable
[C++]
public __gc class SQLString : public INullable
[JScript]
public class SQLString implements INullable

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQLTypes

Assembly: System.Data.dll

See Also

SQLString Members | System.Data.SQLTypes Namespace


SQLString Members

Public:

Constructor

SQLString Constructor Overloaded. [To be supplied.]

Properties

IsNull | Gets whether the Value of the SQLString is Null.
Value | Gets the string that is to be stored.

Methods

Clone | [To be supplied.]
EQ | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GE | [To be supplied.]
GetBytes | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNonUnicodeBytes | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetUnicodeBytes | [To be supplied.]
GT | [To be supplied.]
LE | [To be supplied.]
LT | [To be supplied.]
NE | [To be supplied.]
ToString | Overloaded. Converts a SQLString object to a string.

Operators and Type Conversions

Addition Operator | [To be supplied.]
Equality Operator | [To be supplied.]
Greater Than Operator | [To be supplied.]
Greater Than Or Equal Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Less Than Operator | [To be supplied.]
Less Than Or Equal Operator | [To be supplied.]
SQLGuid to SQLString Conversion | [To be supplied.]
SQLDateTime to SQLString Conversion | [To be supplied.]
SQLInt32 to SQLString Conversion | [To be supplied.]
SQLInt64 to SQLString Conversion | [To be supplied.]
SQLSingle to SQLString Conversion | [To be supplied.]
SQLInt16 to SQLString Conversion | [To be supplied.]
SQLString to String Conversion | [To be supplied.]
SQLBit to SQLString Conversion | [To be supplied.]
SQLByte to SQLString Conversion | [To be supplied.]
SQLDouble to SQLString Conversion | [To be supplied.]
SQLNumeric to SQLString Conversion | [To be supplied.]
SQLMoney to SQLString Conversion | [To be supplied.]
SQLString to SQLDateTime Conversion | Overloaded. [To be supplied.]

Fields

BinarySort | [To be supplied.]
IgnoreCase | [To be supplied.]
IgnoreKanaType | [To be supplied.]
IgnoreNonSpace | [To be supplied.]
IgnoreWidth | [To be supplied.]
Null | Represents a null value that can be assigned to the Value property of an instance of the SQLString class.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLString Class | System.Data.SQLTypes Namespace


SQLString Constructor

[To be supplied.]

Overload List

Initializes a new instance of the SQLString class.

[Visual Basic] Overloads Public Sub New(Integer, Integer, Byte(), Integer, Integer)
[C#] public SQLString(int, int, byte[], int, int);
[C++] public: SQLString(int, int, unsigned char[], int, int);
[JScript] public function SQLString(int, int, Byte[], int, int);

Initializes a new instance of the SQLString class.

[Visual Basic] Overloads Public Sub New(Integer, Integer, Byte())
[C#] public SQLString(int, int, byte[]);
[C++] public: SQLString(int, int, unsigned char[]);
[JScript] public function SQLString(int, int, Byte[]);

Initializes a new instance of the SQLString class.

[Visual Basic] Overloads Public Sub New(Integer, Integer, Byte(), Boolean)
[C#] public SQLString(int, int, byte[], bool);
[C++] public: SQLString(int, int, unsigned char[], bool);
[JScript] public function SQLString(int, int, Byte[], Boolean);

Initializes a new instance of the SQLString class.

[Visual Basic] Overloads Public Sub New(Integer, Integer, Byte(), Integer, Integer, Boolean)
[C#] public SQLString(int, int, byte[], int, int, bool);
[C++] public: SQLString(int, int, unsigned char[], int, int, bool);
[JScript] public function SQLString(int, int, Byte[], int, int, Boolean);

Initializes a new instance of the SQLString class.

[Visual Basic] Overloads Public Sub New(String, Integer, Integer)
[C#] public SQLString(String, int, int);
[C++] public: SQLString(String*, int, int);
[JScript] public function SQLString(String, int, int);

Initializes a new instance of the SQLString class.

[Visual Basic] Overloads Public Sub New(String, Integer)
[C#] public SQLString(String, int);
[C++] public: SQLString(String*, int);
[JScript] public function SQLString(String, int);

Initializes a new instance of the SQLString class.

[Visual Basic] Overloads Public Sub New(String)
[C#] public SQLString(String);
[C++] public: SQLString(String*);
[JScript] public function SQLString(String);

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLString Constructor (Int32, Int32, Byte[], Int32, Int32)

Initializes a new instance of the SQLString class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal lcid As Integer, _
   ByVal flag As Integer, _
   ByVal data() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
[C#]
public SQLString(
   int lcid,
   int flag,
   byte[] data,
   int index,
   int count
);
[C++]
public: SQLString(
   int lcid,
   int flag,
   unsigned char* data[],
   int index,
   int count
);
[JScript]
public function SQLString(
   lcid : int,
   flag : int,
   data : Byte[],
   index : int,
   count : int
);

Parameters

lcid
A value that identifies the language the array is in.
flag
[To be supplied.]
data
The data array to store.
index
The starting index within the array.
count
The number of characters from index to copy.

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace | SQLString Constructor Overload List


SQLString Constructor (Int32, Int32, Byte[])

Initializes a new instance of the SQLString class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal lcid As Integer, _
   ByVal flag As Integer, _
   ByVal data() As Byte _
)
[C#]
public SQLString(
   int lcid,
   int flag,
   byte[] data
);
[C++]
public: SQLString(
   int lcid,
   int flag,
   unsigned char* data[]
);
[JScript]
public function SQLString(
   lcid : int,
   flag : int,
   data : Byte[]
);

Parameters

lcid
A value that identifies the language the array is in.
flag
[To be supplied.]
data
The data array to store.

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace | SQLString Constructor Overload List


SQLString Constructor (Int32, Int32, Byte[], Boolean)

Initializes a new instance of the SQLString class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal lcid As Integer, _
   ByVal flag As Integer, _
   ByVal data() As Byte, _
   ByVal fUnicode As Boolean _
)
[C#]
public SQLString(
   int lcid,
   int flag,
   byte[] data,
   bool fUnicode
);
[C++]
public: SQLString(
   int lcid,
   int flag,
   unsigned char* data[],
   bool fUnicode
);
[JScript]
public function SQLString(
   lcid : int,
   flag : int,
   data : Byte[],
   fUnicode : Boolean
);

Parameters

lcid
A value that identifies the language the array is in.
flag
[To be supplied.]
data
The data array to store.
fUnicode
true if Unicode encoded, otherwise false.

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace | SQLString Constructor Overload List


SQLString Constructor (Int32, Int32, Byte[], Int32, Int32, Boolean)

Initializes a new instance of the SQLString class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal lcid As Integer, _
   ByVal flag As Integer, _
   ByVal data() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer, _
   ByVal fUnicode As Boolean _
)
[C#]
public SQLString(
   int lcid,
   int flag,
   byte[] data,
   int index,
   int count,
   bool fUnicode
);
[C++]
public: SQLString(
   int lcid,
   int flag,
   unsigned char* data[],
   int index,
   int count,
   bool fUnicode
);
[JScript]
public function SQLString(
   lcid : int,
   flag : int,
   data : Byte[],
   index : int,
   count : int,
   fUnicode : Boolean
);

Parameters

lcid
A value that identifies the language the array is in.
flag
[To be supplied.]
data
The data array to store.
index
The starting index within the array.
count
The number of characters from index to copy.
fUnicode
true if Unicode encoded, otherwise false.

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace | SQLString Constructor Overload List


SQLString Constructor (String, Int32, Int32)

Initializes a new instance of the SQLString class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal data As String, _
   ByVal lcid As Integer, _
   ByVal flag As Integer _
)
[C#]
public SQLString(
   string data,
   int lcid,
   int flag
);
[C++]
public: SQLString(
   String* data,
   int lcid,
   int flag
);
[JScript]
public function SQLString(
   data : String,
   lcid : int,
   flag : int
);

Parameters

data
The string to store.
lcid
A value that identifies the language the array is in.
flag
[To be supplied.]

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace | SQLString Constructor Overload List


SQLString Constructor (String, Int32)

Initializes a new instance of the SQLString class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal data As String, _
   ByVal lcid As Integer _
)
[C#]
public SQLString(
   string data,
   int lcid
);
[C++]
public: SQLString(
   String* data,
   int lcid
);
[JScript]
public function SQLString(
   data : String,
   lcid : int
);

Parameters

data
The string to store.
lcid
A value that identifies the language the array is in.

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace | SQLString Constructor Overload List


SQLString Constructor (String)

Initializes a new instance of the SQLString class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal data As String _
)
[C#]
public SQLString(
   string data
);
[C++]
public: SQLString(
   String* data
);
[JScript]
public function SQLString(
   data : String
);

Parameters

data
The string to store.

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace | SQLString Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLString Properties

The properties of the SQLString class are listed below. For a complete list of SQLString class members, see the SQLString Members topic.

Public:

IsNull | Gets whether the Value of the SQLString is Null.
Value | Gets the string that is to be stored.

See Also

SQLString Class | System.Data.SQLTypes Namespace


SQLString.IsNull

Gets whether the Value of the SQLString is Null.

[Visual Basic]
Overridable Public ReadOnly Property IsNull As Boolean
[C#]
public bool IsNull {virtual get;}
[C++]
public: __property virtual bool get_IsNull();
[JScript]
public function get IsNull() : Boolean;

Property Value

true if Value is Null, otherwise false.

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLString.Value

Gets the string that is to be stored.

[Visual Basic]
Public ReadOnly Property Value As String
[C#]
public string Value {get;}
[C++]
public: __property String* get_Value();
[JScript]
public function get Value() : String;

Property Value

The string that is to be stored.

Exceptions

Exception Type | Condition
SQLNullValueException | The value of the string is Null.

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLString Methods

The methods of the SQLString class are listed below. For a complete list of SQLString class members, see the SQLString Members topic.

Public:

Clone | [To be supplied.]
EQ | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GE | [To be supplied.]
GetBytes | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNonUnicodeBytes | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetUnicodeBytes | [To be supplied.]
GT | [To be supplied.]
LE | [To be supplied.]
LT | [To be supplied.]
NE | [To be supplied.]
ToString | Overloaded. Converts a SQLString object to a string.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLString Class | System.Data.SQLTypes Namespace


SQLString.Clone

[To be supplied.]

[Visual Basic]
Public Function Clone() As SQLString
[C#]
public SQLString Clone();
[C++]
public: SQLString* Clone();
[JScript]
public function Clone() : SQLString;

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLString.EQ

[To be supplied.]

[Visual Basic]
Public Shared Function EQ( _
   ByVal x As SQLString, _
   ByVal y As SQLString _
) As SQLBoolean
[C#]
public static SQLBoolean EQ(
   SQLString x,
   SQLString y
);
[C++]
public: static SQLBoolean EQ(
   SQLString* x,
   SQLString* y
);
[JScript]
public static function EQ(
   x : SQLString,
   y : SQLString
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLString.GE

[To be supplied.]

[Visual Basic]
Public Shared Function GE( _
   ByVal x As SQLString, _
   ByVal y As SQLString _
) As SQLBoolean
[C#]
public static SQLBoolean GE(
   SQLString x,
   SQLString y
);
[C++]
public: static SQLBoolean GE(
   SQLString* x,
   SQLString* y
);
[JScript]
public static function GE(
   x : SQLString,
   y : SQLString
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLString.GetBytes

[To be supplied.]

[Visual Basic]
Public Function GetBytes() As Byte ()
[C#]
public byte[] GetBytes();
[C++]
public: unsigned char* GetBytes() [];
[JScript]
public function GetBytes() : Byte[];

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLString.GetNonUnicodeBytes

[To be supplied.]

[Visual Basic]
Public Function GetNonUnicodeBytes() As Byte ()
[C#]
public byte[] GetNonUnicodeBytes();
[C++]
public: unsigned char* GetNonUnicodeBytes() [];
[JScript]
public function GetNonUnicodeBytes() : Byte[];

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLString.GetUnicodeBytes

[To be supplied.]

[Visual Basic]
Public Function GetUnicodeBytes() As Byte ()
[C#]
public byte[] GetUnicodeBytes();
[C++]
public: unsigned char* GetUnicodeBytes() [];
[JScript]
public function GetUnicodeBytes() : Byte[];

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLString.GT

[To be supplied.]

[Visual Basic]
Public Shared Function GT( _
   ByVal x As SQLString, _
   ByVal y As SQLString _
) As SQLBoolean
[C#]
public static SQLBoolean GT(
   SQLString x,
   SQLString y
);
[C++]
public: static SQLBoolean GT(
   SQLString* x,
   SQLString* y
);
[JScript]
public static function GT(
   x : SQLString,
   y : SQLString
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLString.LE

[To be supplied.]

[Visual Basic]
Public Shared Function LE( _
   ByVal x As SQLString, _
   ByVal y As SQLString _
) As SQLBoolean
[C#]
public static SQLBoolean LE(
   SQLString x,
   SQLString y
);
[C++]
public: static SQLBoolean LE(
   SQLString* x,
   SQLString* y
);
[JScript]
public static function LE(
   x : SQLString,
   y : SQLString
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLString.LT

[To be supplied.]

[Visual Basic]
Public Shared Function LT( _
   ByVal x As SQLString, _
   ByVal y As SQLString _
) As SQLBoolean
[C#]
public static SQLBoolean LT(
   SQLString x,
   SQLString y
);
[C++]
public: static SQLBoolean LT(
   SQLString* x,
   SQLString* y
);
[JScript]
public static function LT(
   x : SQLString,
   y : SQLString
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLString.NE

[To be supplied.]

[Visual Basic]
Public Shared Function NE( _
   ByVal x As SQLString, _
   ByVal y As SQLString _
) As SQLBoolean
[C#]
public static SQLBoolean NE(
   SQLString x,
   SQLString y
);
[C++]
public: static SQLBoolean NE(
   SQLString* x,
   SQLString* y
);
[JScript]
public static function NE(
   x : SQLString,
   y : SQLString
) : SQLBoolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLString.ToString

Converts a SQLString object to a string.

Overload List

Converts a SQLString object to a string.

[Visual Basic] Overloads Overrides Public Function ToString() As String
[C#] public override string ToString();
[C++] public: override String* ToString();
[JScript] public override function ToString() : String;

Converts a SQLString object to a string.

[Visual Basic] Overloads Public Shared Function ToString(SQLString) As String
[C#] public static string ToString(SQLString);
[C++] public: static String* ToString(SQLString*);
[JScript] public static function ToString(SQLString) : String;

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLString.ToString ()

Converts a SQLString object to a string.

[Visual Basic]
Overloads Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace | SQLString.ToString Overload List


SQLString.ToString (SQLString)

Converts a SQLString object to a string.

[Visual Basic]
Overloads Public Shared Function ToString( _
   ByVal value As SQLString _
) As String
[C#]
public static string ToString(
   SQLString value
);
[C++]
public: static String* ToString(
   SQLString* value
);
[JScript]
public static function ToString(
   value : SQLString
) : String;

Parameters

value
An instance of SQLString to convert.

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace | SQLString.ToString Overload List


Operators and Type Conversions

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLString Operators and Type Conversions

The operators and type conversions of the SQLString class are listed below. For a complete list of SQLString class members, see the SQLString Members topic.

Public:

Addition Operator | [To be supplied.]
Equality Operator | [To be supplied.]
Greater Than Operator | [To be supplied.]
Greater Than Or Equal Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Less Than Operator | [To be supplied.]
Less Than Or Equal Operator | [To be supplied.]
SQLGuid to SQLString Conversion | [To be supplied.]
SQLDateTime to SQLString Conversion | [To be supplied.]
SQLInt32 to SQLString Conversion | [To be supplied.]
SQLInt64 to SQLString Conversion | [To be supplied.]
SQLSingle to SQLString Conversion | [To be supplied.]
SQLInt16 to SQLString Conversion | [To be supplied.]
SQLString to String Conversion | [To be supplied.]
SQLBit to SQLString Conversion | [To be supplied.]
SQLByte to SQLString Conversion | [To be supplied.]
SQLDouble to SQLString Conversion | [To be supplied.]
SQLNumeric to SQLString Conversion | [To be supplied.]
SQLMoney to SQLString Conversion | [To be supplied.]
SQLString to SQLDateTime Conversion | Overloaded. [To be supplied.]

See Also

SQLString Class | System.Data.SQLTypes Namespace


SQLString Addition Operator

[To be supplied.]

[C#]
public static SQLString operator +(
   SQLString x,
   SQLString y
);
[C++]
public: static SQLString* operator op_Addition(
   SQLString* x,
   SQLString* y
);
[JScript]
returnValue = x + y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLString Equality Operator

[To be supplied.]

[C#]
public static SQLBoolean operator ==(
   SQLString x,
   SQLString y
);
[C++]
public: static SQLBoolean operator op_Equality(
   SQLString* x,
   SQLString* y
);
[JScript]
returnValue = x == y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLString Greater Than Operator

[To be supplied.]

[C#]
public static SQLBoolean operator >(
   SQLString x,
   SQLString y
);
[C++]
public: static SQLBoolean operator op_GreaterThan(
   SQLString* x,
   SQLString* y
);
[JScript]
returnValue = x > y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLString Greater Than Or Equal Operator

[To be supplied.]

[C#]
public static SQLBoolean operator >=(
   SQLString x,
   SQLString y
);
[C++]
public: static SQLBoolean operator op_GreaterThanOrEqual(
   SQLString* x,
   SQLString* y
);
[JScript]
returnValue = x >= y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLString Inequality Operator

[To be supplied.]

[C#]
public static SQLBoolean operator !=(
   SQLString x,
   SQLString y
);
[C++]
public: static SQLBoolean operator op_Inequality(
   SQLString* x,
   SQLString* y
);
[JScript]
returnValue = x ! = y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLString Less Than Operator

[To be supplied.]

[C#]
public static SQLBoolean operator <(
   SQLString x,
   SQLString y
);
[C++]
public: static SQLBoolean operator op_LessThan(
   SQLString* x,
   SQLString* y
);
[JScript]
returnValue = x < y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLString Less Than Or Equal Operator

[To be supplied.]

[C#]
public static SQLBoolean operator <=(
   SQLString x,
   SQLString y
);
[C++]
public: static SQLBoolean operator op_LessThanOrEqual(
   SQLString* x,
   SQLString* y
);
[JScript]
returnValue = x <= y;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]
y
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]
y
[To be supplied.]

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLGuid to SQLString Conversion

[To be supplied.]

[C#]
public static explicit operator SQLString(
   SQLGuid x
);
[C++]
public: static SQLString* op_Explicit(
   SQLGuid x
);
[JScript]
returnValue = SQLString(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLDateTime to SQLString Conversion

[To be supplied.]

[C#]
public static explicit operator SQLString(
   SQLDateTime x
);
[C++]
public: static SQLString* op_Explicit(
   SQLDateTime x
);
[JScript]
returnValue = SQLString(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLInt32 to SQLString Conversion

[To be supplied.]

[C#]
public static explicit operator SQLString(
   SQLInt32 x
);
[C++]
public: static SQLString* op_Explicit(
   SQLInt32 x
);
[JScript]
returnValue = SQLString(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLInt64 to SQLString Conversion

[To be supplied.]

[C#]
public static explicit operator SQLString(
   SQLInt64 x
);
[C++]
public: static SQLString* op_Explicit(
   SQLInt64 x
);
[JScript]
returnValue = SQLString(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLSingle to SQLString Conversion

[To be supplied.]

[C#]
public static explicit operator SQLString(
   SQLSingle x
);
[C++]
public: static SQLString* op_Explicit(
   SQLSingle x
);
[JScript]
returnValue = SQLString(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLInt16 to SQLString Conversion

[To be supplied.]

[C#]
public static explicit operator SQLString(
   SQLInt16 x
);
[C++]
public: static SQLString* op_Explicit(
   SQLInt16 x
);
[JScript]
returnValue = SQLString(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLString to String Conversion

[To be supplied.]

[C#]
public static explicit operator string(
   SQLString x
);
[C++]
public: operator String*();
[JScript]
returnValue = String(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#]

x
[To be supplied.]

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLBit to SQLString Conversion

[To be supplied.]

[C#]
public static explicit operator SQLString(
   SQLBit x
);
[C++]
public: static SQLString* op_Explicit(
   SQLBit x
);
[JScript]
returnValue = SQLString(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLByte to SQLString Conversion

[To be supplied.]

[C#]
public static explicit operator SQLString(
   SQLByte x
);
[C++]
public: static SQLString* op_Explicit(
   SQLByte x
);
[JScript]
returnValue = SQLString(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLDouble to SQLString Conversion

[To be supplied.]

[C#]
public static explicit operator SQLString(
   SQLDouble x
);
[C++]
public: static SQLString* op_Explicit(
   SQLDouble x
);
[JScript]
returnValue = SQLString(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLNumeric to SQLString Conversion

[To be supplied.]

[C#]
public static explicit operator SQLString(
   SQLNumeric x
);
[C++]
public: static SQLString* op_Explicit(
   SQLNumeric x
);
[JScript]
returnValue = SQLString(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLMoney to SQLString Conversion

[To be supplied.]

[C#]
public static explicit operator SQLString(
   SQLMoney x
);
[C++]
public: static SQLString* op_Explicit(
   SQLMoney x
);
[JScript]
returnValue = SQLString(x);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

x
[To be supplied.]

Parameters [C#, C++]

x
[To be supplied.]

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLString to SQLDateTime Conversion

Build number 1812.

© 2000 Microsoft Corporation. All rights reserved.


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SQLString Fields

The fields of the SQLString class are listed below. For a complete list of SQLString class members, see the SQLString Members topic.

Public:

BinarySort | [To be supplied.]
IgnoreCase | [To be supplied.]
IgnoreKanaType | [To be supplied.]
IgnoreNonSpace | [To be supplied.]
IgnoreWidth | [To be supplied.]
Null | Represents a null value that can be assigned to the Value property of an instance of the SQLString class.

See Also

SQLString Class | System.Data.SQLTypes Namespace


SQLString.BinarySort

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly BinarySort As Integer
[C#]
public static readonly int BinarySort;
[C++]
public: static readonly int BinarySort;
[JScript]
public static var BinarySort : int;

Remarks

BinarySort functions as a constant for the SQLString class.

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLString.IgnoreCase

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly IgnoreCase As Integer
[C#]
public static readonly int IgnoreCase;
[C++]
public: static readonly int IgnoreCase;
[JScript]
public static var IgnoreCase : int;

Remarks

IgnoreCase functions as a constant for the SQLString class.

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLString.IgnoreKanaType

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly IgnoreKanaType As Integer
[C#]
public static readonly int IgnoreKanaType;
[C++]
public: static readonly int IgnoreKanaType;
[JScript]
public static var IgnoreKanaType : int;

Remarks

IgnoreKanaType functions as a constant for the SQLString class.

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLString.IgnoreNonSpace

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly IgnoreNonSpace As Integer
[C#]
public static readonly int IgnoreNonSpace;
[C++]
public: static readonly int IgnoreNonSpace;
[JScript]
public static var IgnoreNonSpace : int;

Remarks

IgnoreNonSpace functions as a constant for the SQLString class.

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLString.IgnoreWidth

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly IgnoreWidth As Integer
[C#]
public static readonly int IgnoreWidth;
[C++]
public: static readonly int IgnoreWidth;
[JScript]
public static var IgnoreWidth : int;

Remarks

IgnoreWidth functions as a constant for the SQLString class.

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLString.Null

Represents a null value that can be assigned to the Value property of an instance of the SQLString class.

[Visual Basic]
Public Shared ReadOnly Null As SQLString
[C#]
public static readonly SQLString Null;
[C++]
public: static readonly SQLString* Null;
[JScript]
public static var Null : SQLString;

Remarks

Null functions as a constant for the SQLString class.

See Also

SQLString Class | SQLString Members | System.Data.SQLTypes Namespace


SQLTruncateException Class

[To be supplied.]

Object
Exception
SQLException
SQLTruncateException

[Visual Basic]
Public Class SQLTruncateException
   Inherits SQLException
[C#]
public class SQLTruncateException : SQLException
[C++]
public __gc class SQLTruncateException : public SQLException
[JScript]
public class SQLTruncateException extends SQLException

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.SQLTypes

Assembly: System.Data.dll

See Also

SQLTruncateException Members | System.Data.SQLTypes Namespace


SQLTruncateException Members

Public:

Constructor

SQLTruncateException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

SQLTruncateException Class | System.Data.SQLTypes Namespace


SQLTruncateException Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public SQLTruncateException();
[C++] public: SQLTruncateException();
[JScript] public function SQLTruncateException();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public SQLTruncateException(String);
[C++] public: SQLTruncateException(String*);
[JScript] public function SQLTruncateException(String);

See Also

SQLTruncateException Class | SQLTruncateException Members | System.Data.SQLTypes Namespace


SQLTruncateException Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public SQLTruncateException();
[C++]
public: SQLTruncateException();
[JScript]
public function SQLTruncateException();

See Also

SQLTruncateException Class | SQLTruncateException Members | System.Data.SQLTypes Namespace | SQLTruncateException Constructor Overload List


SQLTruncateException Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public SQLTruncateException(
   string message
);
[C++]
public: SQLTruncateException(
   String* message
);
[JScript]
public function SQLTruncateException(
   message : String
);

Parameters

message
[To be supplied.]

See Also

SQLTruncateException Class | SQLTruncateException Members | System.Data.SQLTypes Namespace | SQLTruncateException Constructor Overload List


System.Data.XML

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Data.XML Namespace

Classes

Class | Description
AstNode | [To be supplied.]
Axis | [To be supplied.]
CoreXmlReader | [To be supplied.]
DocumentEditor | [To be supplied.]
DocumentNavigator | [To be supplied.]
DocumentReader | [To be supplied.]
Filter | [To be supplied.]
Function | [To be supplied.]
Group | [To be supplied.]
MTNameTable | [To be supplied.]
NamespaceManager | [To be supplied.]
NameTable | INameTable implemented as a simple hash table.
Operand | [To be supplied.]
Operator | [To be supplied.]
Trace | [To be supplied.]
XmlDocument | [To be supplied.]
XmlException | [To be supplied.]
XmlReader | [To be supplied.]
XmlScanner | [To be supplied.]
XmlSchemaCollection | The XmlSchemaCollection contains a set of namespace URI's. Each namespace also have an associated private data cache corresponding to the XML-Data Schema or W3C XML Schema. The XmlSchemaCollection will able to load XSD and XDR schemas, and compile them into an internal "cooked schema representation". The Validate() method then uses this internal representation for efficient runtime validation of any given subtree.
XmlWriter | [To be supplied.]
XPathException | [To be supplied.]
XPathHandler | [To be supplied.]
XPathScanner | [To be supplied.]

Delegates

Delegate | Description
ValidationDelegate | [To be supplied.]

Enumerations

Enumeration | Description
AstNode.QueryType | [To be supplied.]
AstNode.RType | [To be supplied.]
Axis.AxisType | [To be supplied.]
DataSetMapping | [To be supplied.]
Function.FunctionType | [To be supplied.]
Operator.Op | [To be supplied.]
XmlFidelity | [To be supplied.]
XmlNodeType | [To be supplied.]


AstNode Class

[To be supplied.]

Object
AstNode

[Visual Basic]
Public Class AstNode
[C#]
public class AstNode
[C++]
public __gc class AstNode
[JScript]
public class AstNode

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

AstNode Members | System.Data.XML Namespace


AstNode Members

Public:

Constructor

AstNode Constructor [To be supplied.]

Properties

DefaultPriority | [To be supplied.]
ReturnType | [To be supplied.]
TypeOfAst | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
NewAstNode | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AstNode Class | System.Data.XML Namespace


AstNode Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public AstNode();
[C++]
public: AstNode();
[JScript]
public function AstNode();

See Also

AstNode Class | AstNode Members | System.Data.XML Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AstNode Properties

The properties of the AstNode class are listed below. For a complete list of AstNode class members, see the AstNode Members topic.

Public:

DefaultPriority | [To be supplied.]
ReturnType | [To be supplied.]
TypeOfAst | [To be supplied.]

See Also

AstNode Class | System.Data.XML Namespace


AstNode.DefaultPriority

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DefaultPriority As Double
[C#]
public double DefaultPriority {virtual get;}
[C++]
public: __property virtual double get_DefaultPriority();
[JScript]
public function get DefaultPriority() : double;

See Also

AstNode Class | AstNode Members | System.Data.XML Namespace


AstNode.ReturnType

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property ReturnType As AstNode.RType
[C#]
public AstNode.RType ReturnType {virtual get;}
[C++]
public: __property virtual AstNode.RType get_ReturnType();
[JScript]
public function get ReturnType() : AstNode.RType;

See Also

AstNode Class | AstNode Members | System.Data.XML Namespace


AstNode.TypeOfAst

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property TypeOfAst As AstNode.QueryType
[C#]
public AstNode.QueryType TypeOfAst {virtual get;}
[C++]
public: __property virtual AstNode.QueryType get_TypeOfAst();
[JScript]
public function get TypeOfAst() : AstNode.QueryType;

See Also

AstNode Class | AstNode Members | System.Data.XML Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AstNode Methods

The methods of the AstNode class are listed below. For a complete list of AstNode class members, see the AstNode Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
NewAstNode | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AstNode Class | System.Data.XML Namespace


AstNode.NewAstNode

[To be supplied.]

[Visual Basic]
Public Shared Function NewAstNode( _
   ByVal parsestring As String _
) As AstNode
[C#]
public static AstNode NewAstNode(
   string parsestring
);
[C++]
public: static AstNode* NewAstNode(
   String* parsestring
);
[JScript]
public static function NewAstNode(
   parsestring : String
) : AstNode;

Parameters

parsestring
[To be supplied.]

See Also

AstNode Class | AstNode Members | System.Data.XML Namespace


AstNode.QueryType Enumeration

[To be supplied.]

[Visual Basic]
Public Enum AstNode.QueryType
[C#]
public enum AstNode.QueryType
[C++]
public enum AstNode.QueryType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Axis | [To be supplied.]
ConstantOperand | [To be supplied.]
Error | [To be supplied.]
Filter | [To be supplied.]
Function | [To be supplied.]
Group | [To be supplied.]
Operator | [To be supplied.]
Root | [To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

System.Data.XML Namespace


AstNode.RType Enumeration

[To be supplied.]

[Visual Basic]
Public Enum AstNode.RType
[C#]
public enum AstNode.RType
[C++]
public enum AstNode.RType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Any | [To be supplied.]
Boolean | [To be supplied.]
Error | [To be supplied.]
NodeSet | [To be supplied.]
Number | [To be supplied.]
String | [To be supplied.]
Variable | [To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

System.Data.XML Namespace


Axis Class

[To be supplied.]

Object
AstNode
Axis

[Visual Basic]
Public Class Axis
   Inherits AstNode
[C#]
public class Axis : AstNode
[C++]
public __gc class Axis : public AstNode
[JScript]
public class Axis extends AstNode

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

Axis Members | System.Data.XML Namespace


Axis Members

Public:

Constructor

Axis Constructor Overloaded. [To be supplied.]

Properties

AxisName | [To be supplied.]
DefaultPriority | [To be supplied.]
Input | [To be supplied.]
Name | [To be supplied.]
Prefix | [To be supplied.]
ReturnType | [To be supplied.]
Type | [To be supplied.]
TypeOfAst | [To be supplied.]
TypeOfAxis | [To be supplied.]
URN | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Axis Class | System.Data.XML Namespace


Axis Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(AxisType, AstNode, String, String, String, XmlNodeType)
[C#] public Axis(AxisType, AstNode, String, String, String, XmlNodeType);
[C++] public: Axis(AxisType, AstNode, String, String, String, XmlNodeType);
[JScript] public function Axis(AxisType, AstNode, String, String, String, XmlNodeType);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(AxisType, AstNode)
[C#] public Axis(AxisType, AstNode);
[C++] public: Axis(AxisType, AstNode);
[JScript] public function Axis(AxisType, AstNode);

See Also

Axis Class | Axis Members | System.Data.XML Namespace


Axis Constructor (AxisType, AstNode, String, String, String, XmlNodeType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal axistype As Axis.AxisType, _
   ByVal input As AstNode, _
   ByVal urn As String, _
   ByVal prefix As String, _
   ByVal name As String, _
   ByVal nodetype As XmlNodeType _
)
[C#]
public Axis(
   Axis.AxisType axistype,
   AstNode input,
   string urn,
   string prefix,
   string name,
   XmlNodeType nodetype
);
[C++]
public: Axis(
   Axis.AxisType axistype,
   AstNode* input,
   String* urn,
   String* prefix,
   String* name,
   XmlNodeType nodetype
);
[JScript]
public function Axis(
   axistype : Axis.AxisType,
   input : AstNode,
   urn : String,
   prefix : String,
   name : String,
   nodetype : XmlNodeType
);

Parameters

axistype
[To be supplied.]
input
[To be supplied.]
urn
[To be supplied.]
prefix
[To be supplied.]
name
[To be supplied.]
nodetype
[To be supplied.]

See Also

Axis Class | Axis Members | System.Data.XML Namespace | Axis Constructor Overload List


Axis Constructor (AxisType, AstNode)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal axistype As Axis.AxisType, _
   ByVal input As AstNode _
)
[C#]
public Axis(
   Axis.AxisType axistype,
   AstNode input
);
[C++]
public: Axis(
   Axis.AxisType axistype,
   AstNode* input
);
[JScript]
public function Axis(
   axistype : Axis.AxisType,
   input : AstNode
);

Parameters

axistype
[To be supplied.]
input
[To be supplied.]

See Also

Axis Class | Axis Members | System.Data.XML Namespace | Axis Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Axis Properties

The properties of the Axis class are listed below. For a complete list of Axis class members, see the Axis Members topic.

Public:

AxisName | [To be supplied.]
DefaultPriority | [To be supplied.]
Input | [To be supplied.]
Name | [To be supplied.]
Prefix | [To be supplied.]
ReturnType | [To be supplied.]
Type | [To be supplied.]
TypeOfAst | [To be supplied.]
TypeOfAxis | [To be supplied.]
URN | [To be supplied.]

See Also

Axis Class | System.Data.XML Namespace


Axis.AxisName

[To be supplied.]

[Visual Basic]
Public ReadOnly Property AxisName As String
[C#]
public string AxisName {get;}
[C++]
public: __property String* get_AxisName();
[JScript]
public function get AxisName() : String;

See Also

Axis Class | Axis Members | System.Data.XML Namespace


Axis.DefaultPriority

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DefaultPriority As Double
[C#]
public double DefaultPriority {override get;}
[C++]
public: __property virtual double get_DefaultPriority();
[JScript]
public function get DefaultPriority() : double;

See Also

Axis Class | Axis Members | System.Data.XML Namespace


Axis.Input

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Input As AstNode
[C#]
public AstNode Input {get;}
[C++]
public: __property AstNode* get_Input();
[JScript]
public function get Input() : AstNode;

See Also

Axis Class | Axis Members | System.Data.XML Namespace


Axis.Name

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}
[C++]
public: __property String* get_Name();
[JScript]
public function get Name() : String;

See Also

Axis Class | Axis Members | System.Data.XML Namespace


Axis.Prefix

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Prefix As String
[C#]
public string Prefix {get;}
[C++]
public: __property String* get_Prefix();
[JScript]
public function get Prefix() : String;

See Also

Axis Class | Axis Members | System.Data.XML Namespace


Axis.ReturnType

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property ReturnType As AstNode.RType
[C#]
public AstNode.RType ReturnType {override get;}
[C++]
public: __property virtual AstNode.RType get_ReturnType();
[JScript]
public function get ReturnType() : AstNode.RType;

See Also

Axis Class | Axis Members | System.Data.XML Namespace


Axis.Type

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Type As XmlNodeType
[C#]
public XmlNodeType Type {get;}
[C++]
public: __property XmlNodeType get_Type();
[JScript]
public function get Type() : XmlNodeType;

See Also

Axis Class | Axis Members | System.Data.XML Namespace


Axis.TypeOfAst

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property TypeOfAst As AstNode.QueryType
[C#]
public AstNode.QueryType TypeOfAst {override get;}
[C++]
public: __property virtual AstNode.QueryType get_TypeOfAst();
[JScript]
public function get TypeOfAst() : AstNode.QueryType;

See Also

Axis Class | Axis Members | System.Data.XML Namespace


Axis.TypeOfAxis

[To be supplied.]

[Visual Basic]
Public ReadOnly Property TypeOfAxis As Axis.AxisType
[C#]
public Axis.AxisType TypeOfAxis {get;}
[C++]
public: __property Axis.AxisType get_TypeOfAxis();
[JScript]
public function get TypeOfAxis() : Axis.AxisType;

See Also

Axis Class | Axis Members | System.Data.XML Namespace


Axis.URN

[To be supplied.]

[Visual Basic]
Public ReadOnly Property URN As String
[C#]
public string URN {get;}
[C++]
public: __property String* get_URN();
[JScript]
public function get URN() : String;

See Also

Axis Class | Axis Members | System.Data.XML Namespace


Axis.AxisType Enumeration

[To be supplied.]

[Visual Basic]
Public Enum Axis.AxisType
[C#]
public enum Axis.AxisType
[C++]
public enum Axis.AxisType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Ancestor | [To be supplied.]
AncestorOrSelf | [To be supplied.]
Attribute | [To be supplied.]
Child | [To be supplied.]
Descendant | [To be supplied.]
DescendantOrSelf | [To be supplied.]
Following | [To be supplied.]
FollowingSibling | [To be supplied.]
Namespace | [To be supplied.]
None | [To be supplied.]
Parent | [To be supplied.]
Preceding | [To be supplied.]
PrecedingSibling | [To be supplied.]
Self | [To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

System.Data.XML Namespace


CoreXmlReader Class

[To be supplied.]

Object
CoreXmlReader

[Visual Basic]
Public Class CoreXmlReader
   Implements IDataReader, IDataRecord
[C#]
public class CoreXmlReader : IDataReader, IDataRecord
[C++]
public __gc class CoreXmlReader : public IDataReader, IDataRecord
[JScript]
public class CoreXmlReader implements IDataReader, IDataRecord

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader Members

Public:

Constructor

CoreXmlReader Constructor Overloaded. [To be supplied.]

Properties

DataTypeName | [To be supplied.]
DataTypeNamespace | [To be supplied.]
Depth | [To be supplied.]
Empty | [To be supplied.]
EOF | [To be supplied.]
FieldCount | [To be supplied.]
Filter | [To be supplied.]
Flags | [To be supplied.]
Format | [To be supplied.]
HasValue | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the CoreXmlReader class.
LineNumber | [To be supplied.]
LinePos | [To be supplied.]
Name | [To be supplied.]
Namespace | [To be supplied.]
NameTable | [To be supplied.]
NodeType | [To be supplied.]
Prefix | [To be supplied.]
ReadState | [To be supplied.]
ShowEndTag | [To be supplied.]
UriResolver | [To be supplied.]
Value | [To be supplied.]

Methods

Close | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
ExpandEntity | [To be supplied.]
GetBoolean | [To be supplied.]
GetByte | [To be supplied.]
GetBytes | [To be supplied.]
GetChar | [To be supplied.]
GetChars | [To be supplied.]
GetCurrency | [To be supplied.]
GetData | [To be supplied.]
GetDataTypeName | [To be supplied.]
GetDataTypeNamespace | [To be supplied.]
GetDateTime | [To be supplied.]
GetDecimal | [To be supplied.]
GetDouble | [To be supplied.]
GetFieldType | [To be supplied.]
GetFloat | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInt16 | [To be supplied.]
GetInt32 | [To be supplied.]
GetInt64 | [To be supplied.]
GetName | [To be supplied.]
GetNamespace | [To be supplied.]
GetOrdinal | Overloaded. [To be supplied.]
GetPrefix | [To be supplied.]
GetRaw | [To be supplied.]
GetStream | [To be supplied.]
GetString | [To be supplied.]
GetTimeSpan | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | [To be supplied.]
GetValues | [To be supplied.]
IsNull | [To be supplied.]
LookupNamespace | [To be supplied.]
Read | [To be supplied.]
ReadBlock | [To be supplied.]
ReadString | [To be supplied.]
Skip | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

DataTypes | [To be supplied.]
DecodeNames | [To be supplied.]
DTDValidation | [To be supplied.]
ExpandEntities | [To be supplied.]
IgnoreEntities | [To be supplied.]
Namespaces | [To be supplied.]
Normalization | [To be supplied.]
SchemaValidation | [To be supplied.]
TagWhitespace | [To be supplied.]
TokenView | [To be supplied.]
Whitespace | [To be supplied.]

Protected:

Constructor

CoreXmlReader Constructor Overloaded. [To be supplied.]

Properties

IsAttrText | [To be supplied.]
NamespaceManager | [To be supplied.]

Methods

CheckWhitespaceNodeType | [To be supplied.]
CreateNamespaceManager | [To be supplied.]
EndEntity | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetEntityScanner | [To be supplied.]
IsSchema | [To be supplied.]
MatchFilter | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseDtd | [To be supplied.]
ValidateDtd | [To be supplied.]
ValidateEnd | [To be supplied.]
ValidateSchema | [To be supplied.]
ValidateToken | [To be supplied.]

See Also

CoreXmlReader Class | System.Data.XML Namespace


CoreXmlReader Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Protected Sub New(INameTable)
[C#] protected CoreXmlReader(INameTable);
[C++] protected: CoreXmlReader(INameTable*);
[JScript] protected function CoreXmlReader(INameTable);

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public CoreXmlReader();
[C++] public: CoreXmlReader();
[JScript] public function CoreXmlReader();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Stream, INameTable)
[C#] public CoreXmlReader(Stream, INameTable);
[C++] public: CoreXmlReader(Stream*, INameTable);
[JScript] public function CoreXmlReader(Stream, INameTable);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(TextReader, INameTable)
[C#] public CoreXmlReader(TextReader, INameTable);
[C++] public: CoreXmlReader(TextReader*, INameTable);
[JScript] public function CoreXmlReader(TextReader, INameTable);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, INameTable)
[C#] public CoreXmlReader(String, INameTable);
[C++] public: CoreXmlReader(String*, INameTable);
[JScript] public function CoreXmlReader(String, INameTable);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Stream)
[C#] public CoreXmlReader(Stream);
[C++] public: CoreXmlReader(Stream*);
[JScript] public function CoreXmlReader(Stream);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(TextReader)
[C#] public CoreXmlReader(TextReader);
[C++] public: CoreXmlReader(TextReader*);
[JScript] public function CoreXmlReader(TextReader);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public CoreXmlReader(String);
[C++] public: CoreXmlReader(String*);
[JScript] public function CoreXmlReader(String);

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader Constructor (INameTable)

[To be supplied.]

[Visual Basic]
Overloads Protected Sub New( _
   ByVal nt As INameTable _
)
[C#]
protected CoreXmlReader(
   INameTable nt
);
[C++]
protected: CoreXmlReader(
   INameTable* nt
);
[JScript]
protected function CoreXmlReader(
   nt : INameTable
);

Parameters

nt
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace | CoreXmlReader Constructor Overload List


CoreXmlReader Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public CoreXmlReader();
[C++]
public: CoreXmlReader();
[JScript]
public function CoreXmlReader();

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace | CoreXmlReader Constructor Overload List


CoreXmlReader Constructor (Stream, INameTable)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal input As Stream, _
   ByVal nt As INameTable _
)
[C#]
public CoreXmlReader(
   Stream input,
   INameTable nt
);
[C++]
public: CoreXmlReader(
   Stream* input,
   INameTable* nt
);
[JScript]
public function CoreXmlReader(
   input : Stream,
   nt : INameTable
);

Parameters

input
[To be supplied.]
nt
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace | CoreXmlReader Constructor Overload List


CoreXmlReader Constructor (TextReader, INameTable)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal input As TextReader, _
   ByVal nt As INameTable _
)
[C#]
public CoreXmlReader(
   TextReader input,
   INameTable nt
);
[C++]
public: CoreXmlReader(
   TextReader* input,
   INameTable* nt
);
[JScript]
public function CoreXmlReader(
   input : TextReader,
   nt : INameTable
);

Parameters

input
[To be supplied.]
nt
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace | CoreXmlReader Constructor Overload List


CoreXmlReader Constructor (String, INameTable)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal url As String, _
   ByVal nt As INameTable _
)
[C#]
public CoreXmlReader(
   string url,
   INameTable nt
);
[C++]
public: CoreXmlReader(
   String* url,
   INameTable* nt
);
[JScript]
public function CoreXmlReader(
   url : String,
   nt : INameTable
);

Parameters

url
[To be supplied.]
nt
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace | CoreXmlReader Constructor Overload List


CoreXmlReader Constructor (Stream)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal input As Stream _
)
[C#]
public CoreXmlReader(
   Stream input
);
[C++]
public: CoreXmlReader(
   Stream* input
);
[JScript]
public function CoreXmlReader(
   input : Stream
);

Parameters

input
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace | CoreXmlReader Constructor Overload List


CoreXmlReader Constructor (TextReader)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal input As TextReader _
)
[C#]
public CoreXmlReader(
   TextReader input
);
[C++]
public: CoreXmlReader(
   TextReader* input
);
[JScript]
public function CoreXmlReader(
   input : TextReader
);

Parameters

input
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace | CoreXmlReader Constructor Overload List


CoreXmlReader Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal url As String _
)
[C#]
public CoreXmlReader(
   string url
);
[C++]
public: CoreXmlReader(
   String* url
);
[JScript]
public function CoreXmlReader(
   url : String
);

Parameters

url
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace | CoreXmlReader Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CoreXmlReader Properties

The properties of the CoreXmlReader class are listed below. For a complete list of CoreXmlReader class members, see the CoreXmlReader Members topic.

Public:

DataTypeName | [To be supplied.]
DataTypeNamespace | [To be supplied.]
Depth | [To be supplied.]
Empty | [To be supplied.]
EOF | [To be supplied.]
FieldCount | [To be supplied.]
Filter | [To be supplied.]
Flags | [To be supplied.]
Format | [To be supplied.]
HasValue | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the CoreXmlReader class.
LineNumber | [To be supplied.]
LinePos | [To be supplied.]
Name | [To be supplied.]
Namespace | [To be supplied.]
NameTable | [To be supplied.]
NodeType | [To be supplied.]
Prefix | [To be supplied.]
ReadState | [To be supplied.]
ShowEndTag | [To be supplied.]
UriResolver | [To be supplied.]
Value | [To be supplied.]

Protected:

IsAttrText | [To be supplied.]
NamespaceManager | [To be supplied.]

See Also

CoreXmlReader Class | System.Data.XML Namespace


CoreXmlReader.DataTypeName

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DataTypeName As String
[C#]
public string DataTypeName {virtual get;}
[C++]
public: __property virtual String* get_DataTypeName();
[JScript]
public function get DataTypeName() : String;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.DataTypeNamespace

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DataTypeNamespace As String
[C#]
public string DataTypeNamespace {virtual get;}
[C++]
public: __property virtual String* get_DataTypeNamespace();
[JScript]
public function get DataTypeNamespace() : String;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.Depth

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Depth As Integer
[C#]
public int Depth {virtual get;}
[C++]
public: __property virtual int get_Depth();
[JScript]
public function get Depth() : int;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.Empty

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Empty As Boolean
[C#]
public bool Empty {virtual get;}
[C++]
public: __property virtual bool get_Empty();
[JScript]
public function get Empty() : Boolean;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.EOF

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property EOF As Boolean
[C#]
public bool EOF {virtual get;}
[C++]
public: __property virtual bool get_EOF();
[JScript]
public function get EOF() : Boolean;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.FieldCount

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property FieldCount As Integer
[C#]
public int FieldCount {virtual get;}
[C++]
public: __property virtual int get_FieldCount();
[JScript]
public function get FieldCount() : int;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.Filter

[To be supplied.]

[Visual Basic]
Overridable Public Property Filter As String
[C#]
public string Filter {virtual get; virtual set;}
[C++]
public: __property virtual String* get_Filter();
public: __property virtual void set_Filter(String*);
[JScript]
public function get Filter() : String;
public function set Filter(String);

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.Flags

[To be supplied.]

[Visual Basic]
Public Property Flags As Integer
[C#]
public int Flags {get; set;}
[C++]
public: __property int get_Flags();
public: __property void set_Flags(int);
[JScript]
public function get Flags() : int;
public function set Flags(int);

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.Format

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Format As String
[C#]
public string Format {virtual get;}
[C++]
public: __property virtual String* get_Format();
[JScript]
public function get Format() : String;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.HasValue

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property HasValue As Boolean
[C#]
public bool HasValue {virtual get;}
[C++]
public: __property virtual bool get_HasValue();
[JScript]
public function get HasValue() : Boolean;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.IsAttrText

[To be supplied.]

[Visual Basic]
Protected ReadOnly Property IsAttrText As Boolean
[C#]
protected bool IsAttrText {get;}
[C++]
protected: __property bool get_IsAttrText();
[JScript]
protected function get IsAttrText() : Boolean;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the CoreXmlReader class.

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(String) As Object
[C#] public object this[String] {virtual get;}
[C++] public: __property virtual Object* get_Item(String*);
[JScript] CoreXmlReader.Item (String)

[To be supplied.]

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(Integer) As Object
[C#] public object this[int] {virtual get;}
[C++] public: __property virtual Object* get_Item(int);
[JScript] CoreXmlReader.Item (int)

[To be supplied.]

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(String, String) As Object
[C#] public object this[String, String] {virtual get;}
[C++] public: __property virtual Object* get_Item(String*, String*);
[JScript] CoreXmlReader.Item (String, String)

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.Item (String)

[To be supplied.]

[C#] In C#, this member is the indexer for the CoreXmlReader class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal name As String _
) As Object
[C#]
public object this[
   string name
] {virtual get;}
[C++]
public: __property virtual Object* get_Item(
   String* name
);
[JScript]
returnValue = CoreXmlReaderObject.Item(name);
-or-
returnValue = CoreXmlReaderObject(name);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
[To be supplied.]

Parameters [Visual Basic, C#, C++]

name
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace | CoreXmlReader.Item Overload List


CoreXmlReader.Item (Int32)

[To be supplied.]

[C#] In C#, this member is the indexer for the CoreXmlReader class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal i As Integer _
) As Object
[C#]
public object this[
   int i
] {virtual get;}
[C++]
public: __property virtual Object* get_Item(
   int i
);
[JScript]
returnValue = CoreXmlReaderObject.Item(i);
-or-
returnValue = CoreXmlReaderObject(i);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

i
[To be supplied.]

Parameters [Visual Basic, C#, C++]

i
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace | CoreXmlReader.Item Overload List


CoreXmlReader.Item (String, String)

[To be supplied.]

[C#] In C#, this member is the indexer for the CoreXmlReader class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal name As String, _
   ByVal fieldNamespace As String _
) As Object
[C#]
public object this[
   string name,
   string fieldNamespace
] {virtual get;}
[C++]
public: __property virtual Object* get_Item(
   String* name,
   String* fieldNamespace
);
[JScript]
returnValue = CoreXmlReaderObject.Item(name, fieldNamespace);
-or-
returnValue = CoreXmlReaderObject(name, fieldNamespace);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
[To be supplied.]
fieldNamespace
[To be supplied.]

Parameters [Visual Basic, C#, C++]

name
[To be supplied.]
fieldNamespace
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace | CoreXmlReader.Item Overload List


CoreXmlReader.LineNumber

[To be supplied.]

[Visual Basic]
Public ReadOnly Property LineNumber As Integer
[C#]
public int LineNumber {get;}
[C++]
public: __property int get_LineNumber();
[JScript]
public function get LineNumber() : int;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.LinePos

[To be supplied.]

[Visual Basic]
Public ReadOnly Property LinePos As Integer
[C#]
public int LinePos {get;}
[C++]
public: __property int get_LinePos();
[JScript]
public function get LinePos() : int;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.Name

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {virtual get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.Namespace

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Namespace As String
[C#]
public string Namespace {virtual get;}
[C++]
public: __property virtual String* get_Namespace();
[JScript]
public function get Namespace() : String;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.NamespaceManager

[To be supplied.]

[Visual Basic]
Protected ReadOnly Property NamespaceManager As NamespaceManager
[C#]
protected NamespaceManager NamespaceManager {get;}
[C++]
protected: __property NamespaceManager* get_NamespaceManager();
[JScript]
protected function get NamespaceManager() : NamespaceManager;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.NameTable

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property NameTable As INameTable
[C#]
public INameTable NameTable {virtual get;}
[C++]
public: __property virtual INameTable* get_NameTable();
[JScript]
public function get NameTable() : INameTable;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.NodeType

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property NodeType As XmlNodeType
[C#]
public XmlNodeType NodeType {virtual get;}
[C++]
public: __property virtual XmlNodeType get_NodeType();
[JScript]
public function get NodeType() : XmlNodeType;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.Prefix

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Prefix As String
[C#]
public string Prefix {virtual get;}
[C++]
public: __property virtual String* get_Prefix();
[JScript]
public function get Prefix() : String;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.ReadState

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property ReadState As Integer
[C#]
public int ReadState {virtual get;}
[C++]
public: __property virtual int get_ReadState();
[JScript]
public function get ReadState() : int;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.ShowEndTag

[To be supplied.]

[Visual Basic]
Public Property ShowEndTag As Boolean
[C#]
public bool ShowEndTag {get; set;}
[C++]
public: __property bool get_ShowEndTag();
public: __property void set_ShowEndTag(bool);
[JScript]
public function get ShowEndTag() : Boolean;
public function set ShowEndTag(Boolean);

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.UriResolver

[To be supplied.]

[Visual Basic]
Public Property UriResolver As IUriResolver
[C#]
public IUriResolver UriResolver {get; set;}
[C++]
public: __property IUriResolver* get_UriResolver();
public: __property void set_UriResolver(IUriResolver*);
[JScript]
public function get UriResolver() : IUriResolver;
public function set UriResolver(IUriResolver);

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.Value

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Value As String
[C#]
public string Value {get;}
[C++]
public: __property String* get_Value();
[JScript]
public function get Value() : String;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CoreXmlReader Methods

The methods of the CoreXmlReader class are listed below. For a complete list of CoreXmlReader class members, see the CoreXmlReader Members topic.

Public:

Close | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
ExpandEntity | [To be supplied.]
GetBoolean | [To be supplied.]
GetByte | [To be supplied.]
GetBytes | [To be supplied.]
GetChar | [To be supplied.]
GetChars | [To be supplied.]
GetCurrency | [To be supplied.]
GetData | [To be supplied.]
GetDataTypeName | [To be supplied.]
GetDataTypeNamespace | [To be supplied.]
GetDateTime | [To be supplied.]
GetDecimal | [To be supplied.]
GetDouble | [To be supplied.]
GetFieldType | [To be supplied.]
GetFloat | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInt16 | [To be supplied.]
GetInt32 | [To be supplied.]
GetInt64 | [To be supplied.]
GetName | [To be supplied.]
GetNamespace | [To be supplied.]
GetOrdinal | Overloaded. [To be supplied.]
GetPrefix | [To be supplied.]
GetRaw | [To be supplied.]
GetStream | [To be supplied.]
GetString | [To be supplied.]
GetTimeSpan | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | [To be supplied.]
GetValues | [To be supplied.]
IsNull | [To be supplied.]
LookupNamespace | [To be supplied.]
Read | [To be supplied.]
ReadBlock | [To be supplied.]
ReadString | [To be supplied.]
Skip | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

CheckWhitespaceNodeType | [To be supplied.]
CreateNamespaceManager | [To be supplied.]
EndEntity | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetEntityScanner | [To be supplied.]
IsSchema | [To be supplied.]
MatchFilter | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseDtd | [To be supplied.]
ValidateDtd | [To be supplied.]
ValidateEnd | [To be supplied.]
ValidateSchema | [To be supplied.]
ValidateToken | [To be supplied.]

See Also

CoreXmlReader Class | System.Data.XML Namespace


CoreXmlReader.CheckWhitespaceNodeType

[To be supplied.]

[Visual Basic]
Overridable Protected Function CheckWhitespaceNodeType( _
   ByVal name As String, _
   ByVal prefix As String, _
   ByVal ns As String _
) As XmlNodeType
[C#]
protected virtual XmlNodeType CheckWhitespaceNodeType(
   string name,
   string prefix,
   string ns
);
[C++]
protected: virtual XmlNodeType CheckWhitespaceNodeType(
   String* name,
   String* prefix,
   String* ns
);
[JScript]
protected function CheckWhitespaceNodeType(
   name : String,
   prefix : String,
   ns : String
) : XmlNodeType;

Parameters

name
[To be supplied.]
prefix
[To be supplied.]
ns
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.Close

[To be supplied.]

[Visual Basic]
Overridable Public Sub Close()
[C#]
public virtual void Close();
[C++]
public: virtual void Close();
[JScript]
public function Close();

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.CreateNamespaceManager

[To be supplied.]

[Visual Basic]
Overridable Protected Function CreateNamespaceManager() As _
   NamespaceManager
[C#]
protected virtual NamespaceManager CreateNamespaceManager();
[C++]
protected: virtual NamespaceManager* CreateNamespaceManager();
[JScript]
protected function CreateNamespaceManager() : NamespaceManager;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.EndEntity

[To be supplied.]

[Visual Basic]
Overridable Protected Sub EndEntity( _
   ByVal o As Object _
)
[C#]
protected virtual void EndEntity(
   object o
);
[C++]
protected: virtual void EndEntity(
   Object* o
);
[JScript]
protected function EndEntity(
   o : Object
);

Parameters

o
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.ExpandEntity

[To be supplied.]

[Visual Basic]
Public Sub ExpandEntity()
[C#]
public void ExpandEntity();
[C++]
public: void ExpandEntity();
[JScript]
public function ExpandEntity();

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.GetBoolean

[To be supplied.]

[Visual Basic]
Overridable Public Function GetBoolean( _
   ByVal i As Integer _
) As Boolean
[C#]
public virtual bool GetBoolean(
   int i
);
[C++]
public: virtual bool GetBoolean(
   int i
);
[JScript]
public function GetBoolean(
   i : int
) : Boolean;

Parameters

i
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.GetByte

[To be supplied.]

[Visual Basic]
Overridable Public Function GetByte( _
   ByVal i As Integer _
) As Byte
[C#]
public virtual byte GetByte(
   int i
);
[C++]
public: virtual unsigned char GetByte(
   int i
);
[JScript]
public function GetByte(
   i : int
) : Byte;

Parameters

i
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.GetBytes

[To be supplied.]

[Visual Basic]
Overridable Public Function GetBytes( _
   ByVal i As Integer, _
   ByVal buffer() As Byte, _
   ByVal length As Integer, _
   ByVal bufferOffset As Integer, _
   ByVal fieldOffset As Integer _
) As Integer
[C#]
public virtual int GetBytes(
   int i,
   byte[] buffer,
   int length,
   int bufferOffset,
   int fieldOffset
);
[C++]
public: virtual int GetBytes(
   int i,
   unsigned char* buffer[],
   int length,
   int bufferOffset,
   int fieldOffset
);
[JScript]
public function GetBytes(
   i : int,
   buffer : Byte[],
   length : int,
   bufferOffset : int,
   fieldOffset : int
) : int;

Parameters

i
[To be supplied.]
buffer
[To be supplied.]
length
[To be supplied.]
bufferOffset
[To be supplied.]
fieldOffset
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.GetChar

[To be supplied.]

[Visual Basic]
Overridable Public Function GetChar( _
   ByVal i As Integer _
) As Char
[C#]
public virtual char GetChar(
   int i
);
[C++]
public: virtual __wchar_t GetChar(
   int i
);
[JScript]
public function GetChar(
   i : int
) : Char;

Parameters

i
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.GetChars

[To be supplied.]

[Visual Basic]
Overridable Public Function GetChars( _
   ByVal i As Integer, _
   ByVal buffer() As Char, _
   ByVal length As Integer, _
   ByVal bufferOffset As Integer, _
   ByVal fieldOffset As Integer _
) As Integer
[C#]
public virtual int GetChars(
   int i,
   char[] buffer,
   int length,
   int bufferOffset,
   int fieldOffset
);
[C++]
public: virtual int GetChars(
   int i,
   __wchar_t* buffer[],
   int length,
   int bufferOffset,
   int fieldOffset
);
[JScript]
public function GetChars(
   i : int,
   buffer : Char[],
   length : int,
   bufferOffset : int,
   fieldOffset : int
) : int;

Parameters

i
[To be supplied.]
buffer
[To be supplied.]
length
[To be supplied.]
bufferOffset
[To be supplied.]
fieldOffset
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.GetCurrency

[To be supplied.]

[Visual Basic]
Overridable Public Function GetCurrency( _
   ByVal i As Integer _
) As Currency
[C#]
public virtual Currency GetCurrency(
   int i
);
[C++]
public: virtual Currency GetCurrency(
   int i
);
[JScript]
public function GetCurrency(
   i : int
) : Currency;

Parameters

i
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.GetData

[To be supplied.]

[Visual Basic]
Overridable Public Function GetData( _
   ByVal i As Integer _
) As IDataReader
[C#]
public virtual IDataReader GetData(
   int i
);
[C++]
public: virtual IDataReader* GetData(
   int i
);
[JScript]
public function GetData(
   i : int
) : IDataReader;

Parameters

i
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.GetDataTypeName

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDataTypeName( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetDataTypeName(
   int i
);
[C++]
public: virtual String* GetDataTypeName(
   int i
);
[JScript]
public function GetDataTypeName(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.GetDataTypeNamespace

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDataTypeNamespace( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetDataTypeNamespace(
   int i
);
[C++]
public: virtual String* GetDataTypeNamespace(
   int i
);
[JScript]
public function GetDataTypeNamespace(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.GetDateTime

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDateTime( _
   ByVal i As Integer _
) As DateTime
[C#]
public virtual DateTime GetDateTime(
   int i
);
[C++]
public: virtual DateTime GetDateTime(
   int i
);
[JScript]
public function GetDateTime(
   i : int
) : DateTime;

Parameters

i
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.GetDecimal

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDecimal( _
   ByVal i As Integer _
) As Decimal
[C#]
public virtual Decimal GetDecimal(
   int i
);
[C++]
public: virtual Decimal GetDecimal(
   int i
);
[JScript]
public function GetDecimal(
   i : int
) : Decimal;

Parameters

i
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.GetDouble

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDouble( _
   ByVal i As Integer _
) As Double
[C#]
public virtual double GetDouble(
   int i
);
[C++]
public: virtual double GetDouble(
   int i
);
[JScript]
public function GetDouble(
   i : int
) : double;

Parameters

i
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.GetEntityScanner

[To be supplied.]

[Visual Basic]
Overridable Protected Function GetEntityScanner( _
   ByVal name As String, _
   ByRef o As Object _
) As XmlScanner
[C#]
protected virtual XmlScanner GetEntityScanner(
   string name,
   ref object o
);
[C++]
protected: virtual XmlScanner* GetEntityScanner(
   String* name,
   Object** o
);
[JScript]
protected function GetEntityScanner(
   name : String,
   o : Object
) : XmlScanner;

Parameters

name
[To be supplied.]
o
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.GetFieldType

[To be supplied.]

[Visual Basic]
Overridable Public Function GetFieldType( _
   ByVal i As Integer _
) As Type
[C#]
public virtual Type GetFieldType(
   int i
);
[C++]
public: virtual Type* GetFieldType(
   int i
);
[JScript]
public function GetFieldType(
   i : int
) : Type;

Parameters

i
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.GetFloat

[To be supplied.]

[Visual Basic]
Overridable Public Function GetFloat( _
   ByVal i As Integer _
) As Single
[C#]
public virtual float GetFloat(
   int i
);
[C++]
public: virtual float GetFloat(
   int i
);
[JScript]
public function GetFloat(
   i : int
) : float;

Parameters

i
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.GetInt16

[To be supplied.]

[Visual Basic]
Overridable Public Function GetInt16( _
   ByVal i As Integer _
) As Short
[C#]
public virtual short GetInt16(
   int i
);
[C++]
public: virtual short GetInt16(
   int i
);
[JScript]
public function GetInt16(
   i : int
) : Int16;

Parameters

i
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.GetInt32

[To be supplied.]

[Visual Basic]
Overridable Public Function GetInt32( _
   ByVal i As Integer _
) As Integer
[C#]
public virtual int GetInt32(
   int i
);
[C++]
public: virtual int GetInt32(
   int i
);
[JScript]
public function GetInt32(
   i : int
) : int;

Parameters

i
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.GetInt64

[To be supplied.]

[Visual Basic]
Overridable Public Function GetInt64( _
   ByVal i As Integer _
) As Long
[C#]
public virtual long GetInt64(
   int i
);
[C++]
public: virtual __int64 GetInt64(
   int i
);
[JScript]
public function GetInt64(
   i : int
) : long;

Parameters

i
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.GetName

[To be supplied.]

[Visual Basic]
Overridable Public Function GetName( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetName(
   int i
);
[C++]
public: virtual String* GetName(
   int i
);
[JScript]
public function GetName(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.GetNamespace

[To be supplied.]

[Visual Basic]
Overridable Public Function GetNamespace( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetNamespace(
   int i
);
[C++]
public: virtual String* GetNamespace(
   int i
);
[JScript]
public function GetNamespace(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.GetOrdinal

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function GetOrdinal(String, String) As Integer
[C#] public virtual int GetOrdinal(String, String);
[C++] public: virtual int GetOrdinal(String*, String*);
[JScript] public function GetOrdinal(String, String) : int;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function GetOrdinal(String) As Integer
[C#] public virtual int GetOrdinal(String);
[C++] public: virtual int GetOrdinal(String*);
[JScript] public function GetOrdinal(String) : int;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.GetOrdinal (String, String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function GetOrdinal( _
   ByVal name As String, _
   ByVal fieldNamespace As String _
) As Integer
[C#]
public virtual int GetOrdinal(
   string name,
   string fieldNamespace
);
[C++]
public: virtual int GetOrdinal(
   String* name,
   String* fieldNamespace
);
[JScript]
public function GetOrdinal(
   name : String,
   fieldNamespace : String
) : int;

Parameters

name
[To be supplied.]
fieldNamespace
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace | CoreXmlReader.GetOrdinal Overload List


CoreXmlReader.GetOrdinal (String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function GetOrdinal( _
   ByVal name As String _
) As Integer
[C#]
public virtual int GetOrdinal(
   string name
);
[C++]
public: virtual int GetOrdinal(
   String* name
);
[JScript]
public function GetOrdinal(
   name : String
) : int;

Parameters

name
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace | CoreXmlReader.GetOrdinal Overload List


CoreXmlReader.GetPrefix

[To be supplied.]

[Visual Basic]
Overridable Public Function GetPrefix( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetPrefix(
   int i
);
[C++]
public: virtual String* GetPrefix(
   int i
);
[JScript]
public function GetPrefix(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.GetRaw

[To be supplied.]

[Visual Basic]
Overridable Public Function GetRaw( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetRaw(
   int i
);
[C++]
public: virtual String* GetRaw(
   int i
);
[JScript]
public function GetRaw(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.GetStream

[To be supplied.]

[Visual Basic]
Overridable Public Function GetStream( _
   ByVal i As Integer _
) As Stream
[C#]
public virtual Stream GetStream(
   int i
);
[C++]
public: virtual Stream* GetStream(
   int i
);
[JScript]
public function GetStream(
   i : int
) : Stream;

Parameters

i
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.GetString

[To be supplied.]

[Visual Basic]
Overridable Public Function GetString( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetString(
   int i
);
[C++]
public: virtual String* GetString(
   int i
);
[JScript]
public function GetString(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.GetTimeSpan

[To be supplied.]

[Visual Basic]
Overridable Public Function GetTimeSpan( _
   ByVal i As Integer _
) As TimeSpan
[C#]
public virtual TimeSpan GetTimeSpan(
   int i
);
[C++]
public: virtual TimeSpan GetTimeSpan(
   int i
);
[JScript]
public function GetTimeSpan(
   i : int
) : TimeSpan;

Parameters

i
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.GetValue

[To be supplied.]

[Visual Basic]
Overridable Public Sub GetValue( _
   ByVal i As Integer, _
   ByRef value As Object _
)
[C#]
public virtual void GetValue(
   int i,
   ref object value
);
[C++]
public: virtual void GetValue(
   int i,
   Object** value
);
[JScript]
public function GetValue(
   i : int,
   value : Object
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.GetValues

[To be supplied.]

[Visual Basic]
Overridable Public Function GetValues( _
   ByVal values() As Object _
) As Integer
[C#]
public virtual int GetValues(
   object[] values
);
[C++]
public: virtual int GetValues(
   Object* values[]
);
[JScript]
public function GetValues(
   values : Object[]
) : int;

Parameters

values
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.IsNull

[To be supplied.]

[Visual Basic]
Overridable Public Function IsNull( _
   ByVal i As Integer _
) As Boolean
[C#]
public virtual bool IsNull(
   int i
);
[C++]
public: virtual bool IsNull(
   int i
);
[JScript]
public function IsNull(
   i : int
) : Boolean;

Parameters

i
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.IsSchema

[To be supplied.]

[Visual Basic]
Overridable Protected Function IsSchema( _
   ByVal ns As String _
) As Boolean
[C#]
protected virtual bool IsSchema(
   string ns
);
[C++]
protected: virtual bool IsSchema(
   String* ns
);
[JScript]
protected function IsSchema(
   ns : String
) : Boolean;

Parameters

ns
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.LookupNamespace

[To be supplied.]

[Visual Basic]
Public Function LookupNamespace( _
   ByVal prefix As String _
) As String
[C#]
public string LookupNamespace(
   string prefix
);
[C++]
public: String* LookupNamespace(
   String* prefix
);
[JScript]
public function LookupNamespace(
   prefix : String
) : String;

Parameters

prefix
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.MatchFilter

[To be supplied.]

[Visual Basic]
Overridable Protected Function MatchFilter() As Boolean
[C#]
protected virtual bool MatchFilter();
[C++]
protected: virtual bool MatchFilter();
[JScript]
protected function MatchFilter() : Boolean;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.ParseDtd

[To be supplied.]

[Visual Basic]
Overridable Protected Function ParseDtd( _
   ByVal scanner As XmlScanner _
) As String
[C#]
protected virtual string ParseDtd(
   XmlScanner scanner
);
[C++]
protected: virtual String* ParseDtd(
   XmlScanner* scanner
);
[JScript]
protected function ParseDtd(
   scanner : XmlScanner
) : String;

Parameters

scanner
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.Read

[To be supplied.]

[Visual Basic]
Overridable Public Function Read() As Boolean
[C#]
public virtual bool Read();
[C++]
public: virtual bool Read();
[JScript]
public function Read() : Boolean;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.ReadBlock

[To be supplied.]

[Visual Basic]
Public Function ReadBlock( _
   ByVal buffer() As Char, _
   ByVal length As Integer, _
   ByVal destinationIndex As Integer _
) As Integer
[C#]
public int ReadBlock(
   char[] buffer,
   int length,
   int destinationIndex
);
[C++]
public: int ReadBlock(
   __wchar_t* buffer[],
   int length,
   int destinationIndex
);
[JScript]
public function ReadBlock(
   buffer : Char[],
   length : int,
   destinationIndex : int
) : int;

Parameters

buffer
[To be supplied.]
length
[To be supplied.]
destinationIndex
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.ReadString

[To be supplied.]

[Visual Basic]
Public Function ReadString() As String
[C#]
public string ReadString();
[C++]
public: String* ReadString();
[JScript]
public function ReadString() : String;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.Skip

[To be supplied.]

[Visual Basic]
Public Sub Skip()
[C#]
public void Skip();
[C++]
public: void Skip();
[JScript]
public function Skip();

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.ValidateDtd

[To be supplied.]

[Visual Basic]
Overridable Protected Sub ValidateDtd()
[C#]
protected virtual void ValidateDtd();
[C++]
protected: virtual void ValidateDtd();
[JScript]
protected function ValidateDtd();

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.ValidateEnd

[To be supplied.]

[Visual Basic]
Overridable Protected Sub ValidateEnd()
[C#]
protected virtual void ValidateEnd();
[C++]
protected: virtual void ValidateEnd();
[JScript]
protected function ValidateEnd();

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.ValidateSchema

[To be supplied.]

[Visual Basic]
Overridable Protected Sub ValidateSchema( _
   ByVal ns As String _
)
[C#]
protected virtual void ValidateSchema(
   string ns
);
[C++]
protected: virtual void ValidateSchema(
   String* ns
);
[JScript]
protected function ValidateSchema(
   ns : String
);

Parameters

ns
[To be supplied.]

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.ValidateToken

[To be supplied.]

[Visual Basic]
Overridable Protected Sub ValidateToken()
[C#]
protected virtual void ValidateToken();
[C++]
protected: virtual void ValidateToken();
[JScript]
protected function ValidateToken();

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CoreXmlReader Fields

The fields of the CoreXmlReader class are listed below. For a complete list of CoreXmlReader class members, see the CoreXmlReader Members topic.

Public:

DataTypes | [To be supplied.]
DecodeNames | [To be supplied.]
DTDValidation | [To be supplied.]
ExpandEntities | [To be supplied.]
IgnoreEntities | [To be supplied.]
Namespaces | [To be supplied.]
Normalization | [To be supplied.]
SchemaValidation | [To be supplied.]
TagWhitespace | [To be supplied.]
TokenView | [To be supplied.]
Whitespace | [To be supplied.]

See Also

CoreXmlReader Class | System.Data.XML Namespace


CoreXmlReader.DataTypes

[To be supplied.]

[Visual Basic]
Public Const DataTypes As Integer
[C#]
public const int DataTypes;
[C++]
public: const int DataTypes;
[JScript]
public var DataTypes : int;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.DecodeNames

[To be supplied.]

[Visual Basic]
Public Const DecodeNames As Integer
[C#]
public const int DecodeNames;
[C++]
public: const int DecodeNames;
[JScript]
public var DecodeNames : int;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.DTDValidation

[To be supplied.]

[Visual Basic]
Public Const DTDValidation As Integer
[C#]
public const int DTDValidation;
[C++]
public: const int DTDValidation;
[JScript]
public var DTDValidation : int;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.ExpandEntities

[To be supplied.]

[Visual Basic]
Public Const ExpandEntities As Integer
[C#]
public const int ExpandEntities;
[C++]
public: const int ExpandEntities;
[JScript]
public var ExpandEntities : int;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.IgnoreEntities

[To be supplied.]

[Visual Basic]
Public Const IgnoreEntities As Integer
[C#]
public const int IgnoreEntities;
[C++]
public: const int IgnoreEntities;
[JScript]
public var IgnoreEntities : int;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.Namespaces

[To be supplied.]

[Visual Basic]
Public Const Namespaces As Integer
[C#]
public const int Namespaces;
[C++]
public: const int Namespaces;
[JScript]
public var Namespaces : int;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.Normalization

[To be supplied.]

[Visual Basic]
Public Const Normalization As Integer
[C#]
public const int Normalization;
[C++]
public: const int Normalization;
[JScript]
public var Normalization : int;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.SchemaValidation

[To be supplied.]

[Visual Basic]
Public Const SchemaValidation As Integer
[C#]
public const int SchemaValidation;
[C++]
public: const int SchemaValidation;
[JScript]
public var SchemaValidation : int;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.TagWhitespace

[To be supplied.]

[Visual Basic]
Public Const TagWhitespace As Integer
[C#]
public const int TagWhitespace;
[C++]
public: const int TagWhitespace;
[JScript]
public var TagWhitespace : int;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.TokenView

[To be supplied.]

[Visual Basic]
Public Const TokenView As Integer
[C#]
public const int TokenView;
[C++]
public: const int TokenView;
[JScript]
public var TokenView : int;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


CoreXmlReader.Whitespace

[To be supplied.]

[Visual Basic]
Public Const Whitespace As Integer
[C#]
public const int Whitespace;
[C++]
public: const int Whitespace;
[JScript]
public var Whitespace : int;

See Also

CoreXmlReader Class | CoreXmlReader Members | System.Data.XML Namespace


DataSetMapping Enumeration

[To be supplied.]

[Visual Basic]
Public Enum DataSetMapping
[C#]
public enum DataSetMapping
[C++]
public enum DataSetMapping

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Inference | [To be supplied.]
Inline | [To be supplied.]
Loaded | [To be supplied.]
None | [To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

System.Data.XML Namespace


DocumentEditor Class

[To be supplied.]

Object
DocumentEditor

[Visual Basic]
NotInheritable Public Class DocumentEditor
   Implements IDataEditor, IDataNavigator, IDataRecord, IDataBuffer
[C#]
public sealed class DocumentEditor : IDataEditor, IDataNavigator,
   IDataRecord, IDataBuffer
[C++]
public __gc __sealed class DocumentEditor : public IDataEditor,
   IDataNavigator, IDataRecord, IDataBuffer
[JScript]
public class DocumentEditor implements IDataEditor, IDataNavigator,
   IDataRecord, IDataBuffer

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

DocumentEditor Members | System.Data.XML Namespace


DocumentEditor Members

Public:

Constructor

DocumentEditor Constructor Overloaded. [To be supplied.]

Properties

ChildCount | [To be supplied.]
DataTypeName | [To be supplied.]
DataTypeNamespace | [To be supplied.]
Empty | [To be supplied.]
FieldCount | [To be supplied.]
HasChildren | [To be supplied.]
HasValue | [To be supplied.]
IndexInParent | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the DocumentEditor class.
LoadState | [To be supplied.]
Name | [To be supplied.]
Namespace | [To be supplied.]
NameTable | [To be supplied.]
NodeType | [To be supplied.]
Prefix | [To be supplied.]
ReadOnly | [To be supplied.]

Methods

Clear | [To be supplied.]
Clone | [To be supplied.]
CompareOrder | [To be supplied.]
Compile | [To be supplied.]
CopyChildren | [To be supplied.]
CopySelected | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Evaluate | Overloaded. [To be supplied.]
GetBoolean | [To be supplied.]
GetByte | [To be supplied.]
GetBytes | [To be supplied.]
GetChar | [To be supplied.]
GetChars | [To be supplied.]
GetCurrency | [To be supplied.]
GetData | [To be supplied.]
GetDataTypeName | [To be supplied.]
GetDataTypeNamespace | [To be supplied.]
GetDateTime | [To be supplied.]
GetDecimal | [To be supplied.]
GetDouble | [To be supplied.]
GetEnumerator | [To be supplied.]
GetFieldType | [To be supplied.]
GetFloat | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInt16 | [To be supplied.]
GetInt32 | [To be supplied.]
GetInt64 | [To be supplied.]
GetName | [To be supplied.]
GetNamespace | [To be supplied.]
GetOrdinal | Overloaded. [To be supplied.]
GetPrefix | [To be supplied.]
GetRaw | [To be supplied.]
GetStream | [To be supplied.]
GetString | [To be supplied.]
GetTimeSpan | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | [To be supplied.]
GetValues | [To be supplied.]
Insert | Overloaded. [To be supplied.]
IsNull | [To be supplied.]
IsSame | [To be supplied.]
Matches | Overloaded. [To be supplied.]
Move | [To be supplied.]
MoveChildren | [To be supplied.]
MoveFirst | [To be supplied.]
MoveFirstSelected | [To be supplied.]
MoveLast | [To be supplied.]
MoveLastSelected | [To be supplied.]
MoveNext | [To be supplied.]
MoveNextSelected | [To be supplied.]
MovePrevious | [To be supplied.]
MovePreviousSelected | [To be supplied.]
MoveSelected | [To be supplied.]
MoveTo | [To be supplied.]
MoveToChild | [To be supplied.]
MoveToField | [To be supplied.]
MoveToFirstChild | [To be supplied.]
MoveToId | [To be supplied.]
MoveToLastChild | [To be supplied.]
MoveToNull | [To be supplied.]
MoveToParent | [To be supplied.]
MoveToRoot | [To be supplied.]
PopPosition | [To be supplied.]
PushPosition | [To be supplied.]
Remove | Overloaded. [To be supplied.]
RemoveSelected | [To be supplied.]
Select | Overloaded. [To be supplied.]
SetBoolean | [To be supplied.]
SetByte | [To be supplied.]
SetBytes | [To be supplied.]
SetChar | [To be supplied.]
SetChars | [To be supplied.]
SetCurrency | [To be supplied.]
SetData | [To be supplied.]
SetDateTime | [To be supplied.]
SetDecimal | [To be supplied.]
SetDouble | [To be supplied.]
SetFloat | [To be supplied.]
SetInt16 | [To be supplied.]
SetInt32 | [To be supplied.]
SetInt64 | [To be supplied.]
SetName | [To be supplied.]
SetNamespace | [To be supplied.]
SetNull | [To be supplied.]
SetPrefix | [To be supplied.]
SetRaw | [To be supplied.]
SetStream | [To be supplied.]
SetString | [To be supplied.]
SetTimeSpan | [To be supplied.]
SetValue | [To be supplied.]
SetValues | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DocumentEditor Class | System.Data.XML Namespace


DocumentEditor Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(XmlDocument)
[C#] public DocumentEditor(XmlDocument);
[C++] public: DocumentEditor(XmlDocument*);
[JScript] public function DocumentEditor(XmlDocument);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(DocumentEditor)
[C#] public DocumentEditor(DocumentEditor);
[C++] public: DocumentEditor(DocumentEditor*);
[JScript] public function DocumentEditor(DocumentEditor);

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public DocumentEditor();
[C++] public: DocumentEditor();
[JScript] public function DocumentEditor();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(DataRow)
[C#] public DocumentEditor(DataRow);
[C++] public: DocumentEditor(DataRow*);
[JScript] public function DocumentEditor(DataRow);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(INode)
[C#] public DocumentEditor(INode);
[C++] public: DocumentEditor(INode*);
[JScript] public function DocumentEditor(INode);

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor Constructor (XmlDocument)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal xmlDoc As XmlDocument _
)
[C#]
public DocumentEditor(
   XmlDocument xmlDoc
);
[C++]
public: DocumentEditor(
   XmlDocument* xmlDoc
);
[JScript]
public function DocumentEditor(
   xmlDoc : XmlDocument
);

Parameters

xmlDoc
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace | DocumentEditor Constructor Overload List


DocumentEditor Constructor (DocumentEditor)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal that As DocumentEditor _
)
[C#]
public DocumentEditor(
   DocumentEditor that
);
[C++]
public: DocumentEditor(
   DocumentEditor* that
);
[JScript]
public function DocumentEditor(
   that : DocumentEditor
);

Parameters

that
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace | DocumentEditor Constructor Overload List


DocumentEditor Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public DocumentEditor();
[C++]
public: DocumentEditor();
[JScript]
public function DocumentEditor();

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace | DocumentEditor Constructor Overload List


DocumentEditor Constructor (DataRow)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal row As DataRow _
)
[C#]
public DocumentEditor(
   DataRow row
);
[C++]
public: DocumentEditor(
   DataRow* row
);
[JScript]
public function DocumentEditor(
   row : DataRow
);

Parameters

row
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace | DocumentEditor Constructor Overload List


DocumentEditor Constructor (INode)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal node As INode _
)
[C#]
public DocumentEditor(
   INode node
);
[C++]
public: DocumentEditor(
   INode* node
);
[JScript]
public function DocumentEditor(
   node : INode
);

Parameters

node
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace | DocumentEditor Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DocumentEditor Properties

The properties of the DocumentEditor class are listed below. For a complete list of DocumentEditor class members, see the DocumentEditor Members topic.

Public:

ChildCount | [To be supplied.]
DataTypeName | [To be supplied.]
DataTypeNamespace | [To be supplied.]
Empty | [To be supplied.]
FieldCount | [To be supplied.]
HasChildren | [To be supplied.]
HasValue | [To be supplied.]
IndexInParent | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the DocumentEditor class.
LoadState | [To be supplied.]
Name | [To be supplied.]
Namespace | [To be supplied.]
NameTable | [To be supplied.]
NodeType | [To be supplied.]
Prefix | [To be supplied.]
ReadOnly | [To be supplied.]

See Also

DocumentEditor Class | System.Data.XML Namespace


DocumentEditor.ChildCount

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property ChildCount As Integer
[C#]
public int ChildCount {virtual get;}
[C++]
public: __property virtual int get_ChildCount();
[JScript]
public function get ChildCount() : int;

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.DataTypeName

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DataTypeName As String
[C#]
public string DataTypeName {virtual get;}
[C++]
public: __property virtual String* get_DataTypeName();
[JScript]
public function get DataTypeName() : String;

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.DataTypeNamespace

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DataTypeNamespace As String
[C#]
public string DataTypeNamespace {virtual get;}
[C++]
public: __property virtual String* get_DataTypeNamespace();
[JScript]
public function get DataTypeNamespace() : String;

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.Empty

[To be supplied.]

[Visual Basic]
Overridable Public Property Empty As Boolean
[C#]
public bool Empty {virtual get; virtual set;}
[C++]
public: __property virtual bool get_Empty();
public: __property virtual void set_Empty(bool);
[JScript]
public function get Empty() : Boolean;
public function set Empty(Boolean);

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.FieldCount

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property FieldCount As Integer
[C#]
public int FieldCount {virtual get;}
[C++]
public: __property virtual int get_FieldCount();
[JScript]
public function get FieldCount() : int;

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.HasChildren

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property HasChildren As Boolean
[C#]
public bool HasChildren {virtual get;}
[C++]
public: __property virtual bool get_HasChildren();
[JScript]
public function get HasChildren() : Boolean;

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.HasValue

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property HasValue As Boolean
[C#]
public bool HasValue {virtual get;}
[C++]
public: __property virtual bool get_HasValue();
[JScript]
public function get HasValue() : Boolean;

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.IndexInParent

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IndexInParent As Integer
[C#]
public int IndexInParent {virtual get;}
[C++]
public: __property virtual int get_IndexInParent();
[JScript]
public function get IndexInParent() : int;

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the DocumentEditor class.

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Default Property Item(String) As Object
[C#] public object this[String] {virtual get; virtual set;}
[C++] public: __property virtual Object* get_Item(String*);
public: __property virtual void set_Item(String*, Object*);
[JScript] DocumentEditor.Item (String)

[To be supplied.]

[Visual Basic] Overloads Overridable Public Default Property Item(String, String) As Object
[C#] public object this[String, String] {virtual get; virtual set;}
[C++] public: __property virtual Object* get_Item(String*, String*);
public: __property virtual void set_Item(String*, String*, Object*);
[JScript] DocumentEditor.Item (String, String)

[To be supplied.]

[Visual Basic] Overloads Overridable Public Default Property Item(Integer) As Object
[C#] public object this[int] {virtual get; virtual set;}
[C++] public: __property virtual Object* get_Item(int);
public: __property virtual void set_Item(int, Object*);
[JScript] DocumentEditor.Item (int)

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.Item (String)

[To be supplied.]

[C#] In C#, this member is the indexer for the DocumentEditor class.

[Visual Basic]
Overloads Overridable Public Default Property Item( _
   ByVal name As String _
) As Object
[C#]
public object this[
   string name
] {virtual get; virtual set;}
[C++]
public: __property virtual Object* get_Item(
   String* name
);
public: __property virtual void set_Item(
   String* name,
   Object*
);
[JScript]
returnValue = DocumentEditorObject.Item(name);
DocumentEditorObject.Item(name) = returnValue;
-or-
returnValue = DocumentEditorObject(name);
DocumentEditorObject(name) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
[To be supplied.]

Parameters [Visual Basic, C#, C++]

name
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace | DocumentEditor.Item Overload List


DocumentEditor.Item (String, String)

[To be supplied.]

[C#] In C#, this member is the indexer for the DocumentEditor class.

[Visual Basic]
Overloads Overridable Public Default Property Item( _
   ByVal name As String, _
   ByVal uri As String _
) As Object
[C#]
public object this[
   string name,
   string uri
] {virtual get; virtual set;}
[C++]
public: __property virtual Object* get_Item(
   String* name,
   String* uri
);
public: __property virtual void set_Item(
   String* name,
   String* uri,
   Object*
);
[JScript]
returnValue = DocumentEditorObject.Item(name, uri);
DocumentEditorObject.Item(name, uri) = returnValue;
-or-
returnValue = DocumentEditorObject(name, uri);
DocumentEditorObject(name, uri) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
[To be supplied.]
uri
[To be supplied.]

Parameters [Visual Basic, C#, C++]

name
[To be supplied.]
uri
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace | DocumentEditor.Item Overload List


DocumentEditor.Item (Int32)

[To be supplied.]

[C#] In C#, this member is the indexer for the DocumentEditor class.

[Visual Basic]
Overloads Overridable Public Default Property Item( _
   ByVal i As Integer _
) As Object
[C#]
public object this[
   int i
] {virtual get; virtual set;}
[C++]
public: __property virtual Object* get_Item(
   int i
);
public: __property virtual void set_Item(
   int i,
   Object*
);
[JScript]
returnValue = DocumentEditorObject.Item(i);
DocumentEditorObject.Item(i) = returnValue;
-or-
returnValue = DocumentEditorObject(i);
DocumentEditorObject(i) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

i
[To be supplied.]

Parameters [Visual Basic, C#, C++]

i
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace | DocumentEditor.Item Overload List


DocumentEditor.LoadState

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property LoadState As Integer
[C#]
public int LoadState {virtual get;}
[C++]
public: __property virtual int get_LoadState();
[JScript]
public function get LoadState() : int;

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.Name

[To be supplied.]

[Visual Basic]
Overridable Public Property Name As String
[C#]
public string Name {virtual get; virtual set;}
[C++]
public: __property virtual String* get_Name();
public: __property virtual void set_Name(String*);
[JScript]
public function get Name() : String;
public function set Name(String);

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.Namespace

[To be supplied.]

[Visual Basic]
Overridable Public Property Namespace As String
[C#]
public string Namespace {virtual get; virtual set;}
[C++]
public: __property virtual String* get_Namespace();
public: __property virtual void set_Namespace(String*);
[JScript]
public function get Namespace() : String;
public function set Namespace(String);

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.NameTable

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property NameTable As INameTable
[C#]
public INameTable NameTable {virtual get;}
[C++]
public: __property virtual INameTable* get_NameTable();
[JScript]
public function get NameTable() : INameTable;

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.NodeType

[To be supplied.]

[Visual Basic]
Overridable Public Property NodeType As XmlNodeType
[C#]
public XmlNodeType NodeType {virtual get; virtual set;}
[C++]
public: __property virtual XmlNodeType get_NodeType();
public: __property virtual void set_NodeType(XmlNodeType);
[JScript]
public function get NodeType() : XmlNodeType;
public function set NodeType(XmlNodeType);

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.Prefix

[To be supplied.]

[Visual Basic]
Overridable Public Property Prefix As String
[C#]
public string Prefix {virtual get; virtual set;}
[C++]
public: __property virtual String* get_Prefix();
public: __property virtual void set_Prefix(String*);
[JScript]
public function get Prefix() : String;
public function set Prefix(String);

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.ReadOnly

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property ReadOnly As Boolean
[C#]
public bool ReadOnly {virtual get;}
[C++]
public: __property virtual bool get_ReadOnly();
[JScript]
public function get ReadOnly() : Boolean;

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DocumentEditor Methods

The methods of the DocumentEditor class are listed below. For a complete list of DocumentEditor class members, see the DocumentEditor Members topic.

Public:

Clear | [To be supplied.]
Clone | [To be supplied.]
CompareOrder | [To be supplied.]
Compile | [To be supplied.]
CopyChildren | [To be supplied.]
CopySelected | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Evaluate | Overloaded. [To be supplied.]
GetBoolean | [To be supplied.]
GetByte | [To be supplied.]
GetBytes | [To be supplied.]
GetChar | [To be supplied.]
GetChars | [To be supplied.]
GetCurrency | [To be supplied.]
GetData | [To be supplied.]
GetDataTypeName | [To be supplied.]
GetDataTypeNamespace | [To be supplied.]
GetDateTime | [To be supplied.]
GetDecimal | [To be supplied.]
GetDouble | [To be supplied.]
GetEnumerator | [To be supplied.]
GetFieldType | [To be supplied.]
GetFloat | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInt16 | [To be supplied.]
GetInt32 | [To be supplied.]
GetInt64 | [To be supplied.]
GetName | [To be supplied.]
GetNamespace | [To be supplied.]
GetOrdinal | Overloaded. [To be supplied.]
GetPrefix | [To be supplied.]
GetRaw | [To be supplied.]
GetStream | [To be supplied.]
GetString | [To be supplied.]
GetTimeSpan | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | [To be supplied.]
GetValues | [To be supplied.]
Insert | Overloaded. [To be supplied.]
IsNull | [To be supplied.]
IsSame | [To be supplied.]
Matches | Overloaded. [To be supplied.]
Move | [To be supplied.]
MoveChildren | [To be supplied.]
MoveFirst | [To be supplied.]
MoveFirstSelected | [To be supplied.]
MoveLast | [To be supplied.]
MoveLastSelected | [To be supplied.]
MoveNext | [To be supplied.]
MoveNextSelected | [To be supplied.]
MovePrevious | [To be supplied.]
MovePreviousSelected | [To be supplied.]
MoveSelected | [To be supplied.]
MoveTo | [To be supplied.]
MoveToChild | [To be supplied.]
MoveToField | [To be supplied.]
MoveToFirstChild | [To be supplied.]
MoveToId | [To be supplied.]
MoveToLastChild | [To be supplied.]
MoveToNull | [To be supplied.]
MoveToParent | [To be supplied.]
MoveToRoot | [To be supplied.]
PopPosition | [To be supplied.]
PushPosition | [To be supplied.]
Remove | Overloaded. [To be supplied.]
RemoveSelected | [To be supplied.]
Select | Overloaded. [To be supplied.]
SetBoolean | [To be supplied.]
SetByte | [To be supplied.]
SetBytes | [To be supplied.]
SetChar | [To be supplied.]
SetChars | [To be supplied.]
SetCurrency | [To be supplied.]
SetData | [To be supplied.]
SetDateTime | [To be supplied.]
SetDecimal | [To be supplied.]
SetDouble | [To be supplied.]
SetFloat | [To be supplied.]
SetInt16 | [To be supplied.]
SetInt32 | [To be supplied.]
SetInt64 | [To be supplied.]
SetName | [To be supplied.]
SetNamespace | [To be supplied.]
SetNull | [To be supplied.]
SetPrefix | [To be supplied.]
SetRaw | [To be supplied.]
SetStream | [To be supplied.]
SetString | [To be supplied.]
SetTimeSpan | [To be supplied.]
SetValue | [To be supplied.]
SetValues | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DocumentEditor Class | System.Data.XML Namespace


DocumentEditor.Clear

[To be supplied.]

[Visual Basic]
Overridable Public Sub Clear()
[C#]
public virtual void Clear();
[C++]
public: virtual void Clear();
[JScript]
public function Clear();

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.Clone

[To be supplied.]

[Visual Basic]
Overridable Public Function Clone() As IDataNavigator
[C#]
public virtual IDataNavigator Clone();
[C++]
public: virtual IDataNavigator* Clone();
[JScript]
public function Clone() : IDataNavigator;

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.CompareOrder

[To be supplied.]

[Visual Basic]
Overridable Public Function CompareOrder( _
   ByVal r As IDataNavigator _
) As Integer
[C#]
public virtual int CompareOrder(
   IDataNavigator r
);
[C++]
public: virtual int CompareOrder(
   IDataNavigator* r
);
[JScript]
public function CompareOrder(
   r : IDataNavigator
) : int;

Parameters

r
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.Compile

[To be supplied.]

[Visual Basic]
Overridable Public Function Compile( _
   ByVal xpathexpr As String _
) As Object
[C#]
public virtual object Compile(
   string xpathexpr
);
[C++]
public: virtual Object* Compile(
   String* xpathexpr
);
[JScript]
public function Compile(
   xpathexpr : String
) : Object;

Parameters

xpathexpr
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.CopyChildren

[To be supplied.]

[Visual Basic]
Overridable Public Sub CopyChildren( _
   ByVal pos As TreePosition, _
   ByVal other As IDataNavigator _
)
[C#]
public virtual void CopyChildren(
   TreePosition pos,
   IDataNavigator other
);
[C++]
public: virtual void CopyChildren(
   TreePosition pos,
   IDataNavigator* other
);
[JScript]
public function CopyChildren(
   pos : TreePosition,
   other : IDataNavigator
);

Parameters

pos
[To be supplied.]
other
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.CopySelected

[To be supplied.]

[Visual Basic]
Overridable Public Sub CopySelected( _
   ByVal pos As TreePosition, _
   ByVal other As IDataNavigator _
)
[C#]
public virtual void CopySelected(
   TreePosition pos,
   IDataNavigator other
);
[C++]
public: virtual void CopySelected(
   TreePosition pos,
   IDataNavigator* other
);
[JScript]
public function CopySelected(
   pos : TreePosition,
   other : IDataNavigator
);

Parameters

pos
[To be supplied.]
other
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.Evaluate

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Evaluate(Object) As Object
[C#] public virtual object Evaluate(Object);
[C++] public: virtual Object* Evaluate(Object*);
[JScript] public function Evaluate(Object) : Object;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Evaluate(String) As Object
[C#] public virtual object Evaluate(String);
[C++] public: virtual Object* Evaluate(String*);
[JScript] public function Evaluate(String) : Object;

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.Evaluate (Object)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Evaluate( _
   ByVal xpathexpr As Object _
) As Object
[C#]
public virtual object Evaluate(
   object xpathexpr
);
[C++]
public: virtual Object* Evaluate(
   Object* xpathexpr
);
[JScript]
public function Evaluate(
   xpathexpr : Object
) : Object;

Parameters

xpathexpr
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace | DocumentEditor.Evaluate Overload List


DocumentEditor.Evaluate (String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Evaluate( _
   ByVal xpathexpr As String _
) As Object
[C#]
public virtual object Evaluate(
   string xpathexpr
);
[C++]
public: virtual Object* Evaluate(
   String* xpathexpr
);
[JScript]
public function Evaluate(
   xpathexpr : String
) : Object;

Parameters

xpathexpr
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace | DocumentEditor.Evaluate Overload List


DocumentEditor.Finalize

[To be supplied.]

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.GetBoolean

[To be supplied.]

[Visual Basic]
Overridable Public Function GetBoolean( _
   ByVal i As Integer _
) As Boolean
[C#]
public virtual bool GetBoolean(
   int i
);
[C++]
public: virtual bool GetBoolean(
   int i
);
[JScript]
public function GetBoolean(
   i : int
) : Boolean;

Parameters

i
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.GetByte

[To be supplied.]

[Visual Basic]
Overridable Public Function GetByte( _
   ByVal i As Integer _
) As Byte
[C#]
public virtual byte GetByte(
   int i
);
[C++]
public: virtual unsigned char GetByte(
   int i
);
[JScript]
public function GetByte(
   i : int
) : Byte;

Parameters

i
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.GetBytes

[To be supplied.]

[Visual Basic]
Overridable Public Function GetBytes( _
   ByVal i As Integer, _
   ByVal buff() As Byte, _
   ByVal len As Integer, _
   ByVal buffOff As Integer, _
   ByVal fldOff As Integer _
) As Integer
[C#]
public virtual int GetBytes(
   int i,
   byte[] buff,
   int len,
   int buffOff,
   int fldOff
);
[C++]
public: virtual int GetBytes(
   int i,
   unsigned char* buff[],
   int len,
   int buffOff,
   int fldOff
);
[JScript]
public function GetBytes(
   i : int,
   buff : Byte[],
   len : int,
   buffOff : int,
   fldOff : int
) : int;

Parameters

i
[To be supplied.]
buff
[To be supplied.]
len
[To be supplied.]
buffOff
[To be supplied.]
fldOff
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.GetChar

[To be supplied.]

[Visual Basic]
Overridable Public Function GetChar( _
   ByVal i As Integer _
) As Char
[C#]
public virtual char GetChar(
   int i
);
[C++]
public: virtual __wchar_t GetChar(
   int i
);
[JScript]
public function GetChar(
   i : int
) : Char;

Parameters

i
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.GetChars

[To be supplied.]

[Visual Basic]
Overridable Public Function GetChars( _
   ByVal i As Integer, _
   ByVal buff() As Char, _
   ByVal len As Integer, _
   ByVal buffOff As Integer, _
   ByVal fldOff As Integer _
) As Integer
[C#]
public virtual int GetChars(
   int i,
   char[] buff,
   int len,
   int buffOff,
   int fldOff
);
[C++]
public: virtual int GetChars(
   int i,
   __wchar_t* buff[],
   int len,
   int buffOff,
   int fldOff
);
[JScript]
public function GetChars(
   i : int,
   buff : Char[],
   len : int,
   buffOff : int,
   fldOff : int
) : int;

Parameters

i
[To be supplied.]
buff
[To be supplied.]
len
[To be supplied.]
buffOff
[To be supplied.]
fldOff
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.GetCurrency

[To be supplied.]

[Visual Basic]
Overridable Public Function GetCurrency( _
   ByVal i As Integer _
) As Currency
[C#]
public virtual Currency GetCurrency(
   int i
);
[C++]
public: virtual Currency GetCurrency(
   int i
);
[JScript]
public function GetCurrency(
   i : int
) : Currency;

Parameters

i
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.GetData

[To be supplied.]

[Visual Basic]
Overridable Public Function GetData( _
   ByVal i As Integer _
) As IDataReader
[C#]
public virtual IDataReader GetData(
   int i
);
[C++]
public: virtual IDataReader* GetData(
   int i
);
[JScript]
public function GetData(
   i : int
) : IDataReader;

Parameters

i
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.GetDataTypeName

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDataTypeName( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetDataTypeName(
   int i
);
[C++]
public: virtual String* GetDataTypeName(
   int i
);
[JScript]
public function GetDataTypeName(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.GetDataTypeNamespace

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDataTypeNamespace( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetDataTypeNamespace(
   int i
);
[C++]
public: virtual String* GetDataTypeNamespace(
   int i
);
[JScript]
public function GetDataTypeNamespace(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.GetDateTime

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDateTime( _
   ByVal i As Integer _
) As DateTime
[C#]
public virtual DateTime GetDateTime(
   int i
);
[C++]
public: virtual DateTime GetDateTime(
   int i
);
[JScript]
public function GetDateTime(
   i : int
) : DateTime;

Parameters

i
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.GetDecimal

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDecimal( _
   ByVal i As Integer _
) As Decimal
[C#]
public virtual Decimal GetDecimal(
   int i
);
[C++]
public: virtual Decimal GetDecimal(
   int i
);
[JScript]
public function GetDecimal(
   i : int
) : Decimal;

Parameters

i
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.GetDouble

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDouble( _
   ByVal i As Integer _
) As Double
[C#]
public virtual double GetDouble(
   int i
);
[C++]
public: virtual double GetDouble(
   int i
);
[JScript]
public function GetDouble(
   i : int
) : double;

Parameters

i
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.GetEnumerator

[To be supplied.]

[Visual Basic]
Overridable Public Function GetEnumerator() As IEnumerator
[C#]
public virtual IEnumerator GetEnumerator();
[C++]
public: virtual IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.GetFieldType

[To be supplied.]

[Visual Basic]
Overridable Public Function GetFieldType( _
   ByVal i As Integer _
) As Type
[C#]
public virtual Type GetFieldType(
   int i
);
[C++]
public: virtual Type* GetFieldType(
   int i
);
[JScript]
public function GetFieldType(
   i : int
) : Type;

Parameters

i
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.GetFloat

[To be supplied.]

[Visual Basic]
Overridable Public Function GetFloat( _
   ByVal i As Integer _
) As Single
[C#]
public virtual float GetFloat(
   int i
);
[C++]
public: virtual float GetFloat(
   int i
);
[JScript]
public function GetFloat(
   i : int
) : float;

Parameters

i
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.GetInt16

[To be supplied.]

[Visual Basic]
Overridable Public Function GetInt16( _
   ByVal i As Integer _
) As Short
[C#]
public virtual short GetInt16(
   int i
);
[C++]
public: virtual short GetInt16(
   int i
);
[JScript]
public function GetInt16(
   i : int
) : Int16;

Parameters

i
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.GetInt32

[To be supplied.]

[Visual Basic]
Overridable Public Function GetInt32( _
   ByVal i As Integer _
) As Integer
[C#]
public virtual int GetInt32(
   int i
);
[C++]
public: virtual int GetInt32(
   int i
);
[JScript]
public function GetInt32(
   i : int
) : int;

Parameters

i
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.GetInt64

[To be supplied.]

[Visual Basic]
Overridable Public Function GetInt64( _
   ByVal i As Integer _
) As Long
[C#]
public virtual long GetInt64(
   int i
);
[C++]
public: virtual __int64 GetInt64(
   int i
);
[JScript]
public function GetInt64(
   i : int
) : long;

Parameters

i
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.GetName

[To be supplied.]

[Visual Basic]
Overridable Public Function GetName( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetName(
   int i
);
[C++]
public: virtual String* GetName(
   int i
);
[JScript]
public function GetName(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.GetNamespace

[To be supplied.]

[Visual Basic]
Overridable Public Function GetNamespace( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetNamespace(
   int i
);
[C++]
public: virtual String* GetNamespace(
   int i
);
[JScript]
public function GetNamespace(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.GetOrdinal

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function GetOrdinal(String) As Integer
[C#] public virtual int GetOrdinal(String);
[C++] public: virtual int GetOrdinal(String*);
[JScript] public function GetOrdinal(String) : int;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function GetOrdinal(String, String) As Integer
[C#] public virtual int GetOrdinal(String, String);
[C++] public: virtual int GetOrdinal(String*, String*);
[JScript] public function GetOrdinal(String, String) : int;

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.GetOrdinal (String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function GetOrdinal( _
   ByVal name As String _
) As Integer
[C#]
public virtual int GetOrdinal(
   string name
);
[C++]
public: virtual int GetOrdinal(
   String* name
);
[JScript]
public function GetOrdinal(
   name : String
) : int;

Parameters

name
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace | DocumentEditor.GetOrdinal Overload List


DocumentEditor.GetOrdinal (String, String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function GetOrdinal( _
   ByVal name As String, _
   ByVal uri As String _
) As Integer
[C#]
public virtual int GetOrdinal(
   string name,
   string uri
);
[C++]
public: virtual int GetOrdinal(
   String* name,
   String* uri
);
[JScript]
public function GetOrdinal(
   name : String,
   uri : String
) : int;

Parameters

name
[To be supplied.]
uri
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace | DocumentEditor.GetOrdinal Overload List


DocumentEditor.GetPrefix

[To be supplied.]

[Visual Basic]
Overridable Public Function GetPrefix( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetPrefix(
   int i
);
[C++]
public: virtual String* GetPrefix(
   int i
);
[JScript]
public function GetPrefix(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.GetRaw

[To be supplied.]

[Visual Basic]
Overridable Public Function GetRaw( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetRaw(
   int i
);
[C++]
public: virtual String* GetRaw(
   int i
);
[JScript]
public function GetRaw(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.GetStream

[To be supplied.]

[Visual Basic]
Overridable Public Function GetStream( _
   ByVal i As Integer _
) As Stream
[C#]
public virtual Stream GetStream(
   int i
);
[C++]
public: virtual Stream* GetStream(
   int i
);
[JScript]
public function GetStream(
   i : int
) : Stream;

Parameters

i
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.GetString

[To be supplied.]

[Visual Basic]
Overridable Public Function GetString( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetString(
   int i
);
[C++]
public: virtual String* GetString(
   int i
);
[JScript]
public function GetString(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.GetTimeSpan

[To be supplied.]

[Visual Basic]
Overridable Public Function GetTimeSpan( _
   ByVal i As Integer _
) As TimeSpan
[C#]
public virtual TimeSpan GetTimeSpan(
   int i
);
[C++]
public: virtual TimeSpan GetTimeSpan(
   int i
);
[JScript]
public function GetTimeSpan(
   i : int
) : TimeSpan;

Parameters

i
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.GetValue

[To be supplied.]

[Visual Basic]
Overridable Public Sub GetValue( _
   ByVal i As Integer, _
   ByRef value As Object _
)
[C#]
public virtual void GetValue(
   int i,
   ref object value
);
[C++]
public: virtual void GetValue(
   int i,
   Object** value
);
[JScript]
public function GetValue(
   i : int,
   value : Object
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.GetValues

[To be supplied.]

[Visual Basic]
Overridable Public Function GetValues( _
   ByVal values() As Object _
) As Integer
[C#]
public virtual int GetValues(
   object[] values
);
[C++]
public: virtual int GetValues(
   Object* values[]
);
[JScript]
public function GetValues(
   values : Object[]
) : int;

Parameters

values
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.Insert

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Sub Insert(TreePosition, XmlNodeType, String, String, String)
[C#] public virtual void Insert(TreePosition, XmlNodeType, String, String, String);
[C++] public: virtual void Insert(TreePosition, XmlNodeType, String, String, String);
[JScript] public function Insert(TreePosition, XmlNodeType, String, String, String);

[To be supplied.]

[Visual Basic] Overloads Overridable Public Sub Insert(TreePosition, Object, Type)
[C#] public virtual void Insert(TreePosition, Object, Type);
[C++] public: virtual void Insert(TreePosition, Object, Type);
[JScript] public function Insert(TreePosition, Object, Type);

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.Insert (TreePosition, XmlNodeType, String, String, String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Sub Insert( _
   ByVal pos As TreePosition, _
   ByVal nodeType As XmlNodeType, _
   ByVal name As String, _
   ByVal uri As String, _
   ByVal prefix As String _
)
[C#]
public virtual void Insert(
   TreePosition pos,
   XmlNodeType nodeType,
   string name,
   string uri,
   string prefix
);
[C++]
public: virtual void Insert(
   TreePosition pos,
   XmlNodeType nodeType,
   String* name,
   String* uri,
   String* prefix
);
[JScript]
public function Insert(
   pos : TreePosition,
   nodeType : XmlNodeType,
   name : String,
   uri : String,
   prefix : String
);

Parameters

pos
[To be supplied.]
nodeType
[To be supplied.]
name
[To be supplied.]
uri
[To be supplied.]
prefix
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace | DocumentEditor.Insert Overload List


DocumentEditor.Insert (TreePosition, Object, Type)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Sub Insert( _
   ByVal pos As TreePosition, _
   ByVal obj As Object, _
   ByVal type As Type _
)
[C#]
public virtual void Insert(
   TreePosition pos,
   object obj,
   Type type
);
[C++]
public: virtual void Insert(
   TreePosition pos,
   Object* obj,
   Type* type
);
[JScript]
public function Insert(
   pos : TreePosition,
   obj : Object,
   type : Type
);

Parameters

pos
[To be supplied.]
obj
[To be supplied.]
type
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace | DocumentEditor.Insert Overload List


DocumentEditor.IsNull

[To be supplied.]

[Visual Basic]
Overridable Public Function IsNull( _
   ByVal i As Integer _
) As Boolean
[C#]
public virtual bool IsNull(
   int i
);
[C++]
public: virtual bool IsNull(
   int i
);
[JScript]
public function IsNull(
   i : int
) : Boolean;

Parameters

i
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.IsSame

[To be supplied.]

[Visual Basic]
Overridable Public Function IsSame( _
   ByVal pos As IDataNavigator _
) As Boolean
[C#]
public virtual bool IsSame(
   IDataNavigator pos
);
[C++]
public: virtual bool IsSame(
   IDataNavigator* pos
);
[JScript]
public function IsSame(
   pos : IDataNavigator
) : Boolean;

Parameters

pos
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.Matches

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Matches(String) As Boolean
[C#] public virtual bool Matches(String);
[C++] public: virtual bool Matches(String*);
[JScript] public function Matches(String) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Matches(Object) As Boolean
[C#] public virtual bool Matches(Object);
[C++] public: virtual bool Matches(Object*);
[JScript] public function Matches(Object) : Boolean;

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.Matches (String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Matches( _
   ByVal xpathexpr As String _
) As Boolean
[C#]
public virtual bool Matches(
   string xpathexpr
);
[C++]
public: virtual bool Matches(
   String* xpathexpr
);
[JScript]
public function Matches(
   xpathexpr : String
) : Boolean;

Parameters

xpathexpr
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace | DocumentEditor.Matches Overload List


DocumentEditor.Matches (Object)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Matches( _
   ByVal xpathexpr As Object _
) As Boolean
[C#]
public virtual bool Matches(
   object xpathexpr
);
[C++]
public: virtual bool Matches(
   Object* xpathexpr
);
[JScript]
public function Matches(
   xpathexpr : Object
) : Boolean;

Parameters

xpathexpr
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace | DocumentEditor.Matches Overload List


DocumentEditor.Move

[To be supplied.]

[Visual Basic]
Overridable Public Sub Move( _
   ByVal pos As TreePosition, _
   ByVal other As IDataEditor _
)
[C#]
public virtual void Move(
   TreePosition pos,
   IDataEditor other
);
[C++]
public: virtual void Move(
   TreePosition pos,
   IDataEditor* other
);
[JScript]
public function Move(
   pos : TreePosition,
   other : IDataEditor
);

Parameters

pos
[To be supplied.]
other
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.MoveChildren

[To be supplied.]

[Visual Basic]
Overridable Public Sub MoveChildren( _
   ByVal pos As TreePosition, _
   ByVal other As IDataEditor _
)
[C#]
public virtual void MoveChildren(
   TreePosition pos,
   IDataEditor other
);
[C++]
public: virtual void MoveChildren(
   TreePosition pos,
   IDataEditor* other
);
[JScript]
public function MoveChildren(
   pos : TreePosition,
   other : IDataEditor
);

Parameters

pos
[To be supplied.]
other
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.MoveFirst

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveFirst() As Boolean
[C#]
public virtual bool MoveFirst();
[C++]
public: virtual bool MoveFirst();
[JScript]
public function MoveFirst() : Boolean;

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.MoveFirstSelected

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveFirstSelected() As Boolean
[C#]
public virtual bool MoveFirstSelected();
[C++]
public: virtual bool MoveFirstSelected();
[JScript]
public function MoveFirstSelected() : Boolean;

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.MoveLast

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveLast() As Boolean
[C#]
public virtual bool MoveLast();
[C++]
public: virtual bool MoveLast();
[JScript]
public function MoveLast() : Boolean;

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.MoveLastSelected

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveLastSelected() As Boolean
[C#]
public virtual bool MoveLastSelected();
[C++]
public: virtual bool MoveLastSelected();
[JScript]
public function MoveLastSelected() : Boolean;

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.MoveNext

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.MoveNextSelected

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveNextSelected() As Boolean
[C#]
public virtual bool MoveNextSelected();
[C++]
public: virtual bool MoveNextSelected();
[JScript]
public function MoveNextSelected() : Boolean;

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.MovePrevious

[To be supplied.]

[Visual Basic]
Overridable Public Function MovePrevious() As Boolean
[C#]
public virtual bool MovePrevious();
[C++]
public: virtual bool MovePrevious();
[JScript]
public function MovePrevious() : Boolean;

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.MovePreviousSelected

[To be supplied.]

[Visual Basic]
Overridable Public Function MovePreviousSelected() As Boolean
[C#]
public virtual bool MovePreviousSelected();
[C++]
public: virtual bool MovePreviousSelected();
[JScript]
public function MovePreviousSelected() : Boolean;

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.MoveSelected

[To be supplied.]

[Visual Basic]
Overridable Public Sub MoveSelected( _
   ByVal pos As TreePosition, _
   ByVal other As IDataEditor _
)
[C#]
public virtual void MoveSelected(
   TreePosition pos,
   IDataEditor other
);
[C++]
public: virtual void MoveSelected(
   TreePosition pos,
   IDataEditor* other
);
[JScript]
public function MoveSelected(
   pos : TreePosition,
   other : IDataEditor
);

Parameters

pos
[To be supplied.]
other
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.MoveTo

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveTo( _
   ByVal pos As IDataNavigator _
) As Boolean
[C#]
public virtual bool MoveTo(
   IDataNavigator pos
);
[C++]
public: virtual bool MoveTo(
   IDataNavigator* pos
);
[JScript]
public function MoveTo(
   pos : IDataNavigator
) : Boolean;

Parameters

pos
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.MoveToChild

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveToChild( _
   ByVal i As Integer _
) As Boolean
[C#]
public virtual bool MoveToChild(
   int i
);
[C++]
public: virtual bool MoveToChild(
   int i
);
[JScript]
public function MoveToChild(
   i : int
) : Boolean;

Parameters

i
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.MoveToField

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveToField( _
   ByVal i As Integer _
) As Boolean
[C#]
public virtual bool MoveToField(
   int i
);
[C++]
public: virtual bool MoveToField(
   int i
);
[JScript]
public function MoveToField(
   i : int
) : Boolean;

Parameters

i
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.MoveToFirstChild

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveToFirstChild() As Boolean
[C#]
public virtual bool MoveToFirstChild();
[C++]
public: virtual bool MoveToFirstChild();
[JScript]
public function MoveToFirstChild() : Boolean;

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.MoveToId

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveToId( _
   ByVal id As String _
) As Boolean
[C#]
public virtual bool MoveToId(
   string id
);
[C++]
public: virtual bool MoveToId(
   String* id
);
[JScript]
public function MoveToId(
   id : String
) : Boolean;

Parameters

id
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.MoveToLastChild

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveToLastChild() As Boolean
[C#]
public virtual bool MoveToLastChild();
[C++]
public: virtual bool MoveToLastChild();
[JScript]
public function MoveToLastChild() : Boolean;

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.MoveToNull

[To be supplied.]

[Visual Basic]
Overridable Public Sub MoveToNull()
[C#]
public virtual void MoveToNull();
[C++]
public: virtual void MoveToNull();
[JScript]
public function MoveToNull();

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.MoveToParent

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveToParent() As Boolean
[C#]
public virtual bool MoveToParent();
[C++]
public: virtual bool MoveToParent();
[JScript]
public function MoveToParent() : Boolean;

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.MoveToRoot

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveToRoot() As Boolean
[C#]
public virtual bool MoveToRoot();
[C++]
public: virtual bool MoveToRoot();
[JScript]
public function MoveToRoot() : Boolean;

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.PopPosition

[To be supplied.]

[Visual Basic]
Overridable Public Function PopPosition() As Boolean
[C#]
public virtual bool PopPosition();
[C++]
public: virtual bool PopPosition();
[JScript]
public function PopPosition() : Boolean;

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.PushPosition

[To be supplied.]

[Visual Basic]
Overridable Public Sub PushPosition()
[C#]
public virtual void PushPosition();
[C++]
public: virtual void PushPosition();
[JScript]
public function PushPosition();

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.Remove

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Sub Remove(TreePosition)
[C#] public virtual void Remove(TreePosition);
[C++] public: virtual void Remove(TreePosition);
[JScript] public function Remove(TreePosition);

[To be supplied.]

[Visual Basic] Overloads Overridable Public Sub Remove()
[C#] public virtual void Remove();
[C++] public: virtual void Remove();
[JScript] public function Remove();

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.Remove (TreePosition)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Sub Remove( _
   ByVal pos As TreePosition _
)
[C#]
public virtual void Remove(
   TreePosition pos
);
[C++]
public: virtual void Remove(
   TreePosition pos
);
[JScript]
public function Remove(
   pos : TreePosition
);

Parameters

pos
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace | DocumentEditor.Remove Overload List


DocumentEditor.Remove ()

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Sub Remove()
[C#]
public virtual void Remove();
[C++]
public: virtual void Remove();
[JScript]
public function Remove();

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace | DocumentEditor.Remove Overload List


DocumentEditor.RemoveSelected

[To be supplied.]

[Visual Basic]
Overridable Public Sub RemoveSelected()
[C#]
public virtual void RemoveSelected();
[C++]
public: virtual void RemoveSelected();
[JScript]
public function RemoveSelected();

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.Select

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Sub Select(Object)
[C#] public virtual void Select(Object);
[C++] public: virtual void Select(Object*);
[JScript] public function Select(Object);

[To be supplied.]

[Visual Basic] Overloads Overridable Public Sub Select(String)
[C#] public virtual void Select(String);
[C++] public: virtual void Select(String*);
[JScript] public function Select(String);

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.Select (Object)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Sub Select( _
   ByVal xpathexpr As Object _
)
[C#]
public virtual void Select(
   object xpathexpr
);
[C++]
public: virtual void Select(
   Object* xpathexpr
);
[JScript]
public function Select(
   xpathexpr : Object
);

Parameters

xpathexpr
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace | DocumentEditor.Select Overload List


DocumentEditor.Select (String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Sub Select( _
   ByVal xpathexpr As String _
)
[C#]
public virtual void Select(
   string xpathexpr
);
[C++]
public: virtual void Select(
   String* xpathexpr
);
[JScript]
public function Select(
   xpathexpr : String
);

Parameters

xpathexpr
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace | DocumentEditor.Select Overload List


DocumentEditor.SetBoolean

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetBoolean( _
   ByVal i As Integer, _
   ByVal value As Boolean _
)
[C#]
public virtual void SetBoolean(
   int i,
   bool value
);
[C++]
public: virtual void SetBoolean(
   int i,
   bool value
);
[JScript]
public function SetBoolean(
   i : int,
   value : Boolean
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.SetByte

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetByte( _
   ByVal i As Integer, _
   ByVal value As Byte _
)
[C#]
public virtual void SetByte(
   int i,
   byte value
);
[C++]
public: virtual void SetByte(
   int i,
   unsigned char value
);
[JScript]
public function SetByte(
   i : int,
   value : Byte
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.SetBytes

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetBytes( _
   ByVal i As Integer, _
   ByVal buff() As Byte, _
   ByVal len As Integer, _
   ByVal buffOff As Integer, _
   ByVal fldOff As Integer _
)
[C#]
public virtual void SetBytes(
   int i,
   byte[] buff,
   int len,
   int buffOff,
   int fldOff
);
[C++]
public: virtual void SetBytes(
   int i,
   unsigned char* buff[],
   int len,
   int buffOff,
   int fldOff
);
[JScript]
public function SetBytes(
   i : int,
   buff : Byte[],
   len : int,
   buffOff : int,
   fldOff : int
);

Parameters

i
[To be supplied.]
buff
[To be supplied.]
len
[To be supplied.]
buffOff
[To be supplied.]
fldOff
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.SetChar

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetChar( _
   ByVal i As Integer, _
   ByVal value As Char _
)
[C#]
public virtual void SetChar(
   int i,
   char value
);
[C++]
public: virtual void SetChar(
   int i,
   __wchar_t value
);
[JScript]
public function SetChar(
   i : int,
   value : Char
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.SetChars

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetChars( _
   ByVal i As Integer, _
   ByVal buff() As Char, _
   ByVal len As Integer, _
   ByVal buffOff As Integer, _
   ByVal fldOff As Integer _
)
[C#]
public virtual void SetChars(
   int i,
   char[] buff,
   int len,
   int buffOff,
   int fldOff
);
[C++]
public: virtual void SetChars(
   int i,
   __wchar_t* buff[],
   int len,
   int buffOff,
   int fldOff
);
[JScript]
public function SetChars(
   i : int,
   buff : Char[],
   len : int,
   buffOff : int,
   fldOff : int
);

Parameters

i
[To be supplied.]
buff
[To be supplied.]
len
[To be supplied.]
buffOff
[To be supplied.]
fldOff
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.SetCurrency

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetCurrency( _
   ByVal i As Integer, _
   ByVal value As Currency _
)
[C#]
public virtual void SetCurrency(
   int i,
   Currency value
);
[C++]
public: virtual void SetCurrency(
   int i,
   Currency value
);
[JScript]
public function SetCurrency(
   i : int,
   value : Currency
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.SetData

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetData( _
   ByVal i As Integer, _
   ByVal reader As IDataReader _
)
[C#]
public virtual void SetData(
   int i,
   IDataReader reader
);
[C++]
public: virtual void SetData(
   int i,
   IDataReader* reader
);
[JScript]
public function SetData(
   i : int,
   reader : IDataReader
);

Parameters

i
[To be supplied.]
reader
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.SetDateTime

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetDateTime( _
   ByVal i As Integer, _
   ByVal value As DateTime _
)
[C#]
public virtual void SetDateTime(
   int i,
   DateTime value
);
[C++]
public: virtual void SetDateTime(
   int i,
   DateTime value
);
[JScript]
public function SetDateTime(
   i : int,
   value : DateTime
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.SetDecimal

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetDecimal( _
   ByVal i As Integer, _
   ByVal value As Decimal _
)
[C#]
public virtual void SetDecimal(
   int i,
   Decimal value
);
[C++]
public: virtual void SetDecimal(
   int i,
   Decimal value
);
[JScript]
public function SetDecimal(
   i : int,
   value : Decimal
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.SetDouble

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetDouble( _
   ByVal i As Integer, _
   ByVal value As Double _
)
[C#]
public virtual void SetDouble(
   int i,
   double value
);
[C++]
public: virtual void SetDouble(
   int i,
   double value
);
[JScript]
public function SetDouble(
   i : int,
   value : double
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.SetFloat

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetFloat( _
   ByVal i As Integer, _
   ByVal value As Single _
)
[C#]
public virtual void SetFloat(
   int i,
   float value
);
[C++]
public: virtual void SetFloat(
   int i,
   float value
);
[JScript]
public function SetFloat(
   i : int,
   value : float
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.SetInt16

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetInt16( _
   ByVal i As Integer, _
   ByVal value As Short _
)
[C#]
public virtual void SetInt16(
   int i,
   short value
);
[C++]
public: virtual void SetInt16(
   int i,
   short value
);
[JScript]
public function SetInt16(
   i : int,
   value : Int16
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.SetInt32

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetInt32( _
   ByVal i As Integer, _
   ByVal value As Integer _
)
[C#]
public virtual void SetInt32(
   int i,
   int value
);
[C++]
public: virtual void SetInt32(
   int i,
   int value
);
[JScript]
public function SetInt32(
   i : int,
   value : int
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.SetInt64

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetInt64( _
   ByVal i As Integer, _
   ByVal value As Long _
)
[C#]
public virtual void SetInt64(
   int i,
   long value
);
[C++]
public: virtual void SetInt64(
   int i,
   __int64 value
);
[JScript]
public function SetInt64(
   i : int,
   value : long
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.SetName

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetName( _
   ByVal i As Integer, _
   ByVal value As String _
)
[C#]
public virtual void SetName(
   int i,
   string value
);
[C++]
public: virtual void SetName(
   int i,
   String* value
);
[JScript]
public function SetName(
   i : int,
   value : String
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.SetNamespace

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetNamespace( _
   ByVal i As Integer, _
   ByVal value As String _
)
[C#]
public virtual void SetNamespace(
   int i,
   string value
);
[C++]
public: virtual void SetNamespace(
   int i,
   String* value
);
[JScript]
public function SetNamespace(
   i : int,
   value : String
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.SetNull

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetNull( _
   ByVal i As Integer _
)
[C#]
public virtual void SetNull(
   int i
);
[C++]
public: virtual void SetNull(
   int i
);
[JScript]
public function SetNull(
   i : int
);

Parameters

i
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.SetPrefix

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetPrefix( _
   ByVal i As Integer, _
   ByVal value As String _
)
[C#]
public virtual void SetPrefix(
   int i,
   string value
);
[C++]
public: virtual void SetPrefix(
   int i,
   String* value
);
[JScript]
public function SetPrefix(
   i : int,
   value : String
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.SetRaw

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetRaw( _
   ByVal i As Integer, _
   ByVal raw As String _
)
[C#]
public virtual void SetRaw(
   int i,
   string raw
);
[C++]
public: virtual void SetRaw(
   int i,
   String* raw
);
[JScript]
public function SetRaw(
   i : int,
   raw : String
);

Parameters

i
[To be supplied.]
raw
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.SetStream

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetStream( _
   ByVal i As Integer, _
   ByVal stream As Stream _
)
[C#]
public virtual void SetStream(
   int i,
   Stream stream
);
[C++]
public: virtual void SetStream(
   int i,
   Stream* stream
);
[JScript]
public function SetStream(
   i : int,
   stream : Stream
);

Parameters

i
[To be supplied.]
stream
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.SetString

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetString( _
   ByVal i As Integer, _
   ByVal value As String _
)
[C#]
public virtual void SetString(
   int i,
   string value
);
[C++]
public: virtual void SetString(
   int i,
   String* value
);
[JScript]
public function SetString(
   i : int,
   value : String
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.SetTimeSpan

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetTimeSpan( _
   ByVal i As Integer, _
   ByVal value As TimeSpan _
)
[C#]
public virtual void SetTimeSpan(
   int i,
   TimeSpan value
);
[C++]
public: virtual void SetTimeSpan(
   int i,
   TimeSpan value
);
[JScript]
public function SetTimeSpan(
   i : int,
   value : TimeSpan
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.SetValue

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetValue( _
   ByVal i As Integer, _
   ByVal value As Object _
)
[C#]
public virtual void SetValue(
   int i,
   object value
);
[C++]
public: virtual void SetValue(
   int i,
   Object* value
);
[JScript]
public function SetValue(
   i : int,
   value : Object
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentEditor.SetValues

[To be supplied.]

[Visual Basic]
Overridable Public Function SetValues( _
   ByVal values() As Object _
) As Integer
[C#]
public virtual int SetValues(
   object[] values
);
[C++]
public: virtual int SetValues(
   Object* values[]
);
[JScript]
public function SetValues(
   values : Object[]
) : int;

Parameters

values
[To be supplied.]

See Also

DocumentEditor Class | DocumentEditor Members | System.Data.XML Namespace


DocumentNavigator Class

[To be supplied.]

Object
DocumentNavigator

[Visual Basic]
NotInheritable Public Class DocumentNavigator
   Implements IDataNavigator, IDataRecord, INameTable
[C#]
public sealed class DocumentNavigator : IDataNavigator,
   IDataRecord, INameTable
[C++]
public __gc __sealed class DocumentNavigator : public
   IDataNavigator, IDataRecord, INameTable
[JScript]
public class DocumentNavigator implements IDataNavigator,
   IDataRecord, INameTable

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator Members

Public:

Constructor

DocumentNavigator Constructor Overloaded. [To be supplied.]

Properties

ChildCount | [To be supplied.]
DataTypeName | [To be supplied.]
DataTypeNamespace | [To be supplied.]
Empty | [To be supplied.]
FieldCount | [To be supplied.]
HasChildren | [To be supplied.]
HasValue | [To be supplied.]
IndexInParent | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the DocumentNavigator class.
LoadState | [To be supplied.]
Name | [To be supplied.]
Namespace | [To be supplied.]
NameTable | [To be supplied.]
NodeType | [To be supplied.]
Prefix | [To be supplied.]
ReadOnly | [To be supplied.]
Selection | [To be supplied.]

Methods

Add | Overloaded. [To be supplied.]
Clone | [To be supplied.]
CompareOrder | [To be supplied.]
Compile | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Evaluate | Overloaded. [To be supplied.]
Get | Overloaded. [To be supplied.]
GetBoolean | [To be supplied.]
GetByte | [To be supplied.]
GetBytes | [To be supplied.]
GetChar | [To be supplied.]
GetChars | [To be supplied.]
GetCurrency | [To be supplied.]
GetData | [To be supplied.]
GetDataTypeName | [To be supplied.]
GetDataTypeNamespace | [To be supplied.]
GetDateTime | [To be supplied.]
GetDecimal | [To be supplied.]
GetDouble | [To be supplied.]
GetEnumerator | [To be supplied.]
GetFieldType | [To be supplied.]
GetFloat | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInt16 | [To be supplied.]
GetInt32 | [To be supplied.]
GetInt64 | [To be supplied.]
GetName | [To be supplied.]
GetNamespace | [To be supplied.]
GetOrdinal | Overloaded. [To be supplied.]
GetPrefix | [To be supplied.]
GetRaw | [To be supplied.]
GetStream | [To be supplied.]
GetString | [To be supplied.]
GetTimeSpan | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | [To be supplied.]
GetValues | [To be supplied.]
IsNull | [To be supplied.]
IsSame | Overloaded. [To be supplied.]
Matches | Overloaded. [To be supplied.]
MoveFirst | [To be supplied.]
MoveFirstSelected | [To be supplied.]
MoveLast | [To be supplied.]
MoveLastSelected | [To be supplied.]
MoveNext | [To be supplied.]
MoveNextSelected | [To be supplied.]
MovePrevious | [To be supplied.]
MovePreviousSelected | [To be supplied.]
MoveTo | Overloaded. [To be supplied.]
MoveToChild | [To be supplied.]
MoveToField | [To be supplied.]
MoveToFirstChild | [To be supplied.]
MoveToId | [To be supplied.]
MoveToLastChild | [To be supplied.]
MoveToNull | [To be supplied.]
MoveToParent | [To be supplied.]
MoveToRoot | [To be supplied.]
PopPosition | [To be supplied.]
PushPosition | [To be supplied.]
ResetSelection | [To be supplied.]
Select | Overloaded. [To be supplied.]
SelectIds | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DocumentNavigator Class | System.Data.XML Namespace


DocumentNavigator Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(XmlDocument)
[C#] public DocumentNavigator(XmlDocument);
[C++] public: DocumentNavigator(XmlDocument*);
[JScript] public function DocumentNavigator(XmlDocument);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(DataSet)
[C#] public DocumentNavigator(DataSet);
[C++] public: DocumentNavigator(DataSet*);
[JScript] public function DocumentNavigator(DataSet);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(DataRow)
[C#] public DocumentNavigator(DataRow);
[C++] public: DocumentNavigator(DataRow*);
[JScript] public function DocumentNavigator(DataRow);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(INode)
[C#] public DocumentNavigator(INode);
[C++] public: DocumentNavigator(INode*);
[JScript] public function DocumentNavigator(INode);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(DocumentNavigator)
[C#] public DocumentNavigator(DocumentNavigator);
[C++] public: DocumentNavigator(DocumentNavigator*);
[JScript] public function DocumentNavigator(DocumentNavigator);

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator Constructor (XmlDocument)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal doc As XmlDocument _
)
[C#]
public DocumentNavigator(
   XmlDocument doc
);
[C++]
public: DocumentNavigator(
   XmlDocument* doc
);
[JScript]
public function DocumentNavigator(
   doc : XmlDocument
);

Parameters

doc
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace | DocumentNavigator Constructor Overload List


DocumentNavigator Constructor (DataSet)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal ds As DataSet _
)
[C#]
public DocumentNavigator(
   DataSet ds
);
[C++]
public: DocumentNavigator(
   DataSet* ds
);
[JScript]
public function DocumentNavigator(
   ds : DataSet
);

Parameters

ds
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace | DocumentNavigator Constructor Overload List


DocumentNavigator Constructor (DataRow)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal row As DataRow _
)
[C#]
public DocumentNavigator(
   DataRow row
);
[C++]
public: DocumentNavigator(
   DataRow* row
);
[JScript]
public function DocumentNavigator(
   row : DataRow
);

Parameters

row
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace | DocumentNavigator Constructor Overload List


DocumentNavigator Constructor (INode)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal node As INode _
)
[C#]
public DocumentNavigator(
   INode node
);
[C++]
public: DocumentNavigator(
   INode* node
);
[JScript]
public function DocumentNavigator(
   node : INode
);

Parameters

node
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace | DocumentNavigator Constructor Overload List


DocumentNavigator Constructor (DocumentNavigator)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal that As DocumentNavigator _
)
[C#]
public DocumentNavigator(
   DocumentNavigator that
);
[C++]
public: DocumentNavigator(
   DocumentNavigator* that
);
[JScript]
public function DocumentNavigator(
   that : DocumentNavigator
);

Parameters

that
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace | DocumentNavigator Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DocumentNavigator Properties

The properties of the DocumentNavigator class are listed below. For a complete list of DocumentNavigator class members, see the DocumentNavigator Members topic.

Public:

ChildCount | [To be supplied.]
DataTypeName | [To be supplied.]
DataTypeNamespace | [To be supplied.]
Empty | [To be supplied.]
FieldCount | [To be supplied.]
HasChildren | [To be supplied.]
HasValue | [To be supplied.]
IndexInParent | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the DocumentNavigator class.
LoadState | [To be supplied.]
Name | [To be supplied.]
Namespace | [To be supplied.]
NameTable | [To be supplied.]
NodeType | [To be supplied.]
Prefix | [To be supplied.]
ReadOnly | [To be supplied.]
Selection | [To be supplied.]

See Also

DocumentNavigator Class | System.Data.XML Namespace


DocumentNavigator.ChildCount

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property ChildCount As Integer
[C#]
public int ChildCount {virtual get;}
[C++]
public: __property virtual int get_ChildCount();
[JScript]
public function get ChildCount() : int;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.DataTypeName

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DataTypeName As String
[C#]
public string DataTypeName {virtual get;}
[C++]
public: __property virtual String* get_DataTypeName();
[JScript]
public function get DataTypeName() : String;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.DataTypeNamespace

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DataTypeNamespace As String
[C#]
public string DataTypeNamespace {virtual get;}
[C++]
public: __property virtual String* get_DataTypeNamespace();
[JScript]
public function get DataTypeNamespace() : String;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.Empty

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Empty As Boolean
[C#]
public bool Empty {virtual get;}
[C++]
public: __property virtual bool get_Empty();
[JScript]
public function get Empty() : Boolean;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.FieldCount

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property FieldCount As Integer
[C#]
public int FieldCount {virtual get;}
[C++]
public: __property virtual int get_FieldCount();
[JScript]
public function get FieldCount() : int;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.HasChildren

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property HasChildren As Boolean
[C#]
public bool HasChildren {virtual get;}
[C++]
public: __property virtual bool get_HasChildren();
[JScript]
public function get HasChildren() : Boolean;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.HasValue

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property HasValue As Boolean
[C#]
public bool HasValue {virtual get;}
[C++]
public: __property virtual bool get_HasValue();
[JScript]
public function get HasValue() : Boolean;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.IndexInParent

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IndexInParent As Integer
[C#]
public int IndexInParent {virtual get;}
[C++]
public: __property virtual int get_IndexInParent();
[JScript]
public function get IndexInParent() : int;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the DocumentNavigator class.

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(String, String) As Object
[C#] public object this[String, String] {virtual get;}
[C++] public: __property virtual Object* get_Item(String*, String*);
[JScript] DocumentNavigator.Item (String, String)

[To be supplied.]

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(String) As Object
[C#] public object this[String] {virtual get;}
[C++] public: __property virtual Object* get_Item(String*);
[JScript] DocumentNavigator.Item (String)

[To be supplied.]

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(Integer) As Object
[C#] public object this[int] {virtual get;}
[C++] public: __property virtual Object* get_Item(int);
[JScript] DocumentNavigator.Item (int)

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.Item (String, String)

[To be supplied.]

[C#] In C#, this member is the indexer for the DocumentNavigator class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal name As String, _
   ByVal namespaceURI As String _
) As Object
[C#]
public object this[
   string name,
   string namespaceURI
] {virtual get;}
[C++]
public: __property virtual Object* get_Item(
   String* name,
   String* namespaceURI
);
[JScript]
returnValue = DocumentNavigatorObject.Item(name, namespaceURI);
-or-
returnValue = DocumentNavigatorObject(name, namespaceURI);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
[To be supplied.]
namespaceURI
[To be supplied.]

Parameters [Visual Basic, C#, C++]

name
[To be supplied.]
namespaceURI
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace | DocumentNavigator.Item Overload List


DocumentNavigator.Item (String)

[To be supplied.]

[C#] In C#, this member is the indexer for the DocumentNavigator class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal name As String _
) As Object
[C#]
public object this[
   string name
] {virtual get;}
[C++]
public: __property virtual Object* get_Item(
   String* name
);
[JScript]
returnValue = DocumentNavigatorObject.Item(name);
-or-
returnValue = DocumentNavigatorObject(name);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
[To be supplied.]

Parameters [Visual Basic, C#, C++]

name
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace | DocumentNavigator.Item Overload List


DocumentNavigator.Item (Int32)

[To be supplied.]

[C#] In C#, this member is the indexer for the DocumentNavigator class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal i As Integer _
) As Object
[C#]
public object this[
   int i
] {virtual get;}
[C++]
public: __property virtual Object* get_Item(
   int i
);
[JScript]
returnValue = DocumentNavigatorObject.Item(i);
-or-
returnValue = DocumentNavigatorObject(i);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

i
[To be supplied.]

Parameters [Visual Basic, C#, C++]

i
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace | DocumentNavigator.Item Overload List


DocumentNavigator.LoadState

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property LoadState As Integer
[C#]
public int LoadState {virtual get;}
[C++]
public: __property virtual int get_LoadState();
[JScript]
public function get LoadState() : int;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.Name

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {virtual get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.Namespace

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Namespace As String
[C#]
public string Namespace {virtual get;}
[C++]
public: __property virtual String* get_Namespace();
[JScript]
public function get Namespace() : String;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.NameTable

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property NameTable As INameTable
[C#]
public INameTable NameTable {virtual get;}
[C++]
public: __property virtual INameTable* get_NameTable();
[JScript]
public function get NameTable() : INameTable;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.NodeType

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property NodeType As XmlNodeType
[C#]
public XmlNodeType NodeType {virtual get;}
[C++]
public: __property virtual XmlNodeType get_NodeType();
[JScript]
public function get NodeType() : XmlNodeType;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.Prefix

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Prefix As String
[C#]
public string Prefix {virtual get;}
[C++]
public: __property virtual String* get_Prefix();
[JScript]
public function get Prefix() : String;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.ReadOnly

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property ReadOnly As Boolean
[C#]
public bool ReadOnly {virtual get;}
[C++]
public: __property virtual bool get_ReadOnly();
[JScript]
public function get ReadOnly() : Boolean;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.Selection

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Selection As String
[C#]
public string Selection {get;}
[C++]
public: __property String* get_Selection();
[JScript]
public function get Selection() : String;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DocumentNavigator Methods

The methods of the DocumentNavigator class are listed below. For a complete list of DocumentNavigator class members, see the DocumentNavigator Members topic.

Public:

Add | Overloaded. [To be supplied.]
Clone | [To be supplied.]
CompareOrder | [To be supplied.]
Compile | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Evaluate | Overloaded. [To be supplied.]
Get | Overloaded. [To be supplied.]
GetBoolean | [To be supplied.]
GetByte | [To be supplied.]
GetBytes | [To be supplied.]
GetChar | [To be supplied.]
GetChars | [To be supplied.]
GetCurrency | [To be supplied.]
GetData | [To be supplied.]
GetDataTypeName | [To be supplied.]
GetDataTypeNamespace | [To be supplied.]
GetDateTime | [To be supplied.]
GetDecimal | [To be supplied.]
GetDouble | [To be supplied.]
GetEnumerator | [To be supplied.]
GetFieldType | [To be supplied.]
GetFloat | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInt16 | [To be supplied.]
GetInt32 | [To be supplied.]
GetInt64 | [To be supplied.]
GetName | [To be supplied.]
GetNamespace | [To be supplied.]
GetOrdinal | Overloaded. [To be supplied.]
GetPrefix | [To be supplied.]
GetRaw | [To be supplied.]
GetStream | [To be supplied.]
GetString | [To be supplied.]
GetTimeSpan | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | [To be supplied.]
GetValues | [To be supplied.]
IsNull | [To be supplied.]
IsSame | Overloaded. [To be supplied.]
Matches | Overloaded. [To be supplied.]
MoveFirst | [To be supplied.]
MoveFirstSelected | [To be supplied.]
MoveLast | [To be supplied.]
MoveLastSelected | [To be supplied.]
MoveNext | [To be supplied.]
MoveNextSelected | [To be supplied.]
MovePrevious | [To be supplied.]
MovePreviousSelected | [To be supplied.]
MoveTo | Overloaded. [To be supplied.]
MoveToChild | [To be supplied.]
MoveToField | [To be supplied.]
MoveToFirstChild | [To be supplied.]
MoveToId | [To be supplied.]
MoveToLastChild | [To be supplied.]
MoveToNull | [To be supplied.]
MoveToParent | [To be supplied.]
MoveToRoot | [To be supplied.]
PopPosition | [To be supplied.]
PushPosition | [To be supplied.]
ResetSelection | [To be supplied.]
Select | Overloaded. [To be supplied.]
SelectIds | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DocumentNavigator Class | System.Data.XML Namespace


DocumentNavigator.Add

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Add(Char(), Integer, Integer) As String
[C#] public virtual string Add(char[], int, int);
[C++] public: virtual String* Add(__wchar_t*[], int, int);
[JScript] public function Add(Char[], int, int) : String;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Add(String) As String
[C#] public virtual string Add(String);
[C++] public: virtual String* Add(String*);
[JScript] public function Add(String) : String;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.Add (Char[], Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Add( _
   ByVal array() As Char, _
   ByVal offset As Integer, _
   ByVal length As Integer _
) As String
[C#]
public virtual string Add(
   char[] array,
   int offset,
   int length
);
[C++]
public: virtual String* Add(
   __wchar_t* array[],
   int offset,
   int length
);
[JScript]
public function Add(
   array : Char[],
   offset : int,
   length : int
) : String;

Parameters

array
[To be supplied.]
offset
[To be supplied.]
length
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace | DocumentNavigator.Add Overload List


DocumentNavigator.Add (String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Add( _
   ByVal str As String _
) As String
[C#]
public virtual string Add(
   string str
);
[C++]
public: virtual String* Add(
   String* str
);
[JScript]
public function Add(
   str : String
) : String;

Parameters

str
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace | DocumentNavigator.Add Overload List


DocumentNavigator.Clone

[To be supplied.]

[Visual Basic]
Overridable Public Function Clone() As IDataNavigator
[C#]
public virtual IDataNavigator Clone();
[C++]
public: virtual IDataNavigator* Clone();
[JScript]
public function Clone() : IDataNavigator;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.CompareOrder

[To be supplied.]

[Visual Basic]
Overridable Public Function CompareOrder( _
   ByVal rightoperand As IDataNavigator _
) As Integer
[C#]
public virtual int CompareOrder(
   IDataNavigator rightoperand
);
[C++]
public: virtual int CompareOrder(
   IDataNavigator* rightoperand
);
[JScript]
public function CompareOrder(
   rightoperand : IDataNavigator
) : int;

Parameters

rightoperand
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.Compile

[To be supplied.]

[Visual Basic]
Overridable Public Function Compile( _
   ByVal xpathexpr As String _
) As Object
[C#]
public virtual object Compile(
   string xpathexpr
);
[C++]
public: virtual Object* Compile(
   String* xpathexpr
);
[JScript]
public function Compile(
   xpathexpr : String
) : Object;

Parameters

xpathexpr
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.Evaluate

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Evaluate(Object) As Object
[C#] public virtual object Evaluate(Object);
[C++] public: virtual Object* Evaluate(Object*);
[JScript] public function Evaluate(Object) : Object;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Evaluate(String) As Object
[C#] public virtual object Evaluate(String);
[C++] public: virtual Object* Evaluate(String*);
[JScript] public function Evaluate(String) : Object;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.Evaluate (Object)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Evaluate( _
   ByVal xpathexpr As Object _
) As Object
[C#]
public virtual object Evaluate(
   object xpathexpr
);
[C++]
public: virtual Object* Evaluate(
   Object* xpathexpr
);
[JScript]
public function Evaluate(
   xpathexpr : Object
) : Object;

Parameters

xpathexpr
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace | DocumentNavigator.Evaluate Overload List


DocumentNavigator.Evaluate (String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Evaluate( _
   ByVal xpathexpr As String _
) As Object
[C#]
public virtual object Evaluate(
   string xpathexpr
);
[C++]
public: virtual Object* Evaluate(
   String* xpathexpr
);
[JScript]
public function Evaluate(
   xpathexpr : String
) : Object;

Parameters

xpathexpr
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace | DocumentNavigator.Evaluate Overload List


DocumentNavigator.Finalize

[To be supplied.]

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.Get

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Get(Char(), Integer, Integer) As String
[C#] public virtual string Get(char[], int, int);
[C++] public: virtual String* Get(__wchar_t*[], int, int);
[JScript] public function Get(Char[], int, int) : String;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Get(String) As String
[C#] public virtual string Get(String);
[C++] public: virtual String* Get(String*);
[JScript] public function Get(String) : String;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.Get (Char[], Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Get( _
   ByVal array() As Char, _
   ByVal offset As Integer, _
   ByVal length As Integer _
) As String
[C#]
public virtual string Get(
   char[] array,
   int offset,
   int length
);
[C++]
public: virtual String* Get(
   __wchar_t* array[],
   int offset,
   int length
);
[JScript]
public function Get(
   array : Char[],
   offset : int,
   length : int
) : String;

Parameters

array
[To be supplied.]
offset
[To be supplied.]
length
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace | DocumentNavigator.Get Overload List


DocumentNavigator.Get (String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Get( _
   ByVal str As String _
) As String
[C#]
public virtual string Get(
   string str
);
[C++]
public: virtual String* Get(
   String* str
);
[JScript]
public function Get(
   str : String
) : String;

Parameters

str
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace | DocumentNavigator.Get Overload List


DocumentNavigator.GetBoolean

[To be supplied.]

[Visual Basic]
Overridable Public Function GetBoolean( _
   ByVal i As Integer _
) As Boolean
[C#]
public virtual bool GetBoolean(
   int i
);
[C++]
public: virtual bool GetBoolean(
   int i
);
[JScript]
public function GetBoolean(
   i : int
) : Boolean;

Parameters

i
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.GetByte

[To be supplied.]

[Visual Basic]
Overridable Public Function GetByte( _
   ByVal i As Integer _
) As Byte
[C#]
public virtual byte GetByte(
   int i
);
[C++]
public: virtual unsigned char GetByte(
   int i
);
[JScript]
public function GetByte(
   i : int
) : Byte;

Parameters

i
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.GetBytes

[To be supplied.]

[Visual Basic]
Overridable Public Function GetBytes( _
   ByVal i As Integer, _
   ByVal buffer() As Byte, _
   ByVal length As Integer, _
   ByVal bufferoffset As Integer, _
   ByVal fieldoffset As Integer _
) As Integer
[C#]
public virtual int GetBytes(
   int i,
   byte[] buffer,
   int length,
   int bufferoffset,
   int fieldoffset
);
[C++]
public: virtual int GetBytes(
   int i,
   unsigned char* buffer[],
   int length,
   int bufferoffset,
   int fieldoffset
);
[JScript]
public function GetBytes(
   i : int,
   buffer : Byte[],
   length : int,
   bufferoffset : int,
   fieldoffset : int
) : int;

Parameters

i
[To be supplied.]
buffer
[To be supplied.]
length
[To be supplied.]
bufferoffset
[To be supplied.]
fieldoffset
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.GetChar

[To be supplied.]

[Visual Basic]
Overridable Public Function GetChar( _
   ByVal i As Integer _
) As Char
[C#]
public virtual char GetChar(
   int i
);
[C++]
public: virtual __wchar_t GetChar(
   int i
);
[JScript]
public function GetChar(
   i : int
) : Char;

Parameters

i
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.GetChars

[To be supplied.]

[Visual Basic]
Overridable Public Function GetChars( _
   ByVal i As Integer, _
   ByVal buffer() As Char, _
   ByVal length As Integer, _
   ByVal bufferOffset As Integer, _
   ByVal fieldOffset As Integer _
) As Integer
[C#]
public virtual int GetChars(
   int i,
   char[] buffer,
   int length,
   int bufferOffset,
   int fieldOffset
);
[C++]
public: virtual int GetChars(
   int i,
   __wchar_t* buffer[],
   int length,
   int bufferOffset,
   int fieldOffset
);
[JScript]
public function GetChars(
   i : int,
   buffer : Char[],
   length : int,
   bufferOffset : int,
   fieldOffset : int
) : int;

Parameters

i
[To be supplied.]
buffer
[To be supplied.]
length
[To be supplied.]
bufferOffset
[To be supplied.]
fieldOffset
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.GetCurrency

[To be supplied.]

[Visual Basic]
Overridable Public Function GetCurrency( _
   ByVal i As Integer _
) As Currency
[C#]
public virtual Currency GetCurrency(
   int i
);
[C++]
public: virtual Currency GetCurrency(
   int i
);
[JScript]
public function GetCurrency(
   i : int
) : Currency;

Parameters

i
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.GetData

[To be supplied.]

[Visual Basic]
Overridable Public Function GetData( _
   ByVal i As Integer _
) As IDataReader
[C#]
public virtual IDataReader GetData(
   int i
);
[C++]
public: virtual IDataReader* GetData(
   int i
);
[JScript]
public function GetData(
   i : int
) : IDataReader;

Parameters

i
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.GetDataTypeName

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDataTypeName( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetDataTypeName(
   int i
);
[C++]
public: virtual String* GetDataTypeName(
   int i
);
[JScript]
public function GetDataTypeName(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.GetDataTypeNamespace

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDataTypeNamespace( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetDataTypeNamespace(
   int i
);
[C++]
public: virtual String* GetDataTypeNamespace(
   int i
);
[JScript]
public function GetDataTypeNamespace(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.GetDateTime

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDateTime( _
   ByVal i As Integer _
) As DateTime
[C#]
public virtual DateTime GetDateTime(
   int i
);
[C++]
public: virtual DateTime GetDateTime(
   int i
);
[JScript]
public function GetDateTime(
   i : int
) : DateTime;

Parameters

i
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.GetDecimal

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDecimal( _
   ByVal i As Integer _
) As Decimal
[C#]
public virtual Decimal GetDecimal(
   int i
);
[C++]
public: virtual Decimal GetDecimal(
   int i
);
[JScript]
public function GetDecimal(
   i : int
) : Decimal;

Parameters

i
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.GetDouble

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDouble( _
   ByVal i As Integer _
) As Double
[C#]
public virtual double GetDouble(
   int i
);
[C++]
public: virtual double GetDouble(
   int i
);
[JScript]
public function GetDouble(
   i : int
) : double;

Parameters

i
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.GetEnumerator

[To be supplied.]

[Visual Basic]
Overridable Public Function GetEnumerator() As IEnumerator
[C#]
public virtual IEnumerator GetEnumerator();
[C++]
public: virtual IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.GetFieldType

[To be supplied.]

[Visual Basic]
Overridable Public Function GetFieldType( _
   ByVal i As Integer _
) As Type
[C#]
public virtual Type GetFieldType(
   int i
);
[C++]
public: virtual Type* GetFieldType(
   int i
);
[JScript]
public function GetFieldType(
   i : int
) : Type;

Parameters

i
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.GetFloat

[To be supplied.]

[Visual Basic]
Overridable Public Function GetFloat( _
   ByVal i As Integer _
) As Single
[C#]
public virtual float GetFloat(
   int i
);
[C++]
public: virtual float GetFloat(
   int i
);
[JScript]
public function GetFloat(
   i : int
) : float;

Parameters

i
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.GetInt16

[To be supplied.]

[Visual Basic]
Overridable Public Function GetInt16( _
   ByVal i As Integer _
) As Short
[C#]
public virtual short GetInt16(
   int i
);
[C++]
public: virtual short GetInt16(
   int i
);
[JScript]
public function GetInt16(
   i : int
) : Int16;

Parameters

i
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.GetInt32

[To be supplied.]

[Visual Basic]
Overridable Public Function GetInt32( _
   ByVal i As Integer _
) As Integer
[C#]
public virtual int GetInt32(
   int i
);
[C++]
public: virtual int GetInt32(
   int i
);
[JScript]
public function GetInt32(
   i : int
) : int;

Parameters

i
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.GetInt64

[To be supplied.]

[Visual Basic]
Overridable Public Function GetInt64( _
   ByVal i As Integer _
) As Long
[C#]
public virtual long GetInt64(
   int i
);
[C++]
public: virtual __int64 GetInt64(
   int i
);
[JScript]
public function GetInt64(
   i : int
) : long;

Parameters

i
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.GetName

[To be supplied.]

[Visual Basic]
Overridable Public Function GetName( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetName(
   int i
);
[C++]
public: virtual String* GetName(
   int i
);
[JScript]
public function GetName(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.GetNamespace

[To be supplied.]

[Visual Basic]
Overridable Public Function GetNamespace( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetNamespace(
   int i
);
[C++]
public: virtual String* GetNamespace(
   int i
);
[JScript]
public function GetNamespace(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.GetOrdinal

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function GetOrdinal(String, String) As Integer
[C#] public virtual int GetOrdinal(String, String);
[C++] public: virtual int GetOrdinal(String*, String*);
[JScript] public function GetOrdinal(String, String) : int;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function GetOrdinal(String) As Integer
[C#] public virtual int GetOrdinal(String);
[C++] public: virtual int GetOrdinal(String*);
[JScript] public function GetOrdinal(String) : int;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.GetOrdinal (String, String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function GetOrdinal( _
   ByVal name As String, _
   ByVal namespaceURI As String _
) As Integer
[C#]
public virtual int GetOrdinal(
   string name,
   string namespaceURI
);
[C++]
public: virtual int GetOrdinal(
   String* name,
   String* namespaceURI
);
[JScript]
public function GetOrdinal(
   name : String,
   namespaceURI : String
) : int;

Parameters

name
[To be supplied.]
namespaceURI
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace | DocumentNavigator.GetOrdinal Overload List


DocumentNavigator.GetOrdinal (String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function GetOrdinal( _
   ByVal name As String _
) As Integer
[C#]
public virtual int GetOrdinal(
   string name
);
[C++]
public: virtual int GetOrdinal(
   String* name
);
[JScript]
public function GetOrdinal(
   name : String
) : int;

Parameters

name
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace | DocumentNavigator.GetOrdinal Overload List


DocumentNavigator.GetPrefix

[To be supplied.]

[Visual Basic]
Overridable Public Function GetPrefix( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetPrefix(
   int i
);
[C++]
public: virtual String* GetPrefix(
   int i
);
[JScript]
public function GetPrefix(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.GetRaw

[To be supplied.]

[Visual Basic]
Overridable Public Function GetRaw( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetRaw(
   int i
);
[C++]
public: virtual String* GetRaw(
   int i
);
[JScript]
public function GetRaw(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.GetStream

[To be supplied.]

[Visual Basic]
Overridable Public Function GetStream( _
   ByVal i As Integer _
) As Stream
[C#]
public virtual Stream GetStream(
   int i
);
[C++]
public: virtual Stream* GetStream(
   int i
);
[JScript]
public function GetStream(
   i : int
) : Stream;

Parameters

i
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.GetString

[To be supplied.]

[Visual Basic]
Overridable Public Function GetString( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetString(
   int i
);
[C++]
public: virtual String* GetString(
   int i
);
[JScript]
public function GetString(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.GetTimeSpan

[To be supplied.]

[Visual Basic]
Overridable Public Function GetTimeSpan( _
   ByVal i As Integer _
) As TimeSpan
[C#]
public virtual TimeSpan GetTimeSpan(
   int i
);
[C++]
public: virtual TimeSpan GetTimeSpan(
   int i
);
[JScript]
public function GetTimeSpan(
   i : int
) : TimeSpan;

Parameters

i
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.GetValue

[To be supplied.]

[Visual Basic]
Overridable Public Sub GetValue( _
   ByVal i As Integer, _
   ByRef value As Object _
)
[C#]
public virtual void GetValue(
   int i,
   ref object value
);
[C++]
public: virtual void GetValue(
   int i,
   Object** value
);
[JScript]
public function GetValue(
   i : int,
   value : Object
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.GetValues

[To be supplied.]

[Visual Basic]
Overridable Public Function GetValues( _
   ByVal values() As Object _
) As Integer
[C#]
public virtual int GetValues(
   object[] values
);
[C++]
public: virtual int GetValues(
   Object* values[]
);
[JScript]
public function GetValues(
   values : Object[]
) : int;

Parameters

values
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.IsNull

[To be supplied.]

[Visual Basic]
Overridable Public Function IsNull( _
   ByVal i As Integer _
) As Boolean
[C#]
public virtual bool IsNull(
   int i
);
[C++]
public: virtual bool IsNull(
   int i
);
[JScript]
public function IsNull(
   i : int
) : Boolean;

Parameters

i
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.IsSame

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function IsSame(DataRow) As Boolean
[C#] public bool IsSame(DataRow);
[C++] public: bool IsSame(DataRow*);
[JScript] public function IsSame(DataRow) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsSame(INode) As Boolean
[C#] public bool IsSame(INode);
[C++] public: bool IsSame(INode*);
[JScript] public function IsSame(INode) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function IsSame(IDataNavigator) As Boolean
[C#] public virtual bool IsSame(IDataNavigator);
[C++] public: virtual bool IsSame(IDataNavigator*);
[JScript] public function IsSame(IDataNavigator) : Boolean;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.IsSame (DataRow)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsSame( _
   ByVal row As DataRow _
) As Boolean
[C#]
public bool IsSame(
   DataRow row
);
[C++]
public: bool IsSame(
   DataRow* row
);
[JScript]
public function IsSame(
   row : DataRow
) : Boolean;

Parameters

row
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace | DocumentNavigator.IsSame Overload List


DocumentNavigator.IsSame (INode)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsSame( _
   ByVal node As INode _
) As Boolean
[C#]
public bool IsSame(
   INode node
);
[C++]
public: bool IsSame(
   INode* node
);
[JScript]
public function IsSame(
   node : INode
) : Boolean;

Parameters

node
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace | DocumentNavigator.IsSame Overload List


DocumentNavigator.IsSame (IDataNavigator)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function IsSame( _
   ByVal other As IDataNavigator _
) As Boolean
[C#]
public virtual bool IsSame(
   IDataNavigator other
);
[C++]
public: virtual bool IsSame(
   IDataNavigator* other
);
[JScript]
public function IsSame(
   other : IDataNavigator
) : Boolean;

Parameters

other
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace | DocumentNavigator.IsSame Overload List


DocumentNavigator.Matches

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Matches(String) As Boolean
[C#] public virtual bool Matches(String);
[C++] public: virtual bool Matches(String*);
[JScript] public function Matches(String) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Matches(Object) As Boolean
[C#] public virtual bool Matches(Object);
[C++] public: virtual bool Matches(Object*);
[JScript] public function Matches(Object) : Boolean;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.Matches (String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Matches( _
   ByVal xpathexpr As String _
) As Boolean
[C#]
public virtual bool Matches(
   string xpathexpr
);
[C++]
public: virtual bool Matches(
   String* xpathexpr
);
[JScript]
public function Matches(
   xpathexpr : String
) : Boolean;

Parameters

xpathexpr
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace | DocumentNavigator.Matches Overload List


DocumentNavigator.Matches (Object)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Matches( _
   ByVal xpathexpr As Object _
) As Boolean
[C#]
public virtual bool Matches(
   object xpathexpr
);
[C++]
public: virtual bool Matches(
   Object* xpathexpr
);
[JScript]
public function Matches(
   xpathexpr : Object
) : Boolean;

Parameters

xpathexpr
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace | DocumentNavigator.Matches Overload List


DocumentNavigator.MoveFirst

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveFirst() As Boolean
[C#]
public virtual bool MoveFirst();
[C++]
public: virtual bool MoveFirst();
[JScript]
public function MoveFirst() : Boolean;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.MoveFirstSelected

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveFirstSelected() As Boolean
[C#]
public virtual bool MoveFirstSelected();
[C++]
public: virtual bool MoveFirstSelected();
[JScript]
public function MoveFirstSelected() : Boolean;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.MoveLast

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveLast() As Boolean
[C#]
public virtual bool MoveLast();
[C++]
public: virtual bool MoveLast();
[JScript]
public function MoveLast() : Boolean;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.MoveLastSelected

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveLastSelected() As Boolean
[C#]
public virtual bool MoveLastSelected();
[C++]
public: virtual bool MoveLastSelected();
[JScript]
public function MoveLastSelected() : Boolean;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.MoveNext

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.MoveNextSelected

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveNextSelected() As Boolean
[C#]
public virtual bool MoveNextSelected();
[C++]
public: virtual bool MoveNextSelected();
[JScript]
public function MoveNextSelected() : Boolean;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.MovePrevious

[To be supplied.]

[Visual Basic]
Overridable Public Function MovePrevious() As Boolean
[C#]
public virtual bool MovePrevious();
[C++]
public: virtual bool MovePrevious();
[JScript]
public function MovePrevious() : Boolean;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.MovePreviousSelected

[To be supplied.]

[Visual Basic]
Overridable Public Function MovePreviousSelected() As Boolean
[C#]
public virtual bool MovePreviousSelected();
[C++]
public: virtual bool MovePreviousSelected();
[JScript]
public function MovePreviousSelected() : Boolean;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.MoveTo

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function MoveTo(DataRow) As Boolean
[C#] public bool MoveTo(DataRow);
[C++] public: bool MoveTo(DataRow*);
[JScript] public function MoveTo(DataRow) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function MoveTo(INode) As Boolean
[C#] public bool MoveTo(INode);
[C++] public: bool MoveTo(INode*);
[JScript] public function MoveTo(INode) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function MoveTo(IDataNavigator) As Boolean
[C#] public virtual bool MoveTo(IDataNavigator);
[C++] public: virtual bool MoveTo(IDataNavigator*);
[JScript] public function MoveTo(IDataNavigator) : Boolean;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.MoveTo (DataRow)

[To be supplied.]

[Visual Basic]
Overloads Public Function MoveTo( _
   ByVal row As DataRow _
) As Boolean
[C#]
public bool MoveTo(
   DataRow row
);
[C++]
public: bool MoveTo(
   DataRow* row
);
[JScript]
public function MoveTo(
   row : DataRow
) : Boolean;

Parameters

row
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace | DocumentNavigator.MoveTo Overload List


DocumentNavigator.MoveTo (INode)

[To be supplied.]

[Visual Basic]
Overloads Public Function MoveTo( _
   ByVal node As INode _
) As Boolean
[C#]
public bool MoveTo(
   INode node
);
[C++]
public: bool MoveTo(
   INode* node
);
[JScript]
public function MoveTo(
   node : INode
) : Boolean;

Parameters

node
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace | DocumentNavigator.MoveTo Overload List


DocumentNavigator.MoveTo (IDataNavigator)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function MoveTo( _
   ByVal other As IDataNavigator _
) As Boolean
[C#]
public virtual bool MoveTo(
   IDataNavigator other
);
[C++]
public: virtual bool MoveTo(
   IDataNavigator* other
);
[JScript]
public function MoveTo(
   other : IDataNavigator
) : Boolean;

Parameters

other
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace | DocumentNavigator.MoveTo Overload List


DocumentNavigator.MoveToChild

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveToChild( _
   ByVal nChildIndex As Integer _
) As Boolean
[C#]
public virtual bool MoveToChild(
   int nChildIndex
);
[C++]
public: virtual bool MoveToChild(
   int nChildIndex
);
[JScript]
public function MoveToChild(
   nChildIndex : int
) : Boolean;

Parameters

nChildIndex
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.MoveToField

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveToField( _
   ByVal nFieldIndex As Integer _
) As Boolean
[C#]
public virtual bool MoveToField(
   int nFieldIndex
);
[C++]
public: virtual bool MoveToField(
   int nFieldIndex
);
[JScript]
public function MoveToField(
   nFieldIndex : int
) : Boolean;

Parameters

nFieldIndex
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.MoveToFirstChild

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveToFirstChild() As Boolean
[C#]
public virtual bool MoveToFirstChild();
[C++]
public: virtual bool MoveToFirstChild();
[JScript]
public function MoveToFirstChild() : Boolean;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.MoveToId

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveToId( _
   ByVal id As String _
) As Boolean
[C#]
public virtual bool MoveToId(
   string id
);
[C++]
public: virtual bool MoveToId(
   String* id
);
[JScript]
public function MoveToId(
   id : String
) : Boolean;

Parameters

id
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.MoveToLastChild

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveToLastChild() As Boolean
[C#]
public virtual bool MoveToLastChild();
[C++]
public: virtual bool MoveToLastChild();
[JScript]
public function MoveToLastChild() : Boolean;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.MoveToNull

[To be supplied.]

[Visual Basic]
Overridable Public Sub MoveToNull()
[C#]
public virtual void MoveToNull();
[C++]
public: virtual void MoveToNull();
[JScript]
public function MoveToNull();

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.MoveToParent

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveToParent() As Boolean
[C#]
public virtual bool MoveToParent();
[C++]
public: virtual bool MoveToParent();
[JScript]
public function MoveToParent() : Boolean;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.MoveToRoot

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveToRoot() As Boolean
[C#]
public virtual bool MoveToRoot();
[C++]
public: virtual bool MoveToRoot();
[JScript]
public function MoveToRoot() : Boolean;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.PopPosition

[To be supplied.]

[Visual Basic]
Overridable Public Function PopPosition() As Boolean
[C#]
public virtual bool PopPosition();
[C++]
public: virtual bool PopPosition();
[JScript]
public function PopPosition() : Boolean;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.PushPosition

[To be supplied.]

[Visual Basic]
Overridable Public Sub PushPosition()
[C#]
public virtual void PushPosition();
[C++]
public: virtual void PushPosition();
[JScript]
public function PushPosition();

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.ResetSelection

[To be supplied.]

[Visual Basic]
Public Sub ResetSelection()
[C#]
public void ResetSelection();
[C++]
public: void ResetSelection();
[JScript]
public function ResetSelection();

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.Select

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Sub Select(String)
[C#] public virtual void Select(String);
[C++] public: virtual void Select(String*);
[JScript] public function Select(String);

[To be supplied.]

[Visual Basic] Overloads Overridable Public Sub Select(Object)
[C#] public virtual void Select(Object);
[C++] public: virtual void Select(Object*);
[JScript] public function Select(Object);

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentNavigator.Select (String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Sub Select( _
   ByVal xpathexpr As String _
)
[C#]
public virtual void Select(
   string xpathexpr
);
[C++]
public: virtual void Select(
   String* xpathexpr
);
[JScript]
public function Select(
   xpathexpr : String
);

Parameters

xpathexpr
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace | DocumentNavigator.Select Overload List


DocumentNavigator.Select (Object)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Sub Select( _
   ByVal xpathexpr As Object _
)
[C#]
public virtual void Select(
   object xpathexpr
);
[C++]
public: virtual void Select(
   Object* xpathexpr
);
[JScript]
public function Select(
   xpathexpr : Object
);

Parameters

xpathexpr
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace | DocumentNavigator.Select Overload List


DocumentNavigator.SelectIds

[To be supplied.]

[Visual Basic]
Public Sub SelectIds( _
   ByVal ids As String _
)
[C#]
public void SelectIds(
   string ids
);
[C++]
public: void SelectIds(
   String* ids
);
[JScript]
public function SelectIds(
   ids : String
);

Parameters

ids
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.Data.XML Namespace


DocumentReader Class

[To be supplied.]

Object
DocumentReader

[Visual Basic]
NotInheritable Public Class DocumentReader
   Implements IDataReader, IDataRecord, INameTable
[C#]
public sealed class DocumentReader : IDataReader, IDataRecord,
   INameTable
[C++]
public __gc __sealed class DocumentReader : public IDataReader,
   IDataRecord, INameTable
[JScript]
public class DocumentReader implements IDataReader, IDataRecord,
   INameTable

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

DocumentReader Members | System.Data.XML Namespace


DocumentReader Members

Public:

Constructor

DocumentReader Constructor Overloaded. [To be supplied.]

Properties

DataTypeName | [To be supplied.]
DataTypeNamespace | [To be supplied.]
Depth | [To be supplied.]
Empty | [To be supplied.]
EOF | [To be supplied.]
FieldCount | [To be supplied.]
Filter | [To be supplied.]
Format | [To be supplied.]
HasValue | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the DocumentReader class.
Name | [To be supplied.]
Namespace | [To be supplied.]
NameTable | [To be supplied.]
NodeType | [To be supplied.]
Prefix | [To be supplied.]
ReadState | [To be supplied.]

Methods

Add | Overloaded. [To be supplied.]
Close | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | Overloaded. [To be supplied.]
GetBoolean | [To be supplied.]
GetByte | [To be supplied.]
GetBytes | [To be supplied.]
GetChar | [To be supplied.]
GetChars | [To be supplied.]
GetCurrency | [To be supplied.]
GetData | [To be supplied.]
GetDataTypeName | [To be supplied.]
GetDataTypeNamespace | [To be supplied.]
GetDateTime | [To be supplied.]
GetDecimal | [To be supplied.]
GetDouble | [To be supplied.]
GetFieldType | [To be supplied.]
GetFloat | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInt16 | [To be supplied.]
GetInt32 | [To be supplied.]
GetInt64 | [To be supplied.]
GetName | [To be supplied.]
GetNamespace | [To be supplied.]
GetOrdinal | Overloaded. [To be supplied.]
GetPrefix | [To be supplied.]
GetRaw | [To be supplied.]
GetStream | [To be supplied.]
GetString | [To be supplied.]
GetTimeSpan | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | [To be supplied.]
GetValues | [To be supplied.]
IsNull | [To be supplied.]
Read | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DocumentReader Class | System.Data.XML Namespace


DocumentReader Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(XmlDocument)
[C#] public DocumentReader(XmlDocument);
[C++] public: DocumentReader(XmlDocument*);
[JScript] public function DocumentReader(XmlDocument);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(DocumentNavigator, Boolean)
[C#] public DocumentReader(DocumentNavigator, bool);
[C++] public: DocumentReader(DocumentNavigator*, bool);
[JScript] public function DocumentReader(DocumentNavigator, Boolean);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(DocumentNavigator)
[C#] public DocumentReader(DocumentNavigator);
[C++] public: DocumentReader(DocumentNavigator*);
[JScript] public function DocumentReader(DocumentNavigator);

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader Constructor (XmlDocument)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal doc As XmlDocument _
)
[C#]
public DocumentReader(
   XmlDocument doc
);
[C++]
public: DocumentReader(
   XmlDocument* doc
);
[JScript]
public function DocumentReader(
   doc : XmlDocument
);

Parameters

doc
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace | DocumentReader Constructor Overload List


DocumentReader Constructor (DocumentNavigator, Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal dn As DocumentNavigator, _
   ByVal fInclusive As Boolean _
)
[C#]
public DocumentReader(
   DocumentNavigator dn,
   bool fInclusive
);
[C++]
public: DocumentReader(
   DocumentNavigator* dn,
   bool fInclusive
);
[JScript]
public function DocumentReader(
   dn : DocumentNavigator,
   fInclusive : Boolean
);

Parameters

dn
[To be supplied.]
fInclusive
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace | DocumentReader Constructor Overload List


DocumentReader Constructor (DocumentNavigator)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal dn As DocumentNavigator _
)
[C#]
public DocumentReader(
   DocumentNavigator dn
);
[C++]
public: DocumentReader(
   DocumentNavigator* dn
);
[JScript]
public function DocumentReader(
   dn : DocumentNavigator
);

Parameters

dn
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace | DocumentReader Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DocumentReader Properties

The properties of the DocumentReader class are listed below. For a complete list of DocumentReader class members, see the DocumentReader Members topic.

Public:

DataTypeName | [To be supplied.]
DataTypeNamespace | [To be supplied.]
Depth | [To be supplied.]
Empty | [To be supplied.]
EOF | [To be supplied.]
FieldCount | [To be supplied.]
Filter | [To be supplied.]
Format | [To be supplied.]
HasValue | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the DocumentReader class.
Name | [To be supplied.]
Namespace | [To be supplied.]
NameTable | [To be supplied.]
NodeType | [To be supplied.]
Prefix | [To be supplied.]
ReadState | [To be supplied.]

See Also

DocumentReader Class | System.Data.XML Namespace


DocumentReader.DataTypeName

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DataTypeName As String
[C#]
public string DataTypeName {virtual get;}
[C++]
public: __property virtual String* get_DataTypeName();
[JScript]
public function get DataTypeName() : String;

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.DataTypeNamespace

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DataTypeNamespace As String
[C#]
public string DataTypeNamespace {virtual get;}
[C++]
public: __property virtual String* get_DataTypeNamespace();
[JScript]
public function get DataTypeNamespace() : String;

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.Depth

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Depth As Integer
[C#]
public int Depth {virtual get;}
[C++]
public: __property virtual int get_Depth();
[JScript]
public function get Depth() : int;

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.Empty

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Empty As Boolean
[C#]
public bool Empty {virtual get;}
[C++]
public: __property virtual bool get_Empty();
[JScript]
public function get Empty() : Boolean;

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.EOF

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property EOF As Boolean
[C#]
public bool EOF {virtual get;}
[C++]
public: __property virtual bool get_EOF();
[JScript]
public function get EOF() : Boolean;

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.FieldCount

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property FieldCount As Integer
[C#]
public int FieldCount {virtual get;}
[C++]
public: __property virtual int get_FieldCount();
[JScript]
public function get FieldCount() : int;

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.Filter

[To be supplied.]

[Visual Basic]
Overridable Public Property Filter As String
[C#]
public string Filter {virtual get; virtual set;}
[C++]
public: __property virtual String* get_Filter();
public: __property virtual void set_Filter(String*);
[JScript]
public function get Filter() : String;
public function set Filter(String);

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.Format

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Format As String
[C#]
public string Format {virtual get;}
[C++]
public: __property virtual String* get_Format();
[JScript]
public function get Format() : String;

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.HasValue

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property HasValue As Boolean
[C#]
public bool HasValue {virtual get;}
[C++]
public: __property virtual bool get_HasValue();
[JScript]
public function get HasValue() : Boolean;

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the DocumentReader class.

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(String) As Object
[C#] public object this[String] {virtual get;}
[C++] public: __property virtual Object* get_Item(String*);
[JScript] DocumentReader.Item (String)

[To be supplied.]

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(String, String) As Object
[C#] public object this[String, String] {virtual get;}
[C++] public: __property virtual Object* get_Item(String*, String*);
[JScript] DocumentReader.Item (String, String)

[To be supplied.]

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(Integer) As Object
[C#] public object this[int] {virtual get;}
[C++] public: __property virtual Object* get_Item(int);
[JScript] DocumentReader.Item (int)

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.Item (String)

[To be supplied.]

[C#] In C#, this member is the indexer for the DocumentReader class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal name As String _
) As Object
[C#]
public object this[
   string name
] {virtual get;}
[C++]
public: __property virtual Object* get_Item(
   String* name
);
[JScript]
returnValue = DocumentReaderObject.Item(name);
-or-
returnValue = DocumentReaderObject(name);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
[To be supplied.]

Parameters [Visual Basic, C#, C++]

name
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace | DocumentReader.Item Overload List


DocumentReader.Item (String, String)

[To be supplied.]

[C#] In C#, this member is the indexer for the DocumentReader class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal name As String, _
   ByVal namespaceURI As String _
) As Object
[C#]
public object this[
   string name,
   string namespaceURI
] {virtual get;}
[C++]
public: __property virtual Object* get_Item(
   String* name,
   String* namespaceURI
);
[JScript]
returnValue = DocumentReaderObject.Item(name, namespaceURI);
-or-
returnValue = DocumentReaderObject(name, namespaceURI);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
[To be supplied.]
namespaceURI
[To be supplied.]

Parameters [Visual Basic, C#, C++]

name
[To be supplied.]
namespaceURI
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace | DocumentReader.Item Overload List


DocumentReader.Item (Int32)

[To be supplied.]

[C#] In C#, this member is the indexer for the DocumentReader class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal i As Integer _
) As Object
[C#]
public object this[
   int i
] {virtual get;}
[C++]
public: __property virtual Object* get_Item(
   int i
);
[JScript]
returnValue = DocumentReaderObject.Item(i);
-or-
returnValue = DocumentReaderObject(i);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

i
[To be supplied.]

Parameters [Visual Basic, C#, C++]

i
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace | DocumentReader.Item Overload List


DocumentReader.Name

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {virtual get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.Namespace

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Namespace As String
[C#]
public string Namespace {virtual get;}
[C++]
public: __property virtual String* get_Namespace();
[JScript]
public function get Namespace() : String;

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.NameTable

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property NameTable As INameTable
[C#]
public INameTable NameTable {virtual get;}
[C++]
public: __property virtual INameTable* get_NameTable();
[JScript]
public function get NameTable() : INameTable;

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.NodeType

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property NodeType As XmlNodeType
[C#]
public XmlNodeType NodeType {virtual get;}
[C++]
public: __property virtual XmlNodeType get_NodeType();
[JScript]
public function get NodeType() : XmlNodeType;

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.Prefix

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Prefix As String
[C#]
public string Prefix {virtual get;}
[C++]
public: __property virtual String* get_Prefix();
[JScript]
public function get Prefix() : String;

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.ReadState

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property ReadState As Integer
[C#]
public int ReadState {virtual get;}
[C++]
public: __property virtual int get_ReadState();
[JScript]
public function get ReadState() : int;

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DocumentReader Methods

The methods of the DocumentReader class are listed below. For a complete list of DocumentReader class members, see the DocumentReader Members topic.

Public:

Add | Overloaded. [To be supplied.]
Close | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | Overloaded. [To be supplied.]
GetBoolean | [To be supplied.]
GetByte | [To be supplied.]
GetBytes | [To be supplied.]
GetChar | [To be supplied.]
GetChars | [To be supplied.]
GetCurrency | [To be supplied.]
GetData | [To be supplied.]
GetDataTypeName | [To be supplied.]
GetDataTypeNamespace | [To be supplied.]
GetDateTime | [To be supplied.]
GetDecimal | [To be supplied.]
GetDouble | [To be supplied.]
GetFieldType | [To be supplied.]
GetFloat | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInt16 | [To be supplied.]
GetInt32 | [To be supplied.]
GetInt64 | [To be supplied.]
GetName | [To be supplied.]
GetNamespace | [To be supplied.]
GetOrdinal | Overloaded. [To be supplied.]
GetPrefix | [To be supplied.]
GetRaw | [To be supplied.]
GetStream | [To be supplied.]
GetString | [To be supplied.]
GetTimeSpan | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | [To be supplied.]
GetValues | [To be supplied.]
IsNull | [To be supplied.]
Read | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DocumentReader Class | System.Data.XML Namespace


DocumentReader.Add

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Add(Char(), Integer, Integer) As String
[C#] public virtual string Add(char[], int, int);
[C++] public: virtual String* Add(__wchar_t*[], int, int);
[JScript] public function Add(Char[], int, int) : String;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Add(String) As String
[C#] public virtual string Add(String);
[C++] public: virtual String* Add(String*);
[JScript] public function Add(String) : String;

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.Add (Char[], Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Add( _
   ByVal array() As Char, _
   ByVal offset As Integer, _
   ByVal length As Integer _
) As String
[C#]
public virtual string Add(
   char[] array,
   int offset,
   int length
);
[C++]
public: virtual String* Add(
   __wchar_t* array[],
   int offset,
   int length
);
[JScript]
public function Add(
   array : Char[],
   offset : int,
   length : int
) : String;

Parameters

array
[To be supplied.]
offset
[To be supplied.]
length
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace | DocumentReader.Add Overload List


DocumentReader.Add (String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Add( _
   ByVal str As String _
) As String
[C#]
public virtual string Add(
   string str
);
[C++]
public: virtual String* Add(
   String* str
);
[JScript]
public function Add(
   str : String
) : String;

Parameters

str
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace | DocumentReader.Add Overload List


DocumentReader.Close

[To be supplied.]

[Visual Basic]
Overridable Public Sub Close()
[C#]
public virtual void Close();
[C++]
public: virtual void Close();
[JScript]
public function Close();

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.Get

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Get(Char(), Integer, Integer) As String
[C#] public virtual string Get(char[], int, int);
[C++] public: virtual String* Get(__wchar_t*[], int, int);
[JScript] public function Get(Char[], int, int) : String;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Get(String) As String
[C#] public virtual string Get(String);
[C++] public: virtual String* Get(String*);
[JScript] public function Get(String) : String;

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.Get (Char[], Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Get( _
   ByVal array() As Char, _
   ByVal offset As Integer, _
   ByVal length As Integer _
) As String
[C#]
public virtual string Get(
   char[] array,
   int offset,
   int length
);
[C++]
public: virtual String* Get(
   __wchar_t* array[],
   int offset,
   int length
);
[JScript]
public function Get(
   array : Char[],
   offset : int,
   length : int
) : String;

Parameters

array
[To be supplied.]
offset
[To be supplied.]
length
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace | DocumentReader.Get Overload List


DocumentReader.Get (String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Get( _
   ByVal str As String _
) As String
[C#]
public virtual string Get(
   string str
);
[C++]
public: virtual String* Get(
   String* str
);
[JScript]
public function Get(
   str : String
) : String;

Parameters

str
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace | DocumentReader.Get Overload List


DocumentReader.GetBoolean

[To be supplied.]

[Visual Basic]
Overridable Public Function GetBoolean( _
   ByVal i As Integer _
) As Boolean
[C#]
public virtual bool GetBoolean(
   int i
);
[C++]
public: virtual bool GetBoolean(
   int i
);
[JScript]
public function GetBoolean(
   i : int
) : Boolean;

Parameters

i
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.GetByte

[To be supplied.]

[Visual Basic]
Overridable Public Function GetByte( _
   ByVal i As Integer _
) As Byte
[C#]
public virtual byte GetByte(
   int i
);
[C++]
public: virtual unsigned char GetByte(
   int i
);
[JScript]
public function GetByte(
   i : int
) : Byte;

Parameters

i
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.GetBytes

[To be supplied.]

[Visual Basic]
Overridable Public Function GetBytes( _
   ByVal i As Integer, _
   ByVal buffer() As Byte, _
   ByVal length As Integer, _
   ByVal bufferoffset As Integer, _
   ByVal fieldoffset As Integer _
) As Integer
[C#]
public virtual int GetBytes(
   int i,
   byte[] buffer,
   int length,
   int bufferoffset,
   int fieldoffset
);
[C++]
public: virtual int GetBytes(
   int i,
   unsigned char* buffer[],
   int length,
   int bufferoffset,
   int fieldoffset
);
[JScript]
public function GetBytes(
   i : int,
   buffer : Byte[],
   length : int,
   bufferoffset : int,
   fieldoffset : int
) : int;

Parameters

i
[To be supplied.]
buffer
[To be supplied.]
length
[To be supplied.]
bufferoffset
[To be supplied.]
fieldoffset
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.GetChar

[To be supplied.]

[Visual Basic]
Overridable Public Function GetChar( _
   ByVal i As Integer _
) As Char
[C#]
public virtual char GetChar(
   int i
);
[C++]
public: virtual __wchar_t GetChar(
   int i
);
[JScript]
public function GetChar(
   i : int
) : Char;

Parameters

i
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.GetChars

[To be supplied.]

[Visual Basic]
Overridable Public Function GetChars( _
   ByVal i As Integer, _
   ByVal buffer() As Char, _
   ByVal length As Integer, _
   ByVal bufferOffset As Integer, _
   ByVal fieldOffset As Integer _
) As Integer
[C#]
public virtual int GetChars(
   int i,
   char[] buffer,
   int length,
   int bufferOffset,
   int fieldOffset
);
[C++]
public: virtual int GetChars(
   int i,
   __wchar_t* buffer[],
   int length,
   int bufferOffset,
   int fieldOffset
);
[JScript]
public function GetChars(
   i : int,
   buffer : Char[],
   length : int,
   bufferOffset : int,
   fieldOffset : int
) : int;

Parameters

i
[To be supplied.]
buffer
[To be supplied.]
length
[To be supplied.]
bufferOffset
[To be supplied.]
fieldOffset
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.GetCurrency

[To be supplied.]

[Visual Basic]
Overridable Public Function GetCurrency( _
   ByVal i As Integer _
) As Currency
[C#]
public virtual Currency GetCurrency(
   int i
);
[C++]
public: virtual Currency GetCurrency(
   int i
);
[JScript]
public function GetCurrency(
   i : int
) : Currency;

Parameters

i
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.GetData

[To be supplied.]

[Visual Basic]
Overridable Public Function GetData( _
   ByVal i As Integer _
) As IDataReader
[C#]
public virtual IDataReader GetData(
   int i
);
[C++]
public: virtual IDataReader* GetData(
   int i
);
[JScript]
public function GetData(
   i : int
) : IDataReader;

Parameters

i
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.GetDataTypeName

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDataTypeName( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetDataTypeName(
   int i
);
[C++]
public: virtual String* GetDataTypeName(
   int i
);
[JScript]
public function GetDataTypeName(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.GetDataTypeNamespace

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDataTypeNamespace( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetDataTypeNamespace(
   int i
);
[C++]
public: virtual String* GetDataTypeNamespace(
   int i
);
[JScript]
public function GetDataTypeNamespace(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.GetDateTime

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDateTime( _
   ByVal i As Integer _
) As DateTime
[C#]
public virtual DateTime GetDateTime(
   int i
);
[C++]
public: virtual DateTime GetDateTime(
   int i
);
[JScript]
public function GetDateTime(
   i : int
) : DateTime;

Parameters

i
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.GetDecimal

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDecimal( _
   ByVal i As Integer _
) As Decimal
[C#]
public virtual Decimal GetDecimal(
   int i
);
[C++]
public: virtual Decimal GetDecimal(
   int i
);
[JScript]
public function GetDecimal(
   i : int
) : Decimal;

Parameters

i
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.GetDouble

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDouble( _
   ByVal i As Integer _
) As Double
[C#]
public virtual double GetDouble(
   int i
);
[C++]
public: virtual double GetDouble(
   int i
);
[JScript]
public function GetDouble(
   i : int
) : double;

Parameters

i
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.GetFieldType

[To be supplied.]

[Visual Basic]
Overridable Public Function GetFieldType( _
   ByVal i As Integer _
) As Type
[C#]
public virtual Type GetFieldType(
   int i
);
[C++]
public: virtual Type* GetFieldType(
   int i
);
[JScript]
public function GetFieldType(
   i : int
) : Type;

Parameters

i
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.GetFloat

[To be supplied.]

[Visual Basic]
Overridable Public Function GetFloat( _
   ByVal i As Integer _
) As Single
[C#]
public virtual float GetFloat(
   int i
);
[C++]
public: virtual float GetFloat(
   int i
);
[JScript]
public function GetFloat(
   i : int
) : float;

Parameters

i
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.GetInt16

[To be supplied.]

[Visual Basic]
Overridable Public Function GetInt16( _
   ByVal i As Integer _
) As Short
[C#]
public virtual short GetInt16(
   int i
);
[C++]
public: virtual short GetInt16(
   int i
);
[JScript]
public function GetInt16(
   i : int
) : Int16;

Parameters

i
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.GetInt32

[To be supplied.]

[Visual Basic]
Overridable Public Function GetInt32( _
   ByVal i As Integer _
) As Integer
[C#]
public virtual int GetInt32(
   int i
);
[C++]
public: virtual int GetInt32(
   int i
);
[JScript]
public function GetInt32(
   i : int
) : int;

Parameters

i
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.GetInt64

[To be supplied.]

[Visual Basic]
Overridable Public Function GetInt64( _
   ByVal i As Integer _
) As Long
[C#]
public virtual long GetInt64(
   int i
);
[C++]
public: virtual __int64 GetInt64(
   int i
);
[JScript]
public function GetInt64(
   i : int
) : long;

Parameters

i
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.GetName

[To be supplied.]

[Visual Basic]
Overridable Public Function GetName( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetName(
   int i
);
[C++]
public: virtual String* GetName(
   int i
);
[JScript]
public function GetName(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.GetNamespace

[To be supplied.]

[Visual Basic]
Overridable Public Function GetNamespace( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetNamespace(
   int i
);
[C++]
public: virtual String* GetNamespace(
   int i
);
[JScript]
public function GetNamespace(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.GetOrdinal

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function GetOrdinal(String, String) As Integer
[C#] public virtual int GetOrdinal(String, String);
[C++] public: virtual int GetOrdinal(String*, String*);
[JScript] public function GetOrdinal(String, String) : int;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function GetOrdinal(String) As Integer
[C#] public virtual int GetOrdinal(String);
[C++] public: virtual int GetOrdinal(String*);
[JScript] public function GetOrdinal(String) : int;

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.GetOrdinal (String, String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function GetOrdinal( _
   ByVal name As String, _
   ByVal namespaceURI As String _
) As Integer
[C#]
public virtual int GetOrdinal(
   string name,
   string namespaceURI
);
[C++]
public: virtual int GetOrdinal(
   String* name,
   String* namespaceURI
);
[JScript]
public function GetOrdinal(
   name : String,
   namespaceURI : String
) : int;

Parameters

name
[To be supplied.]
namespaceURI
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace | DocumentReader.GetOrdinal Overload List


DocumentReader.GetOrdinal (String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function GetOrdinal( _
   ByVal name As String _
) As Integer
[C#]
public virtual int GetOrdinal(
   string name
);
[C++]
public: virtual int GetOrdinal(
   String* name
);
[JScript]
public function GetOrdinal(
   name : String
) : int;

Parameters

name
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace | DocumentReader.GetOrdinal Overload List


DocumentReader.GetPrefix

[To be supplied.]

[Visual Basic]
Overridable Public Function GetPrefix( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetPrefix(
   int i
);
[C++]
public: virtual String* GetPrefix(
   int i
);
[JScript]
public function GetPrefix(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.GetRaw

[To be supplied.]

[Visual Basic]
Overridable Public Function GetRaw( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetRaw(
   int i
);
[C++]
public: virtual String* GetRaw(
   int i
);
[JScript]
public function GetRaw(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.GetStream

[To be supplied.]

[Visual Basic]
Overridable Public Function GetStream( _
   ByVal i As Integer _
) As Stream
[C#]
public virtual Stream GetStream(
   int i
);
[C++]
public: virtual Stream* GetStream(
   int i
);
[JScript]
public function GetStream(
   i : int
) : Stream;

Parameters

i
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.GetString

[To be supplied.]

[Visual Basic]
Overridable Public Function GetString( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetString(
   int i
);
[C++]
public: virtual String* GetString(
   int i
);
[JScript]
public function GetString(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.GetTimeSpan

[To be supplied.]

[Visual Basic]
Overridable Public Function GetTimeSpan( _
   ByVal i As Integer _
) As TimeSpan
[C#]
public virtual TimeSpan GetTimeSpan(
   int i
);
[C++]
public: virtual TimeSpan GetTimeSpan(
   int i
);
[JScript]
public function GetTimeSpan(
   i : int
) : TimeSpan;

Parameters

i
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.GetValue

[To be supplied.]

[Visual Basic]
Overridable Public Sub GetValue( _
   ByVal i As Integer, _
   ByRef value As Object _
)
[C#]
public virtual void GetValue(
   int i,
   ref object value
);
[C++]
public: virtual void GetValue(
   int i,
   Object** value
);
[JScript]
public function GetValue(
   i : int,
   value : Object
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.GetValues

[To be supplied.]

[Visual Basic]
Overridable Public Function GetValues( _
   ByVal values() As Object _
) As Integer
[C#]
public virtual int GetValues(
   object[] values
);
[C++]
public: virtual int GetValues(
   Object* values[]
);
[JScript]
public function GetValues(
   values : Object[]
) : int;

Parameters

values
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.IsNull

[To be supplied.]

[Visual Basic]
Overridable Public Function IsNull( _
   ByVal i As Integer _
) As Boolean
[C#]
public virtual bool IsNull(
   int i
);
[C++]
public: virtual bool IsNull(
   int i
);
[JScript]
public function IsNull(
   i : int
) : Boolean;

Parameters

i
[To be supplied.]

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


DocumentReader.Read

[To be supplied.]

[Visual Basic]
Overridable Public Function Read() As Boolean
[C#]
public virtual bool Read();
[C++]
public: virtual bool Read();
[JScript]
public function Read() : Boolean;

See Also

DocumentReader Class | DocumentReader Members | System.Data.XML Namespace


Filter Class

[To be supplied.]

Object
AstNode
Filter

[Visual Basic]
Public Class Filter
   Inherits AstNode
[C#]
public class Filter : AstNode
[C++]
public __gc class Filter : public AstNode
[JScript]
public class Filter extends AstNode

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

Filter Members | System.Data.XML Namespace


Filter Members

Public:

Constructor

Filter Constructor [To be supplied.]

Properties

Condition | [To be supplied.]
DefaultPriority (inherited from AstNode) | [To be supplied.]
Input | [To be supplied.]
ReturnType | [To be supplied.]
TypeOfAst | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Filter Class | System.Data.XML Namespace


Filter Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal input As AstNode, _
   ByVal condition As AstNode _
)
[C#]
public Filter(
   AstNode input,
   AstNode condition
);
[C++]
public: Filter(
   AstNode* input,
   AstNode* condition
);
[JScript]
public function Filter(
   input : AstNode,
   condition : AstNode
);

Parameters

input
[To be supplied.]
condition
[To be supplied.]

See Also

Filter Class | Filter Members | System.Data.XML Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Filter Properties

The properties of the Filter class are listed below. For a complete list of Filter class members, see the Filter Members topic.

Public:

Condition | [To be supplied.]
DefaultPriority (inherited from AstNode) | [To be supplied.]
Input | [To be supplied.]
ReturnType | [To be supplied.]
TypeOfAst | [To be supplied.]

See Also

Filter Class | System.Data.XML Namespace


Filter.Condition

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Condition As AstNode
[C#]
public AstNode Condition {get;}
[C++]
public: __property AstNode* get_Condition();
[JScript]
public function get Condition() : AstNode;

See Also

Filter Class | Filter Members | System.Data.XML Namespace


Filter.Input

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Input As AstNode
[C#]
public AstNode Input {get;}
[C++]
public: __property AstNode* get_Input();
[JScript]
public function get Input() : AstNode;

See Also

Filter Class | Filter Members | System.Data.XML Namespace


Filter.ReturnType

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property ReturnType As AstNode.RType
[C#]
public AstNode.RType ReturnType {override get;}
[C++]
public: __property virtual AstNode.RType get_ReturnType();
[JScript]
public function get ReturnType() : AstNode.RType;

See Also

Filter Class | Filter Members | System.Data.XML Namespace


Filter.TypeOfAst

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property TypeOfAst As AstNode.QueryType
[C#]
public AstNode.QueryType TypeOfAst {override get;}
[C++]
public: __property virtual AstNode.QueryType get_TypeOfAst();
[JScript]
public function get TypeOfAst() : AstNode.QueryType;

See Also

Filter Class | Filter Members | System.Data.XML Namespace


Function Class

[To be supplied.]

Object
AstNode
Function

[Visual Basic]
Public Class Function
   Inherits AstNode
[C#]
public class Function : AstNode
[C++]
public __gc class Function : public AstNode
[JScript]
public class Function extends AstNode

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

Function Members | System.Data.XML Namespace


Function Members

Public:

Constructor

Function Constructor Overloaded. [To be supplied.]

Properties

ArgumentList | [To be supplied.]
DefaultPriority (inherited from AstNode) | [To be supplied.]
FunctionName | [To be supplied.]
ReturnType | [To be supplied.]
TypeOfAst | [To be supplied.]
TypeOfFunction | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Function Class | System.Data.XML Namespace


Function Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(FunctionType, ObjectList)
[C#] public Function(FunctionType, ObjectList);
[C++] public: Function(FunctionType, ObjectList);
[JScript] public function Function(FunctionType, ObjectList);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(FunctionType)
[C#] public Function(FunctionType);
[C++] public: Function(FunctionType);
[JScript] public function Function(FunctionType);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(FunctionType, AstNode)
[C#] public Function(FunctionType, AstNode);
[C++] public: Function(FunctionType, AstNode);
[JScript] public function Function(FunctionType, AstNode);

See Also

Function Class | Function Members | System.Data.XML Namespace


Function Constructor (FunctionType, ObjectList)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal ftype As Function.FunctionType, _
   ByVal argumentList As ObjectList _
)
[C#]
public Function(
   Function.FunctionType ftype,
   ObjectList argumentList
);
[C++]
public: Function(
   Function.FunctionType ftype,
   ObjectList* argumentList
);
[JScript]
public function Function(
   ftype : Function.FunctionType,
   argumentList : ObjectList
);

Parameters

ftype
[To be supplied.]
argumentList
[To be supplied.]

See Also

Function Class | Function Members | System.Data.XML Namespace | Function Constructor Overload List


Function Constructor (FunctionType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal ftype As Function.FunctionType _
)
[C#]
public Function(
   Function.FunctionType ftype
);
[C++]
public: Function(
   Function.FunctionType ftype
);
[JScript]
public function Function(
   ftype : Function.FunctionType
);

Parameters

ftype
[To be supplied.]

See Also

Function Class | Function Members | System.Data.XML Namespace | Function Constructor Overload List


Function Constructor (FunctionType, AstNode)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal ftype As Function.FunctionType, _
   ByVal arg As AstNode _
)
[C#]
public Function(
   Function.FunctionType ftype,
   AstNode arg
);
[C++]
public: Function(
   Function.FunctionType ftype,
   AstNode* arg
);
[JScript]
public function Function(
   ftype : Function.FunctionType,
   arg : AstNode
);

Parameters

ftype
[To be supplied.]
arg
[To be supplied.]

See Also

Function Class | Function Members | System.Data.XML Namespace | Function Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Function Properties

The properties of the Function class are listed below. For a complete list of Function class members, see the Function Members topic.

Public:

ArgumentList | [To be supplied.]
DefaultPriority (inherited from AstNode) | [To be supplied.]
FunctionName | [To be supplied.]
ReturnType | [To be supplied.]
TypeOfAst | [To be supplied.]
TypeOfFunction | [To be supplied.]

See Also

Function Class | System.Data.XML Namespace


Function.ArgumentList

[To be supplied.]

[Visual Basic]
Public ReadOnly Property ArgumentList As ObjectList
[C#]
public ObjectList ArgumentList {get;}
[C++]
public: __property ObjectList* get_ArgumentList();
[JScript]
public function get ArgumentList() : ObjectList;

See Also

Function Class | Function Members | System.Data.XML Namespace


Function.FunctionName

[To be supplied.]

[Visual Basic]
Public ReadOnly Property FunctionName As String
[C#]
public string FunctionName {get;}
[C++]
public: __property String* get_FunctionName();
[JScript]
public function get FunctionName() : String;

See Also

Function Class | Function Members | System.Data.XML Namespace


Function.ReturnType

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property ReturnType As AstNode.RType
[C#]
public AstNode.RType ReturnType {override get;}
[C++]
public: __property virtual AstNode.RType get_ReturnType();
[JScript]
public function get ReturnType() : AstNode.RType;

See Also

Function Class | Function Members | System.Data.XML Namespace


Function.TypeOfAst

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property TypeOfAst As AstNode.QueryType
[C#]
public AstNode.QueryType TypeOfAst {override get;}
[C++]
public: __property virtual AstNode.QueryType get_TypeOfAst();
[JScript]
public function get TypeOfAst() : AstNode.QueryType;

See Also

Function Class | Function Members | System.Data.XML Namespace


Function.TypeOfFunction

[To be supplied.]

[Visual Basic]
Public ReadOnly Property TypeOfFunction As Function.FunctionType
[C#]
public Function.FunctionType TypeOfFunction {get;}
[C++]
public: __property Function.FunctionType get_TypeOfFunction();
[JScript]
public function get TypeOfFunction() : Function.FunctionType;

See Also

Function Class | Function Members | System.Data.XML Namespace


Function.FunctionType Enumeration

[To be supplied.]

[Visual Basic]
Public Enum Function.FunctionType
[C#]
public enum Function.FunctionType
[C++]
public enum Function.FunctionType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
FuncBoolean | [To be supplied.]
FuncCeiling | [To be supplied.]
FuncConcat | [To be supplied.]
FuncContains | [To be supplied.]
FuncCount | [To be supplied.]
FuncFalse | [To be supplied.]
FuncFloor | [To be supplied.]
FuncID | [To be supplied.]
FuncLang | [To be supplied.]
FuncLast | [To be supplied.]
FuncLocalName | [To be supplied.]
FuncName | [To be supplied.]
FuncNameSpaceUri | [To be supplied.]
FuncNormalize | [To be supplied.]
FuncNot | [To be supplied.]
FuncNumber | [To be supplied.]
FuncPosition | [To be supplied.]
FuncRound | [To be supplied.]
FuncStartsWith | [To be supplied.]
FuncString | [To be supplied.]
FuncStringLength | [To be supplied.]
FuncSubstring | [To be supplied.]
FuncSubstringAfter | [To be supplied.]
FuncSubstringBefore | [To be supplied.]
FuncSum | [To be supplied.]
FuncTranslate | [To be supplied.]
FuncTrue | [To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

System.Data.XML Namespace


Group Class

[To be supplied.]

Object
AstNode
Group

[Visual Basic]
Public Class Group
   Inherits AstNode
[C#]
public class Group : AstNode
[C++]
public __gc class Group : public AstNode
[JScript]
public class Group extends AstNode

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

Group Members | System.Data.XML Namespace


Group Members

Public:

Constructor

Group Constructor [To be supplied.]

Properties

DefaultPriority | [To be supplied.]
GroupNode | [To be supplied.]
ReturnType | [To be supplied.]
TypeOfAst | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Group Class | System.Data.XML Namespace


Group Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal groupNode As AstNode _
)
[C#]
public Group(
   AstNode groupNode
);
[C++]
public: Group(
   AstNode* groupNode
);
[JScript]
public function Group(
   groupNode : AstNode
);

Parameters

groupNode
[To be supplied.]

See Also

Group Class | Group Members | System.Data.XML Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Group Properties

The properties of the Group class are listed below. For a complete list of Group class members, see the Group Members topic.

Public:

DefaultPriority | [To be supplied.]
GroupNode | [To be supplied.]
ReturnType | [To be supplied.]
TypeOfAst | [To be supplied.]

See Also

Group Class | System.Data.XML Namespace


Group.DefaultPriority

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DefaultPriority As Double
[C#]
public double DefaultPriority {override get;}
[C++]
public: __property virtual double get_DefaultPriority();
[JScript]
public function get DefaultPriority() : double;

See Also

Group Class | Group Members | System.Data.XML Namespace


Group.GroupNode

[To be supplied.]

[Visual Basic]
Public ReadOnly Property GroupNode As AstNode
[C#]
public AstNode GroupNode {get;}
[C++]
public: __property AstNode* get_GroupNode();
[JScript]
public function get GroupNode() : AstNode;

See Also

Group Class | Group Members | System.Data.XML Namespace


Group.ReturnType

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property ReturnType As AstNode.RType
[C#]
public AstNode.RType ReturnType {override get;}
[C++]
public: __property virtual AstNode.RType get_ReturnType();
[JScript]
public function get ReturnType() : AstNode.RType;

See Also

Group Class | Group Members | System.Data.XML Namespace


Group.TypeOfAst

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property TypeOfAst As AstNode.QueryType
[C#]
public AstNode.QueryType TypeOfAst {override get;}
[C++]
public: __property virtual AstNode.QueryType get_TypeOfAst();
[JScript]
public function get TypeOfAst() : AstNode.QueryType;

See Also

Group Class | Group Members | System.Data.XML Namespace


MTNameTable Class

[To be supplied.]

Object
MTNameTable

[Visual Basic]
Public Class MTNameTable
   Implements INameTable
[C#]
public class MTNameTable : INameTable
[C++]
public __gc class MTNameTable : public INameTable
[JScript]
public class MTNameTable implements INameTable

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

MTNameTable Members | System.Data.XML Namespace


MTNameTable Members

Public:

Constructor

MTNameTable Constructor Overloaded. [To be supplied.]

Methods

Add | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | Overloaded. [To be supplied.]
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MTNameTable Class | System.Data.XML Namespace


MTNameTable Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Boolean, Integer)
[C#] public MTNameTable(bool, int);
[C++] public: MTNameTable(bool, int);
[JScript] public function MTNameTable(Boolean, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Boolean)
[C#] public MTNameTable(bool);
[C++] public: MTNameTable(bool);
[JScript] public function MTNameTable(Boolean);

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public MTNameTable();
[C++] public: MTNameTable();
[JScript] public function MTNameTable();

See Also

MTNameTable Class | MTNameTable Members | System.Data.XML Namespace


MTNameTable Constructor (Boolean, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal isThreadSafe As Boolean, _
   ByVal timeout As Integer _
)
[C#]
public MTNameTable(
   bool isThreadSafe,
   int timeout
);
[C++]
public: MTNameTable(
   bool isThreadSafe,
   int timeout
);
[JScript]
public function MTNameTable(
   isThreadSafe : Boolean,
   timeout : int
);

Parameters

isThreadSafe
[To be supplied.]
timeout
[To be supplied.]

See Also

MTNameTable Class | MTNameTable Members | System.Data.XML Namespace | MTNameTable Constructor Overload List


MTNameTable Constructor (Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal isThreadSafe As Boolean _
)
[C#]
public MTNameTable(
   bool isThreadSafe
);
[C++]
public: MTNameTable(
   bool isThreadSafe
);
[JScript]
public function MTNameTable(
   isThreadSafe : Boolean
);

Parameters

isThreadSafe
[To be supplied.]

See Also

MTNameTable Class | MTNameTable Members | System.Data.XML Namespace | MTNameTable Constructor Overload List


MTNameTable Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public MTNameTable();
[C++]
public: MTNameTable();
[JScript]
public function MTNameTable();

See Also

MTNameTable Class | MTNameTable Members | System.Data.XML Namespace | MTNameTable Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MTNameTable Methods

The methods of the MTNameTable class are listed below. For a complete list of MTNameTable class members, see the MTNameTable Members topic.

Public:

Add | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | Overloaded. [To be supplied.]
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MTNameTable Class | System.Data.XML Namespace


MTNameTable.Add

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Add(Char(), Integer, Integer) As String
[C#] public virtual string Add(char[], int, int);
[C++] public: virtual String* Add(__wchar_t*[], int, int);
[JScript] public function Add(Char[], int, int) : String;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Add(String) As String
[C#] public virtual string Add(String);
[C++] public: virtual String* Add(String*);
[JScript] public function Add(String) : String;

See Also

MTNameTable Class | MTNameTable Members | System.Data.XML Namespace


MTNameTable.Add (Char[], Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Add( _
   ByVal key() As Char, _
   ByVal start As Integer, _
   ByVal len As Integer _
) As String
[C#]
public virtual string Add(
   char[] key,
   int start,
   int len
);
[C++]
public: virtual String* Add(
   __wchar_t* key[],
   int start,
   int len
);
[JScript]
public function Add(
   key : Char[],
   start : int,
   len : int
) : String;

Parameters

key
[To be supplied.]
start
[To be supplied.]
len
[To be supplied.]

See Also

MTNameTable Class | MTNameTable Members | System.Data.XML Namespace | MTNameTable.Add Overload List


MTNameTable.Add (String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Add( _
   ByVal value As String _
) As String
[C#]
public virtual string Add(
   string value
);
[C++]
public: virtual String* Add(
   String* value
);
[JScript]
public function Add(
   value : String
) : String;

Parameters

value
[To be supplied.]

See Also

MTNameTable Class | MTNameTable Members | System.Data.XML Namespace | MTNameTable.Add Overload List


MTNameTable.Get

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Get(String) As String
[C#] public virtual string Get(String);
[C++] public: virtual String* Get(String*);
[JScript] public function Get(String) : String;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Get(Char(), Integer, Integer) As String
[C#] public virtual string Get(char[], int, int);
[C++] public: virtual String* Get(__wchar_t*[], int, int);
[JScript] public function Get(Char[], int, int) : String;

See Also

MTNameTable Class | MTNameTable Members | System.Data.XML Namespace


MTNameTable.Get (String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Get( _
   ByVal value As String _
) As String
[C#]
public virtual string Get(
   string value
);
[C++]
public: virtual String* Get(
   String* value
);
[JScript]
public function Get(
   value : String
) : String;

Parameters

value
[To be supplied.]

See Also

MTNameTable Class | MTNameTable Members | System.Data.XML Namespace | MTNameTable.Get Overload List


MTNameTable.Get (Char[], Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Get( _
   ByVal key() As Char, _
   ByVal start As Integer, _
   ByVal len As Integer _
) As String
[C#]
public virtual string Get(
   char[] key,
   int start,
   int len
);
[C++]
public: virtual String* Get(
   __wchar_t* key[],
   int start,
   int len
);
[JScript]
public function Get(
   key : Char[],
   start : int,
   len : int
) : String;

Parameters

key
[To be supplied.]
start
[To be supplied.]
len
[To be supplied.]

See Also

MTNameTable Class | MTNameTable Members | System.Data.XML Namespace | MTNameTable.Get Overload List


MTNameTable.GetEnumerator

[To be supplied.]

[Visual Basic]
Public Function GetEnumerator() As IEnumerator
[C#]
public IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

See Also

MTNameTable Class | MTNameTable Members | System.Data.XML Namespace


NamespaceManager Class

[To be supplied.]

Object
NamespaceManager

[Visual Basic]
MustInherit Public Class NamespaceManager
[C#]
public abstract class NamespaceManager
[C++]
public __gc __abstract class NamespaceManager
[JScript]
public abstract class NamespaceManager

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

NamespaceManager Members | System.Data.XML Namespace


NamespaceManager Members

Public:

Constructor

NamespaceManager Constructor [To be supplied.]

Properties

CurrentDefaultNamespace [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FindNamespace | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsReservedNameSpace | [To be supplied.]
PopNamespace | [To be supplied.]
PushNamespace | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NamespaceManager Class | System.Data.XML Namespace


NamespaceManager Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public NamespaceManager();
[C++]
public: NamespaceManager();
[JScript]
public function NamespaceManager();

See Also

NamespaceManager Class | NamespaceManager Members | System.Data.XML Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

NamespaceManager Properties

The properties of the NamespaceManager class are listed below. For a complete list of NamespaceManager class members, see the NamespaceManager Members topic.

Public:

CurrentDefaultNamespace [To be supplied.]

See Also

NamespaceManager Class | System.Data.XML Namespace


NamespaceManager.CurrentDefaultNamespace

[To be supplied.]

[Visual Basic]
MustOverride Public ReadOnly Property CurrentDefaultNamespace As _
   String
[C#]
public string CurrentDefaultNamespace {abstract get;}
[C++]
public: __property virtual String* get_CurrentDefaultNamespace() =
   0;
[JScript]
public abstract function get CurrentDefaultNamespace() : String;

See Also

NamespaceManager Class | NamespaceManager Members | System.Data.XML Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

NamespaceManager Methods

The methods of the NamespaceManager class are listed below. For a complete list of NamespaceManager class members, see the NamespaceManager Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FindNamespace | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsReservedNameSpace | [To be supplied.]
PopNamespace | [To be supplied.]
PushNamespace | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NamespaceManager Class | System.Data.XML Namespace


NamespaceManager.FindNamespace

[To be supplied.]

[Visual Basic]
MustOverride Public Function FindNamespace( _
   ByVal prefix As String, _
   ByRef urn As String, _
   ByRef srcURN As String _
) As Boolean
[C#]
public abstract bool FindNamespace(
   string prefix,
   ref string urn,
   ref string srcURN
);
[C++]
public: virtual bool FindNamespace(
   String* prefix,
   String** urn,
   String** srcURN
) = 0;
[JScript]
public abstract function FindNamespace(
   prefix : String,
   urn : String,
   srcURN : String
) : Boolean;

Parameters

prefix
[To be supplied.]
urn
[To be supplied.]
srcURN
[To be supplied.]

See Also

NamespaceManager Class | NamespaceManager Members | System.Data.XML Namespace


NamespaceManager.IsReservedNameSpace

[To be supplied.]

[Visual Basic]
MustOverride Public Function IsReservedNameSpace( _
   ByVal ns As String _
) As Boolean
[C#]
public abstract bool IsReservedNameSpace(
   string ns
);
[C++]
public: virtual bool IsReservedNameSpace(
   String* ns
) = 0;
[JScript]
public abstract function IsReservedNameSpace(
   ns : String
) : Boolean;

Parameters

ns
[To be supplied.]

See Also

NamespaceManager Class | NamespaceManager Members | System.Data.XML Namespace


NamespaceManager.PopNamespace

[To be supplied.]

[Visual Basic]
MustOverride Public Sub PopNamespace( _
   ByVal n As Integer _
)
[C#]
public abstract void PopNamespace(
   int n
);
[C++]
public: virtual void PopNamespace(
   int n
) = 0;
[JScript]
public abstract function PopNamespace(
   n : int
);

Parameters

n
[To be supplied.]

See Also

NamespaceManager Class | NamespaceManager Members | System.Data.XML Namespace


NamespaceManager.PushNamespace

[To be supplied.]

[Visual Basic]
MustOverride Public Sub PushNamespace( _
   ByVal prefix As String, _
   ByVal urn As String, _
   ByVal srcURN As String _
)
[C#]
public abstract void PushNamespace(
   string prefix,
   string urn,
   string srcURN
);
[C++]
public: virtual void PushNamespace(
   String* prefix,
   String* urn,
   String* srcURN
) = 0;
[JScript]
public abstract function PushNamespace(
   prefix : String,
   urn : String,
   srcURN : String
);

Parameters

prefix
[To be supplied.]
urn
[To be supplied.]
srcURN
[To be supplied.]

See Also

NamespaceManager Class | NamespaceManager Members | System.Data.XML Namespace


NameTable Class

INameTable implemented as a simple hash table.

Object
NameTable

[Visual Basic]
Public Class NameTable
   Implements INameTable
[C#]
public class NameTable : INameTable
[C++]
public __gc class NameTable : public INameTable
[JScript]
public class NameTable implements INameTable

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

NameTable Members | System.Data.XML Namespace | INameTable


NameTable Members

Public:

Constructor

NameTable Constructor Public constructor.

Methods

Add | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NameTable Class | System.Data.XML Namespace


NameTable Constructor

Public constructor.

[Visual Basic]
Public Sub New()
[C#]
public NameTable();
[C++]
public: NameTable();
[JScript]
public function NameTable();

Return Value

New empty NameTable object.

See Also

NameTable Class | NameTable Members | System.Data.XML Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

NameTable Methods

The methods of the NameTable class are listed below. For a complete list of NameTable class members, see the NameTable Members topic.

Public:

Add | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NameTable Class | System.Data.XML Namespace


NameTable.Add

[To be supplied.]

Overload List

Add the given string to the NameTable or return the existing string if it is already in the NameTable.

[Visual Basic] Overloads Overridable Public Function Add(Char(), Integer, Integer) As String
[C#] public virtual string Add(char[], int, int);
[C++] public: virtual String* Add(__wchar_t*[], int, int);
[JScript] public function Add(Char[], int, int) : String;

Add the given string to the NameTable or return the existing string if it is already in the NameTable.

[Visual Basic] Overloads Overridable Public Function Add(String) As String
[C#] public virtual string Add(String);
[C++] public: virtual String* Add(String*);
[JScript] public function Add(String) : String;

See Also

NameTable Class | NameTable Members | System.Data.XML Namespace


NameTable.Add (Char[], Int32, Int32)

Add the given string to the NameTable or return the existing string if it is already in the NameTable.

[Visual Basic]
Overloads Overridable Public Function Add( _
   ByVal key() As Char, _
   ByVal start As Integer, _
   ByVal len As Integer _
) As String
[C#]
public virtual string Add(
   char[] key,
   int start,
   int len
);
[C++]
public: virtual String* Add(
   __wchar_t* key[],
   int start,
   int len
);
[JScript]
public function Add(
   key : Char[],
   start : int,
   len : int
) : String;

Parameters

key
The character array contains the string to be looked up. The start and length define the position and length of this string within the character array.
start
The zero based offset into the character array defining the start of the string.
len
The number of characters in the string.

Return Value

The new string added or the matching string found the NameTable.

See Also

NameTable Class | NameTable Members | System.Data.XML Namespace | NameTable.Add Overload List


NameTable.Add (String)

Add the given string to the NameTable or return the existing string if it is already in the NameTable.

[Visual Basic]
Overloads Overridable Public Function Add( _
   ByVal key As String _
) As String
[C#]
public virtual string Add(
   string key
);
[C++]
public: virtual String* Add(
   String* key
);
[JScript]
public function Add(
   key : String
) : String;

Parameters

key
The string to find in the NameTable.

Return Value

The new string added or the matching string found the NameTable.

See Also

NameTable Class | NameTable Members | System.Data.XML Namespace | NameTable.Add Overload List


NameTable.Get

[To be supplied.]

Overload List

Find the matching string in the NameTable.

[Visual Basic] Overloads Overridable Public Function Get(String) As String
[C#] public virtual string Get(String);
[C++] public: virtual String* Get(String*);
[JScript] public function Get(String) : String;

Find the matching string atom given a range of characters.

[Visual Basic] Overloads Overridable Public Function Get(Char(), Integer, Integer) As String
[C#] public virtual string Get(char[], int, int);
[C++] public: virtual String* Get(__wchar_t*[], int, int);
[JScript] public function Get(Char[], int, int) : String;

See Also

NameTable Class | NameTable Members | System.Data.XML Namespace


NameTable.Get (String)

Find the matching string in the NameTable.

[Visual Basic]
Overloads Overridable Public Function Get( _
   ByVal value As String _
) As String
[C#]
public virtual string Get(
   string value
);
[C++]
public: virtual String* Get(
   String* value
);
[JScript]
public function Get(
   value : String
) : String;

Parameters

value
The string to find in the NameTable.

Return Value

The matching string in the NameTable.

See Also

NameTable Class | NameTable Members | System.Data.XML Namespace | NameTable.Get Overload List


NameTable.Get (Char[], Int32, Int32)

Find the matching string atom given a range of characters.

[Visual Basic]
Overloads Overridable Public Function Get( _
   ByVal key() As Char, _
   ByVal start As Integer, _
   ByVal len As Integer _
) As String
[C#]
public virtual string Get(
   char[] key,
   int start,
   int len
);
[C++]
public: virtual String* Get(
   __wchar_t* key[],
   int start,
   int len
);
[JScript]
public function Get(
   key : Char[],
   start : int,
   len : int
) : String;

Parameters

key
The character array contains the string to be looked up. The start and length define the position and length of this string within the character array.
start
The zero based offset into the character array defining the start of the string.
len
The number of characters in the string.

Return Value

The matching string in the NameTable.

See Also

NameTable Class | NameTable Members | System.Data.XML Namespace | NameTable.Get Overload List


Operand Class

[To be supplied.]

Object
AstNode
Operand

[Visual Basic]
Public Class Operand
   Inherits AstNode
[C#]
public class Operand : AstNode
[C++]
public __gc class Operand : public AstNode
[JScript]
public class Operand extends AstNode

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

Operand Members | System.Data.XML Namespace


Operand Members

Public:

Constructor

Operand Constructor Overloaded. [To be supplied.]

Properties

DefaultPriority (inherited from AstNode) | [To be supplied.]
OperandType | [To be supplied.]
OperandValue | [To be supplied.]
ReturnType | [To be supplied.]
TypeOfAst | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Operand Class | System.Data.XML Namespace


Operand Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public Operand(String);
[C++] public: Operand(String*);
[JScript] public function Operand(String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Boolean)
[C#] public Operand(String, bool);
[C++] public: Operand(String*, bool);
[JScript] public function Operand(String, Boolean);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Double)
[C#] public Operand(double);
[C++] public: Operand(double);
[JScript] public function Operand(double);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Boolean)
[C#] public Operand(bool);
[C++] public: Operand(bool);
[JScript] public function Operand(Boolean);

See Also

Operand Class | Operand Members | System.Data.XML Namespace


Operand Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal var As String _
)
[C#]
public Operand(
   string var
);
[C++]
public: Operand(
   String* var
);
[JScript]
public function Operand(
   var : String
);

Parameters

var
[To be supplied.]

See Also

Operand Class | Operand Members | System.Data.XML Namespace | Operand Constructor Overload List


Operand Constructor (String, Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal var As String, _
   ByVal isVar As Boolean _
)
[C#]
public Operand(
   string var,
   bool isVar
);
[C++]
public: Operand(
   String* var,
   bool isVar
);
[JScript]
public function Operand(
   var : String,
   isVar : Boolean
);

Parameters

var
[To be supplied.]
isVar
[To be supplied.]

See Also

Operand Class | Operand Members | System.Data.XML Namespace | Operand Constructor Overload List


Operand Constructor (Double)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal var As Double _
)
[C#]
public Operand(
   double var
);
[C++]
public: Operand(
   double var
);
[JScript]
public function Operand(
   var : double
);

Parameters

var
[To be supplied.]

See Also

Operand Class | Operand Members | System.Data.XML Namespace | Operand Constructor Overload List


Operand Constructor (Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal var As Boolean _
)
[C#]
public Operand(
   bool var
);
[C++]
public: Operand(
   bool var
);
[JScript]
public function Operand(
   var : Boolean
);

Parameters

var
[To be supplied.]

See Also

Operand Class | Operand Members | System.Data.XML Namespace | Operand Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Operand Properties

The properties of the Operand class are listed below. For a complete list of Operand class members, see the Operand Members topic.

Public:

DefaultPriority (inherited from AstNode) | [To be supplied.]
OperandType | [To be supplied.]
OperandValue | [To be supplied.]
ReturnType | [To be supplied.]
TypeOfAst | [To be supplied.]

See Also

Operand Class | System.Data.XML Namespace


Operand.OperandType

[To be supplied.]

[Visual Basic]
Public ReadOnly Property OperandType As String
[C#]
public string OperandType {get;}
[C++]
public: __property String* get_OperandType();
[JScript]
public function get OperandType() : String;

See Also

Operand Class | Operand Members | System.Data.XML Namespace


Operand.OperandValue

[To be supplied.]

[Visual Basic]
Public ReadOnly Property OperandValue As Object
[C#]
public object OperandValue {get;}
[C++]
public: __property Object* get_OperandValue();
[JScript]
public function get OperandValue() : Object;

See Also

Operand Class | Operand Members | System.Data.XML Namespace


Operand.ReturnType

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property ReturnType As AstNode.RType
[C#]
public AstNode.RType ReturnType {override get;}
[C++]
public: __property virtual AstNode.RType get_ReturnType();
[JScript]
public function get ReturnType() : AstNode.RType;

See Also

Operand Class | Operand Members | System.Data.XML Namespace


Operand.TypeOfAst

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property TypeOfAst As AstNode.QueryType
[C#]
public AstNode.QueryType TypeOfAst {override get;}
[C++]
public: __property virtual AstNode.QueryType get_TypeOfAst();
[JScript]
public function get TypeOfAst() : AstNode.QueryType;

See Also

Operand Class | Operand Members | System.Data.XML Namespace


Operator Class

[To be supplied.]

Object
AstNode
Operator

[Visual Basic]
Public Class Operator
   Inherits AstNode
[C#]
public class Operator : AstNode
[C++]
public __gc class Operator : public AstNode
[JScript]
public class Operator extends AstNode

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

Operator Members | System.Data.XML Namespace


Operator Members

Public:

Constructor

Operator Constructor [To be supplied.]

Properties

DefaultPriority | [To be supplied.]
Operand1 | [To be supplied.]
Operand2 | [To be supplied.]
OperatorType | [To be supplied.]
OperatorTypeName | [To be supplied.]
ReturnType | [To be supplied.]
TypeOfAst | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Operator Class | System.Data.XML Namespace


Operator Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal op As Operator.Op, _
   ByVal opnd1 As AstNode, _
   ByVal opnd2 As AstNode _
)
[C#]
public Operator(
   Operator.Op op,
   AstNode opnd1,
   AstNode opnd2
);
[C++]
public: Operator(
   Operator.Op op,
   AstNode* opnd1,
   AstNode* opnd2
);
[JScript]
public function Operator(
   op : Operator.Op,
   opnd1 : AstNode,
   opnd2 : AstNode
);

Parameters

op
[To be supplied.]
opnd1
[To be supplied.]
opnd2
[To be supplied.]

See Also

Operator Class | Operator Members | System.Data.XML Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Operator Properties

The properties of the Operator class are listed below. For a complete list of Operator class members, see the Operator Members topic.

Public:

DefaultPriority | [To be supplied.]
Operand1 | [To be supplied.]
Operand2 | [To be supplied.]
OperatorType | [To be supplied.]
OperatorTypeName | [To be supplied.]
ReturnType | [To be supplied.]
TypeOfAst | [To be supplied.]

See Also

Operator Class | System.Data.XML Namespace


Operator.DefaultPriority

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property DefaultPriority As Double
[C#]
public double DefaultPriority {override get;}
[C++]
public: __property virtual double get_DefaultPriority();
[JScript]
public function get DefaultPriority() : double;

See Also

Operator Class | Operator Members | System.Data.XML Namespace


Operator.Operand1

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Operand1 As AstNode
[C#]
public AstNode Operand1 {get;}
[C++]
public: __property AstNode* get_Operand1();
[JScript]
public function get Operand1() : AstNode;

See Also

Operator Class | Operator Members | System.Data.XML Namespace


Operator.Operand2

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Operand2 As AstNode
[C#]
public AstNode Operand2 {get;}
[C++]
public: __property AstNode* get_Operand2();
[JScript]
public function get Operand2() : AstNode;

See Also

Operator Class | Operator Members | System.Data.XML Namespace


Operator.OperatorType

[To be supplied.]

[Visual Basic]
Public ReadOnly Property OperatorType As Operator.Op
[C#]
public Operator.Op OperatorType {get;}
[C++]
public: __property Operator.Op get_OperatorType();
[JScript]
public function get OperatorType() : Operator.Op;

See Also

Operator Class | Operator Members | System.Data.XML Namespace


Operator.OperatorTypeName

[To be supplied.]

[Visual Basic]
Public ReadOnly Property OperatorTypeName As String
[C#]
public string OperatorTypeName {get;}
[C++]
public: __property String* get_OperatorTypeName();
[JScript]
public function get OperatorTypeName() : String;

See Also

Operator Class | Operator Members | System.Data.XML Namespace


Operator.ReturnType

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property ReturnType As AstNode.RType
[C#]
public AstNode.RType ReturnType {override get;}
[C++]
public: __property virtual AstNode.RType get_ReturnType();
[JScript]
public function get ReturnType() : AstNode.RType;

See Also

Operator Class | Operator Members | System.Data.XML Namespace


Operator.TypeOfAst

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property TypeOfAst As AstNode.QueryType
[C#]
public AstNode.QueryType TypeOfAst {override get;}
[C++]
public: __property virtual AstNode.QueryType get_TypeOfAst();
[JScript]
public function get TypeOfAst() : AstNode.QueryType;

See Also

Operator Class | Operator Members | System.Data.XML Namespace


Operator.Op Enumeration

[To be supplied.]

[Visual Basic]
Public Enum Operator.Op
[C#]
public enum Operator.Op
[C++]
public enum Operator.Op

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
AND | [To be supplied.]
DIV | [To be supplied.]
EQ | [To be supplied.]
GE | [To be supplied.]
GT | [To be supplied.]
INVALID | [To be supplied.]
LE | [To be supplied.]
LT | [To be supplied.]
MINUS | [To be supplied.]
MOD | [To be supplied.]
MUL | [To be supplied.]
NE | [To be supplied.]
NEGATE | [To be supplied.]
OR | [To be supplied.]
PLUS | [To be supplied.]
UNION | [To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

System.Data.XML Namespace


Trace Class

[To be supplied.]

Object
Trace

[Visual Basic]
Public Class Trace
[C#]
public class Trace
[C++]
public __gc class Trace
[JScript]
public class Trace

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

Trace Members | System.Data.XML Namespace


Trace Members

Public:

Constructor

Trace Constructor [To be supplied.]

Methods

Assert | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Message | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.
TRACE_SCANNER | Overloaded. [To be supplied.]
TRACE_SCANNER_INTERNAL | Overloaded. [To be supplied.]

Fields

TraceOn [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Trace Class | System.Data.XML Namespace


Trace Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public Trace();
[C++]
public: Trace();
[JScript]
public function Trace();

See Also

Trace Class | Trace Members | System.Data.XML Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Trace Methods

The methods of the Trace class are listed below. For a complete list of Trace class members, see the Trace Members topic.

Public:

Assert | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Message | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.
TRACE_SCANNER | Overloaded. [To be supplied.]
TRACE_SCANNER_INTERNAL | Overloaded. [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Trace Class | System.Data.XML Namespace


Trace.Assert

[To be supplied.]

[Visual Basic]
Public Shared Sub Assert( _
   ByVal condition As Boolean, _
   ByVal assertMessage As String _
)
[C#]
public static void Assert(
   bool condition,
   string assertMessage
);
[C++]
public: static void Assert(
   bool condition,
   String* assertMessage
);
[JScript]
public static function Assert(
   condition : Boolean,
   assertMessage : String
);

Parameters

condition
[To be supplied.]
assertMessage
[To be supplied.]

See Also

Trace Class | Trace Members | System.Data.XML Namespace


Trace.Message

[To be supplied.]

[Visual Basic]
Public Shared Sub Message( _
   ByVal traceMessage As String _
)
[C#]
public static void Message(
   string traceMessage
);
[C++]
public: static void Message(
   String* traceMessage
);
[JScript]
public static function Message(
   traceMessage : String
);

Parameters

traceMessage
[To be supplied.]

See Also

Trace Class | Trace Members | System.Data.XML Namespace


Trace.TRACE_SCANNER

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Shared Sub TRACE_SCANNER(String)
[C#] public static void TRACE_SCANNER(String);
[C++] public: static void TRACE_SCANNER(String*);
[JScript] public static function TRACE_SCANNER(String);

[To be supplied.]

[Visual Basic] Overloads Public Shared Sub TRACE_SCANNER(Integer)
[C#] public static void TRACE_SCANNER(int);
[C++] public: static void TRACE_SCANNER(int);
[JScript] public static function TRACE_SCANNER(int);

See Also

Trace Class | Trace Members | System.Data.XML Namespace


Trace.TRACE_SCANNER (String)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Sub TRACE_SCANNER( _
   ByVal str As String _
)
[C#]
public static void TRACE_SCANNER(
   string str
);
[C++]
public: static void TRACE_SCANNER(
   String* str
);
[JScript]
public static function TRACE_SCANNER(
   str : String
);

Parameters

str
[To be supplied.]

See Also

Trace Class | Trace Members | System.Data.XML Namespace | Trace.TRACE_SCANNER Overload List


Trace.TRACE_SCANNER (Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Sub TRACE_SCANNER( _
   ByVal n As Integer _
)
[C#]
public static void TRACE_SCANNER(
   int n
);
[C++]
public: static void TRACE_SCANNER(
   int n
);
[JScript]
public static function TRACE_SCANNER(
   n : int
);

Parameters

n
[To be supplied.]

See Also

Trace Class | Trace Members | System.Data.XML Namespace | Trace.TRACE_SCANNER Overload List


Trace.TRACE_SCANNER_INTERNAL

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Shared Sub TRACE_SCANNER_INTERNAL(Integer)
[C#] public static void TRACE_SCANNER_INTERNAL(int);
[C++] public: static void TRACE_SCANNER_INTERNAL(int);
[JScript] public static function TRACE_SCANNER_INTERNAL(int);

[To be supplied.]

[Visual Basic] Overloads Public Shared Sub TRACE_SCANNER_INTERNAL(String)
[C#] public static void TRACE_SCANNER_INTERNAL(String);
[C++] public: static void TRACE_SCANNER_INTERNAL(String*);
[JScript] public static function TRACE_SCANNER_INTERNAL(String);

See Also

Trace Class | Trace Members | System.Data.XML Namespace


Trace.TRACE_SCANNER_INTERNAL (Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Sub TRACE_SCANNER_INTERNAL( _
   ByVal n As Integer _
)
[C#]
public static void TRACE_SCANNER_INTERNAL(
   int n
);
[C++]
public: static void TRACE_SCANNER_INTERNAL(
   int n
);
[JScript]
public static function TRACE_SCANNER_INTERNAL(
   n : int
);

Parameters

n
[To be supplied.]

See Also

Trace Class | Trace Members | System.Data.XML Namespace | Trace.TRACE_SCANNER_INTERNAL Overload List


Trace.TRACE_SCANNER_INTERNAL (String)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Sub TRACE_SCANNER_INTERNAL( _
   ByVal str As String _
)
[C#]
public static void TRACE_SCANNER_INTERNAL(
   string str
);
[C++]
public: static void TRACE_SCANNER_INTERNAL(
   String* str
);
[JScript]
public static function TRACE_SCANNER_INTERNAL(
   str : String
);

Parameters

str
[To be supplied.]

See Also

Trace Class | Trace Members | System.Data.XML Namespace | Trace.TRACE_SCANNER_INTERNAL Overload List


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Trace Fields

The fields of the Trace class are listed below. For a complete list of Trace class members, see the Trace Members topic.

Public:

TraceOn [To be supplied.]

See Also

Trace Class | System.Data.XML Namespace


Trace.TraceOn

[To be supplied.]

[Visual Basic]
Public Shared TraceOn As Boolean
[C#]
public static bool TraceOn;
[C++]
public: static bool TraceOn;
[JScript]
public static var TraceOn : Boolean;

See Also

Trace Class | Trace Members | System.Data.XML Namespace


ValidationDelegate Delegate

[To be supplied.]

[Visual Basic]
Public Delegate Sub ValidationDelegate( _
   ByVal hr As Integer, _
   ByVal reason As String _
)
[C#]
public delegate void ValidationDelegate(
   int hr,
   string reason
);
[C++]
public __gc __delegate void ValidationDelegate(
   int hr,
   String* reason
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the ValidationDelegate delegate declaration.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

System.Data.XML Namespace


XmlDocument Class

[To be supplied.]

Object
XmlDocument

[Visual Basic]
NotInheritable Public Class XmlDocument
[C#]
public sealed class XmlDocument
[C++]
public __gc __sealed class XmlDocument
[JScript]
public class XmlDocument

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

XmlDocument Members | System.Data.XML Namespace


XmlDocument Members

Public:

Constructor

XmlDocument Constructor [To be supplied.]

Properties

DataSet | [To be supplied.]
DomDocument | [To be supplied.]
LoadFidelity | [To be supplied.]
LoadMapping | [To be supplied.]
Xml | [To be supplied.]

Methods

Clear | [To be supplied.]
CreateDocumentEditor | Overloaded. [To be supplied.]
CreateDocumentNavigator | Overloaded. [To be supplied.]
CreateDocumentReader | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Load | Overloaded. [To be supplied.]
LoadDataSetMapping | Overloaded. [To be supplied.]
ResetRowVersion | [To be supplied.]
Save | [To be supplied.]
SaveDataSetMapping | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlDocument Class | System.Data.XML Namespace


XmlDocument Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public XmlDocument();
[C++]
public: XmlDocument();
[JScript]
public function XmlDocument();

See Also

XmlDocument Class | XmlDocument Members | System.Data.XML Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlDocument Properties

The properties of the XmlDocument class are listed below. For a complete list of XmlDocument class members, see the XmlDocument Members topic.

Public:

DataSet | [To be supplied.]
DomDocument | [To be supplied.]
LoadFidelity | [To be supplied.]
LoadMapping | [To be supplied.]
Xml | [To be supplied.]

See Also

XmlDocument Class | System.Data.XML Namespace


XmlDocument.DataSet

[To be supplied.]

[Visual Basic]
Public ReadOnly Property DataSet As DataSet
[C#]
public DataSet DataSet {get;}
[C++]
public: __property DataSet* get_DataSet();
[JScript]
public function get DataSet() : DataSet;

See Also

XmlDocument Class | XmlDocument Members | System.Data.XML Namespace


XmlDocument.DomDocument

[To be supplied.]

[Visual Basic]
Public ReadOnly Property DomDocument As IDocument
[C#]
public IDocument DomDocument {get;}
[C++]
public: __property IDocument* get_DomDocument();
[JScript]
public function get DomDocument() : IDocument;

See Also

XmlDocument Class | XmlDocument Members | System.Data.XML Namespace


XmlDocument.LoadFidelity

[To be supplied.]

[Visual Basic]
Public Property LoadFidelity As XmlFidelity
[C#]
public XmlFidelity LoadFidelity {get; set;}
[C++]
public: __property XmlFidelity get_LoadFidelity();
public: __property void set_LoadFidelity(XmlFidelity);
[JScript]
public function get LoadFidelity() : XmlFidelity;
public function set LoadFidelity(XmlFidelity);

See Also

XmlDocument Class | XmlDocument Members | System.Data.XML Namespace


XmlDocument.LoadMapping

[To be supplied.]

[Visual Basic]
Public Property LoadMapping As DataSetMapping
[C#]
public DataSetMapping LoadMapping {get; set;}
[C++]
public: __property DataSetMapping get_LoadMapping();
public: __property void set_LoadMapping(DataSetMapping);
[JScript]
public function get LoadMapping() : DataSetMapping;
public function set LoadMapping(DataSetMapping);

See Also

XmlDocument Class | XmlDocument Members | System.Data.XML Namespace


XmlDocument.Xml

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Xml As String
[C#]
public string Xml {get;}
[C++]
public: __property String* get_Xml();
[JScript]
public function get Xml() : String;

See Also

XmlDocument Class | XmlDocument Members | System.Data.XML Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlDocument Methods

The methods of the XmlDocument class are listed below. For a complete list of XmlDocument class members, see the XmlDocument Members topic.

Public:

Clear | [To be supplied.]
CreateDocumentEditor | Overloaded. [To be supplied.]
CreateDocumentNavigator | Overloaded. [To be supplied.]
CreateDocumentReader | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Load | Overloaded. [To be supplied.]
LoadDataSetMapping | Overloaded. [To be supplied.]
ResetRowVersion | [To be supplied.]
Save | [To be supplied.]
SaveDataSetMapping | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlDocument Class | System.Data.XML Namespace


XmlDocument.Clear

[To be supplied.]

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[JScript]
public function Clear();

See Also

XmlDocument Class | XmlDocument Members | System.Data.XML Namespace


XmlDocument.CreateDocumentEditor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function CreateDocumentEditor(DataRow) As DocumentEditor
[C#] public DocumentEditor CreateDocumentEditor(DataRow);
[C++] public: DocumentEditor* CreateDocumentEditor(DataRow*);
[JScript] public function CreateDocumentEditor(DataRow) : DocumentEditor;

[To be supplied.]

[Visual Basic] Overloads Public Function CreateDocumentEditor() As DocumentEditor
[C#] public DocumentEditor CreateDocumentEditor();
[C++] public: DocumentEditor* CreateDocumentEditor();
[JScript] public function CreateDocumentEditor() : DocumentEditor;

See Also

XmlDocument Class | XmlDocument Members | System.Data.XML Namespace


XmlDocument.CreateDocumentEditor (DataRow)

[To be supplied.]

[Visual Basic]
Overloads Public Function CreateDocumentEditor( _
   ByVal row As DataRow _
) As DocumentEditor
[C#]
public DocumentEditor CreateDocumentEditor(
   DataRow row
);
[C++]
public: DocumentEditor* CreateDocumentEditor(
   DataRow* row
);
[JScript]
public function CreateDocumentEditor(
   row : DataRow
) : DocumentEditor;

Parameters

row
[To be supplied.]

See Also

XmlDocument Class | XmlDocument Members | System.Data.XML Namespace | XmlDocument.CreateDocumentEditor Overload List


XmlDocument.CreateDocumentEditor ()

[To be supplied.]

[Visual Basic]
Overloads Public Function CreateDocumentEditor() As DocumentEditor
[C#]
public DocumentEditor CreateDocumentEditor();
[C++]
public: DocumentEditor* CreateDocumentEditor();
[JScript]
public function CreateDocumentEditor() : DocumentEditor;

See Also

XmlDocument Class | XmlDocument Members | System.Data.XML Namespace | XmlDocument.CreateDocumentEditor Overload List


XmlDocument.CreateDocumentNavigator

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function CreateDocumentNavigator(DataRow) As DocumentNavigator
[C#] public DocumentNavigator CreateDocumentNavigator(DataRow);
[C++] public: DocumentNavigator* CreateDocumentNavigator(DataRow*);
[JScript] public function CreateDocumentNavigator(DataRow) : DocumentNavigator;

[To be supplied.]

[Visual Basic] Overloads Public Function CreateDocumentNavigator() As DocumentNavigator
[C#] public DocumentNavigator CreateDocumentNavigator();
[C++] public: DocumentNavigator* CreateDocumentNavigator();
[JScript] public function CreateDocumentNavigator() : DocumentNavigator;

See Also

XmlDocument Class | XmlDocument Members | System.Data.XML Namespace


XmlDocument.CreateDocumentNavigator (DataRow)

[To be supplied.]

[Visual Basic]
Overloads Public Function CreateDocumentNavigator( _
   ByVal row As DataRow _
) As DocumentNavigator
[C#]
public DocumentNavigator CreateDocumentNavigator(
   DataRow row
);
[C++]
public: DocumentNavigator* CreateDocumentNavigator(
   DataRow* row
);
[JScript]
public function CreateDocumentNavigator(
   row : DataRow
) : DocumentNavigator;

Parameters

row
[To be supplied.]

See Also

XmlDocument Class | XmlDocument Members | System.Data.XML Namespace | XmlDocument.CreateDocumentNavigator Overload List


XmlDocument.CreateDocumentNavigator ()

[To be supplied.]

[Visual Basic]
Overloads Public Function CreateDocumentNavigator() As DocumentNavigator
[C#]
public DocumentNavigator CreateDocumentNavigator();
[C++]
public: DocumentNavigator* CreateDocumentNavigator();
[JScript]
public function CreateDocumentNavigator() : DocumentNavigator;

See Also

XmlDocument Class | XmlDocument Members | System.Data.XML Namespace | XmlDocument.CreateDocumentNavigator Overload List


XmlDocument.CreateDocumentReader

[To be supplied.]

[Visual Basic]
Public Function CreateDocumentReader() As DocumentReader
[C#]
public DocumentReader CreateDocumentReader();
[C++]
public: DocumentReader* CreateDocumentReader();
[JScript]
public function CreateDocumentReader() : DocumentReader;

See Also

XmlDocument Class | XmlDocument Members | System.Data.XML Namespace


XmlDocument.Load

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub Load(IDataReader)
[C#] public void Load(IDataReader);
[C++] public: void Load(IDataReader*);
[JScript] public function Load(IDataReader);

[To be supplied.]

[Visual Basic] Overloads Public Sub Load(XmlReader)
[C#] public void Load(XmlReader);
[C++] public: void Load(XmlReader*);
[JScript] public function Load(XmlReader);

See Also

XmlDocument Class | XmlDocument Members | System.Data.XML Namespace


XmlDocument.Load (IDataReader)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Load( _
   ByVal reader As IDataReader _
)
[C#]
public void Load(
   IDataReader reader
);
[C++]
public: void Load(
   IDataReader* reader
);
[JScript]
public function Load(
   reader : IDataReader
);

Parameters

reader
[To be supplied.]

See Also

XmlDocument Class | XmlDocument Members | System.Data.XML Namespace | XmlDocument.Load Overload List


XmlDocument.Load (XmlReader)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Load( _
   ByVal reader As XmlReader _
)
[C#]
public void Load(
   XmlReader reader
);
[C++]
public: void Load(
   XmlReader* reader
);
[JScript]
public function Load(
   reader : XmlReader
);

Parameters

reader
[To be supplied.]

See Also

XmlDocument Class | XmlDocument Members | System.Data.XML Namespace | XmlDocument.Load Overload List


XmlDocument.LoadDataSetMapping

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub LoadDataSetMapping(XmlReader)
[C#] public void LoadDataSetMapping(XmlReader);
[C++] public: void LoadDataSetMapping(XmlReader*);
[JScript] public function LoadDataSetMapping(XmlReader);

[To be supplied.]

[Visual Basic] Overloads Public Sub LoadDataSetMapping(IDataReader)
[C#] public void LoadDataSetMapping(IDataReader);
[C++] public: void LoadDataSetMapping(IDataReader*);
[JScript] public function LoadDataSetMapping(IDataReader);

See Also

XmlDocument Class | XmlDocument Members | System.Data.XML Namespace


XmlDocument.LoadDataSetMapping (XmlReader)

[To be supplied.]

[Visual Basic]
Overloads Public Sub LoadDataSetMapping( _
   ByVal reader As XmlReader _
)
[C#]
public void LoadDataSetMapping(
   XmlReader reader
);
[C++]
public: void LoadDataSetMapping(
   XmlReader* reader
);
[JScript]
public function LoadDataSetMapping(
   reader : XmlReader
);

Parameters

reader
[To be supplied.]

See Also

XmlDocument Class | XmlDocument Members | System.Data.XML Namespace | XmlDocument.LoadDataSetMapping Overload List


XmlDocument.LoadDataSetMapping (IDataReader)

[To be supplied.]

[Visual Basic]
Overloads Public Sub LoadDataSetMapping( _
   ByVal reader As IDataReader _
)
[C#]
public void LoadDataSetMapping(
   IDataReader reader
);
[C++]
public: void LoadDataSetMapping(
   IDataReader* reader
);
[JScript]
public function LoadDataSetMapping(
   reader : IDataReader
);

Parameters

reader
[To be supplied.]

See Also

XmlDocument Class | XmlDocument Members | System.Data.XML Namespace | XmlDocument.LoadDataSetMapping Overload List


XmlDocument.ResetRowVersion

[To be supplied.]

[Visual Basic]
Public Sub ResetRowVersion( _
   ByVal prevVersion As Integer _
)
[C#]
public void ResetRowVersion(
   int prevVersion
);
[C++]
public: void ResetRowVersion(
   int prevVersion
);
[JScript]
public function ResetRowVersion(
   prevVersion : int
);

Parameters

prevVersion
[To be supplied.]

See Also

XmlDocument Class | XmlDocument Members | System.Data.XML Namespace


XmlDocument.Save

[To be supplied.]

[Visual Basic]
Public Sub Save( _
   ByVal writer As TextWriter _
)
[C#]
public void Save(
   TextWriter writer
);
[C++]
public: void Save(
   TextWriter* writer
);
[JScript]
public function Save(
   writer : TextWriter
);

Parameters

writer
[To be supplied.]

See Also

XmlDocument Class | XmlDocument Members | System.Data.XML Namespace


XmlDocument.SaveDataSetMapping

[To be supplied.]

[Visual Basic]
Public Sub SaveDataSetMapping( _
   ByVal writer As TextWriter _
)
[C#]
public void SaveDataSetMapping(
   TextWriter writer
);
[C++]
public: void SaveDataSetMapping(
   TextWriter* writer
);
[JScript]
public function SaveDataSetMapping(
   writer : TextWriter
);

Parameters

writer
[To be supplied.]

See Also

XmlDocument Class | XmlDocument Members | System.Data.XML Namespace


XmlException Class

[To be supplied.]

Object
Exception
SystemException
ExternalException
XmlException

[Visual Basic]
Public Class XmlException
   Inherits ExternalException
[C#]
public class XmlException : ExternalException
[C++]
public __gc class XmlException : public ExternalException
[JScript]
public class XmlException extends ExternalException

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

XmlException Members | System.Data.XML Namespace


XmlException Members

Public:

Constructor

XmlException Constructor Overloaded. [To be supplied.]

Properties

ErrorCode (inherited from ExternalException) | [To be supplied.]
HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message | [To be supplied.]
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Fields

ANNOTATIONLOCATION | [To be supplied.]
ATTLISTPRESENCE | [To be supplied.]
ATTRIBUTEVALUEDATATYPE | [To be supplied.]
BADATTRIBUTECHAR | [To be supplied.]
BADCOLON | [To be supplied.]
BADCOMMENT | [To be supplied.]
BADDECIMALENTITY | [To be supplied.]
BADEDATA | [To be supplied.]
BADHEXENTITY | [To be supplied.]
BADNAMECHAR | [To be supplied.]
BADSTARTNAMECHAR | [To be supplied.]
BADXMLDECLCASE | [To be supplied.]
DATATYPETEXTONLY | [To be supplied.]
DEFAULTFIXEDATTRIBUTES | [To be supplied.]
DEFAULTIDVALUE | [To be supplied.]
DERIVEDBYNOTALLOWED | [To be supplied.]
DTMAXLENGTHINVALID | [To be supplied.]
DTMINLENGTHINVALID | [To be supplied.]
DTMINMAXLENGTH | [To be supplied.]
DUPATTRIBUTE | [To be supplied.]
DUPATTRIBUTEGROUP | [To be supplied.]
DUPATTRIBUTEVALUE | [To be supplied.]
DUPCOMPLEXTYPE | [To be supplied.]
DUPCONSTRAINT | [To be supplied.]
DUPDTMAXLENGTH | [To be supplied.]
DUPDTMINLENGTH | [To be supplied.]
DUPDTTYPE | [To be supplied.]
DUPELEMENT | [To be supplied.]
DUPELEMENTDECL | [To be supplied.]
DUPENTITY | [To be supplied.]
DUPGROUP | [To be supplied.]
DUPID | [To be supplied.]
DUPIDATTRIBUTE | [To be supplied.]
DUPNOTATION | [To be supplied.]
DUPPARENTITY | [To be supplied.]
DUPSIMPLETYPE | [To be supplied.]
DUPXSDELEMENT | [To be supplied.]
ELEMENTMISSING | [To be supplied.]
ELEMENTNOTALLOWED | [To be supplied.]
ELEMENTREF | [To be supplied.]
EMPTYATTRIBUTEVALUE | [To be supplied.]
EMPTYCONTENT | [To be supplied.]
EMPTYSCHEMACOLLECTION | [To be supplied.]
ENUMERATIONVALUE | [To be supplied.]
EXTERNALENTITYINATTVALUE | [To be supplied.]
FIRST | [To be supplied.]
FIXEDATTRIBUTEVALUE | [To be supplied.]
FORBIDDENATTRIBUTE | [To be supplied.]
GROUPDISABLED | [To be supplied.]
IMPORTLOCATION | [To be supplied.]
INCLUDELOCATION | [To be supplied.]
INCOMPLETECONTENT | [To be supplied.]
INTERNALERROR | [To be supplied.]
INVALIDATTRIBUTEDEFAULT | [To be supplied.]
INVALIDATTRIBUTEVALUE | [To be supplied.]
INVALIDATTTYPE | [To be supplied.]
INVALIDBLOCKDEFAULTVALUE | [To be supplied.]
INVALIDBLOCKVALUE | [To be supplied.]
INVALIDCHARACTER | [To be supplied.]
INVALIDCONDSECT | [To be supplied.]
INVALIDCONTENT | [To be supplied.]
INVALIDCONTENTEXPECTING | [To be supplied.]
INVALIDCONTENTMODEL | [To be supplied.]
INVALIDCONTENTVALUE | [To be supplied.]
INVALIDDEPTH | [To be supplied.]
INVALIDDERIVEDBYVALUE | [To be supplied.]
INVALIDFINALDEFAULTVALUE | [To be supplied.]
INVALIDFINALVALUE | [To be supplied.]
INVALIDID | [To be supplied.]
INVALIDNAME | [To be supplied.]
INVALIDNODETYPE | [To be supplied.]
INVALIDPARENTITYREF | [To be supplied.]
INVALIDPINAME | [To be supplied.]
INVALIDPROCESSCONTENTVALUE | [To be supplied.]
INVALIDROOTDATA | [To be supplied.]
INVALIDTEXTDECL | [To be supplied.]
INVALIDVALUE | [To be supplied.]
INVALIDXMLDECL | [To be supplied.]
INVALIDXMLLANG | [To be supplied.]
INVALIDXMLSPACE | [To be supplied.]
LAST | [To be supplied.]
MANYMAXOCCURS | [To be supplied.]
MAXOCCURSINVALID | [To be supplied.]
MINOCCURSINVALID | [To be supplied.]
MISSATTRIBUTE | [To be supplied.]
MISSDTTYPEVALUE | [To be supplied.]
MISSDTVALUESATTRIBUTE | [To be supplied.]
MISSINGBOM | [To be supplied.]
MISSINGROOT | [To be supplied.]
MISSREQUIREDATTRIBUTE | [To be supplied.]
MIXEDMANY | [To be supplied.]
MULTIPLEATTRIBUTEVALUE | [To be supplied.]
MULTIPLEROOTS | [To be supplied.]
NAMEREF | [To be supplied.]
NOCOLONENTITYNAME | [To be supplied.]
NOELEMENTCONTENT | [To be supplied.]
NOHANDLER | [To be supplied.]
NOINPUT | [To be supplied.]
NOPARTICLE | [To be supplied.]
NOTATIONVALUE | [To be supplied.]
NOTIMPLEMENTED | [To be supplied.]
NOTINSCHEMACOLLECTION | [To be supplied.]
NOTSAMENAMETABLE | [To be supplied.]
NUMENTITYOVERFLOW | [To be supplied.]
PARENTITYREFNESTING | [To be supplied.]
RECURSIVEGENENTITY | [To be supplied.]
RECURSIVEPARENTITY | [To be supplied.]
REQUIREENUMERATION | [To be supplied.]
RESERVEDNS | [To be supplied.]
RESERVEDNSDECL | [To be supplied.]
ROOTMATCHDOCTYPE | [To be supplied.]
SCHEMAROOTEXPECTED | [To be supplied.]
SCH_START | [To be supplied.]
TAGMISMATCH | [To be supplied.]
TEXTDECLPOSITION | [To be supplied.]
TEXTNOTALLOWED | [To be supplied.]
TYPEMUTUALEXCLUSIVE | [To be supplied.]
UNCLOSEDQUOTE | [To be supplied.]
UNDECLAREDATTRIBUTE | [To be supplied.]
UNDECLAREDELEMENT | [To be supplied.]
UNDECLAREDENTITY | [To be supplied.]
UNDECLAREDEQUIVCLASS | [To be supplied.]
UNDECLAREDID | [To be supplied.]
UNDECLAREDNOTATION | [To be supplied.]
UNDECLAREDPARENTITY | [To be supplied.]
UNDECLAREDTYPE | [To be supplied.]
UNEXPECTEDCDATAEND | [To be supplied.]
UNEXPECTEDCHAR | [To be supplied.]
UNEXPECTEDENDTAG | [To be supplied.]
UNEXPECTEDEOF | [To be supplied.]
UNEXPECTEDTOKEN | [To be supplied.]
UNEXPECTEDWS | [To be supplied.]
UNKNOWNCONTENT | [To be supplied.]
UNKNOWNDTTYPE | [To be supplied.]
UNKNOWNENCODING | [To be supplied.]
UNKNOWNMODEL | [To be supplied.]
UNKNOWNNS | [To be supplied.]
UNKNOWNORDER | [To be supplied.]
UNKNOWNREQUIRED | [To be supplied.]
UNPARSEDENTITY | [To be supplied.]
UNPARSEDENTITYREF | [To be supplied.]
UNSUPPORTEDATTRIBUTE | [To be supplied.]
UNSUPPORTEDELEMENT | [To be supplied.]
VALIDATEELEMENT | [To be supplied.]
WRITER_START | [To be supplied.]
XMLDECLNOTFIRST | [To be supplied.]
XML_LAST | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

XmlException Class | System.Data.XML Namespace


XmlException Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public XmlException(int);
[C++] public: XmlException(int);
[JScript] public function XmlException(int);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer, String())
[C#] public XmlException(int, String[]);
[C++] public: XmlException(int, String[]);
[JScript] public function XmlException(int, String[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer, String)
[C#] public XmlException(int, String);
[C++] public: XmlException(int, String);
[JScript] public function XmlException(int, String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer, String(), Integer, Integer)
[C#] public XmlException(int, String[], int, int);
[C++] public: XmlException(int, String[], int, int);
[JScript] public function XmlException(int, String[], int, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer, String, Integer, Integer)
[C#] public XmlException(int, String, int, int);
[C++] public: XmlException(int, String, int, int);
[JScript] public function XmlException(int, String, int, int);

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException Constructor (Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal hr As Integer _
)
[C#]
public XmlException(
   int hr
);
[C++]
public: XmlException(
   int hr
);
[JScript]
public function XmlException(
   hr : int
);

Parameters

hr
[To be supplied.]

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace | XmlException Constructor Overload List


XmlException Constructor (Int32, String[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal hr As Integer, _
   ByVal args() As String _
)
[C#]
public XmlException(
   int hr,
   string[] args
);
[C++]
public: XmlException(
   int hr,
   String* args[]
);
[JScript]
public function XmlException(
   hr : int,
   args : String[]
);

Parameters

hr
[To be supplied.]
args
[To be supplied.]

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace | XmlException Constructor Overload List


XmlException Constructor (Int32, String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal hr As Integer, _
   ByVal arg As String _
)
[C#]
public XmlException(
   int hr,
   string arg
);
[C++]
public: XmlException(
   int hr,
   String* arg
);
[JScript]
public function XmlException(
   hr : int,
   arg : String
);

Parameters

hr
[To be supplied.]
arg
[To be supplied.]

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace | XmlException Constructor Overload List


XmlException Constructor (Int32, String[], Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal hr As Integer, _
   ByVal args() As String, _
   ByVal nLine As Integer, _
   ByVal nPos As Integer _
)
[C#]
public XmlException(
   int hr,
   string[] args,
   int nLine,
   int nPos
);
[C++]
public: XmlException(
   int hr,
   String* args[],
   int nLine,
   int nPos
);
[JScript]
public function XmlException(
   hr : int,
   args : String[],
   nLine : int,
   nPos : int
);

Parameters

hr
[To be supplied.]
args
[To be supplied.]
nLine
[To be supplied.]
nPos
[To be supplied.]

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace | XmlException Constructor Overload List


XmlException Constructor (Int32, String, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal hr As Integer, _
   ByVal arg As String, _
   ByVal nLine As Integer, _
   ByVal nPos As Integer _
)
[C#]
public XmlException(
   int hr,
   string arg,
   int nLine,
   int nPos
);
[C++]
public: XmlException(
   int hr,
   String* arg,
   int nLine,
   int nPos
);
[JScript]
public function XmlException(
   hr : int,
   arg : String,
   nLine : int,
   nPos : int
);

Parameters

hr
[To be supplied.]
arg
[To be supplied.]
nLine
[To be supplied.]
nPos
[To be supplied.]

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace | XmlException Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlException Properties

The properties of the XmlException class are listed below. For a complete list of XmlException class members, see the XmlException Members topic.

Public:

ErrorCode (inherited from ExternalException) | [To be supplied.]
HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message | [To be supplied.]
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

See Also

XmlException Class | System.Data.XML Namespace


XmlException.Message

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Message As String
[C#]
public string Message {override get;}
[C++]
public: __property virtual String* get_Message();
[JScript]
public function get Message() : String;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlException Fields

The fields of the XmlException class are listed below. For a complete list of XmlException class members, see the XmlException Members topic.

Public:

ANNOTATIONLOCATION | [To be supplied.]
ATTLISTPRESENCE | [To be supplied.]
ATTRIBUTEVALUEDATATYPE | [To be supplied.]
BADATTRIBUTECHAR | [To be supplied.]
BADCOLON | [To be supplied.]
BADCOMMENT | [To be supplied.]
BADDECIMALENTITY | [To be supplied.]
BADEDATA | [To be supplied.]
BADHEXENTITY | [To be supplied.]
BADNAMECHAR | [To be supplied.]
BADSTARTNAMECHAR | [To be supplied.]
BADXMLDECLCASE | [To be supplied.]
DATATYPETEXTONLY | [To be supplied.]
DEFAULTFIXEDATTRIBUTES | [To be supplied.]
DEFAULTIDVALUE | [To be supplied.]
DERIVEDBYNOTALLOWED | [To be supplied.]
DTMAXLENGTHINVALID | [To be supplied.]
DTMINLENGTHINVALID | [To be supplied.]
DTMINMAXLENGTH | [To be supplied.]
DUPATTRIBUTE | [To be supplied.]
DUPATTRIBUTEGROUP | [To be supplied.]
DUPATTRIBUTEVALUE | [To be supplied.]
DUPCOMPLEXTYPE | [To be supplied.]
DUPCONSTRAINT | [To be supplied.]
DUPDTMAXLENGTH | [To be supplied.]
DUPDTMINLENGTH | [To be supplied.]
DUPDTTYPE | [To be supplied.]
DUPELEMENT | [To be supplied.]
DUPELEMENTDECL | [To be supplied.]
DUPENTITY | [To be supplied.]
DUPGROUP | [To be supplied.]
DUPID | [To be supplied.]
DUPIDATTRIBUTE | [To be supplied.]
DUPNOTATION | [To be supplied.]
DUPPARENTITY | [To be supplied.]
DUPSIMPLETYPE | [To be supplied.]
DUPXSDELEMENT | [To be supplied.]
ELEMENTMISSING | [To be supplied.]
ELEMENTNOTALLOWED | [To be supplied.]
ELEMENTREF | [To be supplied.]
EMPTYATTRIBUTEVALUE | [To be supplied.]
EMPTYCONTENT | [To be supplied.]
EMPTYSCHEMACOLLECTION | [To be supplied.]
ENUMERATIONVALUE | [To be supplied.]
EXTERNALENTITYINATTVALUE | [To be supplied.]
FIRST | [To be supplied.]
FIXEDATTRIBUTEVALUE | [To be supplied.]
FORBIDDENATTRIBUTE | [To be supplied.]
GROUPDISABLED | [To be supplied.]
IMPORTLOCATION | [To be supplied.]
INCLUDELOCATION | [To be supplied.]
INCOMPLETECONTENT | [To be supplied.]
INTERNALERROR | [To be supplied.]
INVALIDATTRIBUTEDEFAULT | [To be supplied.]
INVALIDATTRIBUTEVALUE | [To be supplied.]
INVALIDATTTYPE | [To be supplied.]
INVALIDBLOCKDEFAULTVALUE | [To be supplied.]
INVALIDBLOCKVALUE | [To be supplied.]
INVALIDCHARACTER | [To be supplied.]
INVALIDCONDSECT | [To be supplied.]
INVALIDCONTENT | [To be supplied.]
INVALIDCONTENTEXPECTING | [To be supplied.]
INVALIDCONTENTMODEL | [To be supplied.]
INVALIDCONTENTVALUE | [To be supplied.]
INVALIDDEPTH | [To be supplied.]
INVALIDDERIVEDBYVALUE | [To be supplied.]
INVALIDFINALDEFAULTVALUE | [To be supplied.]
INVALIDFINALVALUE | [To be supplied.]
INVALIDID | [To be supplied.]
INVALIDNAME | [To be supplied.]
INVALIDNODETYPE | [To be supplied.]
INVALIDPARENTITYREF | [To be supplied.]
INVALIDPINAME | [To be supplied.]
INVALIDPROCESSCONTENTVALUE | [To be supplied.]
INVALIDROOTDATA | [To be supplied.]
INVALIDTEXTDECL | [To be supplied.]
INVALIDVALUE | [To be supplied.]
INVALIDXMLDECL | [To be supplied.]
INVALIDXMLLANG | [To be supplied.]
INVALIDXMLSPACE | [To be supplied.]
LAST | [To be supplied.]
MANYMAXOCCURS | [To be supplied.]
MAXOCCURSINVALID | [To be supplied.]
MINOCCURSINVALID | [To be supplied.]
MISSATTRIBUTE | [To be supplied.]
MISSDTTYPEVALUE | [To be supplied.]
MISSDTVALUESATTRIBUTE | [To be supplied.]
MISSINGBOM | [To be supplied.]
MISSINGROOT | [To be supplied.]
MISSREQUIREDATTRIBUTE | [To be supplied.]
MIXEDMANY | [To be supplied.]
MULTIPLEATTRIBUTEVALUE | [To be supplied.]
MULTIPLEROOTS | [To be supplied.]
NAMEREF | [To be supplied.]
NOCOLONENTITYNAME | [To be supplied.]
NOELEMENTCONTENT | [To be supplied.]
NOHANDLER | [To be supplied.]
NOINPUT | [To be supplied.]
NOPARTICLE | [To be supplied.]
NOTATIONVALUE | [To be supplied.]
NOTIMPLEMENTED | [To be supplied.]
NOTINSCHEMACOLLECTION | [To be supplied.]
NOTSAMENAMETABLE | [To be supplied.]
NUMENTITYOVERFLOW | [To be supplied.]
PARENTITYREFNESTING | [To be supplied.]
RECURSIVEGENENTITY | [To be supplied.]
RECURSIVEPARENTITY | [To be supplied.]
REQUIREENUMERATION | [To be supplied.]
RESERVEDNS | [To be supplied.]
RESERVEDNSDECL | [To be supplied.]
ROOTMATCHDOCTYPE | [To be supplied.]
SCHEMAROOTEXPECTED | [To be supplied.]
SCH_START | [To be supplied.]
TAGMISMATCH | [To be supplied.]
TEXTDECLPOSITION | [To be supplied.]
TEXTNOTALLOWED | [To be supplied.]
TYPEMUTUALEXCLUSIVE | [To be supplied.]
UNCLOSEDQUOTE | [To be supplied.]
UNDECLAREDATTRIBUTE | [To be supplied.]
UNDECLAREDELEMENT | [To be supplied.]
UNDECLAREDENTITY | [To be supplied.]
UNDECLAREDEQUIVCLASS | [To be supplied.]
UNDECLAREDID | [To be supplied.]
UNDECLAREDNOTATION | [To be supplied.]
UNDECLAREDPARENTITY | [To be supplied.]
UNDECLAREDTYPE | [To be supplied.]
UNEXPECTEDCDATAEND | [To be supplied.]
UNEXPECTEDCHAR | [To be supplied.]
UNEXPECTEDENDTAG | [To be supplied.]
UNEXPECTEDEOF | [To be supplied.]
UNEXPECTEDTOKEN | [To be supplied.]
UNEXPECTEDWS | [To be supplied.]
UNKNOWNCONTENT | [To be supplied.]
UNKNOWNDTTYPE | [To be supplied.]
UNKNOWNENCODING | [To be supplied.]
UNKNOWNMODEL | [To be supplied.]
UNKNOWNNS | [To be supplied.]
UNKNOWNORDER | [To be supplied.]
UNKNOWNREQUIRED | [To be supplied.]
UNPARSEDENTITY | [To be supplied.]
UNPARSEDENTITYREF | [To be supplied.]
UNSUPPORTEDATTRIBUTE | [To be supplied.]
UNSUPPORTEDELEMENT | [To be supplied.]
VALIDATEELEMENT | [To be supplied.]
WRITER_START | [To be supplied.]
XMLDECLNOTFIRST | [To be supplied.]
XML_LAST | [To be supplied.]

Protected:

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

XmlException Class | System.Data.XML Namespace


XmlException.ANNOTATIONLOCATION

[To be supplied.]

[Visual Basic]
Public Const ANNOTATIONLOCATION As Integer
[C#]
public const int ANNOTATIONLOCATION;
[C++]
public: const int ANNOTATIONLOCATION;
[JScript]
public var ANNOTATIONLOCATION : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.ATTLISTPRESENCE

[To be supplied.]

[Visual Basic]
Public Const ATTLISTPRESENCE As Integer
[C#]
public const int ATTLISTPRESENCE;
[C++]
public: const int ATTLISTPRESENCE;
[JScript]
public var ATTLISTPRESENCE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.ATTRIBUTEVALUEDATATYPE

[To be supplied.]

[Visual Basic]
Public Const ATTRIBUTEVALUEDATATYPE As Integer
[C#]
public const int ATTRIBUTEVALUEDATATYPE;
[C++]
public: const int ATTRIBUTEVALUEDATATYPE;
[JScript]
public var ATTRIBUTEVALUEDATATYPE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.BADATTRIBUTECHAR

[To be supplied.]

[Visual Basic]
Public Const BADATTRIBUTECHAR As Integer
[C#]
public const int BADATTRIBUTECHAR;
[C++]
public: const int BADATTRIBUTECHAR;
[JScript]
public var BADATTRIBUTECHAR : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.BADCOLON

[To be supplied.]

[Visual Basic]
Public Const BADCOLON As Integer
[C#]
public const int BADCOLON;
[C++]
public: const int BADCOLON;
[JScript]
public var BADCOLON : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.BADCOMMENT

[To be supplied.]

[Visual Basic]
Public Const BADCOMMENT As Integer
[C#]
public const int BADCOMMENT;
[C++]
public: const int BADCOMMENT;
[JScript]
public var BADCOMMENT : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.BADDECIMALENTITY

[To be supplied.]

[Visual Basic]
Public Const BADDECIMALENTITY As Integer
[C#]
public const int BADDECIMALENTITY;
[C++]
public: const int BADDECIMALENTITY;
[JScript]
public var BADDECIMALENTITY : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.BADEDATA

[To be supplied.]

[Visual Basic]
Public Const BADEDATA As Integer
[C#]
public const int BADEDATA;
[C++]
public: const int BADEDATA;
[JScript]
public var BADEDATA : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.BADHEXENTITY

[To be supplied.]

[Visual Basic]
Public Const BADHEXENTITY As Integer
[C#]
public const int BADHEXENTITY;
[C++]
public: const int BADHEXENTITY;
[JScript]
public var BADHEXENTITY : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.BADNAMECHAR

[To be supplied.]

[Visual Basic]
Public Const BADNAMECHAR As Integer
[C#]
public const int BADNAMECHAR;
[C++]
public: const int BADNAMECHAR;
[JScript]
public var BADNAMECHAR : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.BADSTARTNAMECHAR

[To be supplied.]

[Visual Basic]
Public Const BADSTARTNAMECHAR As Integer
[C#]
public const int BADSTARTNAMECHAR;
[C++]
public: const int BADSTARTNAMECHAR;
[JScript]
public var BADSTARTNAMECHAR : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.BADXMLDECLCASE

[To be supplied.]

[Visual Basic]
Public Const BADXMLDECLCASE As Integer
[C#]
public const int BADXMLDECLCASE;
[C++]
public: const int BADXMLDECLCASE;
[JScript]
public var BADXMLDECLCASE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.DATATYPETEXTONLY

[To be supplied.]

[Visual Basic]
Public Const DATATYPETEXTONLY As Integer
[C#]
public const int DATATYPETEXTONLY;
[C++]
public: const int DATATYPETEXTONLY;
[JScript]
public var DATATYPETEXTONLY : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.DEFAULTFIXEDATTRIBUTES

[To be supplied.]

[Visual Basic]
Public Const DEFAULTFIXEDATTRIBUTES As Integer
[C#]
public const int DEFAULTFIXEDATTRIBUTES;
[C++]
public: const int DEFAULTFIXEDATTRIBUTES;
[JScript]
public var DEFAULTFIXEDATTRIBUTES : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.DEFAULTIDVALUE

[To be supplied.]

[Visual Basic]
Public Const DEFAULTIDVALUE As Integer
[C#]
public const int DEFAULTIDVALUE;
[C++]
public: const int DEFAULTIDVALUE;
[JScript]
public var DEFAULTIDVALUE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.DERIVEDBYNOTALLOWED

[To be supplied.]

[Visual Basic]
Public Const DERIVEDBYNOTALLOWED As Integer
[C#]
public const int DERIVEDBYNOTALLOWED;
[C++]
public: const int DERIVEDBYNOTALLOWED;
[JScript]
public var DERIVEDBYNOTALLOWED : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.DTMAXLENGTHINVALID

[To be supplied.]

[Visual Basic]
Public Const DTMAXLENGTHINVALID As Integer
[C#]
public const int DTMAXLENGTHINVALID;
[C++]
public: const int DTMAXLENGTHINVALID;
[JScript]
public var DTMAXLENGTHINVALID : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.DTMINLENGTHINVALID

[To be supplied.]

[Visual Basic]
Public Const DTMINLENGTHINVALID As Integer
[C#]
public const int DTMINLENGTHINVALID;
[C++]
public: const int DTMINLENGTHINVALID;
[JScript]
public var DTMINLENGTHINVALID : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.DTMINMAXLENGTH

[To be supplied.]

[Visual Basic]
Public Const DTMINMAXLENGTH As Integer
[C#]
public const int DTMINMAXLENGTH;
[C++]
public: const int DTMINMAXLENGTH;
[JScript]
public var DTMINMAXLENGTH : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.DUPATTRIBUTE

[To be supplied.]

[Visual Basic]
Public Const DUPATTRIBUTE As Integer
[C#]
public const int DUPATTRIBUTE;
[C++]
public: const int DUPATTRIBUTE;
[JScript]
public var DUPATTRIBUTE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.DUPATTRIBUTEGROUP

[To be supplied.]

[Visual Basic]
Public Const DUPATTRIBUTEGROUP As Integer
[C#]
public const int DUPATTRIBUTEGROUP;
[C++]
public: const int DUPATTRIBUTEGROUP;
[JScript]
public var DUPATTRIBUTEGROUP : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.DUPATTRIBUTEVALUE

[To be supplied.]

[Visual Basic]
Public Const DUPATTRIBUTEVALUE As Integer
[C#]
public const int DUPATTRIBUTEVALUE;
[C++]
public: const int DUPATTRIBUTEVALUE;
[JScript]
public var DUPATTRIBUTEVALUE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.DUPCOMPLEXTYPE

[To be supplied.]

[Visual Basic]
Public Const DUPCOMPLEXTYPE As Integer
[C#]
public const int DUPCOMPLEXTYPE;
[C++]
public: const int DUPCOMPLEXTYPE;
[JScript]
public var DUPCOMPLEXTYPE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.DUPCONSTRAINT

[To be supplied.]

[Visual Basic]
Public Const DUPCONSTRAINT As Integer
[C#]
public const int DUPCONSTRAINT;
[C++]
public: const int DUPCONSTRAINT;
[JScript]
public var DUPCONSTRAINT : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.DUPDTMAXLENGTH

[To be supplied.]

[Visual Basic]
Public Const DUPDTMAXLENGTH As Integer
[C#]
public const int DUPDTMAXLENGTH;
[C++]
public: const int DUPDTMAXLENGTH;
[JScript]
public var DUPDTMAXLENGTH : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.DUPDTMINLENGTH

[To be supplied.]

[Visual Basic]
Public Const DUPDTMINLENGTH As Integer
[C#]
public const int DUPDTMINLENGTH;
[C++]
public: const int DUPDTMINLENGTH;
[JScript]
public var DUPDTMINLENGTH : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.DUPDTTYPE

[To be supplied.]

[Visual Basic]
Public Const DUPDTTYPE As Integer
[C#]
public const int DUPDTTYPE;
[C++]
public: const int DUPDTTYPE;
[JScript]
public var DUPDTTYPE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.DUPELEMENT

[To be supplied.]

[Visual Basic]
Public Const DUPELEMENT As Integer
[C#]
public const int DUPELEMENT;
[C++]
public: const int DUPELEMENT;
[JScript]
public var DUPELEMENT : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.DUPELEMENTDECL

[To be supplied.]

[Visual Basic]
Public Const DUPELEMENTDECL As Integer
[C#]
public const int DUPELEMENTDECL;
[C++]
public: const int DUPELEMENTDECL;
[JScript]
public var DUPELEMENTDECL : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.DUPENTITY

[To be supplied.]

[Visual Basic]
Public Const DUPENTITY As Integer
[C#]
public const int DUPENTITY;
[C++]
public: const int DUPENTITY;
[JScript]
public var DUPENTITY : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.DUPGROUP

[To be supplied.]

[Visual Basic]
Public Const DUPGROUP As Integer
[C#]
public const int DUPGROUP;
[C++]
public: const int DUPGROUP;
[JScript]
public var DUPGROUP : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.DUPID

[To be supplied.]

[Visual Basic]
Public Const DUPID As Integer
[C#]
public const int DUPID;
[C++]
public: const int DUPID;
[JScript]
public var DUPID : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.DUPIDATTRIBUTE

[To be supplied.]

[Visual Basic]
Public Const DUPIDATTRIBUTE As Integer
[C#]
public const int DUPIDATTRIBUTE;
[C++]
public: const int DUPIDATTRIBUTE;
[JScript]
public var DUPIDATTRIBUTE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.DUPNOTATION

[To be supplied.]

[Visual Basic]
Public Const DUPNOTATION As Integer
[C#]
public const int DUPNOTATION;
[C++]
public: const int DUPNOTATION;
[JScript]
public var DUPNOTATION : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.DUPPARENTITY

[To be supplied.]

[Visual Basic]
Public Const DUPPARENTITY As Integer
[C#]
public const int DUPPARENTITY;
[C++]
public: const int DUPPARENTITY;
[JScript]
public var DUPPARENTITY : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.DUPSIMPLETYPE

[To be supplied.]

[Visual Basic]
Public Const DUPSIMPLETYPE As Integer
[C#]
public const int DUPSIMPLETYPE;
[C++]
public: const int DUPSIMPLETYPE;
[JScript]
public var DUPSIMPLETYPE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.DUPXSDELEMENT

[To be supplied.]

[Visual Basic]
Public Const DUPXSDELEMENT As Integer
[C#]
public const int DUPXSDELEMENT;
[C++]
public: const int DUPXSDELEMENT;
[JScript]
public var DUPXSDELEMENT : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.ELEMENTMISSING

[To be supplied.]

[Visual Basic]
Public Const ELEMENTMISSING As Integer
[C#]
public const int ELEMENTMISSING;
[C++]
public: const int ELEMENTMISSING;
[JScript]
public var ELEMENTMISSING : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.ELEMENTNOTALLOWED

[To be supplied.]

[Visual Basic]
Public Const ELEMENTNOTALLOWED As Integer
[C#]
public const int ELEMENTNOTALLOWED;
[C++]
public: const int ELEMENTNOTALLOWED;
[JScript]
public var ELEMENTNOTALLOWED : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.ELEMENTREF

[To be supplied.]

[Visual Basic]
Public Const ELEMENTREF As Integer
[C#]
public const int ELEMENTREF;
[C++]
public: const int ELEMENTREF;
[JScript]
public var ELEMENTREF : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.EMPTYATTRIBUTEVALUE

[To be supplied.]

[Visual Basic]
Public Const EMPTYATTRIBUTEVALUE As Integer
[C#]
public const int EMPTYATTRIBUTEVALUE;
[C++]
public: const int EMPTYATTRIBUTEVALUE;
[JScript]
public var EMPTYATTRIBUTEVALUE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.EMPTYCONTENT

[To be supplied.]

[Visual Basic]
Public Const EMPTYCONTENT As Integer
[C#]
public const int EMPTYCONTENT;
[C++]
public: const int EMPTYCONTENT;
[JScript]
public var EMPTYCONTENT : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.EMPTYSCHEMACOLLECTION

[To be supplied.]

[Visual Basic]
Public Const EMPTYSCHEMACOLLECTION As Integer
[C#]
public const int EMPTYSCHEMACOLLECTION;
[C++]
public: const int EMPTYSCHEMACOLLECTION;
[JScript]
public var EMPTYSCHEMACOLLECTION : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.ENUMERATIONVALUE

[To be supplied.]

[Visual Basic]
Public Const ENUMERATIONVALUE As Integer
[C#]
public const int ENUMERATIONVALUE;
[C++]
public: const int ENUMERATIONVALUE;
[JScript]
public var ENUMERATIONVALUE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.EXTERNALENTITYINATTVALUE

[To be supplied.]

[Visual Basic]
Public Const EXTERNALENTITYINATTVALUE As Integer
[C#]
public const int EXTERNALENTITYINATTVALUE;
[C++]
public: const int EXTERNALENTITYINATTVALUE;
[JScript]
public var EXTERNALENTITYINATTVALUE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.FIRST

[To be supplied.]

[Visual Basic]
Public Const FIRST As Integer
[C#]
public const int FIRST;
[C++]
public: const int FIRST;
[JScript]
public var FIRST : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.FIXEDATTRIBUTEVALUE

[To be supplied.]

[Visual Basic]
Public Const FIXEDATTRIBUTEVALUE As Integer
[C#]
public const int FIXEDATTRIBUTEVALUE;
[C++]
public: const int FIXEDATTRIBUTEVALUE;
[JScript]
public var FIXEDATTRIBUTEVALUE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.FORBIDDENATTRIBUTE

[To be supplied.]

[Visual Basic]
Public Const FORBIDDENATTRIBUTE As Integer
[C#]
public const int FORBIDDENATTRIBUTE;
[C++]
public: const int FORBIDDENATTRIBUTE;
[JScript]
public var FORBIDDENATTRIBUTE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.GROUPDISABLED

[To be supplied.]

[Visual Basic]
Public Const GROUPDISABLED As Integer
[C#]
public const int GROUPDISABLED;
[C++]
public: const int GROUPDISABLED;
[JScript]
public var GROUPDISABLED : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.IMPORTLOCATION

[To be supplied.]

[Visual Basic]
Public Const IMPORTLOCATION As Integer
[C#]
public const int IMPORTLOCATION;
[C++]
public: const int IMPORTLOCATION;
[JScript]
public var IMPORTLOCATION : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.INCLUDELOCATION

[To be supplied.]

[Visual Basic]
Public Const INCLUDELOCATION As Integer
[C#]
public const int INCLUDELOCATION;
[C++]
public: const int INCLUDELOCATION;
[JScript]
public var INCLUDELOCATION : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.INCOMPLETECONTENT

[To be supplied.]

[Visual Basic]
Public Const INCOMPLETECONTENT As Integer
[C#]
public const int INCOMPLETECONTENT;
[C++]
public: const int INCOMPLETECONTENT;
[JScript]
public var INCOMPLETECONTENT : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.INTERNALERROR

[To be supplied.]

[Visual Basic]
Public Const INTERNALERROR As Integer
[C#]
public const int INTERNALERROR;
[C++]
public: const int INTERNALERROR;
[JScript]
public var INTERNALERROR : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.INVALIDATTRIBUTEDEFAULT

[To be supplied.]

[Visual Basic]
Public Const INVALIDATTRIBUTEDEFAULT As Integer
[C#]
public const int INVALIDATTRIBUTEDEFAULT;
[C++]
public: const int INVALIDATTRIBUTEDEFAULT;
[JScript]
public var INVALIDATTRIBUTEDEFAULT : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.INVALIDATTRIBUTEVALUE

[To be supplied.]

[Visual Basic]
Public Const INVALIDATTRIBUTEVALUE As Integer
[C#]
public const int INVALIDATTRIBUTEVALUE;
[C++]
public: const int INVALIDATTRIBUTEVALUE;
[JScript]
public var INVALIDATTRIBUTEVALUE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.INVALIDATTTYPE

[To be supplied.]

[Visual Basic]
Public Const INVALIDATTTYPE As Integer
[C#]
public const int INVALIDATTTYPE;
[C++]
public: const int INVALIDATTTYPE;
[JScript]
public var INVALIDATTTYPE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.INVALIDBLOCKDEFAULTVALUE

[To be supplied.]

[Visual Basic]
Public Const INVALIDBLOCKDEFAULTVALUE As Integer
[C#]
public const int INVALIDBLOCKDEFAULTVALUE;
[C++]
public: const int INVALIDBLOCKDEFAULTVALUE;
[JScript]
public var INVALIDBLOCKDEFAULTVALUE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.INVALIDBLOCKVALUE

[To be supplied.]

[Visual Basic]
Public Const INVALIDBLOCKVALUE As Integer
[C#]
public const int INVALIDBLOCKVALUE;
[C++]
public: const int INVALIDBLOCKVALUE;
[JScript]
public var INVALIDBLOCKVALUE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.INVALIDCHARACTER

[To be supplied.]

[Visual Basic]
Public Const INVALIDCHARACTER As Integer
[C#]
public const int INVALIDCHARACTER;
[C++]
public: const int INVALIDCHARACTER;
[JScript]
public var INVALIDCHARACTER : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.INVALIDCONDSECT

[To be supplied.]

[Visual Basic]
Public Const INVALIDCONDSECT As Integer
[C#]
public const int INVALIDCONDSECT;
[C++]
public: const int INVALIDCONDSECT;
[JScript]
public var INVALIDCONDSECT : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.INVALIDCONTENT

[To be supplied.]

[Visual Basic]
Public Const INVALIDCONTENT As Integer
[C#]
public const int INVALIDCONTENT;
[C++]
public: const int INVALIDCONTENT;
[JScript]
public var INVALIDCONTENT : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.INVALIDCONTENTEXPECTING

[To be supplied.]

[Visual Basic]
Public Const INVALIDCONTENTEXPECTING As Integer
[C#]
public const int INVALIDCONTENTEXPECTING;
[C++]
public: const int INVALIDCONTENTEXPECTING;
[JScript]
public var INVALIDCONTENTEXPECTING : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.INVALIDCONTENTMODEL

[To be supplied.]

[Visual Basic]
Public Const INVALIDCONTENTMODEL As Integer
[C#]
public const int INVALIDCONTENTMODEL;
[C++]
public: const int INVALIDCONTENTMODEL;
[JScript]
public var INVALIDCONTENTMODEL : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.INVALIDCONTENTVALUE

[To be supplied.]

[Visual Basic]
Public Const INVALIDCONTENTVALUE As Integer
[C#]
public const int INVALIDCONTENTVALUE;
[C++]
public: const int INVALIDCONTENTVALUE;
[JScript]
public var INVALIDCONTENTVALUE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.INVALIDDEPTH

[To be supplied.]

[Visual Basic]
Public Const INVALIDDEPTH As Integer
[C#]
public const int INVALIDDEPTH;
[C++]
public: const int INVALIDDEPTH;
[JScript]
public var INVALIDDEPTH : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.INVALIDDERIVEDBYVALUE

[To be supplied.]

[Visual Basic]
Public Const INVALIDDERIVEDBYVALUE As Integer
[C#]
public const int INVALIDDERIVEDBYVALUE;
[C++]
public: const int INVALIDDERIVEDBYVALUE;
[JScript]
public var INVALIDDERIVEDBYVALUE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.INVALIDFINALDEFAULTVALUE

[To be supplied.]

[Visual Basic]
Public Const INVALIDFINALDEFAULTVALUE As Integer
[C#]
public const int INVALIDFINALDEFAULTVALUE;
[C++]
public: const int INVALIDFINALDEFAULTVALUE;
[JScript]
public var INVALIDFINALDEFAULTVALUE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.INVALIDFINALVALUE

[To be supplied.]

[Visual Basic]
Public Const INVALIDFINALVALUE As Integer
[C#]
public const int INVALIDFINALVALUE;
[C++]
public: const int INVALIDFINALVALUE;
[JScript]
public var INVALIDFINALVALUE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.INVALIDID

[To be supplied.]

[Visual Basic]
Public Const INVALIDID As Integer
[C#]
public const int INVALIDID;
[C++]
public: const int INVALIDID;
[JScript]
public var INVALIDID : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.INVALIDNAME

[To be supplied.]

[Visual Basic]
Public Const INVALIDNAME As Integer
[C#]
public const int INVALIDNAME;
[C++]
public: const int INVALIDNAME;
[JScript]
public var INVALIDNAME : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.INVALIDNODETYPE

[To be supplied.]

[Visual Basic]
Public Const INVALIDNODETYPE As Integer
[C#]
public const int INVALIDNODETYPE;
[C++]
public: const int INVALIDNODETYPE;
[JScript]
public var INVALIDNODETYPE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.INVALIDPARENTITYREF

[To be supplied.]

[Visual Basic]
Public Const INVALIDPARENTITYREF As Integer
[C#]
public const int INVALIDPARENTITYREF;
[C++]
public: const int INVALIDPARENTITYREF;
[JScript]
public var INVALIDPARENTITYREF : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.INVALIDPINAME

[To be supplied.]

[Visual Basic]
Public Const INVALIDPINAME As Integer
[C#]
public const int INVALIDPINAME;
[C++]
public: const int INVALIDPINAME;
[JScript]
public var INVALIDPINAME : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.INVALIDPROCESSCONTENTVALUE

[To be supplied.]

[Visual Basic]
Public Const INVALIDPROCESSCONTENTVALUE As Integer
[C#]
public const int INVALIDPROCESSCONTENTVALUE;
[C++]
public: const int INVALIDPROCESSCONTENTVALUE;
[JScript]
public var INVALIDPROCESSCONTENTVALUE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.INVALIDROOTDATA

[To be supplied.]

[Visual Basic]
Public Const INVALIDROOTDATA As Integer
[C#]
public const int INVALIDROOTDATA;
[C++]
public: const int INVALIDROOTDATA;
[JScript]
public var INVALIDROOTDATA : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.INVALIDTEXTDECL

[To be supplied.]

[Visual Basic]
Public Const INVALIDTEXTDECL As Integer
[C#]
public const int INVALIDTEXTDECL;
[C++]
public: const int INVALIDTEXTDECL;
[JScript]
public var INVALIDTEXTDECL : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.INVALIDVALUE

[To be supplied.]

[Visual Basic]
Public Const INVALIDVALUE As Integer
[C#]
public const int INVALIDVALUE;
[C++]
public: const int INVALIDVALUE;
[JScript]
public var INVALIDVALUE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.INVALIDXMLDECL

[To be supplied.]

[Visual Basic]
Public Const INVALIDXMLDECL As Integer
[C#]
public const int INVALIDXMLDECL;
[C++]
public: const int INVALIDXMLDECL;
[JScript]
public var INVALIDXMLDECL : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.INVALIDXMLLANG

[To be supplied.]

[Visual Basic]
Public Const INVALIDXMLLANG As Integer
[C#]
public const int INVALIDXMLLANG;
[C++]
public: const int INVALIDXMLLANG;
[JScript]
public var INVALIDXMLLANG : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.INVALIDXMLSPACE

[To be supplied.]

[Visual Basic]
Public Const INVALIDXMLSPACE As Integer
[C#]
public const int INVALIDXMLSPACE;
[C++]
public: const int INVALIDXMLSPACE;
[JScript]
public var INVALIDXMLSPACE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.LAST

[To be supplied.]

[Visual Basic]
Public Const LAST As Integer
[C#]
public const int LAST;
[C++]
public: const int LAST;
[JScript]
public var LAST : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.MANYMAXOCCURS

[To be supplied.]

[Visual Basic]
Public Const MANYMAXOCCURS As Integer
[C#]
public const int MANYMAXOCCURS;
[C++]
public: const int MANYMAXOCCURS;
[JScript]
public var MANYMAXOCCURS : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.MAXOCCURSINVALID

[To be supplied.]

[Visual Basic]
Public Const MAXOCCURSINVALID As Integer
[C#]
public const int MAXOCCURSINVALID;
[C++]
public: const int MAXOCCURSINVALID;
[JScript]
public var MAXOCCURSINVALID : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.MINOCCURSINVALID

[To be supplied.]

[Visual Basic]
Public Const MINOCCURSINVALID As Integer
[C#]
public const int MINOCCURSINVALID;
[C++]
public: const int MINOCCURSINVALID;
[JScript]
public var MINOCCURSINVALID : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.MISSATTRIBUTE

[To be supplied.]

[Visual Basic]
Public Const MISSATTRIBUTE As Integer
[C#]
public const int MISSATTRIBUTE;
[C++]
public: const int MISSATTRIBUTE;
[JScript]
public var MISSATTRIBUTE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.MISSDTTYPEVALUE

[To be supplied.]

[Visual Basic]
Public Const MISSDTTYPEVALUE As Integer
[C#]
public const int MISSDTTYPEVALUE;
[C++]
public: const int MISSDTTYPEVALUE;
[JScript]
public var MISSDTTYPEVALUE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.MISSDTVALUESATTRIBUTE

[To be supplied.]

[Visual Basic]
Public Const MISSDTVALUESATTRIBUTE As Integer
[C#]
public const int MISSDTVALUESATTRIBUTE;
[C++]
public: const int MISSDTVALUESATTRIBUTE;
[JScript]
public var MISSDTVALUESATTRIBUTE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.MISSINGBOM

[To be supplied.]

[Visual Basic]
Public Const MISSINGBOM As Integer
[C#]
public const int MISSINGBOM;
[C++]
public: const int MISSINGBOM;
[JScript]
public var MISSINGBOM : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.MISSINGROOT

[To be supplied.]

[Visual Basic]
Public Const MISSINGROOT As Integer
[C#]
public const int MISSINGROOT;
[C++]
public: const int MISSINGROOT;
[JScript]
public var MISSINGROOT : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.MISSREQUIREDATTRIBUTE

[To be supplied.]

[Visual Basic]
Public Const MISSREQUIREDATTRIBUTE As Integer
[C#]
public const int MISSREQUIREDATTRIBUTE;
[C++]
public: const int MISSREQUIREDATTRIBUTE;
[JScript]
public var MISSREQUIREDATTRIBUTE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.MIXEDMANY

[To be supplied.]

[Visual Basic]
Public Const MIXEDMANY As Integer
[C#]
public const int MIXEDMANY;
[C++]
public: const int MIXEDMANY;
[JScript]
public var MIXEDMANY : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.MULTIPLEATTRIBUTEVALUE

[To be supplied.]

[Visual Basic]
Public Const MULTIPLEATTRIBUTEVALUE As Integer
[C#]
public const int MULTIPLEATTRIBUTEVALUE;
[C++]
public: const int MULTIPLEATTRIBUTEVALUE;
[JScript]
public var MULTIPLEATTRIBUTEVALUE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.MULTIPLEROOTS

[To be supplied.]

[Visual Basic]
Public Const MULTIPLEROOTS As Integer
[C#]
public const int MULTIPLEROOTS;
[C++]
public: const int MULTIPLEROOTS;
[JScript]
public var MULTIPLEROOTS : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.NAMEREF

[To be supplied.]

[Visual Basic]
Public Const NAMEREF As Integer
[C#]
public const int NAMEREF;
[C++]
public: const int NAMEREF;
[JScript]
public var NAMEREF : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.NOCOLONENTITYNAME

[To be supplied.]

[Visual Basic]
Public Const NOCOLONENTITYNAME As Integer
[C#]
public const int NOCOLONENTITYNAME;
[C++]
public: const int NOCOLONENTITYNAME;
[JScript]
public var NOCOLONENTITYNAME : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.NOELEMENTCONTENT

[To be supplied.]

[Visual Basic]
Public Const NOELEMENTCONTENT As Integer
[C#]
public const int NOELEMENTCONTENT;
[C++]
public: const int NOELEMENTCONTENT;
[JScript]
public var NOELEMENTCONTENT : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.NOHANDLER

[To be supplied.]

[Visual Basic]
Public Const NOHANDLER As Integer
[C#]
public const int NOHANDLER;
[C++]
public: const int NOHANDLER;
[JScript]
public var NOHANDLER : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.NOINPUT

[To be supplied.]

[Visual Basic]
Public Const NOINPUT As Integer
[C#]
public const int NOINPUT;
[C++]
public: const int NOINPUT;
[JScript]
public var NOINPUT : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.NOPARTICLE

[To be supplied.]

[Visual Basic]
Public Const NOPARTICLE As Integer
[C#]
public const int NOPARTICLE;
[C++]
public: const int NOPARTICLE;
[JScript]
public var NOPARTICLE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.NOTATIONVALUE

[To be supplied.]

[Visual Basic]
Public Const NOTATIONVALUE As Integer
[C#]
public const int NOTATIONVALUE;
[C++]
public: const int NOTATIONVALUE;
[JScript]
public var NOTATIONVALUE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.NOTIMPLEMENTED

[To be supplied.]

[Visual Basic]
Public Const NOTIMPLEMENTED As Integer
[C#]
public const int NOTIMPLEMENTED;
[C++]
public: const int NOTIMPLEMENTED;
[JScript]
public var NOTIMPLEMENTED : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.NOTINSCHEMACOLLECTION

[To be supplied.]

[Visual Basic]
Public Const NOTINSCHEMACOLLECTION As Integer
[C#]
public const int NOTINSCHEMACOLLECTION;
[C++]
public: const int NOTINSCHEMACOLLECTION;
[JScript]
public var NOTINSCHEMACOLLECTION : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.NOTSAMENAMETABLE

[To be supplied.]

[Visual Basic]
Public Const NOTSAMENAMETABLE As Integer
[C#]
public const int NOTSAMENAMETABLE;
[C++]
public: const int NOTSAMENAMETABLE;
[JScript]
public var NOTSAMENAMETABLE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.NUMENTITYOVERFLOW

[To be supplied.]

[Visual Basic]
Public Const NUMENTITYOVERFLOW As Integer
[C#]
public const int NUMENTITYOVERFLOW;
[C++]
public: const int NUMENTITYOVERFLOW;
[JScript]
public var NUMENTITYOVERFLOW : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.PARENTITYREFNESTING

[To be supplied.]

[Visual Basic]
Public Const PARENTITYREFNESTING As Integer
[C#]
public const int PARENTITYREFNESTING;
[C++]
public: const int PARENTITYREFNESTING;
[JScript]
public var PARENTITYREFNESTING : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.RECURSIVEGENENTITY

[To be supplied.]

[Visual Basic]
Public Const RECURSIVEGENENTITY As Integer
[C#]
public const int RECURSIVEGENENTITY;
[C++]
public: const int RECURSIVEGENENTITY;
[JScript]
public var RECURSIVEGENENTITY : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.RECURSIVEPARENTITY

[To be supplied.]

[Visual Basic]
Public Const RECURSIVEPARENTITY As Integer
[C#]
public const int RECURSIVEPARENTITY;
[C++]
public: const int RECURSIVEPARENTITY;
[JScript]
public var RECURSIVEPARENTITY : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.REQUIREENUMERATION

[To be supplied.]

[Visual Basic]
Public Const REQUIREENUMERATION As Integer
[C#]
public const int REQUIREENUMERATION;
[C++]
public: const int REQUIREENUMERATION;
[JScript]
public var REQUIREENUMERATION : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.RESERVEDNS

[To be supplied.]

[Visual Basic]
Public Const RESERVEDNS As Integer
[C#]
public const int RESERVEDNS;
[C++]
public: const int RESERVEDNS;
[JScript]
public var RESERVEDNS : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.RESERVEDNSDECL

[To be supplied.]

[Visual Basic]
Public Const RESERVEDNSDECL As Integer
[C#]
public const int RESERVEDNSDECL;
[C++]
public: const int RESERVEDNSDECL;
[JScript]
public var RESERVEDNSDECL : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.ROOTMATCHDOCTYPE

[To be supplied.]

[Visual Basic]
Public Const ROOTMATCHDOCTYPE As Integer
[C#]
public const int ROOTMATCHDOCTYPE;
[C++]
public: const int ROOTMATCHDOCTYPE;
[JScript]
public var ROOTMATCHDOCTYPE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.SCHEMAROOTEXPECTED

[To be supplied.]

[Visual Basic]
Public Const SCHEMAROOTEXPECTED As Integer
[C#]
public const int SCHEMAROOTEXPECTED;
[C++]
public: const int SCHEMAROOTEXPECTED;
[JScript]
public var SCHEMAROOTEXPECTED : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.SCH_START

[To be supplied.]

[Visual Basic]
Public Const SCH_START As Integer
[C#]
public const int SCH_START;
[C++]
public: const int SCH_START;
[JScript]
public var SCH_START : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.TAGMISMATCH

[To be supplied.]

[Visual Basic]
Public Const TAGMISMATCH As Integer
[C#]
public const int TAGMISMATCH;
[C++]
public: const int TAGMISMATCH;
[JScript]
public var TAGMISMATCH : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.TEXTDECLPOSITION

[To be supplied.]

[Visual Basic]
Public Const TEXTDECLPOSITION As Integer
[C#]
public const int TEXTDECLPOSITION;
[C++]
public: const int TEXTDECLPOSITION;
[JScript]
public var TEXTDECLPOSITION : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.TEXTNOTALLOWED

[To be supplied.]

[Visual Basic]
Public Const TEXTNOTALLOWED As Integer
[C#]
public const int TEXTNOTALLOWED;
[C++]
public: const int TEXTNOTALLOWED;
[JScript]
public var TEXTNOTALLOWED : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.TYPEMUTUALEXCLUSIVE

[To be supplied.]

[Visual Basic]
Public Const TYPEMUTUALEXCLUSIVE As Integer
[C#]
public const int TYPEMUTUALEXCLUSIVE;
[C++]
public: const int TYPEMUTUALEXCLUSIVE;
[JScript]
public var TYPEMUTUALEXCLUSIVE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.UNCLOSEDQUOTE

[To be supplied.]

[Visual Basic]
Public Const UNCLOSEDQUOTE As Integer
[C#]
public const int UNCLOSEDQUOTE;
[C++]
public: const int UNCLOSEDQUOTE;
[JScript]
public var UNCLOSEDQUOTE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.UNDECLAREDATTRIBUTE

[To be supplied.]

[Visual Basic]
Public Const UNDECLAREDATTRIBUTE As Integer
[C#]
public const int UNDECLAREDATTRIBUTE;
[C++]
public: const int UNDECLAREDATTRIBUTE;
[JScript]
public var UNDECLAREDATTRIBUTE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.UNDECLAREDELEMENT

[To be supplied.]

[Visual Basic]
Public Const UNDECLAREDELEMENT As Integer
[C#]
public const int UNDECLAREDELEMENT;
[C++]
public: const int UNDECLAREDELEMENT;
[JScript]
public var UNDECLAREDELEMENT : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.UNDECLAREDENTITY

[To be supplied.]

[Visual Basic]
Public Const UNDECLAREDENTITY As Integer
[C#]
public const int UNDECLAREDENTITY;
[C++]
public: const int UNDECLAREDENTITY;
[JScript]
public var UNDECLAREDENTITY : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.UNDECLAREDEQUIVCLASS

[To be supplied.]

[Visual Basic]
Public Const UNDECLAREDEQUIVCLASS As Integer
[C#]
public const int UNDECLAREDEQUIVCLASS;
[C++]
public: const int UNDECLAREDEQUIVCLASS;
[JScript]
public var UNDECLAREDEQUIVCLASS : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.UNDECLAREDID

[To be supplied.]

[Visual Basic]
Public Const UNDECLAREDID As Integer
[C#]
public const int UNDECLAREDID;
[C++]
public: const int UNDECLAREDID;
[JScript]
public var UNDECLAREDID : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.UNDECLAREDNOTATION

[To be supplied.]

[Visual Basic]
Public Const UNDECLAREDNOTATION As Integer
[C#]
public const int UNDECLAREDNOTATION;
[C++]
public: const int UNDECLAREDNOTATION;
[JScript]
public var UNDECLAREDNOTATION : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.UNDECLAREDPARENTITY

[To be supplied.]

[Visual Basic]
Public Const UNDECLAREDPARENTITY As Integer
[C#]
public const int UNDECLAREDPARENTITY;
[C++]
public: const int UNDECLAREDPARENTITY;
[JScript]
public var UNDECLAREDPARENTITY : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.UNDECLAREDTYPE

[To be supplied.]

[Visual Basic]
Public Const UNDECLAREDTYPE As Integer
[C#]
public const int UNDECLAREDTYPE;
[C++]
public: const int UNDECLAREDTYPE;
[JScript]
public var UNDECLAREDTYPE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.UNEXPECTEDCDATAEND

[To be supplied.]

[Visual Basic]
Public Const UNEXPECTEDCDATAEND As Integer
[C#]
public const int UNEXPECTEDCDATAEND;
[C++]
public: const int UNEXPECTEDCDATAEND;
[JScript]
public var UNEXPECTEDCDATAEND : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.UNEXPECTEDCHAR

[To be supplied.]

[Visual Basic]
Public Const UNEXPECTEDCHAR As Integer
[C#]
public const int UNEXPECTEDCHAR;
[C++]
public: const int UNEXPECTEDCHAR;
[JScript]
public var UNEXPECTEDCHAR : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.UNEXPECTEDENDTAG

[To be supplied.]

[Visual Basic]
Public Const UNEXPECTEDENDTAG As Integer
[C#]
public const int UNEXPECTEDENDTAG;
[C++]
public: const int UNEXPECTEDENDTAG;
[JScript]
public var UNEXPECTEDENDTAG : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.UNEXPECTEDEOF

[To be supplied.]

[Visual Basic]
Public Const UNEXPECTEDEOF As Integer
[C#]
public const int UNEXPECTEDEOF;
[C++]
public: const int UNEXPECTEDEOF;
[JScript]
public var UNEXPECTEDEOF : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.UNEXPECTEDTOKEN

[To be supplied.]

[Visual Basic]
Public Const UNEXPECTEDTOKEN As Integer
[C#]
public const int UNEXPECTEDTOKEN;
[C++]
public: const int UNEXPECTEDTOKEN;
[JScript]
public var UNEXPECTEDTOKEN : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.UNEXPECTEDWS

[To be supplied.]

[Visual Basic]
Public Const UNEXPECTEDWS As Integer
[C#]
public const int UNEXPECTEDWS;
[C++]
public: const int UNEXPECTEDWS;
[JScript]
public var UNEXPECTEDWS : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.UNKNOWNCONTENT

[To be supplied.]

[Visual Basic]
Public Const UNKNOWNCONTENT As Integer
[C#]
public const int UNKNOWNCONTENT;
[C++]
public: const int UNKNOWNCONTENT;
[JScript]
public var UNKNOWNCONTENT : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.UNKNOWNDTTYPE

[To be supplied.]

[Visual Basic]
Public Const UNKNOWNDTTYPE As Integer
[C#]
public const int UNKNOWNDTTYPE;
[C++]
public: const int UNKNOWNDTTYPE;
[JScript]
public var UNKNOWNDTTYPE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.UNKNOWNENCODING

[To be supplied.]

[Visual Basic]
Public Const UNKNOWNENCODING As Integer
[C#]
public const int UNKNOWNENCODING;
[C++]
public: const int UNKNOWNENCODING;
[JScript]
public var UNKNOWNENCODING : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.UNKNOWNMODEL

[To be supplied.]

[Visual Basic]
Public Const UNKNOWNMODEL As Integer
[C#]
public const int UNKNOWNMODEL;
[C++]
public: const int UNKNOWNMODEL;
[JScript]
public var UNKNOWNMODEL : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.UNKNOWNNS

[To be supplied.]

[Visual Basic]
Public Const UNKNOWNNS As Integer
[C#]
public const int UNKNOWNNS;
[C++]
public: const int UNKNOWNNS;
[JScript]
public var UNKNOWNNS : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.UNKNOWNORDER

[To be supplied.]

[Visual Basic]
Public Const UNKNOWNORDER As Integer
[C#]
public const int UNKNOWNORDER;
[C++]
public: const int UNKNOWNORDER;
[JScript]
public var UNKNOWNORDER : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.UNKNOWNREQUIRED

[To be supplied.]

[Visual Basic]
Public Const UNKNOWNREQUIRED As Integer
[C#]
public const int UNKNOWNREQUIRED;
[C++]
public: const int UNKNOWNREQUIRED;
[JScript]
public var UNKNOWNREQUIRED : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.UNPARSEDENTITY

[To be supplied.]

[Visual Basic]
Public Const UNPARSEDENTITY As Integer
[C#]
public const int UNPARSEDENTITY;
[C++]
public: const int UNPARSEDENTITY;
[JScript]
public var UNPARSEDENTITY : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.UNPARSEDENTITYREF

[To be supplied.]

[Visual Basic]
Public Const UNPARSEDENTITYREF As Integer
[C#]
public const int UNPARSEDENTITYREF;
[C++]
public: const int UNPARSEDENTITYREF;
[JScript]
public var UNPARSEDENTITYREF : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.UNSUPPORTEDATTRIBUTE

[To be supplied.]

[Visual Basic]
Public Const UNSUPPORTEDATTRIBUTE As Integer
[C#]
public const int UNSUPPORTEDATTRIBUTE;
[C++]
public: const int UNSUPPORTEDATTRIBUTE;
[JScript]
public var UNSUPPORTEDATTRIBUTE : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.UNSUPPORTEDELEMENT

[To be supplied.]

[Visual Basic]
Public Const UNSUPPORTEDELEMENT As Integer
[C#]
public const int UNSUPPORTEDELEMENT;
[C++]
public: const int UNSUPPORTEDELEMENT;
[JScript]
public var UNSUPPORTEDELEMENT : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.VALIDATEELEMENT

[To be supplied.]

[Visual Basic]
Public Const VALIDATEELEMENT As Integer
[C#]
public const int VALIDATEELEMENT;
[C++]
public: const int VALIDATEELEMENT;
[JScript]
public var VALIDATEELEMENT : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.WRITER_START

[To be supplied.]

[Visual Basic]
Public Const WRITER_START As Integer
[C#]
public const int WRITER_START;
[C++]
public: const int WRITER_START;
[JScript]
public var WRITER_START : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.XMLDECLNOTFIRST

[To be supplied.]

[Visual Basic]
Public Const XMLDECLNOTFIRST As Integer
[C#]
public const int XMLDECLNOTFIRST;
[C++]
public: const int XMLDECLNOTFIRST;
[JScript]
public var XMLDECLNOTFIRST : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlException.XML_LAST

[To be supplied.]

[Visual Basic]
Public Const XML_LAST As Integer
[C#]
public const int XML_LAST;
[C++]
public: const int XML_LAST;
[JScript]
public var XML_LAST : int;

See Also

XmlException Class | XmlException Members | System.Data.XML Namespace


XmlFidelity Enumeration

[To be supplied.]

[Visual Basic]
Public Enum XmlFidelity
[C#]
public enum XmlFidelity
[C++]
public enum XmlFidelity

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Full | [To be supplied.]
None | [To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

System.Data.XML Namespace


XmlNodeType Enumeration

[To be supplied.]

[Visual Basic]
Public Enum XmlNodeType
[C#]
public enum XmlNodeType
[C++]
public enum XmlNodeType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
All | [To be supplied.]
Attribute | [To be supplied.]
CDATA | [To be supplied.]
Comment | [To be supplied.]
Document | [To be supplied.]
DocumentFragment | [To be supplied.]
DocumentType | [To be supplied.]
Element | [To be supplied.]
EndTag | [To be supplied.]
Entity | [To be supplied.]
EntityReference | [To be supplied.]
None | [To be supplied.]
Notation | [To be supplied.]
ProcessingInstruction | [To be supplied.]
TagWhitespace | [To be supplied.]
Text | [To be supplied.]
Whitespace | [To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

System.Data.XML Namespace


XmlReader Class

[To be supplied.]

Object
CoreXmlReader
XmlReader

[Visual Basic]
Public Class XmlReader
   Inherits CoreXmlReader
[C#]
public class XmlReader : CoreXmlReader
[C++]
public __gc class XmlReader : public CoreXmlReader
[JScript]
public class XmlReader extends CoreXmlReader

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

XmlReader Members | System.Data.XML Namespace


XmlReader Members

Public:

Constructor

XmlReader Constructor Overloaded. [To be supplied.]

Properties

DataTypeName (inherited from CoreXmlReader) | [To be supplied.]
DataTypeNamespace (inherited from CoreXmlReader) | [To be supplied.]
Depth (inherited from CoreXmlReader) | [To be supplied.]
Empty (inherited from CoreXmlReader) | [To be supplied.]
EOF (inherited from CoreXmlReader) | [To be supplied.]
FieldCount (inherited from CoreXmlReader) | [To be supplied.]
Filter | [To be supplied.]
Flags (inherited from CoreXmlReader) | [To be supplied.]
Format (inherited from CoreXmlReader) | [To be supplied.]
HasValue (inherited from CoreXmlReader) | [To be supplied.]
Item (inherited from CoreXmlReader) | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlReader class.
LineNumber (inherited from CoreXmlReader) | [To be supplied.]
LinePos (inherited from CoreXmlReader) | [To be supplied.]
Name (inherited from CoreXmlReader) | [To be supplied.]
Namespace (inherited from CoreXmlReader) | [To be supplied.]
NameTable (inherited from CoreXmlReader) | [To be supplied.]
NodeType (inherited from CoreXmlReader) | [To be supplied.]
Prefix (inherited from CoreXmlReader) | [To be supplied.]
ReadState (inherited from CoreXmlReader) | [To be supplied.]
ShowEndTag (inherited from CoreXmlReader) | [To be supplied.]
UriResolver (inherited from CoreXmlReader) | [To be supplied.]
ValidationCallback | [To be supplied.]
Value (inherited from CoreXmlReader) | [To be supplied.]

Methods

Close | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
ExpandEntity (inherited from CoreXmlReader) | [To be supplied.]
GetBoolean (inherited from CoreXmlReader) | [To be supplied.]
GetByte (inherited from CoreXmlReader) | [To be supplied.]
GetBytes (inherited from CoreXmlReader) | [To be supplied.]
GetChar (inherited from CoreXmlReader) | [To be supplied.]
GetChars (inherited from CoreXmlReader) | [To be supplied.]
GetCurrency (inherited from CoreXmlReader) | [To be supplied.]
GetData (inherited from CoreXmlReader) | [To be supplied.]
GetDataTypeName (inherited from CoreXmlReader) | [To be supplied.]
GetDataTypeNamespace (inherited from CoreXmlReader) | [To be supplied.]
GetDateTime (inherited from CoreXmlReader) | [To be supplied.]
GetDecimal (inherited from CoreXmlReader) | [To be supplied.]
GetDouble (inherited from CoreXmlReader) | [To be supplied.]
GetFieldType (inherited from CoreXmlReader) | [To be supplied.]
GetFloat (inherited from CoreXmlReader) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInt16 (inherited from CoreXmlReader) | [To be supplied.]
GetInt32 (inherited from CoreXmlReader) | [To be supplied.]
GetInt64 (inherited from CoreXmlReader) | [To be supplied.]
GetName (inherited from CoreXmlReader) | [To be supplied.]
GetNamespace (inherited from CoreXmlReader) | [To be supplied.]
GetOrdinal (inherited from CoreXmlReader) | Overloaded. [To be supplied.]
GetPrefix (inherited from CoreXmlReader) | [To be supplied.]
GetRaw (inherited from CoreXmlReader) | [To be supplied.]
GetStream (inherited from CoreXmlReader) | [To be supplied.]
GetString (inherited from CoreXmlReader) | [To be supplied.]
GetTimeSpan (inherited from CoreXmlReader) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValue (inherited from CoreXmlReader) | [To be supplied.]
GetValues (inherited from CoreXmlReader) | [To be supplied.]
IsNull (inherited from CoreXmlReader) | [To be supplied.]
LookupNamespace (inherited from CoreXmlReader) | [To be supplied.]
Read (inherited from CoreXmlReader) | [To be supplied.]
ReadBlock (inherited from CoreXmlReader) | [To be supplied.]
ReadString (inherited from CoreXmlReader) | [To be supplied.]
Skip (inherited from CoreXmlReader) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

IsAttrText (inherited from CoreXmlReader) | [To be supplied.]
NamespaceManager (inherited from CoreXmlReader) | [To be supplied.]

Methods

CheckWhitespaceNodeType | [To be supplied.]
CreateNamespaceManager | [To be supplied.]
EndEntity | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetEntityScanner | [To be supplied.]
IsSchema | [To be supplied.]
MatchFilter | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseDtd | [To be supplied.]
ValidateDtd | [To be supplied.]
ValidateEnd | [To be supplied.]
ValidateSchema | [To be supplied.]
ValidateToken | [To be supplied.]

See Also

XmlReader Class | System.Data.XML Namespace


XmlReader Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(INameTable)
[C#] public XmlReader(INameTable);
[C++] public: XmlReader(INameTable*);
[JScript] public function XmlReader(INameTable);

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public XmlReader();
[C++] public: XmlReader();
[JScript] public function XmlReader();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Stream, INameTable)
[C#] public XmlReader(Stream, INameTable);
[C++] public: XmlReader(Stream*, INameTable);
[JScript] public function XmlReader(Stream, INameTable);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(TextReader, INameTable)
[C#] public XmlReader(TextReader, INameTable);
[C++] public: XmlReader(TextReader*, INameTable);
[JScript] public function XmlReader(TextReader, INameTable);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, INameTable)
[C#] public XmlReader(String, INameTable);
[C++] public: XmlReader(String*, INameTable);
[JScript] public function XmlReader(String, INameTable);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Stream)
[C#] public XmlReader(Stream);
[C++] public: XmlReader(Stream*);
[JScript] public function XmlReader(Stream);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(TextReader)
[C#] public XmlReader(TextReader);
[C++] public: XmlReader(TextReader*);
[JScript] public function XmlReader(TextReader);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public XmlReader(String);
[C++] public: XmlReader(String*);
[JScript] public function XmlReader(String);

See Also

XmlReader Class | XmlReader Members | System.Data.XML Namespace


XmlReader Constructor (INameTable)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal nt As INameTable _
)
[C#]
public XmlReader(
   INameTable nt
);
[C++]
public: XmlReader(
   INameTable* nt
);
[JScript]
public function XmlReader(
   nt : INameTable
);

Parameters

nt
[To be supplied.]

See Also

XmlReader Class | XmlReader Members | System.Data.XML Namespace | XmlReader Constructor Overload List


XmlReader Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public XmlReader();
[C++]
public: XmlReader();
[JScript]
public function XmlReader();

See Also

XmlReader Class | XmlReader Members | System.Data.XML Namespace | XmlReader Constructor Overload List


XmlReader Constructor (Stream, INameTable)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal input As Stream, _
   ByVal nt As INameTable _
)
[C#]
public XmlReader(
   Stream input,
   INameTable nt
);
[C++]
public: XmlReader(
   Stream* input,
   INameTable* nt
);
[JScript]
public function XmlReader(
   input : Stream,
   nt : INameTable
);

Parameters

input
[To be supplied.]
nt
[To be supplied.]

See Also

XmlReader Class | XmlReader Members | System.Data.XML Namespace | XmlReader Constructor Overload List


XmlReader Constructor (TextReader, INameTable)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal input As TextReader, _
   ByVal nt As INameTable _
)
[C#]
public XmlReader(
   TextReader input,
   INameTable nt
);
[C++]
public: XmlReader(
   TextReader* input,
   INameTable* nt
);
[JScript]
public function XmlReader(
   input : TextReader,
   nt : INameTable
);

Parameters

input
[To be supplied.]
nt
[To be supplied.]

See Also

XmlReader Class | XmlReader Members | System.Data.XML Namespace | XmlReader Constructor Overload List


XmlReader Constructor (String, INameTable)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal url As String, _
   ByVal nt As INameTable _
)
[C#]
public XmlReader(
   string url,
   INameTable nt
);
[C++]
public: XmlReader(
   String* url,
   INameTable* nt
);
[JScript]
public function XmlReader(
   url : String,
   nt : INameTable
);

Parameters

url
[To be supplied.]
nt
[To be supplied.]

See Also

XmlReader Class | XmlReader Members | System.Data.XML Namespace | XmlReader Constructor Overload List


XmlReader Constructor (Stream)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal input As Stream _
)
[C#]
public XmlReader(
   Stream input
);
[C++]
public: XmlReader(
   Stream* input
);
[JScript]
public function XmlReader(
   input : Stream
);

Parameters

input
[To be supplied.]

See Also

XmlReader Class | XmlReader Members | System.Data.XML Namespace | XmlReader Constructor Overload List


XmlReader Constructor (TextReader)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal input As TextReader _
)
[C#]
public XmlReader(
   TextReader input
);
[C++]
public: XmlReader(
   TextReader* input
);
[JScript]
public function XmlReader(
   input : TextReader
);

Parameters

input
[To be supplied.]

See Also

XmlReader Class | XmlReader Members | System.Data.XML Namespace | XmlReader Constructor Overload List


XmlReader Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal url As String _
)
[C#]
public XmlReader(
   string url
);
[C++]
public: XmlReader(
   String* url
);
[JScript]
public function XmlReader(
   url : String
);

Parameters

url
[To be supplied.]

See Also

XmlReader Class | XmlReader Members | System.Data.XML Namespace | XmlReader Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlReader Properties

The properties of the XmlReader class are listed below. For a complete list of XmlReader class members, see the XmlReader Members topic.

Public:

DataTypeName (inherited from CoreXmlReader) | [To be supplied.]
DataTypeNamespace (inherited from CoreXmlReader) | [To be supplied.]
Depth (inherited from CoreXmlReader) | [To be supplied.]
Empty (inherited from CoreXmlReader) | [To be supplied.]
EOF (inherited from CoreXmlReader) | [To be supplied.]
FieldCount (inherited from CoreXmlReader) | [To be supplied.]
Filter | [To be supplied.]
Flags (inherited from CoreXmlReader) | [To be supplied.]
Format (inherited from CoreXmlReader) | [To be supplied.]
HasValue (inherited from CoreXmlReader) | [To be supplied.]
Item (inherited from CoreXmlReader) | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlReader class.
LineNumber (inherited from CoreXmlReader) | [To be supplied.]
LinePos (inherited from CoreXmlReader) | [To be supplied.]
Name (inherited from CoreXmlReader) | [To be supplied.]
Namespace (inherited from CoreXmlReader) | [To be supplied.]
NameTable (inherited from CoreXmlReader) | [To be supplied.]
NodeType (inherited from CoreXmlReader) | [To be supplied.]
Prefix (inherited from CoreXmlReader) | [To be supplied.]
ReadState (inherited from CoreXmlReader) | [To be supplied.]
ShowEndTag (inherited from CoreXmlReader) | [To be supplied.]
UriResolver (inherited from CoreXmlReader) | [To be supplied.]
ValidationCallback | [To be supplied.]
Value (inherited from CoreXmlReader) | [To be supplied.]

Protected:

IsAttrText (inherited from CoreXmlReader) | [To be supplied.]
NamespaceManager (inherited from CoreXmlReader) | [To be supplied.]

See Also

XmlReader Class | System.Data.XML Namespace


XmlReader.Filter

[To be supplied.]

[Visual Basic]
Overridable Public Property Filter As String
[C#]
public string Filter {override get; override set;}
[C++]
public: __property virtual String* get_Filter();
public: __property virtual void set_Filter(String*);
[JScript]
public function get Filter() : String;
public function set Filter(String);

See Also

XmlReader Class | XmlReader Members | System.Data.XML Namespace


XmlReader.ValidationCallback

[To be supplied.]

[Visual Basic]
Public Property ValidationCallback As ValidationDelegate
[C#]
public ValidationDelegate ValidationCallback {get; set;}
[C++]
public: __property ValidationDelegate* get_ValidationCallback();
public: __property void set_ValidationCallback(ValidationDelegate*);
[JScript]
public function get ValidationCallback() : ValidationDelegate;
public function set ValidationCallback(ValidationDelegate);

See Also

XmlReader Class | XmlReader Members | System.Data.XML Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlReader Methods

The methods of the XmlReader class are listed below. For a complete list of XmlReader class members, see the XmlReader Members topic.

Public:

Close | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
ExpandEntity (inherited from CoreXmlReader) | [To be supplied.]
GetBoolean (inherited from CoreXmlReader) | [To be supplied.]
GetByte (inherited from CoreXmlReader) | [To be supplied.]
GetBytes (inherited from CoreXmlReader) | [To be supplied.]
GetChar (inherited from CoreXmlReader) | [To be supplied.]
GetChars (inherited from CoreXmlReader) | [To be supplied.]
GetCurrency (inherited from CoreXmlReader) | [To be supplied.]
GetData (inherited from CoreXmlReader) | [To be supplied.]
GetDataTypeName (inherited from CoreXmlReader) | [To be supplied.]
GetDataTypeNamespace (inherited from CoreXmlReader) | [To be supplied.]
GetDateTime (inherited from CoreXmlReader) | [To be supplied.]
GetDecimal (inherited from CoreXmlReader) | [To be supplied.]
GetDouble (inherited from CoreXmlReader) | [To be supplied.]
GetFieldType (inherited from CoreXmlReader) | [To be supplied.]
GetFloat (inherited from CoreXmlReader) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInt16 (inherited from CoreXmlReader) | [To be supplied.]
GetInt32 (inherited from CoreXmlReader) | [To be supplied.]
GetInt64 (inherited from CoreXmlReader) | [To be supplied.]
GetName (inherited from CoreXmlReader) | [To be supplied.]
GetNamespace (inherited from CoreXmlReader) | [To be supplied.]
GetOrdinal (inherited from CoreXmlReader) | Overloaded. [To be supplied.]
GetPrefix (inherited from CoreXmlReader) | [To be supplied.]
GetRaw (inherited from CoreXmlReader) | [To be supplied.]
GetStream (inherited from CoreXmlReader) | [To be supplied.]
GetString (inherited from CoreXmlReader) | [To be supplied.]
GetTimeSpan (inherited from CoreXmlReader) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValue (inherited from CoreXmlReader) | [To be supplied.]
GetValues (inherited from CoreXmlReader) | [To be supplied.]
IsNull (inherited from CoreXmlReader) | [To be supplied.]
LookupNamespace (inherited from CoreXmlReader) | [To be supplied.]
Read (inherited from CoreXmlReader) | [To be supplied.]
ReadBlock (inherited from CoreXmlReader) | [To be supplied.]
ReadString (inherited from CoreXmlReader) | [To be supplied.]
Skip (inherited from CoreXmlReader) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

CheckWhitespaceNodeType | [To be supplied.]
CreateNamespaceManager | [To be supplied.]
EndEntity | [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetEntityScanner | [To be supplied.]
IsSchema | [To be supplied.]
MatchFilter | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseDtd | [To be supplied.]
ValidateDtd | [To be supplied.]
ValidateEnd | [To be supplied.]
ValidateSchema | [To be supplied.]
ValidateToken | [To be supplied.]

See Also

XmlReader Class | System.Data.XML Namespace


XmlReader.CheckWhitespaceNodeType

[To be supplied.]

[Visual Basic]
Overrides Protected Function CheckWhitespaceNodeType( _
   ByVal name As String, _
   ByVal prefix As String, _
   ByVal ns As String _
) As XmlNodeType
[C#]
protected override XmlNodeType CheckWhitespaceNodeType(
   string name,
   string prefix,
   string ns
);
[C++]
protected: override XmlNodeType CheckWhitespaceNodeType(
   String* name,
   String* prefix,
   String* ns
);
[JScript]
protected override function CheckWhitespaceNodeType(
   name : String,
   prefix : String,
   ns : String
) : XmlNodeType;

Parameters

name
[To be supplied.]
prefix
[To be supplied.]
ns
[To be supplied.]

See Also

XmlReader Class | XmlReader Members | System.Data.XML Namespace


XmlReader.Close

[To be supplied.]

[Visual Basic]
Overrides Public Sub Close()
[C#]
public override void Close();
[C++]
public: override void Close();
[JScript]
public override function Close();

See Also

XmlReader Class | XmlReader Members | System.Data.XML Namespace


XmlReader.CreateNamespaceManager

[To be supplied.]

[Visual Basic]
Overrides Protected Function CreateNamespaceManager() As _
   NamespaceManager
[C#]
protected override NamespaceManager CreateNamespaceManager();
[C++]
protected: override NamespaceManager* CreateNamespaceManager();
[JScript]
protected override function CreateNamespaceManager() :
   NamespaceManager;

See Also

XmlReader Class | XmlReader Members | System.Data.XML Namespace


XmlReader.EndEntity

[To be supplied.]

[Visual Basic]
Overrides Protected Sub EndEntity( _
   ByVal o As Object _
)
[C#]
protected override void EndEntity(
   object o
);
[C++]
protected: override void EndEntity(
   Object* o
);
[JScript]
protected override function EndEntity(
   o : Object
);

Parameters

o
[To be supplied.]

See Also

XmlReader Class | XmlReader Members | System.Data.XML Namespace


XmlReader.GetEntityScanner

[To be supplied.]

[Visual Basic]
Overrides Protected Function GetEntityScanner( _
   ByVal name As String, _
   ByRef o As Object _
) As XmlScanner
[C#]
protected override XmlScanner GetEntityScanner(
   string name,
   ref object o
);
[C++]
protected: override XmlScanner* GetEntityScanner(
   String* name,
   Object** o
);
[JScript]
protected override function GetEntityScanner(
   name : String,
   o : Object
) : XmlScanner;

Parameters

name
[To be supplied.]
o
[To be supplied.]

See Also

XmlReader Class | XmlReader Members | System.Data.XML Namespace


XmlReader.IsSchema

[To be supplied.]

[Visual Basic]
Overrides Protected Function IsSchema( _
   ByVal ns As String _
) As Boolean
[C#]
protected override bool IsSchema(
   string ns
);
[C++]
protected: override bool IsSchema(
   String* ns
);
[JScript]
protected override function IsSchema(
   ns : String
) : Boolean;

Parameters

ns
[To be supplied.]

See Also

XmlReader Class | XmlReader Members | System.Data.XML Namespace


XmlReader.MatchFilter

[To be supplied.]

[Visual Basic]
Overrides Protected Function MatchFilter() As Boolean
[C#]
protected override bool MatchFilter();
[C++]
protected: override bool MatchFilter();
[JScript]
protected override function MatchFilter() : Boolean;

See Also

XmlReader Class | XmlReader Members | System.Data.XML Namespace


XmlReader.ParseDtd

[To be supplied.]

[Visual Basic]
Overrides Protected Function ParseDtd( _
   ByVal scanner As XmlScanner _
) As String
[C#]
protected override string ParseDtd(
   XmlScanner scanner
);
[C++]
protected: override String* ParseDtd(
   XmlScanner* scanner
);
[JScript]
protected override function ParseDtd(
   scanner : XmlScanner
) : String;

Parameters

scanner
[To be supplied.]

See Also

XmlReader Class | XmlReader Members | System.Data.XML Namespace


XmlReader.ValidateDtd

[To be supplied.]

[Visual Basic]
Overrides Protected Sub ValidateDtd()
[C#]
protected override void ValidateDtd();
[C++]
protected: override void ValidateDtd();
[JScript]
protected override function ValidateDtd();

See Also

XmlReader Class | XmlReader Members | System.Data.XML Namespace


XmlReader.ValidateEnd

[To be supplied.]

[Visual Basic]
Overrides Protected Sub ValidateEnd()
[C#]
protected override void ValidateEnd();
[C++]
protected: override void ValidateEnd();
[JScript]
protected override function ValidateEnd();

See Also

XmlReader Class | XmlReader Members | System.Data.XML Namespace


XmlReader.ValidateSchema

[To be supplied.]

[Visual Basic]
Overrides Protected Sub ValidateSchema( _
   ByVal ns As String _
)
[C#]
protected override void ValidateSchema(
   string ns
);
[C++]
protected: override void ValidateSchema(
   String* ns
);
[JScript]
protected override function ValidateSchema(
   ns : String
);

Parameters

ns
[To be supplied.]

See Also

XmlReader Class | XmlReader Members | System.Data.XML Namespace


XmlReader.ValidateToken

[To be supplied.]

[Visual Basic]
Overrides Protected Sub ValidateToken()
[C#]
protected override void ValidateToken();
[C++]
protected: override void ValidateToken();
[JScript]
protected override function ValidateToken();

See Also

XmlReader Class | XmlReader Members | System.Data.XML Namespace


XmlScanner Class

[To be supplied.]

Object
XmlScanner

[Visual Basic]
NotInheritable Public Class XmlScanner
[C#]
public sealed class XmlScanner
[C++]
public __gc __sealed class XmlScanner
[JScript]
public class XmlScanner

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

XmlScanner Members | System.Data.XML Namespace


XmlScanner Members

Public:

Constructor

XmlScanner Constructor Overloaded. [To be supplied.]

Properties

CurrentPos | [To be supplied.]
InDTD | [To be supplied.]
ReadBufferConsistency | [To be supplied.]
StartPos | [To be supplied.]

Methods

Advance | Overloaded. [To be supplied.]
Close | [To be supplied.]
Colon | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetChar | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInternalBuffer | [To be supplied.]
GetLength | [To be supplied.]
GetLineNum | [To be supplied.]
GetLinePos | [To be supplied.]
GetOffset | [To be supplied.]
GetOffsetAndLength | [To be supplied.]
GetStartChar | Overloaded. [To be supplied.]
GetStartLineNum | [To be supplied.]
GetStartLinePos | [To be supplied.]
GetStringFromBuffer | [To be supplied.]
GetText | Overloaded. [To be supplied.]
GetTextAtom | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsToken | Overloaded. [To be supplied.]
IsTokeni | Overloaded. [To be supplied.]
QuoteChar | [To be supplied.]
ScanContent | [To be supplied.]
ScanDecEntity | [To be supplied.]
ScanDeclaration | [To be supplied.]
ScanDtdContent | [To be supplied.]
ScanDtdMarkup | [To be supplied.]
ScanHexEntity | [To be supplied.]
ScanIgnoreSect | [To be supplied.]
ScanLiteral | Overloaded. [To be supplied.]
ScanMarkup | [To be supplied.]
ScanNamedEntity | [To be supplied.]
ScanPI | [To be supplied.]
ScanToken | [To be supplied.]
ScanWhitespace | [To be supplied.]
SkipWhitespace | [To be supplied.]
SwitchEncoding | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlScanner Class | System.Data.XML Namespace


XmlScanner Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(INameTable)
[C#] public XmlScanner(INameTable);
[C++] public: XmlScanner(INameTable*);
[JScript] public function XmlScanner(INameTable);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Char(), INameTable)
[C#] public XmlScanner(char[], INameTable);
[C++] public: XmlScanner(__wchar_t*[], INameTable);
[JScript] public function XmlScanner(Char[], INameTable);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Char(), Integer, Integer, INameTable, Integer, Integer)
[C#] public XmlScanner(char[], int, int, INameTable, int, int);
[C++] public: XmlScanner(__wchar_t*[], int, int, INameTable, int, int);
[JScript] public function XmlScanner(Char[], int, int, INameTable, int, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(StreamReader, INameTable)
[C#] public XmlScanner(StreamReader, INameTable);
[C++] public: XmlScanner(StreamReader*, INameTable);
[JScript] public function XmlScanner(StreamReader, INameTable);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(TextReader, INameTable)
[C#] public XmlScanner(TextReader, INameTable);
[C++] public: XmlScanner(TextReader*, INameTable);
[JScript] public function XmlScanner(TextReader, INameTable);

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner Constructor (INameTable)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal ntable As INameTable _
)
[C#]
public XmlScanner(
   INameTable ntable
);
[C++]
public: XmlScanner(
   INameTable* ntable
);
[JScript]
public function XmlScanner(
   ntable : INameTable
);

Parameters

ntable
[To be supplied.]

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace | XmlScanner Constructor Overload List


XmlScanner Constructor (Char[], INameTable)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal text() As Char, _
   ByVal ntable As INameTable _
)
[C#]
public XmlScanner(
   char[] text,
   INameTable ntable
);
[C++]
public: XmlScanner(
   __wchar_t* text[],
   INameTable* ntable
);
[JScript]
public function XmlScanner(
   text : Char[],
   ntable : INameTable
);

Parameters

text
[To be supplied.]
ntable
[To be supplied.]

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace | XmlScanner Constructor Overload List


XmlScanner Constructor (Char[], Int32, Int32, INameTable, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal text() As Char, _
   ByVal offset As Integer, _
   ByVal length As Integer, _
   ByVal ntable As INameTable, _
   ByVal lineNum As Integer, _
   ByVal linePos As Integer _
)
[C#]
public XmlScanner(
   char[] text,
   int offset,
   int length,
   INameTable ntable,
   int lineNum,
   int linePos
);
[C++]
public: XmlScanner(
   __wchar_t* text[],
   int offset,
   int length,
   INameTable* ntable,
   int lineNum,
   int linePos
);
[JScript]
public function XmlScanner(
   text : Char[],
   offset : int,
   length : int,
   ntable : INameTable,
   lineNum : int,
   linePos : int
);

Parameters

text
[To be supplied.]
offset
[To be supplied.]
length
[To be supplied.]
ntable
[To be supplied.]
lineNum
[To be supplied.]
linePos
[To be supplied.]

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace | XmlScanner Constructor Overload List


XmlScanner Constructor (StreamReader, INameTable)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal reader As StreamReader, _
   ByVal ntable As INameTable _
)
[C#]
public XmlScanner(
   StreamReader reader,
   INameTable ntable
);
[C++]
public: XmlScanner(
   StreamReader* reader,
   INameTable* ntable
);
[JScript]
public function XmlScanner(
   reader : StreamReader,
   ntable : INameTable
);

Parameters

reader
[To be supplied.]
ntable
[To be supplied.]

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace | XmlScanner Constructor Overload List


XmlScanner Constructor (TextReader, INameTable)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal reader As TextReader, _
   ByVal ntable As INameTable _
)
[C#]
public XmlScanner(
   TextReader reader,
   INameTable ntable
);
[C++]
public: XmlScanner(
   TextReader* reader,
   INameTable* ntable
);
[JScript]
public function XmlScanner(
   reader : TextReader,
   ntable : INameTable
);

Parameters

reader
[To be supplied.]
ntable
[To be supplied.]

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace | XmlScanner Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlScanner Properties

The properties of the XmlScanner class are listed below. For a complete list of XmlScanner class members, see the XmlScanner Members topic.

Public:

CurrentPos | [To be supplied.]
InDTD | [To be supplied.]
ReadBufferConsistency | [To be supplied.]
StartPos | [To be supplied.]

See Also

XmlScanner Class | System.Data.XML Namespace


XmlScanner.CurrentPos

[To be supplied.]

[Visual Basic]
Public Property CurrentPos As Integer
[C#]
public int CurrentPos {get; set;}
[C++]
public: __property int get_CurrentPos();
public: __property void set_CurrentPos(int);
[JScript]
public function get CurrentPos() : int;
public function set CurrentPos(int);

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.InDTD

[To be supplied.]

[Visual Basic]
Public Property InDTD As Boolean
[C#]
public bool InDTD {get; set;}
[C++]
public: __property bool get_InDTD();
public: __property void set_InDTD(bool);
[JScript]
public function get InDTD() : Boolean;
public function set InDTD(Boolean);

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.ReadBufferConsistency

[To be supplied.]

[Visual Basic]
Public Property ReadBufferConsistency As Boolean
[C#]
public bool ReadBufferConsistency {get; set;}
[C++]
public: __property bool get_ReadBufferConsistency();
public: __property void set_ReadBufferConsistency(bool);
[JScript]
public function get ReadBufferConsistency() : Boolean;
public function set ReadBufferConsistency(Boolean);

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.StartPos

[To be supplied.]

[Visual Basic]
Public Property StartPos As Integer
[C#]
public int StartPos {get; set;}
[C++]
public: __property int get_StartPos();
public: __property void set_StartPos(int);
[JScript]
public function get StartPos() : int;
public function set StartPos(int);

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlScanner Methods

The methods of the XmlScanner class are listed below. For a complete list of XmlScanner class members, see the XmlScanner Members topic.

Public:

Advance | Overloaded. [To be supplied.]
Close | [To be supplied.]
Colon | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetChar | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInternalBuffer | [To be supplied.]
GetLength | [To be supplied.]
GetLineNum | [To be supplied.]
GetLinePos | [To be supplied.]
GetOffset | [To be supplied.]
GetOffsetAndLength | [To be supplied.]
GetStartChar | Overloaded. [To be supplied.]
GetStartLineNum | [To be supplied.]
GetStartLinePos | [To be supplied.]
GetStringFromBuffer | [To be supplied.]
GetText | Overloaded. [To be supplied.]
GetTextAtom | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsToken | Overloaded. [To be supplied.]
IsTokeni | Overloaded. [To be supplied.]
QuoteChar | [To be supplied.]
ScanContent | [To be supplied.]
ScanDecEntity | [To be supplied.]
ScanDeclaration | [To be supplied.]
ScanDtdContent | [To be supplied.]
ScanDtdMarkup | [To be supplied.]
ScanHexEntity | [To be supplied.]
ScanIgnoreSect | [To be supplied.]
ScanLiteral | Overloaded. [To be supplied.]
ScanMarkup | [To be supplied.]
ScanNamedEntity | [To be supplied.]
ScanPI | [To be supplied.]
ScanToken | [To be supplied.]
ScanWhitespace | [To be supplied.]
SkipWhitespace | [To be supplied.]
SwitchEncoding | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlScanner Class | System.Data.XML Namespace


XmlScanner.Advance

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub Advance(Integer)
[C#] public void Advance(int);
[C++] public: void Advance(int);
[JScript] public function Advance(int);

[To be supplied.]

[Visual Basic] Overloads Public Sub Advance()
[C#] public void Advance();
[C++] public: void Advance();
[JScript] public function Advance();

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.Advance (Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Advance( _
   ByVal amount As Integer _
)
[C#]
public void Advance(
   int amount
);
[C++]
public: void Advance(
   int amount
);
[JScript]
public function Advance(
   amount : int
);

Parameters

amount
[To be supplied.]

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace | XmlScanner.Advance Overload List


XmlScanner.Advance ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub Advance()
[C#]
public void Advance();
[C++]
public: void Advance();
[JScript]
public function Advance();

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace | XmlScanner.Advance Overload List


XmlScanner.Close

[To be supplied.]

[Visual Basic]
Public Sub Close()
[C#]
public void Close();
[C++]
public: void Close();
[JScript]
public function Close();

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.Colon

[To be supplied.]

[Visual Basic]
Public Function Colon() As Integer
[C#]
public int Colon();
[C++]
public: int Colon();
[JScript]
public function Colon() : int;

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.GetChar

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function GetChar(Integer) As Char
[C#] public char GetChar(int);
[C++] public: __wchar_t GetChar(int);
[JScript] public function GetChar(int) : Char;

[To be supplied.]

[Visual Basic] Overloads Public Function GetChar() As Char
[C#] public char GetChar();
[C++] public: __wchar_t GetChar();
[JScript] public function GetChar() : Char;

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.GetChar (Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Function GetChar( _
   ByVal offset As Integer _
) As Char
[C#]
public char GetChar(
   int offset
);
[C++]
public: __wchar_t GetChar(
   int offset
);
[JScript]
public function GetChar(
   offset : int
) : Char;

Parameters

offset
[To be supplied.]

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace | XmlScanner.GetChar Overload List


XmlScanner.GetChar ()

[To be supplied.]

[Visual Basic]
Overloads Public Function GetChar() As Char
[C#]
public char GetChar();
[C++]
public: __wchar_t GetChar();
[JScript]
public function GetChar() : Char;

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace | XmlScanner.GetChar Overload List


XmlScanner.GetInternalBuffer

[To be supplied.]

[Visual Basic]
Public Function GetInternalBuffer() As Char ()
[C#]
public char[] GetInternalBuffer();
[C++]
public: __wchar_t* GetInternalBuffer() [];
[JScript]
public function GetInternalBuffer() : Char[];

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.GetLength

[To be supplied.]

[Visual Basic]
Public Function GetLength() As Integer
[C#]
public int GetLength();
[C++]
public: int GetLength();
[JScript]
public function GetLength() : int;

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.GetLineNum

[To be supplied.]

[Visual Basic]
Public Function GetLineNum() As Integer
[C#]
public int GetLineNum();
[C++]
public: int GetLineNum();
[JScript]
public function GetLineNum() : int;

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.GetLinePos

[To be supplied.]

[Visual Basic]
Public Function GetLinePos() As Integer
[C#]
public int GetLinePos();
[C++]
public: int GetLinePos();
[JScript]
public function GetLinePos() : int;

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.GetOffset

[To be supplied.]

[Visual Basic]
Public Function GetOffset() As Integer
[C#]
public int GetOffset();
[C++]
public: int GetOffset();
[JScript]
public function GetOffset() : int;

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.GetOffsetAndLength

[To be supplied.]

[Visual Basic]
Public Sub GetOffsetAndLength( _
   ByRef offset As Integer, _
   ByRef length As Integer _
)
[C#]
public void GetOffsetAndLength(
   ref int offset,
   ref int length
);
[C++]
public: void GetOffsetAndLength(
   int** offset,
   int** length
);
[JScript]
public function GetOffsetAndLength(
   offset : int,
   length : int
);

Parameters

offset
[To be supplied.]
length
[To be supplied.]

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.GetStartChar

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function GetStartChar(Integer) As Char
[C#] public char GetStartChar(int);
[C++] public: __wchar_t GetStartChar(int);
[JScript] public function GetStartChar(int) : Char;

[To be supplied.]

[Visual Basic] Overloads Public Function GetStartChar() As Char
[C#] public char GetStartChar();
[C++] public: __wchar_t GetStartChar();
[JScript] public function GetStartChar() : Char;

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.GetStartChar (Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Function GetStartChar( _
   ByVal i As Integer _
) As Char
[C#]
public char GetStartChar(
   int i
);
[C++]
public: __wchar_t GetStartChar(
   int i
);
[JScript]
public function GetStartChar(
   i : int
) : Char;

Parameters

i
[To be supplied.]

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace | XmlScanner.GetStartChar Overload List


XmlScanner.GetStartChar ()

[To be supplied.]

[Visual Basic]
Overloads Public Function GetStartChar() As Char
[C#]
public char GetStartChar();
[C++]
public: __wchar_t GetStartChar();
[JScript]
public function GetStartChar() : Char;

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace | XmlScanner.GetStartChar Overload List


XmlScanner.GetStartLineNum

[To be supplied.]

[Visual Basic]
Public Function GetStartLineNum() As Integer
[C#]
public int GetStartLineNum();
[C++]
public: int GetStartLineNum();
[JScript]
public function GetStartLineNum() : int;

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.GetStartLinePos

[To be supplied.]

[Visual Basic]
Public Function GetStartLinePos() As Integer
[C#]
public int GetStartLinePos();
[C++]
public: int GetStartLinePos();
[JScript]
public function GetStartLinePos() : int;

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.GetStringFromBuffer

[To be supplied.]

[Visual Basic]
Public Function GetStringFromBuffer( _
   ByVal start As Integer, _
   ByVal length As Integer _
) As String
[C#]
public string GetStringFromBuffer(
   int start,
   int length
);
[C++]
public: String* GetStringFromBuffer(
   int start,
   int length
);
[JScript]
public function GetStringFromBuffer(
   start : int,
   length : int
) : String;

Parameters

start
[To be supplied.]
length
[To be supplied.]

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.GetText

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function GetText() As String
[C#] public string GetText();
[C++] public: String* GetText();
[JScript] public function GetText() : String;

[To be supplied.]

[Visual Basic] Overloads Public Function GetText(Integer, Integer) As String
[C#] public string GetText(int, int);
[C++] public: String* GetText(int, int);
[JScript] public function GetText(int, int) : String;

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.GetText ()

[To be supplied.]

[Visual Basic]
Overloads Public Function GetText() As String
[C#]
public string GetText();
[C++]
public: String* GetText();
[JScript]
public function GetText() : String;

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace | XmlScanner.GetText Overload List


XmlScanner.GetText (Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Function GetText( _
   ByVal offset As Integer, _
   ByVal length As Integer _
) As String
[C#]
public string GetText(
   int offset,
   int length
);
[C++]
public: String* GetText(
   int offset,
   int length
);
[JScript]
public function GetText(
   offset : int,
   length : int
) : String;

Parameters

offset
[To be supplied.]
length
[To be supplied.]

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace | XmlScanner.GetText Overload List


XmlScanner.GetTextAtom

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function GetTextAtom() As String
[C#] public string GetTextAtom();
[C++] public: String* GetTextAtom();
[JScript] public function GetTextAtom() : String;

[To be supplied.]

[Visual Basic] Overloads Public Function GetTextAtom(Integer, Integer) As String
[C#] public string GetTextAtom(int, int);
[C++] public: String* GetTextAtom(int, int);
[JScript] public function GetTextAtom(int, int) : String;

[To be supplied.]

[Visual Basic] Overloads Public Function GetTextAtom(String) As String
[C#] public string GetTextAtom(String);
[C++] public: String* GetTextAtom(String*);
[JScript] public function GetTextAtom(String) : String;

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.GetTextAtom ()

[To be supplied.]

[Visual Basic]
Overloads Public Function GetTextAtom() As String
[C#]
public string GetTextAtom();
[C++]
public: String* GetTextAtom();
[JScript]
public function GetTextAtom() : String;

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace | XmlScanner.GetTextAtom Overload List


XmlScanner.GetTextAtom (Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Function GetTextAtom( _
   ByVal offset As Integer, _
   ByVal length As Integer _
) As String
[C#]
public string GetTextAtom(
   int offset,
   int length
);
[C++]
public: String* GetTextAtom(
   int offset,
   int length
);
[JScript]
public function GetTextAtom(
   offset : int,
   length : int
) : String;

Parameters

offset
[To be supplied.]
length
[To be supplied.]

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace | XmlScanner.GetTextAtom Overload List


XmlScanner.GetTextAtom (String)

[To be supplied.]

[Visual Basic]
Overloads Public Function GetTextAtom( _
   ByVal name As String _
) As String
[C#]
public string GetTextAtom(
   string name
);
[C++]
public: String* GetTextAtom(
   String* name
);
[JScript]
public function GetTextAtom(
   name : String
) : String;

Parameters

name
[To be supplied.]

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace | XmlScanner.GetTextAtom Overload List


XmlScanner.IsToken

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function IsToken(Char()) As Boolean
[C#] public bool IsToken(char[]);
[C++] public: bool IsToken(__wchar_t*[]);
[JScript] public function IsToken(Char[]) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsToken(String) As Boolean
[C#] public bool IsToken(String);
[C++] public: bool IsToken(String*);
[JScript] public function IsToken(String) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsToken(Integer) As Boolean
[C#] public bool IsToken(int);
[C++] public: bool IsToken(int);
[JScript] public function IsToken(int) : Boolean;

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.IsToken (Char[])

[To be supplied.]

[Visual Basic]
Overloads Public Function IsToken( _
   ByVal pszName() As Char _
) As Boolean
[C#]
public bool IsToken(
   char[] pszName
);
[C++]
public: bool IsToken(
   __wchar_t* pszName[]
);
[JScript]
public function IsToken(
   pszName : Char[]
) : Boolean;

Parameters

pszName
[To be supplied.]

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace | XmlScanner.IsToken Overload List


XmlScanner.IsToken (String)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsToken( _
   ByVal pszName As String _
) As Boolean
[C#]
public bool IsToken(
   string pszName
);
[C++]
public: bool IsToken(
   String* pszName
);
[JScript]
public function IsToken(
   pszName : String
) : Boolean;

Parameters

pszName
[To be supplied.]

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace | XmlScanner.IsToken Overload List


XmlScanner.IsToken (Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsToken( _
   ByVal token As Integer _
) As Boolean
[C#]
public bool IsToken(
   int token
);
[C++]
public: bool IsToken(
   int token
);
[JScript]
public function IsToken(
   token : int
) : Boolean;

Parameters

token
[To be supplied.]

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace | XmlScanner.IsToken Overload List


XmlScanner.IsTokeni

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function IsTokeni(Char()) As Boolean
[C#] public bool IsTokeni(char[]);
[C++] public: bool IsTokeni(__wchar_t*[]);
[JScript] public function IsTokeni(Char[]) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsTokeni(String) As Boolean
[C#] public bool IsTokeni(String);
[C++] public: bool IsTokeni(String*);
[JScript] public function IsTokeni(String) : Boolean;

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.IsTokeni (Char[])

[To be supplied.]

[Visual Basic]
Overloads Public Function IsTokeni( _
   ByVal pszName() As Char _
) As Boolean
[C#]
public bool IsTokeni(
   char[] pszName
);
[C++]
public: bool IsTokeni(
   __wchar_t* pszName[]
);
[JScript]
public function IsTokeni(
   pszName : Char[]
) : Boolean;

Parameters

pszName
[To be supplied.]

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace | XmlScanner.IsTokeni Overload List


XmlScanner.IsTokeni (String)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsTokeni( _
   ByVal pszName As String _
) As Boolean
[C#]
public bool IsTokeni(
   string pszName
);
[C++]
public: bool IsTokeni(
   String* pszName
);
[JScript]
public function IsTokeni(
   pszName : String
) : Boolean;

Parameters

pszName
[To be supplied.]

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace | XmlScanner.IsTokeni Overload List


XmlScanner.QuoteChar

[To be supplied.]

[Visual Basic]
Public Function QuoteChar() As Char
[C#]
public char QuoteChar();
[C++]
public: __wchar_t QuoteChar();
[JScript]
public function QuoteChar() : Char;

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.ScanContent

[To be supplied.]

[Visual Basic]
Public Function ScanContent() As Integer
[C#]
public int ScanContent();
[C++]
public: int ScanContent();
[JScript]
public function ScanContent() : int;

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.ScanDecEntity

[To be supplied.]

[Visual Basic]
Public Function ScanDecEntity() As Char
[C#]
public char ScanDecEntity();
[C++]
public: __wchar_t ScanDecEntity();
[JScript]
public function ScanDecEntity() : Char;

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.ScanDeclaration

[To be supplied.]

[Visual Basic]
Public Sub ScanDeclaration()
[C#]
public void ScanDeclaration();
[C++]
public: void ScanDeclaration();
[JScript]
public function ScanDeclaration();

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.ScanDtdContent

[To be supplied.]

[Visual Basic]
Public Function ScanDtdContent() As Integer
[C#]
public int ScanDtdContent();
[C++]
public: int ScanDtdContent();
[JScript]
public function ScanDtdContent() : int;

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.ScanDtdMarkup

[To be supplied.]

[Visual Basic]
Public Function ScanDtdMarkup() As Integer
[C#]
public int ScanDtdMarkup();
[C++]
public: int ScanDtdMarkup();
[JScript]
public function ScanDtdMarkup() : int;

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.ScanHexEntity

[To be supplied.]

[Visual Basic]
Public Function ScanHexEntity() As Char
[C#]
public char ScanHexEntity();
[C++]
public: __wchar_t ScanHexEntity();
[JScript]
public function ScanHexEntity() : Char;

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.ScanIgnoreSect

[To be supplied.]

[Visual Basic]
Public Function ScanIgnoreSect() As Integer
[C#]
public int ScanIgnoreSect();
[C++]
public: int ScanIgnoreSect();
[JScript]
public function ScanIgnoreSect() : int;

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.ScanLiteral

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function ScanLiteral() As Boolean
[C#] public bool ScanLiteral();
[C++] public: bool ScanLiteral();
[JScript] public function ScanLiteral() : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function ScanLiteral(Boolean, Boolean, Boolean, Boolean) As Integer
[C#] public int ScanLiteral(bool, bool, bool, bool);
[C++] public: int ScanLiteral(bool, bool, bool, bool);
[JScript] public function ScanLiteral(Boolean, Boolean, Boolean, Boolean) : int;

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.ScanLiteral ()

[To be supplied.]

[Visual Basic]
Overloads Public Function ScanLiteral() As Boolean
[C#]
public bool ScanLiteral();
[C++]
public: bool ScanLiteral();
[JScript]
public function ScanLiteral() : Boolean;

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace | XmlScanner.ScanLiteral Overload List


XmlScanner.ScanLiteral (Boolean, Boolean, Boolean, Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Function ScanLiteral( _
   ByVal fGenEntity As Boolean, _
   ByVal fParEntity As Boolean, _
   ByVal fEndQuote As Boolean, _
   ByVal fInEntityValue As Boolean _
) As Integer
[C#]
public int ScanLiteral(
   bool fGenEntity,
   bool fParEntity,
   bool fEndQuote,
   bool fInEntityValue
);
[C++]
public: int ScanLiteral(
   bool fGenEntity,
   bool fParEntity,
   bool fEndQuote,
   bool fInEntityValue
);
[JScript]
public function ScanLiteral(
   fGenEntity : Boolean,
   fParEntity : Boolean,
   fEndQuote : Boolean,
   fInEntityValue : Boolean
) : int;

Parameters

fGenEntity
[To be supplied.]
fParEntity
[To be supplied.]
fEndQuote
[To be supplied.]
fInEntityValue
[To be supplied.]

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace | XmlScanner.ScanLiteral Overload List


XmlScanner.ScanMarkup

[To be supplied.]

[Visual Basic]
Public Function ScanMarkup() As Integer
[C#]
public int ScanMarkup();
[C++]
public: int ScanMarkup();
[JScript]
public function ScanMarkup() : int;

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.ScanNamedEntity

[To be supplied.]

[Visual Basic]
Public Function ScanNamedEntity() As Char
[C#]
public char ScanNamedEntity();
[C++]
public: __wchar_t ScanNamedEntity();
[JScript]
public function ScanNamedEntity() : Char;

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.ScanPI

[To be supplied.]

[Visual Basic]
Public Sub ScanPI()
[C#]
public void ScanPI();
[C++]
public: void ScanPI();
[JScript]
public function ScanPI();

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.ScanToken

[To be supplied.]

[Visual Basic]
Public Function ScanToken( _
   ByVal expected As Integer _
) As Integer
[C#]
public int ScanToken(
   int expected
);
[C++]
public: int ScanToken(
   int expected
);
[JScript]
public function ScanToken(
   expected : int
) : int;

Parameters

expected
[To be supplied.]

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.ScanWhitespace

[To be supplied.]

[Visual Basic]
Public Function ScanWhitespace() As Boolean
[C#]
public bool ScanWhitespace();
[C++]
public: bool ScanWhitespace();
[JScript]
public function ScanWhitespace() : Boolean;

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.SkipWhitespace

[To be supplied.]

[Visual Basic]
Public Function SkipWhitespace() As Integer
[C#]
public int SkipWhitespace();
[C++]
public: int SkipWhitespace();
[JScript]
public function SkipWhitespace() : int;

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlScanner.SwitchEncoding

[To be supplied.]

[Visual Basic]
Public Sub SwitchEncoding( _
   ByVal encoding As String _
)
[C#]
public void SwitchEncoding(
   string encoding
);
[C++]
public: void SwitchEncoding(
   String* encoding
);
[JScript]
public function SwitchEncoding(
   encoding : String
);

Parameters

encoding
[To be supplied.]

See Also

XmlScanner Class | XmlScanner Members | System.Data.XML Namespace


XmlSchemaCollection Class

The XmlSchemaCollection contains a set of namespace URI's. Each namespace also have an associated private data cache corresponding to the XML-Data Schema or W3C XML Schema. The XmlSchemaCollection will able to load XSD and XDR schemas, and compile them into an internal "cooked schema representation". The Validate() method then uses this internal representation for efficient runtime validation of any given subtree.

Object
XmlSchemaCollection

[Visual Basic]
Public Class XmlSchemaCollection
[C#]
public class XmlSchemaCollection
[C++]
public __gc class XmlSchemaCollection
[JScript]
public class XmlSchemaCollection

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

XmlSchemaCollection Members | System.Data.XML Namespace | UriResolver


XmlSchemaCollection Members

Public:

Constructor

XmlSchemaCollection Constructor Public constructor.

Properties

Length | Returns the number of namespaces defined in this collection (whether or not there is an actual schema associated with those namespaces or not).
NameTable | The nametable

Methods

Add | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | Looks up the schema by it's associated namespace URI
GetEnumerator | Get a IEnumerator of the XmlSchemaCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetResolver | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
Remove | Removes the schema associated with the given namespace URI.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Validates the given subtree using the schemas defined in this schema collection.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlSchemaCollection Class | System.Data.XML Namespace


XmlSchemaCollection Constructor

Public constructor.

[Visual Basic]
Public Sub New( _
   ByVal nt As INameTable _
)
[C#]
public XmlSchemaCollection(
   INameTable nt
);
[C++]
public: XmlSchemaCollection(
   INameTable* nt
);
[JScript]
public function XmlSchemaCollection(
   nt : INameTable
);

Parameters

nt
[To be supplied.]

See Also

XmlSchemaCollection Class | XmlSchemaCollection Members | System.Data.XML Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlSchemaCollection Properties

The properties of the XmlSchemaCollection class are listed below. For a complete list of XmlSchemaCollection class members, see the XmlSchemaCollection Members topic.

Public:

Length | Returns the number of namespaces defined in this collection (whether or not there is an actual schema associated with those namespaces or not).
NameTable | The nametable

See Also

XmlSchemaCollection Class | System.Data.XML Namespace


XmlSchemaCollection.Length

Returns the number of namespaces defined in this collection (whether or not there is an actual schema associated with those namespaces or not).

[Visual Basic]
Public ReadOnly Property Length As Integer
[C#]
public int Length {get;}
[C++]
public: __property int get_Length();
[JScript]
public function get Length() : int;

See Also

XmlSchemaCollection Class | XmlSchemaCollection Members | System.Data.XML Namespace


XmlSchemaCollection.NameTable

The nametable

[Visual Basic]
Public ReadOnly Property NameTable As INameTable
[C#]
public INameTable NameTable {get;}
[C++]
public: __property INameTable* get_NameTable();
[JScript]
public function get NameTable() : INameTable;

See Also

XmlSchemaCollection Class | XmlSchemaCollection Members | System.Data.XML Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlSchemaCollection Methods

The methods of the XmlSchemaCollection class are listed below. For a complete list of XmlSchemaCollection class members, see the XmlSchemaCollection Members topic.

Public:

Add | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get | Looks up the schema by it's associated namespace URI
GetEnumerator | Get a IEnumerator of the XmlSchemaCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetResolver | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
Remove | Removes the schema associated with the given namespace URI.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Validates the given subtree using the schemas defined in this schema collection.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlSchemaCollection Class | System.Data.XML Namespace


XmlSchemaCollection.Add

[To be supplied.]

Overload List

Add the given schemas into the schema collection. If the given schema references other namespaces, the schemas for those other namespaces are NOT automatically loaded

[Visual Basic] Overloads Public Sub Add(String, XmlReader)
[C#] public void Add(String, XmlReader);
[C++] public: void Add(String*, XmlReader);
[JScript] public function Add(String, XmlReader);

Add the given schemas into the schema collection. If the given schema references other namespaces, the schemas for those other namespaces are NOT automatically loaded

[Visual Basic] Overloads Public Sub Add(String, IDataNavigator)
[C#] public void Add(String, IDataNavigator);
[C++] public: void Add(String*, IDataNavigator);
[JScript] public function Add(String, IDataNavigator);

Adds all the namespaces defined in the given collection (including their associated schemas) to this collection

[Visual Basic] Overloads Public Sub Add(XmlSchemaCollection)
[C#] public void Add(XmlSchemaCollection);
[C++] public: void Add(XmlSchemaCollection*);
[JScript] public function Add(XmlSchemaCollection);

See Also

XmlSchemaCollection Class | XmlSchemaCollection Members | System.Data.XML Namespace


XmlSchemaCollection.Add (String, XmlReader)

Add the given schemas into the schema collection. If the given schema references other namespaces, the schemas for those other namespaces are NOT automatically loaded

[Visual Basic]
Overloads Public Sub Add( _
   ByVal namespaceURI As String, _
   ByVal reader As XmlReader _
)
[C#]
public void Add(
   string namespaceURI,
   XmlReader reader
);
[C++]
public: void Add(
   String* namespaceURI,
   XmlReader* reader
);
[JScript]
public function Add(
   namespaceURI : String,
   reader : XmlReader
);

Parameters

namespaceURI
[To be supplied.]
reader
[To be supplied.]

See Also

XmlSchemaCollection Class | XmlSchemaCollection Members | System.Data.XML Namespace | XmlSchemaCollection.Add Overload List


XmlSchemaCollection.Add (String, IDataNavigator)

Add the given schemas into the schema collection. If the given schema references other namespaces, the schemas for those other namespaces are NOT automatically loaded

[Visual Basic]
Overloads Public Sub Add( _
   ByVal namespaceURI As String, _
   ByVal nav As IDataNavigator _
)
[C#]
public void Add(
   string namespaceURI,
   IDataNavigator nav
);
[C++]
public: void Add(
   String* namespaceURI,
   IDataNavigator* nav
);
[JScript]
public function Add(
   namespaceURI : String,
   nav : IDataNavigator
);

Parameters

namespaceURI
[To be supplied.]
nav
[To be supplied.]

See Also

XmlSchemaCollection Class | XmlSchemaCollection Members | System.Data.XML Namespace | XmlSchemaCollection.Add Overload List


XmlSchemaCollection.Add (XmlSchemaCollection)

Adds all the namespaces defined in the given collection (including their associated schemas) to this collection

[Visual Basic]
Overloads Public Sub Add( _
   ByVal other As XmlSchemaCollection _
)
[C#]
public void Add(
   XmlSchemaCollection other
);
[C++]
public: void Add(
   XmlSchemaCollection* other
);
[JScript]
public function Add(
   other : XmlSchemaCollection
);

Parameters

other
[To be supplied.]

See Also

XmlSchemaCollection Class | XmlSchemaCollection Members | System.Data.XML Namespace | XmlSchemaCollection.Add Overload List


XmlSchemaCollection.Get

Looks up the schema by it's associated namespace URI

[Visual Basic]
Public Function Get( _
   ByVal namespaceURI As String _
) As IDataNavigator
[C#]
public IDataNavigator Get(
   string namespaceURI
);
[C++]
public: IDataNavigator* Get(
   String* namespaceURI
);
[JScript]
public function Get(
   namespaceURI : String
) : IDataNavigator;

Parameters

namespaceURI
[To be supplied.]

Return Value

A read/only view of the schema. Null if there is currently no loaded schema associated with the given namespace.

See Also

XmlSchemaCollection Class | XmlSchemaCollection Members | System.Data.XML Namespace


XmlSchemaCollection.GetEnumerator

Get a IEnumerator of the XmlSchemaCollection.

[Visual Basic]
Public Function GetEnumerator() As IEnumerator
[C#]
public IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

Return Value

An enumerator for iterating over all the namespaces defined in the current collection. The iterator returns the namespace URI strings.

See Also

XmlSchemaCollection Class | XmlSchemaCollection Members | System.Data.XML Namespace


XmlSchemaCollection.GetResolver

[To be supplied.]

[Visual Basic]
Public Function GetResolver() As IUriResolver
[C#]
public IUriResolver GetResolver();
[C++]
public: IUriResolver* GetResolver();
[JScript]
public function GetResolver() : IUriResolver;

See Also

XmlSchemaCollection Class | XmlSchemaCollection Members | System.Data.XML Namespace


XmlSchemaCollection.Remove

Removes the schema associated with the given namespace URI.

[Visual Basic]
Public Sub Remove( _
   ByVal namespaceURI As String _
)
[C#]
public void Remove(
   string namespaceURI
);
[C++]
public: void Remove(
   String* namespaceURI
);
[JScript]
public function Remove(
   namespaceURI : String
);

Parameters

namespaceURI
[To be supplied.]

See Also

XmlSchemaCollection Class | XmlSchemaCollection Members | System.Data.XML Namespace


XmlSchemaCollection.Validate

Validates the given subtree using the schemas defined in this schema collection.

[Visual Basic]
Public Sub Validate( _
   ByVal navigator As IDataNavigator, _
   ByVal validationCallback As ValidationDelegate _
)
[C#]
public void Validate(
   IDataNavigator navigator,
   ValidationDelegate validationCallback
);
[C++]
public: void Validate(
   IDataNavigator* navigator,
   ValidationDelegate* validationCallback
);
[JScript]
public function Validate(
   navigator : IDataNavigator,
   validationCallback : ValidationDelegate
);

Parameters

navigator
[To be supplied.]
validationCallback
[To be supplied.]

See Also

XmlSchemaCollection Class | XmlSchemaCollection Members | System.Data.XML Namespace


XmlWriter Class

[To be supplied.]

Object
XmlWriter

[Visual Basic]
Public Class XmlWriter
   Implements IDataWriter, IDataBuffer
[C#]
public class XmlWriter : IDataWriter, IDataBuffer
[C++]
public __gc class XmlWriter : public IDataWriter, IDataBuffer
[JScript]
public class XmlWriter implements IDataWriter, IDataBuffer

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

XmlWriter Members | System.Data.XML Namespace


XmlWriter Members

Public:

Constructor

XmlWriter Constructor Overloaded. [To be supplied.]

Properties

DataTypeName | [To be supplied.]
DataTypeNamespace | [To be supplied.]
Depth | [To be supplied.]
Empty | [To be supplied.]
FieldCount | [To be supplied.]
Flags | [To be supplied.]
HasValue | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlWriter class.
Name | [To be supplied.]
Namespace | [To be supplied.]
NameTable | [To be supplied.]
NodeType | [To be supplied.]
Prefix | [To be supplied.]
Value | [To be supplied.]
WriteState | [To be supplied.]

Methods

Clear | [To be supplied.]
Close | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBoolean | [To be supplied.]
GetByte | [To be supplied.]
GetBytes | [To be supplied.]
GetChar | [To be supplied.]
GetChars | [To be supplied.]
GetCurrency | [To be supplied.]
GetData | [To be supplied.]
GetDataTypeName | [To be supplied.]
GetDataTypeNamespace | [To be supplied.]
GetDateTime | [To be supplied.]
GetDecimal | [To be supplied.]
GetDouble | [To be supplied.]
GetFieldType | [To be supplied.]
GetFloat | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInt16 | [To be supplied.]
GetInt32 | [To be supplied.]
GetInt64 | [To be supplied.]
GetName | [To be supplied.]
GetNamespace | [To be supplied.]
GetOrdinal | Overloaded. [To be supplied.]
GetPrefix | [To be supplied.]
GetRaw | [To be supplied.]
GetStream | [To be supplied.]
GetString | [To be supplied.]
GetTimeSpan | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | [To be supplied.]
GetValues | [To be supplied.]
IsNull | [To be supplied.]
SetBoolean | [To be supplied.]
SetByte | [To be supplied.]
SetBytes | [To be supplied.]
SetChar | [To be supplied.]
SetChars | [To be supplied.]
SetCurrency | [To be supplied.]
SetData | [To be supplied.]
SetDateTime | [To be supplied.]
SetDecimal | [To be supplied.]
SetDouble | [To be supplied.]
SetFloat | [To be supplied.]
SetInt16 | [To be supplied.]
SetInt32 | [To be supplied.]
SetInt64 | [To be supplied.]
SetName | [To be supplied.]
SetNamespace | [To be supplied.]
SetNull | [To be supplied.]
SetPrefix | [To be supplied.]
SetRaw | [To be supplied.]
SetStream | [To be supplied.]
SetString | [To be supplied.]
SetTimeSpan | [To be supplied.]
SetValue | [To be supplied.]
SetValues | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | [To be supplied.]

Fields

Namespaces [To be supplied.]

Protected:

Constructor

XmlWriter Constructor Overloaded. [To be supplied.]

Methods

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlWriter Class | System.Data.XML Namespace


XmlWriter Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Protected Sub New(INameTable)
[C#] protected XmlWriter(INameTable);
[C++] protected: XmlWriter(INameTable*);
[JScript] protected function XmlWriter(INameTable);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Encoding)
[C#] public XmlWriter(String, Encoding);
[C++] public: XmlWriter(String*, Encoding);
[JScript] public function XmlWriter(String, Encoding);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Encoding, INameTable)
[C#] public XmlWriter(String, Encoding, INameTable);
[C++] public: XmlWriter(String*, Encoding, INameTable);
[JScript] public function XmlWriter(String, Encoding, INameTable);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Stream, Encoding, Boolean)
[C#] public XmlWriter(Stream, Encoding, bool);
[C++] public: XmlWriter(Stream*, Encoding, bool);
[JScript] public function XmlWriter(Stream, Encoding, Boolean);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Stream, Encoding, Boolean, INameTable)
[C#] public XmlWriter(Stream, Encoding, bool, INameTable);
[C++] public: XmlWriter(Stream*, Encoding, bool, INameTable);
[JScript] public function XmlWriter(Stream, Encoding, Boolean, INameTable);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(TextWriter)
[C#] public XmlWriter(TextWriter);
[C++] public: XmlWriter(TextWriter*);
[JScript] public function XmlWriter(TextWriter);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(TextWriter, INameTable)
[C#] public XmlWriter(TextWriter, INameTable);
[C++] public: XmlWriter(TextWriter*, INameTable);
[JScript] public function XmlWriter(TextWriter, INameTable);

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter Constructor (INameTable)

[To be supplied.]

[Visual Basic]
Overloads Protected Sub New( _
   ByVal nameTable As INameTable _
)
[C#]
protected XmlWriter(
   INameTable nameTable
);
[C++]
protected: XmlWriter(
   INameTable* nameTable
);
[JScript]
protected function XmlWriter(
   nameTable : INameTable
);

Parameters

nameTable
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace | XmlWriter Constructor Overload List


XmlWriter Constructor (String, Encoding)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal fileName As String, _
   ByVal enc As Encoding _
)
[C#]
public XmlWriter(
   string fileName,
   Encoding enc
);
[C++]
public: XmlWriter(
   String* fileName,
   Encoding* enc
);
[JScript]
public function XmlWriter(
   fileName : String,
   enc : Encoding
);

Parameters

fileName
[To be supplied.]
enc
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace | XmlWriter Constructor Overload List


XmlWriter Constructor (String, Encoding, INameTable)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal fileName As String, _
   ByVal enc As Encoding, _
   ByVal nt As INameTable _
)
[C#]
public XmlWriter(
   string fileName,
   Encoding enc,
   INameTable nt
);
[C++]
public: XmlWriter(
   String* fileName,
   Encoding* enc,
   INameTable* nt
);
[JScript]
public function XmlWriter(
   fileName : String,
   enc : Encoding,
   nt : INameTable
);

Parameters

fileName
[To be supplied.]
enc
[To be supplied.]
nt
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace | XmlWriter Constructor Overload List


XmlWriter Constructor (Stream, Encoding, Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal output As Stream, _
   ByVal enc As Encoding, _
   ByVal byteOrderMark As Boolean _
)
[C#]
public XmlWriter(
   Stream output,
   Encoding enc,
   bool byteOrderMark
);
[C++]
public: XmlWriter(
   Stream* output,
   Encoding* enc,
   bool byteOrderMark
);
[JScript]
public function XmlWriter(
   output : Stream,
   enc : Encoding,
   byteOrderMark : Boolean
);

Parameters

output
[To be supplied.]
enc
[To be supplied.]
byteOrderMark
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace | XmlWriter Constructor Overload List


XmlWriter Constructor (Stream, Encoding, Boolean, INameTable)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal output As Stream, _
   ByVal enc As Encoding, _
   ByVal byteOrderMark As Boolean, _
   ByVal nt As INameTable _
)
[C#]
public XmlWriter(
   Stream output,
   Encoding enc,
   bool byteOrderMark,
   INameTable nt
);
[C++]
public: XmlWriter(
   Stream* output,
   Encoding* enc,
   bool byteOrderMark,
   INameTable* nt
);
[JScript]
public function XmlWriter(
   output : Stream,
   enc : Encoding,
   byteOrderMark : Boolean,
   nt : INameTable
);

Parameters

output
[To be supplied.]
enc
[To be supplied.]
byteOrderMark
[To be supplied.]
nt
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace | XmlWriter Constructor Overload List


XmlWriter Constructor (TextWriter)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal s As TextWriter _
)
[C#]
public XmlWriter(
   TextWriter s
);
[C++]
public: XmlWriter(
   TextWriter* s
);
[JScript]
public function XmlWriter(
   s : TextWriter
);

Parameters

s
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace | XmlWriter Constructor Overload List


XmlWriter Constructor (TextWriter, INameTable)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal s As TextWriter, _
   ByVal nt As INameTable _
)
[C#]
public XmlWriter(
   TextWriter s,
   INameTable nt
);
[C++]
public: XmlWriter(
   TextWriter* s,
   INameTable* nt
);
[JScript]
public function XmlWriter(
   s : TextWriter,
   nt : INameTable
);

Parameters

s
[To be supplied.]
nt
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace | XmlWriter Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlWriter Properties

The properties of the XmlWriter class are listed below. For a complete list of XmlWriter class members, see the XmlWriter Members topic.

Public:

DataTypeName | [To be supplied.]
DataTypeNamespace | [To be supplied.]
Depth | [To be supplied.]
Empty | [To be supplied.]
FieldCount | [To be supplied.]
Flags | [To be supplied.]
HasValue | [To be supplied.]
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlWriter class.
Name | [To be supplied.]
Namespace | [To be supplied.]
NameTable | [To be supplied.]
NodeType | [To be supplied.]
Prefix | [To be supplied.]
Value | [To be supplied.]
WriteState | [To be supplied.]

See Also

XmlWriter Class | System.Data.XML Namespace


XmlWriter.DataTypeName

[To be supplied.]

[Visual Basic]
Overridable Public Property DataTypeName As String
[C#]
public string DataTypeName {virtual get; set;}
[C++]
public: __property virtual String* get_DataTypeName();
public: __property void set_DataTypeName(String*);
[JScript]
public function get DataTypeName() : String;
public function set DataTypeName(String);

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.DataTypeNamespace

[To be supplied.]

[Visual Basic]
Overridable Public Property DataTypeNamespace As String
[C#]
public string DataTypeNamespace {virtual get; set;}
[C++]
public: __property virtual String* get_DataTypeNamespace();
public: __property void set_DataTypeNamespace(String*);
[JScript]
public function get DataTypeNamespace() : String;
public function set DataTypeNamespace(String);

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.Depth

[To be supplied.]

[Visual Basic]
Overridable Public Property Depth As Integer
[C#]
public int Depth {virtual get; virtual set;}
[C++]
public: __property virtual int get_Depth();
public: __property virtual void set_Depth(int);
[JScript]
public function get Depth() : int;
public function set Depth(int);

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.Empty

[To be supplied.]

[Visual Basic]
Overridable Public Property Empty As Boolean
[C#]
public bool Empty {virtual get; virtual set;}
[C++]
public: __property virtual bool get_Empty();
public: __property virtual void set_Empty(bool);
[JScript]
public function get Empty() : Boolean;
public function set Empty(Boolean);

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.FieldCount

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property FieldCount As Integer
[C#]
public int FieldCount {virtual get;}
[C++]
public: __property virtual int get_FieldCount();
[JScript]
public function get FieldCount() : int;

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.Flags

[To be supplied.]

[Visual Basic]
Public Property Flags As Integer
[C#]
public int Flags {get; set;}
[C++]
public: __property int get_Flags();
public: __property void set_Flags(int);
[JScript]
public function get Flags() : int;
public function set Flags(int);

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.HasValue

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property HasValue As Boolean
[C#]
public bool HasValue {virtual get;}
[C++]
public: __property virtual bool get_HasValue();
[JScript]
public function get HasValue() : Boolean;

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the XmlWriter class.

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Default Property Item(String) As Object
[C#] public object this[String] {virtual get; virtual set;}
[C++] public: __property virtual Object* get_Item(String*);
public: __property virtual void set_Item(String*, Object*);
[JScript] XmlWriter.Item (String)

[To be supplied.]

[Visual Basic] Overloads Overridable Public Default Property Item(Integer) As Object
[C#] public object this[int] {virtual get; virtual set;}
[C++] public: __property virtual Object* get_Item(int);
public: __property virtual void set_Item(int, Object*);
[JScript] XmlWriter.Item (int)

[To be supplied.]

[Visual Basic] Overloads Overridable Public Default Property Item(String, String) As Object
[C#] public object this[String, String] {virtual get; virtual set;}
[C++] public: __property virtual Object* get_Item(String*, String*);
public: __property virtual void set_Item(String*, String*, Object*);
[JScript] XmlWriter.Item (String, String)

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.Item (String)

[To be supplied.]

[C#] In C#, this member is the indexer for the XmlWriter class.

[Visual Basic]
Overloads Overridable Public Default Property Item( _
   ByVal name As String _
) As Object
[C#]
public object this[
   string name
] {virtual get; virtual set;}
[C++]
public: __property virtual Object* get_Item(
   String* name
);
public: __property virtual void set_Item(
   String* name,
   Object*
);
[JScript]
returnValue = XmlWriterObject.Item(name);
XmlWriterObject.Item(name) = returnValue;
-or-
returnValue = XmlWriterObject(name);
XmlWriterObject(name) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
[To be supplied.]

Parameters [Visual Basic, C#, C++]

name
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace | XmlWriter.Item Overload List


XmlWriter.Item (Int32)

[To be supplied.]

[C#] In C#, this member is the indexer for the XmlWriter class.

[Visual Basic]
Overloads Overridable Public Default Property Item( _
   ByVal i As Integer _
) As Object
[C#]
public object this[
   int i
] {virtual get; virtual set;}
[C++]
public: __property virtual Object* get_Item(
   int i
);
public: __property virtual void set_Item(
   int i,
   Object*
);
[JScript]
returnValue = XmlWriterObject.Item(i);
XmlWriterObject.Item(i) = returnValue;
-or-
returnValue = XmlWriterObject(i);
XmlWriterObject(i) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

i
[To be supplied.]

Parameters [Visual Basic, C#, C++]

i
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace | XmlWriter.Item Overload List


XmlWriter.Item (String, String)

[To be supplied.]

[C#] In C#, this member is the indexer for the XmlWriter class.

[Visual Basic]
Overloads Overridable Public Default Property Item( _
   ByVal name As String, _
   ByVal namespaceURI As String _
) As Object
[C#]
public object this[
   string name,
   string namespaceURI
] {virtual get; virtual set;}
[C++]
public: __property virtual Object* get_Item(
   String* name,
   String* namespaceURI
);
public: __property virtual void set_Item(
   String* name,
   String* namespaceURI,
   Object*
);
[JScript]
returnValue = XmlWriterObject.Item(name, namespaceURI);
XmlWriterObject.Item(name, namespaceURI) = returnValue;
-or-
returnValue = XmlWriterObject(name, namespaceURI);
XmlWriterObject(name, namespaceURI) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
[To be supplied.]
namespaceURI
[To be supplied.]

Parameters [Visual Basic, C#, C++]

name
[To be supplied.]
namespaceURI
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace | XmlWriter.Item Overload List


XmlWriter.Name

[To be supplied.]

[Visual Basic]
Overridable Public Property Name As String
[C#]
public string Name {virtual get; virtual set;}
[C++]
public: __property virtual String* get_Name();
public: __property virtual void set_Name(String*);
[JScript]
public function get Name() : String;
public function set Name(String);

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.Namespace

[To be supplied.]

[Visual Basic]
Overridable Public Property Namespace As String
[C#]
public string Namespace {virtual get; virtual set;}
[C++]
public: __property virtual String* get_Namespace();
public: __property virtual void set_Namespace(String*);
[JScript]
public function get Namespace() : String;
public function set Namespace(String);

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.NameTable

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property NameTable As INameTable
[C#]
public INameTable NameTable {virtual get;}
[C++]
public: __property virtual INameTable* get_NameTable();
[JScript]
public function get NameTable() : INameTable;

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.NodeType

[To be supplied.]

[Visual Basic]
Overridable Public Property NodeType As XmlNodeType
[C#]
public XmlNodeType NodeType {virtual get; virtual set;}
[C++]
public: __property virtual XmlNodeType get_NodeType();
public: __property virtual void set_NodeType(XmlNodeType);
[JScript]
public function get NodeType() : XmlNodeType;
public function set NodeType(XmlNodeType);

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.Prefix

[To be supplied.]

[Visual Basic]
Overridable Public Property Prefix As String
[C#]
public string Prefix {virtual get; virtual set;}
[C++]
public: __property virtual String* get_Prefix();
public: __property virtual void set_Prefix(String*);
[JScript]
public function get Prefix() : String;
public function set Prefix(String);

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.Value

[To be supplied.]

[Visual Basic]
Public Property Value As String
[C#]
public string Value {get; set;}
[C++]
public: __property String* get_Value();
public: __property void set_Value(String*);
[JScript]
public function get Value() : String;
public function set Value(String);

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.WriteState

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property WriteState As Integer
[C#]
public int WriteState {virtual get;}
[C++]
public: __property virtual int get_WriteState();
[JScript]
public function get WriteState() : int;

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlWriter Methods

The methods of the XmlWriter class are listed below. For a complete list of XmlWriter class members, see the XmlWriter Members topic.

Public:

Clear | [To be supplied.]
Close | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBoolean | [To be supplied.]
GetByte | [To be supplied.]
GetBytes | [To be supplied.]
GetChar | [To be supplied.]
GetChars | [To be supplied.]
GetCurrency | [To be supplied.]
GetData | [To be supplied.]
GetDataTypeName | [To be supplied.]
GetDataTypeNamespace | [To be supplied.]
GetDateTime | [To be supplied.]
GetDecimal | [To be supplied.]
GetDouble | [To be supplied.]
GetFieldType | [To be supplied.]
GetFloat | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInt16 | [To be supplied.]
GetInt32 | [To be supplied.]
GetInt64 | [To be supplied.]
GetName | [To be supplied.]
GetNamespace | [To be supplied.]
GetOrdinal | Overloaded. [To be supplied.]
GetPrefix | [To be supplied.]
GetRaw | [To be supplied.]
GetStream | [To be supplied.]
GetString | [To be supplied.]
GetTimeSpan | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | [To be supplied.]
GetValues | [To be supplied.]
IsNull | [To be supplied.]
SetBoolean | [To be supplied.]
SetByte | [To be supplied.]
SetBytes | [To be supplied.]
SetChar | [To be supplied.]
SetChars | [To be supplied.]
SetCurrency | [To be supplied.]
SetData | [To be supplied.]
SetDateTime | [To be supplied.]
SetDecimal | [To be supplied.]
SetDouble | [To be supplied.]
SetFloat | [To be supplied.]
SetInt16 | [To be supplied.]
SetInt32 | [To be supplied.]
SetInt64 | [To be supplied.]
SetName | [To be supplied.]
SetNamespace | [To be supplied.]
SetNull | [To be supplied.]
SetPrefix | [To be supplied.]
SetRaw | [To be supplied.]
SetStream | [To be supplied.]
SetString | [To be supplied.]
SetTimeSpan | [To be supplied.]
SetValue | [To be supplied.]
SetValues | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | [To be supplied.]

Protected:

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlWriter Class | System.Data.XML Namespace


XmlWriter.Clear

[To be supplied.]

[Visual Basic]
Overridable Public Sub Clear()
[C#]
public virtual void Clear();
[C++]
public: virtual void Clear();
[JScript]
public function Clear();

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.Close

[To be supplied.]

[Visual Basic]
Overridable Public Sub Close()
[C#]
public virtual void Close();
[C++]
public: virtual void Close();
[JScript]
public function Close();

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.Finalize

[To be supplied.]

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.GetBoolean

[To be supplied.]

[Visual Basic]
Overridable Public Function GetBoolean( _
   ByVal i As Integer _
) As Boolean
[C#]
public virtual bool GetBoolean(
   int i
);
[C++]
public: virtual bool GetBoolean(
   int i
);
[JScript]
public function GetBoolean(
   i : int
) : Boolean;

Parameters

i
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.GetByte

[To be supplied.]

[Visual Basic]
Overridable Public Function GetByte( _
   ByVal i As Integer _
) As Byte
[C#]
public virtual byte GetByte(
   int i
);
[C++]
public: virtual unsigned char GetByte(
   int i
);
[JScript]
public function GetByte(
   i : int
) : Byte;

Parameters

i
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.GetBytes

[To be supplied.]

[Visual Basic]
Overridable Public Function GetBytes( _
   ByVal i As Integer, _
   ByVal buffer() As Byte, _
   ByVal length As Integer, _
   ByVal bufferOffset As Integer, _
   ByVal fieldOffset As Integer _
) As Integer
[C#]
public virtual int GetBytes(
   int i,
   byte[] buffer,
   int length,
   int bufferOffset,
   int fieldOffset
);
[C++]
public: virtual int GetBytes(
   int i,
   unsigned char* buffer[],
   int length,
   int bufferOffset,
   int fieldOffset
);
[JScript]
public function GetBytes(
   i : int,
   buffer : Byte[],
   length : int,
   bufferOffset : int,
   fieldOffset : int
) : int;

Parameters

i
[To be supplied.]
buffer
[To be supplied.]
length
[To be supplied.]
bufferOffset
[To be supplied.]
fieldOffset
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.GetChar

[To be supplied.]

[Visual Basic]
Overridable Public Function GetChar( _
   ByVal i As Integer _
) As Char
[C#]
public virtual char GetChar(
   int i
);
[C++]
public: virtual __wchar_t GetChar(
   int i
);
[JScript]
public function GetChar(
   i : int
) : Char;

Parameters

i
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.GetChars

[To be supplied.]

[Visual Basic]
Overridable Public Function GetChars( _
   ByVal i As Integer, _
   ByVal buffer() As Char, _
   ByVal length As Integer, _
   ByVal bufferOffset As Integer, _
   ByVal fieldOffset As Integer _
) As Integer
[C#]
public virtual int GetChars(
   int i,
   char[] buffer,
   int length,
   int bufferOffset,
   int fieldOffset
);
[C++]
public: virtual int GetChars(
   int i,
   __wchar_t* buffer[],
   int length,
   int bufferOffset,
   int fieldOffset
);
[JScript]
public function GetChars(
   i : int,
   buffer : Char[],
   length : int,
   bufferOffset : int,
   fieldOffset : int
) : int;

Parameters

i
[To be supplied.]
buffer
[To be supplied.]
length
[To be supplied.]
bufferOffset
[To be supplied.]
fieldOffset
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.GetCurrency

[To be supplied.]

[Visual Basic]
Overridable Public Function GetCurrency( _
   ByVal i As Integer _
) As Currency
[C#]
public virtual Currency GetCurrency(
   int i
);
[C++]
public: virtual Currency GetCurrency(
   int i
);
[JScript]
public function GetCurrency(
   i : int
) : Currency;

Parameters

i
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.GetData

[To be supplied.]

[Visual Basic]
Overridable Public Function GetData( _
   ByVal i As Integer _
) As IDataReader
[C#]
public virtual IDataReader GetData(
   int i
);
[C++]
public: virtual IDataReader* GetData(
   int i
);
[JScript]
public function GetData(
   i : int
) : IDataReader;

Parameters

i
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.GetDataTypeName

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDataTypeName( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetDataTypeName(
   int i
);
[C++]
public: virtual String* GetDataTypeName(
   int i
);
[JScript]
public function GetDataTypeName(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.GetDataTypeNamespace

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDataTypeNamespace( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetDataTypeNamespace(
   int i
);
[C++]
public: virtual String* GetDataTypeNamespace(
   int i
);
[JScript]
public function GetDataTypeNamespace(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.GetDateTime

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDateTime( _
   ByVal i As Integer _
) As DateTime
[C#]
public virtual DateTime GetDateTime(
   int i
);
[C++]
public: virtual DateTime GetDateTime(
   int i
);
[JScript]
public function GetDateTime(
   i : int
) : DateTime;

Parameters

i
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.GetDecimal

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDecimal( _
   ByVal i As Integer _
) As Decimal
[C#]
public virtual Decimal GetDecimal(
   int i
);
[C++]
public: virtual Decimal GetDecimal(
   int i
);
[JScript]
public function GetDecimal(
   i : int
) : Decimal;

Parameters

i
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.GetDouble

[To be supplied.]

[Visual Basic]
Overridable Public Function GetDouble( _
   ByVal i As Integer _
) As Double
[C#]
public virtual double GetDouble(
   int i
);
[C++]
public: virtual double GetDouble(
   int i
);
[JScript]
public function GetDouble(
   i : int
) : double;

Parameters

i
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.GetFieldType

[To be supplied.]

[Visual Basic]
Overridable Public Function GetFieldType( _
   ByVal i As Integer _
) As Type
[C#]
public virtual Type GetFieldType(
   int i
);
[C++]
public: virtual Type* GetFieldType(
   int i
);
[JScript]
public function GetFieldType(
   i : int
) : Type;

Parameters

i
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.GetFloat

[To be supplied.]

[Visual Basic]
Overridable Public Function GetFloat( _
   ByVal i As Integer _
) As Single
[C#]
public virtual float GetFloat(
   int i
);
[C++]
public: virtual float GetFloat(
   int i
);
[JScript]
public function GetFloat(
   i : int
) : float;

Parameters

i
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.GetInt16

[To be supplied.]

[Visual Basic]
Overridable Public Function GetInt16( _
   ByVal i As Integer _
) As Short
[C#]
public virtual short GetInt16(
   int i
);
[C++]
public: virtual short GetInt16(
   int i
);
[JScript]
public function GetInt16(
   i : int
) : Int16;

Parameters

i
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.GetInt32

[To be supplied.]

[Visual Basic]
Overridable Public Function GetInt32( _
   ByVal i As Integer _
) As Integer
[C#]
public virtual int GetInt32(
   int i
);
[C++]
public: virtual int GetInt32(
   int i
);
[JScript]
public function GetInt32(
   i : int
) : int;

Parameters

i
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.GetInt64

[To be supplied.]

[Visual Basic]
Overridable Public Function GetInt64( _
   ByVal i As Integer _
) As Long
[C#]
public virtual long GetInt64(
   int i
);
[C++]
public: virtual __int64 GetInt64(
   int i
);
[JScript]
public function GetInt64(
   i : int
) : long;

Parameters

i
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.GetName

[To be supplied.]

[Visual Basic]
Overridable Public Function GetName( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetName(
   int i
);
[C++]
public: virtual String* GetName(
   int i
);
[JScript]
public function GetName(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.GetNamespace

[To be supplied.]

[Visual Basic]
Overridable Public Function GetNamespace( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetNamespace(
   int i
);
[C++]
public: virtual String* GetNamespace(
   int i
);
[JScript]
public function GetNamespace(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.GetOrdinal

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function GetOrdinal(String, String) As Integer
[C#] public virtual int GetOrdinal(String, String);
[C++] public: virtual int GetOrdinal(String*, String*);
[JScript] public function GetOrdinal(String, String) : int;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function GetOrdinal(String) As Integer
[C#] public virtual int GetOrdinal(String);
[C++] public: virtual int GetOrdinal(String*);
[JScript] public function GetOrdinal(String) : int;

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.GetOrdinal (String, String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function GetOrdinal( _
   ByVal name As String, _
   ByVal namespaceURI As String _
) As Integer
[C#]
public virtual int GetOrdinal(
   string name,
   string namespaceURI
);
[C++]
public: virtual int GetOrdinal(
   String* name,
   String* namespaceURI
);
[JScript]
public function GetOrdinal(
   name : String,
   namespaceURI : String
) : int;

Parameters

name
[To be supplied.]
namespaceURI
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace | XmlWriter.GetOrdinal Overload List


XmlWriter.GetOrdinal (String)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function GetOrdinal( _
   ByVal name As String _
) As Integer
[C#]
public virtual int GetOrdinal(
   string name
);
[C++]
public: virtual int GetOrdinal(
   String* name
);
[JScript]
public function GetOrdinal(
   name : String
) : int;

Parameters

name
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace | XmlWriter.GetOrdinal Overload List


XmlWriter.GetPrefix

[To be supplied.]

[Visual Basic]
Overridable Public Function GetPrefix( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetPrefix(
   int i
);
[C++]
public: virtual String* GetPrefix(
   int i
);
[JScript]
public function GetPrefix(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.GetRaw

[To be supplied.]

[Visual Basic]
Overridable Public Function GetRaw( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetRaw(
   int i
);
[C++]
public: virtual String* GetRaw(
   int i
);
[JScript]
public function GetRaw(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.GetStream

[To be supplied.]

[Visual Basic]
Overridable Public Function GetStream( _
   ByVal i As Integer _
) As Stream
[C#]
public virtual Stream GetStream(
   int i
);
[C++]
public: virtual Stream* GetStream(
   int i
);
[JScript]
public function GetStream(
   i : int
) : Stream;

Parameters

i
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.GetString

[To be supplied.]

[Visual Basic]
Overridable Public Function GetString( _
   ByVal i As Integer _
) As String
[C#]
public virtual string GetString(
   int i
);
[C++]
public: virtual String* GetString(
   int i
);
[JScript]
public function GetString(
   i : int
) : String;

Parameters

i
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.GetTimeSpan

[To be supplied.]

[Visual Basic]
Overridable Public Function GetTimeSpan( _
   ByVal i As Integer _
) As TimeSpan
[C#]
public virtual TimeSpan GetTimeSpan(
   int i
);
[C++]
public: virtual TimeSpan GetTimeSpan(
   int i
);
[JScript]
public function GetTimeSpan(
   i : int
) : TimeSpan;

Parameters

i
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.GetValue

[To be supplied.]

[Visual Basic]
Overridable Public Sub GetValue( _
   ByVal i As Integer, _
   ByRef value As Object _
)
[C#]
public virtual void GetValue(
   int i,
   ref object value
);
[C++]
public: virtual void GetValue(
   int i,
   Object** value
);
[JScript]
public function GetValue(
   i : int,
   value : Object
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.GetValues

[To be supplied.]

[Visual Basic]
Overridable Public Function GetValues( _
   ByVal values() As Object _
) As Integer
[C#]
public virtual int GetValues(
   object[] values
);
[C++]
public: virtual int GetValues(
   Object* values[]
);
[JScript]
public function GetValues(
   values : Object[]
) : int;

Parameters

values
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.IsNull

[To be supplied.]

[Visual Basic]
Overridable Public Function IsNull( _
   ByVal i As Integer _
) As Boolean
[C#]
public virtual bool IsNull(
   int i
);
[C++]
public: virtual bool IsNull(
   int i
);
[JScript]
public function IsNull(
   i : int
) : Boolean;

Parameters

i
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.SetBoolean

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetBoolean( _
   ByVal i As Integer, _
   ByVal value As Boolean _
)
[C#]
public virtual void SetBoolean(
   int i,
   bool value
);
[C++]
public: virtual void SetBoolean(
   int i,
   bool value
);
[JScript]
public function SetBoolean(
   i : int,
   value : Boolean
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.SetByte

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetByte( _
   ByVal i As Integer, _
   ByVal value As Byte _
)
[C#]
public virtual void SetByte(
   int i,
   byte value
);
[C++]
public: virtual void SetByte(
   int i,
   unsigned char value
);
[JScript]
public function SetByte(
   i : int,
   value : Byte
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.SetBytes

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetBytes( _
   ByVal i As Integer, _
   ByVal buffer() As Byte, _
   ByVal length As Integer, _
   ByVal bufferoffset As Integer, _
   ByVal fieldoffset As Integer _
)
[C#]
public virtual void SetBytes(
   int i,
   byte[] buffer,
   int length,
   int bufferoffset,
   int fieldoffset
);
[C++]
public: virtual void SetBytes(
   int i,
   unsigned char* buffer[],
   int length,
   int bufferoffset,
   int fieldoffset
);
[JScript]
public function SetBytes(
   i : int,
   buffer : Byte[],
   length : int,
   bufferoffset : int,
   fieldoffset : int
);

Parameters

i
[To be supplied.]
buffer
[To be supplied.]
length
[To be supplied.]
bufferoffset
[To be supplied.]
fieldoffset
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.SetChar

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetChar( _
   ByVal i As Integer, _
   ByVal value As Char _
)
[C#]
public virtual void SetChar(
   int i,
   char value
);
[C++]
public: virtual void SetChar(
   int i,
   __wchar_t value
);
[JScript]
public function SetChar(
   i : int,
   value : Char
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.SetChars

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetChars( _
   ByVal i As Integer, _
   ByVal buffer() As Char, _
   ByVal length As Integer, _
   ByVal bufferoffset As Integer, _
   ByVal fieldoffset As Integer _
)
[C#]
public virtual void SetChars(
   int i,
   char[] buffer,
   int length,
   int bufferoffset,
   int fieldoffset
);
[C++]
public: virtual void SetChars(
   int i,
   __wchar_t* buffer[],
   int length,
   int bufferoffset,
   int fieldoffset
);
[JScript]
public function SetChars(
   i : int,
   buffer : Char[],
   length : int,
   bufferoffset : int,
   fieldoffset : int
);

Parameters

i
[To be supplied.]
buffer
[To be supplied.]
length
[To be supplied.]
bufferoffset
[To be supplied.]
fieldoffset
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.SetCurrency

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetCurrency( _
   ByVal i As Integer, _
   ByVal value As Currency _
)
[C#]
public virtual void SetCurrency(
   int i,
   Currency value
);
[C++]
public: virtual void SetCurrency(
   int i,
   Currency value
);
[JScript]
public function SetCurrency(
   i : int,
   value : Currency
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.SetData

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetData( _
   ByVal i As Integer, _
   ByVal stm As IDataReader _
)
[C#]
public virtual void SetData(
   int i,
   IDataReader stm
);
[C++]
public: virtual void SetData(
   int i,
   IDataReader* stm
);
[JScript]
public function SetData(
   i : int,
   stm : IDataReader
);

Parameters

i
[To be supplied.]
stm
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.SetDateTime

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetDateTime( _
   ByVal i As Integer, _
   ByVal value As DateTime _
)
[C#]
public virtual void SetDateTime(
   int i,
   DateTime value
);
[C++]
public: virtual void SetDateTime(
   int i,
   DateTime value
);
[JScript]
public function SetDateTime(
   i : int,
   value : DateTime
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.SetDecimal

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetDecimal( _
   ByVal i As Integer, _
   ByVal value As Decimal _
)
[C#]
public virtual void SetDecimal(
   int i,
   Decimal value
);
[C++]
public: virtual void SetDecimal(
   int i,
   Decimal value
);
[JScript]
public function SetDecimal(
   i : int,
   value : Decimal
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.SetDouble

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetDouble( _
   ByVal i As Integer, _
   ByVal value As Double _
)
[C#]
public virtual void SetDouble(
   int i,
   double value
);
[C++]
public: virtual void SetDouble(
   int i,
   double value
);
[JScript]
public function SetDouble(
   i : int,
   value : double
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.SetFloat

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetFloat( _
   ByVal i As Integer, _
   ByVal value As Single _
)
[C#]
public virtual void SetFloat(
   int i,
   float value
);
[C++]
public: virtual void SetFloat(
   int i,
   float value
);
[JScript]
public function SetFloat(
   i : int,
   value : float
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.SetInt16

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetInt16( _
   ByVal i As Integer, _
   ByVal value As Short _
)
[C#]
public virtual void SetInt16(
   int i,
   short value
);
[C++]
public: virtual void SetInt16(
   int i,
   short value
);
[JScript]
public function SetInt16(
   i : int,
   value : Int16
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.SetInt32

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetInt32( _
   ByVal i As Integer, _
   ByVal value As Integer _
)
[C#]
public virtual void SetInt32(
   int i,
   int value
);
[C++]
public: virtual void SetInt32(
   int i,
   int value
);
[JScript]
public function SetInt32(
   i : int,
   value : int
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.SetInt64

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetInt64( _
   ByVal i As Integer, _
   ByVal value As Long _
)
[C#]
public virtual void SetInt64(
   int i,
   long value
);
[C++]
public: virtual void SetInt64(
   int i,
   __int64 value
);
[JScript]
public function SetInt64(
   i : int,
   value : long
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.SetName

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetName( _
   ByVal i As Integer, _
   ByVal value As String _
)
[C#]
public virtual void SetName(
   int i,
   string value
);
[C++]
public: virtual void SetName(
   int i,
   String* value
);
[JScript]
public function SetName(
   i : int,
   value : String
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.SetNamespace

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetNamespace( _
   ByVal i As Integer, _
   ByVal value As String _
)
[C#]
public virtual void SetNamespace(
   int i,
   string value
);
[C++]
public: virtual void SetNamespace(
   int i,
   String* value
);
[JScript]
public function SetNamespace(
   i : int,
   value : String
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.SetNull

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetNull( _
   ByVal i As Integer _
)
[C#]
public virtual void SetNull(
   int i
);
[C++]
public: virtual void SetNull(
   int i
);
[JScript]
public function SetNull(
   i : int
);

Parameters

i
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.SetPrefix

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetPrefix( _
   ByVal i As Integer, _
   ByVal value As String _
)
[C#]
public virtual void SetPrefix(
   int i,
   string value
);
[C++]
public: virtual void SetPrefix(
   int i,
   String* value
);
[JScript]
public function SetPrefix(
   i : int,
   value : String
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.SetRaw

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetRaw( _
   ByVal i As Integer, _
   ByVal raw As String _
)
[C#]
public virtual void SetRaw(
   int i,
   string raw
);
[C++]
public: virtual void SetRaw(
   int i,
   String* raw
);
[JScript]
public function SetRaw(
   i : int,
   raw : String
);

Parameters

i
[To be supplied.]
raw
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.SetStream

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetStream( _
   ByVal i As Integer, _
   ByVal stm As Stream _
)
[C#]
public virtual void SetStream(
   int i,
   Stream stm
);
[C++]
public: virtual void SetStream(
   int i,
   Stream* stm
);
[JScript]
public function SetStream(
   i : int,
   stm : Stream
);

Parameters

i
[To be supplied.]
stm
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.SetString

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetString( _
   ByVal i As Integer, _
   ByVal value As String _
)
[C#]
public virtual void SetString(
   int i,
   string value
);
[C++]
public: virtual void SetString(
   int i,
   String* value
);
[JScript]
public function SetString(
   i : int,
   value : String
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.SetTimeSpan

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetTimeSpan( _
   ByVal i As Integer, _
   ByVal value As TimeSpan _
)
[C#]
public virtual void SetTimeSpan(
   int i,
   TimeSpan value
);
[C++]
public: virtual void SetTimeSpan(
   int i,
   TimeSpan value
);
[JScript]
public function SetTimeSpan(
   i : int,
   value : TimeSpan
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.SetValue

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetValue( _
   ByVal i As Integer, _
   ByVal value As Object _
)
[C#]
public virtual void SetValue(
   int i,
   object value
);
[C++]
public: virtual void SetValue(
   int i,
   Object* value
);
[JScript]
public function SetValue(
   i : int,
   value : Object
);

Parameters

i
[To be supplied.]
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.SetValues

[To be supplied.]

[Visual Basic]
Overridable Public Function SetValues( _
   ByVal values() As Object _
) As Integer
[C#]
public virtual int SetValues(
   object[] values
);
[C++]
public: virtual int SetValues(
   Object* values[]
);
[JScript]
public function SetValues(
   values : Object[]
) : int;

Parameters

values
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XmlWriter.Write

[To be supplied.]

[Visual Basic]
Overridable Public Function Write() As Boolean
[C#]
public virtual bool Write();
[C++]
public: virtual bool Write();
[JScript]
public function Write() : Boolean;

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlWriter Fields

The fields of the XmlWriter class are listed below. For a complete list of XmlWriter class members, see the XmlWriter Members topic.

Public:

Namespaces [To be supplied.]

See Also

XmlWriter Class | System.Data.XML Namespace


XmlWriter.Namespaces

[To be supplied.]

[Visual Basic]
Public Const Namespaces As Integer
[C#]
public const int Namespaces;
[C++]
public: const int Namespaces;
[JScript]
public var Namespaces : int;

See Also

XmlWriter Class | XmlWriter Members | System.Data.XML Namespace


XPathException Class

[To be supplied.]

Object
Exception
SystemException
ExternalException
XPathException

[Visual Basic]
Public Class XPathException
   Inherits ExternalException
[C#]
public class XPathException : ExternalException
[C++]
public __gc class XPathException : public ExternalException
[JScript]
public class XPathException extends ExternalException

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

XPathException Members | System.Data.XML Namespace


XPathException Members

Public:

Properties

ErrorCode (inherited from ExternalException) | [To be supplied.]
HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message | [To be supplied.]
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Fields

BAD_QUERYOBJECT | [To be supplied.]
BOOLEAN_EXPECTED | [To be supplied.]
EXPR_EXPECTED | [To be supplied.]
FIRST | [To be supplied.]
FUNC_EXPECTED | [To be supplied.]
INVALID_ARGUMENT | [To be supplied.]
INVALID_FILTER | [To be supplied.]
INVALID_NAME | [To be supplied.]
INVALID_NODETYPE | [To be supplied.]
INVALID_NO_ARGUMENTS | [To be supplied.]
INVALID_PATTERN | [To be supplied.]
INVALID_TOKEN | [To be supplied.]
LAST | [To be supplied.]
NODESET_EXPECTED | [To be supplied.]
NODETEST_EXPECTED | [To be supplied.]
NOT_SUPPORTED | [To be supplied.]
NO_XPATH_ACTIVE | [To be supplied.]
NUMBER_EXPECTED | [To be supplied.]
QUERY_EXPECTED_FOR_LAST | [To be supplied.]
TEST_EXPECTED | [To be supplied.]
TOKEN_EXPECTED | [To be supplied.]
UNCLOSEDSTRING | [To be supplied.]
UNKNOWN_METHOD | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

XPathException Class | System.Data.XML Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XPathException Properties

The properties of the XPathException class are listed below. For a complete list of XPathException class members, see the XPathException Members topic.

Public:

ErrorCode (inherited from ExternalException) | [To be supplied.]
HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message | [To be supplied.]
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

See Also

XPathException Class | System.Data.XML Namespace


XPathException.Message

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Message As String
[C#]
public string Message {override get;}
[C++]
public: __property virtual String* get_Message();
[JScript]
public function get Message() : String;

See Also

XPathException Class | XPathException Members | System.Data.XML Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XPathException Fields

The fields of the XPathException class are listed below. For a complete list of XPathException class members, see the XPathException Members topic.

Public:

BAD_QUERYOBJECT | [To be supplied.]
BOOLEAN_EXPECTED | [To be supplied.]
EXPR_EXPECTED | [To be supplied.]
FIRST | [To be supplied.]
FUNC_EXPECTED | [To be supplied.]
INVALID_ARGUMENT | [To be supplied.]
INVALID_FILTER | [To be supplied.]
INVALID_NAME | [To be supplied.]
INVALID_NODETYPE | [To be supplied.]
INVALID_NO_ARGUMENTS | [To be supplied.]
INVALID_PATTERN | [To be supplied.]
INVALID_TOKEN | [To be supplied.]
LAST | [To be supplied.]
NODESET_EXPECTED | [To be supplied.]
NODETEST_EXPECTED | [To be supplied.]
NOT_SUPPORTED | [To be supplied.]
NO_XPATH_ACTIVE | [To be supplied.]
NUMBER_EXPECTED | [To be supplied.]
QUERY_EXPECTED_FOR_LAST | [To be supplied.]
TEST_EXPECTED | [To be supplied.]
TOKEN_EXPECTED | [To be supplied.]
UNCLOSEDSTRING | [To be supplied.]
UNKNOWN_METHOD | [To be supplied.]

Protected:

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

XPathException Class | System.Data.XML Namespace


XPathException.BAD_QUERYOBJECT

[To be supplied.]

[Visual Basic]
Public Const BAD_QUERYOBJECT As Integer
[C#]
public const int BAD_QUERYOBJECT;
[C++]
public: const int BAD_QUERYOBJECT;
[JScript]
public var BAD_QUERYOBJECT : int;

See Also

XPathException Class | XPathException Members | System.Data.XML Namespace


XPathException.BOOLEAN_EXPECTED

[To be supplied.]

[Visual Basic]
Public Const BOOLEAN_EXPECTED As Integer
[C#]
public const int BOOLEAN_EXPECTED;
[C++]
public: const int BOOLEAN_EXPECTED;
[JScript]
public var BOOLEAN_EXPECTED : int;

See Also

XPathException Class | XPathException Members | System.Data.XML Namespace


XPathException.EXPR_EXPECTED

[To be supplied.]

[Visual Basic]
Public Const EXPR_EXPECTED As Integer
[C#]
public const int EXPR_EXPECTED;
[C++]
public: const int EXPR_EXPECTED;
[JScript]
public var EXPR_EXPECTED : int;

See Also

XPathException Class | XPathException Members | System.Data.XML Namespace


XPathException.FIRST

[To be supplied.]

[Visual Basic]
Public Const FIRST As Integer
[C#]
public const int FIRST;
[C++]
public: const int FIRST;
[JScript]
public var FIRST : int;

See Also

XPathException Class | XPathException Members | System.Data.XML Namespace


XPathException.FUNC_EXPECTED

[To be supplied.]

[Visual Basic]
Public Const FUNC_EXPECTED As Integer
[C#]
public const int FUNC_EXPECTED;
[C++]
public: const int FUNC_EXPECTED;
[JScript]
public var FUNC_EXPECTED : int;

See Also

XPathException Class | XPathException Members | System.Data.XML Namespace


XPathException.INVALID_ARGUMENT

[To be supplied.]

[Visual Basic]
Public Const INVALID_ARGUMENT As Integer
[C#]
public const int INVALID_ARGUMENT;
[C++]
public: const int INVALID_ARGUMENT;
[JScript]
public var INVALID_ARGUMENT : int;

See Also

XPathException Class | XPathException Members | System.Data.XML Namespace


XPathException.INVALID_FILTER

[To be supplied.]

[Visual Basic]
Public Const INVALID_FILTER As Integer
[C#]
public const int INVALID_FILTER;
[C++]
public: const int INVALID_FILTER;
[JScript]
public var INVALID_FILTER : int;

See Also

XPathException Class | XPathException Members | System.Data.XML Namespace


XPathException.INVALID_NAME

[To be supplied.]

[Visual Basic]
Public Const INVALID_NAME As Integer
[C#]
public const int INVALID_NAME;
[C++]
public: const int INVALID_NAME;
[JScript]
public var INVALID_NAME : int;

See Also

XPathException Class | XPathException Members | System.Data.XML Namespace


XPathException.INVALID_NODETYPE

[To be supplied.]

[Visual Basic]
Public Const INVALID_NODETYPE As Integer
[C#]
public const int INVALID_NODETYPE;
[C++]
public: const int INVALID_NODETYPE;
[JScript]
public var INVALID_NODETYPE : int;

See Also

XPathException Class | XPathException Members | System.Data.XML Namespace


XPathException.INVALID_NO_ARGUMENTS

[To be supplied.]

[Visual Basic]
Public Const INVALID_NO_ARGUMENTS As Integer
[C#]
public const int INVALID_NO_ARGUMENTS;
[C++]
public: const int INVALID_NO_ARGUMENTS;
[JScript]
public var INVALID_NO_ARGUMENTS : int;

See Also

XPathException Class | XPathException Members | System.Data.XML Namespace


XPathException.INVALID_PATTERN

[To be supplied.]

[Visual Basic]
Public Const INVALID_PATTERN As Integer
[C#]
public const int INVALID_PATTERN;
[C++]
public: const int INVALID_PATTERN;
[JScript]
public var INVALID_PATTERN : int;

See Also

XPathException Class | XPathException Members | System.Data.XML Namespace


XPathException.INVALID_TOKEN

[To be supplied.]

[Visual Basic]
Public Const INVALID_TOKEN As Integer
[C#]
public const int INVALID_TOKEN;
[C++]
public: const int INVALID_TOKEN;
[JScript]
public var INVALID_TOKEN : int;

See Also

XPathException Class | XPathException Members | System.Data.XML Namespace


XPathException.LAST

[To be supplied.]

[Visual Basic]
Public Const LAST As Integer
[C#]
public const int LAST;
[C++]
public: const int LAST;
[JScript]
public var LAST : int;

See Also

XPathException Class | XPathException Members | System.Data.XML Namespace


XPathException.NODESET_EXPECTED

[To be supplied.]

[Visual Basic]
Public Const NODESET_EXPECTED As Integer
[C#]
public const int NODESET_EXPECTED;
[C++]
public: const int NODESET_EXPECTED;
[JScript]
public var NODESET_EXPECTED : int;

See Also

XPathException Class | XPathException Members | System.Data.XML Namespace


XPathException.NODETEST_EXPECTED

[To be supplied.]

[Visual Basic]
Public Const NODETEST_EXPECTED As Integer
[C#]
public const int NODETEST_EXPECTED;
[C++]
public: const int NODETEST_EXPECTED;
[JScript]
public var NODETEST_EXPECTED : int;

See Also

XPathException Class | XPathException Members | System.Data.XML Namespace


XPathException.NOT_SUPPORTED

[To be supplied.]

[Visual Basic]
Public Const NOT_SUPPORTED As Integer
[C#]
public const int NOT_SUPPORTED;
[C++]
public: const int NOT_SUPPORTED;
[JScript]
public var NOT_SUPPORTED : int;

See Also

XPathException Class | XPathException Members | System.Data.XML Namespace


XPathException.NO_XPATH_ACTIVE

[To be supplied.]

[Visual Basic]
Public Const NO_XPATH_ACTIVE As Integer
[C#]
public const int NO_XPATH_ACTIVE;
[C++]
public: const int NO_XPATH_ACTIVE;
[JScript]
public var NO_XPATH_ACTIVE : int;

See Also

XPathException Class | XPathException Members | System.Data.XML Namespace


XPathException.NUMBER_EXPECTED

[To be supplied.]

[Visual Basic]
Public Const NUMBER_EXPECTED As Integer
[C#]
public const int NUMBER_EXPECTED;
[C++]
public: const int NUMBER_EXPECTED;
[JScript]
public var NUMBER_EXPECTED : int;

See Also

XPathException Class | XPathException Members | System.Data.XML Namespace


XPathException.QUERY_EXPECTED_FOR_LAST

[To be supplied.]

[Visual Basic]
Public Const QUERY_EXPECTED_FOR_LAST As Integer
[C#]
public const int QUERY_EXPECTED_FOR_LAST;
[C++]
public: const int QUERY_EXPECTED_FOR_LAST;
[JScript]
public var QUERY_EXPECTED_FOR_LAST : int;

See Also

XPathException Class | XPathException Members | System.Data.XML Namespace


XPathException.TEST_EXPECTED

[To be supplied.]

[Visual Basic]
Public Const TEST_EXPECTED As Integer
[C#]
public const int TEST_EXPECTED;
[C++]
public: const int TEST_EXPECTED;
[JScript]
public var TEST_EXPECTED : int;

See Also

XPathException Class | XPathException Members | System.Data.XML Namespace


XPathException.TOKEN_EXPECTED

[To be supplied.]

[Visual Basic]
Public Const TOKEN_EXPECTED As Integer
[C#]
public const int TOKEN_EXPECTED;
[C++]
public: const int TOKEN_EXPECTED;
[JScript]
public var TOKEN_EXPECTED : int;

See Also

XPathException Class | XPathException Members | System.Data.XML Namespace


XPathException.UNCLOSEDSTRING

[To be supplied.]

[Visual Basic]
Public Const UNCLOSEDSTRING As Integer
[C#]
public const int UNCLOSEDSTRING;
[C++]
public: const int UNCLOSEDSTRING;
[JScript]
public var UNCLOSEDSTRING : int;

See Also

XPathException Class | XPathException Members | System.Data.XML Namespace


XPathException.UNKNOWN_METHOD

[To be supplied.]

[Visual Basic]
Public Const UNKNOWN_METHOD As Integer
[C#]
public const int UNKNOWN_METHOD;
[C++]
public: const int UNKNOWN_METHOD;
[JScript]
public var UNKNOWN_METHOD : int;

See Also

XPathException Class | XPathException Members | System.Data.XML Namespace


XPathHandler Class

[To be supplied.]

Object
XPathHandler

[Visual Basic]
Public Class XPathHandler
[C#]
public class XPathHandler
[C++]
public __gc class XPathHandler
[JScript]
public class XPathHandler

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

XPathHandler Members | System.Data.XML Namespace


XPathHandler Members

Public:

Constructor

XPathHandler Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Run | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XPathHandler Class | System.Data.XML Namespace


XPathHandler Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public XPathHandler();
[C++]
public: XPathHandler();
[JScript]
public function XPathHandler();

See Also

XPathHandler Class | XPathHandler Members | System.Data.XML Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XPathHandler Methods

The methods of the XPathHandler class are listed below. For a complete list of XPathHandler class members, see the XPathHandler Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Run | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XPathHandler Class | System.Data.XML Namespace


XPathHandler.Run

[To be supplied.]

[Visual Basic]
Public Function Run( _
   ByVal scanner As XPathScanner _
) As AstNode
[C#]
public AstNode Run(
   XPathScanner scanner
);
[C++]
public: AstNode* Run(
   XPathScanner* scanner
);
[JScript]
public function Run(
   scanner : XPathScanner
) : AstNode;

Parameters

scanner
[To be supplied.]

See Also

XPathHandler Class | XPathHandler Members | System.Data.XML Namespace


XPathScanner Class

[To be supplied.]

Object
XPathScanner

[Visual Basic]
NotInheritable Public Class XPathScanner
[C#]
public sealed class XPathScanner
[C++]
public __gc __sealed class XPathScanner
[JScript]
public class XPathScanner

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML

Assembly: System.Data.dll

See Also

XPathScanner Members | System.Data.XML Namespace


XPathScanner Members

Public:

Constructor

XPathScanner Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SetParseString | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XPathScanner Class | System.Data.XML Namespace


XPathScanner Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public XPathScanner();
[C++]
public: XPathScanner();
[JScript]
public function XPathScanner();

See Also

XPathScanner Class | XPathScanner Members | System.Data.XML Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XPathScanner Methods

The methods of the XPathScanner class are listed below. For a complete list of XPathScanner class members, see the XPathScanner Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SetParseString | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XPathScanner Class | System.Data.XML Namespace


XPathScanner.SetParseString

[To be supplied.]

[Visual Basic]
Public Sub SetParseString( _
   ByVal parsestring As String _
)
[C#]
public void SetParseString(
   string parsestring
);
[C++]
public: void SetParseString(
   String* parsestring
);
[JScript]
public function SetParseString(
   parsestring : String
);

Parameters

parsestring
[To be supplied.]

See Also

XPathScanner Class | XPathScanner Members | System.Data.XML Namespace


System.Data.XML.DOM

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Data.XML.DOM Namespace

Classes

Class | Description
DOMException | [To be supplied.]

Interfaces

Interface | Description
IAttr | [To be supplied.]
ICDATASection | [To be supplied.]
ICharacterData | [To be supplied.]
IComment | [To be supplied.]
IDocument | [To be supplied.]
IDocumentFragment | [To be supplied.]
IDocumentType | [To be supplied.]
IDOMImplementation | [To be supplied.]
IElement | [To be supplied.]
IEntity | [To be supplied.]
IEntityReference | [To be supplied.]
INamedNodeMap | [To be supplied.]
INode | [To be supplied.]
INodeList | [To be supplied.]
IProcessingInstruction | [To be supplied.]
IText | [To be supplied.]

Enumerations

Enumeration | Description
NodeType | [To be supplied.]


DOMException Class

[To be supplied.]

Object
Exception
SystemException
ExternalException
DOMException

[Visual Basic]
Public Class DOMException
   Inherits ExternalException
[C#]
public class DOMException : ExternalException
[C++]
public __gc class DOMException : public ExternalException
[JScript]
public class DOMException extends ExternalException

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML.DOM

Assembly: System.Data.dll

See Also

DOMException Members | System.Data.XML.DOM Namespace


DOMException Members

Public:

Constructor

DOMException Constructor [To be supplied.]

Properties

ErrorCode (inherited from ExternalException) | [To be supplied.]
HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message | [To be supplied.]
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Fields

DOMSTRING_SIZE_ERR | [To be supplied.]
FIRST | [To be supplied.]
HIERARCHY_REQUEST_ERR | [To be supplied.]
INDEX_SIZE_ERR | [To be supplied.]
INUSE_ATTRIBUTE_ERR | [To be supplied.]
INVALID_CHARACTER_ERR | [To be supplied.]
LAST | [To be supplied.]
NOT_FOUND_ERR | [To be supplied.]
NOT_SUPPORTED_ERR | [To be supplied.]
NO_DATA_ALLOWED_ERR | [To be supplied.]
NO_MODIFICATION_ALLOWED_ERR | [To be supplied.]
WRONG_DOCUMENT_ERR | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

DOMException Class | System.Data.XML.DOM Namespace


DOMException Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal hr As Integer _
)
[C#]
public DOMException(
   int hr
);
[C++]
public: DOMException(
   int hr
);
[JScript]
public function DOMException(
   hr : int
);

Parameters

hr
[To be supplied.]

See Also

DOMException Class | DOMException Members | System.Data.XML.DOM Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DOMException Properties

The properties of the DOMException class are listed below. For a complete list of DOMException class members, see the DOMException Members topic.

Public:

ErrorCode (inherited from ExternalException) | [To be supplied.]
HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message | [To be supplied.]
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

See Also

DOMException Class | System.Data.XML.DOM Namespace


DOMException.Message

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Message As String
[C#]
public string Message {override get;}
[C++]
public: __property virtual String* get_Message();
[JScript]
public function get Message() : String;

See Also

DOMException Class | DOMException Members | System.Data.XML.DOM Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DOMException Fields

The fields of the DOMException class are listed below. For a complete list of DOMException class members, see the DOMException Members topic.

Public:

DOMSTRING_SIZE_ERR | [To be supplied.]
FIRST | [To be supplied.]
HIERARCHY_REQUEST_ERR | [To be supplied.]
INDEX_SIZE_ERR | [To be supplied.]
INUSE_ATTRIBUTE_ERR | [To be supplied.]
INVALID_CHARACTER_ERR | [To be supplied.]
LAST | [To be supplied.]
NOT_FOUND_ERR | [To be supplied.]
NOT_SUPPORTED_ERR | [To be supplied.]
NO_DATA_ALLOWED_ERR | [To be supplied.]
NO_MODIFICATION_ALLOWED_ERR | [To be supplied.]
WRONG_DOCUMENT_ERR | [To be supplied.]

Protected:

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

DOMException Class | System.Data.XML.DOM Namespace


DOMException.DOMSTRING_SIZE_ERR

[To be supplied.]

[Visual Basic]
Public Const DOMSTRING_SIZE_ERR As Integer
[C#]
public const int DOMSTRING_SIZE_ERR;
[C++]
public: const int DOMSTRING_SIZE_ERR;
[JScript]
public var DOMSTRING_SIZE_ERR : int;

See Also

DOMException Class | DOMException Members | System.Data.XML.DOM Namespace


DOMException.FIRST

[To be supplied.]

[Visual Basic]
Public Const FIRST As Integer
[C#]
public const int FIRST;
[C++]
public: const int FIRST;
[JScript]
public var FIRST : int;

See Also

DOMException Class | DOMException Members | System.Data.XML.DOM Namespace


DOMException.HIERARCHY_REQUEST_ERR

[To be supplied.]

[Visual Basic]
Public Const HIERARCHY_REQUEST_ERR As Integer
[C#]
public const int HIERARCHY_REQUEST_ERR;
[C++]
public: const int HIERARCHY_REQUEST_ERR;
[JScript]
public var HIERARCHY_REQUEST_ERR : int;

See Also

DOMException Class | DOMException Members | System.Data.XML.DOM Namespace


DOMException.INDEX_SIZE_ERR

[To be supplied.]

[Visual Basic]
Public Const INDEX_SIZE_ERR As Integer
[C#]
public const int INDEX_SIZE_ERR;
[C++]
public: const int INDEX_SIZE_ERR;
[JScript]
public var INDEX_SIZE_ERR : int;

See Also

DOMException Class | DOMException Members | System.Data.XML.DOM Namespace


DOMException.INUSE_ATTRIBUTE_ERR

[To be supplied.]

[Visual Basic]
Public Const INUSE_ATTRIBUTE_ERR As Integer
[C#]
public const int INUSE_ATTRIBUTE_ERR;
[C++]
public: const int INUSE_ATTRIBUTE_ERR;
[JScript]
public var INUSE_ATTRIBUTE_ERR : int;

See Also

DOMException Class | DOMException Members | System.Data.XML.DOM Namespace


DOMException.INVALID_CHARACTER_ERR

[To be supplied.]

[Visual Basic]
Public Const INVALID_CHARACTER_ERR As Integer
[C#]
public const int INVALID_CHARACTER_ERR;
[C++]
public: const int INVALID_CHARACTER_ERR;
[JScript]
public var INVALID_CHARACTER_ERR : int;

See Also

DOMException Class | DOMException Members | System.Data.XML.DOM Namespace


DOMException.LAST

[To be supplied.]

[Visual Basic]
Public Const LAST As Integer
[C#]
public const int LAST;
[C++]
public: const int LAST;
[JScript]
public var LAST : int;

See Also

DOMException Class | DOMException Members | System.Data.XML.DOM Namespace


DOMException.NOT_FOUND_ERR

[To be supplied.]

[Visual Basic]
Public Const NOT_FOUND_ERR As Integer
[C#]
public const int NOT_FOUND_ERR;
[C++]
public: const int NOT_FOUND_ERR;
[JScript]
public var NOT_FOUND_ERR : int;

See Also

DOMException Class | DOMException Members | System.Data.XML.DOM Namespace


DOMException.NOT_SUPPORTED_ERR

[To be supplied.]

[Visual Basic]
Public Const NOT_SUPPORTED_ERR As Integer
[C#]
public const int NOT_SUPPORTED_ERR;
[C++]
public: const int NOT_SUPPORTED_ERR;
[JScript]
public var NOT_SUPPORTED_ERR : int;

See Also

DOMException Class | DOMException Members | System.Data.XML.DOM Namespace


DOMException.NO_DATA_ALLOWED_ERR

[To be supplied.]

[Visual Basic]
Public Const NO_DATA_ALLOWED_ERR As Integer
[C#]
public const int NO_DATA_ALLOWED_ERR;
[C++]
public: const int NO_DATA_ALLOWED_ERR;
[JScript]
public var NO_DATA_ALLOWED_ERR : int;

See Also

DOMException Class | DOMException Members | System.Data.XML.DOM Namespace


DOMException.NO_MODIFICATION_ALLOWED_ERR

[To be supplied.]

[Visual Basic]
Public Const NO_MODIFICATION_ALLOWED_ERR As Integer
[C#]
public const int NO_MODIFICATION_ALLOWED_ERR;
[C++]
public: const int NO_MODIFICATION_ALLOWED_ERR;
[JScript]
public var NO_MODIFICATION_ALLOWED_ERR : int;

See Also

DOMException Class | DOMException Members | System.Data.XML.DOM Namespace


DOMException.WRONG_DOCUMENT_ERR

[To be supplied.]

[Visual Basic]
Public Const WRONG_DOCUMENT_ERR As Integer
[C#]
public const int WRONG_DOCUMENT_ERR;
[C++]
public: const int WRONG_DOCUMENT_ERR;
[JScript]
public var WRONG_DOCUMENT_ERR : int;

See Also

DOMException Class | DOMException Members | System.Data.XML.DOM Namespace


IAttr Interface

[To be supplied.]

IAttr

[Visual Basic]
Public Interface IAttr
   Implements INode
[C#]
public interface IAttr : INode
[C++]
public __gc __interface IAttr : public INode

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML.DOM

Assembly: System.Data.dll

See Also

IAttr Members | System.Data.XML.DOM Namespace


IAttr Members

Properties

name | [To be supplied.]
specified | [To be supplied.]
value | [To be supplied.]

See Also

IAttr Interface | System.Data.XML.DOM Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IAttr Properties

The properties of the IAttr interface are listed below. For a complete list of IAttr interface members, see the IAttr Members topic.

name | [To be supplied.]
specified | [To be supplied.]
value | [To be supplied.]

See Also

IAttr Interface | System.Data.XML.DOM Namespace


IAttr.name

[To be supplied.]

[Visual Basic]
ReadOnly Property name As String
[C#]
string name {get;}
[C++]
String* get_name() = 0;
[JScript]
abstract function get name() : String;

See Also

IAttr Interface | IAttr Members | System.Data.XML.DOM Namespace


IAttr.specified

[To be supplied.]

[Visual Basic]
ReadOnly Property specified As Boolean
[C#]
bool specified {get;}
[C++]
bool get_specified() = 0;
[JScript]
abstract function get specified() : Boolean;

See Also

IAttr Interface | IAttr Members | System.Data.XML.DOM Namespace


IAttr.value

[To be supplied.]

[Visual Basic]
Property value As String
[C#]
string value {get; set;}
[C++]
String* get_value() = 0;void set_value(String*) = 0;
[JScript]
abstract function get value() : String;
public abstract function set value(String);

See Also

IAttr Interface | IAttr Members | System.Data.XML.DOM Namespace


ICDATASection Interface

[To be supplied.]

[Visual Basic]
Public Interface ICDATASection
   Implements IText, ICharacterData, INode
[C#]
public interface ICDATASection : IText, ICharacterData, INode
[C++]
public __gc __interface ICDATASection : public IText,
   ICharacterData, INode

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML.DOM

Assembly: System.Data.dll

See Also

ICDATASection Members | System.Data.XML.DOM Namespace


NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICDATASection Members

See Also

ICDATASection Interface | System.Data.XML.DOM Namespace


ICharacterData Interface

[To be supplied.]

ICharacterData

[Visual Basic]
Public Interface ICharacterData
   Implements INode
[C#]
public interface ICharacterData : INode
[C++]
public __gc __interface ICharacterData : public INode

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML.DOM

Assembly: System.Data.dll

See Also

ICharacterData Members | System.Data.XML.DOM Namespace


ICharacterData Members

Properties

data | [To be supplied.]
length | [To be supplied.]

Methods

appendData | [To be supplied.]
deleteData | [To be supplied.]
insertData | [To be supplied.]
replaceData | [To be supplied.]
substringData | [To be supplied.]

See Also

ICharacterData Interface | System.Data.XML.DOM Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICharacterData Properties

The properties of the ICharacterData interface are listed below. For a complete list of ICharacterData interface members, see the ICharacterData Members topic.

data | [To be supplied.]
length | [To be supplied.]

See Also

ICharacterData Interface | System.Data.XML.DOM Namespace


ICharacterData.data

[To be supplied.]

[Visual Basic]
Property data As String
[C#]
string data {get; set;}
[C++]
String* get_data() = 0;void set_data(String*) = 0;
[JScript]
abstract function get data() : String;
public abstract function set data(String);

See Also

ICharacterData Interface | ICharacterData Members | System.Data.XML.DOM Namespace


ICharacterData.length

[To be supplied.]

[Visual Basic]
ReadOnly Property length As Integer
[C#]
int length {get;}
[C++]
int get_length() = 0;
[JScript]
abstract function get length() : int;

See Also

ICharacterData Interface | ICharacterData Members | System.Data.XML.DOM Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICharacterData Methods

The methods of the ICharacterData interface are listed below. For a complete list of ICharacterData interface members, see the ICharacterData Members topic.

appendData | [To be supplied.]
deleteData | [To be supplied.]
insertData | [To be supplied.]
replaceData | [To be supplied.]
substringData | [To be supplied.]

See Also

ICharacterData Interface | System.Data.XML.DOM Namespace


ICharacterData.appendData

[To be supplied.]

[Visual Basic]
Sub appendData( _
   ByVal strData As String _
)
[C#]
void appendData(
   string strData
);
[C++]
void appendData(
   String* strData
) = 0;
[JScript]
function appendData(
   strData : String
);

Parameters

strData
[To be supplied.]

See Also

ICharacterData Interface | ICharacterData Members | System.Data.XML.DOM Namespace


ICharacterData.deleteData

[To be supplied.]

[Visual Basic]
Sub deleteData( _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
[C#]
void deleteData(
   int offset,
   int count
);
[C++]
void deleteData(
   int offset,
   int count
) = 0;
[JScript]
function deleteData(
   offset : int,
   count : int
);

Parameters

offset
[To be supplied.]
count
[To be supplied.]

See Also

ICharacterData Interface | ICharacterData Members | System.Data.XML.DOM Namespace


ICharacterData.insertData

[To be supplied.]

[Visual Basic]
Sub insertData( _
   ByVal offset As Integer, _
   ByVal strData As String _
)
[C#]
void insertData(
   int offset,
   string strData
);
[C++]
void insertData(
   int offset,
   String* strData
) = 0;
[JScript]
function insertData(
   offset : int,
   strData : String
);

Parameters

offset
[To be supplied.]
strData
[To be supplied.]

See Also

ICharacterData Interface | ICharacterData Members | System.Data.XML.DOM Namespace


ICharacterData.replaceData

[To be supplied.]

[Visual Basic]
Sub replaceData( _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal strData As String _
)
[C#]
void replaceData(
   int offset,
   int count,
   string strData
);
[C++]
void replaceData(
   int offset,
   int count,
   String* strData
) = 0;
[JScript]
function replaceData(
   offset : int,
   count : int,
   strData : String
);

Parameters

offset
[To be supplied.]
count
[To be supplied.]
strData
[To be supplied.]

See Also

ICharacterData Interface | ICharacterData Members | System.Data.XML.DOM Namespace


ICharacterData.substringData

[To be supplied.]

[Visual Basic]
Function substringData( _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As String
[C#]
string substringData(
   int offset,
   int count
);
[C++]
String* substringData(
   int offset,
   int count
) = 0;
[JScript]
function substringData(
   offset : int,
   count : int
) : String;

Parameters

offset
[To be supplied.]
count
[To be supplied.]

See Also

ICharacterData Interface | ICharacterData Members | System.Data.XML.DOM Namespace


IComment Interface

[To be supplied.]

[Visual Basic]
Public Interface IComment
   Implements ICharacterData, INode
[C#]
public interface IComment : ICharacterData, INode
[C++]
public __gc __interface IComment : public ICharacterData, INode

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML.DOM

Assembly: System.Data.dll

See Also

IComment Members | System.Data.XML.DOM Namespace


NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IComment Members

See Also

IComment Interface | System.Data.XML.DOM Namespace


IDocument Interface

[To be supplied.]

IDocument

[Visual Basic]
Public Interface IDocument
   Implements INode
[C#]
public interface IDocument : INode
[C++]
public __gc __interface IDocument : public INode

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML.DOM

Assembly: System.Data.dll

See Also

IDocument Members | System.Data.XML.DOM Namespace


IDocument Members

Properties

doctype | [To be supplied.]
documentElement | [To be supplied.]
implementation | [To be supplied.]
preserveWhiteSpace | [To be supplied.]

Methods

createAttribute | [To be supplied.]
createCDATASection | [To be supplied.]
createComment | [To be supplied.]
createDocumentFragment | [To be supplied.]
createElement | [To be supplied.]
createEntityReference | [To be supplied.]
createNode | [To be supplied.]
createProcessingInstruction | [To be supplied.]
createTextNode | [To be supplied.]
getElementsByTagName | [To be supplied.]
load | [To be supplied.]
loadXML | [To be supplied.]

See Also

IDocument Interface | System.Data.XML.DOM Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDocument Properties

The properties of the IDocument interface are listed below. For a complete list of IDocument interface members, see the IDocument Members topic.

doctype | [To be supplied.]
documentElement | [To be supplied.]
implementation | [To be supplied.]
preserveWhiteSpace | [To be supplied.]

See Also

IDocument Interface | System.Data.XML.DOM Namespace


IDocument.doctype

[To be supplied.]

[Visual Basic]
ReadOnly Property doctype As IDocumentType
[C#]
IDocumentType doctype {get;}
[C++]
IDocumentType* get_doctype() = 0;
[JScript]
abstract function get doctype() : IDocumentType;

See Also

IDocument Interface | IDocument Members | System.Data.XML.DOM Namespace


IDocument.documentElement

[To be supplied.]

[Visual Basic]
ReadOnly Property documentElement As IElement
[C#]
IElement documentElement {get;}
[C++]
IElement* get_documentElement() = 0;
[JScript]
abstract function get documentElement() : IElement;

See Also

IDocument Interface | IDocument Members | System.Data.XML.DOM Namespace


IDocument.implementation

[To be supplied.]

[Visual Basic]
ReadOnly Property implementation As IDOMImplementation
[C#]
IDOMImplementation implementation {get;}
[C++]
IDOMImplementation* get_implementation() = 0;
[JScript]
abstract function get implementation() : IDOMImplementation;

See Also

IDocument Interface | IDocument Members | System.Data.XML.DOM Namespace


IDocument.preserveWhiteSpace

[To be supplied.]

[Visual Basic]
Property preserveWhiteSpace As Boolean
[C#]
bool preserveWhiteSpace {get; set;}
[C++]
bool get_preserveWhiteSpace() = 0;void set_preserveWhiteSpace(bool) = 0;
[JScript]
abstract function get preserveWhiteSpace() : Boolean;
public abstract function set preserveWhiteSpace(Boolean);

See Also

IDocument Interface | IDocument Members | System.Data.XML.DOM Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDocument Methods

The methods of the IDocument interface are listed below. For a complete list of IDocument interface members, see the IDocument Members topic.

createAttribute | [To be supplied.]
createCDATASection | [To be supplied.]
createComment | [To be supplied.]
createDocumentFragment | [To be supplied.]
createElement | [To be supplied.]
createEntityReference | [To be supplied.]
createNode | [To be supplied.]
createProcessingInstruction | [To be supplied.]
createTextNode | [To be supplied.]
getElementsByTagName | [To be supplied.]
load | [To be supplied.]
loadXML | [To be supplied.]

See Also

IDocument Interface | System.Data.XML.DOM Namespace


IDocument.createAttribute

[To be supplied.]

[Visual Basic]
Function createAttribute( _
   ByVal name As String _
) As IAttr
[C#]
IAttr createAttribute(
   string name
);
[C++]
IAttr* createAttribute(
   String* name
) = 0;
[JScript]
function createAttribute(
   name : String
) : IAttr;

Parameters

name
[To be supplied.]

See Also

IDocument Interface | IDocument Members | System.Data.XML.DOM Namespace


IDocument.createCDATASection

[To be supplied.]

[Visual Basic]
Function createCDATASection( _
   ByVal data As String _
) As ICDATASection
[C#]
ICDATASection createCDATASection(
   string data
);
[C++]
ICDATASection* createCDATASection(
   String* data
) = 0;
[JScript]
function createCDATASection(
   data : String
) : ICDATASection;

Parameters

data
[To be supplied.]

See Also

IDocument Interface | IDocument Members | System.Data.XML.DOM Namespace


IDocument.createComment

[To be supplied.]

[Visual Basic]
Function createComment( _
   ByVal data As String _
) As IComment
[C#]
IComment createComment(
   string data
);
[C++]
IComment* createComment(
   String* data
) = 0;
[JScript]
function createComment(
   data : String
) : IComment;

Parameters

data
[To be supplied.]

See Also

IDocument Interface | IDocument Members | System.Data.XML.DOM Namespace


IDocument.createDocumentFragment

[To be supplied.]

[Visual Basic]
Function createDocumentFragment() As IDocumentFragment
[C#]
IDocumentFragment createDocumentFragment();
[C++]
IDocumentFragment* createDocumentFragment() = 0;
[JScript]
function createDocumentFragment() : IDocumentFragment;

See Also

IDocument Interface | IDocument Members | System.Data.XML.DOM Namespace


IDocument.createElement

[To be supplied.]

[Visual Basic]
Function createElement( _
   ByVal tagName As String _
) As IElement
[C#]
IElement createElement(
   string tagName
);
[C++]
IElement* createElement(
   String* tagName
) = 0;
[JScript]
function createElement(
   tagName : String
) : IElement;

Parameters

tagName
[To be supplied.]

See Also

IDocument Interface | IDocument Members | System.Data.XML.DOM Namespace


IDocument.createEntityReference

[To be supplied.]

[Visual Basic]
Function createEntityReference( _
   ByVal name As String _
) As IEntityReference
[C#]
IEntityReference createEntityReference(
   string name
);
[C++]
IEntityReference* createEntityReference(
   String* name
) = 0;
[JScript]
function createEntityReference(
   name : String
) : IEntityReference;

Parameters

name
[To be supplied.]

See Also

IDocument Interface | IDocument Members | System.Data.XML.DOM Namespace


IDocument.createNode

[To be supplied.]

[Visual Basic]
Function createNode( _
   ByVal nodeTypeString As String, _
   ByVal name As String, _
   ByVal uri As String _
) As INode
[C#]
INode createNode(
   string nodeTypeString,
   string name,
   string uri
);
[C++]
INode* createNode(
   String* nodeTypeString,
   String* name,
   String* uri
) = 0;
[JScript]
function createNode(
   nodeTypeString : String,
   name : String,
   uri : String
) : INode;

Parameters

nodeTypeString
[To be supplied.]
name
[To be supplied.]
uri
[To be supplied.]

See Also

IDocument Interface | IDocument Members | System.Data.XML.DOM Namespace


IDocument.createProcessingInstruction

[To be supplied.]

[Visual Basic]
Function createProcessingInstruction( _
   ByVal target As String, _
   ByVal data As String _
) As IProcessingInstruction
[C#]
IProcessingInstruction createProcessingInstruction(
   string target,
   string data
);
[C++]
IProcessingInstruction* createProcessingInstruction(
   String* target,
   String* data
) = 0;
[JScript]
function createProcessingInstruction(
   target : String,
   data : String
) : IProcessingInstruction;

Parameters

target
[To be supplied.]
data
[To be supplied.]

See Also

IDocument Interface | IDocument Members | System.Data.XML.DOM Namespace


IDocument.createTextNode

[To be supplied.]

[Visual Basic]
Function createTextNode( _
   ByVal data As String _
) As IText
[C#]
IText createTextNode(
   string data
);
[C++]
IText* createTextNode(
   String* data
) = 0;
[JScript]
function createTextNode(
   data : String
) : IText;

Parameters

data
[To be supplied.]

See Also

IDocument Interface | IDocument Members | System.Data.XML.DOM Namespace


IDocument.getElementsByTagName

[To be supplied.]

[Visual Basic]
Function getElementsByTagName( _
   ByVal tagname As String _
) As INodeList
[C#]
INodeList getElementsByTagName(
   string tagname
);
[C++]
INodeList* getElementsByTagName(
   String* tagname
) = 0;
[JScript]
function getElementsByTagName(
   tagname : String
) : INodeList;

Parameters

tagname
[To be supplied.]

See Also

IDocument Interface | IDocument Members | System.Data.XML.DOM Namespace


IDocument.load

[To be supplied.]

[Visual Basic]
Sub load( _
   ByVal filename As String _
)
[C#]
void load(
   string filename
);
[C++]
void load(
   String* filename
) = 0;
[JScript]
function load(
   filename : String
);

Parameters

filename
[To be supplied.]

See Also

IDocument Interface | IDocument Members | System.Data.XML.DOM Namespace


IDocument.loadXML

[To be supplied.]

[Visual Basic]
Sub loadXML( _
   ByVal xml As String _
)
[C#]
void loadXML(
   string xml
);
[C++]
void loadXML(
   String* xml
) = 0;
[JScript]
function loadXML(
   xml : String
);

Parameters

xml
[To be supplied.]

See Also

IDocument Interface | IDocument Members | System.Data.XML.DOM Namespace


IDocumentFragment Interface

[To be supplied.]

IDocumentFragment

[Visual Basic]
Public Interface IDocumentFragment
   Implements INode
[C#]
public interface IDocumentFragment : INode
[C++]
public __gc __interface IDocumentFragment : public INode

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML.DOM

Assembly: System.Data.dll

See Also

IDocumentFragment Members | System.Data.XML.DOM Namespace


IDocumentFragment Members

See Also

IDocumentFragment Interface | System.Data.XML.DOM Namespace


IDocumentType Interface

[To be supplied.]

IDocumentType

[Visual Basic]
Public Interface IDocumentType
   Implements INode
[C#]
public interface IDocumentType : INode
[C++]
public __gc __interface IDocumentType : public INode

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML.DOM

Assembly: System.Data.dll

See Also

IDocumentType Members | System.Data.XML.DOM Namespace


IDocumentType Members

Properties

entities | [To be supplied.]
name | [To be supplied.]
notations | [To be supplied.]

See Also

IDocumentType Interface | System.Data.XML.DOM Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDocumentType Properties

The properties of the IDocumentType interface are listed below. For a complete list of IDocumentType interface members, see the IDocumentType Members topic.

entities | [To be supplied.]
name | [To be supplied.]
notations | [To be supplied.]

See Also

IDocumentType Interface | System.Data.XML.DOM Namespace


IDocumentType.entities

[To be supplied.]

[Visual Basic]
ReadOnly Property entities As INamedNodeMap
[C#]
INamedNodeMap entities {get;}
[C++]
INamedNodeMap* get_entities() = 0;
[JScript]
abstract function get entities() : INamedNodeMap;

See Also

IDocumentType Interface | IDocumentType Members | System.Data.XML.DOM Namespace


IDocumentType.name

[To be supplied.]

[Visual Basic]
ReadOnly Property name As String
[C#]
string name {get;}
[C++]
String* get_name() = 0;
[JScript]
abstract function get name() : String;

See Also

IDocumentType Interface | IDocumentType Members | System.Data.XML.DOM Namespace


IDocumentType.notations

[To be supplied.]

[Visual Basic]
ReadOnly Property notations As INamedNodeMap
[C#]
INamedNodeMap notations {get;}
[C++]
INamedNodeMap* get_notations() = 0;
[JScript]
abstract function get notations() : INamedNodeMap;

See Also

IDocumentType Interface | IDocumentType Members | System.Data.XML.DOM Namespace


IDOMImplementation Interface

[To be supplied.]

IDOMImplementation

[Visual Basic]
Public Interface IDOMImplementation
[C#]
public interface IDOMImplementation
[C++]
public __gc __interface IDOMImplementation

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML.DOM

Assembly: System.Data.dll

See Also

IDOMImplementation Members | System.Data.XML.DOM Namespace


IDOMImplementation Members

Methods

hasFeature [To be supplied.]

See Also

IDOMImplementation Interface | System.Data.XML.DOM Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDOMImplementation Methods

The methods of the IDOMImplementation interface are listed below. For a complete list of IDOMImplementation interface members, see the IDOMImplementation Members topic.

hasFeature [To be supplied.]

See Also

IDOMImplementation Interface | System.Data.XML.DOM Namespace


IDOMImplementation.hasFeature

[To be supplied.]

[Visual Basic]
Function hasFeature( _
   ByVal feature As String, _
   ByVal version As String _
) As Boolean
[C#]
bool hasFeature(
   string feature,
   string version
);
[C++]
bool hasFeature(
   String* feature,
   String* version
) = 0;
[JScript]
function hasFeature(
   feature : String,
   version : String
) : Boolean;

Parameters

feature
[To be supplied.]
version
[To be supplied.]

See Also

IDOMImplementation Interface | IDOMImplementation Members | System.Data.XML.DOM Namespace


IElement Interface

[To be supplied.]

IElement

[Visual Basic]
Public Interface IElement
   Implements INode
[C#]
public interface IElement : INode
[C++]
public __gc __interface IElement : public INode

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML.DOM

Assembly: System.Data.dll

See Also

IElement Members | System.Data.XML.DOM Namespace


IElement Members

Properties

tagName [To be supplied.]

Methods

getAttribute | [To be supplied.]
getAttributeNode | [To be supplied.]
getElementsByTagName | [To be supplied.]
normalize | [To be supplied.]
removeAttribute | [To be supplied.]
removeAttributeNode | [To be supplied.]
setAttribute | [To be supplied.]
setAttributeNode | [To be supplied.]

See Also

IElement Interface | System.Data.XML.DOM Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IElement Properties

The properties of the IElement interface are listed below. For a complete list of IElement interface members, see the IElement Members topic.

tagName [To be supplied.]

See Also

IElement Interface | System.Data.XML.DOM Namespace


IElement.tagName

[To be supplied.]

[Visual Basic]
ReadOnly Property tagName As String
[C#]
string tagName {get;}
[C++]
String* get_tagName() = 0;
[JScript]
abstract function get tagName() : String;

See Also

IElement Interface | IElement Members | System.Data.XML.DOM Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IElement Methods

The methods of the IElement interface are listed below. For a complete list of IElement interface members, see the IElement Members topic.

getAttribute | [To be supplied.]
getAttributeNode | [To be supplied.]
getElementsByTagName | [To be supplied.]
normalize | [To be supplied.]
removeAttribute | [To be supplied.]
removeAttributeNode | [To be supplied.]
setAttribute | [To be supplied.]
setAttributeNode | [To be supplied.]

See Also

IElement Interface | System.Data.XML.DOM Namespace


IElement.getAttribute

[To be supplied.]

[Visual Basic]
Function getAttribute( _
   ByVal name As String _
) As String
[C#]
string getAttribute(
   string name
);
[C++]
String* getAttribute(
   String* name
) = 0;
[JScript]
function getAttribute(
   name : String
) : String;

Parameters

name
[To be supplied.]

See Also

IElement Interface | IElement Members | System.Data.XML.DOM Namespace


IElement.getAttributeNode

[To be supplied.]

[Visual Basic]
Function getAttributeNode( _
   ByVal name As String _
) As IAttr
[C#]
IAttr getAttributeNode(
   string name
);
[C++]
IAttr* getAttributeNode(
   String* name
) = 0;
[JScript]
function getAttributeNode(
   name : String
) : IAttr;

Parameters

name
[To be supplied.]

See Also

IElement Interface | IElement Members | System.Data.XML.DOM Namespace


IElement.getElementsByTagName

[To be supplied.]

[Visual Basic]
Function getElementsByTagName( _
   ByVal name As String _
) As INodeList
[C#]
INodeList getElementsByTagName(
   string name
);
[C++]
INodeList* getElementsByTagName(
   String* name
) = 0;
[JScript]
function getElementsByTagName(
   name : String
) : INodeList;

Parameters

name
[To be supplied.]

See Also

IElement Interface | IElement Members | System.Data.XML.DOM Namespace


IElement.normalize

[To be supplied.]

[Visual Basic]
Sub normalize()
[C#]
void normalize();
[C++]
void normalize() = 0;
[JScript]
function normalize();

See Also

IElement Interface | IElement Members | System.Data.XML.DOM Namespace


IElement.removeAttribute

[To be supplied.]

[Visual Basic]
Sub removeAttribute( _
   ByVal name As String _
)
[C#]
void removeAttribute(
   string name
);
[C++]
void removeAttribute(
   String* name
) = 0;
[JScript]
function removeAttribute(
   name : String
);

Parameters

name
[To be supplied.]

See Also

IElement Interface | IElement Members | System.Data.XML.DOM Namespace


IElement.removeAttributeNode

[To be supplied.]

[Visual Basic]
Function removeAttributeNode( _
   ByVal oldAttr As IAttr _
) As IAttr
[C#]
IAttr removeAttributeNode(
   IAttr oldAttr
);
[C++]
IAttr* removeAttributeNode(
   IAttr* oldAttr
) = 0;
[JScript]
function removeAttributeNode(
   oldAttr : IAttr
) : IAttr;

Parameters

oldAttr
[To be supplied.]

See Also

IElement Interface | IElement Members | System.Data.XML.DOM Namespace


IElement.setAttribute

[To be supplied.]

[Visual Basic]
Sub setAttribute( _
   ByVal name As String, _
   ByVal value As String _
)
[C#]
void setAttribute(
   string name,
   string value
);
[C++]
void setAttribute(
   String* name,
   String* value
) = 0;
[JScript]
function setAttribute(
   name : String,
   value : String
);

Parameters

name
[To be supplied.]
value
[To be supplied.]

See Also

IElement Interface | IElement Members | System.Data.XML.DOM Namespace


IElement.setAttributeNode

[To be supplied.]

[Visual Basic]
Function setAttributeNode( _
   ByVal newAttr As IAttr _
) As IAttr
[C#]
IAttr setAttributeNode(
   IAttr newAttr
);
[C++]
IAttr* setAttributeNode(
   IAttr* newAttr
) = 0;
[JScript]
function setAttributeNode(
   newAttr : IAttr
) : IAttr;

Parameters

newAttr
[To be supplied.]

See Also

IElement Interface | IElement Members | System.Data.XML.DOM Namespace


IEntity Interface

[To be supplied.]

IEntity

[Visual Basic]
Public Interface IEntity
   Implements INode
[C#]
public interface IEntity : INode
[C++]
public __gc __interface IEntity : public INode

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML.DOM

Assembly: System.Data.dll

See Also

IEntity Members | System.Data.XML.DOM Namespace


IEntity Members

Properties

notationName | [To be supplied.]
publicId | [To be supplied.]
systemId | [To be supplied.]

See Also

IEntity Interface | System.Data.XML.DOM Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IEntity Properties

The properties of the IEntity interface are listed below. For a complete list of IEntity interface members, see the IEntity Members topic.

notationName | [To be supplied.]
publicId | [To be supplied.]
systemId | [To be supplied.]

See Also

IEntity Interface | System.Data.XML.DOM Namespace


IEntity.notationName

[To be supplied.]

[Visual Basic]
ReadOnly Property notationName As String
[C#]
string notationName {get;}
[C++]
String* get_notationName() = 0;
[JScript]
abstract function get notationName() : String;

See Also

IEntity Interface | IEntity Members | System.Data.XML.DOM Namespace


IEntity.publicId

[To be supplied.]

[Visual Basic]
ReadOnly Property publicId As String
[C#]
string publicId {get;}
[C++]
String* get_publicId() = 0;
[JScript]
abstract function get publicId() : String;

See Also

IEntity Interface | IEntity Members | System.Data.XML.DOM Namespace


IEntity.systemId

[To be supplied.]

[Visual Basic]
ReadOnly Property systemId As String
[C#]
string systemId {get;}
[C++]
String* get_systemId() = 0;
[JScript]
abstract function get systemId() : String;

See Also

IEntity Interface | IEntity Members | System.Data.XML.DOM Namespace


IEntityReference Interface

[To be supplied.]

IEntityReference

[Visual Basic]
Public Interface IEntityReference
   Implements INode
[C#]
public interface IEntityReference : INode
[C++]
public __gc __interface IEntityReference : public INode

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML.DOM

Assembly: System.Data.dll

See Also

IEntityReference Members | System.Data.XML.DOM Namespace


NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IEntityReference Members

See Also

IEntityReference Interface | System.Data.XML.DOM Namespace


INamedNodeMap Interface

[To be supplied.]

INamedNodeMap

[Visual Basic]
Public Interface INamedNodeMap
[C#]
public interface INamedNodeMap
[C++]
public __gc __interface INamedNodeMap

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML.DOM

Assembly: System.Data.dll

See Also

INamedNodeMap Members | System.Data.XML.DOM Namespace


INamedNodeMap Members

Properties

length [To be supplied.]

Methods

getNamedItem | [To be supplied.]
item | [To be supplied.]
removeNamedItem | [To be supplied.]
setNamedItem | [To be supplied.]

See Also

INamedNodeMap Interface | System.Data.XML.DOM Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

INamedNodeMap Properties

The properties of the INamedNodeMap interface are listed below. For a complete list of INamedNodeMap interface members, see the INamedNodeMap Members topic.

length [To be supplied.]

See Also

INamedNodeMap Interface | System.Data.XML.DOM Namespace


INamedNodeMap.length

[To be supplied.]

[Visual Basic]
ReadOnly Property length As Integer
[C#]
int length {get;}
[C++]
int get_length() = 0;
[JScript]
abstract function get length() : int;

See Also

INamedNodeMap Interface | INamedNodeMap Members | System.Data.XML.DOM Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

INamedNodeMap Methods

The methods of the INamedNodeMap interface are listed below. For a complete list of INamedNodeMap interface members, see the INamedNodeMap Members topic.

getNamedItem | [To be supplied.]
item | [To be supplied.]
removeNamedItem | [To be supplied.]
setNamedItem | [To be supplied.]

See Also

INamedNodeMap Interface | System.Data.XML.DOM Namespace


INamedNodeMap.getNamedItem

[To be supplied.]

[Visual Basic]
Function getNamedItem( _
   ByVal name As String _
) As INode
[C#]
INode getNamedItem(
   string name
);
[C++]
INode* getNamedItem(
   String* name
) = 0;
[JScript]
function getNamedItem(
   name : String
) : INode;

Parameters

name
[To be supplied.]

See Also

INamedNodeMap Interface | INamedNodeMap Members | System.Data.XML.DOM Namespace


INamedNodeMap.item

[To be supplied.]

[Visual Basic]
Function item( _
   ByVal index As Integer _
) As INode
[C#]
INode item(
   int index
);
[C++]
INode* item(
   int index
) = 0;
[JScript]
function item(
   index : int
) : INode;

Parameters

index
[To be supplied.]

See Also

INamedNodeMap Interface | INamedNodeMap Members | System.Data.XML.DOM Namespace


INamedNodeMap.removeNamedItem

[To be supplied.]

[Visual Basic]
Function removeNamedItem( _
   ByVal name As String _
) As INode
[C#]
INode removeNamedItem(
   string name
);
[C++]
INode* removeNamedItem(
   String* name
) = 0;
[JScript]
function removeNamedItem(
   name : String
) : INode;

Parameters

name
[To be supplied.]

See Also

INamedNodeMap Interface | INamedNodeMap Members | System.Data.XML.DOM Namespace


INamedNodeMap.setNamedItem

[To be supplied.]

[Visual Basic]
Function setNamedItem( _
   ByVal arg As INode _
) As INode
[C#]
INode setNamedItem(
   INode arg
);
[C++]
INode* setNamedItem(
   INode* arg
) = 0;
[JScript]
function setNamedItem(
   arg : INode
) : INode;

Parameters

arg
[To be supplied.]

See Also

INamedNodeMap Interface | INamedNodeMap Members | System.Data.XML.DOM Namespace


INode Interface

[To be supplied.]

INode

[Visual Basic]
Public Interface INode
[C#]
public interface INode
[C++]
public __gc __interface INode

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML.DOM

Assembly: System.Data.dll

See Also

INode Members | System.Data.XML.DOM Namespace


INode Members

Properties

attributes | [To be supplied.]
baseName | [To be supplied.]
childNodes | [To be supplied.]
firstChild | [To be supplied.]
lastChild | [To be supplied.]
namespaceURI | [To be supplied.]
nextSibling | [To be supplied.]
nodeName | [To be supplied.]
nodeType | [To be supplied.]
nodeValue | [To be supplied.]
ownerDocument | [To be supplied.]
parentNode | [To be supplied.]
prefix | [To be supplied.]
previousSibling | [To be supplied.]
text | [To be supplied.]
xml | [To be supplied.]

Methods

appendChild | [To be supplied.]
cloneNode | [To be supplied.]
hasChildNodes | [To be supplied.]
insertBefore | [To be supplied.]
removeChild | [To be supplied.]
replaceChild | [To be supplied.]

See Also

INode Interface | System.Data.XML.DOM Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

INode Properties

The properties of the INode interface are listed below. For a complete list of INode interface members, see the INode Members topic.

attributes | [To be supplied.]
baseName | [To be supplied.]
childNodes | [To be supplied.]
firstChild | [To be supplied.]
lastChild | [To be supplied.]
namespaceURI | [To be supplied.]
nextSibling | [To be supplied.]
nodeName | [To be supplied.]
nodeType | [To be supplied.]
nodeValue | [To be supplied.]
ownerDocument | [To be supplied.]
parentNode | [To be supplied.]
prefix | [To be supplied.]
previousSibling | [To be supplied.]
text | [To be supplied.]
xml | [To be supplied.]

See Also

INode Interface | System.Data.XML.DOM Namespace


INode.attributes

[To be supplied.]

[Visual Basic]
ReadOnly Property attributes As INamedNodeMap
[C#]
INamedNodeMap attributes {get;}
[C++]
INamedNodeMap* get_attributes() = 0;
[JScript]
abstract function get attributes() : INamedNodeMap;

See Also

INode Interface | INode Members | System.Data.XML.DOM Namespace


INode.baseName

[To be supplied.]

[Visual Basic]
ReadOnly Property baseName As String
[C#]
string baseName {get;}
[C++]
String* get_baseName() = 0;
[JScript]
abstract function get baseName() : String;

See Also

INode Interface | INode Members | System.Data.XML.DOM Namespace


INode.childNodes

[To be supplied.]

[Visual Basic]
ReadOnly Property childNodes As INodeList
[C#]
INodeList childNodes {get;}
[C++]
INodeList* get_childNodes() = 0;
[JScript]
abstract function get childNodes() : INodeList;

See Also

INode Interface | INode Members | System.Data.XML.DOM Namespace


INode.firstChild

[To be supplied.]

[Visual Basic]
ReadOnly Property firstChild As INode
[C#]
INode firstChild {get;}
[C++]
INode* get_firstChild() = 0;
[JScript]
abstract function get firstChild() : INode;

See Also

INode Interface | INode Members | System.Data.XML.DOM Namespace


INode.lastChild

[To be supplied.]

[Visual Basic]
ReadOnly Property lastChild As INode
[C#]
INode lastChild {get;}
[C++]
INode* get_lastChild() = 0;
[JScript]
abstract function get lastChild() : INode;

See Also

INode Interface | INode Members | System.Data.XML.DOM Namespace


INode.namespaceURI

[To be supplied.]

[Visual Basic]
ReadOnly Property namespaceURI As String
[C#]
string namespaceURI {get;}
[C++]
String* get_namespaceURI() = 0;
[JScript]
abstract function get namespaceURI() : String;

See Also

INode Interface | INode Members | System.Data.XML.DOM Namespace


INode.nextSibling

[To be supplied.]

[Visual Basic]
ReadOnly Property nextSibling As INode
[C#]
INode nextSibling {get;}
[C++]
INode* get_nextSibling() = 0;
[JScript]
abstract function get nextSibling() : INode;

See Also

INode Interface | INode Members | System.Data.XML.DOM Namespace


INode.nodeName

[To be supplied.]

[Visual Basic]
ReadOnly Property nodeName As String
[C#]
string nodeName {get;}
[C++]
String* get_nodeName() = 0;
[JScript]
abstract function get nodeName() : String;

See Also

INode Interface | INode Members | System.Data.XML.DOM Namespace


INode.nodeType

[To be supplied.]

[Visual Basic]
ReadOnly Property nodeType As NodeType
[C#]
NodeType nodeType {get;}
[C++]
NodeType get_nodeType() = 0;
[JScript]
abstract function get nodeType() : NodeType;

See Also

INode Interface | INode Members | System.Data.XML.DOM Namespace


INode.nodeValue

[To be supplied.]

[Visual Basic]
Property nodeValue As String
[C#]
string nodeValue {get; set;}
[C++]
String* get_nodeValue() = 0;void set_nodeValue(String*) = 0;
[JScript]
abstract function get nodeValue() : String;
public abstract function set nodeValue(String);

See Also

INode Interface | INode Members | System.Data.XML.DOM Namespace


INode.ownerDocument

[To be supplied.]

[Visual Basic]
ReadOnly Property ownerDocument As IDocument
[C#]
IDocument ownerDocument {get;}
[C++]
IDocument* get_ownerDocument() = 0;
[JScript]
abstract function get ownerDocument() : IDocument;

See Also

INode Interface | INode Members | System.Data.XML.DOM Namespace


INode.parentNode

[To be supplied.]

[Visual Basic]
ReadOnly Property parentNode As INode
[C#]
INode parentNode {get;}
[C++]
INode* get_parentNode() = 0;
[JScript]
abstract function get parentNode() : INode;

See Also

INode Interface | INode Members | System.Data.XML.DOM Namespace


INode.prefix

[To be supplied.]

[Visual Basic]
ReadOnly Property prefix As String
[C#]
string prefix {get;}
[C++]
String* get_prefix() = 0;
[JScript]
abstract function get prefix() : String;

See Also

INode Interface | INode Members | System.Data.XML.DOM Namespace


INode.previousSibling

[To be supplied.]

[Visual Basic]
ReadOnly Property previousSibling As INode
[C#]
INode previousSibling {get;}
[C++]
INode* get_previousSibling() = 0;
[JScript]
abstract function get previousSibling() : INode;

See Also

INode Interface | INode Members | System.Data.XML.DOM Namespace


INode.text

[To be supplied.]

[Visual Basic]
Property text As String
[C#]
string text {get; set;}
[C++]
String* get_text() = 0;void set_text(String*) = 0;
[JScript]
abstract function get text() : String;
public abstract function set text(String);

See Also

INode Interface | INode Members | System.Data.XML.DOM Namespace


INode.xml

[To be supplied.]

[Visual Basic]
ReadOnly Property xml As String
[C#]
string xml {get;}
[C++]
String* get_xml() = 0;
[JScript]
abstract function get xml() : String;

See Also

INode Interface | INode Members | System.Data.XML.DOM Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

INode Methods

The methods of the INode interface are listed below. For a complete list of INode interface members, see the INode Members topic.

appendChild | [To be supplied.]
cloneNode | [To be supplied.]
hasChildNodes | [To be supplied.]
insertBefore | [To be supplied.]
removeChild | [To be supplied.]
replaceChild | [To be supplied.]

See Also

INode Interface | System.Data.XML.DOM Namespace


INode.appendChild

[To be supplied.]

[Visual Basic]
Function appendChild( _
   ByVal newChild As INode _
) As INode
[C#]
INode appendChild(
   INode newChild
);
[C++]
INode* appendChild(
   INode* newChild
) = 0;
[JScript]
function appendChild(
   newChild : INode
) : INode;

Parameters

newChild
[To be supplied.]

See Also

INode Interface | INode Members | System.Data.XML.DOM Namespace


INode.cloneNode

[To be supplied.]

[Visual Basic]
Function cloneNode( _
   ByVal deep As Boolean _
) As INode
[C#]
INode cloneNode(
   bool deep
);
[C++]
INode* cloneNode(
   bool deep
) = 0;
[JScript]
function cloneNode(
   deep : Boolean
) : INode;

Parameters

deep
[To be supplied.]

See Also

INode Interface | INode Members | System.Data.XML.DOM Namespace


INode.hasChildNodes

[To be supplied.]

[Visual Basic]
Function hasChildNodes() As Boolean
[C#]
bool hasChildNodes();
[C++]
bool hasChildNodes() = 0;
[JScript]
function hasChildNodes() : Boolean;

See Also

INode Interface | INode Members | System.Data.XML.DOM Namespace


INode.insertBefore

[To be supplied.]

[Visual Basic]
Function insertBefore( _
   ByVal newChild As INode, _
   ByVal refChild As INode _
) As INode
[C#]
INode insertBefore(
   INode newChild,
   INode refChild
);
[C++]
INode* insertBefore(
   INode* newChild,
   INode* refChild
) = 0;
[JScript]
function insertBefore(
   newChild : INode,
   refChild : INode
) : INode;

Parameters

newChild
[To be supplied.]
refChild
[To be supplied.]

See Also

INode Interface | INode Members | System.Data.XML.DOM Namespace


INode.removeChild

[To be supplied.]

[Visual Basic]
Function removeChild( _
   ByVal oldChild As INode _
) As INode
[C#]
INode removeChild(
   INode oldChild
);
[C++]
INode* removeChild(
   INode* oldChild
) = 0;
[JScript]
function removeChild(
   oldChild : INode
) : INode;

Parameters

oldChild
[To be supplied.]

See Also

INode Interface | INode Members | System.Data.XML.DOM Namespace


INode.replaceChild

[To be supplied.]

[Visual Basic]
Function replaceChild( _
   ByVal newChild As INode, _
   ByVal oldChild As INode _
) As INode
[C#]
INode replaceChild(
   INode newChild,
   INode oldChild
);
[C++]
INode* replaceChild(
   INode* newChild,
   INode* oldChild
) = 0;
[JScript]
function replaceChild(
   newChild : INode,
   oldChild : INode
) : INode;

Parameters

newChild
[To be supplied.]
oldChild
[To be supplied.]

See Also

INode Interface | INode Members | System.Data.XML.DOM Namespace


INodeList Interface

[To be supplied.]

INodeList

[Visual Basic]
Public Interface INodeList
[C#]
public interface INodeList
[C++]
public __gc __interface INodeList

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML.DOM

Assembly: System.Data.dll

See Also

INodeList Members | System.Data.XML.DOM Namespace


INodeList Members

Properties

length | [To be supplied.]
nextNode | [To be supplied.]

Methods

item | [To be supplied.]
reset | [To be supplied.]

See Also

INodeList Interface | System.Data.XML.DOM Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

INodeList Properties

The properties of the INodeList interface are listed below. For a complete list of INodeList interface members, see the INodeList Members topic.

length | [To be supplied.]
nextNode | [To be supplied.]

See Also

INodeList Interface | System.Data.XML.DOM Namespace


INodeList.length

[To be supplied.]

[Visual Basic]
ReadOnly Property length As Integer
[C#]
int length {get;}
[C++]
int get_length() = 0;
[JScript]
abstract function get length() : int;

See Also

INodeList Interface | INodeList Members | System.Data.XML.DOM Namespace


INodeList.nextNode

[To be supplied.]

[Visual Basic]
ReadOnly Property nextNode As INode
[C#]
INode nextNode {get;}
[C++]
INode* get_nextNode() = 0;
[JScript]
abstract function get nextNode() : INode;

See Also

INodeList Interface | INodeList Members | System.Data.XML.DOM Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

INodeList Methods

The methods of the INodeList interface are listed below. For a complete list of INodeList interface members, see the INodeList Members topic.

item | [To be supplied.]
reset | [To be supplied.]

See Also

INodeList Interface | System.Data.XML.DOM Namespace


INodeList.item

[To be supplied.]

[Visual Basic]
Function item( _
   ByVal index As Integer _
) As INode
[C#]
INode item(
   int index
);
[C++]
INode* item(
   int index
) = 0;
[JScript]
function item(
   index : int
) : INode;

Parameters

index
[To be supplied.]

See Also

INodeList Interface | INodeList Members | System.Data.XML.DOM Namespace


INodeList.reset

[To be supplied.]

[Visual Basic]
Sub reset()
[C#]
void reset();
[C++]
void reset() = 0;
[JScript]
function reset();

See Also

INodeList Interface | INodeList Members | System.Data.XML.DOM Namespace


IProcessingInstruction Interface

[To be supplied.]

IProcessingInstruction

[Visual Basic]
Public Interface IProcessingInstruction
   Implements INode
[C#]
public interface IProcessingInstruction : INode
[C++]
public __gc __interface IProcessingInstruction : public INode

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML.DOM

Assembly: System.Data.dll

See Also

IProcessingInstruction Members | System.Data.XML.DOM Namespace


IProcessingInstruction Members

Properties

data | [To be supplied.]
target | [To be supplied.]

See Also

IProcessingInstruction Interface | System.Data.XML.DOM Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IProcessingInstruction Properties

The properties of the IProcessingInstruction interface are listed below. For a complete list of IProcessingInstruction interface members, see the IProcessingInstruction Members topic.

data | [To be supplied.]
target | [To be supplied.]

See Also

IProcessingInstruction Interface | System.Data.XML.DOM Namespace


IProcessingInstruction.data

[To be supplied.]

[Visual Basic]
Property data As String
[C#]
string data {get; set;}
[C++]
String* get_data() = 0;void set_data(String*) = 0;
[JScript]
abstract function get data() : String;
public abstract function set data(String);

See Also

IProcessingInstruction Interface | IProcessingInstruction Members | System.Data.XML.DOM Namespace


IProcessingInstruction.target

[To be supplied.]

[Visual Basic]
ReadOnly Property target As String
[C#]
string target {get;}
[C++]
String* get_target() = 0;
[JScript]
abstract function get target() : String;

See Also

IProcessingInstruction Interface | IProcessingInstruction Members | System.Data.XML.DOM Namespace


IText Interface

[To be supplied.]

[Visual Basic]
Public Interface IText
   Implements ICharacterData, INode
[C#]
public interface IText : ICharacterData, INode
[C++]
public __gc __interface IText : public ICharacterData, INode

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML.DOM

Assembly: System.Data.dll

See Also

IText Members | System.Data.XML.DOM Namespace


IText Members

Methods

splitText [To be supplied.]

See Also

IText Interface | System.Data.XML.DOM Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IText Methods

The methods of the IText interface are listed below. For a complete list of IText interface members, see the IText Members topic.

splitText [To be supplied.]

See Also

IText Interface | System.Data.XML.DOM Namespace


IText.splitText

[To be supplied.]

[Visual Basic]
Function splitText( _
   ByVal offset As Integer _
) As IText
[C#]
IText splitText(
   int offset
);
[C++]
IText* splitText(
   int offset
) = 0;
[JScript]
function splitText(
   offset : int
) : IText;

Parameters

offset
[To be supplied.]

See Also

IText Interface | IText Members | System.Data.XML.DOM Namespace


NodeType Enumeration

[To be supplied.]

[Visual Basic]
Public Enum NodeType
[C#]
public enum NodeType
[C++]
public enum NodeType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
ATTRIBUTE_NODE | [To be supplied.]
CDATA_SECTION_NODE | [To be supplied.]
COMMENT_NODE | [To be supplied.]
DOCUMENT_FRAGMENT_NODE | [To be supplied.]
DOCUMENT_NODE | [To be supplied.]
DOCUMENT_TYPE_NODE | [To be supplied.]
ELEMENT_NODE | [To be supplied.]
ENTITY_NODE | [To be supplied.]
ENTITY_REFERENCE_NODE | [To be supplied.]
NOTATION_NODE | [To be supplied.]
PROCESSING_INSTRUCTION_NODE | [To be supplied.]
TEXT_NODE | [To be supplied.]
UNDEFINED_NODE | [To be supplied.]

Requirements

Namespace: System.Data.XML.DOM

Assembly: System.Data.dll

See Also

System.Data.XML.DOM Namespace


System.Data.XML.XPath

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Data.XML.XPath Namespace

Enumerations

Enumeration | Description
Querytype | [To be supplied.]


Querytype Enumeration

[To be supplied.]

[Visual Basic]
Public Enum Querytype
[C#]
public enum Querytype
[C++]
public enum Querytype

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Ancestor | [To be supplied.]
Attribute | [To be supplied.]
Child | [To be supplied.]
Constant | [To be supplied.]
Descendant | [To be supplied.]
None | [To be supplied.]

Requirements

Namespace: System.Data.XML.XPath

Assembly: System.Data.dll

See Also

System.Data.XML.XPath Namespace


System.Data.XML.XSLT

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Data.XML.XSLT Namespace

Classes

Class | Description
Debug | [To be supplied.]
NSParamList | [To be supplied.]
XsltException | [To be supplied.]
XslTransform | [To be supplied.]

Interfaces

Interface | Description
IDataTransform | [To be supplied.]


Debug Class

[To be supplied.]

Object
Debug

[Visual Basic]
NotInheritable Public Class Debug
[C#]
public sealed class Debug
[C++]
public __gc __sealed class Debug
[JScript]
public class Debug

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML.XSLT

Assembly: System.Data.dll

See Also

Debug Members | System.Data.XML.XSLT Namespace


Debug Members

Public:

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.
TraceOff | [To be supplied.]
TraceOn | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Debug Class | System.Data.XML.XSLT Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Debug Methods

The methods of the Debug class are listed below. For a complete list of Debug class members, see the Debug Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.
TraceOff | [To be supplied.]
TraceOn | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Debug Class | System.Data.XML.XSLT Namespace


Debug.TraceOff

[To be supplied.]

[Visual Basic]
Public Shared Sub TraceOff()
[C#]
public static void TraceOff();
[C++]
public: static void TraceOff();
[JScript]
public static function TraceOff();

See Also

Debug Class | Debug Members | System.Data.XML.XSLT Namespace


Debug.TraceOn

[To be supplied.]

[Visual Basic]
Public Shared Sub TraceOn()
[C#]
public static void TraceOn();
[C++]
public: static void TraceOn();
[JScript]
public static function TraceOn();

See Also

Debug Class | Debug Members | System.Data.XML.XSLT Namespace


IDataTransform Interface

[To be supplied.]

IDataTransform

[Visual Basic]
Public Interface IDataTransform
[C#]
public interface IDataTransform
[C++]
public __gc __interface IDataTransform

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IDataTransform

Class | Description
XslTransform | [To be supplied.]

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML.XSLT

Assembly: System.Data.dll

See Also

IDataTransform Members | System.Data.XML.XSLT Namespace


IDataTransform Members

Methods

Transform Overloaded. [To be supplied.]

See Also

IDataTransform Interface | System.Data.XML.XSLT Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDataTransform Methods

The methods of the IDataTransform interface are listed below. For a complete list of IDataTransform interface members, see the IDataTransform Members topic.

Transform Overloaded. [To be supplied.]

See Also

IDataTransform Interface | System.Data.XML.XSLT Namespace


IDataTransform.Transform

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Sub Transform(IDataNavigator, NSParamList, IDataWriter)
[C#] void Transform(IDataNavigator, NSParamList, IDataWriter);
[C++] void Transform(IDataNavigator*, NSParamList, IDataWriter) = 0;
[JScript] function Transform(IDataNavigator, NSParamList, IDataWriter);

[To be supplied.]

[Visual Basic] Overloads Function Transform(IDataNavigator, NSParamList) As IDataReader
[C#] IDataReader Transform(IDataNavigator, NSParamList);
[C++] IDataReader* Transform(IDataNavigator*, NSParamList) = 0;
[JScript] function Transform(IDataNavigator, NSParamList) : IDataReader;

See Also

IDataTransform Interface | IDataTransform Members | System.Data.XML.XSLT Namespace


IDataTransform.Transform (IDataNavigator, NSParamList, IDataWriter)

[To be supplied.]

[Visual Basic]
Overloads Sub Transform( _
   ByVal input As IDataNavigator, _
   ByVal args As NSParamList, _
   ByVal output As IDataWriter _
)
[C#]
void Transform(
   IDataNavigator input,
   NSParamList args,
   IDataWriter output
);
[C++]
void Transform(
   IDataNavigator* input,
   NSParamList* args,
   IDataWriter* output
) = 0;
[JScript]
function Transform(
   input : IDataNavigator,
   args : NSParamList,
   output : IDataWriter
);

Parameters

input
[To be supplied.]
args
[To be supplied.]
output
[To be supplied.]

See Also

IDataTransform Interface | IDataTransform Members | System.Data.XML.XSLT Namespace | IDataTransform.Transform Overload List


IDataTransform.Transform (IDataNavigator, NSParamList)

[To be supplied.]

[Visual Basic]
Overloads Function Transform( _
   ByVal input As IDataNavigator, _
   ByVal args As NSParamList _
) As IDataReader
[C#]
IDataReader Transform(
   IDataNavigator input,
   NSParamList args
);
[C++]
IDataReader* Transform(
   IDataNavigator* input,
   NSParamList* args
) = 0;
[JScript]
function Transform(
   input : IDataNavigator,
   args : NSParamList
) : IDataReader;

Parameters

input
[To be supplied.]
args
[To be supplied.]

See Also

IDataTransform Interface | IDataTransform Members | System.Data.XML.XSLT Namespace | IDataTransform.Transform Overload List


NSParamList Class

[To be supplied.]

Object
NSParamList

[Visual Basic]
Public Class NSParamList
[C#]
public class NSParamList
[C++]
public __gc class NSParamList
[JScript]
public class NSParamList

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML.XSLT

Assembly: System.Data.dll

See Also

NSParamList Members | System.Data.XML.XSLT Namespace


NSParamList Members

Public:

Constructor

NSParamList Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NSParamList Class | System.Data.XML.XSLT Namespace


NSParamList Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public NSParamList();
[C++]
public: NSParamList();
[JScript]
public function NSParamList();

See Also

NSParamList Class | NSParamList Members | System.Data.XML.XSLT Namespace


XsltException Class

[To be supplied.]

Object
Exception
XsltException

[Visual Basic]
Public Class XsltException
   Inherits Exception
[C#]
public class XsltException : Exception
[C++]
public __gc class XsltException : public Exception
[JScript]
public class XsltException extends Exception

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML.XSLT

Assembly: System.Data.dll

See Also

XsltException Members | System.Data.XML.XSLT Namespace


XsltException Members

Public:

Properties

HelpLink | [To be supplied.]
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message | [To be supplied.]
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

XsltException Class | System.Data.XML.XSLT Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XsltException Properties

The properties of the XsltException class are listed below. For a complete list of XsltException class members, see the XsltException Members topic.

Public:

HelpLink | [To be supplied.]
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message | [To be supplied.]
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

See Also

XsltException Class | System.Data.XML.XSLT Namespace


XsltException.HelpLink

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property HelpLink As String
[C#]
public string HelpLink {override get;}
[C++]
public: __property virtual String* get_HelpLink();
[JScript]
public function get HelpLink() : String;

See Also

XsltException Class | XsltException Members | System.Data.XML.XSLT Namespace


XsltException.Message

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Message As String
[C#]
public string Message {override get;}
[C++]
public: __property virtual String* get_Message();
[JScript]
public function get Message() : String;

See Also

XsltException Class | XsltException Members | System.Data.XML.XSLT Namespace


XslTransform Class

[To be supplied.]

Object
XslTransform

[Visual Basic]
Public Class XslTransform
   Implements IDataTransform
[C#]
public class XslTransform : IDataTransform
[C++]
public __gc class XslTransform : public IDataTransform
[JScript]
public class XslTransform implements IDataTransform

Remarks

[To be supplied.]

Requirements

Namespace: System.Data.XML.XSLT

Assembly: System.Data.dll

See Also

XslTransform Members | System.Data.XML.XSLT Namespace


XslTransform Members

Public:

Constructor

XslTransform Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Load | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform | Overloaded. [To be supplied.]
TransformRecord | [To be supplied.]
TransformString | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XslTransform Class | System.Data.XML.XSLT Namespace


XslTransform Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public XslTransform();
[C++]
public: XslTransform();
[JScript]
public function XslTransform();

See Also

XslTransform Class | XslTransform Members | System.Data.XML.XSLT Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XslTransform Methods

The methods of the XslTransform class are listed below. For a complete list of XslTransform class members, see the XslTransform Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Load | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform | Overloaded. [To be supplied.]
TransformRecord | [To be supplied.]
TransformString | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XslTransform Class | System.Data.XML.XSLT Namespace


XslTransform.Load

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub Load(IDataReader, String)
[C#] public void Load(IDataReader, String);
[C++] public: void Load(IDataReader*, String);
[JScript] public function Load(IDataReader, String);

[To be supplied.]

[Visual Basic] Overloads Public Sub Load(IDataNavigator, String)
[C#] public void Load(IDataNavigator, String);
[C++] public: void Load(IDataNavigator*, String);
[JScript] public function Load(IDataNavigator, String);

[To be supplied.]

[Visual Basic] Overloads Public Sub Load(String)
[C#] public void Load(String);
[C++] public: void Load(String*);
[JScript] public function Load(String);

See Also

XslTransform Class | XslTransform Members | System.Data.XML.XSLT Namespace


XslTransform.Load (IDataReader, String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Load( _
   ByVal stylesheet As IDataReader, _
   ByVal stylesheetURI As String _
)
[C#]
public void Load(
   IDataReader stylesheet,
   string stylesheetURI
);
[C++]
public: void Load(
   IDataReader* stylesheet,
   String* stylesheetURI
);
[JScript]
public function Load(
   stylesheet : IDataReader,
   stylesheetURI : String
);

Parameters

stylesheet
[To be supplied.]
stylesheetURI
[To be supplied.]

See Also

XslTransform Class | XslTransform Members | System.Data.XML.XSLT Namespace | XslTransform.Load Overload List


XslTransform.Load (IDataNavigator, String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Load( _
   ByVal stylesheet As IDataNavigator, _
   ByVal stylesheetURI As String _
)
[C#]
public void Load(
   IDataNavigator stylesheet,
   string stylesheetURI
);
[C++]
public: void Load(
   IDataNavigator* stylesheet,
   String* stylesheetURI
);
[JScript]
public function Load(
   stylesheet : IDataNavigator,
   stylesheetURI : String
);

Parameters

stylesheet
[To be supplied.]
stylesheetURI
[To be supplied.]

See Also

XslTransform Class | XslTransform Members | System.Data.XML.XSLT Namespace | XslTransform.Load Overload List


XslTransform.Load (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Load( _
   ByVal url As String _
)
[C#]
public void Load(
   string url
);
[C++]
public: void Load(
   String* url
);
[JScript]
public function Load(
   url : String
);

Parameters

url
[To be supplied.]

See Also

XslTransform Class | XslTransform Members | System.Data.XML.XSLT Namespace | XslTransform.Load Overload List


XslTransform.Transform

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Sub Transform(IDataNavigator, NSParamList, IDataWriter)
[C#] public virtual void Transform(IDataNavigator, NSParamList, IDataWriter);
[C++] public: virtual void Transform(IDataNavigator*, NSParamList, IDataWriter);
[JScript] public function Transform(IDataNavigator, NSParamList, IDataWriter);

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Transform(IDataNavigator, NSParamList) As IDataReader
[C#] public virtual IDataReader Transform(IDataNavigator, NSParamList);
[C++] public: virtual IDataReader* Transform(IDataNavigator*, NSParamList);
[JScript] public function Transform(IDataNavigator, NSParamList) : IDataReader;

See Also

XslTransform Class | XslTransform Members | System.Data.XML.XSLT Namespace


XslTransform.Transform (IDataNavigator, NSParamList, IDataWriter)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Sub Transform( _
   ByVal input As IDataNavigator, _
   ByVal args As NSParamList, _
   ByVal output As IDataWriter _
)
[C#]
public virtual void Transform(
   IDataNavigator input,
   NSParamList args,
   IDataWriter output
);
[C++]
public: virtual void Transform(
   IDataNavigator* input,
   NSParamList* args,
   IDataWriter* output
);
[JScript]
public function Transform(
   input : IDataNavigator,
   args : NSParamList,
   output : IDataWriter
);

Parameters

input
[To be supplied.]
args
[To be supplied.]
output
[To be supplied.]

See Also

XslTransform Class | XslTransform Members | System.Data.XML.XSLT Namespace | XslTransform.Transform Overload List


XslTransform.Transform (IDataNavigator, NSParamList)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Transform( _
   ByVal input As IDataNavigator, _
   ByVal args As NSParamList _
) As IDataReader
[C#]
public virtual IDataReader Transform(
   IDataNavigator input,
   NSParamList args
);
[C++]
public: virtual IDataReader* Transform(
   IDataNavigator* input,
   NSParamList* args
);
[JScript]
public function Transform(
   input : IDataNavigator,
   args : NSParamList
) : IDataReader;

Parameters

input
[To be supplied.]
args
[To be supplied.]

See Also

XslTransform Class | XslTransform Members | System.Data.XML.XSLT Namespace | XslTransform.Transform Overload List


XslTransform.TransformRecord

[To be supplied.]

[Visual Basic]
Public Function TransformRecord( _
   ByVal input As IDataNavigator, _
   ByVal args As NSParamList _
) As IDataReader
[C#]
public IDataReader TransformRecord(
   IDataNavigator input,
   NSParamList args
);
[C++]
public: IDataReader* TransformRecord(
   IDataNavigator* input,
   NSParamList* args
);
[JScript]
public function TransformRecord(
   input : IDataNavigator,
   args : NSParamList
) : IDataReader;

Parameters

input
[To be supplied.]
args
[To be supplied.]

See Also

XslTransform Class | XslTransform Members | System.Data.XML.XSLT Namespace


XslTransform.TransformString

[To be supplied.]

[Visual Basic]
Public Function TransformString( _
   ByVal input As IDataNavigator, _
   ByVal args As NSParamList _
) As String
[C#]
public string TransformString(
   IDataNavigator input,
   NSParamList args
);
[C++]
public: String* TransformString(
   IDataNavigator* input,
   NSParamList* args
);
[JScript]
public function TransformString(
   input : IDataNavigator,
   args : NSParamList
) : String;

Parameters

input
[To be supplied.]
args
[To be supplied.]

See Also

XslTransform Class | XslTransform Members | System.Data.XML.XSLT Namespace


System.Diagnostics

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Diagnostics Namespace

Classes

Class | Description
BooleanSwitch | Provides a simple on/off switch that can be used to control debugging and tracing output.
ConditionalAttribute | [To be supplied.]
Counter | Provides access to system timers.
CounterCreationData | A struct defining the counter type, name and help string for a custom counter.
CounterCreationDataCollection | [To be supplied.]
CounterSampleCalculator | Set of utility functions for interpreting the counter data NOTE: most of this code was taken and ported from counters.c (PerfMon source code)
CountersData | A strongly typed collection containing InstancesData for a category.
Debug | Provides a set of properties and methods for debugging code.
DebuggableAmbivalentAttribute | [To be supplied.]
DebuggableAttribute | [To be supplied.]
Debugger | Enables communication with a debugger.
DebuggerHiddenAttribute | [To be supplied.]
DebuggerStepThroughAttribute | [To be supplied.]
DefaultTraceListener | Provides the default output methods and behavior for tracing.
EventLog | Provides interaction with Windows 2000 event logs.
EventLog.EntriesEnumerator | Holds an EventLog.EventLogEntryCollection that consists of the entries in an event log.
EventLog.EventLogEntryCollection | [To be supplied.]
EventLogEntry | EventLogEntry encapsulates a single record in the NT event log.
EventLogEvent | Provides data for the System.Diagnostics.EventLog.EntryWritten event.
EventLogInstaller | This class acts as an installer for the EventLog component. Essentially, it calls EventLog.CreateEventSource.
EventLogNames | [To be supplied.]
EventLogTraceListener | This class provides a simple listener for directing trace output to a text writer or stream, for example Console.Out or FileStream.
InstanceData | A holder of instance data.
InstancesData | A strongly typed collection containing InstanceData for a counter.
PerformanceCounter | Performance Counter component. This class provides support for NT Performance counters. It handles both the existing counters (accesible by Perf Registry Interface) and user defined (extensible) counters. This class is a part of a larger framework, that includes the perf dll object and perf service.
PerformanceCounterCategory | A Performance counter category object.
PerformanceCounterInstaller | [To be supplied.]
PerformanceCounterManager | [To be supplied.]
Process | Provides access to local and remote processes. Enables you to start and stop system processes.
ProcessModule | A process module component represents a DLL or EXE loaded into a particular process. Using this component, you can determine information about the module.
ProcessStartInfo | A set of values used to specify a process to start. This is used in conjunction with the Process component.
ProcessThread | Represents a thread running in a process on a machine. This can be use to obtain information about the thread, such as it's performance characteristics. This is returned from the ProcessThread property.
SerializableRegistryKey | [To be supplied.]
StackFrame | [To be supplied.]
StackTrace | [To be supplied.]
Switch | Provides an abstract (in Visual Basic MustInherit) base class to create new debugging and tracing switches.
TextWriterTraceListener | Directs tracing or debugging output to a TextWriter or to a Stream, such as Console.Out or FileStream.
Trace | Provides a set of properties and methods to trace the execution of your code.
TraceListener | Provides the abstract (MustInherit) base class for the listeners who monitor trace and debug output.
TraceListeners | Provides a thread-safe list of TraceListeners. A thread-safe list is synchronized.
TraceSwitch | Provides a multi-level switch to enable or disable tracing and debug output for a compiled application or framework.

Interfaces

Interface | Description
ICollectData | [To be supplied.]

Structures

Structure | Description
CounterSample | A struct holding the raw data for a performance counter.

Delegates

Delegate | Description
EventLogEventHandler | [To be supplied.]

Enumerations

Enumeration | Description
EventLogEntryType | Specifies the event type of the event log entry.
PerformanceCounterType | Enum of friendly names to counter types (maps directory to the native types)
ProcessPriorityClass | A category of priority for a process. Threads within a process run at a priority which is relative to the process priority class.
ProcessWindowStyle | A set of values indicating how the window should appear when starting a process.
ThreadPriorityLevel | Specifies the priority level of a thread. The priority level is not an absolute level, but instead contributes to the actual thread priority by considering the priority class of the process.
ThreadState | Specifies the execution state of a thread.
ThreadWaitReason | Specifies the reason a thread is waiting.
TraceLevel | Specifies what messages to output for debugging and tracing.


BooleanSwitch Class

Provides a simple on/off switch that can be used to control debugging and tracing output.

Object
Switch
BooleanSwitch

[Visual Basic]
Public Class BooleanSwitch
   Inherits Switch
[C#]
public class BooleanSwitch : Switch
[C++]
public __gc class BooleanSwitch : public Switch
[JScript]
public class BooleanSwitch extends Switch

Remarks

When the System.Diagnostics.BooleanSwitch constructor cannot find initial switch settings in the registry or in environmental variables, the new switch is set to disabled (false) by default. To enable a disabled switch, call the SetSwitchSetting method with a value other than zero ("0").

To find out if a switch is enabled or disabled, access the Enabled field.

For more information, see <DebugTopicTBD>.

Requirements

Namespace: System.Diagnostics

Assembly: System.dll

Example [Visual Basic]

The following example creates a BooleanSwitch which controls the debug output of MyMethod.

[Visual Basic]

Dim traceParams As BooleanSwitch
Assign traceParams As BooleanSwitch("traceParams","tracing of function params")
...
Public Function MyMethod(a As Integer, b As String) As String
   If traceParams.Enabled Then
      Debug.WriteLine "MyMethod( " & a & " , " & b & " ) called"
   End If
   ...
End Function

See Also

BooleanSwitch Members | System.Diagnostics Namespace | Switch | TraceSwitch | Debug | Trace


BooleanSwitch Members

Public:

Constructor

BooleanSwitch Constructor Initializes a new instance of the BooleanSwitch class.

Properties

Description (inherited from Switch) | Gets a description of the switch.
DisplayName (inherited from Switch) | Gets a name used to identify the switch. This name can be displayed on a user interface.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Enabled Specifies whether the switch is enabled (true) or disabled (false).

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetSwitchSetting | Sets whether the switch is enabled or disabled.

See Also

BooleanSwitch Class | System.Diagnostics Namespace


BooleanSwitch Constructor

Initializes a new instance of the BooleanSwitch class.

[Visual Basic]
Public Sub New( _
   ByVal displayName As String, _
   ByVal description As String _
)
[C#]
public BooleanSwitch(
   string displayName,
   string description
);
[C++]
public: BooleanSwitch(
   String* displayName,
   String* description
);
[JScript]
public function BooleanSwitch(
   displayName : String,
   description : String
);

Parameters

displayName
A name to display on a user interface.
description
A description of the switch.

Remarks

When a BooleanSwitch is instantiated, the displayName is used to find initial switch settings in the registry or in environmental variables. If the constructor cannot find initial settings, the Enabled field is set to disabled (false). To enable a diabled switch, call the SetSwitchSetting method with a value other than zero ("0").

See Also

BooleanSwitch Class | BooleanSwitch Members | System.Diagnostics Namespace | BooleanSwitch | Switch | Debug | Trace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

BooleanSwitch Methods

The methods of the BooleanSwitch class are listed below. For a complete list of BooleanSwitch class members, see the BooleanSwitch Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetSwitchSetting | Sets whether the switch is enabled or disabled.

See Also

BooleanSwitch Class | System.Diagnostics Namespace


BooleanSwitch.SetSwitchSetting

Sets whether the switch is enabled or disabled.

[Visual Basic]
Overrides Protected Sub SetSwitchSetting( _
   ByVal value As Integer _
)
[C#]
protected override void SetSwitchSetting(
   int value
);
[C++]
protected: override void SetSwitchSetting(
   int value
);
[JScript]
protected override function SetSwitchSetting(
   value : int
);

Parameters

value
Zero ("0") for disabled; any other number for enabled.

Remarks

To enable a disabled instance of a BooleanSwitch, call this method with a value other than zero ("0"). To disable an enabled switch, call SetSwitchSetting with zero ("0").

Assess the Enabled field to see whether a switch is enabled or disabled.

See Also

BooleanSwitch Class | BooleanSwitch Members | System.Diagnostics Namespace | BooleanSwitch | Switch | Debug | Trace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

BooleanSwitch Fields

The fields of the BooleanSwitch class are listed below. For a complete list of BooleanSwitch class members, see the BooleanSwitch Members topic.

Public:

Enabled Specifies whether the switch is enabled (true) or disabled (false).

See Also

BooleanSwitch Class | System.Diagnostics Namespace


BooleanSwitch.Enabled

Specifies whether the switch is enabled (true) or disabled (false).

[Visual Basic]
Public Enabled As Boolean
[C#]
public bool Enabled;
[C++]
public: bool Enabled;
[JScript]
public var Enabled : Boolean;

Remarks

By default, this field is set to disabled (false).

See Also

BooleanSwitch Class | BooleanSwitch Members | System.Diagnostics Namespace | BooleanSwitch | Switch | Debug | Trace


ConditionalAttribute Class

[To be supplied.]

Object
Attribute
ConditionalAttribute

[Visual Basic]
Public Class ConditionalAttribute
   Inherits Attribute
[C#]
public class ConditionalAttribute : Attribute
[C++]
public __gc class ConditionalAttribute : public Attribute
[JScript]
public class ConditionalAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: mscorlib.dll

See Also

ConditionalAttribute Members | System.Diagnostics Namespace


ConditionalAttribute Members

Public:

Constructor

ConditionalAttribute Constructor [To be supplied.]

Properties

ConditionString [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConditionalAttribute Class | System.Diagnostics Namespace


ConditionalAttribute Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal conditionString As String _
)
[C#]
public ConditionalAttribute(
   string conditionString
);
[C++]
public: ConditionalAttribute(
   String* conditionString
);
[JScript]
public function ConditionalAttribute(
   conditionString : String
);

Parameters

conditionString
[To be supplied.]

See Also

ConditionalAttribute Class | ConditionalAttribute Members | System.Diagnostics Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ConditionalAttribute Properties

The properties of the ConditionalAttribute class are listed below. For a complete list of ConditionalAttribute class members, see the ConditionalAttribute Members topic.

Public:

ConditionString [To be supplied.]

See Also

ConditionalAttribute Class | System.Diagnostics Namespace


ConditionalAttribute.ConditionString

[To be supplied.]

[Visual Basic]
Public ReadOnly Property ConditionString As String
[C#]
public string ConditionString {get;}
[C++]
public: __property String* get_ConditionString();
[JScript]
public function get ConditionString() : String;

See Also

ConditionalAttribute Class | ConditionalAttribute Members | System.Diagnostics Namespace


Counter Class

Provides access to system timers.

Object
Counter

[Visual Basic]
Public Class Counter
[C#]
public class Counter
[C++]
public __gc class Counter
[JScript]
public class Counter

Remarks

To get the number of seconds, divide Value by Frequency.

Use the GetElapsed property to get how long an operation takes to run.

Requirements

Namespace: System.Diagnostics

Assembly: System.dll

See Also

Counter Members | System.Diagnostics Namespace


Counter Members

Public:

Constructor

Counter Constructor [To be supplied.]

Properties

Frequency | Gets the frequency of the system counter in counts per second.
Value | Gets the current system counter value.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetElapsed | Gets the elapsed time in seconds since the last time GetElapsed was called.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Counter Class | System.Diagnostics Namespace


Counter Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public Counter();
[C++]
public: Counter();
[JScript]
public function Counter();

See Also

Counter Class | Counter Members | System.Diagnostics Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Counter Properties

The properties of the Counter class are listed below. For a complete list of Counter class members, see the Counter Members topic.

Public:

Frequency | Gets the frequency of the system counter in counts per second.
Value | Gets the current system counter value.

See Also

Counter Class | System.Diagnostics Namespace


Counter.Frequency

Gets the frequency of the system counter in counts per second.

[Visual Basic]
Public Shared ReadOnly Property Frequency As Long
[C#]
public static long Frequency {get;}
[C++]
public: __property static __int64 get_Frequency();
[JScript]
public static function get Frequency() : long;

Property Value

The frequency of the system counter in counts per second.

See Also

Counter Class | Counter Members | System.Diagnostics Namespace


Counter.Value

Gets the current system counter value.

[Visual Basic]
Public Shared ReadOnly Property Value As Long
[C#]
public static long Value {get;}
[C++]
public: __property static __int64 get_Value();
[JScript]
public static function get Value() : long;

Property Value

The current system counter value.

See Also

Counter Class | Counter Members | System.Diagnostics Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Counter Methods

The methods of the Counter class are listed below. For a complete list of Counter class members, see the Counter Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetElapsed | Gets the elapsed time in seconds since the last time GetElapsed was called.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Counter Class | System.Diagnostics Namespace


Counter.GetElapsed

Gets the elapsed time in seconds since the last time GetElapsed was called.

[Visual Basic]
Public Shared Function GetElapsed() As Single
[C#]
public static float GetElapsed();
[C++]
public: static float GetElapsed();
[JScript]
public static function GetElapsed() : float;

Return Value

The elapsed time in seconds since the last time GetElapsed was called.

Remarks

Use this property to determine the amount of elapsed time for an operation. The first time GetElapsed is called it will return zero (0).

See Also

Counter Class | Counter Members | System.Diagnostics Namespace


CounterCreationData Class

A struct defining the counter type, name and help string for a custom counter.

Object
CounterCreationData

[Visual Basic]
Public Class CounterCreationData
[C#]
public class CounterCreationData
[C++]
public __gc class CounterCreationData
[JScript]
public class CounterCreationData

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

CounterCreationData Members | System.Diagnostics Namespace


CounterCreationData Members

Public:

Constructor

CounterCreationData Constructor Overloaded. [To be supplied.]

Properties

CounterHelp | [To be supplied.]
CounterName | [To be supplied.]
CounterType | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CounterCreationData Class | System.Diagnostics Namespace


CounterCreationData Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public CounterCreationData();
[C++] public: CounterCreationData();
[JScript] public function CounterCreationData();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, String, PerformanceCounterType)
[C#] public CounterCreationData(String, String, PerformanceCounterType);
[C++] public: CounterCreationData(String*, String*, PerformanceCounterType);
[JScript] public function CounterCreationData(String, String, PerformanceCounterType);

See Also

CounterCreationData Class | CounterCreationData Members | System.Diagnostics Namespace


CounterCreationData Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public CounterCreationData();
[C++]
public: CounterCreationData();
[JScript]
public function CounterCreationData();

See Also

CounterCreationData Class | CounterCreationData Members | System.Diagnostics Namespace | CounterCreationData Constructor Overload List


CounterCreationData Constructor (String, String, PerformanceCounterType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal counterName As String, _
   ByVal counterHelp As String, _
   ByVal counterType As PerformanceCounterType _
)
[C#]
public CounterCreationData(
   string counterName,
   string counterHelp,
   PerformanceCounterType counterType
);
[C++]
public: CounterCreationData(
   String* counterName,
   String* counterHelp,
   PerformanceCounterType counterType
);
[JScript]
public function CounterCreationData(
   counterName : String,
   counterHelp : String,
   counterType : PerformanceCounterType
);

Parameters

counterName
[To be supplied.]
counterHelp
[To be supplied.]
counterType
[To be supplied.]

See Also

CounterCreationData Class | CounterCreationData Members | System.Diagnostics Namespace | CounterCreationData Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CounterCreationData Properties

The properties of the CounterCreationData class are listed below. For a complete list of CounterCreationData class members, see the CounterCreationData Members topic.

Public:

CounterHelp | [To be supplied.]
CounterName | [To be supplied.]
CounterType | [To be supplied.]

See Also

CounterCreationData Class | System.Diagnostics Namespace


CounterCreationData.CounterHelp

[To be supplied.]

[Visual Basic]
Public Property CounterHelp As String
[C#]
public string CounterHelp {get; set;}
[C++]
public: __property String* get_CounterHelp();
public: __property void set_CounterHelp(String*);
[JScript]
public function get CounterHelp() : String;
public function set CounterHelp(String);

See Also

CounterCreationData Class | CounterCreationData Members | System.Diagnostics Namespace


CounterCreationData.CounterName

[To be supplied.]

[Visual Basic]
Public Property CounterName As String
[C#]
public string CounterName {get; set;}
[C++]
public: __property String* get_CounterName();
public: __property void set_CounterName(String*);
[JScript]
public function get CounterName() : String;
public function set CounterName(String);

See Also

CounterCreationData Class | CounterCreationData Members | System.Diagnostics Namespace


CounterCreationData.CounterType

[To be supplied.]

[Visual Basic]
Public Property CounterType As PerformanceCounterType
[C#]
public PerformanceCounterType CounterType {get; set;}
[C++]
public: __property PerformanceCounterType get_CounterType();
public: __property void set_CounterType(PerformanceCounterType);
[JScript]
public function get CounterType() : PerformanceCounterType;
public function set CounterType(PerformanceCounterType);

See Also

CounterCreationData Class | CounterCreationData Members | System.Diagnostics Namespace


CounterCreationDataCollection Class

[To be supplied.]

Object
CounterCreationDataCollection

[Visual Basic]
Public Class CounterCreationDataCollection
   Implements ICollection, IEnumerable
[C#]
public class CounterCreationDataCollection : ICollection,
   IEnumerable
[C++]
public __gc class CounterCreationDataCollection : public
   ICollection, IEnumerable
[JScript]
public class CounterCreationDataCollection implements ICollection,
   IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

CounterCreationDataCollection Members | System.Diagnostics Namespace


CounterCreationDataCollection Members

Public:

Constructor

CounterCreationDataCollection Constructor [To be supplied.]

Properties

All | [To be supplied.]
Count | [To be supplied.]
Item | [To be supplied.] In C#, this member is the indexer for the CounterCreationDataCollection class.

Methods

Add | [To be supplied.]
AddRange | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Remove | [To be supplied.]
RemoveRange | [To be supplied.]
ShouldPersistAll | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CounterCreationDataCollection Class | System.Diagnostics Namespace


CounterCreationDataCollection Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CounterCreationDataCollection();
[C++]
public: CounterCreationDataCollection();
[JScript]
public function CounterCreationDataCollection();

See Also

CounterCreationDataCollection Class | CounterCreationDataCollection Members | System.Diagnostics Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CounterCreationDataCollection Properties

The properties of the CounterCreationDataCollection class are listed below. For a complete list of CounterCreationDataCollection class members, see the CounterCreationDataCollection Members topic.

Public:

All | [To be supplied.]
Count | [To be supplied.]
Item | [To be supplied.] In C#, this member is the indexer for the CounterCreationDataCollection class.

See Also

CounterCreationDataCollection Class | System.Diagnostics Namespace


CounterCreationDataCollection.All

[To be supplied.]

[Visual Basic]
Public Property All As CounterCreationData ()
[C#]
public CounterCreationData[] All {get; set;}
[C++]
public: __property CounterCreationData* get_All();
public: __property void set_All(CounterCreationData*[]);
[JScript]
public function get All() : CounterCreationData[];
public function set All(CounterCreationData[]);

See Also

CounterCreationDataCollection Class | CounterCreationDataCollection Members | System.Diagnostics Namespace


CounterCreationDataCollection.Count

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

See Also

CounterCreationDataCollection Class | CounterCreationDataCollection Members | System.Diagnostics Namespace


CounterCreationDataCollection.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the CounterCreationDataCollection class.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As CounterCreationData
[C#]
public CounterCreationData this[
   int index
] {get; set;}
[C++]
public: __property CounterCreationData* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   CounterCreationData*
);
[JScript]
returnValue = CounterCreationDataCollectionObject.Item(index);
CounterCreationDataCollectionObject.Item(index) = returnValue;
-or-
returnValue = CounterCreationDataCollectionObject(index);
CounterCreationDataCollectionObject(index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
[To be supplied.]

Parameters [Visual Basic, C#, C++]

index
[To be supplied.]

See Also

CounterCreationDataCollection Class | CounterCreationDataCollection Members | System.Diagnostics Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CounterCreationDataCollection Methods

The methods of the CounterCreationDataCollection class are listed below. For a complete list of CounterCreationDataCollection class members, see the CounterCreationDataCollection Members topic.

Public:

Add | [To be supplied.]
AddRange | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Remove | [To be supplied.]
RemoveRange | [To be supplied.]
ShouldPersistAll | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CounterCreationDataCollection Class | System.Diagnostics Namespace


CounterCreationDataCollection.Add

[To be supplied.]

[Visual Basic]
Overridable Public Sub Add( _
   ByVal data As CounterCreationData _
)
[C#]
public virtual void Add(
   CounterCreationData data
);
[C++]
public: virtual void Add(
   CounterCreationData* data
);
[JScript]
public function Add(
   data : CounterCreationData
);

Parameters

data
[To be supplied.]

See Also

CounterCreationDataCollection Class | CounterCreationDataCollection Members | System.Diagnostics Namespace


CounterCreationDataCollection.AddRange

[To be supplied.]

[Visual Basic]
Overridable Public Sub AddRange( _
   ByVal range As CounterCreationDataCollection _
)
[C#]
public virtual void AddRange(
   CounterCreationDataCollection range
);
[C++]
public: virtual void AddRange(
   CounterCreationDataCollection* range
);
[JScript]
public function AddRange(
   range : CounterCreationDataCollection
);

Parameters

range
[To be supplied.]

See Also

CounterCreationDataCollection Class | CounterCreationDataCollection Members | System.Diagnostics Namespace


CounterCreationDataCollection.GetEnumerator

[To be supplied.]

[Visual Basic]
Public Function GetEnumerator() As IEnumerator
[C#]
public IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

See Also

CounterCreationDataCollection Class | CounterCreationDataCollection Members | System.Diagnostics Namespace


CounterCreationDataCollection.Remove

[To be supplied.]

[Visual Basic]
Overridable Public Sub Remove( _
   ByVal index As Integer _
)
[C#]
public virtual void Remove(
   int index
);
[C++]
public: virtual void Remove(
   int index
);
[JScript]
public function Remove(
   index : int
);

Parameters

index
[To be supplied.]

See Also

CounterCreationDataCollection Class | CounterCreationDataCollection Members | System.Diagnostics Namespace


CounterCreationDataCollection.RemoveRange

[To be supplied.]

[Visual Basic]
Overridable Public Sub RemoveRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
[C#]
public virtual void RemoveRange(
   int index,
   int count
);
[C++]
public: virtual void RemoveRange(
   int index,
   int count
);
[JScript]
public function RemoveRange(
   index : int,
   count : int
);

Parameters

index
[To be supplied.]
count
[To be supplied.]

See Also

CounterCreationDataCollection Class | CounterCreationDataCollection Members | System.Diagnostics Namespace


CounterCreationDataCollection.ShouldPersistAll

[To be supplied.]

[Visual Basic]
Public Function ShouldPersistAll() As Boolean
[C#]
public bool ShouldPersistAll();
[C++]
public: bool ShouldPersistAll();
[JScript]
public function ShouldPersistAll() : Boolean;

See Also

CounterCreationDataCollection Class | CounterCreationDataCollection Members | System.Diagnostics Namespace


CounterSample Structure

A struct holding the raw data for a performance counter.

Object
ValueType
CounterSample

[Visual Basic]
Public Structure CounterSample
[C#]
public struct CounterSample
[C++]
public __value struct CounterSample

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

CounterSample Members | System.Diagnostics Namespace


CounterSample Members

Public:

Constructor

CounterSample Constructor [To be supplied.]

Methods

Calculate | Overloaded. [To be supplied.]
Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Fields

BaseValue | Optional base raw value for the counter (only used if multiple counter based).
CounterFrequency | Raw counter frequency
CounterType | Counter type
Empty | [To be supplied.]
RawValue | Raw value of the counter.
SystemFrequency | Raw system frequency
TimeStamp | Raw timestamp
TimeStamp100nSec | Raw high fidelity timestamp

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CounterSample Structure | System.Diagnostics Namespace


CounterSample Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal rawValue As Long, _
   ByVal baseValue As Long, _
   ByVal counterFrequency As Long, _
   ByVal systemFrequency As Long, _
   ByVal timeStamp As Long, _
   ByVal timeStamp100nSec As Long, _
   ByVal counterType As PerformanceCounterType _
)
[C#]
public CounterSample(
   long rawValue,
   long baseValue,
   long counterFrequency,
   long systemFrequency,
   long timeStamp,
   long timeStamp100nSec,
   PerformanceCounterType counterType
);
[C++]
public: CounterSample(
   __int64 rawValue,
   __int64 baseValue,
   __int64 counterFrequency,
   __int64 systemFrequency,
   __int64 timeStamp,
   __int64 timeStamp100nSec,
   PerformanceCounterType counterType
);
[JScript]
public function CounterSample(
   rawValue : long,
   baseValue : long,
   counterFrequency : long,
   systemFrequency : long,
   timeStamp : long,
   timeStamp100nSec : long,
   counterType : PerformanceCounterType
);

Parameters

rawValue
[To be supplied.]
baseValue
[To be supplied.]
counterFrequency
[To be supplied.]
systemFrequency
[To be supplied.]
timeStamp
[To be supplied.]
timeStamp100nSec
[To be supplied.]
counterType
[To be supplied.]

See Also

CounterSample Structure | CounterSample Members | System.Diagnostics Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CounterSample Methods

The methods of the CounterSample structure are listed below. For a complete list of CounterSample structure members, see the CounterSample Members topic.

Public:

Calculate | Overloaded. [To be supplied.]
Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CounterSample Structure | System.Diagnostics Namespace


CounterSample.Calculate

[To be supplied.]

Overload List

Static functions to calculate the performance value off the sample

[Visual Basic] Overloads Public Shared Function Calculate(CounterSample) As Single
[C#] public static float Calculate(CounterSample);
[C++] public: static float Calculate(CounterSample);
[JScript] public static function Calculate(CounterSample) : float;

Static functions to calculate the performance value off the samples

[Visual Basic] Overloads Public Shared Function Calculate(CounterSample, CounterSample) As Single
[C#] public static float Calculate(CounterSample, CounterSample);
[C++] public: static float Calculate(CounterSample, CounterSample);
[JScript] public static function Calculate(CounterSample, CounterSample) : float;

See Also

CounterSample Structure | CounterSample Members | System.Diagnostics Namespace


CounterSample.Calculate (CounterSample)

Static functions to calculate the performance value off the sample

[Visual Basic]
Overloads Public Shared Function Calculate( _
   ByVal counterSample As CounterSample _
) As Single
[C#]
public static float Calculate(
   CounterSample counterSample
);
[C++]
public: static float Calculate(
   CounterSample counterSample
);
[JScript]
public static function Calculate(
   counterSample : CounterSample
) : float;

Parameters

counterSample
Countersample to calculate from.

Return Value

Calculated performance value.

See Also

CounterSample Structure | CounterSample Members | System.Diagnostics Namespace | CounterSample.Calculate Overload List


CounterSample.Calculate (CounterSample, CounterSample)

Static functions to calculate the performance value off the samples

[Visual Basic]
Overloads Public Shared Function Calculate( _
   ByVal counterSample As CounterSample, _
   ByVal nextCounterSample As CounterSample _
) As Single
[C#]
public static float Calculate(
   CounterSample counterSample,
   CounterSample nextCounterSample
);
[C++]
public: static float Calculate(
   CounterSample counterSample,
   CounterSample nextCounterSample
);
[JScript]
public static function Calculate(
   counterSample : CounterSample,
   nextCounterSample : CounterSample
) : float;

Parameters

counterSample
Countersample to calculate from.
nextCounterSample
Countersample with time greater than the 'counterSample'

Return Value

Calculated performance value.

See Also

CounterSample Structure | CounterSample Members | System.Diagnostics Namespace | CounterSample.Calculate Overload List


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CounterSample Fields

The fields of the CounterSample structure are listed below. For a complete list of CounterSample structure members, see the CounterSample Members topic.

Public:

BaseValue | Optional base raw value for the counter (only used if multiple counter based).
CounterFrequency | Raw counter frequency
CounterType | Counter type
Empty | [To be supplied.]
RawValue | Raw value of the counter.
SystemFrequency | Raw system frequency
TimeStamp | Raw timestamp
TimeStamp100nSec | Raw high fidelity timestamp

See Also

CounterSample Structure | System.Diagnostics Namespace


CounterSample.BaseValue

Optional base raw value for the counter (only used if multiple counter based).

[Visual Basic]
Public BaseValue As Long
[C#]
public long BaseValue;
[C++]
public: __int64 BaseValue;
[JScript]
public var BaseValue : long;

See Also

CounterSample Structure | CounterSample Members | System.Diagnostics Namespace


CounterSample.CounterFrequency

Raw counter frequency

[Visual Basic]
Public CounterFrequency As Long
[C#]
public long CounterFrequency;
[C++]
public: __int64 CounterFrequency;
[JScript]
public var CounterFrequency : long;

See Also

CounterSample Structure | CounterSample Members | System.Diagnostics Namespace


CounterSample.CounterType

Counter type

[Visual Basic]
Public CounterType As PerformanceCounterType
[C#]
public PerformanceCounterType CounterType;
[C++]
public: PerformanceCounterType CounterType;
[JScript]
public var CounterType : PerformanceCounterType;

See Also

CounterSample Structure | CounterSample Members | System.Diagnostics Namespace


CounterSample.Empty

[To be supplied.]

[Visual Basic]
Public Shared Empty As CounterSample
[C#]
public static CounterSample Empty;
[C++]
public: static CounterSample Empty;
[JScript]
public static var Empty : CounterSample;

See Also

CounterSample Structure | CounterSample Members | System.Diagnostics Namespace


CounterSample.RawValue

Raw value of the counter.

[Visual Basic]
Public RawValue As Long
[C#]
public long RawValue;
[C++]
public: __int64 RawValue;
[JScript]
public var RawValue : long;

See Also

CounterSample Structure | CounterSample Members | System.Diagnostics Namespace


CounterSample.SystemFrequency

Raw system frequency

[Visual Basic]
Public SystemFrequency As Long
[C#]
public long SystemFrequency;
[C++]
public: __int64 SystemFrequency;
[JScript]
public var SystemFrequency : long;

See Also

CounterSample Structure | CounterSample Members | System.Diagnostics Namespace


CounterSample.TimeStamp

Raw timestamp

[Visual Basic]
Public TimeStamp As Long
[C#]
public long TimeStamp;
[C++]
public: __int64 TimeStamp;
[JScript]
public var TimeStamp : long;

See Also

CounterSample Structure | CounterSample Members | System.Diagnostics Namespace


CounterSample.TimeStamp100nSec

Raw high fidelity timestamp

[Visual Basic]
Public TimeStamp100nSec As Long
[C#]
public long TimeStamp100nSec;
[C++]
public: __int64 TimeStamp100nSec;
[JScript]
public var TimeStamp100nSec : long;

See Also

CounterSample Structure | CounterSample Members | System.Diagnostics Namespace


CounterSampleCalculator Class

Set of utility functions for interpreting the counter data NOTE: most of this code was taken and ported from counters.c (PerfMon source code)

Object
CounterSampleCalculator

[Visual Basic]
Public Class CounterSampleCalculator
[C#]
public class CounterSampleCalculator
[C++]
public __gc class CounterSampleCalculator
[JScript]
public class CounterSampleCalculator

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

CounterSampleCalculator Members | System.Diagnostics Namespace


CounterSampleCalculator Members

Public:

Constructor

CounterSampleCalculator Constructor [To be supplied.]

Methods

ComputeCounterValue | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CounterSampleCalculator Class | System.Diagnostics Namespace


CounterSampleCalculator Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CounterSampleCalculator();
[C++]
public: CounterSampleCalculator();
[JScript]
public function CounterSampleCalculator();

See Also

CounterSampleCalculator Class | CounterSampleCalculator Members | System.Diagnostics Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CounterSampleCalculator Methods

The methods of the CounterSampleCalculator class are listed below. For a complete list of CounterSampleCalculator class members, see the CounterSampleCalculator Members topic.

Public:

ComputeCounterValue | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CounterSampleCalculator Class | System.Diagnostics Namespace


CounterSampleCalculator.ComputeCounterValue

[To be supplied.]

Overload List

Computes the calculated value given a raw counter sample.

[Visual Basic] Overloads Public Shared Function ComputeCounterValue(CounterSample) As Single
[C#] public static float ComputeCounterValue(CounterSample);
[C++] public: static float ComputeCounterValue(CounterSample);
[JScript] public static function ComputeCounterValue(CounterSample) : float;

Computes the calculated value given a raw counter sample.

[Visual Basic] Overloads Public Shared Function ComputeCounterValue(CounterSample, CounterSample) As Single
[C#] public static float ComputeCounterValue(CounterSample, CounterSample);
[C++] public: static float ComputeCounterValue(CounterSample, CounterSample);
[JScript] public static function ComputeCounterValue(CounterSample, CounterSample) : float;

See Also

CounterSampleCalculator Class | CounterSampleCalculator Members | System.Diagnostics Namespace


CounterSampleCalculator.ComputeCounterValue (CounterSample)

Computes the calculated value given a raw counter sample.

[Visual Basic]
Overloads Public Shared Function ComputeCounterValue( _
   ByVal newSample As CounterSample _
) As Single
[C#]
public static float ComputeCounterValue(
   CounterSample newSample
);
[C++]
public: static float ComputeCounterValue(
   CounterSample newSample
);
[JScript]
public static function ComputeCounterValue(
   newSample : CounterSample
) : float;

Parameters

newSample
Curent CounterSample to use.

Return Value

Floating point representation of outcome

See Also

CounterSampleCalculator Class | CounterSampleCalculator Members | System.Diagnostics Namespace | CounterSampleCalculator.ComputeCounterValue Overload List


CounterSampleCalculator.ComputeCounterValue (CounterSample, CounterSample)

Computes the calculated value given a raw counter sample.

[Visual Basic]
Overloads Public Shared Function ComputeCounterValue( _
   ByVal oldSample As CounterSample, _
   ByVal newSample As CounterSample _
) As Single
[C#]
public static float ComputeCounterValue(
   CounterSample oldSample,
   CounterSample newSample
);
[C++]
public: static float ComputeCounterValue(
   CounterSample oldSample,
   CounterSample newSample
);
[JScript]
public static function ComputeCounterValue(
   oldSample : CounterSample,
   newSample : CounterSample
) : float;

Parameters

oldSample
Previous CounterSample to use.
newSample
Curent CounterSample to use.

Return Value

Floating point representation of outcome

See Also

CounterSampleCalculator Class | CounterSampleCalculator Members | System.Diagnostics Namespace | CounterSampleCalculator.ComputeCounterValue Overload List


CountersData Class

A strongly typed collection containing InstancesData for a category.

Object
Hashtable
CountersData

[Visual Basic]
Public Class CountersData
   Inherits Hashtable
[C#]
public class CountersData : Hashtable
[C++]
public __gc class CountersData : public Hashtable
[JScript]
public class CountersData extends Hashtable

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

CountersData Members | System.Diagnostics Namespace


CountersData Members

Public:

Constructor

CountersData Constructor [To be supplied.]

Properties

Count (inherited from Hashtable) | Gets the number of key-and-value pairs in the Hashtable.
IsReadOnly (inherited from Hashtable) | Gets a value indicating whether the Hashtable is read-only.
IsSynchronized (inherited from Hashtable) | Gets a value indicating whether access to the Hashtable is synchronized (thread-safe).
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the CountersData class.
Keys (inherited from Hashtable) | Gets an ICollection containing the keys in the Hashtable.
SyncRoot (inherited from Hashtable) | Gets an object that can be used to synchronize access to the Hashtable.
Values (inherited from Hashtable) | Gets an ICollection containing the values in the Hashtable.

Methods

Add (inherited from Hashtable) | Adds an entry with the specified key and value into the Hashtable.
Clear (inherited from Hashtable) | Removes all entries from the Hashtable.
Clone (inherited from Hashtable) | Creates a shallow copy of the Hashtable.
Contains (inherited from Hashtable) | Determines if the Hashtable contains a specific key.
ContainsKey (inherited from Hashtable) | Determines if the Hashtable contains a specific key.
ContainsValue (inherited from Hashtable) | Determines if the Hashtable contains a specific value.
CopyTo (inherited from Hashtable) | Copies the Hashtable values into a one-dimensional Array instance at the specified index.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from Hashtable) | Returns an enumerator which can be used to iterate through the Hashtable.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Hashtable) | Implements the ISerializable interface and returns the data needed to serialize the Hashtable.
GetType (inherited from Object) | Gets the Type of the Object.
OnDeserialization (inherited from Hashtable) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from Hashtable) | Removes the entry with the specified key from the Hashtable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetHash (inherited from Hashtable) | Returns the hash code for the specified key.
KeyEquals (inherited from Hashtable) | Compares a specific Object with a specific key in the Hashtable.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

comparer (inherited from Hashtable) | Represents the comparer to use for the Hashtable.
hcp (inherited from Hashtable) | Represents the object that can dispense hash codes.

See Also

CountersData Class | System.Diagnostics Namespace


CountersData Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CountersData();
[C++]
public: CountersData();
[JScript]
public function CountersData();

See Also

CountersData Class | CountersData Members | System.Diagnostics Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CountersData Properties

The properties of the CountersData class are listed below. For a complete list of CountersData class members, see the CountersData Members topic.

Public:

Count (inherited from Hashtable) | Gets the number of key-and-value pairs in the Hashtable.
IsReadOnly (inherited from Hashtable) | Gets a value indicating whether the Hashtable is read-only.
IsSynchronized (inherited from Hashtable) | Gets a value indicating whether access to the Hashtable is synchronized (thread-safe).
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the CountersData class.
Keys (inherited from Hashtable) | Gets an ICollection containing the keys in the Hashtable.
SyncRoot (inherited from Hashtable) | Gets an object that can be used to synchronize access to the Hashtable.
Values (inherited from Hashtable) | Gets an ICollection containing the values in the Hashtable.

See Also

CountersData Class | System.Diagnostics Namespace


CountersData.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the CountersData class.

Overload List

[To be supplied.]

[Visual Basic] Overloads Property Item As Object
[C#] object Item {override set;}
[C++] public: __property virtual void set_Item(Object* key, Object*);
[JScript] CountersData.Item ()

[To be supplied.]

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(String) As InstancesData
[C#] public InstancesData this[String] {virtual get;}
[C++] public: __property virtual InstancesData* get_Item(String*);
[JScript] CountersData.Item (String)

See Also

CountersData Class | CountersData Members | System.Diagnostics Namespace


CountersData.Item ()

[To be supplied.]

[C#] In C#, this member is the indexer for the CountersData class.

[Visual Basic]
Overloads Property Item As Object
[C#]
object Item {override set;}
[C++]
public: __property virtual void set_Item(
   Object* key,
   Object*
);
[JScript]
public function set Item(Object);
-or-
public function set Item(Object);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

See Also

CountersData Class | CountersData Members | System.Diagnostics Namespace | CountersData.Item Overload List


CountersData.Item (String)

[To be supplied.]

[C#] In C#, this member is the indexer for the CountersData class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal counterName As String _
) As InstancesData
[C#]
public InstancesData this[
   string counterName
] {virtual get;}
[C++]
public: __property virtual InstancesData* get_Item(
   String* counterName
);
[JScript]
returnValue = CountersDataObject.Item(counterName);
-or-
returnValue = CountersDataObject(counterName);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

counterName
[To be supplied.]

Parameters [Visual Basic, C#, C++]

counterName
[To be supplied.]

See Also

CountersData Class | CountersData Members | System.Diagnostics Namespace | CountersData.Item Overload List


Debug Class

Provides a set of properties and methods for debugging code.

Object
Debug

[Visual Basic]
Public Class Debug
[C#]
public class Debug
[C++]
public __gc class Debug
[JScript]
public class Debug

Remarks

By using methods in the Debug class to print debugging information and check your logic with assertions, you can make your code more robust without impacting your shipping product's performance and code size. By default, Debug is off in retail builds.

The BooleanSwitch and TraceSwitch classes provide a means to control the tracing output dynamically. The values of these switches can be modified outside the compiled application.

You can customize the tracing output's target by adding TraceListener instances to or removing instances from the Listeners collection. By default, trace output is emitted using the DefaultTraceListener class.

The Debug class provides properties to get or set the level of Indent, the IndentSize and whether to AutoFlush after each write.

This class also provides methods to display an Assert dialog box, and to set an assertion that will always Fail. This class provides write methods in the following variations: Write, WriteLine, WriteIf and WriteLineIf.

Use Trace to instrument retail builds.

For more information, see <DebugTopicTBD>.

Requirements

Namespace: System.Diagnostics

Assembly: System.dll

Example [C#]

The following example creates three switches to control the debugging output for the Customer class.

[C#]

Class Customer{
   // trace each method flow
   static BooleanSwitch debugMethods("DebugMethods","Debug logic flow");
   // trace method parameters
   static BooleanSwitch debugParams("DebugParams","Debug parameter values");
   // trace return values
   static BooleanSwitch debugResults("DebugResults","Debug calculations");

   string Name(string last, string first){
      Debug.WriteLineIf(debugMethods.Enabled, "Name called");
      Debug.WriteLineIf(debugParams.Enabled, "Params: " + last + ", " + first);

      string fullName = first + " " + last;

      Debug.WriteLineIf(debugMethods.Enabled, "Name terminates");
      Debug.WriteLineIf(debugResults.Enabled, "Result: " + fullName);
      return fullName;
   }
}

If the debugMethods and debugResults are set to true, and debugParams is set to false, the output for a call to Name("Smith", "John") would be:

Name called

Name terminates

Result: John Smith

See Also

Debug Members | System.Diagnostics Namespace | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute


Debug Members

Public:

Constructor

Debug Constructor [To be supplied.]

Properties

AutoFlush | Gets or sets whether Flush should be called on the Listeners after every write.
Indent | Gets or sets the indent level.
IndentSize | Gets or sets the number of spaces in an indent.
Listeners | Gets the collection of listeners that is monitoring the debug output.

Methods

Assert | Overloaded. Checks for a condition and displays a message if the condition is false.
Close | Clears the output buffer and then closes the Listeners so that they no longer receive debugging output.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Fail | Overloaded. Emits or displays a message for an assertion that always fails.
Flush | Clears the output buffer and causes any buffered data to be written to the Listeners.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Overloaded. Writes information about the trace to the trace listeners in the Listeners collection.
WriteIf | Overloaded. Writes a message to the trace listeners in the Listeners collection if a condition is true.
WriteLine | Overloaded. Writes information about the trace followed by a line terminator to the trace listeners in the Listeners collection.
WriteLineIf | Overloaded. Writes information about the trace followed by a line terminator to the trace listeners in the Listeners collection if a condition is true.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Debug Class | System.Diagnostics Namespace


Debug Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public Debug();
[C++]
public: Debug();
[JScript]
public function Debug();

See Also

Debug Class | Debug Members | System.Diagnostics Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Debug Properties

The properties of the Debug class are listed below. For a complete list of Debug class members, see the Debug Members topic.

Public:

AutoFlush | Gets or sets whether Flush should be called on the Listeners after every write.
Indent | Gets or sets the indent level.
IndentSize | Gets or sets the number of spaces in an indent.
Listeners | Gets the collection of listeners that is monitoring the debug output.

See Also

Debug Class | System.Diagnostics Namespace


Debug.AutoFlush

Gets or sets whether Flush should be called on the Listeners after every write.

[Visual Basic]
Public Shared Property AutoFlush As Boolean
[C#]
public static bool AutoFlush {get; set;}
[C++]
public: __property static bool get_AutoFlush();
public: __property static void set_AutoFlush(bool);
[JScript]
public static function get AutoFlush() : Boolean;
public static function set AutoFlush(Boolean);

Property Value

true if Flush is called on the Listeners after every write; otherwise, false.

Remarks

The default is false.

See Also

Debug Class | Debug Members | System.Diagnostics Namespace | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute


Debug.Indent

Gets or sets the indent level.

[Visual Basic]
Public Shared Property Indent As Integer
[C#]
public static int Indent {get; set;}
[C++]
public: __property static int get_Indent();
public: __property static void set_Indent(int);
[JScript]
public static function get Indent() : int;
public static function set Indent(int);

Property Value

The indent level.

Remarks

The default is zero (0). This property is stored on per-thread/per-request basis.

Example [C#]

The following example sets the indent level and emits debugging messages.

[C#]

Debug.WriteLine("List of errors:");
Debug.Indent = Debug.Indent + 1;
Debug.Writeline("Error 1: File not found");
Debug.WriteLine("Error 2: Directory not found");
Debug.Indent = Debug.Indent - 1;
Debug.WriteLine("End of list of errors");

See Also

Debug Class | Debug Members | System.Diagnostics Namespace | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute


Debug.IndentSize

Gets or sets the number of spaces in an indent.

[Visual Basic]
Public Shared Property IndentSize As Integer
[C#]
public static int IndentSize {get; set;}
[C++]
public: __property static int get_IndentSize();
public: __property static void set_IndentSize(int);
[JScript]
public static function get IndentSize() : int;
public static function set IndentSize(int);

Property Value

The number of spaces in an indent.

Remarks

The default is four (4) spaces. The property is stored on per-thread/per-request basis.

See Also

Debug Class | Debug Members | System.Diagnostics Namespace | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute


Debug.Listeners

Gets the collection of listeners that is monitoring the debug output.

[Visual Basic]
Public Shared ReadOnly Property Listeners As TraceListeners
[C#]
public static TraceListeners Listeners {get;}
[C++]
public: __property static TraceListeners* get_Listeners();
[JScript]
public static function get Listeners() : TraceListeners;

Property Value

A TraceListeners that represents a collection of type TraceListener that is monitoring the debug output.

Remarks

The listeners produce the output. By default, the collection contains an instance of the DefaultTraceListener class. If you want to remove the default listener, call the Remove method, and pass it the instance of the DefaultTraceListener. To redirect output to the screen, add an instance of the TextWriterTraceListener that uses the Console.Out stream.

See Also

Debug Class | Debug Members | System.Diagnostics Namespace | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Debug Methods

The methods of the Debug class are listed below. For a complete list of Debug class members, see the Debug Members topic.

Public:

Assert | Overloaded. Checks for a condition and displays a message if the condition is false.
Close | Clears the output buffer and then closes the Listeners so that they no longer receive debugging output.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Fail | Overloaded. Emits or displays a message for an assertion that always fails.
Flush | Clears the output buffer and causes any buffered data to be written to the Listeners.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Overloaded. Writes information about the trace to the trace listeners in the Listeners collection.
WriteIf | Overloaded. Writes a message to the trace listeners in the Listeners collection if a condition is true.
WriteLine | Overloaded. Writes information about the trace followed by a line terminator to the trace listeners in the Listeners collection.
WriteLineIf | Overloaded. Writes information about the trace followed by a line terminator to the trace listeners in the Listeners collection if a condition is true.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Debug Class | System.Diagnostics Namespace


Debug.Assert

Checks for a condition and displays a message if the condition is false.

Overload List

Checks for a condition and displays both the specified messages if the condition is false.

[Visual Basic] Overloads Public Shared Sub Assert(Boolean, String, String)
[C#] public static void Assert(bool, String, String);
[C++] public: static void Assert(bool, String, String);
[JScript] public static function Assert(Boolean, String, String);

Checks for a condition and displays a message if the condition is false.

[Visual Basic] Overloads Public Shared Sub Assert(Boolean, String)
[C#] public static void Assert(bool, String);
[C++] public: static void Assert(bool, String);
[JScript] public static function Assert(Boolean, String);

Checks for a condition and outputs the callstack if the condition is false.

[Visual Basic] Overloads Public Shared Sub Assert(Boolean)
[C#] public static void Assert(bool);
[C++] public: static void Assert(bool);
[JScript] public static function Assert(Boolean);

See Also

Debug Class | Debug Members | System.Diagnostics Namespace


Debug.Assert (Boolean, String, String)

Checks for a condition and displays both the specified messages if the condition is false.

[Visual Basic]
Overloads Public Shared Sub Assert( _
   ByVal condition As Boolean, _
   ByVal message As String, _
   ByVal detailMessage As String _
)
[C#]
public static void Assert(
   bool condition,
   string message,
   string detailMessage
);
[C++]
public: static void Assert(
   bool condition,
   String* message,
   String* detailMessage
);
[JScript]
public static function Assert(
   condition : Boolean,
   message : String,
   detailMessage : String
);

Parameters

condition
A condition which if false causes the messages to be displayed.
message
A message to display.
detailMessage
A detailed message to display.

Remarks

Typically Assert is used to identify logic errors during program development. Assert will evaluate the condition. If the result is false, it sends diagnostic messages to the Listeners.

The default behavior is to display a message box when the application is running in a user interface mode, and to output the message to the default trace output. You can customize this behavior by adding a TraceListener to or removing one from the Listeners collection.

See Also

Debug Class | Debug Members | System.Diagnostics Namespace | Debug.Assert Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute


Debug.Assert (Boolean, String)

Checks for a condition and displays a message if the condition is false.

[Visual Basic]
Overloads Public Shared Sub Assert( _
   ByVal condition As Boolean, _
   ByVal message As String _
)
[C#]
public static void Assert(
   bool condition,
   string message
);
[C++]
public: static void Assert(
   bool condition,
   String* message
);
[JScript]
public static function Assert(
   condition : Boolean,
   message : String
);

Parameters

condition
A condition which if false causes a message to be displayed.
message
A message to display.

Remarks

Typically Assert is used to identify logic errors during program development. Assert will evaluate the condition. If the result is false, it sends diagnostic messages to the Listeners.

The default behavior is to display a message box when the application is running in a user interface mode, and to output the message to the default trace output. You can customize this behavior by adding a TraceListener to or removing one from the Listeners collection.

See Also

Debug Class | Debug Members | System.Diagnostics Namespace | Debug.Assert Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute


Debug.Assert (Boolean)

Checks for a condition and outputs the callstack if the condition is false.

[Visual Basic]
Overloads Public Shared Sub Assert( _
   ByVal condition As Boolean _
)
[C#]
public static void Assert(
   bool condition
);
[C++]
public: static void Assert(
   bool condition
);
[JScript]
public static function Assert(
   condition : Boolean
);

Parameters

condition
A condition which if false causes a message to be displayed.

Remarks

Assert outputs the callstack with file and line number, if it is available, for each line in the callstack.

Typically Assert is used to identify logic errors during program development. Assert will evaluate the condition. If the result is false, it sends diagnostic messages to the Listeners.

The default behavior is to display a message box when the application is running in a user interface mode, and to output the message to the default trace output. You can customize this behavior by adding a TraceListener to or removing one from the Listeners collection.

See Also

Debug Class | Debug Members | System.Diagnostics Namespace | Debug.Assert Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute


Debug.Close

Clears the output buffer and then closes the Listeners so that they no longer receive debugging output.

[Visual Basic]
Public Shared Sub Close()
[C#]
public static void Close();
[C++]
public: static void Close();
[JScript]
public static function Close();

Remarks

Use this method when the output is going to a file such as to the TextWriterTraceListener.

See Also

Debug Class | Debug Members | System.Diagnostics Namespace | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute


Debug.Fail

Emits or displays a message for an assertion that always fails.

Overload List

Emits or displays displays both the specified messages for an assertion that always fails.

[Visual Basic] Overloads Public Shared Sub Fail(String, String)
[C#] public static void Fail(String, String);
[C++] public: static void Fail(String*, String*);
[JScript] public static function Fail(String, String);

Emits or displays a message for an assertion that always fails.

[Visual Basic] Overloads Public Shared Sub Fail(String)
[C#] public static void Fail(String);
[C++] public: static void Fail(String*);
[JScript] public static function Fail(String);

See Also

Debug Class | Debug Members | System.Diagnostics Namespace


Debug.Fail (String, String)

Emits or displays displays both the specified messages for an assertion that always fails.

[Visual Basic]
Overloads Public Shared Sub Fail( _
   ByVal message As String, _
   ByVal detailMessage As String _
)
[C#]
public static void Fail(
   string message,
   string detailMessage
);
[C++]
public: static void Fail(
   String* message,
   String* detailMessage
);
[JScript]
public static function Fail(
   message : String,
   detailMessage : String
);

Parameters

message
A message to emit or display.
detailMessage
A detailed message to emit or display.

Remarks

The default behavior is to output the message and detailedMessage to a message box when the application is running in a user interface mode, and to the TraceListener instances in the Listeners collection. You can customize this behavior by adding a TraceListener to or removing one from the Listeners collection.

See Also

Debug Class | Debug Members | System.Diagnostics Namespace | Debug.Fail Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute


Debug.Fail (String)

Emits or displays a message for an assertion that always fails.

[Visual Basic]
Overloads Public Shared Sub Fail( _
   ByVal message As String _
)
[C#]
public static void Fail(
   string message
);
[C++]
public: static void Fail(
   String* message
);
[JScript]
public static function Fail(
   message : String
);

Parameters

message
A message to emit or display.

Remarks

The default behavior is to output the message to a message box when the application is running in a user interface mode, and to the TraceListener instances in the Listeners collection. You can customize this behavior by adding a TraceListener to or removing one from the Listeners collection.

See Also

Debug Class | Debug Members | System.Diagnostics Namespace | Debug.Fail Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute


Debug.Flush

Clears the output buffer and causes any buffered data to be written to the Listeners.

[Visual Basic]
Public Shared Sub Flush()
[C#]
public static void Flush();
[C++]
public: static void Flush();
[JScript]
public static function Flush();

See Also

Debug Class | Debug Members | System.Diagnostics Namespace | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute


Debug.Write

Writes information about the trace to the trace listeners in the Listeners collection.

Overload List

Writes a category name and the name of the value parameter to the trace listeners in the Listeners collection.

[Visual Basic] Overloads Public Shared Sub Write(Object, String)
[C#] public static void Write(Object, String);
[C++] public: static void Write(Object*, String);
[JScript] public static function Write(Object, String);

Writes the name of the value parameter to the trace listeners in the Listeners collection.

[Visual Basic] Overloads Public Shared Sub Write(Object)
[C#] public static void Write(Object);
[C++] public: static void Write(Object*);
[JScript] public static function Write(Object);

Writes a message to the trace listeners in the Listeners collection.

[Visual Basic] Overloads Public Shared Sub Write(String)
[C#] public static void Write(String);
[C++] public: static void Write(String*);
[JScript] public static function Write(String);

Writes a category name and message to the trace listeners in the Listeners collection.

[Visual Basic] Overloads Public Shared Sub Write(String, String)
[C#] public static void Write(String, String);
[C++] public: static void Write(String*, String*);
[JScript] public static function Write(String, String);

See Also

Debug Class | Debug Members | System.Diagnostics Namespace


Debug.Write (Object, String)

Writes a category name and the name of the value parameter to the trace listeners in the Listeners collection.

[Visual Basic]
Overloads Public Shared Sub Write( _
   ByVal value As Object, _
   ByVal category As String _
)
[C#]
public static void Write(
   object value,
   string category
);
[C++]
public: static void Write(
   Object* value,
   String* category
);
[JScript]
public static function Write(
   value : Object,
   category : String
);

Parameters

value
An Object whose name is sent to the System.Debug.Listeners.
category
A category name to write.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

The category can be used to group output messages.

See Also

Debug Class | Debug Members | System.Diagnostics Namespace | Debug.Write Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute


Debug.Write (Object)

Writes the name of the value parameter to the trace listeners in the Listeners collection.

[Visual Basic]
Overloads Public Shared Sub Write( _
   ByVal value As Object _
)
[C#]
public static void Write(
   object value
);
[C++]
public: static void Write(
   Object* value
);
[JScript]
public static function Write(
   value : Object
);

Parameters

value
An Object whose name is sent to the Listeners.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

See Also

Debug Class | Debug Members | System.Diagnostics Namespace | Debug.Write Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute


Debug.Write (String)

Writes a message to the trace listeners in the Listeners collection.

[Visual Basic]
Overloads Public Shared Sub Write( _
   ByVal message As String _
)
[C#]
public static void Write(
   string message
);
[C++]
public: static void Write(
   String* message
);
[JScript]
public static function Write(
   message : String
);

Parameters

message
A message to write.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

See Also

Debug Class | Debug Members | System.Diagnostics Namespace | Debug.Write Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute


Debug.Write (String, String)

Writes a category name and message to the trace listeners in the Listeners collection.

[Visual Basic]
Overloads Public Shared Sub Write( _
   ByVal message As String, _
   ByVal category As String _
)
[C#]
public static void Write(
   string message,
   string category
);
[C++]
public: static void Write(
   String* message,
   String* category
);
[JScript]
public static function Write(
   message : String,
   category : String
);

Parameters

message
A message to write.
category
A category name to write.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

The category can be used to group output messages.

See Also

Debug Class | Debug Members | System.Diagnostics Namespace | Debug.Write Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute


Debug.WriteIf

Writes a message to the trace listeners in the Listeners collection if a condition is true.

Overload List

Writes the name of the value parameter to the trace listeners in the Listeners collection if a condition is true.

[Visual Basic] Overloads Public Shared Sub WriteIf(Boolean, Object)
[C#] public static void WriteIf(bool, Object);
[C++] public: static void WriteIf(bool, Object);
[JScript] public static function WriteIf(Boolean, Object);

Writes a category name and message to the trace listeners in the Listeners collection if a condition is true.

[Visual Basic] Overloads Public Shared Sub WriteIf(Boolean, String, String)
[C#] public static void WriteIf(bool, String, String);
[C++] public: static void WriteIf(bool, String, String);
[JScript] public static function WriteIf(Boolean, String, String);

Writes a category name and the name of the value parameter to the trace listeners in the Listeners collection if a condition is true.

[Visual Basic] Overloads Public Shared Sub WriteIf(Boolean, Object, String)
[C#] public static void WriteIf(bool, Object, String);
[C++] public: static void WriteIf(bool, Object, String);
[JScript] public static function WriteIf(Boolean, Object, String);

Writes a message to the trace listeners in the Listeners collection if a condition is true.

[Visual Basic] Overloads Public Shared Sub WriteIf(Boolean, String)
[C#] public static void WriteIf(bool, String);
[C++] public: static void WriteIf(bool, String);
[JScript] public static function WriteIf(Boolean, String);

See Also

Debug Class | Debug Members | System.Diagnostics Namespace


Debug.WriteIf (Boolean, Object)

Writes the name of the value parameter to the trace listeners in the Listeners collection if a condition is true.

[Visual Basic]
Overloads Public Shared Sub WriteIf( _
   ByVal condition As Boolean, _
   ByVal value As Object _
)
[C#]
public static void WriteIf(
   bool condition,
   object value
);
[C++]
public: static void WriteIf(
   bool condition,
   Object* value
);
[JScript]
public static function WriteIf(
   condition : Boolean,
   value : Object
);

Parameters

condition
A condition which if true will cause the message to be written.
value
An Object whose name is sent to the Listeners.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

Notes to Implementers: You can minimize the performance penalty of instrumenting your application by using If...Then statements instead of using WriteIf statements. The following two code examples send the same debugging message. However, the first example is much faster when tracing is off, because if mySwitch.TraceError evaluates to false you do not call Write. The second example always calls WriteIf, even when mySwitch.TraceError is false and no tracing output is produced. This can result in unnecessary execution of an arbitrarily complex code.

First example.

if(mySwitch.TraceError)
   Debug.Write("aNumber = " + aNumber + " out of range");

Second example.

Debug.WriteIf(mySwitch.TraceError, "aNumber = " + aNumber + " out of range");

See Also

Debug Class | Debug Members | System.Diagnostics Namespace | Debug.WriteIf Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute


Debug.WriteIf (Boolean, String, String)

Writes a category name and message to the trace listeners in the Listeners collection if a condition is true.

[Visual Basic]
Overloads Public Shared Sub WriteIf( _
   ByVal condition As Boolean, _
   ByVal message As String, _
   ByVal category As String _
)
[C#]
public static void WriteIf(
   bool condition,
   string message,
   string category
);
[C++]
public: static void WriteIf(
   bool condition,
   String* message,
   String* category
);
[JScript]
public static function WriteIf(
   condition : Boolean,
   message : String,
   category : String
);

Parameters

condition
A condition which if true will cause the message to be written.
message
A message to write.
category
A category name to write.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

The category can be used to group output messages.

Notes to Implementers: You can minimize the performance penalty of instrumenting your application by using If...Then statements instead of using WriteIf statements. The following two code examples send the same debugging message. However, the first example is much faster when tracing is off, because if mySwitch.TraceError evaluates to false you do not call Write. The second example always calls WriteIf, even when mySwitch.TraceError is false and no tracing output is produced. This can result in unnecessary execution of an arbitrarily complex code.

First example.

if(mySwitch.TraceError)
   Debug.Write("aNumber = " + aNumber + " out of range");

Second example.

Debug.WriteIf(mySwitch.TraceError, "aNumber = " + aNumber + " out of range");

See Also

Debug Class | Debug Members | System.Diagnostics Namespace | Debug.WriteIf Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute


Debug.WriteIf (Boolean, Object, String)

Writes a category name and the name of the value parameter to the trace listeners in the Listeners collection if a condition is true.

[Visual Basic]
Overloads Public Shared Sub WriteIf( _
   ByVal condition As Boolean, _
   ByVal value As Object, _
   ByVal category As String _
)
[C#]
public static void WriteIf(
   bool condition,
   object value,
   string category
);
[C++]
public: static void WriteIf(
   bool condition,
   Object* value,
   String* category
);
[JScript]
public static function WriteIf(
   condition : Boolean,
   value : Object,
   category : String
);

Parameters

condition
A condition which if true will cause the message to be written.
value
An Object whose name is sent to the Listeners.
category
A category name to write.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

The category can be used to group output messages.

Notes to Implementers: You can minimize the performance penalty of instrumenting your application by using If...Then statements instead of using WriteIf statements. The following two code examples send the same debugging message. However, the first example is much faster when tracing is off, because if mySwitch.TraceError evaluates to false you do not call Write. The second example always calls WriteIf, even when mySwitch.TraceError is false and no tracing output is produced. This can result in unnecessary execution of an arbitrarily complex code.

First example.

if(mySwitch.TraceError)
   Debug.Write("aNumber = " + aNumber + " out of range");

Second example.

Debug.WriteIf(mySwitch.TraceError, "aNumber = " + aNumber + " out of range");

See Also

Debug Class | Debug Members | System.Diagnostics Namespace | Debug.WriteIf Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute


Debug.WriteIf (Boolean, String)

Writes a message to the trace listeners in the Listeners collection if a condition is true.

[Visual Basic]
Overloads Public Shared Sub WriteIf( _
   ByVal condition As Boolean, _
   ByVal message As String _
)
[C#]
public static void WriteIf(
   bool condition,
   string message
);
[C++]
public: static void WriteIf(
   bool condition,
   String* message
);
[JScript]
public static function WriteIf(
   condition : Boolean,
   message : String
);

Parameters

condition
A condition which if true will cause the message to be written.
message
A message to write.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

Notes to Implementers: You can minimize the performance penalty of instrumenting your application by using If...Then statements instead of using WriteIf statements. The following two code examples send the same debugging message. However, the first example is much faster when tracing is off, because if mySwitch.TraceError evaluates to false you do not call Write. The second example always calls WriteIf, even when mySwitch.TraceError is false and no tracing output is produced. This can result in unnecessary execution of an arbitrarily complex code.

First example.

if(mySwitch.TraceError)
   Debug.Write("aNumber = " + aNumber + " out of range");

Second example.

Debug.WriteIf(mySwitch.TraceError, "aNumber = " + aNumber + " out of range");

See Also

Debug Class | Debug Members | System.Diagnostics Namespace | Debug.WriteIf Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute


Debug.WriteLine

Writes information about the trace followed by a line terminator to the trace listeners in the Listeners collection.

Overload List

Writes a message followed by a line terminator to the trace listeners in the Listeners collection. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic] Overloads Public Shared Sub WriteLine(String)
[C#] public static void WriteLine(String);
[C++] public: static void WriteLine(String*);
[JScript] public static function WriteLine(String);

Writes the name of the value parameter followed by a line terminator to the trace listeners in the Listeners collection. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic] Overloads Public Shared Sub WriteLine(Object)
[C#] public static void WriteLine(Object);
[C++] public: static void WriteLine(Object*);
[JScript] public static function WriteLine(Object);

Writes a category name and the name of the value parameter followed by a line terminator to the trace listeners in the Listeners collection. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic] Overloads Public Shared Sub WriteLine(Object, String)
[C#] public static void WriteLine(Object, String);
[C++] public: static void WriteLine(Object*, String);
[JScript] public static function WriteLine(Object, String);

Writes a category name and message followed by a line terminator to the trace listeners in the Listeners collection. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic] Overloads Public Shared Sub WriteLine(String, String)
[C#] public static void WriteLine(String, String);
[C++] public: static void WriteLine(String*, String*);
[JScript] public static function WriteLine(String, String);

See Also

Debug Class | Debug Members | System.Diagnostics Namespace


Debug.WriteLine (String)

Writes a message followed by a line terminator to the trace listeners in the Listeners collection. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic]
Overloads Public Shared Sub WriteLine( _
   ByVal message As String _
)
[C#]
public static void WriteLine(
   string message
);
[C++]
public: static void WriteLine(
   String* message
);
[JScript]
public static function WriteLine(
   message : String
);

Parameters

message
A message to write.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

See Also

Debug Class | Debug Members | System.Diagnostics Namespace | Debug.WriteLine Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute


Debug.WriteLine (Object)

Writes the name of the value parameter followed by a line terminator to the trace listeners in the Listeners collection. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic]
Overloads Public Shared Sub WriteLine( _
   ByVal value As Object _
)
[C#]
public static void WriteLine(
   object value
);
[C++]
public: static void WriteLine(
   Object* value
);
[JScript]
public static function WriteLine(
   value : Object
);

Parameters

value
An Object whose name is sent to the Listeners.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

See Also

Debug Class | Debug Members | System.Diagnostics Namespace | Debug.WriteLine Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute


Debug.WriteLine (Object, String)

Writes a category name and the name of the value parameter followed by a line terminator to the trace listeners in the Listeners collection. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic]
Overloads Public Shared Sub WriteLine( _
   ByVal value As Object, _
   ByVal category As String _
)
[C#]
public static void WriteLine(
   object value,
   string category
);
[C++]
public: static void WriteLine(
   Object* value,
   String* category
);
[JScript]
public static function WriteLine(
   value : Object,
   category : String
);

Parameters

value
An Object whose name is sent to the Listeners.
category
A category name to write.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

The category can be used to group output messages.

See Also

Debug Class | Debug Members | System.Diagnostics Namespace | Debug.WriteLine Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute


Debug.WriteLine (String, String)

Writes a category name and message followed by a line terminator to the trace listeners in the Listeners collection. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic]
Overloads Public Shared Sub WriteLine( _
   ByVal message As String, _
   ByVal category As String _
)
[C#]
public static void WriteLine(
   string message,
   string category
);
[C++]
public: static void WriteLine(
   String* message,
   String* category
);
[JScript]
public static function WriteLine(
   message : String,
   category : String
);

Parameters

message
A message to write.
category
A category name to write.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

The category can be used to group output messages.

See Also

Debug Class | Debug Members | System.Diagnostics Namespace | Debug.WriteLine Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute


Debug.WriteLineIf

Writes information about the trace followed by a line terminator to the trace listeners in the Listeners collection if a condition is true.

Overload List

Writes a category name and the name of the value parameter followed by a line terminator to the trace listeners in the Listeners collection if a condition is true. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic] Overloads Public Shared Sub WriteLineIf(Boolean, Object, String)
[C#] public static void WriteLineIf(bool, Object, String);
[C++] public: static void WriteLineIf(bool, Object, String);
[JScript] public static function WriteLineIf(Boolean, Object, String);

Writes a message followed by a line terminator to the trace listeners in the Listeners collection if a condition is true. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic] Overloads Public Shared Sub WriteLineIf(Boolean, String)
[C#] public static void WriteLineIf(bool, String);
[C++] public: static void WriteLineIf(bool, String);
[JScript] public static function WriteLineIf(Boolean, String);

Writes the name of the value parameter followed by a line terminator to the trace listeners in the Listeners collection if a condition is true. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic] Overloads Public Shared Sub WriteLineIf(Boolean, Object)
[C#] public static void WriteLineIf(bool, Object);
[C++] public: static void WriteLineIf(bool, Object);
[JScript] public static function WriteLineIf(Boolean, Object);

Writes a category name and message followed by a line terminator to the trace listeners in the Listeners collection if a condition is true. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic] Overloads Public Shared Sub WriteLineIf(Boolean, String, String)
[C#] public static void WriteLineIf(bool, String, String);
[C++] public: static void WriteLineIf(bool, String, String);
[JScript] public static function WriteLineIf(Boolean, String, String);

See Also

Debug Class | Debug Members | System.Diagnostics Namespace


Debug.WriteLineIf (Boolean, Object, String)

Writes a category name and the name of the value parameter followed by a line terminator to the trace listeners in the Listeners collection if a condition is true. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic]
Overloads Public Shared Sub WriteLineIf( _
   ByVal condition As Boolean, _
   ByVal value As Object, _
   ByVal category As String _
)
[C#]
public static void WriteLineIf(
   bool condition,
   object value,
   string category
);
[C++]
public: static void WriteLineIf(
   bool condition,
   Object* value,
   String* category
);
[JScript]
public static function WriteLineIf(
   condition : Boolean,
   value : Object,
   category : String
);

Parameters

condition
A condition which if true will cause the message to be written.
value
An Object whose name is sent to the Listeners.
category
A category name to write.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

The category can be used to group output messages.

Notes to Implementers: You can minimize the performance penalty of instrumenting your application by using If...Then statements instead of using WriteIf statements. The following two code examples send the same debugging message. However, the first example is much faster when tracing is off, because if mySwitch.TraceError evaluates to false you do not call Write. The second example always calls WriteIf, even when mySwitch.TraceError is false and no tracing output is produced. This can result in unnecessary execution of an arbitrarily complex code.

First example.

if(mySwitch.TraceError)
   Debug.Write("aNumber = " + aNumber + " out of range");

Second example.

Debug.WriteIf(mySwitch.TraceError, "aNumber = " + aNumber + " out of range");

See Also

Debug Class | Debug Members | System.Diagnostics Namespace | Debug.WriteLineIf Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute


Debug.WriteLineIf (Boolean, String)

Writes a message followed by a line terminator to the trace listeners in the Listeners collection if a condition is true. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic]
Overloads Public Shared Sub WriteLineIf( _
   ByVal condition As Boolean, _
   ByVal message As String _
)
[C#]
public static void WriteLineIf(
   bool condition,
   string message
);
[C++]
public: static void WriteLineIf(
   bool condition,
   String* message
);
[JScript]
public static function WriteLineIf(
   condition : Boolean,
   message : String
);

Parameters

condition
A condition which if true will cause the message to be written.
message
A message to write.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

Notes to Implementers: You can minimize the performance penalty of instrumenting your application by using If...Then statements instead of using WriteIf statements. The following two code examples send the same debugging message. However, the first example is much faster when tracing is off, because if mySwitch.TraceError evaluates to false you do not call Write. The second example always calls WriteIf, even when mySwitch.TraceError is false and no tracing output is produced. This can result in unnecessary execution of an arbitrarily complex code.

First example.

if(mySwitch.TraceError)
   Debug.Write("aNumber = " + aNumber + " out of range");

Second example.

Debug.WriteIf(mySwitch.TraceError, "aNumber = " + aNumber + " out of range");

See Also

Debug Class | Debug Members | System.Diagnostics Namespace | Debug.WriteLineIf Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute


Debug.WriteLineIf (Boolean, Object)

Writes the name of the value parameter followed by a line terminator to the trace listeners in the Listeners collection if a condition is true. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic]
Overloads Public Shared Sub WriteLineIf( _
   ByVal condition As Boolean, _
   ByVal value As Object _
)
[C#]
public static void WriteLineIf(
   bool condition,
   object value
);
[C++]
public: static void WriteLineIf(
   bool condition,
   Object* value
);
[JScript]
public static function WriteLineIf(
   condition : Boolean,
   value : Object
);

Parameters

condition
A condition which if true will cause the message to be written.
value
An Object whose name is sent to the Listeners.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

Notes to Implementers: You can minimize the performance penalty of instrumenting your application by using If...Then statements instead of using WriteIf statements. The following two code examples send the same debugging message. However, the first example is much faster when tracing is off, because if mySwitch.TraceError evaluates to false you do not call Write. The second example always calls WriteIf, even when mySwitch.TraceError is false and no tracing output is produced. This can result in unnecessary execution of an arbitrarily complex code.

First example.

if(mySwitch.TraceError)
   Debug.Write("aNumber = " + aNumber + " out of range");

Second example.

Debug.WriteIf(mySwitch.TraceError, "aNumber = " + aNumber + " out of range");

See Also

Debug Class | Debug Members | System.Diagnostics Namespace | Debug.WriteLineIf Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute


Debug.WriteLineIf (Boolean, String, String)

Writes a category name and message followed by a line terminator to the trace listeners in the Listeners collection if a condition is true. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic]
Overloads Public Shared Sub WriteLineIf( _
   ByVal condition As Boolean, _
   ByVal message As String, _
   ByVal category As String _
)
[C#]
public static void WriteLineIf(
   bool condition,
   string message,
   string category
);
[C++]
public: static void WriteLineIf(
   bool condition,
   String* message,
   String* category
);
[JScript]
public static function WriteLineIf(
   condition : Boolean,
   message : String,
   category : String
);

Parameters

condition
A condition which if true will cause the message to be written.
message
A message to write.
category
A category to write.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

The category can be used to group output messages.

Notes to Implementers: You can minimize the performance penalty of instrumenting your application by using If...Then statements instead of using WriteIf statements. The following two code examples send the same debugging message. However, the first example is much faster when tracing is off, because if mySwitch.TraceError evaluates to false you do not call Write. The second example always calls WriteIf, even when mySwitch.TraceError is false and no tracing output is produced. This can result in unnecessary execution of an arbitrarily complex code.

First example.

if(mySwitch.TraceError)
   Debug.Write("aNumber = " + aNumber + " out of range");

Second example.

Debug.WriteIf(mySwitch.TraceError, "aNumber = " + aNumber + " out of range");

See Also

Debug Class | Debug Members | System.Diagnostics Namespace | Debug.WriteLineIf Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute


DebuggableAmbivalentAttribute Class

[To be supplied.]

Object
Attribute
DebuggableAmbivalentAttribute

[Visual Basic]
Public Class DebuggableAmbivalentAttribute
   Inherits Attribute
[C#]
public class DebuggableAmbivalentAttribute : Attribute
[C++]
public __gc class DebuggableAmbivalentAttribute : public Attribute
[JScript]
public class DebuggableAmbivalentAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: mscorlib.dll

See Also

DebuggableAmbivalentAttribute Members | System.Diagnostics Namespace


DebuggableAmbivalentAttribute Members

Public:

Constructor

DebuggableAmbivalentAttribute Constructor [To be supplied.]

Properties

IsAmibvalent [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DebuggableAmbivalentAttribute Class | System.Diagnostics Namespace


DebuggableAmbivalentAttribute Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal fAmbivalent As Boolean _
)
[C#]
public DebuggableAmbivalentAttribute(
   bool fAmbivalent
);
[C++]
public: DebuggableAmbivalentAttribute(
   bool fAmbivalent
);
[JScript]
public function DebuggableAmbivalentAttribute(
   fAmbivalent : Boolean
);

Parameters

fAmbivalent
[To be supplied.]

See Also

DebuggableAmbivalentAttribute Class | DebuggableAmbivalentAttribute Members | System.Diagnostics Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DebuggableAmbivalentAttribute Properties

The properties of the DebuggableAmbivalentAttribute class are listed below. For a complete list of DebuggableAmbivalentAttribute class members, see the DebuggableAmbivalentAttribute Members topic.

Public:

IsAmibvalent [To be supplied.]

See Also

DebuggableAmbivalentAttribute Class | System.Diagnostics Namespace


DebuggableAmbivalentAttribute.IsAmibvalent

[To be supplied.]

[Visual Basic]
Public ReadOnly Property IsAmibvalent As Boolean
[C#]
public bool IsAmibvalent {get;}
[C++]
public: __property bool get_IsAmibvalent();
[JScript]
public function get IsAmibvalent() : Boolean;

See Also

DebuggableAmbivalentAttribute Class | DebuggableAmbivalentAttribute Members | System.Diagnostics Namespace


DebuggableAttribute Class

[To be supplied.]

Object
Attribute
DebuggableAttribute

[Visual Basic]
Public Class DebuggableAttribute
   Inherits Attribute
[C#]
public class DebuggableAttribute : Attribute
[C++]
public __gc class DebuggableAttribute : public Attribute
[JScript]
public class DebuggableAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: mscorlib.dll

See Also

DebuggableAttribute Members | System.Diagnostics Namespace


DebuggableAttribute Members

Public:

Constructor

DebuggableAttribute Constructor [To be supplied.]

Properties

IsJITOptimizerDisabled | [To be supplied.]
IsJITTrackingEnabled | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DebuggableAttribute Class | System.Diagnostics Namespace


DebuggableAttribute Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal fEnableJITcompileTracking As Boolean, _
   ByVal fDisableJITcompileOptimizer As Boolean _
)
[C#]
public DebuggableAttribute(
   bool fEnableJITcompileTracking,
   bool fDisableJITcompileOptimizer
);
[C++]
public: DebuggableAttribute(
   bool fEnableJITcompileTracking,
   bool fDisableJITcompileOptimizer
);
[JScript]
public function DebuggableAttribute(
   fEnableJITcompileTracking : Boolean,
   fDisableJITcompileOptimizer : Boolean
);

Parameters

fEnableJITcompileTracking
[To be supplied.]
fDisableJITcompileOptimizer
[To be supplied.]

See Also

DebuggableAttribute Class | DebuggableAttribute Members | System.Diagnostics Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DebuggableAttribute Properties

The properties of the DebuggableAttribute class are listed below. For a complete list of DebuggableAttribute class members, see the DebuggableAttribute Members topic.

Public:

IsJITOptimizerDisabled | [To be supplied.]
IsJITTrackingEnabled | [To be supplied.]

See Also

DebuggableAttribute Class | System.Diagnostics Namespace


DebuggableAttribute.IsJITOptimizerDisabled

[To be supplied.]

[Visual Basic]
Public ReadOnly Property IsJITOptimizerDisabled As Boolean
[C#]
public bool IsJITOptimizerDisabled {get;}
[C++]
public: __property bool get_IsJITOptimizerDisabled();
[JScript]
public function get IsJITOptimizerDisabled() : Boolean;

See Also

DebuggableAttribute Class | DebuggableAttribute Members | System.Diagnostics Namespace


DebuggableAttribute.IsJITTrackingEnabled

[To be supplied.]

[Visual Basic]
Public ReadOnly Property IsJITTrackingEnabled As Boolean
[C#]
public bool IsJITTrackingEnabled {get;}
[C++]
public: __property bool get_IsJITTrackingEnabled();
[JScript]
public function get IsJITTrackingEnabled() : Boolean;

See Also

DebuggableAttribute Class | DebuggableAttribute Members | System.Diagnostics Namespace


Debugger Class

Enables communication with a debugger.

Object
Debugger

[Visual Basic]
NotInheritable Public Class Debugger
[C#]
public sealed class Debugger
[C++]
public __gc __sealed class Debugger
[JScript]
public class Debugger

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: mscorlib.dll

See Also

Debugger Members | System.Diagnostics Namespace


Debugger Members

Public:

Constructor

Debugger Constructor [To be supplied.]

Properties

IsAttached Returns a Boolean indicating whether or not a debugger is attached to the process.

Methods

Break | Causes a breakpoint to be signaled to an attached debugger.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsLogging | Checks to see if logging is enabled by an attached debugger.
Launch | Launches and attaches a debugger to the process.
Log | Posts a message for the attached debugger.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

DefaultCategory Represents the default category of message with a constant.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Debugger Class | System.Diagnostics Namespace


Debugger Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public Debugger();
[C++]
public: Debugger();
[JScript]
public function Debugger();

See Also

Debugger Class | Debugger Members | System.Diagnostics Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Debugger Properties

The properties of the Debugger class are listed below. For a complete list of Debugger class members, see the Debugger Members topic.

Public:

IsAttached Returns a Boolean indicating whether or not a debugger is attached to the process.

See Also

Debugger Class | System.Diagnostics Namespace


Debugger.IsAttached

Returns a Boolean indicating whether or not a debugger is attached to the process.

[Visual Basic]
Public Shared ReadOnly Property IsAttached As Boolean
[C#]
public static bool IsAttached {get;}
[C++]
public: __property static bool get_IsAttached();
[JScript]
public static function get IsAttached() : Boolean;

Property Value

true if a debugger is attached; otherwise, false.

See Also

Debugger Class | Debugger Members | System.Diagnostics Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Debugger Methods

The methods of the Debugger class are listed below. For a complete list of Debugger class members, see the Debugger Members topic.

Public:

Break | Causes a breakpoint to be signaled to an attached debugger.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsLogging | Checks to see if logging is enabled by an attached debugger.
Launch | Launches and attaches a debugger to the process.
Log | Posts a message for the attached debugger.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Debugger Class | System.Diagnostics Namespace


Debugger.Break

Causes a breakpoint to be signaled to an attached debugger.

[Visual Basic]
Public Shared Sub Break()
[C#]
public static void Break();
[C++]
public: static void Break();
[JScript]
public static function Break();

Remarks

If no debugger is attached, users are asked if they want to attach a debugger. If yes, the debugger is launched.

See Also

Debugger Class | Debugger Members | System.Diagnostics Namespace


Debugger.IsLogging

Checks to see if logging is enabled by an attached debugger.

[Visual Basic]
Public Shared Function IsLogging() As Boolean
[C#]
public static bool IsLogging();
[C++]
public: static bool IsLogging();
[JScript]
public static function IsLogging() : Boolean;

Return Value

true if a debugger is attached and logging is enabled; otherwise, false

See Also

Debugger Class | Debugger Members | System.Diagnostics Namespace


Debugger.Launch

Launches and attaches a debugger to the process.

[Visual Basic]
Public Shared Function Launch() As Boolean
[C#]
public static bool Launch();
[C++]
public: static bool Launch();
[JScript]
public static function Launch() : Boolean;

Return Value

true if the launch was successful or if the debugger was already attached; otherwise, false.

Remarks

If a debugger is already attached, nothing happens.

See Also

Debugger Class | Debugger Members | System.Diagnostics Namespace


Debugger.Log

Posts a message for the attached debugger.

[Visual Basic]
Public Shared Sub Log( _
   ByVal level As Integer, _
   ByVal category As String, _
   ByVal message As String _
)
[C#]
public static void Log(
   int level,
   string category,
   string message
);
[C++]
public: static void Log(
   int level,
   String* category,
   String* message
);
[JScript]
public static function Log(
   level : int,
   category : String,
   message : String
);

Parameters

level
A description of the importance of the message.
category
A string describing the category of the message.
message
A string representing the message to show.

Remarks

If there is no debugger attached, has no effect. The debugger may or may not report the message, depending on its settings.

See Also

Debugger Class | Debugger Members | System.Diagnostics Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Debugger Fields

The fields of the Debugger class are listed below. For a complete list of Debugger class members, see the Debugger Members topic.

Public:

DefaultCategory Represents the default category of message with a constant.

See Also

Debugger Class | System.Diagnostics Namespace


Debugger.DefaultCategory

Represents the default category of message with a constant.

[Visual Basic]
Public Shared ReadOnly DefaultCategory As String
[C#]
public static readonly string DefaultCategory;
[C++]
public: static readonly String* DefaultCategory;
[JScript]
public static var DefaultCategory : String;

See Also

Debugger Class | Debugger Members | System.Diagnostics Namespace


DebuggerHiddenAttribute Class

[To be supplied.]

Object
Attribute
DebuggerHiddenAttribute

[Visual Basic]
Public Class DebuggerHiddenAttribute
   Inherits Attribute
[C#]
public class DebuggerHiddenAttribute : Attribute
[C++]
public __gc class DebuggerHiddenAttribute : public Attribute
[JScript]
public class DebuggerHiddenAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: mscorlib.dll

See Also

DebuggerHiddenAttribute Members | System.Diagnostics Namespace


DebuggerHiddenAttribute Members

Public:

Constructor

DebuggerHiddenAttribute Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DebuggerHiddenAttribute Class | System.Diagnostics Namespace


DebuggerHiddenAttribute Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public DebuggerHiddenAttribute();
[C++]
public: DebuggerHiddenAttribute();
[JScript]
public function DebuggerHiddenAttribute();

See Also

DebuggerHiddenAttribute Class | DebuggerHiddenAttribute Members | System.Diagnostics Namespace


DebuggerStepThroughAttribute Class

[To be supplied.]

Object
Attribute
DebuggerStepThroughAttribute

[Visual Basic]
Public Class DebuggerStepThroughAttribute
   Inherits Attribute
[C#]
public class DebuggerStepThroughAttribute : Attribute
[C++]
public __gc class DebuggerStepThroughAttribute : public Attribute
[JScript]
public class DebuggerStepThroughAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: mscorlib.dll

See Also

DebuggerStepThroughAttribute Members | System.Diagnostics Namespace


DebuggerStepThroughAttribute Members

Public:

Constructor

DebuggerStepThroughAttribute Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DebuggerStepThroughAttribute Class | System.Diagnostics Namespace


DebuggerStepThroughAttribute Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public DebuggerStepThroughAttribute();
[C++]
public: DebuggerStepThroughAttribute();
[JScript]
public function DebuggerStepThroughAttribute();

See Also

DebuggerStepThroughAttribute Class | DebuggerStepThroughAttribute Members | System.Diagnostics Namespace


DefaultTraceListener Class

Provides the default output methods and behavior for tracing.

Object
TraceListener
DefaultTraceListener

[Visual Basic]
Public Class DefaultTraceListener
   Inherits TraceListener
[C#]
public class DefaultTraceListener : TraceListener
[C++]
public __gc class DefaultTraceListener : public TraceListener
[JScript]
public class DefaultTraceListener extends TraceListener

Remarks

This class is automatically added to the Debug Listeners and to the Trace Listeners collections.

By default, Write and WriteLine methods emit the message to the Microsoft.Win32.Interop.Windows.OutputDebugString API, and to Log.

The Fail method, by default, displays a message box when the application is running in a user interface mode, and also emits the message using WriteLine.

Requirements

Namespace: System.Diagnostics

Assembly: System.dll

See Also

DefaultTraceListener Members | System.Diagnostics Namespace | TraceListener | TextWriterTraceListener | Debug | Trace


DefaultTraceListener Members

Public:

Constructor

DefaultTraceListener Constructor Initializes a new instance of the DefaultTraceListener class.

Properties

Indent (inherited from TraceListener) | Gets or sets the indent level.
IndentSize (inherited from TraceListener) | Gets or sets the number of spaces in an indent.
Name (inherited from TraceListener) | Gets or sets a name for this TraceListener.

Methods

Close (inherited from TraceListener) | When overridden in a derived class, closes the output stream so that it no longer receives tracing or debugging output.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Fail | Overloaded. Emits or displays a message and a stack trace for an assertion that always fails.
Flush (inherited from TraceListener) | When overridden in a derived class, flushes the output buffer.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write (inherited from TraceListener) | Overloaded. Writes a message, category name, or object name.
WriteLine (inherited from TraceListener) | Overloaded. Writes a message, category name, or object name followed by a line terminator.

Protected:

Properties

NeedIndent (inherited from TraceListener) Gets or sets whether an indent is needed.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
WriteIndent (inherited from TraceListener) | Writes the indent and resets the NeedIndent property to false.

See Also

DefaultTraceListener Class | System.Diagnostics Namespace


DefaultTraceListener Constructor

Initializes a new instance of the DefaultTraceListener class.

[Visual Basic]
Public Sub New()
[C#]
public DefaultTraceListener();
[C++]
public: DefaultTraceListener();
[JScript]
public function DefaultTraceListener();

See Also

DefaultTraceListener Class | DefaultTraceListener Members | System.Diagnostics Namespace | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DefaultTraceListener Methods

The methods of the DefaultTraceListener class are listed below. For a complete list of DefaultTraceListener class members, see the DefaultTraceListener Members topic.

Public:

Close (inherited from TraceListener) | When overridden in a derived class, closes the output stream so that it no longer receives tracing or debugging output.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Fail | Overloaded. Emits or displays a message and a stack trace for an assertion that always fails.
Flush (inherited from TraceListener) | When overridden in a derived class, flushes the output buffer.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write (inherited from TraceListener) | Overloaded. Writes a message, category name, or object name.
WriteLine (inherited from TraceListener) | Overloaded. Writes a message, category name, or object name followed by a line terminator.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
WriteIndent (inherited from TraceListener) | Writes the indent and resets the NeedIndent property to false.

See Also

DefaultTraceListener Class | System.Diagnostics Namespace


DefaultTraceListener.Fail

Emits or displays a message and a stack trace for an assertion that always fails.

Overload List

Emits or displays messages and a stack trace for an assertion that always fails.

[Visual Basic] Overloads Overrides Public Sub Fail(String, String)
[C#] public override void Fail(String, String);
[C++] public: override void Fail(String*, String*);
[JScript] public override function Fail(String, String);

Emits or displays a message and a stack trace for an assertion that always fails.

[Visual Basic] Overloads Overrides Public Sub Fail(String)
[C#] public override void Fail(String);
[C++] public: override void Fail(String*);
[JScript] public override function Fail(String);

See Also

DefaultTraceListener Class | DefaultTraceListener Members | System.Diagnostics Namespace


DefaultTraceListener.Fail (String, String)

Emits or displays messages and a stack trace for an assertion that always fails.

[Visual Basic]
Overloads Overrides Public Sub Fail( _
   ByVal message As String, _
   ByVal detailMessage As String _
)
[C#]
public override void Fail(
   string message,
   string detailMessage
);
[C++]
public: override void Fail(
   String* message,
   String* detailMessage
);
[JScript]
public override function Fail(
   message : String,
   detailMessage : String
);

Parameters

message
A message to emit or display.
detailMessage
A detailed message to emit or display.

Remarks

By default this method outputs the message, detailedMessage and a stack trace to a message box when the application is running in a user interface mode, and to the instance of this class.

See Also

DefaultTraceListener Class | DefaultTraceListener Members | System.Diagnostics Namespace | DefaultTraceListener.Fail Overload List | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


DefaultTraceListener.Fail (String)

Emits or displays a message and a stack trace for an assertion that always fails.

[Visual Basic]
Overloads Overrides Public Sub Fail( _
   ByVal message As String _
)
[C#]
public override void Fail(
   string message
);
[C++]
public: override void Fail(
   String* message
);
[JScript]
public override function Fail(
   message : String
);

Parameters

message
A message to emit or display.

Remarks

By default, this method outputs the message, detailedMessage and a stack trace to a message box when the application is running in a user interface mode, and to the instance of this class.

See Also

DefaultTraceListener Class | DefaultTraceListener Members | System.Diagnostics Namespace | DefaultTraceListener.Fail Overload List | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


DefaultTraceListener.Write

Writes the output to the Microsoft.Win32.Interop.Windows.OutputDebugString API and to Log.

[Visual Basic]
Overrides Public Sub Write( _
   ByVal message As String _
)
[C#]
public override void Write(
   string message
);
[C++]
public: override void Write(
   String* message
);
[JScript]
public override function Write(
   message : String
);

Parameters

message
A message to write.

See Also

DefaultTraceListener Class | DefaultTraceListener Members | System.Diagnostics Namespace | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


DefaultTraceListener.WriteLine

Writes the output to the Microsoft.Win32.Interop.Windows.OutputDebugString API and to Log followed by a line terminator. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic]
Overrides Public Sub WriteLine( _
   ByVal message As String _
)
[C#]
public override void WriteLine(
   string message
);
[C++]
public: override void WriteLine(
   String* message
);
[JScript]
public override function WriteLine(
   message : String
);

Parameters

message
A message to write.

Remarks

This method sets NeedIndent to true.

See Also

DefaultTraceListener Class | DefaultTraceListener Members | System.Diagnostics Namespace | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


EventLog Class

Provides interaction with Windows 2000 event logs.

Object
Component
EventLog

[Visual Basic]
Public Class EventLog
   Inherits Component
   Implements ISupportInitialize
[C#]
public class EventLog : Component, ISupportInitialize
[C++]
public __gc class EventLog : public Component, ISupportInitialize
[JScript]
public class EventLog extends Component, ISupportInitialize

Remarks

EventLog lets you manipulate the logs which record information about important software or hardware events that occur. Using EventLog, you can read from existing logs, write entries to logs, create or delete event sources, delete logs, and react to entries your log receives. You can create new logs as well when creating an event source. If the log specified in a call to CreateEventSource does not exist on the computer, the system creates a custom log and registers your application as a source for that log. Use the EventLog class to read and write entries to any event log to which you have the appropriate access.

Note The Security log is read-only.

If you write to an event log, you must specify or create an event Source. The Source registers your application with the event log as a valid source of entries. The Source can only be used to write to a single log at a time. The Source can be any random string, but the name must be distinct from that of other sources on the computer. An attempt to create a duplicated Source value throws an exception. However, a single event log can have multiple sources associated with it.

To read from a log, you can specify only the Log name and MachineName (server computer name) for the EventLog instance. It is not necessary to specify the Source. In either case, the Entries member is automatically populated with the event log's list of entries. Select the appropriate index for an item in the list to read individual entries.

Note You are not explicitly required to specify the MachineName if you are connecting to a log by specifying a Log/ MachineName pair. If you do not specify the MachineName, the local computer, ".", is assumed.

When writing to an event log, you can specify the type of information sent with the entry message. In addition to sending the message, you can send an EventLogEntryType to indicate, for example, whether the message is an Error, Warning, or Information. You can also specify an eventId and category that you have defined in your application and that will display in the Type and Category columns of the event viewer. Finally, you can also attach binary data to your event entry if you need additional information to be associated with a given event.

In addition to manipulating specific event logs and their entries, EventLog provides access to the event log collection itself. You can use the static (in Visual Basic Shared) members of EventLog to delete logs, get log lists, determine if a Source already exists on a given computer, and create or delete a Source.

Windows 2000 has three default logs: Application, System, and Security. Other installed applications and services, such as Active Directory, can have additional event logs. You can use EventLog to create custom event logs that can be viewed through the server's Event Viewer.

Event logging consumes resources such as disk space and processor time. It is important to log only essential information. It is also best to place event log calls in an error path in the code rather than in the main code path, so as not to reduce performance.

When an instance of EventLog is created, the read/write properties are set to initial values. For a list of these values, see the EventLog constructor.

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

Example [Visual Basic]

The following example connects to an event log, "myNewLog", on the local computer. If the source "myNewSource" does not already exist on the computer, it is created. Then, an entry is written to the Log.

Note that the way to create a new event log is through the static (Shared) member CreateEventSource, which creates a Source and registers it to the Log at the time the log is created. Because this is a static (Shared) member of EventLog, it should be called on the class itself rather than on an instance of the class.

Import the System.Diagnostics namespace for this example.

[Visual Basic]

Private Sub ConnectToEventLog()
    'Declare a new event log and event log entry.
    Dim evtLog As EventLog

    'Instantiate a new event log.
    evtLog = New EventLog

    'Otherwise, create a new source and log.
    If Not EventLog.SourceExists("myNewSource") Then
        'If MyNewLog does not exist, it will be created
        EventLog.CreateEventSource("myNewSource", "myNewLog")
    End If

    'Connect the source to the event instance.
    evtLog.Source = "myNewSource"

    'Write an entry to the event log.
    evtLog.WriteEntry("My entry.")
End Sub

See Also

EventLog Members | System.Diagnostics Namespace | EventLogEntry | EventLogEvent


EventLog Members

Public:

Constructor

EventLog Constructor Overloaded. [To be supplied.]

Properties

Entries | Gets the contents of the event log.
Log | Gets or sets the name of the log to read from and write to.
MachineName | Gets or sets the name of the computer on which to read or write events.
Monitoring | [To be supplied.]
Site (inherited from Component) | Gets or sets the site of the Component.
Source | Gets or sets the application name (source name) to register and use when writing to the event log.
SynchronizingObject | Represents the object used to marshal the event handler calls issued as a result of an EventLog change.

Methods

BeginInit | [To be supplied.]
Clear | Clears the event log by removing all entries from it.
Close | Closes the event log and releases read and write handles.
CreateEventSource | Overloaded. Establishes an application as an event source.
Delete | Overloaded. Removes a log resource.
DeleteEventSource | Overloaded. Removes an application's event source registration from the event log.
Dispose | Frees all resources held by the EventLog.
EndInit | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Exists | Overloaded. Determines whether the specified log exists.
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetEventLogs | Overloaded. Creates an array of the event logs.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
SourceExists | Overloaded. Searches a computer's registry for a given event source.
StartMonitoring | [To be supplied.]
StopMonitoring | [To be supplied.]
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
WriteEntry | Overloaded. Logs an entry in the event log.

Events

EntryWritten Occurs when an entry is written to the event log.

Protected:

Methods

Finalize | Called when the object is about to be reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Event Hookup:

Methods

AddOnEntryWritten | Adds an event handler for the System.Diagnostics.EventLog.EntryWritten event.
RemoveOnEntryWritten | Deregisters an event handler from monitoring for the arrival of events.

See Also

EventLog Class | System.Diagnostics Namespace


EventLog Constructor

[To be supplied.]

Overload List

Initializes a new instance of the EventLog class.

[Visual Basic] Overloads Public Sub New()
[C#] public EventLog();
[C++] public: EventLog();
[JScript] public function EventLog();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public EventLog(String);
[C++] public: EventLog(String*);
[JScript] public function EventLog(String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, String)
[C#] public EventLog(String, String);
[C++] public: EventLog(String*, String*);
[JScript] public function EventLog(String, String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, String, String)
[C#] public EventLog(String, String, String);
[C++] public: EventLog(String*, String*, String*);
[JScript] public function EventLog(String, String, String);

Example [Visual Basic]

The following example connects to an event log, "myNewLog", on the local computer. If the source "myNewSource" does not already exist on the computer, it is created. Then, an entry is written to the Log.

Note that the way to create a new event log is through the static (in Visual Basic Shared) member CreateEventSource, which creates a Source and registers it to the Log at the time the log is created. Because this is a static (Shared) member of EventLog, it should be called on the class itself rather than on an instance of the class.

Import the System.Diagnostics namespace for this example.

Note This example shows how to use one of the overloaded version of the EventLog constructor. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub ConnectToEventLog()
    'Declare a new event log and event log entry.
    Dim evtLog As EventLog

    'Instantiate a new event log.
    evtLog = New EventLog

    'Otherwise, create a new source and log.
    If Not EventLog.SourceExists("MyNewSource") Then
        'If MyNewLog does not exist, it will be created
        EventLog.CreateEventSource("MyNewSource", "MyNewLog")
    End If

    'Connect the source to the event instance.
    evtLog.Source = "MyNewSource"

    'Write an entry to the event log.
    evtLog.WriteEntry("My entry.")
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace


EventLog Constructor ()

Initializes a new instance of the EventLog class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public EventLog();
[C++]
public: EventLog();
[JScript]
public function EventLog();

Remarks

Use the EventLog constructor to create an object to read or write entries to a log, or to clear or close a particular log. Before calling any of these methods, associate a Source with your event log object in order to connect it to a particular log in the Windows 2000 event logs. If you will only be reading Entries from the log, you can alternately specify only the Log and MachineName.

Note If you do not specify a MachineName, the local computer (".") will be assumed.

You do not need to create an instance of EventLog to use the methods CreateEventSource, Delete, DeleteEventSource, Exists, GetEventLogs, or SourceExists. These are all static (in Visual Basic Shared) members, so they are called on the EventLog class itself, for example, EventLog.Delete(myLog).

When an instance of EventLog is created, the following read/write properties are set to initial values.

Property | Initial Value
Source | An empty string ("")
Log | An empty string
MachineName | The local computer (".")

You can change the value for any of these properties through a separate call to the property.

Example [Visual Basic]

The following example connects to an event log, "myNewLog", on the local computer. If the source "myNewSource" does not already exist on the computer, it is created. Then, an entry is written to the Log.

Note that the way to create a new event log is through the static (Shared) member CreateEventSource, which creates a Source and registers it to the Log at the time the log is created. Because this is a static (Shared) member of EventLog, it should be called on the class itself rather than on an instance of the class.

Import the System.Diagnostics namespace for this example.

[Visual Basic]

Private Sub ConnectToEventLog()
    'Declare a new event log and event log entry.
    Dim evtLog As EventLog

    'Instantiate a new event log.
    evtLog = New EventLog

    'Otherwise, create a new source and log.
    If Not EventLog.SourceExists("MyNewSource") Then
        'If MyNewLog does not exist, it will be created
        EventLog.CreateEventSource("MyNewSource", "MyNewLog")
    End If

    'Connect the source to the event instance.
    evtLog.Source = "MyNewSource"

    'Write an entry to the event log.
    evtLog.WriteEntry("My entry.")
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | EventLog Constructor Overload List | Source | Log | MachineName | Entries | Clear | Close | WriteEntry | EventLogEntry


EventLog Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal logName As String _
)
[C#]
public EventLog(
   string logName
);
[C++]
public: EventLog(
   String* logName
);
[JScript]
public function EventLog(
   logName : String
);

Parameters

logName
[To be supplied.]

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | EventLog Constructor Overload List


EventLog Constructor (String, String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal logName As String, _
   ByVal machineName As String _
)
[C#]
public EventLog(
   string logName,
   string machineName
);
[C++]
public: EventLog(
   String* logName,
   String* machineName
);
[JScript]
public function EventLog(
   logName : String,
   machineName : String
);

Parameters

logName
[To be supplied.]
machineName
[To be supplied.]

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | EventLog Constructor Overload List


EventLog Constructor (String, String, String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal logName As String, _
   ByVal machineName As String, _
   ByVal source As String _
)
[C#]
public EventLog(
   string logName,
   string machineName,
   string source
);
[C++]
public: EventLog(
   String* logName,
   String* machineName,
   String* source
);
[JScript]
public function EventLog(
   logName : String,
   machineName : String,
   source : String
);

Parameters

logName
[To be supplied.]
machineName
[To be supplied.]
source
[To be supplied.]

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | EventLog Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EventLog Properties

The properties of the EventLog class are listed below. For a complete list of EventLog class members, see the EventLog Members topic.

Public:

Entries | Gets the contents of the event log.
Log | Gets or sets the name of the log to read from and write to.
MachineName | Gets or sets the name of the computer on which to read or write events.
Monitoring | [To be supplied.]
Site (inherited from Component) | Gets or sets the site of the Component.
Source | Gets or sets the application name (source name) to register and use when writing to the event log.
SynchronizingObject | Represents the object used to marshal the event handler calls issued as a result of an EventLog change.

See Also

EventLog Class | System.Diagnostics Namespace


EventLog.Entries

Gets the contents of the event log.

[Visual Basic]
Overridable Public ReadOnly Property Entries As _
   EventLog.EventLogEntryCollection
[C#]
public EventLog.EventLogEntryCollection Entries {virtual get;}
[C++]
public: __property virtual EventLog.EventLogEntryCollection*
   get_Entries();
[JScript]
public function get Entries() : EventLog.EventLogEntryCollection;

Property Value

An EventLog.EventLogEntryCollection that holds the EventLogEntry items in the event log.

Remarks

Use the Entries member when reading from the event log.

Because the property is read-only, you can't modify an entry or write to the log using Entries. Instead, specify a Source and call WriteEntry to write a new log entry. You can use Entries to count the number of entries in the event log, and view all entries or an EventLogEntry in the collection. Use the indexed Item property (EventLogEntryCollection indexer)member to retrieve information about a specific entry, such as Message, Category, TimeWritten and EntryType.

It is not necessary to specify a Source when only reading from a log. You can specify only the Log name and MachineName (server computer name) for the EventLog instance. In either case, the Entries member is automatically populated with the event log's list of entries. You can select the appropriate index for an item in this list to read individual entries.

An important distinction between reading and writing log entries is that it is not necessary to explicitly call a read method. Once the Log and MachineName are specified, the Entries property is automatically populated.

Note You are not explicitly required to specify the MachineName if you are connecting to a log by specifying a Log/ MachineName pair. If you do not specify the MachineName, the local computer, ".", is assumed.

Example [Visual Basic]

The following example uses the Log and MachineName of an EventLog to connect to an event log. Then it displays the Entries in the log.

Because the procedure reads rather than writes entries, it is only necessary to set the Log and MachineName. The Source is only necessary for WriteEntry. Alternately, you can leave the MachineName empty and the local computer will be assumed.

This example assumes you already have a custom event log "myNewLog" on the computer named "myComputer".

Import the System.Diagnostics namespace for this example.

[Visual Basic]

Private Sub GetLogEntries()
    'Declare a new event log
    Dim evtLog As EventLog
    'This is used in the for loop iterating through the evtLog.Entries
    Dim entry As EventLogEntry

    'Instantiate an event log.
    evtLog = New EventLog
    'Set the server and log names so we can read from the log.
    evtLog.MachineName = "myComputer"
    evtLog.Log = "myNewLog"

    'Display the entries in order to the screen.
    For Each entry In evtLog.Entries
        Console.WriteLine("Message: " + entry.Message)
    Next
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | EventLog.EventLogEntryCollection | EventLogEntry | Source | Log | MachineName | WriteEntry


EventLog.Log

Gets or sets the name of the log to read from and write to.

[Visual Basic]
Overridable Public Property Log As String
[C#]
public string Log {virtual get; virtual set;}
[C++]
public: __property virtual String* get_Log();
public: __property virtual void set_Log(String*);
[JScript]
public function get Log() : String;
public function set Log(String);

Property Value

The name of the log. This can be "Application", "System", "Security", an application-specific log or a custom log name. The default is an empty string ("").

Remarks

Three log files exist by default on the server: Application, System, and Security. Applications and services use the Application log file. Device drivers use the System log file. The system generates success and failure audit events in the Security log when auditing is turned on. If you have other applications installed, like Active Directory on Windows 2000, there may be other default log files. In addition, you can create custom log files on a local or remote computer. Custom logs help you organize your entries in a more granular way than is allowed when your components write events to the default Application log.

If you write to an event log, it is not enough to specify the Log property. You must associate a Source with your event log object in order to connect it to a particular log in the Windows 2000 event logs. It is not necessary to specify a Source when only reading from a log. You can specify only the Log name and MachineName (server computer name).

Note You are not explicitly required to specify the MachineName if you are connecting to a log by specifying a Log/ MachineName pair. If you do not specify the MachineName, the local computer (".") is assumed.

If the Source property has not been specified, a call to Log returns an empty string if Log has not been explicitly set to another value. If the Source has been specified, Log returns the name of the log to which that source has been registered.

A source can only be registered to one log at a time. If the Source property has been set for an instance of EventLog, you can't subsequently change the Log property for that EventLog without changing the value of Source or calling DeleteEventSource first. Attempting to change the Log property once the Source property has been set will throw an exception.

There is no way, using methods in EventLog, to create a new log using the Log property alone (that is, without specifying a Source for the Log). You can call CreateEventSource, passing in a new log name as a parameter and then call DeleteEventSource. However, when used in applications, the intent is usually either to create (and write entries to) new application-specific logs, or to read from existing logs.

The Log value cannot be an empty string if Source has not been set. If the Log value changes, the event log is closed and all event handles are released.

Example [Visual Basic]

The following example uses the Log and MachineName of an EventLog to connect to an event log. Then it displays the Entries in the log.

Because the procedure reads rather than writes entries, it is only necessary to set the Log and MachineName. The Source is only necessary for WriteEntry. Alternately, you can leave the MachineName empty and the local computer will be assumed.

This example assumes you already have a custom event log "myNewLog" on the computer named "myComputer".

Import the System.Diagnostics namespace for this example.

[Visual Basic]

Private Sub GetLogEntries()
    'Declare a new event log
    Dim evtLog As EventLog
    'This is used in the for loop iterating through the evtLog.Entries
    Dim entry As EventLogEntry

    'Instantiate an event log.
    evtLog = New EventLog
    'Set the server and log names so we can read from the log.
    evtLog.MachineName = "myComputer"
    evtLog.Log = "myNewLog"

    'Display the entries in order to the screen.
    For Each entry In evtLog.Entries
        Console.WriteLine("Message: " + entry.Message)
    Next
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | MachineName | Source | Entries | Exists | Delete | CreateEventSource | EventLog.EventLogEntryCollection


EventLog.MachineName

Gets or sets the name of the computer on which to read or write events.

[Visual Basic]
Overridable Public Property MachineName As String
[C#]
public string MachineName {virtual get; virtual set;}
[C++]
public: __property virtual String* get_MachineName();
public: __property virtual void set_MachineName(String*);
[JScript]
public function get MachineName() : String;
public function set MachineName(String);

Property Value

The name of the server on which the event log resides. The default is the local computer (".").

Exceptions

Exception Type | Condition
ArgumentException | The computer name is invalid.

Remarks

If you write to an event log, you must associate a Source with your event log object in order to connect it to a particular log in the Windows 2000 event logs. It is not necessary to specify a Source when only reading from a log. You can specify only the Log name and MachineName (server computer name).

Note You are not explicitly required to specify the MachineName if you are connecting to a log by specifying a Log/ MachineName pair. If you do not specify the MachineName, the local computer (".") is assumed.

A source can only be registered to one log at a time. If the Source property has been set for an instance of EventLog, you can't subsequently change the MachineName property for that EventLog without changing the value of Source or calling DeleteEventSource first. If you change the MachineName property, the EventLog closes all handles and reattach to the log and source on the new computer.

The MachineName value cannot be set to an empty string. However, if it is not explicitly set, it defaults to the local computer ("."). If the MachineName value changes, the event log is closed and all event handles are released.

Example [Visual Basic]

The following example uses the Log and MachineName of an EventLog to connect to an event log. Then it displays the Entries in the log.

Because the procedure reads rather than writes entries, it is only necessary to set the Log and MachineName. The Source is only necessary for WriteEntry. Alternately, you can leave the MachineName empty and the local computer will be assumed.

This example assumes you already have a custom event log "myNewLog" on the computer named "myComputer".

Import the System.Diagnostics namespace for this example.

[Visual Basic]

Private Sub GetLogEntries()
    'Declare a new event log
    Dim evtLog As EventLog
    'This is used in the for loop iterating through the evtLog.Entries
    Dim entry As EventLogEntry

    'Instantiate an event log.
    evtLog = New EventLog
    'Set the server and log names so we can read from the log.
    evtLog.MachineName = "myComputer"
    evtLog.Log = "myNewLog"

    'Display the entries in order to the screen.
    For Each entry In evtLog.Entries
        Console.WriteLine("Message: " + entry.Message)
    Next
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | Log | Source | CreateEventSource | DeleteEventSource | Delete | SourceExists | Exists | GetEventLogs


EventLog.Monitoring

[To be supplied.]

[Visual Basic]
Public Property Monitoring As Boolean
[C#]
public bool Monitoring {get; set;}
[C++]
public: __property bool get_Monitoring();
public: __property void set_Monitoring(bool);
[JScript]
public function get Monitoring() : Boolean;
public function set Monitoring(Boolean);

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace


EventLog.Source

Gets or sets the application name (source name) to register and use when writing to the event log.

[Visual Basic]
Overridable Public Property Source As String
[C#]
public string Source {virtual get; virtual set;}
[C++]
public: __property virtual String* get_Source();
public: __property virtual void set_Source(String*);
[JScript]
public function get Source() : String;
public function set Source(String);

Property Value

The application name registered with the event log as a valid source of entries. The default is an empty string ("").

Remarks

The event Source is the name of the software that logs the event. It is often the name of the application, or the name of a subcomponent of the application, if the application is large. Applications and services should write to the Application log or a custom log. Device drivers should add their names to the System log.

If you write to an event log, you must specify or create an event Source. The Source, which can only be used to write to a single log at a time, registers your application with the event log as a valid source of entries. The Source can be any random string, but the name cannot be used by other sources on the computer; an attempt to create a duplicated Source value will throw an exception. However, a single event log can have many different sources writing to it.

Note Source names cannot be hierarchical. That is, you cannot use the backslash "\" character.

It is not necessary to specify a Source when only reading from a log. You can specify only the Log name and MachineName (server computer name) for the EventLog instance. In either case, the Entries member is automatically populated with the event log's list of entries. You can select the appropriate index for an item in this list to read individual entries.

Note You are not explicitly required to specify the MachineName if you are connecting to a log by specifying a Log/ MachineName pair. If you do not specify the MachineName, the local computer (".") is assumed.

The Source value can be an empty string, particularly if you are only reading from the event log. If the Source value changes, the event log to which it is registered is closed and all event handles are released.

If you do not specify a log name when calling CreateEventSource, your source will be registered to the Application log. If you specify the name of a log that doesn't exist, the system creates a custom event log for you and registers the Source to that log.

When you write a log entry using WriteEntry, the system uses the source you identified to find the appropriate log in which to place your entry.

Note If you try to call WriteEntry without first having registered the value specified by your EventLog instance's Source parameter as a valid source, Visual Studio automatically registers your component, using the Source value as the source string.

Example [Visual Basic]

The following example connects to an event log, "myNewLog", on the local computer. If the source "myNewSource" does not already exist on the computer, it is created. Then, an entry is written to the Log.

Note that the way to create a new event log is through the static (in Visual Basic Shared) member CreateEventSource, which creates a Source and registers it to the Log at the time the log is created. Because this is a static (Shared) member of EventLog, it should be called on the class itself rather than on an instance of the class.

Import the System.Diagnostics namespace for this example.

[Visual Basic]

Private Sub ConnectToEventLog()
    'Declare a new event log and event log entry.
    Dim evtLog As EventLog
    'Used in a for loop iterating through entries()
    Dim i As Integer

    'Instantiate a new event log.
    evtLog = New EventLog

    'Otherwise, create a new source and log.
    If Not EventLog.SourceExists("myNewSource") Then
        'If MyNewLog does not exist, it will be created
        EventLog.CreateEventSource("myNewSource", "myNewLog")
    End If

    'Connect the source to the event instance.
    evtLog.Source = "myNewSource"

    'Write an entry to the event log.
    evtLog.WriteEntry("My entry.")
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | Log | MachineName | CreateEventSource | DeleteEventSource | SourceExists


EventLog.SynchronizingObject

Represents the object used to marshal the event handler calls issued as a result of an EventLog change.

[Visual Basic]
Public Property SynchronizingObject As ISynchronizeInvoke
[C#]
public ISynchronizeInvoke SynchronizingObject {get; set;}
[C++]
public: __property ISynchronizeInvoke* get_SynchronizingObject();
public: __property void set_SynchronizingObject(ISynchronizeInvoke*);
[JScript]
public function get SynchronizingObject() : ISynchronizeInvoke;
public function set SynchronizingObject(ISynchronizeInvoke);

Property Value

The ISynchronizeInvoke that is used to marshal the event handler calls issued as a result of an System.Diagnostics.EventLog.EntryWritten event on the event log.

Remarks

Normally this property will be set when the component is placed inside a control or a from, since those components are bound to a specific thread.

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EventLog Methods

The methods of the EventLog class are listed below. For a complete list of EventLog class members, see the EventLog Members topic.

Public:

BeginInit | [To be supplied.]
Clear | Clears the event log by removing all entries from it.
Close | Closes the event log and releases read and write handles.
CreateEventSource | Overloaded. Establishes an application as an event source.
Delete | Overloaded. Removes a log resource.
DeleteEventSource | Overloaded. Removes an application's event source registration from the event log.
Dispose | Frees all resources held by the EventLog.
EndInit | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Exists | Overloaded. Determines whether the specified log exists.
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetEventLogs | Overloaded. Creates an array of the event logs.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
SourceExists | Overloaded. Searches a computer's registry for a given event source.
StartMonitoring | [To be supplied.]
StopMonitoring | [To be supplied.]
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
WriteEntry | Overloaded. Logs an entry in the event log.

Protected:

Finalize | Called when the object is about to be reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Event Hookup:

AddOnEntryWritten | Adds an event handler for the System.Diagnostics.EventLog.EntryWritten event.
RemoveOnEntryWritten | Deregisters an event handler from monitoring for the arrival of events.

See Also

EventLog Class | System.Diagnostics Namespace


EventLog.AddOnEntryWritten

Adds an event handler for the System.Diagnostics.EventLog.EntryWritten event.

[Visual Basic]
Overridable Public Sub AddOnEntryWritten( _
   ByVal handler As EventLogEventHandler _
)
[C#]
public virtual void AddOnEntryWritten(
   EventLogEventHandler handler
);
[C++]
public: virtual void AddOnEntryWritten(
   EventLogEventHandler* handler
);
[JScript]
public function AddOnEntryWritten(
   handler : EventLogEventHandler
);

Parameters

handler
An EventLogEventHandler delegate that represents the method that will handle the System.Diagnostics.EventLog.EntryWritten event.

Exceptions

Exception Type | Condition
ArgumentException | The handler parameter is a null reference (Visual Basic Nothing). The handler might not have been initialized.
ArgumentException | A value is not specified for the Log property. Make sure the log name is not an empty string.
SystemException | The method cannot create a system event to notify the log to start monitoring for events.
Exception | The log cannot be opened. No Windows error code is available.
Win32Exception | The log cannot be opened. A Windows error code is available.

Remarks

This method causes the handler to start accepting events being posted to the active log.

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace


EventLog.BeginInit

[To be supplied.]

[Visual Basic]
Overridable Public Sub BeginInit()
[C#]
public virtual void BeginInit();
[C++]
public: virtual void BeginInit();
[JScript]
public function BeginInit();

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace


EventLog.Clear

Clears the event log by removing all entries from it.

[Visual Basic]
Overridable Public Sub Clear()
[C#]
public virtual void Clear();
[C++]
public: virtual void Clear();
[JScript]
public function Clear();

Exceptions

Exception Type | Condition
Win32Exception | The event log was not cleared successfully.
ArgumentException | A value is not specified for the Log property. Make sure the log name is not an empty string.
Exception | The log cannot be opened. No Windows error code is available.
Win32Exception | The log cannot be opened. A Windows error code is available.

Remarks

Event logs are set with a maximum size that determines how many entries they can contain. When an event log is full, it stops recording new event information. You can clear the log of its existing entries to free the log and allow it to start recording events again. You must have administrator rights to the computer on which the log resides in order to clear event log entries.

Clear closes the event log and releases the event handles, retrieves new read and write handles, and opens the event log back into the previous state. Events that are received after the call to the method will not be cleared along with the existing events.

Example [Visual Basic]

The following example clears an event log.

This example assumes that there is a Source on the local computer named "mySource".

Import the System.Diagnostics namespace for this example.

CAUTION Because Application, System, Security, and other non-custom logs can contain crucial information, make sure "mySource" registered to a custom log before executing this sample code.

[Visual Basic]

Private Sub ClearLog()
    Dim evtLog As EventLog
    evtLog = New EventLog
    Dim eventSource As String
    eventSource = "mySource"

    'Check that the source exists for the log.
    If EventLog.SourceExists(eventSource) Then
        'Connect the eventSource parameter to the event log.
        evtLog.Source = eventSource
        'Clear the log.
        evtLog.Clear()
    End If
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | Close | Delete


EventLog.Close

Closes the event log and releases read and write handles.

[Visual Basic]
Overridable Public Sub Close()
[C#]
public virtual void Close();
[C++]
public: virtual void Close();
[JScript]
public function Close();

Exceptions

Exception Type | Condition
Win32Exception | The event log's read handle or write handle was not released successfully.

Remarks

Call Close before calling Delete on the event log.

The Close method is automatically called by the Dispose method. You do not need to invoke Close explicitly before calling Dispose.

Example [Visual Basic]

following example closes an event log specified by the source "mySource", and deletes the source. This does not delete the log to which the source is registered (use Delete for that), only the source and its registration. The log can be opened again by creating another source with CreateEventSource and registering it to the log.

The local event log instance is created only in order to call Close on the log. All other methods used are static (in Visual Basic Shared) and should be called on the EventLog class itself.

Import the System.Diagnostics namespace for this example.

[Visual Basic]

Private Sub CloseLog()
    'Declare and instantiate an event log.
    Dim evtLog As EventLog
    evtLog = New EventLog
    'Declare a source called "mySource"
    Dim source As String
    source = "mySource"

    'Verify that the source exists.
    If EventLog.SourceExists(source) Then
        'Connect the event log to the source.
        evtLog.Source = source
        'Close the log so that it does not receive new entries.
        evtLog.Close()
        EventLog.DeleteEventSource(source)
    End If
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | Delete | Clear | Dispose


EventLog.CreateEventSource

Establishes an application as an event source.

Overload List

Establishes an application as an event source with the specified Source. Registers the source to a Log that resides on the computer specified by machineName. This method can also be used to create a new custom log on the given computer.

[Visual Basic] Overloads Public Shared Sub CreateEventSource(String, String, String)
[C#] public static void CreateEventSource(String, String, String);
[C++] public: static void CreateEventSource(String*, String*, String*);
[JScript] public static function CreateEventSource(String, String, String);

Establishes an application as an event source with the specified Source. Registers the source to a Log that resides on the local computer. This method can also be used to create a new custom log on the local computer.

[Visual Basic] Overloads Public Shared Sub CreateEventSource(String, String)
[C#] public static void CreateEventSource(String, String);
[C++] public: static void CreateEventSource(String*, String*);
[JScript] public static function CreateEventSource(String, String);

Example [Visual Basic]

The following example connects to an event log, "myNewLog", on the local computer. If the source "myNewSource" does not already exist on the computer, it is created. Then, an entry is written to the Log.

Note that the way to create a new event log is through the static (in Visual Basic Shared) member CreateEventSource, which creates a Source and registers it to the Log at the time the log is created. Because this is a static (Shared) member of EventLog, it should be called on the class itself rather than on an instance of the class.

Import the System.Diagnostics namespace for this example.

Note This example shows how to use one of the overloaded versions of CreateEventSource. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub ConnectToEventLog()
    'Declare a new event log and event log entry.
    Dim evtLog As EventLog

    'Instantiate a new event log.
    evtLog = New EventLog

    'Otherwise, create a new source and log.
    If Not EventLog.SourceExists("myNewSource") Then
        'If MyNewLog does not exist, it will be created
        EventLog.CreateEventSource("myNewSource", "myNewLog")
    End If

    'Connect the source to the event instance.
    evtLog.Source = "myNewSource"

    'Write an entry to the event log.
    evtLog.WriteEntry("Event log entry.")
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace


EventLog.CreateEventSource (String, String, String)

Establishes an application as an event source with the specified Source. Registers the source to a Log that resides on the computer specified by machineName. This method can also be used to create a new custom log on the given computer.

[Visual Basic]
Overloads Public Shared Sub CreateEventSource( _
   ByVal source As String, _
   ByVal logName As String, _
   ByVal machineName As String _
)
[C#]
public static void CreateEventSource(
   string source,
   string logName,
   string machineName
);
[C++]
public: static void CreateEventSource(
   String* source,
   String* logName,
   String* machineName
);
[JScript]
public static function CreateEventSource(
   source : String,
   logName : String,
   machineName : String
);

Parameters

source
The name the application is registered with on the specified computer.
logName
The name of the log that the source's entries are written to. Possible values include: Application, Security, System, or a custom event log. If you do not specify a value, the logName defaults to Application.
machineName
The name of the computer to register this event source with, or "." for the local computer.

Exceptions

Exception Type | Condition
ArgumentException | The machineName parameter is invalid.
ArgumentException | The source parameter is a null reference (in Visual Basic Nothing) or is an empty string ("").
ArgumentException | The source can't be registered because it already exists on the specified computer.
Exception | The application can't open the registry key for the source on the specified computer.

Remarks

Use CreateEventSource both to create a Source and register it to a new or existing log, and also to create a new custom log. Use this overload to create a custom log or to create and register a Source to a log on any server on the network.

If you do not specify a logname when calling CreateEventSource, it defaults to Application. If the Log does not exist on the specified computer, the system creates a custom log and registers your application as a Source for that log.

You only need to create an event source if you are writing to the event log. Before your component can write an entry to an event log, you must register it with the event log as a valid source of events. When you write a log entry using WriteEntry, the system uses the Source to find the appropriate log in which to place your entry. If you are reading the event log, you may either specify the Source, or you may specify a Log/ MachineName pair.

Note If you do not specify a MachineName when reading from a log, the local computer (".") will be assumed.

The source parameter can be any string, although often it will be the name of your application or a component of your application. The source must be unique on the server specified by the machineName parameter. However, a single event log can have many different sources writing to it at once.

Calling this method is optional; if you do not, it is called the first time you use WriteEntry.

Example [Visual Basic]

The following example connects to an event log, "myNewLog", on the computer "myComputer". If the source "myNewSource" does not already exist on the computer, it is created. Then, an entry is written to the Log.

Note that the way to create a new event log is through the static (in Visual Basic Shared) member CreateEventSource, which creates a Source and registers it to the Log at the time the log is created. Because this is a static (Shared) member of EventLog, it should be called on the class itself rather than on an instance of the class.

Import the System.Diagnostics namespace for this example.

[Visual Basic]

Private Sub ConnectToEventLog()
    'Declare a new event log and event log entry.
    Dim evtLog As EventLog

    'Instantiate a new event log.
    evtLog = New EventLog

    'Otherwise, create a new source and log.
    If Not EventLog.SourceExists("myNewSource", "myComputer") Then
        'If MyNewLog does not exist, it will be created
        EventLog.CreateEventSource("myNewSource", "myComputer", "myNewLog")
    End If

    'Connect the source to the event instance.
    evtLog.Source = "myNewSource"

    'Write an entry to the event log.
    evtLog.WriteEntry("Event log entry.")
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | EventLog.CreateEventSource Overload List | DeleteEventSource


EventLog.CreateEventSource (String, String)

Establishes an application as an event source with the specified Source. Registers the source to a Log that resides on the local computer. This method can also be used to create a new custom log on the local computer.

[Visual Basic]
Overloads Public Shared Sub CreateEventSource( _
   ByVal source As String, _
   ByVal logName As String _
)
[C#]
public static void CreateEventSource(
   string source,
   string logName
);
[C++]
public: static void CreateEventSource(
   String* source,
   String* logName
);
[JScript]
public static function CreateEventSource(
   source : String,
   logName : String
);

Parameters

source
The name the application is registered with on the local computer.
logName
The name of the log that the source's entries are written to. Possible values include: Application, Security, System, or a custom event log. If you do not specify a value, the logName defaults to Application.

Exceptions

Exception Type | Condition
ArgumentException | The source parameter is a null reference (in Visual Basic Nothing) or is an empty string ("").
ArgumentException | The source can't be registered because it already exists on the local computer.
Exception | The application can't open the registry key for the source on the local computer.

Remarks

Use CreateEventSource both to create a Source and register it to a new or existing log, and also to create a new custom log. Use this overload to create a custom log or to create and register a Source to an existing log on the local computer.

If you do not specify a logname when calling CreateEventSource, it defaults to Application. If the Log does not exist on the local computer, the system creates a custom log and registers your application as a Source for that log.

You only need to create an event source if you are writing to the event log. Before you can write an entry to an event log, you must register it with the event log as a valid source of events. When you write a log entry using WriteEntry, the system uses the Source to find the appropriate log in which to place your entry. If you are reading the event log, you may either specify the Source, or a Log/ MachineName pair.

Note If you do not specify a MachineName when reading from a log, the local computer (".") will be assumed.

The source parameter can be any string, although often it will be the name of your application or a component of your application. The source must be unique on the local computer. However, a single event log can have many different sources writing to it at once.

Calling this method is optional; if you do not, it is called the first time you call WriteEntry.

Example [Visual Basic]

The following example connects to an event log, "myNewLog", on the local computer. If the source "myNewSource" does not already exist on the computer, it is created. Then, an entry is written to the Log.

Note that the way to create a new event log is through the static (in Visual Basic Shared) member CreateEventSource, which creates a Source and registers it to the Log at the time the log is created. Because this is a static (Shared) member of EventLog, it should be called on the class itself rather than on an instance of the class.

Import the System.Diagnostics namespace for this example.

[Visual Basic]

Private Sub ConnectToEventLog()
    'Declare a new event log and event log entry.
    Dim evtLog As EventLog

    'Instantiate a new event log.
    evtLog = New EventLog

    'Otherwise, create a new source and log.
    If Not EventLog.SourceExists("myNewSource") Then
        'If MyNewLog does not exist, it will be created
        EventLog.CreateEventSource("myNewSource", "myNewLog")
    End If

    'Connect the source to the event instance.
    evtLog.Source = "myNewSource"

    'Write an entry to the event log.
    evtLog.WriteEntry("Event log entry.")
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | EventLog.CreateEventSource Overload List | DeleteEventSource | SourceExists | Source | Log | Delete


EventLog.Delete

Removes a log resource.

Overload List

Removes an event log from the specified computer.

[Visual Basic] Overloads Public Shared Sub Delete(String, String)
[C#] public static void Delete(String, String);
[C++] public: static void Delete(String*, String*);
[JScript] public static function Delete(String, String);

Removes an event log from the local computer.

[Visual Basic] Overloads Public Shared Sub Delete(String)
[C#] public static void Delete(String);
[C++] public: static void Delete(String*);
[JScript] public static function Delete(String);

Example [Visual Basic]

The following example deletes a log from the local computer. The example verifies whether "myLog" exists on the local computer before removing the log.

Import the System.Diagnostics namespace for this example.

Note This example shows how to use one of the overloaded versions of Delete. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub DeleteLog()
    'Declare an event log name
    Dim eventLogName As String
    eventLogName = "myLog"

    'If the event log passed in exists on the server, delete it.
    If EventLog.Exists(eventLogName) Then
        EventLog.Delete(eventLogName)
    End If
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace


EventLog.Delete (String, String)

Removes an event log from the specified computer.

[Visual Basic]
Overloads Public Shared Sub Delete( _
   ByVal logName As String, _
   ByVal machineName As String _
)
[C#]
public static void Delete(
   string logName,
   string machineName
);
[C++]
public: static void Delete(
   String* logName,
   String* machineName
);
[JScript]
public static function Delete(
   logName : String,
   machineName : String
);

Parameters

logName
The name of the log to delete. Possible values include: Application, Security, System, and any custom event logs on the specified computer.
machineName
The name of the computer to delete the log from, or "." for the local computer.

Exceptions

Exception Type | Condition
ArgumentException | The computer name format is invalid.
ArgumentException | The log name is a null reference (in Visual Basic Nothing) or is an empty string ("").
SystemException | There is not an event log service or you don't have access to read the registry.
SystemException | The log was not found.

Remarks

Use this method when the log you want to delete is on a remote computer. You can delete any log on the computer, provided you have the appropriate registry rights.

Delete removes the log specified by logName from the computer specifed by machineName. If you want to delete only the source registered to a log, call DeleteEventSource. If you only want to delete the log entries, call Clear. Delete and DeleteEventSource are static (in Visual Basic Shared) methods, so they can be called on the class itself. It is not necessary to instantiate EventLog to call either method.

This method first deletes the file holding the contents of the log. It then accesses the registry and removes all of the event sources that were registered for that log. Even if you re-create the log at a later point, you will not be able to re-register the event sources, so some applications that previously were able to write entries to that log will not be able to write to the new log.

Note Recreating an event log can be a difficult process. It is good practice to not delete any of the system-created event logs, such as the Application log.

Example [Visual Basic]

The following example deletes a log from the computer "myComputer". The example verifies whether "myLog" exists on the computer before removing the log.

Import the System.Diagnostics namespace for this example.

[Visual Basic]

Private Sub DeleteLog()
    'Declare an event log name
    Dim eventLogName As String
    eventLogName = "myLog"
    Dim computer As String
    computer = "myComputer"

    'If the event log passed in exists on the server, delete it.
    If EventLog.Exists(eventLogName, computer) Then
        EventLog.Delete(eventLogName, computer)
    End If
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | EventLog.Delete Overload List | Clear


EventLog.Delete (String)

Removes an event log from the local computer.

[Visual Basic]
Overloads Public Shared Sub Delete( _
   ByVal logName As String _
)
[C#]
public static void Delete(
   string logName
);
[C++]
public: static void Delete(
   String* logName
);
[JScript]
public static function Delete(
   logName : String
);

Parameters

logName
The name of the log to delete. Possible values include: Application, Security, System, and any custom event logs on the computer.

Exceptions

Exception Type | Condition
ArgumentException | The log name is a null reference (in Visual Basic Nothing) or is an empty string ("").
SystemException | There is no event log service or you don't have access to read the registry.
SystemException | The log was not found.

Remarks

Use this method when the log you want to delete is on the local computer. You can delete any log on the computer, provided you have the appropriate registry rights.

Delete removes the log specified by logName from the local computer. If you want to delete only the source registered to a log, call DeleteEventSource. If you only want to delete the log entries, call Clear. Delete and DeleteEventSource are static (in Visual Basic Shared) methods, so they can be called on the class itself. It is not necessary to instantiate EventLog to call either method.

This method first deletes the file holding the contents of the log. It then accesses the registry and removes all of the event sources that were registered for that log. Even if you re-create the log at a later point, you will not be able to re-register the event sources, so some applications that previously were able to write entries to that log will not be able to write to the new log.

Note Recreating an event log can be a difficult process. It is good practice to not delete any of the system-created event logs, such as the Application log.

Example [Visual Basic]

The following example deletes a log from the local computer. The example verifies whether "myLog" exists on the local computer before removing the log.

Import the System.Diagnostics namespace for this example.

[Visual Basic]

Private Sub DeleteLog()
    'Declare an event log name
    Dim eventLogName As String
    eventLogName = "myLog"

    'If the event log passed in exists on the server, delete it.
    If EventLog.Exists(eventLogName) Then
        EventLog.Delete(eventLogName)
    End If
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | EventLog.Delete Overload List | Clear | Close | DeleteEventSource


EventLog.DeleteEventSource

Removes an application's event source registration from the event log.

Overload List

Removes the application's event source registration from the specified computer.

[Visual Basic] Overloads Public Shared Sub DeleteEventSource(String, String)
[C#] public static void DeleteEventSource(String, String);
[C++] public: static void DeleteEventSource(String*, String*);
[JScript] public static function DeleteEventSource(String, String);

Removes the event source registration from the event log of the local computer.

[Visual Basic] Overloads Public Shared Sub DeleteEventSource(String)
[C#] public static void DeleteEventSource(String);
[C++] public: static void DeleteEventSource(String*);
[JScript] public static function DeleteEventSource(String);

Example [Visual Basic]

The following example closes an event log specified by the source "mySource", and deletes the source. This does not delete the log to which the source is registered (use Delete for that), only the source and its registration. The log can be opened again by creating another source using CreateEventSource and registering it to the log.

The local event log instance is created only in order to call Close on the log. All other methods used are static (in Visual Basic Shared) and should be called on the EventLog class itself.

Import the System.Diagnostics namespace for this example.

Note This example shows how to use one of the overloaded versions of DeleteEventSource. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub CloseLog()
    'Declare and instantiate an event log.
    Dim evtLog As EventLog
    evtLog = New EventLog
    'Declare a source called "mySource"
    Dim source As String
    source = "mySource"

    'Verify that the source exists.
    If EventLog.SourceExists(source) Then
        'Connect the event log to the source.
        evtLog.Source = source
        'Close the log so that it does not receive new entries.
        evtLog.Close()
        EventLog.DeleteEventSource(source)
    End If
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace


EventLog.DeleteEventSource (String, String)

Removes the application's event source registration from the specified computer.

[Visual Basic]
Overloads Public Shared Sub DeleteEventSource( _
   ByVal source As String, _
   ByVal machineName As String _
)
[C#]
public static void DeleteEventSource(
   string source,
   string machineName
);
[C++]
public: static void DeleteEventSource(
   String* source,
   String* machineName
);
[JScript]
public static function DeleteEventSource(
   source : String,
   machineName : String
);

Parameters

source
The name the application is registered with in the event log system.
machineName
The name of the computer to remove the registration from, or a null reference (in Visual Basic Nothing) for the local computer.

Exceptions

Exception Type | Condition
ArgumentException | The machineName parameter is invalid.
ArgumentException | The source parameter does not exist in the registry of the specified computer.
ArgumentException | You do not have write access on the registry key for the event log.

Remarks

Use this overload to remove the registration of a Source from a remote computer. DeleteEventSource accesses the registry on the computer specified by machineName and removes the registration of your application as a valid source of events.

You can remove your component as a valid source of events if you no longer need to use it to write entries to that log. You might do this if you were changing your component from one log to another. Because a source can only be registered to one log at a time, changing the log requires removing the current registration.

DeleteEventSource removes only the source registered to a log. If you want to remove the log itself, call Delete. If you only want to delete the log entries, call Clear. Delete and DeleteEventSource are static (in Visual Basic Shared) methods, so they can be called on the class itself. It is not necessary to instantiate EventLog to call either method.

Deleting a log through a call to Delete does not automatically delete the sources registered to that log. If you want to delete a log, you should first call DeleteEventSource separately for all sources registered to the log.

Example [Visual Basic]

The following example closes an event log specified by the source "mySource" on the computer "myComputer", and deletes the source. This does not delete the log to which the source is registered (use Delete for that), only the source and its registration. The log can be opened again by creating another source using CreateEventSource and registering it to the log.

The local event log instance is created only in order to call Close on the log. All other methods used are static (Shared) and should be called on the EventLog class itself.

Import the System.Diagnostics namespace for this example.

[Visual Basic]

Private Sub CloseLog()
    'Declare and instantiate an event log.
    Dim evtLog As EventLog
    evtLog = New EventLog
    'Declare a source called "mySource"
    Dim source As String
    source = "mySource"
    'Declare a computer called "myComputer"
    Dim computer As String
    computer = "myComputer"

    'Verify that the source exists.
    If EventLog.SourceExists(source, computer) Then
        'Connect the event log to the source.
        evtLog.Source = source
        'Close the log so that it does not receive new entries.
        evtLog.Close()
        EventLog.DeleteEventSource(source, computer)
    End If
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | EventLog.DeleteEventSource Overload List | CreateEventSource | Source | SourceExists | Delete | Clear


EventLog.DeleteEventSource (String)

Removes the event source registration from the event log of the local computer.

[Visual Basic]
Overloads Public Shared Sub DeleteEventSource( _
   ByVal source As String _
)
[C#]
public static void DeleteEventSource(
   string source
);
[C++]
public: static void DeleteEventSource(
   String* source
);
[JScript]
public static function DeleteEventSource(
   source : String
);

Parameters

source
The name the application is registered with in the event log system.

Exceptions

Exception Type | Condition
ArgumentException | The source parameter does not exist in the registry of the local computer.
ArgumentException | You do not have write access on the registry key for the event log.

Remarks

Use this overload to remove the registration of a Source from the local computer. DeleteEventSource accesses the registry on the local computer and removes the registration of your application as a valid source of events.

You can remove your component as a valid source of events if you no longer need to use it to write entries to that log. You might do this if you were changing your component from one log to another. Because a source can only be registered to one log at a time, changing the log requires removing the current registration.

DeleteEventSource removes only the source registered to a log. If you want to remove the log itself, call Delete. If you only want to delete the log entries, call Clear. Delete and DeleteEventSource are static (in Visual Basic Shared) methods, so they can be called on the class itself. It is not necessary to instantiate EventLog to call either method.

Deleting a log through a call to Delete does not automatically delete the sources registered to that log. If you want to delete a log, you should first call DeleteEventSource separately for all sources registered to the log.

Example [Visual Basic]

The following example closes an event log specified by the source "mySource", and deletes the source. This does not delete the log to which the source is registered (use Delete for that), only the source and its registration. The log can be opened again by creating another source using CreateEventSource and registering it to the log.

The local event log instance is created only in order to call Close on the log. All other methods used are static (Shared) and should be called on the EventLog class itself.

Import the System.Diagnostics namespace for this example.

[Visual Basic]

Private Sub CloseLog()
    'Declare and instantiate an event log.
    Dim evtLog As EventLog
    evtLog = New EventLog
    'Declare a source called "mySource"
    Dim source As String
    source = "mySource"

    'Verify that the source exists.
    If EventLog.SourceExists(source) Then
        'Connect the event log to the source.
        evtLog.Source = source
        'Close the log so that it does not receive new entries.
        evtLog.Close()
        EventLog.DeleteEventSource(source)
    End If
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | EventLog.DeleteEventSource Overload List | CreateEventSource | Source | SourceExists | Delete | Clear


EventLog.Dispose

Frees all resources held by the EventLog.

[Visual Basic]
Overrides Public Sub Dispose()
[C#]
public override void Dispose();
[C++]
public: override void Dispose();
[JScript]
public override function Dispose();

Exceptions

Exception Type | Condition
Win32Exception | The event log's read handle or write handle was not released successfully.

Remarks

After closing the event log, this method releases read and write handles. Dispose closes the event log by calling Close, which can trigger exceptions that your calling method must handle.

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | Close | Dispose


EventLog.EndInit

[To be supplied.]

[Visual Basic]
Overridable Public Sub EndInit()
[C#]
public virtual void EndInit();
[C++]
public: virtual void EndInit();
[JScript]
public function EndInit();

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace


EventLog.Exists

Determines whether the specified log exists.

Overload List

Determines whether the log exists on the specified computer.

[Visual Basic] Overloads Public Shared Function Exists(String, String) As Boolean
[C#] public static bool Exists(String, String);
[C++] public: static bool Exists(String*, String*);
[JScript] public static function Exists(String, String) : Boolean;

Determines whether the log exists on the local computer.

[Visual Basic] Overloads Public Shared Function Exists(String) As Boolean
[C#] public static bool Exists(String);
[C++] public: static bool Exists(String*);
[JScript] public static function Exists(String) : Boolean;

Example [Visual Basic]

The following example determines if the log "myLog" exists on the local computer. If it does, it is deleted.

Import the System.Diagnostics namespace for this example.

Note This example shows how to use one of the overloaded versions of Exists. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub DeleteLog()
    'Declare an event log name
    Dim eventLogName As String
    eventLogName = "myLog"

    'If the event log passed in exists on the server, delete it.
    If EventLog.Exists(eventLogName) Then
        EventLog.Delete(eventLogName)
    End If
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace


EventLog.Exists (String, String)

Determines whether the log exists on the specified computer.

[Visual Basic]
Overloads Public Shared Function Exists( _
   ByVal logName As String, _
   ByVal machineName As String _
) As Boolean
[C#]
public static bool Exists(
   string logName,
   string machineName
);
[C++]
public: static bool Exists(
   String* logName,
   String* machineName
);
[JScript]
public static function Exists(
   logName : String,
   machineName : String
) : Boolean;

Parameters

logName
The log for which to search. Possible values include: Application, Security, System, other application-specific logs (such as those associated with Active Directory), or any custom log on the computer.
machineName
The name of the machine on which to search for the log, or "." for the local computer.

Return Value

true if the log exists on the specified computer; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentException | The machineName parameter is in an invalid format. Make sure you have used proper syntax for the computer on which you are searching. The logName is a null reference (in Visual Basic Nothing) or the value is empty.

Remarks

Use this overload to determine if a log exists on a remote computer. If you want to determine whether a source exists on a remote computer, use SourceExists.

This method looks in the registry; if you do not have the appropriate registry rights on the local computer, the query will return false.

Because a new log can't be given the name of an existing log on the same computer, use this method before creating a new log to determine if one with the specified logName already exists on the server specified by the machineName parameter. The logName and machineName parameters are not case sensitive.

Exists is a static (in Visual Basic Shared) method, so it can be called on the class itself. It is not necessary to instantiate EventLog to call Exists.

Example [Visual Basic]

The following example determines if the log "myLog" exists on the computer "myComputer". If it does, it is deleted.

Import the System.Diagnostics namespace for this example.

[Visual Basic]

Private Sub DeleteLog()
    'Declare an event log name
    Dim eventLogName As String
    eventLogName = "myLog"
    Dim computer As String
    computer = "myComputer"

    'If the event log passed in exists on the server, delete it.
    If EventLog.Exists(eventLogName, computer) Then
        EventLog.Delete(eventLogName, computer)
    End If
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | EventLog.Exists Overload List | CreateEventSource | Delete | SourceExists | Log | MachineName


EventLog.Exists (String)

Determines whether the log exists on the local computer.

[Visual Basic]
Overloads Public Shared Function Exists( _
   ByVal logName As String _
) As Boolean
[C#]
public static bool Exists(
   string logName
);
[C++]
public: static bool Exists(
   String* logName
);
[JScript]
public static function Exists(
   logName : String
) : Boolean;

Parameters

logName
The name of the log to search for. Possible values include: Application, Security, System, other application-specific logs (such as those associated with Active Directory), or any custom log on the computer.

Return Value

true if the log exists on the local computer; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentException | The logName is a null reference (in Visual Basic Nothing) or the value is empty.

Remarks

Use this overload to determine if a log exists on the local computer. If you want to determine whether a source exists on the local computer, use SourceExists.

This method looks in the registry; if you do not have the appropriate registry rights on the local computer, the query will return false.

Because a new log can't be given the name of an existing log on the same computer, use this method before creating a new log to determine if one with the specified logName already exists on the local computer. The logName parameter is not case sensitive.

Exists is a static (in Visual Basic Shared) method, so it can be called on the class itself. It is not necessary to instantiate EventLog to call Exists.

Example [Visual Basic]

The following example determines if the log "myLog" exists on the local computer. If it does, it is deleted.

Import the System.Diagnostics namespace for this example.

[Visual Basic]

Private Sub DeleteLog()
    'Declare an event log name
    Dim eventLogName As String
    eventLogName = "myLog"

    'If the event log passed in exists on the server, delete it.
    If EventLog.Exists(eventLogName) Then
        EventLog.Delete(eventLogName)
    End If
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | EventLog.Exists Overload List | CreateEventSource | Delete | SourceExists | Log


EventLog.Finalize

Called when the object is about to be reclaimed by garbage collection.

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

Exceptions

Exception Type | Condition
Win32Exception | The event log's read handle is not released successfully. -or- The event log's write handle is not released successfully.

Remarks

Open resources are closed and the System.Component.Dispose() method is called. The process to close open resources can generate exceptions that must be handled by the method that calls Finalize().

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | Dispose


EventLog.GetEventLogs

Creates an array of the event logs.

Overload List

Searches for all event logs on the given computer and creates an array of EventLog objects to contain the list.

[Visual Basic] Overloads Public Shared Function GetEventLogs(String) As EventLog ()
[C#] public static EventLog[] GetEventLogs(String);
[C++] public: static EventLog* GetEventLogs(String*) [];
[JScript] public static function GetEventLogs(String) : EventLog[];

Searches for all event logs on the local computer and creates an array of EventLog objects to contain the list.

[Visual Basic] Overloads Public Shared Function GetEventLogs() As EventLog ()
[C#] public static EventLog[] GetEventLogs();
[C++] public: static EventLog* GetEventLogs() [];
[JScript] public static function GetEventLogs() : EventLog[];

Example [Visual Basic]

The following example gets a list of logs on the local computer. It then outputs the name of each log.

Import the System.Diagnostics namespace for this example.

Note This example shows how to use one of the overloaded versions of GetEventLogs. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub GetLogList()
    'Declare an array of event logs.
    Dim EventLogList() As EventLog
    'This is used in a for loop
    Dim i As Integer

    'Show the name of each event log on the local computer.
    EventLogList = EventLog.GetEventLogs
    For i = 0 To EventLogList.Length - 1
        Console.WriteLine(EventLogList(i).Log)
    Next
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace


EventLog.GetEventLogs (String)

Searches for all event logs on the given computer and creates an array of EventLog objects to contain the list.

[Visual Basic]
Overloads Public Shared Function GetEventLogs( _
   ByVal machineName As String _
) As EventLog ()
[C#]
public static EventLog[] GetEventLogs(
   string machineName
);
[C++]
public: static EventLog* GetEventLogs(
   String* machineName
) [];
[JScript]
public static function GetEventLogs(
   machineName : String
) : EventLog[];

Parameters

machineName
The computer on which to search for event logs.

Return Value

An array of type EventLog that represents the logs on the given computer.

Exceptions

Exception Type | Condition
ArgumentException | The machineName parameter is an invalid computer name.
SystemException | You don't have read access to the registry. -or- There is no event log service on the computer.

Remarks

The array of EventLog objects is a snapshot of all event logs that are on the computer specified by the machineName parameter when the call to GetEventLogs is made. This is not a dynamic collection, so it does not reflect the deletion or creation of logs in real time. You should verify that a log in the array exists before you read or write to it. The array will usually include at least three logs, Application, System, and Security. If you have created custom logs on the specified computer, they appear in the array as well.

GetEventLogs is a static (in Visual Basic Shared) method, so it can be called on the EventLog class itself. It is not necessary to instantiate an EventLog object to make a call to the method.

Example [Visual Basic]

The following example gets a list of logs on the computer "myComputer". It then outputs the name of each log.

Import the System.Diagnostics namespace for this example.

[Visual Basic]

Private Sub GetRemoteLogList()
    'Declare an array of event logs.
    Dim EventLogList() As EventLog
    'This is used in a for loop
    Dim i As Integer

    'Show the name of each event log on the specified computer.
    EventLogList = EventLog.GetEventLogs("myComputer")
    For i = 0 To EventLogList.Length - 1
        Console.WriteLine(EventLogList(i).Log)
    Next
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | EventLog.GetEventLogs Overload List | Exists | Log | MachineName


EventLog.GetEventLogs ()

Searches for all event logs on the local computer and creates an array of EventLog objects to contain the list.

[Visual Basic]
Overloads Public Shared Function GetEventLogs() As EventLog ()
[C#]
public static EventLog[] GetEventLogs();
[C++]
public: static EventLog* GetEventLogs() [];
[JScript]
public static function GetEventLogs() : EventLog[];

Return Value

An array of type EventLog that represents the logs on the local computer.

Exceptions

Exception Type | Condition
SystemException | You don't have read access to the registry. -or- There is no event log service on the computer.

Remarks

The array of EventLog objects is a snapshot of all event logs that are on the local computer when the call to GetEventLogs is made. This is not a dynamic collection, so it does not reflect the deletion or creation of logs in real time. You should verify that a log in the array exists before you read or write to it. The array will usually include at least three logs, Application, System, and Security. If you have created custom logs on the local computer, they appear in the array as well.

GetEventLogs is a static (in Visual Basic Shared) method, so it can be called on the EventLog class itself. It is not necessary to instantiate an EventLog object to make a call to the method.

Example [Visual Basic]

The following example gets a list of logs on the local computer. It then outputs the name of each log.

Import the System.Diagnostics namespace for this example.

[Visual Basic]

Private Sub GetLogList()
    'Declare an array of event logs.
    Dim EventLogList() As EventLog
    'This is used in a for loop
    Dim i As Integer

    'Show the name of each event log on the local computer.
    EventLogList = EventLog.GetEventLogs
    For i = 0 To EventLogList.Length - 1
        Console.WriteLine(EventLogList(i).Log)
    Next
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | EventLog.GetEventLogs Overload List | Exists | Log


EventLog.RemoveOnEntryWritten

Deregisters an event handler from monitoring for the arrival of events.

[Visual Basic]
Overridable Public Sub RemoveOnEntryWritten( _
   ByVal handler As EventLogEventHandler _
)
[C#]
public virtual void RemoveOnEntryWritten(
   EventLogEventHandler handler
);
[C++]
public: virtual void RemoveOnEntryWritten(
   EventLogEventHandler* handler
);
[JScript]
public function RemoveOnEntryWritten(
   handler : EventLogEventHandler
);

Parameters

handler
A delegate that is receiving events.

Remarks

This method stops the delegate from monitoring for events and closes the event handle.

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | AddOnEntryWritten


EventLog.SourceExists

Searches a computer's registry for a given event source.

Overload List

Determines whether an event source is registered on the local computer.

[Visual Basic] Overloads Public Shared Function SourceExists(String) As Boolean
[C#] public static bool SourceExists(String);
[C++] public: static bool SourceExists(String*);
[JScript] public static function SourceExists(String) : Boolean;

Determines whether an event source is registered on a specified computer.

[Visual Basic] Overloads Public Shared Function SourceExists(String, String) As Boolean
[C#] public static bool SourceExists(String, String);
[C++] public: static bool SourceExists(String*, String*);
[JScript] public static function SourceExists(String, String) : Boolean;

Example [Visual Basic]

The following example connects to an event log, "myNewLog", on the computer "myComputer". If the source "myNewSource" does not already exist on the computer, it is created. Then, an entry is written to the Log.

Note that the way to create a new event log is through the static (in Visual Basic Shared) member CreateEventSource, which creates a Source and registers it to the Log at the time the log is created. Because this is a static (Shared) member of EventLog, it should be called on the class itself rather than on an instance of the class.

Import the System.Diagnostics namespace for this example.

Note This example shows how to use one of the overloaded versions of SourceExists. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub ConnectToEventLog()
    'Declare a new event log and event log entry.
    Dim evtLog As EventLog

    'Instantiate a new event log.
    evtLog = New EventLog

    'Otherwise, create a new source and log.
    If Not EventLog.SourceExists("myNewSource", "myComputer") Then
        'If MyNewLog does not exist, it will be created
        EventLog.CreateEventSource("myNewSource", "myComputer", "myNewLog")
    End If

    'Connect the source to the event instance.
    evtLog.Source = "myNewSource"

    'Write an entry to the event log.
    evtLog.WriteEntry("Event log entry.")
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace


EventLog.SourceExists (String)

Determines whether an event source is registered on the local computer.

[Visual Basic]
Overloads Public Shared Function SourceExists( _
   ByVal source As String _
) As Boolean
[C#]
public static bool SourceExists(
   string source
);
[C++]
public: static bool SourceExists(
   String* source
);
[JScript]
public static function SourceExists(
   source : String
) : Boolean;

Parameters

source
The name of the event source.

Return Value

true if the event source is registered on the local computer; otherwise, false.

Remarks

Use this overload to determine if an event source exists on the local computer. If you want to determine whether a log exists on the local computer, use Exists.

This method looks in the registry; if you do not have the appropriate registry rights on the local computer, the query will return false.

Because a new source can't be given the name of an existing source on the same computer, use this method before attempting to call CreateEventSource to ensure that a source with the name specified by source does not already exist on the local computer. The source parameter is not case sensitive.

SourceExists is a static (in Visual Basic Shared) method, so it can be called on the class itself. It is not necessary to instantiate EventLog to call SourceExists.

Example [Visual Basic]

The following example connects to an event log, "myNewLog", on the local computer. If the source "myNewSource" does not already exist on the computer, it is created. Then, an entry is written to the Log.

Note that the way to create a new event log is through the static (Shared) member CreateEventSource, which creates a Source and registers it to the Log at the time the log is created. Because this is a static (Shared) member of EventLog, it should be called on the class itself rather than on an instance of the class.

Import the System.Diagnostics namespace for this example.

[Visual Basic]

Private Sub ConnectToEventLog()
    'Declare a new event log and event log entry.
    Dim evtLog As EventLog

    'Instantiate a new event log.
    evtLog = New EventLog

    'Otherwise, create a new source and log.
    If Not EventLog.SourceExists("myNewSource") Then
        'If MyNewLog does not exist, it will be created
        EventLog.CreateEventSource("myNewSource", "myNewLog")
    End If

    'Connect the source to the event instance.
    evtLog.Source = "myNewSource"

    'Write an entry to the event log.
    evtLog.WriteEntry("Event log entry.")
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | EventLog.SourceExists Overload List | CreateEventSource | DeleteEventSource | Exists | Source


EventLog.SourceExists (String, String)

Determines whether an event source is registered on a specified computer.

[Visual Basic]
Overloads Public Shared Function SourceExists( _
   ByVal source As String, _
   ByVal machineName As String _
) As Boolean
[C#]
public static bool SourceExists(
   string source,
   string machineName
);
[C++]
public: static bool SourceExists(
   String* source,
   String* machineName
);
[JScript]
public static function SourceExists(
   source : String,
   machineName : String
) : Boolean;

Parameters

source
The name of the event source.
machineName
The name the computer on which to look, or a null reference (in Visual Basic Nothing) for the local computer.

Return Value

true if the event source is registered on the given computer; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentException | The machineName parameter is an invalid computer name.

Remarks

Use this overload to determine if an event source exists on the computer specified by the machineName parameter. If you want to determine whether a log exists on the specified computer, use Exists.

This method looks in the registry; if you do not have the appropriate registry rights on the given server, the query will return false.

Because a new source can't be given the name of an existing source on the same computer, use this method before attempting to call CreateEventSource to ensure that a source with the name specified by source does not already exist on the computer. The source and machineName parameters are not case sensitive.

SourceExists is a static (in Visual Basic Shared) method, so it can be called on the class itself. It is not necessary to instantiate EventLog to call SourceExists.

Example [Visual Basic]

The following example connects to an event log, "myNewLog", on the computer "myComputer". If the source "myNewSource" does not already exist on the computer, it is created. Then, an entry is written to the Log.

Note that the way to create a new event log is through the static (Shared) member CreateEventSource, which creates a Source and registers it to the Log at the time the log is created. Because this is a static (Shared) member of EventLog, it should be called on the class itself rather than on an instance of the class.

Import the System.Diagnostics namespace for this example.

[Visual Basic]

Private Sub ConnectToEventLog()
    'Declare a new event log and event log entry.
    Dim evtLog As EventLog

    'Instantiate a new event log.
    evtLog = New EventLog

    'Otherwise, create a new source and log.
    If Not EventLog.SourceExists("myNewSource", "myComputer") Then
        'If MyNewLog does not exist, it will be created
        EventLog.CreateEventSource("myNewSource", "myComputer", "myNewLog")
    End If

    'Connect the source to the event instance.
    evtLog.Source = "myNewSource"

    'Write an entry to the event log.
    evtLog.WriteEntry("Event log entry.")
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | EventLog.SourceExists Overload List | CreateEventSource | DeleteEventSource | Exists | Source | MachineName


EventLog.StartMonitoring

[To be supplied.]

[Visual Basic]
Overridable Public Sub StartMonitoring()
[C#]
public virtual void StartMonitoring();
[C++]
public: virtual void StartMonitoring();
[JScript]
public function StartMonitoring();

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace


EventLog.StopMonitoring

[To be supplied.]

[Visual Basic]
Overridable Public Sub StopMonitoring()
[C#]
public virtual void StopMonitoring();
[C++]
public: virtual void StopMonitoring();
[JScript]
public function StopMonitoring();

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace


EventLog.WriteEntry

Logs an entry in the event log.

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Shared Sub WriteEntry(String, String, EventLogEntryType, Integer, Integer)
[C#] public static void WriteEntry(String, String, EventLogEntryType, short, short);
[C++] public: static void WriteEntry(String*, String*, EventLogEntryType, short, short);
[JScript] public static function WriteEntry(String, String, EventLogEntryType, Int16, Int16);

Writes an entry of the specified type with the user-defined eventID and category to the event log. The category can be used by the event viewer to filter events in the log.

[Visual Basic] Overloads Public Sub WriteEntry(String, EventLogEntryType, Integer, Integer)
[C#] public void WriteEntry(String, EventLogEntryType, short, short);
[C++] public: void WriteEntry(String*, EventLogEntryType, short, short);
[JScript] public function WriteEntry(String, EventLogEntryType, Int16, Int16);

Writes an entry of the specified type with the user-defined eventID and category to the event log, and appends binary data to the message. The Event Viewer does not interpret this data; it displays raw data only in a combined hexadecimal and text format.

[Visual Basic] Overloads Public Sub WriteEntry(String, EventLogEntryType, Integer, Integer, Byte())
[C#] public void WriteEntry(String, EventLogEntryType, short, short, byte[]);
[C++] public: void WriteEntry(String*, EventLogEntryType, short, short, unsigned char[]);
[JScript] public function WriteEntry(String, EventLogEntryType, Int16, Int16, Byte[]);

Writes an information type entry with the given message text to the event log.

[Visual Basic] Overloads Overridable Public Sub WriteEntry(String)
[C#] public virtual void WriteEntry(String);
[C++] public: virtual void WriteEntry(String*);
[JScript] public function WriteEntry(String);

[To be supplied.]

[Visual Basic] Overloads Public Shared Sub WriteEntry(String, String, EventLogEntryType, Integer, Integer, Byte())
[C#] public static void WriteEntry(String, String, EventLogEntryType, short, short, byte[]);
[C++] public: static void WriteEntry(String*, String*, EventLogEntryType, short, short, unsigned char[]);
[JScript] public static function WriteEntry(String, String, EventLogEntryType, Int16, Int16, Byte[]);

Writes an entry of the specified EventLogEntryType to the event log. Valid types are Error, Warning, Information, Success Audit, and Failure Audit.

[Visual Basic] Overloads Public Sub WriteEntry(String, EventLogEntryType)
[C#] public void WriteEntry(String, EventLogEntryType);
[C++] public: void WriteEntry(String*, EventLogEntryType);
[JScript] public function WriteEntry(String, EventLogEntryType);

[To be supplied.]

[Visual Basic] Overloads Public Shared Sub WriteEntry(String, String)
[C#] public static void WriteEntry(String, String);
[C++] public: static void WriteEntry(String*, String*);
[JScript] public static function WriteEntry(String, String);

[To be supplied.]

[Visual Basic] Overloads Public Shared Sub WriteEntry(String, String, EventLogEntryType)
[C#] public static void WriteEntry(String, String, EventLogEntryType);
[C++] public: static void WriteEntry(String*, String*, EventLogEntryType);
[JScript] public static function WriteEntry(String, String, EventLogEntryType);

[To be supplied.]

[Visual Basic] Overloads Public Shared Sub WriteEntry(String, String, EventLogEntryType, Integer)
[C#] public static void WriteEntry(String, String, EventLogEntryType, short);
[C++] public: static void WriteEntry(String*, String*, EventLogEntryType, short);
[JScript] public static function WriteEntry(String, String, EventLogEntryType, Int16);

Writes an entry of the specified EventLogEntryType and with the user-defined eventID to the event log.

[Visual Basic] Overloads Public Sub WriteEntry(String, EventLogEntryType, Integer)
[C#] public void WriteEntry(String, EventLogEntryType, short);
[C++] public: void WriteEntry(String*, EventLogEntryType, short);
[JScript] public function WriteEntry(String, EventLogEntryType, Int16);

Example [Visual Basic]

The following example connects to a log with the source "myNewSource". It then writes an entry to the log. This example assumes there is an existing source named "myNewSource" on the local computer.

The procedure defines its own eventId values, which correspond to what appears in the Event column of the Event Viewer. The following table describes how the application-defined fileEventType strings correspond to locally-defined eventId values. Note that these are randomly selected for this example; there is no inherent meaning in the eventId or fileEventType values that were chosen.

File Event String | eventId Value
OpenFile | 0x01
ModifyFile | 0x02
CloseFile | 0x04
CreateFile | 0x08
DeleteFile | 0x10
FileAccessDenied | 0x20
FileError | 0x40

When the entry is written to the event log, the entry type (Information, Failure Audit) is specified as well. You can view the entry information in the Event Viewer to see the Type (type), Event (eventId), and message text.

Import the System.Diagnostics namespace for this example.

Note This example shows how to use one of the overloaded versions of WriteEntry. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub WriteEntryWithId(ByVal fileEventType As String)
    'Declare a new event log.
    Dim evtLog As EventLog
    'The eventId corresponds to the file event.
    Dim eventId As Int16
    'The EventLogEntryType we associate with the file event.
    Dim entryType As EventLogEntryType

    'Instantiate a new event log.
    evtLog = New EventLog
    'Connect the event log to the source passed in.
    evtLog.Source = "mySource"

    'Set the eventId and entryType based on the file event passed in.
    Select Case fileEventType
        Case "OpenFile"
'This was randomly defined. The actual values are not crucial.
eventId = 1
entryType = EventLogEntryType.SuccessAudit
        Case "ModifyFile"
eventId = 2
entryType = EventLogEntryType.Information
        Case "CloseFile"
eventId = 4
entryType = EventLogEntryType.Information
        Case "CreateFile"
eventId = 8
entryType = EventLogEntryType.Information
        Case "DeleteFile"
eventId = 16
entryType = EventLogEntryType.Information
        Case "FileAccessDenied"
eventId = 32
entryType = EventLogEntryType.FailureAudit
        Case "FileError"
eventId = 64
entryType = EventLogEntryType.Error
    End Select

    'Write the entry information to the log.
    evtLog.WriteEntry("File access event occurred.", entryType, eventId)
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace


EventLog.WriteEntry (String, String, EventLogEntryType, Int16, Int16)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Sub WriteEntry( _
   ByVal source As String, _
   ByVal message As String, _
   ByVal type As EventLogEntryType, _
   ByVal eventID As Short, _
   ByVal category As Short _
)
[C#]
public static void WriteEntry(
   string source,
   string message,
   EventLogEntryType type,
   short eventID,
   short category
);
[C++]
public: static void WriteEntry(
   String* source,
   String* message,
   EventLogEntryType type,
   short eventID,
   short category
);
[JScript]
public static function WriteEntry(
   source : String,
   message : String,
   type : EventLogEntryType,
   eventID : Int16,
   category : Int16
);

Parameters

source
[To be supplied.]
message
[To be supplied.]
type
[To be supplied.]
eventID
[To be supplied.]
category
[To be supplied.]

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | EventLog.WriteEntry Overload List


EventLog.WriteEntry (String, EventLogEntryType, Int16, Int16)

Writes an entry of the specified type with the user-defined eventID and category to the event log. The category can be used by the event viewer to filter events in the log.

[Visual Basic]
Overloads Public Sub WriteEntry( _
   ByVal message As String, _
   ByVal type As EventLogEntryType, _
   ByVal eventID As Short, _
   ByVal category As Short _
)
[C#]
public void WriteEntry(
   string message,
   EventLogEntryType type,
   short eventID,
   short category
);
[C++]
public: void WriteEntry(
   String* message,
   EventLogEntryType type,
   short eventID,
   short category
);
[JScript]
public function WriteEntry(
   message : String,
   type : EventLogEntryType,
   eventID : Int16,
   category : Int16
);

Parameters

message
The string to write to the event log.
type
One of the EventLogEntryType values.
eventID
The source-specific identifier for the event, which identifies the current message.
category
A source-specific subcategory associated with the message.

Exceptions

Exception Type | Condition
ArgumentException The Source property of the EventLog has not been set.

-or-

The method has attempted to create a new event Source, but the computer name is not valid.

-or-

The method has attempted to create a new event Source, but the source name was not specified.

-or-

The method has attempted to create a new event Source, but the source already exists on the computer.

-or-

The method has attempted to create a new Log, but the first eight characters of the log name are not unique on the computer.

-or-

The method has attempted to open the event log with read access, but the Log property was not specified.

-or-

The method has attempted to open the event log with write access, but the Source property was not specified.

-or-

The message string is too long. The size must be less than 16384 bytes.

-or-

The source is not registered to the given log.
Exception | The registry entry for the Log could not be opened on a remote computer.
InvalidOperationException | The method has attempted to open the event log with write access, but you do not have write access to the log.
Win32Exception The method attempted to release the event log's read or write handle but did not do so successfully.

-or-

The method attempted to open the event log with read access but was unable to do so.

-or-

The event could not be reported to the log.
SystemException | The event log could not be notified to start listenting for events.

Remarks

WriteEntry lets you specify a string message to write to the log. This method writes the given string directly to the log; it does not use a localizable message file.

Use this overload if you want to write an entry with an application-defined category to the event log. Categories help you organize events so Event Viewer can filter them. Each application can define its own numbered categories and the text strings to which they are mapped. The categories must be numbered consecutively beginning with the number 1. The Event Viewer presents the category to the user in the Category column.

In addition to the event identifier, this overload of WriteEntry lets you specify an EventLogEntryType and an event identifier for the event being written to the event log. Event identifiers uniquely identify a particular event. Each application can define its own numbered events and the description strings to which they are mapped. Event viewers can present these strings to the user in the Event column. They should help the user understand what went wrong and suggest what actions to take. The type is indicated in the Event Viewer for a log by an icon and text in the Type column.

You must set the Source property on your EventLog component before you can write entries to the log. You can call CreateEventSource on a new Source to register it before writing to the event log, but this is not necessary. If a new Source has not been registered on the computer to which your component is writing, WriteEntry calls CreateEventSource automatically and registers the Source for you.

If you have not specified a MachineName for your EventLog instance before calling CreateEventSource or WriteEntry, the local computer (".") is assumed.

If the system needs to register the Source through a call to WriteEntry and the Log property has not been set on your EventLog instance, it defaults to the Application log.

Note Many of the exceptions listed above are generated by errors raised during the process of registering the Source.

Example [Visual Basic]

The following example connects to a log with the source "myNewSource". It then writes an entry to the log. This example assumes there is an existing source named "myNewSource" on the local computer.

The procedure defines its own eventId and computerType values, which correspond to what appears in the Event and Category columns of the Event Viewer. The following table describes how the procedure's fileEventType strings correspond to locally-defined eventId values. The second table describes how computer names correspond to application-defined computer types. Note that this was randomly selected for this example; there is no inherent meaning in the eventId, computerType,or fileEventType values.

File Event String | Value
OpenFile | 0x01
FileAccessDenied | 0x02
FileError | 0x04
Computer Name | Value
type1Computer | 0x01
type2Computer | 0x02

When the entry is written to the event log, the entry type (Information, Failure Audit), which this procedure associates with each file event, is specified as well. You can view the entry information in the Event Viewer to see the Type (type), Event (eventId), Category (category), and message text.

Import the System.Diagnostics namespace for this example.

[Visual Basic]

Private Sub WriteEntryWithId(ByVal fileEventType As String, ByVal computer As String)
    'Declare a new event log.
    Dim evtLog As EventLog
    'The eventId corresponds to the file event.
    Dim eventId As Int16
    'The EventLogEntryType we associate with the file event.
    Dim entryType As EventLogEntryType
    'The computer type: type1, type2, etc..
    Dim computerType As Int16

    'Instantiate a new event log.
    evtLog = New EventLog
    'Connect the event log to the source.
    evtLog.Source = "mySource"

    'Set the computer type. This was randomly-defined for the example.
    Select Case computer
        Case "type1Computer"
'Application-assigned computer type.
computerType = 1
        Case "type2Computer"
computerType = 2
    End Select

    'Set the eventId and entryType based on the file event passed in.
    Select Case fileEventType
        Case "OpenFile"
'This was randomly defined. The actual values are not crucial.
eventId = 1
entryType = EventLogEntryType.SuccessAudit
        Case "FileAccessDenied"
eventId = 2
entryType = EventLogEntryType.FailureAudit
        Case "FileError"
eventId = 4
entryType = EventLogEntryType.Error
    End Select

    'Write the entry information to the log.
    evtLog.WriteEntry("File access event occurred.", entryType, eventId, computerType)
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | EventLog.WriteEntry Overload List | EventLogEntryType | Source | CreateEventSource | DeleteEventSource | SourceExists


EventLog.WriteEntry (String, EventLogEntryType, Int16, Int16, Byte[])

Writes an entry of the specified type with the user-defined eventID and category to the event log, and appends binary data to the message. The Event Viewer does not interpret this data; it displays raw data only in a combined hexadecimal and text format.

[Visual Basic]
Overloads Public Sub WriteEntry( _
   ByVal message As String, _
   ByVal type As EventLogEntryType, _
   ByVal eventID As Short, _
   ByVal category As Short, _
   ByVal rawData() As Byte _
)
[C#]
public void WriteEntry(
   string message,
   EventLogEntryType type,
   short eventID,
   short category,
   byte[] rawData
);
[C++]
public: void WriteEntry(
   String* message,
   EventLogEntryType type,
   short eventID,
   short category,
   unsigned char* rawData[]
);
[JScript]
public function WriteEntry(
   message : String,
   type : EventLogEntryType,
   eventID : Int16,
   category : Int16,
   rawData : Byte[]
);

Parameters

message
The string to write to the event log.
type
One of the EventLogEntryType values.
eventID
The source-specific identifier for the event, which identifies the current message.
category
A source-specific subcategory associated with the message.
rawData
An array of bytes that holds the binary data associated with the entry.

Exceptions

Exception Type | Condition
ArgumentException The Source property of the EventLog has not been set.

-or-

The method has attempted to create a new event Source, but the computer name is not valid.

-or-

The method has attempted to create a new event Source, but the source name was not specified.

-or-

The method has attempted to create a new event Source, but the source already exists on the computer.

-or-

The method has attempted to create a new Log, but the first eight characters of the log name are not unique on the computer.

-or-

The method has attempted to open the event log with read access, but the Log property was not specified.

-or-

The method has attempted to open the event log with write access, but the Source property was not specified.

-or-

The message string is too long. The size must be less than 16384 bytes.

-or-

The source is not registered to the given log.
Exception | The registry entry for the Log could not be opened on a remote computer.
InvalidOperationException | The method has attempted to open the event log with write access, but you do not have write access to the log.
Win32Exception The method attempted to release the event log's read or write handle but did not do so successfully.

-or-

The method attempted to open the event log with read access but was unable to do so.

-or-

The event could not be reported to the log.
SystemException | The event log could not be notified to start listenting for events.

Remarks

WriteEntry lets you specify a string message to write to the log. This method writes the given string directly to the log; it does not use a localizable message file.

Use this overload if you want to write application-defined event-specific data to the event log. The Event Viewer does not interpret this data; it displays extra data only in a combined hexadecimal and text format. Use event-specific data sparingly, including it only if you are sure it will be useful to someone debugging the problem. You can also use event-specific data to store information the application can process independently of the Event Viewer. For example, you could write a viewer specifically for your events, or write a program that scans the logfile and makes reports that include information from the event-specific data.

In addition to the event identifier, this overload of WriteEntry lets you specify an EventLogEntryType, an event identifier for the event being written to the event log, and an application-defined category with which to filter events.

Event identifiers (eventID) uniquely identify a particular event. Each application can define its own numbered events and the description strings to which they are mapped. These strings should help the user understand what went wrong and suggest what actions to take. Each application can also define its own numbered categories (category) and the text strings to which they are mapped. The categories must be numbered consecutively beginning with the number 1. The Event Viewer presents the eventID

or its associated strings to the user in the "Event" column and the category in the "Category" column. The type is indicated in the Event Viewer for a log by an icon and text in the "Type" column.

You must set the Source property on your EventLog component before you can write entries to the log. You can call CreateEventSource on a new Source to register it before writing to the event log, but this is not necessary. If a new Source has not been registered on the computer to which your component is writing, WriteEntry calls CreateEventSource automatically and registers the Source for you.

If you have not specified a MachineName for your EventLog instance before calling CreateEventSource or WriteEntry, the local computer (".") is assumed.

If the system needs to register the Source through a call to WriteEntry and the Log property has not been set on your EventLog instance, it defaults to the Application log.

Note Many of the exceptions listed above are generated by errors raised during the process of registering the Source.

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | EventLog.WriteEntry Overload List | EventLogEntryType | Source | CreateEventSource | DeleteEventSource | SourceExists


EventLog.WriteEntry (String)

Writes an information type entry with the given message text to the event log.

[Visual Basic]
Overloads Overridable Public Sub WriteEntry( _
   ByVal message As String _
)
[C#]
public virtual void WriteEntry(
   string message
);
[C++]
public: virtual void WriteEntry(
   String* message
);
[JScript]
public function WriteEntry(
   message : String
);

Parameters

message
The string to write to the event log

Exceptions

Exception Type | Condition
ArgumentException The Source property of the EventLog has not been set.

-or-

The method has attempted to create a new event Source, but the computer name is not valid.

-or-

The method has attempted to create a new event Source, but the source name was not specified.

-or-

The method has attempted to create a new event Source, but the source already exists on the computer.

-or-

The method has attempted to create a new Log, but the first eight characters of the log name are not unique on the computer.

-or-

The method has attempted to open the event log with read access, but the Log property was not specified.

-or-

The method has attempted to open the event log with write access, but the Source property was not specified.

-or-

The message string is too long. The size must be less than 16384 bytes.

-or-

The source is not registered to the given log.
Exception | The registry entry for the Log could not be opened on a remote computer.
InvalidOperationException | The method has attempted to open the event log with write access, but you do not have write access to the log.
Win32Exception The method attempted to release the event log's read or write handle but failed.

-or-

The method attempted to open the event log with read access but failed.

-or-

The event could not be reported to the log.
SystemException | The event log could not be notified to start receiving events.

Remarks

WriteEntry lets you specify a string message to write to the log. This method writes the given string directly to the log; it does not use a localizable message file.

Use this overload if you want to write an information entry to the event log. If you want to specify any other EventLogEntryType, use a different overload of WriteEntry.

You must set the Source property on your EventLog component before you can write entries to the log. You can call CreateEventSource on a new Source to register it before writing to the event log, but this is not necessary. If a new Source has not been registered on the computer to which your component is writing, WriteEntry calls CreateEventSource automatically and registers the Source for you.

If you have not specified a MachineName for your EventLog instance before calling CreateEventSource or WriteEntry, the local computer (".") is assumed.

If the system needs to register the Source through a call to WriteEntry and the Log property has not been set on your EventLog instance, it defaults to the Application log.

Note Many of the exceptions listed above are generated by errors raised during the process of registering the Source.

Example [Visual Basic]

The following example connects to a log with the source "myNewSource". It then writes an entry to the log. This example assumes there is an existing source named "myNewSource" on the local computer.

Import the System.Diagnostics namespace for this example.

[Visual Basic]

Private Sub WriteToEventLog()
    'Declare a new event log and event log entry.
    Dim evtLog As EventLog

    'Instantiate a new event log.
    evtLog = New EventLog

    'Connect the source to the event instance.
    evtLog.Source = "myNewSource"

    'Write an entry to the event log.
    evtLog.WriteEntry("Event log entry.")
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | EventLog.WriteEntry Overload List | Source | CreateEventSource | DeleteEventSource | SourceExists


EventLog.WriteEntry (String, String, EventLogEntryType, Int16, Int16, Byte[])

[To be supplied.]

[Visual Basic]
Overloads Public Shared Sub WriteEntry( _
   ByVal source As String, _
   ByVal message As String, _
   ByVal type As EventLogEntryType, _
   ByVal eventID As Short, _
   ByVal category As Short, _
   ByVal rawData() As Byte _
)
[C#]
public static void WriteEntry(
   string source,
   string message,
   EventLogEntryType type,
   short eventID,
   short category,
   byte[] rawData
);
[C++]
public: static void WriteEntry(
   String* source,
   String* message,
   EventLogEntryType type,
   short eventID,
   short category,
   unsigned char* rawData[]
);
[JScript]
public static function WriteEntry(
   source : String,
   message : String,
   type : EventLogEntryType,
   eventID : Int16,
   category : Int16,
   rawData : Byte[]
);

Parameters

source
[To be supplied.]
message
[To be supplied.]
type
[To be supplied.]
eventID
[To be supplied.]
category
[To be supplied.]
rawData
[To be supplied.]

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | EventLog.WriteEntry Overload List


EventLog.WriteEntry (String, EventLogEntryType)

Writes an entry of the specified EventLogEntryType to the event log. Valid types are Error, Warning, Information, Success Audit, and Failure Audit.

[Visual Basic]
Overloads Public Sub WriteEntry( _
   ByVal message As String, _
   ByVal type As EventLogEntryType _
)
[C#]
public void WriteEntry(
   string message,
   EventLogEntryType type
);
[C++]
public: void WriteEntry(
   String* message,
   EventLogEntryType type
);
[JScript]
public function WriteEntry(
   message : String,
   type : EventLogEntryType
);

Parameters

message
The string to write to the event log.
type
One of the EventLogEntryType values.

Exceptions

Exception Type | Condition
ArgumentException The Source property of the EventLog has not been set.

-or-

The method has attempted to create a new event Source, but the computer name is not valid.

-or-

The method has attempted to create a new event Source, but the source name was not specified.

-or-

The method has attempted to create a new event Source, but the source already exists on the computer.

-or-

The method has attempted to create a new Log, but the first eight characters of the log name are not unique on the computer.

-or-

The method has attempted to open the event log with read access, but the Log property was not specified.

-or-

The method has attempted to open the event log with write access, but the Source property was not specified.

-or-

The message string is too long. The size must be less than 16384 bytes.

-or-

The source is not registered to the given log.
Exception | The registry entry for the Log could not be opened on a remote computer.
InvalidOperationException | The method has attempted to open the event log with write access, but you do not have write access to the log.
Win32Exception The method attempted to release the event log's read or write handle but did not do so successfully.

-or-

The method attempted to open the event log with read access but was unable to do so.

-or-

The event could not be reported to the log.
SystemException | The event log could not be notified to start listenting for events.

Remarks

WriteEntry lets you specify a string message to write to the log. This method writes the given string directly to the log; it does not use a localizable message file.

Use this overload if you want to write an entry of a specified EventLogEntryType to the event log. The type is indicated in the Event Viewer for a log by an icon and text in the Type column.

You must set the Source property on your EventLog component before you can write entries to the log. You can call CreateEventSource on a new Source to register it before writing to the event log, but this is not necessary. If a new Source has not been registered on the computer to which your component is writing, WriteEntry calls CreateEventSource automatically and registers the Source for you.

If you have not specified a MachineName for your EventLog instance before calling CreateEventSource or WriteEntry, the local computer (".") is assumed.

If the system needs to register the Source through a call to WriteEntry and the Log property has not been set on your EventLog instance, it defaults to the Application log.

Note Many of the exceptions listed above are generated by errors raised during the process of registering the Source.

Example [Visual Basic]

The following example connects to a log with the source "myNewSource". It then writes a warning type entry to the log. This example assumes there is an existing source named "myNewSource" on the local computer.

Import the System.Diagnostics namespace for this example.

[Visual Basic]

Private Sub WriteWarningToEventLog()
    'Declare a new event log and event log entry.
    Dim evtLog As EventLog

    'Instantiate a new event log.
    evtLog = New EventLog

    'Connect the source to the event instance.
    evtLog.Source = "myNewSource"

    'Write an entry to the event log.
    evtLog.WriteEntry("Event log warning.", EventLogEntryType.Warning)
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | EventLog.WriteEntry Overload List | EventLogEntryType | Source | CreateEventSource | DeleteEventSource | SourceExists


EventLog.WriteEntry (String, String)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Sub WriteEntry( _
   ByVal source As String, _
   ByVal message As String _
)
[C#]
public static void WriteEntry(
   string source,
   string message
);
[C++]
public: static void WriteEntry(
   String* source,
   String* message
);
[JScript]
public static function WriteEntry(
   source : String,
   message : String
);

Parameters

source
[To be supplied.]
message
[To be supplied.]

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | EventLog.WriteEntry Overload List


EventLog.WriteEntry (String, String, EventLogEntryType)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Sub WriteEntry( _
   ByVal source As String, _
   ByVal message As String, _
   ByVal type As EventLogEntryType _
)
[C#]
public static void WriteEntry(
   string source,
   string message,
   EventLogEntryType type
);
[C++]
public: static void WriteEntry(
   String* source,
   String* message,
   EventLogEntryType type
);
[JScript]
public static function WriteEntry(
   source : String,
   message : String,
   type : EventLogEntryType
);

Parameters

source
[To be supplied.]
message
[To be supplied.]
type
[To be supplied.]

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | EventLog.WriteEntry Overload List


EventLog.WriteEntry (String, String, EventLogEntryType, Int16)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Sub WriteEntry( _
   ByVal source As String, _
   ByVal message As String, _
   ByVal type As EventLogEntryType, _
   ByVal eventID As Short _
)
[C#]
public static void WriteEntry(
   string source,
   string message,
   EventLogEntryType type,
   short eventID
);
[C++]
public: static void WriteEntry(
   String* source,
   String* message,
   EventLogEntryType type,
   short eventID
);
[JScript]
public static function WriteEntry(
   source : String,
   message : String,
   type : EventLogEntryType,
   eventID : Int16
);

Parameters

source
[To be supplied.]
message
[To be supplied.]
type
[To be supplied.]
eventID
[To be supplied.]

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | EventLog.WriteEntry Overload List


EventLog.WriteEntry (String, EventLogEntryType, Int16)

Writes an entry of the specified EventLogEntryType and with the user-defined eventID to the event log.

[Visual Basic]
Overloads Public Sub WriteEntry( _
   ByVal message As String, _
   ByVal type As EventLogEntryType, _
   ByVal eventID As Short _
)
[C#]
public void WriteEntry(
   string message,
   EventLogEntryType type,
   short eventID
);
[C++]
public: void WriteEntry(
   String* message,
   EventLogEntryType type,
   short eventID
);
[JScript]
public function WriteEntry(
   message : String,
   type : EventLogEntryType,
   eventID : Int16
);

Parameters

message
The string to write to the event log.
type
One of the EventLogEntryType values.
eventID
The source-specific identifier for the event, which identifies the current message.

Exceptions

Exception Type | Condition
ArgumentException The Source property of the EventLog has not been set.

-or-

The method has attempted to create a new event Source, but the computer name is not valid.

-or-

The method has attempted to create a new event Source, but the source name was not specified.

-or-

The method has attempted to create a new event Source, but the source already exists on the computer.

-or-

The method has attempted to create a new Log, but the first eight characters of the log name are not unique on the computer.

-or-

The method has attempted to open the event log with read access, but the Log property was not specified.

-or-

The method has attempted to open the event log with write access, but the Source property was not specified.

-or-

The message string is too long. The size must be less than 16384 bytes.

-or-

The source is not registered to the given log.
Exception | The registry entry for the Log could not be opened on a remote computer.
InvalidOperationException | The method has attempted to open the event log with write access, but you do not have write access to the log.
Win32Exception The method attempted to release the event log's read or write handle but did not do so successfully.

-or-

The method attempted to open the event log with read access but was unable to do so.

-or-

The event could not be reported to the log.
SystemException | The event log could not be notified to start listenting for events.

Remarks

WriteEntry lets you specify a string message to write to the log. This method writes the given string directly to the log; it does not use a localizable message file.

Use this overload if you want to write an entry with an application-defined eventID to the event log. The eventID together with the Source uniquely identifies an event. Each application can define its own numbered events and the description strings to which they are mapped. Event viewers can present these strings to the user in the "Event" column. They should help the user understand what went wrong and suggest what actions to take.

In addition to the event identifier, this overload of WriteEntry lets you specify an EventLogEntryType for the event being written to the event log. The type is indicated in the Event Viewer for a log by an icon and text in the Type column.

You must set the Source property on your EventLog component before you can write entries to the log. You can call CreateEventSource on a new Source to register it before writing to the event log, but this is not necessary. If a new Source has not been registered on the computer to which your component is writing, WriteEntry calls CreateEventSource automatically and registers the Source for you.

If you have not specified a MachineName for your EventLog instance before calling CreateEventSource or WriteEntry, the local computer (".") is assumed.

If the system needs to register the Source through a call to WriteEntry and the Log property has not been set on your EventLog instance, it defaults to the Application log.

Note Many of the exceptions listed above are generated by errors raised during the process of registering the Source.

Example [Visual Basic]

The following example connects to a log with the source "myNewSource". It then writes an entry to the log. This example assumes there is an existing source named "myNewSource" on the local computer.

The procedure defines its own eventId values, which correspond to what appears in the Event column of the Event Viewer. The following table describes how the application-defined fileEventType strings correspond to locally-defined eventId values. Note that these are randomly selected for this example; there is no inherent meaning in the eventId or fileEventType values that were chosen.

File Event String | eventId Value
OpenFile | 0x01
ModifyFile | 0x02
CloseFile | 0x04
CreateFile | 0x08
DeleteFile | 0x10
FileAccessDenied | 0x20
FileError | 0x40

When the entry is written to the event log, the entry type (Information, Failure Audit) is specified as well. You can view the entry information in the Event Viewer to see the Type (type), Event (eventId), and message text.

Import the System.Diagnostics namespace for this example.

[Visual Basic]

Private Sub WriteEntryWithId(ByVal fileEventType As String)
    'Declare a new event log.
    Dim evtLog As EventLog
    'The eventId corresponds to the file event.
    Dim eventId As Int16
    'The EventLogEntryType we associate with the file event.
    Dim entryType As EventLogEntryType

    'Instantiate a new event log.
    evtLog = New EventLog
    'Connect the event log to the source passed in.
    evtLog.Source = "mySource"

    'Set the eventId and entryType based on the file event passed in.
    Select Case fileEventType
        Case "OpenFile"
'This was randomly defined. The actual values are not crucial.
eventId = 1
entryType = EventLogEntryType.SuccessAudit
        Case "ModifyFile"
eventId = 2
entryType = EventLogEntryType.Information
        Case "CloseFile"
eventId = 4
entryType = EventLogEntryType.Information
        Case "CreateFile"
eventId = 8
entryType = EventLogEntryType.Information
        Case "DeleteFile"
eventId = 16
entryType = EventLogEntryType.Information
        Case "FileAccessDenied"
eventId = 32
entryType = EventLogEntryType.FailureAudit
        Case "FileError"
eventId = 64
entryType = EventLogEntryType.Error
    End Select

    'Write the entry information to the log.
    evtLog.WriteEntry("File access event occurred.", entryType, eventId)
End Sub

See Also

EventLog Class | EventLog Members | System.Diagnostics Namespace | EventLog.WriteEntry Overload List | EventLogEntryType | Source | CreateEventSource | DeleteEventSource | SourceExists


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EventLog Events

The events of the EventLog class are listed below. For a complete list of EventLog class members, see the EventLog Members topic.

Public:

EntryWritten Occurs when an entry is written to the event log.

See Also

EventLog Class | System.Diagnostics Namespace


EventLog EntryWritten Event

Occurs when an entry is written to the event log.

The following declaration shows the syntax for a method that handles the EntryWritten event.

[Visual Basic]
Private Sub EventLogName_EntryWritten( _
   ByVal sender As Object, _
   ByVal e As EventLogEventArgs _
)
[C#]
private void EventLogName_EntryWritten(
   object sender,
   EventLogEventArgs e
);
[C++]
private: void EventLogName_EntryWritten(
   Object* sender,
   EventLogEventArgs* e
);
[JScript]
private EventLogName_EntryWritten(
   sender : Object,
   e : EventLogEventArgs
);

Parameters

sender
The source of the event.
e
An EventLogEventArgs that contains the event data.

Remarks

When overriding System.Diagnostics.EventLog.EntryWritten in a derived class, be sure to call the base class's System.Diagnostics.EventLog.EntryWritten method.

When you create an System.Diagnostics.EventLog.EntryWritten delegate, you identify the method that will handle the event. To associate the event with your event-handling method, add an instance of the delegate to the event. The event-handling method is called whenever the event occurs, until you remove the delegate. For more information about handling events with delegates, see TBD.

See Also

EventLog Class | EventLog MembersTopic | System.Diagnostics Namespace


EventLog.EntriesEnumerator Class

Holds an EventLog.EventLogEntryCollection that consists of the entries in an event log.

Object
EventLog.EntriesEnumerator

[Visual Basic]
Public Class EventLog.EntriesEnumerator
   Implements IEnumerator
[C#]
public class EventLog.EntriesEnumerator : IEnumerator
[C++]
public __gc class EventLog.EntriesEnumerator : public IEnumerator
[JScript]
public class EventLog.EntriesEnumerator implements IEnumerator

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

EventLog.EntriesEnumerator Members | System.Diagnostics Namespace


EventLog.EntriesEnumerator Members

Public:

Properties

Current [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
MoveNext | [To be supplied.]
Reset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EventLog.EntriesEnumerator Class | System.Diagnostics Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EventLog.EntriesEnumerator Properties

The properties of the EventLog.EntriesEnumerator class are listed below. For a complete list of EventLog.EntriesEnumerator class members, see the EventLog.EntriesEnumerator Members topic.

Public:

Current [To be supplied.]

See Also

EventLog.EntriesEnumerator Class | System.Diagnostics Namespace


EventLog.EntriesEnumerator.Current

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Current As Object
[C#]
public object Current {virtual get;}
[C++]
public: __property virtual Object* get_Current();
[JScript]
public function get Current() : Object;

See Also

EventLog.EntriesEnumerator Class | EventLog.EntriesEnumerator Members | System.Diagnostics Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EventLog.EntriesEnumerator Methods

The methods of the EventLog.EntriesEnumerator class are listed below. For a complete list of EventLog.EntriesEnumerator class members, see the EventLog.EntriesEnumerator Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
MoveNext | [To be supplied.]
Reset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EventLog.EntriesEnumerator Class | System.Diagnostics Namespace


EventLog.EntriesEnumerator.MoveNext

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;

See Also

EventLog.EntriesEnumerator Class | EventLog.EntriesEnumerator Members | System.Diagnostics Namespace


EventLog.EntriesEnumerator.Reset

[To be supplied.]

[Visual Basic]
Overridable Public Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();

See Also

EventLog.EntriesEnumerator Class | EventLog.EntriesEnumerator Members | System.Diagnostics Namespace


EventLog.EventLogEntryCollection Class

[To be supplied.]

Object
EventLog.EventLogEntryCollection

[Visual Basic]
Public Class EventLog.EventLogEntryCollection
   Implements ICollection, IEnumerable
[C#]
public class EventLog.EventLogEntryCollection : ICollection,
   IEnumerable
[C++]
public __gc class EventLog.EventLogEntryCollection : public
   ICollection, IEnumerable
[JScript]
public class EventLog.EventLogEntryCollection implements
   ICollection, IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

EventLog.EventLogEntryCollection Members | System.Diagnostics Namespace


EventLog.EventLogEntryCollection Members

Public:

Properties

All | [To be supplied.]
Count | [To be supplied.]
Item | [To be supplied.] In C#, this member is the indexer for the EventLog.EventLogEntryCollection class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EventLog.EventLogEntryCollection Class | System.Diagnostics Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EventLog.EventLogEntryCollection Properties

The properties of the EventLog.EventLogEntryCollection class are listed below. For a complete list of EventLog.EventLogEntryCollection class members, see the EventLog.EventLogEntryCollection Members topic.

Public:

All | [To be supplied.]
Count | [To be supplied.]
Item | [To be supplied.] In C#, this member is the indexer for the EventLog.EventLogEntryCollection class.

See Also

EventLog.EventLogEntryCollection Class | System.Diagnostics Namespace


EventLog.EventLogEntryCollection.All

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property All As EventLogEntry ()
[C#]
public EventLogEntry[] All {virtual get;}
[C++]
public: __property virtual EventLogEntry* get_All();
[JScript]
public function get All() : EventLogEntry[];

See Also

EventLog.EventLogEntryCollection Class | EventLog.EventLogEntryCollection Members | System.Diagnostics Namespace


EventLog.EventLogEntryCollection.Count

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

See Also

EventLog.EventLogEntryCollection Class | EventLog.EventLogEntryCollection Members | System.Diagnostics Namespace


EventLog.EventLogEntryCollection.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the EventLog.EventLogEntryCollection class.

[Visual Basic]
Overridable Public Default ReadOnly Property Item( _
   ByVal index As Integer _
) As EventLogEntry
[C#]
public EventLogEntry this[
   int index
] {virtual get;}
[C++]
public: __property virtual EventLogEntry* get_Item(
   int index
);
[JScript]
returnValue = EventLog.EventLogEntryCollectionObject.Item(index);
-or-
returnValue = EventLog.EventLogEntryCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
[To be supplied.]

Parameters [Visual Basic, C#, C++]

index
[To be supplied.]

See Also

EventLog.EventLogEntryCollection Class | EventLog.EventLogEntryCollection Members | System.Diagnostics Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EventLog.EventLogEntryCollection Methods

The methods of the EventLog.EventLogEntryCollection class are listed below. For a complete list of EventLog.EventLogEntryCollection class members, see the EventLog.EventLogEntryCollection Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EventLog.EventLogEntryCollection Class | System.Diagnostics Namespace


EventLog.EventLogEntryCollection.GetEnumerator

[To be supplied.]

[Visual Basic]
Public Function GetEnumerator() As IEnumerator
[C#]
public IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

See Also

EventLog.EventLogEntryCollection Class | EventLog.EventLogEntryCollection Members | System.Diagnostics Namespace


EventLogEntry Class

EventLogEntry encapsulates a single record in the NT event log.

Object
Component
EventLogEntry

[Visual Basic]
NotInheritable Public Class EventLogEntry
   Inherits Component
   Implements IPersistable
[C#]
public sealed class EventLogEntry : Component, IPersistable
[C++]
public __gc __sealed class EventLogEntry : public Component,
   IPersistable
[JScript]
public class EventLogEntry extends Component, IPersistable

Remarks

Objects of this type are not publicly creatable; to get one, use EventLogReader.

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

EventLogEntry Members | System.Diagnostics Namespace


EventLogEntry Members

Public:

Properties

Category | Gets the text associated with the CategoryNumber for this entry.
CategoryNumber | Gets the application-specific category number for this entry
Data | Gets the binary data associated with the entry.
EntryType | Gets the type of this entry.
EventID | Gets the application-specific event indentifier of this entry.
Extension | [To be supplied.]
Index | Gets the index of this entry in the event log.
MachineName | Gets the name of the computer on which this entry was generated.
Message | Gets the localized message corresponding to this event entry.
ReplacementStrings | Gets the replacement strings associated with the entry.
Site (inherited from Component) | Gets or sets the site of the Component.
Source | Gets the name of the application that generated this event.
TimeGenerated | Gets the time at which this event was generated, in local time.
TimeWritten | Gets the time at which this event was written to the log, in local time.
UserName | Gets the name of the user responsible for this event.

Methods

Dispose (inherited from Component) | Disposes of the Component.
Equals | Overloaded. [To be supplied.]
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Save | Saves an entry as a stream of data.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EventLogEntry Class | System.Diagnostics Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EventLogEntry Properties

The properties of the EventLogEntry class are listed below. For a complete list of EventLogEntry class members, see the EventLogEntry Members topic.

Public:

Category | Gets the text associated with the CategoryNumber for this entry.
CategoryNumber | Gets the application-specific category number for this entry
Data | Gets the binary data associated with the entry.
EntryType | Gets the type of this entry.
EventID | Gets the application-specific event indentifier of this entry.
Extension | [To be supplied.]
Index | Gets the index of this entry in the event log.
MachineName | Gets the name of the computer on which this entry was generated.
Message | Gets the localized message corresponding to this event entry.
ReplacementStrings | Gets the replacement strings associated with the entry.
Site (inherited from Component) | Gets or sets the site of the Component.
Source | Gets the name of the application that generated this event.
TimeGenerated | Gets the time at which this event was generated, in local time.
TimeWritten | Gets the time at which this event was written to the log, in local time.
UserName | Gets the name of the user responsible for this event.

See Also

EventLogEntry Class | System.Diagnostics Namespace


EventLogEntry.Category

Gets the text associated with the CategoryNumber for this entry.

[Visual Basic]
Public ReadOnly Property Category As String
[C#]
public string Category {get;}
[C++]
public: __property String* get_Category();
[JScript]
public function get Category() : String;

Property Value

The application-specific category number.

Exceptions

Exception Type | Condition
Exception | The space could not be allocated for one of the insertion strings associated with the Category.

Remarks

The text strings associated with the Category are stored in the computer's registry. Windows environment variables are translated before being inserted into the resulting text string.

See Also

EventLogEntry Class | EventLogEntry Members | System.Diagnostics Namespace


EventLogEntry.CategoryNumber

Gets the application-specific category number for this entry

[Visual Basic]
Public ReadOnly Property CategoryNumber As Short
[C#]
public short CategoryNumber {get;}
[C++]
public: __property short get_CategoryNumber();
[JScript]
public function get CategoryNumber() : Int16;

Property Value

The entry's category number.

Remarks

Each application (source) can define its own numbered categories and the text strings to which they are mapped. Categories must be numbered successively, beginning with 1.

See Also

EventLogEntry Class | EventLogEntry Members | System.Diagnostics Namespace | EntryType


EventLogEntry.Data

Gets the binary data associated with the entry.

[Visual Basic]
Public ReadOnly Property Data As Byte ()
[C#]
public byte[] Data {get;}
[C++]
public: __property unsigned char* get_Data();
[JScript]
public function get Data() : Byte[];

Property Value

An array of type Byte.

Remarks

This method instantiates an array that holds a copy of the entry's event-specific binary data. Use event-specific data sparingly, including it only if it will be useful to someone debugging the problem. Event-specific data can be used to store information the application will process independent of the event viewer, for example to make reports from the log file.

See Also

EventLogEntry Class | EventLogEntry Members | System.Diagnostics Namespace


EventLogEntry.EntryType

Gets the type of this entry.

[Visual Basic]
Public ReadOnly Property EntryType As EventLogEntryType
[C#]
public EventLogEntryType EntryType {get;}
[C++]
public: __property EventLogEntryType get_EntryType();
[JScript]
public function get EntryType() : EventLogEntryType;

Property Value

The EventLogEntryType that indicates the Event Type associated with the entry in the event log system.

Remarks

There are five types of events that can be logged. All event classifications have well-defined common data and can optionally include event-specific data. The application indicates the event type when it reports an event. Each event must be of a single type. The Event Viewer uses this type to determine which icon to display in the list view of the log.

The event log entry type can be:

Value | Type
1 | Error
2 | Warning
4 | Information
8 | Success Audit
16 | Failure Audit

See Also

EventLogEntry Class | EventLogEntry Members | System.Diagnostics Namespace | CategoryNumber


EventLogEntry.EventID

Gets the application-specific event indentifier of this entry.

[Visual Basic]
Public ReadOnly Property EventID As Integer
[C#]
public int EventID {get;}
[C++]
public: __property int get_EventID();
[JScript]
public function get EventID() : int;

Property Value

The application-specific ID of this entry.

Remarks

Event identifiers uniquely identify a particular event. Each source can define its own numbered events.

See Also

EventLogEntry Class | EventLogEntry Members | System.Diagnostics Namespace


EventLogEntry.Extension

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Extension As String
[C#]
public string Extension {get;}
[C++]
public: __property String* get_Extension();
[JScript]
public function get Extension() : String;

Property Value

[To be supplied.]

See Also

EventLogEntry Class | EventLogEntry Members | System.Diagnostics Namespace | IPersistable


EventLogEntry.Index

Gets the index of this entry in the event log.

[Visual Basic]
Public ReadOnly Property Index As Integer
[C#]
public int Index {get;}
[C++]
public: __property int get_Index();
[JScript]
public function get Index() : int;

Property Value

The index of this entry in the event log.

Remarks

This number is not necessarily zero-based.

See Also

EventLogEntry Class | EventLogEntry Members | System.Diagnostics Namespace


EventLogEntry.MachineName

Gets the name of the computer on which this entry was generated.

[Visual Basic]
Public ReadOnly Property MachineName As String
[C#]
public string MachineName {get;}
[C++]
public: __property String* get_MachineName();
[JScript]
public function get MachineName() : String;

Property Value

The name of the computer on which this entry was generated.

See Also

EventLogEntry Class | EventLogEntry Members | System.Diagnostics Namespace


EventLogEntry.Message

Gets the localized message corresponding to this event entry.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property String* get_Message();
[JScript]
public function get Message() : String;

Property Value

The formatted, localized text for the message. This includes associated replacement strings.

Exceptions

Exception Type | Condition
Exception | The space could not be allocated for one of the insertion strings associated with the message.

Remarks

This method opens the Windows Registry to determine the filename of the .DLL file containing the localized text. If you receive a Registry error when testing your source code, verify the .DLL file's existence on the computer. If insertion strings are included in the message, catch errors in their allocation.

See Also

EventLogEntry Class | EventLogEntry Members | System.Diagnostics Namespace


EventLogEntry.ReplacementStrings

Gets the replacement strings associated with the entry.

[Visual Basic]
Public ReadOnly Property ReplacementStrings As String ()
[C#]
public string[] ReplacementStrings {get;}
[C++]
public: __property String* get_ReplacementStrings();
[JScript]
public function get ReplacementStrings() : String[];

Property Value

An array of type String that holds the insertion strings stored in the event entry.

Remarks

This method retrieves only the replacement strings for the entry. To get the full message, call getMessage().

See Also

EventLogEntry Class | EventLogEntry Members | System.Diagnostics Namespace | Message


EventLogEntry.Source

Gets the name of the application that generated this event.

[Visual Basic]
Public ReadOnly Property Source As String
[C#]
public string Source {get;}
[C++]
public: __property String* get_Source();
[JScript]
public function get Source() : String;

Property Value

The application name.

See Also

EventLogEntry Class | EventLogEntry Members | System.Diagnostics Namespace


EventLogEntry.TimeGenerated

Gets the time at which this event was generated, in local time.

[Visual Basic]
Public ReadOnly Property TimeGenerated As DateTime
[C#]
public DateTime TimeGenerated {get;}
[C++]
public: __property DateTime get_TimeGenerated();
[JScript]
public function get TimeGenerated() : DateTime;

Property Value

A DateTime that represents the time at which this event was generated.

Remarks

TimeGenerated has millisecond accuracy.

This method holds the time that an event was generated. This may not be the same as the time that the event information was written to the event log. For the latter, use TimeWritten.

See Also

EventLogEntry Class | EventLogEntry Members | System.Diagnostics Namespace | TimeWritten


EventLogEntry.TimeWritten

Gets the time at which this event was written to the log, in local time.

[Visual Basic]
Public ReadOnly Property TimeWritten As DateTime
[C#]
public DateTime TimeWritten {get;}
[C++]
public: __property DateTime get_TimeWritten();
[JScript]
public function get TimeWritten() : DateTime;

Property Value

A DateTime that represents the time at which this event was written to the log.

Remarks

TimeWritten has millisecond accuracy.

This method holds the time that an event information was written to the event log. This may not be the same as the time that the event was generated. For the latter, use TimeGenerated.

See Also

EventLogEntry Class | EventLogEntry Members | System.Diagnostics Namespace | TimeGenerated


EventLogEntry.UserName

Gets the name of the user responsible for this event.

[Visual Basic]
Public ReadOnly Property UserName As String
[C#]
public string UserName {get;}
[C++]
public: __property String* get_UserName();
[JScript]
public function get UserName() : String;

Property Value

The security identifier (SID) that uniquely identifies a user or group.

Exceptions

Exception Type | Condition
SystemException | Account information could not be obtained for the user's SID.

Remarks

This property is often blank for events in logs other than the Security log.

See Also

EventLogEntry Class | EventLogEntry Members | System.Diagnostics Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EventLogEntry Methods

The methods of the EventLogEntry class are listed below. For a complete list of EventLogEntry class members, see the EventLogEntry Members topic.

Public:

Dispose (inherited from Component) | Disposes of the Component.
Equals | Overloaded. [To be supplied.]
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Save | Saves an entry as a stream of data.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EventLogEntry Class | System.Diagnostics Namespace


EventLogEntry.Equals

Performs a comparison between two event log entries.

[Visual Basic]
Shadows Public Function Equals( _
   ByVal otherEntry As EventLogEntry _
) As Boolean
[C#]
public new bool Equals(
   EventLogEntry otherEntry
);
[C++]
public: new bool Equals(
   EventLogEntry* otherEntry
);
[JScript]
public new function Equals(
   otherEntry : EventLogEntry
) : Boolean;

Parameters

otherEntry
The EventLogEntry to compare.

Return Value

true if the EventLogEntry objects are identical; otherwise, false.

Remarks

This method performs a Byte-wise comparison between the two objects.

See Also

EventLogEntry Class | EventLogEntry Members | System.Diagnostics Namespace


EventLogEntry.Save

Saves an entry as a stream of data.

[Visual Basic]
Overridable Public Sub Save( _
   ByVal stream As Stream _
)
[C#]
public virtual void Save(
   Stream stream
);
[C++]
public: virtual void Save(
   Stream* stream
);
[JScript]
public function Save(
   stream : Stream
);

Parameters

stream
The TBD Object that writes the chunk containing the EventLogEntry to disk.

Remarks

This method performs a Byte-wise write of the entry to disk.

See Also

EventLogEntry Class | EventLogEntry Members | System.Diagnostics Namespace | IPersistable


EventLogEntryType Enumeration

Specifies the event type of the event log entry.

[Visual Basic]
Public Enum EventLogEntryType
[C#]
public enum EventLogEntryType
[C++]
public enum EventLogEntryType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

There are five types of events that can be logged. All event classifications have well-defined common data and can optionally include event-specific data. Each event must be of a single type. The application indicates the event type when it reports an event. The Event Viewer uses this type to determine which icon to display in the list view of the log.

Members

Member Name | Description
Error | An error event. This indicates a significant problem the user should know about; usually a loss of functionality or data.
FailureAudit | A failure audit event. This indicates a security event that occurs when an audited access attempt fails; for example, a failed attempt to open a file.
Information | An information event. This indicates a significant successful operation.
SuccessAudit | A success audit event. This indicates a security event that occurs when an audited access attempt is successful; for example, a successful logon.
Warning | A warning event. This indicates a problem that is not immediately significant, but that may signify conditions that could cause future problems.

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

System.Diagnostics Namespace


EventLogEvent Class

Provides data for the System.Diagnostics.EventLog.EntryWritten event.

Object
EventArgs
EventLogEvent

[Visual Basic]
Public Class EventLogEvent
   Inherits EventArgs
[C#]
public class EventLogEvent : EventArgs
[C++]
public __gc class EventLogEvent : public EventArgs
[JScript]
public class EventLogEvent extends EventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

EventLogEvent Members | System.Diagnostics Namespace


EventLogEvent Members

Public:

Constructor

EventLogEvent Constructor Overloaded. Initializes a new instance of the EventLogEvent class.

Properties

ExtendedInfo (inherited from EventArgs) Holds a reference to an object that manages the event's state.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Entry Represents an event log entry.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EventLogEvent Class | System.Diagnostics Namespace


EventLogEvent Constructor

Initializes a new instance of the EventLogEvent class.

Overload List

The default constructor, which initializes a new instance of the EventLogEvent class without specifying a value for Entry.

[Visual Basic] Overloads Public Sub New()
[C#] public EventLogEvent();
[C++] public: EventLogEvent();
[JScript] public function EventLogEvent();

Initializes a new instance of the EventLogEvent class with the specified event log entry.

[Visual Basic] Overloads Public Sub New(EventLogEntry)
[C#] public EventLogEvent(EventLogEntry);
[C++] public: EventLogEvent(EventLogEntry*);
[JScript] public function EventLogEvent(EventLogEntry);

See Also

EventLogEvent Class | EventLogEvent Members | System.Diagnostics Namespace


EventLogEvent Constructor ()

The default constructor, which initializes a new instance of the EventLogEvent class without specifying a value for Entry.

[Visual Basic]
Overloads Public Sub New()
[C#]
public EventLogEvent();
[C++]
public: EventLogEvent();
[JScript]
public function EventLogEvent();

See Also

EventLogEvent Class | EventLogEvent Members | System.Diagnostics Namespace | EventLogEvent Constructor Overload List


EventLogEvent Constructor (EventLogEntry)

Initializes a new instance of the EventLogEvent class with the specified event log entry.

[Visual Basic]
Overloads Public Sub New( _
   ByVal entry As EventLogEntry _
)
[C#]
public EventLogEvent(
   EventLogEntry entry
);
[C++]
public: EventLogEvent(
   EventLogEntry* entry
);
[JScript]
public function EventLogEvent(
   entry : EventLogEntry
);

Parameters

entry
[To be supplied.]

See Also

EventLogEvent Class | EventLogEvent Members | System.Diagnostics Namespace | EventLogEvent Constructor Overload List


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EventLogEvent Fields

The fields of the EventLogEvent class are listed below. For a complete list of EventLogEvent class members, see the EventLogEvent Members topic.

Public:

Entry Represents an event log entry.

See Also

EventLogEvent Class | System.Diagnostics Namespace


EventLogEvent.Entry

Represents an event log entry.

[Visual Basic]
Public Entry As EventLogEntry
[C#]
public EventLogEntry Entry;
[C++]
public: EventLogEntry* Entry;
[JScript]
public var Entry : EventLogEntry;

See Also

EventLogEvent Class | EventLogEvent Members | System.Diagnostics Namespace


EventLogEventHandler Delegate

[To be supplied.]

[Visual Basic]
Public Delegate Sub EventLogEventHandler( _
   ByVal sender As Object, _
   ByVal e As EventLogEvent _
)
[C#]
public delegate void EventLogEventHandler(
   object sender,
   EventLogEvent e
);
[C++]
public __gc __delegate void EventLogEventHandler(
   Object* sender,
   EventLogEvent* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the EventLogEventHandler delegate declaration.

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

System.Diagnostics Namespace


EventLogInstaller Class

This class acts as an installer for the EventLog component. Essentially, it calls EventLog.CreateEventSource.

Object
Component
Installer
ComponentInstaller
EventLogInstaller

[Visual Basic]
Public Class EventLogInstaller
   Inherits ComponentInstaller
[C#]
public class EventLogInstaller : ComponentInstaller
[C++]
public __gc class EventLogInstaller : public ComponentInstaller
[JScript]
public class EventLogInstaller extends ComponentInstaller

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

EventLogInstaller Members | System.Diagnostics Namespace


EventLogInstaller Members

Public:

Constructor

EventLogInstaller Constructor [To be supplied.]

Properties

Context (inherited from Installer) | Gets or sets information about the current installation.
HelpText (inherited from Installer) | Gets the help text for all of the Installer objects contained in the Installers collection of this installer instance.
Installers (inherited from Installer) | Gets the collection of Installer objects contained in this Installer instance.
Log | The log in which the source will be created
Parent (inherited from Installer) | Gets or sets the Installer whose InstallerCollection contains this Installer instance.
Site (inherited from Component) | Gets or sets the site of the Component.
Source | The source to be created
UninstallAction | Determines whether the event log is removed at uninstall time.

Methods

Commit (inherited from Installer) | Completes the install transaction.
CopyFromComponent | A method on ComponentInstaller that lets us copy properties.
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Install | Called when we should perform the install. Inherited from Installer.
Rollback | Called when this or another component in the installation has failed.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
Uninstall | Called to remove the event log source from the machine.

Events

AfterCommit (inherited from Installer) | Occurs after the installations handled by the installers in the InstallerCollection of this instance are committed.
AfterInstall (inherited from Installer) | Occurs after the Install methods of all the installers in the InstallerCollection of this instance have run.
AfterRollback (inherited from Installer) | Occurs after the installations handled by the installers in the InstallerCollection of this instance are rolled back.
AfterUninstall (inherited from Installer) | Occurs after the installations handled by the installers in the InstallerCollection of this instance are uninstalled.
BeforeCommit (inherited from Installer) | Occurs before the installations handled by the installers in the InstallerCollection of this instance are committed.
BeforeInstall (inherited from Installer) | Occurs before the installers in the InstallerCollection of this instance are run.
BeforeRollback (inherited from Installer) | Occurs before the installations handled by the installers in the InstallerCollection of this instance are rolled back.
BeforeUninstall (inherited from Installer) | Occurs before the installations handled by the installers in the InstallerCollection of this instance are uninstalled.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCommit (inherited from Installer) | Raises the OnAfterCommit event.
OnAfterInstall (inherited from Installer) | Raises the OnAfterInstall event.
OnAfterRollback (inherited from Installer) | Raises the OnAfterRollback event.
OnAfterUninstall (inherited from Installer) | Raises the OnAfterUninstall event.
OnBeforeCommit (inherited from Installer) | Raises the OnBeforeCommit event.
OnBeforeInstall (inherited from Installer) | Raises the OnBeforeInstall event.
OnBeforeRollback (inherited from Installer) | Raises the OnBeforeRollback event.
OnBeforeUninstall (inherited from Installer) | Raises the OnBeforeUninstall event.

Event Hookup:

Methods

AddOnAfterCommit (inherited from Installer) | [To be supplied.]
AddOnAfterInstall (inherited from Installer) | [To be supplied.]
AddOnAfterRollback (inherited from Installer) | [To be supplied.]
AddOnAfterUninstall (inherited from Installer) | [To be supplied.]
AddOnBeforeCommit (inherited from Installer) | [To be supplied.]
AddOnBeforeInstall (inherited from Installer) | [To be supplied.]
AddOnBeforeRollback (inherited from Installer) | [To be supplied.]
AddOnBeforeUninstall (inherited from Installer) | [To be supplied.]
RemoveOnAfterCommit (inherited from Installer) | [To be supplied.]
RemoveOnAfterInstall (inherited from Installer) | [To be supplied.]
RemoveOnAfterRollback (inherited from Installer) | [To be supplied.]
RemoveOnAfterUninstall (inherited from Installer) | [To be supplied.]
RemoveOnBeforeCommit (inherited from Installer) | [To be supplied.]
RemoveOnBeforeInstall (inherited from Installer) | [To be supplied.]
RemoveOnBeforeRollback (inherited from Installer) | [To be supplied.]
RemoveOnBeforeUninstall (inherited from Installer) | [To be supplied.]

See Also

EventLogInstaller Class | System.Diagnostics Namespace


EventLogInstaller Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public EventLogInstaller();
[C++]
public: EventLogInstaller();
[JScript]
public function EventLogInstaller();

See Also

EventLogInstaller Class | EventLogInstaller Members | System.Diagnostics Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EventLogInstaller Properties

The properties of the EventLogInstaller class are listed below. For a complete list of EventLogInstaller class members, see the EventLogInstaller Members topic.

Public:

Context (inherited from Installer) | Gets or sets information about the current installation.
HelpText (inherited from Installer) | Gets the help text for all of the Installer objects contained in the Installers collection of this installer instance.
Installers (inherited from Installer) | Gets the collection of Installer objects contained in this Installer instance.
Log | The log in which the source will be created
Parent (inherited from Installer) | Gets or sets the Installer whose InstallerCollection contains this Installer instance.
Site (inherited from Component) | Gets or sets the site of the Component.
Source | The source to be created
UninstallAction | Determines whether the event log is removed at uninstall time.

See Also

EventLogInstaller Class | System.Diagnostics Namespace


EventLogInstaller.Log

The log in which the source will be created

[Visual Basic]
Public Property Log As String
[C#]
public string Log {get; set;}
[C++]
public: __property String* get_Log();
public: __property void set_Log(String*);
[JScript]
public function get Log() : String;
public function set Log(String);

See Also

EventLogInstaller Class | EventLogInstaller Members | System.Diagnostics Namespace


EventLogInstaller.Source

The source to be created

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property String* get_Source();
public: __property void set_Source(String*);
[JScript]
public function get Source() : String;
public function set Source(String);

See Also

EventLogInstaller Class | EventLogInstaller Members | System.Diagnostics Namespace


EventLogInstaller.UninstallAction

Determines whether the event log is removed at uninstall time.

[Visual Basic]
Public Property UninstallAction As UninstallAction
[C#]
public UninstallAction UninstallAction {get; set;}
[C++]
public: __property UninstallAction get_UninstallAction();
public: __property void set_UninstallAction(UninstallAction);
[JScript]
public function get UninstallAction() : UninstallAction;
public function set UninstallAction(UninstallAction);

See Also

EventLogInstaller Class | EventLogInstaller Members | System.Diagnostics Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EventLogInstaller Methods

The methods of the EventLogInstaller class are listed below. For a complete list of EventLogInstaller class members, see the EventLogInstaller Members topic.

Public:

Commit (inherited from Installer) | Completes the install transaction.
CopyFromComponent | A method on ComponentInstaller that lets us copy properties.
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Install | Called when we should perform the install. Inherited from Installer.
Rollback | Called when this or another component in the installation has failed.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
Uninstall | Called to remove the event log source from the machine.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCommit (inherited from Installer) | Raises the OnAfterCommit event.
OnAfterInstall (inherited from Installer) | Raises the OnAfterInstall event.
OnAfterRollback (inherited from Installer) | Raises the OnAfterRollback event.
OnAfterUninstall (inherited from Installer) | Raises the OnAfterUninstall event.
OnBeforeCommit (inherited from Installer) | Raises the OnBeforeCommit event.
OnBeforeInstall (inherited from Installer) | Raises the OnBeforeInstall event.
OnBeforeRollback (inherited from Installer) | Raises the OnBeforeRollback event.
OnBeforeUninstall (inherited from Installer) | Raises the OnBeforeUninstall event.

Event Hookup:

AddOnAfterCommit (inherited from Installer) | [To be supplied.]
AddOnAfterInstall (inherited from Installer) | [To be supplied.]
AddOnAfterRollback (inherited from Installer) | [To be supplied.]
AddOnAfterUninstall (inherited from Installer) | [To be supplied.]
AddOnBeforeCommit (inherited from Installer) | [To be supplied.]
AddOnBeforeInstall (inherited from Installer) | [To be supplied.]
AddOnBeforeRollback (inherited from Installer) | [To be supplied.]
AddOnBeforeUninstall (inherited from Installer) | [To be supplied.]
RemoveOnAfterCommit (inherited from Installer) | [To be supplied.]
RemoveOnAfterInstall (inherited from Installer) | [To be supplied.]
RemoveOnAfterRollback (inherited from Installer) | [To be supplied.]
RemoveOnAfterUninstall (inherited from Installer) | [To be supplied.]
RemoveOnBeforeCommit (inherited from Installer) | [To be supplied.]
RemoveOnBeforeInstall (inherited from Installer) | [To be supplied.]
RemoveOnBeforeRollback (inherited from Installer) | [To be supplied.]
RemoveOnBeforeUninstall (inherited from Installer) | [To be supplied.]

See Also

EventLogInstaller Class | System.Diagnostics Namespace


EventLogInstaller.CopyFromComponent

A method on ComponentInstaller that lets us copy properties.

[Visual Basic]
Overrides Public Sub CopyFromComponent( _
   ByVal component As IComponent _
)
[C#]
public override void CopyFromComponent(
   IComponent component
);
[C++]
public: override void CopyFromComponent(
   IComponent* component
);
[JScript]
public override function CopyFromComponent(
   component : IComponent
);

Parameters

component
[To be supplied.]

See Also

EventLogInstaller Class | EventLogInstaller Members | System.Diagnostics Namespace


EventLogInstaller.Install

Called when we should perform the install. Inherited from Installer.

[Visual Basic]
Overrides Public Sub Install( _
   ByVal savedState As IDictionary _
)
[C#]
public override void Install(
   IDictionary savedState
);
[C++]
public: override void Install(
   IDictionary* savedState
);
[JScript]
public override function Install(
   savedState : IDictionary
);

Parameters

savedState
[To be supplied.]

See Also

EventLogInstaller Class | EventLogInstaller Members | System.Diagnostics Namespace


EventLogInstaller.Rollback

Called when this or another component in the installation has failed.

[Visual Basic]
Overrides Public Sub Rollback( _
   ByVal savedState As IDictionary _
)
[C#]
public override void Rollback(
   IDictionary savedState
);
[C++]
public: override void Rollback(
   IDictionary* savedState
);
[JScript]
public override function Rollback(
   savedState : IDictionary
);

Parameters

savedState
[To be supplied.]

See Also

EventLogInstaller Class | EventLogInstaller Members | System.Diagnostics Namespace


EventLogInstaller.Uninstall

Called to remove the event log source from the machine.

[Visual Basic]
Overrides Public Sub Uninstall( _
   ByVal savedState As IDictionary _
)
[C#]
public override void Uninstall(
   IDictionary savedState
);
[C++]
public: override void Uninstall(
   IDictionary* savedState
);
[JScript]
public override function Uninstall(
   savedState : IDictionary
);

Parameters

savedState
[To be supplied.]

See Also

EventLogInstaller Class | EventLogInstaller Members | System.Diagnostics Namespace


EventLogNames Class

[To be supplied.]

Object
EventLogNames

[Visual Basic]
NotInheritable Public Class EventLogNames
[C#]
public sealed class EventLogNames
[C++]
public __gc __sealed class EventLogNames
[JScript]
public class EventLogNames

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

EventLogNames Members | System.Diagnostics Namespace


EventLogNames Members

Public:

Constructor

EventLogNames Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsValid | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Application | [To be supplied.]
Security | [To be supplied.]
System | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EventLogNames Class | System.Diagnostics Namespace


EventLogNames Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public EventLogNames();
[C++]
public: EventLogNames();
[JScript]
public function EventLogNames();

See Also

EventLogNames Class | EventLogNames Members | System.Diagnostics Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EventLogNames Methods

The methods of the EventLogNames class are listed below. For a complete list of EventLogNames class members, see the EventLogNames Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsValid | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EventLogNames Class | System.Diagnostics Namespace


EventLogNames.IsValid

[To be supplied.]

[Visual Basic]
Public Shared Function IsValid( _
   ByVal value As Integer _
) As Boolean
[C#]
public static bool IsValid(
   int value
);
[C++]
public: static bool IsValid(
   int value
);
[JScript]
public static function IsValid(
   value : int
) : Boolean;

Parameters

value
[To be supplied.]

See Also

EventLogNames Class | EventLogNames Members | System.Diagnostics Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EventLogNames Fields

The fields of the EventLogNames class are listed below. For a complete list of EventLogNames class members, see the EventLogNames Members topic.

Public:

Application | [To be supplied.]
Security | [To be supplied.]
System | [To be supplied.]

See Also

EventLogNames Class | System.Diagnostics Namespace


EventLogNames.Application

[To be supplied.]

[Visual Basic]
Public Const Application As Integer
[C#]
public const int Application;
[C++]
public: const int Application;
[JScript]
public var Application : int;

See Also

EventLogNames Class | EventLogNames Members | System.Diagnostics Namespace


EventLogNames.Security

[To be supplied.]

[Visual Basic]
Public Const Security As Integer
[C#]
public const int Security;
[C++]
public: const int Security;
[JScript]
public var Security : int;

See Also

EventLogNames Class | EventLogNames Members | System.Diagnostics Namespace


EventLogNames.System

[To be supplied.]

[Visual Basic]
Public Const System As Integer
[C#]
public const int System;
[C++]
public: const int System;
[JScript]
public var System : int;

See Also

EventLogNames Class | EventLogNames Members | System.Diagnostics Namespace


EventLogTraceListener Class

This class provides a simple listener for directing trace output to a text writer or stream, for example Console.Out or FileStream.

Object
TraceListener
EventLogTraceListener

[Visual Basic]
Public Class EventLogTraceListener
   Inherits TraceListener
[C#]
public class EventLogTraceListener : TraceListener
[C++]
public __gc class EventLogTraceListener : public TraceListener
[JScript]
public class EventLogTraceListener extends TraceListener

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

EventLogTraceListener Members | System.Diagnostics Namespace


EventLogTraceListener Members

Public:

Constructor

EventLogTraceListener Constructor Overloaded. [To be supplied.]

Properties

EventLog | The event log to write to.
Indent (inherited from TraceListener) | Gets or sets the indent level.
IndentSize (inherited from TraceListener) | Gets or sets the number of spaces in an indent.
Name | The name of this trace listener. Defaults to the source name of the event log.

Methods

Close | Closes the text writer.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Fail (inherited from TraceListener) | Overloaded. Emits or displays a message for an assertion that always fails.
Flush (inherited from TraceListener) | When overridden in a derived class, flushes the output buffer.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write (inherited from TraceListener) | Overloaded. Writes a message, category name, or object name.
WriteLine (inherited from TraceListener) | Overloaded. Writes a message, category name, or object name followed by a line terminator.

Protected:

Properties

NeedIndent (inherited from TraceListener) Gets or sets whether an indent is needed.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
WriteIndent (inherited from TraceListener) | Writes the indent and resets the NeedIndent property to false.

See Also

EventLogTraceListener Class | System.Diagnostics Namespace


EventLogTraceListener Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public EventLogTraceListener();
[C++] public: EventLogTraceListener();
[JScript] public function EventLogTraceListener();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(EventLog)
[C#] public EventLogTraceListener(EventLog);
[C++] public: EventLogTraceListener(EventLog*);
[JScript] public function EventLogTraceListener(EventLog);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public EventLogTraceListener(String);
[C++] public: EventLogTraceListener(String*);
[JScript] public function EventLogTraceListener(String);

See Also

EventLogTraceListener Class | EventLogTraceListener Members | System.Diagnostics Namespace


EventLogTraceListener Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public EventLogTraceListener();
[C++]
public: EventLogTraceListener();
[JScript]
public function EventLogTraceListener();

See Also

EventLogTraceListener Class | EventLogTraceListener Members | System.Diagnostics Namespace | EventLogTraceListener Constructor Overload List


EventLogTraceListener Constructor (EventLog)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal eventLog As EventLog _
)
[C#]
public EventLogTraceListener(
   EventLog eventLog
);
[C++]
public: EventLogTraceListener(
   EventLog* eventLog
);
[JScript]
public function EventLogTraceListener(
   eventLog : EventLog
);

Parameters

eventLog
[To be supplied.]

See Also

EventLogTraceListener Class | EventLogTraceListener Members | System.Diagnostics Namespace | EventLogTraceListener Constructor Overload List


EventLogTraceListener Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal source As String _
)
[C#]
public EventLogTraceListener(
   string source
);
[C++]
public: EventLogTraceListener(
   String* source
);
[JScript]
public function EventLogTraceListener(
   source : String
);

Parameters

source
[To be supplied.]

See Also

EventLogTraceListener Class | EventLogTraceListener Members | System.Diagnostics Namespace | EventLogTraceListener Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EventLogTraceListener Properties

The properties of the EventLogTraceListener class are listed below. For a complete list of EventLogTraceListener class members, see the EventLogTraceListener Members topic.

Public:

EventLog | The event log to write to.
Indent (inherited from TraceListener) | Gets or sets the indent level.
IndentSize (inherited from TraceListener) | Gets or sets the number of spaces in an indent.
Name | The name of this trace listener. Defaults to the source name of the event log.

Protected:

NeedIndent (inherited from TraceListener) Gets or sets whether an indent is needed.

See Also

EventLogTraceListener Class | System.Diagnostics Namespace


EventLogTraceListener.EventLog

The event log to write to.

[Visual Basic]
Overridable Public Property EventLog As EventLog
[C#]
public EventLog EventLog {virtual get; virtual set;}
[C++]
public: __property virtual EventLog* get_EventLog();
public: __property virtual void set_EventLog(EventLog*);
[JScript]
public function get EventLog() : EventLog;
public function set EventLog(EventLog);

See Also

EventLogTraceListener Class | EventLogTraceListener Members | System.Diagnostics Namespace


EventLogTraceListener.Name

The name of this trace listener. Defaults to the source name of the event log.

[Visual Basic]
Overridable Public Property Name As String
[C#]
public string Name {override get; override set;}
[C++]
public: __property virtual String* get_Name();
public: __property virtual void set_Name(String*);
[JScript]
public function get Name() : String;
public function set Name(String);

See Also

EventLogTraceListener Class | EventLogTraceListener Members | System.Diagnostics Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EventLogTraceListener Methods

The methods of the EventLogTraceListener class are listed below. For a complete list of EventLogTraceListener class members, see the EventLogTraceListener Members topic.

Public:

Close | Closes the text writer.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Fail (inherited from TraceListener) | Overloaded. Emits or displays a message for an assertion that always fails.
Flush (inherited from TraceListener) | When overridden in a derived class, flushes the output buffer.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write (inherited from TraceListener) | Overloaded. Writes a message, category name, or object name.
WriteLine (inherited from TraceListener) | Overloaded. Writes a message, category name, or object name followed by a line terminator.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
WriteIndent (inherited from TraceListener) | Writes the indent and resets the NeedIndent property to false.

See Also

EventLogTraceListener Class | System.Diagnostics Namespace


EventLogTraceListener.Close

Closes the text writer.

[Visual Basic]
Overrides Public Sub Close()
[C#]
public override void Close();
[C++]
public: override void Close();
[JScript]
public override function Close();

See Also

EventLogTraceListener Class | EventLogTraceListener Members | System.Diagnostics Namespace


EventLogTraceListener.Write

Writes to the event log.

[Visual Basic]
Overrides Public Sub Write( _
   ByVal message As String _
)
[C#]
public override void Write(
   string message
);
[C++]
public: override void Write(
   String* message
);
[JScript]
public override function Write(
   message : String
);

Parameters

message
[To be supplied.]

See Also

EventLogTraceListener Class | EventLogTraceListener Members | System.Diagnostics Namespace


EventLogTraceListener.WriteLine

Writes to the event log.

[Visual Basic]
Overrides Public Sub WriteLine( _
   ByVal message As String _
)
[C#]
public override void WriteLine(
   string message
);
[C++]
public: override void WriteLine(
   String* message
);
[JScript]
public override function WriteLine(
   message : String
);

Parameters

message
[To be supplied.]

See Also

EventLogTraceListener Class | EventLogTraceListener Members | System.Diagnostics Namespace


ICollectData Interface

[To be supplied.]

ICollectData

[Visual Basic]
Public Interface ICollectData
[C#]
public interface ICollectData
[C++]
public __gc __interface ICollectData

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement ICollectData

Class | Description
PerformanceCounterManager | [To be supplied.]

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

ICollectData Members | System.Diagnostics Namespace


ICollectData Members

Methods

CloseData | [To be supplied.]
CollectData | [To be supplied.]

See Also

ICollectData Interface | System.Diagnostics Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICollectData Methods

The methods of the ICollectData interface are listed below. For a complete list of ICollectData interface members, see the ICollectData Members topic.

CloseData | [To be supplied.]
CollectData | [To be supplied.]

See Also

ICollectData Interface | System.Diagnostics Namespace


ICollectData.CloseData

[To be supplied.]

[Visual Basic]
Sub CloseData()
[C#]
void CloseData();
[C++]
void CloseData() = 0;
[JScript]
function CloseData();

See Also

ICollectData Interface | ICollectData Members | System.Diagnostics Namespace


ICollectData.CollectData

[To be supplied.]

[Visual Basic]
Sub CollectData( _
   ByVal id As Integer, _
   ByVal valueName As Integer, _
   ByVal data As Integer, _
   ByVal totalBytes As Integer, _
   ByVal res() As Integer _
)
[C#]
void CollectData(
   in int id,
   in int valueName,
   in int data,
   in int totalBytes,
   out int[] res
);
[C++]
void CollectData(
   __in int id,
   __in int valueName,
   __in int data,
   __in int totalBytes,
   int** res[]
) = 0;
[JScript]
function CollectData(
   in id : int,
   in valueName : int,
   in data : int,
   in totalBytes : int,
   res : int[]
);

Parameters

id
[To be supplied.]
valueName
[To be supplied.]
data
[To be supplied.]
totalBytes
[To be supplied.]
res
[To be supplied.]

See Also

ICollectData Interface | ICollectData Members | System.Diagnostics Namespace


InstanceData Class

A holder of instance data.

Object
InstanceData

[Visual Basic]
Public Class InstanceData
[C#]
public class InstanceData
[C++]
public __gc class InstanceData
[JScript]
public class InstanceData

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

InstanceData Members | System.Diagnostics Namespace


InstanceData Members

Public:

Constructor

InstanceData Constructor [To be supplied.]

Properties

InstanceName | [To be supplied.]
RawValue | [To be supplied.]
Sample | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InstanceData Class | System.Diagnostics Namespace


InstanceData Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal instanceName As String, _
   ByVal sample As CounterSample _
)
[C#]
public InstanceData(
   string instanceName,
   CounterSample sample
);
[C++]
public: InstanceData(
   String* instanceName,
   CounterSample sample
);
[JScript]
public function InstanceData(
   instanceName : String,
   sample : CounterSample
);

Parameters

instanceName
[To be supplied.]
sample
[To be supplied.]

See Also

InstanceData Class | InstanceData Members | System.Diagnostics Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

InstanceData Properties

The properties of the InstanceData class are listed below. For a complete list of InstanceData class members, see the InstanceData Members topic.

Public:

InstanceName | [To be supplied.]
RawValue | [To be supplied.]
Sample | [To be supplied.]

See Also

InstanceData Class | System.Diagnostics Namespace


InstanceData.InstanceName

[To be supplied.]

[Visual Basic]
Public ReadOnly Property InstanceName As String
[C#]
public string InstanceName {get;}
[C++]
public: __property String* get_InstanceName();
[JScript]
public function get InstanceName() : String;

See Also

InstanceData Class | InstanceData Members | System.Diagnostics Namespace


InstanceData.RawValue

[To be supplied.]

[Visual Basic]
Public ReadOnly Property RawValue As Long
[C#]
public long RawValue {get;}
[C++]
public: __property __int64 get_RawValue();
[JScript]
public function get RawValue() : long;

See Also

InstanceData Class | InstanceData Members | System.Diagnostics Namespace


InstanceData.Sample

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Sample As CounterSample
[C#]
public CounterSample Sample {get;}
[C++]
public: __property CounterSample get_Sample();
[JScript]
public function get Sample() : CounterSample;

See Also

InstanceData Class | InstanceData Members | System.Diagnostics Namespace


InstancesData Class

A strongly typed collection containing InstanceData for a counter.

Object
Hashtable
InstancesData

[Visual Basic]
Public Class InstancesData
   Inherits Hashtable
[C#]
public class InstancesData : Hashtable
[C++]
public __gc class InstancesData : public Hashtable
[JScript]
public class InstancesData extends Hashtable

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

InstancesData Members | System.Diagnostics Namespace


InstancesData Members

Public:

Constructor

InstancesData Constructor [To be supplied.]

Properties

Count (inherited from Hashtable) | Gets the number of key-and-value pairs in the Hashtable.
CounterName | [To be supplied.]
IsReadOnly (inherited from Hashtable) | Gets a value indicating whether the Hashtable is read-only.
IsSynchronized (inherited from Hashtable) | Gets a value indicating whether access to the Hashtable is synchronized (thread-safe).
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the InstancesData class.
Keys (inherited from Hashtable) | Gets an ICollection containing the keys in the Hashtable.
SyncRoot (inherited from Hashtable) | Gets an object that can be used to synchronize access to the Hashtable.
Values (inherited from Hashtable) | Gets an ICollection containing the values in the Hashtable.

Methods

Add (inherited from Hashtable) | Adds an entry with the specified key and value into the Hashtable.
Clear (inherited from Hashtable) | Removes all entries from the Hashtable.
Clone (inherited from Hashtable) | Creates a shallow copy of the Hashtable.
Contains (inherited from Hashtable) | Determines if the Hashtable contains a specific key.
ContainsKey (inherited from Hashtable) | Determines if the Hashtable contains a specific key.
ContainsValue (inherited from Hashtable) | Determines if the Hashtable contains a specific value.
CopyTo (inherited from Hashtable) | Copies the Hashtable values into a one-dimensional Array instance at the specified index.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from Hashtable) | Returns an enumerator which can be used to iterate through the Hashtable.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Hashtable) | Implements the ISerializable interface and returns the data needed to serialize the Hashtable.
GetType (inherited from Object) | Gets the Type of the Object.
OnDeserialization (inherited from Hashtable) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from Hashtable) | Removes the entry with the specified key from the Hashtable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetHash (inherited from Hashtable) | Returns the hash code for the specified key.
KeyEquals (inherited from Hashtable) | Compares a specific Object with a specific key in the Hashtable.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

comparer (inherited from Hashtable) | Represents the comparer to use for the Hashtable.
hcp (inherited from Hashtable) | Represents the object that can dispense hash codes.

See Also

InstancesData Class | System.Diagnostics Namespace


InstancesData Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal counterName As String _
)
[C#]
public InstancesData(
   string counterName
);
[C++]
public: InstancesData(
   String* counterName
);
[JScript]
public function InstancesData(
   counterName : String
);

Parameters

counterName
[To be supplied.]

See Also

InstancesData Class | InstancesData Members | System.Diagnostics Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

InstancesData Properties

The properties of the InstancesData class are listed below. For a complete list of InstancesData class members, see the InstancesData Members topic.

Public:

Count (inherited from Hashtable) | Gets the number of key-and-value pairs in the Hashtable.
CounterName | [To be supplied.]
IsReadOnly (inherited from Hashtable) | Gets a value indicating whether the Hashtable is read-only.
IsSynchronized (inherited from Hashtable) | Gets a value indicating whether access to the Hashtable is synchronized (thread-safe).
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the InstancesData class.
Keys (inherited from Hashtable) | Gets an ICollection containing the keys in the Hashtable.
SyncRoot (inherited from Hashtable) | Gets an object that can be used to synchronize access to the Hashtable.
Values (inherited from Hashtable) | Gets an ICollection containing the values in the Hashtable.

See Also

InstancesData Class | System.Diagnostics Namespace


InstancesData.CounterName

[To be supplied.]

[Visual Basic]
Public ReadOnly Property CounterName As String
[C#]
public string CounterName {get;}
[C++]
public: __property String* get_CounterName();
[JScript]
public function get CounterName() : String;

See Also

InstancesData Class | InstancesData Members | System.Diagnostics Namespace


InstancesData.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the InstancesData class.

Overload List

[To be supplied.]

[Visual Basic] Overloads Property Item As Object
[C#] object Item {override set;}
[C++] public: __property virtual void set_Item(Object* key, Object*);
[JScript] InstancesData.Item ()

[To be supplied.]

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(String) As InstanceData
[C#] public InstanceData this[String] {virtual get;}
[C++] public: __property virtual InstanceData* get_Item(String*);
[JScript] InstancesData.Item (String)

See Also

InstancesData Class | InstancesData Members | System.Diagnostics Namespace


InstancesData.Item ()

[To be supplied.]

[C#] In C#, this member is the indexer for the InstancesData class.

[Visual Basic]
Overloads Property Item As Object
[C#]
object Item {override set;}
[C++]
public: __property virtual void set_Item(
   Object* key,
   Object*
);
[JScript]
public function set Item(Object);
-or-
public function set Item(Object);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

See Also

InstancesData Class | InstancesData Members | System.Diagnostics Namespace | InstancesData.Item Overload List


InstancesData.Item (String)

[To be supplied.]

[C#] In C#, this member is the indexer for the InstancesData class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal instanceName As String _
) As InstanceData
[C#]
public InstanceData this[
   string instanceName
] {virtual get;}
[C++]
public: __property virtual InstanceData* get_Item(
   String* instanceName
);
[JScript]
returnValue = InstancesDataObject.Item(instanceName);
-or-
returnValue = InstancesDataObject(instanceName);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

instanceName
[To be supplied.]

Parameters [Visual Basic, C#, C++]

instanceName
[To be supplied.]

See Also

InstancesData Class | InstancesData Members | System.Diagnostics Namespace | InstancesData.Item Overload List


PerformanceCounter Class

Performance Counter component. This class provides support for NT Performance counters. It handles both the existing counters (accesible by Perf Registry Interface) and user defined (extensible) counters. This class is a part of a larger framework, that includes the perf dll object and perf service.

Object
Component
PerformanceCounter

[Visual Basic]
Public Class PerformanceCounter
   Inherits Component
[C#]
public class PerformanceCounter : Component
[C++]
public __gc class PerformanceCounter : public Component
[JScript]
public class PerformanceCounter extends Component

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

PerformanceCounter Members | System.Diagnostics Namespace


PerformanceCounter Members

Public:

Constructor

PerformanceCounter Constructor Overloaded. [To be supplied.]

Properties

CategoryName | Returns the performance category name for this performance counter
CounterHelp | Returns the description message for this performance counter
CounterName | Sets/returns the performance counter name for this performance counter
CounterType | Sets/Returns the counter type for this performance counter
InstanceName | Sets/returns an instance name for this performance counter
MachineName | Set/returns the machine name for this performance counter
RawValue | Directly accesses the raw value of this counter. If counter type is of a 32-bit size, it will truncate the value given to 32 bits. This can be significantly more performant for scenarios where the raw value is sufficient. Note that this only works for custom counters created using this component, non-custom counters will throw an exception if this property is accessed.
ReadOnly | Returns true if counter is read only (system counter, foreign extensible counter or remote counter)
SingleInstance | Indicates if this counter only has a single instance. Some counters may support multiple instances, for example the processor counter will have one instance per processor on the machine.
Site (inherited from Component) | Gets or sets the site of the Component.

Methods

CategoryExists | Overloaded. [To be supplied.]
Close | Frees all the resources allocated by this counter
CloseSharedResources | Frees all the resources allocated for all performance counters, frees File Mapping used by extensible counters, unloads dll's used to read counters.
CreateCategory | Overloaded. [To be supplied.]
DeleteCategory | Overloaded. [To be supplied.]
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Exists | Overloaded. [To be supplied.]
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
IncrementBy | Increments the value of this counter. If counter type is of a 32-bit size, it'll truncate the value given to 32 bits.
IsSingleInstance | Returns true if the performance category for this object is a single instance category
NextSample | Obtains a counter sample and returns the raw value for it.
NextValue | Obtains a counter sample and returns the calculated value for it. NOTE: For counters whose calculated value depend upon 2 counter reads, the very first read will return 0.0.
ReadCategory | Reads all the counter and instance data of this performance category.
RefreshSharedResources | Used to refresh all the resources allocated for all performance counters, it will refresh the File Mapping used to write to extensible counters and the dll's used to read system counters.
RemoveInstance | Removes this counter instance from the shared memory
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PerformanceCounter Class | System.Diagnostics Namespace


PerformanceCounter Constructor

[To be supplied.]

Overload List

The defaut constructor. Creates the perf counter object

[Visual Basic] Overloads Public Sub New()
[C#] public PerformanceCounter();
[C++] public: PerformanceCounter();
[JScript] public function PerformanceCounter();

Creates the Performance Counter Object

[Visual Basic] Overloads Public Sub New(String, String, String, String)
[C#] public PerformanceCounter(String, String, String, String);
[C++] public: PerformanceCounter(String*, String*, String*, String*);
[JScript] public function PerformanceCounter(String, String, String, String);

Creates the Performance Counter Object on local machine.

[Visual Basic] Overloads Public Sub New(String, String, String)
[C#] public PerformanceCounter(String, String, String);
[C++] public: PerformanceCounter(String*, String*, String*);
[JScript] public function PerformanceCounter(String, String, String);

Creates the Performance Counter Object, assumes that it's a single instance

[Visual Basic] Overloads Public Sub New(String, String)
[C#] public PerformanceCounter(String, String);
[C++] public: PerformanceCounter(String*, String*);
[JScript] public function PerformanceCounter(String, String);

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace


PerformanceCounter Constructor ()

The defaut constructor. Creates the perf counter object

[Visual Basic]
Overloads Public Sub New()
[C#]
public PerformanceCounter();
[C++]
public: PerformanceCounter();
[JScript]
public function PerformanceCounter();

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace | PerformanceCounter Constructor Overload List


PerformanceCounter Constructor (String, String, String, String)

Creates the Performance Counter Object

[Visual Basic]
Overloads Public Sub New( _
   ByVal categoryName As String, _
   ByVal counterName As String, _
   ByVal instanceName As String, _
   ByVal machineName As String _
)
[C#]
public PerformanceCounter(
   string categoryName,
   string counterName,
   string instanceName,
   string machineName
);
[C++]
public: PerformanceCounter(
   String* categoryName,
   String* counterName,
   String* instanceName,
   String* machineName
);
[JScript]
public function PerformanceCounter(
   categoryName : String,
   counterName : String,
   instanceName : String,
   machineName : String
);

Parameters

categoryName
performance category name
counterName
name of the performance counter
instanceName
name of the performance category instance
machineName
performance counter on that machine

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace | PerformanceCounter Constructor Overload List


PerformanceCounter Constructor (String, String, String)

Creates the Performance Counter Object on local machine.

[Visual Basic]
Overloads Public Sub New( _
   ByVal categoryName As String, _
   ByVal counterName As String, _
   ByVal instanceName As String _
)
[C#]
public PerformanceCounter(
   string categoryName,
   string counterName,
   string instanceName
);
[C++]
public: PerformanceCounter(
   String* categoryName,
   String* counterName,
   String* instanceName
);
[JScript]
public function PerformanceCounter(
   categoryName : String,
   counterName : String,
   instanceName : String
);

Parameters

categoryName
performance category name
counterName
name of the performance counter
instanceName
name of the performance category instance

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace | PerformanceCounter Constructor Overload List


PerformanceCounter Constructor (String, String)

Creates the Performance Counter Object, assumes that it's a single instance

[Visual Basic]
Overloads Public Sub New( _
   ByVal categoryName As String, _
   ByVal counterName As String _
)
[C#]
public PerformanceCounter(
   string categoryName,
   string counterName
);
[C++]
public: PerformanceCounter(
   String* categoryName,
   String* counterName
);
[JScript]
public function PerformanceCounter(
   categoryName : String,
   counterName : String
);

Parameters

categoryName
performance category name
counterName
name of the performance counter

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace | PerformanceCounter Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PerformanceCounter Properties

The properties of the PerformanceCounter class are listed below. For a complete list of PerformanceCounter class members, see the PerformanceCounter Members topic.

Public:

CategoryName | Returns the performance category name for this performance counter
CounterHelp | Returns the description message for this performance counter
CounterName | Sets/returns the performance counter name for this performance counter
CounterType | Sets/Returns the counter type for this performance counter
InstanceName | Sets/returns an instance name for this performance counter
MachineName | Set/returns the machine name for this performance counter
RawValue | Directly accesses the raw value of this counter. If counter type is of a 32-bit size, it will truncate the value given to 32 bits. This can be significantly more performant for scenarios where the raw value is sufficient. Note that this only works for custom counters created using this component, non-custom counters will throw an exception if this property is accessed.
ReadOnly | Returns true if counter is read only (system counter, foreign extensible counter or remote counter)
SingleInstance | Indicates if this counter only has a single instance. Some counters may support multiple instances, for example the processor counter will have one instance per processor on the machine.
Site (inherited from Component) | Gets or sets the site of the Component.

See Also

PerformanceCounter Class | System.Diagnostics Namespace


PerformanceCounter.CategoryName

Returns the performance category name for this performance counter

[Visual Basic]
Public Property CategoryName As String
[C#]
public string CategoryName {get; set;}
[C++]
public: __property String* get_CategoryName();
public: __property void set_CategoryName(String*);
[JScript]
public function get CategoryName() : String;
public function set CategoryName(String);

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace


PerformanceCounter.CounterHelp

Returns the description message for this performance counter

[Visual Basic]
Public ReadOnly Property CounterHelp As String
[C#]
public string CounterHelp {get;}
[C++]
public: __property String* get_CounterHelp();
[JScript]
public function get CounterHelp() : String;

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace


PerformanceCounter.CounterName

Sets/returns the performance counter name for this performance counter

[Visual Basic]
Public Property CounterName As String
[C#]
public string CounterName {get; set;}
[C++]
public: __property String* get_CounterName();
public: __property void set_CounterName(String*);
[JScript]
public function get CounterName() : String;
public function set CounterName(String);

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace


PerformanceCounter.CounterType

Sets/Returns the counter type for this performance counter

[Visual Basic]
Public ReadOnly Property CounterType As PerformanceCounterType
[C#]
public PerformanceCounterType CounterType {get;}
[C++]
public: __property PerformanceCounterType get_CounterType();
[JScript]
public function get CounterType() : PerformanceCounterType;

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace


PerformanceCounter.InstanceName

Sets/returns an instance name for this performance counter

[Visual Basic]
Public Property InstanceName As String
[C#]
public string InstanceName {get; set;}
[C++]
public: __property String* get_InstanceName();
public: __property void set_InstanceName(String*);
[JScript]
public function get InstanceName() : String;
public function set InstanceName(String);

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace


PerformanceCounter.MachineName

Set/returns the machine name for this performance counter

[Visual Basic]
Public Property MachineName As String
[C#]
public string MachineName {get; set;}
[C++]
public: __property String* get_MachineName();
public: __property void set_MachineName(String*);
[JScript]
public function get MachineName() : String;
public function set MachineName(String);

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace


PerformanceCounter.RawValue

Directly accesses the raw value of this counter. If counter type is of a 32-bit size, it will truncate the value given to 32 bits. This can be significantly more performant for scenarios where the raw value is sufficient. Note that this only works for custom counters created using this component, non-custom counters will throw an exception if this property is accessed.

[Visual Basic]
Public Property RawValue As Long
[C#]
public long RawValue {get; set;}
[C++]
public: __property __int64 get_RawValue();
public: __property void set_RawValue(__int64);
[JScript]
public function get RawValue() : long;
public function set RawValue(long);

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace


PerformanceCounter.ReadOnly

Returns true if counter is read only (system counter, foreign extensible counter or remote counter)

[Visual Basic]
Public ReadOnly Property ReadOnly As Boolean
[C#]
public bool ReadOnly {get;}
[C++]
public: __property bool get_ReadOnly();
[JScript]
public function get ReadOnly() : Boolean;

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace


PerformanceCounter.SingleInstance

Indicates if this counter only has a single instance. Some counters may support multiple instances, for example the processor counter will have one instance per processor on the machine.

[Visual Basic]
Public ReadOnly Property SingleInstance As Boolean
[C#]
public bool SingleInstance {get;}
[C++]
public: __property bool get_SingleInstance();
[JScript]
public function get SingleInstance() : Boolean;

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PerformanceCounter Methods

The methods of the PerformanceCounter class are listed below. For a complete list of PerformanceCounter class members, see the PerformanceCounter Members topic.

Public:

CategoryExists | Overloaded. [To be supplied.]
Close | Frees all the resources allocated by this counter
CloseSharedResources | Frees all the resources allocated for all performance counters, frees File Mapping used by extensible counters, unloads dll's used to read counters.
CreateCategory | Overloaded. [To be supplied.]
DeleteCategory | Overloaded. [To be supplied.]
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Exists | Overloaded. [To be supplied.]
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
IncrementBy | Increments the value of this counter. If counter type is of a 32-bit size, it'll truncate the value given to 32 bits.
IsSingleInstance | Returns true if the performance category for this object is a single instance category
NextSample | Obtains a counter sample and returns the raw value for it.
NextValue | Obtains a counter sample and returns the calculated value for it. NOTE: For counters whose calculated value depend upon 2 counter reads, the very first read will return 0.0.
ReadCategory | Reads all the counter and instance data of this performance category.
RefreshSharedResources | Used to refresh all the resources allocated for all performance counters, it will refresh the File Mapping used to write to extensible counters and the dll's used to read system counters.
RemoveInstance | Removes this counter instance from the shared memory
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PerformanceCounter Class | System.Diagnostics Namespace


PerformanceCounter.CategoryExists

[To be supplied.]

Overload List

Returns true if the category is registered in the machine.

[Visual Basic] Overloads Public Shared Function CategoryExists(String, String) As Boolean
[C#] public static bool CategoryExists(String, String);
[C++] public: static bool CategoryExists(String*, String*);
[JScript] public static function CategoryExists(String, String) : Boolean;

Returns a bool of whether the categoryName is in the system or not.

[Visual Basic] Overloads Public Shared Function CategoryExists(String) As Boolean
[C#] public static bool CategoryExists(String);
[C++] public: static bool CategoryExists(String*);
[JScript] public static function CategoryExists(String) : Boolean;

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace


PerformanceCounter.CategoryExists (String, String)

Returns true if the category is registered in the machine.

[Visual Basic]
Overloads Public Shared Function CategoryExists( _
   ByVal categoryName As String, _
   ByVal machineName As String _
) As Boolean
[C#]
public static bool CategoryExists(
   string categoryName,
   string machineName
);
[C++]
public: static bool CategoryExists(
   String* categoryName,
   String* machineName
);
[JScript]
public static function CategoryExists(
   categoryName : String,
   machineName : String
) : Boolean;

Parameters

categoryName
performance category to look for
machineName
the machine to look on

Return Value

true if the category is registered, false otherwise.

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace | PerformanceCounter.CategoryExists Overload List


PerformanceCounter.CategoryExists (String)

Returns a bool of whether the categoryName is in the system or not.

[Visual Basic]
Overloads Public Shared Function CategoryExists( _
   ByVal categoryName As String _
) As Boolean
[C#]
public static bool CategoryExists(
   string categoryName
);
[C++]
public: static bool CategoryExists(
   String* categoryName
);
[JScript]
public static function CategoryExists(
   categoryName : String
) : Boolean;

Parameters

categoryName
performance category from which to remove a counter

Return Value

true if the categoryName exists, false otherwise

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace | PerformanceCounter.CategoryExists Overload List


PerformanceCounter.Close

Frees all the resources allocated by this counter

[Visual Basic]
Public Sub Close()
[C#]
public void Close();
[C++]
public: void Close();
[JScript]
public function Close();

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace


PerformanceCounter.CloseSharedResources

Frees all the resources allocated for all performance counters, frees File Mapping used by extensible counters, unloads dll's used to read counters.

[Visual Basic]
Public Shared Sub CloseSharedResources()
[C#]
public static void CloseSharedResources();
[C++]
public: static void CloseSharedResources();
[JScript]
public static function CloseSharedResources();

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace


PerformanceCounter.CreateCategory

[To be supplied.]

Overload List

Registers one extensible performance category of type NumberOfItems32 with the system

[Visual Basic] Overloads Public Shared Function CreateCategory(String, String, String, String) As PerformanceCounterCategory
[C#] public static PerformanceCounterCategory CreateCategory(String, String, String, String);
[C++] public: static PerformanceCounterCategory* CreateCategory(String*, String*, String*, String*);
[JScript] public static function CreateCategory(String, String, String, String) : PerformanceCounterCategory;

Registers the extensible performance category with the system

[Visual Basic] Overloads Public Shared Function CreateCategory(String, String, CounterCreationData(), String) As PerformanceCounterCategory
[C#] public static PerformanceCounterCategory CreateCategory(String, String, CounterCreationData[], String);
[C++] public: static PerformanceCounterCategory* CreateCategory(String*, String*, CounterCreationData[], String*);
[JScript] public static function CreateCategory(String, String, CounterCreationData[], String) : PerformanceCounterCategory;

Registers the extensible performance category with the system

[Visual Basic] Overloads Public Shared Function CreateCategory(String, String, CounterCreationData()) As PerformanceCounterCategory
[C#] public static PerformanceCounterCategory CreateCategory(String, String, CounterCreationData[]);
[C++] public: static PerformanceCounterCategory* CreateCategory(String*, String*, CounterCreationData[]);
[JScript] public static function CreateCategory(String, String, CounterCreationData[]) : PerformanceCounterCategory;

Registers one extensible performance category of type NumberOfItems32 with the system

[Visual Basic] Overloads Public Shared Function CreateCategory(String, String, String, String, String) As PerformanceCounterCategory
[C#] public static PerformanceCounterCategory CreateCategory(String, String, String, String, String);
[C++] public: static PerformanceCounterCategory* CreateCategory(String*, String*, String*, String*, String*);
[JScript] public static function CreateCategory(String, String, String, String, String) : PerformanceCounterCategory;

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace


PerformanceCounter.CreateCategory (String, String, String, String)

Registers one extensible performance category of type NumberOfItems32 with the system

[Visual Basic]
Overloads Public Shared Function CreateCategory( _
   ByVal categoryName As String, _
   ByVal categoryHelp As String, _
   ByVal counterName As String, _
   ByVal counterHelp As String _
) As PerformanceCounterCategory
[C#]
public static PerformanceCounterCategory CreateCategory(
   string categoryName,
   string categoryHelp,
   string counterName,
   string counterHelp
);
[C++]
public: static PerformanceCounterCategory* CreateCategory(
   String* categoryName,
   String* categoryHelp,
   String* counterName,
   String* counterHelp
);
[JScript]
public static function CreateCategory(
   categoryName : String,
   categoryHelp : String,
   counterName : String,
   counterHelp : String
) : PerformanceCounterCategory;

Parameters

categoryName
performance category name
categoryHelp
description message for the category
counterName
name of the performance counter
counterHelp
description message for the counter

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace | PerformanceCounter.CreateCategory Overload List


PerformanceCounter.CreateCategory (String, String, CounterCreationData[], String)

Registers the extensible performance category with the system

[Visual Basic]
Overloads Public Shared Function CreateCategory( _
   ByVal categoryName As String, _
   ByVal categoryHelp As String, _
   ByVal counterData() As CounterCreationData, _
   ByVal machineName As String _
) As PerformanceCounterCategory
[C#]
public static PerformanceCounterCategory CreateCategory(
   string categoryName,
   string categoryHelp,
   CounterCreationData[] counterData,
   string machineName
);
[C++]
public: static PerformanceCounterCategory* CreateCategory(
   String* categoryName,
   String* categoryHelp,
   CounterCreationData* counterData[],
   String* machineName
);
[JScript]
public static function CreateCategory(
   categoryName : String,
   categoryHelp : String,
   counterData : CounterCreationData[],
   machineName : String
) : PerformanceCounterCategory;

Parameters

categoryName
performance category name
categoryHelp
description message for the category
counterData
collection of CounterCreationData specifying the counters to be created
machineName
machine in which to register the counter.

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace | PerformanceCounter.CreateCategory Overload List


PerformanceCounter.CreateCategory (String, String, CounterCreationData[])

Registers the extensible performance category with the system

[Visual Basic]
Overloads Public Shared Function CreateCategory( _
   ByVal categoryName As String, _
   ByVal categoryHelp As String, _
   ByVal creationData() As CounterCreationData _
) As PerformanceCounterCategory
[C#]
public static PerformanceCounterCategory CreateCategory(
   string categoryName,
   string categoryHelp,
   CounterCreationData[] creationData
);
[C++]
public: static PerformanceCounterCategory* CreateCategory(
   String* categoryName,
   String* categoryHelp,
   CounterCreationData* creationData[]
);
[JScript]
public static function CreateCategory(
   categoryName : String,
   categoryHelp : String,
   creationData : CounterCreationData[]
) : PerformanceCounterCategory;

Parameters

categoryName
performance category name
categoryHelp
description message for the category
creationData
collection of CounterCreationData specifying the counters to be created

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace | PerformanceCounter.CreateCategory Overload List


PerformanceCounter.CreateCategory (String, String, String, String, String)

Registers one extensible performance category of type NumberOfItems32 with the system

[Visual Basic]
Overloads Public Shared Function CreateCategory( _
   ByVal categoryName As String, _
   ByVal categoryHelp As String, _
   ByVal counterName As String, _
   ByVal counterHelp As String, _
   ByVal machineName As String _
) As PerformanceCounterCategory
[C#]
public static PerformanceCounterCategory CreateCategory(
   string categoryName,
   string categoryHelp,
   string counterName,
   string counterHelp,
   string machineName
);
[C++]
public: static PerformanceCounterCategory* CreateCategory(
   String* categoryName,
   String* categoryHelp,
   String* counterName,
   String* counterHelp,
   String* machineName
);
[JScript]
public static function CreateCategory(
   categoryName : String,
   categoryHelp : String,
   counterName : String,
   counterHelp : String,
   machineName : String
) : PerformanceCounterCategory;

Parameters

categoryName
performance category name
categoryHelp
description message for the category
counterName
name of the performance counter
counterHelp
description message for the counter
machineName
machine in which to register the counter.

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace | PerformanceCounter.CreateCategory Overload List


PerformanceCounter.DeleteCategory

[To be supplied.]

Overload List

Removes the counter (category) from the system

[Visual Basic] Overloads Public Shared Sub DeleteCategory(String)
[C#] public static void DeleteCategory(String);
[C++] public: static void DeleteCategory(String*);
[JScript] public static function DeleteCategory(String);

Removes the counter (category) from the system

[Visual Basic] Overloads Public Shared Sub DeleteCategory(String, String)
[C#] public static void DeleteCategory(String, String);
[C++] public: static void DeleteCategory(String*, String*);
[JScript] public static function DeleteCategory(String, String);

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace


PerformanceCounter.DeleteCategory (String)

Removes the counter (category) from the system

[Visual Basic]
Overloads Public Shared Sub DeleteCategory( _
   ByVal categoryName As String _
)
[C#]
public static void DeleteCategory(
   string categoryName
);
[C++]
public: static void DeleteCategory(
   String* categoryName
);
[JScript]
public static function DeleteCategory(
   categoryName : String
);

Parameters

categoryName
performance category from which to remove a counter

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace | PerformanceCounter.DeleteCategory Overload List


PerformanceCounter.DeleteCategory (String, String)

Removes the counter (category) from the system

[Visual Basic]
Overloads Public Shared Sub DeleteCategory( _
   ByVal categoryName As String, _
   ByVal machineName As String _
)
[C#]
public static void DeleteCategory(
   string categoryName,
   string machineName
);
[C++]
public: static void DeleteCategory(
   String* categoryName,
   String* machineName
);
[JScript]
public static function DeleteCategory(
   categoryName : String,
   machineName : String
);

Parameters

categoryName
performance category from which to remove a counter
machineName
machine in which to delete the counter.

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace | PerformanceCounter.DeleteCategory Overload List


PerformanceCounter.Exists

[To be supplied.]

Overload List

Returns true if the counter is registered for this category on the current machine.

[Visual Basic] Overloads Public Shared Function Exists(String, String) As Boolean
[C#] public static bool Exists(String, String);
[C++] public: static bool Exists(String*, String*);
[JScript] public static function Exists(String, String) : Boolean;

Returns true if the counter is registered for this category on a particular machine.

[Visual Basic] Overloads Public Shared Function Exists(String, String, String) As Boolean
[C#] public static bool Exists(String, String, String);
[C++] public: static bool Exists(String*, String*, String*);
[JScript] public static function Exists(String, String, String) : Boolean;

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace


PerformanceCounter.Exists (String, String)

Returns true if the counter is registered for this category on the current machine.

[Visual Basic]
Overloads Public Shared Function Exists( _
   ByVal categoryName As String, _
   ByVal counterName As String _
) As Boolean
[C#]
public static bool Exists(
   string categoryName,
   string counterName
);
[C++]
public: static bool Exists(
   String* categoryName,
   String* counterName
);
[JScript]
public static function Exists(
   categoryName : String,
   counterName : String
) : Boolean;

Parameters

categoryName
[To be supplied.]
counterName
[To be supplied.]

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace | PerformanceCounter.Exists Overload List


PerformanceCounter.Exists (String, String, String)

Returns true if the counter is registered for this category on a particular machine.

[Visual Basic]
Overloads Public Shared Function Exists( _
   ByVal categoryName As String, _
   ByVal counterName As String, _
   ByVal machineName As String _
) As Boolean
[C#]
public static bool Exists(
   string categoryName,
   string counterName,
   string machineName
);
[C++]
public: static bool Exists(
   String* categoryName,
   String* counterName,
   String* machineName
);
[JScript]
public static function Exists(
   categoryName : String,
   counterName : String,
   machineName : String
) : Boolean;

Parameters

categoryName
[To be supplied.]
counterName
[To be supplied.]
machineName
[To be supplied.]

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace | PerformanceCounter.Exists Overload List


PerformanceCounter.IncrementBy

Increments the value of this counter. If counter type is of a 32-bit size, it'll truncate the value given to 32 bits.

[Visual Basic]
Public Function IncrementBy( _
   ByVal value As Long _
) As Long
[C#]
public long IncrementBy(
   long value
);
[C++]
public: __int64 IncrementBy(
   __int64 value
);
[JScript]
public function IncrementBy(
   value : long
) : long;

Parameters

value
Value to increment (decrements with a negative value).

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace


PerformanceCounter.IsSingleInstance

Returns true if the performance category for this object is a single instance category

[Visual Basic]
Public Shared Function IsSingleInstance( _
   ByVal categoryName As String, _
   ByVal machineName As String _
) As Boolean
[C#]
public static bool IsSingleInstance(
   string categoryName,
   string machineName
);
[C++]
public: static bool IsSingleInstance(
   String* categoryName,
   String* machineName
);
[JScript]
public static function IsSingleInstance(
   categoryName : String,
   machineName : String
) : Boolean;

Parameters

categoryName
[To be supplied.]
machineName
[To be supplied.]

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace


PerformanceCounter.NextSample

Obtains a counter sample and returns the raw value for it.

[Visual Basic]
Public Function NextSample() As CounterSample
[C#]
public CounterSample NextSample();
[C++]
public: CounterSample NextSample();
[JScript]
public function NextSample() : CounterSample;

Return Value

Returns the next CounterSample value for this counter.

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace


PerformanceCounter.NextValue

Obtains a counter sample and returns the calculated value for it. NOTE: For counters whose calculated value depend upon 2 counter reads, the very first read will return 0.0.

[Visual Basic]
Public Function NextValue() As Single
[C#]
public float NextValue();
[C++]
public: float NextValue();
[JScript]
public function NextValue() : float;

Return Value

Returns the next calculated value for this counter.

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace


PerformanceCounter.ReadCategory

Reads all the counter and instance data of this performance category.

[Visual Basic]
Public Function ReadCategory() As CountersData
[C#]
public CountersData ReadCategory();
[C++]
public: CountersData* ReadCategory();
[JScript]
public function ReadCategory() : CountersData;

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace


PerformanceCounter.RefreshSharedResources

Used to refresh all the resources allocated for all performance counters, it will refresh the File Mapping used to write to extensible counters and the dll's used to read system counters.

[Visual Basic]
Public Shared Sub RefreshSharedResources()
[C#]
public static void RefreshSharedResources();
[C++]
public: static void RefreshSharedResources();
[JScript]
public static function RefreshSharedResources();

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace


PerformanceCounter.RemoveInstance

Removes this counter instance from the shared memory

[Visual Basic]
Public Sub RemoveInstance()
[C#]
public void RemoveInstance();
[C++]
public: void RemoveInstance();
[JScript]
public function RemoveInstance();

See Also

PerformanceCounter Class | PerformanceCounter Members | System.Diagnostics Namespace


PerformanceCounterCategory Class

A Performance counter category object.

Object
PerformanceCounterCategory

[Visual Basic]
Public Class PerformanceCounterCategory
[C#]
public class PerformanceCounterCategory
[C++]
public __gc class PerformanceCounterCategory
[JScript]
public class PerformanceCounterCategory

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

PerformanceCounterCategory Members | System.Diagnostics Namespace


PerformanceCounterCategory Members

Public:

Constructor

PerformanceCounterCategory Constructor Overloaded. [To be supplied.]

Properties

CategoryHelp | Gets/sets the Category help
CategoryName | Gets/sets the Category name
MachineName | Gets/sets the Machine name

Methods

CounterExists | Returns true if the counter is registered for this category
Create | Overloaded. [To be supplied.]
Delete | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Exists | Overloaded. [To be supplied.]
GetCategories | Overloaded. [To be supplied.]
GetCounters | Returns an array of counters in this category
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInstanceNames | Returns an array of instances for this category
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PerformanceCounterCategory Class | System.Diagnostics Namespace


PerformanceCounterCategory Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public PerformanceCounterCategory();
[C++] public: PerformanceCounterCategory();
[JScript] public function PerformanceCounterCategory();

Creates a PerformanceCounterCategory object for given category. Uses the local machine.

[Visual Basic] Overloads Public Sub New(String)
[C#] public PerformanceCounterCategory(String);
[C++] public: PerformanceCounterCategory(String*);
[JScript] public function PerformanceCounterCategory(String);

Creates a PerformanceCounterCategory object for given category. Uses the given machine name.

[Visual Basic] Overloads Public Sub New(String, String)
[C#] public PerformanceCounterCategory(String, String);
[C++] public: PerformanceCounterCategory(String*, String*);
[JScript] public function PerformanceCounterCategory(String, String);

See Also

PerformanceCounterCategory Class | PerformanceCounterCategory Members | System.Diagnostics Namespace


PerformanceCounterCategory Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public PerformanceCounterCategory();
[C++]
public: PerformanceCounterCategory();
[JScript]
public function PerformanceCounterCategory();

See Also

PerformanceCounterCategory Class | PerformanceCounterCategory Members | System.Diagnostics Namespace | PerformanceCounterCategory Constructor Overload List


PerformanceCounterCategory Constructor (String)

Creates a PerformanceCounterCategory object for given category. Uses the local machine.

[Visual Basic]
Overloads Public Sub New( _
   ByVal categoryName As String _
)
[C#]
public PerformanceCounterCategory(
   string categoryName
);
[C++]
public: PerformanceCounterCategory(
   String* categoryName
);
[JScript]
public function PerformanceCounterCategory(
   categoryName : String
);

Parameters

categoryName
Category name

See Also

PerformanceCounterCategory Class | PerformanceCounterCategory Members | System.Diagnostics Namespace | PerformanceCounterCategory Constructor Overload List


PerformanceCounterCategory Constructor (String, String)

Creates a PerformanceCounterCategory object for given category. Uses the given machine name.

[Visual Basic]
Overloads Public Sub New( _
   ByVal categoryName As String, _
   ByVal machineName As String _
)
[C#]
public PerformanceCounterCategory(
   string categoryName,
   string machineName
);
[C++]
public: PerformanceCounterCategory(
   String* categoryName,
   String* machineName
);
[JScript]
public function PerformanceCounterCategory(
   categoryName : String,
   machineName : String
);

Parameters

categoryName
Category name
machineName
Machine to connect

See Also

PerformanceCounterCategory Class | PerformanceCounterCategory Members | System.Diagnostics Namespace | PerformanceCounterCategory Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PerformanceCounterCategory Properties

The properties of the PerformanceCounterCategory class are listed below. For a complete list of PerformanceCounterCategory class members, see the PerformanceCounterCategory Members topic.

Public:

CategoryHelp | Gets/sets the Category help
CategoryName | Gets/sets the Category name
MachineName | Gets/sets the Machine name

See Also

PerformanceCounterCategory Class | System.Diagnostics Namespace


PerformanceCounterCategory.CategoryHelp

Gets/sets the Category help

[Visual Basic]
Public ReadOnly Property CategoryHelp As String
[C#]
public string CategoryHelp {get;}
[C++]
public: __property String* get_CategoryHelp();
[JScript]
public function get CategoryHelp() : String;

See Also

PerformanceCounterCategory Class | PerformanceCounterCategory Members | System.Diagnostics Namespace


PerformanceCounterCategory.CategoryName

Gets/sets the Category name

[Visual Basic]
Public Property CategoryName As String
[C#]
public string CategoryName {get; set;}
[C++]
public: __property String* get_CategoryName();
public: __property void set_CategoryName(String*);
[JScript]
public function get CategoryName() : String;
public function set CategoryName(String);

See Also

PerformanceCounterCategory Class | PerformanceCounterCategory Members | System.Diagnostics Namespace


PerformanceCounterCategory.MachineName

Gets/sets the Machine name

[Visual Basic]
Public Property MachineName As String
[C#]
public string MachineName {get; set;}
[C++]
public: __property String* get_MachineName();
public: __property void set_MachineName(String*);
[JScript]
public function get MachineName() : String;
public function set MachineName(String);

See Also

PerformanceCounterCategory Class | PerformanceCounterCategory Members | System.Diagnostics Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PerformanceCounterCategory Methods

The methods of the PerformanceCounterCategory class are listed below. For a complete list of PerformanceCounterCategory class members, see the PerformanceCounterCategory Members topic.

Public:

CounterExists | Returns true if the counter is registered for this category
Create | Overloaded. [To be supplied.]
Delete | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Exists | Overloaded. [To be supplied.]
GetCategories | Overloaded. [To be supplied.]
GetCounters | Returns an array of counters in this category
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInstanceNames | Returns an array of instances for this category
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PerformanceCounterCategory Class | System.Diagnostics Namespace


PerformanceCounterCategory.CounterExists

Returns true if the counter is registered for this category

[Visual Basic]
Public Function CounterExists( _
   ByVal counterName As String _
) As Boolean
[C#]
public bool CounterExists(
   string counterName
);
[C++]
public: bool CounterExists(
   String* counterName
);
[JScript]
public function CounterExists(
   counterName : String
) : Boolean;

Parameters

counterName
counter to look for

Return Value

true if the counter is registered, false otherwise

See Also

PerformanceCounterCategory Class | PerformanceCounterCategory Members | System.Diagnostics Namespace


PerformanceCounterCategory.Create

[To be supplied.]

Overload List

Registers the extensible performance category with the system

[Visual Basic] Overloads Public Shared Function Create(String, String, CounterCreationData(), String) As PerformanceCounterCategory
[C#] public static PerformanceCounterCategory Create(String, String, CounterCreationData[], String);
[C++] public: static PerformanceCounterCategory* Create(String*, String*, CounterCreationData[], String*);
[JScript] public static function Create(String, String, CounterCreationData[], String) : PerformanceCounterCategory;

Registers the extensible performance category with the system on the local machine

[Visual Basic] Overloads Public Shared Function Create(String, String, CounterCreationData()) As PerformanceCounterCategory
[C#] public static PerformanceCounterCategory Create(String, String, CounterCreationData[]);
[C++] public: static PerformanceCounterCategory* Create(String*, String*, CounterCreationData[]);
[JScript] public static function Create(String, String, CounterCreationData[]) : PerformanceCounterCategory;

Registers one extensible performance category of type NumberOfItems32 with the system

[Visual Basic] Overloads Public Shared Function Create(String, String, String, String, String) As PerformanceCounterCategory
[C#] public static PerformanceCounterCategory Create(String, String, String, String, String);
[C++] public: static PerformanceCounterCategory* Create(String*, String*, String*, String*, String*);
[JScript] public static function Create(String, String, String, String, String) : PerformanceCounterCategory;

Registers one extensible performance category of type NumberOfItems32 with the system

[Visual Basic] Overloads Public Shared Function Create(String, String, String, String) As PerformanceCounterCategory
[C#] public static PerformanceCounterCategory Create(String, String, String, String);
[C++] public: static PerformanceCounterCategory* Create(String*, String*, String*, String*);
[JScript] public static function Create(String, String, String, String) : PerformanceCounterCategory;

See Also

PerformanceCounterCategory Class | PerformanceCounterCategory Members | System.Diagnostics Namespace


PerformanceCounterCategory.Create (String, String, CounterCreationData[], String)

Registers the extensible performance category with the system

[Visual Basic]
Overloads Public Shared Function Create( _
   ByVal categoryName As String, _
   ByVal categoryHelp As String, _
   ByVal counterData() As CounterCreationData, _
   ByVal machineName As String _
) As PerformanceCounterCategory
[C#]
public static PerformanceCounterCategory Create(
   string categoryName,
   string categoryHelp,
   CounterCreationData[] counterData,
   string machineName
);
[C++]
public: static PerformanceCounterCategory* Create(
   String* categoryName,
   String* categoryHelp,
   CounterCreationData* counterData[],
   String* machineName
);
[JScript]
public static function Create(
   categoryName : String,
   categoryHelp : String,
   counterData : CounterCreationData[],
   machineName : String
) : PerformanceCounterCategory;

Parameters

categoryName
performance category name
categoryHelp
description message for the category
counterData
collection of CounterCreationData specifying the counters to be created
machineName
machine in which to register the counter.

See Also

PerformanceCounterCategory Class | PerformanceCounterCategory Members | System.Diagnostics Namespace | PerformanceCounterCategory.Create Overload List


PerformanceCounterCategory.Create (String, String, CounterCreationData[])

Registers the extensible performance category with the system on the local machine

[Visual Basic]
Overloads Public Shared Function Create( _
   ByVal categoryName As String, _
   ByVal categoryHelp As String, _
   ByVal counterData() As CounterCreationData _
) As PerformanceCounterCategory
[C#]
public static PerformanceCounterCategory Create(
   string categoryName,
   string categoryHelp,
   CounterCreationData[] counterData
);
[C++]
public: static PerformanceCounterCategory* Create(
   String* categoryName,
   String* categoryHelp,
   CounterCreationData* counterData[]
);
[JScript]
public static function Create(
   categoryName : String,
   categoryHelp : String,
   counterData : CounterCreationData[]
) : PerformanceCounterCategory;

Parameters

categoryName
performance category name
categoryHelp
description message for the category
counterData
collection of CounterCreationData specifying the counters to be created

See Also

PerformanceCounterCategory Class | PerformanceCounterCategory Members | System.Diagnostics Namespace | PerformanceCounterCategory.Create Overload List


PerformanceCounterCategory.Create (String, String, String, String, String)

Registers one extensible performance category of type NumberOfItems32 with the system

[Visual Basic]
Overloads Public Shared Function Create( _
   ByVal categoryName As String, _
   ByVal categoryHelp As String, _
   ByVal counterName As String, _
   ByVal counterHelp As String, _
   ByVal machineName As String _
) As PerformanceCounterCategory
[C#]
public static PerformanceCounterCategory Create(
   string categoryName,
   string categoryHelp,
   string counterName,
   string counterHelp,
   string machineName
);
[C++]
public: static PerformanceCounterCategory* Create(
   String* categoryName,
   String* categoryHelp,
   String* counterName,
   String* counterHelp,
   String* machineName
);
[JScript]
public static function Create(
   categoryName : String,
   categoryHelp : String,
   counterName : String,
   counterHelp : String,
   machineName : String
) : PerformanceCounterCategory;

Parameters

categoryName
performance category name
categoryHelp
description message for the category
counterName
name of the performance counter
counterHelp
description message for the counter
machineName
machine in which to register the counter.

See Also

PerformanceCounterCategory Class | PerformanceCounterCategory Members | System.Diagnostics Namespace | PerformanceCounterCategory.Create Overload List


PerformanceCounterCategory.Create (String, String, String, String)

Registers one extensible performance category of type NumberOfItems32 with the system

[Visual Basic]
Overloads Public Shared Function Create( _
   ByVal categoryName As String, _
   ByVal categoryHelp As String, _
   ByVal counterName As String, _
   ByVal counterHelp As String _
) As PerformanceCounterCategory
[C#]
public static PerformanceCounterCategory Create(
   string categoryName,
   string categoryHelp,
   string counterName,
   string counterHelp
);
[C++]
public: static PerformanceCounterCategory* Create(
   String* categoryName,
   String* categoryHelp,
   String* counterName,
   String* counterHelp
);
[JScript]
public static function Create(
   categoryName : String,
   categoryHelp : String,
   counterName : String,
   counterHelp : String
) : PerformanceCounterCategory;

Parameters

categoryName
performance category name
categoryHelp
description message for the category
counterName
name of the performance counter
counterHelp
description message for the counter

See Also

PerformanceCounterCategory Class | PerformanceCounterCategory Members | System.Diagnostics Namespace | PerformanceCounterCategory.Create Overload List


PerformanceCounterCategory.Delete

[To be supplied.]

Overload List

Removes the counter (category) from the system

[Visual Basic] Overloads Public Shared Sub Delete(String)
[C#] public static void Delete(String);
[C++] public: static void Delete(String*);
[JScript] public static function Delete(String);

Removes the counter (category) from the system

[Visual Basic] Overloads Public Shared Sub Delete(String, String)
[C#] public static void Delete(String, String);
[C++] public: static void Delete(String*, String*);
[JScript] public static function Delete(String, String);

See Also

PerformanceCounterCategory Class | PerformanceCounterCategory Members | System.Diagnostics Namespace


PerformanceCounterCategory.Delete (String)

Removes the counter (category) from the system

[Visual Basic]
Overloads Public Shared Sub Delete( _
   ByVal categoryName As String _
)
[C#]
public static void Delete(
   string categoryName
);
[C++]
public: static void Delete(
   String* categoryName
);
[JScript]
public static function Delete(
   categoryName : String
);

Parameters

categoryName
performance category from which to remove a counter

See Also

PerformanceCounterCategory Class | PerformanceCounterCategory Members | System.Diagnostics Namespace | PerformanceCounterCategory.Delete Overload List


PerformanceCounterCategory.Delete (String, String)

Removes the counter (category) from the system

[Visual Basic]
Overloads Public Shared Sub Delete( _
   ByVal categoryName As String, _
   ByVal machineName As String _
)
[C#]
public static void Delete(
   string categoryName,
   string machineName
);
[C++]
public: static void Delete(
   String* categoryName,
   String* machineName
);
[JScript]
public static function Delete(
   categoryName : String,
   machineName : String
);

Parameters

categoryName
performance category from which to remove a counter
machineName
machine in which to delete the counter.

See Also

PerformanceCounterCategory Class | PerformanceCounterCategory Members | System.Diagnostics Namespace | PerformanceCounterCategory.Delete Overload List


PerformanceCounterCategory.Exists

[To be supplied.]

Overload List

Returns true if the category is registered on the current machine.

[Visual Basic] Overloads Public Shared Function Exists(String) As Boolean
[C#] public static bool Exists(String);
[C++] public: static bool Exists(String*);
[JScript] public static function Exists(String) : Boolean;

Returns true if the category is registered in the machine.

[Visual Basic] Overloads Public Shared Function Exists(String, String) As Boolean
[C#] public static bool Exists(String, String);
[C++] public: static bool Exists(String*, String*);
[JScript] public static function Exists(String, String) : Boolean;

See Also

PerformanceCounterCategory Class | PerformanceCounterCategory Members | System.Diagnostics Namespace


PerformanceCounterCategory.Exists (String)

Returns true if the category is registered on the current machine.

[Visual Basic]
Overloads Public Shared Function Exists( _
   ByVal categoryName As String _
) As Boolean
[C#]
public static bool Exists(
   string categoryName
);
[C++]
public: static bool Exists(
   String* categoryName
);
[JScript]
public static function Exists(
   categoryName : String
) : Boolean;

Parameters

categoryName
performance category from which to remove a counter

Return Value

true if the category is registered, false otherwise

See Also

PerformanceCounterCategory Class | PerformanceCounterCategory Members | System.Diagnostics Namespace | PerformanceCounterCategory.Exists Overload List


PerformanceCounterCategory.Exists (String, String)

Returns true if the category is registered in the machine.

[Visual Basic]
Overloads Public Shared Function Exists( _
   ByVal categoryName As String, _
   ByVal machineName As String _
) As Boolean
[C#]
public static bool Exists(
   string categoryName,
   string machineName
);
[C++]
public: static bool Exists(
   String* categoryName,
   String* machineName
);
[JScript]
public static function Exists(
   categoryName : String,
   machineName : String
) : Boolean;

Parameters

categoryName
performance category to look for
machineName
the machine to look on

Return Value

true if the category is registered, false otherwise.

See Also

PerformanceCounterCategory Class | PerformanceCounterCategory Members | System.Diagnostics Namespace | PerformanceCounterCategory.Exists Overload List


PerformanceCounterCategory.GetCategories

[To be supplied.]

Overload List

Returns an array of performance counter categories for a particular machine.

[Visual Basic] Overloads Public Shared Function GetCategories(String) As PerformanceCounterCategory ()
[C#] public static PerformanceCounterCategory[] GetCategories(String);
[C++] public: static PerformanceCounterCategory* GetCategories(String*) [];
[JScript] public static function GetCategories(String) : PerformanceCounterCategory[];

Returns an array of performance counter categories for the current machine.

[Visual Basic] Overloads Public Shared Function GetCategories() As PerformanceCounterCategory ()
[C#] public static PerformanceCounterCategory[] GetCategories();
[C++] public: static PerformanceCounterCategory* GetCategories() [];
[JScript] public static function GetCategories() : PerformanceCounterCategory[];

See Also

PerformanceCounterCategory Class | PerformanceCounterCategory Members | System.Diagnostics Namespace


PerformanceCounterCategory.GetCategories (String)

Returns an array of performance counter categories for a particular machine.

[Visual Basic]
Overloads Public Shared Function GetCategories( _
   ByVal machineName As String _
) As PerformanceCounterCategory ()
[C#]
public static PerformanceCounterCategory[] GetCategories(
   string machineName
);
[C++]
public: static PerformanceCounterCategory* GetCategories(
   String* machineName
) [];
[JScript]
public static function GetCategories(
   machineName : String
) : PerformanceCounterCategory[];

Parameters

machineName
Machine to retrieve categories from.

Return Value

Returns an array of performance counter categories for a particular machine.

See Also

PerformanceCounterCategory Class | PerformanceCounterCategory Members | System.Diagnostics Namespace | PerformanceCounterCategory.GetCategories Overload List


PerformanceCounterCategory.GetCategories ()

Returns an array of performance counter categories for the current machine.

[Visual Basic]
Overloads Public Shared Function GetCategories() As PerformanceCounterCategory _
   ()
[C#]
public static PerformanceCounterCategory[] GetCategories();
[C++]
public: static PerformanceCounterCategory* GetCategories() [];
[JScript]
public static function GetCategories() :
   PerformanceCounterCategory
   ;

Return Value

Returns an array of performance counter categories for the current machine.

See Also

PerformanceCounterCategory Class | PerformanceCounterCategory Members | System.Diagnostics Namespace | PerformanceCounterCategory.GetCategories Overload List


PerformanceCounterCategory.GetCounters

Returns an array of counters in this category

[Visual Basic]
Public Function GetCounters() As PerformanceCounter ()
[C#]
public PerformanceCounter[] GetCounters();
[C++]
public: PerformanceCounter* GetCounters() [];
[JScript]
public function GetCounters() : PerformanceCounter[];

Return Value

Returns an array of counters in this category

See Also

PerformanceCounterCategory Class | PerformanceCounterCategory Members | System.Diagnostics Namespace


PerformanceCounterCategory.GetInstanceNames

Returns an array of instances for this category

[Visual Basic]
Public Function GetInstanceNames() As String ()
[C#]
public string[] GetInstanceNames();
[C++]
public: String* GetInstanceNames() [];
[JScript]
public function GetInstanceNames() : String[];

Return Value

String array containing the instance names for this category

See Also

PerformanceCounterCategory Class | PerformanceCounterCategory Members | System.Diagnostics Namespace


PerformanceCounterInstaller Class

[To be supplied.]

Object
Component
Installer
ComponentInstaller
PerformanceCounterInstaller

[Visual Basic]
Public Class PerformanceCounterInstaller
   Inherits ComponentInstaller
[C#]
public class PerformanceCounterInstaller : ComponentInstaller
[C++]
public __gc class PerformanceCounterInstaller : public
   ComponentInstaller
[JScript]
public class PerformanceCounterInstaller extends ComponentInstaller

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

PerformanceCounterInstaller Members | System.Diagnostics Namespace


PerformanceCounterInstaller Members

Public:

Constructor

PerformanceCounterInstaller Constructor [To be supplied.]

Properties

CategoryHelp | [To be supplied.]
CategoryName | [To be supplied.]
Context (inherited from Installer) | Gets or sets information about the current installation.
Counters | [To be supplied.]
HelpText (inherited from Installer) | Gets the help text for all of the Installer objects contained in the Installers collection of this installer instance.
Installers (inherited from Installer) | Gets the collection of Installer objects contained in this Installer instance.
MachineName | [To be supplied.]
Parent (inherited from Installer) | Gets or sets the Installer whose InstallerCollection contains this Installer instance.
Site (inherited from Component) | Gets or sets the site of the Component.
UninstallAction | [To be supplied.]

Methods

Commit (inherited from Installer) | Completes the install transaction.
CopyFromComponent | [To be supplied.]
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Install | [To be supplied.]
Rollback | [To be supplied.]
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
Uninstall | [To be supplied.]

Events

AfterCommit (inherited from Installer) | Occurs after the installations handled by the installers in the InstallerCollection of this instance are committed.
AfterInstall (inherited from Installer) | Occurs after the Install methods of all the installers in the InstallerCollection of this instance have run.
AfterRollback (inherited from Installer) | Occurs after the installations handled by the installers in the InstallerCollection of this instance are rolled back.
AfterUninstall (inherited from Installer) | Occurs after the installations handled by the installers in the InstallerCollection of this instance are uninstalled.
BeforeCommit (inherited from Installer) | Occurs before the installations handled by the installers in the InstallerCollection of this instance are committed.
BeforeInstall (inherited from Installer) | Occurs before the installers in the InstallerCollection of this instance are run.
BeforeRollback (inherited from Installer) | Occurs before the installations handled by the installers in the InstallerCollection of this instance are rolled back.
BeforeUninstall (inherited from Installer) | Occurs before the installations handled by the installers in the InstallerCollection of this instance are uninstalled.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCommit (inherited from Installer) | Raises the OnAfterCommit event.
OnAfterInstall (inherited from Installer) | Raises the OnAfterInstall event.
OnAfterRollback (inherited from Installer) | Raises the OnAfterRollback event.
OnAfterUninstall (inherited from Installer) | Raises the OnAfterUninstall event.
OnBeforeCommit (inherited from Installer) | Raises the OnBeforeCommit event.
OnBeforeInstall (inherited from Installer) | Raises the OnBeforeInstall event.
OnBeforeRollback (inherited from Installer) | Raises the OnBeforeRollback event.
OnBeforeUninstall (inherited from Installer) | Raises the OnBeforeUninstall event.

Event Hookup:

Methods

AddOnAfterCommit (inherited from Installer) | [To be supplied.]
AddOnAfterInstall (inherited from Installer) | [To be supplied.]
AddOnAfterRollback (inherited from Installer) | [To be supplied.]
AddOnAfterUninstall (inherited from Installer) | [To be supplied.]
AddOnBeforeCommit (inherited from Installer) | [To be supplied.]
AddOnBeforeInstall (inherited from Installer) | [To be supplied.]
AddOnBeforeRollback (inherited from Installer) | [To be supplied.]
AddOnBeforeUninstall (inherited from Installer) | [To be supplied.]
RemoveOnAfterCommit (inherited from Installer) | [To be supplied.]
RemoveOnAfterInstall (inherited from Installer) | [To be supplied.]
RemoveOnAfterRollback (inherited from Installer) | [To be supplied.]
RemoveOnAfterUninstall (inherited from Installer) | [To be supplied.]
RemoveOnBeforeCommit (inherited from Installer) | [To be supplied.]
RemoveOnBeforeInstall (inherited from Installer) | [To be supplied.]
RemoveOnBeforeRollback (inherited from Installer) | [To be supplied.]
RemoveOnBeforeUninstall (inherited from Installer) | [To be supplied.]

See Also

PerformanceCounterInstaller Class | System.Diagnostics Namespace


PerformanceCounterInstaller Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public PerformanceCounterInstaller();
[C++]
public: PerformanceCounterInstaller();
[JScript]
public function PerformanceCounterInstaller();

See Also

PerformanceCounterInstaller Class | PerformanceCounterInstaller Members | System.Diagnostics Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PerformanceCounterInstaller Properties

The properties of the PerformanceCounterInstaller class are listed below. For a complete list of PerformanceCounterInstaller class members, see the PerformanceCounterInstaller Members topic.

Public:

CategoryHelp | [To be supplied.]
CategoryName | [To be supplied.]
Context (inherited from Installer) | Gets or sets information about the current installation.
Counters | [To be supplied.]
HelpText (inherited from Installer) | Gets the help text for all of the Installer objects contained in the Installers collection of this installer instance.
Installers (inherited from Installer) | Gets the collection of Installer objects contained in this Installer instance.
MachineName | [To be supplied.]
Parent (inherited from Installer) | Gets or sets the Installer whose InstallerCollection contains this Installer instance.
Site (inherited from Component) | Gets or sets the site of the Component.
UninstallAction | [To be supplied.]

See Also

PerformanceCounterInstaller Class | System.Diagnostics Namespace


PerformanceCounterInstaller.CategoryHelp

[To be supplied.]

[Visual Basic]
Public Property CategoryHelp As String
[C#]
public string CategoryHelp {get; set;}
[C++]
public: __property String* get_CategoryHelp();
public: __property void set_CategoryHelp(String*);
[JScript]
public function get CategoryHelp() : String;
public function set CategoryHelp(String);

See Also

PerformanceCounterInstaller Class | PerformanceCounterInstaller Members | System.Diagnostics Namespace


PerformanceCounterInstaller.CategoryName

[To be supplied.]

[Visual Basic]
Public Property CategoryName As String
[C#]
public string CategoryName {get; set;}
[C++]
public: __property String* get_CategoryName();
public: __property void set_CategoryName(String*);
[JScript]
public function get CategoryName() : String;
public function set CategoryName(String);

See Also

PerformanceCounterInstaller Class | PerformanceCounterInstaller Members | System.Diagnostics Namespace


PerformanceCounterInstaller.Counters

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Counters As CounterCreationDataCollection
[C#]
public CounterCreationDataCollection Counters {get;}
[C++]
public: __property CounterCreationDataCollection* get_Counters();
[JScript]
public function get Counters() : CounterCreationDataCollection;

See Also

PerformanceCounterInstaller Class | PerformanceCounterInstaller Members | System.Diagnostics Namespace


PerformanceCounterInstaller.MachineName

[To be supplied.]

[Visual Basic]
Public Property MachineName As String
[C#]
public string MachineName {get; set;}
[C++]
public: __property String* get_MachineName();
public: __property void set_MachineName(String*);
[JScript]
public function get MachineName() : String;
public function set MachineName(String);

See Also

PerformanceCounterInstaller Class | PerformanceCounterInstaller Members | System.Diagnostics Namespace


PerformanceCounterInstaller.UninstallAction

[To be supplied.]

[Visual Basic]
Public Property UninstallAction As UninstallAction
[C#]
public UninstallAction UninstallAction {get; set;}
[C++]
public: __property UninstallAction get_UninstallAction();
public: __property void set_UninstallAction(UninstallAction);
[JScript]
public function get UninstallAction() : UninstallAction;
public function set UninstallAction(UninstallAction);

See Also

PerformanceCounterInstaller Class | PerformanceCounterInstaller Members | System.Diagnostics Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PerformanceCounterInstaller Methods

The methods of the PerformanceCounterInstaller class are listed below. For a complete list of PerformanceCounterInstaller class members, see the PerformanceCounterInstaller Members topic.

Public:

Commit (inherited from Installer) | Completes the install transaction.
CopyFromComponent | [To be supplied.]
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Install | [To be supplied.]
Rollback | [To be supplied.]
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
Uninstall | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCommit (inherited from Installer) | Raises the OnAfterCommit event.
OnAfterInstall (inherited from Installer) | Raises the OnAfterInstall event.
OnAfterRollback (inherited from Installer) | Raises the OnAfterRollback event.
OnAfterUninstall (inherited from Installer) | Raises the OnAfterUninstall event.
OnBeforeCommit (inherited from Installer) | Raises the OnBeforeCommit event.
OnBeforeInstall (inherited from Installer) | Raises the OnBeforeInstall event.
OnBeforeRollback (inherited from Installer) | Raises the OnBeforeRollback event.
OnBeforeUninstall (inherited from Installer) | Raises the OnBeforeUninstall event.

Event Hookup:

AddOnAfterCommit (inherited from Installer) | [To be supplied.]
AddOnAfterInstall (inherited from Installer) | [To be supplied.]
AddOnAfterRollback (inherited from Installer) | [To be supplied.]
AddOnAfterUninstall (inherited from Installer) | [To be supplied.]
AddOnBeforeCommit (inherited from Installer) | [To be supplied.]
AddOnBeforeInstall (inherited from Installer) | [To be supplied.]
AddOnBeforeRollback (inherited from Installer) | [To be supplied.]
AddOnBeforeUninstall (inherited from Installer) | [To be supplied.]
RemoveOnAfterCommit (inherited from Installer) | [To be supplied.]
RemoveOnAfterInstall (inherited from Installer) | [To be supplied.]
RemoveOnAfterRollback (inherited from Installer) | [To be supplied.]
RemoveOnAfterUninstall (inherited from Installer) | [To be supplied.]
RemoveOnBeforeCommit (inherited from Installer) | [To be supplied.]
RemoveOnBeforeInstall (inherited from Installer) | [To be supplied.]
RemoveOnBeforeRollback (inherited from Installer) | [To be supplied.]
RemoveOnBeforeUninstall (inherited from Installer) | [To be supplied.]

See Also

PerformanceCounterInstaller Class | System.Diagnostics Namespace


PerformanceCounterInstaller.CopyFromComponent

[To be supplied.]

[Visual Basic]
Overrides Public Sub CopyFromComponent( _
   ByVal component As IComponent _
)
[C#]
public override void CopyFromComponent(
   IComponent component
);
[C++]
public: override void CopyFromComponent(
   IComponent* component
);
[JScript]
public override function CopyFromComponent(
   component : IComponent
);

Parameters

component
[To be supplied.]

See Also

PerformanceCounterInstaller Class | PerformanceCounterInstaller Members | System.Diagnostics Namespace


PerformanceCounterInstaller.Install

[To be supplied.]

[Visual Basic]
Overrides Public Sub Install( _
   ByVal state As IDictionary _
)
[C#]
public override void Install(
   IDictionary state
);
[C++]
public: override void Install(
   IDictionary* state
);
[JScript]
public override function Install(
   state : IDictionary
);

Parameters

state
[To be supplied.]

See Also

PerformanceCounterInstaller Class | PerformanceCounterInstaller Members | System.Diagnostics Namespace


PerformanceCounterInstaller.Rollback

[To be supplied.]

[Visual Basic]
Overrides Public Sub Rollback( _
   ByVal state As IDictionary _
)
[C#]
public override void Rollback(
   IDictionary state
);
[C++]
public: override void Rollback(
   IDictionary* state
);
[JScript]
public override function Rollback(
   state : IDictionary
);

Parameters

state
[To be supplied.]

See Also

PerformanceCounterInstaller Class | PerformanceCounterInstaller Members | System.Diagnostics Namespace


PerformanceCounterInstaller.Uninstall

[To be supplied.]

[Visual Basic]
Overrides Public Sub Uninstall( _
   ByVal state As IDictionary _
)
[C#]
public override void Uninstall(
   IDictionary state
);
[C++]
public: override void Uninstall(
   IDictionary* state
);
[JScript]
public override function Uninstall(
   state : IDictionary
);

Parameters

state
[To be supplied.]

See Also

PerformanceCounterInstaller Class | PerformanceCounterInstaller Members | System.Diagnostics Namespace


PerformanceCounterManager Class

[To be supplied.]

Object
PerformanceCounterManager

[Visual Basic]
Public Class PerformanceCounterManager
   Implements ICollectData
[C#]
public class PerformanceCounterManager : ICollectData
[C++]
public __gc class PerformanceCounterManager : public ICollectData
[JScript]
public class PerformanceCounterManager implements ICollectData

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

PerformanceCounterManager Members | System.Diagnostics Namespace


PerformanceCounterManager Members

Public:

Constructor

PerformanceCounterManager Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
OutputDebugString | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

guid [To be supplied.]

Protected:

Methods

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PerformanceCounterManager Class | System.Diagnostics Namespace


PerformanceCounterManager Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public PerformanceCounterManager();
[C++]
public: PerformanceCounterManager();
[JScript]
public function PerformanceCounterManager();

See Also

PerformanceCounterManager Class | PerformanceCounterManager Members | System.Diagnostics Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PerformanceCounterManager Methods

The methods of the PerformanceCounterManager class are listed below. For a complete list of PerformanceCounterManager class members, see the PerformanceCounterManager Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
OutputDebugString | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PerformanceCounterManager Class | System.Diagnostics Namespace


PerformanceCounterManager.Finalize

[To be supplied.]

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

PerformanceCounterManager Class | PerformanceCounterManager Members | System.Diagnostics Namespace


PerformanceCounterManager.OutputDebugString

[To be supplied.]

[Visual Basic]
extern Public Shared Sub OutputDebugString( _
   ByVal message As String _
)
[C#]
public static extern void OutputDebugString(
   string message
);
[C++]
public: static extern void OutputDebugString(
   String* message
);
[JScript]
public static extern function OutputDebugString(
   message : String
);

Parameters

message
[To be supplied.]

See Also

PerformanceCounterManager Class | PerformanceCounterManager Members | System.Diagnostics Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PerformanceCounterManager Fields

The fields of the PerformanceCounterManager class are listed below. For a complete list of PerformanceCounterManager class members, see the PerformanceCounterManager Members topic.

Public:

guid [To be supplied.]

See Also

PerformanceCounterManager Class | System.Diagnostics Namespace


PerformanceCounterManager.guid

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly guid As Guid
[C#]
public static readonly Guid guid;
[C++]
public: static readonly Guid guid;
[JScript]
public static var guid : Guid;

See Also

PerformanceCounterManager Class | PerformanceCounterManager Members | System.Diagnostics Namespace


PerformanceCounterType Enumeration

Enum of friendly names to counter types (maps directory to the native types)

[Visual Basic]
Public Enum PerformanceCounterType
[C#]
public enum PerformanceCounterType
[C++]
public enum PerformanceCounterType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
AverageTimePerSecond32 | [To be supplied.]
AverageTimePerSecond64 | [To be supplied.]
CountPerTimeInterval32 | [To be supplied.]
CountPerTimeInterval64 | [To be supplied.]
DifferenceBetweenValues32 | [To be supplied.]
DifferenceBetweenValues64 | [To be supplied.]
ElapsedTime | [To be supplied.]
MultipleUseNumberOfItems | [To be supplied.]
MultipleUsePercentage | [To be supplied.]
MultipleUsePercentage100NS | [To be supplied.]
MultipleUsePercentageInverse | [To be supplied.]
MultipleUsePercentageInverse100NS | [To be supplied.]
NumberOfItems32 | [To be supplied.]
NumberOfItems64 | [To be supplied.]
NumberOfItemsHEX32 | [To be supplied.]
NumberOfItemsHEX64 | [To be supplied.]
NumberOfOperations | [To be supplied.]
NumberOfSamplesTaken | [To be supplied.]
RateOfChangePerSecond32 | [To be supplied.]
RateOfChangePerSecond64 | [To be supplied.]
RawBase | [To be supplied.]
RawFraction | [To be supplied.]
Sampling | [To be supplied.]
SamplingPercentage | [To be supplied.]
UsePercentage | [To be supplied.]
UsePercentage100NS | [To be supplied.]
UsePercentageInverse | [To be supplied.]
UsePercentageInverse100NS | [To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

System.Diagnostics Namespace


Process Class

Provides access to local and remote processes. Enables you to start and stop system processes.

Object
Component
Process

[Visual Basic]
Public Class Process
   Inherits Component
[C#]
public class Process : Component
[C++]
public __gc class Process : public Component
[JScript]
public class Process extends Component

Remarks

A Process component provides access to an executable running on a computer. A process, in the simplest terms, is a running application. A thread is the basic unit to which the operating system allocates processor time. A thread can execute any part of the process code, including parts currently being executed by another thread.

The Process component is a useful tool to monitor applications. Using the Process component, you can obtain a list of processes that are running, or start a new process. A Process component is used to access system processes. Once a Process component has been initialized, it can then be used to obtain information about the running process, such as the set of threads, loaded modules (.dll or .exe's), or performance information such as the amount of memory the process is using. Once the Process component has obtained information about the associated process, it will not try to obtain it again until you call the Refresh method.

A system process is identified uniquely on the system by its process ID In addition, a process, like many Windows resources, has a handle by which it identifies itself, but which may not be unique on the computer. A handle is the generic term for an identifier to a resource. The process handle, accessed through the Handle property on the Process component, is persisted by the operating system even when the process has exited so that you can get administrative information about the process, like the ExitCode (usually, 0 for success or a non-zero error code) and the ExitTime. Handles are an extremely precious resource, so leaking handles is more virulent than leaking memory. The operating system will only release the handle and associated data when there are no longer any handles to the process on the system, when the HandleCount is 0.

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

Process Members | System.Diagnostics Namespace | Start | ProcessStartInfo | CloseMainWindow | Kill | ProcessThread


Process Members

Public:

Constructor

Process Constructor Initializes a new instance of the System.Diagnostics.Process.Process class.

Properties

BasePriority | Gets the base priority of the associated process.
ExitCode | Gets the value that was specified by the associated process when it was terminated.
ExitTime | Gets the time that the associated process exited.
Handle | Returns the native handle for the associated process. The handle is only available if this component started the process.
HandleCount | Gets the number of handles that are associated with the process.
HasExited | Gets a value indicating whether the associated process has been terminated.
Id | Gets the unique identifier for the associated process.
MachineName | Gets the name of the computer on which the associated process is running.
MainModule | Gets the main module for the associated process.
MainWindowHandle | Returns the window handle of the main window of the associated process.
MainWindowTitle | Returns the caption of the MainWindowHandle of the process. If the handle is zero (0), then an empty string is returned.
MaxWorkingSet | Gets or sets the maximum allowable working set for the associated process.
MinWorkingSet | Gets or sets the minimum allowable working set for the associated process.
Modules | Gets the modules that have been loaded by the associated process.
NonpagedSystemMemorySize | Returns the amount of memory that the system has allocated on behalf of the associated process that can not be written to the virtual memory paging file.
PagedMemorySize | Returns the amount of memory that the associated process has allocated that can be written to the virtual memory paging file.
PagedSystemMemorySize | Returns the amount of memory that the system has allocated on behalf of the associated process that can be written to the virtual memory paging file.
PeakPagedMemorySize | Returns the maximum amount of memory that the associated process has allocated that can be written to the virtual memory paging file.
PeakVirtualMemorySize | Returns the maximum amount of virtual memory that the associated process has requested.
PeakWorkingSet | Returns the maximum amount of physical memory that the associated process required at once.
PriorityBoostEnabled | Gets or sets a value indicating whether the associated process priority should be temporarily boosted by the operating system when the main window has focus.
PriorityClass | Gets or sets the overall priority category for the associated process.
PrivateMemorySize | Returns the number of bytes that the associated process has allocated that cannot be shared with other processes.
PrivilegedProcessorTime | Returns the amount of time the process has spent running code inside the operating system core.
ProcessName | Gets the friendly name of the process.
ProcessorAffinity | Gets or sets which processors the threads in this process can be scheduled to run on.
Responding | Gets a value indicating whether or not the user interface of the process is responding.
Site (inherited from Component) | Gets or sets the site of the Component.
StartInfo | Gets or sets the parameters to pass into the Start method for the Process.
StartTime | Returns the time the associated process was started.
SynchronizingObject | Represents the object used to marshal the event handler calls issued as a result of a Process exit. Normally this property will be set when the component is placed inside a control or a from, since those components are bound to a specific thread.
Threads | Gets the set of threads that are running in the associated process.
TotalProcessorTime | Returns the amount of time the associated process has spent utilizing the CPU. It is the sum of the UserProcessorTime and PrivilegedProcessorTime.
UserProcessorTime | Returns the amount of time the associated process has spent running code inside the application portion of the process (not the operating system core).
VirtualMemorySize | Returns the amount of virtual memory that the associated process has requested.
WatchForExit | Gets or sets whether the System.Diagnostics.Process.Exited event is fired when the process terminates.
WorkingSet | Returns the total amount of physical memory the associated process.

Methods

Close | Frees any resources associated with this component.
CloseMainWindow | Closes a process that has a user interface by sending a close message to its main window.
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetCurrentProcess | Returns a new Process component and associates it with the current active process.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProcessById | Overloaded. Creates a new Process component, associating it with the existing process resource specified by the processId parameter.
GetProcesses | Overloaded. Creates an array of new Process components, associating them with existing process resources on the specified computer.
GetProcessesByName | Overloaded. Creates an array of new Process components, associating them with the existing process resources specified by the processName parameter.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Kill | Stops the associated process immediately.
Refresh | Discards any information about the associated process that has been cached inside the process component. After Refresh is called, the first request for information for each property causes the process component to obtain a new value from the associated process.
Start | Overloaded. Starts a process resource and associates it with a Process component.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
WaitForExit | Overloaded. Sets a period to wait for the associated process to exit.
WaitForInputIdle | Overloaded. Instructs the Process component to wait for the associated process to enter an idle state.

Events

Exited [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnExited | Raises the System.Diagnostics.Process.Exited event.

Event Hookup:

Methods

AddOnExited | Adds the Exited event handler.
RemoveOnExited | Remove the Exited event handler.

See Also

Process Class | System.Diagnostics Namespace


Process Constructor

Initializes a new instance of the System.Diagnostics.Process.Process class.

[Visual Basic]
Public Sub New()
[C#]
public Process();
[C++]
public: Process();
[JScript]
public function Process();

Remarks

You have two options when associating a new Process component with a process resource. You can use the constructor to explicitly create the Process component yourself, set the appropriate members of the StartInfo property and then call Start to associate the Process with a new system process, or you can associate the Process with a running system process using GetProcessById or one of the GetProcesses return values.

If you use a static (in Visual Basic Shared) overload of the Start method to start a new system process, a new Process component is created for you and automatically associated with the process.

Both options provide similar functionality to the Run dialog box of the Windows Start menu. Anything that can be typed into a command line can be launched by setting appropriate values for the StartInfo and calling the parameterless Start method, or passing the appropriate parameter into the static (Shared) Start member.

Once you have created a Process component, either through the constructor or through one of the static Start overloads, you have a view into the associated process. This is not a dynamic view that updates itself automatically when the process properties have changed in memory. Instead, you must call Refresh on the component to update Process property information in your application.

See Also

Process Class | Process Members | System.Diagnostics Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Process Properties

The properties of the Process class are listed below. For a complete list of Process class members, see the Process Members topic.

Public:

BasePriority | Gets the base priority of the associated process.
ExitCode | Gets the value that was specified by the associated process when it was terminated.
ExitTime | Gets the time that the associated process exited.
Handle | Returns the native handle for the associated process. The handle is only available if this component started the process.
HandleCount | Gets the number of handles that are associated with the process.
HasExited | Gets a value indicating whether the associated process has been terminated.
Id | Gets the unique identifier for the associated process.
MachineName | Gets the name of the computer on which the associated process is running.
MainModule | Gets the main module for the associated process.
MainWindowHandle | Returns the window handle of the main window of the associated process.
MainWindowTitle | Returns the caption of the MainWindowHandle of the process. If the handle is zero (0), then an empty string is returned.
MaxWorkingSet | Gets or sets the maximum allowable working set for the associated process.
MinWorkingSet | Gets or sets the minimum allowable working set for the associated process.
Modules | Gets the modules that have been loaded by the associated process.
NonpagedSystemMemorySize | Returns the amount of memory that the system has allocated on behalf of the associated process that can not be written to the virtual memory paging file.
PagedMemorySize | Returns the amount of memory that the associated process has allocated that can be written to the virtual memory paging file.
PagedSystemMemorySize | Returns the amount of memory that the system has allocated on behalf of the associated process that can be written to the virtual memory paging file.
PeakPagedMemorySize | Returns the maximum amount of memory that the associated process has allocated that can be written to the virtual memory paging file.
PeakVirtualMemorySize | Returns the maximum amount of virtual memory that the associated process has requested.
PeakWorkingSet | Returns the maximum amount of physical memory that the associated process required at once.
PriorityBoostEnabled | Gets or sets a value indicating whether the associated process priority should be temporarily boosted by the operating system when the main window has focus.
PriorityClass | Gets or sets the overall priority category for the associated process.
PrivateMemorySize | Returns the number of bytes that the associated process has allocated that cannot be shared with other processes.
PrivilegedProcessorTime | Returns the amount of time the process has spent running code inside the operating system core.
ProcessName | Gets the friendly name of the process.
ProcessorAffinity | Gets or sets which processors the threads in this process can be scheduled to run on.
Responding | Gets a value indicating whether or not the user interface of the process is responding.
Site (inherited from Component) | Gets or sets the site of the Component.
StartInfo | Gets or sets the parameters to pass into the Start method for the Process.
StartTime | Returns the time the associated process was started.
SynchronizingObject | Represents the object used to marshal the event handler calls issued as a result of a Process exit. Normally this property will be set when the component is placed inside a control or a from, since those components are bound to a specific thread.
Threads | Gets the set of threads that are running in the associated process.
TotalProcessorTime | Returns the amount of time the associated process has spent utilizing the CPU. It is the sum of the UserProcessorTime and PrivilegedProcessorTime.
UserProcessorTime | Returns the amount of time the associated process has spent running code inside the application portion of the process (not the operating system core).
VirtualMemorySize | Returns the amount of virtual memory that the associated process has requested.
WatchForExit | Gets or sets whether the System.Diagnostics.Process.Exited event is fired when the process terminates.
WorkingSet | Returns the total amount of physical memory the associated process.

See Also

Process Class | System.Diagnostics Namespace


Process.BasePriority

Gets the base priority of the associated process.

[Visual Basic]
Public ReadOnly Property BasePriority As Integer
[C#]
public int BasePriority {get;}
[C++]
public: __property int get_BasePriority();
[JScript]
public function get BasePriority() : int;

Property Value

The base priority, computed from the PriorityClass of the associated process.

Exceptions

Exception Type | Condition
SystemException | The process has exited. -or- The process has not started, so there is no process ID.

Remarks

The process's BasePriority is the starting priority for threads created within the associated process. You can view information about the base priority through the Performance Monitor's "Priority Base" counter.

Based on time elapsed or other boosts, the base priority level can be changed by the operating system when a process should be placed ahead of others.

The BasePriority property lets you view the starting priority assigned to a process. However, because it is read-only, you cannot use BasePriority to set a process's priority. To change the priority, use PriorityClass. BasePriority is viewable using the system's Performance Monitor. The counter can also be viewed programmatically. PriorityClass cannot be viewed using the Performance Monitor. The following tabel shows the relationship between BasePriority values and PriorityClass values.

BasePriority | PriorityClass
4 | Idle
8 | Normal
13 | High
24 | RealTime

See Also

Process Class | Process Members | System.Diagnostics Namespace | PriorityClass | ProcessPriorityClass | ThreadPriorityLevel


Process.ExitCode

Gets the value that was specified by the associated process when it was terminated.

[Visual Basic]
Public ReadOnly Property ExitCode As Integer
[C#]
public int ExitCode {get;}
[C++]
public: __property int get_ExitCode();
[JScript]
public function get ExitCode() : int;

Property Value

The code specified by the associated process when the process was terminated. A successful exit returns zero (0).

Exceptions

Exception Type | Condition
InvalidOperationException | The process has not been exited. -or- The process Handle is not valid.

Remarks

Use ExitCode to get the status returned when the system process exited. You can write your code to return any value to the calling method, and handle value in your code, much like an integer return value for a Main procedure. Indicate a successful exit by an ExitCode value of zero, and errors by non-zero values which your calling method can use to identify the cause of an abnormal process termination. It is not necessary to follow these guidelines, but usually developers follow the convention.

See TBD in the Platform SDK for a list of common HRESULT values and the associated error conditions.

If you try to get the ExitCode before System.Diagnostics.Process.Exited is true, an exception will be thrown. Examine the System.Diagnostics.Process.Exited property first to verify whether the process for which you are retrieving the exit code has been terminated.

You can use the CloseMainWindow or Kill methods to cause an associated process to exit. If the process is running asynchronously, WatchForExit must be set to true for the Process component to receive notification that the process has exited. If the process is running synchronously with your application, WaitForExit pauses processing until the associated component exits.

See Also

Process Class | Process Members | System.Diagnostics Namespace | HasExited | CloseMainWindow | Kill | WaitForExit | WatchForExit


Process.ExitTime

Gets the time that the associated process exited.

[Visual Basic]
Public ReadOnly Property ExitTime As DateTime
[C#]
public DateTime ExitTime {get;}
[C++]
public: __property DateTime get_ExitTime();
[JScript]
public function get ExitTime() : DateTime;

Property Value

A DateTime that indicates when the associated process was terminated.

Remarks

If the process has not terminated, attempting to retrieve the ExitTime causes an exception. Use HasExited before getting the ExitTime to determine if the associated process has terminated.

See Also

Process Class | Process Members | System.Diagnostics Namespace | Handle | ExitCode


Process.Handle

Returns the native handle for the associated process. The handle is only available if this component started the process.

[Visual Basic]
Public ReadOnly Property Handle As Integer
[C#]
public int Handle {get;}
[C++]
public: __property int get_Handle();
[JScript]
public function get Handle() : int;

Property Value

The handle assigned to the associated process when it was started, used by the operating system to keep track of process attributes.

Remarks

Handle is a way to refer to a process from within an application. The instance handle is the base address at which the application loaded. In Win32, each application has its own address space, so instance handles of different process can be identical. Therefore, unlike the case under Win16, under Win32, you cannot identify a process by its instance handle because it is not guaranteed to be unique.

A unique application can obtain a handle to a process which can be used as a parameter to many process-information and control functions. This handle is private to an application--process handles cannot be shared. In addition to the handle, a process has a process Id which, unlike the Handle, is valid throughout the system.

Handle has the value zero (0) if it has not been set. This usually implies that the process has not been started, because starting a process causes the operating system to assign it a process handle. Only processes started through a call to Start cause the Handle property to be populated.

When you start a Process within a calling application, the HandleCount increments to reflect the active process. You associate additional Win32 handles to the process by calling the process additional times in your code. When a process is terminated, the HandleCount is decreased.

See Also

Process Class | Process Members | System.Diagnostics Namespace | Id | ExitCode | ExitTime | HandleCount | Start | Refresh


Process.HandleCount

Gets the number of handles that are associated with the process.

[Visual Basic]
Public ReadOnly Property HandleCount As Integer
[C#]
public int HandleCount {get;}
[C++]
public: __property int get_HandleCount();
[JScript]
public function get HandleCount() : int;

Property Value

The number of operating system handles currently associated with the process.

Remarks

Handle is a way to refer to a process object from within an application. An application can obtain a handle to a process which can be used as a parameter to many process-information and control functions. This handle is private to an application--process handles cannot be shared (is this the same type of handle?). In addition to the handle, a process has a process Id which, unlike the Handle, is valid throughout the system.

When you start a Process within a calling application, the HandleCount increments to reflect the active process. You associate additional Win32 handles to the process by calling the process additional times in your code. When a process is terminated, the HandleCount is decreased.

See Also

Process Class | Process Members | System.Diagnostics Namespace | Handle | Start | CloseMainWindow | Kill


Process.HasExited

Gets a value indicating whether the associated process has been terminated.

[Visual Basic]
Public ReadOnly Property HasExited As Boolean
[C#]
public bool HasExited {get;}
[C++]
public: __property bool get_HasExited();
[JScript]
public function get HasExited() : Boolean;

Property Value

true if the operating system process referenced by the Process component has terminated; otherwise, false.

Exceptions

Exception Type | Condition
SystemException | There is no process associated with the object.
Win32Exception | The exit code for the process could not be retrieved.

Remarks

A value of true for HasExited indicates that the associated process has terminated, either normally or abnormally. You can request or force the associated process to exit by calling CloseMainWindow or Kill. When the process has exited, the operating system releases process memory, but retains administrative information about the process like the handle, exit code and exit time. You can use the ExitCode and ExitTime to view this information. This information is released when all Process components associated with the system process are destroyed and hold no more handles to the exited process.

A process can terminate independently of the code being processed. The value of System.Diagnostics.Process.Exited is updated automatically, even if the associated process exits independently.

See Also

Process Class | Process Members | System.Diagnostics Namespace | ExitCode | ExitTime | WaitForExit | WatchForExit | OnExited


Process.Id

Gets the unique identifier for the associated process.

[Visual Basic]
Public ReadOnly Property Id As Integer
[C#]
public int Id {get;}
[C++]
public: __property int get_Id();
[JScript]
public function get Id() : int;

Property Value

The system-generated unique identifier of the associated process referenced by the Process instance.

Exceptions

Exception Type | Condition
SystemException | No process Id has been set. -or- There is no process associated with this Process object.

Remarks

The process Id does not exist if the associated process is not running. Therefore, you should either ensure that the process is running before attempting to retrieve its Id, or handle the exception that would be thrown if the process has not been started. Until the process terminates, the process identifier uniquely identifies the process throughout the system.

You can use the ID of an associated process on a local or remote computer to connect a running process to a new Process component by using the GetProcessById method. GetProcessById is a static (in Visual Basic Shared) method that creates a new component and sets the Id property for the new Process automatically.

Process identifiers can be reused by the system. The Id is only unique while the associated process is running. Once the process has terminated, the Id can be reused for an unrelated process.

Because the Id is unique on the system, it can be passed to other threads, as an alternative to passing a Process component. This can save system resources yet guarantees that the process is being correctly identified.

See Also

Process Class | Process Members | System.Diagnostics Namespace | Handle | GetProcessById


Process.MachineName

Gets the name of the computer on which the associated process is running.

[Visual Basic]
Public ReadOnly Property MachineName As String
[C#]
public string MachineName {get;}
[C++]
public: __property String* get_MachineName();
[JScript]
public function get MachineName() : String;

Property Value

The name of the computer on which the associated process is running.

Exceptions

Exception Type | Condition
SystemException | There is no process associated with this Process object.

Remarks

Set MachineName to view the processes running on another computer on the network. For security reasons, you cannot call Start, CloseMainWindow, or Kill on remote computers. You can view statistical data and process information for processes running on remote computers, but you cannot start or stop them. Several Process component members throw exceptions if you attempt to get, set, or implement them on remote computers.

The MachineName can be an empty string (""). Unlike other services like Message Queuing, the local computer (".") is not assumed.

See Also

Process Class | Process Members | System.Diagnostics Namespace | GetProcesses | GetProcessById | System.Diagnostics.Process.GetProcessByName


Process.MainModule

Gets the main module for the associated process.

[Visual Basic]
Public ReadOnly Property MainModule As ProcessModule
[C#]
public ProcessModule MainModule {get;}
[C++]
public: __property ProcessModule* get_MainModule();
[JScript]
public function get MainModule() : ProcessModule;

Property Value

The ProcessModule that was used to start the process.

Exceptions

Exception Type | Condition
SystemException | You are attempting to access this property on a process on a non-Windows NT computer.

Remarks

A process module represents a .dll or .exe loaded into a particular process. A ProcessModule instance lets you view information about a module, including module and file name, and module memory details.

The MainModule property indicates the executable that was used to start the process.

See Also

Process Class | Process Members | System.Diagnostics Namespace | Modules


Process.MainWindowHandle

Returns the window handle of the main window of the associated process.

[Visual Basic]
Public ReadOnly Property MainWindowHandle As Integer
[C#]
public int MainWindowHandle {get;}
[C++]
public: __property int get_MainWindowHandle();
[JScript]
public function get MainWindowHandle() : int;

Property Value

The system-generated window handle of the main window of the associated process.

Exceptions

Exception Type | Condition
SystemException | The MainWindowHandle is not defined because the process has exited. -or- You are attempting to retrieve the MainWindowHandle for a process running on a remote computer.

Remarks

You can only retrieve the MainWindowHandle for processes running on the local computer. The MainWindowHandle is a 32-bit value assigned that uniquely identifies the window that is responsible for the startup of the process.

A process only has a main window associated with it if the process has a graphical interface. If the associated process does not have a main window, the MainWindowHandle value is zero (0). If you have just started a process, and would like to use its main window handle, consider using the WaitForInputIdle method to allow the process to finish starting and ensure the main window handle has been created. Otherwise, an exception will be thrown.

See Also

Process Class | Process Members | System.Diagnostics Namespace | MainWindowTitle | MainModule


Process.MainWindowTitle

Returns the caption of the MainWindowHandle of the process. If the handle is zero (0), then an empty string is returned.

[Visual Basic]
Public ReadOnly Property MainWindowTitle As String
[C#]
public string MainWindowTitle {get;}
[C++]
public: __property String* get_MainWindowTitle();
[JScript]
public function get MainWindowTitle() : String;

See Also

Process Class | Process Members | System.Diagnostics Namespace


Process.MaxWorkingSet

Gets or sets the maximum allowable working set for the associated process.

[Visual Basic]
Public Property MaxWorkingSet As Integer
[C#]
public int MaxWorkingSet {get; set;}
[C++]
public: __property int get_MaxWorkingSet();
public: __property void set_MaxWorkingSet(int);
[JScript]
public function get MaxWorkingSet() : int;
public function set MaxWorkingSet(int);

Property Value

The maximum working set size allowed in memory for the process.

Exceptions

Exception Type | Condition
Win32Exception | Working set information could not be retrieved from the associated process resource. -or- The process ID or process handle is 0. (The process has not been started.)
SystemException | You are attempting to access the MaxWorkingSet on a remote computer. The property is only available for processes running on the local computer. -or- The process Id is not available. -or- The process has exited.

Remarks

The working set of a program is a collection of those pages in its virtual address space that have been recently referenced. It includes both shared and private data. The shared data includes pages that contain all instructions your application executes, including those in your DLLs and the system DLLs. As the working set size increases, memory demand increases.

A process has an associated minimum working set size and maximum working set size. Each time a process resource is created, it reserves the minimum working set size for the process. The virtual memory manager attempts to keep enough memory for the minimum working set resident when the process is active, but keeps no more than the maximum size.

Note By "process" here, we mean the associated process resource, not an instance of the Process class.

The system sets the default working set sizes. You can modify the working set sizes using the MaxWorkingSet and MinWorkingSet members. Setting these values is not a guarantee that the memory will be reserved or resident.

CAUTION Be careful about requesting too large a minimum or maximum working set size, because doing so can degrade system performance.

See Also

Process Class | Process Members | System.Diagnostics Namespace | MinWorkingSet


Process.MinWorkingSet

Gets or sets the minimum allowable working set for the associated process.

[Visual Basic]
Public Property MinWorkingSet As Integer
[C#]
public int MinWorkingSet {get; set;}
[C++]
public: __property int get_MinWorkingSet();
public: __property void set_MinWorkingSet(int);
[JScript]
public function get MinWorkingSet() : int;
public function set MinWorkingSet(int);

Property Value

The minimum requested working set size in memory for the process.

Exceptions

Exception Type | Condition
Win32Exception | Working set information could not be retrieved from the associated process resource. -or- The process ID or process handle is 0. (The process has not been started.)
SystemException | You are attempting to access the MaxWorkingSet on a remote computer. The property is only available for processes running on the local computer. -or- The process Id is not available. -or- The process has exited.

Remarks

The working set of a program is a collection of those pages in its virtual address space that have been recently referenced. It includes both shared and private data. The shared data includes pages that contain all instructions your application executes, including those in your .dll files and the system .dll files. As the working set size increases, memory demand increases.

A process has an associated minimum working set size and maximum working set size. Each time a process resource is created, it reserves the minimum working set size for the process. The virtual memory manager attempts to keep enough memory for the minimum working set resident when the process is active, but keeps no more than the maximum size.

Note By "process" here, we mean the associated process resource, not an instance of the Process class.

The system sets the default working set sizes. You can modify the working set sizes using the MaxWorkingSet and MinWorkingSet members. Setting these values is not a guarantee that the memory will be reserved or resident.

CAUTION Be careful about requesting too large a minimum or maximum working set size, because doing so can degrade system performance.

See Also

Process Class | Process Members | System.Diagnostics Namespace | MaxWorkingSet


Process.Modules

Gets the modules that have been loaded by the associated process.

[Visual Basic]
Public ReadOnly Property Modules As ProcessModule ()
[C#]
public ProcessModule[] Modules {get;}
[C++]
public: __property ProcessModule* get_Modules();
[JScript]
public function get Modules() : ProcessModule[];

Property Value

An array of type ProcessModule that indicates the modules that have been loaded by the associated process.

Exceptions

Exception Type | Condition
SystemException | You are attempting to access the Modules on a remote computer. The property is only available for processes running on the local computer. -or- The process Id is not available.

Remarks

A process module represents a .dll or .exe loaded into a particular process. A ProcessModule instance lets you view information about a module, including module and file name, and module memory details.

A process can load multiple modules into memory.

See Also

Process Class | Process Members | System.Diagnostics Namespace | ProcessModule


Process.NonpagedSystemMemorySize

Returns the amount of memory that the system has allocated on behalf of the associated process that can not be written to the virtual memory paging file.

[Visual Basic]
Public ReadOnly Property NonpagedSystemMemorySize As Integer
[C#]
public int NonpagedSystemMemorySize {get;}
[C++]
public: __property int get_NonpagedSystemMemorySize();
[JScript]
public function get NonpagedSystemMemorySize() : int;

See Also

Process Class | Process Members | System.Diagnostics Namespace


Process.PagedMemorySize

Returns the amount of memory that the associated process has allocated that can be written to the virtual memory paging file.

[Visual Basic]
Public ReadOnly Property PagedMemorySize As Integer
[C#]
public int PagedMemorySize {get;}
[C++]
public: __property int get_PagedMemorySize();
[JScript]
public function get PagedMemorySize() : int;

See Also

Process Class | Process Members | System.Diagnostics Namespace


Process.PagedSystemMemorySize

Returns the amount of memory that the system has allocated on behalf of the associated process that can be written to the virtual memory paging file.

[Visual Basic]
Public ReadOnly Property PagedSystemMemorySize As Integer
[C#]
public int PagedSystemMemorySize {get;}
[C++]
public: __property int get_PagedSystemMemorySize();
[JScript]
public function get PagedSystemMemorySize() : int;

See Also

Process Class | Process Members | System.Diagnostics Namespace


Process.PeakPagedMemorySize

Returns the maximum amount of memory that the associated process has allocated that can be written to the virtual memory paging file.

[Visual Basic]
Public ReadOnly Property PeakPagedMemorySize As Integer
[C#]
public int PeakPagedMemorySize {get;}
[C++]
public: __property int get_PeakPagedMemorySize();
[JScript]
public function get PeakPagedMemorySize() : int;

See Also

Process Class | Process Members | System.Diagnostics Namespace


Process.PeakVirtualMemorySize

Returns the maximum amount of virtual memory that the associated process has requested.

[Visual Basic]
Public ReadOnly Property PeakVirtualMemorySize As Integer
[C#]
public int PeakVirtualMemorySize {get;}
[C++]
public: __property int get_PeakVirtualMemorySize();
[JScript]
public function get PeakVirtualMemorySize() : int;

See Also

Process Class | Process Members | System.Diagnostics Namespace


Process.PeakWorkingSet

Returns the maximum amount of physical memory that the associated process required at once.

[Visual Basic]
Public ReadOnly Property PeakWorkingSet As Integer
[C#]
public int PeakWorkingSet {get;}
[C++]
public: __property int get_PeakWorkingSet();
[JScript]
public function get PeakWorkingSet() : int;

See Also

Process Class | Process Members | System.Diagnostics Namespace


Process.PriorityBoostEnabled

Gets or sets a value indicating whether the associated process priority should be temporarily boosted by the operating system when the main window has focus.

[Visual Basic]
Public Property PriorityBoostEnabled As Boolean
[C#]
public bool PriorityBoostEnabled {get; set;}
[C++]
public: __property bool get_PriorityBoostEnabled();
public: __property void set_PriorityBoostEnabled(bool);
[JScript]
public function get PriorityBoostEnabled() : Boolean;
public function set PriorityBoostEnabled(Boolean);

Property Value

true if dynamic boosting of the process priority should take place for a process when it is taken out of wait state; otherwise, false. The default is false.

Exceptions

Exception Type | Condition
Win32Exception | Priority boost information could not be retrieved from the associated process resource. -or- The process ID or process handle is 0. (The process has not been started.)
SystemException | You are attempting to access the Modules on a remote computer. The property is only available for processes running on the local computer. -or- The process Id is not available.

Remarks

When a thread runs in a process whose priority class has one of the dynamic priority enumeration values (Normal, High, or RunTime), the system temporarily boosts the thread's priority when it is taken out of a wait state. This prevents other processes from interrupting the processing of the current thread. The PriorityBoostEnabled setting affects all existing threads and any threads subsequently created by the process. To restore normal behavior, set the PriorityBoostEnabled property to false.

Note Boosting the priority too high can drain resources from essential operating system and network functions, causing problems with other operating system tasks.

See Also

Process Class | Process Members | System.Diagnostics Namespace | PriorityClass | BasePriority


Process.PriorityClass

Gets or sets the overall priority category for the associated process.

[Visual Basic]
Public Property PriorityClass As ProcessPriorityClass
[C#]
public ProcessPriorityClass PriorityClass {get; set;}
[C++]
public: __property ProcessPriorityClass get_PriorityClass();
public: __property void set_PriorityClass(ProcessPriorityClass);
[JScript]
public function get PriorityClass() : ProcessPriorityClass;
public function set PriorityClass(ProcessPriorityClass);

Property Value

The priority category for the associated process, from which the process's BasePriority is calculated.

Exceptions

Exception Type | Condition
Win32Exception | Process priority information could not be set or retrieved from the associated process resource. -or- The process ID or process handle is 0. (The process has not been started.)
SystemException | You are attempting to access the Modules on a remote computer. The property is only available for processes running on the local computer. -or- The process Id was not available.

Remarks

A process priority class encompasses a range of thread priority levels. Threads with different priorities running in the process run relative to the process's PriorityClass. Win32 uses four priority classes with seven base priority levels per class. These process priority classes are captured in the enumeration, ProcessPriorityClass, which lets you set the process priority to Idle, Normal, High, AboveNormal, BelowNormal, or RealTime. Based on time elapsed or other boosts, the base priority level can be changed by the operating system when a process needs to be put ahead of others for access to the processor. In addition, you can set PriorityBoostEnabled to temporarily boost the priority level of threads that have been taken out of wait state. The priority is reset when the process returns to the wait state.

The BasePriority property lets you view the starting priority assigned to a process. However, because it is read-only, you cannot use BasePriority to set a process's priority. To change the priority, use PriorityClass. PriorityClass returns or sets the overall priority category for the process. Threads with different priority levels running in the process run relative to the PriorityClass.

PriorityClass cannot be viewed using the Performance Monitor. The following table shows the relationship between BasePriority values and PriorityClass values.

BasePriority | PriorityClass
4 | Idle
8 | Normal
13 | High
24 | RealTime

See Also

Process Class | Process Members | System.Diagnostics Namespace | BasePriority | PriorityBoostEnabled


Process.PrivateMemorySize

Returns the number of bytes that the associated process has allocated that cannot be shared with other processes.

[Visual Basic]
Public ReadOnly Property PrivateMemorySize As Integer
[C#]
public int PrivateMemorySize {get;}
[C++]
public: __property int get_PrivateMemorySize();
[JScript]
public function get PrivateMemorySize() : int;

See Also

Process Class | Process Members | System.Diagnostics Namespace


Process.PrivilegedProcessorTime

Returns the amount of time the process has spent running code inside the operating system core.

[Visual Basic]
Public ReadOnly Property PrivilegedProcessorTime As TimeSpan
[C#]
public TimeSpan PrivilegedProcessorTime {get;}
[C++]
public: __property TimeSpan get_PrivilegedProcessorTime();
[JScript]
public function get PrivilegedProcessorTime() : TimeSpan;

See Also

Process Class | Process Members | System.Diagnostics Namespace


Process.ProcessName

Gets the friendly name of the process.

[Visual Basic]
Public ReadOnly Property ProcessName As String
[C#]
public string ProcessName {get;}
[C++]
public: __property String* get_ProcessName();
[JScript]
public function get ProcessName() : String;

Property Value

The friendly name by which the process is identified by the user of the system.

Exceptions

Exception Type | Condition
SystemException | The process does not have an ID, or there is no process associated with the Process instance. -or- The associated process has exited.

Remarks

The ProcessName is a friendly name for the process, without the .exe extension or the path, such as "Outlook". It is helpful for getting and manipulating all processes associated with the same executable. For example, you can call GetProcessesByName, passing in an executable name, in order to retrieve every running instance on the specified computer. You can use this array, for example, to shut down all running instances of the executable.

See Also

Process Class | Process Members | System.Diagnostics Namespace | GetProcessesByName


Process.ProcessorAffinity

Gets or sets which processors the threads in this process can be scheduled to run on.

[Visual Basic]
Public Property ProcessorAffinity As Integer
[C#]
public int ProcessorAffinity {get; set;}
[C++]
public: __property int get_ProcessorAffinity();
public: __property void set_ProcessorAffinity(int);
[JScript]
public function get ProcessorAffinity() : int;
public function set ProcessorAffinity(int);

Property Value

A bit mask representing the processors that the threads in the associated process can run on. The default is 0.

Exceptions

Exception Type | Condition
Win32Exception | ProcessorAffinity information could not be set or retrieved from the associated process resource. -or- The process ID or process handle is 0. (The process has not been started.)
SystemException | The process Id was not available. -or- The process has exited.

Remarks

In Windows 2000, a thread in a process can migrate from processor to processor, with each migration reloading the processor cache. Under heavy system loads, specifying which processor should run a specific thread can improve performance by reducing the number of times the processor cache is reloaded. The association between a processor and a thread is called the processor affinity.

Each processor is represented as a bit: bit 0 is processor 1, bit 1 is processor 2, and so forth. If you set a bit representing a processor to 1, that processor is selected for thread assignment. When you set ProcessorAffinity to 0, the operating system's scheduling algorithms set the thread's affinity. When the ProcessorAffinity is set to any non-zero value, the value is interpreted as a bit mask that specifies those processors eligible for selection.

The following table shows a selection of ProcessorAffinity values for an eight-processor system.

Bit Mask | Binary Value | Eligible Processors
0x0001 | 00000000 00000001 | 1
0x0003 | 00000000 00000011 | 1 and 2
0x0007 | 00000000 00000111 | 1, 2 and 3
0x0009 | 00000000 00001001 | 1 and 4
0x007F | 00000000 01111111 | 1, 2, 3, 4, 5, 6 and 7

See Also

Process Class | Process Members | System.Diagnostics Namespace


Process.Responding

Gets a value indicating whether or not the user interface of the process is responding.

[Visual Basic]
Public ReadOnly Property Responding As Boolean
[C#]
public bool Responding {get;}
[C++]
public: __property bool get_Responding();
[JScript]
public function get Responding() : Boolean;

Property Value

true if the user interface of the associated process is responding to the system; otherwise, false.

Remarks

Responding contacts the interface of a process that has a user interface to determine if the process is responding to user input. If the interface does not respond immediately, Responding returns false. Use this property to determine whether the interface of the associated process has stopped responding.

If the process does not have a MainWindowHandle, this property returns true.

See Also

Process Class | Process Members | System.Diagnostics Namespace | MainWindowHandle


Process.StartInfo

Gets or sets the parameters to pass into the Start method for the Process.

[Visual Basic]
Public Property StartInfo As ProcessStartInfo
[C#]
public ProcessStartInfo StartInfo {get; set;}
[C++]
public: __property ProcessStartInfo* get_StartInfo();
public: __property void set_StartInfo(ProcessStartInfo*);
[JScript]
public function get StartInfo() : ProcessStartInfo;
public function set StartInfo(ProcessStartInfo);

Property Value

The ProcessStartInfo that represent the arguments with which to start the process. These arguments include the name of the file to be associated with the process.

Exceptions

Exception Type | Condition
ArgumentException | The value that specifies the StartInfo is a null reference (in Visual Basic Nothing).

Remarks

StartInfo represents the set of parameters necessary to start a process. When Start is called, the StartInfo is used to specify the process to start. StartInfo gives you the means to call Start on an existing Process component.

The only necessary StartInfo member to set is the FileName. The behavior of a process started by specifying its FileName is similar to typing the information into the Run dialog box of the Start menu. Therefore, the FileName does not need to be an executable. It can be any file type whose extension has been associated with an application installed on the system, for example ".txt" if you have associated text files with an editor like Notepad, or ".doc" if you have .doc files associated with a word processing tool like Microsoft Word. Similarly, in the same way that the Run dialog box can accept an executable name with or without the extension, the extension is optional as well in the FileName member. For example, you can set the FileName to either "Notepad.exe" or "Notepad".

If the FileName involves a nonexecutable file, like a .doc file, you can include verbs specifying what action to take on the file. For example you could set the Verb to "Print" for a file ending in the .doc extension.

When the process is started, the FileName is the file that populates the (read-only) MainModule property. If you want to retrieve the executable associated with the process after it has started, use the MainModule property. If you want to set the executable on a Process instance for which an associated process has not been started, use the StartInfo property's FileName member. Because the members associated with the StartInfo property are arguments that are passed into the Start method for a process, changing the FileName property after the associated process has been started will not reset the MainModule property. These properties are only used to initialize the associated process.

See Also

Process Class | Process Members | System.Diagnostics Namespace | Start | FileName


Process.StartTime

Returns the time the associated process was started.

[Visual Basic]
Public ReadOnly Property StartTime As DateTime
[C#]
public DateTime StartTime {get;}
[C++]
public: __property DateTime get_StartTime();
[JScript]
public function get StartTime() : DateTime;

See Also

Process Class | Process Members | System.Diagnostics Namespace


Process.SynchronizingObject

Represents the object used to marshal the event handler calls issued as a result of a Process exit. Normally this property will be set when the component is placed inside a control or a from, since those components are bound to a specific thread.

[Visual Basic]
Public Property SynchronizingObject As ISynchronizeInvoke
[C#]
public ISynchronizeInvoke SynchronizingObject {get; set;}
[C++]
public: __property ISynchronizeInvoke* get_SynchronizingObject();
public: __property void set_SynchronizingObject(ISynchronizeInvoke*);
[JScript]
public function get SynchronizingObject() : ISynchronizeInvoke;
public function set SynchronizingObject(ISynchronizeInvoke);

See Also

Process Class | Process Members | System.Diagnostics Namespace


Process.Threads

Gets the set of threads that are running in the associated process.

[Visual Basic]
Public ReadOnly Property Threads As ProcessThread ()
[C#]
public ProcessThread[] Threads {get;}
[C++]
public: __property ProcessThread* get_Threads();
[JScript]
public function get Threads() : ProcessThread[];

Property Value

An array of type ProcessThread that represents the operating system threads currently running in the associated process.

Exceptions

Exception Type | Condition
SystemException | The process does not have an Id, or there is no process associated with the Process instance. -or- The associated process has exited.

Remarks

A thread executes code in a process. Each process is started with a single thread, its primary thread. Any of its threads can create additional threads. The total number of threads is determined by available RAM. Threads within a process share the address space of the process.

Use ProcessThread to get all the threads associated with the current process. The primary thread is not necessarily the thread at index zero in the array.

See Also

Process Class | Process Members | System.Diagnostics Namespace | ProcessThread | BasePriority


Process.TotalProcessorTime

Returns the amount of time the associated process has spent utilizing the CPU. It is the sum of the UserProcessorTime and PrivilegedProcessorTime.

[Visual Basic]
Public ReadOnly Property TotalProcessorTime As TimeSpan
[C#]
public TimeSpan TotalProcessorTime {get;}
[C++]
public: __property TimeSpan get_TotalProcessorTime();
[JScript]
public function get TotalProcessorTime() : TimeSpan;

See Also

Process Class | Process Members | System.Diagnostics Namespace


Process.UserProcessorTime

Returns the amount of time the associated process has spent running code inside the application portion of the process (not the operating system core).

[Visual Basic]
Public ReadOnly Property UserProcessorTime As TimeSpan
[C#]
public TimeSpan UserProcessorTime {get;}
[C++]
public: __property TimeSpan get_UserProcessorTime();
[JScript]
public function get UserProcessorTime() : TimeSpan;

See Also

Process Class | Process Members | System.Diagnostics Namespace


Process.VirtualMemorySize

Returns the amount of virtual memory that the associated process has requested.

[Visual Basic]
Public ReadOnly Property VirtualMemorySize As Integer
[C#]
public int VirtualMemorySize {get;}
[C++]
public: __property int get_VirtualMemorySize();
[JScript]
public function get VirtualMemorySize() : int;

See Also

Process Class | Process Members | System.Diagnostics Namespace


Process.WatchForExit

Gets or sets whether the System.Diagnostics.Process.Exited event is fired when the process terminates.

[Visual Basic]
Public Property WatchForExit As Boolean
[C#]
public bool WatchForExit {get; set;}
[C++]
public: __property bool get_WatchForExit();
public: __property void set_WatchForExit(bool);
[JScript]
public function get WatchForExit() : Boolean;
public function set WatchForExit(Boolean);

Property Value

true if the System.Diagnostics.Process.Exited event is fired when the associated process is terminated (either through an exit or a call to Kill); otherwise, false.

Remarks

WatchForExit indicates whether the component should be notified when the operating system has shut down a process. WatchForExit is used in asynchronous processing to notify your application that a process has exited. To make your application wait for an exit synchronously (which interrupts processing of the application until the exit event has occurred), use the WaitForExit method .

Note If you are using Visiual Studio and double click on a Process component in your project, an System.Diagnostics.Process.Exited event handling delegate and event handling method are automatically generated. Another line sets the WatchForExit property to false. You must change this property to true in order for your event handling method to be executed when the associated process exits.

When an associated process exits (is shut down by the operation system either through a normal or abnormal termination), the operating system notifies any process component to which that process was associated, as long as the WatchForExit value for each component has been set to true. If the process was started by the component, the component can then access administrative information for the associated process, still being stored by the operating system. Such information includes ExitTime, and ExitCode.

After the associated process has exited, the Handle of the component no longer points to an existing process resource. Instead, it can just be used to access the operating system's information about the process resource. The operating system is aware there are handles to exited processes that have not been released by Process components, and keeps the ExitTime and Handle information in memory until the HandleCount is zero.

There is a cost associated with waiting for a process to exit. If WatchForExit is true, the System.Diagnostics.Process.Exited event is fired when the associated process terminates. The procedures that you have specified for the System.Diagnostics.Process.Exited event run at that time.

Sometimes your application can start a process and it is not important for you to be notified when of its closure. For example, your application can launch Notepad for the user to do text editing, but makes no further use of the application after it is launched. You can choose not to be notified when the process exits, because it is not relevant to the continued operation of your application. You can set WatchForExit to false to save system resources.

See Also

Process Class | Process Members | System.Diagnostics Namespace | WaitForExit | System.Diagnostics.Process.Exited | CloseMainWindow | Kill | Handle | ExitTime


Process.WorkingSet

Returns the total amount of physical memory the associated process.

[Visual Basic]
Public ReadOnly Property WorkingSet As Integer
[C#]
public int WorkingSet {get;}
[C++]
public: __property int get_WorkingSet();
[JScript]
public function get WorkingSet() : int;

See Also

Process Class | Process Members | System.Diagnostics Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Process Methods

The methods of the Process class are listed below. For a complete list of Process class members, see the Process Members topic.

Public:

Close | Frees any resources associated with this component.
CloseMainWindow | Closes a process that has a user interface by sending a close message to its main window.
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetCurrentProcess | Returns a new Process component and associates it with the current active process.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProcessById | Overloaded. Creates a new Process component, associating it with the existing process resource specified by the processId parameter.
GetProcesses | Overloaded. Creates an array of new Process components, associating them with existing process resources on the specified computer.
GetProcessesByName | Overloaded. Creates an array of new Process components, associating them with the existing process resources specified by the processName parameter.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Kill | Stops the associated process immediately.
Refresh | Discards any information about the associated process that has been cached inside the process component. After Refresh is called, the first request for information for each property causes the process component to obtain a new value from the associated process.
Start | Overloaded. Starts a process resource and associates it with a Process component.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
WaitForExit | Overloaded. Sets a period to wait for the associated process to exit.
WaitForInputIdle | Overloaded. Instructs the Process component to wait for the associated process to enter an idle state.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnExited | Raises the System.Diagnostics.Process.Exited event.

Event Hookup:

AddOnExited | Adds the Exited event handler.
RemoveOnExited | Remove the Exited event handler.

See Also

Process Class | System.Diagnostics Namespace


Process.AddOnExited

Adds the Exited event handler.

[Visual Basic]
Public Sub AddOnExited( _
   ByVal handler As EventHandler _
)
[C#]
public void AddOnExited(
   EventHandler handler
);
[C++]
public: void AddOnExited(
   EventHandler* handler
);
[JScript]
public function AddOnExited(
   handler : EventHandler
);

Parameters

handler
[To be supplied.]

See Also

Process Class | Process Members | System.Diagnostics Namespace


Process.Close

Frees any resources associated with this component.

[Visual Basic]
Public Sub Close()
[C#]
public void Close();
[C++]
public: void Close();
[JScript]
public function Close();

See Also

Process Class | Process Members | System.Diagnostics Namespace


Process.CloseMainWindow

Closes a process that has a user interface by sending a close message to its main window.

[Visual Basic]
Public Function CloseMainWindow() As Boolean
[C#]
public bool CloseMainWindow();
[C++]
public: bool CloseMainWindow();
[JScript]
public function CloseMainWindow() : Boolean;

Return Value

true if the close message was successfully sent; false if the associated process does not have a main window, or the main window is disabled (for example if a modal dialog is being shown).

Remarks

When a process is executing, its message loop is in a wait state, and executes every time a windows message is sent to the process by the operating system. Calling CloseMainWindow revokes all running message loops on all threads and closes all windows. The request to exit the process by calling CloseMainWindow does not force the application to quit. It can ask for user verification to perform the shutdown, or it can refuse shutdown if the application is running a macro. To force a shutdown, use Kill. The behavior of CloseMainWindow is identical to that of a user closing an application's main window using the Close button. Hence, the request to exit the process by closing the main window does not force the application to quit immediately.

Data edited by the process or resources allocated to the process can be lost if you call Kill. Kill causes an abnormal process termination, and should only be used when necessary. CloseMainWindow enables an orderly shutdown of the process and closes all windows: it is preferable for applications with an interface. If CloseMainWindow fails, you may use Kill to terminate the process. Kill is the only way to terminate processes that do not have graphical interfaces.

Note Currently, all processes started using a Process component open in a command window. They contain a message loop and you can attempt to close them using CloseMainWindow. This will change in a future release. Depending on how the non-graphical interface process is coded, CloseMainWindow could fail and Kill could be necessary in order to stop the process.

You can only call Kill and CloseMainWindow on processes that are running on the local computer. For security reasons, you cannot cause processes on remote computers to exit. You can only view information for processes running on remote computers.

See Also

Process Class | Process Members | System.Diagnostics Namespace


Process.GetCurrentProcess

Returns a new Process component and associates it with the current active process.

[Visual Basic]
Public Shared Function GetCurrentProcess() As Process
[C#]
public static Process GetCurrentProcess();
[C++]
public: static Process* GetCurrentProcess();
[JScript]
public static function GetCurrentProcess() : Process;

Return Value

A new Process component that is associated with the process resource running the calling application.

Remarks

Use this method to create a new Process component and associate it with the active process resource on the local computer. Like the similar GetProcessById, GetProcessesByName, and GetProcesses methods, GetCurrentProcess does not create a new process resource; it only associates an existing resource with a new application-defined Process component.

Because the GetCurrentProcess method is static (in Visual Basic Shared), you do not need to create an instance of the Process component before you call the method. You can call the method on the Process class itself.

See Also

Process Class | Process Members | System.Diagnostics Namespace | GetProcessById | GetProcessesByName | GetProcesses


Process.GetProcessById

Creates a new Process component, associating it with the existing process resource specified by the processId parameter.

Overload List

Returns a new Process component given the identifier of a process on the local computer.

[Visual Basic] Overloads Public Shared Function GetProcessById(Integer) As Process
[C#] public static Process GetProcessById(int);
[C++] public: static Process* GetProcessById(int);
[JScript] public static function GetProcessById(int) : Process;

Returns a new Process component given a process identifier and the name of a computer in the network.

[Visual Basic] Overloads Public Shared Function GetProcessById(Integer, String) As Process
[C#] public static Process GetProcessById(int, String);
[C++] public: static Process* GetProcessById(int, String);
[JScript] public static function GetProcessById(int, String) : Process;

See Also

Process Class | Process Members | System.Diagnostics Namespace


Process.GetProcessById (Int32)

Returns a new Process component given the identifier of a process on the local computer.

[Visual Basic]
Overloads Public Shared Function GetProcessById( _
   ByVal processId As Integer _
) As Process
[C#]
public static Process GetProcessById(
   int processId
);
[C++]
public: static Process* GetProcessById(
   int processId
);
[JScript]
public static function GetProcessById(
   processId : int
) : Process;

Parameters

processId
The system-unique identifier of a process resource.

Return Value

A Process component associated with a local process resource identified by the given Id.

Remarks

Use this method to create a new Process component and associate it with a process resource on the local computer. The process resource must already exist on the computer, because GetProcessById does not create backend resources, but rather associates them with an application-generated Process component. A process Id can only be retrieved for a process that is currently running on the computer. Once the process terminates, GetProcessById throws an exception if you pass in an expired Id.

On any given computer, the Id of a process is unique. GetProcessById returns one process at most. If you want to get all processes running a particular application, use GetProcessesByName. If there are multiple processes on the given computer running the application specified by the processName

parameter, GetProcessesByName returns an array containing all associated processes. You can query each of these processes in turn for their Id. The process ID can be viewed in the Windows Task Manager's Processes panel. The PID column gives the process ID assigned to a process.

Because the GetProcessById method is static (in Visual Basic Shared), you do not need to create an instance of the Process component before you call the method. You can call the method on the Process class itself.

See Also

Process Class | Process Members | System.Diagnostics Namespace | Process.GetProcessById Overload List | Id | GetProcessesByName | GetProcesses | GetCurrentProcess


Process.GetProcessById (Int32, String)

Returns a new Process component given a process identifier and the name of a computer in the network.

[Visual Basic]
Overloads Public Shared Function GetProcessById( _
   ByVal processId As Integer, _
   ByVal machineName As String _
) As Process
[C#]
public static Process GetProcessById(
   int processId,
   string machineName
);
[C++]
public: static Process* GetProcessById(
   int processId,
   String* machineName
);
[JScript]
public static function GetProcessById(
   processId : int,
   machineName : String
) : Process;

Parameters

processId
The system-unique identifier of a process resource.
machineName
[To be supplied.]

Return Value

A Process component associated with a remote process resource identified by the given Id.

Remarks

Use this method to create a new Process component and associate it with a process resource on a remote computer on the network. The process resource must already exist on the specified computer, because GetProcessById does not create backend resources, but rather associates them with an application-generated Process component. A process Id can only be retrieved for a process that is currently running on the computer. Once the process terminates, GetProcessById throws an exception if you pass in an expired Id.

On any given computer, the Id of a process is unique. GetProcessById returns one process at most. If you want to get all processes running a particular application, use GetProcessesByName. If there are multiple processes on the given computer running the application specified by the processName parameter, GetProcessesByName returns an array containing all associated processes. You can query each of these processes in turn for their Id. The process ID can be viewed in the Windows Task Manager's Processes panel. The PID column gives the process ID assigned to a process.

Because the GetProcessById method is static (in Visual Basic Shared), you do not need to create an instance of the Process component before you call the method. You can call the method on the Process class itself.

If you do not specify a machineName, the local computer is used. You can alternately specify the local computer by setting machineName to the value "." or an empty string ("").

See Also

Process Class | Process Members | System.Diagnostics Namespace | Process.GetProcessById Overload List | Id | MachineName | GetProcessesByName | GetProcesses | GetCurrentProcess


Process.GetProcesses

Creates an array of new Process components, associating them with existing process resources on the specified computer.

Overload List

Creates a new Process component for each process resource on the specified computer.

[Visual Basic] Overloads Public Shared Function GetProcesses(String) As Process ()
[C#] public static Process[] GetProcesses(String);
[C++] public: static Process* GetProcesses(String*) [];
[JScript] public static function GetProcesses(String) : Process[];

Creates a new Process component for each process resource on the local computer.

[Visual Basic] Overloads Public Shared Function GetProcesses() As Process ()
[C#] public static Process[] GetProcesses();
[C++] public: static Process* GetProcesses() [];
[JScript] public static function GetProcesses() : Process[];

Example

We use Notepad and Internet Explorer because they open separate instances of the application in separate windows. Some applications, like Word, can open multiple instances in the same window and hence the same process.

It is most demonstrative to open multiple instances of Notepad and Internet Explorer before executing the code.

See Also

Process Class | Process Members | System.Diagnostics Namespace


Process.GetProcesses (String)

Creates a new Process component for each process resource on the specified computer.

[Visual Basic]
Overloads Public Shared Function GetProcesses( _
   ByVal machineName As String _
) As Process ()
[C#]
public static Process[] GetProcesses(
   string machineName
);
[C++]
public: static Process* GetProcesses(
   String* machineName
) [];
[JScript]
public static function GetProcesses(
   machineName : String
) : Process[];

Parameters

machineName
[To be supplied.]

Return Value

An array of type Process that represents all of the process resources running on the computer specified by the machineName parameter.

Remarks

Use this method to create an array of new Process components and associate them with all of the process resources on the specified (usually remote) computer. The process resources must already exist on the computer, because GetProcesses does not create backend resources, but rather associates them with application-generated Process components. Because the operating system itself is running background processes, this array is never empty.

If you don't want to retrieve all processes running on the computer, you can restrict their number by using the GetProcessById or GetProcessesByName methods. GetProcessById creates a Process component that is associated with the specific process identified on the system by the processId value you pass into the method call. GetProcessesByName creates an array of Process components whose associated process resources share the executable file you pass as the processName argument into the method.

Because the GetProcesses method is static (in Visual Basic Shared), you do not need to create an instance of the Process component before you call the method. You can call the method on the Process class itself.

This overload of the GetProcesses method is generally used to retrieve the list of process resources running on a remote computer on the network, but you can specify the local computer as well, by passing in "." or an empty string ("").

See Also

Process Class | Process Members | System.Diagnostics Namespace | Process.GetProcesses Overload List | MachineName | GetProcessById | GetProcessesByName | GetCurrentProcess


Process.GetProcesses ()

Creates a new Process component for each process resource on the local computer.

[Visual Basic]
Overloads Public Shared Function GetProcesses() As Process ()
[C#]
public static Process[] GetProcesses();
[C++]
public: static Process* GetProcesses() [];
[JScript]
public static function GetProcesses() : Process[];

Return Value

An array of type Process that represents all of the process resources running on the local computer.

Remarks

Use this method to create an array of new Process components and associate them with all of the process resources on the local computer. The process resources must already exist on the local computer, because GetProcesses does not create backend resources, but rather associates them with application-generated Process components. Because the operating system itself is running background processes, this array is never empty.

If you don't want to retrieve all processes running on the computer, you can restrict their number by using the GetProcessById or GetProcessesByName methods. GetProcessById creates a Process component that is associated with the specific process identified on the system by the processId value you pass into the method call. GetProcessesByName creates an array of Process components whose associated process resources share the executable file you pass as the processName argument into the method.

Because the GetProcesses method is static (in Visual Basic Shared), you do not need to create an instance of the Process component before you call the method. You can call the method on the Process class itself.

Example

We use Notepad and Internet Explorer because they open separate instances of the application in separate windows. Some applications, like Word, can open multiple instances in the same window and hence the same process.

It is most demonstrative to open multiple instances of Notepad and Internet Explorer before executing the code.

See Also

Process Class | Process Members | System.Diagnostics Namespace | Process.GetProcesses Overload List | MachineName | GetProcessById | GetProcessesByName | GetCurrentProcess


Process.GetProcessesByName

Creates an array of new Process components, associating them with the existing process resources specified by the processName parameter.

Overload List

Creates an array of Process components that are associated with process resources on a remote computer. These process resources share the specified process name.

[Visual Basic] Overloads Public Shared Function GetProcessesByName(String, String) As Process ()
[C#] public static Process[] GetProcessesByName(String, String);
[C++] public: static Process* GetProcessesByName(String*, String*) [];
[JScript] public static function GetProcessesByName(String, String) : Process[];

Creates an array of Process components that are associated with process resources on the local computer. These process resources share the specified process name.

[Visual Basic] Overloads Public Shared Function GetProcessesByName(String) As Process ()
[C#] public static Process[] GetProcessesByName(String);
[C++] public: static Process* GetProcessesByName(String*) [];
[JScript] public static function GetProcessesByName(String) : Process[];

Example [Visual Basic]

The following example gets all processes on the local computer that are running the application specified by the procName parameter (in this example, "notepad"), and trying to close each one down in turn by calling CloseMainWindow. CloseMainWindow is a request to close down, so the procedure forces a close using Kill if the call to CloseMainWindow returns false.

This example assumes that the procName passed in refers to an application that has a graphical interface, and hence a message loop. CloseMainWindow requires the associated process to have a message loop in order to send a window close message to the process.

Note This example shows how to use one of the overloaded versions of GetProcessesByName. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub StopProcesses(ByVal procName As String)
    'Declare a new process component.
    Dim myproc As System.Diagnostics.Process

    'Get all instances of Notepad that are open, attempt to close them.
    For Each myproc In Process.GetProcessesByName(processName)
        If Not myproc.CloseMainWindow Then
'If closing is not successful, then force termination.
myproc.Kill
        End If
    Next
End Sub

See Also

Process Class | Process Members | System.Diagnostics Namespace


Process.GetProcessesByName (String, String)

Creates an array of Process components that are associated with process resources on a remote computer. These process resources share the specified process name.

[Visual Basic]
Overloads Public Shared Function GetProcessesByName( _
   ByVal processName As String, _
   ByVal machineName As String _
) As Process ()
[C#]
public static Process[] GetProcessesByName(
   string processName,
   string machineName
);
[C++]
public: static Process* GetProcessesByName(
   String* processName,
   String* machineName
) [];
[JScript]
public static function GetProcessesByName(
   processName : String,
   machineName : String
) : Process[];

Parameters

processName
The friendly name of the process.
machineName
[To be supplied.]

Return Value

An array of type Process that represents the process resources running the specified application or file.

Remarks

Use this method to create an array of new Process components and associate them with process resources that are all running the same executable file on the specified computer. The process resources must already exist on the specified computer, because GetProcessesByName does not create backend resources, but rather associates them with application-generated Process components. A processName can be specified for an executable that is not currently running on the computer, so the array could be empty when it returns from the method call.

The process name is a friendly name for the process, without the .exe extension or the path, such as "Outlook". GetProcessesByName is helpful for getting and manipulating all processes associated with the same executable file. For example, you can pass in an executable name as the processName parameter in order to shut down all running instances of that executable.

While a process Id is unique to a single process resource on the system, multiple processes on a computer can be running the application specified by the processName parameter. Therefore, GetProcessById will return one process at most, but GetProcessesByName returns an array containing all associated processes. You can query each of these processes in turn for their Id if you need to manipulate the process using standard API calls. You cannot access process resources through the process name alone, but once you have retrieved an array of Process components that have been associated with the process resources, you can start, terminate, and otherwise manipulate the backend resources.

Because the GetProcessesByName method is static (in Visual Basic Shared), you do not need to create an instance of the Process component before you call the method. You can call the method on the Process class itself.

If you do not specify a processName, an empty string ("") is assumed.

You can use this overload to get processes on the local computer as well as a remote computer. Use "." or an empty string ("") to specify the local computer. Another overload exists that uses the local computer by default.

You can only access processes on remote machines in order to view information, such as statistics, about the processes. Because of security restrictions, you cannot close, kill or start processes on remote machines. tech review: can you get exited event notifications?

See Also

Process Class | Process Members | System.Diagnostics Namespace | Process.GetProcessesByName Overload List | ProcessName | MachineName | GetProcessById | GetProcesses | GetCurrentProcess


Process.GetProcessesByName (String)

Creates an array of Process components that are associated with process resources on the local computer. These process resources share the specified process name.

[Visual Basic]
Overloads Public Shared Function GetProcessesByName( _
   ByVal processName As String _
) As Process ()
[C#]
public static Process[] GetProcessesByName(
   string processName
);
[C++]
public: static Process* GetProcessesByName(
   String* processName
) [];
[JScript]
public static function GetProcessesByName(
   processName : String
) : Process[];

Parameters

processName
The friendly name of the process.

Return Value

An array of type Process that represents the process resources running the specified application or file.

Remarks

Use this method to create an array of new Process components and associate them with process resources that are all running the same executable file on the local computer. The process resources must already exist on the computer, because GetProcessesByName does not create backend resources, but rather associates them with application-generated Process components. A processName can be specified for an executable not currently running on the local computer, so the array can be empty when it returns from the method call.

The process name is a friendly name for the process, without the .exe extension or the path, such as "Outlook". GetProcessesByName is helpful for getting and manipulating all processes associated with the same executable file. For example, you can pass in an executable name as the processName parameter, in order to shut down all running instances of that executable.

While a process Id is unique to a single process resource on the system, multiple processes on the local computer can be running the application specified by the processName parameter. Therefore, GetProcessById returns one process at most, but GetProcessesByName returns an array containing all associated processes. You can query each of these processes in turn for their Id if you need to manipulate the process using standard API calls. You cannot access process resources through the process name alone, but once you have retrieved an array of Process components that have been associated with the process resources, you can start, terminate, and otherwise manipulate the backend resources.

Because the GetProcessesByName method is static (in Visual Basic Shared), you do not need to create an instance of the Process component before you call the method. You can call the method on the Process class itself.

If you do not specify a processName, an empty string ("") is assumed.

Example [Visual Basic]

The following example gets all processes on the local computer that are running the application specified by the procName parameter (in this example, "notepad"), and trying to close each one down in turn by calling CloseMainWindow. CloseMainWindow is a request to close down, so the procedure forces a close using Kill if the call to CloseMainWindow returns false.

This example assumes that the procName passed in refers to an application that has a graphical interface, and hence a message loop. CloseMainWindow requires the associated process to have a message loop in order to send a window close message to the process.

[Visual Basic]

Private Sub StopProcesses(ByVal procName As String)
    'Declare a new process component.
    Dim myproc As System.Diagnostics.Process

    'Get all instances of Notepad that are open, attempt to close them.
    For Each myproc In Process.GetProcessesByName(processName)
        If Not myproc.CloseMainWindow Then
'If closing is not successful, then force termination.
myproc.Kill
        End If
    Next
End Sub

See Also

Process Class | Process Members | System.Diagnostics Namespace | Process.GetProcessesByName Overload List | ProcessName | GetProcessById | GetProcesses | GetCurrentProcess


Process.Kill

Stops the associated process immediately.

[Visual Basic]
Public Sub Kill()
[C#]
public void Kill();
[C++]
public: void Kill();
[JScript]
public function Kill();

Exceptions

Exception Type | Condition
Win32Exception | The associated process could not be terminated for the reason specified in the string. For example, the [give example] or [give another example].
SystemException | No process Id has been set, and a Handle from which the Id can be determined does not exist. -or- There is no process associated with this Process object. -or- You are attempting to call Kill on a process running on a remote computer. The method is only available for processes running on the local computer.

Remarks

Kill forces a shutdown, while CloseMainWindow only requests a shutdown. When a process with a graphical interface is executing, its message loop is in a wait state, and executes every time a windows message is sent to the process by the operating system. Calling CloseMainWindow revokes all running message loops on all threads. The request to exit the process by calling CloseMainWindow does not force the application to quit. It asks for user verification to perform the shutdown, or it refuses shutdown if the application is running a macro.

Data edited by the process or resources allocated to the process can be lost if you call Kill. Kill causes an abnormal process termination, so only use it when necessary. CloseMainWindow enables an orderly shutdown of the process and closes all windows, so it is preferable for applications with an interface. If CloseMainWindow fails, you might have to call Kill to terminate the process. Kill is the only way to terminate processes that do not have graphical interfaces, because these processes do not have a message loop that can receive and handle a windows Close message.

Note Currently, all processes started using a Process component open in a command window, so they contain a message loop and you can attempt to close them using CloseMainWindow. This will change before final release. Depending on how the non-graphical interface process is coded, CloseMainWindow may not succeed and Kill may be necessary in order to stop the process.

You can only call Kill and CloseMainWindow on processes that are running on the local computer. For security reasons, you cannot cause processes on remote computers to exit. You can only view information for processes running on remote computers.

See Also

Process Class | Process Members | System.Diagnostics Namespace | CloseMainWindow | Start


Process.OnExited

Raises the System.Diagnostics.Process.Exited event.

[Visual Basic]
Overridable Protected Sub OnExited()
[C#]
protected virtual void OnExited();
[C++]
protected: virtual void OnExited();
[JScript]
protected function OnExited();

Remarks

OnExited is the API that raises the System.Diagnostics.Process.Exited event. Calling OnExited causes the System.Diagnostics.Process.Exited event to occur. This is the only way to raise the event using the Process component, and is primarily used when subclassing the component.

As an alternative to OnExited, you can write your own event handling method. You create your own event handling delegate and your own event handling method.

Note If you are using the Visual Studio environment, an event handling delegate (AddOnExited) and an event handling method (Process1_Exited) are created for you when you drag a Process component onto a form and double-click the icon. The code you create to run when the System.Diagnostics.Process.Exited event occurs is entered into the Process1_Exited procedure. You do not need to create the OnExited member, since it is implemented for you.

Raising an event invokes the event-handling method through a delegate. For an overview, see TBD.

Notes to Inheritors: When overriding OnExited in a derived class, be sure to call the base class's OnExited method.

See Also

Process Class | Process Members | System.Diagnostics Namespace | System.Diagnostics.Process.Exited


Process.Refresh

Discards any information about the associated process that has been cached inside the process component. After Refresh is called, the first request for information for each property causes the process component to obtain a new value from the associated process.

[Visual Basic]
Public Sub Refresh()
[C#]
public void Refresh();
[C++]
public: void Refresh();
[JScript]
public function Refresh();

Remarks

When a Process component is associated with a process resource, the property values of the Process are immediately populated according to the status of the associated process. If the information of the associated process subsequently changes, those changes are not reflected in the Process component's cached values. The Process component is a snapshot of the process resource at the time they are associated. To view the current values for the associated process, call the Refresh method.

See Also

Process Class | Process Members | System.Diagnostics Namespace


Process.RemoveOnExited

Remove the Exited event handler.

[Visual Basic]
Public Sub RemoveOnExited( _
   ByVal handler As EventHandler _
)
[C#]
public void RemoveOnExited(
   EventHandler handler
);
[C++]
public: void RemoveOnExited(
   EventHandler* handler
);
[JScript]
public function RemoveOnExited(
   handler : EventHandler
);

Parameters

handler
[To be supplied.]

See Also

Process Class | Process Members | System.Diagnostics Namespace


Process.Start

Starts a process resource and associates it with a Process component.

Overload List

Starts a process specified by the StartInfo property of this Process component and associates it with the Process. If a process resource is reused rather than started, the reused process is associated with this Process component.

[Visual Basic] Overloads Overridable Public Function Start() As Boolean
[C#] public virtual bool Start();
[C++] public: virtual bool Start();
[JScript] public function Start() : Boolean;

Starts a process resource specified by the process start information passed in, for example the file name of the process to start. Associates the process resource with a new Process component.

[Visual Basic] Overloads Public Shared Function Start(ProcessStartInfo) As Process
[C#] public static Process Start(ProcessStartInfo);
[C++] public: static Process* Start(ProcessStartInfo*);
[JScript] public static function Start(ProcessStartInfo) : Process;

Starts a process resource by specifying the name of a document or application file. Associates the process resource with a new Process component.

[Visual Basic] Overloads Public Shared Function Start(String) As Process
[C#] public static Process Start(String);
[C++] public: static Process* Start(String*);
[JScript] public static function Start(String) : Process;

Starts a process resource by specifying the name of an application and a set of command line arguments. Associates the process resource with a new Process component.

[Visual Basic] Overloads Public Shared Function Start(String, String) As Process
[C#] public static Process Start(String, String);
[C++] public: static Process* Start(String*, String*);
[JScript] public static function Start(String, String) : Process;

Example

The following example demonstrates starting Internet Explorer as a process from within your application. It passes in the URL

See Also

Process Class | Process Members | System.Diagnostics Namespace


Process.Start ()

Starts a process specified by the StartInfo property of this Process component and associates it with the Process. If a process resource is reused rather than started, the reused process is associated with this Process component.

[Visual Basic]
Overloads Overridable Public Function Start() As Boolean
[C#]
public virtual bool Start();
[C++]
public: virtual bool Start();
[JScript]
public function Start() : Boolean;

Return Value

true if a process resource is started; false if no new process resource is started (for example, if an existing process is reused).

Exceptions

Exception Type | Condition
ArgumentException | No file name was specified in the Process component's StartInfo.
Win32Exception | There was an error opening the associated file.

Remarks

Use this overload to start a process resource and associate it with the current Process component. The return value true indicates that a new process resource was started. If the process resource specified by the FileName member of the StartInfo property is already running on the computer, no additional process resource is started. Instead, the running process resource is reused and false is returned.

Note If you are using Visual Studio, this overload of the Start method is the one that you insert into your code after you drag a Process component onto the designer. Use the Properties window to expand the StartInfo category and write the appropriate value into the FileName property. Your changes will appear in the form's InitializeComponent procedure.

This overload of Start is not a static (in Visual Basic Shared) method. You must call it on an instance of the Process class. Before calling Start, you must first specify StartInfo property information for this Process because that information is used to determine the process resource to start.

The other overloads of the Start method are static (Shared) members. You do not need to create an instance of the Process component before you call those overloads of the method. Instead, you can call Start on the Process class itself and a new Process component is created if the process was started (or a null reference (in Visual Basic Nothing) is returned if a process was reused). The process resource is automatically associated with the new Process component returned by the call to the Start method.

The StartInfo members can be used to duplicate the functionality of the Run dialog box of the Windows Start menu. Anything that can be typed into a command line can be launched by setting appropriate values for the StartInfo. The only StartInfo property that must be set is the FileName. The FileName does not have to be an executable. It can be any file type whose extension has been associated with an application installed on the system, for example ".txt" if you have associated text files with an editor like Notepad, or ".doc" if you have .doc files associated with a word processing tool like Microsoft Word.

In the command line, you can specify actions to take for certain types of files. For example, you can print documents or edit text files. Specify these actions using the Verb or Verbs members of the StartInfo property. For other types of files, you can specify command line arguments when launching them from the Run dialog box of the Start menu. For example, you can pass a URL as an argument if you specify your browser as the FileName. These arguments can be specified in the StartInfo property's Arguments member.

See the ProcessStartInfo class for details about process start information.

Whenever you use Start to start a process, you must be sure to close it or you risk losing system resources. Close processes using CloseMainWindow or Kill. CloseMainWindow is used to close processes that contain a graphical interface, while Kill must be used for non-graphical applications that do not have a message pump to handle a windows Close request.

Note Currently, all processes started using a Process component open in a command window. They contain a message loop and you can attempt to close them using CloseMainWindow. This will change in a future release. Depending on how the non-graphical interface process is coded, CloseMainWindow could fail and Kill could be necessary in order to stop the process.

Example [Visual Basic]

The following example demonstrates starting one of four processes (Word, Excel, Internet Explorer, or Notepad) depending on information regarding a document passed into the procedure, and assigning information to an existing process object which is then started by the procedure.

StartProcess takes two parameters. The first parameter is the name of a document (in this case, 'document' is a generic term for any viewable file, for example MyDoc.doc or MyFile.txt) and the second is the extension of the document (.doc, .txt, .htm., or .xls). Using the extension, the StartProcess procedure associates an application with the Process component's StartInfo. Then the document itself is assigned as an argument with which the application is opened. In the case of Excel or Word, the document is opened in order to be printed. In the case of Notepad or Internet Explorer, the document is only loaded into the application's window.

The fileName and arguments are the same that would type into the Run dialog box of the Start menu. A window displays the document passed into StartProcess as the docName

parameter.

[Visual Basic]

Private Sub StartProcess(ByVal fileName As String, ByVal extension As String)
    'Declare and instantiate a new process component.
    Dim myproc As System.Diagnostics.Process
    myproc = New System.Diagnostics.Process

    'Do not receive an event when the process exits.
    myproc.WatchForExit = False

    'Use the extenstion to determine which application to open.
    Select Case extension
        Case "doc"
'.doc files open in Word.
myproc.StartInfo.FileName = "winword"
'Print the file.
myproc.StartInfo.Verb = "print"
        Case "xls"
'.xls files open in Excel.
myproc.StartInfo.FileName = "excel"
'Print the file.
myproc.StartInfo.Verb = "print"
        Case "htm"
'.htm files open in the browser.
myproc.StartInfo.FileName = "iexplore"
        Case "txt"
'.txt files open in Notepad.
myproc.StartInfo.FileName = "notepad"
    End Select

    'Assign the document the file should open.
    myproc.StartInfo.Arguments = fileName

    'Start the application and assign it to the process component.
    myproc.Start
End Sub

See Also

Process Class | Process Members | System.Diagnostics Namespace | Process.Start Overload List | StartInfo | FileName | ProcessStartInfo | CloseMainWindow | Kill


Process.Start (ProcessStartInfo)

Starts a process resource specified by the process start information passed in, for example the file name of the process to start. Associates the process resource with a new Process component.

[Visual Basic]
Overloads Public Shared Function Start( _
   ByVal startInfo As ProcessStartInfo _
) As Process
[C#]
public static Process Start(
   ProcessStartInfo startInfo
);
[C++]
public: static Process* Start(
   ProcessStartInfo* startInfo
);
[JScript]
public static function Start(
   startInfo : ProcessStartInfo
) : Process;

Parameters

startInfo
The ProcessStartInfo that contains information used to start the process, including file name or command line arguments.

Return Value

A new Process component associated with the process resource, or a null reference (in Visual Basic Nothing) if no process resource is started (for example, if an existing process is reused).

Exceptions

Exception Type | Condition
ArgumentException | The startInfo parameter is a null reference (Nothing).

Remarks

Use this overload to start a process resource by specifying a ProcessStartInfo instance, and associate it with a new Process component. If the process is already running, no additional process resource is started. Instead, the existing process resource is reused and no new Process component is created. In such a case, instead of returning a new Process component, the call to Start returns a null reference (Nothing) to the calling procedure.

This overload lets you start a process without first instantiating a Process object. Using this overload with a ProcessStartInfo parameter is an alternate for the explicit steps of instantiating a Process, setting its StartInfo properties, and calling Start on the Process.

Using a ProcessStartInfo instance as the parameter lets you call Start with the most control over what is passed into the call to start process. If you only need to pass in a file name or a file name and arguments, it is not necessary to create a new ProcessStartInfo instance, although that is an option. The only StartInfo property that must be set is the FileName. The FileName does not need to be an executable. It can be any file type whose extension has been associated with an application installed on the system, for example ".txt" if you have associated text files with an editor like Notepad, or ".doc" if you have .doc files associated with a word processing tool like Microsoft Word.

This overload of the Start method is a static (in Visual Basic Shared) member. You do not need to create an instance of the Process component before you call the method. You can call Start on the Process class itself. The process resource is automatically associated with the new Process component returned by the call to the Start method.

Unlike the other overloads, the parameterless overload of Start is not a static (Shared) member. Use the paremeterless overload when you have already created a Process instance, specified start information including the file name, and want to start a process resource and associate it with the existing Process. Use one of the static (Shared) overloads when you want to create a new Process component rather than start a process on an existing component. Both this overload and the parameterless overload allow you to specify the start information for the process resource using a ProcessStartInfo instance.

Whenever you use Start to start a process, you must be sure to close it or you risk losing system resources. You close processes using CloseMainWindow or Kill. CloseMainWindow is used to close processes that contain a graphical interface, while Kill must be used for non-graphical applications that do not have a message pump to handle a windows Close request.

Note Currently, all processes started using a Process component open in a command window. They contain a message loop and you can attempt to close them using CloseMainWindow. This will change in a future release. Depending on how the non-graphical interface process is coded, CloseMainWindow could fail and Kill could be necessary in order to stop the process.

See Also

Process Class | Process Members | System.Diagnostics Namespace | Process.Start Overload List | StartInfo | FileName | ProcessStartInfo | CloseMainWindow | Kill


Process.Start (String)

Starts a process resource by specifying the name of a document or application file. Associates the process resource with a new Process component.

[Visual Basic]
Overloads Public Shared Function Start( _
   ByVal fileName As String _
) As Process
[C#]
public static Process Start(
   string fileName
);
[C++]
public: static Process* Start(
   String* fileName
);
[JScript]
public static function Start(
   fileName : String
) : Process;

Parameters

fileName
The name of a document or application file to run in the process.

Return Value

A new Process component associated with the process resource, or a null reference (in Visual Basic Nothing) if no process resource is started (for example, if an existing process is reused).

Exceptions

Exception Type | Condition
ArgumentException | The fileName parameter is a null reference (Nothing).

Remarks

Use this overload to start a process resource by specifying its file name, and associate it with a new Process component. If the process is already running, no additional process resource is started. Instead, the existing process resource is reused and no new Process component is created. In such a case, instead of returning a new Process component, the call to Start returns a null reference (Nothing) to the calling procedure.

This overload lets you start a process without first instantiating a Process object. It is an alternate for the explicit steps of instantiating a Process object, setting the FileName member of the StartInfo property, and calling Start on the Process.

The behavior of a process started by specifying its fileName is similar to typing the fileName into the Run dialog box of the Windows Start menu. Therefore, the fileName does not have to be an executable. It can be any file type whose extension has been associated with an application installed on the system, for example ".txt" if you have associated text files with an editor like Notepad, or ".doc" if you have .doc files associated with a word processing tool like Microsoft Word. Similarly, in the same way that the Run dialog box can accept an executable name with or without the extension, the extension is optional as well in the fileName parameter. For example, you can set the fileName to either "Notepad.exe" or "Notepad".

This overload of the Start method is a static (in Visual Basic Shared) member. You do not need to create an instance of the Process component before you call the method. You can call Start on the Process class itself. The process resource is automatically associated with the new Process component returned by the call to the Start method.

Unlike the other overloads, the parameterless overload of Start is not a static (Shared) member. Use the parameterless overload when you have already created a Process instance, specified start information including the file name, and want to start a process resource and associate it with the existing Process. Use one of the static (Shared) overloads when you want to create a new Process component rather than start a process on an existing component. Both this overload and the parameterless overload allow you to specify the file name of the process resource to start.

Whenever you use Start to start a process, you must be sure to close it or you risk losing system resources. You close processes using CloseMainWindow or Kill. CloseMainWindow is used to close processes that contain a graphical interface, while Kill must be used for non-graphical applications that do not have a message pump to handle a windows Close request.

Note Currently, all processes started using a Process component open in a command window. They contain a message loop and you can attempt to close them using CloseMainWindow. This will change in a future release. Depending on how the non-graphical interface process is coded, CloseMainWindow could fail and Kill could be necessary in order to stop the process.

Example [Visual Basic]

The following example demonstrates opening Notepad by passing the name of the application to the Start method. Because Notepad could receive a close request before the window has opened and initialized, the procedure instructs it to wait until Notepad is in its message loop in an idle state before receiving input. The example code results in the opening a blank Notepad window.

[Visual Basic]

Private Sub StartWithFileName()
    'Declare and instantiate a new process component.
    Dim myproc As System.Diagnostics.Process
    myproc = New System.Diagnostics.Process

    'Do not receive an event when the process exits.
    myproc.WatchForExit = False
    'Start Notepad and assign it to the process component.
    myproc.Start "Notepad"

    'This prevents the window from accepting a close before it has fully opened.
    myproc.WaitForInputIdle
End Sub

See Also

Process Class | Process Members | System.Diagnostics Namespace | Process.Start Overload List | FileName | StartInfo | CloseMainWindow | Kill


Process.Start (String, String)

Starts a process resource by specifying the name of an application and a set of command line arguments. Associates the process resource with a new Process component.

[Visual Basic]
Overloads Public Shared Function Start( _
   ByVal fileName As String, _
   ByVal arguments As String _
) As Process
[C#]
public static Process Start(
   string fileName,
   string arguments
);
[C++]
public: static Process* Start(
   String* fileName,
   String* arguments
);
[JScript]
public static function Start(
   fileName : String,
   arguments : String
) : Process;

Parameters

fileName
The name of an application file to run in the process.
arguments
[To be supplied.]

Return Value

A new Process component associated with the process resource, or a null reference (in Visual Basic Nothing) if no process resource is started (for example, if an existing process is reused).

Exceptions

Exception Type | Condition
ArgumentException | The fileName or arguments parameters are a null reference (Nothing).

Remarks

Use this overload to start a process resource by specifying its file name and command line arguments, and associate it with a new Process component. If the process is already running, no additional process resource is started. Instead, the existing process resource is reused and no new Process component is created. In such a case, instead of returning a new Process component, the call to Start returns a null reference (Nothing) to the calling procedure.

This overload lets you start a process without first instantiating a Process object. It is an alternate for the explicit steps of instantiating a Process object, setting the FileName and Arguments members of the StartInfo property, and calling Start on the Process.

The behavior of a process started by specifying its fileName and arguments is similar to typing the fileName and arguments into the Run dialog box of the Windows Start menu. Therefore, the fileName does not have to be an executable. It can be any file type whose extension has been associated with an application installed on the system, for example ".txt" if you have associated text files with an editor like Notepad, or ".doc" if you have .doc files associated with a word processing tool like Microsoft Word. Similarly, in the same way that the Run dialog box can accept an executable name with or without the extension, the extension is optional as well in the fileName parameter. For example, you can set the fileName to either "Notepad.exe" or "Notepad". If fileName represents an executable, arguments

may represent, for example, a file to act upon, such as the text file in Notepad

myfile.

This overload of the Start method is a static (in Visual Basic Shared) member. You do not need to create an instance of the Process component before you call the method. You can call Start on the Process class itself. The process resource is automatically associated with the new Process component returned by the call to the Start method.

Unlike the other overloads, the parameterless overload of Start is not a static (Shared) member. Use the parameterless overload when you have already created a Process instance, specified start information including the file name, and want to start a process resource and associate it with the existing Process. Use one of the static (Shared) overloads when you want to create a new Process component rather than start a process on an existing component. Both this overload and the parameterless overload allow you to specify the file name of the process resource and command line arguments to pass into the call to start the process.

Whenever you use Start to start a process, you must be sure to close it or you risk losing system resources. You close processes using CloseMainWindow or Kill. CloseMainWindow is used to close processes that contain a graphical interface, while Kill must be used for non-graphical applications that do not have a message pump to handle a windows Close request.

Note Currently, all processes started using a Process component open in a command window. They contain a message loop and you can attempt to close them using CloseMainWindow. This will change in a future release. Depending on how the non-graphical interface process is coded, CloseMainWindow could fail and Kill could be necessary in order to stop the process.

Example

The following example demonstrates starting Internet Explorer as a process from within your application. It passes in the URL

See Also

Process Class | Process Members | System.Diagnostics Namespace | Process.Start Overload List


Process.WaitForExit

Sets a period to wait for the associated process to exit.

Overload List

Instructs the Process component to wait the specified number of milliseconds for the associated process to exit.

[Visual Basic] Overloads Public Function WaitForExit(Integer) As Boolean
[C#] public bool WaitForExit(int);
[C++] public: bool WaitForExit(int);
[JScript] public function WaitForExit(int) : Boolean;

Instructs the Process component to wait indefinitely for the associated process to exit.

[Visual Basic] Overloads Public Sub WaitForExit()
[C#] public void WaitForExit();
[C++] public: void WaitForExit();
[JScript] public function WaitForExit();

See Also

Process Class | Process Members | System.Diagnostics Namespace


Process.WaitForExit (Int32)

Instructs the Process component to wait the specified number of milliseconds for the associated process to exit.

[Visual Basic]
Overloads Public Function WaitForExit( _
   ByVal milliseconds As Integer _
) As Boolean
[C#]
public bool WaitForExit(
   int milliseconds
);
[C++]
public: bool WaitForExit(
   int milliseconds
);
[JScript]
public function WaitForExit(
   milliseconds : int
) : Boolean;

Parameters

milliseconds
The amount of time, in milliseconds, to wait for the associated process to exit. The maximum is the largest possible value of a 32-bit integer, which represents infinity on the operating system.

Return Value

true if the associated process exited; otherwise, false.

Exceptions

Exception Type | Condition
Win32Exception | The wait setting could not be accessed for the reason specified in the string. For example, the [give example] or [give another example].
SystemException | No process Id has been set, and a Handle from which the Id can be determined does not exist. -or- There is no process associated with this Process object. -or- You are attempting to call WaitForExit on a process running on a remote computer. The method is only available for processes running on the local computer.

Remarks

WaitForExit is used in synchronous processing to notify your application that a process has exited. To allow your application to continue processing and be notified asynchronously that an System.Diagnostics.Process.Exited event has occurred, use the WaitForExit member and create an System.Diagnostics.Process.Exited event handling delegate and event handling method.

This overload of WaitForExit instructs the Process component to wait a finite amount of time for the process to exit. If the associated process does not exit by the end of the interval because the request to terminate is denied, false is returned to the calling procedure. You can specify a negative number for milliseconds, but it is treated by WaitForExit as a very large positive number. If you pass in 0 to the method, it returns true only if the process has already exited.

When an associated process exits (is shut down by the operation system through either a normal or abnormal termination), the system stores information about the associated process and returns to the component that had called WaitForExit. The Process component can then access administrative information for the associated process stored by the operation system. Such information includes ExitTime, and is retrieved using the Handle to the now-exited process.

Because the associated process has exited, the handle that the process component has no longer points to an existing process resource. Instead, it can only be used to access the operating system's information about the process resource. The system is aware of handles to exited processes that have not been released by Process components, and keeps the ExitTime and Handle information in memory until the Process component specifically frees the resources. For this reason, any time you call Start on a Process, call Close when the associated process has terminated and you no longer need administrative information about it. Close frees the memory devoted to the exited process.

See Also

Process Class | Process Members | System.Diagnostics Namespace | Process.WaitForExit Overload List | CloseMainWindow | Kill | Handle | ExitTime | WatchForExit | System.Diagnostics.Process.Exited


Process.WaitForExit ()

Instructs the Process component to wait indefinitely for the associated process to exit.

[Visual Basic]
Overloads Public Sub WaitForExit()
[C#]
public void WaitForExit();
[C++]
public: void WaitForExit();
[JScript]
public function WaitForExit();

Exceptions

Exception Type | Condition
Win32Exception | The wait setting could not be accessed for the reason specified in the string. For example, the [give example] or [give another example].
SystemException | No process Id has been set, and a Handle from which the Id can be determined does not exist. -or- There is no process associated with this Process object. -or- You are attempting to call WaitForExit on a process running on a remote computer. The method is only available for processes running on the local computer.

Remarks

WaitForExit is used in synchronous processing to notify your application that a process has exited. To allow your application to continue processing and be notified asynchronously that an System.Diagnostics.Process.Exited event has occurred, use the WaitForExit member and create an System.Diagnostics.Process.Exited event handling delegate and event handling method.

This overload of WaitForExit instructs the Process component to wait an infinite amount of time for the process to exit. This can cause an application to stop responding. For example, if you call CloseMainWindow on a Process that has a user interface, the request to the operating system to terminate the associated process may not be handled if the process is coded to never enter its message loop

When an associated process exits (is shut down by the operation system through either a normal or abnormal termination), the system stores information about the associated process and returns to the component that had called WaitForExit. The Process component can then access administrative information for the associated process stored by the operation system. Such information includes ExitTime, and is retrieved using the Handle to the now-exited process.

Because the associated process has exited, the handle that the process component has no longer points to an existing process resource. Instead, it can only be used to access the operating system's information about the process resource. The system is aware of handles to exited processes that have not been released by Process components, and keeps the ExitTime and Handle information in memory until the Process component specifically frees the resources. For this reason, any time you call Start on a Process, call Close when the associated process has terminated and you no longer need administrative information about it. Close frees the memory devoted to the exited process.

See Also

Process Class | Process Members | System.Diagnostics Namespace | Process.WaitForExit Overload List | CloseMainWindow | Kill | Handle | ExitTime | WatchForExit | System.Diagnostics.Process.Exited


Process.WaitForInputIdle

Instructs the Process component to wait for the associated process to enter an idle state.

Overload List

Causes the Process component to wait the specified number of milliseconds for the associated process to enter an idle state. This is only applicable for processes with a user interface, therefore a message loop.

[Visual Basic] Overloads Public Function WaitForInputIdle(Integer) As Boolean
[C#] public bool WaitForInputIdle(int);
[C++] public: bool WaitForInputIdle(int);
[JScript] public function WaitForInputIdle(int) : Boolean;

Instructs the Process component to wait indefinitely for the associated process to enter an idle state. This is only applicable for processes with a user interface, therefore a message loop.

[Visual Basic] Overloads Public Function WaitForInputIdle() As Boolean
[C#] public bool WaitForInputIdle();
[C++] public: bool WaitForInputIdle();
[JScript] public function WaitForInputIdle() : Boolean;

See Also

Process Class | Process Members | System.Diagnostics Namespace


Process.WaitForInputIdle (Int32)

Causes the Process component to wait the specified number of milliseconds for the associated process to enter an idle state. This is only applicable for processes with a user interface, therefore a message loop.

[Visual Basic]
Overloads Public Function WaitForInputIdle( _
   ByVal milliseconds As Integer _
) As Boolean
[C#]
public bool WaitForInputIdle(
   int milliseconds
);
[C++]
public: bool WaitForInputIdle(
   int milliseconds
);
[JScript]
public function WaitForInputIdle(
   milliseconds : int
) : Boolean;

Parameters

milliseconds
The amount of time, in milliseconds, to wait for the associated process to become idle. The maximum is the largest possible value of a 32-bit integer, which represents infinity on the operating system.

Return Value

true if the associated process reached an idle state; otherwise, false.

Remarks

Use WaitForInputIdle to force processing of your application to wait until the message loop has returned to the idle state. When a process with a user interface is executing, its message loop executes every time a windows message is sent to the process by the operating system. The process then returns to the message loop. A process is said to be in an idle state when it is waiting for messages inside of a message loop. This is useful, for example, when your application waits for a starting process to finish creating its main window before communicating with that window.

Note Currently, all processes started using a Process component open in a command window. They contain a message loop and you can set WaitForInputIdle on them meaningfully. This will change in a future release.

If a process does not have a message loop, WaitForInputIdle immediately returns false.

This overload of WaitForInputIdle instructs the Process component to wait a finite amount of time for the process to become idle in the message loop. If the associated process has not become idle by the end of the interval because the loop is still processing messages, false is returned to the calling procedure.

See Also

Process Class | Process Members | System.Diagnostics Namespace | Process.WaitForInputIdle Overload List | Start | CloseMainWindow


Process.WaitForInputIdle ()

Instructs the Process component to wait indefinitely for the associated process to enter an idle state. This is only applicable for processes with a user interface, therefore a message loop.

[Visual Basic]
Overloads Public Function WaitForInputIdle() As Boolean
[C#]
public bool WaitForInputIdle();
[C++]
public: bool WaitForInputIdle();
[JScript]
public function WaitForInputIdle() : Boolean;

Return Value

true if the associated process reached an idle state; otherwise, false.

Remarks

Use WaitForInputIdle to force processing of your application to wait until the message loop has returned to the idle state. When a process with a user interface is executing, its message loop executes every time a windows message is sent to the process by the operating system. The process then returns to the message loop. A process is said to be in an idle state when it is waiting for messages inside of a message loop. This is useful, for example, when your application waits for a starting process to finish creating its main window before communicating with that window.

Note Currently, all processes started using a Process component open in a command window. They contain a message loop and you can set WaitForInputIdle on them meaningfully. This will change in a future release.

If a process does not have a message loop, WaitForInputIdle immediately returns false.

This overload of WaitForInputIdle instructs the Process component to wait indefinitely for the process to become idle in the message loop. This can cause an application to stop responding. For example, if the process is coded to always immediately exits it message loop, as in the code fragment while(true).

See Also

Process Class | Process Members | System.Diagnostics Namespace | Process.WaitForInputIdle Overload List | Start | CloseMainWindow


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Process Events

The events of the Process class are listed below. For a complete list of Process class members, see the Process Members topic.

Public:

Exited [To be supplied.]

See Also

Process Class | System.Diagnostics Namespace


Process Exited Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the Exited event.

[Visual Basic]
Private Sub ProcessName_Exited( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
private void ProcessName_Exited(
   object sender,
   EventArgs e
);
[C++]
private: void ProcessName_Exited(
   Object* sender,
   EventArgs* e
);
[JScript]
private ProcessName_Exited(
   sender : Object,
   e : EventArgs
);

Parameters

sender
The source of the event.
e
An EventArgs that contains the event data. The following EventArgs properties provide information specific to this event.
Property Description
ExtendedInfo
Holds a reference to an object that manages the event's state.

Remarks

The System.Diagnostics.Process.Exited event indicates that the associated process exited. This can mean either a process termination (aborted process) or a successfully closed process. When the operating system shuts down a process, any process component that is waiting for an exit is notified. The component can then access the associated process information that is still resident in the operating system memory, like ExitTime, by using the handle that it has to the process.

Because the associated process has exited, the handle that the process component has no longer points to an existing process resource. Instead, it can only be used to access the operating system's information about the process resource. The system is aware of handles to exited processes that have not been released by Process components, and keeps the ExitTime and Handle information in memory until the Process component specifically frees the resources.

Note Even if you have a handle to an exited process, you cannot call Start again to reconnect to the same process. Calling Start releases the associated process automatically, and connects to a process with the same file but an entirely new Handle.

See Also

Process Class | Process MembersTopic | System.Diagnostics Namespace


ProcessModule Class

A process module component represents a DLL or EXE loaded into a particular process. Using this component, you can determine information about the module.

Object
Component
ProcessModule

[Visual Basic]
Public Class ProcessModule
   Inherits Component
[C#]
public class ProcessModule : Component
[C++]
public __gc class ProcessModule : public Component
[JScript]
public class ProcessModule extends Component

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

ProcessModule Members | System.Diagnostics Namespace


ProcessModule Members

Public:

Properties

BaseAddress | Returns the memory address that the module was loaded at.
EntryPointAddress | Returns the memory address for function that runs when the module is loaded and run.
FileName | Returns the full file path for the location of the module.
FileVersionInfo | Returns version information about the module.
ModuleMemorySize | Returns the amount of memory required to load the module. This does not include any additional memory allocations made by the module once it is running; it only includes the size of the static code and data in the module file.
ModuleName | Returns the name of the Module.
Site (inherited from Component) | Gets or sets the site of the Component.

Methods

Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProcessModule Class | System.Diagnostics Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ProcessModule Properties

The properties of the ProcessModule class are listed below. For a complete list of ProcessModule class members, see the ProcessModule Members topic.

Public:

BaseAddress | Returns the memory address that the module was loaded at.
EntryPointAddress | Returns the memory address for function that runs when the module is loaded and run.
FileName | Returns the full file path for the location of the module.
FileVersionInfo | Returns version information about the module.
ModuleMemorySize | Returns the amount of memory required to load the module. This does not include any additional memory allocations made by the module once it is running; it only includes the size of the static code and data in the module file.
ModuleName | Returns the name of the Module.
Site (inherited from Component) | Gets or sets the site of the Component.

See Also

ProcessModule Class | System.Diagnostics Namespace


ProcessModule.BaseAddress

Returns the memory address that the module was loaded at.

[Visual Basic]
Public ReadOnly Property BaseAddress As Integer
[C#]
public int BaseAddress {get;}
[C++]
public: __property int get_BaseAddress();
[JScript]
public function get BaseAddress() : int;

See Also

ProcessModule Class | ProcessModule Members | System.Diagnostics Namespace


ProcessModule.EntryPointAddress

Returns the memory address for function that runs when the module is loaded and run.

[Visual Basic]
Public ReadOnly Property EntryPointAddress As Integer
[C#]
public int EntryPointAddress {get;}
[C++]
public: __property int get_EntryPointAddress();
[JScript]
public function get EntryPointAddress() : int;

See Also

ProcessModule Class | ProcessModule Members | System.Diagnostics Namespace


ProcessModule.FileName

Returns the full file path for the location of the module.

[Visual Basic]
Public ReadOnly Property FileName As String
[C#]
public string FileName {get;}
[C++]
public: __property String* get_FileName();
[JScript]
public function get FileName() : String;

See Also

ProcessModule Class | ProcessModule Members | System.Diagnostics Namespace


ProcessModule.FileVersionInfo

Returns version information about the module.

[Visual Basic]
Public ReadOnly Property FileVersionInfo As FileVersionInfo
[C#]
public FileVersionInfo FileVersionInfo {get;}
[C++]
public: __property FileVersionInfo* get_FileVersionInfo();
[JScript]
public function get FileVersionInfo() : FileVersionInfo;

See Also

ProcessModule Class | ProcessModule Members | System.Diagnostics Namespace


ProcessModule.ModuleMemorySize

Returns the amount of memory required to load the module. This does not include any additional memory allocations made by the module once it is running; it only includes the size of the static code and data in the module file.

[Visual Basic]
Public ReadOnly Property ModuleMemorySize As Integer
[C#]
public int ModuleMemorySize {get;}
[C++]
public: __property int get_ModuleMemorySize();
[JScript]
public function get ModuleMemorySize() : int;

See Also

ProcessModule Class | ProcessModule Members | System.Diagnostics Namespace


ProcessModule.ModuleName

Returns the name of the Module.

[Visual Basic]
Public ReadOnly Property ModuleName As String
[C#]
public string ModuleName {get;}
[C++]
public: __property String* get_ModuleName();
[JScript]
public function get ModuleName() : String;

See Also

ProcessModule Class | ProcessModule Members | System.Diagnostics Namespace


ProcessPriorityClass Enumeration

A category of priority for a process. Threads within a process run at a priority which is relative to the process priority class.

[Visual Basic]
Public Enum ProcessPriorityClass
[C#]
public enum ProcessPriorityClass
[C++]
public enum ProcessPriorityClass

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
AboveNormal | Indicates a process that has priority above Normal but below High.
BelowNormal | Indicates a process that has priority above Idle but below Normal.
High | Specify this class for a process that performs time-critical tasks that must be executed immediately. The threads of the process preempt the threads of normal or idle priority class processes. An example is the Task List, which must respond quickly when called by the user, regardless of the load on the operating system. Use extreme care when using the high-priority class, because a high-priority class application can use nearly all available CPU time.
Idle | Specify this class for a process whose threads run only when the system is idle. The threads of the process are preempted by the threads of any process running in a higher priority class. An example is a screen saver. The idle-priority class is inherited by child processes.
Normal | Specify this class for a process with no special scheduling needs.
RealTime | Specify this class for a process that has the highest possible priority. The threads of the process preempt the threads of all other processes, including operating system processes performing important tasks. For example, a real-time process that executes for more than a very brief interval can cause disk caches not to flush or cause the mouse to be unresponsive.

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

System.Diagnostics Namespace


ProcessStartInfo Class

A set of values used to specify a process to start. This is used in conjunction with the Process component.

Object
Component
ProcessStartInfo

[Visual Basic]
Public Class ProcessStartInfo
   Inherits Component
[C#]
public class ProcessStartInfo : Component
[C++]
public __gc class ProcessStartInfo : public Component
[JScript]
public class ProcessStartInfo extends Component

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

ProcessStartInfo Members | System.Diagnostics Namespace


ProcessStartInfo Members

Public:

Constructor

ProcessStartInfo Constructor Overloaded. [To be supplied.]

Properties

Arguments | Specifies the set of command line arguments to use when starting the application.
ErrorDialog | Sets or returns whether or not an error dialog should be displayed to the user if the process can not be started.
ErrorDialogParentHandle | Sets or returns the window handle to use for the error dialog that is shown when a process can not be started. If ErrorDialog is true, this specifies the parent window for the dialog that is shown. It is useful to specify a parent in order to keep the dialog in front of the application.
FileName | Returns or sets the application, document, or URL that is to be started.
Site (inherited from Component) | Gets or sets the site of the Component.
Verb | Specifies the verb to use when opening the filename. For example, the "print" verb will print a document specified using FileName. Each file extension has it's own set of verbs, which can be obtained using the Verbs property. The default verb can be specified using "".
Verbs | Returns the set of verbs associated with the file specified by the FileName property.
WindowStyle | Sets or returns the style of window that should be used for the newly created process.
WorkingDirectory | Returns or sets the initial directory for the process that is started. Specify "" to if the default is desired.

Methods

Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProcessStartInfo Class | System.Diagnostics Namespace


ProcessStartInfo Constructor

[To be supplied.]

Overload List

Default constructor. At least the FileName property must be set before starting the process.

[Visual Basic] Overloads Public Sub New()
[C#] public ProcessStartInfo();
[C++] public: ProcessStartInfo();
[JScript] public function ProcessStartInfo();

Specifies the name of the application or document that is to be started.

[Visual Basic] Overloads Public Sub New(String)
[C#] public ProcessStartInfo(String);
[C++] public: ProcessStartInfo(String*);
[JScript] public function ProcessStartInfo(String);

Specifies the name of the application that is to be started, as well as a set of command line arguments to pass to the application.

[Visual Basic] Overloads Public Sub New(String, String)
[C#] public ProcessStartInfo(String, String);
[C++] public: ProcessStartInfo(String*, String*);
[JScript] public function ProcessStartInfo(String, String);

See Also

ProcessStartInfo Class | ProcessStartInfo Members | System.Diagnostics Namespace


ProcessStartInfo Constructor ()

Default constructor. At least the FileName property must be set before starting the process.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ProcessStartInfo();
[C++]
public: ProcessStartInfo();
[JScript]
public function ProcessStartInfo();

See Also

ProcessStartInfo Class | ProcessStartInfo Members | System.Diagnostics Namespace | ProcessStartInfo Constructor Overload List


ProcessStartInfo Constructor (String)

Specifies the name of the application or document that is to be started.

[Visual Basic]
Overloads Public Sub New( _
   ByVal fileName As String _
)
[C#]
public ProcessStartInfo(
   string fileName
);
[C++]
public: ProcessStartInfo(
   String* fileName
);
[JScript]
public function ProcessStartInfo(
   fileName : String
);

Parameters

fileName
[To be supplied.]

See Also

ProcessStartInfo Class | ProcessStartInfo Members | System.Diagnostics Namespace | ProcessStartInfo Constructor Overload List


ProcessStartInfo Constructor (String, String)

Specifies the name of the application that is to be started, as well as a set of command line arguments to pass to the application.

[Visual Basic]
Overloads Public Sub New( _
   ByVal fileName As String, _
   ByVal arguments As String _
)
[C#]
public ProcessStartInfo(
   string fileName,
   string arguments
);
[C++]
public: ProcessStartInfo(
   String* fileName,
   String* arguments
);
[JScript]
public function ProcessStartInfo(
   fileName : String,
   arguments : String
);

Parameters

fileName
[To be supplied.]
arguments
[To be supplied.]

See Also

ProcessStartInfo Class | ProcessStartInfo Members | System.Diagnostics Namespace | ProcessStartInfo Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ProcessStartInfo Properties

The properties of the ProcessStartInfo class are listed below. For a complete list of ProcessStartInfo class members, see the ProcessStartInfo Members topic.

Public:

Arguments | Specifies the set of command line arguments to use when starting the application.
ErrorDialog | Sets or returns whether or not an error dialog should be displayed to the user if the process can not be started.
ErrorDialogParentHandle | Sets or returns the window handle to use for the error dialog that is shown when a process can not be started. If ErrorDialog is true, this specifies the parent window for the dialog that is shown. It is useful to specify a parent in order to keep the dialog in front of the application.
FileName | Returns or sets the application, document, or URL that is to be started.
Site (inherited from Component) | Gets or sets the site of the Component.
Verb | Specifies the verb to use when opening the filename. For example, the "print" verb will print a document specified using FileName. Each file extension has it's own set of verbs, which can be obtained using the Verbs property. The default verb can be specified using "".
Verbs | Returns the set of verbs associated with the file specified by the FileName property.
WindowStyle | Sets or returns the style of window that should be used for the newly created process.
WorkingDirectory | Returns or sets the initial directory for the process that is started. Specify "" to if the default is desired.

See Also

ProcessStartInfo Class | System.Diagnostics Namespace


ProcessStartInfo.Arguments

Specifies the set of command line arguments to use when starting the application.

[Visual Basic]
Public Property Arguments As String
[C#]
public string Arguments {get; set;}
[C++]
public: __property String* get_Arguments();
public: __property void set_Arguments(String*);
[JScript]
public function get Arguments() : String;
public function set Arguments(String);

See Also

ProcessStartInfo Class | ProcessStartInfo Members | System.Diagnostics Namespace


ProcessStartInfo.ErrorDialog

Sets or returns whether or not an error dialog should be displayed to the user if the process can not be started.

[Visual Basic]
Public Property ErrorDialog As Boolean
[C#]
public bool ErrorDialog {get; set;}
[C++]
public: __property bool get_ErrorDialog();
public: __property void set_ErrorDialog(bool);
[JScript]
public function get ErrorDialog() : Boolean;
public function set ErrorDialog(Boolean);

See Also

ProcessStartInfo Class | ProcessStartInfo Members | System.Diagnostics Namespace


ProcessStartInfo.ErrorDialogParentHandle

Sets or returns the window handle to use for the error dialog that is shown when a process can not be started. If ErrorDialog is true, this specifies the parent window for the dialog that is shown. It is useful to specify a parent in order to keep the dialog in front of the application.

[Visual Basic]
Public Property ErrorDialogParentHandle As Integer
[C#]
public int ErrorDialogParentHandle {get; set;}
[C++]
public: __property int get_ErrorDialogParentHandle();
public: __property void set_ErrorDialogParentHandle(int);
[JScript]
public function get ErrorDialogParentHandle() : int;
public function set ErrorDialogParentHandle(int);

See Also

ProcessStartInfo Class | ProcessStartInfo Members | System.Diagnostics Namespace


ProcessStartInfo.FileName

Returns or sets the application, document, or URL that is to be started.

[Visual Basic]
Public Property FileName As String
[C#]
public string FileName {get; set;}
[C++]
public: __property String* get_FileName();
public: __property void set_FileName(String*);
[JScript]
public function get FileName() : String;
public function set FileName(String);

See Also

ProcessStartInfo Class | ProcessStartInfo Members | System.Diagnostics Namespace


ProcessStartInfo.Verb

Specifies the verb to use when opening the filename. For example, the "print" verb will print a document specified using FileName. Each file extension has it's own set of verbs, which can be obtained using the Verbs property. The default verb can be specified using "".

[Visual Basic]
Public Property Verb As String
[C#]
public string Verb {get; set;}
[C++]
public: __property String* get_Verb();
public: __property void set_Verb(String*);
[JScript]
public function get Verb() : String;
public function set Verb(String);

See Also

ProcessStartInfo Class | ProcessStartInfo Members | System.Diagnostics Namespace


ProcessStartInfo.Verbs

Returns the set of verbs associated with the file specified by the FileName property.

[Visual Basic]
Public ReadOnly Property Verbs As String ()
[C#]
public string[] Verbs {get;}
[C++]
public: __property String* get_Verbs();
[JScript]
public function get Verbs() : String[];

See Also

ProcessStartInfo Class | ProcessStartInfo Members | System.Diagnostics Namespace | Verb


ProcessStartInfo.WindowStyle

Sets or returns the style of window that should be used for the newly created process.

[Visual Basic]
Public Property WindowStyle As ProcessWindowStyle
[C#]
public ProcessWindowStyle WindowStyle {get; set;}
[C++]
public: __property ProcessWindowStyle get_WindowStyle();
public: __property void set_WindowStyle(ProcessWindowStyle);
[JScript]
public function get WindowStyle() : ProcessWindowStyle;
public function set WindowStyle(ProcessWindowStyle);

See Also

ProcessStartInfo Class | ProcessStartInfo Members | System.Diagnostics Namespace


ProcessStartInfo.WorkingDirectory

Returns or sets the initial directory for the process that is started. Specify "" to if the default is desired.

[Visual Basic]
Public Property WorkingDirectory As String
[C#]
public string WorkingDirectory {get; set;}
[C++]
public: __property String* get_WorkingDirectory();
public: __property void set_WorkingDirectory(String*);
[JScript]
public function get WorkingDirectory() : String;
public function set WorkingDirectory(String);

See Also

ProcessStartInfo Class | ProcessStartInfo Members | System.Diagnostics Namespace


ProcessThread Class

Represents a thread running in a process on a machine. This can be use to obtain information about the thread, such as it's performance characteristics. This is returned from the ProcessThread property.

Object
Component
ProcessThread

[Visual Basic]
Public Class ProcessThread
   Inherits Component
[C#]
public class ProcessThread : Component
[C++]
public __gc class ProcessThread : public Component
[JScript]
public class ProcessThread extends Component

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

ProcessThread Members | System.Diagnostics Namespace


ProcessThread Members

Public:

Properties

BasePriority | Returns the base priority of the thread which is computed by combining the process priority class with the priority level of the associated thread.
CurrentPriority | The current priority indicates the actual priority of the associated thread, which may deviate from the base priority based on how the OS is currently scheduling the thread.
Id | Returns the unique identifier for the associated thread.
IdealProcessor | Sets the process that this thread would ideally like to run on.
PriorityBoostEnabled | Returns or sets whether this thread would like a priority boost if the user interacts with user interface associated with this thread.
PriorityLevel | Returns or sets the priority level of the associated thread. The priority level is not an absolute level, but instead contributes to the actual thread priority by considering the priority class of the process.
PrivilegedProcessorTime | Returns the amount of time the thread has spent running code inside the operating system core.
ProcessorAffinity | Sets which processors the associated thread is allowed to be scheduled to run on. Each processor is represented as a bit: bit 0 is processor one, bit 1 is processor two, etc. For example, the value 1 means run on processor one, 2 means run on processor two, 3 means run on processor one or two.
Site (inherited from Component) | Gets or sets the site of the Component.
StartAddress | Returns the memory address of the function that was called when the associated thread was started.
StartTime | Returns the time the associated thread was started.
ThreadState | Returns the current state of the associated thread, e.g. is it running, waiting, etc.
TotalProcessorTime | Returns the amount of time the associated thread has spent utilizing the CPU. It is the sum of the UserProcessorTime and PrivilegedProcessorTime.
UserProcessorTime | Returns the amount of time the associated thread has spent running code inside the application (not the operating system core).
WaitReason | Returns the reason the associated thread is waiting, if any.

Methods

Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
ResetIdealProcessor | Resets the ideal processor so there is no ideal processor for this thread (e.g. any processor is ideal).
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProcessThread Class | System.Diagnostics Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ProcessThread Properties

The properties of the ProcessThread class are listed below. For a complete list of ProcessThread class members, see the ProcessThread Members topic.

Public:

BasePriority | Returns the base priority of the thread which is computed by combining the process priority class with the priority level of the associated thread.
CurrentPriority | The current priority indicates the actual priority of the associated thread, which may deviate from the base priority based on how the OS is currently scheduling the thread.
Id | Returns the unique identifier for the associated thread.
IdealProcessor | Sets the process that this thread would ideally like to run on.
PriorityBoostEnabled | Returns or sets whether this thread would like a priority boost if the user interacts with user interface associated with this thread.
PriorityLevel | Returns or sets the priority level of the associated thread. The priority level is not an absolute level, but instead contributes to the actual thread priority by considering the priority class of the process.
PrivilegedProcessorTime | Returns the amount of time the thread has spent running code inside the operating system core.
ProcessorAffinity | Sets which processors the associated thread is allowed to be scheduled to run on. Each processor is represented as a bit: bit 0 is processor one, bit 1 is processor two, etc. For example, the value 1 means run on processor one, 2 means run on processor two, 3 means run on processor one or two.
Site (inherited from Component) | Gets or sets the site of the Component.
StartAddress | Returns the memory address of the function that was called when the associated thread was started.
StartTime | Returns the time the associated thread was started.
ThreadState | Returns the current state of the associated thread, e.g. is it running, waiting, etc.
TotalProcessorTime | Returns the amount of time the associated thread has spent utilizing the CPU. It is the sum of the UserProcessorTime and PrivilegedProcessorTime.
UserProcessorTime | Returns the amount of time the associated thread has spent running code inside the application (not the operating system core).
WaitReason | Returns the reason the associated thread is waiting, if any.

See Also

ProcessThread Class | System.Diagnostics Namespace


ProcessThread.BasePriority

Returns the base priority of the thread which is computed by combining the process priority class with the priority level of the associated thread.

[Visual Basic]
Public ReadOnly Property BasePriority As Integer
[C#]
public int BasePriority {get;}
[C++]
public: __property int get_BasePriority();
[JScript]
public function get BasePriority() : int;

See Also

ProcessThread Class | ProcessThread Members | System.Diagnostics Namespace


ProcessThread.CurrentPriority

The current priority indicates the actual priority of the associated thread, which may deviate from the base priority based on how the OS is currently scheduling the thread.

[Visual Basic]
Public ReadOnly Property CurrentPriority As Integer
[C#]
public int CurrentPriority {get;}
[C++]
public: __property int get_CurrentPriority();
[JScript]
public function get CurrentPriority() : int;

See Also

ProcessThread Class | ProcessThread Members | System.Diagnostics Namespace


ProcessThread.Id

Returns the unique identifier for the associated thread.

[Visual Basic]
Public ReadOnly Property Id As Integer
[C#]
public int Id {get;}
[C++]
public: __property int get_Id();
[JScript]
public function get Id() : int;

See Also

ProcessThread Class | ProcessThread Members | System.Diagnostics Namespace


ProcessThread.IdealProcessor

Sets the process that this thread would ideally like to run on.

[Visual Basic]
Property IdealProcessor As Integer
[C#]
int IdealProcessor {set;}
[C++]
public: __property void set_IdealProcessor(int);
[JScript]
public function set IdealProcessor(int);

See Also

ProcessThread Class | ProcessThread Members | System.Diagnostics Namespace | ResetIdealProcessor


ProcessThread.PriorityBoostEnabled

Returns or sets whether this thread would like a priority boost if the user interacts with user interface associated with this thread.

[Visual Basic]
Public Property PriorityBoostEnabled As Boolean
[C#]
public bool PriorityBoostEnabled {get; set;}
[C++]
public: __property bool get_PriorityBoostEnabled();
public: __property void set_PriorityBoostEnabled(bool);
[JScript]
public function get PriorityBoostEnabled() : Boolean;
public function set PriorityBoostEnabled(Boolean);

See Also

ProcessThread Class | ProcessThread Members | System.Diagnostics Namespace


ProcessThread.PriorityLevel

Returns or sets the priority level of the associated thread. The priority level is not an absolute level, but instead contributes to the actual thread priority by considering the priority class of the process.

[Visual Basic]
Public Property PriorityLevel As ThreadPriorityLevel
[C#]
public ThreadPriorityLevel PriorityLevel {get; set;}
[C++]
public: __property ThreadPriorityLevel get_PriorityLevel();
public: __property void set_PriorityLevel(ThreadPriorityLevel);
[JScript]
public function get PriorityLevel() : ThreadPriorityLevel;
public function set PriorityLevel(ThreadPriorityLevel);

See Also

ProcessThread Class | ProcessThread Members | System.Diagnostics Namespace


ProcessThread.PrivilegedProcessorTime

Returns the amount of time the thread has spent running code inside the operating system core.

[Visual Basic]
Public ReadOnly Property PrivilegedProcessorTime As TimeSpan
[C#]
public TimeSpan PrivilegedProcessorTime {get;}
[C++]
public: __property TimeSpan get_PrivilegedProcessorTime();
[JScript]
public function get PrivilegedProcessorTime() : TimeSpan;

See Also

ProcessThread Class | ProcessThread Members | System.Diagnostics Namespace


ProcessThread.ProcessorAffinity

Sets which processors the associated thread is allowed to be scheduled to run on. Each processor is represented as a bit: bit 0 is processor one, bit 1 is processor two, etc. For example, the value 1 means run on processor one, 2 means run on processor two, 3 means run on processor one or two.

[Visual Basic]
Property ProcessorAffinity As Integer
[C#]
int ProcessorAffinity {set;}
[C++]
public: __property void set_ProcessorAffinity(int);
[JScript]
public function set ProcessorAffinity(int);

See Also

ProcessThread Class | ProcessThread Members | System.Diagnostics Namespace


ProcessThread.StartAddress

Returns the memory address of the function that was called when the associated thread was started.

[Visual Basic]
Public ReadOnly Property StartAddress As Integer
[C#]
public int StartAddress {get;}
[C++]
public: __property int get_StartAddress();
[JScript]
public function get StartAddress() : int;

See Also

ProcessThread Class | ProcessThread Members | System.Diagnostics Namespace


ProcessThread.StartTime

Returns the time the associated thread was started.

[Visual Basic]
Public ReadOnly Property StartTime As DateTime
[C#]
public DateTime StartTime {get;}
[C++]
public: __property DateTime get_StartTime();
[JScript]
public function get StartTime() : DateTime;

See Also

ProcessThread Class | ProcessThread Members | System.Diagnostics Namespace


ProcessThread.ThreadState

Returns the current state of the associated thread, e.g. is it running, waiting, etc.

[Visual Basic]
Public ReadOnly Property ThreadState As ThreadState
[C#]
public ThreadState ThreadState {get;}
[C++]
public: __property ThreadState get_ThreadState();
[JScript]
public function get ThreadState() : ThreadState;

See Also

ProcessThread Class | ProcessThread Members | System.Diagnostics Namespace


ProcessThread.TotalProcessorTime

Returns the amount of time the associated thread has spent utilizing the CPU. It is the sum of the UserProcessorTime and PrivilegedProcessorTime.

[Visual Basic]
Public ReadOnly Property TotalProcessorTime As TimeSpan
[C#]
public TimeSpan TotalProcessorTime {get;}
[C++]
public: __property TimeSpan get_TotalProcessorTime();
[JScript]
public function get TotalProcessorTime() : TimeSpan;

See Also

ProcessThread Class | ProcessThread Members | System.Diagnostics Namespace


ProcessThread.UserProcessorTime

Returns the amount of time the associated thread has spent running code inside the application (not the operating system core).

[Visual Basic]
Public ReadOnly Property UserProcessorTime As TimeSpan
[C#]
public TimeSpan UserProcessorTime {get;}
[C++]
public: __property TimeSpan get_UserProcessorTime();
[JScript]
public function get UserProcessorTime() : TimeSpan;

See Also

ProcessThread Class | ProcessThread Members | System.Diagnostics Namespace


ProcessThread.WaitReason

Returns the reason the associated thread is waiting, if any.

[Visual Basic]
Public ReadOnly Property WaitReason As ThreadWaitReason
[C#]
public ThreadWaitReason WaitReason {get;}
[C++]
public: __property ThreadWaitReason get_WaitReason();
[JScript]
public function get WaitReason() : ThreadWaitReason;

See Also

ProcessThread Class | ProcessThread Members | System.Diagnostics Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ProcessThread Methods

The methods of the ProcessThread class are listed below. For a complete list of ProcessThread class members, see the ProcessThread Members topic.

Public:

Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
ResetIdealProcessor | Resets the ideal processor so there is no ideal processor for this thread (e.g. any processor is ideal).
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProcessThread Class | System.Diagnostics Namespace


ProcessThread.ResetIdealProcessor

Resets the ideal processor so there is no ideal processor for this thread (e.g. any processor is ideal).

[Visual Basic]
Public Sub ResetIdealProcessor()
[C#]
public void ResetIdealProcessor();
[C++]
public: void ResetIdealProcessor();
[JScript]
public function ResetIdealProcessor();

See Also

ProcessThread Class | ProcessThread Members | System.Diagnostics Namespace | IdealProcessor


ProcessWindowStyle Enumeration

A set of values indicating how the window should appear when starting a process.

[Visual Basic]
Public Enum ProcessWindowStyle
[C#]
public enum ProcessWindowStyle
[C++]
public enum ProcessWindowStyle

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Maximized | Show the window maximized.
Minimized | Show the window minimized.
Normal | Show the window in a default location.

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

System.Diagnostics Namespace


SerializableRegistryKey Class

[To be supplied.]

Object
SerializableRegistryKey

[Visual Basic]
Public Class SerializableRegistryKey
[C#]
public class SerializableRegistryKey
[C++]
public __gc class SerializableRegistryKey
[JScript]
public class SerializableRegistryKey

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

SerializableRegistryKey Members | System.Diagnostics Namespace


SerializableRegistryKey Members

Public:

Constructor

SerializableRegistryKey Constructor Overloaded. [To be supplied.]

Methods

CopyFromRegistry | [To be supplied.]
CopyToRegistry | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

KeyNames | [To be supplied.]
Keys | [To be supplied.]
ValueNames | [To be supplied.]
Values | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SerializableRegistryKey Class | System.Diagnostics Namespace


SerializableRegistryKey Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public SerializableRegistryKey();
[C++] public: SerializableRegistryKey();
[JScript] public function SerializableRegistryKey();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(RegistryKey)
[C#] public SerializableRegistryKey(RegistryKey);
[C++] public: SerializableRegistryKey(RegistryKey*);
[JScript] public function SerializableRegistryKey(RegistryKey);

See Also

SerializableRegistryKey Class | SerializableRegistryKey Members | System.Diagnostics Namespace


SerializableRegistryKey Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public SerializableRegistryKey();
[C++]
public: SerializableRegistryKey();
[JScript]
public function SerializableRegistryKey();

See Also

SerializableRegistryKey Class | SerializableRegistryKey Members | System.Diagnostics Namespace | SerializableRegistryKey Constructor Overload List


SerializableRegistryKey Constructor (RegistryKey)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal keyToSave As RegistryKey _
)
[C#]
public SerializableRegistryKey(
   RegistryKey keyToSave
);
[C++]
public: SerializableRegistryKey(
   RegistryKey* keyToSave
);
[JScript]
public function SerializableRegistryKey(
   keyToSave : RegistryKey
);

Parameters

keyToSave
[To be supplied.]

See Also

SerializableRegistryKey Class | SerializableRegistryKey Members | System.Diagnostics Namespace | SerializableRegistryKey Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SerializableRegistryKey Methods

The methods of the SerializableRegistryKey class are listed below. For a complete list of SerializableRegistryKey class members, see the SerializableRegistryKey Members topic.

Public:

CopyFromRegistry | [To be supplied.]
CopyToRegistry | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SerializableRegistryKey Class | System.Diagnostics Namespace


SerializableRegistryKey.CopyFromRegistry

[To be supplied.]

[Visual Basic]
Public Sub CopyFromRegistry( _
   ByVal keyToSave As RegistryKey _
)
[C#]
public void CopyFromRegistry(
   RegistryKey keyToSave
);
[C++]
public: void CopyFromRegistry(
   RegistryKey* keyToSave
);
[JScript]
public function CopyFromRegistry(
   keyToSave : RegistryKey
);

Parameters

keyToSave
[To be supplied.]

See Also

SerializableRegistryKey Class | SerializableRegistryKey Members | System.Diagnostics Namespace


SerializableRegistryKey.CopyToRegistry

[To be supplied.]

[Visual Basic]
Public Sub CopyToRegistry( _
   ByVal baseKey As RegistryKey _
)
[C#]
public void CopyToRegistry(
   RegistryKey baseKey
);
[C++]
public: void CopyToRegistry(
   RegistryKey* baseKey
);
[JScript]
public function CopyToRegistry(
   baseKey : RegistryKey
);

Parameters

baseKey
[To be supplied.]

See Also

SerializableRegistryKey Class | SerializableRegistryKey Members | System.Diagnostics Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SerializableRegistryKey Fields

The fields of the SerializableRegistryKey class are listed below. For a complete list of SerializableRegistryKey class members, see the SerializableRegistryKey Members topic.

Public:

KeyNames | [To be supplied.]
Keys | [To be supplied.]
ValueNames | [To be supplied.]
Values | [To be supplied.]

See Also

SerializableRegistryKey Class | System.Diagnostics Namespace


SerializableRegistryKey.KeyNames

[To be supplied.]

[Visual Basic]
Public KeyNames() As String
[C#]
public string[] KeyNames;
[C++]
public: String* KeyNames[];
[JScript]
public var KeyNames : String[];

See Also

SerializableRegistryKey Class | SerializableRegistryKey Members | System.Diagnostics Namespace


SerializableRegistryKey.Keys

[To be supplied.]

[Visual Basic]
Public Keys() As SerializableRegistryKey
[C#]
public SerializableRegistryKey[] Keys;
[C++]
public: SerializableRegistryKey* Keys[];
[JScript]
public var Keys : SerializableRegistryKey[];

See Also

SerializableRegistryKey Class | SerializableRegistryKey Members | System.Diagnostics Namespace


SerializableRegistryKey.ValueNames

[To be supplied.]

[Visual Basic]
Public ValueNames() As String
[C#]
public string[] ValueNames;
[C++]
public: String* ValueNames[];
[JScript]
public var ValueNames : String[];

See Also

SerializableRegistryKey Class | SerializableRegistryKey Members | System.Diagnostics Namespace


SerializableRegistryKey.Values

[To be supplied.]

[Visual Basic]
Public Values() As Object
[C#]
public object[] Values;
[C++]
public: Object* Values[];
[JScript]
public var Values : Object[];

See Also

SerializableRegistryKey Class | SerializableRegistryKey Members | System.Diagnostics Namespace


StackFrame Class

[To be supplied.]

Object
StackFrame

[Visual Basic]
Public Class StackFrame
[C#]
public class StackFrame
[C++]
public __gc class StackFrame
[JScript]
public class StackFrame

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: mscorlib.dll

See Also

StackFrame Members | System.Diagnostics Namespace


StackFrame Members

Public:

Constructor

StackFrame Constructor Overloaded. Initializes a new StackFrame object corresponding to the active stack frame.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetFileColumnNumber | [To be supplied.]
GetFileLineNumber | Gets the line number in the file containing the code being executed. This information is normally extracted from the debugging symbols for the executable.
GetFileName | Gets the file name containing the code being executed. This information is normally extracted from the debugging symbols for the executable.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetILOffset | Gets the offset from the start of the IL code for the method being executed. This offset may be approximate depending on whether the JIT compiler is generating debugging code or not.
GetMethod | Gets the method in which the frame is executing.
GetNativeOffset | Gets the offset from the start of the native (JIT-compiled) code for the method being executed.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Builds a readable representation of the stack trace.

Fields

OFFSET_UNKNOWN Constant returned when the native or IL offset is unknown.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StackFrame Class | System.Diagnostics Namespace


StackFrame Constructor

Initializes a new StackFrame object corresponding to the active stack frame.

Overload List

Initializes a new StackFrame object corresponding to the active stack frame.

[Visual Basic] Overloads Public Sub New()
[C#] public StackFrame();
[C++] public: StackFrame();
[JScript] public function StackFrame();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Boolean)
[C#] public StackFrame(bool);
[C++] public: StackFrame(bool);
[JScript] public function StackFrame(Boolean);

Initializes a new StackFrame object corresponding to the active stack frame.

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public StackFrame(int);
[C++] public: StackFrame(int);
[JScript] public function StackFrame(int);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer, Boolean)
[C#] public StackFrame(int, bool);
[C++] public: StackFrame(int, bool);
[JScript] public function StackFrame(int, Boolean);

Constructs a "fake" stack frame that just contains the given file name and line number. Use this constructor when you don't want to use the debugger's line mapping logic.

[Visual Basic] Overloads Public Sub New(String, Integer)
[C#] public StackFrame(String, int);
[C++] public: StackFrame(String*, int);
[JScript] public function StackFrame(String, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Integer, Integer)
[C#] public StackFrame(String, int, int);
[C++] public: StackFrame(String*, int, int);
[JScript] public function StackFrame(String, int, int);

See Also

StackFrame Class | StackFrame Members | System.Diagnostics Namespace


StackFrame Constructor ()

Initializes a new StackFrame object corresponding to the active stack frame.

[Visual Basic]
Overloads Public Sub New()
[C#]
public StackFrame();
[C++]
public: StackFrame();
[JScript]
public function StackFrame();

See Also

StackFrame Class | StackFrame Members | System.Diagnostics Namespace | StackFrame Constructor Overload List


StackFrame Constructor (Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal fNeedFileInfo As Boolean _
)
[C#]
public StackFrame(
   bool fNeedFileInfo
);
[C++]
public: StackFrame(
   bool fNeedFileInfo
);
[JScript]
public function StackFrame(
   fNeedFileInfo : Boolean
);

Parameters

fNeedFileInfo
[To be supplied.]

See Also

StackFrame Class | StackFrame Members | System.Diagnostics Namespace | StackFrame Constructor Overload List


StackFrame Constructor (Int32)

Initializes a new StackFrame object corresponding to the active stack frame.

[Visual Basic]
Overloads Public Sub New( _
   ByVal skipFrames As Integer _
)
[C#]
public StackFrame(
   int skipFrames
);
[C++]
public: StackFrame(
   int skipFrames
);
[JScript]
public function StackFrame(
   skipFrames : int
);

Parameters

skipFrames
The number of frames up the stack to skip.

See Also

StackFrame Class | StackFrame Members | System.Diagnostics Namespace | StackFrame Constructor Overload List


StackFrame Constructor (Int32, Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal skipFrames As Integer, _
   ByVal fNeedFileInfo As Boolean _
)
[C#]
public StackFrame(
   int skipFrames,
   bool fNeedFileInfo
);
[C++]
public: StackFrame(
   int skipFrames,
   bool fNeedFileInfo
);
[JScript]
public function StackFrame(
   skipFrames : int,
   fNeedFileInfo : Boolean
);

Parameters

skipFrames
[To be supplied.]
fNeedFileInfo
[To be supplied.]

See Also

StackFrame Class | StackFrame Members | System.Diagnostics Namespace | StackFrame Constructor Overload List


StackFrame Constructor (String, Int32)

Constructs a "fake" stack frame that just contains the given file name and line number. Use this constructor when you don't want to use the debugger's line mapping logic.

[Visual Basic]
Overloads Public Sub New( _
   ByVal fileName As String, _
   ByVal lineNumber As Integer _
)
[C#]
public StackFrame(
   string fileName,
   int lineNumber
);
[C++]
public: StackFrame(
   String* fileName,
   int lineNumber
);
[JScript]
public function StackFrame(
   fileName : String,
   lineNumber : int
);

Parameters

fileName
The given file name.
lineNumber
The line number in the specified file.

See Also

StackFrame Class | StackFrame Members | System.Diagnostics Namespace | StackFrame Constructor Overload List


StackFrame Constructor (String, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal fileName As String, _
   ByVal lineNumber As Integer, _
   ByVal colNumber As Integer _
)
[C#]
public StackFrame(
   string fileName,
   int lineNumber,
   int colNumber
);
[C++]
public: StackFrame(
   String* fileName,
   int lineNumber,
   int colNumber
);
[JScript]
public function StackFrame(
   fileName : String,
   lineNumber : int,
   colNumber : int
);

Parameters

fileName
[To be supplied.]
lineNumber
[To be supplied.]
colNumber
[To be supplied.]

See Also

StackFrame Class | StackFrame Members | System.Diagnostics Namespace | StackFrame Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StackFrame Methods

The methods of the StackFrame class are listed below. For a complete list of StackFrame class members, see the StackFrame Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetFileColumnNumber | [To be supplied.]
GetFileLineNumber | Gets the line number in the file containing the code being executed. This information is normally extracted from the debugging symbols for the executable.
GetFileName | Gets the file name containing the code being executed. This information is normally extracted from the debugging symbols for the executable.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetILOffset | Gets the offset from the start of the IL code for the method being executed. This offset may be approximate depending on whether the JIT compiler is generating debugging code or not.
GetMethod | Gets the method in which the frame is executing.
GetNativeOffset | Gets the offset from the start of the native (JIT-compiled) code for the method being executed.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Builds a readable representation of the stack trace.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StackFrame Class | System.Diagnostics Namespace


StackFrame.GetFileColumnNumber

[To be supplied.]

[Visual Basic]
Overridable Public Function GetFileColumnNumber() As Integer
[C#]
public virtual int GetFileColumnNumber();
[C++]
public: virtual int GetFileColumnNumber();
[JScript]
public function GetFileColumnNumber() : int;

See Also

StackFrame Class | StackFrame Members | System.Diagnostics Namespace


StackFrame.GetFileLineNumber

Gets the line number in the file containing the code being executed. This information is normally extracted from the debugging symbols for the executable.

[Visual Basic]
Overridable Public Function GetFileLineNumber() As Integer
[C#]
public virtual int GetFileLineNumber();
[C++]
public: virtual int GetFileLineNumber();
[JScript]
public function GetFileLineNumber() : int;

Return Value

The file line number or zero if it cannot be determined.

Remarks

This method is not yet implemented.

See Also

StackFrame Class | StackFrame Members | System.Diagnostics Namespace


StackFrame.GetFileName

Gets the file name containing the code being executed. This information is normally extracted from the debugging symbols for the executable.

[Visual Basic]
Overridable Public Function GetFileName() As String
[C#]
public virtual string GetFileName();
[C++]
public: virtual String* GetFileName();
[JScript]
public function GetFileName() : String;

Return Value

The file name or null if it cannot be determined.

Remarks

This method is not yet implemented.

See Also

StackFrame Class | StackFrame Members | System.Diagnostics Namespace


StackFrame.GetILOffset

Gets the offset from the start of the IL code for the method being executed. This offset may be approximate depending on whether the JIT compiler is generating debugging code or not.

[Visual Basic]
Overridable Public Function GetILOffset() As Integer
[C#]
public virtual int GetILOffset();
[C++]
public: virtual int GetILOffset();
[JScript]
public function GetILOffset() : int;

Return Value

The offset from the start of the IL code for the method being executed.

See Also

StackFrame Class | StackFrame Members | System.Diagnostics Namespace


StackFrame.GetMethod

Gets the method in which the frame is executing.

[Visual Basic]
Overridable Public Function GetMethod() As MethodBase
[C#]
public virtual MethodBase GetMethod();
[C++]
public: virtual MethodBase* GetMethod();
[JScript]
public function GetMethod() : MethodBase;

Return Value

The method the frame is executing in.

See Also

StackFrame Class | StackFrame Members | System.Diagnostics Namespace


StackFrame.GetNativeOffset

Gets the offset from the start of the native (JIT-compiled) code for the method being executed.

[Visual Basic]
Overridable Public Function GetNativeOffset() As Integer
[C#]
public virtual int GetNativeOffset();
[C++]
public: virtual int GetNativeOffset();
[JScript]
public function GetNativeOffset() : int;

Return Value

The offset from the start of the native (JIT-compiled) code for the method being executed.

See Also

StackFrame Class | StackFrame Members | System.Diagnostics Namespace


StackFrame.ToString

Builds a readable representation of the stack trace.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

Returns a readable representation.

See Also

StackFrame Class | StackFrame Members | System.Diagnostics Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StackFrame Fields

The fields of the StackFrame class are listed below. For a complete list of StackFrame class members, see the StackFrame Members topic.

Public:

OFFSET_UNKNOWN Constant returned when the native or IL offset is unknown.

See Also

StackFrame Class | System.Diagnostics Namespace


StackFrame.OFFSET_UNKNOWN

Constant returned when the native or IL offset is unknown.

[Visual Basic]
Public Const OFFSET_UNKNOWN As Integer
[C#]
public const int OFFSET_UNKNOWN;
[C++]
public: const int OFFSET_UNKNOWN;
[JScript]
public var OFFSET_UNKNOWN : int;

See Also

StackFrame Class | StackFrame Members | System.Diagnostics Namespace


StackTrace Class

[To be supplied.]

Object
StackTrace

[Visual Basic]
Public Class StackTrace
[C#]
public class StackTrace
[C++]
public __gc class StackTrace
[JScript]
public class StackTrace

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: mscorlib.dll

See Also

StackTrace Members | System.Diagnostics Namespace


StackTrace Members

Public:

Constructor

StackTrace Constructor Overloaded. Initializes a new instance of the StackTrace class.

Properties

FrameCount Holds the number of frames in the stack trace.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetFrame | Gets the specified stack frame.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Builds a readable representation of the stack trace.

Fields

METHODS_TO_SKIP Uses a constant to define the number of methods that are to be omitted from the stack trace.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StackTrace Class | System.Diagnostics Namespace


StackTrace Constructor

Initializes a new instance of the StackTrace class.

Overload List

Initializes a new instance of the StackTrace class.

[Visual Basic] Overloads Public Sub New()
[C#] public StackTrace();
[C++] public: StackTrace();
[JScript] public function StackTrace();

Initializes a new instance of the StackTrace class.

[Visual Basic] Overloads Public Sub New(Boolean)
[C#] public StackTrace(bool);
[C++] public: StackTrace(bool);
[JScript] public function StackTrace(Boolean);

Initializes a new instance of the StackTrace class from the current location, in a caller's frame.

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public StackTrace(int);
[C++] public: StackTrace(int);
[JScript] public function StackTrace(int);

Initializes a new instance of the StackTrace class from the current location, in a caller's frame.

[Visual Basic] Overloads Public Sub New(Integer, Boolean)
[C#] public StackTrace(int, bool);
[C++] public: StackTrace(int, bool);
[JScript] public function StackTrace(int, Boolean);

Initializes a new instance of the StackTrace class containing a single frame.

[Visual Basic] Overloads Public Sub New(StackFrame)
[C#] public StackTrace(StackFrame);
[C++] public: StackTrace(StackFrame*);
[JScript] public function StackTrace(StackFrame);

Initializes a new instance of the StackTrace class.

[Visual Basic] Overloads Public Sub New(Thread, Boolean)
[C#] public StackTrace(Thread, bool);
[C++] public: StackTrace(Thread*, bool);
[JScript] public function StackTrace(Thread, Boolean);

See Also

StackTrace Class | StackTrace Members | System.Diagnostics Namespace


StackTrace Constructor ()

Initializes a new instance of the StackTrace class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public StackTrace();
[C++]
public: StackTrace();
[JScript]
public function StackTrace();

See Also

StackTrace Class | StackTrace Members | System.Diagnostics Namespace | StackTrace Constructor Overload List


StackTrace Constructor (Boolean)

Initializes a new instance of the StackTrace class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal fNeedFileInfo As Boolean _
)
[C#]
public StackTrace(
   bool fNeedFileInfo
);
[C++]
public: StackTrace(
   bool fNeedFileInfo
);
[JScript]
public function StackTrace(
   fNeedFileInfo : Boolean
);

Parameters

fNeedFileInfo
[To be supplied.]

See Also

StackTrace Class | StackTrace Members | System.Diagnostics Namespace | StackTrace Constructor Overload List


StackTrace Constructor (Int32)

Initializes a new instance of the StackTrace class from the current location, in a caller's frame.

[Visual Basic]
Overloads Public Sub New( _
   ByVal skipFrames As Integer _
)
[C#]
public StackTrace(
   int skipFrames
);
[C++]
public: StackTrace(
   int skipFrames
);
[JScript]
public function StackTrace(
   skipFrames : int
);

Parameters

skipFrames
The number of frames up the stack to start the trace from.

See Also

StackTrace Class | StackTrace Members | System.Diagnostics Namespace | StackTrace Constructor Overload List


StackTrace Constructor (Int32, Boolean)

Initializes a new instance of the StackTrace class from the current location, in a caller's frame.

[Visual Basic]
Overloads Public Sub New( _
   ByVal skipFrames As Integer, _
   ByVal fNeedFileInfo As Boolean _
)
[C#]
public StackTrace(
   int skipFrames,
   bool fNeedFileInfo
);
[C++]
public: StackTrace(
   int skipFrames,
   bool fNeedFileInfo
);
[JScript]
public function StackTrace(
   skipFrames : int,
   fNeedFileInfo : Boolean
);

Parameters

skipFrames
The number of frames up the stack to start the trace from.
fNeedFileInfo
[To be supplied.]

See Also

StackTrace Class | StackTrace Members | System.Diagnostics Namespace | StackTrace Constructor Overload List


StackTrace Constructor (StackFrame)

Initializes a new instance of the StackTrace class containing a single frame.

[Visual Basic]
Overloads Public Sub New( _
   ByVal frame As StackFrame _
)
[C#]
public StackTrace(
   StackFrame frame
);
[C++]
public: StackTrace(
   StackFrame* frame
);
[JScript]
public function StackTrace(
   frame : StackFrame
);

Parameters

frame
The frame that the StackTrace object should contain.

Remarks

Use this constructor when you do not want the overhead of a full stack trace.

See Also

StackTrace Class | StackTrace Members | System.Diagnostics Namespace | StackTrace Constructor Overload List


StackTrace Constructor (Thread, Boolean)

Initializes a new instance of the StackTrace class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal targetThread As Thread, _
   ByVal needFileInfo As Boolean _
)
[C#]
public StackTrace(
   Thread targetThread,
   bool needFileInfo
);
[C++]
public: StackTrace(
   Thread* targetThread,
   bool needFileInfo
);
[JScript]
public function StackTrace(
   targetThread : Thread,
   needFileInfo : Boolean
);

Parameters

targetThread
[To be supplied.]
needFileInfo
[To be supplied.]

See Also

StackTrace Class | StackTrace Members | System.Diagnostics Namespace | StackTrace Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StackTrace Properties

The properties of the StackTrace class are listed below. For a complete list of StackTrace class members, see the StackTrace Members topic.

Public:

FrameCount Holds the number of frames in the stack trace.

See Also

StackTrace Class | System.Diagnostics Namespace


StackTrace.FrameCount

Holds the number of frames in the stack trace.

[Visual Basic]
Overridable Public ReadOnly Property FrameCount As Integer
[C#]
public int FrameCount {virtual get;}
[C++]
public: __property virtual int get_FrameCount();
[JScript]
public function get FrameCount() : int;

See Also

StackTrace Class | StackTrace Members | System.Diagnostics Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StackTrace Methods

The methods of the StackTrace class are listed below. For a complete list of StackTrace class members, see the StackTrace Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetFrame | Gets the specified stack frame.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Builds a readable representation of the stack trace.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StackTrace Class | System.Diagnostics Namespace


StackTrace.GetFrame

Gets the specified stack frame.

[Visual Basic]
Overridable Public Function GetFrame( _
   ByVal index As Integer _
) As StackFrame
[C#]
public virtual StackFrame GetFrame(
   int index
);
[C++]
public: virtual StackFrame* GetFrame(
   int index
);
[JScript]
public function GetFrame(
   index : int
) : StackFrame;

Parameters

index
The index of the stack frame requested.

Return Value

The specified stack frame.

Remarks

Stack frames are numbered starting at 0, which is the last stack frame pushed.

See Also

StackTrace Class | StackTrace Members | System.Diagnostics Namespace


StackTrace.ToString

Builds a readable representation of the stack trace.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

A readable representation of the stack trace.

See Also

StackTrace Class | StackTrace Members | System.Diagnostics Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StackTrace Fields

The fields of the StackTrace class are listed below. For a complete list of StackTrace class members, see the StackTrace Members topic.

Public:

METHODS_TO_SKIP Uses a constant to define the number of methods that are to be omitted from the stack trace.

See Also

StackTrace Class | System.Diagnostics Namespace


StackTrace.METHODS_TO_SKIP

Uses a constant to define the number of methods that are to be omitted from the stack trace.

[Visual Basic]
Public Const METHODS_TO_SKIP As Integer
[C#]
public const int METHODS_TO_SKIP;
[C++]
public: const int METHODS_TO_SKIP;
[JScript]
public var METHODS_TO_SKIP : int;

Remarks

That many methods are skipped at the beginning of the stack trace.

See Also

StackTrace Class | StackTrace Members | System.Diagnostics Namespace


Switch Class

Provides an abstract (in Visual Basic MustInherit) base class to create new debugging and tracing switches.

Object
Switch

[Visual Basic]
MustInherit Public Class Switch
[C#]
public abstract class Switch
[C++]
public __gc __abstract class Switch
[JScript]
public abstract class Switch

Remarks

A switch provides an efficient mechanism for enabling or disabling tracing and debug output at run time using external settings. The Switch class implements default behavior for switches, such as switch management mechanisms that allow you to automatically change the switch level at run time, cataloging, and integration with registry and environmental variables.

This class is the base class for BooleanSwitch and TraceSwitch. These two switches should meet most of your debugging and tracing needs.

Notes to Inheritors: If you need different trace levels, or different mechanisms for setting switch levels than those provided by BooleanSwitch and TraceSwitch, you can inherit from Switch. When inheriting from this class, you must override the SetSwitchSetting method.

For more information, see <DebugTopicTBD>.

Requirements

Namespace: System.Diagnostics

Assembly: System.dll

Example [Visual Basic]

The following example shows how to define a new switch class with four levels of tracing that can be used to trace a call stack. You can use the switch to instrument your application to log each method entry, exit, or both entry and exit.

[Visual Basic]

Enum MethodTracingSwitchLevel
   Off = 1
   EnteringMethod = 2
   ExitingMethod = 3
   Both = 4
End Enum

Class MethodTracingSwitch
   Inherits SwitchBase
   Private outExit As Boolean
   Private outEnter As Boolean

   Public New(displayName As String, description As String)
   MyBase.New(displayName, description)
   End Sub

   Public Property Let Level As MethodTracingSwitchLevel
      SetSwitchSettings value
   End Property

   Protected Override Sub SetSwitchSetting(value As Integer)
      outExit = False
      outEnter = False
      If value = EnteringMethod Or value = Both
         outEnter = True
      Endif
      If value = ExitingMethod Or value = Both
         outExit = True
      Endif
   End Sub

   Public Property Get OutputExit
      OutputExit = outExit
   End Property

   Public Property Get OutputEnter
      OutputEnter = outEnter
   End Property

End Class

The following example implements the new switch in MyMethod. It outputs debugging messages when entering and leaving the method.

[Visual Basic]

Dim methodTracer As New MethodTracingSwitch( _
   ?methods?,?tracing entering entering and exiting?)

Public Sub MyMethod(param As Integer) As Boolean
   Debug.WriteLineIf methodTracer.OutputEntering, _
      ?Entering MyMethod(? & param & ?)?
   ?
   MyMethod = result
   ?
   Debug.WriteLineIf methodTracer.OutputExiting, _
      ?Exiting MyMethod = ? & result
End Sub

See Also

Switch Members | System.Diagnostics Namespace | BooleanSwitch | TraceSwitch | Debug | Trace


Switch Members

Public:

Properties

Description | Gets a description of the switch.
DisplayName | Gets a name used to identify the switch. This name can be displayed on a user interface.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SetSwitchSetting | Overloaded. Sets a switch to the level specified in value.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Constructor

Switch Constructor Initializes a new instance of the Switch class.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetSwitchSetting | Overloaded. Sets a switch to the level specified in value.

See Also

Switch Class | System.Diagnostics Namespace


Switch Constructor

Initializes a new instance of the Switch class.

[Visual Basic]
Protected Sub New( _
   ByVal displayName As String, _
   ByVal description As String _
)
[C#]
protected Switch(
   string displayName,
   string description
);
[C++]
protected: Switch(
   String* displayName,
   String* description
);
[JScript]
protected function Switch(
   displayName : String,
   description : String
);

Parameters

displayName
A name of the switch to display in a user interface.
description
A description for the switch.

Remarks

When a Switch object is instantiated, the displayName is used to find initial switch settings in the registry, environmental variables. The default value is the empty string ("").

See Also

Switch Class | Switch Members | System.Diagnostics Namespace | Switch | BooleanSwitch | TraceSwitch | Debug | Trace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Switch Properties

The properties of the Switch class are listed below. For a complete list of Switch class members, see the Switch Members topic.

Public:

Description | Gets a description of the switch.
DisplayName | Gets a name used to identify the switch. This name can be displayed on a user interface.

See Also

Switch Class | System.Diagnostics Namespace


Switch.Description

Gets a description of the switch.

[Visual Basic]
Public ReadOnly Property Description As String
[C#]
public string Description {get;}
[C++]
public: __property String* get_Description();
[JScript]
public function get Description() : String;

Property Value

A description of the switch.

Remarks

This description should depict the function of the switch. For example, you could describe the switch as "Enables tracing for the CompModSwitches.DirectoryWatcher component." The default value is the empty string ("").

See Also

Switch Class | Switch Members | System.Diagnostics Namespace | Switch | BooleanSwitch | TraceSwitch | Debug | Trace


Switch.DisplayName

Gets a name used to identify the switch. This name can be displayed on a user interface.

[Visual Basic]
Public ReadOnly Property DisplayName As String
[C#]
public string DisplayName {get;}
[C++]
public: __property String* get_DisplayName();
[JScript]
public function get DisplayName() : String;

Property Value

A name used to identify the switch.

Remarks

When a Switch object is instantiated, the DisplayName is used to find initial switch settings in the registry, or in environmental variables. The default value is the empty string ("").

See Also

Switch Class | Switch Members | System.Diagnostics Namespace | Switch | BooleanSwitch | TraceSwitch | Debug | Trace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Switch Methods

The methods of the Switch class are listed below. For a complete list of Switch class members, see the Switch Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SetSwitchSetting | Overloaded. Sets a switch to the level specified in value.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetSwitchSetting | Overloaded. Sets a switch to the level specified in value.

See Also

Switch Class | System.Diagnostics Namespace


Switch.SetSwitchSetting

Sets a switch to the level specified in value.

Overload List

Sets the displayName switch to the level specified in value.

[Visual Basic] Overloads Public Shared Sub SetSwitchSetting(String, Integer)
[C#] public static void SetSwitchSetting(String, int);
[C++] public: static void SetSwitchSetting(String*, int);
[JScript] public static function SetSwitchSetting(String, int);

When overridden in a derived class, sets a switch to the level specified in value.

[Visual Basic] Overloads MustOverride Protected Sub SetSwitchSetting(Integer)
[C#] protected abstract void SetSwitchSetting(int);
[C++] protected: virtual void SetSwitchSetting(int) = 0;
[JScript] protected abstract function SetSwitchSetting(int);

See Also

Switch Class | Switch Members | System.Diagnostics Namespace


Switch.SetSwitchSetting (String, Int32)

Sets the displayName switch to the level specified in value.

[Visual Basic]
Overloads Public Shared Sub SetSwitchSetting( _
   ByVal displayName As String, _
   ByVal value As Integer _
)
[C#]
public static void SetSwitchSetting(
   string displayName,
   int value
);
[C++]
public: static void SetSwitchSetting(
   String* displayName,
   int value
);
[JScript]
public static function SetSwitchSetting(
   displayName : String,
   value : int
);

Parameters

displayName
The name of the switch.
value
The new level to set the switch.

Remarks

Typically, this method is called during initialization.

See Also

Switch Class | Switch Members | System.Diagnostics Namespace | Switch.SetSwitchSetting Overload List | Switch | BooleanSwitch | TraceSwitch | Debug | Trace


Switch.SetSwitchSetting (Int32)

When overridden in a derived class, sets a switch to the level specified in value.

[Visual Basic]
Overloads MustOverride Protected Sub SetSwitchSetting( _
   ByVal value As Integer _
)
[C#]
protected abstract void SetSwitchSetting(
   int value
);
[C++]
protected: virtual void SetSwitchSetting(
   int value
) = 0;
[JScript]
protected abstract function SetSwitchSetting(
   value : int
);

Parameters

value
The new level to set the switch.

Remarks

Typically, this method is called during initialization.

See Also

Switch Class | Switch Members | System.Diagnostics Namespace | Switch.SetSwitchSetting Overload List | Switch | BooleanSwitch | TraceSwitch | Debug | Trace


TextWriterTraceListener Class

Directs tracing or debugging output to a TextWriter or to a Stream, such as Console.Out or FileStream.

Object
TraceListener
TextWriterTraceListener

[Visual Basic]
Public Class TextWriterTraceListener
   Inherits TraceListener
[C#]
public class TextWriterTraceListener : TraceListener
[C++]
public __gc class TextWriterTraceListener : public TraceListener
[JScript]
public class TextWriterTraceListener extends TraceListener

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics

Assembly: System.dll

See Also

TextWriterTraceListener Members | System.Diagnostics Namespace | TraceListener | DefaultTraceListener | Stream | TextWriter | Debug | Trace


TextWriterTraceListener Members

Public:

Constructor

TextWriterTraceListener Constructor Overloaded. Initializes a new instance of the TextWriterTraceListener class.

Properties

Indent (inherited from TraceListener) | Gets or sets the indent level.
IndentSize (inherited from TraceListener) | Gets or sets the number of spaces in an indent.
Name (inherited from TraceListener) | Gets or sets a name for this TraceListener.
Writer | Gets or sets the text writer that receives the tracing or debugging output.

Methods

Close | Closes the Writer so that it no longer receives tracing or debugging output.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Fail (inherited from TraceListener) | Overloaded. Emits or displays a message for an assertion that always fails.
Flush | Flushes the output buffer for the Writer.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write (inherited from TraceListener) | Overloaded. Writes a message, category name, or object name.
WriteLine (inherited from TraceListener) | Overloaded. Writes a message, category name, or object name followed by a line terminator.

Protected:

Properties

NeedIndent (inherited from TraceListener) Gets or sets whether an indent is needed.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
WriteIndent (inherited from TraceListener) | Writes the indent and resets the NeedIndent property to false.

See Also

TextWriterTraceListener Class | System.Diagnostics Namespace


TextWriterTraceListener Constructor

Initializes a new instance of the TextWriterTraceListener class.

Overload List

Initializes a new instance of the TextWriterTraceListener class.

[Visual Basic] Overloads Public Sub New()
[C#] public TextWriterTraceListener();
[C++] public: TextWriterTraceListener();
[JScript] public function TextWriterTraceListener();

Initializes a new instance of the TextWriterTraceListener class using the stream parameter as the recipient of the debugging and tracing output.

[Visual Basic] Overloads Public Sub New(Stream)
[C#] public TextWriterTraceListener(Stream);
[C++] public: TextWriterTraceListener(Stream*);
[JScript] public function TextWriterTraceListener(Stream);

Initializes a new instance of the TextWriterTraceListener class with the specified Name and using the stream parameter as the recipient of the debugging and tracing output.

[Visual Basic] Overloads Public Sub New(Stream, String)
[C#] public TextWriterTraceListener(Stream, String);
[C++] public: TextWriterTraceListener(Stream*, String);
[JScript] public function TextWriterTraceListener(Stream, String);

Initializes a new instance of the TextWriterTraceListener class using the specified writer as recipient of the tracing or debugging output.

[Visual Basic] Overloads Public Sub New(TextWriter)
[C#] public TextWriterTraceListener(TextWriter);
[C++] public: TextWriterTraceListener(TextWriter*);
[JScript] public function TextWriterTraceListener(TextWriter);

Initializes a new instance of the TextWriterTraceListener class with the specified Name and using the specified writer as recipient of the tracing or debugging output.

[Visual Basic] Overloads Public Sub New(TextWriter, String)
[C#] public TextWriterTraceListener(TextWriter, String);
[C++] public: TextWriterTraceListener(TextWriter*, String);
[JScript] public function TextWriterTraceListener(TextWriter, String);

See Also

TextWriterTraceListener Class | TextWriterTraceListener Members | System.Diagnostics Namespace


TextWriterTraceListener Constructor ()

Initializes a new instance of the TextWriterTraceListener class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public TextWriterTraceListener();
[C++]
public: TextWriterTraceListener();
[JScript]
public function TextWriterTraceListener();

Remarks

This contructor uses the TextWriter stream as the recipient of the tracing or debugging output. It initializes the Name property to "TextWriter".

See Also

TextWriterTraceListener Class | TextWriterTraceListener Members | System.Diagnostics Namespace | TextWriterTraceListener Constructor Overload List | TraceListener | DefaultTraceListener | TextWriterTraceListener | Stream | TextWriter | Debug | Trace


TextWriterTraceListener Constructor (Stream)

Initializes a new instance of the TextWriterTraceListener class using the stream parameter as the recipient of the debugging and tracing output.

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream _
)
[C#]
public TextWriterTraceListener(
   Stream stream
);
[C++]
public: TextWriterTraceListener(
   Stream* stream
);
[JScript]
public function TextWriterTraceListener(
   stream : Stream
);

Parameters

stream
A Stream that represents the stream that the TextWriterTraceListener writes to.

Exceptions

Exception Type | Condition
ArgumentNullException | The stream is a null reference (in Visual Basic Nothing).

Remarks

This constructor initializes the Name property to an empty string ("").

See Also

TextWriterTraceListener Class | TextWriterTraceListener Members | System.Diagnostics Namespace | TextWriterTraceListener Constructor Overload List | TraceListener | DefaultTraceListener | TextWriterTraceListener | Stream | TextWriter | Debug | Trace


TextWriterTraceListener Constructor (Stream, String)

Initializes a new instance of the TextWriterTraceListener class with the specified Name and using the stream parameter as the recipient of the debugging and tracing output.

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream, _
   ByVal name As String _
)
[C#]
public TextWriterTraceListener(
   Stream stream,
   string name
);
[C++]
public: TextWriterTraceListener(
   Stream* stream,
   String* name
);
[JScript]
public function TextWriterTraceListener(
   stream : Stream,
   name : String
);

Parameters

stream
A Stream that represents the stream that the TextWriterTraceListener writes to.
name
The name of the new instance.

Exceptions

Exception Type | Condition
ArgumentNullException | The stream is a null reference (in Visual Basic Nothing).

Remarks

This constructor initializes the Name property to the Name

parameter or to an empty string ("") if the Name parameter is a null reference (Nothing).

See Also

TextWriterTraceListener Class | TextWriterTraceListener Members | System.Diagnostics Namespace | TextWriterTraceListener Constructor Overload List | TraceListener | DefaultTraceListener | TextWriterTraceListener | Stream | TextWriter | Debug | Trace


TextWriterTraceListener Constructor (TextWriter)

Initializes a new instance of the TextWriterTraceListener class using the specified writer as recipient of the tracing or debugging output.

[Visual Basic]
Overloads Public Sub New( _
   ByVal writer As TextWriter _
)
[C#]
public TextWriterTraceListener(
   TextWriter writer
);
[C++]
public: TextWriterTraceListener(
   TextWriter* writer
);
[JScript]
public function TextWriterTraceListener(
   writer : TextWriter
);

Parameters

writer
A TextWriter that receives the output from the TextWriterTraceListener.

Exceptions

Exception Type | Condition
ArgumentNullException | The writer is a null reference (in Visual Basic Nothing).

Remarks

This constructor initializes the Name property to an empty string ("").

See Also

TextWriterTraceListener Class | TextWriterTraceListener Members | System.Diagnostics Namespace | TextWriterTraceListener Constructor Overload List | TraceListener | DefaultTraceListener | TextWriterTraceListener | Stream | TextWriter | Debug | Trace


TextWriterTraceListener Constructor (TextWriter, String)

Initializes a new instance of the TextWriterTraceListener class with the specified Name and using the specified writer as recipient of the tracing or debugging output.

[Visual Basic]
Overloads Public Sub New( _
   ByVal writer As TextWriter, _
   ByVal name As String _
)
[C#]
public TextWriterTraceListener(
   TextWriter writer,
   string name
);
[C++]
public: TextWriterTraceListener(
   TextWriter* writer,
   String* name
);
[JScript]
public function TextWriterTraceListener(
   writer : TextWriter,
   name : String
);

Parameters

writer
A TextWriter that receives the output from the TextWriterTraceListener.
name
The name of the new instance.

Exceptions

Exception Type | Condition
ArgumentNullException | The writer is a null reference (in Visual Basic Nothing).

See Also

TextWriterTraceListener Class | TextWriterTraceListener Members | System.Diagnostics Namespace | TextWriterTraceListener Constructor Overload List | TraceListener | DefaultTraceListener | TextWriterTraceListener | Stream | TextWriter | Debug | Trace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TextWriterTraceListener Properties

The properties of the TextWriterTraceListener class are listed below. For a complete list of TextWriterTraceListener class members, see the TextWriterTraceListener Members topic.

Public:

Indent (inherited from TraceListener) | Gets or sets the indent level.
IndentSize (inherited from TraceListener) | Gets or sets the number of spaces in an indent.
Name (inherited from TraceListener) | Gets or sets a name for this TraceListener.
Writer | Gets or sets the text writer that receives the tracing or debugging output.

Protected:

NeedIndent (inherited from TraceListener) Gets or sets whether an indent is needed.

See Also

TextWriterTraceListener Class | System.Diagnostics Namespace


TextWriterTraceListener.Writer

Gets or sets the text writer that receives the tracing or debugging output.

[Visual Basic]
Overridable Public Property Writer As TextWriter
[C#]
public TextWriter Writer {virtual get; virtual set;}
[C++]
public: __property virtual TextWriter* get_Writer();
public: __property virtual void set_Writer(TextWriter*);
[JScript]
public function get Writer() : TextWriter;
public function set Writer(TextWriter);

Property Value

A TextWriter that represents the writer that receives the tracing or debugging output.

See Also

TextWriterTraceListener Class | TextWriterTraceListener Members | System.Diagnostics Namespace | TraceListener | DefaultTraceListener | TextWriterTraceListener | Stream | TextWriter | Debug | Trace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TextWriterTraceListener Methods

The methods of the TextWriterTraceListener class are listed below. For a complete list of TextWriterTraceListener class members, see the TextWriterTraceListener Members topic.

Public:

Close | Closes the Writer so that it no longer receives tracing or debugging output.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Fail (inherited from TraceListener) | Overloaded. Emits or displays a message for an assertion that always fails.
Flush | Flushes the output buffer for the Writer.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write (inherited from TraceListener) | Overloaded. Writes a message, category name, or object name.
WriteLine (inherited from TraceListener) | Overloaded. Writes a message, category name, or object name followed by a line terminator.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
WriteIndent (inherited from TraceListener) | Writes the indent and resets the NeedIndent property to false.

See Also

TextWriterTraceListener Class | System.Diagnostics Namespace


TextWriterTraceListener.Close

Closes the Writer so that it no longer receives tracing or debugging output.

[Visual Basic]
Overrides Public Sub Close()
[C#]
public override void Close();
[C++]
public: override void Close();
[JScript]
public override function Close();

Remarks

If you want to send debugging or tracing output to a Writer after a call to this method, you should reinitialize the text writer.

See Also

TextWriterTraceListener Class | TextWriterTraceListener Members | System.Diagnostics Namespace | TraceListener | DefaultTraceListener | TextWriterTraceListener | Stream | TextWriter | Debug | Trace


TextWriterTraceListener.Flush

Flushes the output buffer for the Writer.

[Visual Basic]
Overrides Public Sub Flush()
[C#]
public override void Flush();
[C++]
public: override void Flush();
[JScript]
public override function Flush();

See Also

TextWriterTraceListener Class | TextWriterTraceListener Members | System.Diagnostics Namespace | TraceListener | DefaultTraceListener | TextWriterTraceListener | Stream | TextWriter | Debug | Trace


TextWriterTraceListener.Write

Writes a message to this instance's Writer.

[Visual Basic]
Overrides Public Sub Write( _
   ByVal message As String _
)
[C#]
public override void Write(
   string message
);
[C++]
public: override void Write(
   String* message
);
[JScript]
public override function Write(
   message : String
);

Parameters

message
A message to write.

See Also

TextWriterTraceListener Class | TextWriterTraceListener Members | System.Diagnostics Namespace | TraceListener | DefaultTraceListener | TextWriterTraceListener | Stream | TextWriter | Debug | Trace


TextWriterTraceListener.WriteLine

Writes a message to this instance's Writer followed by a line terminator. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic]
Overrides Public Sub WriteLine( _
   ByVal message As String _
)
[C#]
public override void WriteLine(
   string message
);
[C++]
public: override void WriteLine(
   String* message
);
[JScript]
public override function WriteLine(
   message : String
);

Parameters

message
A message to write.

See Also

TextWriterTraceListener Class | TextWriterTraceListener Members | System.Diagnostics Namespace | TraceListener | DefaultTraceListener | TextWriterTraceListener | Stream | TextWriter | Debug | Trace


ThreadPriorityLevel Enumeration

Specifies the priority level of a thread. The priority level is not an absolute level, but instead contributes to the actual thread priority by considering the priority class of the process.

[Visual Basic]
Public Enum ThreadPriorityLevel
[C#]
public enum ThreadPriorityLevel
[C++]
public enum ThreadPriorityLevel

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
AboveNormal | Above normal priority
BelowNormal | Below normal priority
Highest | Highest priority
Idle | Idle priority
Lowest | Lowest priority
Normal | Normal priority
TimeCritical | Time critical priority

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

System.Diagnostics Namespace


ThreadState Enumeration

Specifies the execution state of a thread.

[Visual Basic]
Public Enum ThreadState
[C#]
public enum ThreadState
[C++]
public enum ThreadState

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Initialized | The thread has been initialized, but has not started yet.
Ready | The thread is in ready state.
Running | The thread is running.
Standby | The thread is in standby state.
Terminated | The thread has exited.
Transition | The thread is transitioning between states.
Unknown | The thread state is unknown.
Wait | The thread is waiting.

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

System.Diagnostics Namespace


ThreadWaitReason Enumeration

Specifies the reason a thread is waiting.

[Visual Basic]
Public Enum ThreadWaitReason
[C#]
public enum ThreadWaitReason
[C++]
public enum ThreadWaitReason

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
EventPairHigh | Thread is waiting for event pair high.
EventPairLow | Thread is waiting for event pair low.
ExcecutionDelay | Thread execution is delayed.
Executive | Thread is waiting for the scheduler.
FreePage | Thread is waiting for a free virtual memory page.
LpcReceive | Thread is waiting for a local procedure call to arrive.
LpcReply | Thread is waiting for reply to a local procedure call to arrive.
PageIn | Thread is waiting for a virtual memory page to arrive in memory.
PageOut | Thread is waiting for a virtual memory page to be written to disk.
Suspended | Thread execution is suspended.
SystemAllocation | Thread is waiting for a system allocation.
Unknown | Thread is waiting for an unknown reason.
UserRequest | Thread is waiting for a user request.
VirtualMemory | Thread is waiting for virtual memory.

Requirements

Namespace: System.Diagnostics

Assembly: System.Diagnostics.dll

See Also

System.Diagnostics Namespace


Trace Class

Provides a set of properties and methods to trace the execution of your code.

Object
Trace

[Visual Basic]
Public Class Trace
[C#]
public class Trace
[C++]
public __gc class Trace
[JScript]
public class Trace

Remarks

You can use the properties and methods in the Trace class to instrument retail builds. By default, Trace is on in retail builds. Therefore, code is generated for all methods marked with Conditional("TRACE"). This allows a user to turn on tracing to help identify the problem without you recompiling the program. In contrast, by default Debug is off in retail builds.

Note To enable tracing, you must add the "/D:TRACE" flag to the compiler command line when you compile your code.

The BooleanSwitch and TraceSwitch classes provide a means to control the tracing output dynamically. The values of these switches can be modified outside the compiled application.

You can customize the tracing output's target by adding TraceListener instances to or removing instances from the Listeners collection. By default, trace output is emitted using the DefaultTraceListener class.

The Trace class provides properties to get or set the level of Indent, the IndentSize and whether to AutoFlush after each write.

This class also provides methods to display an Assert dialog box, and to set an assertion that will always Fail. This class provides write methods in the following variations: Write, WriteLine, WriteIf and WriteLineIf.

For more information, see <DebugTopicTBD>.

Requirements

Namespace: System.Diagnostics

Assembly: System.dll

Example [C#]

The following example creates three switches to control the tracing output for the Customer class.

[C#]

Class Customer{
   // trace each method flow
   static BooleanSwitch traceMethods("TraceMethods", "Trace logic flow");
   // trace method parameters
   static BooleanSwitch traceParams("TraceParams", "Trace parameter values");
   // trace return values
   static BooleanSwitch traceResults("TraceResults", "Trace calculations");

   string Name(string last, string first){
      Trace.WriteLineIf(traceMethods.Enabled, "Name called");
      Trace.WriteLineIf(traceParams.Enabled, "Params: " + last + ", " + first);

      string fullName = first + " " + last;

      Trace.WriteLineIf(traceMethods.Enabled, "Name terminates");
      Trace.WriteLineIf(traceResults.Enabled, "Result: " + fullName);
      return fullName;
   }
}

If the traceMethods and traceResults are set to true, and traceParams is set to false, the output for a call to Name("Smith", "John") would be:

Name called

Name terminates

Result: John Smith

See Also

Trace Members | System.Diagnostics Namespace | Debug | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute


Trace Members

Public:

Constructor

Trace Constructor [To be supplied.]

Properties

AutoFlush | Gets or sets whether Flush should be called on the Listeners after every write.
Indent | Gets or sets the indent level.
IndentSize | Gets or sets the number of spaces in an indent.
Listeners | Gets the collection of listeners that is monitoring the trace output.

Methods

Assert | Overloaded. Checks for a condition and displays a message if the condition is false.
Close | Clears the output buffer and then closes the Listeners so that they no longer receive debugging output.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Fail | Overloaded. Emits or displays a message for an assertion that always fails.
Flush | Clears the output buffer and causes any buffered data to be written to the Listeners.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Overloaded. Writes information about the trace to the trace listeners in the Listeners collection.
WriteIf | Overloaded. Writes a message to the trace listeners in the Listeners collection if a condition is true.
WriteLine | Overloaded. Writes information about the trace followed by a line terminator to the trace listeners in the Listeners collection.
WriteLineIf | Overloaded. Writes information about the trace followed by a line terminator to the trace listeners in the Listeners collection if a condition is true.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Trace Class | System.Diagnostics Namespace


Trace Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public Trace();
[C++]
public: Trace();
[JScript]
public function Trace();

See Also

Trace Class | Trace Members | System.Diagnostics Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Trace Properties

The properties of the Trace class are listed below. For a complete list of Trace class members, see the Trace Members topic.

Public:

AutoFlush | Gets or sets whether Flush should be called on the Listeners after every write.
Indent | Gets or sets the indent level.
IndentSize | Gets or sets the number of spaces in an indent.
Listeners | Gets the collection of listeners that is monitoring the trace output.

See Also

Trace Class | System.Diagnostics Namespace


Trace.AutoFlush

Gets or sets whether Flush should be called on the Listeners after every write.

[Visual Basic]
Public Shared Property AutoFlush As Boolean
[C#]
public static bool AutoFlush {get; set;}
[C++]
public: __property static bool get_AutoFlush();
public: __property static void set_AutoFlush(bool);
[JScript]
public static function get AutoFlush() : Boolean;
public static function set AutoFlush(Boolean);

Property Value

true if Flush is called on the Listeners after every write; otherwise, false.

Remarks

The default is false.

See Also

Trace Class | Trace Members | System.Diagnostics Namespace | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute


Trace.Indent

Gets or sets the indent level.

[Visual Basic]
Public Shared Property Indent As Integer
[C#]
public static int Indent {get; set;}
[C++]
public: __property static int get_Indent();
public: __property static void set_Indent(int);
[JScript]
public static function get Indent() : int;
public static function set Indent(int);

Property Value

The indent level.

Remarks

The default is zero (0). This property is stored on per-thread/per-request basis.

Example [C#]

The following example sets the indent level and emits tracing messages.

[C#]

Trace.WriteLine("List of errors:");
Trace.Indent = Debug.Indent + 1;
Trace.Writeline("Error 1: File not found");
Trace.WriteLine("Error 2: Directory not found");
Trace.Indent = Debug.Indent - 1;
Trace.WriteLine("End of list of errors");

See Also

Trace Class | Trace Members | System.Diagnostics Namespace | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute


Trace.IndentSize

Gets or sets the number of spaces in an indent.

[Visual Basic]
Public Shared Property IndentSize As Integer
[C#]
public static int IndentSize {get; set;}
[C++]
public: __property static int get_IndentSize();
public: __property static void set_IndentSize(int);
[JScript]
public static function get IndentSize() : int;
public static function set IndentSize(int);

Property Value

The number of spaces in an indent.

Remarks

The default is 4 (four spaces). The property is stored on per-thread/per-request basis.

See Also

Trace Class | Trace Members | System.Diagnostics Namespace | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute


Trace.Listeners

Gets the collection of listeners that is monitoring the trace output.

[Visual Basic]
Public Shared ReadOnly Property Listeners As TraceListeners
[C#]
public static TraceListeners Listeners {get;}
[C++]
public: __property static TraceListeners* get_Listeners();
[JScript]
public static function get Listeners() : TraceListeners;

Property Value

A TraceListeners that represents a collection of type TraceListener that is monitoring the trace output.

Remarks

The listeners produce the output. By default, the collection contains an instance of the DefaultTraceListener class. If you want to remove the default listener, call the Remove method, and pass it the instance of the DefaultTraceListener. To redirect output to the screen, add an instance of the TextWriterTraceListener that uses the Console.Out stream.

See Also

Trace Class | Trace Members | System.Diagnostics Namespace | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Trace Methods

The methods of the Trace class are listed below. For a complete list of Trace class members, see the Trace Members topic.

Public:

Assert | Overloaded. Checks for a condition and displays a message if the condition is false.
Close | Clears the output buffer and then closes the Listeners so that they no longer receive debugging output.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Fail | Overloaded. Emits or displays a message for an assertion that always fails.
Flush | Clears the output buffer and causes any buffered data to be written to the Listeners.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Overloaded. Writes information about the trace to the trace listeners in the Listeners collection.
WriteIf | Overloaded. Writes a message to the trace listeners in the Listeners collection if a condition is true.
WriteLine | Overloaded. Writes information about the trace followed by a line terminator to the trace listeners in the Listeners collection.
WriteLineIf | Overloaded. Writes information about the trace followed by a line terminator to the trace listeners in the Listeners collection if a condition is true.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Trace Class | System.Diagnostics Namespace


Trace.Assert

Checks for a condition and displays a message if the condition is false.

Overload List

Checks for a condition and displays both the specified messages if the condition is false.

[Visual Basic] Overloads Public Shared Sub Assert(Boolean, String, String)
[C#] public static void Assert(bool, String, String);
[C++] public: static void Assert(bool, String, String);
[JScript] public static function Assert(Boolean, String, String);

Checks for a condition and displays a message if the condition is false.

[Visual Basic] Overloads Public Shared Sub Assert(Boolean, String)
[C#] public static void Assert(bool, String);
[C++] public: static void Assert(bool, String);
[JScript] public static function Assert(Boolean, String);

Checks for a condition and outputs the callstack if the condition is false.

[Visual Basic] Overloads Public Shared Sub Assert(Boolean)
[C#] public static void Assert(bool);
[C++] public: static void Assert(bool);
[JScript] public static function Assert(Boolean);

See Also

Trace Class | Trace Members | System.Diagnostics Namespace


Trace.Assert (Boolean, String, String)

Checks for a condition and displays both the specified messages if the condition is false.

[Visual Basic]
Overloads Public Shared Sub Assert( _
   ByVal condition As Boolean, _
   ByVal message As String, _
   ByVal detailMessage As String _
)
[C#]
public static void Assert(
   bool condition,
   string message,
   string detailMessage
);
[C++]
public: static void Assert(
   bool condition,
   String* message,
   String* detailMessage
);
[JScript]
public static function Assert(
   condition : Boolean,
   message : String,
   detailMessage : String
);

Parameters

condition
A condition which if false causes messages to be displayed.
message
A message to display.
detailMessage
A detailed message to display.

Remarks

Typically Assert is used to identify logic errors during program development. Assert will evaluate the condition. If the result is false, it sends diagnostic messages to the Listeners.The default behavior is to display a message box when the application is running in a user interface mode, and to output the message to the default trace output. You can customize this behavior by adding a TraceListener to or removing one from the Listeners collection.

See Also

Trace Class | Trace Members | System.Diagnostics Namespace | Trace.Assert Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute


Trace.Assert (Boolean, String)

Checks for a condition and displays a message if the condition is false.

[Visual Basic]
Overloads Public Shared Sub Assert( _
   ByVal condition As Boolean, _
   ByVal message As String _
)
[C#]
public static void Assert(
   bool condition,
   string message
);
[C++]
public: static void Assert(
   bool condition,
   String* message
);
[JScript]
public static function Assert(
   condition : Boolean,
   message : String
);

Parameters

condition
A condition which if false causes a message to be displayed.
message
A message to display.

Remarks

Typically Assert is used to identify logic errors during program development. Assert will evaluate the condition. If the result is false, it sends diagnostic messages to the Listeners.The default behavior is to display a message box when the application is running in a user interface mode, and to output the message to the default trace output. You can customize this behavior by adding a TraceListener to or removing one from the Listeners collection.

See Also

Trace Class | Trace Members | System.Diagnostics Namespace | Trace.Assert Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute


Trace.Assert (Boolean)

Checks for a condition and outputs the callstack if the condition is false.

[Visual Basic]
Overloads Public Shared Sub Assert( _
   ByVal condition As Boolean _
)
[C#]
public static void Assert(
   bool condition
);
[C++]
public: static void Assert(
   bool condition
);
[JScript]
public static function Assert(
   condition : Boolean
);

Parameters

condition
A condition which if false causes a message to be displayed.

Remarks

Assert outputs the callstack with file and line number, if it is available, for each line in the callstack.

Typically Assert is used to identify logic errors during program development. Assert will evaluate the condition. If the result is false, it sends diagnostic messages to the Listeners.

The default behavior is to display a message box when the application is running in a user interface mode, and to output the message to the default trace output. You can customize this behavior by adding a TraceListener to or removing one from the Listeners collection.

See Also

Trace Class | Trace Members | System.Diagnostics Namespace | Trace.Assert Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute


Trace.Close

Clears the output buffer and then closes the Listeners so that they no longer receive debugging output.

[Visual Basic]
Public Shared Sub Close()
[C#]
public static void Close();
[C++]
public: static void Close();
[JScript]
public static function Close();

Remarks

Use this method when the output is going to a file such as to the TextWriterTraceListener.

See Also

Trace Class | Trace Members | System.Diagnostics Namespace | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute


Trace.Fail

Emits or displays a message for an assertion that always fails.

Overload List

Displays displays both the specified messages for an assertion that always fails.

[Visual Basic] Overloads Public Shared Sub Fail(String, String)
[C#] public static void Fail(String, String);
[C++] public: static void Fail(String*, String*);
[JScript] public static function Fail(String, String);

Emits or displays a message for an assertion that always fails.

[Visual Basic] Overloads Public Shared Sub Fail(String)
[C#] public static void Fail(String);
[C++] public: static void Fail(String*);
[JScript] public static function Fail(String);

See Also

Trace Class | Trace Members | System.Diagnostics Namespace


Trace.Fail (String, String)

Displays displays both the specified messages for an assertion that always fails.

[Visual Basic]
Overloads Public Shared Sub Fail( _
   ByVal message As String, _
   ByVal detailMessage As String _
)
[C#]
public static void Fail(
   string message,
   string detailMessage
);
[C++]
public: static void Fail(
   String* message,
   String* detailMessage
);
[JScript]
public static function Fail(
   message : String,
   detailMessage : String
);

Parameters

message
A message to emit or display.
detailMessage
A detailed message to emit or display.

Remarks

The default behavior is to output the message and detailedMessage

to a message box when the application is running in a user interface mode, and to the TraceListener instances in the Listeners collection. You can customize this behavior by adding a TraceListener to or removing one from the Listeners collection.

See Also

Trace Class | Trace Members | System.Diagnostics Namespace | Trace.Fail Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute


Trace.Fail (String)

Emits or displays a message for an assertion that always fails.

[Visual Basic]
Overloads Public Shared Sub Fail( _
   ByVal message As String _
)
[C#]
public static void Fail(
   string message
);
[C++]
public: static void Fail(
   String* message
);
[JScript]
public static function Fail(
   message : String
);

Parameters

message
A message to emit or display.

Remarks

The default behavior is to output the message to a message box when the application is running in a user interface mode, and to the TraceListener instances in the Listeners collection. You can customize this behavior by adding a TraceListener to or removing one from the Listeners collection.

See Also

Trace Class | Trace Members | System.Diagnostics Namespace | Trace.Fail Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute


Trace.Flush

Clears the output buffer and causes any buffered data to be written to the Listeners.

[Visual Basic]
Public Shared Sub Flush()
[C#]
public static void Flush();
[C++]
public: static void Flush();
[JScript]
public static function Flush();

See Also

Trace Class | Trace Members | System.Diagnostics Namespace | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute


Trace.Write

Writes information about the trace to the trace listeners in the Listeners collection.

Overload List

Writes a category name and the name of the value parameter to the trace listeners in the Listeners collection.

[Visual Basic] Overloads Public Shared Sub Write(Object, String)
[C#] public static void Write(Object, String);
[C++] public: static void Write(Object*, String);
[JScript] public static function Write(Object, String);

Writes the name of the value parameter to the trace listeners in the Listeners collection.

[Visual Basic] Overloads Public Shared Sub Write(Object)
[C#] public static void Write(Object);
[C++] public: static void Write(Object*);
[JScript] public static function Write(Object);

Writes a message to the trace listeners in the Listeners collection.

[Visual Basic] Overloads Public Shared Sub Write(String)
[C#] public static void Write(String);
[C++] public: static void Write(String*);
[JScript] public static function Write(String);

Writes a category name and message to the trace listeners in the Listeners collection.

[Visual Basic] Overloads Public Shared Sub Write(String, String)
[C#] public static void Write(String, String);
[C++] public: static void Write(String*, String*);
[JScript] public static function Write(String, String);

See Also

Trace Class | Trace Members | System.Diagnostics Namespace


Trace.Write (Object, String)

Writes a category name and the name of the value parameter to the trace listeners in the Listeners collection.

[Visual Basic]
Overloads Public Shared Sub Write( _
   ByVal value As Object, _
   ByVal category As String _
)
[C#]
public static void Write(
   object value,
   string category
);
[C++]
public: static void Write(
   Object* value,
   String* category
);
[JScript]
public static function Write(
   value : Object,
   category : String
);

Parameters

value
An Object name is sent to the Listeners.
category
A category name to write.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

The category can be used to group output messages.

See Also

Trace Class | Trace Members | System.Diagnostics Namespace | Trace.Write Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute


Trace.Write (Object)

Writes the name of the value parameter to the trace listeners in the Listeners collection.

[Visual Basic]
Overloads Public Shared Sub Write( _
   ByVal value As Object _
)
[C#]
public static void Write(
   object value
);
[C++]
public: static void Write(
   Object* value
);
[JScript]
public static function Write(
   value : Object
);

Parameters

value
An Object whose name is sent to the Listeners.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

See Also

Trace Class | Trace Members | System.Diagnostics Namespace | Trace.Write Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute


Trace.Write (String)

Writes a message to the trace listeners in the Listeners collection.

[Visual Basic]
Overloads Public Shared Sub Write( _
   ByVal message As String _
)
[C#]
public static void Write(
   string message
);
[C++]
public: static void Write(
   String* message
);
[JScript]
public static function Write(
   message : String
);

Parameters

message
A message to write.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

See Also

Trace Class | Trace Members | System.Diagnostics Namespace | Trace.Write Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute


Trace.Write (String, String)

Writes a category name and message to the trace listeners in the Listeners collection.

[Visual Basic]
Overloads Public Shared Sub Write( _
   ByVal message As String, _
   ByVal category As String _
)
[C#]
public static void Write(
   string message,
   string category
);
[C++]
public: static void Write(
   String* message,
   String* category
);
[JScript]
public static function Write(
   message : String,
   category : String
);

Parameters

message
A message to write.
category
A category name to write.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

The category can be used to group output messages.

See Also

Trace Class | Trace Members | System.Diagnostics Namespace | Trace.Write Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute


Trace.WriteIf

Writes a message to the trace listeners in the Listeners collection if a condition is true.

Overload List

Writes the name of the value parameter to the trace listeners in the Listeners collection if a condition is true.

[Visual Basic] Overloads Public Shared Sub WriteIf(Boolean, Object)
[C#] public static void WriteIf(bool, Object);
[C++] public: static void WriteIf(bool, Object);
[JScript] public static function WriteIf(Boolean, Object);

Writes a category name and message to the trace listeners in the Listeners collection if a condition is true.

[Visual Basic] Overloads Public Shared Sub WriteIf(Boolean, String, String)
[C#] public static void WriteIf(bool, String, String);
[C++] public: static void WriteIf(bool, String, String);
[JScript] public static function WriteIf(Boolean, String, String);

Writes a category name and the name of the value parameter to the trace listeners in the Listeners collection if a condition is true.

[Visual Basic] Overloads Public Shared Sub WriteIf(Boolean, Object, String)
[C#] public static void WriteIf(bool, Object, String);
[C++] public: static void WriteIf(bool, Object, String);
[JScript] public static function WriteIf(Boolean, Object, String);

Writes a message to the trace listeners in the Listeners collection if a condition is true.

[Visual Basic] Overloads Public Shared Sub WriteIf(Boolean, String)
[C#] public static void WriteIf(bool, String);
[C++] public: static void WriteIf(bool, String);
[JScript] public static function WriteIf(Boolean, String);

See Also

Trace Class | Trace Members | System.Diagnostics Namespace


Trace.WriteIf (Boolean, Object)

Writes the name of the value parameter to the trace listeners in the Listeners collection if a condition is true.

[Visual Basic]
Overloads Public Shared Sub WriteIf( _
   ByVal condition As Boolean, _
   ByVal value As Object _
)
[C#]
public static void WriteIf(
   bool condition,
   object value
);
[C++]
public: static void WriteIf(
   bool condition,
   Object* value
);
[JScript]
public static function WriteIf(
   condition : Boolean,
   value : Object
);

Parameters

condition
A condition which if true will cause the message to be written.
value
An Object whose name is sent to the Listeners.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

Notes to Implementers: You can minimize the performance penalty of instrumenting your application by using If...Then statements instead of using WriteIf statements. The following two code examples send the same debugging message. However, the first example is much faster when tracing is off, because if mySwitch.TraceError evaluates to false you do not call Write. The second example always calls WriteIf, even when mySwitch.TraceError is false and no tracing output is produced. This can result in unnecessary execution of an arbitrarily complex code.

First example.

if(mySwitch.TraceError)
   Trace.Write("aNumber = " + aNumber + " out of range");

Second example.

Trace.WriteIf(mySwitch.TraceError, "aNumber = " + aNumber + " out of range");

See Also

Trace Class | Trace Members | System.Diagnostics Namespace | Trace.WriteIf Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute


Trace.WriteIf (Boolean, String, String)

Writes a category name and message to the trace listeners in the Listeners collection if a condition is true.

[Visual Basic]
Overloads Public Shared Sub WriteIf( _
   ByVal condition As Boolean, _
   ByVal message As String, _
   ByVal category As String _
)
[C#]
public static void WriteIf(
   bool condition,
   string message,
   string category
);
[C++]
public: static void WriteIf(
   bool condition,
   String* message,
   String* category
);
[JScript]
public static function WriteIf(
   condition : Boolean,
   message : String,
   category : String
);

Parameters

condition
A condition which if true will cause the message to be written.
message
A message to write.
category
A category name to write.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

The category can be used to group output messages.

Notes to Implementers: You can minimize the performance penalty of instrumenting your application by using If...Then statements instead of using WriteIf statements. The following two code examples send the same debugging message. However, the first example is much faster when tracing is off, because if mySwitch.TraceError evaluates to false you do not call Write. The second example always calls WriteIf, even when mySwitch.TraceError is false and no tracing output is produced. This can result in unnecessary execution of an arbitrarily complex code.

First example.

if(mySwitch.TraceError)
   Trace.Write("aNumber = " + aNumber + " out of range");

Second example.

Trace.WriteIf(mySwitch.TraceError, "aNumber = " + aNumber + " out of range");

See Also

Trace Class | Trace Members | System.Diagnostics Namespace | Trace.WriteIf Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute


Trace.WriteIf (Boolean, Object, String)

Writes a category name and the name of the value parameter to the trace listeners in the Listeners collection if a condition is true.

[Visual Basic]
Overloads Public Shared Sub WriteIf( _
   ByVal condition As Boolean, _
   ByVal value As Object, _
   ByVal category As String _
)
[C#]
public static void WriteIf(
   bool condition,
   object value,
   string category
);
[C++]
public: static void WriteIf(
   bool condition,
   Object* value,
   String* category
);
[JScript]
public static function WriteIf(
   condition : Boolean,
   value : Object,
   category : String
);

Parameters

condition
A condition which if true will cause the message to be written.
value
An Object whose name is sent to the Listeners.
category
A category name to write.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

The category can be used to group output messages.

Notes to Implementers: You can minimize the performance penalty of instrumenting your application by using If...Then statements instead of using WriteIf statements. The following two code examples send the same debugging message. However, the first example is much faster when tracing is off, because if mySwitch.TraceError evaluates to false you do not call Write. The second example always calls WriteIf, even when mySwitch.TraceError is false and no tracing output is produced. This can result in unnecessary execution of an arbitrarily complex code.

First example.

if(mySwitch.TraceError)
   Trace.Write("aNumber = " + aNumber + " out of range");

Second example.

Trace.WriteIf(mySwitch.TraceError, "aNumber = " + aNumber + " out of range");

See Also

Trace Class | Trace Members | System.Diagnostics Namespace | Trace.WriteIf Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute


Trace.WriteIf (Boolean, String)

Writes a message to the trace listeners in the Listeners collection if a condition is true.

[Visual Basic]
Overloads Public Shared Sub WriteIf( _
   ByVal condition As Boolean, _
   ByVal message As String _
)
[C#]
public static void WriteIf(
   bool condition,
   string message
);
[C++]
public: static void WriteIf(
   bool condition,
   String* message
);
[JScript]
public static function WriteIf(
   condition : Boolean,
   message : String
);

Parameters

condition
A condition which if true will cause the message to be written.
message
A message to write.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

Notes to Implementers: You can minimize the performance penalty of instrumenting your application by using If...Then statements instead of using WriteIf statements. The following two code examples send the same debugging message. However, the first example is much faster when tracing is off, because if mySwitch.TraceError evaluates to false you do not call Write. The second example always calls WriteIf, even when mySwitch.TraceError is false and no tracing output is produced. This can result in unnecessary execution of an arbitrarily complex code.

First example.

if(mySwitch.TraceError)
   Trace.Write("aNumber = " + aNumber + " out of range");

Second example.

Trace.WriteIf(mySwitch.TraceError, "aNumber = " + aNumber + " out of range");

See Also

Trace Class | Trace Members | System.Diagnostics Namespace | Trace.WriteIf Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute


Trace.WriteLine

Writes information about the trace followed by a line terminator to the trace listeners in the Listeners collection.

Overload List

Writes a message followed by a line terminator to the trace listeners in the Listeners collection. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic] Overloads Public Shared Sub WriteLine(String)
[C#] public static void WriteLine(String);
[C++] public: static void WriteLine(String*);
[JScript] public static function WriteLine(String);

Writes the name of the value parameter followed by a line terminator to the trace listeners in the Listeners collection. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic] Overloads Public Shared Sub WriteLine(Object)
[C#] public static void WriteLine(Object);
[C++] public: static void WriteLine(Object*);
[JScript] public static function WriteLine(Object);

Writes a category name and the name of the value parameter followed by a line terminator to the trace listeners in the Listeners collection. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic] Overloads Public Shared Sub WriteLine(Object, String)
[C#] public static void WriteLine(Object, String);
[C++] public: static void WriteLine(Object*, String);
[JScript] public static function WriteLine(Object, String);

Writes a category name and message followed by a line terminator to the trace listeners in the Listeners collection. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic] Overloads Public Shared Sub WriteLine(String, String)
[C#] public static void WriteLine(String, String);
[C++] public: static void WriteLine(String*, String*);
[JScript] public static function WriteLine(String, String);

See Also

Trace Class | Trace Members | System.Diagnostics Namespace


Trace.WriteLine (String)

Writes a message followed by a line terminator to the trace listeners in the Listeners collection. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic]
Overloads Public Shared Sub WriteLine( _
   ByVal message As String _
)
[C#]
public static void WriteLine(
   string message
);
[C++]
public: static void WriteLine(
   String* message
);
[JScript]
public static function WriteLine(
   message : String
);

Parameters

message
A message to write.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

See Also

Trace Class | Trace Members | System.Diagnostics Namespace | Trace.WriteLine Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute


Trace.WriteLine (Object)

Writes the name of the value parameter followed by a line terminator to the trace listeners in the Listeners collection. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic]
Overloads Public Shared Sub WriteLine( _
   ByVal value As Object _
)
[C#]
public static void WriteLine(
   object value
);
[C++]
public: static void WriteLine(
   Object* value
);
[JScript]
public static function WriteLine(
   value : Object
);

Parameters

value
An Object whose name is sent to the Listeners.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

See Also

Trace Class | Trace Members | System.Diagnostics Namespace | Trace.WriteLine Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute


Trace.WriteLine (Object, String)

Writes a category name and the name of the value parameter followed by a line terminator to the trace listeners in the Listeners collection. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic]
Overloads Public Shared Sub WriteLine( _
   ByVal value As Object, _
   ByVal category As String _
)
[C#]
public static void WriteLine(
   object value,
   string category
);
[C++]
public: static void WriteLine(
   Object* value,
   String* category
);
[JScript]
public static function WriteLine(
   value : Object,
   category : String
);

Parameters

value
An Object whose name is sent to the Listeners.
category
A category name to write.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

The category can be used to group output messages.

See Also

Trace Class | Trace Members | System.Diagnostics Namespace | Trace.WriteLine Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute


Trace.WriteLine (String, String)

Writes a category name and message followed by a line terminator to the trace listeners in the Listeners collection. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic]
Overloads Public Shared Sub WriteLine( _
   ByVal message As String, _
   ByVal category As String _
)
[C#]
public static void WriteLine(
   string message,
   string category
);
[C++]
public: static void WriteLine(
   String* message,
   String* category
);
[JScript]
public static function WriteLine(
   message : String,
   category : String
);

Parameters

message
A message to write.
category
A category name to write.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

The category can be used to group output messages.

See Also

Trace Class | Trace Members | System.Diagnostics Namespace | Trace.WriteLine Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute


Trace.WriteLineIf

Writes information about the trace followed by a line terminator to the trace listeners in the Listeners collection if a condition is true.

Overload List

Writes a category name and the name of the value parameter followed by a line terminator to the trace listeners in the Listeners collection if a condition is true. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic] Overloads Public Shared Sub WriteLineIf(Boolean, Object, String)
[C#] public static void WriteLineIf(bool, Object, String);
[C++] public: static void WriteLineIf(bool, Object, String);
[JScript] public static function WriteLineIf(Boolean, Object, String);

Writes a message followed by a line terminator to the trace listeners in the Listeners collection if a condition is true. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic] Overloads Public Shared Sub WriteLineIf(Boolean, String)
[C#] public static void WriteLineIf(bool, String);
[C++] public: static void WriteLineIf(bool, String);
[JScript] public static function WriteLineIf(Boolean, String);

Writes the name of the value parameter followed by a line terminator to the trace listeners in the Listeners collection if a condition is true. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic] Overloads Public Shared Sub WriteLineIf(Boolean, Object)
[C#] public static void WriteLineIf(bool, Object);
[C++] public: static void WriteLineIf(bool, Object);
[JScript] public static function WriteLineIf(Boolean, Object);

Writes a category name and message followed by a line terminator to the trace listeners in the Listeners collection if a condition is true. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic] Overloads Public Shared Sub WriteLineIf(Boolean, String, String)
[C#] public static void WriteLineIf(bool, String, String);
[C++] public: static void WriteLineIf(bool, String, String);
[JScript] public static function WriteLineIf(Boolean, String, String);

See Also

Trace Class | Trace Members | System.Diagnostics Namespace


Trace.WriteLineIf (Boolean, Object, String)

Writes a category name and the name of the value parameter followed by a line terminator to the trace listeners in the Listeners collection if a condition is true. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic]
Overloads Public Shared Sub WriteLineIf( _
   ByVal condition As Boolean, _
   ByVal value As Object, _
   ByVal category As String _
)
[C#]
public static void WriteLineIf(
   bool condition,
   object value,
   string category
);
[C++]
public: static void WriteLineIf(
   bool condition,
   Object* value,
   String* category
);
[JScript]
public static function WriteLineIf(
   condition : Boolean,
   value : Object,
   category : String
);

Parameters

condition
A condition which if true will cause the message to be written.
value
An Object whose name is sent to the Listeners.
category
A category name to write.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

The category can be used to group output messages.

Notes to Implementers: You can minimize the performance penalty of instrumenting your application by using If...Then statements instead of using WriteIf statements. The following two code examples send the same debugging message. However, the first example is much faster when tracing is off, because if mySwitch.TraceError evaluates to false you do not call Write. The second example always calls WriteIf, even when mySwitch.TraceError is false and no tracing output is produced. This can result in unnecessary execution of an arbitrarily complex code.

First example.

if(mySwitch.TraceError)
   Trace.Write("aNumber = " + aNumber + " out of range");

Second example.

Trace.WriteIf(mySwitch.TraceError, "aNumber = " + aNumber + " out of range");

See Also

Trace Class | Trace Members | System.Diagnostics Namespace | Trace.WriteLineIf Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute


Trace.WriteLineIf (Boolean, String)

Writes a message followed by a line terminator to the trace listeners in the Listeners collection if a condition is true. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic]
Overloads Public Shared Sub WriteLineIf( _
   ByVal condition As Boolean, _
   ByVal message As String _
)
[C#]
public static void WriteLineIf(
   bool condition,
   string message
);
[C++]
public: static void WriteLineIf(
   bool condition,
   String* message
);
[JScript]
public static function WriteLineIf(
   condition : Boolean,
   message : String
);

Parameters

condition
A condition which if true will cause the message to be written.
message
A message to write.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

Notes to Implementers: You can minimize the performance penalty of instrumenting your application by using If...Then statements instead of using WriteIf statements. The following two code examples send the same debugging message. However, the first example is much faster when tracing is off, because if mySwitch.TraceError evaluates to false you do not call Write. The second example always calls WriteIf, even when mySwitch.TraceError is false and no tracing output is produced. This can result in unnecessary execution of an arbitrarily complex code.

First example.

if(mySwitch.TraceError)
   Trace.Write("aNumber = " + aNumber + " out of range");

Second example.

Trace.WriteIf(mySwitch.TraceError, "aNumber = " + aNumber + " out of range");

See Also

Trace Class | Trace Members | System.Diagnostics Namespace | Trace.WriteLineIf Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute


Trace.WriteLineIf (Boolean, Object)

Writes the name of the value parameter followed by a line terminator to the trace listeners in the Listeners collection if a condition is true. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic]
Overloads Public Shared Sub WriteLineIf( _
   ByVal condition As Boolean, _
   ByVal value As Object _
)
[C#]
public static void WriteLineIf(
   bool condition,
   object value
);
[C++]
public: static void WriteLineIf(
   bool condition,
   Object* value
);
[JScript]
public static function WriteLineIf(
   condition : Boolean,
   value : Object
);

Parameters

condition
A condition which if true will cause the message to be written.
value
An Object whose name is sent to the Listeners.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

Notes to Implementers: You can minimize the performance penalty of instrumenting your application by using If...Then statements instead of using WriteIf statements. The following two code examples send the same debugging message. However, the first example is much faster when tracing is off, because if mySwitch.TraceError evaluates to false you do not call Write. The second example always calls WriteIf, even when mySwitch.TraceError is false and no tracing output is produced. This can result in unnecessary execution of an arbitrarily complex code.

First example.

if(mySwitch.TraceError)
   Trace.Write("aNumber = " + aNumber + " out of range");

Second example.

Trace.WriteIf(mySwitch.TraceError, "aNumber = " + aNumber + " out of range");

See Also

Trace Class | Trace Members | System.Diagnostics Namespace | Trace.WriteLineIf Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute


Trace.WriteLineIf (Boolean, String, String)

Writes a category name and message followed by a line terminator to the trace listeners in the Listeners collection if a condition is true. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic]
Overloads Public Shared Sub WriteLineIf( _
   ByVal condition As Boolean, _
   ByVal message As String, _
   ByVal category As String _
)
[C#]
public static void WriteLineIf(
   bool condition,
   string message,
   string category
);
[C++]
public: static void WriteLineIf(
   bool condition,
   String* message,
   String* category
);
[JScript]
public static function WriteLineIf(
   condition : Boolean,
   message : String,
   category : String
);

Parameters

condition
A condition which if true will cause the message to be written.
message
A message to write.
category
A category name to write.

Remarks

By default, the output is written to the managed code debuggers, the Microsoft.Win32.Interop.Windows.OutputDebugString API and to the Log method.

The category can be used to group output messages.

Notes to Implementers: You can minimize the performance penalty of instrumenting your application by using If...Then statements instead of using WriteIf statements. The following two code examples send the same debugging message. However, the first example is much faster when tracing is off, because if mySwitch.TraceError evaluates to false you do not call Write. The second example always calls WriteIf, even when mySwitch.TraceError is false and no tracing output is produced. This can result in unnecessary execution of an arbitrarily complex code.

First example.

if(mySwitch.TraceError)
   Trace.Write("aNumber = " + aNumber + " out of range");

Second example.

Trace.WriteIf(mySwitch.TraceError, "aNumber = " + aNumber + " out of range");

See Also

Trace Class | Trace Members | System.Diagnostics Namespace | Trace.WriteLineIf Overload List | Debug | Trace | BooleanSwitch | TraceSwitch | TraceListener | DefaultTraceListener | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute | ConditionalAttribute


TraceLevel Enumeration

Specifies what messages to output for debugging and tracing.

[Visual Basic]
Public Enum TraceLevel
[C#]
public enum TraceLevel
[C++]
public enum TraceLevel

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

This enumeration is used by the TraceSwitch class.

Members

Member Name | Description
Error | Output error handling messages.
Info | Output informational messages, warnings and error handling messages.
Off | Does not output tracing and debugging messages.
Verbose | Output all debugging and tracing messages.
Warning | Output warnings and error handling messages.

Requirements

Namespace: System.Diagnostics

Assembly: System.dll

See Also

System.Diagnostics Namespace | Debug | Trace | TraceSwitch


TraceListener Class

Provides the abstract (in Visual Basic MustInherit) base class for the listeners who monitor trace and debug output.

Object
TraceListener

[Visual Basic]
MustInherit Public Class TraceListener
[C#]
public abstract class TraceListener
[C++]
public __gc __abstract class TraceListener
[JScript]
public abstract class TraceListener

Remarks

Notes to Inheritors: Inherit from this class to implement a custom listener for the Debug and Trace classes. At a minimum, you must override the Write and WriteLine methods. Additionally, you can override the Close and Flush methods.

For examples of how to implement a TraceListener, see the DefaultTraceListener and TextWriterTraceListener classes.

Requirements

Namespace: System.Diagnostics

Assembly: System.dll

See Also

TraceListener Members | System.Diagnostics Namespace | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListener Members

Public:

Properties

Indent | Gets or sets the indent level.
IndentSize | Gets or sets the number of spaces in an indent.
Name | Gets or sets a name for this TraceListener.

Methods

Close | When overridden in a derived class, closes the output stream so that it no longer receives tracing or debugging output.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Fail | Overloaded. Emits or displays a message for an assertion that always fails.
Flush | When overridden in a derived class, flushes the output buffer.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Overloaded. Writes a message, category name, or object name.
WriteLine | Overloaded. Writes a message, category name, or object name followed by a line terminator.

Protected:

Constructor

TraceListener Constructor Overloaded. [To be supplied.]

Properties

NeedIndent Gets or sets whether an indent is needed.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
WriteIndent | Writes the indent and resets the NeedIndent property to false.

See Also

TraceListener Class | System.Diagnostics Namespace


TraceListener Constructor

[To be supplied.]

Overload List

Initializes a new instance of the TraceListener class.

[Visual Basic] Overloads Protected Sub New()
[C#] protected TraceListener();
[C++] protected: TraceListener();
[JScript] protected function TraceListener();

Initializes a new instance of the TraceListener class.

[Visual Basic] Overloads Protected Sub New(String)
[C#] protected TraceListener(String);
[C++] protected: TraceListener(String*);
[JScript] protected function TraceListener(String);

See Also

TraceListener Class | TraceListener Members | System.Diagnostics Namespace


TraceListener Constructor ()

Initializes a new instance of the TraceListener class.

[Visual Basic]
Overloads Protected Sub New()
[C#]
protected TraceListener();
[C++]
protected: TraceListener();
[JScript]
protected function TraceListener();

See Also

TraceListener Class | TraceListener Members | System.Diagnostics Namespace | TraceListener Constructor Overload List | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListener Constructor (String)

Initializes a new instance of the TraceListener class.

[Visual Basic]
Overloads Protected Sub New( _
   ByVal name As String _
)
[C#]
protected TraceListener(
   string name
);
[C++]
protected: TraceListener(
   String* name
);
[JScript]
protected function TraceListener(
   name : String
);

Parameters

name
The name of the TraceListener.

See Also

TraceListener Class | TraceListener Members | System.Diagnostics Namespace | TraceListener Constructor Overload List | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TraceListener Properties

The properties of the TraceListener class are listed below. For a complete list of TraceListener class members, see the TraceListener Members topic.

Public:

Indent | Gets or sets the indent level.
IndentSize | Gets or sets the number of spaces in an indent.
Name | Gets or sets a name for this TraceListener.

Protected:

NeedIndent Gets or sets whether an indent is needed.

See Also

TraceListener Class | System.Diagnostics Namespace


TraceListener.Indent

Gets or sets the indent level.

[Visual Basic]
Public Property Indent As Integer
[C#]
public int Indent {get; set;}
[C++]
public: __property int get_Indent();
public: __property void set_Indent(int);
[JScript]
public function get Indent() : int;
public function set Indent(int);

Property Value

The indent level.

Remarks

The default is zero (0). This property is stored on per-thread/per-request basis.

See Also

TraceListener Class | TraceListener Members | System.Diagnostics Namespace | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListener.IndentSize

Gets or sets the number of spaces in an indent.

[Visual Basic]
Public Property IndentSize As Integer
[C#]
public int IndentSize {get; set;}
[C++]
public: __property int get_IndentSize();
public: __property void set_IndentSize(int);
[JScript]
public function get IndentSize() : int;
public function set IndentSize(int);

Property Value

The number of spaces in an indent.

Remarks

Default is four (4) spaces. The property is stored on per-thread/per-request basis.

See Also

TraceListener Class | TraceListener Members | System.Diagnostics Namespace | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListener.Name

Gets or sets a name for this TraceListener.

[Visual Basic]
Overridable Public Property Name As String
[C#]
public string Name {virtual get; virtual set;}
[C++]
public: __property virtual String* get_Name();
public: __property virtual void set_Name(String*);
[JScript]
public function get Name() : String;
public function set Name(String);

Property Value

A name for this TraceListener.

Remarks

The name can be used to organize and access listeners in a TraceListeners collection. The default is an empty string ("").

See Also

TraceListener Class | TraceListener Members | System.Diagnostics Namespace | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListener.NeedIndent

Gets or sets whether an indent is needed.

[Visual Basic]
Protected Property NeedIndent As Boolean
[C#]
protected bool NeedIndent {get; set;}
[C++]
protected: __property bool get_NeedIndent();
protected: __property void set_NeedIndent(bool);
[JScript]
protected function get NeedIndent() : Boolean;
protected function set NeedIndent(Boolean);

Property Value

true if an indent is needed; otherwise, false.

See Also

TraceListener Class | TraceListener Members | System.Diagnostics Namespace | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TraceListener Methods

The methods of the TraceListener class are listed below. For a complete list of TraceListener class members, see the TraceListener Members topic.

Public:

Close | When overridden in a derived class, closes the output stream so that it no longer receives tracing or debugging output.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Fail | Overloaded. Emits or displays a message for an assertion that always fails.
Flush | When overridden in a derived class, flushes the output buffer.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Overloaded. Writes a message, category name, or object name.
WriteLine | Overloaded. Writes a message, category name, or object name followed by a line terminator.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
WriteIndent | Writes the indent and resets the NeedIndent property to false.

See Also

TraceListener Class | System.Diagnostics Namespace


TraceListener.Close

When overridden in a derived class, closes the output stream so that it no longer receives tracing or debugging output.

[Visual Basic]
Overridable Public Sub Close()
[C#]
public virtual void Close();
[C++]
public: virtual void Close();
[JScript]
public function Close();

Remarks

Use this method when the output is going to a file such as to the TextWriterTraceListener. After a call to this method, you should reinitialize the object.

See Also

TraceListener Class | TraceListener Members | System.Diagnostics Namespace | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListener.Fail

Emits or displays a message for an assertion that always fails.

Overload List

Emits or displays a message for an assertion that always fails.

[Visual Basic] Overloads Overridable Public Sub Fail(String)
[C#] public virtual void Fail(String);
[C++] public: virtual void Fail(String*);
[JScript] public function Fail(String);

Emits or displays messages for an assertion that always fails.

[Visual Basic] Overloads Overridable Public Sub Fail(String, String)
[C#] public virtual void Fail(String, String);
[C++] public: virtual void Fail(String*, String*);
[JScript] public function Fail(String, String);

See Also

TraceListener Class | TraceListener Members | System.Diagnostics Namespace


TraceListener.Fail (String)

Emits or displays a message for an assertion that always fails.

[Visual Basic]
Overloads Overridable Public Sub Fail( _
   ByVal message As String _
)
[C#]
public virtual void Fail(
   string message
);
[C++]
public: virtual void Fail(
   String* message
);
[JScript]
public function Fail(
   message : String
);

Parameters

message
A message to emit or display.

Remarks

The default behavior is to output the message to a message box when the application is running in a user interface mode, and to the TraceListener instances in a TraceListeners collection. By default, the TraceListeners collection has an instance of a DefaultTraceListener. You can customize this behavior by adding a TraceListener to or removing one from the collection.

See Also

TraceListener Class | TraceListener Members | System.Diagnostics Namespace | TraceListener.Fail Overload List | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListener.Fail (String, String)

Emits or displays messages for an assertion that always fails.

[Visual Basic]
Overloads Overridable Public Sub Fail( _
   ByVal message As String, _
   ByVal detailMessage As String _
)
[C#]
public virtual void Fail(
   string message,
   string detailMessage
);
[C++]
public: virtual void Fail(
   String* message,
   String* detailMessage
);
[JScript]
public function Fail(
   message : String,
   detailMessage : String
);

Parameters

message
A message to emit or display.
detailMessage
A detailed message to emit or display.

Remarks

The default behavior is to output the message and detailedMessage to a message box when the application is running in a user interface mode, and to the TraceListener instances in a TraceListeners collection. By default, the TraceListeners collection has an instance of a DefaultTraceListener. You can customize this behavior by adding a TraceListener to or removing one from the collection.

See Also

TraceListener Class | TraceListener Members | System.Diagnostics Namespace | TraceListener.Fail Overload List | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListener.Flush

When overridden in a derived class, flushes the output buffer.

[Visual Basic]
Overridable Public Sub Flush()
[C#]
public virtual void Flush();
[C++]
public: virtual void Flush();
[JScript]
public function Flush();

See Also

TraceListener Class | TraceListener Members | System.Diagnostics Namespace | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListener.Write

Writes a message, category name, or object name.

Overload List

Writes a category name and the name of the o parameter.

[Visual Basic] Overloads Overridable Public Sub Write(Object, String)
[C#] public virtual void Write(Object, String);
[C++] public: virtual void Write(Object*, String);
[JScript] public function Write(Object, String);

Writes a category name and a message.

[Visual Basic] Overloads Overridable Public Sub Write(String, String)
[C#] public virtual void Write(String, String);
[C++] public: virtual void Write(String*, String*);
[JScript] public function Write(String, String);

When overridden in a derived class, writes the message.

[Visual Basic] Overloads MustOverride Public Sub Write(String)
[C#] public abstract void Write(String);
[C++] public: virtual void Write(String*) = 0;
[JScript] public abstract function Write(String);

Writes the name of the o parameter.

[Visual Basic] Overloads Overridable Public Sub Write(Object)
[C#] public virtual void Write(Object);
[C++] public: virtual void Write(Object*);
[JScript] public function Write(Object);

See Also

TraceListener Class | TraceListener Members | System.Diagnostics Namespace


TraceListener.Write (Object, String)

Writes a category name and the name of the o parameter.

[Visual Basic]
Overloads Overridable Public Sub Write( _
   ByVal o As Object, _
   ByVal category As String _
)
[C#]
public virtual void Write(
   object o,
   string category
);
[C++]
public: virtual void Write(
   Object* o,
   String* category
);
[JScript]
public function Write(
   o : Object,
   category : String
);

Parameters

o
An Object whose name you want to write.
category
A category name to write.

See Also

TraceListener Class | TraceListener Members | System.Diagnostics Namespace | TraceListener.Write Overload List | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListener.Write (String, String)

Writes a category name and a message.

[Visual Basic]
Overloads Overridable Public Sub Write( _
   ByVal message As String, _
   ByVal category As String _
)
[C#]
public virtual void Write(
   string message,
   string category
);
[C++]
public: virtual void Write(
   String* message,
   String* category
);
[JScript]
public function Write(
   message : String,
   category : String
);

Parameters

message
A message to write.
category
A category name to write.

See Also

TraceListener Class | TraceListener Members | System.Diagnostics Namespace | TraceListener.Write Overload List | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListener.Write (String)

When overridden in a derived class, writes the message.

[Visual Basic]
Overloads MustOverride Public Sub Write( _
   ByVal message As String _
)
[C#]
public abstract void Write(
   string message
);
[C++]
public: virtual void Write(
   String* message
) = 0;
[JScript]
public abstract function Write(
   message : String
);

Parameters

message
A message to write.

Remarks

Notes to Inheritors: When inheriting from this class, you must override this method. To support an indentation, you should call WriteIndent if NeedIndent is true. If you need to indent the following line, you must reset NeedIndent to true.

See Also

TraceListener Class | TraceListener Members | System.Diagnostics Namespace | TraceListener.Write Overload List | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListener.Write (Object)

Writes the name of the o parameter.

[Visual Basic]
Overloads Overridable Public Sub Write( _
   ByVal o As Object _
)
[C#]
public virtual void Write(
   object o
);
[C++]
public: virtual void Write(
   Object* o
);
[JScript]
public function Write(
   o : Object
);

Parameters

o
An Object whose name you want to write.

See Also

TraceListener Class | TraceListener Members | System.Diagnostics Namespace | TraceListener.Write Overload List | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListener.WriteIndent

Writes the indent and resets the NeedIndent property to false.

[Visual Basic]
Overridable Protected Sub WriteIndent()
[C#]
protected virtual void WriteIndent();
[C++]
protected: virtual void WriteIndent();
[JScript]
protected function WriteIndent();

Remarks

Writes the indent and resets NeedIndent to false. Call this method if NeedIndent is true, when you are overloading Write and WriteLine. By default this method uses blank spaces for indentation.

See Also

TraceListener Class | TraceListener Members | System.Diagnostics Namespace | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListener.WriteLine

Writes a message, category name, or object name followed by a line terminator.

Overload List

Writes a category name and a message followed by a line terminator. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic] Overloads Overridable Public Sub WriteLine(String, String)
[C#] public virtual void WriteLine(String, String);
[C++] public: virtual void WriteLine(String*, String*);
[JScript] public function WriteLine(String, String);

Writes a category name and the name of the o

parameter followed by a line terminator. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic] Overloads Overridable Public Sub WriteLine(Object, String)
[C#] public virtual void WriteLine(Object, String);
[C++] public: virtual void WriteLine(Object*, String);
[JScript] public function WriteLine(Object, String);

When overridden in a dervied class, writes a message followed by a line terminator. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic] Overloads MustOverride Public Sub WriteLine(String)
[C#] public abstract void WriteLine(String);
[C++] public: virtual void WriteLine(String*) = 0;
[JScript] public abstract function WriteLine(String);

Writes the name of the o parameter followed by a line terminator. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic] Overloads Overridable Public Sub WriteLine(Object)
[C#] public virtual void WriteLine(Object);
[C++] public: virtual void WriteLine(Object*);
[JScript] public function WriteLine(Object);

See Also

TraceListener Class | TraceListener Members | System.Diagnostics Namespace


TraceListener.WriteLine (String, String)

Writes a category name and a message followed by a line terminator. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic]
Overloads Overridable Public Sub WriteLine( _
   ByVal message As String, _
   ByVal category As String _
)
[C#]
public virtual void WriteLine(
   string message,
   string category
);
[C++]
public: virtual void WriteLine(
   String* message,
   String* category
);
[JScript]
public function WriteLine(
   message : String,
   category : String
);

Parameters

message
A message to write.
category
A category name to write.

See Also

TraceListener Class | TraceListener Members | System.Diagnostics Namespace | TraceListener.WriteLine Overload List | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListener.WriteLine (Object, String)

Writes a category name and the name of the o

parameter followed by a line terminator. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic]
Overloads Overridable Public Sub WriteLine( _
   ByVal o As Object, _
   ByVal category As String _
)
[C#]
public virtual void WriteLine(
   object o,
   string category
);
[C++]
public: virtual void WriteLine(
   Object* o,
   String* category
);
[JScript]
public function WriteLine(
   o : Object,
   category : String
);

Parameters

o
An Object whose name you want to write.
category
A category name to write.

See Also

TraceListener Class | TraceListener Members | System.Diagnostics Namespace | TraceListener.WriteLine Overload List | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListener.WriteLine (String)

When overridden in a dervied class, writes a message followed by a line terminator. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic]
Overloads MustOverride Public Sub WriteLine( _
   ByVal message As String _
)
[C#]
public abstract void WriteLine(
   string message
);
[C++]
public: virtual void WriteLine(
   String* message
) = 0;
[JScript]
public abstract function WriteLine(
   message : String
);

Parameters

message
A message to write.

Remarks

Notes to Inheritors: When inheriting from this class, you must override this method. To support an indentation, you should call WriteIndent if NeedIndent is true. If you need to indent the following line, you must reset NeedIndent to true.

See Also

TraceListener Class | TraceListener Members | System.Diagnostics Namespace | TraceListener.WriteLine Overload List | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListener.WriteLine (Object)

Writes the name of the o parameter followed by a line terminator. The default line terminator is a carriage return followed by a line feed ("\r\n").

[Visual Basic]
Overloads Overridable Public Sub WriteLine( _
   ByVal o As Object _
)
[C#]
public virtual void WriteLine(
   object o
);
[C++]
public: virtual void WriteLine(
   Object* o
);
[JScript]
public function WriteLine(
   o : Object
);

Parameters

o
An Object whose name you want to write.

See Also

TraceListener Class | TraceListener Members | System.Diagnostics Namespace | TraceListener.WriteLine Overload List | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListeners Class

Provides a thread-safe list of TraceListeners. A thread-safe list is synchronized.

Object
TraceListeners

[Visual Basic]
Public Class TraceListeners
   Implements IList, ICollection, IEnumerable
[C#]
public class TraceListeners : IList, ICollection, IEnumerable
[C++]
public __gc class TraceListeners : public IList, ICollection,
   IEnumerable
[JScript]
public class TraceListeners implements IList, ICollection,
   IEnumerable

Remarks

This list is thread-safe because the accessors and the enumerator do not take synchronization locks. Methods like Add, Remove, and Clear atomically modify the list.

The TraceListeners class provides the following properties for information about the list: Count, IsReadOnly, SyncRoot, IsSynchronized. It also provides the following methods: Contains, GetEnumerator, IndexOf,

This class also provides the following methods to modify the list: Add, Clear, Insert, and Remove. The CopyTo method copies a part of the list to an array. The RemoveAt method deletes the list member at a specified index number.

Requirements

Namespace: System.Diagnostics

Assembly: System.dll

See Also

TraceListeners Members | System.Diagnostics Namespace | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListeners Members

Public:

Properties

Count | Gets the number of listeners in the list.
IsReadOnly | Gets whether the list is read-only.
IsSynchronized | Gets whether this list is synchronized. A synchronized list is thread-safe.
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the TraceListeners class.
SyncRoot | Gets an object that can be used to synchronize access to the list.

Methods

Add | Adds a TraceListener to the list.
Clear | Clears all the listeners from the list.
Contains | Checks whether the list contains the specified listener.
CopyTo | Copies a section of the current TraceListeners list to the specified array at the specified index.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Gets an enumerator for this list.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | [To be supplied.]
Insert | Inserts the listener at the specified index.
Remove | Overloaded. Removes the specified TraceListener from the list.
RemoveAt | Removes the TraceListener at the specified index.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TraceListeners Class | System.Diagnostics Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TraceListeners Properties

The properties of the TraceListeners class are listed below. For a complete list of TraceListeners class members, see the TraceListeners Members topic.

Public:

Count | Gets the number of listeners in the list.
IsReadOnly | Gets whether the list is read-only.
IsSynchronized | Gets whether this list is synchronized. A synchronized list is thread-safe.
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the TraceListeners class.
SyncRoot | Gets an object that can be used to synchronize access to the list.

See Also

TraceListeners Class | System.Diagnostics Namespace


TraceListeners.Count

Gets the number of listeners in the list.

[Visual Basic]
Overridable Public ReadOnly Property Count As Integer
[C#]
public int Count {virtual get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;

Property Value

The number of listeners in the list.

Remarks

The Count property can be used to set the limits of a loop that iterates through a list of objects. If the list is zero-based, be sure to use "Count- 1" as the upper bound of the loop.

See Also

TraceListeners Class | TraceListeners Members | System.Diagnostics Namespace | TraceListeners | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListeners.IsReadOnly

Gets whether the list is read-only.

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {virtual get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;

Property Value

true if the list is read-only; otherwise, false.

See Also

TraceListeners Class | TraceListeners Members | System.Diagnostics Namespace | TraceListeners | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListeners.IsSynchronized

Gets whether this list is synchronized. A synchronized list is thread-safe.

[Visual Basic]
Overridable Public ReadOnly Property IsSynchronized As Boolean
[C#]
public bool IsSynchronized {virtual get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;

Property Value

true if the list is synchronized; otherwise, false.

Remarks

This list is synchronized. Therefore this property always returns true.

See Also

TraceListeners Class | TraceListeners Members | System.Diagnostics Namespace | TraceListeners | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListeners.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the TraceListeners class.

Overload List

Gets the first TraceListener in the list with the specified name.

[Visual Basic] Overloads Public Default ReadOnly Property Item(String) As TraceListener
[C#] public TraceListener this[String] {get;}
[C++] public: __property TraceListener* get_Item(String*);
[JScript] TraceListeners.Item (String)

Gets or sets the TraceListener at the specified index.

[Visual Basic] Overloads Public Default Property Item(Integer) As TraceListener
[C#] public TraceListener this[int] {get; set;}
[C++] public: __property TraceListener* get_Item(int);
public: __property void set_Item(int, TraceListener*);
[JScript] TraceListeners.Item (int)

See Also

TraceListeners Class | TraceListeners Members | System.Diagnostics Namespace


TraceListeners.Item (String)

Gets the first TraceListener in the list with the specified name.

[C#] In C#, this member is the indexer for the TraceListeners class.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
   ByVal name As String _
) As TraceListener
[C#]
public TraceListener this[
   string name
] {get;}
[C++]
public: __property TraceListener* get_Item(
   String* name
);
[JScript]
returnValue = TraceListenersObject.Item(name);
-or-
returnValue = TraceListenersObject(name);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
The name of the TraceListener to get from the list.

Parameters [Visual Basic, C#, C++]

name
The name of the TraceListener to get from the list.

Property Value

The first TraceListener in the list with the given name. This item returns a null reference (in Visual Basic Nothing) if no TraceListener with the given name can be found.

Remarks

The Item property (TraceListeners indexer) is case-sensitive when searching for names. That is, if two listeners exist with the names "Lname" and "lname," Item property (TraceListeners indexer) will find the specific listener you name.

See Also

TraceListeners Class | TraceListeners Members | System.Diagnostics Namespace | TraceListeners.Item Overload List | TraceListeners | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListeners.Item (Int32)

Gets or sets the TraceListener at the specified index.

[C#] In C#, this member is the indexer for the TraceListeners class.

[Visual Basic]
Overloads Public Default Property Item( _
   ByVal i As Integer _
) As TraceListener
[C#]
public TraceListener this[
   int i
] {get; set;}
[C++]
public: __property TraceListener* get_Item(
   int i
);
public: __property void set_Item(
   int i,
   TraceListener*
);
[JScript]
returnValue = TraceListenersObject.Item(i);
TraceListenersObject.Item(i) = returnValue;
-or-
returnValue = TraceListenersObject(i);
TraceListenersObject(i) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

i
The zero-based index of the TraceListener to get from the list.

Parameters [Visual Basic, C#, C++]

i
The zero-based index of the TraceListener to get from the list.

Property Value

A TraceListener with the specified index.

Remarks

The index is zero-based. Therefore, you must subtract one (1) from the numerical position of a particular TraceListener to access that TraceListener. For example, to get the third TraceListener, you need to specify System.ComponentModel.TraceListeners.this (2).

See Also

TraceListeners Class | TraceListeners Members | System.Diagnostics Namespace | TraceListeners.Item Overload List | TraceListeners | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListeners.SyncRoot

Gets an object that can be used to synchronize access to the list.

[Visual Basic]
Overridable Public ReadOnly Property SyncRoot As Object
[C#]
public object SyncRoot {virtual get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;

Property Value

An Object that can be used to synchronize access to the list.

Remarks

This list is synchronized. Therefore, this property gets the current System.Diagnostics.TraceListerners.

See Also

TraceListeners Class | TraceListeners Members | System.Diagnostics Namespace | TraceListeners | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TraceListeners Methods

The methods of the TraceListeners class are listed below. For a complete list of TraceListeners class members, see the TraceListeners Members topic.

Public:

Add | Adds a TraceListener to the list.
Clear | Clears all the listeners from the list.
Contains | Checks whether the list contains the specified listener.
CopyTo | Copies a section of the current TraceListeners list to the specified array at the specified index.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Gets an enumerator for this list.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | [To be supplied.]
Insert | Inserts the listener at the specified index.
Remove | Overloaded. Removes the specified TraceListener from the list.
RemoveAt | Removes the TraceListener at the specified index.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TraceListeners Class | System.Diagnostics Namespace


TraceListeners.Add

Adds a TraceListener to the list.

[Visual Basic]
Public Function Add( _
   ByVal listener As TraceListener _
) As Integer
[C#]
public int Add(
   TraceListener listener
);
[C++]
public: int Add(
   TraceListener* listener
);
[JScript]
public function Add(
   listener : TraceListener
) : int;

Parameters

listener
A TraceListener that you want to add to the list.

Return Value

The position at which the new listener was inserted.

See Also

TraceListeners Class | TraceListeners Members | System.Diagnostics Namespace | TraceListeners | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListeners.Clear

Clears all the listeners from the list.

[Visual Basic]
Overridable Public Sub Clear()
[C#]
public virtual void Clear();
[C++]
public: virtual void Clear();
[JScript]
public function Clear();

See Also

TraceListeners Class | TraceListeners Members | System.Diagnostics Namespace | TraceListeners | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListeners.Contains

Checks whether the list contains the specified listener.

[Visual Basic]
Public Function Contains( _
   ByVal listener As TraceListener _
) As Boolean
[C#]
public bool Contains(
   TraceListener listener
);
[C++]
public: bool Contains(
   TraceListener* listener
);
[JScript]
public function Contains(
   listener : TraceListener
) : Boolean;

Parameters

listener
A System.TraceListener that you want to find in the list.

Return Value

true if the listener is in the list; otherwise, false.

Remarks

The Contains method can be used to confirm the existence of a TraceListener before performing further operations.

See Also

TraceListeners Class | TraceListeners Members | System.Diagnostics Namespace | TraceListeners | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListeners.CopyTo

Copies a section of the current TraceListeners list to the specified array at the specified index.

[Visual Basic]
Overridable Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
[C#]
public virtual void CopyTo(
   Array array,
   int index
);
[C++]
public: virtual void CopyTo(
   Array* array,
   int index
);
[JScript]
public function CopyTo(
   array : Array,
   index : int
);

Parameters

array
An array of type Array to copy the elements into.
index
The starting index number in the current list to copy from.

See Also

TraceListeners Class | TraceListeners Members | System.Diagnostics Namespace | TraceListeners | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListeners.GetEnumerator

Gets an enumerator for this list.

[Visual Basic]
Overridable Public Function GetEnumerator() As IEnumerator
[C#]
public virtual IEnumerator GetEnumerator();
[C++]
public: virtual IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

Return Value

An enumerator of type IEnumerator.

See Also

TraceListeners Class | TraceListeners Members | System.Diagnostics Namespace | TraceListeners | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListeners.IndexOf

[To be supplied.]

[Visual Basic]
Public Function IndexOf( _
   ByVal listener As TraceListener _
) As Integer
[C#]
public int IndexOf(
   TraceListener listener
);
[C++]
public: int IndexOf(
   TraceListener* listener
);
[JScript]
public function IndexOf(
   listener : TraceListener
) : int;

Parameters

listener
[To be supplied.]

See Also

TraceListeners Class | TraceListeners Members | System.Diagnostics Namespace


TraceListeners.Insert

Inserts the listener at the specified index.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal listener As TraceListener _
)
[C#]
public void Insert(
   int index,
   TraceListener listener
);
[C++]
public: void Insert(
   int index,
   TraceListener* listener
);
[JScript]
public function Insert(
   index : int,
   listener : TraceListener
);

Parameters

index
The position in the list that you want to insert the listener.
listener
A TraceListener to insert in the list.

Remarks

If index equals the number of items in the list, then the listener is appended to the end of the list.

The index is zero-based. Therefore, if you want the insert the listener into the third position, you must call Insert (2).

See Also

TraceListeners Class | TraceListeners Members | System.Diagnostics Namespace | TraceListeners | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListeners.Remove

Removes the specified TraceListener from the list.

Overload List

Removes the first listener in the list that has the specified name.

[Visual Basic] Overloads Public Sub Remove(String)
[C#] public void Remove(String);
[C++] public: void Remove(String*);
[JScript] public function Remove(String);

Removes the specified instance of the TraceListener class from the list.

[Visual Basic] Overloads Public Sub Remove(TraceListener)
[C#] public void Remove(TraceListener);
[C++] public: void Remove(TraceListener*);
[JScript] public function Remove(TraceListener);

See Also

TraceListeners Class | TraceListeners Members | System.Diagnostics Namespace


TraceListeners.Remove (String)

Removes the first listener in the list that has the specified name.

[Visual Basic]
Overloads Public Sub Remove( _
   ByVal name As String _
)
[C#]
public void Remove(
   string name
);
[C++]
public: void Remove(
   String* name
);
[JScript]
public function Remove(
   name : String
);

Parameters

name
The name of the TraceListener that you want to remove from the list.

Remarks

The name is case-sensitive. That is, if two listeners exist with the names "Rname" and "rname," the System.TraceListeners.Remove method will find the specific listener you name.

See Also

TraceListeners Class | TraceListeners Members | System.Diagnostics Namespace | TraceListeners.Remove Overload List | TraceListeners | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListeners.Remove (TraceListener)

Removes the specified instance of the TraceListener class from the list.

[Visual Basic]
Overloads Public Sub Remove( _
   ByVal listener As TraceListener _
)
[C#]
public void Remove(
   TraceListener listener
);
[C++]
public: void Remove(
   TraceListener* listener
);
[JScript]
public function Remove(
   listener : TraceListener
);

Parameters

listener
A TraceListener that you want to remove from the list.

See Also

TraceListeners Class | TraceListeners Members | System.Diagnostics Namespace | TraceListeners.Remove Overload List | TraceListeners | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceListeners.RemoveAt

Removes the TraceListener at the specified index.

[Visual Basic]
Overridable Public Sub RemoveAt( _
   ByVal index As Integer _
)
[C#]
public virtual void RemoveAt(
   int index
);
[C++]
public: virtual void RemoveAt(
   int index
);
[JScript]
public function RemoveAt(
   index : int
);

Parameters

index
The zero-based index of the TraceListener you want to remove from the list.

Remarks

The index is zero-based. Therefore, you must subtract one from the numerical position of a particular TraceListener to delete that TraceListener. For example, to remove the third TraceListener, you need to specify RemoveAt (2).

See Also

TraceListeners Class | TraceListeners Members | System.Diagnostics Namespace | TraceListeners | TraceListener | DefaultTraceListener | TextWriterTraceListener | Debug | Trace


TraceSwitch Class

Provides a multi-level switch to enable or disable tracing and debug output for a compiled application or framework.

Object
Switch
TraceSwitch

[Visual Basic]
Public Class TraceSwitch
   Inherits Switch
[C#]
public class TraceSwitch : Switch
[C++]
public __gc class TraceSwitch : public Switch
[JScript]
public class TraceSwitch extends Switch

Remarks

You can use the trace levels to filter out messages based on their importance. The switch can be enabled or disabled from code, from an environment variable, from a registry setting, or from a debug configuration file.

When the System.Diagnostics.TraceSwitch constructor cannot find initial switch settings in the registry or in environmental variables, the Level of the new switch is set to Off.

To specify the TraceLevel of the switch, call the Level property with one of the TraceLevel enumeration values. The Level also can be set by an external setting file. Setting the Level property updates the other properties in this class.

The following properties test the TraceLevel of the switch:

  • TraceError
  • TraceWarning
  • TraceInfo
  • TraceVerbose

For more information on instrumenting your application, see <DebugTopicTBD>.

Requirements

Namespace: System.Diagnostics

Assembly: System.dll

Example [Visual Basic]

The following example creates a new TraceSwitch. It checks the switch level before outputting debugging messages.

[Visual Basic]

Dim arithmeticSwitch As TraceSwitch
Assign arithmeticSwitch = New TraceSwitch("arithmeticSwitch","tracing arithmetic operations")
...
If b = 0 Then
   DivideIntegers = 0;
   If arithmeticSwitch.OutputError Then
      Debug.WriteLine "division by zero in DivideIntegers"
   Exit Function
End If
DivideIntegers = a/b
If arithmeticSwitch.OutputVerbose Then
   Debug.WriteLine "DivideIntegers resulted in " & a/b
End If

See Also

TraceSwitch Members | System.Diagnostics Namespace | Switch | BooleanSwitch | TraceLevel | Debug | Trace


TraceSwitch Members

Public:

Constructor

TraceSwitch Constructor Initializes a new instance of the TraceSwitch class.

Properties

Description (inherited from Switch) | Gets a description of the switch.
DisplayName (inherited from Switch) | Gets a name used to identify the switch. This name can be displayed on a user interface.
Level | Gets or sets the trace level which specifies what messages to output for tracing and debugging.
TraceError | Gets a value indicating whether the Level is set to Error, Warning, Info, or Verbose.
TraceInfo | Gets a value indicating whether the Level is set to Info or Verbose.
TraceVerbose | Gets a value indicating whether the Level is set to Verbose.
TraceWarning | Gets a value indicating whether the Level is set to Warning, Info, or Verbose.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TraceSwitch Class | System.Diagnostics Namespace


TraceSwitch Constructor

Initializes a new instance of the TraceSwitch class.

[Visual Basic]
Public Sub New( _
   ByVal displayName As String, _
   ByVal description As String _
)
[C#]
public TraceSwitch(
   string displayName,
   string description
);
[C++]
public: TraceSwitch(
   String* displayName,
   String* description
);
[JScript]
public function TraceSwitch(
   displayName : String,
   description : String
);

Parameters

displayName
A name to display on a user interface.
description
A description of the switch.

Remarks

When a TraceSwitch is instantiated, the displayName is used to find initial switch settings in the registry or in environmental variables. If the constructor cannot find initial settings, the Level is set to Off. To specify the TraceLevel, call the Level property with one of the TraceLevel enumeration values.

The level also can be set by an external setting file.

See Also

TraceSwitch Class | TraceSwitch Members | System.Diagnostics Namespace | TraceSwitch | TraceLevel | Switch | Debug | Trace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TraceSwitch Properties

The properties of the TraceSwitch class are listed below. For a complete list of TraceSwitch class members, see the TraceSwitch Members topic.

Public:

Description (inherited from Switch) | Gets a description of the switch.
DisplayName (inherited from Switch) | Gets a name used to identify the switch. This name can be displayed on a user interface.
Level | Gets or sets the trace level which specifies what messages to output for tracing and debugging.
TraceError | Gets a value indicating whether the Level is set to Error, Warning, Info, or Verbose.
TraceInfo | Gets a value indicating whether the Level is set to Info or Verbose.
TraceVerbose | Gets a value indicating whether the Level is set to Verbose.
TraceWarning | Gets a value indicating whether the Level is set to Warning, Info, or Verbose.

See Also

TraceSwitch Class | System.Diagnostics Namespace


TraceSwitch.Level

Gets or sets the trace level which specifies what messages to output for tracing and debugging.

[Visual Basic]
Public Property Level As TraceLevel
[C#]
public TraceLevel Level {get; set;}
[C++]
public: __property TraceLevel get_Level();
public: __property void set_Level(TraceLevel);
[JScript]
public function get Level() : TraceLevel;
public function set Level(TraceLevel);

Property Value

One of the TraceLevel values that specifies what messages to output for tracing and debugging.

Exceptions

Exception Type | Condition
ArgumentException | Setting the level to a value not in the TraceLevel enumeration.

Remarks

The default value is Off. The level can be set by an external setting file.

Setting this property will update the TraceError, TraceWarning, TraceInfo, and TraceVerbose properties in this class.

See Also

TraceSwitch Class | TraceSwitch Members | System.Diagnostics Namespace | TraceSwitch | TraceLevel | Switch | Debug | Trace


TraceSwitch.TraceError

Gets a value indicating whether the Level is set to Error, Warning, Info, or Verbose.

[Visual Basic]
Public ReadOnly Property TraceError As Boolean
[C#]
public bool TraceError {get;}
[C++]
public: __property bool get_TraceError();
[JScript]
public function get TraceError() : Boolean;

Property Value

true if the Level is set to Error, Warning, Info, or Verbose; otherwise, false.

Remarks

When the Level is set to Error, only error handling messages are output. When the Level is set to Warning, Info, or Verbose, additional tracing or debugging messages are output.

See Also

TraceSwitch Class | TraceSwitch Members | System.Diagnostics Namespace | TraceSwitch | Switch | TraceLevel | Debug | Trace


TraceSwitch.TraceInfo

Gets a value indicating whether the Level is set to Info or Verbose.

[Visual Basic]
Public ReadOnly Property TraceInfo As Boolean
[C#]
public bool TraceInfo {get;}
[C++]
public: __property bool get_TraceInfo();
[JScript]
public function get TraceInfo() : Boolean;

Property Value

true if the Level is set to Info or Verbose; otherwise, false.

Remarks

When the Level is set to Warning, informational messages, warnings and error handling messages are output. When the Level is set to Verbose, additional tracing or debugging messages are output.

See Also

TraceSwitch Class | TraceSwitch Members | System.Diagnostics Namespace | TraceSwitch | Switch | TraceLevel | Debug | Trace


TraceSwitch.TraceVerbose

Gets a value indicating whether the Level is set to Verbose.

[Visual Basic]
Public ReadOnly Property TraceVerbose As Boolean
[C#]
public bool TraceVerbose {get;}
[C++]
public: __property bool get_TraceVerbose();
[JScript]
public function get TraceVerbose() : Boolean;

Property Value

true if the Level is set to Verbose; otherwise, false.

Remarks

When the Level is set to Verbose, all debugging and tracing messages are output.

See Also

TraceSwitch Class | TraceSwitch Members | System.Diagnostics Namespace | TraceSwitch | Switch | TraceLevel | Debug | Trace


TraceSwitch.TraceWarning

Gets a value indicating whether the Level is set to Warning, Info, or Verbose.

[Visual Basic]
Public ReadOnly Property TraceWarning As Boolean
[C#]
public bool TraceWarning {get;}
[C++]
public: __property bool get_TraceWarning();
[JScript]
public function get TraceWarning() : Boolean;

Property Value

true if the Level is set to Warning, Info, or Verbose; otherwise, false.

Remarks

When the Level is set to Warning, warnings and error handling messages are output. When the Level is set to Info, or Verbose, additional tracing or debugging messages are output.

See Also

TraceSwitch Class | TraceSwitch Members | System.Diagnostics Namespace | TraceSwitch | Switch | TraceLevel | Debug | Trace


System.Diagnostics.SymbolStore

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Diagnostics.SymbolStore Namespace

Classes

Class | Description
SymDocumentType | Holds the public GUIDs for document types to be used with the symbol store.
SymLanguageType | Holds the public GUIDs for language types to be used with the symbol store.
SymLanguageVendor | Holds the public GUIDs for language vendors to be used with the symbol store.

Interfaces

Interface | Description
ISymbolBinder | Represents a symbol binder for managed code.
ISymbolDocument | Represents a document referenced by a symbol store.
ISymbolDocumentWriter | Represents a document referenced by a symbol store.
ISymbolMethod | Represents a method within a symbol reader.
ISymbolNamespace | Represents a namespace within a symbol reader.
ISymbolReader | Represents a symbol reader for managed code.
ISymbolScope | Represents a lexical scope within IsymMethod, providing access to the start and end offsets of the scope, as well as its child and parent scopes.
ISymbolVariable | Represents a symbol within a symbol store.
ISymbolWriter | Represents a symbol writer for managed code.

Structures

Structure | Description
SymbolToken | Provides an opaque representation of the token used and returned by the metadata.

Enumerations

Enumeration | Description
SymAddressKind | Specifies address types for local variables, parameters, and fields in the methods DefineLocalVariable, DefineParameter, and DefineField.


ISymbolBinder Interface

Represents a symbol binder for managed code.

ISymbolBinder

[Visual Basic]
Public Interface ISymbolBinder
[C#]
public interface ISymbolBinder
[C++]
public __gc __interface ISymbolBinder

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics.SymbolStore

Assembly: mscorlib.dll

See Also

ISymbolBinder Members | System.Diagnostics.SymbolStore Namespace


ISymbolBinder Members

Methods

GetReader Gets the interface for the symbol reader for the current file.

See Also

ISymbolBinder Interface | System.Diagnostics.SymbolStore Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ISymbolBinder Methods

The methods of the ISymbolBinder interface are listed below. For a complete list of ISymbolBinder interface members, see the ISymbolBinder Members topic.

GetReader Gets the interface for the symbol reader for the current file.

See Also

ISymbolBinder Interface | System.Diagnostics.SymbolStore Namespace


ISymbolBinder.GetReader

Gets the interface for the symbol reader for the current file.

[Visual Basic]
Function GetReader( _
   ByVal importer As Integer, _
   ByVal filename As String, _
   ByVal searchPath As String _
) As ISymbolReader
[C#]
ISymbolReader GetReader(
   int importer,
   string filename,
   string searchPath
);
[C++]
ISymbolReader* GetReader(
   int importer,
   String* filename,
   String* searchPath
) = 0;
[JScript]
function GetReader(
   importer : int,
   filename : String,
   searchPath : String
) : ISymbolReader;

Parameters

importer
[To be supplied.]
filename
[To be supplied.]
searchPath
[To be supplied.]

Remarks

To be supplied

See Also

ISymbolBinder Interface | ISymbolBinder Members | System.Diagnostics.SymbolStore Namespace


ISymbolDocument Interface

Represents a document referenced by a symbol store.

ISymbolDocument

[Visual Basic]
Public Interface ISymbolDocument
[C#]
public interface ISymbolDocument
[C++]
public __gc __interface ISymbolDocument

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

A document is defined by a URL and a document type GUID. Using the document type GUID and the URL, you can locate the document however it is stored. Document source can optionally be stored in the symbol store.

This interface also provides access to that source if it is present.

Requirements

Namespace: System.Diagnostics.SymbolStore

Assembly: mscorlib.dll

See Also

ISymbolDocument Members | System.Diagnostics.SymbolStore Namespace


ISymbolDocument Members

Properties

CheckSumAlgorithmId | Gets the checksum algorithm identifier.
DocumentType | Gets the type of the current document.
HasEmbeddedSource | Checks whether the current document is stored in the symbol store.
Language | Gets the language of the current document.
LanguageVendor | Gets the language vendor of the current document.
SourceLength | Gets the length, in bytes, of the embedded source.
URL | Gets the URL of the current document.

Methods

FindClosestLine | Returns the closest line that is a sequence point, given a line in the current document that may or may not be a sequence point.
GetCheckSum | Gets the checksum.
GetSourceRange | Gets the embedded document source for the specified range.

See Also

ISymbolDocument Interface | System.Diagnostics.SymbolStore Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ISymbolDocument Properties

The properties of the ISymbolDocument interface are listed below. For a complete list of ISymbolDocument interface members, see the ISymbolDocument Members topic.

CheckSumAlgorithmId | Gets the checksum algorithm identifier.
DocumentType | Gets the type of the current document.
HasEmbeddedSource | Checks whether the current document is stored in the symbol store.
Language | Gets the language of the current document.
LanguageVendor | Gets the language vendor of the current document.
SourceLength | Gets the length, in bytes, of the embedded source.
URL | Gets the URL of the current document.

See Also

ISymbolDocument Interface | System.Diagnostics.SymbolStore Namespace


ISymbolDocument.CheckSumAlgorithmId

Gets the checksum algorithm identifier.

[Visual Basic]
ReadOnly Property CheckSumAlgorithmId As Guid
[C#]
Guid CheckSumAlgorithmId {get;}
[C++]
Guid get_CheckSumAlgorithmId() = 0;
[JScript]
abstract function get CheckSumAlgorithmId() : Guid;

Property Value

Return the check sum algorithm identifier.

Remarks

A GUID of all zeros if there is no checksum.

See Also

ISymbolDocument Interface | ISymbolDocument Members | System.Diagnostics.SymbolStore Namespace


ISymbolDocument.DocumentType

Gets the type of the current document.

[Visual Basic]
ReadOnly Property DocumentType As Guid
[C#]
Guid DocumentType {get;}
[C++]
Guid get_DocumentType() = 0;
[JScript]
abstract function get DocumentType() : Guid;

Property Value

The type of the current document.

See Also

ISymbolDocument Interface | ISymbolDocument Members | System.Diagnostics.SymbolStore Namespace


ISymbolDocument.HasEmbeddedSource

Checks whether the current document is stored in the symbol store.

[Visual Basic]
ReadOnly Property HasEmbeddedSource As Boolean
[C#]
bool HasEmbeddedSource {get;}
[C++]
bool get_HasEmbeddedSource() = 0;
[JScript]
abstract function get HasEmbeddedSource() : Boolean;

Property Value

true if the current document is stored in the symbol store; otherwise, false.

See Also

ISymbolDocument Interface | ISymbolDocument Members | System.Diagnostics.SymbolStore Namespace


ISymbolDocument.Language

Gets the language of the current document.

[Visual Basic]
ReadOnly Property Language As Guid
[C#]
Guid Language {get;}
[C++]
Guid get_Language() = 0;
[JScript]
abstract function get Language() : Guid;

Property Value

The language of the current document.

See Also

ISymbolDocument Interface | ISymbolDocument Members | System.Diagnostics.SymbolStore Namespace


ISymbolDocument.LanguageVendor

Gets the language vendor of the current document.

[Visual Basic]
ReadOnly Property LanguageVendor As Guid
[C#]
Guid LanguageVendor {get;}
[C++]
Guid get_LanguageVendor() = 0;
[JScript]
abstract function get LanguageVendor() : Guid;

Property Value

The language vendor of the current document.

See Also

ISymbolDocument Interface | ISymbolDocument Members | System.Diagnostics.SymbolStore Namespace


ISymbolDocument.SourceLength

Gets the length, in bytes, of the embedded source.

[Visual Basic]
ReadOnly Property SourceLength As Integer
[C#]
int SourceLength {get;}
[C++]
int get_SourceLength() = 0;
[JScript]
abstract function get SourceLength() : int;

Property Value

The source length of the current document.

See Also

ISymbolDocument Interface | ISymbolDocument Members | System.Diagnostics.SymbolStore Namespace


ISymbolDocument.URL

Gets the URL of the current document.

[Visual Basic]
ReadOnly Property URL As String
[C#]
string URL {get;}
[C++]
String* get_URL() = 0;
[JScript]
abstract function get URL() : String;

Property Value

The URL of the current document.

See Also

ISymbolDocument Interface | ISymbolDocument Members | System.Diagnostics.SymbolStore Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ISymbolDocument Methods

The methods of the ISymbolDocument interface are listed below. For a complete list of ISymbolDocument interface members, see the ISymbolDocument Members topic.

FindClosestLine | Returns the closest line that is a sequence point, given a line in the current document that may or may not be a sequence point.
GetCheckSum | Gets the checksum.
GetSourceRange | Gets the embedded document source for the specified range.

See Also

ISymbolDocument Interface | System.Diagnostics.SymbolStore Namespace


ISymbolDocument.FindClosestLine

Returns the closest line that is a sequence point, given a line in the current document that may or may not be a sequence point.

[Visual Basic]
Function FindClosestLine( _
   ByVal line As Integer _
) As Integer
[C#]
int FindClosestLine(
   int line
);
[C++]
int FindClosestLine(
   int line
) = 0;
[JScript]
function FindClosestLine(
   line : int
) : int;

Parameters

line
The specified line in the document.

Return Value

The closest line that is a sequence point.

See Also

ISymbolDocument Interface | ISymbolDocument Members | System.Diagnostics.SymbolStore Namespace


ISymbolDocument.GetCheckSum

Gets the checksum.

[Visual Basic]
Function GetCheckSum() As Byte ()
[C#]
byte[] GetCheckSum();
[C++]
unsigned char* GetCheckSum() [] = 0;
[JScript]
function GetCheckSum() : Byte[];

Return Value

The checksum.

See Also

ISymbolDocument Interface | ISymbolDocument Members | System.Diagnostics.SymbolStore Namespace


ISymbolDocument.GetSourceRange

Gets the embedded document source for the specified range.

[Visual Basic]
Function GetSourceRange( _
   ByVal startLine As Integer, _
   ByVal startColumn As Integer, _
   ByVal endLine As Integer, _
   ByVal endColumn As Integer _
) As Byte ()
[C#]
byte[] GetSourceRange(
   int startLine,
   int startColumn,
   int endLine,
   int endColumn
);
[C++]
unsigned char* GetSourceRange(
   int startLine,
   int startColumn,
   int endLine,
   int endColumn
) [] = 0;
[JScript]
function GetSourceRange(
   startLine : int,
   startColumn : int,
   endLine : int,
   endColumn : int
) : Byte[];

Parameters

startLine
The starting line in the current document.
startColumn
The starting column in the current document.
endLine
The ending line in the current document.
endColumn
The ending column in the current document.

Return Value

The document source for the specified range.

See Also

ISymbolDocument Interface | ISymbolDocument Members | System.Diagnostics.SymbolStore Namespace


ISymbolDocumentWriter Interface

Represents a document referenced by a symbol store.

ISymbolDocumentWriter

[Visual Basic]
Public Interface ISymbolDocumentWriter
[C#]
public interface ISymbolDocumentWriter
[C++]
public __gc __interface ISymbolDocumentWriter

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

A document is defined by a URL and a document type GUID. Optionally, the document source can be stored in the symbol store.

Requirements

Namespace: System.Diagnostics.SymbolStore

Assembly: mscorlib.dll

See Also

ISymbolDocumentWriter Members | System.Diagnostics.SymbolStore Namespace


ISymbolDocumentWriter Members

Methods

SetCheckSum | Sets checksum information.
SetSource | Stores the raw source for a document into the symbol store.

See Also

ISymbolDocumentWriter Interface | System.Diagnostics.SymbolStore Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ISymbolDocumentWriter Methods

The methods of the ISymbolDocumentWriter interface are listed below. For a complete list of ISymbolDocumentWriter interface members, see the ISymbolDocumentWriter Members topic.

SetCheckSum | Sets checksum information.
SetSource | Stores the raw source for a document into the symbol store.

See Also

ISymbolDocumentWriter Interface | System.Diagnostics.SymbolStore Namespace


ISymbolDocumentWriter.SetCheckSum

Sets checksum information.

[Visual Basic]
Sub SetCheckSum( _
   ByVal algorithmId As Guid, _
   ByVal checkSum() As Byte _
)
[C#]
void SetCheckSum(
   Guid algorithmId,
   byte[] checkSum
);
[C++]
void SetCheckSum(
   Guid algorithmId,
   unsigned char* checkSum[]
) = 0;
[JScript]
function SetCheckSum(
   algorithmId : Guid,
   checkSum : Byte[]
);

Parameters

algorithmId
The GUID representing the algorithm ID.
checkSum
The checksum.

Remarks

To be supplied

See Also

ISymbolDocumentWriter Interface | ISymbolDocumentWriter Members | System.Diagnostics.SymbolStore Namespace


ISymbolDocumentWriter.SetSource

Stores the raw source for a document into the symbol store.

[Visual Basic]
Sub SetSource( _
   ByVal source() As Byte _
)
[C#]
void SetSource(
   byte[] source
);
[C++]
void SetSource(
   unsigned char* source[]
) = 0;
[JScript]
function SetSource(
   source : Byte[]
);

Parameters

source
The document source represented as unsigned bytes.

Remarks

An array of unsigned bytes is used instead of character data to accommodate a wider variety of sources.

See Also

ISymbolDocumentWriter Interface | ISymbolDocumentWriter Members | System.Diagnostics.SymbolStore Namespace


ISymbolMethod Interface

Represents a method within a symbol reader.

ISymbolMethod

[Visual Basic]
Public Interface ISymbolMethod
[C#]
public interface ISymbolMethod
[C++]
public __gc __interface ISymbolMethod

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

This provides access to only the symbol related attributes of a method such as sequence points, lexical scopes, and parameter information. Use it in conjunction with other means to read the type-related attributes of a method (for example: the System.Reflection classes).

Requirements

Namespace: System.Diagnostics.SymbolStore

Assembly: mscorlib.dll

See Also

ISymbolMethod Members | System.Diagnostics.SymbolStore Namespace


ISymbolMethod Members

Properties

RootScope | Gets the root lexical scope for the current method. This scope encloses the entire method.
SequencePointCount | Gets the count of the sequence points in the method.
Token | Gets the metadata token for the current method.

Methods

GetNamespace | Gets the namespace that the current method is defined within.
GetOffset | Gets the offset within the method that corresponds to the specified position.
GetParameters | Gets the parameters for the current method.
GetRanges | Given a position in a document, get an array of start/end offset pairs that correspond to the ranges of IL that the position covers within this method. The array is an array of integers and is [start, end, start, end]. The number of range pairs is the length of the array divided by 2.
GetScope | Given an offset within the method, returns the most enclosing lexical scope.
GetSequencePoints | Get the sequence points for the current method.
GetSourceStartEnd | Get the start and end positions for the source of the current method.

See Also

ISymbolMethod Interface | System.Diagnostics.SymbolStore Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ISymbolMethod Properties

The properties of the ISymbolMethod interface are listed below. For a complete list of ISymbolMethod interface members, see the ISymbolMethod Members topic.

RootScope | Gets the root lexical scope for the current method. This scope encloses the entire method.
SequencePointCount | Gets the count of the sequence points in the method.
Token | Gets the metadata token for the current method.

See Also

ISymbolMethod Interface | System.Diagnostics.SymbolStore Namespace


ISymbolMethod.RootScope

Gets the root lexical scope for the current method. This scope encloses the entire method.

[Visual Basic]
ReadOnly Property RootScope As ISymbolScope
[C#]
ISymbolScope RootScope {get;}
[C++]
ISymbolScope* get_RootScope() = 0;
[JScript]
abstract function get RootScope() : ISymbolScope;

See Also

ISymbolMethod Interface | ISymbolMethod Members | System.Diagnostics.SymbolStore Namespace


ISymbolMethod.SequencePointCount

Gets the count of the sequence points in the method.

[Visual Basic]
ReadOnly Property SequencePointCount As Integer
[C#]
int SequencePointCount {get;}
[C++]
int get_SequencePointCount() = 0;
[JScript]
abstract function get SequencePointCount() : int;

Property Value

The count of the sequence points in the method.

See Also

ISymbolMethod Interface | ISymbolMethod Members | System.Diagnostics.SymbolStore Namespace


ISymbolMethod.Token

Gets the metadata token for the current method.

[Visual Basic]
ReadOnly Property Token As SymbolToken
[C#]
SymbolToken Token {get;}
[C++]
SymbolToken get_Token() = 0;
[JScript]
abstract function get Token() : SymbolToken;

Property Value

The metadata token for the current method.

See Also

ISymbolMethod Interface | ISymbolMethod Members | System.Diagnostics.SymbolStore Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ISymbolMethod Methods

The methods of the ISymbolMethod interface are listed below. For a complete list of ISymbolMethod interface members, see the ISymbolMethod Members topic.

GetNamespace | Gets the namespace that the current method is defined within.
GetOffset | Gets the offset within the method that corresponds to the specified position.
GetParameters | Gets the parameters for the current method.
GetRanges | Given a position in a document, get an array of start/end offset pairs that correspond to the ranges of IL that the position covers within this method. The array is an array of integers and is [start, end, start, end]. The number of range pairs is the length of the array divided by 2.
GetScope | Given an offset within the method, returns the most enclosing lexical scope.
GetSequencePoints | Get the sequence points for the current method.
GetSourceStartEnd | Get the start and end positions for the source of the current method.

See Also

ISymbolMethod Interface | System.Diagnostics.SymbolStore Namespace


ISymbolMethod.GetNamespace

Gets the namespace that the current method is defined within.

[Visual Basic]
Function GetNamespace() As ISymbolNamespace
[C#]
ISymbolNamespace GetNamespace();
[C++]
ISymbolNamespace* GetNamespace() = 0;
[JScript]
function GetNamespace() : ISymbolNamespace;

Return Value

The namespace that the current method is defined within.

See Also

ISymbolMethod Interface | ISymbolMethod Members | System.Diagnostics.SymbolStore Namespace


ISymbolMethod.GetOffset

Gets the offset within the method that corresponds to the specified position.

[Visual Basic]
Function GetOffset( _
   ByVal document As ISymbolDocument, _
   ByVal line As Integer, _
   ByVal column As Integer _
) As Integer
[C#]
int GetOffset(
   ISymbolDocument document,
   int line,
   int column
);
[C++]
int GetOffset(
   ISymbolDocument* document,
   int line,
   int column
) = 0;
[JScript]
function GetOffset(
   document : ISymbolDocument,
   line : int,
   column : int
) : int;

Parameters

document
The document for which the offset is requested.
line
The document line corresponding to the offset.
column
The document column corresponding to the offset.

Return Value

The offset within the specified document.

Remarks

The parameters are returned in the order they are defined within the method's signature.

See Also

ISymbolMethod Interface | ISymbolMethod Members | System.Diagnostics.SymbolStore Namespace


ISymbolMethod.GetParameters

Gets the parameters for the current method.

[Visual Basic]
Function GetParameters() As ISymbolVariable ()
[C#]
ISymbolVariable[] GetParameters();
[C++]
ISymbolVariable* GetParameters() [] = 0;
[JScript]
function GetParameters() : ISymbolVariable[];

Return Value

The array of parameters for the current method.

Remarks

The parameters are returned in the order they are defined within the method's signature.

See Also

ISymbolMethod Interface | ISymbolMethod Members | System.Diagnostics.SymbolStore Namespace


ISymbolMethod.GetRanges

Given a position in a document, get an array of start/end offset pairs that correspond to the ranges of IL that the position covers within this method. The array is an array of integers and is [start, end, start, end]. The number of range pairs is the length of the array divided by 2.

[Visual Basic]
Function GetRanges( _
   ByVal document As ISymbolDocument, _
   ByVal line As Integer, _
   ByVal column As Integer _
) As Integer ()
[C#]
int[] GetRanges(
   ISymbolDocument document,
   int line,
   int column
);
[C++]
int* GetRanges(
   ISymbolDocument* document,
   int line,
   int column
) [] = 0;
[JScript]
function GetRanges(
   document : ISymbolDocument,
   line : int,
   column : int
) : int[];

Parameters

document
The document for which the offset is requested.
line
The document line corresponding to the ranges.
column
The document column corresponding to the ranges.

Return Value

An array of start/end offset pairs.

See Also

ISymbolMethod Interface | ISymbolMethod Members | System.Diagnostics.SymbolStore Namespace


ISymbolMethod.GetScope

Given an offset within the method, returns the most enclosing lexical scope.

[Visual Basic]
Function GetScope( _
   ByVal offset As Integer _
) As ISymbolScope
[C#]
ISymbolScope GetScope(
   int offset
);
[C++]
ISymbolScope* GetScope(
   int offset
) = 0;
[JScript]
function GetScope(
   offset : int
) : ISymbolScope;

Parameters

offset
The byte offset within the method of the lexical scope.

Return Value

The most enclosing lexical scope for the given byte offset within the method.

Remarks

This can be used to start local variable searches.

See Also

ISymbolMethod Interface | ISymbolMethod Members | System.Diagnostics.SymbolStore Namespace


ISymbolMethod.GetSequencePoints

Get the sequence points for the current method.

[Visual Basic]
Sub GetSequencePoints( _
   ByVal offsets() As Integer, _
   ByVal documents() As ISymbolDocument, _
   ByVal lines() As Integer, _
   ByVal columns() As Integer, _
   ByVal endLines() As Integer, _
   ByVal endColumns() As Integer _
)
[C#]
void GetSequencePoints(
   int[] offsets,
   ISymbolDocument[] documents,
   int[] lines,
   int[] columns,
   int[] endLines,
   int[] endColumns
);
[C++]
void GetSequencePoints(
   int* offsets[],
   ISymbolDocument* documents[],
   int* lines[],
   int* columns[],
   int* endLines[],
   int* endColumns[]
) = 0;
[JScript]
function GetSequencePoints(
   offsets : int[],
   documents : ISymbolDocument[],
   lines : int[],
   columns : int[],
   endLines : int[],
   endColumns : int[]
);

Parameters

offsets
The array of byte offsets from the beginning of the method for the sequence points.
documents
The array of documents in which the sequence points are located.
lines
The array of lines in the documents at which the sequence points are located.
columns
The array of columns in the documents at which the sequence points are located.
endLines
[To be supplied.]
endColumns
[To be supplied.]

Remarks

The sequence points are sorted by offset and are for all documents in the method. Use GetSequencePointCount to retrieve the count of all sequence points and create arrays of the proper size.

GetSequencePoints will verify the size of each array and place the sequence point information into each. If any array is NULL, the data for that array is simply not returned.

See Also

ISymbolMethod Interface | ISymbolMethod Members | System.Diagnostics.SymbolStore Namespace


ISymbolMethod.GetSourceStartEnd

Get the start and end positions for the source of the current method.

[Visual Basic]
Function GetSourceStartEnd( _
   ByVal docs() As ISymbolDocument, _
   ByVal lines() As Integer, _
   ByVal columns() As Integer _
) As Boolean
[C#]
bool GetSourceStartEnd(
   ISymbolDocument[] docs,
   int[] lines,
   int[] columns
);
[C++]
bool GetSourceStartEnd(
   ISymbolDocument* docs[],
   int* lines[],
   int* columns[]
) = 0;
[JScript]
function GetSourceStartEnd(
   docs : ISymbolDocument[],
   lines : int[],
   columns : int[]
) : Boolean;

Parameters

docs
The starting and ending source documents.
lines
The starting and ending lines in the corresponding source documents.
columns
The starting and ending columns in the corresponding source documents.

Return Value

true if the positions were defined; otherwise, false.

Remarks

The first array position is the start, and the second is the end.

See Also

ISymbolMethod Interface | ISymbolMethod Members | System.Diagnostics.SymbolStore Namespace


ISymbolNamespace Interface

Represents a namespace within a symbol reader.

ISymbolNamespace

[Visual Basic]
Public Interface ISymbolNamespace
[C#]
public interface ISymbolNamespace
[C++]
public __gc __interface ISymbolNamespace

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics.SymbolStore

Assembly: mscorlib.dll

See Also

ISymbolNamespace Members | System.Diagnostics.SymbolStore Namespace


ISymbolNamespace Members

Properties

Name Gets the namespace.

Methods

GetNamespaces | Gets the children of the current namespace.
GetVariables | Gets all the variables defined at global scope within the current namespace.

See Also

ISymbolNamespace Interface | System.Diagnostics.SymbolStore Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ISymbolNamespace Properties

The properties of the ISymbolNamespace interface are listed below. For a complete list of ISymbolNamespace interface members, see the ISymbolNamespace Members topic.

Name Gets the namespace.

See Also

ISymbolNamespace Interface | System.Diagnostics.SymbolStore Namespace


ISymbolNamespace.Name

Gets the namespace.

[Visual Basic]
ReadOnly Property Name As String
[C#]
string Name {get;}
[C++]
String* get_Name() = 0;
[JScript]
abstract function get Name() : String;

Property Value

The namespace.

See Also

ISymbolNamespace Interface | ISymbolNamespace Members | System.Diagnostics.SymbolStore Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ISymbolNamespace Methods

The methods of the ISymbolNamespace interface are listed below. For a complete list of ISymbolNamespace interface members, see the ISymbolNamespace Members topic.

GetNamespaces | Gets the children of the current namespace.
GetVariables | Gets all the variables defined at global scope within the current namespace.

See Also

ISymbolNamespace Interface | System.Diagnostics.SymbolStore Namespace


ISymbolNamespace.GetNamespaces

Gets the children of the current namespace.

[Visual Basic]
Function GetNamespaces() As ISymbolNamespace ()
[C#]
ISymbolNamespace[] GetNamespaces();
[C++]
ISymbolNamespace* GetNamespaces() [] = 0;
[JScript]
function GetNamespaces() : ISymbolNamespace[];

Return Value

The children of the current namespace.

See Also

ISymbolNamespace Interface | ISymbolNamespace Members | System.Diagnostics.SymbolStore Namespace


ISymbolNamespace.GetVariables

Gets all the variables defined at global scope within the current namespace.

[Visual Basic]
Function GetVariables() As ISymbolVariable ()
[C#]
ISymbolVariable[] GetVariables();
[C++]
ISymbolVariable* GetVariables() [] = 0;
[JScript]
function GetVariables() : ISymbolVariable[];

Return Value

The variables defined at global scope within the current namespace.

See Also

ISymbolNamespace Interface | ISymbolNamespace Members | System.Diagnostics.SymbolStore Namespace


ISymbolReader Interface

Represents a symbol reader for managed code.

ISymbolReader

[Visual Basic]
Public Interface ISymbolReader
[C#]
public interface ISymbolReader
[C++]
public __gc __interface ISymbolReader

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

The interface provides access to documents, methods, and variables.

Requirements

Namespace: System.Diagnostics.SymbolStore

Assembly: mscorlib.dll

See Also

ISymbolReader Members | System.Diagnostics.SymbolStore Namespace


ISymbolReader Members

Properties

UserEntryPoint Gets the metadata token for the method that was specified as the user entry point for the module, if any.

Methods

GetDocument | Gets a document specified by the language, vendor, and type.
GetDocuments | Gets the array of all the documents defined in the symbol store.
GetGlobalVariables | Gets all global variables in the module.
GetMethod | Overloaded. Gets a symbol reader method object.
GetMethodFromDocumentPosition | Gets the symbol reader method object that contains the specified position in a document.
GetNamespaces | Gets the namespaces defined at global scope within the current symbol store.
GetSymAttribute | Gets an attribute value given the attribute name.
GetVariables | Gets all the variables defined in the specified type.

See Also

ISymbolReader Interface | System.Diagnostics.SymbolStore Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ISymbolReader Properties

The properties of the ISymbolReader interface are listed below. For a complete list of ISymbolReader interface members, see the ISymbolReader Members topic.

UserEntryPoint Gets the metadata token for the method that was specified as the user entry point for the module, if any.

See Also

ISymbolReader Interface | System.Diagnostics.SymbolStore Namespace


ISymbolReader.UserEntryPoint

Gets the metadata token for the method that was specified as the user entry point for the module, if any.

[Visual Basic]
ReadOnly Property UserEntryPoint As SymbolToken
[C#]
SymbolToken UserEntryPoint {get;}
[C++]
SymbolToken get_UserEntryPoint() = 0;
[JScript]
abstract function get UserEntryPoint() : SymbolToken;

Property Value

The metadata token for the method that is the user entry point for the module.

Remarks

This would be, perhaps, the user's main method rather than compiler generated stubs before the main method.

See Also

ISymbolReader Interface | ISymbolReader Members | System.Diagnostics.SymbolStore Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ISymbolReader Methods

The methods of the ISymbolReader interface are listed below. For a complete list of ISymbolReader interface members, see the ISymbolReader Members topic.

GetDocument | Gets a document specified by the language, vendor, and type.
GetDocuments | Gets the array of all the documents defined in the symbol store.
GetGlobalVariables | Gets all global variables in the module.
GetMethod | Overloaded. Gets a symbol reader method object.
GetMethodFromDocumentPosition | Gets the symbol reader method object that contains the specified position in a document.
GetNamespaces | Gets the namespaces defined at global scope within the current symbol store.
GetSymAttribute | Gets an attribute value given the attribute name.
GetVariables | Gets all the variables defined in the specified type.

See Also

ISymbolReader Interface | System.Diagnostics.SymbolStore Namespace


ISymbolReader.GetDocument

Gets a document specified by the language, vendor, and type.

[Visual Basic]
Function GetDocument( _
   ByVal url As String, _
   ByVal language As Guid, _
   ByVal languageVendor As Guid, _
   ByVal documentType As Guid _
) As ISymbolDocument
[C#]
ISymbolDocument GetDocument(
   string url,
   Guid language,
   Guid languageVendor,
   Guid documentType
);
[C++]
ISymbolDocument* GetDocument(
   String* url,
   Guid language,
   Guid languageVendor,
   Guid documentType
) = 0;
[JScript]
function GetDocument(
   url : String,
   language : Guid,
   languageVendor : Guid,
   documentType : Guid
) : ISymbolDocument;

Parameters

url
The URL that identifies the document.
language
The document language. This argument can be specified as NULL.
languageVendor
The identity of the vendor for the document language. This argument can be specified as NULL.
documentType
The type of the document. This argument can be specified as NULL.

Return Value

The specified document.

See Also

ISymbolReader Interface | ISymbolReader Members | System.Diagnostics.SymbolStore Namespace


ISymbolReader.GetDocuments

Gets the array of all the documents defined in the symbol store.

[Visual Basic]
Function GetDocuments() As ISymbolDocument ()
[C#]
ISymbolDocument[] GetDocuments();
[C++]
ISymbolDocument* GetDocuments() [] = 0;
[JScript]
function GetDocuments() : ISymbolDocument[];

Return Value

The array of all documents defined in the symbol store.

See Also

ISymbolReader Interface | ISymbolReader Members | System.Diagnostics.SymbolStore Namespace


ISymbolReader.GetGlobalVariables

Gets all global variables in the module.

[Visual Basic]
Function GetGlobalVariables() As ISymbolVariable ()
[C#]
ISymbolVariable[] GetGlobalVariables();
[C++]
ISymbolVariable* GetGlobalVariables() [] = 0;
[JScript]
function GetGlobalVariables() : ISymbolVariable[];

Return Value

An array of all variables in the module.

See Also

ISymbolReader Interface | ISymbolReader Members | System.Diagnostics.SymbolStore Namespace


ISymbolReader.GetMethod

Gets a symbol reader method object.

Overload List

Gets a symbol reader method object given the identifier of a method.

[Visual Basic] Overloads Function GetMethod(SymbolToken) As ISymbolMethod
[C#] ISymbolMethod GetMethod(SymbolToken);
[C++] ISymbolMethod* GetMethod(SymbolToken) = 0;
[JScript] function GetMethod(SymbolToken) : ISymbolMethod;

Gets a symbol reader method object given the identifier of a method and its Edit and Continue version.

[Visual Basic] Overloads Function GetMethod(SymbolToken, Integer) As ISymbolMethod
[C#] ISymbolMethod GetMethod(SymbolToken, int);
[C++] ISymbolMethod* GetMethod(SymbolToken, int) = 0;
[JScript] function GetMethod(SymbolToken, int) : ISymbolMethod;

See Also

ISymbolReader Interface | ISymbolReader Members | System.Diagnostics.SymbolStore Namespace


ISymbolReader.GetMethod (SymbolToken)

Gets a symbol reader method object given the identifier of a method.

[Visual Basic]
Overloads Function GetMethod( _
   ByVal method As SymbolToken _
) As ISymbolMethod
[C#]
ISymbolMethod GetMethod(
   SymbolToken method
);
[C++]
ISymbolMethod* GetMethod(
   SymbolToken method
) = 0;
[JScript]
function GetMethod(
   method : SymbolToken
) : ISymbolMethod;

Parameters

method
The metadata token of the method.

Return Value

The symbol reader method object for the specified method identifier.

See Also

ISymbolReader Interface | ISymbolReader Members | System.Diagnostics.SymbolStore Namespace | ISymbolReader.GetMethod Overload List


ISymbolReader.GetMethod (SymbolToken, Int32)

Gets a symbol reader method object given the identifier of a method and its Edit and Continue version.

[Visual Basic]
Overloads Function GetMethod( _
   ByVal method As SymbolToken, _
   ByVal version As Integer _
) As ISymbolMethod
[C#]
ISymbolMethod GetMethod(
   SymbolToken method,
   int version
);
[C++]
ISymbolMethod* GetMethod(
   SymbolToken method,
   int version
) = 0;
[JScript]
function GetMethod(
   method : SymbolToken,
   version : int
) : ISymbolMethod;

Parameters

method
The metadata token of the method.
version
The Edit and Continue version of the method.

Return Value

The symbol reader method object for the specified method identifier.

See Also

ISymbolReader Interface | ISymbolReader Members | System.Diagnostics.SymbolStore Namespace | ISymbolReader.GetMethod Overload List


ISymbolReader.GetMethodFromDocumentPosition

Gets the symbol reader method object that contains the specified position in a document.

[Visual Basic]
Function GetMethodFromDocumentPosition( _
   ByVal document As ISymbolDocument, _
   ByVal line As Integer, _
   ByVal column As Integer _
) As ISymbolMethod
[C#]
ISymbolMethod GetMethodFromDocumentPosition(
   ISymbolDocument document,
   int line,
   int column
);
[C++]
ISymbolMethod* GetMethodFromDocumentPosition(
   ISymbolDocument* document,
   int line,
   int column
) = 0;
[JScript]
function GetMethodFromDocumentPosition(
   document : ISymbolDocument,
   line : int,
   column : int
) : ISymbolMethod;

Parameters

document
The document in which the method is located.
line
The position of the line within the document. Lines are numbered beginning at 1.
column
The position of column within the document. Columns are numbered beginning at 1.

Return Value

The reader method object for the specified position in the document.

See Also

ISymbolReader Interface | ISymbolReader Members | System.Diagnostics.SymbolStore Namespace


ISymbolReader.GetNamespaces

Gets the namespaces defined at global scope within the current symbol store.

[Visual Basic]
Function GetNamespaces() As ISymbolNamespace ()
[C#]
ISymbolNamespace[] GetNamespaces();
[C++]
ISymbolNamespace* GetNamespaces() [] = 0;
[JScript]
function GetNamespaces() : ISymbolNamespace[];

Return Value

The namespaces defined at global scope within the current symbol store.

See Also

ISymbolReader Interface | ISymbolReader Members | System.Diagnostics.SymbolStore Namespace


ISymbolReader.GetSymAttribute

Gets an attribute value given the attribute name.

[Visual Basic]
Function GetSymAttribute( _
   ByVal parent As SymbolToken, _
   ByVal name As String _
) As Byte ()
[C#]
byte[] GetSymAttribute(
   SymbolToken parent,
   string name
);
[C++]
unsigned char* GetSymAttribute(
   SymbolToken parent,
   String* name
) [] = 0;
[JScript]
function GetSymAttribute(
   parent : SymbolToken,
   name : String
) : Byte[];

Parameters

parent
The metadata token for the object for which the attribute is requested.
name
The attribute name.

Return Value

The value of the attribute.

Remarks

This attribute is associated only with symbolic information and is not a metadata custom attribute.

See Also

ISymbolReader Interface | ISymbolReader Members | System.Diagnostics.SymbolStore Namespace


ISymbolReader.GetVariables

Gets all the variables defined in the specified type.

[Visual Basic]
Function GetVariables( _
   ByVal parent As SymbolToken _
) As ISymbolVariable ()
[C#]
ISymbolVariable[] GetVariables(
   SymbolToken parent
);
[C++]
ISymbolVariable* GetVariables(
   SymbolToken parent
) [] = 0;
[JScript]
function GetVariables(
   parent : SymbolToken
) : ISymbolVariable[];

Parameters

parent
The metadata token for the type for which the variables are requested.

See Also

ISymbolReader Interface | ISymbolReader Members | System.Diagnostics.SymbolStore Namespace


ISymbolScope Interface

Represents a lexical scope within IsymMethod, providing access to the start and end offsets of the scope, as well as its child and parent scopes.

ISymbolScope

[Visual Basic]
Public Interface ISymbolScope
[C#]
public interface ISymbolScope
[C++]
public __gc __interface ISymbolScope

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

The interface also provides access to all the locals defined within the current scope.

Requirements

Namespace: System.Diagnostics.SymbolStore

Assembly: mscorlib.dll

See Also

ISymbolScope Members | System.Diagnostics.SymbolStore Namespace


ISymbolScope Members

Properties

EndOffset | Gets the end byte offset of the current lexical scope.
Method | Gets the method that contains the current lexical scope.
Parent | Gets the parent lexical scope of the current scope.
StartOffset | Gets the start byte offset of the current lexical scope.

Methods

GetChildren | Gets the lexical scopes that are children of the current lexical scope.
GetLocals | Gets the local variables within the current lexical scope.
GetNamespaces | Gets the namespaces that are being used within the current scope.

See Also

ISymbolScope Interface | System.Diagnostics.SymbolStore Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ISymbolScope Properties

The properties of the ISymbolScope interface are listed below. For a complete list of ISymbolScope interface members, see the ISymbolScope Members topic.

EndOffset | Gets the end byte offset of the current lexical scope.
Method | Gets the method that contains the current lexical scope.
Parent | Gets the parent lexical scope of the current scope.
StartOffset | Gets the start byte offset of the current lexical scope.

See Also

ISymbolScope Interface | System.Diagnostics.SymbolStore Namespace


ISymbolScope.EndOffset

Gets the end byte offset of the current lexical scope.

[Visual Basic]
ReadOnly Property EndOffset As Integer
[C#]
int EndOffset {get;}
[C++]
int get_EndOffset() = 0;
[JScript]
abstract function get EndOffset() : int;

Property Value

The end offset of the current lexical scope.

See Also

ISymbolScope Interface | ISymbolScope Members | System.Diagnostics.SymbolStore Namespace


ISymbolScope.Method

Gets the method that contains the current lexical scope.

[Visual Basic]
ReadOnly Property Method As ISymbolMethod
[C#]
ISymbolMethod Method {get;}
[C++]
ISymbolMethod* get_Method() = 0;
[JScript]
abstract function get Method() : ISymbolMethod;

Property Value

The method that contains the current lexical scope.

See Also

ISymbolScope Interface | ISymbolScope Members | System.Diagnostics.SymbolStore Namespace


ISymbolScope.Parent

Gets the parent lexical scope of the current scope.

[Visual Basic]
ReadOnly Property Parent As ISymbolScope
[C#]
ISymbolScope Parent {get;}
[C++]
ISymbolScope* get_Parent() = 0;
[JScript]
abstract function get Parent() : ISymbolScope;

Property Value

The parent lexical scope of the current scope.

See Also

ISymbolScope Interface | ISymbolScope Members | System.Diagnostics.SymbolStore Namespace


ISymbolScope.StartOffset

Gets the start byte offset of the current lexical scope.

[Visual Basic]
ReadOnly Property StartOffset As Integer
[C#]
int StartOffset {get;}
[C++]
int get_StartOffset() = 0;
[JScript]
abstract function get StartOffset() : int;

Property Value

The start byte offset of the current lexical scope.

See Also

ISymbolScope Interface | ISymbolScope Members | System.Diagnostics.SymbolStore Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ISymbolScope Methods

The methods of the ISymbolScope interface are listed below. For a complete list of ISymbolScope interface members, see the ISymbolScope Members topic.

GetChildren | Gets the lexical scopes that are children of the current lexical scope.
GetLocals | Gets the local variables within the current lexical scope.
GetNamespaces | Gets the namespaces that are being used within the current scope.

See Also

ISymbolScope Interface | System.Diagnostics.SymbolStore Namespace


ISymbolScope.GetChildren

Gets the lexical scopes that are children of the current lexical scope.

[Visual Basic]
Function GetChildren() As ISymbolScope ()
[C#]
ISymbolScope[] GetChildren();
[C++]
ISymbolScope* GetChildren() [] = 0;
[JScript]
function GetChildren() : ISymbolScope[];

Return Value

The lexical scopes that are children of the current lexical scope.

See Also

ISymbolScope Interface | ISymbolScope Members | System.Diagnostics.SymbolStore Namespace


ISymbolScope.GetLocals

Gets the local variables within the current lexical scope.

[Visual Basic]
Function GetLocals() As ISymbolVariable ()
[C#]
ISymbolVariable[] GetLocals();
[C++]
ISymbolVariable* GetLocals() [] = 0;
[JScript]
function GetLocals() : ISymbolVariable[];

Return Value

The local variables within the current lexical scope.

Remarks

The local variables are returned in no particular order. If a local variable changes its address within the current scope that that variable will be returned multiple times, each with a different offset range.

See Also

ISymbolScope Interface | ISymbolScope Members | System.Diagnostics.SymbolStore Namespace


ISymbolScope.GetNamespaces

Gets the namespaces that are being used within the current scope.

[Visual Basic]
Function GetNamespaces() As ISymbolNamespace ()
[C#]
ISymbolNamespace[] GetNamespaces();
[C++]
ISymbolNamespace* GetNamespaces() [] = 0;
[JScript]
function GetNamespaces() : ISymbolNamespace[];

Return Value

The namespaces that are being used within the current scope.

See Also

ISymbolScope Interface | ISymbolScope Members | System.Diagnostics.SymbolStore Namespace


ISymbolVariable Interface

Represents a symbol within a symbol store.

ISymbolVariable

[Visual Basic]
Public Interface ISymbolVariable
[C#]
public interface ISymbolVariable
[C++]
public __gc __interface ISymbolVariable

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

This could be a parameter, a local variable, or a field.

Requirements

Namespace: System.Diagnostics.SymbolStore

Assembly: mscorlib.dll

See Also

ISymbolVariable Members | System.Diagnostics.SymbolStore Namespace


ISymbolVariable Members

Properties

AddressField1 | Gets the first address of the variable.
AddressField2 | Gets the second address of the variable.
AddressField3 | Gets the third address of the variable.
AddressKind | Gets the types of the addresses.
Attributes | Gets the variable attributes.
EndOffset | Gets the end offset of the variable within the variable's scope.
Name | Gets the name of the variable.
StartOffset | Gets the start byte offset of the variable within the variable's scope.

Methods

GetSignature Gets the variable signature.

See Also

ISymbolVariable Interface | System.Diagnostics.SymbolStore Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ISymbolVariable Properties

The properties of the ISymbolVariable interface are listed below. For a complete list of ISymbolVariable interface members, see the ISymbolVariable Members topic.

AddressField1 | Gets the first address of the variable.
AddressField2 | Gets the second address of the variable.
AddressField3 | Gets the third address of the variable.
AddressKind | Gets the types of the addresses.
Attributes | Gets the variable attributes.
EndOffset | Gets the end offset of the variable within the variable's scope.
Name | Gets the name of the variable.
StartOffset | Gets the start byte offset of the variable within the variable's scope.

See Also

ISymbolVariable Interface | System.Diagnostics.SymbolStore Namespace


ISymbolVariable.AddressField1

Gets the first address of the variable.

[Visual Basic]
ReadOnly Property AddressField1 As Integer
[C#]
int AddressField1 {get;}
[C++]
int get_AddressField1() = 0;
[JScript]
abstract function get AddressField1() : int;

Property Value

The first address of the variable.

See Also

ISymbolVariable Interface | ISymbolVariable Members | System.Diagnostics.SymbolStore Namespace


ISymbolVariable.AddressField2

Gets the second address of the variable.

[Visual Basic]
ReadOnly Property AddressField2 As Integer
[C#]
int AddressField2 {get;}
[C++]
int get_AddressField2() = 0;
[JScript]
abstract function get AddressField2() : int;

Property Value

The second address of the variable.

See Also

ISymbolVariable Interface | ISymbolVariable Members | System.Diagnostics.SymbolStore Namespace


ISymbolVariable.AddressField3

Gets the third address of the variable.

[Visual Basic]
ReadOnly Property AddressField3 As Integer
[C#]
int AddressField3 {get;}
[C++]
int get_AddressField3() = 0;
[JScript]
abstract function get AddressField3() : int;

Property Value

The third address of the variable.

See Also

ISymbolVariable Interface | ISymbolVariable Members | System.Diagnostics.SymbolStore Namespace


ISymbolVariable.AddressKind

Gets the types of the addresses.

[Visual Basic]
ReadOnly Property AddressKind As SymAddressKind
[C#]
SymAddressKind AddressKind {get;}
[C++]
SymAddressKind get_AddressKind() = 0;
[JScript]
abstract function get AddressKind() : SymAddressKind;

Property Value

The types of the addresses. SymAddressKind provides the field definitions.

See Also

ISymbolVariable Interface | ISymbolVariable Members | System.Diagnostics.SymbolStore Namespace


ISymbolVariable.Attributes

Gets the variable attributes.

[Visual Basic]
ReadOnly Property Attributes As Object
[C#]
object Attributes {get;}
[C++]
Object* get_Attributes() = 0;
[JScript]
abstract function get Attributes() : Object;

Property Value

The variable attributes.

See Also

ISymbolVariable Interface | ISymbolVariable Members | System.Diagnostics.SymbolStore Namespace


ISymbolVariable.EndOffset

Gets the end offset of the variable within the variable's scope.

[Visual Basic]
ReadOnly Property EndOffset As Integer
[C#]
int EndOffset {get;}
[C++]
int get_EndOffset() = 0;
[JScript]
abstract function get EndOffset() : int;

Property Value

The end offset of the variable.

Remarks

Applies only to local variable.

See Also

ISymbolVariable Interface | ISymbolVariable Members | System.Diagnostics.SymbolStore Namespace


ISymbolVariable.Name

Gets the name of the variable.

[Visual Basic]
ReadOnly Property Name As String
[C#]
string Name {get;}
[C++]
String* get_Name() = 0;
[JScript]
abstract function get Name() : String;

Property Value

The name of the variable.

See Also

ISymbolVariable Interface | ISymbolVariable Members | System.Diagnostics.SymbolStore Namespace


ISymbolVariable.StartOffset

Gets the start byte offset of the variable within the variable's scope.

[Visual Basic]
ReadOnly Property StartOffset As Integer
[C#]
int StartOffset {get;}
[C++]
int get_StartOffset() = 0;
[JScript]
abstract function get StartOffset() : int;

Property Value

The start byte offset of the variable.

Remarks

Applies only to local variables.

See Also

ISymbolVariable Interface | ISymbolVariable Members | System.Diagnostics.SymbolStore Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ISymbolVariable Methods

The methods of the ISymbolVariable interface are listed below. For a complete list of ISymbolVariable interface members, see the ISymbolVariable Members topic.

GetSignature Gets the variable signature.

See Also

ISymbolVariable Interface | System.Diagnostics.SymbolStore Namespace


ISymbolVariable.GetSignature

Gets the variable signature.

[Visual Basic]
Function GetSignature() As Byte ()
[C#]
byte[] GetSignature();
[C++]
unsigned char* GetSignature() [] = 0;
[JScript]
function GetSignature() : Byte[];

Return Value

The variable signature as an opaque byte blob.

See Also

ISymbolVariable Interface | ISymbolVariable Members | System.Diagnostics.SymbolStore Namespace


ISymbolWriter Interface

Represents a symbol writer for managed code.

ISymbolWriter

[Visual Basic]
Public Interface ISymbolWriter
[C#]
public interface ISymbolWriter
[C++]
public __gc __interface ISymbolWriter

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

The interface provides methods to define documents, sequence points, lexical scopes, and variables.

Requirements

Namespace: System.Diagnostics.SymbolStore

Assembly: mscorlib.dll

See Also

ISymbolWriter Members | System.Diagnostics.SymbolStore Namespace


ISymbolWriter Members

Methods

Close | Closes ISymWriter and commits the symbols to the symbol store.
CloseMethod | Closes the current method.
CloseNamespace | Closes the most recently opened namespace.
CloseScope | Closes the current lexical scope.
DefineDocument | Defines a source document.
DefineField | Defines a field in a type or a global field.
DefineGlobalVariable | Defines a single global variable.
DefineLocalVariable | Defines a single parameter in the current method. The type of each parameter is taken from its position (sequence) within the method's signature. Defines a single variable in the current lexical scope.
DefineParameter | Defines a parameter.
DefineSequencePoints | Defines a group of sequence points within the current method.
Initialize | [To be supplied.]
OpenMethod | Opens a method to emit symbol information into.
OpenNamespace | Opens a new namespace.
OpenScope | Opens a new lexical scope in the current method.
SetMethodSourceRange | [To be supplied.]
SetScopeRange | Defines the offset range for the specified lexical scope.
SetSymAttribute | Defines an attribute given the attribute name and the attribute value.
SetUnderlyingWriter | [To be supplied.]
SetUserEntryPoint | Identifies the method that the user has defined as the entry point for the current module.
UsingNamespace | Specifies that the given, fully qualified namespace name is being used within the currently open lexical scope.

See Also

ISymbolWriter Interface | System.Diagnostics.SymbolStore Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ISymbolWriter Methods

The methods of the ISymbolWriter interface are listed below. For a complete list of ISymbolWriter interface members, see the ISymbolWriter Members topic.

Close | Closes ISymWriter and commits the symbols to the symbol store.
CloseMethod | Closes the current method.
CloseNamespace | Closes the most recently opened namespace.
CloseScope | Closes the current lexical scope.
DefineDocument | Defines a source document.
DefineField | Defines a field in a type or a global field.
DefineGlobalVariable | Defines a single global variable.
DefineLocalVariable | Defines a single parameter in the current method. The type of each parameter is taken from its position (sequence) within the method's signature. Defines a single variable in the current lexical scope.
DefineParameter | Defines a parameter.
DefineSequencePoints | Defines a group of sequence points within the current method.
Initialize | [To be supplied.]
OpenMethod | Opens a method to emit symbol information into.
OpenNamespace | Opens a new namespace.
OpenScope | Opens a new lexical scope in the current method.
SetMethodSourceRange | [To be supplied.]
SetScopeRange | Defines the offset range for the specified lexical scope.
SetSymAttribute | Defines an attribute given the attribute name and the attribute value.
SetUnderlyingWriter | [To be supplied.]
SetUserEntryPoint | Identifies the method that the user has defined as the entry point for the current module.
UsingNamespace | Specifies that the given, fully qualified namespace name is being used within the currently open lexical scope.

See Also

ISymbolWriter Interface | System.Diagnostics.SymbolStore Namespace


ISymbolWriter.Close

Closes ISymWriter and commits the symbols to the symbol store.

[Visual Basic]
Sub Close()
[C#]
void Close();
[C++]
void Close() = 0;
[JScript]
function Close();

Remarks

ISymWriter becomes invalid after this call for further updates.

See Also

ISymbolWriter Interface | ISymbolWriter Members | System.Diagnostics.SymbolStore Namespace


ISymbolWriter.CloseMethod

Closes the current method.

[Visual Basic]
Sub CloseMethod()
[C#]
void CloseMethod();
[C++]
void CloseMethod() = 0;
[JScript]
function CloseMethod();

Remarks

Once a method is closed, no more symbols can be defined within it.

See Also

ISymbolWriter Interface | ISymbolWriter Members | System.Diagnostics.SymbolStore Namespace


ISymbolWriter.CloseNamespace

Closes the most recently opened namespace.

[Visual Basic]
Sub CloseNamespace()
[C#]
void CloseNamespace();
[C++]
void CloseNamespace() = 0;
[JScript]
function CloseNamespace();

See Also

ISymbolWriter Interface | ISymbolWriter Members | System.Diagnostics.SymbolStore Namespace


ISymbolWriter.CloseScope

Closes the current lexical scope.

[Visual Basic]
Sub CloseScope( _
   ByVal endOffset As Integer _
)
[C#]
void CloseScope(
   int endOffset
);
[C++]
void CloseScope(
   int endOffset
) = 0;
[JScript]
function CloseScope(
   endOffset : int
);

Parameters

endOffset
The points past the last instruction in the scope.

Remarks

Once a scope is closed, no more variables can be defined within it.

See Also

ISymbolWriter Interface | ISymbolWriter Members | System.Diagnostics.SymbolStore Namespace


ISymbolWriter.DefineDocument

Defines a source document.

[Visual Basic]
Function DefineDocument( _
   ByVal url As String, _
   ByVal language As Guid, _
   ByVal languageVendor As Guid, _
   ByVal documentType As Guid _
) As ISymbolDocumentWriter
[C#]
ISymbolDocumentWriter DefineDocument(
   string url,
   Guid language,
   Guid languageVendor,
   Guid documentType
);
[C++]
ISymbolDocumentWriter* DefineDocument(
   String* url,
   Guid language,
   Guid languageVendor,
   Guid documentType
) = 0;
[JScript]
function DefineDocument(
   url : String,
   language : Guid,
   languageVendor : Guid,
   documentType : Guid
) : ISymbolDocumentWriter;

Parameters

url
The URL that identifies the document.
language
The document language. This argument can be NULL.
languageVendor
The identity of the vendor for the document language. This argument can be NULL.
documentType
The type of the document. This argument can be NULL.

Return Value

A pointer to the ISymDocument object that represents the document.

See Also

ISymbolWriter Interface | ISymbolWriter Members | System.Diagnostics.SymbolStore Namespace


ISymbolWriter.DefineField

Defines a field in a type or a global field.

[Visual Basic]
Sub DefineField( _
   ByVal parent As SymbolToken, _
   ByVal name As String, _
   ByVal attributes As FieldAttributes, _
   ByVal signature() As Byte, _
   ByVal addrKind As SymAddressKind, _
   ByVal addr1 As Integer, _
   ByVal addr2 As Integer, _
   ByVal addr3 As Integer _
)
[C#]
void DefineField(
   SymbolToken parent,
   string name,
   FieldAttributes attributes,
   byte[] signature,
   SymAddressKind addrKind,
   int addr1,
   int addr2,
   int addr3
);
[C++]
void DefineField(
   SymbolToken parent,
   String* name,
   FieldAttributes attributes,
   unsigned char* signature[],
   SymAddressKind addrKind,
   int addr1,
   int addr2,
   int addr3
) = 0;
[JScript]
function DefineField(
   parent : SymbolToken,
   name : String,
   attributes : FieldAttributes,
   signature : Byte[],
   addrKind : SymAddressKind,
   addr1 : int,
   addr2 : int,
   addr3 : int
);

Parameters

parent
The metadata type or method token.
name
The field name.
attributes
The field attributes specified using the FieldAttributes enum.
signature
The field signature.
addrKind
The address types for addr1 and addr2 using SymAddressKind.
addr1
The first address for the field specification.
addr2
The second address for the field specification.
addr3
The third address for the field specification.

See Also

ISymbolWriter Interface | ISymbolWriter Members | System.Diagnostics.SymbolStore Namespace


ISymbolWriter.DefineGlobalVariable

Defines a single global variable.

[Visual Basic]
Sub DefineGlobalVariable( _
   ByVal name As String, _
   ByVal attributes As FieldAttributes, _
   ByVal signature() As Byte, _
   ByVal addrKind As SymAddressKind, _
   ByVal addr1 As Integer, _
   ByVal addr2 As Integer, _
   ByVal addr3 As Integer _
)
[C#]
void DefineGlobalVariable(
   string name,
   FieldAttributes attributes,
   byte[] signature,
   SymAddressKind addrKind,
   int addr1,
   int addr2,
   int addr3
);
[C++]
void DefineGlobalVariable(
   String* name,
   FieldAttributes attributes,
   unsigned char* signature[],
   SymAddressKind addrKind,
   int addr1,
   int addr2,
   int addr3
) = 0;
[JScript]
function DefineGlobalVariable(
   name : String,
   attributes : FieldAttributes,
   signature : Byte[],
   addrKind : SymAddressKind,
   addr1 : int,
   addr2 : int,
   addr3 : int
);

Parameters

name
The global variable name.
attributes
The global variable attributes specified using the FieldAttributes enum.
signature
The global variable signature.
addrKind
The address types for addr1, addr2, and addr3 using SymAddressKind.
addr1
The first address for the global variable specification.
addr2
The second address for the global variable specification.
addr3
The third address for the global variable specification.

See Also

ISymbolWriter Interface | ISymbolWriter Members | System.Diagnostics.SymbolStore Namespace


ISymbolWriter.DefineLocalVariable

Defines a single parameter in the current method. The type of each parameter is taken from its position (sequence) within the method's signature.

Defines a single variable in the current lexical scope.

[Visual Basic]
Sub DefineLocalVariable( _
   ByVal name As String, _
   ByVal attributes As FieldAttributes, _
   ByVal signature() As Byte, _
   ByVal addrKind As SymAddressKind, _
   ByVal addr1 As Integer, _
   ByVal addr2 As Integer, _
   ByVal addr3 As Integer, _
   ByVal startOffset As Integer, _
   ByVal endOffset As Integer _
)
[C#]
void DefineLocalVariable(
   string name,
   FieldAttributes attributes,
   byte[] signature,
   SymAddressKind addrKind,
   int addr1,
   int addr2,
   int addr3,
   int startOffset,
   int endOffset
);
[C++]
void DefineLocalVariable(
   String* name,
   FieldAttributes attributes,
   unsigned char* signature[],
   SymAddressKind addrKind,
   int addr1,
   int addr2,
   int addr3,
   int startOffset,
   int endOffset
) = 0;
[JScript]
function DefineLocalVariable(
   name : String,
   attributes : FieldAttributes,
   signature : Byte[],
   addrKind : SymAddressKind,
   addr1 : int,
   addr2 : int,
   addr3 : int,
   startOffset : int,
   endOffset : int
);

Parameters

name
The local variable name.
attributes
The local variable attributes specified using the FieldAttributes enum.
signature
The local variable signature.
addrKind
The address types for addr1, addr2, and addr3 using SymAddressKind.
addr1
The first address for the local variable specification.
addr2
The second address for the local variable specification.
addr3
The third address for the local variable specification.
startOffset
If zero, it is ignored and the variable is defined over the entire scope. If non-zero, it must fall with the extent (offsets) of the current scope.
endOffset
If zero, it is ignored and the variable is defined over the entire scope. If non-zero, it must fall with the extent (offsets) of the current scope.

Remarks

The startOffset and endOffset parameters are optional. If their value is 0, they are ignored and the variable is defined over the entire scope. If their value is non-zero, they must fall within the offsets of the current scope.

This can be called multiple times for a variable of the same name that has multiple homes throughout a scope. (Note: Start and end offsets must not overlap in such a case.)

If parameters were defined in the metadata for a specified method, you would not have to define them again with calls to this method. The symbol readers will have to be smart enough to check the normal metadata for these first, and then fall back to the symbol store.

See Also

ISymbolWriter Interface | ISymbolWriter Members | System.Diagnostics.SymbolStore Namespace


ISymbolWriter.DefineParameter

Defines a parameter.

[Visual Basic]
Sub DefineParameter( _
   ByVal name As String, _
   ByVal attributes As ParameterAttributes, _
   ByVal sequence As Integer, _
   ByVal addrKind As SymAddressKind, _
   ByVal addr1 As Integer, _
   ByVal addr2 As Integer, _
   ByVal addr3 As Integer _
)
[C#]
void DefineParameter(
   string name,
   ParameterAttributes attributes,
   int sequence,
   SymAddressKind addrKind,
   int addr1,
   int addr2,
   int addr3
);
[C++]
void DefineParameter(
   String* name,
   ParameterAttributes attributes,
   int sequence,
   SymAddressKind addrKind,
   int addr1,
   int addr2,
   int addr3
) = 0;
[JScript]
function DefineParameter(
   name : String,
   attributes : ParameterAttributes,
   sequence : int,
   addrKind : SymAddressKind,
   addr1 : int,
   addr2 : int,
   addr3 : int
);

Parameters

name
The parameter name.
attributes
The parameter attributes specified using the ParameterAttributes enum.
sequence
The parameter signature.
addrKind
The address types for addr1, addr2, and addr3 using SymAddressKind.
addr1
The first address for the parameter specification.
addr2
The second address for the parameter specification.
addr3
The third address for the parameter specification.

See Also

ISymbolWriter Interface | ISymbolWriter Members | System.Diagnostics.SymbolStore Namespace


ISymbolWriter.DefineSequencePoints

Defines a group of sequence points within the current method.

[Visual Basic]
Sub DefineSequencePoints( _
   ByVal document As ISymbolDocumentWriter, _
   ByVal offsets() As Integer, _
   ByVal lines() As Integer, _
   ByVal columns() As Integer, _
   ByVal endLines() As Integer, _
   ByVal endColumns() As Integer _
)
[C#]
void DefineSequencePoints(
   ISymbolDocumentWriter document,
   int[] offsets,
   int[] lines,
   int[] columns,
   int[] endLines,
   int[] endColumns
);
[C++]
void DefineSequencePoints(
   ISymbolDocumentWriter* document,
   int* offsets[],
   int* lines[],
   int* columns[],
   int* endLines[],
   int* endColumns[]
) = 0;
[JScript]
function DefineSequencePoints(
   document : ISymbolDocumentWriter,
   offsets : int[],
   lines : int[],
   columns : int[],
   endLines : int[],
   endColumns : int[]
);

Parameters

document
The document object for which the sequence points are being defined.
offsets
The sequence point offsets measured from the beginning of methods.
lines
The document lines for the sequence points.
columns
The document positions for the sequence points.
endLines
[To be supplied.]
endColumns
[To be supplied.]

Remarks

Each line and each column defines the start of a statement within a method. The arrays should be sorted in the increasing order of offsets. The offset is always the offset from the start of the method, in bytes.

See Also

ISymbolWriter Interface | ISymbolWriter Members | System.Diagnostics.SymbolStore Namespace


ISymbolWriter.Initialize

[To be supplied.]

[Visual Basic]
Sub Initialize( _
   ByVal emitter As Integer, _
   ByVal filename As String, _
   ByVal fFullBuild As Boolean _
)
[C#]
void Initialize(
   int emitter,
   string filename,
   bool fFullBuild
);
[C++]
void Initialize(
   int emitter,
   String* filename,
   bool fFullBuild
) = 0;
[JScript]
function Initialize(
   emitter : int,
   filename : String,
   fFullBuild : Boolean
);

Parameters

emitter
[To be supplied.]
filename
[To be supplied.]
fFullBuild
[To be supplied.]

See Also

ISymbolWriter Interface | ISymbolWriter Members | System.Diagnostics.SymbolStore Namespace


ISymbolWriter.OpenMethod

Opens a method to emit symbol information into.

[Visual Basic]
Sub OpenMethod( _
   ByVal method As SymbolToken _
)
[C#]
void OpenMethod(
   SymbolToken method
);
[C++]
void OpenMethod(
   SymbolToken method
) = 0;
[JScript]
function OpenMethod(
   method : SymbolToken
);

Parameters

method
The metadata token for the method to be opened.

Remarks

The specified method becomes the current method for calls to define sequence points, parameters, and lexical scopes. There is an implicit lexical scope around the entire method. Reopening a method that has been previously closed effectively erases any previously defined symbols for the method.

See Also

ISymbolWriter Interface | ISymbolWriter Members | System.Diagnostics.SymbolStore Namespace


ISymbolWriter.OpenNamespace

Opens a new namespace.

[Visual Basic]
Sub OpenNamespace( _
   ByVal name As String _
)
[C#]
void OpenNamespace(
   string name
);
[C++]
void OpenNamespace(
   String* name
) = 0;
[JScript]
function OpenNamespace(
   name : String
);

Parameters

name
The name of the new namespace.

Remarks

Call this before defining methods or variables that live within a namespace. Namespaces can be nested.

See Also

ISymbolWriter Interface | ISymbolWriter Members | System.Diagnostics.SymbolStore Namespace


ISymbolWriter.OpenScope

Opens a new lexical scope in the current method.

[Visual Basic]
Function OpenScope( _
   ByVal startOffset As Integer _
) As Integer
[C#]
int OpenScope(
   int startOffset
);
[C++]
int OpenScope(
   int startOffset
) = 0;
[JScript]
function OpenScope(
   startOffset : int
) : int;

Parameters

startOffset
The offset in bytes from the beginning of the method of the first instruction in the lexical scope.

Return Value

An opaque scope identifier that can be used with SetScopeRange to define a scope's start and end offsets at a later time. In this case, the offsets passed to OpenScope and CloseScope are ignored. A scope identifier is valid only in the current method.

Remarks

The scope becomes the new current scope and is effectively pushed onto a stack of scopes. Scopes must form a hierarchy. Siblings are not allowed to overlap.

Scope identifiers are only valid in the current method.

See Also

ISymbolWriter Interface | ISymbolWriter Members | System.Diagnostics.SymbolStore Namespace


ISymbolWriter.SetMethodSourceRange

[To be supplied.]

[Visual Basic]
Sub SetMethodSourceRange( _
   ByVal startDoc As ISymbolDocumentWriter, _
   ByVal startLine As Integer, _
   ByVal startColumn As Integer, _
   ByVal endDoc As ISymbolDocumentWriter, _
   ByVal endLine As Integer, _
   ByVal endColumn As Integer _
)
[C#]
void SetMethodSourceRange(
   ISymbolDocumentWriter startDoc,
   int startLine,
   int startColumn,
   ISymbolDocumentWriter endDoc,
   int endLine,
   int endColumn
);
[C++]
void SetMethodSourceRange(
   ISymbolDocumentWriter* startDoc,
   int startLine,
   int startColumn,
   ISymbolDocumentWriter* endDoc,
   int endLine,
   int endColumn
) = 0;
[JScript]
function SetMethodSourceRange(
   startDoc : ISymbolDocumentWriter,
   startLine : int,
   startColumn : int,
   endDoc : ISymbolDocumentWriter,
   endLine : int,
   endColumn : int
);

Parameters

startDoc
[To be supplied.]
startLine
[To be supplied.]
startColumn
[To be supplied.]
endDoc
[To be supplied.]
endLine
[To be supplied.]
endColumn
[To be supplied.]

See Also

ISymbolWriter Interface | ISymbolWriter Members | System.Diagnostics.SymbolStore Namespace


ISymbolWriter.SetScopeRange

Defines the offset range for the specified lexical scope.

[Visual Basic]
Sub SetScopeRange( _
   ByVal scopeID As Integer, _
   ByVal startOffset As Integer, _
   ByVal endOffset As Integer _
)
[C#]
void SetScopeRange(
   int scopeID,
   int startOffset,
   int endOffset
);
[C++]
void SetScopeRange(
   int scopeID,
   int startOffset,
   int endOffset
) = 0;
[JScript]
function SetScopeRange(
   scopeID : int,
   startOffset : int,
   endOffset : int
);

Parameters

scopeID
The identifier of the lexical scope.
startOffset
The byte offset of the beginning of the lexical scope.
endOffset
The byte offset of the end of the lexical scope.

See Also

ISymbolWriter Interface | ISymbolWriter Members | System.Diagnostics.SymbolStore Namespace


ISymbolWriter.SetSymAttribute

Defines an attribute given the attribute name and the attribute value.

[Visual Basic]
Sub SetSymAttribute( _
   ByVal parent As SymbolToken, _
   ByVal name As String, _
   ByVal data() As Byte _
)
[C#]
void SetSymAttribute(
   SymbolToken parent,
   string name,
   byte[] data
);
[C++]
void SetSymAttribute(
   SymbolToken parent,
   String* name,
   unsigned char* data[]
) = 0;
[JScript]
function SetSymAttribute(
   parent : SymbolToken,
   name : String,
   data : Byte[]
);

Parameters

parent
The metadata token for which the attribute is being defined.
name
The attribute name.
data
The attribute value.

Remarks

This attribute is associated only with symbolic information and is not a metadata custom attribute.

See Also

ISymbolWriter Interface | ISymbolWriter Members | System.Diagnostics.SymbolStore Namespace


ISymbolWriter.SetUnderlyingWriter

[To be supplied.]

[Visual Basic]
Sub SetUnderlyingWriter( _
   ByVal underlyingWriter As Integer _
)
[C#]
void SetUnderlyingWriter(
   int underlyingWriter
);
[C++]
void SetUnderlyingWriter(
   int underlyingWriter
) = 0;
[JScript]
function SetUnderlyingWriter(
   underlyingWriter : int
);

Parameters

underlyingWriter
[To be supplied.]

See Also

ISymbolWriter Interface | ISymbolWriter Members | System.Diagnostics.SymbolStore Namespace


ISymbolWriter.SetUserEntryPoint

Identifies the method that the user has defined as the entry point for the current module.

[Visual Basic]
Sub SetUserEntryPoint( _
   ByVal entryMethod As SymbolToken _
)
[C#]
void SetUserEntryPoint(
   SymbolToken entryMethod
);
[C++]
void SetUserEntryPoint(
   SymbolToken entryMethod
) = 0;
[JScript]
function SetUserEntryPoint(
   entryMethod : SymbolToken
);

Parameters

entryMethod
The metadata token for the method that is the user entry point.

Remarks

This would be, perhaps, the user's main method rather than the compiler generated stubs before main.

See Also

ISymbolWriter Interface | ISymbolWriter Members | System.Diagnostics.SymbolStore Namespace


ISymbolWriter.UsingNamespace

Specifies that the given, fully qualified namespace name is being used within the currently open lexical scope.

[Visual Basic]
Sub UsingNamespace( _
   ByVal fullName As String _
)
[C#]
void UsingNamespace(
   string fullName
);
[C++]
void UsingNamespace(
   String* fullName
) = 0;
[JScript]
function UsingNamespace(
   fullName : String
);

Parameters

fullName
The fully qualified name of the namespace.

Remarks

Closing the current scope will also stop using the namespace, and the namespace will be in use in all scopes that inherit from the currently open scope.

See Also

ISymbolWriter Interface | ISymbolWriter Members | System.Diagnostics.SymbolStore Namespace


SymAddressKind Enumeration

Specifies address types for local variables, parameters, and fields in the methods DefineLocalVariable, DefineParameter, and DefineField.

[Visual Basic]
Public Enum SymAddressKind
[C#]
public enum SymAddressKind
[C++]
public enum SymAddressKind

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

The addr1 and addr2 parameters refer to the address parameters in those methods.

Members

Member Name | Description
BitField | Specifies a bit field. The addr1 parameter is the position where the field starts. The addr2 parameter is the field length.
ILOffset | Specifies an IL offset. The addr1 parameter is the IL local variable or parameter index.
NativeOffset | Specifies a native offset. The addr1 parameter is the offset from start of the parent.
NativeRegister | Specifies a native register address. The addr1 parameter is the register in which the variable is stored.
NativeRegisterRegister | Specifies a register-relative address. The addr1 parameter is the register low, and the addr2 parameter is the register high.
NativeRegisterRelative | Specifies a register-relative address.The addr1 parameter is the register, and the addr2 parameter is the offset.
NativeRegisterStack | Specifies a register-relative address. The addr1 parameter is the register low. The addr2 parameter is the register stack, and addr3 is the offset.
NativeRVA | Specifies a native RVA. The addr1 parameter is the RVA in the module.
NativeStackRegister | Specifies a register-relative address. The addr1 parameter is the register stack. The addr2 parameter is the offset, and addr3 is the register high.

Requirements

Namespace: System.Diagnostics.SymbolStore

Assembly: mscorlib.dll

See Also

System.Diagnostics.SymbolStore Namespace


SymbolToken Structure

Provides an opaque representation of the token used and returned by the metadata.

Object
ValueType
SymbolToken

[Visual Basic]
Public Structure SymbolToken
[C#]
public struct SymbolToken
[C++]
public __value struct SymbolToken

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics.SymbolStore

Assembly: mscorlib.dll

See Also

SymbolToken Members | System.Diagnostics.SymbolStore Namespace


SymbolToken Members

Public:

Constructor

SymbolToken Constructor Initializes a new instance of the Token class, given a value.

Methods

Equals | Checks to see if obj is an instance of Token and is equal to this instance
GetHashCode | Generates the hash code for the current token.
GetToken | Gets the value of the current Token.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SymbolToken Structure | System.Diagnostics.SymbolStore Namespace


SymbolToken Constructor

Initializes a new instance of the Token class, given a value.

[Visual Basic]
Public Sub New( _
   ByVal val As Integer _
)
[C#]
public SymbolToken(
   int val
);
[C++]
public: SymbolToken(
   int val
);
[JScript]
public function SymbolToken(
   val : int
);

Parameters

val
The value to be used for the token.

See Also

SymbolToken Structure | SymbolToken Members | System.Diagnostics.SymbolStore Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SymbolToken Methods

The methods of the SymbolToken structure are listed below. For a complete list of SymbolToken structure members, see the SymbolToken Members topic.

Public:

Equals | Checks to see if obj is an instance of Token and is equal to this instance
GetHashCode | Generates the hash code for the current token.
GetToken | Gets the value of the current Token.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SymbolToken Structure | System.Diagnostics.SymbolStore Namespace


SymbolToken.Equals

Checks to see if obj is an instance of Token and is equal to this instance

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
[To be supplied.]

Return Value

true if obj is an instance of Token and is equal to this instance; otherwise, false.

See Also

SymbolToken Structure | SymbolToken Members | System.Diagnostics.SymbolStore Namespace


SymbolToken.GetHashCode

Generates the hash code for the current token.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

The hash code for the current token.

See Also

SymbolToken Structure | SymbolToken Members | System.Diagnostics.SymbolStore Namespace


SymbolToken.GetToken

Gets the value of the current Token.

[Visual Basic]
Public Function GetToken() As Integer
[C#]
public int GetToken();
[C++]
public: int GetToken();
[JScript]
public function GetToken() : int;

Return Value

[To be supplied.

See Also

SymbolToken Structure | SymbolToken Members | System.Diagnostics.SymbolStore Namespace


SymDocumentType Class

Holds the public GUIDs for document types to be used with the symbol store.

Object
SymDocumentType

[Visual Basic]
Public Class SymDocumentType
[C#]
public class SymDocumentType
[C++]
public __gc class SymDocumentType
[JScript]
public class SymDocumentType

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics.SymbolStore

Assembly: mscorlib.dll

See Also

SymDocumentType Members | System.Diagnostics.SymbolStore Namespace


SymDocumentType Members

Public:

Constructor

SymDocumentType Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Text Specifies the GUID of the document type to be used with the symbol store.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SymDocumentType Class | System.Diagnostics.SymbolStore Namespace


SymDocumentType Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public SymDocumentType();
[C++]
public: SymDocumentType();
[JScript]
public function SymDocumentType();

See Also

SymDocumentType Class | SymDocumentType Members | System.Diagnostics.SymbolStore Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SymDocumentType Fields

The fields of the SymDocumentType class are listed below. For a complete list of SymDocumentType class members, see the SymDocumentType Members topic.

Public:

Text Specifies the GUID of the document type to be used with the symbol store.

See Also

SymDocumentType Class | System.Diagnostics.SymbolStore Namespace


SymDocumentType.Text

Specifies the GUID of the document type to be used with the symbol store.

[Visual Basic]
Public Shared ReadOnly Text As Guid
[C#]
public static readonly Guid Text;
[C++]
public: static readonly Guid Text;
[JScript]
public static var Text : Guid;

See Also

SymDocumentType Class | SymDocumentType Members | System.Diagnostics.SymbolStore Namespace


SymLanguageType Class

Holds the public GUIDs for language types to be used with the symbol store.

Object
SymLanguageType

[Visual Basic]
Public Class SymLanguageType
[C#]
public class SymLanguageType
[C++]
public __gc class SymLanguageType
[JScript]
public class SymLanguageType

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics.SymbolStore

Assembly: mscorlib.dll

See Also

SymLanguageType Members | System.Diagnostics.SymbolStore Namespace


SymLanguageType Members

Public:

Constructor

SymLanguageType Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Basic | Specifies the GUID of the Basic language type to be used with the symbol store.
C | Specifies the GUID of the C language type to be used with the symbol store.
Cobol | Specifies the GUID of the Cobol language type to be used with the symbol store.
CPlusPlus | Specifies the GUID of the C++ language type to be used with the symbol store.
CSharp | Specifies the GUID of the C# language type to be used with the symbol store.
ILAssembly | Specifies the GUID of the ILAssembly language type to be used with the symbol store.
Java | Specifies the GUID of the Java language type to be used with the symbol store.
JScript | Specifies the GUID of the JScript language type to be used with the symbol store.
MCPlusPlus | Specifies the GUID of the managed C++ language type to be used with the symbol store.
Pascal | Specifies the GUID of the Pascal language type to be used with the symbol store.
SMC | Specifies the GUID of the SMC language type to be used with the symbol store.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SymLanguageType Class | System.Diagnostics.SymbolStore Namespace


SymLanguageType Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public SymLanguageType();
[C++]
public: SymLanguageType();
[JScript]
public function SymLanguageType();

See Also

SymLanguageType Class | SymLanguageType Members | System.Diagnostics.SymbolStore Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SymLanguageType Fields

The fields of the SymLanguageType class are listed below. For a complete list of SymLanguageType class members, see the SymLanguageType Members topic.

Public:

Basic | Specifies the GUID of the Basic language type to be used with the symbol store.
C | Specifies the GUID of the C language type to be used with the symbol store.
Cobol | Specifies the GUID of the Cobol language type to be used with the symbol store.
CPlusPlus | Specifies the GUID of the C++ language type to be used with the symbol store.
CSharp | Specifies the GUID of the C# language type to be used with the symbol store.
ILAssembly | Specifies the GUID of the ILAssembly language type to be used with the symbol store.
Java | Specifies the GUID of the Java language type to be used with the symbol store.
JScript | Specifies the GUID of the JScript language type to be used with the symbol store.
MCPlusPlus | Specifies the GUID of the managed C++ language type to be used with the symbol store.
Pascal | Specifies the GUID of the Pascal language type to be used with the symbol store.
SMC | Specifies the GUID of the SMC language type to be used with the symbol store.

See Also

SymLanguageType Class | System.Diagnostics.SymbolStore Namespace


SymLanguageType.Basic

Specifies the GUID of the Basic language type to be used with the symbol store.

[Visual Basic]
Public Shared ReadOnly Basic As Guid
[C#]
public static readonly Guid Basic;
[C++]
public: static readonly Guid Basic;
[JScript]
public static var Basic : Guid;

See Also

SymLanguageType Class | SymLanguageType Members | System.Diagnostics.SymbolStore Namespace


SymLanguageType.C

Specifies the GUID of the C language type to be used with the symbol store.

[Visual Basic]
Public Shared ReadOnly C As Guid
[C#]
public static readonly Guid C;
[C++]
public: static readonly Guid C;
[JScript]
public static var C : Guid;

See Also

SymLanguageType Class | SymLanguageType Members | System.Diagnostics.SymbolStore Namespace


SymLanguageType.Cobol

Specifies the GUID of the Cobol language type to be used with the symbol store.

[Visual Basic]
Public Shared ReadOnly Cobol As Guid
[C#]
public static readonly Guid Cobol;
[C++]
public: static readonly Guid Cobol;
[JScript]
public static var Cobol : Guid;

See Also

SymLanguageType Class | SymLanguageType Members | System.Diagnostics.SymbolStore Namespace


SymLanguageType.CPlusPlus

Specifies the GUID of the C++ language type to be used with the symbol store.

[Visual Basic]
Public Shared ReadOnly CPlusPlus As Guid
[C#]
public static readonly Guid CPlusPlus;
[C++]
public: static readonly Guid CPlusPlus;
[JScript]
public static var CPlusPlus : Guid;

See Also

SymLanguageType Class | SymLanguageType Members | System.Diagnostics.SymbolStore Namespace


SymLanguageType.CSharp

Specifies the GUID of the C# language type to be used with the symbol store.

[Visual Basic]
Public Shared ReadOnly CSharp As Guid
[C#]
public static readonly Guid CSharp;
[C++]
public: static readonly Guid CSharp;
[JScript]
public static var CSharp : Guid;

See Also

SymLanguageType Class | SymLanguageType Members | System.Diagnostics.SymbolStore Namespace


SymLanguageType.ILAssembly

Specifies the GUID of the ILAssembly language type to be used with the symbol store.

[Visual Basic]
Public Shared ReadOnly ILAssembly As Guid
[C#]
public static readonly Guid ILAssembly;
[C++]
public: static readonly Guid ILAssembly;
[JScript]
public static var ILAssembly : Guid;

See Also

SymLanguageType Class | SymLanguageType Members | System.Diagnostics.SymbolStore Namespace


SymLanguageType.Java

Specifies the GUID of the Java language type to be used with the symbol store.

[Visual Basic]
Public Shared ReadOnly Java As Guid
[C#]
public static readonly Guid Java;
[C++]
public: static readonly Guid Java;
[JScript]
public static var Java : Guid;

See Also

SymLanguageType Class | SymLanguageType Members | System.Diagnostics.SymbolStore Namespace


SymLanguageType.JScript

Specifies the GUID of the JScript language type to be used with the symbol store.

[Visual Basic]
Public Shared ReadOnly JScript As Guid
[C#]
public static readonly Guid JScript;
[C++]
public: static readonly Guid JScript;
[JScript]
public static var JScript : Guid;

See Also

SymLanguageType Class | SymLanguageType Members | System.Diagnostics.SymbolStore Namespace


SymLanguageType.MCPlusPlus

Specifies the GUID of the managed C++ language type to be used with the symbol store.

[Visual Basic]
Public Shared ReadOnly MCPlusPlus As Guid
[C#]
public static readonly Guid MCPlusPlus;
[C++]
public: static readonly Guid MCPlusPlus;
[JScript]
public static var MCPlusPlus : Guid;

See Also

SymLanguageType Class | SymLanguageType Members | System.Diagnostics.SymbolStore Namespace


SymLanguageType.Pascal

Specifies the GUID of the Pascal language type to be used with the symbol store.

[Visual Basic]
Public Shared ReadOnly Pascal As Guid
[C#]
public static readonly Guid Pascal;
[C++]
public: static readonly Guid Pascal;
[JScript]
public static var Pascal : Guid;

See Also

SymLanguageType Class | SymLanguageType Members | System.Diagnostics.SymbolStore Namespace


SymLanguageType.SMC

Specifies the GUID of the SMC language type to be used with the symbol store.

[Visual Basic]
Public Shared ReadOnly SMC As Guid
[C#]
public static readonly Guid SMC;
[C++]
public: static readonly Guid SMC;
[JScript]
public static var SMC : Guid;

See Also

SymLanguageType Class | SymLanguageType Members | System.Diagnostics.SymbolStore Namespace


SymLanguageVendor Class

Holds the public GUIDs for language vendors to be used with the symbol store.

Object
SymLanguageVendor

[Visual Basic]
Public Class SymLanguageVendor
[C#]
public class SymLanguageVendor
[C++]
public __gc class SymLanguageVendor
[JScript]
public class SymLanguageVendor

Remarks

[To be supplied.]

Requirements

Namespace: System.Diagnostics.SymbolStore

Assembly: mscorlib.dll

See Also

SymLanguageVendor Members | System.Diagnostics.SymbolStore Namespace


SymLanguageVendor Members

Public:

Constructor

SymLanguageVendor Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Microsoft Specifies the GUID of the Microsoft language vendor.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SymLanguageVendor Class | System.Diagnostics.SymbolStore Namespace


SymLanguageVendor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public SymLanguageVendor();
[C++]
public: SymLanguageVendor();
[JScript]
public function SymLanguageVendor();

See Also

SymLanguageVendor Class | SymLanguageVendor Members | System.Diagnostics.SymbolStore Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SymLanguageVendor Fields

The fields of the SymLanguageVendor class are listed below. For a complete list of SymLanguageVendor class members, see the SymLanguageVendor Members topic.

Public:

Microsoft Specifies the GUID of the Microsoft language vendor.

See Also

SymLanguageVendor Class | System.Diagnostics.SymbolStore Namespace


SymLanguageVendor.Microsoft

Specifies the GUID of the Microsoft language vendor.

[Visual Basic]
Public Shared ReadOnly Microsoft As Guid
[C#]
public static readonly Guid Microsoft;
[C++]
public: static readonly Guid Microsoft;
[JScript]
public static var Microsoft : Guid;

See Also

SymLanguageVendor Class | SymLanguageVendor Members | System.Diagnostics.SymbolStore Namespace


System.DirectoryServices

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.DirectoryServices Namespace

Classes

Class | Description
AdsiBinder | A helper class to bind Adsi objects. Basically given a path to an Adsi object, this object retrieves the COM object, wraps it as a managed Object pointer and allows users to retrieve it.
DirectoryEntry | This object encapsulates a node in the Active Directory hierarchy.
DirectoryEntryCollection | Contains the children (child entries) of an entry.
DirectoryEntryCollection.ChildEnumerator | Supports a simple ForEach-style iteration over a collection and defines enumerators, size, and synchronization methods.
DirectoryEntryCollection.CollectionOverStringVariantProperty | Represents a collection of objects that can be individually indexed.
DirectoryEntryProperty | Represents a single property on a DirectoryEntry.
DirectoryEntryPropertyCollection | Contains the properties on an entry.
DirectoryEntryPropertyCollection.PropertyEnumerator | Supports a simple ForEach-style iteration over a collection and defines enumerators, size, and synchronization methods.
DirectoryEntryPropertyValueCollection | Specifies a collection of values for a multi-valued property.
DirectorySearcher | Lets you search and perform queries against the Active Directory hierarchy.
SearchResults | [To be supplied.]
SearchResults.ResultsEnumerator | [To be supplied.]
SearchResultsEntry | [To be supplied.]
SearchResultsProperty | [To be supplied.]
SearchResultsPropertyCollection | [To be supplied.]
SearchResultsPropertyCollection.SearchResultsPropertyEnumerator | [To be supplied.]
SearchResultsPropertyValueCollection | [To be supplied.]
SortOption | [To be supplied.]

Enumerations

Enumeration | Description
ReferralChasingOptions | [To be supplied.]
SearchScope | Used to determine the set of nodes examined in a search with DirectorySearcher.
SortDirection | [To be supplied.]


AdsiBinder Class

A helper class to bind Adsi objects. Basically given a path to an Adsi object, this object retrieves the COM object, wraps it as a managed Object pointer and allows users to retrieve it.

Object
Component
AdsiBinder

[Visual Basic]
Public Class AdsiBinder
   Inherits Component
[C#]
public class AdsiBinder : Component
[C++]
public __gc class AdsiBinder : public Component
[JScript]
public class AdsiBinder extends Component

Remarks

[To be supplied.]

Requirements

Namespace: System.DirectoryServices

Assembly: System.DirectoryServices.dll

See Also

AdsiBinder Members | System.DirectoryServices Namespace


AdsiBinder Members

Public:

Constructor

AdsiBinder Constructor Overloaded. [To be supplied.]

Properties

Path | Gets/sets the Path to the Adsi object.
Site (inherited from Component) | Gets or sets the site of the Component.
Value | Gets the object as specified in the Path.

Methods

ADsGetObject | [To be supplied.]
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AdsiBinder Class | System.DirectoryServices Namespace


AdsiBinder Constructor

[To be supplied.]

Overload List

Default constructor.

[Visual Basic] Overloads Public Sub New()
[C#] public AdsiBinder();
[C++] public: AdsiBinder();
[JScript] public function AdsiBinder();

Constructor that sets the Path property.

[Visual Basic] Overloads Public Sub New(String)
[C#] public AdsiBinder(String);
[C++] public: AdsiBinder(String*);
[JScript] public function AdsiBinder(String);

See Also

AdsiBinder Class | AdsiBinder Members | System.DirectoryServices Namespace


AdsiBinder Constructor ()

Default constructor.

[Visual Basic]
Overloads Public Sub New()
[C#]
public AdsiBinder();
[C++]
public: AdsiBinder();
[JScript]
public function AdsiBinder();

See Also

AdsiBinder Class | AdsiBinder Members | System.DirectoryServices Namespace | AdsiBinder Constructor Overload List


AdsiBinder Constructor (String)

Constructor that sets the Path property.

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As String _
)
[C#]
public AdsiBinder(
   string path
);
[C++]
public: AdsiBinder(
   String* path
);
[JScript]
public function AdsiBinder(
   path : String
);

Parameters

path
[To be supplied.]

See Also

AdsiBinder Class | AdsiBinder Members | System.DirectoryServices Namespace | AdsiBinder Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AdsiBinder Properties

The properties of the AdsiBinder class are listed below. For a complete list of AdsiBinder class members, see the AdsiBinder Members topic.

Public:

Path | Gets/sets the Path to the Adsi object.
Site (inherited from Component) | Gets or sets the site of the Component.
Value | Gets the object as specified in the Path.

See Also

AdsiBinder Class | System.DirectoryServices Namespace


AdsiBinder.Path

Gets/sets the Path to the Adsi object.

[Visual Basic]
Public Property Path As String
[C#]
public string Path {get; set;}
[C++]
public: __property String* get_Path();
public: __property void set_Path(String*);
[JScript]
public function get Path() : String;
public function set Path(String);

See Also

AdsiBinder Class | AdsiBinder Members | System.DirectoryServices Namespace


AdsiBinder.Value

Gets the object as specified in the Path.

[Visual Basic]
Public ReadOnly Property Value As Object
[C#]
public object Value {get;}
[C++]
public: __property Object* get_Value();
[JScript]
public function get Value() : Object;

See Also

AdsiBinder Class | AdsiBinder Members | System.DirectoryServices Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AdsiBinder Methods

The methods of the AdsiBinder class are listed below. For a complete list of AdsiBinder class members, see the AdsiBinder Members topic.

Public:

ADsGetObject | [To be supplied.]
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AdsiBinder Class | System.DirectoryServices Namespace


AdsiBinder.ADsGetObject

[To be supplied.]

[Visual Basic]
extern Public Shared Function ADsGetObject( _
   ByVal path As String, _
   ByRef iid As Guid, _
   ByRef ppObject As Object _
) As Integer
[C#]
public static extern int ADsGetObject(
   string path,
   ref Guid iid,
   ref object ppObject
);
[C++]
public: static extern int ADsGetObject(
   String* path,
   __in Guid** iid,
   __in Object** ppObject
);
[JScript]
public static extern function ADsGetObject(
   path : String,
   iid : Guid,
   ppObject : Object
) : int;

Parameters

path
[To be supplied.]
iid
[To be supplied.]
ppObject
[To be supplied.]

See Also

AdsiBinder Class | AdsiBinder Members | System.DirectoryServices Namespace


DirectoryEntry Class

This object encapsulates a node in the Active Directory hierarchy.

Object
Component
DirectoryEntry

[Visual Basic]
Public Class DirectoryEntry
   Inherits Component
[C#]
public class DirectoryEntry : Component
[C++]
public __gc class DirectoryEntry : public Component
[JScript]
public class DirectoryEntry extends Component

Remarks

Use this class for easy access to the Active Directory from managed code.

Provides the means for client applications of directory services to use one set of interfaces to communicate with any namespace that provides an Active Directory Service Interface (ADSI) implementation. ADSI clients use the interfaces in place of the network-specific Application Programming Interface (API) calls to gain simpler access to the services for a namespace.

This set of interfaces support directory queries and object management, no matter which network environment contains the resource. They can be an LDAP-based, NDS-based, or NTDS-based directory. It does not matter so long as a service provider is available for that directory service.

Requirements

Namespace: System.DirectoryServices

Assembly: System.DirectoryServices.dll

See Also

DirectoryEntry Members | System.DirectoryServices Namespace | DirectoryEntryCollection | DirectoryEntryProperty | DirectoryEntryPropertyCollection | DirectoryEntryPropertyValueCollection


DirectoryEntry Members

Public:

Constructor

DirectoryEntry Constructor Overloaded. Initializes a new instance of the DirectoryEntry class.

Properties

Children | Gets a DirectoryEntryCollection containing the child entries of this node in the Active Directory hierarchy.
Guid | Gets the globally unique identifier of the DirectoryEntry.
Name | Gets the relative name of the object as named with the underlying directory service.
NativeObject | Gets the native Active Directory Services Interface (ADSI) object.
Parent | Gets this entry's parent entry in the store.
Password | Gets or sets the password to use when authenticating the client.
Path | Gets or sets the path for this DirectoryEntry.
Properties | Gets a DirectoryEntryPropertyCollection of properties set on this object.
SchemaClassName | Gets the name of the schema used for this DirectoryEntry.
SchemaEntry | Gets the DirectoryEntry that holds schema information for this entry.
Site (inherited from Component) | Gets or sets the site of the Component.
UsePropertyCache | Gets a value indicating whether the cache should not be committed after each operation.
Username | Gets or sets the username to use when authenticating the client.
UseSecureAuthentication | Gets or sets a value indicating whether the WinNt provider uses NT LAN Manager (NTLM) to authenticate the client.

Methods

Close | Closes the DirectoryEntry and releases any system resources associated with this component.
CommitChanges | Saves any changes to the entry in the directory store.
CopyTo | Overloaded. Creates a copy of this entry as a child of the given parent.
DeleteTree | Deletes this entry and its entire subtree from the Active Directory hierarchy.
Dispose | Disposes of the resources (other than memory) used by the DirectoryEntry.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Exists | Searches the directory store at the given path to see whether the entry exists and if it can be bound to.
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Invoke | Calls a method on the native Active Directory.
MoveTo | Overloaded. Moves this entry to the given parent.
RefreshCache | Overloaded. Loads the property values for this directory entry into the property cache.
Rename | Changes the name of this entry.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Protected:

Methods

Finalize | Frees all resources associated with the component.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirectoryEntry Class | System.DirectoryServices Namespace


DirectoryEntry Constructor

Initializes a new instance of the DirectoryEntry class.

Overload List

Initializes a new instance of the DirectoryEntry class.

[Visual Basic] Overloads Public Sub New()
[C#] public DirectoryEntry();
[C++] public: DirectoryEntry();
[JScript] public function DirectoryEntry();

Initializes a new instance of the DirectoryEntry class that will bind to the directory entry at path.

[Visual Basic] Overloads Public Sub New(String)
[C#] public DirectoryEntry(String);
[C++] public: DirectoryEntry(String*);
[JScript] public function DirectoryEntry(String);

Initializes a new instance of the DirectoryEntry class.

[Visual Basic] Overloads Public Sub New(String, String, String)
[C#] public DirectoryEntry(String, String, String);
[C++] public: DirectoryEntry(String*, String*, String*);
[JScript] public function DirectoryEntry(String, String, String);

Initializes a new instance of the DirectoryEntry class.

[Visual Basic] Overloads Public Sub New(String, String, String, Boolean)
[C#] public DirectoryEntry(String, String, String, bool);
[C++] public: DirectoryEntry(String*, String*, String*, bool);
[JScript] public function DirectoryEntry(String, String, String, Boolean);

Initializes a new instance of the DirectoryEntry class that will bind to the native Active Directory object which is passed in.

[Visual Basic] Overloads Public Sub New(Object)
[C#] public DirectoryEntry(Object);
[C++] public: DirectoryEntry(Object*);
[JScript] public function DirectoryEntry(Object);

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace


DirectoryEntry Constructor ()

Initializes a new instance of the DirectoryEntry class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public DirectoryEntry();
[C++]
public: DirectoryEntry();
[JScript]
public function DirectoryEntry();

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace | DirectoryEntry Constructor Overload List


DirectoryEntry Constructor (String)

Initializes a new instance of the DirectoryEntry class that will bind to the directory entry at path.

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As String _
)
[C#]
public DirectoryEntry(
   string path
);
[C++]
public: DirectoryEntry(
   String* path
);
[JScript]
public function DirectoryEntry(
   path : String
);

Parameters

path
The path at which to bind the DirectoryEntry to the directory.

Exceptions

Exception Type | Condition
 | [To be supplied.]

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace | DirectoryEntry Constructor Overload List


DirectoryEntry Constructor (String, String, String)

Initializes a new instance of the DirectoryEntry class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As String, _
   ByVal username As String, _
   ByVal password As String _
)
[C#]
public DirectoryEntry(
   string path,
   string username,
   string password
);
[C++]
public: DirectoryEntry(
   String* path,
   String* username,
   String* password
);
[JScript]
public function DirectoryEntry(
   path : String,
   username : String,
   password : String
);

Parameters

path
The path of this DirectoryEntry.
username
[To be supplied.]
password
[To be supplied.]

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace | DirectoryEntry Constructor Overload List | Password | Path | Username


DirectoryEntry Constructor (String, String, String, Boolean)

Initializes a new instance of the DirectoryEntry class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As String, _
   ByVal username As String, _
   ByVal password As String, _
   ByVal secureAuthentication As Boolean _
)
[C#]
public DirectoryEntry(
   string path,
   string username,
   string password,
   bool secureAuthentication
);
[C++]
public: DirectoryEntry(
   String* path,
   String* username,
   String* password,
   bool secureAuthentication
);
[JScript]
public function DirectoryEntry(
   path : String,
   username : String,
   password : String,
   secureAuthentication : Boolean
);

Parameters

path
The path of this DirectoryEntry.
username
[To be supplied.]
password
[To be supplied.]
secureAuthentication
[To be supplied.]

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace | DirectoryEntry Constructor Overload List | Password | Path | UseSecureAuthentication | Username


DirectoryEntry Constructor (Object)

Initializes a new instance of the DirectoryEntry class that will bind to the native Active Directory object which is passed in.

[Visual Basic]
Overloads Public Sub New( _
   ByVal adsObject As Object _
)
[C#]
public DirectoryEntry(
   object adsObject
);
[C++]
public: DirectoryEntry(
   Object* adsObject
);
[JScript]
public function DirectoryEntry(
   adsObject : Object
);

Parameters

adsObject
The native Active Directory object to bind to.

Remarks

This constructor is useful if you have acquired a native Active Directory object through a native Application Programming Interface.

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace | DirectoryEntry Constructor Overload List | NativeObject


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DirectoryEntry Properties

The properties of the DirectoryEntry class are listed below. For a complete list of DirectoryEntry class members, see the DirectoryEntry Members topic.

Public:

Children | Gets a DirectoryEntryCollection containing the child entries of this node in the Active Directory hierarchy.
Guid | Gets the globally unique identifier of the DirectoryEntry.
Name | Gets the relative name of the object as named with the underlying directory service.
NativeObject | Gets the native Active Directory Services Interface (ADSI) object.
Parent | Gets this entry's parent entry in the store.
Password | Gets or sets the password to use when authenticating the client.
Path | Gets or sets the path for this DirectoryEntry.
Properties | Gets a DirectoryEntryPropertyCollection of properties set on this object.
SchemaClassName | Gets the name of the schema used for this DirectoryEntry.
SchemaEntry | Gets the DirectoryEntry that holds schema information for this entry.
Site (inherited from Component) | Gets or sets the site of the Component.
UsePropertyCache | Gets a value indicating whether the cache should not be committed after each operation.
Username | Gets or sets the username to use when authenticating the client.
UseSecureAuthentication | Gets or sets a value indicating whether the WinNt provider uses NT LAN Manager (NTLM) to authenticate the client.

See Also

DirectoryEntry Class | System.DirectoryServices Namespace


DirectoryEntry.Children

Gets a DirectoryEntryCollection containing the child entries of this node in the Active Directory hierarchy.

[Visual Basic]
Public ReadOnly Property Children As DirectoryEntryCollection
[C#]
public DirectoryEntryCollection Children {get;}
[C++]
public: __property DirectoryEntryCollection* get_Children();
[JScript]
public function get Children() : DirectoryEntryCollection;

Property Value

A DirectoryEntryCollection containing the child entries of this node in the Active Directory hierarchy.

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace | DirectoryEntryCollection


DirectoryEntry.Guid

Gets the globally unique identifier of the DirectoryEntry.

[Visual Basic]
Public ReadOnly Property Guid As Guid
[C#]
public Guid Guid {get;}
[C++]
public: __property Guid get_Guid();
[JScript]
public function get Guid() : Guid;

Property Value

The globally unique identifier of the DirectoryEntry.

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace | Guid


DirectoryEntry.Name

Gets the relative name of the object as named with the underlying directory service.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}
[C++]
public: __property String* get_Name();
[JScript]
public function get Name() : String;

Property Value

The relative name of the object as named with the underlying directory service.

Remarks

This name distinguishes this entry from its siblings and must be unique in each instance of DirectoryEntry. An exception is thrown if the name already exists in the DirectoryEntry.

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace


DirectoryEntry.NativeObject

Gets the native Active Directory Services Interface (ADSI) object.

[Visual Basic]
Public ReadOnly Property NativeObject As Object
[C#]
public object NativeObject {get;}
[C++]
public: __property Object* get_NativeObject();
[JScript]
public function get NativeObject() : Object;

Property Value

The native ADSI object.

Remarks

Use this property to cast the native Active Directory object when you want to use a COM interface.

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace


DirectoryEntry.Parent

Gets this entry's parent entry in the store.

[Visual Basic]
Public ReadOnly Property Parent As DirectoryEntry
[C#]
public DirectoryEntry Parent {get;}
[C++]
public: __property DirectoryEntry* get_Parent();
[JScript]
public function get Parent() : DirectoryEntry;

Property Value

This entry's parent entry in the store.

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace


DirectoryEntry.Password

Gets or sets the password to use when authenticating the client.

[Visual Basic]
Public Property Password As String
[C#]
public string Password {get; set;}
[C++]
public: __property String* get_Password();
public: __property void set_Password(String*);
[JScript]
public function get Password() : String;
public function set Password(String);

Property Value

The password to use when authenticating the client.

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace


DirectoryEntry.Path

Gets or sets the path for this DirectoryEntry.

[Visual Basic]
Public Property Path As String
[C#]
public string Path {get; set;}
[C++]
public: __property String* get_Path();
public: __property void set_Path(String*);
[JScript]
public function get Path() : String;
public function set Path(String);

Property Value

The path of this DirectoryEntry.

Remarks

The Path property uniquely identifies this entry in a networked environment. The entry can always be retrieved using this path.

Setting the path will retrieve a new entry out of the directory store, it will not change the path of the currently bound entry.

Note The portion of the Path that identifies the provider is case sensitive.

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace


DirectoryEntry.Properties

Gets a DirectoryEntryPropertyCollection of properties set on this object.

[Visual Basic]
Public ReadOnly Property Properties As _
   DirectoryEntryPropertyCollection
[C#]
public DirectoryEntryPropertyCollection Properties {get;}
[C++]
public: __property DirectoryEntryPropertyCollection*
   get_Properties();
[JScript]
public function get Properties() : DirectoryEntryPropertyCollection;

Property Value

A DirectoryEntryPropertyCollection of properties set on this object.

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace | DirectoryEntryPropertyCollection


DirectoryEntry.SchemaClassName

Gets the name of the schema used for this DirectoryEntry.

[Visual Basic]
Public ReadOnly Property SchemaClassName As String
[C#]
public string SchemaClassName {get;}
[C++]
public: __property String* get_SchemaClassName();
[JScript]
public function get SchemaClassName() : String;

Property Value

The name of the schema used for this DirectoryEntry.

Remarks

This is the same as the Name property of the SchemaEntry property.

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace | Name | SchemaEntry


DirectoryEntry.SchemaEntry

Gets the DirectoryEntry that holds schema information for this entry.

[Visual Basic]
Public ReadOnly Property SchemaEntry As DirectoryEntry
[C#]
public DirectoryEntry SchemaEntry {get;}
[C++]
public: __property DirectoryEntry* get_SchemaEntry();
[JScript]
public function get SchemaEntry() : DirectoryEntry;

Property Value

The DirectoryEntry that holds schema information for this entry.

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace


DirectoryEntry.UsePropertyCache

Gets a value indicating whether the cache should not be committed after each operation.

[Visual Basic]
Public Property UsePropertyCache As Boolean
[C#]
public bool UsePropertyCache {get; set;}
[C++]
public: __property bool get_UsePropertyCache();
public: __property void set_UsePropertyCache(bool);
[JScript]
public function get UsePropertyCache() : Boolean;
public function set UsePropertyCache(Boolean);

Property Value

true if the cache should not be committed after each operation; false if the cache should be committed after each operation. The default is true.

Remarks

By default, changes to properties are done locally to a cache and reading property values is cached after the first read. Setting this to false will cause the cache to be committed after operation.

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace | CommitChanges


DirectoryEntry.Username

Gets or sets the username to use when authenticating the client.

[Visual Basic]
Public Property Username As String
[C#]
public string Username {get; set;}
[C++]
public: __property String* get_Username();
public: __property void set_Username(String*);
[JScript]
public function get Username() : String;
public function set Username(String);

Property Value

The username to use when authenticating the client.

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace


DirectoryEntry.UseSecureAuthentication

Gets or sets a value indicating whether the WinNt provider uses NT LAN Manager (NTLM) to authenticate the client.

[Visual Basic]
Public Property UseSecureAuthentication As Boolean
[C#]
public bool UseSecureAuthentication {get; set;}
[C++]
public: __property bool get_UseSecureAuthentication();
public: __property void set_UseSecureAuthentication(bool);
[JScript]
public function get UseSecureAuthentication() : Boolean;
public function set UseSecureAuthentication(Boolean);

Property Value

true if the WinNt provider uses NT LAN Manager (NTLM) to authenticate the client; otherwise, false.

Remarks

Active Directory will use Kerberos, and possibly NTLM, to authenticate the client. When the Username and Password are set to a null reference (in Visual Basic Nothing), Active Directory Service Interface (ADSI) binds to the object using the security context of the calling thread, which is either the security context of the user account under which the application is running or of the client user account that the calling thread is impersonating.

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DirectoryEntry Methods

The methods of the DirectoryEntry class are listed below. For a complete list of DirectoryEntry class members, see the DirectoryEntry Members topic.

Public:

Close | Closes the DirectoryEntry and releases any system resources associated with this component.
CommitChanges | Saves any changes to the entry in the directory store.
CopyTo | Overloaded. Creates a copy of this entry as a child of the given parent.
DeleteTree | Deletes this entry and its entire subtree from the Active Directory hierarchy.
Dispose | Disposes of the resources (other than memory) used by the DirectoryEntry.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Exists | Searches the directory store at the given path to see whether the entry exists and if it can be bound to.
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Invoke | Calls a method on the native Active Directory.
MoveTo | Overloaded. Moves this entry to the given parent.
RefreshCache | Overloaded. Loads the property values for this directory entry into the property cache.
Rename | Changes the name of this entry.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Protected:

Finalize | Frees all resources associated with the component.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirectoryEntry Class | System.DirectoryServices Namespace


DirectoryEntry.Close

Closes the DirectoryEntry and releases any system resources associated with this component.

[Visual Basic]
Public Sub Close()
[C#]
public void Close();
[C++]
public: void Close();
[JScript]
public function Close();

Remarks

Following a call to Close, any operations on the DirectoryEntry may raise exceptions.

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace


DirectoryEntry.CommitChanges

Saves any changes to the entry in the directory store.

[Visual Basic]
Public Sub CommitChanges()
[C#]
public void CommitChanges();
[C++]
public: void CommitChanges();
[JScript]
public function CommitChanges();

Remarks

These changes include changes to the DirectoryEntryPropertyValueCollection as well as calls to Create (if this is the newly created entry) or Remove (if this is the container).

CAUTION If you call RefreshCache before calling CommitChanges, any uncommitted changes to the property cache will be lost.

By default, changes to properties are done locally to a cache and reading property values is cached after the first read. For more information, see UsePropertyCache.

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace | Create | Remove | RefreshCache | UsePropertyCache


DirectoryEntry.CopyTo

Creates a copy of this entry as a child of the given parent.

Overload List

Creates a copy of this entry as a child of the given parent and gives it a new name.

[Visual Basic] Overloads Public Function CopyTo(DirectoryEntry, String) As DirectoryEntry
[C#] public DirectoryEntry CopyTo(DirectoryEntry, String);
[C++] public: DirectoryEntry* CopyTo(DirectoryEntry*, String);
[JScript] public function CopyTo(DirectoryEntry, String) : DirectoryEntry;

Creates a copy of this entry as a child of the given parent.

[Visual Basic] Overloads Public Function CopyTo(DirectoryEntry) As DirectoryEntry
[C#] public DirectoryEntry CopyTo(DirectoryEntry);
[C++] public: DirectoryEntry* CopyTo(DirectoryEntry*);
[JScript] public function CopyTo(DirectoryEntry) : DirectoryEntry;

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace


DirectoryEntry.CopyTo (DirectoryEntry, String)

Creates a copy of this entry as a child of the given parent and gives it a new name.

[Visual Basic]
Overloads Public Function CopyTo( _
   ByVal newParent As DirectoryEntry, _
   ByVal newName As String _
) As DirectoryEntry
[C#]
public DirectoryEntry CopyTo(
   DirectoryEntry newParent,
   string newName
);
[C++]
public: DirectoryEntry* CopyTo(
   DirectoryEntry* newParent,
   String* newName
);
[JScript]
public function CopyTo(
   newParent : DirectoryEntry,
   newName : String
) : DirectoryEntry;

Parameters

newParent
The parent DirectoryEntry.
newName
The name of the copy of the this entry.

Return Value

A renamed copy of this entry as a child of the given parent.

Exceptions

Exception Type | Condition
COMException | The given DirectoryEntry does not exist. The associated error code is E_ADS_UNKNOWN_OBJECT.

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace | DirectoryEntry.CopyTo Overload List


DirectoryEntry.CopyTo (DirectoryEntry)

Creates a copy of this entry as a child of the given parent.

[Visual Basic]
Overloads Public Function CopyTo( _
   ByVal newParent As DirectoryEntry _
) As DirectoryEntry
[C#]
public DirectoryEntry CopyTo(
   DirectoryEntry newParent
);
[C++]
public: DirectoryEntry* CopyTo(
   DirectoryEntry* newParent
);
[JScript]
public function CopyTo(
   newParent : DirectoryEntry
) : DirectoryEntry;

Parameters

newParent
The parent DirectoryEntry.

Return Value

A copy of this entry as a child of the given parent.

Exceptions

Exception Type | Condition
COMException | The given DirectoryEntry does not exist. The associated error code is E_ADS_UNKNOWN_OBJECT.

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace | DirectoryEntry.CopyTo Overload List


DirectoryEntry.DeleteTree

Deletes this entry and its entire subtree from the Active Directory hierarchy.

[Visual Basic]
Public Sub DeleteTree()
[C#]
public void DeleteTree();
[C++]
public: void DeleteTree();
[JScript]
public function DeleteTree();

Exceptions

Exception Type | Condition
InvalidOperationException | This method is not supported by the provider.

Remarks

CAUTION The entry and its entire subtree are deleted from the Active Directory hierarchy.

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace


DirectoryEntry.Dispose

Disposes of the resources (other than memory) used by the DirectoryEntry.

[Visual Basic]
Overrides Public Sub Dispose()
[C#]
public override void Dispose();
[C++]
public: override void Dispose();
[JScript]
public override function Dispose();

Remarks

Call Dispose when you are finished using the DirectoryEntry. The Dispose method leaves the DirectoryEntry in an unusable state. After calling Dispose, you must release all references to the DirectoryEntry so the memory it was occupying can be reclaimed by garbage collection.

Note Always call Dispose before you release your last reference to the DirectoryEntry. Otherwise, the resources the DirectoryEntry is using will not be freed until garbage collection calls the DirectoryEntry object's destructor.

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace


DirectoryEntry.Exists

Searches the directory store at the given path to see whether the entry exists and if it can be bound to.

[Visual Basic]
Public Shared Function Exists( _
   ByVal path As String _
) As Boolean
[C#]
public static bool Exists(
   string path
);
[C++]
public: static bool Exists(
   String* path
);
[JScript]
public static function Exists(
   path : String
) : Boolean;

Parameters

path
The path at which to search the directory store.

Return Value

true if the entry exists in the directory store at the specified path and it can be bound to; otherwise, false.

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace


DirectoryEntry.Finalize

Frees all resources associated with the component.

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace


DirectoryEntry.Invoke

Calls a method on the native Active Directory.

[Visual Basic]
Public Function Invoke( _
   ByVal methodName As String, _
   ByVal ParamArray args() As Object _
) As Object
[C#]
public object Invoke(
   string methodName,
   params object[] args
);
[C++]
public: Object* Invoke(
   String* methodName,
   Object* args[]
);
[JScript]
public function Invoke(
   methodName : String,
   args : Object[]
) : Object;

Parameters

methodName
Then name of the method to invoke.
args
An array of type Object that contains the arguments of the method to invoke.

Return Value

The return value of the invoked method.

Exceptions

Exception Type | Condition
MissingMethodException | The method to invoke cannot be found.

Remarks

If the the return value implements the IADs interface then a corresponding DirectoryEntry instance is returned instead.

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace | Object


DirectoryEntry.MoveTo

Moves this entry to the given parent.

Overload List

Moves this entry to the given parent.

[Visual Basic] Overloads Public Sub MoveTo(DirectoryEntry)
[C#] public void MoveTo(DirectoryEntry);
[C++] public: void MoveTo(DirectoryEntry*);
[JScript] public function MoveTo(DirectoryEntry);

Moves this entry to the given parent, and gives it a new name.

[Visual Basic] Overloads Public Sub MoveTo(DirectoryEntry, String)
[C#] public void MoveTo(DirectoryEntry, String);
[C++] public: void MoveTo(DirectoryEntry*, String);
[JScript] public function MoveTo(DirectoryEntry, String);

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace


DirectoryEntry.MoveTo (DirectoryEntry)

Moves this entry to the given parent.

[Visual Basic]
Overloads Public Sub MoveTo( _
   ByVal newParent As DirectoryEntry _
)
[C#]
public void MoveTo(
   DirectoryEntry newParent
);
[C++]
public: void MoveTo(
   DirectoryEntry* newParent
);
[JScript]
public function MoveTo(
   newParent : DirectoryEntry
);

Parameters

newParent
The parent to which you want to move this entry.

Exceptions

Exception Type | Condition
COMException | The given DirectoryEntry does not exist. The associated error code is E_ADS_UNKNOWN_OBJECT.

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace | DirectoryEntry.MoveTo Overload List


DirectoryEntry.MoveTo (DirectoryEntry, String)

Moves this entry to the given parent, and gives it a new name.

[Visual Basic]
Overloads Public Sub MoveTo( _
   ByVal newParent As DirectoryEntry, _
   ByVal newName As String _
)
[C#]
public void MoveTo(
   DirectoryEntry newParent,
   string newName
);
[C++]
public: void MoveTo(
   DirectoryEntry* newParent,
   String* newName
);
[JScript]
public function MoveTo(
   newParent : DirectoryEntry,
   newName : String
);

Parameters

newParent
The parent to which you want to move this entry.
newName
The new name of this entry.

Exceptions

Exception Type | Condition
COMException | The given DirectoryEntry does not exist. The associated error code is E_ADS_UNKNOWN_OBJECT.
InvalidOperationException | The given DirectoryEntry is not capable of being a parent.

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace | DirectoryEntry.MoveTo Overload List


DirectoryEntry.RefreshCache

Loads the property values for this directory entry into the property cache.

Overload List

Loads the property values for this directory entry into the property cache.

[Visual Basic] Overloads Public Sub RefreshCache()
[C#] public void RefreshCache();
[C++] public: void RefreshCache();
[JScript] public function RefreshCache();

Loads the values of the specified properties into the property cache.

[Visual Basic] Overloads Public Sub RefreshCache(String())
[C#] public void RefreshCache(String[]);
[C++] public: void RefreshCache(String*[]);
[JScript] public function RefreshCache(String[]);

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace


DirectoryEntry.RefreshCache ()

Loads the property values for this directory entry into the property cache.

[Visual Basic]
Overloads Public Sub RefreshCache()
[C#]
public void RefreshCache();
[C++]
public: void RefreshCache();
[JScript]
public function RefreshCache();

Remarks

CAUTION Any uncommitted changes to the property cache will be lost. Use CommitChanges to persist changes to the directory store.

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace | DirectoryEntry.RefreshCache Overload List | CommitChanges


DirectoryEntry.RefreshCache (String[])

Loads the values of the specified properties into the property cache.

[Visual Basic]
Overloads Public Sub RefreshCache( _
   ByVal propertyNames() As String _
)
[C#]
public void RefreshCache(
   string[] propertyNames
);
[C++]
public: void RefreshCache(
   String* propertyNames[]
);
[JScript]
public function RefreshCache(
   propertyNames : String[]
);

Parameters

propertyNames
An array of the specified properties.

Remarks

CAUTION Any uncommitted changes to the property cache will be lost. Use CommitChanges to persist changes to the directory store.

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace | DirectoryEntry.RefreshCache Overload List | CommitChanges


DirectoryEntry.Rename

Changes the name of this entry.

[Visual Basic]
Public Sub Rename( _
   ByVal newName As String _
)
[C#]
public void Rename(
   string newName
);
[C++]
public: void Rename(
   String* newName
);
[JScript]
public function Rename(
   newName : String
);

Parameters

newName
The new name of the entry.

Remarks

Note This will also affect the path used to refer to this entry.

See Also

DirectoryEntry Class | DirectoryEntry Members | System.DirectoryServices Namespace


DirectoryEntryCollection Class

Contains the children (child entries) of an entry.

Object
DirectoryEntryCollection

[Visual Basic]
Public Class DirectoryEntryCollection
   Implements ICollection, IEnumerable
[C#]
public class DirectoryEntryCollection : ICollection, IEnumerable
[C++]
public __gc class DirectoryEntryCollection : public ICollection,
   IEnumerable
[JScript]
public class DirectoryEntryCollection implements ICollection,
   IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.DirectoryServices

Assembly: System.DirectoryServices.dll

See Also

DirectoryEntryCollection Members | System.DirectoryServices Namespace


DirectoryEntryCollection Members

Public:

Properties

Count | Gets the number of children in this container.
IsReadOnly | Gets whether the property is read-only.
IsSynchronized | Gets whether this collection is synchronized.
SchemasToLoad | Gets the schemas that specify which children are shown.
SyncRoot | Gets an object to use for synchronization (thread safety).

Methods

CopyTo | Copies the elements of this instance into an Array, starting at a particular index into the array.
Create | Creates a request to create a new entry in the container.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Find | Overloaded. Returns the child with the given name.
GetEnumerator | Returns an enumerator, which can be used to iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Remove | Deletes a child DirectoryEntry from this collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirectoryEntryCollection Class | System.DirectoryServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DirectoryEntryCollection Properties

The properties of the DirectoryEntryCollection class are listed below. For a complete list of DirectoryEntryCollection class members, see the DirectoryEntryCollection Members topic.

Public:

Count | Gets the number of children in this container.
IsReadOnly | Gets whether the property is read-only.
IsSynchronized | Gets whether this collection is synchronized.
SchemasToLoad | Gets the schemas that specify which children are shown.
SyncRoot | Gets an object to use for synchronization (thread safety).

See Also

DirectoryEntryCollection Class | System.DirectoryServices Namespace


DirectoryEntryCollection.Count

Gets the number of children in this container.

[Visual Basic]
Overridable Public ReadOnly Property Count As Integer
[C#]
public int Count {virtual get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;

Property Value

The number of children in this container.

Remarks

Not all providers support getting the count.

See Also

DirectoryEntryCollection Class | DirectoryEntryCollection Members | System.DirectoryServices Namespace


DirectoryEntryCollection.IsReadOnly

Gets whether the property is read-only.

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {virtual get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;

Property Value

true if the property is read-only; otherwise, false.

Remarks

Only the properties provided by the Web Store are marked as read-only. These properties are never set by applications; they are provided by the store.

See Also

DirectoryEntryCollection Class | DirectoryEntryCollection Members | System.DirectoryServices Namespace


DirectoryEntryCollection.IsSynchronized

Gets whether this collection is synchronized.

[Visual Basic]
Overridable Public ReadOnly Property IsSynchronized As Boolean
[C#]
public bool IsSynchronized {virtual get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;

Property Value

true if this collection is synchronized; otherwise, false.

Remarks

Use SyncRoot to get an object to use for synchronization.

See Also

DirectoryEntryCollection Class | DirectoryEntryCollection Members | System.DirectoryServices Namespace


DirectoryEntryCollection.SchemasToLoad

Gets the schemas that specify which children are shown.

[Visual Basic]
Public ReadOnly Property SchemasToLoad As _
   DirectoryEntryCollection.CollectionOverStringVariantProperty
[C#]
public DirectoryEntryCollection.CollectionOverStringVariantProperty
   SchemasToLoad {get;}
[C++]
public: __property
   DirectoryEntryCollection.CollectionOverStringVariantProperty*
   get_SchemasToLoad();
[JScript]
public function get SchemasToLoad() :
   DirectoryEntryCollection.CollectionOverStringVariantProperty;

Property Value

A DirectoryEntryCollection.CollectionOverStringVariantProperty that specifies which children are shown.

Remarks

If the collection is empty, entries of all types are returned.

See Also

DirectoryEntryCollection Class | DirectoryEntryCollection Members | System.DirectoryServices Namespace | DirectoryEntryCollection.CollectionOverStringVariantProperty


DirectoryEntryCollection.SyncRoot

Gets an object to use for synchronization (thread safety).

[Visual Basic]
Overridable Public ReadOnly Property SyncRoot As Object
[C#]
public object SyncRoot {virtual get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;

Property Value

An object to use for synchronization.

See Also

DirectoryEntryCollection Class | DirectoryEntryCollection Members | System.DirectoryServices Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DirectoryEntryCollection Methods

The methods of the DirectoryEntryCollection class are listed below. For a complete list of DirectoryEntryCollection class members, see the DirectoryEntryCollection Members topic.

Public:

CopyTo | Copies the elements of this instance into an Array, starting at a particular index into the array.
Create | Creates a request to create a new entry in the container.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Find | Overloaded. Returns the child with the given name.
GetEnumerator | Returns an enumerator, which can be used to iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Remove | Deletes a child DirectoryEntry from this collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirectoryEntryCollection Class | System.DirectoryServices Namespace


DirectoryEntryCollection.CopyTo

Copies the elements of this instance into an Array, starting at a particular index into the array.

[Visual Basic]
Overridable Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
[C#]
public virtual void CopyTo(
   Array array,
   int index
);
[C++]
public: virtual void CopyTo(
   Array* array,
   int index
);
[JScript]
public function CopyTo(
   array : Array,
   index : int
);

Parameters

array
An array of type Array that will hold this collection's elements.
index
The beginning index in the array where the elements will be copied.

Exceptions

Exception Type | Condition
ArgumentException | The index plus the size of this collection is greater than the length ot the Array.
ArgumentNullException | The array is a null reference (in Visual Basic Nothing).
IndexOutOfRangeException | The index is out of the array's bounds.

See Also

DirectoryEntryCollection Class | DirectoryEntryCollection Members | System.DirectoryServices Namespace


DirectoryEntryCollection.Create

Creates a request to create a new entry in the container.

[Visual Basic]
Public Function Create( _
   ByVal name As String, _
   ByVal schemaClassName As String _
) As DirectoryEntry
[C#]
public DirectoryEntry Create(
   string name,
   string schemaClassName
);
[C++]
public: DirectoryEntry* Create(
   String* name,
   String* schemaClassName
);
[JScript]
public function Create(
   name : String,
   schemaClassName : String
) : DirectoryEntry;

Parameters

name
[To be supplied.]
schemaClassName
[To be supplied.]

Return Value

A DirectoryEntry that represents the new entry.

Exceptions

Exception Type | Condition
COMException | The DirectoryEntry already exists. The associated error code is E_ADS_OBJECT_EXISTS.

Remarks

Note You must call the CommitChanges method on the new entry to make the creation persistent.

This allows for creation of mandatory property values on the new entry.

See Also

DirectoryEntryCollection Class | DirectoryEntryCollection Members | System.DirectoryServices Namespace | DirectoryEntry


DirectoryEntryCollection.Find

Returns the child with the given name.

Overload List

Returns the child with the given name.

[Visual Basic] Overloads Public Function Find(String) As DirectoryEntry
[C#] public DirectoryEntry Find(String);
[C++] public: DirectoryEntry* Find(String*);
[JScript] public function Find(String) : DirectoryEntry;

Returns the child with the given name and of the given type.

[Visual Basic] Overloads Public Function Find(String, String) As DirectoryEntry
[C#] public DirectoryEntry Find(String, String);
[C++] public: DirectoryEntry* Find(String*, String*);
[JScript] public function Find(String, String) : DirectoryEntry;

See Also

DirectoryEntryCollection Class | DirectoryEntryCollection Members | System.DirectoryServices Namespace


DirectoryEntryCollection.Find (String)

Returns the child with the given name.

[Visual Basic]
Overloads Public Function Find( _
   ByVal name As String _
) As DirectoryEntry
[C#]
public DirectoryEntry Find(
   string name
);
[C++]
public: DirectoryEntry* Find(
   String* name
);
[JScript]
public function Find(
   name : String
) : DirectoryEntry;

Parameters

name
The name of the child you are looking for.

Return Value

A DirectoryEntry that represents the child that was found.

Exceptions

Exception Type | Condition
COMException | The given child entry does not exist. The associated error code is E_ADS_UNKNOWN_OBJECT.

Remarks

If children of different types have the same name, the first matching child is returned.

See Also

DirectoryEntryCollection Class | DirectoryEntryCollection Members | System.DirectoryServices Namespace | DirectoryEntryCollection.Find Overload List | DirectoryEntry


DirectoryEntryCollection.Find (String, String)

Returns the child with the given name and of the given type.

[Visual Basic]
Overloads Public Function Find( _
   ByVal name As String, _
   ByVal schemaClassName As String _
) As DirectoryEntry
[C#]
public DirectoryEntry Find(
   string name,
   string schemaClassName
);
[C++]
public: DirectoryEntry* Find(
   String* name,
   String* schemaClassName
);
[JScript]
public function Find(
   name : String,
   schemaClassName : String
) : DirectoryEntry;

Parameters

name
The name of the child you are looking for.
schemaClassName
The type of the child you are looking for.

Return Value

A DirectoryEntry that represents the child you found.

Exceptions

Exception Type | Condition
COMException | The given child entry does not exist. The associated error code is E_ADS_UNKNOWN_OBJECT.

See Also

DirectoryEntryCollection Class | DirectoryEntryCollection Members | System.DirectoryServices Namespace | DirectoryEntryCollection.Find Overload List | DirectoryEntry


DirectoryEntryCollection.GetEnumerator

Returns an enumerator, which can be used to iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As ChildEnumerator
[C#]
public ChildEnumerator GetEnumerator();
[C++]
public: ChildEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : ChildEnumerator;

Return Value

An enumerator, which can be used to iterate through the collection.

See Also

DirectoryEntryCollection Class | DirectoryEntryCollection Members | System.DirectoryServices Namespace | DirectoryEntryCollection.ChildEnumerator


DirectoryEntryCollection.Remove

Deletes a child DirectoryEntry from this collection.

[Visual Basic]
Public Sub Remove( _
   ByVal entry As DirectoryEntry _
)
[C#]
public void Remove(
   DirectoryEntry entry
);
[C++]
public: void Remove(
   DirectoryEntry* entry
);
[JScript]
public function Remove(
   entry : DirectoryEntry
);

Parameters

entry
The DirectoryEntry to delete.

Exceptions

Exception Type | Condition
InvalidOperationException | The node you are trying to remove is not a child of the given DirectoryEntry.
COMException | The given DirectoryEntry does not exist. The associated error code is E_ADS_OBJECT_UNKNOWN.

Remarks

The entry must be an empty container or a non-container. To delete an entry and all its children, use the DeleteTree method from DirectoryEntry.

See Also

DirectoryEntryCollection Class | DirectoryEntryCollection Members | System.DirectoryServices Namespace


DirectoryEntryCollection.ChildEnumerator Class

Supports a simple ForEach-style iteration over a collection and defines enumerators, size, and synchronization methods.

Object
DirectoryEntryCollection.ChildEnumerator

[Visual Basic]
Public Class DirectoryEntryCollection.ChildEnumerator
   Implements IEnumerator
[C#]
public class DirectoryEntryCollection.ChildEnumerator : IEnumerator
[C++]
public __gc class DirectoryEntryCollection.ChildEnumerator : public
   IEnumerator
[JScript]
public class DirectoryEntryCollection.ChildEnumerator implements
   IEnumerator

Remarks

[To be supplied.]

Requirements

Namespace: System.DirectoryServices

Assembly: System.DirectoryServices.dll

See Also

DirectoryEntryCollection.ChildEnumerator Members | System.DirectoryServices Namespace | DirectoryEntryCollection


DirectoryEntryCollection.ChildEnumerator Members

Public:

Properties

Current [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
MoveNext | [To be supplied.]
Reset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirectoryEntryCollection.ChildEnumerator Class | System.DirectoryServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DirectoryEntryCollection.ChildEnumerator Properties

The properties of the DirectoryEntryCollection.ChildEnumerator class are listed below. For a complete list of DirectoryEntryCollection.ChildEnumerator class members, see the DirectoryEntryCollection.ChildEnumerator Members topic.

Public:

Current [To be supplied.]

See Also

DirectoryEntryCollection.ChildEnumerator Class | System.DirectoryServices Namespace


DirectoryEntryCollection.ChildEnumerator.Current

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Current As DirectoryEntry
[C#]
public DirectoryEntry Current {get;}
[C++]
public: __property DirectoryEntry* get_Current();
[JScript]
public function get Current() : DirectoryEntry;

See Also

DirectoryEntryCollection.ChildEnumerator Class | DirectoryEntryCollection.ChildEnumerator Members | System.DirectoryServices Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DirectoryEntryCollection.ChildEnumerator Methods

The methods of the DirectoryEntryCollection.ChildEnumerator class are listed below. For a complete list of DirectoryEntryCollection.ChildEnumerator class members, see the DirectoryEntryCollection.ChildEnumerator Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
MoveNext | [To be supplied.]
Reset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirectoryEntryCollection.ChildEnumerator Class | System.DirectoryServices Namespace


DirectoryEntryCollection.ChildEnumerator.MoveNext

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;

See Also

DirectoryEntryCollection.ChildEnumerator Class | DirectoryEntryCollection.ChildEnumerator Members | System.DirectoryServices Namespace


DirectoryEntryCollection.ChildEnumerator.Reset

[To be supplied.]

[Visual Basic]
Overridable Public Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();

See Also

DirectoryEntryCollection.ChildEnumerator Class | DirectoryEntryCollection.ChildEnumerator Members | System.DirectoryServices Namespace


DirectoryEntryCollection.CollectionOverStringVariantProperty Class

Represents a collection of objects that can be individually indexed.

Object
DirectoryEntryCollection.CollectionOverStringVariantProperty

[Visual Basic]
Public Class _
   DirectoryEntryCollection.CollectionOverStringVariantProperty
   Implements IList, ICollection, IEnumerable
[C#]
public class
   DirectoryEntryCollection.CollectionOverStringVariantProperty :
   IList, ICollection, IEnumerable
[C++]
public __gc class
   DirectoryEntryCollection.CollectionOverStringVariantProperty :
   public IList, ICollection, IEnumerable
[JScript]
public class
   DirectoryEntryCollection.CollectionOverStringVariantProperty
   implements IList, ICollection, IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.DirectoryServices

Assembly: System.DirectoryServices.dll

See Also

DirectoryEntryCollection.CollectionOverStringVariantProperty Members | System.DirectoryServices Namespace


DirectoryEntryCollection.CollectionOverStringVariantProperty Members

Public:

Properties

Count | [To be supplied.]
IsReadOnly | [To be supplied.]
IsSynchronized | [To be supplied.]
Item | [To be supplied.] In C#, this member is the indexer for the DirectoryEntryCollection.CollectionOverStringVariantProperty class.
SyncRoot | [To be supplied.]

Methods

Add | [To be supplied.]
AddRange | [To be supplied.]
Clear | [To be supplied.]
Contains | [To be supplied.]
CopyTo | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | [To be supplied.]
Insert | [To be supplied.]
Remove | [To be supplied.]
RemoveAt | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirectoryEntryCollection.CollectionOverStringVariantProperty Class | System.DirectoryServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DirectoryEntryCollection.CollectionOverStringVariantProperty Properties

The properties of the DirectoryEntryCollection.CollectionOverStringVariantProperty class are listed below. For a complete list of DirectoryEntryCollection.CollectionOverStringVariantProperty class members, see the DirectoryEntryCollection.CollectionOverStringVariantProperty Members topic.

Public:

Count | [To be supplied.]
IsReadOnly | [To be supplied.]
IsSynchronized | [To be supplied.]
Item | [To be supplied.] In C#, this member is the indexer for the DirectoryEntryCollection.CollectionOverStringVariantProperty class.
SyncRoot | [To be supplied.]

See Also

DirectoryEntryCollection.CollectionOverStringVariantProperty Class | System.DirectoryServices Namespace


DirectoryEntryCollection.CollectionOverStringVariantProperty.Count

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Count As Integer
[C#]
public int Count {virtual get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;

See Also

DirectoryEntryCollection.CollectionOverStringVariantProperty Class | DirectoryEntryCollection.CollectionOverStringVariantProperty Members | System.DirectoryServices Namespace


DirectoryEntryCollection.CollectionOverStringVariantProperty.IsReadOnly

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {virtual get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;

See Also

DirectoryEntryCollection.CollectionOverStringVariantProperty Class | DirectoryEntryCollection.CollectionOverStringVariantProperty Members | System.DirectoryServices Namespace


DirectoryEntryCollection.CollectionOverStringVariantProperty.IsSynchronized

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsSynchronized As Boolean
[C#]
public bool IsSynchronized {virtual get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;

See Also

DirectoryEntryCollection.CollectionOverStringVariantProperty Class | DirectoryEntryCollection.CollectionOverStringVariantProperty Members | System.DirectoryServices Namespace


DirectoryEntryCollection.CollectionOverStringVariantProperty.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the DirectoryEntryCollection.CollectionOverStringVariantProperty class.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As String
[C#]
public string this[
   int index
] {get; set;}
[C++]
public: __property String* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   String*
);
[JScript]
returnValue = DirectoryEntryCollection.CollectionOverStringVariantPropertyObject.Item(index);
DirectoryEntryCollection.CollectionOverStringVariantPropertyObject.Item(index) = returnValue;
-or-
returnValue = DirectoryEntryCollection.CollectionOverStringVariantPropertyObject(index);
DirectoryEntryCollection.CollectionOverStringVariantPropertyObject(index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
[To be supplied.]

Parameters [Visual Basic, C#, C++]

index
[To be supplied.]

See Also

DirectoryEntryCollection.CollectionOverStringVariantProperty Class | DirectoryEntryCollection.CollectionOverStringVariantProperty Members | System.DirectoryServices Namespace


DirectoryEntryCollection.CollectionOverStringVariantProperty.SyncRoot

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property SyncRoot As Object
[C#]
public object SyncRoot {virtual get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;

See Also

DirectoryEntryCollection.CollectionOverStringVariantProperty Class | DirectoryEntryCollection.CollectionOverStringVariantProperty Members | System.DirectoryServices Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DirectoryEntryCollection.CollectionOverStringVariantProperty Methods

The methods of the DirectoryEntryCollection.CollectionOverStringVariantProperty class are listed below. For a complete list of DirectoryEntryCollection.CollectionOverStringVariantProperty class members, see the DirectoryEntryCollection.CollectionOverStringVariantProperty Members topic.

Public:

Add | [To be supplied.]
AddRange | [To be supplied.]
Clear | [To be supplied.]
Contains | [To be supplied.]
CopyTo | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | [To be supplied.]
Insert | [To be supplied.]
Remove | [To be supplied.]
RemoveAt | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirectoryEntryCollection.CollectionOverStringVariantProperty Class | System.DirectoryServices Namespace


DirectoryEntryCollection.CollectionOverStringVariantProperty.Add

[To be supplied.]

[Visual Basic]
Public Function Add( _
   ByVal value As String _
) As Integer
[C#]
public int Add(
   string value
);
[C++]
public: int Add(
   String* value
);
[JScript]
public function Add(
   value : String
) : int;

Parameters

value
[To be supplied.]

See Also

DirectoryEntryCollection.CollectionOverStringVariantProperty Class | DirectoryEntryCollection.CollectionOverStringVariantProperty Members | System.DirectoryServices Namespace


DirectoryEntryCollection.CollectionOverStringVariantProperty.AddRange

[To be supplied.]

[Visual Basic]
Public Sub AddRange( _
   ByVal value() As String _
)
[C#]
public void AddRange(
   string[] value
);
[C++]
public: void AddRange(
   String* value[]
);
[JScript]
public function AddRange(
   value : String[]
);

Parameters

value
[To be supplied.]

See Also

DirectoryEntryCollection.CollectionOverStringVariantProperty Class | DirectoryEntryCollection.CollectionOverStringVariantProperty Members | System.DirectoryServices Namespace


DirectoryEntryCollection.CollectionOverStringVariantProperty.Clear

[To be supplied.]

[Visual Basic]
Overridable Public Sub Clear()
[C#]
public virtual void Clear();
[C++]
public: virtual void Clear();
[JScript]
public function Clear();

See Also

DirectoryEntryCollection.CollectionOverStringVariantProperty Class | DirectoryEntryCollection.CollectionOverStringVariantProperty Members | System.DirectoryServices Namespace


DirectoryEntryCollection.CollectionOverStringVariantProperty.Contains

[To be supplied.]

[Visual Basic]
Public Function Contains( _
   ByVal value As String _
) As Boolean
[C#]
public bool Contains(
   string value
);
[C++]
public: bool Contains(
   String* value
);
[JScript]
public function Contains(
   value : String
) : Boolean;

Parameters

value
[To be supplied.]

See Also

DirectoryEntryCollection.CollectionOverStringVariantProperty Class | DirectoryEntryCollection.CollectionOverStringVariantProperty Members | System.DirectoryServices Namespace


DirectoryEntryCollection.CollectionOverStringVariantProperty.CopyTo

[To be supplied.]

[Visual Basic]
Overridable Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
[C#]
public virtual void CopyTo(
   Array array,
   int index
);
[C++]
public: virtual void CopyTo(
   Array* array,
   int index
);
[JScript]
public function CopyTo(
   array : Array,
   index : int
);

Parameters

array
[To be supplied.]
index
[To be supplied.]

See Also

DirectoryEntryCollection.CollectionOverStringVariantProperty Class | DirectoryEntryCollection.CollectionOverStringVariantProperty Members | System.DirectoryServices Namespace


DirectoryEntryCollection.CollectionOverStringVariantProperty.GetEnumerator

[To be supplied.]

[Visual Basic]
Overridable Public Function GetEnumerator() As IEnumerator
[C#]
public virtual IEnumerator GetEnumerator();
[C++]
public: virtual IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

See Also

DirectoryEntryCollection.CollectionOverStringVariantProperty Class | DirectoryEntryCollection.CollectionOverStringVariantProperty Members | System.DirectoryServices Namespace


DirectoryEntryCollection.CollectionOverStringVariantProperty.IndexOf

[To be supplied.]

[Visual Basic]
Public Function IndexOf( _
   ByVal value As String _
) As Integer
[C#]
public int IndexOf(
   string value
);
[C++]
public: int IndexOf(
   String* value
);
[JScript]
public function IndexOf(
   value : String
) : int;

Parameters

value
[To be supplied.]

See Also

DirectoryEntryCollection.CollectionOverStringVariantProperty Class | DirectoryEntryCollection.CollectionOverStringVariantProperty Members | System.DirectoryServices Namespace


DirectoryEntryCollection.CollectionOverStringVariantProperty.Insert

[To be supplied.]

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As String _
)
[C#]
public void Insert(
   int index,
   string value
);
[C++]
public: void Insert(
   int index,
   String* value
);
[JScript]
public function Insert(
   index : int,
   value : String
);

Parameters

index
[To be supplied.]
value
[To be supplied.]

See Also

DirectoryEntryCollection.CollectionOverStringVariantProperty Class | DirectoryEntryCollection.CollectionOverStringVariantProperty Members | System.DirectoryServices Namespace


DirectoryEntryCollection.CollectionOverStringVariantProperty.Remove

[To be supplied.]

[Visual Basic]
Public Sub Remove( _
   ByVal value As String _
)
[C#]
public void Remove(
   string value
);
[C++]
public: void Remove(
   String* value
);
[JScript]
public function Remove(
   value : String
);

Parameters

value
[To be supplied.]

See Also

DirectoryEntryCollection.CollectionOverStringVariantProperty Class | DirectoryEntryCollection.CollectionOverStringVariantProperty Members | System.DirectoryServices Namespace


DirectoryEntryCollection.CollectionOverStringVariantProperty.RemoveAt

[To be supplied.]

[Visual Basic]
Overridable Public Sub RemoveAt( _
   ByVal index As Integer _
)
[C#]
public virtual void RemoveAt(
   int index
);
[C++]
public: virtual void RemoveAt(
   int index
);
[JScript]
public function RemoveAt(
   index : int
);

Parameters

index
[To be supplied.]

See Also

DirectoryEntryCollection.CollectionOverStringVariantProperty Class | DirectoryEntryCollection.CollectionOverStringVariantProperty Members | System.DirectoryServices Namespace


DirectoryEntryProperty Class

Represents a single property on a DirectoryEntry.

Object
DirectoryEntryProperty

[Visual Basic]
Public Class DirectoryEntryProperty
[C#]
public class DirectoryEntryProperty
[C++]
public __gc class DirectoryEntryProperty
[JScript]
public class DirectoryEntryProperty

Remarks

The property may have multiple values.

Requirements

Namespace: System.DirectoryServices

Assembly: System.DirectoryServices.dll

See Also

DirectoryEntryProperty Members | System.DirectoryServices Namespace | DirectoryEntry | DirectoryEntryCollection | DirectoryEntryPropertyCollection | DirectoryEntryPropertyValueCollection


DirectoryEntryProperty Members

Public:

Properties

Name | Gets the name of the property.
Value | Gets or sets the value of the property.
Values | Gets a collection containing the values of this property.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirectoryEntryProperty Class | System.DirectoryServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DirectoryEntryProperty Properties

The properties of the DirectoryEntryProperty class are listed below. For a complete list of DirectoryEntryProperty class members, see the DirectoryEntryProperty Members topic.

Public:

Name | Gets the name of the property.
Value | Gets or sets the value of the property.
Values | Gets a collection containing the values of this property.

See Also

DirectoryEntryProperty Class | System.DirectoryServices Namespace


DirectoryEntryProperty.Name

Gets the name of the property.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}
[C++]
public: __property String* get_Name();
[JScript]
public function get Name() : String;

Property Value

The name of the property.

See Also

DirectoryEntryProperty Class | DirectoryEntryProperty Members | System.DirectoryServices Namespace


DirectoryEntryProperty.Value

Gets or sets the value of the property.

[Visual Basic]
Overridable Public Property Value As Object
[C#]
public object Value {virtual get; virtual set;}
[C++]
public: __property virtual Object* get_Value();
public: __property virtual void set_Value(Object*);
[JScript]
public function get Value() : Object;
public function set Value(Object);

Property Value

The value of the DirectoryEntryProperty. If the DirectoryEntryProperty has multiple values, the Value will be an array of the values.

Exceptions

Exception Type | Condition
COMException | The DirectoryEntryProperty does not have a value. -or- The value is not a valid type for the property. The associated error code is E_ADS_PROPERTY_INVALID.

See Also

DirectoryEntryProperty Class | DirectoryEntryProperty Members | System.DirectoryServices Namespace


DirectoryEntryProperty.Values

Gets a collection containing the values of this property.

[Visual Basic]
Overridable Public ReadOnly Property Values As _
   DirectoryEntryPropertyValueCollection
[C#]
public DirectoryEntryPropertyValueCollection Values {virtual get;}
[C++]
public: __property virtual DirectoryEntryPropertyValueCollection*
   get_Values();
[JScript]
public function get Values() :
   DirectoryEntryPropertyValueCollection;

Property Value

A collection containing the values of this property.

See Also

DirectoryEntryProperty Class | DirectoryEntryProperty Members | System.DirectoryServices Namespace | DirectoryEntryPropertyValueCollection


DirectoryEntryPropertyCollection Class

Contains the properties on an entry.

Object
DirectoryEntryPropertyCollection

[Visual Basic]
Public Class DirectoryEntryPropertyCollection
[C#]
public class DirectoryEntryPropertyCollection
[C++]
public __gc class DirectoryEntryPropertyCollection
[JScript]
public class DirectoryEntryPropertyCollection

Remarks

[To be supplied.]

Requirements

Namespace: System.DirectoryServices

Assembly: System.DirectoryServices.dll

See Also

DirectoryEntryPropertyCollection Members | System.DirectoryServices Namespace | DirectoryEntry | DirectoryEntryCollection | DirectoryEntryProperty | DirectoryEntryPropertyValueCollection


DirectoryEntryPropertyCollection Members

Public:

Properties

Count | Gets the number of properties available on this entry.
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the DirectoryEntryPropertyCollection class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Returns an enumerator, which can be used to iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirectoryEntryPropertyCollection Class | System.DirectoryServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DirectoryEntryPropertyCollection Properties

The properties of the DirectoryEntryPropertyCollection class are listed below. For a complete list of DirectoryEntryPropertyCollection class members, see the DirectoryEntryPropertyCollection Members topic.

Public:

Count | Gets the number of properties available on this entry.
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the DirectoryEntryPropertyCollection class.

See Also

DirectoryEntryPropertyCollection Class | System.DirectoryServices Namespace


DirectoryEntryPropertyCollection.Count

Gets the number of properties available on this entry.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

Property Value

The number of properties available on this entry.

See Also

DirectoryEntryPropertyCollection Class | DirectoryEntryPropertyCollection Members | System.DirectoryServices Namespace


DirectoryEntryPropertyCollection.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the DirectoryEntryPropertyCollection class.

Overload List

Gets the property with the given name.

[Visual Basic] Overloads Public Default ReadOnly Property Item(String) As DirectoryEntryProperty
[C#] public DirectoryEntryProperty this[String] {get;}
[C++] public: __property DirectoryEntryProperty* get_Item(String*);
[JScript] DirectoryEntryPropertyCollection.Item (String)

Gets the property at the given index.

[Visual Basic] Overloads Public Default ReadOnly Property Item(Integer) As DirectoryEntryProperty
[C#] public DirectoryEntryProperty this[int] {get;}
[C++] public: __property DirectoryEntryProperty* get_Item(int);
[JScript] DirectoryEntryPropertyCollection.Item (int)

See Also

DirectoryEntryPropertyCollection Class | DirectoryEntryPropertyCollection Members | System.DirectoryServices Namespace


DirectoryEntryPropertyCollection.Item (String)

Gets the property with the given name.

[C#] In C#, this member is the indexer for the DirectoryEntryPropertyCollection class.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
   ByVal name As String _
) As DirectoryEntryProperty
[C#]
public DirectoryEntryProperty this[
   string name
] {get;}
[C++]
public: __property DirectoryEntryProperty* get_Item(
   String* name
);
[JScript]
returnValue = DirectoryEntryPropertyCollectionObject.Item(name);
-or-
returnValue = DirectoryEntryPropertyCollectionObject(name);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
The name of the property to retrieve.

Parameters [Visual Basic, C#, C++]

name
The name of the property to retrieve.

Property Value

The property with the given name.

Exceptions

Exception Type | Condition
COMException | The property does not exist. The associated error code is E_ADS_PROPERTY_NOT_SUPPORTED.

See Also

DirectoryEntryPropertyCollection Class | DirectoryEntryPropertyCollection Members | System.DirectoryServices Namespace | DirectoryEntryPropertyCollection.Item Overload List | DirectoryEntryProperty


DirectoryEntryPropertyCollection.Item (Int32)

Gets the property at the given index.

[C#] In C#, this member is the indexer for the DirectoryEntryPropertyCollection class.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
   ByVal i As Integer _
) As DirectoryEntryProperty
[C#]
public DirectoryEntryProperty this[
   int i
] {get;}
[C++]
public: __property DirectoryEntryProperty* get_Item(
   int i
);
[JScript]
returnValue = DirectoryEntryPropertyCollectionObject.Item(i);
-or-
returnValue = DirectoryEntryPropertyCollectionObject(i);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

i
The zero-based index of the collection.

Parameters [Visual Basic, C#, C++]

i
The zero-based index of the collection.

Property Value

The property from the given index.

Exceptions

Exception Type | Condition
NotSupportedException | The entry's properties cannot be indexed by number.

See Also

DirectoryEntryPropertyCollection Class | DirectoryEntryPropertyCollection Members | System.DirectoryServices Namespace | DirectoryEntryPropertyCollection.Item Overload List | DirectoryEntryProperty


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DirectoryEntryPropertyCollection Methods

The methods of the DirectoryEntryPropertyCollection class are listed below. For a complete list of DirectoryEntryPropertyCollection class members, see the DirectoryEntryPropertyCollection Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Returns an enumerator, which can be used to iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirectoryEntryPropertyCollection Class | System.DirectoryServices Namespace


DirectoryEntryPropertyCollection.GetEnumerator

Returns an enumerator, which can be used to iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As IEnumerator
[C#]
public IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

Return Value

An enumerator, which can be used to iterate through the collection.

See Also

DirectoryEntryPropertyCollection Class | DirectoryEntryPropertyCollection Members | System.DirectoryServices Namespace | System.IEnumerator


DirectoryEntryPropertyCollection.PropertyEnumerator Class

Supports a simple ForEach-style iteration over a collection and defines enumerators, size, and synchronization methods.

Object
DirectoryEntryPropertyCollection.PropertyEnumerator

[Visual Basic]
Public Class DirectoryEntryPropertyCollection.PropertyEnumerator
   Implements IEnumerator
[C#]
public class DirectoryEntryPropertyCollection.PropertyEnumerator :
   IEnumerator
[C++]
public __gc class
   DirectoryEntryPropertyCollection.PropertyEnumerator : public
   IEnumerator
[JScript]
public class DirectoryEntryPropertyCollection.PropertyEnumerator
   implements IEnumerator

Remarks

[To be supplied.]

Requirements

Namespace: System.DirectoryServices

Assembly: System.DirectoryServices.dll

See Also

DirectoryEntryPropertyCollection.PropertyEnumerator Members | System.DirectoryServices Namespace | DirectoryEntryPropertyCollection


DirectoryEntryPropertyCollection.PropertyEnumerator Members

Public:

Properties

Current [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
MoveNext | [To be supplied.]
Reset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirectoryEntryPropertyCollection.PropertyEnumerator Class | System.DirectoryServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DirectoryEntryPropertyCollection.PropertyEnumerator Properties

The properties of the DirectoryEntryPropertyCollection.PropertyEnumerator class are listed below. For a complete list of DirectoryEntryPropertyCollection.PropertyEnumerator class members, see the DirectoryEntryPropertyCollection.PropertyEnumerator Members topic.

Public:

Current [To be supplied.]

See Also

DirectoryEntryPropertyCollection.PropertyEnumerator Class | System.DirectoryServices Namespace


DirectoryEntryPropertyCollection.PropertyEnumerator.Current

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Current As DirectoryEntryProperty
[C#]
public DirectoryEntryProperty Current {get;}
[C++]
public: __property DirectoryEntryProperty* get_Current();
[JScript]
public function get Current() : DirectoryEntryProperty;

See Also

DirectoryEntryPropertyCollection.PropertyEnumerator Class | DirectoryEntryPropertyCollection.PropertyEnumerator Members | System.DirectoryServices Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DirectoryEntryPropertyCollection.PropertyEnumerator Methods

The methods of the DirectoryEntryPropertyCollection.PropertyEnumerator class are listed below. For a complete list of DirectoryEntryPropertyCollection.PropertyEnumerator class members, see the DirectoryEntryPropertyCollection.PropertyEnumerator Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
MoveNext | [To be supplied.]
Reset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirectoryEntryPropertyCollection.PropertyEnumerator Class | System.DirectoryServices Namespace


DirectoryEntryPropertyCollection.PropertyEnumerator.MoveNext

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;

See Also

DirectoryEntryPropertyCollection.PropertyEnumerator Class | DirectoryEntryPropertyCollection.PropertyEnumerator Members | System.DirectoryServices Namespace


DirectoryEntryPropertyCollection.PropertyEnumerator.Reset

[To be supplied.]

[Visual Basic]
Overridable Public Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();

See Also

DirectoryEntryPropertyCollection.PropertyEnumerator Class | DirectoryEntryPropertyCollection.PropertyEnumerator Members | System.DirectoryServices Namespace


DirectoryEntryPropertyValueCollection Class

Specifies a collection of values for a multi-valued property.

Object
DirectoryEntryPropertyValueCollection

[Visual Basic]
Public Class DirectoryEntryPropertyValueCollection
   Implements ICollection, IEnumerable
[C#]
public class DirectoryEntryPropertyValueCollection : ICollection,
   IEnumerable
[C++]
public __gc class DirectoryEntryPropertyValueCollection : public
   ICollection, IEnumerable
[JScript]
public class DirectoryEntryPropertyValueCollection implements
   ICollection, IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.DirectoryServices

Assembly: System.DirectoryServices.dll

See Also

DirectoryEntryPropertyValueCollection Members | System.DirectoryServices Namespace | DirectoryEntry | DirectoryEntryCollection | DirectoryEntryProperty | DirectoryEntryPropertyCollection


DirectoryEntryPropertyValueCollection Members

Public:

Properties

IsReadOnly | Gets a value indicating whether the DirectoryEntryProperty is read-only.
IsSynchronized | Gets a value indicating whether this collection is synchronized.
SyncRoot | Gets an object to use for synchronization (thread safety).

Methods

Add | Appends the value to the set of values for this property.
AddRange | Appends the values to the set of values for this property.
Clear | Removes all values for this property, causing the property to be unassigned.
CopyTo | Copies the elements of this instance into an Array, starting at a particular index into the given array.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Returns an enumerator, which can be used to iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Remove | Removes the value from the collection.
RemoveRange | Removes the values from the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirectoryEntryPropertyValueCollection Class | System.DirectoryServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DirectoryEntryPropertyValueCollection Properties

The properties of the DirectoryEntryPropertyValueCollection class are listed below. For a complete list of DirectoryEntryPropertyValueCollection class members, see the DirectoryEntryPropertyValueCollection Members topic.

Public:

IsReadOnly | Gets a value indicating whether the DirectoryEntryProperty is read-only.
IsSynchronized | Gets a value indicating whether this collection is synchronized.
SyncRoot | Gets an object to use for synchronization (thread safety).

See Also

DirectoryEntryPropertyValueCollection Class | System.DirectoryServices Namespace


DirectoryEntryPropertyValueCollection.IsReadOnly

Gets a value indicating whether the DirectoryEntryProperty is read-only.

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {virtual get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;

Property Value

true if the DirectoryEntryProperty is read-only; otherwise, false.

See Also

DirectoryEntryPropertyValueCollection Class | DirectoryEntryPropertyValueCollection Members | System.DirectoryServices Namespace


DirectoryEntryPropertyValueCollection.IsSynchronized

Gets a value indicating whether this collection is synchronized.

[Visual Basic]
Overridable Public ReadOnly Property IsSynchronized As Boolean
[C#]
public bool IsSynchronized {virtual get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[JScript]
public function get IsSynchronized() : Boolean;

Property Value

true if this collection is thread-safe; otherwise, false.

Remarks

Use System.DirectoryEntryPropertyValueCollection.SyncRoot to get an object to use for synchronization.

See Also

DirectoryEntryPropertyValueCollection Class | DirectoryEntryPropertyValueCollection Members | System.DirectoryServices Namespace | SyncRoot


DirectoryEntryPropertyValueCollection.SyncRoot

Gets an object to use for synchronization (thread safety).

[Visual Basic]
Overridable Public ReadOnly Property SyncRoot As Object
[C#]
public object SyncRoot {virtual get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[JScript]
public function get SyncRoot() : Object;

Property Value

An object to use for synchronization.

See Also

DirectoryEntryPropertyValueCollection Class | DirectoryEntryPropertyValueCollection Members | System.DirectoryServices Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DirectoryEntryPropertyValueCollection Methods

The methods of the DirectoryEntryPropertyValueCollection class are listed below. For a complete list of DirectoryEntryPropertyValueCollection class members, see the DirectoryEntryPropertyValueCollection Members topic.

Public:

Add | Appends the value to the set of values for this property.
AddRange | Appends the values to the set of values for this property.
Clear | Removes all values for this property, causing the property to be unassigned.
CopyTo | Copies the elements of this instance into an Array, starting at a particular index into the given array.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Returns an enumerator, which can be used to iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Remove | Removes the value from the collection.
RemoveRange | Removes the values from the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirectoryEntryPropertyValueCollection Class | System.DirectoryServices Namespace


DirectoryEntryPropertyValueCollection.Add

Appends the value to the set of values for this property.

[Visual Basic]
Public Sub Add( _
   ByVal value As Object _
)
[C#]
public void Add(
   object value
);
[C++]
public: void Add(
   Object* value
);
[JScript]
public function Add(
   value : Object
);

Parameters

value
The value to add.

Exceptions

Exception Type | Condition
COMException | The value is not a valid type for the property. The associated error code is E_ADS_PROPERTY_INVALID.

See Also

DirectoryEntryPropertyValueCollection Class | DirectoryEntryPropertyValueCollection Members | System.DirectoryServices Namespace


DirectoryEntryPropertyValueCollection.AddRange

Appends the values to the set of values for this property.

[Visual Basic]
Public Sub AddRange( _
   ByVal values() As Object _
)
[C#]
public void AddRange(
   object[] values
);
[C++]
public: void AddRange(
   Object* values[]
);
[JScript]
public function AddRange(
   values : Object[]
);

Parameters

values
An array of type Object that contains the values to add.

See Also

DirectoryEntryPropertyValueCollection Class | DirectoryEntryPropertyValueCollection Members | System.DirectoryServices Namespace


DirectoryEntryPropertyValueCollection.Clear

Removes all values for this property, causing the property to be unassigned.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[JScript]
public function Clear();

See Also

DirectoryEntryPropertyValueCollection Class | DirectoryEntryPropertyValueCollection Members | System.DirectoryServices Namespace


DirectoryEntryPropertyValueCollection.CopyTo

Copies the elements of this instance into an Array, starting at a particular index into the given array.

[Visual Basic]
Overridable Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
[C#]
public virtual void CopyTo(
   Array array,
   int index
);
[C++]
public: virtual void CopyTo(
   Array* array,
   int index
);
[JScript]
public function CopyTo(
   array : Array,
   index : int
);

Parameters

array
An array of type Array that will hold the collection's elements.
index
The beginning index in the array where the elements will be copied.

Exceptions

Exception Type | Condition
ArgumentException | The index plus the size of this collection is greater than the length of the array.
ArgumentNullException | The array is null.
ArgumentOutOfRangeException | The index is out of the array's bounds.

See Also

DirectoryEntryPropertyValueCollection Class | DirectoryEntryPropertyValueCollection Members | System.DirectoryServices Namespace


DirectoryEntryPropertyValueCollection.GetEnumerator

Returns an enumerator, which can be used to iterate through the collection.

[Visual Basic]
Overridable Public Function GetEnumerator() As IEnumerator
[C#]
public virtual IEnumerator GetEnumerator();
[C++]
public: virtual IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

Return Value

An enumerator, which can be used to iterate through the collection.

See Also

DirectoryEntryPropertyValueCollection Class | DirectoryEntryPropertyValueCollection Members | System.DirectoryServices Namespace | System.IEnumerator


DirectoryEntryPropertyValueCollection.Remove

Removes the value from the collection.

[Visual Basic]
Public Sub Remove( _
   ByVal value As Object _
)
[C#]
public void Remove(
   object value
);
[C++]
public: void Remove(
   Object* value
);
[JScript]
public function Remove(
   value : Object
);

Parameters

value
The value to remove.

See Also

DirectoryEntryPropertyValueCollection Class | DirectoryEntryPropertyValueCollection Members | System.DirectoryServices Namespace


DirectoryEntryPropertyValueCollection.RemoveRange

Removes the values from the collection.

[Visual Basic]
Public Sub RemoveRange( _
   ByVal values() As Object _
)
[C#]
public void RemoveRange(
   object[] values
);
[C++]
public: void RemoveRange(
   Object* values[]
);
[JScript]
public function RemoveRange(
   values : Object[]
);

Parameters

values
An array of type Object that contains the values to remove.

See Also

DirectoryEntryPropertyValueCollection Class | DirectoryEntryPropertyValueCollection Members | System.DirectoryServices Namespace


DirectorySearcher Class

Lets you search and perform queries against the Active Directory hierarchy.

Object
Component
DirectorySearcher

[Visual Basic]
Public Class DirectorySearcher
   Inherits Component
[C#]
public class DirectorySearcher : Component
[C++]
public __gc class DirectorySearcher : public Component
[JScript]
public class DirectorySearcher extends Component

Remarks

[To be supplied.]

Requirements

Namespace: System.DirectoryServices

Assembly: System.DirectoryServices.dll

See Also

DirectorySearcher Members | System.DirectoryServices Namespace


DirectorySearcher Members

Public:

Constructor

DirectorySearcher Constructor Overloaded. [To be supplied.]

Properties

CacheResults | Specifies whether the result should be cached on the client machine. By default, ADSI caches the result set. Turning off this option may be more desirable for large result sets.
ClientTimeout | The maximum amount of time the client will wait for the server to return results. If the server does not respond within this time, the search will be aborted, and no results will be returned.
Filter | The Filter property is a single string conforming to RFC2254, which specifies the LDAP filter string format. It uses prefix notation to combine qualifications (though "=" is still infix). For example, The default value is "(objectClass=*)", which retrieves all objects.
PageSize | Instructs the server to perform a paged search. Once the server has found PageSize objects, it will stop searching and return the results to the client. When the client requests more data, the server will restart the search where it left off. Default is-1, which means do not page.
PropertiesToLoad | The set of properties to be retrieved with the search. By default, the Path and Name properties are retrieved.
PropertyNamesOnly | UNDONE, stefanph: If they're not excluded, what do you get?!
ReferralChasing | Specifies how (and whether) referrals are chased.
SearchRoot | The node in the Active Directory hierarchy at which the search will start.
SearchScope | Determines the scope of the search. Default is SearchScope.Subtree.
ServerPageTimeLimit | Specifies the time limit that the server should observe to search a page of results (as opposed to the time limit for the entire search). Set to a negative value for no time limit. This property applies only to searches where PageSize has been set to something other than the default.
ServerTimeLimit | The maximum amount of time the server will spend searching. If the time limit is reached, only entries found up to that point will be returned. Set to a negative value to use the server-determined default.
Site (inherited from Component) | Gets or sets the site of the Component.
SizeLimit | The maximum number of entries the server will find before returning. If the size limit is reached, only entries found up to that point will be returned. Specify-1 to use the server-determined default size limit.
Sort | Allows you to set a property on which the results should be sorted.

Methods

Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FindAll | Executes the search. A collection of results is returned that you can iterate over.
FindOne | Executes the search. If the search returns more than one entry, only the first one is returned. If no entries were find matching the search criteria, null is returned.
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirectorySearcher Class | System.DirectoryServices Namespace


DirectorySearcher Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public DirectorySearcher();
[C++] public: DirectorySearcher();
[JScript] public function DirectorySearcher();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(DirectoryEntry)
[C#] public DirectorySearcher(DirectoryEntry);
[C++] public: DirectorySearcher(DirectoryEntry*);
[JScript] public function DirectorySearcher(DirectoryEntry);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(DirectoryEntry, String)
[C#] public DirectorySearcher(DirectoryEntry, String);
[C++] public: DirectorySearcher(DirectoryEntry*, String);
[JScript] public function DirectorySearcher(DirectoryEntry, String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(DirectoryEntry, String, String())
[C#] public DirectorySearcher(DirectoryEntry, String, String[]);
[C++] public: DirectorySearcher(DirectoryEntry*, String, String[]);
[JScript] public function DirectorySearcher(DirectoryEntry, String, String[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public DirectorySearcher(String);
[C++] public: DirectorySearcher(String*);
[JScript] public function DirectorySearcher(String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, String())
[C#] public DirectorySearcher(String, String[]);
[C++] public: DirectorySearcher(String*, String*[]);
[JScript] public function DirectorySearcher(String, String[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, String(), SearchScope)
[C#] public DirectorySearcher(String, String[], SearchScope);
[C++] public: DirectorySearcher(String*, String*[], SearchScope);
[JScript] public function DirectorySearcher(String, String[], SearchScope);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(DirectoryEntry, String, String(), SearchScope)
[C#] public DirectorySearcher(DirectoryEntry, String, String[], SearchScope);
[C++] public: DirectorySearcher(DirectoryEntry*, String, String[], SearchScope);
[JScript] public function DirectorySearcher(DirectoryEntry, String, String[], SearchScope);

See Also

DirectorySearcher Class | DirectorySearcher Members | System.DirectoryServices Namespace


DirectorySearcher Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public DirectorySearcher();
[C++]
public: DirectorySearcher();
[JScript]
public function DirectorySearcher();

See Also

DirectorySearcher Class | DirectorySearcher Members | System.DirectoryServices Namespace | DirectorySearcher Constructor Overload List


DirectorySearcher Constructor (DirectoryEntry)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal searchRoot As DirectoryEntry _
)
[C#]
public DirectorySearcher(
   DirectoryEntry searchRoot
);
[C++]
public: DirectorySearcher(
   DirectoryEntry* searchRoot
);
[JScript]
public function DirectorySearcher(
   searchRoot : DirectoryEntry
);

Parameters

searchRoot
[To be supplied.]

See Also

DirectorySearcher Class | DirectorySearcher Members | System.DirectoryServices Namespace | DirectorySearcher Constructor Overload List


DirectorySearcher Constructor (DirectoryEntry, String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal searchRoot As DirectoryEntry, _
   ByVal filter As String _
)
[C#]
public DirectorySearcher(
   DirectoryEntry searchRoot,
   string filter
);
[C++]
public: DirectorySearcher(
   DirectoryEntry* searchRoot,
   String* filter
);
[JScript]
public function DirectorySearcher(
   searchRoot : DirectoryEntry,
   filter : String
);

Parameters

searchRoot
[To be supplied.]
filter
[To be supplied.]

See Also

DirectorySearcher Class | DirectorySearcher Members | System.DirectoryServices Namespace | DirectorySearcher Constructor Overload List


DirectorySearcher Constructor (DirectoryEntry, String, String[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal searchRoot As DirectoryEntry, _
   ByVal filter As String, _
   ByVal propertiesToLoad() As String _
)
[C#]
public DirectorySearcher(
   DirectoryEntry searchRoot,
   string filter,
   string[] propertiesToLoad
);
[C++]
public: DirectorySearcher(
   DirectoryEntry* searchRoot,
   String* filter,
   String* propertiesToLoad[]
);
[JScript]
public function DirectorySearcher(
   searchRoot : DirectoryEntry,
   filter : String,
   propertiesToLoad : String[]
);

Parameters

searchRoot
[To be supplied.]
filter
[To be supplied.]
propertiesToLoad
[To be supplied.]

See Also

DirectorySearcher Class | DirectorySearcher Members | System.DirectoryServices Namespace | DirectorySearcher Constructor Overload List


DirectorySearcher Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal filter As String _
)
[C#]
public DirectorySearcher(
   string filter
);
[C++]
public: DirectorySearcher(
   String* filter
);
[JScript]
public function DirectorySearcher(
   filter : String
);

Parameters

filter
[To be supplied.]

See Also

DirectorySearcher Class | DirectorySearcher Members | System.DirectoryServices Namespace | DirectorySearcher Constructor Overload List


DirectorySearcher Constructor (String, String[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal filter As String, _
   ByVal propertiesToLoad() As String _
)
[C#]
public DirectorySearcher(
   string filter,
   string[] propertiesToLoad
);
[C++]
public: DirectorySearcher(
   String* filter,
   String* propertiesToLoad[]
);
[JScript]
public function DirectorySearcher(
   filter : String,
   propertiesToLoad : String[]
);

Parameters

filter
[To be supplied.]
propertiesToLoad
[To be supplied.]

See Also

DirectorySearcher Class | DirectorySearcher Members | System.DirectoryServices Namespace | DirectorySearcher Constructor Overload List


DirectorySearcher Constructor (String, String[], SearchScope)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal filter As String, _
   ByVal propertiesToLoad() As String, _
   ByVal scope As SearchScope _
)
[C#]
public DirectorySearcher(
   string filter,
   string[] propertiesToLoad,
   SearchScope scope
);
[C++]
public: DirectorySearcher(
   String* filter,
   String* propertiesToLoad[],
   SearchScope scope
);
[JScript]
public function DirectorySearcher(
   filter : String,
   propertiesToLoad : String[],
   scope : SearchScope
);

Parameters

filter
[To be supplied.]
propertiesToLoad
[To be supplied.]
scope
[To be supplied.]

See Also

DirectorySearcher Class | DirectorySearcher Members | System.DirectoryServices Namespace | DirectorySearcher Constructor Overload List


DirectorySearcher Constructor (DirectoryEntry, String, String[], SearchScope)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal searchRoot As DirectoryEntry, _
   ByVal filter As String, _
   ByVal propertiesToLoad() As String, _
   ByVal scope As SearchScope _
)
[C#]
public DirectorySearcher(
   DirectoryEntry searchRoot,
   string filter,
   string[] propertiesToLoad,
   SearchScope scope
);
[C++]
public: DirectorySearcher(
   DirectoryEntry* searchRoot,
   String* filter,
   String* propertiesToLoad[],
   SearchScope scope
);
[JScript]
public function DirectorySearcher(
   searchRoot : DirectoryEntry,
   filter : String,
   propertiesToLoad : String[],
   scope : SearchScope
);

Parameters

searchRoot
[To be supplied.]
filter
[To be supplied.]
propertiesToLoad
[To be supplied.]
scope
[To be supplied.]

See Also

DirectorySearcher Class | DirectorySearcher Members | System.DirectoryServices Namespace | DirectorySearcher Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DirectorySearcher Properties

The properties of the DirectorySearcher class are listed below. For a complete list of DirectorySearcher class members, see the DirectorySearcher Members topic.

Public:

CacheResults | Specifies whether the result should be cached on the client machine. By default, ADSI caches the result set. Turning off this option may be more desirable for large result sets.
ClientTimeout | The maximum amount of time the client will wait for the server to return results. If the server does not respond within this time, the search will be aborted, and no results will be returned.
Filter | The Filter property is a single string conforming to RFC2254, which specifies the LDAP filter string format. It uses prefix notation to combine qualifications (though "=" is still infix). For example, The default value is "(objectClass=*)", which retrieves all objects.
PageSize | Instructs the server to perform a paged search. Once the server has found PageSize objects, it will stop searching and return the results to the client. When the client requests more data, the server will restart the search where it left off. Default is-1, which means do not page.
PropertiesToLoad | The set of properties to be retrieved with the search. By default, the Path and Name properties are retrieved.
PropertyNamesOnly | UNDONE, stefanph: If they're not excluded, what do you get?!
ReferralChasing | Specifies how (and whether) referrals are chased.
SearchRoot | The node in the Active Directory hierarchy at which the search will start.
SearchScope | Determines the scope of the search. Default is SearchScope.Subtree.
ServerPageTimeLimit | Specifies the time limit that the server should observe to search a page of results (as opposed to the time limit for the entire search). Set to a negative value for no time limit. This property applies only to searches where PageSize has been set to something other than the default.
ServerTimeLimit | The maximum amount of time the server will spend searching. If the time limit is reached, only entries found up to that point will be returned. Set to a negative value to use the server-determined default.
Site (inherited from Component) | Gets or sets the site of the Component.
SizeLimit | The maximum number of entries the server will find before returning. If the size limit is reached, only entries found up to that point will be returned. Specify-1 to use the server-determined default size limit.
Sort | Allows you to set a property on which the results should be sorted.

See Also

DirectorySearcher Class | System.DirectoryServices Namespace


DirectorySearcher.CacheResults

Specifies whether the result should be cached on the client machine. By default, ADSI caches the result set. Turning off this option may be more desirable for large result sets.

[Visual Basic]
Public Property CacheResults As Boolean
[C#]
public bool CacheResults {get; set;}
[C++]
public: __property bool get_CacheResults();
public: __property void set_CacheResults(bool);
[JScript]
public function get CacheResults() : Boolean;
public function set CacheResults(Boolean);

See Also

DirectorySearcher Class | DirectorySearcher Members | System.DirectoryServices Namespace


DirectorySearcher.ClientTimeout

The maximum amount of time the client will wait for the server to return results. If the server does not respond within this time, the search will be aborted, and no results will be returned.

[Visual Basic]
Public Property ClientTimeout As TimeSpan
[C#]
public TimeSpan ClientTimeout {get; set;}
[C++]
public: __property TimeSpan get_ClientTimeout();
public: __property void set_ClientTimeout(TimeSpan);
[JScript]
public function get ClientTimeout() : TimeSpan;
public function set ClientTimeout(TimeSpan);

See Also

DirectorySearcher Class | DirectorySearcher Members | System.DirectoryServices Namespace


DirectorySearcher.Filter

The Filter property is a single string conforming to RFC2254, which specifies the LDAP filter string format. It uses prefix notation to combine qualifications (though "=" is still infix). For example, The default value is "(objectClass=*)", which retrieves all objects.

[Visual Basic]
Public Property Filter As String
[C#]
public string Filter {get; set;}
[C++]
public: __property String* get_Filter();
public: __property void set_Filter(String*);
[JScript]
public function get Filter() : String;
public function set Filter(String);

See Also

DirectorySearcher Class | DirectorySearcher Members | System.DirectoryServices Namespace


DirectorySearcher.PageSize

Instructs the server to perform a paged search. Once the server has found PageSize objects, it will stop searching and return the results to the client. When the client requests more data, the server will restart the search where it left off. Default is-1, which means do not page.

[Visual Basic]
Public Property PageSize As Integer
[C#]
public int PageSize {get; set;}
[C++]
public: __property int get_PageSize();
public: __property void set_PageSize(int);
[JScript]
public function get PageSize() : int;
public function set PageSize(int);

See Also

DirectorySearcher Class | DirectorySearcher Members | System.DirectoryServices Namespace


DirectorySearcher.PropertiesToLoad

The set of properties to be retrieved with the search. By default, the Path and Name properties are retrieved.

[Visual Basic]
Public ReadOnly Property PropertiesToLoad As StringCollection
[C#]
public StringCollection PropertiesToLoad {get;}
[C++]
public: __property StringCollection* get_PropertiesToLoad();
[JScript]
public function get PropertiesToLoad() : StringCollection;

See Also

DirectorySearcher Class | DirectorySearcher Members | System.DirectoryServices Namespace


DirectorySearcher.PropertyNamesOnly

UNDONE, stefanph: If they're not excluded, what do you get?!

[Visual Basic]
Public Property PropertyNamesOnly As Boolean
[C#]
public bool PropertyNamesOnly {get; set;}
[C++]
public: __property bool get_PropertyNamesOnly();
public: __property void set_PropertyNamesOnly(bool);
[JScript]
public function get PropertyNamesOnly() : Boolean;
public function set PropertyNamesOnly(Boolean);

See Also

DirectorySearcher Class | DirectorySearcher Members | System.DirectoryServices Namespace


DirectorySearcher.ReferralChasing

Specifies how (and whether) referrals are chased.

[Visual Basic]
Public Property ReferralChasing As ReferralChasingOptions
[C#]
public ReferralChasingOptions ReferralChasing {get; set;}
[C++]
public: __property ReferralChasingOptions get_ReferralChasing();
public: __property void set_ReferralChasing(ReferralChasingOptions);
[JScript]
public function get ReferralChasing() : ReferralChasingOptions;
public function set ReferralChasing(ReferralChasingOptions);

See Also

DirectorySearcher Class | DirectorySearcher Members | System.DirectoryServices Namespace


DirectorySearcher.SearchRoot

The node in the Active Directory hierarchy at which the search will start.

[Visual Basic]
Public Property SearchRoot As DirectoryEntry
[C#]
public DirectoryEntry SearchRoot {get; set;}
[C++]
public: __property DirectoryEntry* get_SearchRoot();
public: __property void set_SearchRoot(DirectoryEntry*);
[JScript]
public function get SearchRoot() : DirectoryEntry;
public function set SearchRoot(DirectoryEntry);

See Also

DirectorySearcher Class | DirectorySearcher Members | System.DirectoryServices Namespace


DirectorySearcher.SearchScope

Determines the scope of the search. Default is SearchScope.Subtree.

[Visual Basic]
Public Property SearchScope As SearchScope
[C#]
public SearchScope SearchScope {get; set;}
[C++]
public: __property SearchScope get_SearchScope();
public: __property void set_SearchScope(SearchScope);
[JScript]
public function get SearchScope() : SearchScope;
public function set SearchScope(SearchScope);

See Also

DirectorySearcher Class | DirectorySearcher Members | System.DirectoryServices Namespace


DirectorySearcher.ServerPageTimeLimit

Specifies the time limit that the server should observe to search a page of results (as opposed to the time limit for the entire search). Set to a negative value for no time limit. This property applies only to searches where PageSize has been set to something other than the default.

[Visual Basic]
Public Property ServerPageTimeLimit As TimeSpan
[C#]
public TimeSpan ServerPageTimeLimit {get; set;}
[C++]
public: __property TimeSpan get_ServerPageTimeLimit();
public: __property void set_ServerPageTimeLimit(TimeSpan);
[JScript]
public function get ServerPageTimeLimit() : TimeSpan;
public function set ServerPageTimeLimit(TimeSpan);

See Also

DirectorySearcher Class | DirectorySearcher Members | System.DirectoryServices Namespace


DirectorySearcher.ServerTimeLimit

The maximum amount of time the server will spend searching. If the time limit is reached, only entries found up to that point will be returned. Set to a negative value to use the server-determined default.

[Visual Basic]
Public Property ServerTimeLimit As TimeSpan
[C#]
public TimeSpan ServerTimeLimit {get; set;}
[C++]
public: __property TimeSpan get_ServerTimeLimit();
public: __property void set_ServerTimeLimit(TimeSpan);
[JScript]
public function get ServerTimeLimit() : TimeSpan;
public function set ServerTimeLimit(TimeSpan);

See Also

DirectorySearcher Class | DirectorySearcher Members | System.DirectoryServices Namespace


DirectorySearcher.SizeLimit

The maximum number of entries the server will find before returning. If the size limit is reached, only entries found up to that point will be returned. Specify-1 to use the server-determined default size limit.

[Visual Basic]
Public Property SizeLimit As Integer
[C#]
public int SizeLimit {get; set;}
[C++]
public: __property int get_SizeLimit();
public: __property void set_SizeLimit(int);
[JScript]
public function get SizeLimit() : int;
public function set SizeLimit(int);

See Also

DirectorySearcher Class | DirectorySearcher Members | System.DirectoryServices Namespace


DirectorySearcher.Sort

Allows you to set a property on which the results should be sorted.

[Visual Basic]
Public ReadOnly Property Sort As SortOption
[C#]
public SortOption Sort {get;}
[C++]
public: __property SortOption* get_Sort();
[JScript]
public function get Sort() : SortOption;

See Also

DirectorySearcher Class | DirectorySearcher Members | System.DirectoryServices Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DirectorySearcher Methods

The methods of the DirectorySearcher class are listed below. For a complete list of DirectorySearcher class members, see the DirectorySearcher Members topic.

Public:

Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FindAll | Executes the search. A collection of results is returned that you can iterate over.
FindOne | Executes the search. If the search returns more than one entry, only the first one is returned. If no entries were find matching the search criteria, null is returned.
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirectorySearcher Class | System.DirectoryServices Namespace


DirectorySearcher.FindAll

Executes the search. A collection of results is returned that you can iterate over.

[Visual Basic]
Public Function FindAll() As SearchResults
[C#]
public SearchResults FindAll();
[C++]
public: SearchResults* FindAll();
[JScript]
public function FindAll() : SearchResults;

See Also

DirectorySearcher Class | DirectorySearcher Members | System.DirectoryServices Namespace


DirectorySearcher.FindOne

Executes the search. If the search returns more than one entry, only the first one is returned. If no entries were find matching the search criteria, null is returned.

[Visual Basic]
Public Function FindOne() As SearchResultsEntry
[C#]
public SearchResultsEntry FindOne();
[C++]
public: SearchResultsEntry* FindOne();
[JScript]
public function FindOne() : SearchResultsEntry;

See Also

DirectorySearcher Class | DirectorySearcher Members | System.DirectoryServices Namespace


ReferralChasingOptions Enumeration

[To be supplied.]

[Visual Basic]
Public Enum ReferralChasingOptions
[C#]
public enum ReferralChasingOptions
[C++]
public enum ReferralChasingOptions

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
All | [To be supplied.]
External | [To be supplied.]
None | [To be supplied.]
Subordinate | [To be supplied.]

Requirements

Namespace: System.DirectoryServices

Assembly: System.DirectoryServices.dll

See Also

System.DirectoryServices Namespace


SearchResults Class

[To be supplied.]

Object
SearchResults

[Visual Basic]
Public Class SearchResults
   Implements IEnumerable
[C#]
public class SearchResults : IEnumerable
[C++]
public __gc class SearchResults : public IEnumerable
[JScript]
public class SearchResults implements IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.DirectoryServices

Assembly: System.DirectoryServices.dll

See Also

SearchResults Members | System.DirectoryServices Namespace


SearchResults Members

Public:

Properties

Handle | Returns the ADS_SEARCH_HANDLE value used by this result set.
PropertiesLoaded | A read-only collection of the properties specified on DirectorySearcher before the search was executed.

Methods

Dispose | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchResults Class | System.DirectoryServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SearchResults Properties

The properties of the SearchResults class are listed below. For a complete list of SearchResults class members, see the SearchResults Members topic.

Public:

Handle | Returns the ADS_SEARCH_HANDLE value used by this result set.
PropertiesLoaded | A read-only collection of the properties specified on DirectorySearcher before the search was executed.

See Also

SearchResults Class | System.DirectoryServices Namespace


SearchResults.Handle

Returns the ADS_SEARCH_HANDLE value used by this result set.

[Visual Basic]
Public ReadOnly Property Handle As Integer
[C#]
public int Handle {get;}
[C++]
public: __property int get_Handle();
[JScript]
public function get Handle() : int;

See Also

SearchResults Class | SearchResults Members | System.DirectoryServices Namespace


SearchResults.PropertiesLoaded

A read-only collection of the properties specified on DirectorySearcher before the search was executed.

[Visual Basic]
Public ReadOnly Property PropertiesLoaded As String ()
[C#]
public string[] PropertiesLoaded {get;}
[C++]
public: __property String* get_PropertiesLoaded();
[JScript]
public function get PropertiesLoaded() : String[];

See Also

SearchResults Class | SearchResults Members | System.DirectoryServices Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SearchResults Methods

The methods of the SearchResults class are listed below. For a complete list of SearchResults class members, see the SearchResults Members topic.

Public:

Dispose | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchResults Class | System.DirectoryServices Namespace


SearchResults.Dispose

[To be supplied.]

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[JScript]
public function Dispose();

See Also

SearchResults Class | SearchResults Members | System.DirectoryServices Namespace


SearchResults.Finalize

[To be supplied.]

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

SearchResults Class | SearchResults Members | System.DirectoryServices Namespace


SearchResults.GetEnumerator

[To be supplied.]

[Visual Basic]
Public Function GetEnumerator() As ResultsEnumerator
[C#]
public ResultsEnumerator GetEnumerator();
[C++]
public: ResultsEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : ResultsEnumerator;

See Also

SearchResults Class | SearchResults Members | System.DirectoryServices Namespace


SearchResults.ResultsEnumerator Class

[To be supplied.]

Object
SearchResults.ResultsEnumerator

[Visual Basic]
Public Class SearchResults.ResultsEnumerator
   Implements IEnumerator
[C#]
public class SearchResults.ResultsEnumerator : IEnumerator
[C++]
public __gc class SearchResults.ResultsEnumerator : public
   IEnumerator
[JScript]
public class SearchResults.ResultsEnumerator implements IEnumerator

Remarks

[To be supplied.]

Requirements

Namespace: System.DirectoryServices

Assembly: System.DirectoryServices.dll

See Also

SearchResults.ResultsEnumerator Members | System.DirectoryServices Namespace


SearchResults.ResultsEnumerator Members

Public:

Properties

Current [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
MoveNext | [To be supplied.]
Reset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchResults.ResultsEnumerator Class | System.DirectoryServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SearchResults.ResultsEnumerator Properties

The properties of the SearchResults.ResultsEnumerator class are listed below. For a complete list of SearchResults.ResultsEnumerator class members, see the SearchResults.ResultsEnumerator Members topic.

Public:

Current [To be supplied.]

See Also

SearchResults.ResultsEnumerator Class | System.DirectoryServices Namespace


SearchResults.ResultsEnumerator.Current

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Current As SearchResultsEntry
[C#]
public SearchResultsEntry Current {get;}
[C++]
public: __property SearchResultsEntry* get_Current();
[JScript]
public function get Current() : SearchResultsEntry;

See Also

SearchResults.ResultsEnumerator Class | SearchResults.ResultsEnumerator Members | System.DirectoryServices Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SearchResults.ResultsEnumerator Methods

The methods of the SearchResults.ResultsEnumerator class are listed below. For a complete list of SearchResults.ResultsEnumerator class members, see the SearchResults.ResultsEnumerator Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
MoveNext | [To be supplied.]
Reset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchResults.ResultsEnumerator Class | System.DirectoryServices Namespace


SearchResults.ResultsEnumerator.MoveNext

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;

See Also

SearchResults.ResultsEnumerator Class | SearchResults.ResultsEnumerator Members | System.DirectoryServices Namespace


SearchResults.ResultsEnumerator.Reset

[To be supplied.]

[Visual Basic]
Overridable Public Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();

See Also

SearchResults.ResultsEnumerator Class | SearchResults.ResultsEnumerator Members | System.DirectoryServices Namespace


SearchResultsEntry Class

[To be supplied.]

Object
SearchResultsEntry

[Visual Basic]
Public Class SearchResultsEntry
[C#]
public class SearchResultsEntry
[C++]
public __gc class SearchResultsEntry
[JScript]
public class SearchResultsEntry

Remarks

[To be supplied.]

Requirements

Namespace: System.DirectoryServices

Assembly: System.DirectoryServices.dll

See Also

SearchResultsEntry Members | System.DirectoryServices Namespace


SearchResultsEntry Members

Public:

Properties

Path | [To be supplied.]
Properties | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDirectoryEntry | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchResultsEntry Class | System.DirectoryServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SearchResultsEntry Properties

The properties of the SearchResultsEntry class are listed below. For a complete list of SearchResultsEntry class members, see the SearchResultsEntry Members topic.

Public:

Path | [To be supplied.]
Properties | [To be supplied.]

See Also

SearchResultsEntry Class | System.DirectoryServices Namespace


SearchResultsEntry.Path

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Path As String
[C#]
public string Path {get;}
[C++]
public: __property String* get_Path();
[JScript]
public function get Path() : String;

See Also

SearchResultsEntry Class | SearchResultsEntry Members | System.DirectoryServices Namespace


SearchResultsEntry.Properties

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Properties As _
   SearchResultsPropertyCollection
[C#]
public SearchResultsPropertyCollection Properties {get;}
[C++]
public: __property SearchResultsPropertyCollection*
   get_Properties();
[JScript]
public function get Properties() : SearchResultsPropertyCollection;

See Also

SearchResultsEntry Class | SearchResultsEntry Members | System.DirectoryServices Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SearchResultsEntry Methods

The methods of the SearchResultsEntry class are listed below. For a complete list of SearchResultsEntry class members, see the SearchResultsEntry Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDirectoryEntry | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchResultsEntry Class | System.DirectoryServices Namespace


SearchResultsEntry.GetDirectoryEntry

[To be supplied.]

[Visual Basic]
Public Function GetDirectoryEntry() As DirectoryEntry
[C#]
public DirectoryEntry GetDirectoryEntry();
[C++]
public: DirectoryEntry* GetDirectoryEntry();
[JScript]
public function GetDirectoryEntry() : DirectoryEntry;

See Also

SearchResultsEntry Class | SearchResultsEntry Members | System.DirectoryServices Namespace


SearchResultsProperty Class

[To be supplied.]

Object
SearchResultsProperty

[Visual Basic]
Public Class SearchResultsProperty
[C#]
public class SearchResultsProperty
[C++]
public __gc class SearchResultsProperty
[JScript]
public class SearchResultsProperty

Remarks

[To be supplied.]

Requirements

Namespace: System.DirectoryServices

Assembly: System.DirectoryServices.dll

See Also

SearchResultsProperty Members | System.DirectoryServices Namespace


SearchResultsProperty Members

Public:

Properties

Name | [To be supplied.]
Value | [To be supplied.]
Values | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchResultsProperty Class | System.DirectoryServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SearchResultsProperty Properties

The properties of the SearchResultsProperty class are listed below. For a complete list of SearchResultsProperty class members, see the SearchResultsProperty Members topic.

Public:

Name | [To be supplied.]
Value | [To be supplied.]
Values | [To be supplied.]

See Also

SearchResultsProperty Class | System.DirectoryServices Namespace


SearchResultsProperty.Name

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}
[C++]
public: __property String* get_Name();
[JScript]
public function get Name() : String;

See Also

SearchResultsProperty Class | SearchResultsProperty Members | System.DirectoryServices Namespace


SearchResultsProperty.Value

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Value As Object
[C#]
public object Value {get;}
[C++]
public: __property Object* get_Value();
[JScript]
public function get Value() : Object;

See Also

SearchResultsProperty Class | SearchResultsProperty Members | System.DirectoryServices Namespace


SearchResultsProperty.Values

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Values As _
   SearchResultsPropertyValueCollection
[C#]
public SearchResultsPropertyValueCollection Values {get;}
[C++]
public: __property SearchResultsPropertyValueCollection*
   get_Values();
[JScript]
public function get Values() : SearchResultsPropertyValueCollection;

See Also

SearchResultsProperty Class | SearchResultsProperty Members | System.DirectoryServices Namespace


SearchResultsPropertyCollection Class

[To be supplied.]

Object
SearchResultsPropertyCollection

[Visual Basic]
Public Class SearchResultsPropertyCollection
[C#]
public class SearchResultsPropertyCollection
[C++]
public __gc class SearchResultsPropertyCollection
[JScript]
public class SearchResultsPropertyCollection

Remarks

[To be supplied.]

Requirements

Namespace: System.DirectoryServices

Assembly: System.DirectoryServices.dll

See Also

SearchResultsPropertyCollection Members | System.DirectoryServices Namespace


SearchResultsPropertyCollection Members

Public:

Properties

Item [To be supplied.]

In C#, this member is the indexer for the SearchResultsPropertyCollection class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchResultsPropertyCollection Class | System.DirectoryServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SearchResultsPropertyCollection Properties

The properties of the SearchResultsPropertyCollection class are listed below. For a complete list of SearchResultsPropertyCollection class members, see the SearchResultsPropertyCollection Members topic.

Public:

Item [To be supplied.]

In C#, this member is the indexer for the SearchResultsPropertyCollection class.

See Also

SearchResultsPropertyCollection Class | System.DirectoryServices Namespace


SearchResultsPropertyCollection.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the SearchResultsPropertyCollection class.

[Visual Basic]
Public Default ReadOnly Property Item( _
   ByVal name As String _
) As SearchResultsProperty
[C#]
public SearchResultsProperty this[
   string name
] {get;}
[C++]
public: __property SearchResultsProperty* get_Item(
   String* name
);
[JScript]
returnValue = SearchResultsPropertyCollectionObject.Item(name);
-or-
returnValue = SearchResultsPropertyCollectionObject(name);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
[To be supplied.]

Parameters [Visual Basic, C#, C++]

name
[To be supplied.]

See Also

SearchResultsPropertyCollection Class | SearchResultsPropertyCollection Members | System.DirectoryServices Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SearchResultsPropertyCollection Methods

The methods of the SearchResultsPropertyCollection class are listed below. For a complete list of SearchResultsPropertyCollection class members, see the SearchResultsPropertyCollection Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchResultsPropertyCollection Class | System.DirectoryServices Namespace


SearchResultsPropertyCollection.GetEnumerator

[To be supplied.]

[Visual Basic]
Public Function GetEnumerator() As SearchResultsPropertyEnumerator
[C#]
public SearchResultsPropertyEnumerator GetEnumerator();
[C++]
public: SearchResultsPropertyEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : SearchResultsPropertyEnumerator;

See Also

SearchResultsPropertyCollection Class | SearchResultsPropertyCollection Members | System.DirectoryServices Namespace


SearchResultsPropertyCollection.SearchResultsPropertyEnumerator Class

[To be supplied.]

Object
SearchResultsPropertyCollection.SearchResultsPropertyEnumerator

[Visual Basic]
Public Class _
   SearchResultsPropertyCollection.SearchResultsPropertyEnumerator
   Implements IEnumerator
[C#]
public class
   SearchResultsPropertyCollection.SearchResultsPropertyEnumerator :
   IEnumerator
[C++]
public __gc class
   SearchResultsPropertyCollection.SearchResultsPropertyEnumerator :
   public IEnumerator
[JScript]
public class
   SearchResultsPropertyCollection.SearchResultsPropertyEnumerator
   implements IEnumerator

Remarks

[To be supplied.]

Requirements

Namespace: System.DirectoryServices

Assembly: System.DirectoryServices.dll

See Also

SearchResultsPropertyCollection.SearchResultsPropertyEnumerator Members | System.DirectoryServices Namespace


SearchResultsPropertyCollection.SearchResultsPropertyEnumerator Members

Public:

Properties

Current [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
MoveNext | [To be supplied.]
Reset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchResultsPropertyCollection.SearchResultsPropertyEnumerator Class | System.DirectoryServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SearchResultsPropertyCollection.SearchResultsPropertyEnumerator Properties

The properties of the SearchResultsPropertyCollection.SearchResultsPropertyEnumerator class are listed below. For a complete list of SearchResultsPropertyCollection.SearchResultsPropertyEnumerator class members, see the SearchResultsPropertyCollection.SearchResultsPropertyEnumerator Members topic.

Public:

Current [To be supplied.]

See Also

SearchResultsPropertyCollection.SearchResultsPropertyEnumerator Class | System.DirectoryServices Namespace


SearchResultsPropertyCollection.SearchResultsPropertyEnumerator.Current

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Current As SearchResultsProperty
[C#]
public SearchResultsProperty Current {get;}
[C++]
public: __property SearchResultsProperty* get_Current();
[JScript]
public function get Current() : SearchResultsProperty;

See Also

SearchResultsPropertyCollection.SearchResultsPropertyEnumerator Class | SearchResultsPropertyCollection.SearchResultsPropertyEnumerator Members | System.DirectoryServices Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SearchResultsPropertyCollection.SearchResultsPropertyEnumerator Methods

The methods of the SearchResultsPropertyCollection.SearchResultsPropertyEnumerator class are listed below. For a complete list of SearchResultsPropertyCollection.SearchResultsPropertyEnumerator class members, see the SearchResultsPropertyCollection.SearchResultsPropertyEnumerator Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
MoveNext | [To be supplied.]
Reset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchResultsPropertyCollection.SearchResultsPropertyEnumerator Class | System.DirectoryServices Namespace


SearchResultsPropertyCollection.SearchResultsPropertyEnumerator.MoveNext

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;

See Also

SearchResultsPropertyCollection.SearchResultsPropertyEnumerator Class | SearchResultsPropertyCollection.SearchResultsPropertyEnumerator Members | System.DirectoryServices Namespace


SearchResultsPropertyCollection.SearchResultsPropertyEnumerator.Reset

[To be supplied.]

[Visual Basic]
Overridable Public Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();

See Also

SearchResultsPropertyCollection.SearchResultsPropertyEnumerator Class | SearchResultsPropertyCollection.SearchResultsPropertyEnumerator Members | System.DirectoryServices Namespace


SearchResultsPropertyValueCollection Class

[To be supplied.]

Object
SearchResultsPropertyValueCollection

[Visual Basic]
Public Class SearchResultsPropertyValueCollection
[C#]
public class SearchResultsPropertyValueCollection
[C++]
public __gc class SearchResultsPropertyValueCollection
[JScript]
public class SearchResultsPropertyValueCollection

Remarks

[To be supplied.]

Requirements

Namespace: System.DirectoryServices

Assembly: System.DirectoryServices.dll

See Also

SearchResultsPropertyValueCollection Members | System.DirectoryServices Namespace


SearchResultsPropertyValueCollection Members

Public:

Properties

Item [To be supplied.]

In C#, this member is the indexer for the SearchResultsPropertyValueCollection class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchResultsPropertyValueCollection Class | System.DirectoryServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SearchResultsPropertyValueCollection Properties

The properties of the SearchResultsPropertyValueCollection class are listed below. For a complete list of SearchResultsPropertyValueCollection class members, see the SearchResultsPropertyValueCollection Members topic.

Public:

Item [To be supplied.]

In C#, this member is the indexer for the SearchResultsPropertyValueCollection class.

See Also

SearchResultsPropertyValueCollection Class | System.DirectoryServices Namespace


SearchResultsPropertyValueCollection.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the SearchResultsPropertyValueCollection class.

[Visual Basic]
Public Default ReadOnly Property Item( _
   ByVal index As Integer _
) As Object
[C#]
public object this[
   int index
] {get;}
[C++]
public: __property Object* get_Item(
   int index
);
[JScript]
returnValue = SearchResultsPropertyValueCollectionObject.Item(index);
-or-
returnValue = SearchResultsPropertyValueCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
[To be supplied.]

Parameters [Visual Basic, C#, C++]

index
[To be supplied.]

See Also

SearchResultsPropertyValueCollection Class | SearchResultsPropertyValueCollection Members | System.DirectoryServices Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SearchResultsPropertyValueCollection Methods

The methods of the SearchResultsPropertyValueCollection class are listed below. For a complete list of SearchResultsPropertyValueCollection class members, see the SearchResultsPropertyValueCollection Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchResultsPropertyValueCollection Class | System.DirectoryServices Namespace


SearchResultsPropertyValueCollection.GetEnumerator

[To be supplied.]

[Visual Basic]
Public Function GetEnumerator() As IEnumerator
[C#]
public IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

See Also

SearchResultsPropertyValueCollection Class | SearchResultsPropertyValueCollection Members | System.DirectoryServices Namespace


SearchScope Enumeration

Used to determine the set of nodes examined in a search with DirectorySearcher.

[Visual Basic]
Public Enum SearchScope
[C#]
public enum SearchScope
[C++]
public enum SearchScope

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Base | [To be supplied.]
OneLevel | [To be supplied.]
Subtree | [To be supplied.]

Requirements

Namespace: System.DirectoryServices

Assembly: System.DirectoryServices.dll

See Also

System.DirectoryServices Namespace


SortDirection Enumeration

[To be supplied.]

[Visual Basic]
Public Enum SortDirection
[C#]
public enum SortDirection
[C++]
public enum SortDirection

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Ascending | [To be supplied.]
Descending | [To be supplied.]

Requirements

Namespace: System.DirectoryServices

Assembly: System.DirectoryServices.dll

See Also

System.DirectoryServices Namespace


SortOption Class

[To be supplied.]

Object
SortOption

[Visual Basic]
Public Class SortOption
[C#]
public class SortOption
[C++]
public __gc class SortOption
[JScript]
public class SortOption

Remarks

[To be supplied.]

Requirements

Namespace: System.DirectoryServices

Assembly: System.DirectoryServices.dll

See Also

SortOption Members | System.DirectoryServices Namespace


SortOption Members

Public:

Constructor

SortOption Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Direction | [To be supplied.]
PropertyName | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SortOption Class | System.DirectoryServices Namespace


SortOption Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public SortOption();
[C++]
public: SortOption();
[JScript]
public function SortOption();

See Also

SortOption Class | SortOption Members | System.DirectoryServices Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SortOption Fields

The fields of the SortOption class are listed below. For a complete list of SortOption class members, see the SortOption Members topic.

Public:

Direction | [To be supplied.]
PropertyName | [To be supplied.]

See Also

SortOption Class | System.DirectoryServices Namespace


SortOption.Direction

[To be supplied.]

[Visual Basic]
Public Direction As SortDirection
[C#]
public SortDirection Direction;
[C++]
public: SortDirection Direction;
[JScript]
public var Direction : SortDirection;

See Also

SortOption Class | SortOption Members | System.DirectoryServices Namespace


SortOption.PropertyName

[To be supplied.]

[Visual Basic]
Public PropertyName As String
[C#]
public string PropertyName;
[C++]
public: String* PropertyName;
[JScript]
public var PropertyName : String;

See Also

SortOption Class | SortOption Members | System.DirectoryServices Namespace


System.Drawing

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Drawing Namespace

Classes

Class | Description
Bitmap | Encapsultates a GDI+ bitmap.
Brush | Classes derrived from this abstract base class define objects used to fill the interiors of graphical shapes such as rectangles, ellipses, pies, polygons, and paths.
Brushes | Brushes for all the standard colors.
ColorConverter | ColorConverter is a class that can be used to convert colors from one data type to another. Access this class through the TypeDescriptor.
ColorTranslator | [To be supplied.]
Cursor | A cursor object is used to paint the mouse pointer. Different cursor shapes are used as visual queues to inform the user what operation the mouse will have.
CursorConverter | CursorConverter is a class that can be used to convert colors from one data type to another. Access this class through the TypeDescriptor.
Cursors | Standard cursors
Font | [To be supplied.]
FontConverter | FontConverter is a class that can be used to convert fonts from one data type to another. Access this class through the TypeDescriptor.
FontFamily | Abstracts a group of type faces having a similar basic design but having certain variation in styles.
Graphics | [To be supplied.]
GraphicsAdvancedAttribute | [To be supplied.]
Icon | This class represents a Windows icon, which is a small bitmap image used to represent an object. Icons can be thought of as transparent bitmaps, although their size is determined by the system.
IconConverter | IconConverter is a class that can be used to convert Icon from one data type to another. Access this class through the TypeDescriptor.
Image | [To be supplied.]
ImageAnimator | [To be supplied.]
ImageConverter | ImageConverter is a class that can be used to convert Image from one data type to another. Access this class through the TypeDescriptor.
Pen | Defines an object used to draw lines and curves.
Pens | Pens for all the standard colors.
PointConverter | PointConverter is a class that can be used to convert Point from one data type to another. Access this class through the TypeDescriptor.
RectangleConverter | RectangleConverter is a class that can be used to convert rectangles from one data type to another. Access this class through the TypeDescriptor.
Region | [To be supplied.]
SizeConverter | SizeConverter is a class that can be used to convert Size from one data type to another. Access this class through the TypeDescriptor.
SolidBrush | [To be supplied.]
StringFormat | [To be supplied.]
SystemBrushes | Brushes for select Windows system-wide colors. Whenever possible, try to use SystemPens and SystemBrushes rather than SystemColors.
SystemColors | Windows system-wide colors. Whenever possible, try to use SystemPens and SystemBrushes rather than SystemColors.
SystemIcons | Icon objects for Windows system-wide icons.
SystemPens | Pens for select Windows system-wide colors. Whenever possible, try to use SystemPens and SystemBrushes rather than SystemColors.
TextureBrush | [To be supplied.]
ToolboxBitmapAttribute | ToolboxBitmapAttribute defines the images associated with a specified component. The component can offer a small and large image (large is optional).

Structures

Structure | Description
Color | [To be supplied.]
Point | This is a class that represents a single (X,Y) coordinate and various interesting operations on such a coordinate.
PointF | [To be supplied.]
Rectangle | Rectangle. Stores the location and size of a rectangular region. For more advanced region functions use a Region object.
RectangleF | RectangleF. Stores the location and size of a rectangular region. For more advanced region functions use a Region object.
Size | [To be supplied.]
SizeF | [To be supplied.]

Delegates

Delegate | Description
Graphics.DrawImageAbort | [To be supplied.]
Graphics.EnumerateMetafileProc | [To be supplied.]
Image.GetThumbnailImageAbort | [To be supplied.]

Enumerations

Enumeration | Description
BrushStyle | Defines a variety of brush styles that can be applied to brushes.
ContentAlignment | Content alignment.
FontStyle | Specifies style information applied to text.
GraphicsUnit | [To be supplied.]
KnownColor | [To be supplied.]
PenStyle | Defines different styles that a pen can be created with.
PolyFillMode | Enum that represents the different ways a region's overlapping polygons may be filled.
StringAlignment | [To be supplied.]
StringFormatFlags | [To be supplied.]
StringTrimming | [To be supplied.]
StringUnit | [To be supplied.]


Bitmap Class

Encapsultates a GDI+ bitmap.

Object
MarshalByRefObject
Image
Bitmap

[Visual Basic]
NotInheritable Public Class Bitmap
   Inherits Image
[C#]
public sealed class Bitmap : Image
[C++]
public __gc __sealed class Bitmap : public Image
[JScript]
public class Bitmap extends Image

Remarks

A bitmap consists of the pixel data for a graphics image and it's attributes.

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

Bitmap Members | System.Drawing Namespace


Bitmap Members

Public:

Constructor

Bitmap Constructor Overloaded. Initializes a new instance of the Bitmap class.

Properties

Flags (inherited from Image) | [To be supplied.]
FrameDimensionsList (inherited from Image) | [To be supplied.]
Height (inherited from Image) | [To be supplied.]
HorizontalResolution (inherited from Image) | [To be supplied.]
Palette (inherited from Image) | [To be supplied.]
PhysicalDimension (inherited from Image) | [To be supplied.]
PixelFormat (inherited from Image) | [To be supplied.]
PropertyIdList (inherited from Image) | [To be supplied.]
PropertyItems (inherited from Image) | [To be supplied.]
RawFormat (inherited from Image) | [To be supplied.]
Size (inherited from Image) | [To be supplied.]
VerticalResolution (inherited from Image) | [To be supplied.]
Width (inherited from Image) | [To be supplied.]

Methods

Clone | Overloaded. Creates a copy of this Bitmap.
Dispose (inherited from Image) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FromHICON | [To be supplied.]
FromResource | [To be supplied.]
GetBounds (inherited from Image) | [To be supplied.]
GetEncoderParameterList (inherited from Image) | [To be supplied.]
GetFrameCount (inherited from Image) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHBITMAP | Overloaded. [To be supplied.]
GetHICON | [To be supplied.]
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetObjectData (inherited from Image) | ISerializable private implementation
GetPixel | Gets the color of the specified pixel in this Bitmap.
GetPropertyItem (inherited from Image) | [To be supplied.]
GetThumbnailImage (inherited from Image) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
LockBits | [To be supplied.]
MakeTransparent | Overloaded. Makes a color transparent for this Bitmap.
RemovePropertyItem (inherited from Image) | [To be supplied.]
Save (inherited from Image) | Overloaded. [To be supplied.]
SaveAdd (inherited from Image) | Overloaded. [To be supplied.]
SelectActiveFrame (inherited from Image) | [To be supplied.]
SetPixel | Sets the color of the specified pixel in this Bitmap.
SetPropertyItem (inherited from Image) | Overloaded. [To be supplied.]
SetResolution | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.
UnlockBits | [To be supplied.]

Protected:

Methods

Finalize (inherited from Image) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Bitmap Class | System.Drawing Namespace


Bitmap Constructor

Initializes a new instance of the Bitmap class.

Overload List

Initializes a new instance of the Bitmap class from the specified file.

[Visual Basic] Overloads Public Sub New(String)
[C#] public Bitmap(String);
[C++] public: Bitmap(String*);
[JScript] public function Bitmap(String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Boolean)
[C#] public Bitmap(String, bool);
[C++] public: Bitmap(String*, bool);
[JScript] public function Bitmap(String, Boolean);

Initializes a new instance of the Bitmap class from a specified resource.

[Visual Basic] Overloads Public Sub New(Type, String)
[C#] public Bitmap(Type, String);
[C++] public: Bitmap(Type*, String);
[JScript] public function Bitmap(Type, String);

Initializes a new instance of the Bitmap class from the specified data stream.

[Visual Basic] Overloads Public Sub New(Stream)
[C#] public Bitmap(Stream);
[C++] public: Bitmap(Stream*);
[JScript] public function Bitmap(Stream);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Stream, Boolean)
[C#] public Bitmap(Stream, bool);
[C++] public: Bitmap(Stream*, bool);
[JScript] public function Bitmap(Stream, Boolean);

Initializes a new instance of the Bitmap class with the specified size, pixel format, and pixel data.

[Visual Basic] Overloads Public Sub New(Integer, Integer, Integer, PixelFormat, Integer)
[C#] public Bitmap(int, int, int, PixelFormat, int);
[C++] public: Bitmap(int, int, int, PixelFormat, int);
[JScript] public function Bitmap(int, int, int, PixelFormat, int);

Initializes a new instance of the Bitmap class with the specified size and format.

[Visual Basic] Overloads Public Sub New(Integer, Integer, PixelFormat)
[C#] public Bitmap(int, int, PixelFormat);
[C++] public: Bitmap(int, int, PixelFormat);
[JScript] public function Bitmap(int, int, PixelFormat);

Initializes a new instance of the Bitmap class with the specified size.

[Visual Basic] Overloads Public Sub New(Integer, Integer)
[C#] public Bitmap(int, int);
[C++] public: Bitmap(int, int);
[JScript] public function Bitmap(int, int);

Initializes a new instance of the Bitmap class with the specified size and target Graphics.

[Visual Basic] Overloads Public Sub New(Integer, Integer, Graphics)
[C#] public Bitmap(int, int, Graphics);
[C++] public: Bitmap(int, int, Graphics);
[JScript] public function Bitmap(int, int, Graphics);

Initializes a new instance of the Bitmap class, from the specified existing image, with the specified size.

[Visual Basic] Overloads Public Sub New(Image)
[C#] public Bitmap(Image);
[C++] public: Bitmap(Image*);
[JScript] public function Bitmap(Image);

Initializes a new instance of the TBD class, from the specified existing image, with the specified size.

[Visual Basic] Overloads Public Sub New(Image, Integer, Integer)
[C#] public Bitmap(Image, int, int);
[C++] public: Bitmap(Image*, int, int);
[JScript] public function Bitmap(Image, int, int);

Initializes a new instance of the Bitmap class, from the specified existing image, with the specified size.

[Visual Basic] Overloads Public Sub New(Image, Size)
[C#] public Bitmap(Image, Size);
[C++] public: Bitmap(Image*, Size);
[JScript] public function Bitmap(Image, Size);

See Also

Bitmap Class | Bitmap Members | System.Drawing Namespace


Bitmap Constructor (String)

Initializes a new instance of the Bitmap class from the specified file.

[Visual Basic]
Overloads Public Sub New( _
   ByVal filename As String _
)
[C#]
public Bitmap(
   string filename
);
[C++]
public: Bitmap(
   String* filename
);
[JScript]
public function Bitmap(
   filename : String
);

Parameters

filename
The name of the bitmap file.

See Also

Bitmap Class | Bitmap Members | System.Drawing Namespace | Bitmap Constructor Overload List


Bitmap Constructor (String, Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal filename As String, _
   ByVal useICM As Boolean _
)
[C#]
public Bitmap(
   string filename,
   bool useICM
);
[C++]
public: Bitmap(
   String* filename,
   bool useICM
);
[JScript]
public function Bitmap(
   filename : String,
   useICM : Boolean
);

Parameters

filename
[To be supplied.]
useICM
[To be supplied.]

See Also

Bitmap Class | Bitmap Members | System.Drawing Namespace | Bitmap Constructor Overload List


Bitmap Constructor (Type, String)

Initializes a new instance of the Bitmap class from a specified resource.

[Visual Basic]
Overloads Public Sub New( _
   ByVal type As Type, _
   ByVal resource As String _
)
[C#]
public Bitmap(
   Type type,
   string resource
);
[C++]
public: Bitmap(
   Type* type,
   String* resource
);
[JScript]
public function Bitmap(
   type : Type,
   resource : String
);

Parameters

type
The class used to extract the resource.
resource
The name of the resource.

See Also

Bitmap Class | Bitmap Members | System.Drawing Namespace | Bitmap Constructor Overload List


Bitmap Constructor (Stream)

Initializes a new instance of the Bitmap class from the specified data stream.

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream _
)
[C#]
public Bitmap(
   Stream stream
);
[C++]
public: Bitmap(
   Stream* stream
);
[JScript]
public function Bitmap(
   stream : Stream
);

Parameters

stream
The data stream used to load the image.

See Also

Bitmap Class | Bitmap Members | System.Drawing Namespace | Bitmap Constructor Overload List


Bitmap Constructor (Stream, Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream, _
   ByVal useICM As Boolean _
)
[C#]
public Bitmap(
   Stream stream,
   bool useICM
);
[C++]
public: Bitmap(
   Stream* stream,
   bool useICM
);
[JScript]
public function Bitmap(
   stream : Stream,
   useICM : Boolean
);

Parameters

stream
[To be supplied.]
useICM
[To be supplied.]

See Also

Bitmap Class | Bitmap Members | System.Drawing Namespace | Bitmap Constructor Overload List


Bitmap Constructor (Int32, Int32, Int32, PixelFormat, Int32)

Initializes a new instance of the Bitmap class with the specified size, pixel format, and pixel data.

[Visual Basic]
Overloads Public Sub New( _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal stride As Integer, _
   ByVal format As PixelFormat, _
   ByVal scan0 As Integer _
)
[C#]
public Bitmap(
   int width,
   int height,
   int stride,
   PixelFormat format,
   int scan0
);
[C++]
public: Bitmap(
   int width,
   int height,
   int stride,
   PixelFormat format,
   int scan0
);
[JScript]
public function Bitmap(
   width : int,
   height : int,
   stride : int,
   format : PixelFormat,
   scan0 : int
);

Parameters

width
The width, in pixels, of the new Bitmap.
height
The height, in pixels, of the new Bitmap.
stride
The memory size of a row in the stream of pixel data.
format
The TBD for the new Bitmap.
scan0
The address of a stream of pixel data.

See Also

Bitmap Class | Bitmap Members | System.Drawing Namespace | Bitmap Constructor Overload List


Bitmap Constructor (Int32, Int32, PixelFormat)

Initializes a new instance of the Bitmap class with the specified size and format.

[Visual Basic]
Overloads Public Sub New( _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal format As PixelFormat _
)
[C#]
public Bitmap(
   int width,
   int height,
   PixelFormat format
);
[C++]
public: Bitmap(
   int width,
   int height,
   PixelFormat format
);
[JScript]
public function Bitmap(
   width : int,
   height : int,
   format : PixelFormat
);

Parameters

width
The width, in pixels, of the new Bitmap.
height
The height, in pixels, of the new Bitmap.
format
The PixelFormat of the new Bitmap.

See Also

Bitmap Class | Bitmap Members | System.Drawing Namespace | Bitmap Constructor Overload List


Bitmap Constructor (Int32, Int32)

Initializes a new instance of the Bitmap class with the specified size.

[Visual Basic]
Overloads Public Sub New( _
   ByVal width As Integer, _
   ByVal height As Integer _
)
[C#]
public Bitmap(
   int width,
   int height
);
[C++]
public: Bitmap(
   int width,
   int height
);
[JScript]
public function Bitmap(
   width : int,
   height : int
);

Parameters

width
The width, in pixels, of the new Bitmap.
height
The height, in pixels, of the new Bitmap.

Remarks

This constructor creates a Bitmap with a PixelFormat of Format32bppARGB.

See Also

Bitmap Class | Bitmap Members | System.Drawing Namespace | Bitmap Constructor Overload List


Bitmap Constructor (Int32, Int32, Graphics)

Initializes a new instance of the Bitmap class with the specified size and target Graphics.

[Visual Basic]
Overloads Public Sub New( _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal g As Graphics _
)
[C#]
public Bitmap(
   int width,
   int height,
   Graphics g
);
[C++]
public: Bitmap(
   int width,
   int height,
   Graphics* g
);
[JScript]
public function Bitmap(
   width : int,
   height : int,
   g : Graphics
);

Parameters

width
The width, in pixels, of the new Bitmap.
height
The height, in pixels, of the new Bitmap.
g
The target TBD for the new Bitmap.

See Also

Bitmap Class | Bitmap Members | System.Drawing Namespace | Bitmap Constructor Overload List


Bitmap Constructor (Image)

Initializes a new instance of the Bitmap class, from the specified existing image, with the specified size.

[Visual Basic]
Overloads Public Sub New( _
   ByVal original As Image _
)
[C#]
public Bitmap(
   Image original
);
[C++]
public: Bitmap(
   Image* original
);
[JScript]
public function Bitmap(
   original : Image
);

Parameters

original
The TBD from which to create the new Bitmap.

See Also

Bitmap Class | Bitmap Members | System.Drawing Namespace | Bitmap Constructor Overload List


Bitmap Constructor (Image, Int32, Int32)

Initializes a new instance of the TBD class, from the specified existing image, with the specified size.

[Visual Basic]
Overloads Public Sub New( _
   ByVal original As Image, _
   ByVal width As Integer, _
   ByVal height As Integer _
)
[C#]
public Bitmap(
   Image original,
   int width,
   int height
);
[C++]
public: Bitmap(
   Image* original,
   int width,
   int height
);
[JScript]
public function Bitmap(
   original : Image,
   width : int,
   height : int
);

Parameters

original
The TBD from which to create the new TBD.
width
The width, in pixels, of the new Bitmap.
height
The height, in pixels, of the new Bitmap.

See Also

Bitmap Class | Bitmap Members | System.Drawing Namespace | Bitmap Constructor Overload List


Bitmap Constructor (Image, Size)

Initializes a new instance of the Bitmap class, from the specified existing image, with the specified size.

[Visual Basic]
Overloads Public Sub New( _
   ByVal original As Image, _
   ByVal newSize As Size _
)
[C#]
public Bitmap(
   Image original,
   Size newSize
);
[C++]
public: Bitmap(
   Image* original,
   Size newSize
);
[JScript]
public function Bitmap(
   original : Image,
   newSize : Size
);

Parameters

original
The TBD from which to create the new Bitmap.
newSize
The TBD of the new Bitmap.

See Also

Bitmap Class | Bitmap Members | System.Drawing Namespace | Bitmap Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Bitmap Methods

The methods of the Bitmap class are listed below. For a complete list of Bitmap class members, see the Bitmap Members topic.

Public:

Clone | Overloaded. Creates a copy of this Bitmap.
Dispose (inherited from Image) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FromHICON | [To be supplied.]
FromResource | [To be supplied.]
GetBounds (inherited from Image) | [To be supplied.]
GetEncoderParameterList (inherited from Image) | [To be supplied.]
GetFrameCount (inherited from Image) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHBITMAP | Overloaded. [To be supplied.]
GetHICON | [To be supplied.]
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetObjectData (inherited from Image) | ISerializable private implementation
GetPixel | Gets the color of the specified pixel in this Bitmap.
GetPropertyItem (inherited from Image) | [To be supplied.]
GetThumbnailImage (inherited from Image) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
LockBits | [To be supplied.]
MakeTransparent | Overloaded. Makes a color transparent for this Bitmap.
RemovePropertyItem (inherited from Image) | [To be supplied.]
Save (inherited from Image) | Overloaded. [To be supplied.]
SaveAdd (inherited from Image) | Overloaded. [To be supplied.]
SelectActiveFrame (inherited from Image) | [To be supplied.]
SetPixel | Sets the color of the specified pixel in this Bitmap.
SetPropertyItem (inherited from Image) | Overloaded. [To be supplied.]
SetResolution | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.
UnlockBits | [To be supplied.]

Protected:

Finalize (inherited from Image) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Bitmap Class | System.Drawing Namespace


Bitmap.Clone

Creates a copy of this Bitmap.

Overload List

Creates a copy of the section of this Bitmap defined bywith a specified PixelFormat.

[Visual Basic] Overloads Public Function Clone(Rectangle, PixelFormat) As Bitmap
[C#] public Bitmap Clone(Rectangle, PixelFormat);
[C++] public: Bitmap* Clone(Rectangle, PixelFormat);
[JScript] public function Clone(Rectangle, PixelFormat) : Bitmap;

Creates a copy of the section of this Bitmap defined bywith a specified PixelFormat.

[Visual Basic] Overloads Public Function Clone(RectangleF, PixelFormat) As Bitmap
[C#] public Bitmap Clone(RectangleF, PixelFormat);
[C++] public: Bitmap* Clone(RectangleF, PixelFormat);
[JScript] public function Clone(RectangleF, PixelFormat) : Bitmap;

See Also

Bitmap Class | Bitmap Members | System.Drawing Namespace


Bitmap.Clone (Rectangle, PixelFormat)

Creates a copy of the section of this Bitmap defined bywith a specified PixelFormat.

[Visual Basic]
Overloads Public Function Clone( _
   ByVal rect As Rectangle, _
   ByVal format As PixelFormat _
) As Bitmap
[C#]
public Bitmap Clone(
   Rectangle rect,
   PixelFormat format
);
[C++]
public: Bitmap* Clone(
   Rectangle rect,
   PixelFormat format
);
[JScript]
public function Clone(
   rect : Rectangle,
   format : PixelFormat
) : Bitmap;

Parameters

rect
Defines the portion of this Bitmap to copy.
format
Specifies the TBD for the destination Bitmap.

Return Value

The Bitmap that this method creates.

See Also

Bitmap Class | Bitmap Members | System.Drawing Namespace | Bitmap.Clone Overload List


Bitmap.Clone (RectangleF, PixelFormat)

Creates a copy of the section of this Bitmap defined bywith a specified PixelFormat.

[Visual Basic]
Overloads Public Function Clone( _
   ByVal rect As RectangleF, _
   ByVal format As PixelFormat _
) As Bitmap
[C#]
public Bitmap Clone(
   RectangleF rect,
   PixelFormat format
);
[C++]
public: Bitmap* Clone(
   RectangleF rect,
   PixelFormat format
);
[JScript]
public function Clone(
   rect : RectangleF,
   format : PixelFormat
) : Bitmap;

Parameters

rect
Defines the portion of this Bitmap to copy.
format
Specifies the TBD for the destination Bitmap.

Return Value

The Bitmap that this method creates.

See Also

Bitmap Class | Bitmap Members | System.Drawing Namespace | Bitmap.Clone Overload List


Bitmap.FromHICON

[To be supplied.]

[Visual Basic]
Public Shared Function FromHICON( _
   ByVal hicon As Integer _
) As Bitmap
[C#]
public static Bitmap FromHICON(
   int hicon
);
[C++]
public: static Bitmap* FromHICON(
   int hicon
);
[JScript]
public static function FromHICON(
   hicon : int
) : Bitmap;

Parameters

hicon
[To be supplied.]

See Also

Bitmap Class | Bitmap Members | System.Drawing Namespace


Bitmap.FromResource

[To be supplied.]

[Visual Basic]
Public Shared Function FromResource( _
   ByVal hinstance As Integer, _
   ByVal bitmapName As String _
) As Bitmap
[C#]
public static Bitmap FromResource(
   int hinstance,
   string bitmapName
);
[C++]
public: static Bitmap* FromResource(
   int hinstance,
   String* bitmapName
);
[JScript]
public static function FromResource(
   hinstance : int,
   bitmapName : String
) : Bitmap;

Parameters

hinstance
[To be supplied.]
bitmapName
[To be supplied.]

See Also

Bitmap Class | Bitmap Members | System.Drawing Namespace


Bitmap.GetHBITMAP

[To be supplied.]

Overload List

Creates a Win32 HBITMAP out of the image. You are responsible for de-allocating the HBITMAP with Windows.DeleteObject(handle). If the image uses transparency, the background will be filled with the specified background color.

[Visual Basic] Overloads Public Function GetHBITMAP(Color) As Integer
[C#] public int GetHBITMAP(Color);
[C++] public: int GetHBITMAP(Color);
[JScript] public function GetHBITMAP(Color) : int;

[To be supplied.]

[Visual Basic] Overloads Public Function GetHBITMAP() As Integer
[C#] public int GetHBITMAP();
[C++] public: int GetHBITMAP();
[JScript] public function GetHBITMAP() : int;

See Also

Bitmap Class | Bitmap Members | System.Drawing Namespace


Bitmap.GetHBITMAP (Color)

Creates a Win32 HBITMAP out of the image. You are responsible for de-allocating the HBITMAP with Windows.DeleteObject(handle). If the image uses transparency, the background will be filled with the specified background color.

[Visual Basic]
Overloads Public Function GetHBITMAP( _
   ByVal background As Color _
) As Integer
[C#]
public int GetHBITMAP(
   Color background
);
[C++]
public: int GetHBITMAP(
   Color background
);
[JScript]
public function GetHBITMAP(
   background : Color
) : int;

Parameters

background
A TBD that represents the background color of this Bitmap.

Return Value

The handle to this Bitmap.

See Also

Bitmap Class | Bitmap Members | System.Drawing Namespace | Bitmap.GetHBITMAP Overload List


Bitmap.GetHBITMAP ()

[To be supplied.]

[Visual Basic]
Overloads Public Function GetHBITMAP() As Integer
[C#]
public int GetHBITMAP();
[C++]
public: int GetHBITMAP();
[JScript]
public function GetHBITMAP() : int;

See Also

Bitmap Class | Bitmap Members | System.Drawing Namespace | Bitmap.GetHBITMAP Overload List


Bitmap.GetHICON

[To be supplied.]

[Visual Basic]
Public Function GetHICON() As Integer
[C#]
public int GetHICON();
[C++]
public: int GetHICON();
[JScript]
public function GetHICON() : int;

See Also

Bitmap Class | Bitmap Members | System.Drawing Namespace


Bitmap.GetPixel

Gets the color of the specified pixel in this Bitmap.

[Visual Basic]
Public Function GetPixel( _
   ByVal x As Integer, _
   ByVal y As Integer _
) As Color
[C#]
public Color GetPixel(
   int x,
   int y
);
[C++]
public: Color GetPixel(
   int x,
   int y
);
[JScript]
public function GetPixel(
   x : int,
   y : int
) : Color;

Parameters

x
The x-coordinate of the pixel to retrieve.
y
The y-coordinate of the pixel to retrieve.

Return Value

A Color that represents the color of the specified pixel.

See Also

Bitmap Class | Bitmap Members | System.Drawing Namespace


Bitmap.LockBits

[To be supplied.]

[Visual Basic]
Public Function LockBits( _
   ByVal rect As Rectangle, _
   ByVal flags As ImageLockMode, _
   ByVal format As PixelFormat _
) As BitmapData
[C#]
public BitmapData LockBits(
   Rectangle rect,
   ImageLockMode flags,
   PixelFormat format
);
[C++]
public: BitmapData* LockBits(
   Rectangle rect,
   ImageLockMode flags,
   PixelFormat format
);
[JScript]
public function LockBits(
   rect : Rectangle,
   flags : ImageLockMode,
   format : PixelFormat
) : BitmapData;

Parameters

rect
[To be supplied.]
flags
[To be supplied.]
format
[To be supplied.]

See Also

Bitmap Class | Bitmap Members | System.Drawing Namespace


Bitmap.MakeTransparent

Makes a color transparent for this Bitmap.

Overload List

Makes the specified color transparent for this Bitmap.

[Visual Basic] Overloads Public Sub MakeTransparent(Color)
[C#] public void MakeTransparent(Color);
[C++] public: void MakeTransparent(Color);
[JScript] public function MakeTransparent(Color);

Makes the default transparent color transparent for this Bitmap.

[Visual Basic] Overloads Public Sub MakeTransparent()
[C#] public void MakeTransparent();
[C++] public: void MakeTransparent();
[JScript] public function MakeTransparent();

See Also

Bitmap Class | Bitmap Members | System.Drawing Namespace


Bitmap.MakeTransparent (Color)

Makes the specified color transparent for this Bitmap.

[Visual Basic]
Overloads Public Sub MakeTransparent( _
   ByVal transparentColor As Color _
)
[C#]
public void MakeTransparent(
   Color transparentColor
);
[C++]
public: void MakeTransparent(
   Color transparentColor
);
[JScript]
public function MakeTransparent(
   transparentColor : Color
);

Parameters

transparentColor
The Color to make transparent.

See Also

Bitmap Class | Bitmap Members | System.Drawing Namespace | Bitmap.MakeTransparent Overload List


Bitmap.MakeTransparent ()

Makes the default transparent color transparent for this Bitmap.

[Visual Basic]
Overloads Public Sub MakeTransparent()
[C#]
public void MakeTransparent();
[C++]
public: void MakeTransparent();
[JScript]
public function MakeTransparent();

See Also

Bitmap Class | Bitmap Members | System.Drawing Namespace | Bitmap.MakeTransparent Overload List


Bitmap.SetPixel

Sets the color of the specified pixel in this Bitmap.

[Visual Basic]
Public Sub SetPixel( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal color As Color _
)
[C#]
public void SetPixel(
   int x,
   int y,
   Color color
);
[C++]
public: void SetPixel(
   int x,
   int y,
   Color color
);
[JScript]
public function SetPixel(
   x : int,
   y : int,
   color : Color
);

Parameters

x
The x-coordinate of the pixel to set.
y
The y-coordinate of the pixel to set.
color
A Color that represents the color to assign to the specified pixel.

See Also

Bitmap Class | Bitmap Members | System.Drawing Namespace


Bitmap.SetResolution

[To be supplied.]

[Visual Basic]
Public Sub SetResolution( _
   ByVal xDpi As Single, _
   ByVal yDpi As Single _
)
[C#]
public void SetResolution(
   float xDpi,
   float yDpi
);
[C++]
public: void SetResolution(
   float xDpi,
   float yDpi
);
[JScript]
public function SetResolution(
   xDpi : float,
   yDpi : float
);

Parameters

xDpi
[To be supplied.]
yDpi
[To be supplied.]

See Also

Bitmap Class | Bitmap Members | System.Drawing Namespace


Bitmap.UnlockBits

[To be supplied.]

[Visual Basic]
Public Sub UnlockBits( _
   ByVal bitmapdata As BitmapData _
)
[C#]
public void UnlockBits(
   BitmapData bitmapdata
);
[C++]
public: void UnlockBits(
   BitmapData* bitmapdata
);
[JScript]
public function UnlockBits(
   bitmapdata : BitmapData
);

Parameters

bitmapdata
[To be supplied.]

See Also

Bitmap Class | Bitmap Members | System.Drawing Namespace


Brush Class

Classes derrived from this abstract base class define objects used to fill the interiors of graphical shapes such as rectangles, ellipses, pies, polygons, and paths.

Object
MarshalByRefObject
Brush

[Visual Basic]
MustInherit Public Class Brush
   Inherits MarshalByRefObject
   Implements ICloneable
[C#]
public abstract class Brush : MarshalByRefObject, ICloneable
[C++]
public __gc __abstract class Brush : public MarshalByRefObject,
   ICloneable
[JScript]
public abstract class Brush extends MarshalByRefObject, ICloneable

Remarks

This is an abstract base class and cannot be instantiated. To instantiate a brush object, use classes derrived from Brush, such as SolidBrush, TextureBrush, and RectangleGradientBrush.

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

Brush Members | System.Drawing Namespace | System.Drawing, RadialGradientBrush[cref, System.Drawing, RectangleGradientBrush[cref, System.Drawing, PathGradientBrush[cref, System.Drawing, TriangleGradientBrush[cref, System.Drawing, TextureBrush[cref, System.Drawing, LineGradientBrush[cref, System.Drawing.SolidBrush


Brush Members

Public:

Methods

Clone | When overriden in a derived class, creates an exact copy of this Brush.
Dispose | Deletes this Brush.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize | Releases memory allocated for this Brush.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Brush Class | System.Drawing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Brush Methods

The methods of the Brush class are listed below. For a complete list of Brush class members, see the Brush Members topic.

Public:

Clone | When overriden in a derived class, creates an exact copy of this Brush.
Dispose | Deletes this Brush.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize | Releases memory allocated for this Brush.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Brush Class | System.Drawing Namespace


Brush.Clone

When overriden in a derived class, creates an exact copy of this Brush.

[Visual Basic]
MustOverride Public Function Clone() As Object
[C#]
public abstract object Clone();
[C++]
public: virtual Object* Clone() = 0;
[JScript]
public abstract function Clone() : Object;

Return Value

The new Brush that this method creates.

See Also

Brush Class | Brush Members | System.Drawing Namespace


Brush.Dispose

Deletes this Brush.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[JScript]
public function Dispose();

See Also

Brush Class | Brush Members | System.Drawing Namespace


Brush.Finalize

Releases memory allocated for this Brush.

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

Brush Class | Brush Members | System.Drawing Namespace


Brushes Class

Brushes for all the standard colors.

Object
Brushes

[Visual Basic]
NotInheritable Public Class Brushes
[C#]
public sealed class Brushes
[C++]
public __gc __sealed class Brushes
[JScript]
public class Brushes

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

Brushes Members | System.Drawing Namespace | Color | Brush | SystemBrushes


Brushes Members

Public:

Properties

AliceBlue | [To be supplied.]
AntiqueWhite | [To be supplied.]
Aqua | [To be supplied.]
Aquamarine | [To be supplied.]
Azure | [To be supplied.]
Beige | [To be supplied.]
Bisque | [To be supplied.]
Black | [To be supplied.]
BlanchedAlmond | [To be supplied.]
Blue | [To be supplied.]
BlueViolet | [To be supplied.]
Brown | [To be supplied.]
BurlyWood | [To be supplied.]
CadetBlue | [To be supplied.]
Chartreuse | [To be supplied.]
Chocolate | [To be supplied.]
Coral | [To be supplied.]
Cornflower | [To be supplied.]
Cornsilk | [To be supplied.]
Crimson | [To be supplied.]
Cyan | [To be supplied.]
DarkBlue | [To be supplied.]
DarkCyan | [To be supplied.]
DarkGoldenrod | [To be supplied.]
DarkGray | [To be supplied.]
DarkGreen | [To be supplied.]
DarkKhaki | [To be supplied.]
DarkMagenta | [To be supplied.]
DarkOliveGreen | [To be supplied.]
DarkOrange | [To be supplied.]
DarkOrchid | [To be supplied.]
DarkRed | [To be supplied.]
DarkSalmon | [To be supplied.]
DarkSeaGreen | [To be supplied.]
DarkSlateBlue | [To be supplied.]
DarkSlateGray | [To be supplied.]
DarkTurquoise | [To be supplied.]
DarkViolet | [To be supplied.]
DeepPink | [To be supplied.]
DeepSkyBlue | [To be supplied.]
DimGray | [To be supplied.]
DodgerBlue | [To be supplied.]
Firebrick | [To be supplied.]
FloralWhite | [To be supplied.]
ForestGreen | [To be supplied.]
Fuchsia | [To be supplied.]
Gainsboro | [To be supplied.]
GhostWhite | [To be supplied.]
Gold | [To be supplied.]
Goldenrod | [To be supplied.]
Gray | [To be supplied.]
Green | [To be supplied.]
GreenYellow | [To be supplied.]
Honeydew | [To be supplied.]
HotPink | [To be supplied.]
IndianRed | [To be supplied.]
Indigo | [To be supplied.]
Ivory | [To be supplied.]
Khaki | [To be supplied.]
Lavender | [To be supplied.]
LavenderBlush | [To be supplied.]
LawnGreen | [To be supplied.]
LemonChiffon | [To be supplied.]
LightBlue | [To be supplied.]
LightCoral | [To be supplied.]
LightCyan | [To be supplied.]
LightGoldenrodYellow | [To be supplied.]
LightGray | [To be supplied.]
LightGreen | [To be supplied.]
LightPink | [To be supplied.]
LightSalmon | [To be supplied.]
LightSeaGreen | [To be supplied.]
LightSkyBlue | [To be supplied.]
LightSlateGray | [To be supplied.]
LightSteelBlue | [To be supplied.]
LightYellow | [To be supplied.]
Lime | [To be supplied.]
LimeGreen | [To be supplied.]
Linen | [To be supplied.]
Magenta | [To be supplied.]
Maroon | [To be supplied.]
MediumAquamarine | [To be supplied.]
MediumBlue | [To be supplied.]
MediumOrchid | [To be supplied.]
MediumPurple | [To be supplied.]
MediumSeaGreen | [To be supplied.]
MediumSlateBlue | [To be supplied.]
MediumSpringGreen | [To be supplied.]
MediumTurquoise | [To be supplied.]
MediumVioletRed | [To be supplied.]
MidnightBlue | [To be supplied.]
MintCream | [To be supplied.]
MistyRose | [To be supplied.]
Moccasin | [To be supplied.]
NavajoWhite | [To be supplied.]
Navy | [To be supplied.]
OldLace | [To be supplied.]
Olive | [To be supplied.]
OliveDrab | [To be supplied.]
Orange | [To be supplied.]
OrangeRed | [To be supplied.]
Orchid | [To be supplied.]
PaleGoldenrod | [To be supplied.]
PaleGreen | [To be supplied.]
PaleTurquoise | [To be supplied.]
PaleVioletRed | [To be supplied.]
PapayaWhip | [To be supplied.]
PeachPuff | [To be supplied.]
Peru | [To be supplied.]
Pink | [To be supplied.]
Plum | [To be supplied.]
PowderBlue | [To be supplied.]
Purple | [To be supplied.]
Red | [To be supplied.]
RosyBrown | [To be supplied.]
RoyalBlue | [To be supplied.]
SaddleBrown | [To be supplied.]
Salmon | [To be supplied.]
SandyBrown | [To be supplied.]
SeaGreen | [To be supplied.]
SeaShell | [To be supplied.]
Sienna | [To be supplied.]
Silver | [To be supplied.]
SkyBlue | [To be supplied.]
SlateBlue | [To be supplied.]
SlateGray | [To be supplied.]
Snow | [To be supplied.]
SpringGreen | [To be supplied.]
SteelBlue | [To be supplied.]
Tan | [To be supplied.]
Teal | [To be supplied.]
Thistle | [To be supplied.]
Tomato | [To be supplied.]
Transparent | [To be supplied.]
Turquoise | [To be supplied.]
Violet | [To be supplied.]
Wheat | [To be supplied.]
White | [To be supplied.]
WhiteSmoke | [To be supplied.]
Yellow | [To be supplied.]
YellowGreen | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Brushes Class | System.Drawing Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Brushes Properties

The properties of the Brushes class are listed below. For a complete list of Brushes class members, see the Brushes Members topic.

Public:

AliceBlue | [To be supplied.]
AntiqueWhite | [To be supplied.]
Aqua | [To be supplied.]
Aquamarine | [To be supplied.]
Azure | [To be supplied.]
Beige | [To be supplied.]
Bisque | [To be supplied.]
Black | [To be supplied.]
BlanchedAlmond | [To be supplied.]
Blue | [To be supplied.]
BlueViolet | [To be supplied.]
Brown | [To be supplied.]
BurlyWood | [To be supplied.]
CadetBlue | [To be supplied.]
Chartreuse | [To be supplied.]
Chocolate | [To be supplied.]
Coral | [To be supplied.]
Cornflower | [To be supplied.]
Cornsilk | [To be supplied.]
Crimson | [To be supplied.]
Cyan | [To be supplied.]
DarkBlue | [To be supplied.]
DarkCyan | [To be supplied.]
DarkGoldenrod | [To be supplied.]
DarkGray | [To be supplied.]
DarkGreen | [To be supplied.]
DarkKhaki | [To be supplied.]
DarkMagenta | [To be supplied.]
DarkOliveGreen | [To be supplied.]
DarkOrange | [To be supplied.]
DarkOrchid | [To be supplied.]
DarkRed | [To be supplied.]
DarkSalmon | [To be supplied.]
DarkSeaGreen | [To be supplied.]
DarkSlateBlue | [To be supplied.]
DarkSlateGray | [To be supplied.]
DarkTurquoise | [To be supplied.]
DarkViolet | [To be supplied.]
DeepPink | [To be supplied.]
DeepSkyBlue | [To be supplied.]
DimGray | [To be supplied.]
DodgerBlue | [To be supplied.]
Firebrick | [To be supplied.]
FloralWhite | [To be supplied.]
ForestGreen | [To be supplied.]
Fuchsia | [To be supplied.]
Gainsboro | [To be supplied.]
GhostWhite | [To be supplied.]
Gold | [To be supplied.]
Goldenrod | [To be supplied.]
Gray | [To be supplied.]
Green | [To be supplied.]
GreenYellow | [To be supplied.]
Honeydew | [To be supplied.]
HotPink | [To be supplied.]
IndianRed | [To be supplied.]
Indigo | [To be supplied.]
Ivory | [To be supplied.]
Khaki | [To be supplied.]
Lavender | [To be supplied.]
LavenderBlush | [To be supplied.]
LawnGreen | [To be supplied.]
LemonChiffon | [To be supplied.]
LightBlue | [To be supplied.]
LightCoral | [To be supplied.]
LightCyan | [To be supplied.]
LightGoldenrodYellow | [To be supplied.]
LightGray | [To be supplied.]
LightGreen | [To be supplied.]
LightPink | [To be supplied.]
LightSalmon | [To be supplied.]
LightSeaGreen | [To be supplied.]
LightSkyBlue | [To be supplied.]
LightSlateGray | [To be supplied.]
LightSteelBlue | [To be supplied.]
LightYellow | [To be supplied.]
Lime | [To be supplied.]
LimeGreen | [To be supplied.]
Linen | [To be supplied.]
Magenta | [To be supplied.]
Maroon | [To be supplied.]
MediumAquamarine | [To be supplied.]
MediumBlue | [To be supplied.]
MediumOrchid | [To be supplied.]
MediumPurple | [To be supplied.]
MediumSeaGreen | [To be supplied.]
MediumSlateBlue | [To be supplied.]
MediumSpringGreen | [To be supplied.]
MediumTurquoise | [To be supplied.]
MediumVioletRed | [To be supplied.]
MidnightBlue | [To be supplied.]
MintCream | [To be supplied.]
MistyRose | [To be supplied.]
Moccasin | [To be supplied.]
NavajoWhite | [To be supplied.]
Navy | [To be supplied.]
OldLace | [To be supplied.]
Olive | [To be supplied.]
OliveDrab | [To be supplied.]
Orange | [To be supplied.]
OrangeRed | [To be supplied.]
Orchid | [To be supplied.]
PaleGoldenrod | [To be supplied.]
PaleGreen | [To be supplied.]
PaleTurquoise | [To be supplied.]
PaleVioletRed | [To be supplied.]
PapayaWhip | [To be supplied.]
PeachPuff | [To be supplied.]
Peru | [To be supplied.]
Pink | [To be supplied.]
Plum | [To be supplied.]
PowderBlue | [To be supplied.]
Purple | [To be supplied.]
Red | [To be supplied.]
RosyBrown | [To be supplied.]
RoyalBlue | [To be supplied.]
SaddleBrown | [To be supplied.]
Salmon | [To be supplied.]
SandyBrown | [To be supplied.]
SeaGreen | [To be supplied.]
SeaShell | [To be supplied.]
Sienna | [To be supplied.]
Silver | [To be supplied.]
SkyBlue | [To be supplied.]
SlateBlue | [To be supplied.]
SlateGray | [To be supplied.]
Snow | [To be supplied.]
SpringGreen | [To be supplied.]
SteelBlue | [To be supplied.]
Tan | [To be supplied.]
Teal | [To be supplied.]
Thistle | [To be supplied.]
Tomato | [To be supplied.]
Transparent | [To be supplied.]
Turquoise | [To be supplied.]
Violet | [To be supplied.]
Wheat | [To be supplied.]
White | [To be supplied.]
WhiteSmoke | [To be supplied.]
Yellow | [To be supplied.]
YellowGreen | [To be supplied.]

See Also

Brushes Class | System.Drawing Namespace


Brushes.AliceBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property AliceBlue As Brush
[C#]
public static Brush AliceBlue {get;}
[C++]
public: __property static Brush* get_AliceBlue();
[JScript]
public static function get AliceBlue() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.AntiqueWhite

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property AntiqueWhite As Brush
[C#]
public static Brush AntiqueWhite {get;}
[C++]
public: __property static Brush* get_AntiqueWhite();
[JScript]
public static function get AntiqueWhite() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Aqua

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Aqua As Brush
[C#]
public static Brush Aqua {get;}
[C++]
public: __property static Brush* get_Aqua();
[JScript]
public static function get Aqua() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Aquamarine

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Aquamarine As Brush
[C#]
public static Brush Aquamarine {get;}
[C++]
public: __property static Brush* get_Aquamarine();
[JScript]
public static function get Aquamarine() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Azure

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Azure As Brush
[C#]
public static Brush Azure {get;}
[C++]
public: __property static Brush* get_Azure();
[JScript]
public static function get Azure() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Beige

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Beige As Brush
[C#]
public static Brush Beige {get;}
[C++]
public: __property static Brush* get_Beige();
[JScript]
public static function get Beige() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Bisque

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Bisque As Brush
[C#]
public static Brush Bisque {get;}
[C++]
public: __property static Brush* get_Bisque();
[JScript]
public static function get Bisque() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Black

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Black As Brush
[C#]
public static Brush Black {get;}
[C++]
public: __property static Brush* get_Black();
[JScript]
public static function get Black() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.BlanchedAlmond

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property BlanchedAlmond As Brush
[C#]
public static Brush BlanchedAlmond {get;}
[C++]
public: __property static Brush* get_BlanchedAlmond();
[JScript]
public static function get BlanchedAlmond() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Blue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Blue As Brush
[C#]
public static Brush Blue {get;}
[C++]
public: __property static Brush* get_Blue();
[JScript]
public static function get Blue() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.BlueViolet

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property BlueViolet As Brush
[C#]
public static Brush BlueViolet {get;}
[C++]
public: __property static Brush* get_BlueViolet();
[JScript]
public static function get BlueViolet() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Brown

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Brown As Brush
[C#]
public static Brush Brown {get;}
[C++]
public: __property static Brush* get_Brown();
[JScript]
public static function get Brown() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.BurlyWood

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property BurlyWood As Brush
[C#]
public static Brush BurlyWood {get;}
[C++]
public: __property static Brush* get_BurlyWood();
[JScript]
public static function get BurlyWood() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.CadetBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property CadetBlue As Brush
[C#]
public static Brush CadetBlue {get;}
[C++]
public: __property static Brush* get_CadetBlue();
[JScript]
public static function get CadetBlue() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Chartreuse

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Chartreuse As Brush
[C#]
public static Brush Chartreuse {get;}
[C++]
public: __property static Brush* get_Chartreuse();
[JScript]
public static function get Chartreuse() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Chocolate

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Chocolate As Brush
[C#]
public static Brush Chocolate {get;}
[C++]
public: __property static Brush* get_Chocolate();
[JScript]
public static function get Chocolate() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Coral

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Coral As Brush
[C#]
public static Brush Coral {get;}
[C++]
public: __property static Brush* get_Coral();
[JScript]
public static function get Coral() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Cornflower

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Cornflower As Brush
[C#]
public static Brush Cornflower {get;}
[C++]
public: __property static Brush* get_Cornflower();
[JScript]
public static function get Cornflower() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Cornsilk

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Cornsilk As Brush
[C#]
public static Brush Cornsilk {get;}
[C++]
public: __property static Brush* get_Cornsilk();
[JScript]
public static function get Cornsilk() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Crimson

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Crimson As Brush
[C#]
public static Brush Crimson {get;}
[C++]
public: __property static Brush* get_Crimson();
[JScript]
public static function get Crimson() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Cyan

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Cyan As Brush
[C#]
public static Brush Cyan {get;}
[C++]
public: __property static Brush* get_Cyan();
[JScript]
public static function get Cyan() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.DarkBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkBlue As Brush
[C#]
public static Brush DarkBlue {get;}
[C++]
public: __property static Brush* get_DarkBlue();
[JScript]
public static function get DarkBlue() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.DarkCyan

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkCyan As Brush
[C#]
public static Brush DarkCyan {get;}
[C++]
public: __property static Brush* get_DarkCyan();
[JScript]
public static function get DarkCyan() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.DarkGoldenrod

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkGoldenrod As Brush
[C#]
public static Brush DarkGoldenrod {get;}
[C++]
public: __property static Brush* get_DarkGoldenrod();
[JScript]
public static function get DarkGoldenrod() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.DarkGray

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkGray As Brush
[C#]
public static Brush DarkGray {get;}
[C++]
public: __property static Brush* get_DarkGray();
[JScript]
public static function get DarkGray() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.DarkGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkGreen As Brush
[C#]
public static Brush DarkGreen {get;}
[C++]
public: __property static Brush* get_DarkGreen();
[JScript]
public static function get DarkGreen() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.DarkKhaki

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkKhaki As Brush
[C#]
public static Brush DarkKhaki {get;}
[C++]
public: __property static Brush* get_DarkKhaki();
[JScript]
public static function get DarkKhaki() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.DarkMagenta

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkMagenta As Brush
[C#]
public static Brush DarkMagenta {get;}
[C++]
public: __property static Brush* get_DarkMagenta();
[JScript]
public static function get DarkMagenta() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.DarkOliveGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkOliveGreen As Brush
[C#]
public static Brush DarkOliveGreen {get;}
[C++]
public: __property static Brush* get_DarkOliveGreen();
[JScript]
public static function get DarkOliveGreen() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.DarkOrange

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkOrange As Brush
[C#]
public static Brush DarkOrange {get;}
[C++]
public: __property static Brush* get_DarkOrange();
[JScript]
public static function get DarkOrange() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.DarkOrchid

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkOrchid As Brush
[C#]
public static Brush DarkOrchid {get;}
[C++]
public: __property static Brush* get_DarkOrchid();
[JScript]
public static function get DarkOrchid() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.DarkRed

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkRed As Brush
[C#]
public static Brush DarkRed {get;}
[C++]
public: __property static Brush* get_DarkRed();
[JScript]
public static function get DarkRed() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.DarkSalmon

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkSalmon As Brush
[C#]
public static Brush DarkSalmon {get;}
[C++]
public: __property static Brush* get_DarkSalmon();
[JScript]
public static function get DarkSalmon() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.DarkSeaGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkSeaGreen As Brush
[C#]
public static Brush DarkSeaGreen {get;}
[C++]
public: __property static Brush* get_DarkSeaGreen();
[JScript]
public static function get DarkSeaGreen() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.DarkSlateBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkSlateBlue As Brush
[C#]
public static Brush DarkSlateBlue {get;}
[C++]
public: __property static Brush* get_DarkSlateBlue();
[JScript]
public static function get DarkSlateBlue() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.DarkSlateGray

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkSlateGray As Brush
[C#]
public static Brush DarkSlateGray {get;}
[C++]
public: __property static Brush* get_DarkSlateGray();
[JScript]
public static function get DarkSlateGray() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.DarkTurquoise

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkTurquoise As Brush
[C#]
public static Brush DarkTurquoise {get;}
[C++]
public: __property static Brush* get_DarkTurquoise();
[JScript]
public static function get DarkTurquoise() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.DarkViolet

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkViolet As Brush
[C#]
public static Brush DarkViolet {get;}
[C++]
public: __property static Brush* get_DarkViolet();
[JScript]
public static function get DarkViolet() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.DeepPink

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DeepPink As Brush
[C#]
public static Brush DeepPink {get;}
[C++]
public: __property static Brush* get_DeepPink();
[JScript]
public static function get DeepPink() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.DeepSkyBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DeepSkyBlue As Brush
[C#]
public static Brush DeepSkyBlue {get;}
[C++]
public: __property static Brush* get_DeepSkyBlue();
[JScript]
public static function get DeepSkyBlue() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.DimGray

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DimGray As Brush
[C#]
public static Brush DimGray {get;}
[C++]
public: __property static Brush* get_DimGray();
[JScript]
public static function get DimGray() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.DodgerBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DodgerBlue As Brush
[C#]
public static Brush DodgerBlue {get;}
[C++]
public: __property static Brush* get_DodgerBlue();
[JScript]
public static function get DodgerBlue() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Firebrick

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Firebrick As Brush
[C#]
public static Brush Firebrick {get;}
[C++]
public: __property static Brush* get_Firebrick();
[JScript]
public static function get Firebrick() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.FloralWhite

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property FloralWhite As Brush
[C#]
public static Brush FloralWhite {get;}
[C++]
public: __property static Brush* get_FloralWhite();
[JScript]
public static function get FloralWhite() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.ForestGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property ForestGreen As Brush
[C#]
public static Brush ForestGreen {get;}
[C++]
public: __property static Brush* get_ForestGreen();
[JScript]
public static function get ForestGreen() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Fuchsia

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Fuchsia As Brush
[C#]
public static Brush Fuchsia {get;}
[C++]
public: __property static Brush* get_Fuchsia();
[JScript]
public static function get Fuchsia() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Gainsboro

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Gainsboro As Brush
[C#]
public static Brush Gainsboro {get;}
[C++]
public: __property static Brush* get_Gainsboro();
[JScript]
public static function get Gainsboro() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.GhostWhite

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property GhostWhite As Brush
[C#]
public static Brush GhostWhite {get;}
[C++]
public: __property static Brush* get_GhostWhite();
[JScript]
public static function get GhostWhite() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Gold

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Gold As Brush
[C#]
public static Brush Gold {get;}
[C++]
public: __property static Brush* get_Gold();
[JScript]
public static function get Gold() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Goldenrod

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Goldenrod As Brush
[C#]
public static Brush Goldenrod {get;}
[C++]
public: __property static Brush* get_Goldenrod();
[JScript]
public static function get Goldenrod() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Gray

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Gray As Brush
[C#]
public static Brush Gray {get;}
[C++]
public: __property static Brush* get_Gray();
[JScript]
public static function get Gray() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Green

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Green As Brush
[C#]
public static Brush Green {get;}
[C++]
public: __property static Brush* get_Green();
[JScript]
public static function get Green() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.GreenYellow

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property GreenYellow As Brush
[C#]
public static Brush GreenYellow {get;}
[C++]
public: __property static Brush* get_GreenYellow();
[JScript]
public static function get GreenYellow() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Honeydew

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Honeydew As Brush
[C#]
public static Brush Honeydew {get;}
[C++]
public: __property static Brush* get_Honeydew();
[JScript]
public static function get Honeydew() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.HotPink

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property HotPink As Brush
[C#]
public static Brush HotPink {get;}
[C++]
public: __property static Brush* get_HotPink();
[JScript]
public static function get HotPink() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.IndianRed

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property IndianRed As Brush
[C#]
public static Brush IndianRed {get;}
[C++]
public: __property static Brush* get_IndianRed();
[JScript]
public static function get IndianRed() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Indigo

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Indigo As Brush
[C#]
public static Brush Indigo {get;}
[C++]
public: __property static Brush* get_Indigo();
[JScript]
public static function get Indigo() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Ivory

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Ivory As Brush
[C#]
public static Brush Ivory {get;}
[C++]
public: __property static Brush* get_Ivory();
[JScript]
public static function get Ivory() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Khaki

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Khaki As Brush
[C#]
public static Brush Khaki {get;}
[C++]
public: __property static Brush* get_Khaki();
[JScript]
public static function get Khaki() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Lavender

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Lavender As Brush
[C#]
public static Brush Lavender {get;}
[C++]
public: __property static Brush* get_Lavender();
[JScript]
public static function get Lavender() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.LavenderBlush

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LavenderBlush As Brush
[C#]
public static Brush LavenderBlush {get;}
[C++]
public: __property static Brush* get_LavenderBlush();
[JScript]
public static function get LavenderBlush() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.LawnGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LawnGreen As Brush
[C#]
public static Brush LawnGreen {get;}
[C++]
public: __property static Brush* get_LawnGreen();
[JScript]
public static function get LawnGreen() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.LemonChiffon

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LemonChiffon As Brush
[C#]
public static Brush LemonChiffon {get;}
[C++]
public: __property static Brush* get_LemonChiffon();
[JScript]
public static function get LemonChiffon() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.LightBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightBlue As Brush
[C#]
public static Brush LightBlue {get;}
[C++]
public: __property static Brush* get_LightBlue();
[JScript]
public static function get LightBlue() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.LightCoral

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightCoral As Brush
[C#]
public static Brush LightCoral {get;}
[C++]
public: __property static Brush* get_LightCoral();
[JScript]
public static function get LightCoral() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.LightCyan

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightCyan As Brush
[C#]
public static Brush LightCyan {get;}
[C++]
public: __property static Brush* get_LightCyan();
[JScript]
public static function get LightCyan() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.LightGoldenrodYellow

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightGoldenrodYellow As Brush
[C#]
public static Brush LightGoldenrodYellow {get;}
[C++]
public: __property static Brush* get_LightGoldenrodYellow();
[JScript]
public static function get LightGoldenrodYellow() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.LightGray

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightGray As Brush
[C#]
public static Brush LightGray {get;}
[C++]
public: __property static Brush* get_LightGray();
[JScript]
public static function get LightGray() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.LightGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightGreen As Brush
[C#]
public static Brush LightGreen {get;}
[C++]
public: __property static Brush* get_LightGreen();
[JScript]
public static function get LightGreen() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.LightPink

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightPink As Brush
[C#]
public static Brush LightPink {get;}
[C++]
public: __property static Brush* get_LightPink();
[JScript]
public static function get LightPink() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.LightSalmon

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightSalmon As Brush
[C#]
public static Brush LightSalmon {get;}
[C++]
public: __property static Brush* get_LightSalmon();
[JScript]
public static function get LightSalmon() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.LightSeaGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightSeaGreen As Brush
[C#]
public static Brush LightSeaGreen {get;}
[C++]
public: __property static Brush* get_LightSeaGreen();
[JScript]
public static function get LightSeaGreen() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.LightSkyBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightSkyBlue As Brush
[C#]
public static Brush LightSkyBlue {get;}
[C++]
public: __property static Brush* get_LightSkyBlue();
[JScript]
public static function get LightSkyBlue() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.LightSlateGray

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightSlateGray As Brush
[C#]
public static Brush LightSlateGray {get;}
[C++]
public: __property static Brush* get_LightSlateGray();
[JScript]
public static function get LightSlateGray() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.LightSteelBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightSteelBlue As Brush
[C#]
public static Brush LightSteelBlue {get;}
[C++]
public: __property static Brush* get_LightSteelBlue();
[JScript]
public static function get LightSteelBlue() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.LightYellow

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightYellow As Brush
[C#]
public static Brush LightYellow {get;}
[C++]
public: __property static Brush* get_LightYellow();
[JScript]
public static function get LightYellow() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Lime

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Lime As Brush
[C#]
public static Brush Lime {get;}
[C++]
public: __property static Brush* get_Lime();
[JScript]
public static function get Lime() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.LimeGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LimeGreen As Brush
[C#]
public static Brush LimeGreen {get;}
[C++]
public: __property static Brush* get_LimeGreen();
[JScript]
public static function get LimeGreen() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Linen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Linen As Brush
[C#]
public static Brush Linen {get;}
[C++]
public: __property static Brush* get_Linen();
[JScript]
public static function get Linen() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Magenta

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Magenta As Brush
[C#]
public static Brush Magenta {get;}
[C++]
public: __property static Brush* get_Magenta();
[JScript]
public static function get Magenta() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Maroon

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Maroon As Brush
[C#]
public static Brush Maroon {get;}
[C++]
public: __property static Brush* get_Maroon();
[JScript]
public static function get Maroon() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.MediumAquamarine

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MediumAquamarine As Brush
[C#]
public static Brush MediumAquamarine {get;}
[C++]
public: __property static Brush* get_MediumAquamarine();
[JScript]
public static function get MediumAquamarine() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.MediumBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MediumBlue As Brush
[C#]
public static Brush MediumBlue {get;}
[C++]
public: __property static Brush* get_MediumBlue();
[JScript]
public static function get MediumBlue() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.MediumOrchid

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MediumOrchid As Brush
[C#]
public static Brush MediumOrchid {get;}
[C++]
public: __property static Brush* get_MediumOrchid();
[JScript]
public static function get MediumOrchid() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.MediumPurple

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MediumPurple As Brush
[C#]
public static Brush MediumPurple {get;}
[C++]
public: __property static Brush* get_MediumPurple();
[JScript]
public static function get MediumPurple() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.MediumSeaGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MediumSeaGreen As Brush
[C#]
public static Brush MediumSeaGreen {get;}
[C++]
public: __property static Brush* get_MediumSeaGreen();
[JScript]
public static function get MediumSeaGreen() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.MediumSlateBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MediumSlateBlue As Brush
[C#]
public static Brush MediumSlateBlue {get;}
[C++]
public: __property static Brush* get_MediumSlateBlue();
[JScript]
public static function get MediumSlateBlue() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.MediumSpringGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MediumSpringGreen As Brush
[C#]
public static Brush MediumSpringGreen {get;}
[C++]
public: __property static Brush* get_MediumSpringGreen();
[JScript]
public static function get MediumSpringGreen() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.MediumTurquoise

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MediumTurquoise As Brush
[C#]
public static Brush MediumTurquoise {get;}
[C++]
public: __property static Brush* get_MediumTurquoise();
[JScript]
public static function get MediumTurquoise() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.MediumVioletRed

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MediumVioletRed As Brush
[C#]
public static Brush MediumVioletRed {get;}
[C++]
public: __property static Brush* get_MediumVioletRed();
[JScript]
public static function get MediumVioletRed() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.MidnightBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MidnightBlue As Brush
[C#]
public static Brush MidnightBlue {get;}
[C++]
public: __property static Brush* get_MidnightBlue();
[JScript]
public static function get MidnightBlue() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.MintCream

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MintCream As Brush
[C#]
public static Brush MintCream {get;}
[C++]
public: __property static Brush* get_MintCream();
[JScript]
public static function get MintCream() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.MistyRose

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MistyRose As Brush
[C#]
public static Brush MistyRose {get;}
[C++]
public: __property static Brush* get_MistyRose();
[JScript]
public static function get MistyRose() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Moccasin

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Moccasin As Brush
[C#]
public static Brush Moccasin {get;}
[C++]
public: __property static Brush* get_Moccasin();
[JScript]
public static function get Moccasin() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.NavajoWhite

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property NavajoWhite As Brush
[C#]
public static Brush NavajoWhite {get;}
[C++]
public: __property static Brush* get_NavajoWhite();
[JScript]
public static function get NavajoWhite() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Navy

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Navy As Brush
[C#]
public static Brush Navy {get;}
[C++]
public: __property static Brush* get_Navy();
[JScript]
public static function get Navy() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.OldLace

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property OldLace As Brush
[C#]
public static Brush OldLace {get;}
[C++]
public: __property static Brush* get_OldLace();
[JScript]
public static function get OldLace() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Olive

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Olive As Brush
[C#]
public static Brush Olive {get;}
[C++]
public: __property static Brush* get_Olive();
[JScript]
public static function get Olive() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.OliveDrab

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property OliveDrab As Brush
[C#]
public static Brush OliveDrab {get;}
[C++]
public: __property static Brush* get_OliveDrab();
[JScript]
public static function get OliveDrab() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Orange

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Orange As Brush
[C#]
public static Brush Orange {get;}
[C++]
public: __property static Brush* get_Orange();
[JScript]
public static function get Orange() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.OrangeRed

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property OrangeRed As Brush
[C#]
public static Brush OrangeRed {get;}
[C++]
public: __property static Brush* get_OrangeRed();
[JScript]
public static function get OrangeRed() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Orchid

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Orchid As Brush
[C#]
public static Brush Orchid {get;}
[C++]
public: __property static Brush* get_Orchid();
[JScript]
public static function get Orchid() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.PaleGoldenrod

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property PaleGoldenrod As Brush
[C#]
public static Brush PaleGoldenrod {get;}
[C++]
public: __property static Brush* get_PaleGoldenrod();
[JScript]
public static function get PaleGoldenrod() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.PaleGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property PaleGreen As Brush
[C#]
public static Brush PaleGreen {get;}
[C++]
public: __property static Brush* get_PaleGreen();
[JScript]
public static function get PaleGreen() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.PaleTurquoise

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property PaleTurquoise As Brush
[C#]
public static Brush PaleTurquoise {get;}
[C++]
public: __property static Brush* get_PaleTurquoise();
[JScript]
public static function get PaleTurquoise() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.PaleVioletRed

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property PaleVioletRed As Brush
[C#]
public static Brush PaleVioletRed {get;}
[C++]
public: __property static Brush* get_PaleVioletRed();
[JScript]
public static function get PaleVioletRed() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.PapayaWhip

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property PapayaWhip As Brush
[C#]
public static Brush PapayaWhip {get;}
[C++]
public: __property static Brush* get_PapayaWhip();
[JScript]
public static function get PapayaWhip() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.PeachPuff

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property PeachPuff As Brush
[C#]
public static Brush PeachPuff {get;}
[C++]
public: __property static Brush* get_PeachPuff();
[JScript]
public static function get PeachPuff() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Peru

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Peru As Brush
[C#]
public static Brush Peru {get;}
[C++]
public: __property static Brush* get_Peru();
[JScript]
public static function get Peru() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Pink

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Pink As Brush
[C#]
public static Brush Pink {get;}
[C++]
public: __property static Brush* get_Pink();
[JScript]
public static function get Pink() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Plum

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Plum As Brush
[C#]
public static Brush Plum {get;}
[C++]
public: __property static Brush* get_Plum();
[JScript]
public static function get Plum() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.PowderBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property PowderBlue As Brush
[C#]
public static Brush PowderBlue {get;}
[C++]
public: __property static Brush* get_PowderBlue();
[JScript]
public static function get PowderBlue() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Purple

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Purple As Brush
[C#]
public static Brush Purple {get;}
[C++]
public: __property static Brush* get_Purple();
[JScript]
public static function get Purple() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Red

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Red As Brush
[C#]
public static Brush Red {get;}
[C++]
public: __property static Brush* get_Red();
[JScript]
public static function get Red() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.RosyBrown

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property RosyBrown As Brush
[C#]
public static Brush RosyBrown {get;}
[C++]
public: __property static Brush* get_RosyBrown();
[JScript]
public static function get RosyBrown() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.RoyalBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property RoyalBlue As Brush
[C#]
public static Brush RoyalBlue {get;}
[C++]
public: __property static Brush* get_RoyalBlue();
[JScript]
public static function get RoyalBlue() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.SaddleBrown

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SaddleBrown As Brush
[C#]
public static Brush SaddleBrown {get;}
[C++]
public: __property static Brush* get_SaddleBrown();
[JScript]
public static function get SaddleBrown() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Salmon

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Salmon As Brush
[C#]
public static Brush Salmon {get;}
[C++]
public: __property static Brush* get_Salmon();
[JScript]
public static function get Salmon() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.SandyBrown

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SandyBrown As Brush
[C#]
public static Brush SandyBrown {get;}
[C++]
public: __property static Brush* get_SandyBrown();
[JScript]
public static function get SandyBrown() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.SeaGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SeaGreen As Brush
[C#]
public static Brush SeaGreen {get;}
[C++]
public: __property static Brush* get_SeaGreen();
[JScript]
public static function get SeaGreen() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.SeaShell

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SeaShell As Brush
[C#]
public static Brush SeaShell {get;}
[C++]
public: __property static Brush* get_SeaShell();
[JScript]
public static function get SeaShell() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Sienna

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Sienna As Brush
[C#]
public static Brush Sienna {get;}
[C++]
public: __property static Brush* get_Sienna();
[JScript]
public static function get Sienna() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Silver

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Silver As Brush
[C#]
public static Brush Silver {get;}
[C++]
public: __property static Brush* get_Silver();
[JScript]
public static function get Silver() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.SkyBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SkyBlue As Brush
[C#]
public static Brush SkyBlue {get;}
[C++]
public: __property static Brush* get_SkyBlue();
[JScript]
public static function get SkyBlue() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.SlateBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SlateBlue As Brush
[C#]
public static Brush SlateBlue {get;}
[C++]
public: __property static Brush* get_SlateBlue();
[JScript]
public static function get SlateBlue() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.SlateGray

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SlateGray As Brush
[C#]
public static Brush SlateGray {get;}
[C++]
public: __property static Brush* get_SlateGray();
[JScript]
public static function get SlateGray() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Snow

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Snow As Brush
[C#]
public static Brush Snow {get;}
[C++]
public: __property static Brush* get_Snow();
[JScript]
public static function get Snow() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.SpringGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SpringGreen As Brush
[C#]
public static Brush SpringGreen {get;}
[C++]
public: __property static Brush* get_SpringGreen();
[JScript]
public static function get SpringGreen() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.SteelBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SteelBlue As Brush
[C#]
public static Brush SteelBlue {get;}
[C++]
public: __property static Brush* get_SteelBlue();
[JScript]
public static function get SteelBlue() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Tan

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Tan As Brush
[C#]
public static Brush Tan {get;}
[C++]
public: __property static Brush* get_Tan();
[JScript]
public static function get Tan() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Teal

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Teal As Brush
[C#]
public static Brush Teal {get;}
[C++]
public: __property static Brush* get_Teal();
[JScript]
public static function get Teal() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Thistle

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Thistle As Brush
[C#]
public static Brush Thistle {get;}
[C++]
public: __property static Brush* get_Thistle();
[JScript]
public static function get Thistle() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Tomato

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Tomato As Brush
[C#]
public static Brush Tomato {get;}
[C++]
public: __property static Brush* get_Tomato();
[JScript]
public static function get Tomato() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Transparent

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Transparent As Brush
[C#]
public static Brush Transparent {get;}
[C++]
public: __property static Brush* get_Transparent();
[JScript]
public static function get Transparent() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Turquoise

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Turquoise As Brush
[C#]
public static Brush Turquoise {get;}
[C++]
public: __property static Brush* get_Turquoise();
[JScript]
public static function get Turquoise() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Violet

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Violet As Brush
[C#]
public static Brush Violet {get;}
[C++]
public: __property static Brush* get_Violet();
[JScript]
public static function get Violet() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Wheat

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Wheat As Brush
[C#]
public static Brush Wheat {get;}
[C++]
public: __property static Brush* get_Wheat();
[JScript]
public static function get Wheat() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.White

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property White As Brush
[C#]
public static Brush White {get;}
[C++]
public: __property static Brush* get_White();
[JScript]
public static function get White() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.WhiteSmoke

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property WhiteSmoke As Brush
[C#]
public static Brush WhiteSmoke {get;}
[C++]
public: __property static Brush* get_WhiteSmoke();
[JScript]
public static function get WhiteSmoke() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.Yellow

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Yellow As Brush
[C#]
public static Brush Yellow {get;}
[C++]
public: __property static Brush* get_Yellow();
[JScript]
public static function get Yellow() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


Brushes.YellowGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property YellowGreen As Brush
[C#]
public static Brush YellowGreen {get;}
[C++]
public: __property static Brush* get_YellowGreen();
[JScript]
public static function get YellowGreen() : Brush;

See Also

Brushes Class | Brushes Members | System.Drawing Namespace


BrushStyle Enumeration

Defines a variety of brush styles that can be applied to brushes.

[Visual Basic]
Public Enum BrushStyle
[C#]
public enum BrushStyle
[C++]
public enum BrushStyle

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
BackwardDiagonal | Hatched brush consisting of backwards diagonal lines.
Cross | Hatched brush consisting of horizontal and vertical crossing lines.
DiagonalCross | Hatched brush consisting of diagonal crossing lines.
ForwardDiagonal | Hatched brush consisting of forward diagonal lines.
Hollow | "Hollow" brush that doesn't paint anything.
Horizontal | Hatched brush consisting of horizontal lines.
Max | [To be supplied.]
Min | [To be supplied.]
Pattern | Brush with a patern consisting of a custom bitmap.
Solid | Solid colored brush.
Vertical | Hatched brush consisting of vertical lines.

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

System.Drawing Namespace | Brush


Color Structure

[To be supplied.]

Object
ValueType
Color

[Visual Basic]
Public Structure Color
[C#]
public struct Color
[C++]
public __value struct Color

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

Color Members | System.Drawing Namespace


Color Members

Public:

Properties

A | Returns the alpha value from the Color object.
AliceBlue | [To be supplied.]
AntiqueWhite | [To be supplied.]
Aqua | [To be supplied.]
Aquamarine | [To be supplied.]
Azure | [To be supplied.]
B | Returns the blue value from the Color object.
Beige | [To be supplied.]
Bisque | [To be supplied.]
Black | [To be supplied.]
BlanchedAlmond | [To be supplied.]
Blue | [To be supplied.]
BlueViolet | [To be supplied.]
Brown | [To be supplied.]
BurlyWood | [To be supplied.]
CadetBlue | [To be supplied.]
Chartreuse | [To be supplied.]
Chocolate | [To be supplied.]
Coral | [To be supplied.]
Cornflower | [To be supplied.]
Cornsilk | [To be supplied.]
Crimson | [To be supplied.]
Cyan | [To be supplied.]
DarkBlue | [To be supplied.]
DarkCyan | [To be supplied.]
DarkGoldenrod | [To be supplied.]
DarkGray | [To be supplied.]
DarkGreen | [To be supplied.]
DarkKhaki | [To be supplied.]
DarkMagenta | [To be supplied.]
DarkOliveGreen | [To be supplied.]
DarkOrange | [To be supplied.]
DarkOrchid | [To be supplied.]
DarkRed | [To be supplied.]
DarkSalmon | [To be supplied.]
DarkSeaGreen | [To be supplied.]
DarkSlateBlue | [To be supplied.]
DarkSlateGray | [To be supplied.]
DarkTurquoise | [To be supplied.]
DarkViolet | [To be supplied.]
DeepPink | [To be supplied.]
DeepSkyBlue | [To be supplied.]
DimGray | [To be supplied.]
DodgerBlue | [To be supplied.]
Firebrick | [To be supplied.]
FloralWhite | [To be supplied.]
ForestGreen | [To be supplied.]
Fuchsia | [To be supplied.]
G | Returns the green value from the Color object.
Gainsboro | [To be supplied.]
GhostWhite | [To be supplied.]
Gold | [To be supplied.]
Goldenrod | [To be supplied.]
Gray | [To be supplied.]
Green | [To be supplied.]
GreenYellow | [To be supplied.]
Honeydew | [To be supplied.]
HotPink | [To be supplied.]
IndianRed | [To be supplied.]
Indigo | [To be supplied.]
IsEmpty | Determines if this color is empty. This will only return true for uninitialized colors.
IsKnownColor | Determines if this color is a known (predefined) color. Predefined colors are defined in the KnownColor enum.
IsNamedColor | Determines if the color can be converted to a name, that is if it has a name or is a KnownColor.
Ivory | [To be supplied.]
Khaki | [To be supplied.]
Lavender | [To be supplied.]
LavenderBlush | [To be supplied.]
LawnGreen | [To be supplied.]
LemonChiffon | [To be supplied.]
LightBlue | [To be supplied.]
LightCoral | [To be supplied.]
LightCyan | [To be supplied.]
LightGoldenrodYellow | [To be supplied.]
LightGray | [To be supplied.]
LightGreen | [To be supplied.]
LightPink | [To be supplied.]
LightSalmon | [To be supplied.]
LightSeaGreen | [To be supplied.]
LightSkyBlue | [To be supplied.]
LightSlateGray | [To be supplied.]
LightSteelBlue | [To be supplied.]
LightYellow | [To be supplied.]
Lime | [To be supplied.]
LimeGreen | [To be supplied.]
Linen | [To be supplied.]
Magenta | [To be supplied.]
Maroon | [To be supplied.]
MediumAquamarine | [To be supplied.]
MediumBlue | [To be supplied.]
MediumOrchid | [To be supplied.]
MediumPurple | [To be supplied.]
MediumSeaGreen | [To be supplied.]
MediumSlateBlue | [To be supplied.]
MediumSpringGreen | [To be supplied.]
MediumTurquoise | [To be supplied.]
MediumVioletRed | [To be supplied.]
MidnightBlue | [To be supplied.]
MintCream | [To be supplied.]
MistyRose | [To be supplied.]
Moccasin | [To be supplied.]
Name | Determines the name of the color. This will either return the user defined name of the color, if the color was created from a name, or the name of the known color. For custom colors, the RGB value will be returned.
NavajoWhite | [To be supplied.]
Navy | [To be supplied.]
OldLace | [To be supplied.]
Olive | [To be supplied.]
OliveDrab | [To be supplied.]
Orange | [To be supplied.]
OrangeRed | [To be supplied.]
Orchid | [To be supplied.]
PaleGoldenrod | [To be supplied.]
PaleGreen | [To be supplied.]
PaleTurquoise | [To be supplied.]
PaleVioletRed | [To be supplied.]
PapayaWhip | [To be supplied.]
PeachPuff | [To be supplied.]
Peru | [To be supplied.]
Pink | [To be supplied.]
Plum | [To be supplied.]
PowderBlue | [To be supplied.]
Purple | [To be supplied.]
R | Returns the red value from the Color object.
Red | [To be supplied.]
RosyBrown | [To be supplied.]
RoyalBlue | [To be supplied.]
SaddleBrown | [To be supplied.]
Salmon | [To be supplied.]
SandyBrown | [To be supplied.]
SeaGreen | [To be supplied.]
SeaShell | [To be supplied.]
Sienna | [To be supplied.]
Silver | [To be supplied.]
SkyBlue | [To be supplied.]
SlateBlue | [To be supplied.]
SlateGray | [To be supplied.]
Snow | [To be supplied.]
SpringGreen | [To be supplied.]
SteelBlue | [To be supplied.]
Tan | [To be supplied.]
Teal | [To be supplied.]
Thistle | [To be supplied.]
Tomato | [To be supplied.]
Transparent | [To be supplied.]
Turquoise | [To be supplied.]
Violet | [To be supplied.]
Wheat | [To be supplied.]
White | [To be supplied.]
WhiteSmoke | [To be supplied.]
Yellow | [To be supplied.]
YellowGreen | [To be supplied.]

Methods

Equals | [To be supplied.]
FromARGB | Overloaded. [To be supplied.]
FromKnownColor | Creates a color object from the specified KnownColor.
FromName | Creates a color object with the specified name.
FromSRGB64 | Creates a color object from the specified sRGB64 value. The resulting color object will have 64 bit precision.
FromString | [To be supplied.]
GetBrightness | The HSB brightness for this color.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetHue | The HSB Hue value for this color, in degrees.
GetSaturation | The HSB saturation for this color.
GetType (inherited from Object) | Gets the Type of the Object.
ToARGB | Returns the ARGB value of this color.
ToKnownColor | Returns the KnownColor value for this color, if it is based on a KnownColor.
ToSRGB64 | Returns the sRGB64 value of this color.
ToString | [To be supplied.]

Operators

Equality Operator | [To be supplied.]
Inequality Operator | [To be supplied.]

Fields

Empty [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Color Structure | System.Drawing Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Color Properties

The properties of the Color structure are listed below. For a complete list of Color structure members, see the Color Members topic.

Public:

A | Returns the alpha value from the Color object.
AliceBlue | [To be supplied.]
AntiqueWhite | [To be supplied.]
Aqua | [To be supplied.]
Aquamarine | [To be supplied.]
Azure | [To be supplied.]
B | Returns the blue value from the Color object.
Beige | [To be supplied.]
Bisque | [To be supplied.]
Black | [To be supplied.]
BlanchedAlmond | [To be supplied.]
Blue | [To be supplied.]
BlueViolet | [To be supplied.]
Brown | [To be supplied.]
BurlyWood | [To be supplied.]
CadetBlue | [To be supplied.]
Chartreuse | [To be supplied.]
Chocolate | [To be supplied.]
Coral | [To be supplied.]
Cornflower | [To be supplied.]
Cornsilk | [To be supplied.]
Crimson | [To be supplied.]
Cyan | [To be supplied.]
DarkBlue | [To be supplied.]
DarkCyan | [To be supplied.]
DarkGoldenrod | [To be supplied.]
DarkGray | [To be supplied.]
DarkGreen | [To be supplied.]
DarkKhaki | [To be supplied.]
DarkMagenta | [To be supplied.]
DarkOliveGreen | [To be supplied.]
DarkOrange | [To be supplied.]
DarkOrchid | [To be supplied.]
DarkRed | [To be supplied.]
DarkSalmon | [To be supplied.]
DarkSeaGreen | [To be supplied.]
DarkSlateBlue | [To be supplied.]
DarkSlateGray | [To be supplied.]
DarkTurquoise | [To be supplied.]
DarkViolet | [To be supplied.]
DeepPink | [To be supplied.]
DeepSkyBlue | [To be supplied.]
DimGray | [To be supplied.]
DodgerBlue | [To be supplied.]
Firebrick | [To be supplied.]
FloralWhite | [To be supplied.]
ForestGreen | [To be supplied.]
Fuchsia | [To be supplied.]
G | Returns the green value from the Color object.
Gainsboro | [To be supplied.]
GhostWhite | [To be supplied.]
Gold | [To be supplied.]
Goldenrod | [To be supplied.]
Gray | [To be supplied.]
Green | [To be supplied.]
GreenYellow | [To be supplied.]
Honeydew | [To be supplied.]
HotPink | [To be supplied.]
IndianRed | [To be supplied.]
Indigo | [To be supplied.]
IsEmpty | Determines if this color is empty. This will only return true for uninitialized colors.
IsKnownColor | Determines if this color is a known (predefined) color. Predefined colors are defined in the KnownColor enum.
IsNamedColor | Determines if the color can be converted to a name, that is if it has a name or is a KnownColor.
Ivory | [To be supplied.]
Khaki | [To be supplied.]
Lavender | [To be supplied.]
LavenderBlush | [To be supplied.]
LawnGreen | [To be supplied.]
LemonChiffon | [To be supplied.]
LightBlue | [To be supplied.]
LightCoral | [To be supplied.]
LightCyan | [To be supplied.]
LightGoldenrodYellow | [To be supplied.]
LightGray | [To be supplied.]
LightGreen | [To be supplied.]
LightPink | [To be supplied.]
LightSalmon | [To be supplied.]
LightSeaGreen | [To be supplied.]
LightSkyBlue | [To be supplied.]
LightSlateGray | [To be supplied.]
LightSteelBlue | [To be supplied.]
LightYellow | [To be supplied.]
Lime | [To be supplied.]
LimeGreen | [To be supplied.]
Linen | [To be supplied.]
Magenta | [To be supplied.]
Maroon | [To be supplied.]
MediumAquamarine | [To be supplied.]
MediumBlue | [To be supplied.]
MediumOrchid | [To be supplied.]
MediumPurple | [To be supplied.]
MediumSeaGreen | [To be supplied.]
MediumSlateBlue | [To be supplied.]
MediumSpringGreen | [To be supplied.]
MediumTurquoise | [To be supplied.]
MediumVioletRed | [To be supplied.]
MidnightBlue | [To be supplied.]
MintCream | [To be supplied.]
MistyRose | [To be supplied.]
Moccasin | [To be supplied.]
Name | Determines the name of the color. This will either return the user defined name of the color, if the color was created from a name, or the name of the known color. For custom colors, the RGB value will be returned.
NavajoWhite | [To be supplied.]
Navy | [To be supplied.]
OldLace | [To be supplied.]
Olive | [To be supplied.]
OliveDrab | [To be supplied.]
Orange | [To be supplied.]
OrangeRed | [To be supplied.]
Orchid | [To be supplied.]
PaleGoldenrod | [To be supplied.]
PaleGreen | [To be supplied.]
PaleTurquoise | [To be supplied.]
PaleVioletRed | [To be supplied.]
PapayaWhip | [To be supplied.]
PeachPuff | [To be supplied.]
Peru | [To be supplied.]
Pink | [To be supplied.]
Plum | [To be supplied.]
PowderBlue | [To be supplied.]
Purple | [To be supplied.]
R | Returns the red value from the Color object.
Red | [To be supplied.]
RosyBrown | [To be supplied.]
RoyalBlue | [To be supplied.]
SaddleBrown | [To be supplied.]
Salmon | [To be supplied.]
SandyBrown | [To be supplied.]
SeaGreen | [To be supplied.]
SeaShell | [To be supplied.]
Sienna | [To be supplied.]
Silver | [To be supplied.]
SkyBlue | [To be supplied.]
SlateBlue | [To be supplied.]
SlateGray | [To be supplied.]
Snow | [To be supplied.]
SpringGreen | [To be supplied.]
SteelBlue | [To be supplied.]
Tan | [To be supplied.]
Teal | [To be supplied.]
Thistle | [To be supplied.]
Tomato | [To be supplied.]
Transparent | [To be supplied.]
Turquoise | [To be supplied.]
Violet | [To be supplied.]
Wheat | [To be supplied.]
White | [To be supplied.]
WhiteSmoke | [To be supplied.]
Yellow | [To be supplied.]
YellowGreen | [To be supplied.]

See Also

Color Structure | System.Drawing Namespace


Color.A

Returns the alpha value from the Color object.

[Visual Basic]
Public ReadOnly Property A As Byte
[C#]
public byte A {get;}
[C++]
public: __property unsigned char get_A();
[JScript]
public function get A() : Byte;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.AliceBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property AliceBlue As Color
[C#]
public static Color AliceBlue {get;}
[C++]
public: __property static Color get_AliceBlue();
[JScript]
public static function get AliceBlue() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.AntiqueWhite

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property AntiqueWhite As Color
[C#]
public static Color AntiqueWhite {get;}
[C++]
public: __property static Color get_AntiqueWhite();
[JScript]
public static function get AntiqueWhite() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Aqua

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Aqua As Color
[C#]
public static Color Aqua {get;}
[C++]
public: __property static Color get_Aqua();
[JScript]
public static function get Aqua() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Aquamarine

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Aquamarine As Color
[C#]
public static Color Aquamarine {get;}
[C++]
public: __property static Color get_Aquamarine();
[JScript]
public static function get Aquamarine() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Azure

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Azure As Color
[C#]
public static Color Azure {get;}
[C++]
public: __property static Color get_Azure();
[JScript]
public static function get Azure() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.B

Returns the blue value from the Color object.

[Visual Basic]
Public ReadOnly Property B As Byte
[C#]
public byte B {get;}
[C++]
public: __property unsigned char get_B();
[JScript]
public function get B() : Byte;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Beige

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Beige As Color
[C#]
public static Color Beige {get;}
[C++]
public: __property static Color get_Beige();
[JScript]
public static function get Beige() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Bisque

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Bisque As Color
[C#]
public static Color Bisque {get;}
[C++]
public: __property static Color get_Bisque();
[JScript]
public static function get Bisque() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Black

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Black As Color
[C#]
public static Color Black {get;}
[C++]
public: __property static Color get_Black();
[JScript]
public static function get Black() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.BlanchedAlmond

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property BlanchedAlmond As Color
[C#]
public static Color BlanchedAlmond {get;}
[C++]
public: __property static Color get_BlanchedAlmond();
[JScript]
public static function get BlanchedAlmond() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Blue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Blue As Color
[C#]
public static Color Blue {get;}
[C++]
public: __property static Color get_Blue();
[JScript]
public static function get Blue() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.BlueViolet

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property BlueViolet As Color
[C#]
public static Color BlueViolet {get;}
[C++]
public: __property static Color get_BlueViolet();
[JScript]
public static function get BlueViolet() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Brown

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Brown As Color
[C#]
public static Color Brown {get;}
[C++]
public: __property static Color get_Brown();
[JScript]
public static function get Brown() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.BurlyWood

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property BurlyWood As Color
[C#]
public static Color BurlyWood {get;}
[C++]
public: __property static Color get_BurlyWood();
[JScript]
public static function get BurlyWood() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.CadetBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property CadetBlue As Color
[C#]
public static Color CadetBlue {get;}
[C++]
public: __property static Color get_CadetBlue();
[JScript]
public static function get CadetBlue() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Chartreuse

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Chartreuse As Color
[C#]
public static Color Chartreuse {get;}
[C++]
public: __property static Color get_Chartreuse();
[JScript]
public static function get Chartreuse() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Chocolate

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Chocolate As Color
[C#]
public static Color Chocolate {get;}
[C++]
public: __property static Color get_Chocolate();
[JScript]
public static function get Chocolate() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Coral

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Coral As Color
[C#]
public static Color Coral {get;}
[C++]
public: __property static Color get_Coral();
[JScript]
public static function get Coral() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Cornflower

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Cornflower As Color
[C#]
public static Color Cornflower {get;}
[C++]
public: __property static Color get_Cornflower();
[JScript]
public static function get Cornflower() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Cornsilk

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Cornsilk As Color
[C#]
public static Color Cornsilk {get;}
[C++]
public: __property static Color get_Cornsilk();
[JScript]
public static function get Cornsilk() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Crimson

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Crimson As Color
[C#]
public static Color Crimson {get;}
[C++]
public: __property static Color get_Crimson();
[JScript]
public static function get Crimson() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Cyan

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Cyan As Color
[C#]
public static Color Cyan {get;}
[C++]
public: __property static Color get_Cyan();
[JScript]
public static function get Cyan() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.DarkBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkBlue As Color
[C#]
public static Color DarkBlue {get;}
[C++]
public: __property static Color get_DarkBlue();
[JScript]
public static function get DarkBlue() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.DarkCyan

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkCyan As Color
[C#]
public static Color DarkCyan {get;}
[C++]
public: __property static Color get_DarkCyan();
[JScript]
public static function get DarkCyan() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.DarkGoldenrod

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkGoldenrod As Color
[C#]
public static Color DarkGoldenrod {get;}
[C++]
public: __property static Color get_DarkGoldenrod();
[JScript]
public static function get DarkGoldenrod() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.DarkGray

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkGray As Color
[C#]
public static Color DarkGray {get;}
[C++]
public: __property static Color get_DarkGray();
[JScript]
public static function get DarkGray() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.DarkGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkGreen As Color
[C#]
public static Color DarkGreen {get;}
[C++]
public: __property static Color get_DarkGreen();
[JScript]
public static function get DarkGreen() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.DarkKhaki

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkKhaki As Color
[C#]
public static Color DarkKhaki {get;}
[C++]
public: __property static Color get_DarkKhaki();
[JScript]
public static function get DarkKhaki() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.DarkMagenta

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkMagenta As Color
[C#]
public static Color DarkMagenta {get;}
[C++]
public: __property static Color get_DarkMagenta();
[JScript]
public static function get DarkMagenta() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.DarkOliveGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkOliveGreen As Color
[C#]
public static Color DarkOliveGreen {get;}
[C++]
public: __property static Color get_DarkOliveGreen();
[JScript]
public static function get DarkOliveGreen() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.DarkOrange

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkOrange As Color
[C#]
public static Color DarkOrange {get;}
[C++]
public: __property static Color get_DarkOrange();
[JScript]
public static function get DarkOrange() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.DarkOrchid

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkOrchid As Color
[C#]
public static Color DarkOrchid {get;}
[C++]
public: __property static Color get_DarkOrchid();
[JScript]
public static function get DarkOrchid() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.DarkRed

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkRed As Color
[C#]
public static Color DarkRed {get;}
[C++]
public: __property static Color get_DarkRed();
[JScript]
public static function get DarkRed() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.DarkSalmon

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkSalmon As Color
[C#]
public static Color DarkSalmon {get;}
[C++]
public: __property static Color get_DarkSalmon();
[JScript]
public static function get DarkSalmon() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.DarkSeaGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkSeaGreen As Color
[C#]
public static Color DarkSeaGreen {get;}
[C++]
public: __property static Color get_DarkSeaGreen();
[JScript]
public static function get DarkSeaGreen() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.DarkSlateBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkSlateBlue As Color
[C#]
public static Color DarkSlateBlue {get;}
[C++]
public: __property static Color get_DarkSlateBlue();
[JScript]
public static function get DarkSlateBlue() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.DarkSlateGray

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkSlateGray As Color
[C#]
public static Color DarkSlateGray {get;}
[C++]
public: __property static Color get_DarkSlateGray();
[JScript]
public static function get DarkSlateGray() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.DarkTurquoise

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkTurquoise As Color
[C#]
public static Color DarkTurquoise {get;}
[C++]
public: __property static Color get_DarkTurquoise();
[JScript]
public static function get DarkTurquoise() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.DarkViolet

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkViolet As Color
[C#]
public static Color DarkViolet {get;}
[C++]
public: __property static Color get_DarkViolet();
[JScript]
public static function get DarkViolet() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.DeepPink

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DeepPink As Color
[C#]
public static Color DeepPink {get;}
[C++]
public: __property static Color get_DeepPink();
[JScript]
public static function get DeepPink() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.DeepSkyBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DeepSkyBlue As Color
[C#]
public static Color DeepSkyBlue {get;}
[C++]
public: __property static Color get_DeepSkyBlue();
[JScript]
public static function get DeepSkyBlue() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.DimGray

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DimGray As Color
[C#]
public static Color DimGray {get;}
[C++]
public: __property static Color get_DimGray();
[JScript]
public static function get DimGray() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.DodgerBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DodgerBlue As Color
[C#]
public static Color DodgerBlue {get;}
[C++]
public: __property static Color get_DodgerBlue();
[JScript]
public static function get DodgerBlue() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Firebrick

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Firebrick As Color
[C#]
public static Color Firebrick {get;}
[C++]
public: __property static Color get_Firebrick();
[JScript]
public static function get Firebrick() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.FloralWhite

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property FloralWhite As Color
[C#]
public static Color FloralWhite {get;}
[C++]
public: __property static Color get_FloralWhite();
[JScript]
public static function get FloralWhite() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.ForestGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property ForestGreen As Color
[C#]
public static Color ForestGreen {get;}
[C++]
public: __property static Color get_ForestGreen();
[JScript]
public static function get ForestGreen() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Fuchsia

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Fuchsia As Color
[C#]
public static Color Fuchsia {get;}
[C++]
public: __property static Color get_Fuchsia();
[JScript]
public static function get Fuchsia() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.G

Returns the green value from the Color object.

[Visual Basic]
Public ReadOnly Property G As Byte
[C#]
public byte G {get;}
[C++]
public: __property unsigned char get_G();
[JScript]
public function get G() : Byte;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Gainsboro

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Gainsboro As Color
[C#]
public static Color Gainsboro {get;}
[C++]
public: __property static Color get_Gainsboro();
[JScript]
public static function get Gainsboro() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.GhostWhite

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property GhostWhite As Color
[C#]
public static Color GhostWhite {get;}
[C++]
public: __property static Color get_GhostWhite();
[JScript]
public static function get GhostWhite() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Gold

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Gold As Color
[C#]
public static Color Gold {get;}
[C++]
public: __property static Color get_Gold();
[JScript]
public static function get Gold() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Goldenrod

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Goldenrod As Color
[C#]
public static Color Goldenrod {get;}
[C++]
public: __property static Color get_Goldenrod();
[JScript]
public static function get Goldenrod() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Gray

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Gray As Color
[C#]
public static Color Gray {get;}
[C++]
public: __property static Color get_Gray();
[JScript]
public static function get Gray() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Green

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Green As Color
[C#]
public static Color Green {get;}
[C++]
public: __property static Color get_Green();
[JScript]
public static function get Green() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.GreenYellow

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property GreenYellow As Color
[C#]
public static Color GreenYellow {get;}
[C++]
public: __property static Color get_GreenYellow();
[JScript]
public static function get GreenYellow() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Honeydew

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Honeydew As Color
[C#]
public static Color Honeydew {get;}
[C++]
public: __property static Color get_Honeydew();
[JScript]
public static function get Honeydew() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.HotPink

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property HotPink As Color
[C#]
public static Color HotPink {get;}
[C++]
public: __property static Color get_HotPink();
[JScript]
public static function get HotPink() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.IndianRed

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property IndianRed As Color
[C#]
public static Color IndianRed {get;}
[C++]
public: __property static Color get_IndianRed();
[JScript]
public static function get IndianRed() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Indigo

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Indigo As Color
[C#]
public static Color Indigo {get;}
[C++]
public: __property static Color get_Indigo();
[JScript]
public static function get Indigo() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.IsEmpty

Determines if this color is empty. This will only return true for uninitialized colors.

[Visual Basic]
Public ReadOnly Property IsEmpty As Boolean
[C#]
public bool IsEmpty {get;}
[C++]
public: __property bool get_IsEmpty();
[JScript]
public function get IsEmpty() : Boolean;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.IsKnownColor

Determines if this color is a known (predefined) color. Predefined colors are defined in the KnownColor enum.

[Visual Basic]
Public ReadOnly Property IsKnownColor As Boolean
[C#]
public bool IsKnownColor {get;}
[C++]
public: __property bool get_IsKnownColor();
[JScript]
public function get IsKnownColor() : Boolean;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.IsNamedColor

Determines if the color can be converted to a name, that is if it has a name or is a KnownColor.

[Visual Basic]
Public ReadOnly Property IsNamedColor As Boolean
[C#]
public bool IsNamedColor {get;}
[C++]
public: __property bool get_IsNamedColor();
[JScript]
public function get IsNamedColor() : Boolean;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Ivory

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Ivory As Color
[C#]
public static Color Ivory {get;}
[C++]
public: __property static Color get_Ivory();
[JScript]
public static function get Ivory() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Khaki

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Khaki As Color
[C#]
public static Color Khaki {get;}
[C++]
public: __property static Color get_Khaki();
[JScript]
public static function get Khaki() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Lavender

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Lavender As Color
[C#]
public static Color Lavender {get;}
[C++]
public: __property static Color get_Lavender();
[JScript]
public static function get Lavender() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.LavenderBlush

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LavenderBlush As Color
[C#]
public static Color LavenderBlush {get;}
[C++]
public: __property static Color get_LavenderBlush();
[JScript]
public static function get LavenderBlush() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.LawnGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LawnGreen As Color
[C#]
public static Color LawnGreen {get;}
[C++]
public: __property static Color get_LawnGreen();
[JScript]
public static function get LawnGreen() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.LemonChiffon

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LemonChiffon As Color
[C#]
public static Color LemonChiffon {get;}
[C++]
public: __property static Color get_LemonChiffon();
[JScript]
public static function get LemonChiffon() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.LightBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightBlue As Color
[C#]
public static Color LightBlue {get;}
[C++]
public: __property static Color get_LightBlue();
[JScript]
public static function get LightBlue() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.LightCoral

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightCoral As Color
[C#]
public static Color LightCoral {get;}
[C++]
public: __property static Color get_LightCoral();
[JScript]
public static function get LightCoral() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.LightCyan

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightCyan As Color
[C#]
public static Color LightCyan {get;}
[C++]
public: __property static Color get_LightCyan();
[JScript]
public static function get LightCyan() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.LightGoldenrodYellow

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightGoldenrodYellow As Color
[C#]
public static Color LightGoldenrodYellow {get;}
[C++]
public: __property static Color get_LightGoldenrodYellow();
[JScript]
public static function get LightGoldenrodYellow() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.LightGray

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightGray As Color
[C#]
public static Color LightGray {get;}
[C++]
public: __property static Color get_LightGray();
[JScript]
public static function get LightGray() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.LightGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightGreen As Color
[C#]
public static Color LightGreen {get;}
[C++]
public: __property static Color get_LightGreen();
[JScript]
public static function get LightGreen() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.LightPink

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightPink As Color
[C#]
public static Color LightPink {get;}
[C++]
public: __property static Color get_LightPink();
[JScript]
public static function get LightPink() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.LightSalmon

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightSalmon As Color
[C#]
public static Color LightSalmon {get;}
[C++]
public: __property static Color get_LightSalmon();
[JScript]
public static function get LightSalmon() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.LightSeaGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightSeaGreen As Color
[C#]
public static Color LightSeaGreen {get;}
[C++]
public: __property static Color get_LightSeaGreen();
[JScript]
public static function get LightSeaGreen() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.LightSkyBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightSkyBlue As Color
[C#]
public static Color LightSkyBlue {get;}
[C++]
public: __property static Color get_LightSkyBlue();
[JScript]
public static function get LightSkyBlue() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.LightSlateGray

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightSlateGray As Color
[C#]
public static Color LightSlateGray {get;}
[C++]
public: __property static Color get_LightSlateGray();
[JScript]
public static function get LightSlateGray() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.LightSteelBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightSteelBlue As Color
[C#]
public static Color LightSteelBlue {get;}
[C++]
public: __property static Color get_LightSteelBlue();
[JScript]
public static function get LightSteelBlue() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.LightYellow

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightYellow As Color
[C#]
public static Color LightYellow {get;}
[C++]
public: __property static Color get_LightYellow();
[JScript]
public static function get LightYellow() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Lime

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Lime As Color
[C#]
public static Color Lime {get;}
[C++]
public: __property static Color get_Lime();
[JScript]
public static function get Lime() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.LimeGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LimeGreen As Color
[C#]
public static Color LimeGreen {get;}
[C++]
public: __property static Color get_LimeGreen();
[JScript]
public static function get LimeGreen() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Linen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Linen As Color
[C#]
public static Color Linen {get;}
[C++]
public: __property static Color get_Linen();
[JScript]
public static function get Linen() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Magenta

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Magenta As Color
[C#]
public static Color Magenta {get;}
[C++]
public: __property static Color get_Magenta();
[JScript]
public static function get Magenta() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Maroon

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Maroon As Color
[C#]
public static Color Maroon {get;}
[C++]
public: __property static Color get_Maroon();
[JScript]
public static function get Maroon() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.MediumAquamarine

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MediumAquamarine As Color
[C#]
public static Color MediumAquamarine {get;}
[C++]
public: __property static Color get_MediumAquamarine();
[JScript]
public static function get MediumAquamarine() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.MediumBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MediumBlue As Color
[C#]
public static Color MediumBlue {get;}
[C++]
public: __property static Color get_MediumBlue();
[JScript]
public static function get MediumBlue() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.MediumOrchid

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MediumOrchid As Color
[C#]
public static Color MediumOrchid {get;}
[C++]
public: __property static Color get_MediumOrchid();
[JScript]
public static function get MediumOrchid() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.MediumPurple

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MediumPurple As Color
[C#]
public static Color MediumPurple {get;}
[C++]
public: __property static Color get_MediumPurple();
[JScript]
public static function get MediumPurple() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.MediumSeaGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MediumSeaGreen As Color
[C#]
public static Color MediumSeaGreen {get;}
[C++]
public: __property static Color get_MediumSeaGreen();
[JScript]
public static function get MediumSeaGreen() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.MediumSlateBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MediumSlateBlue As Color
[C#]
public static Color MediumSlateBlue {get;}
[C++]
public: __property static Color get_MediumSlateBlue();
[JScript]
public static function get MediumSlateBlue() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.MediumSpringGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MediumSpringGreen As Color
[C#]
public static Color MediumSpringGreen {get;}
[C++]
public: __property static Color get_MediumSpringGreen();
[JScript]
public static function get MediumSpringGreen() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.MediumTurquoise

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MediumTurquoise As Color
[C#]
public static Color MediumTurquoise {get;}
[C++]
public: __property static Color get_MediumTurquoise();
[JScript]
public static function get MediumTurquoise() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.MediumVioletRed

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MediumVioletRed As Color
[C#]
public static Color MediumVioletRed {get;}
[C++]
public: __property static Color get_MediumVioletRed();
[JScript]
public static function get MediumVioletRed() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.MidnightBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MidnightBlue As Color
[C#]
public static Color MidnightBlue {get;}
[C++]
public: __property static Color get_MidnightBlue();
[JScript]
public static function get MidnightBlue() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.MintCream

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MintCream As Color
[C#]
public static Color MintCream {get;}
[C++]
public: __property static Color get_MintCream();
[JScript]
public static function get MintCream() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.MistyRose

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MistyRose As Color
[C#]
public static Color MistyRose {get;}
[C++]
public: __property static Color get_MistyRose();
[JScript]
public static function get MistyRose() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Moccasin

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Moccasin As Color
[C#]
public static Color Moccasin {get;}
[C++]
public: __property static Color get_Moccasin();
[JScript]
public static function get Moccasin() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Name

Determines the name of the color. This will either return the user defined name of the color, if the color was created from a name, or the name of the known color. For custom colors, the RGB value will be returned.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}
[C++]
public: __property String* get_Name();
[JScript]
public function get Name() : String;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.NavajoWhite

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property NavajoWhite As Color
[C#]
public static Color NavajoWhite {get;}
[C++]
public: __property static Color get_NavajoWhite();
[JScript]
public static function get NavajoWhite() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Navy

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Navy As Color
[C#]
public static Color Navy {get;}
[C++]
public: __property static Color get_Navy();
[JScript]
public static function get Navy() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.OldLace

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property OldLace As Color
[C#]
public static Color OldLace {get;}
[C++]
public: __property static Color get_OldLace();
[JScript]
public static function get OldLace() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Olive

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Olive As Color
[C#]
public static Color Olive {get;}
[C++]
public: __property static Color get_Olive();
[JScript]
public static function get Olive() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.OliveDrab

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property OliveDrab As Color
[C#]
public static Color OliveDrab {get;}
[C++]
public: __property static Color get_OliveDrab();
[JScript]
public static function get OliveDrab() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Orange

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Orange As Color
[C#]
public static Color Orange {get;}
[C++]
public: __property static Color get_Orange();
[JScript]
public static function get Orange() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.OrangeRed

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property OrangeRed As Color
[C#]
public static Color OrangeRed {get;}
[C++]
public: __property static Color get_OrangeRed();
[JScript]
public static function get OrangeRed() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Orchid

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Orchid As Color
[C#]
public static Color Orchid {get;}
[C++]
public: __property static Color get_Orchid();
[JScript]
public static function get Orchid() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.PaleGoldenrod

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property PaleGoldenrod As Color
[C#]
public static Color PaleGoldenrod {get;}
[C++]
public: __property static Color get_PaleGoldenrod();
[JScript]
public static function get PaleGoldenrod() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.PaleGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property PaleGreen As Color
[C#]
public static Color PaleGreen {get;}
[C++]
public: __property static Color get_PaleGreen();
[JScript]
public static function get PaleGreen() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.PaleTurquoise

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property PaleTurquoise As Color
[C#]
public static Color PaleTurquoise {get;}
[C++]
public: __property static Color get_PaleTurquoise();
[JScript]
public static function get PaleTurquoise() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.PaleVioletRed

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property PaleVioletRed As Color
[C#]
public static Color PaleVioletRed {get;}
[C++]
public: __property static Color get_PaleVioletRed();
[JScript]
public static function get PaleVioletRed() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.PapayaWhip

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property PapayaWhip As Color
[C#]
public static Color PapayaWhip {get;}
[C++]
public: __property static Color get_PapayaWhip();
[JScript]
public static function get PapayaWhip() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.PeachPuff

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property PeachPuff As Color
[C#]
public static Color PeachPuff {get;}
[C++]
public: __property static Color get_PeachPuff();
[JScript]
public static function get PeachPuff() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Peru

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Peru As Color
[C#]
public static Color Peru {get;}
[C++]
public: __property static Color get_Peru();
[JScript]
public static function get Peru() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Pink

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Pink As Color
[C#]
public static Color Pink {get;}
[C++]
public: __property static Color get_Pink();
[JScript]
public static function get Pink() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Plum

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Plum As Color
[C#]
public static Color Plum {get;}
[C++]
public: __property static Color get_Plum();
[JScript]
public static function get Plum() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.PowderBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property PowderBlue As Color
[C#]
public static Color PowderBlue {get;}
[C++]
public: __property static Color get_PowderBlue();
[JScript]
public static function get PowderBlue() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Purple

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Purple As Color
[C#]
public static Color Purple {get;}
[C++]
public: __property static Color get_Purple();
[JScript]
public static function get Purple() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.R

Returns the red value from the Color object.

[Visual Basic]
Public ReadOnly Property R As Byte
[C#]
public byte R {get;}
[C++]
public: __property unsigned char get_R();
[JScript]
public function get R() : Byte;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Red

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Red As Color
[C#]
public static Color Red {get;}
[C++]
public: __property static Color get_Red();
[JScript]
public static function get Red() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.RosyBrown

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property RosyBrown As Color
[C#]
public static Color RosyBrown {get;}
[C++]
public: __property static Color get_RosyBrown();
[JScript]
public static function get RosyBrown() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.RoyalBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property RoyalBlue As Color
[C#]
public static Color RoyalBlue {get;}
[C++]
public: __property static Color get_RoyalBlue();
[JScript]
public static function get RoyalBlue() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.SaddleBrown

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SaddleBrown As Color
[C#]
public static Color SaddleBrown {get;}
[C++]
public: __property static Color get_SaddleBrown();
[JScript]
public static function get SaddleBrown() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Salmon

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Salmon As Color
[C#]
public static Color Salmon {get;}
[C++]
public: __property static Color get_Salmon();
[JScript]
public static function get Salmon() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.SandyBrown

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SandyBrown As Color
[C#]
public static Color SandyBrown {get;}
[C++]
public: __property static Color get_SandyBrown();
[JScript]
public static function get SandyBrown() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.SeaGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SeaGreen As Color
[C#]
public static Color SeaGreen {get;}
[C++]
public: __property static Color get_SeaGreen();
[JScript]
public static function get SeaGreen() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.SeaShell

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SeaShell As Color
[C#]
public static Color SeaShell {get;}
[C++]
public: __property static Color get_SeaShell();
[JScript]
public static function get SeaShell() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Sienna

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Sienna As Color
[C#]
public static Color Sienna {get;}
[C++]
public: __property static Color get_Sienna();
[JScript]
public static function get Sienna() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Silver

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Silver As Color
[C#]
public static Color Silver {get;}
[C++]
public: __property static Color get_Silver();
[JScript]
public static function get Silver() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.SkyBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SkyBlue As Color
[C#]
public static Color SkyBlue {get;}
[C++]
public: __property static Color get_SkyBlue();
[JScript]
public static function get SkyBlue() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.SlateBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SlateBlue As Color
[C#]
public static Color SlateBlue {get;}
[C++]
public: __property static Color get_SlateBlue();
[JScript]
public static function get SlateBlue() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.SlateGray

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SlateGray As Color
[C#]
public static Color SlateGray {get;}
[C++]
public: __property static Color get_SlateGray();
[JScript]
public static function get SlateGray() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Snow

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Snow As Color
[C#]
public static Color Snow {get;}
[C++]
public: __property static Color get_Snow();
[JScript]
public static function get Snow() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.SpringGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SpringGreen As Color
[C#]
public static Color SpringGreen {get;}
[C++]
public: __property static Color get_SpringGreen();
[JScript]
public static function get SpringGreen() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.SteelBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SteelBlue As Color
[C#]
public static Color SteelBlue {get;}
[C++]
public: __property static Color get_SteelBlue();
[JScript]
public static function get SteelBlue() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Tan

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Tan As Color
[C#]
public static Color Tan {get;}
[C++]
public: __property static Color get_Tan();
[JScript]
public static function get Tan() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Teal

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Teal As Color
[C#]
public static Color Teal {get;}
[C++]
public: __property static Color get_Teal();
[JScript]
public static function get Teal() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Thistle

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Thistle As Color
[C#]
public static Color Thistle {get;}
[C++]
public: __property static Color get_Thistle();
[JScript]
public static function get Thistle() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Tomato

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Tomato As Color
[C#]
public static Color Tomato {get;}
[C++]
public: __property static Color get_Tomato();
[JScript]
public static function get Tomato() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Transparent

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Transparent As Color
[C#]
public static Color Transparent {get;}
[C++]
public: __property static Color get_Transparent();
[JScript]
public static function get Transparent() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Turquoise

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Turquoise As Color
[C#]
public static Color Turquoise {get;}
[C++]
public: __property static Color get_Turquoise();
[JScript]
public static function get Turquoise() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Violet

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Violet As Color
[C#]
public static Color Violet {get;}
[C++]
public: __property static Color get_Violet();
[JScript]
public static function get Violet() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Wheat

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Wheat As Color
[C#]
public static Color Wheat {get;}
[C++]
public: __property static Color get_Wheat();
[JScript]
public static function get Wheat() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.White

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property White As Color
[C#]
public static Color White {get;}
[C++]
public: __property static Color get_White();
[JScript]
public static function get White() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.WhiteSmoke

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property WhiteSmoke As Color
[C#]
public static Color WhiteSmoke {get;}
[C++]
public: __property static Color get_WhiteSmoke();
[JScript]
public static function get WhiteSmoke() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.Yellow

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Yellow As Color
[C#]
public static Color Yellow {get;}
[C++]
public: __property static Color get_Yellow();
[JScript]
public static function get Yellow() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.YellowGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property YellowGreen As Color
[C#]
public static Color YellowGreen {get;}
[C++]
public: __property static Color get_YellowGreen();
[JScript]
public static function get YellowGreen() : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Color Methods

The methods of the Color structure are listed below. For a complete list of Color structure members, see the Color Members topic.

Public:

Equals | [To be supplied.]
FromARGB | Overloaded. [To be supplied.]
FromKnownColor | Creates a color object from the specified KnownColor.
FromName | Creates a color object with the specified name.
FromSRGB64 | Creates a color object from the specified sRGB64 value. The resulting color object will have 64 bit precision.
FromString | [To be supplied.]
GetBrightness | The HSB brightness for this color.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetHue | The HSB Hue value for this color, in degrees.
GetSaturation | The HSB saturation for this color.
GetType (inherited from Object) | Gets the Type of the Object.
ToARGB | Returns the ARGB value of this color.
ToKnownColor | Returns the KnownColor value for this color, if it is based on a KnownColor.
ToSRGB64 | Returns the sRGB64 value of this color.
ToString | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Color Structure | System.Drawing Namespace


Color.Equals

[To be supplied.]

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
[To be supplied.]

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.FromARGB

[To be supplied.]

Overload List

Creates a color object from the specified ARGB values. The resulting color object will have 32 bit precision.

[Visual Basic] Overloads Public Shared Function FromARGB(Integer, Integer, Integer, Integer) As Color
[C#] public static Color FromARGB(int, int, int, int);
[C++] public: static Color FromARGB(int, int, int, int);
[JScript] public static function FromARGB(int, int, int, int) : Color;

Creates a new Color object based upon baseColor, with the alpha changed to alpha

[Visual Basic] Overloads Public Shared Function FromARGB(Integer, Color) As Color
[C#] public static Color FromARGB(int, Color);
[C++] public: static Color FromARGB(int, Color);
[JScript] public static function FromARGB(int, Color) : Color;

Creates a color object from the ARGB (32 bit) value;

[Visual Basic] Overloads Public Shared Function FromARGB(Integer) As Color
[C#] public static Color FromARGB(int);
[C++] public: static Color FromARGB(int);
[JScript] public static function FromARGB(int) : Color;

Creates a color object from the specified RGB values. The resulting color object will have 32 bit precision.

[Visual Basic] Overloads Public Shared Function FromARGB(Integer, Integer, Integer) As Color
[C#] public static Color FromARGB(int, int, int);
[C++] public: static Color FromARGB(int, int, int);
[JScript] public static function FromARGB(int, int, int) : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.FromARGB (Int32, Int32, Int32, Int32)

Creates a color object from the specified ARGB values. The resulting color object will have 32 bit precision.

[Visual Basic]
Overloads Public Shared Function FromARGB( _
   ByVal alpha As Integer, _
   ByVal red As Integer, _
   ByVal green As Integer, _
   ByVal blue As Integer _
) As Color
[C#]
public static Color FromARGB(
   int alpha,
   int red,
   int green,
   int blue
);
[C++]
public: static Color FromARGB(
   int alpha,
   int red,
   int green,
   int blue
);
[JScript]
public static function FromARGB(
   alpha : int,
   red : int,
   green : int,
   blue : int
) : Color;

Parameters

alpha
[To be supplied.]
red
[To be supplied.]
green
[To be supplied.]
blue
[To be supplied.]

See Also

Color Structure | Color Members | System.Drawing Namespace | Color.FromARGB Overload List


Color.FromARGB (Int32, Color)

Creates a new Color object based upon baseColor, with the alpha changed to alpha

[Visual Basic]
Overloads Public Shared Function FromARGB( _
   ByVal alpha As Integer, _
   ByVal baseColor As Color _
) As Color
[C#]
public static Color FromARGB(
   int alpha,
   Color baseColor
);
[C++]
public: static Color FromARGB(
   int alpha,
   Color baseColor
);
[JScript]
public static function FromARGB(
   alpha : int,
   baseColor : Color
) : Color;

Parameters

alpha
[To be supplied.]
baseColor
[To be supplied.]

See Also

Color Structure | Color Members | System.Drawing Namespace | Color.FromARGB Overload List


Color.FromARGB (Int32)

Creates a color object from the ARGB (32 bit) value;

[Visual Basic]
Overloads Public Shared Function FromARGB( _
   ByVal argb As Integer _
) As Color
[C#]
public static Color FromARGB(
   int argb
);
[C++]
public: static Color FromARGB(
   int argb
);
[JScript]
public static function FromARGB(
   argb : int
) : Color;

Parameters

argb
[To be supplied.]

See Also

Color Structure | Color Members | System.Drawing Namespace | Color.FromARGB Overload List


Color.FromARGB (Int32, Int32, Int32)

Creates a color object from the specified RGB values. The resulting color object will have 32 bit precision.

[Visual Basic]
Overloads Public Shared Function FromARGB( _
   ByVal red As Integer, _
   ByVal green As Integer, _
   ByVal blue As Integer _
) As Color
[C#]
public static Color FromARGB(
   int red,
   int green,
   int blue
);
[C++]
public: static Color FromARGB(
   int red,
   int green,
   int blue
);
[JScript]
public static function FromARGB(
   red : int,
   green : int,
   blue : int
) : Color;

Parameters

red
[To be supplied.]
green
[To be supplied.]
blue
[To be supplied.]

See Also

Color Structure | Color Members | System.Drawing Namespace | Color.FromARGB Overload List


Color.FromKnownColor

Creates a color object from the specified KnownColor.

[Visual Basic]
Public Shared Function FromKnownColor( _
   ByVal color As KnownColor _
) As Color
[C#]
public static Color FromKnownColor(
   KnownColor color
);
[C++]
public: static Color FromKnownColor(
   KnownColor color
);
[JScript]
public static function FromKnownColor(
   color : KnownColor
) : Color;

Parameters

color
[To be supplied.]

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.FromName

Creates a color object with the specified name.

[Visual Basic]
Public Shared Function FromName( _
   ByVal name As String _
) As Color
[C#]
public static Color FromName(
   string name
);
[C++]
public: static Color FromName(
   String* name
);
[JScript]
public static function FromName(
   name : String
) : Color;

Parameters

name
[To be supplied.]

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.FromSRGB64

Creates a color object from the specified sRGB64 value. The resulting color object will have 64 bit precision.

[Visual Basic]
Public Shared Function FromSRGB64( _
   ByVal sRGB64 As Long _
) As Color
[C#]
public static Color FromSRGB64(
   long sRGB64
);
[C++]
public: static Color FromSRGB64(
   __int64 sRGB64
);
[JScript]
public static function FromSRGB64(
   sRGB64 : long
) : Color;

Parameters

sRGB64
[To be supplied.]

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.FromString

[To be supplied.]

[Visual Basic]
Public Shared Function FromString( _
   ByVal colorString As String _
) As Color
[C#]
public static Color FromString(
   string colorString
);
[C++]
public: static Color FromString(
   String* colorString
);
[JScript]
public static function FromString(
   colorString : String
) : Color;

Parameters

colorString
[To be supplied.]

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.GetBrightness

The HSB brightness for this color.

[Visual Basic]
Public Function GetBrightness() As Single
[C#]
public float GetBrightness();
[C++]
public: float GetBrightness();
[JScript]
public function GetBrightness() : float;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.GetHue

The HSB Hue value for this color, in degrees.

[Visual Basic]
Public Function GetHue() As Single
[C#]
public float GetHue();
[C++]
public: float GetHue();
[JScript]
public function GetHue() : float;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.GetSaturation

The HSB saturation for this color.

[Visual Basic]
Public Function GetSaturation() As Single
[C#]
public float GetSaturation();
[C++]
public: float GetSaturation();
[JScript]
public function GetSaturation() : float;

Return Value

the saturation, where 0 is grey and 1 is the most saturated.

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.ToARGB

Returns the ARGB value of this color.

[Visual Basic]
Public Function ToARGB() As Integer
[C#]
public int ToARGB();
[C++]
public: int ToARGB();
[JScript]
public function ToARGB() : int;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.ToKnownColor

Returns the KnownColor value for this color, if it is based on a KnownColor.

[Visual Basic]
Public Function ToKnownColor() As KnownColor
[C#]
public KnownColor ToKnownColor();
[C++]
public: KnownColor ToKnownColor();
[JScript]
public function ToKnownColor() : KnownColor;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.ToSRGB64

Returns the sRGB64 value of this color.

[Visual Basic]
Public Function ToSRGB64() As Long
[C#]
public long ToSRGB64();
[C++]
public: __int64 ToSRGB64();
[JScript]
public function ToSRGB64() : long;

See Also

Color Structure | Color Members | System.Drawing Namespace


Color.ToString

[To be supplied.]

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

Color Structure | Color Members | System.Drawing Namespace


Operators

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Color Operators

The operators of the Color structure are listed below. For a complete list of Color structure members, see the Color Members topic.

Public:

Equality Operator | [To be supplied.]
Inequality Operator | [To be supplied.]

See Also

Color Structure | System.Drawing Namespace


Color Equality Operator

[To be supplied.]

[C#]
public static bool operator ==(
   Color left,
   Color right
);
[C++]
public: static bool operator op_Equality(
   Color left,
   Color right
);
[JScript]
returnValue = left == right;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

left
[To be supplied.]
right
[To be supplied.]

Parameters [C#, C++]

left
[To be supplied.]
right
[To be supplied.]

See Also

Color Structure | Color Members | System.Drawing Namespace


Color Inequality Operator

[To be supplied.]

[C#]
public static bool operator !=(
   Color left,
   Color right
);
[C++]
public: static bool operator op_Inequality(
   Color left,
   Color right
);
[JScript]
returnValue = left ! = right;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

left
[To be supplied.]
right
[To be supplied.]

Parameters [C#, C++]

left
[To be supplied.]
right
[To be supplied.]

See Also

Color Structure | Color Members | System.Drawing Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Color Fields

The fields of the Color structure are listed below. For a complete list of Color structure members, see the Color Members topic.

Public:

Empty [To be supplied.]

See Also

Color Structure | System.Drawing Namespace


Color.Empty

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Empty As Color
[C#]
public static readonly Color Empty;
[C++]
public: static readonly Color Empty;
[JScript]
public static var Empty : Color;

See Also

Color Structure | Color Members | System.Drawing Namespace


ColorConverter Class

ColorConverter is a class that can be used to convert colors from one data type to another. Access this class through the TypeDescriptor.

Object
TypeConverter
ColorConverter

[Visual Basic]
Public Class ColorConverter
   Inherits TypeConverter
[C#]
public class ColorConverter : TypeConverter
[C++]
public __gc class ColorConverter : public TypeConverter
[JScript]
public class ColorConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

ColorConverter Members | System.Drawing Namespace


ColorConverter Members

Public:

Constructor

ColorConverter Constructor [To be supplied.]

Methods

CanConvertFrom | Overloaded. [To be supplied.]
CanConvertTo (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the converter's native type.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text into an object.
ConvertTo | Overloaded. [To be supplied.]
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo | Overloaded. [To be supplied.]
GetProperties (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValues (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid (inherited from TypeConverter) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

ColorConverter Class | System.Drawing Namespace


ColorConverter Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ColorConverter();
[C++]
public: ColorConverter();
[JScript]
public function ColorConverter();

See Also

ColorConverter Class | ColorConverter Members | System.Drawing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ColorConverter Methods

The methods of the ColorConverter class are listed below. For a complete list of ColorConverter class members, see the ColorConverter Members topic.

Public:

CanConvertFrom | Overloaded. [To be supplied.]
CanConvertTo (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the converter's native type.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text into an object.
ConvertTo | Overloaded. [To be supplied.]
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo | Overloaded. [To be supplied.]
GetProperties (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValues (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid (inherited from TypeConverter) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

ColorConverter Class | System.Drawing Namespace


ColorConverter.CanConvertFrom

Determines if this converter can convert an object in the given source type to the native type of the converter.

[Visual Basic]
Overrides Public Function CanConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal sourceType As Type _
) As Boolean
[C#]
public override bool CanConvertFrom(
   ITypeDescriptorContext context,
   Type sourceType
);
[C++]
public: override bool CanConvertFrom(
   ITypeDescriptorContext* context,
   Type* sourceType
);
[JScript]
public override function CanConvertFrom(
   context : ITypeDescriptorContext,
   sourceType : Type
) : Boolean;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
sourceType
The type you wish to convert from.

Return Value

True if this object can perform the conversion.

See Also

ColorConverter Class | ColorConverter Members | System.Drawing Namespace


ColorConverter.ConvertFrom

Converts the given object to the converter's native type.

[Visual Basic]
Overrides Public Function ConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal arguments() As Object _
) As Object
[C#]
public override object ConvertFrom(
   ITypeDescriptorContext context,
   object value,
   object[] arguments
);
[C++]
public: override Object* ConvertFrom(
   ITypeDescriptorContext* context,
   Object* value,
   Object* arguments[]
);
[JScript]
public override function ConvertFrom(
   context : ITypeDescriptorContext,
   value : Object,
   arguments : Object[]
) : Object;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
value
The object to convert.
arguments
An optional array of arguments to use when doing the conversion. The number and content of these arguments is dependent on the implementer of the value formatter.

Return Value

The converted object. This will throw an excetpion if the converson could not be performed.

See Also

ColorConverter Class | ColorConverter Members | System.Drawing Namespace


ColorConverter.ConvertTo

Converts the given object to another type. The most common types to convert are to and from a string object. The default implementation will make a call to ToString on the object if the object is valid and if the destination type is string. If this cannot convert to the desitnation type, this will throw a NotSupportedException.

[Visual Basic]
Overrides Public Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal destinationType As Type, _
   ByVal arguments() As Object _
) As Object
[C#]
public override object ConvertTo(
   ITypeDescriptorContext context,
   object value,
   Type destinationType,
   object[] arguments
);
[C++]
public: override Object* ConvertTo(
   ITypeDescriptorContext* context,
   Object* value,
   Type* destinationType,
   Object* arguments[]
);
[JScript]
public override function ConvertTo(
   context : ITypeDescriptorContext,
   value : Object,
   destinationType : Type,
   arguments : Object[]
) : Object;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
value
The object to convert.
destinationType
The type to convert the object to.
arguments
An optional array of arguments to use when doing the conversion. The number and content of these arguments is dependent on the implementer of the value formatter.

Return Value

The converted object.

See Also

ColorConverter Class | ColorConverter Members | System.Drawing Namespace


ColorConverter.CreateInstance

Recreates an object given its PersistInfo. This information was generated by a prior call to GetPersistInfo.

[Visual Basic]
Overrides Public Function CreateInstance( _
   ByVal context As ITypeDescriptorContext, _
   ByVal persistInfo As PersistInfo _
) As Object
[C#]
public override object CreateInstance(
   ITypeDescriptorContext context,
   PersistInfo persistInfo
);
[C++]
public: override Object* CreateInstance(
   ITypeDescriptorContext* context,
   PersistInfo* persistInfo
);
[JScript]
public override function CreateInstance(
   context : ITypeDescriptorContext,
   persistInfo : PersistInfo
) : Object;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
persistInfo
The persistence information to use when re-creating the object.

Return Value

An object representing the given PersistInfo.

See Also

ColorConverter Class | ColorConverter Members | System.Drawing Namespace | PersistInfo | TBD


ColorConverter.GetPersistInfo

Retrieves the PersistInfo object for the given value. This object describes the given value as persisted information, which can be saved to disk or moved. This information can later be reconstructed by passing the PersistInfo to GetValue.

[Visual Basic]
Overrides Public Function GetPersistInfo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As PersistInfo
[C#]
public override PersistInfo GetPersistInfo(
   ITypeDescriptorContext context,
   object value
);
[C++]
public: override PersistInfo* GetPersistInfo(
   ITypeDescriptorContext* context,
   Object* value
);
[JScript]
public override function GetPersistInfo(
   context : ITypeDescriptorContext,
   value : Object
) : PersistInfo;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
value
The object to persist.

Return Value

The PersistInfo representing the persisted state of the given object.

See Also

ColorConverter Class | ColorConverter Members | System.Drawing Namespace | PersistInfo | TBD


ColorConverter.GetStandardValues

Retrieves a collection containing a set of standard values for the data type this validator is designed for. This will return null if the data type does not support a standard set of values.

[Visual Basic]
Overrides Public Function GetStandardValues( _
   ByVal context As ITypeDescriptorContext _
) As StandardValuesCollection
[C#]
public override StandardValuesCollection GetStandardValues(
   ITypeDescriptorContext context
);
[C++]
public: override StandardValuesCollection* GetStandardValues(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetStandardValues(
   context : ITypeDescriptorContext
) : StandardValuesCollection;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.

Return Value

A collection containing a standard set of valid values, or null. The default implementation always returns null.

See Also

ColorConverter Class | ColorConverter Members | System.Drawing Namespace


ColorConverter.GetStandardValuesSupported

Determines if this object supports a standard set of values that can be picked from a list.

[Visual Basic]
Overrides Public Function GetStandardValuesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
[C#]
public override bool GetStandardValuesSupported(
   ITypeDescriptorContext context
);
[C++]
public: override bool GetStandardValuesSupported(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetStandardValuesSupported(
   context : ITypeDescriptorContext
) : Boolean;

Parameters

context
A type descriptor through which additional context may be provided.

Return Value

Returns true if GetStandardValues should be called to find a common set of values the object supports.

See Also

ColorConverter Class | ColorConverter Members | System.Drawing Namespace


ColorTranslator Class

[To be supplied.]

Object
ColorTranslator

[Visual Basic]
NotInheritable Public Class ColorTranslator
[C#]
public sealed class ColorTranslator
[C++]
public __gc __sealed class ColorTranslator
[JScript]
public class ColorTranslator

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

ColorTranslator Members | System.Drawing Namespace


ColorTranslator Members

Public:

Constructor

ColorTranslator Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FromHTML | [To be supplied.]
FromOLE | [To be supplied.]
FromWin32 | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToHTML | [To be supplied.]
ToOLE | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.
ToWin32 | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ColorTranslator Class | System.Drawing Namespace


ColorTranslator Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ColorTranslator();
[C++]
public: ColorTranslator();
[JScript]
public function ColorTranslator();

See Also

ColorTranslator Class | ColorTranslator Members | System.Drawing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ColorTranslator Methods

The methods of the ColorTranslator class are listed below. For a complete list of ColorTranslator class members, see the ColorTranslator Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FromHTML | [To be supplied.]
FromOLE | [To be supplied.]
FromWin32 | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToHTML | [To be supplied.]
ToOLE | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.
ToWin32 | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ColorTranslator Class | System.Drawing Namespace


ColorTranslator.FromHTML

[To be supplied.]

[Visual Basic]
Public Shared Function FromHTML( _
   ByVal htmlColor As String _
) As Color
[C#]
public static Color FromHTML(
   string htmlColor
);
[C++]
public: static Color FromHTML(
   String* htmlColor
);
[JScript]
public static function FromHTML(
   htmlColor : String
) : Color;

Parameters

htmlColor
[To be supplied.]

See Also

ColorTranslator Class | ColorTranslator Members | System.Drawing Namespace


ColorTranslator.FromOLE

[To be supplied.]

[Visual Basic]
Public Shared Function FromOLE( _
   ByVal oleColor As Integer _
) As Color
[C#]
public static Color FromOLE(
   int oleColor
);
[C++]
public: static Color FromOLE(
   int oleColor
);
[JScript]
public static function FromOLE(
   oleColor : int
) : Color;

Parameters

oleColor
[To be supplied.]

See Also

ColorTranslator Class | ColorTranslator Members | System.Drawing Namespace


ColorTranslator.FromWin32

[To be supplied.]

[Visual Basic]
Public Shared Function FromWin32( _
   ByVal win32Color As Integer _
) As Color
[C#]
public static Color FromWin32(
   int win32Color
);
[C++]
public: static Color FromWin32(
   int win32Color
);
[JScript]
public static function FromWin32(
   win32Color : int
) : Color;

Parameters

win32Color
[To be supplied.]

See Also

ColorTranslator Class | ColorTranslator Members | System.Drawing Namespace


ColorTranslator.ToHTML

[To be supplied.]

[Visual Basic]
Public Shared Function ToHTML( _
   ByVal c As Color _
) As String
[C#]
public static string ToHTML(
   Color c
);
[C++]
public: static String* ToHTML(
   Color c
);
[JScript]
public static function ToHTML(
   c : Color
) : String;

Parameters

c
[To be supplied.]

See Also

ColorTranslator Class | ColorTranslator Members | System.Drawing Namespace


ColorTranslator.ToOLE

[To be supplied.]

[Visual Basic]
Public Shared Function ToOLE( _
   ByVal c As Color _
) As Integer
[C#]
public static int ToOLE(
   Color c
);
[C++]
public: static int ToOLE(
   Color c
);
[JScript]
public static function ToOLE(
   c : Color
) : int;

Parameters

c
[To be supplied.]

See Also

ColorTranslator Class | ColorTranslator Members | System.Drawing Namespace


ColorTranslator.ToWin32

[To be supplied.]

[Visual Basic]
Public Shared Function ToWin32( _
   ByVal c As Color _
) As Integer
[C#]
public static int ToWin32(
   Color c
);
[C++]
public: static int ToWin32(
   Color c
);
[JScript]
public static function ToWin32(
   c : Color
) : int;

Parameters

c
[To be supplied.]

See Also

ColorTranslator Class | ColorTranslator Members | System.Drawing Namespace


ContentAlignment Enumeration

Content alignment.

[Visual Basic]
Public Enum ContentAlignment
[C#]
public enum ContentAlignment
[C++]
public enum ContentAlignment

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Bottom | [To be supplied.]
BottomCenter | [To be supplied.]
BottomLeft | [To be supplied.]
BottomRight | [To be supplied.]
Center | [To be supplied.]
Left | [To be supplied.]
Middle | [To be supplied.]
MiddleCenter | [To be supplied.]
MiddleLeft | [To be supplied.]
MiddleRight | [To be supplied.]
Right | [To be supplied.]
Top | [To be supplied.]
TopCenter | [To be supplied.]
TopLeft | [To be supplied.]
TopRight | [To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

System.Drawing Namespace


Cursor Class

A cursor object is used to paint the mouse pointer. Different cursor shapes are used as visual queues to inform the user what operation the mouse will have.

Object
Cursor

[Visual Basic]
Public Class Cursor
[C#]
public class Cursor
[C++]
public __gc class Cursor
[JScript]
public class Cursor

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

Cursor Members | System.Drawing Namespace


Cursor Members

Public:

Constructor

Cursor Constructor Overloaded. [To be supplied.]

Properties

Clip | The current cursor clipping rectangle in screen coordinates. A clipped cursor will only be allowed to move within it's rectangle. Generally, the OS only allows this if the mouse is currently captured. If the cursor is not currently clipped, the resulting rectangle contains the dimensions of the entire screen.
Current | The current mouse cursor, or null if the cursor is not visible.
Handle | The Win32 handle for this object. This is not a copy of the handle; do not free it.
Position | The current cursor position in screen coordinates. When setting this property, if the new coordinates are not within the screen rectangle set by the most recent setClip() call, Windows automatically adjusts the coordinates so that the cursor stays within the rectangle.
Size | The size of this cursor object.

Methods

Clone | Clones the cursor object, creating a duplicate image.
CopyHandle | Duplicates this cursor's Win32 handle. You are responsible for freeing the returned handle when you are done with it.
Dispose | Cleans up the resources allocated by this object. Once called, the cursor object is no longer useful.
Draw | Draws this image to a graphics object. The drawing command originates on the graphics object, but a graphics object generally has no idea how to render a given image. So, it passes the call to the actual image. This version crops the image to the given dimensions and allows the user to specify a rectangle within the image to draw.
DrawStretched | Draws this image to a graphics object. The drawing command originates on the graphics object, but a graphics object generally has no idea how to render a given image. So, it passes the call to the actual image. This version stretches the image to the given dimensions and allows the user to specify a rectangle within the image to draw.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Hide | Hides the cursor. For every call to Cursor.Hide() there must be a balancing call to Cursor.Show().
Show | Displays the cursor. For every call to Cursor.Show() there must have been a previous call to Cursor.Hide().
ToString | Retrieves a human readable string representing the cursor.

Protected:

Methods

DestroyHandle | Called when this object is going to destroy it's Win32 handle. You may override this if there is something special you need to do to destroy the handle. This will be called even if the handle is not owned by this object, which is handy if you want to create a derived class that has it's own create/destroy semantics. The default implementation will call the appropriate Win32 call to destroy the handle if this object currently owns the handle. It will do nothing if the object does not currently own the handle.
Finalize | Cleans up Windows resources for this object.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Cursor Class | System.Drawing Namespace


Cursor Constructor

[To be supplied.]

Overload List

Creates a cursor object given a handle. The cursor object does not claim ownership of the handle; you must free it when you are done.

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public Cursor(int);
[C++] public: Cursor(int);
[JScript] public function Cursor(int);

Creates a cursor given a file. The file must be a standard disk based cursor (.cur) file.

[Visual Basic] Overloads Public Sub New(String)
[C#] public Cursor(String);
[C++] public: Cursor(String*);
[JScript] public function Cursor(String);

Creates a cursor object given a resource name and location.

[Visual Basic] Overloads Public Sub New(Type, String)
[C#] public Cursor(Type, String);
[C++] public: Cursor(Type*, String);
[JScript] public function Cursor(Type, String);

Creates a cursor object given a data stream. The stream must contain a cursor file.

[Visual Basic] Overloads Public Sub New(Stream)
[C#] public Cursor(Stream);
[C++] public: Cursor(Stream*);
[JScript] public function Cursor(Stream);

Creates a cursor object given a COM stream. The stream must contain a cursor file.

[Visual Basic] Overloads Public Sub New(IStream)
[C#] public Cursor(IStream);
[C++] public: Cursor(IStream*);
[JScript] public function Cursor(IStream);

Creates a cursor object given an OLE IPicture object.

[Visual Basic] Overloads Public Sub New(IPicture)
[C#] public Cursor(IPicture);
[C++] public: Cursor(IPicture*);
[JScript] public function Cursor(IPicture);

See Also

Cursor Class | Cursor Members | System.Drawing Namespace


Cursor Constructor (Int32)

Creates a cursor object given a handle. The cursor object does not claim ownership of the handle; you must free it when you are done.

[Visual Basic]
Overloads Public Sub New( _
   ByVal handle As Integer _
)
[C#]
public Cursor(
   int handle
);
[C++]
public: Cursor(
   int handle
);
[JScript]
public function Cursor(
   handle : int
);

Parameters

handle
The Win32 cursor handle to wrap.

See Also

Cursor Class | Cursor Members | System.Drawing Namespace | Cursor Constructor Overload List


Cursor Constructor (String)

Creates a cursor given a file. The file must be a standard disk based cursor (.cur) file.

[Visual Basic]
Overloads Public Sub New( _
   ByVal fileName As String _
)
[C#]
public Cursor(
   string fileName
);
[C++]
public: Cursor(
   String* fileName
);
[JScript]
public function Cursor(
   fileName : String
);

Parameters

fileName
The cursor file to load.

See Also

Cursor Class | Cursor Members | System.Drawing Namespace | Cursor Constructor Overload List


Cursor Constructor (Type, String)

Creates a cursor object given a resource name and location.

[Visual Basic]
Overloads Public Sub New( _
   ByVal type As Type, _
   ByVal resource As String _
)
[C#]
public Cursor(
   Type type,
   string resource
);
[C++]
public: Cursor(
   Type* type,
   String* resource
);
[JScript]
public function Cursor(
   type : Type,
   resource : String
);

Parameters

type
The class that we will use to locate the resource.
resource
The resource name.

See Also

Cursor Class | Cursor Members | System.Drawing Namespace | Cursor Constructor Overload List


Cursor Constructor (Stream)

Creates a cursor object given a data stream. The stream must contain a cursor file.

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream _
)
[C#]
public Cursor(
   Stream stream
);
[C++]
public: Cursor(
   Stream* stream
);
[JScript]
public function Cursor(
   stream : Stream
);

Parameters

stream
The data stream to load.

See Also

Cursor Class | Cursor Members | System.Drawing Namespace | Cursor Constructor Overload List


Cursor Constructor (IStream)

Creates a cursor object given a COM stream. The stream must contain a cursor file.

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As IStream _
)
[C#]
public Cursor(
   IStream stream
);
[C++]
public: Cursor(
   IStream* stream
);
[JScript]
public function Cursor(
   stream : IStream
);

Parameters

stream
The COM stream to load.

See Also

Cursor Class | Cursor Members | System.Drawing Namespace | Cursor Constructor Overload List


Cursor Constructor (IPicture)

Creates a cursor object given an OLE IPicture object.

[Visual Basic]
Overloads Public Sub New( _
   ByVal picture As IPicture _
)
[C#]
public Cursor(
   IPicture picture
);
[C++]
public: Cursor(
   IPicture* picture
);
[JScript]
public function Cursor(
   picture : IPicture
);

Parameters

picture
The IPicture object to load the cursor from.

See Also

Cursor Class | Cursor Members | System.Drawing Namespace | Cursor Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Cursor Properties

The properties of the Cursor class are listed below. For a complete list of Cursor class members, see the Cursor Members topic.

Public:

Clip | The current cursor clipping rectangle in screen coordinates. A clipped cursor will only be allowed to move within it's rectangle. Generally, the OS only allows this if the mouse is currently captured. If the cursor is not currently clipped, the resulting rectangle contains the dimensions of the entire screen.
Current | The current mouse cursor, or null if the cursor is not visible.
Handle | The Win32 handle for this object. This is not a copy of the handle; do not free it.
Position | The current cursor position in screen coordinates. When setting this property, if the new coordinates are not within the screen rectangle set by the most recent setClip() call, Windows automatically adjusts the coordinates so that the cursor stays within the rectangle.
Size | The size of this cursor object.

See Also

Cursor Class | System.Drawing Namespace


Cursor.Clip

The current cursor clipping rectangle in screen coordinates. A clipped cursor will only be allowed to move within it's rectangle. Generally, the OS only allows this if the mouse is currently captured. If the cursor is not currently clipped, the resulting rectangle contains the dimensions of the entire screen.

[Visual Basic]
Public Shared Property Clip As Rectangle
[C#]
public static Rectangle Clip {get; set;}
[C++]
public: __property static Rectangle get_Clip();
public: __property static void set_Clip(Rectangle);
[JScript]
public static function get Clip() : Rectangle;
public static function set Clip(Rectangle);

See Also

Cursor Class | Cursor Members | System.Drawing Namespace


Cursor.Current

The current mouse cursor, or null if the cursor is not visible.

[Visual Basic]
Public Shared Property Current As Cursor
[C#]
public static Cursor Current {get; set;}
[C++]
public: __property static Cursor* get_Current();
public: __property static void set_Current(Cursor*);
[JScript]
public static function get Current() : Cursor;
public static function set Current(Cursor);

See Also

Cursor Class | Cursor Members | System.Drawing Namespace


Cursor.Handle

The Win32 handle for this object. This is not a copy of the handle; do not free it.

[Visual Basic]
Public ReadOnly Property Handle As Integer
[C#]
public int Handle {get;}
[C++]
public: __property int get_Handle();
[JScript]
public function get Handle() : int;

See Also

Cursor Class | Cursor Members | System.Drawing Namespace


Cursor.Position

The current cursor position in screen coordinates. When setting this property, if the new coordinates are not within the screen rectangle set by the most recent setClip() call, Windows automatically adjusts the coordinates so that the cursor stays within the rectangle.

[Visual Basic]
Public Shared Property Position As Point
[C#]
public static Point Position {get; set;}
[C++]
public: __property static Point get_Position();
public: __property static void set_Position(Point);
[JScript]
public static function get Position() : Point;
public static function set Position(Point);

See Also

Cursor Class | Cursor Members | System.Drawing Namespace


Cursor.Size

The size of this cursor object.

[Visual Basic]
Public ReadOnly Property Size As Size
[C#]
public Size Size {get;}
[C++]
public: __property Size get_Size();
[JScript]
public function get Size() : Size;

See Also

Cursor Class | Cursor Members | System.Drawing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Cursor Methods

The methods of the Cursor class are listed below. For a complete list of Cursor class members, see the Cursor Members topic.

Public:

Clone | Clones the cursor object, creating a duplicate image.
CopyHandle | Duplicates this cursor's Win32 handle. You are responsible for freeing the returned handle when you are done with it.
Dispose | Cleans up the resources allocated by this object. Once called, the cursor object is no longer useful.
Draw | Draws this image to a graphics object. The drawing command originates on the graphics object, but a graphics object generally has no idea how to render a given image. So, it passes the call to the actual image. This version crops the image to the given dimensions and allows the user to specify a rectangle within the image to draw.
DrawStretched | Draws this image to a graphics object. The drawing command originates on the graphics object, but a graphics object generally has no idea how to render a given image. So, it passes the call to the actual image. This version stretches the image to the given dimensions and allows the user to specify a rectangle within the image to draw.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Hide | Hides the cursor. For every call to Cursor.Hide() there must be a balancing call to Cursor.Show().
Show | Displays the cursor. For every call to Cursor.Show() there must have been a previous call to Cursor.Hide().
ToString | Retrieves a human readable string representing the cursor.

Protected:

DestroyHandle | Called when this object is going to destroy it's Win32 handle. You may override this if there is something special you need to do to destroy the handle. This will be called even if the handle is not owned by this object, which is handy if you want to create a derived class that has it's own create/destroy semantics. The default implementation will call the appropriate Win32 call to destroy the handle if this object currently owns the handle. It will do nothing if the object does not currently own the handle.
Finalize | Cleans up Windows resources for this object.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Cursor Class | System.Drawing Namespace


Cursor.Clone

Clones the cursor object, creating a duplicate image.

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

Return Value

an object that can be casted to an Cursor.

See Also

Cursor Class | Cursor Members | System.Drawing Namespace


Cursor.CopyHandle

Duplicates this cursor's Win32 handle. You are responsible for freeing the returned handle when you are done with it.

[Visual Basic]
Public Function CopyHandle() As Integer
[C#]
public int CopyHandle();
[C++]
public: int CopyHandle();
[JScript]
public function CopyHandle() : int;

Return Value

a Win32 cursor handle.

See Also

Cursor Class | Cursor Members | System.Drawing Namespace


Cursor.DestroyHandle

Called when this object is going to destroy it's Win32 handle. You may override this if there is something special you need to do to destroy the handle. This will be called even if the handle is not owned by this object, which is handy if you want to create a derived class that has it's own create/destroy semantics. The default implementation will call the appropriate Win32 call to destroy the handle if this object currently owns the handle. It will do nothing if the object does not currently own the handle.

[Visual Basic]
Overridable Protected Sub DestroyHandle()
[C#]
protected virtual void DestroyHandle();
[C++]
protected: virtual void DestroyHandle();
[JScript]
protected function DestroyHandle();

See Also

Cursor Class | Cursor Members | System.Drawing Namespace


Cursor.Dispose

Cleans up the resources allocated by this object. Once called, the cursor object is no longer useful.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[JScript]
public function Dispose();

See Also

Cursor Class | Cursor Members | System.Drawing Namespace


Cursor.Draw

Draws this image to a graphics object. The drawing command originates on the graphics object, but a graphics object generally has no idea how to render a given image. So, it passes the call to the actual image. This version crops the image to the given dimensions and allows the user to specify a rectangle within the image to draw.

[Visual Basic]
Public Sub Draw( _
   ByVal g As Graphics, _
   ByVal targetRect As Rectangle _
)
[C#]
public void Draw(
   Graphics g,
   Rectangle targetRect
);
[C++]
public: void Draw(
   Graphics* g,
   Rectangle targetRect
);
[JScript]
public function Draw(
   g : Graphics,
   targetRect : Rectangle
);

Parameters

g
The graphics object to render to.
targetRect
The rectangle to crop to.

See Also

Cursor Class | Cursor Members | System.Drawing Namespace


Cursor.DrawStretched

Draws this image to a graphics object. The drawing command originates on the graphics object, but a graphics object generally has no idea how to render a given image. So, it passes the call to the actual image. This version stretches the image to the given dimensions and allows the user to specify a rectangle within the image to draw.

[Visual Basic]
Public Sub DrawStretched( _
   ByVal g As Graphics, _
   ByVal targetRect As Rectangle _
)
[C#]
public void DrawStretched(
   Graphics g,
   Rectangle targetRect
);
[C++]
public: void DrawStretched(
   Graphics* g,
   Rectangle targetRect
);
[JScript]
public function DrawStretched(
   g : Graphics,
   targetRect : Rectangle
);

Parameters

g
The graphics object to render to.
targetRect
The rectangle to stretch the image to.

See Also

Cursor Class | Cursor Members | System.Drawing Namespace


Cursor.Finalize

Cleans up Windows resources for this object.

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

Cursor Class | Cursor Members | System.Drawing Namespace


Cursor.Hide

Hides the cursor. For every call to Cursor.Hide() there must be a balancing call to Cursor.Show().

[Visual Basic]
Public Shared Sub Hide()
[C#]
public static void Hide();
[C++]
public: static void Hide();
[JScript]
public static function Hide();

See Also

Cursor Class | Cursor Members | System.Drawing Namespace | Show


Cursor.Show

Displays the cursor. For every call to Cursor.Show() there must have been a previous call to Cursor.Hide().

[Visual Basic]
Public Shared Sub Show()
[C#]
public static void Show();
[C++]
public: static void Show();
[JScript]
public static function Show();

See Also

Cursor Class | Cursor Members | System.Drawing Namespace | Hide


Cursor.ToString

Retrieves a human readable string representing the cursor.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

a string describing the cursor.

See Also

Cursor Class | Cursor Members | System.Drawing Namespace


CursorConverter Class

CursorConverter is a class that can be used to convert colors from one data type to another. Access this class through the TypeDescriptor.

Object
TypeConverter
CursorConverter

[Visual Basic]
Public Class CursorConverter
   Inherits TypeConverter
[C#]
public class CursorConverter : TypeConverter
[C++]
public __gc class CursorConverter : public TypeConverter
[JScript]
public class CursorConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

CursorConverter Members | System.Drawing Namespace


CursorConverter Members

Public:

Constructor

CursorConverter Constructor [To be supplied.]

Methods

CanConvertFrom (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type.
ConvertFrom | Overloaded. [To be supplied.]
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text into an object.
ConvertTo | Overloaded. [To be supplied.]
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetProperties (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValues | Overloaded. [To be supplied.]
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid (inherited from TypeConverter) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

CursorConverter Class | System.Drawing Namespace


CursorConverter Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CursorConverter();
[C++]
public: CursorConverter();
[JScript]
public function CursorConverter();

See Also

CursorConverter Class | CursorConverter Members | System.Drawing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CursorConverter Methods

The methods of the CursorConverter class are listed below. For a complete list of CursorConverter class members, see the CursorConverter Members topic.

Public:

CanConvertFrom (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type.
ConvertFrom | Overloaded. [To be supplied.]
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text into an object.
ConvertTo | Overloaded. [To be supplied.]
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetProperties (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValues | Overloaded. [To be supplied.]
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid (inherited from TypeConverter) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

CursorConverter Class | System.Drawing Namespace


CursorConverter.CanConvertFrom

Determines if this converter can convert an object in the given source type to the native type of the converter.

[Visual Basic]
Overrides Public Function CanConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal sourceType As Type _
) As Boolean
[C#]
public override bool CanConvertFrom(
   ITypeDescriptorContext context,
   Type sourceType
);
[C++]
public: override bool CanConvertFrom(
   ITypeDescriptorContext* context,
   Type* sourceType
);
[JScript]
public override function CanConvertFrom(
   context : ITypeDescriptorContext,
   sourceType : Type
) : Boolean;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
sourceType
The type you wish to convert from.

Return Value

True if this object can perform the conversion.

See Also

CursorConverter Class | CursorConverter Members | System.Drawing Namespace


CursorConverter.ConvertFrom

Converts the given object to the converter's native type.

[Visual Basic]
Overrides Public Function ConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal arguments() As Object _
) As Object
[C#]
public override object ConvertFrom(
   ITypeDescriptorContext context,
   object value,
   object[] arguments
);
[C++]
public: override Object* ConvertFrom(
   ITypeDescriptorContext* context,
   Object* value,
   Object* arguments[]
);
[JScript]
public override function ConvertFrom(
   context : ITypeDescriptorContext,
   value : Object,
   arguments : Object[]
) : Object;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
value
The object to convert.
arguments
An optional array of arguments to use when doing the conversion. The number and content of these arguments is dependent on the implementer of the value formatter.

Return Value

The converted object. This will throw an excetpion if the converson could not be performed.

See Also

CursorConverter Class | CursorConverter Members | System.Drawing Namespace


CursorConverter.ConvertTo

Converts the given object to another type. The most common types to convert are to and from a string object. The default implementation will make a call to ToString on the object if the object is valid and if the destination type is string. If this cannot convert to the desitnation type, this will throw a NotSupportedException.

[Visual Basic]
Overrides Public Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal destinationType As Type, _
   ByVal arguments() As Object _
) As Object
[C#]
public override object ConvertTo(
   ITypeDescriptorContext context,
   object value,
   Type destinationType,
   object[] arguments
);
[C++]
public: override Object* ConvertTo(
   ITypeDescriptorContext* context,
   Object* value,
   Type* destinationType,
   Object* arguments[]
);
[JScript]
public override function ConvertTo(
   context : ITypeDescriptorContext,
   value : Object,
   destinationType : Type,
   arguments : Object[]
) : Object;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
value
The object to convert.
destinationType
The type to convert the object to.
arguments
An optional array of arguments to use when doing the conversion. The number and content of these arguments is dependent on the implementer of the value formatter.

Return Value

The converted object.

See Also

CursorConverter Class | CursorConverter Members | System.Drawing Namespace


CursorConverter.GetPersistInfo

Retrieves the PersistInfo object for the given value. This object describes the given value as persisted information, which can be saved to disk or moved. This information can later be reconstructed by passing the PersistInfo to GetValue.

[Visual Basic]
Overrides Public Function GetPersistInfo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As PersistInfo
[C#]
public override PersistInfo GetPersistInfo(
   ITypeDescriptorContext context,
   object value
);
[C++]
public: override PersistInfo* GetPersistInfo(
   ITypeDescriptorContext* context,
   Object* value
);
[JScript]
public override function GetPersistInfo(
   context : ITypeDescriptorContext,
   value : Object
) : PersistInfo;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
value
The object to persist.

Return Value

The PersistInfo representing the persisted state of the given object.

See Also

CursorConverter Class | CursorConverter Members | System.Drawing Namespace | PersistInfo | TBD


CursorConverter.GetStandardValues

Retrieves a collection containing a set of standard values for the data type this validator is designed for. This will return null if the data type does not support a standard set of values.

[Visual Basic]
Overrides Public Function GetStandardValues( _
   ByVal context As ITypeDescriptorContext _
) As StandardValuesCollection
[C#]
public override StandardValuesCollection GetStandardValues(
   ITypeDescriptorContext context
);
[C++]
public: override StandardValuesCollection* GetStandardValues(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetStandardValues(
   context : ITypeDescriptorContext
) : StandardValuesCollection;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.

Return Value

A collection containing a standard set of valid values, or null. The default implementation always returns null.

See Also

CursorConverter Class | CursorConverter Members | System.Drawing Namespace


CursorConverter.GetStandardValuesSupported

Determines if this object supports a standard set of values that can be picked from a list.

[Visual Basic]
Overrides Public Function GetStandardValuesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
[C#]
public override bool GetStandardValuesSupported(
   ITypeDescriptorContext context
);
[C++]
public: override bool GetStandardValuesSupported(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetStandardValuesSupported(
   context : ITypeDescriptorContext
) : Boolean;

Parameters

context
A type descriptor through which additional context may be provided.

Return Value

Returns true if GetStandardValues should be called to find a common set of values the object supports.

See Also

CursorConverter Class | CursorConverter Members | System.Drawing Namespace


Cursors Class

Standard cursors

Object
Cursors

[Visual Basic]
NotInheritable Public Class Cursors
[C#]
public sealed class Cursors
[C++]
public __gc __sealed class Cursors
[JScript]
public class Cursors

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

Cursors Members | System.Drawing Namespace | Cursor


Cursors Members

Public:

Properties

AppStarting | [To be supplied.]
Arrow | [To be supplied.]
Cross | [To be supplied.]
Default | [To be supplied.]
Hand | [To be supplied.]
Help | [To be supplied.]
HSplit | [To be supplied.]
IBeam | [To be supplied.]
No | [To be supplied.]
NoMove2D | [To be supplied.]
NoMoveHoriz | [To be supplied.]
NoMoveVert | [To be supplied.]
PanEast | [To be supplied.]
PanNE | [To be supplied.]
PanNorth | [To be supplied.]
PanNW | [To be supplied.]
PanSE | [To be supplied.]
PanSouth | [To be supplied.]
PanSW | [To be supplied.]
PanWest | [To be supplied.]
SizeAll | [To be supplied.]
SizeNESW | [To be supplied.]
SizeNS | [To be supplied.]
SizeNWSE | [To be supplied.]
SizeWE | [To be supplied.]
UpArrow | [To be supplied.]
VSplit | [To be supplied.]
WaitCursor | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Cursors Class | System.Drawing Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Cursors Properties

The properties of the Cursors class are listed below. For a complete list of Cursors class members, see the Cursors Members topic.

Public:

AppStarting | [To be supplied.]
Arrow | [To be supplied.]
Cross | [To be supplied.]
Default | [To be supplied.]
Hand | [To be supplied.]
Help | [To be supplied.]
HSplit | [To be supplied.]
IBeam | [To be supplied.]
No | [To be supplied.]
NoMove2D | [To be supplied.]
NoMoveHoriz | [To be supplied.]
NoMoveVert | [To be supplied.]
PanEast | [To be supplied.]
PanNE | [To be supplied.]
PanNorth | [To be supplied.]
PanNW | [To be supplied.]
PanSE | [To be supplied.]
PanSouth | [To be supplied.]
PanSW | [To be supplied.]
PanWest | [To be supplied.]
SizeAll | [To be supplied.]
SizeNESW | [To be supplied.]
SizeNS | [To be supplied.]
SizeNWSE | [To be supplied.]
SizeWE | [To be supplied.]
UpArrow | [To be supplied.]
VSplit | [To be supplied.]
WaitCursor | [To be supplied.]

See Also

Cursors Class | System.Drawing Namespace


Cursors.AppStarting

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property AppStarting As Cursor
[C#]
public static Cursor AppStarting {get;}
[C++]
public: __property static Cursor* get_AppStarting();
[JScript]
public static function get AppStarting() : Cursor;

See Also

Cursors Class | Cursors Members | System.Drawing Namespace


Cursors.Arrow

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Arrow As Cursor
[C#]
public static Cursor Arrow {get;}
[C++]
public: __property static Cursor* get_Arrow();
[JScript]
public static function get Arrow() : Cursor;

See Also

Cursors Class | Cursors Members | System.Drawing Namespace


Cursors.Cross

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Cross As Cursor
[C#]
public static Cursor Cross {get;}
[C++]
public: __property static Cursor* get_Cross();
[JScript]
public static function get Cross() : Cursor;

See Also

Cursors Class | Cursors Members | System.Drawing Namespace


Cursors.Default

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Default As Cursor
[C#]
public static Cursor Default {get;}
[C++]
public: __property static Cursor* get_Default();
[JScript]
public static function get Default() : Cursor;

See Also

Cursors Class | Cursors Members | System.Drawing Namespace


Cursors.Hand

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Hand As Cursor
[C#]
public static Cursor Hand {get;}
[C++]
public: __property static Cursor* get_Hand();
[JScript]
public static function get Hand() : Cursor;

See Also

Cursors Class | Cursors Members | System.Drawing Namespace


Cursors.Help

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Help As Cursor
[C#]
public static Cursor Help {get;}
[C++]
public: __property static Cursor* get_Help();
[JScript]
public static function get Help() : Cursor;

See Also

Cursors Class | Cursors Members | System.Drawing Namespace


Cursors.HSplit

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property HSplit As Cursor
[C#]
public static Cursor HSplit {get;}
[C++]
public: __property static Cursor* get_HSplit();
[JScript]
public static function get HSplit() : Cursor;

See Also

Cursors Class | Cursors Members | System.Drawing Namespace


Cursors.IBeam

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property IBeam As Cursor
[C#]
public static Cursor IBeam {get;}
[C++]
public: __property static Cursor* get_IBeam();
[JScript]
public static function get IBeam() : Cursor;

See Also

Cursors Class | Cursors Members | System.Drawing Namespace


Cursors.No

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property No As Cursor
[C#]
public static Cursor No {get;}
[C++]
public: __property static Cursor* get_No();
[JScript]
public static function get No() : Cursor;

See Also

Cursors Class | Cursors Members | System.Drawing Namespace


Cursors.NoMove2D

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property NoMove2D As Cursor
[C#]
public static Cursor NoMove2D {get;}
[C++]
public: __property static Cursor* get_NoMove2D();
[JScript]
public static function get NoMove2D() : Cursor;

See Also

Cursors Class | Cursors Members | System.Drawing Namespace


Cursors.NoMoveHoriz

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property NoMoveHoriz As Cursor
[C#]
public static Cursor NoMoveHoriz {get;}
[C++]
public: __property static Cursor* get_NoMoveHoriz();
[JScript]
public static function get NoMoveHoriz() : Cursor;

See Also

Cursors Class | Cursors Members | System.Drawing Namespace


Cursors.NoMoveVert

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property NoMoveVert As Cursor
[C#]
public static Cursor NoMoveVert {get;}
[C++]
public: __property static Cursor* get_NoMoveVert();
[JScript]
public static function get NoMoveVert() : Cursor;

See Also

Cursors Class | Cursors Members | System.Drawing Namespace


Cursors.PanEast

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property PanEast As Cursor
[C#]
public static Cursor PanEast {get;}
[C++]
public: __property static Cursor* get_PanEast();
[JScript]
public static function get PanEast() : Cursor;

See Also

Cursors Class | Cursors Members | System.Drawing Namespace


Cursors.PanNE

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property PanNE As Cursor
[C#]
public static Cursor PanNE {get;}
[C++]
public: __property static Cursor* get_PanNE();
[JScript]
public static function get PanNE() : Cursor;

See Also

Cursors Class | Cursors Members | System.Drawing Namespace


Cursors.PanNorth

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property PanNorth As Cursor
[C#]
public static Cursor PanNorth {get;}
[C++]
public: __property static Cursor* get_PanNorth();
[JScript]
public static function get PanNorth() : Cursor;

See Also

Cursors Class | Cursors Members | System.Drawing Namespace


Cursors.PanNW

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property PanNW As Cursor
[C#]
public static Cursor PanNW {get;}
[C++]
public: __property static Cursor* get_PanNW();
[JScript]
public static function get PanNW() : Cursor;

See Also

Cursors Class | Cursors Members | System.Drawing Namespace


Cursors.PanSE

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property PanSE As Cursor
[C#]
public static Cursor PanSE {get;}
[C++]
public: __property static Cursor* get_PanSE();
[JScript]
public static function get PanSE() : Cursor;

See Also

Cursors Class | Cursors Members | System.Drawing Namespace


Cursors.PanSouth

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property PanSouth As Cursor
[C#]
public static Cursor PanSouth {get;}
[C++]
public: __property static Cursor* get_PanSouth();
[JScript]
public static function get PanSouth() : Cursor;

See Also

Cursors Class | Cursors Members | System.Drawing Namespace


Cursors.PanSW

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property PanSW As Cursor
[C#]
public static Cursor PanSW {get;}
[C++]
public: __property static Cursor* get_PanSW();
[JScript]
public static function get PanSW() : Cursor;

See Also

Cursors Class | Cursors Members | System.Drawing Namespace


Cursors.PanWest

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property PanWest As Cursor
[C#]
public static Cursor PanWest {get;}
[C++]
public: __property static Cursor* get_PanWest();
[JScript]
public static function get PanWest() : Cursor;

See Also

Cursors Class | Cursors Members | System.Drawing Namespace


Cursors.SizeAll

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SizeAll As Cursor
[C#]
public static Cursor SizeAll {get;}
[C++]
public: __property static Cursor* get_SizeAll();
[JScript]
public static function get SizeAll() : Cursor;

See Also

Cursors Class | Cursors Members | System.Drawing Namespace


Cursors.SizeNESW

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SizeNESW As Cursor
[C#]
public static Cursor SizeNESW {get;}
[C++]
public: __property static Cursor* get_SizeNESW();
[JScript]
public static function get SizeNESW() : Cursor;

See Also

Cursors Class | Cursors Members | System.Drawing Namespace


Cursors.SizeNS

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SizeNS As Cursor
[C#]
public static Cursor SizeNS {get;}
[C++]
public: __property static Cursor* get_SizeNS();
[JScript]
public static function get SizeNS() : Cursor;

See Also

Cursors Class | Cursors Members | System.Drawing Namespace


Cursors.SizeNWSE

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SizeNWSE As Cursor
[C#]
public static Cursor SizeNWSE {get;}
[C++]
public: __property static Cursor* get_SizeNWSE();
[JScript]
public static function get SizeNWSE() : Cursor;

See Also

Cursors Class | Cursors Members | System.Drawing Namespace


Cursors.SizeWE

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SizeWE As Cursor
[C#]
public static Cursor SizeWE {get;}
[C++]
public: __property static Cursor* get_SizeWE();
[JScript]
public static function get SizeWE() : Cursor;

See Also

Cursors Class | Cursors Members | System.Drawing Namespace


Cursors.UpArrow

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property UpArrow As Cursor
[C#]
public static Cursor UpArrow {get;}
[C++]
public: __property static Cursor* get_UpArrow();
[JScript]
public static function get UpArrow() : Cursor;

See Also

Cursors Class | Cursors Members | System.Drawing Namespace


Cursors.VSplit

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property VSplit As Cursor
[C#]
public static Cursor VSplit {get;}
[C++]
public: __property static Cursor* get_VSplit();
[JScript]
public static function get VSplit() : Cursor;

See Also

Cursors Class | Cursors Members | System.Drawing Namespace


Cursors.WaitCursor

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property WaitCursor As Cursor
[C#]
public static Cursor WaitCursor {get;}
[C++]
public: __property static Cursor* get_WaitCursor();
[JScript]
public static function get WaitCursor() : Cursor;

See Also

Cursors Class | Cursors Members | System.Drawing Namespace


Font Class

[To be supplied.]

Object
MarshalByRefObject
Font

[Visual Basic]
NotInheritable Public Class Font
   Inherits MarshalByRefObject
   Implements ICloneable
[C#]
public sealed class Font : MarshalByRefObject, ICloneable
[C++]
public __gc __sealed class Font : public MarshalByRefObject,
   ICloneable
[JScript]
public class Font extends MarshalByRefObject, ICloneable

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

Font Members | System.Drawing Namespace


Font Members

Public:

Constructor

Font Constructor Overloaded. [To be supplied.]

Properties

Bold | [To be supplied.]
FontFamily | [To be supplied.]
Height | [To be supplied.]
Italic | The italic property of the font.
Name | The face name of the font.
Size | [To be supplied.]
SizeInPoints | [To be supplied.]
Strikeout | [To be supplied.]
Style | [To be supplied.]
Underline | [To be supplied.]
Unit | [To be supplied.]

Methods

Clone | [To be supplied.]
Dispose | [To be supplied.]
Equals | [To be supplied.]
FromHDC | [To be supplied.]
FromHFONT | [To be supplied.]
FromLOGFONT | Overloaded. [To be supplied.]
GetHashCode | [To be supplied.]
GetHeight | [To be supplied.]
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
ToHFONT | [To be supplied.]
ToLOGFONT | Overloaded. [To be supplied.]
ToString | [To be supplied.]

Protected:

Methods

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Font Class | System.Drawing Namespace


Font Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Font, FontStyle)
[C#] public Font(Font, FontStyle);
[C++] public: Font(Font*, FontStyle);
[JScript] public function Font(Font, FontStyle);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(FontFamily, Single, FontStyle, GraphicsUnit)
[C#] public Font(FontFamily, float, FontStyle, GraphicsUnit);
[C++] public: Font(FontFamily*, float, FontStyle, GraphicsUnit);
[JScript] public function Font(FontFamily, float, FontStyle, GraphicsUnit);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(FontFamily, Single, FontStyle)
[C#] public Font(FontFamily, float, FontStyle);
[C++] public: Font(FontFamily*, float, FontStyle);
[JScript] public function Font(FontFamily, float, FontStyle);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(FontFamily, Single, GraphicsUnit)
[C#] public Font(FontFamily, float, GraphicsUnit);
[C++] public: Font(FontFamily*, float, GraphicsUnit);
[JScript] public function Font(FontFamily, float, GraphicsUnit);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(FontFamily, Single)
[C#] public Font(FontFamily, float);
[C++] public: Font(FontFamily*, float);
[JScript] public function Font(FontFamily, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Single, FontStyle, GraphicsUnit)
[C#] public Font(String, float, FontStyle, GraphicsUnit);
[C++] public: Font(String*, float, FontStyle, GraphicsUnit);
[JScript] public function Font(String, float, FontStyle, GraphicsUnit);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Single, FontStyle)
[C#] public Font(String, float, FontStyle);
[C++] public: Font(String*, float, FontStyle);
[JScript] public function Font(String, float, FontStyle);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Single, GraphicsUnit)
[C#] public Font(String, float, GraphicsUnit);
[C++] public: Font(String*, float, GraphicsUnit);
[JScript] public function Font(String, float, GraphicsUnit);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Single)
[C#] public Font(String, float);
[C++] public: Font(String*, float);
[JScript] public function Font(String, float);

See Also

Font Class | Font Members | System.Drawing Namespace


Font Constructor (Font, FontStyle)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal prototype As Font, _
   ByVal additionalStyles As FontStyle _
)
[C#]
public Font(
   Font prototype,
   FontStyle additionalStyles
);
[C++]
public: Font(
   Font* prototype,
   FontStyle additionalStyles
);
[JScript]
public function Font(
   prototype : Font,
   additionalStyles : FontStyle
);

Parameters

prototype
[To be supplied.]
additionalStyles
[To be supplied.]

See Also

Font Class | Font Members | System.Drawing Namespace | Font Constructor Overload List


Font Constructor (FontFamily, Single, FontStyle, GraphicsUnit)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal family As FontFamily, _
   ByVal emSize As Single, _
   ByVal style As FontStyle, _
   ByVal unit As GraphicsUnit _
)
[C#]
public Font(
   FontFamily family,
   float emSize,
   FontStyle style,
   GraphicsUnit unit
);
[C++]
public: Font(
   FontFamily* family,
   float emSize,
   FontStyle style,
   GraphicsUnit unit
);
[JScript]
public function Font(
   family : FontFamily,
   emSize : float,
   style : FontStyle,
   unit : GraphicsUnit
);

Parameters

family
[To be supplied.]
emSize
[To be supplied.]
style
[To be supplied.]
unit
[To be supplied.]

See Also

Font Class | Font Members | System.Drawing Namespace | Font Constructor Overload List


Font Constructor (FontFamily, Single, FontStyle)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal family As FontFamily, _
   ByVal emSize As Single, _
   ByVal style As FontStyle _
)
[C#]
public Font(
   FontFamily family,
   float emSize,
   FontStyle style
);
[C++]
public: Font(
   FontFamily* family,
   float emSize,
   FontStyle style
);
[JScript]
public function Font(
   family : FontFamily,
   emSize : float,
   style : FontStyle
);

Parameters

family
[To be supplied.]
emSize
[To be supplied.]
style
[To be supplied.]

See Also

Font Class | Font Members | System.Drawing Namespace | Font Constructor Overload List


Font Constructor (FontFamily, Single, GraphicsUnit)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal family As FontFamily, _
   ByVal emSize As Single, _
   ByVal unit As GraphicsUnit _
)
[C#]
public Font(
   FontFamily family,
   float emSize,
   GraphicsUnit unit
);
[C++]
public: Font(
   FontFamily* family,
   float emSize,
   GraphicsUnit unit
);
[JScript]
public function Font(
   family : FontFamily,
   emSize : float,
   unit : GraphicsUnit
);

Parameters

family
[To be supplied.]
emSize
[To be supplied.]
unit
[To be supplied.]

See Also

Font Class | Font Members | System.Drawing Namespace | Font Constructor Overload List


Font Constructor (FontFamily, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal family As FontFamily, _
   ByVal emSize As Single _
)
[C#]
public Font(
   FontFamily family,
   float emSize
);
[C++]
public: Font(
   FontFamily* family,
   float emSize
);
[JScript]
public function Font(
   family : FontFamily,
   emSize : float
);

Parameters

family
[To be supplied.]
emSize
[To be supplied.]

See Also

Font Class | Font Members | System.Drawing Namespace | Font Constructor Overload List


Font Constructor (String, Single, FontStyle, GraphicsUnit)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal familyName As String, _
   ByVal emSize As Single, _
   ByVal style As FontStyle, _
   ByVal unit As GraphicsUnit _
)
[C#]
public Font(
   string familyName,
   float emSize,
   FontStyle style,
   GraphicsUnit unit
);
[C++]
public: Font(
   String* familyName,
   float emSize,
   FontStyle style,
   GraphicsUnit unit
);
[JScript]
public function Font(
   familyName : String,
   emSize : float,
   style : FontStyle,
   unit : GraphicsUnit
);

Parameters

familyName
[To be supplied.]
emSize
[To be supplied.]
style
[To be supplied.]
unit
[To be supplied.]

See Also

Font Class | Font Members | System.Drawing Namespace | Font Constructor Overload List


Font Constructor (String, Single, FontStyle)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal familyName As String, _
   ByVal emSize As Single, _
   ByVal style As FontStyle _
)
[C#]
public Font(
   string familyName,
   float emSize,
   FontStyle style
);
[C++]
public: Font(
   String* familyName,
   float emSize,
   FontStyle style
);
[JScript]
public function Font(
   familyName : String,
   emSize : float,
   style : FontStyle
);

Parameters

familyName
[To be supplied.]
emSize
[To be supplied.]
style
[To be supplied.]

See Also

Font Class | Font Members | System.Drawing Namespace | Font Constructor Overload List


Font Constructor (String, Single, GraphicsUnit)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal familyName As String, _
   ByVal emSize As Single, _
   ByVal unit As GraphicsUnit _
)
[C#]
public Font(
   string familyName,
   float emSize,
   GraphicsUnit unit
);
[C++]
public: Font(
   String* familyName,
   float emSize,
   GraphicsUnit unit
);
[JScript]
public function Font(
   familyName : String,
   emSize : float,
   unit : GraphicsUnit
);

Parameters

familyName
[To be supplied.]
emSize
[To be supplied.]
unit
[To be supplied.]

See Also

Font Class | Font Members | System.Drawing Namespace | Font Constructor Overload List


Font Constructor (String, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal familyName As String, _
   ByVal emSize As Single _
)
[C#]
public Font(
   string familyName,
   float emSize
);
[C++]
public: Font(
   String* familyName,
   float emSize
);
[JScript]
public function Font(
   familyName : String,
   emSize : float
);

Parameters

familyName
[To be supplied.]
emSize
[To be supplied.]

See Also

Font Class | Font Members | System.Drawing Namespace | Font Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Font Properties

The properties of the Font class are listed below. For a complete list of Font class members, see the Font Members topic.

Public:

Bold | [To be supplied.]
FontFamily | [To be supplied.]
Height | [To be supplied.]
Italic | The italic property of the font.
Name | The face name of the font.
Size | [To be supplied.]
SizeInPoints | [To be supplied.]
Strikeout | [To be supplied.]
Style | [To be supplied.]
Underline | [To be supplied.]
Unit | [To be supplied.]

See Also

Font Class | System.Drawing Namespace


Font.Bold

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Bold As Boolean
[C#]
public bool Bold {get;}
[C++]
public: __property bool get_Bold();
[JScript]
public function get Bold() : Boolean;

See Also

Font Class | Font Members | System.Drawing Namespace


Font.FontFamily

[To be supplied.]

[Visual Basic]
Public ReadOnly Property FontFamily As FontFamily
[C#]
public FontFamily FontFamily {get;}
[C++]
public: __property FontFamily* get_FontFamily();
[JScript]
public function get FontFamily() : FontFamily;

See Also

Font Class | Font Members | System.Drawing Namespace


Font.Height

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Height As Integer
[C#]
public int Height {get;}
[C++]
public: __property int get_Height();
[JScript]
public function get Height() : int;

See Also

Font Class | Font Members | System.Drawing Namespace


Font.Italic

The italic property of the font.

[Visual Basic]
Public ReadOnly Property Italic As Boolean
[C#]
public bool Italic {get;}
[C++]
public: __property bool get_Italic();
[JScript]
public function get Italic() : Boolean;

See Also

Font Class | Font Members | System.Drawing Namespace


Font.Name

The face name of the font.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}
[C++]
public: __property String* get_Name();
[JScript]
public function get Name() : String;

See Also

Font Class | Font Members | System.Drawing Namespace


Font.Size

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Size As Single
[C#]
public float Size {get;}
[C++]
public: __property float get_Size();
[JScript]
public function get Size() : float;

See Also

Font Class | Font Members | System.Drawing Namespace


Font.SizeInPoints

[To be supplied.]

[Visual Basic]
Public ReadOnly Property SizeInPoints As Single
[C#]
public float SizeInPoints {get;}
[C++]
public: __property float get_SizeInPoints();
[JScript]
public function get SizeInPoints() : float;

See Also

Font Class | Font Members | System.Drawing Namespace


Font.Strikeout

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Strikeout As Boolean
[C#]
public bool Strikeout {get;}
[C++]
public: __property bool get_Strikeout();
[JScript]
public function get Strikeout() : Boolean;

See Also

Font Class | Font Members | System.Drawing Namespace


Font.Style

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Style As FontStyle
[C#]
public FontStyle Style {get;}
[C++]
public: __property FontStyle get_Style();
[JScript]
public function get Style() : FontStyle;

See Also

Font Class | Font Members | System.Drawing Namespace


Font.Underline

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Underline As Boolean
[C#]
public bool Underline {get;}
[C++]
public: __property bool get_Underline();
[JScript]
public function get Underline() : Boolean;

See Also

Font Class | Font Members | System.Drawing Namespace


Font.Unit

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Unit As GraphicsUnit
[C#]
public GraphicsUnit Unit {get;}
[C++]
public: __property GraphicsUnit get_Unit();
[JScript]
public function get Unit() : GraphicsUnit;

See Also

Font Class | Font Members | System.Drawing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Font Methods

The methods of the Font class are listed below. For a complete list of Font class members, see the Font Members topic.

Public:

Clone | [To be supplied.]
Dispose | [To be supplied.]
Equals | [To be supplied.]
FromHDC | [To be supplied.]
FromHFONT | [To be supplied.]
FromLOGFONT | Overloaded. [To be supplied.]
GetHashCode | [To be supplied.]
GetHeight | [To be supplied.]
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
ToHFONT | [To be supplied.]
ToLOGFONT | Overloaded. [To be supplied.]
ToString | [To be supplied.]

Protected:

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Font Class | System.Drawing Namespace


Font.Clone

[To be supplied.]

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

See Also

Font Class | Font Members | System.Drawing Namespace


Font.Dispose

[To be supplied.]

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[JScript]
public function Dispose();

See Also

Font Class | Font Members | System.Drawing Namespace


Font.Equals

[To be supplied.]

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
[To be supplied.]

See Also

Font Class | Font Members | System.Drawing Namespace


Font.Finalize

[To be supplied.]

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

Font Class | Font Members | System.Drawing Namespace


Font.FromHDC

[To be supplied.]

[Visual Basic]
Public Shared Function FromHDC( _
   ByVal hdc As Integer _
) As Font
[C#]
public static Font FromHDC(
   int hdc
);
[C++]
public: static Font* FromHDC(
   int hdc
);
[JScript]
public static function FromHDC(
   hdc : int
) : Font;

Parameters

hdc
[To be supplied.]

See Also

Font Class | Font Members | System.Drawing Namespace


Font.FromHFONT

[To be supplied.]

[Visual Basic]
Public Shared Function FromHFONT( _
   ByVal hFont As Integer _
) As Font
[C#]
public static Font FromHFONT(
   int hFont
);
[C++]
public: static Font* FromHFONT(
   int hFont
);
[JScript]
public static function FromHFONT(
   hFont : int
) : Font;

Parameters

hFont
[To be supplied.]

See Also

Font Class | Font Members | System.Drawing Namespace


Font.FromLOGFONT

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Shared Function FromLOGFONT(LOGFONT) As Font
[C#] public static Font FromLOGFONT(LOGFONT);
[C++] public: static Font* FromLOGFONT(LOGFONT*);
[JScript] public static function FromLOGFONT(LOGFONT) : Font;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function FromLOGFONT(LOGFONT, Integer) As Font
[C#] public static Font FromLOGFONT(LOGFONT, int);
[C++] public: static Font* FromLOGFONT(LOGFONT*, int);
[JScript] public static function FromLOGFONT(LOGFONT, int) : Font;

See Also

Font Class | Font Members | System.Drawing Namespace


Font.FromLOGFONT (LOGFONT)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function FromLOGFONT( _
   ByVal lf As LOGFONT _
) As Font
[C#]
public static Font FromLOGFONT(
   LOGFONT lf
);
[C++]
public: static Font* FromLOGFONT(
   LOGFONT* lf
);
[JScript]
public static function FromLOGFONT(
   lf : LOGFONT
) : Font;

Parameters

lf
[To be supplied.]

See Also

Font Class | Font Members | System.Drawing Namespace | Font.FromLOGFONT Overload List


Font.FromLOGFONT (LOGFONT, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function FromLOGFONT( _
   ByVal lf As LOGFONT, _
   ByVal hdc As Integer _
) As Font
[C#]
public static Font FromLOGFONT(
   LOGFONT lf,
   int hdc
);
[C++]
public: static Font* FromLOGFONT(
   LOGFONT* lf,
   int hdc
);
[JScript]
public static function FromLOGFONT(
   lf : LOGFONT,
   hdc : int
) : Font;

Parameters

lf
[To be supplied.]
hdc
[To be supplied.]

See Also

Font Class | Font Members | System.Drawing Namespace | Font.FromLOGFONT Overload List


Font.GetHashCode

[To be supplied.]

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

See Also

Font Class | Font Members | System.Drawing Namespace


Font.GetHeight

[To be supplied.]

[Visual Basic]
Public Function GetHeight( _
   ByVal graphics As Graphics _
) As Single
[C#]
public float GetHeight(
   Graphics graphics
);
[C++]
public: float GetHeight(
   Graphics* graphics
);
[JScript]
public function GetHeight(
   graphics : Graphics
) : float;

Parameters

graphics
[To be supplied.]

See Also

Font Class | Font Members | System.Drawing Namespace


Font.ToHFONT

[To be supplied.]

[Visual Basic]
Public Function ToHFONT() As Integer
[C#]
public int ToHFONT();
[C++]
public: int ToHFONT();
[JScript]
public function ToHFONT() : int;

See Also

Font Class | Font Members | System.Drawing Namespace


Font.ToLOGFONT

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function ToLOGFONT() As LOGFONT
[C#] public LOGFONT ToLOGFONT();
[C++] public: LOGFONT* ToLOGFONT();
[JScript] public function ToLOGFONT() : LOGFONT;

[To be supplied.]

[Visual Basic] Overloads Public Function ToLOGFONT(Graphics) As LOGFONT
[C#] public LOGFONT ToLOGFONT(Graphics);
[C++] public: LOGFONT* ToLOGFONT(Graphics*);
[JScript] public function ToLOGFONT(Graphics) : LOGFONT;

See Also

Font Class | Font Members | System.Drawing Namespace


Font.ToLOGFONT ()

[To be supplied.]

[Visual Basic]
Overloads Public Function ToLOGFONT() As LOGFONT
[C#]
public LOGFONT ToLOGFONT();
[C++]
public: LOGFONT* ToLOGFONT();
[JScript]
public function ToLOGFONT() : LOGFONT;

See Also

Font Class | Font Members | System.Drawing Namespace | Font.ToLOGFONT Overload List


Font.ToLOGFONT (Graphics)

[To be supplied.]

[Visual Basic]
Overloads Public Function ToLOGFONT( _
   ByVal graphics As Graphics _
) As LOGFONT
[C#]
public LOGFONT ToLOGFONT(
   Graphics graphics
);
[C++]
public: LOGFONT* ToLOGFONT(
   Graphics* graphics
);
[JScript]
public function ToLOGFONT(
   graphics : Graphics
) : LOGFONT;

Parameters

graphics
[To be supplied.]

See Also

Font Class | Font Members | System.Drawing Namespace | Font.ToLOGFONT Overload List


Font.ToString

[To be supplied.]

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

Font Class | Font Members | System.Drawing Namespace


FontConverter Class

FontConverter is a class that can be used to convert fonts from one data type to another. Access this class through the TypeDescriptor.

Object
TypeConverter
FontConverter

[Visual Basic]
Public Class FontConverter
   Inherits TypeConverter
[C#]
public class FontConverter : TypeConverter
[C++]
public __gc class FontConverter : public TypeConverter
[JScript]
public class FontConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

FontConverter Members | System.Drawing Namespace


FontConverter Members

Public:

Constructor

FontConverter Constructor [To be supplied.]

Methods

CanConvertFrom | Overloaded. [To be supplied.]
CanConvertTo (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type.
ConvertFrom | Overloaded. [To be supplied.]
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text into an object.
ConvertTo | Overloaded. [To be supplied.]
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetProperties | Overloaded. [To be supplied.]
GetPropertiesSupported | Overloaded. [To be supplied.]
GetStandardValues (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid (inherited from TypeConverter) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

FontConverter Class | System.Drawing Namespace


FontConverter Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public FontConverter();
[C++]
public: FontConverter();
[JScript]
public function FontConverter();

See Also

FontConverter Class | FontConverter Members | System.Drawing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

FontConverter Methods

The methods of the FontConverter class are listed below. For a complete list of FontConverter class members, see the FontConverter Members topic.

Public:

CanConvertFrom | Overloaded. [To be supplied.]
CanConvertTo (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type.
ConvertFrom | Overloaded. [To be supplied.]
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text into an object.
ConvertTo | Overloaded. [To be supplied.]
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetProperties | Overloaded. [To be supplied.]
GetPropertiesSupported | Overloaded. [To be supplied.]
GetStandardValues (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid (inherited from TypeConverter) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

FontConverter Class | System.Drawing Namespace


FontConverter.CanConvertFrom

Determines if this converter can convert an object in the given source type to the native type of the converter.

[Visual Basic]
Overrides Public Function CanConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal sourceType As Type _
) As Boolean
[C#]
public override bool CanConvertFrom(
   ITypeDescriptorContext context,
   Type sourceType
);
[C++]
public: override bool CanConvertFrom(
   ITypeDescriptorContext* context,
   Type* sourceType
);
[JScript]
public override function CanConvertFrom(
   context : ITypeDescriptorContext,
   sourceType : Type
) : Boolean;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
sourceType
The type you wish to convert from.

Return Value

True if this object can perform the conversion.

See Also

FontConverter Class | FontConverter Members | System.Drawing Namespace


FontConverter.ConvertFrom

Converts the given object to the converter's native type.

[Visual Basic]
Overrides Public Function ConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal arguments() As Object _
) As Object
[C#]
public override object ConvertFrom(
   ITypeDescriptorContext context,
   object value,
   object[] arguments
);
[C++]
public: override Object* ConvertFrom(
   ITypeDescriptorContext* context,
   Object* value,
   Object* arguments[]
);
[JScript]
public override function ConvertFrom(
   context : ITypeDescriptorContext,
   value : Object,
   arguments : Object[]
) : Object;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
value
The object to convert.
arguments
An optional array of arguments to use when doing the conversion. The number and content of these arguments is dependent on the implementer of the value formatter.

Return Value

The converted object. This will throw an excetpion if the converson could not be performed.

See Also

FontConverter Class | FontConverter Members | System.Drawing Namespace


FontConverter.ConvertTo

Converts the given object to another type. The most common types to convert are to and from a string object. The default implementation will make a call to ToString on the object if the object is valid and if the destination type is string. If this cannot convert to the desitnation type, this will throw a NotSupportedException.

[Visual Basic]
Overrides Public Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal destinationType As Type, _
   ByVal arguments() As Object _
) As Object
[C#]
public override object ConvertTo(
   ITypeDescriptorContext context,
   object value,
   Type destinationType,
   object[] arguments
);
[C++]
public: override Object* ConvertTo(
   ITypeDescriptorContext* context,
   Object* value,
   Type* destinationType,
   Object* arguments[]
);
[JScript]
public override function ConvertTo(
   context : ITypeDescriptorContext,
   value : Object,
   destinationType : Type,
   arguments : Object[]
) : Object;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
value
The object to convert.
destinationType
The type to convert the object to.
arguments
An optional array of arguments to use when doing the conversion. The number and content of these arguments is dependent on the implementer of the value formatter.

Return Value

The converted object.

See Also

FontConverter Class | FontConverter Members | System.Drawing Namespace


FontConverter.CreateInstance

[To be supplied.]

Overload List

Recreates an object given its PersistInfo. This information was generated by a prior call to GetPersistInfo.

[Visual Basic] Overloads Overrides Public Function CreateInstance(ITypeDescriptorContext, PersistInfo) As Object
[C#] public override object CreateInstance(ITypeDescriptorContext, PersistInfo);
[C++] public: override Object* CreateInstance(ITypeDescriptorContext*, PersistInfo);
[JScript] public override function CreateInstance(ITypeDescriptorContext, PersistInfo) : Object;

Creates an instance of this type given a set of property values for the object. This is useful for objects that are immutable, but still want to provide changable properties.

[Visual Basic] Overloads Overrides Public Function CreateInstance(ITypeDescriptorContext, IDictionary) As Object
[C#] public override object CreateInstance(ITypeDescriptorContext, IDictionary);
[C++] public: override Object* CreateInstance(ITypeDescriptorContext*, IDictionary);
[JScript] public override function CreateInstance(ITypeDescriptorContext, IDictionary) : Object;

See Also

FontConverter Class | FontConverter Members | System.Drawing Namespace


FontConverter.CreateInstance (ITypeDescriptorContext, PersistInfo)

Recreates an object given its PersistInfo. This information was generated by a prior call to GetPersistInfo.

[Visual Basic]
Overloads Overrides Public Function CreateInstance( _
   ByVal context As ITypeDescriptorContext, _
   ByVal persistInfo As PersistInfo _
) As Object
[C#]
public override object CreateInstance(
   ITypeDescriptorContext context,
   PersistInfo persistInfo
);
[C++]
public: override Object* CreateInstance(
   ITypeDescriptorContext* context,
   PersistInfo* persistInfo
);
[JScript]
public override function CreateInstance(
   context : ITypeDescriptorContext,
   persistInfo : PersistInfo
) : Object;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
persistInfo
The persistence information to use when re-creating the object.

Return Value

An object representing the given PersistInfo.

See Also

FontConverter Class | FontConverter Members | System.Drawing Namespace | FontConverter.CreateInstance Overload List | PersistInfo | TBD


FontConverter.CreateInstance (ITypeDescriptorContext, IDictionary)

Creates an instance of this type given a set of property values for the object. This is useful for objects that are immutable, but still want to provide changable properties.

[Visual Basic]
Overloads Overrides Public Function CreateInstance( _
   ByVal context As ITypeDescriptorContext, _
   ByVal propertyValues As IDictionary _
) As Object
[C#]
public override object CreateInstance(
   ITypeDescriptorContext context,
   IDictionary propertyValues
);
[C++]
public: override Object* CreateInstance(
   ITypeDescriptorContext* context,
   IDictionary* propertyValues
);
[JScript]
public override function CreateInstance(
   context : ITypeDescriptorContext,
   propertyValues : IDictionary
) : Object;

Parameters

context
A type descriptor through which additional context may be provided.
propertyValues
A dictionary of new property values. The dictionary contains a series of name-value pairs, one for each property returned from GetProperties.

Return Value

The newly created object, or null if the object could not be created. The default implementation returns null.

See Also

FontConverter Class | FontConverter Members | System.Drawing Namespace | FontConverter.CreateInstance Overload List


FontConverter.GetCreateInstanceSupported

Determines if changing a value on this object should require a call to CreateInstance to create a new value.

[Visual Basic]
Overrides Public Function GetCreateInstanceSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
[C#]
public override bool GetCreateInstanceSupported(
   ITypeDescriptorContext context
);
[C++]
public: override bool GetCreateInstanceSupported(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetCreateInstanceSupported(
   context : ITypeDescriptorContext
) : Boolean;

Parameters

context
A type descriptor through which additional context may be provided.

Return Value

Returns true if CreateInstance should be called when a change is made to one or more properties of this object.

See Also

FontConverter Class | FontConverter Members | System.Drawing Namespace


FontConverter.GetPersistInfo

Retrieves the PersistInfo object for the given value. This object describes the given value as persisted information, which can be saved to disk or moved. This information can later be reconstructed by passing the PersistInfo to GetValue.

[Visual Basic]
Overrides Public Function GetPersistInfo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As PersistInfo
[C#]
public override PersistInfo GetPersistInfo(
   ITypeDescriptorContext context,
   object value
);
[C++]
public: override PersistInfo* GetPersistInfo(
   ITypeDescriptorContext* context,
   Object* value
);
[JScript]
public override function GetPersistInfo(
   context : ITypeDescriptorContext,
   value : Object
) : PersistInfo;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
value
The object to persist.

Return Value

The PersistInfo representing the persisted state of the given object.

See Also

FontConverter Class | FontConverter Members | System.Drawing Namespace | PersistInfo | TBD


FontConverter.GetProperties

Retrieves the set of properties for this type. By default, a type has does not return any properties. An easy implementation of this method can just call TypeDescriptor.GetProperties for the correct data type.

[Visual Basic]
Overrides Public Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal attributes() As MemberAttribute _
) As PropertyDescriptorCollection
[C#]
public override PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value,
   MemberAttribute[] attributes
);
[C++]
public: override PropertyDescriptorCollection* GetProperties(
   ITypeDescriptorContext* context,
   Object* value,
   MemberAttribute* attributes[]
);
[JScript]
public override function GetProperties(
   context : ITypeDescriptorContext,
   value : Object,
   attributes : MemberAttribute[]
) : PropertyDescriptorCollection;

Parameters

context
A type descriptor through which additional context may be provided.
value
The value of the object to get the properties for.
attributes
[To be supplied.]

Return Value

The set of properties that should be exposed for this data type. If no properties should be exposed, thsi may return null. The default implementation always returns null.

See Also

FontConverter Class | FontConverter Members | System.Drawing Namespace


FontConverter.GetPropertiesSupported

Determines if this object supports properties. By default, this is false.

[Visual Basic]
Overrides Public Function GetPropertiesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
[C#]
public override bool GetPropertiesSupported(
   ITypeDescriptorContext context
);
[C++]
public: override bool GetPropertiesSupported(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetPropertiesSupported(
   context : ITypeDescriptorContext
) : Boolean;

Parameters

context
A type descriptor through which additional context may be provided.

Return Value

Returns true if GetProperties should be called to find the properties of this object.

See Also

FontConverter Class | FontConverter Members | System.Drawing Namespace


FontFamily Class

Abstracts a group of type faces having a similar basic design but having certain variation in styles.

Object
MarshalByRefObject
FontFamily

[Visual Basic]
NotInheritable Public Class FontFamily
   Inherits MarshalByRefObject
[C#]
public sealed class FontFamily : MarshalByRefObject
[C++]
public __gc __sealed class FontFamily : public MarshalByRefObject
[JScript]
public class FontFamily extends MarshalByRefObject

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

FontFamily Members | System.Drawing Namespace


FontFamily Members

Public:

Constructor

FontFamily Constructor Overloaded. Initializes a new instance of the FontFamily class.

Properties

Families | Returns an array that contains all of the FontFamily objects associated with the current graphics context.
GenericMonospace | Gets a generic monospace FontFamily.
GenericSansSerif | Gets a generic SansSerif FontFamily.
GenericSerif | Gets a generic Serif FontFamily.
Name | Gets the name of this FontFamily.

Methods

Dispose | Disposes of this FontFamily.
Equals | [To be supplied.]
GetCellAscent | Returns the ascender metric for Windows.
GetCellDescent | Returns the descender metric for Windows.
GetEmHeight | Gets the size of the Em square for the specified style in font design units.
GetFamilies | Returns an array that contains all of the FontFamily objects associated with the specified graphics context.
GetHashCode | Gets a hash code for this FontFamily.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetLineSpacing | Returns the distance between two consecutive lines of text for this FontFamily with the specified FontStyle.
GetName | Retuns the name of this FontFamily in the specified language.
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
IsStyleAvailable | Indicates whether the specified FontStyle is available.
ToString | Converts this FontFamily to a human-readable string.

Protected:

Methods

Finalize | Allows an object to free resources before the object is reclaimed by the Garbage Collector (GC).
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FontFamily Class | System.Drawing Namespace


FontFamily Constructor

Initializes a new instance of the FontFamily class.

Overload List

Initializes a new instance of the FontFamily class with the specified name.

[Visual Basic] Overloads Public Sub New(String)
[C#] public FontFamily(String);
[C++] public: FontFamily(String*);
[JScript] public function FontFamily(String);

Initializes a new instance of the FontFamily class in the specified FontCollection and with the specified name.

[Visual Basic] Overloads Public Sub New(String, FontCollection)
[C#] public FontFamily(String, FontCollection);
[C++] public: FontFamily(String*, FontCollection);
[JScript] public function FontFamily(String, FontCollection);

Initializes a new instance of the FontFamily class from the specified generic font family.

[Visual Basic] Overloads Public Sub New(GenericFontFamilies)
[C#] public FontFamily(GenericFontFamilies);
[C++] public: FontFamily(GenericFontFamilies);
[JScript] public function FontFamily(GenericFontFamilies);

See Also

FontFamily Class | FontFamily Members | System.Drawing Namespace


FontFamily Constructor (String)

Initializes a new instance of the FontFamily class with the specified name.

[Visual Basic]
Overloads Public Sub New( _
   ByVal name As String _
)
[C#]
public FontFamily(
   string name
);
[C++]
public: FontFamily(
   String* name
);
[JScript]
public function FontFamily(
   name : String
);

Parameters

name
The name of the new FontFamily.

See Also

FontFamily Class | FontFamily Members | System.Drawing Namespace | FontFamily Constructor Overload List


FontFamily Constructor (String, FontCollection)

Initializes a new instance of the FontFamily class in the specified FontCollection and with the specified name.

[Visual Basic]
Overloads Public Sub New( _
   ByVal name As String, _
   ByVal fontCollection As FontCollection _
)
[C#]
public FontFamily(
   string name,
   FontCollection fontCollection
);
[C++]
public: FontFamily(
   String* name,
   FontCollection* fontCollection
);
[JScript]
public function FontFamily(
   name : String,
   fontCollection : FontCollection
);

Parameters

name
A String that represents the name of the new FontFamily.
fontCollection
[To be supplied.]

See Also

FontFamily Class | FontFamily Members | System.Drawing Namespace | FontFamily Constructor Overload List


FontFamily Constructor (GenericFontFamilies)

Initializes a new instance of the FontFamily class from the specified generic font family.

[Visual Basic]
Overloads Public Sub New( _
   ByVal genericFamily As GenericFontFamilies _
)
[C#]
public FontFamily(
   GenericFontFamilies genericFamily
);
[C++]
public: FontFamily(
   GenericFontFamilies genericFamily
);
[JScript]
public function FontFamily(
   genericFamily : GenericFontFamilies
);

Parameters

genericFamily
The GenericFontFamilies element from which to create the new FontFamily.

See Also

FontFamily Class | FontFamily Members | System.Drawing Namespace | FontFamily Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

FontFamily Properties

The properties of the FontFamily class are listed below. For a complete list of FontFamily class members, see the FontFamily Members topic.

Public:

Families | Returns an array that contains all of the FontFamily objects associated with the current graphics context.
GenericMonospace | Gets a generic monospace FontFamily.
GenericSansSerif | Gets a generic SansSerif FontFamily.
GenericSerif | Gets a generic Serif FontFamily.
Name | Gets the name of this FontFamily.

See Also

FontFamily Class | System.Drawing Namespace


FontFamily.Families

Returns an array that contains all of the FontFamily objects associated with the current graphics context.

[Visual Basic]
Public Shared ReadOnly Property Families As FontFamily ()
[C#]
public static FontFamily[] Families {get;}
[C++]
public: __property static FontFamily* get_Families();
[JScript]
public static function get Families() : FontFamily[];

Property Value

An array of FontFamily objects associated with the current graphics context.

See Also

FontFamily Class | FontFamily Members | System.Drawing Namespace


FontFamily.GenericMonospace

Gets a generic monospace FontFamily.

[Visual Basic]
Public ReadOnly Property GenericMonospace As FontFamily
[C#]
public FontFamily GenericMonospace {get;}
[C++]
public: __property FontFamily* get_GenericMonospace();
[JScript]
public function get GenericMonospace() : FontFamily;

Property Value

A FontFamily that represents a generic monospace font.

See Also

FontFamily Class | FontFamily Members | System.Drawing Namespace


FontFamily.GenericSansSerif

Gets a generic SansSerif FontFamily.

[Visual Basic]
Public ReadOnly Property GenericSansSerif As FontFamily
[C#]
public FontFamily GenericSansSerif {get;}
[C++]
public: __property FontFamily* get_GenericSansSerif();
[JScript]
public function get GenericSansSerif() : FontFamily;

Property Value

A FontFamily that represents a generic SansSerif font.

See Also

FontFamily Class | FontFamily Members | System.Drawing Namespace | GenericFontFamilies


FontFamily.GenericSerif

Gets a generic Serif FontFamily.

[Visual Basic]
Public ReadOnly Property GenericSerif As FontFamily
[C#]
public FontFamily GenericSerif {get;}
[C++]
public: __property FontFamily* get_GenericSerif();
[JScript]
public function get GenericSerif() : FontFamily;

Property Value

A FontFamily that represents a generic Serif font.

See Also

FontFamily Class | FontFamily Members | System.Drawing Namespace | GenericFontFamilies


FontFamily.Name

Gets the name of this FontFamily.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}
[C++]
public: __property String* get_Name();
[JScript]
public function get Name() : String;

Property Value

A String that represents the name of this FontFamily.

See Also

FontFamily Class | FontFamily Members | System.Drawing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

FontFamily Methods

The methods of the FontFamily class are listed below. For a complete list of FontFamily class members, see the FontFamily Members topic.

Public:

Dispose | Disposes of this FontFamily.
Equals | [To be supplied.]
GetCellAscent | Returns the ascender metric for Windows.
GetCellDescent | Returns the descender metric for Windows.
GetEmHeight | Gets the size of the Em square for the specified style in font design units.
GetFamilies | Returns an array that contains all of the FontFamily objects associated with the specified graphics context.
GetHashCode | Gets a hash code for this FontFamily.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetLineSpacing | Returns the distance between two consecutive lines of text for this FontFamily with the specified FontStyle.
GetName | Retuns the name of this FontFamily in the specified language.
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
IsStyleAvailable | Indicates whether the specified FontStyle is available.
ToString | Converts this FontFamily to a human-readable string.

Protected:

Finalize | Allows an object to free resources before the object is reclaimed by the Garbage Collector (GC).
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FontFamily Class | System.Drawing Namespace


FontFamily.Dispose

Disposes of this FontFamily.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[JScript]
public function Dispose();

See Also

FontFamily Class | FontFamily Members | System.Drawing Namespace


FontFamily.Equals

[To be supplied.]

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
[To be supplied.]

See Also

FontFamily Class | FontFamily Members | System.Drawing Namespace


FontFamily.Finalize

Allows an object to free resources before the object is reclaimed by the Garbage Collector (GC).

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

FontFamily Class | FontFamily Members | System.Drawing Namespace


FontFamily.GetCellAscent

Returns the ascender metric for Windows.

[Visual Basic]
Public Function GetCellAscent( _
   ByVal style As FontStyle _
) As Integer
[C#]
public int GetCellAscent(
   FontStyle style
);
[C++]
public: int GetCellAscent(
   FontStyle style
);
[JScript]
public function GetCellAscent(
   style : FontStyle
) : int;

Parameters

style
[To be supplied.]

Return Value

The ascender metric for this FontFamily with the specified FontStyle.

Remarks

This value is computed as yMax for all characters in the Windows ANSI character set. The return value is equivalent to the GDI TEXTMETRIC.tmAscent.

See Also

FontFamily Class | FontFamily Members | System.Drawing Namespace


FontFamily.GetCellDescent

Returns the descender metric for Windows.

[Visual Basic]
Public Function GetCellDescent( _
   ByVal style As FontStyle _
) As Integer
[C#]
public int GetCellDescent(
   FontStyle style
);
[C++]
public: int GetCellDescent(
   FontStyle style
);
[JScript]
public function GetCellDescent(
   style : FontStyle
) : int;

Parameters

style
[To be supplied.]

Return Value

The descender metric for this FontFamily with the specified FontStyle.

Remarks

This value is computed as-yMin for all characters in the Windows ANSI character set. The return value is equivalent to the GDI TEXTMETRIC.tmDescent.

See Also

FontFamily Class | FontFamily Members | System.Drawing Namespace


FontFamily.GetEmHeight

Gets the size of the Em square for the specified style in font design units.

[Visual Basic]
Public Function GetEmHeight( _
   ByVal style As FontStyle _
) As Integer
[C#]
public int GetEmHeight(
   FontStyle style
);
[C++]
public: int GetEmHeight(
   FontStyle style
);
[JScript]
public function GetEmHeight(
   style : FontStyle
) : int;

Parameters

style
The FontStyle for which to get the Em height.

Return Value

The height of the Em square.

Remarks

The Em square is the basic metric by which fonts are sized, it is an imaginary square that is used to size and align glyphs. The dimensions of the em square typically are those of the full body height of a font plus some extra spacing to prevent lines of text from colliding when typeset without extra leading (spacing between lines).

See Also

FontFamily Class | FontFamily Members | System.Drawing Namespace


FontFamily.GetFamilies

Returns an array that contains all of the FontFamily objects associated with the specified graphics context.

[Visual Basic]
Public Shared Function GetFamilies( _
   ByVal graphics As Graphics _
) As FontFamily ()
[C#]
public static FontFamily[] GetFamilies(
   Graphics graphics
);
[C++]
public: static FontFamily* GetFamilies(
   Graphics* graphics
) [];
[JScript]
public static function GetFamilies(
   graphics : Graphics
) : FontFamily[];

Parameters

graphics
The Graphics from which to return FontFamily objects.

Return Value

An array of FontFamily objects associated with the specified Graphics.

See Also

FontFamily Class | FontFamily Members | System.Drawing Namespace


FontFamily.GetHashCode

Gets a hash code for this FontFamily.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

See Also

FontFamily Class | FontFamily Members | System.Drawing Namespace


FontFamily.GetLineSpacing

Returns the distance between two consecutive lines of text for this FontFamily with the specified FontStyle.

[Visual Basic]
Public Function GetLineSpacing( _
   ByVal style As FontStyle _
) As Integer
[C#]
public int GetLineSpacing(
   FontStyle style
);
[C++]
public: int GetLineSpacing(
   FontStyle style
);
[JScript]
public function GetLineSpacing(
   style : FontStyle
) : int;

Parameters

style
The FontStyle to apply.

Return Value

The distance between two consecutive lines of text.

See Also

FontFamily Class | FontFamily Members | System.Drawing Namespace


FontFamily.GetName

Retuns the name of this FontFamily in the specified language.

[Visual Basic]
Public Function GetName( _
   ByVal language As Integer _
) As String
[C#]
public string GetName(
   int language
);
[C++]
public: String* GetName(
   int language
);
[JScript]
public function GetName(
   language : int
) : String;

Parameters

language
The language in which the name is returned.

Return Value

A String that represents the name of this FontFamily in the specified language.

See Also

FontFamily Class | FontFamily Members | System.Drawing Namespace


FontFamily.IsStyleAvailable

Indicates whether the specified FontStyle is available.

[Visual Basic]
Public Function IsStyleAvailable( _
   ByVal style As FontStyle _
) As Boolean
[C#]
public bool IsStyleAvailable(
   FontStyle style
);
[C++]
public: bool IsStyleAvailable(
   FontStyle style
);
[JScript]
public function IsStyleAvailable(
   style : FontStyle
) : Boolean;

Parameters

style
The FontStyle to test.

See Also

FontFamily Class | FontFamily Members | System.Drawing Namespace


FontFamily.ToString

Converts this FontFamily to a human-readable string.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

The string that represents this FontFamily.

See Also

FontFamily Class | FontFamily Members | System.Drawing Namespace


FontStyle Enumeration

Specifies style information applied to text.

[Visual Basic]
Public Enum FontStyle
[C#]
public enum FontStyle
[C++]
public enum FontStyle

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Bold | Bold text.
BoldItalic | Bold and Italic text.
Italic | Italic text.
Regular | Normal text.
Strikeout | Text with a line through the middle.
Underline | Underlined text.

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

System.Drawing Namespace


Graphics Class

[To be supplied.]

Object
MarshalByRefObject
Graphics

[Visual Basic]
NotInheritable Public Class Graphics
   Inherits MarshalByRefObject
[C#]
public sealed class Graphics : MarshalByRefObject
[C++]
public __gc __sealed class Graphics : public MarshalByRefObject
[JScript]
public class Graphics extends MarshalByRefObject

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

Graphics Members | System.Drawing Namespace


Graphics Members

Public:

Properties

Clip | [To be supplied.]
ClipBounds | [To be supplied.]
CompositingMode | [To be supplied.]
CompositingQuality | [To be supplied.]
DpiX | [To be supplied.]
DpiY | [To be supplied.]
InterpolationMode | [To be supplied.]
IsClipEmpty | [To be supplied.]
IsVisibleClipEmpty | [To be supplied.]
PageScale | [To be supplied.]
PageUnit | [To be supplied.]
PixelOffsetMode | [To be supplied.]
RenderingOrigin | [To be supplied.]
SmoothingMode | [To be supplied.]
TextGammaValue | [To be supplied.]
TextRenderingHint | [To be supplied.]
Transform | [To be supplied.]
VisibleClipBounds | [To be supplied.]

Methods

AddMetafileComment | [To be supplied.]
BeginContainer | Overloaded. [To be supplied.]
Clear | [To be supplied.]
Dispose | [To be supplied.]
DrawArc | Overloaded. [To be supplied.]
DrawBezier | Overloaded. [To be supplied.]
DrawBeziers | Overloaded. [To be supplied.]
DrawClosedCurve | Overloaded. [To be supplied.]
DrawCurve | Overloaded. [To be supplied.]
DrawEllipse | Overloaded. [To be supplied.]
DrawIcon | Overloaded. [To be supplied.]
DrawIconUnstretched | Draws this image to a graphics object. The drawing command originates on the graphics object, but a graphics object generally has no idea how to render a given image. So, it passes the call to the actual image. This version stretches the image to the given dimensions and allows the user to specify a rectangle within the image to draw.
DrawImage | Overloaded. [To be supplied.]
DrawImageUnscaled | Overloaded. [To be supplied.]
DrawLine | Overloaded. [To be supplied.]
DrawLines | Overloaded. [To be supplied.]
DrawPath | [To be supplied.]
DrawPie | Overloaded. [To be supplied.]
DrawPolygon | Overloaded. [To be supplied.]
DrawRectangle | Overloaded. [To be supplied.]
DrawRectangles | Overloaded. [To be supplied.]
DrawString | Overloaded. [To be supplied.]
EndContainer | [To be supplied.]
EnumerateMetafile | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
ExcludeClip | Overloaded. [To be supplied.]
FillClosedCurve | Overloaded. [To be supplied.]
FillEllipse | Overloaded. [To be supplied.]
FillPath | [To be supplied.]
FillPie | Overloaded. [To be supplied.]
FillPolygon | Overloaded. [To be supplied.]
FillRectangle | Overloaded. [To be supplied.]
FillRectangles | Overloaded. [To be supplied.]
FillRegion | [To be supplied.]
Flush | Overloaded. [To be supplied.]
FromHDC | Overloaded. [To be supplied.]
FromHWND | [To be supplied.]
FromImage | [To be supplied.]
GetHalftonePalette | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHDC | [To be supplied.]
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetNearestColor | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
IntersectClip | Overloaded. [To be supplied.]
IsVisible | Overloaded. [To be supplied.]
MeasureString | Overloaded. [To be supplied.]
MeasureStringRegion | [To be supplied.]
MultiplyTransform | Overloaded. [To be supplied.]
ReleaseHDC | [To be supplied.]
ResetClip | [To be supplied.]
ResetTransform | [To be supplied.]
Restore | [To be supplied.]
RotateTransform | Overloaded. [To be supplied.]
Save | [To be supplied.]
ScaleTransform | Overloaded. [To be supplied.]
SetClip | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.
TransformPoints | Overloaded. [To be supplied.]
TranslateClip | Overloaded. [To be supplied.]
TranslateTransform | Overloaded. [To be supplied.]

Protected:

Methods

Finalize | Deletes this Graphics, and frees the memory allocated for it.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Graphics Class | System.Drawing Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Graphics Properties

The properties of the Graphics class are listed below. For a complete list of Graphics class members, see the Graphics Members topic.

Public:

Clip | [To be supplied.]
ClipBounds | [To be supplied.]
CompositingMode | [To be supplied.]
CompositingQuality | [To be supplied.]
DpiX | [To be supplied.]
DpiY | [To be supplied.]
InterpolationMode | [To be supplied.]
IsClipEmpty | [To be supplied.]
IsVisibleClipEmpty | [To be supplied.]
PageScale | [To be supplied.]
PageUnit | [To be supplied.]
PixelOffsetMode | [To be supplied.]
RenderingOrigin | [To be supplied.]
SmoothingMode | [To be supplied.]
TextGammaValue | [To be supplied.]
TextRenderingHint | [To be supplied.]
Transform | [To be supplied.]
VisibleClipBounds | [To be supplied.]

See Also

Graphics Class | System.Drawing Namespace


Graphics.Clip

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Clip As Region
[C#]
public Region Clip {get;}
[C++]
public: __property Region* get_Clip();
[JScript]
public function get Clip() : Region;

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.ClipBounds

[To be supplied.]

[Visual Basic]
Public ReadOnly Property ClipBounds As RectangleF
[C#]
public RectangleF ClipBounds {get;}
[C++]
public: __property RectangleF get_ClipBounds();
[JScript]
public function get ClipBounds() : RectangleF;

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.CompositingMode

[To be supplied.]

[Visual Basic]
Public Property CompositingMode As CompositingMode
[C#]
public CompositingMode CompositingMode {get; set;}
[C++]
public: __property CompositingMode get_CompositingMode();
public: __property void set_CompositingMode(CompositingMode);
[JScript]
public function get CompositingMode() : CompositingMode;
public function set CompositingMode(CompositingMode);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.CompositingQuality

[To be supplied.]

[Visual Basic]
Public Property CompositingQuality As CompositingQuality
[C#]
public CompositingQuality CompositingQuality {get; set;}
[C++]
public: __property CompositingQuality get_CompositingQuality();
public: __property void set_CompositingQuality(CompositingQuality);
[JScript]
public function get CompositingQuality() : CompositingQuality;
public function set CompositingQuality(CompositingQuality);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.DpiX

[To be supplied.]

[Visual Basic]
Public ReadOnly Property DpiX As Single
[C#]
public float DpiX {get;}
[C++]
public: __property float get_DpiX();
[JScript]
public function get DpiX() : float;

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.DpiY

[To be supplied.]

[Visual Basic]
Public ReadOnly Property DpiY As Single
[C#]
public float DpiY {get;}
[C++]
public: __property float get_DpiY();
[JScript]
public function get DpiY() : float;

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.InterpolationMode

[To be supplied.]

[Visual Basic]
Public Property InterpolationMode As InterpolationMode
[C#]
public InterpolationMode InterpolationMode {get; set;}
[C++]
public: __property InterpolationMode get_InterpolationMode();
public: __property void set_InterpolationMode(InterpolationMode);
[JScript]
public function get InterpolationMode() : InterpolationMode;
public function set InterpolationMode(InterpolationMode);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.IsClipEmpty

[To be supplied.]

[Visual Basic]
Public ReadOnly Property IsClipEmpty As Boolean
[C#]
public bool IsClipEmpty {get;}
[C++]
public: __property bool get_IsClipEmpty();
[JScript]
public function get IsClipEmpty() : Boolean;

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.IsVisibleClipEmpty

[To be supplied.]

[Visual Basic]
Public ReadOnly Property IsVisibleClipEmpty As Boolean
[C#]
public bool IsVisibleClipEmpty {get;}
[C++]
public: __property bool get_IsVisibleClipEmpty();
[JScript]
public function get IsVisibleClipEmpty() : Boolean;

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.PageScale

[To be supplied.]

[Visual Basic]
Public Property PageScale As Single
[C#]
public float PageScale {get; set;}
[C++]
public: __property float get_PageScale();
public: __property void set_PageScale(float);
[JScript]
public function get PageScale() : float;
public function set PageScale(float);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.PageUnit

[To be supplied.]

[Visual Basic]
Public Property PageUnit As GraphicsUnit
[C#]
public GraphicsUnit PageUnit {get; set;}
[C++]
public: __property GraphicsUnit get_PageUnit();
public: __property void set_PageUnit(GraphicsUnit);
[JScript]
public function get PageUnit() : GraphicsUnit;
public function set PageUnit(GraphicsUnit);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.PixelOffsetMode

[To be supplied.]

[Visual Basic]
Public Property PixelOffsetMode As PixelOffsetMode
[C#]
public PixelOffsetMode PixelOffsetMode {get; set;}
[C++]
public: __property PixelOffsetMode get_PixelOffsetMode();
public: __property void set_PixelOffsetMode(PixelOffsetMode);
[JScript]
public function get PixelOffsetMode() : PixelOffsetMode;
public function set PixelOffsetMode(PixelOffsetMode);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.RenderingOrigin

[To be supplied.]

[Visual Basic]
Public Property RenderingOrigin As Point
[C#]
public Point RenderingOrigin {get; set;}
[C++]
public: __property Point get_RenderingOrigin();
public: __property void set_RenderingOrigin(Point);
[JScript]
public function get RenderingOrigin() : Point;
public function set RenderingOrigin(Point);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.SmoothingMode

[To be supplied.]

[Visual Basic]
Public Property SmoothingMode As SmoothingMode
[C#]
public SmoothingMode SmoothingMode {get; set;}
[C++]
public: __property SmoothingMode get_SmoothingMode();
public: __property void set_SmoothingMode(SmoothingMode);
[JScript]
public function get SmoothingMode() : SmoothingMode;
public function set SmoothingMode(SmoothingMode);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.TextGammaValue

[To be supplied.]

[Visual Basic]
Public Property TextGammaValue As Integer
[C#]
public int TextGammaValue {get; set;}
[C++]
public: __property int get_TextGammaValue();
public: __property void set_TextGammaValue(int);
[JScript]
public function get TextGammaValue() : int;
public function set TextGammaValue(int);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.TextRenderingHint

[To be supplied.]

[Visual Basic]
Public Property TextRenderingHint As TextRenderingHint
[C#]
public TextRenderingHint TextRenderingHint {get; set;}
[C++]
public: __property TextRenderingHint get_TextRenderingHint();
public: __property void set_TextRenderingHint(TextRenderingHint);
[JScript]
public function get TextRenderingHint() : TextRenderingHint;
public function set TextRenderingHint(TextRenderingHint);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.Transform

[To be supplied.]

[Visual Basic]
Public Property Transform As Matrix
[C#]
public Matrix Transform {get; set;}
[C++]
public: __property Matrix* get_Transform();
public: __property void set_Transform(Matrix*);
[JScript]
public function get Transform() : Matrix;
public function set Transform(Matrix);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.VisibleClipBounds

[To be supplied.]

[Visual Basic]
Public ReadOnly Property VisibleClipBounds As RectangleF
[C#]
public RectangleF VisibleClipBounds {get;}
[C++]
public: __property RectangleF get_VisibleClipBounds();
[JScript]
public function get VisibleClipBounds() : RectangleF;

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Graphics Methods

The methods of the Graphics class are listed below. For a complete list of Graphics class members, see the Graphics Members topic.

Public:

AddMetafileComment | [To be supplied.]
BeginContainer | Overloaded. [To be supplied.]
Clear | [To be supplied.]
Dispose | [To be supplied.]
DrawArc | Overloaded. [To be supplied.]
DrawBezier | Overloaded. [To be supplied.]
DrawBeziers | Overloaded. [To be supplied.]
DrawClosedCurve | Overloaded. [To be supplied.]
DrawCurve | Overloaded. [To be supplied.]
DrawEllipse | Overloaded. [To be supplied.]
DrawIcon | Overloaded. [To be supplied.]
DrawIconUnstretched | Draws this image to a graphics object. The drawing command originates on the graphics object, but a graphics object generally has no idea how to render a given image. So, it passes the call to the actual image. This version stretches the image to the given dimensions and allows the user to specify a rectangle within the image to draw.
DrawImage | Overloaded. [To be supplied.]
DrawImageUnscaled | Overloaded. [To be supplied.]
DrawLine | Overloaded. [To be supplied.]
DrawLines | Overloaded. [To be supplied.]
DrawPath | [To be supplied.]
DrawPie | Overloaded. [To be supplied.]
DrawPolygon | Overloaded. [To be supplied.]
DrawRectangle | Overloaded. [To be supplied.]
DrawRectangles | Overloaded. [To be supplied.]
DrawString | Overloaded. [To be supplied.]
EndContainer | [To be supplied.]
EnumerateMetafile | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
ExcludeClip | Overloaded. [To be supplied.]
FillClosedCurve | Overloaded. [To be supplied.]
FillEllipse | Overloaded. [To be supplied.]
FillPath | [To be supplied.]
FillPie | Overloaded. [To be supplied.]
FillPolygon | Overloaded. [To be supplied.]
FillRectangle | Overloaded. [To be supplied.]
FillRectangles | Overloaded. [To be supplied.]
FillRegion | [To be supplied.]
Flush | Overloaded. [To be supplied.]
FromHDC | Overloaded. [To be supplied.]
FromHWND | [To be supplied.]
FromImage | [To be supplied.]
GetHalftonePalette | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHDC | [To be supplied.]
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetNearestColor | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
IntersectClip | Overloaded. [To be supplied.]
IsVisible | Overloaded. [To be supplied.]
MeasureString | Overloaded. [To be supplied.]
MeasureStringRegion | [To be supplied.]
MultiplyTransform | Overloaded. [To be supplied.]
ReleaseHDC | [To be supplied.]
ResetClip | [To be supplied.]
ResetTransform | [To be supplied.]
Restore | [To be supplied.]
RotateTransform | Overloaded. [To be supplied.]
Save | [To be supplied.]
ScaleTransform | Overloaded. [To be supplied.]
SetClip | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.
TransformPoints | Overloaded. [To be supplied.]
TranslateClip | Overloaded. [To be supplied.]
TranslateTransform | Overloaded. [To be supplied.]

Protected:

Finalize | Deletes this Graphics, and frees the memory allocated for it.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Graphics Class | System.Drawing Namespace


Graphics.AddMetafileComment

[To be supplied.]

[Visual Basic]
Public Sub AddMetafileComment( _
   ByVal data() As Byte _
)
[C#]
public void AddMetafileComment(
   byte[] data
);
[C++]
public: void AddMetafileComment(
   unsigned char* data[]
);
[JScript]
public function AddMetafileComment(
   data : Byte[]
);

Parameters

data
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.BeginContainer

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function BeginContainer(RectangleF, RectangleF, GraphicsUnit) As GraphicsContainer
[C#] public GraphicsContainer BeginContainer(RectangleF, RectangleF, GraphicsUnit);
[C++] public: GraphicsContainer* BeginContainer(RectangleF, RectangleF, GraphicsUnit);
[JScript] public function BeginContainer(RectangleF, RectangleF, GraphicsUnit) : GraphicsContainer;

[To be supplied.]

[Visual Basic] Overloads Public Function BeginContainer() As GraphicsContainer
[C#] public GraphicsContainer BeginContainer();
[C++] public: GraphicsContainer* BeginContainer();
[JScript] public function BeginContainer() : GraphicsContainer;

[To be supplied.]

[Visual Basic] Overloads Public Function BeginContainer(Rectangle, Rectangle, GraphicsUnit) As GraphicsContainer
[C#] public GraphicsContainer BeginContainer(Rectangle, Rectangle, GraphicsUnit);
[C++] public: GraphicsContainer* BeginContainer(Rectangle, Rectangle, GraphicsUnit);
[JScript] public function BeginContainer(Rectangle, Rectangle, GraphicsUnit) : GraphicsContainer;

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.BeginContainer (RectangleF, RectangleF, GraphicsUnit)

[To be supplied.]

[Visual Basic]
Overloads Public Function BeginContainer( _
   ByVal dstrect As RectangleF, _
   ByVal srcrect As RectangleF, _
   ByVal unit As GraphicsUnit _
) As GraphicsContainer
[C#]
public GraphicsContainer BeginContainer(
   RectangleF dstrect,
   RectangleF srcrect,
   GraphicsUnit unit
);
[C++]
public: GraphicsContainer* BeginContainer(
   RectangleF dstrect,
   RectangleF srcrect,
   GraphicsUnit unit
);
[JScript]
public function BeginContainer(
   dstrect : RectangleF,
   srcrect : RectangleF,
   unit : GraphicsUnit
) : GraphicsContainer;

Parameters

dstrect
[To be supplied.]
srcrect
[To be supplied.]
unit
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.BeginContainer Overload List


Graphics.BeginContainer ()

[To be supplied.]

[Visual Basic]
Overloads Public Function BeginContainer() As GraphicsContainer
[C#]
public GraphicsContainer BeginContainer();
[C++]
public: GraphicsContainer* BeginContainer();
[JScript]
public function BeginContainer() : GraphicsContainer;

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.BeginContainer Overload List


Graphics.BeginContainer (Rectangle, Rectangle, GraphicsUnit)

[To be supplied.]

[Visual Basic]
Overloads Public Function BeginContainer( _
   ByVal dstrect As Rectangle, _
   ByVal srcrect As Rectangle, _
   ByVal unit As GraphicsUnit _
) As GraphicsContainer
[C#]
public GraphicsContainer BeginContainer(
   Rectangle dstrect,
   Rectangle srcrect,
   GraphicsUnit unit
);
[C++]
public: GraphicsContainer* BeginContainer(
   Rectangle dstrect,
   Rectangle srcrect,
   GraphicsUnit unit
);
[JScript]
public function BeginContainer(
   dstrect : Rectangle,
   srcrect : Rectangle,
   unit : GraphicsUnit
) : GraphicsContainer;

Parameters

dstrect
[To be supplied.]
srcrect
[To be supplied.]
unit
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.BeginContainer Overload List


Graphics.Clear

[To be supplied.]

[Visual Basic]
Public Sub Clear( _
   ByVal color As Color _
)
[C#]
public void Clear(
   Color color
);
[C++]
public: void Clear(
   Color color
);
[JScript]
public function Clear(
   color : Color
);

Parameters

color
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.Dispose

[To be supplied.]

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[JScript]
public function Dispose();

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.DrawArc

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawArc(Pen, Integer, Integer, Integer, Integer, Integer, Integer)
[C#] public void DrawArc(Pen, int, int, int, int, int, int);
[C++] public: void DrawArc(Pen*, int, int, int, int, int, int);
[JScript] public function DrawArc(Pen, int, int, int, int, int, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawArc(Pen, RectangleF, Single, Single)
[C#] public void DrawArc(Pen, RectangleF, float, float);
[C++] public: void DrawArc(Pen*, RectangleF, float, float);
[JScript] public function DrawArc(Pen, RectangleF, float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawArc(Pen, Single, Single, Single, Single, Single, Single)
[C#] public void DrawArc(Pen, float, float, float, float, float, float);
[C++] public: void DrawArc(Pen*, float, float, float, float, float, float);
[JScript] public function DrawArc(Pen, float, float, float, float, float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawArc(Pen, Rectangle, Single, Single)
[C#] public void DrawArc(Pen, Rectangle, float, float);
[C++] public: void DrawArc(Pen*, Rectangle, float, float);
[JScript] public function DrawArc(Pen, Rectangle, float, float);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.DrawArc (Pen, Int32, Int32, Int32, Int32, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawArc( _
   ByVal pen As Pen, _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal startAngle As Integer, _
   ByVal sweepAngle As Integer _
)
[C#]
public void DrawArc(
   Pen pen,
   int x,
   int y,
   int width,
   int height,
   int startAngle,
   int sweepAngle
);
[C++]
public: void DrawArc(
   Pen* pen,
   int x,
   int y,
   int width,
   int height,
   int startAngle,
   int sweepAngle
);
[JScript]
public function DrawArc(
   pen : Pen,
   x : int,
   y : int,
   width : int,
   height : int,
   startAngle : int,
   sweepAngle : int
);

Parameters

pen
[To be supplied.]
x
[To be supplied.]
y
[To be supplied.]
width
[To be supplied.]
height
[To be supplied.]
startAngle
[To be supplied.]
sweepAngle
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawArc Overload List


Graphics.DrawArc (Pen, RectangleF, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawArc( _
   ByVal pen As Pen, _
   ByVal rect As RectangleF, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
[C#]
public void DrawArc(
   Pen pen,
   RectangleF rect,
   float startAngle,
   float sweepAngle
);
[C++]
public: void DrawArc(
   Pen* pen,
   RectangleF rect,
   float startAngle,
   float sweepAngle
);
[JScript]
public function DrawArc(
   pen : Pen,
   rect : RectangleF,
   startAngle : float,
   sweepAngle : float
);

Parameters

pen
[To be supplied.]
rect
[To be supplied.]
startAngle
[To be supplied.]
sweepAngle
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawArc Overload List


Graphics.DrawArc (Pen, Single, Single, Single, Single, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawArc( _
   ByVal pen As Pen, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
[C#]
public void DrawArc(
   Pen pen,
   float x,
   float y,
   float width,
   float height,
   float startAngle,
   float sweepAngle
);
[C++]
public: void DrawArc(
   Pen* pen,
   float x,
   float y,
   float width,
   float height,
   float startAngle,
   float sweepAngle
);
[JScript]
public function DrawArc(
   pen : Pen,
   x : float,
   y : float,
   width : float,
   height : float,
   startAngle : float,
   sweepAngle : float
);

Parameters

pen
[To be supplied.]
x
[To be supplied.]
y
[To be supplied.]
width
[To be supplied.]
height
[To be supplied.]
startAngle
[To be supplied.]
sweepAngle
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawArc Overload List


Graphics.DrawArc (Pen, Rectangle, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawArc( _
   ByVal pen As Pen, _
   ByVal rect As Rectangle, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
[C#]
public void DrawArc(
   Pen pen,
   Rectangle rect,
   float startAngle,
   float sweepAngle
);
[C++]
public: void DrawArc(
   Pen* pen,
   Rectangle rect,
   float startAngle,
   float sweepAngle
);
[JScript]
public function DrawArc(
   pen : Pen,
   rect : Rectangle,
   startAngle : float,
   sweepAngle : float
);

Parameters

pen
[To be supplied.]
rect
[To be supplied.]
startAngle
[To be supplied.]
sweepAngle
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawArc Overload List


Graphics.DrawBezier

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawBezier(Pen, Point, Point, Point, Point)
[C#] public void DrawBezier(Pen, Point, Point, Point, Point);
[C++] public: void DrawBezier(Pen*, Point, Point, Point, Point);
[JScript] public function DrawBezier(Pen, Point, Point, Point, Point);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawBezier(Pen, PointF, PointF, PointF, PointF)
[C#] public void DrawBezier(Pen, PointF, PointF, PointF, PointF);
[C++] public: void DrawBezier(Pen*, PointF, PointF, PointF, PointF);
[JScript] public function DrawBezier(Pen, PointF, PointF, PointF, PointF);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawBezier(Pen, Single, Single, Single, Single, Single, Single, Single, Single)
[C#] public void DrawBezier(Pen, float, float, float, float, float, float, float, float);
[C++] public: void DrawBezier(Pen*, float, float, float, float, float, float, float, float);
[JScript] public function DrawBezier(Pen, float, float, float, float, float, float, float, float);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.DrawBezier (Pen, Point, Point, Point, Point)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawBezier( _
   ByVal pen As Pen, _
   ByVal pt1 As Point, _
   ByVal pt2 As Point, _
   ByVal pt3 As Point, _
   ByVal pt4 As Point _
)
[C#]
public void DrawBezier(
   Pen pen,
   Point pt1,
   Point pt2,
   Point pt3,
   Point pt4
);
[C++]
public: void DrawBezier(
   Pen* pen,
   Point pt1,
   Point pt2,
   Point pt3,
   Point pt4
);
[JScript]
public function DrawBezier(
   pen : Pen,
   pt1 : Point,
   pt2 : Point,
   pt3 : Point,
   pt4 : Point
);

Parameters

pen
[To be supplied.]
pt1
[To be supplied.]
pt2
[To be supplied.]
pt3
[To be supplied.]
pt4
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawBezier Overload List


Graphics.DrawBezier (Pen, PointF, PointF, PointF, PointF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawBezier( _
   ByVal pen As Pen, _
   ByVal pt1 As PointF, _
   ByVal pt2 As PointF, _
   ByVal pt3 As PointF, _
   ByVal pt4 As PointF _
)
[C#]
public void DrawBezier(
   Pen pen,
   PointF pt1,
   PointF pt2,
   PointF pt3,
   PointF pt4
);
[C++]
public: void DrawBezier(
   Pen* pen,
   PointF pt1,
   PointF pt2,
   PointF pt3,
   PointF pt4
);
[JScript]
public function DrawBezier(
   pen : Pen,
   pt1 : PointF,
   pt2 : PointF,
   pt3 : PointF,
   pt4 : PointF
);

Parameters

pen
[To be supplied.]
pt1
[To be supplied.]
pt2
[To be supplied.]
pt3
[To be supplied.]
pt4
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawBezier Overload List


Graphics.DrawBezier (Pen, Single, Single, Single, Single, Single, Single, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawBezier( _
   ByVal pen As Pen, _
   ByVal x1 As Single, _
   ByVal y1 As Single, _
   ByVal x2 As Single, _
   ByVal y2 As Single, _
   ByVal x3 As Single, _
   ByVal y3 As Single, _
   ByVal x4 As Single, _
   ByVal y4 As Single _
)
[C#]
public void DrawBezier(
   Pen pen,
   float x1,
   float y1,
   float x2,
   float y2,
   float x3,
   float y3,
   float x4,
   float y4
);
[C++]
public: void DrawBezier(
   Pen* pen,
   float x1,
   float y1,
   float x2,
   float y2,
   float x3,
   float y3,
   float x4,
   float y4
);
[JScript]
public function DrawBezier(
   pen : Pen,
   x1 : float,
   y1 : float,
   x2 : float,
   y2 : float,
   x3 : float,
   y3 : float,
   x4 : float,
   y4 : float
);

Parameters

pen
[To be supplied.]
x1
[To be supplied.]
y1
[To be supplied.]
x2
[To be supplied.]
y2
[To be supplied.]
x3
[To be supplied.]
y3
[To be supplied.]
x4
[To be supplied.]
y4
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawBezier Overload List


Graphics.DrawBeziers

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawBeziers(Pen, Point())
[C#] public void DrawBeziers(Pen, Point[]);
[C++] public: void DrawBeziers(Pen*, Point[]);
[JScript] public function DrawBeziers(Pen, Point[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawBeziers(Pen, PointF())
[C#] public void DrawBeziers(Pen, PointF[]);
[C++] public: void DrawBeziers(Pen*, PointF[]);
[JScript] public function DrawBeziers(Pen, PointF[]);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.DrawBeziers (Pen, Point[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawBeziers( _
   ByVal pen As Pen, _
   ByVal points() As Point _
)
[C#]
public void DrawBeziers(
   Pen pen,
   Point[] points
);
[C++]
public: void DrawBeziers(
   Pen* pen,
   Point* points[]
);
[JScript]
public function DrawBeziers(
   pen : Pen,
   points : Point[]
);

Parameters

pen
[To be supplied.]
points
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawBeziers Overload List


Graphics.DrawBeziers (Pen, PointF[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawBeziers( _
   ByVal pen As Pen, _
   ByVal points() As PointF _
)
[C#]
public void DrawBeziers(
   Pen pen,
   PointF[] points
);
[C++]
public: void DrawBeziers(
   Pen* pen,
   PointF* points[]
);
[JScript]
public function DrawBeziers(
   pen : Pen,
   points : PointF[]
);

Parameters

pen
[To be supplied.]
points
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawBeziers Overload List


Graphics.DrawClosedCurve

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawClosedCurve(Pen, PointF())
[C#] public void DrawClosedCurve(Pen, PointF[]);
[C++] public: void DrawClosedCurve(Pen*, PointF[]);
[JScript] public function DrawClosedCurve(Pen, PointF[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawClosedCurve(Pen, Point(), Single, FillMode)
[C#] public void DrawClosedCurve(Pen, Point[], float, FillMode);
[C++] public: void DrawClosedCurve(Pen*, Point[], float, FillMode);
[JScript] public function DrawClosedCurve(Pen, Point[], float, FillMode);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawClosedCurve(Pen, PointF(), Single, FillMode)
[C#] public void DrawClosedCurve(Pen, PointF[], float, FillMode);
[C++] public: void DrawClosedCurve(Pen*, PointF[], float, FillMode);
[JScript] public function DrawClosedCurve(Pen, PointF[], float, FillMode);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawClosedCurve(Pen, Point())
[C#] public void DrawClosedCurve(Pen, Point[]);
[C++] public: void DrawClosedCurve(Pen*, Point[]);
[JScript] public function DrawClosedCurve(Pen, Point[]);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.DrawClosedCurve (Pen, PointF[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawClosedCurve( _
   ByVal pen As Pen, _
   ByVal points() As PointF _
)
[C#]
public void DrawClosedCurve(
   Pen pen,
   PointF[] points
);
[C++]
public: void DrawClosedCurve(
   Pen* pen,
   PointF* points[]
);
[JScript]
public function DrawClosedCurve(
   pen : Pen,
   points : PointF[]
);

Parameters

pen
[To be supplied.]
points
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawClosedCurve Overload List


Graphics.DrawClosedCurve (Pen, Point[], Single, FillMode)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawClosedCurve( _
   ByVal pen As Pen, _
   ByVal points() As Point, _
   ByVal tension As Single, _
   ByVal fillmode As FillMode _
)
[C#]
public void DrawClosedCurve(
   Pen pen,
   Point[] points,
   float tension,
   FillMode fillmode
);
[C++]
public: void DrawClosedCurve(
   Pen* pen,
   Point* points[],
   float tension,
   FillMode fillmode
);
[JScript]
public function DrawClosedCurve(
   pen : Pen,
   points : Point[],
   tension : float,
   fillmode : FillMode
);

Parameters

pen
[To be supplied.]
points
[To be supplied.]
tension
[To be supplied.]
fillmode
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawClosedCurve Overload List


Graphics.DrawClosedCurve (Pen, PointF[], Single, FillMode)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawClosedCurve( _
   ByVal pen As Pen, _
   ByVal points() As PointF, _
   ByVal tension As Single, _
   ByVal fillmode As FillMode _
)
[C#]
public void DrawClosedCurve(
   Pen pen,
   PointF[] points,
   float tension,
   FillMode fillmode
);
[C++]
public: void DrawClosedCurve(
   Pen* pen,
   PointF* points[],
   float tension,
   FillMode fillmode
);
[JScript]
public function DrawClosedCurve(
   pen : Pen,
   points : PointF[],
   tension : float,
   fillmode : FillMode
);

Parameters

pen
[To be supplied.]
points
[To be supplied.]
tension
[To be supplied.]
fillmode
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawClosedCurve Overload List


Graphics.DrawClosedCurve (Pen, Point[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawClosedCurve( _
   ByVal pen As Pen, _
   ByVal points() As Point _
)
[C#]
public void DrawClosedCurve(
   Pen pen,
   Point[] points
);
[C++]
public: void DrawClosedCurve(
   Pen* pen,
   Point* points[]
);
[JScript]
public function DrawClosedCurve(
   pen : Pen,
   points : Point[]
);

Parameters

pen
[To be supplied.]
points
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawClosedCurve Overload List


Graphics.DrawCurve

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawCurve(Pen, PointF(), Integer, Integer)
[C#] public void DrawCurve(Pen, PointF[], int, int);
[C++] public: void DrawCurve(Pen*, PointF[], int, int);
[JScript] public function DrawCurve(Pen, PointF[], int, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawCurve(Pen, PointF(), Single)
[C#] public void DrawCurve(Pen, PointF[], float);
[C++] public: void DrawCurve(Pen*, PointF[], float);
[JScript] public function DrawCurve(Pen, PointF[], float);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawCurve(Pen, PointF())
[C#] public void DrawCurve(Pen, PointF[]);
[C++] public: void DrawCurve(Pen*, PointF[]);
[JScript] public function DrawCurve(Pen, PointF[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawCurve(Pen, PointF(), Integer, Integer, Single)
[C#] public void DrawCurve(Pen, PointF[], int, int, float);
[C++] public: void DrawCurve(Pen*, PointF[], int, int, float);
[JScript] public function DrawCurve(Pen, PointF[], int, int, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawCurve(Pen, Point())
[C#] public void DrawCurve(Pen, Point[]);
[C++] public: void DrawCurve(Pen*, Point[]);
[JScript] public function DrawCurve(Pen, Point[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawCurve(Pen, Point(), Single)
[C#] public void DrawCurve(Pen, Point[], float);
[C++] public: void DrawCurve(Pen*, Point[], float);
[JScript] public function DrawCurve(Pen, Point[], float);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawCurve(Pen, Point(), Integer, Integer, Single)
[C#] public void DrawCurve(Pen, Point[], int, int, float);
[C++] public: void DrawCurve(Pen*, Point[], int, int, float);
[JScript] public function DrawCurve(Pen, Point[], int, int, float);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.DrawCurve (Pen, PointF[], Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawCurve( _
   ByVal pen As Pen, _
   ByVal points() As PointF, _
   ByVal offset As Integer, _
   ByVal numberOfSegments As Integer _
)
[C#]
public void DrawCurve(
   Pen pen,
   PointF[] points,
   int offset,
   int numberOfSegments
);
[C++]
public: void DrawCurve(
   Pen* pen,
   PointF* points[],
   int offset,
   int numberOfSegments
);
[JScript]
public function DrawCurve(
   pen : Pen,
   points : PointF[],
   offset : int,
   numberOfSegments : int
);

Parameters

pen
[To be supplied.]
points
[To be supplied.]
offset
[To be supplied.]
numberOfSegments
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawCurve Overload List


Graphics.DrawCurve (Pen, PointF[], Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawCurve( _
   ByVal pen As Pen, _
   ByVal points() As PointF, _
   ByVal tension As Single _
)
[C#]
public void DrawCurve(
   Pen pen,
   PointF[] points,
   float tension
);
[C++]
public: void DrawCurve(
   Pen* pen,
   PointF* points[],
   float tension
);
[JScript]
public function DrawCurve(
   pen : Pen,
   points : PointF[],
   tension : float
);

Parameters

pen
[To be supplied.]
points
[To be supplied.]
tension
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawCurve Overload List


Graphics.DrawCurve (Pen, PointF[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawCurve( _
   ByVal pen As Pen, _
   ByVal points() As PointF _
)
[C#]
public void DrawCurve(
   Pen pen,
   PointF[] points
);
[C++]
public: void DrawCurve(
   Pen* pen,
   PointF* points[]
);
[JScript]
public function DrawCurve(
   pen : Pen,
   points : PointF[]
);

Parameters

pen
[To be supplied.]
points
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawCurve Overload List


Graphics.DrawCurve (Pen, PointF[], Int32, Int32, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawCurve( _
   ByVal pen As Pen, _
   ByVal points() As PointF, _
   ByVal offset As Integer, _
   ByVal numberOfSegments As Integer, _
   ByVal tension As Single _
)
[C#]
public void DrawCurve(
   Pen pen,
   PointF[] points,
   int offset,
   int numberOfSegments,
   float tension
);
[C++]
public: void DrawCurve(
   Pen* pen,
   PointF* points[],
   int offset,
   int numberOfSegments,
   float tension
);
[JScript]
public function DrawCurve(
   pen : Pen,
   points : PointF[],
   offset : int,
   numberOfSegments : int,
   tension : float
);

Parameters

pen
[To be supplied.]
points
[To be supplied.]
offset
[To be supplied.]
numberOfSegments
[To be supplied.]
tension
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawCurve Overload List


Graphics.DrawCurve (Pen, Point[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawCurve( _
   ByVal pen As Pen, _
   ByVal points() As Point _
)
[C#]
public void DrawCurve(
   Pen pen,
   Point[] points
);
[C++]
public: void DrawCurve(
   Pen* pen,
   Point* points[]
);
[JScript]
public function DrawCurve(
   pen : Pen,
   points : Point[]
);

Parameters

pen
[To be supplied.]
points
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawCurve Overload List


Graphics.DrawCurve (Pen, Point[], Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawCurve( _
   ByVal pen As Pen, _
   ByVal points() As Point, _
   ByVal tension As Single _
)
[C#]
public void DrawCurve(
   Pen pen,
   Point[] points,
   float tension
);
[C++]
public: void DrawCurve(
   Pen* pen,
   Point* points[],
   float tension
);
[JScript]
public function DrawCurve(
   pen : Pen,
   points : Point[],
   tension : float
);

Parameters

pen
[To be supplied.]
points
[To be supplied.]
tension
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawCurve Overload List


Graphics.DrawCurve (Pen, Point[], Int32, Int32, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawCurve( _
   ByVal pen As Pen, _
   ByVal points() As Point, _
   ByVal offset As Integer, _
   ByVal numberOfSegments As Integer, _
   ByVal tension As Single _
)
[C#]
public void DrawCurve(
   Pen pen,
   Point[] points,
   int offset,
   int numberOfSegments,
   float tension
);
[C++]
public: void DrawCurve(
   Pen* pen,
   Point* points[],
   int offset,
   int numberOfSegments,
   float tension
);
[JScript]
public function DrawCurve(
   pen : Pen,
   points : Point[],
   offset : int,
   numberOfSegments : int,
   tension : float
);

Parameters

pen
[To be supplied.]
points
[To be supplied.]
offset
[To be supplied.]
numberOfSegments
[To be supplied.]
tension
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawCurve Overload List


Graphics.DrawEllipse

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawEllipse(Pen, Rectangle)
[C#] public void DrawEllipse(Pen, Rectangle);
[C++] public: void DrawEllipse(Pen*, Rectangle);
[JScript] public function DrawEllipse(Pen, Rectangle);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawEllipse(Pen, Integer, Integer, Integer, Integer)
[C#] public void DrawEllipse(Pen, int, int, int, int);
[C++] public: void DrawEllipse(Pen*, int, int, int, int);
[JScript] public function DrawEllipse(Pen, int, int, int, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawEllipse(Pen, Single, Single, Single, Single)
[C#] public void DrawEllipse(Pen, float, float, float, float);
[C++] public: void DrawEllipse(Pen*, float, float, float, float);
[JScript] public function DrawEllipse(Pen, float, float, float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawEllipse(Pen, RectangleF)
[C#] public void DrawEllipse(Pen, RectangleF);
[C++] public: void DrawEllipse(Pen*, RectangleF);
[JScript] public function DrawEllipse(Pen, RectangleF);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.DrawEllipse (Pen, Rectangle)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawEllipse( _
   ByVal pen As Pen, _
   ByVal rect As Rectangle _
)
[C#]
public void DrawEllipse(
   Pen pen,
   Rectangle rect
);
[C++]
public: void DrawEllipse(
   Pen* pen,
   Rectangle rect
);
[JScript]
public function DrawEllipse(
   pen : Pen,
   rect : Rectangle
);

Parameters

pen
[To be supplied.]
rect
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawEllipse Overload List


Graphics.DrawEllipse (Pen, Int32, Int32, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawEllipse( _
   ByVal pen As Pen, _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer _
)
[C#]
public void DrawEllipse(
   Pen pen,
   int x,
   int y,
   int width,
   int height
);
[C++]
public: void DrawEllipse(
   Pen* pen,
   int x,
   int y,
   int width,
   int height
);
[JScript]
public function DrawEllipse(
   pen : Pen,
   x : int,
   y : int,
   width : int,
   height : int
);

Parameters

pen
[To be supplied.]
x
[To be supplied.]
y
[To be supplied.]
width
[To be supplied.]
height
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawEllipse Overload List


Graphics.DrawEllipse (Pen, Single, Single, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawEllipse( _
   ByVal pen As Pen, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
[C#]
public void DrawEllipse(
   Pen pen,
   float x,
   float y,
   float width,
   float height
);
[C++]
public: void DrawEllipse(
   Pen* pen,
   float x,
   float y,
   float width,
   float height
);
[JScript]
public function DrawEllipse(
   pen : Pen,
   x : float,
   y : float,
   width : float,
   height : float
);

Parameters

pen
[To be supplied.]
x
[To be supplied.]
y
[To be supplied.]
width
[To be supplied.]
height
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawEllipse Overload List


Graphics.DrawEllipse (Pen, RectangleF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawEllipse( _
   ByVal pen As Pen, _
   ByVal rect As RectangleF _
)
[C#]
public void DrawEllipse(
   Pen pen,
   RectangleF rect
);
[C++]
public: void DrawEllipse(
   Pen* pen,
   RectangleF rect
);
[JScript]
public function DrawEllipse(
   pen : Pen,
   rect : RectangleF
);

Parameters

pen
[To be supplied.]
rect
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawEllipse Overload List


Graphics.DrawIcon

[To be supplied.]

Overload List

Draws this image to a graphics object. The drawing command originates on the graphics object, but a graphics object generally has no idea how to render a given image. So, it passes the call to the actual image. This version crops the image to the given dimensions and allows the user to specify a rectangle within the image to draw.

[Visual Basic] Overloads Public Sub DrawIcon(Icon, Rectangle)
[C#] public void DrawIcon(Icon, Rectangle);
[C++] public: void DrawIcon(Icon*, Rectangle);
[JScript] public function DrawIcon(Icon, Rectangle);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawIcon(Icon, Integer, Integer)
[C#] public void DrawIcon(Icon, int, int);
[C++] public: void DrawIcon(Icon*, int, int);
[JScript] public function DrawIcon(Icon, int, int);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.DrawIcon (Icon, Rectangle)

Draws this image to a graphics object. The drawing command originates on the graphics object, but a graphics object generally has no idea how to render a given image. So, it passes the call to the actual image. This version crops the image to the given dimensions and allows the user to specify a rectangle within the image to draw.

[Visual Basic]
Overloads Public Sub DrawIcon( _
   ByVal icon As Icon, _
   ByVal targetRect As Rectangle _
)
[C#]
public void DrawIcon(
   Icon icon,
   Rectangle targetRect
);
[C++]
public: void DrawIcon(
   Icon* icon,
   Rectangle targetRect
);
[JScript]
public function DrawIcon(
   icon : Icon,
   targetRect : Rectangle
);

Parameters

icon
[To be supplied.]
targetRect
The rectangle to crop to.

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawIcon Overload List


Graphics.DrawIcon (Icon, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawIcon( _
   ByVal icon As Icon, _
   ByVal x As Integer, _
   ByVal y As Integer _
)
[C#]
public void DrawIcon(
   Icon icon,
   int x,
   int y
);
[C++]
public: void DrawIcon(
   Icon* icon,
   int x,
   int y
);
[JScript]
public function DrawIcon(
   icon : Icon,
   x : int,
   y : int
);

Parameters

icon
[To be supplied.]
x
[To be supplied.]
y
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawIcon Overload List


Graphics.DrawIconUnstretched

Draws this image to a graphics object. The drawing command originates on the graphics object, but a graphics object generally has no idea how to render a given image. So, it passes the call to the actual image. This version stretches the image to the given dimensions and allows the user to specify a rectangle within the image to draw.

[Visual Basic]
Public Sub DrawIconUnstretched( _
   ByVal icon As Icon, _
   ByVal targetRect As Rectangle _
)
[C#]
public void DrawIconUnstretched(
   Icon icon,
   Rectangle targetRect
);
[C++]
public: void DrawIconUnstretched(
   Icon* icon,
   Rectangle targetRect
);
[JScript]
public function DrawIconUnstretched(
   icon : Icon,
   targetRect : Rectangle
);

Parameters

icon
[To be supplied.]
targetRect
The rectangle to stretch the image to.

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.DrawImage

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImage(Image, Point(), Rectangle, GraphicsUnit)
[C#] public void DrawImage(Image, Point[], Rectangle, GraphicsUnit);
[C++] public: void DrawImage(Image*, Point[], Rectangle, GraphicsUnit);
[JScript] public function DrawImage(Image, Point[], Rectangle, GraphicsUnit);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImage(Image, Point(), Rectangle, GraphicsUnit, ImageAttributes)
[C#] public void DrawImage(Image, Point[], Rectangle, GraphicsUnit, ImageAttributes);
[C++] public: void DrawImage(Image*, Point[], Rectangle, GraphicsUnit, ImageAttributes);
[JScript] public function DrawImage(Image, Point[], Rectangle, GraphicsUnit, ImageAttributes);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImage(Image, Rectangle, Integer, Integer, Integer, Integer, GraphicsUnit, ImageAttributes, DrawImageAbort, Integer)
[C#] public void DrawImage(Image, Rectangle, int, int, int, int, GraphicsUnit, ImageAttributes, DrawImageAbort, int);
[C++] public: void DrawImage(Image*, Rectangle, int, int, int, int, GraphicsUnit, ImageAttributes, DrawImageAbort, int);
[JScript] public function DrawImage(Image, Rectangle, int, int, int, int, GraphicsUnit, ImageAttributes, DrawImageAbort, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImage(Image, PointF(), RectangleF, GraphicsUnit, ImageAttributes, DrawImageAbort, Integer)
[C#] public void DrawImage(Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes, DrawImageAbort, int);
[C++] public: void DrawImage(Image*, PointF[], RectangleF, GraphicsUnit, ImageAttributes, DrawImageAbort, int);
[JScript] public function DrawImage(Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes, DrawImageAbort, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImage(Image, Rectangle, Single, Single, Single, Single, GraphicsUnit)
[C#] public void DrawImage(Image, Rectangle, float, float, float, float, GraphicsUnit);
[C++] public: void DrawImage(Image*, Rectangle, float, float, float, float, GraphicsUnit);
[JScript] public function DrawImage(Image, Rectangle, float, float, float, float, GraphicsUnit);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImage(Image, Point(), Rectangle, GraphicsUnit, ImageAttributes, DrawImageAbort, Integer)
[C#] public void DrawImage(Image, Point[], Rectangle, GraphicsUnit, ImageAttributes, DrawImageAbort, int);
[C++] public: void DrawImage(Image*, Point[], Rectangle, GraphicsUnit, ImageAttributes, DrawImageAbort, int);
[JScript] public function DrawImage(Image, Point[], Rectangle, GraphicsUnit, ImageAttributes, DrawImageAbort, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImage(Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes, DrawImageAbort)
[C#] public void DrawImage(Image, Rectangle, float, float, float, float, GraphicsUnit, ImageAttributes, DrawImageAbort);
[C++] public: void DrawImage(Image*, Rectangle, float, float, float, float, GraphicsUnit, ImageAttributes, DrawImageAbort);
[JScript] public function DrawImage(Image, Rectangle, float, float, float, float, GraphicsUnit, ImageAttributes, DrawImageAbort);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImage(Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes)
[C#] public void DrawImage(Image, Rectangle, float, float, float, float, GraphicsUnit, ImageAttributes);
[C++] public: void DrawImage(Image*, Rectangle, float, float, float, float, GraphicsUnit, ImageAttributes);
[JScript] public function DrawImage(Image, Rectangle, float, float, float, float, GraphicsUnit, ImageAttributes);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImage(Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes, DrawImageAbort, Integer)
[C#] public void DrawImage(Image, Rectangle, float, float, float, float, GraphicsUnit, ImageAttributes, DrawImageAbort, int);
[C++] public: void DrawImage(Image*, Rectangle, float, float, float, float, GraphicsUnit, ImageAttributes, DrawImageAbort, int);
[JScript] public function DrawImage(Image, Rectangle, float, float, float, float, GraphicsUnit, ImageAttributes, DrawImageAbort, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImage(Image, Rectangle, Integer, Integer, Integer, Integer, GraphicsUnit, ImageAttributes, DrawImageAbort)
[C#] public void DrawImage(Image, Rectangle, int, int, int, int, GraphicsUnit, ImageAttributes, DrawImageAbort);
[C++] public: void DrawImage(Image*, Rectangle, int, int, int, int, GraphicsUnit, ImageAttributes, DrawImageAbort);
[JScript] public function DrawImage(Image, Rectangle, int, int, int, int, GraphicsUnit, ImageAttributes, DrawImageAbort);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImage(Image, Point(), Rectangle, GraphicsUnit, ImageAttributes, DrawImageAbort)
[C#] public void DrawImage(Image, Point[], Rectangle, GraphicsUnit, ImageAttributes, DrawImageAbort);
[C++] public: void DrawImage(Image*, Point[], Rectangle, GraphicsUnit, ImageAttributes, DrawImageAbort);
[JScript] public function DrawImage(Image, Point[], Rectangle, GraphicsUnit, ImageAttributes, DrawImageAbort);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImage(Image, Rectangle, Integer, Integer, Integer, Integer, GraphicsUnit)
[C#] public void DrawImage(Image, Rectangle, int, int, int, int, GraphicsUnit);
[C++] public: void DrawImage(Image*, Rectangle, int, int, int, int, GraphicsUnit);
[JScript] public function DrawImage(Image, Rectangle, int, int, int, int, GraphicsUnit);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImage(Image, Rectangle, Integer, Integer, Integer, Integer, GraphicsUnit, ImageAttributes)
[C#] public void DrawImage(Image, Rectangle, int, int, int, int, GraphicsUnit, ImageAttributes);
[C++] public: void DrawImage(Image*, Rectangle, int, int, int, int, GraphicsUnit, ImageAttributes);
[JScript] public function DrawImage(Image, Rectangle, int, int, int, int, GraphicsUnit, ImageAttributes);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImage(Image, Rectangle, Rectangle, GraphicsUnit)
[C#] public void DrawImage(Image, Rectangle, Rectangle, GraphicsUnit);
[C++] public: void DrawImage(Image*, Rectangle, Rectangle, GraphicsUnit);
[JScript] public function DrawImage(Image, Rectangle, Rectangle, GraphicsUnit);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImage(Image, RectangleF, RectangleF, GraphicsUnit)
[C#] public void DrawImage(Image, RectangleF, RectangleF, GraphicsUnit);
[C++] public: void DrawImage(Image*, RectangleF, RectangleF, GraphicsUnit);
[JScript] public function DrawImage(Image, RectangleF, RectangleF, GraphicsUnit);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImage(Image, PointF(), RectangleF, GraphicsUnit, ImageAttributes)
[C#] public void DrawImage(Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes);
[C++] public: void DrawImage(Image*, PointF[], RectangleF, GraphicsUnit, ImageAttributes);
[JScript] public function DrawImage(Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImage(Image, PointF(), RectangleF, GraphicsUnit)
[C#] public void DrawImage(Image, PointF[], RectangleF, GraphicsUnit);
[C++] public: void DrawImage(Image*, PointF[], RectangleF, GraphicsUnit);
[JScript] public function DrawImage(Image, PointF[], RectangleF, GraphicsUnit);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImage(Image, Single, Single, RectangleF, GraphicsUnit)
[C#] public void DrawImage(Image, float, float, RectangleF, GraphicsUnit);
[C++] public: void DrawImage(Image*, float, float, RectangleF, GraphicsUnit);
[JScript] public function DrawImage(Image, float, float, RectangleF, GraphicsUnit);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImage(Image, Integer, Integer, Rectangle, GraphicsUnit)
[C#] public void DrawImage(Image, int, int, Rectangle, GraphicsUnit);
[C++] public: void DrawImage(Image*, int, int, Rectangle, GraphicsUnit);
[JScript] public function DrawImage(Image, int, int, Rectangle, GraphicsUnit);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImage(Image, PointF())
[C#] public void DrawImage(Image, PointF[]);
[C++] public: void DrawImage(Image*, PointF[]);
[JScript] public function DrawImage(Image, PointF[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImage(Image, Point())
[C#] public void DrawImage(Image, Point[]);
[C++] public: void DrawImage(Image*, Point[]);
[JScript] public function DrawImage(Image, Point[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImage(Image, Integer, Integer, Integer, Integer)
[C#] public void DrawImage(Image, int, int, int, int);
[C++] public: void DrawImage(Image*, int, int, int, int);
[JScript] public function DrawImage(Image, int, int, int, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImage(Image, Single, Single)
[C#] public void DrawImage(Image, float, float);
[C++] public: void DrawImage(Image*, float, float);
[JScript] public function DrawImage(Image, float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImage(Image, RectangleF)
[C#] public void DrawImage(Image, RectangleF);
[C++] public: void DrawImage(Image*, RectangleF);
[JScript] public function DrawImage(Image, RectangleF);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImage(Image, PointF(), RectangleF, GraphicsUnit, ImageAttributes, DrawImageAbort)
[C#] public void DrawImage(Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes, DrawImageAbort);
[C++] public: void DrawImage(Image*, PointF[], RectangleF, GraphicsUnit, ImageAttributes, DrawImageAbort);
[JScript] public function DrawImage(Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes, DrawImageAbort);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImage(Image, PointF)
[C#] public void DrawImage(Image, PointF);
[C++] public: void DrawImage(Image*, PointF);
[JScript] public function DrawImage(Image, PointF);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImage(Image, Integer, Integer)
[C#] public void DrawImage(Image, int, int);
[C++] public: void DrawImage(Image*, int, int);
[JScript] public function DrawImage(Image, int, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImage(Image, Rectangle)
[C#] public void DrawImage(Image, Rectangle);
[C++] public: void DrawImage(Image*, Rectangle);
[JScript] public function DrawImage(Image, Rectangle);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImage(Image, Single, Single, Single, Single)
[C#] public void DrawImage(Image, float, float, float, float);
[C++] public: void DrawImage(Image*, float, float, float, float);
[JScript] public function DrawImage(Image, float, float, float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImage(Image, Point)
[C#] public void DrawImage(Image, Point);
[C++] public: void DrawImage(Image*, Point);
[JScript] public function DrawImage(Image, Point);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.DrawImage (Image, Point[], Rectangle, GraphicsUnit)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal destPoints() As Point, _
   ByVal srcRect As Rectangle, _
   ByVal srcUnit As GraphicsUnit _
)
[C#]
public void DrawImage(
   Image image,
   Point[] destPoints,
   Rectangle srcRect,
   GraphicsUnit srcUnit
);
[C++]
public: void DrawImage(
   Image* image,
   Point* destPoints[],
   Rectangle srcRect,
   GraphicsUnit srcUnit
);
[JScript]
public function DrawImage(
   image : Image,
   destPoints : Point[],
   srcRect : Rectangle,
   srcUnit : GraphicsUnit
);

Parameters

image
[To be supplied.]
destPoints
[To be supplied.]
srcRect
[To be supplied.]
srcUnit
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal destPoints() As Point, _
   ByVal srcRect As Rectangle, _
   ByVal srcUnit As GraphicsUnit, _
   ByVal imageAttr As ImageAttributes _
)
[C#]
public void DrawImage(
   Image image,
   Point[] destPoints,
   Rectangle srcRect,
   GraphicsUnit srcUnit,
   ImageAttributes imageAttr
);
[C++]
public: void DrawImage(
   Image* image,
   Point* destPoints[],
   Rectangle srcRect,
   GraphicsUnit srcUnit,
   ImageAttributes* imageAttr
);
[JScript]
public function DrawImage(
   image : Image,
   destPoints : Point[],
   srcRect : Rectangle,
   srcUnit : GraphicsUnit,
   imageAttr : ImageAttributes
);

Parameters

image
[To be supplied.]
destPoints
[To be supplied.]
srcRect
[To be supplied.]
srcUnit
[To be supplied.]
imageAttr
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes, DrawImageAbort, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal destRect As Rectangle, _
   ByVal srcX As Integer, _
   ByVal srcY As Integer, _
   ByVal srcWidth As Integer, _
   ByVal srcHeight As Integer, _
   ByVal srcUnit As GraphicsUnit, _
   ByVal imageAttrs As ImageAttributes, _
   ByVal callback As Graphics.DrawImageAbort, _
   ByVal callbackData As Integer _
)
[C#]
public void DrawImage(
   Image image,
   Rectangle destRect,
   int srcX,
   int srcY,
   int srcWidth,
   int srcHeight,
   GraphicsUnit srcUnit,
   ImageAttributes imageAttrs,
   Graphics.DrawImageAbort callback,
   int callbackData
);
[C++]
public: void DrawImage(
   Image* image,
   Rectangle destRect,
   int srcX,
   int srcY,
   int srcWidth,
   int srcHeight,
   GraphicsUnit srcUnit,
   ImageAttributes* imageAttrs,
   Graphics.DrawImageAbort* callback,
   int callbackData
);
[JScript]
public function DrawImage(
   image : Image,
   destRect : Rectangle,
   srcX : int,
   srcY : int,
   srcWidth : int,
   srcHeight : int,
   srcUnit : GraphicsUnit,
   imageAttrs : ImageAttributes,
   callback : Graphics.DrawImageAbort,
   callbackData : int
);

Parameters

image
[To be supplied.]
destRect
[To be supplied.]
srcX
[To be supplied.]
srcY
[To be supplied.]
srcWidth
[To be supplied.]
srcHeight
[To be supplied.]
srcUnit
[To be supplied.]
imageAttrs
[To be supplied.]
callback
[To be supplied.]
callbackData
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes, DrawImageAbort, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal destPoints() As PointF, _
   ByVal srcRect As RectangleF, _
   ByVal srcUnit As GraphicsUnit, _
   ByVal imageAttr As ImageAttributes, _
   ByVal callback As Graphics.DrawImageAbort, _
   ByVal callbackData As Integer _
)
[C#]
public void DrawImage(
   Image image,
   PointF[] destPoints,
   RectangleF srcRect,
   GraphicsUnit srcUnit,
   ImageAttributes imageAttr,
   Graphics.DrawImageAbort callback,
   int callbackData
);
[C++]
public: void DrawImage(
   Image* image,
   PointF* destPoints[],
   RectangleF srcRect,
   GraphicsUnit srcUnit,
   ImageAttributes* imageAttr,
   Graphics.DrawImageAbort* callback,
   int callbackData
);
[JScript]
public function DrawImage(
   image : Image,
   destPoints : PointF[],
   srcRect : RectangleF,
   srcUnit : GraphicsUnit,
   imageAttr : ImageAttributes,
   callback : Graphics.DrawImageAbort,
   callbackData : int
);

Parameters

image
[To be supplied.]
destPoints
[To be supplied.]
srcRect
[To be supplied.]
srcUnit
[To be supplied.]
imageAttr
[To be supplied.]
callback
[To be supplied.]
callbackData
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal destRect As Rectangle, _
   ByVal srcX As Single, _
   ByVal srcY As Single, _
   ByVal srcWidth As Single, _
   ByVal srcHeight As Single, _
   ByVal srcUnit As GraphicsUnit _
)
[C#]
public void DrawImage(
   Image image,
   Rectangle destRect,
   float srcX,
   float srcY,
   float srcWidth,
   float srcHeight,
   GraphicsUnit srcUnit
);
[C++]
public: void DrawImage(
   Image* image,
   Rectangle destRect,
   float srcX,
   float srcY,
   float srcWidth,
   float srcHeight,
   GraphicsUnit srcUnit
);
[JScript]
public function DrawImage(
   image : Image,
   destRect : Rectangle,
   srcX : float,
   srcY : float,
   srcWidth : float,
   srcHeight : float,
   srcUnit : GraphicsUnit
);

Parameters

image
[To be supplied.]
destRect
[To be supplied.]
srcX
[To be supplied.]
srcY
[To be supplied.]
srcWidth
[To be supplied.]
srcHeight
[To be supplied.]
srcUnit
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes, DrawImageAbort, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal destPoints() As Point, _
   ByVal srcRect As Rectangle, _
   ByVal srcUnit As GraphicsUnit, _
   ByVal imageAttr As ImageAttributes, _
   ByVal callback As Graphics.DrawImageAbort, _
   ByVal callbackData As Integer _
)
[C#]
public void DrawImage(
   Image image,
   Point[] destPoints,
   Rectangle srcRect,
   GraphicsUnit srcUnit,
   ImageAttributes imageAttr,
   Graphics.DrawImageAbort callback,
   int callbackData
);
[C++]
public: void DrawImage(
   Image* image,
   Point* destPoints[],
   Rectangle srcRect,
   GraphicsUnit srcUnit,
   ImageAttributes* imageAttr,
   Graphics.DrawImageAbort* callback,
   int callbackData
);
[JScript]
public function DrawImage(
   image : Image,
   destPoints : Point[],
   srcRect : Rectangle,
   srcUnit : GraphicsUnit,
   imageAttr : ImageAttributes,
   callback : Graphics.DrawImageAbort,
   callbackData : int
);

Parameters

image
[To be supplied.]
destPoints
[To be supplied.]
srcRect
[To be supplied.]
srcUnit
[To be supplied.]
imageAttr
[To be supplied.]
callback
[To be supplied.]
callbackData
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes, DrawImageAbort)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal destRect As Rectangle, _
   ByVal srcX As Single, _
   ByVal srcY As Single, _
   ByVal srcWidth As Single, _
   ByVal srcHeight As Single, _
   ByVal srcUnit As GraphicsUnit, _
   ByVal imageAttrs As ImageAttributes, _
   ByVal callback As Graphics.DrawImageAbort _
)
[C#]
public void DrawImage(
   Image image,
   Rectangle destRect,
   float srcX,
   float srcY,
   float srcWidth,
   float srcHeight,
   GraphicsUnit srcUnit,
   ImageAttributes imageAttrs,
   Graphics.DrawImageAbort callback
);
[C++]
public: void DrawImage(
   Image* image,
   Rectangle destRect,
   float srcX,
   float srcY,
   float srcWidth,
   float srcHeight,
   GraphicsUnit srcUnit,
   ImageAttributes* imageAttrs,
   Graphics.DrawImageAbort* callback
);
[JScript]
public function DrawImage(
   image : Image,
   destRect : Rectangle,
   srcX : float,
   srcY : float,
   srcWidth : float,
   srcHeight : float,
   srcUnit : GraphicsUnit,
   imageAttrs : ImageAttributes,
   callback : Graphics.DrawImageAbort
);

Parameters

image
[To be supplied.]
destRect
[To be supplied.]
srcX
[To be supplied.]
srcY
[To be supplied.]
srcWidth
[To be supplied.]
srcHeight
[To be supplied.]
srcUnit
[To be supplied.]
imageAttrs
[To be supplied.]
callback
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal destRect As Rectangle, _
   ByVal srcX As Single, _
   ByVal srcY As Single, _
   ByVal srcWidth As Single, _
   ByVal srcHeight As Single, _
   ByVal srcUnit As GraphicsUnit, _
   ByVal imageAttrs As ImageAttributes _
)
[C#]
public void DrawImage(
   Image image,
   Rectangle destRect,
   float srcX,
   float srcY,
   float srcWidth,
   float srcHeight,
   GraphicsUnit srcUnit,
   ImageAttributes imageAttrs
);
[C++]
public: void DrawImage(
   Image* image,
   Rectangle destRect,
   float srcX,
   float srcY,
   float srcWidth,
   float srcHeight,
   GraphicsUnit srcUnit,
   ImageAttributes* imageAttrs
);
[JScript]
public function DrawImage(
   image : Image,
   destRect : Rectangle,
   srcX : float,
   srcY : float,
   srcWidth : float,
   srcHeight : float,
   srcUnit : GraphicsUnit,
   imageAttrs : ImageAttributes
);

Parameters

image
[To be supplied.]
destRect
[To be supplied.]
srcX
[To be supplied.]
srcY
[To be supplied.]
srcWidth
[To be supplied.]
srcHeight
[To be supplied.]
srcUnit
[To be supplied.]
imageAttrs
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes, DrawImageAbort, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal destRect As Rectangle, _
   ByVal srcX As Single, _
   ByVal srcY As Single, _
   ByVal srcWidth As Single, _
   ByVal srcHeight As Single, _
   ByVal srcUnit As GraphicsUnit, _
   ByVal imageAttrs As ImageAttributes, _
   ByVal callback As Graphics.DrawImageAbort, _
   ByVal callbackData As Integer _
)
[C#]
public void DrawImage(
   Image image,
   Rectangle destRect,
   float srcX,
   float srcY,
   float srcWidth,
   float srcHeight,
   GraphicsUnit srcUnit,
   ImageAttributes imageAttrs,
   Graphics.DrawImageAbort callback,
   int callbackData
);
[C++]
public: void DrawImage(
   Image* image,
   Rectangle destRect,
   float srcX,
   float srcY,
   float srcWidth,
   float srcHeight,
   GraphicsUnit srcUnit,
   ImageAttributes* imageAttrs,
   Graphics.DrawImageAbort* callback,
   int callbackData
);
[JScript]
public function DrawImage(
   image : Image,
   destRect : Rectangle,
   srcX : float,
   srcY : float,
   srcWidth : float,
   srcHeight : float,
   srcUnit : GraphicsUnit,
   imageAttrs : ImageAttributes,
   callback : Graphics.DrawImageAbort,
   callbackData : int
);

Parameters

image
[To be supplied.]
destRect
[To be supplied.]
srcX
[To be supplied.]
srcY
[To be supplied.]
srcWidth
[To be supplied.]
srcHeight
[To be supplied.]
srcUnit
[To be supplied.]
imageAttrs
[To be supplied.]
callback
[To be supplied.]
callbackData
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes, DrawImageAbort)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal destRect As Rectangle, _
   ByVal srcX As Integer, _
   ByVal srcY As Integer, _
   ByVal srcWidth As Integer, _
   ByVal srcHeight As Integer, _
   ByVal srcUnit As GraphicsUnit, _
   ByVal imageAttr As ImageAttributes, _
   ByVal callback As Graphics.DrawImageAbort _
)
[C#]
public void DrawImage(
   Image image,
   Rectangle destRect,
   int srcX,
   int srcY,
   int srcWidth,
   int srcHeight,
   GraphicsUnit srcUnit,
   ImageAttributes imageAttr,
   Graphics.DrawImageAbort callback
);
[C++]
public: void DrawImage(
   Image* image,
   Rectangle destRect,
   int srcX,
   int srcY,
   int srcWidth,
   int srcHeight,
   GraphicsUnit srcUnit,
   ImageAttributes* imageAttr,
   Graphics.DrawImageAbort* callback
);
[JScript]
public function DrawImage(
   image : Image,
   destRect : Rectangle,
   srcX : int,
   srcY : int,
   srcWidth : int,
   srcHeight : int,
   srcUnit : GraphicsUnit,
   imageAttr : ImageAttributes,
   callback : Graphics.DrawImageAbort
);

Parameters

image
[To be supplied.]
destRect
[To be supplied.]
srcX
[To be supplied.]
srcY
[To be supplied.]
srcWidth
[To be supplied.]
srcHeight
[To be supplied.]
srcUnit
[To be supplied.]
imageAttr
[To be supplied.]
callback
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes, DrawImageAbort)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal destPoints() As Point, _
   ByVal srcRect As Rectangle, _
   ByVal srcUnit As GraphicsUnit, _
   ByVal imageAttr As ImageAttributes, _
   ByVal callback As Graphics.DrawImageAbort _
)
[C#]
public void DrawImage(
   Image image,
   Point[] destPoints,
   Rectangle srcRect,
   GraphicsUnit srcUnit,
   ImageAttributes imageAttr,
   Graphics.DrawImageAbort callback
);
[C++]
public: void DrawImage(
   Image* image,
   Point* destPoints[],
   Rectangle srcRect,
   GraphicsUnit srcUnit,
   ImageAttributes* imageAttr,
   Graphics.DrawImageAbort* callback
);
[JScript]
public function DrawImage(
   image : Image,
   destPoints : Point[],
   srcRect : Rectangle,
   srcUnit : GraphicsUnit,
   imageAttr : ImageAttributes,
   callback : Graphics.DrawImageAbort
);

Parameters

image
[To be supplied.]
destPoints
[To be supplied.]
srcRect
[To be supplied.]
srcUnit
[To be supplied.]
imageAttr
[To be supplied.]
callback
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal destRect As Rectangle, _
   ByVal srcX As Integer, _
   ByVal srcY As Integer, _
   ByVal srcWidth As Integer, _
   ByVal srcHeight As Integer, _
   ByVal srcUnit As GraphicsUnit _
)
[C#]
public void DrawImage(
   Image image,
   Rectangle destRect,
   int srcX,
   int srcY,
   int srcWidth,
   int srcHeight,
   GraphicsUnit srcUnit
);
[C++]
public: void DrawImage(
   Image* image,
   Rectangle destRect,
   int srcX,
   int srcY,
   int srcWidth,
   int srcHeight,
   GraphicsUnit srcUnit
);
[JScript]
public function DrawImage(
   image : Image,
   destRect : Rectangle,
   srcX : int,
   srcY : int,
   srcWidth : int,
   srcHeight : int,
   srcUnit : GraphicsUnit
);

Parameters

image
[To be supplied.]
destRect
[To be supplied.]
srcX
[To be supplied.]
srcY
[To be supplied.]
srcWidth
[To be supplied.]
srcHeight
[To be supplied.]
srcUnit
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal destRect As Rectangle, _
   ByVal srcX As Integer, _
   ByVal srcY As Integer, _
   ByVal srcWidth As Integer, _
   ByVal srcHeight As Integer, _
   ByVal srcUnit As GraphicsUnit, _
   ByVal imageAttr As ImageAttributes _
)
[C#]
public void DrawImage(
   Image image,
   Rectangle destRect,
   int srcX,
   int srcY,
   int srcWidth,
   int srcHeight,
   GraphicsUnit srcUnit,
   ImageAttributes imageAttr
);
[C++]
public: void DrawImage(
   Image* image,
   Rectangle destRect,
   int srcX,
   int srcY,
   int srcWidth,
   int srcHeight,
   GraphicsUnit srcUnit,
   ImageAttributes* imageAttr
);
[JScript]
public function DrawImage(
   image : Image,
   destRect : Rectangle,
   srcX : int,
   srcY : int,
   srcWidth : int,
   srcHeight : int,
   srcUnit : GraphicsUnit,
   imageAttr : ImageAttributes
);

Parameters

image
[To be supplied.]
destRect
[To be supplied.]
srcX
[To be supplied.]
srcY
[To be supplied.]
srcWidth
[To be supplied.]
srcHeight
[To be supplied.]
srcUnit
[To be supplied.]
imageAttr
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage (Image, Rectangle, Rectangle, GraphicsUnit)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal destRect As Rectangle, _
   ByVal srcRect As Rectangle, _
   ByVal srcUnit As GraphicsUnit _
)
[C#]
public void DrawImage(
   Image image,
   Rectangle destRect,
   Rectangle srcRect,
   GraphicsUnit srcUnit
);
[C++]
public: void DrawImage(
   Image* image,
   Rectangle destRect,
   Rectangle srcRect,
   GraphicsUnit srcUnit
);
[JScript]
public function DrawImage(
   image : Image,
   destRect : Rectangle,
   srcRect : Rectangle,
   srcUnit : GraphicsUnit
);

Parameters

image
[To be supplied.]
destRect
[To be supplied.]
srcRect
[To be supplied.]
srcUnit
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage (Image, RectangleF, RectangleF, GraphicsUnit)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal destRect As RectangleF, _
   ByVal srcRect As RectangleF, _
   ByVal srcUnit As GraphicsUnit _
)
[C#]
public void DrawImage(
   Image image,
   RectangleF destRect,
   RectangleF srcRect,
   GraphicsUnit srcUnit
);
[C++]
public: void DrawImage(
   Image* image,
   RectangleF destRect,
   RectangleF srcRect,
   GraphicsUnit srcUnit
);
[JScript]
public function DrawImage(
   image : Image,
   destRect : RectangleF,
   srcRect : RectangleF,
   srcUnit : GraphicsUnit
);

Parameters

image
[To be supplied.]
destRect
[To be supplied.]
srcRect
[To be supplied.]
srcUnit
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal destPoints() As PointF, _
   ByVal srcRect As RectangleF, _
   ByVal srcUnit As GraphicsUnit, _
   ByVal imageAttr As ImageAttributes _
)
[C#]
public void DrawImage(
   Image image,
   PointF[] destPoints,
   RectangleF srcRect,
   GraphicsUnit srcUnit,
   ImageAttributes imageAttr
);
[C++]
public: void DrawImage(
   Image* image,
   PointF* destPoints[],
   RectangleF srcRect,
   GraphicsUnit srcUnit,
   ImageAttributes* imageAttr
);
[JScript]
public function DrawImage(
   image : Image,
   destPoints : PointF[],
   srcRect : RectangleF,
   srcUnit : GraphicsUnit,
   imageAttr : ImageAttributes
);

Parameters

image
[To be supplied.]
destPoints
[To be supplied.]
srcRect
[To be supplied.]
srcUnit
[To be supplied.]
imageAttr
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage (Image, PointF[], RectangleF, GraphicsUnit)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal destPoints() As PointF, _
   ByVal srcRect As RectangleF, _
   ByVal srcUnit As GraphicsUnit _
)
[C#]
public void DrawImage(
   Image image,
   PointF[] destPoints,
   RectangleF srcRect,
   GraphicsUnit srcUnit
);
[C++]
public: void DrawImage(
   Image* image,
   PointF* destPoints[],
   RectangleF srcRect,
   GraphicsUnit srcUnit
);
[JScript]
public function DrawImage(
   image : Image,
   destPoints : PointF[],
   srcRect : RectangleF,
   srcUnit : GraphicsUnit
);

Parameters

image
[To be supplied.]
destPoints
[To be supplied.]
srcRect
[To be supplied.]
srcUnit
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage (Image, Single, Single, RectangleF, GraphicsUnit)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal srcRect As RectangleF, _
   ByVal srcUnit As GraphicsUnit _
)
[C#]
public void DrawImage(
   Image image,
   float x,
   float y,
   RectangleF srcRect,
   GraphicsUnit srcUnit
);
[C++]
public: void DrawImage(
   Image* image,
   float x,
   float y,
   RectangleF srcRect,
   GraphicsUnit srcUnit
);
[JScript]
public function DrawImage(
   image : Image,
   x : float,
   y : float,
   srcRect : RectangleF,
   srcUnit : GraphicsUnit
);

Parameters

image
[To be supplied.]
x
[To be supplied.]
y
[To be supplied.]
srcRect
[To be supplied.]
srcUnit
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage (Image, Int32, Int32, Rectangle, GraphicsUnit)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal srcRect As Rectangle, _
   ByVal srcUnit As GraphicsUnit _
)
[C#]
public void DrawImage(
   Image image,
   int x,
   int y,
   Rectangle srcRect,
   GraphicsUnit srcUnit
);
[C++]
public: void DrawImage(
   Image* image,
   int x,
   int y,
   Rectangle srcRect,
   GraphicsUnit srcUnit
);
[JScript]
public function DrawImage(
   image : Image,
   x : int,
   y : int,
   srcRect : Rectangle,
   srcUnit : GraphicsUnit
);

Parameters

image
[To be supplied.]
x
[To be supplied.]
y
[To be supplied.]
srcRect
[To be supplied.]
srcUnit
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage (Image, PointF[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal destPoints() As PointF _
)
[C#]
public void DrawImage(
   Image image,
   PointF[] destPoints
);
[C++]
public: void DrawImage(
   Image* image,
   PointF* destPoints[]
);
[JScript]
public function DrawImage(
   image : Image,
   destPoints : PointF[]
);

Parameters

image
[To be supplied.]
destPoints
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage (Image, Point[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal destPoints() As Point _
)
[C#]
public void DrawImage(
   Image image,
   Point[] destPoints
);
[C++]
public: void DrawImage(
   Image* image,
   Point* destPoints[]
);
[JScript]
public function DrawImage(
   image : Image,
   destPoints : Point[]
);

Parameters

image
[To be supplied.]
destPoints
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage (Image, Int32, Int32, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer _
)
[C#]
public void DrawImage(
   Image image,
   int x,
   int y,
   int width,
   int height
);
[C++]
public: void DrawImage(
   Image* image,
   int x,
   int y,
   int width,
   int height
);
[JScript]
public function DrawImage(
   image : Image,
   x : int,
   y : int,
   width : int,
   height : int
);

Parameters

image
[To be supplied.]
x
[To be supplied.]
y
[To be supplied.]
width
[To be supplied.]
height
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage (Image, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal x As Single, _
   ByVal y As Single _
)
[C#]
public void DrawImage(
   Image image,
   float x,
   float y
);
[C++]
public: void DrawImage(
   Image* image,
   float x,
   float y
);
[JScript]
public function DrawImage(
   image : Image,
   x : float,
   y : float
);

Parameters

image
[To be supplied.]
x
[To be supplied.]
y
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage (Image, RectangleF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal rect As RectangleF _
)
[C#]
public void DrawImage(
   Image image,
   RectangleF rect
);
[C++]
public: void DrawImage(
   Image* image,
   RectangleF rect
);
[JScript]
public function DrawImage(
   image : Image,
   rect : RectangleF
);

Parameters

image
[To be supplied.]
rect
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes, DrawImageAbort)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal destPoints() As PointF, _
   ByVal srcRect As RectangleF, _
   ByVal srcUnit As GraphicsUnit, _
   ByVal imageAttr As ImageAttributes, _
   ByVal callback As Graphics.DrawImageAbort _
)
[C#]
public void DrawImage(
   Image image,
   PointF[] destPoints,
   RectangleF srcRect,
   GraphicsUnit srcUnit,
   ImageAttributes imageAttr,
   Graphics.DrawImageAbort callback
);
[C++]
public: void DrawImage(
   Image* image,
   PointF* destPoints[],
   RectangleF srcRect,
   GraphicsUnit srcUnit,
   ImageAttributes* imageAttr,
   Graphics.DrawImageAbort* callback
);
[JScript]
public function DrawImage(
   image : Image,
   destPoints : PointF[],
   srcRect : RectangleF,
   srcUnit : GraphicsUnit,
   imageAttr : ImageAttributes,
   callback : Graphics.DrawImageAbort
);

Parameters

image
[To be supplied.]
destPoints
[To be supplied.]
srcRect
[To be supplied.]
srcUnit
[To be supplied.]
imageAttr
[To be supplied.]
callback
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage (Image, PointF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal point As PointF _
)
[C#]
public void DrawImage(
   Image image,
   PointF point
);
[C++]
public: void DrawImage(
   Image* image,
   PointF point
);
[JScript]
public function DrawImage(
   image : Image,
   point : PointF
);

Parameters

image
[To be supplied.]
point
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage (Image, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal x As Integer, _
   ByVal y As Integer _
)
[C#]
public void DrawImage(
   Image image,
   int x,
   int y
);
[C++]
public: void DrawImage(
   Image* image,
   int x,
   int y
);
[JScript]
public function DrawImage(
   image : Image,
   x : int,
   y : int
);

Parameters

image
[To be supplied.]
x
[To be supplied.]
y
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage (Image, Rectangle)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal rect As Rectangle _
)
[C#]
public void DrawImage(
   Image image,
   Rectangle rect
);
[C++]
public: void DrawImage(
   Image* image,
   Rectangle rect
);
[JScript]
public function DrawImage(
   image : Image,
   rect : Rectangle
);

Parameters

image
[To be supplied.]
rect
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage (Image, Single, Single, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
[C#]
public void DrawImage(
   Image image,
   float x,
   float y,
   float width,
   float height
);
[C++]
public: void DrawImage(
   Image* image,
   float x,
   float y,
   float width,
   float height
);
[JScript]
public function DrawImage(
   image : Image,
   x : float,
   y : float,
   width : float,
   height : float
);

Parameters

image
[To be supplied.]
x
[To be supplied.]
y
[To be supplied.]
width
[To be supplied.]
height
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage (Image, Point)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal point As Point _
)
[C#]
public void DrawImage(
   Image image,
   Point point
);
[C++]
public: void DrawImage(
   Image* image,
   Point point
);
[JScript]
public function DrawImage(
   image : Image,
   point : Point
);

Parameters

image
[To be supplied.]
point
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImage Overload List


Graphics.DrawImageUnscaled

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImageUnscaled(Image, Integer, Integer)
[C#] public void DrawImageUnscaled(Image, int, int);
[C++] public: void DrawImageUnscaled(Image*, int, int);
[JScript] public function DrawImageUnscaled(Image, int, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImageUnscaled(Image, Point)
[C#] public void DrawImageUnscaled(Image, Point);
[C++] public: void DrawImageUnscaled(Image*, Point);
[JScript] public function DrawImageUnscaled(Image, Point);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImageUnscaled(Image, Integer, Integer, Integer, Integer)
[C#] public void DrawImageUnscaled(Image, int, int, int, int);
[C++] public: void DrawImageUnscaled(Image*, int, int, int, int);
[JScript] public function DrawImageUnscaled(Image, int, int, int, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawImageUnscaled(Image, Rectangle)
[C#] public void DrawImageUnscaled(Image, Rectangle);
[C++] public: void DrawImageUnscaled(Image*, Rectangle);
[JScript] public function DrawImageUnscaled(Image, Rectangle);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.DrawImageUnscaled (Image, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImageUnscaled( _
   ByVal image As Image, _
   ByVal x As Integer, _
   ByVal y As Integer _
)
[C#]
public void DrawImageUnscaled(
   Image image,
   int x,
   int y
);
[C++]
public: void DrawImageUnscaled(
   Image* image,
   int x,
   int y
);
[JScript]
public function DrawImageUnscaled(
   image : Image,
   x : int,
   y : int
);

Parameters

image
[To be supplied.]
x
[To be supplied.]
y
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImageUnscaled Overload List


Graphics.DrawImageUnscaled (Image, Point)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImageUnscaled( _
   ByVal image As Image, _
   ByVal point As Point _
)
[C#]
public void DrawImageUnscaled(
   Image image,
   Point point
);
[C++]
public: void DrawImageUnscaled(
   Image* image,
   Point point
);
[JScript]
public function DrawImageUnscaled(
   image : Image,
   point : Point
);

Parameters

image
[To be supplied.]
point
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImageUnscaled Overload List


Graphics.DrawImageUnscaled (Image, Int32, Int32, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImageUnscaled( _
   ByVal image As Image, _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer _
)
[C#]
public void DrawImageUnscaled(
   Image image,
   int x,
   int y,
   int width,
   int height
);
[C++]
public: void DrawImageUnscaled(
   Image* image,
   int x,
   int y,
   int width,
   int height
);
[JScript]
public function DrawImageUnscaled(
   image : Image,
   x : int,
   y : int,
   width : int,
   height : int
);

Parameters

image
[To be supplied.]
x
[To be supplied.]
y
[To be supplied.]
width
[To be supplied.]
height
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImageUnscaled Overload List


Graphics.DrawImageUnscaled (Image, Rectangle)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawImageUnscaled( _
   ByVal image As Image, _
   ByVal rect As Rectangle _
)
[C#]
public void DrawImageUnscaled(
   Image image,
   Rectangle rect
);
[C++]
public: void DrawImageUnscaled(
   Image* image,
   Rectangle rect
);
[JScript]
public function DrawImageUnscaled(
   image : Image,
   rect : Rectangle
);

Parameters

image
[To be supplied.]
rect
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawImageUnscaled Overload List


Graphics.DrawLine

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawLine(Pen, Point, Point)
[C#] public void DrawLine(Pen, Point, Point);
[C++] public: void DrawLine(Pen*, Point, Point);
[JScript] public function DrawLine(Pen, Point, Point);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawLine(Pen, Integer, Integer, Integer, Integer)
[C#] public void DrawLine(Pen, int, int, int, int);
[C++] public: void DrawLine(Pen*, int, int, int, int);
[JScript] public function DrawLine(Pen, int, int, int, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawLine(Pen, Single, Single, Single, Single)
[C#] public void DrawLine(Pen, float, float, float, float);
[C++] public: void DrawLine(Pen*, float, float, float, float);
[JScript] public function DrawLine(Pen, float, float, float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawLine(Pen, PointF, PointF)
[C#] public void DrawLine(Pen, PointF, PointF);
[C++] public: void DrawLine(Pen*, PointF, PointF);
[JScript] public function DrawLine(Pen, PointF, PointF);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.DrawLine (Pen, Point, Point)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawLine( _
   ByVal pen As Pen, _
   ByVal pt1 As Point, _
   ByVal pt2 As Point _
)
[C#]
public void DrawLine(
   Pen pen,
   Point pt1,
   Point pt2
);
[C++]
public: void DrawLine(
   Pen* pen,
   Point pt1,
   Point pt2
);
[JScript]
public function DrawLine(
   pen : Pen,
   pt1 : Point,
   pt2 : Point
);

Parameters

pen
[To be supplied.]
pt1
[To be supplied.]
pt2
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawLine Overload List


Graphics.DrawLine (Pen, Int32, Int32, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawLine( _
   ByVal pen As Pen, _
   ByVal x1 As Integer, _
   ByVal y1 As Integer, _
   ByVal x2 As Integer, _
   ByVal y2 As Integer _
)
[C#]
public void DrawLine(
   Pen pen,
   int x1,
   int y1,
   int x2,
   int y2
);
[C++]
public: void DrawLine(
   Pen* pen,
   int x1,
   int y1,
   int x2,
   int y2
);
[JScript]
public function DrawLine(
   pen : Pen,
   x1 : int,
   y1 : int,
   x2 : int,
   y2 : int
);

Parameters

pen
[To be supplied.]
x1
[To be supplied.]
y1
[To be supplied.]
x2
[To be supplied.]
y2
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawLine Overload List


Graphics.DrawLine (Pen, Single, Single, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawLine( _
   ByVal pen As Pen, _
   ByVal x1 As Single, _
   ByVal y1 As Single, _
   ByVal x2 As Single, _
   ByVal y2 As Single _
)
[C#]
public void DrawLine(
   Pen pen,
   float x1,
   float y1,
   float x2,
   float y2
);
[C++]
public: void DrawLine(
   Pen* pen,
   float x1,
   float y1,
   float x2,
   float y2
);
[JScript]
public function DrawLine(
   pen : Pen,
   x1 : float,
   y1 : float,
   x2 : float,
   y2 : float
);

Parameters

pen
[To be supplied.]
x1
[To be supplied.]
y1
[To be supplied.]
x2
[To be supplied.]
y2
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawLine Overload List


Graphics.DrawLine (Pen, PointF, PointF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawLine( _
   ByVal pen As Pen, _
   ByVal pt1 As PointF, _
   ByVal pt2 As PointF _
)
[C#]
public void DrawLine(
   Pen pen,
   PointF pt1,
   PointF pt2
);
[C++]
public: void DrawLine(
   Pen* pen,
   PointF pt1,
   PointF pt2
);
[JScript]
public function DrawLine(
   pen : Pen,
   pt1 : PointF,
   pt2 : PointF
);

Parameters

pen
[To be supplied.]
pt1
[To be supplied.]
pt2
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawLine Overload List


Graphics.DrawLines

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawLines(Pen, Point())
[C#] public void DrawLines(Pen, Point[]);
[C++] public: void DrawLines(Pen*, Point[]);
[JScript] public function DrawLines(Pen, Point[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawLines(Pen, PointF())
[C#] public void DrawLines(Pen, PointF[]);
[C++] public: void DrawLines(Pen*, PointF[]);
[JScript] public function DrawLines(Pen, PointF[]);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.DrawLines (Pen, Point[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawLines( _
   ByVal pen As Pen, _
   ByVal points() As Point _
)
[C#]
public void DrawLines(
   Pen pen,
   Point[] points
);
[C++]
public: void DrawLines(
   Pen* pen,
   Point* points[]
);
[JScript]
public function DrawLines(
   pen : Pen,
   points : Point[]
);

Parameters

pen
[To be supplied.]
points
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawLines Overload List


Graphics.DrawLines (Pen, PointF[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawLines( _
   ByVal pen As Pen, _
   ByVal points() As PointF _
)
[C#]
public void DrawLines(
   Pen pen,
   PointF[] points
);
[C++]
public: void DrawLines(
   Pen* pen,
   PointF* points[]
);
[JScript]
public function DrawLines(
   pen : Pen,
   points : PointF[]
);

Parameters

pen
[To be supplied.]
points
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawLines Overload List


Graphics.DrawPath

[To be supplied.]

[Visual Basic]
Public Sub DrawPath( _
   ByVal pen As Pen, _
   ByVal path As GraphicsPath _
)
[C#]
public void DrawPath(
   Pen pen,
   GraphicsPath path
);
[C++]
public: void DrawPath(
   Pen* pen,
   GraphicsPath* path
);
[JScript]
public function DrawPath(
   pen : Pen,
   path : GraphicsPath
);

Parameters

pen
[To be supplied.]
path
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.DrawPie

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawPie(Pen, Rectangle, Single, Single)
[C#] public void DrawPie(Pen, Rectangle, float, float);
[C++] public: void DrawPie(Pen*, Rectangle, float, float);
[JScript] public function DrawPie(Pen, Rectangle, float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawPie(Pen, Integer, Integer, Integer, Integer, Integer, Integer)
[C#] public void DrawPie(Pen, int, int, int, int, int, int);
[C++] public: void DrawPie(Pen*, int, int, int, int, int, int);
[JScript] public function DrawPie(Pen, int, int, int, int, int, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawPie(Pen, RectangleF, Single, Single)
[C#] public void DrawPie(Pen, RectangleF, float, float);
[C++] public: void DrawPie(Pen*, RectangleF, float, float);
[JScript] public function DrawPie(Pen, RectangleF, float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawPie(Pen, Single, Single, Single, Single, Single, Single)
[C#] public void DrawPie(Pen, float, float, float, float, float, float);
[C++] public: void DrawPie(Pen*, float, float, float, float, float, float);
[JScript] public function DrawPie(Pen, float, float, float, float, float, float);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.DrawPie (Pen, Rectangle, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawPie( _
   ByVal pen As Pen, _
   ByVal rect As Rectangle, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
[C#]
public void DrawPie(
   Pen pen,
   Rectangle rect,
   float startAngle,
   float sweepAngle
);
[C++]
public: void DrawPie(
   Pen* pen,
   Rectangle rect,
   float startAngle,
   float sweepAngle
);
[JScript]
public function DrawPie(
   pen : Pen,
   rect : Rectangle,
   startAngle : float,
   sweepAngle : float
);

Parameters

pen
[To be supplied.]
rect
[To be supplied.]
startAngle
[To be supplied.]
sweepAngle
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawPie Overload List


Graphics.DrawPie (Pen, Int32, Int32, Int32, Int32, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawPie( _
   ByVal pen As Pen, _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal startAngle As Integer, _
   ByVal sweepAngle As Integer _
)
[C#]
public void DrawPie(
   Pen pen,
   int x,
   int y,
   int width,
   int height,
   int startAngle,
   int sweepAngle
);
[C++]
public: void DrawPie(
   Pen* pen,
   int x,
   int y,
   int width,
   int height,
   int startAngle,
   int sweepAngle
);
[JScript]
public function DrawPie(
   pen : Pen,
   x : int,
   y : int,
   width : int,
   height : int,
   startAngle : int,
   sweepAngle : int
);

Parameters

pen
[To be supplied.]
x
[To be supplied.]
y
[To be supplied.]
width
[To be supplied.]
height
[To be supplied.]
startAngle
[To be supplied.]
sweepAngle
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawPie Overload List


Graphics.DrawPie (Pen, RectangleF, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawPie( _
   ByVal pen As Pen, _
   ByVal rect As RectangleF, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
[C#]
public void DrawPie(
   Pen pen,
   RectangleF rect,
   float startAngle,
   float sweepAngle
);
[C++]
public: void DrawPie(
   Pen* pen,
   RectangleF rect,
   float startAngle,
   float sweepAngle
);
[JScript]
public function DrawPie(
   pen : Pen,
   rect : RectangleF,
   startAngle : float,
   sweepAngle : float
);

Parameters

pen
[To be supplied.]
rect
[To be supplied.]
startAngle
[To be supplied.]
sweepAngle
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawPie Overload List


Graphics.DrawPie (Pen, Single, Single, Single, Single, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawPie( _
   ByVal pen As Pen, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
[C#]
public void DrawPie(
   Pen pen,
   float x,
   float y,
   float width,
   float height,
   float startAngle,
   float sweepAngle
);
[C++]
public: void DrawPie(
   Pen* pen,
   float x,
   float y,
   float width,
   float height,
   float startAngle,
   float sweepAngle
);
[JScript]
public function DrawPie(
   pen : Pen,
   x : float,
   y : float,
   width : float,
   height : float,
   startAngle : float,
   sweepAngle : float
);

Parameters

pen
[To be supplied.]
x
[To be supplied.]
y
[To be supplied.]
width
[To be supplied.]
height
[To be supplied.]
startAngle
[To be supplied.]
sweepAngle
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawPie Overload List


Graphics.DrawPolygon

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawPolygon(Pen, Point())
[C#] public void DrawPolygon(Pen, Point[]);
[C++] public: void DrawPolygon(Pen*, Point[]);
[JScript] public function DrawPolygon(Pen, Point[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawPolygon(Pen, PointF())
[C#] public void DrawPolygon(Pen, PointF[]);
[C++] public: void DrawPolygon(Pen*, PointF[]);
[JScript] public function DrawPolygon(Pen, PointF[]);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.DrawPolygon (Pen, Point[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawPolygon( _
   ByVal pen As Pen, _
   ByVal points() As Point _
)
[C#]
public void DrawPolygon(
   Pen pen,
   Point[] points
);
[C++]
public: void DrawPolygon(
   Pen* pen,
   Point* points[]
);
[JScript]
public function DrawPolygon(
   pen : Pen,
   points : Point[]
);

Parameters

pen
[To be supplied.]
points
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawPolygon Overload List


Graphics.DrawPolygon (Pen, PointF[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawPolygon( _
   ByVal pen As Pen, _
   ByVal points() As PointF _
)
[C#]
public void DrawPolygon(
   Pen pen,
   PointF[] points
);
[C++]
public: void DrawPolygon(
   Pen* pen,
   PointF* points[]
);
[JScript]
public function DrawPolygon(
   pen : Pen,
   points : PointF[]
);

Parameters

pen
[To be supplied.]
points
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawPolygon Overload List


Graphics.DrawRectangle

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawRectangle(Pen, Integer, Integer, Integer, Integer)
[C#] public void DrawRectangle(Pen, int, int, int, int);
[C++] public: void DrawRectangle(Pen*, int, int, int, int);
[JScript] public function DrawRectangle(Pen, int, int, int, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawRectangle(Pen, Single, Single, Single, Single)
[C#] public void DrawRectangle(Pen, float, float, float, float);
[C++] public: void DrawRectangle(Pen*, float, float, float, float);
[JScript] public function DrawRectangle(Pen, float, float, float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawRectangle(Pen, Rectangle)
[C#] public void DrawRectangle(Pen, Rectangle);
[C++] public: void DrawRectangle(Pen*, Rectangle);
[JScript] public function DrawRectangle(Pen, Rectangle);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.DrawRectangle (Pen, Int32, Int32, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawRectangle( _
   ByVal pen As Pen, _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer _
)
[C#]
public void DrawRectangle(
   Pen pen,
   int x,
   int y,
   int width,
   int height
);
[C++]
public: void DrawRectangle(
   Pen* pen,
   int x,
   int y,
   int width,
   int height
);
[JScript]
public function DrawRectangle(
   pen : Pen,
   x : int,
   y : int,
   width : int,
   height : int
);

Parameters

pen
[To be supplied.]
x
[To be supplied.]
y
[To be supplied.]
width
[To be supplied.]
height
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawRectangle Overload List


Graphics.DrawRectangle (Pen, Single, Single, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawRectangle( _
   ByVal pen As Pen, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
[C#]
public void DrawRectangle(
   Pen pen,
   float x,
   float y,
   float width,
   float height
);
[C++]
public: void DrawRectangle(
   Pen* pen,
   float x,
   float y,
   float width,
   float height
);
[JScript]
public function DrawRectangle(
   pen : Pen,
   x : float,
   y : float,
   width : float,
   height : float
);

Parameters

pen
[To be supplied.]
x
[To be supplied.]
y
[To be supplied.]
width
[To be supplied.]
height
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawRectangle Overload List


Graphics.DrawRectangle (Pen, Rectangle)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawRectangle( _
   ByVal pen As Pen, _
   ByVal rect As Rectangle _
)
[C#]
public void DrawRectangle(
   Pen pen,
   Rectangle rect
);
[C++]
public: void DrawRectangle(
   Pen* pen,
   Rectangle rect
);
[JScript]
public function DrawRectangle(
   pen : Pen,
   rect : Rectangle
);

Parameters

pen
[To be supplied.]
rect
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawRectangle Overload List


Graphics.DrawRectangles

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawRectangles(Pen, RectangleF())
[C#] public void DrawRectangles(Pen, RectangleF[]);
[C++] public: void DrawRectangles(Pen*, RectangleF[]);
[JScript] public function DrawRectangles(Pen, RectangleF[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawRectangles(Pen, Rectangle())
[C#] public void DrawRectangles(Pen, Rectangle[]);
[C++] public: void DrawRectangles(Pen*, Rectangle[]);
[JScript] public function DrawRectangles(Pen, Rectangle[]);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.DrawRectangles (Pen, RectangleF[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawRectangles( _
   ByVal pen As Pen, _
   ByVal rects() As RectangleF _
)
[C#]
public void DrawRectangles(
   Pen pen,
   RectangleF[] rects
);
[C++]
public: void DrawRectangles(
   Pen* pen,
   RectangleF* rects[]
);
[JScript]
public function DrawRectangles(
   pen : Pen,
   rects : RectangleF[]
);

Parameters

pen
[To be supplied.]
rects
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawRectangles Overload List


Graphics.DrawRectangles (Pen, Rectangle[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawRectangles( _
   ByVal pen As Pen, _
   ByVal rects() As Rectangle _
)
[C#]
public void DrawRectangles(
   Pen pen,
   Rectangle[] rects
);
[C++]
public: void DrawRectangles(
   Pen* pen,
   Rectangle* rects[]
);
[JScript]
public function DrawRectangles(
   pen : Pen,
   rects : Rectangle[]
);

Parameters

pen
[To be supplied.]
rects
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawRectangles Overload List


Graphics.DrawString

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawString(String, Font, Brush, PointF)
[C#] public void DrawString(String, Font, Brush, PointF);
[C++] public: void DrawString(String*, Font, Brush, PointF);
[JScript] public function DrawString(String, Font, Brush, PointF);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawString(String, Font, Brush, Single, Single)
[C#] public void DrawString(String, Font, Brush, float, float);
[C++] public: void DrawString(String*, Font, Brush, float, float);
[JScript] public function DrawString(String, Font, Brush, float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawString(String, Font, Brush, PointF, StringFormat)
[C#] public void DrawString(String, Font, Brush, PointF, StringFormat);
[C++] public: void DrawString(String*, Font, Brush, PointF, StringFormat);
[JScript] public function DrawString(String, Font, Brush, PointF, StringFormat);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawString(String, Font, Brush, Single, Single, StringFormat)
[C#] public void DrawString(String, Font, Brush, float, float, StringFormat);
[C++] public: void DrawString(String*, Font, Brush, float, float, StringFormat);
[JScript] public function DrawString(String, Font, Brush, float, float, StringFormat);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawString(String, Font, Brush, PointF, RectangleF, StringFormat)
[C#] public void DrawString(String, Font, Brush, PointF, RectangleF, StringFormat);
[C++] public: void DrawString(String*, Font, Brush, PointF, RectangleF, StringFormat);
[JScript] public function DrawString(String, Font, Brush, PointF, RectangleF, StringFormat);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawString(String, Font, Brush, Single, Single, RectangleF, StringFormat)
[C#] public void DrawString(String, Font, Brush, float, float, RectangleF, StringFormat);
[C++] public: void DrawString(String*, Font, Brush, float, float, RectangleF, StringFormat);
[JScript] public function DrawString(String, Font, Brush, float, float, RectangleF, StringFormat);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawString(String, Font, Brush, RectangleF, RectangleF, StringFormat)
[C#] public void DrawString(String, Font, Brush, RectangleF, RectangleF, StringFormat);
[C++] public: void DrawString(String*, Font, Brush, RectangleF, RectangleF, StringFormat);
[JScript] public function DrawString(String, Font, Brush, RectangleF, RectangleF, StringFormat);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawString(String, Font, Brush, RectangleF, RectangleF)
[C#] public void DrawString(String, Font, Brush, RectangleF, RectangleF);
[C++] public: void DrawString(String*, Font, Brush, RectangleF, RectangleF);
[JScript] public function DrawString(String, Font, Brush, RectangleF, RectangleF);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawString(String, Font, Brush, RectangleF, StringFormat)
[C#] public void DrawString(String, Font, Brush, RectangleF, StringFormat);
[C++] public: void DrawString(String*, Font, Brush, RectangleF, StringFormat);
[JScript] public function DrawString(String, Font, Brush, RectangleF, StringFormat);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawString(String, Font, Brush, RectangleF)
[C#] public void DrawString(String, Font, Brush, RectangleF);
[C++] public: void DrawString(String*, Font, Brush, RectangleF);
[JScript] public function DrawString(String, Font, Brush, RectangleF);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawString(String, Font, Brush, PointF, RectangleF)
[C#] public void DrawString(String, Font, Brush, PointF, RectangleF);
[C++] public: void DrawString(String*, Font, Brush, PointF, RectangleF);
[JScript] public function DrawString(String, Font, Brush, PointF, RectangleF);

[To be supplied.]

[Visual Basic] Overloads Public Sub DrawString(String, Font, Brush, Single, Single, RectangleF)
[C#] public void DrawString(String, Font, Brush, float, float, RectangleF);
[C++] public: void DrawString(String*, Font, Brush, float, float, RectangleF);
[JScript] public function DrawString(String, Font, Brush, float, float, RectangleF);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.DrawString (String, Font, Brush, PointF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawString( _
   ByVal s As String, _
   ByVal font As Font, _
   ByVal brush As Brush, _
   ByVal point As PointF _
)
[C#]
public void DrawString(
   string s,
   Font font,
   Brush brush,
   PointF point
);
[C++]
public: void DrawString(
   String* s,
   Font* font,
   Brush* brush,
   PointF point
);
[JScript]
public function DrawString(
   s : String,
   font : Font,
   brush : Brush,
   point : PointF
);

Parameters

s
[To be supplied.]
font
[To be supplied.]
brush
[To be supplied.]
point
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawString Overload List


Graphics.DrawString (String, Font, Brush, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawString( _
   ByVal s As String, _
   ByVal font As Font, _
   ByVal brush As Brush, _
   ByVal x As Single, _
   ByVal y As Single _
)
[C#]
public void DrawString(
   string s,
   Font font,
   Brush brush,
   float x,
   float y
);
[C++]
public: void DrawString(
   String* s,
   Font* font,
   Brush* brush,
   float x,
   float y
);
[JScript]
public function DrawString(
   s : String,
   font : Font,
   brush : Brush,
   x : float,
   y : float
);

Parameters

s
[To be supplied.]
font
[To be supplied.]
brush
[To be supplied.]
x
[To be supplied.]
y
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawString Overload List


Graphics.DrawString (String, Font, Brush, PointF, StringFormat)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawString( _
   ByVal s As String, _
   ByVal font As Font, _
   ByVal brush As Brush, _
   ByVal point As PointF, _
   ByVal format As StringFormat _
)
[C#]
public void DrawString(
   string s,
   Font font,
   Brush brush,
   PointF point,
   StringFormat format
);
[C++]
public: void DrawString(
   String* s,
   Font* font,
   Brush* brush,
   PointF point,
   StringFormat* format
);
[JScript]
public function DrawString(
   s : String,
   font : Font,
   brush : Brush,
   point : PointF,
   format : StringFormat
);

Parameters

s
[To be supplied.]
font
[To be supplied.]
brush
[To be supplied.]
point
[To be supplied.]
format
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawString Overload List


Graphics.DrawString (String, Font, Brush, Single, Single, StringFormat)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawString( _
   ByVal s As String, _
   ByVal font As Font, _
   ByVal brush As Brush, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal format As StringFormat _
)
[C#]
public void DrawString(
   string s,
   Font font,
   Brush brush,
   float x,
   float y,
   StringFormat format
);
[C++]
public: void DrawString(
   String* s,
   Font* font,
   Brush* brush,
   float x,
   float y,
   StringFormat* format
);
[JScript]
public function DrawString(
   s : String,
   font : Font,
   brush : Brush,
   x : float,
   y : float,
   format : StringFormat
);

Parameters

s
[To be supplied.]
font
[To be supplied.]
brush
[To be supplied.]
x
[To be supplied.]
y
[To be supplied.]
format
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawString Overload List


Graphics.DrawString (String, Font, Brush, PointF, RectangleF, StringFormat)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawString( _
   ByVal s As String, _
   ByVal font As Font, _
   ByVal brush As Brush, _
   ByVal point As PointF, _
   ByVal clippingRectangle As RectangleF, _
   ByVal format As StringFormat _
)
[C#]
public void DrawString(
   string s,
   Font font,
   Brush brush,
   PointF point,
   RectangleF clippingRectangle,
   StringFormat format
);
[C++]
public: void DrawString(
   String* s,
   Font* font,
   Brush* brush,
   PointF point,
   RectangleF clippingRectangle,
   StringFormat* format
);
[JScript]
public function DrawString(
   s : String,
   font : Font,
   brush : Brush,
   point : PointF,
   clippingRectangle : RectangleF,
   format : StringFormat
);

Parameters

s
[To be supplied.]
font
[To be supplied.]
brush
[To be supplied.]
point
[To be supplied.]
clippingRectangle
[To be supplied.]
format
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawString Overload List


Graphics.DrawString (String, Font, Brush, Single, Single, RectangleF, StringFormat)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawString( _
   ByVal s As String, _
   ByVal font As Font, _
   ByVal brush As Brush, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal clippingRectangle As RectangleF, _
   ByVal format As StringFormat _
)
[C#]
public void DrawString(
   string s,
   Font font,
   Brush brush,
   float x,
   float y,
   RectangleF clippingRectangle,
   StringFormat format
);
[C++]
public: void DrawString(
   String* s,
   Font* font,
   Brush* brush,
   float x,
   float y,
   RectangleF clippingRectangle,
   StringFormat* format
);
[JScript]
public function DrawString(
   s : String,
   font : Font,
   brush : Brush,
   x : float,
   y : float,
   clippingRectangle : RectangleF,
   format : StringFormat
);

Parameters

s
[To be supplied.]
font
[To be supplied.]
brush
[To be supplied.]
x
[To be supplied.]
y
[To be supplied.]
clippingRectangle
[To be supplied.]
format
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawString Overload List


Graphics.DrawString (String, Font, Brush, RectangleF, RectangleF, StringFormat)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawString( _
   ByVal s As String, _
   ByVal font As Font, _
   ByVal brush As Brush, _
   ByVal layoutRectangle As RectangleF, _
   ByVal clippingRectangle As RectangleF, _
   ByVal format As StringFormat _
)
[C#]
public void DrawString(
   string s,
   Font font,
   Brush brush,
   RectangleF layoutRectangle,
   RectangleF clippingRectangle,
   StringFormat format
);
[C++]
public: void DrawString(
   String* s,
   Font* font,
   Brush* brush,
   RectangleF layoutRectangle,
   RectangleF clippingRectangle,
   StringFormat* format
);
[JScript]
public function DrawString(
   s : String,
   font : Font,
   brush : Brush,
   layoutRectangle : RectangleF,
   clippingRectangle : RectangleF,
   format : StringFormat
);

Parameters

s
[To be supplied.]
font
[To be supplied.]
brush
[To be supplied.]
layoutRectangle
[To be supplied.]
clippingRectangle
[To be supplied.]
format
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawString Overload List


Graphics.DrawString (String, Font, Brush, RectangleF, RectangleF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawString( _
   ByVal s As String, _
   ByVal font As Font, _
   ByVal brush As Brush, _
   ByVal layoutRectangle As RectangleF, _
   ByVal clippingRectangle As RectangleF _
)
[C#]
public void DrawString(
   string s,
   Font font,
   Brush brush,
   RectangleF layoutRectangle,
   RectangleF clippingRectangle
);
[C++]
public: void DrawString(
   String* s,
   Font* font,
   Brush* brush,
   RectangleF layoutRectangle,
   RectangleF clippingRectangle
);
[JScript]
public function DrawString(
   s : String,
   font : Font,
   brush : Brush,
   layoutRectangle : RectangleF,
   clippingRectangle : RectangleF
);

Parameters

s
[To be supplied.]
font
[To be supplied.]
brush
[To be supplied.]
layoutRectangle
[To be supplied.]
clippingRectangle
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawString Overload List


Graphics.DrawString (String, Font, Brush, RectangleF, StringFormat)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawString( _
   ByVal s As String, _
   ByVal font As Font, _
   ByVal brush As Brush, _
   ByVal layoutRectangle As RectangleF, _
   ByVal format As StringFormat _
)
[C#]
public void DrawString(
   string s,
   Font font,
   Brush brush,
   RectangleF layoutRectangle,
   StringFormat format
);
[C++]
public: void DrawString(
   String* s,
   Font* font,
   Brush* brush,
   RectangleF layoutRectangle,
   StringFormat* format
);
[JScript]
public function DrawString(
   s : String,
   font : Font,
   brush : Brush,
   layoutRectangle : RectangleF,
   format : StringFormat
);

Parameters

s
[To be supplied.]
font
[To be supplied.]
brush
[To be supplied.]
layoutRectangle
[To be supplied.]
format
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawString Overload List


Graphics.DrawString (String, Font, Brush, RectangleF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawString( _
   ByVal s As String, _
   ByVal font As Font, _
   ByVal brush As Brush, _
   ByVal layoutRectangle As RectangleF _
)
[C#]
public void DrawString(
   string s,
   Font font,
   Brush brush,
   RectangleF layoutRectangle
);
[C++]
public: void DrawString(
   String* s,
   Font* font,
   Brush* brush,
   RectangleF layoutRectangle
);
[JScript]
public function DrawString(
   s : String,
   font : Font,
   brush : Brush,
   layoutRectangle : RectangleF
);

Parameters

s
[To be supplied.]
font
[To be supplied.]
brush
[To be supplied.]
layoutRectangle
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawString Overload List


Graphics.DrawString (String, Font, Brush, PointF, RectangleF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawString( _
   ByVal s As String, _
   ByVal font As Font, _
   ByVal brush As Brush, _
   ByVal point As PointF, _
   ByVal clippingRectangle As RectangleF _
)
[C#]
public void DrawString(
   string s,
   Font font,
   Brush brush,
   PointF point,
   RectangleF clippingRectangle
);
[C++]
public: void DrawString(
   String* s,
   Font* font,
   Brush* brush,
   PointF point,
   RectangleF clippingRectangle
);
[JScript]
public function DrawString(
   s : String,
   font : Font,
   brush : Brush,
   point : PointF,
   clippingRectangle : RectangleF
);

Parameters

s
[To be supplied.]
font
[To be supplied.]
brush
[To be supplied.]
point
[To be supplied.]
clippingRectangle
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawString Overload List


Graphics.DrawString (String, Font, Brush, Single, Single, RectangleF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub DrawString( _
   ByVal s As String, _
   ByVal font As Font, _
   ByVal brush As Brush, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal clippingRectangle As RectangleF _
)
[C#]
public void DrawString(
   string s,
   Font font,
   Brush brush,
   float x,
   float y,
   RectangleF clippingRectangle
);
[C++]
public: void DrawString(
   String* s,
   Font* font,
   Brush* brush,
   float x,
   float y,
   RectangleF clippingRectangle
);
[JScript]
public function DrawString(
   s : String,
   font : Font,
   brush : Brush,
   x : float,
   y : float,
   clippingRectangle : RectangleF
);

Parameters

s
[To be supplied.]
font
[To be supplied.]
brush
[To be supplied.]
x
[To be supplied.]
y
[To be supplied.]
clippingRectangle
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.DrawString Overload List


Graphics.EndContainer

[To be supplied.]

[Visual Basic]
Public Sub EndContainer( _
   ByVal container As GraphicsContainer _
)
[C#]
public void EndContainer(
   GraphicsContainer container
);
[C++]
public: void EndContainer(
   GraphicsContainer* container
);
[JScript]
public function EndContainer(
   container : GraphicsContainer
);

Parameters

container
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.EnumerateMetafile

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, Point, Rectangle, GraphicsUnit, EnumerateMetafileProc)
[C#] public void EnumerateMetafile(Metafile, Point, Rectangle, GraphicsUnit, EnumerateMetafileProc);
[C++] public: void EnumerateMetafile(Metafile*, Point, Rectangle, GraphicsUnit, EnumerateMetafileProc);
[JScript] public function EnumerateMetafile(Metafile, Point, Rectangle, GraphicsUnit, EnumerateMetafileProc);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, Point, Rectangle, GraphicsUnit, EnumerateMetafileProc, Integer)
[C#] public void EnumerateMetafile(Metafile, Point, Rectangle, GraphicsUnit, EnumerateMetafileProc, int);
[C++] public: void EnumerateMetafile(Metafile*, Point, Rectangle, GraphicsUnit, EnumerateMetafileProc, int);
[JScript] public function EnumerateMetafile(Metafile, Point, Rectangle, GraphicsUnit, EnumerateMetafileProc, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, Point, Rectangle, GraphicsUnit, EnumerateMetafileProc, Integer, ImageAttributes)
[C#] public void EnumerateMetafile(Metafile, Point, Rectangle, GraphicsUnit, EnumerateMetafileProc, int, ImageAttributes);
[C++] public: void EnumerateMetafile(Metafile*, Point, Rectangle, GraphicsUnit, EnumerateMetafileProc, int, ImageAttributes);
[JScript] public function EnumerateMetafile(Metafile, Point, Rectangle, GraphicsUnit, EnumerateMetafileProc, int, ImageAttributes);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, PointF, RectangleF, GraphicsUnit, EnumerateMetafileProc)
[C#] public void EnumerateMetafile(Metafile, PointF, RectangleF, GraphicsUnit, EnumerateMetafileProc);
[C++] public: void EnumerateMetafile(Metafile*, PointF, RectangleF, GraphicsUnit, EnumerateMetafileProc);
[JScript] public function EnumerateMetafile(Metafile, PointF, RectangleF, GraphicsUnit, EnumerateMetafileProc);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, Point(), EnumerateMetafileProc, Integer, ImageAttributes)
[C#] public void EnumerateMetafile(Metafile, Point[], EnumerateMetafileProc, int, ImageAttributes);
[C++] public: void EnumerateMetafile(Metafile*, Point[], EnumerateMetafileProc, int, ImageAttributes);
[JScript] public function EnumerateMetafile(Metafile, Point[], EnumerateMetafileProc, int, ImageAttributes);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, PointF, RectangleF, GraphicsUnit, EnumerateMetafileProc, Integer, ImageAttributes)
[C#] public void EnumerateMetafile(Metafile, PointF, RectangleF, GraphicsUnit, EnumerateMetafileProc, int, ImageAttributes);
[C++] public: void EnumerateMetafile(Metafile*, PointF, RectangleF, GraphicsUnit, EnumerateMetafileProc, int, ImageAttributes);
[JScript] public function EnumerateMetafile(Metafile, PointF, RectangleF, GraphicsUnit, EnumerateMetafileProc, int, ImageAttributes);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, PointF, RectangleF, GraphicsUnit, EnumerateMetafileProc, Integer)
[C#] public void EnumerateMetafile(Metafile, PointF, RectangleF, GraphicsUnit, EnumerateMetafileProc, int);
[C++] public: void EnumerateMetafile(Metafile*, PointF, RectangleF, GraphicsUnit, EnumerateMetafileProc, int);
[JScript] public function EnumerateMetafile(Metafile, PointF, RectangleF, GraphicsUnit, EnumerateMetafileProc, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, RectangleF, RectangleF, GraphicsUnit, EnumerateMetafileProc)
[C#] public void EnumerateMetafile(Metafile, RectangleF, RectangleF, GraphicsUnit, EnumerateMetafileProc);
[C++] public: void EnumerateMetafile(Metafile*, RectangleF, RectangleF, GraphicsUnit, EnumerateMetafileProc);
[JScript] public function EnumerateMetafile(Metafile, RectangleF, RectangleF, GraphicsUnit, EnumerateMetafileProc);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, Rectangle, Rectangle, GraphicsUnit, EnumerateMetafileProc, Integer, ImageAttributes)
[C#] public void EnumerateMetafile(Metafile, Rectangle, Rectangle, GraphicsUnit, EnumerateMetafileProc, int, ImageAttributes);
[C++] public: void EnumerateMetafile(Metafile*, Rectangle, Rectangle, GraphicsUnit, EnumerateMetafileProc, int, ImageAttributes);
[JScript] public function EnumerateMetafile(Metafile, Rectangle, Rectangle, GraphicsUnit, EnumerateMetafileProc, int, ImageAttributes);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, PointF(), RectangleF, GraphicsUnit, EnumerateMetafileProc)
[C#] public void EnumerateMetafile(Metafile, PointF[], RectangleF, GraphicsUnit, EnumerateMetafileProc);
[C++] public: void EnumerateMetafile(Metafile*, PointF[], RectangleF, GraphicsUnit, EnumerateMetafileProc);
[JScript] public function EnumerateMetafile(Metafile, PointF[], RectangleF, GraphicsUnit, EnumerateMetafileProc);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, PointF(), RectangleF, GraphicsUnit, EnumerateMetafileProc, Integer)
[C#] public void EnumerateMetafile(Metafile, PointF[], RectangleF, GraphicsUnit, EnumerateMetafileProc, int);
[C++] public: void EnumerateMetafile(Metafile*, PointF[], RectangleF, GraphicsUnit, EnumerateMetafileProc, int);
[JScript] public function EnumerateMetafile(Metafile, PointF[], RectangleF, GraphicsUnit, EnumerateMetafileProc, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, Rectangle, Rectangle, GraphicsUnit, EnumerateMetafileProc, Integer)
[C#] public void EnumerateMetafile(Metafile, Rectangle, Rectangle, GraphicsUnit, EnumerateMetafileProc, int);
[C++] public: void EnumerateMetafile(Metafile*, Rectangle, Rectangle, GraphicsUnit, EnumerateMetafileProc, int);
[JScript] public function EnumerateMetafile(Metafile, Rectangle, Rectangle, GraphicsUnit, EnumerateMetafileProc, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, RectangleF, RectangleF, GraphicsUnit, EnumerateMetafileProc, Integer)
[C#] public void EnumerateMetafile(Metafile, RectangleF, RectangleF, GraphicsUnit, EnumerateMetafileProc, int);
[C++] public: void EnumerateMetafile(Metafile*, RectangleF, RectangleF, GraphicsUnit, EnumerateMetafileProc, int);
[JScript] public function EnumerateMetafile(Metafile, RectangleF, RectangleF, GraphicsUnit, EnumerateMetafileProc, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, RectangleF, RectangleF, GraphicsUnit, EnumerateMetafileProc, Integer, ImageAttributes)
[C#] public void EnumerateMetafile(Metafile, RectangleF, RectangleF, GraphicsUnit, EnumerateMetafileProc, int, ImageAttributes);
[C++] public: void EnumerateMetafile(Metafile*, RectangleF, RectangleF, GraphicsUnit, EnumerateMetafileProc, int, ImageAttributes);
[JScript] public function EnumerateMetafile(Metafile, RectangleF, RectangleF, GraphicsUnit, EnumerateMetafileProc, int, ImageAttributes);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, Rectangle, Rectangle, GraphicsUnit, EnumerateMetafileProc)
[C#] public void EnumerateMetafile(Metafile, Rectangle, Rectangle, GraphicsUnit, EnumerateMetafileProc);
[C++] public: void EnumerateMetafile(Metafile*, Rectangle, Rectangle, GraphicsUnit, EnumerateMetafileProc);
[JScript] public function EnumerateMetafile(Metafile, Rectangle, Rectangle, GraphicsUnit, EnumerateMetafileProc);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, Point(), EnumerateMetafileProc, Integer)
[C#] public void EnumerateMetafile(Metafile, Point[], EnumerateMetafileProc, int);
[C++] public: void EnumerateMetafile(Metafile*, Point[], EnumerateMetafileProc, int);
[JScript] public function EnumerateMetafile(Metafile, Point[], EnumerateMetafileProc, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, Point, EnumerateMetafileProc, Integer, ImageAttributes)
[C#] public void EnumerateMetafile(Metafile, Point, EnumerateMetafileProc, int, ImageAttributes);
[C++] public: void EnumerateMetafile(Metafile*, Point, EnumerateMetafileProc, int, ImageAttributes);
[JScript] public function EnumerateMetafile(Metafile, Point, EnumerateMetafileProc, int, ImageAttributes);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, Point, EnumerateMetafileProc, Integer)
[C#] public void EnumerateMetafile(Metafile, Point, EnumerateMetafileProc, int);
[C++] public: void EnumerateMetafile(Metafile*, Point, EnumerateMetafileProc, int);
[JScript] public function EnumerateMetafile(Metafile, Point, EnumerateMetafileProc, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, RectangleF, EnumerateMetafileProc, Integer)
[C#] public void EnumerateMetafile(Metafile, RectangleF, EnumerateMetafileProc, int);
[C++] public: void EnumerateMetafile(Metafile*, RectangleF, EnumerateMetafileProc, int);
[JScript] public function EnumerateMetafile(Metafile, RectangleF, EnumerateMetafileProc, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, RectangleF, EnumerateMetafileProc)
[C#] public void EnumerateMetafile(Metafile, RectangleF, EnumerateMetafileProc);
[C++] public: void EnumerateMetafile(Metafile*, RectangleF, EnumerateMetafileProc);
[JScript] public function EnumerateMetafile(Metafile, RectangleF, EnumerateMetafileProc);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, PointF, EnumerateMetafileProc, Integer)
[C#] public void EnumerateMetafile(Metafile, PointF, EnumerateMetafileProc, int);
[C++] public: void EnumerateMetafile(Metafile*, PointF, EnumerateMetafileProc, int);
[JScript] public function EnumerateMetafile(Metafile, PointF, EnumerateMetafileProc, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, PointF, EnumerateMetafileProc)
[C#] public void EnumerateMetafile(Metafile, PointF, EnumerateMetafileProc);
[C++] public: void EnumerateMetafile(Metafile*, PointF, EnumerateMetafileProc);
[JScript] public function EnumerateMetafile(Metafile, PointF, EnumerateMetafileProc);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, Point, EnumerateMetafileProc)
[C#] public void EnumerateMetafile(Metafile, Point, EnumerateMetafileProc);
[C++] public: void EnumerateMetafile(Metafile*, Point, EnumerateMetafileProc);
[JScript] public function EnumerateMetafile(Metafile, Point, EnumerateMetafileProc);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, PointF, EnumerateMetafileProc, Integer, ImageAttributes)
[C#] public void EnumerateMetafile(Metafile, PointF, EnumerateMetafileProc, int, ImageAttributes);
[C++] public: void EnumerateMetafile(Metafile*, PointF, EnumerateMetafileProc, int, ImageAttributes);
[JScript] public function EnumerateMetafile(Metafile, PointF, EnumerateMetafileProc, int, ImageAttributes);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, PointF(), EnumerateMetafileProc, Integer)
[C#] public void EnumerateMetafile(Metafile, PointF[], EnumerateMetafileProc, int);
[C++] public: void EnumerateMetafile(Metafile*, PointF[], EnumerateMetafileProc, int);
[JScript] public function EnumerateMetafile(Metafile, PointF[], EnumerateMetafileProc, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, PointF(), EnumerateMetafileProc)
[C#] public void EnumerateMetafile(Metafile, PointF[], EnumerateMetafileProc);
[C++] public: void EnumerateMetafile(Metafile*, PointF[], EnumerateMetafileProc);
[JScript] public function EnumerateMetafile(Metafile, PointF[], EnumerateMetafileProc);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, Point(), EnumerateMetafileProc)
[C#] public void EnumerateMetafile(Metafile, Point[], EnumerateMetafileProc);
[C++] public: void EnumerateMetafile(Metafile*, Point[], EnumerateMetafileProc);
[JScript] public function EnumerateMetafile(Metafile, Point[], EnumerateMetafileProc);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, PointF(), EnumerateMetafileProc, Integer, ImageAttributes)
[C#] public void EnumerateMetafile(Metafile, PointF[], EnumerateMetafileProc, int, ImageAttributes);
[C++] public: void EnumerateMetafile(Metafile*, PointF[], EnumerateMetafileProc, int, ImageAttributes);
[JScript] public function EnumerateMetafile(Metafile, PointF[], EnumerateMetafileProc, int, ImageAttributes);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, Rectangle, EnumerateMetafileProc)
[C#] public void EnumerateMetafile(Metafile, Rectangle, EnumerateMetafileProc);
[C++] public: void EnumerateMetafile(Metafile*, Rectangle, EnumerateMetafileProc);
[JScript] public function EnumerateMetafile(Metafile, Rectangle, EnumerateMetafileProc);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, RectangleF, EnumerateMetafileProc, Integer, ImageAttributes)
[C#] public void EnumerateMetafile(Metafile, RectangleF, EnumerateMetafileProc, int, ImageAttributes);
[C++] public: void EnumerateMetafile(Metafile*, RectangleF, EnumerateMetafileProc, int, ImageAttributes);
[JScript] public function EnumerateMetafile(Metafile, RectangleF, EnumerateMetafileProc, int, ImageAttributes);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, Rectangle, EnumerateMetafileProc, Integer, ImageAttributes)
[C#] public void EnumerateMetafile(Metafile, Rectangle, EnumerateMetafileProc, int, ImageAttributes);
[C++] public: void EnumerateMetafile(Metafile*, Rectangle, EnumerateMetafileProc, int, ImageAttributes);
[JScript] public function EnumerateMetafile(Metafile, Rectangle, EnumerateMetafileProc, int, ImageAttributes);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, Rectangle, EnumerateMetafileProc, Integer)
[C#] public void EnumerateMetafile(Metafile, Rectangle, EnumerateMetafileProc, int);
[C++] public: void EnumerateMetafile(Metafile*, Rectangle, EnumerateMetafileProc, int);
[JScript] public function EnumerateMetafile(Metafile, Rectangle, EnumerateMetafileProc, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, PointF(), RectangleF, GraphicsUnit, EnumerateMetafileProc, Integer, ImageAttributes)
[C#] public void EnumerateMetafile(Metafile, PointF[], RectangleF, GraphicsUnit, EnumerateMetafileProc, int, ImageAttributes);
[C++] public: void EnumerateMetafile(Metafile*, PointF[], RectangleF, GraphicsUnit, EnumerateMetafileProc, int, ImageAttributes);
[JScript] public function EnumerateMetafile(Metafile, PointF[], RectangleF, GraphicsUnit, EnumerateMetafileProc, int, ImageAttributes);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, Point(), Rectangle, GraphicsUnit, EnumerateMetafileProc, Integer, ImageAttributes)
[C#] public void EnumerateMetafile(Metafile, Point[], Rectangle, GraphicsUnit, EnumerateMetafileProc, int, ImageAttributes);
[C++] public: void EnumerateMetafile(Metafile*, Point[], Rectangle, GraphicsUnit, EnumerateMetafileProc, int, ImageAttributes);
[JScript] public function EnumerateMetafile(Metafile, Point[], Rectangle, GraphicsUnit, EnumerateMetafileProc, int, ImageAttributes);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, Point(), Rectangle, GraphicsUnit, EnumerateMetafileProc, Integer)
[C#] public void EnumerateMetafile(Metafile, Point[], Rectangle, GraphicsUnit, EnumerateMetafileProc, int);
[C++] public: void EnumerateMetafile(Metafile*, Point[], Rectangle, GraphicsUnit, EnumerateMetafileProc, int);
[JScript] public function EnumerateMetafile(Metafile, Point[], Rectangle, GraphicsUnit, EnumerateMetafileProc, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub EnumerateMetafile(Metafile, Point(), Rectangle, GraphicsUnit, EnumerateMetafileProc)
[C#] public void EnumerateMetafile(Metafile, Point[], Rectangle, GraphicsUnit, EnumerateMetafileProc);
[C++] public: void EnumerateMetafile(Metafile*, Point[], Rectangle, GraphicsUnit, EnumerateMetafileProc);
[JScript] public function EnumerateMetafile(Metafile, Point[], Rectangle, GraphicsUnit, EnumerateMetafileProc);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.EnumerateMetafile (Metafile, Point, Rectangle, GraphicsUnit, EnumerateMetafileProc)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destPoint As Point, _
   ByVal srcRect As Rectangle, _
   ByVal srcUnit As GraphicsUnit, _
   ByVal callback As Graphics.EnumerateMetafileProc _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   Point destPoint,
   Rectangle srcRect,
   GraphicsUnit srcUnit,
   Graphics.EnumerateMetafileProc callback
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   Point destPoint,
   Rectangle srcRect,
   GraphicsUnit srcUnit,
   Graphics.EnumerateMetafileProc* callback
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destPoint : Point,
   srcRect : Rectangle,
   srcUnit : GraphicsUnit,
   callback : Graphics.EnumerateMetafileProc
);

Parameters

metafile
[To be supplied.]
destPoint
[To be supplied.]
srcRect
[To be supplied.]
srcUnit
[To be supplied.]
callback
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, Point, Rectangle, GraphicsUnit, EnumerateMetafileProc, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destPoint As Point, _
   ByVal srcRect As Rectangle, _
   ByVal srcUnit As GraphicsUnit, _
   ByVal callback As Graphics.EnumerateMetafileProc, _
   ByVal callbackData As Integer _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   Point destPoint,
   Rectangle srcRect,
   GraphicsUnit srcUnit,
   Graphics.EnumerateMetafileProc callback,
   int callbackData
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   Point destPoint,
   Rectangle srcRect,
   GraphicsUnit srcUnit,
   Graphics.EnumerateMetafileProc* callback,
   int callbackData
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destPoint : Point,
   srcRect : Rectangle,
   srcUnit : GraphicsUnit,
   callback : Graphics.EnumerateMetafileProc,
   callbackData : int
);

Parameters

metafile
[To be supplied.]
destPoint
[To be supplied.]
srcRect
[To be supplied.]
srcUnit
[To be supplied.]
callback
[To be supplied.]
callbackData
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, Point, Rectangle, GraphicsUnit, EnumerateMetafileProc, Int32, ImageAttributes)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destPoint As Point, _
   ByVal srcRect As Rectangle, _
   ByVal unit As GraphicsUnit, _
   ByVal callback As Graphics.EnumerateMetafileProc, _
   ByVal callbackData As Integer, _
   ByVal imageAttr As ImageAttributes _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   Point destPoint,
   Rectangle srcRect,
   GraphicsUnit unit,
   Graphics.EnumerateMetafileProc callback,
   int callbackData,
   ImageAttributes imageAttr
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   Point destPoint,
   Rectangle srcRect,
   GraphicsUnit unit,
   Graphics.EnumerateMetafileProc* callback,
   int callbackData,
   ImageAttributes* imageAttr
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destPoint : Point,
   srcRect : Rectangle,
   unit : GraphicsUnit,
   callback : Graphics.EnumerateMetafileProc,
   callbackData : int,
   imageAttr : ImageAttributes
);

Parameters

metafile
[To be supplied.]
destPoint
[To be supplied.]
srcRect
[To be supplied.]
unit
[To be supplied.]
callback
[To be supplied.]
callbackData
[To be supplied.]
imageAttr
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, PointF, RectangleF, GraphicsUnit, EnumerateMetafileProc)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destPoint As PointF, _
   ByVal srcRect As RectangleF, _
   ByVal srcUnit As GraphicsUnit, _
   ByVal callback As Graphics.EnumerateMetafileProc _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   PointF destPoint,
   RectangleF srcRect,
   GraphicsUnit srcUnit,
   Graphics.EnumerateMetafileProc callback
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   PointF destPoint,
   RectangleF srcRect,
   GraphicsUnit srcUnit,
   Graphics.EnumerateMetafileProc* callback
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destPoint : PointF,
   srcRect : RectangleF,
   srcUnit : GraphicsUnit,
   callback : Graphics.EnumerateMetafileProc
);

Parameters

metafile
[To be supplied.]
destPoint
[To be supplied.]
srcRect
[To be supplied.]
srcUnit
[To be supplied.]
callback
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, Point[], EnumerateMetafileProc, Int32, ImageAttributes)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destPoints() As Point, _
   ByVal callback As Graphics.EnumerateMetafileProc, _
   ByVal callbackData As Integer, _
   ByVal imageAttr As ImageAttributes _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   Point[] destPoints,
   Graphics.EnumerateMetafileProc callback,
   int callbackData,
   ImageAttributes imageAttr
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   Point* destPoints[],
   Graphics.EnumerateMetafileProc* callback,
   int callbackData,
   ImageAttributes* imageAttr
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destPoints : Point[],
   callback : Graphics.EnumerateMetafileProc,
   callbackData : int,
   imageAttr : ImageAttributes
);

Parameters

metafile
[To be supplied.]
destPoints
[To be supplied.]
callback
[To be supplied.]
callbackData
[To be supplied.]
imageAttr
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, PointF, RectangleF, GraphicsUnit, EnumerateMetafileProc, Int32, ImageAttributes)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destPoint As PointF, _
   ByVal srcRect As RectangleF, _
   ByVal unit As GraphicsUnit, _
   ByVal callback As Graphics.EnumerateMetafileProc, _
   ByVal callbackData As Integer, _
   ByVal imageAttr As ImageAttributes _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   PointF destPoint,
   RectangleF srcRect,
   GraphicsUnit unit,
   Graphics.EnumerateMetafileProc callback,
   int callbackData,
   ImageAttributes imageAttr
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   PointF destPoint,
   RectangleF srcRect,
   GraphicsUnit unit,
   Graphics.EnumerateMetafileProc* callback,
   int callbackData,
   ImageAttributes* imageAttr
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destPoint : PointF,
   srcRect : RectangleF,
   unit : GraphicsUnit,
   callback : Graphics.EnumerateMetafileProc,
   callbackData : int,
   imageAttr : ImageAttributes
);

Parameters

metafile
[To be supplied.]
destPoint
[To be supplied.]
srcRect
[To be supplied.]
unit
[To be supplied.]
callback
[To be supplied.]
callbackData
[To be supplied.]
imageAttr
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, PointF, RectangleF, GraphicsUnit, EnumerateMetafileProc, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destPoint As PointF, _
   ByVal srcRect As RectangleF, _
   ByVal srcUnit As GraphicsUnit, _
   ByVal callback As Graphics.EnumerateMetafileProc, _
   ByVal callbackData As Integer _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   PointF destPoint,
   RectangleF srcRect,
   GraphicsUnit srcUnit,
   Graphics.EnumerateMetafileProc callback,
   int callbackData
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   PointF destPoint,
   RectangleF srcRect,
   GraphicsUnit srcUnit,
   Graphics.EnumerateMetafileProc* callback,
   int callbackData
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destPoint : PointF,
   srcRect : RectangleF,
   srcUnit : GraphicsUnit,
   callback : Graphics.EnumerateMetafileProc,
   callbackData : int
);

Parameters

metafile
[To be supplied.]
destPoint
[To be supplied.]
srcRect
[To be supplied.]
srcUnit
[To be supplied.]
callback
[To be supplied.]
callbackData
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, RectangleF, RectangleF, GraphicsUnit, EnumerateMetafileProc)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destRect As RectangleF, _
   ByVal srcRect As RectangleF, _
   ByVal srcUnit As GraphicsUnit, _
   ByVal callback As Graphics.EnumerateMetafileProc _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   RectangleF destRect,
   RectangleF srcRect,
   GraphicsUnit srcUnit,
   Graphics.EnumerateMetafileProc callback
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   RectangleF destRect,
   RectangleF srcRect,
   GraphicsUnit srcUnit,
   Graphics.EnumerateMetafileProc* callback
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destRect : RectangleF,
   srcRect : RectangleF,
   srcUnit : GraphicsUnit,
   callback : Graphics.EnumerateMetafileProc
);

Parameters

metafile
[To be supplied.]
destRect
[To be supplied.]
srcRect
[To be supplied.]
srcUnit
[To be supplied.]
callback
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, Rectangle, Rectangle, GraphicsUnit, EnumerateMetafileProc, Int32, ImageAttributes)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destRect As Rectangle, _
   ByVal srcRect As Rectangle, _
   ByVal unit As GraphicsUnit, _
   ByVal callback As Graphics.EnumerateMetafileProc, _
   ByVal callbackData As Integer, _
   ByVal imageAttr As ImageAttributes _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   Rectangle destRect,
   Rectangle srcRect,
   GraphicsUnit unit,
   Graphics.EnumerateMetafileProc callback,
   int callbackData,
   ImageAttributes imageAttr
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   Rectangle destRect,
   Rectangle srcRect,
   GraphicsUnit unit,
   Graphics.EnumerateMetafileProc* callback,
   int callbackData,
   ImageAttributes* imageAttr
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destRect : Rectangle,
   srcRect : Rectangle,
   unit : GraphicsUnit,
   callback : Graphics.EnumerateMetafileProc,
   callbackData : int,
   imageAttr : ImageAttributes
);

Parameters

metafile
[To be supplied.]
destRect
[To be supplied.]
srcRect
[To be supplied.]
unit
[To be supplied.]
callback
[To be supplied.]
callbackData
[To be supplied.]
imageAttr
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, PointF[], RectangleF, GraphicsUnit, EnumerateMetafileProc)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destPoints() As PointF, _
   ByVal srcRect As RectangleF, _
   ByVal srcUnit As GraphicsUnit, _
   ByVal callback As Graphics.EnumerateMetafileProc _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   PointF[] destPoints,
   RectangleF srcRect,
   GraphicsUnit srcUnit,
   Graphics.EnumerateMetafileProc callback
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   PointF* destPoints[],
   RectangleF srcRect,
   GraphicsUnit srcUnit,
   Graphics.EnumerateMetafileProc* callback
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destPoints : PointF[],
   srcRect : RectangleF,
   srcUnit : GraphicsUnit,
   callback : Graphics.EnumerateMetafileProc
);

Parameters

metafile
[To be supplied.]
destPoints
[To be supplied.]
srcRect
[To be supplied.]
srcUnit
[To be supplied.]
callback
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, PointF[], RectangleF, GraphicsUnit, EnumerateMetafileProc, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destPoints() As PointF, _
   ByVal srcRect As RectangleF, _
   ByVal srcUnit As GraphicsUnit, _
   ByVal callback As Graphics.EnumerateMetafileProc, _
   ByVal callbackData As Integer _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   PointF[] destPoints,
   RectangleF srcRect,
   GraphicsUnit srcUnit,
   Graphics.EnumerateMetafileProc callback,
   int callbackData
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   PointF* destPoints[],
   RectangleF srcRect,
   GraphicsUnit srcUnit,
   Graphics.EnumerateMetafileProc* callback,
   int callbackData
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destPoints : PointF[],
   srcRect : RectangleF,
   srcUnit : GraphicsUnit,
   callback : Graphics.EnumerateMetafileProc,
   callbackData : int
);

Parameters

metafile
[To be supplied.]
destPoints
[To be supplied.]
srcRect
[To be supplied.]
srcUnit
[To be supplied.]
callback
[To be supplied.]
callbackData
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, Rectangle, Rectangle, GraphicsUnit, EnumerateMetafileProc, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destRect As Rectangle, _
   ByVal srcRect As Rectangle, _
   ByVal srcUnit As GraphicsUnit, _
   ByVal callback As Graphics.EnumerateMetafileProc, _
   ByVal callbackData As Integer _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   Rectangle destRect,
   Rectangle srcRect,
   GraphicsUnit srcUnit,
   Graphics.EnumerateMetafileProc callback,
   int callbackData
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   Rectangle destRect,
   Rectangle srcRect,
   GraphicsUnit srcUnit,
   Graphics.EnumerateMetafileProc* callback,
   int callbackData
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destRect : Rectangle,
   srcRect : Rectangle,
   srcUnit : GraphicsUnit,
   callback : Graphics.EnumerateMetafileProc,
   callbackData : int
);

Parameters

metafile
[To be supplied.]
destRect
[To be supplied.]
srcRect
[To be supplied.]
srcUnit
[To be supplied.]
callback
[To be supplied.]
callbackData
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, RectangleF, RectangleF, GraphicsUnit, EnumerateMetafileProc, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destRect As RectangleF, _
   ByVal srcRect As RectangleF, _
   ByVal srcUnit As GraphicsUnit, _
   ByVal callback As Graphics.EnumerateMetafileProc, _
   ByVal callbackData As Integer _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   RectangleF destRect,
   RectangleF srcRect,
   GraphicsUnit srcUnit,
   Graphics.EnumerateMetafileProc callback,
   int callbackData
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   RectangleF destRect,
   RectangleF srcRect,
   GraphicsUnit srcUnit,
   Graphics.EnumerateMetafileProc* callback,
   int callbackData
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destRect : RectangleF,
   srcRect : RectangleF,
   srcUnit : GraphicsUnit,
   callback : Graphics.EnumerateMetafileProc,
   callbackData : int
);

Parameters

metafile
[To be supplied.]
destRect
[To be supplied.]
srcRect
[To be supplied.]
srcUnit
[To be supplied.]
callback
[To be supplied.]
callbackData
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, RectangleF, RectangleF, GraphicsUnit, EnumerateMetafileProc, Int32, ImageAttributes)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destRect As RectangleF, _
   ByVal srcRect As RectangleF, _
   ByVal unit As GraphicsUnit, _
   ByVal callback As Graphics.EnumerateMetafileProc, _
   ByVal callbackData As Integer, _
   ByVal imageAttr As ImageAttributes _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   RectangleF destRect,
   RectangleF srcRect,
   GraphicsUnit unit,
   Graphics.EnumerateMetafileProc callback,
   int callbackData,
   ImageAttributes imageAttr
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   RectangleF destRect,
   RectangleF srcRect,
   GraphicsUnit unit,
   Graphics.EnumerateMetafileProc* callback,
   int callbackData,
   ImageAttributes* imageAttr
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destRect : RectangleF,
   srcRect : RectangleF,
   unit : GraphicsUnit,
   callback : Graphics.EnumerateMetafileProc,
   callbackData : int,
   imageAttr : ImageAttributes
);

Parameters

metafile
[To be supplied.]
destRect
[To be supplied.]
srcRect
[To be supplied.]
unit
[To be supplied.]
callback
[To be supplied.]
callbackData
[To be supplied.]
imageAttr
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, Rectangle, Rectangle, GraphicsUnit, EnumerateMetafileProc)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destRect As Rectangle, _
   ByVal srcRect As Rectangle, _
   ByVal srcUnit As GraphicsUnit, _
   ByVal callback As Graphics.EnumerateMetafileProc _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   Rectangle destRect,
   Rectangle srcRect,
   GraphicsUnit srcUnit,
   Graphics.EnumerateMetafileProc callback
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   Rectangle destRect,
   Rectangle srcRect,
   GraphicsUnit srcUnit,
   Graphics.EnumerateMetafileProc* callback
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destRect : Rectangle,
   srcRect : Rectangle,
   srcUnit : GraphicsUnit,
   callback : Graphics.EnumerateMetafileProc
);

Parameters

metafile
[To be supplied.]
destRect
[To be supplied.]
srcRect
[To be supplied.]
srcUnit
[To be supplied.]
callback
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, Point[], EnumerateMetafileProc, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destPoints() As Point, _
   ByVal callback As Graphics.EnumerateMetafileProc, _
   ByVal callbackData As Integer _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   Point[] destPoints,
   Graphics.EnumerateMetafileProc callback,
   int callbackData
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   Point* destPoints[],
   Graphics.EnumerateMetafileProc* callback,
   int callbackData
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destPoints : Point[],
   callback : Graphics.EnumerateMetafileProc,
   callbackData : int
);

Parameters

metafile
[To be supplied.]
destPoints
[To be supplied.]
callback
[To be supplied.]
callbackData
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, Point, EnumerateMetafileProc, Int32, ImageAttributes)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destPoint As Point, _
   ByVal callback As Graphics.EnumerateMetafileProc, _
   ByVal callbackData As Integer, _
   ByVal imageAttr As ImageAttributes _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   Point destPoint,
   Graphics.EnumerateMetafileProc callback,
   int callbackData,
   ImageAttributes imageAttr
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   Point destPoint,
   Graphics.EnumerateMetafileProc* callback,
   int callbackData,
   ImageAttributes* imageAttr
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destPoint : Point,
   callback : Graphics.EnumerateMetafileProc,
   callbackData : int,
   imageAttr : ImageAttributes
);

Parameters

metafile
[To be supplied.]
destPoint
[To be supplied.]
callback
[To be supplied.]
callbackData
[To be supplied.]
imageAttr
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, Point, EnumerateMetafileProc, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destPoint As Point, _
   ByVal callback As Graphics.EnumerateMetafileProc, _
   ByVal callbackData As Integer _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   Point destPoint,
   Graphics.EnumerateMetafileProc callback,
   int callbackData
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   Point destPoint,
   Graphics.EnumerateMetafileProc* callback,
   int callbackData
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destPoint : Point,
   callback : Graphics.EnumerateMetafileProc,
   callbackData : int
);

Parameters

metafile
[To be supplied.]
destPoint
[To be supplied.]
callback
[To be supplied.]
callbackData
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, RectangleF, EnumerateMetafileProc, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destRect As RectangleF, _
   ByVal callback As Graphics.EnumerateMetafileProc, _
   ByVal callbackData As Integer _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   RectangleF destRect,
   Graphics.EnumerateMetafileProc callback,
   int callbackData
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   RectangleF destRect,
   Graphics.EnumerateMetafileProc* callback,
   int callbackData
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destRect : RectangleF,
   callback : Graphics.EnumerateMetafileProc,
   callbackData : int
);

Parameters

metafile
[To be supplied.]
destRect
[To be supplied.]
callback
[To be supplied.]
callbackData
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, RectangleF, EnumerateMetafileProc)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destRect As RectangleF, _
   ByVal callback As Graphics.EnumerateMetafileProc _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   RectangleF destRect,
   Graphics.EnumerateMetafileProc callback
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   RectangleF destRect,
   Graphics.EnumerateMetafileProc* callback
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destRect : RectangleF,
   callback : Graphics.EnumerateMetafileProc
);

Parameters

metafile
[To be supplied.]
destRect
[To be supplied.]
callback
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, PointF, EnumerateMetafileProc, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destPoint As PointF, _
   ByVal callback As Graphics.EnumerateMetafileProc, _
   ByVal callbackData As Integer _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   PointF destPoint,
   Graphics.EnumerateMetafileProc callback,
   int callbackData
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   PointF destPoint,
   Graphics.EnumerateMetafileProc* callback,
   int callbackData
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destPoint : PointF,
   callback : Graphics.EnumerateMetafileProc,
   callbackData : int
);

Parameters

metafile
[To be supplied.]
destPoint
[To be supplied.]
callback
[To be supplied.]
callbackData
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, PointF, EnumerateMetafileProc)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destPoint As PointF, _
   ByVal callback As Graphics.EnumerateMetafileProc _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   PointF destPoint,
   Graphics.EnumerateMetafileProc callback
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   PointF destPoint,
   Graphics.EnumerateMetafileProc* callback
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destPoint : PointF,
   callback : Graphics.EnumerateMetafileProc
);

Parameters

metafile
[To be supplied.]
destPoint
[To be supplied.]
callback
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, Point, EnumerateMetafileProc)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destPoint As Point, _
   ByVal callback As Graphics.EnumerateMetafileProc _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   Point destPoint,
   Graphics.EnumerateMetafileProc callback
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   Point destPoint,
   Graphics.EnumerateMetafileProc* callback
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destPoint : Point,
   callback : Graphics.EnumerateMetafileProc
);

Parameters

metafile
[To be supplied.]
destPoint
[To be supplied.]
callback
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, PointF, EnumerateMetafileProc, Int32, ImageAttributes)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destPoint As PointF, _
   ByVal callback As Graphics.EnumerateMetafileProc, _
   ByVal callbackData As Integer, _
   ByVal imageAttr As ImageAttributes _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   PointF destPoint,
   Graphics.EnumerateMetafileProc callback,
   int callbackData,
   ImageAttributes imageAttr
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   PointF destPoint,
   Graphics.EnumerateMetafileProc* callback,
   int callbackData,
   ImageAttributes* imageAttr
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destPoint : PointF,
   callback : Graphics.EnumerateMetafileProc,
   callbackData : int,
   imageAttr : ImageAttributes
);

Parameters

metafile
[To be supplied.]
destPoint
[To be supplied.]
callback
[To be supplied.]
callbackData
[To be supplied.]
imageAttr
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, PointF[], EnumerateMetafileProc, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destPoints() As PointF, _
   ByVal callback As Graphics.EnumerateMetafileProc, _
   ByVal callbackData As Integer _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   PointF[] destPoints,
   Graphics.EnumerateMetafileProc callback,
   int callbackData
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   PointF* destPoints[],
   Graphics.EnumerateMetafileProc* callback,
   int callbackData
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destPoints : PointF[],
   callback : Graphics.EnumerateMetafileProc,
   callbackData : int
);

Parameters

metafile
[To be supplied.]
destPoints
[To be supplied.]
callback
[To be supplied.]
callbackData
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, PointF[], EnumerateMetafileProc)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destPoints() As PointF, _
   ByVal callback As Graphics.EnumerateMetafileProc _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   PointF[] destPoints,
   Graphics.EnumerateMetafileProc callback
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   PointF* destPoints[],
   Graphics.EnumerateMetafileProc* callback
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destPoints : PointF[],
   callback : Graphics.EnumerateMetafileProc
);

Parameters

metafile
[To be supplied.]
destPoints
[To be supplied.]
callback
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, Point[], EnumerateMetafileProc)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destPoints() As Point, _
   ByVal callback As Graphics.EnumerateMetafileProc _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   Point[] destPoints,
   Graphics.EnumerateMetafileProc callback
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   Point* destPoints[],
   Graphics.EnumerateMetafileProc* callback
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destPoints : Point[],
   callback : Graphics.EnumerateMetafileProc
);

Parameters

metafile
[To be supplied.]
destPoints
[To be supplied.]
callback
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, PointF[], EnumerateMetafileProc, Int32, ImageAttributes)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destPoints() As PointF, _
   ByVal callback As Graphics.EnumerateMetafileProc, _
   ByVal callbackData As Integer, _
   ByVal imageAttr As ImageAttributes _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   PointF[] destPoints,
   Graphics.EnumerateMetafileProc callback,
   int callbackData,
   ImageAttributes imageAttr
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   PointF* destPoints[],
   Graphics.EnumerateMetafileProc* callback,
   int callbackData,
   ImageAttributes* imageAttr
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destPoints : PointF[],
   callback : Graphics.EnumerateMetafileProc,
   callbackData : int,
   imageAttr : ImageAttributes
);

Parameters

metafile
[To be supplied.]
destPoints
[To be supplied.]
callback
[To be supplied.]
callbackData
[To be supplied.]
imageAttr
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, Rectangle, EnumerateMetafileProc)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destRect As Rectangle, _
   ByVal callback As Graphics.EnumerateMetafileProc _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   Rectangle destRect,
   Graphics.EnumerateMetafileProc callback
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   Rectangle destRect,
   Graphics.EnumerateMetafileProc* callback
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destRect : Rectangle,
   callback : Graphics.EnumerateMetafileProc
);

Parameters

metafile
[To be supplied.]
destRect
[To be supplied.]
callback
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, RectangleF, EnumerateMetafileProc, Int32, ImageAttributes)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destRect As RectangleF, _
   ByVal callback As Graphics.EnumerateMetafileProc, _
   ByVal callbackData As Integer, _
   ByVal imageAttr As ImageAttributes _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   RectangleF destRect,
   Graphics.EnumerateMetafileProc callback,
   int callbackData,
   ImageAttributes imageAttr
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   RectangleF destRect,
   Graphics.EnumerateMetafileProc* callback,
   int callbackData,
   ImageAttributes* imageAttr
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destRect : RectangleF,
   callback : Graphics.EnumerateMetafileProc,
   callbackData : int,
   imageAttr : ImageAttributes
);

Parameters

metafile
[To be supplied.]
destRect
[To be supplied.]
callback
[To be supplied.]
callbackData
[To be supplied.]
imageAttr
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, Rectangle, EnumerateMetafileProc, Int32, ImageAttributes)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destRect As Rectangle, _
   ByVal callback As Graphics.EnumerateMetafileProc, _
   ByVal callbackData As Integer, _
   ByVal imageAttr As ImageAttributes _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   Rectangle destRect,
   Graphics.EnumerateMetafileProc callback,
   int callbackData,
   ImageAttributes imageAttr
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   Rectangle destRect,
   Graphics.EnumerateMetafileProc* callback,
   int callbackData,
   ImageAttributes* imageAttr
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destRect : Rectangle,
   callback : Graphics.EnumerateMetafileProc,
   callbackData : int,
   imageAttr : ImageAttributes
);

Parameters

metafile
[To be supplied.]
destRect
[To be supplied.]
callback
[To be supplied.]
callbackData
[To be supplied.]
imageAttr
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, Rectangle, EnumerateMetafileProc, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destRect As Rectangle, _
   ByVal callback As Graphics.EnumerateMetafileProc, _
   ByVal callbackData As Integer _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   Rectangle destRect,
   Graphics.EnumerateMetafileProc callback,
   int callbackData
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   Rectangle destRect,
   Graphics.EnumerateMetafileProc* callback,
   int callbackData
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destRect : Rectangle,
   callback : Graphics.EnumerateMetafileProc,
   callbackData : int
);

Parameters

metafile
[To be supplied.]
destRect
[To be supplied.]
callback
[To be supplied.]
callbackData
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, PointF[], RectangleF, GraphicsUnit, EnumerateMetafileProc, Int32, ImageAttributes)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destPoints() As PointF, _
   ByVal srcRect As RectangleF, _
   ByVal unit As GraphicsUnit, _
   ByVal callback As Graphics.EnumerateMetafileProc, _
   ByVal callbackData As Integer, _
   ByVal imageAttr As ImageAttributes _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   PointF[] destPoints,
   RectangleF srcRect,
   GraphicsUnit unit,
   Graphics.EnumerateMetafileProc callback,
   int callbackData,
   ImageAttributes imageAttr
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   PointF* destPoints[],
   RectangleF srcRect,
   GraphicsUnit unit,
   Graphics.EnumerateMetafileProc* callback,
   int callbackData,
   ImageAttributes* imageAttr
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destPoints : PointF[],
   srcRect : RectangleF,
   unit : GraphicsUnit,
   callback : Graphics.EnumerateMetafileProc,
   callbackData : int,
   imageAttr : ImageAttributes
);

Parameters

metafile
[To be supplied.]
destPoints
[To be supplied.]
srcRect
[To be supplied.]
unit
[To be supplied.]
callback
[To be supplied.]
callbackData
[To be supplied.]
imageAttr
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, Point[], Rectangle, GraphicsUnit, EnumerateMetafileProc, Int32, ImageAttributes)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destPoints() As Point, _
   ByVal srcRect As Rectangle, _
   ByVal unit As GraphicsUnit, _
   ByVal callback As Graphics.EnumerateMetafileProc, _
   ByVal callbackData As Integer, _
   ByVal imageAttr As ImageAttributes _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   Point[] destPoints,
   Rectangle srcRect,
   GraphicsUnit unit,
   Graphics.EnumerateMetafileProc callback,
   int callbackData,
   ImageAttributes imageAttr
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   Point* destPoints[],
   Rectangle srcRect,
   GraphicsUnit unit,
   Graphics.EnumerateMetafileProc* callback,
   int callbackData,
   ImageAttributes* imageAttr
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destPoints : Point[],
   srcRect : Rectangle,
   unit : GraphicsUnit,
   callback : Graphics.EnumerateMetafileProc,
   callbackData : int,
   imageAttr : ImageAttributes
);

Parameters

metafile
[To be supplied.]
destPoints
[To be supplied.]
srcRect
[To be supplied.]
unit
[To be supplied.]
callback
[To be supplied.]
callbackData
[To be supplied.]
imageAttr
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, Point[], Rectangle, GraphicsUnit, EnumerateMetafileProc, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destPoints() As Point, _
   ByVal srcRect As Rectangle, _
   ByVal srcUnit As GraphicsUnit, _
   ByVal callback As Graphics.EnumerateMetafileProc, _
   ByVal callbackData As Integer _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   Point[] destPoints,
   Rectangle srcRect,
   GraphicsUnit srcUnit,
   Graphics.EnumerateMetafileProc callback,
   int callbackData
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   Point* destPoints[],
   Rectangle srcRect,
   GraphicsUnit srcUnit,
   Graphics.EnumerateMetafileProc* callback,
   int callbackData
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destPoints : Point[],
   srcRect : Rectangle,
   srcUnit : GraphicsUnit,
   callback : Graphics.EnumerateMetafileProc,
   callbackData : int
);

Parameters

metafile
[To be supplied.]
destPoints
[To be supplied.]
srcRect
[To be supplied.]
srcUnit
[To be supplied.]
callback
[To be supplied.]
callbackData
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.EnumerateMetafile (Metafile, Point[], Rectangle, GraphicsUnit, EnumerateMetafileProc)

[To be supplied.]

[Visual Basic]
Overloads Public Sub EnumerateMetafile( _
   ByVal metafile As Metafile, _
   ByVal destPoints() As Point, _
   ByVal srcRect As Rectangle, _
   ByVal srcUnit As GraphicsUnit, _
   ByVal callback As Graphics.EnumerateMetafileProc _
)
[C#]
public void EnumerateMetafile(
   Metafile metafile,
   Point[] destPoints,
   Rectangle srcRect,
   GraphicsUnit srcUnit,
   Graphics.EnumerateMetafileProc callback
);
[C++]
public: void EnumerateMetafile(
   Metafile* metafile,
   Point* destPoints[],
   Rectangle srcRect,
   GraphicsUnit srcUnit,
   Graphics.EnumerateMetafileProc* callback
);
[JScript]
public function EnumerateMetafile(
   metafile : Metafile,
   destPoints : Point[],
   srcRect : Rectangle,
   srcUnit : GraphicsUnit,
   callback : Graphics.EnumerateMetafileProc
);

Parameters

metafile
[To be supplied.]
destPoints
[To be supplied.]
srcRect
[To be supplied.]
srcUnit
[To be supplied.]
callback
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.EnumerateMetafile Overload List


Graphics.ExcludeClip

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub ExcludeClip(Region)
[C#] public void ExcludeClip(Region);
[C++] public: void ExcludeClip(Region*);
[JScript] public function ExcludeClip(Region);

[To be supplied.]

[Visual Basic] Overloads Public Sub ExcludeClip(Rectangle)
[C#] public void ExcludeClip(Rectangle);
[C++] public: void ExcludeClip(Rectangle);
[JScript] public function ExcludeClip(Rectangle);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.ExcludeClip (Region)

[To be supplied.]

[Visual Basic]
Overloads Public Sub ExcludeClip( _
   ByVal region As Region _
)
[C#]
public void ExcludeClip(
   Region region
);
[C++]
public: void ExcludeClip(
   Region* region
);
[JScript]
public function ExcludeClip(
   region : Region
);

Parameters

region
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.ExcludeClip Overload List


Graphics.ExcludeClip (Rectangle)

[To be supplied.]

[Visual Basic]
Overloads Public Sub ExcludeClip( _
   ByVal rect As Rectangle _
)
[C#]
public void ExcludeClip(
   Rectangle rect
);
[C++]
public: void ExcludeClip(
   Rectangle rect
);
[JScript]
public function ExcludeClip(
   rect : Rectangle
);

Parameters

rect
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.ExcludeClip Overload List


Graphics.FillClosedCurve

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub FillClosedCurve(Brush, Point(), FillMode)
[C#] public void FillClosedCurve(Brush, Point[], FillMode);
[C++] public: void FillClosedCurve(Brush*, Point[], FillMode);
[JScript] public function FillClosedCurve(Brush, Point[], FillMode);

[To be supplied.]

[Visual Basic] Overloads Public Sub FillClosedCurve(Brush, Point(), FillMode, Single)
[C#] public void FillClosedCurve(Brush, Point[], FillMode, float);
[C++] public: void FillClosedCurve(Brush*, Point[], FillMode, float);
[JScript] public function FillClosedCurve(Brush, Point[], FillMode, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub FillClosedCurve(Brush, PointF())
[C#] public void FillClosedCurve(Brush, PointF[]);
[C++] public: void FillClosedCurve(Brush*, PointF[]);
[JScript] public function FillClosedCurve(Brush, PointF[]);

Fills the interior of a closed curve defined by an array of points.

[Visual Basic] Overloads Public Sub FillClosedCurve(Brush, PointF(), FillMode)
[C#] public void FillClosedCurve(Brush, PointF[], FillMode);
[C++] public: void FillClosedCurve(Brush*, PointF[], FillMode);
[JScript] public function FillClosedCurve(Brush, PointF[], FillMode);

[To be supplied.]

[Visual Basic] Overloads Public Sub FillClosedCurve(Brush, PointF(), FillMode, Single)
[C#] public void FillClosedCurve(Brush, PointF[], FillMode, float);
[C++] public: void FillClosedCurve(Brush*, PointF[], FillMode, float);
[JScript] public function FillClosedCurve(Brush, PointF[], FillMode, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub FillClosedCurve(Brush, Point())
[C#] public void FillClosedCurve(Brush, Point[]);
[C++] public: void FillClosedCurve(Brush*, Point[]);
[JScript] public function FillClosedCurve(Brush, Point[]);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.FillClosedCurve (Brush, Point[], FillMode)

[To be supplied.]

[Visual Basic]
Overloads Public Sub FillClosedCurve( _
   ByVal brush As Brush, _
   ByVal points() As Point, _
   ByVal fillmode As FillMode _
)
[C#]
public void FillClosedCurve(
   Brush brush,
   Point[] points,
   FillMode fillmode
);
[C++]
public: void FillClosedCurve(
   Brush* brush,
   Point* points[],
   FillMode fillmode
);
[JScript]
public function FillClosedCurve(
   brush : Brush,
   points : Point[],
   fillmode : FillMode
);

Parameters

brush
[To be supplied.]
points
[To be supplied.]
fillmode
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.FillClosedCurve Overload List


Graphics.FillClosedCurve (Brush, Point[], FillMode, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub FillClosedCurve( _
   ByVal brush As Brush, _
   ByVal points() As Point, _
   ByVal fillmode As FillMode, _
   ByVal tension As Single _
)
[C#]
public void FillClosedCurve(
   Brush brush,
   Point[] points,
   FillMode fillmode,
   float tension
);
[C++]
public: void FillClosedCurve(
   Brush* brush,
   Point* points[],
   FillMode fillmode,
   float tension
);
[JScript]
public function FillClosedCurve(
   brush : Brush,
   points : Point[],
   fillmode : FillMode,
   tension : float
);

Parameters

brush
[To be supplied.]
points
[To be supplied.]
fillmode
[To be supplied.]
tension
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.FillClosedCurve Overload List


Graphics.FillClosedCurve (Brush, PointF[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub FillClosedCurve( _
   ByVal brush As Brush, _
   ByVal points() As PointF _
)
[C#]
public void FillClosedCurve(
   Brush brush,
   PointF[] points
);
[C++]
public: void FillClosedCurve(
   Brush* brush,
   PointF* points[]
);
[JScript]
public function FillClosedCurve(
   brush : Brush,
   points : PointF[]
);

Parameters

brush
[To be supplied.]
points
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.FillClosedCurve Overload List


Graphics.FillClosedCurve (Brush, PointF[], FillMode)

Fills the interior of a closed curve defined by an array of points.

[Visual Basic]
Overloads Public Sub FillClosedCurve( _
   ByVal brush As Brush, _
   ByVal points() As PointF, _
   ByVal fillmode As FillMode _
)
[C#]
public void FillClosedCurve(
   Brush brush,
   PointF[] points,
   FillMode fillmode
);
[C++]
public: void FillClosedCurve(
   Brush* brush,
   PointF* points[],
   FillMode fillmode
);
[JScript]
public function FillClosedCurve(
   brush : Brush,
   points : PointF[],
   fillmode : FillMode
);

Parameters

brush
A Brush that determines the characteristics of the fill pattern.
points
An array of PointF objects that represent the points through which the curve passes.
fillmode
A FillMode that determines the

Remarks

This method fills the interior of a smooth closed curve that passes through each point in thearray. If the last point indoes not match the first point, then the curve is closed by connecting the last point to the first point.

Theparameter determines the shape of the curve. If the value ofis 0, this method draws line segments to connect the points.

The points array must contain at least 4 elements.

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.FillClosedCurve Overload List


Graphics.FillClosedCurve (Brush, PointF[], FillMode, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub FillClosedCurve( _
   ByVal brush As Brush, _
   ByVal points() As PointF, _
   ByVal fillmode As FillMode, _
   ByVal tension As Single _
)
[C#]
public void FillClosedCurve(
   Brush brush,
   PointF[] points,
   FillMode fillmode,
   float tension
);
[C++]
public: void FillClosedCurve(
   Brush* brush,
   PointF* points[],
   FillMode fillmode,
   float tension
);
[JScript]
public function FillClosedCurve(
   brush : Brush,
   points : PointF[],
   fillmode : FillMode,
   tension : float
);

Parameters

brush
[To be supplied.]
points
[To be supplied.]
fillmode
[To be supplied.]
tension
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.FillClosedCurve Overload List


Graphics.FillClosedCurve (Brush, Point[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub FillClosedCurve( _
   ByVal brush As Brush, _
   ByVal points() As Point _
)
[C#]
public void FillClosedCurve(
   Brush brush,
   Point[] points
);
[C++]
public: void FillClosedCurve(
   Brush* brush,
   Point* points[]
);
[JScript]
public function FillClosedCurve(
   brush : Brush,
   points : Point[]
);

Parameters

brush
[To be supplied.]
points
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.FillClosedCurve Overload List


Graphics.FillEllipse

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub FillEllipse(Brush, Single, Single, Single, Single)
[C#] public void FillEllipse(Brush, float, float, float, float);
[C++] public: void FillEllipse(Brush*, float, float, float, float);
[JScript] public function FillEllipse(Brush, float, float, float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub FillEllipse(Brush, RectangleF)
[C#] public void FillEllipse(Brush, RectangleF);
[C++] public: void FillEllipse(Brush*, RectangleF);
[JScript] public function FillEllipse(Brush, RectangleF);

[To be supplied.]

[Visual Basic] Overloads Public Sub FillEllipse(Brush, Rectangle)
[C#] public void FillEllipse(Brush, Rectangle);
[C++] public: void FillEllipse(Brush*, Rectangle);
[JScript] public function FillEllipse(Brush, Rectangle);

[To be supplied.]

[Visual Basic] Overloads Public Sub FillEllipse(Brush, Integer, Integer, Integer, Integer)
[C#] public void FillEllipse(Brush, int, int, int, int);
[C++] public: void FillEllipse(Brush*, int, int, int, int);
[JScript] public function FillEllipse(Brush, int, int, int, int);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.FillEllipse (Brush, Single, Single, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub FillEllipse( _
   ByVal brush As Brush, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
[C#]
public void FillEllipse(
   Brush brush,
   float x,
   float y,
   float width,
   float height
);
[C++]
public: void FillEllipse(
   Brush* brush,
   float x,
   float y,
   float width,
   float height
);
[JScript]
public function FillEllipse(
   brush : Brush,
   x : float,
   y : float,
   width : float,
   height : float
);

Parameters

brush
[To be supplied.]
x
[To be supplied.]
y
[To be supplied.]
width
[To be supplied.]
height
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.FillEllipse Overload List


Graphics.FillEllipse (Brush, RectangleF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub FillEllipse( _
   ByVal brush As Brush, _
   ByVal rect As RectangleF _
)
[C#]
public void FillEllipse(
   Brush brush,
   RectangleF rect
);
[C++]
public: void FillEllipse(
   Brush* brush,
   RectangleF rect
);
[JScript]
public function FillEllipse(
   brush : Brush,
   rect : RectangleF
);

Parameters

brush
[To be supplied.]
rect
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.FillEllipse Overload List


Graphics.FillEllipse (Brush, Rectangle)

[To be supplied.]

[Visual Basic]
Overloads Public Sub FillEllipse( _
   ByVal brush As Brush, _
   ByVal rect As Rectangle _
)
[C#]
public void FillEllipse(
   Brush brush,
   Rectangle rect
);
[C++]
public: void FillEllipse(
   Brush* brush,
   Rectangle rect
);
[JScript]
public function FillEllipse(
   brush : Brush,
   rect : Rectangle
);

Parameters

brush
[To be supplied.]
rect
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.FillEllipse Overload List


Graphics.FillEllipse (Brush, Int32, Int32, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub FillEllipse( _
   ByVal brush As Brush, _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer _
)
[C#]
public void FillEllipse(
   Brush brush,
   int x,
   int y,
   int width,
   int height
);
[C++]
public: void FillEllipse(
   Brush* brush,
   int x,
   int y,
   int width,
   int height
);
[JScript]
public function FillEllipse(
   brush : Brush,
   x : int,
   y : int,
   width : int,
   height : int
);

Parameters

brush
[To be supplied.]
x
[To be supplied.]
y
[To be supplied.]
width
[To be supplied.]
height
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.FillEllipse Overload List


Graphics.FillPath

[To be supplied.]

[Visual Basic]
Public Sub FillPath( _
   ByVal brush As Brush, _
   ByVal path As GraphicsPath _
)
[C#]
public void FillPath(
   Brush brush,
   GraphicsPath path
);
[C++]
public: void FillPath(
   Brush* brush,
   GraphicsPath* path
);
[JScript]
public function FillPath(
   brush : Brush,
   path : GraphicsPath
);

Parameters

brush
[To be supplied.]
path
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.FillPie

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub FillPie(Brush, Single, Single, Single, Single, Single, Single)
[C#] public void FillPie(Brush, float, float, float, float, float, float);
[C++] public: void FillPie(Brush*, float, float, float, float, float, float);
[JScript] public function FillPie(Brush, float, float, float, float, float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub FillPie(Brush, Rectangle, Single, Single)
[C#] public void FillPie(Brush, Rectangle, float, float);
[C++] public: void FillPie(Brush*, Rectangle, float, float);
[JScript] public function FillPie(Brush, Rectangle, float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub FillPie(Brush, Integer, Integer, Integer, Integer, Integer, Integer)
[C#] public void FillPie(Brush, int, int, int, int, int, int);
[C++] public: void FillPie(Brush*, int, int, int, int, int, int);
[JScript] public function FillPie(Brush, int, int, int, int, int, int);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.FillPie (Brush, Single, Single, Single, Single, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub FillPie( _
   ByVal brush As Brush, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
[C#]
public void FillPie(
   Brush brush,
   float x,
   float y,
   float width,
   float height,
   float startAngle,
   float sweepAngle
);
[C++]
public: void FillPie(
   Brush* brush,
   float x,
   float y,
   float width,
   float height,
   float startAngle,
   float sweepAngle
);
[JScript]
public function FillPie(
   brush : Brush,
   x : float,
   y : float,
   width : float,
   height : float,
   startAngle : float,
   sweepAngle : float
);

Parameters

brush
[To be supplied.]
x
[To be supplied.]
y
[To be supplied.]
width
[To be supplied.]
height
[To be supplied.]
startAngle
[To be supplied.]
sweepAngle
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.FillPie Overload List


Graphics.FillPie (Brush, Rectangle, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub FillPie( _
   ByVal brush As Brush, _
   ByVal rect As Rectangle, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
[C#]
public void FillPie(
   Brush brush,
   Rectangle rect,
   float startAngle,
   float sweepAngle
);
[C++]
public: void FillPie(
   Brush* brush,
   Rectangle rect,
   float startAngle,
   float sweepAngle
);
[JScript]
public function FillPie(
   brush : Brush,
   rect : Rectangle,
   startAngle : float,
   sweepAngle : float
);

Parameters

brush
[To be supplied.]
rect
[To be supplied.]
startAngle
[To be supplied.]
sweepAngle
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.FillPie Overload List


Graphics.FillPie (Brush, Int32, Int32, Int32, Int32, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub FillPie( _
   ByVal brush As Brush, _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal startAngle As Integer, _
   ByVal sweepAngle As Integer _
)
[C#]
public void FillPie(
   Brush brush,
   int x,
   int y,
   int width,
   int height,
   int startAngle,
   int sweepAngle
);
[C++]
public: void FillPie(
   Brush* brush,
   int x,
   int y,
   int width,
   int height,
   int startAngle,
   int sweepAngle
);
[JScript]
public function FillPie(
   brush : Brush,
   x : int,
   y : int,
   width : int,
   height : int,
   startAngle : int,
   sweepAngle : int
);

Parameters

brush
[To be supplied.]
x
[To be supplied.]
y
[To be supplied.]
width
[To be supplied.]
height
[To be supplied.]
startAngle
[To be supplied.]
sweepAngle
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.FillPie Overload List


Graphics.FillPolygon

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub FillPolygon(Brush, Point())
[C#] public void FillPolygon(Brush, Point[]);
[C++] public: void FillPolygon(Brush*, Point[]);
[JScript] public function FillPolygon(Brush, Point[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub FillPolygon(Brush, Point(), FillMode)
[C#] public void FillPolygon(Brush, Point[], FillMode);
[C++] public: void FillPolygon(Brush*, Point[], FillMode);
[JScript] public function FillPolygon(Brush, Point[], FillMode);

[To be supplied.]

[Visual Basic] Overloads Public Sub FillPolygon(Brush, PointF(), FillMode)
[C#] public void FillPolygon(Brush, PointF[], FillMode);
[C++] public: void FillPolygon(Brush*, PointF[], FillMode);
[JScript] public function FillPolygon(Brush, PointF[], FillMode);

[To be supplied.]

[Visual Basic] Overloads Public Sub FillPolygon(Brush, PointF())
[C#] public void FillPolygon(Brush, PointF[]);
[C++] public: void FillPolygon(Brush*, PointF[]);
[JScript] public function FillPolygon(Brush, PointF[]);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.FillPolygon (Brush, Point[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub FillPolygon( _
   ByVal brush As Brush, _
   ByVal points() As Point _
)
[C#]
public void FillPolygon(
   Brush brush,
   Point[] points
);
[C++]
public: void FillPolygon(
   Brush* brush,
   Point* points[]
);
[JScript]
public function FillPolygon(
   brush : Brush,
   points : Point[]
);

Parameters

brush
[To be supplied.]
points
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.FillPolygon Overload List


Graphics.FillPolygon (Brush, Point[], FillMode)

[To be supplied.]

[Visual Basic]
Overloads Public Sub FillPolygon( _
   ByVal brush As Brush, _
   ByVal points() As Point, _
   ByVal fillMode As FillMode _
)
[C#]
public void FillPolygon(
   Brush brush,
   Point[] points,
   FillMode fillMode
);
[C++]
public: void FillPolygon(
   Brush* brush,
   Point* points[],
   FillMode fillMode
);
[JScript]
public function FillPolygon(
   brush : Brush,
   points : Point[],
   fillMode : FillMode
);

Parameters

brush
[To be supplied.]
points
[To be supplied.]
fillMode
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.FillPolygon Overload List


Graphics.FillPolygon (Brush, PointF[], FillMode)

[To be supplied.]

[Visual Basic]
Overloads Public Sub FillPolygon( _
   ByVal brush As Brush, _
   ByVal points() As PointF, _
   ByVal fillMode As FillMode _
)
[C#]
public void FillPolygon(
   Brush brush,
   PointF[] points,
   FillMode fillMode
);
[C++]
public: void FillPolygon(
   Brush* brush,
   PointF* points[],
   FillMode fillMode
);
[JScript]
public function FillPolygon(
   brush : Brush,
   points : PointF[],
   fillMode : FillMode
);

Parameters

brush
[To be supplied.]
points
[To be supplied.]
fillMode
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.FillPolygon Overload List


Graphics.FillPolygon (Brush, PointF[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub FillPolygon( _
   ByVal brush As Brush, _
   ByVal points() As PointF _
)
[C#]
public void FillPolygon(
   Brush brush,
   PointF[] points
);
[C++]
public: void FillPolygon(
   Brush* brush,
   PointF* points[]
);
[JScript]
public function FillPolygon(
   brush : Brush,
   points : PointF[]
);

Parameters

brush
[To be supplied.]
points
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.FillPolygon Overload List


Graphics.FillRectangle

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub FillRectangle(Brush, Single, Single, Single, Single)
[C#] public void FillRectangle(Brush, float, float, float, float);
[C++] public: void FillRectangle(Brush*, float, float, float, float);
[JScript] public function FillRectangle(Brush, float, float, float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub FillRectangle(Brush, Rectangle)
[C#] public void FillRectangle(Brush, Rectangle);
[C++] public: void FillRectangle(Brush*, Rectangle);
[JScript] public function FillRectangle(Brush, Rectangle);

[To be supplied.]

[Visual Basic] Overloads Public Sub FillRectangle(Brush, RectangleF)
[C#] public void FillRectangle(Brush, RectangleF);
[C++] public: void FillRectangle(Brush*, RectangleF);
[JScript] public function FillRectangle(Brush, RectangleF);

[To be supplied.]

[Visual Basic] Overloads Public Sub FillRectangle(Brush, Integer, Integer, Integer, Integer)
[C#] public void FillRectangle(Brush, int, int, int, int);
[C++] public: void FillRectangle(Brush*, int, int, int, int);
[JScript] public function FillRectangle(Brush, int, int, int, int);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.FillRectangle (Brush, Single, Single, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub FillRectangle( _
   ByVal brush As Brush, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
[C#]
public void FillRectangle(
   Brush brush,
   float x,
   float y,
   float width,
   float height
);
[C++]
public: void FillRectangle(
   Brush* brush,
   float x,
   float y,
   float width,
   float height
);
[JScript]
public function FillRectangle(
   brush : Brush,
   x : float,
   y : float,
   width : float,
   height : float
);

Parameters

brush
[To be supplied.]
x
[To be supplied.]
y
[To be supplied.]
width
[To be supplied.]
height
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.FillRectangle Overload List


Graphics.FillRectangle (Brush, Rectangle)

[To be supplied.]

[Visual Basic]
Overloads Public Sub FillRectangle( _
   ByVal brush As Brush, _
   ByVal rect As Rectangle _
)
[C#]
public void FillRectangle(
   Brush brush,
   Rectangle rect
);
[C++]
public: void FillRectangle(
   Brush* brush,
   Rectangle rect
);
[JScript]
public function FillRectangle(
   brush : Brush,
   rect : Rectangle
);

Parameters

brush
[To be supplied.]
rect
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.FillRectangle Overload List


Graphics.FillRectangle (Brush, RectangleF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub FillRectangle( _
   ByVal brush As Brush, _
   ByVal rect As RectangleF _
)
[C#]
public void FillRectangle(
   Brush brush,
   RectangleF rect
);
[C++]
public: void FillRectangle(
   Brush* brush,
   RectangleF rect
);
[JScript]
public function FillRectangle(
   brush : Brush,
   rect : RectangleF
);

Parameters

brush
[To be supplied.]
rect
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.FillRectangle Overload List


Graphics.FillRectangle (Brush, Int32, Int32, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub FillRectangle( _
   ByVal brush As Brush, _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer _
)
[C#]
public void FillRectangle(
   Brush brush,
   int x,
   int y,
   int width,
   int height
);
[C++]
public: void FillRectangle(
   Brush* brush,
   int x,
   int y,
   int width,
   int height
);
[JScript]
public function FillRectangle(
   brush : Brush,
   x : int,
   y : int,
   width : int,
   height : int
);

Parameters

brush
[To be supplied.]
x
[To be supplied.]
y
[To be supplied.]
width
[To be supplied.]
height
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.FillRectangle Overload List


Graphics.FillRectangles

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub FillRectangles(Brush, Rectangle())
[C#] public void FillRectangles(Brush, Rectangle[]);
[C++] public: void FillRectangles(Brush*, Rectangle[]);
[JScript] public function FillRectangles(Brush, Rectangle[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub FillRectangles(Brush, RectangleF())
[C#] public void FillRectangles(Brush, RectangleF[]);
[C++] public: void FillRectangles(Brush*, RectangleF[]);
[JScript] public function FillRectangles(Brush, RectangleF[]);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.FillRectangles (Brush, Rectangle[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub FillRectangles( _
   ByVal brush As Brush, _
   ByVal rects() As Rectangle _
)
[C#]
public void FillRectangles(
   Brush brush,
   Rectangle[] rects
);
[C++]
public: void FillRectangles(
   Brush* brush,
   Rectangle* rects[]
);
[JScript]
public function FillRectangles(
   brush : Brush,
   rects : Rectangle[]
);

Parameters

brush
[To be supplied.]
rects
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.FillRectangles Overload List


Graphics.FillRectangles (Brush, RectangleF[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub FillRectangles( _
   ByVal brush As Brush, _
   ByVal rects() As RectangleF _
)
[C#]
public void FillRectangles(
   Brush brush,
   RectangleF[] rects
);
[C++]
public: void FillRectangles(
   Brush* brush,
   RectangleF* rects[]
);
[JScript]
public function FillRectangles(
   brush : Brush,
   rects : RectangleF[]
);

Parameters

brush
[To be supplied.]
rects
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.FillRectangles Overload List


Graphics.FillRegion

[To be supplied.]

[Visual Basic]
Public Sub FillRegion( _
   ByVal brush As Brush, _
   ByVal region As Region _
)
[C#]
public void FillRegion(
   Brush brush,
   Region region
);
[C++]
public: void FillRegion(
   Brush* brush,
   Region* region
);
[JScript]
public function FillRegion(
   brush : Brush,
   region : Region
);

Parameters

brush
[To be supplied.]
region
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.Finalize

Deletes this Graphics, and frees the memory allocated for it.

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.Flush

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub Flush(FlushIntention)
[C#] public void Flush(FlushIntention);
[C++] public: void Flush(FlushIntention);
[JScript] public function Flush(FlushIntention);

[To be supplied.]

[Visual Basic] Overloads Public Sub Flush()
[C#] public void Flush();
[C++] public: void Flush();
[JScript] public function Flush();

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.Flush (FlushIntention)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Flush( _
   ByVal intention As FlushIntention _
)
[C#]
public void Flush(
   FlushIntention intention
);
[C++]
public: void Flush(
   FlushIntention intention
);
[JScript]
public function Flush(
   intention : FlushIntention
);

Parameters

intention
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.Flush Overload List


Graphics.Flush ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub Flush()
[C#]
public void Flush();
[C++]
public: void Flush();
[JScript]
public function Flush();

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.Flush Overload List


Graphics.FromHDC

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Shared Function FromHDC(Integer) As Graphics
[C#] public static Graphics FromHDC(int);
[C++] public: static Graphics* FromHDC(int);
[JScript] public static function FromHDC(int) : Graphics;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function FromHDC(Integer, Integer) As Graphics
[C#] public static Graphics FromHDC(int, int);
[C++] public: static Graphics* FromHDC(int, int);
[JScript] public static function FromHDC(int, int) : Graphics;

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.FromHDC (Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function FromHDC( _
   ByVal hdc As Integer _
) As Graphics
[C#]
public static Graphics FromHDC(
   int hdc
);
[C++]
public: static Graphics* FromHDC(
   int hdc
);
[JScript]
public static function FromHDC(
   hdc : int
) : Graphics;

Parameters

hdc
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.FromHDC Overload List


Graphics.FromHDC (Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function FromHDC( _
   ByVal hdc As Integer, _
   ByVal hdevice As Integer _
) As Graphics
[C#]
public static Graphics FromHDC(
   int hdc,
   int hdevice
);
[C++]
public: static Graphics* FromHDC(
   int hdc,
   int hdevice
);
[JScript]
public static function FromHDC(
   hdc : int,
   hdevice : int
) : Graphics;

Parameters

hdc
[To be supplied.]
hdevice
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.FromHDC Overload List


Graphics.FromHWND

[To be supplied.]

[Visual Basic]
Public Shared Function FromHWND( _
   ByVal hwnd As Integer _
) As Graphics
[C#]
public static Graphics FromHWND(
   int hwnd
);
[C++]
public: static Graphics* FromHWND(
   int hwnd
);
[JScript]
public static function FromHWND(
   hwnd : int
) : Graphics;

Parameters

hwnd
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.FromImage

[To be supplied.]

[Visual Basic]
Public Shared Function FromImage( _
   ByVal image As Image _
) As Graphics
[C#]
public static Graphics FromImage(
   Image image
);
[C++]
public: static Graphics* FromImage(
   Image* image
);
[JScript]
public static function FromImage(
   image : Image
) : Graphics;

Parameters

image
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.GetHalftonePalette

[To be supplied.]

[Visual Basic]
Public Shared Function GetHalftonePalette() As Integer
[C#]
public static int GetHalftonePalette();
[C++]
public: static int GetHalftonePalette();
[JScript]
public static function GetHalftonePalette() : int;

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.GetHDC

[To be supplied.]

[Visual Basic]
Public Function GetHDC() As Integer
[C#]
public int GetHDC();
[C++]
public: int GetHDC();
[JScript]
public function GetHDC() : int;

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.GetNearestColor

[To be supplied.]

[Visual Basic]
Public Function GetNearestColor( _
   ByVal color As Color _
) As Color
[C#]
public Color GetNearestColor(
   Color color
);
[C++]
public: Color GetNearestColor(
   Color color
);
[JScript]
public function GetNearestColor(
   color : Color
) : Color;

Parameters

color
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.IntersectClip

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub IntersectClip(Rectangle)
[C#] public void IntersectClip(Rectangle);
[C++] public: void IntersectClip(Rectangle);
[JScript] public function IntersectClip(Rectangle);

[To be supplied.]

[Visual Basic] Overloads Public Sub IntersectClip(Region)
[C#] public void IntersectClip(Region);
[C++] public: void IntersectClip(Region*);
[JScript] public function IntersectClip(Region);

[To be supplied.]

[Visual Basic] Overloads Public Sub IntersectClip(RectangleF)
[C#] public void IntersectClip(RectangleF);
[C++] public: void IntersectClip(RectangleF);
[JScript] public function IntersectClip(RectangleF);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.IntersectClip (Rectangle)

[To be supplied.]

[Visual Basic]
Overloads Public Sub IntersectClip( _
   ByVal rect As Rectangle _
)
[C#]
public void IntersectClip(
   Rectangle rect
);
[C++]
public: void IntersectClip(
   Rectangle rect
);
[JScript]
public function IntersectClip(
   rect : Rectangle
);

Parameters

rect
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.IntersectClip Overload List


Graphics.IntersectClip (Region)

[To be supplied.]

[Visual Basic]
Overloads Public Sub IntersectClip( _
   ByVal region As Region _
)
[C#]
public void IntersectClip(
   Region region
);
[C++]
public: void IntersectClip(
   Region* region
);
[JScript]
public function IntersectClip(
   region : Region
);

Parameters

region
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.IntersectClip Overload List


Graphics.IntersectClip (RectangleF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub IntersectClip( _
   ByVal rect As RectangleF _
)
[C#]
public void IntersectClip(
   RectangleF rect
);
[C++]
public: void IntersectClip(
   RectangleF rect
);
[JScript]
public function IntersectClip(
   rect : RectangleF
);

Parameters

rect
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.IntersectClip Overload List


Graphics.IsVisible

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(Rectangle) As Boolean
[C#] public bool IsVisible(Rectangle);
[C++] public: bool IsVisible(Rectangle);
[JScript] public function IsVisible(Rectangle) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(Integer, Integer, Integer, Integer) As Boolean
[C#] public bool IsVisible(int, int, int, int);
[C++] public: bool IsVisible(int, int, int, int);
[JScript] public function IsVisible(int, int, int, int) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(RectangleF) As Boolean
[C#] public bool IsVisible(RectangleF);
[C++] public: bool IsVisible(RectangleF);
[JScript] public function IsVisible(RectangleF) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(Single, Single, Single, Single) As Boolean
[C#] public bool IsVisible(float, float, float, float);
[C++] public: bool IsVisible(float, float, float, float);
[JScript] public function IsVisible(float, float, float, float) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(Point) As Boolean
[C#] public bool IsVisible(Point);
[C++] public: bool IsVisible(Point);
[JScript] public function IsVisible(Point) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(Integer, Integer) As Boolean
[C#] public bool IsVisible(int, int);
[C++] public: bool IsVisible(int, int);
[JScript] public function IsVisible(int, int) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(PointF) As Boolean
[C#] public bool IsVisible(PointF);
[C++] public: bool IsVisible(PointF);
[JScript] public function IsVisible(PointF) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(Single, Single) As Boolean
[C#] public bool IsVisible(float, float);
[C++] public: bool IsVisible(float, float);
[JScript] public function IsVisible(float, float) : Boolean;

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.IsVisible (Rectangle)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal rect As Rectangle _
) As Boolean
[C#]
public bool IsVisible(
   Rectangle rect
);
[C++]
public: bool IsVisible(
   Rectangle rect
);
[JScript]
public function IsVisible(
   rect : Rectangle
) : Boolean;

Parameters

rect
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.IsVisible Overload List


Graphics.IsVisible (Int32, Int32, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer _
) As Boolean
[C#]
public bool IsVisible(
   int x,
   int y,
   int width,
   int height
);
[C++]
public: bool IsVisible(
   int x,
   int y,
   int width,
   int height
);
[JScript]
public function IsVisible(
   x : int,
   y : int,
   width : int,
   height : int
) : Boolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]
width
[To be supplied.]
height
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.IsVisible Overload List


Graphics.IsVisible (RectangleF)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal rect As RectangleF _
) As Boolean
[C#]
public bool IsVisible(
   RectangleF rect
);
[C++]
public: bool IsVisible(
   RectangleF rect
);
[JScript]
public function IsVisible(
   rect : RectangleF
) : Boolean;

Parameters

rect
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.IsVisible Overload List


Graphics.IsVisible (Single, Single, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal width As Single, _
   ByVal height As Single _
) As Boolean
[C#]
public bool IsVisible(
   float x,
   float y,
   float width,
   float height
);
[C++]
public: bool IsVisible(
   float x,
   float y,
   float width,
   float height
);
[JScript]
public function IsVisible(
   x : float,
   y : float,
   width : float,
   height : float
) : Boolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]
width
[To be supplied.]
height
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.IsVisible Overload List


Graphics.IsVisible (Point)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal point As Point _
) As Boolean
[C#]
public bool IsVisible(
   Point point
);
[C++]
public: bool IsVisible(
   Point point
);
[JScript]
public function IsVisible(
   point : Point
) : Boolean;

Parameters

point
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.IsVisible Overload List


Graphics.IsVisible (Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal x As Integer, _
   ByVal y As Integer _
) As Boolean
[C#]
public bool IsVisible(
   int x,
   int y
);
[C++]
public: bool IsVisible(
   int x,
   int y
);
[JScript]
public function IsVisible(
   x : int,
   y : int
) : Boolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.IsVisible Overload List


Graphics.IsVisible (PointF)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal point As PointF _
) As Boolean
[C#]
public bool IsVisible(
   PointF point
);
[C++]
public: bool IsVisible(
   PointF point
);
[JScript]
public function IsVisible(
   point : PointF
) : Boolean;

Parameters

point
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.IsVisible Overload List


Graphics.IsVisible (Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal x As Single, _
   ByVal y As Single _
) As Boolean
[C#]
public bool IsVisible(
   float x,
   float y
);
[C++]
public: bool IsVisible(
   float x,
   float y
);
[JScript]
public function IsVisible(
   x : float,
   y : float
) : Boolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.IsVisible Overload List


Graphics.MeasureString

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function MeasureString(String, Font, SizeF, StringFormat, Integer, Integer) As SizeF
[C#] public SizeF MeasureString(String, Font, SizeF, StringFormat, int, int);
[C++] public: SizeF MeasureString(String*, Font, SizeF, StringFormat, int, int);
[JScript] public function MeasureString(String, Font, SizeF, StringFormat, int, int) : SizeF;

[To be supplied.]

[Visual Basic] Overloads Public Function MeasureString(String, Font, PointF, StringFormat) As SizeF
[C#] public SizeF MeasureString(String, Font, PointF, StringFormat);
[C++] public: SizeF MeasureString(String*, Font, PointF, StringFormat);
[JScript] public function MeasureString(String, Font, PointF, StringFormat) : SizeF;

[To be supplied.]

[Visual Basic] Overloads Public Function MeasureString(String, Font, Integer) As SizeF
[C#] public SizeF MeasureString(String, Font, int);
[C++] public: SizeF MeasureString(String*, Font, int);
[JScript] public function MeasureString(String, Font, int) : SizeF;

[To be supplied.]

[Visual Basic] Overloads Public Function MeasureString(String, Font, Integer, StringFormat) As SizeF
[C#] public SizeF MeasureString(String, Font, int, StringFormat);
[C++] public: SizeF MeasureString(String*, Font, int, StringFormat);
[JScript] public function MeasureString(String, Font, int, StringFormat) : SizeF;

[To be supplied.]

[Visual Basic] Overloads Public Function MeasureString(String, Font, SizeF, StringFormat) As SizeF
[C#] public SizeF MeasureString(String, Font, SizeF, StringFormat);
[C++] public: SizeF MeasureString(String*, Font, SizeF, StringFormat);
[JScript] public function MeasureString(String, Font, SizeF, StringFormat) : SizeF;

[To be supplied.]

[Visual Basic] Overloads Public Function MeasureString(String, Font, SizeF) As SizeF
[C#] public SizeF MeasureString(String, Font, SizeF);
[C++] public: SizeF MeasureString(String*, Font, SizeF);
[JScript] public function MeasureString(String, Font, SizeF) : SizeF;

[To be supplied.]

[Visual Basic] Overloads Public Function MeasureString(String, Font) As SizeF
[C#] public SizeF MeasureString(String, Font);
[C++] public: SizeF MeasureString(String*, Font);
[JScript] public function MeasureString(String, Font) : SizeF;

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.MeasureString (String, Font, SizeF, StringFormat, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Function MeasureString( _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal layoutArea As SizeF, _
   ByVal stringFormat As StringFormat, _
   ByRef charactersFitted As Integer, _
   ByRef linesFilled As Integer _
) As SizeF
[C#]
public SizeF MeasureString(
   string text,
   Font font,
   SizeF layoutArea,
   StringFormat stringFormat,
   ref int charactersFitted,
   ref int linesFilled
);
[C++]
public: SizeF MeasureString(
   String* text,
   Font* font,
   SizeF layoutArea,
   StringFormat* stringFormat,
   int** charactersFitted,
   int** linesFilled
);
[JScript]
public function MeasureString(
   text : String,
   font : Font,
   layoutArea : SizeF,
   stringFormat : StringFormat,
   charactersFitted : int,
   linesFilled : int
) : SizeF;

Parameters

text
[To be supplied.]
font
[To be supplied.]
layoutArea
[To be supplied.]
stringFormat
[To be supplied.]
charactersFitted
[To be supplied.]
linesFilled
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.MeasureString Overload List


Graphics.MeasureString (String, Font, PointF, StringFormat)

[To be supplied.]

[Visual Basic]
Overloads Public Function MeasureString( _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal origin As PointF, _
   ByVal stringFormat As StringFormat _
) As SizeF
[C#]
public SizeF MeasureString(
   string text,
   Font font,
   PointF origin,
   StringFormat stringFormat
);
[C++]
public: SizeF MeasureString(
   String* text,
   Font* font,
   PointF origin,
   StringFormat* stringFormat
);
[JScript]
public function MeasureString(
   text : String,
   font : Font,
   origin : PointF,
   stringFormat : StringFormat
) : SizeF;

Parameters

text
[To be supplied.]
font
[To be supplied.]
origin
[To be supplied.]
stringFormat
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.MeasureString Overload List


Graphics.MeasureString (String, Font, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Function MeasureString( _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal width As Integer _
) As SizeF
[C#]
public SizeF MeasureString(
   string text,
   Font font,
   int width
);
[C++]
public: SizeF MeasureString(
   String* text,
   Font* font,
   int width
);
[JScript]
public function MeasureString(
   text : String,
   font : Font,
   width : int
) : SizeF;

Parameters

text
[To be supplied.]
font
[To be supplied.]
width
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.MeasureString Overload List


Graphics.MeasureString (String, Font, Int32, StringFormat)

[To be supplied.]

[Visual Basic]
Overloads Public Function MeasureString( _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal width As Integer, _
   ByVal format As StringFormat _
) As SizeF
[C#]
public SizeF MeasureString(
   string text,
   Font font,
   int width,
   StringFormat format
);
[C++]
public: SizeF MeasureString(
   String* text,
   Font* font,
   int width,
   StringFormat* format
);
[JScript]
public function MeasureString(
   text : String,
   font : Font,
   width : int,
   format : StringFormat
) : SizeF;

Parameters

text
[To be supplied.]
font
[To be supplied.]
width
[To be supplied.]
format
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.MeasureString Overload List


Graphics.MeasureString (String, Font, SizeF, StringFormat)

[To be supplied.]

[Visual Basic]
Overloads Public Function MeasureString( _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal layoutArea As SizeF, _
   ByVal stringFormat As StringFormat _
) As SizeF
[C#]
public SizeF MeasureString(
   string text,
   Font font,
   SizeF layoutArea,
   StringFormat stringFormat
);
[C++]
public: SizeF MeasureString(
   String* text,
   Font* font,
   SizeF layoutArea,
   StringFormat* stringFormat
);
[JScript]
public function MeasureString(
   text : String,
   font : Font,
   layoutArea : SizeF,
   stringFormat : StringFormat
) : SizeF;

Parameters

text
[To be supplied.]
font
[To be supplied.]
layoutArea
[To be supplied.]
stringFormat
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.MeasureString Overload List


Graphics.MeasureString (String, Font, SizeF)

[To be supplied.]

[Visual Basic]
Overloads Public Function MeasureString( _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal layoutArea As SizeF _
) As SizeF
[C#]
public SizeF MeasureString(
   string text,
   Font font,
   SizeF layoutArea
);
[C++]
public: SizeF MeasureString(
   String* text,
   Font* font,
   SizeF layoutArea
);
[JScript]
public function MeasureString(
   text : String,
   font : Font,
   layoutArea : SizeF
) : SizeF;

Parameters

text
[To be supplied.]
font
[To be supplied.]
layoutArea
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.MeasureString Overload List


Graphics.MeasureString (String, Font)

[To be supplied.]

[Visual Basic]
Overloads Public Function MeasureString( _
   ByVal text As String, _
   ByVal font As Font _
) As SizeF
[C#]
public SizeF MeasureString(
   string text,
   Font font
);
[C++]
public: SizeF MeasureString(
   String* text,
   Font* font
);
[JScript]
public function MeasureString(
   text : String,
   font : Font
) : SizeF;

Parameters

text
[To be supplied.]
font
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.MeasureString Overload List


Graphics.MeasureStringRegion

[To be supplied.]

[Visual Basic]
Public Function MeasureStringRegion( _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal layoutRect As RectangleF, _
   ByVal stringFormat As StringFormat, _
   ByVal firstCharacterIndex As Integer, _
   ByVal characterCount As Integer _
) As Region
[C#]
public Region MeasureStringRegion(
   string text,
   Font font,
   RectangleF layoutRect,
   StringFormat stringFormat,
   int firstCharacterIndex,
   int characterCount
);
[C++]
public: Region* MeasureStringRegion(
   String* text,
   Font* font,
   RectangleF layoutRect,
   StringFormat* stringFormat,
   int firstCharacterIndex,
   int characterCount
);
[JScript]
public function MeasureStringRegion(
   text : String,
   font : Font,
   layoutRect : RectangleF,
   stringFormat : StringFormat,
   firstCharacterIndex : int,
   characterCount : int
) : Region;

Parameters

text
[To be supplied.]
font
[To be supplied.]
layoutRect
[To be supplied.]
stringFormat
[To be supplied.]
firstCharacterIndex
[To be supplied.]
characterCount
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.MultiplyTransform

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub MultiplyTransform(Matrix)
[C#] public void MultiplyTransform(Matrix);
[C++] public: void MultiplyTransform(Matrix*);
[JScript] public function MultiplyTransform(Matrix);

[To be supplied.]

[Visual Basic] Overloads Public Sub MultiplyTransform(Matrix, MatrixOrder)
[C#] public void MultiplyTransform(Matrix, MatrixOrder);
[C++] public: void MultiplyTransform(Matrix*, MatrixOrder);
[JScript] public function MultiplyTransform(Matrix, MatrixOrder);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.MultiplyTransform (Matrix)

[To be supplied.]

[Visual Basic]
Overloads Public Sub MultiplyTransform( _
   ByVal matrix As Matrix _
)
[C#]
public void MultiplyTransform(
   Matrix matrix
);
[C++]
public: void MultiplyTransform(
   Matrix* matrix
);
[JScript]
public function MultiplyTransform(
   matrix : Matrix
);

Parameters

matrix
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.MultiplyTransform Overload List


Graphics.MultiplyTransform (Matrix, MatrixOrder)

[To be supplied.]

[Visual Basic]
Overloads Public Sub MultiplyTransform( _
   ByVal matrix As Matrix, _
   ByVal order As MatrixOrder _
)
[C#]
public void MultiplyTransform(
   Matrix matrix,
   MatrixOrder order
);
[C++]
public: void MultiplyTransform(
   Matrix* matrix,
   MatrixOrder order
);
[JScript]
public function MultiplyTransform(
   matrix : Matrix,
   order : MatrixOrder
);

Parameters

matrix
[To be supplied.]
order
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.MultiplyTransform Overload List


Graphics.ReleaseHDC

[To be supplied.]

[Visual Basic]
Public Sub ReleaseHDC( _
   ByVal hdc As Integer _
)
[C#]
public void ReleaseHDC(
   int hdc
);
[C++]
public: void ReleaseHDC(
   int hdc
);
[JScript]
public function ReleaseHDC(
   hdc : int
);

Parameters

hdc
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.ResetClip

[To be supplied.]

[Visual Basic]
Public Sub ResetClip()
[C#]
public void ResetClip();
[C++]
public: void ResetClip();
[JScript]
public function ResetClip();

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.ResetTransform

[To be supplied.]

[Visual Basic]
Public Sub ResetTransform()
[C#]
public void ResetTransform();
[C++]
public: void ResetTransform();
[JScript]
public function ResetTransform();

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.Restore

[To be supplied.]

[Visual Basic]
Public Sub Restore( _
   ByVal gstate As GraphicsState _
)
[C#]
public void Restore(
   GraphicsState gstate
);
[C++]
public: void Restore(
   GraphicsState* gstate
);
[JScript]
public function Restore(
   gstate : GraphicsState
);

Parameters

gstate
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.RotateTransform

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub RotateTransform(Single, MatrixOrder)
[C#] public void RotateTransform(float, MatrixOrder);
[C++] public: void RotateTransform(float, MatrixOrder);
[JScript] public function RotateTransform(float, MatrixOrder);

[To be supplied.]

[Visual Basic] Overloads Public Sub RotateTransform(Single)
[C#] public void RotateTransform(float);
[C++] public: void RotateTransform(float);
[JScript] public function RotateTransform(float);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.RotateTransform (Single, MatrixOrder)

[To be supplied.]

[Visual Basic]
Overloads Public Sub RotateTransform( _
   ByVal angle As Single, _
   ByVal order As MatrixOrder _
)
[C#]
public void RotateTransform(
   float angle,
   MatrixOrder order
);
[C++]
public: void RotateTransform(
   float angle,
   MatrixOrder order
);
[JScript]
public function RotateTransform(
   angle : float,
   order : MatrixOrder
);

Parameters

angle
[To be supplied.]
order
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.RotateTransform Overload List


Graphics.RotateTransform (Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub RotateTransform( _
   ByVal angle As Single _
)
[C#]
public void RotateTransform(
   float angle
);
[C++]
public: void RotateTransform(
   float angle
);
[JScript]
public function RotateTransform(
   angle : float
);

Parameters

angle
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.RotateTransform Overload List


Graphics.Save

[To be supplied.]

[Visual Basic]
Public Function Save() As GraphicsState
[C#]
public GraphicsState Save();
[C++]
public: GraphicsState* Save();
[JScript]
public function Save() : GraphicsState;

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.ScaleTransform

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub ScaleTransform(Single, Single, MatrixOrder)
[C#] public void ScaleTransform(float, float, MatrixOrder);
[C++] public: void ScaleTransform(float, float, MatrixOrder);
[JScript] public function ScaleTransform(float, float, MatrixOrder);

[To be supplied.]

[Visual Basic] Overloads Public Sub ScaleTransform(Single, Single)
[C#] public void ScaleTransform(float, float);
[C++] public: void ScaleTransform(float, float);
[JScript] public function ScaleTransform(float, float);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.ScaleTransform (Single, Single, MatrixOrder)

[To be supplied.]

[Visual Basic]
Overloads Public Sub ScaleTransform( _
   ByVal sx As Single, _
   ByVal sy As Single, _
   ByVal order As MatrixOrder _
)
[C#]
public void ScaleTransform(
   float sx,
   float sy,
   MatrixOrder order
);
[C++]
public: void ScaleTransform(
   float sx,
   float sy,
   MatrixOrder order
);
[JScript]
public function ScaleTransform(
   sx : float,
   sy : float,
   order : MatrixOrder
);

Parameters

sx
[To be supplied.]
sy
[To be supplied.]
order
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.ScaleTransform Overload List


Graphics.ScaleTransform (Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub ScaleTransform( _
   ByVal sx As Single, _
   ByVal sy As Single _
)
[C#]
public void ScaleTransform(
   float sx,
   float sy
);
[C++]
public: void ScaleTransform(
   float sx,
   float sy
);
[JScript]
public function ScaleTransform(
   sx : float,
   sy : float
);

Parameters

sx
[To be supplied.]
sy
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.ScaleTransform Overload List


Graphics.SetClip

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub SetClip(GraphicsPath)
[C#] public void SetClip(GraphicsPath);
[C++] public: void SetClip(GraphicsPath*);
[JScript] public function SetClip(GraphicsPath);

[To be supplied.]

[Visual Basic] Overloads Public Sub SetClip(RectangleF, CombineMode)
[C#] public void SetClip(RectangleF, CombineMode);
[C++] public: void SetClip(RectangleF, CombineMode);
[JScript] public function SetClip(RectangleF, CombineMode);

[To be supplied.]

[Visual Basic] Overloads Public Sub SetClip(Region, CombineMode)
[C#] public void SetClip(Region, CombineMode);
[C++] public: void SetClip(Region*, CombineMode);
[JScript] public function SetClip(Region, CombineMode);

[To be supplied.]

[Visual Basic] Overloads Public Sub SetClip(GraphicsPath, CombineMode)
[C#] public void SetClip(GraphicsPath, CombineMode);
[C++] public: void SetClip(GraphicsPath*, CombineMode);
[JScript] public function SetClip(GraphicsPath, CombineMode);

[To be supplied.]

[Visual Basic] Overloads Public Sub SetClip(Region)
[C#] public void SetClip(Region);
[C++] public: void SetClip(Region*);
[JScript] public function SetClip(Region);

[To be supplied.]

[Visual Basic] Overloads Public Sub SetClip(Graphics, CombineMode)
[C#] public void SetClip(Graphics, CombineMode);
[C++] public: void SetClip(Graphics*, CombineMode);
[JScript] public function SetClip(Graphics, CombineMode);

[To be supplied.]

[Visual Basic] Overloads Public Sub SetClip(Graphics)
[C#] public void SetClip(Graphics);
[C++] public: void SetClip(Graphics*);
[JScript] public function SetClip(Graphics);

[To be supplied.]

[Visual Basic] Overloads Public Sub SetClip(Rectangle)
[C#] public void SetClip(Rectangle);
[C++] public: void SetClip(Rectangle);
[JScript] public function SetClip(Rectangle);

[To be supplied.]

[Visual Basic] Overloads Public Sub SetClip(RectangleF)
[C#] public void SetClip(RectangleF);
[C++] public: void SetClip(RectangleF);
[JScript] public function SetClip(RectangleF);

[To be supplied.]

[Visual Basic] Overloads Public Sub SetClip(Rectangle, CombineMode)
[C#] public void SetClip(Rectangle, CombineMode);
[C++] public: void SetClip(Rectangle, CombineMode);
[JScript] public function SetClip(Rectangle, CombineMode);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.SetClip (GraphicsPath)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetClip( _
   ByVal path As GraphicsPath _
)
[C#]
public void SetClip(
   GraphicsPath path
);
[C++]
public: void SetClip(
   GraphicsPath* path
);
[JScript]
public function SetClip(
   path : GraphicsPath
);

Parameters

path
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.SetClip Overload List


Graphics.SetClip (RectangleF, CombineMode)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetClip( _
   ByVal rect As RectangleF, _
   ByVal combineMode As CombineMode _
)
[C#]
public void SetClip(
   RectangleF rect,
   CombineMode combineMode
);
[C++]
public: void SetClip(
   RectangleF rect,
   CombineMode combineMode
);
[JScript]
public function SetClip(
   rect : RectangleF,
   combineMode : CombineMode
);

Parameters

rect
[To be supplied.]
combineMode
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.SetClip Overload List


Graphics.SetClip (Region, CombineMode)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetClip( _
   ByVal region As Region, _
   ByVal combineMode As CombineMode _
)
[C#]
public void SetClip(
   Region region,
   CombineMode combineMode
);
[C++]
public: void SetClip(
   Region* region,
   CombineMode combineMode
);
[JScript]
public function SetClip(
   region : Region,
   combineMode : CombineMode
);

Parameters

region
[To be supplied.]
combineMode
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.SetClip Overload List


Graphics.SetClip (GraphicsPath, CombineMode)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetClip( _
   ByVal path As GraphicsPath, _
   ByVal combineMode As CombineMode _
)
[C#]
public void SetClip(
   GraphicsPath path,
   CombineMode combineMode
);
[C++]
public: void SetClip(
   GraphicsPath* path,
   CombineMode combineMode
);
[JScript]
public function SetClip(
   path : GraphicsPath,
   combineMode : CombineMode
);

Parameters

path
[To be supplied.]
combineMode
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.SetClip Overload List


Graphics.SetClip (Region)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetClip( _
   ByVal region As Region _
)
[C#]
public void SetClip(
   Region region
);
[C++]
public: void SetClip(
   Region* region
);
[JScript]
public function SetClip(
   region : Region
);

Parameters

region
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.SetClip Overload List


Graphics.SetClip (Graphics, CombineMode)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetClip( _
   ByVal g As Graphics, _
   ByVal combineMode As CombineMode _
)
[C#]
public void SetClip(
   Graphics g,
   CombineMode combineMode
);
[C++]
public: void SetClip(
   Graphics* g,
   CombineMode combineMode
);
[JScript]
public function SetClip(
   g : Graphics,
   combineMode : CombineMode
);

Parameters

g
[To be supplied.]
combineMode
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.SetClip Overload List


Graphics.SetClip (Graphics)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetClip( _
   ByVal g As Graphics _
)
[C#]
public void SetClip(
   Graphics g
);
[C++]
public: void SetClip(
   Graphics* g
);
[JScript]
public function SetClip(
   g : Graphics
);

Parameters

g
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.SetClip Overload List


Graphics.SetClip (Rectangle)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetClip( _
   ByVal rect As Rectangle _
)
[C#]
public void SetClip(
   Rectangle rect
);
[C++]
public: void SetClip(
   Rectangle rect
);
[JScript]
public function SetClip(
   rect : Rectangle
);

Parameters

rect
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.SetClip Overload List


Graphics.SetClip (RectangleF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetClip( _
   ByVal rect As RectangleF _
)
[C#]
public void SetClip(
   RectangleF rect
);
[C++]
public: void SetClip(
   RectangleF rect
);
[JScript]
public function SetClip(
   rect : RectangleF
);

Parameters

rect
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.SetClip Overload List


Graphics.SetClip (Rectangle, CombineMode)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetClip( _
   ByVal rect As Rectangle, _
   ByVal combineMode As CombineMode _
)
[C#]
public void SetClip(
   Rectangle rect,
   CombineMode combineMode
);
[C++]
public: void SetClip(
   Rectangle rect,
   CombineMode combineMode
);
[JScript]
public function SetClip(
   rect : Rectangle,
   combineMode : CombineMode
);

Parameters

rect
[To be supplied.]
combineMode
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.SetClip Overload List


Graphics.TransformPoints

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub TransformPoints(CoordinateSpace, CoordinateSpace, Point())
[C#] public void TransformPoints(CoordinateSpace, CoordinateSpace, Point[]);
[C++] public: void TransformPoints(CoordinateSpace, CoordinateSpace, Point[]);
[JScript] public function TransformPoints(CoordinateSpace, CoordinateSpace, Point[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub TransformPoints(CoordinateSpace, CoordinateSpace, PointF())
[C#] public void TransformPoints(CoordinateSpace, CoordinateSpace, PointF[]);
[C++] public: void TransformPoints(CoordinateSpace, CoordinateSpace, PointF[]);
[JScript] public function TransformPoints(CoordinateSpace, CoordinateSpace, PointF[]);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.TransformPoints (CoordinateSpace, CoordinateSpace, Point[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub TransformPoints( _
   ByVal destSpace As CoordinateSpace, _
   ByVal srcSpace As CoordinateSpace, _
   ByVal pts() As Point _
)
[C#]
public void TransformPoints(
   CoordinateSpace destSpace,
   CoordinateSpace srcSpace,
   Point[] pts
);
[C++]
public: void TransformPoints(
   CoordinateSpace destSpace,
   CoordinateSpace srcSpace,
   Point* pts[]
);
[JScript]
public function TransformPoints(
   destSpace : CoordinateSpace,
   srcSpace : CoordinateSpace,
   pts : Point[]
);

Parameters

destSpace
[To be supplied.]
srcSpace
[To be supplied.]
pts
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.TransformPoints Overload List


Graphics.TransformPoints (CoordinateSpace, CoordinateSpace, PointF[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub TransformPoints( _
   ByVal destSpace As CoordinateSpace, _
   ByVal srcSpace As CoordinateSpace, _
   ByVal pts() As PointF _
)
[C#]
public void TransformPoints(
   CoordinateSpace destSpace,
   CoordinateSpace srcSpace,
   PointF[] pts
);
[C++]
public: void TransformPoints(
   CoordinateSpace destSpace,
   CoordinateSpace srcSpace,
   PointF* pts[]
);
[JScript]
public function TransformPoints(
   destSpace : CoordinateSpace,
   srcSpace : CoordinateSpace,
   pts : PointF[]
);

Parameters

destSpace
[To be supplied.]
srcSpace
[To be supplied.]
pts
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.TransformPoints Overload List


Graphics.TranslateClip

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub TranslateClip(Single, Single)
[C#] public void TranslateClip(float, float);
[C++] public: void TranslateClip(float, float);
[JScript] public function TranslateClip(float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub TranslateClip(Integer, Integer)
[C#] public void TranslateClip(int, int);
[C++] public: void TranslateClip(int, int);
[JScript] public function TranslateClip(int, int);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.TranslateClip (Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub TranslateClip( _
   ByVal dx As Single, _
   ByVal dy As Single _
)
[C#]
public void TranslateClip(
   float dx,
   float dy
);
[C++]
public: void TranslateClip(
   float dx,
   float dy
);
[JScript]
public function TranslateClip(
   dx : float,
   dy : float
);

Parameters

dx
[To be supplied.]
dy
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.TranslateClip Overload List


Graphics.TranslateClip (Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub TranslateClip( _
   ByVal dx As Integer, _
   ByVal dy As Integer _
)
[C#]
public void TranslateClip(
   int dx,
   int dy
);
[C++]
public: void TranslateClip(
   int dx,
   int dy
);
[JScript]
public function TranslateClip(
   dx : int,
   dy : int
);

Parameters

dx
[To be supplied.]
dy
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.TranslateClip Overload List


Graphics.TranslateTransform

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub TranslateTransform(Single, Single)
[C#] public void TranslateTransform(float, float);
[C++] public: void TranslateTransform(float, float);
[JScript] public function TranslateTransform(float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub TranslateTransform(Single, Single, MatrixOrder)
[C#] public void TranslateTransform(float, float, MatrixOrder);
[C++] public: void TranslateTransform(float, float, MatrixOrder);
[JScript] public function TranslateTransform(float, float, MatrixOrder);

See Also

Graphics Class | Graphics Members | System.Drawing Namespace


Graphics.TranslateTransform (Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub TranslateTransform( _
   ByVal dx As Single, _
   ByVal dy As Single _
)
[C#]
public void TranslateTransform(
   float dx,
   float dy
);
[C++]
public: void TranslateTransform(
   float dx,
   float dy
);
[JScript]
public function TranslateTransform(
   dx : float,
   dy : float
);

Parameters

dx
[To be supplied.]
dy
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.TranslateTransform Overload List


Graphics.TranslateTransform (Single, Single, MatrixOrder)

[To be supplied.]

[Visual Basic]
Overloads Public Sub TranslateTransform( _
   ByVal dx As Single, _
   ByVal dy As Single, _
   ByVal order As MatrixOrder _
)
[C#]
public void TranslateTransform(
   float dx,
   float dy,
   MatrixOrder order
);
[C++]
public: void TranslateTransform(
   float dx,
   float dy,
   MatrixOrder order
);
[JScript]
public function TranslateTransform(
   dx : float,
   dy : float,
   order : MatrixOrder
);

Parameters

dx
[To be supplied.]
dy
[To be supplied.]
order
[To be supplied.]

See Also

Graphics Class | Graphics Members | System.Drawing Namespace | Graphics.TranslateTransform Overload List


Graphics.DrawImageAbort Delegate

[To be supplied.]

[Visual Basic]
Public Delegate Sub Graphics.DrawImageAbort( _
   ByVal callbackdata As Integer _
) As Boolean
[C#]
public delegate bool Graphics.DrawImageAbort(
   int callbackdata
);
[C++]
public __gc __delegate bool Graphics.DrawImageAbort(
   int callbackdata
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the Graphics.DrawImageAbort delegate declaration.

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

System.Drawing Namespace


Graphics.EnumerateMetafileProc Delegate

[To be supplied.]

[Visual Basic]
Public Delegate Sub Graphics.EnumerateMetafileProc( _
   ByVal recordType As EmfPlusRecordType, _
   ByVal flags As Integer, _
   ByVal dataSize As Integer, _
   ByVal data As Integer, _
   ByVal callbackData As Integer _
) As Boolean
[C#]
public delegate bool Graphics.EnumerateMetafileProc(
   EmfPlusRecordType recordType,
   int flags,
   int dataSize,
   int data,
   int callbackData
);
[C++]
public __gc __delegate bool Graphics.EnumerateMetafileProc(
   EmfPlusRecordType recordType,
   int flags,
   int dataSize,
   int data,
   int callbackData
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the Graphics.EnumerateMetafileProc delegate declaration.

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

System.Drawing Namespace


GraphicsAdvancedAttribute Class

[To be supplied.]

Object
Attribute
MemberAttribute
GraphicsAdvancedAttribute

[Visual Basic]
NotInheritable Public Class GraphicsAdvancedAttribute
   Inherits MemberAttribute
[C#]
public sealed class GraphicsAdvancedAttribute : MemberAttribute
[C++]
public __gc __sealed class GraphicsAdvancedAttribute : public
   MemberAttribute
[JScript]
public class GraphicsAdvancedAttribute extends MemberAttribute

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

GraphicsAdvancedAttribute Members | System.Drawing Namespace


GraphicsAdvancedAttribute Members

Public:

Constructor

GraphicsAdvancedAttribute Constructor [To be supplied.]

Properties

Level | [To be supplied.]
TypeId (inherited from MemberAttribute) | Gets a unique ID for this MemberAttribute.

Methods

Equals (inherited from MemberAttribute) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsDefaultAttribute (inherited from MemberAttribute) | When overridden in a derived class, specifies whether this MemberAttribute is the default attribute for the class.
Match (inherited from MemberAttribute) | Determines whether one attribute matches another.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GraphicsAdvancedAttribute Class | System.Drawing Namespace


GraphicsAdvancedAttribute Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal level As Integer _
)
[C#]
public GraphicsAdvancedAttribute(
   int level
);
[C++]
public: GraphicsAdvancedAttribute(
   int level
);
[JScript]
public function GraphicsAdvancedAttribute(
   level : int
);

Parameters

level
[To be supplied.]

See Also

GraphicsAdvancedAttribute Class | GraphicsAdvancedAttribute Members | System.Drawing Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

GraphicsAdvancedAttribute Properties

The properties of the GraphicsAdvancedAttribute class are listed below. For a complete list of GraphicsAdvancedAttribute class members, see the GraphicsAdvancedAttribute Members topic.

Public:

Level | [To be supplied.]
TypeId (inherited from MemberAttribute) | Gets a unique ID for this MemberAttribute.

See Also

GraphicsAdvancedAttribute Class | System.Drawing Namespace


GraphicsAdvancedAttribute.Level

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Level As Integer
[C#]
public int Level {get;}
[C++]
public: __property int get_Level();
[JScript]
public function get Level() : int;

See Also

GraphicsAdvancedAttribute Class | GraphicsAdvancedAttribute Members | System.Drawing Namespace


GraphicsUnit Enumeration

[To be supplied.]

[Visual Basic]
Public Enum GraphicsUnit
[C#]
public enum GraphicsUnit
[C++]
public enum GraphicsUnit

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Display | [To be supplied.]
Document | [To be supplied.]
Inch | [To be supplied.]
Millimeter | [To be supplied.]
Pixel | [To be supplied.]
Point | [To be supplied.]
World | [To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

System.Drawing Namespace


Icon Class

This class represents a Windows icon, which is a small bitmap image used to represent an object. Icons can be thought of as transparent bitmaps, although their size is determined by the system.

Object
Icon

[Visual Basic]
Public Class Icon
   Implements IPersistable, ISerializable, ICloneable
[C#]
public class Icon : IPersistable, ISerializable, ICloneable
[C++]
public __gc class Icon : public IPersistable, ISerializable,
   ICloneable
[JScript]
public class Icon implements IPersistable, ISerializable,
   ICloneable

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

Icon Members | System.Drawing Namespace


Icon Members

Public:

Constructor

Icon Constructor Overloaded. [To be supplied.]

Properties

Handle | The Win32 handle for this object. This is not a copy of the handle; do not free it.
Height | [To be supplied.]
Size | The size of this icon object.
Width | [To be supplied.]

Methods

Clone | Clones the icon object, creating a duplicate image.
CopyHandle | Duplicates this icon's Win32 handle. You are responsible for freeing the returned handle when you are done with it.
Dispose | Cleans up the resources allocated by this object. Once called, the cursor object is no longer useful.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetFromHandle | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Save | Saves this image to the given output stream.
ToBitmap | [To be supplied.]
ToString | Retrieves a human readable string representing the cursor.

Protected:

Methods

Finalize | Cleans up Windows resources for this object.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Icon Class | System.Drawing Namespace


Icon Constructor

[To be supplied.]

Overload List

Creates an icon object from a given Win32 icon handle. The Icon object does not claim ownership of the icon handle; you must free it when you are done.

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public Icon(int);
[C++] public: Icon(int);
[JScript] public function Icon(int);

Loads an icon object from the given filename.

[Visual Basic] Overloads Public Sub New(String)
[C#] public Icon(String);
[C++] public: Icon(String*);
[JScript] public function Icon(String);

Duplicates the given icon, attempting to find a version of the icon that matches the requested size. If a version cannot be found that exactally matches the size, the closest match will be used. Note that if original is an icon with a single size, this will merely create a dupicate icon. You can use the stretching modes of drawImage to force the icon to the size you want.

[Visual Basic] Overloads Public Sub New(Icon, Integer, Integer)
[C#] public Icon(Icon, int, int);
[C++] public: Icon(Icon*, int, int);
[JScript] public function Icon(Icon, int, int);

Loads an icon object from the given resource.

[Visual Basic] Overloads Public Sub New(Type, String)
[C#] public Icon(Type, String);
[C++] public: Icon(Type*, String);
[JScript] public function Icon(Type, String);

Loads an icon object from the given data stream.

[Visual Basic] Overloads Public Sub New(Stream)
[C#] public Icon(Stream);
[C++] public: Icon(Stream*);
[JScript] public function Icon(Stream);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Stream, Integer, Integer)
[C#] public Icon(Stream, int, int);
[C++] public: Icon(Stream*, int, int);
[JScript] public function Icon(Stream, int, int);

See Also

Icon Class | Icon Members | System.Drawing Namespace


Icon Constructor (Int32)

Creates an icon object from a given Win32 icon handle. The Icon object does not claim ownership of the icon handle; you must free it when you are done.

[Visual Basic]
Overloads Public Sub New( _
   ByVal handle As Integer _
)
[C#]
public Icon(
   int handle
);
[C++]
public: Icon(
   int handle
);
[JScript]
public function Icon(
   handle : int
);

Parameters

handle
The Win32 icon handle.

See Also

Icon Class | Icon Members | System.Drawing Namespace | Icon Constructor Overload List


Icon Constructor (String)

Loads an icon object from the given filename.

[Visual Basic]
Overloads Public Sub New( _
   ByVal fileName As String _
)
[C#]
public Icon(
   string fileName
);
[C++]
public: Icon(
   String* fileName
);
[JScript]
public function Icon(
   fileName : String
);

Parameters

fileName
The file to load the icon from.

See Also

Icon Class | Icon Members | System.Drawing Namespace | Icon Constructor Overload List


Icon Constructor (Icon, Int32, Int32)

Duplicates the given icon, attempting to find a version of the icon that matches the requested size. If a version cannot be found that exactally matches the size, the closest match will be used. Note that if original is an icon with a single size, this will merely create a dupicate icon. You can use the stretching modes of drawImage to force the icon to the size you want.

[Visual Basic]
Overloads Public Sub New( _
   ByVal original As Icon, _
   ByVal width As Integer, _
   ByVal height As Integer _
)
[C#]
public Icon(
   Icon original,
   int width,
   int height
);
[C++]
public: Icon(
   Icon* original,
   int width,
   int height
);
[JScript]
public function Icon(
   original : Icon,
   width : int,
   height : int
);

Parameters

original
The icon to load the different size from.
width
The width of the new icon.
height
The height of the new icon.

See Also

Icon Class | Icon Members | System.Drawing Namespace | Icon Constructor Overload List


Icon Constructor (Type, String)

Loads an icon object from the given resource.

[Visual Basic]
Overloads Public Sub New( _
   ByVal type As Type, _
   ByVal resource As String _
)
[C#]
public Icon(
   Type type,
   string resource
);
[C++]
public: Icon(
   Type* type,
   String* resource
);
[JScript]
public function Icon(
   type : Type,
   resource : String
);

Parameters

type
The type of the resource class.
resource
The resource name to load.

See Also

Icon Class | Icon Members | System.Drawing Namespace | Icon Constructor Overload List


Icon Constructor (Stream)

Loads an icon object from the given data stream.

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream _
)
[C#]
public Icon(
   Stream stream
);
[C++]
public: Icon(
   Stream* stream
);
[JScript]
public function Icon(
   stream : Stream
);

Parameters

stream
The data stream to load the icon from.

See Also

Icon Class | Icon Members | System.Drawing Namespace | Icon Constructor Overload List | Stream


Icon Constructor (Stream, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream, _
   ByVal width As Integer, _
   ByVal height As Integer _
)
[C#]
public Icon(
   Stream stream,
   int width,
   int height
);
[C++]
public: Icon(
   Stream* stream,
   int width,
   int height
);
[JScript]
public function Icon(
   stream : Stream,
   width : int,
   height : int
);

Parameters

stream
[To be supplied.]
width
[To be supplied.]
height
[To be supplied.]

See Also

Icon Class | Icon Members | System.Drawing Namespace | Icon Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Icon Properties

The properties of the Icon class are listed below. For a complete list of Icon class members, see the Icon Members topic.

Public:

Handle | The Win32 handle for this object. This is not a copy of the handle; do not free it.
Height | [To be supplied.]
Size | The size of this icon object.
Width | [To be supplied.]

See Also

Icon Class | System.Drawing Namespace


Icon.Handle

The Win32 handle for this object. This is not a copy of the handle; do not free it.

[Visual Basic]
Public ReadOnly Property Handle As Integer
[C#]
public int Handle {get;}
[C++]
public: __property int get_Handle();
[JScript]
public function get Handle() : int;

See Also

Icon Class | Icon Members | System.Drawing Namespace


Icon.Height

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Height As Integer
[C#]
public int Height {get;}
[C++]
public: __property int get_Height();
[JScript]
public function get Height() : int;

See Also

Icon Class | Icon Members | System.Drawing Namespace


Icon.Size

The size of this icon object.

[Visual Basic]
Public ReadOnly Property Size As Size
[C#]
public Size Size {get;}
[C++]
public: __property Size get_Size();
[JScript]
public function get Size() : Size;

See Also

Icon Class | Icon Members | System.Drawing Namespace


Icon.Width

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Width As Integer
[C#]
public int Width {get;}
[C++]
public: __property int get_Width();
[JScript]
public function get Width() : int;

See Also

Icon Class | Icon Members | System.Drawing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Icon Methods

The methods of the Icon class are listed below. For a complete list of Icon class members, see the Icon Members topic.

Public:

Clone | Clones the icon object, creating a duplicate image.
CopyHandle | Duplicates this icon's Win32 handle. You are responsible for freeing the returned handle when you are done with it.
Dispose | Cleans up the resources allocated by this object. Once called, the cursor object is no longer useful.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetFromHandle | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Save | Saves this image to the given output stream.
ToBitmap | [To be supplied.]
ToString | Retrieves a human readable string representing the cursor.

Protected:

Finalize | Cleans up Windows resources for this object.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Icon Class | System.Drawing Namespace


Icon.Clone

Clones the icon object, creating a duplicate image.

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

Return Value

an object that can be casted to an Icon.

See Also

Icon Class | Icon Members | System.Drawing Namespace


Icon.CopyHandle

Duplicates this icon's Win32 handle. You are responsible for freeing the returned handle when you are done with it.

[Visual Basic]
Public Function CopyHandle() As Integer
[C#]
public int CopyHandle();
[C++]
public: int CopyHandle();
[JScript]
public function CopyHandle() : int;

Return Value

a Win32 icon handle.

See Also

Icon Class | Icon Members | System.Drawing Namespace


Icon.Dispose

Cleans up the resources allocated by this object. Once called, the cursor object is no longer useful.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[JScript]
public function Dispose();

See Also

Icon Class | Icon Members | System.Drawing Namespace


Icon.Finalize

Cleans up Windows resources for this object.

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

Icon Class | Icon Members | System.Drawing Namespace


Icon.GetFromHandle

[To be supplied.]

[Visual Basic]
Public Shared Function GetFromHandle( _
   ByVal handle As Integer _
) As Icon
[C#]
public static Icon GetFromHandle(
   int handle
);
[C++]
public: static Icon* GetFromHandle(
   int handle
);
[JScript]
public static function GetFromHandle(
   handle : int
) : Icon;

Parameters

handle
[To be supplied.]

See Also

Icon Class | Icon Members | System.Drawing Namespace


Icon.Save

Saves this image to the given output stream.

[Visual Basic]
Overridable Public Sub Save( _
   ByVal outputStream As Stream _
)
[C#]
public virtual void Save(
   Stream outputStream
);
[C++]
public: virtual void Save(
   Stream* outputStream
);
[JScript]
public function Save(
   outputStream : Stream
);

Parameters

outputStream
The stream to save to. This can be a file, data object, or other Stream.

See Also

Icon Class | Icon Members | System.Drawing Namespace


Icon.ToBitmap

[To be supplied.]

[Visual Basic]
Public Function ToBitmap() As Bitmap
[C#]
public Bitmap ToBitmap();
[C++]
public: Bitmap* ToBitmap();
[JScript]
public function ToBitmap() : Bitmap;

See Also

Icon Class | Icon Members | System.Drawing Namespace


Icon.ToString

Retrieves a human readable string representing the cursor.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

a string describing the cursor.

See Also

Icon Class | Icon Members | System.Drawing Namespace


IconConverter Class

IconConverter is a class that can be used to convert Icon from one data type to another. Access this class through the TypeDescriptor.

Object
TypeConverter
IconConverter

[Visual Basic]
Public Class IconConverter
   Inherits TypeConverter
[C#]
public class IconConverter : TypeConverter
[C++]
public __gc class IconConverter : public TypeConverter
[JScript]
public class IconConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

IconConverter Members | System.Drawing Namespace


IconConverter Members

Public:

Constructor

IconConverter Constructor [To be supplied.]

Methods

CanConvertFrom (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the converter's native type.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text into an object.
ConvertTo | Overloaded. [To be supplied.]
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetProperties (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValues (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid (inherited from TypeConverter) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

IconConverter Class | System.Drawing Namespace


IconConverter Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public IconConverter();
[C++]
public: IconConverter();
[JScript]
public function IconConverter();

See Also

IconConverter Class | IconConverter Members | System.Drawing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IconConverter Methods

The methods of the IconConverter class are listed below. For a complete list of IconConverter class members, see the IconConverter Members topic.

Public:

CanConvertFrom (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the converter's native type.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text into an object.
ConvertTo | Overloaded. [To be supplied.]
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetProperties (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValues (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid (inherited from TypeConverter) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

IconConverter Class | System.Drawing Namespace


IconConverter.ConvertTo

Converts the given object to another type. The most common types to convert are to and from a string object. The default implementation will make a call to ToString on the object if the object is valid and if the destination type is string. If this cannot convert to the desitnation type, this will throw a NotSupportedException.

[Visual Basic]
Overrides Public Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal destinationType As Type, _
   ByVal arguments() As Object _
) As Object
[C#]
public override object ConvertTo(
   ITypeDescriptorContext context,
   object value,
   Type destinationType,
   object[] arguments
);
[C++]
public: override Object* ConvertTo(
   ITypeDescriptorContext* context,
   Object* value,
   Type* destinationType,
   Object* arguments[]
);
[JScript]
public override function ConvertTo(
   context : ITypeDescriptorContext,
   value : Object,
   destinationType : Type,
   arguments : Object[]
) : Object;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
value
The object to convert.
destinationType
The type to convert the object to.
arguments
An optional array of arguments to use when doing the conversion. The number and content of these arguments is dependent on the implementer of the value formatter.

Return Value

The converted object.

See Also

IconConverter Class | IconConverter Members | System.Drawing Namespace


IconConverter.GetProperties

Retrieves the set of properties for this type. By default, a type has does not return any properties. An easy implementation of this method can just call TypeDescriptor.GetProperties for the correct data type.

[Visual Basic]
Overrides Public Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal attributes() As MemberAttribute _
) As PropertyDescriptorCollection
[C#]
public override PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value,
   MemberAttribute[] attributes
);
[C++]
public: override PropertyDescriptorCollection* GetProperties(
   ITypeDescriptorContext* context,
   Object* value,
   MemberAttribute* attributes[]
);
[JScript]
public override function GetProperties(
   context : ITypeDescriptorContext,
   value : Object,
   attributes : MemberAttribute[]
) : PropertyDescriptorCollection;

Parameters

context
A type descriptor through which additional context may be provided.
value
The value of the object to get the properties for.
attributes
[To be supplied.]

Return Value

The set of properties that should be exposed for this data type. If no properties should be exposed, thsi may return null. The default implementation always returns null.

See Also

IconConverter Class | IconConverter Members | System.Drawing Namespace


IconConverter.GetPropertiesSupported

Determines if this object supports properties. By default, this is false.

[Visual Basic]
Overrides Public Function GetPropertiesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
[C#]
public override bool GetPropertiesSupported(
   ITypeDescriptorContext context
);
[C++]
public: override bool GetPropertiesSupported(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetPropertiesSupported(
   context : ITypeDescriptorContext
) : Boolean;

Parameters

context
A type descriptor through which additional context may be provided.

Return Value

Returns true if GetProperties should be called to find the properties of this object.

See Also

IconConverter Class | IconConverter Members | System.Drawing Namespace


Image Class

[To be supplied.]

Object
MarshalByRefObject
Image

[Visual Basic]
MustInherit Public Class Image
   Inherits MarshalByRefObject
   Implements IPersistable, ISerializable, ICloneable
[C#]
public abstract class Image : MarshalByRefObject, IPersistable,
   ISerializable, ICloneable
[C++]
public __gc __abstract class Image : public MarshalByRefObject,
   IPersistable, ISerializable, ICloneable
[JScript]
public abstract class Image extends MarshalByRefObject,
   IPersistable, ISerializable, ICloneable

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

Image Members | System.Drawing Namespace


Image Members

Public:

Properties

Flags | [To be supplied.]
FrameDimensionsList | [To be supplied.]
Height | [To be supplied.]
HorizontalResolution | [To be supplied.]
Palette | [To be supplied.]
PhysicalDimension | [To be supplied.]
PixelFormat | [To be supplied.]
PropertyIdList | [To be supplied.]
PropertyItems | [To be supplied.]
RawFormat | [To be supplied.]
Size | [To be supplied.]
VerticalResolution | [To be supplied.]
Width | [To be supplied.]

Methods

Clone | [To be supplied.]
Dispose | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FromFile | [To be supplied.]
FromHBITMAP | Overloaded. [To be supplied.]
FromStream | [To be supplied.]
GetBounds | [To be supplied.]
GetEncoderParameterList | [To be supplied.]
GetFrameCount | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetPixelFormatSize | [To be supplied.]
GetPropertyItem | [To be supplied.]
GetThumbnailImage | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
IsAlphaPixelFormat | [To be supplied.]
IsCanonicalPixelFormat | [To be supplied.]
IsExtendedPixelFormat | [To be supplied.]
IsIndexedPixelFormat | [To be supplied.]
RemovePropertyItem | [To be supplied.]
Save | Overloaded. [To be supplied.]
SaveAdd | Overloaded. [To be supplied.]
SelectActiveFrame | [To be supplied.]
SetPropertyItem | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Image Class | System.Drawing Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Image Properties

The properties of the Image class are listed below. For a complete list of Image class members, see the Image Members topic.

Public:

Flags | [To be supplied.]
FrameDimensionsList | [To be supplied.]
Height | [To be supplied.]
HorizontalResolution | [To be supplied.]
Palette | [To be supplied.]
PhysicalDimension | [To be supplied.]
PixelFormat | [To be supplied.]
PropertyIdList | [To be supplied.]
PropertyItems | [To be supplied.]
RawFormat | [To be supplied.]
Size | [To be supplied.]
VerticalResolution | [To be supplied.]
Width | [To be supplied.]

See Also

Image Class | System.Drawing Namespace


Image.Flags

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Flags As Integer
[C#]
public int Flags {get;}
[C++]
public: __property int get_Flags();
[JScript]
public function get Flags() : int;

See Also

Image Class | Image Members | System.Drawing Namespace


Image.FrameDimensionsList

[To be supplied.]

[Visual Basic]
Public ReadOnly Property FrameDimensionsList As Guid ()
[C#]
public Guid[] FrameDimensionsList {get;}
[C++]
public: __property Guid* get_FrameDimensionsList();
[JScript]
public function get FrameDimensionsList() : Guid[];

See Also

Image Class | Image Members | System.Drawing Namespace


Image.Height

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Height As Integer
[C#]
public int Height {get;}
[C++]
public: __property int get_Height();
[JScript]
public function get Height() : int;

See Also

Image Class | Image Members | System.Drawing Namespace


Image.HorizontalResolution

[To be supplied.]

[Visual Basic]
Public ReadOnly Property HorizontalResolution As Single
[C#]
public float HorizontalResolution {get;}
[C++]
public: __property float get_HorizontalResolution();
[JScript]
public function get HorizontalResolution() : float;

See Also

Image Class | Image Members | System.Drawing Namespace


Image.Palette

[To be supplied.]

[Visual Basic]
Public Property Palette As ColorPalette
[C#]
public ColorPalette Palette {get; set;}
[C++]
public: __property ColorPalette* get_Palette();
public: __property void set_Palette(ColorPalette*);
[JScript]
public function get Palette() : ColorPalette;
public function set Palette(ColorPalette);

See Also

Image Class | Image Members | System.Drawing Namespace


Image.PhysicalDimension

[To be supplied.]

[Visual Basic]
Public ReadOnly Property PhysicalDimension As SizeF
[C#]
public SizeF PhysicalDimension {get;}
[C++]
public: __property SizeF get_PhysicalDimension();
[JScript]
public function get PhysicalDimension() : SizeF;

See Also

Image Class | Image Members | System.Drawing Namespace


Image.PixelFormat

[To be supplied.]

[Visual Basic]
Public ReadOnly Property PixelFormat As PixelFormat
[C#]
public PixelFormat PixelFormat {get;}
[C++]
public: __property PixelFormat get_PixelFormat();
[JScript]
public function get PixelFormat() : PixelFormat;

See Also

Image Class | Image Members | System.Drawing Namespace


Image.PropertyIdList

[To be supplied.]

[Visual Basic]
Public ReadOnly Property PropertyIdList As Integer ()
[C#]
public int[] PropertyIdList {get;}
[C++]
public: __property int* get_PropertyIdList();
[JScript]
public function get PropertyIdList() : int[];

See Also

Image Class | Image Members | System.Drawing Namespace


Image.PropertyItems

[To be supplied.]

[Visual Basic]
Public ReadOnly Property PropertyItems As PropertyItem ()
[C#]
public PropertyItem[] PropertyItems {get;}
[C++]
public: __property PropertyItem* get_PropertyItems();
[JScript]
public function get PropertyItems() : PropertyItem[];

See Also

Image Class | Image Members | System.Drawing Namespace


Image.RawFormat

[To be supplied.]

[Visual Basic]
Public ReadOnly Property RawFormat As ImageFormat
[C#]
public ImageFormat RawFormat {get;}
[C++]
public: __property ImageFormat* get_RawFormat();
[JScript]
public function get RawFormat() : ImageFormat;

See Also

Image Class | Image Members | System.Drawing Namespace


Image.Size

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Size As Size
[C#]
public Size Size {get;}
[C++]
public: __property Size get_Size();
[JScript]
public function get Size() : Size;

See Also

Image Class | Image Members | System.Drawing Namespace


Image.VerticalResolution

[To be supplied.]

[Visual Basic]
Public ReadOnly Property VerticalResolution As Single
[C#]
public float VerticalResolution {get;}
[C++]
public: __property float get_VerticalResolution();
[JScript]
public function get VerticalResolution() : float;

See Also

Image Class | Image Members | System.Drawing Namespace


Image.Width

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Width As Integer
[C#]
public int Width {get;}
[C++]
public: __property int get_Width();
[JScript]
public function get Width() : int;

See Also

Image Class | Image Members | System.Drawing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Image Methods

The methods of the Image class are listed below. For a complete list of Image class members, see the Image Members topic.

Public:

Clone | [To be supplied.]
Dispose | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FromFile | [To be supplied.]
FromHBITMAP | Overloaded. [To be supplied.]
FromStream | [To be supplied.]
GetBounds | [To be supplied.]
GetEncoderParameterList | [To be supplied.]
GetFrameCount | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetPixelFormatSize | [To be supplied.]
GetPropertyItem | [To be supplied.]
GetThumbnailImage | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
IsAlphaPixelFormat | [To be supplied.]
IsCanonicalPixelFormat | [To be supplied.]
IsExtendedPixelFormat | [To be supplied.]
IsIndexedPixelFormat | [To be supplied.]
RemovePropertyItem | [To be supplied.]
Save | Overloaded. [To be supplied.]
SaveAdd | Overloaded. [To be supplied.]
SelectActiveFrame | [To be supplied.]
SetPropertyItem | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Image Class | System.Drawing Namespace


Image.Clone

[To be supplied.]

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

See Also

Image Class | Image Members | System.Drawing Namespace


Image.Dispose

[To be supplied.]

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[JScript]
public function Dispose();

See Also

Image Class | Image Members | System.Drawing Namespace


Image.Finalize

[To be supplied.]

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

Image Class | Image Members | System.Drawing Namespace


Image.FromFile

[To be supplied.]

[Visual Basic]
Public Shared Function FromFile( _
   ByVal filename As String _
) As Image
[C#]
public static Image FromFile(
   string filename
);
[C++]
public: static Image* FromFile(
   String* filename
);
[JScript]
public static function FromFile(
   filename : String
) : Image;

Parameters

filename
[To be supplied.]

See Also

Image Class | Image Members | System.Drawing Namespace


Image.FromHBITMAP

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Shared Function FromHBITMAP(Integer, Integer) As Bitmap
[C#] public static Bitmap FromHBITMAP(int, int);
[C++] public: static Bitmap* FromHBITMAP(int, int);
[JScript] public static function FromHBITMAP(int, int) : Bitmap;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function FromHBITMAP(Integer) As Bitmap
[C#] public static Bitmap FromHBITMAP(int);
[C++] public: static Bitmap* FromHBITMAP(int);
[JScript] public static function FromHBITMAP(int) : Bitmap;

See Also

Image Class | Image Members | System.Drawing Namespace


Image.FromHBITMAP (Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function FromHBITMAP( _
   ByVal hBitmap As Integer, _
   ByVal hPalette As Integer _
) As Bitmap
[C#]
public static Bitmap FromHBITMAP(
   int hBitmap,
   int hPalette
);
[C++]
public: static Bitmap* FromHBITMAP(
   int hBitmap,
   int hPalette
);
[JScript]
public static function FromHBITMAP(
   hBitmap : int,
   hPalette : int
) : Bitmap;

Parameters

hBitmap
[To be supplied.]
hPalette
[To be supplied.]

See Also

Image Class | Image Members | System.Drawing Namespace | Image.FromHBITMAP Overload List


Image.FromHBITMAP (Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function FromHBITMAP( _
   ByVal hBitmap As Integer _
) As Bitmap
[C#]
public static Bitmap FromHBITMAP(
   int hBitmap
);
[C++]
public: static Bitmap* FromHBITMAP(
   int hBitmap
);
[JScript]
public static function FromHBITMAP(
   hBitmap : int
) : Bitmap;

Parameters

hBitmap
[To be supplied.]

See Also

Image Class | Image Members | System.Drawing Namespace | Image.FromHBITMAP Overload List


Image.FromStream

[To be supplied.]

[Visual Basic]
Public Shared Function FromStream( _
   ByVal stream As Stream _
) As Image
[C#]
public static Image FromStream(
   Stream stream
);
[C++]
public: static Image* FromStream(
   Stream* stream
);
[JScript]
public static function FromStream(
   stream : Stream
) : Image;

Parameters

stream
[To be supplied.]

See Also

Image Class | Image Members | System.Drawing Namespace


Image.GetBounds

[To be supplied.]

[Visual Basic]
Public Function GetBounds( _
   ByRef pageUnit As GraphicsUnit _
) As RectangleF
[C#]
public RectangleF GetBounds(
   ref GraphicsUnit pageUnit
);
[C++]
public: RectangleF GetBounds(
   GraphicsUnit** pageUnit
);
[JScript]
public function GetBounds(
   pageUnit : GraphicsUnit
) : RectangleF;

Parameters

pageUnit
[To be supplied.]

See Also

Image Class | Image Members | System.Drawing Namespace


Image.GetEncoderParameterList

[To be supplied.]

[Visual Basic]
Public Function GetEncoderParameterList( _
   ByVal encoder As Guid _
) As EncoderParameters
[C#]
public EncoderParameters GetEncoderParameterList(
   Guid encoder
);
[C++]
public: EncoderParameters* GetEncoderParameterList(
   Guid encoder
);
[JScript]
public function GetEncoderParameterList(
   encoder : Guid
) : EncoderParameters;

Parameters

encoder
[To be supplied.]

See Also

Image Class | Image Members | System.Drawing Namespace


Image.GetFrameCount

[To be supplied.]

[Visual Basic]
Public Function GetFrameCount( _
   ByVal dimensionID As Guid _
) As Integer
[C#]
public int GetFrameCount(
   Guid dimensionID
);
[C++]
public: int GetFrameCount(
   Guid dimensionID
);
[JScript]
public function GetFrameCount(
   dimensionID : Guid
) : int;

Parameters

dimensionID
[To be supplied.]

See Also

Image Class | Image Members | System.Drawing Namespace


Image.GetPixelFormatSize

[To be supplied.]

[Visual Basic]
Public Shared Function GetPixelFormatSize( _
   ByVal pixfmt As PixelFormat _
) As Integer
[C#]
public static int GetPixelFormatSize(
   PixelFormat pixfmt
);
[C++]
public: static int GetPixelFormatSize(
   PixelFormat pixfmt
);
[JScript]
public static function GetPixelFormatSize(
   pixfmt : PixelFormat
) : int;

Parameters

pixfmt
[To be supplied.]

See Also

Image Class | Image Members | System.Drawing Namespace


Image.GetPropertyItem

[To be supplied.]

[Visual Basic]
Public Function GetPropertyItem( _
   ByVal propid As Integer _
) As PropertyItem
[C#]
public PropertyItem GetPropertyItem(
   int propid
);
[C++]
public: PropertyItem* GetPropertyItem(
   int propid
);
[JScript]
public function GetPropertyItem(
   propid : int
) : PropertyItem;

Parameters

propid
[To be supplied.]

See Also

Image Class | Image Members | System.Drawing Namespace


Image.GetThumbnailImage

[To be supplied.]

[Visual Basic]
Public Function GetThumbnailImage( _
   ByVal thumbWidth As Integer, _
   ByVal thumbHeight As Integer, _
   ByVal callback As Image.GetThumbnailImageAbort, _
   ByVal callbackData As Integer _
) As Image
[C#]
public Image GetThumbnailImage(
   int thumbWidth,
   int thumbHeight,
   Image.GetThumbnailImageAbort callback,
   int callbackData
);
[C++]
public: Image* GetThumbnailImage(
   int thumbWidth,
   int thumbHeight,
   Image.GetThumbnailImageAbort* callback,
   int callbackData
);
[JScript]
public function GetThumbnailImage(
   thumbWidth : int,
   thumbHeight : int,
   callback : Image.GetThumbnailImageAbort,
   callbackData : int
) : Image;

Parameters

thumbWidth
[To be supplied.]
thumbHeight
[To be supplied.]
callback
[To be supplied.]
callbackData
[To be supplied.]

See Also

Image Class | Image Members | System.Drawing Namespace


Image.IsAlphaPixelFormat

[To be supplied.]

[Visual Basic]
Public Shared Function IsAlphaPixelFormat( _
   ByVal pixfmt As PixelFormat _
) As Boolean
[C#]
public static bool IsAlphaPixelFormat(
   PixelFormat pixfmt
);
[C++]
public: static bool IsAlphaPixelFormat(
   PixelFormat pixfmt
);
[JScript]
public static function IsAlphaPixelFormat(
   pixfmt : PixelFormat
) : Boolean;

Parameters

pixfmt
[To be supplied.]

See Also

Image Class | Image Members | System.Drawing Namespace


Image.IsCanonicalPixelFormat

[To be supplied.]

[Visual Basic]
Public Shared Function IsCanonicalPixelFormat( _
   ByVal pixfmt As PixelFormat _
) As Boolean
[C#]
public static bool IsCanonicalPixelFormat(
   PixelFormat pixfmt
);
[C++]
public: static bool IsCanonicalPixelFormat(
   PixelFormat pixfmt
);
[JScript]
public static function IsCanonicalPixelFormat(
   pixfmt : PixelFormat
) : Boolean;

Parameters

pixfmt
[To be supplied.]

See Also

Image Class | Image Members | System.Drawing Namespace


Image.IsExtendedPixelFormat

[To be supplied.]

[Visual Basic]
Public Shared Function IsExtendedPixelFormat( _
   ByVal pixfmt As PixelFormat _
) As Boolean
[C#]
public static bool IsExtendedPixelFormat(
   PixelFormat pixfmt
);
[C++]
public: static bool IsExtendedPixelFormat(
   PixelFormat pixfmt
);
[JScript]
public static function IsExtendedPixelFormat(
   pixfmt : PixelFormat
) : Boolean;

Parameters

pixfmt
[To be supplied.]

See Also

Image Class | Image Members | System.Drawing Namespace


Image.IsIndexedPixelFormat

[To be supplied.]

[Visual Basic]
Public Shared Function IsIndexedPixelFormat( _
   ByVal pixfmt As PixelFormat _
) As Boolean
[C#]
public static bool IsIndexedPixelFormat(
   PixelFormat pixfmt
);
[C++]
public: static bool IsIndexedPixelFormat(
   PixelFormat pixfmt
);
[JScript]
public static function IsIndexedPixelFormat(
   pixfmt : PixelFormat
) : Boolean;

Parameters

pixfmt
[To be supplied.]

See Also

Image Class | Image Members | System.Drawing Namespace


Image.RemovePropertyItem

[To be supplied.]

[Visual Basic]
Public Sub RemovePropertyItem( _
   ByVal propid As Integer _
)
[C#]
public void RemovePropertyItem(
   int propid
);
[C++]
public: void RemovePropertyItem(
   int propid
);
[JScript]
public function RemovePropertyItem(
   propid : int
);

Parameters

propid
[To be supplied.]

See Also

Image Class | Image Members | System.Drawing Namespace


Image.Save

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub Save(String, ImageFormat)
[C#] public void Save(String, ImageFormat);
[C++] public: void Save(String*, ImageFormat);
[JScript] public function Save(String, ImageFormat);

[To be supplied.]

[Visual Basic] Overloads Public Sub Save(String)
[C#] public void Save(String);
[C++] public: void Save(String*);
[JScript] public function Save(String);

[To be supplied.]

[Visual Basic] Overloads Overridable Public Sub Save(Stream)
[C#] public virtual void Save(Stream);
[C++] public: virtual void Save(Stream*);
[JScript] public function Save(Stream);

[To be supplied.]

[Visual Basic] Overloads Public Sub Save(Stream, ImageFormat, EncoderParameters)
[C#] public void Save(Stream, ImageFormat, EncoderParameters);
[C++] public: void Save(Stream*, ImageFormat, EncoderParameters);
[JScript] public function Save(Stream, ImageFormat, EncoderParameters);

[To be supplied.]

[Visual Basic] Overloads Public Sub Save(Stream, ImageFormat)
[C#] public void Save(Stream, ImageFormat);
[C++] public: void Save(Stream*, ImageFormat);
[JScript] public function Save(Stream, ImageFormat);

[To be supplied.]

[Visual Basic] Overloads Public Sub Save(String, ImageFormat, EncoderParameters)
[C#] public void Save(String, ImageFormat, EncoderParameters);
[C++] public: void Save(String*, ImageFormat, EncoderParameters);
[JScript] public function Save(String, ImageFormat, EncoderParameters);

See Also

Image Class | Image Members | System.Drawing Namespace


Image.Save (String, ImageFormat)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Save( _
   ByVal filename As String, _
   ByVal format As ImageFormat _
)
[C#]
public void Save(
   string filename,
   ImageFormat format
);
[C++]
public: void Save(
   String* filename,
   ImageFormat* format
);
[JScript]
public function Save(
   filename : String,
   format : ImageFormat
);

Parameters

filename
[To be supplied.]
format
[To be supplied.]

See Also

Image Class | Image Members | System.Drawing Namespace | Image.Save Overload List


Image.Save (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Save( _
   ByVal filename As String _
)
[C#]
public void Save(
   string filename
);
[C++]
public: void Save(
   String* filename
);
[JScript]
public function Save(
   filename : String
);

Parameters

filename
[To be supplied.]

See Also

Image Class | Image Members | System.Drawing Namespace | Image.Save Overload List


Image.Save (Stream)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Sub Save( _
   ByVal stream As Stream _
)
[C#]
public virtual void Save(
   Stream stream
);
[C++]
public: virtual void Save(
   Stream* stream
);
[JScript]
public function Save(
   stream : Stream
);

Parameters

stream
[To be supplied.]

See Also

Image Class | Image Members | System.Drawing Namespace | Image.Save Overload List


Image.Save (Stream, ImageFormat, EncoderParameters)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Save( _
   ByVal stream As Stream, _
   ByVal format As ImageFormat, _
   ByVal encoderParams As EncoderParameters _
)
[C#]
public void Save(
   Stream stream,
   ImageFormat format,
   EncoderParameters encoderParams
);
[C++]
public: void Save(
   Stream* stream,
   ImageFormat* format,
   EncoderParameters* encoderParams
);
[JScript]
public function Save(
   stream : Stream,
   format : ImageFormat,
   encoderParams : EncoderParameters
);

Parameters

stream
[To be supplied.]
format
[To be supplied.]
encoderParams
[To be supplied.]

See Also

Image Class | Image Members | System.Drawing Namespace | Image.Save Overload List


Image.Save (Stream, ImageFormat)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Save( _
   ByVal stream As Stream, _
   ByVal format As ImageFormat _
)
[C#]
public void Save(
   Stream stream,
   ImageFormat format
);
[C++]
public: void Save(
   Stream* stream,
   ImageFormat* format
);
[JScript]
public function Save(
   stream : Stream,
   format : ImageFormat
);

Parameters

stream
[To be supplied.]
format
[To be supplied.]

See Also

Image Class | Image Members | System.Drawing Namespace | Image.Save Overload List


Image.Save (String, ImageFormat, EncoderParameters)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Save( _
   ByVal filename As String, _
   ByVal format As ImageFormat, _
   ByVal encoderParams As EncoderParameters _
)
[C#]
public void Save(
   string filename,
   ImageFormat format,
   EncoderParameters encoderParams
);
[C++]
public: void Save(
   String* filename,
   ImageFormat* format,
   EncoderParameters* encoderParams
);
[JScript]
public function Save(
   filename : String,
   format : ImageFormat,
   encoderParams : EncoderParameters
);

Parameters

filename
[To be supplied.]
format
[To be supplied.]
encoderParams
[To be supplied.]

See Also

Image Class | Image Members | System.Drawing Namespace | Image.Save Overload List


Image.SaveAdd

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub SaveAdd(Image, EncoderParameters)
[C#] public void SaveAdd(Image, EncoderParameters);
[C++] public: void SaveAdd(Image*, EncoderParameters);
[JScript] public function SaveAdd(Image, EncoderParameters);

[To be supplied.]

[Visual Basic] Overloads Public Sub SaveAdd(EncoderParameters)
[C#] public void SaveAdd(EncoderParameters);
[C++] public: void SaveAdd(EncoderParameters*);
[JScript] public function SaveAdd(EncoderParameters);

See Also

Image Class | Image Members | System.Drawing Namespace


Image.SaveAdd (Image, EncoderParameters)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SaveAdd( _
   ByVal image As Image, _
   ByVal encoderParams As EncoderParameters _
)
[C#]
public void SaveAdd(
   Image image,
   EncoderParameters encoderParams
);
[C++]
public: void SaveAdd(
   Image* image,
   EncoderParameters* encoderParams
);
[JScript]
public function SaveAdd(
   image : Image,
   encoderParams : EncoderParameters
);

Parameters

image
[To be supplied.]
encoderParams
[To be supplied.]

See Also

Image Class | Image Members | System.Drawing Namespace | Image.SaveAdd Overload List


Image.SaveAdd (EncoderParameters)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SaveAdd( _
   ByVal encoderParams As EncoderParameters _
)
[C#]
public void SaveAdd(
   EncoderParameters encoderParams
);
[C++]
public: void SaveAdd(
   EncoderParameters* encoderParams
);
[JScript]
public function SaveAdd(
   encoderParams : EncoderParameters
);

Parameters

encoderParams
[To be supplied.]

See Also

Image Class | Image Members | System.Drawing Namespace | Image.SaveAdd Overload List


Image.SelectActiveFrame

[To be supplied.]

[Visual Basic]
Public Function SelectActiveFrame( _
   ByVal dimensionID As Guid, _
   ByVal frameIndex As Integer _
) As Integer
[C#]
public int SelectActiveFrame(
   Guid dimensionID,
   int frameIndex
);
[C++]
public: int SelectActiveFrame(
   Guid dimensionID,
   int frameIndex
);
[JScript]
public function SelectActiveFrame(
   dimensionID : Guid,
   frameIndex : int
) : int;

Parameters

dimensionID
[To be supplied.]
frameIndex
[To be supplied.]

See Also

Image Class | Image Members | System.Drawing Namespace


Image.SetPropertyItem

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub SetPropertyItem(PropertyItem)
[C#] public void SetPropertyItem(PropertyItem);
[C++] public: void SetPropertyItem(PropertyItem*);
[JScript] public function SetPropertyItem(PropertyItem);

[To be supplied.]

[Visual Basic] Overloads Public Sub SetPropertyItem(Integer, PropertyItem)
[C#] public void SetPropertyItem(int, PropertyItem);
[C++] public: void SetPropertyItem(int, PropertyItem);
[JScript] public function SetPropertyItem(int, PropertyItem);

See Also

Image Class | Image Members | System.Drawing Namespace


Image.SetPropertyItem (PropertyItem)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetPropertyItem( _
   ByVal propitem As PropertyItem _
)
[C#]
public void SetPropertyItem(
   PropertyItem propitem
);
[C++]
public: void SetPropertyItem(
   PropertyItem* propitem
);
[JScript]
public function SetPropertyItem(
   propitem : PropertyItem
);

Parameters

propitem
[To be supplied.]

See Also

Image Class | Image Members | System.Drawing Namespace | Image.SetPropertyItem Overload List


Image.SetPropertyItem (Int32, PropertyItem)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetPropertyItem( _
   ByVal propid As Integer, _
   ByVal propitem As PropertyItem _
)
[C#]
public void SetPropertyItem(
   int propid,
   PropertyItem propitem
);
[C++]
public: void SetPropertyItem(
   int propid,
   PropertyItem* propitem
);
[JScript]
public function SetPropertyItem(
   propid : int,
   propitem : PropertyItem
);

Parameters

propid
[To be supplied.]
propitem
[To be supplied.]

See Also

Image Class | Image Members | System.Drawing Namespace | Image.SetPropertyItem Overload List


Image.GetThumbnailImageAbort Delegate

[To be supplied.]

[Visual Basic]
Public Delegate Sub Image.GetThumbnailImageAbort() As Boolean
[C#]
public delegate bool Image.GetThumbnailImageAbort();
[C++]
public __gc __delegate bool Image.GetThumbnailImageAbort();

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the Image.GetThumbnailImageAbort delegate declaration.

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

System.Drawing Namespace


ImageAnimator Class

[To be supplied.]

Object
ImageAnimator

[Visual Basic]
Public Class ImageAnimator
[C#]
public class ImageAnimator
[C++]
public __gc class ImageAnimator
[JScript]
public class ImageAnimator

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

ImageAnimator Members | System.Drawing Namespace


ImageAnimator Members

Public:

Methods

Animate | Adds an image to the image manager.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
StopAnimate | Removes an image from the image manager.
ThreadProc | The main animation loop.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ImageAnimator Class | System.Drawing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ImageAnimator Methods

The methods of the ImageAnimator class are listed below. For a complete list of ImageAnimator class members, see the ImageAnimator Members topic.

Public:

Animate | Adds an image to the image manager.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
StopAnimate | Removes an image from the image manager.
ThreadProc | The main animation loop.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ImageAnimator Class | System.Drawing Namespace


ImageAnimator.Animate

Adds an image to the image manager.

[Visual Basic]
Public Shared Sub Animate( _
   ByVal image As Image, _
   ByVal onFrameChangedHandler As EventHandler _
)
[C#]
public static void Animate(
   Image image,
   EventHandler onFrameChangedHandler
);
[C++]
public: static void Animate(
   Image* image,
   EventHandler* onFrameChangedHandler
);
[JScript]
public static function Animate(
   image : Image,
   onFrameChangedHandler : EventHandler
);

Parameters

image
[To be supplied.]
onFrameChangedHandler
[To be supplied.]

See Also

ImageAnimator Class | ImageAnimator Members | System.Drawing Namespace


ImageAnimator.StopAnimate

Removes an image from the image manager.

[Visual Basic]
Public Shared Sub StopAnimate( _
   ByVal image As Image, _
   ByVal onFrameChangedHandler As EventHandler _
)
[C#]
public static void StopAnimate(
   Image image,
   EventHandler onFrameChangedHandler
);
[C++]
public: static void StopAnimate(
   Image* image,
   EventHandler* onFrameChangedHandler
);
[JScript]
public static function StopAnimate(
   image : Image,
   onFrameChangedHandler : EventHandler
);

Parameters

image
[To be supplied.]
onFrameChangedHandler
[To be supplied.]

See Also

ImageAnimator Class | ImageAnimator Members | System.Drawing Namespace


ImageAnimator.ThreadProc

The main animation loop.

[Visual Basic]
Public Shared Sub ThreadProc()
[C#]
public static void ThreadProc();
[C++]
public: static void ThreadProc();
[JScript]
public static function ThreadProc();

See Also

ImageAnimator Class | ImageAnimator Members | System.Drawing Namespace


ImageConverter Class

ImageConverter is a class that can be used to convert Image from one data type to another. Access this class through the TypeDescriptor.

Object
TypeConverter
ImageConverter

[Visual Basic]
Public Class ImageConverter
   Inherits TypeConverter
[C#]
public class ImageConverter : TypeConverter
[C++]
public __gc class ImageConverter : public TypeConverter
[JScript]
public class ImageConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

ImageConverter Members | System.Drawing Namespace


ImageConverter Members

Public:

Constructor

ImageConverter Constructor [To be supplied.]

Methods

CanConvertFrom (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the converter's native type.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text into an object.
ConvertTo | Overloaded. [To be supplied.]
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetProperties (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValues (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid (inherited from TypeConverter) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

ImageConverter Class | System.Drawing Namespace


ImageConverter Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ImageConverter();
[C++]
public: ImageConverter();
[JScript]
public function ImageConverter();

See Also

ImageConverter Class | ImageConverter Members | System.Drawing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ImageConverter Methods

The methods of the ImageConverter class are listed below. For a complete list of ImageConverter class members, see the ImageConverter Members topic.

Public:

CanConvertFrom (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the converter's native type.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text into an object.
ConvertTo | Overloaded. [To be supplied.]
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetProperties (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValues (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid (inherited from TypeConverter) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

ImageConverter Class | System.Drawing Namespace


ImageConverter.ConvertTo

Converts the given object to another type. The most common types to convert are to and from a string object. The default implementation will make a call to ToString on the object if the object is valid and if the destination type is string. If this cannot convert to the desitnation type, this will throw a NotSupportedException.

[Visual Basic]
Overrides Public Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal destinationType As Type, _
   ByVal arguments() As Object _
) As Object
[C#]
public override object ConvertTo(
   ITypeDescriptorContext context,
   object value,
   Type destinationType,
   object[] arguments
);
[C++]
public: override Object* ConvertTo(
   ITypeDescriptorContext* context,
   Object* value,
   Type* destinationType,
   Object* arguments[]
);
[JScript]
public override function ConvertTo(
   context : ITypeDescriptorContext,
   value : Object,
   destinationType : Type,
   arguments : Object[]
) : Object;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
value
The object to convert.
destinationType
The type to convert the object to.
arguments
An optional array of arguments to use when doing the conversion. The number and content of these arguments is dependent on the implementer of the value formatter.

Return Value

The converted object.

See Also

ImageConverter Class | ImageConverter Members | System.Drawing Namespace


ImageConverter.GetProperties

Retrieves the set of properties for this type. By default, a type has does not return any properties. An easy implementation of this method can just call TypeDescriptor.GetProperties for the correct data type.

[Visual Basic]
Overrides Public Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal attributes() As MemberAttribute _
) As PropertyDescriptorCollection
[C#]
public override PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value,
   MemberAttribute[] attributes
);
[C++]
public: override PropertyDescriptorCollection* GetProperties(
   ITypeDescriptorContext* context,
   Object* value,
   MemberAttribute* attributes[]
);
[JScript]
public override function GetProperties(
   context : ITypeDescriptorContext,
   value : Object,
   attributes : MemberAttribute[]
) : PropertyDescriptorCollection;

Parameters

context
A type descriptor through which additional context may be provided.
value
The value of the object to get the properties for.
attributes
The value of the object to get the properties for.

Return Value

The set of properties that should be exposed for this data type. If no properties should be exposed, thsi may return null. The default implementation always returns null.

See Also

ImageConverter Class | ImageConverter Members | System.Drawing Namespace


ImageConverter.GetPropertiesSupported

Determines if this object supports properties. By default, this is false.

[Visual Basic]
Overrides Public Function GetPropertiesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
[C#]
public override bool GetPropertiesSupported(
   ITypeDescriptorContext context
);
[C++]
public: override bool GetPropertiesSupported(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetPropertiesSupported(
   context : ITypeDescriptorContext
) : Boolean;

Parameters

context
A type descriptor through which additional context may be provided.

Return Value

Returns true if GetProperties should be called to find the properties of this object.

See Also

ImageConverter Class | ImageConverter Members | System.Drawing Namespace


KnownColor Enumeration

[To be supplied.]

[Visual Basic]
Public Enum KnownColor
[C#]
public enum KnownColor
[C++]
public enum KnownColor

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
ActiveBorder | [To be supplied.]
ActiveCaption | [To be supplied.]
ActiveCaptionText | [To be supplied.]
AliceBlue | [To be supplied.]
AntiqueWhite | [To be supplied.]
AppWorkspace | [To be supplied.]
Aqua | [To be supplied.]
Aquamarine | [To be supplied.]
Azure | [To be supplied.]
Beige | [To be supplied.]
Bisque | [To be supplied.]
Black | [To be supplied.]
BlanchedAlmond | [To be supplied.]
Blue | [To be supplied.]
BlueViolet | [To be supplied.]
Brown | [To be supplied.]
BurlyWood | [To be supplied.]
CadetBlue | [To be supplied.]
Chartreuse | [To be supplied.]
Chocolate | [To be supplied.]
Control | [To be supplied.]
ControlDark | [To be supplied.]
ControlDarkDark | [To be supplied.]
ControlLight | [To be supplied.]
ControlLightLight | [To be supplied.]
ControlText | [To be supplied.]
Coral | [To be supplied.]
Cornflower | [To be supplied.]
Cornsilk | [To be supplied.]
Crimson | [To be supplied.]
Cyan | [To be supplied.]
DarkBlue | [To be supplied.]
DarkCyan | [To be supplied.]
DarkGoldenrod | [To be supplied.]
DarkGray | [To be supplied.]
DarkGreen | [To be supplied.]
DarkKhaki | [To be supplied.]
DarkMagenta | [To be supplied.]
DarkOliveGreen | [To be supplied.]
DarkOrange | [To be supplied.]
DarkOrchid | [To be supplied.]
DarkRed | [To be supplied.]
DarkSalmon | [To be supplied.]
DarkSeaGreen | [To be supplied.]
DarkSlateBlue | [To be supplied.]
DarkSlateGray | [To be supplied.]
DarkTurquoise | [To be supplied.]
DarkViolet | [To be supplied.]
DeepPink | [To be supplied.]
DeepSkyBlue | [To be supplied.]
Desktop | [To be supplied.]
DimGray | [To be supplied.]
DodgerBlue | [To be supplied.]
Firebrick | [To be supplied.]
FloralWhite | [To be supplied.]
ForestGreen | [To be supplied.]
Fuchsia | [To be supplied.]
Gainsboro | [To be supplied.]
GhostWhite | [To be supplied.]
Gold | [To be supplied.]
Goldenrod | [To be supplied.]
Gray | [To be supplied.]
GrayText | [To be supplied.]
Green | [To be supplied.]
GreenYellow | [To be supplied.]
Highlight | [To be supplied.]
HighlightText | [To be supplied.]
Honeydew | [To be supplied.]
HotPink | [To be supplied.]
HotTrack | [To be supplied.]
InactiveBorder | [To be supplied.]
InactiveCaption | [To be supplied.]
InactiveCaptionText | [To be supplied.]
IndianRed | [To be supplied.]
Indigo | [To be supplied.]
Info | [To be supplied.]
InfoText | [To be supplied.]
Ivory | [To be supplied.]
Khaki | [To be supplied.]
Lavender | [To be supplied.]
LavenderBlush | [To be supplied.]
LawnGreen | [To be supplied.]
LemonChiffon | [To be supplied.]
LightBlue | [To be supplied.]
LightCoral | [To be supplied.]
LightCyan | [To be supplied.]
LightGoldenrodYellow | [To be supplied.]
LightGray | [To be supplied.]
LightGreen | [To be supplied.]
LightPink | [To be supplied.]
LightSalmon | [To be supplied.]
LightSeaGreen | [To be supplied.]
LightSkyBlue | [To be supplied.]
LightSlateGray | [To be supplied.]
LightSteelBlue | [To be supplied.]
LightYellow | [To be supplied.]
Lime | [To be supplied.]
LimeGreen | [To be supplied.]
Linen | [To be supplied.]
Magenta | [To be supplied.]
Maroon | [To be supplied.]
MediumAquamarine | [To be supplied.]
MediumBlue | [To be supplied.]
MediumOrchid | [To be supplied.]
MediumPurple | [To be supplied.]
MediumSeaGreen | [To be supplied.]
MediumSlateBlue | [To be supplied.]
MediumSpringGreen | [To be supplied.]
MediumTurquoise | [To be supplied.]
MediumVioletRed | [To be supplied.]
Menu | [To be supplied.]
MenuText | [To be supplied.]
MidnightBlue | [To be supplied.]
MintCream | [To be supplied.]
MistyRose | [To be supplied.]
Moccasin | [To be supplied.]
NavajoWhite | [To be supplied.]
Navy | [To be supplied.]
OldLace | [To be supplied.]
Olive | [To be supplied.]
OliveDrab | [To be supplied.]
Orange | [To be supplied.]
OrangeRed | [To be supplied.]
Orchid | [To be supplied.]
PaleGoldenrod | [To be supplied.]
PaleGreen | [To be supplied.]
PaleTurquoise | [To be supplied.]
PaleVioletRed | [To be supplied.]
PapayaWhip | [To be supplied.]
PeachPuff | [To be supplied.]
Peru | [To be supplied.]
Pink | [To be supplied.]
Plum | [To be supplied.]
PowderBlue | [To be supplied.]
Purple | [To be supplied.]
Red | [To be supplied.]
RosyBrown | [To be supplied.]
RoyalBlue | [To be supplied.]
SaddleBrown | [To be supplied.]
Salmon | [To be supplied.]
SandyBrown | [To be supplied.]
ScrollBar | [To be supplied.]
SeaGreen | [To be supplied.]
SeaShell | [To be supplied.]
Sienna | [To be supplied.]
Silver | [To be supplied.]
SkyBlue | [To be supplied.]
SlateBlue | [To be supplied.]
SlateGray | [To be supplied.]
Snow | [To be supplied.]
SpringGreen | [To be supplied.]
SteelBlue | [To be supplied.]
Tan | [To be supplied.]
Teal | [To be supplied.]
Thistle | [To be supplied.]
Tomato | [To be supplied.]
Transparent | [To be supplied.]
Turquoise | [To be supplied.]
Violet | [To be supplied.]
Wheat | [To be supplied.]
White | [To be supplied.]
WhiteSmoke | [To be supplied.]
Window | [To be supplied.]
WindowFrame | [To be supplied.]
WindowText | [To be supplied.]
Yellow | [To be supplied.]
YellowGreen | [To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

System.Drawing Namespace


Pen Class

Defines an object used to draw lines and curves.

Object
MarshalByRefObject
Pen

[Visual Basic]
NotInheritable Public Class Pen
   Inherits MarshalByRefObject
   Implements ISystemColorTracker, ICloneable
[C#]
public sealed class Pen : MarshalByRefObject, ISystemColorTracker,
   ICloneable
[C++]
public __gc __sealed class Pen : public MarshalByRefObject,
   ISystemColorTracker, ICloneable
[JScript]
public class Pen extends MarshalByRefObject, ISystemColorTracker,
   ICloneable

Remarks

A Pen draws a line of specified width and style. Use the DashStyle property to draw several varieties of dashed lines. The line drawn by a Pen can be filled in a variety of fill styles including solid colors and textures. The fill style depends on brush or texture that is used as the fill object.

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

Pen Members | System.Drawing Namespace


Pen Members

Public:

Constructor

Pen Constructor Overloaded. Initializes a new instance of the Pen class.

Properties

Alignment | [To be supplied.]
Brush | [To be supplied.]
Color | [To be supplied.]
CompoundArray | [To be supplied.]
CustomEndCap | [To be supplied.]
CustomStartCap | [To be supplied.]
DashCap | [To be supplied.]
DashOffset | [To be supplied.]
DashPattern | [To be supplied.]
DashStyle | [To be supplied.]
EndCap | [To be supplied.]
LineJoin | [To be supplied.]
MiterLimit | [To be supplied.]
PenType | [To be supplied.]
StartCap | [To be supplied.]
Transform | [To be supplied.]
Width | [To be supplied.]

Methods

Clone | [To be supplied.]
Dispose | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
MultiplyTransform | Overloaded. [To be supplied.]
OnSystemColorChanged | [To be supplied.]
ResetTransform | [To be supplied.]
RotateTransform | Overloaded. [To be supplied.]
ScaleTransform | Overloaded. [To be supplied.]
SetLineCap | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.
TranslateTransform | Overloaded. [To be supplied.]

Fields

BrushFilled | [To be supplied.]
Nominal | [To be supplied.]
Texture | [To be supplied.]

Protected:

Methods

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Pen Class | System.Drawing Namespace


Pen Constructor

Initializes a new instance of the Pen class.

Overload List

Initializes a new instance of the Pen class with the specified coor.

[Visual Basic] Overloads Public Sub New(Color)
[C#] public Pen(Color);
[C++] public: Pen(Color);
[JScript] public function Pen(Color);

Initializes a new instance of the Pen class with the specified Color and Width.

[Visual Basic] Overloads Public Sub New(Color, Single)
[C#] public Pen(Color, float);
[C++] public: Pen(Color, float);
[JScript] public function Pen(Color, float);

Initializes a new instance of the Pen class with the specified Brush.

[Visual Basic] Overloads Public Sub New(Brush)
[C#] public Pen(Brush);
[C++] public: Pen(Brush*);
[JScript] public function Pen(Brush);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Brush, Single)
[C#] public Pen(Brush, float);
[C++] public: Pen(Brush*, float);
[JScript] public function Pen(Brush, float);

See Also

Pen Class | Pen Members | System.Drawing Namespace


Pen Constructor (Color)

Initializes a new instance of the Pen class with the specified coor.

[Visual Basic]
Overloads Public Sub New( _
   ByVal color As Color _
)
[C#]
public Pen(
   Color color
);
[C++]
public: Pen(
   Color color
);
[JScript]
public function Pen(
   color : Color
);

Parameters

color
[To be supplied.]

Remarks

This constructor creates a Pen and initializes data members as follows: Color set to, and Width set to 1.0.

See Also

Pen Class | Pen Members | System.Drawing Namespace | Pen Constructor Overload List


Pen Constructor (Color, Single)

Initializes a new instance of the Pen class with the specified Color and Width.

[Visual Basic]
Overloads Public Sub New( _
   ByVal color As Color, _
   ByVal width As Single _
)
[C#]
public Pen(
   Color color,
   float width
);
[C++]
public: Pen(
   Color color,
   float width
);
[JScript]
public function Pen(
   color : Color,
   width : float
);

Parameters

color
[To be supplied.]
width
[To be supplied.]

Remarks

This constructor creates a Pen and initializes data members as follows: Color set to, and Width set to.

See Also

Pen Class | Pen Members | System.Drawing Namespace | Pen Constructor Overload List


Pen Constructor (Brush)

Initializes a new instance of the Pen class with the specified Brush.

[Visual Basic]
Overloads Public Sub New( _
   ByVal brush As Brush _
)
[C#]
public Pen(
   Brush brush
);
[C++]
public: Pen(
   Brush* brush
);
[JScript]
public function Pen(
   brush : Brush
);

Parameters

brush
[To be supplied.]

Remarks

This constructor creates a Pen and initializes data members as follows: Brush set to, and Width set to 1.0.

See Also

Pen Class | Pen Members | System.Drawing Namespace | Pen Constructor Overload List


Pen Constructor (Brush, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal brush As Brush, _
   ByVal width As Single _
)
[C#]
public Pen(
   Brush brush,
   float width
);
[C++]
public: Pen(
   Brush* brush,
   float width
);
[JScript]
public function Pen(
   brush : Brush,
   width : float
);

Parameters

brush
[To be supplied.]
width
[To be supplied.]

See Also

Pen Class | Pen Members | System.Drawing Namespace | Pen Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Pen Properties

The properties of the Pen class are listed below. For a complete list of Pen class members, see the Pen Members topic.

Public:

Alignment | [To be supplied.]
Brush | [To be supplied.]
Color | [To be supplied.]
CompoundArray | [To be supplied.]
CustomEndCap | [To be supplied.]
CustomStartCap | [To be supplied.]
DashCap | [To be supplied.]
DashOffset | [To be supplied.]
DashPattern | [To be supplied.]
DashStyle | [To be supplied.]
EndCap | [To be supplied.]
LineJoin | [To be supplied.]
MiterLimit | [To be supplied.]
PenType | [To be supplied.]
StartCap | [To be supplied.]
Transform | [To be supplied.]
Width | [To be supplied.]

See Also

Pen Class | System.Drawing Namespace


Pen.Alignment

[To be supplied.]

[Visual Basic]
Public Property Alignment As PenAlignment
[C#]
public PenAlignment Alignment {get; set;}
[C++]
public: __property PenAlignment get_Alignment();
public: __property void set_Alignment(PenAlignment);
[JScript]
public function get Alignment() : PenAlignment;
public function set Alignment(PenAlignment);

See Also

Pen Class | Pen Members | System.Drawing Namespace


Pen.Brush

[To be supplied.]

[Visual Basic]
Public Property Brush As Brush
[C#]
public Brush Brush {get; set;}
[C++]
public: __property Brush* get_Brush();
public: __property void set_Brush(Brush*);
[JScript]
public function get Brush() : Brush;
public function set Brush(Brush);

See Also

Pen Class | Pen Members | System.Drawing Namespace


Pen.Color

[To be supplied.]

[Visual Basic]
Public Property Color As Color
[C#]
public Color Color {get; set;}
[C++]
public: __property Color get_Color();
public: __property void set_Color(Color);
[JScript]
public function get Color() : Color;
public function set Color(Color);

See Also

Pen Class | Pen Members | System.Drawing Namespace


Pen.CompoundArray

[To be supplied.]

[Visual Basic]
Public Property CompoundArray As Single ()
[C#]
public float[] CompoundArray {get; set;}
[C++]
public: __property float* get_CompoundArray();
public: __property void set_CompoundArray(float*[]);
[JScript]
public function get CompoundArray() : float[];
public function set CompoundArray(float[]);

See Also

Pen Class | Pen Members | System.Drawing Namespace


Pen.CustomEndCap

[To be supplied.]

[Visual Basic]
Public Property CustomEndCap As CustomLineCap
[C#]
public CustomLineCap CustomEndCap {get; set;}
[C++]
public: __property CustomLineCap* get_CustomEndCap();
public: __property void set_CustomEndCap(CustomLineCap*);
[JScript]
public function get CustomEndCap() : CustomLineCap;
public function set CustomEndCap(CustomLineCap);

See Also

Pen Class | Pen Members | System.Drawing Namespace


Pen.CustomStartCap

[To be supplied.]

[Visual Basic]
Public Property CustomStartCap As CustomLineCap
[C#]
public CustomLineCap CustomStartCap {get; set;}
[C++]
public: __property CustomLineCap* get_CustomStartCap();
public: __property void set_CustomStartCap(CustomLineCap*);
[JScript]
public function get CustomStartCap() : CustomLineCap;
public function set CustomStartCap(CustomLineCap);

See Also

Pen Class | Pen Members | System.Drawing Namespace


Pen.DashCap

[To be supplied.]

[Visual Basic]
Public Property DashCap As LineCap
[C#]
public LineCap DashCap {get; set;}
[C++]
public: __property LineCap get_DashCap();
public: __property void set_DashCap(LineCap);
[JScript]
public function get DashCap() : LineCap;
public function set DashCap(LineCap);

See Also

Pen Class | Pen Members | System.Drawing Namespace


Pen.DashOffset

[To be supplied.]

[Visual Basic]
Public Property DashOffset As Single
[C#]
public float DashOffset {get; set;}
[C++]
public: __property float get_DashOffset();
public: __property void set_DashOffset(float);
[JScript]
public function get DashOffset() : float;
public function set DashOffset(float);

See Also

Pen Class | Pen Members | System.Drawing Namespace


Pen.DashPattern

[To be supplied.]

[Visual Basic]
Public Property DashPattern As Single ()
[C#]
public float[] DashPattern {get; set;}
[C++]
public: __property float* get_DashPattern();
public: __property void set_DashPattern(float*[]);
[JScript]
public function get DashPattern() : float[];
public function set DashPattern(float[]);

See Also

Pen Class | Pen Members | System.Drawing Namespace


Pen.DashStyle

[To be supplied.]

[Visual Basic]
Public Property DashStyle As DashStyle
[C#]
public DashStyle DashStyle {get; set;}
[C++]
public: __property DashStyle get_DashStyle();
public: __property void set_DashStyle(DashStyle);
[JScript]
public function get DashStyle() : DashStyle;
public function set DashStyle(DashStyle);

See Also

Pen Class | Pen Members | System.Drawing Namespace


Pen.EndCap

[To be supplied.]

[Visual Basic]
Public Property EndCap As LineCap
[C#]
public LineCap EndCap {get; set;}
[C++]
public: __property LineCap get_EndCap();
public: __property void set_EndCap(LineCap);
[JScript]
public function get EndCap() : LineCap;
public function set EndCap(LineCap);

See Also

Pen Class | Pen Members | System.Drawing Namespace


Pen.LineJoin

[To be supplied.]

[Visual Basic]
Public Property LineJoin As LineJoin
[C#]
public LineJoin LineJoin {get; set;}
[C++]
public: __property LineJoin get_LineJoin();
public: __property void set_LineJoin(LineJoin);
[JScript]
public function get LineJoin() : LineJoin;
public function set LineJoin(LineJoin);

See Also

Pen Class | Pen Members | System.Drawing Namespace


Pen.MiterLimit

[To be supplied.]

[Visual Basic]
Public Property MiterLimit As Single
[C#]
public float MiterLimit {get; set;}
[C++]
public: __property float get_MiterLimit();
public: __property void set_MiterLimit(float);
[JScript]
public function get MiterLimit() : float;
public function set MiterLimit(float);

See Also

Pen Class | Pen Members | System.Drawing Namespace


Pen.PenType

[To be supplied.]

[Visual Basic]
Public ReadOnly Property PenType As PenType
[C#]
public PenType PenType {get;}
[C++]
public: __property PenType get_PenType();
[JScript]
public function get PenType() : PenType;

See Also

Pen Class | Pen Members | System.Drawing Namespace


Pen.StartCap

[To be supplied.]

[Visual Basic]
Public Property StartCap As LineCap
[C#]
public LineCap StartCap {get; set;}
[C++]
public: __property LineCap get_StartCap();
public: __property void set_StartCap(LineCap);
[JScript]
public function get StartCap() : LineCap;
public function set StartCap(LineCap);

See Also

Pen Class | Pen Members | System.Drawing Namespace


Pen.Transform

[To be supplied.]

[Visual Basic]
Public Property Transform As Matrix
[C#]
public Matrix Transform {get; set;}
[C++]
public: __property Matrix* get_Transform();
public: __property void set_Transform(Matrix*);
[JScript]
public function get Transform() : Matrix;
public function set Transform(Matrix);

See Also

Pen Class | Pen Members | System.Drawing Namespace


Pen.Width

[To be supplied.]

[Visual Basic]
Public Property Width As Single
[C#]
public float Width {get; set;}
[C++]
public: __property float get_Width();
public: __property void set_Width(float);
[JScript]
public function get Width() : float;
public function set Width(float);

See Also

Pen Class | Pen Members | System.Drawing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Pen Methods

The methods of the Pen class are listed below. For a complete list of Pen class members, see the Pen Members topic.

Public:

Clone | [To be supplied.]
Dispose | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
MultiplyTransform | Overloaded. [To be supplied.]
OnSystemColorChanged | [To be supplied.]
ResetTransform | [To be supplied.]
RotateTransform | Overloaded. [To be supplied.]
ScaleTransform | Overloaded. [To be supplied.]
SetLineCap | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.
TranslateTransform | Overloaded. [To be supplied.]

Protected:

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Pen Class | System.Drawing Namespace


Pen.Clone

[To be supplied.]

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

See Also

Pen Class | Pen Members | System.Drawing Namespace


Pen.Dispose

[To be supplied.]

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[JScript]
public function Dispose();

See Also

Pen Class | Pen Members | System.Drawing Namespace


Pen.Finalize

[To be supplied.]

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

Pen Class | Pen Members | System.Drawing Namespace


Pen.MultiplyTransform

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub MultiplyTransform(Matrix, MatrixOrder)
[C#] public void MultiplyTransform(Matrix, MatrixOrder);
[C++] public: void MultiplyTransform(Matrix*, MatrixOrder);
[JScript] public function MultiplyTransform(Matrix, MatrixOrder);

[To be supplied.]

[Visual Basic] Overloads Public Sub MultiplyTransform(Matrix)
[C#] public void MultiplyTransform(Matrix);
[C++] public: void MultiplyTransform(Matrix*);
[JScript] public function MultiplyTransform(Matrix);

See Also

Pen Class | Pen Members | System.Drawing Namespace


Pen.MultiplyTransform (Matrix, MatrixOrder)

[To be supplied.]

[Visual Basic]
Overloads Public Sub MultiplyTransform( _
   ByVal matrix As Matrix, _
   ByVal order As MatrixOrder _
)
[C#]
public void MultiplyTransform(
   Matrix matrix,
   MatrixOrder order
);
[C++]
public: void MultiplyTransform(
   Matrix* matrix,
   MatrixOrder order
);
[JScript]
public function MultiplyTransform(
   matrix : Matrix,
   order : MatrixOrder
);

Parameters

matrix
[To be supplied.]
order
[To be supplied.]

See Also

Pen Class | Pen Members | System.Drawing Namespace | Pen.MultiplyTransform Overload List


Pen.MultiplyTransform (Matrix)

[To be supplied.]

[Visual Basic]
Overloads Public Sub MultiplyTransform( _
   ByVal matrix As Matrix _
)
[C#]
public void MultiplyTransform(
   Matrix matrix
);
[C++]
public: void MultiplyTransform(
   Matrix* matrix
);
[JScript]
public function MultiplyTransform(
   matrix : Matrix
);

Parameters

matrix
[To be supplied.]

See Also

Pen Class | Pen Members | System.Drawing Namespace | Pen.MultiplyTransform Overload List


Pen.OnSystemColorChanged

[To be supplied.]

[Visual Basic]
Overridable Public Sub OnSystemColorChanged()
[C#]
public virtual void OnSystemColorChanged();
[C++]
public: virtual void OnSystemColorChanged();
[JScript]
public function OnSystemColorChanged();

See Also

Pen Class | Pen Members | System.Drawing Namespace


Pen.ResetTransform

[To be supplied.]

[Visual Basic]
Public Sub ResetTransform()
[C#]
public void ResetTransform();
[C++]
public: void ResetTransform();
[JScript]
public function ResetTransform();

See Also

Pen Class | Pen Members | System.Drawing Namespace


Pen.RotateTransform

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub RotateTransform(Single)
[C#] public void RotateTransform(float);
[C++] public: void RotateTransform(float);
[JScript] public function RotateTransform(float);

[To be supplied.]

[Visual Basic] Overloads Public Sub RotateTransform(Single, MatrixOrder)
[C#] public void RotateTransform(float, MatrixOrder);
[C++] public: void RotateTransform(float, MatrixOrder);
[JScript] public function RotateTransform(float, MatrixOrder);

See Also

Pen Class | Pen Members | System.Drawing Namespace


Pen.RotateTransform (Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub RotateTransform( _
   ByVal angle As Single _
)
[C#]
public void RotateTransform(
   float angle
);
[C++]
public: void RotateTransform(
   float angle
);
[JScript]
public function RotateTransform(
   angle : float
);

Parameters

angle
[To be supplied.]

See Also

Pen Class | Pen Members | System.Drawing Namespace | Pen.RotateTransform Overload List


Pen.RotateTransform (Single, MatrixOrder)

[To be supplied.]

[Visual Basic]
Overloads Public Sub RotateTransform( _
   ByVal angle As Single, _
   ByVal order As MatrixOrder _
)
[C#]
public void RotateTransform(
   float angle,
   MatrixOrder order
);
[C++]
public: void RotateTransform(
   float angle,
   MatrixOrder order
);
[JScript]
public function RotateTransform(
   angle : float,
   order : MatrixOrder
);

Parameters

angle
[To be supplied.]
order
[To be supplied.]

See Also

Pen Class | Pen Members | System.Drawing Namespace | Pen.RotateTransform Overload List


Pen.ScaleTransform

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub ScaleTransform(Single, Single)
[C#] public void ScaleTransform(float, float);
[C++] public: void ScaleTransform(float, float);
[JScript] public function ScaleTransform(float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub ScaleTransform(Single, Single, MatrixOrder)
[C#] public void ScaleTransform(float, float, MatrixOrder);
[C++] public: void ScaleTransform(float, float, MatrixOrder);
[JScript] public function ScaleTransform(float, float, MatrixOrder);

See Also

Pen Class | Pen Members | System.Drawing Namespace


Pen.ScaleTransform (Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub ScaleTransform( _
   ByVal sx As Single, _
   ByVal sy As Single _
)
[C#]
public void ScaleTransform(
   float sx,
   float sy
);
[C++]
public: void ScaleTransform(
   float sx,
   float sy
);
[JScript]
public function ScaleTransform(
   sx : float,
   sy : float
);

Parameters

sx
[To be supplied.]
sy
[To be supplied.]

See Also

Pen Class | Pen Members | System.Drawing Namespace | Pen.ScaleTransform Overload List


Pen.ScaleTransform (Single, Single, MatrixOrder)

[To be supplied.]

[Visual Basic]
Overloads Public Sub ScaleTransform( _
   ByVal sx As Single, _
   ByVal sy As Single, _
   ByVal order As MatrixOrder _
)
[C#]
public void ScaleTransform(
   float sx,
   float sy,
   MatrixOrder order
);
[C++]
public: void ScaleTransform(
   float sx,
   float sy,
   MatrixOrder order
);
[JScript]
public function ScaleTransform(
   sx : float,
   sy : float,
   order : MatrixOrder
);

Parameters

sx
[To be supplied.]
sy
[To be supplied.]
order
[To be supplied.]

See Also

Pen Class | Pen Members | System.Drawing Namespace | Pen.ScaleTransform Overload List


Pen.SetLineCap

[To be supplied.]

[Visual Basic]
Public Sub SetLineCap( _
   ByVal startCap As LineCap, _
   ByVal endCap As LineCap, _
   ByVal dashCap As LineCap _
)
[C#]
public void SetLineCap(
   LineCap startCap,
   LineCap endCap,
   LineCap dashCap
);
[C++]
public: void SetLineCap(
   LineCap startCap,
   LineCap endCap,
   LineCap dashCap
);
[JScript]
public function SetLineCap(
   startCap : LineCap,
   endCap : LineCap,
   dashCap : LineCap
);

Parameters

startCap
[To be supplied.]
endCap
[To be supplied.]
dashCap
[To be supplied.]

See Also

Pen Class | Pen Members | System.Drawing Namespace


Pen.TranslateTransform

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub TranslateTransform(Single, Single)
[C#] public void TranslateTransform(float, float);
[C++] public: void TranslateTransform(float, float);
[JScript] public function TranslateTransform(float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub TranslateTransform(Single, Single, MatrixOrder)
[C#] public void TranslateTransform(float, float, MatrixOrder);
[C++] public: void TranslateTransform(float, float, MatrixOrder);
[JScript] public function TranslateTransform(float, float, MatrixOrder);

See Also

Pen Class | Pen Members | System.Drawing Namespace


Pen.TranslateTransform (Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub TranslateTransform( _
   ByVal dx As Single, _
   ByVal dy As Single _
)
[C#]
public void TranslateTransform(
   float dx,
   float dy
);
[C++]
public: void TranslateTransform(
   float dx,
   float dy
);
[JScript]
public function TranslateTransform(
   dx : float,
   dy : float
);

Parameters

dx
[To be supplied.]
dy
[To be supplied.]

See Also

Pen Class | Pen Members | System.Drawing Namespace | Pen.TranslateTransform Overload List


Pen.TranslateTransform (Single, Single, MatrixOrder)

[To be supplied.]

[Visual Basic]
Overloads Public Sub TranslateTransform( _
   ByVal dx As Single, _
   ByVal dy As Single, _
   ByVal order As MatrixOrder _
)
[C#]
public void TranslateTransform(
   float dx,
   float dy,
   MatrixOrder order
);
[C++]
public: void TranslateTransform(
   float dx,
   float dy,
   MatrixOrder order
);
[JScript]
public function TranslateTransform(
   dx : float,
   dy : float,
   order : MatrixOrder
);

Parameters

dx
[To be supplied.]
dy
[To be supplied.]
order
[To be supplied.]

See Also

Pen Class | Pen Members | System.Drawing Namespace | Pen.TranslateTransform Overload List


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Pen Fields

The fields of the Pen class are listed below. For a complete list of Pen class members, see the Pen Members topic.

Public:

BrushFilled | [To be supplied.]
Nominal | [To be supplied.]
Texture | [To be supplied.]

See Also

Pen Class | System.Drawing Namespace


Pen.BrushFilled

[To be supplied.]

[Visual Basic]
Public Const BrushFilled As Integer
[C#]
public const int BrushFilled;
[C++]
public: const int BrushFilled;
[JScript]
public var BrushFilled : int;

See Also

Pen Class | Pen Members | System.Drawing Namespace


Pen.Nominal

[To be supplied.]

[Visual Basic]
Public Const Nominal As Integer
[C#]
public const int Nominal;
[C++]
public: const int Nominal;
[JScript]
public var Nominal : int;

See Also

Pen Class | Pen Members | System.Drawing Namespace


Pen.Texture

[To be supplied.]

[Visual Basic]
Public Const Texture As Integer
[C#]
public const int Texture;
[C++]
public: const int Texture;
[JScript]
public var Texture : int;

See Also

Pen Class | Pen Members | System.Drawing Namespace


Pens Class

Pens for all the standard colors.

Object
Pens

[Visual Basic]
NotInheritable Public Class Pens
[C#]
public sealed class Pens
[C++]
public __gc __sealed class Pens
[JScript]
public class Pens

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

Pens Members | System.Drawing Namespace | Color | Pen | SystemPens


Pens Members

Public:

Properties

AliceBlue | [To be supplied.]
AntiqueWhite | [To be supplied.]
Aqua | [To be supplied.]
Aquamarine | [To be supplied.]
Azure | [To be supplied.]
Beige | [To be supplied.]
Bisque | [To be supplied.]
Black | [To be supplied.]
BlanchedAlmond | [To be supplied.]
Blue | [To be supplied.]
BlueViolet | [To be supplied.]
Brown | [To be supplied.]
BurlyWood | [To be supplied.]
CadetBlue | [To be supplied.]
Chartreuse | [To be supplied.]
Chocolate | [To be supplied.]
Coral | [To be supplied.]
Cornflower | [To be supplied.]
Cornsilk | [To be supplied.]
Crimson | [To be supplied.]
Cyan | [To be supplied.]
DarkBlue | [To be supplied.]
DarkCyan | [To be supplied.]
DarkGoldenrod | [To be supplied.]
DarkGray | [To be supplied.]
DarkGreen | [To be supplied.]
DarkKhaki | [To be supplied.]
DarkMagenta | [To be supplied.]
DarkOliveGreen | [To be supplied.]
DarkOrange | [To be supplied.]
DarkOrchid | [To be supplied.]
DarkRed | [To be supplied.]
DarkSalmon | [To be supplied.]
DarkSeaGreen | [To be supplied.]
DarkSlateBlue | [To be supplied.]
DarkSlateGray | [To be supplied.]
DarkTurquoise | [To be supplied.]
DarkViolet | [To be supplied.]
DeepPink | [To be supplied.]
DeepSkyBlue | [To be supplied.]
DimGray | [To be supplied.]
DodgerBlue | [To be supplied.]
Firebrick | [To be supplied.]
FloralWhite | [To be supplied.]
ForestGreen | [To be supplied.]
Fuchsia | [To be supplied.]
Gainsboro | [To be supplied.]
GhostWhite | [To be supplied.]
Gold | [To be supplied.]
Goldenrod | [To be supplied.]
Gray | [To be supplied.]
Green | [To be supplied.]
GreenYellow | [To be supplied.]
Honeydew | [To be supplied.]
HotPink | [To be supplied.]
IndianRed | [To be supplied.]
Indigo | [To be supplied.]
Ivory | [To be supplied.]
Khaki | [To be supplied.]
Lavender | [To be supplied.]
LavenderBlush | [To be supplied.]
LawnGreen | [To be supplied.]
LemonChiffon | [To be supplied.]
LightBlue | [To be supplied.]
LightCoral | [To be supplied.]
LightCyan | [To be supplied.]
LightGoldenrodYellow | [To be supplied.]
LightGray | [To be supplied.]
LightGreen | [To be supplied.]
LightPink | [To be supplied.]
LightSalmon | [To be supplied.]
LightSeaGreen | [To be supplied.]
LightSkyBlue | [To be supplied.]
LightSlateGray | [To be supplied.]
LightSteelBlue | [To be supplied.]
LightYellow | [To be supplied.]
Lime | [To be supplied.]
LimeGreen | [To be supplied.]
Linen | [To be supplied.]
Magenta | [To be supplied.]
Maroon | [To be supplied.]
MediumAquamarine | [To be supplied.]
MediumBlue | [To be supplied.]
MediumOrchid | [To be supplied.]
MediumPurple | [To be supplied.]
MediumSeaGreen | [To be supplied.]
MediumSlateBlue | [To be supplied.]
MediumSpringGreen | [To be supplied.]
MediumTurquoise | [To be supplied.]
MediumVioletRed | [To be supplied.]
MidnightBlue | [To be supplied.]
MintCream | [To be supplied.]
MistyRose | [To be supplied.]
Moccasin | [To be supplied.]
NavajoWhite | [To be supplied.]
Navy | [To be supplied.]
OldLace | [To be supplied.]
Olive | [To be supplied.]
OliveDrab | [To be supplied.]
Orange | [To be supplied.]
OrangeRed | [To be supplied.]
Orchid | [To be supplied.]
PaleGoldenrod | [To be supplied.]
PaleGreen | [To be supplied.]
PaleTurquoise | [To be supplied.]
PaleVioletRed | [To be supplied.]
PapayaWhip | [To be supplied.]
PeachPuff | [To be supplied.]
Peru | [To be supplied.]
Pink | [To be supplied.]
Plum | [To be supplied.]
PowderBlue | [To be supplied.]
Purple | [To be supplied.]
Red | [To be supplied.]
RosyBrown | [To be supplied.]
RoyalBlue | [To be supplied.]
SaddleBrown | [To be supplied.]
Salmon | [To be supplied.]
SandyBrown | [To be supplied.]
SeaGreen | [To be supplied.]
SeaShell | [To be supplied.]
Sienna | [To be supplied.]
Silver | [To be supplied.]
SkyBlue | [To be supplied.]
SlateBlue | [To be supplied.]
SlateGray | [To be supplied.]
Snow | [To be supplied.]
SpringGreen | [To be supplied.]
SteelBlue | [To be supplied.]
Tan | [To be supplied.]
Teal | [To be supplied.]
Thistle | [To be supplied.]
Tomato | [To be supplied.]
Transparent | [To be supplied.]
Turquoise | [To be supplied.]
Violet | [To be supplied.]
Wheat | [To be supplied.]
White | [To be supplied.]
WhiteSmoke | [To be supplied.]
Yellow | [To be supplied.]
YellowGreen | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Pens Class | System.Drawing Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Pens Properties

The properties of the Pens class are listed below. For a complete list of Pens class members, see the Pens Members topic.

Public:

AliceBlue | [To be supplied.]
AntiqueWhite | [To be supplied.]
Aqua | [To be supplied.]
Aquamarine | [To be supplied.]
Azure | [To be supplied.]
Beige | [To be supplied.]
Bisque | [To be supplied.]
Black | [To be supplied.]
BlanchedAlmond | [To be supplied.]
Blue | [To be supplied.]
BlueViolet | [To be supplied.]
Brown | [To be supplied.]
BurlyWood | [To be supplied.]
CadetBlue | [To be supplied.]
Chartreuse | [To be supplied.]
Chocolate | [To be supplied.]
Coral | [To be supplied.]
Cornflower | [To be supplied.]
Cornsilk | [To be supplied.]
Crimson | [To be supplied.]
Cyan | [To be supplied.]
DarkBlue | [To be supplied.]
DarkCyan | [To be supplied.]
DarkGoldenrod | [To be supplied.]
DarkGray | [To be supplied.]
DarkGreen | [To be supplied.]
DarkKhaki | [To be supplied.]
DarkMagenta | [To be supplied.]
DarkOliveGreen | [To be supplied.]
DarkOrange | [To be supplied.]
DarkOrchid | [To be supplied.]
DarkRed | [To be supplied.]
DarkSalmon | [To be supplied.]
DarkSeaGreen | [To be supplied.]
DarkSlateBlue | [To be supplied.]
DarkSlateGray | [To be supplied.]
DarkTurquoise | [To be supplied.]
DarkViolet | [To be supplied.]
DeepPink | [To be supplied.]
DeepSkyBlue | [To be supplied.]
DimGray | [To be supplied.]
DodgerBlue | [To be supplied.]
Firebrick | [To be supplied.]
FloralWhite | [To be supplied.]
ForestGreen | [To be supplied.]
Fuchsia | [To be supplied.]
Gainsboro | [To be supplied.]
GhostWhite | [To be supplied.]
Gold | [To be supplied.]
Goldenrod | [To be supplied.]
Gray | [To be supplied.]
Green | [To be supplied.]
GreenYellow | [To be supplied.]
Honeydew | [To be supplied.]
HotPink | [To be supplied.]
IndianRed | [To be supplied.]
Indigo | [To be supplied.]
Ivory | [To be supplied.]
Khaki | [To be supplied.]
Lavender | [To be supplied.]
LavenderBlush | [To be supplied.]
LawnGreen | [To be supplied.]
LemonChiffon | [To be supplied.]
LightBlue | [To be supplied.]
LightCoral | [To be supplied.]
LightCyan | [To be supplied.]
LightGoldenrodYellow | [To be supplied.]
LightGray | [To be supplied.]
LightGreen | [To be supplied.]
LightPink | [To be supplied.]
LightSalmon | [To be supplied.]
LightSeaGreen | [To be supplied.]
LightSkyBlue | [To be supplied.]
LightSlateGray | [To be supplied.]
LightSteelBlue | [To be supplied.]
LightYellow | [To be supplied.]
Lime | [To be supplied.]
LimeGreen | [To be supplied.]
Linen | [To be supplied.]
Magenta | [To be supplied.]
Maroon | [To be supplied.]
MediumAquamarine | [To be supplied.]
MediumBlue | [To be supplied.]
MediumOrchid | [To be supplied.]
MediumPurple | [To be supplied.]
MediumSeaGreen | [To be supplied.]
MediumSlateBlue | [To be supplied.]
MediumSpringGreen | [To be supplied.]
MediumTurquoise | [To be supplied.]
MediumVioletRed | [To be supplied.]
MidnightBlue | [To be supplied.]
MintCream | [To be supplied.]
MistyRose | [To be supplied.]
Moccasin | [To be supplied.]
NavajoWhite | [To be supplied.]
Navy | [To be supplied.]
OldLace | [To be supplied.]
Olive | [To be supplied.]
OliveDrab | [To be supplied.]
Orange | [To be supplied.]
OrangeRed | [To be supplied.]
Orchid | [To be supplied.]
PaleGoldenrod | [To be supplied.]
PaleGreen | [To be supplied.]
PaleTurquoise | [To be supplied.]
PaleVioletRed | [To be supplied.]
PapayaWhip | [To be supplied.]
PeachPuff | [To be supplied.]
Peru | [To be supplied.]
Pink | [To be supplied.]
Plum | [To be supplied.]
PowderBlue | [To be supplied.]
Purple | [To be supplied.]
Red | [To be supplied.]
RosyBrown | [To be supplied.]
RoyalBlue | [To be supplied.]
SaddleBrown | [To be supplied.]
Salmon | [To be supplied.]
SandyBrown | [To be supplied.]
SeaGreen | [To be supplied.]
SeaShell | [To be supplied.]
Sienna | [To be supplied.]
Silver | [To be supplied.]
SkyBlue | [To be supplied.]
SlateBlue | [To be supplied.]
SlateGray | [To be supplied.]
Snow | [To be supplied.]
SpringGreen | [To be supplied.]
SteelBlue | [To be supplied.]
Tan | [To be supplied.]
Teal | [To be supplied.]
Thistle | [To be supplied.]
Tomato | [To be supplied.]
Transparent | [To be supplied.]
Turquoise | [To be supplied.]
Violet | [To be supplied.]
Wheat | [To be supplied.]
White | [To be supplied.]
WhiteSmoke | [To be supplied.]
Yellow | [To be supplied.]
YellowGreen | [To be supplied.]

See Also

Pens Class | System.Drawing Namespace


Pens.AliceBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property AliceBlue As Pen
[C#]
public static Pen AliceBlue {get;}
[C++]
public: __property static Pen* get_AliceBlue();
[JScript]
public static function get AliceBlue() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.AntiqueWhite

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property AntiqueWhite As Pen
[C#]
public static Pen AntiqueWhite {get;}
[C++]
public: __property static Pen* get_AntiqueWhite();
[JScript]
public static function get AntiqueWhite() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Aqua

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Aqua As Pen
[C#]
public static Pen Aqua {get;}
[C++]
public: __property static Pen* get_Aqua();
[JScript]
public static function get Aqua() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Aquamarine

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Aquamarine As Pen
[C#]
public static Pen Aquamarine {get;}
[C++]
public: __property static Pen* get_Aquamarine();
[JScript]
public static function get Aquamarine() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Azure

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Azure As Pen
[C#]
public static Pen Azure {get;}
[C++]
public: __property static Pen* get_Azure();
[JScript]
public static function get Azure() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Beige

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Beige As Pen
[C#]
public static Pen Beige {get;}
[C++]
public: __property static Pen* get_Beige();
[JScript]
public static function get Beige() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Bisque

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Bisque As Pen
[C#]
public static Pen Bisque {get;}
[C++]
public: __property static Pen* get_Bisque();
[JScript]
public static function get Bisque() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Black

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Black As Pen
[C#]
public static Pen Black {get;}
[C++]
public: __property static Pen* get_Black();
[JScript]
public static function get Black() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.BlanchedAlmond

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property BlanchedAlmond As Pen
[C#]
public static Pen BlanchedAlmond {get;}
[C++]
public: __property static Pen* get_BlanchedAlmond();
[JScript]
public static function get BlanchedAlmond() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Blue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Blue As Pen
[C#]
public static Pen Blue {get;}
[C++]
public: __property static Pen* get_Blue();
[JScript]
public static function get Blue() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.BlueViolet

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property BlueViolet As Pen
[C#]
public static Pen BlueViolet {get;}
[C++]
public: __property static Pen* get_BlueViolet();
[JScript]
public static function get BlueViolet() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Brown

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Brown As Pen
[C#]
public static Pen Brown {get;}
[C++]
public: __property static Pen* get_Brown();
[JScript]
public static function get Brown() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.BurlyWood

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property BurlyWood As Pen
[C#]
public static Pen BurlyWood {get;}
[C++]
public: __property static Pen* get_BurlyWood();
[JScript]
public static function get BurlyWood() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.CadetBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property CadetBlue As Pen
[C#]
public static Pen CadetBlue {get;}
[C++]
public: __property static Pen* get_CadetBlue();
[JScript]
public static function get CadetBlue() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Chartreuse

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Chartreuse As Pen
[C#]
public static Pen Chartreuse {get;}
[C++]
public: __property static Pen* get_Chartreuse();
[JScript]
public static function get Chartreuse() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Chocolate

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Chocolate As Pen
[C#]
public static Pen Chocolate {get;}
[C++]
public: __property static Pen* get_Chocolate();
[JScript]
public static function get Chocolate() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Coral

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Coral As Pen
[C#]
public static Pen Coral {get;}
[C++]
public: __property static Pen* get_Coral();
[JScript]
public static function get Coral() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Cornflower

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Cornflower As Pen
[C#]
public static Pen Cornflower {get;}
[C++]
public: __property static Pen* get_Cornflower();
[JScript]
public static function get Cornflower() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Cornsilk

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Cornsilk As Pen
[C#]
public static Pen Cornsilk {get;}
[C++]
public: __property static Pen* get_Cornsilk();
[JScript]
public static function get Cornsilk() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Crimson

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Crimson As Pen
[C#]
public static Pen Crimson {get;}
[C++]
public: __property static Pen* get_Crimson();
[JScript]
public static function get Crimson() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Cyan

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Cyan As Pen
[C#]
public static Pen Cyan {get;}
[C++]
public: __property static Pen* get_Cyan();
[JScript]
public static function get Cyan() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.DarkBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkBlue As Pen
[C#]
public static Pen DarkBlue {get;}
[C++]
public: __property static Pen* get_DarkBlue();
[JScript]
public static function get DarkBlue() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.DarkCyan

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkCyan As Pen
[C#]
public static Pen DarkCyan {get;}
[C++]
public: __property static Pen* get_DarkCyan();
[JScript]
public static function get DarkCyan() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.DarkGoldenrod

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkGoldenrod As Pen
[C#]
public static Pen DarkGoldenrod {get;}
[C++]
public: __property static Pen* get_DarkGoldenrod();
[JScript]
public static function get DarkGoldenrod() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.DarkGray

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkGray As Pen
[C#]
public static Pen DarkGray {get;}
[C++]
public: __property static Pen* get_DarkGray();
[JScript]
public static function get DarkGray() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.DarkGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkGreen As Pen
[C#]
public static Pen DarkGreen {get;}
[C++]
public: __property static Pen* get_DarkGreen();
[JScript]
public static function get DarkGreen() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.DarkKhaki

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkKhaki As Pen
[C#]
public static Pen DarkKhaki {get;}
[C++]
public: __property static Pen* get_DarkKhaki();
[JScript]
public static function get DarkKhaki() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.DarkMagenta

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkMagenta As Pen
[C#]
public static Pen DarkMagenta {get;}
[C++]
public: __property static Pen* get_DarkMagenta();
[JScript]
public static function get DarkMagenta() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.DarkOliveGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkOliveGreen As Pen
[C#]
public static Pen DarkOliveGreen {get;}
[C++]
public: __property static Pen* get_DarkOliveGreen();
[JScript]
public static function get DarkOliveGreen() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.DarkOrange

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkOrange As Pen
[C#]
public static Pen DarkOrange {get;}
[C++]
public: __property static Pen* get_DarkOrange();
[JScript]
public static function get DarkOrange() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.DarkOrchid

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkOrchid As Pen
[C#]
public static Pen DarkOrchid {get;}
[C++]
public: __property static Pen* get_DarkOrchid();
[JScript]
public static function get DarkOrchid() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.DarkRed

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkRed As Pen
[C#]
public static Pen DarkRed {get;}
[C++]
public: __property static Pen* get_DarkRed();
[JScript]
public static function get DarkRed() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.DarkSalmon

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkSalmon As Pen
[C#]
public static Pen DarkSalmon {get;}
[C++]
public: __property static Pen* get_DarkSalmon();
[JScript]
public static function get DarkSalmon() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.DarkSeaGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkSeaGreen As Pen
[C#]
public static Pen DarkSeaGreen {get;}
[C++]
public: __property static Pen* get_DarkSeaGreen();
[JScript]
public static function get DarkSeaGreen() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.DarkSlateBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkSlateBlue As Pen
[C#]
public static Pen DarkSlateBlue {get;}
[C++]
public: __property static Pen* get_DarkSlateBlue();
[JScript]
public static function get DarkSlateBlue() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.DarkSlateGray

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkSlateGray As Pen
[C#]
public static Pen DarkSlateGray {get;}
[C++]
public: __property static Pen* get_DarkSlateGray();
[JScript]
public static function get DarkSlateGray() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.DarkTurquoise

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkTurquoise As Pen
[C#]
public static Pen DarkTurquoise {get;}
[C++]
public: __property static Pen* get_DarkTurquoise();
[JScript]
public static function get DarkTurquoise() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.DarkViolet

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DarkViolet As Pen
[C#]
public static Pen DarkViolet {get;}
[C++]
public: __property static Pen* get_DarkViolet();
[JScript]
public static function get DarkViolet() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.DeepPink

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DeepPink As Pen
[C#]
public static Pen DeepPink {get;}
[C++]
public: __property static Pen* get_DeepPink();
[JScript]
public static function get DeepPink() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.DeepSkyBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DeepSkyBlue As Pen
[C#]
public static Pen DeepSkyBlue {get;}
[C++]
public: __property static Pen* get_DeepSkyBlue();
[JScript]
public static function get DeepSkyBlue() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.DimGray

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DimGray As Pen
[C#]
public static Pen DimGray {get;}
[C++]
public: __property static Pen* get_DimGray();
[JScript]
public static function get DimGray() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.DodgerBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property DodgerBlue As Pen
[C#]
public static Pen DodgerBlue {get;}
[C++]
public: __property static Pen* get_DodgerBlue();
[JScript]
public static function get DodgerBlue() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Firebrick

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Firebrick As Pen
[C#]
public static Pen Firebrick {get;}
[C++]
public: __property static Pen* get_Firebrick();
[JScript]
public static function get Firebrick() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.FloralWhite

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property FloralWhite As Pen
[C#]
public static Pen FloralWhite {get;}
[C++]
public: __property static Pen* get_FloralWhite();
[JScript]
public static function get FloralWhite() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.ForestGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property ForestGreen As Pen
[C#]
public static Pen ForestGreen {get;}
[C++]
public: __property static Pen* get_ForestGreen();
[JScript]
public static function get ForestGreen() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Fuchsia

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Fuchsia As Pen
[C#]
public static Pen Fuchsia {get;}
[C++]
public: __property static Pen* get_Fuchsia();
[JScript]
public static function get Fuchsia() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Gainsboro

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Gainsboro As Pen
[C#]
public static Pen Gainsboro {get;}
[C++]
public: __property static Pen* get_Gainsboro();
[JScript]
public static function get Gainsboro() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.GhostWhite

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property GhostWhite As Pen
[C#]
public static Pen GhostWhite {get;}
[C++]
public: __property static Pen* get_GhostWhite();
[JScript]
public static function get GhostWhite() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Gold

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Gold As Pen
[C#]
public static Pen Gold {get;}
[C++]
public: __property static Pen* get_Gold();
[JScript]
public static function get Gold() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Goldenrod

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Goldenrod As Pen
[C#]
public static Pen Goldenrod {get;}
[C++]
public: __property static Pen* get_Goldenrod();
[JScript]
public static function get Goldenrod() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Gray

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Gray As Pen
[C#]
public static Pen Gray {get;}
[C++]
public: __property static Pen* get_Gray();
[JScript]
public static function get Gray() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Green

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Green As Pen
[C#]
public static Pen Green {get;}
[C++]
public: __property static Pen* get_Green();
[JScript]
public static function get Green() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.GreenYellow

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property GreenYellow As Pen
[C#]
public static Pen GreenYellow {get;}
[C++]
public: __property static Pen* get_GreenYellow();
[JScript]
public static function get GreenYellow() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Honeydew

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Honeydew As Pen
[C#]
public static Pen Honeydew {get;}
[C++]
public: __property static Pen* get_Honeydew();
[JScript]
public static function get Honeydew() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.HotPink

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property HotPink As Pen
[C#]
public static Pen HotPink {get;}
[C++]
public: __property static Pen* get_HotPink();
[JScript]
public static function get HotPink() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.IndianRed

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property IndianRed As Pen
[C#]
public static Pen IndianRed {get;}
[C++]
public: __property static Pen* get_IndianRed();
[JScript]
public static function get IndianRed() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Indigo

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Indigo As Pen
[C#]
public static Pen Indigo {get;}
[C++]
public: __property static Pen* get_Indigo();
[JScript]
public static function get Indigo() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Ivory

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Ivory As Pen
[C#]
public static Pen Ivory {get;}
[C++]
public: __property static Pen* get_Ivory();
[JScript]
public static function get Ivory() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Khaki

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Khaki As Pen
[C#]
public static Pen Khaki {get;}
[C++]
public: __property static Pen* get_Khaki();
[JScript]
public static function get Khaki() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Lavender

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Lavender As Pen
[C#]
public static Pen Lavender {get;}
[C++]
public: __property static Pen* get_Lavender();
[JScript]
public static function get Lavender() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.LavenderBlush

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LavenderBlush As Pen
[C#]
public static Pen LavenderBlush {get;}
[C++]
public: __property static Pen* get_LavenderBlush();
[JScript]
public static function get LavenderBlush() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.LawnGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LawnGreen As Pen
[C#]
public static Pen LawnGreen {get;}
[C++]
public: __property static Pen* get_LawnGreen();
[JScript]
public static function get LawnGreen() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.LemonChiffon

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LemonChiffon As Pen
[C#]
public static Pen LemonChiffon {get;}
[C++]
public: __property static Pen* get_LemonChiffon();
[JScript]
public static function get LemonChiffon() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.LightBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightBlue As Pen
[C#]
public static Pen LightBlue {get;}
[C++]
public: __property static Pen* get_LightBlue();
[JScript]
public static function get LightBlue() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.LightCoral

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightCoral As Pen
[C#]
public static Pen LightCoral {get;}
[C++]
public: __property static Pen* get_LightCoral();
[JScript]
public static function get LightCoral() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.LightCyan

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightCyan As Pen
[C#]
public static Pen LightCyan {get;}
[C++]
public: __property static Pen* get_LightCyan();
[JScript]
public static function get LightCyan() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.LightGoldenrodYellow

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightGoldenrodYellow As Pen
[C#]
public static Pen LightGoldenrodYellow {get;}
[C++]
public: __property static Pen* get_LightGoldenrodYellow();
[JScript]
public static function get LightGoldenrodYellow() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.LightGray

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightGray As Pen
[C#]
public static Pen LightGray {get;}
[C++]
public: __property static Pen* get_LightGray();
[JScript]
public static function get LightGray() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.LightGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightGreen As Pen
[C#]
public static Pen LightGreen {get;}
[C++]
public: __property static Pen* get_LightGreen();
[JScript]
public static function get LightGreen() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.LightPink

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightPink As Pen
[C#]
public static Pen LightPink {get;}
[C++]
public: __property static Pen* get_LightPink();
[JScript]
public static function get LightPink() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.LightSalmon

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightSalmon As Pen
[C#]
public static Pen LightSalmon {get;}
[C++]
public: __property static Pen* get_LightSalmon();
[JScript]
public static function get LightSalmon() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.LightSeaGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightSeaGreen As Pen
[C#]
public static Pen LightSeaGreen {get;}
[C++]
public: __property static Pen* get_LightSeaGreen();
[JScript]
public static function get LightSeaGreen() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.LightSkyBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightSkyBlue As Pen
[C#]
public static Pen LightSkyBlue {get;}
[C++]
public: __property static Pen* get_LightSkyBlue();
[JScript]
public static function get LightSkyBlue() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.LightSlateGray

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightSlateGray As Pen
[C#]
public static Pen LightSlateGray {get;}
[C++]
public: __property static Pen* get_LightSlateGray();
[JScript]
public static function get LightSlateGray() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.LightSteelBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightSteelBlue As Pen
[C#]
public static Pen LightSteelBlue {get;}
[C++]
public: __property static Pen* get_LightSteelBlue();
[JScript]
public static function get LightSteelBlue() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.LightYellow

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LightYellow As Pen
[C#]
public static Pen LightYellow {get;}
[C++]
public: __property static Pen* get_LightYellow();
[JScript]
public static function get LightYellow() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Lime

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Lime As Pen
[C#]
public static Pen Lime {get;}
[C++]
public: __property static Pen* get_Lime();
[JScript]
public static function get Lime() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.LimeGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property LimeGreen As Pen
[C#]
public static Pen LimeGreen {get;}
[C++]
public: __property static Pen* get_LimeGreen();
[JScript]
public static function get LimeGreen() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Linen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Linen As Pen
[C#]
public static Pen Linen {get;}
[C++]
public: __property static Pen* get_Linen();
[JScript]
public static function get Linen() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Magenta

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Magenta As Pen
[C#]
public static Pen Magenta {get;}
[C++]
public: __property static Pen* get_Magenta();
[JScript]
public static function get Magenta() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Maroon

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Maroon As Pen
[C#]
public static Pen Maroon {get;}
[C++]
public: __property static Pen* get_Maroon();
[JScript]
public static function get Maroon() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.MediumAquamarine

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MediumAquamarine As Pen
[C#]
public static Pen MediumAquamarine {get;}
[C++]
public: __property static Pen* get_MediumAquamarine();
[JScript]
public static function get MediumAquamarine() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.MediumBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MediumBlue As Pen
[C#]
public static Pen MediumBlue {get;}
[C++]
public: __property static Pen* get_MediumBlue();
[JScript]
public static function get MediumBlue() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.MediumOrchid

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MediumOrchid As Pen
[C#]
public static Pen MediumOrchid {get;}
[C++]
public: __property static Pen* get_MediumOrchid();
[JScript]
public static function get MediumOrchid() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.MediumPurple

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MediumPurple As Pen
[C#]
public static Pen MediumPurple {get;}
[C++]
public: __property static Pen* get_MediumPurple();
[JScript]
public static function get MediumPurple() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.MediumSeaGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MediumSeaGreen As Pen
[C#]
public static Pen MediumSeaGreen {get;}
[C++]
public: __property static Pen* get_MediumSeaGreen();
[JScript]
public static function get MediumSeaGreen() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.MediumSlateBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MediumSlateBlue As Pen
[C#]
public static Pen MediumSlateBlue {get;}
[C++]
public: __property static Pen* get_MediumSlateBlue();
[JScript]
public static function get MediumSlateBlue() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.MediumSpringGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MediumSpringGreen As Pen
[C#]
public static Pen MediumSpringGreen {get;}
[C++]
public: __property static Pen* get_MediumSpringGreen();
[JScript]
public static function get MediumSpringGreen() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.MediumTurquoise

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MediumTurquoise As Pen
[C#]
public static Pen MediumTurquoise {get;}
[C++]
public: __property static Pen* get_MediumTurquoise();
[JScript]
public static function get MediumTurquoise() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.MediumVioletRed

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MediumVioletRed As Pen
[C#]
public static Pen MediumVioletRed {get;}
[C++]
public: __property static Pen* get_MediumVioletRed();
[JScript]
public static function get MediumVioletRed() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.MidnightBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MidnightBlue As Pen
[C#]
public static Pen MidnightBlue {get;}
[C++]
public: __property static Pen* get_MidnightBlue();
[JScript]
public static function get MidnightBlue() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.MintCream

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MintCream As Pen
[C#]
public static Pen MintCream {get;}
[C++]
public: __property static Pen* get_MintCream();
[JScript]
public static function get MintCream() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.MistyRose

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property MistyRose As Pen
[C#]
public static Pen MistyRose {get;}
[C++]
public: __property static Pen* get_MistyRose();
[JScript]
public static function get MistyRose() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Moccasin

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Moccasin As Pen
[C#]
public static Pen Moccasin {get;}
[C++]
public: __property static Pen* get_Moccasin();
[JScript]
public static function get Moccasin() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.NavajoWhite

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property NavajoWhite As Pen
[C#]
public static Pen NavajoWhite {get;}
[C++]
public: __property static Pen* get_NavajoWhite();
[JScript]
public static function get NavajoWhite() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Navy

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Navy As Pen
[C#]
public static Pen Navy {get;}
[C++]
public: __property static Pen* get_Navy();
[JScript]
public static function get Navy() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.OldLace

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property OldLace As Pen
[C#]
public static Pen OldLace {get;}
[C++]
public: __property static Pen* get_OldLace();
[JScript]
public static function get OldLace() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Olive

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Olive As Pen
[C#]
public static Pen Olive {get;}
[C++]
public: __property static Pen* get_Olive();
[JScript]
public static function get Olive() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.OliveDrab

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property OliveDrab As Pen
[C#]
public static Pen OliveDrab {get;}
[C++]
public: __property static Pen* get_OliveDrab();
[JScript]
public static function get OliveDrab() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Orange

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Orange As Pen
[C#]
public static Pen Orange {get;}
[C++]
public: __property static Pen* get_Orange();
[JScript]
public static function get Orange() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.OrangeRed

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property OrangeRed As Pen
[C#]
public static Pen OrangeRed {get;}
[C++]
public: __property static Pen* get_OrangeRed();
[JScript]
public static function get OrangeRed() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Orchid

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Orchid As Pen
[C#]
public static Pen Orchid {get;}
[C++]
public: __property static Pen* get_Orchid();
[JScript]
public static function get Orchid() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.PaleGoldenrod

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property PaleGoldenrod As Pen
[C#]
public static Pen PaleGoldenrod {get;}
[C++]
public: __property static Pen* get_PaleGoldenrod();
[JScript]
public static function get PaleGoldenrod() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.PaleGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property PaleGreen As Pen
[C#]
public static Pen PaleGreen {get;}
[C++]
public: __property static Pen* get_PaleGreen();
[JScript]
public static function get PaleGreen() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.PaleTurquoise

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property PaleTurquoise As Pen
[C#]
public static Pen PaleTurquoise {get;}
[C++]
public: __property static Pen* get_PaleTurquoise();
[JScript]
public static function get PaleTurquoise() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.PaleVioletRed

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property PaleVioletRed As Pen
[C#]
public static Pen PaleVioletRed {get;}
[C++]
public: __property static Pen* get_PaleVioletRed();
[JScript]
public static function get PaleVioletRed() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.PapayaWhip

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property PapayaWhip As Pen
[C#]
public static Pen PapayaWhip {get;}
[C++]
public: __property static Pen* get_PapayaWhip();
[JScript]
public static function get PapayaWhip() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.PeachPuff

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property PeachPuff As Pen
[C#]
public static Pen PeachPuff {get;}
[C++]
public: __property static Pen* get_PeachPuff();
[JScript]
public static function get PeachPuff() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Peru

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Peru As Pen
[C#]
public static Pen Peru {get;}
[C++]
public: __property static Pen* get_Peru();
[JScript]
public static function get Peru() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Pink

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Pink As Pen
[C#]
public static Pen Pink {get;}
[C++]
public: __property static Pen* get_Pink();
[JScript]
public static function get Pink() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Plum

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Plum As Pen
[C#]
public static Pen Plum {get;}
[C++]
public: __property static Pen* get_Plum();
[JScript]
public static function get Plum() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.PowderBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property PowderBlue As Pen
[C#]
public static Pen PowderBlue {get;}
[C++]
public: __property static Pen* get_PowderBlue();
[JScript]
public static function get PowderBlue() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Purple

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Purple As Pen
[C#]
public static Pen Purple {get;}
[C++]
public: __property static Pen* get_Purple();
[JScript]
public static function get Purple() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Red

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Red As Pen
[C#]
public static Pen Red {get;}
[C++]
public: __property static Pen* get_Red();
[JScript]
public static function get Red() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.RosyBrown

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property RosyBrown As Pen
[C#]
public static Pen RosyBrown {get;}
[C++]
public: __property static Pen* get_RosyBrown();
[JScript]
public static function get RosyBrown() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.RoyalBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property RoyalBlue As Pen
[C#]
public static Pen RoyalBlue {get;}
[C++]
public: __property static Pen* get_RoyalBlue();
[JScript]
public static function get RoyalBlue() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.SaddleBrown

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SaddleBrown As Pen
[C#]
public static Pen SaddleBrown {get;}
[C++]
public: __property static Pen* get_SaddleBrown();
[JScript]
public static function get SaddleBrown() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Salmon

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Salmon As Pen
[C#]
public static Pen Salmon {get;}
[C++]
public: __property static Pen* get_Salmon();
[JScript]
public static function get Salmon() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.SandyBrown

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SandyBrown As Pen
[C#]
public static Pen SandyBrown {get;}
[C++]
public: __property static Pen* get_SandyBrown();
[JScript]
public static function get SandyBrown() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.SeaGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SeaGreen As Pen
[C#]
public static Pen SeaGreen {get;}
[C++]
public: __property static Pen* get_SeaGreen();
[JScript]
public static function get SeaGreen() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.SeaShell

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SeaShell As Pen
[C#]
public static Pen SeaShell {get;}
[C++]
public: __property static Pen* get_SeaShell();
[JScript]
public static function get SeaShell() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Sienna

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Sienna As Pen
[C#]
public static Pen Sienna {get;}
[C++]
public: __property static Pen* get_Sienna();
[JScript]
public static function get Sienna() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Silver

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Silver As Pen
[C#]
public static Pen Silver {get;}
[C++]
public: __property static Pen* get_Silver();
[JScript]
public static function get Silver() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.SkyBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SkyBlue As Pen
[C#]
public static Pen SkyBlue {get;}
[C++]
public: __property static Pen* get_SkyBlue();
[JScript]
public static function get SkyBlue() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.SlateBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SlateBlue As Pen
[C#]
public static Pen SlateBlue {get;}
[C++]
public: __property static Pen* get_SlateBlue();
[JScript]
public static function get SlateBlue() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.SlateGray

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SlateGray As Pen
[C#]
public static Pen SlateGray {get;}
[C++]
public: __property static Pen* get_SlateGray();
[JScript]
public static function get SlateGray() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Snow

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Snow As Pen
[C#]
public static Pen Snow {get;}
[C++]
public: __property static Pen* get_Snow();
[JScript]
public static function get Snow() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.SpringGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SpringGreen As Pen
[C#]
public static Pen SpringGreen {get;}
[C++]
public: __property static Pen* get_SpringGreen();
[JScript]
public static function get SpringGreen() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.SteelBlue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property SteelBlue As Pen
[C#]
public static Pen SteelBlue {get;}
[C++]
public: __property static Pen* get_SteelBlue();
[JScript]
public static function get SteelBlue() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Tan

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Tan As Pen
[C#]
public static Pen Tan {get;}
[C++]
public: __property static Pen* get_Tan();
[JScript]
public static function get Tan() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Teal

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Teal As Pen
[C#]
public static Pen Teal {get;}
[C++]
public: __property static Pen* get_Teal();
[JScript]
public static function get Teal() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Thistle

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Thistle As Pen
[C#]
public static Pen Thistle {get;}
[C++]
public: __property static Pen* get_Thistle();
[JScript]
public static function get Thistle() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Tomato

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Tomato As Pen
[C#]
public static Pen Tomato {get;}
[C++]
public: __property static Pen* get_Tomato();
[JScript]
public static function get Tomato() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Transparent

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Transparent As Pen
[C#]
public static Pen Transparent {get;}
[C++]
public: __property static Pen* get_Transparent();
[JScript]
public static function get Transparent() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Turquoise

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Turquoise As Pen
[C#]
public static Pen Turquoise {get;}
[C++]
public: __property static Pen* get_Turquoise();
[JScript]
public static function get Turquoise() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Violet

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Violet As Pen
[C#]
public static Pen Violet {get;}
[C++]
public: __property static Pen* get_Violet();
[JScript]
public static function get Violet() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Wheat

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Wheat As Pen
[C#]
public static Pen Wheat {get;}
[C++]
public: __property static Pen* get_Wheat();
[JScript]
public static function get Wheat() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.White

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property White As Pen
[C#]
public static Pen White {get;}
[C++]
public: __property static Pen* get_White();
[JScript]
public static function get White() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.WhiteSmoke

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property WhiteSmoke As Pen
[C#]
public static Pen WhiteSmoke {get;}
[C++]
public: __property static Pen* get_WhiteSmoke();
[JScript]
public static function get WhiteSmoke() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.Yellow

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property Yellow As Pen
[C#]
public static Pen Yellow {get;}
[C++]
public: __property static Pen* get_Yellow();
[JScript]
public static function get Yellow() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


Pens.YellowGreen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property YellowGreen As Pen
[C#]
public static Pen YellowGreen {get;}
[C++]
public: __property static Pen* get_YellowGreen();
[JScript]
public static function get YellowGreen() : Pen;

See Also

Pens Class | Pens Members | System.Drawing Namespace


PenStyle Enumeration

Defines different styles that a pen can be created with.

[Visual Basic]
Public Enum PenStyle
[C#]
public enum PenStyle
[C++]
public enum PenStyle

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Dash | Pen style that consists of a series of dashed lines:--------
DashDot | Pen style that consists of a dash, followed by a dot: _ . _ . _ .
DashDotDot | Pen style that consists of a dash, followed by two dots: _ . . _ . . _ . .
Dot | Pen style that consists of a dotted line: ...........
InsideFrame | This style creates a solid pen that will be drawn from within any given bounding rectangle. Using this style allows you to have a wide pen that automatically conforms to the interior of a rectangle.
Max | [To be supplied.]
Min | [To be supplied.]
Null | A "null" pen is a pen that doesn't draw at all. This is useful when you have a function that always draws a border, but you don't want the border.
Solid | Pen style that consists of a solid line: ___________

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

System.Drawing Namespace | Pen


Point Structure

This is a class that represents a single (X,Y) coordinate and various interesting operations on such a coordinate.

Object
ValueType
Point

[Visual Basic]
Public Structure Point
[C#]
public struct Point
[C++]
public __value struct Point

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

Point Members | System.Drawing Namespace


Point Members

Public:

Constructor

Point Constructor Overloaded. [To be supplied.]

Properties

IsEmpty | [To be supplied.]
X | [To be supplied.]
Y | [To be supplied.]

Methods

Copy | [To be supplied.]
Equals | Tests to see if the two points represent the same logical location. Doesn't actually test for object identity equality.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
Offset | [To be supplied.]
ToString | [To be supplied.]

Operators and Type Conversions

Addition Operator | Translates a Point by a given Size.
Equality Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Subtraction Operator | Translates a Point by the negative of a given Size.
Point to Size Conversion | [To be supplied.]
Point to PointF Conversion | [To be supplied.]

Fields

Empty [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Point Structure | System.Drawing Namespace


Point Constructor

[To be supplied.]

Overload List

Create a new Point object at the given location.

[Visual Basic] Overloads Public Sub New(Integer, Integer)
[C#] public Point(int, int);
[C++] public: Point(int, int);
[JScript] public function Point(int, int);

Create a new Point object given an existing Size object.

[Visual Basic] Overloads Public Sub New(Size)
[C#] public Point(Size);
[C++] public: Point(Size);
[JScript] public function Point(Size);

Create a new point object given the coordinates crammed into a 32bit integer. The low order 16bits are the horizontal [x] coordinate and the higher 16bits are the vertical [Y] coordinate.

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public Point(int);
[C++] public: Point(int);
[JScript] public function Point(int);

See Also

Point Structure | Point Members | System.Drawing Namespace


Point Constructor (Int32, Int32)

Create a new Point object at the given location.

[Visual Basic]
Overloads Public Sub New( _
   ByVal x As Integer, _
   ByVal y As Integer _
)
[C#]
public Point(
   int x,
   int y
);
[C++]
public: Point(
   int x,
   int y
);
[JScript]
public function Point(
   x : int,
   y : int
);

Parameters

x
Horizontal poisiton of the point.
y
Vertical position of the point.

See Also

Point Structure | Point Members | System.Drawing Namespace | Point Constructor Overload List


Point Constructor (Size)

Create a new Point object given an existing Size object.

[Visual Basic]
Overloads Public Sub New( _
   ByVal sz As Size _
)
[C#]
public Point(
   Size sz
);
[C++]
public: Point(
   Size sz
);
[JScript]
public function Point(
   sz : Size
);

Parameters

sz
Size object.

See Also

Point Structure | Point Members | System.Drawing Namespace | Point Constructor Overload List


Point Constructor (Int32)

Create a new point object given the coordinates crammed into a 32bit integer. The low order 16bits are the horizontal [x] coordinate and the higher 16bits are the vertical [Y] coordinate.

[Visual Basic]
Overloads Public Sub New( _
   ByVal dw As Integer _
)
[C#]
public Point(
   int dw
);
[C++]
public: Point(
   int dw
);
[JScript]
public function Point(
   dw : int
);

Parameters

dw
Integer with the two coordinate values in it

See Also

Point Structure | Point Members | System.Drawing Namespace | Point Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Point Properties

The properties of the Point structure are listed below. For a complete list of Point structure members, see the Point Members topic.

Public:

IsEmpty | [To be supplied.]
X | [To be supplied.]
Y | [To be supplied.]

See Also

Point Structure | System.Drawing Namespace


Point.IsEmpty

[To be supplied.]

[Visual Basic]
Public ReadOnly Property IsEmpty As Boolean
[C#]
public bool IsEmpty {get;}
[C++]
public: __property bool get_IsEmpty();
[JScript]
public function get IsEmpty() : Boolean;

See Also

Point Structure | Point Members | System.Drawing Namespace


Point.X

[To be supplied.]

[Visual Basic]
Public Property X As Integer
[C#]
public int X {get; set;}
[C++]
public: __property int get_X();
public: __property void set_X(int);
[JScript]
public function get X() : int;
public function set X(int);

See Also

Point Structure | Point Members | System.Drawing Namespace


Point.Y

[To be supplied.]

[Visual Basic]
Public Property Y As Integer
[C#]
public int Y {get; set;}
[C++]
public: __property int get_Y();
public: __property void set_Y(int);
[JScript]
public function get Y() : int;
public function set Y(int);

See Also

Point Structure | Point Members | System.Drawing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Point Methods

The methods of the Point structure are listed below. For a complete list of Point structure members, see the Point Members topic.

Public:

Copy | [To be supplied.]
Equals | Tests to see if the two points represent the same logical location. Doesn't actually test for object identity equality.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
Offset | [To be supplied.]
ToString | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Point Structure | System.Drawing Namespace


Point.Copy

[To be supplied.]

[Visual Basic]
Public Shared Function Copy( _
   ByVal pt As Point _
) As Point
[C#]
public static Point Copy(
   Point pt
);
[C++]
public: static Point Copy(
   Point pt
);
[JScript]
public static function Copy(
   pt : Point
) : Point;

Parameters

pt
[To be supplied.]

See Also

Point Structure | Point Members | System.Drawing Namespace


Point.Equals

Tests to see if the two points represent the same logical location. Doesn't actually test for object identity equality.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
Test to see if this object is the same as the current one.

Return Value

boolean indicating true if they are the same, false otherwise.

See Also

Point Structure | Point Members | System.Drawing Namespace


Point.Offset

[To be supplied.]

[Visual Basic]
Public Sub Offset( _
   ByVal dx As Integer, _
   ByVal dy As Integer _
)
[C#]
public void Offset(
   int dx,
   int dy
);
[C++]
public: void Offset(
   int dx,
   int dy
);
[JScript]
public function Offset(
   dx : int,
   dy : int
);

Parameters

dx
[To be supplied.]
dy
[To be supplied.]

See Also

Point Structure | Point Members | System.Drawing Namespace


Point.ToString

[To be supplied.]

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

Point Structure | Point Members | System.Drawing Namespace


Operators and Type Conversions

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Point Operators and Type Conversions

The operators and type conversions of the Point structure are listed below. For a complete list of Point structure members, see the Point Members topic.

Public:

Addition Operator | Translates a Point by a given Size.
Equality Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Subtraction Operator | Translates a Point by the negative of a given Size.
Point to Size Conversion | [To be supplied.]
Point to PointF Conversion | [To be supplied.]

See Also

Point Structure | System.Drawing Namespace


Point Addition Operator

Translates a Point by a given Size.

[C#]
public static Point operator +(
   Point pt,
   Size sz
);
[C++]
public: static Point operator op_Addition(
   Point pt,
   Size sz
);
[JScript]
returnValue = pt + sz;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

pt
Point to add the size to
sz
Size to add to the point

Parameters [C#, C++]

pt
Point to add the size to
sz
Size to add to the point

See Also

Point Structure | Point Members | System.Drawing Namespace


Point Equality Operator

[To be supplied.]

[C#]
public static bool operator ==(
   Point left,
   Point right
);
[C++]
public: static bool operator op_Equality(
   Point left,
   Point right
);
[JScript]
returnValue = left == right;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

left
[To be supplied.]
right
[To be supplied.]

Parameters [C#, C++]

left
[To be supplied.]
right
[To be supplied.]

See Also

Point Structure | Point Members | System.Drawing Namespace


Point Inequality Operator

[To be supplied.]

[C#]
public static bool operator !=(
   Point left,
   Point right
);
[C++]
public: static bool operator op_Inequality(
   Point left,
   Point right
);
[JScript]
returnValue = left ! = right;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

left
[To be supplied.]
right
[To be supplied.]

Parameters [C#, C++]

left
[To be supplied.]
right
[To be supplied.]

See Also

Point Structure | Point Members | System.Drawing Namespace


Point Subtraction Operator

Translates a Point by the negative of a given Size.

[C#]
public static Point operator -(
   Point pt,
   Size sz
);
[C++]
public: static Point operator op_Subtraction(
   Point pt,
   Size sz
);
[JScript]
returnValue = pt - sz;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

pt
Point to subtract the size from
sz
Size to subtract from the point

Parameters [C#, C++]

pt
Point to subtract the size from
sz
Size to subtract from the point

See Also

Point Structure | Point Members | System.Drawing Namespace


Point to Size Conversion

[To be supplied.]

[C#]
public static explicit operator Size(
   Point p
);
[C++]
public: operator Size();
[JScript]
returnValue = Size(p);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

p
[To be supplied.]

Parameters [C#]

p
[To be supplied.]

See Also

Point Structure | Point Members | System.Drawing Namespace


Point to PointF Conversion

[To be supplied.]

[C#]
public static implicit operator PointF(
   Point p
);
[C++]
public: operator PointF();
[JScript]
returnValue = p;

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

p
[To be supplied.]

Parameters [C#]

p
[To be supplied.]

See Also

Point Structure | Point Members | System.Drawing Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Point Fields

The fields of the Point structure are listed below. For a complete list of Point structure members, see the Point Members topic.

Public:

Empty [To be supplied.]

See Also

Point Structure | System.Drawing Namespace


Point.Empty

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Empty As Point
[C#]
public static readonly Point Empty;
[C++]
public: static readonly Point Empty;
[JScript]
public static var Empty : Point;

See Also

Point Structure | Point Members | System.Drawing Namespace


PointConverter Class

PointConverter is a class that can be used to convert Point from one data type to another. Access this class through the TypeDescriptor.

Object
TypeConverter
PointConverter

[Visual Basic]
Public Class PointConverter
   Inherits TypeConverter
[C#]
public class PointConverter : TypeConverter
[C++]
public __gc class PointConverter : public TypeConverter
[JScript]
public class PointConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

PointConverter Members | System.Drawing Namespace


PointConverter Members

Public:

Constructor

PointConverter Constructor [To be supplied.]

Methods

CanConvertFrom (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type.
ConvertFrom | Overloaded. [To be supplied.]
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text into an object.
ConvertTo | Overloaded. [To be supplied.]
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetProperties (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValues (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid (inherited from TypeConverter) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

PointConverter Class | System.Drawing Namespace


PointConverter Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public PointConverter();
[C++]
public: PointConverter();
[JScript]
public function PointConverter();

See Also

PointConverter Class | PointConverter Members | System.Drawing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PointConverter Methods

The methods of the PointConverter class are listed below. For a complete list of PointConverter class members, see the PointConverter Members topic.

Public:

CanConvertFrom (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type.
ConvertFrom | Overloaded. [To be supplied.]
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text into an object.
ConvertTo | Overloaded. [To be supplied.]
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetProperties (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValues (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid (inherited from TypeConverter) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

PointConverter Class | System.Drawing Namespace


PointConverter.CanConvertFrom

Determines if this converter can convert an object in the given source type to the native type of the converter.

[Visual Basic]
Overrides Public Function CanConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal sourceType As Type _
) As Boolean
[C#]
public override bool CanConvertFrom(
   ITypeDescriptorContext context,
   Type sourceType
);
[C++]
public: override bool CanConvertFrom(
   ITypeDescriptorContext* context,
   Type* sourceType
);
[JScript]
public override function CanConvertFrom(
   context : ITypeDescriptorContext,
   sourceType : Type
) : Boolean;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
sourceType
The type you wish to convert from.

Return Value

True if this object can perform the conversion.

See Also

PointConverter Class | PointConverter Members | System.Drawing Namespace


PointConverter.ConvertFrom

Converts the given object to the converter's native type.

[Visual Basic]
Overrides Public Function ConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal arguments() As Object _
) As Object
[C#]
public override object ConvertFrom(
   ITypeDescriptorContext context,
   object value,
   object[] arguments
);
[C++]
public: override Object* ConvertFrom(
   ITypeDescriptorContext* context,
   Object* value,
   Object* arguments[]
);
[JScript]
public override function ConvertFrom(
   context : ITypeDescriptorContext,
   value : Object,
   arguments : Object[]
) : Object;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
value
The object to convert.
arguments
An optional array of arguments to use when doing the conversion. The number and content of these arguments is dependent on the implementer of the value formatter.

Return Value

The converted object. This will throw an excetpion if the converson could not be performed.

See Also

PointConverter Class | PointConverter Members | System.Drawing Namespace


PointConverter.ConvertTo

Converts the given object to another type. The most common types to convert are to and from a string object. The default implementation will make a call to ToString on the object if the object is valid and if the destination type is string. If this cannot convert to the desitnation type, this will throw a NotSupportedException.

[Visual Basic]
Overrides Public Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal destinationType As Type, _
   ByVal arguments() As Object _
) As Object
[C#]
public override object ConvertTo(
   ITypeDescriptorContext context,
   object value,
   Type destinationType,
   object[] arguments
);
[C++]
public: override Object* ConvertTo(
   ITypeDescriptorContext* context,
   Object* value,
   Type* destinationType,
   Object* arguments[]
);
[JScript]
public override function ConvertTo(
   context : ITypeDescriptorContext,
   value : Object,
   destinationType : Type,
   arguments : Object[]
) : Object;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
value
The object to convert.
destinationType
The type to convert the object to.
arguments
An optional array of arguments to use when doing the conversion. The number and content of these arguments is dependent on the implementer of the value formatter.

Return Value

The converted object.

See Also

PointConverter Class | PointConverter Members | System.Drawing Namespace


PointConverter.CreateInstance

[To be supplied.]

Overload List

Recreates an object given its PersistInfo. This information was generated by a prior call to GetPersistInfo.

[Visual Basic] Overloads Overrides Public Function CreateInstance(ITypeDescriptorContext, PersistInfo) As Object
[C#] public override object CreateInstance(ITypeDescriptorContext, PersistInfo);
[C++] public: override Object* CreateInstance(ITypeDescriptorContext*, PersistInfo);
[JScript] public override function CreateInstance(ITypeDescriptorContext, PersistInfo) : Object;

Creates an instance of this type given a set of property values for the object. This is useful for objects that are immutable, but still want to provide changable properties.

[Visual Basic] Overloads Overrides Public Function CreateInstance(ITypeDescriptorContext, IDictionary) As Object
[C#] public override object CreateInstance(ITypeDescriptorContext, IDictionary);
[C++] public: override Object* CreateInstance(ITypeDescriptorContext*, IDictionary);
[JScript] public override function CreateInstance(ITypeDescriptorContext, IDictionary) : Object;

See Also

PointConverter Class | PointConverter Members | System.Drawing Namespace


PointConverter.CreateInstance (ITypeDescriptorContext, PersistInfo)

Recreates an object given its PersistInfo. This information was generated by a prior call to GetPersistInfo.

[Visual Basic]
Overloads Overrides Public Function CreateInstance( _
   ByVal context As ITypeDescriptorContext, _
   ByVal persistInfo As PersistInfo _
) As Object
[C#]
public override object CreateInstance(
   ITypeDescriptorContext context,
   PersistInfo persistInfo
);
[C++]
public: override Object* CreateInstance(
   ITypeDescriptorContext* context,
   PersistInfo* persistInfo
);
[JScript]
public override function CreateInstance(
   context : ITypeDescriptorContext,
   persistInfo : PersistInfo
) : Object;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
persistInfo
The persistence information to use when re-creating the object.

Return Value

An object representing the given PersistInfo.

See Also

PointConverter Class | PointConverter Members | System.Drawing Namespace | PointConverter.CreateInstance Overload List | PersistInfo | TBD


PointConverter.CreateInstance (ITypeDescriptorContext, IDictionary)

Creates an instance of this type given a set of property values for the object. This is useful for objects that are immutable, but still want to provide changable properties.

[Visual Basic]
Overloads Overrides Public Function CreateInstance( _
   ByVal context As ITypeDescriptorContext, _
   ByVal propertyValues As IDictionary _
) As Object
[C#]
public override object CreateInstance(
   ITypeDescriptorContext context,
   IDictionary propertyValues
);
[C++]
public: override Object* CreateInstance(
   ITypeDescriptorContext* context,
   IDictionary* propertyValues
);
[JScript]
public override function CreateInstance(
   context : ITypeDescriptorContext,
   propertyValues : IDictionary
) : Object;

Parameters

context
A type descriptor through which additional context may be provided.
propertyValues
A dictionary of new property values. The dictionary contains a series of name-value pairs, one for each property returned from GetProperties.

Return Value

The newly created object, or null if the object could not be created. The default implementation returns null.

See Also

PointConverter Class | PointConverter Members | System.Drawing Namespace | PointConverter.CreateInstance Overload List


PointConverter.GetCreateInstanceSupported

Determines if changing a value on this object should require a call to CreateInstance to create a new value.

[Visual Basic]
Overrides Public Function GetCreateInstanceSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
[C#]
public override bool GetCreateInstanceSupported(
   ITypeDescriptorContext context
);
[C++]
public: override bool GetCreateInstanceSupported(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetCreateInstanceSupported(
   context : ITypeDescriptorContext
) : Boolean;

Parameters

context
A type descriptor through which additional context may be provided.

Return Value

Returns true if CreateInstance should be called when a change is made to one or more properties of this object.

See Also

PointConverter Class | PointConverter Members | System.Drawing Namespace


PointConverter.GetPersistInfo

Retrieves the PersistInfo object for the given value. This object describes the given value as persisted information, which can be saved to disk or moved. This information can later be reconstructed by passing the PersistInfo to GetValue.

[Visual Basic]
Overrides Public Function GetPersistInfo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As PersistInfo
[C#]
public override PersistInfo GetPersistInfo(
   ITypeDescriptorContext context,
   object value
);
[C++]
public: override PersistInfo* GetPersistInfo(
   ITypeDescriptorContext* context,
   Object* value
);
[JScript]
public override function GetPersistInfo(
   context : ITypeDescriptorContext,
   value : Object
) : PersistInfo;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
value
The object to persist.

Return Value

The PersistInfo representing the persisted state of the given object.

See Also

PointConverter Class | PointConverter Members | System.Drawing Namespace | PersistInfo | TBD


PointConverter.GetProperties

Retrieves the set of properties for this type. By default, a type has does not return any properties. An easy implementation of this method can just call TypeDescriptor.GetProperties for the correct data type.

[Visual Basic]
Overrides Public Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal attributes() As MemberAttribute _
) As PropertyDescriptorCollection
[C#]
public override PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value,
   MemberAttribute[] attributes
);
[C++]
public: override PropertyDescriptorCollection* GetProperties(
   ITypeDescriptorContext* context,
   Object* value,
   MemberAttribute* attributes[]
);
[JScript]
public override function GetProperties(
   context : ITypeDescriptorContext,
   value : Object,
   attributes : MemberAttribute[]
) : PropertyDescriptorCollection;

Parameters

context
A type descriptor through which additional context may be provided.
value
The value of the object to get the properties for.
attributes
[To be supplied.]

Return Value

The set of properties that should be exposed for this data type. If no properties should be exposed, thsi may return null. The default implementation always returns null.

See Also

PointConverter Class | PointConverter Members | System.Drawing Namespace


PointConverter.GetPropertiesSupported

Determines if this object supports properties. By default, this is false.

[Visual Basic]
Overrides Public Function GetPropertiesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
[C#]
public override bool GetPropertiesSupported(
   ITypeDescriptorContext context
);
[C++]
public: override bool GetPropertiesSupported(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetPropertiesSupported(
   context : ITypeDescriptorContext
) : Boolean;

Parameters

context
A type descriptor through which additional context may be provided.

Return Value

Returns true if GetProperties should be called to find the properties of this object.

See Also

PointConverter Class | PointConverter Members | System.Drawing Namespace


PointF Structure

[To be supplied.]

Object
ValueType
PointF

[Visual Basic]
Public Structure PointF
[C#]
public struct PointF
[C++]
public __value struct PointF

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

PointF Members | System.Drawing Namespace


PointF Members

Public:

Constructor

PointF Constructor [To be supplied.]

Properties

IsEmpty | [To be supplied.]
X | [To be supplied.]
Y | [To be supplied.]

Methods

Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Type Conversions

PointF to Point Conversion [To be supplied.]

Fields

Empty [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PointF Structure | System.Drawing Namespace


PointF Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal x As Single, _
   ByVal y As Single _
)
[C#]
public PointF(
   float x,
   float y
);
[C++]
public: PointF(
   float x,
   float y
);
[JScript]
public function PointF(
   x : float,
   y : float
);

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

PointF Structure | PointF Members | System.Drawing Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PointF Properties

The properties of the PointF structure are listed below. For a complete list of PointF structure members, see the PointF Members topic.

Public:

IsEmpty | [To be supplied.]
X | [To be supplied.]
Y | [To be supplied.]

See Also

PointF Structure | System.Drawing Namespace


PointF.IsEmpty

[To be supplied.]

[Visual Basic]
Public ReadOnly Property IsEmpty As Boolean
[C#]
public bool IsEmpty {get;}
[C++]
public: __property bool get_IsEmpty();
[JScript]
public function get IsEmpty() : Boolean;

See Also

PointF Structure | PointF Members | System.Drawing Namespace


PointF.X

[To be supplied.]

[Visual Basic]
Public Property X As Single
[C#]
public float X {get; set;}
[C++]
public: __property float get_X();
public: __property void set_X(float);
[JScript]
public function get X() : float;
public function set X(float);

See Also

PointF Structure | PointF Members | System.Drawing Namespace


PointF.Y

[To be supplied.]

[Visual Basic]
Public Property Y As Single
[C#]
public float Y {get; set;}
[C++]
public: __property float get_Y();
public: __property void set_Y(float);
[JScript]
public function get Y() : float;
public function set Y(float);

See Also

PointF Structure | PointF Members | System.Drawing Namespace


Type Conversions

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PointF Type Conversions

The type conversions of the PointF structure are listed below. For a complete list of PointF structure members, see the PointF Members topic.

Public:

PointF to Point Conversion [To be supplied.]

See Also

PointF Structure | System.Drawing Namespace


PointF to Point Conversion

[To be supplied.]

[C#]
public static explicit operator Point(
   PointF p
);
[C++]
public: operator Point();
[JScript]
returnValue = Point(p);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

p
[To be supplied.]

Parameters [C#]

p
[To be supplied.]

See Also

PointF Structure | PointF Members | System.Drawing Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PointF Fields

The fields of the PointF structure are listed below. For a complete list of PointF structure members, see the PointF Members topic.

Public:

Empty [To be supplied.]

See Also

PointF Structure | System.Drawing Namespace


PointF.Empty

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Empty As PointF
[C#]
public static readonly PointF Empty;
[C++]
public: static readonly PointF Empty;
[JScript]
public static var Empty : PointF;

See Also

PointF Structure | PointF Members | System.Drawing Namespace


PolyFillMode Enumeration

Enum that represents the different ways a region's overlapping polygons may be filled.

[Visual Basic]
Public Enum PolyFillMode
[C#]
public enum PolyFillMode
[C++]
public enum PolyFillMode

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Alternate | When the polygon-filling mode is ALTERNATE, the system fills the area between odd-numbered and even-numbered polygon sides on each scan line. That is, the system fills the area between the first and second side, between the third and fourth side, and so on. This mode is the default.
Max | [To be supplied.]
Min | [To be supplied.]
Winding | When the polygon-filling mode is WINDING, the system uses the direction in which a figure was drawn to determine whether to fill an area. Each line segment in a polygon is drawn in either a clockwise or a counterclockwise direction. Whenever an imaginary line drawn from an enclosed area to the outside of a figure passes through a clockwise line segment, a count is incremented. When the line passes through a counterclockwise line segment, the count is decremented. The area is filled if the count is nonzero when the line reaches the outside of the figure.

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

System.Drawing Namespace


Rectangle Structure

Rectangle. Stores the location and size of a rectangular region. For more advanced region functions use a Region object.

Object
ValueType
Rectangle

[Visual Basic]
Public Structure Rectangle
[C#]
public struct Rectangle
[C++]
public __value struct Rectangle

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

Rectangle Members | System.Drawing Namespace | Region


Rectangle Members

Public:

Constructor

Rectangle Constructor Overloaded. [To be supplied.]

Properties

Bottom | Retrieves the bottom value for this rectangle.
Height | [To be supplied.]
IsEmpty | [To be supplied.]
Left | Retrieves the left value for this rectangle.
Location | [To be supplied.]
Right | The right value for this rectangle.
Size | [To be supplied.]
Top | Retrieves the top value for this rectangle.
Width | [To be supplied.]
X | [To be supplied.]
Y | [To be supplied.]

Methods

Contains | Overloaded. [To be supplied.]
Equals | [To be supplied.]
FromLTRB | [To be supplied.]
GetHashCode | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
Inflate | Overloaded. [To be supplied.]
Intersect | Overloaded. [To be supplied.]
IntersectsWith | Determines if this rectangle intersets with rect.
Offset | Overloaded. [To be supplied.]
ToString | [To be supplied.]
Union | Creates a rectangle that represents the union between a and b.

Operators

Equality Operator | [To be supplied.]
Inequality Operator | [To be supplied.]

Fields

Empty [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Rectangle Structure | System.Drawing Namespace


Rectangle Constructor

[To be supplied.]

Overload List

Creates a new Rectangle. The size and location are determined from the parameters.

[Visual Basic] Overloads Public Sub New(Integer, Integer, Integer, Integer)
[C#] public Rectangle(int, int, int, int);
[C++] public: Rectangle(int, int, int, int);
[JScript] public function Rectangle(int, int, int, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Point, Size)
[C#] public Rectangle(Point, Size);
[C++] public: Rectangle(Point, Size);
[JScript] public function Rectangle(Point, Size);

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace


Rectangle Constructor (Int32, Int32, Int32, Int32)

Creates a new Rectangle. The size and location are determined from the parameters.

[Visual Basic]
Overloads Public Sub New( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer _
)
[C#]
public Rectangle(
   int x,
   int y,
   int width,
   int height
);
[C++]
public: Rectangle(
   int x,
   int y,
   int width,
   int height
);
[JScript]
public function Rectangle(
   x : int,
   y : int,
   width : int,
   height : int
);

Parameters

x
x location
y
y location
width
width
height
height

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace | Rectangle Constructor Overload List


Rectangle Constructor (Point, Size)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal location As Point, _
   ByVal size As Size _
)
[C#]
public Rectangle(
   Point location,
   Size size
);
[C++]
public: Rectangle(
   Point location,
   Size size
);
[JScript]
public function Rectangle(
   location : Point,
   size : Size
);

Parameters

location
[To be supplied.]
size
[To be supplied.]

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace | Rectangle Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Rectangle Properties

The properties of the Rectangle structure are listed below. For a complete list of Rectangle structure members, see the Rectangle Members topic.

Public:

Bottom | Retrieves the bottom value for this rectangle.
Height | [To be supplied.]
IsEmpty | [To be supplied.]
Left | Retrieves the left value for this rectangle.
Location | [To be supplied.]
Right | The right value for this rectangle.
Size | [To be supplied.]
Top | Retrieves the top value for this rectangle.
Width | [To be supplied.]
X | [To be supplied.]
Y | [To be supplied.]

See Also

Rectangle Structure | System.Drawing Namespace


Rectangle.Bottom

Retrieves the bottom value for this rectangle.

[Visual Basic]
Public ReadOnly Property Bottom As Integer
[C#]
public int Bottom {get;}
[C++]
public: __property int get_Bottom();
[JScript]
public function get Bottom() : int;

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace


Rectangle.Height

[To be supplied.]

[Visual Basic]
Public Property Height As Integer
[C#]
public int Height {get; set;}
[C++]
public: __property int get_Height();
public: __property void set_Height(int);
[JScript]
public function get Height() : int;
public function set Height(int);

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace


Rectangle.IsEmpty

[To be supplied.]

[Visual Basic]
Public ReadOnly Property IsEmpty As Boolean
[C#]
public bool IsEmpty {get;}
[C++]
public: __property bool get_IsEmpty();
[JScript]
public function get IsEmpty() : Boolean;

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace


Rectangle.Left

Retrieves the left value for this rectangle.

[Visual Basic]
Public ReadOnly Property Left As Integer
[C#]
public int Left {get;}
[C++]
public: __property int get_Left();
[JScript]
public function get Left() : int;

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace


Rectangle.Location

[To be supplied.]

[Visual Basic]
Public Property Location As Point
[C#]
public Point Location {get; set;}
[C++]
public: __property Point get_Location();
public: __property void set_Location(Point);
[JScript]
public function get Location() : Point;
public function set Location(Point);

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace


Rectangle.Right

The right value for this rectangle.

[Visual Basic]
Public ReadOnly Property Right As Integer
[C#]
public int Right {get;}
[C++]
public: __property int get_Right();
[JScript]
public function get Right() : int;

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace


Rectangle.Size

[To be supplied.]

[Visual Basic]
Public Property Size As Size
[C#]
public Size Size {get; set;}
[C++]
public: __property Size get_Size();
public: __property void set_Size(Size);
[JScript]
public function get Size() : Size;
public function set Size(Size);

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace


Rectangle.Top

Retrieves the top value for this rectangle.

[Visual Basic]
Public ReadOnly Property Top As Integer
[C#]
public int Top {get;}
[C++]
public: __property int get_Top();
[JScript]
public function get Top() : int;

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace


Rectangle.Width

[To be supplied.]

[Visual Basic]
Public Property Width As Integer
[C#]
public int Width {get; set;}
[C++]
public: __property int get_Width();
public: __property void set_Width(int);
[JScript]
public function get Width() : int;
public function set Width(int);

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace


Rectangle.X

[To be supplied.]

[Visual Basic]
Public Property X As Integer
[C#]
public int X {get; set;}
[C++]
public: __property int get_X();
public: __property void set_X(int);
[JScript]
public function get X() : int;
public function set X(int);

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace


Rectangle.Y

[To be supplied.]

[Visual Basic]
Public Property Y As Integer
[C#]
public int Y {get; set;}
[C++]
public: __property int get_Y();
public: __property void set_Y(int);
[JScript]
public function get Y() : int;
public function set Y(int);

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Rectangle Methods

The methods of the Rectangle structure are listed below. For a complete list of Rectangle structure members, see the Rectangle Members topic.

Public:

Contains | Overloaded. [To be supplied.]
Equals | [To be supplied.]
FromLTRB | [To be supplied.]
GetHashCode | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
Inflate | Overloaded. [To be supplied.]
Intersect | Overloaded. [To be supplied.]
IntersectsWith | Determines if this rectangle intersets with rect.
Offset | Overloaded. [To be supplied.]
ToString | [To be supplied.]
Union | Creates a rectangle that represents the union between a and b.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Rectangle Structure | System.Drawing Namespace


Rectangle.Contains

[To be supplied.]

Overload List

Determines if the specfied point is contained within this rectangle.

[Visual Basic] Overloads Public Function Contains(Point) As Boolean
[C#] public bool Contains(Point);
[C++] public: bool Contains(Point);
[JScript] public function Contains(Point) : Boolean;

Determines if the specfied point is contained within this rectangle.

[Visual Basic] Overloads Public Function Contains(Integer, Integer) As Boolean
[C#] public bool Contains(int, int);
[C++] public: bool Contains(int, int);
[JScript] public function Contains(int, int) : Boolean;

Determines if rect is entirely contained within this rectangle.

[Visual Basic] Overloads Public Function Contains(Rectangle) As Boolean
[C#] public bool Contains(Rectangle);
[C++] public: bool Contains(Rectangle);
[JScript] public function Contains(Rectangle) : Boolean;

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace


Rectangle.Contains (Point)

Determines if the specfied point is contained within this rectangle.

[Visual Basic]
Overloads Public Function Contains( _
   ByVal pt As Point _
) As Boolean
[C#]
public bool Contains(
   Point pt
);
[C++]
public: bool Contains(
   Point pt
);
[JScript]
public function Contains(
   pt : Point
) : Boolean;

Parameters

pt
Point to test

Return Value

true if the point is contained within this rectangle.

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace | Rectangle.Contains Overload List


Rectangle.Contains (Int32, Int32)

Determines if the specfied point is contained within this rectangle.

[Visual Basic]
Overloads Public Function Contains( _
   ByVal x As Integer, _
   ByVal y As Integer _
) As Boolean
[C#]
public bool Contains(
   int x,
   int y
);
[C++]
public: bool Contains(
   int x,
   int y
);
[JScript]
public function Contains(
   x : int,
   y : int
) : Boolean;

Parameters

x
X location to test
y
Y location to test

Return Value

true if the point is contained within this rectangle.

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace | Rectangle.Contains Overload List


Rectangle.Contains (Rectangle)

Determines if rect is entirely contained within this rectangle.

[Visual Basic]
Overloads Public Function Contains( _
   ByVal rect As Rectangle _
) As Boolean
[C#]
public bool Contains(
   Rectangle rect
);
[C++]
public: bool Contains(
   Rectangle rect
);
[JScript]
public function Contains(
   rect : Rectangle
) : Boolean;

Parameters

rect
Rectangle to test

Return Value

true if the rectangle is contained.

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace | Rectangle.Contains Overload List


Rectangle.Equals

[To be supplied.]

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
[To be supplied.]

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace


Rectangle.FromLTRB

[To be supplied.]

[Visual Basic]
Public Shared Function FromLTRB( _
   ByVal left As Integer, _
   ByVal top As Integer, _
   ByVal right As Integer, _
   ByVal bottom As Integer _
) As Rectangle
[C#]
public static Rectangle FromLTRB(
   int left,
   int top,
   int right,
   int bottom
);
[C++]
public: static Rectangle FromLTRB(
   int left,
   int top,
   int right,
   int bottom
);
[JScript]
public static function FromLTRB(
   left : int,
   top : int,
   right : int,
   bottom : int
) : Rectangle;

Parameters

left
[To be supplied.]
top
[To be supplied.]
right
[To be supplied.]
bottom
[To be supplied.]

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace


Rectangle.GetHashCode

[To be supplied.]

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace


Rectangle.Inflate

[To be supplied.]

Overload List

Creates a rectangle that is inflated by the specified amount. If a negative size is specified the rectangle will be deflated.

[Visual Basic] Overloads Public Shared Function Inflate(Rectangle, Integer, Integer) As Rectangle
[C#] public static Rectangle Inflate(Rectangle, int, int);
[C++] public: static Rectangle Inflate(Rectangle, int, int);
[JScript] public static function Inflate(Rectangle, int, int) : Rectangle;

Inflates this rectangle by the specified amount. If a negative size is specified the rectangle will be deflated.

[Visual Basic] Overloads Public Sub Inflate(Size)
[C#] public void Inflate(Size);
[C++] public: void Inflate(Size);
[JScript] public function Inflate(Size);

Inflates this rectangle by the specified amount. If a negative size is specified the rectangle will be deflated.

[Visual Basic] Overloads Public Sub Inflate(Integer, Integer)
[C#] public void Inflate(int, int);
[C++] public: void Inflate(int, int);
[JScript] public function Inflate(int, int);

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace


Rectangle.Inflate (Rectangle, Int32, Int32)

Creates a rectangle that is inflated by the specified amount. If a negative size is specified the rectangle will be deflated.

[Visual Basic]
Overloads Public Shared Function Inflate( _
   ByVal rect As Rectangle, _
   ByVal x As Integer, _
   ByVal y As Integer _
) As Rectangle
[C#]
public static Rectangle Inflate(
   Rectangle rect,
   int x,
   int y
);
[C++]
public: static Rectangle Inflate(
   Rectangle rect,
   int x,
   int y
);
[JScript]
public static function Inflate(
   rect : Rectangle,
   x : int,
   y : int
) : Rectangle;

Parameters

rect
Rectangle to base the operation on. This rectangle will not be modified.
x
Amount to inflate this rectangle horizontally.
y
Amount to inflate this rectangle vertically.

Return Value

the resulting rectangle.

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace | Rectangle.Inflate Overload List


Rectangle.Inflate (Size)

Inflates this rectangle by the specified amount. If a negative size is specified the rectangle will be deflated.

[Visual Basic]
Overloads Public Sub Inflate( _
   ByVal size As Size _
)
[C#]
public void Inflate(
   Size size
);
[C++]
public: void Inflate(
   Size size
);
[JScript]
public function Inflate(
   size : Size
);

Parameters

size
Amount to inflate this rectangle.

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace | Rectangle.Inflate Overload List


Rectangle.Inflate (Int32, Int32)

Inflates this rectangle by the specified amount. If a negative size is specified the rectangle will be deflated.

[Visual Basic]
Overloads Public Sub Inflate( _
   ByVal x As Integer, _
   ByVal y As Integer _
)
[C#]
public void Inflate(
   int x,
   int y
);
[C++]
public: void Inflate(
   int x,
   int y
);
[JScript]
public function Inflate(
   x : int,
   y : int
);

Parameters

x
Amount to inflate this rectangle horizontally.
y
Amount to inflate this rectangle vertically.

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace | Rectangle.Inflate Overload List


Rectangle.Intersect

[To be supplied.]

Overload List

Creates a rectangle.

[Visual Basic] Overloads Public Sub Intersect(Rectangle)
[C#] public void Intersect(Rectangle);
[C++] public: void Intersect(Rectangle);
[JScript] public function Intersect(Rectangle);

Creates a rectangle that represents the intersetion between a and b. If there is no intersection, null is returned.

[Visual Basic] Overloads Public Shared Function Intersect(Rectangle, Rectangle) As Rectangle
[C#] public static Rectangle Intersect(Rectangle, Rectangle);
[C++] public: static Rectangle Intersect(Rectangle, Rectangle);
[JScript] public static function Intersect(Rectangle, Rectangle) : Rectangle;

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace


Rectangle.Intersect (Rectangle)

Creates a rectangle.

[Visual Basic]
Overloads Public Sub Intersect( _
   ByVal rect As Rectangle _
)
[C#]
public void Intersect(
   Rectangle rect
);
[C++]
public: void Intersect(
   Rectangle rect
);
[JScript]
public function Intersect(
   rect : Rectangle
);

Parameters

rect
Rectangle to create

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace | Rectangle.Intersect Overload List


Rectangle.Intersect (Rectangle, Rectangle)

Creates a rectangle that represents the intersetion between a and b. If there is no intersection, null is returned.

[Visual Basic]
Overloads Public Shared Function Intersect( _
   ByVal a As Rectangle, _
   ByVal b As Rectangle _
) As Rectangle
[C#]
public static Rectangle Intersect(
   Rectangle a,
   Rectangle b
);
[C++]
public: static Rectangle Intersect(
   Rectangle a,
   Rectangle b
);
[JScript]
public static function Intersect(
   a : Rectangle,
   b : Rectangle
) : Rectangle;

Parameters

a
Rectangle to intersect
b
Rectangle to intersect

Return Value

the insected region

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace | Rectangle.Intersect Overload List


Rectangle.IntersectsWith

Determines if this rectangle intersets with rect.

[Visual Basic]
Public Function IntersectsWith( _
   ByVal rect As Rectangle _
) As Boolean
[C#]
public bool IntersectsWith(
   Rectangle rect
);
[C++]
public: bool IntersectsWith(
   Rectangle rect
);
[JScript]
public function IntersectsWith(
   rect : Rectangle
) : Boolean;

Parameters

rect
Rectangle to test

Return Value

true if there is any intersection

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace


Rectangle.Offset

[To be supplied.]

Overload List

Adjusts the location of this rectangle by the specified amount.

[Visual Basic] Overloads Public Sub Offset(Point)
[C#] public void Offset(Point);
[C++] public: void Offset(Point);
[JScript] public function Offset(Point);

Adjusts the location of this rectangle by the specified amount.

[Visual Basic] Overloads Public Sub Offset(Integer, Integer)
[C#] public void Offset(int, int);
[C++] public: void Offset(int, int);
[JScript] public function Offset(int, int);

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace


Rectangle.Offset (Point)

Adjusts the location of this rectangle by the specified amount.

[Visual Basic]
Overloads Public Sub Offset( _
   ByVal pos As Point _
)
[C#]
public void Offset(
   Point pos
);
[C++]
public: void Offset(
   Point pos
);
[JScript]
public function Offset(
   pos : Point
);

Parameters

pos
Amount to offset the location

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace | Rectangle.Offset Overload List


Rectangle.Offset (Int32, Int32)

Adjusts the location of this rectangle by the specified amount.

[Visual Basic]
Overloads Public Sub Offset( _
   ByVal x As Integer, _
   ByVal y As Integer _
)
[C#]
public void Offset(
   int x,
   int y
);
[C++]
public: void Offset(
   int x,
   int y
);
[JScript]
public function Offset(
   x : int,
   y : int
);

Parameters

x
Amount to offset the location horizontally
y
Amount to offset the location vertically

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace | Rectangle.Offset Overload List


Rectangle.ToString

[To be supplied.]

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace


Rectangle.Union

Creates a rectangle that represents the union between a and b.

[Visual Basic]
Public Shared Function Union( _
   ByVal a As Rectangle, _
   ByVal b As Rectangle _
) As Rectangle
[C#]
public static Rectangle Union(
   Rectangle a,
   Rectangle b
);
[C++]
public: static Rectangle Union(
   Rectangle a,
   Rectangle b
);
[JScript]
public static function Union(
   a : Rectangle,
   b : Rectangle
) : Rectangle;

Parameters

a
Rectangle to union
b
Rectangle to union

Return Value

the unioned region.

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace


Operators

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Rectangle Operators

The operators of the Rectangle structure are listed below. For a complete list of Rectangle structure members, see the Rectangle Members topic.

Public:

Equality Operator | [To be supplied.]
Inequality Operator | [To be supplied.]

See Also

Rectangle Structure | System.Drawing Namespace


Rectangle Equality Operator

[To be supplied.]

[C#]
public static bool operator ==(
   Rectangle left,
   Rectangle right
);
[C++]
public: static bool operator op_Equality(
   Rectangle left,
   Rectangle right
);
[JScript]
returnValue = left == right;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

left
[To be supplied.]
right
[To be supplied.]

Parameters [C#, C++]

left
[To be supplied.]
right
[To be supplied.]

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace


Rectangle Inequality Operator

[To be supplied.]

[C#]
public static bool operator !=(
   Rectangle left,
   Rectangle right
);
[C++]
public: static bool operator op_Inequality(
   Rectangle left,
   Rectangle right
);
[JScript]
returnValue = left ! = right;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

left
[To be supplied.]
right
[To be supplied.]

Parameters [C#, C++]

left
[To be supplied.]
right
[To be supplied.]

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Rectangle Fields

The fields of the Rectangle structure are listed below. For a complete list of Rectangle structure members, see the Rectangle Members topic.

Public:

Empty [To be supplied.]

See Also

Rectangle Structure | System.Drawing Namespace


Rectangle.Empty

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Empty As Rectangle
[C#]
public static readonly Rectangle Empty;
[C++]
public: static readonly Rectangle Empty;
[JScript]
public static var Empty : Rectangle;

See Also

Rectangle Structure | Rectangle Members | System.Drawing Namespace


RectangleConverter Class

RectangleConverter is a class that can be used to convert rectangles from one data type to another. Access this class through the TypeDescriptor.

Object
TypeConverter
RectangleConverter

[Visual Basic]
Public Class RectangleConverter
   Inherits TypeConverter
[C#]
public class RectangleConverter : TypeConverter
[C++]
public __gc class RectangleConverter : public TypeConverter
[JScript]
public class RectangleConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

RectangleConverter Members | System.Drawing Namespace


RectangleConverter Members

Public:

Constructor

RectangleConverter Constructor [To be supplied.]

Methods

CanConvertFrom (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type.
ConvertFrom | Overloaded. [To be supplied.]
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text into an object.
ConvertTo | Overloaded. [To be supplied.]
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetProperties (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValues (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid (inherited from TypeConverter) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

RectangleConverter Class | System.Drawing Namespace


RectangleConverter Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public RectangleConverter();
[C++]
public: RectangleConverter();
[JScript]
public function RectangleConverter();

See Also

RectangleConverter Class | RectangleConverter Members | System.Drawing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RectangleConverter Methods

The methods of the RectangleConverter class are listed below. For a complete list of RectangleConverter class members, see the RectangleConverter Members topic.

Public:

CanConvertFrom (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type.
ConvertFrom | Overloaded. [To be supplied.]
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text into an object.
ConvertTo | Overloaded. [To be supplied.]
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetProperties (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValues (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid (inherited from TypeConverter) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

RectangleConverter Class | System.Drawing Namespace


RectangleConverter.CanConvertFrom

Determines if this converter can convert an object in the given source type to the native type of the converter.

[Visual Basic]
Overrides Public Function CanConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal sourceType As Type _
) As Boolean
[C#]
public override bool CanConvertFrom(
   ITypeDescriptorContext context,
   Type sourceType
);
[C++]
public: override bool CanConvertFrom(
   ITypeDescriptorContext* context,
   Type* sourceType
);
[JScript]
public override function CanConvertFrom(
   context : ITypeDescriptorContext,
   sourceType : Type
) : Boolean;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
sourceType
The type you wish to convert from.

Return Value

True if this object can perform the conversion.

See Also

RectangleConverter Class | RectangleConverter Members | System.Drawing Namespace


RectangleConverter.ConvertFrom

Converts the given object to the converter's native type.

[Visual Basic]
Overrides Public Function ConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal arguments() As Object _
) As Object
[C#]
public override object ConvertFrom(
   ITypeDescriptorContext context,
   object value,
   object[] arguments
);
[C++]
public: override Object* ConvertFrom(
   ITypeDescriptorContext* context,
   Object* value,
   Object* arguments[]
);
[JScript]
public override function ConvertFrom(
   context : ITypeDescriptorContext,
   value : Object,
   arguments : Object[]
) : Object;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
value
The object to convert.
arguments
An optional array of arguments to use when doing the conversion. The number and content of these arguments is dependent on the implementer of the value formatter.

Return Value

The converted object. This will throw an excetpion if the converson could not be performed.

See Also

RectangleConverter Class | RectangleConverter Members | System.Drawing Namespace


RectangleConverter.ConvertTo

Converts the given object to another type. The most common types to convert are to and from a string object. The default implementation will make a call to ToString on the object if the object is valid and if the destination type is string. If this cannot convert to the desitnation type, this will throw a NotSupportedException.

[Visual Basic]
Overrides Public Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal destinationType As Type, _
   ByVal arguments() As Object _
) As Object
[C#]
public override object ConvertTo(
   ITypeDescriptorContext context,
   object value,
   Type destinationType,
   object[] arguments
);
[C++]
public: override Object* ConvertTo(
   ITypeDescriptorContext* context,
   Object* value,
   Type* destinationType,
   Object* arguments[]
);
[JScript]
public override function ConvertTo(
   context : ITypeDescriptorContext,
   value : Object,
   destinationType : Type,
   arguments : Object[]
) : Object;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
value
The object to convert.
destinationType
The type to convert the object to.
arguments
An optional array of arguments to use when doing the conversion. The number and content of these arguments is dependent on the implementer of the value formatter.

Return Value

The converted object.

See Also

RectangleConverter Class | RectangleConverter Members | System.Drawing Namespace


RectangleConverter.CreateInstance

[To be supplied.]

Overload List

Recreates an object given its PersistInfo. This information was generated by a prior call to GetPersistInfo.

[Visual Basic] Overloads Overrides Public Function CreateInstance(ITypeDescriptorContext, PersistInfo) As Object
[C#] public override object CreateInstance(ITypeDescriptorContext, PersistInfo);
[C++] public: override Object* CreateInstance(ITypeDescriptorContext*, PersistInfo);
[JScript] public override function CreateInstance(ITypeDescriptorContext, PersistInfo) : Object;

Creates an instance of this type given a set of property values for the object. This is useful for objects that are immutable, but still want to provide changable properties.

[Visual Basic] Overloads Overrides Public Function CreateInstance(ITypeDescriptorContext, IDictionary) As Object
[C#] public override object CreateInstance(ITypeDescriptorContext, IDictionary);
[C++] public: override Object* CreateInstance(ITypeDescriptorContext*, IDictionary);
[JScript] public override function CreateInstance(ITypeDescriptorContext, IDictionary) : Object;

See Also

RectangleConverter Class | RectangleConverter Members | System.Drawing Namespace


RectangleConverter.CreateInstance (ITypeDescriptorContext, PersistInfo)

Recreates an object given its PersistInfo. This information was generated by a prior call to GetPersistInfo.

[Visual Basic]
Overloads Overrides Public Function CreateInstance( _
   ByVal context As ITypeDescriptorContext, _
   ByVal persistInfo As PersistInfo _
) As Object
[C#]
public override object CreateInstance(
   ITypeDescriptorContext context,
   PersistInfo persistInfo
);
[C++]
public: override Object* CreateInstance(
   ITypeDescriptorContext* context,
   PersistInfo* persistInfo
);
[JScript]
public override function CreateInstance(
   context : ITypeDescriptorContext,
   persistInfo : PersistInfo
) : Object;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
persistInfo
The persistence information to use when re-creating the object.

Return Value

An object representing the given PersistInfo.

See Also

RectangleConverter Class | RectangleConverter Members | System.Drawing Namespace | RectangleConverter.CreateInstance Overload List | PersistInfo | TBD


RectangleConverter.CreateInstance (ITypeDescriptorContext, IDictionary)

Creates an instance of this type given a set of property values for the object. This is useful for objects that are immutable, but still want to provide changable properties.

[Visual Basic]
Overloads Overrides Public Function CreateInstance( _
   ByVal context As ITypeDescriptorContext, _
   ByVal propertyValues As IDictionary _
) As Object
[C#]
public override object CreateInstance(
   ITypeDescriptorContext context,
   IDictionary propertyValues
);
[C++]
public: override Object* CreateInstance(
   ITypeDescriptorContext* context,
   IDictionary* propertyValues
);
[JScript]
public override function CreateInstance(
   context : ITypeDescriptorContext,
   propertyValues : IDictionary
) : Object;

Parameters

context
A type descriptor through which additional context may be provided.
propertyValues
A dictionary of new property values. The dictionary contains a series of name-value pairs, one for each property returned from GetProperties.

Return Value

The newly created object, or null if the object could not be created. The default implementation returns null.

See Also

RectangleConverter Class | RectangleConverter Members | System.Drawing Namespace | RectangleConverter.CreateInstance Overload List


RectangleConverter.GetCreateInstanceSupported

Determines if changing a value on this object should require a call to CreateInstance to create a new value.

[Visual Basic]
Overrides Public Function GetCreateInstanceSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
[C#]
public override bool GetCreateInstanceSupported(
   ITypeDescriptorContext context
);
[C++]
public: override bool GetCreateInstanceSupported(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetCreateInstanceSupported(
   context : ITypeDescriptorContext
) : Boolean;

Parameters

context
A type descriptor through which additional context may be provided.

Return Value

Returns true if CreateInstance should be called when a change is made to one or more properties of this object.

See Also

RectangleConverter Class | RectangleConverter Members | System.Drawing Namespace


RectangleConverter.GetPersistInfo

Retrieves the PersistInfo object for the given value. This object describes the given value as persisted information, which can be saved to disk or moved. This information can later be reconstructed by passing the PersistInfo to GetValue.

[Visual Basic]
Overrides Public Function GetPersistInfo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As PersistInfo
[C#]
public override PersistInfo GetPersistInfo(
   ITypeDescriptorContext context,
   object value
);
[C++]
public: override PersistInfo* GetPersistInfo(
   ITypeDescriptorContext* context,
   Object* value
);
[JScript]
public override function GetPersistInfo(
   context : ITypeDescriptorContext,
   value : Object
) : PersistInfo;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
value
The object to persist.

Return Value

The PersistInfo representing the persisted state of the given object.

See Also

RectangleConverter Class | RectangleConverter Members | System.Drawing Namespace | PersistInfo | TBD


RectangleConverter.GetProperties

Retrieves the set of properties for this type. By default, a type has does not return any properties. An easy implementation of this method can just call TypeDescriptor.GetProperties for the correct data type.

[Visual Basic]
Overrides Public Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal attributes() As MemberAttribute _
) As PropertyDescriptorCollection
[C#]
public override PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value,
   MemberAttribute[] attributes
);
[C++]
public: override PropertyDescriptorCollection* GetProperties(
   ITypeDescriptorContext* context,
   Object* value,
   MemberAttribute* attributes[]
);
[JScript]
public override function GetProperties(
   context : ITypeDescriptorContext,
   value : Object,
   attributes : MemberAttribute[]
) : PropertyDescriptorCollection;

Parameters

context
A type descriptor through which additional context may be provided.
value
The value of the object to get the properties for.
attributes
[To be supplied.]

Return Value

The set of properties that should be exposed for this data type. If no properties should be exposed, thsi may return null. The default implementation always returns null.

See Also

RectangleConverter Class | RectangleConverter Members | System.Drawing Namespace


RectangleConverter.GetPropertiesSupported

Determines if this object supports properties. By default, this is false.

[Visual Basic]
Overrides Public Function GetPropertiesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
[C#]
public override bool GetPropertiesSupported(
   ITypeDescriptorContext context
);
[C++]
public: override bool GetPropertiesSupported(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetPropertiesSupported(
   context : ITypeDescriptorContext
) : Boolean;

Parameters

context
A type descriptor through which additional context may be provided.

Return Value

Returns true if GetProperties should be called to find the properties of this object.

See Also

RectangleConverter Class | RectangleConverter Members | System.Drawing Namespace


RectangleF Structure

RectangleF. Stores the location and size of a rectangular region. For more advanced region functions use a Region object.

Object
ValueType
RectangleF

[Visual Basic]
Public Structure RectangleF
[C#]
public struct RectangleF
[C++]
public __value struct RectangleF

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

RectangleF Members | System.Drawing Namespace | Region


RectangleF Members

Public:

Constructor

RectangleF Constructor Overloaded. [To be supplied.]

Properties

Bottom | Retrieves the bottom value for this RectangleF.
Height | [To be supplied.]
IsEmpty | [To be supplied.]
Left | Retrieves the left value for this RectangleF.
Location | [To be supplied.]
Right | The right value for this RectangleF.
Size | [To be supplied.]
Top | Retrieves the top value for this RectangleF.
Width | [To be supplied.]
X | [To be supplied.]
Y | [To be supplied.]

Methods

Contains | Overloaded. [To be supplied.]
Equals | [To be supplied.]
FromLTRB | [To be supplied.]
GetHashCode | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
Inflate | Overloaded. [To be supplied.]
Intersect | Overloaded. [To be supplied.]
IntersectsWith | Determines if this RectangleF intersets with rect.
Offset | Overloaded. [To be supplied.]
ToString | [To be supplied.]
Union | Creates a RectangleF that represents the union between a and b.

Operators and Type Conversions

Equality Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
RectangleF to Rectangle Conversion | [To be supplied.]
Rectangle to RectangleF Conversion | [To be supplied.]

Fields

Empty [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RectangleF Structure | System.Drawing Namespace


RectangleF Constructor

[To be supplied.]

Overload List

Creates a new RectangleF. The size and location are determined from the parameters.

[Visual Basic] Overloads Public Sub New(Single, Single, Single, Single)
[C#] public RectangleF(float, float, float, float);
[C++] public: RectangleF(float, float, float, float);
[JScript] public function RectangleF(float, float, float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(PointF, SizeF)
[C#] public RectangleF(PointF, SizeF);
[C++] public: RectangleF(PointF, SizeF);
[JScript] public function RectangleF(PointF, SizeF);

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace


RectangleF Constructor (Single, Single, Single, Single)

Creates a new RectangleF. The size and location are determined from the parameters.

[Visual Basic]
Overloads Public Sub New( _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
[C#]
public RectangleF(
   float x,
   float y,
   float width,
   float height
);
[C++]
public: RectangleF(
   float x,
   float y,
   float width,
   float height
);
[JScript]
public function RectangleF(
   x : float,
   y : float,
   width : float,
   height : float
);

Parameters

x
x location
y
y location
width
width
height
height

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace | RectangleF Constructor Overload List


RectangleF Constructor (PointF, SizeF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal location As PointF, _
   ByVal size As SizeF _
)
[C#]
public RectangleF(
   PointF location,
   SizeF size
);
[C++]
public: RectangleF(
   PointF location,
   SizeF size
);
[JScript]
public function RectangleF(
   location : PointF,
   size : SizeF
);

Parameters

location
[To be supplied.]
size
[To be supplied.]

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace | RectangleF Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RectangleF Properties

The properties of the RectangleF structure are listed below. For a complete list of RectangleF structure members, see the RectangleF Members topic.

Public:

Bottom | Retrieves the bottom value for this RectangleF.
Height | [To be supplied.]
IsEmpty | [To be supplied.]
Left | Retrieves the left value for this RectangleF.
Location | [To be supplied.]
Right | The right value for this RectangleF.
Size | [To be supplied.]
Top | Retrieves the top value for this RectangleF.
Width | [To be supplied.]
X | [To be supplied.]
Y | [To be supplied.]

See Also

RectangleF Structure | System.Drawing Namespace


RectangleF.Bottom

Retrieves the bottom value for this RectangleF.

[Visual Basic]
Public ReadOnly Property Bottom As Single
[C#]
public float Bottom {get;}
[C++]
public: __property float get_Bottom();
[JScript]
public function get Bottom() : float;

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace


RectangleF.Height

[To be supplied.]

[Visual Basic]
Public Property Height As Single
[C#]
public float Height {get; set;}
[C++]
public: __property float get_Height();
public: __property void set_Height(float);
[JScript]
public function get Height() : float;
public function set Height(float);

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace


RectangleF.IsEmpty

[To be supplied.]

[Visual Basic]
Public ReadOnly Property IsEmpty As Boolean
[C#]
public bool IsEmpty {get;}
[C++]
public: __property bool get_IsEmpty();
[JScript]
public function get IsEmpty() : Boolean;

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace


RectangleF.Left

Retrieves the left value for this RectangleF.

[Visual Basic]
Public ReadOnly Property Left As Single
[C#]
public float Left {get;}
[C++]
public: __property float get_Left();
[JScript]
public function get Left() : float;

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace


RectangleF.Location

[To be supplied.]

[Visual Basic]
Public Property Location As PointF
[C#]
public PointF Location {get; set;}
[C++]
public: __property PointF get_Location();
public: __property void set_Location(PointF);
[JScript]
public function get Location() : PointF;
public function set Location(PointF);

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace


RectangleF.Right

The right value for this RectangleF.

[Visual Basic]
Public ReadOnly Property Right As Single
[C#]
public float Right {get;}
[C++]
public: __property float get_Right();
[JScript]
public function get Right() : float;

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace


RectangleF.Size

[To be supplied.]

[Visual Basic]
Public Property Size As SizeF
[C#]
public SizeF Size {get; set;}
[C++]
public: __property SizeF get_Size();
public: __property void set_Size(SizeF);
[JScript]
public function get Size() : SizeF;
public function set Size(SizeF);

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace


RectangleF.Top

Retrieves the top value for this RectangleF.

[Visual Basic]
Public ReadOnly Property Top As Single
[C#]
public float Top {get;}
[C++]
public: __property float get_Top();
[JScript]
public function get Top() : float;

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace


RectangleF.Width

[To be supplied.]

[Visual Basic]
Public Property Width As Single
[C#]
public float Width {get; set;}
[C++]
public: __property float get_Width();
public: __property void set_Width(float);
[JScript]
public function get Width() : float;
public function set Width(float);

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace


RectangleF.X

[To be supplied.]

[Visual Basic]
Public Property X As Single
[C#]
public float X {get; set;}
[C++]
public: __property float get_X();
public: __property void set_X(float);
[JScript]
public function get X() : float;
public function set X(float);

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace


RectangleF.Y

[To be supplied.]

[Visual Basic]
Public Property Y As Single
[C#]
public float Y {get; set;}
[C++]
public: __property float get_Y();
public: __property void set_Y(float);
[JScript]
public function get Y() : float;
public function set Y(float);

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RectangleF Methods

The methods of the RectangleF structure are listed below. For a complete list of RectangleF structure members, see the RectangleF Members topic.

Public:

Contains | Overloaded. [To be supplied.]
Equals | [To be supplied.]
FromLTRB | [To be supplied.]
GetHashCode | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
Inflate | Overloaded. [To be supplied.]
Intersect | Overloaded. [To be supplied.]
IntersectsWith | Determines if this RectangleF intersets with rect.
Offset | Overloaded. [To be supplied.]
ToString | [To be supplied.]
Union | Creates a RectangleF that represents the union between a and b.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RectangleF Structure | System.Drawing Namespace


RectangleF.Contains

[To be supplied.]

Overload List

Determines if the specfied point is contained within this RectangleF.

[Visual Basic] Overloads Public Function Contains(PointF) As Boolean
[C#] public bool Contains(PointF);
[C++] public: bool Contains(PointF);
[JScript] public function Contains(PointF) : Boolean;

Determines if the specfied point is contained within this RectangleF.

[Visual Basic] Overloads Public Function Contains(Single, Single) As Boolean
[C#] public bool Contains(float, float);
[C++] public: bool Contains(float, float);
[JScript] public function Contains(float, float) : Boolean;

Determines if rect is entirely contained within this RectangleF.

[Visual Basic] Overloads Public Function Contains(RectangleF) As Boolean
[C#] public bool Contains(RectangleF);
[C++] public: bool Contains(RectangleF);
[JScript] public function Contains(RectangleF) : Boolean;

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace


RectangleF.Contains (PointF)

Determines if the specfied point is contained within this RectangleF.

[Visual Basic]
Overloads Public Function Contains( _
   ByVal pt As PointF _
) As Boolean
[C#]
public bool Contains(
   PointF pt
);
[C++]
public: bool Contains(
   PointF pt
);
[JScript]
public function Contains(
   pt : PointF
) : Boolean;

Parameters

pt
PointF to test

Return Value

true if the point is contained within this RectangleF.

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace | RectangleF.Contains Overload List


RectangleF.Contains (Single, Single)

Determines if the specfied point is contained within this RectangleF.

[Visual Basic]
Overloads Public Function Contains( _
   ByVal x As Single, _
   ByVal y As Single _
) As Boolean
[C#]
public bool Contains(
   float x,
   float y
);
[C++]
public: bool Contains(
   float x,
   float y
);
[JScript]
public function Contains(
   x : float,
   y : float
) : Boolean;

Parameters

x
X location to test
y
Y location to test

Return Value

true if the point is contained within this RectangleF.

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace | RectangleF.Contains Overload List


RectangleF.Contains (RectangleF)

Determines if rect is entirely contained within this RectangleF.

[Visual Basic]
Overloads Public Function Contains( _
   ByVal rect As RectangleF _
) As Boolean
[C#]
public bool Contains(
   RectangleF rect
);
[C++]
public: bool Contains(
   RectangleF rect
);
[JScript]
public function Contains(
   rect : RectangleF
) : Boolean;

Parameters

rect
RectangleF to test

Return Value

true if the RectangleF is contained.

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace | RectangleF.Contains Overload List


RectangleF.Equals

[To be supplied.]

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
[To be supplied.]

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace


RectangleF.FromLTRB

[To be supplied.]

[Visual Basic]
Public Shared Function FromLTRB( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal right As Single, _
   ByVal bottom As Single _
) As RectangleF
[C#]
public static RectangleF FromLTRB(
   float left,
   float top,
   float right,
   float bottom
);
[C++]
public: static RectangleF FromLTRB(
   float left,
   float top,
   float right,
   float bottom
);
[JScript]
public static function FromLTRB(
   left : float,
   top : float,
   right : float,
   bottom : float
) : RectangleF;

Parameters

left
[To be supplied.]
top
[To be supplied.]
right
[To be supplied.]
bottom
[To be supplied.]

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace


RectangleF.GetHashCode

[To be supplied.]

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace


RectangleF.Inflate

[To be supplied.]

Overload List

Inflates this RectangleF by the specified amount. If a negative size is specified the RectangleF will be deflated.

[Visual Basic] Overloads Public Sub Inflate(SizeF)
[C#] public void Inflate(SizeF);
[C++] public: void Inflate(SizeF);
[JScript] public function Inflate(SizeF);

Inflates this RectangleF by the specified amount. If a negative size is specified the RectangleF will be deflated.

[Visual Basic] Overloads Public Sub Inflate(Single, Single)
[C#] public void Inflate(float, float);
[C++] public: void Inflate(float, float);
[JScript] public function Inflate(float, float);

Creates a RectangleF that is inflated by the specified amount. If a negative size is specified the RectangleF will be deflated.

[Visual Basic] Overloads Public Shared Function Inflate(RectangleF, Single, Single) As RectangleF
[C#] public static RectangleF Inflate(RectangleF, float, float);
[C++] public: static RectangleF Inflate(RectangleF, float, float);
[JScript] public static function Inflate(RectangleF, float, float) : RectangleF;

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace


RectangleF.Inflate (SizeF)

Inflates this RectangleF by the specified amount. If a negative size is specified the RectangleF will be deflated.

[Visual Basic]
Overloads Public Sub Inflate( _
   ByVal size As SizeF _
)
[C#]
public void Inflate(
   SizeF size
);
[C++]
public: void Inflate(
   SizeF size
);
[JScript]
public function Inflate(
   size : SizeF
);

Parameters

size
Amount to inflate this RectangleF.

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace | RectangleF.Inflate Overload List


RectangleF.Inflate (Single, Single)

Inflates this RectangleF by the specified amount. If a negative size is specified the RectangleF will be deflated.

[Visual Basic]
Overloads Public Sub Inflate( _
   ByVal x As Single, _
   ByVal y As Single _
)
[C#]
public void Inflate(
   float x,
   float y
);
[C++]
public: void Inflate(
   float x,
   float y
);
[JScript]
public function Inflate(
   x : float,
   y : float
);

Parameters

x
Amount to inflate this RectangleF horizontally.
y
Amount to inflate this RectangleF vertically.

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace | RectangleF.Inflate Overload List


RectangleF.Inflate (RectangleF, Single, Single)

Creates a RectangleF that is inflated by the specified amount. If a negative size is specified the RectangleF will be deflated.

[Visual Basic]
Overloads Public Shared Function Inflate( _
   ByVal rect As RectangleF, _
   ByVal x As Single, _
   ByVal y As Single _
) As RectangleF
[C#]
public static RectangleF Inflate(
   RectangleF rect,
   float x,
   float y
);
[C++]
public: static RectangleF Inflate(
   RectangleF rect,
   float x,
   float y
);
[JScript]
public static function Inflate(
   rect : RectangleF,
   x : float,
   y : float
) : RectangleF;

Parameters

rect
RectangleF to base the operation on. This RectangleF will not be modified.
x
Amount to inflate this RectangleF horizontally.
y
Amount to inflate this RectangleF vertically.

Return Value

the resulting RectangleF.

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace | RectangleF.Inflate Overload List


RectangleF.Intersect

[To be supplied.]

Overload List

Creates a RectangleF that represents the intersetion between a and b. If there is no intersection, null is returned.

[Visual Basic] Overloads Public Shared Function Intersect(RectangleF, RectangleF) As RectangleF
[C#] public static RectangleF Intersect(RectangleF, RectangleF);
[C++] public: static RectangleF Intersect(RectangleF, RectangleF);
[JScript] public static function Intersect(RectangleF, RectangleF) : RectangleF;

Creates a RectangleF.

[Visual Basic] Overloads Public Sub Intersect(RectangleF)
[C#] public void Intersect(RectangleF);
[C++] public: void Intersect(RectangleF);
[JScript] public function Intersect(RectangleF);

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace


RectangleF.Intersect (RectangleF, RectangleF)

Creates a RectangleF that represents the intersetion between a and b. If there is no intersection, null is returned.

[Visual Basic]
Overloads Public Shared Function Intersect( _
   ByVal a As RectangleF, _
   ByVal b As RectangleF _
) As RectangleF
[C#]
public static RectangleF Intersect(
   RectangleF a,
   RectangleF b
);
[C++]
public: static RectangleF Intersect(
   RectangleF a,
   RectangleF b
);
[JScript]
public static function Intersect(
   a : RectangleF,
   b : RectangleF
) : RectangleF;

Parameters

a
RectangleF to intersect
b
RectangleF to intersect

Return Value

the insected region

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace | RectangleF.Intersect Overload List


RectangleF.Intersect (RectangleF)

Creates a RectangleF.

[Visual Basic]
Overloads Public Sub Intersect( _
   ByVal rect As RectangleF _
)
[C#]
public void Intersect(
   RectangleF rect
);
[C++]
public: void Intersect(
   RectangleF rect
);
[JScript]
public function Intersect(
   rect : RectangleF
);

Parameters

rect
[To be supplied.]

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace | RectangleF.Intersect Overload List


RectangleF.IntersectsWith

Determines if this RectangleF intersets with rect.

[Visual Basic]
Public Function IntersectsWith( _
   ByVal rect As RectangleF _
) As Boolean
[C#]
public bool IntersectsWith(
   RectangleF rect
);
[C++]
public: bool IntersectsWith(
   RectangleF rect
);
[JScript]
public function IntersectsWith(
   rect : RectangleF
) : Boolean;

Parameters

rect
RectangleF to test

Return Value

true if there is any intersection

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace


RectangleF.Offset

[To be supplied.]

Overload List

Adjusts the location of this RectangleF by the specified amount.

[Visual Basic] Overloads Public Sub Offset(Single, Single)
[C#] public void Offset(float, float);
[C++] public: void Offset(float, float);
[JScript] public function Offset(float, float);

Adjusts the location of this RectangleF by the specified amount.

[Visual Basic] Overloads Public Sub Offset(PointF)
[C#] public void Offset(PointF);
[C++] public: void Offset(PointF);
[JScript] public function Offset(PointF);

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace


RectangleF.Offset (Single, Single)

Adjusts the location of this RectangleF by the specified amount.

[Visual Basic]
Overloads Public Sub Offset( _
   ByVal x As Single, _
   ByVal y As Single _
)
[C#]
public void Offset(
   float x,
   float y
);
[C++]
public: void Offset(
   float x,
   float y
);
[JScript]
public function Offset(
   x : float,
   y : float
);

Parameters

x
Amount to offset the location horizontally
y
Amount to offset the location vertically

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace | RectangleF.Offset Overload List


RectangleF.Offset (PointF)

Adjusts the location of this RectangleF by the specified amount.

[Visual Basic]
Overloads Public Sub Offset( _
   ByVal pos As PointF _
)
[C#]
public void Offset(
   PointF pos
);
[C++]
public: void Offset(
   PointF pos
);
[JScript]
public function Offset(
   pos : PointF
);

Parameters

pos
Amount to offset the location

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace | RectangleF.Offset Overload List


RectangleF.ToString

[To be supplied.]

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace


RectangleF.Union

Creates a RectangleF that represents the union between a and b.

[Visual Basic]
Public Shared Function Union( _
   ByVal a As RectangleF, _
   ByVal b As RectangleF _
) As RectangleF
[C#]
public static RectangleF Union(
   RectangleF a,
   RectangleF b
);
[C++]
public: static RectangleF Union(
   RectangleF a,
   RectangleF b
);
[JScript]
public static function Union(
   a : RectangleF,
   b : RectangleF
) : RectangleF;

Parameters

a
RectangleF to union
b
RectangleF to union

Return Value

the unioned region.

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace


Operators and Type Conversions

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RectangleF Operators and Type Conversions

The operators and type conversions of the RectangleF structure are listed below. For a complete list of RectangleF structure members, see the RectangleF Members topic.

Public:

Equality Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
RectangleF to Rectangle Conversion | [To be supplied.]
Rectangle to RectangleF Conversion | [To be supplied.]

See Also

RectangleF Structure | System.Drawing Namespace


RectangleF Equality Operator

[To be supplied.]

[C#]
public static bool operator ==(
   RectangleF left,
   RectangleF right
);
[C++]
public: static bool operator op_Equality(
   RectangleF left,
   RectangleF right
);
[JScript]
returnValue = left == right;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

left
[To be supplied.]
right
[To be supplied.]

Parameters [C#, C++]

left
[To be supplied.]
right
[To be supplied.]

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace


RectangleF Inequality Operator

[To be supplied.]

[C#]
public static bool operator !=(
   RectangleF left,
   RectangleF right
);
[C++]
public: static bool operator op_Inequality(
   RectangleF left,
   RectangleF right
);
[JScript]
returnValue = left ! = right;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

left
[To be supplied.]
right
[To be supplied.]

Parameters [C#, C++]

left
[To be supplied.]
right
[To be supplied.]

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace


RectangleF to Rectangle Conversion

[To be supplied.]

[C#]
public static explicit operator Rectangle(
   RectangleF r
);
[C++]
public: operator Rectangle();
[JScript]
returnValue = Rectangle(r);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

r
[To be supplied.]

Parameters [C#]

r
[To be supplied.]

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace


Rectangle to RectangleF Conversion

[To be supplied.]

[C#]
public static implicit operator RectangleF(
   Rectangle r
);
[C++]
public: static RectangleF op_Implicit(
   Rectangle r
);
[JScript]
returnValue = r;

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

r
[To be supplied.]

Parameters [C#, C++]

r
[To be supplied.]

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RectangleF Fields

The fields of the RectangleF structure are listed below. For a complete list of RectangleF structure members, see the RectangleF Members topic.

Public:

Empty [To be supplied.]

See Also

RectangleF Structure | System.Drawing Namespace


RectangleF.Empty

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Empty As RectangleF
[C#]
public static readonly RectangleF Empty;
[C++]
public: static readonly RectangleF Empty;
[JScript]
public static var Empty : RectangleF;

See Also

RectangleF Structure | RectangleF Members | System.Drawing Namespace


Region Class

[To be supplied.]

Object
MarshalByRefObject
Region

[Visual Basic]
NotInheritable Public Class Region
   Inherits MarshalByRefObject
[C#]
public sealed class Region : MarshalByRefObject
[C++]
public __gc __sealed class Region : public MarshalByRefObject
[JScript]
public class Region extends MarshalByRefObject

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

Region Members | System.Drawing Namespace


Region Members

Public:

Constructor

Region Constructor Overloaded. [To be supplied.]

Methods

Clone | [To be supplied.]
Complement | Overloaded. [To be supplied.]
Dispose | [To be supplied.]
Equals | Overloaded. [To be supplied.]
Exclude | Overloaded. [To be supplied.]
FromHRGN | [To be supplied.]
GetBounds | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHRGN | [To be supplied.]
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetRegionData | [To be supplied.]
GetRegionScans | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
Intersect | Overloaded. [To be supplied.]
IsEmpty | [To be supplied.]
IsInfinite | [To be supplied.]
IsVisible | Overloaded. [To be supplied.]
MakeEmpty | [To be supplied.]
MakeInfinite | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform | [To be supplied.]
Translate | Overloaded. [To be supplied.]
Union | Overloaded. [To be supplied.]
Xor | Overloaded. [To be supplied.]

Protected:

Methods

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Region Class | System.Drawing Namespace


Region Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public Region();
[C++] public: Region();
[JScript] public function Region();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(RectangleF)
[C#] public Region(RectangleF);
[C++] public: Region(RectangleF);
[JScript] public function Region(RectangleF);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Rectangle)
[C#] public Region(Rectangle);
[C++] public: Region(Rectangle);
[JScript] public function Region(Rectangle);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(GraphicsPath)
[C#] public Region(GraphicsPath);
[C++] public: Region(GraphicsPath*);
[JScript] public function Region(GraphicsPath);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(RegionData)
[C#] public Region(RegionData);
[C++] public: Region(RegionData*);
[JScript] public function Region(RegionData);

See Also

Region Class | Region Members | System.Drawing Namespace


Region Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public Region();
[C++]
public: Region();
[JScript]
public function Region();

See Also

Region Class | Region Members | System.Drawing Namespace | Region Constructor Overload List


Region Constructor (RectangleF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal rect As RectangleF _
)
[C#]
public Region(
   RectangleF rect
);
[C++]
public: Region(
   RectangleF rect
);
[JScript]
public function Region(
   rect : RectangleF
);

Parameters

rect
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region Constructor Overload List


Region Constructor (Rectangle)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal rect As Rectangle _
)
[C#]
public Region(
   Rectangle rect
);
[C++]
public: Region(
   Rectangle rect
);
[JScript]
public function Region(
   rect : Rectangle
);

Parameters

rect
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region Constructor Overload List


Region Constructor (GraphicsPath)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As GraphicsPath _
)
[C#]
public Region(
   GraphicsPath path
);
[C++]
public: Region(
   GraphicsPath* path
);
[JScript]
public function Region(
   path : GraphicsPath
);

Parameters

path
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region Constructor Overload List


Region Constructor (RegionData)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal rgnData As RegionData _
)
[C#]
public Region(
   RegionData rgnData
);
[C++]
public: Region(
   RegionData* rgnData
);
[JScript]
public function Region(
   rgnData : RegionData
);

Parameters

rgnData
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Region Methods

The methods of the Region class are listed below. For a complete list of Region class members, see the Region Members topic.

Public:

Clone | [To be supplied.]
Complement | Overloaded. [To be supplied.]
Dispose | [To be supplied.]
Equals | Overloaded. [To be supplied.]
Exclude | Overloaded. [To be supplied.]
FromHRGN | [To be supplied.]
GetBounds | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHRGN | [To be supplied.]
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetRegionData | [To be supplied.]
GetRegionScans | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
Intersect | Overloaded. [To be supplied.]
IsEmpty | [To be supplied.]
IsInfinite | [To be supplied.]
IsVisible | Overloaded. [To be supplied.]
MakeEmpty | [To be supplied.]
MakeInfinite | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform | [To be supplied.]
Translate | Overloaded. [To be supplied.]
Union | Overloaded. [To be supplied.]
Xor | Overloaded. [To be supplied.]

Protected:

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Region Class | System.Drawing Namespace


Region.Clone

[To be supplied.]

[Visual Basic]
Public Function Clone() As Region
[C#]
public Region Clone();
[C++]
public: Region* Clone();
[JScript]
public function Clone() : Region;

See Also

Region Class | Region Members | System.Drawing Namespace


Region.Complement

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub Complement(RectangleF)
[C#] public void Complement(RectangleF);
[C++] public: void Complement(RectangleF);
[JScript] public function Complement(RectangleF);

[To be supplied.]

[Visual Basic] Overloads Public Sub Complement(Rectangle)
[C#] public void Complement(Rectangle);
[C++] public: void Complement(Rectangle);
[JScript] public function Complement(Rectangle);

[To be supplied.]

[Visual Basic] Overloads Public Sub Complement(Region)
[C#] public void Complement(Region);
[C++] public: void Complement(Region*);
[JScript] public function Complement(Region);

[To be supplied.]

[Visual Basic] Overloads Public Sub Complement(GraphicsPath)
[C#] public void Complement(GraphicsPath);
[C++] public: void Complement(GraphicsPath*);
[JScript] public function Complement(GraphicsPath);

See Also

Region Class | Region Members | System.Drawing Namespace


Region.Complement (RectangleF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Complement( _
   ByVal rect As RectangleF _
)
[C#]
public void Complement(
   RectangleF rect
);
[C++]
public: void Complement(
   RectangleF rect
);
[JScript]
public function Complement(
   rect : RectangleF
);

Parameters

rect
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.Complement Overload List


Region.Complement (Rectangle)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Complement( _
   ByVal rect As Rectangle _
)
[C#]
public void Complement(
   Rectangle rect
);
[C++]
public: void Complement(
   Rectangle rect
);
[JScript]
public function Complement(
   rect : Rectangle
);

Parameters

rect
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.Complement Overload List


Region.Complement (Region)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Complement( _
   ByVal region As Region _
)
[C#]
public void Complement(
   Region region
);
[C++]
public: void Complement(
   Region* region
);
[JScript]
public function Complement(
   region : Region
);

Parameters

region
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.Complement Overload List


Region.Complement (GraphicsPath)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Complement( _
   ByVal path As GraphicsPath _
)
[C#]
public void Complement(
   GraphicsPath path
);
[C++]
public: void Complement(
   GraphicsPath* path
);
[JScript]
public function Complement(
   path : GraphicsPath
);

Parameters

path
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.Complement Overload List


Region.Dispose

[To be supplied.]

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[JScript]
public function Dispose();

See Also

Region Class | Region Members | System.Drawing Namespace


Region.Equals

[To be supplied.]

[Visual Basic]
Public Function Equals( _
   ByVal region As Region, _
   ByVal g As Graphics _
) As Boolean
[C#]
public bool Equals(
   Region region,
   Graphics g
);
[C++]
public: bool Equals(
   Region* region,
   Graphics* g
);
[JScript]
public function Equals(
   region : Region,
   g : Graphics
) : Boolean;

Parameters

region
[To be supplied.]
g
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace


Region.Exclude

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub Exclude(Rectangle)
[C#] public void Exclude(Rectangle);
[C++] public: void Exclude(Rectangle);
[JScript] public function Exclude(Rectangle);

[To be supplied.]

[Visual Basic] Overloads Public Sub Exclude(RectangleF)
[C#] public void Exclude(RectangleF);
[C++] public: void Exclude(RectangleF);
[JScript] public function Exclude(RectangleF);

[To be supplied.]

[Visual Basic] Overloads Public Sub Exclude(Region)
[C#] public void Exclude(Region);
[C++] public: void Exclude(Region*);
[JScript] public function Exclude(Region);

[To be supplied.]

[Visual Basic] Overloads Public Sub Exclude(GraphicsPath)
[C#] public void Exclude(GraphicsPath);
[C++] public: void Exclude(GraphicsPath*);
[JScript] public function Exclude(GraphicsPath);

See Also

Region Class | Region Members | System.Drawing Namespace


Region.Exclude (Rectangle)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Exclude( _
   ByVal rect As Rectangle _
)
[C#]
public void Exclude(
   Rectangle rect
);
[C++]
public: void Exclude(
   Rectangle rect
);
[JScript]
public function Exclude(
   rect : Rectangle
);

Parameters

rect
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.Exclude Overload List


Region.Exclude (RectangleF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Exclude( _
   ByVal rect As RectangleF _
)
[C#]
public void Exclude(
   RectangleF rect
);
[C++]
public: void Exclude(
   RectangleF rect
);
[JScript]
public function Exclude(
   rect : RectangleF
);

Parameters

rect
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.Exclude Overload List


Region.Exclude (Region)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Exclude( _
   ByVal region As Region _
)
[C#]
public void Exclude(
   Region region
);
[C++]
public: void Exclude(
   Region* region
);
[JScript]
public function Exclude(
   region : Region
);

Parameters

region
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.Exclude Overload List


Region.Exclude (GraphicsPath)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Exclude( _
   ByVal path As GraphicsPath _
)
[C#]
public void Exclude(
   GraphicsPath path
);
[C++]
public: void Exclude(
   GraphicsPath* path
);
[JScript]
public function Exclude(
   path : GraphicsPath
);

Parameters

path
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.Exclude Overload List


Region.Finalize

[To be supplied.]

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

Region Class | Region Members | System.Drawing Namespace


Region.FromHRGN

[To be supplied.]

[Visual Basic]
Public Shared Function FromHRGN( _
   ByVal hrgn As Integer _
) As Region
[C#]
public static Region FromHRGN(
   int hrgn
);
[C++]
public: static Region* FromHRGN(
   int hrgn
);
[JScript]
public static function FromHRGN(
   hrgn : int
) : Region;

Parameters

hrgn
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace


Region.GetBounds

[To be supplied.]

[Visual Basic]
Public Function GetBounds( _
   ByVal g As Graphics _
) As RectangleF
[C#]
public RectangleF GetBounds(
   Graphics g
);
[C++]
public: RectangleF GetBounds(
   Graphics* g
);
[JScript]
public function GetBounds(
   g : Graphics
) : RectangleF;

Parameters

g
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace


Region.GetHRGN

[To be supplied.]

[Visual Basic]
Public Function GetHRGN( _
   ByVal g As Graphics _
) As Integer
[C#]
public int GetHRGN(
   Graphics g
);
[C++]
public: int GetHRGN(
   Graphics* g
);
[JScript]
public function GetHRGN(
   g : Graphics
) : int;

Parameters

g
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace


Region.GetRegionData

[To be supplied.]

[Visual Basic]
Public Function GetRegionData() As RegionData
[C#]
public RegionData GetRegionData();
[C++]
public: RegionData* GetRegionData();
[JScript]
public function GetRegionData() : RegionData;

See Also

Region Class | Region Members | System.Drawing Namespace


Region.GetRegionScans

[To be supplied.]

[Visual Basic]
Public Function GetRegionScans( _
   ByVal matrix As Matrix _
) As RectangleF ()
[C#]
public RectangleF[] GetRegionScans(
   Matrix matrix
);
[C++]
public: RectangleF* GetRegionScans(
   Matrix* matrix
) [];
[JScript]
public function GetRegionScans(
   matrix : Matrix
) : RectangleF[];

Parameters

matrix
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace


Region.Intersect

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub Intersect(Region)
[C#] public void Intersect(Region);
[C++] public: void Intersect(Region*);
[JScript] public function Intersect(Region);

[To be supplied.]

[Visual Basic] Overloads Public Sub Intersect(GraphicsPath)
[C#] public void Intersect(GraphicsPath);
[C++] public: void Intersect(GraphicsPath*);
[JScript] public function Intersect(GraphicsPath);

[To be supplied.]

[Visual Basic] Overloads Public Sub Intersect(Rectangle)
[C#] public void Intersect(Rectangle);
[C++] public: void Intersect(Rectangle);
[JScript] public function Intersect(Rectangle);

[To be supplied.]

[Visual Basic] Overloads Public Sub Intersect(RectangleF)
[C#] public void Intersect(RectangleF);
[C++] public: void Intersect(RectangleF);
[JScript] public function Intersect(RectangleF);

See Also

Region Class | Region Members | System.Drawing Namespace


Region.Intersect (Region)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Intersect( _
   ByVal region As Region _
)
[C#]
public void Intersect(
   Region region
);
[C++]
public: void Intersect(
   Region* region
);
[JScript]
public function Intersect(
   region : Region
);

Parameters

region
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.Intersect Overload List


Region.Intersect (GraphicsPath)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Intersect( _
   ByVal path As GraphicsPath _
)
[C#]
public void Intersect(
   GraphicsPath path
);
[C++]
public: void Intersect(
   GraphicsPath* path
);
[JScript]
public function Intersect(
   path : GraphicsPath
);

Parameters

path
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.Intersect Overload List


Region.Intersect (Rectangle)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Intersect( _
   ByVal rect As Rectangle _
)
[C#]
public void Intersect(
   Rectangle rect
);
[C++]
public: void Intersect(
   Rectangle rect
);
[JScript]
public function Intersect(
   rect : Rectangle
);

Parameters

rect
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.Intersect Overload List


Region.Intersect (RectangleF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Intersect( _
   ByVal rect As RectangleF _
)
[C#]
public void Intersect(
   RectangleF rect
);
[C++]
public: void Intersect(
   RectangleF rect
);
[JScript]
public function Intersect(
   rect : RectangleF
);

Parameters

rect
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.Intersect Overload List


Region.IsEmpty

[To be supplied.]

[Visual Basic]
Public Function IsEmpty( _
   ByVal g As Graphics _
) As Boolean
[C#]
public bool IsEmpty(
   Graphics g
);
[C++]
public: bool IsEmpty(
   Graphics* g
);
[JScript]
public function IsEmpty(
   g : Graphics
) : Boolean;

Parameters

g
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace


Region.IsInfinite

[To be supplied.]

[Visual Basic]
Public Function IsInfinite( _
   ByVal g As Graphics _
) As Boolean
[C#]
public bool IsInfinite(
   Graphics g
);
[C++]
public: bool IsInfinite(
   Graphics* g
);
[JScript]
public function IsInfinite(
   g : Graphics
) : Boolean;

Parameters

g
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace


Region.IsVisible

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(Single, Single, Single, Single) As Boolean
[C#] public bool IsVisible(float, float, float, float);
[C++] public: bool IsVisible(float, float, float, float);
[JScript] public function IsVisible(float, float, float, float) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(RectangleF) As Boolean
[C#] public bool IsVisible(RectangleF);
[C++] public: bool IsVisible(RectangleF);
[JScript] public function IsVisible(RectangleF) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(Single, Single, Single, Single, Graphics) As Boolean
[C#] public bool IsVisible(float, float, float, float, Graphics);
[C++] public: bool IsVisible(float, float, float, float, Graphics);
[JScript] public function IsVisible(float, float, float, float, Graphics) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(Integer, Integer, Integer, Integer) As Boolean
[C#] public bool IsVisible(int, int, int, int);
[C++] public: bool IsVisible(int, int, int, int);
[JScript] public function IsVisible(int, int, int, int) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(Single, Single, Graphics) As Boolean
[C#] public bool IsVisible(float, float, Graphics);
[C++] public: bool IsVisible(float, float, Graphics);
[JScript] public function IsVisible(float, float, Graphics) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(PointF) As Boolean
[C#] public bool IsVisible(PointF);
[C++] public: bool IsVisible(PointF);
[JScript] public function IsVisible(PointF) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(Single, Single) As Boolean
[C#] public bool IsVisible(float, float);
[C++] public: bool IsVisible(float, float);
[JScript] public function IsVisible(float, float) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(PointF, Graphics) As Boolean
[C#] public bool IsVisible(PointF, Graphics);
[C++] public: bool IsVisible(PointF, Graphics);
[JScript] public function IsVisible(PointF, Graphics) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(Rectangle, Graphics) As Boolean
[C#] public bool IsVisible(Rectangle, Graphics);
[C++] public: bool IsVisible(Rectangle, Graphics);
[JScript] public function IsVisible(Rectangle, Graphics) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(Integer, Integer, Integer, Integer, Graphics) As Boolean
[C#] public bool IsVisible(int, int, int, int, Graphics);
[C++] public: bool IsVisible(int, int, int, int, Graphics);
[JScript] public function IsVisible(int, int, int, int, Graphics) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(Rectangle) As Boolean
[C#] public bool IsVisible(Rectangle);
[C++] public: bool IsVisible(Rectangle);
[JScript] public function IsVisible(Rectangle) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(Point, Graphics) As Boolean
[C#] public bool IsVisible(Point, Graphics);
[C++] public: bool IsVisible(Point, Graphics);
[JScript] public function IsVisible(Point, Graphics) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(RectangleF, Graphics) As Boolean
[C#] public bool IsVisible(RectangleF, Graphics);
[C++] public: bool IsVisible(RectangleF, Graphics);
[JScript] public function IsVisible(RectangleF, Graphics) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(Integer, Integer, Graphics) As Boolean
[C#] public bool IsVisible(int, int, Graphics);
[C++] public: bool IsVisible(int, int, Graphics);
[JScript] public function IsVisible(int, int, Graphics) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(Point) As Boolean
[C#] public bool IsVisible(Point);
[C++] public: bool IsVisible(Point);
[JScript] public function IsVisible(Point) : Boolean;

See Also

Region Class | Region Members | System.Drawing Namespace


Region.IsVisible (Single, Single, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal width As Single, _
   ByVal height As Single _
) As Boolean
[C#]
public bool IsVisible(
   float x,
   float y,
   float width,
   float height
);
[C++]
public: bool IsVisible(
   float x,
   float y,
   float width,
   float height
);
[JScript]
public function IsVisible(
   x : float,
   y : float,
   width : float,
   height : float
) : Boolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]
width
[To be supplied.]
height
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.IsVisible Overload List


Region.IsVisible (RectangleF)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal rect As RectangleF _
) As Boolean
[C#]
public bool IsVisible(
   RectangleF rect
);
[C++]
public: bool IsVisible(
   RectangleF rect
);
[JScript]
public function IsVisible(
   rect : RectangleF
) : Boolean;

Parameters

rect
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.IsVisible Overload List


Region.IsVisible (Single, Single, Single, Single, Graphics)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal g As Graphics _
) As Boolean
[C#]
public bool IsVisible(
   float x,
   float y,
   float width,
   float height,
   Graphics g
);
[C++]
public: bool IsVisible(
   float x,
   float y,
   float width,
   float height,
   Graphics* g
);
[JScript]
public function IsVisible(
   x : float,
   y : float,
   width : float,
   height : float,
   g : Graphics
) : Boolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]
width
[To be supplied.]
height
[To be supplied.]
g
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.IsVisible Overload List


Region.IsVisible (Int32, Int32, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer _
) As Boolean
[C#]
public bool IsVisible(
   int x,
   int y,
   int width,
   int height
);
[C++]
public: bool IsVisible(
   int x,
   int y,
   int width,
   int height
);
[JScript]
public function IsVisible(
   x : int,
   y : int,
   width : int,
   height : int
) : Boolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]
width
[To be supplied.]
height
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.IsVisible Overload List


Region.IsVisible (Single, Single, Graphics)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal g As Graphics _
) As Boolean
[C#]
public bool IsVisible(
   float x,
   float y,
   Graphics g
);
[C++]
public: bool IsVisible(
   float x,
   float y,
   Graphics* g
);
[JScript]
public function IsVisible(
   x : float,
   y : float,
   g : Graphics
) : Boolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]
g
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.IsVisible Overload List


Region.IsVisible (PointF)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal point As PointF _
) As Boolean
[C#]
public bool IsVisible(
   PointF point
);
[C++]
public: bool IsVisible(
   PointF point
);
[JScript]
public function IsVisible(
   point : PointF
) : Boolean;

Parameters

point
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.IsVisible Overload List


Region.IsVisible (Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal x As Single, _
   ByVal y As Single _
) As Boolean
[C#]
public bool IsVisible(
   float x,
   float y
);
[C++]
public: bool IsVisible(
   float x,
   float y
);
[JScript]
public function IsVisible(
   x : float,
   y : float
) : Boolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.IsVisible Overload List


Region.IsVisible (PointF, Graphics)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal point As PointF, _
   ByVal g As Graphics _
) As Boolean
[C#]
public bool IsVisible(
   PointF point,
   Graphics g
);
[C++]
public: bool IsVisible(
   PointF point,
   Graphics* g
);
[JScript]
public function IsVisible(
   point : PointF,
   g : Graphics
) : Boolean;

Parameters

point
[To be supplied.]
g
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.IsVisible Overload List


Region.IsVisible (Rectangle, Graphics)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal rect As Rectangle, _
   ByVal g As Graphics _
) As Boolean
[C#]
public bool IsVisible(
   Rectangle rect,
   Graphics g
);
[C++]
public: bool IsVisible(
   Rectangle rect,
   Graphics* g
);
[JScript]
public function IsVisible(
   rect : Rectangle,
   g : Graphics
) : Boolean;

Parameters

rect
[To be supplied.]
g
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.IsVisible Overload List


Region.IsVisible (Int32, Int32, Int32, Int32, Graphics)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal g As Graphics _
) As Boolean
[C#]
public bool IsVisible(
   int x,
   int y,
   int width,
   int height,
   Graphics g
);
[C++]
public: bool IsVisible(
   int x,
   int y,
   int width,
   int height,
   Graphics* g
);
[JScript]
public function IsVisible(
   x : int,
   y : int,
   width : int,
   height : int,
   g : Graphics
) : Boolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]
width
[To be supplied.]
height
[To be supplied.]
g
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.IsVisible Overload List


Region.IsVisible (Rectangle)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal rect As Rectangle _
) As Boolean
[C#]
public bool IsVisible(
   Rectangle rect
);
[C++]
public: bool IsVisible(
   Rectangle rect
);
[JScript]
public function IsVisible(
   rect : Rectangle
) : Boolean;

Parameters

rect
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.IsVisible Overload List


Region.IsVisible (Point, Graphics)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal point As Point, _
   ByVal g As Graphics _
) As Boolean
[C#]
public bool IsVisible(
   Point point,
   Graphics g
);
[C++]
public: bool IsVisible(
   Point point,
   Graphics* g
);
[JScript]
public function IsVisible(
   point : Point,
   g : Graphics
) : Boolean;

Parameters

point
[To be supplied.]
g
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.IsVisible Overload List


Region.IsVisible (RectangleF, Graphics)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal rect As RectangleF, _
   ByVal g As Graphics _
) As Boolean
[C#]
public bool IsVisible(
   RectangleF rect,
   Graphics g
);
[C++]
public: bool IsVisible(
   RectangleF rect,
   Graphics* g
);
[JScript]
public function IsVisible(
   rect : RectangleF,
   g : Graphics
) : Boolean;

Parameters

rect
[To be supplied.]
g
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.IsVisible Overload List


Region.IsVisible (Int32, Int32, Graphics)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal g As Graphics _
) As Boolean
[C#]
public bool IsVisible(
   int x,
   int y,
   Graphics g
);
[C++]
public: bool IsVisible(
   int x,
   int y,
   Graphics* g
);
[JScript]
public function IsVisible(
   x : int,
   y : int,
   g : Graphics
) : Boolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]
g
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.IsVisible Overload List


Region.IsVisible (Point)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal point As Point _
) As Boolean
[C#]
public bool IsVisible(
   Point point
);
[C++]
public: bool IsVisible(
   Point point
);
[JScript]
public function IsVisible(
   point : Point
) : Boolean;

Parameters

point
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.IsVisible Overload List


Region.MakeEmpty

[To be supplied.]

[Visual Basic]
Public Sub MakeEmpty()
[C#]
public void MakeEmpty();
[C++]
public: void MakeEmpty();
[JScript]
public function MakeEmpty();

See Also

Region Class | Region Members | System.Drawing Namespace


Region.MakeInfinite

[To be supplied.]

[Visual Basic]
Public Sub MakeInfinite()
[C#]
public void MakeInfinite();
[C++]
public: void MakeInfinite();
[JScript]
public function MakeInfinite();

See Also

Region Class | Region Members | System.Drawing Namespace


Region.Transform

[To be supplied.]

[Visual Basic]
Public Sub Transform( _
   ByVal matrix As Matrix _
)
[C#]
public void Transform(
   Matrix matrix
);
[C++]
public: void Transform(
   Matrix* matrix
);
[JScript]
public function Transform(
   matrix : Matrix
);

Parameters

matrix
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace


Region.Translate

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub Translate(Single, Single)
[C#] public void Translate(float, float);
[C++] public: void Translate(float, float);
[JScript] public function Translate(float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub Translate(Integer, Integer)
[C#] public void Translate(int, int);
[C++] public: void Translate(int, int);
[JScript] public function Translate(int, int);

See Also

Region Class | Region Members | System.Drawing Namespace


Region.Translate (Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Translate( _
   ByVal dx As Single, _
   ByVal dy As Single _
)
[C#]
public void Translate(
   float dx,
   float dy
);
[C++]
public: void Translate(
   float dx,
   float dy
);
[JScript]
public function Translate(
   dx : float,
   dy : float
);

Parameters

dx
[To be supplied.]
dy
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.Translate Overload List


Region.Translate (Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Translate( _
   ByVal dx As Integer, _
   ByVal dy As Integer _
)
[C#]
public void Translate(
   int dx,
   int dy
);
[C++]
public: void Translate(
   int dx,
   int dy
);
[JScript]
public function Translate(
   dx : int,
   dy : int
);

Parameters

dx
[To be supplied.]
dy
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.Translate Overload List


Region.Union

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub Union(GraphicsPath)
[C#] public void Union(GraphicsPath);
[C++] public: void Union(GraphicsPath*);
[JScript] public function Union(GraphicsPath);

[To be supplied.]

[Visual Basic] Overloads Public Sub Union(Region)
[C#] public void Union(Region);
[C++] public: void Union(Region*);
[JScript] public function Union(Region);

[To be supplied.]

[Visual Basic] Overloads Public Sub Union(RectangleF)
[C#] public void Union(RectangleF);
[C++] public: void Union(RectangleF);
[JScript] public function Union(RectangleF);

[To be supplied.]

[Visual Basic] Overloads Public Sub Union(Rectangle)
[C#] public void Union(Rectangle);
[C++] public: void Union(Rectangle);
[JScript] public function Union(Rectangle);

See Also

Region Class | Region Members | System.Drawing Namespace


Region.Union (GraphicsPath)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Union( _
   ByVal path As GraphicsPath _
)
[C#]
public void Union(
   GraphicsPath path
);
[C++]
public: void Union(
   GraphicsPath* path
);
[JScript]
public function Union(
   path : GraphicsPath
);

Parameters

path
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.Union Overload List


Region.Union (Region)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Union( _
   ByVal region As Region _
)
[C#]
public void Union(
   Region region
);
[C++]
public: void Union(
   Region* region
);
[JScript]
public function Union(
   region : Region
);

Parameters

region
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.Union Overload List


Region.Union (RectangleF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Union( _
   ByVal rect As RectangleF _
)
[C#]
public void Union(
   RectangleF rect
);
[C++]
public: void Union(
   RectangleF rect
);
[JScript]
public function Union(
   rect : RectangleF
);

Parameters

rect
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.Union Overload List


Region.Union (Rectangle)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Union( _
   ByVal rect As Rectangle _
)
[C#]
public void Union(
   Rectangle rect
);
[C++]
public: void Union(
   Rectangle rect
);
[JScript]
public function Union(
   rect : Rectangle
);

Parameters

rect
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.Union Overload List


Region.Xor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub Xor(GraphicsPath)
[C#] public void Xor(GraphicsPath);
[C++] public: void Xor(GraphicsPath*);
[JScript] public function Xor(GraphicsPath);

[To be supplied.]

[Visual Basic] Overloads Public Sub Xor(Region)
[C#] public void Xor(Region);
[C++] public: void Xor(Region*);
[JScript] public function Xor(Region);

[To be supplied.]

[Visual Basic] Overloads Public Sub Xor(RectangleF)
[C#] public void Xor(RectangleF);
[C++] public: void Xor(RectangleF);
[JScript] public function Xor(RectangleF);

[To be supplied.]

[Visual Basic] Overloads Public Sub Xor(Rectangle)
[C#] public void Xor(Rectangle);
[C++] public: void Xor(Rectangle);
[JScript] public function Xor(Rectangle);

See Also

Region Class | Region Members | System.Drawing Namespace


Region.Xor (GraphicsPath)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Xor( _
   ByVal path As GraphicsPath _
)
[C#]
public void Xor(
   GraphicsPath path
);
[C++]
public: void Xor(
   GraphicsPath* path
);
[JScript]
public function Xor(
   path : GraphicsPath
);

Parameters

path
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.Xor Overload List


Region.Xor (Region)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Xor( _
   ByVal region As Region _
)
[C#]
public void Xor(
   Region region
);
[C++]
public: void Xor(
   Region* region
);
[JScript]
public function Xor(
   region : Region
);

Parameters

region
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.Xor Overload List


Region.Xor (RectangleF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Xor( _
   ByVal rect As RectangleF _
)
[C#]
public void Xor(
   RectangleF rect
);
[C++]
public: void Xor(
   RectangleF rect
);
[JScript]
public function Xor(
   rect : RectangleF
);

Parameters

rect
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.Xor Overload List


Region.Xor (Rectangle)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Xor( _
   ByVal rect As Rectangle _
)
[C#]
public void Xor(
   Rectangle rect
);
[C++]
public: void Xor(
   Rectangle rect
);
[JScript]
public function Xor(
   rect : Rectangle
);

Parameters

rect
[To be supplied.]

See Also

Region Class | Region Members | System.Drawing Namespace | Region.Xor Overload List


Size Structure

[To be supplied.]

Object
ValueType
Size

[Visual Basic]
Public Structure Size
[C#]
public struct Size
[C++]
public __value struct Size

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

Size Members | System.Drawing Namespace


Size Members

Public:

Constructor

Size Constructor Overloaded. [To be supplied.]

Properties

Height | [To be supplied.]
IsEmpty | [To be supplied.]
Width | [To be supplied.]

Methods

Copy | [To be supplied.]
Equals | Tests to see if the two sizes represent the same logical size. Doesn't actually test for object identity equality.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | A string representation of a Size

Operators and Type Conversions

Addition Operator | Expands a Size by another Size.
Equality Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Subtraction Operator | Contracts a Size by another Size.
Size to Point Conversion | [To be supplied.]
Size to SizeF Conversion | [To be supplied.]

Fields

Empty [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Size Structure | System.Drawing Namespace


Size Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Point)
[C#] public Size(Point);
[C++] public: Size(Point);
[JScript] public function Size(Point);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer, Integer)
[C#] public Size(int, int);
[C++] public: Size(int, int);
[JScript] public function Size(int, int);

See Also

Size Structure | Size Members | System.Drawing Namespace


Size Constructor (Point)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal pt As Point _
)
[C#]
public Size(
   Point pt
);
[C++]
public: Size(
   Point pt
);
[JScript]
public function Size(
   pt : Point
);

Parameters

pt
[To be supplied.]

See Also

Size Structure | Size Members | System.Drawing Namespace | Size Constructor Overload List


Size Constructor (Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal width As Integer, _
   ByVal height As Integer _
)
[C#]
public Size(
   int width,
   int height
);
[C++]
public: Size(
   int width,
   int height
);
[JScript]
public function Size(
   width : int,
   height : int
);

Parameters

width
[To be supplied.]
height
[To be supplied.]

See Also

Size Structure | Size Members | System.Drawing Namespace | Size Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Size Properties

The properties of the Size structure are listed below. For a complete list of Size structure members, see the Size Members topic.

Public:

Height | [To be supplied.]
IsEmpty | [To be supplied.]
Width | [To be supplied.]

See Also

Size Structure | System.Drawing Namespace


Size.Height

[To be supplied.]

[Visual Basic]
Public Property Height As Integer
[C#]
public int Height {get; set;}
[C++]
public: __property int get_Height();
public: __property void set_Height(int);
[JScript]
public function get Height() : int;
public function set Height(int);

See Also

Size Structure | Size Members | System.Drawing Namespace


Size.IsEmpty

[To be supplied.]

[Visual Basic]
Public ReadOnly Property IsEmpty As Boolean
[C#]
public bool IsEmpty {get;}
[C++]
public: __property bool get_IsEmpty();
[JScript]
public function get IsEmpty() : Boolean;

See Also

Size Structure | Size Members | System.Drawing Namespace


Size.Width

[To be supplied.]

[Visual Basic]
Public Property Width As Integer
[C#]
public int Width {get; set;}
[C++]
public: __property int get_Width();
public: __property void set_Width(int);
[JScript]
public function get Width() : int;
public function set Width(int);

See Also

Size Structure | Size Members | System.Drawing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Size Methods

The methods of the Size structure are listed below. For a complete list of Size structure members, see the Size Members topic.

Public:

Copy | [To be supplied.]
Equals | Tests to see if the two sizes represent the same logical size. Doesn't actually test for object identity equality.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | A string representation of a Size

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Size Structure | System.Drawing Namespace


Size.Copy

[To be supplied.]

[Visual Basic]
Public Shared Function Copy( _
   ByVal sz As Size _
) As Size
[C#]
public static Size Copy(
   Size sz
);
[C++]
public: static Size Copy(
   Size sz
);
[JScript]
public static function Copy(
   sz : Size
) : Size;

Parameters

sz
[To be supplied.]

See Also

Size Structure | Size Members | System.Drawing Namespace


Size.Equals

Tests to see if the two sizes represent the same logical size. Doesn't actually test for object identity equality.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
Test to see if this object is the same as the current one.

Return Value

boolean indicating true if they are the same, false otherwise.

See Also

Size Structure | Size Members | System.Drawing Namespace


Size.ToString

A string representation of a Size

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

Size Structure | Size Members | System.Drawing Namespace


Operators and Type Conversions

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Size Operators and Type Conversions

The operators and type conversions of the Size structure are listed below. For a complete list of Size structure members, see the Size Members topic.

Public:

Addition Operator | Expands a Size by another Size.
Equality Operator | [To be supplied.]
Inequality Operator | [To be supplied.]
Subtraction Operator | Contracts a Size by another Size.
Size to Point Conversion | [To be supplied.]
Size to SizeF Conversion | [To be supplied.]

See Also

Size Structure | System.Drawing Namespace


Size Addition Operator

Expands a Size by another Size.

[C#]
public static Size operator +(
   Size sz1,
   Size sz2
);
[C++]
public: static Size operator op_Addition(
   Size sz1,
   Size sz2
);
[JScript]
returnValue = sz1 + sz2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

sz1
Size to expand.
sz2
Size to expand sz1 by.

Parameters [C#, C++]

sz1
Size to expand.
sz2
Size to expand sz1 by.

See Also

Size Structure | Size Members | System.Drawing Namespace


Size Equality Operator

[To be supplied.]

[C#]
public static bool operator ==(
   Size sz1,
   Size sz2
);
[C++]
public: static bool operator op_Equality(
   Size sz1,
   Size sz2
);
[JScript]
returnValue = sz1 == sz2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

sz1
[To be supplied.]
sz2
[To be supplied.]

Parameters [C#, C++]

sz1
[To be supplied.]
sz2
[To be supplied.]

See Also

Size Structure | Size Members | System.Drawing Namespace


Size Inequality Operator

[To be supplied.]

[C#]
public static bool operator !=(
   Size sz1,
   Size sz2
);
[C++]
public: static bool operator op_Inequality(
   Size sz1,
   Size sz2
);
[JScript]
returnValue = sz1 ! = sz2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

sz1
[To be supplied.]
sz2
[To be supplied.]

Parameters [C#, C++]

sz1
[To be supplied.]
sz2
[To be supplied.]

See Also

Size Structure | Size Members | System.Drawing Namespace


Size Subtraction Operator

Contracts a Size by another Size.

[C#]
public static Size operator -(
   Size sz1,
   Size sz2
);
[C++]
public: static Size operator op_Subtraction(
   Size sz1,
   Size sz2
);
[JScript]
returnValue = sz1 - sz2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

sz1
Size to contract.
sz2
Size to contract sz1 by.

Parameters [C#, C++]

sz1
Size to contract.
sz2
Size to contract sz1 by.

See Also

Size Structure | Size Members | System.Drawing Namespace


Size to Point Conversion

[To be supplied.]

[C#]
public static explicit operator Point(
   Size size
);
[C++]
public: operator Point();
[JScript]
returnValue = Point(size);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

size
[To be supplied.]

Parameters [C#]

size
[To be supplied.]

See Also

Size Structure | Size Members | System.Drawing Namespace


Size to SizeF Conversion

[To be supplied.]

[C#]
public static implicit operator SizeF(
   Size p
);
[C++]
public: operator SizeF();
[JScript]
returnValue = p;

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

p
[To be supplied.]

Parameters [C#]

p
[To be supplied.]

See Also

Size Structure | Size Members | System.Drawing Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Size Fields

The fields of the Size structure are listed below. For a complete list of Size structure members, see the Size Members topic.

Public:

Empty [To be supplied.]

See Also

Size Structure | System.Drawing Namespace


Size.Empty

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Empty As Size
[C#]
public static readonly Size Empty;
[C++]
public: static readonly Size Empty;
[JScript]
public static var Empty : Size;

See Also

Size Structure | Size Members | System.Drawing Namespace


SizeConverter Class

SizeConverter is a class that can be used to convert Size from one data type to another. Access this class through the TypeDescriptor.

Object
TypeConverter
SizeConverter

[Visual Basic]
Public Class SizeConverter
   Inherits TypeConverter
[C#]
public class SizeConverter : TypeConverter
[C++]
public __gc class SizeConverter : public TypeConverter
[JScript]
public class SizeConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

SizeConverter Members | System.Drawing Namespace


SizeConverter Members

Public:

Constructor

SizeConverter Constructor [To be supplied.]

Methods

CanConvertFrom (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type.
ConvertFrom | Overloaded. [To be supplied.]
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text into an object.
ConvertTo | Overloaded. [To be supplied.]
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetProperties (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValues (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid (inherited from TypeConverter) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

SizeConverter Class | System.Drawing Namespace


SizeConverter Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public SizeConverter();
[C++]
public: SizeConverter();
[JScript]
public function SizeConverter();

See Also

SizeConverter Class | SizeConverter Members | System.Drawing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SizeConverter Methods

The methods of the SizeConverter class are listed below. For a complete list of SizeConverter class members, see the SizeConverter Members topic.

Public:

CanConvertFrom (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to the native type of the converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type.
ConvertFrom | Overloaded. [To be supplied.]
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text into an object.
ConvertTo | Overloaded. [To be supplied.]
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreateInstanceSupported | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInfo (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetProperties (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValues (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsValid (inherited from TypeConverter) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetConvertFromException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Retrieves a suitable exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

SizeConverter Class | System.Drawing Namespace


SizeConverter.CanConvertFrom

Determines if this converter can convert an object in the given source type to the native type of the converter.

[Visual Basic]
Overrides Public Function CanConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal sourceType As Type _
) As Boolean
[C#]
public override bool CanConvertFrom(
   ITypeDescriptorContext context,
   Type sourceType
);
[C++]
public: override bool CanConvertFrom(
   ITypeDescriptorContext* context,
   Type* sourceType
);
[JScript]
public override function CanConvertFrom(
   context : ITypeDescriptorContext,
   sourceType : Type
) : Boolean;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
sourceType
The type you wish to convert from.

Return Value

True if this object can perform the conversion.

See Also

SizeConverter Class | SizeConverter Members | System.Drawing Namespace


SizeConverter.ConvertFrom

Converts the given object to the converter's native type.

[Visual Basic]
Overrides Public Function ConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal arguments() As Object _
) As Object
[C#]
public override object ConvertFrom(
   ITypeDescriptorContext context,
   object value,
   object[] arguments
);
[C++]
public: override Object* ConvertFrom(
   ITypeDescriptorContext* context,
   Object* value,
   Object* arguments[]
);
[JScript]
public override function ConvertFrom(
   context : ITypeDescriptorContext,
   value : Object,
   arguments : Object[]
) : Object;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
value
The object to convert.
arguments
An optional array of arguments to use when doing the conversion. The number and content of these arguments is dependent on the implementer of the value formatter.

Return Value

The converted object. This will throw an excetpion if the converson could not be performed.

See Also

SizeConverter Class | SizeConverter Members | System.Drawing Namespace


SizeConverter.ConvertTo

Converts the given object to another type. The most common types to convert are to and from a string object. The default implementation will make a call to ToString on the object if the object is valid and if the destination type is string. If this cannot convert to the desitnation type, this will throw a NotSupportedException.

[Visual Basic]
Overrides Public Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal destinationType As Type, _
   ByVal arguments() As Object _
) As Object
[C#]
public override object ConvertTo(
   ITypeDescriptorContext context,
   object value,
   Type destinationType,
   object[] arguments
);
[C++]
public: override Object* ConvertTo(
   ITypeDescriptorContext* context,
   Object* value,
   Type* destinationType,
   Object* arguments[]
);
[JScript]
public override function ConvertTo(
   context : ITypeDescriptorContext,
   value : Object,
   destinationType : Type,
   arguments : Object[]
) : Object;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
value
The object to convert.
destinationType
The type to convert the object to.
arguments
An optional array of arguments to use when doing the conversion. The number and content of these arguments is dependent on the implementer of the value formatter.

Return Value

The converted object.

See Also

SizeConverter Class | SizeConverter Members | System.Drawing Namespace


SizeConverter.CreateInstance

[To be supplied.]

Overload List

Recreates an object given its PersistInfo. This information was generated by a prior call to GetPersistInfo.

[Visual Basic] Overloads Overrides Public Function CreateInstance(ITypeDescriptorContext, PersistInfo) As Object
[C#] public override object CreateInstance(ITypeDescriptorContext, PersistInfo);
[C++] public: override Object* CreateInstance(ITypeDescriptorContext*, PersistInfo);
[JScript] public override function CreateInstance(ITypeDescriptorContext, PersistInfo) : Object;

Creates an instance of this type given a set of property values for the object. This is useful for objects that are immutable, but still want to provide changable properties.

[Visual Basic] Overloads Overrides Public Function CreateInstance(ITypeDescriptorContext, IDictionary) As Object
[C#] public override object CreateInstance(ITypeDescriptorContext, IDictionary);
[C++] public: override Object* CreateInstance(ITypeDescriptorContext*, IDictionary);
[JScript] public override function CreateInstance(ITypeDescriptorContext, IDictionary) : Object;

See Also

SizeConverter Class | SizeConverter Members | System.Drawing Namespace


SizeConverter.CreateInstance (ITypeDescriptorContext, PersistInfo)

Recreates an object given its PersistInfo. This information was generated by a prior call to GetPersistInfo.

[Visual Basic]
Overloads Overrides Public Function CreateInstance( _
   ByVal context As ITypeDescriptorContext, _
   ByVal persistInfo As PersistInfo _
) As Object
[C#]
public override object CreateInstance(
   ITypeDescriptorContext context,
   PersistInfo persistInfo
);
[C++]
public: override Object* CreateInstance(
   ITypeDescriptorContext* context,
   PersistInfo* persistInfo
);
[JScript]
public override function CreateInstance(
   context : ITypeDescriptorContext,
   persistInfo : PersistInfo
) : Object;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
persistInfo
The persistence information to use when re-creating the object.

Return Value

An object representing the given PersistInfo.

See Also

SizeConverter Class | SizeConverter Members | System.Drawing Namespace | SizeConverter.CreateInstance Overload List | PersistInfo | TBD


SizeConverter.CreateInstance (ITypeDescriptorContext, IDictionary)

Creates an instance of this type given a set of property values for the object. This is useful for objects that are immutable, but still want to provide changable properties.

[Visual Basic]
Overloads Overrides Public Function CreateInstance( _
   ByVal context As ITypeDescriptorContext, _
   ByVal propertyValues As IDictionary _
) As Object
[C#]
public override object CreateInstance(
   ITypeDescriptorContext context,
   IDictionary propertyValues
);
[C++]
public: override Object* CreateInstance(
   ITypeDescriptorContext* context,
   IDictionary* propertyValues
);
[JScript]
public override function CreateInstance(
   context : ITypeDescriptorContext,
   propertyValues : IDictionary
) : Object;

Parameters

context
A type descriptor through which additional context may be provided.
propertyValues
A dictionary of new property values. The dictionary contains a series of name-value pairs, one for each property returned from GetProperties.

Return Value

The newly created object, or null if the object could not be created. The default implementation returns null.

See Also

SizeConverter Class | SizeConverter Members | System.Drawing Namespace | SizeConverter.CreateInstance Overload List


SizeConverter.GetCreateInstanceSupported

Determines if changing a value on this object should require a call to CreateInstance to create a new value.

[Visual Basic]
Overrides Public Function GetCreateInstanceSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
[C#]
public override bool GetCreateInstanceSupported(
   ITypeDescriptorContext context
);
[C++]
public: override bool GetCreateInstanceSupported(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetCreateInstanceSupported(
   context : ITypeDescriptorContext
) : Boolean;

Parameters

context
A type descriptor through which additional context may be provided.

Return Value

Returns true if CreateInstance should be called when a change is made to one or more properties of this object.

See Also

SizeConverter Class | SizeConverter Members | System.Drawing Namespace


SizeConverter.GetPersistInfo

Retrieves the PersistInfo object for the given value. This object describes the given value as persisted information, which can be saved to disk or moved. This information can later be reconstructed by passing the PersistInfo to GetValue.

[Visual Basic]
Overrides Public Function GetPersistInfo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As PersistInfo
[C#]
public override PersistInfo GetPersistInfo(
   ITypeDescriptorContext context,
   object value
);
[C++]
public: override PersistInfo* GetPersistInfo(
   ITypeDescriptorContext* context,
   Object* value
);
[JScript]
public override function GetPersistInfo(
   context : ITypeDescriptorContext,
   value : Object
) : PersistInfo;

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
value
The object to persist.

Return Value

The PersistInfo representing the persisted state of the given object.

See Also

SizeConverter Class | SizeConverter Members | System.Drawing Namespace | PersistInfo | TBD


SizeConverter.GetProperties

Retrieves the set of properties for this type. By default, a type has does not return any properties. An easy implementation of this method can just call TypeDescriptor.GetProperties for the correct data type.

[Visual Basic]
Overrides Public Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal attributes() As MemberAttribute _
) As PropertyDescriptorCollection
[C#]
public override PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value,
   MemberAttribute[] attributes
);
[C++]
public: override PropertyDescriptorCollection* GetProperties(
   ITypeDescriptorContext* context,
   Object* value,
   MemberAttribute* attributes[]
);
[JScript]
public override function GetProperties(
   context : ITypeDescriptorContext,
   value : Object,
   attributes : MemberAttribute[]
) : PropertyDescriptorCollection;

Parameters

context
A type descriptor through which additional context may be provided.
value
The value of the object to get the properties for.
attributes
[To be supplied.]

Return Value

The set of properties that should be exposed for this data type. If no properties should be exposed, thsi may return null. The default implementation always returns null.

See Also

SizeConverter Class | SizeConverter Members | System.Drawing Namespace


SizeConverter.GetPropertiesSupported

Determines if this object supports properties. By default, this is false.

[Visual Basic]
Overrides Public Function GetPropertiesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
[C#]
public override bool GetPropertiesSupported(
   ITypeDescriptorContext context
);
[C++]
public: override bool GetPropertiesSupported(
   ITypeDescriptorContext* context
);
[JScript]
public override function GetPropertiesSupported(
   context : ITypeDescriptorContext
) : Boolean;

Parameters

context
A type descriptor through which additional context may be provided.

Return Value

Returns true if GetProperties should be called to find the properties of this object.

See Also

SizeConverter Class | SizeConverter Members | System.Drawing Namespace


SizeF Structure

[To be supplied.]

Object
ValueType
SizeF

[Visual Basic]
Public Structure SizeF
[C#]
public struct SizeF
[C++]
public __value struct SizeF

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

SizeF Members | System.Drawing Namespace


SizeF Members

Public:

Constructor

SizeF Constructor Overloaded. [To be supplied.]

Properties

Height | [To be supplied.]
IsEmpty | [To be supplied.]
Width | [To be supplied.]

Methods

Equals | Tests to see if the two sizes represent the same logical size. Doesn't actually test for object identity equality.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | A string representation of a SizeF

Operators and Type Conversions

Addition Operator | Expands a SizeF by another SizeF.
Subtraction Operator | Contracts a SizeF by another SizeF.
SizeF to Size Conversion | [To be supplied.]
SizeF to PointF Conversion | [To be supplied.]

Fields

Empty [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SizeF Structure | System.Drawing Namespace


SizeF Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(SizeF)
[C#] public SizeF(SizeF);
[C++] public: SizeF(SizeF);
[JScript] public function SizeF(SizeF);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(PointF)
[C#] public SizeF(PointF);
[C++] public: SizeF(PointF);
[JScript] public function SizeF(PointF);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Single, Single)
[C#] public SizeF(float, float);
[C++] public: SizeF(float, float);
[JScript] public function SizeF(float, float);

See Also

SizeF Structure | SizeF Members | System.Drawing Namespace


SizeF Constructor (SizeF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal size As SizeF _
)
[C#]
public SizeF(
   SizeF size
);
[C++]
public: SizeF(
   SizeF size
);
[JScript]
public function SizeF(
   size : SizeF
);

Parameters

size
[To be supplied.]

See Also

SizeF Structure | SizeF Members | System.Drawing Namespace | SizeF Constructor Overload List


SizeF Constructor (PointF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal pt As PointF _
)
[C#]
public SizeF(
   PointF pt
);
[C++]
public: SizeF(
   PointF pt
);
[JScript]
public function SizeF(
   pt : PointF
);

Parameters

pt
[To be supplied.]

See Also

SizeF Structure | SizeF Members | System.Drawing Namespace | SizeF Constructor Overload List


SizeF Constructor (Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal width As Single, _
   ByVal height As Single _
)
[C#]
public SizeF(
   float width,
   float height
);
[C++]
public: SizeF(
   float width,
   float height
);
[JScript]
public function SizeF(
   width : float,
   height : float
);

Parameters

width
[To be supplied.]
height
[To be supplied.]

See Also

SizeF Structure | SizeF Members | System.Drawing Namespace | SizeF Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SizeF Properties

The properties of the SizeF structure are listed below. For a complete list of SizeF structure members, see the SizeF Members topic.

Public:

Height | [To be supplied.]
IsEmpty | [To be supplied.]
Width | [To be supplied.]

See Also

SizeF Structure | System.Drawing Namespace


SizeF.Height

[To be supplied.]

[Visual Basic]
Public Property Height As Single
[C#]
public float Height {get; set;}
[C++]
public: __property float get_Height();
public: __property void set_Height(float);
[JScript]
public function get Height() : float;
public function set Height(float);

See Also

SizeF Structure | SizeF Members | System.Drawing Namespace


SizeF.IsEmpty

[To be supplied.]

[Visual Basic]
Public ReadOnly Property IsEmpty As Boolean
[C#]
public bool IsEmpty {get;}
[C++]
public: __property bool get_IsEmpty();
[JScript]
public function get IsEmpty() : Boolean;

See Also

SizeF Structure | SizeF Members | System.Drawing Namespace


SizeF.Width

[To be supplied.]

[Visual Basic]
Public Property Width As Single
[C#]
public float Width {get; set;}
[C++]
public: __property float get_Width();
public: __property void set_Width(float);
[JScript]
public function get Width() : float;
public function set Width(float);

See Also

SizeF Structure | SizeF Members | System.Drawing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SizeF Methods

The methods of the SizeF structure are listed below. For a complete list of SizeF structure members, see the SizeF Members topic.

Public:

Equals | Tests to see if the two sizes represent the same logical size. Doesn't actually test for object identity equality.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | A string representation of a SizeF

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SizeF Structure | System.Drawing Namespace


SizeF.Equals

Tests to see if the two sizes represent the same logical size. Doesn't actually test for object identity equality.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
Test to see if this object is the same as the current one.

Return Value

boolean indicating true if they are the same, false otherwise.

See Also

SizeF Structure | SizeF Members | System.Drawing Namespace


SizeF.ToString

A string representation of a SizeF

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

SizeF Structure | SizeF Members | System.Drawing Namespace


Operators and Type Conversions

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SizeF Operators and Type Conversions

The operators and type conversions of the SizeF structure are listed below. For a complete list of SizeF structure members, see the SizeF Members topic.

Public:

Addition Operator | Expands a SizeF by another SizeF.
Subtraction Operator | Contracts a SizeF by another SizeF.
SizeF to Size Conversion | [To be supplied.]
SizeF to PointF Conversion | [To be supplied.]

See Also

SizeF Structure | System.Drawing Namespace


SizeF Addition Operator

Expands a SizeF by another SizeF.

[C#]
public static SizeF operator +(
   SizeF sz1,
   SizeF sz2
);
[C++]
public: static SizeF operator op_Addition(
   SizeF sz1,
   SizeF sz2
);
[JScript]
returnValue = sz1 + sz2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

sz1
SizeF to expand.
sz2
SizeF to expand sz1 by.

Parameters [C#, C++]

sz1
SizeF to expand.
sz2
SizeF to expand sz1 by.

See Also

SizeF Structure | SizeF Members | System.Drawing Namespace


SizeF Subtraction Operator

Contracts a SizeF by another SizeF.

[C#]
public static SizeF operator -(
   SizeF sz1,
   SizeF sz2
);
[C++]
public: static SizeF operator op_Subtraction(
   SizeF sz1,
   SizeF sz2
);
[JScript]
returnValue = sz1 - sz2;

[Visual Basic] In Visual Basic, you cannot use the operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

sz1
SizeF to contract.
sz2
SizeF to contract sz1 by.

Parameters [C#, C++]

sz1
SizeF to contract.
sz2
SizeF to contract sz1 by.

See Also

SizeF Structure | SizeF Members | System.Drawing Namespace


SizeF to Size Conversion

[To be supplied.]

[C#]
public static explicit operator Size(
   SizeF p
);
[C++]
public: operator Size();
[JScript]
returnValue = Size(p);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

p
[To be supplied.]

Parameters [C#]

p
[To be supplied.]

See Also

SizeF Structure | SizeF Members | System.Drawing Namespace


SizeF to PointF Conversion

[To be supplied.]

[C#]
public static explicit operator PointF(
   SizeF size
);
[C++]
public: operator PointF();
[JScript]
returnValue = PointF(size);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

size
[To be supplied.]

Parameters [C#]

size
[To be supplied.]

See Also

SizeF Structure | SizeF Members | System.Drawing Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SizeF Fields

The fields of the SizeF structure are listed below. For a complete list of SizeF structure members, see the SizeF Members topic.

Public:

Empty [To be supplied.]

See Also

SizeF Structure | System.Drawing Namespace


SizeF.Empty

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Empty As SizeF
[C#]
public static readonly SizeF Empty;
[C++]
public: static readonly SizeF Empty;
[JScript]
public static var Empty : SizeF;

See Also

SizeF Structure | SizeF Members | System.Drawing Namespace


SolidBrush Class

[To be supplied.]

Object
MarshalByRefObject
Brush
SolidBrush

[Visual Basic]
NotInheritable Public Class SolidBrush
   Inherits Brush
   Implements ISystemColorTracker
[C#]
public sealed class SolidBrush : Brush, ISystemColorTracker
[C++]
public __gc __sealed class SolidBrush : public Brush,
   ISystemColorTracker
[JScript]
public class SolidBrush extends Brush, ISystemColorTracker

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

SolidBrush Members | System.Drawing Namespace


SolidBrush Members

Public:

Constructor

SolidBrush Constructor [To be supplied.]

Properties

Color [To be supplied.]

Methods

Clone | [To be supplied.]
Dispose (inherited from Brush) | Deletes this Brush.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
OnSystemColorChanged | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Brush) | Releases memory allocated for this Brush.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SolidBrush Class | System.Drawing Namespace


SolidBrush Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal color As Color _
)
[C#]
public SolidBrush(
   Color color
);
[C++]
public: SolidBrush(
   Color color
);
[JScript]
public function SolidBrush(
   color : Color
);

Parameters

color
[To be supplied.]

See Also

SolidBrush Class | SolidBrush Members | System.Drawing Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SolidBrush Properties

The properties of the SolidBrush class are listed below. For a complete list of SolidBrush class members, see the SolidBrush Members topic.

Public:

Color [To be supplied.]

See Also

SolidBrush Class | System.Drawing Namespace


SolidBrush.Color

[To be supplied.]

[Visual Basic]
Public Property Color As Color
[C#]
public Color Color {get; set;}
[C++]
public: __property Color get_Color();
public: __property void set_Color(Color);
[JScript]
public function get Color() : Color;
public function set Color(Color);

See Also

SolidBrush Class | SolidBrush Members | System.Drawing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SolidBrush Methods

The methods of the SolidBrush class are listed below. For a complete list of SolidBrush class members, see the SolidBrush Members topic.

Public:

Clone | [To be supplied.]
Dispose (inherited from Brush) | Deletes this Brush.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
OnSystemColorChanged | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Brush) | Releases memory allocated for this Brush.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SolidBrush Class | System.Drawing Namespace


SolidBrush.Clone

[To be supplied.]

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
public: override Object* Clone();
[JScript]
public override function Clone() : Object;

See Also

SolidBrush Class | SolidBrush Members | System.Drawing Namespace


SolidBrush.OnSystemColorChanged

[To be supplied.]

[Visual Basic]
Overridable Public Sub OnSystemColorChanged()
[C#]
public virtual void OnSystemColorChanged();
[C++]
public: virtual void OnSystemColorChanged();
[JScript]
public function OnSystemColorChanged();

See Also

SolidBrush Class | SolidBrush Members | System.Drawing Namespace


StringAlignment Enumeration

[To be supplied.]

[Visual Basic]
Public Enum StringAlignment
[C#]
public enum StringAlignment
[C++]
public enum StringAlignment

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Center | [To be supplied.]
Far | [To be supplied.]
Near | [To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

System.Drawing Namespace


StringFormat Class

[To be supplied.]

Object
MarshalByRefObject
StringFormat

[Visual Basic]
NotInheritable Public Class StringFormat
   Inherits MarshalByRefObject
   Implements ICloneable
[C#]
public sealed class StringFormat : MarshalByRefObject, ICloneable
[C++]
public __gc __sealed class StringFormat : public
   MarshalByRefObject, ICloneable
[JScript]
public class StringFormat extends MarshalByRefObject, ICloneable

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

StringFormat Members | System.Drawing Namespace


StringFormat Members

Public:

Constructor

StringFormat Constructor Overloaded. [To be supplied.]

Properties

Alignment | [To be supplied.]
FormatFlags | [To be supplied.]
GenericDefault | [To be supplied.]
GenericTypographic | [To be supplied.]
HotkeyPrefix | [To be supplied.]
LineAlignment | [To be supplied.]
Trimming | [To be supplied.]

Methods

Clone | [To be supplied.]
Dispose | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetLineSpacing | [To be supplied.]
GetTabStops | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
SetLineSpacing | Overloaded. [To be supplied.]
SetTabStops | [To be supplied.]
ToString | [To be supplied.]

Protected:

Methods

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StringFormat Class | System.Drawing Namespace


StringFormat Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public StringFormat();
[C++] public: StringFormat();
[JScript] public function StringFormat();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(StringFormatFlags)
[C#] public StringFormat(StringFormatFlags);
[C++] public: StringFormat(StringFormatFlags);
[JScript] public function StringFormat(StringFormatFlags);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(StringFormatFlags, Integer)
[C#] public StringFormat(StringFormatFlags, int);
[C++] public: StringFormat(StringFormatFlags, int);
[JScript] public function StringFormat(StringFormatFlags, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(StringFormat)
[C#] public StringFormat(StringFormat);
[C++] public: StringFormat(StringFormat*);
[JScript] public function StringFormat(StringFormat);

See Also

StringFormat Class | StringFormat Members | System.Drawing Namespace


StringFormat Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public StringFormat();
[C++]
public: StringFormat();
[JScript]
public function StringFormat();

See Also

StringFormat Class | StringFormat Members | System.Drawing Namespace | StringFormat Constructor Overload List


StringFormat Constructor (StringFormatFlags)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal options As StringFormatFlags _
)
[C#]
public StringFormat(
   StringFormatFlags options
);
[C++]
public: StringFormat(
   StringFormatFlags options
);
[JScript]
public function StringFormat(
   options : StringFormatFlags
);

Parameters

options
[To be supplied.]

See Also

StringFormat Class | StringFormat Members | System.Drawing Namespace | StringFormat Constructor Overload List


StringFormat Constructor (StringFormatFlags, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal options As StringFormatFlags, _
   ByVal language As Integer _
)
[C#]
public StringFormat(
   StringFormatFlags options,
   int language
);
[C++]
public: StringFormat(
   StringFormatFlags options,
   int language
);
[JScript]
public function StringFormat(
   options : StringFormatFlags,
   language : int
);

Parameters

options
[To be supplied.]
language
[To be supplied.]

See Also

StringFormat Class | StringFormat Members | System.Drawing Namespace | StringFormat Constructor Overload List


StringFormat Constructor (StringFormat)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal format As StringFormat _
)
[C#]
public StringFormat(
   StringFormat format
);
[C++]
public: StringFormat(
   StringFormat* format
);
[JScript]
public function StringFormat(
   format : StringFormat
);

Parameters

format
[To be supplied.]

See Also

StringFormat Class | StringFormat Members | System.Drawing Namespace | StringFormat Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StringFormat Properties

The properties of the StringFormat class are listed below. For a complete list of StringFormat class members, see the StringFormat Members topic.

Public:

Alignment | [To be supplied.]
FormatFlags | [To be supplied.]
GenericDefault | [To be supplied.]
GenericTypographic | [To be supplied.]
HotkeyPrefix | [To be supplied.]
LineAlignment | [To be supplied.]
Trimming | [To be supplied.]

See Also

StringFormat Class | System.Drawing Namespace


StringFormat.Alignment

[To be supplied.]

[Visual Basic]
Public Property Alignment As StringAlignment
[C#]
public StringAlignment Alignment {get; set;}
[C++]
public: __property StringAlignment get_Alignment();
public: __property void set_Alignment(StringAlignment);
[JScript]
public function get Alignment() : StringAlignment;
public function set Alignment(StringAlignment);

See Also

StringFormat Class | StringFormat Members | System.Drawing Namespace


StringFormat.FormatFlags

[To be supplied.]

[Visual Basic]
Public Property FormatFlags As StringFormatFlags
[C#]
public StringFormatFlags FormatFlags {get; set;}
[C++]
public: __property StringFormatFlags get_FormatFlags();
public: __property void set_FormatFlags(StringFormatFlags);
[JScript]
public function get FormatFlags() : StringFormatFlags;
public function set FormatFlags(StringFormatFlags);

See Also

StringFormat Class | StringFormat Members | System.Drawing Namespace


StringFormat.GenericDefault

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property GenericDefault As StringFormat
[C#]
public static StringFormat GenericDefault {get;}
[C++]
public: __property static StringFormat* get_GenericDefault();
[JScript]
public static function get GenericDefault() : StringFormat;

See Also

StringFormat Class | StringFormat Members | System.Drawing Namespace


StringFormat.GenericTypographic

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property GenericTypographic As StringFormat
[C#]
public static StringFormat GenericTypographic {get;}
[C++]
public: __property static StringFormat* get_GenericTypographic();
[JScript]
public static function get GenericTypographic() : StringFormat;

See Also

StringFormat Class | StringFormat Members | System.Drawing Namespace


StringFormat.HotkeyPrefix

[To be supplied.]

[Visual Basic]
Public Property HotkeyPrefix As HotkeyPrefix
[C#]
public HotkeyPrefix HotkeyPrefix {get; set;}
[C++]
public: __property HotkeyPrefix get_HotkeyPrefix();
public: __property void set_HotkeyPrefix(HotkeyPrefix);
[JScript]
public function get HotkeyPrefix() : HotkeyPrefix;
public function set HotkeyPrefix(HotkeyPrefix);

See Also

StringFormat Class | StringFormat Members | System.Drawing Namespace


StringFormat.LineAlignment

[To be supplied.]

[Visual Basic]
Public Property LineAlignment As StringAlignment
[C#]
public StringAlignment LineAlignment {get; set;}
[C++]
public: __property StringAlignment get_LineAlignment();
public: __property void set_LineAlignment(StringAlignment);
[JScript]
public function get LineAlignment() : StringAlignment;
public function set LineAlignment(StringAlignment);

See Also

StringFormat Class | StringFormat Members | System.Drawing Namespace


StringFormat.Trimming

[To be supplied.]

[Visual Basic]
Public Property Trimming As StringTrimming
[C#]
public StringTrimming Trimming {get; set;}
[C++]
public: __property StringTrimming get_Trimming();
public: __property void set_Trimming(StringTrimming);
[JScript]
public function get Trimming() : StringTrimming;
public function set Trimming(StringTrimming);

See Also

StringFormat Class | StringFormat Members | System.Drawing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StringFormat Methods

The methods of the StringFormat class are listed below. For a complete list of StringFormat class members, see the StringFormat Members topic.

Public:

Clone | [To be supplied.]
Dispose | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetLineSpacing | [To be supplied.]
GetTabStops | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
SetLineSpacing | Overloaded. [To be supplied.]
SetTabStops | [To be supplied.]
ToString | [To be supplied.]

Protected:

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StringFormat Class | System.Drawing Namespace


StringFormat.Clone

[To be supplied.]

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

See Also

StringFormat Class | StringFormat Members | System.Drawing Namespace


StringFormat.Dispose

[To be supplied.]

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[JScript]
public function Dispose();

See Also

StringFormat Class | StringFormat Members | System.Drawing Namespace


StringFormat.Finalize

[To be supplied.]

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

StringFormat Class | StringFormat Members | System.Drawing Namespace


StringFormat.GetLineSpacing

[To be supplied.]

[Visual Basic]
Public Sub GetLineSpacing( _
   ByRef amount As Single, _
   ByRef method As LineSpacing _
)
[C#]
public void GetLineSpacing(
   ref float amount,
   ref LineSpacing method
);
[C++]
public: void GetLineSpacing(
   float** amount,
   LineSpacing** method
);
[JScript]
public function GetLineSpacing(
   amount : float,
   method : LineSpacing
);

Parameters

amount
[To be supplied.]
method
[To be supplied.]

See Also

StringFormat Class | StringFormat Members | System.Drawing Namespace


StringFormat.GetTabStops

[To be supplied.]

[Visual Basic]
Public Function GetTabStops( _
   ByRef firstTabOffset As Single _
) As Single ()
[C#]
public float[] GetTabStops(
   ref float firstTabOffset
);
[C++]
public: float* GetTabStops(
   float** firstTabOffset
) [];
[JScript]
public function GetTabStops(
   firstTabOffset : float
) : float[];

Parameters

firstTabOffset
[To be supplied.]

See Also

StringFormat Class | StringFormat Members | System.Drawing Namespace


StringFormat.SetLineSpacing

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub SetLineSpacing(Single)
[C#] public void SetLineSpacing(float);
[C++] public: void SetLineSpacing(float);
[JScript] public function SetLineSpacing(float);

[To be supplied.]

[Visual Basic] Overloads Public Sub SetLineSpacing()
[C#] public void SetLineSpacing();
[C++] public: void SetLineSpacing();
[JScript] public function SetLineSpacing();

[To be supplied.]

[Visual Basic] Overloads Public Sub SetLineSpacing(Single, LineSpacing)
[C#] public void SetLineSpacing(float, LineSpacing);
[C++] public: void SetLineSpacing(float, LineSpacing);
[JScript] public function SetLineSpacing(float, LineSpacing);

See Also

StringFormat Class | StringFormat Members | System.Drawing Namespace


StringFormat.SetLineSpacing (Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetLineSpacing( _
   ByVal amount As Single _
)
[C#]
public void SetLineSpacing(
   float amount
);
[C++]
public: void SetLineSpacing(
   float amount
);
[JScript]
public function SetLineSpacing(
   amount : float
);

Parameters

amount
[To be supplied.]

See Also

StringFormat Class | StringFormat Members | System.Drawing Namespace | StringFormat.SetLineSpacing Overload List


StringFormat.SetLineSpacing ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetLineSpacing()
[C#]
public void SetLineSpacing();
[C++]
public: void SetLineSpacing();
[JScript]
public function SetLineSpacing();

See Also

StringFormat Class | StringFormat Members | System.Drawing Namespace | StringFormat.SetLineSpacing Overload List


StringFormat.SetLineSpacing (Single, LineSpacing)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetLineSpacing( _
   ByVal amount As Single, _
   ByVal method As LineSpacing _
)
[C#]
public void SetLineSpacing(
   float amount,
   LineSpacing method
);
[C++]
public: void SetLineSpacing(
   float amount,
   LineSpacing method
);
[JScript]
public function SetLineSpacing(
   amount : float,
   method : LineSpacing
);

Parameters

amount
[To be supplied.]
method
[To be supplied.]

See Also

StringFormat Class | StringFormat Members | System.Drawing Namespace | StringFormat.SetLineSpacing Overload List


StringFormat.SetTabStops

[To be supplied.]

[Visual Basic]
Public Sub SetTabStops( _
   ByVal firstTabOffset As Single, _
   ByVal tabStops() As Single _
)
[C#]
public void SetTabStops(
   float firstTabOffset,
   float[] tabStops
);
[C++]
public: void SetTabStops(
   float firstTabOffset,
   float* tabStops[]
);
[JScript]
public function SetTabStops(
   firstTabOffset : float,
   tabStops : float[]
);

Parameters

firstTabOffset
[To be supplied.]
tabStops
[To be supplied.]

See Also

StringFormat Class | StringFormat Members | System.Drawing Namespace


StringFormat.ToString

[To be supplied.]

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

See Also

StringFormat Class | StringFormat Members | System.Drawing Namespace


StringFormatFlags Enumeration

[To be supplied.]

[Visual Basic]
Public Enum StringFormatFlags
[C#]
public enum StringFormatFlags
[C++]
public enum StringFormatFlags

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
DirectionRightToLeft | [To be supplied.]
DirectionVertical | [To be supplied.]
DisableKashidaJustification | [To be supplied.]
DisableKerning | [To be supplied.]
DisableLigatures | [To be supplied.]
DisplayFormatControl | [To be supplied.]
FitBlackBox | [To be supplied.]
LayoutLegacyBidi | [To be supplied.]
LineLimit | [To be supplied.]
MeasureTrailingSpaces | [To be supplied.]
NoChanges | [To be supplied.]
NoClip | [To be supplied.]
NoFontFallback | [To be supplied.]
NoWrap | [To be supplied.]
NumberContextArabic | [To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

System.Drawing Namespace


StringTrimming Enumeration

[To be supplied.]

[Visual Basic]
Public Enum StringTrimming
[C#]
public enum StringTrimming
[C++]
public enum StringTrimming

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Character | [To be supplied.]
EllipsisCharacter | [To be supplied.]
EllipsisPath | [To be supplied.]
EllipsisWord | [To be supplied.]
None | [To be supplied.]
Word | [To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

System.Drawing Namespace


StringUnit Enumeration

[To be supplied.]

[Visual Basic]
Public Enum StringUnit
[C#]
public enum StringUnit
[C++]
public enum StringUnit

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Display | [To be supplied.]
Document | [To be supplied.]
Em | [To be supplied.]
Inch | [To be supplied.]
Millimeter | [To be supplied.]
Pixel | [To be supplied.]
Point | [To be supplied.]
World | [To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

System.Drawing Namespace


SystemBrushes Class

Brushes for select Windows system-wide colors. Whenever possible, try to use SystemPens and SystemBrushes rather than SystemColors.

Object
SystemBrushes

[Visual Basic]
NotInheritable Public Class SystemBrushes
[C#]
public sealed class SystemBrushes
[C++]
public __gc __sealed class SystemBrushes
[JScript]
public class SystemBrushes

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

SystemBrushes Members | System.Drawing Namespace | Brush | SystemPens | SystemColors


SystemBrushes Members

Public:

Properties

ActiveBorder | Brush is the color of the active window border.
ActiveCaption | Brush is the color of the active caption bar.
ActiveCaptionText | Brush is the color of the active caption bar.
AppWorkspace | Brush is the color of the app workspace window.
Control | Brush is the control color, which is the surface color for 3D elements.
ControlDark | Brush is the shadow part of a 3D element.
ControlDarkDark | Brush is the darkest part of a 3D element.
ControlLight | Brush is the highlight part of a 3D element.
ControlLightLight | Brush is the lighest part of a 3D element.
ControlText | Brush is the color of text on controls.
Desktop | Brush is the color of the desktop.
Highlight | Brush is the color of the background of highlighted elements.
HighlightText | Brush is the color of the foreground of highlighted elements.
HotTrack | Brush is the color used to represent hot tracking.
InactiveBorder | Brush is the color if an inactive window border.
InactiveCaption | Brush is the color of an inactive caption bar.
Info | Brush is the color of the background of the info tooltip.
Menu | Brush is the color of the menu background.
ScrollBar | Brush is the color of a scroll bar background.
Window | Brush is the color of the window background.
WindowText | Brush is the color of text on controls.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SystemBrushes Class | System.Drawing Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SystemBrushes Properties

The properties of the SystemBrushes class are listed below. For a complete list of SystemBrushes class members, see the SystemBrushes Members topic.

Public:

ActiveBorder | Brush is the color of the active window border.
ActiveCaption | Brush is the color of the active caption bar.
ActiveCaptionText | Brush is the color of the active caption bar.
AppWorkspace | Brush is the color of the app workspace window.
Control | Brush is the control color, which is the surface color for 3D elements.
ControlDark | Brush is the shadow part of a 3D element.
ControlDarkDark | Brush is the darkest part of a 3D element.
ControlLight | Brush is the highlight part of a 3D element.
ControlLightLight | Brush is the lighest part of a 3D element.
ControlText | Brush is the color of text on controls.
Desktop | Brush is the color of the desktop.
Highlight | Brush is the color of the background of highlighted elements.
HighlightText | Brush is the color of the foreground of highlighted elements.
HotTrack | Brush is the color used to represent hot tracking.
InactiveBorder | Brush is the color if an inactive window border.
InactiveCaption | Brush is the color of an inactive caption bar.
Info | Brush is the color of the background of the info tooltip.
Menu | Brush is the color of the menu background.
ScrollBar | Brush is the color of a scroll bar background.
Window | Brush is the color of the window background.
WindowText | Brush is the color of text on controls.

See Also

SystemBrushes Class | System.Drawing Namespace


SystemBrushes.ActiveBorder

Brush is the color of the active window border.

[Visual Basic]
Public Shared ReadOnly Property ActiveBorder As Brush
[C#]
public static Brush ActiveBorder {get;}
[C++]
public: __property static Brush* get_ActiveBorder();
[JScript]
public static function get ActiveBorder() : Brush;

See Also

SystemBrushes Class | SystemBrushes Members | System.Drawing Namespace


SystemBrushes.ActiveCaption

Brush is the color of the active caption bar.

[Visual Basic]
Public Shared ReadOnly Property ActiveCaption As Brush
[C#]
public static Brush ActiveCaption {get;}
[C++]
public: __property static Brush* get_ActiveCaption();
[JScript]
public static function get ActiveCaption() : Brush;

See Also

SystemBrushes Class | SystemBrushes Members | System.Drawing Namespace


SystemBrushes.ActiveCaptionText

Brush is the color of the active caption bar.

[Visual Basic]
Public Shared ReadOnly Property ActiveCaptionText As Brush
[C#]
public static Brush ActiveCaptionText {get;}
[C++]
public: __property static Brush* get_ActiveCaptionText();
[JScript]
public static function get ActiveCaptionText() : Brush;

See Also

SystemBrushes Class | SystemBrushes Members | System.Drawing Namespace


SystemBrushes.AppWorkspace

Brush is the color of the app workspace window.

[Visual Basic]
Public Shared ReadOnly Property AppWorkspace As Brush
[C#]
public static Brush AppWorkspace {get;}
[C++]
public: __property static Brush* get_AppWorkspace();
[JScript]
public static function get AppWorkspace() : Brush;

See Also

SystemBrushes Class | SystemBrushes Members | System.Drawing Namespace


SystemBrushes.Control

Brush is the control color, which is the surface color for 3D elements.

[Visual Basic]
Public Shared ReadOnly Property Control As Brush
[C#]
public static Brush Control {get;}
[C++]
public: __property static Brush* get_Control();
[JScript]
public static function get Control() : Brush;

See Also

SystemBrushes Class | SystemBrushes Members | System.Drawing Namespace


SystemBrushes.ControlDark

Brush is the shadow part of a 3D element.

[Visual Basic]
Public Shared ReadOnly Property ControlDark As Brush
[C#]
public static Brush ControlDark {get;}
[C++]
public: __property static Brush* get_ControlDark();
[JScript]
public static function get ControlDark() : Brush;

See Also

SystemBrushes Class | SystemBrushes Members | System.Drawing Namespace


SystemBrushes.ControlDarkDark

Brush is the darkest part of a 3D element.

[Visual Basic]
Public Shared ReadOnly Property ControlDarkDark As Brush
[C#]
public static Brush ControlDarkDark {get;}
[C++]
public: __property static Brush* get_ControlDarkDark();
[JScript]
public static function get ControlDarkDark() : Brush;

See Also

SystemBrushes Class | SystemBrushes Members | System.Drawing Namespace


SystemBrushes.ControlLight

Brush is the highlight part of a 3D element.

[Visual Basic]
Public Shared ReadOnly Property ControlLight As Brush
[C#]
public static Brush ControlLight {get;}
[C++]
public: __property static Brush* get_ControlLight();
[JScript]
public static function get ControlLight() : Brush;

See Also

SystemBrushes Class | SystemBrushes Members | System.Drawing Namespace


SystemBrushes.ControlLightLight

Brush is the lighest part of a 3D element.

[Visual Basic]
Public Shared ReadOnly Property ControlLightLight As Brush
[C#]
public static Brush ControlLightLight {get;}
[C++]
public: __property static Brush* get_ControlLightLight();
[JScript]
public static function get ControlLightLight() : Brush;

See Also

SystemBrushes Class | SystemBrushes Members | System.Drawing Namespace


SystemBrushes.ControlText

Brush is the color of text on controls.

[Visual Basic]
Public Shared ReadOnly Property ControlText As Brush
[C#]
public static Brush ControlText {get;}
[C++]
public: __property static Brush* get_ControlText();
[JScript]
public static function get ControlText() : Brush;

See Also

SystemBrushes Class | SystemBrushes Members | System.Drawing Namespace


SystemBrushes.Desktop

Brush is the color of the desktop.

[Visual Basic]
Public Shared ReadOnly Property Desktop As Brush
[C#]
public static Brush Desktop {get;}
[C++]
public: __property static Brush* get_Desktop();
[JScript]
public static function get Desktop() : Brush;

See Also

SystemBrushes Class | SystemBrushes Members | System.Drawing Namespace


SystemBrushes.Highlight

Brush is the color of the background of highlighted elements.

[Visual Basic]
Public Shared ReadOnly Property Highlight As Brush
[C#]
public static Brush Highlight {get;}
[C++]
public: __property static Brush* get_Highlight();
[JScript]
public static function get Highlight() : Brush;

See Also

SystemBrushes Class | SystemBrushes Members | System.Drawing Namespace


SystemBrushes.HighlightText

Brush is the color of the foreground of highlighted elements.

[Visual Basic]
Public Shared ReadOnly Property HighlightText As Brush
[C#]
public static Brush HighlightText {get;}
[C++]
public: __property static Brush* get_HighlightText();
[JScript]
public static function get HighlightText() : Brush;

See Also

SystemBrushes Class | SystemBrushes Members | System.Drawing Namespace


SystemBrushes.HotTrack

Brush is the color used to represent hot tracking.

[Visual Basic]
Public Shared ReadOnly Property HotTrack As Brush
[C#]
public static Brush HotTrack {get;}
[C++]
public: __property static Brush* get_HotTrack();
[JScript]
public static function get HotTrack() : Brush;

See Also

SystemBrushes Class | SystemBrushes Members | System.Drawing Namespace


SystemBrushes.InactiveBorder

Brush is the color if an inactive window border.

[Visual Basic]
Public Shared ReadOnly Property InactiveBorder As Brush
[C#]
public static Brush InactiveBorder {get;}
[C++]
public: __property static Brush* get_InactiveBorder();
[JScript]
public static function get InactiveBorder() : Brush;

See Also

SystemBrushes Class | SystemBrushes Members | System.Drawing Namespace


SystemBrushes.InactiveCaption

Brush is the color of an inactive caption bar.

[Visual Basic]
Public Shared ReadOnly Property InactiveCaption As Brush
[C#]
public static Brush InactiveCaption {get;}
[C++]
public: __property static Brush* get_InactiveCaption();
[JScript]
public static function get InactiveCaption() : Brush;

See Also

SystemBrushes Class | SystemBrushes Members | System.Drawing Namespace


SystemBrushes.Info

Brush is the color of the background of the info tooltip.

[Visual Basic]
Public Shared ReadOnly Property Info As Brush
[C#]
public static Brush Info {get;}
[C++]
public: __property static Brush* get_Info();
[JScript]
public static function get Info() : Brush;

See Also

SystemBrushes Class | SystemBrushes Members | System.Drawing Namespace


SystemBrushes.Menu

Brush is the color of the menu background.

[Visual Basic]
Public Shared ReadOnly Property Menu As Brush
[C#]
public static Brush Menu {get;}
[C++]
public: __property static Brush* get_Menu();
[JScript]
public static function get Menu() : Brush;

See Also

SystemBrushes Class | SystemBrushes Members | System.Drawing Namespace


SystemBrushes.ScrollBar

Brush is the color of a scroll bar background.

[Visual Basic]
Public Shared ReadOnly Property ScrollBar As Brush
[C#]
public static Brush ScrollBar {get;}
[C++]
public: __property static Brush* get_ScrollBar();
[JScript]
public static function get ScrollBar() : Brush;

See Also

SystemBrushes Class | SystemBrushes Members | System.Drawing Namespace


SystemBrushes.Window

Brush is the color of the window background.

[Visual Basic]
Public Shared ReadOnly Property Window As Brush
[C#]
public static Brush Window {get;}
[C++]
public: __property static Brush* get_Window();
[JScript]
public static function get Window() : Brush;

See Also

SystemBrushes Class | SystemBrushes Members | System.Drawing Namespace


SystemBrushes.WindowText

Brush is the color of text on controls.

[Visual Basic]
Public Shared ReadOnly Property WindowText As Brush
[C#]
public static Brush WindowText {get;}
[C++]
public: __property static Brush* get_WindowText();
[JScript]
public static function get WindowText() : Brush;

See Also

SystemBrushes Class | SystemBrushes Members | System.Drawing Namespace


SystemColors Class

Windows system-wide colors. Whenever possible, try to use SystemPens and SystemBrushes rather than SystemColors.

Object
SystemColors

[Visual Basic]
NotInheritable Public Class SystemColors
[C#]
public sealed class SystemColors
[C++]
public __gc __sealed class SystemColors
[JScript]
public class SystemColors

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

SystemColors Members | System.Drawing Namespace | Color | SystemPens | SystemBrushes


SystemColors Members

Public:

Constructor

SystemColors Constructor [To be supplied.]

Properties

ActiveBorder | The color of the filled area of an active window border.
ActiveCaption | The color of the background of an active title bar caption.
ActiveCaptionText | The color of the text of an active title bar caption.
AppWorkspace | The color of the application workspace. The application workspace is the area in a multiple document view that is not being occupied by documents.
Control | The color of the background of push buttons and other 3D objects.
ControlDark | The color of shadows on 3D objects.
ControlDarkDark | The color of very dark shadows on 3D objects.
ControlLight | The color of highlights on 3D objects.
ControlLightLight | The color of very light highlights on 3D objects.
ControlText | The color of the text of push buttons and other 3D objects
Desktop | This color is the user-defined color of the Windows desktop.
GrayText | The color of text that is being shown in a disabled, or grayed-out state.
Highlight | The color of the background of highlighted text. This includes selected menu items as well as selected text.
HighlightText | The color of the text of highlighted text. This includes selected menu items as well as selected text.
HotTrack | The hot track color.
InactiveBorder | The color of the filled area of an inactive window border.
InactiveCaption | The color of the background of an inactive title bar caption.
InactiveCaptionText | The color of the text of an inactive title bar caption.
Info | The color of the info/tool tip background.
InfoText | The color of the info/tool tip text.
Menu | The color of the background of a menu.
MenuText | The color of the text on a menu.
ScrollBar | The color of the scroll bar area that is not being used by the thumb button.
Window | The color of the client area of a window.
WindowFrame | The color of the thin frame drawn around a window.
WindowText | The color of the text in the client area of a window.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SystemColors Class | System.Drawing Namespace


SystemColors Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public SystemColors();
[C++]
public: SystemColors();
[JScript]
public function SystemColors();

See Also

SystemColors Class | SystemColors Members | System.Drawing Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SystemColors Properties

The properties of the SystemColors class are listed below. For a complete list of SystemColors class members, see the SystemColors Members topic.

Public:

ActiveBorder | The color of the filled area of an active window border.
ActiveCaption | The color of the background of an active title bar caption.
ActiveCaptionText | The color of the text of an active title bar caption.
AppWorkspace | The color of the application workspace. The application workspace is the area in a multiple document view that is not being occupied by documents.
Control | The color of the background of push buttons and other 3D objects.
ControlDark | The color of shadows on 3D objects.
ControlDarkDark | The color of very dark shadows on 3D objects.
ControlLight | The color of highlights on 3D objects.
ControlLightLight | The color of very light highlights on 3D objects.
ControlText | The color of the text of push buttons and other 3D objects
Desktop | This color is the user-defined color of the Windows desktop.
GrayText | The color of text that is being shown in a disabled, or grayed-out state.
Highlight | The color of the background of highlighted text. This includes selected menu items as well as selected text.
HighlightText | The color of the text of highlighted text. This includes selected menu items as well as selected text.
HotTrack | The hot track color.
InactiveBorder | The color of the filled area of an inactive window border.
InactiveCaption | The color of the background of an inactive title bar caption.
InactiveCaptionText | The color of the text of an inactive title bar caption.
Info | The color of the info/tool tip background.
InfoText | The color of the info/tool tip text.
Menu | The color of the background of a menu.
MenuText | The color of the text on a menu.
ScrollBar | The color of the scroll bar area that is not being used by the thumb button.
Window | The color of the client area of a window.
WindowFrame | The color of the thin frame drawn around a window.
WindowText | The color of the text in the client area of a window.

See Also

SystemColors Class | System.Drawing Namespace


SystemColors.ActiveBorder

The color of the filled area of an active window border.

[Visual Basic]
Public Shared ReadOnly Property ActiveBorder As Color
[C#]
public static Color ActiveBorder {get;}
[C++]
public: __property static Color get_ActiveBorder();
[JScript]
public static function get ActiveBorder() : Color;

See Also

SystemColors Class | SystemColors Members | System.Drawing Namespace


SystemColors.ActiveCaption

The color of the background of an active title bar caption.

[Visual Basic]
Public Shared ReadOnly Property ActiveCaption As Color
[C#]
public static Color ActiveCaption {get;}
[C++]
public: __property static Color get_ActiveCaption();
[JScript]
public static function get ActiveCaption() : Color;

See Also

SystemColors Class | SystemColors Members | System.Drawing Namespace


SystemColors.ActiveCaptionText

The color of the text of an active title bar caption.

[Visual Basic]
Public Shared ReadOnly Property ActiveCaptionText As Color
[C#]
public static Color ActiveCaptionText {get;}
[C++]
public: __property static Color get_ActiveCaptionText();
[JScript]
public static function get ActiveCaptionText() : Color;

See Also

SystemColors Class | SystemColors Members | System.Drawing Namespace


SystemColors.AppWorkspace

The color of the application workspace. The application workspace is the area in a multiple document view that is not being occupied by documents.

[Visual Basic]
Public Shared ReadOnly Property AppWorkspace As Color
[C#]
public static Color AppWorkspace {get;}
[C++]
public: __property static Color get_AppWorkspace();
[JScript]
public static function get AppWorkspace() : Color;

See Also

SystemColors Class | SystemColors Members | System.Drawing Namespace


SystemColors.Control

The color of the background of push buttons and other 3D objects.

[Visual Basic]
Public Shared ReadOnly Property Control As Color
[C#]
public static Color Control {get;}
[C++]
public: __property static Color get_Control();
[JScript]
public static function get Control() : Color;

See Also

SystemColors Class | SystemColors Members | System.Drawing Namespace


SystemColors.ControlDark

The color of shadows on 3D objects.

[Visual Basic]
Public Shared ReadOnly Property ControlDark As Color
[C#]
public static Color ControlDark {get;}
[C++]
public: __property static Color get_ControlDark();
[JScript]
public static function get ControlDark() : Color;

See Also

SystemColors Class | SystemColors Members | System.Drawing Namespace


SystemColors.ControlDarkDark

The color of very dark shadows on 3D objects.

[Visual Basic]
Public Shared ReadOnly Property ControlDarkDark As Color
[C#]
public static Color ControlDarkDark {get;}
[C++]
public: __property static Color get_ControlDarkDark();
[JScript]
public static function get ControlDarkDark() : Color;

See Also

SystemColors Class | SystemColors Members | System.Drawing Namespace


SystemColors.ControlLight

The color of highlights on 3D objects.

[Visual Basic]
Public Shared ReadOnly Property ControlLight As Color
[C#]
public static Color ControlLight {get;}
[C++]
public: __property static Color get_ControlLight();
[JScript]
public static function get ControlLight() : Color;

See Also

SystemColors Class | SystemColors Members | System.Drawing Namespace


SystemColors.ControlLightLight

The color of very light highlights on 3D objects.

[Visual Basic]
Public Shared ReadOnly Property ControlLightLight As Color
[C#]
public static Color ControlLightLight {get;}
[C++]
public: __property static Color get_ControlLightLight();
[JScript]
public static function get ControlLightLight() : Color;

See Also

SystemColors Class | SystemColors Members | System.Drawing Namespace


SystemColors.ControlText

The color of the text of push buttons and other 3D objects

[Visual Basic]
Public Shared ReadOnly Property ControlText As Color
[C#]
public static Color ControlText {get;}
[C++]
public: __property static Color get_ControlText();
[JScript]
public static function get ControlText() : Color;

See Also

SystemColors Class | SystemColors Members | System.Drawing Namespace


SystemColors.Desktop

This color is the user-defined color of the Windows desktop.

[Visual Basic]
Public Shared ReadOnly Property Desktop As Color
[C#]
public static Color Desktop {get;}
[C++]
public: __property static Color get_Desktop();
[JScript]
public static function get Desktop() : Color;

See Also

SystemColors Class | SystemColors Members | System.Drawing Namespace


SystemColors.GrayText

The color of text that is being shown in a disabled, or grayed-out state.

[Visual Basic]
Public Shared ReadOnly Property GrayText As Color
[C#]
public static Color GrayText {get;}
[C++]
public: __property static Color get_GrayText();
[JScript]
public static function get GrayText() : Color;

See Also

SystemColors Class | SystemColors Members | System.Drawing Namespace


SystemColors.Highlight

The color of the background of highlighted text. This includes selected menu items as well as selected text.

[Visual Basic]
Public Shared ReadOnly Property Highlight As Color
[C#]
public static Color Highlight {get;}
[C++]
public: __property static Color get_Highlight();
[JScript]
public static function get Highlight() : Color;

See Also

SystemColors Class | SystemColors Members | System.Drawing Namespace


SystemColors.HighlightText

The color of the text of highlighted text. This includes selected menu items as well as selected text.

[Visual Basic]
Public Shared ReadOnly Property HighlightText As Color
[C#]
public static Color HighlightText {get;}
[C++]
public: __property static Color get_HighlightText();
[JScript]
public static function get HighlightText() : Color;

See Also

SystemColors Class | SystemColors Members | System.Drawing Namespace


SystemColors.HotTrack

The hot track color.

[Visual Basic]
Public Shared ReadOnly Property HotTrack As Color
[C#]
public static Color HotTrack {get;}
[C++]
public: __property static Color get_HotTrack();
[JScript]
public static function get HotTrack() : Color;

See Also

SystemColors Class | SystemColors Members | System.Drawing Namespace


SystemColors.InactiveBorder

The color of the filled area of an inactive window border.

[Visual Basic]
Public Shared ReadOnly Property InactiveBorder As Color
[C#]
public static Color InactiveBorder {get;}
[C++]
public: __property static Color get_InactiveBorder();
[JScript]
public static function get InactiveBorder() : Color;

See Also

SystemColors Class | SystemColors Members | System.Drawing Namespace


SystemColors.InactiveCaption

The color of the background of an inactive title bar caption.

[Visual Basic]
Public Shared ReadOnly Property InactiveCaption As Color
[C#]
public static Color InactiveCaption {get;}
[C++]
public: __property static Color get_InactiveCaption();
[JScript]
public static function get InactiveCaption() : Color;

See Also

SystemColors Class | SystemColors Members | System.Drawing Namespace


SystemColors.InactiveCaptionText

The color of the text of an inactive title bar caption.

[Visual Basic]
Public Shared ReadOnly Property InactiveCaptionText As Color
[C#]
public static Color InactiveCaptionText {get;}
[C++]
public: __property static Color get_InactiveCaptionText();
[JScript]
public static function get InactiveCaptionText() : Color;

See Also

SystemColors Class | SystemColors Members | System.Drawing Namespace


SystemColors.Info

The color of the info/tool tip background.

[Visual Basic]
Public Shared ReadOnly Property Info As Color
[C#]
public static Color Info {get;}
[C++]
public: __property static Color get_Info();
[JScript]
public static function get Info() : Color;

See Also

SystemColors Class | SystemColors Members | System.Drawing Namespace


SystemColors.InfoText

The color of the info/tool tip text.

[Visual Basic]
Public Shared ReadOnly Property InfoText As Color
[C#]
public static Color InfoText {get;}
[C++]
public: __property static Color get_InfoText();
[JScript]
public static function get InfoText() : Color;

See Also

SystemColors Class | SystemColors Members | System.Drawing Namespace


SystemColors.Menu

The color of the background of a menu.

[Visual Basic]
Public Shared ReadOnly Property Menu As Color
[C#]
public static Color Menu {get;}
[C++]
public: __property static Color get_Menu();
[JScript]
public static function get Menu() : Color;

See Also

SystemColors Class | SystemColors Members | System.Drawing Namespace


SystemColors.MenuText

The color of the text on a menu.

[Visual Basic]
Public Shared ReadOnly Property MenuText As Color
[C#]
public static Color MenuText {get;}
[C++]
public: __property static Color get_MenuText();
[JScript]
public static function get MenuText() : Color;

See Also

SystemColors Class | SystemColors Members | System.Drawing Namespace


SystemColors.ScrollBar

The color of the scroll bar area that is not being used by the thumb button.

[Visual Basic]
Public Shared ReadOnly Property ScrollBar As Color
[C#]
public static Color ScrollBar {get;}
[C++]
public: __property static Color get_ScrollBar();
[JScript]
public static function get ScrollBar() : Color;

See Also

SystemColors Class | SystemColors Members | System.Drawing Namespace


SystemColors.Window

The color of the client area of a window.

[Visual Basic]
Public Shared ReadOnly Property Window As Color
[C#]
public static Color Window {get;}
[C++]
public: __property static Color get_Window();
[JScript]
public static function get Window() : Color;

See Also

SystemColors Class | SystemColors Members | System.Drawing Namespace


SystemColors.WindowFrame

The color of the thin frame drawn around a window.

[Visual Basic]
Public Shared ReadOnly Property WindowFrame As Color
[C#]
public static Color WindowFrame {get;}
[C++]
public: __property static Color get_WindowFrame();
[JScript]
public static function get WindowFrame() : Color;

See Also

SystemColors Class | SystemColors Members | System.Drawing Namespace


SystemColors.WindowText

The color of the text in the client area of a window.

[Visual Basic]
Public Shared ReadOnly Property WindowText As Color
[C#]
public static Color WindowText {get;}
[C++]
public: __property static Color get_WindowText();
[JScript]
public static function get WindowText() : Color;

See Also

SystemColors Class | SystemColors Members | System.Drawing Namespace


SystemIcons Class

Icon objects for Windows system-wide icons.

Object
SystemIcons

[Visual Basic]
NotInheritable Public Class SystemIcons
[C#]
public sealed class SystemIcons
[C++]
public __gc __sealed class SystemIcons
[JScript]
public class SystemIcons

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

SystemIcons Members | System.Drawing Namespace | Icon


SystemIcons Members

Public:

Constructor

SystemIcons Constructor [To be supplied.]

Properties

Application | Icon is the default Application icon. (WIN32: IDI_APPLICATION)
Asterisk | Icon is the system Asterisk icon. (WIN32: IDI_ASTERISK)
Error | Icon is the system Error icon. (WIN32: IDI_ERROR)
Exclamation | Icon is the system Exclamation icon. (WIN32: IDI_EXCLAMATION)
Hand | Icon is the system Hand icon. (WIN32: IDI_HAND)
Information | Icon is the system Information icon. (WIN32: IDI_INFORMATION)
Question | Icon is the system Question icon. (WIN32: IDI_QUESTION)
Warning | Icon is the system Warning icon. (WIN32: IDI_WARNING)
WinLogo | Icon is the Windows Logo icon. (WIN32: IDI_WINLOGO)

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SystemIcons Class | System.Drawing Namespace


SystemIcons Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public SystemIcons();
[C++]
public: SystemIcons();
[JScript]
public function SystemIcons();

See Also

SystemIcons Class | SystemIcons Members | System.Drawing Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SystemIcons Properties

The properties of the SystemIcons class are listed below. For a complete list of SystemIcons class members, see the SystemIcons Members topic.

Public:

Application | Icon is the default Application icon. (WIN32: IDI_APPLICATION)
Asterisk | Icon is the system Asterisk icon. (WIN32: IDI_ASTERISK)
Error | Icon is the system Error icon. (WIN32: IDI_ERROR)
Exclamation | Icon is the system Exclamation icon. (WIN32: IDI_EXCLAMATION)
Hand | Icon is the system Hand icon. (WIN32: IDI_HAND)
Information | Icon is the system Information icon. (WIN32: IDI_INFORMATION)
Question | Icon is the system Question icon. (WIN32: IDI_QUESTION)
Warning | Icon is the system Warning icon. (WIN32: IDI_WARNING)
WinLogo | Icon is the Windows Logo icon. (WIN32: IDI_WINLOGO)

See Also

SystemIcons Class | System.Drawing Namespace


SystemIcons.Application

Icon is the default Application icon. (WIN32: IDI_APPLICATION)

[Visual Basic]
Public Shared ReadOnly Property Application As Icon
[C#]
public static Icon Application {get;}
[C++]
public: __property static Icon* get_Application();
[JScript]
public static function get Application() : Icon;

See Also

SystemIcons Class | SystemIcons Members | System.Drawing Namespace


SystemIcons.Asterisk

Icon is the system Asterisk icon. (WIN32: IDI_ASTERISK)

[Visual Basic]
Public Shared ReadOnly Property Asterisk As Icon
[C#]
public static Icon Asterisk {get;}
[C++]
public: __property static Icon* get_Asterisk();
[JScript]
public static function get Asterisk() : Icon;

See Also

SystemIcons Class | SystemIcons Members | System.Drawing Namespace


SystemIcons.Error

Icon is the system Error icon. (WIN32: IDI_ERROR)

[Visual Basic]
Public Shared ReadOnly Property Error As Icon
[C#]
public static Icon Error {get;}
[C++]
public: __property static Icon* get_Error();
[JScript]
public static function get Error() : Icon;

See Also

SystemIcons Class | SystemIcons Members | System.Drawing Namespace


SystemIcons.Exclamation

Icon is the system Exclamation icon. (WIN32: IDI_EXCLAMATION)

[Visual Basic]
Public Shared ReadOnly Property Exclamation As Icon
[C#]
public static Icon Exclamation {get;}
[C++]
public: __property static Icon* get_Exclamation();
[JScript]
public static function get Exclamation() : Icon;

See Also

SystemIcons Class | SystemIcons Members | System.Drawing Namespace


SystemIcons.Hand

Icon is the system Hand icon. (WIN32: IDI_HAND)

[Visual Basic]
Public Shared ReadOnly Property Hand As Icon
[C#]
public static Icon Hand {get;}
[C++]
public: __property static Icon* get_Hand();
[JScript]
public static function get Hand() : Icon;

See Also

SystemIcons Class | SystemIcons Members | System.Drawing Namespace


SystemIcons.Information

Icon is the system Information icon. (WIN32: IDI_INFORMATION)

[Visual Basic]
Public Shared ReadOnly Property Information As Icon
[C#]
public static Icon Information {get;}
[C++]
public: __property static Icon* get_Information();
[JScript]
public static function get Information() : Icon;

See Also

SystemIcons Class | SystemIcons Members | System.Drawing Namespace


SystemIcons.Question

Icon is the system Question icon. (WIN32: IDI_QUESTION)

[Visual Basic]
Public Shared ReadOnly Property Question As Icon
[C#]
public static Icon Question {get;}
[C++]
public: __property static Icon* get_Question();
[JScript]
public static function get Question() : Icon;

See Also

SystemIcons Class | SystemIcons Members | System.Drawing Namespace


SystemIcons.Warning

Icon is the system Warning icon. (WIN32: IDI_WARNING)

[Visual Basic]
Public Shared ReadOnly Property Warning As Icon
[C#]
public static Icon Warning {get;}
[C++]
public: __property static Icon* get_Warning();
[JScript]
public static function get Warning() : Icon;

See Also

SystemIcons Class | SystemIcons Members | System.Drawing Namespace


SystemIcons.WinLogo

Icon is the Windows Logo icon. (WIN32: IDI_WINLOGO)

[Visual Basic]
Public Shared ReadOnly Property WinLogo As Icon
[C#]
public static Icon WinLogo {get;}
[C++]
public: __property static Icon* get_WinLogo();
[JScript]
public static function get WinLogo() : Icon;

See Also

SystemIcons Class | SystemIcons Members | System.Drawing Namespace


SystemPens Class

Pens for select Windows system-wide colors. Whenever possible, try to use SystemPens and SystemBrushes rather than SystemColors.

Object
SystemPens

[Visual Basic]
NotInheritable Public Class SystemPens
[C#]
public sealed class SystemPens
[C++]
public __gc __sealed class SystemPens
[JScript]
public class SystemPens

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

SystemPens Members | System.Drawing Namespace | Pen | SystemBrushes | SystemColors


SystemPens Members

Public:

Properties

ActiveCaptionText | Pen is the color of the active window's caption text.
Control | Pen is the color of a button or control.
ControlDark | Pen is the color of the shadow part of a 3D element
ControlLightLight | Pen is the color of the lightest part of a 3D element
ControlText | Pen is the color of the text on a button or control.
GrayText | Pen is the color of disabled text.
Highlight | Pen is the color of a highlighted background.
HighlightText | Pen is the color of highlighted text.
InactiveCaptionText | Pen is the color of an inactive window's caption text.
InfoText | Pen is the color of the info tooltip's text.
MenuText | Pen is the color of the menu text.
WindowFrame | Pen is the color of the window frame.
WindowText | Pen is the color of a window's text.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SystemPens Class | System.Drawing Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SystemPens Properties

The properties of the SystemPens class are listed below. For a complete list of SystemPens class members, see the SystemPens Members topic.

Public:

ActiveCaptionText | Pen is the color of the active window's caption text.
Control | Pen is the color of a button or control.
ControlDark | Pen is the color of the shadow part of a 3D element
ControlLightLight | Pen is the color of the lightest part of a 3D element
ControlText | Pen is the color of the text on a button or control.
GrayText | Pen is the color of disabled text.
Highlight | Pen is the color of a highlighted background.
HighlightText | Pen is the color of highlighted text.
InactiveCaptionText | Pen is the color of an inactive window's caption text.
InfoText | Pen is the color of the info tooltip's text.
MenuText | Pen is the color of the menu text.
WindowFrame | Pen is the color of the window frame.
WindowText | Pen is the color of a window's text.

See Also

SystemPens Class | System.Drawing Namespace


SystemPens.ActiveCaptionText

Pen is the color of the active window's caption text.

[Visual Basic]
Public Shared ReadOnly Property ActiveCaptionText As Pen
[C#]
public static Pen ActiveCaptionText {get;}
[C++]
public: __property static Pen* get_ActiveCaptionText();
[JScript]
public static function get ActiveCaptionText() : Pen;

See Also

SystemPens Class | SystemPens Members | System.Drawing Namespace


SystemPens.Control

Pen is the color of a button or control.

[Visual Basic]
Public Shared ReadOnly Property Control As Pen
[C#]
public static Pen Control {get;}
[C++]
public: __property static Pen* get_Control();
[JScript]
public static function get Control() : Pen;

See Also

SystemPens Class | SystemPens Members | System.Drawing Namespace


SystemPens.ControlDark

Pen is the color of the shadow part of a 3D element

[Visual Basic]
Public Shared ReadOnly Property ControlDark As Pen
[C#]
public static Pen ControlDark {get;}
[C++]
public: __property static Pen* get_ControlDark();
[JScript]
public static function get ControlDark() : Pen;

See Also

SystemPens Class | SystemPens Members | System.Drawing Namespace


SystemPens.ControlLightLight

Pen is the color of the lightest part of a 3D element

[Visual Basic]
Public Shared ReadOnly Property ControlLightLight As Pen
[C#]
public static Pen ControlLightLight {get;}
[C++]
public: __property static Pen* get_ControlLightLight();
[JScript]
public static function get ControlLightLight() : Pen;

See Also

SystemPens Class | SystemPens Members | System.Drawing Namespace


SystemPens.ControlText

Pen is the color of the text on a button or control.

[Visual Basic]
Public Shared ReadOnly Property ControlText As Pen
[C#]
public static Pen ControlText {get;}
[C++]
public: __property static Pen* get_ControlText();
[JScript]
public static function get ControlText() : Pen;

See Also

SystemPens Class | SystemPens Members | System.Drawing Namespace


SystemPens.GrayText

Pen is the color of disabled text.

[Visual Basic]
Public Shared ReadOnly Property GrayText As Pen
[C#]
public static Pen GrayText {get;}
[C++]
public: __property static Pen* get_GrayText();
[JScript]
public static function get GrayText() : Pen;

See Also

SystemPens Class | SystemPens Members | System.Drawing Namespace


SystemPens.Highlight

Pen is the color of a highlighted background.

[Visual Basic]
Public Shared ReadOnly Property Highlight As Pen
[C#]
public static Pen Highlight {get;}
[C++]
public: __property static Pen* get_Highlight();
[JScript]
public static function get Highlight() : Pen;

See Also

SystemPens Class | SystemPens Members | System.Drawing Namespace


SystemPens.HighlightText

Pen is the color of highlighted text.

[Visual Basic]
Public Shared ReadOnly Property HighlightText As Pen
[C#]
public static Pen HighlightText {get;}
[C++]
public: __property static Pen* get_HighlightText();
[JScript]
public static function get HighlightText() : Pen;

See Also

SystemPens Class | SystemPens Members | System.Drawing Namespace


SystemPens.InactiveCaptionText

Pen is the color of an inactive window's caption text.

[Visual Basic]
Public Shared ReadOnly Property InactiveCaptionText As Pen
[C#]
public static Pen InactiveCaptionText {get;}
[C++]
public: __property static Pen* get_InactiveCaptionText();
[JScript]
public static function get InactiveCaptionText() : Pen;

See Also

SystemPens Class | SystemPens Members | System.Drawing Namespace


SystemPens.InfoText

Pen is the color of the info tooltip's text.

[Visual Basic]
Public Shared ReadOnly Property InfoText As Pen
[C#]
public static Pen InfoText {get;}
[C++]
public: __property static Pen* get_InfoText();
[JScript]
public static function get InfoText() : Pen;

See Also

SystemPens Class | SystemPens Members | System.Drawing Namespace


SystemPens.MenuText

Pen is the color of the menu text.

[Visual Basic]
Public Shared ReadOnly Property MenuText As Pen
[C#]
public static Pen MenuText {get;}
[C++]
public: __property static Pen* get_MenuText();
[JScript]
public static function get MenuText() : Pen;

See Also

SystemPens Class | SystemPens Members | System.Drawing Namespace


SystemPens.WindowFrame

Pen is the color of the window frame.

[Visual Basic]
Public Shared ReadOnly Property WindowFrame As Pen
[C#]
public static Pen WindowFrame {get;}
[C++]
public: __property static Pen* get_WindowFrame();
[JScript]
public static function get WindowFrame() : Pen;

See Also

SystemPens Class | SystemPens Members | System.Drawing Namespace


SystemPens.WindowText

Pen is the color of a window's text.

[Visual Basic]
Public Shared ReadOnly Property WindowText As Pen
[C#]
public static Pen WindowText {get;}
[C++]
public: __property static Pen* get_WindowText();
[JScript]
public static function get WindowText() : Pen;

See Also

SystemPens Class | SystemPens Members | System.Drawing Namespace


TextureBrush Class

[To be supplied.]

Object
MarshalByRefObject
Brush
TextureBrush

[Visual Basic]
NotInheritable Public Class TextureBrush
   Inherits Brush
[C#]
public sealed class TextureBrush : Brush
[C++]
public __gc __sealed class TextureBrush : public Brush
[JScript]
public class TextureBrush extends Brush

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

TextureBrush Members | System.Drawing Namespace


TextureBrush Members

Public:

Constructor

TextureBrush Constructor Overloaded. [To be supplied.]

Properties

Bitmap | [To be supplied.]
Image | [To be supplied.]
Transform | [To be supplied.]
WrapMode | [To be supplied.]

Methods

Clone | [To be supplied.]
Dispose (inherited from Brush) | Deletes this Brush.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
MultiplyTransform | Overloaded. [To be supplied.]
ResetTransform | [To be supplied.]
RotateTransform | Overloaded. [To be supplied.]
ScaleTransform | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.
TranslateTransform | Overloaded. [To be supplied.]

Protected:

Methods

Finalize (inherited from Brush) | Releases memory allocated for this Brush.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TextureBrush Class | System.Drawing Namespace


TextureBrush Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Image)
[C#] public TextureBrush(Image);
[C++] public: TextureBrush(Image*);
[JScript] public function TextureBrush(Image);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Image, WrapMode)
[C#] public TextureBrush(Image, WrapMode);
[C++] public: TextureBrush(Image*, WrapMode);
[JScript] public function TextureBrush(Image, WrapMode);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Image, WrapMode, RectangleF)
[C#] public TextureBrush(Image, WrapMode, RectangleF);
[C++] public: TextureBrush(Image*, WrapMode, RectangleF);
[JScript] public function TextureBrush(Image, WrapMode, RectangleF);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Image, WrapMode, Rectangle)
[C#] public TextureBrush(Image, WrapMode, Rectangle);
[C++] public: TextureBrush(Image*, WrapMode, Rectangle);
[JScript] public function TextureBrush(Image, WrapMode, Rectangle);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Image, RectangleF)
[C#] public TextureBrush(Image, RectangleF);
[C++] public: TextureBrush(Image*, RectangleF);
[JScript] public function TextureBrush(Image, RectangleF);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Image, RectangleF, ImageAttributes)
[C#] public TextureBrush(Image, RectangleF, ImageAttributes);
[C++] public: TextureBrush(Image*, RectangleF, ImageAttributes);
[JScript] public function TextureBrush(Image, RectangleF, ImageAttributes);

See Also

TextureBrush Class | TextureBrush Members | System.Drawing Namespace


TextureBrush Constructor (Image)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal bitmap As Image _
)
[C#]
public TextureBrush(
   Image bitmap
);
[C++]
public: TextureBrush(
   Image* bitmap
);
[JScript]
public function TextureBrush(
   bitmap : Image
);

Parameters

bitmap
[To be supplied.]

See Also

TextureBrush Class | TextureBrush Members | System.Drawing Namespace | TextureBrush Constructor Overload List


TextureBrush Constructor (Image, WrapMode)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal image As Image, _
   ByVal wrapMode As WrapMode _
)
[C#]
public TextureBrush(
   Image image,
   WrapMode wrapMode
);
[C++]
public: TextureBrush(
   Image* image,
   WrapMode wrapMode
);
[JScript]
public function TextureBrush(
   image : Image,
   wrapMode : WrapMode
);

Parameters

image
[To be supplied.]
wrapMode
[To be supplied.]

See Also

TextureBrush Class | TextureBrush Members | System.Drawing Namespace | TextureBrush Constructor Overload List


TextureBrush Constructor (Image, WrapMode, RectangleF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal image As Image, _
   ByVal wrapMode As WrapMode, _
   ByVal dstRect As RectangleF _
)
[C#]
public TextureBrush(
   Image image,
   WrapMode wrapMode,
   RectangleF dstRect
);
[C++]
public: TextureBrush(
   Image* image,
   WrapMode wrapMode,
   RectangleF dstRect
);
[JScript]
public function TextureBrush(
   image : Image,
   wrapMode : WrapMode,
   dstRect : RectangleF
);

Parameters

image
[To be supplied.]
wrapMode
[To be supplied.]
dstRect
[To be supplied.]

See Also

TextureBrush Class | TextureBrush Members | System.Drawing Namespace | TextureBrush Constructor Overload List


TextureBrush Constructor (Image, WrapMode, Rectangle)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal image As Image, _
   ByVal wrapMode As WrapMode, _
   ByVal dstRect As Rectangle _
)
[C#]
public TextureBrush(
   Image image,
   WrapMode wrapMode,
   Rectangle dstRect
);
[C++]
public: TextureBrush(
   Image* image,
   WrapMode wrapMode,
   Rectangle dstRect
);
[JScript]
public function TextureBrush(
   image : Image,
   wrapMode : WrapMode,
   dstRect : Rectangle
);

Parameters

image
[To be supplied.]
wrapMode
[To be supplied.]
dstRect
[To be supplied.]

See Also

TextureBrush Class | TextureBrush Members | System.Drawing Namespace | TextureBrush Constructor Overload List


TextureBrush Constructor (Image, RectangleF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal image As Image, _
   ByVal dstRect As RectangleF _
)
[C#]
public TextureBrush(
   Image image,
   RectangleF dstRect
);
[C++]
public: TextureBrush(
   Image* image,
   RectangleF dstRect
);
[JScript]
public function TextureBrush(
   image : Image,
   dstRect : RectangleF
);

Parameters

image
[To be supplied.]
dstRect
[To be supplied.]

See Also

TextureBrush Class | TextureBrush Members | System.Drawing Namespace | TextureBrush Constructor Overload List


TextureBrush Constructor (Image, RectangleF, ImageAttributes)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal image As Image, _
   ByVal dstRect As RectangleF, _
   ByVal imageAttr As ImageAttributes _
)
[C#]
public TextureBrush(
   Image image,
   RectangleF dstRect,
   ImageAttributes imageAttr
);
[C++]
public: TextureBrush(
   Image* image,
   RectangleF dstRect,
   ImageAttributes* imageAttr
);
[JScript]
public function TextureBrush(
   image : Image,
   dstRect : RectangleF,
   imageAttr : ImageAttributes
);

Parameters

image
[To be supplied.]
dstRect
[To be supplied.]
imageAttr
[To be supplied.]

See Also

TextureBrush Class | TextureBrush Members | System.Drawing Namespace | TextureBrush Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TextureBrush Properties

The properties of the TextureBrush class are listed below. For a complete list of TextureBrush class members, see the TextureBrush Members topic.

Public:

Bitmap | [To be supplied.]
Image | [To be supplied.]
Transform | [To be supplied.]
WrapMode | [To be supplied.]

See Also

TextureBrush Class | System.Drawing Namespace


TextureBrush.Bitmap

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Bitmap As Bitmap
[C#]
public Bitmap Bitmap {get;}
[C++]
public: __property Bitmap* get_Bitmap();
[JScript]
public function get Bitmap() : Bitmap;

See Also

TextureBrush Class | TextureBrush Members | System.Drawing Namespace


TextureBrush.Image

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Image As Image
[C#]
public Image Image {get;}
[C++]
public: __property Image* get_Image();
[JScript]
public function get Image() : Image;

See Also

TextureBrush Class | TextureBrush Members | System.Drawing Namespace


TextureBrush.Transform

[To be supplied.]

[Visual Basic]
Public Property Transform As Matrix
[C#]
public Matrix Transform {get; set;}
[C++]
public: __property Matrix* get_Transform();
public: __property void set_Transform(Matrix*);
[JScript]
public function get Transform() : Matrix;
public function set Transform(Matrix);

See Also

TextureBrush Class | TextureBrush Members | System.Drawing Namespace


TextureBrush.WrapMode

[To be supplied.]

[Visual Basic]
Public Property WrapMode As WrapMode
[C#]
public WrapMode WrapMode {get; set;}
[C++]
public: __property WrapMode get_WrapMode();
public: __property void set_WrapMode(WrapMode);
[JScript]
public function get WrapMode() : WrapMode;
public function set WrapMode(WrapMode);

See Also

TextureBrush Class | TextureBrush Members | System.Drawing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TextureBrush Methods

The methods of the TextureBrush class are listed below. For a complete list of TextureBrush class members, see the TextureBrush Members topic.

Public:

Clone | [To be supplied.]
Dispose (inherited from Brush) | Deletes this Brush.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
MultiplyTransform | Overloaded. [To be supplied.]
ResetTransform | [To be supplied.]
RotateTransform | Overloaded. [To be supplied.]
ScaleTransform | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.
TranslateTransform | Overloaded. [To be supplied.]

Protected:

Finalize (inherited from Brush) | Releases memory allocated for this Brush.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TextureBrush Class | System.Drawing Namespace


TextureBrush.Clone

[To be supplied.]

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
public: override Object* Clone();
[JScript]
public override function Clone() : Object;

See Also

TextureBrush Class | TextureBrush Members | System.Drawing Namespace


TextureBrush.MultiplyTransform

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub MultiplyTransform(Matrix, MatrixOrder)
[C#] public void MultiplyTransform(Matrix, MatrixOrder);
[C++] public: void MultiplyTransform(Matrix*, MatrixOrder);
[JScript] public function MultiplyTransform(Matrix, MatrixOrder);

[To be supplied.]

[Visual Basic] Overloads Public Sub MultiplyTransform(Matrix)
[C#] public void MultiplyTransform(Matrix);
[C++] public: void MultiplyTransform(Matrix*);
[JScript] public function MultiplyTransform(Matrix);

See Also

TextureBrush Class | TextureBrush Members | System.Drawing Namespace


TextureBrush.MultiplyTransform (Matrix, MatrixOrder)

[To be supplied.]

[Visual Basic]
Overloads Public Sub MultiplyTransform( _
   ByVal matrix As Matrix, _
   ByVal order As MatrixOrder _
)
[C#]
public void MultiplyTransform(
   Matrix matrix,
   MatrixOrder order
);
[C++]
public: void MultiplyTransform(
   Matrix* matrix,
   MatrixOrder order
);
[JScript]
public function MultiplyTransform(
   matrix : Matrix,
   order : MatrixOrder
);

Parameters

matrix
[To be supplied.]
order
[To be supplied.]

See Also

TextureBrush Class | TextureBrush Members | System.Drawing Namespace | TextureBrush.MultiplyTransform Overload List


TextureBrush.MultiplyTransform (Matrix)

[To be supplied.]

[Visual Basic]
Overloads Public Sub MultiplyTransform( _
   ByVal matrix As Matrix _
)
[C#]
public void MultiplyTransform(
   Matrix matrix
);
[C++]
public: void MultiplyTransform(
   Matrix* matrix
);
[JScript]
public function MultiplyTransform(
   matrix : Matrix
);

Parameters

matrix
[To be supplied.]

See Also

TextureBrush Class | TextureBrush Members | System.Drawing Namespace | TextureBrush.MultiplyTransform Overload List


TextureBrush.ResetTransform

[To be supplied.]

[Visual Basic]
Public Sub ResetTransform()
[C#]
public void ResetTransform();
[C++]
public: void ResetTransform();
[JScript]
public function ResetTransform();

See Also

TextureBrush Class | TextureBrush Members | System.Drawing Namespace


TextureBrush.RotateTransform

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub RotateTransform(Single)
[C#] public void RotateTransform(float);
[C++] public: void RotateTransform(float);
[JScript] public function RotateTransform(float);

[To be supplied.]

[Visual Basic] Overloads Public Sub RotateTransform(Single, MatrixOrder)
[C#] public void RotateTransform(float, MatrixOrder);
[C++] public: void RotateTransform(float, MatrixOrder);
[JScript] public function RotateTransform(float, MatrixOrder);

See Also

TextureBrush Class | TextureBrush Members | System.Drawing Namespace


TextureBrush.RotateTransform (Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub RotateTransform( _
   ByVal angle As Single _
)
[C#]
public void RotateTransform(
   float angle
);
[C++]
public: void RotateTransform(
   float angle
);
[JScript]
public function RotateTransform(
   angle : float
);

Parameters

angle
[To be supplied.]

See Also

TextureBrush Class | TextureBrush Members | System.Drawing Namespace | TextureBrush.RotateTransform Overload List


TextureBrush.RotateTransform (Single, MatrixOrder)

[To be supplied.]

[Visual Basic]
Overloads Public Sub RotateTransform( _
   ByVal angle As Single, _
   ByVal order As MatrixOrder _
)
[C#]
public void RotateTransform(
   float angle,
   MatrixOrder order
);
[C++]
public: void RotateTransform(
   float angle,
   MatrixOrder order
);
[JScript]
public function RotateTransform(
   angle : float,
   order : MatrixOrder
);

Parameters

angle
[To be supplied.]
order
[To be supplied.]

See Also

TextureBrush Class | TextureBrush Members | System.Drawing Namespace | TextureBrush.RotateTransform Overload List


TextureBrush.ScaleTransform

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub ScaleTransform(Single, Single)
[C#] public void ScaleTransform(float, float);
[C++] public: void ScaleTransform(float, float);
[JScript] public function ScaleTransform(float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub ScaleTransform(Single, Single, MatrixOrder)
[C#] public void ScaleTransform(float, float, MatrixOrder);
[C++] public: void ScaleTransform(float, float, MatrixOrder);
[JScript] public function ScaleTransform(float, float, MatrixOrder);

See Also

TextureBrush Class | TextureBrush Members | System.Drawing Namespace


TextureBrush.ScaleTransform (Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub ScaleTransform( _
   ByVal sx As Single, _
   ByVal sy As Single _
)
[C#]
public void ScaleTransform(
   float sx,
   float sy
);
[C++]
public: void ScaleTransform(
   float sx,
   float sy
);
[JScript]
public function ScaleTransform(
   sx : float,
   sy : float
);

Parameters

sx
[To be supplied.]
sy
[To be supplied.]

See Also

TextureBrush Class | TextureBrush Members | System.Drawing Namespace | TextureBrush.ScaleTransform Overload List


TextureBrush.ScaleTransform (Single, Single, MatrixOrder)

[To be supplied.]

[Visual Basic]
Overloads Public Sub ScaleTransform( _
   ByVal sx As Single, _
   ByVal sy As Single, _
   ByVal order As MatrixOrder _
)
[C#]
public void ScaleTransform(
   float sx,
   float sy,
   MatrixOrder order
);
[C++]
public: void ScaleTransform(
   float sx,
   float sy,
   MatrixOrder order
);
[JScript]
public function ScaleTransform(
   sx : float,
   sy : float,
   order : MatrixOrder
);

Parameters

sx
[To be supplied.]
sy
[To be supplied.]
order
[To be supplied.]

See Also

TextureBrush Class | TextureBrush Members | System.Drawing Namespace | TextureBrush.ScaleTransform Overload List


TextureBrush.TranslateTransform

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub TranslateTransform(Single, Single, MatrixOrder)
[C#] public void TranslateTransform(float, float, MatrixOrder);
[C++] public: void TranslateTransform(float, float, MatrixOrder);
[JScript] public function TranslateTransform(float, float, MatrixOrder);

[To be supplied.]

[Visual Basic] Overloads Public Sub TranslateTransform(Single, Single)
[C#] public void TranslateTransform(float, float);
[C++] public: void TranslateTransform(float, float);
[JScript] public function TranslateTransform(float, float);

See Also

TextureBrush Class | TextureBrush Members | System.Drawing Namespace


TextureBrush.TranslateTransform (Single, Single, MatrixOrder)

[To be supplied.]

[Visual Basic]
Overloads Public Sub TranslateTransform( _
   ByVal dx As Single, _
   ByVal dy As Single, _
   ByVal order As MatrixOrder _
)
[C#]
public void TranslateTransform(
   float dx,
   float dy,
   MatrixOrder order
);
[C++]
public: void TranslateTransform(
   float dx,
   float dy,
   MatrixOrder order
);
[JScript]
public function TranslateTransform(
   dx : float,
   dy : float,
   order : MatrixOrder
);

Parameters

dx
[To be supplied.]
dy
[To be supplied.]
order
[To be supplied.]

See Also

TextureBrush Class | TextureBrush Members | System.Drawing Namespace | TextureBrush.TranslateTransform Overload List


TextureBrush.TranslateTransform (Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub TranslateTransform( _
   ByVal dx As Single, _
   ByVal dy As Single _
)
[C#]
public void TranslateTransform(
   float dx,
   float dy
);
[C++]
public: void TranslateTransform(
   float dx,
   float dy
);
[JScript]
public function TranslateTransform(
   dx : float,
   dy : float
);

Parameters

dx
[To be supplied.]
dy
[To be supplied.]

See Also

TextureBrush Class | TextureBrush Members | System.Drawing Namespace | TextureBrush.TranslateTransform Overload List


ToolboxBitmapAttribute Class

ToolboxBitmapAttribute defines the images associated with a specified component. The component can offer a small and large image (large is optional).

Object
Attribute
MemberAttribute
ToolboxBitmapAttribute

[Visual Basic]
Public Class ToolboxBitmapAttribute
   Inherits MemberAttribute
[C#]
public class ToolboxBitmapAttribute : MemberAttribute
[C++]
public __gc class ToolboxBitmapAttribute : public MemberAttribute
[JScript]
public class ToolboxBitmapAttribute extends MemberAttribute

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing

Assembly: System.Drawing.dll

See Also

ToolboxBitmapAttribute Members | System.Drawing Namespace | MemberAttribute


ToolboxBitmapAttribute Members

Public:

Constructor

ToolboxBitmapAttribute Constructor Overloaded. [To be supplied.]

Properties

TypeId (inherited from MemberAttribute) Gets a unique ID for this MemberAttribute.

Methods

Equals (inherited from MemberAttribute) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetImage | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsDefaultAttribute (inherited from MemberAttribute) | When overridden in a derived class, specifies whether this MemberAttribute is the default attribute for the class.
Match (inherited from MemberAttribute) | Determines whether one attribute matches another.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Default Default name is null

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ToolboxBitmapAttribute Class | System.Drawing Namespace


ToolboxBitmapAttribute Constructor

[To be supplied.]

Overload List

Constructs a new ToolboxBitmapAttribute.

[Visual Basic] Overloads Public Sub New(Image)
[C#] public ToolboxBitmapAttribute(Image);
[C++] public: ToolboxBitmapAttribute(Image*);
[JScript] public function ToolboxBitmapAttribute(Image);

Constructs a new ToolboxBitmapAttribute.

[Visual Basic] Overloads Public Sub New(String)
[C#] public ToolboxBitmapAttribute(String);
[C++] public: ToolboxBitmapAttribute(String*);
[JScript] public function ToolboxBitmapAttribute(String);

Constructs a new ToolboxBitmapAttribute.

[Visual Basic] Overloads Public Sub New(Image, Image)
[C#] public ToolboxBitmapAttribute(Image, Image);
[C++] public: ToolboxBitmapAttribute(Image*, Image*);
[JScript] public function ToolboxBitmapAttribute(Image, Image);

See Also

ToolboxBitmapAttribute Class | ToolboxBitmapAttribute Members | System.Drawing Namespace


ToolboxBitmapAttribute Constructor (Image)

Constructs a new ToolboxBitmapAttribute.

[Visual Basic]
Overloads Public Sub New( _
   ByVal smallImage As Image _
)
[C#]
public ToolboxBitmapAttribute(
   Image smallImage
);
[C++]
public: ToolboxBitmapAttribute(
   Image* smallImage
);
[JScript]
public function ToolboxBitmapAttribute(
   smallImage : Image
);

Parameters

smallImage
16 x 16 bitmap for the component.

See Also

ToolboxBitmapAttribute Class | ToolboxBitmapAttribute Members | System.Drawing Namespace | ToolboxBitmapAttribute Constructor Overload List


ToolboxBitmapAttribute Constructor (String)

Constructs a new ToolboxBitmapAttribute.

[Visual Basic]
Overloads Public Sub New( _
   ByVal imageFile As String _
)
[C#]
public ToolboxBitmapAttribute(
   string imageFile
);
[C++]
public: ToolboxBitmapAttribute(
   String* imageFile
);
[JScript]
public function ToolboxBitmapAttribute(
   imageFile : String
);

Parameters

imageFile
the file neame for a 16 x 16 bitmap for the component.

See Also

ToolboxBitmapAttribute Class | ToolboxBitmapAttribute Members | System.Drawing Namespace | ToolboxBitmapAttribute Constructor Overload List


ToolboxBitmapAttribute Constructor (Image, Image)

Constructs a new ToolboxBitmapAttribute.

[Visual Basic]
Overloads Public Sub New( _
   ByVal smallImage As Image, _
   ByVal largeImage As Image _
)
[C#]
public ToolboxBitmapAttribute(
   Image smallImage,
   Image largeImage
);
[C++]
public: ToolboxBitmapAttribute(
   Image* smallImage,
   Image* largeImage
);
[JScript]
public function ToolboxBitmapAttribute(
   smallImage : Image,
   largeImage : Image
);

Parameters

smallImage
16 x 16 bitmap for the component.
largeImage
Any size bitmap for the component.

See Also

ToolboxBitmapAttribute Class | ToolboxBitmapAttribute Members | System.Drawing Namespace | ToolboxBitmapAttribute Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ToolboxBitmapAttribute Methods

The methods of the ToolboxBitmapAttribute class are listed below. For a complete list of ToolboxBitmapAttribute class members, see the ToolboxBitmapAttribute Members topic.

Public:

Equals (inherited from MemberAttribute) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetImage | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsDefaultAttribute (inherited from MemberAttribute) | When overridden in a derived class, specifies whether this MemberAttribute is the default attribute for the class.
Match (inherited from MemberAttribute) | Determines whether one attribute matches another.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ToolboxBitmapAttribute Class | System.Drawing Namespace


ToolboxBitmapAttribute.GetImage

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function GetImage(Object, Boolean) As Image
[C#] public Image GetImage(Object, bool);
[C++] public: Image* GetImage(Object*, bool);
[JScript] public function GetImage(Object, Boolean) : Image;

[To be supplied.]

[Visual Basic] Overloads Public Function GetImage(Object) As Image
[C#] public Image GetImage(Object);
[C++] public: Image* GetImage(Object*);
[JScript] public function GetImage(Object) : Image;

[To be supplied.]

[Visual Basic] Overloads Public Function GetImage(Type, Boolean) As Image
[C#] public Image GetImage(Type, bool);
[C++] public: Image* GetImage(Type*, bool);
[JScript] public function GetImage(Type, Boolean) : Image;

[To be supplied.]

[Visual Basic] Overloads Public Function GetImage(Type) As Image
[C#] public Image GetImage(Type);
[C++] public: Image* GetImage(Type*);
[JScript] public function GetImage(Type) : Image;

See Also

ToolboxBitmapAttribute Class | ToolboxBitmapAttribute Members | System.Drawing Namespace


ToolboxBitmapAttribute.GetImage (Object, Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Function GetImage( _
   ByVal component As Object, _
   ByVal large As Boolean _
) As Image
[C#]
public Image GetImage(
   object component,
   bool large
);
[C++]
public: Image* GetImage(
   Object* component,
   bool large
);
[JScript]
public function GetImage(
   component : Object,
   large : Boolean
) : Image;

Parameters

component
[To be supplied.]
large
[To be supplied.]

See Also

ToolboxBitmapAttribute Class | ToolboxBitmapAttribute Members | System.Drawing Namespace | ToolboxBitmapAttribute.GetImage Overload List


ToolboxBitmapAttribute.GetImage (Object)

[To be supplied.]

[Visual Basic]
Overloads Public Function GetImage( _
   ByVal component As Object _
) As Image
[C#]
public Image GetImage(
   object component
);
[C++]
public: Image* GetImage(
   Object* component
);
[JScript]
public function GetImage(
   component : Object
) : Image;

Parameters

component
[To be supplied.]

See Also

ToolboxBitmapAttribute Class | ToolboxBitmapAttribute Members | System.Drawing Namespace | ToolboxBitmapAttribute.GetImage Overload List


ToolboxBitmapAttribute.GetImage (Type, Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Function GetImage( _
   ByVal type As Type, _
   ByVal large As Boolean _
) As Image
[C#]
public Image GetImage(
   Type type,
   bool large
);
[C++]
public: Image* GetImage(
   Type* type,
   bool large
);
[JScript]
public function GetImage(
   type : Type,
   large : Boolean
) : Image;

Parameters

type
[To be supplied.]
large
[To be supplied.]

See Also

ToolboxBitmapAttribute Class | ToolboxBitmapAttribute Members | System.Drawing Namespace | ToolboxBitmapAttribute.GetImage Overload List


ToolboxBitmapAttribute.GetImage (Type)

[To be supplied.]

[Visual Basic]
Overloads Public Function GetImage( _
   ByVal type As Type _
) As Image
[C#]
public Image GetImage(
   Type type
);
[C++]
public: Image* GetImage(
   Type* type
);
[JScript]
public function GetImage(
   type : Type
) : Image;

Parameters

type
[To be supplied.]

See Also

ToolboxBitmapAttribute Class | ToolboxBitmapAttribute Members | System.Drawing Namespace | ToolboxBitmapAttribute.GetImage Overload List


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ToolboxBitmapAttribute Fields

The fields of the ToolboxBitmapAttribute class are listed below. For a complete list of ToolboxBitmapAttribute class members, see the ToolboxBitmapAttribute Members topic.

Public:

Default Default name is null

See Also

ToolboxBitmapAttribute Class | System.Drawing Namespace


ToolboxBitmapAttribute.Default

Default name is null

[Visual Basic]
Public Shared ReadOnly Default As ToolboxBitmapAttribute
[C#]
public static readonly ToolboxBitmapAttribute Default;
[C++]
public: static readonly ToolboxBitmapAttribute* Default;
[JScript]
public static var Default : ToolboxBitmapAttribute;

See Also

ToolboxBitmapAttribute Class | ToolboxBitmapAttribute Members | System.Drawing Namespace


System.Drawing.Design

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Drawing.Design Namespace

Classes

Class | Description
DrawingToolboxItem | [To be supplied.]
PropertyValueUIItem | Object that describes the extended UI glyph to be displayed on the property browser. These items will display glyphs that are painted in the right side of the property name column of the property grid.
ToolboxItem | Base implementation of a toolbox item. Toolbox items interact with the toolbox and allow a single item to describe multiple components.
UITypeEditor | UITypeEditor is an editor that provides a way to visually edit the values of a type. edit types.

Interfaces

Interface | Description
IPropertyValueUIService | This interface allows additional ui to be added to the property browser. When a property is painted, the PropertyValueUIHandler items added to this service will be invoked and handlers can be added to them. Each handler can add a small icon to the property that will be painted at the right side of the "property name" column. This icon can be clicked on to launch additional UI, etc.
IToolboxUser | A designer may implement this interface if it wants to be notified of toolbox actions.

Delegates

Delegate | Description
PropertyValueUIHandler | The delegate to be added to IPropertyValueUIService. When this delegate is fired, PropertyValueUIItem objects may be added to valueUIItemList.
PropertyValueUIItemInvokeHandler | Delegate handler that will be fired when an icon on PropertyValueUIItem is double clicked. Add a delegate of this type to the object that you want to be notified when the icon is double clicked.

Enumerations

Enumeration | Description
ToolboxItemInfoEnum | [To be supplied.]
UITypeEditorEditStyle | Defines the range of styles a UITypeEditor provides when editing an object.


DrawingToolboxItem Class

[To be supplied.]

Object
ToolboxItem
DrawingToolboxItem

[Visual Basic]
Public Class DrawingToolboxItem
   Inherits ToolboxItem
[C#]
public class DrawingToolboxItem : ToolboxItem
[C++]
public __gc class DrawingToolboxItem : public ToolboxItem
[JScript]
public class DrawingToolboxItem extends ToolboxItem

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Design

Assembly: System.Drawing.dll

See Also

DrawingToolboxItem Members | System.Drawing.Design Namespace


DrawingToolboxItem Members

Public:

Constructor

DrawingToolboxItem Constructor Overloaded. [To be supplied.]

Properties

AssemblyNames (inherited from ToolboxItem) | Retrieves the list of module paths associated with each type contained in this ToolboxItem
DisplayName (inherited from ToolboxItem) | Retrieves the display name for this ToolboxItem. This is the string that will be displayed for the item in the toolbox
Extension (inherited from ToolboxItem) | [To be supplied.]
Flags (inherited from ToolboxItem) | Retrieves the capability flags of this item.
ItemBitmap (inherited from ToolboxItem) | Retrieves the Bitmap that will be used on the toolbox for this item. This bitmap must be 16 x 16 pixels.
ItemCount (inherited from ToolboxItem) | Retrieves the number of Types contained in this ToolboxItem
ItemTypeNames (inherited from ToolboxItem) | Retrieves the fully-qualified string names of the Types contained in this ToolboxItem

Methods

CreateComponents (inherited from ToolboxItem) | Overloaded. [To be supplied.]
Equals (inherited from ToolboxItem) | [To be supplied.]
GetHashCode (inherited from ToolboxItem) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
Save (inherited from ToolboxItem) | Saves this ToolboxItem's state from the stream. If derived classes wish to do any special persistance they MUST override this method, and first call base.Save() before doing their own persistance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Events

ComponentsCreated (inherited from ToolboxItem) [To be supplied.]

Protected:

Methods

CreateComponentsCore (inherited from ToolboxItem) | Creates objects from each Type contained in this ToolboxItem, and adds them to the designer. You may override this method to alter the way components are created.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
Load (inherited from ToolboxItem) | Loads this ToolboxItem's state from the stream. If derived classes wish to do any special persistance they MUST override this method, and first call base.Load() before doing their own persistance.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnComponentsCreated (inherited from ToolboxItem) | Fires a handler that will be fired when this ToolboxItem creates a Component.

Event Hookup:

Methods

AddOnComponentsCreated (inherited from ToolboxItem) | Adds a handler that will be fired when this ToolboxItem creates a Component.
RemoveOnComponentsCreated (inherited from ToolboxItem) | Removes a handler that will be fired when this ToolboxItem creates a Component.

See Also

DrawingToolboxItem Class | System.Drawing.Design Namespace


DrawingToolboxItem Constructor

[To be supplied.]

Overload List

Basic ctor. Display name will be short type name.

[Visual Basic] Overloads Public Sub New(Type)
[C#] public DrawingToolboxItem(Type);
[C++] public: DrawingToolboxItem(Type*);
[JScript] public function DrawingToolboxItem(Type);

Basic ctor. Display name will be short type name.

[Visual Basic] Overloads Public Sub New(String)
[C#] public DrawingToolboxItem(String);
[C++] public: DrawingToolboxItem(String*);
[JScript] public function DrawingToolboxItem(String);

The stream based ctor. Derived classes of ToolboxItem MUST override and call this ctor, as well as the Load and Save methods.

[Visual Basic] Overloads Public Sub New(Stream)
[C#] public DrawingToolboxItem(Stream);
[C++] public: DrawingToolboxItem(Stream*);
[JScript] public function DrawingToolboxItem(Stream);

See Also

DrawingToolboxItem Class | DrawingToolboxItem Members | System.Drawing.Design Namespace


DrawingToolboxItem Constructor (Type)

Basic ctor. Display name will be short type name.

[Visual Basic]
Overloads Public Sub New( _
   ByVal toolType As Type _
)
[C#]
public DrawingToolboxItem(
   Type toolType
);
[C++]
public: DrawingToolboxItem(
   Type* toolType
);
[JScript]
public function DrawingToolboxItem(
   toolType : Type
);

Parameters

toolType
The Type of the tool for this toolbox item

See Also

DrawingToolboxItem Class | DrawingToolboxItem Members | System.Drawing.Design Namespace | DrawingToolboxItem Constructor Overload List


DrawingToolboxItem Constructor (String)

Basic ctor. Display name will be short type name.

[Visual Basic]
Overloads Public Sub New( _
   ByVal toolTypeName As String _
)
[C#]
public DrawingToolboxItem(
   string toolTypeName
);
[C++]
public: DrawingToolboxItem(
   String* toolTypeName
);
[JScript]
public function DrawingToolboxItem(
   toolTypeName : String
);

Parameters

toolTypeName
The fully qualified type name of the tool for this toolbox item

See Also

DrawingToolboxItem Class | DrawingToolboxItem Members | System.Drawing.Design Namespace | DrawingToolboxItem Constructor Overload List


DrawingToolboxItem Constructor (Stream)

The stream based ctor. Derived classes of ToolboxItem MUST override and call this ctor, as well as the Load and Save methods.

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream _
)
[C#]
public DrawingToolboxItem(
   Stream stream
);
[C++]
public: DrawingToolboxItem(
   Stream* stream
);
[JScript]
public function DrawingToolboxItem(
   stream : Stream
);

Parameters

stream
The stream to initalize from

See Also

DrawingToolboxItem Class | DrawingToolboxItem Members | System.Drawing.Design Namespace | DrawingToolboxItem Constructor Overload List | IPersistable


IPropertyValueUIService Interface

This interface allows additional ui to be added to the property browser. When a property is painted, the PropertyValueUIHandler items added to this service will be invoked and handlers can be added to them. Each handler can add a small icon to the property that will be painted at the right side of the "property name" column. This icon can be clicked on to launch additional UI, etc.

IPropertyValueUIService

[Visual Basic]
Public Interface IPropertyValueUIService
[C#]
public interface IPropertyValueUIService
[C++]
public __gc __interface IPropertyValueUIService

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Design

Assembly: System.Drawing.dll

See Also

IPropertyValueUIService Members | System.Drawing.Design Namespace


IPropertyValueUIService Members

Methods

AddPropertyValueUIHandler | Adds a PropertyValueUIHandler to this service. When GetPropertyUIValueItems is called, each handler added to this service will be called and given the opportunity to add an icon to the specified property.
GetPropertyUIValueItems | Gets all the PropertyValueUIItems that should be displayed on the given property. For each item returned, a glyph icon will be aded to the property.
RemovePropertyValueUIHandler | Removes a PropertyValueUIHandler to this service. When GetPropertyUIValueItems is called, each handler added to this service will be called and given the opportunity to add an icon to the specified property.

See Also

IPropertyValueUIService Interface | System.Drawing.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IPropertyValueUIService Methods

The methods of the IPropertyValueUIService interface are listed below. For a complete list of IPropertyValueUIService interface members, see the IPropertyValueUIService Members topic.

AddPropertyValueUIHandler | Adds a PropertyValueUIHandler to this service. When GetPropertyUIValueItems is called, each handler added to this service will be called and given the opportunity to add an icon to the specified property.
GetPropertyUIValueItems | Gets all the PropertyValueUIItems that should be displayed on the given property. For each item returned, a glyph icon will be aded to the property.
RemovePropertyValueUIHandler | Removes a PropertyValueUIHandler to this service. When GetPropertyUIValueItems is called, each handler added to this service will be called and given the opportunity to add an icon to the specified property.

See Also

IPropertyValueUIService Interface | System.Drawing.Design Namespace


IPropertyValueUIService.AddPropertyValueUIHandler

Adds a PropertyValueUIHandler to this service. When GetPropertyUIValueItems is called, each handler added to this service will be called and given the opportunity to add an icon to the specified property.

[Visual Basic]
Sub AddPropertyValueUIHandler( _
   ByVal newHandler As PropertyValueUIHandler _
)
[C#]
void AddPropertyValueUIHandler(
   PropertyValueUIHandler newHandler
);
[C++]
void AddPropertyValueUIHandler(
   PropertyValueUIHandler* newHandler
) = 0;
[JScript]
function AddPropertyValueUIHandler(
   newHandler : PropertyValueUIHandler
);

Parameters

newHandler
The handler to add.

See Also

IPropertyValueUIService Interface | IPropertyValueUIService Members | System.Drawing.Design Namespace


IPropertyValueUIService.GetPropertyUIValueItems

Gets all the PropertyValueUIItems that should be displayed on the given property. For each item returned, a glyph icon will be aded to the property.

[Visual Basic]
Function GetPropertyUIValueItems( _
   ByVal component As Object, _
   ByVal propDesc As PropertyDescriptor _
) As PropertyValueUIItem ()
[C#]
PropertyValueUIItem[] GetPropertyUIValueItems(
   object component,
   PropertyDescriptor propDesc
);
[C++]
PropertyValueUIItem* GetPropertyUIValueItems(
   Object* component,
   PropertyDescriptor* propDesc
) [] = 0;
[JScript]
function GetPropertyUIValueItems(
   component : Object,
   propDesc : PropertyDescriptor
) : PropertyValueUIItem[];

Parameters

component
The component that owns the property.
propDesc
The property descriptor that the current property is displaying.

See Also

IPropertyValueUIService Interface | IPropertyValueUIService Members | System.Drawing.Design Namespace


IPropertyValueUIService.RemovePropertyValueUIHandler

Removes a PropertyValueUIHandler to this service. When GetPropertyUIValueItems is called, each handler added to this service will be called and given the opportunity to add an icon to the specified property.

[Visual Basic]
Sub RemovePropertyValueUIHandler( _
   ByVal newHandler As PropertyValueUIHandler _
)
[C#]
void RemovePropertyValueUIHandler(
   PropertyValueUIHandler newHandler
);
[C++]
void RemovePropertyValueUIHandler(
   PropertyValueUIHandler* newHandler
) = 0;
[JScript]
function RemovePropertyValueUIHandler(
   newHandler : PropertyValueUIHandler
);

Parameters

newHandler
The handler to remove.

See Also

IPropertyValueUIService Interface | IPropertyValueUIService Members | System.Drawing.Design Namespace


IToolboxUser Interface

A designer may implement this interface if it wants to be notified of toolbox actions.

IToolboxUser

[Visual Basic]
Public Interface IToolboxUser
[C#]
public interface IToolboxUser
[C++]
public __gc __interface IToolboxUser

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Design

Assembly: System.Drawing.dll

See Also

IToolboxUser Members | System.Drawing.Design Namespace


IToolboxUser Members

Methods

GetToolSupported | [To be supplied.]
ToolPicked | This will be called when the user double-clicks on a toolbox item. The document designer should create a component for the given tool. Only tools that are enabled in the toolbox will be passed to this method.

See Also

IToolboxUser Interface | System.Drawing.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IToolboxUser Methods

The methods of the IToolboxUser interface are listed below. For a complete list of IToolboxUser interface members, see the IToolboxUser Members topic.

GetToolSupported | [To be supplied.]
ToolPicked | This will be called when the user double-clicks on a toolbox item. The document designer should create a component for the given tool. Only tools that are enabled in the toolbox will be passed to this method.

See Also

IToolboxUser Interface | System.Drawing.Design Namespace


IToolboxUser.GetToolSupported

[To be supplied.]

[Visual Basic]
Function GetToolSupported( _
   ByVal tool As ToolboxItem _
) As Boolean
[C#]
bool GetToolSupported(
   ToolboxItem tool
);
[C++]
bool GetToolSupported(
   ToolboxItem* tool
) = 0;
[JScript]
function GetToolSupported(
   tool : ToolboxItem
) : Boolean;

Parameters

tool
[To be supplied.]

See Also

IToolboxUser Interface | IToolboxUser Members | System.Drawing.Design Namespace


IToolboxUser.ToolPicked

This will be called when the user double-clicks on a toolbox item. The document designer should create a component for the given tool. Only tools that are enabled in the toolbox will be passed to this method.

[Visual Basic]
Sub ToolPicked( _
   ByVal tool As ToolboxItem _
)
[C#]
void ToolPicked(
   ToolboxItem tool
);
[C++]
void ToolPicked(
   ToolboxItem* tool
) = 0;
[JScript]
function ToolPicked(
   tool : ToolboxItem
);

Parameters

tool
The tool to create.

See Also

IToolboxUser Interface | IToolboxUser Members | System.Drawing.Design Namespace


PropertyValueUIHandler Delegate

The delegate to be added to IPropertyValueUIService. When this delegate is fired, PropertyValueUIItem objects may be added to valueUIItemList.

[Visual Basic]
Public Delegate Sub PropertyValueUIHandler( _
   ByVal component As Object, _
   ByVal propDesc As PropertyDescriptor, _
   ByVal valueUIItemList As ObjectList _
)
[C#]
public delegate void PropertyValueUIHandler(
   object component,
   PropertyDescriptor propDesc,
   ObjectList valueUIItemList
);
[C++]
public __gc __delegate void PropertyValueUIHandler(
   Object* component,
   PropertyDescriptor* propDesc,
   ObjectList* valueUIItemList
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the PropertyValueUIHandler delegate declaration.

The component that owns the property.
The property that being queried.
PropertyValueUIItem objects may be added to this list by objects that implement this handler.

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Design

Assembly: System.Drawing.dll

See Also

System.Drawing.Design Namespace


PropertyValueUIItem Class

Object that describes the extended UI glyph to be displayed on the property browser. These items will display glyphs that are painted in the right side of the property name column of the property grid.

Object
PropertyValueUIItem

[Visual Basic]
Public Class PropertyValueUIItem
[C#]
public class PropertyValueUIItem
[C++]
public __gc class PropertyValueUIItem
[JScript]
public class PropertyValueUIItem

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Design

Assembly: System.Drawing.dll

See Also

PropertyValueUIItem Members | System.Drawing.Design Namespace | IPropertyValueUIService


PropertyValueUIItem Members

Public:

Constructor

PropertyValueUIItem Constructor Constructs a PropertyValueUIItem object.

Properties

Image | The image that will be drawn on the property grid. This image must be 8x8 pixels. It is often advisable to also make it support transparency.
InvokeHandler | The handler that will be fired when this item is double clicked.
ToolTip | The tooltip to display for this glyph.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Reset | The action to call when this item is Reset. Override this class and this member to implement undoing any action that causes this item to be drawn.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyValueUIItem Class | System.Drawing.Design Namespace


PropertyValueUIItem Constructor

Constructs a PropertyValueUIItem object.

[Visual Basic]
Public Sub New( _
   ByVal uiItemImage As Image, _
   ByVal handler As PropertyValueUIItemInvokeHandler, _
   ByVal tooltip As String _
)
[C#]
public PropertyValueUIItem(
   Image uiItemImage,
   PropertyValueUIItemInvokeHandler handler,
   string tooltip
);
[C++]
public: PropertyValueUIItem(
   Image* uiItemImage,
   PropertyValueUIItemInvokeHandler* handler,
   String* tooltip
);
[JScript]
public function PropertyValueUIItem(
   uiItemImage : Image,
   handler : PropertyValueUIItemInvokeHandler,
   tooltip : String
);

Parameters

uiItemImage
The image to display. Must be 8x8 pixels.
handler
The handler to fired when the image is double clicked.
tooltip
The tooltip to display for this icon.

See Also

PropertyValueUIItem Class | PropertyValueUIItem Members | System.Drawing.Design Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PropertyValueUIItem Properties

The properties of the PropertyValueUIItem class are listed below. For a complete list of PropertyValueUIItem class members, see the PropertyValueUIItem Members topic.

Public:

Image | The image that will be drawn on the property grid. This image must be 8x8 pixels. It is often advisable to also make it support transparency.
InvokeHandler | The handler that will be fired when this item is double clicked.
ToolTip | The tooltip to display for this glyph.

See Also

PropertyValueUIItem Class | System.Drawing.Design Namespace


PropertyValueUIItem.Image

The image that will be drawn on the property grid. This image must be 8x8 pixels. It is often advisable to also make it support transparency.

[Visual Basic]
Overridable Public ReadOnly Property Image As Image
[C#]
public Image Image {virtual get;}
[C++]
public: __property virtual Image* get_Image();
[JScript]
public function get Image() : Image;

See Also

PropertyValueUIItem Class | PropertyValueUIItem Members | System.Drawing.Design Namespace


PropertyValueUIItem.InvokeHandler

The handler that will be fired when this item is double clicked.

[Visual Basic]
Overridable Public ReadOnly Property InvokeHandler As _
   PropertyValueUIItemInvokeHandler
[C#]
public PropertyValueUIItemInvokeHandler InvokeHandler {virtual
   get;}
[C++]
public: __property virtual PropertyValueUIItemInvokeHandler*
   get_InvokeHandler();
[JScript]
public function get InvokeHandler() :
   PropertyValueUIItemInvokeHandler;

See Also

PropertyValueUIItem Class | PropertyValueUIItem Members | System.Drawing.Design Namespace | PropertyValueUIItemInvokeHandler


PropertyValueUIItem.ToolTip

The tooltip to display for this glyph.

[Visual Basic]
Overridable Public ReadOnly Property ToolTip As String
[C#]
public string ToolTip {virtual get;}
[C++]
public: __property virtual String* get_ToolTip();
[JScript]
public function get ToolTip() : String;

See Also

PropertyValueUIItem Class | PropertyValueUIItem Members | System.Drawing.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PropertyValueUIItem Methods

The methods of the PropertyValueUIItem class are listed below. For a complete list of PropertyValueUIItem class members, see the PropertyValueUIItem Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Reset | The action to call when this item is Reset. Override this class and this member to implement undoing any action that causes this item to be drawn.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyValueUIItem Class | System.Drawing.Design Namespace


PropertyValueUIItem.Reset

The action to call when this item is Reset. Override this class and this member to implement undoing any action that causes this item to be drawn.

[Visual Basic]
Overridable Public Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();

See Also

PropertyValueUIItem Class | PropertyValueUIItem Members | System.Drawing.Design Namespace


PropertyValueUIItemInvokeHandler Delegate

Delegate handler that will be fired when an icon on PropertyValueUIItem is double clicked. Add a delegate of this type to the object that you want to be notified when the icon is double clicked.

[Visual Basic]
Public Delegate Sub PropertyValueUIItemInvokeHandler( _
   ByVal context As ITypeDescriptorContext, _
   ByVal descriptor As PropertyDescriptor, _
   ByVal invokedItem As PropertyValueUIItem _
)
[C#]
public delegate void PropertyValueUIItemInvokeHandler(
   ITypeDescriptorContext context,
   PropertyDescriptor descriptor,
   PropertyValueUIItem invokedItem
);
[C++]
public __gc __delegate void PropertyValueUIItemInvokeHandler(
   ITypeDescriptorContext* context,
   PropertyDescriptor* descriptor,
   PropertyValueUIItem* invokedItem
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the PropertyValueUIItemInvokeHandler delegate declaration.

The ITypeDescriptorContext for the property that the item is on.
The property that was double clicked.
The PropertyValueUIItem that was double clicked.

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Design

Assembly: System.Drawing.dll

See Also

System.Drawing.Design Namespace | ITypeDescriptorContext | PropertyValueUIItem | IPropertyValueUIService


ToolboxItem Class

Base implementation of a toolbox item. Toolbox items interact with the toolbox and allow a single item to describe multiple components.

Object
ToolboxItem

[Visual Basic]
Public Class ToolboxItem
   Implements IPersistable
[C#]
public class ToolboxItem : IPersistable
[C++]
public __gc class ToolboxItem : public IPersistable
[JScript]
public class ToolboxItem implements IPersistable

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Design

Assembly: System.Drawing.dll

See Also

ToolboxItem Members | System.Drawing.Design Namespace


ToolboxItem Members

Public:

Constructor

ToolboxItem Constructor Overloaded. [To be supplied.]

Properties

AssemblyNames | Retrieves the list of module paths associated with each type contained in this ToolboxItem
DisplayName | Retrieves the display name for this ToolboxItem. This is the string that will be displayed for the item in the toolbox
Flags | Retrieves the capability flags of this item.
ItemBitmap | Retrieves the Bitmap that will be used on the toolbox for this item. This bitmap must be 16 x 16 pixels.
ItemCount | Retrieves the number of Types contained in this ToolboxItem
ItemTypeNames | Retrieves the fully-qualified string names of the Types contained in this ToolboxItem

Methods

CreateComponents | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Save | Saves this ToolboxItem's state from the stream. If derived classes wish to do any special persistance they MUST override this method, and first call base.Save() before doing their own persistance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Events

ComponentsCreated [To be supplied.]

Fields

Version The version number of the toolbox item. Increment this number every time a change is made to the ToolboxItem or assembly that requires the toolbox to be reset.

Protected:

Methods

CreateComponentsCore | Creates objects from each Type contained in this ToolboxItem, and adds them to the designer. You may override this method to alter the way components are created.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
Load | Loads this ToolboxItem's state from the stream. If derived classes wish to do any special persistance they MUST override this method, and first call base.Load() before doing their own persistance.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnComponentsCreated | Fires a handler that will be fired when this ToolboxItem creates a Component.

Event Hookup:

Methods

AddOnComponentsCreated | Adds a handler that will be fired when this ToolboxItem creates a Component.
RemoveOnComponentsCreated | Removes a handler that will be fired when this ToolboxItem creates a Component.

See Also

ToolboxItem Class | System.Drawing.Design Namespace


ToolboxItem Constructor

[To be supplied.]

Overload List

Basic ctor. Display name will be short type name.

[Visual Basic] Overloads Public Sub New(Type)
[C#] public ToolboxItem(Type);
[C++] public: ToolboxItem(Type*);
[JScript] public function ToolboxItem(Type);

Basic ctor.

[Visual Basic] Overloads Public Sub New(Type, String)
[C#] public ToolboxItem(Type, String);
[C++] public: ToolboxItem(Type*, String);
[JScript] public function ToolboxItem(Type, String);

Basic ctor.

[Visual Basic] Overloads Public Sub New(Type, Bitmap)
[C#] public ToolboxItem(Type, Bitmap);
[C++] public: ToolboxItem(Type*, Bitmap);
[JScript] public function ToolboxItem(Type, Bitmap);

Basic ctor.

[Visual Basic] Overloads Public Sub New(Type, String, Bitmap)
[C#] public ToolboxItem(Type, String, Bitmap);
[C++] public: ToolboxItem(Type*, String, Bitmap);
[JScript] public function ToolboxItem(Type, String, Bitmap);

Basic ctor for a multi-type ToolboxItem

[Visual Basic] Overloads Public Sub New(Type(), String, Bitmap)
[C#] public ToolboxItem(Type[], String, Bitmap);
[C++] public: ToolboxItem(Type*[], String, Bitmap);
[JScript] public function ToolboxItem(Type[], String, Bitmap);

Basic ctor. Display name will be short type name.

[Visual Basic] Overloads Public Sub New(String)
[C#] public ToolboxItem(String);
[C++] public: ToolboxItem(String*);
[JScript] public function ToolboxItem(String);

Basic ctor.

[Visual Basic] Overloads Public Sub New(String, String)
[C#] public ToolboxItem(String, String);
[C++] public: ToolboxItem(String*, String*);
[JScript] public function ToolboxItem(String, String);

Basic ctor.

[Visual Basic] Overloads Public Sub New(String, Bitmap)
[C#] public ToolboxItem(String, Bitmap);
[C++] public: ToolboxItem(String*, Bitmap);
[JScript] public function ToolboxItem(String, Bitmap);

Basic ctor.

[Visual Basic] Overloads Public Sub New(String, String, Bitmap)
[C#] public ToolboxItem(String, String, Bitmap);
[C++] public: ToolboxItem(String*, String*, Bitmap);
[JScript] public function ToolboxItem(String, String, Bitmap);

Basic ctor for a multi-type ToolboxItem

[Visual Basic] Overloads Public Sub New(String(), String, Bitmap)
[C#] public ToolboxItem(String[], String, Bitmap);
[C++] public: ToolboxItem(String*[], String*, Bitmap);
[JScript] public function ToolboxItem(String[], String, Bitmap);

The stream based ctor. Derived classes of ToolboxItem MUST override and call this ctor, as well as the Load and Save methods.

[Visual Basic] Overloads Public Sub New(Stream)
[C#] public ToolboxItem(Stream);
[C++] public: ToolboxItem(Stream*);
[JScript] public function ToolboxItem(Stream);

See Also

ToolboxItem Class | ToolboxItem Members | System.Drawing.Design Namespace


ToolboxItem Constructor (Type)

Basic ctor. Display name will be short type name.

[Visual Basic]
Overloads Public Sub New( _
   ByVal toolType As Type _
)
[C#]
public ToolboxItem(
   Type toolType
);
[C++]
public: ToolboxItem(
   Type* toolType
);
[JScript]
public function ToolboxItem(
   toolType : Type
);

Parameters

toolType
The Type of the tool for this toolbox item

See Also

ToolboxItem Class | ToolboxItem Members | System.Drawing.Design Namespace | ToolboxItem Constructor Overload List


ToolboxItem Constructor (Type, String)

Basic ctor.

[Visual Basic]
Overloads Public Sub New( _
   ByVal toolType As Type, _
   ByVal displayName As String _
)
[C#]
public ToolboxItem(
   Type toolType,
   string displayName
);
[C++]
public: ToolboxItem(
   Type* toolType,
   String* displayName
);
[JScript]
public function ToolboxItem(
   toolType : Type,
   displayName : String
);

Parameters

toolType
The Type of the tool for this toolbox item
displayName
The name to display on the toolbox for this tool

See Also

ToolboxItem Class | ToolboxItem Members | System.Drawing.Design Namespace | ToolboxItem Constructor Overload List


ToolboxItem Constructor (Type, Bitmap)

Basic ctor.

[Visual Basic]
Overloads Public Sub New( _
   ByVal toolType As Type, _
   ByVal itemBitmap As Bitmap _
)
[C#]
public ToolboxItem(
   Type toolType,
   Bitmap itemBitmap
);
[C++]
public: ToolboxItem(
   Type* toolType,
   Bitmap* itemBitmap
);
[JScript]
public function ToolboxItem(
   toolType : Type,
   itemBitmap : Bitmap
);

Parameters

toolType
The Type of the tool for this toolbox item
itemBitmap
The bitmap to use on the toolbox item.

See Also

ToolboxItem Class | ToolboxItem Members | System.Drawing.Design Namespace | ToolboxItem Constructor Overload List


ToolboxItem Constructor (Type, String, Bitmap)

Basic ctor.

[Visual Basic]
Overloads Public Sub New( _
   ByVal toolType As Type, _
   ByVal displayName As String, _
   ByVal itemBitmap As Bitmap _
)
[C#]
public ToolboxItem(
   Type toolType,
   string displayName,
   Bitmap itemBitmap
);
[C++]
public: ToolboxItem(
   Type* toolType,
   String* displayName,
   Bitmap* itemBitmap
);
[JScript]
public function ToolboxItem(
   toolType : Type,
   displayName : String,
   itemBitmap : Bitmap
);

Parameters

toolType
The Type of the tool for this toolbox item
displayName
The name to display on the toolbox for this tool
itemBitmap
The bitmap to use on the toolbox item.

See Also

ToolboxItem Class | ToolboxItem Members | System.Drawing.Design Namespace | ToolboxItem Constructor Overload List


ToolboxItem Constructor (Type[], String, Bitmap)

Basic ctor for a multi-type ToolboxItem

[Visual Basic]
Overloads Public Sub New( _
   ByVal toolTypes() As Type, _
   ByVal displayName As String, _
   ByVal itemBitmap As Bitmap _
)
[C#]
public ToolboxItem(
   Type[] toolTypes,
   string displayName,
   Bitmap itemBitmap
);
[C++]
public: ToolboxItem(
   Type* toolTypes[],
   String* displayName,
   Bitmap* itemBitmap
);
[JScript]
public function ToolboxItem(
   toolTypes : Type[],
   displayName : String,
   itemBitmap : Bitmap
);

Parameters

toolTypes
An array of fully qualified type names for the tools that this ToolboxItem describes
displayName
The name to display on the toolbox for this tool
itemBitmap
The bitmap to use on the toolbox item.

See Also

ToolboxItem Class | ToolboxItem Members | System.Drawing.Design Namespace | ToolboxItem Constructor Overload List


ToolboxItem Constructor (String)

Basic ctor. Display name will be short type name.

[Visual Basic]
Overloads Public Sub New( _
   ByVal toolTypeName As String _
)
[C#]
public ToolboxItem(
   string toolTypeName
);
[C++]
public: ToolboxItem(
   String* toolTypeName
);
[JScript]
public function ToolboxItem(
   toolTypeName : String
);

Parameters

toolTypeName
The fully qualified type name of the tool for this toolbox item

See Also

ToolboxItem Class | ToolboxItem Members | System.Drawing.Design Namespace | ToolboxItem Constructor Overload List


ToolboxItem Constructor (String, String)

Basic ctor.

[Visual Basic]
Overloads Public Sub New( _
   ByVal toolTypeName As String, _
   ByVal displayName As String _
)
[C#]
public ToolboxItem(
   string toolTypeName,
   string displayName
);
[C++]
public: ToolboxItem(
   String* toolTypeName,
   String* displayName
);
[JScript]
public function ToolboxItem(
   toolTypeName : String,
   displayName : String
);

Parameters

toolTypeName
The fully qualified type name of the tool for this toolbox item
displayName
The name to display on the toolbox for this tool

See Also

ToolboxItem Class | ToolboxItem Members | System.Drawing.Design Namespace | ToolboxItem Constructor Overload List


ToolboxItem Constructor (String, Bitmap)

Basic ctor.

[Visual Basic]
Overloads Public Sub New( _
   ByVal toolTypeName As String, _
   ByVal itemBitmap As Bitmap _
)
[C#]
public ToolboxItem(
   string toolTypeName,
   Bitmap itemBitmap
);
[C++]
public: ToolboxItem(
   String* toolTypeName,
   Bitmap* itemBitmap
);
[JScript]
public function ToolboxItem(
   toolTypeName : String,
   itemBitmap : Bitmap
);

Parameters

toolTypeName
The fully qualified type name of the tool for this toolbox item
itemBitmap
The bitmap to use on the toolbox item.

See Also

ToolboxItem Class | ToolboxItem Members | System.Drawing.Design Namespace | ToolboxItem Constructor Overload List


ToolboxItem Constructor (String, String, Bitmap)

Basic ctor.

[Visual Basic]
Overloads Public Sub New( _
   ByVal toolTypeName As String, _
   ByVal displayName As String, _
   ByVal itemBitmap As Bitmap _
)
[C#]
public ToolboxItem(
   string toolTypeName,
   string displayName,
   Bitmap itemBitmap
);
[C++]
public: ToolboxItem(
   String* toolTypeName,
   String* displayName,
   Bitmap* itemBitmap
);
[JScript]
public function ToolboxItem(
   toolTypeName : String,
   displayName : String,
   itemBitmap : Bitmap
);

Parameters

toolTypeName
The fully qualified type name of the tool for this toolbox item
displayName
The name to display on the toolbox for this tool
itemBitmap
The bitmap to use on the toolbox item.

See Also

ToolboxItem Class | ToolboxItem Members | System.Drawing.Design Namespace | ToolboxItem Constructor Overload List


ToolboxItem Constructor (String[], String, Bitmap)

Basic ctor for a multi-type ToolboxItem

[Visual Basic]
Overloads Public Sub New( _
   ByVal toolTypeNames() As String, _
   ByVal displayName As String, _
   ByVal itemBitmap As Bitmap _
)
[C#]
public ToolboxItem(
   string[] toolTypeNames,
   string displayName,
   Bitmap itemBitmap
);
[C++]
public: ToolboxItem(
   String* toolTypeNames[],
   String* displayName,
   Bitmap* itemBitmap
);
[JScript]
public function ToolboxItem(
   toolTypeNames : String[],
   displayName : String,
   itemBitmap : Bitmap
);

Parameters

toolTypeNames
An array of fully qualified type names for the tools that this ToolboxItem describes
displayName
The name to display on the toolbox for this tool
itemBitmap
The bitmap to use on the toolbox item.

See Also

ToolboxItem Class | ToolboxItem Members | System.Drawing.Design Namespace | ToolboxItem Constructor Overload List


ToolboxItem Constructor (Stream)

The stream based ctor. Derived classes of ToolboxItem MUST override and call this ctor, as well as the Load and Save methods.

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream _
)
[C#]
public ToolboxItem(
   Stream stream
);
[C++]
public: ToolboxItem(
   Stream* stream
);
[JScript]
public function ToolboxItem(
   stream : Stream
);

Parameters

stream
The stream to initalize from

See Also

ToolboxItem Class | ToolboxItem Members | System.Drawing.Design Namespace | ToolboxItem Constructor Overload List | IPersistable


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ToolboxItem Properties

The properties of the ToolboxItem class are listed below. For a complete list of ToolboxItem class members, see the ToolboxItem Members topic.

Public:

AssemblyNames | Retrieves the list of module paths associated with each type contained in this ToolboxItem
DisplayName | Retrieves the display name for this ToolboxItem. This is the string that will be displayed for the item in the toolbox
Flags | Retrieves the capability flags of this item.
ItemBitmap | Retrieves the Bitmap that will be used on the toolbox for this item. This bitmap must be 16 x 16 pixels.
ItemCount | Retrieves the number of Types contained in this ToolboxItem
ItemTypeNames | Retrieves the fully-qualified string names of the Types contained in this ToolboxItem

See Also

ToolboxItem Class | System.Drawing.Design Namespace


ToolboxItem.AssemblyNames

Retrieves the list of module paths associated with each type contained in this ToolboxItem

[Visual Basic]
Public ReadOnly Property AssemblyNames As AssemblyName ()
[C#]
public AssemblyName[] AssemblyNames {get;}
[C++]
public: __property AssemblyName* get_AssemblyNames();
[JScript]
public function get AssemblyNames() : AssemblyName[];

Property Value

The an array of string module paths of each type contained in this ToolboxItem

See Also

ToolboxItem Class | ToolboxItem Members | System.Drawing.Design Namespace


ToolboxItem.DisplayName

Retrieves the display name for this ToolboxItem. This is the string that will be displayed for the item in the toolbox

[Visual Basic]
Public ReadOnly Property DisplayName As String
[C#]
public string DisplayName {get;}
[C++]
public: __property String* get_DisplayName();
[JScript]
public function get DisplayName() : String;

See Also

ToolboxItem Class | ToolboxItem Members | System.Drawing.Design Namespace


ToolboxItem.Flags

Retrieves the capability flags of this item.

[Visual Basic]
Overridable Public ReadOnly Property Flags As ToolboxItemInfoEnum
[C#]
public ToolboxItemInfoEnum Flags {virtual get;}
[C++]
public: __property virtual ToolboxItemInfoEnum get_Flags();
[JScript]
public function get Flags() : ToolboxItemInfoEnum;

Property Value

The info flags for this item, from ToolboxItemInfoEnum

See Also

ToolboxItem Class | ToolboxItem Members | System.Drawing.Design Namespace


ToolboxItem.ItemBitmap

Retrieves the Bitmap that will be used on the toolbox for this item. This bitmap must be 16 x 16 pixels.

[Visual Basic]
Overridable Public ReadOnly Property ItemBitmap As Bitmap
[C#]
public Bitmap ItemBitmap {virtual get;}
[C++]
public: __property virtual Bitmap* get_ItemBitmap();
[JScript]
public function get ItemBitmap() : Bitmap;

Property Value

The bitmap to display on the toolbox for this ToolboxItem.

See Also

ToolboxItem Class | ToolboxItem Members | System.Drawing.Design Namespace


ToolboxItem.ItemCount

Retrieves the number of Types contained in this ToolboxItem

[Visual Basic]
Public ReadOnly Property ItemCount As Integer
[C#]
public int ItemCount {get;}
[C++]
public: __property int get_ItemCount();
[JScript]
public function get ItemCount() : int;

Property Value

The number of types contained in this ToolboxItem

See Also

ToolboxItem Class | ToolboxItem Members | System.Drawing.Design Namespace


ToolboxItem.ItemTypeNames

Retrieves the fully-qualified string names of the Types contained in this ToolboxItem

[Visual Basic]
Public ReadOnly Property ItemTypeNames As String ()
[C#]
public string[] ItemTypeNames {get;}
[C++]
public: __property String* get_ItemTypeNames();
[JScript]
public function get ItemTypeNames() : String[];

Property Value

The an array of string type names contained in this ToolboxItem

See Also

ToolboxItem Class | ToolboxItem Members | System.Drawing.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ToolboxItem Methods

The methods of the ToolboxItem class are listed below. For a complete list of ToolboxItem class members, see the ToolboxItem Members topic.

Public:

CreateComponents | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Save | Saves this ToolboxItem's state from the stream. If derived classes wish to do any special persistance they MUST override this method, and first call base.Save() before doing their own persistance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

CreateComponentsCore | Creates objects from each Type contained in this ToolboxItem, and adds them to the designer. You may override this method to alter the way components are created.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
Load | Loads this ToolboxItem's state from the stream. If derived classes wish to do any special persistance they MUST override this method, and first call base.Load() before doing their own persistance.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnComponentsCreated | Fires a handler that will be fired when this ToolboxItem creates a Component.

Event Hookup:

AddOnComponentsCreated | Adds a handler that will be fired when this ToolboxItem creates a Component.
RemoveOnComponentsCreated | Removes a handler that will be fired when this ToolboxItem creates a Component.

See Also

ToolboxItem Class | System.Drawing.Design Namespace


ToolboxItem.AddOnComponentsCreated

Adds a handler that will be fired when this ToolboxItem creates a Component.

[Visual Basic]
Public Sub AddOnComponentsCreated( _
   ByVal e As ToolboxComponentsCreatedEventHandler _
)
[C#]
public void AddOnComponentsCreated(
   ToolboxComponentsCreatedEventHandler e
);
[C++]
public: void AddOnComponentsCreated(
   ToolboxComponentsCreatedEventHandler* e
);
[JScript]
public function AddOnComponentsCreated(
   e : ToolboxComponentsCreatedEventHandler
);

Parameters

e
[To be supplied.]

See Also

ToolboxItem Class | ToolboxItem Members | System.Drawing.Design Namespace


ToolboxItem.CreateComponents

[To be supplied.]

Overload List

Creates objects from each Type contained in this ToolboxItem.

[Visual Basic] Overloads Public Function CreateComponents() As IComponent ()
[C#] public IComponent[] CreateComponents();
[C++] public: IComponent* CreateComponents() [];
[JScript] public function CreateComponents() : IComponent[];

Creates objects from each Type contained in this ToolboxItem, and adds them to the designer

[Visual Basic] Overloads Public Function CreateComponents(IDesignerHost) As IComponent ()
[C#] public IComponent[] CreateComponents(IDesignerHost);
[C++] public: IComponent* CreateComponents(IDesignerHost*) [];
[JScript] public function CreateComponents(IDesignerHost) : IComponent[];

See Also

ToolboxItem Class | ToolboxItem Members | System.Drawing.Design Namespace


ToolboxItem.CreateComponents ()

Creates objects from each Type contained in this ToolboxItem.

[Visual Basic]
Overloads Public Function CreateComponents() As IComponent ()
[C#]
public IComponent[] CreateComponents();
[C++]
public: IComponent* CreateComponents() [];
[JScript]
public function CreateComponents() : IComponent[];

Return Value

An array of created IComponent objects.

See Also

ToolboxItem Class | ToolboxItem Members | System.Drawing.Design Namespace | ToolboxItem.CreateComponents Overload List


ToolboxItem.CreateComponents (IDesignerHost)

Creates objects from each Type contained in this ToolboxItem, and adds them to the designer

[Visual Basic]
Overloads Public Function CreateComponents( _
   ByVal host As IDesignerHost _
) As IComponent ()
[C#]
public IComponent[] CreateComponents(
   IDesignerHost host
);
[C++]
public: IComponent* CreateComponents(
   IDesignerHost* host
) [];
[JScript]
public function CreateComponents(
   host : IDesignerHost
) : IComponent[];

Parameters

host
The IDesignerHost to use to create the components.

Return Value

An array of created IComponent objects.

See Also

ToolboxItem Class | ToolboxItem Members | System.Drawing.Design Namespace | ToolboxItem.CreateComponents Overload List


ToolboxItem.CreateComponentsCore

Creates objects from each Type contained in this ToolboxItem, and adds them to the designer. You may override this method to alter the way components are created.

[Visual Basic]
Overridable Protected Function CreateComponentsCore( _
   ByVal host As IDesignerHost _
) As IComponent ()
[C#]
protected virtual IComponent[] CreateComponentsCore(
   IDesignerHost host
);
[C++]
protected: virtual IComponent* CreateComponentsCore(
   IDesignerHost* host
) [];
[JScript]
protected function CreateComponentsCore(
   host : IDesignerHost
) : IComponent[];

Parameters

host
The IDesignerHost to use to create the components.

Return Value

An array of created IComponent objects.

See Also

ToolboxItem Class | ToolboxItem Members | System.Drawing.Design Namespace


ToolboxItem.Load

Loads this ToolboxItem's state from the stream. If derived classes wish to do any special persistance they MUST override this method, and first call base.Load() before doing their own persistance.

[Visual Basic]
Overridable Protected Sub Load( _
   ByVal s As Stream _
)
[C#]
protected virtual void Load(
   Stream s
);
[C++]
protected: virtual void Load(
   Stream* s
);
[JScript]
protected function Load(
   s : Stream
);

Parameters

s
The stream to load state from.

See Also

ToolboxItem Class | ToolboxItem Members | System.Drawing.Design Namespace


ToolboxItem.OnComponentsCreated

Fires a handler that will be fired when this ToolboxItem creates a Component.

[Visual Basic]
Overridable Protected Sub OnComponentsCreated( _
   ByVal args As ToolboxComponentsCreatedEvent _
)
[C#]
protected virtual void OnComponentsCreated(
   ToolboxComponentsCreatedEvent args
);
[C++]
protected: virtual void OnComponentsCreated(
   ToolboxComponentsCreatedEvent* args
);
[JScript]
protected function OnComponentsCreated(
   args : ToolboxComponentsCreatedEvent
);

Parameters

args
[To be supplied.]

See Also

ToolboxItem Class | ToolboxItem Members | System.Drawing.Design Namespace


ToolboxItem.RemoveOnComponentsCreated

Removes a handler that will be fired when this ToolboxItem creates a Component.

[Visual Basic]
Public Sub RemoveOnComponentsCreated( _
   ByVal e As ToolboxComponentsCreatedEventHandler _
)
[C#]
public void RemoveOnComponentsCreated(
   ToolboxComponentsCreatedEventHandler e
);
[C++]
public: void RemoveOnComponentsCreated(
   ToolboxComponentsCreatedEventHandler* e
);
[JScript]
public function RemoveOnComponentsCreated(
   e : ToolboxComponentsCreatedEventHandler
);

Parameters

e
[To be supplied.]

See Also

ToolboxItem Class | ToolboxItem Members | System.Drawing.Design Namespace


ToolboxItem.Save

Saves this ToolboxItem's state from the stream. If derived classes wish to do any special persistance they MUST override this method, and first call base.Save() before doing their own persistance.

[Visual Basic]
Overridable Public Sub Save( _
   ByVal s As Stream _
)
[C#]
public virtual void Save(
   Stream s
);
[C++]
public: virtual void Save(
   Stream* s
);
[JScript]
public function Save(
   s : Stream
);

Parameters

s
The stream to save state to.

See Also

ToolboxItem Class | ToolboxItem Members | System.Drawing.Design Namespace


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ToolboxItem Events

The events of the ToolboxItem class are listed below. For a complete list of ToolboxItem class members, see the ToolboxItem Members topic.

Public:

ComponentsCreated [To be supplied.]

See Also

ToolboxItem Class | System.Drawing.Design Namespace


ToolboxItem ComponentsCreated Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the ComponentsCreated event.

[Visual Basic]
Private Sub ToolboxItemName_ComponentsCreated( _
   ByVal sender As Object, _
   ByVal e As ToolboxComponentsCreatedEventArgs _
)
[C#]
private void ToolboxItemName_ComponentsCreated(
   object sender,
   ToolboxComponentsCreatedEventArgs e
);
[C++]
private: void ToolboxItemName_ComponentsCreated(
   Object* sender,
   ToolboxComponentsCreatedEventArgs* e
);
[JScript]
private ToolboxItemName_ComponentsCreated(
   sender : Object,
   e : ToolboxComponentsCreatedEventArgs
);

Parameters

sender
The source of the event.
e
A System.ComponentModel.Design.ToolboxComponentsCreatedEventArgs that contains the event data.

See Also

ToolboxItem Class | ToolboxItem MembersTopic | System.Drawing.Design Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ToolboxItem Fields

The fields of the ToolboxItem class are listed below. For a complete list of ToolboxItem class members, see the ToolboxItem Members topic.

Public:

Version The version number of the toolbox item. Increment this number every time a change is made to the ToolboxItem or assembly that requires the toolbox to be reset.

See Also

ToolboxItem Class | System.Drawing.Design Namespace


ToolboxItem.Version

The version number of the toolbox item. Increment this number every time a change is made to the ToolboxItem or assembly that requires the toolbox to be reset.

[Visual Basic]
Public Shared ReadOnly Version As Integer
[C#]
public static readonly int Version;
[C++]
public: static readonly int Version;
[JScript]
public static var Version : int;

See Also

ToolboxItem Class | ToolboxItem Members | System.Drawing.Design Namespace


ToolboxItemInfoEnum Enumeration

[To be supplied.]

[Visual Basic]
Public Enum ToolboxItemInfoEnum
[C#]
public enum ToolboxItemInfoEnum
[C++]
public enum ToolboxItemInfoEnum

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Default | [To be supplied.]
HasUI | [To be supplied.]

Requirements

Namespace: System.Drawing.Design

Assembly: System.Drawing.dll

See Also

System.Drawing.Design Namespace


UITypeEditor Class

UITypeEditor is an editor that provides a way to visually edit the values of a type. edit types.

Object
UITypeEditor

[Visual Basic]
Public Class UITypeEditor
[C#]
public class UITypeEditor
[C++]
public __gc class UITypeEditor
[JScript]
public class UITypeEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Design

Assembly: System.Drawing.dll

See Also

UITypeEditor Members | System.Drawing.Design Namespace


UITypeEditor Members

Public:

Constructor

UITypeEditor Constructor [To be supplied.]

Methods

EditValue | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEditStyle | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UITypeEditor Class | System.Drawing.Design Namespace


UITypeEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public UITypeEditor();
[C++]
public: UITypeEditor();
[JScript]
public function UITypeEditor();

See Also

UITypeEditor Class | UITypeEditor Members | System.Drawing.Design Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UITypeEditor Methods

The methods of the UITypeEditor class are listed below. For a complete list of UITypeEditor class members, see the UITypeEditor Members topic.

Public:

EditValue | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEditStyle | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
PaintValue | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UITypeEditor Class | System.Drawing.Design Namespace


UITypeEditor.EditValue

[To be supplied.]

Overload List

Edits the given object value using the editor style provided by GetEditorStyle. A service provider is provided so that any required editing services can be obtained.

[Visual Basic] Overloads Overridable Public Function EditValue(ITypeDescriptorContext, IServiceObjectProvider, Object) As Object
[C#] public virtual object EditValue(ITypeDescriptorContext, IServiceObjectProvider, Object);
[C++] public: virtual Object* EditValue(ITypeDescriptorContext*, IServiceObjectProvider, Object);
[JScript] public function EditValue(ITypeDescriptorContext, IServiceObjectProvider, Object) : Object;

Edits the given object value using the editor style provided by GetEditorStyle. A service provider is provided so that any required editing services can be obtained.

[Visual Basic] Overloads Public Function EditValue(IServiceObjectProvider, Object) As Object
[C#] public object EditValue(IServiceObjectProvider, Object);
[C++] public: Object* EditValue(IServiceObjectProvider*, Object);
[JScript] public function EditValue(IServiceObjectProvider, Object) : Object;

See Also

UITypeEditor Class | UITypeEditor Members | System.Drawing.Design Namespace


UITypeEditor.EditValue (ITypeDescriptorContext, IServiceObjectProvider, Object)

Edits the given object value using the editor style provided by GetEditorStyle. A service provider is provided so that any required editing services can be obtained.

[Visual Basic]
Overloads Overridable Public Function EditValue( _
   ByVal context As ITypeDescriptorContext, _
   ByVal provider As IServiceObjectProvider, _
   ByVal value As Object _
) As Object
[C#]
public virtual object EditValue(
   ITypeDescriptorContext context,
   IServiceObjectProvider provider,
   object value
);
[C++]
public: virtual Object* EditValue(
   ITypeDescriptorContext* context,
   IServiceObjectProvider* provider,
   Object* value
);
[JScript]
public function EditValue(
   context : ITypeDescriptorContext,
   provider : IServiceObjectProvider,
   value : Object
) : Object;

Parameters

context
A type descriptor context that can be used to provide additional context information.
provider
A service provider object through which editing services may be obtained.
value
An instance of the value being edited.

Return Value

The new value of the object. If the value of the object hasn't changed, this should return the same object it was passed.

See Also

UITypeEditor Class | UITypeEditor Members | System.Drawing.Design Namespace | UITypeEditor.EditValue Overload List


UITypeEditor.EditValue (IServiceObjectProvider, Object)

Edits the given object value using the editor style provided by GetEditorStyle. A service provider is provided so that any required editing services can be obtained.

[Visual Basic]
Overloads Public Function EditValue( _
   ByVal provider As IServiceObjectProvider, _
   ByVal value As Object _
) As Object
[C#]
public object EditValue(
   IServiceObjectProvider provider,
   object value
);
[C++]
public: Object* EditValue(
   IServiceObjectProvider* provider,
   Object* value
);
[JScript]
public function EditValue(
   provider : IServiceObjectProvider,
   value : Object
) : Object;

Parameters

provider
A service provider object through which editing services may be obtained.
value
An instance of the value being edited.

Return Value

The new value of the object. If the value of the object hasn't changed, this should return the same object it was passed.

See Also

UITypeEditor Class | UITypeEditor Members | System.Drawing.Design Namespace | UITypeEditor.EditValue Overload List


UITypeEditor.GetEditStyle

[To be supplied.]

Overload List

Retrieves the editing style of the Edit method. If the method is not supported, this will return None.

[Visual Basic] Overloads Overridable Public Function GetEditStyle(ITypeDescriptorContext) As UITypeEditorEditStyle
[C#] public virtual UITypeEditorEditStyle GetEditStyle(ITypeDescriptorContext);
[C++] public: virtual UITypeEditorEditStyle GetEditStyle(ITypeDescriptorContext*);
[JScript] public function GetEditStyle(ITypeDescriptorContext) : UITypeEditorEditStyle;

Retrieves the editing style of the Edit method. If the method is not supported, this will return None.

[Visual Basic] Overloads Public Function GetEditStyle() As UITypeEditorEditStyle
[C#] public UITypeEditorEditStyle GetEditStyle();
[C++] public: UITypeEditorEditStyle GetEditStyle();
[JScript] public function GetEditStyle() : UITypeEditorEditStyle;

See Also

UITypeEditor Class | UITypeEditor Members | System.Drawing.Design Namespace


UITypeEditor.GetEditStyle (ITypeDescriptorContext)

Retrieves the editing style of the Edit method. If the method is not supported, this will return None.

[Visual Basic]
Overloads Overridable Public Function GetEditStyle( _
   ByVal context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
[C#]
public virtual UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext context
);
[C++]
public: virtual UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext* context
);
[JScript]
public function GetEditStyle(
   context : ITypeDescriptorContext
) : UITypeEditorEditStyle;

Parameters

context
A type descriptor context that can be used to provide additional context information.

Return Value

An enum value indicating the provided editing style.

See Also

UITypeEditor Class | UITypeEditor Members | System.Drawing.Design Namespace | UITypeEditor.GetEditStyle Overload List


UITypeEditor.GetEditStyle ()

Retrieves the editing style of the Edit method. If the method is not supported, this will return None.

[Visual Basic]
Overloads Public Function GetEditStyle() As UITypeEditorEditStyle
[C#]
public UITypeEditorEditStyle GetEditStyle();
[C++]
public: UITypeEditorEditStyle GetEditStyle();
[JScript]
public function GetEditStyle() : UITypeEditorEditStyle;

Return Value

An enum value indicating the provided editing style.

See Also

UITypeEditor Class | UITypeEditor Members | System.Drawing.Design Namespace | UITypeEditor.GetEditStyle Overload List


UITypeEditor.GetPaintValueSupported

[To be supplied.]

Overload List

Determines if this editor supports the painting of a representation of an object's value.

[Visual Basic] Overloads Overridable Public Function GetPaintValueSupported(ITypeDescriptorContext) As Boolean
[C#] public virtual bool GetPaintValueSupported(ITypeDescriptorContext);
[C++] public: virtual bool GetPaintValueSupported(ITypeDescriptorContext*);
[JScript] public function GetPaintValueSupported(ITypeDescriptorContext) : Boolean;

Determines if this editor supports the painting of a representation of an object's value.

[Visual Basic] Overloads Public Function GetPaintValueSupported() As Boolean
[C#] public bool GetPaintValueSupported();
[C++] public: bool GetPaintValueSupported();
[JScript] public function GetPaintValueSupported() : Boolean;

See Also

UITypeEditor Class | UITypeEditor Members | System.Drawing.Design Namespace


UITypeEditor.GetPaintValueSupported (ITypeDescriptorContext)

Determines if this editor supports the painting of a representation of an object's value.

[Visual Basic]
Overloads Overridable Public Function GetPaintValueSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
[C#]
public virtual bool GetPaintValueSupported(
   ITypeDescriptorContext context
);
[C++]
public: virtual bool GetPaintValueSupported(
   ITypeDescriptorContext* context
);
[JScript]
public function GetPaintValueSupported(
   context : ITypeDescriptorContext
) : Boolean;

Parameters

context
A type descriptor context that can be used to provide additional context information.

Return Value

Returns true if PaintValue is implemented.

See Also

UITypeEditor Class | UITypeEditor Members | System.Drawing.Design Namespace | UITypeEditor.GetPaintValueSupported Overload List


UITypeEditor.GetPaintValueSupported ()

Determines if this editor supports the painting of a representation of an object's value.

[Visual Basic]
Overloads Public Function GetPaintValueSupported() As Boolean
[C#]
public bool GetPaintValueSupported();
[C++]
public: bool GetPaintValueSupported();
[JScript]
public function GetPaintValueSupported() : Boolean;

Return Value

Returns true if PaintValue is implemented.

See Also

UITypeEditor Class | UITypeEditor Members | System.Drawing.Design Namespace | UITypeEditor.GetPaintValueSupported Overload List


UITypeEditor.PaintValue

[To be supplied.]

Overload List

Paints a representative value of the given object to the provided canvas. Painting should be done within the boundaries of the provided rectangle.

[Visual Basic] Overloads Public Sub PaintValue(Object, Graphics, Rectangle)
[C#] public void PaintValue(Object, Graphics, Rectangle);
[C++] public: void PaintValue(Object*, Graphics, Rectangle);
[JScript] public function PaintValue(Object, Graphics, Rectangle);

Paints a representative value of the given object to the provided canvas. Painting should be done within the boundaries of the provided rectangle.

[Visual Basic] Overloads Overridable Public Sub PaintValue(ITypeDescriptorContext, Object, Graphics, Rectangle)
[C#] public virtual void PaintValue(ITypeDescriptorContext, Object, Graphics, Rectangle);
[C++] public: virtual void PaintValue(ITypeDescriptorContext*, Object, Graphics, Rectangle);
[JScript] public function PaintValue(ITypeDescriptorContext, Object, Graphics, Rectangle);

See Also

UITypeEditor Class | UITypeEditor Members | System.Drawing.Design Namespace


UITypeEditor.PaintValue (Object, Graphics, Rectangle)

Paints a representative value of the given object to the provided canvas. Painting should be done within the boundaries of the provided rectangle.

[Visual Basic]
Overloads Public Sub PaintValue( _
   ByVal value As Object, _
   ByVal canvas As Graphics, _
   ByVal rectangle As Rectangle _
)
[C#]
public void PaintValue(
   object value,
   Graphics canvas,
   Rectangle rectangle
);
[C++]
public: void PaintValue(
   Object* value,
   Graphics* canvas,
   Rectangle rectangle
);
[JScript]
public function PaintValue(
   value : Object,
   canvas : Graphics,
   rectangle : Rectangle
);

Parameters

value
An instance of the value being edited.
canvas
A drawing canvas to paint the value's representation on.
rectangle
The size to make the painted value.

See Also

UITypeEditor Class | UITypeEditor Members | System.Drawing.Design Namespace | UITypeEditor.PaintValue Overload List


UITypeEditor.PaintValue (ITypeDescriptorContext, Object, Graphics, Rectangle)

Paints a representative value of the given object to the provided canvas. Painting should be done within the boundaries of the provided rectangle.

[Visual Basic]
Overloads Overridable Public Sub PaintValue( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal canvas As Graphics, _
   ByVal rectangle As Rectangle _
)
[C#]
public virtual void PaintValue(
   ITypeDescriptorContext context,
   object value,
   Graphics canvas,
   Rectangle rectangle
);
[C++]
public: virtual void PaintValue(
   ITypeDescriptorContext* context,
   Object* value,
   Graphics* canvas,
   Rectangle rectangle
);
[JScript]
public function PaintValue(
   context : ITypeDescriptorContext,
   value : Object,
   canvas : Graphics,
   rectangle : Rectangle
);

Parameters

context
A type descriptor context that can be used to provide additional context information.
value
An instance of the value being edited.
canvas
A drawing canvas to paint the value's representation on.
rectangle
The size to make the painted value.

See Also

UITypeEditor Class | UITypeEditor Members | System.Drawing.Design Namespace | UITypeEditor.PaintValue Overload List


UITypeEditorEditStyle Enumeration

Defines the range of styles a UITypeEditor provides when editing an object.

[Visual Basic]
Public Enum UITypeEditorEditStyle
[C#]
public enum UITypeEditorEditStyle
[C++]
public enum UITypeEditorEditStyle

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
DropDown | [To be supplied.]
Modal | [To be supplied.]
None | [To be supplied.]

Requirements

Namespace: System.Drawing.Design

Assembly: System.Drawing.dll

See Also

System.Drawing.Design Namespace


System.Drawing.Drawing2D

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Drawing.Drawing2D Namespace

Classes

Class | Description
AdjustableArrowCap | [To be supplied.]
Blend | [To be supplied.]
ColorBlend | [To be supplied.]
CustomLineCap | [To be supplied.]
GraphicsContainer | Represents the internal data of a graphics container.
GraphicsPath | Represents a series of connected lines and curves.
GraphicsPathIterator | [To be supplied.]
GraphicsState | [To be supplied.]
HatchBrush | [To be supplied.]
LinearGradientBrush | [To be supplied.]
Matrix | [To be supplied.]
PathData | [To be supplied.]
PathGradientBrush | [To be supplied.]
RegionData | [To be supplied.]

Enumerations

Enumeration | Description
CombineMode | [To be supplied.]
CompositingMode | [To be supplied.]
CompositingQuality | [To be supplied.]
CoordinateSpace | [To be supplied.]
DashStyle | [To be supplied.]
FillMode | [To be supplied.]
FlushIntention | [To be supplied.]
HatchStyle | [To be supplied.]
InterpolationMode | [To be supplied.]
LinearGradientMode | [To be supplied.]
LineCap | [To be supplied.]
LineJoin | [To be supplied.]
MatrixOrder | [To be supplied.]
PathPointType | [To be supplied.]
PenAlignment | [To be supplied.]
PenType | [To be supplied.]
PixelOffsetMode | [To be supplied.]
QualityMode | [To be supplied.]
RenderingHint | [To be supplied.]
SmoothingMode | [To be supplied.]
WarpMode | [To be supplied.]
WrapMode | [To be supplied.]


AdjustableArrowCap Class

[To be supplied.]

Object
MarshalByRefObject
CustomLineCap
AdjustableArrowCap

[Visual Basic]
NotInheritable Public Class AdjustableArrowCap
   Inherits CustomLineCap
[C#]
public sealed class AdjustableArrowCap : CustomLineCap
[C++]
public __gc __sealed class AdjustableArrowCap : public
   CustomLineCap
[JScript]
public class AdjustableArrowCap extends CustomLineCap

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

AdjustableArrowCap Members | System.Drawing.Drawing2D Namespace


AdjustableArrowCap Members

Public:

Constructor

AdjustableArrowCap Constructor Overloaded. [To be supplied.]

Properties

BaseCap (inherited from CustomLineCap) | [To be supplied.]
BaseInset (inherited from CustomLineCap) | [To be supplied.]
Filled | [To be supplied.]
Height | [To be supplied.]
MiddleInset | [To be supplied.]
StrokeJoin (inherited from CustomLineCap) | [To be supplied.]
Width | [To be supplied.]
WidthScale (inherited from CustomLineCap) | [To be supplied.]

Methods

Clone (inherited from CustomLineCap) | [To be supplied.]
Dispose (inherited from CustomLineCap) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetStrokeCaps (inherited from CustomLineCap) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
SetStrokeCaps (inherited from CustomLineCap) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from CustomLineCap) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AdjustableArrowCap Class | System.Drawing.Drawing2D Namespace


AdjustableArrowCap Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Single, Single)
[C#] public AdjustableArrowCap(float, float);
[C++] public: AdjustableArrowCap(float, float);
[JScript] public function AdjustableArrowCap(float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Single, Single, Boolean)
[C#] public AdjustableArrowCap(float, float, bool);
[C++] public: AdjustableArrowCap(float, float, bool);
[JScript] public function AdjustableArrowCap(float, float, Boolean);

See Also

AdjustableArrowCap Class | AdjustableArrowCap Members | System.Drawing.Drawing2D Namespace


AdjustableArrowCap Constructor (Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal width As Single, _
   ByVal height As Single _
)
[C#]
public AdjustableArrowCap(
   float width,
   float height
);
[C++]
public: AdjustableArrowCap(
   float width,
   float height
);
[JScript]
public function AdjustableArrowCap(
   width : float,
   height : float
);

Parameters

width
[To be supplied.]
height
[To be supplied.]

See Also

AdjustableArrowCap Class | AdjustableArrowCap Members | System.Drawing.Drawing2D Namespace | AdjustableArrowCap Constructor Overload List


AdjustableArrowCap Constructor (Single, Single, Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal isFilled As Boolean _
)
[C#]
public AdjustableArrowCap(
   float width,
   float height,
   bool isFilled
);
[C++]
public: AdjustableArrowCap(
   float width,
   float height,
   bool isFilled
);
[JScript]
public function AdjustableArrowCap(
   width : float,
   height : float,
   isFilled : Boolean
);

Parameters

width
[To be supplied.]
height
[To be supplied.]
isFilled
[To be supplied.]

See Also

AdjustableArrowCap Class | AdjustableArrowCap Members | System.Drawing.Drawing2D Namespace | AdjustableArrowCap Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AdjustableArrowCap Properties

The properties of the AdjustableArrowCap class are listed below. For a complete list of AdjustableArrowCap class members, see the AdjustableArrowCap Members topic.

Public:

BaseCap (inherited from CustomLineCap) | [To be supplied.]
BaseInset (inherited from CustomLineCap) | [To be supplied.]
Filled | [To be supplied.]
Height | [To be supplied.]
MiddleInset | [To be supplied.]
StrokeJoin (inherited from CustomLineCap) | [To be supplied.]
Width | [To be supplied.]
WidthScale (inherited from CustomLineCap) | [To be supplied.]

See Also

AdjustableArrowCap Class | System.Drawing.Drawing2D Namespace


AdjustableArrowCap.Filled

[To be supplied.]

[Visual Basic]
Public Property Filled As Boolean
[C#]
public bool Filled {get; set;}
[C++]
public: __property bool get_Filled();
public: __property void set_Filled(bool);
[JScript]
public function get Filled() : Boolean;
public function set Filled(Boolean);

See Also

AdjustableArrowCap Class | AdjustableArrowCap Members | System.Drawing.Drawing2D Namespace


AdjustableArrowCap.Height

[To be supplied.]

[Visual Basic]
Public Property Height As Single
[C#]
public float Height {get; set;}
[C++]
public: __property float get_Height();
public: __property void set_Height(float);
[JScript]
public function get Height() : float;
public function set Height(float);

See Also

AdjustableArrowCap Class | AdjustableArrowCap Members | System.Drawing.Drawing2D Namespace


AdjustableArrowCap.MiddleInset

[To be supplied.]

[Visual Basic]
Public Property MiddleInset As Single
[C#]
public float MiddleInset {get; set;}
[C++]
public: __property float get_MiddleInset();
public: __property void set_MiddleInset(float);
[JScript]
public function get MiddleInset() : float;
public function set MiddleInset(float);

See Also

AdjustableArrowCap Class | AdjustableArrowCap Members | System.Drawing.Drawing2D Namespace


AdjustableArrowCap.Width

[To be supplied.]

[Visual Basic]
Public Property Width As Single
[C#]
public float Width {get; set;}
[C++]
public: __property float get_Width();
public: __property void set_Width(float);
[JScript]
public function get Width() : float;
public function set Width(float);

See Also

AdjustableArrowCap Class | AdjustableArrowCap Members | System.Drawing.Drawing2D Namespace


Blend Class

[To be supplied.]

Object
Blend

[Visual Basic]
NotInheritable Public Class Blend
[C#]
public sealed class Blend
[C++]
public __gc __sealed class Blend
[JScript]
public class Blend

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

Blend Members | System.Drawing.Drawing2D Namespace


Blend Members

Public:

Constructor

Blend Constructor Overloaded. [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Factors | [To be supplied.]
Positions | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Blend Class | System.Drawing.Drawing2D Namespace


Blend Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public Blend();
[C++] public: Blend();
[JScript] public function Blend();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public Blend(int);
[C++] public: Blend(int);
[JScript] public function Blend(int);

See Also

Blend Class | Blend Members | System.Drawing.Drawing2D Namespace


Blend Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public Blend();
[C++]
public: Blend();
[JScript]
public function Blend();

See Also

Blend Class | Blend Members | System.Drawing.Drawing2D Namespace | Blend Constructor Overload List


Blend Constructor (Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal count As Integer _
)
[C#]
public Blend(
   int count
);
[C++]
public: Blend(
   int count
);
[JScript]
public function Blend(
   count : int
);

Parameters

count
[To be supplied.]

See Also

Blend Class | Blend Members | System.Drawing.Drawing2D Namespace | Blend Constructor Overload List


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Blend Fields

The fields of the Blend class are listed below. For a complete list of Blend class members, see the Blend Members topic.

Public:

Factors | [To be supplied.]
Positions | [To be supplied.]

See Also

Blend Class | System.Drawing.Drawing2D Namespace


Blend.Factors

[To be supplied.]

[Visual Basic]
Public Factors() As Single
[C#]
public float[] Factors;
[C++]
public: float* Factors[];
[JScript]
public var Factors : float[];

See Also

Blend Class | Blend Members | System.Drawing.Drawing2D Namespace


Blend.Positions

[To be supplied.]

[Visual Basic]
Public Positions() As Single
[C#]
public float[] Positions;
[C++]
public: float* Positions[];
[JScript]
public var Positions : float[];

See Also

Blend Class | Blend Members | System.Drawing.Drawing2D Namespace


ColorBlend Class

[To be supplied.]

Object
ColorBlend

[Visual Basic]
NotInheritable Public Class ColorBlend
[C#]
public sealed class ColorBlend
[C++]
public __gc __sealed class ColorBlend
[JScript]
public class ColorBlend

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

ColorBlend Members | System.Drawing.Drawing2D Namespace


ColorBlend Members

Public:

Constructor

ColorBlend Constructor Overloaded. [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Colors | [To be supplied.]
Positions | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ColorBlend Class | System.Drawing.Drawing2D Namespace


ColorBlend Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public ColorBlend();
[C++] public: ColorBlend();
[JScript] public function ColorBlend();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public ColorBlend(int);
[C++] public: ColorBlend(int);
[JScript] public function ColorBlend(int);

See Also

ColorBlend Class | ColorBlend Members | System.Drawing.Drawing2D Namespace


ColorBlend Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public ColorBlend();
[C++]
public: ColorBlend();
[JScript]
public function ColorBlend();

See Also

ColorBlend Class | ColorBlend Members | System.Drawing.Drawing2D Namespace | ColorBlend Constructor Overload List


ColorBlend Constructor (Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal count As Integer _
)
[C#]
public ColorBlend(
   int count
);
[C++]
public: ColorBlend(
   int count
);
[JScript]
public function ColorBlend(
   count : int
);

Parameters

count
[To be supplied.]

See Also

ColorBlend Class | ColorBlend Members | System.Drawing.Drawing2D Namespace | ColorBlend Constructor Overload List


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ColorBlend Fields

The fields of the ColorBlend class are listed below. For a complete list of ColorBlend class members, see the ColorBlend Members topic.

Public:

Colors | [To be supplied.]
Positions | [To be supplied.]

See Also

ColorBlend Class | System.Drawing.Drawing2D Namespace


ColorBlend.Colors

[To be supplied.]

[Visual Basic]
Public Colors() As Color
[C#]
public Color[] Colors;
[C++]
public: Color* Colors[];
[JScript]
public var Colors : Color[];

See Also

ColorBlend Class | ColorBlend Members | System.Drawing.Drawing2D Namespace


ColorBlend.Positions

[To be supplied.]

[Visual Basic]
Public Positions() As Single
[C#]
public float[] Positions;
[C++]
public: float* Positions[];
[JScript]
public var Positions : float[];

See Also

ColorBlend Class | ColorBlend Members | System.Drawing.Drawing2D Namespace


CombineMode Enumeration

[To be supplied.]

[Visual Basic]
Public Enum CombineMode
[C#]
public enum CombineMode
[C++]
public enum CombineMode

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Complement | [To be supplied.]
Exclude | [To be supplied.]
Intersect | [To be supplied.]
Replace | [To be supplied.]
Union | [To be supplied.]
Xor | [To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

System.Drawing.Drawing2D Namespace


CompositingMode Enumeration

[To be supplied.]

[Visual Basic]
Public Enum CompositingMode
[C#]
public enum CompositingMode
[C++]
public enum CompositingMode

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
SourceCopy | [To be supplied.]
SourceOver | [To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

System.Drawing.Drawing2D Namespace


CompositingQuality Enumeration

[To be supplied.]

[Visual Basic]
Public Enum CompositingQuality
[C#]
public enum CompositingQuality
[C++]
public enum CompositingQuality

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
AssumeLinear | [To be supplied.]
Default | [To be supplied.]
GammaCorrected | [To be supplied.]
HighQuality | [To be supplied.]
HighSpeed | [To be supplied.]
Invalid | [To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

System.Drawing.Drawing2D Namespace


CoordinateSpace Enumeration

[To be supplied.]

[Visual Basic]
Public Enum CoordinateSpace
[C#]
public enum CoordinateSpace
[C++]
public enum CoordinateSpace

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Device | [To be supplied.]
Page | [To be supplied.]
World | [To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

System.Drawing.Drawing2D Namespace


CustomLineCap Class

[To be supplied.]

Object
MarshalByRefObject
CustomLineCap

[Visual Basic]
Public Class CustomLineCap
   Inherits MarshalByRefObject
   Implements ICloneable
[C#]
public class CustomLineCap : MarshalByRefObject, ICloneable
[C++]
public __gc class CustomLineCap : public MarshalByRefObject,
   ICloneable
[JScript]
public class CustomLineCap extends MarshalByRefObject, ICloneable

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

CustomLineCap Members | System.Drawing.Drawing2D Namespace


CustomLineCap Members

Public:

Constructor

CustomLineCap Constructor Overloaded. [To be supplied.]

Properties

BaseCap | [To be supplied.]
BaseInset | [To be supplied.]
StrokeJoin | [To be supplied.]
WidthScale | [To be supplied.]

Methods

Clone | [To be supplied.]
Dispose | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetStrokeCaps | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
SetStrokeCaps | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CustomLineCap Class | System.Drawing.Drawing2D Namespace


CustomLineCap Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(GraphicsPath, GraphicsPath)
[C#] public CustomLineCap(GraphicsPath, GraphicsPath);
[C++] public: CustomLineCap(GraphicsPath*, GraphicsPath*);
[JScript] public function CustomLineCap(GraphicsPath, GraphicsPath);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(GraphicsPath, GraphicsPath, LineCap)
[C#] public CustomLineCap(GraphicsPath, GraphicsPath, LineCap);
[C++] public: CustomLineCap(GraphicsPath*, GraphicsPath*, LineCap);
[JScript] public function CustomLineCap(GraphicsPath, GraphicsPath, LineCap);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(GraphicsPath, GraphicsPath, LineCap, Single)
[C#] public CustomLineCap(GraphicsPath, GraphicsPath, LineCap, float);
[C++] public: CustomLineCap(GraphicsPath*, GraphicsPath*, LineCap, float);
[JScript] public function CustomLineCap(GraphicsPath, GraphicsPath, LineCap, float);

See Also

CustomLineCap Class | CustomLineCap Members | System.Drawing.Drawing2D Namespace


CustomLineCap Constructor (GraphicsPath, GraphicsPath)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal fillPath As GraphicsPath, _
   ByVal strokePath As GraphicsPath _
)
[C#]
public CustomLineCap(
   GraphicsPath fillPath,
   GraphicsPath strokePath
);
[C++]
public: CustomLineCap(
   GraphicsPath* fillPath,
   GraphicsPath* strokePath
);
[JScript]
public function CustomLineCap(
   fillPath : GraphicsPath,
   strokePath : GraphicsPath
);

Parameters

fillPath
[To be supplied.]
strokePath
[To be supplied.]

See Also

CustomLineCap Class | CustomLineCap Members | System.Drawing.Drawing2D Namespace | CustomLineCap Constructor Overload List


CustomLineCap Constructor (GraphicsPath, GraphicsPath, LineCap)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal fillPath As GraphicsPath, _
   ByVal strokePath As GraphicsPath, _
   ByVal baseCap As LineCap _
)
[C#]
public CustomLineCap(
   GraphicsPath fillPath,
   GraphicsPath strokePath,
   LineCap baseCap
);
[C++]
public: CustomLineCap(
   GraphicsPath* fillPath,
   GraphicsPath* strokePath,
   LineCap baseCap
);
[JScript]
public function CustomLineCap(
   fillPath : GraphicsPath,
   strokePath : GraphicsPath,
   baseCap : LineCap
);

Parameters

fillPath
[To be supplied.]
strokePath
[To be supplied.]
baseCap
[To be supplied.]

See Also

CustomLineCap Class | CustomLineCap Members | System.Drawing.Drawing2D Namespace | CustomLineCap Constructor Overload List


CustomLineCap Constructor (GraphicsPath, GraphicsPath, LineCap, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal fillPath As GraphicsPath, _
   ByVal strokePath As GraphicsPath, _
   ByVal baseCap As LineCap, _
   ByVal baseInset As Single _
)
[C#]
public CustomLineCap(
   GraphicsPath fillPath,
   GraphicsPath strokePath,
   LineCap baseCap,
   float baseInset
);
[C++]
public: CustomLineCap(
   GraphicsPath* fillPath,
   GraphicsPath* strokePath,
   LineCap baseCap,
   float baseInset
);
[JScript]
public function CustomLineCap(
   fillPath : GraphicsPath,
   strokePath : GraphicsPath,
   baseCap : LineCap,
   baseInset : float
);

Parameters

fillPath
[To be supplied.]
strokePath
[To be supplied.]
baseCap
[To be supplied.]
baseInset
[To be supplied.]

See Also

CustomLineCap Class | CustomLineCap Members | System.Drawing.Drawing2D Namespace | CustomLineCap Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CustomLineCap Properties

The properties of the CustomLineCap class are listed below. For a complete list of CustomLineCap class members, see the CustomLineCap Members topic.

Public:

BaseCap | [To be supplied.]
BaseInset | [To be supplied.]
StrokeJoin | [To be supplied.]
WidthScale | [To be supplied.]

See Also

CustomLineCap Class | System.Drawing.Drawing2D Namespace


CustomLineCap.BaseCap

[To be supplied.]

[Visual Basic]
Public Property BaseCap As LineCap
[C#]
public LineCap BaseCap {get; set;}
[C++]
public: __property LineCap get_BaseCap();
public: __property void set_BaseCap(LineCap);
[JScript]
public function get BaseCap() : LineCap;
public function set BaseCap(LineCap);

See Also

CustomLineCap Class | CustomLineCap Members | System.Drawing.Drawing2D Namespace


CustomLineCap.BaseInset

[To be supplied.]

[Visual Basic]
Public Property BaseInset As Single
[C#]
public float BaseInset {get; set;}
[C++]
public: __property float get_BaseInset();
public: __property void set_BaseInset(float);
[JScript]
public function get BaseInset() : float;
public function set BaseInset(float);

See Also

CustomLineCap Class | CustomLineCap Members | System.Drawing.Drawing2D Namespace


CustomLineCap.StrokeJoin

[To be supplied.]

[Visual Basic]
Public Property StrokeJoin As LineJoin
[C#]
public LineJoin StrokeJoin {get; set;}
[C++]
public: __property LineJoin get_StrokeJoin();
public: __property void set_StrokeJoin(LineJoin);
[JScript]
public function get StrokeJoin() : LineJoin;
public function set StrokeJoin(LineJoin);

See Also

CustomLineCap Class | CustomLineCap Members | System.Drawing.Drawing2D Namespace


CustomLineCap.WidthScale

[To be supplied.]

[Visual Basic]
Public Property WidthScale As Single
[C#]
public float WidthScale {get; set;}
[C++]
public: __property float get_WidthScale();
public: __property void set_WidthScale(float);
[JScript]
public function get WidthScale() : float;
public function set WidthScale(float);

See Also

CustomLineCap Class | CustomLineCap Members | System.Drawing.Drawing2D Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CustomLineCap Methods

The methods of the CustomLineCap class are listed below. For a complete list of CustomLineCap class members, see the CustomLineCap Members topic.

Public:

Clone | [To be supplied.]
Dispose | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetStrokeCaps | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
SetStrokeCaps | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CustomLineCap Class | System.Drawing.Drawing2D Namespace


CustomLineCap.Clone

[To be supplied.]

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

See Also

CustomLineCap Class | CustomLineCap Members | System.Drawing.Drawing2D Namespace


CustomLineCap.Dispose

[To be supplied.]

[Visual Basic]
Overridable Public Sub Dispose()
[C#]
public virtual void Dispose();
[C++]
public: virtual void Dispose();
[JScript]
public function Dispose();

See Also

CustomLineCap Class | CustomLineCap Members | System.Drawing.Drawing2D Namespace


CustomLineCap.Finalize

[To be supplied.]

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

CustomLineCap Class | CustomLineCap Members | System.Drawing.Drawing2D Namespace


CustomLineCap.GetStrokeCaps

[To be supplied.]

[Visual Basic]
Public Sub GetStrokeCaps( _
   ByRef startCap As LineCap, _
   ByRef endCap As LineCap _
)
[C#]
public void GetStrokeCaps(
   ref LineCap startCap,
   ref LineCap endCap
);
[C++]
public: void GetStrokeCaps(
   LineCap** startCap,
   LineCap** endCap
);
[JScript]
public function GetStrokeCaps(
   startCap : LineCap,
   endCap : LineCap
);

Parameters

startCap
[To be supplied.]
endCap
[To be supplied.]

See Also

CustomLineCap Class | CustomLineCap Members | System.Drawing.Drawing2D Namespace


CustomLineCap.SetStrokeCaps

[To be supplied.]

[Visual Basic]
Public Sub SetStrokeCaps( _
   ByVal startCap As LineCap, _
   ByVal endCap As LineCap _
)
[C#]
public void SetStrokeCaps(
   LineCap startCap,
   LineCap endCap
);
[C++]
public: void SetStrokeCaps(
   LineCap startCap,
   LineCap endCap
);
[JScript]
public function SetStrokeCaps(
   startCap : LineCap,
   endCap : LineCap
);

Parameters

startCap
[To be supplied.]
endCap
[To be supplied.]

See Also

CustomLineCap Class | CustomLineCap Members | System.Drawing.Drawing2D Namespace


DashStyle Enumeration

[To be supplied.]

[Visual Basic]
Public Enum DashStyle
[C#]
public enum DashStyle
[C++]
public enum DashStyle

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Custom | [To be supplied.]
Dash | [To be supplied.]
DashDot | [To be supplied.]
DashDotDot | [To be supplied.]
Dot | [To be supplied.]
Solid | [To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

System.Drawing.Drawing2D Namespace


FillMode Enumeration

[To be supplied.]

[Visual Basic]
Public Enum FillMode
[C#]
public enum FillMode
[C++]
public enum FillMode

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Alternate | [To be supplied.]
Winding | [To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

System.Drawing.Drawing2D Namespace


FlushIntention Enumeration

[To be supplied.]

[Visual Basic]
Public Enum FlushIntention
[C#]
public enum FlushIntention
[C++]
public enum FlushIntention

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Flush | [To be supplied.]
Sync | [To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

System.Drawing.Drawing2D Namespace


GraphicsContainer Class

Represents the internal data of a graphics container.

Object
MarshalByRefObject
GraphicsContainer

[Visual Basic]
NotInheritable Public Class GraphicsContainer
   Inherits MarshalByRefObject
[C#]
public sealed class GraphicsContainer : MarshalByRefObject
[C++]
public __gc __sealed class GraphicsContainer : public
   MarshalByRefObject
[JScript]
public class GraphicsContainer extends MarshalByRefObject

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

GraphicsContainer Members | System.Drawing.Drawing2D Namespace


GraphicsContainer Members

Public:

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GraphicsContainer Class | System.Drawing.Drawing2D Namespace


GraphicsPath Class

Represents a series of connected lines and curves.

Object
MarshalByRefObject
GraphicsPath

[Visual Basic]
NotInheritable Public Class GraphicsPath
   Inherits MarshalByRefObject
   Implements ICloneable
[C#]
public sealed class GraphicsPath : MarshalByRefObject, ICloneable
[C++]
public __gc __sealed class GraphicsPath : public
   MarshalByRefObject, ICloneable
[JScript]
public class GraphicsPath extends MarshalByRefObject, ICloneable

Remarks

Applications use paths to draw outlines of shapes, fill the interiors of shapes, and create clipping regions. The graphics engine maintains the coordinates of geometric shapes in a path in world coordinate space. The coordinates are transformed by the current transform to the physical coordinate space when the path is used. As a result, an application can use a path multiple times. A path may be composed of any number of figures. Each figure is either composed of a sequence of connected lines and curves or a geometric shape primitive. The starting point of a figure is the first point in the sequence of connected lines and curves. The ending point is the last point in the sequence. The starting and ending points of a geometric shape primitive are defined by the primitive specification. A figure that consists of a sequence of connected lines and curves (whose starting and ending points may be coincident) is an open figure, unless it is closed explicitly. An open figure does not have an interior, and will be ignored when a path is filled or converted to clipping regions. The closeFigure method closes the current figure by connecting a line from the ending point to the starting point. A figure that consists of a geometric shape primitive is a closed figure. A new figure is implicitly started when a path is created, when a figure is closed, or explicitly when the startFigure method is called. When a geometric shape primitive is added to a path, it adds a figure containing the geometric shape, and also implicitly starts a new figure. Consequently, there is always a current figure in a path. When lines and curves are added to a path, an implicit line is added as needed to connect the ending point of the current figure to the starting point of the new lines and curves to form a sequence of connected lines and curves. A figure has a direction that describes how line and curve segments are traced between the starting point and the ending point. The direction is defined in the order that lines and curves are added to a figure, or is defined by the geometric shape primitive. The direction is used in determining the path interiors for clipping and fill.

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath Members

Public:

Constructor

GraphicsPath Constructor Overloaded. Initializes a new instance of the GraphicsPath class.

Properties

FillMode | [To be supplied.]
PathData | [To be supplied.]
PathPoints | [To be supplied.]
PathTypes | [To be supplied.]
PointCount | [To be supplied.]

Methods

AddArc | Overloaded. [To be supplied.]
AddBezier | Overloaded. [To be supplied.]
AddBeziers | Overloaded. [To be supplied.]
AddClosedCurve | Overloaded. [To be supplied.]
AddCurve | Overloaded. [To be supplied.]
AddEllipse | Overloaded. [To be supplied.]
AddLine | Overloaded. [To be supplied.]
AddLines | Overloaded. [To be supplied.]
AddPath | [To be supplied.]
AddPie | Overloaded. [To be supplied.]
AddPolygon | Overloaded. [To be supplied.]
AddRectangle | Overloaded. [To be supplied.]
AddRectangles | Overloaded. [To be supplied.]
AddString | Overloaded. [To be supplied.]
ClearMarkers | [To be supplied.]
Clone | [To be supplied.]
CloseAllFigures | [To be supplied.]
CloseFigure | [To be supplied.]
Dispose | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Flatten | Overloaded. [To be supplied.]
GetBounds | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLastPoint | [To be supplied.]
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
IsOutlineVisible | Overloaded. [To be supplied.]
IsVisible | Overloaded. [To be supplied.]
Reset | [To be supplied.]
Reverse | [To be supplied.]
SetMarkers | [To be supplied.]
StartFigure | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform | [To be supplied.]
Warp | Overloaded. [To be supplied.]
Widen | Overloaded. [To be supplied.]

Protected:

Methods

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GraphicsPath Class | System.Drawing.Drawing2D Namespace


GraphicsPath Constructor

Initializes a new instance of the GraphicsPath class.

Overload List

Initializes a new instance of the GraphicsPath class with a FillMode of Alternate.

[Visual Basic] Overloads Public Sub New()
[C#] public GraphicsPath();
[C++] public: GraphicsPath();
[JScript] public function GraphicsPath();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(FillMode)
[C#] public GraphicsPath(FillMode);
[C++] public: GraphicsPath(FillMode);
[JScript] public function GraphicsPath(FillMode);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(PointF(), Byte())
[C#] public GraphicsPath(PointF[], byte[]);
[C++] public: GraphicsPath(PointF*[], unsigned char[]);
[JScript] public function GraphicsPath(PointF[], Byte[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(PointF(), Byte(), FillMode)
[C#] public GraphicsPath(PointF[], byte[], FillMode);
[C++] public: GraphicsPath(PointF*[], unsigned char[], FillMode);
[JScript] public function GraphicsPath(PointF[], Byte[], FillMode);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Point(), Byte())
[C#] public GraphicsPath(Point[], byte[]);
[C++] public: GraphicsPath(Point*[], unsigned char[]);
[JScript] public function GraphicsPath(Point[], Byte[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Point(), Byte(), FillMode)
[C#] public GraphicsPath(Point[], byte[], FillMode);
[C++] public: GraphicsPath(Point*[], unsigned char[], FillMode);
[JScript] public function GraphicsPath(Point[], Byte[], FillMode);

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath Constructor ()

Initializes a new instance of the GraphicsPath class with a FillMode of Alternate.

[Visual Basic]
Overloads Public Sub New()
[C#]
public GraphicsPath();
[C++]
public: GraphicsPath();
[JScript]
public function GraphicsPath();

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath Constructor Overload List


GraphicsPath Constructor (FillMode)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal fillMode As FillMode _
)
[C#]
public GraphicsPath(
   FillMode fillMode
);
[C++]
public: GraphicsPath(
   FillMode fillMode
);
[JScript]
public function GraphicsPath(
   fillMode : FillMode
);

Parameters

fillMode
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath Constructor Overload List


GraphicsPath Constructor (PointF[], Byte[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal pts() As PointF, _
   ByVal types() As Byte _
)
[C#]
public GraphicsPath(
   PointF[] pts,
   byte[] types
);
[C++]
public: GraphicsPath(
   PointF* pts[],
   unsigned char* types[]
);
[JScript]
public function GraphicsPath(
   pts : PointF[],
   types : Byte[]
);

Parameters

pts
[To be supplied.]
types
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath Constructor Overload List


GraphicsPath Constructor (PointF[], Byte[], FillMode)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal pts() As PointF, _
   ByVal types() As Byte, _
   ByVal fillMode As FillMode _
)
[C#]
public GraphicsPath(
   PointF[] pts,
   byte[] types,
   FillMode fillMode
);
[C++]
public: GraphicsPath(
   PointF* pts[],
   unsigned char* types[],
   FillMode fillMode
);
[JScript]
public function GraphicsPath(
   pts : PointF[],
   types : Byte[],
   fillMode : FillMode
);

Parameters

pts
[To be supplied.]
types
[To be supplied.]
fillMode
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath Constructor Overload List


GraphicsPath Constructor (Point[], Byte[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal pts() As Point, _
   ByVal types() As Byte _
)
[C#]
public GraphicsPath(
   Point[] pts,
   byte[] types
);
[C++]
public: GraphicsPath(
   Point* pts[],
   unsigned char* types[]
);
[JScript]
public function GraphicsPath(
   pts : Point[],
   types : Byte[]
);

Parameters

pts
[To be supplied.]
types
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath Constructor Overload List


GraphicsPath Constructor (Point[], Byte[], FillMode)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal pts() As Point, _
   ByVal types() As Byte, _
   ByVal fillMode As FillMode _
)
[C#]
public GraphicsPath(
   Point[] pts,
   byte[] types,
   FillMode fillMode
);
[C++]
public: GraphicsPath(
   Point* pts[],
   unsigned char* types[],
   FillMode fillMode
);
[JScript]
public function GraphicsPath(
   pts : Point[],
   types : Byte[],
   fillMode : FillMode
);

Parameters

pts
[To be supplied.]
types
[To be supplied.]
fillMode
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

GraphicsPath Properties

The properties of the GraphicsPath class are listed below. For a complete list of GraphicsPath class members, see the GraphicsPath Members topic.

Public:

FillMode | [To be supplied.]
PathData | [To be supplied.]
PathPoints | [To be supplied.]
PathTypes | [To be supplied.]
PointCount | [To be supplied.]

See Also

GraphicsPath Class | System.Drawing.Drawing2D Namespace


GraphicsPath.FillMode

[To be supplied.]

[Visual Basic]
Public Property FillMode As FillMode
[C#]
public FillMode FillMode {get; set;}
[C++]
public: __property FillMode get_FillMode();
public: __property void set_FillMode(FillMode);
[JScript]
public function get FillMode() : FillMode;
public function set FillMode(FillMode);

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.PathData

[To be supplied.]

[Visual Basic]
Public ReadOnly Property PathData As PathData
[C#]
public PathData PathData {get;}
[C++]
public: __property PathData* get_PathData();
[JScript]
public function get PathData() : PathData;

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.PathPoints

[To be supplied.]

[Visual Basic]
Public ReadOnly Property PathPoints As PointF ()
[C#]
public PointF[] PathPoints {get;}
[C++]
public: __property PointF* get_PathPoints();
[JScript]
public function get PathPoints() : PointF[];

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.PathTypes

[To be supplied.]

[Visual Basic]
Public ReadOnly Property PathTypes As Byte ()
[C#]
public byte[] PathTypes {get;}
[C++]
public: __property unsigned char* get_PathTypes();
[JScript]
public function get PathTypes() : Byte[];

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.PointCount

[To be supplied.]

[Visual Basic]
Public ReadOnly Property PointCount As Integer
[C#]
public int PointCount {get;}
[C++]
public: __property int get_PointCount();
[JScript]
public function get PointCount() : int;

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

GraphicsPath Methods

The methods of the GraphicsPath class are listed below. For a complete list of GraphicsPath class members, see the GraphicsPath Members topic.

Public:

AddArc | Overloaded. [To be supplied.]
AddBezier | Overloaded. [To be supplied.]
AddBeziers | Overloaded. [To be supplied.]
AddClosedCurve | Overloaded. [To be supplied.]
AddCurve | Overloaded. [To be supplied.]
AddEllipse | Overloaded. [To be supplied.]
AddLine | Overloaded. [To be supplied.]
AddLines | Overloaded. [To be supplied.]
AddPath | [To be supplied.]
AddPie | Overloaded. [To be supplied.]
AddPolygon | Overloaded. [To be supplied.]
AddRectangle | Overloaded. [To be supplied.]
AddRectangles | Overloaded. [To be supplied.]
AddString | Overloaded. [To be supplied.]
ClearMarkers | [To be supplied.]
Clone | [To be supplied.]
CloseAllFigures | [To be supplied.]
CloseFigure | [To be supplied.]
Dispose | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Flatten | Overloaded. [To be supplied.]
GetBounds | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLastPoint | [To be supplied.]
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
IsOutlineVisible | Overloaded. [To be supplied.]
IsVisible | Overloaded. [To be supplied.]
Reset | [To be supplied.]
Reverse | [To be supplied.]
SetMarkers | [To be supplied.]
StartFigure | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform | [To be supplied.]
Warp | Overloaded. [To be supplied.]
Widen | Overloaded. [To be supplied.]

Protected:

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GraphicsPath Class | System.Drawing.Drawing2D Namespace


GraphicsPath.AddArc

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub AddArc(Rectangle, Single, Single)
[C#] public void AddArc(Rectangle, float, float);
[C++] public: void AddArc(Rectangle, float, float);
[JScript] public function AddArc(Rectangle, float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub AddArc(Integer, Integer, Integer, Integer, Single, Single)
[C#] public void AddArc(int, int, int, int, float, float);
[C++] public: void AddArc(int, int, int, int, float, float);
[JScript] public function AddArc(int, int, int, int, float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub AddArc(RectangleF, Single, Single)
[C#] public void AddArc(RectangleF, float, float);
[C++] public: void AddArc(RectangleF, float, float);
[JScript] public function AddArc(RectangleF, float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub AddArc(Single, Single, Single, Single, Single, Single)
[C#] public void AddArc(float, float, float, float, float, float);
[C++] public: void AddArc(float, float, float, float, float, float);
[JScript] public function AddArc(float, float, float, float, float, float);

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.AddArc (Rectangle, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddArc( _
   ByVal rect As Rectangle, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
[C#]
public void AddArc(
   Rectangle rect,
   float startAngle,
   float sweepAngle
);
[C++]
public: void AddArc(
   Rectangle rect,
   float startAngle,
   float sweepAngle
);
[JScript]
public function AddArc(
   rect : Rectangle,
   startAngle : float,
   sweepAngle : float
);

Parameters

rect
[To be supplied.]
startAngle
[To be supplied.]
sweepAngle
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddArc Overload List


GraphicsPath.AddArc (Int32, Int32, Int32, Int32, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddArc( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
[C#]
public void AddArc(
   int x,
   int y,
   int width,
   int height,
   float startAngle,
   float sweepAngle
);
[C++]
public: void AddArc(
   int x,
   int y,
   int width,
   int height,
   float startAngle,
   float sweepAngle
);
[JScript]
public function AddArc(
   x : int,
   y : int,
   width : int,
   height : int,
   startAngle : float,
   sweepAngle : float
);

Parameters

x
[To be supplied.]
y
[To be supplied.]
width
[To be supplied.]
height
[To be supplied.]
startAngle
[To be supplied.]
sweepAngle
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddArc Overload List


GraphicsPath.AddArc (RectangleF, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddArc( _
   ByVal rect As RectangleF, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
[C#]
public void AddArc(
   RectangleF rect,
   float startAngle,
   float sweepAngle
);
[C++]
public: void AddArc(
   RectangleF rect,
   float startAngle,
   float sweepAngle
);
[JScript]
public function AddArc(
   rect : RectangleF,
   startAngle : float,
   sweepAngle : float
);

Parameters

rect
[To be supplied.]
startAngle
[To be supplied.]
sweepAngle
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddArc Overload List


GraphicsPath.AddArc (Single, Single, Single, Single, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddArc( _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
[C#]
public void AddArc(
   float x,
   float y,
   float width,
   float height,
   float startAngle,
   float sweepAngle
);
[C++]
public: void AddArc(
   float x,
   float y,
   float width,
   float height,
   float startAngle,
   float sweepAngle
);
[JScript]
public function AddArc(
   x : float,
   y : float,
   width : float,
   height : float,
   startAngle : float,
   sweepAngle : float
);

Parameters

x
[To be supplied.]
y
[To be supplied.]
width
[To be supplied.]
height
[To be supplied.]
startAngle
[To be supplied.]
sweepAngle
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddArc Overload List


GraphicsPath.AddBezier

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub AddBezier(PointF, PointF, PointF, PointF)
[C#] public void AddBezier(PointF, PointF, PointF, PointF);
[C++] public: void AddBezier(PointF, PointF, PointF, PointF);
[JScript] public function AddBezier(PointF, PointF, PointF, PointF);

[To be supplied.]

[Visual Basic] Overloads Public Sub AddBezier(Point, Point, Point, Point)
[C#] public void AddBezier(Point, Point, Point, Point);
[C++] public: void AddBezier(Point, Point, Point, Point);
[JScript] public function AddBezier(Point, Point, Point, Point);

[To be supplied.]

[Visual Basic] Overloads Public Sub AddBezier(Integer, Integer, Integer, Integer, Integer, Integer, Integer, Integer)
[C#] public void AddBezier(int, int, int, int, int, int, int, int);
[C++] public: void AddBezier(int, int, int, int, int, int, int, int);
[JScript] public function AddBezier(int, int, int, int, int, int, int, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub AddBezier(Single, Single, Single, Single, Single, Single, Single, Single)
[C#] public void AddBezier(float, float, float, float, float, float, float, float);
[C++] public: void AddBezier(float, float, float, float, float, float, float, float);
[JScript] public function AddBezier(float, float, float, float, float, float, float, float);

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.AddBezier (PointF, PointF, PointF, PointF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddBezier( _
   ByVal pt1 As PointF, _
   ByVal pt2 As PointF, _
   ByVal pt3 As PointF, _
   ByVal pt4 As PointF _
)
[C#]
public void AddBezier(
   PointF pt1,
   PointF pt2,
   PointF pt3,
   PointF pt4
);
[C++]
public: void AddBezier(
   PointF pt1,
   PointF pt2,
   PointF pt3,
   PointF pt4
);
[JScript]
public function AddBezier(
   pt1 : PointF,
   pt2 : PointF,
   pt3 : PointF,
   pt4 : PointF
);

Parameters

pt1
[To be supplied.]
pt2
[To be supplied.]
pt3
[To be supplied.]
pt4
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddBezier Overload List


GraphicsPath.AddBezier (Point, Point, Point, Point)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddBezier( _
   ByVal pt1 As Point, _
   ByVal pt2 As Point, _
   ByVal pt3 As Point, _
   ByVal pt4 As Point _
)
[C#]
public void AddBezier(
   Point pt1,
   Point pt2,
   Point pt3,
   Point pt4
);
[C++]
public: void AddBezier(
   Point pt1,
   Point pt2,
   Point pt3,
   Point pt4
);
[JScript]
public function AddBezier(
   pt1 : Point,
   pt2 : Point,
   pt3 : Point,
   pt4 : Point
);

Parameters

pt1
[To be supplied.]
pt2
[To be supplied.]
pt3
[To be supplied.]
pt4
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddBezier Overload List


GraphicsPath.AddBezier (Int32, Int32, Int32, Int32, Int32, Int32, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddBezier( _
   ByVal x1 As Integer, _
   ByVal y1 As Integer, _
   ByVal x2 As Integer, _
   ByVal y2 As Integer, _
   ByVal x3 As Integer, _
   ByVal y3 As Integer, _
   ByVal x4 As Integer, _
   ByVal y4 As Integer _
)
[C#]
public void AddBezier(
   int x1,
   int y1,
   int x2,
   int y2,
   int x3,
   int y3,
   int x4,
   int y4
);
[C++]
public: void AddBezier(
   int x1,
   int y1,
   int x2,
   int y2,
   int x3,
   int y3,
   int x4,
   int y4
);
[JScript]
public function AddBezier(
   x1 : int,
   y1 : int,
   x2 : int,
   y2 : int,
   x3 : int,
   y3 : int,
   x4 : int,
   y4 : int
);

Parameters

x1
[To be supplied.]
y1
[To be supplied.]
x2
[To be supplied.]
y2
[To be supplied.]
x3
[To be supplied.]
y3
[To be supplied.]
x4
[To be supplied.]
y4
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddBezier Overload List


GraphicsPath.AddBezier (Single, Single, Single, Single, Single, Single, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddBezier( _
   ByVal x1 As Single, _
   ByVal y1 As Single, _
   ByVal x2 As Single, _
   ByVal y2 As Single, _
   ByVal x3 As Single, _
   ByVal y3 As Single, _
   ByVal x4 As Single, _
   ByVal y4 As Single _
)
[C#]
public void AddBezier(
   float x1,
   float y1,
   float x2,
   float y2,
   float x3,
   float y3,
   float x4,
   float y4
);
[C++]
public: void AddBezier(
   float x1,
   float y1,
   float x2,
   float y2,
   float x3,
   float y3,
   float x4,
   float y4
);
[JScript]
public function AddBezier(
   x1 : float,
   y1 : float,
   x2 : float,
   y2 : float,
   x3 : float,
   y3 : float,
   x4 : float,
   y4 : float
);

Parameters

x1
[To be supplied.]
y1
[To be supplied.]
x2
[To be supplied.]
y2
[To be supplied.]
x3
[To be supplied.]
y3
[To be supplied.]
x4
[To be supplied.]
y4
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddBezier Overload List


GraphicsPath.AddBeziers

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub AddBeziers(Point())
[C#] public void AddBeziers(Point[]);
[C++] public: void AddBeziers(Point*[]);
[JScript] public function AddBeziers(Point[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub AddBeziers(PointF())
[C#] public void AddBeziers(PointF[]);
[C++] public: void AddBeziers(PointF*[]);
[JScript] public function AddBeziers(PointF[]);

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.AddBeziers (Point[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddBeziers( _
   ByVal points() As Point _
)
[C#]
public void AddBeziers(
   Point[] points
);
[C++]
public: void AddBeziers(
   Point* points[]
);
[JScript]
public function AddBeziers(
   points : Point[]
);

Parameters

points
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddBeziers Overload List


GraphicsPath.AddBeziers (PointF[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddBeziers( _
   ByVal points() As PointF _
)
[C#]
public void AddBeziers(
   PointF[] points
);
[C++]
public: void AddBeziers(
   PointF* points[]
);
[JScript]
public function AddBeziers(
   points : PointF[]
);

Parameters

points
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddBeziers Overload List


GraphicsPath.AddClosedCurve

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub AddClosedCurve(PointF(), Single)
[C#] public void AddClosedCurve(PointF[], float);
[C++] public: void AddClosedCurve(PointF*[], float);
[JScript] public function AddClosedCurve(PointF[], float);

[To be supplied.]

[Visual Basic] Overloads Public Sub AddClosedCurve(PointF())
[C#] public void AddClosedCurve(PointF[]);
[C++] public: void AddClosedCurve(PointF*[]);
[JScript] public function AddClosedCurve(PointF[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub AddClosedCurve(Point(), Single)
[C#] public void AddClosedCurve(Point[], float);
[C++] public: void AddClosedCurve(Point*[], float);
[JScript] public function AddClosedCurve(Point[], float);

[To be supplied.]

[Visual Basic] Overloads Public Sub AddClosedCurve(Point())
[C#] public void AddClosedCurve(Point[]);
[C++] public: void AddClosedCurve(Point*[]);
[JScript] public function AddClosedCurve(Point[]);

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.AddClosedCurve (PointF[], Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddClosedCurve( _
   ByVal points() As PointF, _
   ByVal tension As Single _
)
[C#]
public void AddClosedCurve(
   PointF[] points,
   float tension
);
[C++]
public: void AddClosedCurve(
   PointF* points[],
   float tension
);
[JScript]
public function AddClosedCurve(
   points : PointF[],
   tension : float
);

Parameters

points
[To be supplied.]
tension
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddClosedCurve Overload List


GraphicsPath.AddClosedCurve (PointF[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddClosedCurve( _
   ByVal points() As PointF _
)
[C#]
public void AddClosedCurve(
   PointF[] points
);
[C++]
public: void AddClosedCurve(
   PointF* points[]
);
[JScript]
public function AddClosedCurve(
   points : PointF[]
);

Parameters

points
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddClosedCurve Overload List


GraphicsPath.AddClosedCurve (Point[], Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddClosedCurve( _
   ByVal points() As Point, _
   ByVal tension As Single _
)
[C#]
public void AddClosedCurve(
   Point[] points,
   float tension
);
[C++]
public: void AddClosedCurve(
   Point* points[],
   float tension
);
[JScript]
public function AddClosedCurve(
   points : Point[],
   tension : float
);

Parameters

points
[To be supplied.]
tension
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddClosedCurve Overload List


GraphicsPath.AddClosedCurve (Point[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddClosedCurve( _
   ByVal points() As Point _
)
[C#]
public void AddClosedCurve(
   Point[] points
);
[C++]
public: void AddClosedCurve(
   Point* points[]
);
[JScript]
public function AddClosedCurve(
   points : Point[]
);

Parameters

points
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddClosedCurve Overload List


GraphicsPath.AddCurve

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub AddCurve(PointF(), Integer, Integer, Single)
[C#] public void AddCurve(PointF[], int, int, float);
[C++] public: void AddCurve(PointF*[], int, int, float);
[JScript] public function AddCurve(PointF[], int, int, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub AddCurve(PointF(), Single)
[C#] public void AddCurve(PointF[], float);
[C++] public: void AddCurve(PointF*[], float);
[JScript] public function AddCurve(PointF[], float);

[To be supplied.]

[Visual Basic] Overloads Public Sub AddCurve(PointF())
[C#] public void AddCurve(PointF[]);
[C++] public: void AddCurve(PointF*[]);
[JScript] public function AddCurve(PointF[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub AddCurve(Point(), Integer, Integer, Single)
[C#] public void AddCurve(Point[], int, int, float);
[C++] public: void AddCurve(Point*[], int, int, float);
[JScript] public function AddCurve(Point[], int, int, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub AddCurve(Point(), Single)
[C#] public void AddCurve(Point[], float);
[C++] public: void AddCurve(Point*[], float);
[JScript] public function AddCurve(Point[], float);

[To be supplied.]

[Visual Basic] Overloads Public Sub AddCurve(Point())
[C#] public void AddCurve(Point[]);
[C++] public: void AddCurve(Point*[]);
[JScript] public function AddCurve(Point[]);

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.AddCurve (PointF[], Int32, Int32, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddCurve( _
   ByVal points() As PointF, _
   ByVal offset As Integer, _
   ByVal numberOfSegments As Integer, _
   ByVal tension As Single _
)
[C#]
public void AddCurve(
   PointF[] points,
   int offset,
   int numberOfSegments,
   float tension
);
[C++]
public: void AddCurve(
   PointF* points[],
   int offset,
   int numberOfSegments,
   float tension
);
[JScript]
public function AddCurve(
   points : PointF[],
   offset : int,
   numberOfSegments : int,
   tension : float
);

Parameters

points
[To be supplied.]
offset
[To be supplied.]
numberOfSegments
[To be supplied.]
tension
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddCurve Overload List


GraphicsPath.AddCurve (PointF[], Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddCurve( _
   ByVal points() As PointF, _
   ByVal tension As Single _
)
[C#]
public void AddCurve(
   PointF[] points,
   float tension
);
[C++]
public: void AddCurve(
   PointF* points[],
   float tension
);
[JScript]
public function AddCurve(
   points : PointF[],
   tension : float
);

Parameters

points
[To be supplied.]
tension
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddCurve Overload List


GraphicsPath.AddCurve (PointF[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddCurve( _
   ByVal points() As PointF _
)
[C#]
public void AddCurve(
   PointF[] points
);
[C++]
public: void AddCurve(
   PointF* points[]
);
[JScript]
public function AddCurve(
   points : PointF[]
);

Parameters

points
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddCurve Overload List


GraphicsPath.AddCurve (Point[], Int32, Int32, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddCurve( _
   ByVal points() As Point, _
   ByVal offset As Integer, _
   ByVal numberOfSegments As Integer, _
   ByVal tension As Single _
)
[C#]
public void AddCurve(
   Point[] points,
   int offset,
   int numberOfSegments,
   float tension
);
[C++]
public: void AddCurve(
   Point* points[],
   int offset,
   int numberOfSegments,
   float tension
);
[JScript]
public function AddCurve(
   points : Point[],
   offset : int,
   numberOfSegments : int,
   tension : float
);

Parameters

points
[To be supplied.]
offset
[To be supplied.]
numberOfSegments
[To be supplied.]
tension
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddCurve Overload List


GraphicsPath.AddCurve (Point[], Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddCurve( _
   ByVal points() As Point, _
   ByVal tension As Single _
)
[C#]
public void AddCurve(
   Point[] points,
   float tension
);
[C++]
public: void AddCurve(
   Point* points[],
   float tension
);
[JScript]
public function AddCurve(
   points : Point[],
   tension : float
);

Parameters

points
[To be supplied.]
tension
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddCurve Overload List


GraphicsPath.AddCurve (Point[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddCurve( _
   ByVal points() As Point _
)
[C#]
public void AddCurve(
   Point[] points
);
[C++]
public: void AddCurve(
   Point* points[]
);
[JScript]
public function AddCurve(
   points : Point[]
);

Parameters

points
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddCurve Overload List


GraphicsPath.AddEllipse

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub AddEllipse(Rectangle)
[C#] public void AddEllipse(Rectangle);
[C++] public: void AddEllipse(Rectangle);
[JScript] public function AddEllipse(Rectangle);

[To be supplied.]

[Visual Basic] Overloads Public Sub AddEllipse(Integer, Integer, Integer, Integer)
[C#] public void AddEllipse(int, int, int, int);
[C++] public: void AddEllipse(int, int, int, int);
[JScript] public function AddEllipse(int, int, int, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub AddEllipse(RectangleF)
[C#] public void AddEllipse(RectangleF);
[C++] public: void AddEllipse(RectangleF);
[JScript] public function AddEllipse(RectangleF);

[To be supplied.]

[Visual Basic] Overloads Public Sub AddEllipse(Single, Single, Single, Single)
[C#] public void AddEllipse(float, float, float, float);
[C++] public: void AddEllipse(float, float, float, float);
[JScript] public function AddEllipse(float, float, float, float);

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.AddEllipse (Rectangle)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddEllipse( _
   ByVal rect As Rectangle _
)
[C#]
public void AddEllipse(
   Rectangle rect
);
[C++]
public: void AddEllipse(
   Rectangle rect
);
[JScript]
public function AddEllipse(
   rect : Rectangle
);

Parameters

rect
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddEllipse Overload List


GraphicsPath.AddEllipse (Int32, Int32, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddEllipse( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer _
)
[C#]
public void AddEllipse(
   int x,
   int y,
   int width,
   int height
);
[C++]
public: void AddEllipse(
   int x,
   int y,
   int width,
   int height
);
[JScript]
public function AddEllipse(
   x : int,
   y : int,
   width : int,
   height : int
);

Parameters

x
[To be supplied.]
y
[To be supplied.]
width
[To be supplied.]
height
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddEllipse Overload List


GraphicsPath.AddEllipse (RectangleF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddEllipse( _
   ByVal rect As RectangleF _
)
[C#]
public void AddEllipse(
   RectangleF rect
);
[C++]
public: void AddEllipse(
   RectangleF rect
);
[JScript]
public function AddEllipse(
   rect : RectangleF
);

Parameters

rect
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddEllipse Overload List


GraphicsPath.AddEllipse (Single, Single, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddEllipse( _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
[C#]
public void AddEllipse(
   float x,
   float y,
   float width,
   float height
);
[C++]
public: void AddEllipse(
   float x,
   float y,
   float width,
   float height
);
[JScript]
public function AddEllipse(
   x : float,
   y : float,
   width : float,
   height : float
);

Parameters

x
[To be supplied.]
y
[To be supplied.]
width
[To be supplied.]
height
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddEllipse Overload List


GraphicsPath.AddLine

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub AddLine(Integer, Integer, Integer, Integer)
[C#] public void AddLine(int, int, int, int);
[C++] public: void AddLine(int, int, int, int);
[JScript] public function AddLine(int, int, int, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub AddLine(Point, Point)
[C#] public void AddLine(Point, Point);
[C++] public: void AddLine(Point, Point);
[JScript] public function AddLine(Point, Point);

[To be supplied.]

[Visual Basic] Overloads Public Sub AddLine(Single, Single, Single, Single)
[C#] public void AddLine(float, float, float, float);
[C++] public: void AddLine(float, float, float, float);
[JScript] public function AddLine(float, float, float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub AddLine(PointF, PointF)
[C#] public void AddLine(PointF, PointF);
[C++] public: void AddLine(PointF, PointF);
[JScript] public function AddLine(PointF, PointF);

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.AddLine (Int32, Int32, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddLine( _
   ByVal x1 As Integer, _
   ByVal y1 As Integer, _
   ByVal x2 As Integer, _
   ByVal y2 As Integer _
)
[C#]
public void AddLine(
   int x1,
   int y1,
   int x2,
   int y2
);
[C++]
public: void AddLine(
   int x1,
   int y1,
   int x2,
   int y2
);
[JScript]
public function AddLine(
   x1 : int,
   y1 : int,
   x2 : int,
   y2 : int
);

Parameters

x1
[To be supplied.]
y1
[To be supplied.]
x2
[To be supplied.]
y2
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddLine Overload List


GraphicsPath.AddLine (Point, Point)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddLine( _
   ByVal pt1 As Point, _
   ByVal pt2 As Point _
)
[C#]
public void AddLine(
   Point pt1,
   Point pt2
);
[C++]
public: void AddLine(
   Point pt1,
   Point pt2
);
[JScript]
public function AddLine(
   pt1 : Point,
   pt2 : Point
);

Parameters

pt1
[To be supplied.]
pt2
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddLine Overload List


GraphicsPath.AddLine (Single, Single, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddLine( _
   ByVal x1 As Single, _
   ByVal y1 As Single, _
   ByVal x2 As Single, _
   ByVal y2 As Single _
)
[C#]
public void AddLine(
   float x1,
   float y1,
   float x2,
   float y2
);
[C++]
public: void AddLine(
   float x1,
   float y1,
   float x2,
   float y2
);
[JScript]
public function AddLine(
   x1 : float,
   y1 : float,
   x2 : float,
   y2 : float
);

Parameters

x1
[To be supplied.]
y1
[To be supplied.]
x2
[To be supplied.]
y2
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddLine Overload List


GraphicsPath.AddLine (PointF, PointF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddLine( _
   ByVal pt1 As PointF, _
   ByVal pt2 As PointF _
)
[C#]
public void AddLine(
   PointF pt1,
   PointF pt2
);
[C++]
public: void AddLine(
   PointF pt1,
   PointF pt2
);
[JScript]
public function AddLine(
   pt1 : PointF,
   pt2 : PointF
);

Parameters

pt1
[To be supplied.]
pt2
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddLine Overload List


GraphicsPath.AddLines

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub AddLines(PointF())
[C#] public void AddLines(PointF[]);
[C++] public: void AddLines(PointF*[]);
[JScript] public function AddLines(PointF[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub AddLines(Point())
[C#] public void AddLines(Point[]);
[C++] public: void AddLines(Point*[]);
[JScript] public function AddLines(Point[]);

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.AddLines (PointF[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddLines( _
   ByVal points() As PointF _
)
[C#]
public void AddLines(
   PointF[] points
);
[C++]
public: void AddLines(
   PointF* points[]
);
[JScript]
public function AddLines(
   points : PointF[]
);

Parameters

points
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddLines Overload List


GraphicsPath.AddLines (Point[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddLines( _
   ByVal points() As Point _
)
[C#]
public void AddLines(
   Point[] points
);
[C++]
public: void AddLines(
   Point* points[]
);
[JScript]
public function AddLines(
   points : Point[]
);

Parameters

points
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddLines Overload List


GraphicsPath.AddPath

[To be supplied.]

[Visual Basic]
Public Sub AddPath( _
   ByVal addingPath As GraphicsPath, _
   ByVal connect As Boolean _
)
[C#]
public void AddPath(
   GraphicsPath addingPath,
   bool connect
);
[C++]
public: void AddPath(
   GraphicsPath* addingPath,
   bool connect
);
[JScript]
public function AddPath(
   addingPath : GraphicsPath,
   connect : Boolean
);

Parameters

addingPath
[To be supplied.]
connect
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.AddPie

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub AddPie(Integer, Integer, Integer, Integer, Single, Single)
[C#] public void AddPie(int, int, int, int, float, float);
[C++] public: void AddPie(int, int, int, int, float, float);
[JScript] public function AddPie(int, int, int, int, float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub AddPie(Rectangle, Single, Single)
[C#] public void AddPie(Rectangle, float, float);
[C++] public: void AddPie(Rectangle, float, float);
[JScript] public function AddPie(Rectangle, float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub AddPie(Single, Single, Single, Single, Single, Single)
[C#] public void AddPie(float, float, float, float, float, float);
[C++] public: void AddPie(float, float, float, float, float, float);
[JScript] public function AddPie(float, float, float, float, float, float);

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.AddPie (Int32, Int32, Int32, Int32, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddPie( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
[C#]
public void AddPie(
   int x,
   int y,
   int width,
   int height,
   float startAngle,
   float sweepAngle
);
[C++]
public: void AddPie(
   int x,
   int y,
   int width,
   int height,
   float startAngle,
   float sweepAngle
);
[JScript]
public function AddPie(
   x : int,
   y : int,
   width : int,
   height : int,
   startAngle : float,
   sweepAngle : float
);

Parameters

x
[To be supplied.]
y
[To be supplied.]
width
[To be supplied.]
height
[To be supplied.]
startAngle
[To be supplied.]
sweepAngle
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddPie Overload List


GraphicsPath.AddPie (Rectangle, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddPie( _
   ByVal rect As Rectangle, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
[C#]
public void AddPie(
   Rectangle rect,
   float startAngle,
   float sweepAngle
);
[C++]
public: void AddPie(
   Rectangle rect,
   float startAngle,
   float sweepAngle
);
[JScript]
public function AddPie(
   rect : Rectangle,
   startAngle : float,
   sweepAngle : float
);

Parameters

rect
[To be supplied.]
startAngle
[To be supplied.]
sweepAngle
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddPie Overload List


GraphicsPath.AddPie (Single, Single, Single, Single, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddPie( _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
[C#]
public void AddPie(
   float x,
   float y,
   float width,
   float height,
   float startAngle,
   float sweepAngle
);
[C++]
public: void AddPie(
   float x,
   float y,
   float width,
   float height,
   float startAngle,
   float sweepAngle
);
[JScript]
public function AddPie(
   x : float,
   y : float,
   width : float,
   height : float,
   startAngle : float,
   sweepAngle : float
);

Parameters

x
[To be supplied.]
y
[To be supplied.]
width
[To be supplied.]
height
[To be supplied.]
startAngle
[To be supplied.]
sweepAngle
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddPie Overload List


GraphicsPath.AddPolygon

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub AddPolygon(Point())
[C#] public void AddPolygon(Point[]);
[C++] public: void AddPolygon(Point*[]);
[JScript] public function AddPolygon(Point[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub AddPolygon(PointF())
[C#] public void AddPolygon(PointF[]);
[C++] public: void AddPolygon(PointF*[]);
[JScript] public function AddPolygon(PointF[]);

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.AddPolygon (Point[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddPolygon( _
   ByVal points() As Point _
)
[C#]
public void AddPolygon(
   Point[] points
);
[C++]
public: void AddPolygon(
   Point* points[]
);
[JScript]
public function AddPolygon(
   points : Point[]
);

Parameters

points
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddPolygon Overload List


GraphicsPath.AddPolygon (PointF[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddPolygon( _
   ByVal points() As PointF _
)
[C#]
public void AddPolygon(
   PointF[] points
);
[C++]
public: void AddPolygon(
   PointF* points[]
);
[JScript]
public function AddPolygon(
   points : PointF[]
);

Parameters

points
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddPolygon Overload List


GraphicsPath.AddRectangle

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub AddRectangle(Rectangle)
[C#] public void AddRectangle(Rectangle);
[C++] public: void AddRectangle(Rectangle);
[JScript] public function AddRectangle(Rectangle);

[To be supplied.]

[Visual Basic] Overloads Public Sub AddRectangle(RectangleF)
[C#] public void AddRectangle(RectangleF);
[C++] public: void AddRectangle(RectangleF);
[JScript] public function AddRectangle(RectangleF);

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.AddRectangle (Rectangle)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddRectangle( _
   ByVal rect As Rectangle _
)
[C#]
public void AddRectangle(
   Rectangle rect
);
[C++]
public: void AddRectangle(
   Rectangle rect
);
[JScript]
public function AddRectangle(
   rect : Rectangle
);

Parameters

rect
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddRectangle Overload List


GraphicsPath.AddRectangle (RectangleF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddRectangle( _
   ByVal rect As RectangleF _
)
[C#]
public void AddRectangle(
   RectangleF rect
);
[C++]
public: void AddRectangle(
   RectangleF rect
);
[JScript]
public function AddRectangle(
   rect : RectangleF
);

Parameters

rect
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddRectangle Overload List


GraphicsPath.AddRectangles

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub AddRectangles(Rectangle())
[C#] public void AddRectangles(Rectangle[]);
[C++] public: void AddRectangles(Rectangle*[]);
[JScript] public function AddRectangles(Rectangle[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub AddRectangles(RectangleF())
[C#] public void AddRectangles(RectangleF[]);
[C++] public: void AddRectangles(RectangleF*[]);
[JScript] public function AddRectangles(RectangleF[]);

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.AddRectangles (Rectangle[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddRectangles( _
   ByVal rects() As Rectangle _
)
[C#]
public void AddRectangles(
   Rectangle[] rects
);
[C++]
public: void AddRectangles(
   Rectangle* rects[]
);
[JScript]
public function AddRectangles(
   rects : Rectangle[]
);

Parameters

rects
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddRectangles Overload List


GraphicsPath.AddRectangles (RectangleF[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddRectangles( _
   ByVal rects() As RectangleF _
)
[C#]
public void AddRectangles(
   RectangleF[] rects
);
[C++]
public: void AddRectangles(
   RectangleF* rects[]
);
[JScript]
public function AddRectangles(
   rects : RectangleF[]
);

Parameters

rects
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddRectangles Overload List


GraphicsPath.AddString

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub AddString(String, FontFamily, Integer, Single, Point, StringFormat)
[C#] public void AddString(String, FontFamily, int, float, Point, StringFormat);
[C++] public: void AddString(String*, FontFamily, int, float, Point, StringFormat);
[JScript] public function AddString(String, FontFamily, int, float, Point, StringFormat);

[To be supplied.]

[Visual Basic] Overloads Public Sub AddString(String, FontFamily, Integer, Single, PointF, StringFormat)
[C#] public void AddString(String, FontFamily, int, float, PointF, StringFormat);
[C++] public: void AddString(String*, FontFamily, int, float, PointF, StringFormat);
[JScript] public function AddString(String, FontFamily, int, float, PointF, StringFormat);

[To be supplied.]

[Visual Basic] Overloads Public Sub AddString(String, FontFamily, Integer, Single, RectangleF, StringFormat)
[C#] public void AddString(String, FontFamily, int, float, RectangleF, StringFormat);
[C++] public: void AddString(String*, FontFamily, int, float, RectangleF, StringFormat);
[JScript] public function AddString(String, FontFamily, int, float, RectangleF, StringFormat);

[To be supplied.]

[Visual Basic] Overloads Public Sub AddString(String, FontFamily, Integer, Single, Rectangle, StringFormat)
[C#] public void AddString(String, FontFamily, int, float, Rectangle, StringFormat);
[C++] public: void AddString(String*, FontFamily, int, float, Rectangle, StringFormat);
[JScript] public function AddString(String, FontFamily, int, float, Rectangle, StringFormat);

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.AddString (String, FontFamily, Int32, Single, Point, StringFormat)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddString( _
   ByVal s As String, _
   ByVal family As FontFamily, _
   ByVal style As Integer, _
   ByVal emSize As Single, _
   ByVal origin As Point, _
   ByVal format As StringFormat _
)
[C#]
public void AddString(
   string s,
   FontFamily family,
   int style,
   float emSize,
   Point origin,
   StringFormat format
);
[C++]
public: void AddString(
   String* s,
   FontFamily* family,
   int style,
   float emSize,
   Point origin,
   StringFormat* format
);
[JScript]
public function AddString(
   s : String,
   family : FontFamily,
   style : int,
   emSize : float,
   origin : Point,
   format : StringFormat
);

Parameters

s
[To be supplied.]
family
[To be supplied.]
style
[To be supplied.]
emSize
[To be supplied.]
origin
[To be supplied.]
format
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddString Overload List


GraphicsPath.AddString (String, FontFamily, Int32, Single, PointF, StringFormat)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddString( _
   ByVal s As String, _
   ByVal family As FontFamily, _
   ByVal style As Integer, _
   ByVal emSize As Single, _
   ByVal origin As PointF, _
   ByVal format As StringFormat _
)
[C#]
public void AddString(
   string s,
   FontFamily family,
   int style,
   float emSize,
   PointF origin,
   StringFormat format
);
[C++]
public: void AddString(
   String* s,
   FontFamily* family,
   int style,
   float emSize,
   PointF origin,
   StringFormat* format
);
[JScript]
public function AddString(
   s : String,
   family : FontFamily,
   style : int,
   emSize : float,
   origin : PointF,
   format : StringFormat
);

Parameters

s
[To be supplied.]
family
[To be supplied.]
style
[To be supplied.]
emSize
[To be supplied.]
origin
[To be supplied.]
format
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddString Overload List


GraphicsPath.AddString (String, FontFamily, Int32, Single, RectangleF, StringFormat)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddString( _
   ByVal s As String, _
   ByVal family As FontFamily, _
   ByVal style As Integer, _
   ByVal emSize As Single, _
   ByVal layoutRect As RectangleF, _
   ByVal format As StringFormat _
)
[C#]
public void AddString(
   string s,
   FontFamily family,
   int style,
   float emSize,
   RectangleF layoutRect,
   StringFormat format
);
[C++]
public: void AddString(
   String* s,
   FontFamily* family,
   int style,
   float emSize,
   RectangleF layoutRect,
   StringFormat* format
);
[JScript]
public function AddString(
   s : String,
   family : FontFamily,
   style : int,
   emSize : float,
   layoutRect : RectangleF,
   format : StringFormat
);

Parameters

s
[To be supplied.]
family
[To be supplied.]
style
[To be supplied.]
emSize
[To be supplied.]
layoutRect
[To be supplied.]
format
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddString Overload List


GraphicsPath.AddString (String, FontFamily, Int32, Single, Rectangle, StringFormat)

[To be supplied.]

[Visual Basic]
Overloads Public Sub AddString( _
   ByVal s As String, _
   ByVal family As FontFamily, _
   ByVal style As Integer, _
   ByVal emSize As Single, _
   ByVal layoutRect As Rectangle, _
   ByVal format As StringFormat _
)
[C#]
public void AddString(
   string s,
   FontFamily family,
   int style,
   float emSize,
   Rectangle layoutRect,
   StringFormat format
);
[C++]
public: void AddString(
   String* s,
   FontFamily* family,
   int style,
   float emSize,
   Rectangle layoutRect,
   StringFormat* format
);
[JScript]
public function AddString(
   s : String,
   family : FontFamily,
   style : int,
   emSize : float,
   layoutRect : Rectangle,
   format : StringFormat
);

Parameters

s
[To be supplied.]
family
[To be supplied.]
style
[To be supplied.]
emSize
[To be supplied.]
layoutRect
[To be supplied.]
format
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.AddString Overload List


GraphicsPath.ClearMarkers

[To be supplied.]

[Visual Basic]
Public Sub ClearMarkers()
[C#]
public void ClearMarkers();
[C++]
public: void ClearMarkers();
[JScript]
public function ClearMarkers();

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.Clone

[To be supplied.]

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.CloseAllFigures

[To be supplied.]

[Visual Basic]
Public Sub CloseAllFigures()
[C#]
public void CloseAllFigures();
[C++]
public: void CloseAllFigures();
[JScript]
public function CloseAllFigures();

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.CloseFigure

[To be supplied.]

[Visual Basic]
Public Sub CloseFigure()
[C#]
public void CloseFigure();
[C++]
public: void CloseFigure();
[JScript]
public function CloseFigure();

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.Dispose

[To be supplied.]

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[JScript]
public function Dispose();

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.Finalize

[To be supplied.]

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.Flatten

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub Flatten()
[C#] public void Flatten();
[C++] public: void Flatten();
[JScript] public function Flatten();

[To be supplied.]

[Visual Basic] Overloads Public Sub Flatten(Matrix)
[C#] public void Flatten(Matrix);
[C++] public: void Flatten(Matrix*);
[JScript] public function Flatten(Matrix);

[To be supplied.]

[Visual Basic] Overloads Public Sub Flatten(Matrix, Single)
[C#] public void Flatten(Matrix, float);
[C++] public: void Flatten(Matrix*, float);
[JScript] public function Flatten(Matrix, float);

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.Flatten ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub Flatten()
[C#]
public void Flatten();
[C++]
public: void Flatten();
[JScript]
public function Flatten();

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.Flatten Overload List


GraphicsPath.Flatten (Matrix)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Flatten( _
   ByVal matrix As Matrix _
)
[C#]
public void Flatten(
   Matrix matrix
);
[C++]
public: void Flatten(
   Matrix* matrix
);
[JScript]
public function Flatten(
   matrix : Matrix
);

Parameters

matrix
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.Flatten Overload List


GraphicsPath.Flatten (Matrix, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Flatten( _
   ByVal matrix As Matrix, _
   ByVal flatness As Single _
)
[C#]
public void Flatten(
   Matrix matrix,
   float flatness
);
[C++]
public: void Flatten(
   Matrix* matrix,
   float flatness
);
[JScript]
public function Flatten(
   matrix : Matrix,
   flatness : float
);

Parameters

matrix
[To be supplied.]
flatness
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.Flatten Overload List


GraphicsPath.GetBounds

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function GetBounds(Matrix) As RectangleF
[C#] public RectangleF GetBounds(Matrix);
[C++] public: RectangleF GetBounds(Matrix*);
[JScript] public function GetBounds(Matrix) : RectangleF;

[To be supplied.]

[Visual Basic] Overloads Public Function GetBounds() As RectangleF
[C#] public RectangleF GetBounds();
[C++] public: RectangleF GetBounds();
[JScript] public function GetBounds() : RectangleF;

[To be supplied.]

[Visual Basic] Overloads Public Function GetBounds(Matrix, Pen) As RectangleF
[C#] public RectangleF GetBounds(Matrix, Pen);
[C++] public: RectangleF GetBounds(Matrix*, Pen);
[JScript] public function GetBounds(Matrix, Pen) : RectangleF;

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.GetBounds (Matrix)

[To be supplied.]

[Visual Basic]
Overloads Public Function GetBounds( _
   ByVal matrix As Matrix _
) As RectangleF
[C#]
public RectangleF GetBounds(
   Matrix matrix
);
[C++]
public: RectangleF GetBounds(
   Matrix* matrix
);
[JScript]
public function GetBounds(
   matrix : Matrix
) : RectangleF;

Parameters

matrix
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.GetBounds Overload List


GraphicsPath.GetBounds ()

[To be supplied.]

[Visual Basic]
Overloads Public Function GetBounds() As RectangleF
[C#]
public RectangleF GetBounds();
[C++]
public: RectangleF GetBounds();
[JScript]
public function GetBounds() : RectangleF;

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.GetBounds Overload List


GraphicsPath.GetBounds (Matrix, Pen)

[To be supplied.]

[Visual Basic]
Overloads Public Function GetBounds( _
   ByVal matrix As Matrix, _
   ByVal pen As Pen _
) As RectangleF
[C#]
public RectangleF GetBounds(
   Matrix matrix,
   Pen pen
);
[C++]
public: RectangleF GetBounds(
   Matrix* matrix,
   Pen* pen
);
[JScript]
public function GetBounds(
   matrix : Matrix,
   pen : Pen
) : RectangleF;

Parameters

matrix
[To be supplied.]
pen
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.GetBounds Overload List


GraphicsPath.GetLastPoint

[To be supplied.]

[Visual Basic]
Public Function GetLastPoint() As PointF
[C#]
public PointF GetLastPoint();
[C++]
public: PointF GetLastPoint();
[JScript]
public function GetLastPoint() : PointF;

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.IsOutlineVisible

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function IsOutlineVisible(Point, Pen, Graphics) As Boolean
[C#] public bool IsOutlineVisible(Point, Pen, Graphics);
[C++] public: bool IsOutlineVisible(Point, Pen, Graphics);
[JScript] public function IsOutlineVisible(Point, Pen, Graphics) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsOutlineVisible(Integer, Integer, Pen, Graphics) As Boolean
[C#] public bool IsOutlineVisible(int, int, Pen, Graphics);
[C++] public: bool IsOutlineVisible(int, int, Pen, Graphics);
[JScript] public function IsOutlineVisible(int, int, Pen, Graphics) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsOutlineVisible(PointF, Pen, Graphics) As Boolean
[C#] public bool IsOutlineVisible(PointF, Pen, Graphics);
[C++] public: bool IsOutlineVisible(PointF, Pen, Graphics);
[JScript] public function IsOutlineVisible(PointF, Pen, Graphics) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsOutlineVisible(Integer, Integer, Pen) As Boolean
[C#] public bool IsOutlineVisible(int, int, Pen);
[C++] public: bool IsOutlineVisible(int, int, Pen);
[JScript] public function IsOutlineVisible(int, int, Pen) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsOutlineVisible(Point, Pen) As Boolean
[C#] public bool IsOutlineVisible(Point, Pen);
[C++] public: bool IsOutlineVisible(Point, Pen);
[JScript] public function IsOutlineVisible(Point, Pen) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsOutlineVisible(Single, Single, Pen) As Boolean
[C#] public bool IsOutlineVisible(float, float, Pen);
[C++] public: bool IsOutlineVisible(float, float, Pen);
[JScript] public function IsOutlineVisible(float, float, Pen) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsOutlineVisible(PointF, Pen) As Boolean
[C#] public bool IsOutlineVisible(PointF, Pen);
[C++] public: bool IsOutlineVisible(PointF, Pen);
[JScript] public function IsOutlineVisible(PointF, Pen) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsOutlineVisible(Single, Single, Pen, Graphics) As Boolean
[C#] public bool IsOutlineVisible(float, float, Pen, Graphics);
[C++] public: bool IsOutlineVisible(float, float, Pen, Graphics);
[JScript] public function IsOutlineVisible(float, float, Pen, Graphics) : Boolean;

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.IsOutlineVisible (Point, Pen, Graphics)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsOutlineVisible( _
   ByVal pt As Point, _
   ByVal pen As Pen, _
   ByVal graphics As Graphics _
) As Boolean
[C#]
public bool IsOutlineVisible(
   Point pt,
   Pen pen,
   Graphics graphics
);
[C++]
public: bool IsOutlineVisible(
   Point pt,
   Pen* pen,
   Graphics* graphics
);
[JScript]
public function IsOutlineVisible(
   pt : Point,
   pen : Pen,
   graphics : Graphics
) : Boolean;

Parameters

pt
[To be supplied.]
pen
[To be supplied.]
graphics
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.IsOutlineVisible Overload List


GraphicsPath.IsOutlineVisible (Int32, Int32, Pen, Graphics)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsOutlineVisible( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal pen As Pen, _
   ByVal graphics As Graphics _
) As Boolean
[C#]
public bool IsOutlineVisible(
   int x,
   int y,
   Pen pen,
   Graphics graphics
);
[C++]
public: bool IsOutlineVisible(
   int x,
   int y,
   Pen* pen,
   Graphics* graphics
);
[JScript]
public function IsOutlineVisible(
   x : int,
   y : int,
   pen : Pen,
   graphics : Graphics
) : Boolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]
pen
[To be supplied.]
graphics
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.IsOutlineVisible Overload List


GraphicsPath.IsOutlineVisible (PointF, Pen, Graphics)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsOutlineVisible( _
   ByVal pt As PointF, _
   ByVal pen As Pen, _
   ByVal graphics As Graphics _
) As Boolean
[C#]
public bool IsOutlineVisible(
   PointF pt,
   Pen pen,
   Graphics graphics
);
[C++]
public: bool IsOutlineVisible(
   PointF pt,
   Pen* pen,
   Graphics* graphics
);
[JScript]
public function IsOutlineVisible(
   pt : PointF,
   pen : Pen,
   graphics : Graphics
) : Boolean;

Parameters

pt
[To be supplied.]
pen
[To be supplied.]
graphics
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.IsOutlineVisible Overload List


GraphicsPath.IsOutlineVisible (Int32, Int32, Pen)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsOutlineVisible( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal pen As Pen _
) As Boolean
[C#]
public bool IsOutlineVisible(
   int x,
   int y,
   Pen pen
);
[C++]
public: bool IsOutlineVisible(
   int x,
   int y,
   Pen* pen
);
[JScript]
public function IsOutlineVisible(
   x : int,
   y : int,
   pen : Pen
) : Boolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]
pen
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.IsOutlineVisible Overload List


GraphicsPath.IsOutlineVisible (Point, Pen)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsOutlineVisible( _
   ByVal point As Point, _
   ByVal pen As Pen _
) As Boolean
[C#]
public bool IsOutlineVisible(
   Point point,
   Pen pen
);
[C++]
public: bool IsOutlineVisible(
   Point point,
   Pen* pen
);
[JScript]
public function IsOutlineVisible(
   point : Point,
   pen : Pen
) : Boolean;

Parameters

point
[To be supplied.]
pen
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.IsOutlineVisible Overload List


GraphicsPath.IsOutlineVisible (Single, Single, Pen)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsOutlineVisible( _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal pen As Pen _
) As Boolean
[C#]
public bool IsOutlineVisible(
   float x,
   float y,
   Pen pen
);
[C++]
public: bool IsOutlineVisible(
   float x,
   float y,
   Pen* pen
);
[JScript]
public function IsOutlineVisible(
   x : float,
   y : float,
   pen : Pen
) : Boolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]
pen
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.IsOutlineVisible Overload List


GraphicsPath.IsOutlineVisible (PointF, Pen)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsOutlineVisible( _
   ByVal point As PointF, _
   ByVal pen As Pen _
) As Boolean
[C#]
public bool IsOutlineVisible(
   PointF point,
   Pen pen
);
[C++]
public: bool IsOutlineVisible(
   PointF point,
   Pen* pen
);
[JScript]
public function IsOutlineVisible(
   point : PointF,
   pen : Pen
) : Boolean;

Parameters

point
[To be supplied.]
pen
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.IsOutlineVisible Overload List


GraphicsPath.IsOutlineVisible (Single, Single, Pen, Graphics)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsOutlineVisible( _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal pen As Pen, _
   ByVal graphics As Graphics _
) As Boolean
[C#]
public bool IsOutlineVisible(
   float x,
   float y,
   Pen pen,
   Graphics graphics
);
[C++]
public: bool IsOutlineVisible(
   float x,
   float y,
   Pen* pen,
   Graphics* graphics
);
[JScript]
public function IsOutlineVisible(
   x : float,
   y : float,
   pen : Pen,
   graphics : Graphics
) : Boolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]
pen
[To be supplied.]
graphics
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.IsOutlineVisible Overload List


GraphicsPath.IsVisible

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(Integer, Integer, Graphics) As Boolean
[C#] public bool IsVisible(int, int, Graphics);
[C++] public: bool IsVisible(int, int, Graphics);
[JScript] public function IsVisible(int, int, Graphics) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(Point) As Boolean
[C#] public bool IsVisible(Point);
[C++] public: bool IsVisible(Point);
[JScript] public function IsVisible(Point) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(PointF) As Boolean
[C#] public bool IsVisible(PointF);
[C++] public: bool IsVisible(PointF);
[JScript] public function IsVisible(PointF) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(Point, Graphics) As Boolean
[C#] public bool IsVisible(Point, Graphics);
[C++] public: bool IsVisible(Point, Graphics);
[JScript] public function IsVisible(Point, Graphics) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(PointF, Graphics) As Boolean
[C#] public bool IsVisible(PointF, Graphics);
[C++] public: bool IsVisible(PointF, Graphics);
[JScript] public function IsVisible(PointF, Graphics) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(Single, Single, Graphics) As Boolean
[C#] public bool IsVisible(float, float, Graphics);
[C++] public: bool IsVisible(float, float, Graphics);
[JScript] public function IsVisible(float, float, Graphics) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(Single, Single) As Boolean
[C#] public bool IsVisible(float, float);
[C++] public: bool IsVisible(float, float);
[JScript] public function IsVisible(float, float) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Public Function IsVisible(Integer, Integer) As Boolean
[C#] public bool IsVisible(int, int);
[C++] public: bool IsVisible(int, int);
[JScript] public function IsVisible(int, int) : Boolean;

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.IsVisible (Int32, Int32, Graphics)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal graphics As Graphics _
) As Boolean
[C#]
public bool IsVisible(
   int x,
   int y,
   Graphics graphics
);
[C++]
public: bool IsVisible(
   int x,
   int y,
   Graphics* graphics
);
[JScript]
public function IsVisible(
   x : int,
   y : int,
   graphics : Graphics
) : Boolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]
graphics
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.IsVisible Overload List


GraphicsPath.IsVisible (Point)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal point As Point _
) As Boolean
[C#]
public bool IsVisible(
   Point point
);
[C++]
public: bool IsVisible(
   Point point
);
[JScript]
public function IsVisible(
   point : Point
) : Boolean;

Parameters

point
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.IsVisible Overload List


GraphicsPath.IsVisible (PointF)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal point As PointF _
) As Boolean
[C#]
public bool IsVisible(
   PointF point
);
[C++]
public: bool IsVisible(
   PointF point
);
[JScript]
public function IsVisible(
   point : PointF
) : Boolean;

Parameters

point
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.IsVisible Overload List


GraphicsPath.IsVisible (Point, Graphics)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal pt As Point, _
   ByVal graphics As Graphics _
) As Boolean
[C#]
public bool IsVisible(
   Point pt,
   Graphics graphics
);
[C++]
public: bool IsVisible(
   Point pt,
   Graphics* graphics
);
[JScript]
public function IsVisible(
   pt : Point,
   graphics : Graphics
) : Boolean;

Parameters

pt
[To be supplied.]
graphics
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.IsVisible Overload List


GraphicsPath.IsVisible (PointF, Graphics)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal pt As PointF, _
   ByVal graphics As Graphics _
) As Boolean
[C#]
public bool IsVisible(
   PointF pt,
   Graphics graphics
);
[C++]
public: bool IsVisible(
   PointF pt,
   Graphics* graphics
);
[JScript]
public function IsVisible(
   pt : PointF,
   graphics : Graphics
) : Boolean;

Parameters

pt
[To be supplied.]
graphics
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.IsVisible Overload List


GraphicsPath.IsVisible (Single, Single, Graphics)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal graphics As Graphics _
) As Boolean
[C#]
public bool IsVisible(
   float x,
   float y,
   Graphics graphics
);
[C++]
public: bool IsVisible(
   float x,
   float y,
   Graphics* graphics
);
[JScript]
public function IsVisible(
   x : float,
   y : float,
   graphics : Graphics
) : Boolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]
graphics
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.IsVisible Overload List


GraphicsPath.IsVisible (Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal x As Single, _
   ByVal y As Single _
) As Boolean
[C#]
public bool IsVisible(
   float x,
   float y
);
[C++]
public: bool IsVisible(
   float x,
   float y
);
[JScript]
public function IsVisible(
   x : float,
   y : float
) : Boolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.IsVisible Overload List


GraphicsPath.IsVisible (Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Function IsVisible( _
   ByVal x As Integer, _
   ByVal y As Integer _
) As Boolean
[C#]
public bool IsVisible(
   int x,
   int y
);
[C++]
public: bool IsVisible(
   int x,
   int y
);
[JScript]
public function IsVisible(
   x : int,
   y : int
) : Boolean;

Parameters

x
[To be supplied.]
y
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.IsVisible Overload List


GraphicsPath.Reset

[To be supplied.]

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();
[C++]
public: void Reset();
[JScript]
public function Reset();

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.Reverse

[To be supplied.]

[Visual Basic]
Public Sub Reverse()
[C#]
public void Reverse();
[C++]
public: void Reverse();
[JScript]
public function Reverse();

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.SetMarkers

[To be supplied.]

[Visual Basic]
Public Sub SetMarkers()
[C#]
public void SetMarkers();
[C++]
public: void SetMarkers();
[JScript]
public function SetMarkers();

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.StartFigure

[To be supplied.]

[Visual Basic]
Public Sub StartFigure()
[C#]
public void StartFigure();
[C++]
public: void StartFigure();
[JScript]
public function StartFigure();

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.Transform

[To be supplied.]

[Visual Basic]
Public Sub Transform( _
   ByVal matrix As Matrix _
)
[C#]
public void Transform(
   Matrix matrix
);
[C++]
public: void Transform(
   Matrix* matrix
);
[JScript]
public function Transform(
   matrix : Matrix
);

Parameters

matrix
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.Warp

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub Warp(PointF(), RectangleF, Matrix, WarpMode)
[C#] public void Warp(PointF[], RectangleF, Matrix, WarpMode);
[C++] public: void Warp(PointF*[], RectangleF, Matrix, WarpMode);
[JScript] public function Warp(PointF[], RectangleF, Matrix, WarpMode);

[To be supplied.]

[Visual Basic] Overloads Public Sub Warp(PointF(), RectangleF, Matrix, WarpMode, Single)
[C#] public void Warp(PointF[], RectangleF, Matrix, WarpMode, float);
[C++] public: void Warp(PointF*[], RectangleF, Matrix, WarpMode, float);
[JScript] public function Warp(PointF[], RectangleF, Matrix, WarpMode, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub Warp(PointF(), RectangleF)
[C#] public void Warp(PointF[], RectangleF);
[C++] public: void Warp(PointF*[], RectangleF);
[JScript] public function Warp(PointF[], RectangleF);

[To be supplied.]

[Visual Basic] Overloads Public Sub Warp(PointF(), RectangleF, Matrix)
[C#] public void Warp(PointF[], RectangleF, Matrix);
[C++] public: void Warp(PointF*[], RectangleF, Matrix);
[JScript] public function Warp(PointF[], RectangleF, Matrix);

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.Warp (PointF[], RectangleF, Matrix, WarpMode)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Warp( _
   ByVal destPoints() As PointF, _
   ByVal srcRect As RectangleF, _
   ByVal matrix As Matrix, _
   ByVal warpMode As WarpMode _
)
[C#]
public void Warp(
   PointF[] destPoints,
   RectangleF srcRect,
   Matrix matrix,
   WarpMode warpMode
);
[C++]
public: void Warp(
   PointF* destPoints[],
   RectangleF srcRect,
   Matrix* matrix,
   WarpMode warpMode
);
[JScript]
public function Warp(
   destPoints : PointF[],
   srcRect : RectangleF,
   matrix : Matrix,
   warpMode : WarpMode
);

Parameters

destPoints
[To be supplied.]
srcRect
[To be supplied.]
matrix
[To be supplied.]
warpMode
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.Warp Overload List


GraphicsPath.Warp (PointF[], RectangleF, Matrix, WarpMode, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Warp( _
   ByVal destPoints() As PointF, _
   ByVal srcRect As RectangleF, _
   ByVal matrix As Matrix, _
   ByVal warpMode As WarpMode, _
   ByVal flatness As Single _
)
[C#]
public void Warp(
   PointF[] destPoints,
   RectangleF srcRect,
   Matrix matrix,
   WarpMode warpMode,
   float flatness
);
[C++]
public: void Warp(
   PointF* destPoints[],
   RectangleF srcRect,
   Matrix* matrix,
   WarpMode warpMode,
   float flatness
);
[JScript]
public function Warp(
   destPoints : PointF[],
   srcRect : RectangleF,
   matrix : Matrix,
   warpMode : WarpMode,
   flatness : float
);

Parameters

destPoints
[To be supplied.]
srcRect
[To be supplied.]
matrix
[To be supplied.]
warpMode
[To be supplied.]
flatness
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.Warp Overload List


GraphicsPath.Warp (PointF[], RectangleF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Warp( _
   ByVal destPoints() As PointF, _
   ByVal srcRect As RectangleF _
)
[C#]
public void Warp(
   PointF[] destPoints,
   RectangleF srcRect
);
[C++]
public: void Warp(
   PointF* destPoints[],
   RectangleF srcRect
);
[JScript]
public function Warp(
   destPoints : PointF[],
   srcRect : RectangleF
);

Parameters

destPoints
[To be supplied.]
srcRect
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.Warp Overload List


GraphicsPath.Warp (PointF[], RectangleF, Matrix)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Warp( _
   ByVal destPoints() As PointF, _
   ByVal srcRect As RectangleF, _
   ByVal matrix As Matrix _
)
[C#]
public void Warp(
   PointF[] destPoints,
   RectangleF srcRect,
   Matrix matrix
);
[C++]
public: void Warp(
   PointF* destPoints[],
   RectangleF srcRect,
   Matrix* matrix
);
[JScript]
public function Warp(
   destPoints : PointF[],
   srcRect : RectangleF,
   matrix : Matrix
);

Parameters

destPoints
[To be supplied.]
srcRect
[To be supplied.]
matrix
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.Warp Overload List


GraphicsPath.Widen

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub Widen(Pen, Matrix, Boolean)
[C#] public void Widen(Pen, Matrix, bool);
[C++] public: void Widen(Pen*, Matrix, bool);
[JScript] public function Widen(Pen, Matrix, Boolean);

[To be supplied.]

[Visual Basic] Overloads Public Sub Widen(Pen, Matrix)
[C#] public void Widen(Pen, Matrix);
[C++] public: void Widen(Pen*, Matrix);
[JScript] public function Widen(Pen, Matrix);

[To be supplied.]

[Visual Basic] Overloads Public Sub Widen(Pen)
[C#] public void Widen(Pen);
[C++] public: void Widen(Pen*);
[JScript] public function Widen(Pen);

[To be supplied.]

[Visual Basic] Overloads Public Sub Widen(Pen, Single, Single, Matrix, Boolean)
[C#] public void Widen(Pen, float, float, Matrix, bool);
[C++] public: void Widen(Pen*, float, float, Matrix, bool);
[JScript] public function Widen(Pen, float, float, Matrix, Boolean);

[To be supplied.]

[Visual Basic] Overloads Public Sub Widen(Pen, Single, Single, Matrix)
[C#] public void Widen(Pen, float, float, Matrix);
[C++] public: void Widen(Pen*, float, float, Matrix);
[JScript] public function Widen(Pen, float, float, Matrix);

[To be supplied.]

[Visual Basic] Overloads Public Sub Widen(Pen, Single, Single)
[C#] public void Widen(Pen, float, float);
[C++] public: void Widen(Pen*, float, float);
[JScript] public function Widen(Pen, float, float);

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace


GraphicsPath.Widen (Pen, Matrix, Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Widen( _
   ByVal pen As Pen, _
   ByVal matrix As Matrix, _
   ByVal removeSelfIntersects As Boolean _
)
[C#]
public void Widen(
   Pen pen,
   Matrix matrix,
   bool removeSelfIntersects
);
[C++]
public: void Widen(
   Pen* pen,
   Matrix* matrix,
   bool removeSelfIntersects
);
[JScript]
public function Widen(
   pen : Pen,
   matrix : Matrix,
   removeSelfIntersects : Boolean
);

Parameters

pen
[To be supplied.]
matrix
[To be supplied.]
removeSelfIntersects
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.Widen Overload List


GraphicsPath.Widen (Pen, Matrix)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Widen( _
   ByVal pen As Pen, _
   ByVal matrix As Matrix _
)
[C#]
public void Widen(
   Pen pen,
   Matrix matrix
);
[C++]
public: void Widen(
   Pen* pen,
   Matrix* matrix
);
[JScript]
public function Widen(
   pen : Pen,
   matrix : Matrix
);

Parameters

pen
[To be supplied.]
matrix
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.Widen Overload List


GraphicsPath.Widen (Pen)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Widen( _
   ByVal pen As Pen _
)
[C#]
public void Widen(
   Pen pen
);
[C++]
public: void Widen(
   Pen* pen
);
[JScript]
public function Widen(
   pen : Pen
);

Parameters

pen
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.Widen Overload List


GraphicsPath.Widen (Pen, Single, Single, Matrix, Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Widen( _
   ByVal pen As Pen, _
   ByVal minXres As Single, _
   ByVal minYres As Single, _
   ByVal matrix As Matrix, _
   ByVal removeSelfIntersects As Boolean _
)
[C#]
public void Widen(
   Pen pen,
   float minXres,
   float minYres,
   Matrix matrix,
   bool removeSelfIntersects
);
[C++]
public: void Widen(
   Pen* pen,
   float minXres,
   float minYres,
   Matrix* matrix,
   bool removeSelfIntersects
);
[JScript]
public function Widen(
   pen : Pen,
   minXres : float,
   minYres : float,
   matrix : Matrix,
   removeSelfIntersects : Boolean
);

Parameters

pen
[To be supplied.]
minXres
[To be supplied.]
minYres
[To be supplied.]
matrix
[To be supplied.]
removeSelfIntersects
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.Widen Overload List


GraphicsPath.Widen (Pen, Single, Single, Matrix)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Widen( _
   ByVal pen As Pen, _
   ByVal minXres As Single, _
   ByVal minYres As Single, _
   ByVal matrix As Matrix _
)
[C#]
public void Widen(
   Pen pen,
   float minXres,
   float minYres,
   Matrix matrix
);
[C++]
public: void Widen(
   Pen* pen,
   float minXres,
   float minYres,
   Matrix* matrix
);
[JScript]
public function Widen(
   pen : Pen,
   minXres : float,
   minYres : float,
   matrix : Matrix
);

Parameters

pen
[To be supplied.]
minXres
[To be supplied.]
minYres
[To be supplied.]
matrix
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.Widen Overload List


GraphicsPath.Widen (Pen, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Widen( _
   ByVal pen As Pen, _
   ByVal minXres As Single, _
   ByVal minYres As Single _
)
[C#]
public void Widen(
   Pen pen,
   float minXres,
   float minYres
);
[C++]
public: void Widen(
   Pen* pen,
   float minXres,
   float minYres
);
[JScript]
public function Widen(
   pen : Pen,
   minXres : float,
   minYres : float
);

Parameters

pen
[To be supplied.]
minXres
[To be supplied.]
minYres
[To be supplied.]

See Also

GraphicsPath Class | GraphicsPath Members | System.Drawing.Drawing2D Namespace | GraphicsPath.Widen Overload List


GraphicsPathIterator Class

[To be supplied.]

Object
MarshalByRefObject
GraphicsPathIterator

[Visual Basic]
NotInheritable Public Class GraphicsPathIterator
   Inherits MarshalByRefObject
[C#]
public sealed class GraphicsPathIterator : MarshalByRefObject
[C++]
public __gc __sealed class GraphicsPathIterator : public
   MarshalByRefObject
[JScript]
public class GraphicsPathIterator extends MarshalByRefObject

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

GraphicsPathIterator Members | System.Drawing.Drawing2D Namespace


GraphicsPathIterator Members

Public:

Constructor

GraphicsPathIterator Constructor [To be supplied.]

Properties

Count | [To be supplied.]
SubpathCount | [To be supplied.]

Methods

CopyData | [To be supplied.]
Dispose | [To be supplied.]
Enumerate | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetType (inherited from Object) | Gets the Type of the Object.
HasCurve | [To be supplied.]
InitializeLifetimeService (inherited from MarshalByRefObject) |
NextMarker | Overloaded. [To be supplied.]
NextPathType | [To be supplied.]
NextSubpath | Overloaded. [To be supplied.]
Rewind | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GraphicsPathIterator Class | System.Drawing.Drawing2D Namespace


GraphicsPathIterator Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal path As GraphicsPath _
)
[C#]
public GraphicsPathIterator(
   GraphicsPath path
);
[C++]
public: GraphicsPathIterator(
   GraphicsPath* path
);
[JScript]
public function GraphicsPathIterator(
   path : GraphicsPath
);

Parameters

path
[To be supplied.]

See Also

GraphicsPathIterator Class | GraphicsPathIterator Members | System.Drawing.Drawing2D Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

GraphicsPathIterator Properties

The properties of the GraphicsPathIterator class are listed below. For a complete list of GraphicsPathIterator class members, see the GraphicsPathIterator Members topic.

Public:

Count | [To be supplied.]
SubpathCount | [To be supplied.]

See Also

GraphicsPathIterator Class | System.Drawing.Drawing2D Namespace


GraphicsPathIterator.Count

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

See Also

GraphicsPathIterator Class | GraphicsPathIterator Members | System.Drawing.Drawing2D Namespace


GraphicsPathIterator.SubpathCount

[To be supplied.]

[Visual Basic]
Public ReadOnly Property SubpathCount As Integer
[C#]
public int SubpathCount {get;}
[C++]
public: __property int get_SubpathCount();
[JScript]
public function get SubpathCount() : int;

See Also

GraphicsPathIterator Class | GraphicsPathIterator Members | System.Drawing.Drawing2D Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

GraphicsPathIterator Methods

The methods of the GraphicsPathIterator class are listed below. For a complete list of GraphicsPathIterator class members, see the GraphicsPathIterator Members topic.

Public:

CopyData | [To be supplied.]
Dispose | [To be supplied.]
Enumerate | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetType (inherited from Object) | Gets the Type of the Object.
HasCurve | [To be supplied.]
InitializeLifetimeService (inherited from MarshalByRefObject) |
NextMarker | Overloaded. [To be supplied.]
NextPathType | [To be supplied.]
NextSubpath | Overloaded. [To be supplied.]
Rewind | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GraphicsPathIterator Class | System.Drawing.Drawing2D Namespace


GraphicsPathIterator.CopyData

[To be supplied.]

[Visual Basic]
Public Function CopyData( _
   ByRef points() As PointF, _
   ByRef types() As Byte, _
   ByVal startIndex As Integer, _
   ByVal endIndex As Integer _
) As Integer
[C#]
public int CopyData(
   ref PointF[] points,
   ref byte[] types,
   int startIndex,
   int endIndex
);
[C++]
public: int CopyData(
   PointF** points[],
   unsigned char** types[],
   int startIndex,
   int endIndex
);
[JScript]
public function CopyData(
   points : PointF[],
   types : Byte[],
   startIndex : int,
   endIndex : int
) : int;

Parameters

points
[To be supplied.]
types
[To be supplied.]
startIndex
[To be supplied.]
endIndex
[To be supplied.]

See Also

GraphicsPathIterator Class | GraphicsPathIterator Members | System.Drawing.Drawing2D Namespace


GraphicsPathIterator.Dispose

[To be supplied.]

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[JScript]
public function Dispose();

See Also

GraphicsPathIterator Class | GraphicsPathIterator Members | System.Drawing.Drawing2D Namespace


GraphicsPathIterator.Enumerate

[To be supplied.]

[Visual Basic]
Public Function Enumerate( _
   ByRef points() As PointF, _
   ByRef types() As Byte _
) As Integer
[C#]
public int Enumerate(
   ref PointF[] points,
   ref byte[] types
);
[C++]
public: int Enumerate(
   PointF** points[],
   unsigned char** types[]
);
[JScript]
public function Enumerate(
   points : PointF[],
   types : Byte[]
) : int;

Parameters

points
[To be supplied.]
types
[To be supplied.]

See Also

GraphicsPathIterator Class | GraphicsPathIterator Members | System.Drawing.Drawing2D Namespace


GraphicsPathIterator.Finalize

[To be supplied.]

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

GraphicsPathIterator Class | GraphicsPathIterator Members | System.Drawing.Drawing2D Namespace


GraphicsPathIterator.HasCurve

[To be supplied.]

[Visual Basic]
Public Function HasCurve() As Boolean
[C#]
public bool HasCurve();
[C++]
public: bool HasCurve();
[JScript]
public function HasCurve() : Boolean;

See Also

GraphicsPathIterator Class | GraphicsPathIterator Members | System.Drawing.Drawing2D Namespace


GraphicsPathIterator.NextMarker

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function NextMarker(Integer, Integer) As Integer
[C#] public int NextMarker(int, int);
[C++] public: int NextMarker(int*, int*);
[JScript] public function NextMarker(int, int) : int;

[To be supplied.]

[Visual Basic] Overloads Public Function NextMarker(GraphicsPath) As Integer
[C#] public int NextMarker(GraphicsPath);
[C++] public: int NextMarker(GraphicsPath*);
[JScript] public function NextMarker(GraphicsPath) : int;

See Also

GraphicsPathIterator Class | GraphicsPathIterator Members | System.Drawing.Drawing2D Namespace


GraphicsPathIterator.NextMarker (Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Function NextMarker( _
   ByRef startIndex As Integer, _
   ByRef endIndex As Integer _
) As Integer
[C#]
public int NextMarker(
   ref int startIndex,
   ref int endIndex
);
[C++]
public: int NextMarker(
   int** startIndex,
   int** endIndex
);
[JScript]
public function NextMarker(
   startIndex : int,
   endIndex : int
) : int;

Parameters

startIndex
[To be supplied.]
endIndex
[To be supplied.]

See Also

GraphicsPathIterator Class | GraphicsPathIterator Members | System.Drawing.Drawing2D Namespace | GraphicsPathIterator.NextMarker Overload List


GraphicsPathIterator.NextMarker (GraphicsPath)

[To be supplied.]

[Visual Basic]
Overloads Public Function NextMarker( _
   ByVal path As GraphicsPath _
) As Integer
[C#]
public int NextMarker(
   GraphicsPath path
);
[C++]
public: int NextMarker(
   GraphicsPath* path
);
[JScript]
public function NextMarker(
   path : GraphicsPath
) : int;

Parameters

path
[To be supplied.]

See Also

GraphicsPathIterator Class | GraphicsPathIterator Members | System.Drawing.Drawing2D Namespace | GraphicsPathIterator.NextMarker Overload List


GraphicsPathIterator.NextPathType

[To be supplied.]

[Visual Basic]
Public Function NextPathType( _
   ByRef pathType As Byte, _
   ByRef startIndex As Integer, _
   ByRef endIndex As Integer _
) As Integer
[C#]
public int NextPathType(
   ref byte pathType,
   ref int startIndex,
   ref int endIndex
);
[C++]
public: int NextPathType(
   unsigned char** pathType,
   int** startIndex,
   int** endIndex
);
[JScript]
public function NextPathType(
   pathType : Byte,
   startIndex : int,
   endIndex : int
) : int;

Parameters

pathType
[To be supplied.]
startIndex
[To be supplied.]
endIndex
[To be supplied.]

See Also

GraphicsPathIterator Class | GraphicsPathIterator Members | System.Drawing.Drawing2D Namespace


GraphicsPathIterator.NextSubpath

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function NextSubpath(Integer, Integer, Boolean) As Integer
[C#] public int NextSubpath(int, int, bool);
[C++] public: int NextSubpath(int*, int*, bool);
[JScript] public function NextSubpath(int, int, Boolean) : int;

[To be supplied.]

[Visual Basic] Overloads Public Function NextSubpath(GraphicsPath, Boolean) As Integer
[C#] public int NextSubpath(GraphicsPath, bool);
[C++] public: int NextSubpath(GraphicsPath*, bool);
[JScript] public function NextSubpath(GraphicsPath, Boolean) : int;

See Also

GraphicsPathIterator Class | GraphicsPathIterator Members | System.Drawing.Drawing2D Namespace


GraphicsPathIterator.NextSubpath (Int32, Int32, Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Function NextSubpath( _
   ByRef startIndex As Integer, _
   ByRef endIndex As Integer, _
   ByRef isClosed As Boolean _
) As Integer
[C#]
public int NextSubpath(
   ref int startIndex,
   ref int endIndex,
   ref bool isClosed
);
[C++]
public: int NextSubpath(
   int** startIndex,
   int** endIndex,
   bool** isClosed
);
[JScript]
public function NextSubpath(
   startIndex : int,
   endIndex : int,
   isClosed : Boolean
) : int;

Parameters

startIndex
[To be supplied.]
endIndex
[To be supplied.]
isClosed
[To be supplied.]

See Also

GraphicsPathIterator Class | GraphicsPathIterator Members | System.Drawing.Drawing2D Namespace | GraphicsPathIterator.NextSubpath Overload List


GraphicsPathIterator.NextSubpath (GraphicsPath, Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Function NextSubpath( _
   ByVal path As GraphicsPath, _
   ByRef isClosed As Boolean _
) As Integer
[C#]
public int NextSubpath(
   GraphicsPath path,
   ref bool isClosed
);
[C++]
public: int NextSubpath(
   GraphicsPath* path,
   bool** isClosed
);
[JScript]
public function NextSubpath(
   path : GraphicsPath,
   isClosed : Boolean
) : int;

Parameters

path
[To be supplied.]
isClosed
[To be supplied.]

See Also

GraphicsPathIterator Class | GraphicsPathIterator Members | System.Drawing.Drawing2D Namespace | GraphicsPathIterator.NextSubpath Overload List


GraphicsPathIterator.Rewind

[To be supplied.]

[Visual Basic]
Public Sub Rewind()
[C#]
public void Rewind();
[C++]
public: void Rewind();
[JScript]
public function Rewind();

See Also

GraphicsPathIterator Class | GraphicsPathIterator Members | System.Drawing.Drawing2D Namespace


GraphicsState Class

[To be supplied.]

Object
MarshalByRefObject
GraphicsState

[Visual Basic]
NotInheritable Public Class GraphicsState
   Inherits MarshalByRefObject
[C#]
public sealed class GraphicsState : MarshalByRefObject
[C++]
public __gc __sealed class GraphicsState : public
   MarshalByRefObject
[JScript]
public class GraphicsState extends MarshalByRefObject

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

GraphicsState Members | System.Drawing.Drawing2D Namespace


GraphicsState Members

Public:

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GraphicsState Class | System.Drawing.Drawing2D Namespace


HatchBrush Class

[To be supplied.]

Object
MarshalByRefObject
Brush
HatchBrush

[Visual Basic]
NotInheritable Public Class HatchBrush
   Inherits Brush
[C#]
public sealed class HatchBrush : Brush
[C++]
public __gc __sealed class HatchBrush : public Brush
[JScript]
public class HatchBrush extends Brush

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

HatchBrush Members | System.Drawing.Drawing2D Namespace


HatchBrush Members

Public:

Constructor

HatchBrush Constructor Overloaded. [To be supplied.]

Properties

BackgroundColor | [To be supplied.]
ForegroundColor | [To be supplied.]
HatchStyle | [To be supplied.]

Methods

Clone | [To be supplied.]
Dispose (inherited from Brush) | Deletes this Brush.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Brush) | Releases memory allocated for this Brush.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HatchBrush Class | System.Drawing.Drawing2D Namespace


HatchBrush Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(HatchStyle, Color)
[C#] public HatchBrush(HatchStyle, Color);
[C++] public: HatchBrush(HatchStyle, Color);
[JScript] public function HatchBrush(HatchStyle, Color);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(HatchStyle, Color, Color)
[C#] public HatchBrush(HatchStyle, Color, Color);
[C++] public: HatchBrush(HatchStyle, Color, Color);
[JScript] public function HatchBrush(HatchStyle, Color, Color);

See Also

HatchBrush Class | HatchBrush Members | System.Drawing.Drawing2D Namespace


HatchBrush Constructor (HatchStyle, Color)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal hatchstyle As HatchStyle, _
   ByVal foreColor As Color _
)
[C#]
public HatchBrush(
   HatchStyle hatchstyle,
   Color foreColor
);
[C++]
public: HatchBrush(
   HatchStyle hatchstyle,
   Color foreColor
);
[JScript]
public function HatchBrush(
   hatchstyle : HatchStyle,
   foreColor : Color
);

Parameters

hatchstyle
[To be supplied.]
foreColor
[To be supplied.]

See Also

HatchBrush Class | HatchBrush Members | System.Drawing.Drawing2D Namespace | HatchBrush Constructor Overload List


HatchBrush Constructor (HatchStyle, Color, Color)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal hatchstyle As HatchStyle, _
   ByVal foreColor As Color, _
   ByVal backColor As Color _
)
[C#]
public HatchBrush(
   HatchStyle hatchstyle,
   Color foreColor,
   Color backColor
);
[C++]
public: HatchBrush(
   HatchStyle hatchstyle,
   Color foreColor,
   Color backColor
);
[JScript]
public function HatchBrush(
   hatchstyle : HatchStyle,
   foreColor : Color,
   backColor : Color
);

Parameters

hatchstyle
[To be supplied.]
foreColor
[To be supplied.]
backColor
[To be supplied.]

See Also

HatchBrush Class | HatchBrush Members | System.Drawing.Drawing2D Namespace | HatchBrush Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

HatchBrush Properties

The properties of the HatchBrush class are listed below. For a complete list of HatchBrush class members, see the HatchBrush Members topic.

Public:

BackgroundColor | [To be supplied.]
ForegroundColor | [To be supplied.]
HatchStyle | [To be supplied.]

See Also

HatchBrush Class | System.Drawing.Drawing2D Namespace


HatchBrush.BackgroundColor

[To be supplied.]

[Visual Basic]
Public ReadOnly Property BackgroundColor As Color
[C#]
public Color BackgroundColor {get;}
[C++]
public: __property Color get_BackgroundColor();
[JScript]
public function get BackgroundColor() : Color;

See Also

HatchBrush Class | HatchBrush Members | System.Drawing.Drawing2D Namespace


HatchBrush.ForegroundColor

[To be supplied.]

[Visual Basic]
Public ReadOnly Property ForegroundColor As Color
[C#]
public Color ForegroundColor {get;}
[C++]
public: __property Color get_ForegroundColor();
[JScript]
public function get ForegroundColor() : Color;

See Also

HatchBrush Class | HatchBrush Members | System.Drawing.Drawing2D Namespace


HatchBrush.HatchStyle

[To be supplied.]

[Visual Basic]
Public ReadOnly Property HatchStyle As HatchStyle
[C#]
public HatchStyle HatchStyle {get;}
[C++]
public: __property HatchStyle get_HatchStyle();
[JScript]
public function get HatchStyle() : HatchStyle;

See Also

HatchBrush Class | HatchBrush Members | System.Drawing.Drawing2D Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

HatchBrush Methods

The methods of the HatchBrush class are listed below. For a complete list of HatchBrush class members, see the HatchBrush Members topic.

Public:

Clone | [To be supplied.]
Dispose (inherited from Brush) | Deletes this Brush.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Brush) | Releases memory allocated for this Brush.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HatchBrush Class | System.Drawing.Drawing2D Namespace


HatchBrush.Clone

[To be supplied.]

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
public: override Object* Clone();
[JScript]
public override function Clone() : Object;

See Also

HatchBrush Class | HatchBrush Members | System.Drawing.Drawing2D Namespace


HatchStyle Enumeration

[To be supplied.]

[Visual Basic]
Public Enum HatchStyle
[C#]
public enum HatchStyle
[C++]
public enum HatchStyle

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
BackwardDiagonal | [To be supplied.]
Cross | [To be supplied.]
DiagonalCross | [To be supplied.]
ForwardDiagonal | [To be supplied.]
Horizontal | [To be supplied.]
Vertical | [To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

System.Drawing.Drawing2D Namespace


InterpolationMode Enumeration

[To be supplied.]

[Visual Basic]
Public Enum InterpolationMode
[C#]
public enum InterpolationMode
[C++]
public enum InterpolationMode

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Bicubic | [To be supplied.]
Bilinear | [To be supplied.]
Default | [To be supplied.]
High | [To be supplied.]
HighQualityBicubic | [To be supplied.]
HighQualityBilinear | [To be supplied.]
Invalid | [To be supplied.]
Low | [To be supplied.]
NearestNeighbor | [To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

System.Drawing.Drawing2D Namespace


LinearGradientBrush Class

[To be supplied.]

Object
MarshalByRefObject
Brush
LinearGradientBrush

[Visual Basic]
NotInheritable Public Class LinearGradientBrush
   Inherits Brush
[C#]
public sealed class LinearGradientBrush : Brush
[C++]
public __gc __sealed class LinearGradientBrush : public Brush
[JScript]
public class LinearGradientBrush extends Brush

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

LinearGradientBrush Members | System.Drawing.Drawing2D Namespace


LinearGradientBrush Members

Public:

Constructor

LinearGradientBrush Constructor Overloaded. [To be supplied.]

Properties

Blend | [To be supplied.]
GammaCorrected | [To be supplied.]
GammaCorrection | [To be supplied.]
InterpolationColors | [To be supplied.]
LinearColors | [To be supplied.]
LinearPoints | [To be supplied.]
Rectangle | [To be supplied.]
Transform | [To be supplied.]
WrapMode | [To be supplied.]

Methods

Clone | [To be supplied.]
Dispose (inherited from Brush) | Deletes this Brush.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
MultiplyTransform | Overloaded. [To be supplied.]
ResetTransform | [To be supplied.]
RotateTransform | Overloaded. [To be supplied.]
ScaleTransform | Overloaded. [To be supplied.]
SetBlendTriangularShape | Overloaded. [To be supplied.]
SetSigmaBellShape | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.
TranslateTransform | Overloaded. [To be supplied.]

Protected:

Methods

Finalize (inherited from Brush) | Releases memory allocated for this Brush.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LinearGradientBrush Class | System.Drawing.Drawing2D Namespace


LinearGradientBrush Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(PointF, PointF, Color, Color)
[C#] public LinearGradientBrush(PointF, PointF, Color, Color);
[C++] public: LinearGradientBrush(PointF, PointF, Color, Color);
[JScript] public function LinearGradientBrush(PointF, PointF, Color, Color);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Point, Point, Color, Color)
[C#] public LinearGradientBrush(Point, Point, Color, Color);
[C++] public: LinearGradientBrush(Point, Point, Color, Color);
[JScript] public function LinearGradientBrush(Point, Point, Color, Color);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(RectangleF, Color, Color, LinearGradientMode)
[C#] public LinearGradientBrush(RectangleF, Color, Color, LinearGradientMode);
[C++] public: LinearGradientBrush(RectangleF, Color, Color, LinearGradientMode);
[JScript] public function LinearGradientBrush(RectangleF, Color, Color, LinearGradientMode);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Rectangle, Color, Color, LinearGradientMode)
[C#] public LinearGradientBrush(Rectangle, Color, Color, LinearGradientMode);
[C++] public: LinearGradientBrush(Rectangle, Color, Color, LinearGradientMode);
[JScript] public function LinearGradientBrush(Rectangle, Color, Color, LinearGradientMode);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(RectangleF, Color, Color, Single)
[C#] public LinearGradientBrush(RectangleF, Color, Color, float);
[C++] public: LinearGradientBrush(RectangleF, Color, Color, float);
[JScript] public function LinearGradientBrush(RectangleF, Color, Color, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(RectangleF, Color, Color, Single, Boolean)
[C#] public LinearGradientBrush(RectangleF, Color, Color, float, bool);
[C++] public: LinearGradientBrush(RectangleF, Color, Color, float, bool);
[JScript] public function LinearGradientBrush(RectangleF, Color, Color, float, Boolean);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Rectangle, Color, Color, Single)
[C#] public LinearGradientBrush(Rectangle, Color, Color, float);
[C++] public: LinearGradientBrush(Rectangle, Color, Color, float);
[JScript] public function LinearGradientBrush(Rectangle, Color, Color, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Rectangle, Color, Color, Single, Boolean)
[C#] public LinearGradientBrush(Rectangle, Color, Color, float, bool);
[C++] public: LinearGradientBrush(Rectangle, Color, Color, float, bool);
[JScript] public function LinearGradientBrush(Rectangle, Color, Color, float, Boolean);

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace


LinearGradientBrush Constructor (PointF, PointF, Color, Color)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal point1 As PointF, _
   ByVal point2 As PointF, _
   ByVal color1 As Color, _
   ByVal color2 As Color _
)
[C#]
public LinearGradientBrush(
   PointF point1,
   PointF point2,
   Color color1,
   Color color2
);
[C++]
public: LinearGradientBrush(
   PointF point1,
   PointF point2,
   Color color1,
   Color color2
);
[JScript]
public function LinearGradientBrush(
   point1 : PointF,
   point2 : PointF,
   color1 : Color,
   color2 : Color
);

Parameters

point1
[To be supplied.]
point2
[To be supplied.]
color1
[To be supplied.]
color2
[To be supplied.]

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace | LinearGradientBrush Constructor Overload List


LinearGradientBrush Constructor (Point, Point, Color, Color)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal point1 As Point, _
   ByVal point2 As Point, _
   ByVal color1 As Color, _
   ByVal color2 As Color _
)
[C#]
public LinearGradientBrush(
   Point point1,
   Point point2,
   Color color1,
   Color color2
);
[C++]
public: LinearGradientBrush(
   Point point1,
   Point point2,
   Color color1,
   Color color2
);
[JScript]
public function LinearGradientBrush(
   point1 : Point,
   point2 : Point,
   color1 : Color,
   color2 : Color
);

Parameters

point1
[To be supplied.]
point2
[To be supplied.]
color1
[To be supplied.]
color2
[To be supplied.]

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace | LinearGradientBrush Constructor Overload List


LinearGradientBrush Constructor (RectangleF, Color, Color, LinearGradientMode)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal rect As RectangleF, _
   ByVal color1 As Color, _
   ByVal color2 As Color, _
   ByVal linearGradientMode As LinearGradientMode _
)
[C#]
public LinearGradientBrush(
   RectangleF rect,
   Color color1,
   Color color2,
   LinearGradientMode linearGradientMode
);
[C++]
public: LinearGradientBrush(
   RectangleF rect,
   Color color1,
   Color color2,
   LinearGradientMode linearGradientMode
);
[JScript]
public function LinearGradientBrush(
   rect : RectangleF,
   color1 : Color,
   color2 : Color,
   linearGradientMode : LinearGradientMode
);

Parameters

rect
[To be supplied.]
color1
[To be supplied.]
color2
[To be supplied.]
linearGradientMode
[To be supplied.]

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace | LinearGradientBrush Constructor Overload List


LinearGradientBrush Constructor (Rectangle, Color, Color, LinearGradientMode)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal rect As Rectangle, _
   ByVal color1 As Color, _
   ByVal color2 As Color, _
   ByVal linearGradientMode As LinearGradientMode _
)
[C#]
public LinearGradientBrush(
   Rectangle rect,
   Color color1,
   Color color2,
   LinearGradientMode linearGradientMode
);
[C++]
public: LinearGradientBrush(
   Rectangle rect,
   Color color1,
   Color color2,
   LinearGradientMode linearGradientMode
);
[JScript]
public function LinearGradientBrush(
   rect : Rectangle,
   color1 : Color,
   color2 : Color,
   linearGradientMode : LinearGradientMode
);

Parameters

rect
[To be supplied.]
color1
[To be supplied.]
color2
[To be supplied.]
linearGradientMode
[To be supplied.]

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace | LinearGradientBrush Constructor Overload List


LinearGradientBrush Constructor (RectangleF, Color, Color, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal rect As RectangleF, _
   ByVal color1 As Color, _
   ByVal color2 As Color, _
   ByVal angle As Single _
)
[C#]
public LinearGradientBrush(
   RectangleF rect,
   Color color1,
   Color color2,
   float angle
);
[C++]
public: LinearGradientBrush(
   RectangleF rect,
   Color color1,
   Color color2,
   float angle
);
[JScript]
public function LinearGradientBrush(
   rect : RectangleF,
   color1 : Color,
   color2 : Color,
   angle : float
);

Parameters

rect
[To be supplied.]
color1
[To be supplied.]
color2
[To be supplied.]
angle
[To be supplied.]

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace | LinearGradientBrush Constructor Overload List


LinearGradientBrush Constructor (RectangleF, Color, Color, Single, Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal rect As RectangleF, _
   ByVal color1 As Color, _
   ByVal color2 As Color, _
   ByVal angle As Single, _
   ByVal isAngleScaleable As Boolean _
)
[C#]
public LinearGradientBrush(
   RectangleF rect,
   Color color1,
   Color color2,
   float angle,
   bool isAngleScaleable
);
[C++]
public: LinearGradientBrush(
   RectangleF rect,
   Color color1,
   Color color2,
   float angle,
   bool isAngleScaleable
);
[JScript]
public function LinearGradientBrush(
   rect : RectangleF,
   color1 : Color,
   color2 : Color,
   angle : float,
   isAngleScaleable : Boolean
);

Parameters

rect
[To be supplied.]
color1
[To be supplied.]
color2
[To be supplied.]
angle
[To be supplied.]
isAngleScaleable
[To be supplied.]

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace | LinearGradientBrush Constructor Overload List


LinearGradientBrush Constructor (Rectangle, Color, Color, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal rect As Rectangle, _
   ByVal color1 As Color, _
   ByVal color2 As Color, _
   ByVal angle As Single _
)
[C#]
public LinearGradientBrush(
   Rectangle rect,
   Color color1,
   Color color2,
   float angle
);
[C++]
public: LinearGradientBrush(
   Rectangle rect,
   Color color1,
   Color color2,
   float angle
);
[JScript]
public function LinearGradientBrush(
   rect : Rectangle,
   color1 : Color,
   color2 : Color,
   angle : float
);

Parameters

rect
[To be supplied.]
color1
[To be supplied.]
color2
[To be supplied.]
angle
[To be supplied.]

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace | LinearGradientBrush Constructor Overload List


LinearGradientBrush Constructor (Rectangle, Color, Color, Single, Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal rect As Rectangle, _
   ByVal color1 As Color, _
   ByVal color2 As Color, _
   ByVal angle As Single, _
   ByVal isAngleScaleable As Boolean _
)
[C#]
public LinearGradientBrush(
   Rectangle rect,
   Color color1,
   Color color2,
   float angle,
   bool isAngleScaleable
);
[C++]
public: LinearGradientBrush(
   Rectangle rect,
   Color color1,
   Color color2,
   float angle,
   bool isAngleScaleable
);
[JScript]
public function LinearGradientBrush(
   rect : Rectangle,
   color1 : Color,
   color2 : Color,
   angle : float,
   isAngleScaleable : Boolean
);

Parameters

rect
[To be supplied.]
color1
[To be supplied.]
color2
[To be supplied.]
angle
[To be supplied.]
isAngleScaleable
[To be supplied.]

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace | LinearGradientBrush Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

LinearGradientBrush Properties

The properties of the LinearGradientBrush class are listed below. For a complete list of LinearGradientBrush class members, see the LinearGradientBrush Members topic.

Public:

Blend | [To be supplied.]
GammaCorrected | [To be supplied.]
GammaCorrection | [To be supplied.]
InterpolationColors | [To be supplied.]
LinearColors | [To be supplied.]
LinearPoints | [To be supplied.]
Rectangle | [To be supplied.]
Transform | [To be supplied.]
WrapMode | [To be supplied.]

See Also

LinearGradientBrush Class | System.Drawing.Drawing2D Namespace


LinearGradientBrush.Blend

[To be supplied.]

[Visual Basic]
Public Property Blend As Blend
[C#]
public Blend Blend {get; set;}
[C++]
public: __property Blend* get_Blend();
public: __property void set_Blend(Blend*);
[JScript]
public function get Blend() : Blend;
public function set Blend(Blend);

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace


LinearGradientBrush.GammaCorrected

[To be supplied.]

[Visual Basic]
Public Property GammaCorrected As Boolean
[C#]
public bool GammaCorrected {get; set;}
[C++]
public: __property bool get_GammaCorrected();
public: __property void set_GammaCorrected(bool);
[JScript]
public function get GammaCorrected() : Boolean;
public function set GammaCorrected(Boolean);

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace


LinearGradientBrush.GammaCorrection

[To be supplied.]

[Visual Basic]
Public Property GammaCorrection As Boolean
[C#]
public bool GammaCorrection {get; set;}
[C++]
public: __property bool get_GammaCorrection();
public: __property void set_GammaCorrection(bool);
[JScript]
public function get GammaCorrection() : Boolean;
public function set GammaCorrection(Boolean);

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace


LinearGradientBrush.InterpolationColors

[To be supplied.]

[Visual Basic]
Public Property InterpolationColors As ColorBlend
[C#]
public ColorBlend InterpolationColors {get; set;}
[C++]
public: __property ColorBlend* get_InterpolationColors();
public: __property void set_InterpolationColors(ColorBlend*);
[JScript]
public function get InterpolationColors() : ColorBlend;
public function set InterpolationColors(ColorBlend);

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace


LinearGradientBrush.LinearColors

[To be supplied.]

[Visual Basic]
Public Property LinearColors As Color ()
[C#]
public Color[] LinearColors {get; set;}
[C++]
public: __property Color* get_LinearColors();
public: __property void set_LinearColors(Color*[]);
[JScript]
public function get LinearColors() : Color[];
public function set LinearColors(Color[]);

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace


LinearGradientBrush.LinearPoints

[To be supplied.]

[Visual Basic]
Public Property LinearPoints As PointF ()
[C#]
public PointF[] LinearPoints {get; set;}
[C++]
public: __property PointF* get_LinearPoints();
public: __property void set_LinearPoints(PointF*[]);
[JScript]
public function get LinearPoints() : PointF[];
public function set LinearPoints(PointF[]);

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace


LinearGradientBrush.Rectangle

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Rectangle As RectangleF
[C#]
public RectangleF Rectangle {get;}
[C++]
public: __property RectangleF get_Rectangle();
[JScript]
public function get Rectangle() : RectangleF;

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace


LinearGradientBrush.Transform

[To be supplied.]

[Visual Basic]
Public Property Transform As Matrix
[C#]
public Matrix Transform {get; set;}
[C++]
public: __property Matrix* get_Transform();
public: __property void set_Transform(Matrix*);
[JScript]
public function get Transform() : Matrix;
public function set Transform(Matrix);

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace


LinearGradientBrush.WrapMode

[To be supplied.]

[Visual Basic]
Public Property WrapMode As WrapMode
[C#]
public WrapMode WrapMode {get; set;}
[C++]
public: __property WrapMode get_WrapMode();
public: __property void set_WrapMode(WrapMode);
[JScript]
public function get WrapMode() : WrapMode;
public function set WrapMode(WrapMode);

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

LinearGradientBrush Methods

The methods of the LinearGradientBrush class are listed below. For a complete list of LinearGradientBrush class members, see the LinearGradientBrush Members topic.

Public:

Clone | [To be supplied.]
Dispose (inherited from Brush) | Deletes this Brush.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
MultiplyTransform | Overloaded. [To be supplied.]
ResetTransform | [To be supplied.]
RotateTransform | Overloaded. [To be supplied.]
ScaleTransform | Overloaded. [To be supplied.]
SetBlendTriangularShape | Overloaded. [To be supplied.]
SetSigmaBellShape | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.
TranslateTransform | Overloaded. [To be supplied.]

Protected:

Finalize (inherited from Brush) | Releases memory allocated for this Brush.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LinearGradientBrush Class | System.Drawing.Drawing2D Namespace


LinearGradientBrush.Clone

[To be supplied.]

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
public: override Object* Clone();
[JScript]
public override function Clone() : Object;

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace


LinearGradientBrush.MultiplyTransform

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub MultiplyTransform(Matrix, MatrixOrder)
[C#] public void MultiplyTransform(Matrix, MatrixOrder);
[C++] public: void MultiplyTransform(Matrix*, MatrixOrder);
[JScript] public function MultiplyTransform(Matrix, MatrixOrder);

[To be supplied.]

[Visual Basic] Overloads Public Sub MultiplyTransform(Matrix)
[C#] public void MultiplyTransform(Matrix);
[C++] public: void MultiplyTransform(Matrix*);
[JScript] public function MultiplyTransform(Matrix);

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace


LinearGradientBrush.MultiplyTransform (Matrix, MatrixOrder)

[To be supplied.]

[Visual Basic]
Overloads Public Sub MultiplyTransform( _
   ByVal matrix As Matrix, _
   ByVal order As MatrixOrder _
)
[C#]
public void MultiplyTransform(
   Matrix matrix,
   MatrixOrder order
);
[C++]
public: void MultiplyTransform(
   Matrix* matrix,
   MatrixOrder order
);
[JScript]
public function MultiplyTransform(
   matrix : Matrix,
   order : MatrixOrder
);

Parameters

matrix
[To be supplied.]
order
[To be supplied.]

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace | LinearGradientBrush.MultiplyTransform Overload List


LinearGradientBrush.MultiplyTransform (Matrix)

[To be supplied.]

[Visual Basic]
Overloads Public Sub MultiplyTransform( _
   ByVal matrix As Matrix _
)
[C#]
public void MultiplyTransform(
   Matrix matrix
);
[C++]
public: void MultiplyTransform(
   Matrix* matrix
);
[JScript]
public function MultiplyTransform(
   matrix : Matrix
);

Parameters

matrix
[To be supplied.]

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace | LinearGradientBrush.MultiplyTransform Overload List


LinearGradientBrush.ResetTransform

[To be supplied.]

[Visual Basic]
Public Sub ResetTransform()
[C#]
public void ResetTransform();
[C++]
public: void ResetTransform();
[JScript]
public function ResetTransform();

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace


LinearGradientBrush.RotateTransform

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub RotateTransform(Single, MatrixOrder)
[C#] public void RotateTransform(float, MatrixOrder);
[C++] public: void RotateTransform(float, MatrixOrder);
[JScript] public function RotateTransform(float, MatrixOrder);

[To be supplied.]

[Visual Basic] Overloads Public Sub RotateTransform(Single)
[C#] public void RotateTransform(float);
[C++] public: void RotateTransform(float);
[JScript] public function RotateTransform(float);

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace


LinearGradientBrush.RotateTransform (Single, MatrixOrder)

[To be supplied.]

[Visual Basic]
Overloads Public Sub RotateTransform( _
   ByVal angle As Single, _
   ByVal order As MatrixOrder _
)
[C#]
public void RotateTransform(
   float angle,
   MatrixOrder order
);
[C++]
public: void RotateTransform(
   float angle,
   MatrixOrder order
);
[JScript]
public function RotateTransform(
   angle : float,
   order : MatrixOrder
);

Parameters

angle
[To be supplied.]
order
[To be supplied.]

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace | LinearGradientBrush.RotateTransform Overload List


LinearGradientBrush.RotateTransform (Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub RotateTransform( _
   ByVal angle As Single _
)
[C#]
public void RotateTransform(
   float angle
);
[C++]
public: void RotateTransform(
   float angle
);
[JScript]
public function RotateTransform(
   angle : float
);

Parameters

angle
[To be supplied.]

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace | LinearGradientBrush.RotateTransform Overload List


LinearGradientBrush.ScaleTransform

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub ScaleTransform(Single, Single)
[C#] public void ScaleTransform(float, float);
[C++] public: void ScaleTransform(float, float);
[JScript] public function ScaleTransform(float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub ScaleTransform(Single, Single, MatrixOrder)
[C#] public void ScaleTransform(float, float, MatrixOrder);
[C++] public: void ScaleTransform(float, float, MatrixOrder);
[JScript] public function ScaleTransform(float, float, MatrixOrder);

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace


LinearGradientBrush.ScaleTransform (Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub ScaleTransform( _
   ByVal sx As Single, _
   ByVal sy As Single _
)
[C#]
public void ScaleTransform(
   float sx,
   float sy
);
[C++]
public: void ScaleTransform(
   float sx,
   float sy
);
[JScript]
public function ScaleTransform(
   sx : float,
   sy : float
);

Parameters

sx
[To be supplied.]
sy
[To be supplied.]

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace | LinearGradientBrush.ScaleTransform Overload List


LinearGradientBrush.ScaleTransform (Single, Single, MatrixOrder)

[To be supplied.]

[Visual Basic]
Overloads Public Sub ScaleTransform( _
   ByVal sx As Single, _
   ByVal sy As Single, _
   ByVal order As MatrixOrder _
)
[C#]
public void ScaleTransform(
   float sx,
   float sy,
   MatrixOrder order
);
[C++]
public: void ScaleTransform(
   float sx,
   float sy,
   MatrixOrder order
);
[JScript]
public function ScaleTransform(
   sx : float,
   sy : float,
   order : MatrixOrder
);

Parameters

sx
[To be supplied.]
sy
[To be supplied.]
order
[To be supplied.]

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace | LinearGradientBrush.ScaleTransform Overload List


LinearGradientBrush.SetBlendTriangularShape

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub SetBlendTriangularShape(Single, Single)
[C#] public void SetBlendTriangularShape(float, float);
[C++] public: void SetBlendTriangularShape(float, float);
[JScript] public function SetBlendTriangularShape(float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub SetBlendTriangularShape(Single)
[C#] public void SetBlendTriangularShape(float);
[C++] public: void SetBlendTriangularShape(float);
[JScript] public function SetBlendTriangularShape(float);

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace


LinearGradientBrush.SetBlendTriangularShape (Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetBlendTriangularShape( _
   ByVal focus As Single, _
   ByVal scale As Single _
)
[C#]
public void SetBlendTriangularShape(
   float focus,
   float scale
);
[C++]
public: void SetBlendTriangularShape(
   float focus,
   float scale
);
[JScript]
public function SetBlendTriangularShape(
   focus : float,
   scale : float
);

Parameters

focus
[To be supplied.]
scale
[To be supplied.]

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace | LinearGradientBrush.SetBlendTriangularShape Overload List


LinearGradientBrush.SetBlendTriangularShape (Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetBlendTriangularShape( _
   ByVal focus As Single _
)
[C#]
public void SetBlendTriangularShape(
   float focus
);
[C++]
public: void SetBlendTriangularShape(
   float focus
);
[JScript]
public function SetBlendTriangularShape(
   focus : float
);

Parameters

focus
[To be supplied.]

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace | LinearGradientBrush.SetBlendTriangularShape Overload List


LinearGradientBrush.SetSigmaBellShape

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub SetSigmaBellShape(Single, Single)
[C#] public void SetSigmaBellShape(float, float);
[C++] public: void SetSigmaBellShape(float, float);
[JScript] public function SetSigmaBellShape(float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub SetSigmaBellShape(Single)
[C#] public void SetSigmaBellShape(float);
[C++] public: void SetSigmaBellShape(float);
[JScript] public function SetSigmaBellShape(float);

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace


LinearGradientBrush.SetSigmaBellShape (Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetSigmaBellShape( _
   ByVal focus As Single, _
   ByVal scale As Single _
)
[C#]
public void SetSigmaBellShape(
   float focus,
   float scale
);
[C++]
public: void SetSigmaBellShape(
   float focus,
   float scale
);
[JScript]
public function SetSigmaBellShape(
   focus : float,
   scale : float
);

Parameters

focus
[To be supplied.]
scale
[To be supplied.]

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace | LinearGradientBrush.SetSigmaBellShape Overload List


LinearGradientBrush.SetSigmaBellShape (Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetSigmaBellShape( _
   ByVal focus As Single _
)
[C#]
public void SetSigmaBellShape(
   float focus
);
[C++]
public: void SetSigmaBellShape(
   float focus
);
[JScript]
public function SetSigmaBellShape(
   focus : float
);

Parameters

focus
[To be supplied.]

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace | LinearGradientBrush.SetSigmaBellShape Overload List


LinearGradientBrush.TranslateTransform

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub TranslateTransform(Single, Single)
[C#] public void TranslateTransform(float, float);
[C++] public: void TranslateTransform(float, float);
[JScript] public function TranslateTransform(float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub TranslateTransform(Single, Single, MatrixOrder)
[C#] public void TranslateTransform(float, float, MatrixOrder);
[C++] public: void TranslateTransform(float, float, MatrixOrder);
[JScript] public function TranslateTransform(float, float, MatrixOrder);

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace


LinearGradientBrush.TranslateTransform (Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub TranslateTransform( _
   ByVal dx As Single, _
   ByVal dy As Single _
)
[C#]
public void TranslateTransform(
   float dx,
   float dy
);
[C++]
public: void TranslateTransform(
   float dx,
   float dy
);
[JScript]
public function TranslateTransform(
   dx : float,
   dy : float
);

Parameters

dx
[To be supplied.]
dy
[To be supplied.]

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace | LinearGradientBrush.TranslateTransform Overload List


LinearGradientBrush.TranslateTransform (Single, Single, MatrixOrder)

[To be supplied.]

[Visual Basic]
Overloads Public Sub TranslateTransform( _
   ByVal dx As Single, _
   ByVal dy As Single, _
   ByVal order As MatrixOrder _
)
[C#]
public void TranslateTransform(
   float dx,
   float dy,
   MatrixOrder order
);
[C++]
public: void TranslateTransform(
   float dx,
   float dy,
   MatrixOrder order
);
[JScript]
public function TranslateTransform(
   dx : float,
   dy : float,
   order : MatrixOrder
);

Parameters

dx
[To be supplied.]
dy
[To be supplied.]
order
[To be supplied.]

See Also

LinearGradientBrush Class | LinearGradientBrush Members | System.Drawing.Drawing2D Namespace | LinearGradientBrush.TranslateTransform Overload List


LinearGradientMode Enumeration

[To be supplied.]

[Visual Basic]
Public Enum LinearGradientMode
[C#]
public enum LinearGradientMode
[C++]
public enum LinearGradientMode

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
BackwardDiagonal | [To be supplied.]
ForwardDiagonal | [To be supplied.]
Horizontal | [To be supplied.]
Vertical | [To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

System.Drawing.Drawing2D Namespace


LineCap Enumeration

[To be supplied.]

[Visual Basic]
Public Enum LineCap
[C#]
public enum LineCap
[C++]
public enum LineCap

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
AnchorMask | [To be supplied.]
ArrowAnchor | [To be supplied.]
Custom | [To be supplied.]
DiamondAnchor | [To be supplied.]
Flat | [To be supplied.]
NoAnchor | [To be supplied.]
Round | [To be supplied.]
RoundAnchor | [To be supplied.]
Square | [To be supplied.]
SquareAnchor | [To be supplied.]
Triangle | [To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

System.Drawing.Drawing2D Namespace


LineJoin Enumeration

[To be supplied.]

[Visual Basic]
Public Enum LineJoin
[C#]
public enum LineJoin
[C++]
public enum LineJoin

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Bevel | [To be supplied.]
Miter | [To be supplied.]
Round | [To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

System.Drawing.Drawing2D Namespace


Matrix Class

[To be supplied.]

Object
MarshalByRefObject
Matrix

[Visual Basic]
NotInheritable Public Class Matrix
   Inherits MarshalByRefObject
[C#]
public sealed class Matrix : MarshalByRefObject
[C++]
public __gc __sealed class Matrix : public MarshalByRefObject
[JScript]
public class Matrix extends MarshalByRefObject

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

Matrix Members | System.Drawing.Drawing2D Namespace


Matrix Members

Public:

Constructor

Matrix Constructor Overloaded. [To be supplied.]

Properties

Elements | [To be supplied.]
IsIdentity | [To be supplied.]
IsInvertible | [To be supplied.]
OffsetX | [To be supplied.]
OffsetY | [To be supplied.]

Methods

Clone | [To be supplied.]
Dispose | [To be supplied.]
Equals | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
Invert | [To be supplied.]
Multiply | Overloaded. [To be supplied.]
Reset | [To be supplied.]
Rotate | Overloaded. [To be supplied.]
RotateAt | Overloaded. [To be supplied.]
Scale | Overloaded. [To be supplied.]
Shear | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.
TransformPoints | Overloaded. [To be supplied.]
TransformVectors | Overloaded. [To be supplied.]
Translate | Overloaded. [To be supplied.]
VectorTransformPoints | Overloaded. [To be supplied.]

Protected:

Methods

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Matrix Class | System.Drawing.Drawing2D Namespace


Matrix Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public Matrix();
[C++] public: Matrix();
[JScript] public function Matrix();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Single, Single, Single, Single, Single, Single)
[C#] public Matrix(float, float, float, float, float, float);
[C++] public: Matrix(float, float, float, float, float, float);
[JScript] public function Matrix(float, float, float, float, float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(RectangleF, PointF())
[C#] public Matrix(RectangleF, PointF[]);
[C++] public: Matrix(RectangleF, PointF[]);
[JScript] public function Matrix(RectangleF, PointF[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Rectangle, Point())
[C#] public Matrix(Rectangle, Point[]);
[C++] public: Matrix(Rectangle, Point[]);
[JScript] public function Matrix(Rectangle, Point[]);

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace


Matrix Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public Matrix();
[C++]
public: Matrix();
[JScript]
public function Matrix();

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace | Matrix Constructor Overload List


Matrix Constructor (Single, Single, Single, Single, Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal m11 As Single, _
   ByVal m12 As Single, _
   ByVal m21 As Single, _
   ByVal m22 As Single, _
   ByVal dx As Single, _
   ByVal dy As Single _
)
[C#]
public Matrix(
   float m11,
   float m12,
   float m21,
   float m22,
   float dx,
   float dy
);
[C++]
public: Matrix(
   float m11,
   float m12,
   float m21,
   float m22,
   float dx,
   float dy
);
[JScript]
public function Matrix(
   m11 : float,
   m12 : float,
   m21 : float,
   m22 : float,
   dx : float,
   dy : float
);

Parameters

m11
[To be supplied.]
m12
[To be supplied.]
m21
[To be supplied.]
m22
[To be supplied.]
dx
[To be supplied.]
dy
[To be supplied.]

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace | Matrix Constructor Overload List


Matrix Constructor (RectangleF, PointF[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal rect As RectangleF, _
   ByVal plgpts() As PointF _
)
[C#]
public Matrix(
   RectangleF rect,
   PointF[] plgpts
);
[C++]
public: Matrix(
   RectangleF rect,
   PointF* plgpts[]
);
[JScript]
public function Matrix(
   rect : RectangleF,
   plgpts : PointF[]
);

Parameters

rect
[To be supplied.]
plgpts
[To be supplied.]

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace | Matrix Constructor Overload List


Matrix Constructor (Rectangle, Point[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal rect As Rectangle, _
   ByVal plgpts() As Point _
)
[C#]
public Matrix(
   Rectangle rect,
   Point[] plgpts
);
[C++]
public: Matrix(
   Rectangle rect,
   Point* plgpts[]
);
[JScript]
public function Matrix(
   rect : Rectangle,
   plgpts : Point[]
);

Parameters

rect
[To be supplied.]
plgpts
[To be supplied.]

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace | Matrix Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Matrix Properties

The properties of the Matrix class are listed below. For a complete list of Matrix class members, see the Matrix Members topic.

Public:

Elements | [To be supplied.]
IsIdentity | [To be supplied.]
IsInvertible | [To be supplied.]
OffsetX | [To be supplied.]
OffsetY | [To be supplied.]

See Also

Matrix Class | System.Drawing.Drawing2D Namespace


Matrix.Elements

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Elements As Single ()
[C#]
public float[] Elements {get;}
[C++]
public: __property float* get_Elements();
[JScript]
public function get Elements() : float[];

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace


Matrix.IsIdentity

[To be supplied.]

[Visual Basic]
Public ReadOnly Property IsIdentity As Boolean
[C#]
public bool IsIdentity {get;}
[C++]
public: __property bool get_IsIdentity();
[JScript]
public function get IsIdentity() : Boolean;

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace


Matrix.IsInvertible

[To be supplied.]

[Visual Basic]
Public ReadOnly Property IsInvertible As Boolean
[C#]
public bool IsInvertible {get;}
[C++]
public: __property bool get_IsInvertible();
[JScript]
public function get IsInvertible() : Boolean;

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace


Matrix.OffsetX

[To be supplied.]

[Visual Basic]
Public ReadOnly Property OffsetX As Single
[C#]
public float OffsetX {get;}
[C++]
public: __property float get_OffsetX();
[JScript]
public function get OffsetX() : float;

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace


Matrix.OffsetY

[To be supplied.]

[Visual Basic]
Public ReadOnly Property OffsetY As Single
[C#]
public float OffsetY {get;}
[C++]
public: __property float get_OffsetY();
[JScript]
public function get OffsetY() : float;

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Matrix Methods

The methods of the Matrix class are listed below. For a complete list of Matrix class members, see the Matrix Members topic.

Public:

Clone | [To be supplied.]
Dispose | [To be supplied.]
Equals | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
Invert | [To be supplied.]
Multiply | Overloaded. [To be supplied.]
Reset | [To be supplied.]
Rotate | Overloaded. [To be supplied.]
RotateAt | Overloaded. [To be supplied.]
Scale | Overloaded. [To be supplied.]
Shear | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.
TransformPoints | Overloaded. [To be supplied.]
TransformVectors | Overloaded. [To be supplied.]
Translate | Overloaded. [To be supplied.]
VectorTransformPoints | Overloaded. [To be supplied.]

Protected:

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Matrix Class | System.Drawing.Drawing2D Namespace


Matrix.Clone

[To be supplied.]

[Visual Basic]
Public Function Clone() As Matrix
[C#]
public Matrix Clone();
[C++]
public: Matrix* Clone();
[JScript]
public function Clone() : Matrix;

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace


Matrix.Dispose

[To be supplied.]

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[JScript]
public function Dispose();

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace


Matrix.Equals

[To be supplied.]

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
[To be supplied.]

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace


Matrix.Finalize

[To be supplied.]

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace


Matrix.Invert

[To be supplied.]

[Visual Basic]
Public Sub Invert()
[C#]
public void Invert();
[C++]
public: void Invert();
[JScript]
public function Invert();

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace


Matrix.Multiply

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub Multiply(Matrix)
[C#] public void Multiply(Matrix);
[C++] public: void Multiply(Matrix*);
[JScript] public function Multiply(Matrix);

[To be supplied.]

[Visual Basic] Overloads Public Sub Multiply(Matrix, MatrixOrder)
[C#] public void Multiply(Matrix, MatrixOrder);
[C++] public: void Multiply(Matrix*, MatrixOrder);
[JScript] public function Multiply(Matrix, MatrixOrder);

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace


Matrix.Multiply (Matrix)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Multiply( _
   ByVal matrix As Matrix _
)
[C#]
public void Multiply(
   Matrix matrix
);
[C++]
public: void Multiply(
   Matrix* matrix
);
[JScript]
public function Multiply(
   matrix : Matrix
);

Parameters

matrix
[To be supplied.]

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace | Matrix.Multiply Overload List


Matrix.Multiply (Matrix, MatrixOrder)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Multiply( _
   ByVal matrix As Matrix, _
   ByVal order As MatrixOrder _
)
[C#]
public void Multiply(
   Matrix matrix,
   MatrixOrder order
);
[C++]
public: void Multiply(
   Matrix* matrix,
   MatrixOrder order
);
[JScript]
public function Multiply(
   matrix : Matrix,
   order : MatrixOrder
);

Parameters

matrix
[To be supplied.]
order
[To be supplied.]

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace | Matrix.Multiply Overload List


Matrix.Reset

[To be supplied.]

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();
[C++]
public: void Reset();
[JScript]
public function Reset();

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace


Matrix.Rotate

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub Rotate(Single, MatrixOrder)
[C#] public void Rotate(float, MatrixOrder);
[C++] public: void Rotate(float, MatrixOrder);
[JScript] public function Rotate(float, MatrixOrder);

[To be supplied.]

[Visual Basic] Overloads Public Sub Rotate(Single)
[C#] public void Rotate(float);
[C++] public: void Rotate(float);
[JScript] public function Rotate(float);

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace


Matrix.Rotate (Single, MatrixOrder)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Rotate( _
   ByVal angle As Single, _
   ByVal order As MatrixOrder _
)
[C#]
public void Rotate(
   float angle,
   MatrixOrder order
);
[C++]
public: void Rotate(
   float angle,
   MatrixOrder order
);
[JScript]
public function Rotate(
   angle : float,
   order : MatrixOrder
);

Parameters

angle
[To be supplied.]
order
[To be supplied.]

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace | Matrix.Rotate Overload List


Matrix.Rotate (Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Rotate( _
   ByVal angle As Single _
)
[C#]
public void Rotate(
   float angle
);
[C++]
public: void Rotate(
   float angle
);
[JScript]
public function Rotate(
   angle : float
);

Parameters

angle
[To be supplied.]

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace | Matrix.Rotate Overload List


Matrix.RotateAt

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub RotateAt(Single, PointF)
[C#] public void RotateAt(float, PointF);
[C++] public: void RotateAt(float, PointF);
[JScript] public function RotateAt(float, PointF);

[To be supplied.]

[Visual Basic] Overloads Public Sub RotateAt(Single, PointF, MatrixOrder)
[C#] public void RotateAt(float, PointF, MatrixOrder);
[C++] public: void RotateAt(float, PointF, MatrixOrder);
[JScript] public function RotateAt(float, PointF, MatrixOrder);

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace


Matrix.RotateAt (Single, PointF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub RotateAt( _
   ByVal angle As Single, _
   ByVal point As PointF _
)
[C#]
public void RotateAt(
   float angle,
   PointF point
);
[C++]
public: void RotateAt(
   float angle,
   PointF point
);
[JScript]
public function RotateAt(
   angle : float,
   point : PointF
);

Parameters

angle
[To be supplied.]
point
[To be supplied.]

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace | Matrix.RotateAt Overload List


Matrix.RotateAt (Single, PointF, MatrixOrder)

[To be supplied.]

[Visual Basic]
Overloads Public Sub RotateAt( _
   ByVal angle As Single, _
   ByVal point As PointF, _
   ByVal order As MatrixOrder _
)
[C#]
public void RotateAt(
   float angle,
   PointF point,
   MatrixOrder order
);
[C++]
public: void RotateAt(
   float angle,
   PointF point,
   MatrixOrder order
);
[JScript]
public function RotateAt(
   angle : float,
   point : PointF,
   order : MatrixOrder
);

Parameters

angle
[To be supplied.]
point
[To be supplied.]
order
[To be supplied.]

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace | Matrix.RotateAt Overload List


Matrix.Scale

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub Scale(Single, Single, MatrixOrder)
[C#] public void Scale(float, float, MatrixOrder);
[C++] public: void Scale(float, float, MatrixOrder);
[JScript] public function Scale(float, float, MatrixOrder);

[To be supplied.]

[Visual Basic] Overloads Public Sub Scale(Single, Single)
[C#] public void Scale(float, float);
[C++] public: void Scale(float, float);
[JScript] public function Scale(float, float);

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace


Matrix.Scale (Single, Single, MatrixOrder)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Scale( _
   ByVal scaleX As Single, _
   ByVal scaleY As Single, _
   ByVal order As MatrixOrder _
)
[C#]
public void Scale(
   float scaleX,
   float scaleY,
   MatrixOrder order
);
[C++]
public: void Scale(
   float scaleX,
   float scaleY,
   MatrixOrder order
);
[JScript]
public function Scale(
   scaleX : float,
   scaleY : float,
   order : MatrixOrder
);

Parameters

scaleX
[To be supplied.]
scaleY
[To be supplied.]
order
[To be supplied.]

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace | Matrix.Scale Overload List


Matrix.Scale (Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Scale( _
   ByVal scaleX As Single, _
   ByVal scaleY As Single _
)
[C#]
public void Scale(
   float scaleX,
   float scaleY
);
[C++]
public: void Scale(
   float scaleX,
   float scaleY
);
[JScript]
public function Scale(
   scaleX : float,
   scaleY : float
);

Parameters

scaleX
[To be supplied.]
scaleY
[To be supplied.]

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace | Matrix.Scale Overload List


Matrix.Shear

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub Shear(Single, Single)
[C#] public void Shear(float, float);
[C++] public: void Shear(float, float);
[JScript] public function Shear(float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub Shear(Single, Single, MatrixOrder)
[C#] public void Shear(float, float, MatrixOrder);
[C++] public: void Shear(float, float, MatrixOrder);
[JScript] public function Shear(float, float, MatrixOrder);

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace


Matrix.Shear (Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Shear( _
   ByVal shearX As Single, _
   ByVal shearY As Single _
)
[C#]
public void Shear(
   float shearX,
   float shearY
);
[C++]
public: void Shear(
   float shearX,
   float shearY
);
[JScript]
public function Shear(
   shearX : float,
   shearY : float
);

Parameters

shearX
[To be supplied.]
shearY
[To be supplied.]

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace | Matrix.Shear Overload List


Matrix.Shear (Single, Single, MatrixOrder)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Shear( _
   ByVal shearX As Single, _
   ByVal shearY As Single, _
   ByVal order As MatrixOrder _
)
[C#]
public void Shear(
   float shearX,
   float shearY,
   MatrixOrder order
);
[C++]
public: void Shear(
   float shearX,
   float shearY,
   MatrixOrder order
);
[JScript]
public function Shear(
   shearX : float,
   shearY : float,
   order : MatrixOrder
);

Parameters

shearX
[To be supplied.]
shearY
[To be supplied.]
order
[To be supplied.]

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace | Matrix.Shear Overload List


Matrix.TransformPoints

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub TransformPoints(PointF())
[C#] public void TransformPoints(PointF[]);
[C++] public: void TransformPoints(PointF*[]);
[JScript] public function TransformPoints(PointF[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub TransformPoints(Point())
[C#] public void TransformPoints(Point[]);
[C++] public: void TransformPoints(Point*[]);
[JScript] public function TransformPoints(Point[]);

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace


Matrix.TransformPoints (PointF[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub TransformPoints( _
   ByVal pts() As PointF _
)
[C#]
public void TransformPoints(
   PointF[] pts
);
[C++]
public: void TransformPoints(
   PointF* pts[]
);
[JScript]
public function TransformPoints(
   pts : PointF[]
);

Parameters

pts
[To be supplied.]

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace | Matrix.TransformPoints Overload List


Matrix.TransformPoints (Point[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub TransformPoints( _
   ByVal pts() As Point _
)
[C#]
public void TransformPoints(
   Point[] pts
);
[C++]
public: void TransformPoints(
   Point* pts[]
);
[JScript]
public function TransformPoints(
   pts : Point[]
);

Parameters

pts
[To be supplied.]

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace | Matrix.TransformPoints Overload List


Matrix.TransformVectors

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub TransformVectors(PointF())
[C#] public void TransformVectors(PointF[]);
[C++] public: void TransformVectors(PointF*[]);
[JScript] public function TransformVectors(PointF[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub TransformVectors(Point())
[C#] public void TransformVectors(Point[]);
[C++] public: void TransformVectors(Point*[]);
[JScript] public function TransformVectors(Point[]);

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace


Matrix.TransformVectors (PointF[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub TransformVectors( _
   ByVal pts() As PointF _
)
[C#]
public void TransformVectors(
   PointF[] pts
);
[C++]
public: void TransformVectors(
   PointF* pts[]
);
[JScript]
public function TransformVectors(
   pts : PointF[]
);

Parameters

pts
[To be supplied.]

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace | Matrix.TransformVectors Overload List


Matrix.TransformVectors (Point[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub TransformVectors( _
   ByVal pts() As Point _
)
[C#]
public void TransformVectors(
   Point[] pts
);
[C++]
public: void TransformVectors(
   Point* pts[]
);
[JScript]
public function TransformVectors(
   pts : Point[]
);

Parameters

pts
[To be supplied.]

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace | Matrix.TransformVectors Overload List


Matrix.Translate

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub Translate(Single, Single)
[C#] public void Translate(float, float);
[C++] public: void Translate(float, float);
[JScript] public function Translate(float, float);

[To be supplied.]

[Visual Basic] Overloads Public Sub Translate(Single, Single, MatrixOrder)
[C#] public void Translate(float, float, MatrixOrder);
[C++] public: void Translate(float, float, MatrixOrder);
[JScript] public function Translate(float, float, MatrixOrder);

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace


Matrix.Translate (Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Translate( _
   ByVal offsetX As Single, _
   ByVal offsetY As Single _
)
[C#]
public void Translate(
   float offsetX,
   float offsetY
);
[C++]
public: void Translate(
   float offsetX,
   float offsetY
);
[JScript]
public function Translate(
   offsetX : float,
   offsetY : float
);

Parameters

offsetX
[To be supplied.]
offsetY
[To be supplied.]

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace | Matrix.Translate Overload List


Matrix.Translate (Single, Single, MatrixOrder)

[To be supplied.]

[Visual Basic]
Overloads Public Sub Translate( _
   ByVal offsetX As Single, _
   ByVal offsetY As Single, _
   ByVal order As MatrixOrder _
)
[C#]
public void Translate(
   float offsetX,
   float offsetY,
   MatrixOrder order
);
[C++]
public: void Translate(
   float offsetX,
   float offsetY,
   MatrixOrder order
);
[JScript]
public function Translate(
   offsetX : float,
   offsetY : float,
   order : MatrixOrder
);

Parameters

offsetX
[To be supplied.]
offsetY
[To be supplied.]
order
[To be supplied.]

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace | Matrix.Translate Overload List


Matrix.VectorTransformPoints

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub VectorTransformPoints(PointF())
[C#] public void VectorTransformPoints(PointF[]);
[C++] public: void VectorTransformPoints(PointF*[]);
[JScript] public function VectorTransformPoints(PointF[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub VectorTransformPoints(Point())
[C#] public void VectorTransformPoints(Point[]);
[C++] public: void VectorTransformPoints(Point*[]);
[JScript] public function VectorTransformPoints(Point[]);

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace


Matrix.VectorTransformPoints (PointF[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub VectorTransformPoints( _
   ByVal pts() As PointF _
)
[C#]
public void VectorTransformPoints(
   PointF[] pts
);
[C++]
public: void VectorTransformPoints(
   PointF* pts[]
);
[JScript]
public function VectorTransformPoints(
   pts : PointF[]
);

Parameters

pts
[To be supplied.]

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace | Matrix.VectorTransformPoints Overload List


Matrix.VectorTransformPoints (Point[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub VectorTransformPoints( _
   ByVal pts() As Point _
)
[C#]
public void VectorTransformPoints(
   Point[] pts
);
[C++]
public: void VectorTransformPoints(
   Point* pts[]
);
[JScript]
public function VectorTransformPoints(
   pts : Point[]
);

Parameters

pts
[To be supplied.]

See Also

Matrix Class | Matrix Members | System.Drawing.Drawing2D Namespace | Matrix.VectorTransformPoints Overload List


MatrixOrder Enumeration

[To be supplied.]

[Visual Basic]
Public Enum MatrixOrder
[C#]
public enum MatrixOrder
[C++]
public enum MatrixOrder

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Append | [To be supplied.]
Prepend | [To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

System.Drawing.Drawing2D Namespace


PathData Class

[To be supplied.]

Object
PathData

[Visual Basic]
NotInheritable Public Class PathData
[C#]
public sealed class PathData
[C++]
public __gc __sealed class PathData
[JScript]
public class PathData

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

PathData Members | System.Drawing.Drawing2D Namespace


PathData Members

Public:

Constructor

PathData Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

points | [To be supplied.]
types | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PathData Class | System.Drawing.Drawing2D Namespace


PathData Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public PathData();
[C++]
public: PathData();
[JScript]
public function PathData();

See Also

PathData Class | PathData Members | System.Drawing.Drawing2D Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PathData Fields

The fields of the PathData class are listed below. For a complete list of PathData class members, see the PathData Members topic.

Public:

points | [To be supplied.]
types | [To be supplied.]

See Also

PathData Class | System.Drawing.Drawing2D Namespace


PathData.points

[To be supplied.]

[Visual Basic]
Public points() As PointF
[C#]
public PointF[] points;
[C++]
public: PointF* points[];
[JScript]
public var points : PointF[];

See Also

PathData Class | PathData Members | System.Drawing.Drawing2D Namespace


PathData.types

[To be supplied.]

[Visual Basic]
Public types() As Byte
[C#]
public byte[] types;
[C++]
public: unsigned char* types[];
[JScript]
public var types : Byte[];

See Also

PathData Class | PathData Members | System.Drawing.Drawing2D Namespace


PathGradientBrush Class

[To be supplied.]

Object
MarshalByRefObject
Brush
PathGradientBrush

[Visual Basic]
NotInheritable Public Class PathGradientBrush
   Inherits Brush
[C#]
public sealed class PathGradientBrush : Brush
[C++]
public __gc __sealed class PathGradientBrush : public Brush
[JScript]
public class PathGradientBrush extends Brush

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

PathGradientBrush Members | System.Drawing.Drawing2D Namespace


PathGradientBrush Members

Public:

Constructor

PathGradientBrush Constructor Overloaded. [To be supplied.]

Properties

Blend | [To be supplied.]
CenterColor | [To be supplied.]
CenterPoint | [To be supplied.]
FocusScales | [To be supplied.]
GammaCorrected | [To be supplied.]
GammaCorrection | [To be supplied.]
GraphicsPath | [To be supplied.]
InterpolationColors | [To be supplied.]
Polygon | [To be supplied.]
Rectangle | [To be supplied.]
SurroundColors | [To be supplied.]
Transform | [To be supplied.]
WrapMode | [To be supplied.]

Methods

Clone | [To be supplied.]
Dispose (inherited from Brush) | Deletes this Brush.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
MultiplyTransform | Overloaded. [To be supplied.]
ResetTransform | [To be supplied.]
RotateTransform | Overloaded. [To be supplied.]
ScaleTransform | Overloaded. [To be supplied.]
SetBlendTriangularShape | Overloaded. [To be supplied.]
SetSigmaBellShape | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.
TranslateTransform | Overloaded. [To be supplied.]

Protected:

Methods

Finalize (inherited from Brush) | Releases memory allocated for this Brush.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PathGradientBrush Class | System.Drawing.Drawing2D Namespace


PathGradientBrush Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(PointF())
[C#] public PathGradientBrush(PointF[]);
[C++] public: PathGradientBrush(PointF*[]);
[JScript] public function PathGradientBrush(PointF[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(PointF(), WrapMode)
[C#] public PathGradientBrush(PointF[], WrapMode);
[C++] public: PathGradientBrush(PointF*[], WrapMode);
[JScript] public function PathGradientBrush(PointF[], WrapMode);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Point())
[C#] public PathGradientBrush(Point[]);
[C++] public: PathGradientBrush(Point*[]);
[JScript] public function PathGradientBrush(Point[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Point(), WrapMode)
[C#] public PathGradientBrush(Point[], WrapMode);
[C++] public: PathGradientBrush(Point*[], WrapMode);
[JScript] public function PathGradientBrush(Point[], WrapMode);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(GraphicsPath)
[C#] public PathGradientBrush(GraphicsPath);
[C++] public: PathGradientBrush(GraphicsPath*);
[JScript] public function PathGradientBrush(GraphicsPath);

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace


PathGradientBrush Constructor (PointF[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal points() As PointF _
)
[C#]
public PathGradientBrush(
   PointF[] points
);
[C++]
public: PathGradientBrush(
   PointF* points[]
);
[JScript]
public function PathGradientBrush(
   points : PointF[]
);

Parameters

points
[To be supplied.]

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace | PathGradientBrush Constructor Overload List


PathGradientBrush Constructor (PointF[], WrapMode)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal points() As PointF, _
   ByVal wrapMode As WrapMode _
)
[C#]
public PathGradientBrush(
   PointF[] points,
   WrapMode wrapMode
);
[C++]
public: PathGradientBrush(
   PointF* points[],
   WrapMode wrapMode
);
[JScript]
public function PathGradientBrush(
   points : PointF[],
   wrapMode : WrapMode
);

Parameters

points
[To be supplied.]
wrapMode
[To be supplied.]

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace | PathGradientBrush Constructor Overload List


PathGradientBrush Constructor (Point[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal points() As Point _
)
[C#]
public PathGradientBrush(
   Point[] points
);
[C++]
public: PathGradientBrush(
   Point* points[]
);
[JScript]
public function PathGradientBrush(
   points : Point[]
);

Parameters

points
[To be supplied.]

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace | PathGradientBrush Constructor Overload List


PathGradientBrush Constructor (Point[], WrapMode)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal points() As Point, _
   ByVal wrapMode As WrapMode _
)
[C#]
public PathGradientBrush(
   Point[] points,
   WrapMode wrapMode
);
[C++]
public: PathGradientBrush(
   Point* points[],
   WrapMode wrapMode
);
[JScript]
public function PathGradientBrush(
   points : Point[],
   wrapMode : WrapMode
);

Parameters

points
[To be supplied.]
wrapMode
[To be supplied.]

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace | PathGradientBrush Constructor Overload List


PathGradientBrush Constructor (GraphicsPath)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As GraphicsPath _
)
[C#]
public PathGradientBrush(
   GraphicsPath path
);
[C++]
public: PathGradientBrush(
   GraphicsPath* path
);
[JScript]
public function PathGradientBrush(
   path : GraphicsPath
);

Parameters

path
[To be supplied.]

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace | PathGradientBrush Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PathGradientBrush Properties

The properties of the PathGradientBrush class are listed below. For a complete list of PathGradientBrush class members, see the PathGradientBrush Members topic.

Public:

Blend | [To be supplied.]
CenterColor | [To be supplied.]
CenterPoint | [To be supplied.]
FocusScales | [To be supplied.]
GammaCorrected | [To be supplied.]
GammaCorrection | [To be supplied.]
GraphicsPath | [To be supplied.]
InterpolationColors | [To be supplied.]
Polygon | [To be supplied.]
Rectangle | [To be supplied.]
SurroundColors | [To be supplied.]
Transform | [To be supplied.]
WrapMode | [To be supplied.]

See Also

PathGradientBrush Class | System.Drawing.Drawing2D Namespace


PathGradientBrush.Blend

[To be supplied.]

[Visual Basic]
Public Property Blend As Blend
[C#]
public Blend Blend {get; set;}
[C++]
public: __property Blend* get_Blend();
public: __property void set_Blend(Blend*);
[JScript]
public function get Blend() : Blend;
public function set Blend(Blend);

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace


PathGradientBrush.CenterColor

[To be supplied.]

[Visual Basic]
Public Property CenterColor As Color
[C#]
public Color CenterColor {get; set;}
[C++]
public: __property Color get_CenterColor();
public: __property void set_CenterColor(Color);
[JScript]
public function get CenterColor() : Color;
public function set CenterColor(Color);

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace


PathGradientBrush.CenterPoint

[To be supplied.]

[Visual Basic]
Public Property CenterPoint As PointF
[C#]
public PointF CenterPoint {get; set;}
[C++]
public: __property PointF get_CenterPoint();
public: __property void set_CenterPoint(PointF);
[JScript]
public function get CenterPoint() : PointF;
public function set CenterPoint(PointF);

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace


PathGradientBrush.FocusScales

[To be supplied.]

[Visual Basic]
Public Property FocusScales As PointF
[C#]
public PointF FocusScales {get; set;}
[C++]
public: __property PointF get_FocusScales();
public: __property void set_FocusScales(PointF);
[JScript]
public function get FocusScales() : PointF;
public function set FocusScales(PointF);

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace


PathGradientBrush.GammaCorrected

[To be supplied.]

[Visual Basic]
Public Property GammaCorrected As Boolean
[C#]
public bool GammaCorrected {get; set;}
[C++]
public: __property bool get_GammaCorrected();
public: __property void set_GammaCorrected(bool);
[JScript]
public function get GammaCorrected() : Boolean;
public function set GammaCorrected(Boolean);

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace


PathGradientBrush.GammaCorrection

[To be supplied.]

[Visual Basic]
Public Property GammaCorrection As Boolean
[C#]
public bool GammaCorrection {get; set;}
[C++]
public: __property bool get_GammaCorrection();
public: __property void set_GammaCorrection(bool);
[JScript]
public function get GammaCorrection() : Boolean;
public function set GammaCorrection(Boolean);

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace


PathGradientBrush.GraphicsPath

[To be supplied.]

[Visual Basic]
Public Property GraphicsPath As GraphicsPath
[C#]
public GraphicsPath GraphicsPath {get; set;}
[C++]
public: __property GraphicsPath* get_GraphicsPath();
public: __property void set_GraphicsPath(GraphicsPath*);
[JScript]
public function get GraphicsPath() : GraphicsPath;
public function set GraphicsPath(GraphicsPath);

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace


PathGradientBrush.InterpolationColors

[To be supplied.]

[Visual Basic]
Public Property InterpolationColors As ColorBlend
[C#]
public ColorBlend InterpolationColors {get; set;}
[C++]
public: __property ColorBlend* get_InterpolationColors();
public: __property void set_InterpolationColors(ColorBlend*);
[JScript]
public function get InterpolationColors() : ColorBlend;
public function set InterpolationColors(ColorBlend);

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace


PathGradientBrush.Polygon

[To be supplied.]

[Visual Basic]
Public Property Polygon As PointF ()
[C#]
public PointF[] Polygon {get; set;}
[C++]
public: __property PointF* get_Polygon();
public: __property void set_Polygon(PointF*[]);
[JScript]
public function get Polygon() : PointF[];
public function set Polygon(PointF[]);

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace


PathGradientBrush.Rectangle

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Rectangle As RectangleF
[C#]
public RectangleF Rectangle {get;}
[C++]
public: __property RectangleF get_Rectangle();
[JScript]
public function get Rectangle() : RectangleF;

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace


PathGradientBrush.SurroundColors

[To be supplied.]

[Visual Basic]
Public Property SurroundColors As Color ()
[C#]
public Color[] SurroundColors {get; set;}
[C++]
public: __property Color* get_SurroundColors();
public: __property void set_SurroundColors(Color*[]);
[JScript]
public function get SurroundColors() : Color[];
public function set SurroundColors(Color[]);

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace


PathGradientBrush.Transform

[To be supplied.]

[Visual Basic]
Public Property Transform As Matrix
[C#]
public Matrix Transform {get; set;}
[C++]
public: __property Matrix* get_Transform();
public: __property void set_Transform(Matrix*);
[JScript]
public function get Transform() : Matrix;
public function set Transform(Matrix);

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace


PathGradientBrush.WrapMode

[To be supplied.]

[Visual Basic]
Public Property WrapMode As WrapMode
[C#]
public WrapMode WrapMode {get; set;}
[C++]
public: __property WrapMode get_WrapMode();
public: __property void set_WrapMode(WrapMode);
[JScript]
public function get WrapMode() : WrapMode;
public function set WrapMode(WrapMode);

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PathGradientBrush Methods

The methods of the PathGradientBrush class are listed below. For a complete list of PathGradientBrush class members, see the PathGradientBrush Members topic.

Public:

Clone | [To be supplied.]
Dispose (inherited from Brush) | Deletes this Brush.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
MultiplyTransform | Overloaded. [To be supplied.]
ResetTransform | [To be supplied.]
RotateTransform | Overloaded. [To be supplied.]
ScaleTransform | Overloaded. [To be supplied.]
SetBlendTriangularShape | Overloaded. [To be supplied.]
SetSigmaBellShape | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.
TranslateTransform | Overloaded. [To be supplied.]

Protected:

Finalize (inherited from Brush) | Releases memory allocated for this Brush.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PathGradientBrush Class | System.Drawing.Drawing2D Namespace


PathGradientBrush.Clone

[To be supplied.]

[Visual Basic]
Overrides Public Function Clone() As Object
[C#]
public override object Clone();
[C++]
public: override Object* Clone();
[JScript]
public override function Clone() : Object;

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace


PathGradientBrush.MultiplyTransform

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub MultiplyTransform(Matrix)
[C#] public void MultiplyTransform(Matrix);
[C++] public: void MultiplyTransform(Matrix*);
[JScript] public function MultiplyTransform(Matrix);

[To be supplied.]

[Visual Basic] Overloads Public Sub MultiplyTransform(Matrix, MatrixOrder)
[C#] public void MultiplyTransform(Matrix, MatrixOrder);
[C++] public: void MultiplyTransform(Matrix*, MatrixOrder);
[JScript] public function MultiplyTransform(Matrix, MatrixOrder);

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace


PathGradientBrush.MultiplyTransform (Matrix)

[To be supplied.]

[Visual Basic]
Overloads Public Sub MultiplyTransform( _
   ByVal matrix As Matrix _
)
[C#]
public void MultiplyTransform(
   Matrix matrix
);
[C++]
public: void MultiplyTransform(
   Matrix* matrix
);
[JScript]
public function MultiplyTransform(
   matrix : Matrix
);

Parameters

matrix
[To be supplied.]

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace | PathGradientBrush.MultiplyTransform Overload List


PathGradientBrush.MultiplyTransform (Matrix, MatrixOrder)

[To be supplied.]

[Visual Basic]
Overloads Public Sub MultiplyTransform( _
   ByVal matrix As Matrix, _
   ByVal order As MatrixOrder _
)
[C#]
public void MultiplyTransform(
   Matrix matrix,
   MatrixOrder order
);
[C++]
public: void MultiplyTransform(
   Matrix* matrix,
   MatrixOrder order
);
[JScript]
public function MultiplyTransform(
   matrix : Matrix,
   order : MatrixOrder
);

Parameters

matrix
[To be supplied.]
order
[To be supplied.]

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace | PathGradientBrush.MultiplyTransform Overload List


PathGradientBrush.ResetTransform

[To be supplied.]

[Visual Basic]
Public Sub ResetTransform()
[C#]
public void ResetTransform();
[C++]
public: void ResetTransform();
[JScript]
public function ResetTransform();

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace


PathGradientBrush.RotateTransform

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub RotateTransform(Single)
[C#] public void RotateTransform(float);
[C++] public: void RotateTransform(float);
[JScript] public function RotateTransform(float);

[To be supplied.]

[Visual Basic] Overloads Public Sub RotateTransform(Single, MatrixOrder)
[C#] public void RotateTransform(float, MatrixOrder);
[C++] public: void RotateTransform(float, MatrixOrder);
[JScript] public function RotateTransform(float, MatrixOrder);

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace


PathGradientBrush.RotateTransform (Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub RotateTransform( _
   ByVal angle As Single _
)
[C#]
public void RotateTransform(
   float angle
);
[C++]
public: void RotateTransform(
   float angle
);
[JScript]
public function RotateTransform(
   angle : float
);

Parameters

angle
[To be supplied.]

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace | PathGradientBrush.RotateTransform Overload List


PathGradientBrush.RotateTransform (Single, MatrixOrder)

[To be supplied.]

[Visual Basic]
Overloads Public Sub RotateTransform( _
   ByVal angle As Single, _
   ByVal order As MatrixOrder _
)
[C#]
public void RotateTransform(
   float angle,
   MatrixOrder order
);
[C++]
public: void RotateTransform(
   float angle,
   MatrixOrder order
);
[JScript]
public function RotateTransform(
   angle : float,
   order : MatrixOrder
);

Parameters

angle
[To be supplied.]
order
[To be supplied.]

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace | PathGradientBrush.RotateTransform Overload List


PathGradientBrush.ScaleTransform

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub ScaleTransform(Single, Single, MatrixOrder)
[C#] public void ScaleTransform(float, float, MatrixOrder);
[C++] public: void ScaleTransform(float, float, MatrixOrder);
[JScript] public function ScaleTransform(float, float, MatrixOrder);

[To be supplied.]

[Visual Basic] Overloads Public Sub ScaleTransform(Single, Single)
[C#] public void ScaleTransform(float, float);
[C++] public: void ScaleTransform(float, float);
[JScript] public function ScaleTransform(float, float);

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace


PathGradientBrush.ScaleTransform (Single, Single, MatrixOrder)

[To be supplied.]

[Visual Basic]
Overloads Public Sub ScaleTransform( _
   ByVal sx As Single, _
   ByVal sy As Single, _
   ByVal order As MatrixOrder _
)
[C#]
public void ScaleTransform(
   float sx,
   float sy,
   MatrixOrder order
);
[C++]
public: void ScaleTransform(
   float sx,
   float sy,
   MatrixOrder order
);
[JScript]
public function ScaleTransform(
   sx : float,
   sy : float,
   order : MatrixOrder
);

Parameters

sx
[To be supplied.]
sy
[To be supplied.]
order
[To be supplied.]

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace | PathGradientBrush.ScaleTransform Overload List


PathGradientBrush.ScaleTransform (Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub ScaleTransform( _
   ByVal sx As Single, _
   ByVal sy As Single _
)
[C#]
public void ScaleTransform(
   float sx,
   float sy
);
[C++]
public: void ScaleTransform(
   float sx,
   float sy
);
[JScript]
public function ScaleTransform(
   sx : float,
   sy : float
);

Parameters

sx
[To be supplied.]
sy
[To be supplied.]

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace | PathGradientBrush.ScaleTransform Overload List


PathGradientBrush.SetBlendTriangularShape

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub SetBlendTriangularShape(Single)
[C#] public void SetBlendTriangularShape(float);
[C++] public: void SetBlendTriangularShape(float);
[JScript] public function SetBlendTriangularShape(float);

[To be supplied.]

[Visual Basic] Overloads Public Sub SetBlendTriangularShape(Single, Single)
[C#] public void SetBlendTriangularShape(float, float);
[C++] public: void SetBlendTriangularShape(float, float);
[JScript] public function SetBlendTriangularShape(float, float);

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace


PathGradientBrush.SetBlendTriangularShape (Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetBlendTriangularShape( _
   ByVal focus As Single _
)
[C#]
public void SetBlendTriangularShape(
   float focus
);
[C++]
public: void SetBlendTriangularShape(
   float focus
);
[JScript]
public function SetBlendTriangularShape(
   focus : float
);

Parameters

focus
[To be supplied.]

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace | PathGradientBrush.SetBlendTriangularShape Overload List


PathGradientBrush.SetBlendTriangularShape (Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetBlendTriangularShape( _
   ByVal focus As Single, _
   ByVal scale As Single _
)
[C#]
public void SetBlendTriangularShape(
   float focus,
   float scale
);
[C++]
public: void SetBlendTriangularShape(
   float focus,
   float scale
);
[JScript]
public function SetBlendTriangularShape(
   focus : float,
   scale : float
);

Parameters

focus
[To be supplied.]
scale
[To be supplied.]

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace | PathGradientBrush.SetBlendTriangularShape Overload List


PathGradientBrush.SetSigmaBellShape

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub SetSigmaBellShape(Single)
[C#] public void SetSigmaBellShape(float);
[C++] public: void SetSigmaBellShape(float);
[JScript] public function SetSigmaBellShape(float);

[To be supplied.]

[Visual Basic] Overloads Public Sub SetSigmaBellShape(Single, Single)
[C#] public void SetSigmaBellShape(float, float);
[C++] public: void SetSigmaBellShape(float, float);
[JScript] public function SetSigmaBellShape(float, float);

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace


PathGradientBrush.SetSigmaBellShape (Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetSigmaBellShape( _
   ByVal focus As Single _
)
[C#]
public void SetSigmaBellShape(
   float focus
);
[C++]
public: void SetSigmaBellShape(
   float focus
);
[JScript]
public function SetSigmaBellShape(
   focus : float
);

Parameters

focus
[To be supplied.]

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace | PathGradientBrush.SetSigmaBellShape Overload List


PathGradientBrush.SetSigmaBellShape (Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetSigmaBellShape( _
   ByVal focus As Single, _
   ByVal scale As Single _
)
[C#]
public void SetSigmaBellShape(
   float focus,
   float scale
);
[C++]
public: void SetSigmaBellShape(
   float focus,
   float scale
);
[JScript]
public function SetSigmaBellShape(
   focus : float,
   scale : float
);

Parameters

focus
[To be supplied.]
scale
[To be supplied.]

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace | PathGradientBrush.SetSigmaBellShape Overload List


PathGradientBrush.TranslateTransform

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub TranslateTransform(Single, Single, MatrixOrder)
[C#] public void TranslateTransform(float, float, MatrixOrder);
[C++] public: void TranslateTransform(float, float, MatrixOrder);
[JScript] public function TranslateTransform(float, float, MatrixOrder);

[To be supplied.]

[Visual Basic] Overloads Public Sub TranslateTransform(Single, Single)
[C#] public void TranslateTransform(float, float);
[C++] public: void TranslateTransform(float, float);
[JScript] public function TranslateTransform(float, float);

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace


PathGradientBrush.TranslateTransform (Single, Single, MatrixOrder)

[To be supplied.]

[Visual Basic]
Overloads Public Sub TranslateTransform( _
   ByVal dx As Single, _
   ByVal dy As Single, _
   ByVal order As MatrixOrder _
)
[C#]
public void TranslateTransform(
   float dx,
   float dy,
   MatrixOrder order
);
[C++]
public: void TranslateTransform(
   float dx,
   float dy,
   MatrixOrder order
);
[JScript]
public function TranslateTransform(
   dx : float,
   dy : float,
   order : MatrixOrder
);

Parameters

dx
[To be supplied.]
dy
[To be supplied.]
order
[To be supplied.]

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace | PathGradientBrush.TranslateTransform Overload List


PathGradientBrush.TranslateTransform (Single, Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub TranslateTransform( _
   ByVal dx As Single, _
   ByVal dy As Single _
)
[C#]
public void TranslateTransform(
   float dx,
   float dy
);
[C++]
public: void TranslateTransform(
   float dx,
   float dy
);
[JScript]
public function TranslateTransform(
   dx : float,
   dy : float
);

Parameters

dx
[To be supplied.]
dy
[To be supplied.]

See Also

PathGradientBrush Class | PathGradientBrush Members | System.Drawing.Drawing2D Namespace | PathGradientBrush.TranslateTransform Overload List


PathPointType Enumeration

[To be supplied.]

[Visual Basic]
Public Enum PathPointType
[C#]
public enum PathPointType
[C++]
public enum PathPointType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Bezier | [To be supplied.]
Bezier2 | [To be supplied.]
Bezier3 | [To be supplied.]
Bezier4 | [To be supplied.]
Bezier5 | [To be supplied.]
Bezier6 | [To be supplied.]
CloseSubpath | [To be supplied.]
DashMode | [To be supplied.]
Line | [To be supplied.]
PathMarker | [To be supplied.]
PathTypeMask | [To be supplied.]
Start | [To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

System.Drawing.Drawing2D Namespace


PenAlignment Enumeration

[To be supplied.]

[Visual Basic]
Public Enum PenAlignment
[C#]
public enum PenAlignment
[C++]
public enum PenAlignment

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Center | [To be supplied.]
Inset | [To be supplied.]
Left | [To be supplied.]
Outset | [To be supplied.]
Right | [To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

System.Drawing.Drawing2D Namespace


PenType Enumeration

[To be supplied.]

[Visual Basic]
Public Enum PenType
[C#]
public enum PenType
[C++]
public enum PenType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
HatchFill | [To be supplied.]
LinearGradient | [To be supplied.]
PathGradient | [To be supplied.]
SolidColor | [To be supplied.]
TextureFill | [To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

System.Drawing.Drawing2D Namespace


PixelOffsetMode Enumeration

[To be supplied.]

[Visual Basic]
Public Enum PixelOffsetMode
[C#]
public enum PixelOffsetMode
[C++]
public enum PixelOffsetMode

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Default | [To be supplied.]
Half | [To be supplied.]
HighQuality | [To be supplied.]
HighSpeed | [To be supplied.]
Invalid | [To be supplied.]
None | [To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

System.Drawing.Drawing2D Namespace


QualityMode Enumeration

[To be supplied.]

[Visual Basic]
Public Enum QualityMode
[C#]
public enum QualityMode
[C++]
public enum QualityMode

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Default | [To be supplied.]
High | [To be supplied.]
Invalid | [To be supplied.]
Low | [To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

System.Drawing.Drawing2D Namespace


RegionData Class

[To be supplied.]

Object
RegionData

[Visual Basic]
NotInheritable Public Class RegionData
[C#]
public sealed class RegionData
[C++]
public __gc __sealed class RegionData
[JScript]
public class RegionData

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

RegionData Members | System.Drawing.Drawing2D Namespace


RegionData Members

Public:

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

regionData [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RegionData Class | System.Drawing.Drawing2D Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RegionData Fields

The fields of the RegionData class are listed below. For a complete list of RegionData class members, see the RegionData Members topic.

Public:

regionData [To be supplied.]

See Also

RegionData Class | System.Drawing.Drawing2D Namespace


RegionData.regionData

[To be supplied.]

[Visual Basic]
Public regionData() As Byte
[C#]
public byte[] regionData;
[C++]
public: unsigned char* regionData[];
[JScript]
public var regionData : Byte[];

See Also

RegionData Class | RegionData Members | System.Drawing.Drawing2D Namespace


RenderingHint Enumeration

[To be supplied.]

[Visual Basic]
Public Enum RenderingHint
[C#]
public enum RenderingHint
[C++]
public enum RenderingHint

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
AntiAliased | [To be supplied.]
None | [To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

System.Drawing.Drawing2D Namespace


SmoothingMode Enumeration

[To be supplied.]

[Visual Basic]
Public Enum SmoothingMode
[C#]
public enum SmoothingMode
[C++]
public enum SmoothingMode

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
AntiAlias | [To be supplied.]
Default | [To be supplied.]
HighQuality | [To be supplied.]
HighSpeed | [To be supplied.]
Invalid | [To be supplied.]
None | [To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

System.Drawing.Drawing2D Namespace


WarpMode Enumeration

[To be supplied.]

[Visual Basic]
Public Enum WarpMode
[C#]
public enum WarpMode
[C++]
public enum WarpMode

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Bilinear | [To be supplied.]
Perspective | [To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

System.Drawing.Drawing2D Namespace


WrapMode Enumeration

[To be supplied.]

[Visual Basic]
Public Enum WrapMode
[C#]
public enum WrapMode
[C++]
public enum WrapMode

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Clamp | [To be supplied.]
Tile | [To be supplied.]
TileFlipX | [To be supplied.]
TileFlipXY | [To be supplied.]
TileFlipY | [To be supplied.]

Requirements

Namespace: System.Drawing.Drawing2D

Assembly: System.Drawing.dll

See Also

System.Drawing.Drawing2D Namespace


System.Drawing.Imaging

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Drawing.Imaging Namespace

Classes

Class | Description
APMFileHeader | [To be supplied.]
BitmapData | [To be supplied.]
ColorMap | [To be supplied.]
ColorMatrix | [To be supplied.]
ColorPalette | [To be supplied.]
Decoder | [To be supplied.]
Encoder | [To be supplied.]
EncoderParameter | [To be supplied.]
EncoderParameters | [To be supplied.]
ImageAttributes | [To be supplied.]
ImageCodecInfo | [To be supplied.]
ImageFormat | [To be supplied.]
Metafile | [To be supplied.]
MetafileHeader | [To be supplied.]
METAHEADER | [To be supplied.]
PropertyItem | [To be supplied.]

Enumerations

Enumeration | Description
ColorAdjustType | [To be supplied.]
ColorChannelFlags | [To be supplied.]
ColorMapType | [To be supplied.]
ColorMatrixFlags | [To be supplied.]
ColorMode | [To be supplied.]
EmfPlusRecordType | [To be supplied.]
EmfType | [To be supplied.]
ImageCodecFlags | [To be supplied.]
ImageFlags | [To be supplied.]
ImageLockMode | [To be supplied.]
MetafileFrameUnit | [To be supplied.]
MetafileType | [To be supplied.]
PaletteFlags | [To be supplied.]
PixelFormat | [To be supplied.]
ValueType | [To be supplied.]


APMFileHeader Class

[To be supplied.]

Object
APMFileHeader

[Visual Basic]
NotInheritable Public Class APMFileHeader
[C#]
public sealed class APMFileHeader
[C++]
public __gc __sealed class APMFileHeader
[JScript]
public class APMFileHeader

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

APMFileHeader Members | System.Drawing.Imaging Namespace


APMFileHeader Members

Public:

Constructor

APMFileHeader Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

bboxBottom | [To be supplied.]
bboxLeft | [To be supplied.]
bboxRight | [To be supplied.]
bboxTop | [To be supplied.]
checksum | [To be supplied.]
hmf | [To be supplied.]
inch | [To be supplied.]
key | [To be supplied.]
reserved | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

APMFileHeader Class | System.Drawing.Imaging Namespace


APMFileHeader Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public APMFileHeader();
[C++]
public: APMFileHeader();
[JScript]
public function APMFileHeader();

See Also

APMFileHeader Class | APMFileHeader Members | System.Drawing.Imaging Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

APMFileHeader Fields

The fields of the APMFileHeader class are listed below. For a complete list of APMFileHeader class members, see the APMFileHeader Members topic.

Public:

bboxBottom | [To be supplied.]
bboxLeft | [To be supplied.]
bboxRight | [To be supplied.]
bboxTop | [To be supplied.]
checksum | [To be supplied.]
hmf | [To be supplied.]
inch | [To be supplied.]
key | [To be supplied.]
reserved | [To be supplied.]

See Also

APMFileHeader Class | System.Drawing.Imaging Namespace


APMFileHeader.bboxBottom

[To be supplied.]

[Visual Basic]
Public bboxBottom As Short
[C#]
public short bboxBottom;
[C++]
public: short bboxBottom;
[JScript]
public var bboxBottom : Int16;

See Also

APMFileHeader Class | APMFileHeader Members | System.Drawing.Imaging Namespace


APMFileHeader.bboxLeft

[To be supplied.]

[Visual Basic]
Public bboxLeft As Short
[C#]
public short bboxLeft;
[C++]
public: short bboxLeft;
[JScript]
public var bboxLeft : Int16;

See Also

APMFileHeader Class | APMFileHeader Members | System.Drawing.Imaging Namespace


APMFileHeader.bboxRight

[To be supplied.]

[Visual Basic]
Public bboxRight As Short
[C#]
public short bboxRight;
[C++]
public: short bboxRight;
[JScript]
public var bboxRight : Int16;

See Also

APMFileHeader Class | APMFileHeader Members | System.Drawing.Imaging Namespace


APMFileHeader.bboxTop

[To be supplied.]

[Visual Basic]
Public bboxTop As Short
[C#]
public short bboxTop;
[C++]
public: short bboxTop;
[JScript]
public var bboxTop : Int16;

See Also

APMFileHeader Class | APMFileHeader Members | System.Drawing.Imaging Namespace


APMFileHeader.checksum

[To be supplied.]

[Visual Basic]
Public checksum As Short
[C#]
public short checksum;
[C++]
public: short checksum;
[JScript]
public var checksum : Int16;

See Also

APMFileHeader Class | APMFileHeader Members | System.Drawing.Imaging Namespace


APMFileHeader.hmf

[To be supplied.]

[Visual Basic]
Public hmf As Short
[C#]
public short hmf;
[C++]
public: short hmf;
[JScript]
public var hmf : Int16;

See Also

APMFileHeader Class | APMFileHeader Members | System.Drawing.Imaging Namespace


APMFileHeader.inch

[To be supplied.]

[Visual Basic]
Public inch As Short
[C#]
public short inch;
[C++]
public: short inch;
[JScript]
public var inch : Int16;

See Also

APMFileHeader Class | APMFileHeader Members | System.Drawing.Imaging Namespace


APMFileHeader.key

[To be supplied.]

[Visual Basic]
Public key As Integer
[C#]
public int key;
[C++]
public: int key;
[JScript]
public var key : int;

See Also

APMFileHeader Class | APMFileHeader Members | System.Drawing.Imaging Namespace


APMFileHeader.reserved

[To be supplied.]

[Visual Basic]
Public reserved As Integer
[C#]
public int reserved;
[C++]
public: int reserved;
[JScript]
public var reserved : int;

See Also

APMFileHeader Class | APMFileHeader Members | System.Drawing.Imaging Namespace


BitmapData Class

[To be supplied.]

Object
BitmapData

[Visual Basic]
NotInheritable Public Class BitmapData
[C#]
public sealed class BitmapData
[C++]
public __gc __sealed class BitmapData
[JScript]
public class BitmapData

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

BitmapData Members | System.Drawing.Imaging Namespace


BitmapData Members

Public:

Constructor

BitmapData Constructor [To be supplied.]

Properties

PixelFormat [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Height | [To be supplied.]
Reserved | [To be supplied.]
Scan0 | [To be supplied.]
Stride | [To be supplied.]
Width | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BitmapData Class | System.Drawing.Imaging Namespace


BitmapData Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public BitmapData();
[C++]
public: BitmapData();
[JScript]
public function BitmapData();

See Also

BitmapData Class | BitmapData Members | System.Drawing.Imaging Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

BitmapData Properties

The properties of the BitmapData class are listed below. For a complete list of BitmapData class members, see the BitmapData Members topic.

Public:

PixelFormat [To be supplied.]

See Also

BitmapData Class | System.Drawing.Imaging Namespace


BitmapData.PixelFormat

[To be supplied.]

[Visual Basic]
Public Property PixelFormat As PixelFormat
[C#]
public PixelFormat PixelFormat {get; set;}
[C++]
public: __property PixelFormat get_PixelFormat();
public: __property void set_PixelFormat(PixelFormat);
[JScript]
public function get PixelFormat() : PixelFormat;
public function set PixelFormat(PixelFormat);

See Also

BitmapData Class | BitmapData Members | System.Drawing.Imaging Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

BitmapData Fields

The fields of the BitmapData class are listed below. For a complete list of BitmapData class members, see the BitmapData Members topic.

Public:

Height | [To be supplied.]
Reserved | [To be supplied.]
Scan0 | [To be supplied.]
Stride | [To be supplied.]
Width | [To be supplied.]

See Also

BitmapData Class | System.Drawing.Imaging Namespace


BitmapData.Height

[To be supplied.]

[Visual Basic]
Public Height As Integer
[C#]
public int Height;
[C++]
public: int Height;
[JScript]
public var Height : int;

See Also

BitmapData Class | BitmapData Members | System.Drawing.Imaging Namespace


BitmapData.Reserved

[To be supplied.]

[Visual Basic]
Public Reserved As Integer
[C#]
public int Reserved;
[C++]
public: int Reserved;
[JScript]
public var Reserved : int;

See Also

BitmapData Class | BitmapData Members | System.Drawing.Imaging Namespace


BitmapData.Scan0

[To be supplied.]

[Visual Basic]
Public Scan0 As Integer
[C#]
public int Scan0;
[C++]
public: int Scan0;
[JScript]
public var Scan0 : int;

See Also

BitmapData Class | BitmapData Members | System.Drawing.Imaging Namespace


BitmapData.Stride

[To be supplied.]

[Visual Basic]
Public Stride As Integer
[C#]
public int Stride;
[C++]
public: int Stride;
[JScript]
public var Stride : int;

See Also

BitmapData Class | BitmapData Members | System.Drawing.Imaging Namespace


BitmapData.Width

[To be supplied.]

[Visual Basic]
Public Width As Integer
[C#]
public int Width;
[C++]
public: int Width;
[JScript]
public var Width : int;

See Also

BitmapData Class | BitmapData Members | System.Drawing.Imaging Namespace


ColorAdjustType Enumeration

[To be supplied.]

[Visual Basic]
Public Enum ColorAdjustType
[C#]
public enum ColorAdjustType
[C++]
public enum ColorAdjustType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Any | [To be supplied.]
Bitmap | [To be supplied.]
Brush | [To be supplied.]
Count | [To be supplied.]
Default | [To be supplied.]
Pen | [To be supplied.]
Text | [To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

System.Drawing.Imaging Namespace


ColorChannelFlags Enumeration

[To be supplied.]

[Visual Basic]
Public Enum ColorChannelFlags
[C#]
public enum ColorChannelFlags
[C++]
public enum ColorChannelFlags

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
ColorChannelC | [To be supplied.]
ColorChannelK | [To be supplied.]
ColorChannelLast | [To be supplied.]
ColorChannelM | [To be supplied.]
ColorChannelY | [To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

System.Drawing.Imaging Namespace


ColorMap Class

[To be supplied.]

Object
ColorMap

[Visual Basic]
NotInheritable Public Class ColorMap
[C#]
public sealed class ColorMap
[C++]
public __gc __sealed class ColorMap
[JScript]
public class ColorMap

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

ColorMap Members | System.Drawing.Imaging Namespace


ColorMap Members

Public:

Constructor

ColorMap Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

newColor | [To be supplied.]
oldColor | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ColorMap Class | System.Drawing.Imaging Namespace


ColorMap Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ColorMap();
[C++]
public: ColorMap();
[JScript]
public function ColorMap();

See Also

ColorMap Class | ColorMap Members | System.Drawing.Imaging Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ColorMap Fields

The fields of the ColorMap class are listed below. For a complete list of ColorMap class members, see the ColorMap Members topic.

Public:

newColor | [To be supplied.]
oldColor | [To be supplied.]

See Also

ColorMap Class | System.Drawing.Imaging Namespace


ColorMap.newColor

[To be supplied.]

[Visual Basic]
Public newColor As Color
[C#]
public Color newColor;
[C++]
public: Color newColor;
[JScript]
public var newColor : Color;

See Also

ColorMap Class | ColorMap Members | System.Drawing.Imaging Namespace


ColorMap.oldColor

[To be supplied.]

[Visual Basic]
Public oldColor As Color
[C#]
public Color oldColor;
[C++]
public: Color oldColor;
[JScript]
public var oldColor : Color;

See Also

ColorMap Class | ColorMap Members | System.Drawing.Imaging Namespace


ColorMapType Enumeration

[To be supplied.]

[Visual Basic]
Public Enum ColorMapType
[C#]
public enum ColorMapType
[C++]
public enum ColorMapType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Brush | [To be supplied.]
Default | [To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

System.Drawing.Imaging Namespace


ColorMatrix Class

[To be supplied.]

Object
ColorMatrix

[Visual Basic]
NotInheritable Public Class ColorMatrix
[C#]
public sealed class ColorMatrix
[C++]
public __gc __sealed class ColorMatrix
[JScript]
public class ColorMatrix

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

ColorMatrix Members | System.Drawing.Imaging Namespace


ColorMatrix Members

Public:

Constructor

ColorMatrix Constructor Overloaded. [To be supplied.]

Properties

Item [To be supplied.]

In C#, this member is the indexer for the ColorMatrix class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

matrix00 | [To be supplied.]
matrix01 | [To be supplied.]
matrix02 | [To be supplied.]
matrix03 | [To be supplied.]
matrix04 | [To be supplied.]
matrix10 | [To be supplied.]
matrix11 | [To be supplied.]
matrix12 | [To be supplied.]
matrix13 | [To be supplied.]
matrix14 | [To be supplied.]
matrix20 | [To be supplied.]
matrix21 | [To be supplied.]
matrix22 | [To be supplied.]
matrix23 | [To be supplied.]
matrix24 | [To be supplied.]
matrix30 | [To be supplied.]
matrix31 | [To be supplied.]
matrix32 | [To be supplied.]
matrix33 | [To be supplied.]
matrix34 | [To be supplied.]
matrix40 | [To be supplied.]
matrix41 | [To be supplied.]
matrix42 | [To be supplied.]
matrix43 | [To be supplied.]
matrix44 | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ColorMatrix Class | System.Drawing.Imaging Namespace


ColorMatrix Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public ColorMatrix();
[C++] public: ColorMatrix();
[JScript] public function ColorMatrix();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Single()())
[C#] public ColorMatrix(Single[][]);
[C++] public: ColorMatrix(Single[][]);
[JScript] public function ColorMatrix(Single[][]);

See Also

ColorMatrix Class | ColorMatrix Members | System.Drawing.Imaging Namespace


ColorMatrix Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public ColorMatrix();
[C++]
public: ColorMatrix();
[JScript]
public function ColorMatrix();

See Also

ColorMatrix Class | ColorMatrix Members | System.Drawing.Imaging Namespace | ColorMatrix Constructor Overload List


ColorMatrix Constructor (Single[][])

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal newColorMatrix()() As Single _
)
[C#]
public ColorMatrix(
   float[][] newColorMatrix
);
[C++]
public: ColorMatrix(
   float* newColorMatrix[]
);
[JScript]
public function ColorMatrix(
   newColorMatrix : float[][]
);

Parameters

newColorMatrix
[To be supplied.]

See Also

ColorMatrix Class | ColorMatrix Members | System.Drawing.Imaging Namespace | ColorMatrix Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ColorMatrix Properties

The properties of the ColorMatrix class are listed below. For a complete list of ColorMatrix class members, see the ColorMatrix Members topic.

Public:

Item [To be supplied.]

In C#, this member is the indexer for the ColorMatrix class.

See Also

ColorMatrix Class | System.Drawing.Imaging Namespace


ColorMatrix.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the ColorMatrix class.

[Visual Basic]
Public Default Property Item( _
   ByVal row As Integer, _
   ByVal column As Integer _
) As Single
[C#]
public float this[
   int row,
   int column
] {get; set;}
[C++]
public: __property float get_Item(
   int row,
   int column
);
public: __property void set_Item(
   int row,
   int column,
   float
);
[JScript]
returnValue = ColorMatrixObject.Item(row, column);
ColorMatrixObject.Item(row, column) = returnValue;
-or-
returnValue = ColorMatrixObject(row, column);
ColorMatrixObject(row, column) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

row
[To be supplied.]
column
[To be supplied.]

Parameters [Visual Basic, C#, C++]

row
[To be supplied.]
column
[To be supplied.]

See Also

ColorMatrix Class | ColorMatrix Members | System.Drawing.Imaging Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ColorMatrix Fields

The fields of the ColorMatrix class are listed below. For a complete list of ColorMatrix class members, see the ColorMatrix Members topic.

Public:

matrix00 | [To be supplied.]
matrix01 | [To be supplied.]
matrix02 | [To be supplied.]
matrix03 | [To be supplied.]
matrix04 | [To be supplied.]
matrix10 | [To be supplied.]
matrix11 | [To be supplied.]
matrix12 | [To be supplied.]
matrix13 | [To be supplied.]
matrix14 | [To be supplied.]
matrix20 | [To be supplied.]
matrix21 | [To be supplied.]
matrix22 | [To be supplied.]
matrix23 | [To be supplied.]
matrix24 | [To be supplied.]
matrix30 | [To be supplied.]
matrix31 | [To be supplied.]
matrix32 | [To be supplied.]
matrix33 | [To be supplied.]
matrix34 | [To be supplied.]
matrix40 | [To be supplied.]
matrix41 | [To be supplied.]
matrix42 | [To be supplied.]
matrix43 | [To be supplied.]
matrix44 | [To be supplied.]

See Also

ColorMatrix Class | System.Drawing.Imaging Namespace


ColorMatrix.matrix00

[To be supplied.]

[Visual Basic]
Public matrix00 As Single
[C#]
public float matrix00;
[C++]
public: float matrix00;
[JScript]
public var matrix00 : float;

See Also

ColorMatrix Class | ColorMatrix Members | System.Drawing.Imaging Namespace


ColorMatrix.matrix01

[To be supplied.]

[Visual Basic]
Public matrix01 As Single
[C#]
public float matrix01;
[C++]
public: float matrix01;
[JScript]
public var matrix01 : float;

See Also

ColorMatrix Class | ColorMatrix Members | System.Drawing.Imaging Namespace


ColorMatrix.matrix02

[To be supplied.]

[Visual Basic]
Public matrix02 As Single
[C#]
public float matrix02;
[C++]
public: float matrix02;
[JScript]
public var matrix02 : float;

See Also

ColorMatrix Class | ColorMatrix Members | System.Drawing.Imaging Namespace


ColorMatrix.matrix03

[To be supplied.]

[Visual Basic]
Public matrix03 As Single
[C#]
public float matrix03;
[C++]
public: float matrix03;
[JScript]
public var matrix03 : float;

See Also

ColorMatrix Class | ColorMatrix Members | System.Drawing.Imaging Namespace


ColorMatrix.matrix04

[To be supplied.]

[Visual Basic]
Public matrix04 As Single
[C#]
public float matrix04;
[C++]
public: float matrix04;
[JScript]
public var matrix04 : float;

See Also

ColorMatrix Class | ColorMatrix Members | System.Drawing.Imaging Namespace


ColorMatrix.matrix10

[To be supplied.]

[Visual Basic]
Public matrix10 As Single
[C#]
public float matrix10;
[C++]
public: float matrix10;
[JScript]
public var matrix10 : float;

See Also

ColorMatrix Class | ColorMatrix Members | System.Drawing.Imaging Namespace


ColorMatrix.matrix11

[To be supplied.]

[Visual Basic]
Public matrix11 As Single
[C#]
public float matrix11;
[C++]
public: float matrix11;
[JScript]
public var matrix11 : float;

See Also

ColorMatrix Class | ColorMatrix Members | System.Drawing.Imaging Namespace


ColorMatrix.matrix12

[To be supplied.]

[Visual Basic]
Public matrix12 As Single
[C#]
public float matrix12;
[C++]
public: float matrix12;
[JScript]
public var matrix12 : float;

See Also

ColorMatrix Class | ColorMatrix Members | System.Drawing.Imaging Namespace


ColorMatrix.matrix13

[To be supplied.]

[Visual Basic]
Public matrix13 As Single
[C#]
public float matrix13;
[C++]
public: float matrix13;
[JScript]
public var matrix13 : float;

See Also

ColorMatrix Class | ColorMatrix Members | System.Drawing.Imaging Namespace


ColorMatrix.matrix14

[To be supplied.]

[Visual Basic]
Public matrix14 As Single
[C#]
public float matrix14;
[C++]
public: float matrix14;
[JScript]
public var matrix14 : float;

See Also

ColorMatrix Class | ColorMatrix Members | System.Drawing.Imaging Namespace


ColorMatrix.matrix20

[To be supplied.]

[Visual Basic]
Public matrix20 As Single
[C#]
public float matrix20;
[C++]
public: float matrix20;
[JScript]
public var matrix20 : float;

See Also

ColorMatrix Class | ColorMatrix Members | System.Drawing.Imaging Namespace


ColorMatrix.matrix21

[To be supplied.]

[Visual Basic]
Public matrix21 As Single
[C#]
public float matrix21;
[C++]
public: float matrix21;
[JScript]
public var matrix21 : float;

See Also

ColorMatrix Class | ColorMatrix Members | System.Drawing.Imaging Namespace


ColorMatrix.matrix22

[To be supplied.]

[Visual Basic]
Public matrix22 As Single
[C#]
public float matrix22;
[C++]
public: float matrix22;
[JScript]
public var matrix22 : float;

See Also

ColorMatrix Class | ColorMatrix Members | System.Drawing.Imaging Namespace


ColorMatrix.matrix23

[To be supplied.]

[Visual Basic]
Public matrix23 As Single
[C#]
public float matrix23;
[C++]
public: float matrix23;
[JScript]
public var matrix23 : float;

See Also

ColorMatrix Class | ColorMatrix Members | System.Drawing.Imaging Namespace


ColorMatrix.matrix24

[To be supplied.]

[Visual Basic]
Public matrix24 As Single
[C#]
public float matrix24;
[C++]
public: float matrix24;
[JScript]
public var matrix24 : float;

See Also

ColorMatrix Class | ColorMatrix Members | System.Drawing.Imaging Namespace


ColorMatrix.matrix30

[To be supplied.]

[Visual Basic]
Public matrix30 As Single
[C#]
public float matrix30;
[C++]
public: float matrix30;
[JScript]
public var matrix30 : float;

See Also

ColorMatrix Class | ColorMatrix Members | System.Drawing.Imaging Namespace


ColorMatrix.matrix31

[To be supplied.]

[Visual Basic]
Public matrix31 As Single
[C#]
public float matrix31;
[C++]
public: float matrix31;
[JScript]
public var matrix31 : float;

See Also

ColorMatrix Class | ColorMatrix Members | System.Drawing.Imaging Namespace


ColorMatrix.matrix32

[To be supplied.]

[Visual Basic]
Public matrix32 As Single
[C#]
public float matrix32;
[C++]
public: float matrix32;
[JScript]
public var matrix32 : float;

See Also

ColorMatrix Class | ColorMatrix Members | System.Drawing.Imaging Namespace


ColorMatrix.matrix33

[To be supplied.]

[Visual Basic]
Public matrix33 As Single
[C#]
public float matrix33;
[C++]
public: float matrix33;
[JScript]
public var matrix33 : float;

See Also

ColorMatrix Class | ColorMatrix Members | System.Drawing.Imaging Namespace


ColorMatrix.matrix34

[To be supplied.]

[Visual Basic]
Public matrix34 As Single
[C#]
public float matrix34;
[C++]
public: float matrix34;
[JScript]
public var matrix34 : float;

See Also

ColorMatrix Class | ColorMatrix Members | System.Drawing.Imaging Namespace


ColorMatrix.matrix40

[To be supplied.]

[Visual Basic]
Public matrix40 As Single
[C#]
public float matrix40;
[C++]
public: float matrix40;
[JScript]
public var matrix40 : float;

See Also

ColorMatrix Class | ColorMatrix Members | System.Drawing.Imaging Namespace


ColorMatrix.matrix41

[To be supplied.]

[Visual Basic]
Public matrix41 As Single
[C#]
public float matrix41;
[C++]
public: float matrix41;
[JScript]
public var matrix41 : float;

See Also

ColorMatrix Class | ColorMatrix Members | System.Drawing.Imaging Namespace


ColorMatrix.matrix42

[To be supplied.]

[Visual Basic]
Public matrix42 As Single
[C#]
public float matrix42;
[C++]
public: float matrix42;
[JScript]
public var matrix42 : float;

See Also

ColorMatrix Class | ColorMatrix Members | System.Drawing.Imaging Namespace


ColorMatrix.matrix43

[To be supplied.]

[Visual Basic]
Public matrix43 As Single
[C#]
public float matrix43;
[C++]
public: float matrix43;
[JScript]
public var matrix43 : float;

See Also

ColorMatrix Class | ColorMatrix Members | System.Drawing.Imaging Namespace


ColorMatrix.matrix44

[To be supplied.]

[Visual Basic]
Public matrix44 As Single
[C#]
public float matrix44;
[C++]
public: float matrix44;
[JScript]
public var matrix44 : float;

See Also

ColorMatrix Class | ColorMatrix Members | System.Drawing.Imaging Namespace


ColorMatrixFlags Enumeration

[To be supplied.]

[Visual Basic]
Public Enum ColorMatrixFlags
[C#]
public enum ColorMatrixFlags
[C++]
public enum ColorMatrixFlags

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
AltGrays | [To be supplied.]
Default | [To be supplied.]
SkipGrays | [To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

System.Drawing.Imaging Namespace


ColorMode Enumeration

[To be supplied.]

[Visual Basic]
Public Enum ColorMode
[C#]
public enum ColorMode
[C++]
public enum ColorMode

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
ARGB32Mode | [To be supplied.]
ARGB64Mode | [To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

System.Drawing.Imaging Namespace


ColorPalette Class

[To be supplied.]

Object
ColorPalette

[Visual Basic]
NotInheritable Public Class ColorPalette
[C#]
public sealed class ColorPalette
[C++]
public __gc __sealed class ColorPalette
[JScript]
public class ColorPalette

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

ColorPalette Members | System.Drawing.Imaging Namespace


ColorPalette Members

Public:

Properties

Entries | [To be supplied.]
Flags | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ColorPalette Class | System.Drawing.Imaging Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ColorPalette Properties

The properties of the ColorPalette class are listed below. For a complete list of ColorPalette class members, see the ColorPalette Members topic.

Public:

Entries | [To be supplied.]
Flags | [To be supplied.]

See Also

ColorPalette Class | System.Drawing.Imaging Namespace


ColorPalette.Entries

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Entries As Color ()
[C#]
public Color[] Entries {get;}
[C++]
public: __property Color* get_Entries();
[JScript]
public function get Entries() : Color[];

See Also

ColorPalette Class | ColorPalette Members | System.Drawing.Imaging Namespace


ColorPalette.Flags

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Flags As Integer
[C#]
public int Flags {get;}
[C++]
public: __property int get_Flags();
[JScript]
public function get Flags() : int;

See Also

ColorPalette Class | ColorPalette Members | System.Drawing.Imaging Namespace


Decoder Class

[To be supplied.]

Object
Decoder

[Visual Basic]
NotInheritable Public Class Decoder
[C#]
public sealed class Decoder
[C++]
public __gc __sealed class Decoder
[JScript]
public class Decoder

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

Decoder Members | System.Drawing.Imaging Namespace


Decoder Members

Public:

Constructor

Decoder Constructor [To be supplied.]

Properties

GUID [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

IconRes | [To be supplied.]
OutputChannel | [To be supplied.]
TransColor | [To be supplied.]
TransRange | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Decoder Class | System.Drawing.Imaging Namespace


Decoder Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal guid As Guid _
)
[C#]
public Decoder(
   Guid guid
);
[C++]
public: Decoder(
   Guid guid
);
[JScript]
public function Decoder(
   guid : Guid
);

Parameters

guid
[To be supplied.]

See Also

Decoder Class | Decoder Members | System.Drawing.Imaging Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Decoder Properties

The properties of the Decoder class are listed below. For a complete list of Decoder class members, see the Decoder Members topic.

Public:

GUID [To be supplied.]

See Also

Decoder Class | System.Drawing.Imaging Namespace


Decoder.GUID

[To be supplied.]

[Visual Basic]
Public ReadOnly Property GUID As Guid
[C#]
public Guid GUID {get;}
[C++]
public: __property Guid get_GUID();
[JScript]
public function get GUID() : Guid;

See Also

Decoder Class | Decoder Members | System.Drawing.Imaging Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Decoder Fields

The fields of the Decoder class are listed below. For a complete list of Decoder class members, see the Decoder Members topic.

Public:

IconRes | [To be supplied.]
OutputChannel | [To be supplied.]
TransColor | [To be supplied.]
TransRange | [To be supplied.]

See Also

Decoder Class | System.Drawing.Imaging Namespace


Decoder.IconRes

[To be supplied.]

[Visual Basic]
Public Shared IconRes As Decoder
[C#]
public static Decoder IconRes;
[C++]
public: static Decoder* IconRes;
[JScript]
public static var IconRes : Decoder;

See Also

Decoder Class | Decoder Members | System.Drawing.Imaging Namespace


Decoder.OutputChannel

[To be supplied.]

[Visual Basic]
Public Shared OutputChannel As Decoder
[C#]
public static Decoder OutputChannel;
[C++]
public: static Decoder* OutputChannel;
[JScript]
public static var OutputChannel : Decoder;

See Also

Decoder Class | Decoder Members | System.Drawing.Imaging Namespace


Decoder.TransColor

[To be supplied.]

[Visual Basic]
Public Shared TransColor As Decoder
[C#]
public static Decoder TransColor;
[C++]
public: static Decoder* TransColor;
[JScript]
public static var TransColor : Decoder;

See Also

Decoder Class | Decoder Members | System.Drawing.Imaging Namespace


Decoder.TransRange

[To be supplied.]

[Visual Basic]
Public Shared TransRange As Decoder
[C#]
public static Decoder TransRange;
[C++]
public: static Decoder* TransRange;
[JScript]
public static var TransRange : Decoder;

See Also

Decoder Class | Decoder Members | System.Drawing.Imaging Namespace


EmfPlusRecordType Enumeration

[To be supplied.]

[Visual Basic]
Public Enum EmfPlusRecordType
[C#]
public enum EmfPlusRecordType
[C++]
public enum EmfPlusRecordType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
BeginContainer | [To be supplied.]
BeginContainerNoParams | [To be supplied.]
Brush | [To be supplied.]
Clear | [To be supplied.]
Comment | [To be supplied.]
DrawArc | [To be supplied.]
DrawBeziers | [To be supplied.]
DrawClosedCurve | [To be supplied.]
DrawCurve | [To be supplied.]
DrawEllipse | [To be supplied.]
DrawImage | [To be supplied.]
DrawImagePoints | [To be supplied.]
DrawLines | [To be supplied.]
DrawPath | [To be supplied.]
DrawPie | [To be supplied.]
DrawRects | [To be supplied.]
DrawString | [To be supplied.]
EmfAbortPath | [To be supplied.]
EmfAlphaBlend | [To be supplied.]
EmfAngleArc | [To be supplied.]
EmfArcTo | [To be supplied.]
EmfBeginPath | [To be supplied.]
EmfBitBlt | [To be supplied.]
EmfChord | [To be supplied.]
EmfCloseFigure | [To be supplied.]
EmfColorCorrectPalette | [To be supplied.]
EmfColorMatchToTargetW | [To be supplied.]
EmfCreateBrushIndirect | [To be supplied.]
EmfCreateColorSpace | [To be supplied.]
EmfCreateColorSpaceW | [To be supplied.]
EmfCreateDIBPatternBrushPt | [To be supplied.]
EmfCreateMonoBrush | [To be supplied.]
EmfCreatePalette | [To be supplied.]
EmfCreatePen | [To be supplied.]
EmfDeleteColorSpace | [To be supplied.]
EmfDeleteObject | [To be supplied.]
EmfDrawEscape | [To be supplied.]
EmfEllipse | [To be supplied.]
EmfEndPath | [To be supplied.]
EmfEOF | [To be supplied.]
EmfExcludeClipRect | [To be supplied.]
EmfExtCreateFontIndirect | [To be supplied.]
EmfExtCreatePen | [To be supplied.]
EmfExtEscape | [To be supplied.]
EmfExtFloodFill | [To be supplied.]
EmfExtSelectClipRgn | [To be supplied.]
EmfExtTextOutA | [To be supplied.]
EmfExtTextOutW | [To be supplied.]
EmfFillPath | [To be supplied.]
EmfFillRgn | [To be supplied.]
EmfFlattenPath | [To be supplied.]
EmfForceUFIMapping | [To be supplied.]
EmfFrameRgn | [To be supplied.]
EmfGdiComment | [To be supplied.]
EmfGLSBoundedRecord | [To be supplied.]
EmfGLSRecord | [To be supplied.]
EmfGradientFill | [To be supplied.]
EmfHeader | [To be supplied.]
EmfIntersectClipRect | [To be supplied.]
EmfInvertRgn | [To be supplied.]
EmfLineTo | [To be supplied.]
EmfMaskBlt | [To be supplied.]
EmfMax | [To be supplied.]
EmfMin | [To be supplied.]
EmfModifyWorldTransform | [To be supplied.]
EmfMoveToEx | [To be supplied.]
EmfNamedEscpae | [To be supplied.]
EmfOffsetClipRgn | [To be supplied.]
EmfPaintRgn | [To be supplied.]
EmfPie | [To be supplied.]
EmfPixelFormat | [To be supplied.]
EmfPlgBlt | [To be supplied.]
EmfPlusRecordBase | [To be supplied.]
EmfPolyBezier | [To be supplied.]
EmfPolyBezier16 | [To be supplied.]
EmfPolyBezierTo | [To be supplied.]
EmfPolyBezierTo16 | [To be supplied.]
EmfPolyDraw | [To be supplied.]
EmfPolyDraw16 | [To be supplied.]
EmfPolygon | [To be supplied.]
EmfPolygon16 | [To be supplied.]
EmfPolyline | [To be supplied.]
EmfPolyline16 | [To be supplied.]
EmfPolyLineTo | [To be supplied.]
EmfPolylineTo16 | [To be supplied.]
EmfPolyPolygon | [To be supplied.]
EmfPolyPolygon16 | [To be supplied.]
EmfPolyPolyline | [To be supplied.]
EmfPolyPolyline16 | [To be supplied.]
EmfPolyTextOutA | [To be supplied.]
EmfPolyTextOutW | [To be supplied.]
EmfRealizePalette | [To be supplied.]
EmfRectangle | [To be supplied.]
EmfReserved_069 | [To be supplied.]
EmfReserved_117 | [To be supplied.]
EmfResizePalette | [To be supplied.]
EmfRestoreDC | [To be supplied.]
EmfRoundRect | [To be supplied.]
EmfSaveDC | [To be supplied.]
EmfScaleViewportExtEx | [To be supplied.]
EmfScaleWindowExtEx | [To be supplied.]
EmfSelectClipPath | [To be supplied.]
EmfSelectObject | [To be supplied.]
EmfSelectPalette | [To be supplied.]
EmfSetArcDirection | [To be supplied.]
EmfSetBkColor | [To be supplied.]
EmfSetBkMode | [To be supplied.]
EmfSetBrushOrgEx | [To be supplied.]
EmfSetColorAdjustment | [To be supplied.]
EmfSetColorSpace | [To be supplied.]
EmfSetDIBitsToDevice | [To be supplied.]
EmfSetICMMode | [To be supplied.]
EmfSetICMProfileA | [To be supplied.]
EmfSetICMProfileW | [To be supplied.]
EmfSetLayout | [To be supplied.]
EmfSetLinkedUFIs | [To be supplied.]
EmfSetMapMode | [To be supplied.]
EmfSetMapperFlags | [To be supplied.]
EmfSetMetaRgn | [To be supplied.]
EmfSetMiterLimit | [To be supplied.]
EmfSetPaletteEntries | [To be supplied.]
EmfSetPixelV | [To be supplied.]
EmfSetPolyFillMode | [To be supplied.]
EmfSetROP2 | [To be supplied.]
EmfSetStretchBltMode | [To be supplied.]
EmfSetTextAlign | [To be supplied.]
EmfSetTextColor | [To be supplied.]
EmfSetTextJustification | [To be supplied.]
EmfSetViewportExtEx | [To be supplied.]
EmfSetViewportOrgEx | [To be supplied.]
EmfSetWindowExtEx | [To be supplied.]
EmfSetWindowOrgEx | [To be supplied.]
EmfSetWorldTransform | [To be supplied.]
EmfSmallTextOut | [To be supplied.]
EmfStartDoc | [To be supplied.]
EmfStretchBlt | [To be supplied.]
EmfStretchDIBits | [To be supplied.]
EmfStrokeAndFillPath | [To be supplied.]
EmfStrokePath | [To be supplied.]
EmfTransparentBlt | [To be supplied.]
EmfWidenPath | [To be supplied.]
EndContainer | [To be supplied.]
EndOfFile | [To be supplied.]
FillClosedCurve | [To be supplied.]
FillEllipse | [To be supplied.]
FillPath | [To be supplied.]
FillPie | [To be supplied.]
FillPolygon | [To be supplied.]
FillRects | [To be supplied.]
FillRegion | [To be supplied.]
FirstObject | [To be supplied.]
Font | [To be supplied.]
GetDC | [To be supplied.]
Header | [To be supplied.]
Image | [To be supplied.]
ImageAttributes | [To be supplied.]
Invalid | [To be supplied.]
LastObject | [To be supplied.]
Max | [To be supplied.]
Min | [To be supplied.]
MultiFormatEnd | [To be supplied.]
MultiFormatSection | [To be supplied.]
MultiFormatStart | [To be supplied.]
MultiplyWorldTransform | [To be supplied.]
OffsetClip | [To be supplied.]
Path | [To be supplied.]
Pen | [To be supplied.]
PenSetBrush | [To be supplied.]
Region | [To be supplied.]
ResetClip | [To be supplied.]
Restore | [To be supplied.]
RotateWorldTransform | [To be supplied.]
Save | [To be supplied.]
ScaleWorldTransform | [To be supplied.]
SetAntiAliasMode | [To be supplied.]
SetClipPath | [To be supplied.]
SetClipRect | [To be supplied.]
SetClipRegion | [To be supplied.]
SetCompositingMode | [To be supplied.]
SetCompositingQuality | [To be supplied.]
SetPageTransform | [To be supplied.]
SetRenderingOrigin | [To be supplied.]
SetTextGammaValue | [To be supplied.]
SetTextRenderingHint | [To be supplied.]
SetWorldTransform | [To be supplied.]
StringFormat | [To be supplied.]
Total | [To be supplied.]
TranslateWorldTransform | [To be supplied.]
WmfAnimatePalette | [To be supplied.]
WmfArc | [To be supplied.]
WmfBitBlt | [To be supplied.]
WmfChord | [To be supplied.]
WmfCreateBrushIndirect | [To be supplied.]
WmfCreateFontIndirect | [To be supplied.]
WmfCreatePalette | [To be supplied.]
WmfCreatePatternBrush | [To be supplied.]
WmfCreatePenIndirect | [To be supplied.]
WmfCreateRegion | [To be supplied.]
WmfDeleteObject | [To be supplied.]
WmfDIBBitBlt | [To be supplied.]
WmfDIBCreatePatternBrush | [To be supplied.]
WmfDIBStretchBlt | [To be supplied.]
WmfEllipse | [To be supplied.]
WmfEscape | [To be supplied.]
WmfExcludeClipRect | [To be supplied.]
WmfExtFloodFill | [To be supplied.]
WmfExtTextOut | [To be supplied.]
WmfFillRegion | [To be supplied.]
WmfFloodFill | [To be supplied.]
WmfFrameRegion | [To be supplied.]
WmfIntersectClipRect | [To be supplied.]
WmfInvertRegion | [To be supplied.]
WmfLineTo | [To be supplied.]
WmfMoveTo | [To be supplied.]
WmfOffsetCilpRgn | [To be supplied.]
WmfOffsetViewportOrg | [To be supplied.]
WmfOffsetWindowOrg | [To be supplied.]
WmfPaintRegion | [To be supplied.]
WmfPatBlt | [To be supplied.]
WmfPie | [To be supplied.]
WmfPolygon | [To be supplied.]
WmfPolyline | [To be supplied.]
WmfPolyPolygon | [To be supplied.]
WmfRealizePalette | [To be supplied.]
WmfRecordBase | [To be supplied.]
WmfRectangle | [To be supplied.]
WmfResizePalette | [To be supplied.]
WmfRestoreDC | [To be supplied.]
WmfRoundRect | [To be supplied.]
WmfSaveDC | [To be supplied.]
WmfScaleViewportExt | [To be supplied.]
WmfScaleWindowExt | [To be supplied.]
WmfSelectClipRegion | [To be supplied.]
WmfSelectObject | [To be supplied.]
WmfSelectPalette | [To be supplied.]
WmfSetBkColor | [To be supplied.]
WmfSetBkMode | [To be supplied.]
WmfSetDIBToDev | [To be supplied.]
WmfSetLayout | [To be supplied.]
WmfSetMapMode | [To be supplied.]
WmfSetMapperFlags | [To be supplied.]
WmfSetPalEntries | [To be supplied.]
WmfSetPixel | [To be supplied.]
WmfSetPolyFillMode | [To be supplied.]
WmfSetRelAbs | [To be supplied.]
WmfSetROP2 | [To be supplied.]
WmfSetStretchBltMode | [To be supplied.]
WmfSetTextAlign | [To be supplied.]
WmfSetTextCharExtra | [To be supplied.]
WmfSetTextColor | [To be supplied.]
WmfSetTextJustification | [To be supplied.]
WmfSetViewportExt | [To be supplied.]
WmfSetViewportOrg | [To be supplied.]
WmfSetWindowExt | [To be supplied.]
WmfSetWindowOrg | [To be supplied.]
WmfStretchBlt | [To be supplied.]
WmfStretchDIB | [To be supplied.]
WmfTextOut | [To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

System.Drawing.Imaging Namespace


EmfType Enumeration

[To be supplied.]

[Visual Basic]
Public Enum EmfType
[C#]
public enum EmfType
[C++]
public enum EmfType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
EmfOnly | [To be supplied.]
EmfPlusDual | [To be supplied.]
EmfPlusOnly | [To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

System.Drawing.Imaging Namespace


Encoder Class

[To be supplied.]

Object
Encoder

[Visual Basic]
NotInheritable Public Class Encoder
[C#]
public sealed class Encoder
[C++]
public __gc __sealed class Encoder
[JScript]
public class Encoder

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

Encoder Members | System.Drawing.Imaging Namespace


Encoder Members

Public:

Constructor

Encoder Constructor [To be supplied.]

Properties

GUID [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

ChrominanceTable | [To be supplied.]
ColorDepth | [To be supplied.]
Compression | [To be supplied.]
LuminanceTable | [To be supplied.]
Quality | [To be supplied.]
RenderMethod | [To be supplied.]
SaveFlag | [To be supplied.]
ScanMethod | [To be supplied.]
Transformation | [To be supplied.]
Version | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Encoder Class | System.Drawing.Imaging Namespace


Encoder Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal guid As Guid _
)
[C#]
public Encoder(
   Guid guid
);
[C++]
public: Encoder(
   Guid guid
);
[JScript]
public function Encoder(
   guid : Guid
);

Parameters

guid
[To be supplied.]

See Also

Encoder Class | Encoder Members | System.Drawing.Imaging Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Encoder Properties

The properties of the Encoder class are listed below. For a complete list of Encoder class members, see the Encoder Members topic.

Public:

GUID [To be supplied.]

See Also

Encoder Class | System.Drawing.Imaging Namespace


Encoder.GUID

[To be supplied.]

[Visual Basic]
Public ReadOnly Property GUID As Guid
[C#]
public Guid GUID {get;}
[C++]
public: __property Guid get_GUID();
[JScript]
public function get GUID() : Guid;

See Also

Encoder Class | Encoder Members | System.Drawing.Imaging Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Encoder Fields

The fields of the Encoder class are listed below. For a complete list of Encoder class members, see the Encoder Members topic.

Public:

ChrominanceTable | [To be supplied.]
ColorDepth | [To be supplied.]
Compression | [To be supplied.]
LuminanceTable | [To be supplied.]
Quality | [To be supplied.]
RenderMethod | [To be supplied.]
SaveFlag | [To be supplied.]
ScanMethod | [To be supplied.]
Transformation | [To be supplied.]
Version | [To be supplied.]

See Also

Encoder Class | System.Drawing.Imaging Namespace


Encoder.ChrominanceTable

[To be supplied.]

[Visual Basic]
Public Shared ChrominanceTable As Encoder
[C#]
public static Encoder ChrominanceTable;
[C++]
public: static Encoder* ChrominanceTable;
[JScript]
public static var ChrominanceTable : Encoder;

See Also

Encoder Class | Encoder Members | System.Drawing.Imaging Namespace


Encoder.ColorDepth

[To be supplied.]

[Visual Basic]
Public Shared ColorDepth As Encoder
[C#]
public static Encoder ColorDepth;
[C++]
public: static Encoder* ColorDepth;
[JScript]
public static var ColorDepth : Encoder;

See Also

Encoder Class | Encoder Members | System.Drawing.Imaging Namespace


Encoder.Compression

[To be supplied.]

[Visual Basic]
Public Shared Compression As Encoder
[C#]
public static Encoder Compression;
[C++]
public: static Encoder* Compression;
[JScript]
public static var Compression : Encoder;

See Also

Encoder Class | Encoder Members | System.Drawing.Imaging Namespace


Encoder.LuminanceTable

[To be supplied.]

[Visual Basic]
Public Shared LuminanceTable As Encoder
[C#]
public static Encoder LuminanceTable;
[C++]
public: static Encoder* LuminanceTable;
[JScript]
public static var LuminanceTable : Encoder;

See Also

Encoder Class | Encoder Members | System.Drawing.Imaging Namespace


Encoder.Quality

[To be supplied.]

[Visual Basic]
Public Shared Quality As Encoder
[C#]
public static Encoder Quality;
[C++]
public: static Encoder* Quality;
[JScript]
public static var Quality : Encoder;

See Also

Encoder Class | Encoder Members | System.Drawing.Imaging Namespace


Encoder.RenderMethod

[To be supplied.]

[Visual Basic]
Public Shared RenderMethod As Encoder
[C#]
public static Encoder RenderMethod;
[C++]
public: static Encoder* RenderMethod;
[JScript]
public static var RenderMethod : Encoder;

See Also

Encoder Class | Encoder Members | System.Drawing.Imaging Namespace


Encoder.SaveFlag

[To be supplied.]

[Visual Basic]
Public Shared SaveFlag As Encoder
[C#]
public static Encoder SaveFlag;
[C++]
public: static Encoder* SaveFlag;
[JScript]
public static var SaveFlag : Encoder;

See Also

Encoder Class | Encoder Members | System.Drawing.Imaging Namespace


Encoder.ScanMethod

[To be supplied.]

[Visual Basic]
Public Shared ScanMethod As Encoder
[C#]
public static Encoder ScanMethod;
[C++]
public: static Encoder* ScanMethod;
[JScript]
public static var ScanMethod : Encoder;

See Also

Encoder Class | Encoder Members | System.Drawing.Imaging Namespace


Encoder.Transformation

[To be supplied.]

[Visual Basic]
Public Shared Transformation As Encoder
[C#]
public static Encoder Transformation;
[C++]
public: static Encoder* Transformation;
[JScript]
public static var Transformation : Encoder;

See Also

Encoder Class | Encoder Members | System.Drawing.Imaging Namespace


Encoder.Version

[To be supplied.]

[Visual Basic]
Public Shared Version As Encoder
[C#]
public static Encoder Version;
[C++]
public: static Encoder* Version;
[JScript]
public static var Version : Encoder;

See Also

Encoder Class | Encoder Members | System.Drawing.Imaging Namespace


EncoderParameter Class

[To be supplied.]

Object
EncoderParameter

[Visual Basic]
NotInheritable Public Class EncoderParameter
[C#]
public sealed class EncoderParameter
[C++]
public __gc __sealed class EncoderParameter
[JScript]
public class EncoderParameter

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

EncoderParameter Members | System.Drawing.Imaging Namespace


EncoderParameter Members

Public:

Constructor

EncoderParameter Constructor Overloaded. [To be supplied.]

Methods

Dispose | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EncoderParameter Class | System.Drawing.Imaging Namespace


EncoderParameter Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Encoder, Byte)
[C#] public EncoderParameter(Encoder, byte);
[C++] public: EncoderParameter(Encoder*, unsigned char);
[JScript] public function EncoderParameter(Encoder, Byte);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Encoder, Byte, Boolean)
[C#] public EncoderParameter(Encoder, byte, bool);
[C++] public: EncoderParameter(Encoder*, unsigned char, bool);
[JScript] public function EncoderParameter(Encoder, Byte, Boolean);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Encoder, Integer)
[C#] public EncoderParameter(Encoder, short);
[C++] public: EncoderParameter(Encoder*, short);
[JScript] public function EncoderParameter(Encoder, Int16);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Encoder, Long)
[C#] public EncoderParameter(Encoder, long);
[C++] public: EncoderParameter(Encoder*, __int64);
[JScript] public function EncoderParameter(Encoder, long);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Encoder, Integer, Integer)
[C#] public EncoderParameter(Encoder, int, int);
[C++] public: EncoderParameter(Encoder*, int, int);
[JScript] public function EncoderParameter(Encoder, int, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Encoder, Long, Long)
[C#] public EncoderParameter(Encoder, long, long);
[C++] public: EncoderParameter(Encoder*, __int64, __int64);
[JScript] public function EncoderParameter(Encoder, long, long);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Encoder, Integer, Integer, Integer, Integer)
[C#] public EncoderParameter(Encoder, int, int, int, int);
[C++] public: EncoderParameter(Encoder*, int, int, int, int);
[JScript] public function EncoderParameter(Encoder, int, int, int, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Encoder, String)
[C#] public EncoderParameter(Encoder, String);
[C++] public: EncoderParameter(Encoder*, String);
[JScript] public function EncoderParameter(Encoder, String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Encoder, Byte())
[C#] public EncoderParameter(Encoder, byte[]);
[C++] public: EncoderParameter(Encoder*, unsigned char[]);
[JScript] public function EncoderParameter(Encoder, Byte[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Encoder, Byte(), Boolean)
[C#] public EncoderParameter(Encoder, byte[], bool);
[C++] public: EncoderParameter(Encoder*, unsigned char[], bool);
[JScript] public function EncoderParameter(Encoder, Byte[], Boolean);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Encoder, Integer())
[C#] public EncoderParameter(Encoder, short[]);
[C++] public: EncoderParameter(Encoder*, short[]);
[JScript] public function EncoderParameter(Encoder, Int16[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Encoder, Long())
[C#] public EncoderParameter(Encoder, long[]);
[C++] public: EncoderParameter(Encoder*, __int64[]);
[JScript] public function EncoderParameter(Encoder, long[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Encoder, Integer(), Integer())
[C#] public EncoderParameter(Encoder, int[], int[]);
[C++] public: EncoderParameter(Encoder*, int[], int[]);
[JScript] public function EncoderParameter(Encoder, int[], int[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Encoder, Long(), Long())
[C#] public EncoderParameter(Encoder, long[], long[]);
[C++] public: EncoderParameter(Encoder*, __int64[], __int64[]);
[JScript] public function EncoderParameter(Encoder, long[], long[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Encoder, Integer(), Integer(), Integer(), Integer())
[C#] public EncoderParameter(Encoder, int[], int[], int[], int[]);
[C++] public: EncoderParameter(Encoder*, int[], int[], int[], int[]);
[JScript] public function EncoderParameter(Encoder, int[], int[], int[], int[]);

See Also

EncoderParameter Class | EncoderParameter Members | System.Drawing.Imaging Namespace


EncoderParameter Constructor (Encoder, Byte)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal encoder As Encoder, _
   ByVal _byte As Byte _
)
[C#]
public EncoderParameter(
   Encoder encoder,
   byte _byte
);
[C++]
public: EncoderParameter(
   Encoder* encoder,
   unsigned char _byte
);
[JScript]
public function EncoderParameter(
   encoder : Encoder,
   _byte : Byte
);

Parameters

encoder
[To be supplied.]
_byte
[To be supplied.]

See Also

EncoderParameter Class | EncoderParameter Members | System.Drawing.Imaging Namespace | EncoderParameter Constructor Overload List


EncoderParameter Constructor (Encoder, Byte, Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal encoder As Encoder, _
   ByVal _byte As Byte, _
   ByVal undefined As Boolean _
)
[C#]
public EncoderParameter(
   Encoder encoder,
   byte _byte,
   bool undefined
);
[C++]
public: EncoderParameter(
   Encoder* encoder,
   unsigned char _byte,
   bool undefined
);
[JScript]
public function EncoderParameter(
   encoder : Encoder,
   _byte : Byte,
   undefined : Boolean
);

Parameters

encoder
[To be supplied.]
_byte
[To be supplied.]
undefined
[To be supplied.]

See Also

EncoderParameter Class | EncoderParameter Members | System.Drawing.Imaging Namespace | EncoderParameter Constructor Overload List


EncoderParameter Constructor (Encoder, Int16)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal encoder As Encoder, _
   ByVal _short As Short _
)
[C#]
public EncoderParameter(
   Encoder encoder,
   short _short
);
[C++]
public: EncoderParameter(
   Encoder* encoder,
   short _short
);
[JScript]
public function EncoderParameter(
   encoder : Encoder,
   _short : Int16
);

Parameters

encoder
[To be supplied.]
_short
[To be supplied.]

See Also

EncoderParameter Class | EncoderParameter Members | System.Drawing.Imaging Namespace | EncoderParameter Constructor Overload List


EncoderParameter Constructor (Encoder, Int64)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal encoder As Encoder, _
   ByVal _long As Long _
)
[C#]
public EncoderParameter(
   Encoder encoder,
   long _long
);
[C++]
public: EncoderParameter(
   Encoder* encoder,
   __int64 _long
);
[JScript]
public function EncoderParameter(
   encoder : Encoder,
   _long : long
);

Parameters

encoder
[To be supplied.]
_long
[To be supplied.]

See Also

EncoderParameter Class | EncoderParameter Members | System.Drawing.Imaging Namespace | EncoderParameter Constructor Overload List


EncoderParameter Constructor (Encoder, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal encoder As Encoder, _
   ByVal numerator As Integer, _
   ByVal demoninator As Integer _
)
[C#]
public EncoderParameter(
   Encoder encoder,
   int numerator,
   int demoninator
);
[C++]
public: EncoderParameter(
   Encoder* encoder,
   int numerator,
   int demoninator
);
[JScript]
public function EncoderParameter(
   encoder : Encoder,
   numerator : int,
   demoninator : int
);

Parameters

encoder
[To be supplied.]
numerator
[To be supplied.]
demoninator
[To be supplied.]

See Also

EncoderParameter Class | EncoderParameter Members | System.Drawing.Imaging Namespace | EncoderParameter Constructor Overload List


EncoderParameter Constructor (Encoder, Int64, Int64)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal encoder As Encoder, _
   ByVal rangebegin As Long, _
   ByVal rangeend As Long _
)
[C#]
public EncoderParameter(
   Encoder encoder,
   long rangebegin,
   long rangeend
);
[C++]
public: EncoderParameter(
   Encoder* encoder,
   __int64 rangebegin,
   __int64 rangeend
);
[JScript]
public function EncoderParameter(
   encoder : Encoder,
   rangebegin : long,
   rangeend : long
);

Parameters

encoder
[To be supplied.]
rangebegin
[To be supplied.]
rangeend
[To be supplied.]

See Also

EncoderParameter Class | EncoderParameter Members | System.Drawing.Imaging Namespace | EncoderParameter Constructor Overload List


EncoderParameter Constructor (Encoder, Int32, Int32, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal encoder As Encoder, _
   ByVal numerator1 As Integer, _
   ByVal demoninator1 As Integer, _
   ByVal numerator2 As Integer, _
   ByVal demoninator2 As Integer _
)
[C#]
public EncoderParameter(
   Encoder encoder,
   int numerator1,
   int demoninator1,
   int numerator2,
   int demoninator2
);
[C++]
public: EncoderParameter(
   Encoder* encoder,
   int numerator1,
   int demoninator1,
   int numerator2,
   int demoninator2
);
[JScript]
public function EncoderParameter(
   encoder : Encoder,
   numerator1 : int,
   demoninator1 : int,
   numerator2 : int,
   demoninator2 : int
);

Parameters

encoder
[To be supplied.]
numerator1
[To be supplied.]
demoninator1
[To be supplied.]
numerator2
[To be supplied.]
demoninator2
[To be supplied.]

See Also

EncoderParameter Class | EncoderParameter Members | System.Drawing.Imaging Namespace | EncoderParameter Constructor Overload List


EncoderParameter Constructor (Encoder, String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal encoder As Encoder, _
   ByVal _string As String _
)
[C#]
public EncoderParameter(
   Encoder encoder,
   string _string
);
[C++]
public: EncoderParameter(
   Encoder* encoder,
   String* _string
);
[JScript]
public function EncoderParameter(
   encoder : Encoder,
   _string : String
);

Parameters

encoder
[To be supplied.]
_string
[To be supplied.]

See Also

EncoderParameter Class | EncoderParameter Members | System.Drawing.Imaging Namespace | EncoderParameter Constructor Overload List


EncoderParameter Constructor (Encoder, Byte[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal encoder As Encoder, _
   ByVal _byte() As Byte _
)
[C#]
public EncoderParameter(
   Encoder encoder,
   byte[] _byte
);
[C++]
public: EncoderParameter(
   Encoder* encoder,
   unsigned char* _byte[]
);
[JScript]
public function EncoderParameter(
   encoder : Encoder,
   _byte : Byte[]
);

Parameters

encoder
[To be supplied.]
_byte
[To be supplied.]

See Also

EncoderParameter Class | EncoderParameter Members | System.Drawing.Imaging Namespace | EncoderParameter Constructor Overload List


EncoderParameter Constructor (Encoder, Byte[], Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal encoder As Encoder, _
   ByVal _byte() As Byte, _
   ByVal _undefined As Boolean _
)
[C#]
public EncoderParameter(
   Encoder encoder,
   byte[] _byte,
   bool _undefined
);
[C++]
public: EncoderParameter(
   Encoder* encoder,
   unsigned char* _byte[],
   bool _undefined
);
[JScript]
public function EncoderParameter(
   encoder : Encoder,
   _byte : Byte[],
   _undefined : Boolean
);

Parameters

encoder
[To be supplied.]
_byte
[To be supplied.]
_undefined
[To be supplied.]

See Also

EncoderParameter Class | EncoderParameter Members | System.Drawing.Imaging Namespace | EncoderParameter Constructor Overload List


EncoderParameter Constructor (Encoder, Int16[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal encoder As Encoder, _
   ByVal _short() As Short _
)
[C#]
public EncoderParameter(
   Encoder encoder,
   short[] _short
);
[C++]
public: EncoderParameter(
   Encoder* encoder,
   short* _short[]
);
[JScript]
public function EncoderParameter(
   encoder : Encoder,
   _short : Int16[]
);

Parameters

encoder
[To be supplied.]
_short
[To be supplied.]

See Also

EncoderParameter Class | EncoderParameter Members | System.Drawing.Imaging Namespace | EncoderParameter Constructor Overload List


EncoderParameter Constructor (Encoder, Int64[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal encoder As Encoder, _
   ByVal _long() As Long _
)
[C#]
public EncoderParameter(
   Encoder encoder,
   long[] _long
);
[C++]
public: EncoderParameter(
   Encoder* encoder,
   __int64* _long[]
);
[JScript]
public function EncoderParameter(
   encoder : Encoder,
   _long : long[]
);

Parameters

encoder
[To be supplied.]
_long
[To be supplied.]

See Also

EncoderParameter Class | EncoderParameter Members | System.Drawing.Imaging Namespace | EncoderParameter Constructor Overload List


EncoderParameter Constructor (Encoder, Int32[], Int32[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal encoder As Encoder, _
   ByVal numerator() As Integer, _
   ByVal denominator() As Integer _
)
[C#]
public EncoderParameter(
   Encoder encoder,
   int[] numerator,
   int[] denominator
);
[C++]
public: EncoderParameter(
   Encoder* encoder,
   int* numerator[],
   int* denominator[]
);
[JScript]
public function EncoderParameter(
   encoder : Encoder,
   numerator : int[],
   denominator : int[]
);

Parameters

encoder
[To be supplied.]
numerator
[To be supplied.]
denominator
[To be supplied.]

See Also

EncoderParameter Class | EncoderParameter Members | System.Drawing.Imaging Namespace | EncoderParameter Constructor Overload List


EncoderParameter Constructor (Encoder, Int64[], Int64[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal encoder As Encoder, _
   ByVal rangebegin() As Long, _
   ByVal rangeend() As Long _
)
[C#]
public EncoderParameter(
   Encoder encoder,
   long[] rangebegin,
   long[] rangeend
);
[C++]
public: EncoderParameter(
   Encoder* encoder,
   __int64* rangebegin[],
   __int64* rangeend[]
);
[JScript]
public function EncoderParameter(
   encoder : Encoder,
   rangebegin : long[],
   rangeend : long[]
);

Parameters

encoder
[To be supplied.]
rangebegin
[To be supplied.]
rangeend
[To be supplied.]

See Also

EncoderParameter Class | EncoderParameter Members | System.Drawing.Imaging Namespace | EncoderParameter Constructor Overload List


EncoderParameter Constructor (Encoder, Int32[], Int32[], Int32[], Int32[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal encoder As Encoder, _
   ByVal numerator1() As Integer, _
   ByVal denominator1() As Integer, _
   ByVal numerator2() As Integer, _
   ByVal denominator2() As Integer _
)
[C#]
public EncoderParameter(
   Encoder encoder,
   int[] numerator1,
   int[] denominator1,
   int[] numerator2,
   int[] denominator2
);
[C++]
public: EncoderParameter(
   Encoder* encoder,
   int* numerator1[],
   int* denominator1[],
   int* numerator2[],
   int* denominator2[]
);
[JScript]
public function EncoderParameter(
   encoder : Encoder,
   numerator1 : int[],
   denominator1 : int[],
   numerator2 : int[],
   denominator2 : int[]
);

Parameters

encoder
[To be supplied.]
numerator1
[To be supplied.]
denominator1
[To be supplied.]
numerator2
[To be supplied.]
denominator2
[To be supplied.]

See Also

EncoderParameter Class | EncoderParameter Members | System.Drawing.Imaging Namespace | EncoderParameter Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EncoderParameter Methods

The methods of the EncoderParameter class are listed below. For a complete list of EncoderParameter class members, see the EncoderParameter Members topic.

Public:

Dispose | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EncoderParameter Class | System.Drawing.Imaging Namespace


EncoderParameter.Dispose

[To be supplied.]

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[JScript]
public function Dispose();

See Also

EncoderParameter Class | EncoderParameter Members | System.Drawing.Imaging Namespace


EncoderParameters Class

[To be supplied.]

Object
EncoderParameters

[Visual Basic]
NotInheritable Public Class EncoderParameters
[C#]
public sealed class EncoderParameters
[C++]
public __gc __sealed class EncoderParameters
[JScript]
public class EncoderParameters

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

EncoderParameters Members | System.Drawing.Imaging Namespace


EncoderParameters Members

Public:

Constructor

EncoderParameters Constructor Overloaded. [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

param [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EncoderParameters Class | System.Drawing.Imaging Namespace


EncoderParameters Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public EncoderParameters(int);
[C++] public: EncoderParameters(int);
[JScript] public function EncoderParameters(int);

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public EncoderParameters();
[C++] public: EncoderParameters();
[JScript] public function EncoderParameters();

See Also

EncoderParameters Class | EncoderParameters Members | System.Drawing.Imaging Namespace


EncoderParameters Constructor (Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal count As Integer _
)
[C#]
public EncoderParameters(
   int count
);
[C++]
public: EncoderParameters(
   int count
);
[JScript]
public function EncoderParameters(
   count : int
);

Parameters

count
[To be supplied.]

See Also

EncoderParameters Class | EncoderParameters Members | System.Drawing.Imaging Namespace | EncoderParameters Constructor Overload List


EncoderParameters Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public EncoderParameters();
[C++]
public: EncoderParameters();
[JScript]
public function EncoderParameters();

See Also

EncoderParameters Class | EncoderParameters Members | System.Drawing.Imaging Namespace | EncoderParameters Constructor Overload List


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EncoderParameters Fields

The fields of the EncoderParameters class are listed below. For a complete list of EncoderParameters class members, see the EncoderParameters Members topic.

Public:

param [To be supplied.]

See Also

EncoderParameters Class | System.Drawing.Imaging Namespace


EncoderParameters.param

[To be supplied.]

[Visual Basic]
Public param() As EncoderParameter
[C#]
public EncoderParameter[] param;
[C++]
public: EncoderParameter* param[];
[JScript]
public var param : EncoderParameter[];

See Also

EncoderParameters Class | EncoderParameters Members | System.Drawing.Imaging Namespace


ImageAttributes Class

[To be supplied.]

Object
ImageAttributes

[Visual Basic]
NotInheritable Public Class ImageAttributes
   Implements ICloneable
[C#]
public sealed class ImageAttributes : ICloneable
[C++]
public __gc __sealed class ImageAttributes : public ICloneable
[JScript]
public class ImageAttributes implements ICloneable

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

ImageAttributes Members | System.Drawing.Imaging Namespace


ImageAttributes Members

Public:

Constructor

ImageAttributes Constructor [To be supplied.]

Methods

ClearBrushRemapTable | [To be supplied.]
ClearColorKey | Overloaded. [To be supplied.]
ClearColorMatrix | Overloaded. [To be supplied.]
ClearGamma | Overloaded. [To be supplied.]
ClearNoOp | Overloaded. [To be supplied.]
ClearOutputChannel | Overloaded. [To be supplied.]
ClearOutputChannelColorProfile | Overloaded. [To be supplied.]
ClearRemapTable | Overloaded. [To be supplied.]
ClearThreshold | Overloaded. [To be supplied.]
Clone | [To be supplied.]
Dispose | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetAdjustedPalette | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SetBrushRemapTable | [To be supplied.]
SetColorKey | Overloaded. [To be supplied.]
SetColorMatrices | Overloaded. [To be supplied.]
SetColorMatrix | Overloaded. [To be supplied.]
SetGamma | Overloaded. [To be supplied.]
SetICMMode | [To be supplied.]
SetNoOp | Overloaded. [To be supplied.]
SetOutputChannel | Overloaded. [To be supplied.]
SetOutputChannelColorProfile | Overloaded. [To be supplied.]
SetRemapTable | Overloaded. [To be supplied.]
SetThreshold | Overloaded. [To be supplied.]
SetWrapMode | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ImageAttributes Class | System.Drawing.Imaging Namespace


ImageAttributes Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ImageAttributes();
[C++]
public: ImageAttributes();
[JScript]
public function ImageAttributes();

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ImageAttributes Methods

The methods of the ImageAttributes class are listed below. For a complete list of ImageAttributes class members, see the ImageAttributes Members topic.

Public:

ClearBrushRemapTable | [To be supplied.]
ClearColorKey | Overloaded. [To be supplied.]
ClearColorMatrix | Overloaded. [To be supplied.]
ClearGamma | Overloaded. [To be supplied.]
ClearNoOp | Overloaded. [To be supplied.]
ClearOutputChannel | Overloaded. [To be supplied.]
ClearOutputChannelColorProfile | Overloaded. [To be supplied.]
ClearRemapTable | Overloaded. [To be supplied.]
ClearThreshold | Overloaded. [To be supplied.]
Clone | [To be supplied.]
Dispose | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetAdjustedPalette | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SetBrushRemapTable | [To be supplied.]
SetColorKey | Overloaded. [To be supplied.]
SetColorMatrices | Overloaded. [To be supplied.]
SetColorMatrix | Overloaded. [To be supplied.]
SetGamma | Overloaded. [To be supplied.]
SetICMMode | [To be supplied.]
SetNoOp | Overloaded. [To be supplied.]
SetOutputChannel | Overloaded. [To be supplied.]
SetOutputChannelColorProfile | Overloaded. [To be supplied.]
SetRemapTable | Overloaded. [To be supplied.]
SetThreshold | Overloaded. [To be supplied.]
SetWrapMode | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ImageAttributes Class | System.Drawing.Imaging Namespace


ImageAttributes.ClearBrushRemapTable

[To be supplied.]

[Visual Basic]
Public Sub ClearBrushRemapTable()
[C#]
public void ClearBrushRemapTable();
[C++]
public: void ClearBrushRemapTable();
[JScript]
public function ClearBrushRemapTable();

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace


ImageAttributes.ClearColorKey

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub ClearColorKey(ColorAdjustType)
[C#] public void ClearColorKey(ColorAdjustType);
[C++] public: void ClearColorKey(ColorAdjustType);
[JScript] public function ClearColorKey(ColorAdjustType);

[To be supplied.]

[Visual Basic] Overloads Public Sub ClearColorKey()
[C#] public void ClearColorKey();
[C++] public: void ClearColorKey();
[JScript] public function ClearColorKey();

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace


ImageAttributes.ClearColorKey (ColorAdjustType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub ClearColorKey( _
   ByVal type As ColorAdjustType _
)
[C#]
public void ClearColorKey(
   ColorAdjustType type
);
[C++]
public: void ClearColorKey(
   ColorAdjustType type
);
[JScript]
public function ClearColorKey(
   type : ColorAdjustType
);

Parameters

type
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.ClearColorKey Overload List


ImageAttributes.ClearColorKey ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub ClearColorKey()
[C#]
public void ClearColorKey();
[C++]
public: void ClearColorKey();
[JScript]
public function ClearColorKey();

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.ClearColorKey Overload List


ImageAttributes.ClearColorMatrix

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub ClearColorMatrix()
[C#] public void ClearColorMatrix();
[C++] public: void ClearColorMatrix();
[JScript] public function ClearColorMatrix();

[To be supplied.]

[Visual Basic] Overloads Public Sub ClearColorMatrix(ColorAdjustType)
[C#] public void ClearColorMatrix(ColorAdjustType);
[C++] public: void ClearColorMatrix(ColorAdjustType);
[JScript] public function ClearColorMatrix(ColorAdjustType);

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace


ImageAttributes.ClearColorMatrix ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub ClearColorMatrix()
[C#]
public void ClearColorMatrix();
[C++]
public: void ClearColorMatrix();
[JScript]
public function ClearColorMatrix();

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.ClearColorMatrix Overload List


ImageAttributes.ClearColorMatrix (ColorAdjustType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub ClearColorMatrix( _
   ByVal type As ColorAdjustType _
)
[C#]
public void ClearColorMatrix(
   ColorAdjustType type
);
[C++]
public: void ClearColorMatrix(
   ColorAdjustType type
);
[JScript]
public function ClearColorMatrix(
   type : ColorAdjustType
);

Parameters

type
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.ClearColorMatrix Overload List


ImageAttributes.ClearGamma

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub ClearGamma(ColorAdjustType)
[C#] public void ClearGamma(ColorAdjustType);
[C++] public: void ClearGamma(ColorAdjustType);
[JScript] public function ClearGamma(ColorAdjustType);

[To be supplied.]

[Visual Basic] Overloads Public Sub ClearGamma()
[C#] public void ClearGamma();
[C++] public: void ClearGamma();
[JScript] public function ClearGamma();

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace


ImageAttributes.ClearGamma (ColorAdjustType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub ClearGamma( _
   ByVal type As ColorAdjustType _
)
[C#]
public void ClearGamma(
   ColorAdjustType type
);
[C++]
public: void ClearGamma(
   ColorAdjustType type
);
[JScript]
public function ClearGamma(
   type : ColorAdjustType
);

Parameters

type
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.ClearGamma Overload List


ImageAttributes.ClearGamma ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub ClearGamma()
[C#]
public void ClearGamma();
[C++]
public: void ClearGamma();
[JScript]
public function ClearGamma();

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.ClearGamma Overload List


ImageAttributes.ClearNoOp

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub ClearNoOp()
[C#] public void ClearNoOp();
[C++] public: void ClearNoOp();
[JScript] public function ClearNoOp();

[To be supplied.]

[Visual Basic] Overloads Public Sub ClearNoOp(ColorAdjustType)
[C#] public void ClearNoOp(ColorAdjustType);
[C++] public: void ClearNoOp(ColorAdjustType);
[JScript] public function ClearNoOp(ColorAdjustType);

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace


ImageAttributes.ClearNoOp ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub ClearNoOp()
[C#]
public void ClearNoOp();
[C++]
public: void ClearNoOp();
[JScript]
public function ClearNoOp();

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.ClearNoOp Overload List


ImageAttributes.ClearNoOp (ColorAdjustType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub ClearNoOp( _
   ByVal type As ColorAdjustType _
)
[C#]
public void ClearNoOp(
   ColorAdjustType type
);
[C++]
public: void ClearNoOp(
   ColorAdjustType type
);
[JScript]
public function ClearNoOp(
   type : ColorAdjustType
);

Parameters

type
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.ClearNoOp Overload List


ImageAttributes.ClearOutputChannel

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub ClearOutputChannel(ColorAdjustType)
[C#] public void ClearOutputChannel(ColorAdjustType);
[C++] public: void ClearOutputChannel(ColorAdjustType);
[JScript] public function ClearOutputChannel(ColorAdjustType);

[To be supplied.]

[Visual Basic] Overloads Public Sub ClearOutputChannel()
[C#] public void ClearOutputChannel();
[C++] public: void ClearOutputChannel();
[JScript] public function ClearOutputChannel();

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace


ImageAttributes.ClearOutputChannel (ColorAdjustType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub ClearOutputChannel( _
   ByVal type As ColorAdjustType _
)
[C#]
public void ClearOutputChannel(
   ColorAdjustType type
);
[C++]
public: void ClearOutputChannel(
   ColorAdjustType type
);
[JScript]
public function ClearOutputChannel(
   type : ColorAdjustType
);

Parameters

type
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.ClearOutputChannel Overload List


ImageAttributes.ClearOutputChannel ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub ClearOutputChannel()
[C#]
public void ClearOutputChannel();
[C++]
public: void ClearOutputChannel();
[JScript]
public function ClearOutputChannel();

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.ClearOutputChannel Overload List


ImageAttributes.ClearOutputChannelColorProfile

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub ClearOutputChannelColorProfile(ColorAdjustType)
[C#] public void ClearOutputChannelColorProfile(ColorAdjustType);
[C++] public: void ClearOutputChannelColorProfile(ColorAdjustType);
[JScript] public function ClearOutputChannelColorProfile(ColorAdjustType);

[To be supplied.]

[Visual Basic] Overloads Public Sub ClearOutputChannelColorProfile()
[C#] public void ClearOutputChannelColorProfile();
[C++] public: void ClearOutputChannelColorProfile();
[JScript] public function ClearOutputChannelColorProfile();

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace


ImageAttributes.ClearOutputChannelColorProfile (ColorAdjustType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub ClearOutputChannelColorProfile( _
   ByVal type As ColorAdjustType _
)
[C#]
public void ClearOutputChannelColorProfile(
   ColorAdjustType type
);
[C++]
public: void ClearOutputChannelColorProfile(
   ColorAdjustType type
);
[JScript]
public function ClearOutputChannelColorProfile(
   type : ColorAdjustType
);

Parameters

type
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.ClearOutputChannelColorProfile Overload List


ImageAttributes.ClearOutputChannelColorProfile ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub ClearOutputChannelColorProfile()
[C#]
public void ClearOutputChannelColorProfile();
[C++]
public: void ClearOutputChannelColorProfile();
[JScript]
public function ClearOutputChannelColorProfile();

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.ClearOutputChannelColorProfile Overload List


ImageAttributes.ClearRemapTable

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub ClearRemapTable(ColorAdjustType)
[C#] public void ClearRemapTable(ColorAdjustType);
[C++] public: void ClearRemapTable(ColorAdjustType);
[JScript] public function ClearRemapTable(ColorAdjustType);

[To be supplied.]

[Visual Basic] Overloads Public Sub ClearRemapTable()
[C#] public void ClearRemapTable();
[C++] public: void ClearRemapTable();
[JScript] public function ClearRemapTable();

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace


ImageAttributes.ClearRemapTable (ColorAdjustType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub ClearRemapTable( _
   ByVal type As ColorAdjustType _
)
[C#]
public void ClearRemapTable(
   ColorAdjustType type
);
[C++]
public: void ClearRemapTable(
   ColorAdjustType type
);
[JScript]
public function ClearRemapTable(
   type : ColorAdjustType
);

Parameters

type
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.ClearRemapTable Overload List


ImageAttributes.ClearRemapTable ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub ClearRemapTable()
[C#]
public void ClearRemapTable();
[C++]
public: void ClearRemapTable();
[JScript]
public function ClearRemapTable();

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.ClearRemapTable Overload List


ImageAttributes.ClearThreshold

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub ClearThreshold()
[C#] public void ClearThreshold();
[C++] public: void ClearThreshold();
[JScript] public function ClearThreshold();

[To be supplied.]

[Visual Basic] Overloads Public Sub ClearThreshold(ColorAdjustType)
[C#] public void ClearThreshold(ColorAdjustType);
[C++] public: void ClearThreshold(ColorAdjustType);
[JScript] public function ClearThreshold(ColorAdjustType);

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace


ImageAttributes.ClearThreshold ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub ClearThreshold()
[C#]
public void ClearThreshold();
[C++]
public: void ClearThreshold();
[JScript]
public function ClearThreshold();

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.ClearThreshold Overload List


ImageAttributes.ClearThreshold (ColorAdjustType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub ClearThreshold( _
   ByVal type As ColorAdjustType _
)
[C#]
public void ClearThreshold(
   ColorAdjustType type
);
[C++]
public: void ClearThreshold(
   ColorAdjustType type
);
[JScript]
public function ClearThreshold(
   type : ColorAdjustType
);

Parameters

type
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.ClearThreshold Overload List


ImageAttributes.Clone

[To be supplied.]

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace


ImageAttributes.Dispose

[To be supplied.]

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[JScript]
public function Dispose();

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace


ImageAttributes.Finalize

[To be supplied.]

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace


ImageAttributes.GetAdjustedPalette

[To be supplied.]

[Visual Basic]
Public Sub GetAdjustedPalette( _
   ByVal palette As ColorPalette, _
   ByVal type As ColorAdjustType _
)
[C#]
public void GetAdjustedPalette(
   ColorPalette palette,
   ColorAdjustType type
);
[C++]
public: void GetAdjustedPalette(
   ColorPalette* palette,
   ColorAdjustType type
);
[JScript]
public function GetAdjustedPalette(
   palette : ColorPalette,
   type : ColorAdjustType
);

Parameters

palette
[To be supplied.]
type
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace


ImageAttributes.SetBrushRemapTable

[To be supplied.]

[Visual Basic]
Public Sub SetBrushRemapTable( _
   ByVal map() As ColorMap _
)
[C#]
public void SetBrushRemapTable(
   ColorMap[] map
);
[C++]
public: void SetBrushRemapTable(
   ColorMap* map[]
);
[JScript]
public function SetBrushRemapTable(
   map : ColorMap[]
);

Parameters

map
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace


ImageAttributes.SetColorKey

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub SetColorKey(Color, Color, ColorAdjustType)
[C#] public void SetColorKey(Color, Color, ColorAdjustType);
[C++] public: void SetColorKey(Color, Color, ColorAdjustType);
[JScript] public function SetColorKey(Color, Color, ColorAdjustType);

[To be supplied.]

[Visual Basic] Overloads Public Sub SetColorKey(Color, Color)
[C#] public void SetColorKey(Color, Color);
[C++] public: void SetColorKey(Color, Color);
[JScript] public function SetColorKey(Color, Color);

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace


ImageAttributes.SetColorKey (Color, Color, ColorAdjustType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetColorKey( _
   ByVal colorLow As Color, _
   ByVal colorHigh As Color, _
   ByVal type As ColorAdjustType _
)
[C#]
public void SetColorKey(
   Color colorLow,
   Color colorHigh,
   ColorAdjustType type
);
[C++]
public: void SetColorKey(
   Color colorLow,
   Color colorHigh,
   ColorAdjustType type
);
[JScript]
public function SetColorKey(
   colorLow : Color,
   colorHigh : Color,
   type : ColorAdjustType
);

Parameters

colorLow
[To be supplied.]
colorHigh
[To be supplied.]
type
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.SetColorKey Overload List


ImageAttributes.SetColorKey (Color, Color)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetColorKey( _
   ByVal colorLow As Color, _
   ByVal colorHigh As Color _
)
[C#]
public void SetColorKey(
   Color colorLow,
   Color colorHigh
);
[C++]
public: void SetColorKey(
   Color colorLow,
   Color colorHigh
);
[JScript]
public function SetColorKey(
   colorLow : Color,
   colorHigh : Color
);

Parameters

colorLow
[To be supplied.]
colorHigh
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.SetColorKey Overload List


ImageAttributes.SetColorMatrices

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub SetColorMatrices(ColorMatrix, ColorMatrix, ColorMatrixFlags)
[C#] public void SetColorMatrices(ColorMatrix, ColorMatrix, ColorMatrixFlags);
[C++] public: void SetColorMatrices(ColorMatrix*, ColorMatrix*, ColorMatrixFlags);
[JScript] public function SetColorMatrices(ColorMatrix, ColorMatrix, ColorMatrixFlags);

[To be supplied.]

[Visual Basic] Overloads Public Sub SetColorMatrices(ColorMatrix, ColorMatrix)
[C#] public void SetColorMatrices(ColorMatrix, ColorMatrix);
[C++] public: void SetColorMatrices(ColorMatrix*, ColorMatrix*);
[JScript] public function SetColorMatrices(ColorMatrix, ColorMatrix);

[To be supplied.]

[Visual Basic] Overloads Public Sub SetColorMatrices(ColorMatrix, ColorMatrix, ColorMatrixFlags, ColorAdjustType)
[C#] public void SetColorMatrices(ColorMatrix, ColorMatrix, ColorMatrixFlags, ColorAdjustType);
[C++] public: void SetColorMatrices(ColorMatrix*, ColorMatrix*, ColorMatrixFlags, ColorAdjustType);
[JScript] public function SetColorMatrices(ColorMatrix, ColorMatrix, ColorMatrixFlags, ColorAdjustType);

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace


ImageAttributes.SetColorMatrices (ColorMatrix, ColorMatrix, ColorMatrixFlags)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetColorMatrices( _
   ByVal newColorMatrix As ColorMatrix, _
   ByVal grayMatrix As ColorMatrix, _
   ByVal flags As ColorMatrixFlags _
)
[C#]
public void SetColorMatrices(
   ColorMatrix newColorMatrix,
   ColorMatrix grayMatrix,
   ColorMatrixFlags flags
);
[C++]
public: void SetColorMatrices(
   ColorMatrix* newColorMatrix,
   ColorMatrix* grayMatrix,
   ColorMatrixFlags flags
);
[JScript]
public function SetColorMatrices(
   newColorMatrix : ColorMatrix,
   grayMatrix : ColorMatrix,
   flags : ColorMatrixFlags
);

Parameters

newColorMatrix
[To be supplied.]
grayMatrix
[To be supplied.]
flags
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.SetColorMatrices Overload List


ImageAttributes.SetColorMatrices (ColorMatrix, ColorMatrix)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetColorMatrices( _
   ByVal newColorMatrix As ColorMatrix, _
   ByVal grayMatrix As ColorMatrix _
)
[C#]
public void SetColorMatrices(
   ColorMatrix newColorMatrix,
   ColorMatrix grayMatrix
);
[C++]
public: void SetColorMatrices(
   ColorMatrix* newColorMatrix,
   ColorMatrix* grayMatrix
);
[JScript]
public function SetColorMatrices(
   newColorMatrix : ColorMatrix,
   grayMatrix : ColorMatrix
);

Parameters

newColorMatrix
[To be supplied.]
grayMatrix
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.SetColorMatrices Overload List


ImageAttributes.SetColorMatrices (ColorMatrix, ColorMatrix, ColorMatrixFlags, ColorAdjustType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetColorMatrices( _
   ByVal newColorMatrix As ColorMatrix, _
   ByVal grayMatrix As ColorMatrix, _
   ByVal mode As ColorMatrixFlags, _
   ByVal type As ColorAdjustType _
)
[C#]
public void SetColorMatrices(
   ColorMatrix newColorMatrix,
   ColorMatrix grayMatrix,
   ColorMatrixFlags mode,
   ColorAdjustType type
);
[C++]
public: void SetColorMatrices(
   ColorMatrix* newColorMatrix,
   ColorMatrix* grayMatrix,
   ColorMatrixFlags mode,
   ColorAdjustType type
);
[JScript]
public function SetColorMatrices(
   newColorMatrix : ColorMatrix,
   grayMatrix : ColorMatrix,
   mode : ColorMatrixFlags,
   type : ColorAdjustType
);

Parameters

newColorMatrix
[To be supplied.]
grayMatrix
[To be supplied.]
mode
[To be supplied.]
type
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.SetColorMatrices Overload List


ImageAttributes.SetColorMatrix

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub SetColorMatrix(ColorMatrix, ColorMatrixFlags)
[C#] public void SetColorMatrix(ColorMatrix, ColorMatrixFlags);
[C++] public: void SetColorMatrix(ColorMatrix*, ColorMatrixFlags);
[JScript] public function SetColorMatrix(ColorMatrix, ColorMatrixFlags);

[To be supplied.]

[Visual Basic] Overloads Public Sub SetColorMatrix(ColorMatrix)
[C#] public void SetColorMatrix(ColorMatrix);
[C++] public: void SetColorMatrix(ColorMatrix*);
[JScript] public function SetColorMatrix(ColorMatrix);

[To be supplied.]

[Visual Basic] Overloads Public Sub SetColorMatrix(ColorMatrix, ColorMatrixFlags, ColorAdjustType)
[C#] public void SetColorMatrix(ColorMatrix, ColorMatrixFlags, ColorAdjustType);
[C++] public: void SetColorMatrix(ColorMatrix*, ColorMatrixFlags, ColorAdjustType);
[JScript] public function SetColorMatrix(ColorMatrix, ColorMatrixFlags, ColorAdjustType);

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace


ImageAttributes.SetColorMatrix (ColorMatrix, ColorMatrixFlags)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetColorMatrix( _
   ByVal newColorMatrix As ColorMatrix, _
   ByVal flags As ColorMatrixFlags _
)
[C#]
public void SetColorMatrix(
   ColorMatrix newColorMatrix,
   ColorMatrixFlags flags
);
[C++]
public: void SetColorMatrix(
   ColorMatrix* newColorMatrix,
   ColorMatrixFlags flags
);
[JScript]
public function SetColorMatrix(
   newColorMatrix : ColorMatrix,
   flags : ColorMatrixFlags
);

Parameters

newColorMatrix
[To be supplied.]
flags
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.SetColorMatrix Overload List


ImageAttributes.SetColorMatrix (ColorMatrix)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetColorMatrix( _
   ByVal newColorMatrix As ColorMatrix _
)
[C#]
public void SetColorMatrix(
   ColorMatrix newColorMatrix
);
[C++]
public: void SetColorMatrix(
   ColorMatrix* newColorMatrix
);
[JScript]
public function SetColorMatrix(
   newColorMatrix : ColorMatrix
);

Parameters

newColorMatrix
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.SetColorMatrix Overload List


ImageAttributes.SetColorMatrix (ColorMatrix, ColorMatrixFlags, ColorAdjustType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetColorMatrix( _
   ByVal newColorMatrix As ColorMatrix, _
   ByVal mode As ColorMatrixFlags, _
   ByVal type As ColorAdjustType _
)
[C#]
public void SetColorMatrix(
   ColorMatrix newColorMatrix,
   ColorMatrixFlags mode,
   ColorAdjustType type
);
[C++]
public: void SetColorMatrix(
   ColorMatrix* newColorMatrix,
   ColorMatrixFlags mode,
   ColorAdjustType type
);
[JScript]
public function SetColorMatrix(
   newColorMatrix : ColorMatrix,
   mode : ColorMatrixFlags,
   type : ColorAdjustType
);

Parameters

newColorMatrix
[To be supplied.]
mode
[To be supplied.]
type
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.SetColorMatrix Overload List


ImageAttributes.SetGamma

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub SetGamma(Single)
[C#] public void SetGamma(float);
[C++] public: void SetGamma(float);
[JScript] public function SetGamma(float);

[To be supplied.]

[Visual Basic] Overloads Public Sub SetGamma(Single, ColorAdjustType)
[C#] public void SetGamma(float, ColorAdjustType);
[C++] public: void SetGamma(float, ColorAdjustType);
[JScript] public function SetGamma(float, ColorAdjustType);

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace


ImageAttributes.SetGamma (Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetGamma( _
   ByVal gamma As Single _
)
[C#]
public void SetGamma(
   float gamma
);
[C++]
public: void SetGamma(
   float gamma
);
[JScript]
public function SetGamma(
   gamma : float
);

Parameters

gamma
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.SetGamma Overload List


ImageAttributes.SetGamma (Single, ColorAdjustType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetGamma( _
   ByVal gamma As Single, _
   ByVal type As ColorAdjustType _
)
[C#]
public void SetGamma(
   float gamma,
   ColorAdjustType type
);
[C++]
public: void SetGamma(
   float gamma,
   ColorAdjustType type
);
[JScript]
public function SetGamma(
   gamma : float,
   type : ColorAdjustType
);

Parameters

gamma
[To be supplied.]
type
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.SetGamma Overload List


ImageAttributes.SetICMMode

[To be supplied.]

[Visual Basic]
Public Sub SetICMMode( _
   ByVal ICMon As Boolean _
)
[C#]
public void SetICMMode(
   bool ICMon
);
[C++]
public: void SetICMMode(
   bool ICMon
);
[JScript]
public function SetICMMode(
   ICMon : Boolean
);

Parameters

ICMon
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace


ImageAttributes.SetNoOp

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub SetNoOp(ColorAdjustType)
[C#] public void SetNoOp(ColorAdjustType);
[C++] public: void SetNoOp(ColorAdjustType);
[JScript] public function SetNoOp(ColorAdjustType);

[To be supplied.]

[Visual Basic] Overloads Public Sub SetNoOp()
[C#] public void SetNoOp();
[C++] public: void SetNoOp();
[JScript] public function SetNoOp();

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace


ImageAttributes.SetNoOp (ColorAdjustType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetNoOp( _
   ByVal type As ColorAdjustType _
)
[C#]
public void SetNoOp(
   ColorAdjustType type
);
[C++]
public: void SetNoOp(
   ColorAdjustType type
);
[JScript]
public function SetNoOp(
   type : ColorAdjustType
);

Parameters

type
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.SetNoOp Overload List


ImageAttributes.SetNoOp ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetNoOp()
[C#]
public void SetNoOp();
[C++]
public: void SetNoOp();
[JScript]
public function SetNoOp();

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.SetNoOp Overload List


ImageAttributes.SetOutputChannel

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub SetOutputChannel(ColorChannelFlags)
[C#] public void SetOutputChannel(ColorChannelFlags);
[C++] public: void SetOutputChannel(ColorChannelFlags);
[JScript] public function SetOutputChannel(ColorChannelFlags);

[To be supplied.]

[Visual Basic] Overloads Public Sub SetOutputChannel(ColorChannelFlags, ColorAdjustType)
[C#] public void SetOutputChannel(ColorChannelFlags, ColorAdjustType);
[C++] public: void SetOutputChannel(ColorChannelFlags, ColorAdjustType);
[JScript] public function SetOutputChannel(ColorChannelFlags, ColorAdjustType);

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace


ImageAttributes.SetOutputChannel (ColorChannelFlags)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetOutputChannel( _
   ByVal flags As ColorChannelFlags _
)
[C#]
public void SetOutputChannel(
   ColorChannelFlags flags
);
[C++]
public: void SetOutputChannel(
   ColorChannelFlags flags
);
[JScript]
public function SetOutputChannel(
   flags : ColorChannelFlags
);

Parameters

flags
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.SetOutputChannel Overload List


ImageAttributes.SetOutputChannel (ColorChannelFlags, ColorAdjustType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetOutputChannel( _
   ByVal flags As ColorChannelFlags, _
   ByVal type As ColorAdjustType _
)
[C#]
public void SetOutputChannel(
   ColorChannelFlags flags,
   ColorAdjustType type
);
[C++]
public: void SetOutputChannel(
   ColorChannelFlags flags,
   ColorAdjustType type
);
[JScript]
public function SetOutputChannel(
   flags : ColorChannelFlags,
   type : ColorAdjustType
);

Parameters

flags
[To be supplied.]
type
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.SetOutputChannel Overload List


ImageAttributes.SetOutputChannelColorProfile

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub SetOutputChannelColorProfile(String)
[C#] public void SetOutputChannelColorProfile(String);
[C++] public: void SetOutputChannelColorProfile(String*);
[JScript] public function SetOutputChannelColorProfile(String);

[To be supplied.]

[Visual Basic] Overloads Public Sub SetOutputChannelColorProfile(String, ColorAdjustType)
[C#] public void SetOutputChannelColorProfile(String, ColorAdjustType);
[C++] public: void SetOutputChannelColorProfile(String*, ColorAdjustType);
[JScript] public function SetOutputChannelColorProfile(String, ColorAdjustType);

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace


ImageAttributes.SetOutputChannelColorProfile (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetOutputChannelColorProfile( _
   ByVal colorProfileFilename As String _
)
[C#]
public void SetOutputChannelColorProfile(
   string colorProfileFilename
);
[C++]
public: void SetOutputChannelColorProfile(
   String* colorProfileFilename
);
[JScript]
public function SetOutputChannelColorProfile(
   colorProfileFilename : String
);

Parameters

colorProfileFilename
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.SetOutputChannelColorProfile Overload List


ImageAttributes.SetOutputChannelColorProfile (String, ColorAdjustType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetOutputChannelColorProfile( _
   ByVal colorProfileFilename As String, _
   ByVal type As ColorAdjustType _
)
[C#]
public void SetOutputChannelColorProfile(
   string colorProfileFilename,
   ColorAdjustType type
);
[C++]
public: void SetOutputChannelColorProfile(
   String* colorProfileFilename,
   ColorAdjustType type
);
[JScript]
public function SetOutputChannelColorProfile(
   colorProfileFilename : String,
   type : ColorAdjustType
);

Parameters

colorProfileFilename
[To be supplied.]
type
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.SetOutputChannelColorProfile Overload List


ImageAttributes.SetRemapTable

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub SetRemapTable(ColorMap(), ColorAdjustType)
[C#] public void SetRemapTable(ColorMap[], ColorAdjustType);
[C++] public: void SetRemapTable(ColorMap*[], ColorAdjustType);
[JScript] public function SetRemapTable(ColorMap[], ColorAdjustType);

[To be supplied.]

[Visual Basic] Overloads Public Sub SetRemapTable(ColorMap())
[C#] public void SetRemapTable(ColorMap[]);
[C++] public: void SetRemapTable(ColorMap*[]);
[JScript] public function SetRemapTable(ColorMap[]);

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace


ImageAttributes.SetRemapTable (ColorMap[], ColorAdjustType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetRemapTable( _
   ByVal map() As ColorMap, _
   ByVal type As ColorAdjustType _
)
[C#]
public void SetRemapTable(
   ColorMap[] map,
   ColorAdjustType type
);
[C++]
public: void SetRemapTable(
   ColorMap* map[],
   ColorAdjustType type
);
[JScript]
public function SetRemapTable(
   map : ColorMap[],
   type : ColorAdjustType
);

Parameters

map
[To be supplied.]
type
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.SetRemapTable Overload List


ImageAttributes.SetRemapTable (ColorMap[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetRemapTable( _
   ByVal map() As ColorMap _
)
[C#]
public void SetRemapTable(
   ColorMap[] map
);
[C++]
public: void SetRemapTable(
   ColorMap* map[]
);
[JScript]
public function SetRemapTable(
   map : ColorMap[]
);

Parameters

map
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.SetRemapTable Overload List


ImageAttributes.SetThreshold

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub SetThreshold(Single)
[C#] public void SetThreshold(float);
[C++] public: void SetThreshold(float);
[JScript] public function SetThreshold(float);

[To be supplied.]

[Visual Basic] Overloads Public Sub SetThreshold(Single, ColorAdjustType)
[C#] public void SetThreshold(float, ColorAdjustType);
[C++] public: void SetThreshold(float, ColorAdjustType);
[JScript] public function SetThreshold(float, ColorAdjustType);

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace


ImageAttributes.SetThreshold (Single)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetThreshold( _
   ByVal threshold As Single _
)
[C#]
public void SetThreshold(
   float threshold
);
[C++]
public: void SetThreshold(
   float threshold
);
[JScript]
public function SetThreshold(
   threshold : float
);

Parameters

threshold
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.SetThreshold Overload List


ImageAttributes.SetThreshold (Single, ColorAdjustType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetThreshold( _
   ByVal threshold As Single, _
   ByVal type As ColorAdjustType _
)
[C#]
public void SetThreshold(
   float threshold,
   ColorAdjustType type
);
[C++]
public: void SetThreshold(
   float threshold,
   ColorAdjustType type
);
[JScript]
public function SetThreshold(
   threshold : float,
   type : ColorAdjustType
);

Parameters

threshold
[To be supplied.]
type
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.SetThreshold Overload List


ImageAttributes.SetWrapMode

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub SetWrapMode(WrapMode)
[C#] public void SetWrapMode(WrapMode);
[C++] public: void SetWrapMode(WrapMode);
[JScript] public function SetWrapMode(WrapMode);

[To be supplied.]

[Visual Basic] Overloads Public Sub SetWrapMode(WrapMode, Color)
[C#] public void SetWrapMode(WrapMode, Color);
[C++] public: void SetWrapMode(WrapMode, Color);
[JScript] public function SetWrapMode(WrapMode, Color);

[To be supplied.]

[Visual Basic] Overloads Public Sub SetWrapMode(WrapMode, Color, Boolean)
[C#] public void SetWrapMode(WrapMode, Color, bool);
[C++] public: void SetWrapMode(WrapMode, Color, bool);
[JScript] public function SetWrapMode(WrapMode, Color, Boolean);

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace


ImageAttributes.SetWrapMode (WrapMode)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetWrapMode( _
   ByVal mode As WrapMode _
)
[C#]
public void SetWrapMode(
   WrapMode mode
);
[C++]
public: void SetWrapMode(
   WrapMode mode
);
[JScript]
public function SetWrapMode(
   mode : WrapMode
);

Parameters

mode
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.SetWrapMode Overload List


ImageAttributes.SetWrapMode (WrapMode, Color)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetWrapMode( _
   ByVal mode As WrapMode, _
   ByVal color As Color _
)
[C#]
public void SetWrapMode(
   WrapMode mode,
   Color color
);
[C++]
public: void SetWrapMode(
   WrapMode mode,
   Color color
);
[JScript]
public function SetWrapMode(
   mode : WrapMode,
   color : Color
);

Parameters

mode
[To be supplied.]
color
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.SetWrapMode Overload List


ImageAttributes.SetWrapMode (WrapMode, Color, Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetWrapMode( _
   ByVal mode As WrapMode, _
   ByVal color As Color, _
   ByVal clamp As Boolean _
)
[C#]
public void SetWrapMode(
   WrapMode mode,
   Color color,
   bool clamp
);
[C++]
public: void SetWrapMode(
   WrapMode mode,
   Color color,
   bool clamp
);
[JScript]
public function SetWrapMode(
   mode : WrapMode,
   color : Color,
   clamp : Boolean
);

Parameters

mode
[To be supplied.]
color
[To be supplied.]
clamp
[To be supplied.]

See Also

ImageAttributes Class | ImageAttributes Members | System.Drawing.Imaging Namespace | ImageAttributes.SetWrapMode Overload List


ImageCodecFlags Enumeration

[To be supplied.]

[Visual Basic]
Public Enum ImageCodecFlags
[C#]
public enum ImageCodecFlags
[C++]
public enum ImageCodecFlags

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
BlockingDecode | [To be supplied.]
Builtin | [To be supplied.]
Decoder | [To be supplied.]
Encoder | [To be supplied.]
SeekableEncode | [To be supplied.]
SupportBitmap | [To be supplied.]
SupportVector | [To be supplied.]
System | [To be supplied.]
User | [To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

System.Drawing.Imaging Namespace


ImageCodecInfo Class

[To be supplied.]

Object
ImageCodecInfo

[Visual Basic]
NotInheritable Public Class ImageCodecInfo
[C#]
public sealed class ImageCodecInfo
[C++]
public __gc __sealed class ImageCodecInfo
[JScript]
public class ImageCodecInfo

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

ImageCodecInfo Members | System.Drawing.Imaging Namespace


ImageCodecInfo Members

Public:

Methods

AddImageCodec | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetImageDecoders | [To be supplied.]
GetImageEncoders | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
RemoveImageCodec | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Clsid | [To be supplied.]
CodecName | [To be supplied.]
DllName | [To be supplied.]
FilenameExtension | [To be supplied.]
Flags | [To be supplied.]
FormatDescription | [To be supplied.]
FormatID | [To be supplied.]
MimeType | [To be supplied.]
SignatureMasks | [To be supplied.]
SignaturePatterns | [To be supplied.]
Version | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ImageCodecInfo Class | System.Drawing.Imaging Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ImageCodecInfo Methods

The methods of the ImageCodecInfo class are listed below. For a complete list of ImageCodecInfo class members, see the ImageCodecInfo Members topic.

Public:

AddImageCodec | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetImageDecoders | [To be supplied.]
GetImageEncoders | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
RemoveImageCodec | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ImageCodecInfo Class | System.Drawing.Imaging Namespace


ImageCodecInfo.AddImageCodec

[To be supplied.]

[Visual Basic]
Public Shared Sub AddImageCodec( _
   ByVal imagecs As ImageCodecInfo _
)
[C#]
public static void AddImageCodec(
   ImageCodecInfo imagecs
);
[C++]
public: static void AddImageCodec(
   ImageCodecInfo* imagecs
);
[JScript]
public static function AddImageCodec(
   imagecs : ImageCodecInfo
);

Parameters

imagecs
[To be supplied.]

See Also

ImageCodecInfo Class | ImageCodecInfo Members | System.Drawing.Imaging Namespace


ImageCodecInfo.GetImageDecoders

[To be supplied.]

[Visual Basic]
Public Shared Function GetImageDecoders() As ImageCodecInfo ()
[C#]
public static ImageCodecInfo[] GetImageDecoders();
[C++]
public: static ImageCodecInfo* GetImageDecoders() [];
[JScript]
public static function GetImageDecoders() : ImageCodecInfo[];

See Also

ImageCodecInfo Class | ImageCodecInfo Members | System.Drawing.Imaging Namespace


ImageCodecInfo.GetImageEncoders

[To be supplied.]

[Visual Basic]
Public Shared Function GetImageEncoders() As ImageCodecInfo ()
[C#]
public static ImageCodecInfo[] GetImageEncoders();
[C++]
public: static ImageCodecInfo* GetImageEncoders() [];
[JScript]
public static function GetImageEncoders() : ImageCodecInfo[];

See Also

ImageCodecInfo Class | ImageCodecInfo Members | System.Drawing.Imaging Namespace


ImageCodecInfo.RemoveImageCodec

[To be supplied.]

[Visual Basic]
Public Shared Sub RemoveImageCodec( _
   ByVal imagecs As ImageCodecInfo _
)
[C#]
public static void RemoveImageCodec(
   ImageCodecInfo imagecs
);
[C++]
public: static void RemoveImageCodec(
   ImageCodecInfo* imagecs
);
[JScript]
public static function RemoveImageCodec(
   imagecs : ImageCodecInfo
);

Parameters

imagecs
[To be supplied.]

See Also

ImageCodecInfo Class | ImageCodecInfo Members | System.Drawing.Imaging Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ImageCodecInfo Fields

The fields of the ImageCodecInfo class are listed below. For a complete list of ImageCodecInfo class members, see the ImageCodecInfo Members topic.

Public:

Clsid | [To be supplied.]
CodecName | [To be supplied.]
DllName | [To be supplied.]
FilenameExtension | [To be supplied.]
Flags | [To be supplied.]
FormatDescription | [To be supplied.]
FormatID | [To be supplied.]
MimeType | [To be supplied.]
SignatureMasks | [To be supplied.]
SignaturePatterns | [To be supplied.]
Version | [To be supplied.]

See Also

ImageCodecInfo Class | System.Drawing.Imaging Namespace


ImageCodecInfo.Clsid

[To be supplied.]

[Visual Basic]
Public Clsid As Guid
[C#]
public Guid Clsid;
[C++]
public: Guid Clsid;
[JScript]
public var Clsid : Guid;

See Also

ImageCodecInfo Class | ImageCodecInfo Members | System.Drawing.Imaging Namespace


ImageCodecInfo.CodecName

[To be supplied.]

[Visual Basic]
Public CodecName As String
[C#]
public string CodecName;
[C++]
public: String* CodecName;
[JScript]
public var CodecName : String;

See Also

ImageCodecInfo Class | ImageCodecInfo Members | System.Drawing.Imaging Namespace


ImageCodecInfo.DllName

[To be supplied.]

[Visual Basic]
Public DllName As String
[C#]
public string DllName;
[C++]
public: String* DllName;
[JScript]
public var DllName : String;

See Also

ImageCodecInfo Class | ImageCodecInfo Members | System.Drawing.Imaging Namespace


ImageCodecInfo.FilenameExtension

[To be supplied.]

[Visual Basic]
Public FilenameExtension As String
[C#]
public string FilenameExtension;
[C++]
public: String* FilenameExtension;
[JScript]
public var FilenameExtension : String;

See Also

ImageCodecInfo Class | ImageCodecInfo Members | System.Drawing.Imaging Namespace


ImageCodecInfo.Flags

[To be supplied.]

[Visual Basic]
Public Flags As ImageCodecFlags
[C#]
public ImageCodecFlags Flags;
[C++]
public: ImageCodecFlags Flags;
[JScript]
public var Flags : ImageCodecFlags;

See Also

ImageCodecInfo Class | ImageCodecInfo Members | System.Drawing.Imaging Namespace


ImageCodecInfo.FormatDescription

[To be supplied.]

[Visual Basic]
Public FormatDescription As String
[C#]
public string FormatDescription;
[C++]
public: String* FormatDescription;
[JScript]
public var FormatDescription : String;

See Also

ImageCodecInfo Class | ImageCodecInfo Members | System.Drawing.Imaging Namespace


ImageCodecInfo.FormatID

[To be supplied.]

[Visual Basic]
Public FormatID As Guid
[C#]
public Guid FormatID;
[C++]
public: Guid FormatID;
[JScript]
public var FormatID : Guid;

See Also

ImageCodecInfo Class | ImageCodecInfo Members | System.Drawing.Imaging Namespace


ImageCodecInfo.MimeType

[To be supplied.]

[Visual Basic]
Public MimeType As String
[C#]
public string MimeType;
[C++]
public: String* MimeType;
[JScript]
public var MimeType : String;

See Also

ImageCodecInfo Class | ImageCodecInfo Members | System.Drawing.Imaging Namespace


ImageCodecInfo.SignatureMasks

[To be supplied.]

[Visual Basic]
Public SignatureMasks()() As Byte
[C#]
public byte[][] SignatureMasks;
[C++]
public: unsigned char* SignatureMasks[];
[JScript]
public var SignatureMasks : Byte[][];

See Also

ImageCodecInfo Class | ImageCodecInfo Members | System.Drawing.Imaging Namespace


ImageCodecInfo.SignaturePatterns

[To be supplied.]

[Visual Basic]
Public SignaturePatterns()() As Byte
[C#]
public byte[][] SignaturePatterns;
[C++]
public: unsigned char* SignaturePatterns[];
[JScript]
public var SignaturePatterns : Byte[][];

See Also

ImageCodecInfo Class | ImageCodecInfo Members | System.Drawing.Imaging Namespace


ImageCodecInfo.Version

[To be supplied.]

[Visual Basic]
Public Version As Integer
[C#]
public int Version;
[C++]
public: int Version;
[JScript]
public var Version : int;

See Also

ImageCodecInfo Class | ImageCodecInfo Members | System.Drawing.Imaging Namespace


ImageFlags Enumeration

[To be supplied.]

[Visual Basic]
Public Enum ImageFlags
[C#]
public enum ImageFlags
[C++]
public enum ImageFlags

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Caching | [To be supplied.]
ColorSpaceCMYK | [To be supplied.]
ColorSpaceGRAY | [To be supplied.]
ColorSpaceRGB | [To be supplied.]
ColorSpaceYCBCR | [To be supplied.]
ColorSpaceYCCK | [To be supplied.]
HasAlpha | [To be supplied.]
HasRealDPI | [To be supplied.]
HasRealPixelSize | [To be supplied.]
HasTranslucent | [To be supplied.]
None | [To be supplied.]
PartiallyScalable | [To be supplied.]
ReadOnly | [To be supplied.]
Scalable | [To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

System.Drawing.Imaging Namespace


ImageFormat Class

[To be supplied.]

Object
ImageFormat

[Visual Basic]
NotInheritable Public Class ImageFormat
[C#]
public sealed class ImageFormat
[C++]
public __gc __sealed class ImageFormat
[JScript]
public class ImageFormat

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

ImageFormat Members | System.Drawing.Imaging Namespace


ImageFormat Members

Public:

Constructor

ImageFormat Constructor [To be supplied.]

Properties

GUID [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

BMP | [To be supplied.]
EMF | [To be supplied.]
GIF | [To be supplied.]
Icon | [To be supplied.]
JPEG | [To be supplied.]
PNG | [To be supplied.]
TIFF | [To be supplied.]
WMF | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ImageFormat Class | System.Drawing.Imaging Namespace


ImageFormat Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal guid As Guid _
)
[C#]
public ImageFormat(
   Guid guid
);
[C++]
public: ImageFormat(
   Guid guid
);
[JScript]
public function ImageFormat(
   guid : Guid
);

Parameters

guid
[To be supplied.]

See Also

ImageFormat Class | ImageFormat Members | System.Drawing.Imaging Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ImageFormat Properties

The properties of the ImageFormat class are listed below. For a complete list of ImageFormat class members, see the ImageFormat Members topic.

Public:

GUID [To be supplied.]

See Also

ImageFormat Class | System.Drawing.Imaging Namespace


ImageFormat.GUID

[To be supplied.]

[Visual Basic]
Public ReadOnly Property GUID As Guid
[C#]
public Guid GUID {get;}
[C++]
public: __property Guid get_GUID();
[JScript]
public function get GUID() : Guid;

See Also

ImageFormat Class | ImageFormat Members | System.Drawing.Imaging Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ImageFormat Fields

The fields of the ImageFormat class are listed below. For a complete list of ImageFormat class members, see the ImageFormat Members topic.

Public:

BMP | [To be supplied.]
EMF | [To be supplied.]
GIF | [To be supplied.]
Icon | [To be supplied.]
JPEG | [To be supplied.]
PNG | [To be supplied.]
TIFF | [To be supplied.]
WMF | [To be supplied.]

See Also

ImageFormat Class | System.Drawing.Imaging Namespace


ImageFormat.BMP

[To be supplied.]

[Visual Basic]
Public Shared BMP As ImageFormat
[C#]
public static ImageFormat BMP;
[C++]
public: static ImageFormat* BMP;
[JScript]
public static var BMP : ImageFormat;

See Also

ImageFormat Class | ImageFormat Members | System.Drawing.Imaging Namespace


ImageFormat.EMF

[To be supplied.]

[Visual Basic]
Public Shared EMF As ImageFormat
[C#]
public static ImageFormat EMF;
[C++]
public: static ImageFormat* EMF;
[JScript]
public static var EMF : ImageFormat;

See Also

ImageFormat Class | ImageFormat Members | System.Drawing.Imaging Namespace


ImageFormat.GIF

[To be supplied.]

[Visual Basic]
Public Shared GIF As ImageFormat
[C#]
public static ImageFormat GIF;
[C++]
public: static ImageFormat* GIF;
[JScript]
public static var GIF : ImageFormat;

See Also

ImageFormat Class | ImageFormat Members | System.Drawing.Imaging Namespace


ImageFormat.Icon

[To be supplied.]

[Visual Basic]
Public Shared Icon As ImageFormat
[C#]
public static ImageFormat Icon;
[C++]
public: static ImageFormat* Icon;
[JScript]
public static var Icon : ImageFormat;

See Also

ImageFormat Class | ImageFormat Members | System.Drawing.Imaging Namespace


ImageFormat.JPEG

[To be supplied.]

[Visual Basic]
Public Shared JPEG As ImageFormat
[C#]
public static ImageFormat JPEG;
[C++]
public: static ImageFormat* JPEG;
[JScript]
public static var JPEG : ImageFormat;

See Also

ImageFormat Class | ImageFormat Members | System.Drawing.Imaging Namespace


ImageFormat.PNG

[To be supplied.]

[Visual Basic]
Public Shared PNG As ImageFormat
[C#]
public static ImageFormat PNG;
[C++]
public: static ImageFormat* PNG;
[JScript]
public static var PNG : ImageFormat;

See Also

ImageFormat Class | ImageFormat Members | System.Drawing.Imaging Namespace


ImageFormat.TIFF

[To be supplied.]

[Visual Basic]
Public Shared TIFF As ImageFormat
[C#]
public static ImageFormat TIFF;
[C++]
public: static ImageFormat* TIFF;
[JScript]
public static var TIFF : ImageFormat;

See Also

ImageFormat Class | ImageFormat Members | System.Drawing.Imaging Namespace


ImageFormat.WMF

[To be supplied.]

[Visual Basic]
Public Shared WMF As ImageFormat
[C#]
public static ImageFormat WMF;
[C++]
public: static ImageFormat* WMF;
[JScript]
public static var WMF : ImageFormat;

See Also

ImageFormat Class | ImageFormat Members | System.Drawing.Imaging Namespace


ImageLockMode Enumeration

[To be supplied.]

[Visual Basic]
Public Enum ImageLockMode
[C#]
public enum ImageLockMode
[C++]
public enum ImageLockMode

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
ReadOnly | [To be supplied.]
ReadWrite | [To be supplied.]
UserInputBuffer | [To be supplied.]
WriteOnly | [To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

System.Drawing.Imaging Namespace


Metafile Class

[To be supplied.]

Object
MarshalByRefObject
Image
Metafile

[Visual Basic]
NotInheritable Public Class Metafile
   Inherits Image
[C#]
public sealed class Metafile : Image
[C++]
public __gc __sealed class Metafile : public Image
[JScript]
public class Metafile extends Image

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

Metafile Members | System.Drawing.Imaging Namespace


Metafile Members

Public:

Constructor

Metafile Constructor Overloaded. [To be supplied.]

Properties

Flags (inherited from Image) | [To be supplied.]
FrameDimensionsList (inherited from Image) | [To be supplied.]
Height (inherited from Image) | [To be supplied.]
HorizontalResolution (inherited from Image) | [To be supplied.]
Palette (inherited from Image) | [To be supplied.]
PhysicalDimension (inherited from Image) | [To be supplied.]
PixelFormat (inherited from Image) | [To be supplied.]
PropertyIdList (inherited from Image) | [To be supplied.]
PropertyItems (inherited from Image) | [To be supplied.]
RawFormat (inherited from Image) | [To be supplied.]
Size (inherited from Image) | [To be supplied.]
VerticalResolution (inherited from Image) | [To be supplied.]
Width (inherited from Image) | [To be supplied.]

Methods

Clone (inherited from Image) | [To be supplied.]
Dispose (inherited from Image) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBounds (inherited from Image) | [To be supplied.]
GetEncoderParameterList (inherited from Image) | [To be supplied.]
GetFrameCount (inherited from Image) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHENHMETAFILE | [To be supplied.]
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetMetafileHeader | Overloaded. [To be supplied.]
GetObjectData (inherited from Image) | ISerializable private implementation
GetPropertyItem (inherited from Image) | [To be supplied.]
GetThumbnailImage (inherited from Image) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
PlayRecord | [To be supplied.]
RemovePropertyItem (inherited from Image) | [To be supplied.]
Save (inherited from Image) | Overloaded. [To be supplied.]
SaveAdd (inherited from Image) | Overloaded. [To be supplied.]
SelectActiveFrame (inherited from Image) | [To be supplied.]
SetPropertyItem (inherited from Image) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Image) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Metafile Class | System.Drawing.Imaging Namespace


Metafile Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer, APMFileHeader)
[C#] public Metafile(int, APMFileHeader);
[C++] public: Metafile(int, APMFileHeader);
[JScript] public function Metafile(int, APMFileHeader);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer, APMFileHeader, Boolean)
[C#] public Metafile(int, APMFileHeader, bool);
[C++] public: Metafile(int, APMFileHeader, bool);
[JScript] public function Metafile(int, APMFileHeader, Boolean);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer, Boolean)
[C#] public Metafile(int, bool);
[C++] public: Metafile(int, bool);
[JScript] public function Metafile(int, Boolean);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public Metafile(String);
[C++] public: Metafile(String*);
[JScript] public function Metafile(String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Stream)
[C#] public Metafile(Stream);
[C++] public: Metafile(Stream*);
[JScript] public function Metafile(Stream);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer, EmfType)
[C#] public Metafile(int, EmfType);
[C++] public: Metafile(int, EmfType);
[JScript] public function Metafile(int, EmfType);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer, EmfType, String)
[C#] public Metafile(int, EmfType, String);
[C++] public: Metafile(int, EmfType, String);
[JScript] public function Metafile(int, EmfType, String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer, RectangleF)
[C#] public Metafile(int, RectangleF);
[C++] public: Metafile(int, RectangleF);
[JScript] public function Metafile(int, RectangleF);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer, RectangleF, MetafileFrameUnit)
[C#] public Metafile(int, RectangleF, MetafileFrameUnit);
[C++] public: Metafile(int, RectangleF, MetafileFrameUnit);
[JScript] public function Metafile(int, RectangleF, MetafileFrameUnit);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer, RectangleF, MetafileFrameUnit, EmfType)
[C#] public Metafile(int, RectangleF, MetafileFrameUnit, EmfType);
[C++] public: Metafile(int, RectangleF, MetafileFrameUnit, EmfType);
[JScript] public function Metafile(int, RectangleF, MetafileFrameUnit, EmfType);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer, RectangleF, MetafileFrameUnit, EmfType, String)
[C#] public Metafile(int, RectangleF, MetafileFrameUnit, EmfType, String);
[C++] public: Metafile(int, RectangleF, MetafileFrameUnit, EmfType, String);
[JScript] public function Metafile(int, RectangleF, MetafileFrameUnit, EmfType, String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer, Rectangle)
[C#] public Metafile(int, Rectangle);
[C++] public: Metafile(int, Rectangle);
[JScript] public function Metafile(int, Rectangle);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer, Rectangle, MetafileFrameUnit)
[C#] public Metafile(int, Rectangle, MetafileFrameUnit);
[C++] public: Metafile(int, Rectangle, MetafileFrameUnit);
[JScript] public function Metafile(int, Rectangle, MetafileFrameUnit);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer, Rectangle, MetafileFrameUnit, EmfType)
[C#] public Metafile(int, Rectangle, MetafileFrameUnit, EmfType);
[C++] public: Metafile(int, Rectangle, MetafileFrameUnit, EmfType);
[JScript] public function Metafile(int, Rectangle, MetafileFrameUnit, EmfType);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer, Rectangle, MetafileFrameUnit, EmfType, String)
[C#] public Metafile(int, Rectangle, MetafileFrameUnit, EmfType, String);
[C++] public: Metafile(int, Rectangle, MetafileFrameUnit, EmfType, String);
[JScript] public function Metafile(int, Rectangle, MetafileFrameUnit, EmfType, String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Integer)
[C#] public Metafile(String, int);
[C++] public: Metafile(String*, int);
[JScript] public function Metafile(String, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Integer, EmfType)
[C#] public Metafile(String, int, EmfType);
[C++] public: Metafile(String*, int, EmfType);
[JScript] public function Metafile(String, int, EmfType);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Integer, EmfType, String)
[C#] public Metafile(String, int, EmfType, String);
[C++] public: Metafile(String*, int, EmfType, String*);
[JScript] public function Metafile(String, int, EmfType, String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Integer, RectangleF)
[C#] public Metafile(String, int, RectangleF);
[C++] public: Metafile(String*, int, RectangleF);
[JScript] public function Metafile(String, int, RectangleF);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Integer, RectangleF, MetafileFrameUnit)
[C#] public Metafile(String, int, RectangleF, MetafileFrameUnit);
[C++] public: Metafile(String*, int, RectangleF, MetafileFrameUnit);
[JScript] public function Metafile(String, int, RectangleF, MetafileFrameUnit);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Integer, RectangleF, MetafileFrameUnit, EmfType)
[C#] public Metafile(String, int, RectangleF, MetafileFrameUnit, EmfType);
[C++] public: Metafile(String*, int, RectangleF, MetafileFrameUnit, EmfType);
[JScript] public function Metafile(String, int, RectangleF, MetafileFrameUnit, EmfType);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Integer, RectangleF, MetafileFrameUnit, String)
[C#] public Metafile(String, int, RectangleF, MetafileFrameUnit, String);
[C++] public: Metafile(String*, int, RectangleF, MetafileFrameUnit, String*);
[JScript] public function Metafile(String, int, RectangleF, MetafileFrameUnit, String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Integer, RectangleF, MetafileFrameUnit, EmfType, String)
[C#] public Metafile(String, int, RectangleF, MetafileFrameUnit, EmfType, String);
[C++] public: Metafile(String*, int, RectangleF, MetafileFrameUnit, EmfType, String*);
[JScript] public function Metafile(String, int, RectangleF, MetafileFrameUnit, EmfType, String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Integer, Rectangle)
[C#] public Metafile(String, int, Rectangle);
[C++] public: Metafile(String*, int, Rectangle);
[JScript] public function Metafile(String, int, Rectangle);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Integer, Rectangle, MetafileFrameUnit)
[C#] public Metafile(String, int, Rectangle, MetafileFrameUnit);
[C++] public: Metafile(String*, int, Rectangle, MetafileFrameUnit);
[JScript] public function Metafile(String, int, Rectangle, MetafileFrameUnit);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Integer, Rectangle, MetafileFrameUnit, EmfType)
[C#] public Metafile(String, int, Rectangle, MetafileFrameUnit, EmfType);
[C++] public: Metafile(String*, int, Rectangle, MetafileFrameUnit, EmfType);
[JScript] public function Metafile(String, int, Rectangle, MetafileFrameUnit, EmfType);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Integer, Rectangle, MetafileFrameUnit, String)
[C#] public Metafile(String, int, Rectangle, MetafileFrameUnit, String);
[C++] public: Metafile(String*, int, Rectangle, MetafileFrameUnit, String*);
[JScript] public function Metafile(String, int, Rectangle, MetafileFrameUnit, String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Integer, Rectangle, MetafileFrameUnit, EmfType, String)
[C#] public Metafile(String, int, Rectangle, MetafileFrameUnit, EmfType, String);
[C++] public: Metafile(String*, int, Rectangle, MetafileFrameUnit, EmfType, String*);
[JScript] public function Metafile(String, int, Rectangle, MetafileFrameUnit, EmfType, String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Stream, Integer)
[C#] public Metafile(Stream, int);
[C++] public: Metafile(Stream*, int);
[JScript] public function Metafile(Stream, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Stream, Integer, EmfType)
[C#] public Metafile(Stream, int, EmfType);
[C++] public: Metafile(Stream*, int, EmfType);
[JScript] public function Metafile(Stream, int, EmfType);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Stream, Integer, EmfType, String)
[C#] public Metafile(Stream, int, EmfType, String);
[C++] public: Metafile(Stream*, int, EmfType, String);
[JScript] public function Metafile(Stream, int, EmfType, String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Stream, Integer, RectangleF)
[C#] public Metafile(Stream, int, RectangleF);
[C++] public: Metafile(Stream*, int, RectangleF);
[JScript] public function Metafile(Stream, int, RectangleF);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Stream, Integer, RectangleF, MetafileFrameUnit)
[C#] public Metafile(Stream, int, RectangleF, MetafileFrameUnit);
[C++] public: Metafile(Stream*, int, RectangleF, MetafileFrameUnit);
[JScript] public function Metafile(Stream, int, RectangleF, MetafileFrameUnit);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Stream, Integer, RectangleF, MetafileFrameUnit, EmfType)
[C#] public Metafile(Stream, int, RectangleF, MetafileFrameUnit, EmfType);
[C++] public: Metafile(Stream*, int, RectangleF, MetafileFrameUnit, EmfType);
[JScript] public function Metafile(Stream, int, RectangleF, MetafileFrameUnit, EmfType);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Stream, Integer, RectangleF, MetafileFrameUnit, EmfType, String)
[C#] public Metafile(Stream, int, RectangleF, MetafileFrameUnit, EmfType, String);
[C++] public: Metafile(Stream*, int, RectangleF, MetafileFrameUnit, EmfType, String);
[JScript] public function Metafile(Stream, int, RectangleF, MetafileFrameUnit, EmfType, String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Stream, Integer, Rectangle)
[C#] public Metafile(Stream, int, Rectangle);
[C++] public: Metafile(Stream*, int, Rectangle);
[JScript] public function Metafile(Stream, int, Rectangle);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Stream, Integer, Rectangle, MetafileFrameUnit)
[C#] public Metafile(Stream, int, Rectangle, MetafileFrameUnit);
[C++] public: Metafile(Stream*, int, Rectangle, MetafileFrameUnit);
[JScript] public function Metafile(Stream, int, Rectangle, MetafileFrameUnit);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Stream, Integer, Rectangle, MetafileFrameUnit, EmfType)
[C#] public Metafile(Stream, int, Rectangle, MetafileFrameUnit, EmfType);
[C++] public: Metafile(Stream*, int, Rectangle, MetafileFrameUnit, EmfType);
[JScript] public function Metafile(Stream, int, Rectangle, MetafileFrameUnit, EmfType);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Stream, Integer, Rectangle, MetafileFrameUnit, EmfType, String)
[C#] public Metafile(Stream, int, Rectangle, MetafileFrameUnit, EmfType, String);
[C++] public: Metafile(Stream*, int, Rectangle, MetafileFrameUnit, EmfType, String);
[JScript] public function Metafile(Stream, int, Rectangle, MetafileFrameUnit, EmfType, String);

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace


Metafile Constructor (Int32, APMFileHeader)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal hMetafile As Integer, _
   ByVal apmHeader As APMFileHeader _
)
[C#]
public Metafile(
   int hMetafile,
   APMFileHeader apmHeader
);
[C++]
public: Metafile(
   int hMetafile,
   APMFileHeader* apmHeader
);
[JScript]
public function Metafile(
   hMetafile : int,
   apmHeader : APMFileHeader
);

Parameters

hMetafile
[To be supplied.]
apmHeader
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (Int32, APMFileHeader, Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal hMetafile As Integer, _
   ByVal apmHeader As APMFileHeader, _
   ByVal deleteWmf As Boolean _
)
[C#]
public Metafile(
   int hMetafile,
   APMFileHeader apmHeader,
   bool deleteWmf
);
[C++]
public: Metafile(
   int hMetafile,
   APMFileHeader* apmHeader,
   bool deleteWmf
);
[JScript]
public function Metafile(
   hMetafile : int,
   apmHeader : APMFileHeader,
   deleteWmf : Boolean
);

Parameters

hMetafile
[To be supplied.]
apmHeader
[To be supplied.]
deleteWmf
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (Int32, Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal hEnhMetafile As Integer, _
   ByVal deleteEmf As Boolean _
)
[C#]
public Metafile(
   int hEnhMetafile,
   bool deleteEmf
);
[C++]
public: Metafile(
   int hEnhMetafile,
   bool deleteEmf
);
[JScript]
public function Metafile(
   hEnhMetafile : int,
   deleteEmf : Boolean
);

Parameters

hEnhMetafile
[To be supplied.]
deleteEmf
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal filename As String _
)
[C#]
public Metafile(
   string filename
);
[C++]
public: Metafile(
   String* filename
);
[JScript]
public function Metafile(
   filename : String
);

Parameters

filename
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (Stream)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream _
)
[C#]
public Metafile(
   Stream stream
);
[C++]
public: Metafile(
   Stream* stream
);
[JScript]
public function Metafile(
   stream : Stream
);

Parameters

stream
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (Int32, EmfType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal referenceHdc As Integer, _
   ByVal emfType As EmfType _
)
[C#]
public Metafile(
   int referenceHdc,
   EmfType emfType
);
[C++]
public: Metafile(
   int referenceHdc,
   EmfType emfType
);
[JScript]
public function Metafile(
   referenceHdc : int,
   emfType : EmfType
);

Parameters

referenceHdc
[To be supplied.]
emfType
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (Int32, EmfType, String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal referenceHdc As Integer, _
   ByVal emfType As EmfType, _
   ByVal description As String _
)
[C#]
public Metafile(
   int referenceHdc,
   EmfType emfType,
   string description
);
[C++]
public: Metafile(
   int referenceHdc,
   EmfType emfType,
   String* description
);
[JScript]
public function Metafile(
   referenceHdc : int,
   emfType : EmfType,
   description : String
);

Parameters

referenceHdc
[To be supplied.]
emfType
[To be supplied.]
description
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (Int32, RectangleF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal referenceHdc As Integer, _
   ByVal frameRect As RectangleF _
)
[C#]
public Metafile(
   int referenceHdc,
   RectangleF frameRect
);
[C++]
public: Metafile(
   int referenceHdc,
   RectangleF frameRect
);
[JScript]
public function Metafile(
   referenceHdc : int,
   frameRect : RectangleF
);

Parameters

referenceHdc
[To be supplied.]
frameRect
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (Int32, RectangleF, MetafileFrameUnit)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal referenceHdc As Integer, _
   ByVal frameRect As RectangleF, _
   ByVal frameUnit As MetafileFrameUnit _
)
[C#]
public Metafile(
   int referenceHdc,
   RectangleF frameRect,
   MetafileFrameUnit frameUnit
);
[C++]
public: Metafile(
   int referenceHdc,
   RectangleF frameRect,
   MetafileFrameUnit frameUnit
);
[JScript]
public function Metafile(
   referenceHdc : int,
   frameRect : RectangleF,
   frameUnit : MetafileFrameUnit
);

Parameters

referenceHdc
[To be supplied.]
frameRect
[To be supplied.]
frameUnit
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (Int32, RectangleF, MetafileFrameUnit, EmfType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal referenceHdc As Integer, _
   ByVal frameRect As RectangleF, _
   ByVal frameUnit As MetafileFrameUnit, _
   ByVal type As EmfType _
)
[C#]
public Metafile(
   int referenceHdc,
   RectangleF frameRect,
   MetafileFrameUnit frameUnit,
   EmfType type
);
[C++]
public: Metafile(
   int referenceHdc,
   RectangleF frameRect,
   MetafileFrameUnit frameUnit,
   EmfType type
);
[JScript]
public function Metafile(
   referenceHdc : int,
   frameRect : RectangleF,
   frameUnit : MetafileFrameUnit,
   type : EmfType
);

Parameters

referenceHdc
[To be supplied.]
frameRect
[To be supplied.]
frameUnit
[To be supplied.]
type
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (Int32, RectangleF, MetafileFrameUnit, EmfType, String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal referenceHdc As Integer, _
   ByVal frameRect As RectangleF, _
   ByVal frameUnit As MetafileFrameUnit, _
   ByVal type As EmfType, _
   ByVal description As String _
)
[C#]
public Metafile(
   int referenceHdc,
   RectangleF frameRect,
   MetafileFrameUnit frameUnit,
   EmfType type,
   string description
);
[C++]
public: Metafile(
   int referenceHdc,
   RectangleF frameRect,
   MetafileFrameUnit frameUnit,
   EmfType type,
   String* description
);
[JScript]
public function Metafile(
   referenceHdc : int,
   frameRect : RectangleF,
   frameUnit : MetafileFrameUnit,
   type : EmfType,
   description : String
);

Parameters

referenceHdc
[To be supplied.]
frameRect
[To be supplied.]
frameUnit
[To be supplied.]
type
[To be supplied.]
description
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (Int32, Rectangle)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal referenceHdc As Integer, _
   ByVal frameRect As Rectangle _
)
[C#]
public Metafile(
   int referenceHdc,
   Rectangle frameRect
);
[C++]
public: Metafile(
   int referenceHdc,
   Rectangle frameRect
);
[JScript]
public function Metafile(
   referenceHdc : int,
   frameRect : Rectangle
);

Parameters

referenceHdc
[To be supplied.]
frameRect
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (Int32, Rectangle, MetafileFrameUnit)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal referenceHdc As Integer, _
   ByVal frameRect As Rectangle, _
   ByVal frameUnit As MetafileFrameUnit _
)
[C#]
public Metafile(
   int referenceHdc,
   Rectangle frameRect,
   MetafileFrameUnit frameUnit
);
[C++]
public: Metafile(
   int referenceHdc,
   Rectangle frameRect,
   MetafileFrameUnit frameUnit
);
[JScript]
public function Metafile(
   referenceHdc : int,
   frameRect : Rectangle,
   frameUnit : MetafileFrameUnit
);

Parameters

referenceHdc
[To be supplied.]
frameRect
[To be supplied.]
frameUnit
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (Int32, Rectangle, MetafileFrameUnit, EmfType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal referenceHdc As Integer, _
   ByVal frameRect As Rectangle, _
   ByVal frameUnit As MetafileFrameUnit, _
   ByVal type As EmfType _
)
[C#]
public Metafile(
   int referenceHdc,
   Rectangle frameRect,
   MetafileFrameUnit frameUnit,
   EmfType type
);
[C++]
public: Metafile(
   int referenceHdc,
   Rectangle frameRect,
   MetafileFrameUnit frameUnit,
   EmfType type
);
[JScript]
public function Metafile(
   referenceHdc : int,
   frameRect : Rectangle,
   frameUnit : MetafileFrameUnit,
   type : EmfType
);

Parameters

referenceHdc
[To be supplied.]
frameRect
[To be supplied.]
frameUnit
[To be supplied.]
type
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (Int32, Rectangle, MetafileFrameUnit, EmfType, String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal referenceHdc As Integer, _
   ByVal frameRect As Rectangle, _
   ByVal frameUnit As MetafileFrameUnit, _
   ByVal type As EmfType, _
   ByVal desc As String _
)
[C#]
public Metafile(
   int referenceHdc,
   Rectangle frameRect,
   MetafileFrameUnit frameUnit,
   EmfType type,
   string desc
);
[C++]
public: Metafile(
   int referenceHdc,
   Rectangle frameRect,
   MetafileFrameUnit frameUnit,
   EmfType type,
   String* desc
);
[JScript]
public function Metafile(
   referenceHdc : int,
   frameRect : Rectangle,
   frameUnit : MetafileFrameUnit,
   type : EmfType,
   desc : String
);

Parameters

referenceHdc
[To be supplied.]
frameRect
[To be supplied.]
frameUnit
[To be supplied.]
type
[To be supplied.]
desc
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (String, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal fileName As String, _
   ByVal referenceHdc As Integer _
)
[C#]
public Metafile(
   string fileName,
   int referenceHdc
);
[C++]
public: Metafile(
   String* fileName,
   int referenceHdc
);
[JScript]
public function Metafile(
   fileName : String,
   referenceHdc : int
);

Parameters

fileName
[To be supplied.]
referenceHdc
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (String, Int32, EmfType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal fileName As String, _
   ByVal referenceHdc As Integer, _
   ByVal type As EmfType _
)
[C#]
public Metafile(
   string fileName,
   int referenceHdc,
   EmfType type
);
[C++]
public: Metafile(
   String* fileName,
   int referenceHdc,
   EmfType type
);
[JScript]
public function Metafile(
   fileName : String,
   referenceHdc : int,
   type : EmfType
);

Parameters

fileName
[To be supplied.]
referenceHdc
[To be supplied.]
type
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (String, Int32, EmfType, String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal fileName As String, _
   ByVal referenceHdc As Integer, _
   ByVal type As EmfType, _
   ByVal description As String _
)
[C#]
public Metafile(
   string fileName,
   int referenceHdc,
   EmfType type,
   string description
);
[C++]
public: Metafile(
   String* fileName,
   int referenceHdc,
   EmfType type,
   String* description
);
[JScript]
public function Metafile(
   fileName : String,
   referenceHdc : int,
   type : EmfType,
   description : String
);

Parameters

fileName
[To be supplied.]
referenceHdc
[To be supplied.]
type
[To be supplied.]
description
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (String, Int32, RectangleF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal fileName As String, _
   ByVal referenceHdc As Integer, _
   ByVal frameRect As RectangleF _
)
[C#]
public Metafile(
   string fileName,
   int referenceHdc,
   RectangleF frameRect
);
[C++]
public: Metafile(
   String* fileName,
   int referenceHdc,
   RectangleF frameRect
);
[JScript]
public function Metafile(
   fileName : String,
   referenceHdc : int,
   frameRect : RectangleF
);

Parameters

fileName
[To be supplied.]
referenceHdc
[To be supplied.]
frameRect
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (String, Int32, RectangleF, MetafileFrameUnit)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal fileName As String, _
   ByVal referenceHdc As Integer, _
   ByVal frameRect As RectangleF, _
   ByVal frameUnit As MetafileFrameUnit _
)
[C#]
public Metafile(
   string fileName,
   int referenceHdc,
   RectangleF frameRect,
   MetafileFrameUnit frameUnit
);
[C++]
public: Metafile(
   String* fileName,
   int referenceHdc,
   RectangleF frameRect,
   MetafileFrameUnit frameUnit
);
[JScript]
public function Metafile(
   fileName : String,
   referenceHdc : int,
   frameRect : RectangleF,
   frameUnit : MetafileFrameUnit
);

Parameters

fileName
[To be supplied.]
referenceHdc
[To be supplied.]
frameRect
[To be supplied.]
frameUnit
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (String, Int32, RectangleF, MetafileFrameUnit, EmfType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal fileName As String, _
   ByVal referenceHdc As Integer, _
   ByVal frameRect As RectangleF, _
   ByVal frameUnit As MetafileFrameUnit, _
   ByVal type As EmfType _
)
[C#]
public Metafile(
   string fileName,
   int referenceHdc,
   RectangleF frameRect,
   MetafileFrameUnit frameUnit,
   EmfType type
);
[C++]
public: Metafile(
   String* fileName,
   int referenceHdc,
   RectangleF frameRect,
   MetafileFrameUnit frameUnit,
   EmfType type
);
[JScript]
public function Metafile(
   fileName : String,
   referenceHdc : int,
   frameRect : RectangleF,
   frameUnit : MetafileFrameUnit,
   type : EmfType
);

Parameters

fileName
[To be supplied.]
referenceHdc
[To be supplied.]
frameRect
[To be supplied.]
frameUnit
[To be supplied.]
type
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (String, Int32, RectangleF, MetafileFrameUnit, String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal fileName As String, _
   ByVal referenceHdc As Integer, _
   ByVal frameRect As RectangleF, _
   ByVal frameUnit As MetafileFrameUnit, _
   ByVal desc As String _
)
[C#]
public Metafile(
   string fileName,
   int referenceHdc,
   RectangleF frameRect,
   MetafileFrameUnit frameUnit,
   string desc
);
[C++]
public: Metafile(
   String* fileName,
   int referenceHdc,
   RectangleF frameRect,
   MetafileFrameUnit frameUnit,
   String* desc
);
[JScript]
public function Metafile(
   fileName : String,
   referenceHdc : int,
   frameRect : RectangleF,
   frameUnit : MetafileFrameUnit,
   desc : String
);

Parameters

fileName
[To be supplied.]
referenceHdc
[To be supplied.]
frameRect
[To be supplied.]
frameUnit
[To be supplied.]
desc
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (String, Int32, RectangleF, MetafileFrameUnit, EmfType, String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal fileName As String, _
   ByVal referenceHdc As Integer, _
   ByVal frameRect As RectangleF, _
   ByVal frameUnit As MetafileFrameUnit, _
   ByVal type As EmfType, _
   ByVal description As String _
)
[C#]
public Metafile(
   string fileName,
   int referenceHdc,
   RectangleF frameRect,
   MetafileFrameUnit frameUnit,
   EmfType type,
   string description
);
[C++]
public: Metafile(
   String* fileName,
   int referenceHdc,
   RectangleF frameRect,
   MetafileFrameUnit frameUnit,
   EmfType type,
   String* description
);
[JScript]
public function Metafile(
   fileName : String,
   referenceHdc : int,
   frameRect : RectangleF,
   frameUnit : MetafileFrameUnit,
   type : EmfType,
   description : String
);

Parameters

fileName
[To be supplied.]
referenceHdc
[To be supplied.]
frameRect
[To be supplied.]
frameUnit
[To be supplied.]
type
[To be supplied.]
description
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (String, Int32, Rectangle)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal fileName As String, _
   ByVal referenceHdc As Integer, _
   ByVal frameRect As Rectangle _
)
[C#]
public Metafile(
   string fileName,
   int referenceHdc,
   Rectangle frameRect
);
[C++]
public: Metafile(
   String* fileName,
   int referenceHdc,
   Rectangle frameRect
);
[JScript]
public function Metafile(
   fileName : String,
   referenceHdc : int,
   frameRect : Rectangle
);

Parameters

fileName
[To be supplied.]
referenceHdc
[To be supplied.]
frameRect
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (String, Int32, Rectangle, MetafileFrameUnit)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal fileName As String, _
   ByVal referenceHdc As Integer, _
   ByVal frameRect As Rectangle, _
   ByVal frameUnit As MetafileFrameUnit _
)
[C#]
public Metafile(
   string fileName,
   int referenceHdc,
   Rectangle frameRect,
   MetafileFrameUnit frameUnit
);
[C++]
public: Metafile(
   String* fileName,
   int referenceHdc,
   Rectangle frameRect,
   MetafileFrameUnit frameUnit
);
[JScript]
public function Metafile(
   fileName : String,
   referenceHdc : int,
   frameRect : Rectangle,
   frameUnit : MetafileFrameUnit
);

Parameters

fileName
[To be supplied.]
referenceHdc
[To be supplied.]
frameRect
[To be supplied.]
frameUnit
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (String, Int32, Rectangle, MetafileFrameUnit, EmfType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal fileName As String, _
   ByVal referenceHdc As Integer, _
   ByVal frameRect As Rectangle, _
   ByVal frameUnit As MetafileFrameUnit, _
   ByVal type As EmfType _
)
[C#]
public Metafile(
   string fileName,
   int referenceHdc,
   Rectangle frameRect,
   MetafileFrameUnit frameUnit,
   EmfType type
);
[C++]
public: Metafile(
   String* fileName,
   int referenceHdc,
   Rectangle frameRect,
   MetafileFrameUnit frameUnit,
   EmfType type
);
[JScript]
public function Metafile(
   fileName : String,
   referenceHdc : int,
   frameRect : Rectangle,
   frameUnit : MetafileFrameUnit,
   type : EmfType
);

Parameters

fileName
[To be supplied.]
referenceHdc
[To be supplied.]
frameRect
[To be supplied.]
frameUnit
[To be supplied.]
type
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (String, Int32, Rectangle, MetafileFrameUnit, String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal fileName As String, _
   ByVal referenceHdc As Integer, _
   ByVal frameRect As Rectangle, _
   ByVal frameUnit As MetafileFrameUnit, _
   ByVal description As String _
)
[C#]
public Metafile(
   string fileName,
   int referenceHdc,
   Rectangle frameRect,
   MetafileFrameUnit frameUnit,
   string description
);
[C++]
public: Metafile(
   String* fileName,
   int referenceHdc,
   Rectangle frameRect,
   MetafileFrameUnit frameUnit,
   String* description
);
[JScript]
public function Metafile(
   fileName : String,
   referenceHdc : int,
   frameRect : Rectangle,
   frameUnit : MetafileFrameUnit,
   description : String
);

Parameters

fileName
[To be supplied.]
referenceHdc
[To be supplied.]
frameRect
[To be supplied.]
frameUnit
[To be supplied.]
description
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (String, Int32, Rectangle, MetafileFrameUnit, EmfType, String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal fileName As String, _
   ByVal referenceHdc As Integer, _
   ByVal frameRect As Rectangle, _
   ByVal frameUnit As MetafileFrameUnit, _
   ByVal type As EmfType, _
   ByVal description As String _
)
[C#]
public Metafile(
   string fileName,
   int referenceHdc,
   Rectangle frameRect,
   MetafileFrameUnit frameUnit,
   EmfType type,
   string description
);
[C++]
public: Metafile(
   String* fileName,
   int referenceHdc,
   Rectangle frameRect,
   MetafileFrameUnit frameUnit,
   EmfType type,
   String* description
);
[JScript]
public function Metafile(
   fileName : String,
   referenceHdc : int,
   frameRect : Rectangle,
   frameUnit : MetafileFrameUnit,
   type : EmfType,
   description : String
);

Parameters

fileName
[To be supplied.]
referenceHdc
[To be supplied.]
frameRect
[To be supplied.]
frameUnit
[To be supplied.]
type
[To be supplied.]
description
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (Stream, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream, _
   ByVal referenceHdc As Integer _
)
[C#]
public Metafile(
   Stream stream,
   int referenceHdc
);
[C++]
public: Metafile(
   Stream* stream,
   int referenceHdc
);
[JScript]
public function Metafile(
   stream : Stream,
   referenceHdc : int
);

Parameters

stream
[To be supplied.]
referenceHdc
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (Stream, Int32, EmfType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream, _
   ByVal referenceHdc As Integer, _
   ByVal type As EmfType _
)
[C#]
public Metafile(
   Stream stream,
   int referenceHdc,
   EmfType type
);
[C++]
public: Metafile(
   Stream* stream,
   int referenceHdc,
   EmfType type
);
[JScript]
public function Metafile(
   stream : Stream,
   referenceHdc : int,
   type : EmfType
);

Parameters

stream
[To be supplied.]
referenceHdc
[To be supplied.]
type
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (Stream, Int32, EmfType, String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream, _
   ByVal referenceHdc As Integer, _
   ByVal type As EmfType, _
   ByVal description As String _
)
[C#]
public Metafile(
   Stream stream,
   int referenceHdc,
   EmfType type,
   string description
);
[C++]
public: Metafile(
   Stream* stream,
   int referenceHdc,
   EmfType type,
   String* description
);
[JScript]
public function Metafile(
   stream : Stream,
   referenceHdc : int,
   type : EmfType,
   description : String
);

Parameters

stream
[To be supplied.]
referenceHdc
[To be supplied.]
type
[To be supplied.]
description
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (Stream, Int32, RectangleF)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream, _
   ByVal referenceHdc As Integer, _
   ByVal frameRect As RectangleF _
)
[C#]
public Metafile(
   Stream stream,
   int referenceHdc,
   RectangleF frameRect
);
[C++]
public: Metafile(
   Stream* stream,
   int referenceHdc,
   RectangleF frameRect
);
[JScript]
public function Metafile(
   stream : Stream,
   referenceHdc : int,
   frameRect : RectangleF
);

Parameters

stream
[To be supplied.]
referenceHdc
[To be supplied.]
frameRect
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (Stream, Int32, RectangleF, MetafileFrameUnit)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream, _
   ByVal referenceHdc As Integer, _
   ByVal frameRect As RectangleF, _
   ByVal frameUnit As MetafileFrameUnit _
)
[C#]
public Metafile(
   Stream stream,
   int referenceHdc,
   RectangleF frameRect,
   MetafileFrameUnit frameUnit
);
[C++]
public: Metafile(
   Stream* stream,
   int referenceHdc,
   RectangleF frameRect,
   MetafileFrameUnit frameUnit
);
[JScript]
public function Metafile(
   stream : Stream,
   referenceHdc : int,
   frameRect : RectangleF,
   frameUnit : MetafileFrameUnit
);

Parameters

stream
[To be supplied.]
referenceHdc
[To be supplied.]
frameRect
[To be supplied.]
frameUnit
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (Stream, Int32, RectangleF, MetafileFrameUnit, EmfType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream, _
   ByVal referenceHdc As Integer, _
   ByVal frameRect As RectangleF, _
   ByVal frameUnit As MetafileFrameUnit, _
   ByVal type As EmfType _
)
[C#]
public Metafile(
   Stream stream,
   int referenceHdc,
   RectangleF frameRect,
   MetafileFrameUnit frameUnit,
   EmfType type
);
[C++]
public: Metafile(
   Stream* stream,
   int referenceHdc,
   RectangleF frameRect,
   MetafileFrameUnit frameUnit,
   EmfType type
);
[JScript]
public function Metafile(
   stream : Stream,
   referenceHdc : int,
   frameRect : RectangleF,
   frameUnit : MetafileFrameUnit,
   type : EmfType
);

Parameters

stream
[To be supplied.]
referenceHdc
[To be supplied.]
frameRect
[To be supplied.]
frameUnit
[To be supplied.]
type
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (Stream, Int32, RectangleF, MetafileFrameUnit, EmfType, String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream, _
   ByVal referenceHdc As Integer, _
   ByVal frameRect As RectangleF, _
   ByVal frameUnit As MetafileFrameUnit, _
   ByVal type As EmfType, _
   ByVal description As String _
)
[C#]
public Metafile(
   Stream stream,
   int referenceHdc,
   RectangleF frameRect,
   MetafileFrameUnit frameUnit,
   EmfType type,
   string description
);
[C++]
public: Metafile(
   Stream* stream,
   int referenceHdc,
   RectangleF frameRect,
   MetafileFrameUnit frameUnit,
   EmfType type,
   String* description
);
[JScript]
public function Metafile(
   stream : Stream,
   referenceHdc : int,
   frameRect : RectangleF,
   frameUnit : MetafileFrameUnit,
   type : EmfType,
   description : String
);

Parameters

stream
[To be supplied.]
referenceHdc
[To be supplied.]
frameRect
[To be supplied.]
frameUnit
[To be supplied.]
type
[To be supplied.]
description
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (Stream, Int32, Rectangle)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream, _
   ByVal referenceHdc As Integer, _
   ByVal frameRect As Rectangle _
)
[C#]
public Metafile(
   Stream stream,
   int referenceHdc,
   Rectangle frameRect
);
[C++]
public: Metafile(
   Stream* stream,
   int referenceHdc,
   Rectangle frameRect
);
[JScript]
public function Metafile(
   stream : Stream,
   referenceHdc : int,
   frameRect : Rectangle
);

Parameters

stream
[To be supplied.]
referenceHdc
[To be supplied.]
frameRect
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (Stream, Int32, Rectangle, MetafileFrameUnit)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream, _
   ByVal referenceHdc As Integer, _
   ByVal frameRect As Rectangle, _
   ByVal frameUnit As MetafileFrameUnit _
)
[C#]
public Metafile(
   Stream stream,
   int referenceHdc,
   Rectangle frameRect,
   MetafileFrameUnit frameUnit
);
[C++]
public: Metafile(
   Stream* stream,
   int referenceHdc,
   Rectangle frameRect,
   MetafileFrameUnit frameUnit
);
[JScript]
public function Metafile(
   stream : Stream,
   referenceHdc : int,
   frameRect : Rectangle,
   frameUnit : MetafileFrameUnit
);

Parameters

stream
[To be supplied.]
referenceHdc
[To be supplied.]
frameRect
[To be supplied.]
frameUnit
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (Stream, Int32, Rectangle, MetafileFrameUnit, EmfType)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream, _
   ByVal referenceHdc As Integer, _
   ByVal frameRect As Rectangle, _
   ByVal frameUnit As MetafileFrameUnit, _
   ByVal type As EmfType _
)
[C#]
public Metafile(
   Stream stream,
   int referenceHdc,
   Rectangle frameRect,
   MetafileFrameUnit frameUnit,
   EmfType type
);
[C++]
public: Metafile(
   Stream* stream,
   int referenceHdc,
   Rectangle frameRect,
   MetafileFrameUnit frameUnit,
   EmfType type
);
[JScript]
public function Metafile(
   stream : Stream,
   referenceHdc : int,
   frameRect : Rectangle,
   frameUnit : MetafileFrameUnit,
   type : EmfType
);

Parameters

stream
[To be supplied.]
referenceHdc
[To be supplied.]
frameRect
[To be supplied.]
frameUnit
[To be supplied.]
type
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Metafile Constructor (Stream, Int32, Rectangle, MetafileFrameUnit, EmfType, String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream, _
   ByVal referenceHdc As Integer, _
   ByVal frameRect As Rectangle, _
   ByVal frameUnit As MetafileFrameUnit, _
   ByVal type As EmfType, _
   ByVal description As String _
)
[C#]
public Metafile(
   Stream stream,
   int referenceHdc,
   Rectangle frameRect,
   MetafileFrameUnit frameUnit,
   EmfType type,
   string description
);
[C++]
public: Metafile(
   Stream* stream,
   int referenceHdc,
   Rectangle frameRect,
   MetafileFrameUnit frameUnit,
   EmfType type,
   String* description
);
[JScript]
public function Metafile(
   stream : Stream,
   referenceHdc : int,
   frameRect : Rectangle,
   frameUnit : MetafileFrameUnit,
   type : EmfType,
   description : String
);

Parameters

stream
[To be supplied.]
referenceHdc
[To be supplied.]
frameRect
[To be supplied.]
frameUnit
[To be supplied.]
type
[To be supplied.]
description
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Metafile Methods

The methods of the Metafile class are listed below. For a complete list of Metafile class members, see the Metafile Members topic.

Public:

Clone (inherited from Image) | [To be supplied.]
Dispose (inherited from Image) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBounds (inherited from Image) | [To be supplied.]
GetEncoderParameterList (inherited from Image) | [To be supplied.]
GetFrameCount (inherited from Image) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHENHMETAFILE | [To be supplied.]
GetLifetimeService (inherited from MarshalByRefObject) | This method is used return a lifetime service object that is used to control the lifetime policy to the object. For the default Lifetime service this will be an object of type ILease.
GetMetafileHeader | Overloaded. [To be supplied.]
GetObjectData (inherited from Image) | ISerializable private implementation
GetPropertyItem (inherited from Image) | [To be supplied.]
GetThumbnailImage (inherited from Image) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
InitializeLifetimeService (inherited from MarshalByRefObject) |
PlayRecord | [To be supplied.]
RemovePropertyItem (inherited from Image) | [To be supplied.]
Save (inherited from Image) | Overloaded. [To be supplied.]
SaveAdd (inherited from Image) | Overloaded. [To be supplied.]
SelectActiveFrame (inherited from Image) | [To be supplied.]
SetPropertyItem (inherited from Image) | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Image) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Metafile Class | System.Drawing.Imaging Namespace


Metafile.GetHENHMETAFILE

[To be supplied.]

[Visual Basic]
Public Function GetHENHMETAFILE() As Integer
[C#]
public int GetHENHMETAFILE();
[C++]
public: int GetHENHMETAFILE();
[JScript]
public function GetHENHMETAFILE() : int;

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace


Metafile.GetMetafileHeader

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Shared Function GetMetafileHeader(String) As MetafileHeader
[C#] public static MetafileHeader GetMetafileHeader(String);
[C++] public: static MetafileHeader* GetMetafileHeader(String*);
[JScript] public static function GetMetafileHeader(String) : MetafileHeader;

[To be supplied.]

[Visual Basic] Overloads Public Shared Sub GetMetafileHeader(String, MetafileHeader)
[C#] public static void GetMetafileHeader(String, MetafileHeader);
[C++] public: static void GetMetafileHeader(String*, MetafileHeader);
[JScript] public static function GetMetafileHeader(String, MetafileHeader);

[To be supplied.]

[Visual Basic] Overloads Public Shared Function GetMetafileHeader(Integer) As MetafileHeader
[C#] public static MetafileHeader GetMetafileHeader(int);
[C++] public: static MetafileHeader* GetMetafileHeader(int);
[JScript] public static function GetMetafileHeader(int) : MetafileHeader;

[To be supplied.]

[Visual Basic] Overloads Public Shared Sub GetMetafileHeader(Integer, APMFileHeader, MetafileHeader)
[C#] public static void GetMetafileHeader(int, APMFileHeader, MetafileHeader);
[C++] public: static void GetMetafileHeader(int, APMFileHeader, MetafileHeader);
[JScript] public static function GetMetafileHeader(int, APMFileHeader, MetafileHeader);

[To be supplied.]

[Visual Basic] Overloads Public Shared Function GetMetafileHeader(Integer, APMFileHeader) As MetafileHeader
[C#] public static MetafileHeader GetMetafileHeader(int, APMFileHeader);
[C++] public: static MetafileHeader* GetMetafileHeader(int, APMFileHeader);
[JScript] public static function GetMetafileHeader(int, APMFileHeader) : MetafileHeader;

[To be supplied.]

[Visual Basic] Overloads Public Shared Sub GetMetafileHeader(Integer, MetafileHeader)
[C#] public static void GetMetafileHeader(int, MetafileHeader);
[C++] public: static void GetMetafileHeader(int, MetafileHeader);
[JScript] public static function GetMetafileHeader(int, MetafileHeader);

[To be supplied.]

[Visual Basic] Overloads Public Function GetMetafileHeader() As MetafileHeader
[C#] public MetafileHeader GetMetafileHeader();
[C++] public: MetafileHeader* GetMetafileHeader();
[JScript] public function GetMetafileHeader() : MetafileHeader;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function GetMetafileHeader(Stream) As MetafileHeader
[C#] public static MetafileHeader GetMetafileHeader(Stream);
[C++] public: static MetafileHeader* GetMetafileHeader(Stream*);
[JScript] public static function GetMetafileHeader(Stream) : MetafileHeader;

[To be supplied.]

[Visual Basic] Overloads Public Shared Sub GetMetafileHeader(Stream, MetafileHeader)
[C#] public static void GetMetafileHeader(Stream, MetafileHeader);
[C++] public: static void GetMetafileHeader(Stream*, MetafileHeader);
[JScript] public static function GetMetafileHeader(Stream, MetafileHeader);

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace


Metafile.GetMetafileHeader (String)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function GetMetafileHeader( _
   ByVal fileName As String _
) As MetafileHeader
[C#]
public static MetafileHeader GetMetafileHeader(
   string fileName
);
[C++]
public: static MetafileHeader* GetMetafileHeader(
   String* fileName
);
[JScript]
public static function GetMetafileHeader(
   fileName : String
) : MetafileHeader;

Parameters

fileName
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile.GetMetafileHeader Overload List


Metafile.GetMetafileHeader (String, MetafileHeader)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Sub GetMetafileHeader( _
   ByVal fileName As String, _
   ByVal header As MetafileHeader _
)
[C#]
public static void GetMetafileHeader(
   string fileName,
   MetafileHeader header
);
[C++]
public: static void GetMetafileHeader(
   String* fileName,
   MetafileHeader* header
);
[JScript]
public static function GetMetafileHeader(
   fileName : String,
   header : MetafileHeader
);

Parameters

fileName
[To be supplied.]
header
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile.GetMetafileHeader Overload List


Metafile.GetMetafileHeader (Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function GetMetafileHeader( _
   ByVal hEnhMetafile As Integer _
) As MetafileHeader
[C#]
public static MetafileHeader GetMetafileHeader(
   int hEnhMetafile
);
[C++]
public: static MetafileHeader* GetMetafileHeader(
   int hEnhMetafile
);
[JScript]
public static function GetMetafileHeader(
   hEnhMetafile : int
) : MetafileHeader;

Parameters

hEnhMetafile
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile.GetMetafileHeader Overload List


Metafile.GetMetafileHeader (Int32, APMFileHeader, MetafileHeader)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Sub GetMetafileHeader( _
   ByVal hMetafile As Integer, _
   ByVal apmHeader As APMFileHeader, _
   ByVal header As MetafileHeader _
)
[C#]
public static void GetMetafileHeader(
   int hMetafile,
   APMFileHeader apmHeader,
   MetafileHeader header
);
[C++]
public: static void GetMetafileHeader(
   int hMetafile,
   APMFileHeader* apmHeader,
   MetafileHeader* header
);
[JScript]
public static function GetMetafileHeader(
   hMetafile : int,
   apmHeader : APMFileHeader,
   header : MetafileHeader
);

Parameters

hMetafile
[To be supplied.]
apmHeader
[To be supplied.]
header
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile.GetMetafileHeader Overload List


Metafile.GetMetafileHeader (Int32, APMFileHeader)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function GetMetafileHeader( _
   ByVal hMetafile As Integer, _
   ByVal apmHeader As APMFileHeader _
) As MetafileHeader
[C#]
public static MetafileHeader GetMetafileHeader(
   int hMetafile,
   APMFileHeader apmHeader
);
[C++]
public: static MetafileHeader* GetMetafileHeader(
   int hMetafile,
   APMFileHeader* apmHeader
);
[JScript]
public static function GetMetafileHeader(
   hMetafile : int,
   apmHeader : APMFileHeader
) : MetafileHeader;

Parameters

hMetafile
[To be supplied.]
apmHeader
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile.GetMetafileHeader Overload List


Metafile.GetMetafileHeader (Int32, MetafileHeader)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Sub GetMetafileHeader( _
   ByVal hEnhMetafile As Integer, _
   ByVal header As MetafileHeader _
)
[C#]
public static void GetMetafileHeader(
   int hEnhMetafile,
   MetafileHeader header
);
[C++]
public: static void GetMetafileHeader(
   int hEnhMetafile,
   MetafileHeader* header
);
[JScript]
public static function GetMetafileHeader(
   hEnhMetafile : int,
   header : MetafileHeader
);

Parameters

hEnhMetafile
[To be supplied.]
header
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile.GetMetafileHeader Overload List


Metafile.GetMetafileHeader ()

[To be supplied.]

[Visual Basic]
Overloads Public Function GetMetafileHeader() As MetafileHeader
[C#]
public MetafileHeader GetMetafileHeader();
[C++]
public: MetafileHeader* GetMetafileHeader();
[JScript]
public function GetMetafileHeader() : MetafileHeader;

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile.GetMetafileHeader Overload List


Metafile.GetMetafileHeader (Stream)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function GetMetafileHeader( _
   ByVal stream As Stream _
) As MetafileHeader
[C#]
public static MetafileHeader GetMetafileHeader(
   Stream stream
);
[C++]
public: static MetafileHeader* GetMetafileHeader(
   Stream* stream
);
[JScript]
public static function GetMetafileHeader(
   stream : Stream
) : MetafileHeader;

Parameters

stream
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile.GetMetafileHeader Overload List


Metafile.GetMetafileHeader (Stream, MetafileHeader)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Sub GetMetafileHeader( _
   ByVal stream As Stream, _
   ByVal header As MetafileHeader _
)
[C#]
public static void GetMetafileHeader(
   Stream stream,
   MetafileHeader header
);
[C++]
public: static void GetMetafileHeader(
   Stream* stream,
   MetafileHeader* header
);
[JScript]
public static function GetMetafileHeader(
   stream : Stream,
   header : MetafileHeader
);

Parameters

stream
[To be supplied.]
header
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace | Metafile.GetMetafileHeader Overload List


Metafile.PlayRecord

[To be supplied.]

[Visual Basic]
Public Sub PlayRecord( _
   ByVal recordType As EmfPlusRecordType, _
   ByVal flags As Integer, _
   ByVal dataSize As Integer, _
   ByVal data() As Byte _
)
[C#]
public void PlayRecord(
   EmfPlusRecordType recordType,
   int flags,
   int dataSize,
   byte[] data
);
[C++]
public: void PlayRecord(
   EmfPlusRecordType recordType,
   int flags,
   int dataSize,
   unsigned char* data[]
);
[JScript]
public function PlayRecord(
   recordType : EmfPlusRecordType,
   flags : int,
   dataSize : int,
   data : Byte[]
);

Parameters

recordType
[To be supplied.]
flags
[To be supplied.]
dataSize
[To be supplied.]
data
[To be supplied.]

See Also

Metafile Class | Metafile Members | System.Drawing.Imaging Namespace


MetafileFrameUnit Enumeration

[To be supplied.]

[Visual Basic]
Public Enum MetafileFrameUnit
[C#]
public enum MetafileFrameUnit
[C++]
public enum MetafileFrameUnit

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Document | [To be supplied.]
GdiCompatible | [To be supplied.]
Inch | [To be supplied.]
Millimeter | [To be supplied.]
Pixel | [To be supplied.]
Point | [To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

System.Drawing.Imaging Namespace


MetafileHeader Class

[To be supplied.]

Object
MetafileHeader

[Visual Basic]
NotInheritable Public Class MetafileHeader
[C#]
public sealed class MetafileHeader
[C++]
public __gc __sealed class MetafileHeader
[JScript]
public class MetafileHeader

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

MetafileHeader Members | System.Drawing.Imaging Namespace


MetafileHeader Members

Public:

Properties

Bounds | [To be supplied.]
DeviceBounds | [To be supplied.]
DpiX | [To be supplied.]
DpiY | [To be supplied.]
EmfHeader | [To be supplied.]
EmfPlusHeaderSize | [To be supplied.]
LogicalDpiX | [To be supplied.]
LogicalDpiY | [To be supplied.]
MetafileSize | [To be supplied.]
Type | [To be supplied.]
Version | [To be supplied.]
WmfHeader | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
HasNonDualGdi | [To be supplied.]
IsDisplay | [To be supplied.]
IsEmf | [To be supplied.]
IsEmfOrEmfPlus | [To be supplied.]
IsEmfPlus | [To be supplied.]
IsEmfPlusDual | [To be supplied.]
IsEmfPlusOnly | [To be supplied.]
IsWmf | [To be supplied.]
IsWmfAldus | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MetafileHeader Class | System.Drawing.Imaging Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MetafileHeader Properties

The properties of the MetafileHeader class are listed below. For a complete list of MetafileHeader class members, see the MetafileHeader Members topic.

Public:

Bounds | [To be supplied.]
DeviceBounds | [To be supplied.]
DpiX | [To be supplied.]
DpiY | [To be supplied.]
EmfHeader | [To be supplied.]
EmfPlusHeaderSize | [To be supplied.]
LogicalDpiX | [To be supplied.]
LogicalDpiY | [To be supplied.]
MetafileSize | [To be supplied.]
Type | [To be supplied.]
Version | [To be supplied.]
WmfHeader | [To be supplied.]

See Also

MetafileHeader Class | System.Drawing.Imaging Namespace


MetafileHeader.Bounds

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Bounds As Rectangle
[C#]
public Rectangle Bounds {get;}
[C++]
public: __property Rectangle get_Bounds();
[JScript]
public function get Bounds() : Rectangle;

See Also

MetafileHeader Class | MetafileHeader Members | System.Drawing.Imaging Namespace


MetafileHeader.DeviceBounds

[To be supplied.]

[Visual Basic]
Public ReadOnly Property DeviceBounds As Rectangle
[C#]
public Rectangle DeviceBounds {get;}
[C++]
public: __property Rectangle get_DeviceBounds();
[JScript]
public function get DeviceBounds() : Rectangle;

See Also

MetafileHeader Class | MetafileHeader Members | System.Drawing.Imaging Namespace


MetafileHeader.DpiX

[To be supplied.]

[Visual Basic]
Public ReadOnly Property DpiX As Single
[C#]
public float DpiX {get;}
[C++]
public: __property float get_DpiX();
[JScript]
public function get DpiX() : float;

See Also

MetafileHeader Class | MetafileHeader Members | System.Drawing.Imaging Namespace


MetafileHeader.DpiY

[To be supplied.]

[Visual Basic]
Public ReadOnly Property DpiY As Single
[C#]
public float DpiY {get;}
[C++]
public: __property float get_DpiY();
[JScript]
public function get DpiY() : float;

See Also

MetafileHeader Class | MetafileHeader Members | System.Drawing.Imaging Namespace


MetafileHeader.EmfHeader

[To be supplied.]

[Visual Basic]
Public ReadOnly Property EmfHeader As ENHMETAHEADER
[C#]
public ENHMETAHEADER EmfHeader {get;}
[C++]
public: __property ENHMETAHEADER* get_EmfHeader();
[JScript]
public function get EmfHeader() : ENHMETAHEADER;

See Also

MetafileHeader Class | MetafileHeader Members | System.Drawing.Imaging Namespace


MetafileHeader.EmfPlusHeaderSize

[To be supplied.]

[Visual Basic]
Public ReadOnly Property EmfPlusHeaderSize As Integer
[C#]
public int EmfPlusHeaderSize {get;}
[C++]
public: __property int get_EmfPlusHeaderSize();
[JScript]
public function get EmfPlusHeaderSize() : int;

See Also

MetafileHeader Class | MetafileHeader Members | System.Drawing.Imaging Namespace


MetafileHeader.LogicalDpiX

[To be supplied.]

[Visual Basic]
Public ReadOnly Property LogicalDpiX As Integer
[C#]
public int LogicalDpiX {get;}
[C++]
public: __property int get_LogicalDpiX();
[JScript]
public function get LogicalDpiX() : int;

See Also

MetafileHeader Class | MetafileHeader Members | System.Drawing.Imaging Namespace


MetafileHeader.LogicalDpiY

[To be supplied.]

[Visual Basic]
Public ReadOnly Property LogicalDpiY As Integer
[C#]
public int LogicalDpiY {get;}
[C++]
public: __property int get_LogicalDpiY();
[JScript]
public function get LogicalDpiY() : int;

See Also

MetafileHeader Class | MetafileHeader Members | System.Drawing.Imaging Namespace


MetafileHeader.MetafileSize

[To be supplied.]

[Visual Basic]
Public ReadOnly Property MetafileSize As Integer
[C#]
public int MetafileSize {get;}
[C++]
public: __property int get_MetafileSize();
[JScript]
public function get MetafileSize() : int;

See Also

MetafileHeader Class | MetafileHeader Members | System.Drawing.Imaging Namespace


MetafileHeader.Type

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Type As MetafileType
[C#]
public MetafileType Type {get;}
[C++]
public: __property MetafileType get_Type();
[JScript]
public function get Type() : MetafileType;

See Also

MetafileHeader Class | MetafileHeader Members | System.Drawing.Imaging Namespace


MetafileHeader.Version

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Version As Integer
[C#]
public int Version {get;}
[C++]
public: __property int get_Version();
[JScript]
public function get Version() : int;

See Also

MetafileHeader Class | MetafileHeader Members | System.Drawing.Imaging Namespace


MetafileHeader.WmfHeader

[To be supplied.]

[Visual Basic]
Public ReadOnly Property WmfHeader As METAHEADER
[C#]
public METAHEADER WmfHeader {get;}
[C++]
public: __property METAHEADER* get_WmfHeader();
[JScript]
public function get WmfHeader() : METAHEADER;

See Also

MetafileHeader Class | MetafileHeader Members | System.Drawing.Imaging Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MetafileHeader Methods

The methods of the MetafileHeader class are listed below. For a complete list of MetafileHeader class members, see the MetafileHeader Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
HasNonDualGdi | [To be supplied.]
IsDisplay | [To be supplied.]
IsEmf | [To be supplied.]
IsEmfOrEmfPlus | [To be supplied.]
IsEmfPlus | [To be supplied.]
IsEmfPlusDual | [To be supplied.]
IsEmfPlusOnly | [To be supplied.]
IsWmf | [To be supplied.]
IsWmfAldus | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MetafileHeader Class | System.Drawing.Imaging Namespace


MetafileHeader.HasNonDualGdi

[To be supplied.]

[Visual Basic]
Public Function HasNonDualGdi() As Boolean
[C#]
public bool HasNonDualGdi();
[C++]
public: bool HasNonDualGdi();
[JScript]
public function HasNonDualGdi() : Boolean;

See Also

MetafileHeader Class | MetafileHeader Members | System.Drawing.Imaging Namespace


MetafileHeader.IsDisplay

[To be supplied.]

[Visual Basic]
Public Function IsDisplay() As Boolean
[C#]
public bool IsDisplay();
[C++]
public: bool IsDisplay();
[JScript]
public function IsDisplay() : Boolean;

See Also

MetafileHeader Class | MetafileHeader Members | System.Drawing.Imaging Namespace


MetafileHeader.IsEmf

[To be supplied.]

[Visual Basic]
Public Function IsEmf() As Boolean
[C#]
public bool IsEmf();
[C++]
public: bool IsEmf();
[JScript]
public function IsEmf() : Boolean;

See Also

MetafileHeader Class | MetafileHeader Members | System.Drawing.Imaging Namespace


MetafileHeader.IsEmfOrEmfPlus

[To be supplied.]

[Visual Basic]
Public Function IsEmfOrEmfPlus() As Boolean
[C#]
public bool IsEmfOrEmfPlus();
[C++]
public: bool IsEmfOrEmfPlus();
[JScript]
public function IsEmfOrEmfPlus() : Boolean;

See Also

MetafileHeader Class | MetafileHeader Members | System.Drawing.Imaging Namespace


MetafileHeader.IsEmfPlus

[To be supplied.]

[Visual Basic]
Public Function IsEmfPlus() As Boolean
[C#]
public bool IsEmfPlus();
[C++]
public: bool IsEmfPlus();
[JScript]
public function IsEmfPlus() : Boolean;

See Also

MetafileHeader Class | MetafileHeader Members | System.Drawing.Imaging Namespace


MetafileHeader.IsEmfPlusDual

[To be supplied.]

[Visual Basic]
Public Function IsEmfPlusDual() As Boolean
[C#]
public bool IsEmfPlusDual();
[C++]
public: bool IsEmfPlusDual();
[JScript]
public function IsEmfPlusDual() : Boolean;

See Also

MetafileHeader Class | MetafileHeader Members | System.Drawing.Imaging Namespace


MetafileHeader.IsEmfPlusOnly

[To be supplied.]

[Visual Basic]
Public Function IsEmfPlusOnly() As Boolean
[C#]
public bool IsEmfPlusOnly();
[C++]
public: bool IsEmfPlusOnly();
[JScript]
public function IsEmfPlusOnly() : Boolean;

See Also

MetafileHeader Class | MetafileHeader Members | System.Drawing.Imaging Namespace


MetafileHeader.IsWmf

[To be supplied.]

[Visual Basic]
Public Function IsWmf() As Boolean
[C#]
public bool IsWmf();
[C++]
public: bool IsWmf();
[JScript]
public function IsWmf() : Boolean;

See Also

MetafileHeader Class | MetafileHeader Members | System.Drawing.Imaging Namespace


MetafileHeader.IsWmfAldus

[To be supplied.]

[Visual Basic]
Public Function IsWmfAldus() As Boolean
[C#]
public bool IsWmfAldus();
[C++]
public: bool IsWmfAldus();
[JScript]
public function IsWmfAldus() : Boolean;

See Also

MetafileHeader Class | MetafileHeader Members | System.Drawing.Imaging Namespace


MetafileType Enumeration

[To be supplied.]

[Visual Basic]
Public Enum MetafileType
[C#]
public enum MetafileType
[C++]
public enum MetafileType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Emf | [To be supplied.]
EmfPlusDual | [To be supplied.]
EmfPlusOnly | [To be supplied.]
Invalid | [To be supplied.]
Wmf | [To be supplied.]
WmfAldus | [To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

System.Drawing.Imaging Namespace


METAHEADER Class

[To be supplied.]

Object
METAHEADER

[Visual Basic]
NotInheritable Public Class METAHEADER
[C#]
public sealed class METAHEADER
[C++]
public __gc __sealed class METAHEADER
[JScript]
public class METAHEADER

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

METAHEADER Members | System.Drawing.Imaging Namespace


METAHEADER Members

Public:

Constructor

METAHEADER Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

headerSize | [To be supplied.]
maxRecord | [To be supplied.]
noObjects | [To be supplied.]
noParameters | [To be supplied.]
size | [To be supplied.]
type | [To be supplied.]
version | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

METAHEADER Class | System.Drawing.Imaging Namespace


METAHEADER Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public METAHEADER();
[C++]
public: METAHEADER();
[JScript]
public function METAHEADER();

See Also

METAHEADER Class | METAHEADER Members | System.Drawing.Imaging Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

METAHEADER Fields

The fields of the METAHEADER class are listed below. For a complete list of METAHEADER class members, see the METAHEADER Members topic.

Public:

headerSize | [To be supplied.]
maxRecord | [To be supplied.]
noObjects | [To be supplied.]
noParameters | [To be supplied.]
size | [To be supplied.]
type | [To be supplied.]
version | [To be supplied.]

See Also

METAHEADER Class | System.Drawing.Imaging Namespace


METAHEADER.headerSize

[To be supplied.]

[Visual Basic]
Public headerSize As Short
[C#]
public short headerSize;
[C++]
public: short headerSize;
[JScript]
public var headerSize : Int16;

See Also

METAHEADER Class | METAHEADER Members | System.Drawing.Imaging Namespace


METAHEADER.maxRecord

[To be supplied.]

[Visual Basic]
Public maxRecord As Integer
[C#]
public int maxRecord;
[C++]
public: int maxRecord;
[JScript]
public var maxRecord : int;

See Also

METAHEADER Class | METAHEADER Members | System.Drawing.Imaging Namespace


METAHEADER.noObjects

[To be supplied.]

[Visual Basic]
Public noObjects As Short
[C#]
public short noObjects;
[C++]
public: short noObjects;
[JScript]
public var noObjects : Int16;

See Also

METAHEADER Class | METAHEADER Members | System.Drawing.Imaging Namespace


METAHEADER.noParameters

[To be supplied.]

[Visual Basic]
Public noParameters As Short
[C#]
public short noParameters;
[C++]
public: short noParameters;
[JScript]
public var noParameters : Int16;

See Also

METAHEADER Class | METAHEADER Members | System.Drawing.Imaging Namespace


METAHEADER.size

[To be supplied.]

[Visual Basic]
Public size As Integer
[C#]
public int size;
[C++]
public: int size;
[JScript]
public var size : int;

See Also

METAHEADER Class | METAHEADER Members | System.Drawing.Imaging Namespace


METAHEADER.type

[To be supplied.]

[Visual Basic]
Public type As Short
[C#]
public short type;
[C++]
public: short type;
[JScript]
public var type : Int16;

See Also

METAHEADER Class | METAHEADER Members | System.Drawing.Imaging Namespace


METAHEADER.version

[To be supplied.]

[Visual Basic]
Public version As Short
[C#]
public short version;
[C++]
public: short version;
[JScript]
public var version : Int16;

See Also

METAHEADER Class | METAHEADER Members | System.Drawing.Imaging Namespace


PaletteFlags Enumeration

[To be supplied.]

[Visual Basic]
Public Enum PaletteFlags
[C#]
public enum PaletteFlags
[C++]
public enum PaletteFlags

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
GrayScale | [To be supplied.]
Halftone | [To be supplied.]
HasAlpha | [To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

System.Drawing.Imaging Namespace


PixelFormat Enumeration

[To be supplied.]

[Visual Basic]
Public Enum PixelFormat
[C#]
public enum PixelFormat
[C++]
public enum PixelFormat

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Alpha | [To be supplied.]
Canonical | [To be supplied.]
DontCare | [To be supplied.]
Extended | [To be supplied.]
Format16bppARGB1555 | [To be supplied.]
Format16bppGrayScale | [To be supplied.]
Format16bppRGB555 | [To be supplied.]
Format16bppRGB565 | [To be supplied.]
Format1bppIndexed | [To be supplied.]
Format24bppBGR | [To be supplied.]
Format24bppRGB | [To be supplied.]
Format32bppARGB | [To be supplied.]
Format32bppPARGB | [To be supplied.]
Format32bppRGB | [To be supplied.]
Format48bppRGB | [To be supplied.]
Format4bppIndexed | [To be supplied.]
Format64bppARGB | [To be supplied.]
Format64bppPARGB | [To be supplied.]
Format8bppIndexed | [To be supplied.]
GDI | [To be supplied.]
Indexed | [To be supplied.]
Max | [To be supplied.]
PAlpha | [To be supplied.]
Undefined | [To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

System.Drawing.Imaging Namespace


PropertyItem Class

[To be supplied.]

Object
PropertyItem

[Visual Basic]
NotInheritable Public Class PropertyItem
[C#]
public sealed class PropertyItem
[C++]
public __gc __sealed class PropertyItem
[JScript]
public class PropertyItem

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

PropertyItem Members | System.Drawing.Imaging Namespace


PropertyItem Members

Public:

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

id | [To be supplied.]
len | [To be supplied.]
type | [To be supplied.]
value | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyItem Class | System.Drawing.Imaging Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PropertyItem Fields

The fields of the PropertyItem class are listed below. For a complete list of PropertyItem class members, see the PropertyItem Members topic.

Public:

id | [To be supplied.]
len | [To be supplied.]
type | [To be supplied.]
value | [To be supplied.]

See Also

PropertyItem Class | System.Drawing.Imaging Namespace


PropertyItem.id

[To be supplied.]

[Visual Basic]
Public id As Integer
[C#]
public int id;
[C++]
public: int id;
[JScript]
public var id : int;

See Also

PropertyItem Class | PropertyItem Members | System.Drawing.Imaging Namespace


PropertyItem.len

[To be supplied.]

[Visual Basic]
Public len As Integer
[C#]
public int len;
[C++]
public: int len;
[JScript]
public var len : int;

See Also

PropertyItem Class | PropertyItem Members | System.Drawing.Imaging Namespace


PropertyItem.type

[To be supplied.]

[Visual Basic]
Public type As Short
[C#]
public short type;
[C++]
public: short type;
[JScript]
public var type : Int16;

See Also

PropertyItem Class | PropertyItem Members | System.Drawing.Imaging Namespace


PropertyItem.value

[To be supplied.]

[Visual Basic]
Public value() As Byte
[C#]
public byte[] value;
[C++]
public: unsigned char* value[];
[JScript]
public var value : Byte[];

See Also

PropertyItem Class | PropertyItem Members | System.Drawing.Imaging Namespace


ValueType Enumeration

[To be supplied.]

[Visual Basic]
Public Enum ValueType
[C#]
public enum ValueType
[C++]
public enum ValueType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
ASCII | [To be supplied.]
Byte | [To be supplied.]
Long | [To be supplied.]
LongRange | [To be supplied.]
Rational | [To be supplied.]
RationalRange | [To be supplied.]
Short | [To be supplied.]
Undefined | [To be supplied.]

Requirements

Namespace: System.Drawing.Imaging

Assembly: System.Drawing.dll

See Also

System.Drawing.Imaging Namespace


System.Drawing.Printing

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Drawing.Printing Namespace

Classes

Class | Description
InvalidPrinterException | Represents the exception that is thrown when trying to access a printer using invalid PrinterSettings.
Margins | Specifies the margins of a printed page.
MarginsConverter | Provides a type converter to convert Margins to and from various other representations.
PageSettings | Settings that apply to a single page.
PaperSize | The size of a piece of paper.
PaperSource | Specifies the paper tray from which the printer gets paper.
PreviewPageInfo | Specifies print preview information for a single page. This class cannot be inherited.
PreviewPrintController | A PrintController which "prints" to a series of images.
PrintController | A PrintController controls how a PrintDocument is printed-- how a bunch of PrintPageEventArgs's are turned into actual printer output. PrintDocument.Print invokes PrintController.StartPrint, EndPrint, StartPage, and EndPage, which in turn tell the printer what to print. Print preview uses a specialized PrintController; most users will never need to touch a PrintController.
PrintDocument | Defines a reusable object that sends output to the printer.
PrinterResolution | Retrieves the custom resolution supported by a printer.
PrinterSettings | Information about how a document should be printed, including which printer to print it on.
PrinterSettings.PaperSizeCollection | Collection of PaperSize's...
PrinterSettings.PaperSourceCollection | Collection of PaperSource's...
PrinterSettings.PrinterResolutionCollection | Collection of PrinterResolution's...
PrinterSettings.StringCollection | Collection of String's...
PrinterUnitConvert | Specifies a series of conversion methods that are useful when interoperating with the raw Win32 printing API. This class cannot be inherited.
PrintEventArgs | Provides data for the OnBeginPrint and OnEndPrint events.
PrintPageEventArgs | Provides data for the OnPrintPage event.
QueryPageSettingsEventArgs | Provides data for the System.Drawing.Printing.PrintDocument.QueryPageSettings event.
StandardPrintController | Specifies a print controller that sends information to a printer.

Delegates

Delegate | Description
PrintEventHandler | Represents the method that will handle the System.Drawing.Printing.PrintDocument.BeginPrint, System.Drawing.Printing.PrintDocument.EndPrint, or System.Drawing.Printing.PrintDocument.QueryPageSettings event of a PrintDocument.
PrintPageEventHandler | Represents the method that will handle the System.Drawing.Printing.PrintDocument.PrintPage event of a PrintDocument.
QueryPageSettingsEventHandler | Represents the method that will handle the System.Drawing.Printing.PrintDocument.QueryPageSettings event of a PrintDocument.

Enumerations

Enumeration | Description
Duplex | Specifies the printer's duplex setting.
PaperKind | Specifies the standard paper sizes.
PaperSourceKind | Standard paper sources.
PrinterResolutionKind | Specifies a printer resolution.
PrinterUnit | Specifies several of the units of measure Win32 uses for printing.
PrintRange | Specifies the option buttons in the print dialog box that designate the part of the document to print.


Duplex Enumeration

Specifies the printer's duplex setting.

[Visual Basic]
Public Enum Duplex
[C#]
public enum Duplex
[C++]
public enum Duplex

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

This enumeration is used by PrinterSettings.

Members

Member Name | Description
Default | The printer's default duplex setting.
Horizontal | Double-sided, horizontal printing.
Simplex | Single-sided printing.
Vertical | Double-sided, vertical printing.

Requirements

Namespace: System.Drawing.Printing

Assembly: System.Drawing.dll

See Also

System.Drawing.Printing Namespace


InvalidPrinterException Class

Represents the exception that is thrown when trying to access a printer using invalid PrinterSettings.

Object
Exception
InvalidPrinterException

[Visual Basic]
Public Class InvalidPrinterException
   Inherits Exception
[C#]
public class InvalidPrinterException : Exception
[C++]
public __gc class InvalidPrinterException : public Exception
[JScript]
public class InvalidPrinterException extends Exception

Remarks

The most common cause of invalid PrinterSettings is referencing a printer which doesn't exist.

Requirements

Namespace: System.Drawing.Printing

Assembly: System.Drawing.dll

See Also

InvalidPrinterException Members | System.Drawing.Printing Namespace


InvalidPrinterException Members

Public:

Constructor

InvalidPrinterException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

InvalidPrinterException Class | System.Drawing.Printing Namespace


InvalidPrinterException Constructor

[To be supplied.]

Overload List

Initializes a new instance of the InvalidPrinterException class.

[Visual Basic] Overloads Public Sub New(PrinterSettings)
[C#] public InvalidPrinterException(PrinterSettings);
[C++] public: InvalidPrinterException(PrinterSettings*);
[JScript] public function InvalidPrinterException(PrinterSettings);

Initializes a new instance of the InvalidPrinterException class.

[Visual Basic] Overloads Public Sub New(String)
[C#] public InvalidPrinterException(String);
[C++] public: InvalidPrinterException(String*);
[JScript] public function InvalidPrinterException(String);

See Also

InvalidPrinterException Class | InvalidPrinterException Members | System.Drawing.Printing Namespace


InvalidPrinterException Constructor (PrinterSettings)

Initializes a new instance of the InvalidPrinterException class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal settings As PrinterSettings _
)
[C#]
public InvalidPrinterException(
   PrinterSettings settings
);
[C++]
public: InvalidPrinterException(
   PrinterSettings* settings
);
[JScript]
public function InvalidPrinterException(
   settings : PrinterSettings
);

Parameters

settings
[To be supplied.]

See Also

InvalidPrinterException Class | InvalidPrinterException Members | System.Drawing.Printing Namespace | InvalidPrinterException Constructor Overload List


InvalidPrinterException Constructor (String)

Initializes a new instance of the InvalidPrinterException class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal printerName As String _
)
[C#]
public InvalidPrinterException(
   string printerName
);
[C++]
public: InvalidPrinterException(
   String* printerName
);
[JScript]
public function InvalidPrinterException(
   printerName : String
);

Parameters

printerName
[To be supplied.]

See Also

InvalidPrinterException Class | InvalidPrinterException Members | System.Drawing.Printing Namespace | InvalidPrinterException Constructor Overload List


Margins Class

Specifies the margins of a printed page.

Object
Margins

[Visual Basic]
Public Class Margins
   Implements ICloneable
[C#]
public class Margins : ICloneable
[C++]
public __gc class Margins : public ICloneable
[JScript]
public class Margins implements ICloneable

Remarks

This class is used to manipulate margins in PageSettings and PrintController. System.Drawing.Printing.MarginsConvertor is the type descriptor for this class.

Left, Right, Top, and Bottom are properties that define the margins. Clone creates an identical System.Drawing.Printing.Margin. Equals determines if another object is equivalent a System.Drawing.Printing.Margin.

Requirements

Namespace: System.Drawing.Printing

Assembly: System.Drawing.dll

See Also

Margins Members | System.Drawing.Printing Namespace | PageSettings | PrintController | MarginsConverter


Margins Members

Public:

Constructor

Margins Constructor Overloaded. Initializes a new instance of a the Margins class .

Properties

Bottom | Gets or sets the bottom margin, in hundredths of an inch.
Left | Gets or sets the left margin, in hundredths of an inch.
Right | Gets or sets the right margin, in hundredths of an inch.
Top | Gets or sets the top margin, in hundredths of an inch.

Methods

Clone | Retrieves a duplicate of this object, member by member.
Equals | Compares this Margins to a specified Margins to see whether they are equivalent.
GetHashCode | Calculates and retrieves a hash code based on the left, right, up, and bottom margins.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Margins Class | System.Drawing.Printing Namespace


Margins Constructor

Initializes a new instance of a the Margins class .

Overload List

Initializes a new instance of a the Margins class with one inch margins.

[Visual Basic] Overloads Public Sub New()
[C#] public Margins();
[C++] public: Margins();
[JScript] public function Margins();

Initializes a new instance of a the Margins class with the specified left, right, top, and bottom margins.

[Visual Basic] Overloads Public Sub New(Integer, Integer, Integer, Integer)
[C#] public Margins(int, int, int, int);
[C++] public: Margins(int, int, int, int);
[JScript] public function Margins(int, int, int, int);

See Also

Margins Class | Margins Members | System.Drawing.Printing Namespace


Margins Constructor ()

Initializes a new instance of a the Margins class with one inch margins.

[Visual Basic]
Overloads Public Sub New()
[C#]
public Margins();
[C++]
public: Margins();
[JScript]
public function Margins();

Remarks

This

See Also

Margins Class | Margins Members | System.Drawing.Printing Namespace | Margins Constructor Overload List


Margins Constructor (Int32, Int32, Int32, Int32)

Initializes a new instance of a the Margins class with the specified left, right, top, and bottom margins.

[Visual Basic]
Overloads Public Sub New( _
   ByVal left As Integer, _
   ByVal right As Integer, _
   ByVal top As Integer, _
   ByVal bottom As Integer _
)
[C#]
public Margins(
   int left,
   int right,
   int top,
   int bottom
);
[C++]
public: Margins(
   int left,
   int right,
   int top,
   int bottom
);
[JScript]
public function Margins(
   left : int,
   right : int,
   top : int,
   bottom : int
);

Parameters

left
The left margin, in hundredths of an inch.
right
The right margin, in hundredths of an inch.
top
The top margin, in hundredths of an inch.
bottom
The bottom margin, in hundredths of an inch.

See Also

Margins Class | Margins Members | System.Drawing.Printing Namespace | Margins Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Margins Properties

The properties of the Margins class are listed below. For a complete list of Margins class members, see the Margins Members topic.

Public:

Bottom | Gets or sets the bottom margin, in hundredths of an inch.
Left | Gets or sets the left margin, in hundredths of an inch.
Right | Gets or sets the right margin, in hundredths of an inch.
Top | Gets or sets the top margin, in hundredths of an inch.

See Also

Margins Class | System.Drawing.Printing Namespace


Margins.Bottom

Gets or sets the bottom margin, in hundredths of an inch.

[Visual Basic]
Public Property Bottom As Integer
[C#]
public int Bottom {get; set;}
[C++]
public: __property int get_Bottom();
public: __property void set_Bottom(int);
[JScript]
public function get Bottom() : int;
public function set Bottom(int);

Property Value

The bottom margin, in hundredths of an inch.

See Also

Margins Class | Margins Members | System.Drawing.Printing Namespace | Left | Right | System.Drawing.Printing.Margins.Up


Margins.Left

Gets or sets the left margin, in hundredths of an inch.

[Visual Basic]
Public Property Left As Integer
[C#]
public int Left {get; set;}
[C++]
public: __property int get_Left();
public: __property void set_Left(int);
[JScript]
public function get Left() : int;
public function set Left(int);

Property Value

The left margin, in hundredths of an inch.

See Also

Margins Class | Margins Members | System.Drawing.Printing Namespace | Right | Top | Bottom


Margins.Right

Gets or sets the right margin, in hundredths of an inch.

[Visual Basic]
Public Property Right As Integer
[C#]
public int Right {get; set;}
[C++]
public: __property int get_Right();
public: __property void set_Right(int);
[JScript]
public function get Right() : int;
public function set Right(int);

Property Value

The right margin, in hundredths of an inch.

See Also

Margins Class | Margins Members | System.Drawing.Printing Namespace | Left | Top | Bottom


Margins.Top

Gets or sets the top margin, in hundredths of an inch.

[Visual Basic]
Public Property Top As Integer
[C#]
public int Top {get; set;}
[C++]
public: __property int get_Top();
public: __property void set_Top(int);
[JScript]
public function get Top() : int;
public function set Top(int);

Property Value

The top margin, in hundredths of an inch.

See Also

Margins Class | Margins Members | System.Drawing.Printing Namespace | Left | Right | Bottom


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Margins Methods

The methods of the Margins class are listed below. For a complete list of Margins class members, see the Margins Members topic.

Public:

Clone | Retrieves a duplicate of this object, member by member.
Equals | Compares this Margins to a specified Margins to see whether they are equivalent.
GetHashCode | Calculates and retrieves a hash code based on the left, right, up, and bottom margins.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Margins Class | System.Drawing.Printing Namespace


Margins.Clone

Retrieves a duplicate of this object, member by member.

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

Return Value

A duplicate of this object.

See Also

Margins Class | Margins Members | System.Drawing.Printing Namespace | Equals


Margins.Equals

Compares this Margins to a specified Margins to see whether they are equivalent.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The object to which to compare this Margins.

Return Value

true if the objects are equivalent; otherwise, false.

See Also

Margins Class | Margins Members | System.Drawing.Printing Namespace | Clone


Margins.GetHashCode

Calculates and retrieves a hash code based on the left, right, up, and bottom margins.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

A hash code based on the left, right, up, and bottom margins.

See Also

Margins Class | Margins Members | System.Drawing.Printing Namespace


MarginsConverter Class

Provides a type converter to convert Margins to and from various other representations.

Object
TypeConverter
MarginsConverter

[Visual Basic]
Public Class MarginsConverter
   Inherits TypeConverter
[C#]
public class MarginsConverter : TypeConverter
[C++]
public __gc class MarginsConverter : public TypeConverter
[JScript]
public class MarginsConverter extends TypeConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Printing

Assembly: System.Drawing.dll

See Also

System.Drawing.Printing Namespace


PageSettings Class

Settings that apply to a single page.

Object
PageSettings

[Visual Basic]
Public Class PageSettings
   Implements ICloneable
[C#]
public class PageSettings : ICloneable
[C++]
public __gc class PageSettings : public ICloneable
[JScript]
public class PageSettings implements ICloneable

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Printing

Assembly: System.Drawing.dll

See Also

PageSettings Members | System.Drawing.Printing Namespace | PrintDocument


PageSettings Members

Public:

Constructor

PageSettings Constructor Overloaded. [To be supplied.]

Properties

Bounds | Gets the bounds of the page, taking into account the Landscape property.
Color | Gets or sets a value indicating whether the page is printed in color.
Landscape | Gets or sets a value indicating whether the page should be printed in landscape or portrait orientation.
Margins | Gets or sets a value indicating the margins for this page.
PaperSize | Gets or sets a value indicating the paper size.
PaperSource | Gets or sets a value indicating the paper source (i.e. upper bin).
PrinterResolution | Gets or sets a value indicating the printer resolution for the page.
PrinterSettings | Gets or sets the associated PrinterSettings, which is used to find default values for unset properties.

Methods

Clone | Copies the settings and margins.
CopyToHDEVMODE | Copies the relevant information out of the PageSettings and into the handle.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SetHDEVMODE | Copies the relevant information out of the handle and into the PageSettings.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PageSettings Class | System.Drawing.Printing Namespace


PageSettings Constructor

[To be supplied.]

Overload List

Creates a PageSettings initialized from the default printer.

[Visual Basic] Overloads Public Sub New()
[C#] public PageSettings();
[C++] public: PageSettings();
[JScript] public function PageSettings();

Creates a PageSettings initialized from the specified printer.

[Visual Basic] Overloads Public Sub New(PrinterSettings)
[C#] public PageSettings(PrinterSettings);
[C++] public: PageSettings(PrinterSettings*);
[JScript] public function PageSettings(PrinterSettings);

See Also

PageSettings Class | PageSettings Members | System.Drawing.Printing Namespace


PageSettings Constructor ()

Creates a PageSettings initialized from the default printer.

[Visual Basic]
Overloads Public Sub New()
[C#]
public PageSettings();
[C++]
public: PageSettings();
[JScript]
public function PageSettings();

See Also

PageSettings Class | PageSettings Members | System.Drawing.Printing Namespace | PageSettings Constructor Overload List


PageSettings Constructor (PrinterSettings)

Creates a PageSettings initialized from the specified printer.

[Visual Basic]
Overloads Public Sub New( _
   ByVal printerSettings As PrinterSettings _
)
[C#]
public PageSettings(
   PrinterSettings printerSettings
);
[C++]
public: PageSettings(
   PrinterSettings* printerSettings
);
[JScript]
public function PageSettings(
   printerSettings : PrinterSettings
);

Parameters

printerSettings
The printer to use

See Also

PageSettings Class | PageSettings Members | System.Drawing.Printing Namespace | PageSettings Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PageSettings Properties

The properties of the PageSettings class are listed below. For a complete list of PageSettings class members, see the PageSettings Members topic.

Public:

Bounds | Gets the bounds of the page, taking into account the Landscape property.
Color | Gets or sets a value indicating whether the page is printed in color.
Landscape | Gets or sets a value indicating whether the page should be printed in landscape or portrait orientation.
Margins | Gets or sets a value indicating the margins for this page.
PaperSize | Gets or sets a value indicating the paper size.
PaperSource | Gets or sets a value indicating the paper source (i.e. upper bin).
PrinterResolution | Gets or sets a value indicating the printer resolution for the page.
PrinterSettings | Gets or sets the associated PrinterSettings, which is used to find default values for unset properties.

See Also

PageSettings Class | System.Drawing.Printing Namespace


PageSettings.Bounds

Gets the bounds of the page, taking into account the Landscape property.

[Visual Basic]
Public ReadOnly Property Bounds As Rectangle
[C#]
public Rectangle Bounds {get;}
[C++]
public: __property Rectangle get_Bounds();
[JScript]
public function get Bounds() : Rectangle;

See Also

PageSettings Class | PageSettings Members | System.Drawing.Printing Namespace


PageSettings.Color

Gets or sets a value indicating whether the page is printed in color.

[Visual Basic]
Public Property Color As Boolean
[C#]
public bool Color {get; set;}
[C++]
public: __property bool get_Color();
public: __property void set_Color(bool);
[JScript]
public function get Color() : Boolean;
public function set Color(Boolean);

Property Value

true if the page is printed in color; otherwise, false.

See Also

PageSettings Class | PageSettings Members | System.Drawing.Printing Namespace


PageSettings.Landscape

Gets or sets a value indicating whether the page should be printed in landscape or portrait orientation.

[Visual Basic]
Public Property Landscape As Boolean
[C#]
public bool Landscape {get; set;}
[C++]
public: __property bool get_Landscape();
public: __property void set_Landscape(bool);
[JScript]
public function get Landscape() : Boolean;
public function set Landscape(Boolean);

Property Value

true if the page should be printed in landscape orientation; otherwise false.

See Also

PageSettings Class | PageSettings Members | System.Drawing.Printing Namespace


PageSettings.Margins

Gets or sets a value indicating the margins for this page.

[Visual Basic]
Public Property Margins As Margins
[C#]
public Margins Margins {get; set;}
[C++]
public: __property Margins* get_Margins();
public: __property void set_Margins(Margins*);
[JScript]
public function get Margins() : Margins;
public function set Margins(Margins);

Property Value

The margins for this page, in one hundredths of an inch.

See Also

PageSettings Class | PageSettings Members | System.Drawing.Printing Namespace | Margins


PageSettings.PaperSize

Gets or sets a value indicating the paper size.

[Visual Basic]
Public Property PaperSize As PaperSize
[C#]
public PaperSize PaperSize {get; set;}
[C++]
public: __property PaperSize* get_PaperSize();
public: __property void set_PaperSize(PaperSize*);
[JScript]
public function get PaperSize() : PaperSize;
public function set PaperSize(PaperSize);

Property Value

The paper size.

See Also

PageSettings Class | PageSettings Members | System.Drawing.Printing Namespace | PaperSize


PageSettings.PaperSource

Gets or sets a value indicating the paper source (i.e. upper bin).

[Visual Basic]
Public Property PaperSource As PaperSource
[C#]
public PaperSource PaperSource {get; set;}
[C++]
public: __property PaperSource* get_PaperSource();
public: __property void set_PaperSource(PaperSource*);
[JScript]
public function get PaperSource() : PaperSource;
public function set PaperSource(PaperSource);

Property Value

The paper source (i.e. upper bin).

See Also

PageSettings Class | PageSettings Members | System.Drawing.Printing Namespace | PaperSources


PageSettings.PrinterResolution

Gets or sets a value indicating the printer resolution for the page.

[Visual Basic]
Public Property PrinterResolution As PrinterResolution
[C#]
public PrinterResolution PrinterResolution {get; set;}
[C++]
public: __property PrinterResolution* get_PrinterResolution();
public: __property void set_PrinterResolution(PrinterResolution*);
[JScript]
public function get PrinterResolution() : PrinterResolution;
public function set PrinterResolution(PrinterResolution);

Property Value

One of the PrinterResolution values.

See Also

PageSettings Class | PageSettings Members | System.Drawing.Printing Namespace | PrinterResolution


PageSettings.PrinterSettings

Gets or sets the associated PrinterSettings, which is used to find default values for unset properties.

[Visual Basic]
Public Property PrinterSettings As PrinterSettings
[C#]
public PrinterSettings PrinterSettings {get; set;}
[C++]
public: __property PrinterSettings* get_PrinterSettings();
public: __property void set_PrinterSettings(PrinterSettings*);
[JScript]
public function get PrinterSettings() : PrinterSettings;
public function set PrinterSettings(PrinterSettings);

See Also

PageSettings Class | PageSettings Members | System.Drawing.Printing Namespace | PrinterSettings


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PageSettings Methods

The methods of the PageSettings class are listed below. For a complete list of PageSettings class members, see the PageSettings Members topic.

Public:

Clone | Copies the settings and margins.
CopyToHDEVMODE | Copies the relevant information out of the PageSettings and into the handle.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SetHDEVMODE | Copies the relevant information out of the handle and into the PageSettings.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PageSettings Class | System.Drawing.Printing Namespace


PageSettings.Clone

Copies the settings and margins.

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

See Also

PageSettings Class | PageSettings Members | System.Drawing.Printing Namespace


PageSettings.CopyToHDEVMODE

Copies the relevant information out of the PageSettings and into the handle.

[Visual Basic]
Public Sub CopyToHDEVMODE( _
   ByVal hDevmode As Integer _
)
[C#]
public void CopyToHDEVMODE(
   int hDevmode
);
[C++]
public: void CopyToHDEVMODE(
   int hDevmode
);
[JScript]
public function CopyToHDEVMODE(
   hDevmode : int
);

Parameters

hDevmode
[To be supplied.]

See Also

PageSettings Class | PageSettings Members | System.Drawing.Printing Namespace


PageSettings.SetHDEVMODE

Copies the relevant information out of the handle and into the PageSettings.

[Visual Basic]
Public Sub SetHDEVMODE( _
   ByVal hDevmode As Integer _
)
[C#]
public void SetHDEVMODE(
   int hDevmode
);
[C++]
public: void SetHDEVMODE(
   int hDevmode
);
[JScript]
public function SetHDEVMODE(
   hDevmode : int
);

Parameters

hDevmode
[To be supplied.]

See Also

PageSettings Class | PageSettings Members | System.Drawing.Printing Namespace


PaperKind Enumeration

Specifies the standard paper sizes.

[Visual Basic]
Public Enum PaperKind
[C#]
public enum PaperKind
[C++]
public enum PaperKind

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
A2 | A2 paper (420 mm by 594 mm).
A3 | A3 paper (297 mm by 420 mm).
A3Extra | A3 Extra paper (322 mm by 445 mm).
A3ExtraTransverse | A3 Extra Transverse paper (322 mm by 445 mm).
A3Rotated | Rotated A3 paper (420mm by 297 mm).
A3Transverse | A3 Transverse paper (297 mm by 420 mm).
A4 | A4 paper (210 mm by 297 mm).
A4Extra | A4 Extra paper (9.27 in. by 12.69 in.). This value is specific to the PostScript driver and is used only by Linotronic printers to help save paper.
A4Plus | A4 Plus paper (210 mm by 330 mm).
A4Rotated | Rotated A4 paper (297 mm by 210 mm). Requires Windows 98, Windows NT 4.0, or later.
A4Small | A4 Small paper (210 mm by 297 mm).
A4Transverse | A4 Transverse paper (210 mm by 297 mm).
A5 | A5 paper (148 mm by 210 mm).
A5Extra | A5 Extra paper (174 mm by 235 mm).
A5Rotated | A 210-by-148-millimeter rotated A5 sheet. Requires Windows 98, Windows NT 4.0, or later.
A5Transverse | A5 Transverse paper (148 mm by 210 mm).
A6 | A6 paper (105 mm by 148 mm). Requires Windows 98, Windows NT 4.0, or later.
A6Rotated | Rotated A6 (148 mm by 105 mm). Requires Windows 98, Windows NT 4.0, or later.
APlus | SuperA/SuperA/A4 sheet (227 mm by 356 mm).
B4 | B4 paper (250 mm by 354 mm).
B4Envelope | B4 envelope (250 mm by 53 mm).
B4JISRotated | JIS rotated B4 paper (364 mm by 257 mm). Requires Windows 98, Windows NT 4.0, or later.
B5 | B5 paper (182 mm by 257 mm).
B5Envelope | B5 envelope (176 mm by 250 mm).
B5Extra | ISO B5 Extra paper (201 mm by 276 mm).
B5JISRotated | JIS rotated B5 paper (257 mm by 182 mm). Requires Windows 98, Windows NT 4.0, or later.
B5Transverse | JIS B5 Transverse paper (182 mm by 257 mm).
B6Envelope | B6 envelope (176 mm by 125 mm).
B6JIS | JIS B6 paper (128 mm by 182 mm). Requires Windows 98, Windows NT 4.0, or later.
B6JISRotated | JIS rotated B6 paper (182 mm by 128 mm). Requires Windows 98, Windows NT 4.0, or later.
BPlus | SuperB/SuperB/A3 paper (305 mm by 487 mm).
C3Envelope | C3 envelope (324 mm by 458 mm).
C4Envelope | C4 envelope (229 mm by 324 mm).
C5Envelope | C5 envelope (162 mm by 229 mm).
C65Envelope | C65 envelope (114 mm by 29 mm).
C6Envelope | C6 envelope (114 mm by 162 mm).
CSheet | C paper (17 in. by 22 in.).
Custom | The paper size is defined by the user.
DLEnvelope | DL envelope (110 mm by 220 mm).
DSheet | D paper (22 in. by 34 in.).
ESheet | E paper (34 in. by 44 in.).
Executive | Executive paper (7.25 in. by 10.5 in.).
Folio | Folio paper (8.5 in. by 13 in.).
GermanLegalFanfold | German Legal Fanfold (8.5 in. by 13 in.).
GermanStandardFanfold | German Standard Fanfold (8.5 in. by 12 in.).
InviteEnvelope | Invite envelope (220 mm by 220 mm)
ISOB4 | ISO B4 (250 mm by 353 mm).
ItalyEnvelope | Italy envelope (110 mm by 230 mm).
JapaneseDoublePostcard | Japanese Double postcard (200 mm by 148 mm). Requires Windows 98, Windows NT 4.0, or later.
JapaneseDoublePostcardRotated | Rotated Japanese Double postcard (148 mm by 200 mm). Requires Windows 98, Windows NT 4.0, or later.
JapaneseEnvelopeChouNumber3 | Japanese Chou #3 envelope. Requires Windows 98, Windows NT 4.0, or later.
JapaneseEnvelopeChouNumber3Rotated | Rotated Japanese Chou #3 envelope. Requires Windows 98, Windows NT 4.0, or later.
JapaneseEnvelopeChouNumber4 | Japanese Chou #4 envelope. Requires Windows 98, Windows NT 4.0, or later.
JapaneseEnvelopeChouNumber4Rotated | Rotated Japanese Chou #4 envelope. Requires Windows 98, Windows NT 4.0, or later.
JapaneseEnvelopeKakuNumber2 | A Japanese Kaku #2 envelope. Requires Windows 98, Windows NT 4.0, or later.
JapaneseEnvelopeKakuNumber2Rotated | Rotated Japanese Kaku #2 envelope. Requires Windows 98, Windows NT 4.0, or later.
JapaneseEnvelopeKakuNumber3 | Japanese Kaku #3 envelope. Requires Windows 98, Windows NT 4.0, or later.
JapaneseEnvelopeKakuNumber3Rotated | Rotated Japanese Kaku #3 envelope. Requires Windows 98, Windows NT 4.0, or later.
JapaneseEnvelopeYouNumber4 | Japanese You #4 envelope. Requires Windows 98, Windows NT 4.0, or later.
JapaneseEnvelopeYouNumber4Rotated | Rotated Japanese You #4 envelope. Requires Windows 98, Windows NT 4.0, or later.
JapanesePostcard | Japanese postcard (100 mm by 148 mm).
JapanesePostcardRotated | Rotated Japanese postcard (148 mm by 100 mm). Requires Windows 98, Windows NT 4.0, or later.
Ledger | Ledger paper (17 in. by 11 in.).
Legal | Legal paper (8.5 in. by 14 in.).
LegalExtra | Legal Extra paper (9.275 in. by 15 in.). This value is specific to the PostScript driver and is used only by Linotronic printers in order to conserve paper.
Letter | Letter paper (8.5 in. by 11 in.).
LetterExtra | Letter Extra paper (9.275 in. by 12 in.). This value is specific to the PostScript driver and is used only by Linotronic printers in order to conserve paper.
LetterExtraTransverse | Letter Extra Transverse paper (9.275 in. by 12 in.).
LetterPlus | Letter Plus paper (8.5 in. by 12.69 in.).
LetterRotated | Rotated letter paper (11 in. by 8.5 in.).
LetterSmall | Small Letter paper (8.5 in. by 11 in.).
LetterTransverse | Letter Transverse paper (8.275 in. by 11 in.).
MonarchEnvelope | Monarch Envelope (3.875 in. by 7.5 in.).
Note | Note paper (8.5 in. by 11 in.).
Number10Envelope | #10 envelope (4.125 in. by 9.5 in.).
Number11Envelope | #11 Envelope (4.5 in. by 10.375 in.).
Number12Envelope | #12 envelope (4.75 in. by 11 in.).
Number14Envelope | #14 envelope (5 in. by 11.5 in.).
Number9Envelope | #9 envelope (3.875 in. by 8.875 in.).
PersonalEnvelope | 6 3/4 envelope (3.625 in. by 6.5 in.).
PRC16K | People's Republic of China 16K paper (146 mm by 215 mm). Requires Windows 98, Windows NT 4.0, or later.
PRC16KRotated | People's Republic of China rotated 16K paper (146 mm by 215 mm). Requires Windows 98, Windows NT 4.0, or later.
PRC32K | People's Republic of China 32K paper (97 mm by 151 mm). Requires Windows 98, Windows NT 4.0, or later.
PRC32KBig | People's Republic of China 32K Big paper (97 mm by 151 mm). Requires Windows 98, Windows NT 4.0, or later.
PRC32KBigRotated | People's Republic of China rotated 32K Big paper (97 mm by 151 mm). Requires Windows 98, Windows NT 4.0, or later.
PRC32KRotated | People's Republic of China rotated 32K paper (97 mm by 151 mm). Requires Windows 98, Windows NT 4.0, or later.
PRCEnvelopeNumber1 | People's Republic of China #1 envelope (102 mm by 165 mm). Requires Windows 98, Windows NT 4.0, or later.
PRCEnvelopeNumber10 | People's Republic of China #10 envelope (324 mm by 458 mm). Requires Windows 98, Windows NT 4.0, or later.
PRCEnvelopeNumber10Rotated | People's Republic of China rotated #10 envelope (458 mm by 324 mm). Requires Windows 98, Windows NT 4.0, or later.
PRCEnvelopeNumber1Rotated | People's Republic of China rotated #1 envelope (165 mm by 102 mm). Requires Windows 98, Windows NT 4.0, or later.
PRCEnvelopeNumber2 | People's Republic of China #2 envelope (102 mm by 176 mm). Requires Windows 98, Windows NT 4.0, or later.
PRCEnvelopeNumber2Rotated | People's Republic of China rotated #2 envelope (176 mm by 102 mm). Requires Windows 98, Windows NT 4.0, or later.
PRCEnvelopeNumber3 | People's Republic of China #3 envelope (125 mm by 176 mm). Requires Windows 98, Windows NT 4.0, or later.
PRCEnvelopeNumber3Rotated | People's Republic of China rotated #3 envelope (176 mm by 125 mm). Requires Windows 98, Windows NT 4.0, or later.
PRCEnvelopeNumber4 | People's Republic of China #4 envelope (110 mm by 208 mm). Requires Windows 98, Windows NT 4.0, or later.
PRCEnvelopeNumber4Rotated | People's Republic of China rotated #4 envelope (208 mm by 110 mm). Requires Windows 98, Windows NT 4.0, or later.
PRCEnvelopeNumber5 | People's Republic of China #5 envelope (110 mm by 220 mm). Requires Windows 98, Windows NT 4.0, or later.
PRCEnvelopeNumber5Rotated | People's Republic of China Envelope rotated #5 envelope (220 mm by 110 mm). Requires Windows 98, Windows NT 4.0, or later.
PRCEnvelopeNumber6 | People's Republic of China #6 envelope (120 mm by 230 mm). Requires Windows 98, Windows NT 4.0, or later.
PRCEnvelopeNumber6Rotated | People's Republic of China rotated #6 envelope (230 mm by 120 mm). Requires Windows 98, Windows NT 4.0, or later.
PRCEnvelopeNumber7 | People's Republic of China #7 envelope (160 mm by 230 mm). Requires Windows 98, Windows NT 4.0, or later.
PRCEnvelopeNumber7Rotated | People's Republic of China rotated #7 envelope (230 mm by 160 mm). Requires Windows 98, Windows NT 4.0, or later.
PRCEnvelopeNumber8 | People's Republic of China #8 envelope (120 mm by 309 mm). Requires Windows 98, Windows NT 4.0, or later.
PRCEnvelopeNumber8Rotated | People's Republic of China rotated #8 envelope (309 mm by 120 mm). Requires Windows 98, Windows NT 4.0, or later.
PRCEnvelopeNumber9 | People's Republic of China #9 envelope (229 mm by 324 mm). Requires Windows 98, Windows NT 4.0, or later.
PRCEnvelopeNumber9Rotated | People's Republic of China rotated #9 envelope (324 mm by 229 mm). Requires Windows 98, Windows NT 4.0, or later.
Quarto | Quarto paper (215 mm by 275 mm).
Standard10x11 | 10-by-11-inch paper.
Standard10x14 | 10-by-14-inch paper.
Standard11x17 | 11-by-17-inch paper.
Standard12x11 | 12-by-11-inch paper. Requires Windows 98, Windows NT 4.0, or later.
Standard15x11 | 15-by-11-inch paper.
Standard9x11 | 9-by-11-inch paper.
Statement | Statement paper (5.5 in. by 8.5 in.)
Tabloid | Tabloid paper (11 in. by 17 in.).
TabloidExtra | Tabloid Extra paper (11.69 in. by 18 in.). This value is specific to the PostScript driver and is used only by Linotronic printers in order to conserve paper.
USStandardFanfold | US Standard Fanfold (14.875 in. by 11 in.).

Requirements

Namespace: System.Drawing.Printing

Assembly: System.Drawing.dll

See Also

System.Drawing.Printing Namespace


PaperSize Class

The size of a piece of paper.

Object
PaperSize

[Visual Basic]
Public Class PaperSize
[C#]
public class PaperSize
[C++]
public __gc class PaperSize
[JScript]
public class PaperSize

Remarks

This class manipulates paper size properties.

PageSettings and PrinterSettings use this class.

Requirements

Namespace: System.Drawing.Printing

Assembly: System.Drawing.dll

See Also

PaperSize Members | System.Drawing.Printing Namespace | PaperKind | PageSettings | PrinterSettings


PaperSize Members

Public:

Constructor

PaperSize Constructor Initializes a new instance of the PaperSize class.

Properties

Height | Gets or sets the height of the paper, in hundredths of an inch.
Kind | Gets the type of paper.
PaperName | Gets or sets the name of the type of paper.
Width | Gets or sets the width of the paper, in hundredths of an inch.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PaperSize Class | System.Drawing.Printing Namespace


PaperSize Constructor

Initializes a new instance of the PaperSize class.

[Visual Basic]
Public Sub New( _
   ByVal name As String, _
   ByVal width As Integer, _
   ByVal height As Integer _
)
[C#]
public PaperSize(
   string name,
   int width,
   int height
);
[C++]
public: PaperSize(
   String* name,
   int width,
   int height
);
[JScript]
public function PaperSize(
   name : String,
   width : int,
   height : int
);

Parameters

name
The name of the paper.
width
The width of the paper, in hundredths of an inch.
height
The height of the paper, in hundredths of an inch.

See Also

PaperSize Class | PaperSize Members | System.Drawing.Printing Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PaperSize Properties

The properties of the PaperSize class are listed below. For a complete list of PaperSize class members, see the PaperSize Members topic.

Public:

Height | Gets or sets the height of the paper, in hundredths of an inch.
Kind | Gets the type of paper.
PaperName | Gets or sets the name of the type of paper.
Width | Gets or sets the width of the paper, in hundredths of an inch.

See Also

PaperSize Class | System.Drawing.Printing Namespace


PaperSize.Height

Gets or sets the height of the paper, in hundredths of an inch.

[Visual Basic]
Public Property Height As Integer
[C#]
public int Height {get; set;}
[C++]
public: __property int get_Height();
public: __property void set_Height(int);
[JScript]
public function get Height() : int;
public function set Height(int);

Property Value

The height of the paper, in hundredths of an inch.

Exceptions

Exception Type | Condition
ArgumentException | The paper size is not custom.

Remarks

This measurement is for the portrait orientation of the paper.

See Also

PaperSize Class | PaperSize Members | System.Drawing.Printing Namespace | Width


PaperSize.Kind

Gets the type of paper.

[Visual Basic]
Public ReadOnly Property Kind As PaperKind
[C#]
public PaperKind Kind {get;}
[C++]
public: __property PaperKind get_Kind();
[JScript]
public function get Kind() : PaperKind;

Property Value

One of the PaperKind values.

See Also

PaperSize Class | PaperSize Members | System.Drawing.Printing Namespace | PaperKind


PaperSize.PaperName

Gets or sets the name of the type of paper.

[Visual Basic]
Public Property PaperName As String
[C#]
public string PaperName {get; set;}
[C++]
public: __property String* get_PaperName();
public: __property void set_PaperName(String*);
[JScript]
public function get PaperName() : String;
public function set PaperName(String);

Property Value

The name of the type of paper.

Exceptions

Exception Type | Condition
ArgumentException | The paper size is not custom.

See Also

PaperSize Class | PaperSize Members | System.Drawing.Printing Namespace


PaperSize.Width

Gets or sets the width of the paper, in hundredths of an inch.

[Visual Basic]
Public Property Width As Integer
[C#]
public int Width {get; set;}
[C++]
public: __property int get_Width();
public: __property void set_Width(int);
[JScript]
public function get Width() : int;
public function set Width(int);

Property Value

The width of the paper, in hundredths of an inch.

Exceptions

Exception Type | Condition
ArgumentException | The paper size is not custom.

Remarks

This measurement is for the portrait orientation of the paper.

See Also

PaperSize Class | PaperSize Members | System.Drawing.Printing Namespace | Height


PaperSource Class

Specifies the paper tray from which the printer gets paper.

Object
PaperSource

[Visual Basic]
Public Class PaperSource
[C#]
public class PaperSource
[C++]
public __gc class PaperSource
[JScript]
public class PaperSource

Remarks

This class is used by PaperSources and by multiple methods of the PrinterSettings.PaperSourceCollection class.

Requirements

Namespace: System.Drawing.Printing

Assembly: System.Drawing.dll

See Also

PaperSource Members | System.Drawing.Printing Namespace | PrinterSettings | PaperSourceKind | PrinterSettings.PaperSourceCollection


PaperSource Members

Public:

Properties

Kind | Gets a value indicating the type of paper source.
SourceName | Gets the name of the paper source.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PaperSource Class | System.Drawing.Printing Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PaperSource Properties

The properties of the PaperSource class are listed below. For a complete list of PaperSource class members, see the PaperSource Members topic.

Public:

Kind | Gets a value indicating the type of paper source.
SourceName | Gets the name of the paper source.

See Also

PaperSource Class | System.Drawing.Printing Namespace


PaperSource.Kind

Gets a value indicating the type of paper source.

[Visual Basic]
Public ReadOnly Property Kind As PaperSourceKind
[C#]
public PaperSourceKind Kind {get;}
[C++]
public: __property PaperSourceKind get_Kind();
[JScript]
public function get Kind() : PaperSourceKind;

Property Value

One of the PaperSourceKind values.

See Also

PaperSource Class | PaperSource Members | System.Drawing.Printing Namespace | PaperSourceKind


PaperSource.SourceName

Gets the name of the paper source.

[Visual Basic]
Public ReadOnly Property SourceName As String
[C#]
public string SourceName {get;}
[C++]
public: __property String* get_SourceName();
[JScript]
public function get SourceName() : String;

Property Value

The name of the paper source.

See Also

PaperSource Class | PaperSource Members | System.Drawing.Printing Namespace


PaperSourceKind Enumeration

Standard paper sources.

[Visual Basic]
Public Enum PaperSourceKind
[C#]
public enum PaperSourceKind
[C++]
public enum PaperSourceKind

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

This enumeration is used by Kind.

Members

Member Name | Description
AutomaticFeed | Automatic-fed paper.
Cassette | A paper cassette.
Custom | A printer-specific paper source.
Envelope | An envelope.
FormSource | [To be supplied.]
LargeCapacity | A large-capacity bin a printer.
LargeFormat | Large-format paper.
Lower | The lower bin of a printer.
Manual | Manually-fed paper.
ManualFeed | A manually-fed envelope.
Middle | The middle bin of a printer.
SmallFormat | Small-format paper.
TractorFeed | A tractor feed.
Upper | The upper bin of a printer (or, if the printer only has one bin, the only bin).

Requirements

Namespace: System.Drawing.Printing

Assembly: System.Drawing.dll

See Also

System.Drawing.Printing Namespace | PaperSource


PreviewPageInfo Class

Specifies print preview information for a single page. This class cannot be inherited.

Object
PreviewPageInfo

[Visual Basic]
NotInheritable Public Class PreviewPageInfo
[C#]
public sealed class PreviewPageInfo
[C++]
public __gc __sealed class PreviewPageInfo
[JScript]
public class PreviewPageInfo

Remarks

This class is used extensively by PreviewPrintController.

Requirements

Namespace: System.Drawing.Printing

Assembly: System.Drawing.dll

See Also

PreviewPageInfo Members | System.Drawing.Printing Namespace


PreviewPageInfo Members

Public:

Constructor

PreviewPageInfo Constructor Initializes a new instance of the PreviewPageInfo class.

Properties

Image | Gets an image of the printed page.
PhysicalSize | Gets a value indicating the size of the printed page, in hundredths of an inch.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PreviewPageInfo Class | System.Drawing.Printing Namespace


PreviewPageInfo Constructor

Initializes a new instance of the PreviewPageInfo class.

[Visual Basic]
Public Sub New( _
   ByVal image As Image, _
   ByVal physicalSize As Size _
)
[C#]
public PreviewPageInfo(
   Image image,
   Size physicalSize
);
[C++]
public: PreviewPageInfo(
   Image* image,
   Size physicalSize
);
[JScript]
public function PreviewPageInfo(
   image : Image,
   physicalSize : Size
);

Parameters

image
The image of the printed page.
physicalSize
The size of the printed page in hundredths of an inch.

See Also

PreviewPageInfo Class | PreviewPageInfo Members | System.Drawing.Printing Namespace | Image | Point | Size


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PreviewPageInfo Properties

The properties of the PreviewPageInfo class are listed below. For a complete list of PreviewPageInfo class members, see the PreviewPageInfo Members topic.

Public:

Image | Gets an image of the printed page.
PhysicalSize | Gets a value indicating the size of the printed page, in hundredths of an inch.

See Also

PreviewPageInfo Class | System.Drawing.Printing Namespace


PreviewPageInfo.Image

Gets an image of the printed page.

[Visual Basic]
Public ReadOnly Property Image As Image
[C#]
public Image Image {get;}
[C++]
public: __property Image* get_Image();
[JScript]
public function get Image() : Image;

Property Value

An image of the printed page.

See Also

PreviewPageInfo Class | PreviewPageInfo Members | System.Drawing.Printing Namespace | Image


PreviewPageInfo.PhysicalSize

Gets a value indicating the size of the printed page, in hundredths of an inch.

[Visual Basic]
Public ReadOnly Property PhysicalSize As Size
[C#]
public Size PhysicalSize {get;}
[C++]
public: __property Size get_PhysicalSize();
[JScript]
public function get PhysicalSize() : Size;

Property Value

The size of the printed page, in hundredths of an inch.

See Also

PreviewPageInfo Class | PreviewPageInfo Members | System.Drawing.Printing Namespace | Size


PreviewPrintController Class

A PrintController which "prints" to a series of images.

Object
PrintController
PreviewPrintController

[Visual Basic]
Public Class PreviewPrintController
   Inherits PrintController
[C#]
public class PreviewPrintController : PrintController
[C++]
public __gc class PreviewPrintController : public PrintController
[JScript]
public class PreviewPrintController extends PrintController

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Printing

Assembly: System.Drawing.dll

See Also

PreviewPrintController Members | System.Drawing.Printing Namespace


PreviewPrintController Members

Public:

Constructor

PreviewPrintController Constructor [To be supplied.]

Methods

EndPage (inherited from PrintController) | Called immediately after the PrintDocument's PrintPage event is raised. If an exception is thrown inside the PrintDocument's PrintPage event, this method will not be called.
EndPrint (inherited from PrintController) | Called immediately after the PrintDocument's EndPrint event is raised. This method will be called even if an uncaught exception was thrown while printing.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPreviewPageInfo | The "printout".
GetType (inherited from Object) | Gets the Type of the Object.
StartPage (inherited from PrintController) | Called immediately before the PrintDocument's PrintPage event is raised.
StartPrint (inherited from PrintController) | Called immediately after the PrintDocument's OnBeginPrint event is raised. Consider checking whether the PrinterSettings are valid.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PreviewPrintController Class | System.Drawing.Printing Namespace


PreviewPrintController Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public PreviewPrintController();
[C++]
public: PreviewPrintController();
[JScript]
public function PreviewPrintController();

See Also

PreviewPrintController Class | PreviewPrintController Members | System.Drawing.Printing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PreviewPrintController Methods

The methods of the PreviewPrintController class are listed below. For a complete list of PreviewPrintController class members, see the PreviewPrintController Members topic.

Public:

EndPage (inherited from PrintController) | Called immediately after the PrintDocument's PrintPage event is raised. If an exception is thrown inside the PrintDocument's PrintPage event, this method will not be called.
EndPrint (inherited from PrintController) | Called immediately after the PrintDocument's EndPrint event is raised. This method will be called even if an uncaught exception was thrown while printing.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPreviewPageInfo | The "printout".
GetType (inherited from Object) | Gets the Type of the Object.
StartPage (inherited from PrintController) | Called immediately before the PrintDocument's PrintPage event is raised.
StartPrint (inherited from PrintController) | Called immediately after the PrintDocument's OnBeginPrint event is raised. Consider checking whether the PrinterSettings are valid.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PreviewPrintController Class | System.Drawing.Printing Namespace


PreviewPrintController.GetPreviewPageInfo

The "printout".

[Visual Basic]
Public Function GetPreviewPageInfo() As PreviewPageInfo ()
[C#]
public PreviewPageInfo[] GetPreviewPageInfo();
[C++]
public: PreviewPageInfo* GetPreviewPageInfo() [];
[JScript]
public function GetPreviewPageInfo() : PreviewPageInfo[];

See Also

PreviewPrintController Class | PreviewPrintController Members | System.Drawing.Printing Namespace | PreviewPageInfo


PrintController Class

A PrintController controls how a PrintDocument is printed-- how a bunch of PrintPageEventArgs's are turned into actual printer output. PrintDocument.Print invokes PrintController.StartPrint, EndPrint, StartPage, and EndPage, which in turn tell the printer what to print. Print preview uses a specialized PrintController; most users will never need to touch a PrintController.

Object
PrintController

[Visual Basic]
MustInherit Public Class PrintController
[C#]
public abstract class PrintController
[C++]
public __gc __abstract class PrintController
[JScript]
public abstract class PrintController

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Printing

Assembly: System.Drawing.dll

See Also

PrintController Members | System.Drawing.Printing Namespace


PrintController Members

Public:

Constructor

PrintController Constructor Initializes a new instance of the PrintController class.

Methods

EndPage | Called immediately after the PrintDocument's PrintPage event is raised. If an exception is thrown inside the PrintDocument's PrintPage event, this method will not be called.
EndPrint | Called immediately after the PrintDocument's EndPrint event is raised. This method will be called even if an uncaught exception was thrown while printing.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
StartPage | Called immediately before the PrintDocument's PrintPage event is raised.
StartPrint | Called immediately after the PrintDocument's OnBeginPrint event is raised. Consider checking whether the PrinterSettings are valid.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PrintController Class | System.Drawing.Printing Namespace


PrintController Constructor

Initializes a new instance of the PrintController class.

[Visual Basic]
Public Sub New()
[C#]
public PrintController();
[C++]
public: PrintController();
[JScript]
public function PrintController();

See Also

PrintController Class | PrintController Members | System.Drawing.Printing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PrintController Methods

The methods of the PrintController class are listed below. For a complete list of PrintController class members, see the PrintController Members topic.

Public:

EndPage | Called immediately after the PrintDocument's PrintPage event is raised. If an exception is thrown inside the PrintDocument's PrintPage event, this method will not be called.
EndPrint | Called immediately after the PrintDocument's EndPrint event is raised. This method will be called even if an uncaught exception was thrown while printing.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
StartPage | Called immediately before the PrintDocument's PrintPage event is raised.
StartPrint | Called immediately after the PrintDocument's OnBeginPrint event is raised. Consider checking whether the PrinterSettings are valid.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PrintController Class | System.Drawing.Printing Namespace


PrintController.EndPage

Called immediately after the PrintDocument's PrintPage event is raised. If an exception is thrown inside the PrintDocument's PrintPage event, this method will not be called.

[Visual Basic]
MustOverride Public Sub EndPage( _
   ByVal document As PrintDocument, _
   ByVal e As PrintPageEventArgs _
)
[C#]
public abstract void EndPage(
   PrintDocument document,
   PrintPageEventArgs e
);
[C++]
public: virtual void EndPage(
   PrintDocument* document,
   PrintPageEventArgs* e
) = 0;
[JScript]
public abstract function EndPage(
   document : PrintDocument,
   e : PrintPageEventArgs
);

Parameters

document
The document being printed.
e
A PrintPageEventArgs that contains the event data.

See Also

PrintController Class | PrintController Members | System.Drawing.Printing Namespace


PrintController.EndPrint

Called immediately after the PrintDocument's EndPrint event is raised. This method will be called even if an uncaught exception was thrown while printing.

[Visual Basic]
MustOverride Public Sub EndPrint( _
   ByVal document As PrintDocument, _
   ByVal e As PrintEventArgs _
)
[C#]
public abstract void EndPrint(
   PrintDocument document,
   PrintEventArgs e
);
[C++]
public: virtual void EndPrint(
   PrintDocument* document,
   PrintEventArgs* e
) = 0;
[JScript]
public abstract function EndPrint(
   document : PrintDocument,
   e : PrintEventArgs
);

Parameters

document
The document being printed.
e
A PrintEventArgs that contains the event data.

See Also

PrintController Class | PrintController Members | System.Drawing.Printing Namespace


PrintController.StartPage

Called immediately before the PrintDocument's PrintPage event is raised.

[Visual Basic]
MustOverride Public Function StartPage( _
   ByVal document As PrintDocument, _
   ByVal e As PrintPageEventArgs _
) As Graphics
[C#]
public abstract Graphics StartPage(
   PrintDocument document,
   PrintPageEventArgs e
);
[C++]
public: virtual Graphics* StartPage(
   PrintDocument* document,
   PrintPageEventArgs* e
) = 0;
[JScript]
public abstract function StartPage(
   document : PrintDocument,
   e : PrintPageEventArgs
) : Graphics;

Parameters

document
The document being printed.
e
A PrintPageEventArgs that contains the event data. . e.Graphics will be null; StartPage's return value will be used to fill in that property.

See Also

PrintController Class | PrintController Members | System.Drawing.Printing Namespace


PrintController.StartPrint

Called immediately after the PrintDocument's OnBeginPrint event is raised. Consider checking whether the PrinterSettings are valid.

[Visual Basic]
MustOverride Public Sub StartPrint( _
   ByVal document As PrintDocument, _
   ByVal e As PrintEventArgs _
)
[C#]
public abstract void StartPrint(
   PrintDocument document,
   PrintEventArgs e
);
[C++]
public: virtual void StartPrint(
   PrintDocument* document,
   PrintEventArgs* e
) = 0;
[JScript]
public abstract function StartPrint(
   document : PrintDocument,
   e : PrintEventArgs
);

Parameters

document
The document being printed.
e
A PrintEventArgs that contains the event data.

See Also

PrintController Class | PrintController Members | System.Drawing.Printing Namespace


PrintDocument Class

Defines a reusable object that sends output to the printer.

Object
Component
PrintDocument

[Visual Basic]
Public Class PrintDocument
   Inherits Component
[C#]
public class PrintDocument : Component
[C++]
public __gc class PrintDocument : public Component
[JScript]
public class PrintDocument extends Component

Remarks

Typically, you will instantiate a template, set some properties describing what to print, then call the Print method. A PrintPage event will be raised for each page; in order to print anything interesting, you must handle this event.

Requirements

Namespace: System.Drawing.Printing

Assembly: System.Drawing.dll

See Also

PrintDocument Members | System.Drawing.Printing Namespace | PageSettings | PrintController | PrinterSettings


PrintDocument Members

Public:

Constructor

PrintDocument Constructor Initializes a new instance of the PrintDocument class.

Properties

DefaultPageSettings | Gets the default page settings for the document being printed.
DocumentName | Gets the name to display to the user while printing the document (i.e., in a print status dialog or a printer queue).
PrintController | Gets or sets the print controller that guides the printing process.
PrinterSettings | Gets or sets a value indicating the printer on which the document is printed.
Site (inherited from Component) | Gets or sets the site of the Component.

Methods

Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Print | Prints the document.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Events

BeginPrint | Occurs when Print is called, before the first page is printed.
EndPrint | Occurs when Print is called, after the last page is printed.
PrintPage | [To be supplied.]
QueryPageSettings | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnBeginPrint | Raises the System.Drawing.Printing.PrintDocument.BeginPrint event.
OnEndPrint | Raises the System.Drawing.Printing.PrintDocument.EndPrint event.
OnPrintPage | Raises the System.Drawing.Printing.PrintDocument.PrintPage event.
OnQueryPageSettings | Raises the System.Drawing.Printing.PrintDocument.QueryPageSettings event.

Event Hookup:

Methods

AddOnBeginPrint | Adds an event handler for the OnBeginPrint event.
AddOnEndPrint | Adds an event handler for the OnEndPrint event.
AddOnPrintPage | Adds an event handler for the PrintPage event. The PrintPage event occurs when it's time to print a page.
AddOnQueryPageSettings | Adds an event handler for the OnQueryPageSettings event. The OnQueryPageSettings event occurs immediately before each page is printed; if you wish to change page settings in the middle of a print job, do it here.
RemoveOnBeginPrint | Removes an event handler that has been associated with the OnBeginPrint event.
RemoveOnEndPrint | Removes the given handler for the "OnEndPrint" event. If there are duplicate entries, ALL are removed.
RemoveOnPrintPage | Removes the given handler for the "OnPrintPage" event. If there are duplicate entries, ALL are removed.
RemoveOnQueryPageSettings | Removes the given handler for the "OnQueryPageSettings" event. If there are duplicate entries, ALL are removed.

See Also

PrintDocument Class | System.Drawing.Printing Namespace


PrintDocument Constructor

Initializes a new instance of the PrintDocument class.

[Visual Basic]
Public Sub New()
[C#]
public PrintDocument();
[C++]
public: PrintDocument();
[JScript]
public function PrintDocument();

Remarks

This constructor is typically not called directly, but rather from a the constructor of a descendant class.

Property | Default Value
DocumentName | document
PrintController |

See Also

PrintDocument Class | PrintDocument Members | System.Drawing.Printing Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PrintDocument Properties

The properties of the PrintDocument class are listed below. For a complete list of PrintDocument class members, see the PrintDocument Members topic.

Public:

DefaultPageSettings | Gets the default page settings for the document being printed.
DocumentName | Gets the name to display to the user while printing the document (i.e., in a print status dialog or a printer queue).
PrintController | Gets or sets the print controller that guides the printing process.
PrinterSettings | Gets or sets a value indicating the printer on which the document is printed.
Site (inherited from Component) | Gets or sets the site of the Component.

See Also

PrintDocument Class | System.Drawing.Printing Namespace


PrintDocument.DefaultPageSettings

Gets the default page settings for the document being printed.

[Visual Basic]
Public Property DefaultPageSettings As PageSettings
[C#]
public PageSettings DefaultPageSettings {get; set;}
[C++]
public: __property PageSettings* get_DefaultPageSettings();
public: __property void set_DefaultPageSettings(PageSettings*);
[JScript]
public function get DefaultPageSettings() : PageSettings;
public function set DefaultPageSettings(PageSettings);

Property Value

The default page settings for the document being printed, or a null reference (in Visual Basic Nothing) if this printer is not currently printing.

See Also

PrintDocument Class | PrintDocument Members | System.Drawing.Printing Namespace | PageSettings | DocumentName | PrintController | PrinterSettings


PrintDocument.DocumentName

Gets the name to display to the user while printing the document (i.e., in a print status dialog or a printer queue).

[Visual Basic]
Public Property DocumentName As String
[C#]
public string DocumentName {get; set;}
[C++]
public: __property String* get_DocumentName();
public: __property void set_DocumentName(String*);
[JScript]
public function get DocumentName() : String;
public function set DocumentName(String);

Property Value

The name to display to the user while printing the document (i.e., in a print status dialog or a printer queue).

See Also

PrintDocument Class | PrintDocument Members | System.Drawing.Printing Namespace | DefaultPageSettings | PrintController | PrinterSettings


PrintDocument.PrintController

Gets or sets the print controller that guides the printing process.

[Visual Basic]
Public Property PrintController As PrintController
[C#]
public PrintController PrintController {get; set;}
[C++]
public: __property PrintController* get_PrintController();
public: __property void set_PrintController(PrintController*);
[JScript]
public function get PrintController() : PrintController;
public function set PrintController(PrintController);

Property Value

The print controller that guides the printing process.

See Also

PrintDocument Class | PrintDocument Members | System.Drawing.Printing Namespace | PrintController | DefaultPageSettings | DocumentName | PrinterSettings


PrintDocument.PrinterSettings

Gets or sets a value indicating the printer on which the document is printed.

[Visual Basic]
Public Property PrinterSettings As PrinterSettings
[C#]
public PrinterSettings PrinterSettings {get; set;}
[C++]
public: __property PrinterSettings* get_PrinterSettings();
public: __property void set_PrinterSettings(PrinterSettings*);
[JScript]
public function get PrinterSettings() : PrinterSettings;
public function set PrinterSettings(PrinterSettings);

Property Value

The printer on which the document is printed, or a null reference (in Visual Basic Nothing) if not currently printing.

See Also

PrintDocument Class | PrintDocument Members | System.Drawing.Printing Namespace | PrinterSettings | DefaultPageSettings | DocumentName | PrintController


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PrintDocument Methods

The methods of the PrintDocument class are listed below. For a complete list of PrintDocument class members, see the PrintDocument Members topic.

Public:

Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Print | Prints the document.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnBeginPrint | Raises the System.Drawing.Printing.PrintDocument.BeginPrint event.
OnEndPrint | Raises the System.Drawing.Printing.PrintDocument.EndPrint event.
OnPrintPage | Raises the System.Drawing.Printing.PrintDocument.PrintPage event.
OnQueryPageSettings | Raises the System.Drawing.Printing.PrintDocument.QueryPageSettings event.

Event Hookup:

AddOnBeginPrint | Adds an event handler for the OnBeginPrint event.
AddOnEndPrint | Adds an event handler for the OnEndPrint event.
AddOnPrintPage | Adds an event handler for the PrintPage event. The PrintPage event occurs when it's time to print a page.
AddOnQueryPageSettings | Adds an event handler for the OnQueryPageSettings event. The OnQueryPageSettings event occurs immediately before each page is printed; if you wish to change page settings in the middle of a print job, do it here.
RemoveOnBeginPrint | Removes an event handler that has been associated with the OnBeginPrint event.
RemoveOnEndPrint | Removes the given handler for the "OnEndPrint" event. If there are duplicate entries, ALL are removed.
RemoveOnPrintPage | Removes the given handler for the "OnPrintPage" event. If there are duplicate entries, ALL are removed.
RemoveOnQueryPageSettings | Removes the given handler for the "OnQueryPageSettings" event. If there are duplicate entries, ALL are removed.

See Also

PrintDocument Class | System.Drawing.Printing Namespace


PrintDocument.AddOnBeginPrint

Adds an event handler for the OnBeginPrint event.

[Visual Basic]
Public Sub AddOnBeginPrint( _
   ByVal handler As PrintEventHandler _
)
[C#]
public void AddOnBeginPrint(
   PrintEventHandler handler
);
[C++]
public: void AddOnBeginPrint(
   PrintEventHandler* handler
);
[JScript]
public function AddOnBeginPrint(
   handler : PrintEventHandler
);

Parameters

handler
A PrintEventHandler delegate that represents the method that will handle the OnBeginPrint event.

See Also

PrintDocument Class | PrintDocument Members | System.Drawing.Printing Namespace


PrintDocument.AddOnEndPrint

Adds an event handler for the OnEndPrint event.

[Visual Basic]
Public Sub AddOnEndPrint( _
   ByVal handler As PrintEventHandler _
)
[C#]
public void AddOnEndPrint(
   PrintEventHandler handler
);
[C++]
public: void AddOnEndPrint(
   PrintEventHandler* handler
);
[JScript]
public function AddOnEndPrint(
   handler : PrintEventHandler
);

Parameters

handler
[To be supplied.]

See Also

PrintDocument Class | PrintDocument Members | System.Drawing.Printing Namespace


PrintDocument.AddOnPrintPage

Adds an event handler for the PrintPage event. The PrintPage event occurs when it's time to print a page.

[Visual Basic]
Public Sub AddOnPrintPage( _
   ByVal handler As PrintPageEventHandler _
)
[C#]
public void AddOnPrintPage(
   PrintPageEventHandler handler
);
[C++]
public: void AddOnPrintPage(
   PrintPageEventHandler* handler
);
[JScript]
public function AddOnPrintPage(
   handler : PrintPageEventHandler
);

Parameters

handler
New handler to install for this event.

See Also

PrintDocument Class | PrintDocument Members | System.Drawing.Printing Namespace


PrintDocument.AddOnQueryPageSettings

Adds an event handler for the OnQueryPageSettings event. The OnQueryPageSettings event occurs immediately before each page is printed; if you wish to change page settings in the middle of a print job, do it here.

[Visual Basic]
Public Sub AddOnQueryPageSettings( _
   ByVal handler As PrintEventHandler _
)
[C#]
public void AddOnQueryPageSettings(
   PrintEventHandler handler
);
[C++]
public: void AddOnQueryPageSettings(
   PrintEventHandler* handler
);
[JScript]
public function AddOnQueryPageSettings(
   handler : PrintEventHandler
);

Parameters

handler
New handler to install for this event.

See Also

PrintDocument Class | PrintDocument Members | System.Drawing.Printing Namespace


PrintDocument.OnBeginPrint

Raises the System.Drawing.Printing.PrintDocument.BeginPrint event.

[Visual Basic]
Overridable Protected Sub OnBeginPrint( _
   ByVal e As PrintEventArgs _
)
[C#]
protected virtual void OnBeginPrint(
   PrintEventArgs e
);
[C++]
protected: virtual void OnBeginPrint(
   PrintEventArgs* e
);
[JScript]
protected function OnBeginPrint(
   e : PrintEventArgs
);

Parameters

e
A PrintEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview see <TBD>.

Notes to Inheritors: When overriding OnBeginPrint in a derived class, be sure to call the base class's OnBeginPrint method.

See Also

PrintDocument Class | PrintDocument Members | System.Drawing.Printing Namespace


PrintDocument.OnEndPrint

Raises the System.Drawing.Printing.PrintDocument.EndPrint event.

[Visual Basic]
Overridable Protected Sub OnEndPrint( _
   ByVal e As PrintEventArgs _
)
[C#]
protected virtual void OnEndPrint(
   PrintEventArgs e
);
[C++]
protected: virtual void OnEndPrint(
   PrintEventArgs* e
);
[JScript]
protected function OnEndPrint(
   e : PrintEventArgs
);

Parameters

e
A PrintEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview see TBD.

Notes to Inheritors: When overriding OnEndPrint in a derived class, be sure to call the base class's OnEndPrint method.

See Also

PrintDocument Class | PrintDocument Members | System.Drawing.Printing Namespace


PrintDocument.OnPrintPage

Raises the System.Drawing.Printing.PrintDocument.PrintPage event.

[Visual Basic]
Overridable Protected Sub OnPrintPage( _
   ByVal e As PrintPageEventArgs _
)
[C#]
protected virtual void OnPrintPage(
   PrintPageEventArgs e
);
[C++]
protected: virtual void OnPrintPage(
   PrintPageEventArgs* e
);
[JScript]
protected function OnPrintPage(
   e : PrintPageEventArgs
);

Parameters

e
A PrintPageEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview see TBD.

Notes to Inheritors: When overriding OnPrintPage in a derived class, be sure to call the base class's OnPrintPage method.

See Also

PrintDocument Class | PrintDocument Members | System.Drawing.Printing Namespace


PrintDocument.OnQueryPageSettings

Raises the System.Drawing.Printing.PrintDocument.QueryPageSettings event.

[Visual Basic]
Overridable Protected Sub OnQueryPageSettings( _
   ByVal e As PrintEventArgs _
)
[C#]
protected virtual void OnQueryPageSettings(
   PrintEventArgs e
);
[C++]
protected: virtual void OnQueryPageSettings(
   PrintEventArgs* e
);
[JScript]
protected function OnQueryPageSettings(
   e : PrintEventArgs
);

Parameters

e
A PrintEventArgs that contains the event data.

Remarks

Raising an event invokes the event-handling method through a delegate. For an overview see TBD.

Notes to Inheritors: When overriding OnQueryPageSettings in a derived class, be sure to call the base class's OnQueryPageSettings method.

See Also

PrintDocument Class | PrintDocument Members | System.Drawing.Printing Namespace


PrintDocument.Print

Prints the document.

[Visual Basic]
Public Sub Print()
[C#]
public void Print();
[C++]
public: void Print();
[JScript]
public function Print();

Remarks

Note If an unhandled exception is thrown during printing, the print document will be aborted.

See Also

PrintDocument Class | PrintDocument Members | System.Drawing.Printing Namespace


PrintDocument.RemoveOnBeginPrint

Removes an event handler that has been associated with the OnBeginPrint event.

[Visual Basic]
Public Sub RemoveOnBeginPrint( _
   ByVal handler As PrintEventHandler _
)
[C#]
public void RemoveOnBeginPrint(
   PrintEventHandler handler
);
[C++]
public: void RemoveOnBeginPrint(
   PrintEventHandler* handler
);
[JScript]
public function RemoveOnBeginPrint(
   handler : PrintEventHandler
);

Parameters

handler
The PrintEventHandler delegate to remove.

Remarks

If there are duplicate entries, all are removed.

See Also

PrintDocument Class | PrintDocument Members | System.Drawing.Printing Namespace | AddOnBeginPrint


PrintDocument.RemoveOnEndPrint

Removes the given handler for the "OnEndPrint" event. If there are duplicate entries, ALL are removed.

[Visual Basic]
Public Sub RemoveOnEndPrint( _
   ByVal handler As PrintEventHandler _
)
[C#]
public void RemoveOnEndPrint(
   PrintEventHandler handler
);
[C++]
public: void RemoveOnEndPrint(
   PrintEventHandler* handler
);
[JScript]
public function RemoveOnEndPrint(
   handler : PrintEventHandler
);

Parameters

handler
The PrintEventHandler delegate to remove.

See Also

PrintDocument Class | PrintDocument Members | System.Drawing.Printing Namespace | AddOnEndPrint


PrintDocument.RemoveOnPrintPage

Removes the given handler for the "OnPrintPage" event. If there are duplicate entries, ALL are removed.

[Visual Basic]
Public Sub RemoveOnPrintPage( _
   ByVal handler As PrintPageEventHandler _
)
[C#]
public void RemoveOnPrintPage(
   PrintPageEventHandler handler
);
[C++]
public: void RemoveOnPrintPage(
   PrintPageEventHandler* handler
);
[JScript]
public function RemoveOnPrintPage(
   handler : PrintPageEventHandler
);

Parameters

handler
The PrintEventHandler delegate to remove.

See Also

PrintDocument Class | PrintDocument Members | System.Drawing.Printing Namespace | AddOnPrintPage


PrintDocument.RemoveOnQueryPageSettings

Removes the given handler for the "OnQueryPageSettings" event. If there are duplicate entries, ALL are removed.

[Visual Basic]
Public Sub RemoveOnQueryPageSettings( _
   ByVal handler As PrintEventHandler _
)
[C#]
public void RemoveOnQueryPageSettings(
   PrintEventHandler handler
);
[C++]
public: void RemoveOnQueryPageSettings(
   PrintEventHandler* handler
);
[JScript]
public function RemoveOnQueryPageSettings(
   handler : PrintEventHandler
);

Parameters

handler
The PrintEventHandler delegate to remove.

See Also

PrintDocument Class | PrintDocument Members | System.Drawing.Printing Namespace | AddOnQueryPageSettings


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PrintDocument Events

The events of the PrintDocument class are listed below. For a complete list of PrintDocument class members, see the PrintDocument Members topic.

Public:

BeginPrint | Occurs when Print is called, before the first page is printed.
EndPrint | Occurs when Print is called, after the last page is printed.
PrintPage | [To be supplied.]
QueryPageSettings | [To be supplied.]

See Also

PrintDocument Class | System.Drawing.Printing Namespace


PrintDocument BeginPrint Event

Occurs when Print is called, before the first page is printed.

The following declaration shows the syntax for a method that handles the BeginPrint event.

[Visual Basic]
Private Sub PrintDocumentName_BeginPrint( _
   ByVal sender As Object, _
   ByVal e As PrintEventArgs _
)
[C#]
private void PrintDocumentName_BeginPrint(
   object sender,
   PrintEventArgs e
);
[C++]
private: void PrintDocumentName_BeginPrint(
   Object* sender,
   PrintEventArgs* e
);
[JScript]
private PrintDocumentName_BeginPrint(
   sender : Object,
   e : PrintEventArgs
);

Parameters

sender
The source of the event.
e
A PrintEventArgs that contains the event data.

See Also

PrintDocument Class | PrintDocument MembersTopic | System.Drawing.Printing Namespace | PrintDocument.OnBeginPrint | PrintDocument.OnEndPrint | PrintDocument.EndPrint | PrintDocument.OnPrintPage | PrintDocument.PrintPage | PrintDocument.OnQueryPageSettings | PrintDocument.QueryPageSettings


PrintDocument EndPrint Event

Occurs when Print is called, after the last page is printed.

The following declaration shows the syntax for a method that handles the EndPrint event.

[Visual Basic]
Private Sub PrintDocumentName_EndPrint( _
   ByVal sender As Object, _
   ByVal e As PrintEventArgs _
)
[C#]
private void PrintDocumentName_EndPrint(
   object sender,
   PrintEventArgs e
);
[C++]
private: void PrintDocumentName_EndPrint(
   Object* sender,
   PrintEventArgs* e
);
[JScript]
private PrintDocumentName_EndPrint(
   sender : Object,
   e : PrintEventArgs
);

Parameters

sender
The source of the event.
e
A PrintEventArgs that contains the event data.

See Also

PrintDocument Class | PrintDocument MembersTopic | System.Drawing.Printing Namespace | PrintDocument.OnBeginPrint | PrintDocument.BeginPrint | PrintDocument.OnEndPrint | PrintDocument.OnPrintPage | PrintDocument.PrintPage | PrintDocument.OnQueryPageSettings | PrintDocument.QueryPageSettings


PrintDocument PrintPage Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the PrintPage event.

[Visual Basic]
Private Sub PrintDocumentName_PrintPage( _
   ByVal sender As Object, _
   ByVal e As PrintPageEventArgs _
)
[C#]
private void PrintDocumentName_PrintPage(
   object sender,
   PrintPageEventArgs e
);
[C++]
private: void PrintDocumentName_PrintPage(
   Object* sender,
   PrintPageEventArgs* e
);
[JScript]
private PrintDocumentName_PrintPage(
   sender : Object,
   e : PrintPageEventArgs
);

Parameters

sender
The source of the event.
e
A PrintPageEventArgs that contains the event data. The following PrintPageEventArgs properties provide information specific to this event.
Property Description
Cancel
Gets or sets a value indicating whether the print job should be canceled.
Graphics
Gets the Graphics used to paint the item.
HasMorePages
Gets or sets a value indicating whether there is an additional page to be printed.
MarginBounds
Gets the rectangular area that represents the page between the margins.
PageBounds
Gets the rectangular area that represents the total area of the page.
PageSettings
Specifieds the page settings for the current page.

See Also

PrintDocument Class | PrintDocument MembersTopic | System.Drawing.Printing Namespace | PrintDocument.OnBeginPrint | PrintDocument.BeginPrint | PrintDocument.OnEndPrint | PrintDocument.EndPrint | PrintDocument.OnPrintPage | PrintDocument.OnQueryPageSettings | PrintDocument.QueryPageSettings


PrintDocument QueryPageSettings Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the QueryPageSettings event.

[Visual Basic]
Private Sub PrintDocumentName_QueryPageSettings( _
   ByVal sender As Object, _
   ByVal e As PrintEventArgs _
)
[C#]
private void PrintDocumentName_QueryPageSettings(
   object sender,
   PrintEventArgs e
);
[C++]
private: void PrintDocumentName_QueryPageSettings(
   Object* sender,
   PrintEventArgs* e
);
[JScript]
private PrintDocumentName_QueryPageSettings(
   sender : Object,
   e : PrintEventArgs
);

Parameters

sender
The source of the event.
e
A PrintEventArgs that contains the event data.

See Also

PrintDocument Class | PrintDocument MembersTopic | System.Drawing.Printing Namespace | PrintDocument.OnBeginPrint | PrintDocument.BeginPrint | PrintDocument.OnEndPrint | PrintDocument.EndPrint | PrintDocument.OnPrintPage | PrintDocument.PrintPage | PrintDocument.OnQueryPageSettings


PrinterResolution Class

Retrieves the custom resolution supported by a printer.

Object
PrinterResolution

[Visual Basic]
Public Class PrinterResolution
[C#]
public class PrinterResolution
[C++]
public __gc class PrinterResolution
[JScript]
public class PrinterResolution

Remarks

Use Kind to determine if the printer resolution type is Custom. If so, use X and Y to determine the printer resolution in the x- and y-directions.

Requirements

Namespace: System.Drawing.Printing

Assembly: System.Drawing.dll

See Also

PrinterResolution Members | System.Drawing.Printing Namespace | PrinterResolutionKind


PrinterResolution Members

Public:

Properties

Kind | Gets a value indicating the kind of printer resolution.
X | Gets a the printer resolution in the x dimension, in dots per inch.
Y | Gets a the printer resolution in the y dimension, in dots per inch.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PrinterResolution Class | System.Drawing.Printing Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PrinterResolution Properties

The properties of the PrinterResolution class are listed below. For a complete list of PrinterResolution class members, see the PrinterResolution Members topic.

Public:

Kind | Gets a value indicating the kind of printer resolution.
X | Gets a the printer resolution in the x dimension, in dots per inch.
Y | Gets a the printer resolution in the y dimension, in dots per inch.

See Also

PrinterResolution Class | System.Drawing.Printing Namespace


PrinterResolution.Kind

Gets a value indicating the kind of printer resolution.

[Visual Basic]
Public ReadOnly Property Kind As PrinterResolutionKind
[C#]
public PrinterResolutionKind Kind {get;}
[C++]
public: __property PrinterResolutionKind get_Kind();
[JScript]
public function get Kind() : PrinterResolutionKind;

Property Value

One of the PrinterResolutionKind values.

See Also

PrinterResolution Class | PrinterResolution Members | System.Drawing.Printing Namespace | PrinterResolutionKind


PrinterResolution.X

Gets a the printer resolution in the x dimension, in dots per inch.

[Visual Basic]
Public ReadOnly Property X As Integer
[C#]
public int X {get;}
[C++]
public: __property int get_X();
[JScript]
public function get X() : int;

Property Value

The printer resolution in the x dimension, in dots per inch.

Remarks

If Kind is not set to Custom, X will be set to-1.

See Also

PrinterResolution Class | PrinterResolution Members | System.Drawing.Printing Namespace


PrinterResolution.Y

Gets a the printer resolution in the y dimension, in dots per inch.

[Visual Basic]
Public ReadOnly Property Y As Integer
[C#]
public int Y {get;}
[C++]
public: __property int get_Y();
[JScript]
public function get Y() : int;

Property Value

The printer resolution in the y dimension, in dots per inch.

Remarks

If Kind is not set to Custom, Y will be set to-1.

See Also

PrinterResolution Class | PrinterResolution Members | System.Drawing.Printing Namespace


PrinterResolutionKind Enumeration

Specifies a printer resolution.

[Visual Basic]
Public Enum PrinterResolutionKind
[C#]
public enum PrinterResolutionKind
[C++]
public enum PrinterResolutionKind

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

All printers support high, medium, low, and draft resolutions, although they may generate the same output.

This enumeration is used by PrinterResolution, PrinterSettings, and PageSettings.

Members

Member Name | Description
Custom | Custom resolution.
Draft | Draft-quality resolution.
High | High resolution.
Low | Low resolution.
Medium | Medium resolution.

Requirements

Namespace: System.Drawing.Printing

Assembly: System.Drawing.dll

See Also

System.Drawing.Printing Namespace | PrinterResolution


PrinterSettings Class

Information about how a document should be printed, including which printer to print it on.

Object
PrinterSettings

[Visual Basic]
Public Class PrinterSettings
   Implements ICloneable
[C#]
public class PrinterSettings : ICloneable
[C++]
public __gc class PrinterSettings : public ICloneable
[JScript]
public class PrinterSettings implements ICloneable

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Printing

Assembly: System.Drawing.dll

See Also

PrinterSettings Members | System.Drawing.Printing Namespace


PrinterSettings Members

Public:

Constructor

PrinterSettings Constructor Initializes a new instance of the PrinterSettings class.

Properties

CanDuplex | Gets a value indicating whether the printer supports duplex (double-sided) printing.
Collate | Gets or sets a value indicating whether the print out is collated.
Copies | Gets or sets the number of copies to print.
DefaultPageSettings | Gets the default page settings for this printer.
Duplex | Gets or sets the printer's duplex setting.
FromPage | Gets or sets the first page to print. The NGWS runtime does not by any attention to this property; it is up to the application to interpret it as appropriate.
InstalledPrinters | Gets the names of all printers installed on the machine.
IsPlotter | Gets a value indicating whether the printer is a plotter, as opposed to a raster printer.
IsValid | Gets a value indicating whether the PrinterName property designates a valid printer.
LandscapeAngle | Gets the angle, in degrees, which the portrait orientation is rotated to produce the landscape orientation.
MaximumCopies | Gets the maximum number of copies allowed by the printer.
MaximumPage | Gets or sets the highest FromPage or ToPage which may be selected in a print dialog box.
MinimumPage | The lowest FromPage or ToPage which may be selected in a print dialog box.
PaperSizes | Gets the paper sizes supported by this printer.
PaperSources | Gets the paper sources available on this printer.
PrinterName | Gets or sets the name of the printer.
PrinterResolutions | Gets the resolutions supported by this printer.
PrintRange | Gets or sets a value indicating the pages the user has asked to print.
SupportsColor | Gets a value indicating whether the printer supports color printing.
ToPage | Gets or sets the last page to print. The NGWS runtime does not pay any attention to this property; it is up to the application to interpret it as appropriate.

Methods

Clone | Creates an identical copy of this object.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHDEVMODE | Overloaded. [To be supplied.]
GetHDEVNAMES | Creates a handle to a DEVNAMES structure which correspond too the printer settings. When you are done with the handle, you must deallocate it yourself: Windows.GlobalFree(handle); Where "handle" is the return value from this method.
GetType (inherited from Object) | Gets the Type of the Object.
SetHDEVMODE | Copies the relevant information out of the handle and into the PrinterSettings.
SetHDEVNAMES | Copies the relevant information out of the handle and into the PrinterSettings.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PrinterSettings Class | System.Drawing.Printing Namespace


PrinterSettings Constructor

Initializes a new instance of the PrinterSettings class.

[Visual Basic]
Public Sub New()
[C#]
public PrinterSettings();
[C++]
public: PrinterSettings();
[JScript]
public function PrinterSettings();

See Also

PrinterSettings Class | PrinterSettings Members | System.Drawing.Printing Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PrinterSettings Properties

The properties of the PrinterSettings class are listed below. For a complete list of PrinterSettings class members, see the PrinterSettings Members topic.

Public:

CanDuplex | Gets a value indicating whether the printer supports duplex (double-sided) printing.
Collate | Gets or sets a value indicating whether the print out is collated.
Copies | Gets or sets the number of copies to print.
DefaultPageSettings | Gets the default page settings for this printer.
Duplex | Gets or sets the printer's duplex setting.
FromPage | Gets or sets the first page to print. The NGWS runtime does not by any attention to this property; it is up to the application to interpret it as appropriate.
InstalledPrinters | Gets the names of all printers installed on the machine.
IsPlotter | Gets a value indicating whether the printer is a plotter, as opposed to a raster printer.
IsValid | Gets a value indicating whether the PrinterName property designates a valid printer.
LandscapeAngle | Gets the angle, in degrees, which the portrait orientation is rotated to produce the landscape orientation.
MaximumCopies | Gets the maximum number of copies allowed by the printer.
MaximumPage | Gets or sets the highest FromPage or ToPage which may be selected in a print dialog box.
MinimumPage | The lowest FromPage or ToPage which may be selected in a print dialog box.
PaperSizes | Gets the paper sizes supported by this printer.
PaperSources | Gets the paper sources available on this printer.
PrinterName | Gets or sets the name of the printer.
PrinterResolutions | Gets the resolutions supported by this printer.
PrintRange | Gets or sets a value indicating the pages the user has asked to print.
SupportsColor | Gets a value indicating whether the printer supports color printing.
ToPage | Gets or sets the last page to print. The NGWS runtime does not pay any attention to this property; it is up to the application to interpret it as appropriate.

See Also

PrinterSettings Class | System.Drawing.Printing Namespace


PrinterSettings.CanDuplex

Gets a value indicating whether the printer supports duplex (double-sided) printing.

[Visual Basic]
Public ReadOnly Property CanDuplex As Boolean
[C#]
public bool CanDuplex {get;}
[C++]
public: __property bool get_CanDuplex();
[JScript]
public function get CanDuplex() : Boolean;

Property Value

true if the printer supports duplex printing; otherwise, false.

See Also

PrinterSettings Class | PrinterSettings Members | System.Drawing.Printing Namespace | Collate | IsPlotter | IsValid | SupportsColor


PrinterSettings.Collate

Gets or sets a value indicating whether the print out is collated.

[Visual Basic]
Public Property Collate As Boolean
[C#]
public bool Collate {get; set;}
[C++]
public: __property bool get_Collate();
public: __property void set_Collate(bool);
[JScript]
public function get Collate() : Boolean;
public function set Collate(Boolean);

Property Value

true if the print out is collated; otherwise, false.

See Also

PrinterSettings Class | PrinterSettings Members | System.Drawing.Printing Namespace | CanDuplex | IsPlotter | IsValid | SupportsColor


PrinterSettings.Copies

Gets or sets the number of copies to print.

[Visual Basic]
Public Property Copies As Short
[C#]
public short Copies {get; set;}
[C++]
public: __property short get_Copies();
public: __property void set_Copies(short);
[JScript]
public function get Copies() : Int16;
public function set Copies(Int16);

Property Value

The number of copies to print.

See Also

PrinterSettings Class | PrinterSettings Members | System.Drawing.Printing Namespace | DefaultPageSettings | Duplex | FromPage | LandscapeAngle | MaximumCopies | MaximumPage | MinimumPage | PrintRange | PrinterName | ToPage


PrinterSettings.DefaultPageSettings

Gets the default page settings for this printer.

[Visual Basic]
Public ReadOnly Property DefaultPageSettings As PageSettings
[C#]
public PageSettings DefaultPageSettings {get;}
[C++]
public: __property PageSettings* get_DefaultPageSettings();
[JScript]
public function get DefaultPageSettings() : PageSettings;

Property Value

The default page settings for this printer.

See Also

PrinterSettings Class | PrinterSettings Members | System.Drawing.Printing Namespace | Copies | Duplex | FromPage | LandscapeAngle | MaximumCopies | MaximumPage | MinimumPage | PrintRange | PrinterName | ToPage


PrinterSettings.Duplex

Gets or sets the printer's duplex setting.

[Visual Basic]
Public Property Duplex As Duplex
[C#]
public Duplex Duplex {get; set;}
[C++]
public: __property Duplex get_Duplex();
public: __property void set_Duplex(Duplex);
[JScript]
public function get Duplex() : Duplex;
public function set Duplex(Duplex);

Property Value

The printer's duplex setting.

See Also

PrinterSettings Class | PrinterSettings Members | System.Drawing.Printing Namespace | Duplex | Copies | DefaultPageSettings | FromPage | LandscapeAngle | MaximumCopies | MaximumPage | MinimumPage | PrintRange | PrinterName | ToPage


PrinterSettings.FromPage

Gets or sets the first page to print. The NGWS frameworks does not by any attention to this property; it is up to the application to interpret it as appropriate.

[Visual Basic]
Public Property FromPage As Integer
[C#]
public int FromPage {get; set;}
[C++]
public: __property int get_FromPage();
public: __property void set_FromPage(int);
[JScript]
public function get FromPage() : int;
public function set FromPage(int);

Property Value

The first page to print.

Exceptions

Exception Type | Condition
ArgumentException | The value is less that zero.

Remarks

When using this method,

This method does not include any error trapping.

See Also

PrinterSettings Class | PrinterSettings Members | System.Drawing.Printing Namespace | Copies | DefaultPageSettings | Duplex | LandscapeAngle | MaximumCopies | MaximumPage | MinimumPage | PrintRange | PrinterName | ToPage


PrinterSettings.InstalledPrinters

Gets the names of all printers installed on the machine.

[Visual Basic]
Public ReadOnly Property InstalledPrinters As _
   PrinterSettings.StringCollection
[C#]
public PrinterSettings.StringCollection InstalledPrinters {get;}
[C++]
public: __property PrinterSettings.StringCollection*
   get_InstalledPrinters();
[JScript]
public function get InstalledPrinters() :
   PrinterSettings.StringCollection;

Property Value

The names of all printers installed on the machine.

See Also

PrinterSettings Class | PrinterSettings Members | System.Drawing.Printing Namespace | String | PrinterSettings.StringCollection | PaperSizes | PaperSources | PrinterResolutions


PrinterSettings.IsPlotter

Gets a value indicating whether the printer is a plotter, as opposed to a raster printer.

[Visual Basic]
Public ReadOnly Property IsPlotter As Boolean
[C#]
public bool IsPlotter {get;}
[C++]
public: __property bool get_IsPlotter();
[JScript]
public function get IsPlotter() : Boolean;

Property Value

true if the printer is a plotter; otherwise, false.

See Also

PrinterSettings Class | PrinterSettings Members | System.Drawing.Printing Namespace | CanDuplex | Collate | IsValid | SupportsColor


PrinterSettings.IsValid

Gets a value indicating whether the PrinterName property designates a valid printer.

[Visual Basic]
Public ReadOnly Property IsValid As Boolean
[C#]
public bool IsValid {get;}
[C++]
public: __property bool get_IsValid();
[JScript]
public function get IsValid() : Boolean;

Property Value

true if PrinterName designates a valid printer; otherwise, false.

See Also

PrinterSettings Class | PrinterSettings Members | System.Drawing.Printing Namespace | CanDuplex | Collate | IsPlotter | SupportsColor


PrinterSettings.LandscapeAngle

Gets the angle, in degrees, which the portrait orientation is rotated to produce the landscape orientation.

[Visual Basic]
Public ReadOnly Property LandscapeAngle As Integer
[C#]
public int LandscapeAngle {get;}
[C++]
public: __property int get_LandscapeAngle();
[JScript]
public function get LandscapeAngle() : int;

Property Value

The angle, in degrees, which the portrait orientation is rotated to produce the landscape orientation.

Remarks

Legal rotation values are 90 and 270 degrees. If landscape is not supported, the only legal rotation value is 0 degrees.

See Also

PrinterSettings Class | PrinterSettings Members | System.Drawing.Printing Namespace | Copies | DefaultPageSettings | Duplex | FromPage | MaximumCopies | MaximumPage | MinimumPage | PrintRange | PrinterName | ToPage


PrinterSettings.MaximumCopies

Gets the maximum number of copies allowed by the printer.

[Visual Basic]
Public ReadOnly Property MaximumCopies As Integer
[C#]
public int MaximumCopies {get;}
[C++]
public: __property int get_MaximumCopies();
[JScript]
public function get MaximumCopies() : int;

Property Value

The maximum number of copies allowed by the printer.

See Also

PrinterSettings Class | PrinterSettings Members | System.Drawing.Printing Namespace | Copies | DefaultPageSettings | Duplex | FromPage | LandscapeAngle | MaximumPage | MinimumPage | PrintRange | PrinterName | ToPage


PrinterSettings.MaximumPage

Gets or sets the highest FromPage or ToPage which may be selected in a print dialog box.

[Visual Basic]
Public Property MaximumPage As Integer
[C#]
public int MaximumPage {get; set;}
[C++]
public: __property int get_MaximumPage();
public: __property void set_MaximumPage(int);
[JScript]
public function get MaximumPage() : int;
public function set MaximumPage(int);

Property Value

The highest allowable maximum page.

Exceptions

Exception Type | Condition
ArgumentException | The maximum page number is less than zero.

See Also

PrinterSettings Class | PrinterSettings Members | System.Drawing.Printing Namespace | Copies | DefaultPageSettings | Duplex | FromPage | LandscapeAngle | MaximumCopies | MinimumPage | PrintRange | PrinterName | ToPage


PrinterSettings.MinimumPage

The lowest FromPage or ToPage which may be selected in a print dialog box.

[Visual Basic]
Public Property MinimumPage As Integer
[C#]
public int MinimumPage {get; set;}
[C++]
public: __property int get_MinimumPage();
public: __property void set_MinimumPage(int);
[JScript]
public function get MinimumPage() : int;
public function set MinimumPage(int);

Property Value

The lowest allowable minimum page.

Exceptions

Exception Type | Condition
ArgumentException | The minimum page number is less than zero.

See Also

PrinterSettings Class | PrinterSettings Members | System.Drawing.Printing Namespace | Copies | DefaultPageSettings | Duplex | FromPage | LandscapeAngle | MaximumCopies | MaximumPage | PrintRange | PrinterName | ToPage


PrinterSettings.PaperSizes

Gets the paper sizes supported by this printer.

[Visual Basic]
Public ReadOnly Property PaperSizes As _
   PrinterSettings.PaperSizeCollection
[C#]
public PrinterSettings.PaperSizeCollection PaperSizes {get;}
[C++]
public: __property PrinterSettings.PaperSizeCollection*
   get_PaperSizes();
[JScript]
public function get PaperSizes() :
   PrinterSettings.PaperSizeCollection;

Property Value

The paper sizes supported by this printer.

See Also

PrinterSettings Class | PrinterSettings Members | System.Drawing.Printing Namespace | PaperSize | PrinterSettings.PaperSizeCollection | InstalledPrinters | PaperSources | PrinterResolutions


PrinterSettings.PaperSources

Gets the paper sources available on this printer.

[Visual Basic]
Public ReadOnly Property PaperSources As _
   PrinterSettings.PaperSourceCollection
[C#]
public PrinterSettings.PaperSourceCollection PaperSources {get;}
[C++]
public: __property PrinterSettings.PaperSourceCollection*
   get_PaperSources();
[JScript]
public function get PaperSources() :
   PrinterSettings.PaperSourceCollection;

Property Value

The paper sources (i.e. trays) available on this printer.

See Also

PrinterSettings Class | PrinterSettings Members | System.Drawing.Printing Namespace | PaperSource | PrinterSettings.PaperSourceCollection | InstalledPrinters | PaperSizes | PrinterResolutions


PrinterSettings.PrinterName

Gets or sets the name of the printer.

[Visual Basic]
Public Property PrinterName As String
[C#]
public string PrinterName {get; set;}
[C++]
public: __property String* get_PrinterName();
public: __property void set_PrinterName(String*);
[JScript]
public function get PrinterName() : String;
public function set PrinterName(String);

Property Value

The name of the printer.

See Also

PrinterSettings Class | PrinterSettings Members | System.Drawing.Printing Namespace | Copies | DefaultPageSettings | Duplex | FromPage | LandscapeAngle | MaximumCopies | MaximumPage | MinimumPage | PrintRange | ToPage


PrinterSettings.PrinterResolutions

Gets the resolutions supported by this printer.

[Visual Basic]
Public ReadOnly Property PrinterResolutions As _
   PrinterSettings.PrinterResolutionCollection
[C#]
public PrinterSettings.PrinterResolutionCollection
   PrinterResolutions {get;}
[C++]
public: __property PrinterSettings.PrinterResolutionCollection*
   get_PrinterResolutions();
[JScript]
public function get PrinterResolutions() :
   PrinterSettings.PrinterResolutionCollection;

Property Value

The resolutions supported by this printer.

See Also

PrinterSettings Class | PrinterSettings Members | System.Drawing.Printing Namespace | PrinterResolution | PrinterSettings.PrinterResolutionCollection | InstalledPrinters | PaperSizes | PaperSources


PrinterSettings.PrintRange

Gets or sets a value indicating the pages the user has asked to print.

[Visual Basic]
Public Property PrintRange As PrintRange
[C#]
public PrintRange PrintRange {get; set;}
[C++]
public: __property PrintRange get_PrintRange();
public: __property void set_PrintRange(PrintRange);
[JScript]
public function get PrintRange() : PrintRange;
public function set PrintRange(PrintRange);

Property Value

The pages the user has asked to print.

Remarks

Except for the PrintDialog, the NGWS frameworks does not pay any attention to this property; it is up to the application to interpret it as appropriate.

When this property is used in an application

See Also

PrinterSettings Class | PrinterSettings Members | System.Drawing.Printing Namespace | PrintRange | Copies | DefaultPageSettings | Duplex | FromPage | LandscapeAngle | MaximumCopies | MaximumPage | MinimumPage | PrinterName | ToPage


PrinterSettings.SupportsColor

Gets a value indicating whether the printer supports color printing.

[Visual Basic]
Public ReadOnly Property SupportsColor As Boolean
[C#]
public bool SupportsColor {get;}
[C++]
public: __property bool get_SupportsColor();
[JScript]
public function get SupportsColor() : Boolean;

Property Value

true if the printer supports color printing; otherwise, false.

See Also

PrinterSettings Class | PrinterSettings Members | System.Drawing.Printing Namespace | CanDuplex | Collate | IsPlotter | IsValid


PrinterSettings.ToPage

Gets or sets the last page to print. the NGWS frameworks does not pay any attention to this property; it is up to the application to interpret it as appropriate.

[Visual Basic]
Public Property ToPage As Integer
[C#]
public int ToPage {get; set;}
[C++]
public: __property int get_ToPage();
public: __property void set_ToPage(int);
[JScript]
public function get ToPage() : int;
public function set ToPage(int);

Property Value

The last page to print.

Exceptions

Exception Type | Condition
ArgumentException | The value is less than zero.

See Also

PrinterSettings Class | PrinterSettings Members | System.Drawing.Printing Namespace | Copies | DefaultPageSettings | Duplex | FromPage | LandscapeAngle | MaximumCopies | MaximumPage | MinimumPage | PrintRange | PrinterName


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PrinterSettings Methods

The methods of the PrinterSettings class are listed below. For a complete list of PrinterSettings class members, see the PrinterSettings Members topic.

Public:

Clone | Creates an identical copy of this object.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHDEVMODE | Overloaded. [To be supplied.]
GetHDEVNAMES | Creates a handle to a DEVNAMES structure which correspond too the printer settings. When you are done with the handle, you must deallocate it yourself: Windows.GlobalFree(handle); Where "handle" is the return value from this method.
GetType (inherited from Object) | Gets the Type of the Object.
SetHDEVMODE | Copies the relevant information out of the handle and into the PrinterSettings.
SetHDEVNAMES | Copies the relevant information out of the handle and into the PrinterSettings.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PrinterSettings Class | System.Drawing.Printing Namespace


PrinterSettings.Clone

Creates an identical copy of this object.

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

Return Value

An identical copy of this object.

See Also

PrinterSettings Class | PrinterSettings Members | System.Drawing.Printing Namespace


PrinterSettings.GetHDEVMODE

[To be supplied.]

Overload List

Creates a handle to a DEVMODE structure which correspond to the printer and page settings. When you are done with the handle, you must deallocate it yourself: Windows.GlobalFree(handle); Where "handle" is the return value from this method.

[Visual Basic] Overloads Public Function GetHDEVMODE(PageSettings) As Integer
[C#] public int GetHDEVMODE(PageSettings);
[C++] public: int GetHDEVMODE(PageSettings*);
[JScript] public function GetHDEVMODE(PageSettings) : int;

Creates a handle to a DEVMODE structure which correspond too the printer settings. When you are done with the handle, you must deallocate it yourself: Windows.GlobalFree(handle); Where "handle" is the return value from this method.

[Visual Basic] Overloads Public Function GetHDEVMODE() As Integer
[C#] public int GetHDEVMODE();
[C++] public: int GetHDEVMODE();
[JScript] public function GetHDEVMODE() : int;

See Also

PrinterSettings Class | PrinterSettings Members | System.Drawing.Printing Namespace


PrinterSettings.GetHDEVMODE (PageSettings)

Creates a handle to a DEVMODE structure which correspond to the printer and page settings. When you are done with the handle, you must deallocate it yourself: Windows.GlobalFree(handle); Where "handle" is the return value from this method.

[Visual Basic]
Overloads Public Function GetHDEVMODE( _
   ByVal pageSettings As PageSettings _
) As Integer
[C#]
public int GetHDEVMODE(
   PageSettings pageSettings
);
[C++]
public: int GetHDEVMODE(
   PageSettings* pageSettings
);
[JScript]
public function GetHDEVMODE(
   pageSettings : PageSettings
) : int;

Parameters

pageSettings
[To be supplied.]

See Also

PrinterSettings Class | PrinterSettings Members | System.Drawing.Printing Namespace | PrinterSettings.GetHDEVMODE Overload List


PrinterSettings.GetHDEVMODE ()

Creates a handle to a DEVMODE structure which correspond too the printer settings. When you are done with the handle, you must deallocate it yourself: Windows.GlobalFree(handle); Where "handle" is the return value from this method.

[Visual Basic]
Overloads Public Function GetHDEVMODE() As Integer
[C#]
public int GetHDEVMODE();
[C++]
public: int GetHDEVMODE();
[JScript]
public function GetHDEVMODE() : int;

See Also

PrinterSettings Class | PrinterSettings Members | System.Drawing.Printing Namespace | PrinterSettings.GetHDEVMODE Overload List


PrinterSettings.GetHDEVNAMES

Creates a handle to a DEVNAMES structure which correspond too the printer settings. When you are done with the handle, you must deallocate it yourself: Windows.GlobalFree(handle); Where "handle" is the return value from this method.

[Visual Basic]
Public Function GetHDEVNAMES() As Integer
[C#]
public int GetHDEVNAMES();
[C++]
public: int GetHDEVNAMES();
[JScript]
public function GetHDEVNAMES() : int;

See Also

PrinterSettings Class | PrinterSettings Members | System.Drawing.Printing Namespace


PrinterSettings.SetHDEVMODE

Copies the relevant information out of the handle and into the PrinterSettings.

[Visual Basic]
Public Sub SetHDEVMODE( _
   ByVal hDevmode As Integer _
)
[C#]
public void SetHDEVMODE(
   int hDevmode
);
[C++]
public: void SetHDEVMODE(
   int hDevmode
);
[JScript]
public function SetHDEVMODE(
   hDevmode : int
);

Parameters

hDevmode
[To be supplied.]

See Also

PrinterSettings Class | PrinterSettings Members | System.Drawing.Printing Namespace


PrinterSettings.SetHDEVNAMES

Copies the relevant information out of the handle and into the PrinterSettings.

[Visual Basic]
Public Sub SetHDEVNAMES( _
   ByVal hDevnames As Integer _
)
[C#]
public void SetHDEVNAMES(
   int hDevnames
);
[C++]
public: void SetHDEVNAMES(
   int hDevnames
);
[JScript]
public function SetHDEVNAMES(
   hDevnames : int
);

Parameters

hDevnames
A handle

Exceptions

Exception Type | Condition
ArgumentException | [To be supplied.]

See Also

PrinterSettings Class | PrinterSettings Members | System.Drawing.Printing Namespace


PrinterSettings.PaperSizeCollection Class

Collection of PaperSize's...

Object
PrinterSettings.PaperSizeCollection

[Visual Basic]
Public Class PrinterSettings.PaperSizeCollection
   Implements ICollection, IEnumerable
[C#]
public class PrinterSettings.PaperSizeCollection : ICollection,
   IEnumerable
[C++]
public __gc class PrinterSettings.PaperSizeCollection : public
   ICollection, IEnumerable
[JScript]
public class PrinterSettings.PaperSizeCollection implements
   ICollection, IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Printing

Assembly: System.Drawing.dll

See Also

PrinterSettings.PaperSizeCollection Members | System.Drawing.Printing Namespace | PaperSize


PrinterSettings.PaperSizeCollection Members

Public:

Constructor

PrinterSettingsPaperSizeCollection Constructor [To be supplied.]

Properties

All | [To be supplied.]
Count | [To be supplied.]
Item | [To be supplied.] In C#, this member is the indexer for the PrinterSettings.PaperSizeCollection class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PrinterSettings.PaperSizeCollection Class | System.Drawing.Printing Namespace


PrinterSettings.PaperSizeCollection Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal array() As PaperSize _
)
[C#]
public PrinterSettings.PaperSizeCollection(
   PaperSize[] array
);
[C++]
public: PrinterSettings.PaperSizeCollection(
   PaperSize* array[]
);
[JScript]
public function PrinterSettings.PaperSizeCollection(
   array : PaperSize[]
);

Parameters

array
[To be supplied.]

See Also

PrinterSettings.PaperSizeCollection Class | PrinterSettings.PaperSizeCollection Members | System.Drawing.Printing Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PrinterSettings.PaperSizeCollection Properties

The properties of the PrinterSettings.PaperSizeCollection class are listed below. For a complete list of PrinterSettings.PaperSizeCollection class members, see the PrinterSettings.PaperSizeCollection Members topic.

Public:

All | [To be supplied.]
Count | [To be supplied.]
Item | [To be supplied.] In C#, this member is the indexer for the PrinterSettings.PaperSizeCollection class.

See Also

PrinterSettings.PaperSizeCollection Class | System.Drawing.Printing Namespace


PrinterSettings.PaperSizeCollection.All

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property All As PaperSize ()
[C#]
public PaperSize[] All {virtual get;}
[C++]
public: __property virtual PaperSize* get_All();
[JScript]
public function get All() : PaperSize[];

See Also

PrinterSettings.PaperSizeCollection Class | PrinterSettings.PaperSizeCollection Members | System.Drawing.Printing Namespace


PrinterSettings.PaperSizeCollection.Count

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

See Also

PrinterSettings.PaperSizeCollection Class | PrinterSettings.PaperSizeCollection Members | System.Drawing.Printing Namespace


PrinterSettings.PaperSizeCollection.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the PrinterSettings.PaperSizeCollection class.

[Visual Basic]
Overridable Public Default ReadOnly Property Item( _
   ByVal index As Integer _
) As PaperSize
[C#]
public PaperSize this[
   int index
] {virtual get;}
[C++]
public: __property virtual PaperSize* get_Item(
   int index
);
[JScript]
returnValue = PrinterSettings.PaperSizeCollectionObject.Item(index);
-or-
returnValue = PrinterSettings.PaperSizeCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
[To be supplied.]

Parameters [Visual Basic, C#, C++]

index
[To be supplied.]

See Also

PrinterSettings.PaperSizeCollection Class | PrinterSettings.PaperSizeCollection Members | System.Drawing.Printing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PrinterSettings.PaperSizeCollection Methods

The methods of the PrinterSettings.PaperSizeCollection class are listed below. For a complete list of PrinterSettings.PaperSizeCollection class members, see the PrinterSettings.PaperSizeCollection Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PrinterSettings.PaperSizeCollection Class | System.Drawing.Printing Namespace


PrinterSettings.PaperSizeCollection.GetEnumerator

[To be supplied.]

[Visual Basic]
Public Function GetEnumerator() As IEnumerator
[C#]
public IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

See Also

PrinterSettings.PaperSizeCollection Class | PrinterSettings.PaperSizeCollection Members | System.Drawing.Printing Namespace


PrinterSettings.PaperSourceCollection Class

Collection of PaperSource's...

Object
PrinterSettings.PaperSourceCollection

[Visual Basic]
Public Class PrinterSettings.PaperSourceCollection
   Implements ICollection, IEnumerable
[C#]
public class PrinterSettings.PaperSourceCollection : ICollection,
   IEnumerable
[C++]
public __gc class PrinterSettings.PaperSourceCollection : public
   ICollection, IEnumerable
[JScript]
public class PrinterSettings.PaperSourceCollection implements
   ICollection, IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Printing

Assembly: System.Drawing.dll

See Also

PrinterSettings.PaperSourceCollection Members | System.Drawing.Printing Namespace | PaperSource


PrinterSettings.PaperSourceCollection Members

Public:

Constructor

PrinterSettingsPaperSourceCollection Constructor [To be supplied.]

Properties

All | [To be supplied.]
Count | [To be supplied.]
Item | [To be supplied.] In C#, this member is the indexer for the PrinterSettings.PaperSourceCollection class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PrinterSettings.PaperSourceCollection Class | System.Drawing.Printing Namespace


PrinterSettings.PaperSourceCollection Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal array() As PaperSource _
)
[C#]
public PrinterSettings.PaperSourceCollection(
   PaperSource[] array
);
[C++]
public: PrinterSettings.PaperSourceCollection(
   PaperSource* array[]
);
[JScript]
public function PrinterSettings.PaperSourceCollection(
   array : PaperSource[]
);

Parameters

array
[To be supplied.]

See Also

PrinterSettings.PaperSourceCollection Class | PrinterSettings.PaperSourceCollection Members | System.Drawing.Printing Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PrinterSettings.PaperSourceCollection Properties

The properties of the PrinterSettings.PaperSourceCollection class are listed below. For a complete list of PrinterSettings.PaperSourceCollection class members, see the PrinterSettings.PaperSourceCollection Members topic.

Public:

All | [To be supplied.]
Count | [To be supplied.]
Item | [To be supplied.] In C#, this member is the indexer for the PrinterSettings.PaperSourceCollection class.

See Also

PrinterSettings.PaperSourceCollection Class | System.Drawing.Printing Namespace


PrinterSettings.PaperSourceCollection.All

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property All As PaperSource ()
[C#]
public PaperSource[] All {virtual get;}
[C++]
public: __property virtual PaperSource* get_All();
[JScript]
public function get All() : PaperSource[];

See Also

PrinterSettings.PaperSourceCollection Class | PrinterSettings.PaperSourceCollection Members | System.Drawing.Printing Namespace


PrinterSettings.PaperSourceCollection.Count

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

See Also

PrinterSettings.PaperSourceCollection Class | PrinterSettings.PaperSourceCollection Members | System.Drawing.Printing Namespace


PrinterSettings.PaperSourceCollection.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the PrinterSettings.PaperSourceCollection class.

[Visual Basic]
Overridable Public Default ReadOnly Property Item( _
   ByVal index As Integer _
) As PaperSource
[C#]
public PaperSource this[
   int index
] {virtual get;}
[C++]
public: __property virtual PaperSource* get_Item(
   int index
);
[JScript]
returnValue = PrinterSettings.PaperSourceCollectionObject.Item(index);
-or-
returnValue = PrinterSettings.PaperSourceCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
[To be supplied.]

Parameters [Visual Basic, C#, C++]

index
[To be supplied.]

See Also

PrinterSettings.PaperSourceCollection Class | PrinterSettings.PaperSourceCollection Members | System.Drawing.Printing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PrinterSettings.PaperSourceCollection Methods

The methods of the PrinterSettings.PaperSourceCollection class are listed below. For a complete list of PrinterSettings.PaperSourceCollection class members, see the PrinterSettings.PaperSourceCollection Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PrinterSettings.PaperSourceCollection Class | System.Drawing.Printing Namespace


PrinterSettings.PaperSourceCollection.GetEnumerator

[To be supplied.]

[Visual Basic]
Public Function GetEnumerator() As IEnumerator
[C#]
public IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

See Also

PrinterSettings.PaperSourceCollection Class | PrinterSettings.PaperSourceCollection Members | System.Drawing.Printing Namespace


PrinterSettings.PrinterResolutionCollection Class

Collection of PrinterResolution's...

Object
PrinterSettings.PrinterResolutionCollection

[Visual Basic]
Public Class PrinterSettings.PrinterResolutionCollection
   Implements ICollection, IEnumerable
[C#]
public class PrinterSettings.PrinterResolutionCollection :
   ICollection, IEnumerable
[C++]
public __gc class PrinterSettings.PrinterResolutionCollection :
   public ICollection, IEnumerable
[JScript]
public class PrinterSettings.PrinterResolutionCollection implements
   ICollection, IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Printing

Assembly: System.Drawing.dll

See Also

PrinterSettings.PrinterResolutionCollection Members | System.Drawing.Printing Namespace | PrinterResolution


PrinterSettings.PrinterResolutionCollection Members

Public:

Constructor

PrinterSettingsPrinterResolutionCollection Constructor [To be supplied.]

Properties

All | [To be supplied.]
Count | [To be supplied.]
Item | [To be supplied.] In C#, this member is the indexer for the PrinterSettings.PrinterResolutionCollection class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PrinterSettings.PrinterResolutionCollection Class | System.Drawing.Printing Namespace


PrinterSettings.PrinterResolutionCollection Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal array() As PrinterResolution _
)
[C#]
public PrinterSettings.PrinterResolutionCollection(
   PrinterResolution[] array
);
[C++]
public: PrinterSettings.PrinterResolutionCollection(
   PrinterResolution* array[]
);
[JScript]
public function PrinterSettings.PrinterResolutionCollection(
   array : PrinterResolution[]
);

Parameters

array
[To be supplied.]

See Also

PrinterSettings.PrinterResolutionCollection Class | PrinterSettings.PrinterResolutionCollection Members | System.Drawing.Printing Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PrinterSettings.PrinterResolutionCollection Properties

The properties of the PrinterSettings.PrinterResolutionCollection class are listed below. For a complete list of PrinterSettings.PrinterResolutionCollection class members, see the PrinterSettings.PrinterResolutionCollection Members topic.

Public:

All | [To be supplied.]
Count | [To be supplied.]
Item | [To be supplied.] In C#, this member is the indexer for the PrinterSettings.PrinterResolutionCollection class.

See Also

PrinterSettings.PrinterResolutionCollection Class | System.Drawing.Printing Namespace


PrinterSettings.PrinterResolutionCollection.All

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property All As PrinterResolution ()
[C#]
public PrinterResolution[] All {virtual get;}
[C++]
public: __property virtual PrinterResolution* get_All();
[JScript]
public function get All() : PrinterResolution[];

See Also

PrinterSettings.PrinterResolutionCollection Class | PrinterSettings.PrinterResolutionCollection Members | System.Drawing.Printing Namespace


PrinterSettings.PrinterResolutionCollection.Count

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

See Also

PrinterSettings.PrinterResolutionCollection Class | PrinterSettings.PrinterResolutionCollection Members | System.Drawing.Printing Namespace


PrinterSettings.PrinterResolutionCollection.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the PrinterSettings.PrinterResolutionCollection class.

[Visual Basic]
Overridable Public Default ReadOnly Property Item( _
   ByVal index As Integer _
) As PrinterResolution
[C#]
public PrinterResolution this[
   int index
] {virtual get;}
[C++]
public: __property virtual PrinterResolution* get_Item(
   int index
);
[JScript]
returnValue = PrinterSettings.PrinterResolutionCollectionObject.Item(index);
-or-
returnValue = PrinterSettings.PrinterResolutionCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
[To be supplied.]

Parameters [Visual Basic, C#, C++]

index
[To be supplied.]

See Also

PrinterSettings.PrinterResolutionCollection Class | PrinterSettings.PrinterResolutionCollection Members | System.Drawing.Printing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PrinterSettings.PrinterResolutionCollection Methods

The methods of the PrinterSettings.PrinterResolutionCollection class are listed below. For a complete list of PrinterSettings.PrinterResolutionCollection class members, see the PrinterSettings.PrinterResolutionCollection Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PrinterSettings.PrinterResolutionCollection Class | System.Drawing.Printing Namespace


PrinterSettings.PrinterResolutionCollection.GetEnumerator

[To be supplied.]

[Visual Basic]
Public Function GetEnumerator() As IEnumerator
[C#]
public IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

See Also

PrinterSettings.PrinterResolutionCollection Class | PrinterSettings.PrinterResolutionCollection Members | System.Drawing.Printing Namespace


PrinterSettings.StringCollection Class

Collection of String's...

Object
PrinterSettings.StringCollection

[Visual Basic]
Public Class PrinterSettings.StringCollection
   Implements ICollection, IEnumerable
[C#]
public class PrinterSettings.StringCollection : ICollection,
   IEnumerable
[C++]
public __gc class PrinterSettings.StringCollection : public
   ICollection, IEnumerable
[JScript]
public class PrinterSettings.StringCollection implements
   ICollection, IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Printing

Assembly: System.Drawing.dll

See Also

PrinterSettings.StringCollection Members | System.Drawing.Printing Namespace | String


PrinterSettings.StringCollection Members

Public:

Constructor

PrinterSettingsStringCollection Constructor [To be supplied.]

Properties

All | [To be supplied.]
Count | [To be supplied.]
Item | [To be supplied.] In C#, this member is the indexer for the PrinterSettings.StringCollection class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PrinterSettings.StringCollection Class | System.Drawing.Printing Namespace


PrinterSettings.StringCollection Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal array() As String _
)
[C#]
public PrinterSettings.StringCollection(
   string[] array
);
[C++]
public: PrinterSettings.StringCollection(
   String* array[]
);
[JScript]
public function PrinterSettings.StringCollection(
   array : String[]
);

Parameters

array
[To be supplied.]

See Also

PrinterSettings.StringCollection Class | PrinterSettings.StringCollection Members | System.Drawing.Printing Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PrinterSettings.StringCollection Properties

The properties of the PrinterSettings.StringCollection class are listed below. For a complete list of PrinterSettings.StringCollection class members, see the PrinterSettings.StringCollection Members topic.

Public:

All | [To be supplied.]
Count | [To be supplied.]
Item | [To be supplied.] In C#, this member is the indexer for the PrinterSettings.StringCollection class.

See Also

PrinterSettings.StringCollection Class | System.Drawing.Printing Namespace


PrinterSettings.StringCollection.All

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property All As String ()
[C#]
public string[] All {virtual get;}
[C++]
public: __property virtual String* get_All();
[JScript]
public function get All() : String[];

See Also

PrinterSettings.StringCollection Class | PrinterSettings.StringCollection Members | System.Drawing.Printing Namespace


PrinterSettings.StringCollection.Count

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[JScript]
public function get Count() : int;

See Also

PrinterSettings.StringCollection Class | PrinterSettings.StringCollection Members | System.Drawing.Printing Namespace


PrinterSettings.StringCollection.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the PrinterSettings.StringCollection class.

[Visual Basic]
Overridable Public Default ReadOnly Property Item( _
   ByVal index As Integer _
) As String
[C#]
public string this[
   int index
] {virtual get;}
[C++]
public: __property virtual String* get_Item(
   int index
);
[JScript]
returnValue = PrinterSettings.StringCollectionObject.Item(index);
-or-
returnValue = PrinterSettings.StringCollectionObject(index);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
[To be supplied.]

Parameters [Visual Basic, C#, C++]

index
[To be supplied.]

See Also

PrinterSettings.StringCollection Class | PrinterSettings.StringCollection Members | System.Drawing.Printing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PrinterSettings.StringCollection Methods

The methods of the PrinterSettings.StringCollection class are listed below. For a complete list of PrinterSettings.StringCollection class members, see the PrinterSettings.StringCollection Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PrinterSettings.StringCollection Class | System.Drawing.Printing Namespace


PrinterSettings.StringCollection.GetEnumerator

[To be supplied.]

[Visual Basic]
Public Function GetEnumerator() As IEnumerator
[C#]
public IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

See Also

PrinterSettings.StringCollection Class | PrinterSettings.StringCollection Members | System.Drawing.Printing Namespace


PrinterUnit Enumeration

Specifies several of the units of measure Win32 uses for printing.

[Visual Basic]
Public Enum PrinterUnit
[C#]
public enum PrinterUnit
[C++]
public enum PrinterUnit

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

System.Drawing.Printing.PrintPreviewController, PrinterSettings, and System.Drawing.Printing.PageSetupDialog use this enumeration.

Note Most users will never need to use this enum.

Members

Member Name | Description
Display | The default unit (.01 in).
HundredthsOfAMillimeter | One hundredth of a millimeter (.01 mm).
TenthsOfAMillimeter | One tenth of a millimeter (.1 mm).
ThousandthsOfAnInch | One thousandth of an inch (.001 in).

Requirements

Namespace: System.Drawing.Printing

Assembly: System.Drawing.dll

See Also

System.Drawing.Printing Namespace | PrinterUnitConvert


PrinterUnitConvert Class

Specifies a series of conversion methods that are useful when interoperating with the raw Win32 printing API. This class cannot be inherited.

Object
PrinterUnitConvert

[Visual Basic]
NotInheritable Public Class PrinterUnitConvert
[C#]
public sealed class PrinterUnitConvert
[C++]
public __gc __sealed class PrinterUnitConvert
[JScript]
public class PrinterUnitConvert

Remarks

Note Most users will never need to use this class.

Requirements

Namespace: System.Drawing.Printing

Assembly: System.Drawing.dll

See Also

PrinterUnitConvert Members | System.Drawing.Printing Namespace | PrinterUnit


PrinterUnitConvert Members

Public:

Methods

Convert | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PrinterUnitConvert Class | System.Drawing.Printing Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PrinterUnitConvert Methods

The methods of the PrinterUnitConvert class are listed below. For a complete list of PrinterUnitConvert class members, see the PrinterUnitConvert Members topic.

Public:

Convert | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PrinterUnitConvert Class | System.Drawing.Printing Namespace


PrinterUnitConvert.Convert

[To be supplied.]

Overload List

Converts the value, in fromUnit units, to toUnit units.

[Visual Basic] Overloads Public Shared Function Convert(Point, PrinterUnit, PrinterUnit) As Point
[C#] public static Point Convert(Point, PrinterUnit, PrinterUnit);
[C++] public: static Point Convert(Point, PrinterUnit, PrinterUnit);
[JScript] public static function Convert(Point, PrinterUnit, PrinterUnit) : Point;

Converts the value, in fromUnit units, to toUnit units.

[Visual Basic] Overloads Public Shared Function Convert(Integer, PrinterUnit, PrinterUnit) As Integer
[C#] public static int Convert(int, PrinterUnit, PrinterUnit);
[C++] public: static int Convert(int, PrinterUnit, PrinterUnit);
[JScript] public static function Convert(int, PrinterUnit, PrinterUnit) : int;

Converts the value, in fromUnit units, to toUnit units.

[Visual Basic] Overloads Public Shared Function Convert(Size, PrinterUnit, PrinterUnit) As Size
[C#] public static Size Convert(Size, PrinterUnit, PrinterUnit);
[C++] public: static Size Convert(Size, PrinterUnit, PrinterUnit);
[JScript] public static function Convert(Size, PrinterUnit, PrinterUnit) : Size;

Converts the value, in fromUnit units, to toUnit units.

[Visual Basic] Overloads Public Shared Function Convert(Margins, PrinterUnit, PrinterUnit) As Margins
[C#] public static Margins Convert(Margins, PrinterUnit, PrinterUnit);
[C++] public: static Margins* Convert(Margins*, PrinterUnit, PrinterUnit);
[JScript] public static function Convert(Margins, PrinterUnit, PrinterUnit) : Margins;

Converts the value, in fromUnit units, to toUnit units.

[Visual Basic] Overloads Public Shared Function Convert(Rectangle, PrinterUnit, PrinterUnit) As Rectangle
[C#] public static Rectangle Convert(Rectangle, PrinterUnit, PrinterUnit);
[C++] public: static Rectangle Convert(Rectangle, PrinterUnit, PrinterUnit);
[JScript] public static function Convert(Rectangle, PrinterUnit, PrinterUnit) : Rectangle;

Converts the value, in fromUnit units, to toUnit units.

[Visual Basic] Overloads Public Shared Function Convert(Double, PrinterUnit, PrinterUnit) As Double
[C#] public static double Convert(double, PrinterUnit, PrinterUnit);
[C++] public: static double Convert(double, PrinterUnit, PrinterUnit);
[JScript] public static function Convert(double, PrinterUnit, PrinterUnit) : double;

See Also

PrinterUnitConvert Class | PrinterUnitConvert Members | System.Drawing.Printing Namespace


PrinterUnitConvert.Convert (Point, PrinterUnit, PrinterUnit)

Converts the value, in fromUnit units, to toUnit units.

[Visual Basic]
Overloads Public Shared Function Convert( _
   ByVal value As Point, _
   ByVal fromUnit As PrinterUnit, _
   ByVal toUnit As PrinterUnit _
) As Point
[C#]
public static Point Convert(
   Point value,
   PrinterUnit fromUnit,
   PrinterUnit toUnit
);
[C++]
public: static Point Convert(
   Point value,
   PrinterUnit fromUnit,
   PrinterUnit toUnit
);
[JScript]
public static function Convert(
   value : Point,
   fromUnit : PrinterUnit,
   toUnit : PrinterUnit
) : Point;

Parameters

value
[To be supplied.]
fromUnit
[To be supplied.]
toUnit
[To be supplied.]

See Also

PrinterUnitConvert Class | PrinterUnitConvert Members | System.Drawing.Printing Namespace | PrinterUnitConvert.Convert Overload List


PrinterUnitConvert.Convert (Int32, PrinterUnit, PrinterUnit)

Converts the value, in fromUnit units, to toUnit units.

[Visual Basic]
Overloads Public Shared Function Convert( _
   ByVal value As Integer, _
   ByVal fromUnit As PrinterUnit, _
   ByVal toUnit As PrinterUnit _
) As Integer
[C#]
public static int Convert(
   int value,
   PrinterUnit fromUnit,
   PrinterUnit toUnit
);
[C++]
public: static int Convert(
   int value,
   PrinterUnit fromUnit,
   PrinterUnit toUnit
);
[JScript]
public static function Convert(
   value : int,
   fromUnit : PrinterUnit,
   toUnit : PrinterUnit
) : int;

Parameters

value
[To be supplied.]
fromUnit
[To be supplied.]
toUnit
[To be supplied.]

See Also

PrinterUnitConvert Class | PrinterUnitConvert Members | System.Drawing.Printing Namespace | PrinterUnitConvert.Convert Overload List


PrinterUnitConvert.Convert (Size, PrinterUnit, PrinterUnit)

Converts the value, in fromUnit units, to toUnit units.

[Visual Basic]
Overloads Public Shared Function Convert( _
   ByVal value As Size, _
   ByVal fromUnit As PrinterUnit, _
   ByVal toUnit As PrinterUnit _
) As Size
[C#]
public static Size Convert(
   Size value,
   PrinterUnit fromUnit,
   PrinterUnit toUnit
);
[C++]
public: static Size Convert(
   Size value,
   PrinterUnit fromUnit,
   PrinterUnit toUnit
);
[JScript]
public static function Convert(
   value : Size,
   fromUnit : PrinterUnit,
   toUnit : PrinterUnit
) : Size;

Parameters

value
[To be supplied.]
fromUnit
[To be supplied.]
toUnit
[To be supplied.]

See Also

PrinterUnitConvert Class | PrinterUnitConvert Members | System.Drawing.Printing Namespace | PrinterUnitConvert.Convert Overload List


PrinterUnitConvert.Convert (Margins, PrinterUnit, PrinterUnit)

Converts the value, in fromUnit units, to toUnit units.

[Visual Basic]
Overloads Public Shared Function Convert( _
   ByVal value As Margins, _
   ByVal fromUnit As PrinterUnit, _
   ByVal toUnit As PrinterUnit _
) As Margins
[C#]
public static Margins Convert(
   Margins value,
   PrinterUnit fromUnit,
   PrinterUnit toUnit
);
[C++]
public: static Margins* Convert(
   Margins* value,
   PrinterUnit fromUnit,
   PrinterUnit toUnit
);
[JScript]
public static function Convert(
   value : Margins,
   fromUnit : PrinterUnit,
   toUnit : PrinterUnit
) : Margins;

Parameters

value
[To be supplied.]
fromUnit
[To be supplied.]
toUnit
[To be supplied.]

See Also

PrinterUnitConvert Class | PrinterUnitConvert Members | System.Drawing.Printing Namespace | PrinterUnitConvert.Convert Overload List | PrinterUnit


PrinterUnitConvert.Convert (Rectangle, PrinterUnit, PrinterUnit)

Converts the value, in fromUnit units, to toUnit units.

[Visual Basic]
Overloads Public Shared Function Convert( _
   ByVal value As Rectangle, _
   ByVal fromUnit As PrinterUnit, _
   ByVal toUnit As PrinterUnit _
) As Rectangle
[C#]
public static Rectangle Convert(
   Rectangle value,
   PrinterUnit fromUnit,
   PrinterUnit toUnit
);
[C++]
public: static Rectangle Convert(
   Rectangle value,
   PrinterUnit fromUnit,
   PrinterUnit toUnit
);
[JScript]
public static function Convert(
   value : Rectangle,
   fromUnit : PrinterUnit,
   toUnit : PrinterUnit
) : Rectangle;

Parameters

value
[To be supplied.]
fromUnit
[To be supplied.]
toUnit
[To be supplied.]

See Also

PrinterUnitConvert Class | PrinterUnitConvert Members | System.Drawing.Printing Namespace | PrinterUnitConvert.Convert Overload List


PrinterUnitConvert.Convert (Double, PrinterUnit, PrinterUnit)

Converts the value, in fromUnit units, to toUnit units.

[Visual Basic]
Overloads Public Shared Function Convert( _
   ByVal value As Double, _
   ByVal fromUnit As PrinterUnit, _
   ByVal toUnit As PrinterUnit _
) As Double
[C#]
public static double Convert(
   double value,
   PrinterUnit fromUnit,
   PrinterUnit toUnit
);
[C++]
public: static double Convert(
   double value,
   PrinterUnit fromUnit,
   PrinterUnit toUnit
);
[JScript]
public static function Convert(
   value : double,
   fromUnit : PrinterUnit,
   toUnit : PrinterUnit
) : double;

Parameters

value
[To be supplied.]
fromUnit
[To be supplied.]
toUnit
[To be supplied.]

See Also

PrinterUnitConvert Class | PrinterUnitConvert Members | System.Drawing.Printing Namespace | PrinterUnitConvert.Convert Overload List


PrintEventArgs Class

Provides data for the OnBeginPrint and OnEndPrint events.

Object
EventArgs
CancelEventArgs
PrintEventArgs

[Visual Basic]
Public Class PrintEventArgs
   Inherits CancelEventArgs
[C#]
public class PrintEventArgs : CancelEventArgs
[C++]
public __gc class PrintEventArgs : public CancelEventArgs
[JScript]
public class PrintEventArgs extends CancelEventArgs

Remarks

In this release, PrintEventArgs provides no properties to specify event data. This class is reserved for future use.

Requirements

Namespace: System.Drawing.Printing

Assembly: System.Drawing.dll

See Also

PrintEventArgs Members | System.Drawing.Printing Namespace | PrintDocument | PrintEventHandler | OnBeginPrint | System.Drawing.Printing.PrintDocument.BeginPrint | OnEndPrint | System.Drawing.Printing.PrintDocument.EndPrint


PrintEventArgs Members

Public:

Constructor

PrintEventArgs Constructor Initializes a new instance of the PrintEventArgs class.

Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the operation should be cancelled.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PrintEventArgs Class | System.Drawing.Printing Namespace


PrintEventArgs Constructor

Initializes a new instance of the PrintEventArgs class.

[Visual Basic]
Public Sub New()
[C#]
public PrintEventArgs();
[C++]
public: PrintEventArgs();
[JScript]
public function PrintEventArgs();

Remarks

PrintEventArgs is

See Also

PrintEventArgs Class | PrintEventArgs Members | System.Drawing.Printing Namespace


PrintEventHandler Delegate

Represents the method that will handle the System.Drawing.Printing.PrintDocument.BeginPrint, System.Drawing.Printing.PrintDocument.EndPrint, or System.Drawing.Printing.PrintDocument.QueryPageSettings event of a PrintDocument.

[Visual Basic]
Public Delegate Sub PrintEventHandler( _
   ByVal sender As Object, _
   ByVal e As PrintEventArgs _
)
[C#]
public delegate void PrintEventHandler(
   object sender,
   PrintEventArgs e
);
[C++]
public __gc __delegate void PrintEventHandler(
   Object* sender,
   PrintEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the PrintEventHandler delegate declaration.

sender
The source of the event.
e
A PrintEventArgs that contains the event data.

Remarks

When you create a System.WinForms.PrintEventHandler delegate, you identify the method that will handle the event. To associate the event with your event-handling method, add an instance of the delegate to the event. The event-handling method is called whenever the event occurs, unless you remove the delegate. For more information about handling events with delegates, see TBD.

Requirements

Namespace: System.Drawing.Printing

Assembly: System.Drawing.dll

See Also

System.Drawing.Printing Namespace | System.WinForms.PrintDocument | OnBeginPrint | System.WinForms.PrintDocument.BeginPrint | OnEndPrint | System.WinForms.PrintDocument.EndPrint | OnQueryPageSettings | System.Drawing.Printing.PrintDocument.QueryPageSettings | PrintEventArgs


PrintPageEventArgs Class

Provides data for the OnPrintPage event.

Object
EventArgs
PrintPageEventArgs

[Visual Basic]
Public Class PrintPageEventArgs
   Inherits EventArgs
[C#]
public class PrintPageEventArgs : EventArgs
[C++]
public __gc class PrintPageEventArgs : public EventArgs
[JScript]
public class PrintPageEventArgs extends EventArgs

Remarks

Rectangle defines the rectangle in which all painting should be done. Graphics defines the graphics object with which to do the painting.

Requirements

Namespace: System.Drawing.Printing

Assembly: System.Drawing.dll

See Also

PrintPageEventArgs Members | System.Drawing.Printing Namespace | Graphics | Rectangle


PrintPageEventArgs Members

Public:

Constructor

PrintPageEventArgs Constructor Initializes a new instance of the PrintPageEventArgs class.

Properties

Cancel | Gets or sets a value indicating whether the print job should be canceled.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
Graphics | Gets the Graphics used to paint the item.
HasMorePages | Gets or sets a value indicating whether there is an additional page to be printed.
MarginBounds | Gets the rectangular area that represents the page between the margins.
PageBounds | Gets the rectangular area that represents the total area of the page.
PageSettings | Specifieds the page settings for the current page.

Methods

Dispose | Disposes of the resources (other than memory) used by the PrintPageEventArgs.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PrintPageEventArgs Class | System.Drawing.Printing Namespace


PrintPageEventArgs Constructor

Initializes a new instance of the PrintPageEventArgs class.

[Visual Basic]
Public Sub New( _
   ByVal graphics As Graphics, _
   ByVal marginBounds As Rectangle, _
   ByVal pageBounds As Rectangle, _
   ByVal pageSettings As PageSettings _
)
[C#]
public PrintPageEventArgs(
   Graphics graphics,
   Rectangle marginBounds,
   Rectangle pageBounds,
   PageSettings pageSettings
);
[C++]
public: PrintPageEventArgs(
   Graphics* graphics,
   Rectangle marginBounds,
   Rectangle pageBounds,
   PageSettings* pageSettings
);
[JScript]
public function PrintPageEventArgs(
   graphics : Graphics,
   marginBounds : Rectangle,
   pageBounds : Rectangle,
   pageSettings : PageSettings
);

Parameters

graphics
The Graphics used to paint the item.
marginBounds
The area between the margins.
pageBounds
The total area of the paper.
pageSettings
The PageSettings for the page.

See Also

PrintPageEventArgs Class | PrintPageEventArgs Members | System.Drawing.Printing Namespace | Graphics | Rectangle


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PrintPageEventArgs Properties

The properties of the PrintPageEventArgs class are listed below. For a complete list of PrintPageEventArgs class members, see the PrintPageEventArgs Members topic.

Public:

Cancel | Gets or sets a value indicating whether the print job should be canceled.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
Graphics | Gets the Graphics used to paint the item.
HasMorePages | Gets or sets a value indicating whether there is an additional page to be printed.
MarginBounds | Gets the rectangular area that represents the page between the margins.
PageBounds | Gets the rectangular area that represents the total area of the page.
PageSettings | Specifieds the page settings for the current page.

See Also

PrintPageEventArgs Class | System.Drawing.Printing Namespace


PrintPageEventArgs.Cancel

Gets or sets a value indicating whether the print job should be canceled.

[Visual Basic]
Public Property Cancel As Boolean
[C#]
public bool Cancel {get; set;}
[C++]
public: __property bool get_Cancel();
public: __property void set_Cancel(bool);
[JScript]
public function get Cancel() : Boolean;
public function set Cancel(Boolean);

Property Value

true if the print job should be cancelled; otherwise, false.

See Also

PrintPageEventArgs Class | PrintPageEventArgs Members | System.Drawing.Printing Namespace


PrintPageEventArgs.Graphics

Gets the Graphics used to paint the item.

[Visual Basic]
Public ReadOnly Property Graphics As Graphics
[C#]
public Graphics Graphics {get;}
[C++]
public: __property Graphics* get_Graphics();
[JScript]
public function get Graphics() : Graphics;

Property Value

The Graphics used to paint the item.

See Also

PrintPageEventArgs Class | PrintPageEventArgs Members | System.Drawing.Printing Namespace | Graphics


PrintPageEventArgs.HasMorePages

Gets or sets a value indicating whether there is an additional page to be printed.

[Visual Basic]
Public Property HasMorePages As Boolean
[C#]
public bool HasMorePages {get; set;}
[C++]
public: __property bool get_HasMorePages();
public: __property void set_HasMorePages(bool);
[JScript]
public function get HasMorePages() : Boolean;
public function set HasMorePages(Boolean);

Property Value

true if an additional page to be printed; otherwise, false. The default is false.

See Also

PrintPageEventArgs Class | PrintPageEventArgs Members | System.Drawing.Printing Namespace


PrintPageEventArgs.MarginBounds

Gets the rectangular area that represents the page between the margins.

[Visual Basic]
Public ReadOnly Property MarginBounds As Rectangle
[C#]
public Rectangle MarginBounds {get;}
[C++]
public: __property Rectangle get_MarginBounds();
[JScript]
public function get MarginBounds() : Rectangle;

Property Value

The rectangular area that represents the page between the margins.

See Also

PrintPageEventArgs Class | PrintPageEventArgs Members | System.Drawing.Printing Namespace | Rectangle


PrintPageEventArgs.PageBounds

Gets the rectangular area that represents the total area of the page.

[Visual Basic]
Public ReadOnly Property PageBounds As Rectangle
[C#]
public Rectangle PageBounds {get;}
[C++]
public: __property Rectangle get_PageBounds();
[JScript]
public function get PageBounds() : Rectangle;

Property Value

The rectangular area that represents the total area of the page.

Remarks

Note Most printers cannot print at the very edge of the page.

See Also

PrintPageEventArgs Class | PrintPageEventArgs Members | System.Drawing.Printing Namespace | Rectangle


PrintPageEventArgs.PageSettings

Specifieds the page settings for the current page.

[Visual Basic]
Public ReadOnly Property PageSettings As PageSettings
[C#]
public PageSettings PageSettings {get;}
[C++]
public: __property PageSettings* get_PageSettings();
[JScript]
public function get PageSettings() : PageSettings;

Property Value

The page settings for the current page.

See Also

PrintPageEventArgs Class | PrintPageEventArgs Members | System.Drawing.Printing Namespace | PageSettings


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PrintPageEventArgs Methods

The methods of the PrintPageEventArgs class are listed below. For a complete list of PrintPageEventArgs class members, see the PrintPageEventArgs Members topic.

Public:

Dispose | Disposes of the resources (other than memory) used by the PrintPageEventArgs.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PrintPageEventArgs Class | System.Drawing.Printing Namespace


PrintPageEventArgs.Dispose

Disposes of the resources (other than memory) used by the PrintPageEventArgs.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[JScript]
public function Dispose();

Remarks

Call Dispose when you are finished using the PrintPageEventArgs. The Dispose method leaves the PrintPageEventArgs in an unusable state. After calling Dispose, you must release all references to the PrintPageEventArgs so the memory it was occupying can be reclaimed by garbage collection.

Note Dispose before you release your last reference to the PrintPageEventArgs. Otherwise, the resources the PrintPageEventArgs is using will not be freed until garbage collection calls the PrintPageEventArgs object's destructor.

See Also

PrintPageEventArgs Class | PrintPageEventArgs Members | System.Drawing.Printing Namespace


PrintPageEventHandler Delegate

Represents the method that will handle the System.Drawing.Printing.PrintDocument.PrintPage event of a PrintDocument.

[Visual Basic]
Public Delegate Sub PrintPageEventHandler( _
   ByVal sender As Object, _
   ByVal e As PrintPageEventArgs _
)
[C#]
public delegate void PrintPageEventHandler(
   object sender,
   PrintPageEventArgs e
);
[C++]
public __gc __delegate void PrintPageEventHandler(
   Object* sender,
   PrintPageEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the PrintPageEventHandler delegate declaration.

sender
The source of the event.
e
A PrintPageEventArgs that contains the event data.

Remarks

When you create a System.WinForms.PrintPageEventHandler delegate, you identify the method that will handle the event. To associate the event with your event-handling method, add an instance of the delegate to the event. The event-handling method is called whenever the event occurs, unless you remove the delegate. For more information about handling events with delegates, see TBD.

Requirements

Namespace: System.Drawing.Printing

Assembly: System.Drawing.dll

See Also

System.Drawing.Printing Namespace | OnPrintPage | System.WinForms.PrintDocument.PrintPage | System.WinForms.PrintPageEventArgs


PrintRange Enumeration

Specifies the option buttons in the print dialog box that designate the part of the document to print.

[Visual Basic]
Public Enum PrintRange
[C#]
public enum PrintRange
[C++]
public enum PrintRange

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

PrinterSettings uses this enumeration.

Members

Member Name | Description
AllPages | All pages are printed.
Selection | The selected pages are printed.
SomePages | The pages specified by FromPage and ToPage are printed.

Requirements

Namespace: System.Drawing.Printing

Assembly: System.Drawing.dll

See Also

System.Drawing.Printing Namespace | PrinterSettings


QueryPageSettingsEventArgs Class

Provides data for the System.Drawing.Printing.PrintDocument.QueryPageSettings event.

Object
EventArgs
CancelEventArgs
PrintEventArgs
QueryPageSettingsEventArgs

[Visual Basic]
Public Class QueryPageSettingsEventArgs
   Inherits PrintEventArgs
[C#]
public class QueryPageSettingsEventArgs : PrintEventArgs
[C++]
public __gc class QueryPageSettingsEventArgs : public
   PrintEventArgs
[JScript]
public class QueryPageSettingsEventArgs extends PrintEventArgs

Remarks

For more information about handling events with delegates, see TBD.

Requirements

Namespace: System.Drawing.Printing

Assembly: System.Drawing.dll

See Also

QueryPageSettingsEventArgs Members | System.Drawing.Printing Namespace | PrintDocument | OnQueryPageSettings | System.Drawing.Printing.PrintDocument.QueryPageSettings | QueryPageSettingsEventHandler


QueryPageSettingsEventArgs Members

Public:

Constructor

QueryPageSettingsEventArgs Constructor Initializes a new instance of the QueryPageSettingsEventArgs class.

Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the operation should be cancelled.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
PageSettings | Gets or sets the page settings for the page to be printed.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

QueryPageSettingsEventArgs Class | System.Drawing.Printing Namespace


QueryPageSettingsEventArgs Constructor

Initializes a new instance of the QueryPageSettingsEventArgs class.

[Visual Basic]
Public Sub New( _
   ByVal pageSettings As PageSettings _
)
[C#]
public QueryPageSettingsEventArgs(
   PageSettings pageSettings
);
[C++]
public: QueryPageSettingsEventArgs(
   PageSettings* pageSettings
);
[JScript]
public function QueryPageSettingsEventArgs(
   pageSettings : PageSettings
);

Parameters

pageSettings
The page settings for the page to be printed.

Remarks

PrintEventArgs is

See Also

QueryPageSettingsEventArgs Class | QueryPageSettingsEventArgs Members | System.Drawing.Printing Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

QueryPageSettingsEventArgs Properties

The properties of the QueryPageSettingsEventArgs class are listed below. For a complete list of QueryPageSettingsEventArgs class members, see the QueryPageSettingsEventArgs Members topic.

Public:

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the operation should be cancelled.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
PageSettings | Gets or sets the page settings for the page to be printed.

See Also

QueryPageSettingsEventArgs Class | System.Drawing.Printing Namespace


QueryPageSettingsEventArgs.PageSettings

Gets or sets the page settings for the page to be printed.

[Visual Basic]
Public Property PageSettings As PageSettings
[C#]
public PageSettings PageSettings {get; set;}
[C++]
public: __property PageSettings* get_PageSettings();
public: __property void set_PageSettings(PageSettings*);
[JScript]
public function get PageSettings() : PageSettings;
public function set PageSettings(PageSettings);

Property Value

The page settings for the page to be printed.

See Also

QueryPageSettingsEventArgs Class | QueryPageSettingsEventArgs Members | System.Drawing.Printing Namespace | PageSettings


QueryPageSettingsEventHandler Delegate

Represents the method that will handle the System.Drawing.Printing.PrintDocument.QueryPageSettings event of a PrintDocument.

[Visual Basic]
Public Delegate Sub QueryPageSettingsEventHandler( _
   ByVal sender As Object, _
   ByVal e As QueryPageSettingsEventArgs _
)
[C#]
public delegate void QueryPageSettingsEventHandler(
   object sender,
   QueryPageSettingsEventArgs e
);
[C++]
public __gc __delegate void QueryPageSettingsEventHandler(
   Object* sender,
   QueryPageSettingsEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the QueryPageSettingsEventHandler delegate declaration.

sender
The source of the event.
e
A QueryPageSettingsEventArgs that contains the event data.

Remarks

When you create a System.WinForms.QueryPageSettingsEventHandler delegate, you identify the method that will handle the event. To associate the event with your event-handling method, add an instance of the delegate to the event. The event-handling method is called whenever the event occurs, unless you remove the delegate. For more information about handling events with delegates, see TBD.

Requirements

Namespace: System.Drawing.Printing

Assembly: System.Drawing.dll

See Also

System.Drawing.Printing Namespace | System.WinForms.PrintDocument | System.WinForms.PrintDocument.OnQueryPageSettings | System.WinForms.PrintDocument.QueryPageSettings | System.WinForms.QueryPageSettingsEventArgs


StandardPrintController Class

Specifies a print controller that sends information to a printer.

Object
PrintController
StandardPrintController

[Visual Basic]
Public Class StandardPrintController
   Inherits PrintController
[C#]
public class StandardPrintController : PrintController
[C++]
public __gc class StandardPrintController : public PrintController
[JScript]
public class StandardPrintController extends PrintController

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Printing

Assembly: System.Drawing.dll

See Also

StandardPrintController Members | System.Drawing.Printing Namespace


StandardPrintController Members

Public:

Constructor

StandardPrintController Constructor [To be supplied.]

Methods

EndPage (inherited from PrintController) | Called immediately after the PrintDocument's PrintPage event is raised. If an exception is thrown inside the PrintDocument's PrintPage event, this method will not be called.
EndPrint (inherited from PrintController) | Called immediately after the PrintDocument's EndPrint event is raised. This method will be called even if an uncaught exception was thrown while printing.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
StartPage (inherited from PrintController) | Called immediately before the PrintDocument's PrintPage event is raised.
StartPrint (inherited from PrintController) | Called immediately after the PrintDocument's OnBeginPrint event is raised. Consider checking whether the PrinterSettings are valid.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StandardPrintController Class | System.Drawing.Printing Namespace


StandardPrintController Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public StandardPrintController();
[C++]
public: StandardPrintController();
[JScript]
public function StandardPrintController();

See Also

StandardPrintController Class | StandardPrintController Members | System.Drawing.Printing Namespace


System.Drawing.Text

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Drawing.Text Namespace

Classes

Class | Description
FontCollection | When inherited, enumerates the FontFamily objects in a collection of fonts.
InstalledFontCollection | [To be supplied.]
PrivateFontCollection | [To be supplied.]

Enumerations

Enumeration | Description
GenericFontFamilies | Specifies a generic FontFamily.
HotkeyPrefix | [To be supplied.]
LineSpacing | [To be supplied.]
TextRenderingHint | [To be supplied.]


FontCollection Class

When inherited, enumerates the FontFamily objects in a collection of fonts.

Object
FontCollection

[Visual Basic]
MustInherit Public Class FontCollection
[C#]
public abstract class FontCollection
[C++]
public __gc __abstract class FontCollection
[JScript]
public abstract class FontCollection

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Text

Assembly: System.Drawing.dll

See Also

FontCollection Members | System.Drawing.Text Namespace


FontCollection Members

Public:

Properties

Families Gets the array of FontFamily objects associated with this FontCollection.

Methods

Dispose | Disposes of this FontCollection
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize | Allows an object to free resources before the object is reclaimed by the Garbage Collector (GC).
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FontCollection Class | System.Drawing.Text Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

FontCollection Properties

The properties of the FontCollection class are listed below. For a complete list of FontCollection class members, see the FontCollection Members topic.

Public:

Families Gets the array of FontFamily objects associated with this FontCollection.

See Also

FontCollection Class | System.Drawing.Text Namespace


FontCollection.Families

Gets the array of FontFamily objects associated with this FontCollection.

[Visual Basic]
Public ReadOnly Property Families As FontFamily ()
[C#]
public FontFamily[] Families {get;}
[C++]
public: __property FontFamily* get_Families();
[JScript]
public function get Families() : FontFamily[];

Property Value

An array of System.Drawing.Text.FontFamily objects.

See Also

FontCollection Class | FontCollection Members | System.Drawing.Text Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

FontCollection Methods

The methods of the FontCollection class are listed below. For a complete list of FontCollection class members, see the FontCollection Members topic.

Public:

Dispose | Disposes of this FontCollection
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize | Allows an object to free resources before the object is reclaimed by the Garbage Collector (GC).
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FontCollection Class | System.Drawing.Text Namespace


FontCollection.Dispose

Disposes of this FontCollection

[Visual Basic]
Overridable Public Sub Dispose()
[C#]
public virtual void Dispose();
[C++]
public: virtual void Dispose();
[JScript]
public function Dispose();

See Also

FontCollection Class | FontCollection Members | System.Drawing.Text Namespace


FontCollection.Finalize

Allows an object to free resources before the object is reclaimed by the Garbage Collector (GC).

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

FontCollection Class | FontCollection Members | System.Drawing.Text Namespace


GenericFontFamilies Enumeration

Specifies a generic FontFamily.

[Visual Basic]
Public Enum GenericFontFamilies
[C#]
public enum GenericFontFamilies
[C++]
public enum GenericFontFamilies

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Monospace | A generic Monospace FontFamily.
SansSerif | A generic SansSerif FontFamily.
Serif | A generic Serif FontFamily.

Requirements

Namespace: System.Drawing.Text

Assembly: System.Drawing.dll

See Also

System.Drawing.Text Namespace


HotkeyPrefix Enumeration

[To be supplied.]

[Visual Basic]
Public Enum HotkeyPrefix
[C#]
public enum HotkeyPrefix
[C++]
public enum HotkeyPrefix

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Hide | [To be supplied.]
None | [To be supplied.]
Show | [To be supplied.]

Requirements

Namespace: System.Drawing.Text

Assembly: System.Drawing.dll

See Also

System.Drawing.Text Namespace


InstalledFontCollection Class

[To be supplied.]

Object
FontCollection
InstalledFontCollection

[Visual Basic]
NotInheritable Public Class InstalledFontCollection
   Inherits FontCollection
[C#]
public sealed class InstalledFontCollection : FontCollection
[C++]
public __gc __sealed class InstalledFontCollection : public
   FontCollection
[JScript]
public class InstalledFontCollection extends FontCollection

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Text

Assembly: System.Drawing.dll

See Also

InstalledFontCollection Members | System.Drawing.Text Namespace


InstalledFontCollection Members

Public:

Constructor

InstalledFontCollection Constructor [To be supplied.]

Properties

Families (inherited from FontCollection) Gets the array of FontFamily objects associated with this FontCollection.

Methods

Dispose (inherited from FontCollection) | Disposes of this FontCollection
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from FontCollection) | Allows an object to free resources before the object is reclaimed by the Garbage Collector (GC).
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InstalledFontCollection Class | System.Drawing.Text Namespace


InstalledFontCollection Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public InstalledFontCollection();
[C++]
public: InstalledFontCollection();
[JScript]
public function InstalledFontCollection();

See Also

InstalledFontCollection Class | InstalledFontCollection Members | System.Drawing.Text Namespace


LineSpacing Enumeration

[To be supplied.]

[Visual Basic]
Public Enum LineSpacing
[C#]
public enum LineSpacing
[C++]
public enum LineSpacing

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
AtLeast | [To be supplied.]
AtLeastMultiple | [To be supplied.]
Cell | [To be supplied.]
CellAtLeast | [To be supplied.]
CellAtLeastMultiple | [To be supplied.]
Display | [To be supplied.]
Document | [To be supplied.]
Inch | [To be supplied.]
Millimeter | [To be supplied.]
Pixel | [To be supplied.]
Point | [To be supplied.]
Recommended | [To be supplied.]
World | [To be supplied.]

Requirements

Namespace: System.Drawing.Text

Assembly: System.Drawing.dll

See Also

System.Drawing.Text Namespace


PrivateFontCollection Class

[To be supplied.]

Object
FontCollection
PrivateFontCollection

[Visual Basic]
NotInheritable Public Class PrivateFontCollection
   Inherits FontCollection
[C#]
public sealed class PrivateFontCollection : FontCollection
[C++]
public __gc __sealed class PrivateFontCollection : public
   FontCollection
[JScript]
public class PrivateFontCollection extends FontCollection

Remarks

[To be supplied.]

Requirements

Namespace: System.Drawing.Text

Assembly: System.Drawing.dll

See Also

PrivateFontCollection Members | System.Drawing.Text Namespace


PrivateFontCollection Members

Public:

Constructor

PrivateFontCollection Constructor [To be supplied.]

Properties

Families (inherited from FontCollection) Gets the array of FontFamily objects associated with this FontCollection.

Methods

AddFontFile | [To be supplied.]
AddMemoryFont | [To be supplied.]
Dispose | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from FontCollection) | Allows an object to free resources before the object is reclaimed by the Garbage Collector (GC).
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PrivateFontCollection Class | System.Drawing.Text Namespace


PrivateFontCollection Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public PrivateFontCollection();
[C++]
public: PrivateFontCollection();
[JScript]
public function PrivateFontCollection();

See Also

PrivateFontCollection Class | PrivateFontCollection Members | System.Drawing.Text Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PrivateFontCollection Methods

The methods of the PrivateFontCollection class are listed below. For a complete list of PrivateFontCollection class members, see the PrivateFontCollection Members topic.

Public:

AddFontFile | [To be supplied.]
AddMemoryFont | [To be supplied.]
Dispose | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from FontCollection) | Allows an object to free resources before the object is reclaimed by the Garbage Collector (GC).
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PrivateFontCollection Class | System.Drawing.Text Namespace


PrivateFontCollection.AddFontFile

[To be supplied.]

[Visual Basic]
Public Sub AddFontFile( _
   ByVal filename As String _
)
[C#]
public void AddFontFile(
   string filename
);
[C++]
public: void AddFontFile(
   String* filename
);
[JScript]
public function AddFontFile(
   filename : String
);

Parameters

filename
[To be supplied.]

See Also

PrivateFontCollection Class | PrivateFontCollection Members | System.Drawing.Text Namespace


PrivateFontCollection.AddMemoryFont

[To be supplied.]

[Visual Basic]
Public Sub AddMemoryFont( _
   ByVal memory As Integer, _
   ByVal length As Integer _
)
[C#]
public void AddMemoryFont(
   int memory,
   int length
);
[C++]
public: void AddMemoryFont(
   int memory,
   int length
);
[JScript]
public function AddMemoryFont(
   memory : int,
   length : int
);

Parameters

memory
[To be supplied.]
length
[To be supplied.]

See Also

PrivateFontCollection Class | PrivateFontCollection Members | System.Drawing.Text Namespace


PrivateFontCollection.Dispose

[To be supplied.]

[Visual Basic]
Overrides Public Sub Dispose()
[C#]
public override void Dispose();
[C++]
public: override void Dispose();
[JScript]
public override function Dispose();

See Also

PrivateFontCollection Class | PrivateFontCollection Members | System.Drawing.Text Namespace


TextRenderingHint Enumeration

[To be supplied.]

[Visual Basic]
Public Enum TextRenderingHint
[C#]
public enum TextRenderingHint
[C++]
public enum TextRenderingHint

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
AntiAlias | [To be supplied.]
AntiAliasGridFit | [To be supplied.]
ClearTypeGridFit | [To be supplied.]
SingleBitPerPixel | [To be supplied.]
SingleBitPerPixelGridFit | [To be supplied.]

Requirements

Namespace: System.Drawing.Text

Assembly: System.Drawing.dll

See Also

System.Drawing.Text Namespace


System.Globalization

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Globalization Namespace

Classes

Class | Description
Calendar | [To be supplied.]
CalendarTable | [To be supplied.]
CharacterInfo | [To be supplied.]
CodePageEncoding | [To be supplied.]
CompareInfo | [To be supplied.]
CultureInfo | [To be supplied.]
DateTimeFormatInfo | [To be supplied.]
GregorianCalendar | [To be supplied.]
HebrewCalendar | [To be supplied.]
HijriCalendar | [To be supplied.]
JapaneseCalendar | [To be supplied.]
JulianCalendar | [To be supplied.]
KoreanCalendar | [To be supplied.]
NumberFormatInfo | [To be supplied.]
RegionInfo | [To be supplied.]
SortKey | [To be supplied.]
StringInfo | [To be supplied.]
TextElementEnumerator | [To be supplied.]
TextInfo | [To be supplied.]
ThaiBuddhistCalendar | [To be supplied.]

Structures

Structure | Description
DaylightTime | [To be supplied.]

Enumerations

Enumeration | Description
CompareOptions | [To be supplied.]
CultureTypes | [To be supplied.]
DateTimeStyles | [To be supplied.]
GregorianCalendarTypes | [To be supplied.]
NumberStyles | Determines the style permitted in numerical string arguments that are passed to the Parse methods of the numeric base type classes.
UnicodeCategory | [To be supplied.]


Calendar Class

[To be supplied.]

Object
Calendar

[Visual Basic]
MustInherit Public Class Calendar
[C#]
public abstract class Calendar
[C++]
public __gc __abstract class Calendar
[JScript]
public abstract class Calendar

Remarks

A calendar reckons time in divisions such as weeks, months and years. The number, length, and start of the divisions vary in each calendar.

Any instant in time can be represented as an n-tuple of numeric values using a particular calendar. For example, the next vernal equinox occurs at [RB2] (0.0, 0[RB3], 46, 8, 20, 3, 1999) in the Gregorian calendar. An implementation of Calendar can map any DateTime value to such an n-tuple [RB4] and vice versa. The DateTimeFormat class can map between such n-tuples and a textual representation such as "8:46 AM March 20th 1999 AD".

Most [RB5] calendars identify a year that begins the current era. There may be any number of previous eras. The Calendar class identifies the eras as enumerated integers where the current era (CurrentEra) has the value 0.

For consistency, the first unit in each interval (for example, the first month) is assigned the value 1.

The System.Globalization package provides implementations of the GregorianCalendar and JulianCalendar calendars.

Requirements

Namespace: System.Globalization

Assembly: mscorlib.dll

See Also

Calendar Members | System.Globalization Namespace


Calendar Members

Public:

Properties

Eras | [To be supplied.]
TwoDigitYearMax | Gets and sets the maximum value to represent a 2-digit year.

Methods

AddDays | Returns the DateTime object resulting from adding a fractional number of days to the specified DateTime.
AddHours | Returns the DateTime resulting from adding a fractional number of hours to the specified DateTime.
AddMilliseconds | Returns the DateTime resulting from adding the specified number of milliseconds to the specified DateTime.
AddMinutes | Returns the DateTime resulting from adding a fractional number of minutes to the specified DateTime.
AddMonths | Returns the DateTime resulting from adding the specified number of months to the specified DateTime.
AddSeconds | Returns the DateTime resulting from adding a number of seconds to the specified DateTime.
AddWeeks | Returns the DateTime resulting from adding a number of weeks to the specified DateTime.
AddYears | Returns the DateTime resulting from adding the specified number of years to the specified DateTime.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDayOfMonth | Returns the day-of-month part of the specified DateTime.
GetDayOfWeek | Returns the day-of-week part of the specified DateTime.
GetDayOfYear | Returns the day-of-year part of the specified DateTime.
GetDaysInMonth | Overloaded. Returns the number of days in the specified month.
GetDaysInYear | Overloaded. [To be supplied.]
GetEra | Overloaded. [To be supplied.]
GetEraName | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHour | Returns the hour part of the specified DateTime.
GetMilliseconds | Returns the millisecond part of the specified DateTime.
GetMinute | Returns the minute part of the specified DateTime.
GetMonth | Returns the month part of the specified DateTime.
GetMonthsInYear | Overloaded. [To be supplied.]
GetSecond | Returns the second [RB26] part of the specified DateTime.
GetType (inherited from Object) | Gets the Type of the Object.
GetWeekOfYear | Returns the week of year for the specified DateTime.
GetYear | Returns the year part of the specified DateTime.
IsLeapDay | Overloaded. [To be supplied.]
IsLeapMonth | Overloaded. [To be supplied.]
IsLeapYear | Overloaded. [To be supplied.]
ToDateTime | Overloaded. Returns [RB39] the date and time converted to a DateTime value.
ToFourDigitYear | Converts the specified year to the appropriate century by using the TwoDigitYearMax property.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

CurrentEra Represents the current era for the current calendar.

Protected:

Constructor

Calendar Constructor [To be supplied.]

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Calendar Class | System.Globalization Namespace


Calendar Constructor

[To be supplied.]

[Visual Basic]
Protected Sub New()
[C#]
protected Calendar();
[C++]
protected: Calendar();
[JScript]
protected function Calendar();

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Calendar Properties

The properties of the Calendar class are listed below. For a complete list of Calendar class members, see the Calendar Members topic.

Public:

Eras | [To be supplied.]
TwoDigitYearMax | Gets and sets the maximum value to represent a 2-digit year.

See Also

Calendar Class | System.Globalization Namespace


Calendar.Eras

[To be supplied.]

[Visual Basic]
MustOverride Public ReadOnly Property Eras As Integer ()
[C#]
public int[] Eras {abstract get;}
[C++]
public: __property virtual int* get_Eras() = 0;
[JScript]
public abstract function get Eras() : int[];

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Calendar.TwoDigitYearMax

Gets and sets the maximum value to represent a 2-digit year.

[Visual Basic]
Overridable Public Property TwoDigitYearMax As Integer
[C#]
public int TwoDigitYearMax {virtual get; virtual set;}
[C++]
public: __property virtual int get_TwoDigitYearMax();
public: __property virtual void set_TwoDigitYearMax(int);
[JScript]
public function get TwoDigitYearMax() : int;
public function set TwoDigitYearMax(int);

Property Value

Gets and sets[RB11] the maximum value to represent a 2-digit year.

Remarks

This value is the upper boundary of a 100-year range that allows a 2-digit year to be properly translated to a 4-digit year. For example, if 2029 is the upper boundary, a 2-digit value of 30 should be interpreted as 1930 while a 2-digit value of 29 should be interpreted as 2029. In this example, the 100-year range would be from 1930 through 2029.

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Calendar Methods

The methods of the Calendar class are listed below. For a complete list of Calendar class members, see the Calendar Members topic.

Public:

AddDays | Returns the DateTime object resulting from adding a fractional number of days to the specified DateTime.
AddHours | Returns the DateTime resulting from adding a fractional number of hours to the specified DateTime.
AddMilliseconds | Returns the DateTime resulting from adding the specified number of milliseconds to the specified DateTime.
AddMinutes | Returns the DateTime resulting from adding a fractional number of minutes to the specified DateTime.
AddMonths | Returns the DateTime resulting from adding the specified number of months to the specified DateTime.
AddSeconds | Returns the DateTime resulting from adding a number of seconds to the specified DateTime.
AddWeeks | Returns the DateTime resulting from adding a number of weeks to the specified DateTime.
AddYears | Returns the DateTime resulting from adding the specified number of years to the specified DateTime.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDayOfMonth | Returns the day-of-month part of the specified DateTime.
GetDayOfWeek | Returns the day-of-week part of the specified DateTime.
GetDayOfYear | Returns the day-of-year part of the specified DateTime.
GetDaysInMonth | Overloaded. Returns the number of days in the specified month.
GetDaysInYear | Overloaded. [To be supplied.]
GetEra | Overloaded. [To be supplied.]
GetEraName | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHour | Returns the hour part of the specified DateTime.
GetMilliseconds | Returns the millisecond part of the specified DateTime.
GetMinute | Returns the minute part of the specified DateTime.
GetMonth | Returns the month part of the specified DateTime.
GetMonthsInYear | Overloaded. [To be supplied.]
GetSecond | Returns the second [RB26] part of the specified DateTime.
GetType (inherited from Object) | Gets the Type of the Object.
GetWeekOfYear | Returns the week of year for the specified DateTime.
GetYear | Returns the year part of the specified DateTime.
IsLeapDay | Overloaded. [To be supplied.]
IsLeapMonth | Overloaded. [To be supplied.]
IsLeapYear | Overloaded. [To be supplied.]
ToDateTime | Overloaded. Returns [RB39] the date and time converted to a DateTime value.
ToFourDigitYear | Converts the specified year to the appropriate century by using the TwoDigitYearMax property.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Calendar Class | System.Globalization Namespace


Calendar.AddDays

Returns the DateTime object resulting from adding a fractional number of days to the specified DateTime.

[Visual Basic]
Overridable Public Function AddDays( _
   ByVal time As DateTime, _
   ByVal days As Integer _
) As DateTime
[C#]
public virtual DateTime AddDays(
   DateTime time,
   int days
);
[C++]
public: virtual DateTime AddDays(
   DateTime time,
   int days
);
[JScript]
public function AddDays(
   time : DateTime,
   days : int
) : DateTime;

Parameters

time
The DateTime instance to be added.
days
The number of days.

Return Value

The DateTime resulting from adding the specified fractional number of days to the specified DateTime.

Exceptions

Exception Type | Condition
ArgumentException | is thrown if the resulting DateTime is outside the supported range.

Remarks

The result is computed by rounding the fractional number of days specified by days to the nearest millisecond, and adding that interval to the specified DateTime. The days argument is permitted to be negative.

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Calendar.AddHours

Returns the DateTime resulting from adding a fractional number of hours to the specified DateTime.

[Visual Basic]
Overridable Public Function AddHours( _
   ByVal time As DateTime, _
   ByVal hours As Integer _
) As DateTime
[C#]
public virtual DateTime AddHours(
   DateTime time,
   int hours
);
[C++]
public: virtual DateTime AddHours(
   DateTime time,
   int hours
);
[JScript]
public function AddHours(
   time : DateTime,
   hours : int
) : DateTime;

Parameters

time
The DateTime instance to be added.
hours
The number of hours.

Return Value

The DateTime resulting from adding the specified fractional number of hours to the specified DateTime.

Exceptions

Exception Type | Condition
ArgumentException | is thrown if the resulting DateTime is outside the supported range.

Remarks

The result is computed by rounding the fractional number of hours specified by hours to the nearest millisecond, and adding that interval to the specified DateTime. The hours argument is permitted to be negative.

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Calendar.AddMilliseconds

Returns the DateTime resulting from adding the specified number of milliseconds to the specified DateTime.

[Visual Basic]
Overridable Public Function AddMilliseconds( _
   ByVal time As DateTime, _
   ByVal milliseconds As Double _
) As DateTime
[C#]
public virtual DateTime AddMilliseconds(
   DateTime time,
   double milliseconds
);
[C++]
public: virtual DateTime AddMilliseconds(
   DateTime time,
   double milliseconds
);
[JScript]
public function AddMilliseconds(
   time : DateTime,
   milliseconds : double
) : DateTime;

Parameters

time
The DateTime instance to be added.
milliseconds
A number of milliseconds.

Return Value

The DateTime resulting from adding the specified number of milliseconds to the specified DateTime.

Exceptions

Exception Type | Condition
ArgumentException | is thrown if the resulting DateTime is outside the supported range.

Remarks

The result is computed by rounding milliseconds to the nearest integer, and adding that interval to the specified DateTime. The milliseconds argument is permitted to be negative.

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Calendar.AddMinutes

Returns the DateTime resulting from adding a fractional number of minutes to the specified DateTime.

[Visual Basic]
Overridable Public Function AddMinutes( _
   ByVal time As DateTime, _
   ByVal minutes As Integer _
) As DateTime
[C#]
public virtual DateTime AddMinutes(
   DateTime time,
   int minutes
);
[C++]
public: virtual DateTime AddMinutes(
   DateTime time,
   int minutes
);
[JScript]
public function AddMinutes(
   time : DateTime,
   minutes : int
) : DateTime;

Parameters

time
The DateTime instance to be added.
minutes
A fractional number of minutes.

Return Value

The DateTime resulting from adding a fractional number of minutes to the specified DateTime.

Exceptions

Exception Type | Condition
ArgumentException | is thrown if the resulting DateTime is outside the supported range.

Remarks

The result is computed by rounding the fractional number of minutes specified by minutes to the nearest millisecond, and adding that interval to the specified DateTime. The minutes argument is permitted to be negative.

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Calendar.AddMonths

Returns the DateTime resulting from adding the specified number of months to the specified DateTime.

[Visual Basic]
MustOverride Public Function AddMonths( _
   ByVal time As DateTime, _
   ByVal months As Integer _
) As DateTime
[C#]
public abstract DateTime AddMonths(
   DateTime time,
   int months
);
[C++]
public: virtual DateTime AddMonths(
   DateTime time,
   int months
) = 0;
[JScript]
public abstract function AddMonths(
   time : DateTime,
   months : int
) : DateTime;

Parameters

time
The DateTime instance to be added.
months
A number of months (positive or negative).

Return Value

The DateTime resulting from adding the specified number of months to the specified DateTime.

Exceptions

Exception Type | Condition
ArgumentException | is thrown if the resulting DateTime is outside the supported range.

Remarks

The result is computed by incrementing (or decrementing) the year and month parts of the specified DateTime by months months, and, if required, adjusting the day part of the resulting date downwards to the last day of the resulting month in the resulting year. The time-of-day part of the result is the same as the time-of-day part of the specified DateTime.

In more precise terms, considering the specified DateTime to be of the form y/ m/ d + t, where y is the year, m is the month, d is the day, and t is the time-of-day, the result is y1/ m1/ d1 + t, where y1 and m1 are computed by adding value months to y and m, and d1 is the largest value less than or equal to d that denotes a valid day in month m1 of year y1.[RB12]

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Calendar.AddSeconds

Returns the DateTime resulting from adding a number of seconds to the specified DateTime.

[Visual Basic]
Overridable Public Function AddSeconds( _
   ByVal time As DateTime, _
   ByVal value As Integer _
) As DateTime
[C#]
public virtual DateTime AddSeconds(
   DateTime time,
   int value
);
[C++]
public: virtual DateTime AddSeconds(
   DateTime time,
   int value
);
[JScript]
public function AddSeconds(
   time : DateTime,
   value : int
) : DateTime;

Parameters

time
The DateTime instance to be added.
value
A number of seconds.

Return Value

The DateTime resulting from adding the specified fractional number of seconds to the specified DateTime.

Exceptions

Exception Type | Condition
ArgumentException | is thrown if the resulting DateTime is outside the supported range.

Remarks

The result is computed by rounding the fractional number of seconds specified by seconds to the nearest millisecond, and adding that interval to the specified DateTime. The value argument is permitted to be negative.

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Calendar.AddWeeks

Returns the DateTime resulting from adding a number of weeks to the specified DateTime.

[Visual Basic]
Overridable Public Function AddWeeks( _
   ByVal time As DateTime, _
   ByVal weeks As Integer _
) As DateTime
[C#]
public virtual DateTime AddWeeks(
   DateTime time,
   int weeks
);
[C++]
public: virtual DateTime AddWeeks(
   DateTime time,
   int weeks
);
[JScript]
public function AddWeeks(
   time : DateTime,
   weeks : int
) : DateTime;

Parameters

time
The DateTime instance to be added.
weeks
A number of weeks.

Return Value

The DateTime resulting from adding the specified number of weeks to the specified DateTime.

Exceptions

Exception Type | Condition
ArgumentException | is thrown if the resulting DateTime is outside the supported range.

Remarks

The value argument is permitted to be negative.

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Calendar.AddYears

Returns the DateTime resulting from adding the specified number of years to the specified DateTime.

[Visual Basic]
MustOverride Public Function AddYears( _
   ByVal time As DateTime, _
   ByVal years As Integer _
) As DateTime
[C#]
public abstract DateTime AddYears(
   DateTime time,
   int years
);
[C++]
public: virtual DateTime AddYears(
   DateTime time,
   int years
) = 0;
[JScript]
public abstract function AddYears(
   time : DateTime,
   years : int
) : DateTime;

Parameters

time
The DateTime instance to be added.
years
A number of years (positive or negative).

Return Value

The DateTime resulting from adding the specified number of years to the specified DateTime.

Exceptions

Exception Type | Condition
ArgumentException | is thrown if the resulting DateTime is outside the supported range.

Remarks

The result is computed by incrementing (or decrementing) the year part of the specified DateTime by years years. If the month and day of the specified DateTime is 2/29, and if the resulting year is not a leap year, the month and day of the resulting DateTime becomes 2/28. Otherwise, the month, day, and time-of-day parts of the result are the same as those of the specified DateTime.

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Calendar.GetDayOfMonth

Returns the day-of-month part of the specified DateTime.

[Visual Basic]
MustOverride Public Function GetDayOfMonth( _
   ByVal time As DateTime _
) As Integer
[C#]
public abstract int GetDayOfMonth(
   DateTime time
);
[C++]
public: virtual int GetDayOfMonth(
   DateTime time
) = 0;
[JScript]
public abstract function GetDayOfMonth(
   time : DateTime
) : int;

Parameters

time
The DateTime instance.

Return Value

The 1-based day-of-month part of time. The returned value is an integer between 1 and 31[RB13] .

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Calendar.GetDayOfWeek

Returns the day-of-week part of the specified DateTime.

[Visual Basic]
MustOverride Public Function GetDayOfWeek( _
   ByVal time As DateTime _
) As Integer
[C#]
public abstract int GetDayOfWeek(
   DateTime time
);
[C++]
public: virtual int GetDayOfWeek(
   DateTime time
) = 0;
[JScript]
public abstract function GetDayOfWeek(
   time : DateTime
) : int;

Parameters

time
The DateTime instance.

Return Value

The 0-based day-of-week part of the time.

Remarks

The returned value is an integer between 0 and 6[RB14], where 0 indicates Sunday, 1 indicates Monday, 2 indicates Tuesday, 3 indicates Wednesday, 4 indicates Thursday, 5 indicates Friday, and 6 indicates Saturday.

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Calendar.GetDayOfYear

Returns the day-of-year part of the specified DateTime.

[Visual Basic]
MustOverride Public Function GetDayOfYear( _
   ByVal time As DateTime _
) As Integer
[C#]
public abstract int GetDayOfYear(
   DateTime time
);
[C++]
public: virtual int GetDayOfYear(
   DateTime time
) = 0;
[JScript]
public abstract function GetDayOfYear(
   time : DateTime
) : int;

Parameters

time
The DateTime instance.

Return Value

The 1-based day-of-year part of the time.

Remarks

The returned value is an integer between 1 and 366[RB15] .

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Calendar.GetDaysInMonth

Returns the number of days in the specified month.

Overload List

Returns the number of days in the month specified by the specified year, month and era.

[Visual Basic] Overloads MustOverride Public Function GetDaysInMonth(Integer, Integer, Integer) As Integer
[C#] public abstract int GetDaysInMonth(int, int, int);
[C++] public: virtual int GetDaysInMonth(int, int, int) = 0;
[JScript] public abstract function GetDaysInMonth(int, int, int) : int;

Returns the number of days in the month specified by the year and month parameters.

[Visual Basic] Overloads Overridable Public Function GetDaysInMonth(Integer, Integer) As Integer
[C#] public virtual int GetDaysInMonth(int, int);
[C++] public: virtual int GetDaysInMonth(int, int);
[JScript] public function GetDaysInMonth(int, int) : int;

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Calendar.GetDaysInMonth (Int32, Int32, Int32)

Returns the number of days in the month specified by the specified year, month and era.

[Visual Basic]
Overloads MustOverride Public Function GetDaysInMonth( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal era As Integer _
) As Integer
[C#]
public abstract int GetDaysInMonth(
   int year,
   int month,
   int era
);
[C++]
public: virtual int GetDaysInMonth(
   int year,
   int month,
   int era
) = 0;
[JScript]
public abstract function GetDaysInMonth(
   year : int,
   month : int,
   era : int
) : int;

Parameters

year
The year.
month
The month (1...12).
era
The era.

Return Value

The number of days in the specified month. For the month of February (month = 2)[RB18], the returned value is 28 or 29 depending on whether year is a leap year.

Exceptions

Exception Type | Condition
ArgumentException | is thrown if month is less than 1 or greater than 12.

See Also

Calendar Class | Calendar Members | System.Globalization Namespace | Calendar.GetDaysInMonth Overload List


Calendar.GetDaysInMonth (Int32, Int32)

Returns the number of days in the month specified by the year and month parameters.

[Visual Basic]
Overloads Overridable Public Function GetDaysInMonth( _
   ByVal year As Integer, _
   ByVal month As Integer _
) As Integer
[C#]
public virtual int GetDaysInMonth(
   int year,
   int month
);
[C++]
public: virtual int GetDaysInMonth(
   int year,
   int month
);
[JScript]
public function GetDaysInMonth(
   year : int,
   month : int
) : int;

Parameters

year
The year.
month
[To be supplied.]

Return Value

he number of days in the specified month. For the month of February (month = 2), the returned value is 28 or 29 depending on whether year is a leap year.

Exceptions

Exception Type | Condition
ArgumentException | If month is out of range.

See Also

Calendar Class | Calendar Members | System.Globalization Namespace | Calendar.GetDaysInMonth Overload List


Calendar.GetDaysInYear

[To be supplied.]

Overload List

Returns the number of days in the month specified by year and era parameters.

[Visual Basic] Overloads MustOverride Public Function GetDaysInYear(Integer, Integer) As Integer
[C#] public abstract int GetDaysInYear(int, int);
[C++] public: virtual int GetDaysInYear(int, int) = 0;
[JScript] public abstract function GetDaysInYear(int, int) : int;

Returns the number of days in the year specified by the year

parameter and the current era.

[Visual Basic] Overloads Overridable Public Function GetDaysInYear(Integer) As Integer
[C#] public virtual int GetDaysInYear(int);
[C++] public: virtual int GetDaysInYear(int);
[JScript] public function GetDaysInYear(int) : int;

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Calendar.GetDaysInYear (Int32, Int32)

Returns the number of days in the month specified by year and era parameters.

[Visual Basic]
Overloads MustOverride Public Function GetDaysInYear( _
   ByVal year As Integer, _
   ByVal era As Integer _
) As Integer
[C#]
public abstract int GetDaysInYear(
   int year,
   int era
);
[C++]
public: virtual int GetDaysInYear(
   int year,
   int era
) = 0;
[JScript]
public abstract function GetDaysInYear(
   year : int,
   era : int
) : int;

Parameters

year
The year.
era
The era.

Return Value

The number of days in the specified year.

See Also

Calendar Class | Calendar Members | System.Globalization Namespace | Calendar.GetDaysInYear Overload List


Calendar.GetDaysInYear (Int32)

Returns the number of days in the year specified by the year

parameter and the current era.

[Visual Basic]
Overloads Overridable Public Function GetDaysInYear( _
   ByVal year As Integer _
) As Integer
[C#]
public virtual int GetDaysInYear(
   int year
);
[C++]
public: virtual int GetDaysInYear(
   int year
);
[JScript]
public function GetDaysInYear(
   year : int
) : int;

Parameters

year
The number of days in the specified year.

Return Value

The number of days in the year specified by the year parameter for the current era.

Exceptions

Exception Type | Condition
ArgumentException | is thrown if month is less than 1 or greater than 12.

See Also

Calendar Class | Calendar Members | System.Globalization Namespace | Calendar.GetDaysInYear Overload List


Calendar.GetEra

[To be supplied.]

Overload List

Returns the era for the specified DateTime.

[Visual Basic] Overloads MustOverride Public Function GetEra(DateTime) As Integer
[C#] public abstract int GetEra(DateTime);
[C++] public: virtual int GetEra(DateTime) = 0;
[JScript] public abstract function GetEra(DateTime) : int;

[To be supplied.]

[Visual Basic] Overloads MustOverride Public Function GetEra(String) As Integer
[C#] public abstract int GetEra(String);
[C++] public: virtual int GetEra(String*) = 0;
[JScript] public abstract function GetEra(String) : int;

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Calendar.GetEra (DateTime)

Returns the era for the specified DateTime.

[Visual Basic]
Overloads MustOverride Public Function GetEra( _
   ByVal time As DateTime _
) As Integer
[C#]
public abstract int GetEra(
   DateTime time
);
[C++]
public: virtual int GetEra(
   DateTime time
) = 0;
[JScript]
public abstract function GetEra(
   time : DateTime
) : int;

Parameters

time
The DateTime instance.

Return Value

The era for the specified DateTime value.

See Also

Calendar Class | Calendar Members | System.Globalization Namespace | Calendar.GetEra Overload List


Calendar.GetEra (String)

[To be supplied.]

[Visual Basic]
Overloads MustOverride Public Function GetEra( _
   ByVal eraName As String _
) As Integer
[C#]
public abstract int GetEra(
   string eraName
);
[C++]
public: virtual int GetEra(
   String* eraName
) = 0;
[JScript]
public abstract function GetEra(
   eraName : String
) : int;

Parameters

eraName
[To be supplied.]

See Also

Calendar Class | Calendar Members | System.Globalization Namespace | Calendar.GetEra Overload List


Calendar.GetEraName

[To be supplied.]

[Visual Basic]
MustOverride Public Function GetEraName( _
   ByVal era As Integer _
) As String
[C#]
public abstract string GetEraName(
   int era
);
[C++]
public: virtual String* GetEraName(
   int era
) = 0;
[JScript]
public abstract function GetEraName(
   era : int
) : String;

Parameters

era
[To be supplied.]

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Calendar.GetHour

Returns the hour part of the specified DateTime.

[Visual Basic]
Overridable Public Function GetHour( _
   ByVal time As DateTime _
) As Integer
[C#]
public virtual int GetHour(
   DateTime time
);
[C++]
public: virtual int GetHour(
   DateTime time
);
[JScript]
public function GetHour(
   time : DateTime
) : int;

Parameters

time
The DateTime instance.

Return Value

The hour part of the specified DateTime. The returned value is an integer between 0 and 23.[RB19]

Remarks

The returned value is an integer between 0 and 23.[RB20]

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Calendar.GetMilliseconds

Returns the millisecond part of the specified DateTime.

[Visual Basic]
Overridable Public Function GetMilliseconds( _
   ByVal time As DateTime _
) As Double
[C#]
public virtual double GetMilliseconds(
   DateTime time
);
[C++]
public: virtual double GetMilliseconds(
   DateTime time
);
[JScript]
public function GetMilliseconds(
   time : DateTime
) : double;

Parameters

time
The DateTime instance.

Return Value

The millisecond part of the specified DateTime.

Remarks

The returned value is an integer between 0 and 999[RB21] .

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Calendar.GetMinute

Returns the minute part of the specified DateTime.

[Visual Basic]
Overridable Public Function GetMinute( _
   ByVal time As DateTime _
) As Integer
[C#]
public virtual int GetMinute(
   DateTime time
);
[C++]
public: virtual int GetMinute(
   DateTime time
);
[JScript]
public function GetMinute(
   time : DateTime
) : int;

Parameters

time
The DateTime instance.

Return Value

The minute part of the specified DateTime.

Remarks

The returned value is an integer between 0 and 59[RB22] .

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Calendar.GetMonth

Returns the month part of the specified DateTime.

[Visual Basic]
MustOverride Public Function GetMonth( _
   ByVal time As DateTime _
) As Integer
[C#]
public abstract int GetMonth(
   DateTime time
);
[C++]
public: virtual int GetMonth(
   DateTime time
) = 0;
[JScript]
public abstract function GetMonth(
   time : DateTime
) : int;

Parameters

time
The DateTime instance.

Return Value

The 1-based month part of the specified DateTime.

Remarks

The returned value is an integer between 1 and 12.[RB23]

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Calendar.GetMonthsInYear

[To be supplied.]

Overload List

Returns [RB24] the number of months in the specified year and era parameters.

[Visual Basic] Overloads MustOverride Public Function GetMonthsInYear(Integer, Integer) As Integer
[C#] public abstract int GetMonthsInYear(int, int);
[C++] public: virtual int GetMonthsInYear(int, int) = 0;
[JScript] public abstract function GetMonthsInYear(int, int) : int;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function GetMonthsInYear(Integer) As Integer
[C#] public virtual int GetMonthsInYear(int);
[C++] public: virtual int GetMonthsInYear(int);
[JScript] public function GetMonthsInYear(int) : int;

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Calendar.GetMonthsInYear (Int32, Int32)

Returns [RB24] the number of months in the specified year and era parameters.

[Visual Basic]
Overloads MustOverride Public Function GetMonthsInYear( _
   ByVal year As Integer, _
   ByVal era As Integer _
) As Integer
[C#]
public abstract int GetMonthsInYear(
   int year,
   int era
);
[C++]
public: virtual int GetMonthsInYear(
   int year,
   int era
) = 0;
[JScript]
public abstract function GetMonthsInYear(
   year : int,
   era : int
) : int;

Parameters

year
The year.
era
The era.

Return Value

The number of months in the specified year and era[RB25] .

See Also

Calendar Class | Calendar Members | System.Globalization Namespace | Calendar.GetMonthsInYear Overload List


Calendar.GetMonthsInYear (Int32)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function GetMonthsInYear( _
   ByVal year As Integer _
) As Integer
[C#]
public virtual int GetMonthsInYear(
   int year
);
[C++]
public: virtual int GetMonthsInYear(
   int year
);
[JScript]
public function GetMonthsInYear(
   year : int
) : int;

Parameters

year
[To be supplied.]

See Also

Calendar Class | Calendar Members | System.Globalization Namespace | Calendar.GetMonthsInYear Overload List


Calendar.GetSecond

Returns the second [RB26] part of the specified DateTime.

[Visual Basic]
Overridable Public Function GetSecond( _
   ByVal time As DateTime _
) As Integer
[C#]
public virtual int GetSecond(
   DateTime time
);
[C++]
public: virtual int GetSecond(
   DateTime time
);
[JScript]
public function GetSecond(
   time : DateTime
) : int;

Parameters

time
The DateTime instance.

Return Value

The second [RB27] part of the specified DateTime.

Remarks

The returned value is an integer between 0 and 59[RB28] .

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Calendar.GetWeekOfYear

Returns the week of year for the specified DateTime.

[Visual Basic]
MustOverride Public Function GetWeekOfYear( _
   ByVal time As DateTime _
) As Integer
[C#]
public abstract int GetWeekOfYear(
   DateTime time
);
[C++]
public: virtual int GetWeekOfYear(
   DateTime time
) = 0;
[JScript]
public abstract function GetWeekOfYear(
   time : DateTime
) : int;

Parameters

time
The DateTime instance.

Return Value

The week of year for the specified DateTime.

Remarks

The returned value is an integer between 1 and 52[RB29] .

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Calendar.GetYear

Returns the year part of the specified DateTime.

[Visual Basic]
MustOverride Public Function GetYear( _
   ByVal time As DateTime _
) As Integer
[C#]
public abstract int GetYear(
   DateTime time
);
[C++]
public: virtual int GetYear(
   DateTime time
) = 0;
[JScript]
public abstract function GetYear(
   time : DateTime
) : int;

Parameters

time
The DateTime instance.

Return Value

The year part of the specified DateTime.

Remarks

The returned value is an integer between 1 and 9999[RB30] .

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Calendar.IsLeapDay

[To be supplied.]

Overload List

Checks whether a specified day in the specified era

is a leap day.

[Visual Basic] Overloads MustOverride Public Function IsLeapDay(Integer, Integer, Integer, Integer) As Boolean
[C#] public abstract bool IsLeapDay(int, int, int, int);
[C++] public: virtual bool IsLeapDay(int, int, int, int) = 0;
[JScript] public abstract function IsLeapDay(int, int, int, int) : Boolean;

Checks [RB32] whether a specified day in the current era is a leap day.

[Visual Basic] Overloads Overridable Public Function IsLeapDay(Integer, Integer, Integer) As Boolean
[C#] public virtual bool IsLeapDay(int, int, int);
[C++] public: virtual bool IsLeapDay(int, int, int);
[JScript] public function IsLeapDay(int, int, int) : Boolean;

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Calendar.IsLeapDay (Int32, Int32, Int32, Int32)

Checks whether a specified day in the specified era

is a leap day.

[Visual Basic]
Overloads MustOverride Public Function IsLeapDay( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal era As Integer _
) As Boolean
[C#]
public abstract bool IsLeapDay(
   int year,
   int month,
   int day,
   int era
);
[C++]
public: virtual bool IsLeapDay(
   int year,
   int month,
   int day,
   int era
) = 0;
[JScript]
public abstract function IsLeapDay(
   year : int,
   month : int,
   day : int,
   era : int
) : Boolean;

Parameters

year
The year to check.
month
The month to check.
day
The day to check.
era
The era to check.

Return Value

true if and only if [RB33] the specified day is a leap day; otherwise, false.

See Also

Calendar Class | Calendar Members | System.Globalization Namespace | Calendar.IsLeapDay Overload List


Calendar.IsLeapDay (Int32, Int32, Int32)

Checks [RB32] whether a specified day in the current era is a leap day.

[Visual Basic]
Overloads Overridable Public Function IsLeapDay( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer _
) As Boolean
[C#]
public virtual bool IsLeapDay(
   int year,
   int month,
   int day
);
[C++]
public: virtual bool IsLeapDay(
   int year,
   int month,
   int day
);
[JScript]
public function IsLeapDay(
   year : int,
   month : int,
   day : int
) : Boolean;

Parameters

year
The year to check.
month
The month to check.
day
The day to check.

Return Value

true if the specified day is a leap day; otherwise, false.

See Also

Calendar Class | Calendar Members | System.Globalization Namespace | Calendar.IsLeapDay Overload List


Calendar.IsLeapMonth

[To be supplied.]

Overload List

Checks whether a specified month in the specified year in the specified era is a leap month.

[Visual Basic] Overloads MustOverride Public Function IsLeapMonth(Integer, Integer, Integer) As Boolean
[C#] public abstract bool IsLeapMonth(int, int, int);
[C++] public: virtual bool IsLeapMonth(int, int, int) = 0;
[JScript] public abstract function IsLeapMonth(int, int, int) : Boolean;

Checks [RB35] whether a specified month in the current era is a leap month.

[Visual Basic] Overloads Overridable Public Function IsLeapMonth(Integer, Integer) As Boolean
[C#] public virtual bool IsLeapMonth(int, int);
[C++] public: virtual bool IsLeapMonth(int, int);
[JScript] public function IsLeapMonth(int, int) : Boolean;

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Calendar.IsLeapMonth (Int32, Int32, Int32)

Checks whether a specified month in the specified year in the specified era is a leap month.

[Visual Basic]
Overloads MustOverride Public Function IsLeapMonth( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal era As Integer _
) As Boolean
[C#]
public abstract bool IsLeapMonth(
   int year,
   int month,
   int era
);
[C++]
public: virtual bool IsLeapMonth(
   int year,
   int month,
   int era
) = 0;
[JScript]
public abstract function IsLeapMonth(
   year : int,
   month : int,
   era : int
) : Boolean;

Parameters

year
The year to check.
month
The month to check.
era
The era to check.

Return Value

true if and only if [RB36] the specified day is a leap day; otherwise, false.

See Also

Calendar Class | Calendar Members | System.Globalization Namespace | Calendar.IsLeapMonth Overload List


Calendar.IsLeapMonth (Int32, Int32)

Checks [RB35] whether a specified month in the current era is a leap month.

[Visual Basic]
Overloads Overridable Public Function IsLeapMonth( _
   ByVal year As Integer, _
   ByVal month As Integer _
) As Boolean
[C#]
public virtual bool IsLeapMonth(
   int year,
   int month
);
[C++]
public: virtual bool IsLeapMonth(
   int year,
   int month
);
[JScript]
public function IsLeapMonth(
   year : int,
   month : int
) : Boolean;

Parameters

year
The year to check.
month
The month to check.

Return Value

true if month is a leap month; otherwise, false.

See Also

Calendar Class | Calendar Members | System.Globalization Namespace | Calendar.IsLeapMonth Overload List


Calendar.IsLeapYear

[To be supplied.]

Overload List

Checks [RB38] whether a specified year in the current era is a leap year.

[Visual Basic] Overloads Overridable Public Function IsLeapYear(Integer) As Boolean
[C#] public virtual bool IsLeapYear(int);
[C++] public: virtual bool IsLeapYear(int);
[JScript] public function IsLeapYear(int) : Boolean;

Checks whether a specified year in the specified era is a leap year

[Visual Basic] Overloads MustOverride Public Function IsLeapYear(Integer, Integer) As Boolean
[C#] public abstract bool IsLeapYear(int, int);
[C++] public: virtual bool IsLeapYear(int, int) = 0;
[JScript] public abstract function IsLeapYear(int, int) : Boolean;

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Calendar.IsLeapYear (Int32)

Checks [RB38] whether a specified year in the current era is a leap year.

[Visual Basic]
Overloads Overridable Public Function IsLeapYear( _
   ByVal year As Integer _
) As Boolean
[C#]
public virtual bool IsLeapYear(
   int year
);
[C++]
public: virtual bool IsLeapYear(
   int year
);
[JScript]
public function IsLeapYear(
   year : int
) : Boolean;

Parameters

year
The year to check.

Return Value

true if year is a leap year; otherwise, false.

See Also

Calendar Class | Calendar Members | System.Globalization Namespace | Calendar.IsLeapYear Overload List


Calendar.IsLeapYear (Int32, Int32)

Checks whether a specified year in the specified era is a leap year

[Visual Basic]
Overloads MustOverride Public Function IsLeapYear( _
   ByVal year As Integer, _
   ByVal era As Integer _
) As Boolean
[C#]
public abstract bool IsLeapYear(
   int year,
   int era
);
[C++]
public: virtual bool IsLeapYear(
   int year,
   int era
) = 0;
[JScript]
public abstract function IsLeapYear(
   year : int,
   era : int
) : Boolean;

Parameters

year
The year to check.
era
The era to check.

Return Value

true if year is a leap year; otherwise, false.

See Also

Calendar Class | Calendar Members | System.Globalization Namespace | Calendar.IsLeapYear Overload List


Calendar.ToDateTime

Returns [RB39] the date and time converted to a DateTime value.

Overload List

Returns the date and time converted to a DateTime value.

[Visual Basic] Overloads MustOverride Public Function ToDateTime(Integer, Integer, Integer, Integer, Integer, Integer, Integer, Integer) As DateTime
[C#] public abstract DateTime ToDateTime(int, int, int, int, int, int, int, int);
[C++] public: virtual DateTime ToDateTime(int, int, int, int, int, int, int, int) = 0;
[JScript] public abstract function ToDateTime(int, int, int, int, int, int, int, int) : DateTime;

Returns [RB40] the date and time converted to a DateTime value.

[Visual Basic] Overloads Overridable Public Function ToDateTime(Integer, Integer, Integer, Integer, Integer, Integer, Integer) As DateTime
[C#] public virtual DateTime ToDateTime(int, int, int, int, int, int, int);
[C++] public: virtual DateTime ToDateTime(int, int, int, int, int, int, int);
[JScript] public function ToDateTime(int, int, int, int, int, int, int) : DateTime;

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Calendar.ToDateTime (Int32, Int32, Int32, Int32, Int32, Int32, Int32, Int32)

Returns the date and time converted to a DateTime value.

[Visual Basic]
Overloads MustOverride Public Function ToDateTime( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal hour As Integer, _
   ByVal minute As Integer, _
   ByVal second As Integer, _
   ByVal millisecond As Integer, _
   ByVal era As Integer _
) As DateTime
[C#]
public abstract DateTime ToDateTime(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   int millisecond,
   int era
);
[C++]
public: virtual DateTime ToDateTime(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   int millisecond,
   int era
) = 0;
[JScript]
public abstract function ToDateTime(
   year : int,
   month : int,
   day : int,
   hour : int,
   minute : int,
   second : int,
   millisecond : int,
   era : int
) : DateTime;

Parameters

year
The year.
month
The month.
day
The day.
hour
The hour.
minute
The minute.
second
The second.
millisecond
The millisecond.
era
The era.

Return Value

The constructed DateTime [RB42] instance for the specified time.

See Also

Calendar Class | Calendar Members | System.Globalization Namespace | Calendar.ToDateTime Overload List


Calendar.ToDateTime (Int32, Int32, Int32, Int32, Int32, Int32, Int32)

Returns [RB40] the date and time converted to a DateTime value.

[Visual Basic]
Overloads Overridable Public Function ToDateTime( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal hour As Integer, _
   ByVal minute As Integer, _
   ByVal second As Integer, _
   ByVal millisecond As Integer _
) As DateTime
[C#]
public virtual DateTime ToDateTime(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   int millisecond
);
[C++]
public: virtual DateTime ToDateTime(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   int millisecond
);
[JScript]
public function ToDateTime(
   year : int,
   month : int,
   day : int,
   hour : int,
   minute : int,
   second : int,
   millisecond : int
) : DateTime;

Parameters

year
The year.
month
The month.
day
The day.
hour
The hour.
minute
The minute.
second
The second.
millisecond
The millisecond.

Return Value

The constructed DateTime instance for the specified time.

See Also

Calendar Class | Calendar Members | System.Globalization Namespace | Calendar.ToDateTime Overload List


Calendar.ToFourDigitYear

Converts the specified year to the appropriate century by using the TwoDigitYearMax property.

[Visual Basic]
Overridable Public Function ToFourDigitYear( _
   ByVal year As Integer _
) As Integer
[C#]
public virtual int ToFourDigitYear(
   int year
);
[C++]
public: virtual int ToFourDigitYear(
   int year
);
[JScript]
public function ToFourDigitYear(
   year : int
) : int;

Parameters

year
The 2-digit year value to be converted.

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Calendar Fields

The fields of the Calendar class are listed below. For a complete list of Calendar class members, see the Calendar Members topic.

Public:

CurrentEra Represents the current era for the current calendar.

See Also

Calendar Class | System.Globalization Namespace


Calendar.CurrentEra

Represents the current era for the current calendar.

[Visual Basic]
Public Const CurrentEra As Integer
[C#]
public const int CurrentEra;
[C++]
public: const int CurrentEra;
[JScript]
public var CurrentEra : int;

See Also

Calendar Class | Calendar Members | System.Globalization Namespace


CalendarTable Class

[To be supplied.]

Object
CalendarTable

[Visual Basic]
Public Class CalendarTable
[C#]
public class CalendarTable
[C++]
public __gc class CalendarTable
[JScript]
public class CalendarTable

Remarks

[To be supplied.]

Requirements

Namespace: System.Globalization

Assembly: mscorlib.dll

See Also

CalendarTable Members | System.Globalization Namespace


CalendarTable Members

Public:

Constructor

CalendarTable Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInt16Value | [To be supplied.]
GetStringValue | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CalendarTable Class | System.Globalization Namespace


CalendarTable Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CalendarTable();
[C++]
public: CalendarTable();
[JScript]
public function CalendarTable();

See Also

CalendarTable Class | CalendarTable Members | System.Globalization Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CalendarTable Methods

The methods of the CalendarTable class are listed below. For a complete list of CalendarTable class members, see the CalendarTable Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInt16Value | [To be supplied.]
GetStringValue | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CalendarTable Class | System.Globalization Namespace


CalendarTable.GetInt16Value

[To be supplied.]

[Visual Basic]
Public Shared Function GetInt16Value( _
   ByVal calendarID As Integer, _
   ByVal field As Integer _
) As Integer
[C#]
public static int GetInt16Value(
   int calendarID,
   int field
);
[C++]
public: static int GetInt16Value(
   int calendarID,
   int field
);
[JScript]
public static function GetInt16Value(
   calendarID : int,
   field : int
) : int;

Parameters

calendarID
[To be supplied.]
field
[To be supplied.]

See Also

CalendarTable Class | CalendarTable Members | System.Globalization Namespace


CalendarTable.GetStringValue

[To be supplied.]

[Visual Basic]
Public Shared Function GetStringValue( _
   ByVal calendarID As Integer, _
   ByVal field As Integer _
) As String
[C#]
public static string GetStringValue(
   int calendarID,
   int field
);
[C++]
public: static String* GetStringValue(
   int calendarID,
   int field
);
[JScript]
public static function GetStringValue(
   calendarID : int,
   field : int
) : String;

Parameters

calendarID
[To be supplied.]
field
[To be supplied.]

See Also

CalendarTable Class | CalendarTable Members | System.Globalization Namespace


CharacterInfo Class

[To be supplied.]

Object
CharacterInfo

[Visual Basic]
Public Class CharacterInfo
[C#]
public class CharacterInfo
[C++]
public __gc class CharacterInfo
[JScript]
public class CharacterInfo

Remarks

Character type information is independent of culture and region.

Requirements

Namespace: System.Globalization

Assembly: mscorlib.dll

See Also

CharacterInfo Members | System.Globalization Namespace


CharacterInfo Members

Public:

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNumericValue | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetUnicodeCategory | [To be supplied.]
IsControl | Determines whether the specified character is a control code.
IsDigit | Determines whether the specified character is a decimal digit.
IsLetter | [To be supplied.]
IsLower | Determines whether the specified character is a lowercase character.
IsMark | [To be supplied.]
IsNumer | [To be supplied.]
IsPrivateUse | [To be supplied.]
IsPunctuation | Determines whether the specified character is a punctuation character.
IsSeparator | [To be supplied.]
IsSurrogate | [To be supplied.]
IsSymbol | Determines whether the specified character is a symbol character.
IsUpper | Determines whether the specified character is an uppercase character.
IsWhiteSpace | Determines whether the specified character is a white space character.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CharacterInfo Class | System.Globalization Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CharacterInfo Methods

The methods of the CharacterInfo class are listed below. For a complete list of CharacterInfo class members, see the CharacterInfo Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNumericValue | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetUnicodeCategory | [To be supplied.]
IsControl | Determines whether the specified character is a control code.
IsDigit | Determines whether the specified character is a decimal digit.
IsLetter | [To be supplied.]
IsLower | Determines whether the specified character is a lowercase character.
IsMark | [To be supplied.]
IsNumer | [To be supplied.]
IsPrivateUse | [To be supplied.]
IsPunctuation | Determines whether the specified character is a punctuation character.
IsSeparator | [To be supplied.]
IsSurrogate | [To be supplied.]
IsSymbol | Determines whether the specified character is a symbol character.
IsUpper | Determines whether the specified character is an uppercase character.
IsWhiteSpace | Determines whether the specified character is a white space character.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CharacterInfo Class | System.Globalization Namespace


CharacterInfo.GetNumericValue

[To be supplied.]

[Visual Basic]
Public Shared Function GetNumericValue( _
   ByVal ch As Char _
) As Single
[C#]
public static float GetNumericValue(
   char ch
);
[C++]
public: static float GetNumericValue(
   __wchar_t ch
);
[JScript]
public static function GetNumericValue(
   ch : Char
) : float;

Parameters

ch
[To be supplied.]

See Also

CharacterInfo Class | CharacterInfo Members | System.Globalization Namespace


CharacterInfo.GetUnicodeCategory

[To be supplied.]

[Visual Basic]
Public Shared Function GetUnicodeCategory( _
   ByVal ch As Char _
) As UnicodeCategory
[C#]
public static UnicodeCategory GetUnicodeCategory(
   char ch
);
[C++]
public: static UnicodeCategory GetUnicodeCategory(
   __wchar_t ch
);
[JScript]
public static function GetUnicodeCategory(
   ch : Char
) : UnicodeCategory;

Parameters

ch
[To be supplied.]

See Also

CharacterInfo Class | CharacterInfo Members | System.Globalization Namespace


CharacterInfo.IsControl

Determines whether the specified character is a control code.

[Visual Basic]
Public Shared Function IsControl( _
   ByVal ch As Char _
) As Boolean
[C#]
public static bool IsControl(
   char ch
);
[C++]
public: static bool IsControl(
   __wchar_t ch
);
[JScript]
public static function IsControl(
   ch : Char
) : Boolean;

Parameters

ch
The specified character.

Return Value

true if c is a control code; otherwise, false.

Remarks

The first 32 characters in the ASCII character set are control codes for communications and printers.

See Also

CharacterInfo Class | CharacterInfo Members | System.Globalization Namespace


CharacterInfo.IsDigit

Determines whether the specified character is a decimal digit.

[Visual Basic]
Public Shared Function IsDigit( _
   ByVal ch As Char _
) As Boolean
[C#]
public static bool IsDigit(
   char ch
);
[C++]
public: static bool IsDigit(
   __wchar_t ch
);
[JScript]
public static function IsDigit(
   ch : Char
) : Boolean;

Parameters

ch
The specified character.

Return Value

true if c is a decimal digit; otherwise, false.

See Also

CharacterInfo Class | CharacterInfo Members | System.Globalization Namespace


CharacterInfo.IsLetter

[To be supplied.]

[Visual Basic]
Public Shared Function IsLetter( _
   ByVal ch As Char _
) As Boolean
[C#]
public static bool IsLetter(
   char ch
);
[C++]
public: static bool IsLetter(
   __wchar_t ch
);
[JScript]
public static function IsLetter(
   ch : Char
) : Boolean;

Parameters

ch
[To be supplied.]

See Also

CharacterInfo Class | CharacterInfo Members | System.Globalization Namespace


CharacterInfo.IsLower

Determines whether the specified character is a lowercase character.

[Visual Basic]
Public Shared Function IsLower( _
   ByVal c As Char _
) As Boolean
[C#]
public static bool IsLower(
   char c
);
[C++]
public: static bool IsLower(
   __wchar_t c
);
[JScript]
public static function IsLower(
   c : Char
) : Boolean;

Parameters

c
The specified character.

Return Value

true if c is a lowercase character; otherwise, false.

See Also

CharacterInfo Class | CharacterInfo Members | System.Globalization Namespace


CharacterInfo.IsMark

[To be supplied.]

[Visual Basic]
Public Shared Function IsMark( _
   ByVal ch As Char _
) As Boolean
[C#]
public static bool IsMark(
   char ch
);
[C++]
public: static bool IsMark(
   __wchar_t ch
);
[JScript]
public static function IsMark(
   ch : Char
) : Boolean;

Parameters

ch
[To be supplied.]

See Also

CharacterInfo Class | CharacterInfo Members | System.Globalization Namespace


CharacterInfo.IsNumer

[To be supplied.]

[Visual Basic]
Public Shared Function IsNumer( _
   ByVal ch As Char _
) As Boolean
[C#]
public static bool IsNumer(
   char ch
);
[C++]
public: static bool IsNumer(
   __wchar_t ch
);
[JScript]
public static function IsNumer(
   ch : Char
) : Boolean;

Parameters

ch
[To be supplied.]

See Also

CharacterInfo Class | CharacterInfo Members | System.Globalization Namespace


CharacterInfo.IsPrivateUse

[To be supplied.]

[Visual Basic]
Public Shared Function IsPrivateUse( _
   ByVal ch As Char _
) As Boolean
[C#]
public static bool IsPrivateUse(
   char ch
);
[C++]
public: static bool IsPrivateUse(
   __wchar_t ch
);
[JScript]
public static function IsPrivateUse(
   ch : Char
) : Boolean;

Parameters

ch
[To be supplied.]

See Also

CharacterInfo Class | CharacterInfo Members | System.Globalization Namespace


CharacterInfo.IsPunctuation

Determines whether the specified character is a punctuation character.

[Visual Basic]
Public Shared Function IsPunctuation( _
   ByVal ch As Char _
) As Boolean
[C#]
public static bool IsPunctuation(
   char ch
);
[C++]
public: static bool IsPunctuation(
   __wchar_t ch
);
[JScript]
public static function IsPunctuation(
   ch : Char
) : Boolean;

Parameters

ch
The specified character.

Return Value

true if c is a punctuation character; otherwise, false.

See Also

CharacterInfo Class | CharacterInfo Members | System.Globalization Namespace


CharacterInfo.IsSeparator

[To be supplied.]

[Visual Basic]
Public Shared Function IsSeparator( _
   ByVal ch As Char _
) As Boolean
[C#]
public static bool IsSeparator(
   char ch
);
[C++]
public: static bool IsSeparator(
   __wchar_t ch
);
[JScript]
public static function IsSeparator(
   ch : Char
) : Boolean;

Parameters

ch
[To be supplied.]

See Also

CharacterInfo Class | CharacterInfo Members | System.Globalization Namespace


CharacterInfo.IsSurrogate

[To be supplied.]

[Visual Basic]
Public Shared Function IsSurrogate( _
   ByVal ch As Char _
) As Boolean
[C#]
public static bool IsSurrogate(
   char ch
);
[C++]
public: static bool IsSurrogate(
   __wchar_t ch
);
[JScript]
public static function IsSurrogate(
   ch : Char
) : Boolean;

Parameters

ch
[To be supplied.]

See Also

CharacterInfo Class | CharacterInfo Members | System.Globalization Namespace


CharacterInfo.IsSymbol

Determines whether the specified character is a symbol character.

[Visual Basic]
Public Shared Function IsSymbol( _
   ByVal ch As Char _
) As Boolean
[C#]
public static bool IsSymbol(
   char ch
);
[C++]
public: static bool IsSymbol(
   __wchar_t ch
);
[JScript]
public static function IsSymbol(
   ch : Char
) : Boolean;

Parameters

ch
The specified character.

Return Value

true if c is a symbol character; otherwise, false.

See Also

CharacterInfo Class | CharacterInfo Members | System.Globalization Namespace


CharacterInfo.IsUpper

Determines whether the specified character is an uppercase character.

[Visual Basic]
Public Shared Function IsUpper( _
   ByVal c As Char _
) As Boolean
[C#]
public static bool IsUpper(
   char c
);
[C++]
public: static bool IsUpper(
   __wchar_t c
);
[JScript]
public static function IsUpper(
   c : Char
) : Boolean;

Parameters

c
The specified character.

Return Value

true if c is an uppercase character; otherwise, false.

See Also

CharacterInfo Class | CharacterInfo Members | System.Globalization Namespace


CharacterInfo.IsWhiteSpace

Determines whether the specified character is a white space character.

[Visual Basic]
Public Shared Function IsWhiteSpace( _
   ByVal c As Char _
) As Boolean
[C#]
public static bool IsWhiteSpace(
   char c
);
[C++]
public: static bool IsWhiteSpace(
   __wchar_t c
);
[JScript]
public static function IsWhiteSpace(
   c : Char
) : Boolean;

Parameters

c
The specified character.

Return Value

true if c is a white space character; otherwise, false.

Remarks

The white space characters consist of the blank space characters (see the IsBlankSpace method) as well as characters such as[RB3]\x0009 (horizontal tabulation),\x000a (line feed),\x000b (vertical tabulation),\x000c (form feed),\x000d (carriage return), and so on.

See Also

CharacterInfo Class | CharacterInfo Members | System.Globalization Namespace


CodePageEncoding Class

[To be supplied.]

Object
Encoding
CodePageEncoding

[Visual Basic]
Public Class CodePageEncoding
   Inherits Encoding
[C#]
public class CodePageEncoding : Encoding
[C++]
public __gc class CodePageEncoding : public Encoding
[JScript]
public class CodePageEncoding extends Encoding

Remarks

The CodePageEncoding class implements a set of methods for translating between Unicode and a specific Windows code page, which is referred to as the ANSI code page. The code page is the mapping between character glyphs (shapes) and the 1-byte or 2-byte numeric values that are used to represent them.

Any installed code page can be accessed through this encoding, and conversions are performed using the WideCharToMultiByte and MultiByteToWideChar Windows API functions.

This class implements the Encoding abstract base class.

Requirements

Namespace: System.Globalization

Assembly: mscorlib.dll

See Also

CodePageEncoding Members | System.Globalization Namespace


CodePageEncoding Members

Public:

Constructor

CodePageEncoding Constructor Initializes a new instance of the CodePageEncoding class.

Properties

BodyName (inherited from Encoding) | Returns the name for this encoding that can be used with mail agent body tags. If the encoding may not be used, the string is empty.
CodePage | [To be supplied.]
EncodingName (inherited from Encoding) | Returns the human-readable description of the encoding (e.g. Hebrew (DOS)).
HeaderName (inherited from Encoding) | Returns the name for this encoding that can be used with mail agent header tags. If the encoding may not be used, the string is empty.
IsBrowserDisplay (inherited from Encoding) | [To be supplied.]
IsBrowserSave (inherited from Encoding) | [To be supplied.]
IsMailNewsDisplay (inherited from Encoding) | [To be supplied.]
IsMailNewsSave (inherited from Encoding) | [To be supplied.]
WebName (inherited from Encoding) | Returns the array of IANA-registered names for this encoding. If there is an IANA preferred name, it is the first name in the array.
WindowCodePage (inherited from Encoding) | Returns the windows code page that most closely corresponds to this encoding.

Methods

Equals (inherited from Encoding) | [To be supplied.]
GetByteCount | Overloaded. [To be supplied.]
GetBytes (inherited from Encoding) | Overloaded. Returns a byte array containing the encoded representation of the given character array.
GetCharCount (inherited from Encoding) | Overloaded. Returns the number of characters required to decode an array of bytes.
GetChars (inherited from Encoding) | Overloaded. Decodes a range of bytes in an array into an array of characters.
GetDecoder | Gets a decoder object for the current instance of encoding.
GetEncoder (inherited from Encoding) | Returns an encoder object for this instance of encoding. The encoder object can be used to encode a sequence of characters into bytes.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetMaxByteCount | Gets the maximum number of bytes required to encode a specified number of characters.
GetMaxCharCount | Gets the maximum number of characters produced from decoding a specified number of bytes.
GetString (inherited from Encoding) | Overloaded. Decodes the specified byte array into a string.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodePageEncoding Class | System.Globalization Namespace


CodePageEncoding Constructor

Initializes a new instance of the CodePageEncoding class.

[Visual Basic]
Public Sub New( _
   ByVal codepage As Integer _
)
[C#]
public CodePageEncoding(
   int codepage
);
[C++]
public: CodePageEncoding(
   int codepage
);
[JScript]
public function CodePageEncoding(
   codepage : int
);

Parameters

codepage
The NLS [RB1] code page identifier.

See Also

CodePageEncoding Class | CodePageEncoding Members | System.Globalization Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodePageEncoding Properties

The properties of the CodePageEncoding class are listed below. For a complete list of CodePageEncoding class members, see the CodePageEncoding Members topic.

Public:

BodyName (inherited from Encoding) | Returns the name for this encoding that can be used with mail agent body tags. If the encoding may not be used, the string is empty.
CodePage | [To be supplied.]
EncodingName (inherited from Encoding) | Returns the human-readable description of the encoding (e.g. Hebrew (DOS)).
HeaderName (inherited from Encoding) | Returns the name for this encoding that can be used with mail agent header tags. If the encoding may not be used, the string is empty.
IsBrowserDisplay (inherited from Encoding) | [To be supplied.]
IsBrowserSave (inherited from Encoding) | [To be supplied.]
IsMailNewsDisplay (inherited from Encoding) | [To be supplied.]
IsMailNewsSave (inherited from Encoding) | [To be supplied.]
WebName (inherited from Encoding) | Returns the array of IANA-registered names for this encoding. If there is an IANA preferred name, it is the first name in the array.
WindowCodePage (inherited from Encoding) | Returns the windows code page that most closely corresponds to this encoding.

See Also

CodePageEncoding Class | System.Globalization Namespace


CodePageEncoding.CodePage

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property CodePage As Integer
[C#]
public int CodePage {override get;}
[C++]
public: __property virtual int get_CodePage();
[JScript]
public function get CodePage() : int;

See Also

CodePageEncoding Class | CodePageEncoding Members | System.Globalization Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CodePageEncoding Methods

The methods of the CodePageEncoding class are listed below. For a complete list of CodePageEncoding class members, see the CodePageEncoding Members topic.

Public:

Equals (inherited from Encoding) | [To be supplied.]
GetByteCount | Overloaded. [To be supplied.]
GetBytes (inherited from Encoding) | Overloaded. Returns a byte array containing the encoded representation of the given character array.
GetCharCount (inherited from Encoding) | Overloaded. Returns the number of characters required to decode an array of bytes.
GetChars (inherited from Encoding) | Overloaded. Decodes a range of bytes in an array into an array of characters.
GetDecoder | Gets a decoder object for the current instance of encoding.
GetEncoder (inherited from Encoding) | Returns an encoder object for this instance of encoding. The encoder object can be used to encode a sequence of characters into bytes.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetMaxByteCount | Gets the maximum number of bytes required to encode a specified number of characters.
GetMaxCharCount | Gets the maximum number of characters produced from decoding a specified number of bytes.
GetString (inherited from Encoding) | Overloaded. Decodes the specified byte array into a string.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodePageEncoding Class | System.Globalization Namespace


CodePageEncoding.GetByteCount

Returns the number of bytes required to encode a range of characters in the specified array.

[Visual Basic]
Overrides Public Function GetByteCount( _
   ByVal chars() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
[C#]
public override int GetByteCount(
   char[] chars,
   int index,
   int count
);
[C++]
public: override int GetByteCount(
   __wchar_t* chars[],
   int index,
   int count
);
[JScript]
public override function GetByteCount(
   chars : Char[],
   index : int,
   count : int
) : int;

Parameters

chars
The character array to encode.
index
The starting index of the character array to encode.[RB2]
count
The number of characters to encode.

Return Value

The number of bytes required to encode a range of characters in the specified character array.

Exceptions

Exception Type | Condition
ArgumentException | The chars argument is null.
ArgumentException | The index and count arguments do not denote a valid range in the character array.

Remarks

This method overrides Encoding.GetByteCount.

See Also

CodePageEncoding Class | CodePageEncoding Members | System.Globalization Namespace


CodePageEncoding.GetBytes

Encodes a range of an array of characters into an array of bytes and returns the number bytes stored in the array.

[Visual Basic]
Overrides Public Function GetBytes( _
   ByVal chars() As Char, _
   ByVal charIndex As Integer, _
   ByVal charCount As Integer, _
   ByVal bytes() As Byte, _
   ByVal byteIndex As Integer _
) As Integer
[C#]
public override int GetBytes(
   char[] chars,
   int charIndex,
   int charCount,
   byte[] bytes,
   int byteIndex
);
[C++]
public: override int GetBytes(
   __wchar_t* chars[],
   int charIndex,
   int charCount,
   unsigned char* bytes[],
   int byteIndex
);
[JScript]
public override function GetBytes(
   chars : Char[],
   charIndex : int,
   charCount : int,
   bytes : Byte[],
   byteIndex : int
) : int;

Parameters

chars
The character array to encode.
charIndex
The starting index of the character array to encode.[RB3]
charCount
The number of characters to encode.
bytes
The byte array to encode into.
byteIndex
The starting index of the resulting encoding in the byte array.

Return Value

The number of bytes stored into the byte array.

Exceptions

Exception Type | Condition
ArgumentException | The chars or bytes arguments are null.
ArgumentException | The charIndex and charCount arguments do not denote a valid range in the character array.
ArgumentException | The byteIndex or charIndex arguments are not a valid index.[RB4]
ArgumentException | The byteIndex argument is less than 0.
ArgumentException | The byteIndex argument is greater than the length of the byte array.
ArgumentException | The bytes argument is not large enough to hold the encoding of the characters.
System.Globalization.Encoding.BufferOverflow | The byteIndex argument is equal to the length of the byte array.
System.Globalization.Encoding.BufferOverflow | No bytes have been stored into the byte array.

Remarks

This method overrides Encoding.GetBytes.

The GetByteCount method can be used to determine the exact number of bytes that will be produced for a specified range of characters. Alternatively, the GetMaxByteCount method can be used to determine the maximum number of bytes that will be produced for a specified number of characters, regardless of the actual character values.

See Also

CodePageEncoding Class | CodePageEncoding Members | System.Globalization Namespace


CodePageEncoding.GetCharCount

Returns the number of characters produced by decoding a specified range of bytes.

[Visual Basic]
Overrides Public Function GetCharCount( _
   ByVal bytes() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
[C#]
public override int GetCharCount(
   byte[] bytes,
   int index,
   int count
);
[C++]
public: override int GetCharCount(
   unsigned char* bytes[],
   int index,
   int count
);
[JScript]
public override function GetCharCount(
   bytes : Byte[],
   index : int,
   count : int
) : int;

Parameters

bytes
The byte array to decode.
index
The starting index of the byte array to decode.
count
The number of bytes to decode.

Return Value

The number of characters produced by decoding a range of bytes in the specified byte array.

Exceptions

Exception Type | Condition
ArgumentException | The bytes argument is null.
ArgumentException | The index and count arguments do not denote a valid range in the byte array.

Remarks

This method overrides Encoding.GetCharCount.

See Also

CodePageEncoding Class | CodePageEncoding Members | System.Globalization Namespace


CodePageEncoding.GetChars

Decodes a range of an array of bytes into an array of characters and returns the number characters stored in the array.

[Visual Basic]
Overrides Public Function GetChars( _
   ByVal bytes() As Byte, _
   ByVal byteIndex As Integer, _
   ByVal byteCount As Integer, _
   ByVal chars() As Char, _
   ByVal charIndex As Integer _
) As Integer
[C#]
public override int GetChars(
   byte[] bytes,
   int byteIndex,
   int byteCount,
   char[] chars,
   int charIndex
);
[C++]
public: override int GetChars(
   unsigned char* bytes[],
   int byteIndex,
   int byteCount,
   __wchar_t* chars[],
   int charIndex
);
[JScript]
public override function GetChars(
   bytes : Byte[],
   byteIndex : int,
   byteCount : int,
   chars : Char[],
   charIndex : int
) : int;

Parameters

bytes
The byte array to decode.
byteIndex
The starting index of the byte array to decode.
byteCount
The number of bytes to decode.
chars
The character array to decode into.
charIndex
The starting index of the resulting decoding in the character array.

Return Value

The number of characters stored into the character array.

Exceptions

Exception Type | Condition
ArgumentException | The bytes or chars arguments are null.
ArgumentException | The byteIndex and byteCount arguments do not denote a valid range in the byte array.
ArgumentException | The charIndex or byteIndex arguments are not a valid index.
ArgumentException | The charIndex argument is less than 0.
ArgumentException | The charIndex argument is greater than length of the character array.
ArgumentException | The chars argument is not large enough to hold the decoding of the bytes.
System.Globalization.Encoding.BufferOverflow | The charIndex argument is equal to the length of the character array.
System.Globalization.Encoding.BufferOverflow | . No characters have been stored into the character array.

Remarks

This method overrides Encoding.GetChars.

The GetCharCount method can be used to determine the exact number of characters that will be produced for a specified range of bytes. Alternatively, the GetMaxCharCount method can be used to determine the maximum number of characters that will be produced for a specified number of bytes, regardless of the actual byte values.

See Also

CodePageEncoding Class | CodePageEncoding Members | System.Globalization Namespace


CodePageEncoding.GetDecoder

Gets a decoder object for the current instance of encoding.

[Visual Basic]
Overrides Public Function GetDecoder() As Decoder
[C#]
public override Decoder GetDecoder();
[C++]
public: override Decoder* GetDecoder();
[JScript]
public override function GetDecoder() : Decoder;

Return Value

A decoder object for the current encoding.

Remarks

The decoder object can be used to decode a sequence of bytes into a sequence of characters.[RB8]

Contrary to the CodePageEncoding.GetChars family of methods, a decoder can convert partial sequences of bytes into partial sequences of characters by maintaining the appropriate state between the conversions.

This default implementation returns a decoder that simply forwards calls to the GetCharCount and GetChars methods of this encoding. Encoding that requires state to be maintained between successive conversions should override this method and return a new instance of an appropriate decoder implementation.

See Also

CodePageEncoding Class | CodePageEncoding Members | System.Globalization Namespace


CodePageEncoding.GetMaxByteCount

Gets the maximum number of bytes required to encode a specified number of characters.

[Visual Basic]
Overrides Public Function GetMaxByteCount( _
   ByVal charCount As Integer _
) As Integer
[C#]
public override int GetMaxByteCount(
   int charCount
);
[C++]
public: override int GetMaxByteCount(
   int charCount
);
[JScript]
public override function GetMaxByteCount(
   charCount : int
) : int;

Parameters

charCount
The number of characters to encode.

Return Value

The maximum number of bytes required for the encoding of a specified number of characters.

Remarks

This method can be used to determine an appropriate buffer size for byte arrays passed to the CodePageEncoding.GetBytes or Encoder.GetBytes methods for this encoding.

All encoding must guarantee that no buffer overflow exceptions will occur if buffers are sized according to the results of this method.

See Also

CodePageEncoding Class | CodePageEncoding Members | System.Globalization Namespace


CodePageEncoding.GetMaxCharCount

Gets the maximum number of characters produced from decoding a specified number of bytes.

[Visual Basic]
Overrides Public Function GetMaxCharCount( _
   ByVal byteCount As Integer _
) As Integer
[C#]
public override int GetMaxCharCount(
   int byteCount
);
[C++]
public: override int GetMaxCharCount(
   int byteCount
);
[JScript]
public override function GetMaxCharCount(
   byteCount : int
) : int;

Parameters

byteCount
Number of bytes to decode.

Return Value

The maximum number of characters produced from decoding a specified number of bytes.

Remarks

This method can be used to determine an appropriate buffer size for character arrays passed to the CodePageEncoding.GetChars or Decoder.GetChars methods for this encoding.

All encoding must guarantee that no buffer overflow exceptions will occur if buffers are sized according to the results of this method.

See Also

CodePageEncoding Class | CodePageEncoding Members | System.Globalization Namespace


CompareInfo Class

[To be supplied.]

Object
CompareInfo

[Visual Basic]
Public Class CompareInfo
[C#]
public class CompareInfo
[C++]
public __gc class CompareInfo
[JScript]
public class CompareInfo

Remarks

To implement this, [RB2] you need to use the CultureInfo class to get the CompareInfo object. You can use the String class indirectly to get the default CompareInfo object. The String class uses CompareInfo to compare the region of two strings.

In order to compare two strings based on their appropriate culture identification, the CompareInfo takes a sort culture ID for the instance[RB3] . You can get the sort culture ID from the ISortOrder interface.

Requirements

Namespace: System.Globalization

Assembly: mscorlib.dll

See Also

CompareInfo Members | System.Globalization Namespace


CompareInfo Members

Public:

Constructor

CompareInfo Constructor Overloaded. [To be supplied.]

Properties

LCID Returns the properly formed locale identifier for the current CompareInfo.

Methods

Compare | Overloaded. Compares two specified strings with or without specified flags.
Equals | Checks whether the object refers to the same CompareInfo as the current instance.
GetCompareInfo | Overloaded. [To be supplied.]
GetHashCode | Gets the hash code for the instance of CompareInfo.
GetSortKey | Overloaded. Gets the sort key for the specified string.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | Overloaded. [To be supplied.]
IsPrefix | Overloaded. Determines whether the specified prefix is a prefix of the specified string.
IsSuffix | Overloaded. Determines whether the specified suffix is the string's suffix.
LastIndexOf | Overloaded. Returns the last index of the specified character in the string.
ToString | Returns a string describing the current instance of CompareInfo.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompareInfo Class | System.Globalization Namespace


CompareInfo Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public CompareInfo(String);
[C++] public: CompareInfo(String*);
[JScript] public function CompareInfo(String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Integer)
[C#] public CompareInfo(String, int);
[C++] public: CompareInfo(String*, int);
[JScript] public function CompareInfo(String, int);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public CompareInfo(int);
[C++] public: CompareInfo(int);
[JScript] public function CompareInfo(int);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer, Integer)
[C#] public CompareInfo(int, int);
[C++] public: CompareInfo(int, int);
[JScript] public function CompareInfo(int, int);

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace


CompareInfo Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal name As String _
)
[C#]
public CompareInfo(
   string name
);
[C++]
public: CompareInfo(
   String* name
);
[JScript]
public function CompareInfo(
   name : String
);

Parameters

name
[To be supplied.]

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo Constructor Overload List


CompareInfo Constructor (String, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal name As String, _
   ByVal version As Integer _
)
[C#]
public CompareInfo(
   string name,
   int version
);
[C++]
public: CompareInfo(
   String* name,
   int version
);
[JScript]
public function CompareInfo(
   name : String,
   version : int
);

Parameters

name
[To be supplied.]
version
[To be supplied.]

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo Constructor Overload List


CompareInfo Constructor (Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal culture As Integer _
)
[C#]
public CompareInfo(
   int culture
);
[C++]
public: CompareInfo(
   int culture
);
[JScript]
public function CompareInfo(
   culture : int
);

Parameters

culture
[To be supplied.]

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo Constructor Overload List


CompareInfo Constructor (Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal culture As Integer, _
   ByVal version As Integer _
)
[C#]
public CompareInfo(
   int culture,
   int version
);
[C++]
public: CompareInfo(
   int culture,
   int version
);
[JScript]
public function CompareInfo(
   culture : int,
   version : int
);

Parameters

culture
[To be supplied.]
version
[To be supplied.]

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CompareInfo Properties

The properties of the CompareInfo class are listed below. For a complete list of CompareInfo class members, see the CompareInfo Members topic.

Public:

LCID Returns the properly formed locale identifier for the current CompareInfo.

See Also

CompareInfo Class | System.Globalization Namespace


CompareInfo.LCID

Returns the properly formed locale identifier for the current CompareInfo.

[Visual Basic]
Public ReadOnly Property LCID As Integer
[C#]
public int LCID {get;}
[C++]
public: __property int get_LCID();
[JScript]
public function get LCID() : int;

Remarks

This property is provided for ease of integration with NLS[RB10]-based software.

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CompareInfo Methods

The methods of the CompareInfo class are listed below. For a complete list of CompareInfo class members, see the CompareInfo Members topic.

Public:

Compare | Overloaded. Compares two specified strings with or without specified flags.
Equals | Checks whether the object refers to the same CompareInfo as the current instance.
GetCompareInfo | Overloaded. [To be supplied.]
GetHashCode | Gets the hash code for the instance of CompareInfo.
GetSortKey | Overloaded. Gets the sort key for the specified string.
GetType (inherited from Object) | Gets the Type of the Object.
IndexOf | Overloaded. [To be supplied.]
IsPrefix | Overloaded. Determines whether the specified prefix is a prefix of the specified string.
IsSuffix | Overloaded. Determines whether the specified suffix is the string's suffix.
LastIndexOf | Overloaded. Returns the last index of the specified character in the string.
ToString | Returns a string describing the current instance of CompareInfo.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompareInfo Class | System.Globalization Namespace


CompareInfo.Compare

Compares two specified strings with or without specified flags.

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Compare(String, Integer, String, Integer, CompareOptions) As Integer
[C#] public virtual int Compare(String, int, String, int, CompareOptions);
[C++] public: virtual int Compare(String*, int, String*, int, CompareOptions);
[JScript] public function Compare(String, int, String, int, CompareOptions) : int;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Compare(String, Integer, String, Integer) As Integer
[C#] public virtual int Compare(String, int, String, int);
[C++] public: virtual int Compare(String*, int, String*, int);
[JScript] public function Compare(String, int, String, int) : int;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Compare(String, Integer, Integer, String, Integer, Integer, CompareOptions) As Integer
[C#] public virtual int Compare(String, int, int, String, int, int, CompareOptions);
[C++] public: virtual int Compare(String*, int, int, String*, int, int, CompareOptions);
[JScript] public function Compare(String, int, int, String, int, int, CompareOptions) : int;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function Compare(String, Integer, Integer, String, Integer, Integer) As Integer
[C#] public virtual int Compare(String, int, int, String, int, int);
[C++] public: virtual int Compare(String*, int, int, String*, int, int);
[JScript] public function Compare(String, int, int, String, int, int) : int;

Compares the two specified strings.

[Visual Basic] Overloads Overridable Public Function Compare(String, String) As Integer
[C#] public virtual int Compare(String, String);
[C++] public: virtual int Compare(String*, String*);
[JScript] public function Compare(String, String) : int;

Compares two strings using the specified flags.

[Visual Basic] Overloads Overridable Public Function Compare(String, String, CompareOptions) As Integer
[C#] public virtual int Compare(String, String, CompareOptions);
[C++] public: virtual int Compare(String*, String*, CompareOptions);
[JScript] public function Compare(String, String, CompareOptions) : int;

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace


CompareInfo.Compare (String, Int32, String, Int32, CompareOptions)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Compare( _
   ByVal string1 As String, _
   ByVal offset1 As Integer, _
   ByVal string2 As String, _
   ByVal offset2 As Integer, _
   ByVal options As CompareOptions _
) As Integer
[C#]
public virtual int Compare(
   string string1,
   int offset1,
   string string2,
   int offset2,
   CompareOptions options
);
[C++]
public: virtual int Compare(
   String* string1,
   int offset1,
   String* string2,
   int offset2,
   CompareOptions options
);
[JScript]
public function Compare(
   string1 : String,
   offset1 : int,
   string2 : String,
   offset2 : int,
   options : CompareOptions
) : int;

Parameters

string1
[To be supplied.]
offset1
[To be supplied.]
string2
[To be supplied.]
offset2
[To be supplied.]
options
[To be supplied.]

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.Compare Overload List


CompareInfo.Compare (String, Int32, String, Int32)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Compare( _
   ByVal string1 As String, _
   ByVal offset1 As Integer, _
   ByVal string2 As String, _
   ByVal offset2 As Integer _
) As Integer
[C#]
public virtual int Compare(
   string string1,
   int offset1,
   string string2,
   int offset2
);
[C++]
public: virtual int Compare(
   String* string1,
   int offset1,
   String* string2,
   int offset2
);
[JScript]
public function Compare(
   string1 : String,
   offset1 : int,
   string2 : String,
   offset2 : int
) : int;

Parameters

string1
[To be supplied.]
offset1
[To be supplied.]
string2
[To be supplied.]
offset2
[To be supplied.]

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.Compare Overload List


CompareInfo.Compare (String, Int32, Int32, String, Int32, Int32, CompareOptions)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Compare( _
   ByVal string1 As String, _
   ByVal offset1 As Integer, _
   ByVal length1 As Integer, _
   ByVal string2 As String, _
   ByVal offset2 As Integer, _
   ByVal length2 As Integer, _
   ByVal options As CompareOptions _
) As Integer
[C#]
public virtual int Compare(
   string string1,
   int offset1,
   int length1,
   string string2,
   int offset2,
   int length2,
   CompareOptions options
);
[C++]
public: virtual int Compare(
   String* string1,
   int offset1,
   int length1,
   String* string2,
   int offset2,
   int length2,
   CompareOptions options
);
[JScript]
public function Compare(
   string1 : String,
   offset1 : int,
   length1 : int,
   string2 : String,
   offset2 : int,
   length2 : int,
   options : CompareOptions
) : int;

Parameters

string1
[To be supplied.]
offset1
[To be supplied.]
length1
[To be supplied.]
string2
[To be supplied.]
offset2
[To be supplied.]
length2
[To be supplied.]
options
[To be supplied.]

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.Compare Overload List


CompareInfo.Compare (String, Int32, Int32, String, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function Compare( _
   ByVal string1 As String, _
   ByVal offset1 As Integer, _
   ByVal length1 As Integer, _
   ByVal string2 As String, _
   ByVal offset2 As Integer, _
   ByVal length2 As Integer _
) As Integer
[C#]
public virtual int Compare(
   string string1,
   int offset1,
   int length1,
   string string2,
   int offset2,
   int length2
);
[C++]
public: virtual int Compare(
   String* string1,
   int offset1,
   int length1,
   String* string2,
   int offset2,
   int length2
);
[JScript]
public function Compare(
   string1 : String,
   offset1 : int,
   length1 : int,
   string2 : String,
   offset2 : int,
   length2 : int
) : int;

Parameters

string1
[To be supplied.]
offset1
[To be supplied.]
length1
[To be supplied.]
string2
[To be supplied.]
offset2
[To be supplied.]
length2
[To be supplied.]

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.Compare Overload List


CompareInfo.Compare (String, String)

Compares the two specified strings.

[Visual Basic]
Overloads Overridable Public Function Compare( _
   ByVal string1 As String, _
   ByVal string2 As String _
) As Integer
[C#]
public virtual int Compare(
   string string1,
   string string2
);
[C++]
public: virtual int Compare(
   String* string1,
   String* string2
);
[JScript]
public function Compare(
   string1 : String,
   string2 : String
) : int;

Parameters

string1
The first string to be compared.
string2
The second string to be compared.

Return Value

Value | Condition
0 | The two strings are equal.
Less than 0 | The first string is less than the second string.
Greater than 0 | The first string is greater than the second string.

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.Compare Overload List


CompareInfo.Compare (String, String, CompareOptions)

Compares two strings using the specified flags.

[Visual Basic]
Overloads Overridable Public Function Compare( _
   ByVal string1 As String, _
   ByVal string2 As String, _
   ByVal options As CompareOptions _
) As Integer
[C#]
public virtual int Compare(
   string string1,
   string string2,
   CompareOptions options
);
[C++]
public: virtual int Compare(
   String* string1,
   String* string2,
   CompareOptions options
);
[JScript]
public function Compare(
   string1 : String,
   string2 : String,
   options : CompareOptions
) : int;

Parameters

string1
The first string to be compared.
string2
The second string to be compared.
options
The specified flags are the following data members: IgnoreCase, IgnoreKanaType, IgnoreNonSpace, IgnoreSymbols, IgnoreWidth, and StringSort.

Return Value

Value | Condition
0 | The two strings are equal.
Less than 0 | The first string is less than the second string.
Greater than 0 | The first string is greater than the second string.

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.Compare Overload List


CompareInfo.Equals

Checks whether the object refers to the same CompareInfo as the current instance.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal value As Object _
) As Boolean
[C#]
public override bool Equals(
   object value
);
[C++]
public: override bool Equals(
   Object* value
);
[JScript]
public override function Equals(
   value : Object
) : Boolean;

Parameters

value
The object to be compared to the current instance of CompareInfo.

Return Value

true if object is the same as CompareInfo; otherwise, false.[RB15]

Remarks

This method overrides Object.Equals.

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace


CompareInfo.GetCompareInfo

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Shared Function GetCompareInfo(String, Assembly) As CompareInfo
[C#] public static CompareInfo GetCompareInfo(String, Assembly);
[C++] public: static CompareInfo* GetCompareInfo(String*, Assembly);
[JScript] public static function GetCompareInfo(String, Assembly) : CompareInfo;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function GetCompareInfo(Integer) As CompareInfo
[C#] public static CompareInfo GetCompareInfo(int);
[C++] public: static CompareInfo* GetCompareInfo(int);
[JScript] public static function GetCompareInfo(int) : CompareInfo;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function GetCompareInfo(String) As CompareInfo
[C#] public static CompareInfo GetCompareInfo(String);
[C++] public: static CompareInfo* GetCompareInfo(String*);
[JScript] public static function GetCompareInfo(String) : CompareInfo;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function GetCompareInfo(Integer, Assembly) As CompareInfo
[C#] public static CompareInfo GetCompareInfo(int, Assembly);
[C++] public: static CompareInfo* GetCompareInfo(int, Assembly);
[JScript] public static function GetCompareInfo(int, Assembly) : CompareInfo;

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace


CompareInfo.GetCompareInfo (String, Assembly)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function GetCompareInfo( _
   ByVal name As String, _
   ByVal assembly As Assembly _
) As CompareInfo
[C#]
public static CompareInfo GetCompareInfo(
   string name,
   Assembly assembly
);
[C++]
public: static CompareInfo* GetCompareInfo(
   String* name,
   Assembly* assembly
);
[JScript]
public static function GetCompareInfo(
   name : String,
   assembly : Assembly
) : CompareInfo;

Parameters

name
[To be supplied.]
assembly
[To be supplied.]

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.GetCompareInfo Overload List


CompareInfo.GetCompareInfo (Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function GetCompareInfo( _
   ByVal culture As Integer _
) As CompareInfo
[C#]
public static CompareInfo GetCompareInfo(
   int culture
);
[C++]
public: static CompareInfo* GetCompareInfo(
   int culture
);
[JScript]
public static function GetCompareInfo(
   culture : int
) : CompareInfo;

Parameters

culture
[To be supplied.]

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.GetCompareInfo Overload List


CompareInfo.GetCompareInfo (String)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function GetCompareInfo( _
   ByVal name As String _
) As CompareInfo
[C#]
public static CompareInfo GetCompareInfo(
   string name
);
[C++]
public: static CompareInfo* GetCompareInfo(
   String* name
);
[JScript]
public static function GetCompareInfo(
   name : String
) : CompareInfo;

Parameters

name
[To be supplied.]

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.GetCompareInfo Overload List


CompareInfo.GetCompareInfo (Int32, Assembly)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function GetCompareInfo( _
   ByVal culture As Integer, _
   ByVal assembly As Assembly _
) As CompareInfo
[C#]
public static CompareInfo GetCompareInfo(
   int culture,
   Assembly assembly
);
[C++]
public: static CompareInfo* GetCompareInfo(
   int culture,
   Assembly* assembly
);
[JScript]
public static function GetCompareInfo(
   culture : int,
   assembly : Assembly
) : CompareInfo;

Parameters

culture
[To be supplied.]
assembly
[To be supplied.]

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.GetCompareInfo Overload List


CompareInfo.GetHashCode

Gets the hash code for the instance of CompareInfo.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

A hash code for the current CompareInfo object.

Remarks

This method overrides Object.GetHashCode.

If two objects are equal according to the Object.Equals method, they will always have the same hash code.

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace


CompareInfo.GetSortKey

Gets the sort key for the specified string.

Overload List

Gets the sort key for the string with no flags.

[Visual Basic] Overloads Overridable Public Function GetSortKey(String) As SortKey
[C#] public virtual SortKey GetSortKey(String);
[C++] public: virtual SortKey* GetSortKey(String*);
[JScript] public function GetSortKey(String) : SortKey;

Gets the sort key for the string with the specified flags.

[Visual Basic] Overloads Overridable Public Function GetSortKey(String, CompareOptions) As SortKey
[C#] public virtual SortKey GetSortKey(String, CompareOptions);
[C++] public: virtual SortKey* GetSortKey(String*, CompareOptions);
[JScript] public function GetSortKey(String, CompareOptions) : SortKey;

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace


CompareInfo.GetSortKey (String)

Gets the sort key for the string with no flags.

[Visual Basic]
Overloads Overridable Public Function GetSortKey( _
   ByVal source As String _
) As SortKey
[C#]
public virtual SortKey GetSortKey(
   string source
);
[C++]
public: virtual SortKey* GetSortKey(
   String* source
);
[JScript]
public function GetSortKey(
   source : String
) : SortKey;

Parameters

source
The string from which the sort key is to be obtained.

Return Value

The sort key for the string.

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.GetSortKey Overload List


CompareInfo.GetSortKey (String, CompareOptions)

Gets the sort key for the string with the specified flags.

[Visual Basic]
Overloads Overridable Public Function GetSortKey( _
   ByVal source As String, _
   ByVal options As CompareOptions _
) As SortKey
[C#]
public virtual SortKey GetSortKey(
   string source,
   CompareOptions options
);
[C++]
public: virtual SortKey* GetSortKey(
   String* source,
   CompareOptions options
);
[JScript]
public function GetSortKey(
   source : String,
   options : CompareOptions
) : SortKey;

Parameters

source
The string from which the sort key is to be obtained.
options
The flags are the following data members: IgnoreCase, IgnoreKanaType, IgnoreNonSpace, IgnoreSymbols, IgnoreWidth, and StringSort.

Return Value

The SortKey for string.

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.GetSortKey Overload List


CompareInfo.IndexOf

[To be supplied.]

Overload List

Returns the first index of the specified character within a string given the indexes for the search and flags.

[Visual Basic] Overloads Overridable Public Function IndexOf(String, Char, Integer, Integer, CompareOptions) As Integer
[C#] public virtual int IndexOf(String, char, int, int, CompareOptions);
[C++] public: virtual int IndexOf(String*, __wchar_t, int, int, CompareOptions);
[JScript] public function IndexOf(String, Char, int, int, CompareOptions) : int;

Returns the first index of the specified string within a string given the indexes for the search and flags.

[Visual Basic] Overloads Overridable Public Function IndexOf(String, String, Integer, Integer, CompareOptions) As Integer
[C#] public virtual int IndexOf(String, String, int, int, CompareOptions);
[C++] public: virtual int IndexOf(String*, String*, int, int, CompareOptions);
[JScript] public function IndexOf(String, String, int, int, CompareOptions) : int;

Returns the first index of the specified character within a string.

[Visual Basic] Overloads Overridable Public Function IndexOf(String, Char) As Integer
[C#] public virtual int IndexOf(String, char);
[C++] public: virtual int IndexOf(String*, __wchar_t);
[JScript] public function IndexOf(String, Char) : int;

Returns the first index of the specified character within a string using flags.

[Visual Basic] Overloads Overridable Public Function IndexOf(String, Char, CompareOptions) As Integer
[C#] public virtual int IndexOf(String, char, CompareOptions);
[C++] public: virtual int IndexOf(String*, __wchar_t, CompareOptions);
[JScript] public function IndexOf(String, Char, CompareOptions) : int;

Returns the first index of the specified string withina string using flags.

[Visual Basic] Overloads Overridable Public Function IndexOf(String, String, CompareOptions) As Integer
[C#] public virtual int IndexOf(String, String, CompareOptions);
[C++] public: virtual int IndexOf(String*, String*, CompareOptions);
[JScript] public function IndexOf(String, String, CompareOptions) : int;

Returns the first index of the specified string within a string given the indexes for the search.

[Visual Basic] Overloads Overridable Public Function IndexOf(String, String, Integer, Integer) As Integer
[C#] public virtual int IndexOf(String, String, int, int);
[C++] public: virtual int IndexOf(String*, String*, int, int);
[JScript] public function IndexOf(String, String, int, int) : int;

Returns the first index of the specified character within a string given the indexes for the search.

[Visual Basic] Overloads Overridable Public Function IndexOf(String, Char, Integer, Integer) As Integer
[C#] public virtual int IndexOf(String, char, int, int);
[C++] public: virtual int IndexOf(String*, __wchar_t, int, int);
[JScript] public function IndexOf(String, Char, int, int) : int;

Returns the first index of the specified string within a string.

[Visual Basic] Overloads Overridable Public Function IndexOf(String, String) As Integer
[C#] public virtual int IndexOf(String, String);
[C++] public: virtual int IndexOf(String*, String*);
[JScript] public function IndexOf(String, String) : int;

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace


CompareInfo.IndexOf (String, Char, Int32, Int32, CompareOptions)

Returns the first index of the specified character within a string given the indexes for the search and flags.

[Visual Basic]
Overloads Overridable Public Function IndexOf( _
   ByVal source As String, _
   ByVal value As Char, _
   ByVal startIndex As Integer, _
   ByVal endIndex As Integer, _
   ByVal options As CompareOptions _
) As Integer
[C#]
public virtual int IndexOf(
   string source,
   char value,
   int startIndex,
   int endIndex,
   CompareOptions options
);
[C++]
public: virtual int IndexOf(
   String* source,
   __wchar_t value,
   int startIndex,
   int endIndex,
   CompareOptions options
);
[JScript]
public function IndexOf(
   source : String,
   value : Char,
   startIndex : int,
   endIndex : int,
   options : CompareOptions
) : int;

Parameters

source
The string to search.
value
The character to search for within the string.
startIndex
The starting index of the search.
endIndex
The ending index of the search. The search will continue to the end of the string when endIndex is-1.
options
The specified flags are the following data members: IgnoreCase, IgnoreKanaType, IgnoreNonSpace, IgnoreSymbols, IgnoreWidth, and StringSort.

Return Value

Value | Meaning
Less than 0 | The first index where the specified stringvalue is found.
-1 | The specified value is not found.
startIndex | Thevalue argument is an empty string.

Exceptions

Exception Type | Condition
ArgumentException | The value argument is null[RB18] .
IndexOutOfRangeException | The startIndex or endIndex arguments are [RB19] less than 0 or greater than the length of string.

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.IndexOf Overload List


CompareInfo.IndexOf (String, String, Int32, Int32, CompareOptions)

Returns the first index of the specified string within a string given the indexes for the search and flags.

[Visual Basic]
Overloads Overridable Public Function IndexOf( _
   ByVal source As String, _
   ByVal value As String, _
   ByVal startIndex As Integer, _
   ByVal endIndex As Integer, _
   ByVal options As CompareOptions _
) As Integer
[C#]
public virtual int IndexOf(
   string source,
   string value,
   int startIndex,
   int endIndex,
   CompareOptions options
);
[C++]
public: virtual int IndexOf(
   String* source,
   String* value,
   int startIndex,
   int endIndex,
   CompareOptions options
);
[JScript]
public function IndexOf(
   source : String,
   value : String,
   startIndex : int,
   endIndex : int,
   options : CompareOptions
) : int;

Parameters

source
The string to search.
value
The string to search for within the string.
startIndex
The starting index of the search.
endIndex
The ending index of the search. The search will continue to the end of the string when endIndex is-1.
options
The specified flags are the following data members: IgnoreCase, IgnoreKanaType, IgnoreNonSpace, IgnoreSymbols, IgnoreWidth, and StringSort.

Return Value

Value | Meaning
Less than 0 | The first index wherevalue is found.
-1 | value is not found.
startIndex | value is an empty string.

Exceptions

Exception Type | Condition
ArgumentException | The value argument is null.
IndexOutOfRangeException | The startIndex or endIndex arguments are [RB21] less than 0 or greater than the length of string.

Remarks

The search starts from startIndex and ends at endIndex.

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.IndexOf Overload List


CompareInfo.IndexOf (String, Char)

Returns the first index of the specified character within a string.

[Visual Basic]
Overloads Overridable Public Function IndexOf( _
   ByVal source As String, _
   ByVal value As Char _
) As Integer
[C#]
public virtual int IndexOf(
   string source,
   char value
);
[C++]
public: virtual int IndexOf(
   String* source,
   __wchar_t value
);
[JScript]
public function IndexOf(
   source : String,
   value : Char
) : int;

Parameters

source
The string to search.
value
The character value to search for in the string.

Return Value

Value | Meaning
Less than 0 | The first index where the specified stringvalue is found.
-1 | The specified value is not found.
0 | Thevalue parameter is an empty string.

Exceptions

Exception Type | Condition
ArgumentException | is thrown if the value argument is null[RB16] .

Remarks

The entire string is searched.

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.IndexOf Overload List


CompareInfo.IndexOf (String, Char, CompareOptions)

Returns the first index of the specified character within a string using flags.

[Visual Basic]
Overloads Overridable Public Function IndexOf( _
   ByVal source As String, _
   ByVal value As Char, _
   ByVal options As CompareOptions _
) As Integer
[C#]
public virtual int IndexOf(
   string source,
   char value,
   CompareOptions options
);
[C++]
public: virtual int IndexOf(
   String* source,
   __wchar_t value,
   CompareOptions options
);
[JScript]
public function IndexOf(
   source : String,
   value : Char,
   options : CompareOptions
) : int;

Parameters

source
The string to search.
value
The character value to search for within the string.
options
The specified flags are the following data members: IgnoreCase, IgnoreKanaType, IgnoreNonSpace, IgnoreSymbols, IgnoreWidth, and StringSort.

Return Value

Value | Meaning
Less than 0 | The first index where the specified stringvalue is found.
-1 | The specified value is not found.
0 | Thevalue argument is an empty string.

Exceptions

Exception Type | Condition
ArgumentException | is thrown if the value argument is null.

Remarks

The entire string is searched.

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.IndexOf Overload List


CompareInfo.IndexOf (String, String, CompareOptions)

Returns the first index of the specified string withina string using flags.

[Visual Basic]
Overloads Overridable Public Function IndexOf( _
   ByVal source As String, _
   ByVal value As String, _
   ByVal options As CompareOptions _
) As Integer
[C#]
public virtual int IndexOf(
   string source,
   string value,
   CompareOptions options
);
[C++]
public: virtual int IndexOf(
   String* source,
   String* value,
   CompareOptions options
);
[JScript]
public function IndexOf(
   source : String,
   value : String,
   options : CompareOptions
) : int;

Parameters

source
The string to search.
value
The string value to search for within the string.
options
The specified flags are the following data members: IgnoreCase, IgnoreKanaType, IgnoreNonSpace, IgnoreSymbols, IgnoreWidth, and StringSort.

Return Value

Value | Meaning
Less than 0 | The first index where the specified stringvalue is found.
-1 | The specified value is not found.
0 | Thevalue argument is an empty string.

Exceptions

Exception Type | Condition
ArgumentException | is thrown if the value argument is null.

Remarks

The entire string is searched.

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.IndexOf Overload List


CompareInfo.IndexOf (String, String, Int32, Int32)

Returns the first index of the specified string within a string given the indexes for the search.

[Visual Basic]
Overloads Overridable Public Function IndexOf( _
   ByVal source As String, _
   ByVal value As String, _
   ByVal startIndex As Integer, _
   ByVal endIndex As Integer _
) As Integer
[C#]
public virtual int IndexOf(
   string source,
   string value,
   int startIndex,
   int endIndex
);
[C++]
public: virtual int IndexOf(
   String* source,
   String* value,
   int startIndex,
   int endIndex
);
[JScript]
public function IndexOf(
   source : String,
   value : String,
   startIndex : int,
   endIndex : int
) : int;

Parameters

source
The String to search.
value
The string to search for within the string.
startIndex
The starting index of the search.
endIndex
The ending index of the search. The search will continue to the end of the string when endIndex is-1.

Return Value

Value | Meaning
Less than 0 | The first index where the specified stringvalue is found.
-1 | The specified value is not found.
startIndex | Thevalue argument is an empty string.

Exceptions

Exception Type | Condition
ArgumentException | The value argument is null.
IndexOutOfRangeException | The startIndex or endIndex arguments are [RB20] less than 0 or greater than the length of string.

Remarks

The search starts from startIndex and ends at endIndex.

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.IndexOf Overload List


CompareInfo.IndexOf (String, Char, Int32, Int32)

Returns the first index of the specified character within a string given the indexes for the search.

[Visual Basic]
Overloads Overridable Public Function IndexOf( _
   ByVal source As String, _
   ByVal value As Char, _
   ByVal startIndex As Integer, _
   ByVal endIndex As Integer _
) As Integer
[C#]
public virtual int IndexOf(
   string source,
   char value,
   int startIndex,
   int endIndex
);
[C++]
public: virtual int IndexOf(
   String* source,
   __wchar_t value,
   int startIndex,
   int endIndex
);
[JScript]
public function IndexOf(
   source : String,
   value : Char,
   startIndex : int,
   endIndex : int
) : int;

Parameters

source
The string to search.
value
The character value to search for within the string.
startIndex
The starting index of the search.
endIndex
The ending index of the search. The search will continue to the end of the string when endIndex is-1.

Return Value

Value | Meaning
Less than 0 | The first index where the specified stringvalue is found.
-1 | The specified value is not found.
startIndex | Thevalue argument is an empty string.

Exceptions

Exception Type | Condition
ArgumentException | The value argument is null.
IndexOutOfRangeException | The startIndex or endIndex arguments are less [RB17] than 0 or greater than the length of string.

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.IndexOf Overload List


CompareInfo.IndexOf (String, String)

Returns the first index of the specified string within a string.

[Visual Basic]
Overloads Overridable Public Function IndexOf( _
   ByVal source As String, _
   ByVal value As String _
) As Integer
[C#]
public virtual int IndexOf(
   string source,
   string value
);
[C++]
public: virtual int IndexOf(
   String* source,
   String* value
);
[JScript]
public function IndexOf(
   source : String,
   value : String
) : int;

Parameters

source
The string to search.
value
The string value to search for within the string.

Return Value

Value | Meaning
Less than 0 | The first index where the specified stringvalue is found.
-1 | The specified value is not found.
0 | Thevalue argument is an empty string.

Exceptions

Exception Type | Condition
ArgumentException | is thrown if the value argument is null.

Remarks

The entire string is searched.

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.IndexOf Overload List


CompareInfo.IsPrefix

Determines whether the specified prefix is a prefix of the specified string.

Overload List

Determines whether the specified prefix is the string's prefix.

[Visual Basic] Overloads Overridable Public Function IsPrefix(String, String) As Boolean
[C#] public virtual bool IsPrefix(String, String);
[C++] public: virtual bool IsPrefix(String*, String*);
[JScript] public function IsPrefix(String, String) : Boolean;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function IsPrefix(String, String, CompareOptions) As Boolean
[C#] public virtual bool IsPrefix(String, String, CompareOptions);
[C++] public: virtual bool IsPrefix(String*, String*, CompareOptions);
[JScript] public function IsPrefix(String, String, CompareOptions) : Boolean;

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace


CompareInfo.IsPrefix (String, String)

Determines whether the specified prefix is the string's prefix.

[Visual Basic]
Overloads Overridable Public Function IsPrefix( _
   ByVal source As String, _
   ByVal prefix As String _
) As Boolean
[C#]
public virtual bool IsPrefix(
   string source,
   string prefix
);
[C++]
public: virtual bool IsPrefix(
   String* source,
   String* prefix
);
[JScript]
public function IsPrefix(
   source : String,
   prefix : String
) : Boolean;

Parameters

source
The string to search.
prefix
The prefix to search for within the string.

Return Value

true if prefix is the same as the string's prefix or if the prefix is an empty string; false if the length of prefix is greater than the length of string.[RB22]

Exceptions

Exception Type | Condition
NullReferenceException | is thrown if string or prefix are null.

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.IsPrefix Overload List


CompareInfo.IsPrefix (String, String, CompareOptions)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function IsPrefix( _
   ByVal source As String, _
   ByVal prefix As String, _
   ByVal options As CompareOptions _
) As Boolean
[C#]
public virtual bool IsPrefix(
   string source,
   string prefix,
   CompareOptions options
);
[C++]
public: virtual bool IsPrefix(
   String* source,
   String* prefix,
   CompareOptions options
);
[JScript]
public function IsPrefix(
   source : String,
   prefix : String,
   options : CompareOptions
) : Boolean;

Parameters

source
[To be supplied.]
prefix
[To be supplied.]
options
[To be supplied.]

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.IsPrefix Overload List


CompareInfo.IsSuffix

Determines whether the specified suffix is the string's suffix.

Overload List

Compares the specified suffix with the string's suffix.

[Visual Basic] Overloads Overridable Public Function IsSuffix(String, String) As Boolean
[C#] public virtual bool IsSuffix(String, String);
[C++] public: virtual bool IsSuffix(String*, String*);
[JScript] public function IsSuffix(String, String) : Boolean;

Compares the specified suffix with the string's suffix using flags.

[Visual Basic] Overloads Overridable Public Function IsSuffix(String, String, CompareOptions) As Boolean
[C#] public virtual bool IsSuffix(String, String, CompareOptions);
[C++] public: virtual bool IsSuffix(String*, String*, CompareOptions);
[JScript] public function IsSuffix(String, String, CompareOptions) : Boolean;

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace


CompareInfo.IsSuffix (String, String)

Compares the specified suffix with the string's suffix.

[Visual Basic]
Overloads Overridable Public Function IsSuffix( _
   ByVal source As String, _
   ByVal suffix As String _
) As Boolean
[C#]
public virtual bool IsSuffix(
   string source,
   string suffix
);
[C++]
public: virtual bool IsSuffix(
   String* source,
   String* suffix
);
[JScript]
public function IsSuffix(
   source : String,
   suffix : String
) : Boolean;

Parameters

source
The string to search.
suffix
The suffix to search for within the string.

Return Value

true if the suffix argument is the same as the suffix of string or if the suffix is an empty string; false if the length of suffix is greater than the length of string.

Exceptions

Exception Type | Condition
NullReferenceException | is thrown if string or suffix are [RB24] null.

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.IsSuffix Overload List


CompareInfo.IsSuffix (String, String, CompareOptions)

Compares the specified suffix with the string's suffix using flags.

[Visual Basic]
Overloads Overridable Public Function IsSuffix( _
   ByVal source As String, _
   ByVal suffix As String, _
   ByVal options As CompareOptions _
) As Boolean
[C#]
public virtual bool IsSuffix(
   string source,
   string suffix,
   CompareOptions options
);
[C++]
public: virtual bool IsSuffix(
   String* source,
   String* suffix,
   CompareOptions options
);
[JScript]
public function IsSuffix(
   source : String,
   suffix : String,
   options : CompareOptions
) : Boolean;

Parameters

source
The string to search.
suffix
The string suffix to search for within the string.
options
The specified flags are the following data members: IgnoreCase, IgnoreKanaType, IgnoreNonSpace, IgnoreSymbols, IgnoreWidth, and StringSort.

Return Value

true if the suffix argument is the same as the suffix of string or if the suffix is an empty string; false if the length of suffix is greater than the length of string.

Exceptions

Exception Type | Condition
NullReferenceException | is thrown if string or suffix are [RB25] null.

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.IsSuffix Overload List


CompareInfo.LastIndexOf

Returns the last index of the specified character in the string.

Overload List

Gets the last index of a specified string within a string.

[Visual Basic] Overloads Overridable Public Function LastIndexOf(String, String) As Integer
[C#] public virtual int LastIndexOf(String, String);
[C++] public: virtual int LastIndexOf(String*, String*);
[JScript] public function LastIndexOf(String, String) : int;

Gets the last index of the specified character within a string with specified starting and ending search indexes.

[Visual Basic] Overloads Overridable Public Function LastIndexOf(String, Char, Integer, Integer) As Integer
[C#] public virtual int LastIndexOf(String, char, int, int);
[C++] public: virtual int LastIndexOf(String*, __wchar_t, int, int);
[JScript] public function LastIndexOf(String, Char, int, int) : int;

Gets the last index of a specified string within a string using flags.

[Visual Basic] Overloads Overridable Public Function LastIndexOf(String, String, CompareOptions) As Integer
[C#] public virtual int LastIndexOf(String, String, CompareOptions);
[C++] public: virtual int LastIndexOf(String*, String*, CompareOptions);
[JScript] public function LastIndexOf(String, String, CompareOptions) : int;

Gets the last index where the specified character is found in the string.

[Visual Basic] Overloads Overridable Public Function LastIndexOf(String, Char) As Integer
[C#] public virtual int LastIndexOf(String, char);
[C++] public: virtual int LastIndexOf(String*, __wchar_t);
[JScript] public function LastIndexOf(String, Char) : int;

Gets the last index of the specified string within a string with specified starting and ending search indexes using flags.

[Visual Basic] Overloads Overridable Public Function LastIndexOf(String, String, Integer, Integer, CompareOptions) As Integer
[C#] public virtual int LastIndexOf(String, String, int, int, CompareOptions);
[C++] public: virtual int LastIndexOf(String*, String*, int, int, CompareOptions);
[JScript] public function LastIndexOf(String, String, int, int, CompareOptions) : int;

Gets the last index where the specified character is found in the string using flags.

[Visual Basic] Overloads Overridable Public Function LastIndexOf(String, Char, CompareOptions) As Integer
[C#] public virtual int LastIndexOf(String, char, CompareOptions);
[C++] public: virtual int LastIndexOf(String*, __wchar_t, CompareOptions);
[JScript] public function LastIndexOf(String, Char, CompareOptions) : int;

Gets the last index of the specified string within a string with specified starting and ending search indexes.

[Visual Basic] Overloads Overridable Public Function LastIndexOf(String, String, Integer, Integer) As Integer
[C#] public virtual int LastIndexOf(String, String, int, int);
[C++] public: virtual int LastIndexOf(String*, String*, int, int);
[JScript] public function LastIndexOf(String, String, int, int) : int;

Gets the last index of the specified character within a string with specified starting and ending search indexes using flags.

[Visual Basic] Overloads Overridable Public Function LastIndexOf(String, Char, Integer, Integer, CompareOptions) As Integer
[C#] public virtual int LastIndexOf(String, char, int, int, CompareOptions);
[C++] public: virtual int LastIndexOf(String*, __wchar_t, int, int, CompareOptions);
[JScript] public function LastIndexOf(String, Char, int, int, CompareOptions) : int;

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace


CompareInfo.LastIndexOf (String, String)

Gets the last index of a specified string within a string.

[Visual Basic]
Overloads Overridable Public Function LastIndexOf( _
   ByVal source As String, _
   ByVal value As String _
) As Integer
[C#]
public virtual int LastIndexOf(
   string source,
   string value
);
[C++]
public: virtual int LastIndexOf(
   String* source,
   String* value
);
[JScript]
public function LastIndexOf(
   source : String,
   value : String
) : int;

Parameters

source
The string to search.
value
The string to search for within the source.

Return Value

Value | Meaning
Last index | The last index ofvalue in thestring.
-1 | The specified value is not found.
0 | Thevalue argument is an empty string.

Exceptions

Exception Type | Condition
ArgumentException | is thrown if the value argument is null.

Remarks

The search is conducted through the entire source.

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.LastIndexOf Overload List


CompareInfo.LastIndexOf (String, Char, Int32, Int32)

Gets the last index of the specified character within a string with specified starting and ending search indexes.

[Visual Basic]
Overloads Overridable Public Function LastIndexOf( _
   ByVal source As String, _
   ByVal value As Char, _
   ByVal startIndex As Integer, _
   ByVal endIndex As Integer _
) As Integer
[C#]
public virtual int LastIndexOf(
   string source,
   char value,
   int startIndex,
   int endIndex
);
[C++]
public: virtual int LastIndexOf(
   String* source,
   __wchar_t value,
   int startIndex,
   int endIndex
);
[JScript]
public function LastIndexOf(
   source : String,
   value : Char,
   startIndex : int,
   endIndex : int
) : int;

Parameters

source
The string to search.
value
The character to search for within the string.
startIndex
The starting index of the search.
endIndex
The ending index of the search. The search will continue to the end of the string when endIndex is-1.

Return Value

Value | Meaning[RB26]
Last index | The last index of the charactervalue in thestring.
-1 | The specified value is not found.
startIndex | Thevalue argument is an empty string.

Exceptions

Exception Type | Condition
ArgumentException | The value argument is null.
IndexOutOfRangeException | The startIndex or endIndex arguments are [RB27] less than 0 or greater than the length of string.

Remarks

The search starts from startIndex and ends at endIndex.

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.LastIndexOf Overload List


CompareInfo.LastIndexOf (String, String, CompareOptions)

Gets the last index of a specified string within a string using flags.

[Visual Basic]
Overloads Overridable Public Function LastIndexOf( _
   ByVal source As String, _
   ByVal value As String, _
   ByVal options As CompareOptions _
) As Integer
[C#]
public virtual int LastIndexOf(
   string source,
   string value,
   CompareOptions options
);
[C++]
public: virtual int LastIndexOf(
   String* source,
   String* value,
   CompareOptions options
);
[JScript]
public function LastIndexOf(
   source : String,
   value : String,
   options : CompareOptions
) : int;

Parameters

source
The string to search.
value
The string to search for within the source.
options
The specified flags are the following data members: IgnoreCase, IgnoreKanaType, IgnoreNonSpace, IgnoreSymbols, IgnoreWidth, and StringSort.

Return Value

Value | Meaning
Last index | The last index ofvalue in thestring.
-1 | The specified value is not found.
0 | Thevalue argument is an empty string.

Exceptions

Exception Type | Condition
ArgumentException | is thrown if the value argument is null.

Remarks

The search is conducted through the entire source.

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.LastIndexOf Overload List


CompareInfo.LastIndexOf (String, Char)

Gets the last index where the specified character is found in the string.

[Visual Basic]
Overloads Overridable Public Function LastIndexOf( _
   ByVal source As String, _
   ByVal value As Char _
) As Integer
[C#]
public virtual int LastIndexOf(
   string source,
   char value
);
[C++]
public: virtual int LastIndexOf(
   String* source,
   __wchar_t value
);
[JScript]
public function LastIndexOf(
   source : String,
   value : Char
) : int;

Parameters

source
The string to search.
value
The character to search for within the string.

Return Value

Value | Meaning
Last index | The last index of the charactervalue in thestring.
-1 | The specified value is not found.
0 | Thevalue argument is an empty string.

Exceptions

Exception Type | Condition
ArgumentException | is thrown if the value argument is null.

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.LastIndexOf Overload List


CompareInfo.LastIndexOf (String, String, Int32, Int32, CompareOptions)

Gets the last index of the specified string within a string with specified starting and ending search indexes using flags.

[Visual Basic]
Overloads Overridable Public Function LastIndexOf( _
   ByVal source As String, _
   ByVal value As String, _
   ByVal startIndex As Integer, _
   ByVal endIndex As Integer, _
   ByVal options As CompareOptions _
) As Integer
[C#]
public virtual int LastIndexOf(
   string source,
   string value,
   int startIndex,
   int endIndex,
   CompareOptions options
);
[C++]
public: virtual int LastIndexOf(
   String* source,
   String* value,
   int startIndex,
   int endIndex,
   CompareOptions options
);
[JScript]
public function LastIndexOf(
   source : String,
   value : String,
   startIndex : int,
   endIndex : int,
   options : CompareOptions
) : int;

Parameters

source
The string to search.
value
The string value to search for within the string.
startIndex
The starting index of the search.
endIndex
The ending index of the search. The search will continue to the end of the string when endIndex is-1.
options
The specified flags are the following data members: IgnoreCase, IgnoreKanaType, IgnoreNonSpace, IgnoreSymbols, IgnoreWidth, and StringSort.

Return Value

Value | Meaning
Last index | The last index ofvalue in the string.
-1 | The specified value is not found.
startIndex | Thevalue argument is an empty string.

Exceptions

Exception Type | Condition
ArgumentException | The value argument is null.
IndexOutOfRangeException | The startIndex or endIndex arguments are [RB30] less than 0 or greater than the length of string.

Remarks

The search starts from startIndex and ends at endIndex.

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.LastIndexOf Overload List


CompareInfo.LastIndexOf (String, Char, CompareOptions)

Gets the last index where the specified character is found in the string using flags.

[Visual Basic]
Overloads Overridable Public Function LastIndexOf( _
   ByVal source As String, _
   ByVal value As Char, _
   ByVal options As CompareOptions _
) As Integer
[C#]
public virtual int LastIndexOf(
   string source,
   char value,
   CompareOptions options
);
[C++]
public: virtual int LastIndexOf(
   String* source,
   __wchar_t value,
   CompareOptions options
);
[JScript]
public function LastIndexOf(
   source : String,
   value : Char,
   options : CompareOptions
) : int;

Parameters

source
The string to search.
value
The character to search for within the string.
options
The specified flags are the following data members: IgnoreCase, IgnoreKanaType, IgnoreNonSpace, IgnoreSymbols, IgnoreWidth, and StringSort.

Return Value

Value | Meaning
Last index | The last index of the charactervalue in thestring.
-1 | The specified value is not found.
0 | Thevalue argument is an empty string.

Exceptions

Exception Type | Condition
ArgumentException | is thrown if the value argument is null.

Remarks

The search is conducted through the entire string.

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.LastIndexOf Overload List


CompareInfo.LastIndexOf (String, String, Int32, Int32)

Gets the last index of the specified string within a string with specified starting and ending search indexes.

[Visual Basic]
Overloads Overridable Public Function LastIndexOf( _
   ByVal source As String, _
   ByVal value As String, _
   ByVal startIndex As Integer, _
   ByVal endIndex As Integer _
) As Integer
[C#]
public virtual int LastIndexOf(
   string source,
   string value,
   int startIndex,
   int endIndex
);
[C++]
public: virtual int LastIndexOf(
   String* source,
   String* value,
   int startIndex,
   int endIndex
);
[JScript]
public function LastIndexOf(
   source : String,
   value : String,
   startIndex : int,
   endIndex : int
) : int;

Parameters

source
The string to search.
value
The string to search for within the string.
startIndex
The starting index of the search.
endIndex
The ending index of the search. The search will continue to the end of the string when endIndex is-1.

Return Value

Value | Meaning
Last index | The last index ofvalue in the string.
-1 | The specified value is not found.
startIndex | Thevalue argument is an empty string.

Exceptions

Exception Type | Condition
ArgumentException | The value argument is null.
IndexOutOfRangeException | The startIndex or endIndex arguments are [RB29] less than 0 or greater than the length of string.

Remarks

The search starts from startIndex and ends at endIndex.

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.LastIndexOf Overload List


CompareInfo.LastIndexOf (String, Char, Int32, Int32, CompareOptions)

Gets the last index of the specified character within a string with specified starting and ending search indexes using flags.

[Visual Basic]
Overloads Overridable Public Function LastIndexOf( _
   ByVal source As String, _
   ByVal value As Char, _
   ByVal startIndex As Integer, _
   ByVal endIndex As Integer, _
   ByVal options As CompareOptions _
) As Integer
[C#]
public virtual int LastIndexOf(
   string source,
   char value,
   int startIndex,
   int endIndex,
   CompareOptions options
);
[C++]
public: virtual int LastIndexOf(
   String* source,
   __wchar_t value,
   int startIndex,
   int endIndex,
   CompareOptions options
);
[JScript]
public function LastIndexOf(
   source : String,
   value : Char,
   startIndex : int,
   endIndex : int,
   options : CompareOptions
) : int;

Parameters

source
The string to search.
value
The character to search for within the string.
startIndex
The starting index of the search.
endIndex
The ending index of the search. The search will continue to the end of the string when endIndex is-1.
options
The specified flags are the following data members: IgnoreCase, IgnoreKanaType, IgnoreNonSpace, IgnoreSymbols, IgnoreWidth, and StringSort.

Return Value

Value | Meaning
Last index | The last index of the charactervalue in thestring.
-1 | The specified value is not found.
startIndex | Thevalue argument is an empty string.

Exceptions

Exception Type | Condition
ArgumentException | The value argument is null.
IndexOutOfRangeException | The startIndex or endIndex arguments are[RB28] less than 0 or greater than the length of string.

Remarks

The search starts from startIndex and ends at endIndex.

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace | CompareInfo.LastIndexOf Overload List


CompareInfo.ToString

Returns a string describing the current instance of CompareInfo.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

A String describing the current instance of CompareInfo.

Remarks

This method overrides Object.ToString.

See Also

CompareInfo Class | CompareInfo Members | System.Globalization Namespace


CompareOptions Enumeration

[To be supplied.]

[Visual Basic]
Public Enum CompareOptions
[C#]
public enum CompareOptions
[C++]
public enum CompareOptions

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
IgnoreCase | [To be supplied.]
IgnoreKanaType | [To be supplied.]
IgnoreNonSpace | [To be supplied.]
IgnoreSymbols | [To be supplied.]
IgnoreWidth | [To be supplied.]
None | [To be supplied.]
Ordinal | [To be supplied.]
StringSort | [To be supplied.]

Requirements

Namespace: System.Globalization

Assembly: mscorlib.dll

See Also

System.Globalization Namespace


CultureInfo Class

[To be supplied.]

Object
CultureInfo

[Visual Basic]
Public Class CultureInfo
   Implements IServiceObjectProvider
[C#]
public class CultureInfo : IServiceObjectProvider
[C++]
public __gc class CultureInfo : public IServiceObjectProvider
[JScript]
public class CultureInfo implements IServiceObjectProvider

Remarks

It[a1] includes information such as the language, writing system, and calendar used by the culture as well as methods for common operations such as printing dates and sorting strings.

The CultureInfo class is simply a set of user preference information that is dependent on the user's language, sub-language, country, and cultural conventions. This class is useful for obtaining CompareInfo the default locale[a2], which can then be used indirectly by the String class.

The CultureInfo class implements the IFormatProvider interface, which is also implemented by NumberFormatInfo. This obtains the format information object based on the CultureInfo of the current thread by calling CultureInfo.GetFormat (NumberFormatInfo class).

The NLS[a3] class is used to retrieve region and language settings, conduct culturally correct sorting, string comparison, formatting dates and time, string mapping and determining character type information.[a4]

The user selects the locale for the system as the system is installed. The culture names follow the RFC1766 names. The format is as follows <language>-<country>, for example, US English will be "en-US". The language is a lowercase two-letter code in ISO 639-1. The location is an uppercase two-letter code in ISO 3166. For more information see Culture Names.

The following is a list of the predefined CultureInfo names used by the CultureInfo(String) constructor and the Globalization API.[a5]

CultureInfo Name | Culture
af | South Africa
af-neutral | South Africa
ar | Saudi Arabia
ar-ae | U.A.E[a6].
ar-bh | Bahrain
ar-dz | Algeria
ar-eg | Egypt
ar-iq | Iraq
ar-jo | Jordan
ar-kw | Kuwait
ar-lb | Lebanon
ar-ly | Libya
ar-ma | Morocco
ar-om | Oman
ar-qa | Qatar
ar-sa | Saudi Arabia
ar-sy | Syria
ar-tn | Tunisia
ar-ye | Yemen
as | India
as-neutral | India
az-cyrillic | Azerbaijan
az-latin | Azerbaijan
az-neutral | Azerbaijan
be | Belarus
bg | Bulgaria
bg-neutral | Bulgaria
bn | India
bn-neutral | India
ca | Spain
ca-neutral | Spain
da | Denmark
da-neutral | Denmark
de | Germany
de-at | Austria
de-ch | Switzerland
de-li | Liechtenstein
de-lu | Luxembourg
de-neutral | Germany
el | Greece
el-neutral | Greece
en-au | Australia
en-bz | Belize
en-ca | Canada
en-cb | Caribbean
en-gb | United Kingdom
en-ie | Ireland
en-jm | Jamaica
en-neutral | United States
en-nz | New Zealand
en-ph | Republic of the Philippines
en-tt | Trinidad y Tobago
en-us | United States
en-za | South Africa
en-zw | Zimbabwe
es | Spain
es-ar | Argentina
es-bo | Bolivia
es-cl | Chile
es-co | Colombia
es-cr | Costa Rica
es-do | Dominican Republic
es-ec | Ecuador
es-es | Spain
es-gt | Guatemala
es-hn | Honduras
es-mx | Mexico
es-neutral | Spain
es-ni | Nicaragua
es-pa | Panama
es-pe | Peru
es-pr | Puerto Rico
es-py | Paraguay
es-sv | El Salvador
es-uy | Uruguay
es-ve | Venezuela
et | Estonia
et-neutral | Estonia
eu | Spain
eu-neutral | Spain
fa | Iran
fa-neutral | Iran
fi | Finland
fo | Faeroe Islands
fo-neutral | Faeroe Islands
fr | Faeroe Islands
fr-be | Belgium
fr-ca | Canada
fr-ch | Switzerland
fr-lu | Luxembourg
fr-mc | Principality of Monaco
fr-neutral | France
gu | India
gu-neutral | India
he | Israel
he-neutral | Israel
hi | India
hi-kok | India
hi-neutral | India
hi-neutral2 | India
hr-neutral | Croatia
hu | Hungary
hu-neutral | Hungary
hy | Republic of Armenia
hy-neutral | Republic of Armenia
id | Indonesia
id-neutral | Indonesia
is | Iceland
it | Italy
it-ch | Switzerland
it-neutral | Italy
ja | Japan
ja-neutral | Japan
ka | Georgia
ka-neutral | Georgia
kk | Kazakhstan
kk-neutral | Kazakhstan
kn | India
kn-neutral | India
ko | Korea
ko-neutral | Korea
lt | Lithuania
lt-neutral | Lithuania
lv | Latvia
lv-neutral | Latvia
mk | Former Yugoslav Republic of Macedonia
ml | India
ml-neutral | India
mr | India
mr-neutral | India
ms | Malaysia
ms-br | Brunei Darussalam
ms-neutral | Malaysia
ne | India
ne-neutral | India
nl | Netherlands
nl-be | Belgium
nl-neutral | Netherlands
no | Norway
no-bok | Norway
no-no | Norway
or | India
or-neutral | India
pa | India
pa-neutral | India
pl | Poland
pl-neutral | Poland
pt | Portugal
pt-br | Brazil
pt-neutral | Brazil
ro | Romania
ro-neutral | Romania
ru | Russia
ru-neutral | Russia
sa | India
sa-neutral | India
sk | Slovakia
sk-neutral | Slovakia
sl | Slovenia
sl-neutral | Slovenia
sq | Albania
sq-neutral | Albania
sr | Serbia
sr-sp | Serbia
sv | Sweden
sv-fi | Finland
sv-neutral | Sweden
sw | Kenya
sw-neutral | Kenya
ta | India
ta-neutral | India
te | India
te-neutral | India
th | Thailand
th-neutral | Thailand
tr | Turkey
tr-neutral | Turkey
tt | Tatarstan
tt-neutral | Tatarstan
uk | Ukraine
uk-neutral | Ukraine
ur | Islamic Republic of Pakistan
ur-neutral | Islamic Republic of Pakistan
uz | Republic of Uzbekistan
uz-neutral | Republic of Uzbekistan
uz-uz | Republic of Uzbekistan
vi | Viet Nam
vi-neutral | Viet Nam
zh | People's Republic of China
zh-cn | People's Republic of China
zh-hk | Hong Kong
zh-mo | Macau
zh-sg | Singapore
zh-tw | Taiwan

Requirements

Namespace: System.Globalization

Assembly: mscorlib.dll

See Also

CultureInfo Members | System.Globalization Namespace


CultureInfo Members

Public:

Constructor

CultureInfo Constructor Overloaded. [To be supplied.]

Properties

Calendar | [To be supplied.]
CompareInfo | [To be supplied.]
CurrentCulture | [To be supplied.]
CurrentUICulture | [To be supplied.]
DisplayName | Gets the full name of the CultureInfo in the UI language.
EnglishName | Gets the full name of the CultureInfo in the UI language.
InstalledUICulture | [To be supplied.]
InvariantCulture | [To be supplied.]
LCID | Gets the properly formed culture identifier for the current CultureInfo.
Name | Gets the full name of the CultureInfo in the UI language.
NativeName | Gets the full name of the CultureInfo in the native language.
OptionalCalendars | [To be supplied.]
Parent | [To be supplied.]
TextInfo | [To be supplied.]
ThreeLetterISOLanguageName | Gets the ISO 3166 three-letter code for the region of the current CultureInfo.
ThreeLetterWindowLanguageName | Gets the Windows version of the three-letter code for the region of the current CultureInfo.
TwoLetterISOLanguageName | Gets the ISO 3166 two-letter code for the region of the current CultureInfo.

Methods

Equals | Determines whether the specified object refers to the same CultureInfo as the current instance.
GetCultures | [To be supplied.]
GetHashCode | Returns the hash code for the current CultureInfo.
GetServiceObject | Returns a service object for the current instance.
GetThreadCulture | Gets the CultureInfo for the current thread.
GetType (inherited from Object) | Gets the Type of the Object.
SetThreadCulture | Sets the culture on the current thread
ToString | Obtains the name of the CultureInfo.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CultureInfo Class | System.Globalization Namespace


CultureInfo Constructor

[To be supplied.]

Overload List

Initializes a new instance of the CultureInfo class.

[Visual Basic] Overloads Public Sub New(String)
[C#] public CultureInfo(String);
[C++] public: CultureInfo(String*);
[JScript] public function CultureInfo(String);

Initializes a new instance of the CultureInfo class that most closely corresponds to the specified NLS locale identifier.

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public CultureInfo(int);
[C++] public: CultureInfo(int);
[JScript] public function CultureInfo(int);

See Also

CultureInfo Class | CultureInfo Members | System.Globalization Namespace


CultureInfo Constructor (String)

Initializes a new instance of the CultureInfo class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal name As String _
)
[C#]
public CultureInfo(
   string name
);
[C++]
public: CultureInfo(
   String* name
);
[JScript]
public function CultureInfo(
   name : String
);

Parameters

name
A predefined CultureInfo-supplied name with NLS+[a10] or a user-defined name of a previously created CultureInfo. See CultureNames[a11] for a list of names provided with NLS+.

Remarks

The name may be either [a12] a predefined CultureInfo supplied with Globalization or a user-defined name of a previously created CultureInfo. The table at the top of these reference pages provides a list of names.

See Also

CultureInfo Class | CultureInfo Members | System.Globalization Namespace | CultureInfo Constructor Overload List


CultureInfo Constructor (Int32)

Initializes a new instance of the CultureInfo class that most closely corresponds to the specified NLS locale identifier.

[Visual Basic]
Overloads Public Sub New( _
   ByVal culture As Integer _
)
[C#]
public CultureInfo(
   int culture
);
[C++]
public: CultureInfo(
   int culture
);
[JScript]
public function CultureInfo(
   culture : int
);

Parameters

culture
The culture identifier contains information about the primary language identifier, sub-language identifier, and sort ID. The culture parameter is mapped to the corresponding NLS locale identifier.

Exceptions

Exception Type | Condition
ArgumentException | is thrown if culture is not a supported NLS locale identifier.

Remarks

This constructor is provided for ease of integration with NLS-based software.

See Also

CultureInfo Class | CultureInfo Members | System.Globalization Namespace | CultureInfo Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CultureInfo Properties

The properties of the CultureInfo class are listed below. For a complete list of CultureInfo class members, see the CultureInfo Members topic.

Public:

Calendar | [To be supplied.]
CompareInfo | [To be supplied.]
CurrentCulture | [To be supplied.]
CurrentUICulture | [To be supplied.]
DisplayName | Gets the full name of the CultureInfo in the UI language.
EnglishName | Gets the full name of the CultureInfo in the UI language.
InstalledUICulture | [To be supplied.]
InvariantCulture | [To be supplied.]
LCID | Gets the properly formed culture identifier for the current CultureInfo.
Name | Gets the full name of the CultureInfo in the UI language.
NativeName | Gets the full name of the CultureInfo in the native language.
OptionalCalendars | [To be supplied.]
Parent | [To be supplied.]
TextInfo | [To be supplied.]
ThreeLetterISOLanguageName | Gets the ISO 3166 three-letter code for the region of the current CultureInfo.
ThreeLetterWindowLanguageName | Gets the Windows version of the three-letter code for the region of the current CultureInfo.
TwoLetterISOLanguageName | Gets the ISO 3166 two-letter code for the region of the current CultureInfo.

See Also

CultureInfo Class | System.Globalization Namespace


CultureInfo.Calendar

[To be supplied.]

[Visual Basic]
Overridable Public Property Calendar As Calendar
[C#]
public Calendar Calendar {virtual get; virtual set;}
[C++]
public: __property virtual Calendar* get_Calendar();
public: __property virtual void set_Calendar(Calendar*);
[JScript]
public function get Calendar() : Calendar;
public function set Calendar(Calendar);

See Also

CultureInfo Class | CultureInfo Members | System.Globalization Namespace


CultureInfo.CompareInfo

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property CompareInfo As CompareInfo
[C#]
public CompareInfo CompareInfo {virtual get;}
[C++]
public: __property virtual CompareInfo* get_CompareInfo();
[JScript]
public function get CompareInfo() : CompareInfo;

See Also

CultureInfo Class | CultureInfo Members | System.Globalization Namespace


CultureInfo.CurrentCulture

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property CurrentCulture As CultureInfo
[C#]
public static CultureInfo CurrentCulture {get;}
[C++]
public: __property static CultureInfo* get_CurrentCulture();
[JScript]
public static function get CurrentCulture() : CultureInfo;

See Also

CultureInfo Class | CultureInfo Members | System.Globalization Namespace


CultureInfo.CurrentUICulture

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property CurrentUICulture As CultureInfo
[C#]
public static CultureInfo CurrentUICulture {get;}
[C++]
public: __property static CultureInfo* get_CurrentUICulture();
[JScript]
public static function get CurrentUICulture() : CultureInfo;

See Also

CultureInfo Class | CultureInfo Members | System.Globalization Namespace


CultureInfo.DisplayName

Gets the full name of the CultureInfo in the UI language.

[Visual Basic]
Overridable Public ReadOnly Property DisplayName As String
[C#]
public string DisplayName {virtual get;}
[C++]
public: __property virtual String* get_DisplayName();
[JScript]
public function get DisplayName() : String;

See Also

CultureInfo Class | CultureInfo Members | System.Globalization Namespace


CultureInfo.EnglishName

Gets the full name of the CultureInfo in the UI language.

[Visual Basic]
Overridable Public ReadOnly Property EnglishName As String
[C#]
public string EnglishName {virtual get;}
[C++]
public: __property virtual String* get_EnglishName();
[JScript]
public function get EnglishName() : String;

See Also

CultureInfo Class | CultureInfo Members | System.Globalization Namespace


CultureInfo.InstalledUICulture

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property InstalledUICulture As CultureInfo
[C#]
public static CultureInfo InstalledUICulture {get;}
[C++]
public: __property static CultureInfo* get_InstalledUICulture();
[JScript]
public static function get InstalledUICulture() : CultureInfo;

See Also

CultureInfo Class | CultureInfo Members | System.Globalization Namespace


CultureInfo.InvariantCulture

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Property InvariantCulture As CultureInfo
[C#]
public static CultureInfo InvariantCulture {get;}
[C++]
public: __property static CultureInfo* get_InvariantCulture();
[JScript]
public static function get InvariantCulture() : CultureInfo;

See Also

CultureInfo Class | CultureInfo Members | System.Globalization Namespace


CultureInfo.LCID

Gets the properly formed culture identifier for the current CultureInfo.

[Visual Basic]
Overridable Public ReadOnly Property LCID As Integer
[C#]
public int LCID {virtual get;}
[C++]
public: __property virtual int get_LCID();
[JScript]
public function get LCID() : int;

Property Value

Read-only. The culture identifier for the current CultureInfo.

Remarks

This property is provided for ease of integration with NLS-based software.

See Also

CultureInfo Class | CultureInfo Members | System.Globalization Namespace


CultureInfo.Name

Gets the full name of the CultureInfo in the UI language.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {virtual get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

Property Value

Read-only. The full name of the CultureInfo in the UI language. For example, if the CultureInfo is US English, "en-us" will be retrieved.

Remarks

This is the string used to construct a CultureInfo. It is in the format of ISO639-2 (three-letter language name) plus underscore plus ISO 3166 (three-letter country name).

See Also

CultureInfo Class | CultureInfo Members | System.Globalization Namespace


CultureInfo.NativeName

Gets the full name of the CultureInfo in the native language.

[Visual Basic]
Overridable Public ReadOnly Property NativeName As String
[C#]
public string NativeName {virtual get;}
[C++]
public: __property virtual String* get_NativeName();
[JScript]
public function get NativeName() : String;

Property Value

Read-only. The full name of the CultureInfo in the native language. For example, if the CultureInfo is US English, "English (United States)" will be returned.

See Also

CultureInfo Class | CultureInfo Members | System.Globalization Namespace


CultureInfo.OptionalCalendars

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property OptionalCalendars As Calendar _
   ()
[C#]
public Calendar[] OptionalCalendars {virtual get;}
[C++]
public: __property virtual Calendar* get_OptionalCalendars();
[JScript]
public function get OptionalCalendars() : Calendar[];

See Also

CultureInfo Class | CultureInfo Members | System.Globalization Namespace


CultureInfo.Parent

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Parent As CultureInfo
[C#]
public CultureInfo Parent {virtual get;}
[C++]
public: __property virtual CultureInfo* get_Parent();
[JScript]
public function get Parent() : CultureInfo;

See Also

CultureInfo Class | CultureInfo Members | System.Globalization Namespace


CultureInfo.TextInfo

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property TextInfo As TextInfo
[C#]
public TextInfo TextInfo {virtual get;}
[C++]
public: __property virtual TextInfo* get_TextInfo();
[JScript]
public function get TextInfo() : TextInfo;

See Also

CultureInfo Class | CultureInfo Members | System.Globalization Namespace


CultureInfo.ThreeLetterISOLanguageName

Gets the ISO 3166 three-letter code for the region of the current CultureInfo.

[Visual Basic]
Overridable Public ReadOnly Property ThreeLetterISOLanguageName As _
   String
[C#]
public string ThreeLetterISOLanguageName {virtual get;}
[C++]
public: __property virtual String* get_ThreeLetterISOLanguageName();
[JScript]
public function get ThreeLetterISOLanguageName() : String;

Property Value

Read-only. The ISO 3166 three-letter code for the region. For example, the three-letter abbreviation for United States is "usa".

See Also

CultureInfo Class | CultureInfo Members | System.Globalization Namespace


CultureInfo.ThreeLetterWindowLanguageName

Gets the Windows version of the three-letter code for the region of the current CultureInfo.

[Visual Basic]
Overridable Public ReadOnly Property ThreeLetterWindowLanguageName _
   As String
[C#]
public string ThreeLetterWindowLanguageName {virtual get;}
[C++]
public: __property virtual String*
   get_ThreeLetterWindowLanguageName();
[JScript]
public function get ThreeLetterWindowLanguageName() : String;

Property Value

Read-only. The three-letter code for the region. For example, the three-letter abbreviation for United States is "usa".

See Also

CultureInfo Class | CultureInfo Members | System.Globalization Namespace


CultureInfo.TwoLetterISOLanguageName

Gets the ISO 3166 two-letter code for the region of the current CultureInfo.

[Visual Basic]
Overridable Public ReadOnly Property TwoLetterISOLanguageName As _
   String
[C#]
public string TwoLetterISOLanguageName {virtual get;}
[C++]
public: __property virtual String* get_TwoLetterISOLanguageName();
[JScript]
public function get TwoLetterISOLanguageName() : String;

Property Value

Read-only. The two-letter code for the region. For example, the two-letter abbreviation for United States is "us".

See Also

CultureInfo Class | CultureInfo Members | System.Globalization Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CultureInfo Methods

The methods of the CultureInfo class are listed below. For a complete list of CultureInfo class members, see the CultureInfo Members topic.

Public:

Equals | Determines whether the specified object refers to the same CultureInfo as the current instance.
GetCultures | [To be supplied.]
GetHashCode | Returns the hash code for the current CultureInfo.
GetServiceObject | Returns a service object for the current instance.
GetThreadCulture | Gets the CultureInfo for the current thread.
GetType (inherited from Object) | Gets the Type of the Object.
SetThreadCulture | Sets the culture on the current thread
ToString | Obtains the name of the CultureInfo.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CultureInfo Class | System.Globalization Namespace


CultureInfo.Equals

Determines whether the specified object refers to the same CultureInfo as the current instance.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal value As Object _
) As Boolean
[C#]
public override bool Equals(
   object value
);
[C++]
public: override bool Equals(
   Object* value
);
[JScript]
public override function Equals(
   value : Object
) : Boolean;

Parameters

value
The specified object.

Return Value

true if object refers to the same CultureInfo as the current instance; otherwise, false.

Remarks

This method overrides Object.Equals.

See Also

CultureInfo Class | CultureInfo Members | System.Globalization Namespace


CultureInfo.GetCultures

[To be supplied.]

[Visual Basic]
Public Shared Function GetCultures( _
   ByVal types As CultureTypes _
) As CultureInfo ()
[C#]
public static CultureInfo[] GetCultures(
   CultureTypes types
);
[C++]
public: static CultureInfo* GetCultures(
   CultureTypes types
) [];
[JScript]
public static function GetCultures(
   types : CultureTypes
) : CultureInfo[];

Parameters

types
[To be supplied.]

See Also

CultureInfo Class | CultureInfo Members | System.Globalization Namespace


CultureInfo.GetHashCode

Returns the hash code for the current CultureInfo.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

The hash code for the CultureInfo.

Remarks

The hash code is guaranteed to be the same for CultureInfo A and B where A.Equals(B) is true.

This method implements Object.GetHashCode.

See Also

CultureInfo Class | CultureInfo Members | System.Globalization Namespace


CultureInfo.GetServiceObject

Returns a service object for the current instance.

[Visual Basic]
Overridable Public Function GetServiceObject( _
   ByVal service As Type _
) As Object
[C#]
public virtual object GetServiceObject(
   Type service
);
[C++]
public: virtual Object* GetServiceObject(
   Type* service
);
[JScript]
public function GetServiceObject(
   service : Type
) : Object;

Parameters

service
A Type object representing the type of the[a15] service object to get. This function supports only NumberFormatInfo and DateTimeFormatInfo Type objects.

Return Value

A NumberFormatInfo object containing the default number format information for this CultureInfo if service is the Type object for the NumberFormatInfo class. If service is the Type object for the DateTimeFormatInfo class, a DateTimeFormatInfo object containing the default date and time format information for the current CultureInfo is returned. Otherwise, null is returned.

Remarks

This method is invoked by the Format(String, IServiceObjectProvider) method supported by the base data types when the current instance is passed as the IServiceObjectProvider.

This method implements IServiceObjectProvider.GetServiceObject.

See Also

CultureInfo Class | CultureInfo Members | System.Globalization Namespace


CultureInfo.GetThreadCulture

Gets the CultureInfo for the current thread.

[Visual Basic]
Public Shared Function GetThreadCulture() As CultureInfo
[C#]
public static CultureInfo GetThreadCulture();
[C++]
public: static CultureInfo* GetThreadCulture();
[JScript]
public static function GetThreadCulture() : CultureInfo;

See Also

CultureInfo Class | CultureInfo Members | System.Globalization Namespace


CultureInfo.SetThreadCulture

Sets the culture on the current thread

[Visual Basic]
Public Shared Sub SetThreadCulture( _
   ByVal culture As CultureInfo _
)
[C#]
public static void SetThreadCulture(
   CultureInfo culture
);
[C++]
public: static void SetThreadCulture(
   CultureInfo* culture
);
[JScript]
public static function SetThreadCulture(
   culture : CultureInfo
);

Parameters

culture
The CultureInfo to set the thread to.

See Also

CultureInfo Class | CultureInfo Members | System.Globalization Namespace


CultureInfo.ToString

Obtains the name of the CultureInfo.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

The name of the CultureInfo. For example, the name for the CultureInfo of the United States, whose national language is English, would be "English (United States)".

Remarks

This method overrides Object.ToString.

See Also

CultureInfo Class | CultureInfo Members | System.Globalization Namespace


CultureTypes Enumeration

[To be supplied.]

[Visual Basic]
Public Enum CultureTypes
[C#]
public enum CultureTypes
[C++]
public enum CultureTypes

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
AllCultures | [To be supplied.]
InstalledWin32Cultures | [To be supplied.]
NeutralCultures | [To be supplied.]
SpecificCultures | [To be supplied.]

Requirements

Namespace: System.Globalization

Assembly: mscorlib.dll

See Also

System.Globalization Namespace


DateTimeFormatInfo Class

[To be supplied.]

Object
DateTimeFormatInfo

[Visual Basic]
Public Class DateTimeFormatInfo
   Implements ICloneable, IServiceObjectProvider
[C#]
public class DateTimeFormatInfo : ICloneable,
   IServiceObjectProvider
[C++]
public __gc class DateTimeFormatInfo : public ICloneable,
   IServiceObjectProvider
[JScript]
public class DateTimeFormatInfo implements ICloneable,
   IServiceObjectProvider

Remarks

[To be supplied.]

Requirements

Namespace: System.Globalization

Assembly: mscorlib.dll

See Also

DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo Members

Public:

Constructor

DateTimeFormatInfo Constructor Initializes a new culture-independent instance of the DateTimeFormatInfo class. The instance will be invariant, or culturally-independent. The properties of this DateTimeFormatInfo can be modified, if user-defined formatting is desired.

Properties

AbbreviatedDayNames | Retrieves or assigns the abbreviated day names array. The default values are {"Sun", "Mon", "Tue", "Wed", "Thu", "Fri", "Sat"}.
AbbreviatedMonthNames | Retrieves or assigns the names of the months in their abbreviated form.
AMDesignator | Retrieves or assigns the AM designator, with a default value of "AM".
Calendar | [To be supplied.]
CurrentInfo | Returns a DateTimeFormatInfo object that formats values based on the CultureInfo of the current thread.
DateSeparator | Retrieves or assigns the date separator, with a default value of "/".
DayNames | Retrieves or assigns the day names array, with the default values of "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday", "Saturday".
FirstDayOfWeek | Retrieves or assigns the first day of the week, with a default value of 0.
FirstWeekOfYear | Retrieves or assigns the first week of the year.
FullDateTimePattern | Holds the pattern associated with the 'F' format character.
InvariantInfo | Returns a default DateTimeFormatInfo value that formats values in an invariant, or culturally-independent way.
IsReadOnly | Retrieves a value indicating whether the values of this DateTimeFormatInfo object can be modified.
LongDatePattern | Retrieves or assigns the pattern associated with the 'D' format character.
LongTimePattern | Retrieves or assigns the pattern associated with the 'T' format character.
MonthDayPattern | Retrieves or assigns the pattern associated with the 'm' and 'M' format characters.
MonthNames | Retrieves or assigns the names of the months.
PMDesignator | Retrieves or assigns the PM designator, with a default value of "PM".
RFC1123Pattern | Retrieves the pattern associated with the 'r' and 'R' format characters. It represents the RFC standard. [ls3]
ShortDatePattern | Retrieves or assigns the pattern associated with the 'd' format character.
ShortTimePattern | Retrieves or assigns the pattern associated with the 't' format character.
SortableDateTimePattern | Retrieves the associated with the 's' format character.
TimeSeparator | Retrieves or assigns the time separator.
UniversalSortableDateTimePattern | Retrieves the universal sortable DateTime pattern.
YearMonthPattern | Retrieves or assigns the pattern associated with the 'y' and 'Y' format characters.

Methods

Clone | Creates a shallow copy of this instance and sets its ReadOnly field to false.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetAbbreviatedDayName | Overloaded. [To be supplied.]
GetAbbreviatedMonthName | Overloaded. [To be supplied.]
GetAllDateTimePatterns | Overloaded. [To be supplied.]
GetDayName | Overloaded. [To be supplied.]
GetEra | [To be supplied.]
GetEraName | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInstance | Gets the specified DateTimeFormatInfo object.
GetMonthName | Overloaded. Returns the name of the month of the year.
GetServiceObject | Gets the service object of the specified type.
GetType (inherited from Object) | Gets the Type of the Object.
ReadOnly | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DateTimeFormatInfo Class | System.Globalization Namespace


DateTimeFormatInfo Constructor

Initializes a new culture-independent instance of the DateTimeFormatInfo class. The instance will be invariant, or culturally-independent. The properties of this DateTimeFormatInfo can be modified, if user-defined formatting is desired.

[Visual Basic]
Public Sub New()
[C#]
public DateTimeFormatInfo();
[C++]
public: DateTimeFormatInfo();
[JScript]
public function DateTimeFormatInfo();

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DateTimeFormatInfo Properties

The properties of the DateTimeFormatInfo class are listed below. For a complete list of DateTimeFormatInfo class members, see the DateTimeFormatInfo Members topic.

Public:

AbbreviatedDayNames | Retrieves or assigns the abbreviated day names array. The default values are {"Sun", "Mon", "Tue", "Wed", "Thu", "Fri", "Sat"}.
AbbreviatedMonthNames | Retrieves or assigns the names of the months in their abbreviated form.
AMDesignator | Retrieves or assigns the AM designator, with a default value of "AM".
Calendar | [To be supplied.]
CurrentInfo | Returns a DateTimeFormatInfo object that formats values based on the CultureInfo of the current thread.
DateSeparator | Retrieves or assigns the date separator, with a default value of "/".
DayNames | Retrieves or assigns the day names array, with the default values of "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday", "Saturday".
FirstDayOfWeek | Retrieves or assigns the first day of the week, with a default value of 0.
FirstWeekOfYear | Retrieves or assigns the first week of the year.
FullDateTimePattern | Holds the pattern associated with the 'F' format character.
InvariantInfo | Returns a default DateTimeFormatInfo value that formats values in an invariant, or culturally-independent way.
IsReadOnly | Retrieves a value indicating whether the values of this DateTimeFormatInfo object can be modified.
LongDatePattern | Retrieves or assigns the pattern associated with the 'D' format character.
LongTimePattern | Retrieves or assigns the pattern associated with the 'T' format character.
MonthDayPattern | Retrieves or assigns the pattern associated with the 'm' and 'M' format characters.
MonthNames | Retrieves or assigns the names of the months.
PMDesignator | Retrieves or assigns the PM designator, with a default value of "PM".
RFC1123Pattern | Retrieves the pattern associated with the 'r' and 'R' format characters. It represents the RFC standard. [ls3]
ShortDatePattern | Retrieves or assigns the pattern associated with the 'd' format character.
ShortTimePattern | Retrieves or assigns the pattern associated with the 't' format character.
SortableDateTimePattern | Retrieves the associated with the 's' format character.
TimeSeparator | Retrieves or assigns the time separator.
UniversalSortableDateTimePattern | Retrieves the universal sortable DateTime pattern.
YearMonthPattern | Retrieves or assigns the pattern associated with the 'y' and 'Y' format characters.

See Also

DateTimeFormatInfo Class | System.Globalization Namespace


DateTimeFormatInfo.AbbreviatedDayNames

Retrieves or assigns the abbreviated day names array. The default values are {"Sun", "Mon", "Tue", "Wed", "Thu", "Fri", "Sat"}.

[Visual Basic]
Overridable Public Property AbbreviatedDayNames As String ()
[C#]
public string[] AbbreviatedDayNames {virtual get; virtual set;}
[C++]
public: __property virtual String* get_AbbreviatedDayNames();
public: __property virtual void set_AbbreviatedDayNames(String*[]);
[JScript]
public function get AbbreviatedDayNames() : String[];
public function set AbbreviatedDayNames(String[]);

Property Value

. The abbreviated names of the days of the week.

Remarks

The length of this array must be 7. For the invariant

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.AbbreviatedMonthNames

Retrieves or assigns the names of the months in their abbreviated form.

[Visual Basic]
Overridable Public Property AbbreviatedMonthNames As String ()
[C#]
public string[] AbbreviatedMonthNames {virtual get; virtual set;}
[C++]
public: __property virtual String* get_AbbreviatedMonthNames();
public: __property virtual void set_AbbreviatedMonthNames(String*[]);
[JScript]
public function get AbbreviatedMonthNames() : String[];
public function set AbbreviatedMonthNames(String[]);

Property Value

Retrieves and assigns the contents of the abbreviated month names array.

Remarks

Note that the length of the array must be 13, since some calendars have 13 months. If you are working with a 12 month calendar, the 13th element in the array should be an empty string. For the invariant

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.AMDesignator

Retrieves or assigns the AM designator, with a default value of "AM".

[Visual Basic]
Overridable Public Property AMDesignator As String
[C#]
public string AMDesignator {virtual get; virtual set;}
[C++]
public: __property virtual String* get_AMDesignator();
public: __property virtual void set_AMDesignator(String*);
[JScript]
public function get AMDesignator() : String;
public function set AMDesignator(String);

Property Value

The AM designator. The default value is "AM."

Remarks

Note: Assignment is not allowed if the DateTimeFormatInfo object is read-only.

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.Calendar

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Calendar As Calendar
[C#]
public Calendar Calendar {virtual get;}
[C++]
public: __property virtual Calendar* get_Calendar();
[JScript]
public function get Calendar() : Calendar;

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.CurrentInfo

Returns a DateTimeFormatInfo object that formats values based on the CultureInfo of the current thread.

[Visual Basic]
Public Shared ReadOnly Property CurrentInfo As DateTimeFormatInfo
[C#]
public static DateTimeFormatInfo CurrentInfo {get;}
[C++]
public: __property static DateTimeFormatInfo* get_CurrentInfo();
[JScript]
public static function get CurrentInfo() : DateTimeFormatInfo;

Property Value

Returns a DateTimeFormatInfo object from the current locale.

Remarks

It is not possible to set the properties on the culture-specific DateTimeFormatInfo object that is returned.

See DateTimeFormatInfo for details.

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.DateSeparator

Retrieves or assigns the date separator, with a default value of "/".

[Visual Basic]
Overridable Public Property DateSeparator As String
[C#]
public string DateSeparator {virtual get; virtual set;}
[C++]
public: __property virtual String* get_DateSeparator();
public: __property virtual void set_DateSeparator(String*);
[JScript]
public function get DateSeparator() : String;
public function set DateSeparator(String);

Property Value

The date separator, which is "/" by default.

Remarks

Note: Assignment is not allowed if the DateTimeFormatInfo object is read-only.

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.DayNames

Retrieves or assigns the day names array, with the default values of "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday", "Saturday".

[Visual Basic]
Overridable Public Property DayNames As String ()
[C#]
public string[] DayNames {virtual get; virtual set;}
[C++]
public: __property virtual String* get_DayNames();
public: __property virtual void set_DayNames(String*[]);
[JScript]
public function get DayNames() : String[];
public function set DayNames(String[]);

Property Value

The contents of the day names array. The default value is {"Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday", "Saturday"}.

Remarks

Note: Assignment is not allowed if the DateTimeFormatInfo object is read-only.

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.FirstDayOfWeek

Retrieves or assigns the first day of the week, with a default value of 0.

[Visual Basic]
Overridable Public Property FirstDayOfWeek As Integer
[C#]
public int FirstDayOfWeek {virtual get; virtual set;}
[C++]
public: __property virtual int get_FirstDayOfWeek();
public: __property virtual void set_FirstDayOfWeek(int);
[JScript]
public function get FirstDayOfWeek() : int;
public function set FirstDayOfWeek(int);

Property Value

RAn integer representing the first day of the week. The default value is 0.

Remarks

Note: Assignment is not allowed if the DateTimeFormatInfo object is read-only.

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.FirstWeekOfYear

Retrieves or assigns the first week of the year.

[Visual Basic]
Overridable Public Property FirstWeekOfYear As Integer
[C#]
public int FirstWeekOfYear {virtual get; virtual set;}
[C++]
public: __property virtual int get_FirstWeekOfYear();
public: __property virtual void set_FirstWeekOfYear(int);
[JScript]
public function get FirstWeekOfYear() : int;
public function set FirstWeekOfYear(int);

Property Value

Retrieves and assigns an integer representing the first week of the year. For the invariant DateTimeFormatInfo, the value is 0.

Remarks

Note: Assignment is not allowed if the DateTimeFormatInfo object is read-only.

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.FullDateTimePattern

Holds the pattern associated with the 'F' format character.

[Visual Basic]
Overridable Public Property FullDateTimePattern As String
[C#]
public string FullDateTimePattern {virtual get; virtual set;}
[C++]
public: __property virtual String* get_FullDateTimePattern();
public: __property virtual void set_FullDateTimePattern(String*);
[JScript]
public function get FullDateTimePattern() : String;
public function set FullDateTimePattern(String);

Property Value

The pattern associated with the 'F' format character. The default value is "dddd, MMMM dd, yyyy HH:mm:ss".

Remarks

Note: Assignment is not allowed if the DateTimeFormatInfo object is read-only.

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.InvariantInfo

Returns a default DateTimeFormatInfo value that formats values in an invariant, or culturally-independent way.

[Visual Basic]
Public Shared ReadOnly Property InvariantInfo As DateTimeFormatInfo
[C#]
public static DateTimeFormatInfo InvariantInfo {get;}
[C++]
public: __property static DateTimeFormatInfo* get_InvariantInfo();
[JScript]
public static function get InvariantInfo() : DateTimeFormatInfo;

Property Value

Returns an invariant DateTimeFormatInfo object.

Remarks

It is not possible to set the properties on the DateTimeFormatInfo object that is returned. See the cpclaSystem.Globalization.datetimeformatinfoclass topic for details.

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.IsReadOnly

Retrieves a value indicating whether the values of this DateTimeFormatInfo object can be modified.

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {virtual get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;

Property Value

true or false.

Remarks

See the class description and the constructor topic for details on the use of the read-only property.

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.LongDatePattern

Retrieves or assigns the pattern associated with the 'D' format character.

[Visual Basic]
Overridable Public Property LongDatePattern As String
[C#]
public string LongDatePattern {virtual get; virtual set;}
[C++]
public: __property virtual String* get_LongDatePattern();
public: __property virtual void set_LongDatePattern(String*);
[JScript]
public function get LongDatePattern() : String;
public function set LongDatePattern(String);

Property Value

The long date pattern. The default value is "dddd, MMMM dd, yyyy".

Remarks

Note: Assignment is not allowed if the DateTimeFormatInfo object is read-only.

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.LongTimePattern

Retrieves or assigns the pattern associated with the 'T' format character.

[Visual Basic]
Overridable Public Property LongTimePattern As String
[C#]
public string LongTimePattern {virtual get; virtual set;}
[C++]
public: __property virtual String* get_LongTimePattern();
public: __property virtual void set_LongTimePattern(String*);
[JScript]
public function get LongTimePattern() : String;
public function set LongTimePattern(String);

Property Value

The long time pattern. The default value is "HH:mm:ss".

Remarks

Note: Assignment is not allowed if the DateTimeFormatInfo object is read-only.

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.MonthDayPattern

Retrieves or assigns the pattern associated with the 'm' and 'M' format characters.

[Visual Basic]
Overridable Public Property MonthDayPattern As String
[C#]
public string MonthDayPattern {virtual get; virtual set;}
[C++]
public: __property virtual String* get_MonthDayPattern();
public: __property virtual void set_MonthDayPattern(String*);
[JScript]
public function get MonthDayPattern() : String;
public function set MonthDayPattern(String);

Property Value

The month-day date pattern. The default value is "MMMM dd".

Remarks

Note: Assignment is not allowed if the DateTimeFormatInfo object is read-only.

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.MonthNames

Retrieves or assigns the names of the months.

[Visual Basic]
Overridable Public Property MonthNames As String ()
[C#]
public string[] MonthNames {virtual get; virtual set;}
[C++]
public: __property virtual String* get_MonthNames();
public: __property virtual void set_MonthNames(String*[]);
[JScript]
public function get MonthNames() : String[];
public function set MonthNames(String[]);

Property Value

The contents of the month names array. If you are working with a 12 month calendar, the 13th element in the array should be an empty string. For the invariant

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.PMDesignator

Retrieves or assigns the PM designator, with a default value of "PM".

[Visual Basic]
Overridable Public Property PMDesignator As String
[C#]
public string PMDesignator {virtual get; virtual set;}
[C++]
public: __property virtual String* get_PMDesignator();
public: __property virtual void set_PMDesignator(String*);
[JScript]
public function get PMDesignator() : String;
public function set PMDesignator(String);

Property Value

The PM designator. The default value is "PM".

Remarks

Note: Assignment is not allowed if the DateTimeFormatInfo object is read-only.

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.RFC1123Pattern

Retrieves the pattern associated with the 'r' and 'R' format characters. It represents the RFC standard. [ls3]

[Visual Basic]
Overridable Public ReadOnly Property RFC1123Pattern As String
[C#]
public string RFC1123Pattern {virtual get;}
[C++]
public: __property virtual String* get_RFC1123Pattern();
[JScript]
public function get RFC1123Pattern() : String;

Property Value

A string describing the RFC standard. The default value is "HH:mm:ss".

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.ShortDatePattern

Retrieves or assigns the pattern associated with the 'd' format character.

[Visual Basic]
Overridable Public Property ShortDatePattern As String
[C#]
public string ShortDatePattern {virtual get; virtual set;}
[C++]
public: __property virtual String* get_ShortDatePattern();
public: __property virtual void set_ShortDatePattern(String*);
[JScript]
public function get ShortDatePattern() : String;
public function set ShortDatePattern(String);

Property Value

The short date pattern. The default value is "MM/dd/yyyy".

Remarks

Note: Assignment is not allowed if the DateTimeFormatInfo object is read-only.

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.ShortTimePattern

Retrieves or assigns the pattern associated with the 't' format character.

[Visual Basic]
Overridable Public Property ShortTimePattern As String
[C#]
public string ShortTimePattern {virtual get; virtual set;}
[C++]
public: __property virtual String* get_ShortTimePattern();
public: __property virtual void set_ShortTimePattern(String*);
[JScript]
public function get ShortTimePattern() : String;
public function set ShortTimePattern(String);

Property Value

The short time pattern. The default value is "HH:mm".

Remarks

Note: Assignment is not allowed if the DateTimeFormatInfo object is read-only.

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.SortableDateTimePattern

Retrieves the associated with the 's' format character.

[Visual Basic]
Overridable Public ReadOnly Property SortableDateTimePattern As _
   String
[C#]
public string SortableDateTimePattern {virtual get;}
[C++]
public: __property virtual String* get_SortableDateTimePattern();
[JScript]
public function get SortableDateTimePattern() : String;

Property Value

The sortable DateTime pattern. The default value is "yyyy-MM-dd HH:mm:ss".

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.TimeSeparator

Retrieves or assigns the time separator.

[Visual Basic]
Overridable Public Property TimeSeparator As String
[C#]
public string TimeSeparator {virtual get; virtual set;}
[C++]
public: __property virtual String* get_TimeSeparator();
public: __property virtual void set_TimeSeparator(String*);
[JScript]
public function get TimeSeparator() : String;
public function set TimeSeparator(String);

Property Value

The time separator. The default value is ":".

Remarks

Note: Assignment is not allowed if the DateTimeFormatInfo object is read-only.

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.UniversalSortableDateTimePattern

Retrieves the universal sortable DateTime pattern.

[Visual Basic]
Overridable Public ReadOnly Property _
   UniversalSortableDateTimePattern As String
[C#]
public string UniversalSortableDateTimePattern {virtual get;}
[C++]
public: __property virtual String*
   get_UniversalSortableDateTimePattern();
[JScript]
public function get UniversalSortableDateTimePattern() : String;

Property Value

The DateTime pattern. The default value is "yyyy-MM-dd HH:mm:ss".

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.YearMonthPattern

Retrieves or assigns the pattern associated with the 'y' and 'Y' format characters.

[Visual Basic]
Overridable Public Property YearMonthPattern As String
[C#]
public string YearMonthPattern {virtual get; virtual set;}
[C++]
public: __property virtual String* get_YearMonthPattern();
public: __property virtual void set_YearMonthPattern(String*);
[JScript]
public function get YearMonthPattern() : String;
public function set YearMonthPattern(String);

Property Value

The year-month pattern. The default value is "MMMM, yyyy".

Remarks

Note: Assignment is not allowed if the DateTimeFormatInfo object is read-only.

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DateTimeFormatInfo Methods

The methods of the DateTimeFormatInfo class are listed below. For a complete list of DateTimeFormatInfo class members, see the DateTimeFormatInfo Members topic.

Public:

Clone | Creates a shallow copy of this instance and sets its ReadOnly field to false.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetAbbreviatedDayName | Overloaded. [To be supplied.]
GetAbbreviatedMonthName | Overloaded. [To be supplied.]
GetAllDateTimePatterns | Overloaded. [To be supplied.]
GetDayName | Overloaded. [To be supplied.]
GetEra | [To be supplied.]
GetEraName | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInstance | Gets the specified DateTimeFormatInfo object.
GetMonthName | Overloaded. Returns the name of the month of the year.
GetServiceObject | Gets the service object of the specified type.
GetType (inherited from Object) | Gets the Type of the Object.
ReadOnly | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DateTimeFormatInfo Class | System.Globalization Namespace


DateTimeFormatInfo.Clone

Creates a shallow copy of this instance and sets its ReadOnly field to false.

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

Remarks

The properties of the DateTimeFormatInfo object that is created by this method can be modified, if user-defined formatting is desired.

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.GetAbbreviatedDayName

[To be supplied.]

Overload List

Returns the abbreviated name of a specified day of the week.

[Visual Basic] Overloads Overridable Public Function GetAbbreviatedDayName(Integer) As String
[C#] public virtual string GetAbbreviatedDayName(int);
[C++] public: virtual String* GetAbbreviatedDayName(int);
[JScript] public function GetAbbreviatedDayName(int) : String;

Returns the abbreviated name of the specified day of the week using the specified calendar.

[Visual Basic] Overloads Overridable Public Function GetAbbreviatedDayName(Integer, Calendar) As String
[C#] public virtual string GetAbbreviatedDayName(int, Calendar);
[C++] public: virtual String* GetAbbreviatedDayName(int, Calendar);
[JScript] public function GetAbbreviatedDayName(int, Calendar) : String;

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.GetAbbreviatedDayName (Int32)

Returns the abbreviated name of a specified day of the week.

[Visual Basic]
Overloads Overridable Public Function GetAbbreviatedDayName( _
   ByVal dayofweek As Integer _
) As String
[C#]
public virtual string GetAbbreviatedDayName(
   int dayofweek
);
[C++]
public: virtual String* GetAbbreviatedDayName(
   int dayofweek
);
[JScript]
public function GetAbbreviatedDayName(
   dayofweek : int
) : String;

Parameters

dayofweek
A value representing the day of the week. This must satisfy 0 <= dayofweek <= 6.

Return Value

Returns the abbreviated name of the day of the week represented by dayofweek.

Remarks

This method calls GetAbbreviatedDayName(int dayofweek, Calendar* calendar) and passes along the calendar associated with the CultureInfo of the current thread.

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace | DateTimeFormatInfo.GetAbbreviatedDayName Overload List


DateTimeFormatInfo.GetAbbreviatedDayName (Int32, Calendar)

Returns the abbreviated name of the specified day of the week using the specified calendar.

[Visual Basic]
Overloads Overridable Public Function GetAbbreviatedDayName( _
   ByVal dayofweek As Integer, _
   ByVal calendar As Calendar _
) As String
[C#]
public virtual string GetAbbreviatedDayName(
   int dayofweek,
   Calendar calendar
);
[C++]
public: virtual String* GetAbbreviatedDayName(
   int dayofweek,
   Calendar* calendar
);
[JScript]
public function GetAbbreviatedDayName(
   dayofweek : int,
   calendar : Calendar
) : String;

Parameters

dayofweek
A value representing the day of the week. This must satisfy 0 <= dayofweek <= 6.
calendar
The Calendar that represents the calendar in which to get the abbreviated name. If this is null, the GregorianCalendar is used.

Return Value

Returns the abbreviated name for the specified day of the week.

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace | DateTimeFormatInfo.GetAbbreviatedDayName Overload List


DateTimeFormatInfo.GetAbbreviatedMonthName

[To be supplied.]

Overload List

Returns the abbreviated name of the month of the year represented by the specified value using the specified calendar.

[Visual Basic] Overloads Overridable Public Function GetAbbreviatedMonthName(Integer, Calendar) As String
[C#] public virtual string GetAbbreviatedMonthName(int, Calendar);
[C++] public: virtual String* GetAbbreviatedMonthName(int, Calendar);
[JScript] public function GetAbbreviatedMonthName(int, Calendar) : String;

Returns the abbreviated name of the specified month of the year.

[Visual Basic] Overloads Overridable Public Function GetAbbreviatedMonthName(Integer) As String
[C#] public virtual string GetAbbreviatedMonthName(int);
[C++] public: virtual String* GetAbbreviatedMonthName(int);
[JScript] public function GetAbbreviatedMonthName(int) : String;

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.GetAbbreviatedMonthName (Int32, Calendar)

Returns the abbreviated name of the month of the year represented by the specified value using the specified calendar.

[Visual Basic]
Overloads Overridable Public Function GetAbbreviatedMonthName( _
   ByVal month As Integer, _
   ByVal calendar As Calendar _
) As String
[C#]
public virtual string GetAbbreviatedMonthName(
   int month,
   Calendar calendar
);
[C++]
public: virtual String* GetAbbreviatedMonthName(
   int month,
   Calendar* calendar
);
[JScript]
public function GetAbbreviatedMonthName(
   month : int,
   calendar : Calendar
) : String;

Parameters

month
An integer value representing the month for which an abbreviated name is to be returned. The value must be between 1 and 13, inclusive.
calendar
The calendar to be used in obtaining the day name. If this value is null the GregorianCalendar will be used.

Return Value

Returns the abbreviated name of the month represented by month.

Remarks

This method is only partially implemented.

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace | DateTimeFormatInfo.GetAbbreviatedMonthName Overload List


DateTimeFormatInfo.GetAbbreviatedMonthName (Int32)

Returns the abbreviated name of the specified month of the year.

[Visual Basic]
Overloads Overridable Public Function GetAbbreviatedMonthName( _
   ByVal month As Integer _
) As String
[C#]
public virtual string GetAbbreviatedMonthName(
   int month
);
[C++]
public: virtual String* GetAbbreviatedMonthName(
   int month
);
[JScript]
public function GetAbbreviatedMonthName(
   month : int
) : String;

Parameters

month
An integer value representing the month for which an abbreviated name is to be returned. The value must be between 1 and 13, inclusive.

Return Value

The abbreviated name of the month represented by month.

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace | DateTimeFormatInfo.GetAbbreviatedMonthName Overload List


DateTimeFormatInfo.GetAllDateTimePatterns

[To be supplied.]

Overload List

Gets the patterns in which DateTime values can be formatted with the specified format character. See the table of format characters in DateTimeFormatInfo.

[Visual Basic] Overloads Overridable Public Function GetAllDateTimePatterns(Char) As String ()
[C#] public virtual string[] GetAllDateTimePatterns(char);
[C++] public: virtual String* GetAllDateTimePatterns(__wchar_t) [];
[JScript] public function GetAllDateTimePatterns(Char) : String[];

Gets the patterns in which DateTime values can be formatted using the default format characters. See the table of format characters in DateTimeFormatInfo.

[Visual Basic] Overloads Overridable Public Function GetAllDateTimePatterns() As String ()
[C#] public virtual string[] GetAllDateTimePatterns();
[C++] public: virtual String* GetAllDateTimePatterns() [];
[JScript] public function GetAllDateTimePatterns() : String[];

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.GetAllDateTimePatterns (Char)

Gets the patterns in which DateTime values can be formatted with the specified format character. See the table of format characters in DateTimeFormatInfo.

[Visual Basic]
Overloads Overridable Public Function GetAllDateTimePatterns( _
   ByVal format As Char _
) As String ()
[C#]
public virtual string[] GetAllDateTimePatterns(
   char format
);
[C++]
public: virtual String* GetAllDateTimePatterns(
   __wchar_t format
) [];
[JScript]
public function GetAllDateTimePatterns(
   format : Char
) : String[];

Parameters

format
A format character. This must be one of the default format characters shown in the table in DateTimeFormatInfo.

Return Value

An array containing the patterns in which DateTime values can be formatted with the specified format character.

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace | DateTimeFormatInfo.GetAllDateTimePatterns Overload List


DateTimeFormatInfo.GetAllDateTimePatterns ()

Gets the patterns in which DateTime values can be formatted using the default format characters. See the table of format characters in DateTimeFormatInfo.

[Visual Basic]
Overloads Overridable Public Function GetAllDateTimePatterns() As String ()
[C#]
public virtual string[] GetAllDateTimePatterns();
[C++]
public: virtual String* GetAllDateTimePatterns() [];
[JScript]
public function GetAllDateTimePatterns() : String[];

Return Value

An array containing the patterns in which DateTime values can be formatted via the default format characters.

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace | DateTimeFormatInfo.GetAllDateTimePatterns Overload List


DateTimeFormatInfo.GetDayName

[To be supplied.]

Overload List

Returns the name of the specified day of the week.

[Visual Basic] Overloads Overridable Public Function GetDayName(Integer) As String
[C#] public virtual string GetDayName(int);
[C++] public: virtual String* GetDayName(int);
[JScript] public function GetDayName(int) : String;

Returns the name of the specified day of the week using the specified calendar.

[Visual Basic] Overloads Overridable Public Function GetDayName(Integer, Calendar) As String
[C#] public virtual string GetDayName(int, Calendar);
[C++] public: virtual String* GetDayName(int, Calendar);
[JScript] public function GetDayName(int, Calendar) : String;

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.GetDayName (Int32)

Returns the name of the specified day of the week.

[Visual Basic]
Overloads Overridable Public Function GetDayName( _
   ByVal dayofweek As Integer _
) As String
[C#]
public virtual string GetDayName(
   int dayofweek
);
[C++]
public: virtual String* GetDayName(
   int dayofweek
);
[JScript]
public function GetDayName(
   dayofweek : int
) : String;

Parameters

dayofweek
A value representing the day of the week for which a name is to be returned.

Return Value

The name of the day of the week represented by dayofweek.

Remarks

For the invariant

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace | DateTimeFormatInfo.GetDayName Overload List


DateTimeFormatInfo.GetDayName (Int32, Calendar)

Returns the name of the specified day of the week using the specified calendar.

[Visual Basic]
Overloads Overridable Public Function GetDayName( _
   ByVal dayofweek As Integer, _
   ByVal calendar As Calendar _
) As String
[C#]
public virtual string GetDayName(
   int dayofweek,
   Calendar calendar
);
[C++]
public: virtual String* GetDayName(
   int dayofweek,
   Calendar* calendar
);
[JScript]
public function GetDayName(
   dayofweek : int,
   calendar : Calendar
) : String;

Parameters

dayofweek
A value representing the day of the week for which a name is to be returned.
calendar
The calendar to be used in obtaining the day name.

Return Value

The name of the day of the week represented by dayofweek.

Remarks

For the invariant

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace | DateTimeFormatInfo.GetDayName Overload List


DateTimeFormatInfo.GetEra

[To be supplied.]

[Visual Basic]
Overridable Public Function GetEra( _
   ByVal eraName As String _
) As Integer
[C#]
public virtual int GetEra(
   string eraName
);
[C++]
public: virtual int GetEra(
   String* eraName
);
[JScript]
public function GetEra(
   eraName : String
) : int;

Parameters

eraName
[To be supplied.]

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.GetEraName

[To be supplied.]

[Visual Basic]
Overridable Public Function GetEraName( _
   ByVal era As Integer _
) As String
[C#]
public virtual string GetEraName(
   int era
);
[C++]
public: virtual String* GetEraName(
   int era
);
[JScript]
public function GetEraName(
   era : int
) : String;

Parameters

era
[To be supplied.]

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.GetInstance

Gets the specified DateTimeFormatInfo object.

[Visual Basic]
Public Shared Function GetInstance( _
   ByVal sop As IServiceObjectProvider _
) As DateTimeFormatInfo
[C#]
public static DateTimeFormatInfo GetInstance(
   IServiceObjectProvider sop
);
[C++]
public: static DateTimeFormatInfo* GetInstance(
   IServiceObjectProvider* sop
);
[JScript]
public static function GetInstance(
   sop : IServiceObjectProvider
) : DateTimeFormatInfo;

Parameters

sop
The IServiceObjectProvider used to get the DateTimeFormatInfo object.

Return Value

Returns a DateTimeFormatInfo object as described [C5]below .

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.GetMonthName

Returns the name of the month of the year.

Overload List

Returns the name of the specified month of the year.

[Visual Basic] Overloads Overridable Public Function GetMonthName(Integer) As String
[C#] public virtual string GetMonthName(int);
[C++] public: virtual String* GetMonthName(int);
[JScript] public function GetMonthName(int) : String;

Returns the name of the specified month of the year using the specified calendar.

[Visual Basic] Overloads Overridable Public Function GetMonthName(Integer, Calendar) As String
[C#] public virtual string GetMonthName(int, Calendar);
[C++] public: virtual String* GetMonthName(int, Calendar);
[JScript] public function GetMonthName(int, Calendar) : String;

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.GetMonthName (Int32)

Returns the name of the specified month of the year.

[Visual Basic]
Overloads Overridable Public Function GetMonthName( _
   ByVal month As Integer _
) As String
[C#]
public virtual string GetMonthName(
   int month
);
[C++]
public: virtual String* GetMonthName(
   int month
);
[JScript]
public function GetMonthName(
   month : int
) : String;

Parameters

month
A value representing the month whose name is to be returned.

Return Value

The name of the month represented by month.

Remarks

For the invariant

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace | DateTimeFormatInfo.GetMonthName Overload List


DateTimeFormatInfo.GetMonthName (Int32, Calendar)

Returns the name of the specified month of the year using the specified calendar.

[Visual Basic]
Overloads Overridable Public Function GetMonthName( _
   ByVal month As Integer, _
   ByVal calendar As Calendar _
) As String
[C#]
public virtual string GetMonthName(
   int month,
   Calendar calendar
);
[C++]
public: virtual String* GetMonthName(
   int month,
   Calendar* calendar
);
[JScript]
public function GetMonthName(
   month : int,
   calendar : Calendar
) : String;

Parameters

month
A value representing the month whose name is to be returned. This must satisfy 1 <= month <= 13.
calendar
The calendar to be used in obtaining the day name. a Calendar object that represents the calendar in which to get the name. If this is null the GregorianCalendar is used.

Return Value

Returns the name of the month represented by month.

Remarks

For the invariant

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace | DateTimeFormatInfo.GetMonthName Overload List


DateTimeFormatInfo.GetServiceObject

Gets the service object of the specified type.

[Visual Basic]
Overridable Public Function GetServiceObject( _
   ByVal service As Type _
) As Object
[C#]
public virtual object GetServiceObject(
   Type service
);
[C++]
public: virtual Object* GetServiceObject(
   Type* service
);
[JScript]
public function GetServiceObject(
   service : Type
) : Object;

Parameters

service
The class object of the format-information object to get.

Return Value

If service is the Type object for the DateTimeFormatInfo class, then this instance of DateTimeFormatInfo is returned. Otherwise, null is returned.

Remarks

This method is invoked by the Format(String, IServiceObjectProvider) method supported by the base data types when this instance is passed as the IServiceObjectProvider. It implements IServiceObjectProvider.GetServiceObject.

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeFormatInfo.ReadOnly

[To be supplied.]

[Visual Basic]
Public Shared Function ReadOnly( _
   ByVal dtfi As DateTimeFormatInfo _
) As DateTimeFormatInfo
[C#]
public static DateTimeFormatInfo ReadOnly(
   DateTimeFormatInfo dtfi
);
[C++]
public: static DateTimeFormatInfo* ReadOnly(
   DateTimeFormatInfo* dtfi
);
[JScript]
public static function ReadOnly(
   dtfi : DateTimeFormatInfo
) : DateTimeFormatInfo;

Parameters

dtfi
[To be supplied.]

See Also

DateTimeFormatInfo Class | DateTimeFormatInfo Members | System.Globalization Namespace


DateTimeStyles Enumeration

[To be supplied.]

[Visual Basic]
Public Enum DateTimeStyles
[C#]
public enum DateTimeStyles
[C++]
public enum DateTimeStyles

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
AllowInnerWhite | [To be supplied.]
AllowLeadingWhite | [To be supplied.]
AllowTrailingWhite | [To be supplied.]
AllowWhiteSpaces | [To be supplied.]
None | [To be supplied.]

Requirements

Namespace: System.Globalization

Assembly: mscorlib.dll

See Also

System.Globalization Namespace


DaylightTime Structure

[To be supplied.]

Object
ValueType
DaylightTime

[Visual Basic]
Public Structure DaylightTime
[C#]
public struct DaylightTime
[C++]
public __value struct DaylightTime

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Globalization

Assembly: mscorlib.dll

See Also

DaylightTime Members | System.Globalization Namespace


DaylightTime Members

Public:

Methods

Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Fields

Delta | Delta to standard offset in ticks.
End | The end date of a daylight saving period.
Start | The start time of a daylight saving period.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DaylightTime Structure | System.Globalization Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DaylightTime Fields

The fields of the DaylightTime structure are listed below. For a complete list of DaylightTime structure members, see the DaylightTime Members topic.

Public:

Delta | Delta to standard offset in ticks.
End | The end date of a daylight saving period.
Start | The start time of a daylight saving period.

See Also

DaylightTime Structure | System.Globalization Namespace


DaylightTime.Delta

Delta to standard offset in ticks.

[Visual Basic]
Public Delta As Long
[C#]
public long Delta;
[C++]
public: __int64 Delta;
[JScript]
public var Delta : long;

See Also

DaylightTime Structure | DaylightTime Members | System.Globalization Namespace


DaylightTime.End

The end date of a daylight saving period.

[Visual Basic]
Public End As DateTime
[C#]
public DateTime End;
[C++]
public: DateTime End;
[JScript]
public var End : DateTime;

See Also

DaylightTime Structure | DaylightTime Members | System.Globalization Namespace


DaylightTime.Start

The start time of a daylight saving period.

[Visual Basic]
Public Start As DateTime
[C#]
public DateTime Start;
[C++]
public: DateTime Start;
[JScript]
public var Start : DateTime;

See Also

DaylightTime Structure | DaylightTime Members | System.Globalization Namespace


GregorianCalendar Class

[To be supplied.]

Object
Calendar
GregorianCalendar

[Visual Basic]
Public Class GregorianCalendar
   Inherits Calendar
[C#]
public class GregorianCalendar : Calendar
[C++]
public __gc class GregorianCalendar : public Calendar
[JScript]
public class GregorianCalendar extends Calendar

Remarks

In 1582, Pope Gregory XIII made minor changes to the solar Julian or "Old Style" calendar to make it more accurate. Thus the calendar became known as the Gregorian or "New Style" calendar, and adopted in Catholic countries such as Spain and France. Later the Gregorian calendar became popular throughout Western Europe because it was accurate and convenient for international trade. Scandinavian countries adopted it in 1700, Great Britain in 1752, the American colonies in 1752 and India in 1757. China adopted the same calendar in 1911, Russia in 1918, and some Eastern European countries as late as 1940. This calendar recognizes two era values: 0 CurrentEra (AD) 1 BeforeCurrentEra (BC)

Requirements

Namespace: System.Globalization

Assembly: mscorlib.dll

See Also

GregorianCalendar Members | System.Globalization Namespace


GregorianCalendar Members

Public:

Constructor

GregorianCalendar Constructor Overloaded. [To be supplied.]

Properties

CalendarType | [To be supplied.]
Eras | [To be supplied.]
TwoDigitYearMax | Returns the date and time converted to a DateTime value. This value is the upper boundary of a 100-year range that allows a two-digit year to be properly translated to a four-digit year.

Methods

AddDays (inherited from Calendar) | Returns the DateTime object resulting from adding a fractional number of days to the specified DateTime.
AddHours (inherited from Calendar) | Returns the DateTime resulting from adding a fractional number of hours to the specified DateTime.
AddMilliseconds (inherited from Calendar) | Returns the DateTime resulting from adding the specified number of milliseconds to the specified DateTime.
AddMinutes (inherited from Calendar) | Returns the DateTime resulting from adding a fractional number of minutes to the specified DateTime.
AddMonths | Returns the DateTime resulting from adding the given number of months to the specified DateTime.
AddSeconds (inherited from Calendar) | Returns the DateTime resulting from adding a number of seconds to the specified DateTime.
AddWeeks | Returns the DateTime resulting from adding a number of weeks to the specified DateTime.
AddYears | Returns the DateTime resulting from adding the given number of years to the specified DateTime.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDayOfMonth | Returns the day-of-month part of the given DateTime.
GetDayOfWeek | Returns the day-of-week part of the specified DateTime.
GetDayOfYear | Returns the day-of-year part of the specified DateTime.
GetDaysInMonth | Overloaded. [To be supplied.]
GetDaysInYear | Overloaded. [To be supplied.]
GetEra | Overloaded. [To be supplied.]
GetEraName | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHour (inherited from Calendar) | Returns the hour part of the specified DateTime.
GetMilliseconds (inherited from Calendar) | Returns the millisecond part of the specified DateTime.
GetMinute (inherited from Calendar) | Returns the minute part of the specified DateTime.
GetMonth | Returns the month part of the specified DateTime.
GetMonthsInYear | Overloaded. [To be supplied.]
GetSecond (inherited from Calendar) | Returns the second [RB26] part of the specified DateTime.
GetType (inherited from Object) | Gets the Type of the Object.
GetWeekOfYear | Returns the week of year for the given Datetime.
GetYear | Returns the year part of the specified DateTime.
IsLeapDay | Overloaded. [To be supplied.]
IsLeapMonth | Overloaded. [To be supplied.]
IsLeapYear (inherited from Calendar) | Overloaded. [To be supplied.]
ToDateTime | Overloaded. [To be supplied.]
ToFourDigitYear (inherited from Calendar) | Converts the specified year to the appropriate century by using the TwoDigitYearMax property.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

ADEra [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GregorianCalendar Class | System.Globalization Namespace


GregorianCalendar Constructor

[To be supplied.]

Overload List

Initializes an instance of the GregorianCalendar class.

[Visual Basic] Overloads Public Sub New()
[C#] public GregorianCalendar();
[C++] public: GregorianCalendar();
[JScript] public function GregorianCalendar();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(GregorianCalendarTypes)
[C#] public GregorianCalendar(GregorianCalendarTypes);
[C++] public: GregorianCalendar(GregorianCalendarTypes);
[JScript] public function GregorianCalendar(GregorianCalendarTypes);

See Also

GregorianCalendar Class | GregorianCalendar Members | System.Globalization Namespace


GregorianCalendar Constructor ()

Initializes an instance of the GregorianCalendar class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public GregorianCalendar();
[C++]
public: GregorianCalendar();
[JScript]
public function GregorianCalendar();

See Also

GregorianCalendar Class | GregorianCalendar Members | System.Globalization Namespace | GregorianCalendar Constructor Overload List


GregorianCalendar Constructor (GregorianCalendarTypes)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal type As GregorianCalendarTypes _
)
[C#]
public GregorianCalendar(
   GregorianCalendarTypes type
);
[C++]
public: GregorianCalendar(
   GregorianCalendarTypes type
);
[JScript]
public function GregorianCalendar(
   type : GregorianCalendarTypes
);

Parameters

type
[To be supplied.]

See Also

GregorianCalendar Class | GregorianCalendar Members | System.Globalization Namespace | GregorianCalendar Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

GregorianCalendar Properties

The properties of the GregorianCalendar class are listed below. For a complete list of GregorianCalendar class members, see the GregorianCalendar Members topic.

Public:

CalendarType | [To be supplied.]
Eras | [To be supplied.]
TwoDigitYearMax | Returns the date and time converted to a DateTime value. This value is the upper boundary of a 100-year range that allows a two-digit year to be properly translated to a four-digit year.

See Also

GregorianCalendar Class | System.Globalization Namespace


GregorianCalendar.CalendarType

[To be supplied.]

[Visual Basic]
Overridable Public Property CalendarType As GregorianCalendarTypes
[C#]
public GregorianCalendarTypes CalendarType {virtual get; virtual
   set;}
[C++]
public: __property virtual GregorianCalendarTypes get_CalendarType();
public: __property virtual void set_CalendarType(GregorianCalendarTypes);
[JScript]
public function get CalendarType() : GregorianCalendarTypes;
public function set CalendarType(GregorianCalendarTypes);

See Also

GregorianCalendar Class | GregorianCalendar Members | System.Globalization Namespace


GregorianCalendar.Eras

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Eras As Integer ()
[C#]
public int[] Eras {override get;}
[C++]
public: __property virtual int* get_Eras();
[JScript]
public function get Eras() : int[];

See Also

GregorianCalendar Class | GregorianCalendar Members | System.Globalization Namespace


GregorianCalendar.TwoDigitYearMax

Returns the date and time converted to a DateTime value. This value is the upper boundary of a 100-year range that allows a two-digit year to be properly translated to a four-digit year.

[Visual Basic]
Overridable Public ReadOnly Property TwoDigitYearMax As Integer
[C#]
public int TwoDigitYearMax {override get;}
[C++]
public: __property virtual int get_TwoDigitYearMax();
[JScript]
public function get TwoDigitYearMax() : int;

Property Value

Read-only. Retrieves the maximum value to represent a two-digit year.

Example

If 2029 is the upper boundary, a two-digit value of 30 should be interpreted as 1930 while a two digit value of 29 should be interpreted as 2029. In this example, the 100-year range would be from 1930-2029.

See Also

GregorianCalendar Class | GregorianCalendar Members | System.Globalization Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

GregorianCalendar Methods

The methods of the GregorianCalendar class are listed below. For a complete list of GregorianCalendar class members, see the GregorianCalendar Members topic.

Public:

AddDays (inherited from Calendar) | Returns the DateTime object resulting from adding a fractional number of days to the specified DateTime.
AddHours (inherited from Calendar) | Returns the DateTime resulting from adding a fractional number of hours to the specified DateTime.
AddMilliseconds (inherited from Calendar) | Returns the DateTime resulting from adding the specified number of milliseconds to the specified DateTime.
AddMinutes (inherited from Calendar) | Returns the DateTime resulting from adding a fractional number of minutes to the specified DateTime.
AddMonths | Returns the DateTime resulting from adding the given number of months to the specified DateTime.
AddSeconds (inherited from Calendar) | Returns the DateTime resulting from adding a number of seconds to the specified DateTime.
AddWeeks | Returns the DateTime resulting from adding a number of weeks to the specified DateTime.
AddYears | Returns the DateTime resulting from adding the given number of years to the specified DateTime.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDayOfMonth | Returns the day-of-month part of the given DateTime.
GetDayOfWeek | Returns the day-of-week part of the specified DateTime.
GetDayOfYear | Returns the day-of-year part of the specified DateTime.
GetDaysInMonth | Overloaded. [To be supplied.]
GetDaysInYear | Overloaded. [To be supplied.]
GetEra | Overloaded. [To be supplied.]
GetEraName | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHour (inherited from Calendar) | Returns the hour part of the specified DateTime.
GetMilliseconds (inherited from Calendar) | Returns the millisecond part of the specified DateTime.
GetMinute (inherited from Calendar) | Returns the minute part of the specified DateTime.
GetMonth | Returns the month part of the specified DateTime.
GetMonthsInYear | Overloaded. [To be supplied.]
GetSecond (inherited from Calendar) | Returns the second [RB26] part of the specified DateTime.
GetType (inherited from Object) | Gets the Type of the Object.
GetWeekOfYear | Returns the week of year for the given Datetime.
GetYear | Returns the year part of the specified DateTime.
IsLeapDay | Overloaded. [To be supplied.]
IsLeapMonth | Overloaded. [To be supplied.]
IsLeapYear (inherited from Calendar) | Overloaded. [To be supplied.]
ToDateTime | Overloaded. [To be supplied.]
ToFourDigitYear (inherited from Calendar) | Converts the specified year to the appropriate century by using the TwoDigitYearMax property.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GregorianCalendar Class | System.Globalization Namespace


GregorianCalendar.AddMonths

Returns the DateTime resulting from adding the given number of months to the specified DateTime.

[Visual Basic]
Overrides Public Function AddMonths( _
   ByVal time As DateTime, _
   ByVal months As Integer _
) As DateTime
[C#]
public override DateTime AddMonths(
   DateTime time,
   int months
);
[C++]
public: override DateTime AddMonths(
   DateTime time,
   int months
);
[JScript]
public override function AddMonths(
   time : DateTime,
   months : int
) : DateTime;

Parameters

time
The DateTime instance to be added.
months
A number of months (positive or negative).

Remarks

The result is computed by incrementing (or decrementing) the year and month parts of the specified DateTime by the value of months, and, if required, adjusting the day part of the resulting date downwards to the last day of the resulting month in the resulting year. The time-of-day part of the result is the same as the time-of-day part of the specified DateTime.

In more precise terms, considering the specified DateTime to be of the form y/ m/ d + t, where y is the year, m is the month, d is the day, and t is the time-of-day, the result is y1/ m1/ d1 + t, where y1 and m1 are computed by adding months to y and m, and d1 is the largest value less than or equal to d that denotes a valid day in month m1 of year y1.

See Also

GregorianCalendar Class | GregorianCalendar Members | System.Globalization Namespace


GregorianCalendar.AddWeeks

Returns the DateTime resulting from adding a number of weeks to the specified DateTime.

[Visual Basic]
Overrides Public Function AddWeeks( _
   ByVal time As DateTime, _
   ByVal weeks As Integer _
) As DateTime
[C#]
public override DateTime AddWeeks(
   DateTime time,
   int weeks
);
[C++]
public: override DateTime AddWeeks(
   DateTime time,
   int weeks
);
[JScript]
public override function AddWeeks(
   time : DateTime,
   weeks : int
) : DateTime;

Parameters

time
The DateTime instance to be added.
weeks
A number of weeks.

Exceptions

Exception Type | Condition
ArgumentException | if the resulting DateTime is outside the supported range.

Remarks

The weeks argument is permitted to be negative.

See Also

GregorianCalendar Class | GregorianCalendar Members | System.Globalization Namespace


GregorianCalendar.AddYears

Returns the DateTime resulting from adding the given number of years to the specified DateTime.

[Visual Basic]
Overrides Public Function AddYears( _
   ByVal time As DateTime, _
   ByVal years As Integer _
) As DateTime
[C#]
public override DateTime AddYears(
   DateTime time,
   int years
);
[C++]
public: override DateTime AddYears(
   DateTime time,
   int years
);
[JScript]
public override function AddYears(
   time : DateTime,
   years : int
) : DateTime;

Parameters

time
The DateTime instance to be added.
years
A number of years (positive or negative).

Exceptions

Exception Type | Condition
ArgumentException | if the resulting DateTime is outside the supported range.

Remarks

The result is computed by incrementing (or decrementing) the year part of the specified DateTime by years. If the month and day of the specified DateTime is 2/29, and if the resulting year is not a leap year, the month and day of the resulting DateTime becomes 2/28. Otherwise, the month, day, and time-of-day parts of the result are the same as those of the specified DateTime.

See Also

GregorianCalendar Class | GregorianCalendar Members | System.Globalization Namespace


GregorianCalendar.GetDayOfMonth

Returns the day-of-month part of the given DateTime.

[Visual Basic]
Overrides Public Function GetDayOfMonth( _
   ByVal time As DateTime _
) As Integer
[C#]
public override int GetDayOfMonth(
   DateTime time
);
[C++]
public: override int GetDayOfMonth(
   DateTime time
);
[JScript]
public override function GetDayOfMonth(
   time : DateTime
) : int;

Parameters

time
The DateTime instance.

Return Value

Returns the 1-based day-of-month part of the specified DateTime.

Remarks

The returned value is an integer between 1 and 31.

See Also

GregorianCalendar Class | GregorianCalendar Members | System.Globalization Namespace


GregorianCalendar.GetDayOfWeek

Returns the day-of-week part of the specified DateTime.

[Visual Basic]
Overrides Public Function GetDayOfWeek( _
   ByVal time As DateTime _
) As Integer
[C#]
public override int GetDayOfWeek(
   DateTime time
);
[C++]
public: override int GetDayOfWeek(
   DateTime time
);
[JScript]
public override function GetDayOfWeek(
   time : DateTime
) : int;

Parameters

time
The DateTime instance.

Return Value

Returns the 0-based day-of-week part of the specified DateTime.

Remarks

The returned value is an integer between 0 and 6, where 0 indicates Sunday, 1 indicates Monday, 2 indicates Tuesday, 3 indicates Wednesday, 4 indicates Thursday, 5 indicates Friday, and 6 indicates Saturday.

See Also

GregorianCalendar Class | GregorianCalendar Members | System.Globalization Namespace


GregorianCalendar.GetDayOfYear

Returns the day-of-year part of the specified DateTime.

[Visual Basic]
Overrides Public Function GetDayOfYear( _
   ByVal time As DateTime _
) As Integer
[C#]
public override int GetDayOfYear(
   DateTime time
);
[C++]
public: override int GetDayOfYear(
   DateTime time
);
[JScript]
public override function GetDayOfYear(
   time : DateTime
) : int;

Parameters

time
The DateTime instance.

Return Value

Returns the 1-based day-of-year part of the given DateTime.

Remarks

The returned value is an integer between 1 and 366.

See Also

GregorianCalendar Class | GregorianCalendar Members | System.Globalization Namespace


GregorianCalendar.GetDaysInMonth

Returns the number of days in the month of the specified year, month and era.

[Visual Basic]
Overrides Public Function GetDaysInMonth( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal era As Integer _
) As Integer
[C#]
public override int GetDaysInMonth(
   int year,
   int month,
   int era
);
[C++]
public: override int GetDaysInMonth(
   int year,
   int month,
   int era
);
[JScript]
public override function GetDaysInMonth(
   year : int,
   month : int,
   era : int
) : int;

Parameters

year
The year.
month
The month (1..12).
era
The era of this calendar

Return Value

Returns the number of days in the specified year, month, and era.

Exceptions

Exception Type | Condition
ArgumentException | if month is less than 1 or greater than 12.

Remarks

For the month of February (month = 2), the returned value is 28 or 29 depending on whether year is a leap year.

See Also

GregorianCalendar Class | GregorianCalendar Members | System.Globalization Namespace


GregorianCalendar.GetDaysInYear

Returns the number of days in the year specified by the specified year and era.

[Visual Basic]
Overrides Public Function GetDaysInYear( _
   ByVal year As Integer, _
   ByVal era As Integer _
) As Integer
[C#]
public override int GetDaysInYear(
   int year,
   int era
);
[C++]
public: override int GetDaysInYear(
   int year,
   int era
);
[JScript]
public override function GetDaysInYear(
   year : int,
   era : int
) : int;

Parameters

year
The year.
era
The era of this calendar to consider.

Return Value

Returns the number of days in the specified year.

Exceptions

Exception Type | Condition
ArgumentException | if month is less than 1 or greater than 12.

See Also

GregorianCalendar Class | GregorianCalendar Members | System.Globalization Namespace


GregorianCalendar.GetEra

[To be supplied.]

Overload List

Returns the era for the given DateTime.

[Visual Basic] Overloads Overrides Public Function GetEra(DateTime) As Integer
[C#] public override int GetEra(DateTime);
[C++] public: override int GetEra(DateTime);
[JScript] public override function GetEra(DateTime) : int;

[To be supplied.]

[Visual Basic] Overloads Overrides Public Function GetEra(String) As Integer
[C#] public override int GetEra(String);
[C++] public: override int GetEra(String*);
[JScript] public override function GetEra(String) : int;

See Also

GregorianCalendar Class | GregorianCalendar Members | System.Globalization Namespace


GregorianCalendar.GetEra (DateTime)

Returns the era for the given DateTime.

[Visual Basic]
Overloads Overrides Public Function GetEra( _
   ByVal time As DateTime _
) As Integer
[C#]
public override int GetEra(
   DateTime time
);
[C++]
public: override int GetEra(
   DateTime time
);
[JScript]
public override function GetEra(
   time : DateTime
) : int;

Parameters

time
The DateTime instance.

Return Value

Returns the era for the given DateTime value.

See Also

GregorianCalendar Class | GregorianCalendar Members | System.Globalization Namespace | GregorianCalendar.GetEra Overload List


GregorianCalendar.GetEra (String)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Function GetEra( _
   ByVal eraName As String _
) As Integer
[C#]
public override int GetEra(
   string eraName
);
[C++]
public: override int GetEra(
   String* eraName
);
[JScript]
public override function GetEra(
   eraName : String
) : int;

Parameters

eraName
[To be supplied.]

See Also

GregorianCalendar Class | GregorianCalendar Members | System.Globalization Namespace | GregorianCalendar.GetEra Overload List


GregorianCalendar.GetEraName

[To be supplied.]

[Visual Basic]
Overrides Public Function GetEraName( _
   ByVal era As Integer _
) As String
[C#]
public override string GetEraName(
   int era
);
[C++]
public: override String* GetEraName(
   int era
);
[JScript]
public override function GetEraName(
   era : int
) : String;

Parameters

era
[To be supplied.]

See Also

GregorianCalendar Class | GregorianCalendar Members | System.Globalization Namespace


GregorianCalendar.GetMonth

Returns the month part of the specified DateTime.

[Visual Basic]
Overrides Public Function GetMonth( _
   ByVal time As DateTime _
) As Integer
[C#]
public override int GetMonth(
   DateTime time
);
[C++]
public: override int GetMonth(
   DateTime time
);
[JScript]
public override function GetMonth(
   time : DateTime
) : int;

Parameters

time
The DateTime instance.

Return Value

Returns the 1-based month part of the specified DateTime.

Remarks

The returned value is an integer between 1 and 12.

See Also

GregorianCalendar Class | GregorianCalendar Members | System.Globalization Namespace


GregorianCalendar.GetMonthsInYear

Returns the number of months in the given year

and era.

[Visual Basic]
Overrides Public Function GetMonthsInYear( _
   ByVal year As Integer, _
   ByVal era As Integer _
) As Integer
[C#]
public override int GetMonthsInYear(
   int year,
   int era
);
[C++]
public: override int GetMonthsInYear(
   int year,
   int era
);
[JScript]
public override function GetMonthsInYear(
   year : int,
   era : int
) : int;

Parameters

year
The year.
era
The era.

Return Value

Returns the number of months in year and era.

See Also

GregorianCalendar Class | GregorianCalendar Members | System.Globalization Namespace


GregorianCalendar.GetWeekOfYear

Returns the week of year for the given Datetime.

[Visual Basic]
Overrides Public Function GetWeekOfYear( _
   ByVal time As DateTime _
) As Integer
[C#]
public override int GetWeekOfYear(
   DateTime time
);
[C++]
public: override int GetWeekOfYear(
   DateTime time
);
[JScript]
public override function GetWeekOfYear(
   time : DateTime
) : int;

Parameters

time
The DateTime instance.

Return Value

Returns the week of year for the specified DateTime.

Remarks

The returned value is an integer between 1 and 52.

See Also

GregorianCalendar Class | GregorianCalendar Members | System.Globalization Namespace


GregorianCalendar.GetYear

Returns the year part of the specified DateTime.

[Visual Basic]
Overrides Public Function GetYear( _
   ByVal time As DateTime _
) As Integer
[C#]
public override int GetYear(
   DateTime time
);
[C++]
public: override int GetYear(
   DateTime time
);
[JScript]
public override function GetYear(
   time : DateTime
) : int;

Parameters

time
The DateTime instance.

Return Value

Returns the year part of the specified DateTime.

Remarks

The returned value is an integer between 1 and 9999.

See Also

GregorianCalendar Class | GregorianCalendar Members | System.Globalization Namespace


GregorianCalendar.IsLeapDay

Checks whether a specified day in the specified era is a leap day.

[Visual Basic]
Overrides Public Function IsLeapDay( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal era As Integer _
) As Boolean
[C#]
public override bool IsLeapDay(
   int year,
   int month,
   int day,
   int era
);
[C++]
public: override bool IsLeapDay(
   int year,
   int month,
   int day,
   int era
);
[JScript]
public override function IsLeapDay(
   year : int,
   month : int,
   day : int,
   era : int
) : Boolean;

Parameters

year
The year to check.
month
The month to check.
day
The day to check.
era
The era to check.

Return Value

Returns true if and only if the specified day is a leap day; otherwise false.

See Also

GregorianCalendar Class | GregorianCalendar Members | System.Globalization Namespace


GregorianCalendar.IsLeapMonth

Checks whether a specified month in the specified era is a leap month.

[Visual Basic]
Overrides Public Function IsLeapMonth( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal era As Integer _
) As Boolean
[C#]
public override bool IsLeapMonth(
   int year,
   int month,
   int era
);
[C++]
public: override bool IsLeapMonth(
   int year,
   int month,
   int era
);
[JScript]
public override function IsLeapMonth(
   year : int,
   month : int,
   era : int
) : Boolean;

Parameters

year
The year to check.
month
The month to check.
era
The era to check.

Return Value

Returns true if and only if the specified month is a leap month; otherwise false.

See Also

GregorianCalendar Class | GregorianCalendar Members | System.Globalization Namespace


GregorianCalendar.IsLeapYear

Checks whether a given year in the specified era is a leap year.

[Visual Basic]
Overrides Public Function IsLeapYear( _
   ByVal year As Integer, _
   ByVal era As Integer _
) As Boolean
[C#]
public override bool IsLeapYear(
   int year,
   int era
);
[C++]
public: override bool IsLeapYear(
   int year,
   int era
);
[JScript]
public override function IsLeapYear(
   year : int,
   era : int
) : Boolean;

Parameters

year
The year to check.
era
The era to check.

Return Value

Returns true if year is a leap year; otherwise false.

See Also

GregorianCalendar Class | GregorianCalendar Members | System.Globalization Namespace


GregorianCalendar.ToDateTime

Returns the date and time converted to a DateTime value.

[Visual Basic]
Overrides Public Function ToDateTime( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal hour As Integer, _
   ByVal minute As Integer, _
   ByVal second As Integer, _
   ByVal millisecond As Integer, _
   ByVal era As Integer _
) As DateTime
[C#]
public override DateTime ToDateTime(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   int millisecond,
   int era
);
[C++]
public: override DateTime ToDateTime(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   int millisecond,
   int era
);
[JScript]
public override function ToDateTime(
   year : int,
   month : int,
   day : int,
   hour : int,
   minute : int,
   second : int,
   millisecond : int,
   era : int
) : DateTime;

Parameters

year
The year.
month
The month.
day
The day.
hour
The hour.
minute
The minute.
second
The second.
millisecond
The milliseconds.
era
The era.

Return Value

Returns the constructed DateTime instance for the specified time.

Exceptions

Exception Type | Condition
ArgumentException | if provided with an invalid era value

See Also

GregorianCalendar Class | GregorianCalendar Members | System.Globalization Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

GregorianCalendar Fields

The fields of the GregorianCalendar class are listed below. For a complete list of GregorianCalendar class members, see the GregorianCalendar Members topic.

Public:

ADEra [To be supplied.]

See Also

GregorianCalendar Class | System.Globalization Namespace


GregorianCalendar.ADEra

[To be supplied.]

[Visual Basic]
Public Const ADEra As Integer
[C#]
public const int ADEra;
[C++]
public: const int ADEra;
[JScript]
public var ADEra : int;

See Also

GregorianCalendar Class | GregorianCalendar Members | System.Globalization Namespace


GregorianCalendarTypes Enumeration

[To be supplied.]

[Visual Basic]
Public Enum GregorianCalendarTypes
[C#]
public enum GregorianCalendarTypes
[C++]
public enum GregorianCalendarTypes

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Arabic | [To be supplied.]
Localized | [To be supplied.]
MiddleEastFrench | [To be supplied.]
TransliteratedEnglish | [To be supplied.]
TransliteratedFrench | [To be supplied.]
USEnglish | [To be supplied.]

Requirements

Namespace: System.Globalization

Assembly: mscorlib.dll

See Also

System.Globalization Namespace


HebrewCalendar Class

[To be supplied.]

Object
Calendar
HebrewCalendar

[Visual Basic]
Public Class HebrewCalendar
   Inherits Calendar
[C#]
public class HebrewCalendar : Calendar
[C++]
public __gc class HebrewCalendar : public Calendar
[JScript]
public class HebrewCalendar extends Calendar

Remarks

[To be supplied.]

Requirements

Namespace: System.Globalization

Assembly: mscorlib.dll

See Also

HebrewCalendar Members | System.Globalization Namespace


HebrewCalendar Members

Public:

Constructor

HebrewCalendar Constructor [To be supplied.]

Properties

Eras | [To be supplied.]
TwoDigitYearMax | [To be supplied.]

Methods

AddDays (inherited from Calendar) | Returns the DateTime object resulting from adding a fractional number of days to the specified DateTime.
AddHours (inherited from Calendar) | Returns the DateTime resulting from adding a fractional number of hours to the specified DateTime.
AddMilliseconds (inherited from Calendar) | Returns the DateTime resulting from adding the specified number of milliseconds to the specified DateTime.
AddMinutes (inherited from Calendar) | Returns the DateTime resulting from adding a fractional number of minutes to the specified DateTime.
AddMonths | [To be supplied.]
AddSeconds (inherited from Calendar) | Returns the DateTime resulting from adding a number of seconds to the specified DateTime.
AddWeeks (inherited from Calendar) | Returns the DateTime resulting from adding a number of weeks to the specified DateTime.
AddYears | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDayOfMonth | [To be supplied.]
GetDayOfWeek | [To be supplied.]
GetDayOfYear | [To be supplied.]
GetDaysInMonth | Overloaded. [To be supplied.]
GetDaysInYear (inherited from Calendar) | Overloaded. [To be supplied.]
GetEra | Overloaded. [To be supplied.]
GetEraName | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHour (inherited from Calendar) | Returns the hour part of the specified DateTime.
GetMilliseconds (inherited from Calendar) | Returns the millisecond part of the specified DateTime.
GetMinute (inherited from Calendar) | Returns the minute part of the specified DateTime.
GetMonth | [To be supplied.]
GetMonthsInYear | Overloaded. [To be supplied.]
GetSecond (inherited from Calendar) | Returns the second [RB26] part of the specified DateTime.
GetType (inherited from Object) | Gets the Type of the Object.
GetWeekOfYear | [To be supplied.]
GetYear | [To be supplied.]
IsLeapDay (inherited from Calendar) | Overloaded. [To be supplied.]
IsLeapMonth | Overloaded. [To be supplied.]
IsLeapYear | Overloaded. [To be supplied.]
ToDateTime | Overloaded. [To be supplied.]
ToFourDigitYear (inherited from Calendar) | Converts the specified year to the appropriate century by using the TwoDigitYearMax property.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

HebrewEra [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HebrewCalendar Class | System.Globalization Namespace


HebrewCalendar Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public HebrewCalendar();
[C++]
public: HebrewCalendar();
[JScript]
public function HebrewCalendar();

See Also

HebrewCalendar Class | HebrewCalendar Members | System.Globalization Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

HebrewCalendar Properties

The properties of the HebrewCalendar class are listed below. For a complete list of HebrewCalendar class members, see the HebrewCalendar Members topic.

Public:

Eras | [To be supplied.]
TwoDigitYearMax | [To be supplied.]

See Also

HebrewCalendar Class | System.Globalization Namespace


HebrewCalendar.Eras

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Eras As Integer ()
[C#]
public int[] Eras {override get;}
[C++]
public: __property virtual int* get_Eras();
[JScript]
public function get Eras() : int[];

See Also

HebrewCalendar Class | HebrewCalendar Members | System.Globalization Namespace


HebrewCalendar.TwoDigitYearMax

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property TwoDigitYearMax As Integer
[C#]
public int TwoDigitYearMax {override get;}
[C++]
public: __property virtual int get_TwoDigitYearMax();
[JScript]
public function get TwoDigitYearMax() : int;

See Also

HebrewCalendar Class | HebrewCalendar Members | System.Globalization Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

HebrewCalendar Methods

The methods of the HebrewCalendar class are listed below. For a complete list of HebrewCalendar class members, see the HebrewCalendar Members topic.

Public:

AddDays (inherited from Calendar) | Returns the DateTime object resulting from adding a fractional number of days to the specified DateTime.
AddHours (inherited from Calendar) | Returns the DateTime resulting from adding a fractional number of hours to the specified DateTime.
AddMilliseconds (inherited from Calendar) | Returns the DateTime resulting from adding the specified number of milliseconds to the specified DateTime.
AddMinutes (inherited from Calendar) | Returns the DateTime resulting from adding a fractional number of minutes to the specified DateTime.
AddMonths | [To be supplied.]
AddSeconds (inherited from Calendar) | Returns the DateTime resulting from adding a number of seconds to the specified DateTime.
AddWeeks (inherited from Calendar) | Returns the DateTime resulting from adding a number of weeks to the specified DateTime.
AddYears | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDayOfMonth | [To be supplied.]
GetDayOfWeek | [To be supplied.]
GetDayOfYear | [To be supplied.]
GetDaysInMonth | Overloaded. [To be supplied.]
GetDaysInYear (inherited from Calendar) | Overloaded. [To be supplied.]
GetEra | Overloaded. [To be supplied.]
GetEraName | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHour (inherited from Calendar) | Returns the hour part of the specified DateTime.
GetMilliseconds (inherited from Calendar) | Returns the millisecond part of the specified DateTime.
GetMinute (inherited from Calendar) | Returns the minute part of the specified DateTime.
GetMonth | [To be supplied.]
GetMonthsInYear | Overloaded. [To be supplied.]
GetSecond (inherited from Calendar) | Returns the second [RB26] part of the specified DateTime.
GetType (inherited from Object) | Gets the Type of the Object.
GetWeekOfYear | [To be supplied.]
GetYear | [To be supplied.]
IsLeapDay (inherited from Calendar) | Overloaded. [To be supplied.]
IsLeapMonth | Overloaded. [To be supplied.]
IsLeapYear | Overloaded. [To be supplied.]
ToDateTime | Overloaded. [To be supplied.]
ToFourDigitYear (inherited from Calendar) | Converts the specified year to the appropriate century by using the TwoDigitYearMax property.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HebrewCalendar Class | System.Globalization Namespace


HebrewCalendar.AddMonths

[To be supplied.]

[Visual Basic]
Overrides Public Function AddMonths( _
   ByVal time As DateTime, _
   ByVal months As Integer _
) As DateTime
[C#]
public override DateTime AddMonths(
   DateTime time,
   int months
);
[C++]
public: override DateTime AddMonths(
   DateTime time,
   int months
);
[JScript]
public override function AddMonths(
   time : DateTime,
   months : int
) : DateTime;

Parameters

time
[To be supplied.]
months
[To be supplied.]

See Also

HebrewCalendar Class | HebrewCalendar Members | System.Globalization Namespace


HebrewCalendar.AddYears

[To be supplied.]

[Visual Basic]
Overrides Public Function AddYears( _
   ByVal time As DateTime, _
   ByVal years As Integer _
) As DateTime
[C#]
public override DateTime AddYears(
   DateTime time,
   int years
);
[C++]
public: override DateTime AddYears(
   DateTime time,
   int years
);
[JScript]
public override function AddYears(
   time : DateTime,
   years : int
) : DateTime;

Parameters

time
[To be supplied.]
years
[To be supplied.]

See Also

HebrewCalendar Class | HebrewCalendar Members | System.Globalization Namespace


HebrewCalendar.GetDayOfMonth

[To be supplied.]

[Visual Basic]
Overrides Public Function GetDayOfMonth( _
   ByVal time As DateTime _
) As Integer
[C#]
public override int GetDayOfMonth(
   DateTime time
);
[C++]
public: override int GetDayOfMonth(
   DateTime time
);
[JScript]
public override function GetDayOfMonth(
   time : DateTime
) : int;

Parameters

time
[To be supplied.]

See Also

HebrewCalendar Class | HebrewCalendar Members | System.Globalization Namespace


HebrewCalendar.GetDayOfWeek

[To be supplied.]

[Visual Basic]
Overrides Public Function GetDayOfWeek( _
   ByVal time As DateTime _
) As Integer
[C#]
public override int GetDayOfWeek(
   DateTime time
);
[C++]
public: override int GetDayOfWeek(
   DateTime time
);
[JScript]
public override function GetDayOfWeek(
   time : DateTime
) : int;

Parameters

time
[To be supplied.]

See Also

HebrewCalendar Class | HebrewCalendar Members | System.Globalization Namespace


HebrewCalendar.GetDayOfYear

[To be supplied.]

[Visual Basic]
Overrides Public Function GetDayOfYear( _
   ByVal time As DateTime _
) As Integer
[C#]
public override int GetDayOfYear(
   DateTime time
);
[C++]
public: override int GetDayOfYear(
   DateTime time
);
[JScript]
public override function GetDayOfYear(
   time : DateTime
) : int;

Parameters

time
[To be supplied.]

See Also

HebrewCalendar Class | HebrewCalendar Members | System.Globalization Namespace


HebrewCalendar.GetDaysInMonth

[To be supplied.]

[Visual Basic]
Overrides Public Function GetDaysInMonth( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal era As Integer _
) As Integer
[C#]
public override int GetDaysInMonth(
   int year,
   int month,
   int era
);
[C++]
public: override int GetDaysInMonth(
   int year,
   int month,
   int era
);
[JScript]
public override function GetDaysInMonth(
   year : int,
   month : int,
   era : int
) : int;

Parameters

year
[To be supplied.]
month
[To be supplied.]
era
[To be supplied.]

See Also

HebrewCalendar Class | HebrewCalendar Members | System.Globalization Namespace


HebrewCalendar.GetDaysInYear

[To be supplied.]

[Visual Basic]
Overrides Public Function GetDaysInYear( _
   ByVal year As Integer, _
   ByVal era As Integer _
) As Integer
[C#]
public override int GetDaysInYear(
   int year,
   int era
);
[C++]
public: override int GetDaysInYear(
   int year,
   int era
);
[JScript]
public override function GetDaysInYear(
   year : int,
   era : int
) : int;

Parameters

year
[To be supplied.]
era
[To be supplied.]

See Also

HebrewCalendar Class | HebrewCalendar Members | System.Globalization Namespace


HebrewCalendar.GetEra

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overrides Public Function GetEra(String) As Integer
[C#] public override int GetEra(String);
[C++] public: override int GetEra(String*);
[JScript] public override function GetEra(String) : int;

[To be supplied.]

[Visual Basic] Overloads Overrides Public Function GetEra(DateTime) As Integer
[C#] public override int GetEra(DateTime);
[C++] public: override int GetEra(DateTime);
[JScript] public override function GetEra(DateTime) : int;

See Also

HebrewCalendar Class | HebrewCalendar Members | System.Globalization Namespace


HebrewCalendar.GetEra (String)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Function GetEra( _
   ByVal eraName As String _
) As Integer
[C#]
public override int GetEra(
   string eraName
);
[C++]
public: override int GetEra(
   String* eraName
);
[JScript]
public override function GetEra(
   eraName : String
) : int;

Parameters

eraName
[To be supplied.]

See Also

HebrewCalendar Class | HebrewCalendar Members | System.Globalization Namespace | HebrewCalendar.GetEra Overload List


HebrewCalendar.GetEra (DateTime)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Function GetEra( _
   ByVal time As DateTime _
) As Integer
[C#]
public override int GetEra(
   DateTime time
);
[C++]
public: override int GetEra(
   DateTime time
);
[JScript]
public override function GetEra(
   time : DateTime
) : int;

Parameters

time
[To be supplied.]

See Also

HebrewCalendar Class | HebrewCalendar Members | System.Globalization Namespace | HebrewCalendar.GetEra Overload List


HebrewCalendar.GetEraName

[To be supplied.]

[Visual Basic]
Overrides Public Function GetEraName( _
   ByVal era As Integer _
) As String
[C#]
public override string GetEraName(
   int era
);
[C++]
public: override String* GetEraName(
   int era
);
[JScript]
public override function GetEraName(
   era : int
) : String;

Parameters

era
[To be supplied.]

See Also

HebrewCalendar Class | HebrewCalendar Members | System.Globalization Namespace


HebrewCalendar.GetMonth

[To be supplied.]

[Visual Basic]
Overrides Public Function GetMonth( _
   ByVal time As DateTime _
) As Integer
[C#]
public override int GetMonth(
   DateTime time
);
[C++]
public: override int GetMonth(
   DateTime time
);
[JScript]
public override function GetMonth(
   time : DateTime
) : int;

Parameters

time
[To be supplied.]

See Also

HebrewCalendar Class | HebrewCalendar Members | System.Globalization Namespace


HebrewCalendar.GetMonthsInYear

[To be supplied.]

[Visual Basic]
Overrides Public Function GetMonthsInYear( _
   ByVal year As Integer, _
   ByVal era As Integer _
) As Integer
[C#]
public override int GetMonthsInYear(
   int year,
   int era
);
[C++]
public: override int GetMonthsInYear(
   int year,
   int era
);
[JScript]
public override function GetMonthsInYear(
   year : int,
   era : int
) : int;

Parameters

year
[To be supplied.]
era
[To be supplied.]

See Also

HebrewCalendar Class | HebrewCalendar Members | System.Globalization Namespace


HebrewCalendar.GetWeekOfYear

[To be supplied.]

[Visual Basic]
Overrides Public Function GetWeekOfYear( _
   ByVal time As DateTime _
) As Integer
[C#]
public override int GetWeekOfYear(
   DateTime time
);
[C++]
public: override int GetWeekOfYear(
   DateTime time
);
[JScript]
public override function GetWeekOfYear(
   time : DateTime
) : int;

Parameters

time
[To be supplied.]

See Also

HebrewCalendar Class | HebrewCalendar Members | System.Globalization Namespace


HebrewCalendar.GetYear

[To be supplied.]

[Visual Basic]
Overrides Public Function GetYear( _
   ByVal time As DateTime _
) As Integer
[C#]
public override int GetYear(
   DateTime time
);
[C++]
public: override int GetYear(
   DateTime time
);
[JScript]
public override function GetYear(
   time : DateTime
) : int;

Parameters

time
[To be supplied.]

See Also

HebrewCalendar Class | HebrewCalendar Members | System.Globalization Namespace


HebrewCalendar.IsLeapDay

[To be supplied.]

[Visual Basic]
Overrides Public Function IsLeapDay( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal era As Integer _
) As Boolean
[C#]
public override bool IsLeapDay(
   int year,
   int month,
   int day,
   int era
);
[C++]
public: override bool IsLeapDay(
   int year,
   int month,
   int day,
   int era
);
[JScript]
public override function IsLeapDay(
   year : int,
   month : int,
   day : int,
   era : int
) : Boolean;

Parameters

year
[To be supplied.]
month
[To be supplied.]
day
[To be supplied.]
era
[To be supplied.]

See Also

HebrewCalendar Class | HebrewCalendar Members | System.Globalization Namespace


HebrewCalendar.IsLeapMonth

[To be supplied.]

[Visual Basic]
Overrides Public Function IsLeapMonth( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal era As Integer _
) As Boolean
[C#]
public override bool IsLeapMonth(
   int year,
   int month,
   int era
);
[C++]
public: override bool IsLeapMonth(
   int year,
   int month,
   int era
);
[JScript]
public override function IsLeapMonth(
   year : int,
   month : int,
   era : int
) : Boolean;

Parameters

year
[To be supplied.]
month
[To be supplied.]
era
[To be supplied.]

See Also

HebrewCalendar Class | HebrewCalendar Members | System.Globalization Namespace


HebrewCalendar.IsLeapYear

[To be supplied.]

[Visual Basic]
Overrides Public Function IsLeapYear( _
   ByVal year As Integer, _
   ByVal era As Integer _
) As Boolean
[C#]
public override bool IsLeapYear(
   int year,
   int era
);
[C++]
public: override bool IsLeapYear(
   int year,
   int era
);
[JScript]
public override function IsLeapYear(
   year : int,
   era : int
) : Boolean;

Parameters

year
[To be supplied.]
era
[To be supplied.]

See Also

HebrewCalendar Class | HebrewCalendar Members | System.Globalization Namespace


HebrewCalendar.ToDateTime

[To be supplied.]

[Visual Basic]
Overrides Public Function ToDateTime( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal hour As Integer, _
   ByVal minute As Integer, _
   ByVal second As Integer, _
   ByVal millisecond As Integer, _
   ByVal era As Integer _
) As DateTime
[C#]
public override DateTime ToDateTime(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   int millisecond,
   int era
);
[C++]
public: override DateTime ToDateTime(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   int millisecond,
   int era
);
[JScript]
public override function ToDateTime(
   year : int,
   month : int,
   day : int,
   hour : int,
   minute : int,
   second : int,
   millisecond : int,
   era : int
) : DateTime;

Parameters

year
[To be supplied.]
month
[To be supplied.]
day
[To be supplied.]
hour
[To be supplied.]
minute
[To be supplied.]
second
[To be supplied.]
millisecond
[To be supplied.]
era
[To be supplied.]

See Also

HebrewCalendar Class | HebrewCalendar Members | System.Globalization Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

HebrewCalendar Fields

The fields of the HebrewCalendar class are listed below. For a complete list of HebrewCalendar class members, see the HebrewCalendar Members topic.

Public:

HebrewEra [To be supplied.]

See Also

HebrewCalendar Class | System.Globalization Namespace


HebrewCalendar.HebrewEra

[To be supplied.]

[Visual Basic]
Public Const HebrewEra As Integer
[C#]
public const int HebrewEra;
[C++]
public: const int HebrewEra;
[JScript]
public var HebrewEra : int;

See Also

HebrewCalendar Class | HebrewCalendar Members | System.Globalization Namespace


HijriCalendar Class

[To be supplied.]

Object
Calendar
HijriCalendar

[Visual Basic]
Public Class HijriCalendar
   Inherits Calendar
[C#]
public class HijriCalendar : Calendar
[C++]
public __gc class HijriCalendar : public Calendar
[JScript]
public class HijriCalendar extends Calendar

Remarks

[To be supplied.]

Requirements

Namespace: System.Globalization

Assembly: mscorlib.dll

See Also

HijriCalendar Members | System.Globalization Namespace


HijriCalendar Members

Public:

Constructor

HijriCalendar Constructor [To be supplied.]

Properties

Eras | [To be supplied.]
TwoDigitYearMax | [To be supplied.]

Methods

AddDays (inherited from Calendar) | Returns the DateTime object resulting from adding a fractional number of days to the specified DateTime.
AddHours (inherited from Calendar) | Returns the DateTime resulting from adding a fractional number of hours to the specified DateTime.
AddMilliseconds (inherited from Calendar) | Returns the DateTime resulting from adding the specified number of milliseconds to the specified DateTime.
AddMinutes (inherited from Calendar) | Returns the DateTime resulting from adding a fractional number of minutes to the specified DateTime.
AddMonths | [To be supplied.]
AddSeconds (inherited from Calendar) | Returns the DateTime resulting from adding a number of seconds to the specified DateTime.
AddWeeks (inherited from Calendar) | Returns the DateTime resulting from adding a number of weeks to the specified DateTime.
AddYears | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDayOfMonth | [To be supplied.]
GetDayOfWeek | [To be supplied.]
GetDayOfYear | [To be supplied.]
GetDaysInMonth | Overloaded. [To be supplied.]
GetDaysInYear | Overloaded. [To be supplied.]
GetEra | Overloaded. [To be supplied.]
GetEraName | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHour (inherited from Calendar) | Returns the hour part of the specified DateTime.
GetMilliseconds (inherited from Calendar) | Returns the millisecond part of the specified DateTime.
GetMinute (inherited from Calendar) | Returns the minute part of the specified DateTime.
GetMonth | [To be supplied.]
GetMonthsInYear (inherited from Calendar) | Overloaded. [To be supplied.]
GetSecond (inherited from Calendar) | Returns the second [RB26] part of the specified DateTime.
GetType (inherited from Object) | Gets the Type of the Object.
GetWeekOfYear | [To be supplied.]
GetYear | [To be supplied.]
IsLeapDay (inherited from Calendar) | Overloaded. [To be supplied.]
IsLeapMonth (inherited from Calendar) | Overloaded. [To be supplied.]
IsLeapYear (inherited from Calendar) | Overloaded. [To be supplied.]
ToDateTime (inherited from Calendar) | Overloaded. Returns [RB39] the date and time converted to a DateTime value.
ToFourDigitYear (inherited from Calendar) | Converts the specified year to the appropriate century by using the TwoDigitYearMax property.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

HijriEra [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HijriCalendar Class | System.Globalization Namespace


HijriCalendar Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public HijriCalendar();
[C++]
public: HijriCalendar();
[JScript]
public function HijriCalendar();

See Also

HijriCalendar Class | HijriCalendar Members | System.Globalization Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

HijriCalendar Properties

The properties of the HijriCalendar class are listed below. For a complete list of HijriCalendar class members, see the HijriCalendar Members topic.

Public:

Eras | [To be supplied.]
TwoDigitYearMax | [To be supplied.]

See Also

HijriCalendar Class | System.Globalization Namespace


HijriCalendar.Eras

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Eras As Integer ()
[C#]
public int[] Eras {override get;}
[C++]
public: __property virtual int* get_Eras();
[JScript]
public function get Eras() : int[];

See Also

HijriCalendar Class | HijriCalendar Members | System.Globalization Namespace


HijriCalendar.TwoDigitYearMax

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property TwoDigitYearMax As Integer
[C#]
public int TwoDigitYearMax {override get;}
[C++]
public: __property virtual int get_TwoDigitYearMax();
[JScript]
public function get TwoDigitYearMax() : int;

See Also

HijriCalendar Class | HijriCalendar Members | System.Globalization Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

HijriCalendar Methods

The methods of the HijriCalendar class are listed below. For a complete list of HijriCalendar class members, see the HijriCalendar Members topic.

Public:

AddDays (inherited from Calendar) | Returns the DateTime object resulting from adding a fractional number of days to the specified DateTime.
AddHours (inherited from Calendar) | Returns the DateTime resulting from adding a fractional number of hours to the specified DateTime.
AddMilliseconds (inherited from Calendar) | Returns the DateTime resulting from adding the specified number of milliseconds to the specified DateTime.
AddMinutes (inherited from Calendar) | Returns the DateTime resulting from adding a fractional number of minutes to the specified DateTime.
AddMonths | [To be supplied.]
AddSeconds (inherited from Calendar) | Returns the DateTime resulting from adding a number of seconds to the specified DateTime.
AddWeeks (inherited from Calendar) | Returns the DateTime resulting from adding a number of weeks to the specified DateTime.
AddYears | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDayOfMonth | [To be supplied.]
GetDayOfWeek | [To be supplied.]
GetDayOfYear | [To be supplied.]
GetDaysInMonth | Overloaded. [To be supplied.]
GetDaysInYear | Overloaded. [To be supplied.]
GetEra | Overloaded. [To be supplied.]
GetEraName | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHour (inherited from Calendar) | Returns the hour part of the specified DateTime.
GetMilliseconds (inherited from Calendar) | Returns the millisecond part of the specified DateTime.
GetMinute (inherited from Calendar) | Returns the minute part of the specified DateTime.
GetMonth | [To be supplied.]
GetMonthsInYear (inherited from Calendar) | Overloaded. [To be supplied.]
GetSecond (inherited from Calendar) | Returns the second [RB26] part of the specified DateTime.
GetType (inherited from Object) | Gets the Type of the Object.
GetWeekOfYear | [To be supplied.]
GetYear | [To be supplied.]
IsLeapDay (inherited from Calendar) | Overloaded. [To be supplied.]
IsLeapMonth (inherited from Calendar) | Overloaded. [To be supplied.]
IsLeapYear (inherited from Calendar) | Overloaded. [To be supplied.]
ToDateTime (inherited from Calendar) | Overloaded. Returns [RB39] the date and time converted to a DateTime value.
ToFourDigitYear (inherited from Calendar) | Converts the specified year to the appropriate century by using the TwoDigitYearMax property.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HijriCalendar Class | System.Globalization Namespace


HijriCalendar.AddMonths

[To be supplied.]

[Visual Basic]
Overrides Public Function AddMonths( _
   ByVal time As DateTime, _
   ByVal months As Integer _
) As DateTime
[C#]
public override DateTime AddMonths(
   DateTime time,
   int months
);
[C++]
public: override DateTime AddMonths(
   DateTime time,
   int months
);
[JScript]
public override function AddMonths(
   time : DateTime,
   months : int
) : DateTime;

Parameters

time
[To be supplied.]
months
[To be supplied.]

See Also

HijriCalendar Class | HijriCalendar Members | System.Globalization Namespace


HijriCalendar.AddYears

[To be supplied.]

[Visual Basic]
Overrides Public Function AddYears( _
   ByVal time As DateTime, _
   ByVal years As Integer _
) As DateTime
[C#]
public override DateTime AddYears(
   DateTime time,
   int years
);
[C++]
public: override DateTime AddYears(
   DateTime time,
   int years
);
[JScript]
public override function AddYears(
   time : DateTime,
   years : int
) : DateTime;

Parameters

time
[To be supplied.]
years
[To be supplied.]

See Also

HijriCalendar Class | HijriCalendar Members | System.Globalization Namespace


HijriCalendar.GetDayOfMonth

[To be supplied.]

[Visual Basic]
Overrides Public Function GetDayOfMonth( _
   ByVal time As DateTime _
) As Integer
[C#]
public override int GetDayOfMonth(
   DateTime time
);
[C++]
public: override int GetDayOfMonth(
   DateTime time
);
[JScript]
public override function GetDayOfMonth(
   time : DateTime
) : int;

Parameters

time
[To be supplied.]

See Also

HijriCalendar Class | HijriCalendar Members | System.Globalization Namespace


HijriCalendar.GetDayOfWeek

[To be supplied.]

[Visual Basic]
Overrides Public Function GetDayOfWeek( _
   ByVal time As DateTime _
) As Integer
[C#]
public override int GetDayOfWeek(
   DateTime time
);
[C++]
public: override int GetDayOfWeek(
   DateTime time
);
[JScript]
public override function GetDayOfWeek(
   time : DateTime
) : int;

Parameters

time
[To be supplied.]

See Also

HijriCalendar Class | HijriCalendar Members | System.Globalization Namespace


HijriCalendar.GetDayOfYear

[To be supplied.]

[Visual Basic]
Overrides Public Function GetDayOfYear( _
   ByVal time As DateTime _
) As Integer
[C#]
public override int GetDayOfYear(
   DateTime time
);
[C++]
public: override int GetDayOfYear(
   DateTime time
);
[JScript]
public override function GetDayOfYear(
   time : DateTime
) : int;

Parameters

time
[To be supplied.]

See Also

HijriCalendar Class | HijriCalendar Members | System.Globalization Namespace


HijriCalendar.GetDaysInMonth

[To be supplied.]

[Visual Basic]
Overrides Public Function GetDaysInMonth( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal era As Integer _
) As Integer
[C#]
public override int GetDaysInMonth(
   int year,
   int month,
   int era
);
[C++]
public: override int GetDaysInMonth(
   int year,
   int month,
   int era
);
[JScript]
public override function GetDaysInMonth(
   year : int,
   month : int,
   era : int
) : int;

Parameters

year
[To be supplied.]
month
[To be supplied.]
era
[To be supplied.]

See Also

HijriCalendar Class | HijriCalendar Members | System.Globalization Namespace


HijriCalendar.GetDaysInYear

[To be supplied.]

[Visual Basic]
Overrides Public Function GetDaysInYear( _
   ByVal year As Integer, _
   ByVal era As Integer _
) As Integer
[C#]
public override int GetDaysInYear(
   int year,
   int era
);
[C++]
public: override int GetDaysInYear(
   int year,
   int era
);
[JScript]
public override function GetDaysInYear(
   year : int,
   era : int
) : int;

Parameters

year
[To be supplied.]
era
[To be supplied.]

See Also

HijriCalendar Class | HijriCalendar Members | System.Globalization Namespace


HijriCalendar.GetEra

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overrides Public Function GetEra(String) As Integer
[C#] public override int GetEra(String);
[C++] public: override int GetEra(String*);
[JScript] public override function GetEra(String) : int;

[To be supplied.]

[Visual Basic] Overloads Overrides Public Function GetEra(DateTime) As Integer
[C#] public override int GetEra(DateTime);
[C++] public: override int GetEra(DateTime);
[JScript] public override function GetEra(DateTime) : int;

See Also

HijriCalendar Class | HijriCalendar Members | System.Globalization Namespace


HijriCalendar.GetEra (String)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Function GetEra( _
   ByVal eraName As String _
) As Integer
[C#]
public override int GetEra(
   string eraName
);
[C++]
public: override int GetEra(
   String* eraName
);
[JScript]
public override function GetEra(
   eraName : String
) : int;

Parameters

eraName
[To be supplied.]

See Also

HijriCalendar Class | HijriCalendar Members | System.Globalization Namespace | HijriCalendar.GetEra Overload List


HijriCalendar.GetEra (DateTime)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Function GetEra( _
   ByVal time As DateTime _
) As Integer
[C#]
public override int GetEra(
   DateTime time
);
[C++]
public: override int GetEra(
   DateTime time
);
[JScript]
public override function GetEra(
   time : DateTime
) : int;

Parameters

time
[To be supplied.]

See Also

HijriCalendar Class | HijriCalendar Members | System.Globalization Namespace | HijriCalendar.GetEra Overload List


HijriCalendar.GetEraName

[To be supplied.]

[Visual Basic]
Overrides Public Function GetEraName( _
   ByVal era As Integer _
) As String
[C#]
public override string GetEraName(
   int era
);
[C++]
public: override String* GetEraName(
   int era
);
[JScript]
public override function GetEraName(
   era : int
) : String;

Parameters

era
[To be supplied.]

See Also

HijriCalendar Class | HijriCalendar Members | System.Globalization Namespace


HijriCalendar.GetMonth

[To be supplied.]

[Visual Basic]
Overrides Public Function GetMonth( _
   ByVal time As DateTime _
) As Integer
[C#]
public override int GetMonth(
   DateTime time
);
[C++]
public: override int GetMonth(
   DateTime time
);
[JScript]
public override function GetMonth(
   time : DateTime
) : int;

Parameters

time
[To be supplied.]

See Also

HijriCalendar Class | HijriCalendar Members | System.Globalization Namespace


HijriCalendar.GetMonthsInYear

[To be supplied.]

[Visual Basic]
Overrides Public Function GetMonthsInYear( _
   ByVal year As Integer, _
   ByVal era As Integer _
) As Integer
[C#]
public override int GetMonthsInYear(
   int year,
   int era
);
[C++]
public: override int GetMonthsInYear(
   int year,
   int era
);
[JScript]
public override function GetMonthsInYear(
   year : int,
   era : int
) : int;

Parameters

year
[To be supplied.]
era
[To be supplied.]

See Also

HijriCalendar Class | HijriCalendar Members | System.Globalization Namespace


HijriCalendar.GetWeekOfYear

[To be supplied.]

[Visual Basic]
Overrides Public Function GetWeekOfYear( _
   ByVal time As DateTime _
) As Integer
[C#]
public override int GetWeekOfYear(
   DateTime time
);
[C++]
public: override int GetWeekOfYear(
   DateTime time
);
[JScript]
public override function GetWeekOfYear(
   time : DateTime
) : int;

Parameters

time
[To be supplied.]

See Also

HijriCalendar Class | HijriCalendar Members | System.Globalization Namespace


HijriCalendar.GetYear

[To be supplied.]

[Visual Basic]
Overrides Public Function GetYear( _
   ByVal time As DateTime _
) As Integer
[C#]
public override int GetYear(
   DateTime time
);
[C++]
public: override int GetYear(
   DateTime time
);
[JScript]
public override function GetYear(
   time : DateTime
) : int;

Parameters

time
[To be supplied.]

See Also

HijriCalendar Class | HijriCalendar Members | System.Globalization Namespace


HijriCalendar.IsLeapDay

[To be supplied.]

[Visual Basic]
Overrides Public Function IsLeapDay( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal era As Integer _
) As Boolean
[C#]
public override bool IsLeapDay(
   int year,
   int month,
   int day,
   int era
);
[C++]
public: override bool IsLeapDay(
   int year,
   int month,
   int day,
   int era
);
[JScript]
public override function IsLeapDay(
   year : int,
   month : int,
   day : int,
   era : int
) : Boolean;

Parameters

year
[To be supplied.]
month
[To be supplied.]
day
[To be supplied.]
era
[To be supplied.]

See Also

HijriCalendar Class | HijriCalendar Members | System.Globalization Namespace


HijriCalendar.IsLeapMonth

[To be supplied.]

[Visual Basic]
Overrides Public Function IsLeapMonth( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal era As Integer _
) As Boolean
[C#]
public override bool IsLeapMonth(
   int year,
   int month,
   int era
);
[C++]
public: override bool IsLeapMonth(
   int year,
   int month,
   int era
);
[JScript]
public override function IsLeapMonth(
   year : int,
   month : int,
   era : int
) : Boolean;

Parameters

year
[To be supplied.]
month
[To be supplied.]
era
[To be supplied.]

See Also

HijriCalendar Class | HijriCalendar Members | System.Globalization Namespace


HijriCalendar.IsLeapYear

[To be supplied.]

[Visual Basic]
Overrides Public Function IsLeapYear( _
   ByVal year As Integer, _
   ByVal era As Integer _
) As Boolean
[C#]
public override bool IsLeapYear(
   int year,
   int era
);
[C++]
public: override bool IsLeapYear(
   int year,
   int era
);
[JScript]
public override function IsLeapYear(
   year : int,
   era : int
) : Boolean;

Parameters

year
[To be supplied.]
era
[To be supplied.]

See Also

HijriCalendar Class | HijriCalendar Members | System.Globalization Namespace


HijriCalendar.ToDateTime

[To be supplied.]

[Visual Basic]
Overrides Public Function ToDateTime( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal hour As Integer, _
   ByVal minute As Integer, _
   ByVal second As Integer, _
   ByVal millisecond As Integer, _
   ByVal era As Integer _
) As DateTime
[C#]
public override DateTime ToDateTime(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   int millisecond,
   int era
);
[C++]
public: override DateTime ToDateTime(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   int millisecond,
   int era
);
[JScript]
public override function ToDateTime(
   year : int,
   month : int,
   day : int,
   hour : int,
   minute : int,
   second : int,
   millisecond : int,
   era : int
) : DateTime;

Parameters

year
[To be supplied.]
month
[To be supplied.]
day
[To be supplied.]
hour
[To be supplied.]
minute
[To be supplied.]
second
[To be supplied.]
millisecond
[To be supplied.]
era
[To be supplied.]

See Also

HijriCalendar Class | HijriCalendar Members | System.Globalization Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

HijriCalendar Fields

The fields of the HijriCalendar class are listed below. For a complete list of HijriCalendar class members, see the HijriCalendar Members topic.

Public:

HijriEra [To be supplied.]

See Also

HijriCalendar Class | System.Globalization Namespace


HijriCalendar.HijriEra

[To be supplied.]

[Visual Basic]
Public Const HijriEra As Integer
[C#]
public const int HijriEra;
[C++]
public: const int HijriEra;
[JScript]
public var HijriEra : int;

See Also

HijriCalendar Class | HijriCalendar Members | System.Globalization Namespace


JapaneseCalendar Class

[To be supplied.]

Object
Calendar
GregorianCalendar
JapaneseCalendar

[Visual Basic]
Public Class JapaneseCalendar
   Inherits GregorianCalendar
[C#]
public class JapaneseCalendar : GregorianCalendar
[C++]
public __gc class JapaneseCalendar : public GregorianCalendar
[JScript]
public class JapaneseCalendar extends GregorianCalendar

Remarks

[To be supplied.]

Requirements

Namespace: System.Globalization

Assembly: mscorlib.dll

See Also

JapaneseCalendar Members | System.Globalization Namespace


JapaneseCalendar Members

Public:

Constructor

JapaneseCalendar Constructor [To be supplied.]

Properties

CalendarType (inherited from GregorianCalendar) | [To be supplied.]
Eras | [To be supplied.]
TwoDigitYearMax (inherited from GregorianCalendar) | Returns the date and time converted to a DateTime value. This value is the upper boundary of a 100-year range that allows a two-digit year to be properly translated to a four-digit year.

Methods

AddDays (inherited from Calendar) | Returns the DateTime object resulting from adding a fractional number of days to the specified DateTime.
AddHours (inherited from Calendar) | Returns the DateTime resulting from adding a fractional number of hours to the specified DateTime.
AddMilliseconds (inherited from Calendar) | Returns the DateTime resulting from adding the specified number of milliseconds to the specified DateTime.
AddMinutes (inherited from Calendar) | Returns the DateTime resulting from adding a fractional number of minutes to the specified DateTime.
AddMonths (inherited from GregorianCalendar) | Returns the DateTime resulting from adding the given number of months to the specified DateTime.
AddSeconds (inherited from Calendar) | Returns the DateTime resulting from adding a number of seconds to the specified DateTime.
AddWeeks (inherited from GregorianCalendar) | Returns the DateTime resulting from adding a number of weeks to the specified DateTime.
AddYears (inherited from GregorianCalendar) | Returns the DateTime resulting from adding the given number of years to the specified DateTime.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDayOfMonth (inherited from GregorianCalendar) | Returns the day-of-month part of the given DateTime.
GetDayOfWeek (inherited from GregorianCalendar) | Returns the day-of-week part of the specified DateTime.
GetDayOfYear (inherited from GregorianCalendar) | Returns the day-of-year part of the specified DateTime.
GetDaysInMonth | Overloaded. [To be supplied.]
GetDaysInYear | Overloaded. [To be supplied.]
GetEra | Overloaded. [To be supplied.]
GetEraName | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHour (inherited from Calendar) | Returns the hour part of the specified DateTime.
GetMilliseconds (inherited from Calendar) | Returns the millisecond part of the specified DateTime.
GetMinute (inherited from Calendar) | Returns the minute part of the specified DateTime.
GetMonth (inherited from GregorianCalendar) | Returns the month part of the specified DateTime.
GetMonthsInYear (inherited from Calendar) | Overloaded. [To be supplied.]
GetSecond (inherited from Calendar) | Returns the second [RB26] part of the specified DateTime.
GetType (inherited from Object) | Gets the Type of the Object.
GetWeekOfYear (inherited from GregorianCalendar) | Returns the week of year for the given Datetime.
GetYear | [To be supplied.]
IsLeapDay (inherited from Calendar) | Overloaded. [To be supplied.]
IsLeapMonth (inherited from Calendar) | Overloaded. [To be supplied.]
IsLeapYear (inherited from Calendar) | Overloaded. [To be supplied.]
ToDateTime | Overloaded. [To be supplied.]
ToFourDigitYear | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

JapaneseCalendar Class | System.Globalization Namespace


JapaneseCalendar Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public JapaneseCalendar();
[C++]
public: JapaneseCalendar();
[JScript]
public function JapaneseCalendar();

See Also

JapaneseCalendar Class | JapaneseCalendar Members | System.Globalization Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

JapaneseCalendar Properties

The properties of the JapaneseCalendar class are listed below. For a complete list of JapaneseCalendar class members, see the JapaneseCalendar Members topic.

Public:

CalendarType (inherited from GregorianCalendar) | [To be supplied.]
Eras | [To be supplied.]
TwoDigitYearMax (inherited from GregorianCalendar) | Returns the date and time converted to a DateTime value. This value is the upper boundary of a 100-year range that allows a two-digit year to be properly translated to a four-digit year.

See Also

JapaneseCalendar Class | System.Globalization Namespace


JapaneseCalendar.Eras

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Eras As Integer ()
[C#]
public int[] Eras {override get;}
[C++]
public: __property virtual int* get_Eras();
[JScript]
public function get Eras() : int[];

See Also

JapaneseCalendar Class | JapaneseCalendar Members | System.Globalization Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

JapaneseCalendar Methods

The methods of the JapaneseCalendar class are listed below. For a complete list of JapaneseCalendar class members, see the JapaneseCalendar Members topic.

Public:

AddDays (inherited from Calendar) | Returns the DateTime object resulting from adding a fractional number of days to the specified DateTime.
AddHours (inherited from Calendar) | Returns the DateTime resulting from adding a fractional number of hours to the specified DateTime.
AddMilliseconds (inherited from Calendar) | Returns the DateTime resulting from adding the specified number of milliseconds to the specified DateTime.
AddMinutes (inherited from Calendar) | Returns the DateTime resulting from adding a fractional number of minutes to the specified DateTime.
AddMonths (inherited from GregorianCalendar) | Returns the DateTime resulting from adding the given number of months to the specified DateTime.
AddSeconds (inherited from Calendar) | Returns the DateTime resulting from adding a number of seconds to the specified DateTime.
AddWeeks (inherited from GregorianCalendar) | Returns the DateTime resulting from adding a number of weeks to the specified DateTime.
AddYears (inherited from GregorianCalendar) | Returns the DateTime resulting from adding the given number of years to the specified DateTime.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDayOfMonth (inherited from GregorianCalendar) | Returns the day-of-month part of the given DateTime.
GetDayOfWeek (inherited from GregorianCalendar) | Returns the day-of-week part of the specified DateTime.
GetDayOfYear (inherited from GregorianCalendar) | Returns the day-of-year part of the specified DateTime.
GetDaysInMonth | Overloaded. [To be supplied.]
GetDaysInYear | Overloaded. [To be supplied.]
GetEra | Overloaded. [To be supplied.]
GetEraName | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHour (inherited from Calendar) | Returns the hour part of the specified DateTime.
GetMilliseconds (inherited from Calendar) | Returns the millisecond part of the specified DateTime.
GetMinute (inherited from Calendar) | Returns the minute part of the specified DateTime.
GetMonth (inherited from GregorianCalendar) | Returns the month part of the specified DateTime.
GetMonthsInYear (inherited from Calendar) | Overloaded. [To be supplied.]
GetSecond (inherited from Calendar) | Returns the second [RB26] part of the specified DateTime.
GetType (inherited from Object) | Gets the Type of the Object.
GetWeekOfYear (inherited from GregorianCalendar) | Returns the week of year for the given Datetime.
GetYear | [To be supplied.]
IsLeapDay (inherited from Calendar) | Overloaded. [To be supplied.]
IsLeapMonth (inherited from Calendar) | Overloaded. [To be supplied.]
IsLeapYear (inherited from Calendar) | Overloaded. [To be supplied.]
ToDateTime | Overloaded. [To be supplied.]
ToFourDigitYear | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

JapaneseCalendar Class | System.Globalization Namespace


JapaneseCalendar.GetDaysInMonth

[To be supplied.]

[Visual Basic]
Overrides Public Function GetDaysInMonth( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal era As Integer _
) As Integer
[C#]
public override int GetDaysInMonth(
   int year,
   int month,
   int era
);
[C++]
public: override int GetDaysInMonth(
   int year,
   int month,
   int era
);
[JScript]
public override function GetDaysInMonth(
   year : int,
   month : int,
   era : int
) : int;

Parameters

year
[To be supplied.]
month
[To be supplied.]
era
[To be supplied.]

See Also

JapaneseCalendar Class | JapaneseCalendar Members | System.Globalization Namespace


JapaneseCalendar.GetDaysInYear

[To be supplied.]

[Visual Basic]
Overrides Public Function GetDaysInYear( _
   ByVal year As Integer, _
   ByVal era As Integer _
) As Integer
[C#]
public override int GetDaysInYear(
   int year,
   int era
);
[C++]
public: override int GetDaysInYear(
   int year,
   int era
);
[JScript]
public override function GetDaysInYear(
   year : int,
   era : int
) : int;

Parameters

year
[To be supplied.]
era
[To be supplied.]

See Also

JapaneseCalendar Class | JapaneseCalendar Members | System.Globalization Namespace


JapaneseCalendar.GetEra

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overrides Public Function GetEra(DateTime) As Integer
[C#] public override int GetEra(DateTime);
[C++] public: override int GetEra(DateTime);
[JScript] public override function GetEra(DateTime) : int;

[To be supplied.]

[Visual Basic] Overloads Overrides Public Function GetEra(String) As Integer
[C#] public override int GetEra(String);
[C++] public: override int GetEra(String*);
[JScript] public override function GetEra(String) : int;

See Also

JapaneseCalendar Class | JapaneseCalendar Members | System.Globalization Namespace


JapaneseCalendar.GetEra (DateTime)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Function GetEra( _
   ByVal time As DateTime _
) As Integer
[C#]
public override int GetEra(
   DateTime time
);
[C++]
public: override int GetEra(
   DateTime time
);
[JScript]
public override function GetEra(
   time : DateTime
) : int;

Parameters

time
[To be supplied.]

See Also

JapaneseCalendar Class | JapaneseCalendar Members | System.Globalization Namespace | JapaneseCalendar.GetEra Overload List


JapaneseCalendar.GetEra (String)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Function GetEra( _
   ByVal eraName As String _
) As Integer
[C#]
public override int GetEra(
   string eraName
);
[C++]
public: override int GetEra(
   String* eraName
);
[JScript]
public override function GetEra(
   eraName : String
) : int;

Parameters

eraName
[To be supplied.]

See Also

JapaneseCalendar Class | JapaneseCalendar Members | System.Globalization Namespace | JapaneseCalendar.GetEra Overload List


JapaneseCalendar.GetEraName

[To be supplied.]

[Visual Basic]
Overrides Public Function GetEraName( _
   ByVal era As Integer _
) As String
[C#]
public override string GetEraName(
   int era
);
[C++]
public: override String* GetEraName(
   int era
);
[JScript]
public override function GetEraName(
   era : int
) : String;

Parameters

era
[To be supplied.]

See Also

JapaneseCalendar Class | JapaneseCalendar Members | System.Globalization Namespace


JapaneseCalendar.GetMonthsInYear

[To be supplied.]

[Visual Basic]
Overrides Public Function GetMonthsInYear( _
   ByVal year As Integer, _
   ByVal era As Integer _
) As Integer
[C#]
public override int GetMonthsInYear(
   int year,
   int era
);
[C++]
public: override int GetMonthsInYear(
   int year,
   int era
);
[JScript]
public override function GetMonthsInYear(
   year : int,
   era : int
) : int;

Parameters

year
[To be supplied.]
era
[To be supplied.]

See Also

JapaneseCalendar Class | JapaneseCalendar Members | System.Globalization Namespace


JapaneseCalendar.GetYear

[To be supplied.]

[Visual Basic]
Overrides Public Function GetYear( _
   ByVal time As DateTime _
) As Integer
[C#]
public override int GetYear(
   DateTime time
);
[C++]
public: override int GetYear(
   DateTime time
);
[JScript]
public override function GetYear(
   time : DateTime
) : int;

Parameters

time
[To be supplied.]

See Also

JapaneseCalendar Class | JapaneseCalendar Members | System.Globalization Namespace


JapaneseCalendar.IsLeapYear

[To be supplied.]

[Visual Basic]
Overrides Public Function IsLeapYear( _
   ByVal year As Integer, _
   ByVal era As Integer _
) As Boolean
[C#]
public override bool IsLeapYear(
   int year,
   int era
);
[C++]
public: override bool IsLeapYear(
   int year,
   int era
);
[JScript]
public override function IsLeapYear(
   year : int,
   era : int
) : Boolean;

Parameters

year
[To be supplied.]
era
[To be supplied.]

See Also

JapaneseCalendar Class | JapaneseCalendar Members | System.Globalization Namespace


JapaneseCalendar.ToDateTime

[To be supplied.]

[Visual Basic]
Overrides Public Function ToDateTime( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal hour As Integer, _
   ByVal minute As Integer, _
   ByVal second As Integer, _
   ByVal millisecond As Integer, _
   ByVal era As Integer _
) As DateTime
[C#]
public override DateTime ToDateTime(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   int millisecond,
   int era
);
[C++]
public: override DateTime ToDateTime(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   int millisecond,
   int era
);
[JScript]
public override function ToDateTime(
   year : int,
   month : int,
   day : int,
   hour : int,
   minute : int,
   second : int,
   millisecond : int,
   era : int
) : DateTime;

Parameters

year
[To be supplied.]
month
[To be supplied.]
day
[To be supplied.]
hour
[To be supplied.]
minute
[To be supplied.]
second
[To be supplied.]
millisecond
[To be supplied.]
era
[To be supplied.]

See Also

JapaneseCalendar Class | JapaneseCalendar Members | System.Globalization Namespace


JapaneseCalendar.ToFourDigitYear

[To be supplied.]

[Visual Basic]
Overrides Public Function ToFourDigitYear( _
   ByVal year As Integer _
) As Integer
[C#]
public override int ToFourDigitYear(
   int year
);
[C++]
public: override int ToFourDigitYear(
   int year
);
[JScript]
public override function ToFourDigitYear(
   year : int
) : int;

Parameters

year
[To be supplied.]

See Also

JapaneseCalendar Class | JapaneseCalendar Members | System.Globalization Namespace


JulianCalendar Class

[To be supplied.]

Object
Calendar
GregorianCalendar
JulianCalendar

[Visual Basic]
Public Class JulianCalendar
   Inherits GregorianCalendar
[C#]
public class JulianCalendar : GregorianCalendar
[C++]
public __gc class JulianCalendar : public GregorianCalendar
[JScript]
public class JulianCalendar extends GregorianCalendar

Remarks

In 48 B.C., Julius Caesar ordered a calendar reform. This calendar is called the Julian calendar. It consisted of a solar year of twelve months and of 365 days with an extra day every fourth year.

Requirements

Namespace: System.Globalization

Assembly: mscorlib.dll

See Also

JulianCalendar Members | System.Globalization Namespace


JulianCalendar Members

Public:

Constructor

JulianCalendar Constructor Initializes an instance of the JulianCalendar class.

Properties

CalendarType (inherited from GregorianCalendar) | [To be supplied.]
Eras (inherited from GregorianCalendar) | [To be supplied.]
TwoDigitYearMax (inherited from GregorianCalendar) | Returns the date and time converted to a DateTime value. This value is the upper boundary of a 100-year range that allows a two-digit year to be properly translated to a four-digit year.

Methods

AddDays (inherited from Calendar) | Returns the DateTime object resulting from adding a fractional number of days to the specified DateTime.
AddHours (inherited from Calendar) | Returns the DateTime resulting from adding a fractional number of hours to the specified DateTime.
AddMilliseconds (inherited from Calendar) | Returns the DateTime resulting from adding the specified number of milliseconds to the specified DateTime.
AddMinutes (inherited from Calendar) | Returns the DateTime resulting from adding a fractional number of minutes to the specified DateTime.
AddMonths (inherited from GregorianCalendar) | Returns the DateTime resulting from adding the given number of months to the specified DateTime.
AddSeconds (inherited from Calendar) | Returns the DateTime resulting from adding a number of seconds to the specified DateTime.
AddWeeks (inherited from GregorianCalendar) | Returns the DateTime resulting from adding a number of weeks to the specified DateTime.
AddYears (inherited from GregorianCalendar) | Returns the DateTime resulting from adding the given number of years to the specified DateTime.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDayOfMonth (inherited from GregorianCalendar) | Returns the day-of-month part of the given DateTime.
GetDayOfWeek (inherited from GregorianCalendar) | Returns the day-of-week part of the specified DateTime.
GetDayOfYear (inherited from GregorianCalendar) | Returns the day-of-year part of the specified DateTime.
GetDaysInMonth (inherited from GregorianCalendar) | Overloaded. [To be supplied.]
GetDaysInYear (inherited from GregorianCalendar) | Overloaded. [To be supplied.]
GetEra (inherited from GregorianCalendar) | Overloaded. [To be supplied.]
GetEraName (inherited from GregorianCalendar) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHour (inherited from Calendar) | Returns the hour part of the specified DateTime.
GetMilliseconds (inherited from Calendar) | Returns the millisecond part of the specified DateTime.
GetMinute (inherited from Calendar) | Returns the minute part of the specified DateTime.
GetMonth (inherited from GregorianCalendar) | Returns the month part of the specified DateTime.
GetMonthsInYear (inherited from Calendar) | Overloaded. [To be supplied.]
GetSecond (inherited from Calendar) | Returns the second [RB26] part of the specified DateTime.
GetType (inherited from Object) | Gets the Type of the Object.
GetWeekOfYear (inherited from GregorianCalendar) | Returns the week of year for the given Datetime.
GetYear (inherited from GregorianCalendar) | Returns the year part of the specified DateTime.
IsLeapDay (inherited from Calendar) | Overloaded. [To be supplied.]
IsLeapMonth (inherited from GregorianCalendar) | Overloaded. [To be supplied.]
IsLeapYear | Overloaded. [To be supplied.]
ToDateTime (inherited from Calendar) | Overloaded. Returns [RB39] the date and time converted to a DateTime value.
ToFourDigitYear (inherited from Calendar) | Converts the specified year to the appropriate century by using the TwoDigitYearMax property.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

JulianEra [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

JulianCalendar Class | System.Globalization Namespace


JulianCalendar Constructor

Initializes an instance of the JulianCalendar class.

[Visual Basic]
Public Sub New()
[C#]
public JulianCalendar();
[C++]
public: JulianCalendar();
[JScript]
public function JulianCalendar();

See Also

JulianCalendar Class | JulianCalendar Members | System.Globalization Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

JulianCalendar Methods

The methods of the JulianCalendar class are listed below. For a complete list of JulianCalendar class members, see the JulianCalendar Members topic.

Public:

AddDays (inherited from Calendar) | Returns the DateTime object resulting from adding a fractional number of days to the specified DateTime.
AddHours (inherited from Calendar) | Returns the DateTime resulting from adding a fractional number of hours to the specified DateTime.
AddMilliseconds (inherited from Calendar) | Returns the DateTime resulting from adding the specified number of milliseconds to the specified DateTime.
AddMinutes (inherited from Calendar) | Returns the DateTime resulting from adding a fractional number of minutes to the specified DateTime.
AddMonths (inherited from GregorianCalendar) | Returns the DateTime resulting from adding the given number of months to the specified DateTime.
AddSeconds (inherited from Calendar) | Returns the DateTime resulting from adding a number of seconds to the specified DateTime.
AddWeeks (inherited from GregorianCalendar) | Returns the DateTime resulting from adding a number of weeks to the specified DateTime.
AddYears (inherited from GregorianCalendar) | Returns the DateTime resulting from adding the given number of years to the specified DateTime.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDayOfMonth (inherited from GregorianCalendar) | Returns the day-of-month part of the given DateTime.
GetDayOfWeek (inherited from GregorianCalendar) | Returns the day-of-week part of the specified DateTime.
GetDayOfYear (inherited from GregorianCalendar) | Returns the day-of-year part of the specified DateTime.
GetDaysInMonth (inherited from GregorianCalendar) | Overloaded. [To be supplied.]
GetDaysInYear (inherited from GregorianCalendar) | Overloaded. [To be supplied.]
GetEra (inherited from GregorianCalendar) | Overloaded. [To be supplied.]
GetEraName (inherited from GregorianCalendar) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHour (inherited from Calendar) | Returns the hour part of the specified DateTime.
GetMilliseconds (inherited from Calendar) | Returns the millisecond part of the specified DateTime.
GetMinute (inherited from Calendar) | Returns the minute part of the specified DateTime.
GetMonth (inherited from GregorianCalendar) | Returns the month part of the specified DateTime.
GetMonthsInYear (inherited from Calendar) | Overloaded. [To be supplied.]
GetSecond (inherited from Calendar) | Returns the second [RB26] part of the specified DateTime.
GetType (inherited from Object) | Gets the Type of the Object.
GetWeekOfYear (inherited from GregorianCalendar) | Returns the week of year for the given Datetime.
GetYear (inherited from GregorianCalendar) | Returns the year part of the specified DateTime.
IsLeapDay (inherited from Calendar) | Overloaded. [To be supplied.]
IsLeapMonth (inherited from GregorianCalendar) | Overloaded. [To be supplied.]
IsLeapYear | Overloaded. [To be supplied.]
ToDateTime (inherited from Calendar) | Overloaded. Returns [RB39] the date and time converted to a DateTime value.
ToFourDigitYear (inherited from Calendar) | Converts the specified year to the appropriate century by using the TwoDigitYearMax property.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

JulianCalendar Class | System.Globalization Namespace


JulianCalendar.IsLeapYear

Checks whether a given year in the specified era is a leap year.

[Visual Basic]
Overrides Public Function IsLeapYear( _
   ByVal year As Integer, _
   ByVal era As Integer _
) As Boolean
[C#]
public override bool IsLeapYear(
   int year,
   int era
);
[C++]
public: override bool IsLeapYear(
   int year,
   int era
);
[JScript]
public override function IsLeapYear(
   year : int,
   era : int
) : Boolean;

Parameters

year
The year to check.
era
The era to check.

Return Value

Returns true if year is a leap year, false otherwise.

See Also

JulianCalendar Class | JulianCalendar Members | System.Globalization Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

JulianCalendar Fields

The fields of the JulianCalendar class are listed below. For a complete list of JulianCalendar class members, see the JulianCalendar Members topic.

Public:

JulianEra [To be supplied.]

See Also

JulianCalendar Class | System.Globalization Namespace


JulianCalendar.JulianEra

[To be supplied.]

[Visual Basic]
Public Const JulianEra As Integer
[C#]
public const int JulianEra;
[C++]
public: const int JulianEra;
[JScript]
public var JulianEra : int;

See Also

JulianCalendar Class | JulianCalendar Members | System.Globalization Namespace


KoreanCalendar Class

[To be supplied.]

Object
Calendar
GregorianCalendar
KoreanCalendar

[Visual Basic]
Public Class KoreanCalendar
   Inherits GregorianCalendar
[C#]
public class KoreanCalendar : GregorianCalendar
[C++]
public __gc class KoreanCalendar : public GregorianCalendar
[JScript]
public class KoreanCalendar extends GregorianCalendar

Remarks

[To be supplied.]

Requirements

Namespace: System.Globalization

Assembly: mscorlib.dll

See Also

KoreanCalendar Members | System.Globalization Namespace


KoreanCalendar Members

Public:

Constructor

KoreanCalendar Constructor [To be supplied.]

Properties

CalendarType (inherited from GregorianCalendar) | [To be supplied.]
Eras | [To be supplied.]
TwoDigitYearMax (inherited from GregorianCalendar) | Returns the date and time converted to a DateTime value. This value is the upper boundary of a 100-year range that allows a two-digit year to be properly translated to a four-digit year.

Methods

AddDays (inherited from Calendar) | Returns the DateTime object resulting from adding a fractional number of days to the specified DateTime.
AddHours (inherited from Calendar) | Returns the DateTime resulting from adding a fractional number of hours to the specified DateTime.
AddMilliseconds (inherited from Calendar) | Returns the DateTime resulting from adding the specified number of milliseconds to the specified DateTime.
AddMinutes (inherited from Calendar) | Returns the DateTime resulting from adding a fractional number of minutes to the specified DateTime.
AddMonths (inherited from GregorianCalendar) | Returns the DateTime resulting from adding the given number of months to the specified DateTime.
AddSeconds (inherited from Calendar) | Returns the DateTime resulting from adding a number of seconds to the specified DateTime.
AddWeeks (inherited from GregorianCalendar) | Returns the DateTime resulting from adding a number of weeks to the specified DateTime.
AddYears (inherited from GregorianCalendar) | Returns the DateTime resulting from adding the given number of years to the specified DateTime.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDayOfMonth (inherited from GregorianCalendar) | Returns the day-of-month part of the given DateTime.
GetDayOfWeek (inherited from GregorianCalendar) | Returns the day-of-week part of the specified DateTime.
GetDayOfYear (inherited from GregorianCalendar) | Returns the day-of-year part of the specified DateTime.
GetDaysInMonth | Overloaded. [To be supplied.]
GetDaysInYear | Overloaded. [To be supplied.]
GetEra | Overloaded. [To be supplied.]
GetEraName | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHour (inherited from Calendar) | Returns the hour part of the specified DateTime.
GetMilliseconds (inherited from Calendar) | Returns the millisecond part of the specified DateTime.
GetMinute (inherited from Calendar) | Returns the minute part of the specified DateTime.
GetMonth (inherited from GregorianCalendar) | Returns the month part of the specified DateTime.
GetMonthsInYear | Overloaded. [To be supplied.]
GetSecond (inherited from Calendar) | Returns the second [RB26] part of the specified DateTime.
GetType (inherited from Object) | Gets the Type of the Object.
GetWeekOfYear (inherited from GregorianCalendar) | Returns the week of year for the given Datetime.
GetYear | [To be supplied.]
IsLeapDay (inherited from Calendar) | Overloaded. [To be supplied.]
IsLeapMonth (inherited from Calendar) | Overloaded. [To be supplied.]
IsLeapYear | Overloaded. [To be supplied.]
ToDateTime | Overloaded. [To be supplied.]
ToFourDigitYear (inherited from Calendar) | Converts the specified year to the appropriate century by using the TwoDigitYearMax property.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

KoreanEra [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

KoreanCalendar Class | System.Globalization Namespace


KoreanCalendar Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public KoreanCalendar();
[C++]
public: KoreanCalendar();
[JScript]
public function KoreanCalendar();

See Also

KoreanCalendar Class | KoreanCalendar Members | System.Globalization Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

KoreanCalendar Properties

The properties of the KoreanCalendar class are listed below. For a complete list of KoreanCalendar class members, see the KoreanCalendar Members topic.

Public:

CalendarType (inherited from GregorianCalendar) | [To be supplied.]
Eras | [To be supplied.]
TwoDigitYearMax (inherited from GregorianCalendar) | Returns the date and time converted to a DateTime value. This value is the upper boundary of a 100-year range that allows a two-digit year to be properly translated to a four-digit year.

See Also

KoreanCalendar Class | System.Globalization Namespace


KoreanCalendar.Eras

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Eras As Integer ()
[C#]
public int[] Eras {override get;}
[C++]
public: __property virtual int* get_Eras();
[JScript]
public function get Eras() : int[];

See Also

KoreanCalendar Class | KoreanCalendar Members | System.Globalization Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

KoreanCalendar Methods

The methods of the KoreanCalendar class are listed below. For a complete list of KoreanCalendar class members, see the KoreanCalendar Members topic.

Public:

AddDays (inherited from Calendar) | Returns the DateTime object resulting from adding a fractional number of days to the specified DateTime.
AddHours (inherited from Calendar) | Returns the DateTime resulting from adding a fractional number of hours to the specified DateTime.
AddMilliseconds (inherited from Calendar) | Returns the DateTime resulting from adding the specified number of milliseconds to the specified DateTime.
AddMinutes (inherited from Calendar) | Returns the DateTime resulting from adding a fractional number of minutes to the specified DateTime.
AddMonths (inherited from GregorianCalendar) | Returns the DateTime resulting from adding the given number of months to the specified DateTime.
AddSeconds (inherited from Calendar) | Returns the DateTime resulting from adding a number of seconds to the specified DateTime.
AddWeeks (inherited from GregorianCalendar) | Returns the DateTime resulting from adding a number of weeks to the specified DateTime.
AddYears (inherited from GregorianCalendar) | Returns the DateTime resulting from adding the given number of years to the specified DateTime.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDayOfMonth (inherited from GregorianCalendar) | Returns the day-of-month part of the given DateTime.
GetDayOfWeek (inherited from GregorianCalendar) | Returns the day-of-week part of the specified DateTime.
GetDayOfYear (inherited from GregorianCalendar) | Returns the day-of-year part of the specified DateTime.
GetDaysInMonth | Overloaded. [To be supplied.]
GetDaysInYear | Overloaded. [To be supplied.]
GetEra | Overloaded. [To be supplied.]
GetEraName | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHour (inherited from Calendar) | Returns the hour part of the specified DateTime.
GetMilliseconds (inherited from Calendar) | Returns the millisecond part of the specified DateTime.
GetMinute (inherited from Calendar) | Returns the minute part of the specified DateTime.
GetMonth (inherited from GregorianCalendar) | Returns the month part of the specified DateTime.
GetMonthsInYear | Overloaded. [To be supplied.]
GetSecond (inherited from Calendar) | Returns the second [RB26] part of the specified DateTime.
GetType (inherited from Object) | Gets the Type of the Object.
GetWeekOfYear (inherited from GregorianCalendar) | Returns the week of year for the given Datetime.
GetYear | [To be supplied.]
IsLeapDay (inherited from Calendar) | Overloaded. [To be supplied.]
IsLeapMonth (inherited from Calendar) | Overloaded. [To be supplied.]
IsLeapYear | Overloaded. [To be supplied.]
ToDateTime | Overloaded. [To be supplied.]
ToFourDigitYear (inherited from Calendar) | Converts the specified year to the appropriate century by using the TwoDigitYearMax property.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

KoreanCalendar Class | System.Globalization Namespace


KoreanCalendar.GetDaysInMonth

[To be supplied.]

[Visual Basic]
Overrides Public Function GetDaysInMonth( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal era As Integer _
) As Integer
[C#]
public override int GetDaysInMonth(
   int year,
   int month,
   int era
);
[C++]
public: override int GetDaysInMonth(
   int year,
   int month,
   int era
);
[JScript]
public override function GetDaysInMonth(
   year : int,
   month : int,
   era : int
) : int;

Parameters

year
[To be supplied.]
month
[To be supplied.]
era
[To be supplied.]

See Also

KoreanCalendar Class | KoreanCalendar Members | System.Globalization Namespace


KoreanCalendar.GetDaysInYear

[To be supplied.]

[Visual Basic]
Overrides Public Function GetDaysInYear( _
   ByVal year As Integer, _
   ByVal era As Integer _
) As Integer
[C#]
public override int GetDaysInYear(
   int year,
   int era
);
[C++]
public: override int GetDaysInYear(
   int year,
   int era
);
[JScript]
public override function GetDaysInYear(
   year : int,
   era : int
) : int;

Parameters

year
[To be supplied.]
era
[To be supplied.]

See Also

KoreanCalendar Class | KoreanCalendar Members | System.Globalization Namespace


KoreanCalendar.GetEra

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overrides Public Function GetEra(String) As Integer
[C#] public override int GetEra(String);
[C++] public: override int GetEra(String*);
[JScript] public override function GetEra(String) : int;

[To be supplied.]

[Visual Basic] Overloads Overrides Public Function GetEra(DateTime) As Integer
[C#] public override int GetEra(DateTime);
[C++] public: override int GetEra(DateTime);
[JScript] public override function GetEra(DateTime) : int;

See Also

KoreanCalendar Class | KoreanCalendar Members | System.Globalization Namespace


KoreanCalendar.GetEra (String)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Function GetEra( _
   ByVal eraName As String _
) As Integer
[C#]
public override int GetEra(
   string eraName
);
[C++]
public: override int GetEra(
   String* eraName
);
[JScript]
public override function GetEra(
   eraName : String
) : int;

Parameters

eraName
[To be supplied.]

See Also

KoreanCalendar Class | KoreanCalendar Members | System.Globalization Namespace | KoreanCalendar.GetEra Overload List


KoreanCalendar.GetEra (DateTime)

[To be supplied.]

[Visual Basic]
Overloads Overrides Public Function GetEra( _
   ByVal time As DateTime _
) As Integer
[C#]
public override int GetEra(
   DateTime time
);
[C++]
public: override int GetEra(
   DateTime time
);
[JScript]
public override function GetEra(
   time : DateTime
) : int;

Parameters

time
[To be supplied.]

See Also

KoreanCalendar Class | KoreanCalendar Members | System.Globalization Namespace | KoreanCalendar.GetEra Overload List


KoreanCalendar.GetEraName

[To be supplied.]

[Visual Basic]
Overrides Public Function GetEraName( _
   ByVal era As Integer _
) As String
[C#]
public override string GetEraName(
   int era
);
[C++]
public: override String* GetEraName(
   int era
);
[JScript]
public override function GetEraName(
   era : int
) : String;

Parameters

era
[To be supplied.]

See Also

KoreanCalendar Class | KoreanCalendar Members | System.Globalization Namespace


KoreanCalendar.GetMonthsInYear

[To be supplied.]

[Visual Basic]
Overrides Public Function GetMonthsInYear( _
   ByVal year As Integer, _
   ByVal era As Integer _
) As Integer
[C#]
public override int GetMonthsInYear(
   int year,
   int era
);
[C++]
public: override int GetMonthsInYear(
   int year,
   int era
);
[JScript]
public override function GetMonthsInYear(
   year : int,
   era : int
) : int;

Parameters

year
[To be supplied.]
era
[To be supplied.]

See Also

KoreanCalendar Class | KoreanCalendar Members | System.Globalization Namespace


KoreanCalendar.GetYear

[To be supplied.]

[Visual Basic]
Overrides Public Function GetYear( _
   ByVal time As DateTime _
) As Integer
[C#]
public override int GetYear(
   DateTime time
);
[C++]
public: override int GetYear(
   DateTime time
);
[JScript]
public override function GetYear(
   time : DateTime
) : int;

Parameters

time
[To be supplied.]

See Also

KoreanCalendar Class | KoreanCalendar Members | System.Globalization Namespace


KoreanCalendar.IsLeapYear

[To be supplied.]

[Visual Basic]
Overrides Public Function IsLeapYear( _
   ByVal year As Integer, _
   ByVal era As Integer _
) As Boolean
[C#]
public override bool IsLeapYear(
   int year,
   int era
);
[C++]
public: override bool IsLeapYear(
   int year,
   int era
);
[JScript]
public override function IsLeapYear(
   year : int,
   era : int
) : Boolean;

Parameters

year
[To be supplied.]
era
[To be supplied.]

See Also

KoreanCalendar Class | KoreanCalendar Members | System.Globalization Namespace


KoreanCalendar.ToDateTime

[To be supplied.]

[Visual Basic]
Overrides Public Function ToDateTime( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal hour As Integer, _
   ByVal minute As Integer, _
   ByVal second As Integer, _
   ByVal millisecond As Integer, _
   ByVal era As Integer _
) As DateTime
[C#]
public override DateTime ToDateTime(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   int millisecond,
   int era
);
[C++]
public: override DateTime ToDateTime(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   int millisecond,
   int era
);
[JScript]
public override function ToDateTime(
   year : int,
   month : int,
   day : int,
   hour : int,
   minute : int,
   second : int,
   millisecond : int,
   era : int
) : DateTime;

Parameters

year
[To be supplied.]
month
[To be supplied.]
day
[To be supplied.]
hour
[To be supplied.]
minute
[To be supplied.]
second
[To be supplied.]
millisecond
[To be supplied.]
era
[To be supplied.]

See Also

KoreanCalendar Class | KoreanCalendar Members | System.Globalization Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

KoreanCalendar Fields

The fields of the KoreanCalendar class are listed below. For a complete list of KoreanCalendar class members, see the KoreanCalendar Members topic.

Public:

KoreanEra [To be supplied.]

See Also

KoreanCalendar Class | System.Globalization Namespace


KoreanCalendar.KoreanEra

[To be supplied.]

[Visual Basic]
Public Const KoreanEra As Integer
[C#]
public const int KoreanEra;
[C++]
public: const int KoreanEra;
[JScript]
public var KoreanEra : int;

See Also

KoreanCalendar Class | KoreanCalendar Members | System.Globalization Namespace


NumberFormatInfo Class

[To be supplied.]

Object
NumberFormatInfo

[Visual Basic]
NotInheritable Public Class NumberFormatInfo
   Implements ICloneable, IServiceObjectProvider
[C#]
public sealed class NumberFormatInfo : ICloneable,
   IServiceObjectProvider
[C++]
public __gc __sealed class NumberFormatInfo : public ICloneable,
   IServiceObjectProvider
[JScript]
public class NumberFormatInfo implements ICloneable,
   IServiceObjectProvider

Remarks

[To be supplied.]

Requirements

Namespace: System.Globalization

Assembly: mscorlib.dll

See Also

NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo Members

Public:

Constructor

NumberFormatInfo Constructor Creates an invariant, or culturally-independent, NumberFormatInfo object with its ReadOnly property set to false.

Properties

CurrencyDecimalDigits | Retrieves and assigns the number of decimal places used in the representation of currency values.
CurrencyDecimalSeparator | Retrieves and assigns the String used as the decimal separator.
CurrencyGroupSeparator | Retrieves or assigns the character used to separate groups of digits to the left of the decimal point.
CurrencyGroupSize | Retrieves and assigns the group size array.
CurrencyNegativePattern | Retrieves and assigns the format of negative currency values.
CurrencyPositivePattern | Retrieves and assigns the format of positive currency values.
CurrencySymbol | Retrieves and assigns the string used as the local monetary symbol.
CurrentInfo | Returns a NumberFormatInfo object that formats values based on the CultureInfo of the current thread.
InvariantInfo | Returns a NumberFormatInfo object that formats values in an invariant or culturally-independent way.
IsReadOnly | [To be supplied.]
NaNSymbol | Retrieves and assigns the string used to represent the IEEE NaN (not a number) value.
NegativeInfinitySymbol | Retrieves and assigns the string used to represent negative infinity.
NegativeSign | Retrieves and assigns the String used to indicate negative values.
NumberDecimalDigits | Retrieves and assigns the number of decimal places used in the representation of numerical values.
NumberDecimalSeparator | Retrieves and assigns the String used as the decimal separator.
NumberGroupSeparator | Retrieves and assigns the String used to separate groups of digits to the left of the decimal point.
NumberGroupSize | Retrieves and assigns the number of digits in each group to the left of the decimal point.
NumberNegativePattern | Retrieves and assigns the format used for negative values.
PercentDecimalDigits | Retrieves and assigns the number of decimal places used in the representation of percent values.
PercentDecimalSeparator | Retrieves and assigns the character used as the decimal separator.
PercentGroupSeparator | Retrieves and assigns the character used to separate groups of digits to the left of the decimal point.
PercentGroupSize | Retrieves and assigns the group size array.
PercentNegativePattern | Retrieves and assigns the format used for negative percent values.
PercentPositivePattern | Retrieves and assigns the format used for positive percent values.
PercentSymbol | Retrieves and assigns the string used as the local monetary symbol.
PerMilleSymbol | Retrieves and assigns the string used as the per mille symbol.
PositiveInfinitySymbol | Retrieves and assigns the string used to represent positive infinity.
PositiveSign | Retrieves and assigns the character used to indicate positive values.

Methods

Clone | Creates a shallow copy of this instance and sets its ReadOnly field to false.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInstance | Gets the specified NumberFormatInfo object.
GetServiceObject | Gets the specified service object.
GetType (inherited from Object) | Gets the Type of the Object.
ReadOnly | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NumberFormatInfo Class | System.Globalization Namespace


NumberFormatInfo Constructor

Creates an invariant, or culturally-independent, NumberFormatInfo object with its ReadOnly property set to false.

[Visual Basic]
Public Sub New()
[C#]
public NumberFormatInfo();
[C++]
public: NumberFormatInfo();
[JScript]
public function NumberFormatInfo();

Remarks

The properties of this NumberFormatInfo can be modified, if user-defined formatting is desired.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

NumberFormatInfo Properties

The properties of the NumberFormatInfo class are listed below. For a complete list of NumberFormatInfo class members, see the NumberFormatInfo Members topic.

Public:

CurrencyDecimalDigits | Retrieves and assigns the number of decimal places used in the representation of currency values.
CurrencyDecimalSeparator | Retrieves and assigns the String used as the decimal separator.
CurrencyGroupSeparator | Retrieves or assigns the character used to separate groups of digits to the left of the decimal point.
CurrencyGroupSize | Retrieves and assigns the group size array.
CurrencyNegativePattern | Retrieves and assigns the format of negative currency values.
CurrencyPositivePattern | Retrieves and assigns the format of positive currency values.
CurrencySymbol | Retrieves and assigns the string used as the local monetary symbol.
CurrentInfo | Returns a NumberFormatInfo object that formats values based on the CultureInfo of the current thread.
InvariantInfo | Returns a NumberFormatInfo object that formats values in an invariant or culturally-independent way.
IsReadOnly | [To be supplied.]
NaNSymbol | Retrieves and assigns the string used to represent the IEEE NaN (not a number) value.
NegativeInfinitySymbol | Retrieves and assigns the string used to represent negative infinity.
NegativeSign | Retrieves and assigns the String used to indicate negative values.
NumberDecimalDigits | Retrieves and assigns the number of decimal places used in the representation of numerical values.
NumberDecimalSeparator | Retrieves and assigns the String used as the decimal separator.
NumberGroupSeparator | Retrieves and assigns the String used to separate groups of digits to the left of the decimal point.
NumberGroupSize | Retrieves and assigns the number of digits in each group to the left of the decimal point.
NumberNegativePattern | Retrieves and assigns the format used for negative values.
PercentDecimalDigits | Retrieves and assigns the number of decimal places used in the representation of percent values.
PercentDecimalSeparator | Retrieves and assigns the character used as the decimal separator.
PercentGroupSeparator | Retrieves and assigns the character used to separate groups of digits to the left of the decimal point.
PercentGroupSize | Retrieves and assigns the group size array.
PercentNegativePattern | Retrieves and assigns the format used for negative percent values.
PercentPositivePattern | Retrieves and assigns the format used for positive percent values.
PercentSymbol | Retrieves and assigns the string used as the local monetary symbol.
PerMilleSymbol | Retrieves and assigns the string used as the per mille symbol.
PositiveInfinitySymbol | Retrieves and assigns the string used to represent positive infinity.
PositiveSign | Retrieves and assigns the character used to indicate positive values.

See Also

NumberFormatInfo Class | System.Globalization Namespace


NumberFormatInfo.CurrencyDecimalDigits

Retrieves and assigns the number of decimal places used in the representation of currency values.

[Visual Basic]
Public Property CurrencyDecimalDigits As Integer
[C#]
public int CurrencyDecimalDigits {get; set;}
[C++]
public: __property int get_CurrencyDecimalDigits();
public: __property void set_CurrencyDecimalDigits(int);
[JScript]
public function get CurrencyDecimalDigits() : int;
public function set CurrencyDecimalDigits(int);

Property Value

Read/write. The number of decimal places used in the representation of currency values. The default value is 2.

Exceptions

Exception Type | Condition
ArgumentException | value to assign is < 0 or > 99.
InvalidOperationException | This NumberFormatInfo object is read-only and an attempt is made to assign a value.

Remarks

Assignment is not allowed if this NumberFormatInfo object is read-only.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo.CurrencyDecimalSeparator

Retrieves and assigns the String used as the decimal separator.

[Visual Basic]
Public Property CurrencyDecimalSeparator As String
[C#]
public string CurrencyDecimalSeparator {get; set;}
[C++]
public: __property String* get_CurrencyDecimalSeparator();
public: __property void set_CurrencyDecimalSeparator(String*);
[JScript]
public function get CurrencyDecimalSeparator() : String;
public function set CurrencyDecimalSeparator(String);

Property Value

Read/write. The character used as the decimal separator. The default value is '.'.

Exceptions

Exception Type | Condition
ArgumentException | value to assign is null.
InvalidOperationException | This NumberFormatInfo object is read-only and an attempt is made to assign a value.

Remarks

Assignment is not allowed if this NumberFormatInfo object is read-only.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo.CurrencyGroupSeparator

Retrieves or assigns the character used to separate groups of digits to the left of the decimal point.

[Visual Basic]
Public Property CurrencyGroupSeparator As String
[C#]
public string CurrencyGroupSeparator {get; set;}
[C++]
public: __property String* get_CurrencyGroupSeparator();
public: __property void set_CurrencyGroupSeparator(String*);
[JScript]
public function get CurrencyGroupSeparator() : String;
public function set CurrencyGroupSeparator(String);

Property Value

Read/write. The character used to separate groups of digits to the left of the decimal point. The default value is ','.

Exceptions

Exception Type | Condition
ArgumentException | value to assign is null.
InvalidOperationException | This NumberFormatInfo object is read-only and an attempt is made to assign a value.

Remarks

Assignment is not allowed if this NumberFormatInfo object is read-only.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo.CurrencyGroupSize

Retrieves and assigns the group size array.

[Visual Basic]
Public Property CurrencyGroupSize As Integer ()
[C#]
public int[] CurrencyGroupSize {get; set;}
[C++]
public: __property int* get_CurrencyGroupSize();
public: __property void set_CurrencyGroupSize(int*[]);
[JScript]
public function get CurrencyGroupSize() : int[];
public function set CurrencyGroupSize(int[]);

Property Value

Read/write. The group size array. The default value is 3.

Exceptions

Exception Type | Condition
ArgumentException | value to assign is > 9.
InvalidOperationException | This NumberFormatInfo object is read-only and an attempt is made to assign a value.
ArgumentException | value to assign contains non-positive entries other than the last entry, which may be zero.

Remarks

Assignment is not allowed if this NumberFormatInfo object is read-only.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo.CurrencyNegativePattern

Retrieves and assigns the format of negative currency values.

[Visual Basic]
Public Property CurrencyNegativePattern As Integer
[C#]
public int CurrencyNegativePattern {get; set;}
[C++]
public: __property int get_CurrencyNegativePattern();
public: __property void set_CurrencyNegativePattern(int);
[JScript]
public function get CurrencyNegativePattern() : int;
public function set CurrencyNegativePattern(int);

Property Value

Read/write. This property retrieves and assigns the format of negative values. The invariant default value is 0, which reperesents "($1[ls1])".

Exceptions

Exception Type | Condition
ArgumentException | value to assign is < 0 or > 15.
InvalidOperationException | This NumberFormatInfo object is read-only and an attempt is made to assign a value.

Remarks

Assignment is not allowed if this NumberFormatInfo object is read-only.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo.CurrencyPositivePattern

Retrieves and assigns the format of positive currency values.

[Visual Basic]
Public Property CurrencyPositivePattern As Integer
[C#]
public int CurrencyPositivePattern {get; set;}
[C++]
public: __property int get_CurrencyPositivePattern();
public: __property void set_CurrencyPositivePattern(int);
[JScript]
public function get CurrencyPositivePattern() : int;
public function set CurrencyPositivePattern(int);

Property Value

Read/write. The format of positive values. The invariant default value is 0, which represents "$1".

Exceptions

Exception Type | Condition
ArgumentException | value to assign is < 0 or > 3.
InvalidOperationException | This NumberFormatInfo object is read-only and an attempt is made to assign a value.

Remarks

Assignment is not allowed if this NumberFormatInfo object is read-only.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo.CurrencySymbol

Retrieves and assigns the string used as the local monetary symbol.

[Visual Basic]
Public Property CurrencySymbol As String
[C#]
public string CurrencySymbol {get; set;}
[C++]
public: __property String* get_CurrencySymbol();
public: __property void set_CurrencySymbol(String*);
[JScript]
public function get CurrencySymbol() : String;
public function set CurrencySymbol(String);

Property Value

Read/write. The string used as the local monetary symbol. The default value is '$'.

Exceptions

Exception Type | Condition
ArgumentException | value to assign is null.
InvalidOperationException | This NumberFormatInfo object is read-only and an attempt is made to assign a value.

Remarks

Assignment is not allowed if this NumberFormatInfo object is read-only.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo.CurrentInfo

Returns a NumberFormatInfo object that formats values based on the CultureInfo of the current thread.

[Visual Basic]
Public Shared ReadOnly Property CurrentInfo As NumberFormatInfo
[C#]
public static NumberFormatInfo CurrentInfo {get;}
[C++]
public: __property static NumberFormatInfo* get_CurrentInfo();
[JScript]
public static function get CurrentInfo() : NumberFormatInfo;

Property Value

Returns a culture-specific NumberFormatInfo object with its ReadOnly property set to true.

Remarks

It is not possible to set the properties on a culture-specific NumberFormatInfo object.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo.InvariantInfo

Returns a NumberFormatInfo object that formats values in an invariant or culturally-independent way.

[Visual Basic]
Public Shared ReadOnly Property InvariantInfo As NumberFormatInfo
[C#]
public static NumberFormatInfo InvariantInfo {get;}
[C++]
public: __property static NumberFormatInfo* get_InvariantInfo();
[JScript]
public static function get InvariantInfo() : NumberFormatInfo;

Property Value

Returns a reference to the NumberFormatInfo with its ReadOnly property set to true.

Remarks

The returned object's ReadOnly property is set to true; therefore, it is not possible to set the properties on an invariant NumberFormatInfo object obtained by calling this method.

This method is used by the FromString methods.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo.IsReadOnly

[To be supplied.]

[Visual Basic]
Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {get;}
[C++]
public: __property bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo.NaNSymbol

Retrieves and assigns the string used to represent the IEEE NaN (not a number) value.

[Visual Basic]
Public Property NaNSymbol As String
[C#]
public string NaNSymbol {get; set;}
[C++]
public: __property String* get_NaNSymbol();
public: __property void set_NaNSymbol(String*);
[JScript]
public function get NaNSymbol() : String;
public function set NaNSymbol(String);

Property Value

Read/write. The string used to represent NaN values. The default value is 'NaN'.

Exceptions

Exception Type | Condition
ArgumentException | value to assign is null.
InvalidOperationException | This NumberFormatInfo object is read-only and an attempt is made to assign a value.

Remarks

Assignment is not allowed if this NumberFormatInfo object is read-only.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo.NegativeInfinitySymbol

Retrieves and assigns the string used to represent negative infinity.

[Visual Basic]
Public Property NegativeInfinitySymbol As String
[C#]
public string NegativeInfinitySymbol {get; set;}
[C++]
public: __property String* get_NegativeInfinitySymbol();
public: __property void set_NegativeInfinitySymbol(String*);
[JScript]
public function get NegativeInfinitySymbol() : String;
public function set NegativeInfinitySymbol(String);

Property Value

Read/write. The string used to represent negative infinity. The default value is "-Infinity".

Exceptions

Exception Type | Condition
ArgumentException | value to assign is null.
InvalidOperationException | This NumberFormatInfo object is read-only and an attempt is made to assign a value.

Remarks

Assignment is not allowed if this NumberFormatInfo object is read-only.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo.NegativeSign

Retrieves and assigns the String used to indicate negative values.

[Visual Basic]
Public Property NegativeSign As String
[C#]
public string NegativeSign {get; set;}
[C++]
public: __property String* get_NegativeSign();
public: __property void set_NegativeSign(String*);
[JScript]
public function get NegativeSign() : String;
public function set NegativeSign(String);

Property Value

Read/write. The String used to indicate negative values. The default value is '-'.

Exceptions

Exception Type | Condition
ArgumentException | value to assign is null.
InvalidOperationException | This NumberFormatInfo object is read-only and an attempt is made to assign a value.

Remarks

Assignment is not allowed if this NumberFormatInfo object is read-only.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo.NumberDecimalDigits

Retrieves and assigns the number of decimal places used in the representation of numerical values.

[Visual Basic]
Public Property NumberDecimalDigits As Integer
[C#]
public int NumberDecimalDigits {get; set;}
[C++]
public: __property int get_NumberDecimalDigits();
public: __property void set_NumberDecimalDigits(int);
[JScript]
public function get NumberDecimalDigits() : int;
public function set NumberDecimalDigits(int);

Property Value

Read/write. The number of decimal places used to represent numerical values. The default value is 2.

Exceptions

Exception Type | Condition
ArgumentException | value is < 0 or value > 99.
InvalidOperationException | This NumberFormatInfo object is read-only and an attempt is made to assign a value.

Remarks

Assignment is not allowed if this NumberFormatInfo object is read-only.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo.NumberDecimalSeparator

Retrieves and assigns the String used as the decimal separator.

[Visual Basic]
Public Property NumberDecimalSeparator As String
[C#]
public string NumberDecimalSeparator {get; set;}
[C++]
public: __property String* get_NumberDecimalSeparator();
public: __property void set_NumberDecimalSeparator(String*);
[JScript]
public function get NumberDecimalSeparator() : String;
public function set NumberDecimalSeparator(String);

Property Value

Read/write. The String used as the decimal separator. The default value is '.'.

Exceptions

Exception Type | Condition
ArgumentException | value to assign is null.
InvalidOperationException | This NumberFormatInfo object is read-only and an attempt is made to assign a value.

Remarks

Assignment is not allowed if this NumberFormatInfo object is read-only.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo.NumberGroupSeparator

Retrieves and assigns the String used to separate groups of digits to the left of the decimal point.

[Visual Basic]
Public Property NumberGroupSeparator As String
[C#]
public string NumberGroupSeparator {get; set;}
[C++]
public: __property String* get_NumberGroupSeparator();
public: __property void set_NumberGroupSeparator(String*);
[JScript]
public function get NumberGroupSeparator() : String;
public function set NumberGroupSeparator(String);

Property Value

Read/write. The String used to separate groups of digits to the left of the decimal point. The default value is ','.

Exceptions

Exception Type | Condition
ArgumentException | value to assign is null.
InvalidOperationException | This NumberFormatInfo object is read-only and an attempt is made to assign a value.

Remarks

Assignment is not allowed if this NumberFormatInfo object is read-only.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo.NumberGroupSize

Retrieves and assigns the number of digits in each group to the left of the decimal point.

[Visual Basic]
Public Property NumberGroupSize As Integer ()
[C#]
public int[] NumberGroupSize {get; set;}
[C++]
public: __property int* get_NumberGroupSize();
public: __property void set_NumberGroupSize(int*[]);
[JScript]
public function get NumberGroupSize() : int[];
public function set NumberGroupSize(int[]);

Property Value

Read/write. The number of digits in each group to the left of the decimal point. The default is an array of length one with the value 3.

Exceptions

Exception Type | Condition
ArgumentException | value contains any entries that are non-positive other than the last entry, which may be 0.
InvalidOperationException | This NumberFormatInfo object is read-only and an attempt is made to assign a value.
ArgumentException | value contains one or more entries greater than 9.

Remarks

Note: Assignment is not allowed if this NumberFormatInfo object is read-only.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo.NumberNegativePattern

Retrieves and assigns the format used for negative values.

[Visual Basic]
Public Property NumberNegativePattern As Integer
[C#]
public int NumberNegativePattern {get; set;}
[C++]
public: __property int get_NumberNegativePattern();
public: __property void set_NumberNegativePattern(int);
[JScript]
public function get NumberNegativePattern() : int;
public function set NumberNegativePattern(int);

Property Value

Read/write. The format of negative values. The invariant default value is 0, which represents "-1".

Exceptions

Exception Type | Condition
ArgumentException | value to assign is < 0 or > 4.
InvalidOperationException | This NumberFormatInfo object is read-only and an attempt is made to assign a value.

Remarks

Assignment is not allowed if this NumberFormatInfo object is read-only.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo.PercentDecimalDigits

Retrieves and assigns the number of decimal places used in the representation of percent values.

[Visual Basic]
Public Property PercentDecimalDigits As Integer
[C#]
public int PercentDecimalDigits {get; set;}
[C++]
public: __property int get_PercentDecimalDigits();
public: __property void set_PercentDecimalDigits(int);
[JScript]
public function get PercentDecimalDigits() : int;
public function set PercentDecimalDigits(int);

Property Value

Read/write. The number of decimal places used to represent percentages. The default value is 0.

Exceptions

Exception Type | Condition
ArgumentException | value to assign is < 0 or > 99.
InvalidOperationException | This NumberFormatInfo object is read-only and an attempt is made to assign a value.

Remarks

Assignment is not allowed if this NumberFormatInfo object is read-only.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo.PercentDecimalSeparator

Retrieves and assigns the character used as the decimal separator.

[Visual Basic]
Public Property PercentDecimalSeparator As String
[C#]
public string PercentDecimalSeparator {get; set;}
[C++]
public: __property String* get_PercentDecimalSeparator();
public: __property void set_PercentDecimalSeparator(String*);
[JScript]
public function get PercentDecimalSeparator() : String;
public function set PercentDecimalSeparator(String);

Property Value

Read/write. This property retrieves and assigns the character used as the decimal separator. The default value is '.'.

Exceptions

Exception Type | Condition
ArgumentException | value to assign is null.
InvalidOperationException | This NumberFormatInfo object is read-only and an attempt is made to assign a value.

Remarks

Assignment is not allowed if this NumberFormatInfo object is read-only.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo.PercentGroupSeparator

Retrieves and assigns the character used to separate groups of digits to the left of the decimal point.

[Visual Basic]
Public Property PercentGroupSeparator As String
[C#]
public string PercentGroupSeparator {get; set;}
[C++]
public: __property String* get_PercentGroupSeparator();
public: __property void set_PercentGroupSeparator(String*);
[JScript]
public function get PercentGroupSeparator() : String;
public function set PercentGroupSeparator(String);

Property Value

Read/write. The character used to separate groups of digits to the left of the decimal point. The default value is ','.

Exceptions

Exception Type | Condition
ArgumentException | value to assign is null.
InvalidOperationException | This NumberFormatInfo object is read-only and an attempt is made to assign a value.

Remarks

Assignment is not allowed if this NumberFormatInfo object is read-only.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo.PercentGroupSize

Retrieves and assigns the group size array.

[Visual Basic]
Public Property PercentGroupSize As Integer ()
[C#]
public int[] PercentGroupSize {get; set;}
[C++]
public: __property int* get_PercentGroupSize();
public: __property void set_PercentGroupSize(int*[]);
[JScript]
public function get PercentGroupSize() : int[];
public function set PercentGroupSize(int[]);

Property Value

Read/write. The group size array. The default value is 3[LS2] .

Exceptions

Exception Type | Condition
ArgumentException | value contains any entries greater than 9.
InvalidOperationException | This NumberFormatInfo object is read-only and an attempt is made to assign a value.
ArgumentException | value contains any entries that are non-positive other than the last entry, which may be 0.

Remarks

Assignment is not allowed if this NumberFormatInfo object is read-only.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo.PercentNegativePattern

Retrieves and assigns the format used for negative percent values.

[Visual Basic]
Public Property PercentNegativePattern As Integer
[C#]
public int PercentNegativePattern {get; set;}
[C++]
public: __property int get_PercentNegativePattern();
public: __property void set_PercentNegativePattern(int);
[JScript]
public function get PercentNegativePattern() : int;
public function set PercentNegativePattern(int);

Property Value

Read/write. The format used for negative values. The invariant default value is 0, which represents "(1%)"

Exceptions

Exception Type | Condition
ArgumentException | value to assign is < 0 or > 2.
InvalidOperationException | This NumberFormatInfo object is read-only and an attempt is made to assign a value.

Remarks

Assignment is not allowed if this NumberFormatInfo object is read-only.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo.PercentPositivePattern

Retrieves and assigns the format used for positive percent values.

[Visual Basic]
Public Property PercentPositivePattern As Integer
[C#]
public int PercentPositivePattern {get; set;}
[C++]
public: __property int get_PercentPositivePattern();
public: __property void set_PercentPositivePattern(int);
[JScript]
public function get PercentPositivePattern() : int;
public function set PercentPositivePattern(int);

Property Value

Read/write. The format used for positive values. The invariant default value is 0, which represents "1%".

Exceptions

Exception Type | Condition
ArgumentException | value to assign is < 0 or > 2.
InvalidOperationException | This NumberFormatInfo object is read-only and an attempt is made to assign a value.

Remarks

Assignment is not allowed if this NumberFormatInfo object is read-only.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo.PercentSymbol

Retrieves and assigns the string used as the local monetary symbol.

[Visual Basic]
Public Property PercentSymbol As String
[C#]
public string PercentSymbol {get; set;}
[C++]
public: __property String* get_PercentSymbol();
public: __property void set_PercentSymbol(String*);
[JScript]
public function get PercentSymbol() : String;
public function set PercentSymbol(String);

Property Value

Read/write. The string used as the percent symbol. The invariant default value is '%'.

Exceptions

Exception Type | Condition
ArgumentException | value to assign is null.
InvalidOperationException | This NumberFormatInfo object is read-only and an attempt is made to assign a value.

Remarks

Assignment is not allowed if this NumberFormatInfo object is read-only.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo.PerMilleSymbol

Retrieves and assigns the string used as the per mille symbol.

[Visual Basic]
Public Property PerMilleSymbol As String
[C#]
public string PerMilleSymbol {get; set;}
[C++]
public: __property String* get_PerMilleSymbol();
public: __property void set_PerMilleSymbol(String*);
[JScript]
public function get PerMilleSymbol() : String;
public function set PerMilleSymbol(String);

Property Value

Read/write. This property retrieves and assigns the string used as the local per mille symbol. The invariant default value is '?', which is u/2030.

Exceptions

Exception Type | Condition
ArgumentException | value to assign is null.
InvalidOperationException | This NumberFormatInfo object is read-only and an attempt is made to assign a value.

Remarks

Assignment is not allowed if this NumberFormatInfo object is read-only.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo.PositiveInfinitySymbol

Retrieves and assigns the string used to represent positive infinity.

[Visual Basic]
Public Property PositiveInfinitySymbol As String
[C#]
public string PositiveInfinitySymbol {get; set;}
[C++]
public: __property String* get_PositiveInfinitySymbol();
public: __property void set_PositiveInfinitySymbol(String*);
[JScript]
public function get PositiveInfinitySymbol() : String;
public function set PositiveInfinitySymbol(String);

Property Value

Read/write. This property retrieves and assigns the string used to represent positive infinities. The default value is 'Infinity'.

Exceptions

Exception Type | Condition
ArgumentException | value to assign is null.
InvalidOperationException | This NumberFormatInfo object is read-only and an attempt is made to assign a value.

Remarks

Assignment is not allowed if this NumberFormatInfo object is read-only.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo.PositiveSign

Retrieves and assigns the character used to indicate positive values.

[Visual Basic]
Public Property PositiveSign As String
[C#]
public string PositiveSign {get; set;}
[C++]
public: __property String* get_PositiveSign();
public: __property void set_PositiveSign(String*);
[JScript]
public function get PositiveSign() : String;
public function set PositiveSign(String);

Property Value

Read/write. The character used to indicate positive values. The default value is '+'.

Exceptions

Exception Type | Condition
InvalidOperationException | if this NumberFormatInfo object is read-only and an attempt is made to assign a value.

Remarks

Assignment is not allowed if this NumberFormatInfo object is read-only.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

NumberFormatInfo Methods

The methods of the NumberFormatInfo class are listed below. For a complete list of NumberFormatInfo class members, see the NumberFormatInfo Members topic.

Public:

Clone | Creates a shallow copy of this instance and sets its ReadOnly field to false.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInstance | Gets the specified NumberFormatInfo object.
GetServiceObject | Gets the specified service object.
GetType (inherited from Object) | Gets the Type of the Object.
ReadOnly | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NumberFormatInfo Class | System.Globalization Namespace


NumberFormatInfo.Clone

Creates a shallow copy of this instance and sets its ReadOnly field to false.

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

Return Value

A shallow copy of this instance.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo.GetInstance

Gets the specified NumberFormatInfo object.

[Visual Basic]
Public Shared Function GetInstance( _
   ByVal sop As IServiceObjectProvider _
) As NumberFormatInfo
[C#]
public static NumberFormatInfo GetInstance(
   IServiceObjectProvider sop
);
[C++]
public: static NumberFormatInfo* GetInstance(
   IServiceObjectProvider* sop
);
[JScript]
public static function GetInstance(
   sop : IServiceObjectProvider
) : NumberFormatInfo;

Parameters

sop
The IServiceObjectProvider used to get the NumberFormatInfo object.

Return Value

Returns the specified NumberFormatInfo object.

Remarks

The GetServiceObject method on sop is passed a NumberFormatInfo Type object and its return value is cast as a NumberFormatInfo before being returned by this method. Note that if sop is null or if the return value of GetServiceObject is null, then this method simply invokes GetCurrent.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo.GetServiceObject

Gets the specified service object.

[Visual Basic]
Overridable Public Function GetServiceObject( _
   ByVal service As Type _
) As Object
[C#]
public virtual object GetServiceObject(
   Type service
);
[C++]
public: virtual Object* GetServiceObject(
   Type* service
);
[JScript]
public function GetServiceObject(
   service : Type
) : Object;

Parameters

service
A Type object representing the type of the service object to get.

Return Value

If service is the Type object for the NumberFormatInfo class, then this instance of NumberFormatInfo is returned. Otherwise, null is returned.

Remarks

This method provides the implementation for IServiceObjectProvider.GetServiceObject.

This method is invoked by the Format(String, IServiceObjectProvider) method supported by the base data types when this instance is passed as the IServiceObjectProvider.

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberFormatInfo.ReadOnly

[To be supplied.]

[Visual Basic]
Public Shared Function ReadOnly( _
   ByVal nfi As NumberFormatInfo _
) As NumberFormatInfo
[C#]
public static NumberFormatInfo ReadOnly(
   NumberFormatInfo nfi
);
[C++]
public: static NumberFormatInfo* ReadOnly(
   NumberFormatInfo* nfi
);
[JScript]
public static function ReadOnly(
   nfi : NumberFormatInfo
) : NumberFormatInfo;

Parameters

nfi
[To be supplied.]

See Also

NumberFormatInfo Class | NumberFormatInfo Members | System.Globalization Namespace


NumberStyles Enumeration

Determines the style permitted in numerical string arguments that are passed to the Parse methods of the numeric base type classes.

[Visual Basic]
Public Enum NumberStyles
[C#]
public enum NumberStyles
[C++]
public enum NumberStyles

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

The symbols to be used for currency symbol, thousands separator, decimal point indicator, and leading sign are specified by NumberFormatInfo.

The attributes of NumberStyles are set by using the bitwise inclusive OR of the field flags. The Most Significant Bit (MSB) is the leftmost bit.

The third column lists the number styles with individual field flags, which are assigned as individual bits. The last five column headers (Any through Number) are composite number styles that combine individual field flags.

Under the composite number styles, a "1" means that the composite number style includes the individual number style in that row; a "0" means the composite number style does not include the individual number style in that row.

The hexadecimal representation of the composite number styles are listed in the last row of the table.

Bit | Hexadecimal | Number styles with individual field flags | Any | Currency | Float | Integer | Number
MSB: 1 | 100 | AllowCurrencySymbol | 1 | 1 | 0 | 0 | 0
MSB: 2 | 80 | AllowExponent | 1 | 0 | 1 | 0 | 0
MSB: 3 | 40 | AllowThousands | 1 | 1 | 0 | 0 | 1
MSB: 4 | 20 | AllowDecimalPoint | 1 | 1 | 1 | 0 | 1
MSB: 5 | 10 | AllowParentheses | 1 | 1 | 0 | 0 | 0
MSB: 6 | 8 | AllowTrailingSign | 1 | 1 | 0 | 0 | 0
MSB: 7 | 4 | AllowLeadingSign | 1 | 1 | 1 | 1 | 1
MSB: 8 | 2 | AllowTrailingWhite | 1 | 1 | 1 | 1 | 1
LSB: 9 | 1 | AllowLeadingWhite | 1 | 1 | 1 | 1 | 1
 |  | Hexadecimal -> | 1ff | 17f | 0a7 | 7 | 67

Members

Member Name | Description
AllowCurrencySymbol | Indicates that a currency symbol is allowed. Valid currency symbols are determined by the CurrencySymbol property of NumberFormatInfo.
AllowDecimalPoint | Indicates that a decimal point is allowed. Valid decimal point characters are determined by the NumberDecimalSeparator and CurrencyDecimalSeparator properties of NumberFormatInfo.
AllowExponent | Indicates that an exponent is allowed. The format of the number should be {e|E} [{+|-}]xxx.
AllowLeadingSign | Indicates that a leading sign is allowed. Valid leading sign characters are determined by the PositiveSign and NegativeSign properties of NumberFormatInfo.
AllowLeadingWhite | Indicates that a leading white space is allowed. Valid white space characters have the Unicode encoding 0x0009, 0x000A, 0x000B, 0x000C, 0x000D, and 0x0020.
AllowParentheses | Indicates that parentheses are allowed.
AllowThousands | Indicates that group separators are allowed; for instance, separating the hundreds from the thousands. Valid group separator characters are determined by the NumberGroupSeparator and CurrencyGroupSeparator properties of NumberFormatInfo, and the space between them is determined by the NumberGroupSize and CurrencyGroupSize properties of NumberFormatInfo.
AllowTrailingSign | Indicates that a trailing sign is allowed. Valid trailing sign characters are determined by the PositiveSign and NegativeSign properties of NumberFormatInfo.
AllowTrailingWhite | Indicates that trailing white space is allowed. Valid white space characters have the Unicode encoding 0x0009, 0x000A, 0x000B, 0x000C, 0x000D, and 0x0020.
Any | Indicates that all the AllowXXX bit styles are permitted.
Currency | Indicates that all styles except AllowExponent are allowed
Float | Indicates that the AllowLeadingWhite, AllowTrailingWhite, AllowLeadingSign, AllowDecimalPoint and AllowExponent styles are allowed.
Integer | Indicates that the AllowLeadingWhite, AllowTrailingWhite, and AllowLeadingSign styles are allowed.
None | Indicates that none of the bit styles are allowed.
Number | Indicates that the AllowLeadingWhite, AllowTrailingWhite, AllowLeadingSign, AllowDecimalPoint and AllowThousands styles are allowed.

Requirements

Namespace: System.Globalization

Assembly: mscorlib.dll

See Also

System.Globalization Namespace | NumberFormatInfo


RegionInfo Class

[To be supplied.]

Object
RegionInfo

[Visual Basic]
Public Class RegionInfo
[C#]
public class RegionInfo
[C++]
public __gc class RegionInfo
[JScript]
public class RegionInfo

Remarks

In contrast to CultureInfo, the RegionInfo does not represent preferences of the user and does not depend on the user's language or culture.

Requirements

Namespace: System.Globalization

Assembly: mscorlib.dll

See Also

RegionInfo Members | System.Globalization Namespace


RegionInfo Members

Public:

Constructor

RegionInfo Constructor Overloaded. [To be supplied.]

Properties

CurrencySymbol | [To be supplied.]
CurrentRegion | Returns the current RegionInfo object for this instance.
DisplayName | Retrieves the full name of the region in the UI language.
EnglishName | Retrieves the name of the region in English
IsMetric | Determines whether measurements on this instance use the S.I. system.
ISOCurrencySymbol | [To be supplied.]
Name | Retrieves the name of the region.
NativeName | [To be supplied.]
ThreeLetterISORegionName | Retrieves the ISO 3166 three-letter code for the region of this RegionInfo.
ThreeLetterWindowRegionName | Retrieves the Windows version of the three-letter code for the region of this RegionInfo.
TwoLetterISORegionName | Retrieves the ISO 3166 two-letter code for the region of this RegionInfo.

Methods

Equals | Determines whether the given object refers to the same RegionInfo as the current instance.
GetHashCode | Returns the hash code for the RegionInfo.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Returns the name of the region.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RegionInfo Class | System.Globalization Namespace


RegionInfo Constructor

[To be supplied.]

Overload List

Initializes an instance of the named RegionInfo class.

[Visual Basic] Overloads Public Sub New(String)
[C#] public RegionInfo(String);
[C++] public: RegionInfo(String*);
[JScript] public function RegionInfo(String);

Initializes an instance of the RegionInfo class that most closely corresponds to the culture identifier.

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public RegionInfo(int);
[C++] public: RegionInfo(int);
[JScript] public function RegionInfo(int);

See Also

RegionInfo Class | RegionInfo Members | System.Globalization Namespace


RegionInfo Constructor (String)

Initializes an instance of the named RegionInfo class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal name As String _
)
[C#]
public RegionInfo(
   string name
);
[C++]
public: RegionInfo(
   String* name
);
[JScript]
public function RegionInfo(
   name : String
);

Parameters

name
The string indicating the RegionInfo name. The name must be one of the 3 letter names defined by the ISO 3166 standard. Case is not significant.

Remarks

See Region Names for a list of names provided with NLS+.

See Also

RegionInfo Class | RegionInfo Members | System.Globalization Namespace | RegionInfo Constructor Overload List


RegionInfo Constructor (Int32)

Initializes an instance of the RegionInfo class that most closely corresponds to the culture identifier.

[Visual Basic]
Overloads Public Sub New( _
   ByVal culture As Integer _
)
[C#]
public RegionInfo(
   int culture
);
[C++]
public: RegionInfo(
   int culture
);
[JScript]
public function RegionInfo(
   culture : int
);

Parameters

culture
The culture identifier contains information about the primary language identifier, sublanguage identifier and sort ID. The culture parameter is mapped to the corresponding NLS locale identifier.

Remarks

This method is provided for ease of integration with NLS-based software.

See Also

RegionInfo Class | RegionInfo Members | System.Globalization Namespace | RegionInfo Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RegionInfo Properties

The properties of the RegionInfo class are listed below. For a complete list of RegionInfo class members, see the RegionInfo Members topic.

Public:

CurrencySymbol | [To be supplied.]
CurrentRegion | Returns the current RegionInfo object for this instance.
DisplayName | Retrieves the full name of the region in the UI language.
EnglishName | Retrieves the name of the region in English
IsMetric | Determines whether measurements on this instance use the S.I. system.
ISOCurrencySymbol | [To be supplied.]
Name | Retrieves the name of the region.
NativeName | [To be supplied.]
ThreeLetterISORegionName | Retrieves the ISO 3166 three-letter code for the region of this RegionInfo.
ThreeLetterWindowRegionName | Retrieves the Windows version of the three-letter code for the region of this RegionInfo.
TwoLetterISORegionName | Retrieves the ISO 3166 two-letter code for the region of this RegionInfo.

See Also

RegionInfo Class | System.Globalization Namespace


RegionInfo.CurrencySymbol

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property CurrencySymbol As String
[C#]
public string CurrencySymbol {virtual get;}
[C++]
public: __property virtual String* get_CurrencySymbol();
[JScript]
public function get CurrencySymbol() : String;

See Also

RegionInfo Class | RegionInfo Members | System.Globalization Namespace


RegionInfo.CurrentRegion

Returns the current RegionInfo object for this instance.

[Visual Basic]
Public Shared ReadOnly Property CurrentRegion As RegionInfo
[C#]
public static RegionInfo CurrentRegion {get;}
[C++]
public: __property static RegionInfo* get_CurrentRegion();
[JScript]
public static function get CurrentRegion() : RegionInfo;

Property Value

To be supplied.

Remarks

This instance provides methods based on the current user settings. These settings are volatile and may change over the lifetime of the thread.

See Also

RegionInfo Class | RegionInfo Members | System.Globalization Namespace


RegionInfo.DisplayName

Retrieves the full name of the region in the UI language.

[Visual Basic]
Overridable Public ReadOnly Property DisplayName As String
[C#]
public string DisplayName {virtual get;}
[C++]
public: __property virtual String* get_DisplayName();
[JScript]
public function get DisplayName() : String;

See Also

RegionInfo Class | RegionInfo Members | System.Globalization Namespace


RegionInfo.EnglishName

Retrieves the name of the region in English

[Visual Basic]
Overridable Public ReadOnly Property EnglishName As String
[C#]
public string EnglishName {virtual get;}
[C++]
public: __property virtual String* get_EnglishName();
[JScript]
public function get EnglishName() : String;

See Also

RegionInfo Class | RegionInfo Members | System.Globalization Namespace


RegionInfo.IsMetric

Determines whether measurements on this instance use the S.I. system.

[Visual Basic]
Overridable Public ReadOnly Property IsMetric As Boolean
[C#]
public bool IsMetric {virtual get;}
[C++]
public: __property virtual bool get_IsMetric();
[JScript]
public function get IsMetric() : Boolean;

Property Value

Returns true if measurements use the S.I. system.

Remarks

[To be supplied.]

See Also

RegionInfo Class | RegionInfo Members | System.Globalization Namespace


RegionInfo.ISOCurrencySymbol

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property ISOCurrencySymbol As String
[C#]
public string ISOCurrencySymbol {virtual get;}
[C++]
public: __property virtual String* get_ISOCurrencySymbol();
[JScript]
public function get ISOCurrencySymbol() : String;

See Also

RegionInfo Class | RegionInfo Members | System.Globalization Namespace


RegionInfo.Name

Retrieves the name of the region.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {virtual get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

See Also

RegionInfo Class | RegionInfo Members | System.Globalization Namespace


RegionInfo.NativeName

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property NativeName As String
[C#]
public string NativeName {virtual get;}
[C++]
public: __property virtual String* get_NativeName();
[JScript]
public function get NativeName() : String;

See Also

RegionInfo Class | RegionInfo Members | System.Globalization Namespace


RegionInfo.ThreeLetterISORegionName

Retrieves the ISO 3166 three-letter code for the region of this RegionInfo.

[Visual Basic]
Overridable Public ReadOnly Property ThreeLetterISORegionName As _
   String
[C#]
public string ThreeLetterISORegionName {virtual get;}
[C++]
public: __property virtual String* get_ThreeLetterISORegionName();
[JScript]
public function get ThreeLetterISORegionName() : String;

Property Value

Read-only. Retrieves a String representing the ISO 3166 three-letter code for the region. For example, the three-letter abbreviation for United States is "usa".

See Also

RegionInfo Class | RegionInfo Members | System.Globalization Namespace


RegionInfo.ThreeLetterWindowRegionName

Retrieves the Windows version of the three-letter code for the region of this RegionInfo.

[Visual Basic]
Overridable Public ReadOnly Property ThreeLetterWindowRegionName As _
   String
[C#]
public string ThreeLetterWindowRegionName {virtual get;}
[C++]
public: __property virtual String*
   get_ThreeLetterWindowRegionName();
[JScript]
public function get ThreeLetterWindowRegionName() : String;

Property Value

Read-only. Retrieves a String representing the three-letter code for the region. For example, the three-letter abbreviation for United States is "usa".

See Also

RegionInfo Class | RegionInfo Members | System.Globalization Namespace


RegionInfo.TwoLetterISORegionName

Retrieves the ISO 3166 two-letter code for the region of this RegionInfo.

[Visual Basic]
Overridable Public ReadOnly Property TwoLetterISORegionName As _
   String
[C#]
public string TwoLetterISORegionName {virtual get;}
[C++]
public: __property virtual String* get_TwoLetterISORegionName();
[JScript]
public function get TwoLetterISORegionName() : String;

Property Value

Read-only. Retrieves a String representing the two-letter code for the region. For example, the two-letter abbreviation for United States is "us".

See Also

RegionInfo Class | RegionInfo Members | System.Globalization Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RegionInfo Methods

The methods of the RegionInfo class are listed below. For a complete list of RegionInfo class members, see the RegionInfo Members topic.

Public:

Equals | Determines whether the given object refers to the same RegionInfo as the current instance.
GetHashCode | Returns the hash code for the RegionInfo.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Returns the name of the region.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RegionInfo Class | System.Globalization Namespace


RegionInfo.Equals

Determines whether the given object refers to the same RegionInfo as the current instance.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal value As Object _
) As Boolean
[C#]
public override bool Equals(
   object value
);
[C++]
public: override bool Equals(
   Object* value
);
[JScript]
public override function Equals(
   value : Object
) : Boolean;

Parameters

value
The object to be compared to the current instance.

Return Value

Value | Meaning
True | object refers to the same RegionInfo as the current instance.
False | object does not refer to the same RegionInfo as the current instance.

Remarks

This method overrides Object.Equals.

See Also

RegionInfo Class | RegionInfo Members | System.Globalization Namespace


RegionInfo.GetHashCode

Returns the hash code for the RegionInfo.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

Returns the hash code for the RegionInfo.

Remarks

The hash code is guaranteed to be the same for RegionInfo A and B where A.Equals(B) is true.

This method overrides Object.GetHashCode.

See Also

RegionInfo Class | RegionInfo Members | System.Globalization Namespace


RegionInfo.ToString

Returns the name of the region.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

Returns a String representing the name of the region. For example, the region name for the United States is "United States."

Remarks

This method overrides Object.ToString.

See Also

RegionInfo Class | RegionInfo Members | System.Globalization Namespace


SortKey Class

[To be supplied.]

Object
SortKey

[Visual Basic]
Public Class SortKey
[C#]
public class SortKey
[C++]
public __gc class SortKey
[JScript]
public class SortKey

Remarks

[To be supplied.]

Requirements

Namespace: System.Globalization

Assembly: mscorlib.dll

See Also

SortKey Members | System.Globalization Namespace


SortKey Members

Public:

Methods

Compare | Compares two sort keys.
Equals | Checks whether the object refers to the same sort key as the current instance.
GetHashCode | Returns the hash code for the current instance of the sort key.
GetKeyData | Obtains the byte array representing the sort key of the current instance.
GetOriginalString | Obtains the original string used to create the sort key of the current instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Obtains a string describing the sort key.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SortKey Class | System.Globalization Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SortKey Methods

The methods of the SortKey class are listed below. For a complete list of SortKey class members, see the SortKey Members topic.

Public:

Compare | Compares two sort keys.
Equals | Checks whether the object refers to the same sort key as the current instance.
GetHashCode | Returns the hash code for the current instance of the sort key.
GetKeyData | Obtains the byte array representing the sort key of the current instance.
GetOriginalString | Obtains the original string used to create the sort key of the current instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Obtains a string describing the sort key.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SortKey Class | System.Globalization Namespace


SortKey.Compare

Compares two sort keys.

[Visual Basic]
Public Shared Function Compare( _
   ByVal sortkey1 As SortKey, _
   ByVal sortkey2 As SortKey _
) As Integer
[C#]
public static int Compare(
   SortKey sortkey1,
   SortKey sortkey2
);
[C++]
public: static int Compare(
   SortKey* sortkey1,
   SortKey* sortkey2
);
[JScript]
public static function Compare(
   sortkey1 : SortKey,
   sortkey2 : SortKey
) : int;

Parameters

sortkey1
The first sort key.
sortkey2
The second sort key.

Return Value

Value | Condition
0 | The two sort keys are equal.
Less than 0 | sortkey1 is less thansortkey2.
Greater than 0 | sortkey1 is greater thansortkey2.

Remarks

[To be supplied.]

See Also

SortKey Class | SortKey Members | System.Globalization Namespace


SortKey.Equals

Checks whether the object refers to the same sort key as the current instance.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal value As Object _
) As Boolean
[C#]
public override bool Equals(
   object value
);
[C++]
public: override bool Equals(
   Object* value
);
[JScript]
public override function Equals(
   value : Object
) : Boolean;

Parameters

value
The object to be compared to the sort key of the current instance.

Return Value

true if object refers to the same sort key as the current instance; otherwise, false.

Remarks

This method overrides Object.Equals.

See Also

SortKey Class | SortKey Members | System.Globalization Namespace


SortKey.GetHashCode

Returns the hash code for the current instance of the sort key.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

The hash code for the current SortKey instance. The hash code is guaranteed to be the same for sort key A and B where A.Equals(B) is true.

Remarks

This method overrides Object.GetHashCode.

See Also

SortKey Class | SortKey Members | System.Globalization Namespace


SortKey.GetKeyData

Obtains the byte array representing the sort key of the current instance.

[Visual Basic]
Overridable Public Function GetKeyData() As Byte ()
[C#]
public virtual byte[] GetKeyData();
[C++]
public: virtual unsigned char* GetKeyData() [];
[JScript]
public function GetKeyData() : Byte[];

Return Value

A byte array representing the current instance of the sort key.

See Also

SortKey Class | SortKey Members | System.Globalization Namespace


SortKey.GetOriginalString

Obtains the original string used to create the sort key of the current instance.

[Visual Basic]
Overridable Public Function GetOriginalString() As String
[C#]
public virtual string GetOriginalString();
[C++]
public: virtual String* GetOriginalString();
[JScript]
public function GetOriginalString() : String;

Return Value

The original string used to create the current instance of sort key.

See Also

SortKey Class | SortKey Members | System.Globalization Namespace


SortKey.ToString

Obtains a string describing the sort key.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

A String representing the current SortKey instance.

Remarks

This method overrides Object.ToString.

See Also

SortKey Class | SortKey Members | System.Globalization Namespace


StringInfo Class

[To be supplied.]

Object
StringInfo

[Visual Basic]
Public Class StringInfo
[C#]
public class StringInfo
[C++]
public __gc class StringInfo
[JScript]
public class StringInfo

Remarks

[To be supplied.]

Requirements

Namespace: System.Globalization

Assembly: mscorlib.dll

See Also

StringInfo Members | System.Globalization Namespace


StringInfo Members

Public:

Constructor

StringInfo Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNextTextElement | Overloaded. [To be supplied.]
GetTextElementEnumerator | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
ParseCombiningCharacters | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StringInfo Class | System.Globalization Namespace


StringInfo Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public StringInfo();
[C++]
public: StringInfo();
[JScript]
public function StringInfo();

See Also

StringInfo Class | StringInfo Members | System.Globalization Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StringInfo Methods

The methods of the StringInfo class are listed below. For a complete list of StringInfo class members, see the StringInfo Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNextTextElement | Overloaded. [To be supplied.]
GetTextElementEnumerator | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
ParseCombiningCharacters | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StringInfo Class | System.Globalization Namespace


StringInfo.GetNextTextElement

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Shared Function GetNextTextElement(String) As String
[C#] public static string GetNextTextElement(String);
[C++] public: static String* GetNextTextElement(String*);
[JScript] public static function GetNextTextElement(String) : String;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function GetNextTextElement(String, Integer) As String
[C#] public static string GetNextTextElement(String, int);
[C++] public: static String* GetNextTextElement(String*, int);
[JScript] public static function GetNextTextElement(String, int) : String;

See Also

StringInfo Class | StringInfo Members | System.Globalization Namespace


StringInfo.GetNextTextElement (String)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function GetNextTextElement( _
   ByVal str As String _
) As String
[C#]
public static string GetNextTextElement(
   string str
);
[C++]
public: static String* GetNextTextElement(
   String* str
);
[JScript]
public static function GetNextTextElement(
   str : String
) : String;

Parameters

str
[To be supplied.]

See Also

StringInfo Class | StringInfo Members | System.Globalization Namespace | StringInfo.GetNextTextElement Overload List


StringInfo.GetNextTextElement (String, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function GetNextTextElement( _
   ByVal str As String, _
   ByVal index As Integer _
) As String
[C#]
public static string GetNextTextElement(
   string str,
   int index
);
[C++]
public: static String* GetNextTextElement(
   String* str,
   int index
);
[JScript]
public static function GetNextTextElement(
   str : String,
   index : int
) : String;

Parameters

str
[To be supplied.]
index
[To be supplied.]

See Also

StringInfo Class | StringInfo Members | System.Globalization Namespace | StringInfo.GetNextTextElement Overload List


StringInfo.GetTextElementEnumerator

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Shared Function GetTextElementEnumerator(String) As TextElementEnumerator
[C#] public static TextElementEnumerator GetTextElementEnumerator(String);
[C++] public: static TextElementEnumerator* GetTextElementEnumerator(String*);
[JScript] public static function GetTextElementEnumerator(String) : TextElementEnumerator;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function GetTextElementEnumerator(String, Integer) As TextElementEnumerator
[C#] public static TextElementEnumerator GetTextElementEnumerator(String, int);
[C++] public: static TextElementEnumerator* GetTextElementEnumerator(String*, int);
[JScript] public static function GetTextElementEnumerator(String, int) : TextElementEnumerator;

See Also

StringInfo Class | StringInfo Members | System.Globalization Namespace


StringInfo.GetTextElementEnumerator (String)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function GetTextElementEnumerator( _
   ByVal str As String _
) As TextElementEnumerator
[C#]
public static TextElementEnumerator GetTextElementEnumerator(
   string str
);
[C++]
public: static TextElementEnumerator* GetTextElementEnumerator(
   String* str
);
[JScript]
public static function GetTextElementEnumerator(
   str : String
) : TextElementEnumerator;

Parameters

str
[To be supplied.]

See Also

StringInfo Class | StringInfo Members | System.Globalization Namespace | StringInfo.GetTextElementEnumerator Overload List


StringInfo.GetTextElementEnumerator (String, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function GetTextElementEnumerator( _
   ByVal str As String, _
   ByVal index As Integer _
) As TextElementEnumerator
[C#]
public static TextElementEnumerator GetTextElementEnumerator(
   string str,
   int index
);
[C++]
public: static TextElementEnumerator* GetTextElementEnumerator(
   String* str,
   int index
);
[JScript]
public static function GetTextElementEnumerator(
   str : String,
   index : int
) : TextElementEnumerator;

Parameters

str
[To be supplied.]
index
[To be supplied.]

See Also

StringInfo Class | StringInfo Members | System.Globalization Namespace | StringInfo.GetTextElementEnumerator Overload List


StringInfo.ParseCombiningCharacters

[To be supplied.]

[Visual Basic]
Public Shared Function ParseCombiningCharacters( _
   ByVal str As String _
) As Integer ()
[C#]
public static int[] ParseCombiningCharacters(
   string str
);
[C++]
public: static int* ParseCombiningCharacters(
   String* str
) [];
[JScript]
public static function ParseCombiningCharacters(
   str : String
) : int[];

Parameters

str
[To be supplied.]

See Also

StringInfo Class | StringInfo Members | System.Globalization Namespace


TextElementEnumerator Class

[To be supplied.]

Object
TextElementEnumerator

[Visual Basic]
Public Class TextElementEnumerator
   Implements IEnumerator
[C#]
public class TextElementEnumerator : IEnumerator
[C++]
public __gc class TextElementEnumerator : public IEnumerator
[JScript]
public class TextElementEnumerator implements IEnumerator

Remarks

[To be supplied.]

Requirements

Namespace: System.Globalization

Assembly: mscorlib.dll

See Also

TextElementEnumerator Members | System.Globalization Namespace


TextElementEnumerator Members

Public:

Properties

Current | [To be supplied.]
ElementIndex | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetTextElement | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
MoveNext | [To be supplied.]
Reset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TextElementEnumerator Class | System.Globalization Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TextElementEnumerator Properties

The properties of the TextElementEnumerator class are listed below. For a complete list of TextElementEnumerator class members, see the TextElementEnumerator Members topic.

Public:

Current | [To be supplied.]
ElementIndex | [To be supplied.]

See Also

TextElementEnumerator Class | System.Globalization Namespace


TextElementEnumerator.Current

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Current As Object
[C#]
public object Current {virtual get;}
[C++]
public: __property virtual Object* get_Current();
[JScript]
public function get Current() : Object;

See Also

TextElementEnumerator Class | TextElementEnumerator Members | System.Globalization Namespace


TextElementEnumerator.ElementIndex

[To be supplied.]

[Visual Basic]
Public ReadOnly Property ElementIndex As Integer
[C#]
public int ElementIndex {get;}
[C++]
public: __property int get_ElementIndex();
[JScript]
public function get ElementIndex() : int;

See Also

TextElementEnumerator Class | TextElementEnumerator Members | System.Globalization Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TextElementEnumerator Methods

The methods of the TextElementEnumerator class are listed below. For a complete list of TextElementEnumerator class members, see the TextElementEnumerator Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetTextElement | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
MoveNext | [To be supplied.]
Reset | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TextElementEnumerator Class | System.Globalization Namespace


TextElementEnumerator.GetTextElement

[To be supplied.]

[Visual Basic]
Public Function GetTextElement() As String
[C#]
public string GetTextElement();
[C++]
public: String* GetTextElement();
[JScript]
public function GetTextElement() : String;

See Also

TextElementEnumerator Class | TextElementEnumerator Members | System.Globalization Namespace


TextElementEnumerator.MoveNext

[To be supplied.]

[Visual Basic]
Overridable Public Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;

See Also

TextElementEnumerator Class | TextElementEnumerator Members | System.Globalization Namespace


TextElementEnumerator.Reset

[To be supplied.]

[Visual Basic]
Overridable Public Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();

See Also

TextElementEnumerator Class | TextElementEnumerator Members | System.Globalization Namespace


TextInfo Class

[To be supplied.]

Object
TextInfo

[Visual Basic]
Public Class TextInfo
[C#]
public class TextInfo
[C++]
public __gc class TextInfo
[JScript]
public class TextInfo

Remarks

[To be supplied.]

Requirements

Namespace: System.Globalization

Assembly: mscorlib.dll

See Also

TextInfo Members | System.Globalization Namespace


TextInfo Members

Public:

Properties

ANSICodePage | Represents the ANSI code page.
EBCDICCodePage | [To be supplied.]
ListSeparator | Returns the string used to separate items in a list.
MacCodePage | Represents the Macintosh code page.
OEMCodePage | Represents the OEM code page.

Methods

Equals | Determines whether an object refers to the same TextInfo as the current instance.
GetHashCode | Returns the hash code for the Locale.
GetType (inherited from Object) | Gets the Type of the Object.
ToLower | Overloaded. Returns the mapping of the specified character or string to lower case.
ToString | Returns a string describing the current TextInfo.
ToTitleCase | [To be supplied.]
ToUpper | Overloaded. Returns the mapping of the specified character or string to upper case.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TextInfo Class | System.Globalization Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TextInfo Properties

The properties of the TextInfo class are listed below. For a complete list of TextInfo class members, see the TextInfo Members topic.

Public:

ANSICodePage | Represents the ANSI code page.
EBCDICCodePage | [To be supplied.]
ListSeparator | Returns the string used to separate items in a list.
MacCodePage | Represents the Macintosh code page.
OEMCodePage | Represents the OEM code page.

See Also

TextInfo Class | System.Globalization Namespace


TextInfo.ANSICodePage

Represents the ANSI code page.

[Visual Basic]
Overridable Public ReadOnly Property ANSICodePage As Integer
[C#]
public int ANSICodePage {virtual get;}
[C++]
public: __property virtual int get_ANSICodePage();
[JScript]
public function get ANSICodePage() : int;

See Also

TextInfo Class | TextInfo Members | System.Globalization Namespace


TextInfo.EBCDICCodePage

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property EBCDICCodePage As Integer
[C#]
public int EBCDICCodePage {virtual get;}
[C++]
public: __property virtual int get_EBCDICCodePage();
[JScript]
public function get EBCDICCodePage() : int;

See Also

TextInfo Class | TextInfo Members | System.Globalization Namespace


TextInfo.ListSeparator

Returns the string used to separate items in a list.

[Visual Basic]
Overridable Public ReadOnly Property ListSeparator As String
[C#]
public string ListSeparator {virtual get;}
[C++]
public: __property virtual String* get_ListSeparator();
[JScript]
public function get ListSeparator() : String;

Property Value

Returns the string used to separate items in a list.

Remarks

The invariant default is ",".

See Also

TextInfo Class | TextInfo Members | System.Globalization Namespace


TextInfo.MacCodePage

Represents the Macintosh code page.

[Visual Basic]
Overridable Public ReadOnly Property MacCodePage As Integer
[C#]
public int MacCodePage {virtual get;}
[C++]
public: __property virtual int get_MacCodePage();
[JScript]
public function get MacCodePage() : int;

See Also

TextInfo Class | TextInfo Members | System.Globalization Namespace


TextInfo.OEMCodePage

Represents the OEM code page.

[Visual Basic]
Overridable Public ReadOnly Property OEMCodePage As Integer
[C#]
public int OEMCodePage {virtual get;}
[C++]
public: __property virtual int get_OEMCodePage();
[JScript]
public function get OEMCodePage() : int;

See Also

TextInfo Class | TextInfo Members | System.Globalization Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TextInfo Methods

The methods of the TextInfo class are listed below. For a complete list of TextInfo class members, see the TextInfo Members topic.

Public:

Equals | Determines whether an object refers to the same TextInfo as the current instance.
GetHashCode | Returns the hash code for the Locale.
GetType (inherited from Object) | Gets the Type of the Object.
ToLower | Overloaded. Returns the mapping of the specified character or string to lower case.
ToString | Returns a string describing the current TextInfo.
ToTitleCase | [To be supplied.]
ToUpper | Overloaded. Returns the mapping of the specified character or string to upper case.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TextInfo Class | System.Globalization Namespace


TextInfo.Equals

Determines whether an object refers to the same TextInfo as the current instance.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The object to be compared to the current instance.

Return Value

Value | Meaning
True | object has the same Locale as the current instance.
False | object does not have the same Locale as the current instance.

Remarks

This method overrides Object.Equals.

See Also

TextInfo Class | TextInfo Members | System.Globalization Namespace


TextInfo.GetHashCode

Returns the hash code for the Locale.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

Returns the hash code for the Locale. The hash code is guaranteed to be the same for Locale A and B where A.Equals(B) is true.

Remarks

This method overrides Object.GetHashCode.

See Also

TextInfo Class | TextInfo Members | System.Globalization Namespace


TextInfo.ToLower

Returns the mapping of the specified character or string to lower case.

Overload List

Returns the mapping of the specified string to lower case.

[Visual Basic] Overloads Overridable Public Function ToLower(String) As String
[C#] public virtual string ToLower(String);
[C++] public: virtual String* ToLower(String*);
[JScript] public function ToLower(String) : String;

Returns the mapping of the specified character to lower case.

[Visual Basic] Overloads Overridable Public Function ToLower(Char) As Char
[C#] public virtual char ToLower(char);
[C++] public: virtual __wchar_t ToLower(__wchar_t);
[JScript] public function ToLower(Char) : Char;

See Also

TextInfo Class | TextInfo Members | System.Globalization Namespace


TextInfo.ToLower (String)

Returns the mapping of the specified string to lower case.

[Visual Basic]
Overloads Overridable Public Function ToLower( _
   ByVal str As String _
) As String
[C#]
public virtual string ToLower(
   string str
);
[C++]
public: virtual String* ToLower(
   String* str
);
[JScript]
public function ToLower(
   str : String
) : String;

Parameters

str
The string to map to lower case.

Return Value

Returns the mapping of the specified string to lower case.

Remarks

Note that the returned string may differ in length from the input string.

See Also

TextInfo Class | TextInfo Members | System.Globalization Namespace | TextInfo.ToLower Overload List


TextInfo.ToLower (Char)

Returns the mapping of the specified character to lower case.

[Visual Basic]
Overloads Overridable Public Function ToLower( _
   ByVal c As Char _
) As Char
[C#]
public virtual char ToLower(
   char c
);
[C++]
public: virtual __wchar_t ToLower(
   __wchar_t c
);
[JScript]
public function ToLower(
   c : Char
) : Char;

Parameters

c
The character to map to lower case.

Return Value

Returns the mapping of the specified character to lower case.

Remarks

[To be supplied.]

See Also

TextInfo Class | TextInfo Members | System.Globalization Namespace | TextInfo.ToLower Overload List


TextInfo.ToString

Returns a string describing the current TextInfo.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

Returns a String describing this TextInfo.

Remarks

This method overrides Object.ToString.

See Also

TextInfo Class | TextInfo Members | System.Globalization Namespace


TextInfo.ToTitleCase

[To be supplied.]

[Visual Basic]
Public Function ToTitleCase( _
   ByVal str As String _
) As String
[C#]
public string ToTitleCase(
   string str
);
[C++]
public: String* ToTitleCase(
   String* str
);
[JScript]
public function ToTitleCase(
   str : String
) : String;

Parameters

str
[To be supplied.]

See Also

TextInfo Class | TextInfo Members | System.Globalization Namespace


TextInfo.ToUpper

Returns the mapping of the specified character or string to upper case.

Overload List

Returns the mapping of the specified string to upper case.

[Visual Basic] Overloads Overridable Public Function ToUpper(String) As String
[C#] public virtual string ToUpper(String);
[C++] public: virtual String* ToUpper(String*);
[JScript] public function ToUpper(String) : String;

Returns the mapping of the specified character to upper case.

[Visual Basic] Overloads Overridable Public Function ToUpper(Char) As Char
[C#] public virtual char ToUpper(char);
[C++] public: virtual __wchar_t ToUpper(__wchar_t);
[JScript] public function ToUpper(Char) : Char;

See Also

TextInfo Class | TextInfo Members | System.Globalization Namespace


TextInfo.ToUpper (String)

Returns the mapping of the specified string to upper case.

[Visual Basic]
Overloads Overridable Public Function ToUpper( _
   ByVal str As String _
) As String
[C#]
public virtual string ToUpper(
   string str
);
[C++]
public: virtual String* ToUpper(
   String* str
);
[JScript]
public function ToUpper(
   str : String
) : String;

Parameters

str
The string to map to upper case.

Return Value

Returns the mapping of the specified string to upper case.

Remarks

Certain locales have different casing semantics from the file systems in Win32.

Note that the returned string may differ in length from the input string.

See Also

TextInfo Class | TextInfo Members | System.Globalization Namespace | TextInfo.ToUpper Overload List


TextInfo.ToUpper (Char)

Returns the mapping of the specified character to upper case.

[Visual Basic]
Overloads Overridable Public Function ToUpper( _
   ByVal c As Char _
) As Char
[C#]
public virtual char ToUpper(
   char c
);
[C++]
public: virtual __wchar_t ToUpper(
   __wchar_t c
);
[JScript]
public function ToUpper(
   c : Char
) : Char;

Parameters

c
The character to map to upper case.

Return Value

Returns the mapping of the specified character to upper case.

Remarks

Certain locales have different casing semantics from the file systems in Win32. The linguistic flag controls whether the conversion is done using the file system rules or the linguistic rules.

See Also

TextInfo Class | TextInfo Members | System.Globalization Namespace | TextInfo.ToUpper Overload List


ThaiBuddhistCalendar Class

[To be supplied.]

Object
Calendar
GregorianCalendar
KoreanCalendar
ThaiBuddhistCalendar

[Visual Basic]
Public Class ThaiBuddhistCalendar
   Inherits KoreanCalendar
[C#]
public class ThaiBuddhistCalendar : KoreanCalendar
[C++]
public __gc class ThaiBuddhistCalendar : public KoreanCalendar
[JScript]
public class ThaiBuddhistCalendar extends KoreanCalendar

Remarks

[To be supplied.]

Requirements

Namespace: System.Globalization

Assembly: mscorlib.dll

See Also

ThaiBuddhistCalendar Members | System.Globalization Namespace


ThaiBuddhistCalendar Members

Public:

Constructor

ThaiBuddhistCalendar Constructor [To be supplied.]

Properties

CalendarType (inherited from GregorianCalendar) | [To be supplied.]
Eras (inherited from KoreanCalendar) | [To be supplied.]
TwoDigitYearMax (inherited from GregorianCalendar) | Returns the date and time converted to a DateTime value. This value is the upper boundary of a 100-year range that allows a two-digit year to be properly translated to a four-digit year.

Methods

AddDays (inherited from Calendar) | Returns the DateTime object resulting from adding a fractional number of days to the specified DateTime.
AddHours (inherited from Calendar) | Returns the DateTime resulting from adding a fractional number of hours to the specified DateTime.
AddMilliseconds (inherited from Calendar) | Returns the DateTime resulting from adding the specified number of milliseconds to the specified DateTime.
AddMinutes (inherited from Calendar) | Returns the DateTime resulting from adding a fractional number of minutes to the specified DateTime.
AddMonths (inherited from GregorianCalendar) | Returns the DateTime resulting from adding the given number of months to the specified DateTime.
AddSeconds (inherited from Calendar) | Returns the DateTime resulting from adding a number of seconds to the specified DateTime.
AddWeeks (inherited from GregorianCalendar) | Returns the DateTime resulting from adding a number of weeks to the specified DateTime.
AddYears (inherited from GregorianCalendar) | Returns the DateTime resulting from adding the given number of years to the specified DateTime.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDayOfMonth (inherited from GregorianCalendar) | Returns the day-of-month part of the given DateTime.
GetDayOfWeek (inherited from GregorianCalendar) | Returns the day-of-week part of the specified DateTime.
GetDayOfYear (inherited from GregorianCalendar) | Returns the day-of-year part of the specified DateTime.
GetDaysInMonth (inherited from KoreanCalendar) | Overloaded. [To be supplied.]
GetDaysInYear (inherited from KoreanCalendar) | Overloaded. [To be supplied.]
GetEra (inherited from KoreanCalendar) | Overloaded. [To be supplied.]
GetEraName (inherited from KoreanCalendar) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHour (inherited from Calendar) | Returns the hour part of the specified DateTime.
GetMilliseconds (inherited from Calendar) | Returns the millisecond part of the specified DateTime.
GetMinute (inherited from Calendar) | Returns the minute part of the specified DateTime.
GetMonth (inherited from GregorianCalendar) | Returns the month part of the specified DateTime.
GetMonthsInYear (inherited from KoreanCalendar) | Overloaded. [To be supplied.]
GetSecond (inherited from Calendar) | Returns the second [RB26] part of the specified DateTime.
GetType (inherited from Object) | Gets the Type of the Object.
GetWeekOfYear (inherited from GregorianCalendar) | Returns the week of year for the given Datetime.
GetYear (inherited from KoreanCalendar) | [To be supplied.]
IsLeapDay (inherited from Calendar) | Overloaded. [To be supplied.]
IsLeapMonth (inherited from Calendar) | Overloaded. [To be supplied.]
IsLeapYear (inherited from KoreanCalendar) | Overloaded. [To be supplied.]
ToDateTime (inherited from KoreanCalendar) | Overloaded. [To be supplied.]
ToFourDigitYear (inherited from Calendar) | Converts the specified year to the appropriate century by using the TwoDigitYearMax property.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

ThaiBuddhistEra [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ThaiBuddhistCalendar Class | System.Globalization Namespace


ThaiBuddhistCalendar Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ThaiBuddhistCalendar();
[C++]
public: ThaiBuddhistCalendar();
[JScript]
public function ThaiBuddhistCalendar();

See Also

ThaiBuddhistCalendar Class | ThaiBuddhistCalendar Members | System.Globalization Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ThaiBuddhistCalendar Fields

The fields of the ThaiBuddhistCalendar class are listed below. For a complete list of ThaiBuddhistCalendar class members, see the ThaiBuddhistCalendar Members topic.

Public:

ThaiBuddhistEra [To be supplied.]

See Also

ThaiBuddhistCalendar Class | System.Globalization Namespace


ThaiBuddhistCalendar.ThaiBuddhistEra

[To be supplied.]

[Visual Basic]
Public Const ThaiBuddhistEra As Integer
[C#]
public const int ThaiBuddhistEra;
[C++]
public: const int ThaiBuddhistEra;
[JScript]
public var ThaiBuddhistEra : int;

See Also

ThaiBuddhistCalendar Class | ThaiBuddhistCalendar Members | System.Globalization Namespace


UnicodeCategory Enumeration

[To be supplied.]

[Visual Basic]
Public Enum UnicodeCategory
[C#]
public enum UnicodeCategory
[C++]
public enum UnicodeCategory

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
ClosePunctuation | [To be supplied.]
ConnectorPunctuation | [To be supplied.]
Control | [To be supplied.]
CurrencySymbol | [To be supplied.]
DashPunctuation | [To be supplied.]
DecimalDigitNumber | [To be supplied.]
EnclosingMark | [To be supplied.]
FinalQuotePunctuation | [To be supplied.]
Format | [To be supplied.]
InitialQuotePunctuation | [To be supplied.]
LetterNumber | [To be supplied.]
LineSeparator | [To be supplied.]
LowercaseLetter | [To be supplied.]
MathSymbol | [To be supplied.]
ModifierLetter | [To be supplied.]
ModifierSymbol | [To be supplied.]
NonSpacingMark | [To be supplied.]
OpenPunctuation | [To be supplied.]
OtherLetter | [To be supplied.]
OtherNotAssigned | [To be supplied.]
OtherNumber | [To be supplied.]
OtherPunctuation | [To be supplied.]
OtherSymbol | [To be supplied.]
ParagraphSeparator | [To be supplied.]
PrivateUse | [To be supplied.]
SpaceSeparator | [To be supplied.]
SpacingCombiningMark | [To be supplied.]
Surrogate | [To be supplied.]
TitlecaseLetter | [To be supplied.]
UppercaseLetter | [To be supplied.]

Requirements

Namespace: System.Globalization

Assembly: mscorlib.dll

See Also

System.Globalization Namespace


System.IO

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.IO Namespace

Classes

Class | Description
BinaryReader | Reads strings and primitive data types.
BinaryWriter | Writes primitives types in binary from a Stream and supports writing Strings in a particular encoding.
BufferedStream | Represents a buffered stream object.
Directory | Exposes routines for creating, moving, and enumerating through directories and subdirectories.
DirectoryNotFoundException | Returns an exception when trying to access a directory that doesn't exist on disk.
EndOfStreamException | Returns an exception when reading is attempted past the end of a stream.
File | Aids in the creation of FileStream objects and provides routines for the creation, copying, deletion, moving, and opening of files.
FileNotFoundException | Represents a failed attempt to access a file that does not exist on disk.
FileStream | Exposes a Stream around a file, supporting both synchronous and asynchronous methods.
FileSystemEntry | Provides the base class for both File and Directory objects. This class is abstract.
FileSystemEventArgs | Provides data for the directory events: TBD, System.IO.FileSystemEventArgs.Deleted.
FileSystemWatcher | Listens to the system directory change notifications and raises events when a directory or file within a directory changes.
InternalBufferOverflowException | Specifies the exception for an internal buffer overflow.
IOException | Represents an occurrence of an I/O error.
MemoryStream | Provides a way to create streams that have memory as a backing store instead of a disk or a network connection. The MemoryStream class creates a stream out of an array of bytes.
PathTooLongException | Represents an exception that is thrown when a path name or filename is too long.
RenamedEventArgs | Provides data for the System.IO.FileSystemWatcher.Renamed event.
Stream | Provides a way to write and read bytes to and from a backing store. This class is abstract.
StreamReader | Implements a TextReader that reads characters from a byte stream in a particular encoding.
StreamWriter | Implements a TextWriter for writing characters to a stream.
StringReader | Implements a TextReader that reads from a string.
StringWriter | Writes characters to a string.
TextReader | Represents a reader that can read a sequential stream of characters. This class is abstract.
TextWriter | Represents a writer that can write a sequential stream of characters. This class is abstract.

Structures

Structure | Description
WaitForChangedResult | Waits for a change in the specified path.

Delegates

Delegate | Description
FileSystemEventHandler | Represents the method that will handle the System.IO.FileSystemWatcher.Created, or System.IO.FileSystemWatcher.Deleted event of a FileSystemWatcher class.
RenamedEventHandler | Represents the method that will handle the System.IO.FileSystemWatcher.Renamed event of a FileSystemWatcher class.

Enumerations

Enumeration | Description
ChangedFilters | Specifies the changes to watch for in a file or folder.
FileAccess | Allows read, write, or read/write access to a file.
FileMode | Specifies how the operating system should open a file. These values, which are used by the FileStream constructors, control whether a file is overwritten or opened, or some combination thereof.
FileShare | Contains constants for controlling the kind of access other FileStreams can have to the same file.
FileSystemAttributes | Provides attributes for files and directories. Not all attributes are applicable to both files and directories. These constants correspond to those in WinNT.h.
SeekOrigin | Provides the fields that represent seek reference points.
WatcherChangeTypes | Changes that may occur to a file or directory.
WatcherTarget | Specifies whether to monitor a file, directory, or both.


BinaryReader Class

Reads strings and primitive data types.

Object
BinaryReader

[Visual Basic]
Public Class BinaryReader
[C#]
public class BinaryReader
[C++]
public __gc class BinaryReader
[JScript]
public class BinaryReader

Remarks

[To be supplied.]

Requirements

Namespace: System.IO

Assembly: mscorlib.dll

See Also

BinaryReader Members | System.IO Namespace


BinaryReader Members

Public:

Constructor

BinaryReader Constructor Overloaded. Creates a new instance of the BinaryReader class.

Properties

BaseStream Exposes the underlying stream.

Methods

Close | Closes the current reader and releases the underlying stream.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
PeekChar | Returns the next available character without actually reading it from the input stream, and does not advance the byte or character position within the stream.
Read | Overloaded. Reads the next character from the underlying stream and advances the current position of the stream.
ReadBoolean | Reads a Boolean from the current stream. The current position of the stream is advanced by one byte.
ReadByte | Reads the next byte from the current stream and advances the current position of the stream by 1 byte.
ReadBytes | Reads count bytes from the current stream into a byte array, and advances the current position by count bytes.
ReadChar | Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and perhaps the particular character being read from the stream.
ReadChars | Reads count characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and perhaps the particular character being read from the stream.
ReadDouble | Reads a Double (an 8-byte floating point value) from the current stream and advances the current position of the stream by 8 bytes.
ReadInt16 | Reads a 2-byte signed integer from the current stream and advances the current position of the stream by 2 bytes.
ReadInt32 | Reads a 4-byte signed integer from the current stream and advances the current position of the stream by 4 bytes.
ReadInt64 | Reads an 8-byte signed integer from the current stream and advances the current position of the stream by 8 bytes.
ReadSByte | Reads a signed byte from this stream and advances the current position of the stream by one byte.
ReadSingle | Reads a Single (a 4-byte floating point value) from the current stream and advances the current position of the stream by 4 bytes.
ReadString | Reads a String from the current stream. The String is prefixed with the length, encoded as an integer 7 bits at a time.
ReadUInt16 | Reads a two-byte unsigned integer from the current stream and advances the position of the stream by two bytes. This uses little endian encoding.
ReadUInt32 | Reads a four-byte unsigned integer from the current stream and advances the position of the stream by four bytes.
ReadUInt64 | Reads an eight-byte unsigned integer from the current stream and advances the position of the stream by eight bytes.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

FillBuffer | Fills the buffer with the specified number of bytes read from the stream.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BinaryReader Class | System.IO Namespace


BinaryReader Constructor

Creates a new instance of the BinaryReader class.

Overload List

Creates a new instance of the BinaryReader class based on the supplied stream and using UTF8Encoding.

[Visual Basic] Overloads Public Sub New(Stream)
[C#] public BinaryReader(Stream);
[C++] public: BinaryReader(Stream*);
[JScript] public function BinaryReader(Stream);

Creates a new instance of the BinaryReader class based on the supplied stream and a particular character encoding.

[Visual Basic] Overloads Public Sub New(Stream, Encoding)
[C#] public BinaryReader(Stream, Encoding);
[C++] public: BinaryReader(Stream*, Encoding);
[JScript] public function BinaryReader(Stream, Encoding);

See Also

BinaryReader Class | BinaryReader Members | System.IO Namespace


BinaryReader Constructor (Stream)

Creates a new instance of the BinaryReader class based on the supplied stream and using UTF8Encoding.

[Visual Basic]
Overloads Public Sub New( _
   ByVal input As Stream _
)
[C#]
public BinaryReader(
   Stream input
);
[C++]
public: BinaryReader(
   Stream* input
);
[JScript]
public function BinaryReader(
   input : Stream
);

Parameters

input
A stream.

Exceptions

Exception Type | Condition
ArgumentException | The stream does not support reading.
ArgumentNullException | input is a null reference (in Visual Basic Nothing).

See Also

BinaryReader Class | BinaryReader Members | System.IO Namespace | BinaryReader Constructor Overload List


BinaryReader Constructor (Stream, Encoding)

Creates a new instance of the BinaryReader class based on the supplied stream and a particular character encoding.

[Visual Basic]
Overloads Public Sub New( _
   ByVal input As Stream, _
   ByVal encoding As Encoding _
)
[C#]
public BinaryReader(
   Stream input,
   Encoding encoding
);
[C++]
public: BinaryReader(
   Stream* input,
   Encoding* encoding
);
[JScript]
public function BinaryReader(
   input : Stream,
   encoding : Encoding
);

Parameters

input
[To be supplied.]
encoding
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentException | The stream does not support reading.
ArgumentNullException | input or encoding is a null reference (in Visual Basic Nothing).

See Also

BinaryReader Class | BinaryReader Members | System.IO Namespace | BinaryReader Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

BinaryReader Properties

The properties of the BinaryReader class are listed below. For a complete list of BinaryReader class members, see the BinaryReader Members topic.

Public:

BaseStream Exposes the underlying stream.

See Also

BinaryReader Class | System.IO Namespace


BinaryReader.BaseStream

Exposes the underlying stream.

[Visual Basic]
Overridable Public ReadOnly Property BaseStream As Stream
[C#]
public Stream BaseStream {virtual get;}
[C++]
public: __property virtual Stream* get_BaseStream();
[JScript]
public function get BaseStream() : Stream;

Property Value

The underlying stream.

Remarks

Using the underlying stream while reading can cause data loss and corruption. For example, the same bytes might be read more than once, bytes might be skipped, or character reading might become unpredictable.

See Also

BinaryReader Class | BinaryReader Members | System.IO Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

BinaryReader Methods

The methods of the BinaryReader class are listed below. For a complete list of BinaryReader class members, see the BinaryReader Members topic.

Public:

Close | Closes the current reader and releases the underlying stream.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
PeekChar | Returns the next available character without actually reading it from the input stream, and does not advance the byte or character position within the stream.
Read | Overloaded. Reads the next character from the underlying stream and advances the current position of the stream.
ReadBoolean | Reads a Boolean from the current stream. The current position of the stream is advanced by one byte.
ReadByte | Reads the next byte from the current stream and advances the current position of the stream by 1 byte.
ReadBytes | Reads count bytes from the current stream into a byte array, and advances the current position by count bytes.
ReadChar | Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and perhaps the particular character being read from the stream.
ReadChars | Reads count characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and perhaps the particular character being read from the stream.
ReadDouble | Reads a Double (an 8-byte floating point value) from the current stream and advances the current position of the stream by 8 bytes.
ReadInt16 | Reads a 2-byte signed integer from the current stream and advances the current position of the stream by 2 bytes.
ReadInt32 | Reads a 4-byte signed integer from the current stream and advances the current position of the stream by 4 bytes.
ReadInt64 | Reads an 8-byte signed integer from the current stream and advances the current position of the stream by 8 bytes.
ReadSByte | Reads a signed byte from this stream and advances the current position of the stream by one byte.
ReadSingle | Reads a Single (a 4-byte floating point value) from the current stream and advances the current position of the stream by 4 bytes.
ReadString | Reads a String from the current stream. The String is prefixed with the length, encoded as an integer 7 bits at a time.
ReadUInt16 | Reads a two-byte unsigned integer from the current stream and advances the position of the stream by two bytes. This uses little endian encoding.
ReadUInt32 | Reads a four-byte unsigned integer from the current stream and advances the position of the stream by four bytes.
ReadUInt64 | Reads an eight-byte unsigned integer from the current stream and advances the position of the stream by eight bytes.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

FillBuffer | Fills the buffer with the specified number of bytes read from the stream.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BinaryReader Class | System.IO Namespace


BinaryReader.Close

Closes the current reader and releases the underlying stream.

[Visual Basic]
Overridable Public Sub Close()
[C#]
public virtual void Close();
[C++]
public: virtual void Close();
[JScript]
public function Close();

See Also

BinaryReader Class | BinaryReader Members | System.IO Namespace


BinaryReader.FillBuffer

Fills the buffer with the specified number of bytes read from the stream.

[Visual Basic]
Overridable Protected Sub FillBuffer( _
   ByVal numBytes As Integer _
)
[C#]
protected virtual void FillBuffer(
   int numBytes
);
[C++]
protected: virtual void FillBuffer(
   int numBytes
);
[JScript]
protected function FillBuffer(
   numBytes : int
);

Parameters

numBytes
The number of bytes.

Exceptions

Exception Type | Condition
EndOfStreamException | The end of the stream is reached.
IOException | The stream is a null reference (in Visual Basic Nothing) or closed.

See Also

BinaryReader Class | BinaryReader Members | System.IO Namespace


BinaryReader.PeekChar

Returns the next available character without actually reading it from the input stream, and does not advance the byte or character position within the stream.

[Visual Basic]
Overridable Public Function PeekChar() As Integer
[C#]
public virtual int PeekChar();
[C++]
public: virtual int PeekChar();
[JScript]
public function PeekChar() : int;

Return Value

The next available character.

Exceptions

Exception Type | Condition
IOException | The stream is a null reference (in Visual Basic Nothing) or not open.

See Also

BinaryReader Class | BinaryReader Members | System.IO Namespace


BinaryReader.Read

Reads the next character from the underlying stream and advances the current position of the stream.

Overload List

Reads a block of bytes from the current stream into a byte array and advances the current position by count bytes.

[Visual Basic] Overloads Overridable Public Function Read(Byte(), Integer, Integer) As Integer
[C#] public virtual int Read(byte[], int, int);
[C++] public: virtual int Read(unsigned char*[], int, int);
[JScript] public function Read(Byte[], int, int) : int;

Reads the next character from the underlying stream and advances the current position of the stream in accordance with the Encoding used and perhaps the particular character being read from the stream.

[Visual Basic] Overloads Overridable Public Function Read() As Integer
[C#] public virtual int Read();
[C++] public: virtual int Read();
[JScript] public function Read() : int;

Reads a block of characters from the current stream into a character array and advances the current position in accordance with the Encoding used and perhaps the particular character being read from the stream.

[Visual Basic] Overloads Overridable Public Function Read(Char(), Integer, Integer) As Integer
[C#] public virtual int Read(char[], int, int);
[C++] public: virtual int Read(__wchar_t*[], int, int);
[JScript] public function Read(Char[], int, int) : int;

See Also

BinaryReader Class | BinaryReader Members | System.IO Namespace


BinaryReader.Read (Byte[], Int32, Int32)

Reads a block of bytes from the current stream into a byte array and advances the current position by count bytes.

[Visual Basic]
Overloads Overridable Public Function Read( _
   ByVal buffer() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
[C#]
public virtual int Read(
   byte[] buffer,
   int index,
   int count
);
[C++]
public: virtual int Read(
   unsigned char* buffer[],
   int index,
   int count
);
[JScript]
public function Read(
   buffer : Byte[],
   index : int,
   count : int
) : int;

Parameters

buffer
The buffer to read data into.
index
The starting position in the buffer at which to begin reading.
count
The number of characters to read.

Return Value

The number of characters read into buffer. This may be less than the number of bytes requested if that many bytes are not available, or it may be zero if the end of the stream is reached.

Exceptions

Exception Type | Condition
ArgumentException | The buffer length minus index is less than count.
ArgumentNullException | buffer is a null reference (in Visual Basic Nothing).
ArgumentOutOfRangeException | index or count is negative.
IOException | The stream is a null reference (Nothing) or closed.

See Also

BinaryReader Class | BinaryReader Members | System.IO Namespace | BinaryReader.Read Overload List


BinaryReader.Read ()

Reads the next character from the underlying stream and advances the current position of the stream in accordance with the Encoding used and perhaps the particular character being read from the stream.

[Visual Basic]
Overloads Overridable Public Function Read() As Integer
[C#]
public virtual int Read();
[C++]
public: virtual int Read();
[JScript]
public function Read() : int;

Return Value

The next character from the input stream, or-1 if no characters are currently available. This default constructor returns-1.

Exceptions

Exception Type | Condition
IOException | The stream is a null reference (in Visual Basic Nothing) or not open.

See Also

BinaryReader Class | BinaryReader Members | System.IO Namespace | BinaryReader.Read Overload List


BinaryReader.Read (Char[], Int32, Int32)

Reads a block of characters from the current stream into a character array and advances the current position in accordance with the Encoding used and perhaps the particular character being read from the stream.

[Visual Basic]
Overloads Overridable Public Function Read( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
[C#]
public virtual int Read(
   char[] buffer,
   int index,
   int count
);
[C++]
public: virtual int Read(
   __wchar_t* buffer[],
   int index,
   int count
);
[JScript]
public function Read(
   buffer : Char[],
   index : int,
   count : int
) : int;

Parameters

buffer
[To be supplied.]
index
[To be supplied.]
count
[To be supplied.]

Return Value

The total number of characters read into the buffer. This may be less than the number of characters requested if that many characters are not currently available, or it may be zero if the end of the stream is reached.

Exceptions

Exception Type | Condition
ArgumentException | The buffer length minus index is less than count.
ArgumentNullException | buffer is a null reference (in Visual Basic Nothing).
ArgumentOutOfRangeException | index or count is negative.
IOException | The stream is a null reference (Nothing) or closed.

See Also

BinaryReader Class | BinaryReader Members | System.IO Namespace | BinaryReader.Read Overload List


BinaryReader.ReadBoolean

Reads a Boolean from the current stream. The current position of the stream is advanced by one byte.

[Visual Basic]
Overridable Public Function ReadBoolean() As Boolean
[C#]
public virtual bool ReadBoolean();
[C++]
public: virtual bool ReadBoolean();
[JScript]
public function ReadBoolean() : Boolean;

Return Value

true if the byte is non-zero; otherwise false.

Exceptions

Exception Type | Condition
EndOfStreamException | The end of the stream has been reached.
IOException | An I/O error occurs.

See Also

BinaryReader Class | BinaryReader Members | System.IO Namespace


BinaryReader.ReadByte

Reads the next byte from the current stream and advances the current position of the stream by 1 byte.

[Visual Basic]
Overridable Public Function ReadByte() As Byte
[C#]
public virtual byte ReadByte();
[C++]
public: virtual unsigned char ReadByte();
[JScript]
public function ReadByte() : Byte;

Return Value

The next byte read from the current stream.

Exceptions

Exception Type | Condition
EndOfStreamException | The end of the stream has been reached.
IOException | An I/O error occurs.

See Also

BinaryReader Class | BinaryReader Members | System.IO Namespace


BinaryReader.ReadBytes

Reads count bytes from the current stream into a byte array, and advances the current position by count bytes.

[Visual Basic]
Overridable Public Function ReadBytes( _
   ByVal count As Integer _
) As Byte ()
[C#]
public virtual byte[] ReadBytes(
   int count
);
[C++]
public: virtual unsigned char* ReadBytes(
   int count
) [];
[JScript]
public function ReadBytes(
   count : int
) : Byte[];

Parameters

count
The number of bytes to read.

Return Value

A byte array containing data read from the underlying stream. This may be less than the number of bytes requested if the end of the stream is reached.

Exceptions

Exception Type | Condition
EndOfStreamException | The end of the stream has been reached.
IOException | An I/O error occurs.
ArgumentOutOfRangeException | count is negative.

See Also

BinaryReader Class | BinaryReader Members | System.IO Namespace


BinaryReader.ReadChar

Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and perhaps the particular character being read from the stream.

[Visual Basic]
Overridable Public Function ReadChar() As Char
[C#]
public virtual char ReadChar();
[C++]
public: virtual __wchar_t ReadChar();
[JScript]
public function ReadChar() : Char;

Return Value

A character read from the current stream.

Exceptions

Exception Type | Condition
EndOfStreamException | The end of the stream has been reached.
IOException | An I/O error occurs.

See Also

BinaryReader Class | BinaryReader Members | System.IO Namespace


BinaryReader.ReadChars

Reads count characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and perhaps the particular character being read from the stream.

[Visual Basic]
Overridable Public Function ReadChars( _
   ByVal count As Integer _
) As Char ()
[C#]
public virtual char[] ReadChars(
   int count
);
[C++]
public: virtual __wchar_t* ReadChars(
   int count
) [];
[JScript]
public function ReadChars(
   count : int
) : Char[];

Parameters

count
The number of characters to read.

Return Value

A character array containing data read from the underlying stream. This may be less than the number of characters requested if the end of the stream is reached.

Exceptions

Exception Type | Condition
EndOfStreamException | The end of the stream has been reached.
IOException | An I/O error occurs.
ArgumentOutOfRangeException | count is negative.

See Also

BinaryReader Class | BinaryReader Members | System.IO Namespace


BinaryReader.ReadDouble

Reads a Double (an 8-byte floating point value) from the current stream and advances the current position of the stream by 8 bytes.

[Visual Basic]
Overridable Public Function ReadDouble() As Double
[C#]
public virtual double ReadDouble();
[C++]
public: virtual double ReadDouble();
[JScript]
public function ReadDouble() : double;

Return Value

A Double read from the current stream.

Exceptions

Exception Type | Condition
EndOfStreamException | The end of the stream has been reached.
IOException | An I/O error occurs.

See Also

BinaryReader Class | BinaryReader Members | System.IO Namespace


BinaryReader.ReadInt16

Reads a 2-byte signed integer from the current stream and advances the current position of the stream by 2 bytes.

[Visual Basic]
Overridable Public Function ReadInt16() As Short
[C#]
public virtual short ReadInt16();
[C++]
public: virtual short ReadInt16();
[JScript]
public function ReadInt16() : Int16;

Return Value

A 2-byte signed integer read from the current stream.

Exceptions

Exception Type | Condition
EndOfStreamException | The end of the stream has been reached.
IOException | An I/O error occurs.

See Also

BinaryReader Class | BinaryReader Members | System.IO Namespace


BinaryReader.ReadInt32

Reads a 4-byte signed integer from the current stream and advances the current position of the stream by 4 bytes.

[Visual Basic]
Overridable Public Function ReadInt32() As Integer
[C#]
public virtual int ReadInt32();
[C++]
public: virtual int ReadInt32();
[JScript]
public function ReadInt32() : int;

Return Value

A 4-byte signed integer read from the current stream.

Exceptions

Exception Type | Condition
EndOfStreamException | The end of the stream has been reached.
IOException | An I/O error occurs.

See Also

BinaryReader Class | BinaryReader Members | System.IO Namespace


BinaryReader.ReadInt64

Reads an 8-byte signed integer from the current stream and advances the current position of the stream by 8 bytes.

[Visual Basic]
Overridable Public Function ReadInt64() As Long
[C#]
public virtual long ReadInt64();
[C++]
public: virtual __int64 ReadInt64();
[JScript]
public function ReadInt64() : long;

Return Value

An 8-byte signed integer read from the current stream.

Exceptions

Exception Type | Condition
EndOfStreamException | The end of the stream has been reached.
IOException | An I/O error occurs.

See Also

BinaryReader Class | BinaryReader Members | System.IO Namespace


BinaryReader.ReadSByte

Reads a signed byte from this stream and advances the current position of the stream by one byte.

[Visual Basic]
Overridable Public Function ReadSByte() As SByte
[C#]
public virtual sbyte ReadSByte();
[C++]
public: virtual char ReadSByte();
[JScript]
public function ReadSByte() : SByte;

Return Value

A signed byte read from the current stream.

Exceptions

Exception Type | Condition
EndOfStreamException | The end of the stream has been reached.
IOException | An I/O error occurs.

See Also

BinaryReader Class | BinaryReader Members | System.IO Namespace


BinaryReader.ReadSingle

Reads a Single (a 4-byte floating point value) from the current stream and advances the current position of the stream by 4 bytes.

[Visual Basic]
Overridable Public Function ReadSingle() As Single
[C#]
public virtual float ReadSingle();
[C++]
public: virtual float ReadSingle();
[JScript]
public function ReadSingle() : float;

Return Value

A Single read from the current stream.

Exceptions

Exception Type | Condition
EndOfStreamException | The end of the stream has been reached.
IOException | An I/O error occurs.

See Also

BinaryReader Class | BinaryReader Members | System.IO Namespace


BinaryReader.ReadString

Reads a String from the current stream. The String is prefixed with the length, encoded as an integer 7 bits at a time.

[Visual Basic]
Overridable Public Function ReadString() As String
[C#]
public virtual string ReadString();
[C++]
public: virtual String* ReadString();
[JScript]
public function ReadString() : String;

Return Value

A String.

Exceptions

Exception Type | Condition
EndOfStreamException | The end of the stream has been reached.
IOException | An I/O error occurs.

See Also

BinaryReader Class | BinaryReader Members | System.IO Namespace


BinaryReader.ReadUInt16

Reads a two-byte unsigned integer from the current stream and advances the position of the stream by two bytes. This uses little endian encoding.

[Visual Basic]
Overridable Public Function ReadUInt16() As UInt16
[C#]
public virtual ushort ReadUInt16();
[C++]
public: virtual unsigned short ReadUInt16();
[JScript]
public function ReadUInt16() : UInt16;

Return Value

A two-byte unsigned integer read from this stream.

Exceptions

Exception Type | Condition
EndOfStreamException | The end of the stream has been reached.
IOException | An I/O error occurs.

See Also

BinaryReader Class | BinaryReader Members | System.IO Namespace


BinaryReader.ReadUInt32

Reads a four-byte unsigned integer from the current stream and advances the position of the stream by four bytes.

[Visual Basic]
Overridable Public Function ReadUInt32() As UInt32
[C#]
public virtual uint ReadUInt32();
[C++]
public: virtual unsigned int ReadUInt32();
[JScript]
public function ReadUInt32() : UInt32;

Return Value

A four-byte unsigned integer read from this stream.

Exceptions

Exception Type | Condition
EndOfStreamException | The end of the stream has been reached.
IOException | An I/O error occurs.

See Also

BinaryReader Class | BinaryReader Members | System.IO Namespace


BinaryReader.ReadUInt64

Reads an eight-byte unsigned integer from the current stream and advances the position of the stream by eight bytes.

[Visual Basic]
Overridable Public Function ReadUInt64() As UInt64
[C#]
public virtual ulong ReadUInt64();
[C++]
public: virtual unsigned __int64 ReadUInt64();
[JScript]
public function ReadUInt64() : UInt64;

Return Value

An eight-byte unsigned integer read from this stream.

Exceptions

Exception Type | Condition
EndOfStreamException | The end of the stream has been reached.
IOException | An I/O error occurs.

See Also

BinaryReader Class | BinaryReader Members | System.IO Namespace


BinaryWriter Class

Writes primitives types in binary from a Stream and supports writing Strings in a particular encoding.

Object
BinaryWriter

[Visual Basic]
Public Class BinaryWriter
[C#]
public class BinaryWriter
[C++]
public __gc class BinaryWriter
[JScript]
public class BinaryWriter

Remarks

A subclass can override the methods of this class to give unique character encodings.

Requirements

Namespace: System.IO

Assembly: mscorlib.dll

See Also

BinaryWriter Members | System.IO Namespace


BinaryWriter Members

Public:

Constructor

BinaryWriter Constructor Overloaded. Creates a new instance of the BinaryWriter class that writes to a stream.

Properties

BaseStream Flushes all pending writes and returns the stream associated with the writer.

Methods

Close | Closes the current BinaryWriter and releases any system resources associated with it.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Flush | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Seek | Sets the position within the current stream.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Overloaded. Writes a value to the current stream.
WriteString | Writes a length-prefixed string to this stream in the BinaryWriter's current Encoding and advances the current position of the stream in accordance with the Encoding used and perhaps the particular characters being written to the stream.

Fields

Null Causes nothing to be stored when write methods are invoked on BinaryWriter.Null.

Protected:

Constructor

BinaryWriter Constructor Overloaded. Creates a new instance of the BinaryWriter class that writes to a stream.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

OutStream Holds the underlying stream.

See Also

BinaryWriter Class | System.IO Namespace


BinaryWriter Constructor

Creates a new instance of the BinaryWriter class that writes to a stream.

Overload List

Creates a new instance of the BinaryWriter class that writes to a stream.

[Visual Basic] Overloads Protected Sub New()
[C#] protected BinaryWriter();
[C++] protected: BinaryWriter();
[JScript] protected function BinaryWriter();

Creates a new instance of the BinaryWriter class based on the supplied stream and using that stream's encoding.

[Visual Basic] Overloads Public Sub New(Stream)
[C#] public BinaryWriter(Stream);
[C++] public: BinaryWriter(Stream*);
[JScript] public function BinaryWriter(Stream);

Creates a new instance of the BinaryWriter class based on the supplied stream and a particular character encoding.

[Visual Basic] Overloads Public Sub New(Stream, Encoding)
[C#] public BinaryWriter(Stream, Encoding);
[C++] public: BinaryWriter(Stream*, Encoding);
[JScript] public function BinaryWriter(Stream, Encoding);

See Also

BinaryWriter Class | BinaryWriter Members | System.IO Namespace


BinaryWriter Constructor ()

Creates a new instance of the BinaryWriter class that writes to a stream.

[Visual Basic]
Overloads Protected Sub New()
[C#]
protected BinaryWriter();
[C++]
protected: BinaryWriter();
[JScript]
protected function BinaryWriter();

See Also

BinaryWriter Class | BinaryWriter Members | System.IO Namespace | BinaryWriter Constructor Overload List


BinaryWriter Constructor (Stream)

Creates a new instance of the BinaryWriter class based on the supplied stream and using that stream's encoding.

[Visual Basic]
Overloads Public Sub New( _
   ByVal output As Stream _
)
[C#]
public BinaryWriter(
   Stream output
);
[C++]
public: BinaryWriter(
   Stream* output
);
[JScript]
public function BinaryWriter(
   output : Stream
);

Parameters

output
The output stream.

See Also

BinaryWriter Class | BinaryWriter Members | System.IO Namespace | BinaryWriter Constructor Overload List


BinaryWriter Constructor (Stream, Encoding)

Creates a new instance of the BinaryWriter class based on the supplied stream and a particular character encoding.

[Visual Basic]
Overloads Public Sub New( _
   ByVal output As Stream, _
   ByVal encoding As Encoding _
)
[C#]
public BinaryWriter(
   Stream output,
   Encoding encoding
);
[C++]
public: BinaryWriter(
   Stream* output,
   Encoding* encoding
);
[JScript]
public function BinaryWriter(
   output : Stream,
   encoding : Encoding
);

Parameters

output
The supplied stream.
encoding
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentException | The stream does not support writing.
ArgumentNullException | output or encoding is a null reference (in Visual Basic Nothing).

See Also

BinaryWriter Class | BinaryWriter Members | System.IO Namespace | BinaryWriter Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

BinaryWriter Properties

The properties of the BinaryWriter class are listed below. For a complete list of BinaryWriter class members, see the BinaryWriter Members topic.

Public:

BaseStream Flushes all pending writes and returns the stream associated with the writer.

See Also

BinaryWriter Class | System.IO Namespace


BinaryWriter.BaseStream

Flushes all pending writes and returns the stream associated with the writer.

[Visual Basic]
Overridable Public ReadOnly Property BaseStream As Stream
[C#]
public Stream BaseStream {virtual get;}
[C++]
public: __property virtual Stream* get_BaseStream();
[JScript]
public function get BaseStream() : Stream;

Property Value

The stream associated with the writer.

Remarks

All subclasses should override Flush to ensure that all buffered data is sent to the stream.

See Also

BinaryWriter Class | BinaryWriter Members | System.IO Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

BinaryWriter Methods

The methods of the BinaryWriter class are listed below. For a complete list of BinaryWriter class members, see the BinaryWriter Members topic.

Public:

Close | Closes the current BinaryWriter and releases any system resources associated with it.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Flush | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Seek | Sets the position within the current stream.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Overloaded. Writes a value to the current stream.
WriteString | Writes a length-prefixed string to this stream in the BinaryWriter's current Encoding and advances the current position of the stream in accordance with the Encoding used and perhaps the particular characters being written to the stream.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BinaryWriter Class | System.IO Namespace


BinaryWriter.Close

Closes the current BinaryWriter and releases any system resources associated with it.

[Visual Basic]
Public Sub Close()
[C#]
public void Close();
[C++]
public: void Close();
[JScript]
public function Close();

See Also

BinaryWriter Class | BinaryWriter Members | System.IO Namespace


BinaryWriter.Flush

Clears all buffers for the current writer and causes any buffered data to be written to the underlying device.

[Visual Basic]
Public Sub Flush()
[C#]
public void Flush();
[C++]
public: void Flush();
[JScript]
public function Flush();

See Also

BinaryWriter Class | BinaryWriter Members | System.IO Namespace


BinaryWriter.Seek

Sets the position within the current stream.

[Visual Basic]
Public Function Seek( _
   ByVal offset As Integer, _
   ByVal origin As SeekOrigin _
) As Long
[C#]
public long Seek(
   int offset,
   SeekOrigin origin
);
[C++]
public: __int64 Seek(
   int offset,
   SeekOrigin origin
);
[JScript]
public function Seek(
   offset : int,
   origin : SeekOrigin
) : long;

Parameters

offset
A byte offset relative to origin.
origin
[To be supplied.]

Return Value

The position with the current stream.

See Also

BinaryWriter Class | BinaryWriter Members | System.IO Namespace


BinaryWriter.Write

Writes a value to the current stream.

Overload List

Writes a four-byte signed integer to the current stream and advances the stream position by four bytes.

[Visual Basic] Overloads Public Sub Write(Integer)
[C#] public void Write(int);
[C++] public: void Write(int);
[JScript] public function Write(int);

Writes a four-byte unsigned integer to the current stream and advances the stream position by four bytes.

[Visual Basic] Overloads Public Sub Write(UInt32)
[C#] public void Write(uint);
[C++] public: void Write(unsigned int);
[JScript] public function Write(UInt32);

Writes a two-byte signed integer to the current stream and advances the stream position by two bytes.

[Visual Basic] Overloads Public Sub Write(Integer)
[C#] public void Write(short);
[C++] public: void Write(short);
[JScript] public function Write(Int16);

Writes a two-byte unsigned integer to the current stream and advances the stream position by two bytes.

[Visual Basic] Overloads Public Sub Write(UInt16)
[C#] public void Write(ushort);
[C++] public: void Write(unsigned short);
[JScript] public function Write(UInt16);

Writes a four-byte floating-point value to the current stream and advances the stream position by four bytes.

[Visual Basic] Overloads Public Sub Write(Single)
[C#] public void Write(float);
[C++] public: void Write(float);
[JScript] public function Write(float);

Writes a string to the text stream and advances the current position of the stream in accordance with the Encoding used and perhaps the particular characters being written to the stream.

[Visual Basic] Overloads Public Sub Write(String)
[C#] public void Write(String);
[C++] public: void Write(String*);
[JScript] public function Write(String);

Writes an eight-byte signed integer to the current stream and advances the stream position by eight bytes.

[Visual Basic] Overloads Public Sub Write(Long)
[C#] public void Write(long);
[C++] public: void Write(__int64);
[JScript] public function Write(long);

Writes a eight-byte unsigned integer to the current stream and advances the stream position by eight bytes.

[Visual Basic] Overloads Public Sub Write(UInt64)
[C#] public void Write(ulong);
[C++] public: void Write(unsigned __int64);
[JScript] public function Write(UInt64);

Writes a byte to the current stream and advances the stream position by one byte.

[Visual Basic] Overloads Public Sub Write(Byte)
[C#] public void Write(byte);
[C++] public: void Write(unsigned char);
[JScript] public function Write(Byte);

Writes a signed byte to the current stream and advances the stream position by one byte.

[Visual Basic] Overloads Public Sub Write(SByte)
[C#] public void Write(sbyte);
[C++] public: void Write(char);
[JScript] public function Write(SByte);

Writes a region of a byte array to the current stream.

[Visual Basic] Overloads Overridable Public Sub Write(Byte(), Integer, Integer)
[C#] public virtual void Write(byte[], int, int);
[C++] public: virtual void Write(unsigned char*[], int, int);
[JScript] public function Write(Byte[], int, int);

Writes a one-byte Boolean value to the current stream, with zero representing false and one representing true.

[Visual Basic] Overloads Public Sub Write(Boolean)
[C#] public void Write(bool);
[C++] public: void Write(bool);
[JScript] public function Write(Boolean);

Writes a byte array to the underlying stream.

[Visual Basic] Overloads Public Sub Write(Byte())
[C#] public void Write(byte[]);
[C++] public: void Write(unsigned char*[]);
[JScript] public function Write(Byte[]);

Writes a section of a character array to the current stream and advances the current position of the stream in accordance with the Encoding used and perhaps the particular characters being written to the stream.

[Visual Basic] Overloads Public Sub Write(Char(), Integer, Integer)
[C#] public void Write(char[], int, int);
[C++] public: void Write(__wchar_t*[], int, int);
[JScript] public function Write(Char[], int, int);

Writes an eight-byte floating-point value to the current stream and advances the stream position by eight bytes.

[Visual Basic] Overloads Public Sub Write(Double)
[C#] public void Write(double);
[C++] public: void Write(double);
[JScript] public function Write(double);

Writes a Unicode character to the current stream and advances the current position of the stream in accordance with the Encoding used and perhaps the particular characters being written to the stream.

[Visual Basic] Overloads Public Sub Write(Char)
[C#] public void Write(char);
[C++] public: void Write(__wchar_t);
[JScript] public function Write(Char);

Writes a character array to the current stream and advances the current position of the stream in accordance with the Encoding used and perhaps the particular characters being written to the stream.

[Visual Basic] Overloads Public Sub Write(Char())
[C#] public void Write(char[]);
[C++] public: void Write(__wchar_t*[]);
[JScript] public function Write(Char[]);

See Also

BinaryWriter Class | BinaryWriter Members | System.IO Namespace


BinaryWriter.Write (Int32)

Writes a four-byte signed integer to the current stream and advances the stream position by four bytes.

[Visual Basic]
Overloads Public Sub Write( _
   ByVal value As Integer _
)
[C#]
public void Write(
   int value
);
[C++]
public: void Write(
   int value
);
[JScript]
public function Write(
   value : int
);

Parameters

value
The value to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.
ArgumentNullException | value is a null reference (in Visual Basic Nothing).

See Also

BinaryWriter Class | BinaryWriter Members | System.IO Namespace | BinaryWriter.Write Overload List


BinaryWriter.Write (UInt32)

Writes a four-byte unsigned integer to the current stream and advances the stream position by four bytes.

[Visual Basic]
Overloads Public Sub Write( _
   ByVal value As UInt32 _
)
[C#]
public void Write(
   uint value
);
[C++]
public: void Write(
   unsigned int value
);
[JScript]
public function Write(
   value : UInt32
);

Parameters

value
The value to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.
ArgumentNullException | value is a null reference (in Visual Basic Nothing).

See Also

BinaryWriter Class | BinaryWriter Members | System.IO Namespace | BinaryWriter.Write Overload List


BinaryWriter.Write (Int16)

Writes a two-byte signed integer to the current stream and advances the stream position by two bytes.

[Visual Basic]
Overloads Public Sub Write( _
   ByVal value As Short _
)
[C#]
public void Write(
   short value
);
[C++]
public: void Write(
   short value
);
[JScript]
public function Write(
   value : Int16
);

Parameters

value
The value to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.
ArgumentNullException | value is a null reference (in Visual Basic Nothing).

See Also

BinaryWriter Class | BinaryWriter Members | System.IO Namespace | BinaryWriter.Write Overload List


BinaryWriter.Write (UInt16)

Writes a two-byte unsigned integer to the current stream and advances the stream position by two bytes.

[Visual Basic]
Overloads Public Sub Write( _
   ByVal value As UInt16 _
)
[C#]
public void Write(
   ushort value
);
[C++]
public: void Write(
   unsigned short value
);
[JScript]
public function Write(
   value : UInt16
);

Parameters

value
The value to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.
ArgumentNullException | value is a null reference (in Visual Basic Nothing).

See Also

BinaryWriter Class | BinaryWriter Members | System.IO Namespace | BinaryWriter.Write Overload List


BinaryWriter.Write (Single)

Writes a four-byte floating-point value to the current stream and advances the stream position by four bytes.

[Visual Basic]
Overloads Public Sub Write( _
   ByVal value As Single _
)
[C#]
public void Write(
   float value
);
[C++]
public: void Write(
   float value
);
[JScript]
public function Write(
   value : float
);

Parameters

value
The value to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.
ArgumentNullException | value is a null reference (in Visual Basic Nothing).

See Also

BinaryWriter Class | BinaryWriter Members | System.IO Namespace | BinaryWriter.Write Overload List


BinaryWriter.Write (String)

Writes a string to the text stream and advances the current position of the stream in accordance with the Encoding used and perhaps the particular characters being written to the stream.

[Visual Basic]
Overloads Public Sub Write( _
   ByVal value As String _
)
[C#]
public void Write(
   string value
);
[C++]
public: void Write(
   String* value
);
[JScript]
public function Write(
   value : String
);

Parameters

value
The value to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.
ArgumentNullException | value is a null reference (in Visual Basic Nothing).

Remarks

If the specified string is a null reference (Nothing), nothing is written to the text stream.

See Also

BinaryWriter Class | BinaryWriter Members | System.IO Namespace | BinaryWriter.Write Overload List


BinaryWriter.Write (Int64)

Writes an eight-byte signed integer to the current stream and advances the stream position by eight bytes.

[Visual Basic]
Overloads Public Sub Write( _
   ByVal value As Long _
)
[C#]
public void Write(
   long value
);
[C++]
public: void Write(
   __int64 value
);
[JScript]
public function Write(
   value : long
);

Parameters

value
The value to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.
ArgumentNullException | value is a null reference (in Visual Basic Nothing).

See Also

BinaryWriter Class | BinaryWriter Members | System.IO Namespace | BinaryWriter.Write Overload List


BinaryWriter.Write (UInt64)

Writes a eight-byte unsigned integer to the current stream and advances the stream position by eight bytes.

[Visual Basic]
Overloads Public Sub Write( _
   ByVal value As UInt64 _
)
[C#]
public void Write(
   ulong value
);
[C++]
public: void Write(
   unsigned __int64 value
);
[JScript]
public function Write(
   value : UInt64
);

Parameters

value
The value to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.
ArgumentNullException | value is a null reference (in Visual Basic Nothing).

See Also

BinaryWriter Class | BinaryWriter Members | System.IO Namespace | BinaryWriter.Write Overload List


BinaryWriter.Write (Byte)

Writes a byte to the current stream and advances the stream position by one byte.

[Visual Basic]
Overloads Public Sub Write( _
   ByVal value As Byte _
)
[C#]
public void Write(
   byte value
);
[C++]
public: void Write(
   unsigned char value
);
[JScript]
public function Write(
   value : Byte
);

Parameters

value
The byte to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.
ArgumentNullException | value is a null reference (in Visual Basic Nothing).

See Also

BinaryWriter Class | BinaryWriter Members | System.IO Namespace | BinaryWriter.Write Overload List


BinaryWriter.Write (SByte)

Writes a signed byte to the current stream and advances the stream position by one byte.

[Visual Basic]
Overloads Public Sub Write( _
   ByVal value As SByte _
)
[C#]
public void Write(
   sbyte value
);
[C++]
public: void Write(
   char value
);
[JScript]
public function Write(
   value : SByte
);

Parameters

value
The signed byte to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.
ArgumentNullException | value is a null reference (in Visual Basic Nothing).

See Also

BinaryWriter Class | BinaryWriter Members | System.IO Namespace | BinaryWriter.Write Overload List


BinaryWriter.Write (Byte[], Int32, Int32)

Writes a region of a byte array to the current stream.

[Visual Basic]
Overloads Overridable Public Sub Write( _
   ByVal buffer() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
[C#]
public virtual void Write(
   byte[] buffer,
   int index,
   int count
);
[C++]
public: virtual void Write(
   unsigned char* buffer[],
   int index,
   int count
);
[JScript]
public function Write(
   buffer : Byte[],
   index : int,
   count : int
);

Parameters

buffer
A byte array containing the data to write.
index
[To be supplied.]
count
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentException | The buffer length minus index is less than count.
ArgumentNullException | buffer is a null reference (in Visual Basic Nothing).
ArgumentOutOfRangeException | index or count is negative.
IOException | An I/O error occurs.

See Also

BinaryWriter Class | BinaryWriter Members | System.IO Namespace | BinaryWriter.Write Overload List


BinaryWriter.Write (Boolean)

Writes a one-byte Boolean value to the current stream, with zero representing false and one representing true.

[Visual Basic]
Overloads Public Sub Write( _
   ByVal value As Boolean _
)
[C#]
public void Write(
   bool value
);
[C++]
public: void Write(
   bool value
);
[JScript]
public function Write(
   value : Boolean
);

Parameters

value
The Boolean value to write (zero or 1).

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.
ArgumentNullException | value is a null reference (in Visual Basic Nothing).

See Also

BinaryWriter Class | BinaryWriter Members | System.IO Namespace | BinaryWriter.Write Overload List


BinaryWriter.Write (Byte[])

Writes a byte array to the underlying stream.

[Visual Basic]
Overloads Public Sub Write( _
   ByVal buffer() As Byte _
)
[C#]
public void Write(
   byte[] buffer
);
[C++]
public: void Write(
   unsigned char* buffer[]
);
[JScript]
public function Write(
   buffer : Byte[]
);

Parameters

buffer
A byte array containing the data to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.
ArgumentNullException | buffer is a null reference (in Visual Basic Nothing).

See Also

BinaryWriter Class | BinaryWriter Members | System.IO Namespace | BinaryWriter.Write Overload List


BinaryWriter.Write (Char[], Int32, Int32)

Writes a section of a character array to the current stream and advances the current position of the stream in accordance with the Encoding used and perhaps the particular characters being written to the stream.

[Visual Basic]
Overloads Public Sub Write( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
[C#]
public void Write(
   char[] buffer,
   int index,
   int count
);
[C++]
public: void Write(
   __wchar_t* buffer[],
   int index,
   int count
);
[JScript]
public function Write(
   buffer : Char[],
   index : int,
   count : int
);

Parameters

buffer
A character array containing the data to write.
index
The index of buffer at which to begin reading.
count
The number of characters to write.

Exceptions

Exception Type | Condition
ArgumentException | The buffer length minus index is less than count.
ArgumentNullException | buffer is a null reference (in Visual Basic Nothing).
ArgumentOutOfRangeException | index or count is negative.
IOException | An I/O error occurs.

See Also

BinaryWriter Class | BinaryWriter Members | System.IO Namespace | BinaryWriter.Write Overload List


BinaryWriter.Write (Double)

Writes an eight-byte floating-point value to the current stream and advances the stream position by eight bytes.

[Visual Basic]
Overloads Public Sub Write( _
   ByVal value As Double _
)
[C#]
public void Write(
   double value
);
[C++]
public: void Write(
   double value
);
[JScript]
public function Write(
   value : double
);

Parameters

value
The eight-byte floating-point value to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.
ArgumentNullException | value is a null reference (in Visual Basic Nothing).

See Also

BinaryWriter Class | BinaryWriter Members | System.IO Namespace | BinaryWriter.Write Overload List


BinaryWriter.Write (Char)

Writes a Unicode character to the current stream and advances the current position of the stream in accordance with the Encoding used and perhaps the particular characters being written to the stream.

[Visual Basic]
Overloads Public Sub Write( _
   ByVal ch As Char _
)
[C#]
public void Write(
   char ch
);
[C++]
public: void Write(
   __wchar_t ch
);
[JScript]
public function Write(
   ch : Char
);

Parameters

ch
The character to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.

See Also

BinaryWriter Class | BinaryWriter Members | System.IO Namespace | BinaryWriter.Write Overload List


BinaryWriter.Write (Char[])

Writes a character array to the current stream and advances the current position of the stream in accordance with the Encoding used and perhaps the particular characters being written to the stream.

[Visual Basic]
Overloads Public Sub Write( _
   ByVal buffer() As Char _
)
[C#]
public void Write(
   char[] buffer
);
[C++]
public: void Write(
   __wchar_t* buffer[]
);
[JScript]
public function Write(
   buffer : Char[]
);

Parameters

buffer
A character array containing the data to write.

Exceptions

Exception Type | Condition
ArgumentNullException | buffer is a null reference (in Visual Basic Nothing).
IOException | An I/O error occurs.

See Also

BinaryWriter Class | BinaryWriter Members | System.IO Namespace | BinaryWriter.Write Overload List


BinaryWriter.WriteString

Writes a length-prefixed string to this stream in the BinaryWriter's current Encoding and advances the current position of the stream in accordance with the Encoding used and perhaps the particular characters being written to the stream.

[Visual Basic]
Overridable Public Sub WriteString( _
   ByVal value As String _
)
[C#]
public virtual void WriteString(
   string value
);
[C++]
public: virtual void WriteString(
   String* value
);
[JScript]
public function WriteString(
   value : String
);

Parameters

value
The value to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.
ArgumentNullException | value is a null reference (in Visual Basic Nothing).

See Also

BinaryWriter Class | BinaryWriter Members | System.IO Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

BinaryWriter Fields

The fields of the BinaryWriter class are listed below. For a complete list of BinaryWriter class members, see the BinaryWriter Members topic.

Public:

Null Causes nothing to be stored when write methods are invoked on BinaryWriter.Null.

Protected:

OutStream Holds the underlying stream.

See Also

BinaryWriter Class | System.IO Namespace


BinaryWriter.Null

Causes nothing to be stored when write methods are invoked on BinaryWriter.Null.

[Visual Basic]
Public Shared ReadOnly Null As BinaryWriter
[C#]
public static readonly BinaryWriter Null;
[C++]
public: static readonly BinaryWriter* Null;
[JScript]
public static var Null : BinaryWriter;

See Also

BinaryWriter Class | BinaryWriter Members | System.IO Namespace


BinaryWriter.OutStream

Holds the underlying stream.

[Visual Basic]
Protected OutStream As Stream
[C#]
protected Stream OutStream;
[C++]
protected: Stream* OutStream;
[JScript]
protected var OutStream : Stream;

See Also

BinaryWriter Class | BinaryWriter Members | System.IO Namespace


BufferedStream Class

Represents a buffered stream object.

Object
Stream
BufferedStream

[Visual Basic]
Public Class BufferedStream
   Inherits Stream
[C#]
public class BufferedStream : Stream
[C++]
public __gc class BufferedStream : public Stream
[JScript]
public class BufferedStream extends Stream

Remarks

A buffer is a block of bytes in memory used to cache data, thereby reducing the number of calls to the operating system. Buffers thus improve read and write performance. A buffer can be used for either reading or writing, but never both simultaneously. The Read and Write methods of BufferedStream automatically maintain the buffer.

BufferedStream can be composed around certain types of streams. It provides implementations for reading and writing bytes to an underlying data source or repository. Use BinaryReader and BinaryWriter for reading and writing other data types. BufferedStream is designed to prevent the buffer from slowing down input and output when the buffer is not needed. If you always read and write for sizes greater than the internal buffer size, then BufferedStream might not even allocate the internal buffer. BufferedStream also buffers reads and writes in a shared buffer. It is assumed that you will almost always be doing a series of reads or writes, but rarely alternate between the two of them. The FileStream class exposes a Stream around a file, supporting both synchronous and asynchronous methods. It is also used to implement the standard in, standard out, and standard error streams. The File class is a utility class with static methods primarily for the creation of FileStream objects based on file paths and the standard input, standard output, and standard error devices. File is used with FileStream.

Requirements

Namespace: System.IO

Assembly: mscorlib.dll

See Also

BufferedStream Members | System.IO Namespace | FileStream | MemoryStream | Stream


BufferedStream Members

Public:

Constructor

BufferedStream Constructor Overloaded. Initializes a new instance of the BufferedStream class.

Properties

CanRead | Determines whether the current stream supports reading.
CanSeek | Determines whether the current stream supports seeking.
CanWrite | Determines whether the current stream supports writing.
DataAvailable | Determines whether data is available for reading without blocking.
Length | Retrieves the stream length in bytes.
Position | Determines the current position within the current stream.

Methods

BeginRead (inherited from Stream) | Begins an asynchronous read.
BeginWrite (inherited from Stream) | Begins an asynchronous write.
Close | Closes the stream and releases any resources (especially system resources such as sockets and file handles) associated with the current buffered stream.
EndRead (inherited from Stream) | Ends a pending asynchronous read request.
EndWrite (inherited from Stream) | Ends an asynchronous write.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Flush | Updates the underlying data source or repository with the current state of the buffer and subsequently clears the buffer.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Read | Copies bytes from the current buffered stream to an array.
ReadByte | Reads a byte from the underlying stream. Returns the byte cast to an int or-1 if reading from the end of the stream.
Seek | Sets the position within the current buffered stream.
SetLength | Sets the length of the buffered stream.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Copies bytes to the buffered stream and advances the current position within the buffered stream by the number of bytes written.
WriteByte | Writes a byte to the current position in the buffered stream.

Protected:

Methods

CreateWaitHandle (inherited from Stream) | Allocates a WaitHandle object efficiently.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BufferedStream Class | System.IO Namespace


BufferedStream Constructor

Initializes a new instance of the BufferedStream class.

Overload List

Initializes a buffered stream to a default buffer size of 4096 bytes.

[Visual Basic] Overloads Public Sub New(Stream)
[C#] public BufferedStream(Stream);
[C++] public: BufferedStream(Stream*);
[JScript] public function BufferedStream(Stream);

Initializes a buffered stream to the chosen buffer size.

[Visual Basic] Overloads Public Sub New(Stream, Integer)
[C#] public BufferedStream(Stream, int);
[C++] public: BufferedStream(Stream*, int);
[JScript] public function BufferedStream(Stream, int);

See Also

BufferedStream Class | BufferedStream Members | System.IO Namespace


BufferedStream Constructor (Stream)

Initializes a buffered stream to a default buffer size of 4096 bytes.

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream _
)
[C#]
public BufferedStream(
   Stream stream
);
[C++]
public: BufferedStream(
   Stream* stream
);
[JScript]
public function BufferedStream(
   stream : Stream
);

Parameters

stream
The current stream.

Remarks

This constructor only invokes the constructor on Stream. It is invoked by subclasses during the creation of buffered stream objects.

See Also

BufferedStream Class | BufferedStream Members | System.IO Namespace | BufferedStream Constructor Overload List


BufferedStream Constructor (Stream, Int32)

Initializes a buffered stream to the chosen buffer size.

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream, _
   ByVal bufferSize As Integer _
)
[C#]
public BufferedStream(
   Stream stream,
   int bufferSize
);
[C++]
public: BufferedStream(
   Stream* stream,
   int bufferSize
);
[JScript]
public function BufferedStream(
   stream : Stream,
   bufferSize : int
);

Parameters

stream
The current stream.
bufferSize
The buffer size in bytes.

Exceptions

Exception Type | Condition
ArgumentNullException | stream is null.
ArgumentOutOfRangeException | bufferSize is negative.

Remarks

A shared read/write buffer is allocated the first time a BufferedStream object is initialized with this constructor. The shared buffer is not used if all reads and writes are greater than or equal to bufferSize.

See Also

BufferedStream Class | BufferedStream Members | System.IO Namespace | BufferedStream Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

BufferedStream Properties

The properties of the BufferedStream class are listed below. For a complete list of BufferedStream class members, see the BufferedStream Members topic.

Public:

CanRead | Determines whether the current stream supports reading.
CanSeek | Determines whether the current stream supports seeking.
CanWrite | Determines whether the current stream supports writing.
DataAvailable | Determines whether data is available for reading without blocking.
Length | Retrieves the stream length in bytes.
Position | Determines the current position within the current stream.

See Also

BufferedStream Class | System.IO Namespace


BufferedStream.CanRead

Determines whether the current stream supports reading.

[Visual Basic]
Overridable Public ReadOnly Property CanRead As Boolean
[C#]
public bool CanRead {override get;}
[C++]
public: __property virtual bool get_CanRead();
[JScript]
public function get CanRead() : Boolean;

Property Value

true if the stream supports reading, otherwise, false. Also returns false if the stream is closed.

Remarks

If a BufferedStream subclass does not support reading, calls to the Read method throw a NotSupportedException.

See Also

BufferedStream Class | BufferedStream Members | System.IO Namespace | Read


BufferedStream.CanSeek

Determines whether the current stream supports seeking.

[Visual Basic]
Overridable Public ReadOnly Property CanSeek As Boolean
[C#]
public bool CanSeek {override get;}
[C++]
public: __property virtual bool get_CanSeek();
[JScript]
public function get CanSeek() : Boolean;

Property Value

true if the stream supports seeking; otherwise, false. Also returns false if the stream is closed.

Remarks

If a BufferedStream subclass does not support seeking, calls to SetLength or Seek throw a NotSupportedException.

See Also

BufferedStream Class | BufferedStream Members | System.IO Namespace | Position | SetLength | Seek


BufferedStream.CanWrite

Determines whether the current stream supports writing.

[Visual Basic]
Overridable Public ReadOnly Property CanWrite As Boolean
[C#]
public bool CanWrite {override get;}
[C++]
public: __property virtual bool get_CanWrite();
[JScript]
public function get CanWrite() : Boolean;

Property Value

true if the stream supports writing; otherwise, false. Also returns false if the stream is closed.

Remarks

If a BufferedStream subclass does not support writing, calls to Write throw a NotSupportedException.

See Also

BufferedStream Class | BufferedStream Members | System.IO Namespace | Write


BufferedStream.DataAvailable

Determines whether data is available for reading without blocking.

[Visual Basic]
Overridable Public ReadOnly Property DataAvailable As Boolean
[C#]
public bool DataAvailable {override get;}
[C++]
public: __property virtual bool get_DataAvailable();
[JScript]
public function get DataAvailable() : Boolean;

Property Value

true if data is available, false otherwise. Also returns false if the stream is closed.

Exceptions

Exception Type | Condition
IOException | The underlying stream is null or closed.

See Also

BufferedStream Class | BufferedStream Members | System.IO Namespace


BufferedStream.Length

Retrieves the stream length in bytes.

[Visual Basic]
Overridable Public ReadOnly Property Length As Long
[C#]
public long Length {override get;}
[C++]
public: __property virtual __int64 get_Length();
[JScript]
public function get Length() : long;

Property Value

The stream length in bytes.

Exceptions

Exception Type | Condition
IOException | The underlying stream is null or closed.
NotSupportedException | The stream does not support seeking.

See Also

BufferedStream Class | BufferedStream Members | System.IO Namespace


BufferedStream.Position

Determines the current position within the current stream.

[Visual Basic]
Overridable Public Property Position As Long
[C#]
public long Position {override get; override set;}
[C++]
public: __property virtual __int64 get_Position();
public: __property virtual void set_Position(__int64);
[JScript]
public function get Position() : long;
public function set Position(long);

Property Value

The current position within the current stream.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | value is negative.
IOException | An I/O error occurs.
NotSupportedException | The stream does not support seeking.
EndOfStreamException | Seeking was attempted beyond the length of a stream that does not support this.

Remarks

The default implementation of the get accessor invokes Seek to obtain the current position within the underlying stream and then adjusts this value according to the current position within the buffer.

The default implementation of the set accessor copies any data previously written to the buffer to the underlying stream, and then invokes Seek.

Although some streams may allow the position to be set beyond the length of the stream, others may throw an exception.

See Also

BufferedStream Class | BufferedStream Members | System.IO Namespace | CanSeek


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

BufferedStream Methods

The methods of the BufferedStream class are listed below. For a complete list of BufferedStream class members, see the BufferedStream Members topic.

Public:

BeginRead (inherited from Stream) | Begins an asynchronous read.
BeginWrite (inherited from Stream) | Begins an asynchronous write.
Close | Closes the stream and releases any resources (especially system resources such as sockets and file handles) associated with the current buffered stream.
EndRead (inherited from Stream) | Ends a pending asynchronous read request.
EndWrite (inherited from Stream) | Ends an asynchronous write.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Flush | Updates the underlying data source or repository with the current state of the buffer and subsequently clears the buffer.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Read | Copies bytes from the current buffered stream to an array.
ReadByte | Reads a byte from the underlying stream. Returns the byte cast to an int or-1 if reading from the end of the stream.
Seek | Sets the position within the current buffered stream.
SetLength | Sets the length of the buffered stream.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Copies bytes to the buffered stream and advances the current position within the buffered stream by the number of bytes written.
WriteByte | Writes a byte to the current position in the buffered stream.

Protected:

CreateWaitHandle (inherited from Stream) | Allocates a WaitHandle object efficiently.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BufferedStream Class | System.IO Namespace


BufferedStream.Close

Closes the stream and releases any resources (especially system resources such as sockets and file handles) associated with the current buffered stream.

[Visual Basic]
Overrides Public Sub Close()
[C#]
public override void Close();
[C++]
public: override void Close();
[JScript]
public override function Close();

Remarks

Any data previously written to the buffer is copied to the underlying data source or repository before the buffered stream is closed. Therefore, it is not necessary to call Flush before invoking Close. Following a call to Close, any operations on the buffered stream may raise exceptions.

Subclasses of BufferedStream must override this method so that any system resources, such as file handles, are released. The implementation should invoke BufferedStream.Close to ensure that previously written buffer data is safely copied to the underlying data source or repository.

See Also

BufferedStream Class | BufferedStream Members | System.IO Namespace | Flush


BufferedStream.Flush

Updates the underlying data source or repository with the current state of the buffer and subsequently clears the buffer.

[Visual Basic]
Overrides Public Sub Flush()
[C#]
public override void Flush();
[C++]
public: override void Flush();
[JScript]
public override function Flush();

Exceptions

Exception Type | Condition
IOException | The data source or repository is not open.

Remarks

A buffer can be used for either reading or writing, but never both simultaneously. That is, before the buffer can be used for reading, any data previously written to the buffer must be copied to the underlying data source or repository. (Data written to the buffer must also be copied to the underlying data source or repository before the buffer overfills as a result of successive writes.)

On the other hand, before the buffer can be used for writing, the position within the underlying stream must be decremented by the number of unread bytes previously copied from the underlying data source or repository to the buffer. Otherwise data that is subsequently written to the buffer would not be copied to the appropriate place within the underlying stream.

All the read and write methods of BufferedStream automatically maintain the buffer, so there is no need to invoke Flush when switching back and forth between reading and writing.

See Also

BufferedStream Class | BufferedStream Members | System.IO Namespace | Close


BufferedStream.Read

Copies bytes from the current buffered stream to an array.

[Visual Basic]
Overrides Public Function Read( _
   ByVal array() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
[C#]
public override int Read(
   byte[] array,
   int offset,
   int count
);
[C++]
public: override int Read(
   unsigned char* array[],
   int offset,
   int count
);
[JScript]
public override function Read(
   array : Byte[],
   offset : int,
   count : int
) : int;

Parameters

array
The buffer to which bytes are to be copied.
offset
The byte offset in the buffer at which to begin reading bytes.
count
The number of bytes to be read.

Return Value

The total number of bytes read into array. This may be less than the number of bytes requested if that many bytes aren't currently available, or zero if the end of the stream has been reached before any data can be read.

Exceptions

Exception Type | Condition
ArgumentException | Length of array minus offset is less than count.
ArgumentNullException | array is null.
ArgumentOutOfRangeException | offset or count is less than zero.
IOException | The stream is not open or is null.
NotSupportedException | The stream does not support reading.

Remarks

Note that BufferedStream.Read(byte[], int, int) and BufferedStream.Write(byte[], int, int) read and write the number of bytes specified by the count parameter, while StreamReader.Read(char[], int, int) and StreamReader.Write(char[], int, int) read and write the number of characters specified by the count parameter. Use the BufferedStream methods only for reading and writing bytes.

The Read method will return zero only if the end of the stream is reached. In all other cases, Read always reads at least one byte from the stream before returning. If no data is available from the stream upon a call to Read, the method will block until at least one byte of data can be returned.

See Also

BufferedStream Class | BufferedStream Members | System.IO Namespace | BlockCopy | CanRead | Write


BufferedStream.ReadByte

Reads a byte from the underlying stream. Returns the byte cast to an int or-1 if reading from the end of the stream.

[Visual Basic]
Overrides Public Function ReadByte() As Integer
[C#]
public override int ReadByte();
[C++]
public: override int ReadByte();
[JScript]
public override function ReadByte() : int;

Return Value

The byte cast to an int, or-1 if reading from the end of the stream.

Exceptions

Exception Type | Condition
IOException | The stream is closed or does not support reading.

See Also

BufferedStream Class | BufferedStream Members | System.IO Namespace


BufferedStream.Seek

Sets the position within the current buffered stream.

[Visual Basic]
Overrides Public Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
[C#]
public override long Seek(
   long offset,
   SeekOrigin origin
);
[C++]
public: override __int64 Seek(
   __int64 offset,
   SeekOrigin origin
);
[JScript]
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;

Parameters

offset
A byte offset relative to origin.
origin
A field of SeekOrigin indicating the reference point from which the new position is to be obtained.

Return Value

The new position within the current buffered stream.

Exceptions

Exception Type | Condition
IOException | The stream is not open or is null.
NotSupportedException | The stream does not support seeking.
EndOfStreamException | Seeking was attempted beyond the length of a stream that does not support this.

Remarks

If offset is negative, the new position will precede the position specified by origin by the number of bytes specified by offset. If offset is zero, the new position will be the position specified by origin. If offset is positive, the new position will follow the position specified by origin by the number of bytes specified by offset.

Note that some streams may support positioning beyond the length of the stream; others may throw an exception.

See Also

BufferedStream Class | BufferedStream Members | System.IO Namespace


BufferedStream.SetLength

Sets the length of the buffered stream.

[Visual Basic]
Overrides Public Sub SetLength( _
   ByVal value As Long _
)
[C#]
public override void SetLength(
   long value
);
[C++]
public: override void SetLength(
   __int64 value
);
[JScript]
public override function SetLength(
   value : long
);

Parameters

value
An integer indicating the desired length of the current buffered stream in bytes.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | value is less than zero.
IOException | The stream is not open or is null.
NotSupportedException | The stream does not support both writing and seeking.

Remarks

The buffer is flushed before setting the length of the underlying data source or repository. If the specified value is less than the current length of the buffered stream, the buffered stream is truncated. If the specified value is larger than the current length of the buffered stream, the buffered stream is expanded. If the buffered stream is expanded, the contents of the buffered stream between the old and the new length are not defined.

The default implementation of SetLength copies any data previously written to the buffer to the underlying data source or repository. Seek is called to decrement the position within the underlying data source or repository by the number of unread bytes (if any) previously copied from the underlying data source or repository to the buffer. Then SetLength sets the length in bytes of the stream.

See Also

BufferedStream Class | BufferedStream Members | System.IO Namespace


BufferedStream.Write

Copies bytes to the buffered stream and advances the current position within the buffered stream by the number of bytes written.

[Visual Basic]
Overrides Public Function Write( _
   ByVal array() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
[C#]
public override int Write(
   byte[] array,
   int offset,
   int count
);
[C++]
public: override int Write(
   unsigned char* array[],
   int offset,
   int count
);
[JScript]
public override function Write(
   array : Byte[],
   offset : int,
   count : int
) : int;

Parameters

array
An array whose elements are of type Byte, SByte, Char, Int16, Int32, Int64, Single, or Double. This method copies count bytes from array to the current buffered stream.
offset
The byte offset in the buffer at which to begin copying bytes to the current buffered stream.
count
The number of bytes to be written to the current buffered stream.

Return Value

The number of bytes written to the stream.

Exceptions

Exception Type | Condition
ArgumentException | Length of array minus offset is less than count.
ArgumentNullException | array is null.
ArgumentOutOfRangeException | offset or count is less than zero.
IOException | The stream is closed or null.
NotSupportedException | The stream does not support writing.

Remarks

Note that BufferedStream.Read(byte[], int, int) and BufferedStream.Write(byte[], int, int) read and write the number of bytes specified by the count parameter, while StreamReader.Read(char[], int, int) and StreamReader.Write(char[], int, int) read and write the number of characters specified by the count parameter. Use the BufferedStream methods only for reading and writing an integral number of bytes.

See Also

BufferedStream Class | BufferedStream Members | System.IO Namespace | CanWrite | Read


BufferedStream.WriteByte

Writes a byte to the current position in the buffered stream.

[Visual Basic]
Overrides Public Sub WriteByte( _
   ByVal value As Byte _
)
[C#]
public override void WriteByte(
   byte value
);
[C++]
public: override void WriteByte(
   unsigned char value
);
[JScript]
public override function WriteByte(
   value : Byte
);

Parameters

value
A byte to write to the stream.

Exceptions

Exception Type | Condition
IOException | The stream is closed.
NotSupportedException | The stream does not support writing.

Remarks

Writes a byte to a buffered stream efficiently. If the stream is closed or not writable, an exception will be thrown.

See Also

BufferedStream Class | BufferedStream Members | System.IO Namespace


ChangedFilters Enumeration

Specifies the changes to watch for in a file or folder.

[Visual Basic]
Public Enum ChangedFilters
[C#]
public enum ChangedFilters
[C++]
public enum ChangedFilters

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

You can combine the members of this enumeration to watch for more than one kind of change. For example, you can watch for any changes in the size of a file or folder, and for any changes in the security settings. This will raise a flag anytime there is a change in size or the security settings of a file or folder.

Members

Member Name | Description
Attributes | The attributes of the file or folder.
LastAccess | The date that the file or folder was last opened.
LastWrite | The date that the file or folder last had anything written to it.
Security | The security settings of the file or folder.
Size | The size of the file or folder.

Requirements

Namespace: System.IO

Assembly: system.io.dll

See Also

System.IO Namespace


Directory Class

Exposes routines for creating, moving, and enumerating through directories and subdirectories.

Object
FileSystemEntry
Directory

[Visual Basic]
NotInheritable Public Class Directory
   Inherits FileSystemEntry
[C#]
public sealed class Directory : FileSystemEntry
[C++]
public __gc __sealed class Directory : public FileSystemEntry
[JScript]
public class Directory extends FileSystemEntry

Remarks

Instances of the Directory class can enumerate through themselves, returning file or directory objects as appropriate. Directories can be defined as read-only or hidden.

Requirements

Namespace: System.IO

Assembly: mscorlib.dll

See Also

Directory Members | System.IO Namespace | File | Attributes


Directory Members

Public:

Constructor

Directory Constructor Creates a new Directory object on the specified path.

Properties

Attributes | Retrieves or sets directory attributes such as read-only and hidden.
CreationTime | Retrieves the creation time of the current directory.
CurrentDirectory | Gets and sets the current directory. The original directory is the one from which the process was started.
Exists | Determines whether a directory exists.
FullName (inherited from FileSystemEntry) | Retrieves the full path of the directory or file.
IsDirectory | Indicates whether the object is a directory.
IsFile | Indicates whether the object is a file.
LastAccessTime | Retrieves the time the current directory was last accessed.
LastWriteTime | Retrieves the time when the current directory was last written to.
Name | Retrieves the name of the current directory.
Parent | Retrieves the parent directory of a subdirectory.
Root | Retrieves the root portion of a path.

Methods

Combine | Combines two file paths.
CreateDirectories | Creates all directories specified by path.
CreateDirectory | Creates the directory as specified by path.
CreateFile | Creates a file in a specified path and opens it with read/write permission.
CreateSubdirectories | Creates subdirectories on the specified path.
CreateSubdirectory | Creates a subdirectory of the specified directory.
Delete | Overloaded. Deletes a directory and its contents from a path.
DirectoryExists | Tests if the given path refers to an existing directory on disk.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDirectories | Overloaded. Returns an array of Directories in the current directory.
GetDirectoriesInDirectory | Overloaded. Returns an array of Directories in the current directory.
GetDirectoryRoot | Returns the root portion of the specified path.
GetFiles | Overloaded. Returns a file list from the current directory.
GetFilesInDirectory | Overloaded. Retrieves an array of files in the specified directory.
GetFileSystemEntries | Overloaded. Retrieves an array of strongly typed FileSystemEntry objects.
GetFileSystemEntriesInDirectory | Overloaded. Returns an array of strongly typed FileSystemEntry entries in the path.
GetFullPath | Expands the specified path to a fully qualified path.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLogicalDrives | Retrieves the names of the logical drives on this machine in the form "C:\".
GetParent | Retrieves the parent directory of the specified path.
GetType (inherited from Object) | Gets the Type of the Object.
IsDirectoryRooted | Determines whether the specified path refers to a root.
Move | Moves a directory and its contents to a new path.
MoveTo | Moves a directory and its contents to a new path.
Refresh | Refreshes the state of the object.
ToString | Returns the fully qualified path.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

FullPath (inherited from FileSystemEntry) Retrieves the fully qualified path of the directory.

See Also

Directory Class | System.IO Namespace


Directory Constructor

Creates a new Directory object on the specified path.

[Visual Basic]
Public Sub New( _
   ByVal path As String _
)
[C#]
public Directory(
   string path
);
[C++]
public: Directory(
   String* path
);
[JScript]
public function Directory(
   path : String
);

Parameters

path
A string specifying the path on which to create the directory.

Exceptions

Exception Type | Condition
ArgumentNullException | path is null.
DirectoryNotFoundException | The path is not found.
SecurityException | The caller does not have the required permission.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess AllAccess flag required for read, write, and append access to the path.

See Also

Directory Class | Directory Members | System.IO Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Directory Properties

The properties of the Directory class are listed below. For a complete list of Directory class members, see the Directory Members topic.

Public:

Attributes | Retrieves or sets directory attributes such as read-only and hidden.
CreationTime | Retrieves the creation time of the current directory.
CurrentDirectory | Gets and sets the current directory. The original directory is the one from which the process was started.
Exists | Determines whether a directory exists.
FullName (inherited from FileSystemEntry) | Retrieves the full path of the directory or file.
IsDirectory | Indicates whether the object is a directory.
IsFile | Indicates whether the object is a file.
LastAccessTime | Retrieves the time the current directory was last accessed.
LastWriteTime | Retrieves the time when the current directory was last written to.
Name | Retrieves the name of the current directory.
Parent | Retrieves the parent directory of a subdirectory.
Root | Retrieves the root portion of a path.

See Also

Directory Class | System.IO Namespace


Directory.Attributes

Retrieves or sets directory attributes such as read-only and hidden.

[Visual Basic]
Overridable Public Property Attributes As FileSystemAttributes
[C#]
public FileSystemAttributes Attributes {override get; override
   set;}
[C++]
public: __property virtual FileSystemAttributes get_Attributes();
public: __property virtual void set_Attributes(FileSystemAttributes);
[JScript]
public function get Attributes() : FileSystemAttributes;
public function set Attributes(FileSystemAttributes);

Property Value

ReadOnly = 0x1

Hidden = 0x2

Exceptions

Exception Type | Condition
ArgumentNullException | path is null.
DirectoryNotFoundException | The path is not found.
SecurityException | The caller does not have the required permission.
ArgumentException | The file attribute is invalid.

Remarks

As defined in WinNT.h (FILE_ATTRIBUTE_XXX)

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Write flag required for write permission to the path.

See Also

Directory Class | Directory Members | System.IO Namespace


Directory.CreationTime

Retrieves the creation time of the current directory.

[Visual Basic]
Overridable Public ReadOnly Property CreationTime As DateTime
[C#]
public DateTime CreationTime {override get;}
[C++]
public: __property virtual DateTime get_CreationTime();
[JScript]
public function get CreationTime() : DateTime;

Property Value

A DateTime value representing the date and time when the directory was created.

See Also

Directory Class | Directory Members | System.IO Namespace


Directory.CurrentDirectory

Gets and sets the current directory. The original directory is the one from which the process was started.

[Visual Basic]
Public Shared Property CurrentDirectory As String
[C#]
public static string CurrentDirectory {get; set;}
[C++]
public: __property static String* get_CurrentDirectory();
public: __property static void set_CurrentDirectory(String*);
[JScript]
public static function get CurrentDirectory() : String;
public static function set CurrentDirectory(String);

Property Value

Get returns the current directory.

Set/Let is a string representing the fully qualified path of the current directory.

Exceptions

Exception Type | Condition
ArgumentException | The value passed to set is an empty string ("") or contains only whitespaces.
ArgumentNullException | A null value or object is passed to set.
IOException | An I/O error occurs.
DirectoryNotFoundException | The value passed to set specifies a path that cannot be found.
SecurityException | The caller does not have the required permission.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Read and write permission to the directory.

See Also

Directory Class | Directory Members | System.IO Namespace


Directory.Exists

Determines whether a directory exists.

[Visual Basic]
Overridable Public ReadOnly Property Exists As Boolean
[C#]
public bool Exists {override get;}
[C++]
public: __property virtual bool get_Exists();
[JScript]
public function get Exists() : Boolean;

Property Value

true if the directory exists, false otherwise.

Exceptions

Exception Type | Condition
IOException | Refresh() is unable to initialize the data.

See Also

Directory Class | Directory Members | System.IO Namespace


Directory.IsDirectory

Indicates whether the object is a directory.

[Visual Basic]
Overridable Public ReadOnly Property IsDirectory As Boolean
[C#]
public bool IsDirectory {override get;}
[C++]
public: __property virtual bool get_IsDirectory();
[JScript]
public function get IsDirectory() : Boolean;

Property Value

true if the object is a directory; otherwise, false.

See Also

Directory Class | Directory Members | System.IO Namespace


Directory.IsFile

Indicates whether the object is a file.

[Visual Basic]
Overridable Public ReadOnly Property IsFile As Boolean
[C#]
public bool IsFile {override get;}
[C++]
public: __property virtual bool get_IsFile();
[JScript]
public function get IsFile() : Boolean;

Property Value

false if the object is a directory; otherwise, true.

See Also

Directory Class | Directory Members | System.IO Namespace


Directory.LastAccessTime

Retrieves the time the current directory was last accessed.

[Visual Basic]
Overridable Public ReadOnly Property LastAccessTime As DateTime
[C#]
public DateTime LastAccessTime {override get;}
[C++]
public: __property virtual DateTime get_LastAccessTime();
[JScript]
public function get LastAccessTime() : DateTime;

Property Value

A DateTime value representing the date and time when the directory was last accessed.

See Also

Directory Class | Directory Members | System.IO Namespace


Directory.LastWriteTime

Retrieves the time when the current directory was last written to.

[Visual Basic]
Overridable Public ReadOnly Property LastWriteTime As DateTime
[C#]
public DateTime LastWriteTime {override get;}
[C++]
public: __property virtual DateTime get_LastWriteTime();
[JScript]
public function get LastWriteTime() : DateTime;

Property Value

A DateTime value representing the date and time when the directory was last written to.

See Also

Directory Class | Directory Members | System.IO Namespace


Directory.Name

Retrieves the name of the current directory.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {override get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

Property Value

A string representing the directory name and path.

See Also

Directory Class | Directory Members | System.IO Namespace


Directory.Parent

Retrieves the parent directory of a subdirectory.

[Visual Basic]
Public ReadOnly Property Parent As Directory
[C#]
public Directory Parent {get;}
[C++]
public: __property Directory* get_Parent();
[JScript]
public function get Parent() : Directory;

Property Value

A Directory object representing the parent directory, or a null reference (in Visual Basic Nothing) if the path is null or if the file path denotes a root (such as "\", "C:", or * "\\server\share").

See Also

Directory Class | Directory Members | System.IO Namespace


Directory.Root

Retrieves the root portion of a path.

[Visual Basic]
Public ReadOnly Property Root As Directory
[C#]
public Directory Root {get;}
[C++]
public: __property Directory* get_Root();
[JScript]
public function get Root() : Directory;

Property Value

A Directory object representing the root of a path.

See Also

Directory Class | Directory Members | System.IO Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Directory Methods

The methods of the Directory class are listed below. For a complete list of Directory class members, see the Directory Members topic.

Public:

Combine | Combines two file paths.
CreateDirectories | Creates all directories specified by path.
CreateDirectory | Creates the directory as specified by path.
CreateFile | Creates a file in a specified path and opens it with read/write permission.
CreateSubdirectories | Creates subdirectories on the specified path.
CreateSubdirectory | Creates a subdirectory of the specified directory.
Delete | Overloaded. Deletes a directory and its contents from a path.
DirectoryExists | Tests if the given path refers to an existing directory on disk.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDirectories | Overloaded. Returns an array of Directories in the current directory.
GetDirectoriesInDirectory | Overloaded. Returns an array of Directories in the current directory.
GetDirectoryRoot | Returns the root portion of the specified path.
GetFiles | Overloaded. Returns a file list from the current directory.
GetFilesInDirectory | Overloaded. Retrieves an array of files in the specified directory.
GetFileSystemEntries | Overloaded. Retrieves an array of strongly typed FileSystemEntry objects.
GetFileSystemEntriesInDirectory | Overloaded. Returns an array of strongly typed FileSystemEntry entries in the path.
GetFullPath | Expands the specified path to a fully qualified path.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLogicalDrives | Retrieves the names of the logical drives on this machine in the form "C:\".
GetParent | Retrieves the parent directory of the specified path.
GetType (inherited from Object) | Gets the Type of the Object.
IsDirectoryRooted | Determines whether the specified path refers to a root.
Move | Moves a directory and its contents to a new path.
MoveTo | Moves a directory and its contents to a new path.
Refresh | Refreshes the state of the object.
ToString | Returns the fully qualified path.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Directory Class | System.IO Namespace


Directory.Combine

Combines two file paths.

[Visual Basic]
Public Shared Function Combine( _
   ByVal path1 As String, _
   ByVal path2 As String _
) As String
[C#]
public static string Combine(
   string path1,
   string path2
);
[C++]
public: static String* Combine(
   String* path1,
   String* path2
);
[JScript]
public static function Combine(
   path1 : String,
   path2 : String
) : String;

Parameters

path1
The first path.
path2
The second path.

Return Value

A string containing the combined paths. The strings are trimmed to remove the leading and trailing whitespaces.

Exceptions

Exception Type | Condition
ArgumentNullException | path1 or path2 is a null reference (in Visual Basic Nothing).
ArgumentException | path2 is an empty string ("") or IsDirectoryRooted is true.
SecurityException | The caller does not have the required permission.

Remarks

If path2 does not include a root (for example, if path2

does not start with a backslash (\) or a drive specification), the result is a concatenation of the two paths, with an intervening backslash if required. If path2 includes a root, the result is path2. If either path1 or path2 is null, the result is a non-null string. If both path1 and path2 are null, the result is null.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Read and write permission to the paths to be combined.

See Also

Directory Class | Directory Members | System.IO Namespace


Directory.CreateDirectories

Creates all directories specified by path.

[Visual Basic]
Public Shared Function CreateDirectories( _
   ByVal path As String _
) As Directory
[C#]
public static Directory CreateDirectories(
   string path
);
[C++]
public: static Directory* CreateDirectories(
   String* path
);
[JScript]
public static function CreateDirectories(
   path : String
) : Directory;

Parameters

path
The path of directories to create.

Return Value

All directories specified by path.

Exceptions

Exception Type | Condition
ArgumentException | path is an empty string ("") or contains only whitespaces.
ArgumentNullException | path is null.
DirectoryNotFoundException | Part of the directory is not found.
IOException | A file or directory already has the name specified by path.
PathTooLongException | The specified path is too long.
SecurityException | The caller does not have the required permission.

Remarks

The path parameter specifies a directory path, not a file path.

Unlike the CreateDirectory method, CreateDirectories will create as many directories as are required to guarantee that the specified path is valid. It is not an error if some or all of the specified directories exist.

Note Path names are limited to 248 characters.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Write flag required for write permission to the path.

Example

To create the directory "C:\Users\User1\Public\Html" when the current directory is "C:\Users\User1", use any of the following calls:

CreateDirectories("Public\\Html")

CreateDirectories("\\Users\\User1\\Public\\Html")

CreateDirectories("c:\\Users\\User1\\Public\\Html")

Note that an escape character is required by many languages toensure that the backslash is interpreted properly.

See Also

Directory Class | Directory Members | System.IO Namespace | CreateDirectory | CreateSubdirectories


Directory.CreateDirectory

Creates the directory as specified by path.

[Visual Basic]
Public Shared Function CreateDirectory( _
   ByVal path As String _
) As Directory
[C#]
public static Directory CreateDirectory(
   string path
);
[C++]
public: static Directory* CreateDirectory(
   String* path
);
[JScript]
public static function CreateDirectory(
   path : String
) : Directory;

Parameters

path
The fully qualified path of the directory to create. The directory path can be absolute or relative. A relative path will be fully qualified based upon the current directory and drive.

Return Value

The new Directory object.

Exceptions

Exception Type | Condition
ArgumentException | path specifies an invalid file path.
ArgumentNullException | path is null.
DirectoryNotFoundException | Part of the directory is not found.
IOException | A file or directory already has the name specified by path.
PathTooLongException | The specified path is too long.
SecurityException | The caller does not have the required permission.

Remarks

The fully qualified path of the directory to be created is specified by path. Except for the last element, path must designate an existing directory. The last element in path

specifies the name of the new directory to create. An error occurs if a file or directory of that name already exists.

Note Path names are limited to 248 characters.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Write flag required for write permission to the path.

See Also

Directory Class | Directory Members | System.IO Namespace | CreateDirectories | CreateSubdirectory


Directory.CreateFile

Creates a file in a specified path and opens it with read/write permission.

[Visual Basic]
Public Function CreateFile( _
   ByVal fileName As String _
) As File
[C#]
public File CreateFile(
   string fileName
);
[C++]
public: File* CreateFile(
   String* fileName
);
[JScript]
public function CreateFile(
   fileName : String
) : File;

Parameters

fileName
The name of the new file.

Return Value

The name of the new file including its full path.

Exceptions

Exception Type | Condition
AccessException | filename is a directory or access is denied.
ArgumentNullException | filename is null.
DirectoryNotFoundException | Part of the specified directory is not found.
IOException | File name, directory name, or volume label syntax is incorrect.
SecurityException | The caller does not have the required permission.
ArgumentException | filename is an empty string ("").

Remarks

Note Path names are limited to 248 characters, and file names are limited to 260 characters.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Write permission for the path.

See Also

Directory Class | Directory Members | System.IO Namespace


Directory.CreateSubdirectories

Creates subdirectories on the specified path.

[Visual Basic]
Public Function CreateSubdirectories( _
   ByVal path As String _
) As Directory
[C#]
public Directory CreateSubdirectories(
   string path
);
[C++]
public: Directory* CreateSubdirectories(
   String* path
);
[JScript]
public function CreateSubdirectories(
   path : String
) : Directory;

Parameters

path
The specified path.

Return Value

The new subdirectories.

Exceptions

Exception Type | Condition
ArgumentException | path does not specify a valid file path.
ArgumentNullException | path is null.
DirectoryNotFoundException | Part of the directory is not found.
IOException | A file or directory already has the name specified by path.
PathTooLongException | The specified path is too long.
SecurityException | The caller does not have the required permission.

Remarks

Passing in ".." will not get the parent directory.

Note Path names are limited to 248 characters.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Write flag required for write permission to the path.

See Also

Directory Class | Directory Members | System.IO Namespace | CreateDirectories | CreateSubdirectory


Directory.CreateSubdirectory

Creates a subdirectory of the specified directory.

[Visual Basic]
Public Function CreateSubdirectory( _
   ByVal dirName As String _
) As Directory
[C#]
public Directory CreateSubdirectory(
   string dirName
);
[C++]
public: Directory* CreateSubdirectory(
   String* dirName
);
[JScript]
public function CreateSubdirectory(
   dirName : String
) : Directory;

Parameters

dirName
The subdirectory name.

Return Value

The new subdirectory.

Exceptions

Exception Type | Condition
ArgumentException | path does not specify a valid file path.
ArgumentNullException | path is null.
DirectoryNotFoundException | Part of the directory is not found.
IOException | A file or directory already has the name specified by path.
PathTooLongException | The specified path is too long.
SecurityException | The caller does not have the required permission.

Remarks

Note Path names are limited to 248 characters.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Write flag required for write permission to the path.

See Also

Directory Class | Directory Members | System.IO Namespace | CreateDirectory | CreateSubdirectories


Directory.Delete

Deletes a directory and its contents from a path.

Overload List

Deletes directories and its subdirectories and their contents from a path.

[Visual Basic] Overloads Public Sub Delete(Boolean)
[C#] public void Delete(bool);
[C++] public: void Delete(bool);
[JScript] public function Delete(Boolean);

Deletes directories and subdirectories and their contents from a path.

[Visual Basic] Overloads Public Shared Sub Delete(String, Boolean)
[C#] public static void Delete(String, bool);
[C++] public: static void Delete(String*, bool);
[JScript] public static function Delete(String, Boolean);

Deletes a directory and its contents from a specified path.

[Visual Basic] Overloads Public Shared Sub Delete(String)
[C#] public static void Delete(String);
[C++] public: static void Delete(String*);
[JScript] public static function Delete(String);

Deletes a directory and its contents from a path.

[Visual Basic] Overloads Overrides Public Sub Delete()
[C#] public override void Delete();
[C++] public: override void Delete();
[JScript] public override function Delete();

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Write flag required for write permission to the directory and subdirectories to be deleted.

See Also

Directory Class | Directory Members | System.IO Namespace


Directory.Delete (Boolean)

Deletes directories and its subdirectories and their contents from a path.

[Visual Basic]
Overloads Public Sub Delete( _
   ByVal recursive As Boolean _
)
[C#]
public void Delete(
   bool recursive
);
[C++]
public: void Delete(
   bool recursive
);
[JScript]
public function Delete(
   recursive : Boolean
);

Parameters

recursive
true to remove directories, subdirectories, and contents; otherwise false.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.
SecurityException | The caller does not have the required permission.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Write flag required for write permission to the directory and subdirectories to be deleted.

See Also

Directory Class | Directory Members | System.IO Namespace | Directory.Delete Overload List


Directory.Delete (String, Boolean)

Deletes directories and subdirectories and their contents from a path.

[Visual Basic]
Overloads Public Shared Sub Delete( _
   ByVal path As String, _
   ByVal recursive As Boolean _
)
[C#]
public static void Delete(
   string path,
   bool recursive
);
[C++]
public: static void Delete(
   String* path,
   bool recursive
);
[JScript]
public static function Delete(
   path : String,
   recursive : Boolean
);

Parameters

path
The fully qualified name of the directory to remove.
recursive
true to remove directories, subdirectories, and contents, otherwise false.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.
SecurityException | The caller does not have the required permission.
ArgumentException | The directory name is empty or contains only whitespaces.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Write flag required for write permission to the path.

See Also

Directory Class | Directory Members | System.IO Namespace | Directory.Delete Overload List


Directory.Delete (String)

Deletes a directory and its contents from a specified path.

[Visual Basic]
Overloads Public Shared Sub Delete( _
   ByVal path As String _
)
[C#]
public static void Delete(
   string path
);
[C++]
public: static void Delete(
   String* path
);
[JScript]
public static function Delete(
   path : String
);

Parameters

path
The fully qualified name of the directory to remove.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.
SecurityException | The caller does not have the required permission.
ArgumentException | The directory name is empty or contains only whitespaces.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Write flag required for write permission to the path.

See Also

Directory Class | Directory Members | System.IO Namespace | Directory.Delete Overload List


Directory.Delete ()

Deletes a directory and its contents from a path.

[Visual Basic]
Overloads Overrides Public Sub Delete()
[C#]
public override void Delete();
[C++]
public: override void Delete();
[JScript]
public override function Delete();

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.
SecurityException | The caller does not have the required permission.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Write flag required for write permission to the directory to be deleted.

See Also

Directory Class | Directory Members | System.IO Namespace | Directory.Delete Overload List


Directory.DirectoryExists

Tests if the given path refers to an existing directory on disk.

[Visual Basic]
Public Shared Function DirectoryExists( _
   ByVal path As String _
) As Boolean
[C#]
public static bool DirectoryExists(
   string path
);
[C++]
public: static bool DirectoryExists(
   String* path
);
[JScript]
public static function DirectoryExists(
   path : String
) : Boolean;

Parameters

path
The path to test.

Return Value

true if path refers to an existing directory, false otherwise.

Exceptions

Exception Type | Condition
ArgumentException | path is the empty string ("") or contains only whitespaces.
ArgumentNullException | path is null.
IOException | path is invalid or an I/O error occurs (for example, a disk error).
SecurityException | The caller does not have the required permission.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Read flag required for read permission to the target directory's contents.

See Also

Directory Class | Directory Members | System.IO Namespace


Directory.GetDirectories

Returns an array of Directories in the current directory.

Overload List

Returns an array of directories in the current directory matching the given search criteria.

[Visual Basic] Overloads Public Function GetDirectories(String) As Directory ()
[C#] public Directory[] GetDirectories(String);
[C++] public: Directory* GetDirectories(String*) [];
[JScript] public function GetDirectories(String) : Directory[];

Returns an array of Directories in the current directory.

[Visual Basic] Overloads Public Function GetDirectories() As Directory ()
[C#] public Directory[] GetDirectories();
[C++] public: Directory* GetDirectories() [];
[JScript] public function GetDirectories() : Directory[];

See Also

Directory Class | Directory Members | System.IO Namespace


Directory.GetDirectories (String)

Returns an array of directories in the current directory matching the given search criteria.

[Visual Basic]
Overloads Public Function GetDirectories( _
   ByVal searchCriteria As String _
) As Directory ()
[C#]
public Directory[] GetDirectories(
   string searchCriteria
);
[C++]
public: Directory* GetDirectories(
   String* searchCriteria
) [];
[JScript]
public function GetDirectories(
   searchCriteria : String
) : Directory[];

Parameters

searchCriteria
The search string.

Return Value

An array of directories matching searchCriteria.

Exceptions

Exception Type | Condition
ArgumentNullException | searchCriteria is null.

Remarks

".." can only be used in searchCriteria if it is specified as a part of a valid file or directory name. It cannot be used to move up the directory hierarchy. For example:

a..b abc..d is valid.

..ab ab.. .. abc..d\abc.. is invalid.

Other wild card characters are allowed in searchCriteria. For example, a search string such as "System*" would match both the System and System32 directories.

See Also

Directory Class | Directory Members | System.IO Namespace | Directory.GetDirectories Overload List


Directory.GetDirectories ()

Returns an array of Directories in the current directory.

[Visual Basic]
Overloads Public Function GetDirectories() As Directory ()
[C#]
public Directory[] GetDirectories();
[C++]
public: Directory* GetDirectories() [];
[JScript]
public function GetDirectories() : Directory[];

Return Value

An array of Directories.

See Also

Directory Class | Directory Members | System.IO Namespace | Directory.GetDirectories Overload List


Directory.GetDirectoriesInDirectory

Returns an array of Directories in the current directory.

Overload List

Returns an array of Directories in the current directory.

[Visual Basic] Overloads Public Shared Function GetDirectoriesInDirectory(String) As Directory ()
[C#] public static Directory[] GetDirectoriesInDirectory(String);
[C++] public: static Directory* GetDirectoriesInDirectory(String*) [];
[JScript] public static function GetDirectoriesInDirectory(String) : Directory[];

Returns an array of Directories in the current directory matching the specified search criteria, such as "*.txt".

[Visual Basic] Overloads Public Shared Function GetDirectoriesInDirectory(String, String) As Directory ()
[C#] public static Directory[] GetDirectoriesInDirectory(String, String);
[C++] public: static Directory* GetDirectoriesInDirectory(String*, String*) [];
[JScript] public static function GetDirectoriesInDirectory(String, String) : Directory[];

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Read flag required for read permission to the path.

See Also

Directory Class | Directory Members | System.IO Namespace


Directory.GetDirectoriesInDirectory (String)

Returns an array of Directories in the current directory.

[Visual Basic]
Overloads Public Shared Function GetDirectoriesInDirectory( _
   ByVal path As String _
) As Directory ()
[C#]
public static Directory[] GetDirectoriesInDirectory(
   string path
);
[C++]
public: static Directory* GetDirectoriesInDirectory(
   String* path
) [];
[JScript]
public static function GetDirectoriesInDirectory(
   path : String
) : Directory[];

Parameters

path
The path for which to return an array of directories.

Return Value

An array of directories.

Exceptions

Exception Type | Condition
ArgumentNullException | path or searchCriteria is null.
SecurityException | The caller does not have the required permission.
ArgumentException | The directory name is empty or contains only whitespaces.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Read flag required for read permission to the path.

See Also

Directory Class | Directory Members | System.IO Namespace | Directory.GetDirectoriesInDirectory Overload List


Directory.GetDirectoriesInDirectory (String, String)

Returns an array of Directories in the current directory matching the specified search criteria, such as "*.txt".

[Visual Basic]
Overloads Public Shared Function GetDirectoriesInDirectory( _
   ByVal path As String, _
   ByVal searchCriteria As String _
) As Directory ()
[C#]
public static Directory[] GetDirectoriesInDirectory(
   string path,
   string searchCriteria
);
[C++]
public: static Directory* GetDirectoriesInDirectory(
   String* path,
   String* searchCriteria
) [];
[JScript]
public static function GetDirectoriesInDirectory(
   path : String,
   searchCriteria : String
) : Directory[];

Parameters

path
The path for which to return an array of directories.
searchCriteria
The search string, such as "System*".

Return Value

An array of directories matching the search criteria.

Exceptions

Exception Type | Condition
ArgumentNullException | path or searchCriteria is null.
SecurityException | The caller does not have the required permission.
ArgumentException | The directory name is empty or contains only whitespaces.

Remarks

".." can only be used in searchCriteria if it is specified as a part of a valid file or directory name. It cannot be used to move up the directory hierarchy. For example:

a..b abc..d is valid.

..ab ab.. .. abc..d\abc.. is invalid.

Other wild card characters are allowed in searchCriteria. For example, a search string such as "System*" would match both the System and System32 directories.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Read flag required for read permission to the path.

See Also

Directory Class | Directory Members | System.IO Namespace | Directory.GetDirectoriesInDirectory Overload List


Directory.GetDirectoryRoot

Returns the root portion of the specified path.

[Visual Basic]
Public Shared Function GetDirectoryRoot( _
   ByVal path As String _
) As String
[C#]
public static string GetDirectoryRoot(
   string path
);
[C++]
public: static String* GetDirectoryRoot(
   String* path
);
[JScript]
public static function GetDirectoryRoot(
   path : String
) : String;

Parameters

path
The path of a file or directory.

Return Value

The root portion of the specified path.

Exceptions

Exception Type | Condition
ArgumentException | path is empty or contains only whitespaces.
SecurityException | The caller does not have the required permission.

Remarks

The resulting string consists of those leftmost characters of the path that constitute the root of the path. Possible patterns for the resulting string are the following:

  • An empty string (a relative path on the current drive).
  • "\" (an absolute path on the current drive).
  • "X:" (a relative path on a given drive, where X is the drive letter).
  • "X:\" (an absolute path on a given drive).
  • "\\server\share" (a UNC path for a specified server and share name).
  • null if path is null.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Read permission to the path.

See Also

Directory Class | Directory Members | System.IO Namespace


Directory.GetFiles

Returns a file list from the current directory.

Overload List

Returns a file list from the current directory matching the given search criteria, such as "*.txt".

[Visual Basic] Overloads Public Function GetFiles(String) As File ()
[C#] public File[] GetFiles(String);
[C++] public: File* GetFiles(String*) [];
[JScript] public function GetFiles(String) : File[];

Returns a file list from the current directory.

[Visual Basic] Overloads Public Function GetFiles() As File ()
[C#] public File[] GetFiles();
[C++] public: File* GetFiles() [];
[JScript] public function GetFiles() : File[];

See Also

Directory Class | Directory Members | System.IO Namespace


Directory.GetFiles (String)

Returns a file list from the current directory matching the given search criteria, such as "*.txt".

[Visual Basic]
Overloads Public Function GetFiles( _
   ByVal searchCriteria As String _
) As File ()
[C#]
public File[] GetFiles(
   string searchCriteria
);
[C++]
public: File* GetFiles(
   String* searchCriteria
) [];
[JScript]
public function GetFiles(
   searchCriteria : String
) : File[];

Parameters

searchCriteria
The search string.

Return Value

An array of file names.

Exceptions

Exception Type | Condition
ArgumentNullException | searchCriteria is null.

Remarks

".." can only be used in searchCriteria if it is specified as a part of a valid file or directory name. It cannot be used to move up the directory hierarchy. For example:

a..b abc..d is valid.

..ab ab.. .. abc..d\abc.. is invalid.

Other wild card characters are allowed in searchCriteria. For example, a search string such as "System*" would match both the System and System32 directories.

See Also

Directory Class | Directory Members | System.IO Namespace | Directory.GetFiles Overload List


Directory.GetFiles ()

Returns a file list from the current directory.

[Visual Basic]
Overloads Public Function GetFiles() As File ()
[C#]
public File[] GetFiles();
[C++]
public: File* GetFiles() [];
[JScript]
public function GetFiles() : File[];

Return Value

An array of file names.

See Also

Directory Class | Directory Members | System.IO Namespace | Directory.GetFiles Overload List


Directory.GetFilesInDirectory

Retrieves an array of files in the specified directory.

Overload List

Retrieves an array of files in the specified directory.

[Visual Basic] Overloads Public Shared Function GetFilesInDirectory(String) As File ()
[C#] public static File[] GetFilesInDirectory(String);
[C++] public: static File* GetFilesInDirectory(String*) [];
[JScript] public static function GetFilesInDirectory(String) : File[];

Retrieves an array of files matching the specified search criteria from the specified directory.

[Visual Basic] Overloads Public Shared Function GetFilesInDirectory(String, String) As File ()
[C#] public static File[] GetFilesInDirectory(String, String);
[C++] public: static File* GetFilesInDirectory(String*, String*) [];
[JScript] public static function GetFilesInDirectory(String, String) : File[];

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Read permission to the path.

See Also

Directory Class | Directory Members | System.IO Namespace


Directory.GetFilesInDirectory (String)

Retrieves an array of files in the specified directory.

[Visual Basic]
Overloads Public Shared Function GetFilesInDirectory( _
   ByVal path As String _
) As File ()
[C#]
public static File[] GetFilesInDirectory(
   string path
);
[C++]
public: static File* GetFilesInDirectory(
   String* path
) [];
[JScript]
public static function GetFilesInDirectory(
   path : String
) : File[];

Parameters

path
The directory from which to return files.

Return Value

An array of files in the specified directory.

Exceptions

Exception Type | Condition
ArgumentNullException | path is null.
SecurityException | The caller does not have the required permission.
ArgumentException | The directory name is empty or contains only whitespaces.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Read permission to the path.

See Also

Directory Class | Directory Members | System.IO Namespace | Directory.GetFilesInDirectory Overload List


Directory.GetFilesInDirectory (String, String)

Retrieves an array of files matching the specified search criteria from the specified directory.

[Visual Basic]
Overloads Public Shared Function GetFilesInDirectory( _
   ByVal path As String, _
   ByVal searchCriteria As String _
) As File ()
[C#]
public static File[] GetFilesInDirectory(
   string path,
   string searchCriteria
);
[C++]
public: static File* GetFilesInDirectory(
   String* path,
   String* searchCriteria
) [];
[JScript]
public static function GetFilesInDirectory(
   path : String,
   searchCriteria : String
) : File[];

Parameters

path
The directory from which to return files.
searchCriteria
The search string, such as "*.txt".

Return Value

An array of files matching the specified search criteria from the specified directory.

Exceptions

Exception Type | Condition
ArgumentNullException | searchCriteria is a null reference (in Visual Basic Nothing).
ArgumentException | path is a null reference (Nothing), the directory name is empty, or it contains only whitespaces.
SecurityException | The caller does not have the required permission.

Remarks

".." can only be used in searchCriteria if it is specified as a part of a valid file or directory name. It cannot be used to move up the directory hierarchy. For example:

a..b abc..d is valid.

..ab ab.. .. abc..d\abc.. is invalid.

Other wild card characters are allowed in searchCriteria. For example, a search string such as "System*" would match both the System and System32 directories.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Read flag required for read permission to the path.

See Also

Directory Class | Directory Members | System.IO Namespace | Directory.GetFilesInDirectory Overload List


Directory.GetFileSystemEntries

Retrieves an array of strongly typed FileSystemEntry objects.

Overload List

Retrieves an array of strongly typed FileSystemEntry objects matching the specified search criteria.

[Visual Basic] Overloads Public Function GetFileSystemEntries(String) As FileSystemEntry ()
[C#] public FileSystemEntry[] GetFileSystemEntries(String);
[C++] public: FileSystemEntry* GetFileSystemEntries(String*) [];
[JScript] public function GetFileSystemEntries(String) : FileSystemEntry[];

Returns an array of strongly typed FileSystemEntry entries listing all the files and directories.

[Visual Basic] Overloads Public Function GetFileSystemEntries() As FileSystemEntry ()
[C#] public FileSystemEntry[] GetFileSystemEntries();
[C++] public: FileSystemEntry* GetFileSystemEntries() [];
[JScript] public function GetFileSystemEntries() : FileSystemEntry[];

See Also

Directory Class | Directory Members | System.IO Namespace


Directory.GetFileSystemEntries (String)

Retrieves an array of strongly typed FileSystemEntry objects matching the specified search criteria.

[Visual Basic]
Overloads Public Function GetFileSystemEntries( _
   ByVal searchCriteria As String _
) As FileSystemEntry ()
[C#]
public FileSystemEntry[] GetFileSystemEntries(
   string searchCriteria
);
[C++]
public: FileSystemEntry* GetFileSystemEntries(
   String* searchCriteria
) [];
[JScript]
public function GetFileSystemEntries(
   searchCriteria : String
) : FileSystemEntry[];

Parameters

searchCriteria
The search string.

Return Value

An array of strongly typed FileSystemEntry objects matching the search criteria.

Exceptions

Exception Type | Condition
ArgumentNullException | searchCriteria is null.

Remarks

".." can only be used in searchCriteria if it is specified as a part of a valid file or directory name. It cannot be used to move up the directory hierarchy. For example:

a..b abc..d is valid.

..ab ab.. .. abc..d\abc.. is invalid.

Other wild card characters are allowed in searchCriteria. For example, a search string such as "System*" would match both the System and System32 directories.

See Also

Directory Class | Directory Members | System.IO Namespace | Directory.GetFileSystemEntries Overload List | FileSystemEntry


Directory.GetFileSystemEntries ()

Returns an array of strongly typed FileSystemEntry entries listing all the files and directories.

[Visual Basic]
Overloads Public Function GetFileSystemEntries() As FileSystemEntry ()
[C#]
public FileSystemEntry[] GetFileSystemEntries();
[C++]
public: FileSystemEntry* GetFileSystemEntries() [];
[JScript]
public function GetFileSystemEntries() : FileSystemEntry[];

Return Value

An array of strongly typed FileSystemEntry entries.

See Also

Directory Class | Directory Members | System.IO Namespace | Directory.GetFileSystemEntries Overload List | FileSystemEntry


Directory.GetFileSystemEntriesInDirectory

Returns an array of strongly typed FileSystemEntry entries in the path.

Overload List

Returns an array of strongly typed FileSystemEntry entries in the path.

[Visual Basic] Overloads Public Shared Function GetFileSystemEntriesInDirectory(String) As FileSystemEntry ()
[C#] public static FileSystemEntry[] GetFileSystemEntriesInDirectory(String);
[C++] public: static FileSystemEntry* GetFileSystemEntriesInDirectory(String*) [];
[JScript] public static function GetFileSystemEntriesInDirectory(String) : FileSystemEntry[];

Returns an array of strongly typed FileSystemEntry entries in the path matching the specified search criteria, such as "*.txt".

[Visual Basic] Overloads Public Shared Function GetFileSystemEntriesInDirectory(String, String) As FileSystemEntry ()
[C#] public static FileSystemEntry[] GetFileSystemEntriesInDirectory(String, String);
[C++] public: static FileSystemEntry* GetFileSystemEntriesInDirectory(String*, String*) [];
[JScript] public static function GetFileSystemEntriesInDirectory(String, String) : FileSystemEntry[];

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Read flag required for read permission for the path.

See Also

Directory Class | Directory Members | System.IO Namespace


Directory.GetFileSystemEntriesInDirectory (String)

Returns an array of strongly typed FileSystemEntry entries in the path.

[Visual Basic]
Overloads Public Shared Function GetFileSystemEntriesInDirectory( _
   ByVal path As String _
) As FileSystemEntry ()
[C#]
public static FileSystemEntry[] GetFileSystemEntriesInDirectory(
   string path
);
[C++]
public: static FileSystemEntry* GetFileSystemEntriesInDirectory(
   String* path
) [];
[JScript]
public static function GetFileSystemEntriesInDirectory(
   path : String
) : FileSystemEntry[];

Parameters

path
The path to retrieve from.

Return Value

An array of strongly typed FileSystemEntry objects.

Exceptions

Exception Type | Condition
ArgumentNullException | path or searchCriteria is null.
SecurityException | The caller does not have the required permission.
ArgumentException | The directory name is empty or contains only whitespaces.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Read flag required for read permission for the path.

See Also

Directory Class | Directory Members | System.IO Namespace | Directory.GetFileSystemEntriesInDirectory Overload List | FileSystemEntry


Directory.GetFileSystemEntriesInDirectory (String, String)

Returns an array of strongly typed FileSystemEntry entries in the path matching the specified search criteria, such as "*.txt".

[Visual Basic]
Overloads Public Shared Function GetFileSystemEntriesInDirectory( _
   ByVal path As String, _
   ByVal searchCriteria As String _
) As FileSystemEntry ()
[C#]
public static FileSystemEntry[] GetFileSystemEntriesInDirectory(
   string path,
   string searchCriteria
);
[C++]
public: static FileSystemEntry* GetFileSystemEntriesInDirectory(
   String* path,
   String* searchCriteria
) [];
[JScript]
public static function GetFileSystemEntriesInDirectory(
   path : String,
   searchCriteria : String
) : FileSystemEntry[];

Parameters

path
The path to be searched.
searchCriteria
The search string.

Return Value

An array of FileSystemEntry objects matching the search criteria.

Exceptions

Exception Type | Condition
ArgumentNullException | path or searchCriteria is null.
SecurityException | The caller does not have the required permission.
ArgumentException | The directory name is empty or contains only whitespaces.

Remarks

".." can only be used in searchCriteria if it is specified as a part of a valid file or directory name. It cannot be used to move up the directory hierarchy. For example:

a..b abc..d is valid.

..ab ab.. .. abc..d\abc.. is invalid.

Other wild card characters are allowed in searchCriteria. For example, a search string such as "System*" would match both the System and System32 directories.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Read flag required for read permission for the path.

See Also

Directory Class | Directory Members | System.IO Namespace | Directory.GetFileSystemEntriesInDirectory Overload List | FileSystemEntry


Directory.GetFullPath

Expands the specified path to a fully qualified path.

[Visual Basic]
Public Shared Function GetFullPath( _
   ByVal path As String _
) As String
[C#]
public static string GetFullPath(
   string path
);
[C++]
public: static String* GetFullPath(
   String* path
);
[JScript]
public static function GetFullPath(
   path : String
) : String;

Parameters

path
The path to fully qualify.

Return Value

A string consisting of a drive letter, a colon, and a root relative path.

Exceptions

Exception Type | Condition
ArgumentException | path contains one of the characters within the InvalidPathChars array.
IOException | An error occurs in an attempt to return the fully qualified path.
SecurityException | The caller does not have the required permission.

Remarks

This method does not verify that the resulting path is valid or that it refers to an existing file or directory on the associated volume.

Requirements

NGWS Runtime Security:

EnvironmentPermission IsUnrestricted must be true.

See Also

Directory Class | Directory Members | System.IO Namespace


Directory.GetLogicalDrives

Retrieves the names of the logical drives on this machine in the form "C:\".

[Visual Basic]
Public Shared Function GetLogicalDrives() As String ()
[C#]
public static string[] GetLogicalDrives();
[C++]
public: static String* GetLogicalDrives() [];
[JScript]
public static function GetLogicalDrives() : String[];

Return Value

The logical drives on this machine.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs (for example, a disk error).
SecurityException | The caller does not have the required permission.
ArgumentException | The directory name is empty or contains only whitespaces.

Requirements

NGWS Runtime Security:

SecurityPermission UnmanagedCode flag must be set to call unmanaged code, such as calling native code with PInvoke or COM Interop.

See Also

Directory Class | Directory Members | System.IO Namespace


Directory.GetParent

Retrieves the parent directory of the specified path.

[Visual Basic]
Public Shared Function GetParent( _
   ByVal path As String _
) As Directory
[C#]
public static Directory GetParent(
   string path
);
[C++]
public: static Directory* GetParent(
   String* path
);
[JScript]
public static function GetParent(
   path : String
) : Directory;

Parameters

path
The fully qualified path for which to retrieve the parent directory.

Return Value

The parent directory.

Exceptions

Exception Type | Condition
ArgumentNullException | path is a null reference (in Visual Basic Nothing).
ArgumentException | path is an empty string ("") or contains invalid characters.
SecurityException | The caller does not have the required permission.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Read permission to the parent directory.

See Also

Directory Class | Directory Members | System.IO Namespace


Directory.IsDirectoryRooted

Determines whether the specified path refers to a root.

[Visual Basic]
Public Shared Function IsDirectoryRooted( _
   ByVal path As String _
) As Boolean
[C#]
public static bool IsDirectoryRooted(
   string path
);
[C++]
public: static bool IsDirectoryRooted(
   String* path
);
[JScript]
public static function IsDirectoryRooted(
   path : String
) : Boolean;

Parameters

path
The path to test.

Return Value

true if the path is a root path; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentException | path is empty or contains only whitespaces.
ArgumentNullException | path is null.
SecurityException | The caller does not have the required permission.

Remarks

A path is considered rooted if it starts with a backslash ("\"), slash ("/") or a drive letter and a colon ("C:").

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Read permission to the path.

See Also

Directory Class | Directory Members | System.IO Namespace | DirectorySeparatorChar | AltDirectorySeparatorChar | VolumeSeparatorChar


Directory.Move

Moves a directory and its contents to a new path.

[Visual Basic]
Public Shared Sub Move( _
   ByVal srcDirName As String, _
   ByVal destDirName As String _
)
[C#]
public static void Move(
   string srcDirName,
   string destDirName
);
[C++]
public: static void Move(
   String* srcDirName,
   String* destDirName
);
[JScript]
public static function Move(
   srcDirName : String,
   destDirName : String
);

Parameters

srcDirName
The name and path from which to move the directory.
destDirName
The name and path to which to move the directory.

Exceptions

Exception Type | Condition
ArgumentException | srcDirName or destDirName is an empty string ("") or contains only whitespaces.
ArgumentNullException | srcDirName or destDirName is a null reference (in Visual Basic Nothing).
SecurityException | The caller does not have the required permission.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Write flag required for write permission to the destination directory.

See Also

Directory Class | Directory Members | System.IO Namespace


Directory.MoveTo

Moves a directory and its contents to a new path.

[Visual Basic]
Public Sub MoveTo( _
   ByVal destDirName As String _
)
[C#]
public void MoveTo(
   string destDirName
);
[C++]
public: void MoveTo(
   String* destDirName
);
[JScript]
public function MoveTo(
   destDirName : String
);

Parameters

destDirName
The name and path to which to move the directory.

Exceptions

Exception Type | Condition
ArgumentNullException | destDirName is null.
ArgumentException | destDirName is an empty string (''").
IOException | An I/O error occurs.
SecurityException | The caller does not have the required permission.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Write flag required for write permission to the destination directory.

See Also

Directory Class | Directory Members | System.IO Namespace


Directory.Refresh

Refreshes the state of the object.

[Visual Basic]
Overrides Public Sub Refresh()
[C#]
public override void Refresh();
[C++]
public: override void Refresh();
[JScript]
public override function Refresh();

Exceptions

Exception Type | Condition
ArgumentException | The file is not found.
IOException | A device such as a disk drive is not ready.

Remarks

To avoid caching outdated information, call Refresh before attempting to get CreationTime, LastAccessTime, LastWriteTime or Attributes.

See Also

Directory Class | Directory Members | System.IO Namespace


Directory.ToString

Returns the fully qualified path.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

A string representing the full path.

Remarks

See Also

Directory Class | Directory Members | System.IO Namespace


DirectoryNotFoundException Class

Returns an exception when trying to access a directory that doesn't exist on disk.

Object
Exception
IOException
DirectoryNotFoundException

[Visual Basic]
Public Class DirectoryNotFoundException
   Inherits IOException
[C#]
public class DirectoryNotFoundException : IOException
[C++]
public __gc class DirectoryNotFoundException : public IOException
[JScript]
public class DirectoryNotFoundException extends IOException

Remarks

[To be supplied.]

Requirements

Namespace: System.IO

Assembly: mscorlib.dll

See Also

DirectoryNotFoundException Members | System.IO Namespace


DirectoryNotFoundException Members

Public:

Constructor

DirectoryNotFoundException Constructor Overloaded. Creates a new instance of the DirectoryNotFoundException class with its message string.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

DirectoryNotFoundException Class | System.IO Namespace


DirectoryNotFoundException Constructor

Creates a new instance of the DirectoryNotFoundException class with its message string.

Overload List

Creates a new instance of the DirectoryNotFoundException class with its message string set to the empty string ("") and its HRESULT set to COR_E_DIRECTORYNOTFOUND.

[Visual Basic] Overloads Public Sub New()
[C#] public DirectoryNotFoundException();
[C++] public: DirectoryNotFoundException();
[JScript] public function DirectoryNotFoundException();

Creates a new DirectoryNotFoundException with its message string set to message and its HRESULT set to COR_E_DIRECTORYNOTFOUND.

[Visual Basic] Overloads Public Sub New(String)
[C#] public DirectoryNotFoundException(String);
[C++] public: DirectoryNotFoundException(String*);
[JScript] public function DirectoryNotFoundException(String);

Creates a new DirectoryNotFoundException with its message string set to message and inner and its HRESULT set to COR_E_DIRECTORYNOTFOUND.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public DirectoryNotFoundException(String, Exception);
[C++] public: DirectoryNotFoundException(String*, Exception);
[JScript] public function DirectoryNotFoundException(String, Exception);

See Also

DirectoryNotFoundException Class | DirectoryNotFoundException Members | System.IO Namespace


DirectoryNotFoundException Constructor ()

Creates a new instance of the DirectoryNotFoundException class with its message string set to the empty string ("") and its HRESULT set to COR_E_DIRECTORYNOTFOUND.

[Visual Basic]
Overloads Public Sub New()
[C#]
public DirectoryNotFoundException();
[C++]
public: DirectoryNotFoundException();
[JScript]
public function DirectoryNotFoundException();

Remarks

[To be supplied.]

See Also

DirectoryNotFoundException Class | DirectoryNotFoundException Members | System.IO Namespace | DirectoryNotFoundException Constructor Overload List


DirectoryNotFoundException Constructor (String)

Creates a new DirectoryNotFoundException with its message string set to message and its HRESULT set to COR_E_DIRECTORYNOTFOUND.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public DirectoryNotFoundException(
   string message
);
[C++]
public: DirectoryNotFoundException(
   String* message
);
[JScript]
public function DirectoryNotFoundException(
   message : String
);

Parameters

message
The message text for the exception.

Remarks

[To be supplied.]

See Also

DirectoryNotFoundException Class | DirectoryNotFoundException Members | System.IO Namespace | DirectoryNotFoundException Constructor Overload List


DirectoryNotFoundException Constructor (String, Exception)

Creates a new DirectoryNotFoundException with its message string set to message and inner and its HRESULT set to COR_E_DIRECTORYNOTFOUND.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public DirectoryNotFoundException(
   string message,
   Exception inner
);
[C++]
public: DirectoryNotFoundException(
   String* message,
   Exception* inner
);
[JScript]
public function DirectoryNotFoundException(
   message : String,
   inner : Exception
);

Parameters

message
The message text for the exception.
inner
The exception that is the root cause of this exception.

Remarks

When handling exceptions, it is sometimes desirable to throw another exception that is more indicative of the error that has occurred. To avoid losing the original exception and the information that it carries, exceptions can hold a reference to another exception.

See Also

DirectoryNotFoundException Class | DirectoryNotFoundException Members | System.IO Namespace | DirectoryNotFoundException Constructor Overload List


EndOfStreamException Class

Returns an exception when reading is attempted past the end of a stream.

Object
Exception
IOException
EndOfStreamException

[Visual Basic]
Public Class EndOfStreamException
   Inherits IOException
[C#]
public class EndOfStreamException : IOException
[C++]
public __gc class EndOfStreamException : public IOException
[JScript]
public class EndOfStreamException extends IOException

Remarks

[To be supplied.]

Requirements

Namespace: System.IO

Assembly: mscorlib.dll

See Also

EndOfStreamException Members | System.IO Namespace


EndOfStreamException Members

Public:

Constructor

EndOfStreamException Constructor Overloaded. Creates a new instance of the EndOfStreamException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

EndOfStreamException Class | System.IO Namespace


EndOfStreamException Constructor

Creates a new instance of the EndOfStreamException class.

Overload List

Creates a new instance of the EndOfStreamException class with its message string set to the empty string ("") and its HRESULT set to COR_E_ENDOFSTREAM.

[Visual Basic] Overloads Public Sub New()
[C#] public EndOfStreamException();
[C++] public: EndOfStreamException();
[JScript] public function EndOfStreamException();

Creates a new instance of the EndOfStreamException class with its message string set to message and its HRESULT set to COR_E_ENDOFSTREAM.

[Visual Basic] Overloads Public Sub New(String)
[C#] public EndOfStreamException(String);
[C++] public: EndOfStreamException(String*);
[JScript] public function EndOfStreamException(String);

Creates a new instance of the EndOfStreamException class with its message string set to message and inner

and its HRESULT set to COR_E_ENDOFSTREAM.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public EndOfStreamException(String, Exception);
[C++] public: EndOfStreamException(String*, Exception);
[JScript] public function EndOfStreamException(String, Exception);

See Also

EndOfStreamException Class | EndOfStreamException Members | System.IO Namespace


EndOfStreamException Constructor ()

Creates a new instance of the EndOfStreamException class with its message string set to the empty string ("") and its HRESULT set to COR_E_ENDOFSTREAM.

[Visual Basic]
Overloads Public Sub New()
[C#]
public EndOfStreamException();
[C++]
public: EndOfStreamException();
[JScript]
public function EndOfStreamException();

See Also

EndOfStreamException Class | EndOfStreamException Members | System.IO Namespace | EndOfStreamException Constructor Overload List


EndOfStreamException Constructor (String)

Creates a new instance of the EndOfStreamException class with its message string set to message and its HRESULT set to COR_E_ENDOFSTREAM.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public EndOfStreamException(
   string message
);
[C++]
public: EndOfStreamException(
   String* message
);
[JScript]
public function EndOfStreamException(
   message : String
);

Parameters

message
The message text for the exception.

See Also

EndOfStreamException Class | EndOfStreamException Members | System.IO Namespace | EndOfStreamException Constructor Overload List


EndOfStreamException Constructor (String, Exception)

Creates a new instance of the EndOfStreamException class with its message string set to message and inner

and its HRESULT set to COR_E_ENDOFSTREAM.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public EndOfStreamException(
   string message,
   Exception inner
);
[C++]
public: EndOfStreamException(
   String* message,
   Exception* inner
);
[JScript]
public function EndOfStreamException(
   message : String,
   inner : Exception
);

Parameters

message
The message text for the exception.
inner
The exception that is the root cause of the current exception.

Remarks

When handling exceptions, it is sometimes desirable to throw another exception that is more indicative of the error that has occurred. To avoid losing the original exception and the information that it carries, exceptions can hold a reference to another exception.

See Also

EndOfStreamException Class | EndOfStreamException Members | System.IO Namespace | EndOfStreamException Constructor Overload List


File Class

Aids in the creation of FileStream objects and provides routines for the creation, copying, deletion, moving, and opening of files.

Object
FileSystemEntry
File

[Visual Basic]
NotInheritable Public Class File
   Inherits FileSystemEntry
[C#]
public sealed class File : FileSystemEntry
[C++]
public __gc __sealed class File : public FileSystemEntry
[JScript]
public class File extends FileSystemEntry

Remarks

[To be supplied.]

Requirements

Namespace: System.IO

Assembly: mscorlib.dll

See Also

File Members | System.IO Namespace


File Members

Public:

Constructor

File Constructor Creates a File object.

Properties

Attributes | Gets or sets the attributes of the current file.
CreationTime | Gets the creation time of the current file.
Directory | Creates an instance of the parent directory.
DirectoryName | Returns the name of the directory that the file is in.
Exists | Determines whether a file exists.
FullName (inherited from FileSystemEntry) | Retrieves the full path of the directory or file.
IsDirectory | Indicates whether the object is a directory.
IsFile | Indicates whether the object is a file.
LastAccessTime | Contains the time the current file or directory was last accessed.
LastWriteTime | Returns the time when the current file or directory was last written to.
Length | Contains the size of the current file or directory.
Name | Retrieves the name of the file.

Methods

AppendText | Overloaded. Creates a StreamWriter that appends text to a file.
ChangeExtension | Changes a file extension.
Copy | Overloaded. Copies an existing file to a new file.
CopyTo | Overloaded. Copies an existing file to a new file.
Create | Overloaded. Creates a file in the specified path.
CreateText | Overloaded. Creates a StreamWriter that writes a new text file.
Delete | Overloaded. Deletes a file.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FileExists | Determines whether a file exists on the specified path.
GetDirectoryNameFromPath | Returns the directory path of a file.
GetExtension | Returns the extension of the specified path.
GetFileNameFromPath | Returns the name and extension parts of the given path.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetTempFileName | Returns a unique temporary file name and creates a 0-byte file by that name on disk.
GetType (inherited from Object) | Gets the Type of the Object.
HasExtension | Determines whether a path includes a file extension.
Move | Moves a specified file to a new location and potentially a new file name. This method does work across volumes.
MoveTo | Moves a given file to a new location and potentially a new file name. This method works across volumes.
Open | Overloaded. Opens a file with various read-write and sharing privileges.
OpenRead | Overloaded. Creates a read-only Stream around a file..
OpenText | Overloaded. Creates a StreamReader that reads from an existing text file.
OpenWrite | Overloaded. Creates a read-write Stream.
Refresh | Refreshes the state of the object.
ToString | Returns the fully qualified path.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

FullPath (inherited from FileSystemEntry) Retrieves the fully qualified path of the directory.

See Also

File Class | System.IO Namespace


File Constructor

Creates a File object.

[Visual Basic]
Public Sub New( _
   ByVal fileName As String _
)
[C#]
public File(
   string fileName
);
[C++]
public: File(
   String* fileName
);
[JScript]
public function File(
   fileName : String
);

Parameters

fileName
The fully qualified name of the new file, or the relative file name. However, the security check will get the fully qualified name before doing the security check.

Exceptions

Exception Type | Condition
ArgumentNullException | filename is null.
SecurityException | The caller does not have the required permission.
ArgumentException | The file name is empty or contains only whitespaces.

Remarks

You may specify either the fully qualified or the relative file name, but the security check will get the fully qualified name before doing the security check.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Read flag required for read permission for the path on which to create the file.

See Also

File Class | File Members | System.IO Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

File Properties

The properties of the File class are listed below. For a complete list of File class members, see the File Members topic.

Public:

Attributes | Gets or sets the attributes of the current file.
CreationTime | Gets the creation time of the current file.
Directory | Creates an instance of the parent directory.
DirectoryName | Returns the name of the directory that the file is in.
Exists | Determines whether a file exists.
FullName (inherited from FileSystemEntry) | Retrieves the full path of the directory or file.
IsDirectory | Indicates whether the object is a directory.
IsFile | Indicates whether the object is a file.
LastAccessTime | Contains the time the current file or directory was last accessed.
LastWriteTime | Returns the time when the current file or directory was last written to.
Length | Contains the size of the current file or directory.
Name | Retrieves the name of the file.

See Also

File Class | System.IO Namespace


File.Attributes

Gets or sets the attributes of the current file.

[Visual Basic]
Overridable Public Property Attributes As FileSystemAttributes
[C#]
public FileSystemAttributes Attributes {override get; override
   set;}
[C++]
public: __property virtual FileSystemAttributes get_Attributes();
public: __property virtual void set_Attributes(FileSystemAttributes);
[JScript]
public function get Attributes() : FileSystemAttributes;
public function set Attributes(FileSystemAttributes);

Property Value

Current file attributes.

Exceptions

Exception Type | Condition
FileNotFoundException | The caller attempts to access a file that does not exist on disk.
SecurityException | The caller does not have the required permission.
ArgumentException | The caller attempts to set an invalid file attribute.
IOException | Refresh cannot initialize the data.

Remarks

The value of this property is a combination of the archive, compressed, directory, hidden, offline, read-only, system, and temporary file-attribute flags.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Write permission required to set the attributes for the specified file.

See Also

File Class | File Members | System.IO Namespace


File.CreationTime

Gets the creation time of the current file.

[Visual Basic]
Overridable Public ReadOnly Property CreationTime As DateTime
[C#]
public DateTime CreationTime {override get;}
[C++]
public: __property virtual DateTime get_CreationTime();
[JScript]
public function get CreationTime() : DateTime;

Property Value

The creation date and time of the current file. This value is read-only.

Exceptions

Exception Type | Condition
IOException | Refresh cannot initialize the data.

Remarks

This property value is a null reference (in Visual Basic Nothing) if the file system containing the file does not support this information.

See Also

File Class | File Members | System.IO Namespace


File.Directory

Creates an instance of the parent directory.

[Visual Basic]
Public ReadOnly Property Directory As Directory
[C#]
public Directory Directory {get;}
[C++]
public: __property Directory* get_Directory();
[JScript]
public function get Directory() : Directory;

Property Value

A Directory object representing the parent directory.

See Also

File Class | File Members | System.IO Namespace


File.DirectoryName

Returns the name of the directory that the file is in.

[Visual Basic]
Public ReadOnly Property DirectoryName As String
[C#]
public string DirectoryName {get;}
[C++]
public: __property String* get_DirectoryName();
[JScript]
public function get DirectoryName() : String;

Property Value

A string representing the file's directory name.

See Also

File Class | File Members | System.IO Namespace


File.Exists

Determines whether a file exists.

[Visual Basic]
Overridable Public ReadOnly Property Exists As Boolean
[C#]
public bool Exists {override get;}
[C++]
public: __property virtual bool get_Exists();
[JScript]
public function get Exists() : Boolean;

Property Value

true if the file exists, false if the file does not exist or if the file is a directory.

Exceptions

Exception Type | Condition
IOException | Refresh could not initialize the data.
SecurityException | The caller does not have the required permission.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Read permission for the target directory.

See Also

File Class | File Members | System.IO Namespace


File.IsDirectory

Indicates whether the object is a directory.

[Visual Basic]
Overridable Public ReadOnly Property IsDirectory As Boolean
[C#]
public bool IsDirectory {override get;}
[C++]
public: __property virtual bool get_IsDirectory();
[JScript]
public function get IsDirectory() : Boolean;

Property Value

true if the object is a directory; otherwise, false.

See Also

File Class | File Members | System.IO Namespace


File.IsFile

Indicates whether the object is a file.

[Visual Basic]
Overridable Public ReadOnly Property IsFile As Boolean
[C#]
public bool IsFile {override get;}
[C++]
public: __property virtual bool get_IsFile();
[JScript]
public function get IsFile() : Boolean;

Property Value

false if the object is not a file; otherwise, true.

See Also

File Class | File Members | System.IO Namespace


File.LastAccessTime

Contains the time the current file or directory was last accessed.

[Visual Basic]
Overridable Public ReadOnly Property LastAccessTime As DateTime
[C#]
public DateTime LastAccessTime {override get;}
[C++]
public: __property virtual DateTime get_LastAccessTime();
[JScript]
public function get LastAccessTime() : DateTime;

Property Value

The time that the current file or directory was last accessed. This value is read-only.

Exceptions

Exception Type | Condition
IOException | Refresh cannot initialize the data.

Remarks

This property value is a null reference (in Visual Basic Nothing) if the file system containing the file does not support this information.

See Also

File Class | File Members | System.IO Namespace


File.LastWriteTime

Returns the time when the current file or directory was last written to.

[Visual Basic]
Overridable Public ReadOnly Property LastWriteTime As DateTime
[C#]
public DateTime LastWriteTime {override get;}
[C++]
public: __property virtual DateTime get_LastWriteTime();
[JScript]
public function get LastWriteTime() : DateTime;

Property Value

Read-only. The time the current file was last written.

Exceptions

Exception Type | Condition
IOException | Refresh cannot initialize the data.

Remarks

This property value is a null reference (in Visual Basic Nothing) if the file system containing the file does not support this information.

See Also

File Class | File Members | System.IO Namespace


File.Length

Contains the size of the current file or directory.

[Visual Basic]
Public ReadOnly Property Length As Long
[C#]
public long Length {get;}
[C++]
public: __property __int64 get_Length();
[JScript]
public function get Length() : long;

Property Value

Read-only. The size of the current file.

Exceptions

Exception Type | Condition
IOException | Refresh cannot initialize the data.

Remarks

This property value is a null reference (in Visual Basic Nothing) if the file system containing the file does not support this information.

See Also

File Class | File Members | System.IO Namespace


File.Name

Retrieves the name of the file.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {override get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

Property Value

The name of the file. This value is read-only.

See Also

File Class | File Members | System.IO Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

File Methods

The methods of the File class are listed below. For a complete list of File class members, see the File Members topic.

Public:

AppendText | Overloaded. Creates a StreamWriter that appends text to a file.
ChangeExtension | Changes a file extension.
Copy | Overloaded. Copies an existing file to a new file.
CopyTo | Overloaded. Copies an existing file to a new file.
Create | Overloaded. Creates a file in the specified path.
CreateText | Overloaded. Creates a StreamWriter that writes a new text file.
Delete | Overloaded. Deletes a file.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FileExists | Determines whether a file exists on the specified path.
GetDirectoryNameFromPath | Returns the directory path of a file.
GetExtension | Returns the extension of the specified path.
GetFileNameFromPath | Returns the name and extension parts of the given path.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetTempFileName | Returns a unique temporary file name and creates a 0-byte file by that name on disk.
GetType (inherited from Object) | Gets the Type of the Object.
HasExtension | Determines whether a path includes a file extension.
Move | Moves a specified file to a new location and potentially a new file name. This method does work across volumes.
MoveTo | Moves a given file to a new location and potentially a new file name. This method works across volumes.
Open | Overloaded. Opens a file with various read-write and sharing privileges.
OpenRead | Overloaded. Creates a read-only Stream around a file..
OpenText | Overloaded. Creates a StreamReader that reads from an existing text file.
OpenWrite | Overloaded. Creates a read-write Stream.
Refresh | Refreshes the state of the object.
ToString | Returns the fully qualified path.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

File Class | System.IO Namespace


File.AppendText

Creates a StreamWriter that appends text to a file.

Overload List

Creates a StreamWriter that appends text to a file on the specified path.

[Visual Basic] Overloads Public Shared Function AppendText(String) As StreamWriter
[C#] public static StreamWriter AppendText(String);
[C++] public: static StreamWriter* AppendText(String*);
[JScript] public static function AppendText(String) : StreamWriter;

Creates a StreamWriter that appends text to a file.

[Visual Basic] Overloads Public Function AppendText() As StreamWriter
[C#] public StreamWriter AppendText();
[C++] public: StreamWriter* AppendText();
[JScript] public function AppendText() : StreamWriter;

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Append permission to the path.

See Also

File Class | File Members | System.IO Namespace


File.AppendText (String)

Creates a StreamWriter that appends text to a file on the specified path.

[Visual Basic]
Overloads Public Shared Function AppendText( _
   ByVal path As String _
) As StreamWriter
[C#]
public static StreamWriter AppendText(
   string path
);
[C++]
public: static StreamWriter* AppendText(
   String* path
);
[JScript]
public static function AppendText(
   path : String
) : StreamWriter;

Parameters

path
The path of the file to append to.

Return Value

A new StreamWriter.

Exceptions

Exception Type | Condition
ArgumentNullException | path is a null reference (in Visual Basic Nothing).
SecurityException | The caller does not have the required permission.
ArgumentException | The file name is empty or contains only whitespaces.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Append permission to the path.

See Also

File Class | File Members | System.IO Namespace | File.AppendText Overload List


File.AppendText ()

Creates a StreamWriter that appends text to a file.

[Visual Basic]
Overloads Public Function AppendText() As StreamWriter
[C#]
public StreamWriter AppendText();
[C++]
public: StreamWriter* AppendText();
[JScript]
public function AppendText() : StreamWriter;

See Also

File Class | File Members | System.IO Namespace | File.AppendText Overload List


File.ChangeExtension

Changes a file extension.

[Visual Basic]
Public Shared Function ChangeExtension( _
   ByVal path As String, _
   ByVal extension As String _
) As String
[C#]
public static string ChangeExtension(
   string path,
   string extension
);
[C++]
public: static String* ChangeExtension(
   String* path,
   String* extension
);
[JScript]
public static function ChangeExtension(
   path : String,
   extension : String
) : String;

Parameters

path
The path of the file.
extension
The new file extension (with a leading period), or null to remove the extension.

Return Value

Path with the new file extension.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.
SecurityException | The caller does not have the required permission.
ArgumentException | The file name is empty or contains only whitespaces.

Remarks

The path parameter specifies a file path, and the extension parameter specifies a file extension (with a leading period, such as ".exe" or ".cs").

The function returns a file path with the same root, directory, and base name parts as path, but with the file extension changed to the specified extension. If path is null, the function returns null. If path does not contain a file extension, the new file extension is appended to the path. If extension is null, any existing extension is removed from path.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Write permission to the file.

See Also

File Class | File Members | System.IO Namespace


File.Copy

Copies an existing file to a new file.

Overload List

Copies an existing file to a new file, allowing an existing file to be overwritten.

[Visual Basic] Overloads Public Shared Sub Copy(String, String, Boolean)
[C#] public static void Copy(String, String, bool);
[C++] public: static void Copy(String*, String*, bool);
[JScript] public static function Copy(String, String, Boolean);

Copies an existing file to a new file, not allowing an existing file to be overwritten.

[Visual Basic] Overloads Public Shared Sub Copy(String, String)
[C#] public static void Copy(String, String);
[C++] public: static void Copy(String*, String*);
[JScript] public static function Copy(String, String);

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Write permission required to the destination path.

See Also

File Class | File Members | System.IO Namespace


File.Copy (String, String, Boolean)

Copies an existing file to a new file, allowing an existing file to be overwritten.

[Visual Basic]
Overloads Public Shared Sub Copy( _
   ByVal sourceFileName As String, _
   ByVal destFileName As String, _
   ByVal overwrite As Boolean _
)
[C#]
public static void Copy(
   string sourceFileName,
   string destFileName,
   bool overwrite
);
[C++]
public: static void Copy(
   String* sourceFileName,
   String* destFileName,
   bool overwrite
);
[JScript]
public static function Copy(
   sourceFileName : String,
   destFileName : String,
   overwrite : Boolean
);

Parameters

sourceFileName
The name of the file to copy.
destFileName
The name of the new file to copy to.
overwrite
true if the destination file is to be overwritten, false otherwise.

Exceptions

Exception Type | Condition
ArgumentNullException | sourceFileName or destFileName is a null reference (in Visual Basic Nothing).
ArgumentException | sourceFileName or destFileName is an empty string ("") or contains only whitespaces.
IOException | An error occurs or the destination file already exists and overwrite is false.
SecurityException | The caller does not have the required permission.
FileNotFoundException | sourceFileName or destFileName cannot be found.

Remarks

Copy is a static method while CopyTo is an instance method. For CopyTo, you must have created a File object, which stores the source file name. Copy allows the specifying of a source file name without having to create a File object.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Write permission required to the destination path.

See Also

File Class | File Members | System.IO Namespace | File.Copy Overload List


File.Copy (String, String)

Copies an existing file to a new file, not allowing an existing file to be overwritten.

[Visual Basic]
Overloads Public Shared Sub Copy( _
   ByVal sourceFileName As String, _
   ByVal destFileName As String _
)
[C#]
public static void Copy(
   string sourceFileName,
   string destFileName
);
[C++]
public: static void Copy(
   String* sourceFileName,
   String* destFileName
);
[JScript]
public static function Copy(
   sourceFileName : String,
   destFileName : String
);

Parameters

sourceFileName
The name of the file to copy.
destFileName
The name of the new file to copy to.

Exceptions

Exception Type | Condition
ArgumentException | sourceFileName or destFileName is an empty string ("") or contains only whitespaces.
ArgumentNullException | sourceFileName or destFileName is a null reference (in Visual Basic Nothing).
IOException | An error occurs, or the destination file already exists.
SecurityException | The caller does not have the required permission.
FileNotFoundException | sourceFileName cannot be found.

Remarks

Copy is a static method while CopyTo is an instance method. For CopyTo, you must have created a File object, which stores the source file name. Copy allows the specifying of a source file name without having to create a File object.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Write permission required for the destination path.

See Also

File Class | File Members | System.IO Namespace | File.Copy Overload List


File.CopyTo

Copies an existing file to a new file.

Overload List

Copies an existing file to a new file, disallowing the overwriting of an existing file.

[Visual Basic] Overloads Public Function CopyTo(String) As File
[C#] public File CopyTo(String);
[C++] public: File* CopyTo(String*);
[JScript] public function CopyTo(String) : File;

Copies an existing file to a new file, allowing the overwriting of an existing file.

[Visual Basic] Overloads Public Function CopyTo(String, Boolean) As File
[C#] public File CopyTo(String, bool);
[C++] public: File* CopyTo(String*, bool);
[JScript] public function CopyTo(String, Boolean) : File;

Requirements

NGWS Runtime Security:

FileIOPermissionAccess | Read permission required for the source file.
FileIOPermissionAccess | Write permission required for the destination file.

See Also

File Class | File Members | System.IO Namespace


File.CopyTo (String)

Copies an existing file to a new file, disallowing the overwriting of an existing file.

[Visual Basic]
Overloads Public Function CopyTo( _
   ByVal destFileName As String _
) As File
[C#]
public File CopyTo(
   string destFileName
);
[C++]
public: File* CopyTo(
   String* destFileName
);
[JScript]
public function CopyTo(
   destFileName : String
) : File;

Parameters

destFileName
The name of the new file to copy to.

Return Value

A new file with a fully qualified path.

Exceptions

Exception Type | Condition
ArgumentException | The name of the source file, the destination file, or both is an empty string ("") or is all whitespaces.
IOException | An error occurs or the destination file already exists.
SecurityException | The caller does not have the required permission.
ArgumentNullException | The name of the source file, the destination file, or both is a null reference (in Visual Basic Nothing).

Remarks

Copy is a static method while CopyTo is an instance method. For CopyTo, you must have created a File object, which stores the source file name. Copy allows the specifying of a source file name without having to create a File object.

Use the Copy(string, string, bool) method to allow overwriting of an existing file.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess | Read permission required for the source file.
FileIOPermissionAccess | Write permission required for the destination file.

See Also

File Class | File Members | System.IO Namespace | File.CopyTo Overload List


File.CopyTo (String, Boolean)

Copies an existing file to a new file, allowing the overwriting of an existing file.

[Visual Basic]
Overloads Public Function CopyTo( _
   ByVal destFileName As String, _
   ByVal overwrite As Boolean _
) As File
[C#]
public File CopyTo(
   string destFileName,
   bool overwrite
);
[C++]
public: File* CopyTo(
   String* destFileName,
   bool overwrite
);
[JScript]
public function CopyTo(
   destFileName : String,
   overwrite : Boolean
) : File;

Parameters

destFileName
The name of the new file to copy to.
overwrite
true if an existing file may be overwritten, false otherwise.

Return Value

A new file, or an overwrite of an existing file.

Exceptions

Exception Type | Condition
ArgumentException | The name of the source file, the destination file, or both an empty string ("") or is all whitespaces.
IOException | An error occurs or the destination file already exists and overwrite is false.
SecurityException | The caller does not have the required permission.
ArgumentNullException | The name of the source file, the destination file, or both is a null reference (in Visual Basic Nothing).

Remarks

Copy is a static method while CopyTo is an instance method. For CopyTo, you must have created a File object, which stores the source file name. Copy allows the specifying of a source file name without having to create a File object.

Use the Copy(string, string, bool) method to allow overwriting of an existing file.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess | Read permission required for the source file.
FileIOPermissionAccess | Write permission required for the destination file.

See Also

File Class | File Members | System.IO Namespace | File.CopyTo Overload List


File.Create

Creates a file in the specified path.

Overload List

Creates a file in the specified path.

[Visual Basic] Overloads Public Shared Function Create(String) As Stream
[C#] public static Stream Create(String);
[C++] public: static Stream* Create(String*);
[JScript] public static function Create(String) : Stream;

Creates a file in the specified path and having the specified buffer size.

[Visual Basic] Overloads Public Shared Function Create(String, Integer) As Stream
[C#] public static Stream Create(String, int);
[C++] public: static Stream* Create(String*, int);
[JScript] public static function Create(String, int) : Stream;

See Also

File Class | File Members | System.IO Namespace


File.Create (String)

Creates a file in the specified path.

[Visual Basic]
Overloads Public Shared Function Create( _
   ByVal path As String _
) As Stream
[C#]
public static Stream Create(
   string path
);
[C++]
public: static Stream* Create(
   String* path
);
[JScript]
public static function Create(
   path : String
) : Stream;

Parameters

path
Path and name of file to create.

Return Value

A new file.

Exceptions

Exception Type | Condition
IOException | The directory specified in

See Also

File Class | File Members | System.IO Namespace | File.Create Overload List


File.Create (String, Int32)

Creates a file in the specified path and having the specified buffer size.

[Visual Basic]
Overloads Public Shared Function Create( _
   ByVal path As String, _
   ByVal bufferSize As Integer _
) As Stream
[C#]
public static Stream Create(
   string path,
   int bufferSize
);
[C++]
public: static Stream* Create(
   String* path,
   int bufferSize
);
[JScript]
public static function Create(
   path : String,
   bufferSize : int
) : Stream;

Parameters

path
Path and name of file to create.
bufferSize
Size for the file stream's buffer. Must be greater than 0.

Return Value

A new file with the specified buffer size.

Exceptions

Exception Type | Condition
IOException | The directory specified in

See Also

File Class | File Members | System.IO Namespace | File.Create Overload List


File.CreateText

Creates a StreamWriter that writes a new text file.

Overload List

Creates a StreamWriter that writes a new text file.

[Visual Basic] Overloads Public Function CreateText() As StreamWriter
[C#] public StreamWriter CreateText();
[C++] public: StreamWriter* CreateText();
[JScript] public function CreateText() : StreamWriter;

Creates a StreamWriter that writes a new text file on the specified path.

[Visual Basic] Overloads Public Shared Function CreateText(String) As StreamWriter
[C#] public static StreamWriter CreateText(String);
[C++] public: static StreamWriter* CreateText(String*);
[JScript] public static function CreateText(String) : StreamWriter;

See Also

File Class | File Members | System.IO Namespace


File.CreateText ()

Creates a StreamWriter that writes a new text file.

[Visual Basic]
Overloads Public Function CreateText() As StreamWriter
[C#]
public StreamWriter CreateText();
[C++]
public: StreamWriter* CreateText();
[JScript]
public function CreateText() : StreamWriter;

Return Value

A new StreamWriter.

See Also

File Class | File Members | System.IO Namespace | File.CreateText Overload List


File.CreateText (String)

Creates a StreamWriter that writes a new text file on the specified path.

[Visual Basic]
Overloads Public Shared Function CreateText( _
   ByVal path As String _
) As StreamWriter
[C#]
public static StreamWriter CreateText(
   string path
);
[C++]
public: static StreamWriter* CreateText(
   String* path
);
[JScript]
public static function CreateText(
   path : String
) : StreamWriter;

Parameters

path
The path to write the text file to.

Return Value

A new StreamWriter.

Exceptions

Exception Type | Condition
ArgumentNullException | path is a null reference (in Visual Basic Nothing).
SecurityException | The caller does not have the required permission.
ArgumentException | The file name is empty or contains only whitespaces.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Read permission to the path.

See Also

File Class | File Members | System.IO Namespace | File.CreateText Overload List


File.Delete

Deletes a file.

Overload List

Deletes the file specified by the fully qualified path. An exception is not thrown if the specified file does not exist.

[Visual Basic] Overloads Public Shared Sub Delete(String)
[C#] public static void Delete(String);
[C++] public: static void Delete(String*);
[JScript] public static function Delete(String);

Deletes a file.

[Visual Basic] Overloads Overrides Public Sub Delete()
[C#] public override void Delete();
[C++] public: override void Delete();
[JScript] public override function Delete();

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Write permission to the path.

See Also

File Class | File Members | System.IO Namespace


File.Delete (String)

Deletes the file specified by the fully qualified path. An exception is not thrown if the specified file does not exist.

[Visual Basic]
Overloads Public Shared Sub Delete( _
   ByVal path As String _
)
[C#]
public static void Delete(
   string path
);
[C++]
public: static void Delete(
   String* path
);
[JScript]
public static function Delete(
   path : String
);

Parameters

path
The path of the file to be deleted.

Exceptions

Exception Type | Condition
ArgumentNullException | path is a null reference (in Visual Basic Nothing).
IOException | The target file is open or memory mapped on a machine running Windows NT.
SecurityException | The caller does not have the required permission.
ArgumentException | path is empty or contains only whitespaces.

Remarks

On a machine running Windows NT, Delete will fail for a file that is open for normal I/O or a file that is memory mapped. On Win95, the file will be deleted even if the file is in use.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Write permission to the path.

See Also

File Class | File Members | System.IO Namespace | File.Delete Overload List


File.Delete ()

Deletes a file.

[Visual Basic]
Overloads Overrides Public Sub Delete()
[C#]
public override void Delete();
[C++]
public: override void Delete();
[JScript]
public override function Delete();

Exceptions

Exception Type | Condition
ArgumentNullException | path is a null reference (in Visual Basic Nothing).
IOException | The target file is open or memory mapped on a machine running Windows NT.
SecurityException | The caller does not have the required permission.

Remarks

On a machine running Windows NT, Delete will fail for a file that is open for normal I/O or a file that is memory mapped. On Win95, the file will be deleted even if the file is in use.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Write permission to the path.

See Also

File Class | File Members | System.IO Namespace | File.Delete Overload List


File.FileExists

Determines whether a file exists on the specified path.

[Visual Basic]
Public Shared Function FileExists( _
   ByVal path As String _
) As Boolean
[C#]
public static bool FileExists(
   string path
);
[C++]
public: static bool FileExists(
   String* path
);
[JScript]
public static function FileExists(
   path : String
) : Boolean;

Parameters

path
The path to search for the file.

Return Value

true if the file given by the specified path exists, false if the file does not exist or if path specifies a directory.

Exceptions

Exception Type | Condition
ArgumentException | path is the empty string ("") or contains only whitespaces.
ArgumentNullException | path is null.
IOException | path is invalid or an I/O error occurs (for example, a disk error).
SecurityException | The caller does not have the required permission.

Remarks

path can be either relative or absolute. A relative file path will be fully qualified based upon the current directory and drive.

If path describes a directory, this method returns false.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Read permission for the target directory.

See Also

File Class | File Members | System.IO Namespace


File.GetDirectoryNameFromPath

Returns the directory path of a file.

[Visual Basic]
Public Shared Function GetDirectoryNameFromPath( _
   ByVal path As String _
) As String
[C#]
public static string GetDirectoryNameFromPath(
   string path
);
[C++]
public: static String* GetDirectoryNameFromPath(
   String* path
);
[JScript]
public static function GetDirectoryNameFromPath(
   path : String
) : String;

Parameters

path
The path of a file or directory.

Return Value

The directory path of the given path, or a null reference (in Visual Basic Nothing) if the given path denotes a root.

Exceptions

Exception Type | Condition
ArgumentException | path contains invalid characters.
ArgumentException | path is empty or contains only whitespaces.

Remarks

This method effectively removes the last element of the given file path, returning a string consisting of all characters up to but not including the last backslash ("\") in the file path. The returned value is null if the file path is null or if the file path denotes a root (such as "\", "C:", or "\\server\share").

See Also

File Class | File Members | System.IO Namespace


File.GetExtension

Returns the extension of the specified path.

[Visual Basic]
Public Shared Function GetExtension( _
   ByVal path As String _
) As String
[C#]
public static string GetExtension(
   string path
);
[C++]
public: static String* GetExtension(
   String* path
);
[JScript]
public static function GetExtension(
   path : String
) : String;

Parameters

path
The path of a file or directory.

Return Value

The extension of the specified path (including the "."), or Empty.

Exceptions

Exception Type | Condition
ArgumentNullException | path is a null reference (in Visual Basic Nothing).
ArgumentException | path is empty or contains only whitespaces.

Remarks

The extension is obtained by searching backwards within path for the "." character. If "." is matched before Environment.DirectorySeparatorChar, Environment.AltDirectorySeparatorChar, or Environment.VolumeSeparatorChar is encountered, then the "." and the characters following the "." are returned as the result. Otherwise, Empty is returned.

The returned value includes the period (".") character of the extension, such as ".exe" or ".cpp".

See Also

File Class | File Members | System.IO Namespace


File.GetFileNameFromPath

Returns the name and extension parts of the given path.

[Visual Basic]
Public Shared Function GetFileNameFromPath( _
   ByVal path As String _
) As String
[C#]
public static string GetFileNameFromPath(
   string path
);
[C++]
public: static String* GetFileNameFromPath(
   String* path
);
[JScript]
public static function GetFileNameFromPath(
   path : String
) : String;

Parameters

path
The path of a file or directory.

Return Value

The name and extension parts of the given path.

Exceptions

Exception Type | Condition
ArgumentException | path is empty or contains only whitespaces.

See Also

File Class | File Members | System.IO Namespace


File.GetTempFileName

Returns a unique temporary file name and creates a 0-byte file by that name on disk.

[Visual Basic]
Public Shared Function GetTempFileName() As String
[C#]
public static string GetTempFileName();
[C++]
public: static String* GetTempFileName();
[JScript]
public static function GetTempFileName() : String;

Return Value

The name of the temporary file.

Remarks

See Also

File Class | File Members | System.IO Namespace


File.HasExtension

Determines whether a path includes a file extension.

[Visual Basic]
Public Shared Function HasExtension( _
   ByVal path As String _
) As Boolean
[C#]
public static bool HasExtension(
   string path
);
[C++]
public: static bool HasExtension(
   String* path
);
[JScript]
public static function HasExtension(
   path : String
) : Boolean;

Parameters

path
The path to test.

Return Value

true if the characters that follow the last directory separator ("\\" or "/") or volume separator (":") in the path include a period ("."), false otherwise.

Exceptions

Exception Type | Condition
ArgumentException | path is empty or contains only whitespaces.

Remarks

The return value is determined by searching backwards for "." within path. If "." is matched before Environment.DirectorySeparatorChar, Environment.AltDirectorySeparatorChar, or Environment.VolumeSeparatorChar is encountered, then true is returned. Otherwise, false is returned.

See Also

File Class | File Members | System.IO Namespace


File.Move

Moves a specified file to a new location and potentially a new file name. This method does work across volumes.

[Visual Basic]
Public Shared Sub Move( _
   ByVal sourceFileName As String, _
   ByVal destFileName As String _
)
[C#]
public static void Move(
   string sourceFileName,
   string destFileName
);
[C++]
public: static void Move(
   String* sourceFileName,
   String* destFileName
);
[JScript]
public static function Move(
   sourceFileName : String,
   destFileName : String
);

Parameters

sourceFileName
The name of the file to be copied.
destFileName
The name of the new file to copy to.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs or the destination file already exists.
ArgumentNullException | sourceFileName or destFileName is a null reference (in Visual Basic Nothing).
ArgumentException | sourceFileName or destFileName is an empty string ("") or contains only whitespaces.
SecurityException | The caller does not have the required permission.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Read and write permission to the path.

See Also

File Class | File Members | System.IO Namespace


File.MoveTo

Moves a given file to a new location and potentially a new file name. This method works across volumes.

[Visual Basic]
Public Sub MoveTo( _
   ByVal destFileName As String _
)
[C#]
public void MoveTo(
   string destFileName
);
[C++]
public: void MoveTo(
   String* destFileName
);
[JScript]
public function MoveTo(
   destFileName : String
);

Parameters

destFileName
The name of the new file to copy to.

Exceptions

Exception Type | Condition
ArgumentNullException | destFileName is a null reference (in Visual Basic Nothing).
ArgumentException | destFileName is an empty string ("") or contains only whitespaces.
IOException | An error occurs or the destination file already exists.
SecurityException | The caller does not have the required permission.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess | Read permission for the current File object.
FileIOPermissionAccess | Write permission for the current File object and destination file.

See Also

File Class | File Members | System.IO Namespace


File.Open

Opens a file with various read-write and sharing privileges.

Overload List

Opens a file on the specified path, with the specified mode and access.

[Visual Basic] Overloads Public Function Open(String, FileMode, FileAccess) As Stream
[C#] public Stream Open(String, FileMode, FileAccess);
[C++] public: Stream* Open(String*, FileMode, FileAccess);
[JScript] public function Open(String, FileMode, FileAccess) : Stream;

Opens a file in the specified mode with read, write, or read/write access and the specified sharing option.

[Visual Basic] Overloads Public Function Open(FileMode, FileAccess, FileShare) As Stream
[C#] public Stream Open(FileMode, FileAccess, FileShare);
[C++] public: Stream* Open(FileMode, FileAccess, FileShare);
[JScript] public function Open(FileMode, FileAccess, FileShare) : Stream;

Opens a file on the specified path, having the specified mode with read, write, or read/write access and the specified sharing option.

[Visual Basic] Overloads Public Shared Function Open(String, FileMode, FileAccess, FileShare) As Stream
[C#] public static Stream Open(String, FileMode, FileAccess, FileShare);
[C++] public: static Stream* Open(String*, FileMode, FileAccess, FileShare);
[JScript] public static function Open(String, FileMode, FileAccess, FileShare) : Stream;

Opens a file in the specified mode with read, write, or read/write access.

[Visual Basic] Overloads Public Function Open(FileMode, FileAccess) As Stream
[C#] public Stream Open(FileMode, FileAccess);
[C++] public: Stream* Open(FileMode, FileAccess);
[JScript] public function Open(FileMode, FileAccess) : Stream;

Opens a file in the specified mode.

[Visual Basic] Overloads Public Function Open(FileMode) As Stream
[C#] public Stream Open(FileMode);
[C++] public: Stream* Open(FileMode);
[JScript] public function Open(FileMode) : Stream;

Opens a file on the specified path and in the specified mode.

[Visual Basic] Overloads Public Shared Function Open(String, FileMode) As Stream
[C#] public static Stream Open(String, FileMode);
[C++] public: static Stream* Open(String*, FileMode);
[JScript] public static function Open(String, FileMode) : Stream;

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Read permission to the path.

See Also

File Class | File Members | System.IO Namespace


File.Open (String, FileMode, FileAccess)

Opens a file on the specified path, with the specified mode and access.

[Visual Basic]
Overloads Public Function Open( _
   ByVal path As String, _
   ByVal mode As FileMode, _
   ByVal access As FileAccess _
) As Stream
[C#]
public Stream Open(
   string path,
   FileMode mode,
   FileAccess access
);
[C++]
public: Stream* Open(
   String* path,
   FileMode mode,
   FileAccess access
);
[JScript]
public function Open(
   path : String,
   mode : FileMode,
   access : FileAccess
) : Stream;

Parameters

path
[To be supplied.]
mode
[To be supplied.]
access
[To be supplied.]

Return Value

An unshared file on the specified path, with the specified mode and access.

Exceptions

Exception Type | Condition
SecurityException | The caller does not have the required permission.
ArgumentException | path is empty or contains only whitespaces.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Read permission to the path.

See Also

File Class | File Members | System.IO Namespace | File.Open Overload List


File.Open (FileMode, FileAccess, FileShare)

Opens a file in the specified mode with read, write, or read/write access and the specified sharing option.

[Visual Basic]
Overloads Public Function Open( _
   ByVal mode As FileMode, _
   ByVal access As FileAccess, _
   ByVal share As FileShare _
) As Stream
[C#]
public Stream Open(
   FileMode mode,
   FileAccess access,
   FileShare share
);
[C++]
public: Stream* Open(
   FileMode mode,
   FileAccess access,
   FileShare share
);
[JScript]
public function Open(
   mode : FileMode,
   access : FileAccess,
   share : FileShare
) : Stream;

Parameters

mode
One of the six FileMode constants.
access
One of the three FileAccess constants.
share
One of the four FileShare constants.

Return Value

A FileStream opened with the specified mode, access, sharing options.

Exceptions

Exception Type | Condition
SecurityException | The caller does not have the required permission.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Read permission to the path.

See Also

File Class | File Members | System.IO Namespace | File.Open Overload List


File.Open (String, FileMode, FileAccess, FileShare)

Opens a file on the specified path, having the specified mode with read, write, or read/write access and the specified sharing option.

[Visual Basic]
Overloads Public Shared Function Open( _
   ByVal path As String, _
   ByVal mode As FileMode, _
   ByVal access As FileAccess, _
   ByVal share As FileShare _
) As Stream
[C#]
public static Stream Open(
   string path,
   FileMode mode,
   FileAccess access,
   FileShare share
);
[C++]
public: static Stream* Open(
   String* path,
   FileMode mode,
   FileAccess access,
   FileShare share
);
[JScript]
public static function Open(
   path : String,
   mode : FileMode,
   access : FileAccess,
   share : FileShare
) : Stream;

Parameters

path
[To be supplied.]
mode
[To be supplied.]
access
[To be supplied.]
share
[To be supplied.]

Return Value

A file on the specified path, having the specified mode with read, write, or read/write access and the specified sharing option.

Exceptions

Exception Type | Condition
SecurityException | The caller does not have the required permission.
ArgumentException | path is empty or contains only whitespaces.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Read permission to the path.

See Also

File Class | File Members | System.IO Namespace | File.Open Overload List


File.Open (FileMode, FileAccess)

Opens a file in the specified mode with read, write, or read/write access.

[Visual Basic]
Overloads Public Function Open( _
   ByVal mode As FileMode, _
   ByVal access As FileAccess _
) As Stream
[C#]
public Stream Open(
   FileMode mode,
   FileAccess access
);
[C++]
public: Stream* Open(
   FileMode mode,
   FileAccess access
);
[JScript]
public function Open(
   mode : FileMode,
   access : FileAccess
) : Stream;

Parameters

mode
One of the six FileMode constants.
access
One of the three FileAccess constants.

Return Value

A file opened in the specified mode and access, and unshared.

Exceptions

Exception Type | Condition
SecurityException | The caller does not have the required permission.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Read permission to the path.

See Also

File Class | File Members | System.IO Namespace | File.Open Overload List


File.Open (FileMode)

Opens a file in the specified mode.

[Visual Basic]
Overloads Public Function Open( _
   ByVal mode As FileMode _
) As Stream
[C#]
public Stream Open(
   FileMode mode
);
[C++]
public: Stream* Open(
   FileMode mode
);
[JScript]
public function Open(
   mode : FileMode
) : Stream;

Parameters

mode
One of the six FileMode constants.

Return Value

A file opened in the specified mode, with read/write access and unshared.

See Also

File Class | File Members | System.IO Namespace | File.Open Overload List


File.Open (String, FileMode)

Opens a file on the specified path and in the specified mode.

[Visual Basic]
Overloads Public Shared Function Open( _
   ByVal path As String, _
   ByVal mode As FileMode _
) As Stream
[C#]
public static Stream Open(
   string path,
   FileMode mode
);
[C++]
public: static Stream* Open(
   String* path,
   FileMode mode
);
[JScript]
public static function Open(
   path : String,
   mode : FileMode
) : Stream;

Parameters

path
[To be supplied.]
mode
[To be supplied.]

Return Value

A file opened in the specified mode and path, with read/write access and unshared.

Exceptions

Exception Type | Condition
SecurityException | The caller does not have the required permission.
ArgumentException | path is empty or contains only whitespaces.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Read permission to the path.

See Also

File Class | File Members | System.IO Namespace | File.Open Overload List


File.OpenRead

Creates a read-only Stream around a file..

Overload List

Creates a read-only FileStream.

[Visual Basic] Overloads Public Function OpenRead() As Stream
[C#] public Stream OpenRead();
[C++] public: Stream* OpenRead();
[JScript] public function OpenRead() : Stream;

Creates a read-only FileStream on the specified path.

[Visual Basic] Overloads Public Shared Function OpenRead(String) As Stream
[C#] public static Stream OpenRead(String);
[C++] public: static Stream* OpenRead(String*);
[JScript] public static function OpenRead(String) : Stream;

See Also

File Class | File Members | System.IO Namespace


File.OpenRead ()

Creates a read-only FileStream.

[Visual Basic]
Overloads Public Function OpenRead() As Stream
[C#]
public Stream OpenRead();
[C++]
public: Stream* OpenRead();
[JScript]
public function OpenRead() : Stream;

Return Value

A reference to a new read-only Stream object.

See Also

File Class | File Members | System.IO Namespace | File.OpenRead Overload List


File.OpenRead (String)

Creates a read-only FileStream on the specified path.

[Visual Basic]
Overloads Public Shared Function OpenRead( _
   ByVal path As String _
) As Stream
[C#]
public static Stream OpenRead(
   string path
);
[C++]
public: static Stream* OpenRead(
   String* path
);
[JScript]
public static function OpenRead(
   path : String
) : Stream;

Parameters

path
The path of the new FileStream object.

Return Value

A reference to a new read-only Stream object on the specified path.

Exceptions

Exception Type | Condition
SecurityException | The caller does not have the required permission.
ArgumentException | path is empty or contains only whitespaces.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Read permission to the path.

See Also

File Class | File Members | System.IO Namespace | File.OpenRead Overload List


File.OpenText

Creates a StreamReader that reads from an existing text file.

Overload List

Creates a StreamReader that reads from an existing text file.

[Visual Basic] Overloads Public Function OpenText() As StreamReader
[C#] public StreamReader OpenText();
[C++] public: StreamReader* OpenText();
[JScript] public function OpenText() : StreamReader;

Creates a StreamReader that reads from an existing text file having the specified path.

[Visual Basic] Overloads Public Shared Function OpenText(String) As StreamReader
[C#] public static StreamReader OpenText(String);
[C++] public: static StreamReader* OpenText(String*);
[JScript] public static function OpenText(String) : StreamReader;

See Also

File Class | File Members | System.IO Namespace


File.OpenText ()

Creates a StreamReader that reads from an existing text file.

[Visual Basic]
Overloads Public Function OpenText() As StreamReader
[C#]
public StreamReader OpenText();
[C++]
public: StreamReader* OpenText();
[JScript]
public function OpenText() : StreamReader;

Return Value

A new StreamReader.

See Also

File Class | File Members | System.IO Namespace | File.OpenText Overload List


File.OpenText (String)

Creates a StreamReader that reads from an existing text file having the specified path.

[Visual Basic]
Overloads Public Shared Function OpenText( _
   ByVal path As String _
) As StreamReader
[C#]
public static StreamReader OpenText(
   string path
);
[C++]
public: static StreamReader* OpenText(
   String* path
);
[JScript]
public static function OpenText(
   path : String
) : StreamReader;

Parameters

path
The fully qualified path to the text file.

Return Value

A new StreamReader.

Exceptions

Exception Type | Condition
ArgumentNullException | path is a null reference (in Visual Basic Nothing).
SecurityException | The caller does not have the required permission.
ArgumentException | The file name is empty or contains only whitespaces.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Read permission to the path.

See Also

File Class | File Members | System.IO Namespace | File.OpenText Overload List


File.OpenWrite

Creates a read-write Stream.

Overload List

Creates a read-write Stream on the specified path.

[Visual Basic] Overloads Public Shared Function OpenWrite(String) As Stream
[C#] public static Stream OpenWrite(String);
[C++] public: static Stream* OpenWrite(String*);
[JScript] public static function OpenWrite(String) : Stream;

Creates a read-write FileStream.

[Visual Basic] Overloads Public Function OpenWrite() As Stream
[C#] public Stream OpenWrite();
[C++] public: Stream* OpenWrite();
[JScript] public function OpenWrite() : Stream;

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Write permission to the path.

See Also

File Class | File Members | System.IO Namespace


File.OpenWrite (String)

Creates a read-write Stream on the specified path.

[Visual Basic]
Overloads Public Shared Function OpenWrite( _
   ByVal path As String _
) As Stream
[C#]
public static Stream OpenWrite(
   string path
);
[C++]
public: static Stream* OpenWrite(
   String* path
);
[JScript]
public static function OpenWrite(
   path : String
) : Stream;

Parameters

path
The path of the new read-write Stream.

Return Value

A reference to a new read-write, unshared Stream object on the specified path.

Exceptions

Exception Type | Condition
SecurityException | The caller does not have the required permission.
ArgumentException | path is empty or contains only whitespaces.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess Write permission to the path.

See Also

File Class | File Members | System.IO Namespace | File.OpenWrite Overload List


File.OpenWrite ()

Creates a read-write FileStream.

[Visual Basic]
Overloads Public Function OpenWrite() As Stream
[C#]
public Stream OpenWrite();
[C++]
public: Stream* OpenWrite();
[JScript]
public function OpenWrite() : Stream;

Return Value

A reference to a new read-write, unshared Stream object.

See Also

File Class | File Members | System.IO Namespace | File.OpenWrite Overload List


File.Refresh

Refreshes the state of the object.

[Visual Basic]
Overrides Public Sub Refresh()
[C#]
public override void Refresh();
[C++]
public: override void Refresh();
[JScript]
public override function Refresh();

Exceptions

Exception Type | Condition
ArgumentException | The file is not found.
IOException | A device such as a disk drive is not ready.

Remarks

To avoid caching outdated information, call Refresh before attempting to get CreationTime, LastAccessTime, LastWriteTime or Attributes.

See Also

File Class | File Members | System.IO Namespace


File.ToString

Returns the fully qualified path.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

A string representing the full path.

Remarks

See Also

File Class | File Members | System.IO Namespace


FileAccess Enumeration

Allows read, write, or read/write access to a file.

[Visual Basic]
Public Enum FileAccess
[C#]
public enum FileAccess
[C++]
public enum FileAccess

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Read | Specifies read access to the file. Data can be read from the file and the file pointer can be moved. Combine with Write for read-write access.
ReadWrite | Specifies read and write access to the file. Data can be written to the file and the file pointer can be moved. Data can also be read from the file.
Write | Specifies write access to the file. Data can be written to the file and the file pointer can be moved. Combine with Read for read-write access.

Requirements

Namespace: System.IO

Assembly: mscorlib.dll

See Also

System.IO Namespace


FileMode Enumeration

Specifies how the operating system should open a file. These values, which are used by the FileStream constructors, control whether a file is overwritten or opened, or some combination thereof.

[Visual Basic]
Public Enum FileMode
[C#]
public enum FileMode
[C++]
public enum FileMode

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

To append to a file, use Append. To truncate a file or create it if it does not exist, use Create.

Members

Member Name | Description
Append | Opens the file if it exists and seeks to the end of the file, or creates a new file. FileMode.Append can only be used in conjunction with FileAccess.Write. If FileAccess.ReadWrite is specified and FileMode.Append is also specified, an ArgumentException is thrown.
Create | Specifies that the operating system should create a new file. If the file already exists, it will be overwritten. The Append and Write flags of FileIOPermissionAccess are required.
CreateNew | Specifies that the operating system should create a new file. Specifies that the operating system should create a new file. The Append and Write flags of FileIOPermissionAccess are required.
Open | Specifies that the operating system should open an existing file. The Read flag of FileIOPermissionAccess is required.
OpenOrCreate | Specifies that the operating system should open a file if it exists; otherwise, a new file should be created. If the file is opened with FileAccess.Read, the Read flag of FileIOPermissionAccess is required. If file access is FileAccess.ReadWrite and the file exists, the Write flag of FileIOPermissionAccess is required; if it doesn't exist, the Append flag of FileIOPermissionAccess is required in addition.
Truncate | Specifies that the operating system should open an existing file. Once opened, the file should be truncated so that its size is zero bytes. The file must be opened with at least the Write flag of FileIOPermissionAccess enabled.

Requirements

Namespace: System.IO

Assembly: mscorlib.dll

See Also

System.IO Namespace


FileNotFoundException Class

Represents a failed attempt to access a file that does not exist on disk.

Object
Exception
IOException
FileNotFoundException

[Visual Basic]
Public Class FileNotFoundException
   Inherits IOException
[C#]
public class FileNotFoundException : IOException
[C++]
public __gc class FileNotFoundException : public IOException
[JScript]
public class FileNotFoundException extends IOException

Remarks

[To be supplied.]

Requirements

Namespace: System.IO

Assembly: mscorlib.dll

See Also

FileNotFoundException Members | System.IO Namespace


FileNotFoundException Members

Public:

Constructor

FileNotFoundException Constructor Overloaded. Creates a new instance of the FileNotFoundException class with optional message string and Exception reference.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

FileNotFoundException Class | System.IO Namespace


FileNotFoundException Constructor

Creates a new instance of the FileNotFoundException class with optional message string and Exception reference.

Overload List

Creates a new instance of the FileNotFoundException class with its message string set to the empty string ("") and its HRESULT set to COR_E_FILENOTFOUND.

[Visual Basic] Overloads Public Sub New()
[C#] public FileNotFoundException();
[C++] public: FileNotFoundException();
[JScript] public function FileNotFoundException();

Creates a new instance of the FileNotFoundException class with its message string set to message and its HRESULT set to COR_E_FILENOTFOUND.

[Visual Basic] Overloads Public Sub New(String)
[C#] public FileNotFoundException(String);
[C++] public: FileNotFoundException(String*);
[JScript] public function FileNotFoundException(String);

Creates a new instance of the FileNotFoundException class with its message string set to message and inner and its HRESULT set to COR_E_FILENOTFOUND.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public FileNotFoundException(String, Exception);
[C++] public: FileNotFoundException(String*, Exception);
[JScript] public function FileNotFoundException(String, Exception);

See Also

FileNotFoundException Class | FileNotFoundException Members | System.IO Namespace


FileNotFoundException Constructor ()

Creates a new instance of the FileNotFoundException class with its message string set to the empty string ("") and its HRESULT set to COR_E_FILENOTFOUND.

[Visual Basic]
Overloads Public Sub New()
[C#]
public FileNotFoundException();
[C++]
public: FileNotFoundException();
[JScript]
public function FileNotFoundException();

Remarks

[To be supplied.]

See Also

FileNotFoundException Class | FileNotFoundException Members | System.IO Namespace | FileNotFoundException Constructor Overload List


FileNotFoundException Constructor (String)

Creates a new instance of the FileNotFoundException class with its message string set to message and its HRESULT set to COR_E_FILENOTFOUND.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public FileNotFoundException(
   string message
);
[C++]
public: FileNotFoundException(
   String* message
);
[JScript]
public function FileNotFoundException(
   message : String
);

Parameters

message
The message text for the exception.

Remarks

[To be supplied.]

See Also

FileNotFoundException Class | FileNotFoundException Members | System.IO Namespace | FileNotFoundException Constructor Overload List


FileNotFoundException Constructor (String, Exception)

Creates a new instance of the FileNotFoundException class with its message string set to message and inner and its HRESULT set to COR_E_FILENOTFOUND.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public FileNotFoundException(
   string message,
   Exception inner
);
[C++]
public: FileNotFoundException(
   String* message,
   Exception* inner
);
[JScript]
public function FileNotFoundException(
   message : String,
   inner : Exception
);

Parameters

message
The message text for the exception.
inner
The exception that is the root cause of the current exception.

Remarks

When handling exceptions, it is sometimes desirable to throw another exception that is more indicative of the error that has occurred. So that the original exception and the information that it carries not be lost, exceptions can hold a reference to another exception.

See Also

FileNotFoundException Class | FileNotFoundException Members | System.IO Namespace | FileNotFoundException Constructor Overload List


FileShare Enumeration

Contains constants for controlling the kind of access other FileStreams can have to the same file.

[Visual Basic]
Public Enum FileShare
[C#]
public enum FileShare
[C++]
public enum FileShare

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

A typical use of this enumeration is to define whether two processes can simultaneously read from the same file. For example, if a file is opened and FileShare.Read is specified, other users can open the file for reading but not for writing.

Members

Member Name | Description
None | Declines sharing of the current file. Any request to open the file (by this process or another process) will fail until the file is closed.
Read | Allows subsequent opening of the file for reading. If this flag is not specified, any request to open the file for reading (by this process or another process) will fail until the file is closed.
ReadWrite | Allows subsequent opening of the file for reading or writing. If this flag is not specified, any request to open the file for writing or reading (by this process or another process) will fail until the file is closed.
Write | Allows subsequent opening of the file for writing. If this flag is not specified, any request to open the file for writing (by this process or another process) will fail until the file is closed.

Requirements

Namespace: System.IO

Assembly: mscorlib.dll

See Also

System.IO Namespace | FileAccess | FileMode | FileStream


FileStream Class

Exposes a Stream around a file, supporting both synchronous and asynchronous methods.

Object
Stream
FileStream

[Visual Basic]
Public Class FileStream
   Inherits Stream
[C#]
public class FileStream : Stream
[C++]
public __gc class FileStream : public Stream
[JScript]
public class FileStream extends Stream

Remarks

The File class, used in conjunction with FileStream, is a utility class with static methods primarily for the creation of FileStream objects based on file paths and the standard input, standard output, and standard error devices.

The FileStream class can open a file in one of two modes, either synchronously or asynchronously, with significant performance consequences for the synchronous methods (Read and Write) and the asynchronous methods (BeginRead and BeginWrite). FileStream defaults to opening files synchronously.

The MemoryStream class creates a stream from a byte array and functions similarly to a FileStream.

Requirements

Namespace: System.IO

Assembly: mscorlib.dll

Example [C#]

FileStream objects support random access to files using the Seek method. The Seek method allows the read/write position to be moved to any position within the file. This is done with two parameters, a byte offset and a reference point. The byte offset is relative to the reference point, which can either be the beginning, current position, or end of the underlying file. These reference points are represented by the three properties of the SeekOrigin class. (Disk files always support random access. Note that at the time of construction, the CanSeek property is set to true or false depending on the underlying file type. Specifically, if the underlying file type is FILE_TYPE_DISK, as defined in winbase.h, then the CanSeek property is true, and otherwise, false.)

In the following example, a file is opened, or created if it does not already exist, and information is appended to the end of the file. The contents of the file are then written to standard output for display:

[C#]

using System;
using System.IO;

class Directory
{
   public static void Main(String[] args)
   {
     FileStream fs = new FileStream("log.txt", FileMode.OpenOrCreate, FileAccess.Write);
// create a Char writer
     StreamWriter w = new StreamWriter(fs);
// set the file pointer to the end
     w.BaseStream.Seek(0, SeekOrigin.End);
     Log ("Test1", w);
     Log ("Test2", w);
     w.Close(); // close the writer and underlying file
     fs = new FileStream("log.txt", FileMode.OpenOrCreate, FileAccess.Read);
// create a Char reader
     StreamReader r = new StreamReader(fs);
// set the file pointer to the beginning
     r.BaseStream.Seek(0, SeekOrigin.Begin);
     DumpLog (r);
  }
  public static void Log (String logMessage, StreamWriter w)
  {
     w.Write("\r\nLog Entry : ");
     w.WriteLine("{0} {1}", DateTime.Now.ToLongTimeString(),
           DateTime.Now.ToLongDateString());
     w.WriteLine("  :");
     w.WriteLine("  :{0}", logMessage);
     w.WriteLine ("-------------------------------");
// update underlying file
     w.Flush();
  }
  public static void DumpLog (StreamReader r)
  {
// while not at the end of the file
     while (r.Peek() > -1)
     {
        Console.WriteLine(r.ReadLine());
     }
     r.Close();
  }
}

See Also

FileStream Members | System.IO Namespace | File | FileAccess | FileMode | FileShare


FileStream Members

Public:

Constructor

FileStream Constructor Overloaded. Initializes a new instance of the FileStream object for the specified file path or file handle.

Properties

CanRead | Determines whether the current stream supports reading.
CanSeek | Determines whether the current stream supports seeking.
CanWrite | Determines whether the current stream supports writing.
DataAvailable | Determines whether there are any bytes available in the current stream.
Length | Returns the length in bytes of the stream.
Position | Gets the current position of this stream, or sets the current position of this stream to the given value.

Methods

BeginRead | Begins an asynchronous read.
BeginWrite | Begins an asynchronous write.
Close | Releases any resources, namely the file handle, associated with the current file stream.
EndRead | Ends a pending asynchronous read request. EndRead blocks until the read request has completed.
EndWrite | Ends an asynchronous write. It will block until the IO operation has completed.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Flush | Updates the file with the current state of the buffer and subsequently clears the buffer.
GetHandle | Gets the file handle for the file that the current FileStream object encapsulates.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Lock | Prevents access by other processes to all or part of a file.
Read | Reads a block of bytes from the stream and writes the data in a given buffer.
ReadByte | Reads a byte from the file stream. Returns the byte cast to an int or-1 if reading from the end of the stream.
Seek | Sets the current position of this stream to the given value.
SetLength | Sets the length of this stream to the given value.
ToString (inherited from Object) | Returns a String that represents the current Object.
Unlock | Allows access by other processes to all or part of a file that was previously locked.
Write | Writes a block of bytes to this stream using data from a buffer.
WriteByte | Writes a byte to the current position in the file stream.

Protected:

Constructor

FileStream Constructor Overloaded. Initializes a new instance of the FileStream object for the specified file path or file handle.

Methods

CreateWaitHandle (inherited from Stream) | Allocates a WaitHandle object efficiently.
Finalize | Called by the garbage collector when the current object is ready to be finalized.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FileStream Class | System.IO Namespace


FileStream Constructor

Initializes a new instance of the FileStream object for the specified file path or file handle.

Overload List

Initializes a new instance of the FileStream object.

[Visual Basic] Overloads Protected Sub New()
[C#] protected FileStream();
[C++] protected: FileStream();
[JScript] protected function FileStream();

Initializes a new instance of the FileStream object with the specified path and creation mode.

[Visual Basic] Overloads Public Sub New(String, FileMode)
[C#] public FileStream(String, FileMode);
[C++] public: FileStream(String*, FileMode);
[JScript] public function FileStream(String, FileMode);

Initializes a new instance of the FileStream object with the specified path, creation mode, and read/write permission.

[Visual Basic] Overloads Public Sub New(String, FileMode, FileAccess)
[C#] public FileStream(String, FileMode, FileAccess);
[C++] public: FileStream(String*, FileMode, FileAccess);
[JScript] public function FileStream(String, FileMode, FileAccess);

Initializes a new instance of the FileStream object with the specified path, creation mode, read/write, and sharing permission.

[Visual Basic] Overloads Public Sub New(String, FileMode, FileAccess, FileShare)
[C#] public FileStream(String, FileMode, FileAccess, FileShare);
[C++] public: FileStream(String*, FileMode, FileAccess, FileShare);
[JScript] public function FileStream(String, FileMode, FileAccess, FileShare);

Initializes a new instance of the FileStream object with the specified path, creation mode, read/write and sharing permission, and buffer size.

[Visual Basic] Overloads Public Sub New(String, FileMode, FileAccess, FileShare, Integer)
[C#] public FileStream(String, FileMode, FileAccess, FileShare, int);
[C++] public: FileStream(String*, FileMode, FileAccess, FileShare, int);
[JScript] public function FileStream(String, FileMode, FileAccess, FileShare, int);

Initializes a new instance of the FileStream object with the specified path, creation mode, read/write and sharing permission, and buffer size.

[Visual Basic] Overloads Public Sub New(String, FileMode, FileAccess, FileShare, Integer, Boolean)
[C#] public FileStream(String, FileMode, FileAccess, FileShare, int, bool);
[C++] public: FileStream(String*, FileMode, FileAccess, FileShare, int, bool);
[JScript] public function FileStream(String, FileMode, FileAccess, FileShare, int, Boolean);

Initializes a new instance of the FileStream object for the specified file handle, with the specified read/write permission.

[Visual Basic] Overloads Public Sub New(Integer, FileAccess)
[C#] public FileStream(int, FileAccess);
[C++] public: FileStream(int, FileAccess);
[JScript] public function FileStream(int, FileAccess);

Initializes a new instance of the FileStream object for the specified file handle, with the specified read/write permission and FileStream instance ownership.

[Visual Basic] Overloads Public Sub New(Integer, FileAccess, Boolean)
[C#] public FileStream(int, FileAccess, bool);
[C++] public: FileStream(int, FileAccess, bool);
[JScript] public function FileStream(int, FileAccess, Boolean);

Initializes a new instance of the FileStream object for the specified file handle, with the specified read/write permission, FileStream instance ownership, and synchronous or asynchronous state.

[Visual Basic] Overloads Public Sub New(Integer, FileAccess, Boolean, Boolean)
[C#] public FileStream(int, FileAccess, bool, bool);
[C++] public: FileStream(int, FileAccess, bool, bool);
[JScript] public function FileStream(int, FileAccess, Boolean, Boolean);

Initializes a new instance of the FileStream object for the specified file handle, with the specified read/write permission, FileStream instance ownership, synchronous or asynchronous state, and buffer size.

[Visual Basic] Overloads Public Sub New(Integer, FileAccess, Boolean, Boolean, Integer)
[C#] public FileStream(int, FileAccess, bool, bool, int);
[C++] public: FileStream(int, FileAccess, bool, bool, int);
[JScript] public function FileStream(int, FileAccess, Boolean, Boolean, int);

See Also

FileStream Class | FileStream Members | System.IO Namespace


FileStream Constructor ()

Initializes a new instance of the FileStream object.

[Visual Basic]
Overloads Protected Sub New()
[C#]
protected FileStream();
[C++]
protected: FileStream();
[JScript]
protected function FileStream();

Remarks

[To be supplied.]

See Also

FileStream Class | FileStream Members | System.IO Namespace | FileStream Constructor Overload List


FileStream Constructor (String, FileMode)

Initializes a new instance of the FileStream object with the specified path and creation mode.

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As String, _
   ByVal mode As FileMode _
)
[C#]
public FileStream(
   string path,
   FileMode mode
);
[C++]
public: FileStream(
   String* path,
   FileMode mode
);
[JScript]
public function FileStream(
   path : String,
   mode : FileMode
);

Parameters

path
A relative or absolute path for the file that the current FileStream object will encapsulate.
mode
A FileMode constant that controls how the file is opened or created.

Exceptions

Exception Type | Condition
ArgumentNullException | path is either null or an empty string.
ArgumentException | mode is not a field of FileMode.
SecurityException | The caller does not have the required FileIOPermission.
FileNotFoundException | The file cannot be found.
IOException | An I/O error occurs.

Remarks

This constructor calls FileStream(String path, FileMode mode, FileAccess access, FileShare share, int bufferSize). The constructor is given read/write access to the file, and it is opened without sharing (that is, requests to open the file by this or another process will fail until the FileStream object has been closed). The buffer size is set to 8192 bytes (8 KB).

Requirements

NGWS Runtime Security:

FileIOPermissionAccess | Append flag required by FileMode.Create or FileMode.CreateNew and by FileMode.OpenOrCreate if the file does not yet exist.
FileIOPermissionAccess | Write flag required by FileMode.Create or FileMode.CreateNew, by FileMode.OpenOrCreate if the file already exists or does not exist, and by FileMode.Truncate.
FileIOPermissionAccess | Read flag required by FileMode.Open.

See Also

FileStream Class | FileStream Members | System.IO Namespace | FileStream Constructor Overload List


FileStream Constructor (String, FileMode, FileAccess)

Initializes a new instance of the FileStream object with the specified path, creation mode, and read/write permission.

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As String, _
   ByVal mode As FileMode, _
   ByVal access As FileAccess _
)
[C#]
public FileStream(
   string path,
   FileMode mode,
   FileAccess access
);
[C++]
public: FileStream(
   String* path,
   FileMode mode,
   FileAccess access
);
[JScript]
public function FileStream(
   path : String,
   mode : FileMode,
   access : FileAccess
);

Parameters

path
A relative or absolute path for the file that the current FileStream object will encapsulate.
mode
A FileMode constant that determines how the file is opened or created.
access
A FileAccess constant that determines how the file may be accessed by the FileStream object. This sets the CanRead and CanWrite properties of the FileStream object. CanSeek is set to true if path specifies a disk file.

Exceptions

Exception Type | Condition
ArgumentException | mode is not a field of FileMode.
ArgumentException | access is not a field of FileAccess.
ArgumentException | path is an empty string ("").
ArgumentNullException | path is null.
SecurityException | The caller does not have the required FileIOPermission.
FileNotFoundException | The file cannot be found.
IOException | An I/O error occurs.

Remarks

This constructor calls FileStream(String path, FileMode mode, FileAccess access, FileShare share, int bufferSize). The constructor is given read/write access to the file, and it is opened without sharing (that is, requests to open the file by this or another process will fail until the FileStream object has been closed). The buffer size is set to 8192 bytes (8 KB).

Requirements

NGWS Runtime Security:

FileIOPermissionAccess | Write flag required by FileMode.Create or FileMode.CreateNew, by FileMode.OpenOrCreate when access is FileAccess.ReadWrite and the file does not exist, or when access is FileAccess.Read, and by FileMode.Truncate, FileAccess.Write, and FileAccess.ReadWrite.
FileIOPermissionAccess | Read flag required by FileMode.Open, FileAccess.Read, and FileAccess.ReadWrite.
FileIOPermissionAccess | Append flag required by FileMode.Create or FileMode.CreateNew, by FileMode.OpenOrCreate when access is FileAccess.ReadWrite and the file does not yet exist, and byFileMode.OpenOrCreate if the file does not yet exist.

See Also

FileStream Class | FileStream Members | System.IO Namespace | FileStream Constructor Overload List


FileStream Constructor (String, FileMode, FileAccess, FileShare)

Initializes a new instance of the FileStream object with the specified path, creation mode, read/write, and sharing permission.

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As String, _
   ByVal mode As FileMode, _
   ByVal access As FileAccess, _
   ByVal share As FileShare _
)
[C#]
public FileStream(
   string path,
   FileMode mode,
   FileAccess access,
   FileShare share
);
[C++]
public: FileStream(
   String* path,
   FileMode mode,
   FileAccess access,
   FileShare share
);
[JScript]
public function FileStream(
   path : String,
   mode : FileMode,
   access : FileAccess,
   share : FileShare
);

Parameters

path
A relative or absolute path for the file that the current FileStream object will encapsulate.
mode
A FileMode constant that determines how the file is opened or created.
access
A FileAccess constant that determines how the file may be accessed by the FileStream object. This sets the CanRead and CanWrite properties of the FileStream object. CanSeek is set to true if path specifies a disk file.
share
A FileShare constant that determines how the file will be shared by processes.

Exceptions

Exception Type | Condition
ArgumentNullException | path is null.
ArgumentException | mode is not a field of FileMode.
ArgumentException | access is not a field of FileAccess.
ArgumentException | share is not a field of FileShare.
ArgumentException | path is an empty string ("").
SecurityException | The caller does not have the required FileIOPermission.
FileNotFoundException | The file cannot be found.
IOException | An I/O error occurs.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess | Write flag required by FileMode.Create or FileMode.CreateNew, by FileMode.OpenOrCreate when access is FileAccess.ReadWrite and the file does not exist, or when access is FileAccess.Read, and by FileMode.Truncate, FileAccess.Write, and FileAccess.ReadWrite.
FileIOPermissionAccess | Read flag required by FileMode.Open, FileAccess.Read, and FileAccess.ReadWrite.
FileIOPermissionAccess | Append flag required by FileMode.Create or FileMode.CreateNew, by FileMode.OpenOrCreate when access is FileAccess.ReadWrite and the file does not yet exist, and byFileMode.OpenOrCreate if the file does not yet exist.

See Also

FileStream Class | FileStream Members | System.IO Namespace | FileStream Constructor Overload List


FileStream Constructor (String, FileMode, FileAccess, FileShare, Int32)

Initializes a new instance of the FileStream object with the specified path, creation mode, read/write and sharing permission, and buffer size.

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As String, _
   ByVal mode As FileMode, _
   ByVal access As FileAccess, _
   ByVal share As FileShare, _
   ByVal bufferSize As Integer _
)
[C#]
public FileStream(
   string path,
   FileMode mode,
   FileAccess access,
   FileShare share,
   int bufferSize
);
[C++]
public: FileStream(
   String* path,
   FileMode mode,
   FileAccess access,
   FileShare share,
   int bufferSize
);
[JScript]
public function FileStream(
   path : String,
   mode : FileMode,
   access : FileAccess,
   share : FileShare,
   bufferSize : int
);

Parameters

path
A relative or absolute path for the file that the current FileStream object will encapsulate.
mode
A FileMode constant that determines how the file is opened or created.
access
A FileAccess constant that determines how the file may be accessed by the FileStream object. This sets the CanRead and CanWrite properties of the FileStream object. CanSeek is set to true if path specifies a disk file.
share
A FileShare constant that determines how the file will be shared by processes.
bufferSize
The desired buffer size in bytes. For bufferSize values between zero and eight, the actual buffer size is set to 8 bytes.

Exceptions

Exception Type | Condition
ArgumentNullException | path is null.
ArgumentException | path is an empty string.
ArgumentOutOfRangeException | mode is not a field of FileMode.
ArgumentOutOfRangeException | access is not a field of FileAccess.
ArgumentOutOfRangeException | share is not a field of FileShare.
ArgumentOutOfRangeException | bufferSize is not positive.
FileNotFoundException | The file cannot be found. For example, the exception is thrown if mode is FileMode.Truncate, and the file specified by path does not exist. The file must already exist in this mode. In addition, this exception is also called if mode is FileMode.Open, and the file specified by path does not exist. The file must already exist in this mode.
IOException | An I/O error occurs. For example, the exception is thrown if: path is not a valid path. That is, "c:\\Dir\myfile.txt" is missing an escape character in front of the backslash between Dir and myfile.txt.The directory path leading to the file specified by path does not exist on the system. That is, if Dir is not a directory on drive C, "c:\\Dir\\myfile.txt" will result in an error. mode is FileMode.CreateNew and the file specified by path already exists. The file must not already exist in this mode. access requested is not permitted by the operating system for the specified path. For example: access is read/write and there is an attempt to open the existing file "c:\\Dir\\myfile.txt", but the file or directory is set for read-only access.
SecurityException | The caller does not have the appropriate FileIOPermission.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess | Write flag required by FileMode.Create or FileMode.CreateNew, by FileMode.OpenOrCreate when access is FileAccess.ReadWrite and the file does not exist, or when access is FileAccess.Read, and by FileMode.Truncate, FileAccess.Write, and FileAccess.ReadWrite.
FileIOPermissionAccess | Read flag required by FileMode.Open, FileAccess.Read, and FileAccess.ReadWrite.
FileIOPermissionAccess | Append flag required by FileMode.Create or FileMode.CreateNew, by FileMode.OpenOrCreate when access is FileAccess.ReadWrite and the file does not yet exist, and byFileMode.OpenOrCreate if the file does not yet exist.

See Also

FileStream Class | FileStream Members | System.IO Namespace | FileStream Constructor Overload List


FileStream Constructor (String, FileMode, FileAccess, FileShare, Int32, Boolean)

Initializes a new instance of the FileStream object with the specified path, creation mode, read/write and sharing permission, and buffer size.

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As String, _
   ByVal mode As FileMode, _
   ByVal access As FileAccess, _
   ByVal share As FileShare, _
   ByVal bufferSize As Integer, _
   ByVal useAsync As Boolean _
)
[C#]
public FileStream(
   string path,
   FileMode mode,
   FileAccess access,
   FileShare share,
   int bufferSize,
   bool useAsync
);
[C++]
public: FileStream(
   String* path,
   FileMode mode,
   FileAccess access,
   FileShare share,
   int bufferSize,
   bool useAsync
);
[JScript]
public function FileStream(
   path : String,
   mode : FileMode,
   access : FileAccess,
   share : FileShare,
   bufferSize : int,
   useAsync : Boolean
);

Parameters

path
A relative or absolute path for the file that the current FileStream object will encapsulate.
mode
A FileMode constant that determines how the file is opened or created.
access
A FileAccess constant that determines how the file may be accessed by the FileStream object. This sets the CanRead and CanWrite properties of the FileStream object. CanSeek is set to true if path specifies a disk file.
share
A FileShare constant that determines how the file will be shared by processes.
bufferSize
The desired buffer size in bytes.
useAsync
Specifies whether to use asynchronous I/O or synchronous IO. When opened asynchronously, the BeginRead and BeginWrite methods will perform better on large reads or writes, but they may be much slower for small reads or writes. If you have designed your application to take advantage of asynchronous IO, set this to true. Using async IO correctly can speed up applications by as much as a factor of 10, but using it without redesigning the application for asynchronous IO can decrease performance by as much as a factor of 10.

Exceptions

Exception Type | Condition
ArgumentNullException | path is null.
ArgumentException | path is an empty string.
ArgumentOutOfRangeException | mode is not a field of FileMode.
ArgumentOutOfRangeException | access is not a field of FileAccess.
ArgumentOutOfRangeException | share is not a field of FileShare.
ArgumentOutOfRangeException | bufferSize is not positive.
FileNotFoundException | The file cannot be found. For example, the exception is thrown if mode is FileMode.Truncate, and the file specified by path does not exist. The file must already exist in this mode. In addition, this exception is also called if mode is FileMode.Open, and the file specified by path does not exist. The file must already exist in this mode.
IOException | An I/O error occurs. For example, the exception is thrown if: path is not a valid path. That is, "c:\\Dir\myfile.txt" is missing an escape character in front of the backslash between Dir and myfile.txt.The directory path leading to the file specified by path does not exist on the system. That is, if Dir is not a directory on drive C, "c:\\Dir\\myfile.txt" will result in an error. mode is FileMode.CreateNew and the file specified by path already exists. The file must not already exist in this mode. access requested is not permitted by the operating system for the specified path. For example: access is read/write and there is an attempt to open the existing file "c:\\Dir\\myfile.txt", but the file or directory is set for read-only access.
SecurityException | The caller does not have the appropriate FileIOPermission.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess.Write | Required by FileMode.Create or FileMode.CreateNew. Required by FileMode.OpenOrCreate when access is FileAccess.ReadWrite and the file does not exist, or when access is FileAccess.Read. Required by FileMode.Truncate. Required by FileAccess.Write. Required by FileAccess.ReadWrite.
FileIOPermissionAccess.Read | Required by FileMode.Open. Required by FileAccess.Read. Required by FileAccess.ReadWrite.
FileIOPermissionAccess.Append | Required by FileMode.Create or FileMode.CreateNew. Required by FileMode.OpenOrCreate when access is FileAccess.ReadWrite and the file does not yet exist. Required by FileMode.OpenOrCreate if the file does not yet exist.
System.Security.Permissions.FileIOPermissionAccess.Append and System.Security.Permissions.FileIOPermissionAccess.Write | Required by FileMode.Create or FileMode.CreateNew. Required by FileMode.OpenOrCreate when access is FileAccess.ReadWrite and the file does not yet exist. Required by FileMode.OpenOrCreate if the file does not yet exist.
FileIOPermissionAccess.Read | Required by FileMode.Open. Required by FileAccess.Read.
FileIOPermissionAccess.Write | Required by FileMode.OpenOrCreate if access is FileAccess.Read. Required by FileMode.OpenOrCreate when access is FileAccess.ReadWrite and the file already exists. Required by FileMode.Truncate. Required by FileAccess.Write.
System.Security.Permissions.FileIOPermissionAccess.Read and System.Security.Permissions.FileIOPermissionAccess.Write | Required by FileAccess.ReadWrite.

See Also

FileStream Class | FileStream Members | System.IO Namespace | FileStream Constructor Overload List


FileStream Constructor (Int32, FileAccess)

Initializes a new instance of the FileStream object for the specified file handle, with the specified read/write permission.

[Visual Basic]
Overloads Public Sub New( _
   ByVal handle As Integer, _
   ByVal access As FileAccess _
)
[C#]
public FileStream(
   int handle,
   FileAccess access
);
[C++]
public: FileStream(
   int handle,
   FileAccess access
);
[JScript]
public function FileStream(
   handle : int,
   access : FileAccess
);

Parameters

handle
A file handle for the file that the current FileStream object will encapsulate.
access
A FileAccess constant that determines how the file may be accessed by the FileStream object. This sets the CanRead and CanWrite properties of the FileStream object. CanSeek is set to true if path specifies a disk file.

Exceptions

Exception Type | Condition
ArgumentException | access is not a field of FileAccess.
SecurityException | The caller does not have the required FileIOPermission.

Remarks

This constructor calls FileStream(int handle, FileAccess access, bool ownsHandle, int bufferSize), sets ownsHandle to true (this process owns the file handle), and sets bufferSize to 8192 bytes (8 KB). When Close is called, the handle is also closed and the file's handle count is decremented.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess | Read flag required by FileAccess.Read and FileAccess.ReadWrite.
FileIOPermissionAccess | Write flag required by FileAccess.Write and FileAccess.ReadWrite.

See Also

FileStream Class | FileStream Members | System.IO Namespace | FileStream Constructor Overload List


FileStream Constructor (Int32, FileAccess, Boolean)

Initializes a new instance of the FileStream object for the specified file handle, with the specified read/write permission and FileStream instance ownership.

[Visual Basic]
Overloads Public Sub New( _
   ByVal handle As Integer, _
   ByVal access As FileAccess, _
   ByVal ownsHandle As Boolean _
)
[C#]
public FileStream(
   int handle,
   FileAccess access,
   bool ownsHandle
);
[C++]
public: FileStream(
   int handle,
   FileAccess access,
   bool ownsHandle
);
[JScript]
public function FileStream(
   handle : int,
   access : FileAccess,
   ownsHandle : Boolean
);

Parameters

handle
A file handle for the file that this FileStream object will encapsulate.
access
A FileAccess constant that determines how the file may be accessed by the FileStream object. This sets the CanRead and CanWrite properties of the FileStream object. CanSeek is set to true if path specifies a disk file.
ownsHandle
true if the file handle will be owned by this FileStream instance; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentException | access is not a field of FileAccess.
SecurityException | The caller does not have the required FileIOPermission.

Remarks

The FileStream object is given the specified access to the file. The ownership of the handle will be as specified. If this process owns the handle, a call to the Close method will also close the handle. In particular, the file's handle count is decremented. The FileStream object is given a buffer size of 8192 bytes.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess | Read flag required by FileAccess.Read and FileAccess.ReadWrite.
FileIOPermissionAccess | Write flag required by FileAccess.Write and FileAccess.ReadWrite.

See Also

FileStream Class | FileStream Members | System.IO Namespace | FileStream Constructor Overload List


FileStream Constructor (Int32, FileAccess, Boolean, Boolean)

Initializes a new instance of the FileStream object for the specified file handle, with the specified read/write permission, FileStream instance ownership, and synchronous or asynchronous state.

[Visual Basic]
Overloads Public Sub New( _
   ByVal handle As Integer, _
   ByVal access As FileAccess, _
   ByVal ownsHandle As Boolean, _
   ByVal isAsync As Boolean _
)
[C#]
public FileStream(
   int handle,
   FileAccess access,
   bool ownsHandle,
   bool isAsync
);
[C++]
public: FileStream(
   int handle,
   FileAccess access,
   bool ownsHandle,
   bool isAsync
);
[JScript]
public function FileStream(
   handle : int,
   access : FileAccess,
   ownsHandle : Boolean,
   isAsync : Boolean
);

Parameters

handle
A file handle for the file that this FileStream object will encapsulate.
access
A FileAccess constant that determines how the file may be accessed by the FileStream object. This sets the CanRead and CanWrite properties of the FileStream object. CanSeek is set to true if path specifies a disk file.
ownsHandle
true if the file handle will be owned by this FileStream instance; otherwise, false.
isAsync
true if the handle was opened asynchronously (that is, in overlapped I/O mode); otherwise, false.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | access is not a field of FileAccess.
ArgumentOutOfRangeException | bufferSize is not positive.
IOException | An I/O error occurs. For example, if the access requested is not permitted by the operating system for the specified handle. Or, access is read/write and there is an attempt to open the existing file "c:\\Dir\\myfile.txt", but the file or directory is set for read-only access.
SecurityException | The caller does not have the required FileIOPermission.

Remarks

The FileStream object is given the specified access to the file. The ownership of the handle will be as specified. If this process owns the handle, a call to the Close method will also close the handle. In particular, the file's handle count is decremented. The FileStream object is given the specified buffer size.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess | Read flag required by FileAccess.Read and FileAccess.ReadWrite.
FileIOPermissionAccess | Write flag required by FileAccess.Write and FileAccess.ReadWrite.

See Also

FileStream Class | FileStream Members | System.IO Namespace | FileStream Constructor Overload List


FileStream Constructor (Int32, FileAccess, Boolean, Boolean, Int32)

Initializes a new instance of the FileStream object for the specified file handle, with the specified read/write permission, FileStream instance ownership, synchronous or asynchronous state, and buffer size.

[Visual Basic]
Overloads Public Sub New( _
   ByVal handle As Integer, _
   ByVal access As FileAccess, _
   ByVal ownsHandle As Boolean, _
   ByVal isAsync As Boolean, _
   ByVal bufferSize As Integer _
)
[C#]
public FileStream(
   int handle,
   FileAccess access,
   bool ownsHandle,
   bool isAsync,
   int bufferSize
);
[C++]
public: FileStream(
   int handle,
   FileAccess access,
   bool ownsHandle,
   bool isAsync,
   int bufferSize
);
[JScript]
public function FileStream(
   handle : int,
   access : FileAccess,
   ownsHandle : Boolean,
   isAsync : Boolean,
   bufferSize : int
);

Parameters

handle
A file handle for the file that this FileStream object will encapsulate.
access
A FileAccess constant that determines how the file may be accessed by the FileStream object. This sets the CanRead and CanWrite properties of the FileStream object. CanSeek is set to true if path specifies a disk file.
ownsHandle
true if the file handle will be owned by this FileStream instance; otherwise, false.
isAsync
true if the handle was opened asynchronously (that is, in overlapped I/O mode); otherwise, false.
bufferSize
The size of the buffer in bytes.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | access is less than FileAccess.Read or greater than FileAccess.ReadWrite or bufferSize is negative.
ArgumentException | The handle is invalid.
IOException | An I/O error occurs.
SecurityException | The caller does not have the required permission.
ExecutionEngineException | ThreadPoolBindHandle failed.

Requirements

NGWS Runtime Security:

FileIOPermissionAccess | Read flag required by FileAccess.Read and FileAccess.ReadWrite.
FileIOPermissionAccess | Write flag required by FileAccess.Write and FileAccess.ReadWrite.

See Also

FileStream Class | FileStream Members | System.IO Namespace | FileStream Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

FileStream Properties

The properties of the FileStream class are listed below. For a complete list of FileStream class members, see the FileStream Members topic.

Public:

CanRead | Determines whether the current stream supports reading.
CanSeek | Determines whether the current stream supports seeking.
CanWrite | Determines whether the current stream supports writing.
DataAvailable | Determines whether there are any bytes available in the current stream.
Length | Returns the length in bytes of the stream.
Position | Gets the current position of this stream, or sets the current position of this stream to the given value.

See Also

FileStream Class | System.IO Namespace


FileStream.CanRead

Determines whether the current stream supports reading.

[Visual Basic]
Overridable Public ReadOnly Property CanRead As Boolean
[C#]
public bool CanRead {override get;}
[C++]
public: __property virtual bool get_CanRead();
[JScript]
public function get CanRead() : Boolean;

Property Value

true if the stream supports reading; false otherwise. Also returns false if the stream is closed.

Remarks

If a Stream subclass does not support reading, calls to the read and peek methods will throw a NotSupportedException.

See Also

FileStream Class | FileStream Members | System.IO Namespace


FileStream.CanSeek

Determines whether the current stream supports seeking.

[Visual Basic]
Overridable Public ReadOnly Property CanSeek As Boolean
[C#]
public bool CanSeek {override get;}
[C++]
public: __property virtual bool get_CanSeek();
[JScript]
public function get CanSeek() : Boolean;

Property Value

true if the stream supports seeking; false otherwise. Also returns false if the stream is closed.

Remarks

If a Stream subclass does not support seeking, a call to Length (both get and set), Position, or Seek will throw a NotSupportedException.

See Also

FileStream Class | FileStream Members | System.IO Namespace


FileStream.CanWrite

Determines whether the current stream supports writing.

[Visual Basic]
Overridable Public ReadOnly Property CanWrite As Boolean
[C#]
public bool CanWrite {override get;}
[C++]
public: __property virtual bool get_CanWrite();
[JScript]
public function get CanWrite() : Boolean;

Property Value

true if the stream supports writing; false otherwise. Also returns false if the stream is closed.

Remarks

If a Stream subclass does not support writing, a call to Write, BeginWrite, or EndWrite will throw a NotSupportedException.

See Also

FileStream Class | FileStream Members | System.IO Namespace


FileStream.DataAvailable

Determines whether there are any bytes available in the current stream.

[Visual Basic]
Overridable Public ReadOnly Property DataAvailable As Boolean
[C#]
public bool DataAvailable {override get;}
[C++]
public: __property virtual bool get_DataAvailable();
[JScript]
public function get DataAvailable() : Boolean;

Property Value

true if the end of the stream has not been reached; false otherwise.

See Also

FileStream Class | FileStream Members | System.IO Namespace


FileStream.Length

Returns the length in bytes of the stream.

[Visual Basic]
Overridable Public ReadOnly Property Length As Long
[C#]
public long Length {override get;}
[C++]
public: __property virtual __int64 get_Length();
[JScript]
public function get Length() : long;

Property Value

A long value representing the length of the stream in bytes.

Exceptions

Exception Type | Condition
NotSupportedException | CanSeek for this stream is false.
IOException | An I/O error occurs.

See Also

FileStream Class | FileStream Members | System.IO Namespace


FileStream.Position

Gets the current position of this stream, or sets the current position of this stream to the given value.

[Visual Basic]
Overridable Public Property Position As Long
[C#]
public long Position {override get; override set;}
[C++]
public: __property virtual __int64 get_Position();
public: __property virtual void set_Position(__int64);
[JScript]
public function get Position() : long;
public function set Position(long);

Property Value

Get returns the current position of this stream.

Set sets the current position of this stream to the given value.

Exceptions

Exception Type | Condition
NotSupportedException | The stream does not support seeking.
IOException | An I/O error occurs.
EndOfStreamException | Seeking was attempted past the end of a stream that does not support this.

Remarks

The position cannot be set more than one byte beyond the end of the stream. You can set the position to just beyond the last byte so you can append to the file. Opening a new file and then writing to it requires this.

See Also

FileStream Class | FileStream Members | System.IO Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

FileStream Methods

The methods of the FileStream class are listed below. For a complete list of FileStream class members, see the FileStream Members topic.

Public:

BeginRead | Begins an asynchronous read.
BeginWrite | Begins an asynchronous write.
Close | Releases any resources, namely the file handle, associated with the current file stream.
EndRead | Ends a pending asynchronous read request. EndRead blocks until the read request has completed.
EndWrite | Ends an asynchronous write. It will block until the IO operation has completed.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Flush | Updates the file with the current state of the buffer and subsequently clears the buffer.
GetHandle | Gets the file handle for the file that the current FileStream object encapsulates.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Lock | Prevents access by other processes to all or part of a file.
Read | Reads a block of bytes from the stream and writes the data in a given buffer.
ReadByte | Reads a byte from the file stream. Returns the byte cast to an int or-1 if reading from the end of the stream.
Seek | Sets the current position of this stream to the given value.
SetLength | Sets the length of this stream to the given value.
ToString (inherited from Object) | Returns a String that represents the current Object.
Unlock | Allows access by other processes to all or part of a file that was previously locked.
Write | Writes a block of bytes to this stream using data from a buffer.
WriteByte | Writes a byte to the current position in the file stream.

Protected:

CreateWaitHandle (inherited from Stream) | Allocates a WaitHandle object efficiently.
Finalize | Called by the garbage collector when the current object is ready to be finalized.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FileStream Class | System.IO Namespace


FileStream.BeginRead

Begins an asynchronous read.

[Visual Basic]
Overrides Public Function BeginRead( _
   ByVal array() As Byte, _
   ByVal offset As Integer, _
   ByVal numBytes As Integer, _
   ByVal cb As AsyncCallback, _
   ByVal stateObject As Object _
) As IAsyncResult
[C#]
public override IAsyncResult BeginRead(
   byte[] array,
   int offset,
   int numBytes,
   AsyncCallback cb,
   object stateObject
);
[C++]
public: override IAsyncResult* BeginRead(
   unsigned char* array[],
   int offset,
   int numBytes,
   AsyncCallback* cb,
   Object* stateObject
);
[JScript]
public override function BeginRead(
   array : Byte[],
   offset : int,
   numBytes : int,
   cb : AsyncCallback,
   stateObject : Object
) : IAsyncResult;

Parameters

array
The buffer to read data from.
offset
The byte offset in b at which to begin reading.
numBytes
The maximum number of bytes to read.
cb
The AsyncCallback.
stateObject
The state object.

Return Value

An IAsyncResult that references the asynchronous read.

Exceptions

Exception Type | Condition
ArgumentException | The array length minus offset is less than numBytes.
ArgumentNullException | array is null.
ArgumentOutOfRangeException | offset or numBytes are negative.
IOException | An asynchronous read was attempted past the end of the file.

See Also

FileStream Class | FileStream Members | System.IO Namespace


FileStream.BeginWrite

Begins an asynchronous write.

[Visual Basic]
Overrides Public Function BeginWrite( _
   ByVal array() As Byte, _
   ByVal offset As Integer, _
   ByVal numBytes As Integer, _
   ByVal cb As AsyncCallback, _
   ByVal stateObject As Object _
) As IAsyncResult
[C#]
public override IAsyncResult BeginWrite(
   byte[] array,
   int offset,
   int numBytes,
   AsyncCallback cb,
   object stateObject
);
[C++]
public: override IAsyncResult* BeginWrite(
   unsigned char* array[],
   int offset,
   int numBytes,
   AsyncCallback* cb,
   Object* stateObject
);
[JScript]
public override function BeginWrite(
   array : Byte[],
   offset : int,
   numBytes : int,
   cb : AsyncCallback,
   stateObject : Object
) : IAsyncResult;

Parameters

array
The buffer to write data to.
offset
The byte offset in b at which to begin writing.
numBytes
The maximum number of bytes to write.
cb
The AsyncCallback.
stateObject
The state object

Return Value

Returns an IAsyncResult that references the asynchronous write.

See Also

FileStream Class | FileStream Members | System.IO Namespace


FileStream.Close

Releases any resources, namely the file handle, associated with the current file stream.

[Visual Basic]
Overrides Public Sub Close()
[C#]
public override void Close();
[C++]
public: override void Close();
[JScript]
public override function Close();

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.

Remarks

Any data previously written to the buffer is copied to the file before the file stream is closed, so it is not necessary to call Flush before invoking Close. Following a call to Close, any operations on the file stream may raise exceptions. After Close has been called once, it does nothing if called again.

The Finalize method invokes Close so that the file stream is closed before the garbage collector finalizes the object. Any objects such as a StreamWriter that may be writing to the FileStream may not have flushed their data from their internal buffers to the FileStream when FileStream's Finalize closes the Stream. To prevent data loss, it is highly recommended that you always call Close on your highest-level object.

See Also

FileStream Class | FileStream Members | System.IO Namespace


FileStream.EndRead

Ends a pending asynchronous read request. EndRead blocks until the read request has completed.

[Visual Basic]
Overrides Public Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
[C#]
public override int EndRead(
   IAsyncResult asyncResult
);
[C++]
public: override int EndRead(
   IAsyncResult* asyncResult
);
[JScript]
public override function EndRead(
   asyncResult : IAsyncResult
) : int;

Parameters

asyncResult
The reference to the pending asynchronous request to be ended.

Return Value

The number of bytes read or 0 if none were read.

Exceptions

Exception Type | Condition
ArgumentNullException | asyncResult is null.

Remarks

EndRead blocks until the asynchronous request is complete.

See Also

FileStream Class | FileStream Members | System.IO Namespace


FileStream.EndWrite

Ends an asynchronous write. It will block until the IO operation has completed.

[Visual Basic]
Overrides Public Function EndWrite( _
   ByVal asyncResult As IAsyncResult _
) As Integer
[C#]
public override int EndWrite(
   IAsyncResult asyncResult
);
[C++]
public: override int EndWrite(
   IAsyncResult* asyncResult
);
[JScript]
public override function EndWrite(
   asyncResult : IAsyncResult
) : int;

Parameters

asyncResult
A reference to the outstanding Asynchronous IO request.

Return Value

The number of bytes written.

Exceptions

Exception Type | Condition
ArgumentNullException | asyncResult is null.

Remarks

See Also

FileStream Class | FileStream Members | System.IO Namespace


FileStream.Finalize

Called by the garbage collector when the current object is ready to be finalized.

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.

Remarks

Finalize closes the FileStream.

See Also

FileStream Class | FileStream Members | System.IO Namespace


FileStream.Flush

Updates the file with the current state of the buffer and subsequently clears the buffer.

[Visual Basic]
Overrides Public Sub Flush()
[C#]
public override void Flush();
[C++]
public: override void Flush();
[JScript]
public override function Flush();

Exceptions

Exception Type | Condition
IOException | An I/O error occurs. For example, an error is thrown when the file is closed.

Remarks

Because a buffer can be used for either reading or writing, but not both simultaneously, Flush performs two functions. First, any data previously written to the buffer is copied to the file and the buffer is cleared.

Second, if CanSeek is true and data was previously copied from the file to the buffer for reading, the current position within the file is decremented by the number of unread bytes in the buffer. The buffer is then cleared.

See Also

FileStream Class | FileStream Members | System.IO Namespace


FileStream.GetHandle

Gets the file handle for the file that the current FileStream object encapsulates.

[Visual Basic]
Overridable Public Function GetHandle() As Integer
[C#]
public virtual int GetHandle();
[C++]
public: virtual int GetHandle();
[JScript]
public function GetHandle() : int;

Return Value

The file handle for the file encapsulated by this FileStream object, or-1 if the file stream has been closed.

Exceptions

Exception Type | Condition
SecurityException | The caller does not have the required permission.

Requirements

NGWS Runtime Security:

SecurityPermission UnmanagedCode flag must be set to call unmanaged code, such as calling native code with PInvoke or COM Interop.

See Also

FileStream Class | FileStream Members | System.IO Namespace


FileStream.Lock

Prevents access by other processes to all or part of a file.

[Visual Basic]
Overridable Public Sub Lock( _
   ByVal position As Long, _
   ByVal length As Long _
)
[C#]
public virtual void Lock(
   long position,
   long length
);
[C++]
public: virtual void Lock(
   __int64 position,
   __int64 length
);
[JScript]
public function Lock(
   position : long,
   length : long
);

Parameters

position
[To be supplied.]
length
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | position or length are negative.

See Also

FileStream Class | FileStream Members | System.IO Namespace


FileStream.Read

Reads a block of bytes from the stream and writes the data in a given buffer.

[Visual Basic]
Overrides Public Function Read( _
   ByVal array() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
[C#]
public override int Read(
   byte[] array,
   int offset,
   int count
);
[C++]
public: override int Read(
   unsigned char* array[],
   int offset,
   int count
);
[JScript]
public override function Read(
   array : Byte[],
   offset : int,
   count : int
) : int;

Parameters

array
The array to write data into.
offset
The byte offset in buffer at which to begin writing.
count
The maximum number of bytes to read.

Return Value

The total number of bytes read into the buffer. This may be less than the number of bytes requested if that many bytes aren't currently available, or zero if the end of the stream is reached.

Exceptions

Exception Type | Condition
ArgumentNullException | array is null.
ArgumentOutOfRangeException | offset or count is less than zero.
NotSupportedException | The stream does not support reading.
IOException | An I/O error occurs.
ArgumentException | offset and count describe an invalid range in array.

Remarks

The offset parameter gives the offset of the byte in array at which to begin writing (index in the buffer), and the count parameter gives the maximum number of bytes that will be read from this stream. The returned value is the actual number of bytes read, or zero if the end of the stream is reached. If the read operation is successful, the current position of the stream is advanced by the number of bytes read. If an exception occurs, the current position of the stream is unchanged.

The Read method will return zero only if the end of the stream is reached. In all other cases, Read always reads at least one byte from the stream before returning. If no data is available from the stream upon a call to Read, the method will block until at least one byte of data can be returned.

See Also

FileStream Class | FileStream Members | System.IO Namespace


FileStream.ReadByte

Reads a byte from the file stream. Returns the byte cast to an int or-1 if reading from the end of the stream.

[Visual Basic]
Overrides Public Function ReadByte() As Integer
[C#]
public override int ReadByte();
[C++]
public: override int ReadByte();
[JScript]
public override function ReadByte() : int;

Return Value

The byte cast to an int, or-1 if reading from the end of the stream.

Exceptions

Exception Type | Condition
IOException | The stream is closed or does not support reading.

See Also

FileStream Class | FileStream Members | System.IO Namespace


FileStream.Seek

Sets the current position of this stream to the given value.

[Visual Basic]
Overrides Public Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
[C#]
public override long Seek(
   long offset,
   SeekOrigin origin
);
[C++]
public: override __int64 Seek(
   __int64 offset,
   SeekOrigin origin
);
[JScript]
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;

Parameters

offset
The new position of the stream.
origin
The point to seek relative to. Uses a field from SeekOrigin.

Return Value

The new position in the stream.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.
NotSupportedException | The stream does not support seeking.
EndOfStreamException | Seeking was attempted past the end of a stream that does not support this.

Remarks

The position cannot be set more than one byte beyond the end of the stream. You can set the position to just beyond the last byte so you can append to the file. Opening a new file and then writing to it requires this.

See Also

FileStream Class | FileStream Members | System.IO Namespace


FileStream.SetLength

Sets the length of this stream to the given value.

[Visual Basic]
Overrides Public Sub SetLength( _
   ByVal value As Long _
)
[C#]
public override void SetLength(
   long value
);
[C++]
public: override void SetLength(
   __int64 value
);
[JScript]
public override function SetLength(
   value : long
);

Parameters

value
The new length of the stream.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.
NotSupportedException | The stream does not support both writing and seeking.

Remarks

If the given value is less than the current length of the stream, the stream is truncated. If the given value is larger than the current length of the stream, the stream is expanded. If the stream is expanded, the contents of the stream between the old and the new length are undefined. A stream must support both writing and seeking to implement SetLength.

See Also

FileStream Class | FileStream Members | System.IO Namespace


FileStream.Unlock

Allows access by other processes to all or part of a file that was previously locked.

[Visual Basic]
Overridable Public Sub Unlock( _
   ByVal position As Long, _
   ByVal length As Long _
)
[C#]
public virtual void Unlock(
   long position,
   long length
);
[C++]
public: virtual void Unlock(
   __int64 position,
   __int64 length
);
[JScript]
public function Unlock(
   position : long,
   length : long
);

Parameters

position
[To be supplied.]
length
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | position or length are negative.

See Also

FileStream Class | FileStream Members | System.IO Namespace


FileStream.Write

Writes a block of bytes to this stream using data from a buffer.

[Visual Basic]
Overrides Public Function Write( _
   ByVal array() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
[C#]
public override int Write(
   byte[] array,
   int offset,
   int count
);
[C++]
public: override int Write(
   unsigned char* array[],
   int offset,
   int count
);
[JScript]
public override function Write(
   array : Byte[],
   offset : int,
   count : int
) : int;

Parameters

array
The array to read.
offset
The byte offset in buffer at which to begin reading.
count
The maximum number of bytes to write.

Exceptions

Exception Type | Condition
ArgumentNullException | array is a null reference (in Visual Basic Nothing).
ArgumentException | offset and count describe an invalid range in array.
ArgumentOutOfRangeException | offset or count are negative.
IOException | An I/O error occurs.
NotSupportedException | The stream does not support writing.

Remarks

The offset parameter gives the offset of the byte in buffer at which to begin reading, and the count parameter gives the maximum number of bytes that will be written to this stream. If the write operation is successful, the current position of the stream is advanced by the number of bytes written. If an exception occurs, the current position of the stream is unchanged.

See Also

FileStream Class | FileStream Members | System.IO Namespace


FileStream.WriteByte

Writes a byte to the current position in the file stream.

[Visual Basic]
Overrides Public Sub WriteByte( _
   ByVal value As Byte _
)
[C#]
public override void WriteByte(
   byte value
);
[C++]
public: override void WriteByte(
   unsigned char value
);
[JScript]
public override function WriteByte(
   value : Byte
);

Parameters

value
A byte to write to the stream.

Exceptions

Exception Type | Condition
IOException | The stream is closed.
NotSupportedException | The stream does not support writing.

Remarks

Writes a byte to a file stream efficiently. If the stream is closed or not writable, an exception will be thrown.

See Also

FileStream Class | FileStream Members | System.IO Namespace


FileSystemAttributes Enumeration

Provides attributes for files and directories. Not all attributes are applicable to both files and directories. These constants correspond to those in WinNT.h.

[Visual Basic]
Public Enum FileSystemAttributes
[C#]
public enum FileSystemAttributes
[C++]
public enum FileSystemAttributes

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Archive | Indicates the file's archive status. Applications use this attribute to mark files for backup or removal.
Compressed | Indicates the file's compression status.
Directory | Indicates that the file is a directory.
Encrypted | Indicates that the file is encrypted.
Hidden | Indicates that the file is hidden, and thus is not included in an ordinary directory listing.
Normal | Indicates that the file is normal. The file has no other attributes set. This attribute is valid only if used alone.
NotContentIndexed | Indicates that the file will not be indexed by the operating system's content indexing service.
Offline | Indicates that the file is offline. The data of the file is not immediately available.
ReadOnly | Indicates that the file is read-only.
ReparsePoint | Indicates that the file contains a reparse point, which is a block of user-defined data associated with a file or a directory.
SparseFile | Indicates that the file is a sparse file. Sparse files are typically large files whose data are mostly zeros.
System | Indicates that the file is a system file. The file is part of the operating system or is used exclusively by the operating system.
Temporary | Indicates that the file is temporary. File systems attempt to keep all of the data in memory for quicker access rather than flushing the data back to mass storage. A temporary file should be deleted by the application as soon as it is no longer needed.

Requirements

Namespace: System.IO

Assembly: mscorlib.dll

See Also

System.IO Namespace


FileSystemEntry Class

Provides the base class for both File and Directory objects. This class is abstract.

Object
FileSystemEntry

[Visual Basic]
MustInherit Public Class FileSystemEntry
[C#]
public abstract class FileSystemEntry
[C++]
public __gc __abstract class FileSystemEntry
[JScript]
public abstract class FileSystemEntry

Remarks

[To be supplied.]

Requirements

Namespace: System.IO

Assembly: mscorlib.dll

See Also

FileSystemEntry Members | System.IO Namespace


FileSystemEntry Members

Public:

Constructor

FileSystemEntry Constructor [To be supplied.]

Properties

Attributes | Retrieves or sets the attributes of the current file or directory.
CreationTime | Retrieves the creation time of the current file or directory.
Exists | Indicates whether the file or directory exists.
FullName | Retrieves the full path of the directory or file.
IsDirectory | Indicates whether the object is a directory.
IsFile | Indicates whether the object is a file.
LastAccessTime | Retrieves the time the current file or directory was last accessed.
LastWriteTime | Retrieves the time when the current file or directory was last written to.
Name | For files, retrieves the name of the file. For directories, retrieves the name of the last directory in the hierarchy if possible, otherwise retrieves the fully qualified name.

Methods

Delete | Deletes a file or directory.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Refresh | Refreshes the file or directory attribute information.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

FullPath Retrieves the fully qualified path of the directory.

See Also

FileSystemEntry Class | System.IO Namespace


FileSystemEntry Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public FileSystemEntry();
[C++]
public: FileSystemEntry();
[JScript]
public function FileSystemEntry();

See Also

FileSystemEntry Class | FileSystemEntry Members | System.IO Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

FileSystemEntry Properties

The properties of the FileSystemEntry class are listed below. For a complete list of FileSystemEntry class members, see the FileSystemEntry Members topic.

Public:

Attributes | Retrieves or sets the attributes of the current file or directory.
CreationTime | Retrieves the creation time of the current file or directory.
Exists | Indicates whether the file or directory exists.
FullName | Retrieves the full path of the directory or file.
IsDirectory | Indicates whether the object is a directory.
IsFile | Indicates whether the object is a file.
LastAccessTime | Retrieves the time the current file or directory was last accessed.
LastWriteTime | Retrieves the time when the current file or directory was last written to.
Name | For files, retrieves the name of the file. For directories, retrieves the name of the last directory in the hierarchy if possible, otherwise retrieves the fully qualified name.

See Also

FileSystemEntry Class | System.IO Namespace


FileSystemEntry.Attributes

Retrieves or sets the attributes of the current file or directory.

[Visual Basic]
MustOverride Public Property Attributes As FileSystemAttributes
[C#]
public FileSystemAttributes Attributes {abstract get; abstract
   set;}
[C++]
public: __property virtual FileSystemAttributes get_Attributes() = 0;public: __property virtual void set_Attributes(FileSystemAttributes) = 0;
[JScript]
public abstract function get Attributes() : FileSystemAttributes;
public abstract function set Attributes(FileSystemAttributes);

Property Value

The FileSystemAttributes enumeration that indicates the attributes of the current file or directory.

See Also

FileSystemEntry Class | FileSystemEntry Members | System.IO Namespace


FileSystemEntry.CreationTime

Retrieves the creation time of the current file or directory.

[Visual Basic]
MustOverride Public ReadOnly Property CreationTime As DateTime
[C#]
public DateTime CreationTime {abstract get;}
[C++]
public: __property virtual DateTime get_CreationTime() = 0;
[JScript]
public abstract function get CreationTime() : DateTime;

Property Value

A DateTime that is the creation time of the current file or directory.

See Also

FileSystemEntry Class | FileSystemEntry Members | System.IO Namespace


FileSystemEntry.Exists

Indicates whether the file or directory exists.

[Visual Basic]
MustOverride Public ReadOnly Property Exists As Boolean
[C#]
public bool Exists {abstract get;}
[C++]
public: __property virtual bool get_Exists() = 0;
[JScript]
public abstract function get Exists() : Boolean;

Property Value

true if the file or directory exists; otherwise, false.

See Also

FileSystemEntry Class | FileSystemEntry Members | System.IO Namespace


FileSystemEntry.FullName

Retrieves the full path of the directory or file.

[Visual Basic]
Overridable Public ReadOnly Property FullName As String
[C#]
public string FullName {virtual get;}
[C++]
public: __property virtual String* get_FullName();
[JScript]
public function get FullName() : String;

See Also

FileSystemEntry Class | FileSystemEntry Members | System.IO Namespace


FileSystemEntry.IsDirectory

Indicates whether the object is a directory.

[Visual Basic]
MustOverride Public ReadOnly Property IsDirectory As Boolean
[C#]
public bool IsDirectory {abstract get;}
[C++]
public: __property virtual bool get_IsDirectory() = 0;
[JScript]
public abstract function get IsDirectory() : Boolean;

Property Value

true if the object is a directory; otherwise, false.

See Also

FileSystemEntry Class | FileSystemEntry Members | System.IO Namespace


FileSystemEntry.IsFile

Indicates whether the object is a file.

[Visual Basic]
MustOverride Public ReadOnly Property IsFile As Boolean
[C#]
public bool IsFile {abstract get;}
[C++]
public: __property virtual bool get_IsFile() = 0;
[JScript]
public abstract function get IsFile() : Boolean;

Property Value

true if the object is a file; otherwise, false.

See Also

FileSystemEntry Class | FileSystemEntry Members | System.IO Namespace


FileSystemEntry.LastAccessTime

Retrieves the time the current file or directory was last accessed.

[Visual Basic]
MustOverride Public ReadOnly Property LastAccessTime As DateTime
[C#]
public DateTime LastAccessTime {abstract get;}
[C++]
public: __property virtual DateTime get_LastAccessTime() = 0;
[JScript]
public abstract function get LastAccessTime() : DateTime;

Property Value

A DateTime that is the time when the current file or directory was last accessed.

See Also

FileSystemEntry Class | FileSystemEntry Members | System.IO Namespace


FileSystemEntry.LastWriteTime

Retrieves the time when the current file or directory was last written to.

[Visual Basic]
MustOverride Public ReadOnly Property LastWriteTime As DateTime
[C#]
public DateTime LastWriteTime {abstract get;}
[C++]
public: __property virtual DateTime get_LastWriteTime() = 0;
[JScript]
public abstract function get LastWriteTime() : DateTime;

Property Value

A DateTime that is the time when the current file or directory was last written to.

See Also

FileSystemEntry Class | FileSystemEntry Members | System.IO Namespace


FileSystemEntry.Name

For files, retrieves the name of the file. For directories, retrieves the name of the last directory in the hierarchy if possible, otherwise retrieves the fully qualified name.

[Visual Basic]
MustOverride Public ReadOnly Property Name As String
[C#]
public string Name {abstract get;}
[C++]
public: __property virtual String* get_Name() = 0;
[JScript]
public abstract function get Name() : String;

Property Value

A string that is the filename, the name of the last directory in the hierarchy, or the fully qualified name.

See Also

FileSystemEntry Class | FileSystemEntry Members | System.IO Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

FileSystemEntry Methods

The methods of the FileSystemEntry class are listed below. For a complete list of FileSystemEntry class members, see the FileSystemEntry Members topic.

Public:

Delete | Deletes a file or directory.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Refresh | Refreshes the file or directory attribute information.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FileSystemEntry Class | System.IO Namespace


FileSystemEntry.Delete

Deletes a file or directory.

[Visual Basic]
MustOverride Public Sub Delete()
[C#]
public abstract void Delete();
[C++]
public: virtual void Delete() = 0;
[JScript]
public abstract function Delete();

See Also

FileSystemEntry Class | FileSystemEntry Members | System.IO Namespace


FileSystemEntry.Refresh

Refreshes the file or directory attribute information.

[Visual Basic]
MustOverride Public Sub Refresh()
[C#]
public abstract void Refresh();
[C++]
public: virtual void Refresh() = 0;
[JScript]
public abstract function Refresh();

Remarks

Calls must be made to Refresh before attempting to get the attribute information, or the information will be outdated.

See Also

FileSystemEntry Class | FileSystemEntry Members | System.IO Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

FileSystemEntry Fields

The fields of the FileSystemEntry class are listed below. For a complete list of FileSystemEntry class members, see the FileSystemEntry Members topic.

Protected:

FullPath Retrieves the fully qualified path of the directory.

See Also

FileSystemEntry Class | System.IO Namespace


FileSystemEntry.FullPath

Retrieves the fully qualified path of the directory.

[Visual Basic]
Protected FullPath As String
[C#]
protected string FullPath;
[C++]
protected: String* FullPath;
[JScript]
protected var FullPath : String;

Remarks

A string representing the full path of the directory or file.

See Also

FileSystemEntry Class | FileSystemEntry Members | System.IO Namespace


FileSystemEventArgs Class

Provides data for the directory events: TBD, System.IO.FileSystemEventArgs.Deleted.

Object
EventArgs
FileSystemEventArgs

[Visual Basic]
Public Class FileSystemEventArgs
   Inherits EventArgs
[C#]
public class FileSystemEventArgs : EventArgs
[C++]
public __gc class FileSystemEventArgs : public EventArgs
[JScript]
public class FileSystemEventArgs extends EventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.IO

Assembly: system.io.dll

See Also

FileSystemEventArgs Members | System.IO Namespace | OnCreated | OnDeleted | FileSystemEventHandler


FileSystemEventArgs Members

Public:

Constructor

FileSystemEventArgs Constructor Initializes a new instance of the FileSystemEventArgs class.

Properties

ChangeType | Gets one of the WatcherChangeTypes values.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
FullPath | Gets the fully qualifed path of the affected file or directory.
Name | Gets the name of the affected file or directory.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FileSystemEventArgs Class | System.IO Namespace


FileSystemEventArgs Constructor

Initializes a new instance of the FileSystemEventArgs class.

[Visual Basic]
Public Sub New( _
   ByVal changeType As WatcherChangeTypes, _
   ByVal directory As String, _
   ByVal name As String _
)
[C#]
public FileSystemEventArgs(
   WatcherChangeTypes changeType,
   string directory,
   string name
);
[C++]
public: FileSystemEventArgs(
   WatcherChangeTypes changeType,
   String* directory,
   String* name
);
[JScript]
public function FileSystemEventArgs(
   changeType : WatcherChangeTypes,
   directory : String,
   name : String
);

Parameters

changeType
One of the WatcherChangeTypes values.
directory
The root directory of the affected file or directory.
name
The name of the affected file or directory.

Remarks

The FileSystemWatcher component will create and call an event handler passing in this object, specifying the type of change and the affected file or directory.

See Also

FileSystemEventArgs Class | FileSystemEventArgs Members | System.IO Namespace | FileSystemWatcher | WatcherChangeTypes


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

FileSystemEventArgs Properties

The properties of the FileSystemEventArgs class are listed below. For a complete list of FileSystemEventArgs class members, see the FileSystemEventArgs Members topic.

Public:

ChangeType | Gets one of the WatcherChangeTypes values.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
FullPath | Gets the fully qualifed path of the affected file or directory.
Name | Gets the name of the affected file or directory.

See Also

FileSystemEventArgs Class | System.IO Namespace


FileSystemEventArgs.ChangeType

Gets one of the WatcherChangeTypes values.

[Visual Basic]
Overridable Public ReadOnly Property ChangeType As _
   WatcherChangeTypes
[C#]
public WatcherChangeTypes ChangeType {virtual get;}
[C++]
public: __property virtual WatcherChangeTypes get_ChangeType();
[JScript]
public function get ChangeType() : WatcherChangeTypes;

Property Value

One of the WatcherChangeTypes values.

See Also

FileSystemEventArgs Class | FileSystemEventArgs Members | System.IO Namespace | WatcherChangeTypes


FileSystemEventArgs.FullPath

Gets the fully qualifed path of the affected file or directory.

[Visual Basic]
Overridable Public ReadOnly Property FullPath As String
[C#]
public string FullPath {virtual get;}
[C++]
public: __property virtual String* get_FullPath();
[JScript]
public function get FullPath() : String;

Property Value

The path of the affected file or directory.

See Also

FileSystemEventArgs Class | FileSystemEventArgs Members | System.IO Namespace


FileSystemEventArgs.Name

Gets the name of the affected file or directory.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {virtual get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

Property Value

The name of the affected file or directory.

See Also

FileSystemEventArgs Class | FileSystemEventArgs Members | System.IO Namespace


FileSystemEventHandler Delegate

Represents the method that will handle the System.IO.FileSystemWatcher.Created, or System.IO.FileSystemWatcher.Deleted event of a FileSystemWatcher class.

[Visual Basic]
Public Delegate Sub FileSystemEventHandler( _
   ByVal sender As Object, _
   ByVal e As FileSystemEventArgs _
)
[C#]
public delegate void FileSystemEventHandler(
   object sender,
   FileSystemEventArgs e
);
[C++]
public __gc __delegate void FileSystemEventHandler(
   Object* sender,
   FileSystemEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the FileSystemEventHandler delegate declaration.

sender
The source of the event.
e
The FileSystemEventArgs that contains the event data.

Remarks

When you create a FileSystemEventHandler delegate, you identify the method that will handle the event. To associate the event with your event-handling method, add an instance of the delegate to the event. The event-handling method is called whenever the event occurs, unless you remove the delegate. For more information about event handler delegates, see TBD.

Requirements

Namespace: System.IO

Assembly: system.io.dll

See Also

System.IO Namespace | System.IO.FileSystemWatcher.Created | System.IO.FileSystemWatcher.Deleted | FileSystemEventArgs | FileSystemWatcher


FileSystemWatcher Class

Listens to the system directory change notifications and raises events when a directory or file within a directory changes.

Object
Component
FileSystemWatcher

[Visual Basic]
Public Class FileSystemWatcher
   Inherits Component
   Implements ISupportInitialize
[C#]
public class FileSystemWatcher : Component, ISupportInitialize
[C++]
public __gc class FileSystemWatcher : public Component,
   ISupportInitialize
[JScript]
public class FileSystemWatcher extends Component,
   ISupportInitialize

Remarks

Use FileSystemWatcher to watch for changes in a specified directory. You can watch for changes in both files and subdirectories of the specified directory. The component can be used to watch files on your personal computer, a network drive, or a remote machine.

Note You cannot watch a remote computer that does not have Windows NT or Windows 2000 installed. You cannot watch a remote Windows NT 4.0 computer from a Windows NT 4.0 computer.

To watch for changes in all files, set the Filter property to "*.*". To watch a specific file, set the Filter property to the file name. For example, if you want to watch for any changes in the file MyDoc.txt, set the Filter property to "MyDoc.txt". You can also watch for changes in a certain type of file. For example, to watch for changes in any text files, set the Filter property to "*.txt".

Note Hidden files are not ignored.

There are several types of changes you can watch for in a directory or file. For example, you can watch for changes in Attributes, the LastWrite date and time, or the Size of files or directories. This is done by setting the ChangedFilter property to one of the ChangedFilters values. For more information on the type of changes you can watch for, see ChangedFilters. For more information on using the ChangedFilter property, see ChangedFilter.

You can watch for any renaming, deletion, or creation of files or directories. For example, to watch for any renaming of text files, set the Filter property to "*.txt" and call one of the WaitForChanged methods with the WatcherChangeTypes value Renamed given.

The system notifies you of file changes in a buffer that the component creates and passes to the Application Programming Interfaces. If there are a lot of changes in a short amount of time, the buffer can overflow. This causes the component to lose track of changes in the directory, and it will only be able to provide a blanket notification. Increasing the size of the buffer is expensive, as it comes from non-paged memory that cannot be swapped out to disk, so you want to keep the buffer as small as possible. To avoid a buffer overflow, use the ChangedFilter, IncludeSubdirectories, and Target properties so you can filter out your unwanted change notifications. For more information on the buffer size, see InternalBufferSize.

Note Setting the Filter does not decrease what goes into the buffer.

When an instance of FileSystemWatcher is created, some of the read/write properties are set to initial values. For a list of these values, see the FileSystemWatcher constructor.

Requirements

Namespace: System.IO

Assembly: system.io.dll

See Also

FileSystemWatcher Members | System.IO Namespace | ChangedFilter | ChangedFilters | FileSystemEventArgs | FileSystemEventHandler | Filter | IncludeSubdirectories | InternalBufferOverflowException | RenamedEventArgs | RenamedEventHandler | Target | WaitForChangedResult | WatcherChangeTypes | WatcherTarget


FileSystemWatcher Members

Public:

Constructor

FileSystemWatcher Constructor Overloaded. Initializes a new instance of the FileSystemWatcher class.

Properties

ChangedFilter | Gets or sets the type of changes to watch for.
Enabled | Gets or sets a value indicating whether the component is enabled.
Filter | Gets or sets the filter string, used to determine what files are monitored in a directory.
IncludeSubdirectories | Gets or sets a value indicating whether subdirectories within the specified path should be monitored.
InternalBufferSize | Gets or sets the internal buffer size.
Path | Gets or sets the path string of the directory to watch.
Site (inherited from Component) | Gets or sets the site of the Component.
SynchronizingObject | Gets or sets the object used to marshal the event handler calls issued as a result of a directory change.
Target | Gets or sets a value indicating whether to watch files, directories, or files and directories within the given path.

Methods

BeginInit | Notifies the object that initialization is beginning and tells it to standby.
Dispose | Disposes of the resources (other than memory) used by the FileSystemWatcher.
EndInit | Notifies the object that initialization is complete.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Start | Starts monitoring the specified directory.
Stop | Stops monitoring the specified directory.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
WaitForChanged | Overloaded. A synchronous method that returns a structure for the specified type of change that you wish to monitor.

Events

Changed | Occurs when a file or directory is changed.
Created | Occurs when a file or directory is created.
Deleted | Occurs when a file or directory is deleted.
Error | Occurs when an error is raised.
Renamed | Occurs when a file or directory is renamed.

Protected:

Methods

Finalize (inherited from Component) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnChanged | Raises the System.IO.FileSystemWatcher.Changed event.
OnCreated | Raises the System.IO.FileSystemWatcher.Created event.
OnDeleted | Raises the System.IO.FileSystemWatcher.Deleted event.
OnError | Raises the System.IO.FileSystemWatcher.Error event.
OnRenamed | Raises the System.IO.FileSystemWatcher.Renamed event.

Event Hookup:

Methods

AddOnChanged | [To be supplied.]
AddOnCreated | [To be supplied.]
AddOnDeleted | [To be supplied.]
AddOnError | [To be supplied.]
AddOnRenamed | [To be supplied.]
RemoveOnChanged | [To be supplied.]
RemoveOnCreated | [To be supplied.]
RemoveOnDeleted | [To be supplied.]
RemoveOnError | [To be supplied.]
RemoveOnRenamed | [To be supplied.]

See Also

FileSystemWatcher Class | System.IO Namespace


FileSystemWatcher Constructor

Initializes a new instance of the FileSystemWatcher class.

Overload List

Initializes a new instance of the FileSystemWatcher class.

[Visual Basic] Overloads Public Sub New()
[C#] public FileSystemWatcher();
[C++] public: FileSystemWatcher();
[JScript] public function FileSystemWatcher();

Initializes a new instance of the FileSystemWatcher class, given the specified directory to monitor.

[Visual Basic] Overloads Public Sub New(String)
[C#] public FileSystemWatcher(String);
[C++] public: FileSystemWatcher(String*);
[JScript] public function FileSystemWatcher(String);

Initializes a new instance of the FileSystemWatcher class, given the specified directory and type of files to monitor.

[Visual Basic] Overloads Public Sub New(String, String)
[C#] public FileSystemWatcher(String, String);
[C++] public: FileSystemWatcher(String*, String*);
[JScript] public function FileSystemWatcher(String, String);

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace


FileSystemWatcher Constructor ()

Initializes a new instance of the FileSystemWatcher class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public FileSystemWatcher();
[C++]
public: FileSystemWatcher();
[JScript]
public function FileSystemWatcher();

Remarks

Note The component will not begin watching the specified directory until the Path is set.

You cannot watch a remote computer that does not have Windows NT or Windows 2000. You cannot watch a remote Windows NT 4.0 computer from a Windows NT 4.0 computer.

When an instance of FileSystemWatcher is created, the following read/write properties are set to initial values.

Property | Initial Value
ChangedFilter | LastWrite
Enabled | false
Filter | "*.*" (watch all files)
IncludeSubdirectories | false
InternalBufferSize | 8192
Path | empty string ("")
Target | Both

You can change the value for any of these properties through a separate call to the property.

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace | FileSystemWatcher Constructor Overload List | ChangedFilters | FileSystemEventArgs | FileSystemEventHandler | InternalBufferOverflowException | Path | RenamedEventArgs | RenamedEventHandler | WaitForChangedResult | WatcherChangeTypes | WatcherTarget


FileSystemWatcher Constructor (String)

Initializes a new instance of the FileSystemWatcher class, given the specified directory to monitor.

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As String _
)
[C#]
public FileSystemWatcher(
   string path
);
[C++]
public: FileSystemWatcher(
   String* path
);
[JScript]
public function FileSystemWatcher(
   path : String
);

Parameters

path
The directory to monitor, in standard or UNC notation.

Remarks

The component can be used to watch files on your personal computer, a network drive, or a remote machine.

Note You cannot watch a remote computer that does not have Windows NT or Windows 2000. You cannot watch a remote Windows NT 4.0 computer from a Windows NT 4.0 computer. The Filter property is set by default to watch all files.

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace | FileSystemWatcher Constructor Overload List | ChangedFilters | FileSystemEventArgs | FileSystemEventHandler | Filter | InternalBufferOverflowException | Path | RenamedEventArgs | RenamedEventHandler | WaitForChangedResult | WatcherChangeTypes | WatcherTarget


FileSystemWatcher Constructor (String, String)

Initializes a new instance of the FileSystemWatcher class, given the specified directory and type of files to monitor.

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As String, _
   ByVal filter As String _
)
[C#]
public FileSystemWatcher(
   string path,
   string filter
);
[C++]
public: FileSystemWatcher(
   String* path,
   String* filter
);
[JScript]
public function FileSystemWatcher(
   path : String,
   filter : String
);

Parameters

path
The directory to monitor, in standard or UNC notation.
filter
The type of files to watch for. For example, "*.txt" watches for changes to all text files.

Remarks

The component can be used to watch files on your personal computer, a network drive, or a remote machine.

Note You cannot watch a remote computer that does not have Windows NT or Windows 2000. You cannot watch a remote Windows NT 4.0 computer from a Windows NT 4.0 computer.

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace | FileSystemWatcher Constructor Overload List | ChangedFilters | FileSystemEventArgs | FileSystemEventHandler | Filter | InternalBufferOverflowException | Path | RenamedEventArgs | RenamedEventHandler | WaitForChangedResult | WatcherChangeTypes | WatcherTarget


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

FileSystemWatcher Properties

The properties of the FileSystemWatcher class are listed below. For a complete list of FileSystemWatcher class members, see the FileSystemWatcher Members topic.

Public:

ChangedFilter | Gets or sets the type of changes to watch for.
Enabled | Gets or sets a value indicating whether the component is enabled.
Filter | Gets or sets the filter string, used to determine what files are monitored in a directory.
IncludeSubdirectories | Gets or sets a value indicating whether subdirectories within the specified path should be monitored.
InternalBufferSize | Gets or sets the internal buffer size.
Path | Gets or sets the path string of the directory to watch.
Site (inherited from Component) | Gets or sets the site of the Component.
SynchronizingObject | Gets or sets the object used to marshal the event handler calls issued as a result of a directory change.
Target | Gets or sets a value indicating whether to watch files, directories, or files and directories within the given path.

See Also

FileSystemWatcher Class | System.IO Namespace


FileSystemWatcher.ChangedFilter

Gets or sets the type of changes to watch for.

[Visual Basic]
Overridable Public Property ChangedFilter As ChangedFilters
[C#]
public ChangedFilters ChangedFilter {virtual get; virtual set;}
[C++]
public: __property virtual ChangedFilters get_ChangedFilter();
public: __property virtual void set_ChangedFilter(ChangedFilters);
[JScript]
public function get ChangedFilter() : ChangedFilters;
public function set ChangedFilter(ChangedFilters);

Property Value

One of the ChangedFilters values. The default is LastWrite.

Remarks

You can combine the members of the ChangedFilters enumeration to watch for more than one type of change at a time. For example, you can watch for any changes in the the size of a file or folder, and for any changes in the LastWrite time. This raises an event anytime there is a change in the file or folder size, or a change in the LastWrite time of the file or folder.

This is one way to filter out unwanted notifications. For more information on filtering out unwanted notifications, see the Filter, IncludeSubdirectories, InternalBufferSize, and Target properties.

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace | ChangedFilters | Filter | IncludeSubdirectories | InternalBufferSize | Target


FileSystemWatcher.Enabled

Gets or sets a value indicating whether the component is enabled.

[Visual Basic]
Overridable Public Property Enabled As Boolean
[C#]
public bool Enabled {virtual get; virtual set;}
[C++]
public: __property virtual bool get_Enabled();
public: __property virtual void set_Enabled(bool);
[JScript]
public function get Enabled() : Boolean;
public function set Enabled(Boolean);

Property Value

true if the component is enabled; otherwise, false. The default is false. If you are using the component on a designer in Visual Studio 7, the default is true.

Remarks

true is the same as using Start, and false is the same as using Stop.

Note The component will not begin watching the specified directory until the Path property has been set.

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace | Start | Stop


FileSystemWatcher.Filter

Gets or sets the filter string, used to determine what files are monitored in a directory.

[Visual Basic]
Overridable Public Property Filter As String
[C#]
public string Filter {virtual get; virtual set;}
[C++]
public: __property virtual String* get_Filter();
public: __property virtual void set_Filter(String*);
[JScript]
public function get Filter() : String;
public function set Filter(String);

Property Value

The filter string. The default is "*.*" (all files).

Remarks

To watch for changes in all files, set the Filter property to "*.*". To watch a specific file, set the Filter property to the file name. For example, if you want to watch for any changes in the file MyDoc.txt, set the Filter property to "MyDoc.txt". You can also watch for changes in a certain type of file. For example, to watch for changes in any text files, set the Filter property to "*.txt".

The Filter applies to change notifications after they have gone through the buffer and does not limit what goes into the buffer. For more information on filtering out unwanted notifications before recording them in the buffer, see the ChangedFilter, IncludeSubdirectories, InternalBufferSize, and Target properties.

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace | ChangedFilter | IncludeSubdirectories | InternalBufferSize | Target


FileSystemWatcher.IncludeSubdirectories

Gets or sets a value indicating whether subdirectories within the specified path should be monitored.

[Visual Basic]
Overridable Public Property IncludeSubdirectories As Boolean
[C#]
public bool IncludeSubdirectories {virtual get; virtual set;}
[C++]
public: __property virtual bool get_IncludeSubdirectories();
public: __property virtual void set_IncludeSubdirectories(bool);
[JScript]
public function get IncludeSubdirectories() : Boolean;
public function set IncludeSubdirectories(Boolean);

Property Value

true if you want to monitor subdirectories; otherwise, false. The default is false.

Remarks

Use the IncludeSubdirectories property when you want to watch for change notifications for files and directories contained within subdirectories of the Path property. This is one way to filter out unwanted notifications. For more information on filtering out unwanted notifications, see the ChangedFilter, Filter, InternalBufferSize, and Target properties.

When true, IncludeSubdirectories is recursive through the entire sub-tree, not just the child directories. The relative path to a file or directory within the sub-tree is returned in the Name property of FileSystemEventArgs and the OldName property of RenamedEventArgs, depending on the changes you are watching for. You can get the fully qualified path from the FullPath property of FileSystemEventArgs and the OldFullPath property of RenamedEventArgs, depending on the changes you are watching for.

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace | ChangedFilter | FileSystemEventArgs | Filter | TBD | TBD | InternalBufferSize | TBD | TBD | Path | RenamedEventArgs | Target


FileSystemWatcher.InternalBufferSize

Gets or sets the internal buffer size.

[Visual Basic]
Overridable Public Property InternalBufferSize As Integer
[C#]
public int InternalBufferSize {virtual get; virtual set;}
[C++]
public: __property virtual int get_InternalBufferSize();
public: __property virtual void set_InternalBufferSize(int);
[JScript]
public function get InternalBufferSize() : int;
public function set InternalBufferSize(int);

Property Value

The internal buffer size. The default is 8192 (8K).

Remarks

The buffer can be set to anything above 4096 (4K), but for best performance, it should be a multiple of 4K on x86 machines.

The system notifies you of file changes, it stores those changes in a buffer that the component creates and passes to the Application Programming Interfaces. If there are a lot of changes in a short amount of time, the buffer can overflow. This causes the component to lose track of changes in the directory, and it will only be able to provide a blanket notification. Increasing the size of the buffer is expensive, as it comes from non-paged memory that cannot be swapped out to disk, so you want to keep the buffer as small as possible. To avoid a buffer overflow, use the ChangedFilter, Filter, IncludeSubdirectories, and Target properties to filter out unwanted change notifications.

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace | ChangedFilter | OnError | Filter | IncludeSubdirectories | InternalBufferOverflowException | Target


FileSystemWatcher.Path

Gets or sets the path string of the directory to watch.

[Visual Basic]
Overridable Public Property Path As String
[C#]
public string Path {virtual get; virtual set;}
[C++]
public: __property virtual String* get_Path();
public: __property virtual void set_Path(String*);
[JScript]
public function get Path() : String;
public function set Path(String);

Property Value

The path to monitor. The default is an empty string ("").

Remarks

This is a fully qualified path to a directory. The directory is the root at which the system will listen to notifications. To watch a specific file, set the Path property to the correct directory, and the Filter property to the filename.

The Path property supports Universal Naming Convention paths.

Note This property must be set before the component can start watching for changes.

When a directory is renamed, the FileSystemWatcher will automatically "reattach" itself to the newly renamed item. For example, if you set the Path property to "c:\My Documents" and then manually rename the directory to "c:\Your Documents", the component will continue to listen for change notifications on the newly renamed directory. However, when you ask for the Path property, it will contain the old path. This happens because the component determines what directory it is watching based on the handle, rather than the name of the directory. Renaming does not affect the handle. So, if you destroy the component, and then recreate it without updating the Path property, your application will fail because the directory no longer exists.

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace | FileSystemWatcher | Filter


FileSystemWatcher.SynchronizingObject

Gets or sets the object used to marshal the event handler calls issued as a result of a directory change.

[Visual Basic]
Public Property SynchronizingObject As ISynchronizeInvoke
[C#]
public ISynchronizeInvoke SynchronizingObject {get; set;}
[C++]
public: __property ISynchronizeInvoke* get_SynchronizingObject();
public: __property void set_SynchronizingObject(ISynchronizeInvoke*);
[JScript]
public function get SynchronizingObject() : ISynchronizeInvoke;
public function set SynchronizingObject(ISynchronizeInvoke);

Property Value

An ISynchronizeInvoke that represents the object used to marshal the event handler calls issued as a result of a directory change. The default is a null reference (in Visual Basic Nothing).

Remarks

This property will normally be set when the component is placed inside a control or a form, because these components are bound to a specific thread.

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace | ISynchronizeInvoke


FileSystemWatcher.Target

Gets or sets a value indicating whether to watch files, directories, or files and directories within the given path.

[Visual Basic]
Overridable Public Property Target As WatcherTarget
[C#]
public WatcherTarget Target {virtual get; virtual set;}
[C++]
public: __property virtual WatcherTarget get_Target();
public: __property virtual void set_Target(WatcherTarget);
[JScript]
public function get Target() : WatcherTarget;
public function set Target(WatcherTarget);

Property Value

One of the WatcherTarget values. The default is Both.

Remarks

This property is used to determine whether the component should react to file changes, directory changes, or both file and directory changes. For example, if Target is set to listen only to file change notifications, and the Filter property is set to "*.txt", the creation of a directory called "MyDoc.txt" will not result in a change notification.

This is one way to filter out unwanted notifications. For more information on filtering out unwanted notifications, see the ChangedFilter, Filter, IncludeSubdirectories, and InternalBufferSize properties.

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace | ChangedFilter | Filter | IncludeSubdirectories | InternalBufferSize | WatcherTarget


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

FileSystemWatcher Methods

The methods of the FileSystemWatcher class are listed below. For a complete list of FileSystemWatcher class members, see the FileSystemWatcher Members topic.

Public:

BeginInit | Notifies the object that initialization is beginning and tells it to standby.
Dispose | Disposes of the resources (other than memory) used by the FileSystemWatcher.
EndInit | Notifies the object that initialization is complete.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Start | Starts monitoring the specified directory.
Stop | Stops monitoring the specified directory.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
WaitForChanged | Overloaded. A synchronous method that returns a structure for the specified type of change that you wish to monitor.

Protected:

Finalize (inherited from Component) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnChanged | Raises the System.IO.FileSystemWatcher.Changed event.
OnCreated | Raises the System.IO.FileSystemWatcher.Created event.
OnDeleted | Raises the System.IO.FileSystemWatcher.Deleted event.
OnError | Raises the System.IO.FileSystemWatcher.Error event.
OnRenamed | Raises the System.IO.FileSystemWatcher.Renamed event.

Event Hookup:

AddOnChanged | [To be supplied.]
AddOnCreated | [To be supplied.]
AddOnDeleted | [To be supplied.]
AddOnError | [To be supplied.]
AddOnRenamed | [To be supplied.]
RemoveOnChanged | [To be supplied.]
RemoveOnCreated | [To be supplied.]
RemoveOnDeleted | [To be supplied.]
RemoveOnError | [To be supplied.]
RemoveOnRenamed | [To be supplied.]

See Also

FileSystemWatcher Class | System.IO Namespace


FileSystemWatcher.AddOnChanged

[To be supplied.]

[Visual Basic]
Overridable Public Sub AddOnChanged( _
   ByVal handler As FileSystemEventHandler _
)
[C#]
public virtual void AddOnChanged(
   FileSystemEventHandler handler
);
[C++]
public: virtual void AddOnChanged(
   FileSystemEventHandler* handler
);
[JScript]
public function AddOnChanged(
   handler : FileSystemEventHandler
);

Parameters

handler
[To be supplied.]

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace


FileSystemWatcher.AddOnCreated

[To be supplied.]

[Visual Basic]
Overridable Public Sub AddOnCreated( _
   ByVal handler As FileSystemEventHandler _
)
[C#]
public virtual void AddOnCreated(
   FileSystemEventHandler handler
);
[C++]
public: virtual void AddOnCreated(
   FileSystemEventHandler* handler
);
[JScript]
public function AddOnCreated(
   handler : FileSystemEventHandler
);

Parameters

handler
[To be supplied.]

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace


FileSystemWatcher.AddOnDeleted

[To be supplied.]

[Visual Basic]
Overridable Public Sub AddOnDeleted( _
   ByVal handler As FileSystemEventHandler _
)
[C#]
public virtual void AddOnDeleted(
   FileSystemEventHandler handler
);
[C++]
public: virtual void AddOnDeleted(
   FileSystemEventHandler* handler
);
[JScript]
public function AddOnDeleted(
   handler : FileSystemEventHandler
);

Parameters

handler
[To be supplied.]

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace


FileSystemWatcher.AddOnError

[To be supplied.]

[Visual Basic]
Overridable Public Sub AddOnError( _
   ByVal handler As ErrorEventHandler _
)
[C#]
public virtual void AddOnError(
   ErrorEventHandler handler
);
[C++]
public: virtual void AddOnError(
   ErrorEventHandler* handler
);
[JScript]
public function AddOnError(
   handler : ErrorEventHandler
);

Parameters

handler
[To be supplied.]

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace


FileSystemWatcher.AddOnRenamed

[To be supplied.]

[Visual Basic]
Overridable Public Sub AddOnRenamed( _
   ByVal handler As RenamedEventHandler _
)
[C#]
public virtual void AddOnRenamed(
   RenamedEventHandler handler
);
[C++]
public: virtual void AddOnRenamed(
   RenamedEventHandler* handler
);
[JScript]
public function AddOnRenamed(
   handler : RenamedEventHandler
);

Parameters

handler
[To be supplied.]

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace


FileSystemWatcher.BeginInit

Notifies the object that initialization is beginning and tells it to standby.

[Visual Basic]
Overridable Public Sub BeginInit()
[C#]
public virtual void BeginInit();
[C++]
public: virtual void BeginInit();
[JScript]
public function BeginInit();

Remarks

Use this method when you need to change multiple properties on the component all at once. By calling BeginInit, you suspend the component from watching and prevent it from checking its state. Watching the directory and checking its state is resumed by the component when EndInit is called.

Using BeginInit helps keep resource use low. If you do not call BeginInit and EndInit to change multiple properties, then every change you make will cause the component to unhook itself from the system and then reattach itself.

Note The component is not checking its state after BeginInit, and before EndInit, is called. If Enabled is true, you must supply a valid path for the Path property. The component will not begin watching until a valid path is set.

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace | EndInit


FileSystemWatcher.Dispose

Disposes of the resources (other than memory) used by the FileSystemWatcher.

[Visual Basic]
Overrides Public Sub Dispose()
[C#]
public override void Dispose();
[C++]
public: override void Dispose();
[JScript]
public override function Dispose();

Remarks

Call Dispose when you are finished using the FileSystemWatcher. The Dispose method leaves the FileSystemWatcher in an unusable state. After calling Dispose, you must release all references to the FileSystemWatcher so the memory it was occupying can be reclaimed by garbage collection.

Note Always call Dispose before you release your last reference to the FileSystemWatcher. Otherwise, the resources the FileSystemWatcher is using will not be freed until garbage collection calls the FileSystemWatcher object's destructor.

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace


FileSystemWatcher.EndInit

Notifies the object that initialization is complete.

[Visual Basic]
Overridable Public Sub EndInit()
[C#]
public virtual void EndInit();
[C++]
public: virtual void EndInit();
[JScript]
public function EndInit();

Remarks

Watching the directory and checking its state is resumed by the component when EndInit is called. For more information on using EndInit, see BeginInit.

Note The component is not checking its state after BeginInit, and before EndInit, is called. If Enabled is true, you must supply a valid path for the Path property. The component will not begin watching until a valid path is set.

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace | BeginInit


FileSystemWatcher.OnChanged

Raises the System.IO.FileSystemWatcher.Changed event.

[Visual Basic]
Overridable Protected Sub OnChanged( _
   ByVal e As FileSystemEventArgs _
)
[C#]
protected virtual void OnChanged(
   FileSystemEventArgs e
);
[C++]
protected: virtual void OnChanged(
   FileSystemEventArgs* e
);
[JScript]
protected function OnChanged(
   e : FileSystemEventArgs
);

Parameters

e
A FileSystemEventArgs that contains the event data.

Remarks

OnChanged is called when changes are made to the size, system attributes, last write time, last access time, or security permissions of a file or directory in the directory being monitored.

Raising an event invokes the event-handling method through a delegate. For more information, see TBD.

Use the ChangedFilter property to restrict the number of events raised when this event is handled.

Notes to Inheritors: When overriding OnChanged in a derived class, be sure to call the base class's OnChanged method.

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace | System.IO.FileSystemWatcher.Changed | ChangedFilter | FileSystemEventArgs | FileSystemEventHandler


FileSystemWatcher.OnCreated

Raises the System.IO.FileSystemWatcher.Created event.

[Visual Basic]
Overridable Protected Sub OnCreated( _
   ByVal e As FileSystemEventArgs _
)
[C#]
protected virtual void OnCreated(
   FileSystemEventArgs e
);
[C++]
protected: virtual void OnCreated(
   FileSystemEventArgs* e
);
[JScript]
protected function OnCreated(
   e : FileSystemEventArgs
);

Parameters

e
A FileSystemEventArgs that contains the event data.

Remarks

OnCreated is called when a file or directory is created in the directory being monitored.

Some common occurrences, such as copying or moving a file or directory, do not correspond directly to an event, but these occurrences do cause events to be raised. When you copy a file or directory, the system raises an System.IO.FileSystemWatcher.Created event in the directory to which the file was copied, if that directory is being watched. If the directory from which you were copying was being watched by another instance of FileSystemWatcher, no event would be raised. For example, you create two instances of FileSystemWatcher. FileSystemWatcher1 is set to watch "c:\My Documents", and FileSystemWatcher2 is set to watch "c:\Your Documents". Now, if you copy a file from "My Documents" and paste it into "Your Documents", an System.IO.FileSystemWatcher.Created event will be raised in FileSystemWatcher2, but no event is raised for FileSystemWatcher1. Unlike copying, moving a file or directory would raise two events. From the previous example, if you moved a file from "My Documents" to "Your Documents", an System.IO.FileSystemWatcher.Created event would be raised in FileSystemWatcher2 and an System.IO.FileSystemWatcher.Deleted event would be raised in FileSystemWatcher1.

Raising an event invokes the event-handling method through a delegate. For more information, see TBD.

Notes to Inheritors: When overriding OnCreated in a derived class, be sure to call the base class's OnCreated method.

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace | System.IO.FileSystemWatcher.Created | System.IO.FileSystemWatcher.Deleted | FileSystemEventArgs | FileSystemEventHandler


FileSystemWatcher.OnDeleted

Raises the System.IO.FileSystemWatcher.Deleted event.

[Visual Basic]
Overridable Protected Sub OnDeleted( _
   ByVal e As FileSystemEventArgs _
)
[C#]
protected virtual void OnDeleted(
   FileSystemEventArgs e
);
[C++]
protected: virtual void OnDeleted(
   FileSystemEventArgs* e
);
[JScript]
protected function OnDeleted(
   e : FileSystemEventArgs
);

Parameters

e
A FileSystemEventArgs that contains the event data.

Remarks

OnDeleted is called when a file or directory within the directory being monitored is deleted.

Some common occurrences, such as copying or moving a file or directory, do not correspond directly to an event, but these occurrences do cause events to be raised. When you copy a file or directory, the system raises an System.IO.FileSystemWatcher.Created event in the directory to which the file was copied, if that directory is being watched. If the directory from which you were copying was being watched by another instance of FileSystemWatcher, no event would be raised. For example, you create two instances of FileSystemWatcher. FileSystemWatcher1 is set to watch "c:\My Documents", and FileSystemWatcher2 is set to watch "c:\Your Documents". Now, if you copy a file from "My Documents" into "Your Documents", an System.IO.FileSystemWatcher.Created event will be raised by FileSystemWatcher2, but no event is raised for FileSystemWatcher1. Unlike copying, moving a file or directory would raise two events. From the previous example, if you moved a file from "My Documents" to "Your Documents", an System.IO.FileSystemWatcher.Created event would be raised by FileSystemWatcher2 and an System.IO.FileSystemWatcher.Deleted event would be raised by FileSystemWatcher1.

Raising an event invokes the event-handling method through a delegate. For more information, see TBD.

Notes to Inheritors: When overriding OnDeleted in a derived class, be sure to call the base class's OnDeleted method.

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace | System.IO.FileSystemWatcher.Created | System.IO.FileSystemWatcher.Deleted | FileSystemEventArgs | FileSystemEventHandler


FileSystemWatcher.OnError

Raises the System.IO.FileSystemWatcher.Error event.

[Visual Basic]
Overridable Protected Sub OnError( _
   ByVal e As ErrorEventArgs _
)
[C#]
protected virtual void OnError(
   ErrorEventArgs e
);
[C++]
protected: virtual void OnError(
   ErrorEventArgs* e
);
[JScript]
protected function OnError(
   e : ErrorEventArgs
);

Parameters

e
An ErrorEventArgs that contains the event data.

Remarks

OnError is called when an error occurs.

Raising an event invokes the event-handling method through a delegate. For more information, see TBD.

Notes to Inheritors: When overriding OnError in a derived class, be sure to call the base class's OnError method.

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace | System.IO.FileSystemWatcher.Error | ErrorEventArgs | ErrorEventHandler | InternalBufferOverflowException


FileSystemWatcher.OnRenamed

Raises the System.IO.FileSystemWatcher.Renamed event.

[Visual Basic]
Overridable Protected Sub OnRenamed( _
   ByVal e As RenamedEventArgs _
)
[C#]
protected virtual void OnRenamed(
   RenamedEventArgs e
);
[C++]
protected: virtual void OnRenamed(
   RenamedEventArgs* e
);
[JScript]
protected function OnRenamed(
   e : RenamedEventArgs
);

Parameters

e
A RenamedEventArgs that contains the event data.

Remarks

OnRenamed is called when a file or directory within the directory being monitored is renamed.

Raising an event invokes the event-handling method through a delegate. For more information, see TBD.

Notes to Inheritors: When overriding OnRenamed in a derived class, be sure to call the base class's OnRenamed method.

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace | System.IO.FileSystemWatcher.Renamed | RenamedEventArgs | RenamedEventHandler


FileSystemWatcher.RemoveOnChanged

[To be supplied.]

[Visual Basic]
Overridable Public Sub RemoveOnChanged( _
   ByVal handler As FileSystemEventHandler _
)
[C#]
public virtual void RemoveOnChanged(
   FileSystemEventHandler handler
);
[C++]
public: virtual void RemoveOnChanged(
   FileSystemEventHandler* handler
);
[JScript]
public function RemoveOnChanged(
   handler : FileSystemEventHandler
);

Parameters

handler
[To be supplied.]

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace


FileSystemWatcher.RemoveOnCreated

[To be supplied.]

[Visual Basic]
Overridable Public Sub RemoveOnCreated( _
   ByVal handler As FileSystemEventHandler _
)
[C#]
public virtual void RemoveOnCreated(
   FileSystemEventHandler handler
);
[C++]
public: virtual void RemoveOnCreated(
   FileSystemEventHandler* handler
);
[JScript]
public function RemoveOnCreated(
   handler : FileSystemEventHandler
);

Parameters

handler
[To be supplied.]

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace


FileSystemWatcher.RemoveOnDeleted

[To be supplied.]

[Visual Basic]
Overridable Public Sub RemoveOnDeleted( _
   ByVal handler As FileSystemEventHandler _
)
[C#]
public virtual void RemoveOnDeleted(
   FileSystemEventHandler handler
);
[C++]
public: virtual void RemoveOnDeleted(
   FileSystemEventHandler* handler
);
[JScript]
public function RemoveOnDeleted(
   handler : FileSystemEventHandler
);

Parameters

handler
[To be supplied.]

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace


FileSystemWatcher.RemoveOnError

[To be supplied.]

[Visual Basic]
Overridable Public Sub RemoveOnError( _
   ByVal handler As ErrorEventHandler _
)
[C#]
public virtual void RemoveOnError(
   ErrorEventHandler handler
);
[C++]
public: virtual void RemoveOnError(
   ErrorEventHandler* handler
);
[JScript]
public function RemoveOnError(
   handler : ErrorEventHandler
);

Parameters

handler
[To be supplied.]

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace


FileSystemWatcher.RemoveOnRenamed

[To be supplied.]

[Visual Basic]
Overridable Public Sub RemoveOnRenamed( _
   ByVal handler As RenamedEventHandler _
)
[C#]
public virtual void RemoveOnRenamed(
   RenamedEventHandler handler
);
[C++]
public: virtual void RemoveOnRenamed(
   RenamedEventHandler* handler
);
[JScript]
public function RemoveOnRenamed(
   handler : RenamedEventHandler
);

Parameters

handler
[To be supplied.]

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace


FileSystemWatcher.Start

Starts monitoring the specified directory.

[Visual Basic]
Overridable Public Sub Start()
[C#]
public virtual void Start();
[C++]
public: virtual void Start();
[JScript]
public function Start();

Remarks

You can also start monitoring the specified directory by setting the Enabled property to true.

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace | Enabled | Stop


FileSystemWatcher.Stop

Stops monitoring the specified directory.

[Visual Basic]
Overridable Public Sub Stop()
[C#]
public virtual void Stop();
[C++]
public: virtual void Stop();
[JScript]
public function Stop();

Remarks

You can also stop monitoring the specified directory by setting the Enabled property to false.

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace | Enabled | Start


FileSystemWatcher.WaitForChanged

A synchronous method that returns a structure for the specified type of change that you wish to monitor.

Overload List

A synchronous method that returns a structure for the specified type of change that you wish to monitor.

[Visual Basic] Overloads Public Function WaitForChanged(WatcherChangeTypes) As WaitForChangedResult
[C#] public WaitForChangedResult WaitForChanged(WatcherChangeTypes);
[C++] public: WaitForChangedResult WaitForChanged(WatcherChangeTypes);
[JScript] public function WaitForChanged(WatcherChangeTypes) : WaitForChangedResult;

A synchronous method with the type of change and the amount of time to wait for a change specified, that returns a structure for the specified type of change that you wish to monitor.

[Visual Basic] Overloads Public Function WaitForChanged(WatcherChangeTypes, Integer) As WaitForChangedResult
[C#] public WaitForChangedResult WaitForChanged(WatcherChangeTypes, int);
[C++] public: WaitForChangedResult WaitForChanged(WatcherChangeTypes, int);
[JScript] public function WaitForChanged(WatcherChangeTypes, int) : WaitForChangedResult;

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace


FileSystemWatcher.WaitForChanged (WatcherChangeTypes)

A synchronous method that returns a structure for the specified type of change that you wish to monitor.

[Visual Basic]
Overloads Public Function WaitForChanged( _
   ByVal changeType As WatcherChangeTypes _
) As WaitForChangedResult
[C#]
public WaitForChangedResult WaitForChanged(
   WatcherChangeTypes changeType
);
[C++]
public: WaitForChangedResult WaitForChanged(
   WatcherChangeTypes changeType
);
[JScript]
public function WaitForChanged(
   changeType : WatcherChangeTypes
) : WaitForChangedResult;

Parameters

changeType
The WatcherChangeTypes to watch for.

Return Value

The structure for the specified type of change that you are watching for.

Remarks

This method waits indefinately until the first change occurs and then returns. This is the same as using WaitForChanged with the timeout parameter set to-1.

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace | FileSystemWatcher.WaitForChanged Overload List | WaitForChangedResult


FileSystemWatcher.WaitForChanged (WatcherChangeTypes, Int32)

A synchronous method with the type of change and the amount of time to wait for a change specified, that returns a structure for the specified type of change that you wish to monitor.

[Visual Basic]
Overloads Public Function WaitForChanged( _
   ByVal changeType As WatcherChangeTypes, _
   ByVal timeout As Integer _
) As WaitForChangedResult
[C#]
public WaitForChangedResult WaitForChanged(
   WatcherChangeTypes changeType,
   int timeout
);
[C++]
public: WaitForChangedResult WaitForChanged(
   WatcherChangeTypes changeType,
   int timeout
);
[JScript]
public function WaitForChanged(
   changeType : WatcherChangeTypes,
   timeout : int
) : WaitForChangedResult;

Parameters

changeType
The WatcherChangeTypes to watch for.
timeout
The time in milliseconds to wait before timing out.

Return Value

The structure for the specified type of change that you are watching for.

Remarks

This method waits until a change occurs or it has timed out. A value of-1 for the timeout parameter means wait indefinitely.

See Also

FileSystemWatcher Class | FileSystemWatcher Members | System.IO Namespace | FileSystemWatcher.WaitForChanged Overload List | WaitForChangedResult


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

FileSystemWatcher Events

The events of the FileSystemWatcher class are listed below. For a complete list of FileSystemWatcher class members, see the FileSystemWatcher Members topic.

Public:

Changed | Occurs when a file or directory is changed.
Created | Occurs when a file or directory is created.
Deleted | Occurs when a file or directory is deleted.
Error | Occurs when an error is raised.
Renamed | Occurs when a file or directory is renamed.

See Also

FileSystemWatcher Class | System.IO Namespace


FileSystemWatcher Changed Event

Occurs when a file or directory is changed.

The following declaration shows the syntax for a method that handles the Changed event.

[Visual Basic]
Private Sub FileSystemWatcherName_Changed( _
   ByVal sender As Object, _
   ByVal e As FileSystemEventArgs _
)
[C#]
private void FileSystemWatcherName_Changed(
   object sender,
   FileSystemEventArgs e
);
[C++]
private: void FileSystemWatcherName_Changed(
   Object* sender,
   FileSystemEventArgs* e
);
[JScript]
private FileSystemWatcherName_Changed(
   sender : Object,
   e : FileSystemEventArgs
);

Parameters

sender
The source of the event.
e
A FileSystemEventArgs that contains the event data. The following FileSystemEventArgs properties provide information specific to this event.
Property Description
ChangeType
Gets one of the WatcherChangeTypes values.
FullPath
Gets the fully qualifed path of the affected file or directory.
Name
Gets the name of the affected file or directory.

Remarks

The System.IO.FileSystemWatcher.Changed event is raised when changes are made to the size, system attributes, last write time, last access time, or security permissions of a file or directory in the directory being monitored.

Use ChangedFilter to restrict the number of notifications raised when this event is handled.

See Also

FileSystemWatcher Class | FileSystemWatcher MembersTopic | System.IO Namespace | FileSystemWatcher.ChangedFilter | FileSystemWatcher.OnChanged | FileSystemEventArgs | FileSystemEventHandler


FileSystemWatcher Created Event

Occurs when a file or directory is created.

The following declaration shows the syntax for a method that handles the Created event.

[Visual Basic]
Private Sub FileSystemWatcherName_Created( _
   ByVal sender As Object, _
   ByVal e As FileSystemEventArgs _
)
[C#]
private void FileSystemWatcherName_Created(
   object sender,
   FileSystemEventArgs e
);
[C++]
private: void FileSystemWatcherName_Created(
   Object* sender,
   FileSystemEventArgs* e
);
[JScript]
private FileSystemWatcherName_Created(
   sender : Object,
   e : FileSystemEventArgs
);

Parameters

sender
The source of the event.
e
A FileSystemEventArgs that contains the event data. The following FileSystemEventArgs properties provide information specific to this event.
Property Description
ChangeType
Gets one of the WatcherChangeTypes values.
FullPath
Gets the fully qualifed path of the affected file or directory.
Name
Gets the name of the affected file or directory.

Remarks

Some common occurrences, such as copying or moving a file or directory, do not correspond directly to an event, but these occurrences do cause events to be raised. When you copy a file or directory, the system raises an System.IO.FileSystemWatcher.Created event in the directory to which the file was copied, if that directory is being watched. If the directory from which you were copying was being watched by another instance of FileSystemWatcher, no event would be raised. For example, you create two instances of FileSystemWatcher. FileSystemWatcher1 is set to watch "c:\My Documents", and FileSystemWatcher2 is set to watch "c:\Your Documents". Now, if you copy a file from "My Documents" into "Your Documents", an System.IO.FileSystemWatcher.Created event will be raised by FileSystemWatcher2, but no event is raised for FileSystemWatcher1. Unlike copying, moving a file or directory would raise two events. From the previous example, if you moved a file from "My Documents" to "Your Documents", an System.IO.FileSystemWatcher.Created event would be raised by FileSystemWatcher2 and an System.IO.FileSystemWatcher.Deleted event would be raised by FileSystemWatcher1.

See Also

FileSystemWatcher Class | FileSystemWatcher MembersTopic | System.IO Namespace | FileSystemWatcher.Deleted | FileSystemWatcher.OnDeleted | FileSystemEventArgs | FileSystemEventHandler | FileSystemWatcher.OnCreated


FileSystemWatcher Deleted Event

Occurs when a file or directory is deleted.

The following declaration shows the syntax for a method that handles the Deleted event.

[Visual Basic]
Private Sub FileSystemWatcherName_Deleted( _
   ByVal sender As Object, _
   ByVal e As FileSystemEventArgs _
)
[C#]
private void FileSystemWatcherName_Deleted(
   object sender,
   FileSystemEventArgs e
);
[C++]
private: void FileSystemWatcherName_Deleted(
   Object* sender,
   FileSystemEventArgs* e
);
[JScript]
private FileSystemWatcherName_Deleted(
   sender : Object,
   e : FileSystemEventArgs
);

Parameters

sender
The source of the event.
e
A FileSystemEventArgs that contains the event data. The following FileSystemEventArgs properties provide information specific to this event.
Property Description
ChangeType
Gets one of the WatcherChangeTypes values.
FullPath
Gets the fully qualifed path of the affected file or directory.
Name
Gets the name of the affected file or directory.

Remarks

Some common occurrences, such as copying or moving a file or directory, do not correspond directly to an event, but these occurrences do cause events to be raised. When you copy a file or directory, the system raises an System.IO.FileSystemWatcher.Created event in the directory to which the file was copied, if that directory is being watched. If the directory from which you were copying was being watched by another instance of FileSystemWatcher, no event would be raised. For example, you create two instances of FileSystemWatcher. FileSystemWatcher1 is set to watch "c:\My Documents", and FileSystemWatcher2 is set to watch "c:\Your Documents". Now, if you copy a file from "My Documents" into "Your Documents", an System.IO.FileSystemWatcher.Created event will be raised by FileSystemWatcher2, but no event is raised for FileSystemWatcher1. Unlike copying, moving a file or directory would raise two events. From the previous example, if you moved a file from "My Documents" to "Your Documents", an System.IO.FileSystemWatcher.Created event would be raised by FileSystemWatcher2 and an System.IO.FileSystemWatcher.Deleted event would be raised by FileSystemWatcher1.

See Also

FileSystemWatcher Class | FileSystemWatcher MembersTopic | System.IO Namespace | FileSystemWatcher.Created | FileSystemWatcher.OnCreated | FileSystemEventArgs | FileSystemEventHandler | FileSystemWatcher.OnDeleted


FileSystemWatcher Error Event

Occurs when an error is raised.

The following declaration shows the syntax for a method that handles the Error event.

[Visual Basic]
Private Sub FileSystemWatcherName_Error( _
   ByVal sender As Object, _
   ByVal e As ErrorEventArgs _
)
[C#]
private void FileSystemWatcherName_Error(
   object sender,
   ErrorEventArgs e
);
[C++]
private: void FileSystemWatcherName_Error(
   Object* sender,
   ErrorEventArgs* e
);
[JScript]
private FileSystemWatcherName_Error(
   sender : Object,
   e : ErrorEventArgs
);

Parameters

sender
The source of the event.
e
An ErrorEventArgs that contains the event data.

See Also

FileSystemWatcher Class | FileSystemWatcher MembersTopic | System.IO Namespace | ErrorEventArgs | ErrorEventHandler | FileSystemWatcher.OnError


FileSystemWatcher Renamed Event

Occurs when a file or directory is renamed.

The following declaration shows the syntax for a method that handles the Renamed event.

[Visual Basic]
Private Sub FileSystemWatcherName_Renamed( _
   ByVal sender As Object, _
   ByVal e As RenamedEventArgs _
)
[C#]
private void FileSystemWatcherName_Renamed(
   object sender,
   RenamedEventArgs e
);
[C++]
private: void FileSystemWatcherName_Renamed(
   Object* sender,
   RenamedEventArgs* e
);
[JScript]
private FileSystemWatcherName_Renamed(
   sender : Object,
   e : RenamedEventArgs
);

Parameters

sender
The source of the event.
e
A RenamedEventArgs that contains the event data. The following RenamedEventArgs properties provide information specific to this event.
Property Description
OldFullPath
Gets the previous fully qualified path of the affected file or directory.
OldName
Gets the old name of the affected file or directory.

Remarks

Renaming the directory you are watching will not raise a notification. Notifications are only raised for entries inside the directory you are watching.

See Also

FileSystemWatcher Class | FileSystemWatcher MembersTopic | System.IO Namespace | FileSystemWatcher.OnRenamed | FileSystemWatcher.Path | RenamedEventArgs | RenamedEventHandler


InternalBufferOverflowException Class

Specifies the exception for an internal buffer overflow.

Object
Exception
SystemException
InternalBufferOverflowException

[Visual Basic]
Public Class InternalBufferOverflowException
   Inherits SystemException
[C#]
public class InternalBufferOverflowException : SystemException
[C++]
public __gc class InternalBufferOverflowException : public
   SystemException
[JScript]
public class InternalBufferOverflowException extends
   SystemException

Remarks

In a FileSystemWatcher, when you are notified of file changes, the system stores those changes in a buffer that the component creates and passes to the Application Programming Interfaces. If there are a lot of changes in a short amount of time, the buffer can easily overflow, resulting in an exception being thrown, which essentially loses all changes. Increasing the size of the buffer is expensive, so you want to keep the buffer as small as possible. To do this, use the ChangedFilter, IncludeSubdirectories, and Target properties so you can filter out your unwanted change notifications.

Requirements

Namespace: System.IO

Assembly: system.io.dll

See Also

InternalBufferOverflowException Members | System.IO Namespace | ChangedFilter | FileSystemWatcher | IncludeSubdirectories | InternalBufferSize | Target


InternalBufferOverflowException Members

Public:

Constructor

InternalBufferOverflowException Constructor Overloaded. Initializes a new instance of the InternalBufferOverflowException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

InternalBufferOverflowException Class | System.IO Namespace


InternalBufferOverflowException Constructor

Initializes a new instance of the InternalBufferOverflowException class.

Overload List

Initializes a new default instance of the InternalBufferOverflowException class.

[Visual Basic] Overloads Public Sub New()
[C#] public InternalBufferOverflowException();
[C++] public: InternalBufferOverflowException();
[JScript] public function InternalBufferOverflowException();

Initializes a new instance of the InternalBufferOverflowException class with the error message to be displayed specified.

[Visual Basic] Overloads Public Sub New(String)
[C#] public InternalBufferOverflowException(String);
[C++] public: InternalBufferOverflowException(String*);
[JScript] public function InternalBufferOverflowException(String);

Initializes a new instance of the InternalBufferOverflowException class with the message to be displayed, and the generated inner exception specified.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public InternalBufferOverflowException(String, Exception);
[C++] public: InternalBufferOverflowException(String*, Exception);
[JScript] public function InternalBufferOverflowException(String, Exception);

See Also

InternalBufferOverflowException Class | InternalBufferOverflowException Members | System.IO Namespace


InternalBufferOverflowException Constructor ()

Initializes a new default instance of the InternalBufferOverflowException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public InternalBufferOverflowException();
[C++]
public: InternalBufferOverflowException();
[JScript]
public function InternalBufferOverflowException();

Remarks

These constructors are used by the component to signify an error. You should only use them if extending the class or framework. This exception indicates that an internal buffer has overflown and that users should take appropriate steps in their code to ensure that it recovers properly. The cause of the overflow is often having too many changes in a short period of time, causing the internal notification buffer to overflow. To resolve this, increase the InternalBufferSize of the FileSystemWatcher component.

See Also

InternalBufferOverflowException Class | InternalBufferOverflowException Members | System.IO Namespace | InternalBufferOverflowException Constructor Overload List


InternalBufferOverflowException Constructor (String)

Initializes a new instance of the InternalBufferOverflowException class with the error message to be displayed specified.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public InternalBufferOverflowException(
   string message
);
[C++]
public: InternalBufferOverflowException(
   String* message
);
[JScript]
public function InternalBufferOverflowException(
   message : String
);

Parameters

message
The message to be given for the exception.

Remarks

These constructors are used by the component to signify an error. You should only use them if extending the class or framework. This exception indicates that an internal buffer has overflown and that users should take appropriate steps in their code to ensure that it recovers properly. The cause of the overflow is often having too many changes in a short period of time, causing the internal notification buffer to overflow. To resolve this, increase the InternalBufferSize of the FileSystemWatcher component.

See Also

InternalBufferOverflowException Class | InternalBufferOverflowException Members | System.IO Namespace | InternalBufferOverflowException Constructor Overload List


InternalBufferOverflowException Constructor (String, Exception)

Initializes a new instance of the InternalBufferOverflowException class with the message to be displayed, and the generated inner exception specified.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public InternalBufferOverflowException(
   string message,
   Exception inner
);
[C++]
public: InternalBufferOverflowException(
   String* message,
   Exception* inner
);
[JScript]
public function InternalBufferOverflowException(
   message : String,
   inner : Exception
);

Parameters

message
The message to be given for the exception.
inner
The inner exception.

Remarks

These constructors are used by the component to signify an error. You should only use them if extending the class or framework. This exception indicates that an internal buffer has overflown and that users should take appropriate steps in their code to ensure that it recovers properly. The cause of the overflow is often having too many changes in a short period of time, causing the internal notification buffer to overflow. To resolve this, increase the InternalBufferSize of the FileSystemWatcher component.

See Also

InternalBufferOverflowException Class | InternalBufferOverflowException Members | System.IO Namespace | InternalBufferOverflowException Constructor Overload List


IOException Class

Represents an occurrence of an I/O error.

Object
Exception
IOException

[Visual Basic]
Public Class IOException
   Inherits Exception
[C#]
public class IOException : Exception
[C++]
public __gc class IOException : public Exception
[JScript]
public class IOException extends Exception

Remarks

[To be supplied.]

Requirements

Namespace: System.IO

Assembly: mscorlib.dll

See Also

IOException Members | System.IO Namespace


IOException Members

Public:

Constructor

IOException Constructor Overloaded. Creates a new instance of the IOException class with its message string.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

IOException Class | System.IO Namespace


IOException Constructor

Creates a new instance of the IOException class with its message string.

Overload List

Creates a new instance of the IOException class with its message string set to the empty string (""), its HRESULT set to COR_E_IO, and its ExceptionInfo reference set to null.

[Visual Basic] Overloads Public Sub New()
[C#] public IOException();
[C++] public: IOException();
[JScript] public function IOException();

Creates a new IOException with its message string set to message, its HRESULT set to COR_E_IO, and its ExceptionInfo reference set to null.

[Visual Basic] Overloads Public Sub New(String)
[C#] public IOException(String);
[C++] public: IOException(String*);
[JScript] public function IOException(String);

Creates a new IOException with its message string set to message and its HRESULT user-defined.

[Visual Basic] Overloads Public Sub New(String, Integer)
[C#] public IOException(String, int);
[C++] public: IOException(String*, int);
[JScript] public function IOException(String, int);

Creates a new IOException with its message string set to message, its HRESULT set to COR_E_ACCESS, and its ExceptionInfo reference set to null.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public IOException(String, Exception);
[C++] public: IOException(String*, Exception);
[JScript] public function IOException(String, Exception);

See Also

IOException Class | IOException Members | System.IO Namespace


IOException Constructor ()

Creates a new instance of the IOException class with its message string set to the empty string (""), its HRESULT set to COR_E_IO, and its ExceptionInfo reference set to null.

[Visual Basic]
Overloads Public Sub New()
[C#]
public IOException();
[C++]
public: IOException();
[JScript]
public function IOException();

Remarks

[To be supplied.]

See Also

IOException Class | IOException Members | System.IO Namespace | IOException Constructor Overload List


IOException Constructor (String)

Creates a new IOException with its message string set to message, its HRESULT set to COR_E_IO, and its ExceptionInfo reference set to null.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public IOException(
   string message
);
[C++]
public: IOException(
   String* message
);
[JScript]
public function IOException(
   message : String
);

Parameters

message
The message text for the exception.

Remarks

[To be supplied.]

See Also

IOException Class | IOException Members | System.IO Namespace | IOException Constructor Overload List


IOException Constructor (String, Int32)

Creates a new IOException with its message string set to message and its HRESULT user-defined.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal hresult As Integer _
)
[C#]
public IOException(
   string message,
   int hresult
);
[C++]
public: IOException(
   String* message,
   int hresult
);
[JScript]
public function IOException(
   message : String,
   hresult : int
);

Parameters

message
The message text for the exception.
hresult
[To be supplied.]

See Also

IOException Class | IOException Members | System.IO Namespace | IOException Constructor Overload List


IOException Constructor (String, Exception)

Creates a new IOException with its message string set to message, its HRESULT set to COR_E_ACCESS, and its ExceptionInfo reference set to null.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public IOException(
   string message,
   Exception inner
);
[C++]
public: IOException(
   String* message,
   Exception* inner
);
[JScript]
public function IOException(
   message : String,
   inner : Exception
);

Parameters

message
The message text for the exception.
inner
The exception that is the root cause of this exception.

Remarks

When handling exceptions, it is sometimes desirable to throw another exception that is more indicative of the error that has occurred. To avoid losing the original exception and the information that it carries, exceptions can hold a reference to another exception.

See Also

IOException Class | IOException Members | System.IO Namespace | IOException Constructor Overload List


MemoryStream Class

Provides a way to create streams that have memory as a backing store instead of a disk or a network connection. The MemoryStream class creates a stream out of an array of bytes.

Object
Stream
MemoryStream

[Visual Basic]
Public Class MemoryStream
   Inherits Stream
[C#]
public class MemoryStream : Stream
[C++]
public __gc class MemoryStream : public Stream
[JScript]
public class MemoryStream extends Stream

Remarks

MemoryStream encapsulates data stored as an unsigned byte array that is initialized upon creation of a MemoryStream object, or it can be created as empty. The encapsulated data is directly accessible in memory. Memory streams might reduce the need for temporary buffers and files in an application.

Memory streams created with an unsigned byte array provide a non-resizable stream "view" of the data, and can only be written to. When using a byte array, you can neither append to nor shrink the stream, but depending on the parameters passed into the constructor, you may be able to modify the existing contents. Empty memory streams are resizable, and can be written to and read from.

Requirements

Namespace: System.IO

Assembly: mscorlib.dll

See Also

MemoryStream Members | System.IO Namespace


MemoryStream Members

Public:

Constructor

MemoryStream Constructor Overloaded. Creates either an empty MemoryStream with an expandable capacity, or a MemoryStream based on a specified array of bytes with a fixed capacity.

Properties

CanRead | Determines whether the current stream supports reading.
CanSeek | Determines whether the current stream supports seeking.
CanWrite | Determines whether the current stream supports writing.
Capacity | Gets or sets the number of bytes allocated for this stream.
DataAvailable | Determines whether there are any bytes available in the current stream.
Length | Returns the length in bytes of the stream.
Position | Determines the current position within the stream.

Methods

BeginRead (inherited from Stream) | Begins an asynchronous read.
BeginWrite (inherited from Stream) | Begins an asynchronous write.
Close | Closes the stream for reading and writing.
EndRead (inherited from Stream) | Ends a pending asynchronous read request.
EndWrite (inherited from Stream) | Ends an asynchronous write.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Flush | Overrides Flush so that no action is performed.
GetBuffer | Returns the array of unsigned bytes from which this Stream was created.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Read | Reads a block of bytes from the current stream and writes the data to buffer.
ReadByte | Reads a byte from the current stream.
Seek | Sets the current position within the current stream to the specified value.
SetLength | Sets the length of the current stream to the specified value.
ToArray | Writes the entire stream contents to a byte array, regardless of the Position property.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Writes a block of bytes to the current stream using data read from buffer.
WriteByte | Writes a byte to the current stream.
WriteTo | Writes the entire contents of this MemoryStream to another stream.

Protected:

Methods

CreateWaitHandle (inherited from Stream) | Allocates a WaitHandle object efficiently.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MemoryStream Class | System.IO Namespace


MemoryStream Constructor

Creates either an empty MemoryStream with an expandable capacity, or a MemoryStream based on a specified array of bytes with a fixed capacity.

Overload List

Initializes a new MemoryStream with an expandable capacity initially set to zero.

[Visual Basic] Overloads Public Sub New()
[C#] public MemoryStream();
[C++] public: MemoryStream();
[JScript] public function MemoryStream();

Initializes a new MemoryStream with an expandable capacity initially set as specified.

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public MemoryStream(int);
[C++] public: MemoryStream(int);
[JScript] public function MemoryStream(int);

Initializes a new MemoryStream based on the specified byte array.

[Visual Basic] Overloads Public Sub New(Byte())
[C#] public MemoryStream(byte[]);
[C++] public: MemoryStream(unsigned char*[]);
[JScript] public function MemoryStream(Byte[]);

Initializes a new MemoryStream based on the specified byte array with the CanWrite property set as specified.

[Visual Basic] Overloads Public Sub New(Byte(), Boolean)
[C#] public MemoryStream(byte[], bool);
[C++] public: MemoryStream(unsigned char*[], bool);
[JScript] public function MemoryStream(Byte[], Boolean);

Initializes a new MemoryStream based on the specified region (index) of a byte array.

[Visual Basic] Overloads Public Sub New(Byte(), Integer, Integer)
[C#] public MemoryStream(byte[], int, int);
[C++] public: MemoryStream(unsigned char*[], int, int);
[JScript] public function MemoryStream(Byte[], int, int);

Initializes a new MemoryStream based on the specified region of a byte array with the CanWrite property set as specified.

[Visual Basic] Overloads Public Sub New(Byte(), Integer, Integer, Boolean)
[C#] public MemoryStream(byte[], int, int, bool);
[C++] public: MemoryStream(unsigned char*[], int, int, bool);
[JScript] public function MemoryStream(Byte[], int, int, Boolean);

Initializes a new MemoryStream based on the specified region of a byte array with the CanWrite property set as specified.

[Visual Basic] Overloads Public Sub New(Byte(), Integer, Integer, Boolean, Boolean)
[C#] public MemoryStream(byte[], int, int, bool, bool);
[C++] public: MemoryStream(unsigned char*[], int, int, bool, bool);
[JScript] public function MemoryStream(Byte[], int, int, Boolean, Boolean);

See Also

MemoryStream Class | MemoryStream Members | System.IO Namespace


MemoryStream Constructor ()

Initializes a new MemoryStream with an expandable capacity initially set to zero.

[Visual Basic]
Overloads Public Sub New()
[C#]
public MemoryStream();
[C++]
public: MemoryStream();
[JScript]
public function MemoryStream();

Remarks

The CanRead, CanSeek, and CanWrite properties are all set to true.

The capacity of the current stream is automatically increased when the SetLength method is used to set the length to a value larger than the capacity of the current stream.

This constructor exposes the underlying stream, which GetBuffer returns.

See Also

MemoryStream Class | MemoryStream Members | System.IO Namespace | MemoryStream Constructor Overload List


MemoryStream Constructor (Int32)

Initializes a new MemoryStream with an expandable capacity initially set as specified.

[Visual Basic]
Overloads Public Sub New( _
   ByVal capacity As Integer _
)
[C#]
public MemoryStream(
   int capacity
);
[C++]
public: MemoryStream(
   int capacity
);
[JScript]
public function MemoryStream(
   capacity : int
);

Parameters

capacity
The initial size of the internal array in bytes.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | capacity is negative.

Remarks

The CanRead, CanSeek, and CanWrite properties are all set to true.

The capacity is automatically increased when the SetLength method is used to set the length to a value larger than the capacity of the current stream.

This constructor exposes the underlying stream, which GetBuffer returns.

See Also

MemoryStream Class | MemoryStream Members | System.IO Namespace | MemoryStream Constructor Overload List


MemoryStream Constructor (Byte[])

Initializes a new MemoryStream based on the specified byte array.

[Visual Basic]
Overloads Public Sub New( _
   ByVal buffer() As Byte _
)
[C#]
public MemoryStream(
   byte[] buffer
);
[C++]
public: MemoryStream(
   unsigned char* buffer[]
);
[JScript]
public function MemoryStream(
   buffer : Byte[]
);

Parameters

buffer
The array of unsigned bytes from which to create the current stream.

Exceptions

Exception Type | Condition
ArgumentNullException | buffer is null.

Remarks

The CanRead, CanSeek, and CanWrite properties are all set to true. The new stream can be written to but is not resizable.

The length of the stream cannot be set to a value greater than the initial length of the specified byte array; however, the stream can be truncated (see SetLength).

This constructor does not expose the underlying stream. GetBuffer throws AccessException.

See Also

MemoryStream Class | MemoryStream Members | System.IO Namespace | MemoryStream Constructor Overload List


MemoryStream Constructor (Byte[], Boolean)

Initializes a new MemoryStream based on the specified byte array with the CanWrite property set as specified.

[Visual Basic]
Overloads Public Sub New( _
   ByVal buffer() As Byte, _
   ByVal writeable As Boolean _
)
[C#]
public MemoryStream(
   byte[] buffer,
   bool writeable
);
[C++]
public: MemoryStream(
   unsigned char* buffer[],
   bool writeable
);
[JScript]
public function MemoryStream(
   buffer : Byte[],
   writeable : Boolean
);

Parameters

buffer
The array of unsigned bytes from which to create this stream.
writeable
The setting of the CanWrite property, which determines whether the stream will support writing.

Exceptions

Exception Type | Condition
ArgumentNullException | buffer is null.

Remarks

The CanRead and CanSeek properties are both set to true.

The length of the stream cannot be set to a value greater than the initial length of the specified byte array; however, the stream can be truncated (see SetLength).

This constructor does not expose the underlying stream. GetBuffer throws AccessException.

See Also

MemoryStream Class | MemoryStream Members | System.IO Namespace | MemoryStream Constructor Overload List


MemoryStream Constructor (Byte[], Int32, Int32)

Initializes a new MemoryStream based on the specified region (index) of a byte array.

[Visual Basic]
Overloads Public Sub New( _
   ByVal buffer() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
[C#]
public MemoryStream(
   byte[] buffer,
   int index,
   int count
);
[C++]
public: MemoryStream(
   unsigned char* buffer[],
   int index,
   int count
);
[JScript]
public function MemoryStream(
   buffer : Byte[],
   index : int,
   count : int
);

Parameters

buffer
The array of unsigned bytes from which to create this stream.
index
The index into buffer at which the stream begins.
count
The length of the stream in bytes.

Exceptions

Exception Type | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | index or count is less than zero.
ArgumentException | The sum of index and count is greater than the length of buffer.

Remarks

The CanRead, CanSeek, and CanWrite properties are all set to true, but the capacity cannot be changed.

The length of the stream cannot be set to a value greater than the initial length of the specified byte array; however, the stream can be truncated (see SetLength).

This constructor does not expose the underlying stream. GetBuffer throws AccessException. However, the stream is writeable.

See Also

MemoryStream Class | MemoryStream Members | System.IO Namespace | MemoryStream Constructor Overload List


MemoryStream Constructor (Byte[], Int32, Int32, Boolean)

Initializes a new MemoryStream based on the specified region of a byte array with the CanWrite property set as specified.

[Visual Basic]
Overloads Public Sub New( _
   ByVal buffer() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer, _
   ByVal writeable As Boolean _
)
[C#]
public MemoryStream(
   byte[] buffer,
   int index,
   int count,
   bool writeable
);
[C++]
public: MemoryStream(
   unsigned char* buffer[],
   int index,
   int count,
   bool writeable
);
[JScript]
public function MemoryStream(
   buffer : Byte[],
   index : int,
   count : int,
   writeable : Boolean
);

Parameters

buffer
The array of unsigned bytes from which to create this stream.
index
The index into buffer at which the stream begins.
count
The length of the stream in bytes.
writeable
A flag designating whether the stream supports writing. This argument sets the CanWrite property.

Exceptions

Exception Type | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | index or count are negative.
ArgumentException | index and count describe an invalid range in buffer.

Remarks

The CanRead and CanSeek properties are both set to true.

The length of the stream cannot be set to a value greater than the initial length of the specified byte array; however, the stream can be truncated (see SetLength).

See Also

MemoryStream Class | MemoryStream Members | System.IO Namespace | MemoryStream Constructor Overload List


MemoryStream Constructor (Byte[], Int32, Int32, Boolean, Boolean)

Initializes a new MemoryStream based on the specified region of a byte array with the CanWrite property set as specified.

[Visual Basic]
Overloads Public Sub New( _
   ByVal buffer() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer, _
   ByVal writeable As Boolean, _
   ByVal publicallyVisible As Boolean _
)
[C#]
public MemoryStream(
   byte[] buffer,
   int index,
   int count,
   bool writeable,
   bool publicallyVisible
);
[C++]
public: MemoryStream(
   unsigned char* buffer[],
   int index,
   int count,
   bool writeable,
   bool publicallyVisible
);
[JScript]
public function MemoryStream(
   buffer : Byte[],
   index : int,
   count : int,
   writeable : Boolean,
   publicallyVisible : Boolean
);

Parameters

buffer
The array of unsigned bytes from which to create this stream.
index
The index into buffer at which the stream begins.
count
The length of the stream in bytes.
writeable
A flag designating whether the stream supports writing. This argument sets the CanWrite property.
publicallyVisible
true to enable calling GetBuffer; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | index or count is negative.
ArgumentException | The buffer length minus index is less than count.
AccessException | publicallyVisible is false.

Remarks

The CanRead and CanSeek properties are both set to true. This constructor can call GetBuffer.

The length of the stream cannot be set to a value greater than the initial length of the specified byte array; however, the stream can be truncated (see SetLength).

See Also

MemoryStream Class | MemoryStream Members | System.IO Namespace | MemoryStream Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MemoryStream Properties

The properties of the MemoryStream class are listed below. For a complete list of MemoryStream class members, see the MemoryStream Members topic.

Public:

CanRead | Determines whether the current stream supports reading.
CanSeek | Determines whether the current stream supports seeking.
CanWrite | Determines whether the current stream supports writing.
Capacity | Gets or sets the number of bytes allocated for this stream.
DataAvailable | Determines whether there are any bytes available in the current stream.
Length | Returns the length in bytes of the stream.
Position | Determines the current position within the stream.

See Also

MemoryStream Class | System.IO Namespace


MemoryStream.CanRead

Determines whether the current stream supports reading.

[Visual Basic]
Overridable Public ReadOnly Property CanRead As Boolean
[C#]
public bool CanRead {override get;}
[C++]
public: __property virtual bool get_CanRead();
[JScript]
public function get CanRead() : Boolean;

Property Value

true if the stream supports reading. All MemoryStream objects support reading, so the value is always true.

See Also

MemoryStream Class | MemoryStream Members | System.IO Namespace


MemoryStream.CanSeek

Determines whether the current stream supports seeking.

[Visual Basic]
Overridable Public ReadOnly Property CanSeek As Boolean
[C#]
public bool CanSeek {override get;}
[C++]
public: __property virtual bool get_CanSeek();
[JScript]
public function get CanSeek() : Boolean;

Property Value

true if the stream supports seeking. All MemoryStream objects support seeking, so the value is always true.

See Also

MemoryStream Class | MemoryStream Members | System.IO Namespace


MemoryStream.CanWrite

Determines whether the current stream supports writing.

[Visual Basic]
Overridable Public ReadOnly Property CanWrite As Boolean
[C#]
public bool CanWrite {override get;}
[C++]
public: __property virtual bool get_CanWrite();
[JScript]
public function get CanWrite() : Boolean;

Property Value

true if the stream supports writing; otherwise, false.

See Also

MemoryStream Class | MemoryStream Members | System.IO Namespace


MemoryStream.Capacity

Gets or sets the number of bytes allocated for this stream.

[Visual Basic]
Public Property Capacity As Integer
[C#]
public int Capacity {get; set;}
[C++]
public: __property int get_Capacity();
public: __property void set_Capacity(int);
[JScript]
public function get Capacity() : int;
public function set Capacity(int);

Property Value

The length of the usable portion of the buffer for the stream.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | A capacity is set that is negative or less than the current length of the stream.
NotSupportedException | Set is invoked on a stream that is closed or whose capacity cannot be modified.

Remarks

Capacity is the buffer length for system-provided byte arrays. Capacity cannot be set to a value less than the current length of the stream.

See Also

MemoryStream Class | MemoryStream Members | System.IO Namespace


MemoryStream.DataAvailable

Determines whether there are any bytes available in the current stream.

[Visual Basic]
Overridable Public ReadOnly Property DataAvailable As Boolean
[C#]
public bool DataAvailable {override get;}
[C++]
public: __property virtual bool get_DataAvailable();
[JScript]
public function get DataAvailable() : Boolean;

Property Value

The status (open or closed) of the stream, and the beginning writing position within it.

See Also

MemoryStream Class | MemoryStream Members | System.IO Namespace


MemoryStream.Length

Returns the length in bytes of the stream.

[Visual Basic]
Overridable Public ReadOnly Property Length As Long
[C#]
public long Length {override get;}
[C++]
public: __property virtual __int64 get_Length();
[JScript]
public function get Length() : long;

Property Value

The length in bytes of the stream.

Exceptions

Exception Type | Condition
IOException | The stream is closed.

See Also

MemoryStream Class | MemoryStream Members | System.IO Namespace


MemoryStream.Position

Determines the current position within the stream.

[Visual Basic]
Overridable Public Property Position As Long
[C#]
public long Position {override get; override set;}
[C++]
public: __property virtual __int64 get_Position();
public: __property virtual void set_Position(__int64);
[JScript]
public function get Position() : long;
public function set Position(long);

Property Value

The current position within the stream.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | The position is set to a negative value or a value greater than one byte beyond the length of the current stream.
IOException | The stream is closed.

Remarks

Position may not exceed one byte beyond the length of the stream.

See Also

MemoryStream Class | MemoryStream Members | System.IO Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MemoryStream Methods

The methods of the MemoryStream class are listed below. For a complete list of MemoryStream class members, see the MemoryStream Members topic.

Public:

BeginRead (inherited from Stream) | Begins an asynchronous read.
BeginWrite (inherited from Stream) | Begins an asynchronous write.
Close | Closes the stream for reading and writing.
EndRead (inherited from Stream) | Ends a pending asynchronous read request.
EndWrite (inherited from Stream) | Ends an asynchronous write.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Flush | Overrides Flush so that no action is performed.
GetBuffer | Returns the array of unsigned bytes from which this Stream was created.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Read | Reads a block of bytes from the current stream and writes the data to buffer.
ReadByte | Reads a byte from the current stream.
Seek | Sets the current position within the current stream to the specified value.
SetLength | Sets the length of the current stream to the specified value.
ToArray | Writes the entire stream contents to a byte array, regardless of the Position property.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Writes a block of bytes to the current stream using data read from buffer.
WriteByte | Writes a byte to the current stream.
WriteTo | Writes the entire contents of this MemoryStream to another stream.

Protected:

CreateWaitHandle (inherited from Stream) | Allocates a WaitHandle object efficiently.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MemoryStream Class | System.IO Namespace


MemoryStream.Close

Closes the stream for reading and writing.

[Visual Basic]
Overrides Public Sub Close()
[C#]
public override void Close();
[C++]
public: override void Close();
[JScript]
public override function Close();

Remarks

The stream will not support reading nor writing after the current method is invoked. Following a call to Close, any operations on the stream may raise exceptions.

See Also

MemoryStream Class | MemoryStream Members | System.IO Namespace


MemoryStream.Flush

Overrides Flush so that no action is performed.

[Visual Basic]
Overrides Public Sub Flush()
[C#]
public override void Flush();
[C++]
public: override void Flush();
[JScript]
public override function Flush();

See Also

MemoryStream Class | MemoryStream Members | System.IO Namespace


MemoryStream.GetBuffer

Returns the array of unsigned bytes from which this Stream was created.

[Visual Basic]
Overridable Public Function GetBuffer() As Byte ()
[C#]
public virtual byte[] GetBuffer();
[C++]
public: virtual unsigned char* GetBuffer() [];
[JScript]
public function GetBuffer() : Byte[];

Return Value

The array of unsigned bytes from which this Stream was created.

Exceptions

Exception Type | Condition
AccessException | The MemoryStream instance was not created with publicallyVisible set to true in its constructor.

See Also

MemoryStream Class | MemoryStream Members | System.IO Namespace


MemoryStream.Read

Reads a block of bytes from the current stream and writes the data to buffer.

[Visual Basic]
Overrides Public Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
[C#]
public override int Read(
   byte[] buffer,
   int offset,
   int count
);
[C++]
public: override int Read(
   unsigned char* buffer[],
   int offset,
   int count
);
[JScript]
public override function Read(
   buffer : Byte[],
   offset : int,
   count : int
) : int;

Parameters

buffer
The byte array to read into.
offset
The byte offset at which to begin writing.
count
The maximum number of bytes to read.

Return Value

The total number of bytes read into the buffer. This may be less than the number of bytes requested if that many bytes aren't currently available, or zero if the end of the stream is reached.

Exceptions

Exception Type | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | offset or count is negative.
ArgumentException | offset subtracted from the buffer length is less than count.

Remarks

The offset parameter gives the offset of the first byte in buffer to which data from the current stream is written. The count parameter gives the maximum number of bytes to read from the current stream. The returned value is the actual number of bytes read, or zero if the end of the stream is reached.

If the read operation is successful, the current position within the stream is advanced by the number of bytes read. If an exception occurs, the current position within the stream is unchanged.

The Read method will return zero only if the end of the stream is reached. In all other cases, Read always reads at least one byte from the stream before returning. If no data is available from the stream upon a call to Read, the method will block until at least 1 byte of data can be returned.

See Also

MemoryStream Class | MemoryStream Members | System.IO Namespace


MemoryStream.ReadByte

Reads a byte from the current stream.

[Visual Basic]
Overrides Public Function ReadByte() As Integer
[C#]
public override int ReadByte();
[C++]
public: override int ReadByte();
[JScript]
public override function ReadByte() : int;

Return Value

A byte read from the current stream.

See Also

MemoryStream Class | MemoryStream Members | System.IO Namespace


MemoryStream.Seek

Sets the current position within the current stream to the specified value.

[Visual Basic]
Overrides Public Function Seek( _
   ByVal offset As Long, _
   ByVal loc As SeekOrigin _
) As Long
[C#]
public override long Seek(
   long offset,
   SeekOrigin loc
);
[C++]
public: override __int64 Seek(
   __int64 offset,
   SeekOrigin loc
);
[JScript]
public override function Seek(
   offset : long,
   loc : SeekOrigin
) : long;

Parameters

offset
The new position within the stream. This is relative to loc, and may be positive or negative, accordingly.
loc
A field of SeekOrigin, which acts as the seek reference point.

Return Value

The new position within the stream, calculated by combining the initial reference point and the offset.

Exceptions

Exception Type | Condition
IOException | Seeking is attempted before the beginning or more than one byte beyond the end of the stream.

Remarks

Positioning more than one byte beyond the length of the stream is not supported.

See Also

MemoryStream Class | MemoryStream Members | System.IO Namespace


MemoryStream.SetLength

Sets the length of the current stream to the specified value.

[Visual Basic]
Overrides Public Sub SetLength( _
   ByVal value As Long _
)
[C#]
public override void SetLength(
   long value
);
[C++]
public: override void SetLength(
   __int64 value
);
[JScript]
public override function SetLength(
   value : long
);

Parameters

value
The value at which to set the length.

Exceptions

Exception Type | Condition
ArgumentException | value is negative or is greater than Int32.MaxValue minus the origin.
NotSupportedException | The current stream is not resizable and value is larger than the current capacity.
IOException | The current stream does not support writing.

Remarks

If the specified value is less than the current length of the stream, the stream is truncated. If the specified value is larger than the current capacity and the stream is resizable, then the capacity is increased; otherwise a NotSupportedException is thrown. If the length is increased, the contents of the stream between the old and the new length are undefined. A stream must support both writing and seeking for this method to be operational.

See Also

MemoryStream Class | MemoryStream Members | System.IO Namespace


MemoryStream.ToArray

Writes the entire stream contents to a byte array, regardless of the Position property.

[Visual Basic]
Overridable Public Function ToArray() As Byte ()
[C#]
public virtual byte[] ToArray();
[C++]
public: virtual unsigned char* ToArray() [];
[JScript]
public function ToArray() : Byte[];

Return Value

A new byte array.

Exceptions

Exception Type | Condition
ArgumentException | The stream is closed.

See Also

MemoryStream Class | MemoryStream Members | System.IO Namespace


MemoryStream.Write

Writes a block of bytes to the current stream using data read from buffer.

[Visual Basic]
Overrides Public Function Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
[C#]
public override int Write(
   byte[] buffer,
   int offset,
   int count
);
[C++]
public: override int Write(
   unsigned char* buffer[],
   int offset,
   int count
);
[JScript]
public override function Write(
   buffer : Byte[],
   offset : int,
   count : int
) : int;

Parameters

buffer
The buffer to write data to.
offset
The byte offset in buffer at which to begin writing.
count
The maximum number of bytes to write.

Return Value

The number of bytes written.

Exceptions

Exception Type | Condition
ArgumentNullException | buffer is null.
NotSupportedException | The stream does not support writing.
ArgumentException | offset subtracted from the buffer length is less than count.
ArgumentOutOfRangeException | offset or count are negative.

Remarks

The offset parameter gives the offset of the first byte in buffer to write from, and the count parameter gives the number of bytes to write. If the write operation is successful, the current position within the stream is advanced by the number of bytes written. If an exception occurs, the current position within the stream is unchanged.

See Also

MemoryStream Class | MemoryStream Members | System.IO Namespace


MemoryStream.WriteByte

Writes a byte to the current stream.

[Visual Basic]
Overrides Public Sub WriteByte( _
   ByVal value As Byte _
)
[C#]
public override void WriteByte(
   byte value
);
[C++]
public: override void WriteByte(
   unsigned char value
);
[JScript]
public override function WriteByte(
   value : Byte
);

Parameters

value
The byte to write.

See Also

MemoryStream Class | MemoryStream Members | System.IO Namespace


MemoryStream.WriteTo

Writes the entire contents of this MemoryStream to another stream.

[Visual Basic]
Overridable Public Sub WriteTo( _
   ByVal stream As Stream _
)
[C#]
public virtual void WriteTo(
   Stream stream
);
[C++]
public: virtual void WriteTo(
   Stream* stream
);
[JScript]
public function WriteTo(
   stream : Stream
);

Parameters

stream
The stream to write this MemoryStream to.

Exceptions

Exception Type | Condition
ArgumentNullException | stream is null.

See Also

MemoryStream Class | MemoryStream Members | System.IO Namespace


PathTooLongException Class

Represents an exception that is thrown when a path name or filename is too long.

Object
Exception
PathTooLongException

[Visual Basic]
Public Class PathTooLongException
   Inherits Exception
[C#]
public class PathTooLongException : Exception
[C++]
public __gc class PathTooLongException : public Exception
[JScript]
public class PathTooLongException extends Exception

Remarks

[To be supplied.]

Requirements

Namespace: System.IO

Assembly: mscorlib.dll

See Also

PathTooLongException Members | System.IO Namespace


PathTooLongException Members

Public:

Constructor

PathTooLongException Constructor Overloaded. Initializes a new instance of the PathTooLongException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

PathTooLongException Class | System.IO Namespace


PathTooLongException Constructor

Initializes a new instance of the PathTooLongException class.

Overload List

Initializes a new instance of the PathTooLongException class with its HRESULT set to COR_E_PATHTOOLONG.

[Visual Basic] Overloads Public Sub New()
[C#] public PathTooLongException();
[C++] public: PathTooLongException();
[JScript] public function PathTooLongException();

Creates a new instance of the PathTooLongException class with its message string set to message and its HRESULT set to COR_E_PATHTOOLONG.

[Visual Basic] Overloads Public Sub New(String)
[C#] public PathTooLongException(String);
[C++] public: PathTooLongException(String*);
[JScript] public function PathTooLongException(String);

Creates a new instance of the PathTooLongException class that displays the root cause of the exception. Its message string is set to message and its HRESULT is set to COR_E_PATHTOOLONG.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public PathTooLongException(String, Exception);
[C++] public: PathTooLongException(String*, Exception);
[JScript] public function PathTooLongException(String, Exception);

See Also

PathTooLongException Class | PathTooLongException Members | System.IO Namespace


PathTooLongException Constructor ()

Initializes a new instance of the PathTooLongException class with its HRESULT set to COR_E_PATHTOOLONG.

[Visual Basic]
Overloads Public Sub New()
[C#]
public PathTooLongException();
[C++]
public: PathTooLongException();
[JScript]
public function PathTooLongException();

See Also

PathTooLongException Class | PathTooLongException Members | System.IO Namespace | PathTooLongException Constructor Overload List


PathTooLongException Constructor (String)

Creates a new instance of the PathTooLongException class with its message string set to message and its HRESULT set to COR_E_PATHTOOLONG.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public PathTooLongException(
   string message
);
[C++]
public: PathTooLongException(
   String* message
);
[JScript]
public function PathTooLongException(
   message : String
);

Parameters

message
The message text for the exception.

See Also

PathTooLongException Class | PathTooLongException Members | System.IO Namespace | PathTooLongException Constructor Overload List


PathTooLongException Constructor (String, Exception)

Creates a new instance of the PathTooLongException class that displays the root cause of the exception. Its message string is set to message and its HRESULT is set to COR_E_PATHTOOLONG.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public PathTooLongException(
   string message,
   Exception inner
);
[C++]
public: PathTooLongException(
   String* message,
   Exception* inner
);
[JScript]
public function PathTooLongException(
   message : String,
   inner : Exception
);

Parameters

message
The exception that is the root cause of this exception.
inner
[To be supplied.]

Remarks

When handling exceptions, it is sometimes desirable to throw another exception that is more indicative of the error that has occurred. To avoid losing the original exception and the information that it carries, exceptions can hold a reference to another exception.

See Also

PathTooLongException Class | PathTooLongException Members | System.IO Namespace | PathTooLongException Constructor Overload List


RenamedEventArgs Class

Provides data for the System.IO.FileSystemWatcher.Renamed event.

Object
EventArgs
FileSystemEventArgs
RenamedEventArgs

[Visual Basic]
Public Class RenamedEventArgs
   Inherits FileSystemEventArgs
[C#]
public class RenamedEventArgs : FileSystemEventArgs
[C++]
public __gc class RenamedEventArgs : public FileSystemEventArgs
[JScript]
public class RenamedEventArgs extends FileSystemEventArgs

Remarks

This class inherits from FileSystemEventArgs and extends it by adding an old name field to specify the previous name of the affected file or directory.

Requirements

Namespace: System.IO

Assembly: system.io.dll

See Also

RenamedEventArgs Members | System.IO Namespace | FileSystemWatcher | FileSystemEventArgs | OnRenamed | RenamedEventHandler


RenamedEventArgs Members

Public:

Constructor

RenamedEventArgs Constructor Initializes a new instance of the RenamedEventArgs class.

Properties

ChangeType (inherited from FileSystemEventArgs) | Gets one of the WatcherChangeTypes values.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
FullPath (inherited from FileSystemEventArgs) | Gets the fully qualifed path of the affected file or directory.
Name (inherited from FileSystemEventArgs) | Gets the name of the affected file or directory.
OldFullPath | Gets the previous fully qualified path of the affected file or directory.
OldName | Gets the old name of the affected file or directory.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RenamedEventArgs Class | System.IO Namespace


RenamedEventArgs Constructor

Initializes a new instance of the RenamedEventArgs class.

[Visual Basic]
Public Sub New( _
   ByVal changeType As WatcherChangeTypes, _
   ByVal directory As String, _
   ByVal name As String, _
   ByVal oldName As String _
)
[C#]
public RenamedEventArgs(
   WatcherChangeTypes changeType,
   string directory,
   string name,
   string oldName
);
[C++]
public: RenamedEventArgs(
   WatcherChangeTypes changeType,
   String* directory,
   String* name,
   String* oldName
);
[JScript]
public function RenamedEventArgs(
   changeType : WatcherChangeTypes,
   directory : String,
   name : String,
   oldName : String
);

Parameters

changeType
One of the WatcherChangeTypes values.
directory
The name of the affected file or directory.
name
The name of the affected file or directory.
oldName
The old name of the affected file or directory.

Remarks

This class inherits from the FileSystemEventArgs class and extends it by adding an old name field to specify the previous name of the file or directory affected.

See Also

RenamedEventArgs Class | RenamedEventArgs Members | System.IO Namespace | FileSystemEventArgs | WatcherChangeTypes


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RenamedEventArgs Properties

The properties of the RenamedEventArgs class are listed below. For a complete list of RenamedEventArgs class members, see the RenamedEventArgs Members topic.

Public:

ChangeType (inherited from FileSystemEventArgs) | Gets one of the WatcherChangeTypes values.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
FullPath (inherited from FileSystemEventArgs) | Gets the fully qualifed path of the affected file or directory.
Name (inherited from FileSystemEventArgs) | Gets the name of the affected file or directory.
OldFullPath | Gets the previous fully qualified path of the affected file or directory.
OldName | Gets the old name of the affected file or directory.

See Also

RenamedEventArgs Class | System.IO Namespace


RenamedEventArgs.OldFullPath

Gets the previous fully qualified path of the affected file or directory.

[Visual Basic]
Overridable Public ReadOnly Property OldFullPath As String
[C#]
public string OldFullPath {virtual get;}
[C++]
public: __property virtual String* get_OldFullPath();
[JScript]
public function get OldFullPath() : String;

Property Value

The previous fully qualified path of the affected file or directory.

See Also

RenamedEventArgs Class | RenamedEventArgs Members | System.IO Namespace


RenamedEventArgs.OldName

Gets the old name of the affected file or directory.

[Visual Basic]
Overridable Public ReadOnly Property OldName As String
[C#]
public string OldName {virtual get;}
[C++]
public: __property virtual String* get_OldName();
[JScript]
public function get OldName() : String;

Property Value

The previous name of the affected file or directory.

See Also

RenamedEventArgs Class | RenamedEventArgs Members | System.IO Namespace


RenamedEventHandler Delegate

Represents the method that will handle the System.IO.FileSystemWatcher.Renamed event of a FileSystemWatcher class.

[Visual Basic]
Public Delegate Sub RenamedEventHandler( _
   ByVal sender As Object, _
   ByVal e As RenamedEventArgs _
)
[C#]
public delegate void RenamedEventHandler(
   object sender,
   RenamedEventArgs e
);
[C++]
public __gc __delegate void RenamedEventHandler(
   Object* sender,
   RenamedEventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the RenamedEventHandler delegate declaration.

sender
The source of the event.
e
The RenamedEventArgs that contains the event data.

Remarks

When you create a RenamedEventHandler delegate, you identify the method that will handle the event. To associate the event with your event-handling method, add an instance of the delegate to the event. The event-handling method is called whenever the event occurs, unless you remove the delegate. For more information about event handler delegates, see TBD.

Requirements

Namespace: System.IO

Assembly: system.io.dll

See Also

System.IO Namespace | FileSystemWatcher | OnRenamed | System.IO.FileSystemWatcher.Renamed | RenamedEventArgs


SeekOrigin Enumeration

Provides the fields that represent seek reference points.

[Visual Basic]
Public Enum SeekOrigin
[C#]
public enum SeekOrigin
[C++]
public enum SeekOrigin

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Begin | Provides the seek reference position that refers to the beginning of a stream.
Current | Provides the seek reference position that refers to the current position within a stream.
End | Provides the seek reference position that refers to the end of a stream.

Requirements

Namespace: System.IO

Assembly: mscorlib.dll

Example

The following call sets the position of the stream at the end:

Stream.Seek(0,SeekOrigin.End)

See Also

System.IO Namespace


Stream Class

Provides a way to write and read bytes to and from a backing store. This class is abstract.

Object
Stream

[Visual Basic]
MustInherit Public Class Stream
[C#]
public abstract class Stream
[C++]
public __gc __abstract class Stream
[JScript]
public abstract class Stream

Remarks

This Stream class supports the mixing of synchronous and asynchronous reads and writes on the same stream, regardless of whether the operating system allows this. Stream provides default implementations of asynchronous read and write operations in terms of their synchronous implementations, and provides default implementations of synchronous read and write operations in terms of their asynchronous implementations.

Notes to Implementers: When implementing a subclass of Stream, it is necessary to provide an implementation for either the synchronous or asynchronous Read and Write methods. Overriding Read and Write is sufficient; the default implementations of the asynchronous methods (BeginRead, EndRead, BeginWrite, and EndWrite) will work with your implementation of the synchronous methods. Similarly, the synchronous Read and Write methods will work correctly if you provide an implementation of the asynchronous methods. The default implementations of ReadByte and WriteByte call the synchronous Read and Write methods with a one-element byte array. When subclassing Stream, if you have an internal byte buffer, it is strongly recommended that you override these methods to access your internal buffer for better performance.

All classes that represent streams inherit from the Stream class. The Stream class and its subclasses provide a generic view of data sources and repositories, isolating the programmer from the specific details of the operating system and underlying devices.

Streams involve these three fundamental operations:

  1. Streams can be read from. Reading is the transfer of data from a stream into a data structure, such as an array of bytes.
  2. Streams can be written to. Writing is the transfer of data from a data structure into a stream.
  3. Streams can support seeking. Seeking is the querying and modifying of the current position within a stream. Seek capability depends on the kind of backing store a stream has. For example, network streams have no unified concept of a current position, and therefore typically do not support seeking.

Depending on the underlying data source or repository, streams might support only some of these capabilities. An application can query a stream for its capabilities by using the CanRead, CanWrite, and CanSeek properties.

The Read and Write methods read and write data in a variety of formats. For streams that support seeking, the Seek and SetLength methods and the Position and Length properties can be used to query and modify the current position and length of a stream.

Some stream implementations perform local buffering of the underlying data to improve performance. For such streams, the Flush method can be used to clear any internal buffers and ensure that all data has been written to the underlying data source or repository.

Calling Close on a Stream flushes any buffered data, essentially calling Flush for you. Close also releases operating system resources such as file handles, network connections, or memory used for any internal buffering. The BufferedStream class provides the capability of wrapping a buffered stream around another stream in order to improve read and write performance.

The FileStream class is for reading from and writing to files. This class can be used to read and write bytes, characters, strings, and other data-type values to a file. It is also used to implement the standard in, standard out, and standard error streams.

The File class, used in conjunction with FileStream, is a utility class with static methods primarily for the creation of FileStream objects based on file paths and the standard input, standard output, and standard error devices.

The MemoryStream class provides a way to create streams that have memory as a backing store instead of a disk or a network connection. The MemoryStream class creates a stream out of an array of bytes.

Use BinaryWriter and BinaryReader for writing and reading primitive data types.

Requirements

Namespace: System.IO

Assembly: mscorlib.dll

See Also

Stream Members | System.IO Namespace


Stream Members

Public:

Constructor

Stream Constructor [To be supplied.]

Properties

CanRead | Determines whether the current stream supports reading.
CanSeek | Determines whether the current stream supports seeking.
CanWrite | Determines whether the current stream supports writing.
DataAvailable | Determines whether there are any bytes available in the current stream.
Length | Returns the length in bytes of the stream.
Position | Determines the position within the current stream.

Methods

BeginRead | Begins an asynchronous read.
BeginWrite | Begins an asynchronous write.
Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream.
EndRead | Ends a pending asynchronous read request.
EndWrite | Ends an asynchronous write.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Flush | Updates the underlying data source or repository with the current state of the buffer and then clears the buffer. If a stream does not implement a buffer, this method will do nothing.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Read | Reads a sequence of bytes from the current stream and advances the current position within the stream by the number of bytes read.
ReadByte | Reads a byte from the current position in the stream, or-1 if at the end of the stream.
Seek | Sets the position within the current stream.
SetLength | Sets the length of the current stream.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written.
WriteByte | Writes a byte to the current position in the stream. If the stream is closed or not writable, an exception will be thrown.

Fields

Null Provides a repository that can be written to, but not read from. Use Null to redirect output to a stream that will not consume any operating system resources.

Protected:

Methods

CreateWaitHandle | Allocates a WaitHandle object efficiently.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Stream Class | System.IO Namespace


Stream Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public Stream();
[C++]
public: Stream();
[JScript]
public function Stream();

See Also

Stream Class | Stream Members | System.IO Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Stream Properties

The properties of the Stream class are listed below. For a complete list of Stream class members, see the Stream Members topic.

Public:

CanRead | Determines whether the current stream supports reading.
CanSeek | Determines whether the current stream supports seeking.
CanWrite | Determines whether the current stream supports writing.
DataAvailable | Determines whether there are any bytes available in the current stream.
Length | Returns the length in bytes of the stream.
Position | Determines the position within the current stream.

See Also

Stream Class | System.IO Namespace


Stream.CanRead

Determines whether the current stream supports reading.

[Visual Basic]
MustOverride Public ReadOnly Property CanRead As Boolean
[C#]
public bool CanRead {abstract get;}
[C++]
public: __property virtual bool get_CanRead() = 0;
[JScript]
public abstract function get CanRead() : Boolean;

Property Value

true if the stream supports reading; otherwise, false.

Remarks

If a Stream subclass does not support reading, calls to the read and peek methods will throw a NotSupportedException.

See Also

Stream Class | Stream Members | System.IO Namespace


Stream.CanSeek

Determines whether the current stream supports seeking.

[Visual Basic]
MustOverride Public ReadOnly Property CanSeek As Boolean
[C#]
public bool CanSeek {abstract get;}
[C++]
public: __property virtual bool get_CanSeek() = 0;
[JScript]
public abstract function get CanSeek() : Boolean;

Property Value

true if the stream supports seeking; otherwise, false.

Remarks

If a Stream subclass does not support seeking, a call to any of the following methods will throw a NotSupportedException: Length, SetLength, Position, or Seek.

See Also

Stream Class | Stream Members | System.IO Namespace


Stream.CanWrite

Determines whether the current stream supports writing.

[Visual Basic]
MustOverride Public ReadOnly Property CanWrite As Boolean
[C#]
public bool CanWrite {abstract get;}
[C++]
public: __property virtual bool get_CanWrite() = 0;
[JScript]
public abstract function get CanWrite() : Boolean;

Property Value

true if the stream supports writing; otherwise, false.

Remarks

If a Stream subclass does not support writing, calls to the write methods will throw a NotSupportedException.

See Also

Stream Class | Stream Members | System.IO Namespace


Stream.DataAvailable

Determines whether there are any bytes available in the current stream.

[Visual Basic]
MustOverride Public ReadOnly Property DataAvailable As Boolean
[C#]
public bool DataAvailable {abstract get;}
[C++]
public: __property virtual bool get_DataAvailable() = 0;
[JScript]
public abstract function get DataAvailable() : Boolean;

Property Value

true if the end of the stream has not been reached; otherwise, false.

See Also

Stream Class | Stream Members | System.IO Namespace


Stream.Length

Returns the length in bytes of the stream.

[Visual Basic]
MustOverride Public ReadOnly Property Length As Long
[C#]
public long Length {abstract get;}
[C++]
public: __property virtual __int64 get_Length() = 0;
[JScript]
public abstract function get Length() : long;

Property Value

A long value representing the length of the stream in bytes.

Remarks

See Also

Stream Class | Stream Members | System.IO Namespace


Stream.Position

Determines the position within the current stream.

[Visual Basic]
MustOverride Public Property Position As Long
[C#]
public long Position {abstract get; abstract set;}
[C++]
public: __property virtual __int64 get_Position() = 0;public: __property virtual void set_Position(__int64) = 0;
[JScript]
public abstract function get Position() : long;
public abstract function set Position(long);

Property Value

The current position within the stream.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.
NotSupportedException | The stream does not support seeking.

Remarks

This stream must support seeking to get or set the position. Use the CanSeek property to determine whether the stream supports seeking.

The position cannot be set more than one byte beyond the end of the stream. You can set the position to just beyond the last byte so you can append to the file. Opening a new file and then writing to it requires this.

The default get accessor invokes the Seek method. The default set accessor calls Seek and returns the result. Therefore, it is possible to override Seek so that the Position property provides the functionality described above.

See Also

Stream Class | Stream Members | System.IO Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Stream Methods

The methods of the Stream class are listed below. For a complete list of Stream class members, see the Stream Members topic.

Public:

BeginRead | Begins an asynchronous read.
BeginWrite | Begins an asynchronous write.
Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream.
EndRead | Ends a pending asynchronous read request.
EndWrite | Ends an asynchronous write.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Flush | Updates the underlying data source or repository with the current state of the buffer and then clears the buffer. If a stream does not implement a buffer, this method will do nothing.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Read | Reads a sequence of bytes from the current stream and advances the current position within the stream by the number of bytes read.
ReadByte | Reads a byte from the current position in the stream, or-1 if at the end of the stream.
Seek | Sets the position within the current stream.
SetLength | Sets the length of the current stream.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written.
WriteByte | Writes a byte to the current position in the stream. If the stream is closed or not writable, an exception will be thrown.

Protected:

CreateWaitHandle | Allocates a WaitHandle object efficiently.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Stream Class | System.IO Namespace


Stream.BeginRead

Begins an asynchronous read.

[Visual Basic]
Overridable Public Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
[C#]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
);
[C++]
public: virtual IAsyncResult* BeginRead(
   unsigned char* buffer[],
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
);
[JScript]
public function BeginRead(
   buffer : Byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;

Parameters

buffer
The buffer to read data from.
offset
The byte offset in buffer at which to begin reading.
count
The maximum number of bytes to read.
callback
An optional asynchronous callback, to be called when the read is complete.
state
The state object.

Return Value

An IAsyncResult that represents the asynchronous read, which is quite possibly still pending.

Exceptions

Exception Type | Condition
IOException | An asynchronous read was attempted past the end of the file.

Remarks

The current position in the stream is updated when you issue the asynchronous read or write, not when the IO operation completes.

You must call EndRead with this IAsyncResult to find out how many bytes were read.

See Also

Stream Class | Stream Members | System.IO Namespace


Stream.BeginWrite

Begins an asynchronous write.

[Visual Basic]
Overridable Public Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
[C#]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
);
[C++]
public: virtual IAsyncResult* BeginWrite(
   unsigned char* buffer[],
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
);
[JScript]
public function BeginWrite(
   buffer : Byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;

Parameters

buffer
The buffer to write data to.
offset
The byte offset in buffer at which to begin writing.
count
The maximum number of bytes to write.
callback
An optional asynchronous callback, to be called when the write is complete.
state
The state object.

Return Value

An IAsyncResult that represents the asynchronous read, which is quite possibly still pending.

Exceptions

Exception Type | Condition
IOException | An asynchronous write was attempted past the end of the file.

Remarks

The current position in the stream is updated when you issue the asynchronous read or write, not when the IO operation completes.

You must call EndWrite with this IAsyncResult to find out how many bytes were written.

See Also

Stream Class | Stream Members | System.IO Namespace


Stream.Close

Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream.

[Visual Basic]
MustOverride Public Sub Close()
[C#]
public abstract void Close();
[C++]
public: virtual void Close() = 0;
[JScript]
public abstract function Close();

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.

Remarks

Following a call to Close, other operations on the stream might raise exceptions. However, you may safely call Close on a closed stream.

This default implementation does nothing. Stream subclasses must override this method to provide the appropriate functionality.

See Also

Stream Class | Stream Members | System.IO Namespace


Stream.CreateWaitHandle

Allocates a WaitHandle object efficiently.

[Visual Basic]
Overridable Protected Function CreateWaitHandle() As WaitHandle
[C#]
protected virtual WaitHandle CreateWaitHandle();
[C++]
protected: virtual WaitHandle* CreateWaitHandle();
[JScript]
protected function CreateWaitHandle() : WaitHandle;

Return Value

A new WaitHandle.

Remarks

CreateWaitHandle might be useful if you implement the asynchronous methods and require a way of blocking in EndRead or EndWrite until the asynchronous operation is complete.

See Also

Stream Class | Stream Members | System.IO Namespace


Stream.EndRead

Ends a pending asynchronous read request.

[Visual Basic]
Overridable Public Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
[C#]
public virtual int EndRead(
   IAsyncResult asyncResult
);
[C++]
public: virtual int EndRead(
   IAsyncResult* asyncResult
);
[JScript]
public function EndRead(
   asyncResult : IAsyncResult
) : int;

Parameters

asyncResult
The reference to the pending asynchronous request to be ended.

Return Value

The number of bytes read or 0 if none were read.

Exceptions

Exception Type | Condition
ArgumentNullException | asyncResult is null.

Remarks

EndRead will block until the IO operation has completed.

See Also

Stream Class | Stream Members | System.IO Namespace


Stream.EndWrite

Ends an asynchronous write.

[Visual Basic]
Overridable Public Function EndWrite( _
   ByVal asyncResult As IAsyncResult _
) As Integer
[C#]
public virtual int EndWrite(
   IAsyncResult asyncResult
);
[C++]
public: virtual int EndWrite(
   IAsyncResult* asyncResult
);
[JScript]
public function EndWrite(
   asyncResult : IAsyncResult
) : int;

Parameters

asyncResult
A reference to the outstanding Asynchronous IO request.

Return Value

The number of bytes written.

Exceptions

Exception Type | Condition
ArgumentNullException | asyncResult is null.

Remarks

EndWrite will block until the IO operation has completed.

See Also

Stream Class | Stream Members | System.IO Namespace


Stream.Flush

Updates the underlying data source or repository with the current state of the buffer and then clears the buffer.

If a stream does not implement a buffer, this method will do nothing.

[Visual Basic]
MustOverride Public Sub Flush()
[C#]
public abstract void Flush();
[C++]
public: virtual void Flush() = 0;
[JScript]
public abstract function Flush();

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.

Remarks

Because a buffer may be used for either reading or writing, but not both simultaneously, Flush might write to the underlying data source or repository any data previously written to the buffer, or Flush might clear the buffer, or both.

See Also

Stream Class | Stream Members | System.IO Namespace


Stream.Read

Reads a sequence of bytes from the current stream and advances the current position within the stream by the number of bytes read.

[Visual Basic]
Overridable Public Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
[C#]
public virtual int Read(
   byte[] buffer,
   int offset,
   int count
);
[C++]
public: virtual int Read(
   unsigned char* buffer[],
   int offset,
   int count
);
[JScript]
public function Read(
   buffer : Byte[],
   offset : int,
   count : int
) : int;

Parameters

buffer
An array of bytes. A maximum of count bytes are read from the current stream and stored in buffer.
offset
The byte offset in buffer at which to begin storing the data read from the current stream.
count
The maximum number of bytes to be read from the current stream.

Return Value

The total number of bytes read into the buffer. This may be less than the number of bytes requested if that many bytes aren't currently available, or zero if the end of the stream has been reached before any data can be read.

Exceptions

Exception Type | Condition
ArgumentException | The result of offset subtracted from the buffer length is less than count.
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | offset or count is negative.
IOException | An I/O error occurs.
NotSupportedException | The stream does not support reading.

Remarks

The default implementation calls the asynchronous BeginRead method.

Implementations of this method read a maximum of count bytes from the current stream and store them in buffer

beginning at offset. The current position within the stream is advanced by the number of bytes read. However, if an exception occurs, the current position within the stream is unchanged. Implementations return the number of bytes read. The return value is zero only if the position is currently at the end of the stream. The implementation will block until at least one byte of data can be read, in the event that no data is available.

Use BinaryReader for reading primitive data types.

See Also

Stream Class | Stream Members | System.IO Namespace


Stream.ReadByte

Reads a byte from the current position in the stream, or-1 if at the end of the stream.

[Visual Basic]
Overridable Public Function ReadByte() As Integer
[C#]
public virtual int ReadByte();
[C++]
public: virtual int ReadByte();
[JScript]
public function ReadByte() : int;

Return Value

The unsigned byte cast to an int, or-1 if at the end of the stream.

Exceptions

Exception Type | Condition
IOException | The stream is closed.
NotSupportedException | The stream does not support reading.

Remarks

If the stream is closed or not readable, an exception will be thrown.

The implementation on Stream creates a new one-byte array and then calls Read (byte[], int,

int). While this is formally correct, it is inefficient. Any stream with an internal buffer should override this method and provide a much more efficient version that reads their buffer directly, avoiding the extra array allocation on every call.

See Also

Stream Class | Stream Members | System.IO Namespace


Stream.Seek

Sets the position within the current stream.

[Visual Basic]
MustOverride Public Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
[C#]
public abstract long Seek(
   long offset,
   SeekOrigin origin
);
[C++]
public: virtual __int64 Seek(
   __int64 offset,
   SeekOrigin origin
) = 0;
[JScript]
public abstract function Seek(
   offset : long,
   origin : SeekOrigin
) : long;

Parameters

offset
A byte offset relative to origin. If offset is negative, the new position will precede the position specified by origin by the number of bytes specified by offset. If offset is zero, the new position will be the position specified by origin. If offset is positive, the new position will follow the position specified by origin by the number of bytes specified by offset.
origin
A field of SeekOrigin indicating the reference point from which the new position is to be obtained.

Return Value

The new position within the current stream.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.
NotSupportedException | The stream does not support seeking.

Remarks

Stream subclasses that support seeking should override this method to provide the functionality described above. The default implementation simply throws a NotSupportedException.The position cannot be set more than one byte beyond the end of the stream. You can set the position to just beyond the last byte so you can append to the file. Opening a new file and then writing to it requires this.

See Also

Stream Class | Stream Members | System.IO Namespace


Stream.SetLength

Sets the length of the current stream.

[Visual Basic]
MustOverride Public Sub SetLength( _
   ByVal value As Long _
)
[C#]
public abstract void SetLength(
   long value
);
[C++]
public: virtual void SetLength(
   __int64 value
) = 0;
[JScript]
public abstract function SetLength(
   value : long
);

Parameters

value
An integer indicating the desired length of the current stream in bytes.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.
NotSupportedException | The stream does not support both writing and seeking.

Remarks

If the specified value is less than the current length of the stream, the stream is truncated. If the specified value is larger than the current length of the stream, the stream is expanded. If the stream is expanded, the contents of the stream between the old and the new length are not defined.

The default implementation simply throws a NotSupportedException. A subclass of Stream must support both writing and seeking for SetLength to be operational.

See Also

Stream Class | Stream Members | System.IO Namespace


Stream.Write

Writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written.

[Visual Basic]
Overridable Public Function Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
[C#]
public virtual int Write(
   byte[] buffer,
   int offset,
   int count
);
[C++]
public: virtual int Write(
   unsigned char* buffer[],
   int offset,
   int count
);
[JScript]
public function Write(
   buffer : Byte[],
   offset : int,
   count : int
) : int;

Parameters

buffer
An array of bytes. This method copies count bytes from buffer to the current stream.
offset
The byte offset in buffer at which to begin copying bytes to the current stream.
count
The number of bytes to be written to the current stream.

Return Value

The total number of bytes written to the stream.

Exceptions

Exception Type | Condition
ArgumentException | The result of offset subtracted from the buffer length is less than count.
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | offset or count is negative.
IOException | An I/O error occurs.
NotSupportedException | The stream does not support writing.

Remarks

The default implementation calls the asynchronous BeginWrite method.

Implementations of this method copy count bytes to this stream from buffer beginning at offset. If the write operation is successful, the current position within the stream is advanced by the number of bytes written. If an exception occurs, the current position within the stream is unchanged.

Use BinaryWriter for writing primitive data types.

See Also

Stream Class | Stream Members | System.IO Namespace


Stream.WriteByte

Writes a byte to the current position in the stream.

If the stream is closed or not writable, an exception will be thrown.

[Visual Basic]
Overridable Public Sub WriteByte( _
   ByVal value As Byte _
)
[C#]
public virtual void WriteByte(
   byte value
);
[C++]
public: virtual void WriteByte(
   unsigned char value
);
[JScript]
public function WriteByte(
   value : Byte
);

Parameters

value
A byte to write to the stream.

Exceptions

Exception Type | Condition
IOException | The stream is closed.
NotSupportedException | The stream does not support writing.

Remarks

While correct, the implementation on Stream creates a new one byte long array then calls Write(byte[], int, int). Any stream with an internal buffer should override this method and provide a much more efficient version that reads their buffer directly, avoiding the extra array allocation on every call.

See Also

Stream Class | Stream Members | System.IO Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Stream Fields

The fields of the Stream class are listed below. For a complete list of Stream class members, see the Stream Members topic.

Public:

Null Provides a repository that can be written to, but not read from. Use Null to redirect output to a stream that will not consume any operating system resources.

See Also

Stream Class | System.IO Namespace


Stream.Null

Provides a repository that can be written to, but not read from. Use Null to redirect output to a stream that will not consume any operating system resources.

[Visual Basic]
Public Shared ReadOnly Null As Stream
[C#]
public static readonly Stream Null;
[C++]
public: static readonly Stream* Null;
[JScript]
public static var Null : Stream;

Remarks

When the methods of Stream that provide writing are invoked on Null, the call simply returns, and no data is actually written to an underlying data source or repository. Null also implements a Read method that returns zero, without actually reading data from an underlying data source or repository.

See Also

Stream Class | Stream Members | System.IO Namespace


StreamReader Class

Implements a TextReader that reads characters from a byte stream in a particular encoding.

Object
TextReader
StreamReader

[Visual Basic]
Public Class StreamReader
   Inherits TextReader
[C#]
public class StreamReader : TextReader
[C++]
public __gc class StreamReader : public TextReader
[JScript]
public class StreamReader extends TextReader

Remarks

This class implements a TextReader for reading characters from a Stream. StreamReader is designed for character input in a particular encoding, whereas the Stream class is designed for byte input and output.

StreamReader defaults to UTF-8 encoding unless specified otherwise, instead of defaulting to the ANSI code page for the current system. UTF-8 handles Unicode characters correctly and gives consistent results on localized versions of the operating system.

Requirements

Namespace: System.IO

Assembly: mscorlib.dll

See Also

StreamReader Members | System.IO Namespace | Encoding | Stream | StreamWriter


StreamReader Members

Public:

Constructor

StreamReader Constructor Overloaded. Creates a new instance of the StreamReader class for the specified stream.

Properties

BaseStream Returns the underlying stream.

Methods

Close | Closes the StreamReader and releases any system resources associated with the reader.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEncoding | Returns the current character encoding that is being used by the current reader.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Peek | Returns the next available character without actually reading it from the input stream.
Read | Overloaded. Reads the next character or next set of characters from the input stream.
ReadBlock (inherited from TextReader) | Reads a maximum of count characters from the current stream and writes the data to buffer, beginning at index.
ReadLine | Reads a line of characters from the current stream and returns the data as a string.
ReadToEnd | Reads the stream from the current position to the end of the stream.
SwitchEncoding | Overloaded. Switches the current stream's encoding to the new encoding.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Null Returns no characters when Read methods are invoked on empty streams.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StreamReader Class | System.IO Namespace


StreamReader Constructor

Creates a new instance of the StreamReader class for the specified stream.

Overload List

Creates a new instance of the StreamReader class for the specified stream.

[Visual Basic] Overloads Public Sub New(Stream)
[C#] public StreamReader(Stream);
[C++] public: StreamReader(Stream*);
[JScript] public function StreamReader(Stream);

Creates a new instance of the StreamReader class for the specified stream and with the specified character encoding.

[Visual Basic] Overloads Public Sub New(Stream, Encoding)
[C#] public StreamReader(Stream, Encoding);
[C++] public: StreamReader(Stream*, Encoding);
[JScript] public function StreamReader(Stream, Encoding);

Creates a new instance of the StreamReader class for the specified stream, with the specified character encoding and buffer size.

[Visual Basic] Overloads Public Sub New(Stream, Encoding, Integer)
[C#] public StreamReader(Stream, Encoding, int);
[C++] public: StreamReader(Stream*, Encoding, int);
[JScript] public function StreamReader(Stream, Encoding, int);

Creates a new StreamReader for the given stream, with the specified character encoding and buffer size. This constructor automatically detects UTF-8, little endian Unicode, and big endian Unicode text.

[Visual Basic] Overloads Public Sub New(Stream, Encoding, Integer, Boolean)
[C#] public StreamReader(Stream, Encoding, int, bool);
[C++] public: StreamReader(Stream*, Encoding, int, bool);
[JScript] public function StreamReader(Stream, Encoding, int, Boolean);

Creates a new instance of the StreamReader class on the specified path.

[Visual Basic] Overloads Public Sub New(String)
[C#] public StreamReader(String);
[C++] public: StreamReader(String*);
[JScript] public function StreamReader(String);

Creates a new instance of the StreamReader class on the specified path and with the specified character encoding.

[Visual Basic] Overloads Public Sub New(String, Encoding)
[C#] public StreamReader(String, Encoding);
[C++] public: StreamReader(String*, Encoding);
[JScript] public function StreamReader(String, Encoding);

Creates a new instance of the StreamReader class on the specified path, with the specified character encoding and buffer size.

[Visual Basic] Overloads Public Sub New(String, Encoding, Integer)
[C#] public StreamReader(String, Encoding, int);
[C++] public: StreamReader(String*, Encoding, int);
[JScript] public function StreamReader(String, Encoding, int);

Creates a new instance of the StreamReader class on the specified path, with the specified character encoding and buffer size. This constructor automatically detects UTF-8, little endian Unicode, and big endian Unicode text.

[Visual Basic] Overloads Public Sub New(String, Encoding, Integer, Boolean)
[C#] public StreamReader(String, Encoding, int, bool);
[C++] public: StreamReader(String*, Encoding, int, bool);
[JScript] public function StreamReader(String, Encoding, int, Boolean);

See Also

StreamReader Class | StreamReader Members | System.IO Namespace


StreamReader Constructor (Stream)

Creates a new instance of the StreamReader class for the specified stream.

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream _
)
[C#]
public StreamReader(
   Stream stream
);
[C++]
public: StreamReader(
   Stream* stream
);
[JScript]
public function StreamReader(
   stream : Stream
);

Parameters

stream
The stream to be read.

Exceptions

Exception Type | Condition
ArgumentNullException | stream is null.

Remarks

The default character encoding and the default buffer size are used.

See Also

StreamReader Class | StreamReader Members | System.IO Namespace | StreamReader Constructor Overload List


StreamReader Constructor (Stream, Encoding)

Creates a new instance of the StreamReader class for the specified stream and with the specified character encoding.

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream, _
   ByVal encoding As Encoding _
)
[C#]
public StreamReader(
   Stream stream,
   Encoding encoding
);
[C++]
public: StreamReader(
   Stream* stream,
   Encoding* encoding
);
[JScript]
public function StreamReader(
   stream : Stream,
   encoding : Encoding
);

Parameters

stream
The stream to be read.
encoding
The character encoding to use.

Exceptions

Exception Type | Condition
ArgumentException | stream does not support reading.
ArgumentNullException | stream or encoding is null.

Remarks

The character encoding is set by encoding, and the default buffer size is used.

See Also

StreamReader Class | StreamReader Members | System.IO Namespace | StreamReader Constructor Overload List


StreamReader Constructor (Stream, Encoding, Int32)

Creates a new instance of the StreamReader class for the specified stream, with the specified character encoding and buffer size.

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream, _
   ByVal encoding As Encoding, _
   ByVal bufferSize As Integer _
)
[C#]
public StreamReader(
   Stream stream,
   Encoding encoding,
   int bufferSize
);
[C++]
public: StreamReader(
   Stream* stream,
   Encoding* encoding,
   int bufferSize
);
[JScript]
public function StreamReader(
   stream : Stream,
   encoding : Encoding,
   bufferSize : int
);

Parameters

stream
The stream to be read.
encoding
The character encoding to use.
bufferSize
The suggested minimum buffer size.

Exceptions

Exception Type | Condition
ArgumentException | stream does not support reading.
ArgumentNullException | stream or encoding is null.
ArgumentOutOfRangeException | bufferSize is less than or equal to zero.

Remarks

The character encoding is set by encoding. The buffer size, in number of 16-bit characters, is set by bufferSize. If bufferSize is less than the minimum allowable size (128 characters), the minimum allowable size is used.

See Also

StreamReader Class | StreamReader Members | System.IO Namespace | StreamReader Constructor Overload List


StreamReader Constructor (Stream, Encoding, Int32, Boolean)

Creates a new StreamReader for the given stream, with the specified character encoding and buffer size. This constructor automatically detects UTF-8, little endian Unicode, and big endian Unicode text.

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream, _
   ByVal encoding As Encoding, _
   ByVal bufferSize As Integer, _
   ByVal detectEncodingFromByteOrderMarks As Boolean _
)
[C#]
public StreamReader(
   Stream stream,
   Encoding encoding,
   int bufferSize,
   bool detectEncodingFromByteOrderMarks
);
[C++]
public: StreamReader(
   Stream* stream,
   Encoding* encoding,
   int bufferSize,
   bool detectEncodingFromByteOrderMarks
);
[JScript]
public function StreamReader(
   stream : Stream,
   encoding : Encoding,
   bufferSize : int,
   detectEncodingFromByteOrderMarks : Boolean
);

Parameters

stream
The stream to be read.
encoding
The character encoding to use.
bufferSize
The suggested minimum buffer size.
detectEncodingFromByteOrderMarks
An indicator of the encoding type.

Exceptions

Exception Type | Condition
ArgumentException | The stream does not support reading.
ArgumentNullException | stream or encoding is a null reference (in Visual Basic Nothing).
ArgumentOutOfRangeException | bufferSize is negative.

Remarks

This constructor allows you to change the encoding the first time you read from the StreamReader. The detectEncodingFromByteOrderMarks parameter detects the encoding by looking at the first three bytes of the stream. It automatically recognizes UTF-8, little endian Unicode, and big endian Unicode text. If none of those three match, the user-provided Encoding is used.

See Also

StreamReader Class | StreamReader Members | System.IO Namespace | StreamReader Constructor Overload List


StreamReader Constructor (String)

Creates a new instance of the StreamReader class on the specified path.

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As String _
)
[C#]
public StreamReader(
   string path
);
[C++]
public: StreamReader(
   String* path
);
[JScript]
public function StreamReader(
   path : String
);

Parameters

path
The complete file path to be read.

Exceptions

Exception Type | Condition
ArgumentException | path is an empty string ("").
ArgumentNullException | path is null.
FileNotFoundException | The file cannot be found.

Remarks

The complete file path is specified by path. The default character encoding and default buffer size are used.

See Also

StreamReader Class | StreamReader Members | System.IO Namespace | StreamReader Constructor Overload List


StreamReader Constructor (String, Encoding)

Creates a new instance of the StreamReader class on the specified path and with the specified character encoding.

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As String, _
   ByVal encoding As Encoding _
)
[C#]
public StreamReader(
   string path,
   Encoding encoding
);
[C++]
public: StreamReader(
   String* path,
   Encoding* encoding
);
[JScript]
public function StreamReader(
   path : String,
   encoding : Encoding
);

Parameters

path
The complete file path to be read.
encoding
The character encoding to use.

Exceptions

Exception Type | Condition
ArgumentException | path is an empty string ("").
ArgumentNullException | path or encoding is null.
FileNotFoundException | The file cannot be found.

Remarks

The default buffer size is used.

See Also

StreamReader Class | StreamReader Members | System.IO Namespace | StreamReader Constructor Overload List


StreamReader Constructor (String, Encoding, Int32)

Creates a new instance of the StreamReader class on the specified path, with the specified character encoding and buffer size.

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As String, _
   ByVal encoding As Encoding, _
   ByVal bufferSize As Integer _
)
[C#]
public StreamReader(
   string path,
   Encoding encoding,
   int bufferSize
);
[C++]
public: StreamReader(
   String* path,
   Encoding* encoding,
   int bufferSize
);
[JScript]
public function StreamReader(
   path : String,
   encoding : Encoding,
   bufferSize : int
);

Parameters

path
The complete file path to be read.
encoding
The character encoding to use.
bufferSize
The suggested minimum buffer size.

Exceptions

Exception Type | Condition
ArgumentException | path is an empty string.
ArgumentNullException | path or encoding is null.
ArgumentOutOfRangeException | bufferSize is less than zero.
FileNotFoundException | The file cannot be found.

Remarks

The buffer size, in number of 16-bit characters, is set by bufferSize. If bufferSize

is less than the minimum allowable size (128 characters), the minimum allowable size is used.

See Also

StreamReader Class | StreamReader Members | System.IO Namespace | StreamReader Constructor Overload List


StreamReader Constructor (String, Encoding, Int32, Boolean)

Creates a new instance of the StreamReader class on the specified path, with the specified character encoding and buffer size. This constructor automatically detects UTF-8, little endian Unicode, and big endian Unicode text.

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As String, _
   ByVal encoding As Encoding, _
   ByVal bufferSize As Integer, _
   ByVal detectEncodingFromByteOrderMarks As Boolean _
)
[C#]
public StreamReader(
   string path,
   Encoding encoding,
   int bufferSize,
   bool detectEncodingFromByteOrderMarks
);
[C++]
public: StreamReader(
   String* path,
   Encoding* encoding,
   int bufferSize,
   bool detectEncodingFromByteOrderMarks
);
[JScript]
public function StreamReader(
   path : String,
   encoding : Encoding,
   bufferSize : int,
   detectEncodingFromByteOrderMarks : Boolean
);

Parameters

path
The complete file path to be read.
encoding
The character encoding to use.
bufferSize
The suggested minimum buffer size.
detectEncodingFromByteOrderMarks
An indicator of the encoding type.

Exceptions

Exception Type | Condition
ArgumentException | path is an empty string ("").
ArgumentNullException | path or encoding is a null reference (in Visual Basic Nothing).
ArgumentOutOfRangeException | bufferSize is negative.

Remarks

This constructor allows you to change the encoding the first time you read from the StreamReader. The detectEncodingFromByteOrderMarks parameter detects the encoding by looking at the first three bytes of the stream. It automatically recognizes UTF-8, little endian Unicode, and big endian Unicode text. If none of those three match, the user-provided Encoding is used.

See Also

StreamReader Class | StreamReader Members | System.IO Namespace | StreamReader Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StreamReader Properties

The properties of the StreamReader class are listed below. For a complete list of StreamReader class members, see the StreamReader Members topic.

Public:

BaseStream Returns the underlying stream.

See Also

StreamReader Class | System.IO Namespace


StreamReader.BaseStream

Returns the underlying stream.

[Visual Basic]
Overridable Public ReadOnly Property BaseStream As Stream
[C#]
public Stream BaseStream {virtual get;}
[C++]
public: __property virtual Stream* get_BaseStream();
[JScript]
public function get BaseStream() : Stream;

Property Value

The underlying stream.

Remarks

SwitchEncoding can change the encoding, under some complex conditions. Also, the StreamReader constructors with the detectEncodingFromByteOrderMarks parameter can change the encoding the first time you read from the StreamReader.

See Also

StreamReader Class | StreamReader Members | System.IO Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StreamReader Methods

The methods of the StreamReader class are listed below. For a complete list of StreamReader class members, see the StreamReader Members topic.

Public:

Close | Closes the StreamReader and releases any system resources associated with the reader.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEncoding | Returns the current character encoding that is being used by the current reader.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Peek | Returns the next available character without actually reading it from the input stream.
Read | Overloaded. Reads the next character or next set of characters from the input stream.
ReadBlock (inherited from TextReader) | Reads a maximum of count characters from the current stream and writes the data to buffer, beginning at index.
ReadLine | Reads a line of characters from the current stream and returns the data as a string.
ReadToEnd | Reads the stream from the current position to the end of the stream.
SwitchEncoding | Overloaded. Switches the current stream's encoding to the new encoding.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StreamReader Class | System.IO Namespace


StreamReader.Close

Closes the StreamReader and releases any system resources associated with the reader.

[Visual Basic]
Overrides Public Sub Close()
[C#]
public override void Close();
[C++]
public: override void Close();
[JScript]
public override function Close();

Remarks

Following a call to Close, any operations on the reader may raise exceptions.

See Also

StreamReader Class | StreamReader Members | System.IO Namespace


StreamReader.GetEncoding

Returns the current character encoding that is being used by the current reader.

[Visual Basic]
Overridable Public Function GetEncoding() As Encoding
[C#]
public virtual Encoding GetEncoding();
[C++]
public: virtual Encoding* GetEncoding();
[JScript]
public function GetEncoding() : Encoding;

Return Value

The current character encoding being used by the current reader.

See Also

StreamReader Class | StreamReader Members | System.IO Namespace


StreamReader.Peek

Returns the next available character without actually reading it from the input stream.

[Visual Basic]
Overrides Public Function Peek() As Integer
[C#]
public override int Peek();
[C++]
public: override int Peek();
[JScript]
public override function Peek() : int;

Return Value

The next character to be read, or-1 if no more characters are available.

Exceptions

Exception Type | Condition
IOException | The stream is closed.

Remarks

The current position of the stream is not changed by the StreamReader. The returned value is-1 if no more characters are available.

See Also

StreamReader Class | StreamReader Members | System.IO Namespace


StreamReader.Read

Reads the next character or next set of characters from the input stream.

Overload List

Reads a maximum of count characters from the current stream and writes the data to buffer, beginning at index.

[Visual Basic] Overloads Overrides Public Function Read(Char(), Integer, Integer) As Integer
[C#] public override int Read(char[], int, int);
[C++] public: override int Read(__wchar_t*[], int, int);
[JScript] public override function Read(Char[], int, int) : int;

Reads the next character from the input stream and advances the character position within the stream by one character.

[Visual Basic] Overloads Overrides Public Function Read() As Integer
[C#] public override int Read();
[C++] public: override int Read();
[JScript] public override function Read() : int;

See Also

StreamReader Class | StreamReader Members | System.IO Namespace


StreamReader.Read (Char[], Int32, Int32)

Reads a maximum of count characters from the current stream and writes the data to buffer, beginning at index.

[Visual Basic]
Overloads Overrides Public Function Read( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
[C#]
public override int Read(
   char[] buffer,
   int index,
   int count
);
[C++]
public: override int Read(
   __wchar_t* buffer[],
   int index,
   int count
);
[JScript]
public override function Read(
   buffer : Char[],
   index : int,
   count : int
) : int;

Parameters

buffer
The character array to write data to.
index
The index of buffer at which to begin writing.
count
The maximum number of characters to read.

Return Value

The number of characters that have been read. The number will be less than or equal to count, depending on whether the data is available within the stream.

Exceptions

Exception Type | Condition
ArgumentException | The buffer length minus index is less than count.
ArgumentNullException | buffer is a null reference (in Visual Basic Nothing).
ArgumentOutOfRangeException | index or count is negative.
IOException | An I/O error occurs.

Remarks

StreamReader.Read(char[], int, int) and Write (char[], int, int) read and write the number of characters specified by the count parameter. These are to be distinguished from Read and Write, which read and write the number of bytes specified by the count parameter. Use the BufferedStream methods only for reading and writing an integral number of byte array elements.

This method returns after either count characters are read, or the end of the file is reached. ReadBlock is a blocking version of StreamReader.Read.

See Also

StreamReader Class | StreamReader Members | System.IO Namespace | StreamReader.Read Overload List


StreamReader.Read ()

Reads the next character from the input stream and advances the character position within the stream by one character.

[Visual Basic]
Overloads Overrides Public Function Read() As Integer
[C#]
public override int Read();
[C++]
public: override int Read();
[JScript]
public override function Read() : int;

Return Value

The next character from the input stream, or-1 if no more characters are available.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs or the input stream is null.

See Also

StreamReader Class | StreamReader Members | System.IO Namespace | StreamReader.Read Overload List


StreamReader.ReadLine

Reads a line of characters from the current stream and returns the data as a string.

[Visual Basic]
Overrides Public Function ReadLine() As String
[C#]
public override string ReadLine();
[C++]
public: override String* ReadLine();
[JScript]
public override function ReadLine() : String;

Return Value

The next line from the input stream, or null if the end of the input stream has been reached.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs or the input stream is null.

Remarks

A line is defined as a sequence of characters followed by a line feed ("\n") or a carriage return immediately followed by a line feed ("\r\n"). The string that is returned does not contain the terminating carriage return or line feed. The returned value is null if the end of the input stream has been reached.

This method overrides ReadLine.

See Also

StreamReader Class | StreamReader Members | System.IO Namespace


StreamReader.ReadToEnd

Reads the stream from the current position to the end of the stream.

[Visual Basic]
Overrides Public Function ReadToEnd() As String
[C#]
public override string ReadToEnd();
[C++]
public: override String* ReadToEnd();
[JScript]
public override function ReadToEnd() : String;

Return Value

The entire stream as a string.

Exceptions

Exception Type | Condition
IOException | The stream is a null reference (in Visual Basic Nothing).

Remarks

For better performance, call Read (char[], int, int) with a buffer the same size as the StreamReader's internal buffer.

See Also

StreamReader Class | StreamReader Members | System.IO Namespace


StreamReader.SwitchEncoding

Switches the current stream's encoding to the new encoding.

Overload List

Switches the current stream's encoding to the new one, reading from the current position onward.

[Visual Basic] Overloads Overridable Public Sub SwitchEncoding(Encoding)
[C#] public virtual void SwitchEncoding(Encoding);
[C++] public: virtual void SwitchEncoding(Encoding*);
[JScript] public function SwitchEncoding(Encoding);

Switches the current stream's encoding to the new one, reading from the specified character position onward.

[Visual Basic] Overloads Overridable Public Sub SwitchEncoding(Encoding, Integer)
[C#] public virtual void SwitchEncoding(Encoding, int);
[C++] public: virtual void SwitchEncoding(Encoding*, int);
[JScript] public function SwitchEncoding(Encoding, int);

See Also

StreamReader Class | StreamReader Members | System.IO Namespace


StreamReader.SwitchEncoding (Encoding)

Switches the current stream's encoding to the new one, reading from the current position onward.

[Visual Basic]
Overloads Overridable Public Sub SwitchEncoding( _
   ByVal enc As Encoding _
)
[C#]
public virtual void SwitchEncoding(
   Encoding enc
);
[C++]
public: virtual void SwitchEncoding(
   Encoding* enc
);
[JScript]
public function SwitchEncoding(
   enc : Encoding
);

Parameters

enc
The new encoding to use.

Exceptions

Exception Type | Condition
ArgumentNullException | enc is a null reference (in Visual Basic Nothing).
InvalidOperationException | SwitchEncoding is called after reading the second time from the underlying stream.

Remarks

SwitchEncoding supports the reading of a few lines of header information in one encoding, and then reading the rest of the document in a different encoding.

Use SwitchEncoding(Encoding, int) to re-encode from a specified character position in the stream onward, and to read restrictions on the use of SwitchEncoding.

See Also

StreamReader Class | StreamReader Members | System.IO Namespace | StreamReader.SwitchEncoding Overload List


StreamReader.SwitchEncoding (Encoding, Int32)

Switches the current stream's encoding to the new one, reading from the specified character position onward.

[Visual Basic]
Overloads Overridable Public Sub SwitchEncoding( _
   ByVal enc As Encoding, _
   ByVal useCharPos As Integer _
)
[C#]
public virtual void SwitchEncoding(
   Encoding enc,
   int useCharPos
);
[C++]
public: virtual void SwitchEncoding(
   Encoding* enc,
   int useCharPos
);
[JScript]
public function SwitchEncoding(
   enc : Encoding,
   useCharPos : int
);

Parameters

enc
The new encoding to use.
useCharPos
The position at which you want to start using the new encoding.

Exceptions

Exception Type | Condition
ArgumentException | useCharPos is invalid.
ArgumentNullException | enc is a null reference (in Visual Basic Nothing).
InvalidOperationException | SwitchEncoding is called after reading past the first character buffer's worth of data.

Remarks

SwitchEncoding supports the reading of a few lines of header information in one encoding, and then reading the rest of the document in a different encoding.

SwitchEncoding cannot be called after you have read past the first character buffer's worth of data.

This method re-encodes from the specified character position in the stream onwards. Once a stream encoding has been changed, there is no way to read the previous characters from the StreamReader. The bytes are lost.

Note This will only succeed if the StreamReader has not read more than one buffer's worth of data. You can control this to an extent with the bufferSize parameter to the StreamReader constructor.

See Also

StreamReader Class | StreamReader Members | System.IO Namespace | StreamReader.SwitchEncoding Overload List


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StreamReader Fields

The fields of the StreamReader class are listed below. For a complete list of StreamReader class members, see the StreamReader Members topic.

Public:

Null Returns no characters when Read methods are invoked on empty streams.

See Also

StreamReader Class | System.IO Namespace


StreamReader.Null

Returns no characters when Read methods are invoked on empty streams.

[Visual Basic]
Public Shared ReadOnly Null As StreamReader
[C#]
public static readonly StreamReader Null;
[C++]
public: static readonly StreamReader* Null;
[JScript]
public static var Null : StreamReader;

Remarks

When read methods are invoked on StreamReader.Null, zero is always returned. When ReadLine or GetStream are invoked on StreamReader.Null, null is returned.

See Also

StreamReader Class | StreamReader Members | System.IO Namespace


StreamWriter Class

Implements a TextWriter for writing characters to a stream.

Object
TextWriter
StreamWriter

[Visual Basic]
Public Class StreamWriter
   Inherits TextWriter
[C#]
public class StreamWriter : TextWriter
[C++]
public __gc class StreamWriter : public TextWriter
[JScript]
public class StreamWriter extends TextWriter

Remarks

StreamWriter is designed for character output in a particular Encoding, whereas subclasses of Stream are designed for byte input and output.

StreamWriter defaults to UTF8Encoding unless specified otherwise. UTF-8 handles Unicode characters correctly and gives consistent results on localized versions of the operating system.

Requirements

Namespace: System.IO

Assembly: mscorlib.dll

See Also

StreamWriter Members | System.IO Namespace | Stream | StreamReader | Encoder | Encoding


StreamWriter Members

Public:

Constructor

StreamWriter Constructor Overloaded. Creates a new instance of the StreamWriter class.

Properties

AutoFlush | Determines whether the encoder obtained from the Encoding object will flush or maintain its internal state after encoding a sequence of characters.
BaseStream | Returns the base stream, which is a stream that interfaces with a backing store.
NewLine (inherited from TextWriter) | Sets or gets the line terminator string used by the current TextWriter.

Methods

Close | Closes the current writer and releases any system resources associated with the writer.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Flush | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write (inherited from TextWriter) | Overloaded. Writes the given data type to a text stream.
WriteLine (inherited from TextWriter) | Overloaded. Writes a line terminator and other characters as specified by the overloaded parameters.

Fields

Null Provides a repository with no backing store that can be written to, but not read from. Use Null to redirect output to a stream that will not consume any operating system resources.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

CoreNewLine (inherited from TextWriter) Gets the next line in the file.

See Also

StreamWriter Class | System.IO Namespace


StreamWriter Constructor

Creates a new instance of the StreamWriter class.

Overload List

Creates a new instance of the StreamWriter class for the specified stream, using the default encoding and buffer size.

[Visual Basic] Overloads Public Sub New(Stream)
[C#] public StreamWriter(Stream);
[C++] public: StreamWriter(Stream*);
[JScript] public function StreamWriter(Stream);

Creates a new instance of the StreamWriter class for the specified stream, using the specified encoding and the default buffer size.

[Visual Basic] Overloads Public Sub New(Stream, Encoding)
[C#] public StreamWriter(Stream, Encoding);
[C++] public: StreamWriter(Stream*, Encoding);
[JScript] public function StreamWriter(Stream, Encoding);

Creates a new instance of the StreamWriter class for the specified stream, using the specified encoding and buffer size.

[Visual Basic] Overloads Public Sub New(Stream, Encoding, Integer)
[C#] public StreamWriter(Stream, Encoding, int);
[C++] public: StreamWriter(Stream*, Encoding, int);
[JScript] public function StreamWriter(Stream, Encoding, int);

Creates a new instance of the StreamWriter class for the specified file on the specified path, using the default encoding and buffer size.

[Visual Basic] Overloads Public Sub New(String)
[C#] public StreamWriter(String);
[C++] public: StreamWriter(String*);
[JScript] public function StreamWriter(String);

Creates a new instance of the StreamWriter class for the specified file on the specified path, using the default encoding and buffer size. Overwrites or appends to an existing file, or creates a new file.

[Visual Basic] Overloads Public Sub New(String, Boolean)
[C#] public StreamWriter(String, bool);
[C++] public: StreamWriter(String*, bool);
[JScript] public function StreamWriter(String, Boolean);

Creates a new instance of the StreamWriter class for the specified file on the specified path, using the specified encoding and default buffer size. Overwrites or appends to an existing file, or creates a new file.

[Visual Basic] Overloads Public Sub New(String, Boolean, Encoding)
[C#] public StreamWriter(String, bool, Encoding);
[C++] public: StreamWriter(String*, bool, Encoding);
[JScript] public function StreamWriter(String, Boolean, Encoding);

Creates a new instance of the StreamWriter class for the specified file on the specified path, using the specified encoding and buffer size. Overwrites or appends to an existing file, or creates a new file.

[Visual Basic] Overloads Public Sub New(String, Boolean, Encoding, Integer)
[C#] public StreamWriter(String, bool, Encoding, int);
[C++] public: StreamWriter(String*, bool, Encoding, int);
[JScript] public function StreamWriter(String, Boolean, Encoding, int);

See Also

StreamWriter Class | StreamWriter Members | System.IO Namespace


StreamWriter Constructor (Stream)

Creates a new instance of the StreamWriter class for the specified stream, using the default encoding and buffer size.

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream _
)
[C#]
public StreamWriter(
   Stream stream
);
[C++]
public: StreamWriter(
   Stream* stream
);
[JScript]
public function StreamWriter(
   stream : Stream
);

Parameters

stream
The stream to write to.

Exceptions

Exception Type | Condition
ArgumentException | stream is empty.
ArgumentNullException | stream is null.

See Also

StreamWriter Class | StreamWriter Members | System.IO Namespace | StreamWriter Constructor Overload List


StreamWriter Constructor (Stream, Encoding)

Creates a new instance of the StreamWriter class for the specified stream, using the specified encoding and the default buffer size.

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream, _
   ByVal encoding As Encoding _
)
[C#]
public StreamWriter(
   Stream stream,
   Encoding encoding
);
[C++]
public: StreamWriter(
   Stream* stream,
   Encoding* encoding
);
[JScript]
public function StreamWriter(
   stream : Stream,
   encoding : Encoding
);

Parameters

stream
The stream to write to.
encoding
Determines which character encoding to use.

Exceptions

Exception Type | Condition
ArgumentNullException | stream or encoding is null.

See Also

StreamWriter Class | StreamWriter Members | System.IO Namespace | StreamWriter Constructor Overload List


StreamWriter Constructor (Stream, Encoding, Int32)

Creates a new instance of the StreamWriter class for the specified stream, using the specified encoding and buffer size.

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream, _
   ByVal encoding As Encoding, _
   ByVal bufferSize As Integer _
)
[C#]
public StreamWriter(
   Stream stream,
   Encoding encoding,
   int bufferSize
);
[C++]
public: StreamWriter(
   Stream* stream,
   Encoding* encoding,
   int bufferSize
);
[JScript]
public function StreamWriter(
   stream : Stream,
   encoding : Encoding,
   bufferSize : int
);

Parameters

stream
The stream to write to.
encoding
Determines which character encoding to use.
bufferSize
Sets the buffer size.

Exceptions

Exception Type | Condition
ArgumentNullException | stream or encoding is a null reference (in Visual Basic Nothing).
ArgumentOutOfRangeException | bufferSize is negative.
ArgumentException | stream does not support writing.

See Also

StreamWriter Class | StreamWriter Members | System.IO Namespace | StreamWriter Constructor Overload List


StreamWriter Constructor (String)

Creates a new instance of the StreamWriter class for the specified file on the specified path, using the default encoding and buffer size.

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As String _
)
[C#]
public StreamWriter(
   string path
);
[C++]
public: StreamWriter(
   String* path
);
[JScript]
public function StreamWriter(
   path : String
);

Parameters

path
The complete file path to write to.

Exceptions

Exception Type | Condition
AccessException | Access is denied.
ArgumentException | path is empty.
ArgumentNullException | path is a null reference (in Visual Basic Nothing).
DirectoryNotFoundException | The directory to write to is not found.
IOException | path includes an incorrect or invalid syntax for file name, directory name, or volume label syntax.
SecurityException | The caller does not have the required permission.

See Also

StreamWriter Class | StreamWriter Members | System.IO Namespace | StreamWriter Constructor Overload List


StreamWriter Constructor (String, Boolean)

Creates a new instance of the StreamWriter class for the specified file on the specified path, using the default encoding and buffer size. Overwrites or appends to an existing file, or creates a new file.

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As String, _
   ByVal append As Boolean _
)
[C#]
public StreamWriter(
   string path,
   bool append
);
[C++]
public: StreamWriter(
   String* path,
   bool append
);
[JScript]
public function StreamWriter(
   path : String,
   append : Boolean
);

Parameters

path
The complete file path to write to.
append
Determines whether data is to be appended to the file. If the file exists and append is false, the file is overwritten. If the file exists and append is true, the data is appended to the file. Otherwise, a new file is created.

Exceptions

Exception Type | Condition
AccessException | Access is denied.
ArgumentException | path is empty.
ArgumentNullException | path is a null reference (in Visual Basic Nothing).
DirectoryNotFoundException | The directory to write to is not found.
IOException | path includes an incorrect or invalid syntax for file name, directory name, or volume label syntax.
SecurityException | The caller does not have the required permission.

See Also

StreamWriter Class | StreamWriter Members | System.IO Namespace | StreamWriter Constructor Overload List


StreamWriter Constructor (String, Boolean, Encoding)

Creates a new instance of the StreamWriter class for the specified file on the specified path, using the specified encoding and default buffer size. Overwrites or appends to an existing file, or creates a new file.

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As String, _
   ByVal append As Boolean, _
   ByVal encoding As Encoding _
)
[C#]
public StreamWriter(
   string path,
   bool append,
   Encoding encoding
);
[C++]
public: StreamWriter(
   String* path,
   bool append,
   Encoding* encoding
);
[JScript]
public function StreamWriter(
   path : String,
   append : Boolean,
   encoding : Encoding
);

Parameters

path
The complete file path to write to.
append
Determines whether data is to be appended to the file. If the file exists and append is false, the file is overwritten. If the file exists and append is true, the data is appended to the file. Otherwise, a new file is created.
encoding
Determines which character encoding to use.

Exceptions

Exception Type | Condition
AccessException | Access is denied.
ArgumentException | path is empty.
ArgumentNullException | path is null.
DirectoryNotFoundException | The directory to write to is not found.
IOException | path includes an incorrect or invalid syntax for file name, directory name, or volume label syntax.
SecurityException | The caller does not have the required permission.

See Also

StreamWriter Class | StreamWriter Members | System.IO Namespace | StreamWriter Constructor Overload List


StreamWriter Constructor (String, Boolean, Encoding, Int32)

Creates a new instance of the StreamWriter class for the specified file on the specified path, using the specified encoding and buffer size. Overwrites or appends to an existing file, or creates a new file.

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As String, _
   ByVal append As Boolean, _
   ByVal encoding As Encoding, _
   ByVal bufferSize As Integer _
)
[C#]
public StreamWriter(
   string path,
   bool append,
   Encoding encoding,
   int bufferSize
);
[C++]
public: StreamWriter(
   String* path,
   bool append,
   Encoding* encoding,
   int bufferSize
);
[JScript]
public function StreamWriter(
   path : String,
   append : Boolean,
   encoding : Encoding,
   bufferSize : int
);

Parameters

path
The complete file path to write to.
append
Determines whether data is to be appended to the file. If the file exists and append is false, the file is overwritten. If the file exists and append is true, the data is appended to the file. Otherwise, a new file is created.
encoding
Determines which character encoding to use.
bufferSize
Sets the buffer size.

Exceptions

Exception Type | Condition
ArgumentException | path is an empty string ("").
ArgumentNullException | path or encoding is null.
ArgumentOutOfRangeException | bufferSize is negative.
FileNotFoundException | The file cannot be found.
IOException | path includes an incorrect or invalid syntax for file name, directory name, or volume label syntax.
SecurityException | The caller does not have the required permission.

See Also

StreamWriter Class | StreamWriter Members | System.IO Namespace | StreamWriter Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StreamWriter Properties

The properties of the StreamWriter class are listed below. For a complete list of StreamWriter class members, see the StreamWriter Members topic.

Public:

AutoFlush | Determines whether the encoder obtained from the Encoding object will flush or maintain its internal state after encoding a sequence of characters.
BaseStream | Returns the base stream, which is a stream that interfaces with a backing store.
NewLine (inherited from TextWriter) | Sets or gets the line terminator string used by the current TextWriter.

See Also

StreamWriter Class | System.IO Namespace


StreamWriter.AutoFlush

Determines whether the encoder obtained from the Encoding object will flush or maintain its internal state after encoding a sequence of characters.

[Visual Basic]
Overridable Public Property AutoFlush As Boolean
[C#]
public bool AutoFlush {virtual get; virtual set;}
[C++]
public: __property virtual bool get_AutoFlush();
public: __property virtual void set_AutoFlush(bool);
[JScript]
public function get AutoFlush() : Boolean;
public function set AutoFlush(Boolean);

Property Value

true if the Encoder resets its internal state after encoding a sequence of characters received from the invocation of a write method.

false if the Encoder maintains its state between successive calls to a write.

Remarks

StreamWriter would maintain its internal state in order to correctly encode character sequences received from successive calls to the Write methods.

This property does not automate the Flush method, which is called by the Write methods when the buffer reaches maximum capacity.

See Also

StreamWriter Class | StreamWriter Members | System.IO Namespace


StreamWriter.BaseStream

Returns the base stream, which is a stream that interfaces with a backing store.

[Visual Basic]
Overridable Public ReadOnly Property BaseStream As Stream
[C#]
public Stream BaseStream {virtual get;}
[C++]
public: __property virtual Stream* get_BaseStream();
[JScript]
public function get BaseStream() : Stream;

Property Value

The base stream.

See Also

StreamWriter Class | StreamWriter Members | System.IO Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StreamWriter Methods

The methods of the StreamWriter class are listed below. For a complete list of StreamWriter class members, see the StreamWriter Members topic.

Public:

Close | Closes the current writer and releases any system resources associated with the writer.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Flush | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write (inherited from TextWriter) | Overloaded. Writes the given data type to a text stream.
WriteLine (inherited from TextWriter) | Overloaded. Writes a line terminator and other characters as specified by the overloaded parameters.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StreamWriter Class | System.IO Namespace


StreamWriter.Close

Closes the current writer and releases any system resources associated with the writer.

[Visual Basic]
Overrides Public Sub Close()
[C#]
public override void Close();
[C++]
public: override void Close();
[JScript]
public override function Close();

Remarks

You must call Close to ensure that all data is correctly written out to the underlying stream. Following a call to Close, any operations on the writer may raise exceptions.

See Also

StreamWriter Class | StreamWriter Members | System.IO Namespace


StreamWriter.Flush

Clears all buffers for the current writer and causes any buffered data to be written to the underlying device.

[Visual Basic]
Overrides Public Sub Flush()
[C#]
public override void Flush();
[C++]
public: override void Flush();
[JScript]
public override function Flush();

Exceptions

Exception Type | Condition
IOException | The current writer is closed.

See Also

StreamWriter Class | StreamWriter Members | System.IO Namespace | Close


StreamWriter.Write

Writes data to the text stream.

Overload List

Writes a character to the text stream.

[Visual Basic] Overloads Overrides Public Sub Write(Char)
[C#] public override void Write(char);
[C++] public: override void Write(__wchar_t);
[JScript] public override function Write(Char);

Writes a subarray of characters to the text stream.

[Visual Basic] Overloads Overrides Public Sub Write(Char(), Integer, Integer)
[C#] public override void Write(char[], int, int);
[C++] public: override void Write(__wchar_t*[], int, int);
[JScript] public override function Write(Char[], int, int);

Writes a string of characters to the text stream.

[Visual Basic] Overloads Overrides Public Sub Write(String)
[C#] public override void Write(String);
[C++] public: override void Write(String*);
[JScript] public override function Write(String);

See Also

StreamWriter Class | StreamWriter Members | System.IO Namespace


StreamWriter.Write (Char)

Writes a character to the text stream.

[Visual Basic]
Overloads Overrides Public Sub Write( _
   ByVal value As Char _
)
[C#]
public override void Write(
   char value
);
[C++]
public: override void Write(
   __wchar_t value
);
[JScript]
public override function Write(
   value : Char
);

Parameters

value
The character to write to the text stream.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.

See Also

StreamWriter Class | StreamWriter Members | System.IO Namespace | StreamWriter.Write Overload List


StreamWriter.Write (Char[], Int32, Int32)

Writes a subarray of characters to the text stream.

[Visual Basic]
Overloads Overrides Public Sub Write( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
[C#]
public override void Write(
   char[] buffer,
   int index,
   int count
);
[C++]
public: override void Write(
   __wchar_t* buffer[],
   int index,
   int count
);
[JScript]
public override function Write(
   buffer : Char[],
   index : int,
   count : int
);

Parameters

buffer
The character array from which data is read.
index
The index into buffer at which to begin reading.
count
The number of characters to read from buffer.

Exceptions

Exception Type | Condition
ArgumentNullException | buffer is a null reference (in Visual Basic Nothing).
ArgumentException | The buffer length minus index is less than count.
ArgumentOutOfRangeException | index or count is negative.
IOException | An I/O error occurs.

Remarks

StreamReader.Read (char[], int,

int) and StreamWriter.Write (char[], int, int) read and write the number of characters specified by the count parameter, while Stream.Read and Stream.Write read and write the number of bytes specified by the count parameter. Use the Stream methods only for reading and writing an integral number of byte arrays.

The characters are read from buffer beginning at index and ending at index + count. All characters are written to the underlying stream unless the end of the underlying stream is reached prematurely. Flush is invoked automatically if AutoFlush is true.

See Also

StreamWriter Class | StreamWriter Members | System.IO Namespace | StreamWriter.Write Overload List


StreamWriter.Write (String)

Writes a string of characters to the text stream.

[Visual Basic]
Overloads Overrides Public Sub Write( _
   ByVal value As String _
)
[C#]
public override void Write(
   string value
);
[C++]
public: override void Write(
   String* value
);
[JScript]
public override function Write(
   value : String
);

Parameters

value
A string of characters.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.

Remarks

The characters are read from value. All characters are written to the underlying stream unless the end of the underlying stream is reached prematurely. Flush is invoked automatically if AutoFlush is true. If value is a null reference (in Visual Basic Nothing), no operation is performed.

See Also

StreamWriter Class | StreamWriter Members | System.IO Namespace | StreamWriter.Write Overload List


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StreamWriter Fields

The fields of the StreamWriter class are listed below. For a complete list of StreamWriter class members, see the StreamWriter Members topic.

Public:

Null Provides a repository with no backing store that can be written to, but not read from. Use Null to redirect output to a stream that will not consume any operating system resources.

Protected:

CoreNewLine (inherited from TextWriter) Gets the next line in the file.

See Also

StreamWriter Class | System.IO Namespace


StreamWriter.Null

Provides a repository with no backing store that can be written to, but not read from. Use Null to redirect output to a stream that will not consume any operating system resources.

[Visual Basic]
Public Shared ReadOnly Null As StreamWriter
[C#]
public static readonly StreamWriter Null;
[C++]
public: static readonly StreamWriter* Null;
[JScript]
public static var Null : StreamWriter;

Remarks

When the StreamWriter Write methods are invoked on Null, the call simply returns, and no data is actually written to an underlying data source or repository.

See Also

StreamWriter Class | StreamWriter Members | System.IO Namespace


StringReader Class

Implements a TextReader that reads from a string.

Object
TextReader
StringReader

[Visual Basic]
Public Class StringReader
   Inherits TextReader
[C#]
public class StringReader : TextReader
[C++]
public __gc class StringReader : public TextReader
[JScript]
public class StringReader extends TextReader

Remarks

[To be supplied.]

Requirements

Namespace: System.IO

Assembly: mscorlib.dll

See Also

StringReader Members | System.IO Namespace | TextReader | StringWriter


StringReader Members

Public:

Constructor

StringReader Constructor Overloaded. Creates a new instance of the StringReader class.

Methods

Close | Closes the StringReader.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Peek | Returns the next available character without actually reading it from the underlying string.
Read | Overloaded. Reads data from an underlying string.
ReadBlock (inherited from TextReader) | Reads a maximum of count characters from the current stream and writes the data to buffer, beginning at index.
ReadLine | Reads a line.
ReadToEnd | Reads the stream as a string, either in its entirety or from the current position to the end of the stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Constructor

StringReader Constructor Overloaded. Creates a new instance of the StringReader class.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StringReader Class | System.IO Namespace


StringReader Constructor

Creates a new instance of the StringReader class.

Overload List

Creates a new instance of the StringReader class.

[Visual Basic] Overloads Protected Sub New()
[C#] protected StringReader();
[C++] protected: StringReader();
[JScript] protected function StringReader();

Creates a new instance of the StringReader class for the specified string.

[Visual Basic] Overloads Public Sub New(String)
[C#] public StringReader(String);
[C++] public: StringReader(String*);
[JScript] public function StringReader(String);

See Also

StringReader Class | StringReader Members | System.IO Namespace


StringReader Constructor ()

Creates a new instance of the StringReader class.

[Visual Basic]
Overloads Protected Sub New()
[C#]
protected StringReader();
[C++]
protected: StringReader();
[JScript]
protected function StringReader();

See Also

StringReader Class | StringReader Members | System.IO Namespace | StringReader Constructor Overload List


StringReader Constructor (String)

Creates a new instance of the StringReader class for the specified string.

[Visual Basic]
Overloads Public Sub New( _
   ByVal s As String _
)
[C#]
public StringReader(
   string s
);
[C++]
public: StringReader(
   String* s
);
[JScript]
public function StringReader(
   s : String
);

Parameters

s
The string to read.

See Also

StringReader Class | StringReader Members | System.IO Namespace | StringReader Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StringReader Methods

The methods of the StringReader class are listed below. For a complete list of StringReader class members, see the StringReader Members topic.

Public:

Close | Closes the StringReader.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Peek | Returns the next available character without actually reading it from the underlying string.
Read | Overloaded. Reads data from an underlying string.
ReadBlock (inherited from TextReader) | Reads a maximum of count characters from the current stream and writes the data to buffer, beginning at index.
ReadLine | Reads a line.
ReadToEnd | Reads the stream as a string, either in its entirety or from the current position to the end of the stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StringReader Class | System.IO Namespace


StringReader.Close

Closes the StringReader.

[Visual Basic]
Overrides Public Sub Close()
[C#]
public override void Close();
[C++]
public: override void Close();
[JScript]
public override function Close();

Remarks

Following a call to the current method, the StringReader will appear to contain no characters.

See Also

StringReader Class | StringReader Members | System.IO Namespace


StringReader.Peek

Returns the next available character without actually reading it from the underlying string.

[Visual Basic]
Overrides Public Function Peek() As Integer
[C#]
public override int Peek();
[C++]
public: override int Peek();
[JScript]
public override function Peek() : int;

Return Value

The next character to be read, or-1 if no more characters are available.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.

Remarks

The current position of the StringReader is not changed by this operation.

See Also

StringReader Class | StringReader Members | System.IO Namespace


StringReader.Read

Reads data from an underlying string.

Overload List

Reads a block of characters.

[Visual Basic] Overloads Overrides Public Function Read(Char(), Integer, Integer) As Integer
[C#] public override int Read(char[], int, int);
[C++] public: override int Read(__wchar_t*[], int, int);
[JScript] public override function Read(Char[], int, int) : int;

Reads the next character from the underlying string.

[Visual Basic] Overloads Overrides Public Function Read() As Integer
[C#] public override int Read();
[C++] public: override int Read();
[JScript] public override function Read() : int;

See Also

StringReader Class | StringReader Members | System.IO Namespace


StringReader.Read (Char[], Int32, Int32)

Reads a block of characters.

[Visual Basic]
Overloads Overrides Public Function Read( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
[C#]
public override int Read(
   char[] buffer,
   int index,
   int count
);
[C++]
public: override int Read(
   __wchar_t* buffer[],
   int index,
   int count
);
[JScript]
public override function Read(
   buffer : Char[],
   index : int,
   count : int
) : int;

Parameters

buffer
The character array to read data into.
index
The starting index in the buffer.
count
The number of characters to read.

Return Value

The total number of characters read into the buffer. This may be less than the number of characters requested if that many characters are not currently available, or zero if the end of the underlying string is reached.

Exceptions

Exception Type | Condition
ArgumentNullException | buffer is a null reference (in Visual Basic Nothing).
ArgumentException | The buffer length minus index is less than count.
ArgumentOutOfRangeException | index or count is negative.
IOException | An I/O error occurs.

Remarks

The method will read up to count characters from the StringReader into the buffer character array starting at position index. Returns the actual number of characters read, or zero if the end of the string is reached.

See Also

StringReader Class | StringReader Members | System.IO Namespace | StringReader.Read Overload List


StringReader.Read ()

Reads the next character from the underlying string.

[Visual Basic]
Overloads Overrides Public Function Read() As Integer
[C#]
public override int Read();
[C++]
public: override int Read();
[JScript]
public override function Read() : int;

Return Value

The next character from the underlying string, or-1 if no more characters are available.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.

See Also

StringReader Class | StringReader Members | System.IO Namespace | StringReader.Read Overload List


StringReader.ReadLine

Reads a line.

[Visual Basic]
Overrides Public Function ReadLine() As String
[C#]
public override string ReadLine();
[C++]
public: override String* ReadLine();
[JScript]
public override function ReadLine() : String;

Return Value

The next line from the underlying string, or a null reference (in Visual Basic Nothing) if the end of the underlying string is reached.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.

Remarks

A line is defined as a sequence of characters followed by a carriage return ("\r"), a line feed ("\n"), or a carriage return immediately followed by a line feed. The resulting string does not contain the terminating carriage return and/or line feed. The returned value is a null reference (Nothing) if the end of the underlying string has been reached.

See Also

StringReader Class | StringReader Members | System.IO Namespace


StringReader.ReadToEnd

Reads the stream as a string, either in its entirety or from the current position to the end of the stream.

[Visual Basic]
Overrides Public Function ReadToEnd() As String
[C#]
public override string ReadToEnd();
[C++]
public: override String* ReadToEnd();
[JScript]
public override function ReadToEnd() : String;

Return Value

The stream as a string, from the current position to the end of the stream.

See Also

StringReader Class | StringReader Members | System.IO Namespace


StringWriter Class

Writes characters to a string.

Object
TextWriter
StringWriter

[Visual Basic]
Public Class StringWriter
   Inherits TextWriter
[C#]
public class StringWriter : TextWriter
[C++]
public __gc class StringWriter : public TextWriter
[JScript]
public class StringWriter extends TextWriter

Remarks

[To be supplied.]

Requirements

Namespace: System.IO

Assembly: mscorlib.dll

See Also

StringWriter Members | System.IO Namespace | StringBuilder | StringReader


StringWriter Members

Public:

Constructor

StringWriter Constructor Overloaded. Creates a new instance of the StringWriter class.

Properties

NewLine (inherited from TextWriter) Sets or gets the line terminator string used by the current TextWriter.

Methods

Close (inherited from TextWriter) | Closes the current writer and releases any system resources associated with the writer.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Flush (inherited from TextWriter) | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetStringBuilder | Returns the underlying StringBuilder.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Returns a string containing the characters written to the current StringWriter so far.
Write (inherited from TextWriter) | Overloaded. Writes the given data type to a text stream.
WriteLine (inherited from TextWriter) | Overloaded. Writes a line terminator and other characters as specified by the overloaded parameters.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

CoreNewLine (inherited from TextWriter) Gets the next line in the file.

See Also

StringWriter Class | System.IO Namespace


StringWriter Constructor

Creates a new instance of the StringWriter class.

Overload List

Creates a new instance of the StringWriter class.

[Visual Basic] Overloads Public Sub New()
[C#] public StringWriter();
[C++] public: StringWriter();
[JScript] public function StringWriter();

Creates a new instance of the StringWriter class that writes to the specified StringBuilder.

[Visual Basic] Overloads Public Sub New(StringBuilder)
[C#] public StringWriter(StringBuilder);
[C++] public: StringWriter(StringBuilder*);
[JScript] public function StringWriter(StringBuilder);

See Also

StringWriter Class | StringWriter Members | System.IO Namespace


StringWriter Constructor ()

Creates a new instance of the StringWriter class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public StringWriter();
[C++]
public: StringWriter();
[JScript]
public function StringWriter();

Remarks

A new StringBuilder is automatically created and associated with the new StringWriter.

See Also

StringWriter Class | StringWriter Members | System.IO Namespace | StringWriter Constructor Overload List


StringWriter Constructor (StringBuilder)

Creates a new instance of the StringWriter class that writes to the specified StringBuilder.

[Visual Basic]
Overloads Public Sub New( _
   ByVal sb As StringBuilder _
)
[C#]
public StringWriter(
   StringBuilder sb
);
[C++]
public: StringWriter(
   StringBuilder* sb
);
[JScript]
public function StringWriter(
   sb : StringBuilder
);

Parameters

sb
The StringBuilder to write to.

Exceptions

Exception Type | Condition
ArgumentNullException | sb is a null reference (in Visual Basic Nothing).

See Also

StringWriter Class | StringWriter Members | System.IO Namespace | StringWriter Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StringWriter Methods

The methods of the StringWriter class are listed below. For a complete list of StringWriter class members, see the StringWriter Members topic.

Public:

Close (inherited from TextWriter) | Closes the current writer and releases any system resources associated with the writer.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Flush (inherited from TextWriter) | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetStringBuilder | Returns the underlying StringBuilder.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Returns a string containing the characters written to the current StringWriter so far.
Write (inherited from TextWriter) | Overloaded. Writes the given data type to a text stream.
WriteLine (inherited from TextWriter) | Overloaded. Writes a line terminator and other characters as specified by the overloaded parameters.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StringWriter Class | System.IO Namespace


StringWriter.GetStringBuilder

Returns the underlying StringBuilder.

[Visual Basic]
Overridable Public Function GetStringBuilder() As StringBuilder
[C#]
public virtual StringBuilder GetStringBuilder();
[C++]
public: virtual StringBuilder* GetStringBuilder();
[JScript]
public function GetStringBuilder() : StringBuilder;

Return Value

The underlying StringBuilder.

Remarks

This is either the StringBuilder that was passed to the constructor, or the StringBuilder that was automatically created.

See Also

StringWriter Class | StringWriter Members | System.IO Namespace


StringWriter.ToString

Returns a string containing the characters written to the current StringWriter so far.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

The string containing the characters written to the current StringWriter.

See Also

StringWriter Class | StringWriter Members | System.IO Namespace


StringWriter.Write

Writes to the underlying StringBuilder.

Overload List

Writes a string to the underlying StringBuilder.

[Visual Basic] Overloads Overrides Public Sub Write(String)
[C#] public override void Write(String);
[C++] public: override void Write(String*);
[JScript] public override function Write(String);

Writes a character to the underlying StringBuilder.

[Visual Basic] Overloads Overrides Public Sub Write(Char)
[C#] public override void Write(char);
[C++] public: override void Write(__wchar_t);
[JScript] public override function Write(Char);

Writes the specified region of buffer to the underlying StringBuilder.

This method will write count characters of data to this StringWriter from buffer, starting at position index.

[Visual Basic] Overloads Overrides Public Sub Write(Char(), Integer, Integer)
[C#] public override void Write(char[], int, int);
[C++] public: override void Write(__wchar_t*[], int, int);
[JScript] public override function Write(Char[], int, int);

See Also

StringWriter Class | StringWriter Members | System.IO Namespace


StringWriter.Write (String)

Writes a string to the underlying StringBuilder.

[Visual Basic]
Overloads Overrides Public Sub Write( _
   ByVal value As String _
)
[C#]
public override void Write(
   string value
);
[C++]
public: override void Write(
   String* value
);
[JScript]
public override function Write(
   value : String
);

Parameters

value
The string to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.

Remarks

If the specified string is null, nothing is written.

See Also

StringWriter Class | StringWriter Members | System.IO Namespace | StringWriter.Write Overload List


StringWriter.Write (Char)

Writes a character to the underlying StringBuilder.

[Visual Basic]
Overloads Overrides Public Sub Write( _
   ByVal value As Char _
)
[C#]
public override void Write(
   char value
);
[C++]
public: override void Write(
   __wchar_t value
);
[JScript]
public override function Write(
   value : Char
);

Parameters

value
The character to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.

See Also

StringWriter Class | StringWriter Members | System.IO Namespace | StringWriter.Write Overload List


StringWriter.Write (Char[], Int32, Int32)

Writes the specified region of buffer to the underlying StringBuilder.

This method will write count characters of data to this StringWriter from buffer, starting at position index.

[Visual Basic]
Overloads Overrides Public Sub Write( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
[C#]
public override void Write(
   char[] buffer,
   int index,
   int count
);
[C++]
public: override void Write(
   __wchar_t* buffer[],
   int index,
   int count
);
[JScript]
public override function Write(
   buffer : Char[],
   index : int,
   count : int
);

Parameters

buffer
The character array to read data from.
index
The index at which to begin reading from buffer.
count
The maximum number of characters to write.

Exceptions

Exception Type | Condition
ArgumentNullException | buffer is a null reference (in Visual Basic Nothing).
ArgumentOutOfRangeException | index or count is negative.
ArgumentException | index and count describe an invalid range in buffer.
IOException | An I/O error occurs.

See Also

StringWriter Class | StringWriter Members | System.IO Namespace | StringWriter.Write Overload List


TextReader Class

Represents a reader that can read a sequential stream of characters. This class is abstract.

Object
TextReader

[Visual Basic]
MustInherit Public Class TextReader
[C#]
public abstract class TextReader
[C++]
public __gc __abstract class TextReader
[JScript]
public abstract class TextReader

Remarks

A subclass must minimally implement the Peek and Read methods.

Requirements

Namespace: System.IO

Assembly: mscorlib.dll

See Also

TextReader Members | System.IO Namespace


TextReader Members

Public:

Methods

Close | Closes the current instance of TextReader and releases any system resources associated with the TextReader.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Peek | Returns the next available character without actually reading it from the input stream.
Read | Overloaded. Reads data from an input stream.
ReadBlock | Reads a maximum of count characters from the current stream and writes the data to buffer, beginning at index.
ReadLine | Reads a line of characters from the current stream and returns the data as a string.
ReadToEnd | Reads all characters from the current position to the end of the TextReader, and returns them as one string.
Synchronized | Creates a synchronized wrapper around the specified TextReader.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Null Provides a TextReader with no data to read from.

Protected:

Constructor

TextReader Constructor Creates a new instance of the TextReader class, from which a new instance cannot be created. This constructor is for subclassing.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TextReader Class | System.IO Namespace


TextReader Constructor

Creates a new instance of the TextReader class, from which a new instance cannot be created. This constructor is for subclassing.

[Visual Basic]
Protected Sub New()
[C#]
protected TextReader();
[C++]
protected: TextReader();
[JScript]
protected function TextReader();

See Also

TextReader Class | TextReader Members | System.IO Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TextReader Methods

The methods of the TextReader class are listed below. For a complete list of TextReader class members, see the TextReader Members topic.

Public:

Close | Closes the current instance of TextReader and releases any system resources associated with the TextReader.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Peek | Returns the next available character without actually reading it from the input stream.
Read | Overloaded. Reads data from an input stream.
ReadBlock | Reads a maximum of count characters from the current stream and writes the data to buffer, beginning at index.
ReadLine | Reads a line of characters from the current stream and returns the data as a string.
ReadToEnd | Reads all characters from the current position to the end of the TextReader, and returns them as one string.
Synchronized | Creates a synchronized wrapper around the specified TextReader.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TextReader Class | System.IO Namespace


TextReader.Close

Closes the current instance of TextReader and releases any system resources associated with the TextReader.

[Visual Basic]
Overridable Public Sub Close()
[C#]
public virtual void Close();
[C++]
public: virtual void Close();
[JScript]
public function Close();

Remarks

Following a call to Close, any operations on the TextReader may raise exceptions. This default method is empty, but derived classes can override the method to provide the appropriate functionality.

See Also

TextReader Class | TextReader Members | System.IO Namespace


TextReader.Peek

Returns the next available character without actually reading it from the input stream.

[Visual Basic]
Overridable Public Function Peek() As Integer
[C#]
public virtual int Peek();
[C++]
public: virtual int Peek();
[JScript]
public function Peek() : int;

Return Value

The next character to be read, or-1 if no more characters are available.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.

Remarks

The current position of the TextReader is not changed by this operation. The returned value is-1 if no more characters are available. This default method simply returns-1.

See Also

TextReader Class | TextReader Members | System.IO Namespace


TextReader.Read

Reads data from an input stream.

Overload List

Reads a maximum of count characters from the current stream and writes the data to buffer, beginning at index.

[Visual Basic] Overloads Overridable Public Function Read(Char(), Integer, Integer) As Integer
[C#] public virtual int Read(char[], int, int);
[C++] public: virtual int Read(__wchar_t*[], int, int);
[JScript] public function Read(Char[], int, int) : int;

Reads the next character from the input stream.

The returned value is-1 if no more characters are available. This default method simply returns-1.

[Visual Basic] Overloads Overridable Public Function Read() As Integer
[C#] public virtual int Read();
[C++] public: virtual int Read();
[JScript] public function Read() : int;

See Also

TextReader Class | TextReader Members | System.IO Namespace


TextReader.Read (Char[], Int32, Int32)

Reads a maximum of count characters from the current stream and writes the data to buffer, beginning at index.

[Visual Basic]
Overloads Overridable Public Function Read( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
[C#]
public virtual int Read(
   char[] buffer,
   int index,
   int count
);
[C++]
public: virtual int Read(
   __wchar_t* buffer[],
   int index,
   int count
);
[JScript]
public function Read(
   buffer : Char[],
   index : int,
   count : int
) : int;

Parameters

buffer
The character array to write data to.
index
The place in buffer at which to begin writing.
count
The maximum number of characters to read.

Return Value

The number of characters that have been read. The number will be less than or equal to count, depending on whether the data is available within the stream.

Exceptions

Exception Type | Condition
ArgumentNullException | buffer is a null reference (in Visual Basic Nothing).
ArgumentException | The buffer length minus index is less than count.
ArgumentOutOfRangeException | index or count is negative.
IOException | An I/O error occurs.

Remarks

This method returns after either count characters are read or the end of the file is reached. ReadBlock is a blocking version of this method.

See Also

TextReader Class | TextReader Members | System.IO Namespace | TextReader.Read Overload List


TextReader.Read ()

Reads the next character from the input stream.

The returned value is-1 if no more characters are available. This default method simply returns-1.

[Visual Basic]
Overloads Overridable Public Function Read() As Integer
[C#]
public virtual int Read();
[C++]
public: virtual int Read();
[JScript]
public function Read() : int;

Return Value

The next character from the input stream, or-1 if no more characters are available.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.

See Also

TextReader Class | TextReader Members | System.IO Namespace | TextReader.Read Overload List


TextReader.ReadBlock

Reads a maximum of count characters from the current stream and writes the data to buffer, beginning at index.

[Visual Basic]
Overridable Public Function ReadBlock( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
[C#]
public virtual int ReadBlock(
   char[] buffer,
   int index,
   int count
);
[C++]
public: virtual int ReadBlock(
   __wchar_t* buffer[],
   int index,
   int count
);
[JScript]
public function ReadBlock(
   buffer : Char[],
   index : int,
   count : int
) : int;

Parameters

buffer
The character array to write data to.
index
The place in buffer at which to begin writing.
count
The maximum number of characters to read.

Return Value

The number of characters that have been read. The number will be less than or equal to count, depending on whether the EOF character is encountered.

Exceptions

Exception Type | Condition
ArgumentNullException | buffer is a null reference (in Visual Basic Nothing).
ArgumentException | The buffer length minus index is less than count.
ArgumentOutOfRangeException | index or count is negative.
IOException | An I/O error occurs.

Remarks

The method blocks until either count characters are read, or the end of the file is reached. This is a blocking version of Read.

See Also

TextReader Class | TextReader Members | System.IO Namespace


TextReader.ReadLine

Reads a line of characters from the current stream and returns the data as a string.

[Visual Basic]
Overridable Public Function ReadLine() As String
[C#]
public virtual string ReadLine();
[C++]
public: virtual String* ReadLine();
[JScript]
public function ReadLine() : String;

Return Value

The next line from the input stream, or null if the end of the input stream has been reached.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.

Remarks

A line is defined as a sequence of characters followed by a carriage return (\r), a line feed (\n), or a carriage return immediately followed by a line feed (\r\n). The string that is returned does not contain the terminating carriage return and/or line feed. The returned value is null if the end of the input stream has been reached.

See Also

TextReader Class | TextReader Members | System.IO Namespace


TextReader.ReadToEnd

Reads all characters from the current position to the end of the TextReader, and returns them as one string.

[Visual Basic]
Overridable Public Function ReadToEnd() As String
[C#]
public virtual string ReadToEnd();
[C++]
public: virtual String* ReadToEnd();
[JScript]
public function ReadToEnd() : String;

Return Value

A string containing all characters from the current position to the end of the TextReader.

See Also

TextReader Class | TextReader Members | System.IO Namespace


TextReader.Synchronized

Creates a synchronized wrapper around the specified TextReader.

[Visual Basic]
Public Shared Function Synchronized( _
   ByVal t As TextReader _
) As TextReader
[C#]
public static TextReader Synchronized(
   TextReader t
);
[C++]
public: static TextReader* Synchronized(
   TextReader* t
);
[JScript]
public static function Synchronized(
   t : TextReader
) : TextReader;

Parameters

t
The TextReader to synchronize.

Return Value

A synchronized TextReader.

Exceptions

Exception Type | Condition
ArgumentNullException | t is a null reference (in Visual Basic Nothing).

See Also

TextReader Class | TextReader Members | System.IO Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TextReader Fields

The fields of the TextReader class are listed below. For a complete list of TextReader class members, see the TextReader Members topic.

Public:

Null Provides a TextReader with no data to read from.

See Also

TextReader Class | System.IO Namespace


TextReader.Null

Provides a TextReader with no data to read from.

[Visual Basic]
Public Shared ReadOnly Null As TextReader
[C#]
public static readonly TextReader Null;
[C++]
public: static readonly TextReader* Null;
[JScript]
public static var Null : TextReader;

See Also

TextReader Class | TextReader Members | System.IO Namespace


TextWriter Class

Represents a writer that can write a sequential stream of characters. This class is abstract.

Object
TextWriter

[Visual Basic]
MustInherit Public Class TextWriter
[C#]
public abstract class TextWriter
[C++]
public __gc __abstract class TextWriter
[JScript]
public abstract class TextWriter

Remarks

A subclass must minimally implement the Write(Char) method.

This class is intended for character output, not bytes. See StreamWriter for writing bytes.

Requirements

Namespace: System.IO

Assembly: mscorlib.dll

See Also

TextWriter Members | System.IO Namespace


TextWriter Members

Public:

Properties

NewLine Sets or gets the line terminator string used by the current TextWriter.

Methods

Close | Closes the current writer and releases any system resources associated with the writer.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Flush | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Synchronized | Creates a synchronized wrapper around the specified TextWriter.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Overloaded. Writes the given data type to a text stream.
WriteLine | Overloaded. Writes a line terminator and other characters as specified by the overloaded parameters.

Fields

Null Provides a repository with no backing store that can be written to, but not read from. Use Null to redirect output to a stream that will not consume any operating system resources.

Protected:

Constructor

TextWriter Constructor Creates a new instance of the TextWriter class. This constructor is for subclassing.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

CoreNewLine Gets the next line in the file.

See Also

TextWriter Class | System.IO Namespace


TextWriter Constructor

Creates a new instance of the TextWriter class. This constructor is for subclassing.

[Visual Basic]
Protected Sub New()
[C#]
protected TextWriter();
[C++]
protected: TextWriter();
[JScript]
protected function TextWriter();

See Also

TextWriter Class | TextWriter Members | System.IO Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TextWriter Properties

The properties of the TextWriter class are listed below. For a complete list of TextWriter class members, see the TextWriter Members topic.

Public:

NewLine Sets or gets the line terminator string used by the current TextWriter.

See Also

TextWriter Class | System.IO Namespace


TextWriter.NewLine

Sets or gets the line terminator string used by the current TextWriter.

[Visual Basic]
Overridable Public Property NewLine As String
[C#]
public string NewLine {virtual get; virtual set;}
[C++]
public: __property virtual String* get_NewLine();
public: __property virtual void set_NewLine(String*);
[JScript]
public function get NewLine() : String;
public function set NewLine(String);

Property Value

The line terminator string for the current TextWriter.

Remarks

The default line terminator string is a carriage return followed by a line feed ("\r\n").

The line terminator string is written to the text stream whenever one of the WriteLine methods is called. In order for text written by the Writer to be readable by a Reader, only one of the following line terminator strings should be used: "\r", "\n", or "\r\n".

See Also

TextWriter Class | TextWriter Members | System.IO Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TextWriter Methods

The methods of the TextWriter class are listed below. For a complete list of TextWriter class members, see the TextWriter Members topic.

Public:

Close | Closes the current writer and releases any system resources associated with the writer.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Flush | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Synchronized | Creates a synchronized wrapper around the specified TextWriter.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Overloaded. Writes the given data type to a text stream.
WriteLine | Overloaded. Writes a line terminator and other characters as specified by the overloaded parameters.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TextWriter Class | System.IO Namespace


TextWriter.Close

Closes the current writer and releases any system resources associated with the writer.

[Visual Basic]
Overridable Public Sub Close()
[C#]
public virtual void Close();
[C++]
public: virtual void Close();
[JScript]
public function Close();

Remarks

Following a call to Close, any operations on the writer may raise exceptions. This default method is empty, but derived classes can override the method to provide the appropriate functionality.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace


TextWriter.Flush

Clears all buffers for the current writer and causes any buffered data to be written to the underlying device.

[Visual Basic]
Overridable Public Sub Flush()
[C#]
public virtual void Flush();
[C++]
public: virtual void Flush();
[JScript]
public function Flush();

Remarks

This default method is empty, but derived classes can override the method to provide the appropriate functionality.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace


TextWriter.Synchronized

Creates a synchronized wrapper around the specified TextWriter.

[Visual Basic]
Public Shared Function Synchronized( _
   ByVal t As TextWriter _
) As TextWriter
[C#]
public static TextWriter Synchronized(
   TextWriter t
);
[C++]
public: static TextWriter* Synchronized(
   TextWriter* t
);
[JScript]
public static function Synchronized(
   t : TextWriter
) : TextWriter;

Parameters

t
The TextWriter to synchronize.

Return Value

A synchronized TextWriter.

Exceptions

Exception Type | Condition
ArgumentNullException | t is null.

Remarks

[To be supplied.]

See Also

TextWriter Class | TextWriter Members | System.IO Namespace


TextWriter.Write

Writes the given data type to a text stream.

Overload List

Writes the text representation of an unsigned long to the text stream.

[Visual Basic] Overloads Overridable Public Sub Write(UInt64)
[C#] public virtual void Write(ulong);
[C++] public: virtual void Write(unsigned __int64);
[JScript] public function Write(UInt64);

Writes the text representation of an 8-byte integer to the text stream.

[Visual Basic] Overloads Overridable Public Sub Write(Long)
[C#] public virtual void Write(long);
[C++] public: virtual void Write(__int64);
[JScript] public function Write(long);

Writes the text representation of a Single to the text stream.

[Visual Basic] Overloads Overridable Public Sub Write(Single)
[C#] public virtual void Write(float);
[C++] public: virtual void Write(float);
[JScript] public function Write(float);

Writes a string to the text stream.

[Visual Basic] Overloads Overridable Public Sub Write(String)
[C#] public virtual void Write(String);
[C++] public: virtual void Write(String*);
[JScript] public function Write(String);

Writes the text representation of a Double to the text stream.

[Visual Basic] Overloads Overridable Public Sub Write(Double)
[C#] public virtual void Write(double);
[C++] public: virtual void Write(double);
[JScript] public function Write(double);

Writes the text representation of an integer to the text stream.

[Visual Basic] Overloads Overridable Public Sub Write(UInt32)
[C#] public virtual void Write(uint);
[C++] public: virtual void Write(unsigned int);
[JScript] public function Write(UInt32);

Writes a character array to the text stream.

[Visual Basic] Overloads Overridable Public Sub Write(Char())
[C#] public virtual void Write(char[]);
[C++] public: virtual void Write(__wchar_t*[]);
[JScript] public function Write(Char[]);

Writes a character to the text stream.

[Visual Basic] Overloads Overridable Public Sub Write(Char)
[C#] public virtual void Write(char);
[C++] public: virtual void Write(__wchar_t);
[JScript] public function Write(Char);

Writes a subarray of characters to the text stream.

[Visual Basic] Overloads Overridable Public Sub Write(Char(), Integer, Integer)
[C#] public virtual void Write(char[], int, int);
[C++] public: virtual void Write(__wchar_t*[], int, int);
[JScript] public function Write(Char[], int, int);

Writes the text representation of an integer to the text stream.

[Visual Basic] Overloads Overridable Public Sub Write(Integer)
[C#] public virtual void Write(int);
[C++] public: virtual void Write(int);
[JScript] public function Write(int);

Writes the text representation of a Boolean value to the text stream.

[Visual Basic] Overloads Overridable Public Sub Write(Boolean)
[C#] public virtual void Write(bool);
[C++] public: virtual void Write(bool);
[JScript] public function Write(Boolean);

Writes out a formatted string, using the same semantics as Format.

[Visual Basic] Overloads Overridable Public Sub Write(String, Object, Object, Object)
[C#] public virtual void Write(String, Object, Object, Object);
[C++] public: virtual void Write(String*, Object, Object, Object);
[JScript] public function Write(String, Object, Object, Object);

Writes out a formatted string, using the same semantics as Format.

[Visual Basic] Overloads Overridable Public Sub Write(String, Object())
[C#] public virtual void Write(String, Object[]);
[C++] public: virtual void Write(String*, Object[]);
[JScript] public function Write(String, Object[]);

Writes out a formatted string, using the same semantics as Format.

[Visual Basic] Overloads Overridable Public Sub Write(String, Object, Object)
[C#] public virtual void Write(String, Object, Object);
[C++] public: virtual void Write(String*, Object, Object);
[JScript] public function Write(String, Object, Object);

Writes the text representation of an object to the text stream.

[Visual Basic] Overloads Overridable Public Sub Write(Object)
[C#] public virtual void Write(Object);
[C++] public: virtual void Write(Object*);
[JScript] public function Write(Object);

Writes out a formatted string, using the same semantics as Format.

[Visual Basic] Overloads Overridable Public Sub Write(String, Object)
[C#] public virtual void Write(String, Object);
[C++] public: virtual void Write(String*, Object);
[JScript] public function Write(String, Object);

See Also

TextWriter Class | TextWriter Members | System.IO Namespace


TextWriter.Write (UInt64)

Writes the text representation of an unsigned long to the text stream.

[Visual Basic]
Overloads Overridable Public Sub Write( _
   ByVal value As UInt64 _
)
[C#]
public virtual void Write(
   ulong value
);
[C++]
public: virtual void Write(
   unsigned __int64 value
);
[JScript]
public function Write(
   value : UInt64
);

Parameters

value
The unsigned long to write.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (in Visual Basic Nothing) string or object is passed.
IOException | An I/O error occurs.

Remarks

The text representation of the specified value is produced by calling ToString.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.Write Overload List


TextWriter.Write (Int64)

Writes the text representation of an 8-byte integer to the text stream.

[Visual Basic]
Overloads Overridable Public Sub Write( _
   ByVal value As Long _
)
[C#]
public virtual void Write(
   long value
);
[C++]
public: virtual void Write(
   __int64 value
);
[JScript]
public function Write(
   value : long
);

Parameters

value
The 8-byte integer to write.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (in Visual Basic Nothing) string or object is passed.
IOException | An I/O error occurs.

Remarks

The text representation of the specified value is produced by calling ToString.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.Write Overload List


TextWriter.Write (Single)

Writes the text representation of a Single to the text stream.

[Visual Basic]
Overloads Overridable Public Sub Write( _
   ByVal value As Single _
)
[C#]
public virtual void Write(
   float value
);
[C++]
public: virtual void Write(
   float value
);
[JScript]
public function Write(
   value : float
);

Parameters

value
The Single to write.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (in Visual Basic Nothing) string or object is passed.
IOException | An I/O error occurs.

Remarks

The text representation of the specified value is produced by calling ToString.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.Write Overload List


TextWriter.Write (String)

Writes a string to the text stream.

[Visual Basic]
Overloads Overridable Public Sub Write( _
   ByVal value As String _
)
[C#]
public virtual void Write(
   string value
);
[C++]
public: virtual void Write(
   String* value
);
[JScript]
public function Write(
   value : String
);

Parameters

value
The string to write.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (in Visual Basic Nothing) string or object is passed.
IOException | An I/O error occurs.

Remarks

If value is null, nothing is written to the text stream.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.Write Overload List


TextWriter.Write (Double)

Writes the text representation of a Double to the text stream.

[Visual Basic]
Overloads Overridable Public Sub Write( _
   ByVal value As Double _
)
[C#]
public virtual void Write(
   double value
);
[C++]
public: virtual void Write(
   double value
);
[JScript]
public function Write(
   value : double
);

Parameters

value
The Double to write.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (in Visual Basic Nothing) string or object is passed.
IOException | An I/O error occurs.

Remarks

The text representation of the specified value is produced by calling ToString.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.Write Overload List


TextWriter.Write (UInt32)

Writes the text representation of an integer to the text stream.

[Visual Basic]
Overloads Overridable Public Sub Write( _
   ByVal value As UInt32 _
)
[C#]
public virtual void Write(
   uint value
);
[C++]
public: virtual void Write(
   unsigned int value
);
[JScript]
public function Write(
   value : UInt32
);

Parameters

value
The unsigned integer to write.

Exceptions

Exception Type | Condition
ArgumentNullException | A null string or object is passed.
IOException | An I/O error occurs.

Remarks

The text representation of the specified value is produced by calling ToString.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.Write Overload List


TextWriter.Write (Char[])

Writes a character array to the text stream.

[Visual Basic]
Overloads Overridable Public Sub Write( _
   ByVal buffer() As Char _
)
[C#]
public virtual void Write(
   char[] buffer
);
[C++]
public: virtual void Write(
   __wchar_t* buffer[]
);
[JScript]
public function Write(
   buffer : Char[]
);

Parameters

buffer
The character array to write to the text stream.

Exceptions

Exception Type | Condition
ArgumentNullException | buffer is null.
IOException | An I/O error occurs.

Remarks

This default method calls Write() for each of the characters in the character array. If the character array is null, nothing is written.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.Write Overload List


TextWriter.Write (Char)

Writes a character to the text stream.

[Visual Basic]
Overloads Overridable Public Sub Write( _
   ByVal value As Char _
)
[C#]
public virtual void Write(
   char value
);
[C++]
public: virtual void Write(
   __wchar_t value
);
[JScript]
public function Write(
   value : Char
);

Parameters

value
The character to write to the text stream.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.

Remarks

This default method is empty, but derived classes can override the method to provide the appropriate functionality.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.Write Overload List


TextWriter.Write (Char[], Int32, Int32)

Writes a subarray of characters to the text stream.

[Visual Basic]
Overloads Overridable Public Sub Write( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
[C#]
public virtual void Write(
   char[] buffer,
   int index,
   int count
);
[C++]
public: virtual void Write(
   __wchar_t* buffer[],
   int index,
   int count
);
[JScript]
public function Write(
   buffer : Char[],
   index : int,
   count : int
);

Parameters

buffer
The character array to write data from.
index
Starting index in the buffer.
count
The number of characters to write.

Exceptions

Exception Type | Condition
ArgumentNullException | buffer is a null reference (in Visual Basic Nothing).
ArgumentException | The buffer length minus index is less than count.
ArgumentOutOfRangeException | index or count is negative.
IOException | An I/O error occurs.

Remarks

This method will write count characters of data into this writer from the buffer character array starting at position index.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.Write Overload List


TextWriter.Write (Int32)

Writes the text representation of an integer to the text stream.

[Visual Basic]
Overloads Overridable Public Sub Write( _
   ByVal value As Integer _
)
[C#]
public virtual void Write(
   int value
);
[C++]
public: virtual void Write(
   int value
);
[JScript]
public function Write(
   value : int
);

Parameters

value
The integer to write.

Exceptions

Exception Type | Condition
ArgumentNullException | A null string or object is passed.
IOException | An I/O error occurs.

Remarks

The text representation of the specified value is produced by calling ToString.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.Write Overload List


TextWriter.Write (Boolean)

Writes the text representation of a Boolean value to the text stream.

[Visual Basic]
Overloads Overridable Public Sub Write( _
   ByVal value As Boolean _
)
[C#]
public virtual void Write(
   bool value
);
[C++]
public: virtual void Write(
   bool value
);
[JScript]
public function Write(
   value : Boolean
);

Parameters

value
The Boolean to write.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.

Remarks

This method outputs either Boolean.TrueString or Boolean.FalseString.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.Write Overload List


TextWriter.Write (String, Object, Object, Object)

Writes out a formatted string, using the same semantics as Format.

[Visual Basic]
Overloads Overridable Public Sub Write( _
   ByVal format As String, _
   ByVal arg0 As Object, _
   ByVal arg1 As Object, _
   ByVal arg2 As Object _
)
[C#]
public virtual void Write(
   string format,
   object arg0,
   object arg1,
   object arg2
);
[C++]
public: virtual void Write(
   String* format,
   Object* arg0,
   Object* arg1,
   Object* arg2
);
[JScript]
public function Write(
   format : String,
   arg0 : Object,
   arg1 : Object,
   arg2 : Object
);

Parameters

format
The formatting string.
arg0
The object to write into format string.
arg1
The object to write into format string.
arg2
The object to write into format string.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (in Visual Basic Nothing) string or object is passed.
IOException | An I/O error occurs.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.Write Overload List


TextWriter.Write (String, Object[])

Writes out a formatted string, using the same semantics as Format.

[Visual Basic]
Overloads Overridable Public Sub Write( _
   ByVal format As String, _
   ByVal arg() As Object _
)
[C#]
public virtual void Write(
   string format,
   object[] arg
);
[C++]
public: virtual void Write(
   String* format,
   Object* arg[]
);
[JScript]
public function Write(
   format : String,
   arg : Object[]
);

Parameters

format
The formatting string.
arg
The object array to write into format string.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (in Visual Basic Nothing) string or object is passed.
IOException | An I/O error occurs.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.Write Overload List


TextWriter.Write (String, Object, Object)

Writes out a formatted string, using the same semantics as Format.

[Visual Basic]
Overloads Overridable Public Sub Write( _
   ByVal format As String, _
   ByVal arg0 As Object, _
   ByVal arg1 As Object _
)
[C#]
public virtual void Write(
   string format,
   object arg0,
   object arg1
);
[C++]
public: virtual void Write(
   String* format,
   Object* arg0,
   Object* arg1
);
[JScript]
public function Write(
   format : String,
   arg0 : Object,
   arg1 : Object
);

Parameters

format
The formatting string.
arg0
The object to write into format string.
arg1
The object to write into format string.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (in Visual Basic Nothing) string or object is passed.
IOException | An I/O error occurs.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.Write Overload List


TextWriter.Write (Object)

Writes the text representation of an object to the text stream.

[Visual Basic]
Overloads Overridable Public Sub Write( _
   ByVal value As Object _
)
[C#]
public virtual void Write(
   object value
);
[C++]
public: virtual void Write(
   Object* value
);
[JScript]
public function Write(
   value : Object
);

Parameters

value
The object to write.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (in Visual Basic Nothing) string or object is passed.
IOException | An I/O error occurs.

Remarks

If the specified object is null, the string "null" is written to the text stream. Otherwise, the object's ToString method is called to produce the string representation, and the resulting string is then written to the output stream.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.Write Overload List


TextWriter.Write (String, Object)

Writes out a formatted string, using the same semantics as Format.

[Visual Basic]
Overloads Overridable Public Sub Write( _
   ByVal format As String, _
   ByVal arg0 As Object _
)
[C#]
public virtual void Write(
   string format,
   object arg0
);
[C++]
public: virtual void Write(
   String* format,
   Object* arg0
);
[JScript]
public function Write(
   format : String,
   arg0 : Object
);

Parameters

format
The formatting string.
arg0
The object to write into format string.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (in Visual Basic Nothing) string or object is passed.
IOException | An I/O error occurs.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.Write Overload List


TextWriter.WriteLine

Writes a line terminator and other characters as specified by the overloaded parameters.

Overload List

Writes a string followed by a line terminator to the text stream.

[Visual Basic] Overloads Overridable Public Sub WriteLine(String)
[C#] public virtual void WriteLine(String);
[C++] public: virtual void WriteLine(String*);
[JScript] public function WriteLine(String);

Writes the text representation of an object followed by a line terminator to the text stream.

[Visual Basic] Overloads Overridable Public Sub WriteLine(Object)
[C#] public virtual void WriteLine(Object);
[C++] public: virtual void WriteLine(Object*);
[JScript] public function WriteLine(Object);

Writes the text representation of a Single followed by a line terminator to the text stream.

[Visual Basic] Overloads Overridable Public Sub WriteLine(Single)
[C#] public virtual void WriteLine(float);
[C++] public: virtual void WriteLine(float);
[JScript] public function WriteLine(float);

Writes the text representation of a Double followed by a line terminator to the text stream.

[Visual Basic] Overloads Overridable Public Sub WriteLine(Double)
[C#] public virtual void WriteLine(double);
[C++] public: virtual void WriteLine(double);
[JScript] public function WriteLine(double);

Writes out a formatted string and a new line, using the same semantics as Format.

[Visual Basic] Overloads Overridable Public Sub WriteLine(String, Object, Object, Object)
[C#] public virtual void WriteLine(String, Object, Object, Object);
[C++] public: virtual void WriteLine(String*, Object, Object, Object);
[JScript] public function WriteLine(String, Object, Object, Object);

Writes out a formatted string and a new line, using the same semantics as Format.

[Visual Basic] Overloads Overridable Public Sub WriteLine(String, Object())
[C#] public virtual void WriteLine(String, Object[]);
[C++] public: virtual void WriteLine(String*, Object[]);
[JScript] public function WriteLine(String, Object[]);

Writes out a formatted string and a new line, using the same semantics as Format.

[Visual Basic] Overloads Overridable Public Sub WriteLine(String, Object)
[C#] public virtual void WriteLine(String, Object);
[C++] public: virtual void WriteLine(String*, Object);
[JScript] public function WriteLine(String, Object);

Writes out a formatted string and a new line, using the same semantics as Format.

[Visual Basic] Overloads Overridable Public Sub WriteLine(String, Object, Object)
[C#] public virtual void WriteLine(String, Object, Object);
[C++] public: virtual void WriteLine(String*, Object, Object);
[JScript] public function WriteLine(String, Object, Object);

Writes the text representation of an unsigned long followed by a line terminator to the text stream.

[Visual Basic] Overloads Overridable Public Sub WriteLine(UInt64)
[C#] public virtual void WriteLine(ulong);
[C++] public: virtual void WriteLine(unsigned __int64);
[JScript] public function WriteLine(UInt64);

Writes an array of characters followed by a line terminator to the text stream.

[Visual Basic] Overloads Overridable Public Sub WriteLine(Char())
[C#] public virtual void WriteLine(char[]);
[C++] public: virtual void WriteLine(__wchar_t*[]);
[JScript] public function WriteLine(Char[]);

Writes a subarray of characters followed by a line terminator to the text stream.

[Visual Basic] Overloads Overridable Public Sub WriteLine(Char(), Integer, Integer)
[C#] public virtual void WriteLine(char[], int, int);
[C++] public: virtual void WriteLine(__wchar_t*[], int, int);
[JScript] public function WriteLine(Char[], int, int);

Writes a line terminator to the text stream.

[Visual Basic] Overloads Overridable Public Sub WriteLine()
[C#] public virtual void WriteLine();
[C++] public: virtual void WriteLine();
[JScript] public function WriteLine();

Writes a character followed by a line terminator to the text stream.

[Visual Basic] Overloads Overridable Public Sub WriteLine(Char)
[C#] public virtual void WriteLine(char);
[C++] public: virtual void WriteLine(__wchar_t);
[JScript] public function WriteLine(Char);

Writes the text representation of an unsigned integer followed by a line terminator to the text stream.

[Visual Basic] Overloads Overridable Public Sub WriteLine(UInt32)
[C#] public virtual void WriteLine(uint);
[C++] public: virtual void WriteLine(unsigned int);
[JScript] public function WriteLine(UInt32);

Writes the text representation of an 8-byte integer followed by a line terminator to the text stream.

[Visual Basic] Overloads Overridable Public Sub WriteLine(Long)
[C#] public virtual void WriteLine(long);
[C++] public: virtual void WriteLine(__int64);
[JScript] public function WriteLine(long);

Writes the text representation of a Boolean followed by a line terminator to the text stream.

[Visual Basic] Overloads Overridable Public Sub WriteLine(Boolean)
[C#] public virtual void WriteLine(bool);
[C++] public: virtual void WriteLine(bool);
[JScript] public function WriteLine(Boolean);

Writes the text representation of an integer followed by a line terminator to the text stream.

[Visual Basic] Overloads Overridable Public Sub WriteLine(Integer)
[C#] public virtual void WriteLine(int);
[C++] public: virtual void WriteLine(int);
[JScript] public function WriteLine(int);

See Also

TextWriter Class | TextWriter Members | System.IO Namespace


TextWriter.WriteLine (String)

Writes a string followed by a line terminator to the text stream.

[Visual Basic]
Overloads Overridable Public Sub WriteLine( _
   ByVal value As String _
)
[C#]
public virtual void WriteLine(
   string value
);
[C++]
public: virtual void WriteLine(
   String* value
);
[JScript]
public function WriteLine(
   value : String
);

Parameters

value
The string to write.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (in Visual Basic Nothing) string or object is passed.
IOException | An I/O error occurs.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.WriteLine Overload List


TextWriter.WriteLine (Object)

Writes the text representation of an object followed by a line terminator to the text stream.

[Visual Basic]
Overloads Overridable Public Sub WriteLine( _
   ByVal value As Object _
)
[C#]
public virtual void WriteLine(
   object value
);
[C++]
public: virtual void WriteLine(
   Object* value
);
[JScript]
public function WriteLine(
   value : Object
);

Parameters

value
The object to write.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (in Visual Basic Nothing) string or object is passed.
IOException | An I/O error occurs.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.WriteLine Overload List


TextWriter.WriteLine (Single)

Writes the text representation of a Single followed by a line terminator to the text stream.

[Visual Basic]
Overloads Overridable Public Sub WriteLine( _
   ByVal value As Single _
)
[C#]
public virtual void WriteLine(
   float value
);
[C++]
public: virtual void WriteLine(
   float value
);
[JScript]
public function WriteLine(
   value : float
);

Parameters

value
The Single to write.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (in Visual Basic Nothing) string or object is passed.
IOException | An I/O error occurs.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.WriteLine Overload List


TextWriter.WriteLine (Double)

Writes the text representation of a Double followed by a line terminator to the text stream.

[Visual Basic]
Overloads Overridable Public Sub WriteLine( _
   ByVal value As Double _
)
[C#]
public virtual void WriteLine(
   double value
);
[C++]
public: virtual void WriteLine(
   double value
);
[JScript]
public function WriteLine(
   value : double
);

Parameters

value
The Double to write.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (in Visual Basic Nothing) string or object is passed.
IOException | An I/O error occurs.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.WriteLine Overload List


TextWriter.WriteLine (String, Object, Object, Object)

Writes out a formatted string and a new line, using the same semantics as Format.

[Visual Basic]
Overloads Overridable Public Sub WriteLine( _
   ByVal format As String, _
   ByVal arg0 As Object, _
   ByVal arg1 As Object, _
   ByVal arg2 As Object _
)
[C#]
public virtual void WriteLine(
   string format,
   object arg0,
   object arg1,
   object arg2
);
[C++]
public: virtual void WriteLine(
   String* format,
   Object* arg0,
   Object* arg1,
   Object* arg2
);
[JScript]
public function WriteLine(
   format : String,
   arg0 : Object,
   arg1 : Object,
   arg2 : Object
);

Parameters

format
The formatting string.
arg0
The object to write into format string.
arg1
The object to write into format string.
arg2
The object to write into format string.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (in Visual Basic Nothing) string or object is passed.
IOException | An I/O error occurs.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.WriteLine Overload List


TextWriter.WriteLine (String, Object[])

Writes out a formatted string and a new line, using the same semantics as Format.

[Visual Basic]
Overloads Overridable Public Sub WriteLine( _
   ByVal format As String, _
   ByVal arg() As Object _
)
[C#]
public virtual void WriteLine(
   string format,
   object[] arg
);
[C++]
public: virtual void WriteLine(
   String* format,
   Object* arg[]
);
[JScript]
public function WriteLine(
   format : String,
   arg : Object[]
);

Parameters

format
The formatting string.
arg
The object array to write into format string.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (in Visual Basic Nothing) string or object is passed.
IOException | An I/O error occurs.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.WriteLine Overload List


TextWriter.WriteLine (String, Object)

Writes out a formatted string and a new line, using the same semantics as Format.

[Visual Basic]
Overloads Overridable Public Sub WriteLine( _
   ByVal format As String, _
   ByVal arg0 As Object _
)
[C#]
public virtual void WriteLine(
   string format,
   object arg0
);
[C++]
public: virtual void WriteLine(
   String* format,
   Object* arg0
);
[JScript]
public function WriteLine(
   format : String,
   arg0 : Object
);

Parameters

format
The formatted string.
arg0
The object to write into the formatted string.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (in Visual Basic Nothing) string or object is passed.
IOException | An I/O error occurs.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.WriteLine Overload List


TextWriter.WriteLine (String, Object, Object)

Writes out a formatted string and a new line, using the same semantics as Format.

[Visual Basic]
Overloads Overridable Public Sub WriteLine( _
   ByVal format As String, _
   ByVal arg0 As Object, _
   ByVal arg1 As Object _
)
[C#]
public virtual void WriteLine(
   string format,
   object arg0,
   object arg1
);
[C++]
public: virtual void WriteLine(
   String* format,
   Object* arg0,
   Object* arg1
);
[JScript]
public function WriteLine(
   format : String,
   arg0 : Object,
   arg1 : Object
);

Parameters

format
The formatting string.
arg0
The object to write into format string.
arg1
The object to write into the formatted string.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (in Visual Basic Nothing) string or object is passed.
IOException | An I/O error occurs.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.WriteLine Overload List


TextWriter.WriteLine (UInt64)

Writes the text representation of an unsigned long followed by a line terminator to the text stream.

[Visual Basic]
Overloads Overridable Public Sub WriteLine( _
   ByVal value As UInt64 _
)
[C#]
public virtual void WriteLine(
   ulong value
);
[C++]
public: virtual void WriteLine(
   unsigned __int64 value
);
[JScript]
public function WriteLine(
   value : UInt64
);

Parameters

value
The unsigned long to write.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (in Visual Basic Nothing) string or object is passed.
IOException | An I/O error occurs.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.WriteLine Overload List


TextWriter.WriteLine (Char[])

Writes an array of characters followed by a line terminator to the text stream.

[Visual Basic]
Overloads Overridable Public Sub WriteLine( _
   ByVal buffer() As Char _
)
[C#]
public virtual void WriteLine(
   char[] buffer
);
[C++]
public: virtual void WriteLine(
   __wchar_t* buffer[]
);
[JScript]
public function WriteLine(
   buffer : Char[]
);

Parameters

buffer
The character array from which data is read.

Exceptions

Exception Type | Condition
ArgumentException | buffer is null.
IOException | An I/O error occurs.

Remarks

All the characters in buffer are written to the underlying stream unless the end of the underlying stream is reached.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.WriteLine Overload List


TextWriter.WriteLine (Char[], Int32, Int32)

Writes a subarray of characters followed by a line terminator to the text stream.

[Visual Basic]
Overloads Overridable Public Sub WriteLine( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
[C#]
public virtual void WriteLine(
   char[] buffer,
   int index,
   int count
);
[C++]
public: virtual void WriteLine(
   __wchar_t* buffer[],
   int index,
   int count
);
[JScript]
public function WriteLine(
   buffer : Char[],
   index : int,
   count : int
);

Parameters

buffer
The character array from which data is read.
index
The index into buffer at which to begin reading.
count
The maximum number of characters to write.

Return Value

Characters are read from buffer beginning at index and ending at index + count. All characters are written to the underlying stream unless the end of the underlying stream is reached prematurely.

Exceptions

Exception Type | Condition
ArgumentNullException | buffer is a null reference (in Visual Basic Nothing).
ArgumentException | The buffer length minus index is less than count.
ArgumentOutOfRangeException | index or count is negative.
IOException | An I/O error occurs.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.WriteLine Overload List


TextWriter.WriteLine ()

Writes a line terminator to the text stream.

[Visual Basic]
Overloads Overridable Public Sub WriteLine()
[C#]
public virtual void WriteLine();
[C++]
public: virtual void WriteLine();
[JScript]
public function WriteLine();

Return Value

The default line terminator is a carriage return followed by a line feed ("\r\n"), but this value can be changed using the NewLine property.

Exceptions

Exception Type | Condition
IOException | An I/O error occurs.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.WriteLine Overload List


TextWriter.WriteLine (Char)

Writes a character followed by a line terminator to the text stream.

[Visual Basic]
Overloads Overridable Public Sub WriteLine( _
   ByVal value As Char _
)
[C#]
public virtual void WriteLine(
   char value
);
[C++]
public: virtual void WriteLine(
   __wchar_t value
);
[JScript]
public function WriteLine(
   value : Char
);

Parameters

value
The character to write to the text stream.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (in Visual Basic Nothing) string or object is passed.
IOException | An I/O error occurs.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.WriteLine Overload List


TextWriter.WriteLine (UInt32)

Writes the text representation of an unsigned integer followed by a line terminator to the text stream.

[Visual Basic]
Overloads Overridable Public Sub WriteLine( _
   ByVal value As UInt32 _
)
[C#]
public virtual void WriteLine(
   uint value
);
[C++]
public: virtual void WriteLine(
   unsigned int value
);
[JScript]
public function WriteLine(
   value : UInt32
);

Parameters

value
The unsigned integer to write.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (in Visual Basic Nothing) string or object is passed.
IOException | An I/O error occurs.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.WriteLine Overload List


TextWriter.WriteLine (Int64)

Writes the text representation of an 8-byte integer followed by a line terminator to the text stream.

[Visual Basic]
Overloads Overridable Public Sub WriteLine( _
   ByVal value As Long _
)
[C#]
public virtual void WriteLine(
   long value
);
[C++]
public: virtual void WriteLine(
   __int64 value
);
[JScript]
public function WriteLine(
   value : long
);

Parameters

value
The 8-byte integer to write.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (in Visual Basic Nothing) string or object is passed.
IOException | An I/O error occurs.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.WriteLine Overload List


TextWriter.WriteLine (Boolean)

Writes the text representation of a Boolean followed by a line terminator to the text stream.

[Visual Basic]
Overloads Overridable Public Sub WriteLine( _
   ByVal value As Boolean _
)
[C#]
public virtual void WriteLine(
   bool value
);
[C++]
public: virtual void WriteLine(
   bool value
);
[JScript]
public function WriteLine(
   value : Boolean
);

Parameters

value
The Boolean to write.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (in Visual Basic Nothing) string or object is passed.
IOException | An I/O error occurs.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.WriteLine Overload List


TextWriter.WriteLine (Int32)

Writes the text representation of an integer followed by a line terminator to the text stream.

[Visual Basic]
Overloads Overridable Public Sub WriteLine( _
   ByVal value As Integer _
)
[C#]
public virtual void WriteLine(
   int value
);
[C++]
public: virtual void WriteLine(
   int value
);
[JScript]
public function WriteLine(
   value : int
);

Parameters

value
The integer to write.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (in Visual Basic Nothing) string or object is passed.
IOException | An I/O error occurs.

See Also

TextWriter Class | TextWriter Members | System.IO Namespace | TextWriter.WriteLine Overload List


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TextWriter Fields

The fields of the TextWriter class are listed below. For a complete list of TextWriter class members, see the TextWriter Members topic.

Public:

Null Provides a repository with no backing store that can be written to, but not read from. Use Null to redirect output to a stream that will not consume any operating system resources.

Protected:

CoreNewLine Gets the next line in the file.

See Also

TextWriter Class | System.IO Namespace


TextWriter.CoreNewLine

Gets the next line in the file.

[Visual Basic]
Protected CoreNewLine As String
[C#]
protected string CoreNewLine;
[C++]
protected: String* CoreNewLine;
[JScript]
protected var CoreNewLine : String;

See Also

TextWriter Class | TextWriter Members | System.IO Namespace


TextWriter.Null

Provides a repository with no backing store that can be written to, but not read from. Use Null to redirect output to a stream that will not consume any operating system resources.

[Visual Basic]
Public Shared ReadOnly Null As TextWriter
[C#]
public static readonly TextWriter Null;
[C++]
public: static readonly TextWriter* Null;
[JScript]
public static var Null : TextWriter;

See Also

TextWriter Class | TextWriter Members | System.IO Namespace


WaitForChangedResult Structure

Waits for a change in the specified path.

Object
ValueType
WaitForChangedResult

[Visual Basic]
Public Structure WaitForChangedResult
[C#]
public struct WaitForChangedResult
[C++]
public __value struct WaitForChangedResult

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

Responds when either a change occurs, or the call has timed out.

Requirements

Namespace: System.IO

Assembly: system.io.dll

See Also

WaitForChangedResult Members | System.IO Namespace | FileSystemWatcher


WaitForChangedResult Members

Public:

Properties

ChangeType | Gets or sets the type of change to watch for.
Name | Gets or sets the name of the file or subdirectory that has changed.
OldName | Gets or sets the original name of the file or subdirectory that has been renamed.
TimedOut | Gets or sets a value indicating whether the process has timed out.

Methods

Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WaitForChangedResult Structure | System.IO Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

WaitForChangedResult Properties

The properties of the WaitForChangedResult structure are listed below. For a complete list of WaitForChangedResult structure members, see the WaitForChangedResult Members topic.

Public:

ChangeType | Gets or sets the type of change to watch for.
Name | Gets or sets the name of the file or subdirectory that has changed.
OldName | Gets or sets the original name of the file or subdirectory that has been renamed.
TimedOut | Gets or sets a value indicating whether the process has timed out.

See Also

WaitForChangedResult Structure | System.IO Namespace


WaitForChangedResult.ChangeType

Gets or sets the type of change to watch for.

[Visual Basic]
Public Property ChangeType As WatcherChangeTypes
[C#]
public WatcherChangeTypes ChangeType {get; set;}
[C++]
public: __property WatcherChangeTypes get_ChangeType();
public: __property void set_ChangeType(WatcherChangeTypes);
[JScript]
public function get ChangeType() : WatcherChangeTypes;
public function set ChangeType(WatcherChangeTypes);

Property Value

One of the WatcherChangeTypes values.

See Also

WaitForChangedResult Structure | WaitForChangedResult Members | System.IO Namespace | WatcherChangeTypes


WaitForChangedResult.Name

Gets or sets the name of the file or subdirectory that has changed.

[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}
[C++]
public: __property String* get_Name();
public: __property void set_Name(String*);
[JScript]
public function get Name() : String;
public function set Name(String);

Property Value

The name of the file or subdirectory that has changed.

See Also

WaitForChangedResult Structure | WaitForChangedResult Members | System.IO Namespace


WaitForChangedResult.OldName

Gets or sets the original name of the file or subdirectory that has been renamed.

[Visual Basic]
Public Property OldName As String
[C#]
public string OldName {get; set;}
[C++]
public: __property String* get_OldName();
public: __property void set_OldName(String*);
[JScript]
public function get OldName() : String;
public function set OldName(String);

Property Value

The original name of the file or subdirectory that has been renamed.

See Also

WaitForChangedResult Structure | WaitForChangedResult Members | System.IO Namespace


WaitForChangedResult.TimedOut

Gets or sets a value indicating whether the process has timed out.

[Visual Basic]
Public Property TimedOut As Boolean
[C#]
public bool TimedOut {get; set;}
[C++]
public: __property bool get_TimedOut();
public: __property void set_TimedOut(bool);
[JScript]
public function get TimedOut() : Boolean;
public function set TimedOut(Boolean);

Property Value

true if the process has timed out; otherwise, false.

See Also

WaitForChangedResult Structure | WaitForChangedResult Members | System.IO Namespace


WatcherChangeTypes Enumeration

Changes that may occur to a file or directory.

[Visual Basic]
Public Enum WatcherChangeTypes
[C#]
public enum WatcherChangeTypes
[C++]
public enum WatcherChangeTypes

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Changed | The change of a file or folder.
Created | The creation of a file or folder.
Deleted | The deletion of a file or folder.
Renamed | The renaming of a file or folder.

Requirements

Namespace: System.IO

Assembly: system.io.dll

See Also

System.IO Namespace


WatcherTarget Enumeration

Specifies whether to monitor a file, directory, or both.

[Visual Basic]
Public Enum WatcherTarget
[C#]
public enum WatcherTarget
[C++]
public enum WatcherTarget

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

Use the members of this enumeration to watch a file, directory, or both files and directories. Only one member can be used at a time.

Members

Member Name | Description
Both | Watch both files and directories.
Directory | The directory to watch.
File | The file to watch.

Requirements

Namespace: System.IO

Assembly: system.io.dll

See Also

System.IO Namespace


System.IO.IsolatedStorage

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.IO.IsolatedStorage Namespace

Classes

Class | Description
IsolatedStorage | This abstract class is the basis for all forms of isolated storage. For file-based isolated storage, see IsolatedStorageFile class.
IsolatedStorageException | Exceptions thrown from the Isolated Storage system for accessing data files based on application identity.
IsolatedStorageFile | Represents an isolated storage area containing files and directories.
IsolatedStorageFileStream | Exposes a file within isolated storage.

Enumerations

Enumeration | Description
IsolatedStorageScope | Enumerates the levels of isolated storage scope supported. Combinations of the levels may be specified


IsolatedStorage Class

This abstract class is the basis for all forms of isolated storage. For file-based isolated storage, see IsolatedStorageFile class.

Object
IsolatedStorage

[Visual Basic]
MustInherit Public Class IsolatedStorage
[C#]
public abstract class IsolatedStorage
[C++]
public __gc __abstract class IsolatedStorage
[JScript]
public abstract class IsolatedStorage

Remarks

All forms of isolated storage should derive from this base class.

Requirements

Namespace: System.IO.IsolatedStorage

Assembly: mscorlib.dll

NGWS Runtime Security:

IsolatedStoragePermission permission to use isolated storage

See Also

IsolatedStorage Members | System.IO.IsolatedStorage Namespace


IsolatedStorage Members

Public:

Constructor

IsolatedStorage Constructor [To be supplied.]

Properties

AssemblyIdentity | [To be supplied.]
CurrentSize | Current size of isolated storage in use.
DomainIdentity | Get domain identity used to scope isolated storage.
MaximumSize | Maximum size available for isolated storage within limits established by the quota.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Remove | Remove the individual isolated store and all contained data
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

SeperatorExternal | [To be supplied.]
SeperatorInternal | [To be supplied.]

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
InitStore | Initializes a new instance of the IsolatedStorage object.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IsolatedStorage Class | System.IO.IsolatedStorage Namespace


IsolatedStorage Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public IsolatedStorage();
[C++]
public: IsolatedStorage();
[JScript]
public function IsolatedStorage();

See Also

IsolatedStorage Class | IsolatedStorage Members | System.IO.IsolatedStorage Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IsolatedStorage Properties

The properties of the IsolatedStorage class are listed below. For a complete list of IsolatedStorage class members, see the IsolatedStorage Members topic.

Public:

AssemblyIdentity | [To be supplied.]
CurrentSize | Current size of isolated storage in use.
DomainIdentity | Get domain identity used to scope isolated storage.
MaximumSize | Maximum size available for isolated storage within limits established by the quota.

Protected:

SeperatorExternal | [To be supplied.]
SeperatorInternal | [To be supplied.]

See Also

IsolatedStorage Class | System.IO.IsolatedStorage Namespace


IsolatedStorage.AssemblyIdentity

[To be supplied.]

[Visual Basic]
Public ReadOnly Property AssemblyIdentity As Object
[C#]
public object AssemblyIdentity {get;}
[C++]
public: __property Object* get_AssemblyIdentity();
[JScript]
public function get AssemblyIdentity() : Object;

See Also

IsolatedStorage Class | IsolatedStorage Members | System.IO.IsolatedStorage Namespace


IsolatedStorage.CurrentSize

Current size of isolated storage in use.

[Visual Basic]
Public ReadOnly Property CurrentSize As UInt64
[C#]
public ulong CurrentSize {get;}
[C++]
public: __property unsigned __int64 get_CurrentSize();
[JScript]
public function get CurrentSize() : UInt64;

Property Value

The total number of bytes of storage currently in use within the isolated storage scope.

Remarks

Represents the total usage of all files and directories within the isolated storage scope.

See Also

IsolatedStorage Class | IsolatedStorage Members | System.IO.IsolatedStorage Namespace


IsolatedStorage.DomainIdentity

Get domain identity used to scope isolated storage.

[Visual Basic]
Public ReadOnly Property DomainIdentity As Object
[C#]
public object DomainIdentity {get;}
[C++]
public: __property Object* get_DomainIdentity();
[JScript]
public function get DomainIdentity() : Object;

Property Value

Domain identity used to scope isolated storage.

Exceptions

Exception Type | Condition
SecurityException | security requires permission to control permission in order to access this object

Remarks

This property is only required for administration or other specialized types of access, and is not normally required.

Requirements

NGWS Runtime Security:

SecurityPermission security requires permission to ControlPolicy permission in order to access this object

See Also

IsolatedStorage Class | IsolatedStorage Members | System.IO.IsolatedStorage Namespace


IsolatedStorage.MaximumSize

Maximum size available for isolated storage within limits established by the quota.

[Visual Basic]
Public ReadOnly Property MaximumSize As UInt64
[C#]
public ulong MaximumSize {get;}
[C++]
public: __property unsigned __int64 get_MaximumSize();
[JScript]
public function get MaximumSize() : UInt64;

Property Value

Number of bytes of isolated storage available.

Remarks

Number of bytes available is constrained by the isolated storage quota set by the administrator.

See Also

IsolatedStorage Class | IsolatedStorage Members | System.IO.IsolatedStorage Namespace


IsolatedStorage.SeperatorExternal

[To be supplied.]

[Visual Basic]
Overridable Protected ReadOnly Property SeperatorExternal As Char
[C#]
protected char SeperatorExternal {virtual get;}
[C++]
protected: __property virtual __wchar_t get_SeperatorExternal();
[JScript]
protected function get SeperatorExternal() : Char;

See Also

IsolatedStorage Class | IsolatedStorage Members | System.IO.IsolatedStorage Namespace


IsolatedStorage.SeperatorInternal

[To be supplied.]

[Visual Basic]
Overridable Protected ReadOnly Property SeperatorInternal As Char
[C#]
protected char SeperatorInternal {virtual get;}
[C++]
protected: __property virtual __wchar_t get_SeperatorInternal();
[JScript]
protected function get SeperatorInternal() : Char;

See Also

IsolatedStorage Class | IsolatedStorage Members | System.IO.IsolatedStorage Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IsolatedStorage Methods

The methods of the IsolatedStorage class are listed below. For a complete list of IsolatedStorage class members, see the IsolatedStorage Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Remove | Remove the individual isolated store and all contained data
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
InitStore | Initializes a new instance of the IsolatedStorage object.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IsolatedStorage Class | System.IO.IsolatedStorage Namespace


IsolatedStorage.InitStore

Initializes a new instance of the IsolatedStorage object.

[Visual Basic]
Protected Sub InitStore( _
   ByVal scope As IsolatedStorageScope, _
   ByVal AppEvidenceType As Type, _
   ByVal AssemblyEvidenceType As Type _
)
[C#]
protected void InitStore(
   IsolatedStorageScope scope,
   Type AppEvidenceType,
   Type AssemblyEvidenceType
);
[C++]
protected: void InitStore(
   IsolatedStorageScope scope,
   Type* AppEvidenceType,
   Type* AssemblyEvidenceType
);
[JScript]
protected function InitStore(
   scope : IsolatedStorageScope,
   AppEvidenceType : Type,
   AssemblyEvidenceType : Type
);

Parameters

scope
Specifies scope within which to create isolated storage instance
AppEvidenceType
Type of application domain evidence used for isolated storage scope
AssemblyEvidenceType
Type of code assembly evidence used for isolated storage scope

Return Value

none

Remarks

This method is used by subclasses to initialize a new instance.

See Also

IsolatedStorage Class | IsolatedStorage Members | System.IO.IsolatedStorage Namespace


IsolatedStorage.Remove

Remove the individual isolated store and all contained data

[Visual Basic]
MustOverride Public Sub Remove()
[C#]
public abstract void Remove();
[C++]
public: virtual void Remove() = 0;
[JScript]
public abstract function Remove();

Return Value

This is abstract method in this base class; must be implemented by subclasses.

Remarks

See subclass for details.

See Also

IsolatedStorage Class | IsolatedStorage Members | System.IO.IsolatedStorage Namespace


IsolatedStorageException Class

Exceptions thrown from the Isolated Storage system for accessing data files based on application identity.

Object
Exception
IsolatedStorageException

[Visual Basic]
Public Class IsolatedStorageException
   Inherits Exception
[C#]
public class IsolatedStorageException : Exception
[C++]
public __gc class IsolatedStorageException : public Exception
[JScript]
public class IsolatedStorageException extends Exception

Remarks

The most common kind of isolated storage exceptions include:

* missing evidence- isolated storage requires evidence (information about the application) in order to know the application identity in order to connect it to the right associated file space; without this information isolated storage cannot be used

* invalid operations- some FileStream operations, such as asynchronous file access, are not supported for isolated storage

Requirements

Namespace: System.IO.IsolatedStorage

Assembly: mscorlib.dll

See Also

IsolatedStorageException Members | System.IO.IsolatedStorage Namespace


IsolatedStorageException Members

Public:

Constructor

IsolatedStorageException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

IsolatedStorageException Class | System.IO.IsolatedStorage Namespace


IsolatedStorageException Constructor

[To be supplied.]

Overload List

Creates the isolated storage exception object.

[Visual Basic] Overloads Public Sub New()
[C#] public IsolatedStorageException();
[C++] public: IsolatedStorageException();
[JScript] public function IsolatedStorageException();

Creates the isolated storage exception object with specified message string.

[Visual Basic] Overloads Public Sub New(String)
[C#] public IsolatedStorageException(String);
[C++] public: IsolatedStorageException(String*);
[JScript] public function IsolatedStorageException(String);

Creates the isolated storage exception object with specified message string and inner exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public IsolatedStorageException(String, Exception);
[C++] public: IsolatedStorageException(String*, Exception);
[JScript] public function IsolatedStorageException(String, Exception);

See Also

IsolatedStorageException Class | IsolatedStorageException Members | System.IO.IsolatedStorage Namespace


IsolatedStorageException Constructor ()

Creates the isolated storage exception object.

[Visual Basic]
Overloads Public Sub New()
[C#]
public IsolatedStorageException();
[C++]
public: IsolatedStorageException();
[JScript]
public function IsolatedStorageException();

See Also

IsolatedStorageException Class | IsolatedStorageException Members | System.IO.IsolatedStorage Namespace | IsolatedStorageException Constructor Overload List


IsolatedStorageException Constructor (String)

Creates the isolated storage exception object with specified message string.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public IsolatedStorageException(
   string message
);
[C++]
public: IsolatedStorageException(
   String* message
);
[JScript]
public function IsolatedStorageException(
   message : String
);

Parameters

message
String message describing the specific isolated storage exception

See Also

IsolatedStorageException Class | IsolatedStorageException Members | System.IO.IsolatedStorage Namespace | IsolatedStorageException Constructor Overload List


IsolatedStorageException Constructor (String, Exception)

Creates the isolated storage exception object with specified message string and inner exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public IsolatedStorageException(
   string message,
   Exception inner
);
[C++]
public: IsolatedStorageException(
   String* message,
   Exception* inner
);
[JScript]
public function IsolatedStorageException(
   message : String,
   inner : Exception
);

Parameters

message
String message describing the specific isolated storage exception
inner
[To be supplied.]

See Also

IsolatedStorageException Class | IsolatedStorageException Members | System.IO.IsolatedStorage Namespace | IsolatedStorageException Constructor Overload List


IsolatedStorageFile Class

Represents an isolated storage area containing files and directories.

Object
IsolatedStorage
IsolatedStorageFile

[Visual Basic]
Public Class IsolatedStorageFile
   Inherits IsolatedStorage
[C#]
public class IsolatedStorageFile : IsolatedStorage
[C++]
public __gc class IsolatedStorageFile : public IsolatedStorage
[JScript]
public class IsolatedStorageFile extends IsolatedStorage

Remarks

This object corresponds to a specific isolated storage scope, within which exist files represented by IsolatedStorageFileStream objects.

Requirements

Namespace: System.IO.IsolatedStorage

Assembly: mscorlib.dll

NGWS Runtime Security:

IsolatedStoragePermission permission to use isolated storage

See Also

IsolatedStorageFile Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFile Members

Public:

Properties

AssemblyIdentity (inherited from IsolatedStorage) | [To be supplied.]
CurrentSize (inherited from IsolatedStorage) | Current size of isolated storage in use.
DomainIdentity (inherited from IsolatedStorage) | Get domain identity used to scope isolated storage.
MaximumSize (inherited from IsolatedStorage) | Maximum size available for isolated storage within limits established by the quota.

Methods

CreateDirectory | Creates a directory in the isolated storage scope.
DeleteDirectory | Deletes a directory in the isolated storage scope.
DeleteFile | Deletes a file in the isolated storage scope.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDirectoryNames | Enumerates directories in isolated storage scope that matach given pattern.
GetEnumerator | Enumerates files within the isolated storage scope.
GetFileNames | Enumerates files in isolated storage scope that matach given pattern.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetStore | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetUserStoreForAssembly | Isolated storage corresponding to the code assembly identity.
GetUserStoreForDomain | Isolated storage corresponding to the application domain identity.
Remove | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Properties

SeperatorExternal (inherited from IsolatedStorage) | [To be supplied.]
SeperatorInternal (inherited from IsolatedStorage) | [To be supplied.]

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
InitStore (inherited from IsolatedStorage) | Initializes a new instance of the IsolatedStorage object.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IsolatedStorageFile Class | System.IO.IsolatedStorage Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IsolatedStorageFile Methods

The methods of the IsolatedStorageFile class are listed below. For a complete list of IsolatedStorageFile class members, see the IsolatedStorageFile Members topic.

Public:

CreateDirectory | Creates a directory in the isolated storage scope.
DeleteDirectory | Deletes a directory in the isolated storage scope.
DeleteFile | Deletes a file in the isolated storage scope.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDirectoryNames | Enumerates directories in isolated storage scope that matach given pattern.
GetEnumerator | Enumerates files within the isolated storage scope.
GetFileNames | Enumerates files in isolated storage scope that matach given pattern.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetStore | Overloaded. [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetUserStoreForAssembly | Isolated storage corresponding to the code assembly identity.
GetUserStoreForDomain | Isolated storage corresponding to the application domain identity.
Remove | Overloaded. [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
InitStore (inherited from IsolatedStorage) | Initializes a new instance of the IsolatedStorage object.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IsolatedStorageFile Class | System.IO.IsolatedStorage Namespace


IsolatedStorageFile.CreateDirectory

Creates a directory in the isolated storage scope.

[Visual Basic]
Public Sub CreateDirectory( _
   ByVal dir As String _
)
[C#]
public void CreateDirectory(
   string dir
);
[C++]
public: void CreateDirectory(
   String* dir
);
[JScript]
public function CreateDirectory(
   dir : String
);

Parameters

dir
relative path of the directory to create within the isolated storage scope

Return Value

none

Exceptions

Exception Type | Condition
IsolatedStorageException | insufficient permission to create isolated storage directory

Remarks

Created directory initially contains no files.

Requirements

NGWS Runtime Security:

IsolatedStorageFilePermission right to access the isolated storage scope

See Also

IsolatedStorageFile Class | IsolatedStorageFile Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFile.DeleteDirectory

Deletes a directory in the isolated storage scope.

[Visual Basic]
Public Sub DeleteDirectory( _
   ByVal dir As String _
)
[C#]
public void DeleteDirectory(
   string dir
);
[C++]
public: void DeleteDirectory(
   String* dir
);
[JScript]
public function DeleteDirectory(
   dir : String
);

Parameters

dir
relative path of the directory to delete within the isolated storage scope

Return Value

none

Exceptions

Exception Type | Condition
IsolatedStorageException | insufficient permission to delete isolated storage directory

Remarks

Deleting a directory includes deleting all its contents- files and subdirectories. The deleted directory and its contents cannot be recovered once deleted.

Requirements

NGWS Runtime Security:

IsolatedStorageFilePermission right to access the isolated storage scope

See Also

IsolatedStorageFile Class | IsolatedStorageFile Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFile.DeleteFile

Deletes a file in the isolated storage scope.

[Visual Basic]
Public Sub DeleteFile( _
   ByVal file As String _
)
[C#]
public void DeleteFile(
   string file
);
[C++]
public: void DeleteFile(
   String* file
);
[JScript]
public function DeleteFile(
   file : String
);

Parameters

file
relative path of the file to delete within the isolated storage scope

Return Value

none

Exceptions

Exception Type | Condition
IsolatedStorageException | insufficient permission to delete isolated storage file

Remarks

The deleted file cannot be recovered once deleted.

Requirements

NGWS Runtime Security:

IsolatedStorageFilePermission right to access files in the isolated storage scope

See Also

IsolatedStorageFile Class | IsolatedStorageFile Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFile.GetDirectoryNames

Enumerates directories in isolated storage scope that matach given pattern.

[Visual Basic]
Public Function GetDirectoryNames( _
   ByVal searchCriteria As String _
) As String ()
[C#]
public string[] GetDirectoryNames(
   string searchCriteria
);
[C++]
public: String* GetDirectoryNames(
   String* searchCriteria
) [];
[JScript]
public function GetDirectoryNames(
   searchCriteria : String
) : String[];

Parameters

searchCriteria
Wildcard string expression describing matching files to the enumerated

Return Value

Array of strings corresponding to the relative pathnames of directories in the isolated storage scope that matchsearchCriteria. A zero-lengthed array designates that no directories matched.

Remarks

For complete description of search criteria strings see System.IO.Directory.

For file names seeGetFileNames method.

Example

The searchCriteria "foo\data*" will give all subdirectories of "foo" beginning with "data" in the isolated storage scope.

See Also

IsolatedStorageFile Class | IsolatedStorageFile Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFile.GetEnumerator

Enumerates files within the isolated storage scope.

[Visual Basic]
Public Shared Function GetEnumerator( _
   ByVal scope As IsolatedStorageScope _
) As IEnumerator
[C#]
public static IEnumerator GetEnumerator(
   IsolatedStorageScope scope
);
[C++]
public: static IEnumerator* GetEnumerator(
   IsolatedStorageScope scope
);
[JScript]
public static function GetEnumerator(
   scope : IsolatedStorageScope
) : IEnumerator;

Parameters

scope
which scope of isolated storage to be removed

Return Value

Enumerator for the files within the specified isolated storage scope.

See Also

IsolatedStorageFile Class | IsolatedStorageFile Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFile.GetFileNames

Enumerates files in isolated storage scope that matach given pattern.

[Visual Basic]
Public Function GetFileNames( _
   ByVal searchCriteria As String _
) As String ()
[C#]
public string[] GetFileNames(
   string searchCriteria
);
[C++]
public: String* GetFileNames(
   String* searchCriteria
) [];
[JScript]
public function GetFileNames(
   searchCriteria : String
) : String[];

Parameters

searchCriteria
Wildcard string expression describing matching files to the enumerated

Return Value

Array of strings corresponding to the relative pathnames of files in the isolated storage scope that matchsearchCriteria. A zero-lengthed array designates that no files matched.

Remarks

For complete description of search criteria strings see System.IO.Directory.

For directory names seeGetDirectoryNames method.

Example

The searchCriteria "foo\abc*.txt" will give all ".txt" files beginning with "abc" in the "foo" directory of the isolated storage scope.

See Also

IsolatedStorageFile Class | IsolatedStorageFile Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFile.GetStore

[To be supplied.]

Overload List

Represents isolated storage scope given application domain and assembly identity objects.

[Visual Basic] Overloads Public Shared Function GetStore(IsolatedStorageScope, Object, Object) As IsolatedStorageFile
[C#] public static IsolatedStorageFile GetStore(IsolatedStorageScope, Object, Object);
[C++] public: static IsolatedStorageFile* GetStore(IsolatedStorageScope, Object, Object);
[JScript] public static function GetStore(IsolatedStorageScope, Object, Object) : IsolatedStorageFile;

Represents isolated storage scope given application domain and assembly identity evidence types.

[Visual Basic] Overloads Public Shared Function GetStore(IsolatedStorageScope, Type, Type) As IsolatedStorageFile
[C#] public static IsolatedStorageFile GetStore(IsolatedStorageScope, Type, Type);
[C++] public: static IsolatedStorageFile* GetStore(IsolatedStorageScope, Type, Type);
[JScript] public static function GetStore(IsolatedStorageScope, Type, Type) : IsolatedStorageFile;

Requirements

NGWS Runtime Security:

IsolatedStorageFilePermission must have permission to access isolated storage by application domain identity

See Also

IsolatedStorageFile Class | IsolatedStorageFile Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFile.GetStore (IsolatedStorageScope, Object, Object)

Represents isolated storage scope given application domain and assembly identity objects.

[Visual Basic]
Overloads Public Shared Function GetStore( _
   ByVal scope As IsolatedStorageScope, _
   ByVal DomainIdentity As Object, _
   ByVal AssemblyIdentity As Object _
) As IsolatedStorageFile
[C#]
public static IsolatedStorageFile GetStore(
   IsolatedStorageScope scope,
   object DomainIdentity,
   object AssemblyIdentity
);
[C++]
public: static IsolatedStorageFile* GetStore(
   IsolatedStorageScope scope,
   Object* DomainIdentity,
   Object* AssemblyIdentity
);
[JScript]
public static function GetStore(
   scope : IsolatedStorageScope,
   DomainIdentity : Object,
   AssemblyIdentity : Object
) : IsolatedStorageFile;

Parameters

scope
specifies isolated storage scope for the store
DomainIdentity
[To be supplied.]
AssemblyIdentity
[To be supplied.]

Return Value

Newly initialized isolated store instance.

Exceptions

Exception Type | Condition
SecurityException | if sufficient isolated storage permission has not been granted

Remarks

This form of constructor is not usually used by application programs.

Requirements

NGWS Runtime Security:

IsolatedStorageFilePermission must have permission to access isolated storage by application domain identity

See Also

IsolatedStorageFile Class | IsolatedStorageFile Members | System.IO.IsolatedStorage Namespace | IsolatedStorageFile.GetStore Overload List


IsolatedStorageFile.GetStore (IsolatedStorageScope, Type, Type)

Represents isolated storage scope given application domain and assembly identity evidence types.

[Visual Basic]
Overloads Public Shared Function GetStore( _
   ByVal scope As IsolatedStorageScope, _
   ByVal DomainEvidenceType As Type, _
   ByVal AssemblyEvidenceType As Type _
) As IsolatedStorageFile
[C#]
public static IsolatedStorageFile GetStore(
   IsolatedStorageScope scope,
   Type DomainEvidenceType,
   Type AssemblyEvidenceType
);
[C++]
public: static IsolatedStorageFile* GetStore(
   IsolatedStorageScope scope,
   Type* DomainEvidenceType,
   Type* AssemblyEvidenceType
);
[JScript]
public static function GetStore(
   scope : IsolatedStorageScope,
   DomainEvidenceType : Type,
   AssemblyEvidenceType : Type
) : IsolatedStorageFile;

Parameters

scope
specifies isolated storage scope for the store
DomainEvidenceType
[To be supplied.]
AssemblyEvidenceType
[To be supplied.]

Return Value

Newly initialized isolated store instance.

Exceptions

Exception Type | Condition
SecurityException | if sufficient isolated storage permission has not been granted

Remarks

This form of constructor is not usually used by application programs.

Requirements

NGWS Runtime Security:

IsolatedStorageFilePermission must have permission to access isolated storage by application domain identity

See Also

IsolatedStorageFile Class | IsolatedStorageFile Members | System.IO.IsolatedStorage Namespace | IsolatedStorageFile.GetStore Overload List


IsolatedStorageFile.GetUserStoreForAssembly

Isolated storage corresponding to the code assembly identity.

[Visual Basic]
Public Shared Function GetUserStoreForAssembly() As _
   IsolatedStorageFile
[C#]
public static IsolatedStorageFile GetUserStoreForAssembly();
[C++]
public: static IsolatedStorageFile* GetUserStoreForAssembly();
[JScript]
public static function GetUserStoreForAssembly() :
   IsolatedStorageFile;

Return Value

Instance of IsolatedStorageFile corresponding to the isolated storage scope based on the code assembly identity.

Exceptions

Exception Type | Condition
SecurityException | if sufficient isolated storage permission has not been granted

Remarks

Different assemblies running within the same application domain will have distinct isolated storage scopes via this method.

Requirements

NGWS Runtime Security:

IsolatedStorageFilePermission must have permission to access isolated storage by application domain identity

See Also

IsolatedStorageFile Class | IsolatedStorageFile Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFile.GetUserStoreForDomain

Isolated storage corresponding to the application domain identity.

[Visual Basic]
Public Shared Function GetUserStoreForDomain() As _
   IsolatedStorageFile
[C#]
public static IsolatedStorageFile GetUserStoreForDomain();
[C++]
public: static IsolatedStorageFile* GetUserStoreForDomain();
[JScript]
public static function GetUserStoreForDomain() :
   IsolatedStorageFile;

Return Value

Instance of IsolatedStorageFile corresponding to the isolated storage scope based on the application domain identity.

Exceptions

Exception Type | Condition
SecurityException | if sufficient isolated storage permission has not been granted
IsolatedStorageFilePermission | if the necessary isolated storage file permission has not been granted

Remarks

Different assemblies running within the same application domain can refer to a common isolated storage scope via this method.

Requirements

NGWS Runtime Security:

IsolatedStorageFilePermission must have scope by application domain

See Also

IsolatedStorageFile Class | IsolatedStorageFile Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFile.Remove

[To be supplied.]

Overload List

Removes the isolated storage scope and all contents.

[Visual Basic] Overloads Overrides Public Sub Remove()
[C#] public override void Remove();
[C++] public: override void Remove();
[JScript] public override function Remove();

Removes the specified isolated storage scope and all

contents thereof.

[Visual Basic] Overloads Public Shared Sub Remove(IsolatedStorageScope)
[C#] public static void Remove(IsolatedStorageScope);
[C++] public: static void Remove(IsolatedStorageScope);
[JScript] public static function Remove(IsolatedStorageScope);

See Also

IsolatedStorageFile Class | IsolatedStorageFile Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFile.Remove ()

Removes the isolated storage scope and all contents.

[Visual Basic]
Overloads Overrides Public Sub Remove()
[C#]
public override void Remove();
[C++]
public: override void Remove();
[JScript]
public override function Remove();

Return Value

none

Remarks

Irrevocably removes the entire scope and all contained directories and files.

See Also

IsolatedStorageFile Class | IsolatedStorageFile Members | System.IO.IsolatedStorage Namespace | IsolatedStorageFile.Remove Overload List


IsolatedStorageFile.Remove (IsolatedStorageScope)

Removes the specified isolated storage scope and all

contents thereof.

[Visual Basic]
Overloads Public Shared Sub Remove( _
   ByVal scope As IsolatedStorageScope _
)
[C#]
public static void Remove(
   IsolatedStorageScope scope
);
[C++]
public: static void Remove(
   IsolatedStorageScope scope
);
[JScript]
public static function Remove(
   scope : IsolatedStorageScope
);

Parameters

scope
which scope of isolated storage to be removed

Return Value

none

Remarks

Irrevocably removes the entire scope and all contained directories and files.

See Also

IsolatedStorageFile Class | IsolatedStorageFile Members | System.IO.IsolatedStorage Namespace | IsolatedStorageFile.Remove Overload List


IsolatedStorageFileStream Class

Exposes a file within isolated storage.

Object
Stream
FileStream
IsolatedStorageFileStream

[Visual Basic]
Public Class IsolatedStorageFileStream
   Inherits FileStream
[C#]
public class IsolatedStorageFileStream : FileStream
[C++]
public __gc class IsolatedStorageFileStream : public FileStream
[JScript]
public class IsolatedStorageFileStream extends FileStream

Remarks

Use this class to actually read and write files in isolated storage.

Requirements

Namespace: System.IO.IsolatedStorage

Assembly: mscorlib.dll

See Also

IsolatedStorageFileStream Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFileStream Members

Public:

Constructor

IsolatedStorageFileStream Constructor Overloaded. [To be supplied.]

Properties

CanRead | [To be supplied.]
CanSeek | Property tells if file can be read.
CanWrite | Property tells if file can be read.
DataAvailable | Property tells if there is data available to be read or not.
Length | Returns the length in bytes of the stream.
Position | Retrieves the current position of this stream, or sets the current position of this stream to the given value.

Methods

BeginRead | (not supported for isolated storage)
BeginWrite | (not supported for isolated storage)
Close | Releases resources associated with the isolated storage file stream.
EndRead | (not supported for isolated storage)
EndWrite | (not supported for isolated storage)
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Flush | Updates the file with the current state of the buffer and subsequently clears the buffer.
GetHandle | Gets the file handle for the file that the current IsolatedStorageFileStream object encapsulates.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Lock (inherited from FileStream) | Prevents access by other processes to all or part of a file.
Read | Reads a string of bytes from the IsolatedStorageFileStream in isolated storage.
ReadByte | Reads a single byte from the IsolatedStorageFileStream in isolated storage.
Seek | Sets the current position of this stream to the given value. While some streams may support positioning beyond the length of the stream, others will throw an exception in this case.
SetLength | Sets the length of this stream to the given value. If the given value is less than the current length of the stream, the stream is truncated. If the given value is larger than the current length of the stream, the stream is expanded. If the stream is expanded, the contents of the stream between the old and the new length are undefined. A stream must support both writing and seeking for this method to be operational.
ToString (inherited from Object) | Returns a String that represents the current Object.
Unlock (inherited from FileStream) | Allows access by other processes to all or part of a file that was previously locked.
Write | Writes a block of bytes to this stream using data read from a buffer. The buffer parameter can be an instance of the Buffer class, or an array of one of the following types: Byte, SByte, Char, Int16, Int32, Int64, UInt16, UInt32, UInt64, Single, or Double. The offset parameter gives the offset of the byte in buffer at which to begin reading, and the count parameter gives the maximum number of bytes that will be written to this stream. If the write operation is successful, the current position of the stream is advanced by the number of bytes written. If an exception occurs, the current position of the stream is unchanged. The Write method treats the buffer parameter as a block of bytes, regardless of its actual type. Likewise, the offset and count parameters are always specified in bytes. For buffer parameters other than byte arrays, this means that an element index must be multiplied by the element size in bytes to form a correct value for offset or count.
WriteByte | Writes a single byte to the IsolatedStorageFileStream in isolated storage.

Protected:

Methods

CreateWaitHandle (inherited from Stream) | Allocates a WaitHandle object efficiently.
Finalize | Called by the garbage collector when the current object is ready to be finalized.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IsolatedStorageFileStream Class | System.IO.IsolatedStorage Namespace


IsolatedStorageFileStream Constructor

[To be supplied.]

Overload List

Initializes a new instance of an IsolatedStorageFileStream object giving access to the file designated by path in the specified mode. Mode indicates if a new file should be created, an existing one used, and so forth.

[Visual Basic] Overloads Public Sub New(String, FileMode)
[C#] public IsolatedStorageFileStream(String, FileMode);
[C++] public: IsolatedStorageFileStream(String*, FileMode);
[JScript] public function IsolatedStorageFileStream(String, FileMode);

Initializes a new instance of an IsolatedStorageFileStream object giving access to the file designated by path in the specified mode in the context of the isolated storage specified. Mode indicates if a new file should be created, an existing one used, and so forth.

[Visual Basic] Overloads Public Sub New(String, FileMode, IsolatedStorageFile)
[C#] public IsolatedStorageFileStream(String, FileMode, IsolatedStorageFile);
[C++] public: IsolatedStorageFileStream(String*, FileMode, IsolatedStorageFile);
[JScript] public function IsolatedStorageFileStream(String, FileMode, IsolatedStorageFile);

Initializes a new instance of an IsolatedStorageFileStream object giving access to the file designated by path in the specified mode, with the kind of access requested. Mode indicates if a new file should be created, an existing one used, and so forth. Access includes read-only, read-write, etc.

[Visual Basic] Overloads Public Sub New(String, FileMode, FileAccess)
[C#] public IsolatedStorageFileStream(String, FileMode, FileAccess);
[C++] public: IsolatedStorageFileStream(String*, FileMode, FileAccess);
[JScript] public function IsolatedStorageFileStream(String, FileMode, FileAccess);

Initializes a new instance of an IsolatedStorageFileStream object giving access to the file designated by path in the specified mode. Mode indicates if a new file should be created, an existing one used, and so forth. Access includes read-only, read-write, etc.

[Visual Basic] Overloads Public Sub New(String, FileMode, FileAccess, IsolatedStorageFile)
[C#] public IsolatedStorageFileStream(String, FileMode, FileAccess, IsolatedStorageFile);
[C++] public: IsolatedStorageFileStream(String*, FileMode, FileAccess, IsolatedStorageFile);
[JScript] public function IsolatedStorageFileStream(String, FileMode, FileAccess, IsolatedStorageFile);

Initializes a new instance of an IsolatedStorageFileStream object giving access to the file designated by path in the specified mode (read-only, etc.). Mode indicates if a new file should be created, an existing one used, and so forth. Access includes read-only, read-write, etc.

[Visual Basic] Overloads Public Sub New(String, FileMode, FileAccess, FileShare)
[C#] public IsolatedStorageFileStream(String, FileMode, FileAccess, FileShare);
[C++] public: IsolatedStorageFileStream(String*, FileMode, FileAccess, FileShare);
[JScript] public function IsolatedStorageFileStream(String, FileMode, FileAccess, FileShare);

Initializes a new instance of an IsolatedStorageFileStream object giving access to the file designated by path in the specified mode. Mode indicates if a new file should be created, an existing one used, and so forth. Access includes read-only, read-write, etc.

[Visual Basic] Overloads Public Sub New(String, FileMode, FileAccess, FileShare, IsolatedStorageFile)
[C#] public IsolatedStorageFileStream(String, FileMode, FileAccess, FileShare, IsolatedStorageFile);
[C++] public: IsolatedStorageFileStream(String*, FileMode, FileAccess, FileShare, IsolatedStorageFile);
[JScript] public function IsolatedStorageFileStream(String, FileMode, FileAccess, FileShare, IsolatedStorageFile);

Initializes a new instance of an IsolatedStorageFileStream object giving access to the file designated by path in the specified mode, access, and share option, with buffer size specified. Mode indicates if a new file should be created, an existing one used, and so forth. Access includes read-only, read-write, etc.

[Visual Basic] Overloads Public Sub New(String, FileMode, FileAccess, FileShare, Integer)
[C#] public IsolatedStorageFileStream(String, FileMode, FileAccess, FileShare, int);
[C++] public: IsolatedStorageFileStream(String*, FileMode, FileAccess, FileShare, int);
[JScript] public function IsolatedStorageFileStream(String, FileMode, FileAccess, FileShare, int);

Initializes a new instance of an IsolatedStorageFileStream object giving access to the file designated by path in the specified mode, access, and share option, with buffer size specified, in a given isolated storage context. Mode indicates if a new file should be created, an existing one used, and so forth. Access includes read-only, read-write, etc.

[Visual Basic] Overloads Public Sub New(String, FileMode, FileAccess, FileShare, Integer, IsolatedStorageFile)
[C#] public IsolatedStorageFileStream(String, FileMode, FileAccess, FileShare, int, IsolatedStorageFile);
[C++] public: IsolatedStorageFileStream(String*, FileMode, FileAccess, FileShare, int, IsolatedStorageFile);
[JScript] public function IsolatedStorageFileStream(String, FileMode, FileAccess, FileShare, int, IsolatedStorageFile);

Requirements

NGWS Runtime Security:

IsolatedStorage code must have isolated storage access

See Also

IsolatedStorageFileStream Class | IsolatedStorageFileStream Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFileStream Constructor (String, FileMode)

Initializes a new instance of an IsolatedStorageFileStream object giving access to the file designated by path in the specified mode. Mode indicates if a new file should be created, an existing one used, and so forth.

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As String, _
   ByVal mode As FileMode _
)
[C#]
public IsolatedStorageFileStream(
   string path,
   FileMode mode
);
[C++]
public: IsolatedStorageFileStream(
   String* path,
   FileMode mode
);
[JScript]
public function IsolatedStorageFileStream(
   path : String,
   mode : FileMode
);

Parameters

path
relative path within isolated storage of the file
mode
[To be supplied.]

Remarks

Not only much code have the necessary IsolatedStoragePermission, but it must have identity in order to access a particular isolated storage instance.

Requirements

NGWS Runtime Security:

IsolatedStorage code must have isolated storage access

See Also

IsolatedStorageFileStream Class | IsolatedStorageFileStream Members | System.IO.IsolatedStorage Namespace | IsolatedStorageFileStream Constructor Overload List


IsolatedStorageFileStream Constructor (String, FileMode, IsolatedStorageFile)

Initializes a new instance of an IsolatedStorageFileStream object giving access to the file designated by path in the specified mode in the context of the isolated storage specified. Mode indicates if a new file should be created, an existing one used, and so forth.

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As String, _
   ByVal mode As FileMode, _
   ByVal isf As IsolatedStorageFile _
)
[C#]
public IsolatedStorageFileStream(
   string path,
   FileMode mode,
   IsolatedStorageFile isf
);
[C++]
public: IsolatedStorageFileStream(
   String* path,
   FileMode mode,
   IsolatedStorageFile* isf
);
[JScript]
public function IsolatedStorageFileStream(
   path : String,
   mode : FileMode,
   isf : IsolatedStorageFile
);

Parameters

path
relative path within isolated storage of the file
mode
[To be supplied.]
isf
[To be supplied.]

Remarks

Not only much code have the necessary IsolatedStoragePermission, but it must have identity in order to access a particular isolated storage instance.

Requirements

NGWS Runtime Security:

IsolatedStorage code must have isolated storage access

See Also

IsolatedStorageFileStream Class | IsolatedStorageFileStream Members | System.IO.IsolatedStorage Namespace | IsolatedStorageFileStream Constructor Overload List


IsolatedStorageFileStream Constructor (String, FileMode, FileAccess)

Initializes a new instance of an IsolatedStorageFileStream object giving access to the file designated by path in the specified mode, with the kind of access requested. Mode indicates if a new file should be created, an existing one used, and so forth. Access includes read-only, read-write, etc.

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As String, _
   ByVal mode As FileMode, _
   ByVal access As FileAccess _
)
[C#]
public IsolatedStorageFileStream(
   string path,
   FileMode mode,
   FileAccess access
);
[C++]
public: IsolatedStorageFileStream(
   String* path,
   FileMode mode,
   FileAccess access
);
[JScript]
public function IsolatedStorageFileStream(
   path : String,
   mode : FileMode,
   access : FileAccess
);

Parameters

path
relative path within isolated storage of the file
mode
[To be supplied.]
access
[To be supplied.]

Remarks

Not only much code have the necessary IsolatedStoragePermission, but it must have identity in order to access a particular isolated storage instance.

Requirements

NGWS Runtime Security:

IsolatedStorage code must have isolated storage access

See Also

IsolatedStorageFileStream Class | IsolatedStorageFileStream Members | System.IO.IsolatedStorage Namespace | IsolatedStorageFileStream Constructor Overload List


IsolatedStorageFileStream Constructor (String, FileMode, FileAccess, IsolatedStorageFile)

Initializes a new instance of an IsolatedStorageFileStream object giving access to the file designated by path in the specified mode. Mode indicates if a new file should be created, an existing one used, and so forth. Access includes read-only, read-write, etc.

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As String, _
   ByVal mode As FileMode, _
   ByVal access As FileAccess, _
   ByVal isf As IsolatedStorageFile _
)
[C#]
public IsolatedStorageFileStream(
   string path,
   FileMode mode,
   FileAccess access,
   IsolatedStorageFile isf
);
[C++]
public: IsolatedStorageFileStream(
   String* path,
   FileMode mode,
   FileAccess access,
   IsolatedStorageFile* isf
);
[JScript]
public function IsolatedStorageFileStream(
   path : String,
   mode : FileMode,
   access : FileAccess,
   isf : IsolatedStorageFile
);

Parameters

path
relative path within isolated storage of the file
mode
[To be supplied.]
access
[To be supplied.]
isf
[To be supplied.]

Remarks

Not only much code have the necessary IsolatedStoragePermission, but it must have identity in order to access a particular isolated storage instance.

Requirements

NGWS Runtime Security:

IsolatedStorage code must have isolated storage access

See Also

IsolatedStorageFileStream Class | IsolatedStorageFileStream Members | System.IO.IsolatedStorage Namespace | IsolatedStorageFileStream Constructor Overload List


IsolatedStorageFileStream Constructor (String, FileMode, FileAccess, FileShare)

Initializes a new instance of an IsolatedStorageFileStream object giving access to the file designated by path in the specified mode (read-only, etc.). Mode indicates if a new file should be created, an existing one used, and so forth. Access includes read-only, read-write, etc.

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As String, _
   ByVal mode As FileMode, _
   ByVal access As FileAccess, _
   ByVal share As FileShare _
)
[C#]
public IsolatedStorageFileStream(
   string path,
   FileMode mode,
   FileAccess access,
   FileShare share
);
[C++]
public: IsolatedStorageFileStream(
   String* path,
   FileMode mode,
   FileAccess access,
   FileShare share
);
[JScript]
public function IsolatedStorageFileStream(
   path : String,
   mode : FileMode,
   access : FileAccess,
   share : FileShare
);

Parameters

path
relative path within isolated storage of the file
mode
[To be supplied.]
access
[To be supplied.]
share
[To be supplied.]

Remarks

Not only much code have the necessary IsolatedStoragePermission, but it must have identity in order to access a particular isolated storage instance.

Requirements

NGWS Runtime Security:

IsolatedStorage code must have isolated storage access

See Also

IsolatedStorageFileStream Class | IsolatedStorageFileStream Members | System.IO.IsolatedStorage Namespace | IsolatedStorageFileStream Constructor Overload List


IsolatedStorageFileStream Constructor (String, FileMode, FileAccess, FileShare, IsolatedStorageFile)

Initializes a new instance of an IsolatedStorageFileStream object giving access to the file designated by path in the specified mode. Mode indicates if a new file should be created, an existing one used, and so forth. Access includes read-only, read-write, etc.

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As String, _
   ByVal mode As FileMode, _
   ByVal access As FileAccess, _
   ByVal share As FileShare, _
   ByVal isf As IsolatedStorageFile _
)
[C#]
public IsolatedStorageFileStream(
   string path,
   FileMode mode,
   FileAccess access,
   FileShare share,
   IsolatedStorageFile isf
);
[C++]
public: IsolatedStorageFileStream(
   String* path,
   FileMode mode,
   FileAccess access,
   FileShare share,
   IsolatedStorageFile* isf
);
[JScript]
public function IsolatedStorageFileStream(
   path : String,
   mode : FileMode,
   access : FileAccess,
   share : FileShare,
   isf : IsolatedStorageFile
);

Parameters

path
relative path within isolated storage of the file
mode
[To be supplied.]
access
[To be supplied.]
share
[To be supplied.]
isf
[To be supplied.]

Remarks

Not only much code have the necessary IsolatedStoragePermission, but it must have identity in order to access a particular isolated storage instance.

Requirements

NGWS Runtime Security:

IsolatedStorage code must have isolated storage access

See Also

IsolatedStorageFileStream Class | IsolatedStorageFileStream Members | System.IO.IsolatedStorage Namespace | IsolatedStorageFileStream Constructor Overload List


IsolatedStorageFileStream Constructor (String, FileMode, FileAccess, FileShare, Int32)

Initializes a new instance of an IsolatedStorageFileStream object giving access to the file designated by path in the specified mode, access, and share option, with buffer size specified. Mode indicates if a new file should be created, an existing one used, and so forth. Access includes read-only, read-write, etc.

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As String, _
   ByVal mode As FileMode, _
   ByVal access As FileAccess, _
   ByVal share As FileShare, _
   ByVal bufferSize As Integer _
)
[C#]
public IsolatedStorageFileStream(
   string path,
   FileMode mode,
   FileAccess access,
   FileShare share,
   int bufferSize
);
[C++]
public: IsolatedStorageFileStream(
   String* path,
   FileMode mode,
   FileAccess access,
   FileShare share,
   int bufferSize
);
[JScript]
public function IsolatedStorageFileStream(
   path : String,
   mode : FileMode,
   access : FileAccess,
   share : FileShare,
   bufferSize : int
);

Parameters

path
relative path within isolated storage of the file
mode
[To be supplied.]
access
[To be supplied.]
share
[To be supplied.]
bufferSize
[To be supplied.]

Remarks

Not only much code have the necessary IsolatedStoragePermission, but it must have identity in order to access a particular isolated storage instance.

Requirements

NGWS Runtime Security:

IsolatedStorage code must have isolated storage access

See Also

IsolatedStorageFileStream Class | IsolatedStorageFileStream Members | System.IO.IsolatedStorage Namespace | IsolatedStorageFileStream Constructor Overload List


IsolatedStorageFileStream Constructor (String, FileMode, FileAccess, FileShare, Int32, IsolatedStorageFile)

Initializes a new instance of an IsolatedStorageFileStream object giving access to the file designated by path in the specified mode, access, and share option, with buffer size specified, in a given isolated storage context. Mode indicates if a new file should be created, an existing one used, and so forth. Access includes read-only, read-write, etc.

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As String, _
   ByVal mode As FileMode, _
   ByVal access As FileAccess, _
   ByVal share As FileShare, _
   ByVal bufferSize As Integer, _
   ByVal isf As IsolatedStorageFile _
)
[C#]
public IsolatedStorageFileStream(
   string path,
   FileMode mode,
   FileAccess access,
   FileShare share,
   int bufferSize,
   IsolatedStorageFile isf
);
[C++]
public: IsolatedStorageFileStream(
   String* path,
   FileMode mode,
   FileAccess access,
   FileShare share,
   int bufferSize,
   IsolatedStorageFile* isf
);
[JScript]
public function IsolatedStorageFileStream(
   path : String,
   mode : FileMode,
   access : FileAccess,
   share : FileShare,
   bufferSize : int,
   isf : IsolatedStorageFile
);

Parameters

path
relative path within isolated storage of the file
mode
file open mode requested
access
file access requested
share
file sharing requested
bufferSize
specified buffer size
isf
isolated storage context to open in

Remarks

Not only much code have the necessary IsolatedStoragePermission, but it must have identity in order to access a particular isolated storage instance.

Requirements

NGWS Runtime Security:

IsolatedStorage code must have isolated storage access

See Also

IsolatedStorageFileStream Class | IsolatedStorageFileStream Members | System.IO.IsolatedStorage Namespace | IsolatedStorageFileStream Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IsolatedStorageFileStream Properties

The properties of the IsolatedStorageFileStream class are listed below. For a complete list of IsolatedStorageFileStream class members, see the IsolatedStorageFileStream Members topic.

Public:

CanRead | [To be supplied.]
CanSeek | Property tells if file can be read.
CanWrite | Property tells if file can be read.
DataAvailable | Property tells if there is data available to be read or not.
Length | Returns the length in bytes of the stream.
Position | Retrieves the current position of this stream, or sets the current position of this stream to the given value.

See Also

IsolatedStorageFileStream Class | System.IO.IsolatedStorage Namespace


IsolatedStorageFileStream.CanRead

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property CanRead As Boolean
[C#]
public bool CanRead {override get;}
[C++]
public: __property virtual bool get_CanRead();
[JScript]
public function get CanRead() : Boolean;

See Also

IsolatedStorageFileStream Class | IsolatedStorageFileStream Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFileStream.CanSeek

Property tells if file can be read.

[Visual Basic]
Overridable Public ReadOnly Property CanSeek As Boolean
[C#]
public bool CanSeek {override get;}
[C++]
public: __property virtual bool get_CanSeek();
[JScript]
public function get CanSeek() : Boolean;

Property Value

True for isolated storage files that supports seek operations.

Remarks

Use this property to determine if the isolated storage file stream supports seek operations or not.

See Also

IsolatedStorageFileStream Class | IsolatedStorageFileStream Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFileStream.CanWrite

Property tells if file can be read.

[Visual Basic]
Overridable Public ReadOnly Property CanWrite As Boolean
[C#]
public bool CanWrite {override get;}
[C++]
public: __property virtual bool get_CanWrite();
[JScript]
public function get CanWrite() : Boolean;

Property Value

True for isolated storage files that can be written.

Remarks

Use this property to determine if the isolated storage file stream can be written.

See Also

IsolatedStorageFileStream Class | IsolatedStorageFileStream Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFileStream.DataAvailable

Property tells if there is data available to be read or not.

[Visual Basic]
Overridable Public ReadOnly Property DataAvailable As Boolean
[C#]
public bool DataAvailable {override get;}
[C++]
public: __property virtual bool get_DataAvailable();
[JScript]
public function get DataAvailable() : Boolean;

Property Value

True when isolated storage file has data available or not.

Remarks

Use this property to determine if the isolated storage file stream can be read.

See Also

IsolatedStorageFileStream Class | IsolatedStorageFileStream Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFileStream.Length

Returns the length in bytes of the stream.

[Visual Basic]
Overridable Public ReadOnly Property Length As Long
[C#]
public long Length {override get;}
[C++]
public: __property virtual __int64 get_Length();
[JScript]
public function get Length() : long;

Property Value

A long value representing the length of the stream in bytes.

Remarks

Length represents the number of bytes currently in the file. It is not affected by isolated storage quota.

See Also

IsolatedStorageFileStream Class | IsolatedStorageFileStream Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFileStream.Position

Retrieves the current position of this stream, or sets the current position of this stream to the given value.

[Visual Basic]
Overridable Public Property Position As Long
[C#]
public long Position {override get; override set;}
[C++]
public: __property virtual __int64 get_Position();
public: __property virtual void set_Position(__int64);
[JScript]
public function get Position() : long;
public function set Position(long);

Property Value

Get returns the current position of this stream.Set sets the current position of this stream to the given value.

Remarks

Setting this property works when CanSeek property is true.

See Also

IsolatedStorageFileStream Class | IsolatedStorageFileStream Members | System.IO.IsolatedStorage Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IsolatedStorageFileStream Methods

The methods of the IsolatedStorageFileStream class are listed below. For a complete list of IsolatedStorageFileStream class members, see the IsolatedStorageFileStream Members topic.

Public:

BeginRead | (not supported for isolated storage)
BeginWrite | (not supported for isolated storage)
Close | Releases resources associated with the isolated storage file stream.
EndRead | (not supported for isolated storage)
EndWrite | (not supported for isolated storage)
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Flush | Updates the file with the current state of the buffer and subsequently clears the buffer.
GetHandle | Gets the file handle for the file that the current IsolatedStorageFileStream object encapsulates.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Lock (inherited from FileStream) | Prevents access by other processes to all or part of a file.
Read | Reads a string of bytes from the IsolatedStorageFileStream in isolated storage.
ReadByte | Reads a single byte from the IsolatedStorageFileStream in isolated storage.
Seek | Sets the current position of this stream to the given value. While some streams may support positioning beyond the length of the stream, others will throw an exception in this case.
SetLength | Sets the length of this stream to the given value. If the given value is less than the current length of the stream, the stream is truncated. If the given value is larger than the current length of the stream, the stream is expanded. If the stream is expanded, the contents of the stream between the old and the new length are undefined. A stream must support both writing and seeking for this method to be operational.
ToString (inherited from Object) | Returns a String that represents the current Object.
Unlock (inherited from FileStream) | Allows access by other processes to all or part of a file that was previously locked.
Write | Writes a block of bytes to this stream using data read from a buffer. The buffer parameter can be an instance of the Buffer class, or an array of one of the following types: Byte, SByte, Char, Int16, Int32, Int64, UInt16, UInt32, UInt64, Single, or Double. The offset parameter gives the offset of the byte in buffer at which to begin reading, and the count parameter gives the maximum number of bytes that will be written to this stream. If the write operation is successful, the current position of the stream is advanced by the number of bytes written. If an exception occurs, the current position of the stream is unchanged. The Write method treats the buffer parameter as a block of bytes, regardless of its actual type. Likewise, the offset and count parameters are always specified in bytes. For buffer parameters other than byte arrays, this means that an element index must be multiplied by the element size in bytes to form a correct value for offset or count.
WriteByte | Writes a single byte to the IsolatedStorageFileStream in isolated storage.

Protected:

CreateWaitHandle (inherited from Stream) | Allocates a WaitHandle object efficiently.
Finalize | Called by the garbage collector when the current object is ready to be finalized.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IsolatedStorageFileStream Class | System.IO.IsolatedStorage Namespace


IsolatedStorageFileStream.BeginRead

(not supported for isolated storage)

[Visual Basic]
Overrides Public Function BeginRead( _
   ByVal b() As Byte, _
   ByVal offset As Integer, _
   ByVal numBytes As Integer, _
   ByVal cb As AsyncCallback, _
   ByVal stateObject As Object _
) As IAsyncResult
[C#]
public override IAsyncResult BeginRead(
   byte[] b,
   int offset,
   int numBytes,
   AsyncCallback cb,
   object stateObject
);
[C++]
public: override IAsyncResult* BeginRead(
   unsigned char* b[],
   int offset,
   int numBytes,
   AsyncCallback* cb,
   Object* stateObject
);
[JScript]
public override function BeginRead(
   b : Byte[],
   offset : int,
   numBytes : int,
   cb : AsyncCallback,
   stateObject : Object
) : IAsyncResult;

Parameters

b
[To be supplied.]
offset
[To be supplied.]
numBytes
[To be supplied.]
cb
[To be supplied.]
stateObject
[To be supplied.]

See Also

IsolatedStorageFileStream Class | IsolatedStorageFileStream Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFileStream.BeginWrite

(not supported for isolated storage)

[Visual Basic]
Overrides Public Function BeginWrite( _
   ByVal b() As Byte, _
   ByVal offset As Integer, _
   ByVal numBytes As Integer, _
   ByVal cb As AsyncCallback, _
   ByVal stateObject As Object _
) As IAsyncResult
[C#]
public override IAsyncResult BeginWrite(
   byte[] b,
   int offset,
   int numBytes,
   AsyncCallback cb,
   object stateObject
);
[C++]
public: override IAsyncResult* BeginWrite(
   unsigned char* b[],
   int offset,
   int numBytes,
   AsyncCallback* cb,
   Object* stateObject
);
[JScript]
public override function BeginWrite(
   b : Byte[],
   offset : int,
   numBytes : int,
   cb : AsyncCallback,
   stateObject : Object
) : IAsyncResult;

Parameters

b
[To be supplied.]
offset
[To be supplied.]
numBytes
[To be supplied.]
cb
[To be supplied.]
stateObject
[To be supplied.]

See Also

IsolatedStorageFileStream Class | IsolatedStorageFileStream Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFileStream.Close

Releases resources associated with the isolated storage file stream.

[Visual Basic]
Overrides Public Sub Close()
[C#]
public override void Close();
[C++]
public: override void Close();
[JScript]
public override function Close();

Remarks

Any data previously written to the buffer is copied to the file before the file stream is closed, so it is not necessary to call Flush before invoking Close.

Following a call to Close, any operations on the file stream may raise exceptions. After Close has been called once, it does nothing if called again. The Finalize method invokes Close so that the file stream is closed before the garbage collector finalizes the object.

See Also

IsolatedStorageFileStream Class | IsolatedStorageFileStream Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFileStream.EndRead

(not supported for isolated storage)

[Visual Basic]
Overrides Public Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
[C#]
public override int EndRead(
   IAsyncResult asyncResult
);
[C++]
public: override int EndRead(
   IAsyncResult* asyncResult
);
[JScript]
public override function EndRead(
   asyncResult : IAsyncResult
) : int;

Parameters

asyncResult
[To be supplied.]

See Also

IsolatedStorageFileStream Class | IsolatedStorageFileStream Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFileStream.EndWrite

(not supported for isolated storage)

[Visual Basic]
Overrides Public Function EndWrite( _
   ByVal asyncResult As IAsyncResult _
) As Integer
[C#]
public override int EndWrite(
   IAsyncResult asyncResult
);
[C++]
public: override int EndWrite(
   IAsyncResult* asyncResult
);
[JScript]
public override function EndWrite(
   asyncResult : IAsyncResult
) : int;

Parameters

asyncResult
[To be supplied.]

See Also

IsolatedStorageFileStream Class | IsolatedStorageFileStream Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFileStream.Finalize

Called by the garbage collector when the current object is ready to be finalized.

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

Return Value

none

Remarks

Overrides Object.Finalize.

See Also

IsolatedStorageFileStream Class | IsolatedStorageFileStream Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFileStream.Flush

Updates the file with the current state of the buffer and subsequently clears the buffer.

[Visual Basic]
Overrides Public Sub Flush()
[C#]
public override void Flush();
[C++]
public: override void Flush();
[JScript]
public override function Flush();

Remarks

Because a buffer can be used for either reading or writing, but not both simultaneously, Flush performs two functions. First, any data previously written to the buffer is copied to the file and the buffer is cleared. Second, if CanSeek is true and data was previously copied from the file to the buffer for reading, the current position within the file is decremented by the number of unread bytes in the buffer. The buffer is then cleared.

See Also

IsolatedStorageFileStream Class | IsolatedStorageFileStream Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFileStream.GetHandle

Gets the file handle for the file that the current IsolatedStorageFileStream object encapsulates.

[Visual Basic]
Overrides Public Function GetHandle() As Integer
[C#]
public override int GetHandle();
[C++]
public: override int GetHandle();
[JScript]
public override function GetHandle() : int;

Return Value

The file handle for the file that the current IsolatedStorageFileStream object encapsulates.

Remarks

For more detail see System.IO.FileStream.GetHandle().

See Also

IsolatedStorageFileStream Class | IsolatedStorageFileStream Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFileStream.Read

Reads a string of bytes from the IsolatedStorageFileStream in isolated storage.

[Visual Basic]
Overrides Public Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
[C#]
public override int Read(
   byte[] buffer,
   int offset,
   int count
);
[C++]
public: override int Read(
   unsigned char* buffer[],
   int offset,
   int count
);
[JScript]
public override function Read(
   buffer : Byte[],
   offset : int,
   count : int
) : int;

Parameters

buffer
buffer to read into
offset
[To be supplied.]
count
[To be supplied.]

Return Value

The total number of bytes read into the buffer. This may be less than the number of bytes requested if that many bytes aren't currently available, or zero if the end of the stream is reached.

Remarks

The buffer parameter can be an instance of the Buffer class, or an array of one of the following types: Byte, SByte, Char, Int16, Int32, Int64, UInt16, UInt32, UInt64, Single, or Double. The offset parameter gives the offset of the byte in buffer at which to begin writing (index in the buffer), and the count parameter gives the maximum number of bytes that will be read from this stream. The returned value is the actual number of bytes read, or zero if the end of the stream is reached. If the read operation is successful, the current position of the stream is advanced by the number of bytes read. If an exception occurs, the current position of the stream is unchanged.

The Read method treats the buffer parameter as a block of bytes, regardless of its actual type. Likewise, the offset and count parameters are always specified in bytes. For buffer parameters other than byte arrays, this means that an element index must be multiplied by the element size in bytes to form a correct value for offset or count.

The Read method will return zero only if the end of the stream is reached. In all other cases, Read always reads at least one byte from the stream before returning. If no data is available from the stream upon a call to Read, the method will block until at least one byte of data can be returned.

See Also

IsolatedStorageFileStream Class | IsolatedStorageFileStream Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFileStream.ReadByte

Reads a single byte from the IsolatedStorageFileStream in isolated storage.

[Visual Basic]
Overrides Public Function ReadByte() As Integer
[C#]
public override int ReadByte();
[C++]
public: override int ReadByte();
[JScript]
public override function ReadByte() : int;

Return Value

Byte value read from the isolated storage file.

See Also

IsolatedStorageFileStream Class | IsolatedStorageFileStream Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFileStream.Seek

Sets the current position of this stream to the given value. While some streams may support positioning beyond the length of the stream, others will throw an exception in this case.

[Visual Basic]
Overrides Public Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
[C#]
public override long Seek(
   long offset,
   SeekOrigin origin
);
[C++]
public: override __int64 Seek(
   __int64 offset,
   SeekOrigin origin
);
[JScript]
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;

Parameters

offset
The new position of the stream.
origin
[To be supplied.]

Return Value

The new position in the stream.

See Also

IsolatedStorageFileStream Class | IsolatedStorageFileStream Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFileStream.SetLength

Sets the length of this stream to the given value. If the given value is less than the current length of the stream, the stream is truncated. If the given value is larger than the current length of the stream, the stream is expanded. If the stream is expanded, the contents of the stream between the old and the new length are undefined. A stream must support both writing and seeking for this method to be operational.

[Visual Basic]
Overrides Public Sub SetLength( _
   ByVal value As Long _
)
[C#]
public override void SetLength(
   long value
);
[C++]
public: override void SetLength(
   __int64 value
);
[JScript]
public override function SetLength(
   value : long
);

Parameters

value
The new length of the stream.

See Also

IsolatedStorageFileStream Class | IsolatedStorageFileStream Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFileStream.Write

Writes a block of bytes to this stream using data read from a buffer. The buffer parameter can be an instance of the Buffer class, or an array of one of the following types: Byte, SByte, Char, Int16, Int32, Int64, UInt16, UInt32, UInt64, Single, or Double. The offset parameter gives the offset of the byte in buffer at which to begin reading, and the count parameter gives the maximum number of bytes that will be written to this stream. If the write operation is successful, the current position of the stream is advanced by the number of bytes written. If an exception occurs, the current position of the stream is unchanged.

The Write method treats the buffer parameter as a block of bytes, regardless of its actual type. Likewise, the offset and count parameters are always specified in bytes. For buffer parameters other than byte arrays, this means that an element index must be multiplied by the element size in bytes to form a correct value for offset or count.

[Visual Basic]
Overrides Public Function Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
[C#]
public override int Write(
   byte[] buffer,
   int offset,
   int count
);
[C++]
public: override int Write(
   unsigned char* buffer[],
   int offset,
   int count
);
[JScript]
public override function Write(
   buffer : Byte[],
   offset : int,
   count : int
) : int;

Parameters

buffer
buffer to write from
offset
[To be supplied.]
count
[To be supplied.]

Return Value

Number of bytes written.

See Also

IsolatedStorageFileStream Class | IsolatedStorageFileStream Members | System.IO.IsolatedStorage Namespace


IsolatedStorageFileStream.WriteByte

Writes a single byte to the IsolatedStorageFileStream in isolated storage.

[Visual Basic]
Overrides Public Sub WriteByte( _
   ByVal value As Byte _
)
[C#]
public override void WriteByte(
   byte value
);
[C++]
public: override void WriteByte(
   unsigned char value
);
[JScript]
public override function WriteByte(
   value : Byte
);

Parameters

value
byte value to write to the isolated storage file

Return Value

(none)

See Also

IsolatedStorageFileStream Class | IsolatedStorageFileStream Members | System.IO.IsolatedStorage Namespace


IsolatedStorageScope Enumeration

Enumerates the levels of isolated storage scope supported. Combinations of the levels may be specified

[Visual Basic]
Public Enum IsolatedStorageScope
[C#]
public enum IsolatedStorageScope
[C++]
public enum IsolatedStorageScope

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

Use IsolatedStorageScope to specify the scoping to designate an isolated storage context for storing data files.

Members

Member Name | Description
Assembly | Indicates isolated storage scoped to the identity of the assembly.
Domain | Indicates isolated storage scoped to the application domain identity.
None | Indicates no isolated storage usage.
User | Indicates isolated storage scoped by user identity.

Requirements

Namespace: System.IO.IsolatedStorage

Assembly: mscorlib.dll

See Also

System.IO.IsolatedStorage Namespace


System.Messaging

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Messaging Namespace

Classes

Class | Description
ActiveXMessageFormatter | Formatter class that serializes and deserializes primitives into and from MessageQueue messages using binary format.
BinaryMessageFormatter | Formatter class that serializes and deserializes objects into and from MessageQueue messages using binary format.
DataSetMessageFormatter | Formatter class that serializes and deserializes datasets into and from MessageQueue messages using Xml.
DataSetMessageFormatter.TargetTypeEditor | Used to edit DataSet target types in the property browser.
DefaultPropertiesToSend | Specifies the default property values that will be used when sending objects using the message queue.
Message | Provides access to the properties needed to define a Message Queuing message.
MessagePropertyFilter | The property filter class is used to limit the properties retrieved when receiving messages from a queue. Getting a limitied set of properties helps improving performance.
MessageQueue | Provides access to a Message Queuing backend queue resource.
MessageQueueCriteria | This class is used to filter MessageQueues when performing a query in the network, through MessageQueue.GetPublicQueues method.
MessageQueueException | Is thrown if a Microsoft Message Queue Server (MSMQ) internal error occurs.
MessageQueueInstaller | [To be supplied.]
MessageQueuesEnumerator | [To be supplied.]
MessagesEnumerator | Provides forward only cursor semantics to enumerate the messages contained in a queue. Each instance of this object uses a separate cursor.
PeekAsyncEventArgs | Contains the event information that is generated when an MessageQueue asynchronous Peek operation is completed.
ReceiveAsyncEventArgs | Contains the event information that is generated when an MessageQueue asynchronous Receive operation is completed.
SoapMessageFormatter | Formatter class that serializes and deserializes objects into and from MessageQueue messages using Xml.

Interfaces

Interface | Description
IMessageFormatter | The functions defined in this interface are used to serailize and deserialize objects into and from MessageQueue messages.

Delegates

Delegate | Description
PeekCompletedEventHandler | [To be supplied.]
ReceiveCompletedEventHandler | [To be supplied.]

Enumerations

Enumeration | Description
AcknowledgeType | A message can be a normal MSMQ message, a positive or negative (arrival and read) acknowledgment message, or a report message. Typically this property is set by MSMQ when it sends the message.
Acknowledgment | Specifies the type of acknowledgment messages the system posts (in the administration queue) and when acknowledgments are returned.
CryptoProviderType | Typically used when working with foreign queues. The type and name of the cryptographic provider is required to validate the digital signature of a message sent to a foreign queue or messages passed to MSMQ from a foreign queue.
EncryptionAlgorithm | Specifies the encryption algorithm used to encrypt the message body of a private message.
EncryptionRequired | Specifies the privacy level of messages received by the queue.
HashAlgorithm | Specifies the hash algorithm used by Message Queuing when authenticating messages.
MessagePriority | Message priority effects how MSMQ handles the message while it is in route, as well as where the message is placed in the queue. Higher priority messages are given preference during routing, and inserted toward the front of the queue. Messages with the same priority are placed in the queue according to their arrival time.
MessageType | A message can be a normal MSMQ message, a positive or negative (arrival and read) acknowledgment message, or a report message.


AcknowledgeType Enumeration

A message can be a normal MSMQ message, a positive or negative (arrival and read) acknowledgment message, or a report message. Typically this property is set by MSMQ when it sends the message.

[Visual Basic]
Public Enum AcknowledgeType
[C#]
public enum AcknowledgeType
[C++]
public enum AcknowledgeType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
FullReachQueue | Posts positive and negative acknowledgments depending on whether or not the message reaches the queue. This can happen when the time-to-reach-queue timer expires, or a message cannot be authenticated.
FullReceive | Posts a positive or negative acknowledgment depending on whether or not the message is retrieved from the queue before its time-to-be-received timer expires.
None | No acknowledgment messages (positive or negative) are posted.
NotAcknowledgeReachQueue | Posts a negative acknowledgment when the message cannot reach the queue. This can happen when the time-to-reach-queue timer expires, or a message cannot be authenticated.
NotAcknowledgeReceive | Posts a negative acknowledgment when an error occurs and the message cannot be retrieved from the queue before its time-to-be-received timer expires.

Requirements

Namespace: System.Messaging

Assembly: system.messaging.dll

See Also

System.Messaging Namespace


Acknowledgment Enumeration

Specifies the type of acknowledgment messages the system posts (in the administration queue) and when acknowledgments are returned.

[Visual Basic]
Public Enum Acknowledgment
[C#]
public enum Acknowledgment
[C++]
public enum Acknowledgment

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
AccessDenied | The sending application does not have access rights to the destination queue.
BadDestinationQueue | The destination queue is not available to the sending application.
BadEncryption | The destination Queue Manager could not decrypt a private (encrypted) message.
BadSignature | MSMQ could not authenticate the original message. The original message's digital signature is not valid.
CouldNotEncrypt | The source Queue Manager could not encrypt a private message.
HopCountExceeded | The original message's hop count is exceeded.
None | [To be supplied.]
NotTransactionalMessage | A non-transaction message was sent to a transaction queue.
NotTransactionalQueue | A transaction message was sent to a non-transaction queue.
Purged | The message was purged before reaching the destination queue.
QueueDeleted | The queue was deleted before the message could be read from the queue.
QueueExceedMaximumSize | The original message's destination queue is full.
QueuePurged | The queue was purged and the message no longer exists.
ReachQueue | The original message reached its destination queue.
ReachQueueTimeout | Either the time-to-reach-queue or time-to-be-received timer expired before the original message could reach the destination queue.
Receive | The original message was retrieved by the receiving application.
ReceiveTimeout | The original message was not removed from the queue before its time-to-be-received timer expired.

Requirements

Namespace: System.Messaging

Assembly: system.messaging.dll

See Also

System.Messaging Namespace


ActiveXMessageFormatter Class

Formatter class that serializes and deserializes primitives into and from MessageQueue messages using binary format.

Object
ActiveXMessageFormatter

[Visual Basic]
Public Class ActiveXMessageFormatter
   Implements IMessageFormatter
[C#]
public class ActiveXMessageFormatter : IMessageFormatter
[C++]
public __gc class ActiveXMessageFormatter : public
   IMessageFormatter
[JScript]
public class ActiveXMessageFormatter implements IMessageFormatter

Remarks

[To be supplied.]

Requirements

Namespace: System.Messaging

Assembly: system.messaging.dll

See Also

ActiveXMessageFormatter Members | System.Messaging Namespace


ActiveXMessageFormatter Members

Public:

Constructor

ActiveXMessageFormatter Constructor [To be supplied.]

Methods

CanRead | When this method is called, the formatter will attempt to determine if the contents of the message are something the formatter can deal with.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Read | This method is used to read the contents from the given message and create an object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | This method is used to write the given object into the given message. If the formatter cannot understand the given object, an exception is thrown.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ActiveXMessageFormatter Class | System.Messaging Namespace


ActiveXMessageFormatter Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ActiveXMessageFormatter();
[C++]
public: ActiveXMessageFormatter();
[JScript]
public function ActiveXMessageFormatter();

See Also

ActiveXMessageFormatter Class | ActiveXMessageFormatter Members | System.Messaging Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ActiveXMessageFormatter Methods

The methods of the ActiveXMessageFormatter class are listed below. For a complete list of ActiveXMessageFormatter class members, see the ActiveXMessageFormatter Members topic.

Public:

CanRead | When this method is called, the formatter will attempt to determine if the contents of the message are something the formatter can deal with.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Read | This method is used to read the contents from the given message and create an object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | This method is used to write the given object into the given message. If the formatter cannot understand the given object, an exception is thrown.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ActiveXMessageFormatter Class | System.Messaging Namespace


ActiveXMessageFormatter.CanRead

When this method is called, the formatter will attempt to determine if the contents of the message are something the formatter can deal with.

[Visual Basic]
Overridable Public Function CanRead( _
   ByVal message As Message _
) As Boolean
[C#]
public virtual bool CanRead(
   Message message
);
[C++]
public: virtual bool CanRead(
   Message* message
);
[JScript]
public function CanRead(
   message : Message
) : Boolean;

Parameters

message
the message to be inspected.

Return Value

indicates wehter or not the message passed can be read.

See Also

ActiveXMessageFormatter Class | ActiveXMessageFormatter Members | System.Messaging Namespace


ActiveXMessageFormatter.Read

This method is used to read the contents from the given message and create an object.

[Visual Basic]
Overridable Public Function Read( _
   ByVal message As Message _
) As Object
[C#]
public virtual object Read(
   Message message
);
[C++]
public: virtual Object* Read(
   Message* message
);
[JScript]
public function Read(
   message : Message
) : Object;

Parameters

message
the message to deserialize the object from.

Return Value

the object deserialized from the message.

See Also

ActiveXMessageFormatter Class | ActiveXMessageFormatter Members | System.Messaging Namespace


ActiveXMessageFormatter.Write

This method is used to write the given object into the given message. If the formatter cannot understand the given object, an exception is thrown.

[Visual Basic]
Overridable Public Sub Write( _
   ByVal message As Message, _
   ByVal obj As Object _
)
[C#]
public virtual void Write(
   Message message,
   object obj
);
[C++]
public: virtual void Write(
   Message* message,
   Object* obj
);
[JScript]
public function Write(
   message : Message,
   obj : Object
);

Parameters

message
the message to serialize the object into.
obj
the object to be serialized.

See Also

ActiveXMessageFormatter Class | ActiveXMessageFormatter Members | System.Messaging Namespace


BinaryMessageFormatter Class

Formatter class that serializes and deserializes objects into and from MessageQueue messages using binary format.

Object
BinaryMessageFormatter

[Visual Basic]
Public Class BinaryMessageFormatter
   Implements IMessageFormatter
[C#]
public class BinaryMessageFormatter : IMessageFormatter
[C++]
public __gc class BinaryMessageFormatter : public IMessageFormatter
[JScript]
public class BinaryMessageFormatter implements IMessageFormatter

Remarks

[To be supplied.]

Requirements

Namespace: System.Messaging

Assembly: system.messaging.dll

See Also

BinaryMessageFormatter Members | System.Messaging Namespace


BinaryMessageFormatter Members

Public:

Constructor

BinaryMessageFormatter Constructor Overloaded. [To be supplied.]

Properties

TopObjectFormat | Determines how the top (root) object of a graph is laid out in the serialized stream.
TypeFormat | Determines how type descriptions are laid out in the serialized stream.

Methods

CanRead | When this method is called, the formatter will attempt to determine if the contents of the message are something the formatter can deal with.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Read | This method is used to read the contents from the given message and create an object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | This method is used to write the given object into the given message. If the formatter cannot understand the given object, an exception is thrown.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BinaryMessageFormatter Class | System.Messaging Namespace


BinaryMessageFormatter Constructor

[To be supplied.]

Overload List

Creates a new Binary message formatter object.

[Visual Basic] Overloads Public Sub New()
[C#] public BinaryMessageFormatter();
[C++] public: BinaryMessageFormatter();
[JScript] public function BinaryMessageFormatter();

Creates a new Binary message formatter object with the given properties.

[Visual Basic] Overloads Public Sub New(FormatterTopObjectStyle, FormatterTypeStyle)
[C#] public BinaryMessageFormatter(FormatterTopObjectStyle, FormatterTypeStyle);
[C++] public: BinaryMessageFormatter(FormatterTopObjectStyle, FormatterTypeStyle);
[JScript] public function BinaryMessageFormatter(FormatterTopObjectStyle, FormatterTypeStyle);

See Also

BinaryMessageFormatter Class | BinaryMessageFormatter Members | System.Messaging Namespace


BinaryMessageFormatter Constructor ()

Creates a new Binary message formatter object.

[Visual Basic]
Overloads Public Sub New()
[C#]
public BinaryMessageFormatter();
[C++]
public: BinaryMessageFormatter();
[JScript]
public function BinaryMessageFormatter();

See Also

BinaryMessageFormatter Class | BinaryMessageFormatter Members | System.Messaging Namespace | BinaryMessageFormatter Constructor Overload List


BinaryMessageFormatter Constructor (FormatterTopObjectStyle, FormatterTypeStyle)

Creates a new Binary message formatter object with the given properties.

[Visual Basic]
Overloads Public Sub New( _
   ByVal topObjectFormat As FormatterTopObjectStyle, _
   ByVal typeFormat As FormatterTypeStyle _
)
[C#]
public BinaryMessageFormatter(
   FormatterTopObjectStyle topObjectFormat,
   FormatterTypeStyle typeFormat
);
[C++]
public: BinaryMessageFormatter(
   FormatterTopObjectStyle topObjectFormat,
   FormatterTypeStyle typeFormat
);
[JScript]
public function BinaryMessageFormatter(
   topObjectFormat : FormatterTopObjectStyle,
   typeFormat : FormatterTypeStyle
);

Parameters

topObjectFormat
Determines how the top (root) object of a graph is laid out in the serialized stream.
typeFormat
Determines how type descriptions are laid out in the serialized stream.

See Also

BinaryMessageFormatter Class | BinaryMessageFormatter Members | System.Messaging Namespace | BinaryMessageFormatter Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

BinaryMessageFormatter Properties

The properties of the BinaryMessageFormatter class are listed below. For a complete list of BinaryMessageFormatter class members, see the BinaryMessageFormatter Members topic.

Public:

TopObjectFormat | Determines how the top (root) object of a graph is laid out in the serialized stream.
TypeFormat | Determines how type descriptions are laid out in the serialized stream.

See Also

BinaryMessageFormatter Class | System.Messaging Namespace


BinaryMessageFormatter.TopObjectFormat

Determines how the top (root) object of a graph is laid out in the serialized stream.

[Visual Basic]
Public Property TopObjectFormat As FormatterTopObjectStyle
[C#]
public FormatterTopObjectStyle TopObjectFormat {get; set;}
[C++]
public: __property FormatterTopObjectStyle get_TopObjectFormat();
public: __property void set_TopObjectFormat(FormatterTopObjectStyle);
[JScript]
public function get TopObjectFormat() : FormatterTopObjectStyle;
public function set TopObjectFormat(FormatterTopObjectStyle);

See Also

BinaryMessageFormatter Class | BinaryMessageFormatter Members | System.Messaging Namespace


BinaryMessageFormatter.TypeFormat

Determines how type descriptions are laid out in the serialized stream.

[Visual Basic]
Public Property TypeFormat As FormatterTypeStyle
[C#]
public FormatterTypeStyle TypeFormat {get; set;}
[C++]
public: __property FormatterTypeStyle get_TypeFormat();
public: __property void set_TypeFormat(FormatterTypeStyle);
[JScript]
public function get TypeFormat() : FormatterTypeStyle;
public function set TypeFormat(FormatterTypeStyle);

See Also

BinaryMessageFormatter Class | BinaryMessageFormatter Members | System.Messaging Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

BinaryMessageFormatter Methods

The methods of the BinaryMessageFormatter class are listed below. For a complete list of BinaryMessageFormatter class members, see the BinaryMessageFormatter Members topic.

Public:

CanRead | When this method is called, the formatter will attempt to determine if the contents of the message are something the formatter can deal with.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Read | This method is used to read the contents from the given message and create an object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | This method is used to write the given object into the given message. If the formatter cannot understand the given object, an exception is thrown.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BinaryMessageFormatter Class | System.Messaging Namespace


BinaryMessageFormatter.CanRead

When this method is called, the formatter will attempt to determine if the contents of the message are something the formatter can deal with.

[Visual Basic]
Overridable Public Function CanRead( _
   ByVal message As Message _
) As Boolean
[C#]
public virtual bool CanRead(
   Message message
);
[C++]
public: virtual bool CanRead(
   Message* message
);
[JScript]
public function CanRead(
   message : Message
) : Boolean;

Parameters

message
the message to be inspected.

Return Value

indicates wehter or not the message passed can be read.

See Also

BinaryMessageFormatter Class | BinaryMessageFormatter Members | System.Messaging Namespace


BinaryMessageFormatter.Read

This method is used to read the contents from the given message and create an object.

[Visual Basic]
Overridable Public Function Read( _
   ByVal message As Message _
) As Object
[C#]
public virtual object Read(
   Message message
);
[C++]
public: virtual Object* Read(
   Message* message
);
[JScript]
public function Read(
   message : Message
) : Object;

Parameters

message
the message to deserialize the object from.

Return Value

the object deserialized from the message.

See Also

BinaryMessageFormatter Class | BinaryMessageFormatter Members | System.Messaging Namespace


BinaryMessageFormatter.Write

This method is used to write the given object into the given message. If the formatter cannot understand the given object, an exception is thrown.

[Visual Basic]
Overridable Public Sub Write( _
   ByVal message As Message, _
   ByVal obj As Object _
)
[C#]
public virtual void Write(
   Message message,
   object obj
);
[C++]
public: virtual void Write(
   Message* message,
   Object* obj
);
[JScript]
public function Write(
   message : Message,
   obj : Object
);

Parameters

message
the message to serialize the object into.
obj
the object to be serialized.

See Also

BinaryMessageFormatter Class | BinaryMessageFormatter Members | System.Messaging Namespace


CryptoProviderType Enumeration

Typically used when working with foreign queues. The type and name of the cryptographic provider is required to validate the digital signature of a message sent to a foreign queue or messages passed to MSMQ from a foreign queue.

[Visual Basic]
Public Enum CryptoProviderType
[C#]
public enum CryptoProviderType
[C++]
public enum CryptoProviderType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
DSS | [To be supplied.]
FORTEZZA | [To be supplied.]
MS_EXCHANGE | [To be supplied.]
None | [To be supplied.]
RSA_FULL | [To be supplied.]
RSQ_SIG | [To be supplied.]
SSL | [To be supplied.]
STT_ACQ | [To be supplied.]
STT_BRND | [To be supplied.]
STT_ISS | [To be supplied.]
STT_MER | [To be supplied.]
STT_ROOT | [To be supplied.]

Requirements

Namespace: System.Messaging

Assembly: system.messaging.dll

See Also

System.Messaging Namespace


DataSetMessageFormatter Class

Formatter class that serializes and deserializes datasets into and from MessageQueue messages using Xml.

Object
Component
DataSetMessageFormatter

[Visual Basic]
Public Class DataSetMessageFormatter
   Inherits Component
   Implements IMessageFormatter
[C#]
public class DataSetMessageFormatter : Component, IMessageFormatter
[C++]
public __gc class DataSetMessageFormatter : public Component,
   IMessageFormatter
[JScript]
public class DataSetMessageFormatter extends Component,
   IMessageFormatter

Remarks

[To be supplied.]

Requirements

Namespace: System.Messaging

Assembly: system.messaging.dll

See Also

DataSetMessageFormatter Members | System.Messaging Namespace


DataSetMessageFormatter Members

Public:

Constructor

DataSetMessageFormatter Constructor Overloaded. [To be supplied.]

Properties

Site (inherited from Component) | Gets or sets the site of the Component.
TargetType | Specifies the type to create when deserializing strongly typed datasets.

Methods

CanRead | When this method is called, the formatter will attempt to determine if the contents of the message are something the formatter can deal with.
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Read | This method is used to read the contents from the given message and create an object.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
Write | This method is used to write the given object into the given message. If the formatter cannot understand the given object, an exception is thrown.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataSetMessageFormatter Class | System.Messaging Namespace


DataSetMessageFormatter Constructor

[To be supplied.]

Overload List

Creates a new Dataset message formatter object.

[Visual Basic] Overloads Public Sub New()
[C#] public DataSetMessageFormatter();
[C++] public: DataSetMessageFormatter();
[JScript] public function DataSetMessageFormatter();

Creates a new Dataset message formatter object, using the given properties.

[Visual Basic] Overloads Public Sub New(String)
[C#] public DataSetMessageFormatter(String);
[C++] public: DataSetMessageFormatter(String*);
[JScript] public function DataSetMessageFormatter(String);

Creates a new Dataset message formatter object, using the given properties.

[Visual Basic] Overloads Public Sub New(Type)
[C#] public DataSetMessageFormatter(Type);
[C++] public: DataSetMessageFormatter(Type*);
[JScript] public function DataSetMessageFormatter(Type);

See Also

DataSetMessageFormatter Class | DataSetMessageFormatter Members | System.Messaging Namespace


DataSetMessageFormatter Constructor ()

Creates a new Dataset message formatter object.

[Visual Basic]
Overloads Public Sub New()
[C#]
public DataSetMessageFormatter();
[C++]
public: DataSetMessageFormatter();
[JScript]
public function DataSetMessageFormatter();

See Also

DataSetMessageFormatter Class | DataSetMessageFormatter Members | System.Messaging Namespace | DataSetMessageFormatter Constructor Overload List


DataSetMessageFormatter Constructor (String)

Creates a new Dataset message formatter object, using the given properties.

[Visual Basic]
Overloads Public Sub New( _
   ByVal targetType As String _
)
[C#]
public DataSetMessageFormatter(
   string targetType
);
[C++]
public: DataSetMessageFormatter(
   String* targetType
);
[JScript]
public function DataSetMessageFormatter(
   targetType : String
);

Parameters

targetType
Specifies the type to create when deserializing strongly typed datasets.

See Also

DataSetMessageFormatter Class | DataSetMessageFormatter Members | System.Messaging Namespace | DataSetMessageFormatter Constructor Overload List


DataSetMessageFormatter Constructor (Type)

Creates a new Dataset message formatter object, using the given properties.

[Visual Basic]
Overloads Public Sub New( _
   ByVal targetType As Type _
)
[C#]
public DataSetMessageFormatter(
   Type targetType
);
[C++]
public: DataSetMessageFormatter(
   Type* targetType
);
[JScript]
public function DataSetMessageFormatter(
   targetType : Type
);

Parameters

targetType
Specifies the type to create when deserializing strongly typed datasets.

See Also

DataSetMessageFormatter Class | DataSetMessageFormatter Members | System.Messaging Namespace | DataSetMessageFormatter Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataSetMessageFormatter Properties

The properties of the DataSetMessageFormatter class are listed below. For a complete list of DataSetMessageFormatter class members, see the DataSetMessageFormatter Members topic.

Public:

Site (inherited from Component) | Gets or sets the site of the Component.
TargetType | Specifies the type to create when deserializing strongly typed datasets.

See Also

DataSetMessageFormatter Class | System.Messaging Namespace


DataSetMessageFormatter.TargetType

Specifies the type to create when deserializing strongly typed datasets.

[Visual Basic]
Public Property TargetType As Type
[C#]
public Type TargetType {get; set;}
[C++]
public: __property Type* get_TargetType();
public: __property void set_TargetType(Type*);
[JScript]
public function get TargetType() : Type;
public function set TargetType(Type);

See Also

DataSetMessageFormatter Class | DataSetMessageFormatter Members | System.Messaging Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataSetMessageFormatter Methods

The methods of the DataSetMessageFormatter class are listed below. For a complete list of DataSetMessageFormatter class members, see the DataSetMessageFormatter Members topic.

Public:

CanRead | When this method is called, the formatter will attempt to determine if the contents of the message are something the formatter can deal with.
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Read | This method is used to read the contents from the given message and create an object.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
Write | This method is used to write the given object into the given message. If the formatter cannot understand the given object, an exception is thrown.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataSetMessageFormatter Class | System.Messaging Namespace


DataSetMessageFormatter.CanRead

When this method is called, the formatter will attempt to determine if the contents of the message are something the formatter can deal with.

[Visual Basic]
Overridable Public Function CanRead( _
   ByVal message As Message _
) As Boolean
[C#]
public virtual bool CanRead(
   Message message
);
[C++]
public: virtual bool CanRead(
   Message* message
);
[JScript]
public function CanRead(
   message : Message
) : Boolean;

Parameters

message
the message to be inspected.

Return Value

indicates wehter or not the message passed can be read.

See Also

DataSetMessageFormatter Class | DataSetMessageFormatter Members | System.Messaging Namespace


DataSetMessageFormatter.Read

This method is used to read the contents from the given message and create an object.

[Visual Basic]
Overridable Public Function Read( _
   ByVal message As Message _
) As Object
[C#]
public virtual object Read(
   Message message
);
[C++]
public: virtual Object* Read(
   Message* message
);
[JScript]
public function Read(
   message : Message
) : Object;

Parameters

message
the message to deserialize the object from.

Return Value

the object deserialized from the message.

See Also

DataSetMessageFormatter Class | DataSetMessageFormatter Members | System.Messaging Namespace


DataSetMessageFormatter.Write

This method is used to write the given object into the given message. If the formatter cannot understand the given object, an exception is thrown.

[Visual Basic]
Overridable Public Sub Write( _
   ByVal message As Message, _
   ByVal obj As Object _
)
[C#]
public virtual void Write(
   Message message,
   object obj
);
[C++]
public: virtual void Write(
   Message* message,
   Object* obj
);
[JScript]
public function Write(
   message : Message,
   obj : Object
);

Parameters

message
the message to serialize the object into.
obj
the object to be serialized.

See Also

DataSetMessageFormatter Class | DataSetMessageFormatter Members | System.Messaging Namespace


DataSetMessageFormatter.TargetTypeEditor Class

Used to edit DataSet target types in the property browser.

Object
ValueEditor
TypeListEditor
DataSetMessageFormatter.TargetTypeEditor

[Visual Basic]
Public Class DataSetMessageFormatter.TargetTypeEditor
   Inherits TypeListEditor
[C#]
public class DataSetMessageFormatter.TargetTypeEditor :
   TypeListEditor
[C++]
public __gc class DataSetMessageFormatter.TargetTypeEditor : public
   TypeListEditor
[JScript]
public class DataSetMessageFormatter.TargetTypeEditor extends
   TypeListEditor

Remarks

[To be supplied.]

Requirements

Namespace: System.Messaging

Assembly: system.messaging.dll

See Also

DataSetMessageFormatter.TargetTypeEditor Members | System.Messaging Namespace


DataSetMessageFormatter.TargetTypeEditor Members

Public:

Constructor

DataSetMessageFormatterTargetTypeEditor Constructor [To be supplied.]

Properties

Style (inherited from TypeListEditor) | [To be supplied.]
Values (inherited from TypeListEditor) | [To be supplied.]

Methods

EditValue (inherited from ValueEditor) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCreationBundle (inherited from TypeListEditor) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSubProperties (inherited from ValueEditor) | [To be supplied.]
GetTextFromValue (inherited from TypeListEditor) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValueFromSubPropertyValues (inherited from ValueEditor) | [To be supplied.]
GetValueFromText (inherited from TypeListEditor) | [To be supplied.]
IsValid (inherited from ValueEditor) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataSetMessageFormatter.TargetTypeEditor Class | System.Messaging Namespace


DataSetMessageFormatter.TargetTypeEditor Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public DataSetMessageFormatter.TargetTypeEditor();
[C++]
public: DataSetMessageFormatter.TargetTypeEditor();
[JScript]
public function DataSetMessageFormatter.TargetTypeEditor();

See Also

DataSetMessageFormatter.TargetTypeEditor Class | DataSetMessageFormatter.TargetTypeEditor Members | System.Messaging Namespace


DefaultPropertiesToSend Class

Specifies the default property values that will be used when sending objects using the message queue.

Object
DefaultPropertiesToSend

[Visual Basic]
Public Class DefaultPropertiesToSend
[C#]
public class DefaultPropertiesToSend
[C++]
public __gc class DefaultPropertiesToSend
[JScript]
public class DefaultPropertiesToSend

Remarks

You can set default properties that will be used to set selected default values for new messages created by the MessageQueue class. Properties that you do not set explicitly default to the values specified by the constructor, DefaultPropertiesToSend.

All properties in DefaultPropertiesToSend correspond to identically named properties in the Message class. When you modify the default properties for a message queue, you are defining the default property values for outgoing messages associated with that queue.

The property members of DefaultPropertiesToSend provide access to the properties in the Message Queuing application's MSMQMessage object. The following table shows the DefaultPropertiesToSend properties and the corresponding MSMQMessage properties.

DefaultPropertiesToSend Property | MSMQMessage Property
AcknowledgeType | Ack
AdministrationQueue | AdminQueueInfo
AppSpecific | AppSpecific
AttachSenderId | SenderIdType
EncryptionAlgorithm | EncryptionAlgorithm
Extension | Extension
HashAlgorithm | HashAlgorithm
Label | Label
Priority | Priority
Recoverable | Delivery
ResponseQueue | ResponseQueueInfo
TimeToBeReceived | MaxTimeToReceive
TimeToReachQueue | MaxTimeToReachQueue
TransactionStatusQueue | TransactionStatusQueueInfo
UseAuthentication | IsAuthenticated
UseDeadLetterQueue | Journal
UseEncryption | PrivLevel
UseJournalQueue | Journal
UseTracing | Trace

For more information about the MSMQMessage object, see the TBD topic in the Platform SDK.

When you create an instance of DefaultPropertiesToSend, the read/write properties are set to initial values. For a list of these values, see the DefaultPropertiesToSend constructor.

Requirements

Namespace: System.Messaging

Assembly: system.messaging.dll

Example [Visual Basic]

The following example demonstrates defining different DefaultPropertiesToSend based on whether a message passed into the procedure has highest or normal MessagePriority. The properties that are set, which apply to the message to be sent to the message queue, are the Label, the Priority, the TimeToBeReceived, and the TimeToReachQueue. It is important to note that these properties are set through the TBD, but they apply to the Message object.

This example assumes that the calling procedure passes in a MessagePriority, and that an urgent message is indicated by Highest priority. It also assumes that the calling method defines the Message that is to be sent to the queue.

[Visual Basic]

Private Sub SetDefaultPropertiesToSend(ByVal urgency As MessagePriority, ByVal msg As System.Messaging.Message)
    'Create DefaultPropertiesToSend objects
    Dim urgentMessageProperties As DefaultPropertiesToSend
    Dim normalMessageProperties As DefaultPropertiesToSend
    'Define and instantiate a new MessageQueue object
    Dim MessageQueue1 As System.Messaging.MessageQueue.MessageQueue
    Set Me.MessageQueue1 = New System.Messaging.MessageQueue
    'Set the queue formatter to the XML-based formatter
    Set MessageQueue1.Formatter = New System.Messaging.XmlQueueMessageFormatter
    Set MessageQueue1.DefaultPropertiesToSend.UseDeadLetterQueue = True

    'Set the label for the queue (as opposed to the message labels).
    Set MessageQueue1.Label = "Order Queue"
    'Set the queue path
    MessageQueue1.Path = "mycomputer\myqueue"
    'Instantiate two new DefaultPropertiesToSend objects
    Set urgentMessageProperties = New DefaultPropertiesToSend
    Set normalMessageProperties = New DefaultPropertiesToSend
    'Set the label and priority for urgent messages
    urgentMessageProperties.Label = "Urgent Message"
    urgentMessageProperties.Priority = MessagePriority.Highest
    'Make the process wait indefinitely for a message.
    urgentMessageProperties.TimeToBeReceived = Message.InfiniteTimeout
    urgentMessageProperties.TimeToReachQueue = Message.InfiniteTimeout
    urgentMessageProperties.UseDeadLetterQueue = True
    'set the label and priority for normal messages
    normalMessageProperties.Label = "Normal Message"
    normalMessageProperties.Priority = MessagePriority.Normal
    'Make the process wait a finite amount of time for a message.
    normalMessageProperties.TimeToBeReceived = 3000
    normalMessageProperties.TimeToReachQueue = 3000
    normalMessageProperties.UseDeadLetterQueue = True
    'If the message is urgent, use the urgent DefaultPropertiesToSend
    If urgency = MessagePriority.Highest Then
        Set MessageQueue1.DefaultPropertiesToSend = urgentMessageProperties
    Else
        'Otherwise, use normal DefaultPropertiesToSend
        Set MessageQueue1.DefaultPropertiesToSend = normalMessageProperties
    End If
    'Override default properties on the message object
    msg.Priority = MessageQueue1.DefaultPropertiesToSend.Priority
    msg.Label = MessageQueue1.DefaultPropertiesToSend.Label
    msg.TimeToBeReceived = MessageQueue1.DefaultPropertiesToSend.TimeToBeReceived
    msg.TimeToReachQueue = MessageQueue1.DefaultPropertiesToSend.TimeToReachQueue
    'Send the message that was passed in.
    MessageQueue1.Send msg
    'Display Label and MessagePriority information on the screen
    MessageBox.Show MessageQueue1.DefaultPropertiesToSend.Label & ". Priority: " & MessageQueue1.DefaultPropertiesToSend.Priority
End Sub

See Also

DefaultPropertiesToSend Members | System.Messaging Namespace | Message | TBD


DefaultPropertiesToSend Members

Public:

Constructor

DefaultPropertiesToSend Constructor Initializes a new instance of the DefaultPropertiesToSend class.

Properties

AcknowledgeType | Gets or sets the type of acknowledgement messages generated or returned to the sending application.
AdministrationQueue | Gets or sets the queue used for acknowledgement messages generated by the application.
AppSpecific | Gets or sets application-generated information.
AttachSenderId | Gets or sets a value indicating if the sender ID is to be attached to the message.
EncryptionAlgorithm | Gets or sets the encryption algorithm used to encrypt the body of a private message.
Extension | Gets or sets additional information associated with the message.
HashAlgorithm | Gets or sets the hashing algorithm used when authenticating messages.
Label | Gets or sets the message label.
Priority | Gets or sets the message priority.
Recoverable | Gets or sets a value indicating whether the message is guaranteed to be delivered in the event of a computer failure or network problem.
ResponseQueue | Gets or sets the queue which receives application-generated response messages.
TimeToBeReceived | Gets or sets the time limit for the message to be retrieved from the target queue.
TimeToReachQueue | Gets or sets the time limit for the message to reach the queue.
TransactionStatusQueue | Gets the transaction status queue on the source computer.
UseAuthentication | Gets or sets a value indicating whether the message must be authenticated.
UseDeadLetterQueue | Gets or sets a value indicating whether a copy of the message that could not be delivered should be sent to a dead-letter queue.
UseEncryption | Gets or sets a value indicating whether to encrypt private messages.
UseJournalQueue | Gets or sets a value indicating whether a copy of the message should be kept in a machine journal on the originating computer.
UseTracing | Gets or sets a value indicating whether to trace a message as it moves toward its destination queue.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ShouldPersistExtension | Specifies whether to save application-defined information associated with the message.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefaultPropertiesToSend Class | System.Messaging Namespace


DefaultPropertiesToSend Constructor

Initializes a new instance of the DefaultPropertiesToSend class.

[Visual Basic]
Public Sub New()
[C#]
public DefaultPropertiesToSend();
[C++]
public: DefaultPropertiesToSend();
[JScript]
public function DefaultPropertiesToSend();

Remarks

When you create an instance of DefaultPropertiesToSend, the following read/write properties are initialized.

Property | Initial Value
AcknowledgeType | AcknowledgeType.None
AdministrationQueue | a null reference (in Visual Basic Nothing)
AppSpecific | 0
AttachSenderId | true
EncryptionAlgorithm | EncryptionAlgorithm.RC2
Extension | A zero-length array of bytes
HashAlgorithm | HashAlgorithm.MD5
Label | "" (empty string)
Priority | MessagePriority.Normal
Recoverable | false
ResponseQueue | a null reference (Nothing)
TimeToBeReceived | Message.InfiniteTimeout
TimeToReachQueue | Message.InfiniteTimeout
TransactionStatusQueue | a null reference (Nothing)
UseAuthentication | false
UseDeadLetterQueue | false
UseEncryption | false
UseJournalQueue | false
UseTracing | false

You can change the value for any of these properties through a separate call to the property.

Example [Visual Basic]

The following example demonstrates using the constructor to define different DefaultPropertiesToSend based on whether a message passed into the procedure has highest or normal MessagePriority. The properties that are set, which apply to the message to be sent to the message queue, are the Label, the Priority, the TimeToBeReceived, and the TimeToReachQueue. It is important to note that these properties are set through the TBD, but they apply to the Message object.

This example assumes that the calling procedure passes in a MessagePriority, and that an urgent message is indicated by Highest priority. It also assumes that the calling method defines the Message that is to be sent to the queue.

[Visual Basic]

Private Sub SetDefaultPropertiesToSend(ByVal urgency As MessagePriority, ByVal msg As System.Messaging.Message)
    'Create DefaultPropertiesToSend objects
    Dim urgentMessageProperties As DefaultPropertiesToSend
    Dim normalMessageProperties As DefaultPropertiesToSend
    'Define and instantiate a new MessageQueue object
    Dim MessageQueue1 As System.Messaging.MessageQueue.MessageQueue
    Set Me.MessageQueue1 = New System.Messaging.MessageQueue
    'Set the queue formatter to the XML-based formatter
    Set MessageQueue1.Formatter = New System.Messaging.XmlQueueMessageFormatter
    Set MessageQueue1.DefaultPropertiesToSend.UseDeadLetterQueue = True

    'Set the label for the queue (as opposed to the message labels).
    Set MessageQueue1.Label = "Order Queue"
    'Set the queue path
    MessageQueue1.Path = "mycomputer\myqueue"
    'Instantiate two new DefaultPropertiesToSend objects
    Set urgentMessageProperties = New DefaultPropertiesToSend
    Set normalMessageProperties = New DefaultPropertiesToSend
    'Set the label and priority for urgent messages
    urgentMessageProperties.Label = "Urgent Message"
    urgentMessageProperties.Priority = MessagePriority.Highest
    'Make the process wait indefinitely for a message.
    urgentMessageProperties.TimeToBeReceived = Message.InfiniteTimeout
    urgentMessageProperties.TimeToReachQueue = Message.InfiniteTimeout
    urgentMessageProperties.UseDeadLetterQueue = True
    'set the label and priority for normal messages
    normalMessageProperties.Label = "Normal Message"
    normalMessageProperties.Priority = MessagePriority.Normal
    'Make the process wait a finite amount of time for a message.
    normalMessageProperties.TimeToBeReceived = 3000
    normalMessageProperties.TimeToReachQueue = 3000
    normalMessageProperties.UseDeadLetterQueue = True
    'If the message is urgent, use the urgent DefaultPropertiesToSend
    If urgency = MessagePriority.Highest Then
        Set MessageQueue1.DefaultPropertiesToSend = urgentMessageProperties
    Else
        'Otherwise, use normal DefaultPropertiesToSend
        Set MessageQueue1.DefaultPropertiesToSend = normalMessageProperties
    End If
    'Override default properties on the message object
    msg.Priority = MessageQueue1.DefaultPropertiesToSend.Priority
    msg.Label = MessageQueue1.DefaultPropertiesToSend.Label
    msg.TimeToBeReceived = MessageQueue1.DefaultPropertiesToSend.TimeToBeReceived
    msg.TimeToReachQueue = MessageQueue1.DefaultPropertiesToSend.TimeToReachQueue
    'Send the message that was passed in.
    MessageQueue1.Send msg
    'Display Label and MessagePriority information on the screen
    MessageBox.Show MessageQueue1.DefaultPropertiesToSend.Label & ". Priority: " & MessageQueue1.DefaultPropertiesToSend.Priority
End Sub

See Also

DefaultPropertiesToSend Class | DefaultPropertiesToSend Members | System.Messaging Namespace | AcknowledgeType | EncryptionAlgorithm | HashAlgorithm | InfiniteTimeout


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DefaultPropertiesToSend Properties

The properties of the DefaultPropertiesToSend class are listed below. For a complete list of DefaultPropertiesToSend class members, see the DefaultPropertiesToSend Members topic.

Public:

AcknowledgeType | Gets or sets the type of acknowledgement messages generated or returned to the sending application.
AdministrationQueue | Gets or sets the queue used for acknowledgement messages generated by the application.
AppSpecific | Gets or sets application-generated information.
AttachSenderId | Gets or sets a value indicating if the sender ID is to be attached to the message.
EncryptionAlgorithm | Gets or sets the encryption algorithm used to encrypt the body of a private message.
Extension | Gets or sets additional information associated with the message.
HashAlgorithm | Gets or sets the hashing algorithm used when authenticating messages.
Label | Gets or sets the message label.
Priority | Gets or sets the message priority.
Recoverable | Gets or sets a value indicating whether the message is guaranteed to be delivered in the event of a computer failure or network problem.
ResponseQueue | Gets or sets the queue which receives application-generated response messages.
TimeToBeReceived | Gets or sets the time limit for the message to be retrieved from the target queue.
TimeToReachQueue | Gets or sets the time limit for the message to reach the queue.
TransactionStatusQueue | Gets the transaction status queue on the source computer.
UseAuthentication | Gets or sets a value indicating whether the message must be authenticated.
UseDeadLetterQueue | Gets or sets a value indicating whether a copy of the message that could not be delivered should be sent to a dead-letter queue.
UseEncryption | Gets or sets a value indicating whether to encrypt private messages.
UseJournalQueue | Gets or sets a value indicating whether a copy of the message should be kept in a machine journal on the originating computer.
UseTracing | Gets or sets a value indicating whether to trace a message as it moves toward its destination queue.

See Also

DefaultPropertiesToSend Class | System.Messaging Namespace


DefaultPropertiesToSend.AcknowledgeType

Gets or sets the type of acknowledgement messages generated or returned to the sending application.

[Visual Basic]
Public Property AcknowledgeType As AcknowledgeType
[C#]
public AcknowledgeType AcknowledgeType {get; set;}
[C++]
public: __property AcknowledgeType get_AcknowledgeType();
public: __property void set_AcknowledgeType(AcknowledgeType);
[JScript]
public function get AcknowledgeType() : AcknowledgeType;
public function set AcknowledgeType(AcknowledgeType);

Property Value

One of the AcknowledgeType enumeration values. This value is used to determine the type of acknowledgment messages the system posts in the administration queue and when acknowledgments are returned to the sending application. The default is AcknowledgeType.None.

Remarks

AcknowledgeType provides access to the Ack property of the Message Queuing application's MSMQMessage object.

See Also

DefaultPropertiesToSend Class | DefaultPropertiesToSend Members | System.Messaging Namespace | TBD


DefaultPropertiesToSend.AdministrationQueue

Gets or sets the queue used for acknowledgement messages generated by the application.

[Visual Basic]
Public Property AdministrationQueue As MessageQueue
[C#]
public MessageQueue AdministrationQueue {get; set;}
[C++]
public: __property MessageQueue* get_AdministrationQueue();
public: __property void set_AdministrationQueue(MessageQueue*);
[JScript]
public function get AdministrationQueue() : MessageQueue;
public function set AdministrationQueue(MessageQueue);

Property Value

The MessageQueue that specifies the administration queue used for system-generated acknowledgment messages. The default is a null reference (Visual Basic Nothing).

Remarks

AdministrationQueue provides access to the AdminQueueInfo property of the Message Queuing application's MSMQMessage object.

See Also

DefaultPropertiesToSend Class | DefaultPropertiesToSend Members | System.Messaging Namespace | TBD


DefaultPropertiesToSend.AppSpecific

Gets or sets application-generated information.

[Visual Basic]
Public Property AppSpecific As Integer
[C#]
public int AppSpecific {get; set;}
[C++]
public: __property int get_AppSpecific();
public: __property void set_AppSpecific(int);
[JScript]
public function get AppSpecific() : int;
public function set AppSpecific(int);

Property Value

The information generated by the application, such as single integer values or application-defined message classes. The default is 0.

Remarks

AppSpecific provides access to the AppSpecific property of the Message Queuing application's MSMQMessage object.

Where possible, message data should be included in the body of the message rather than in the extension. Use AppSpecific rather than Extension to attach information such as single integer values or application-defined message classes.

See Also

DefaultPropertiesToSend Class | DefaultPropertiesToSend Members | System.Messaging Namespace | TBD


DefaultPropertiesToSend.AttachSenderId

Gets or sets a value indicating if the sender ID is to be attached to the message.

[Visual Basic]
Public Property AttachSenderId As Boolean
[C#]
public bool AttachSenderId {get; set;}
[C++]
public: __property bool get_AttachSenderId();
public: __property void set_AttachSenderId(bool);
[JScript]
public function get AttachSenderId() : Boolean;
public function set AttachSenderId(Boolean);

Property Value

true if the SenderId is to be attached to the message; otherwise, false. The default is true.

Remarks

AttachSenderId provides access to the SenderIdType property of the Message Queuing application's MSMQMessage object.

The SenderId property of the message is an array of bytes that represents the identifier of the sending user. Typically, this property is set when the message is sent. When the sender ID is not attached to the message, the sending application is indicating that Message Queuing should not validate the message's sender or verify that the sender has access rights to the receiving queue.

See Also

DefaultPropertiesToSend Class | DefaultPropertiesToSend Members | System.Messaging Namespace | TBD


DefaultPropertiesToSend.EncryptionAlgorithm

Gets or sets the encryption algorithm used to encrypt the body of a private message.

[Visual Basic]
Public Property EncryptionAlgorithm As EncryptionAlgorithm
[C#]
public EncryptionAlgorithm EncryptionAlgorithm {get; set;}
[C++]
public: __property EncryptionAlgorithm get_EncryptionAlgorithm();
public: __property void set_EncryptionAlgorithm(EncryptionAlgorithm);
[JScript]
public function get EncryptionAlgorithm() : EncryptionAlgorithm;
public function set EncryptionAlgorithm(EncryptionAlgorithm);

Property Value

One of the EncryptionAlgorithm enumeration values. This value is used to encrypt the message body of a private message. The default is RC2.

Remarks

EncryptionAlgorithm provides access to the EncryptAlgorithm property of the Message Queuing application's MSMQMessage object.

See Also

DefaultPropertiesToSend Class | DefaultPropertiesToSend Members | System.Messaging Namespace | TBD


DefaultPropertiesToSend.Extension

Gets or sets additional information associated with the message.

[Visual Basic]
Public Property Extension As Byte ()
[C#]
public byte[] Extension {get; set;}
[C++]
public: __property unsigned char* get_Extension();
public: __property void set_Extension(unsigned char*[]);
[JScript]
public function get Extension() : Byte[];
public function set Extension(Byte[]);

Property Value

An array of bytes that provides additional, application-defined information associated with the message. The default is a zero-length array of bytes.

Remarks

Extension provides access to the Extension property of the Message Queuing application's MSMQMessage object.

Where possible, message data should be included in the body of the message rather than in the extension. Use Extension rather than AppSpecific when you must attach a random binary large object. It is the responsibility of the application to understand the content of this array.

See Also

DefaultPropertiesToSend Class | DefaultPropertiesToSend Members | System.Messaging Namespace | AppSpecific | TBD


DefaultPropertiesToSend.HashAlgorithm

Gets or sets the hashing algorithm used when authenticating messages.

[Visual Basic]
Public Property HashAlgorithm As HashAlgorithm
[C#]
public HashAlgorithm HashAlgorithm {get; set;}
[C++]
public: __property HashAlgorithm get_HashAlgorithm();
public: __property void set_HashAlgorithm(HashAlgorithm);
[JScript]
public function get HashAlgorithm() : HashAlgorithm;
public function set HashAlgorithm(HashAlgorithm);

Property Value

One of the HashAlgorithm enumeration values. This value identifies the hashing algorithm Message Queuing uses when authenticating messages. The default is MD5.

Remarks

HashAlgorithm provides access to the HashAlgorithm property of the Message Queuing application's MSMQMessage object. The Message Queuing run-time code uses the hashing algorithm when creating a digital signature and when authenticating the message.

See Also

DefaultPropertiesToSend Class | DefaultPropertiesToSend Members | System.Messaging Namespace | TBD


DefaultPropertiesToSend.Label

Gets or sets the message label.

[Visual Basic]
Public Property Label As String
[C#]
public string Label {get; set;}
[C++]
public: __property String* get_Label();
public: __property void set_Label(String*);
[JScript]
public function get Label() : String;
public function set Label(String);

Property Value

The label of the message. The default is an empty string.

Remarks

Label provides access to the Label property of the Message Queuing application's MSMQMessage object.

Example [Visual Basic]

The following example demonstrates defining different DefaultPropertiesToSend based on whether a message passed into the procedure has highest or normal MessagePriority. The properties that are set, which apply to the message to be sent to the message queue, are the Label, the Priority, the TimeToBeReceived, and the TimeToReachQueue. It is important to note that these properties are set through the MessageQueue, but they apply to the Message object.

This example assumes that the calling procedure passes in a MessagePriority, and that an urgent message is indicated by Highest priority. It also assumes that the calling method defines the Message that is to be sent to the queue.

[Visual Basic]

Private Sub SetDefaultPropertiesToSend(ByVal urgency As MessagePriority, ByVal msg As System.Messaging.Message)
    'Create DefaultPropertiesToSend objects
    Dim urgentMessageProperties As DefaultPropertiesToSend
    Dim normalMessageProperties As DefaultPropertiesToSend
    'Define and instantiate a new MessageQueue object
    Dim MessageQueue1 As System.Messaging.MessageQueue.MessageQueue
    Set Me.MessageQueue1 = New System.Messaging.MessageQueue
    'Set the queue formatter to the XML-based formatter
    Set MessageQueue1.Formatter = New System.Messaging.XmlQueueMessageFormatter
    Set MessageQueue1.DefaultPropertiesToSend.UseDeadLetterQueue = True

    'Set the label for the queue (as opposed to the message labels).
    Set MessageQueue1.Label = "Order Queue"
    'Set the queue path
    MessageQueue1.Path = "mycomputer\myqueue"
    'Instantiate two new DefaultPropertiesToSend objects
    Set urgentMessageProperties = New DefaultPropertiesToSend
    Set normalMessageProperties = New DefaultPropertiesToSend
    'Set the label and priority for urgent messages
    urgentMessageProperties.Label = "Urgent Message"
    urgentMessageProperties.Priority = MessagePriority.Highest
    'Make the process wait indefinitely for a message.
    urgentMessageProperties.TimeToBeReceived = Message.InfiniteTimeout
    urgentMessageProperties.TimeToReachQueue = Message.InfiniteTimeout
    urgentMessageProperties.UseDeadLetterQueue = True
    'set the label and priority for normal messages
    normalMessageProperties.Label = "Normal Message"
    normalMessageProperties.Priority = MessagePriority.Normal
    'Make the process wait a finite amount of time for a message.
    normalMessageProperties.TimeToBeReceived = 3000
    normalMessageProperties.TimeToReachQueue = 3000
    normalMessageProperties.UseDeadLetterQueue = True
    'If the message is urgent, use the urgent DefaultPropertiesToSend
    If urgency = MessagePriority.Highest Then
        Set MessageQueue1.DefaultPropertiesToSend = urgentMessageProperties
    Else
        'Otherwise, use normal DefaultPropertiesToSend
        Set MessageQueue1.DefaultPropertiesToSend = normalMessageProperties
    End If
    'Override default properties on the message object
    msg.Priority = MessageQueue1.DefaultPropertiesToSend.Priority
    msg.Label = MessageQueue1.DefaultPropertiesToSend.Label
    msg.TimeToBeReceived = MessageQueue1.DefaultPropertiesToSend.TimeToBeReceived
    msg.TimeToReachQueue = MessageQueue1.DefaultPropertiesToSend.TimeToReachQueue
    'Send the message that was passed in.
    MessageQueue1.Send msg
    'Display Label and MessagePriority information on the screen
    MessageBox.Show MessageQueue1.DefaultPropertiesToSend.Label & ". Priority: " & MessageQueue1.DefaultPropertiesToSend.Priority
End Sub

See Also

DefaultPropertiesToSend Class | DefaultPropertiesToSend Members | System.Messaging Namespace | TBD


DefaultPropertiesToSend.Priority

Gets or sets the message priority.

[Visual Basic]
Public Property Priority As MessagePriority
[C#]
public MessagePriority Priority {get; set;}
[C++]
public: __property MessagePriority get_Priority();
public: __property void set_Priority(MessagePriority);
[JScript]
public function get Priority() : MessagePriority;
public function set Priority(MessagePriority);

Property Value

One of the MessagePriority enumeration values. This value represents the priority level of a nontransactional message. The default is Normal.

Remarks

Priority provides access to the Priority property of the Message Queuing application's MSMQMessage object.

Priority can only be set for non-transactional messages, since the Priority for transactional messages is automatically set to 0. Priority is ignored by the transaction.

Message priority affects how Message Queuing handles the message while it is in route, as well as where the message is placed in the queue. Higher priority messages are given preference during routing and inserted toward the front of the queue. Messages with the same priority are placed in the queue according to their arrival time.

Example [Visual Basic]

The following example demonstrates defining different DefaultPropertiesToSend based on whether a message passed into the procedure has highest or normal MessagePriority. The properties that are set, which apply to the message to be sent to the message queue, are the Label, the Priority, the TimeToBeReceived, and the TimeToReachQueue. It is important to note that these properties are set through the MessageQueue, but they apply to the Message object.

This example assumes that the calling procedure passes in a MessagePriority, and that an urgent message is indicated by Highest priority. It also assumes that the calling method defines the Message that is to be sent to the queue.

[Visual Basic]

Private Sub SetDefaultPropertiesToSend(ByVal urgency As MessagePriority, ByVal msg As System.Messaging.Message)
    'Create DefaultPropertiesToSend objects
    Dim urgentMessageProperties As DefaultPropertiesToSend
    Dim normalMessageProperties As DefaultPropertiesToSend
    'Define and instantiate a new MessageQueue object
    Dim MessageQueue1 As System.Messaging.MessageQueue.MessageQueue
    Set Me.MessageQueue1 = New System.Messaging.MessageQueue
    'Set the queue formatter to the XML-based formatter
    Set MessageQueue1.Formatter = New System.Messaging.XmlQueueMessageFormatter
    Set MessageQueue1.DefaultPropertiesToSend.UseDeadLetterQueue = True

    'Set the label for the queue (as opposed to the message labels).
    Set MessageQueue1.Label = "Order Queue"
    'Set the queue path
    MessageQueue1.Path = "mycomputer\myqueue"
    'Instantiate two new DefaultPropertiesToSend objects
    Set urgentMessageProperties = New DefaultPropertiesToSend
    Set normalMessageProperties = New DefaultPropertiesToSend
    'Set the label and priority for urgent messages
    urgentMessageProperties.Label = "Urgent Message"
    urgentMessageProperties.Priority = MessagePriority.Highest
    'Make the process wait indefinitely for a message.
    urgentMessageProperties.TimeToBeReceived = Message.InfiniteTimeout
    urgentMessageProperties.TimeToReachQueue = Message.InfiniteTimeout
    urgentMessageProperties.UseDeadLetterQueue = True
    'set the label and priority for normal messages
    normalMessageProperties.Label = "Normal Message"
    normalMessageProperties.Priority = MessagePriority.Normal
    'Make the process wait a finite amount of time for a message.
    normalMessageProperties.TimeToBeReceived = 3000
    normalMessageProperties.TimeToReachQueue = 3000
    normalMessageProperties.UseDeadLetterQueue = True
    'If the message is urgent, use the urgent DefaultPropertiesToSend
    If urgency = MessagePriority.Highest Then
        Set MessageQueue1.DefaultPropertiesToSend = urgentMessageProperties
    Else
        'Otherwise, use normal DefaultPropertiesToSend
        Set MessageQueue1.DefaultPropertiesToSend = normalMessageProperties
    End If
    'Override default properties on the message object
    msg.Priority = MessageQueue1.DefaultPropertiesToSend.Priority
    msg.Label = MessageQueue1.DefaultPropertiesToSend.Label
    msg.TimeToBeReceived = MessageQueue1.DefaultPropertiesToSend.TimeToBeReceived
    msg.TimeToReachQueue = MessageQueue1.DefaultPropertiesToSend.TimeToReachQueue
    'Send the message that was passed in.
    MessageQueue1.Send msg
    'Display Label and MessagePriority information on the screen
    MessageBox.Show MessageQueue1.DefaultPropertiesToSend.Label & ". Priority: " & MessageQueue1.DefaultPropertiesToSend.Priority
End Sub

See Also

DefaultPropertiesToSend Class | DefaultPropertiesToSend Members | System.Messaging Namespace | TBD


DefaultPropertiesToSend.Recoverable

Gets or sets a value indicating whether the message is guaranteed to be delivered in the event of a computer failure or network problem.

[Visual Basic]
Public Property Recoverable As Boolean
[C#]
public bool Recoverable {get; set;}
[C++]
public: __property bool get_Recoverable();
public: __property void set_Recoverable(bool);
[JScript]
public function get Recoverable() : Boolean;
public function set Recoverable(Boolean);

Property Value

true if the message is guaranteed delivery even if a computer fails while the message is en-route to the queue; false if delivery is not assured in the event of computer failure. The default is false.

Remarks

Recoverable provides access to the Delivery property of the Message Queuing application's MSMQMessage object.

When Recoverable is true, delivery of a message is assured by storing the message locally until a successful forward has been achieved. In every hop along its route, the message is forwarded to the next hop or stored locally in a backup file until delivered. Because of this, throughput may be slower for a message for which Recoverable is true.

Recoverable should be set to true if your message is transactional.

See Also

DefaultPropertiesToSend Class | DefaultPropertiesToSend Members | System.Messaging Namespace | TBD


DefaultPropertiesToSend.ResponseQueue

Gets or sets the queue which receives application-generated response messages.

[Visual Basic]
Public Property ResponseQueue As MessageQueue
[C#]
public MessageQueue ResponseQueue {get; set;}
[C++]
public: __property MessageQueue* get_ResponseQueue();
public: __property void set_ResponseQueue(MessageQueue*);
[JScript]
public function get ResponseQueue() : MessageQueue;
public function set ResponseQueue(MessageQueue);

Property Value

The MessageQueue to which application-generated response messages are returned. The default is a null reference (Visual Basic Nothing).

Remarks

ResponseQueue provides access to the ResponseQueueInfo property of the Message Queuing application's MSMQMessage object.

Messages returned to the response queue are application-defined. The application must define what is in the messages as well as what is to be done when a message is received.

See Also

DefaultPropertiesToSend Class | DefaultPropertiesToSend Members | System.Messaging Namespace | TBD


DefaultPropertiesToSend.TimeToBeReceived

Gets or sets the time limit for the message to be retrieved from the target queue.

[Visual Basic]
Public Property TimeToBeReceived As TimeSpan
[C#]
public TimeSpan TimeToBeReceived {get; set;}
[C++]
public: __property TimeSpan get_TimeToBeReceived();
public: __property void set_TimeToBeReceived(TimeSpan);
[JScript]
public function get TimeToBeReceived() : TimeSpan;
public function set TimeToBeReceived(TimeSpan);

Property Value

The time limit, in seconds, for the message to be retrieved from the target queue. The default is InfiniteTimeout.

Remarks

TimeToBeReceived provides access to the MaxTimeToReceive property of the Message Queuing application's MSMQMessage object.

The time limit for the message to be retrieved from the target queue includes the time spent getting to the destination queue, plus the time spent waiting in the queue before it is retrieved by an application.

If the TimeToBeReceived interval expires before the message is removed from the queue, the Message Queuing application discards the message, sending it to the dead-letter queue if the message's UseDeadLetterQueue property is set to true.

Message Queuing can also send a negative acknowledgment message back to the sending application if the message's AcknowledgeType property is set accordingly and the message is not retrieved before the timer expires.

Example [Visual Basic]

The following example demonstrates defining different DefaultPropertiesToSend based on whether a message passed into the procedure has highest or normal MessagePriority. The properties that are set, which apply to the message to be sent to the message queue, are the Label, the Priority, the TimeToBeReceived, and the TimeToReachQueue. It is important to note that these properties are set through the MessageQueue, but they apply to the Message object.

This example assumes that the calling procedure passes in a MessagePriority, and that an urgent message is indicated by Highest priority. It also assumes that the calling method defines the Message that is to be sent to the queue.

[Visual Basic]

Private Sub SetDefaultPropertiesToSend(ByVal urgency As MessagePriority, ByVal msg As System.Messaging.Message)
    'Create DefaultPropertiesToSend objects
    Dim urgentMessageProperties As DefaultPropertiesToSend
    Dim normalMessageProperties As DefaultPropertiesToSend
    'Define and instantiate a new MessageQueue object
    Dim MessageQueue1 As System.Messaging.MessageQueue.MessageQueue
    Set Me.MessageQueue1 = New System.Messaging.MessageQueue
    'Set the queue formatter to the XML-based formatter
    Set MessageQueue1.Formatter = New System.Messaging.XmlQueueMessageFormatter
    Set MessageQueue1.DefaultPropertiesToSend.UseDeadLetterQueue = True

    'Set the label for the queue (as opposed to the message labels).
    Set MessageQueue1.Label = "Order Queue"
    'Set the queue path
    MessageQueue1.Path = "mycomputer\myqueue"
    'Instantiate two new DefaultPropertiesToSend objects
    Set urgentMessageProperties = New DefaultPropertiesToSend
    Set normalMessageProperties = New DefaultPropertiesToSend
    'Set the label and priority for urgent messages
    urgentMessageProperties.Label = "Urgent Message"
    urgentMessageProperties.Priority = MessagePriority.Highest
    'Make the process wait indefinitely for a message.
    urgentMessageProperties.TimeToBeReceived = Message.InfiniteTimeout
    urgentMessageProperties.TimeToReachQueue = Message.InfiniteTimeout
    urgentMessageProperties.UseDeadLetterQueue = True
    'set the label and priority for normal messages
    normalMessageProperties.Label = "Normal Message"
    normalMessageProperties.Priority = MessagePriority.Normal
    'Make the process wait a finite amount of time for a message.
    normalMessageProperties.TimeToBeReceived = 3000
    normalMessageProperties.TimeToReachQueue = 3000
    normalMessageProperties.UseDeadLetterQueue = True
    'If the message is urgent, use the urgent DefaultPropertiesToSend
    If urgency = MessagePriority.Highest Then
        Set MessageQueue1.DefaultPropertiesToSend = urgentMessageProperties
    Else
        'Otherwise, use normal DefaultPropertiesToSend
        Set MessageQueue1.DefaultPropertiesToSend = normalMessageProperties
    End If
    'Override default properties on the message object
    msg.Priority = MessageQueue1.DefaultPropertiesToSend.Priority
    msg.Label = MessageQueue1.DefaultPropertiesToSend.Label
    msg.TimeToBeReceived = MessageQueue1.DefaultPropertiesToSend.TimeToBeReceived
    msg.TimeToReachQueue = MessageQueue1.DefaultPropertiesToSend.TimeToReachQueue
    'Send the message that was passed in.
    MessageQueue1.Send msg
    'Display Label and MessagePriority information on the screen
    MessageBox.Show MessageQueue1.DefaultPropertiesToSend.Label & ". Priority: " & MessageQueue1.DefaultPropertiesToSend.Priority
End Sub

See Also

DefaultPropertiesToSend Class | DefaultPropertiesToSend Members | System.Messaging Namespace | TBD


DefaultPropertiesToSend.TimeToReachQueue

Gets or sets the time limit for the message to reach the queue.

[Visual Basic]
Public Property TimeToReachQueue As TimeSpan
[C#]
public TimeSpan TimeToReachQueue {get; set;}
[C++]
public: __property TimeSpan get_TimeToReachQueue();
public: __property void set_TimeToReachQueue(TimeSpan);
[JScript]
public function get TimeToReachQueue() : TimeSpan;
public function set TimeToReachQueue(TimeSpan);

Property Value

The time limit, in seconds, for the message to reach the queue. The default is InfiniteTimeout.

Remarks

TimeToReachQueue provides access to the MaxTimeToReachQueue property of the Message Queuing application's MSMQMessage object.

If the TimeToReachQueue interval expires before the message reaches its destination, the Message Queuing application discards the message, sending it to the dead-letter queue if the message's UseDeadLetterQueue property is set to true.

Message Queuing can also send a negative acknowledgment message back to the sending application if the message's AcknowledgeType property is set accordingly and the message does not arrive before the timer expires.

Example [Visual Basic]

The following example demonstrates defining different DefaultPropertiesToSend based on whether a message passed into the procedure has highest or normal MessagePriority. The properties that are set, which apply to the message to be sent to the message queue, are the Label, the Priority, the TimeToBeReceived, and the TimeToReachQueue. It is important to note that these properties are set through the MessageQueue, but they apply to the Message object.

This example assumes that the calling procedure passes in a MessagePriority, and that an urgent message is indicated by Highest priority. It also assumes that the calling method defines the Message that is to be sent to the queue.

[Visual Basic]

Private Sub SetDefaultPropertiesToSend(ByVal urgency As MessagePriority, ByVal msg As System.Messaging.Message)
    'Create DefaultPropertiesToSend objects
    Dim urgentMessageProperties As DefaultPropertiesToSend
    Dim normalMessageProperties As DefaultPropertiesToSend
    'Define and instantiate a new MessageQueue object
    Dim MessageQueue1 As System.Messaging.MessageQueue.MessageQueue
    Set Me.MessageQueue1 = New System.Messaging.MessageQueue
    'Set the queue formatter to the XML-based formatter
    Set MessageQueue1.Formatter = New System.Messaging.XmlQueueMessageFormatter
    Set MessageQueue1.DefaultPropertiesToSend.UseDeadLetterQueue = True

    'Set the label for the queue (as opposed to the message labels).
    Set MessageQueue1.Label = "Order Queue"
    'Set the queue path
    MessageQueue1.Path = "mycomputer\myqueue"
    'Instantiate two new DefaultPropertiesToSend objects
    Set urgentMessageProperties = New DefaultPropertiesToSend
    Set normalMessageProperties = New DefaultPropertiesToSend
    'Set the label and priority for urgent messages
    urgentMessageProperties.Label = "Urgent Message"
    urgentMessageProperties.Priority = MessagePriority.Highest
    'Make the process wait indefinitely for a message.
    urgentMessageProperties.TimeToBeReceived = Message.InfiniteTimeout
    urgentMessageProperties.TimeToReachQueue = Message.InfiniteTimeout
    urgentMessageProperties.UseDeadLetterQueue = True
    'set the label and priority for normal messages
    normalMessageProperties.Label = "Normal Message"
    normalMessageProperties.Priority = MessagePriority.Normal
    'Make the process wait a finite amount of time for a message.
    normalMessageProperties.TimeToBeReceived = 3000
    normalMessageProperties.TimeToReachQueue = 3000
    normalMessageProperties.UseDeadLetterQueue = True
    'If the message is urgent, use the urgent DefaultPropertiesToSend
    If urgency = MessagePriority.Highest Then
        Set MessageQueue1.DefaultPropertiesToSend = urgentMessageProperties
    Else
        'Otherwise, use normal DefaultPropertiesToSend
        Set MessageQueue1.DefaultPropertiesToSend = normalMessageProperties
    End If
    'Override default properties on the message object
    msg.Priority = MessageQueue1.DefaultPropertiesToSend.Priority
    msg.Label = MessageQueue1.DefaultPropertiesToSend.Label
    msg.TimeToBeReceived = MessageQueue1.DefaultPropertiesToSend.TimeToBeReceived
    msg.TimeToReachQueue = MessageQueue1.DefaultPropertiesToSend.TimeToReachQueue
    'Send the message that was passed in.
    MessageQueue1.Send msg
    'Display Label and MessagePriority information on the screen
    MessageBox.Show MessageQueue1.DefaultPropertiesToSend.Label & ". Priority: " & MessageQueue1.DefaultPropertiesToSend.Priority
End Sub

See Also

DefaultPropertiesToSend Class | DefaultPropertiesToSend Members | System.Messaging Namespace | TBD


DefaultPropertiesToSend.TransactionStatusQueue

Gets the transaction status queue on the source computer.

[Visual Basic]
Public Property TransactionStatusQueue As MessageQueue
[C#]
public MessageQueue TransactionStatusQueue {get; set;}
[C++]
public: __property MessageQueue* get_TransactionStatusQueue();
public: __property void set_TransactionStatusQueue(MessageQueue*);
[JScript]
public function get TransactionStatusQueue() : MessageQueue;
public function set TransactionStatusQueue(MessageQueue);

Property Value

The transaction status queue on the source computer, used for sending acknowledgement messages back to the sending application. The default is a null reference (Visual Basic Nothing).

Remarks

TransactionStatusQueue provides access to the TransactionStatusQueueInfo property of the Message Queuing application's MSMQMessage object.

Connector applications can use the MSMQMessage object to send positive (read receipt) or negative acknowledgment messages back to the sending application. The transaction status queue should receive these acknowledgments even if the sending application does not request other acknowledgments.

See Also

DefaultPropertiesToSend Class | DefaultPropertiesToSend Members | System.Messaging Namespace | TBD


DefaultPropertiesToSend.UseAuthentication

Gets or sets a value indicating whether the message must be authenticated.

[Visual Basic]
Public Property UseAuthentication As Boolean
[C#]
public bool UseAuthentication {get; set;}
[C++]
public: __property bool get_UseAuthentication();
public: __property void set_UseAuthentication(bool);
[JScript]
public function get UseAuthentication() : Boolean;
public function set UseAuthentication(Boolean);

Property Value

true if the the sending application requested authentication for the message; otherwise, false. The default is false.

Remarks

UseAuthentication provides access to the IsAuthenticated property of the Message Queuing application's MSMQMessage object.

See Also

DefaultPropertiesToSend Class | DefaultPropertiesToSend Members | System.Messaging Namespace | TBD


DefaultPropertiesToSend.UseDeadLetterQueue

Gets or sets a value indicating whether a copy of the message that could not be delivered should be sent to a dead-letter queue.

[Visual Basic]
Public Property UseDeadLetterQueue As Boolean
[C#]
public bool UseDeadLetterQueue {get; set;}
[C++]
public: __property bool get_UseDeadLetterQueue();
public: __property void set_UseDeadLetterQueue(bool);
[JScript]
public function get UseDeadLetterQueue() : Boolean;
public function set UseDeadLetterQueue(Boolean);

Property Value

true if message delivery failure should result in a copy of the message being sent to a dead-letter queue; otherwise, false. The default is false.

Remarks

UseDeadLetterQueue provides access to a part of the functionality of the Journal property of the Message Queuing application's MSMQMessage object. The rest of the functionality is provided by UseJournalQueue.

In case of delivery failure for non-transactional messages, the message is sent to the non-transactional dead-letter queue on the computer that could not deliver the message (for example, if a message timer expires).

In the case of delivery failure for transactional messages, the message is sent to the transactional dead-letter queue on the source machine in all negative and in-doubt cases.

When you store messages in a dead-letter queue, clear the queue periodically to remove messages that are no longer needed. Messages stored in dead-letter queues count against the quota for the computer where the queue resides (the computer quota is set by the administrator).

See Also

DefaultPropertiesToSend Class | DefaultPropertiesToSend Members | System.Messaging Namespace | TBD


DefaultPropertiesToSend.UseEncryption

Gets or sets a value indicating whether to encrypt private messages.

[Visual Basic]
Public Property UseEncryption As Boolean
[C#]
public bool UseEncryption {get; set;}
[C++]
public: __property bool get_UseEncryption();
public: __property void set_UseEncryption(bool);
[JScript]
public function get UseEncryption() : Boolean;
public function set UseEncryption(Boolean);

Property Value

true to require Message Queuing to encrypt a private message; otherwise, false. The default is false.

Remarks

UseEncryption provides access to the PrivLevel property of the Message Queuing application's MSMQMessage object.

See Also

DefaultPropertiesToSend Class | DefaultPropertiesToSend Members | System.Messaging Namespace | EncryptionAlgorithm | TBD


DefaultPropertiesToSend.UseJournalQueue

Gets or sets a value indicating whether a copy of the message should be kept in a machine journal on the originating computer.

[Visual Basic]
Public Property UseJournalQueue As Boolean
[C#]
public bool UseJournalQueue {get; set;}
[C++]
public: __property bool get_UseJournalQueue();
public: __property void set_UseJournalQueue(bool);
[JScript]
public function get UseJournalQueue() : Boolean;
public function set UseJournalQueue(Boolean);

Property Value

true to require that a copy of a message be kept in the originating computer's machine journal after it has been successfully transmitted (from the originating computer to the next hop); otherwise, false. The default is false.

Remarks

UseJournalQueue provides access to a part of the functionality of the Journal property of the Message Queuing application's MSMQMessage object. The rest of the functionality is provided by UseDeadLetterQueue.

When you store messages in a journal queue, clear the queue periodically to remove messages that are no longer needed. Message stored in journal queues count against the quota for the computer where the queue resides (the computer quota is set by the administrator)

See Also

DefaultPropertiesToSend Class | DefaultPropertiesToSend Members | System.Messaging Namespace | TBD


DefaultPropertiesToSend.UseTracing

Gets or sets a value indicating whether to trace a message as it moves toward its destination queue.

[Visual Basic]
Public Property UseTracing As Boolean
[C#]
public bool UseTracing {get; set;}
[C++]
public: __property bool get_UseTracing();
public: __property void set_UseTracing(bool);
[JScript]
public function get UseTracing() : Boolean;
public function set UseTracing(Boolean);

Property Value

true if each hop made by the original message will generate a report to be sent to the system's report queue; otherwise, false. The default is false.

Remarks

UseTracing provides access to the Trace property of the Message Queuing application's MSMQMessage object.When a message is sent with tracing enabled, a report message is generated and sent to the system report queue each time the message passes through a Message Queuing routing server. Report queues are not limited to Message Queuing application-generated report messages. Application-generated messages can be sent to report queues as well.

See Also

DefaultPropertiesToSend Class | DefaultPropertiesToSend Members | System.Messaging Namespace | TBD


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DefaultPropertiesToSend Methods

The methods of the DefaultPropertiesToSend class are listed below. For a complete list of DefaultPropertiesToSend class members, see the DefaultPropertiesToSend Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ShouldPersistExtension | Specifies whether to save application-defined information associated with the message.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefaultPropertiesToSend Class | System.Messaging Namespace


DefaultPropertiesToSend.ShouldPersistExtension

Specifies whether to save application-defined information associated with the message.

[Visual Basic]
Public Function ShouldPersistExtension() As Boolean
[C#]
public bool ShouldPersistExtension();
[C++]
public: bool ShouldPersistExtension();
[JScript]
public function ShouldPersistExtension() : Boolean;

Return Value

true if Extension information exists and should be persisted; otherwise, false.

Remarks

The Extension property is typically used by applications that need to specify or read non-MSMQ messages. It is the responsibility of the application to understand the content of this property.

See Also

DefaultPropertiesToSend Class | DefaultPropertiesToSend Members | System.Messaging Namespace | Extension


EncryptionAlgorithm Enumeration

Specifies the encryption algorithm used to encrypt the message body of a private message.

[Visual Basic]
Public Enum EncryptionAlgorithm
[C#]
public enum EncryptionAlgorithm
[C++]
public enum EncryptionAlgorithm

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

Cipher modes define the method in which data is encrypted. The stream cipher mode encodes data one bit at a time. The block cipher mode encodes data one block at a time. Although it tends to execute more slowly than stream cipher, block cipher is more secure. The following table describes the cipher mode for each of the EncryptionAlgorithm values.

Encryption | Cipher Mode
RC2 | 64-bit block
RC4 | stream

EncryptionAlgorithm provides access to the EncryptAlgorithm property of the Message Queuing application's MSMQMessage object. The MSMQMessage object's property ultimately provides access to NT encryption levels.

_mq_msmqmessage.encryptalgorithm

Members

Member Name | Description
None | No encryption.
RC2 | The value MQMSG_CALG_RC2. This is the default value for the EncryptAlgorithm property of the Message Queuing application's MSMQMessage object.
RC4 | The value MQMSG_CALG_RC4. This corresponds to the less secure option for the EncryptAlgorithm property of the Message Queuing application's MSMQMessage object.

Requirements

Namespace: System.Messaging

Assembly: system.messaging.dll

See Also

System.Messaging Namespace


EncryptionRequired Enumeration

Specifies the privacy level of messages received by the queue.

[Visual Basic]
Public Enum EncryptionRequired
[C#]
public enum EncryptionRequired
[C++]
public enum EncryptionRequired

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

You can specify whether the queue accepts private (encrypted) messages, non-private (non-encrypted) messages, or both.

For more information about privacy levels, see the TBD documentation in the Platform SDK.

Members

Member Name | Description
Body | Accepts only private (encrypted) messages.
None | Accepts only non-private (non-encrypted) messages.
Optional | Does not force privacy. Accepts private (encrypted) messages and non-private (non-encrypted) messages.

Requirements

Namespace: System.Messaging

Assembly: system.messaging.dll

See Also

System.Messaging Namespace


HashAlgorithm Enumeration

Specifies the hash algorithm used by Message Queuing when authenticating messages.

[Visual Basic]
Public Enum HashAlgorithm
[C#]
public enum HashAlgorithm
[C++]
public enum HashAlgorithm

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

Message authentication provides two services. It provides a way to ensure message integrity and a way to verify who sent the message. To request authentication, the sending application must set the authentication level of the message to be authenticated and attach a security certificate to the message.

To authenticate messages, the Message Queuing run-time DLL on the source computer uses the hashing algorithm when creating a digital signature for a message. The target Queue Manager then uses the same hashing algorithm to authenticate the message when it is received.

For more information about the authentication process, see the TBD documentation in the Platform SDK.

Members

Member Name | Description
MAC | MAC keyed hashing algorithm.
MD2 | MD2 hashing algorithm.
MD4 | MD4 hashing algorithm.
MD5 | MD5 hashing algorithm.
None | No hashing algorithm.
SHA | SHA hashing algorithm.

Requirements

Namespace: System.Messaging

Assembly: system.messaging.dll

See Also

System.Messaging Namespace


IMessageFormatter Interface

The functions defined in this interface are used to serailize and deserialize objects into and from MessageQueue messages.

IMessageFormatter

[Visual Basic]
Public Interface IMessageFormatter
[C#]
public interface IMessageFormatter
[C++]
public __gc __interface IMessageFormatter

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IMessageFormatter

Class | Description
ActiveXMessageFormatter | Formatter class that serializes and deserializes primitives into and from MessageQueue messages using binary format.
BinaryMessageFormatter | Formatter class that serializes and deserializes objects into and from MessageQueue messages using binary format.
DataSetMessageFormatter | Formatter class that serializes and deserializes datasets into and from MessageQueue messages using Xml.
SoapMessageFormatter | Formatter class that serializes and deserializes objects into and from MessageQueue messages using Xml.

Remarks

[To be supplied.]

Requirements

Namespace: System.Messaging

Assembly: system.messaging.dll

See Also

IMessageFormatter Members | System.Messaging Namespace


IMessageFormatter Members

Methods

CanRead | When this method is called, the formatter will attempt to determine if the contents of the message are something the formatter can deal with.
Read | This method is used to read the contents from the given message and create an object.
Write | This method is used to write the given object into the given message. If the formatter cannot understand the given object, an exception is thrown.

See Also

IMessageFormatter Interface | System.Messaging Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IMessageFormatter Methods

The methods of the IMessageFormatter interface are listed below. For a complete list of IMessageFormatter interface members, see the IMessageFormatter Members topic.

CanRead | When this method is called, the formatter will attempt to determine if the contents of the message are something the formatter can deal with.
Read | This method is used to read the contents from the given message and create an object.
Write | This method is used to write the given object into the given message. If the formatter cannot understand the given object, an exception is thrown.

See Also

IMessageFormatter Interface | System.Messaging Namespace


IMessageFormatter.CanRead

When this method is called, the formatter will attempt to determine if the contents of the message are something the formatter can deal with.

[Visual Basic]
Function CanRead( _
   ByVal message As Message _
) As Boolean
[C#]
bool CanRead(
   Message message
);
[C++]
bool CanRead(
   Message* message
) = 0;
[JScript]
function CanRead(
   message : Message
) : Boolean;

Parameters

message
the message to be inspected.

Return Value

indicates wehter or not the message passed can be read.

See Also

IMessageFormatter Interface | IMessageFormatter Members | System.Messaging Namespace


IMessageFormatter.Read

This method is used to read the contents from the given message and create an object.

[Visual Basic]
Function Read( _
   ByVal message As Message _
) As Object
[C#]
object Read(
   Message message
);
[C++]
Object* Read(
   Message* message
) = 0;
[JScript]
function Read(
   message : Message
) : Object;

Parameters

message
the message to deserialize the object from.

Return Value

the object deserialized from the message.

See Also

IMessageFormatter Interface | IMessageFormatter Members | System.Messaging Namespace


IMessageFormatter.Write

This method is used to write the given object into the given message. If the formatter cannot understand the given object, an exception is thrown.

[Visual Basic]
Sub Write( _
   ByVal message As Message, _
   ByVal obj As Object _
)
[C#]
void Write(
   Message message,
   object obj
);
[C++]
void Write(
   Message* message,
   Object* obj
) = 0;
[JScript]
function Write(
   message : Message,
   obj : Object
);

Parameters

message
the message to serialize the object into.
obj
the object to be serialized.

See Also

IMessageFormatter Interface | IMessageFormatter Members | System.Messaging Namespace


Message Class

Provides access to the properties needed to define a Message Queuing message.

Object
Component
Message

[Visual Basic]
Public Class Message
   Inherits Component
[C#]
public class Message : Component
[C++]
public __gc class Message : public Component
[JScript]
public class Message extends Component

Remarks

When you send a message to a message queue, you don't have to always use the Message class, but it gives you more control over the System.Messaging.Message.Send property. For example, you can send a text message using the Send method of MessageQueue without instantiating a Message and assigning the string to the message Body; when you call Send, a Message Queuing message object (an instance of MSMQMessage) is created outside your application to wrap the text string.

Using Message enables you to access and modify the properties of the Message Queuing message object. You have more control over the object's behavior than when you let Message Queuing create a default MSMQMessage outside your application. You can specify encryption and authentication settings, capture sender information and define transaction contexts for your messages. You can also coordinate your messaging application to respond to acknowledgment and report messages in order to monitor your messages.

The message Body, in which the majority of the critical message information is stored, can be accessed both at creation time and throughout the lifetime of the Message instance. The Body is serialized using the Formatter specified, either for the MessageQueue instance or for the message itself. If it is serialized using the System.Messaging.XMLMessageFormatter, it is human-readable even while it is in the queue. If the body is serialized using another formatter (like the binary formatter), it is not human-readable between the time that it is written and the time it is received from the queue. However, binary formatters are useful because they provide faster message throughput.

When an instance of Message is created, some of the read/write properties are set to initial values. For a list of these values, see the Message constructor.

Requirements

Namespace: System.Messaging

Assembly: system.messaging.dll

Example [Visual Basic]

The following example creates an empty message. The example populates the Message with a string Body, and sets other properties. Then the message is sent to a queue. It assumes there is a queue on the computer "myComputer" with the name "myQueue".

The second procedure calls Peek on the first message in the queue "myQueue".

Import the System.Messaging namespace for this example.

[Visual Basic]

Private Sub CreateMessage()
    'Declare a message and message queue
    Dim msg As Message
    Dim mq As MessageQueue

    'Instantiate an empty message object
    msg = New Message

    'Instantiate a new MessageQueue object
    mq = New MessageQueue("myComputer\myQueue")

    'Set selected message properties.
    msg.Priority = MessagePriority.High
    msg.Label = "My Message"
    msg.TimeToBeReceived = New TimeSpan(1000)
    msg.TimeToReachQueue = New TimeSpan(1000)
    msg.Body = "New Message Body"
    'Send the message to the queue.
    mq.Send(msg)
End Sub

Private Sub PeekMessage()
    'Declare a message and message queue.
    Dim msg As Message
    Dim mq As MessageQueue
    'Set the MessageQueue to the queue in the above procedure, myQueue.
    mq = New MessageQueue("myComputer\myQueue")
    'Peek the first message in the queue.
    msg = mq.Peek
End Sub

See Also

Message Members | System.Messaging Namespace | MessageQueue | DefaultPropertiesToSend | Send | Receive | Peek


Message Members

Public:

Constructor

Message Constructor Overloaded. Initializes a new instance of the Message class.

Properties

AcknowledgeType | Gets or sets the type of acknowledgment message that Message Queuing posts when a message arrives in the queue.
Acknowledgment | Gets the classification of acknowledgment messages that Message Queuing posts.
AdministrationQueue | Gets or sets the queue used for acknowledgment messages generated by the application.
AppSpecific | Gets or sets application-generated information regarding the message.
ArrivedTime | Indicates when the message arrived at the queue.
AttachSenderId | Gets or sets a value indicating whether the sender ID is to be attached to the message.
Authenticated | Gets a value indicating whether the message was authenticated.
AuthenticationProviderName | Gets or sets the name of the cryptographic provider used to generate the digital signature of the message.
AuthenticationProviderType | Gets or sets the type of cryptographic provider used to generate the digital signature of the message.
Body | Gets or sets the serialized contents of the message.
BodyStream | Gets or sets the information in the body of the message.
BodyType | Gets or sets the type of data the message body contains.
ConnectorType | Is required whenever an application sets a message property that is typically set by MSMQ. It is typically used in the following two cases. Whenever a message is passed by a connector application, the connector type is required so that the sending and receiving applications know how to interpret the security and acknowledgment properties of the messages. When sending application-encrypted messages, this property tells the MSMQ run time to use the symmetric key.
CorrelationId | Gets or sets the message identifier used by acknowledgment and report messages to reference the original message.
DestinationQueue | Identifies the original destination queue for a message. It is typically used to determine the original destination of a message that is in a journal or dead-letter queue, however it can also be used when sending a response message back to a response queue.
DestinationSymmetricKey | Gets or sets the symmetric key used to encrypt messages.
DigitalSignature | Gets or sets the digital signature used to authenticate the message.
EncryptionAlgorithm | Gets or sets the encryption algorithm used to encrypt the body of a private message.
Extension | Gets or sets additional information associated with the message.
Formatter | Gets or sets the formatter used to read or write an object into the message body.
HashAlgorithm | Gets or sets the hashing algorithm used when authenticating messages.
Id | Gets the Message Queuing-generated identifier of the message.
IsFirstInTransaction | Gets a value indicating whether the message was the first message sent in the transaction.
IsLastInTransaction | Gets a value indicating whether the message was the last message sent in the transaction.
Label | Gets or sets the message label.
MessageType | Gets the type of the message (normal, acknowledgment, or report).
Priority | Gets or sets the message priority, used to determine where the message is placed in the queue.
Recoverable | Gets or sets a value indicating whether the message is guaranteed to be delivered in the event of a computer failure or network problem.
ResponseQueue | Gets or sets the queue which receives application-generated response messages.
SenderCertificate | Specifies the security certificate used to authenticate messages.
SenderId | This property is set by MSMQ, and is used primarily by the receiving Queue Manager when authenticating a message. The receiving Queue Manager uses the sender identifier in this property to verify where the message originated and to verify the sender has access rights to a queue.
SenderVersion | Gets the version of Message Queuing used to send the message.
SentTime | Indicates the date and time that the message was sent by the source Queue Manager.
Site (inherited from Component) | Gets or sets the site of the Component.
SourceMachine | Specifies the computer where the message originated.
TimeToBeReceived | Gets or sets the time limit for the message to be retrieved from the target queue.
TimeToReachQueue | Gets or sets the time limit for the message to reach the queue.
TransactionId | Gets the identifier for the transaction of which the message was a part.
TransactionStatusQueue | Gets the transaction status queue on the source computer.
UseAuthentication | Gets or sets a value indicating whether a message must be authenticated.
UseDeadLetterQueue | Gets or sets a value indicating whether a copy of an undeliverable message should be sent to a dead-letter queue.
UseEncryption | Gets or sets a value indicating whether to encrypt private messages.
UseJournalQueue | Gets or sets a value indicating whether a copy of the message should be kept in a machine journal on the originating computer.
UseTracing | Gets or sets a value indicating whether to trace a message as it moves toward its destination queue.

Methods

Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Fields

InfiniteTimeout Specifies that there is no timeout.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Message Class | System.Messaging Namespace


Message Constructor

Initializes a new instance of the Message class.

Overload List

Initializes a new instance of the Message class with an empty body.

[Visual Basic] Overloads Public Sub New()
[C#] public Message();
[C++] public: Message();
[JScript] public function Message();

Initializes a new instance of the Message class, serializing the object passed as an argument.

[Visual Basic] Overloads Public Sub New(Object)
[C#] public Message(Object);
[C++] public: Message(Object*);
[JScript] public function Message(Object);

Example [Visual Basic]

The following example creates an message with the body "New Message." The example then sends the message to a queue. It assumes there is a queue on the computer "myComputer" with the name "myQueue".

Import the System.Messaging namespace for this example.

Note This example shows how to use one of the overloaded version of the Message constructor. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub CreateMessage()
    'Declare a message and message queue
    Dim msg As Message
    Dim mq As MessageQueue

    'Instantiate a message with the given body.
    msg = New Message("New Message.")

    'Instantiate a new MessageQueue object
    mq = New MessageQueue("myComputer\myQueue")

    'Send the message to the queue.
    mq.Send(msg)
End Sub

See Also

Message Class | Message Members | System.Messaging Namespace


Message Constructor ()

Initializes a new instance of the Message class with an empty body.

[Visual Basic]
Overloads Public Sub New()
[C#]
public Message();
[C++]
public: Message();
[JScript]
public function Message();

Remarks

Use this overload to instantiate an empty Message object.

Specify a Body before sending the Message object. The Body can be any serializable object, such as a text string, structure object, class instance, or embedded object.

The DefaultPropertiesToSend for a MessageQueue are overridden for any Message object that is sent to that queue. (These settings still apply to other objects sent to a queue using Send.)

Set the Formatter before sending the Message to a queue. If you want the body to be human-readable between the time that it is sent and received or peeked, use the SoapMessageFormatter. For messages with dataset bodies, use the DataSetMessageFormatter. The ActiveXMessageFormatter and BinaryMessageFormatter serialize the data into binary representation. The settings require the same formatter at both ends of the message processing. Binary formats are faster than XML format, but not human-readable during transit, and can't be read and fixed if a message becomes corrupted.

When a Message is created, the following read/write properties are set to initial values.

Property | Initial Value
AcknowledgeType | AcknowledgeType.None
AdministrationQueue | a null reference (in Visual Basic Nothing)
AppSpecific | 0
AttachSenderId | true
AuthenticationProviderName | Microsoft Base Cryptographic Provider, Ver. 1.0
AuthenticationProviderType | CryptoProviderType.RSA_FULL
Body | a null reference (Nothing)
BodyStream | Stream.null
BodyType | 0
ConnectorType | Guid.Empty
CorrelationId | "" (empty string)
DestinationSymmetricKey | A zero-length array of bytes
DigitalSignature | A zero-length array of bytes
EncryptionAlgorithm | EncryptionAlgorithm.RC2
Extension | a zero-length array of bytes
Formatter | SoapMessageFormatter
HashAlgorithm | HashAlgorithm.MD5
Label | "" (empty string)
Priority | MessagePriority.Normal
Recoverable | false
ResponseQueue | a null reference (Nothing)
SenderCertificate | a zero-length array of bytes
TimeToBeReceived | Message.InfiniteTimeout
TimeToReachQueue | Message.InfiniteTimeout
TransactionStatusQueue | a null reference (Nothing)
UseAuthentication | false
UseDeadLetterQueue | false
UseEncryption | false
UseJournalQueue | false
UseTracing | false

You can change the value for any of these properties through a separate call to the property.

Example [Visual Basic]

The following example creates an empty message. The example populates the Message with a string Body, and then sends the message to a queue. It assumes there is a queue on the computer "myComputer" with the name "myQueue".

Import the System.Messaging namespace for this example.

[Visual Basic]

Private Sub CreateMessage()
    'Declare a message and message queue
    Dim msg As Message
    Dim mq As MessageQueue

    'Instantiate an empty message object
    msg = New Message

    'Instantiate a new MessageQueue object
    mq = New MessageQueue("myComputer\myQueue")

    'Set message information.
    msg.Body = "New Message Body"
    'Send the message to the queue.
    mq.Send(msg)
End Sub

See Also

Message Class | Message Members | System.Messaging Namespace | Message Constructor Overload List | AcknowledgeType | CryptoProviderType | EncryptionAlgorithm | HashAlgorithm | MessagePriority | SoapMessageFormatter | InfiniteTimeout | Guid | Stream | Body | Send | Peek | Receive


Message Constructor (Object)

Initializes a new instance of the Message class, serializing the object passed as an argument.

[Visual Basic]
Overloads Public Sub New( _
   ByVal body As Object _
)
[C#]
public Message(
   object body
);
[C++]
public: Message(
   Object* body
);
[JScript]
public function Message(
   body : Object
);

Parameters

body
The serializable body of the message.

Remarks

Use this overload to instantiate a Message object with the Body specified by the body parameter. The body parameter can be any serializable object, such as a text string, structure object, class instance, or embedded object.

The DefaultPropertiesToSend for a MessageQueue are overridden for any Message object that is sent to that queue. (These settings still apply to other objects sent to a queue using Send.)

Set the Formatter before sending the Message to a queue. If you want the body to be human-readable between the time that it is sent and received or peeked, use the SoapMessageFormatter. For messages with dataset bodies, use the DataSetMessageFormatter. The ActiveXMessageFormatter and BinaryMessageFormatter serialize the data into binary representation. The settings require the same formatter at both ends of the message processing. Binary formats are faster than XML format, but not human-readable during transit, and can't be read and fixed if a message becomes corrupted.

When a Message is created, the following read/write properties are set to initial values.

Property | Initial Value
AcknowledgeType | AcknowledgeType.None
AdministrationQueue | a null reference (in Visual Basic Nothing)
AppSpecific | 0
AttachSenderId | true
AuthenticationProviderName | Microsoft Base Cryptographic Provider, Ver. 1.0
AuthenticationProviderType | CryptoProviderType.RSA_FULL
Body | the body parameter
BodyStream | Stream.null
BodyType | 0
ConnectorType | Guid.Empty
CorrelationId | "" (empty string)
DestinationSymmetricKey | A zero-length array of bytes
DigitalSignature | A zero-length array of bytes
EncryptionAlgorithm | EncryptionAlgorithm.RC2
Extension | a zero-length array of bytes
Formatter | SoapMessageFormatter
HashAlgorithm | HashAlgorithm.MD5
Label | "" (empty string)
Priority | MessagePriority.Normal
Recoverable | false
ResponseQueue | a null reference (Nothing)
SenderCertificate | a zero-length array of bytes
TimeToBeReceived | Message.InfiniteTimeout
TimeToReachQueue | Message.InfiniteTimeout
TransactionStatusQueue | a null reference (Nothing)
UseAuthentication | false
UseDeadLetterQueue | false
UseEncryption | false
UseJournalQueue | false
UseTracing | false

You can change the value for any of these properties through a separate call to the property.

Example [Visual Basic]

The following example creates an message with the body "New Message." The example then sends the message to a queue. It assumes there is a queue on the computer "myComputer" with the name "myQueue".

Import the System.Messaging namespace for this example.

[Visual Basic]

Private Sub CreateMessage()
    'Declare a message and message queue
    Dim msg As Message
    Dim mq As MessageQueue

    'Instantiate a message with the given body.
    msg = New Message("New Message.")

    'Instantiate a new MessageQueue object
    mq = New MessageQueue("myComputer\myQueue")

    'Send the message to the queue.
    mq.Send(msg)
End Sub

See Also

Message Class | Message Members | System.Messaging Namespace | Message Constructor Overload List | AcknowledgeType | CryptoProviderType | EncryptionAlgorithm | HashAlgorithm | MessagePriority | SoapMessageFormatter | InfiniteTimeout | Guid | Stream | Send | Peek | Receive


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Message Properties

The properties of the Message class are listed below. For a complete list of Message class members, see the Message Members topic.

Public:

AcknowledgeType | Gets or sets the type of acknowledgment message that Message Queuing posts when a message arrives in the queue.
Acknowledgment | Gets the classification of acknowledgment messages that Message Queuing posts.
AdministrationQueue | Gets or sets the queue used for acknowledgment messages generated by the application.
AppSpecific | Gets or sets application-generated information regarding the message.
ArrivedTime | Indicates when the message arrived at the queue.
AttachSenderId | Gets or sets a value indicating whether the sender ID is to be attached to the message.
Authenticated | Gets a value indicating whether the message was authenticated.
AuthenticationProviderName | Gets or sets the name of the cryptographic provider used to generate the digital signature of the message.
AuthenticationProviderType | Gets or sets the type of cryptographic provider used to generate the digital signature of the message.
Body | Gets or sets the serialized contents of the message.
BodyStream | Gets or sets the information in the body of the message.
BodyType | Gets or sets the type of data the message body contains.
ConnectorType | Is required whenever an application sets a message property that is typically set by MSMQ. It is typically used in the following two cases. Whenever a message is passed by a connector application, the connector type is required so that the sending and receiving applications know how to interpret the security and acknowledgment properties of the messages. When sending application-encrypted messages, this property tells the MSMQ run time to use the symmetric key.
CorrelationId | Gets or sets the message identifier used by acknowledgment and report messages to reference the original message.
DestinationQueue | Identifies the original destination queue for a message. It is typically used to determine the original destination of a message that is in a journal or dead-letter queue, however it can also be used when sending a response message back to a response queue.
DestinationSymmetricKey | Gets or sets the symmetric key used to encrypt messages.
DigitalSignature | Gets or sets the digital signature used to authenticate the message.
EncryptionAlgorithm | Gets or sets the encryption algorithm used to encrypt the body of a private message.
Extension | Gets or sets additional information associated with the message.
Formatter | Gets or sets the formatter used to read or write an object into the message body.
HashAlgorithm | Gets or sets the hashing algorithm used when authenticating messages.
Id | Gets the Message Queuing-generated identifier of the message.
IsFirstInTransaction | Gets a value indicating whether the message was the first message sent in the transaction.
IsLastInTransaction | Gets a value indicating whether the message was the last message sent in the transaction.
Label | Gets or sets the message label.
MessageType | Gets the type of the message (normal, acknowledgment, or report).
Priority | Gets or sets the message priority, used to determine where the message is placed in the queue.
Recoverable | Gets or sets a value indicating whether the message is guaranteed to be delivered in the event of a computer failure or network problem.
ResponseQueue | Gets or sets the queue which receives application-generated response messages.
SenderCertificate | Specifies the security certificate used to authenticate messages.
SenderId | This property is set by MSMQ, and is used primarily by the receiving Queue Manager when authenticating a message. The receiving Queue Manager uses the sender identifier in this property to verify where the message originated and to verify the sender has access rights to a queue.
SenderVersion | Gets the version of Message Queuing used to send the message.
SentTime | Indicates the date and time that the message was sent by the source Queue Manager.
Site (inherited from Component) | Gets or sets the site of the Component.
SourceMachine | Specifies the computer where the message originated.
TimeToBeReceived | Gets or sets the time limit for the message to be retrieved from the target queue.
TimeToReachQueue | Gets or sets the time limit for the message to reach the queue.
TransactionId | Gets the identifier for the transaction of which the message was a part.
TransactionStatusQueue | Gets the transaction status queue on the source computer.
UseAuthentication | Gets or sets a value indicating whether a message must be authenticated.
UseDeadLetterQueue | Gets or sets a value indicating whether a copy of an undeliverable message should be sent to a dead-letter queue.
UseEncryption | Gets or sets a value indicating whether to encrypt private messages.
UseJournalQueue | Gets or sets a value indicating whether a copy of the message should be kept in a machine journal on the originating computer.
UseTracing | Gets or sets a value indicating whether to trace a message as it moves toward its destination queue.

See Also

Message Class | System.Messaging Namespace


Message.AcknowledgeType

Gets or sets the type of acknowledgment message that Message Queuing posts when a message arrives in the queue.

[Visual Basic]
Overridable Public Property AcknowledgeType As AcknowledgeType
[C#]
public AcknowledgeType AcknowledgeType {virtual get; virtual set;}
[C++]
public: __property virtual AcknowledgeType get_AcknowledgeType();
public: __property virtual void set_AcknowledgeType(AcknowledgeType);
[JScript]
public function get AcknowledgeType() : AcknowledgeType;
public function set AcknowledgeType(AcknowledgeType);

Property Value

One of the AcknowledgeType values, which represents the type of acknowledgment messages the system posts in the administration queue and when acknowledgments are returned to the sending application. The default is None.

Exceptions

Exception Type | Condition
InvalidOperationException | The message is not set to receive an AcknowledgeType. The AcknowledgeType may be set to None.

Remarks

A message can be a normal Message Queuing message, a positive or negative (arrival and read) acknowledgment message, or a report message. Typically this property is set by Message Queuing when it sends the message.

AcknowledgeType provides access to the Ack property of the Message Queuing MSMQMessage object.

See Also

Message Class | Message Members | System.Messaging Namespace


Message.Acknowledgment

Gets the classification of acknowledgment messages that Message Queuing posts.

[Visual Basic]
Overridable Public ReadOnly Property Acknowledgment As _
   Acknowledgment
[C#]
public Acknowledgment Acknowledgment {virtual get;}
[C++]
public: __property virtual Acknowledgment get_Acknowledgment();
[JScript]
public function get Acknowledgment() : Acknowledgment;

Property Value

One of the Acknowledgement values. The default value is None.

Exceptions

Exception Type | Condition
InvalidOperationException | The message is not an acknowledgment message. The message queue is filtered not to read the Acknowledgement property.

Remarks

A message can be a normal Message Queuing message, a positive or negative (arrival and read) acknowledgment message, or a report message. Typically, this property is set by Message Queuing when it sends the message.

See Also

Message Class | Message Members | System.Messaging Namespace | CorrelationId | PeekById | PeekByCorrelationId | ReceiveById | ReceiveByCorrelationId


Message.AdministrationQueue

Gets or sets the queue used for acknowledgment messages generated by the application.

[Visual Basic]
Overridable Public Property AdministrationQueue As MessageQueue
[C#]
public MessageQueue AdministrationQueue {virtual get; virtual set;}
[C++]
public: __property virtual MessageQueue* get_AdministrationQueue();
public: __property virtual void set_AdministrationQueue(MessageQueue*);
[JScript]
public function get AdministrationQueue() : MessageQueue;
public function set AdministrationQueue(MessageQueue);

Property Value

The MessageQueue that specifies the administration queue used for system-generated acknowledgment messages. The default is a null reference (in Visual Basic Nothing).

Remarks

AdministrationQueue provides access to the AdminQueueInfo property of the Message Queuing application's MSMQMessage object.

See Also

Message Class | Message Members | System.Messaging Namespace


Message.AppSpecific

Gets or sets application-generated information regarding the message.

[Visual Basic]
Overridable Public Property AppSpecific As Integer
[C#]
public int AppSpecific {virtual get; virtual set;}
[C++]
public: __property virtual int get_AppSpecific();
public: __property virtual void set_AppSpecific(int);
[JScript]
public function get AppSpecific() : int;
public function set AppSpecific(int);

Property Value

The information generated by the application, such as single integer values or application-defined message classes. The default is 0.

Remarks

AppSpecific provides access to the AppSpecific property of the Message Queuing application's MSMQMessage object.

See Also

Message Class | Message Members | System.Messaging Namespace


Message.ArrivedTime

Indicates when the message arrived at the queue.

[Visual Basic]
Overridable Public ReadOnly Property ArrivedTime As DateTime
[C#]
public DateTime ArrivedTime {virtual get;}
[C++]
public: __property virtual DateTime get_ArrivedTime();
[JScript]
public function get ArrivedTime() : DateTime;

See Also

Message Class | Message Members | System.Messaging Namespace


Message.AttachSenderId

Gets or sets a value indicating whether the sender ID is to be attached to the message.

[Visual Basic]
Overridable Public Property AttachSenderId As Boolean
[C#]
public bool AttachSenderId {virtual get; virtual set;}
[C++]
public: __property virtual bool get_AttachSenderId();
public: __property virtual void set_AttachSenderId(bool);
[JScript]
public function get AttachSenderId() : Boolean;
public function set AttachSenderId(Boolean);

Property Value

true if the SenderId is to be attached to the message; otherwise, false. The default is true.

Remarks

AttachSenderId provides access to the SenderIdType property of the Message Queuing application's MSMQMessage object.

The SenderId property of the message is an array of bytes that represents the identifier of the sending user. Typically, this property is set when the message is sent. When the sender ID is not attached to the message, the sending application is indicating that Message Queuing should not validate the message's sender or verify that the sender has access rights to the receiving queue.

Example

See Also

Message Class | Message Members | System.Messaging Namespace | SenderId | ConnectorType | UseAuthentication | Authenticated | SenderCertificate | Authenticate


Message.Authenticated

Gets a value indicating whether the message was authenticated.

[Visual Basic]
Overridable Public ReadOnly Property Authenticated As Boolean
[C#]
public bool Authenticated {virtual get;}
[C++]
public: __property virtual bool get_Authenticated();
[JScript]
public function get Authenticated() : Boolean;

Property Value

true if authentication was requested on the message when it entered the queue; otherwise, false.

Exceptions

Exception Type | Condition
InvalidOperationException | The message queue is filtered not to read the Authenticated property. -or- The Authenticated property could not be set.

Remarks

Authenticated is only used by the application interacting with the message when trying to determine if authentication was requested. If the message is in the queue, then the message was authenticated . If Authenticated is true, then the receiving Queue Manager authenticated the message when it received the message.

Note It is not possible to look at the properties of a message to determine if a message failed authentication. Messages that fail authentication are discarded and are not delivered to the queue.

If the receiving application needs only to check whether authentication was requested, it should use IsAuthenticated. However, if the receiving application also needs to check what type of signature was used during authentication, it must use MSMQMessage.ReceivedAuthenticationLevel.

See Also

Message Class | Message Members | System.Messaging Namespace | UseAuthentication | ConnectorType | Authenticate | DigitalSignature


Message.AuthenticationProviderName

Gets or sets the name of the cryptographic provider used to generate the digital signature of the message.

[Visual Basic]
Overridable Public Property AuthenticationProviderName As String
[C#]
public string AuthenticationProviderName {virtual get; virtual
   set;}
[C++]
public: __property virtual String* get_AuthenticationProviderName();
public: __property virtual void set_AuthenticationProviderName(String*);
[JScript]
public function get AuthenticationProviderName() : String;
public function set AuthenticationProviderName(String);

Property Value

The name of the cryptographic provider used to generate the digital signature of the message. The default is Microsoft Base Cryptographic Provider, Ver. 1.0.

Exceptions

Exception Type | Condition
InvalidOperationException | The AuthenticationProviderName property could not be set.
ArgumentException | The AuthenticationProviderName was set to a null reference (in Visual Basic Nothing).

Remarks

AuthenticationProviderName provides access to the AuthenticationProviderName property of the Message Queuing application's MSMQMessage object.

The AuthenticationProviderName is typically used when working with foreign queues. The AuthenticationProviderName and AuthenticationProviderType of the cryptographic provider (authentication provider) are required to validate the digital signature of messages sent to a foreign queue or messages passed to Message Queuing from a foreign queue.

When sending messages, always set AuthenticationProviderName and ConnectorType together. The authentication provider name is ignored if the connector type is not also set when the message is sent.

AuthenticationProviderName can't be a null reference (Nothing), but it can be an empty string ("").

Example

See Also

Message Class | Message Members | System.Messaging Namespace | Authenticated | UseAuthentication | ConnectorType | AuthenticationProviderType | Authenticate


Message.AuthenticationProviderType

Gets or sets the type of cryptographic provider used to generate the digital signature of the message.

[Visual Basic]
Overridable Public Property AuthenticationProviderType As _
   CryptoProviderType
[C#]
public CryptoProviderType AuthenticationProviderType {virtual get;
   virtual set;}
[C++]
public: __property virtual CryptoProviderType get_AuthenticationProviderType();
public: __property virtual void set_AuthenticationProviderType(CryptoProviderType);
[JScript]
public function get AuthenticationProviderType() : CryptoProviderType;
public function set AuthenticationProviderType(CryptoProviderType);

Property Value

One of the CryptoProviderType values. The default is RSA_FULL.

Exceptions

Exception Type | Condition
InvalidOperationException | The AuthenticationProviderType property could not be set.

Remarks

AuthenticationProviderType provides access to the AuthenticationProviderType property of the Message Queuing application's MSMQMessage object.

The AuthenticationProviderType is typically used when working with foreign queues. The AuthenticationProviderName and AuthenticationProviderType of the cryptographic provider (authentication provider) are required to validate the digital signature of messages sent to a foreign queue or messages passed to Message Queuing from a foreign queue.

When sending messages, always set AuthenticationProviderType and ConnectorType together. The authentication provider type is ignored if the connector type is not also set when the message is sent.

Example

See Also

Message Class | Message Members | System.Messaging Namespace | Authenticated | UseAuthentication | ConnectorType | AuthenticationProviderName | Authenticate


Message.Body

Gets or sets the serialized contents of the message.

[Visual Basic]
Public Property Body As Object
[C#]
public object Body {get; set;}
[C++]
public: __property Object* get_Body();
public: __property void set_Body(Object*);
[JScript]
public function get Body() : Object;
public function set Body(Object);

Property Value

An object that specifies the message contents to be serialized, including string, date, currency, number, an array of bytes, or any persistent COM object.

Exceptions

Exception Type | Condition
InvalidOperationException | The Formatter has not been specified.

Remarks

Body provides access to the Body property of the Message Queuing application's MSMQMessage object.

Note Each Message Queuing message can have no more than 4 megabytes of data.

The BodyType indicates the type of information that is stored in the message body. Message Queuing uses this information to identify the type of the Body.

If the Formatter has not been set for serializing the Body of the message, it defaults to SoapMessageFormatter when the Body is written.

Example [Visual Basic]

The following example creates an empty message. The example populates the Message with a string Body, and then sends the message to a queue. It assumes there is a queue on the computer "myComputer" with the name "myQueue".

Import the System.Messaging namespace for this example.

[Visual Basic]

Private Sub CreateMessage()
    'Declare a message and message queue
    Dim msg As Message
    Dim mq As MessageQueue

    'Instantiate an empty message object
    msg = New Message

    'Instantiate a new MessageQueue object
    mq = New MessageQueue("myComputer\myQueue")

    'Set message information.
    msg.Body = "New Message Body"
    'Send the message to the queue.
    mq.Send(msg)
End Sub

See Also

Message Class | Message Members | System.Messaging Namespace | Message | BodyStream | BodyType | Formatter | AppSpecific | Extension | UseEncryption | Send | TBD


Message.BodyStream

Gets or sets the information in the body of the message.

[Visual Basic]
Overridable Public Property BodyStream As Stream
[C#]
public Stream BodyStream {virtual get; virtual set;}
[C++]
public: __property virtual Stream* get_BodyStream();
public: __property virtual void set_BodyStream(Stream*);
[JScript]
public function get BodyStream() : Stream;
public function set BodyStream(Stream);

Property Value

Represents the serialized information included in the Body of the message.

Exceptions

Exception Type | Condition
InvalidOperationException | The message queue is filtered not to read the Body property.

Remarks

The body of a message can consist of any type of information, including string, date, currency, number, an array of bytes, or any persistent COM object.

To read or write the message body, use the Body property. The BodyStream represents the body content after it has been serialized using the formatter specified in the Formatter property.

Example [Visual Basic]

The following example peeks the queue "myQueue" on the computer "myComputer". It retrieves the body of the message as a stream and displays it as output.

Import the System.Messaging namespace for this example.

[Visual Basic]

Private Sub PeekMessage()
    'Declare a message and message queue.
    Dim msg As Message
    Dim mq As MessageQueue
    'Set the MessageQueue to the queue above, myQueue.
    mq = New MessageQueue("myComputer\myQueue")
    'Peek the first message in the queue.
    msg = mq.Peek
    'Show the contents of the body.
    Console.WriteLine(msg.BodyStream.ToString)
End Sub

See Also

Message Class | Message Members | System.Messaging Namespace | Message | Body | BodyType | Formatter | AppSpecific | Extension | UseEncryption | Send | TBD


Message.BodyType

Gets or sets the type of data the message body contains.

[Visual Basic]
Overridable Public Property BodyType As Integer
[C#]
public int BodyType {virtual get; virtual set;}
[C++]
public: __property virtual int get_BodyType();
public: __property virtual void set_BodyType(int);
[JScript]
public function get BodyType() : int;
public function set BodyType(int);

Property Value

The true type of the message body, such as string, date, currency, or number.

Exceptions

Exception Type | Condition
InvalidOperationException | The message queue is filtered not to read the Body property.

Remarks

The BodyType indicates the true type of the object that represents the Body of the message. Message Queuing recognizes the Body as an object or as a serialized stream. BodyType indicates the specific type of the message contents. This can include string, date, currency, number, an array of bytes, or any persistent COM object.

See Also

Message Class | Message Members | System.Messaging Namespace | Message | Body | BodyStream | Formatter | Send | TBD


Message.ConnectorType

Is required whenever an application sets a message property that is typically set by MSMQ. It is typically used in the following two cases. Whenever a message is passed by a connector application, the connector type is required so that the sending and receiving applications know how to interpret the security and acknowledgment properties of the messages. When sending application-encrypted messages, this property tells the MSMQ run time to use the symmetric key.

[Visual Basic]
Overridable Public Property ConnectorType As Guid
[C#]
public Guid ConnectorType {virtual get; virtual set;}
[C++]
public: __property virtual Guid get_ConnectorType();
public: __property virtual void set_ConnectorType(Guid);
[JScript]
public function get ConnectorType() : Guid;
public function set ConnectorType(Guid);

Example

See Also

Message Class | Message Members | System.Messaging Namespace


Message.CorrelationId

Gets or sets the message identifier used by acknowledgment and report messages to reference the original message.

[Visual Basic]
Overridable Public Property CorrelationId As String
[C#]
public string CorrelationId {virtual get; virtual set;}
[C++]
public: __property virtual String* get_CorrelationId();
public: __property virtual void set_CorrelationId(String*);
[JScript]
public function get CorrelationId() : String;
public function set CorrelationId(String);

Property Value

The message identifier (Id) of the original message, used when Message Queuing generates an acknowledgment or report message.

Exceptions

Exception Type | Condition
InvalidOperationException | The message queue is filtered to not read the CorrelationId property.
ArgumentException | The CorrelationId is a null reference (in Visual Basic Nothing).

Remarks

CorrelationId provides access to the CorrelationId property of the Message Queuing MSMQMessage object.

CorrelationId provides an application-defined identifier that the receiving application can use to sort messages.

When Message Queuing generates an acknowledgment or report, it uses the CorrelationId property to specify the message identifier of the message that generated the acknowledgment or report. The application can then look at the CorrelationId property to find the message Id of the original message.

When sending response messages to the sending application, CorrelationId can be set to the Id of the message that is in the queue. This provides a mechanism for the sending application to use to match the response message with the original message that triggered the response.

Example

See Also

Message Class | Message Members | System.Messaging Namespace | Id | Acknowledgement | AcknowledgeType | UseJournalQueue | UseTracing | PeekByCorrelationId | ReceiveByCorrelationId


Message.DestinationQueue

Identifies the original destination queue for a message. It is typically used to determine the original destination of a message that is in a journal or dead-letter queue, however it can also be used when sending a response message back to a response queue.

[Visual Basic]
Overridable Public ReadOnly Property DestinationQueue As _
   MessageQueue
[C#]
public MessageQueue DestinationQueue {virtual get;}
[C++]
public: __property virtual MessageQueue* get_DestinationQueue();
[JScript]
public function get DestinationQueue() : MessageQueue;

See Also

Message Class | Message Members | System.Messaging Namespace


Message.DestinationSymmetricKey

Gets or sets the symmetric key used to encrypt messages.

[Visual Basic]
Overridable Public Property DestinationSymmetricKey As Byte ()
[C#]
public byte[] DestinationSymmetricKey {virtual get; virtual set;}
[C++]
public: __property virtual unsigned char* get_DestinationSymmetricKey();
public: __property virtual void set_DestinationSymmetricKey(unsigned char*[]);
[JScript]
public function get DestinationSymmetricKey() : Byte[];
public function set DestinationSymmetricKey(Byte[]);

Property Value

An array of type 8-bit unsigned integer which specifies the destination symmetric key used to encrypt the message. The default is a zero-length array.

Exceptions

Exception Type | Condition
InvalidOperationException | The message queue is filtered not to read the DestinationSymmetricKey property.
ArgumentException | The DestinationSymmetricKey is a null reference (in Visual Basic Nothing).

Remarks

DestinationSymmetricKey provides access to the DestinationSymmetricKey property of the Message Queuing MSMQMessage object.

DestinationSymmetricKey must be set when you send application-encrypted messages, or when you send encrypted messages to a foreign queue. The symmetric key must be encrypted with the public key of the receiving queue manager before you set this property.

When you send application-encrypted messages, the receiving queue manager uses the symmetric key to decrypt the message before it is sent on to its destination queue.

Messages sent to a foreign queues are first received by the appropriate connector application. When the connector application receives the message, it forwards the encrypted message with the attached symmetric key to the receiving application. It is the responsibility of the receiving application to decrypt the symmetric key and the body of the message.

When sending messages, always set DestinationSymmetricKey and ConnectorType together. DestinationSymmetricKey is ignored if ConnectorType is not also set when the message is sent.

DestinationSymmetricKey has a maximum array size of 256.

Example

See Also

Message Class | Message Members | System.Messaging Namespace | ConnectorType | UseEncryption


Message.DigitalSignature

Gets or sets the digital signature used to authenticate the message.

[Visual Basic]
Overridable Public Property DigitalSignature As Byte ()
[C#]
public byte[] DigitalSignature {virtual get; virtual set;}
[C++]
public: __property virtual unsigned char* get_DigitalSignature();
public: __property virtual void set_DigitalSignature(unsigned char*[]);
[JScript]
public function get DigitalSignature() : Byte[];
public function set DigitalSignature(Byte[]);

Property Value

An array of type 8-bit unsigned integer which specifies the Message Queuing 1.0 digital signature used to authenticate the message. The default is a zero-length array.

Exceptions

Exception Type | Condition
InvalidOperationException | The message queue is filtered to not read the DigitalSignature property.
ArgumentException | The DigitalSignature is a null reference (in Visual Basic Nothing).

Remarks

In most cases, the DigitalSignature is generated and set by Message Queuing when the sending application requests authentication. In these cases, only the receiving application will use this property to retrieve the digital signature attached to the message. The DigitalSignature property can only be used when running Message Queuing 2.0. It is used when authenticating messages that were sent by Message Queuing 1.0.

Note If the sending application sent a Message Queuing 2.0 signature, this property will contain a buffer of 4 zeroed bytes.

DigitalSignature has a maximum array size of 256.

Example

See Also

Message Class | Message Members | System.Messaging Namespace | ConnectorType | UseAuthentication


Message.EncryptionAlgorithm

Gets or sets the encryption algorithm used to encrypt the body of a private message.

[Visual Basic]
Overridable Public Property EncryptionAlgorithm As _
   EncryptionAlgorithm
[C#]
public EncryptionAlgorithm EncryptionAlgorithm {virtual get;
   virtual set;}
[C++]
public: __property virtual EncryptionAlgorithm get_EncryptionAlgorithm();
public: __property virtual void set_EncryptionAlgorithm(EncryptionAlgorithm);
[JScript]
public function get EncryptionAlgorithm() : EncryptionAlgorithm;
public function set EncryptionAlgorithm(EncryptionAlgorithm);

Property Value

One of the EncryptionAlgorithm values used to encrypt the message body of a private message. The default is RC2.

Remarks

EncryptionAlgorithm provides access to the EncryptAlgorithm property of the Message Queuing application's MSMQMessage object.

Example

See Also

Message Class | Message Members | System.Messaging Namespace


Message.Extension

Gets or sets additional information associated with the message.

[Visual Basic]
Overridable Public Property Extension As Byte ()
[C#]
public byte[] Extension {virtual get; virtual set;}
[C++]
public: __property virtual unsigned char* get_Extension();
public: __property virtual void set_Extension(unsigned char*[]);
[JScript]
public function get Extension() : Byte[];
public function set Extension(Byte[]);

Property Value

An array of 8-bit unsigned integers that provides additional, application-defined information associated with the message. The default is a zero-length array of 8-bit unsigned integers.

Exceptions

Exception Type | Condition
InvalidOperationException | The message queue is not filtered to read the Extension property.
ArgumentException | The Extension is a null reference (in Visual Basic Nothing).

Remarks

Extension provides access to the Extension property of the Message Queuing MSMQMessage object.

Where possible, message data should be included in the body of the message rather than in the extension. Use Extension rather than AppSpecific when you must attach a random binary large object. You must code the application to interpret the content of this array.

Example

See Also

Message Class | Message Members | System.Messaging Namespace | Body | AppSpecific


Message.Formatter

Gets or sets the formatter used to read or write an object into the message body.

[Visual Basic]
Public Property Formatter As IMessageFormatter
[C#]
public IMessageFormatter Formatter {get; set;}
[C++]
public: __property IMessageFormatter* get_Formatter();
public: __property void set_Formatter(IMessageFormatter*);
[JScript]
public function get Formatter() : IMessageFormatter;
public function set Formatter(IMessageFormatter);

Property Value

The IMessageFormatter that produces a stream to be written to the message body. The default is SoapMessageFormatter.

Exceptions

Exception Type | Condition
ArgumentException | The Formatter is a null reference (in Visual Basic Nothing).

Remarks

When the Formatter property is initially a null reference (Nothing), the Message attempts to read the body of the message in order to identify a compatible formatter. The formatter classes are used in the order indicated below. Each formatter attempts to determine if the contents of the message are can be read by that formatter.

  1. SoapMessageFormatter
  2. ActiveXMessageFormatter
  3. DataSetMessageFormatter

Use the Formatter both when reading and when writing the message in order to translate the message Body to a stream that can be sent to the message queue. If you use SoapMessageFormatter, the body can be read while it is in the stream state, and a separate XML-compatible formatter can be used to read the message. Any other formatter requires the same formatter to be used both for reading and writing. Binary formatters provide faster data transfer but do not allow a corrupted message to be repaired in the stream state.

See Also

Message Class | Message Members | System.Messaging Namespace | CanRead | SoapMessageFormatter | ActiveXMessageFormatter | BinaryMessageFormatter | DataSetMessageFormatter | TBD


Message.HashAlgorithm

Gets or sets the hashing algorithm used when authenticating messages.

[Visual Basic]
Overridable Public Property HashAlgorithm As HashAlgorithm
[C#]
public HashAlgorithm HashAlgorithm {virtual get; virtual set;}
[C++]
public: __property virtual HashAlgorithm get_HashAlgorithm();
public: __property virtual void set_HashAlgorithm(HashAlgorithm);
[JScript]
public function get HashAlgorithm() : HashAlgorithm;
public function set HashAlgorithm(HashAlgorithm);

Property Value

One of the HashAlgorithm values that identifies the hashing algorithm Message Queuing uses when authenticating messages. The default is MD5.

Exceptions

Exception Type | Condition
InvalidOperationException | The message queue is filtered not to read the HashAlgorithm property.

Remarks

HashAlgorithm provides access to the HashAlgorithm property of the Message Queuing MSMQMessage object. The Message Queuing run-time .dll on the source computer uses the hashing algorithm when it creates a digital signature for a message and when authenticating the message.

Example

See Also

Message Class | Message Members | System.Messaging Namespace | UseAuthentication


Message.Id

Gets the Message Queuing-generated identifier of the message.

[Visual Basic]
Overridable Public ReadOnly Property Id As String
[C#]
public string Id {virtual get;}
[C++]
public: __property virtual String* get_Id();
[JScript]
public function get Id() : String;

Property Value

The Message Queuing-generated unique identifier of the message.

Exceptions

Exception Type | Condition
InvalidOperationException | The Id is undefined. -or- The message queue is filtered not to read the Id property.

Remarks

Id provides access to the Id property of the Message Queuing MSMQMessage object.

Message Queuing generates a message identifier when the message is sent. This identifier is made of 20 8-bit unsigned integers. It is composed of the machine System.GUID of the computer that sends the message and an identifier that uniquely identifies the message on the computer. By combining these two items, the message identifier is unique on the network.

Message Queuing generates message identifiers for all messages, including acknowledgment and report messages. The identifier of the original message can be found in the CorrelationId property of an acknowledgment message.

You can also use the Id when sending a response to a response queue. To provide the identifier of the original message in a response message, set the CorrelationId of the response message to the Id of the original message. The application reading the response message can then use the correlation identifier of the response message to identify the original message.

Example

See Also

Message Class | Message Members | System.Messaging Namespace | CorrelationId | TBD


Message.IsFirstInTransaction

Gets a value indicating whether the message was the first message sent in the transaction.

[Visual Basic]
Overridable Public ReadOnly Property IsFirstInTransaction As _
   Boolean
[C#]
public bool IsFirstInTransaction {virtual get;}
[C++]
public: __property virtual bool get_IsFirstInTransaction();
[JScript]
public function get IsFirstInTransaction() : Boolean;

Property Value

true if the message was the first message sent in the transaction; otherwise, false.

Exceptions

Exception Type | Condition
InvalidOperationException | The message queue is filtered not to read the IsFirstInTransaction property.

Remarks

IsFirstInTransaction provides access to the IsFirstInTransaction property of the Message Queuing MSMQMessage object.

IsFirstInTransaction is used by receiving applications to verify that a message was the first message sent in a single transaction to a single queue.

Note This property is available only with Message Queuing 2.0 and later.

You can use IsFirstInTransaction along with two other properties to verify transaction boundaries: IsLastInTransaction to check whether a message was the last message sent in the transaction, and TransactionId to retrieve the ID of the transaction.

If only one message is sent in a transaction, both IsFirstInTransaction and IsLastInTransaction are set to true.

Example

See Also

Message Class | Message Members | System.Messaging Namespace | IsLastInTransaction | TransactionId | Transactional


Message.IsLastInTransaction

Gets a value indicating whether the message was the last message sent in the transaction.

[Visual Basic]
Overridable Public ReadOnly Property IsLastInTransaction As Boolean
[C#]
public bool IsLastInTransaction {virtual get;}
[C++]
public: __property virtual bool get_IsLastInTransaction();
[JScript]
public function get IsLastInTransaction() : Boolean;

Property Value

true if the message was the last message sent in a single transaction; otherwise, false.

Exceptions

Exception Type | Condition
InvalidOperationException | The message queue is filtered not to read the IsLastInTransaction property.

Remarks

IsLastInTransaction provides access to the IsLastInTransaction property of the Message Queuing MSMQMessage object.

IsLastInTransaction is used by receiving applications to verify that a message was the last message sent in a single transaction to a single queue.

Note This property is available only with Message Queuing 2.0 and later.

You can use IsLastInTransaction along with two other properties to verify transaction boundaries: IsFirstInTransaction to check whether a message was the first message sent in the transaction, and TransactionId to retrieve the ID of the transaction.

If only one message is sent in a transaction, both IsFirstInTransaction and IsLastInTransaction are set to true.

Example

See Also

Message Class | Message Members | System.Messaging Namespace | IsFirstInTransaction | TransactionId | Transactional


Message.Label

Gets or sets the message label.

[Visual Basic]
Overridable Public Property Label As String
[C#]
public string Label {virtual get; virtual set;}
[C++]
public: __property virtual String* get_Label();
public: __property virtual void set_Label(String*);
[JScript]
public function get Label() : String;
public function set Label(String);

Property Value

The label of the message. The default is an empty string ("").

Remarks

Label provides access to the Label property of the Message Queuing MSMQMessage object.

Example [Visual Basic]

The following example creates an empty message. The example populates the Message with a string Body, sets the Label property, and then sends the message to a queue. It assumes there is a queue on the computer "myComputer" with the name "myQueue".

Import the System.Messaging namespace for this example.

[Visual Basic]

Private Sub CreateMessage()
    'Declare a message and message queue
    Dim msg As Message
    Dim mq As MessageQueue

    'Instantiate an empty message object
    msg = New Message

    'Instantiate a new MessageQueue object
    mq = New MessageQueue("myComputer\myQueue")

    'Set selected message properties.
    msg.Label = "My Message"
    msg.Body = "New Message Body"
    'Send the message to the queue.
    mq.Send(msg)
End Sub

See Also

Message Class | Message Members | System.Messaging Namespace


Message.MessageType

Gets the type of the message (normal, acknowledgment, or report).

[Visual Basic]
Overridable Public ReadOnly Property MessageType As MessageType
[C#]
public MessageType MessageType {virtual get;}
[C++]
public: __property virtual MessageType get_MessageType();
[JScript]
public function get MessageType() : MessageType;

Property Value

One of the MessageType values.

Exceptions

Exception Type | Condition
InvalidOperationException | The MessageType could not be retrieved. -or- The message queue is filtered not to read the MessageType property.

Remarks

Typically this property is set by Message Queuing when it sends the message. Messages can be of the following types:

  • A normal Message Queuing message is a typical message sent from an application to a queue.
  • Acknowledgement messages, positive or negative (arrival and read) messages, are generated by Message Queuing whenever the sending application requests them. Message Queuing returns the appropriate acknowledgment message to the administration queue specified by the sending application.
  • Report messages are generated by Message Queuing whenever a report queue is defined at the source Queue Manager.

Example

See Also

Message Class | Message Members | System.Messaging Namespace | MessageType | Acknowledgement | AcknowledgeType


Message.Priority

Gets or sets the message priority, used to determine where the message is placed in the queue.

[Visual Basic]
Overridable Public Property Priority As MessagePriority
[C#]
public MessagePriority Priority {virtual get; virtual set;}
[C++]
public: __property virtual MessagePriority get_Priority();
public: __property virtual void set_Priority(MessagePriority);
[JScript]
public function get Priority() : MessagePriority;
public function set Priority(MessagePriority);

Property Value

One of the MessagePriority values that represents the priority level of a non-transactional message. The default is Normal.

Exceptions

Exception Type | Condition
InvalidOperationException | The message queue is filtered not to read the Priority property.

Remarks

Priority affects how Message Queuing handles the message while it is in route, as well as its place in the queue. High priority messages are given preference during routing, and inserted toward the front of the queue. Messages of equal priority are placed in the queue according to their arrival time.

Priority provides access to the Priority property of the Message Queuing MSMQMessage object.

Priority can only be set for non-transactional messages, because Priority for transactional message is automatically set to 0.

Example [Visual Basic]

The following example creates an empty message. The example populates the Message with a string Body, sets the Priority property, and then sends the message to a queue. It assumes there is a queue on the computer "myComputer" with the name "myQueue".

Import the System.Messaging namespace for this example.

[Visual Basic]

Private Sub CreateMessage()
    'Declare a message and message queue
    Dim msg As Message
    Dim mq As MessageQueue

    'Instantiate an empty message object
    msg = New Message

    'Instantiate a new MessageQueue object
    mq = New MessageQueue("myComputer\myQueue")

    'Set selected message properties.
    msg.Priority = MessagePriority.Highest
    msg.Body = "New Message Body"
    'Send the message to the queue.
    mq.Send(msg)
End Sub

See Also

Message Class | Message Members | System.Messaging Namespace | MessagePriority | MessageType | BasePriority


Message.Recoverable

Gets or sets a value indicating whether the message is guaranteed to be delivered in the event of a computer failure or network problem.

[Visual Basic]
Overridable Public Property Recoverable As Boolean
[C#]
public bool Recoverable {virtual get; virtual set;}
[C++]
public: __property virtual bool get_Recoverable();
public: __property virtual void set_Recoverable(bool);
[JScript]
public function get Recoverable() : Boolean;
public function set Recoverable(Boolean);

Property Value

true if the message is guaranteed delivery even if a computer fails while the message is en-route to the queue; false if delivery is not assured in the event of computer failure. The default is false.

Exceptions

Exception Type | Condition
InvalidOperationException | The message queue is filtered not to read the Recoverable property.

Remarks

Recoverable provides access to the Delivery property of the Message Queuing MSMQMessage object.

When Recoverable is true, delivery of a message is assured by storing the message locally until a successful forward has been achieved. In every hop along its route, the message is forwarded to the next hop or stored locally in a backup file until delivered. Because of this, throughput may be slower for a message for which Recoverable is true.

Recoverable should be set to true if your message is transactional.

See Also

Message Class | Message Members | System.Messaging Namespace | UseTracing


Message.ResponseQueue

Gets or sets the queue which receives application-generated response messages.

[Visual Basic]
Overridable Public Property ResponseQueue As MessageQueue
[C#]
public MessageQueue ResponseQueue {virtual get; virtual set;}
[C++]
public: __property virtual MessageQueue* get_ResponseQueue();
public: __property virtual void set_ResponseQueue(MessageQueue*);
[JScript]
public function get ResponseQueue() : MessageQueue;
public function set ResponseQueue(MessageQueue);

Property Value

The MessageQueue to which application-generated response messages are returned. The default is a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
InvalidOperationException | The message queue is filtered not to read the ResponseQueue property.

Remarks

ResponseQueue provides access to the ResponseQueueInfo property of the Message Queuing MSMQMessage object.

Messages returned to the response queue are application-defined. That is, the application defines the content of the messages and action to take upon reception.

See Also

Message Class | Message Members | System.Messaging Namespace | AdministrationQueue | DestinationQueue | TransactionStatusQueue


Message.SenderCertificate

Specifies the security certificate used to authenticate messages.

[Visual Basic]
Overridable Public Property SenderCertificate As Byte ()
[C#]
public byte[] SenderCertificate {virtual get; virtual set;}
[C++]
public: __property virtual unsigned char* get_SenderCertificate();
public: __property virtual void set_SenderCertificate(unsigned char*[]);
[JScript]
public function get SenderCertificate() : Byte[];
public function set SenderCertificate(Byte[]);

See Also

Message Class | Message Members | System.Messaging Namespace | UseAuthentication | Authenticated


Message.SenderId

This property is set by MSMQ, and is used primarily by the receiving Queue Manager when authenticating a message. The receiving Queue Manager uses the sender identifier in this property to verify where the message originated and to verify the sender has access rights to a queue.

[Visual Basic]
Overridable Public ReadOnly Property SenderId As Byte ()
[C#]
public byte[] SenderId {virtual get;}
[C++]
public: __property virtual unsigned char* get_SenderId();
[JScript]
public function get SenderId() : Byte[];

Example

See Also

Message Class | Message Members | System.Messaging Namespace


Message.SenderVersion

Gets the version of Message Queuing used to send the message.

[Visual Basic]
Overridable Public ReadOnly Property SenderVersion As Long
[C#]
public long SenderVersion {virtual get;}
[C++]
public: __property virtual __int64 get_SenderVersion();
[JScript]
public function get SenderVersion() : long;

Property Value

The version of Message Queuing used to send the message.

Exceptions

Exception Type | Condition
InvalidOperationException | The SenderVersion could not be retrieved. -or- The message queue is filtered to not read the SenderVersion property.

Remarks

SenderVersion provides access to the SenderVersion property of the Message Queuing MSMQMessage object.

SenderVersion is important for features such as transaction processing, which is only supported by Message Queuing 2.0 and later; or digital signatures, which are used to authenticate messages sent by MSMQ 1.0.

The sending Queue Manager sets SenderVersion when the message is sent.

The following table shows possible values for the sender version.

Value | Message Queuing Version
0x0010 | Message Queuing 1.0
0x0020 | Message Queuing 2.0

Example

See Also

Message Class | Message Members | System.Messaging Namespace | TransactionId | IsFirstInTransaction | IsLastInTransaction | TransactionStatusQueue | DigitalSignature


Message.SentTime

Indicates the date and time that the message was sent by the source Queue Manager.

[Visual Basic]
Overridable Public ReadOnly Property SentTime As DateTime
[C#]
public DateTime SentTime {virtual get;}
[C++]
public: __property virtual DateTime get_SentTime();
[JScript]
public function get SentTime() : DateTime;

See Also

Message Class | Message Members | System.Messaging Namespace


Message.SourceMachine

Specifies the computer where the message originated.

[Visual Basic]
Overridable Public ReadOnly Property SourceMachine As String
[C#]
public string SourceMachine {virtual get;}
[C++]
public: __property virtual String* get_SourceMachine();
[JScript]
public function get SourceMachine() : String;

See Also

Message Class | Message Members | System.Messaging Namespace


Message.TimeToBeReceived

Gets or sets the time limit for the message to be retrieved from the target queue.

[Visual Basic]
Overridable Public Property TimeToBeReceived As TimeSpan
[C#]
public TimeSpan TimeToBeReceived {virtual get; virtual set;}
[C++]
public: __property virtual TimeSpan get_TimeToBeReceived();
public: __property virtual void set_TimeToBeReceived(TimeSpan);
[JScript]
public function get TimeToBeReceived() : TimeSpan;
public function set TimeToBeReceived(TimeSpan);

Property Value

The time limit, in seconds, for the message to be retrieved from the target queue. The default is InfiniteTimeout.

Exceptions

Exception Type | Condition
InvalidOperationException | The message queue is filtered not to read the TimeToBeReceived property.
ArgumentException | The value specified for TimeToBeReceived is invalid. It may represent a negative number.

Remarks

TimeToBeReceived provides access to the MaxTimeToReceive property of the Message Queuing MSMQMessage object.

The time limit for the message to be retrieved from the target queue includes the time spent getting to the queue, and the time spent waiting in the queue before the message is retrieved by an application.

If the TimeToBeReceived interval expires before the message is removed from the queue, Message Queuing discards the message and sends it to the dead-letter queue if the message's UseDeadLetterQueue property is set to true.

Message Queuing can also send a negative acknowledgment message to the sending application if the message's AcknowledgeType property is set accordingly and the message is not retrieved before the timeout expires.

InfiniteTimeout is the only negative integer value that can be used for a timeout. If you attempt to specify any other negative value for TimeToBeReceived or TimeToReachQueue, an ArgumentException exception will be thrown. You should catch this exception in your code when setting the TimeToBeReceived.

Example [Visual Basic]

The following example creates an empty message. The example populates the Message with a string Body, sets the TimeToBeReceived and TimeToReachQueue properties, and then sends the message to a queue. It assumes there is a queue on the computer "myComputer" with the name "myQueue".

Import the System.Messaging namespace for this example.

[Visual Basic]

Private Sub CreateMessage()
    'Declare a message and message queue
    Dim msg As Message
    Dim mq As MessageQueue

    'Instantiate an empty message object
    msg = New Message

    'Instantiate a new MessageQueue object
    mq = New MessageQueue("myComputer\myQueue")

    'Set selected message properties.
    msg.TimeToBeReceived = New TimeSpan(1000)
    msg.TimeToReachQueue = New TimeSpan(1000)
    msg.Body = "New Message Body"
    'Send the message to the queue.
    mq.Send(msg)
End Sub

See Also

Message Class | Message Members | System.Messaging Namespace | TimeToReachQueue | InfiniteTimeout | UseTracing | Recoverable


Message.TimeToReachQueue

Gets or sets the time limit for the message to reach the queue.

[Visual Basic]
Overridable Public Property TimeToReachQueue As TimeSpan
[C#]
public TimeSpan TimeToReachQueue {virtual get; virtual set;}
[C++]
public: __property virtual TimeSpan get_TimeToReachQueue();
public: __property virtual void set_TimeToReachQueue(TimeSpan);
[JScript]
public function get TimeToReachQueue() : TimeSpan;
public function set TimeToReachQueue(TimeSpan);

Property Value

The time limit, in seconds, for the message to reach the queue. The default is InfiniteTimeout.

Exceptions

Exception Type | Condition
InvalidOperationException | The message queue is filtered not to read the TimeToReachQueue property.
ArgumentException | The value specified for TimeToReachQueue is invalid. It may represent a negative number.

Remarks

TimeToReachQueue provides to the MaxTimeToReachQueue property of the Message Queuing MSMQMessage object.

If the TimeToReachQueue interval expires before the message reaches its destination, Message Queuing discards the message and sends it to the dead-letter queue if the message's UseDeadLetterQueue property is set to true.

Message Queuing can also send a negative acknowledgment message back to the sending application if the message's AcknowledgeType property is set accordingly and the message does not arrive before the timeout expires

InfiniteTimeout is the only negative integer value that can be used for a timeout. If you attempt to specify any other negative value for TimeToBeReceived or TimeToReachQueue, an ArgumentException exception will be thrown. You should catch this exception in your code when setting the TimeToReachQueue.

Example [Visual Basic]

The following example creates an empty message. The example populates the Message with a string Body, sets the TimeToBeReceived and TimeToReachQueue properties, and then sends the message to a queue. It assumes there is a queue on the computer "myComputer" with the name "myQueue".

Import the System.Messaging namespace for this example.

[Visual Basic]

Private Sub CreateMessage()
    'Declare a message and message queue
    Dim msg As Message
    Dim mq As MessageQueue

    'Instantiate an empty message object
    msg = New Message

    'Instantiate a new MessageQueue object
    mq = New MessageQueue("myComputer\myQueue")

    'Set selected message properties.
    msg.TimeToBeReceived = New TimeSpan(1000)
    msg.TimeToReachQueue = New TimeSpan(1000)
    msg.Body = "New Message Body"
    'Send the message to the queue.
    mq.Send(msg)
End Sub

See Also

Message Class | Message Members | System.Messaging Namespace | TimeToBeReceived | InfiniteTimeout | UseTracing | Recoverable


Message.TransactionId

Gets the identifier for the transaction of which the message was a part.

[Visual Basic]
Overridable Public ReadOnly Property TransactionId As String
[C#]
public string TransactionId {virtual get;}
[C++]
public: __property virtual String* get_TransactionId();
[JScript]
public function get TransactionId() : String;

Property Value

The identifier for the transaction associated with the message. The default is an empty string ("").

Exceptions

Exception Type | Condition
InvalidOperationException | The message queue is filtered not to read the TransactionId property.

Remarks

TransactionId provides access to the TransactionId property of the Message Queuing MSMQMessage object.

TransactionId is used by receiving applications to verify that a message was sent as part of a specific transaction. The transaction identifier is a 20-byte identifier that includes the identifier of the sending computer (first 16 bits) followed by a 4-byte transaction sequence number.

Note This property is available only for Message Queuing 2.0 and later.

Transaction identifiers are not guaranteed to be unique because transaction sequence numbers are not persistent, and they start over again at 2^20. Message Queuing guarantees only that subsequent transactions will have different transaction sequence numbers.

You can use TransactionId along with IsFirstInTransaction and IsLastInTransaction to verify transaction boundaries.

Example

See Also

Message Class | Message Members | System.Messaging Namespace | IsFirstInTransaction | IsLastInTransaction | Transactional


Message.TransactionStatusQueue

Gets the transaction status queue on the source computer.

[Visual Basic]
Overridable Public Property TransactionStatusQueue As MessageQueue
[C#]
public MessageQueue TransactionStatusQueue {virtual get; virtual
   set;}
[C++]
public: __property virtual MessageQueue* get_TransactionStatusQueue();
public: __property virtual void set_TransactionStatusQueue(MessageQueue*);
[JScript]
public function get TransactionStatusQueue() : MessageQueue;
public function set TransactionStatusQueue(MessageQueue);

Property Value

The transaction status queue on the source computer, used for sending acknowledgment messages back to the sending application. The default is a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
InvalidOperationException | The message queue is filtered not to read the TransactionStatusQueue property.

Remarks

TransactionStatusQueue provides access to the TransactionStatusQueueInfo property of the Message Queuing MSMQMessage object.

The transaction status queue is located on the source computer. It is only used by connector applications when they receive transactional messages sent to a foreign queue.

Connector applications use the transaction status queue to send positive (read receipt) or negative acknowledgment messages back to the sending application. The transaction status queue should receive these acknowledgments even if the sending application does not request other acknowledgments.

Example

See Also

Message Class | Message Members | System.Messaging Namespace | TransactionId | AdministrationQueue | DestinationQueue | ResponseQueue | Transactional


Message.UseAuthentication

Gets or sets a value indicating whether a message must be authenticated.

[Visual Basic]
Overridable Public Property UseAuthentication As Boolean
[C#]
public bool UseAuthentication {virtual get; virtual set;}
[C++]
public: __property virtual bool get_UseAuthentication();
public: __property virtual void set_UseAuthentication(bool);
[JScript]
public function get UseAuthentication() : Boolean;
public function set UseAuthentication(Boolean);

Property Value

true if the sending application requested authentication for the message; otherwise, false. The default is false.

Exceptions

Exception Type | Condition
InvalidOperationException | The message queue is filtered not to read the UseAuthentication property.

Remarks

UseAuthentication provides access to the IsAuthenticated property of the Message Queuing MSMQMessage object.

Note It is not possible to look at the properties of a message and determine whether a message failed authentication. Messages that fail authentication are discarded and are not delivered to the queue.

Example

See Also

Message Class | Message Members | System.Messaging Namespace | Authenticated | ConnectorType | AuthenticationProviderName | AuthenticationProviderType | DigitalSignature | Authenticate


Message.UseDeadLetterQueue

Gets or sets a value indicating whether a copy of an undeliverable message should be sent to a dead-letter queue.

[Visual Basic]
Overridable Public Property UseDeadLetterQueue As Boolean
[C#]
public bool UseDeadLetterQueue {virtual get; virtual set;}
[C++]
public: __property virtual bool get_UseDeadLetterQueue();
public: __property virtual void set_UseDeadLetterQueue(bool);
[JScript]
public function get UseDeadLetterQueue() : Boolean;
public function set UseDeadLetterQueue(Boolean);

Property Value

true if message delivery failure results in a copy of the message being sent to a dead-letter queue; otherwise, false. The default is false.

Exceptions

Exception Type | Condition
InvalidOperationException | The message queue is filtered not to read the UseDeadLetterQueue property.

Remarks

UseDeadLetterQueue provides access to a part of the functionality of the Journal property of the Message Queuing MSMQMessage object. The Journal property is accessed by both UseDeadLetterQueue and UseJournalQueue in the Message object.

In case of delivery failure for non-transactional messages, the message is sent to the non-transactional dead-letter queue on the computer that could not deliver the message (for example, if a message timeout expires.)

In the case of delivery failure for transactional messages, the message is sent to the transactional dead-letter queue on the source computer in all negative and in-doubt cases.

When you store messages in a dead-letter queue, clear the queue periodically to remove messages that are no longer needed. Messages stored in dead-letter queues count against the quota for the computer where the queue resides.

Note The computer quota is set by the administrator.

Example [Visual Basic]

The following example creates an empty message. The example populates the Message with a string Body, sets the UseDeadLetterQueue property according to the priority, and then sends the message to a queue. It assumes there is a queue on the computer "myComputer" with the name "myQueue".

Note Choosing to set the System.Messaging.Message.UserDeadLetterQueue property according to the priority is arbitrary and used only for illustrative purposes. A relation between the two is not necessary.

Import the System.Messaging namespace for this example.

[Visual Basic]

Private Sub CreateMessage(ByVal priority As MessagePriority)
    'Declare a message and message queue
    Dim msg As Message
    Dim mq As MessageQueue

    'Instantiate an empty message object
    msg = New Message

    'Instantiate a new MessageQueue object
    mq = New MessageQueue("myComputer\myQueue")

    If priority = MessagePriority.Highest Then
        'Use the deadletter queue for the message
        msg.UseDeadLetterQueue = True
    Else
        'Don't use the deadletter queue for the message.
        msg.UseDeadLetterQueue = False
    End If

    msg.Body = "New Message Body"
    'Send the message to the queue.
    mq.Send(msg)
End Sub

See Also

Message Class | Message Members | System.Messaging Namespace


Message.UseEncryption

Gets or sets a value indicating whether to encrypt private messages.

[Visual Basic]
Overridable Public Property UseEncryption As Boolean
[C#]
public bool UseEncryption {virtual get; virtual set;}
[C++]
public: __property virtual bool get_UseEncryption();
public: __property virtual void set_UseEncryption(bool);
[JScript]
public function get UseEncryption() : Boolean;
public function set UseEncryption(Boolean);

Property Value

true to require Message Queuing to encrypt a private message; otherwise, false. The default is false.

Exceptions

Exception Type | Condition
InvalidOperationException | The message queue is filtered not to read the UseEncryption property.

Remarks

UseEncryption provides access to the PrivLevel property of the Message Queuing MSMQMessage object.

Example

See Also

Message Class | Message Members | System.Messaging Namespace


Message.UseJournalQueue

Gets or sets a value indicating whether a copy of the message should be kept in a machine journal on the originating computer.

[Visual Basic]
Overridable Public Property UseJournalQueue As Boolean
[C#]
public bool UseJournalQueue {virtual get; virtual set;}
[C++]
public: __property virtual bool get_UseJournalQueue();
public: __property virtual void set_UseJournalQueue(bool);
[JScript]
public function get UseJournalQueue() : Boolean;
public function set UseJournalQueue(Boolean);

Property Value

true to require that a copy of a message be kept after transmission from the originating computer to the next hop; otherwise, false. The default is false.

Exceptions

Exception Type | Condition
InvalidOperationException | The message queue is filtered not to read the UseJournalQueue property.

Remarks

UseJournalQueue provides access to part of the functionality of the Journal property of the Message Queuing MSMQMessage object. The Journal property is accessed by both UseDeadLetterQueue and UseJournalQueue in the Message object.

When you store messages in a journal queue, clear the queue periodically to remove messages that are no longer needed. Messages stored in journal queues count against the quota for the computer where the queue resides.

Note The computer quota is set by the administrator.

Example [Visual Basic]

The following example creates an empty message. The example populates the Message with a string Body, sets the UseJournalQueue property according to the priority, and then sends the message to a queue. It assumes there is a queue on the computer "myComputer" with the name "myQueue".

Note Choosing to set the System.Messaging.Message.UserJournalQueue property according to the priority is arbitrary and used only for illustrative purposes. A relation between the two is not necessary.

Import the System.Messaging namespace for this example.

[Visual Basic]

Private Sub CreateMessage(ByVal priority As MessagePriority)
    'Declare a message and message queue
    Dim msg As Message
    Dim mq As MessageQueue

    'Instantiate an empty message object
    msg = New Message

    'Instantiate a new MessageQueue object
    mq = New MessageQueue("myComputer\myQueue")

    If priority = MessagePriority.Highest Then
        'Use the journal queue for the message
        msg.UseJournalQueue = True
    Else
        'Don't use the journal queue for the message.
        msg.UseJournalQueue = False
    End If

    msg.Body = "New Message Body"
    'Send the message to the queue.
    mq.Send(msg)
End Sub

See Also

Message Class | Message Members | System.Messaging Namespace


Message.UseTracing

Gets or sets a value indicating whether to trace a message as it moves toward its destination queue.

[Visual Basic]
Overridable Public Property UseTracing As Boolean
[C#]
public bool UseTracing {virtual get; virtual set;}
[C++]
public: __property virtual bool get_UseTracing();
public: __property virtual void set_UseTracing(bool);
[JScript]
public function get UseTracing() : Boolean;
public function set UseTracing(Boolean);

Property Value

true if each hop made by the original message generates a report to be sent to the system's report queue; otherwise, false. The default is false.

Exceptions

Exception Type | Condition
InvalidOperationException | The message queue is filtered not to read the UseTracing property.

Remarks

UseTracing provides access to the Trace property of the Message Queuing MSMQMessage object.

When a message is sent with tracing enabled, a report message is generated and sent to the system report queue each time the message passes through a Message Queuing routing server. Report queues are not limited to Message Queuing-generated report messages. Application-generated messages can be sent to report queues as well.

If UseTracing is true but the report queue is not defined by the Message Queuing application administrator for Queue Manager associated with the source of the message, this property is ignored.

See Also

Message Class | Message Members | System.Messaging Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Message Fields

The fields of the Message class are listed below. For a complete list of Message class members, see the Message Members topic.

Public:

InfiniteTimeout Specifies that there is no timeout.

See Also

Message Class | System.Messaging Namespace


Message.InfiniteTimeout

Specifies that there is no timeout.

[Visual Basic]
Public Shared InfiniteTimeout As TimeSpan
[C#]
public static TimeSpan InfiniteTimeout;
[C++]
public: static TimeSpan InfiniteTimeout;
[JScript]
public static var InfiniteTimeout : TimeSpan;

Remarks

InfiniteTimeout is used to allow the allocation of a message's existence (TimeToBeReceived) or the time it is allowed to take to reach a queue (TimeToReachQueue). You can specify a given number of seconds, or use InfiniteTimeout to indicate that there is no timeout.

If you specify any negative value besides InfiniteTimeout for TimeToBeReceived or TimeToReachQueue, an ArgumentException exception will be thrown. Catch this exception in your code when you set either property.

See Also

Message Class | Message Members | System.Messaging Namespace | TimeToBeReceived | TimeToReachQueue


MessagePriority Enumeration

Message priority effects how MSMQ handles the message while it is in route, as well as where the message is placed in the queue. Higher priority messages are given preference during routing, and inserted toward the front of the queue. Messages with the same priority are placed in the queue according to their arrival time.

[Visual Basic]
Public Enum MessagePriority
[C#]
public enum MessagePriority
[C++]
public enum MessagePriority

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
AboveNormal | [To be supplied.]
High | [To be supplied.]
Highest | [To be supplied.]
Low | [To be supplied.]
Lowest | [To be supplied.]
Normal | [To be supplied.]
VeryHigh | [To be supplied.]
VeryLow | [To be supplied.]

Requirements

Namespace: System.Messaging

Assembly: system.messaging.dll

See Also

System.Messaging Namespace


MessagePropertyFilter Class

The property filter class is used to limit the properties retrieved when receiving messages from a queue. Getting a limitied set of properties helps improving performance.

Object
MessagePropertyFilter

[Visual Basic]
Public Class MessagePropertyFilter
[C#]
public class MessagePropertyFilter
[C++]
public __gc class MessagePropertyFilter
[JScript]
public class MessagePropertyFilter

Remarks

[To be supplied.]

Requirements

Namespace: System.Messaging

Assembly: system.messaging.dll

See Also

MessagePropertyFilter Members | System.Messaging Namespace


MessagePropertyFilter Members

Public:

Constructor

MessagePropertyFilter Constructor Creates a new MessagePropertyFilter object with the most common properties set. ArrivedTime AdministrationQueue Body CorrelationId Id Label Priority ResponseQueue SentTime

Properties

Acknowledgement | [To be supplied.]
AcknowledgeType | [To be supplied.]
AdministrationQueue | [To be supplied.]
AppSpecific | [To be supplied.]
ArrivedTime | [To be supplied.]
AttachSenderId | [To be supplied.]
Authenticated | [To be supplied.]
AuthenticationProviderName | [To be supplied.]
AuthenticationProviderType | [To be supplied.]
Body | [To be supplied.]
ConnectorType | [To be supplied.]
CorrelationId | [To be supplied.]
DefaultBodySize | The default body buffer size to create, when the message is received.
DefaultExtensionSize | The default extension buffer size to create, when the message is received.
DefaultLabelSize | The default label buffer size to create, when the message is received.
DestinationQueue | [To be supplied.]
DestinationSymmetricKey | [To be supplied.]
DigitalSignature | [To be supplied.]
EncryptionAlgorithm | [To be supplied.]
Extension | [To be supplied.]
HashAlgorithm | [To be supplied.]
Id | [To be supplied.]
IsFirstInTransaction | [To be supplied.]
IsLastInTransaction | [To be supplied.]
Label | [To be supplied.]
MessageType | [To be supplied.]
Priority | [To be supplied.]
Recoverable | [To be supplied.]
ResponseQueue | [To be supplied.]
SenderCertificate | [To be supplied.]
SenderId | [To be supplied.]
SenderVersion | [To be supplied.]
SentTime | [To be supplied.]
SourceMachine | [To be supplied.]
TimeToBeReceived | [To be supplied.]
TimeToReachQueue | [To be supplied.]
TransactionId | [To be supplied.]
TransactionStatusQueue | [To be supplied.]
UseAuthentication | [To be supplied.]
UseDeadLetterQueue | [To be supplied.]
UseEncryption | [To be supplied.]
UseJournalQueue | [To be supplied.]
UseTracing | [To be supplied.]

Methods

ClearAll | Sets all the properties to false. No message properties will be retrieved when receiving messages.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SetAll | Sets all the properties to true. All the message properties will be retrieved when receiving messages.
SetDefaults | Sets the most common properties: ArrivedTime AdministrationQueue Body CorrelationId Id Label Priority ResponseQueue SentTime
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MessagePropertyFilter Class | System.Messaging Namespace


MessagePropertyFilter Constructor

Creates a new MessagePropertyFilter object with the most common properties set. ArrivedTime AdministrationQueue Body CorrelationId Id Label Priority ResponseQueue SentTime

[Visual Basic]
Public Sub New()
[C#]
public MessagePropertyFilter();
[C++]
public: MessagePropertyFilter();
[JScript]
public function MessagePropertyFilter();

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MessagePropertyFilter Properties

The properties of the MessagePropertyFilter class are listed below. For a complete list of MessagePropertyFilter class members, see the MessagePropertyFilter Members topic.

Public:

Acknowledgement | [To be supplied.]
AcknowledgeType | [To be supplied.]
AdministrationQueue | [To be supplied.]
AppSpecific | [To be supplied.]
ArrivedTime | [To be supplied.]
AttachSenderId | [To be supplied.]
Authenticated | [To be supplied.]
AuthenticationProviderName | [To be supplied.]
AuthenticationProviderType | [To be supplied.]
Body | [To be supplied.]
ConnectorType | [To be supplied.]
CorrelationId | [To be supplied.]
DefaultBodySize | The default body buffer size to create, when the message is received.
DefaultExtensionSize | The default extension buffer size to create, when the message is received.
DefaultLabelSize | The default label buffer size to create, when the message is received.
DestinationQueue | [To be supplied.]
DestinationSymmetricKey | [To be supplied.]
DigitalSignature | [To be supplied.]
EncryptionAlgorithm | [To be supplied.]
Extension | [To be supplied.]
HashAlgorithm | [To be supplied.]
Id | [To be supplied.]
IsFirstInTransaction | [To be supplied.]
IsLastInTransaction | [To be supplied.]
Label | [To be supplied.]
MessageType | [To be supplied.]
Priority | [To be supplied.]
Recoverable | [To be supplied.]
ResponseQueue | [To be supplied.]
SenderCertificate | [To be supplied.]
SenderId | [To be supplied.]
SenderVersion | [To be supplied.]
SentTime | [To be supplied.]
SourceMachine | [To be supplied.]
TimeToBeReceived | [To be supplied.]
TimeToReachQueue | [To be supplied.]
TransactionId | [To be supplied.]
TransactionStatusQueue | [To be supplied.]
UseAuthentication | [To be supplied.]
UseDeadLetterQueue | [To be supplied.]
UseEncryption | [To be supplied.]
UseJournalQueue | [To be supplied.]
UseTracing | [To be supplied.]

See Also

MessagePropertyFilter Class | System.Messaging Namespace


MessagePropertyFilter.Acknowledgement

[To be supplied.]

[Visual Basic]
Overridable Public Property Acknowledgement As Boolean
[C#]
public bool Acknowledgement {virtual get; virtual set;}
[C++]
public: __property virtual bool get_Acknowledgement();
public: __property virtual void set_Acknowledgement(bool);
[JScript]
public function get Acknowledgement() : Boolean;
public function set Acknowledgement(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.AcknowledgeType

[To be supplied.]

[Visual Basic]
Overridable Public Property AcknowledgeType As Boolean
[C#]
public bool AcknowledgeType {virtual get; virtual set;}
[C++]
public: __property virtual bool get_AcknowledgeType();
public: __property virtual void set_AcknowledgeType(bool);
[JScript]
public function get AcknowledgeType() : Boolean;
public function set AcknowledgeType(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.AdministrationQueue

[To be supplied.]

[Visual Basic]
Overridable Public Property AdministrationQueue As Boolean
[C#]
public bool AdministrationQueue {virtual get; virtual set;}
[C++]
public: __property virtual bool get_AdministrationQueue();
public: __property virtual void set_AdministrationQueue(bool);
[JScript]
public function get AdministrationQueue() : Boolean;
public function set AdministrationQueue(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.AppSpecific

[To be supplied.]

[Visual Basic]
Overridable Public Property AppSpecific As Boolean
[C#]
public bool AppSpecific {virtual get; virtual set;}
[C++]
public: __property virtual bool get_AppSpecific();
public: __property virtual void set_AppSpecific(bool);
[JScript]
public function get AppSpecific() : Boolean;
public function set AppSpecific(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.ArrivedTime

[To be supplied.]

[Visual Basic]
Overridable Public Property ArrivedTime As Boolean
[C#]
public bool ArrivedTime {virtual get; virtual set;}
[C++]
public: __property virtual bool get_ArrivedTime();
public: __property virtual void set_ArrivedTime(bool);
[JScript]
public function get ArrivedTime() : Boolean;
public function set ArrivedTime(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.AttachSenderId

[To be supplied.]

[Visual Basic]
Overridable Public Property AttachSenderId As Boolean
[C#]
public bool AttachSenderId {virtual get; virtual set;}
[C++]
public: __property virtual bool get_AttachSenderId();
public: __property virtual void set_AttachSenderId(bool);
[JScript]
public function get AttachSenderId() : Boolean;
public function set AttachSenderId(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.Authenticated

[To be supplied.]

[Visual Basic]
Overridable Public Property Authenticated As Boolean
[C#]
public bool Authenticated {virtual get; virtual set;}
[C++]
public: __property virtual bool get_Authenticated();
public: __property virtual void set_Authenticated(bool);
[JScript]
public function get Authenticated() : Boolean;
public function set Authenticated(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.AuthenticationProviderName

[To be supplied.]

[Visual Basic]
Overridable Public Property AuthenticationProviderName As Boolean
[C#]
public bool AuthenticationProviderName {virtual get; virtual set;}
[C++]
public: __property virtual bool get_AuthenticationProviderName();
public: __property virtual void set_AuthenticationProviderName(bool);
[JScript]
public function get AuthenticationProviderName() : Boolean;
public function set AuthenticationProviderName(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.AuthenticationProviderType

[To be supplied.]

[Visual Basic]
Overridable Public Property AuthenticationProviderType As Boolean
[C#]
public bool AuthenticationProviderType {virtual get; virtual set;}
[C++]
public: __property virtual bool get_AuthenticationProviderType();
public: __property virtual void set_AuthenticationProviderType(bool);
[JScript]
public function get AuthenticationProviderType() : Boolean;
public function set AuthenticationProviderType(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.Body

[To be supplied.]

[Visual Basic]
Overridable Public Property Body As Boolean
[C#]
public bool Body {virtual get; virtual set;}
[C++]
public: __property virtual bool get_Body();
public: __property virtual void set_Body(bool);
[JScript]
public function get Body() : Boolean;
public function set Body(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.ConnectorType

[To be supplied.]

[Visual Basic]
Overridable Public Property ConnectorType As Boolean
[C#]
public bool ConnectorType {virtual get; virtual set;}
[C++]
public: __property virtual bool get_ConnectorType();
public: __property virtual void set_ConnectorType(bool);
[JScript]
public function get ConnectorType() : Boolean;
public function set ConnectorType(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.CorrelationId

[To be supplied.]

[Visual Basic]
Overridable Public Property CorrelationId As Boolean
[C#]
public bool CorrelationId {virtual get; virtual set;}
[C++]
public: __property virtual bool get_CorrelationId();
public: __property virtual void set_CorrelationId(bool);
[JScript]
public function get CorrelationId() : Boolean;
public function set CorrelationId(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.DefaultBodySize

The default body buffer size to create, when the message is received.

[Visual Basic]
Public Property DefaultBodySize As Integer
[C#]
public int DefaultBodySize {get; set;}
[C++]
public: __property int get_DefaultBodySize();
public: __property void set_DefaultBodySize(int);
[JScript]
public function get DefaultBodySize() : int;
public function set DefaultBodySize(int);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace


MessagePropertyFilter.DefaultExtensionSize

The default extension buffer size to create, when the message is received.

[Visual Basic]
Public Property DefaultExtensionSize As Integer
[C#]
public int DefaultExtensionSize {get; set;}
[C++]
public: __property int get_DefaultExtensionSize();
public: __property void set_DefaultExtensionSize(int);
[JScript]
public function get DefaultExtensionSize() : int;
public function set DefaultExtensionSize(int);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace


MessagePropertyFilter.DefaultLabelSize

The default label buffer size to create, when the message is received.

[Visual Basic]
Public Property DefaultLabelSize As Integer
[C#]
public int DefaultLabelSize {get; set;}
[C++]
public: __property int get_DefaultLabelSize();
public: __property void set_DefaultLabelSize(int);
[JScript]
public function get DefaultLabelSize() : int;
public function set DefaultLabelSize(int);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace


MessagePropertyFilter.DestinationQueue

[To be supplied.]

[Visual Basic]
Overridable Public Property DestinationQueue As Boolean
[C#]
public bool DestinationQueue {virtual get; virtual set;}
[C++]
public: __property virtual bool get_DestinationQueue();
public: __property virtual void set_DestinationQueue(bool);
[JScript]
public function get DestinationQueue() : Boolean;
public function set DestinationQueue(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.DestinationSymmetricKey

[To be supplied.]

[Visual Basic]
Overridable Public Property DestinationSymmetricKey As Boolean
[C#]
public bool DestinationSymmetricKey {virtual get; virtual set;}
[C++]
public: __property virtual bool get_DestinationSymmetricKey();
public: __property virtual void set_DestinationSymmetricKey(bool);
[JScript]
public function get DestinationSymmetricKey() : Boolean;
public function set DestinationSymmetricKey(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.DigitalSignature

[To be supplied.]

[Visual Basic]
Overridable Public Property DigitalSignature As Boolean
[C#]
public bool DigitalSignature {virtual get; virtual set;}
[C++]
public: __property virtual bool get_DigitalSignature();
public: __property virtual void set_DigitalSignature(bool);
[JScript]
public function get DigitalSignature() : Boolean;
public function set DigitalSignature(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.EncryptionAlgorithm

[To be supplied.]

[Visual Basic]
Overridable Public Property EncryptionAlgorithm As Boolean
[C#]
public bool EncryptionAlgorithm {virtual get; virtual set;}
[C++]
public: __property virtual bool get_EncryptionAlgorithm();
public: __property virtual void set_EncryptionAlgorithm(bool);
[JScript]
public function get EncryptionAlgorithm() : Boolean;
public function set EncryptionAlgorithm(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.Extension

[To be supplied.]

[Visual Basic]
Overridable Public Property Extension As Boolean
[C#]
public bool Extension {virtual get; virtual set;}
[C++]
public: __property virtual bool get_Extension();
public: __property virtual void set_Extension(bool);
[JScript]
public function get Extension() : Boolean;
public function set Extension(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.HashAlgorithm

[To be supplied.]

[Visual Basic]
Overridable Public Property HashAlgorithm As Boolean
[C#]
public bool HashAlgorithm {virtual get; virtual set;}
[C++]
public: __property virtual bool get_HashAlgorithm();
public: __property virtual void set_HashAlgorithm(bool);
[JScript]
public function get HashAlgorithm() : Boolean;
public function set HashAlgorithm(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.Id

[To be supplied.]

[Visual Basic]
Overridable Public Property Id As Boolean
[C#]
public bool Id {virtual get; virtual set;}
[C++]
public: __property virtual bool get_Id();
public: __property virtual void set_Id(bool);
[JScript]
public function get Id() : Boolean;
public function set Id(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.IsFirstInTransaction

[To be supplied.]

[Visual Basic]
Overridable Public Property IsFirstInTransaction As Boolean
[C#]
public bool IsFirstInTransaction {virtual get; virtual set;}
[C++]
public: __property virtual bool get_IsFirstInTransaction();
public: __property virtual void set_IsFirstInTransaction(bool);
[JScript]
public function get IsFirstInTransaction() : Boolean;
public function set IsFirstInTransaction(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.IsLastInTransaction

[To be supplied.]

[Visual Basic]
Overridable Public Property IsLastInTransaction As Boolean
[C#]
public bool IsLastInTransaction {virtual get; virtual set;}
[C++]
public: __property virtual bool get_IsLastInTransaction();
public: __property virtual void set_IsLastInTransaction(bool);
[JScript]
public function get IsLastInTransaction() : Boolean;
public function set IsLastInTransaction(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.Label

[To be supplied.]

[Visual Basic]
Overridable Public Property Label As Boolean
[C#]
public bool Label {virtual get; virtual set;}
[C++]
public: __property virtual bool get_Label();
public: __property virtual void set_Label(bool);
[JScript]
public function get Label() : Boolean;
public function set Label(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.MessageType

[To be supplied.]

[Visual Basic]
Overridable Public Property MessageType As Boolean
[C#]
public bool MessageType {virtual get; virtual set;}
[C++]
public: __property virtual bool get_MessageType();
public: __property virtual void set_MessageType(bool);
[JScript]
public function get MessageType() : Boolean;
public function set MessageType(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.Priority

[To be supplied.]

[Visual Basic]
Overridable Public Property Priority As Boolean
[C#]
public bool Priority {virtual get; virtual set;}
[C++]
public: __property virtual bool get_Priority();
public: __property virtual void set_Priority(bool);
[JScript]
public function get Priority() : Boolean;
public function set Priority(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.Recoverable

[To be supplied.]

[Visual Basic]
Overridable Public Property Recoverable As Boolean
[C#]
public bool Recoverable {virtual get; virtual set;}
[C++]
public: __property virtual bool get_Recoverable();
public: __property virtual void set_Recoverable(bool);
[JScript]
public function get Recoverable() : Boolean;
public function set Recoverable(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.ResponseQueue

[To be supplied.]

[Visual Basic]
Overridable Public Property ResponseQueue As Boolean
[C#]
public bool ResponseQueue {virtual get; virtual set;}
[C++]
public: __property virtual bool get_ResponseQueue();
public: __property virtual void set_ResponseQueue(bool);
[JScript]
public function get ResponseQueue() : Boolean;
public function set ResponseQueue(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.SenderCertificate

[To be supplied.]

[Visual Basic]
Overridable Public Property SenderCertificate As Boolean
[C#]
public bool SenderCertificate {virtual get; virtual set;}
[C++]
public: __property virtual bool get_SenderCertificate();
public: __property virtual void set_SenderCertificate(bool);
[JScript]
public function get SenderCertificate() : Boolean;
public function set SenderCertificate(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.SenderId

[To be supplied.]

[Visual Basic]
Overridable Public Property SenderId As Boolean
[C#]
public bool SenderId {virtual get; virtual set;}
[C++]
public: __property virtual bool get_SenderId();
public: __property virtual void set_SenderId(bool);
[JScript]
public function get SenderId() : Boolean;
public function set SenderId(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.SenderVersion

[To be supplied.]

[Visual Basic]
Overridable Public Property SenderVersion As Boolean
[C#]
public bool SenderVersion {virtual get; virtual set;}
[C++]
public: __property virtual bool get_SenderVersion();
public: __property virtual void set_SenderVersion(bool);
[JScript]
public function get SenderVersion() : Boolean;
public function set SenderVersion(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.SentTime

[To be supplied.]

[Visual Basic]
Overridable Public Property SentTime As Boolean
[C#]
public bool SentTime {virtual get; virtual set;}
[C++]
public: __property virtual bool get_SentTime();
public: __property virtual void set_SentTime(bool);
[JScript]
public function get SentTime() : Boolean;
public function set SentTime(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.SourceMachine

[To be supplied.]

[Visual Basic]
Overridable Public Property SourceMachine As Boolean
[C#]
public bool SourceMachine {virtual get; virtual set;}
[C++]
public: __property virtual bool get_SourceMachine();
public: __property virtual void set_SourceMachine(bool);
[JScript]
public function get SourceMachine() : Boolean;
public function set SourceMachine(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.TimeToBeReceived

[To be supplied.]

[Visual Basic]
Overridable Public Property TimeToBeReceived As Boolean
[C#]
public bool TimeToBeReceived {virtual get; virtual set;}
[C++]
public: __property virtual bool get_TimeToBeReceived();
public: __property virtual void set_TimeToBeReceived(bool);
[JScript]
public function get TimeToBeReceived() : Boolean;
public function set TimeToBeReceived(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.TimeToReachQueue

[To be supplied.]

[Visual Basic]
Overridable Public Property TimeToReachQueue As Boolean
[C#]
public bool TimeToReachQueue {virtual get; virtual set;}
[C++]
public: __property virtual bool get_TimeToReachQueue();
public: __property virtual void set_TimeToReachQueue(bool);
[JScript]
public function get TimeToReachQueue() : Boolean;
public function set TimeToReachQueue(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.TransactionId

[To be supplied.]

[Visual Basic]
Overridable Public Property TransactionId As Boolean
[C#]
public bool TransactionId {virtual get; virtual set;}
[C++]
public: __property virtual bool get_TransactionId();
public: __property virtual void set_TransactionId(bool);
[JScript]
public function get TransactionId() : Boolean;
public function set TransactionId(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.TransactionStatusQueue

[To be supplied.]

[Visual Basic]
Overridable Public Property TransactionStatusQueue As Boolean
[C#]
public bool TransactionStatusQueue {virtual get; virtual set;}
[C++]
public: __property virtual bool get_TransactionStatusQueue();
public: __property virtual void set_TransactionStatusQueue(bool);
[JScript]
public function get TransactionStatusQueue() : Boolean;
public function set TransactionStatusQueue(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.UseAuthentication

[To be supplied.]

[Visual Basic]
Overridable Public Property UseAuthentication As Boolean
[C#]
public bool UseAuthentication {virtual get; virtual set;}
[C++]
public: __property virtual bool get_UseAuthentication();
public: __property virtual void set_UseAuthentication(bool);
[JScript]
public function get UseAuthentication() : Boolean;
public function set UseAuthentication(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.UseDeadLetterQueue

[To be supplied.]

[Visual Basic]
Overridable Public Property UseDeadLetterQueue As Boolean
[C#]
public bool UseDeadLetterQueue {virtual get; virtual set;}
[C++]
public: __property virtual bool get_UseDeadLetterQueue();
public: __property virtual void set_UseDeadLetterQueue(bool);
[JScript]
public function get UseDeadLetterQueue() : Boolean;
public function set UseDeadLetterQueue(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.UseEncryption

[To be supplied.]

[Visual Basic]
Overridable Public Property UseEncryption As Boolean
[C#]
public bool UseEncryption {virtual get; virtual set;}
[C++]
public: __property virtual bool get_UseEncryption();
public: __property virtual void set_UseEncryption(bool);
[JScript]
public function get UseEncryption() : Boolean;
public function set UseEncryption(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.UseJournalQueue

[To be supplied.]

[Visual Basic]
Overridable Public Property UseJournalQueue As Boolean
[C#]
public bool UseJournalQueue {virtual get; virtual set;}
[C++]
public: __property virtual bool get_UseJournalQueue();
public: __property virtual void set_UseJournalQueue(bool);
[JScript]
public function get UseJournalQueue() : Boolean;
public function set UseJournalQueue(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


MessagePropertyFilter.UseTracing

[To be supplied.]

[Visual Basic]
Overridable Public Property UseTracing As Boolean
[C#]
public bool UseTracing {virtual get; virtual set;}
[C++]
public: __property virtual bool get_UseTracing();
public: __property virtual void set_UseTracing(bool);
[JScript]
public function get UseTracing() : Boolean;
public function set UseTracing(Boolean);

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace | Message


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MessagePropertyFilter Methods

The methods of the MessagePropertyFilter class are listed below. For a complete list of MessagePropertyFilter class members, see the MessagePropertyFilter Members topic.

Public:

ClearAll | Sets all the properties to false. No message properties will be retrieved when receiving messages.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SetAll | Sets all the properties to true. All the message properties will be retrieved when receiving messages.
SetDefaults | Sets the most common properties: ArrivedTime AdministrationQueue Body CorrelationId Id Label Priority ResponseQueue SentTime
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MessagePropertyFilter Class | System.Messaging Namespace


MessagePropertyFilter.ClearAll

Sets all the properties to false. No message properties will be retrieved when receiving messages.

[Visual Basic]
Overridable Public Sub ClearAll()
[C#]
public virtual void ClearAll();
[C++]
public: virtual void ClearAll();
[JScript]
public function ClearAll();

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace


MessagePropertyFilter.SetAll

Sets all the properties to true. All the message properties will be retrieved when receiving messages.

[Visual Basic]
Overridable Public Sub SetAll()
[C#]
public virtual void SetAll();
[C++]
public: virtual void SetAll();
[JScript]
public function SetAll();

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace


MessagePropertyFilter.SetDefaults

Sets the most common properties: ArrivedTime AdministrationQueue Body CorrelationId Id Label Priority ResponseQueue SentTime

[Visual Basic]
Overridable Public Sub SetDefaults()
[C#]
public virtual void SetDefaults();
[C++]
public: virtual void SetDefaults();
[JScript]
public function SetDefaults();

See Also

MessagePropertyFilter Class | MessagePropertyFilter Members | System.Messaging Namespace


MessageQueue Class

Provides access to a Message Queuing backend queue resource.

Object
Component
MessageQueue

[Visual Basic]
Public Class MessageQueue
   Inherits Component
[C#]
public class MessageQueue : Component
[C++]
public __gc class MessageQueue : public Component
[JScript]
public class MessageQueue extends Component

Remarks

The MessageQueue class provides a reference to the Message Queuing backend resource. You can connect to an existing resource by specifying its path in the MessageQueue constructor, or create a new backend resource. The instance created in your application must be connected to an existing queue before you can call Send, Peek, or Receive messages. Once connected to a backend resource, you can manipulate the queue properties, like Category and Label.

MessageQueue supports two types of message retrieval, asynchronous and synchronous. The synchronous methods, Peek and Receive, specify a timeout during which the process thread waits for a new message to peek or read. The asynchronous methods, BeginPeek and BeginReceive, allow main application tasks to continue until a message arrives in the queue. The asynchronous methods allow processing to continue in separate threads through the use of callback objects and state objects that communicate information across threads.

Instantiating a MessageQueue object does not result in the creation of a new backend resource, but you can use the Create, Delete, and Purge methods to manage queue resources on the server.

The MessageQueue object supports several ways in which the queue's Path property can be specified. You can use the friendly name defined by the queue's MachineName and QueueName. For public queues, this is MachineName\ QueueName, while for private queues this is MachineName\Private$\ QueueName. Alternately, the FormatName can be specified to support off-line access to message queues. Finally, the queue's Label property can be used to define the queue's Path.

Message Queuing technology enables applications running at different times to communicate across heterogeneous networks and systems that may be temporarily offline. Applications send messages to queues and read messages from queues

When an instance of MessageQueue is created, some of the read/write properties are set to initial values. For a list of these values, see the #ctor constructor.

Requirements

Namespace: System.Messaging

Assembly: system.messaging.dll

Example [Visual Basic]

The following example creates a new MessageQueue object and sends a message to the queue.

This example assumes that there is a priority specified to be 'very low', 'normal', or 'very high' and a body (say, a text string) passed into the procedure. It also assumes there is a Message Queuing computer named myComputer and a queue on that computer called myQueue.

Import the System.Messaging namespace for this example.

[Visual Basic]

Private Sub SendPriorityMessage(ByVal priority As String, ByVal body As Object)
    'Create a new MessageQueue object.
    Dim mq As MessageQueue
    'Initialize the MessageQueue object using the constructor.
    mq = New MessageQueue
    'Set the queue path to an existing queue.
    mq.Path = "myComputer\myQueue"

    'Determine the priority from the value passed in.
    Select Case priority
        Case "very high"
mq.DefaultPropertiesToSend.Priority = MessagePriority.VeryHigh
        Case "very low"
mq.DefaultPropertiesToSend.Priority = MessagePriority.VeryLow
        Case "normal"
mq.DefaultPropertiesToSend.Priority = MessagePriority.Normal
    End Select
    'Send a message to the queue.
    mq.Send(body)
End Sub

See Also

MessageQueue Members | System.Messaging Namespace | Message | DefaultPropertiesToSend | MessageQueueException | MessageQueue | Send | Peek | Receive | BeginPeek | BeginReceive | Path | Label | FormatName | QueueName | MachineName | Create


MessageQueue Members

Public:

Constructor

MessageQueue Constructor Overloaded. Initializes a new instance of the MessageQueue class.

Properties

Authenticate | Gets or sets a value specifying whether the queue only accepts authenticated messages.
BasePriority | Gets or sets a value indicating the base priority used to route a public queue's messages over the network.
CanRead | Gets a value indicating whether the queue has read permission.
CanWrite | Gets a value indicating whether the queue has write permission.
Category | Gets or sets the queue type.
CreateTime | Gets the time and date of the queue's creation.
DefaultPropertiesToSend | Gets or sets the properties to be used by default when sending messages to the queue referenced by this MessageQueue.
DenySharedReceive | [To be supplied.]
EncryptionRequired | Gets or sets a value indicating whether the queue only accepts non-private (non-encrypted) messages.
FormatName | Gets the unique name that was generated for the queue when the queue was created.
Formatter | Gets or sets a formatter class used to format messages read or written to the message body.
Id | Gets the Message Queuing unique identifier for the queue.
Label | Gets or sets the queue description.
LastModifyTime | Indicates the last time the properties of a queue were modified.
MachineName | Gets or sets the name of the computer where the queue referenced by this MessageQueue is located.
MaximumJournalSize | Gets or sets the maximum size of the journal queue.
MaximumQueueSize | Gets or sets the maximum size of the queue.
MessageReadPropertyFilter | Gets or sets the property filter for receiving messages.
Path | Gets or sets the queue's location.
QueueName | Gets or sets the friendly name that identifies the queue.
ReadHandle | The native handle used to receive messages from the message queue
Site (inherited from Component) | Gets or sets the site of the Component.
SynchronizingObject | Represents the object used to marshal the event handler calls issued as a result of a BeginReceive or BeginPeek request into a specific thread. Normally this property will be set when the component is placed inside a control or a from, since those components are bound to a specific thread.
Transactional | Gets a value indicating whether the queue supports transactions.
UseJournalQueue | Gets or sets a value indicating whether retrieved messages are copied to the journal queue.
WriteHandle | The native handle used to send messages to the message queue

Methods

BeginPeek | Overloaded. Returns the first message in the queue without removing it from the queue.
BeginReceive | Overloaded. Receives the first message available in the queue.
BeginTransaction | Creates a new Message Queuing internal transaction context.
Close | Frees all resources allocated by the queue.
CommitTransaction | Commits a pending internal transaction.
Create | Overloaded. Creates a new backend queue resource with the specified path.
Delete | Deletes a queue backend resource identified by the given path.
Dispose (inherited from Component) | Disposes of the Component.
EndPeek | Terminates a peek asynchronous operation identified by the specified interface.
EndReceive | Terminates a receive asynchronous operation identified by the specified interface.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Exists | Determines whether a queue with the specified path exists.
GetAllMessages | Returns all the messages available in the queue.
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetMachineId | [To be supplied.]
GetMessageQueuesEnumerator | Overloaded. [To be supplied.]
GetMessagesEnumerator | Creates an enumerator object for the messages contained in the MessageQueue.
GetPrivateQueuesByMachine | Retrieves all the private queues on the specified computer.
GetPublicQueues | Overloaded. Retrieves public queues on the network.
GetPublicQueuesByCategory | Retrieves a set of public queues filtered by the specified category.
GetPublicQueuesByLabel | Retrieves a set of public queues filtered by the specified label.
GetPublicQueuesByMachine | Retrieves all public queues on the specified computer.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Peek | Overloaded. Returns the first message in the queue without removing it from the queue.
PeekByCorrelationId | Overloaded. [To be supplied.]
PeekById | Overloaded. [To be supplied.]
Purge | Deletes all the messages contained in the queue.
Receive | Overloaded. Receives the first message in the queue.
ReceiveByCorrelationId | Overloaded. [To be supplied.]
ReceiveById | Overloaded. [To be supplied.]
Refresh | Refreshes the properties presented by the MessageQueue to reflect the current state of the resource.
RollbackTransaction | Rolls back the pending internal transaction.
Send | Overloaded. [To be supplied.]
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Events

PeekCompleted | [To be supplied.]
ReceiveCompleted | [To be supplied.]

Fields

InfiniteTimeout | Specifies that there is no timeout period for calls to peek or receive messages.
InifiniteQueueSize | [To be supplied.]

Protected:

Methods

Finalize (inherited from Component) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Event Hookup:

Methods

AddOnPeekCompleted | Adds an event handler for the TBD event.
AddOnReceiveCompleted | Adds an event handler for the TBD event.
RemoveOnPeekCompleted | Removes an event handler from the PeekCompleted event.
RemoveOnReceiveCompleted | Removes an event handler from the ReceiveCompleted event.

See Also

MessageQueue Class | System.Messaging Namespace


MessageQueue Constructor

Initializes a new instance of the MessageQueue class.

Overload List

Initializes a new instance of the MessageQueue class. To use the object instantiated by the default constructor, the Path property must be set.

[Visual Basic] Overloads Public Sub New()
[C#] public MessageQueue();
[C++] public: MessageQueue();
[JScript] public function MessageQueue();

Initializes a new instance of the MessageQueue class that references the Message Queuing application resource specified by the path parameter.

[Visual Basic] Overloads Public Sub New(String)
[C#] public MessageQueue(String);
[C++] public: MessageQueue(String*);
[JScript] public function MessageQueue(String);

Initializes a new instance of the MessageQueue class that references the Message Queuing application resource specified by the path parameter, and has the specified queue access restriction.

[Visual Basic] Overloads Public Sub New(String, Boolean)
[C#] public MessageQueue(String, bool);
[C++] public: MessageQueue(String*, bool);
[JScript] public function MessageQueue(String, Boolean);

Example [Visual Basic]

The following example creates a new MessageQueue object and sends a message to the queue. The Path is set when the MessageQueue is created.

This example assumes that a QueueName (such as "myQueue") and a body (say, a text string) are passed into the procedure. It also assumes there is a Message Queuing computer named myComputer. The queue requires exclusive access by setting sharedModeDenyReceive to true.

Note This example shows how to use one of the overloaded version of the MessageQueue constructor. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub SendMessage(ByVal queueName As String, ByVal body As Object)
    'Define the queue path.
    Dim queuePath As String
    'Set the queue path to an existing queue, such as myComputer\myQueue.
    queuePath = "myComputer\" + queueName
    'define a new MessageQueue object.
    Dim mq As MessageQueue
    'Initialize the MessageQueue with exclusive access.
    mq = New MessageQueue(queuePath, True)

    'Send a message to the queue.
    mq.Send(body)
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue Constructor ()

Initializes a new instance of the MessageQueue class. To use the object instantiated by the default constructor, the Path property must be set.

[Visual Basic]
Overloads Public Sub New()
[C#]
public MessageQueue();
[C++]
public: MessageQueue();
[JScript]
public function MessageQueue();

Exceptions

Exception Type | Condition
ArgumentException | The Path property syntax in invalid. The path may not have been set.
MessageQueueException | The FormatName property is invalid.
MessageQueueException | The application attempted to access a queue defined by its Path property while offline.

Remarks

The MessageQueue constructor instantiates a new instance of a MessageQueue class. The constructor does not create a new Message Queuing object, so the queue to which you link the MessageQueue must already exist. To create a new queue in Message Queuing, use Create.

Use this overloaded constructor when you want to create a new MessageQueue but do not want to tie it immediately to a Message Queuing backend object. Before using the object instantiated by this overload, you must set the Path property to connect to an existing Message Queuing queue. Alternately, you can use Create to create a new backend queue object by setting the MessageQueue instance to the return value of the Create method.

When an instance of MessageQueue is created, the following read/write properties are set to initial values.

Property | Initial Value
DefaultPropertiesToSend | The values set by the default constructor of the DefaultPropertiesToSend class.
Formatter | ?? XmlQueueMessageFormatter
MessageReadPropertyFilter | The values set by the default constructor of the MessagePropertyFilter class. All filter values are set to true.
DenySharedReceive | false

You can change the value for any of these properties through a separate call to the property.

Example [Visual Basic]

The following example creates a new MessageQueue object and sends a message to the queue.

This example assumes that there is a body (say, a text string) passed into the procedure. It also assumes there is a Message Queuing computer named myComputer and a queue on that computer called myQueue.

Import the System.Messaging namespace for this example.

[Visual Basic]

Private Sub SendMessage(ByVal body As Object)
    'Create a new MessageQueue object.
    Dim mq As MessageQueue
    'Initialize the MessageQueue object using the constructor.
    mq = New MessageQueue
    'Set the queue path to an existing queue.
    mq.Path = "myComputer\myQueue"

    'Send a message to the queue.
    mq.Send(body)
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue Constructor Overload List | Create | Path | FormatName


MessageQueue Constructor (String)

Initializes a new instance of the MessageQueue class that references the Message Queuing application resource specified by the path parameter.

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As String _
)
[C#]
public MessageQueue(
   string path
);
[C++]
public: MessageQueue(
   String* path
);
[JScript]
public function MessageQueue(
   path : String
);

Parameters

path
The location of the queue referenced by this MessageQueue, or "." for the local computer. For information on proper syntax for this parameter, see the Remarks section.

Exceptions

Exception Type | Condition
ArgumentException | The Path property syntax in invalid. The path may not have been set.
MessageQueueException | The FormatName property is invalid.
MessageQueueException | The application attempted to access a queue defined by its Path property while offline.

Remarks

The MessageQueue constructor instantiates a new instance of a MessageQueue class. The constructor does not create a new Message Queuing backend object, so the queue to which you link the MessageQueue must already exist in the Message Queuing application. To create a new queue in Message Queuing, use Create.

Use this overload when the Message Queuing queue's path or format name are known and you wish to tie the MessageQueue to this backend resource. This overload of the constructor does not set the queue for exclusive access by the first application to reference the queue. If you want such access, either set the DenySharedReceive property to true or use the constructor that passes this restriction as a parameter.

The syntax for the path parameter depends on the type of queue it references. The following table shows the syntax you should use for a queue of a specified type.

Queue Type | Syntax
Public Queue | MachineName\QueueName
Private Queue | MachineName\Private$\QueueName
Journal Queue | MachineName\QueueName\Journal$
Machine Journal Queue | MachineName\Journal$
Machine Deadletter Queue | MachineName\Deadletter$
Machine Transactional Deadletter Queue | MachineName\XactDeadletter$

You can also use the FormatName or Label of a Message Queuing object to describe the queue path. The following table shows the proper syntax for each type of reference.

Reference | Syntax
Format Name | FormatName:[format name]
Label | Label:[label]

If you will be using the queue to work offline, you must use the format name, not the path name for the constructor. If you are working offline, using the path name will throw an exception because the primary domain controller won't be available to resolve the Path into the FormatName.

If you hard-code the path into your application, deleting and then creating a queue with the same name will not be seen as the same queue, because the queue Id which generates part of the FormatName will have changed.

You can specify the queue's label in the syntax of its path. Use the format Label:[label] in the Path.

When you create an instance of MessageQueue, the following read/write properties are set to initial values, based on the properties of the Message Queuing queue object at the specified path.

Property | Initial Value
Authenticate | The value of the Message Queuing queue object's authenticated setting.
BasePriority | The value of the Message Queuing queue object's base priority setting.
Category | The value of the Message Queuing queue object's type ID setting.
DefaultPropertiesToSend | The values set by the default constructor of the DefaultPropertiesToSend class.
EncryptionRequired | true, if the Message Queuing object's privacy level setting is "Body"; otherwise, false.
Formatter | ?? XmlQueueMessageFormatter
Label | The value of the Message Queuing queue object's label setting.
MachineName | The value of the Message Queuing queue object's computer name setting.
MaximumJournalSize | The value of the Message Queuing queue object's journal storage limit setting.
MaximumQueueSize | The value of the Message Queuing queue object's message storage limit setting.
MessageReadPropertyFilter | The values set by the default constructor of the MessagePropertyFilter class. All filter values are set to true.
Path | The values of the Message Queuing queue object's path setting.
QueueName | The values of the Message Queuing queue object's queue name setting.
DenySharedReceive | false
UseJournalQueue | true, if the Message Queuing object's journal setting is enabled; otherwise, false.

You can change the value for any of these properties through a separate call to the property.

Example [Visual Basic]

The following example creates a new MessageQueue object and sends a message to the queue. The Path is set when the MessageQueue is created.

This example assumes that a QueueName (such as "myQueue") and a body (say, a text string) are passed into the procedure. It also assumes there is a Message Queuing computer named myComputer.

[Visual Basic]

Private Sub SendMessage(ByVal queueName As String, ByVal body As Object)
    'Define the queue path.
    Dim queuePath As String
    'Set the queue path to an existing queue, such as myComputer\myQueue.
    queuePath = "myComputer\" + queueName
    'Define a new MessageQueue object.
    Dim mq As MessageQueue
    'Initialize the MessageQueue object using the constructor.
    mq = New MessageQueue(queuePath)

    'Send a message to the queue.
    mq.Send(body)
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue Constructor Overload List | FormatName | Label | Path | Create


MessageQueue Constructor (String, Boolean)

Initializes a new instance of the MessageQueue class that references the Message Queuing application resource specified by the path parameter, and has the specified queue access restriction.

[Visual Basic]
Overloads Public Sub New( _
   ByVal path As String, _
   ByVal sharedModeDenyReceive As Boolean _
)
[C#]
public MessageQueue(
   string path,
   bool sharedModeDenyReceive
);
[C++]
public: MessageQueue(
   String* path,
   bool sharedModeDenyReceive
);
[JScript]
public function MessageQueue(
   path : String,
   sharedModeDenyReceive : Boolean
);

Parameters

path
The location of the queue referenced by this MessageQueue, or "." for the local computer. For information on proper syntax for this parameter, see the Remarks section.
sharedModeDenyReceive
true if you require exclusive read access over the referenced queue by the first application to access the queue; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentException | The Path property syntax in invalid. The path may not have been set.
MessageQueueException | The FormatName property is invalid.
MessageQueueException | The application attempted to access a queue defined by its Path property while offline.

Remarks

The MessageQueue constructor instantiates a new instance of a MessageQueue class. The constructor does not create a new Message Queuing backend object, so the queue you link the MessageQueue to must already exist in the Message Queuing application. To create a new queue in Message Queuing, use Create.

Use this overload when the Message Queuing queue's path or format name are known and you wish to tie the MessageQueue to this backend resource. This overload of the constructor can set the queue for exclusive access by the first application to reference the queue. If you do not want such access, either set the sharedModeDenyReceive parameter to false or use the constructor that passes in only the path as a parameter.

The syntax for the path parameter depends on the type of queue it references. The following table shows the syntax you should use for a queue of a specified type.

Queue Type | Syntax
Public Queue | MachineName\QueueName
Private Queue | MachineName\Private$\QueueName
Journal Queue | MachineName\QueueName\Journal$
Machine Journal Queue | MachineName\Journal$
Machine Deadletter Queue | MachineName\Deadletter$
Machine Transactional Deadletter Queue | MachineName\XactDeadletter$

You can also use the FormatName of Label of a Message Queuing object to describe the queue path. The following table shows the proper syntax for each type of reference.

Reference | Syntax
Format Name | FormatName:[format name]
Label | Label:[label]

If you will be using the queue to work offline, you must use the format name, not the path name for the constructor. If you are working offline, using the path name will throw an exception because the domain controller which owns the Active Directory won't be available to resolve the Path into the FormatName.

If you hard-code the path into your application, deleting and then creating a queue with the same name will not be seen as the same queue, because the queue Id which generates part of the FormatName will have changed.

You can specify the queue's label in the syntax of its path. Use the format Label:[label] in the Path.

If sharedModeDenyReceive is set to true, the first application to access the queue has exclusive access.

When you create an instance of MessageQueue, the folowing read/write properties are set to initial values, based on the properties of the Message Queuing queue object at the specified path.

Property | Initial Value
Authenticate | The value of the Message Queuing queue object's authenticated setting.
BasePriority | The value of the Message Queuing queue object's base priority setting.
Category | The value of the Message Queuing queue object's type ID setting.
DefaultPropertiesToSend | The values set by the default constructor of the DefaultPropertiesToSend class.
EncryptionRequired | true, if the Message Queuing object's privacy level setting is "Body"; otherwise, false.
Formatter | ?? XmlQueueMessageFormatter
Label | The value of the Message Queuing queue object's label setting.
MachineName | The value of the Message Queuing queue object's computer name setting.
MaximumJournalSize | The value of the Message Queuing queue object's journal storage limit setting.
MaximumQueueSize | The value of the Message Queuing queue object's message storage limit setting.
MessageReadPropertyFilter | The values set by the default constructor of the MessagePropertyFilter class. All filter values are set to true.
Path | The path parameter.
QueueName | The values of the Message Queuing queue object's queue name setting.
DenySharedReceive | The sharedModeDenyReceive parameter.
UseJournalQueue | true, if the Message Queuing object's journal setting is enabled; otherwise, false.

You can change the value for any of these properties through a separate call to the property.

Example [Visual Basic]

The following example creates a new MessageQueue object and sends a message to the queue. The Path is set when the MessageQueue is created.

This example assumes that a QueueName (such as "myQueue") and a body (say, a text string) are passed into the procedure. It also assumes there is a Message Queuing computer named myComputer. The queue requires exclusive access by setting sharedModeDenyReceive to true.

[Visual Basic]

Private Sub SendMessage(ByVal queueName As String, ByVal body As Object)
    'Define the queue path.
    Dim queuePath As String
    'Set the queue path to an existing queue, such as myComputer\myQueue.
    queuePath = "myComputer\" + queueName
    'define a new MessageQueue object.
    Dim mq As MessageQueue
    'Initialize the MessageQueue with exclusive access.
    mq = New MessageQueue(queuePath, True)

    'Send a message to the queue.
    mq.Send(body)
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue Constructor Overload List | FormatName | Label | Path | Create | DenySharedReceive


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MessageQueue Properties

The properties of the MessageQueue class are listed below. For a complete list of MessageQueue class members, see the MessageQueue Members topic.

Public:

Authenticate | Gets or sets a value specifying whether the queue only accepts authenticated messages.
BasePriority | Gets or sets a value indicating the base priority used to route a public queue's messages over the network.
CanRead | Gets a value indicating whether the queue has read permission.
CanWrite | Gets a value indicating whether the queue has write permission.
Category | Gets or sets the queue type.
CreateTime | Gets the time and date of the queue's creation.
DefaultPropertiesToSend | Gets or sets the properties to be used by default when sending messages to the queue referenced by this MessageQueue.
DenySharedReceive | [To be supplied.]
EncryptionRequired | Gets or sets a value indicating whether the queue only accepts non-private (non-encrypted) messages.
FormatName | Gets the unique name that was generated for the queue when the queue was created.
Formatter | Gets or sets a formatter class used to format messages read or written to the message body.
Id | Gets the Message Queuing unique identifier for the queue.
Label | Gets or sets the queue description.
LastModifyTime | Indicates the last time the properties of a queue were modified.
MachineName | Gets or sets the name of the computer where the queue referenced by this MessageQueue is located.
MaximumJournalSize | Gets or sets the maximum size of the journal queue.
MaximumQueueSize | Gets or sets the maximum size of the queue.
MessageReadPropertyFilter | Gets or sets the property filter for receiving messages.
Path | Gets or sets the queue's location.
QueueName | Gets or sets the friendly name that identifies the queue.
ReadHandle | The native handle used to receive messages from the message queue
Site (inherited from Component) | Gets or sets the site of the Component.
SynchronizingObject | Represents the object used to marshal the event handler calls issued as a result of a BeginReceive or BeginPeek request into a specific thread. Normally this property will be set when the component is placed inside a control or a from, since those components are bound to a specific thread.
Transactional | Gets a value indicating whether the queue supports transactions.
UseJournalQueue | Gets or sets a value indicating whether retrieved messages are copied to the journal queue.
WriteHandle | The native handle used to send messages to the message queue

See Also

MessageQueue Class | System.Messaging Namespace


MessageQueue.Authenticate

Gets or sets a value specifying whether the queue only accepts authenticated messages.

[Visual Basic]
Overridable Public Property Authenticate As Boolean
[C#]
public bool Authenticate {virtual get; virtual set;}
[C++]
public: __property virtual bool get_Authenticate();
public: __property virtual void set_Authenticate(bool);
[JScript]
public function get Authenticate() : Boolean;
public function set Authenticate(Boolean);

Property Value

true if the queue only accepts authenticated messages; otherwise, false.

Exceptions

Exception Type | Condition
MessageQueueException | The attempt to get or set the Authenticate setting generated an internal error on the message queue component. The error is specified by the given status message.

Remarks

When a non-authenticated message is sent to a queue that only accepts authenticated messages, the message is rejected. The sending application can request notification when a message is rejected by setting the AcknowledgeType on the message. There is no indication otherwise that the message was rejected, so the message can be lost unless you send it to the deadletter queue.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue.BasePriority

Gets or sets a value indicating the base priority used to route a public queue's messages over the network.

[Visual Basic]
Overridable Public Property BasePriority As Short
[C#]
public short BasePriority {virtual get; virtual set;}
[C++]
public: __property virtual short get_BasePriority();
public: __property virtual void set_BasePriority(short);
[JScript]
public function get BasePriority() : Int16;
public function set BasePriority(Int16);

Property Value

The public queue's base priority. The default is 0.

Exceptions

Exception Type | Condition
ArgumentException | The base priority was set to an invalid value.
MessageQueueException | The attempt to get or set the base priority generated an internal error on the message queue component. The error is specified by the given status message.

Remarks

The BasePriority property can be used to give messages sent to the specified queue a higher (or lower) priority than messages sent to other queues.

BasePriority specifies how a message is treated as it travels through the network. A message queue's BasePriority is not related to the Priority property of a message, which specifies the order in which an incoming message is placed in the queue.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue.CanRead

Gets a value indicating whether the queue has read permission.

[Visual Basic]
Overridable Public ReadOnly Property CanRead As Boolean
[C#]
public bool CanRead {virtual get;}
[C++]
public: __property virtual bool get_CanRead();
[JScript]
public function get CanRead() : Boolean;

Property Value

true if the queue object has permission to read; otherwise, false.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue.CanWrite

Gets a value indicating whether the queue has write permission.

[Visual Basic]
Overridable Public ReadOnly Property CanWrite As Boolean
[C#]
public bool CanWrite {virtual get;}
[C++]
public: __property virtual bool get_CanWrite();
[JScript]
public function get CanWrite() : Boolean;

Property Value

true if the queue object has permission to write; otherwise, false.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue.Category

Gets or sets the queue type.

[Visual Basic]
Overridable Public Property Category As Guid
[C#]
public Guid Category {virtual get; virtual set;}
[C++]
public: __property virtual Guid get_Category();
public: __property virtual void set_Category(Guid);
[JScript]
public function get Category() : Guid;
public function set Category(Guid);

Property Value

A Guid that represents the queue category (Message Queuing type Id). The default is Guid.empty.

Exceptions

Exception Type | Condition
ArgumentException | The queue category was set to an invalid value.
MessageQueueException | The attempt to get or set the queue category generated an internal error on the message queue component. The error is specified by the given status message.

Remarks

The queue category enables an application to categorize associated queues according to the way they are used. The Category can be a null reference. You can also define a new category.

The Category property provides access to the Message Queuing queue-associated type ID read/write property. You can use NewGuid to create a category value that is guaranteed to be unique across all Guid values. However, it is only necessary for the category value to be distinct from other categories, not from all other Guid values. You may assign, for example, the Category for one set of queues to be {00000000-0000-0000-0000-000000000001} and the Category for another set of queues to be {00000000-0000-0000-0000-000000000002}.

Id and Category are both Guid values. However, their behavior is quite different. The Category is a read/write value, while Id is read-only. Also, the Category need not be unique on the network. You can, for example, define all Billing queues to have the same category, and all Order queues to have a different category. The Id values for each queue on the network are guaranteed to be unique when the Message Queuing application creates the queue

Example [Visual Basic]

The following example creates a list of queues associated with a specified category. A queue is passed in by its Path property. The procedure retrieves the Category for that queue and sends a broadcast message to all other queues with the same Category.

This procedure required that a path be passed in. Because GetPublicQueuesByCategory retrieves only public queues, it is assumed that the path is in the form "computer name\queue name". It is also assumed that the category (Message Queuing type id) associated with the queue is not a null reference (in Visual Basic Nothing).

[Visual Basic]

Private Sub SearchPublicQueuesByCategory(ByVal queuePath As String)
    'Create an array to hold the set of message queues.
    Dim mqList() As MessageQueue
    'The following integer is used in the for loop
    Dim i As Integer
    'The category of the queue with the specified path.
    Dim cat As System.Guid

    'Define and instantiate a new MessageQueue with the specified path.
    Dim MessageQueue1 As MessageQueue
    MessageQueue1 = New MessageQueue(queuePath)

    'Get the category of the queue that was passed in.
    cat = MessageQueue1.Category

    'Get an array containing MessageQueue information.
    mqList = MessageQueue.GetPublicQueuesByCategory(cat)

    'Iterate through the message queues to send a message to each one.
    For i = 0 To mqList.Length - 1
        'There may be several machines containing queues with
        'the given category. Send a message to each one
        mqList(i).Send("Broadcast message to queues with category " + cat.ToString)
        'Send notification about the queue and its index in the array.
        MessageBox.Show(mqList(i).Path + " at index: " + i)
    Next
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | Id | TBD | Label | GetPublicQueuesByCategory | GetPublicQueues


MessageQueue.CreateTime

Gets the time and date of the queue's creation.

[Visual Basic]
Overridable Public ReadOnly Property CreateTime As DateTime
[C#]
public DateTime CreateTime {virtual get;}
[C++]
public: __property virtual DateTime get_CreateTime();
[JScript]
public function get CreateTime() : DateTime;

Property Value

A DateTime that represents the date and time at which the queue was created. This refers to the MessageQueue object, not the Message Queuing backend queue object. The default is the current local time (adjusted from Greenwich Mean Time).

Exceptions

Exception Type | Condition
MessageQueueException | The attempt to get the creation time generated an internal error on the message queue component. The error is specified by the given status message. .

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue.DefaultPropertiesToSend

Gets or sets the properties to be used by default when sending messages to the queue referenced by this MessageQueue.

[Visual Basic]
Overridable Public Property DefaultPropertiesToSend As _
   DefaultPropertiesToSend
[C#]
public DefaultPropertiesToSend DefaultPropertiesToSend {virtual
   get; virtual set;}
[C++]
public: __property virtual DefaultPropertiesToSend* get_DefaultPropertiesToSend();
public: __property virtual void set_DefaultPropertiesToSend(DefaultPropertiesToSend*);
[JScript]
public function get DefaultPropertiesToSend() : DefaultPropertiesToSend;
public function set DefaultPropertiesToSend(DefaultPropertiesToSend);

Property Value

A DefaultPropertiesToSend that holds the default property values used when sending messages to the queue.

Exceptions

Exception Type | Condition
ArgumentException | The default properties could not be set for the queue. A property may have been set to an invalid value.
MessageQueueException | The attempt to get or set the default properties generated an internal error on the message queue component. The error is specified by the given status message.

Remarks

The DefaultPropertiesToSend describes the read/write property values that apply to messages sent to the queue referenced by the MessageQueue. When you create a Message object, these properties on the message will be set to their default values. Before you Send a Message object, you must explicitly override the initial values on the Message properties if you want the DefaultPropertiesToSend to apply. If you use the Send method using any object other than a Message, such as a string, the DefaultPropertiesToSend will automatically apply to the object. Only Message instances require these defaults to be explicitly overridden.

Although the properties are set using the MessageQueue object, the DefaultPropertiesToSend refers to properties on the messages that are sent to the queue, not the queue itself.

The default values for the properties are represented in the following table.

Property | Value
AcknowledgeType | AcknowledgeType.None
AdministrationQueue | a null reference (in Visual Basic Nothing)
AppSpecific | 0
AttachSenderId | true
EncryptionAlgorithm | EncryptionAlgorithm.RC2
Extension | A zero-length array of bytes
HashAlgorithm | HashAlgorithm.MD5
Label | "" (empty string)
Priority | MessagePriority.Normal
Recoverable | false
ResponseQueue | a null reference (Nothing)
TimeToBeReceived | Message.InfiniteTimeout
TimeToReachQueue | Message.InfiniteTimeout
TransactionStatusQueue | a null reference (Nothing)
UseAuthentication | false
UseDeadLetterQueue | false
UseEncryption | false
UseJournalQueue | false
UseTracing | false

Example [Visual Basic]

The following example sets different DefaultPropertiesToSend values based on whether a message passed into the procedure has high or normal MessagePriority. The properties that are set, which apply to the message to be sent to the message queue, are: Label, Priority, TimeToBeReceived, and TimeToReachQueue.

It is important to note that these properties are set through the MessageQueue, but they apply to the Message object.

This example assumes that the calling procedure passes in a MessagePriority, and that an urgent message is indicated by Highest priority. It also assumes that the calling method defines the Message that is to be sent to the queue.

[Visual Basic]

Private Sub SetDefaultPropertiesToSend(ByVal priority As MessagePriority, ByVal msg As Message)
    'Create DefaultPropertiesToSend objects
    Dim urgentMessageProperties As DefaultPropertiesToSend
    Dim normalMessageProperties As DefaultPropertiesToSend
    'Define and instantiate a new MessageQueue object
    Dim messageQueue1 As MessageQueue
    messageQueue1 = New MessageQueue

    'Set the queue path
    messageQueue1.Path = "mycomputer\myqueue"
    'Set the label for the queue (as opposed to the message labels).
    messageQueue1.Label = "My Queue"

    'Instantiate two new DefaultPropertiesToSend objects.
    urgentMessageProperties = New DefaultPropertiesToSend
    normalMessageProperties = New DefaultPropertiesToSend

    'Set the label and priority for urgent messages.
    urgentMessageProperties.Label = "Urgent Message"
    urgentMessageProperties.Priority = MessagePriority.Highest
    'Make the process wait indefinitely for a message.
    urgentMessageProperties.TimeToBeReceived = Message.Infinite
    urgentMessageProperties.TimeToReachQueue = Message.Infinite
    urgentMessageProperties.UseDeadLetterQueue = True

    'Set the label and priority for normal messages.
    normalMessageProperties.Label = "Normal Message"
    normalMessageProperties.Priority = MessagePriority.Normal
    'Make the process wait a finite amount of time for a message.
    normalMessageProperties.TimeToBeReceived = 3000
    normalMessageProperties.TimeToReachQueue = 3000
    normalMessageProperties.UseDeadLetterQueue = True
    'If the message is urgent, use the urgent DefaultPropertiesToSend
    If priority = MessagePriority.Highest Then
        messageQueue1.DefaultPropertiesToSend = urgentMessageProperties
    Else
        'Otherwise, use normal DefaultPropertiesToSend
        messageQueue1.DefaultPropertiesToSend = normalMessageProperties
    End If
    'Override default properties on the message object
    msg.Priority = messageQueue1.DefaultPropertiesToSend.Priority
    msg.Label = messageQueue1.DefaultPropertiesToSend.Label
    msg.TimeToBeReceived = messageQueue1.DefaultPropertiesToSend.TimeToBeReceived
    msg.TimeToReachQueue = messageQueue1.DefaultPropertiesToSend.TimeToReachQueue
    'Send the message that was passed in.
    messageQueue1.Send(msg)
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | Message | AcknowledgeType | EncryptionAlgorithm | HashAlgorithm | InfiniteTimeout | InfiniteTimeout


MessageQueue.DenySharedReceive

[To be supplied.]

[Visual Basic]
Overridable Public Property DenySharedReceive As Boolean
[C#]
public bool DenySharedReceive {virtual get; virtual set;}
[C++]
public: __property virtual bool get_DenySharedReceive();
public: __property virtual void set_DenySharedReceive(bool);
[JScript]
public function get DenySharedReceive() : Boolean;
public function set DenySharedReceive(Boolean);

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue.EncryptionRequired

Gets or sets a value indicating whether the queue only accepts non-private (non-encrypted) messages.

[Visual Basic]
Overridable Public Property EncryptionRequired As _
   EncryptionRequired
[C#]
public EncryptionRequired EncryptionRequired {virtual get; virtual
   set;}
[C++]
public: __property virtual EncryptionRequired get_EncryptionRequired();
public: __property virtual void set_EncryptionRequired(EncryptionRequired);
[JScript]
public function get EncryptionRequired() : EncryptionRequired;
public function set EncryptionRequired(EncryptionRequired);

Property Value

One of the EncryptionRequired values. The default is None.

Exceptions

Exception Type | Condition
MessageQueueException | The attempt to get or set the encryption level generated an internal error on the message queue component. The error is specified by the given status message.

Remarks

When you specify that encryption is required on the messages sent to a queue, only the body of the message is encrypted. Other members, such as the message Label or SenderId properties, cannot be encrypted.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue.FormatName

Gets the unique name that was generated for the queue when the queue was created.

[Visual Basic]
Overridable Public ReadOnly Property FormatName As String
[C#]
public string FormatName {virtual get;}
[C++]
public: __property virtual String* get_FormatName();
[JScript]
public function get FormatName() : String;

Property Value

The unique name for the queue, generated by the Message Queuing application when the queue was created.

Exceptions

Exception Type | Condition
MessageQueueException | The Path is not set. -or- There is a problem connecting to the network.

Remarks

The FormatName property specifies the format name of the queue. This property or the Path property must be set before accessing the queue. Message Queuing uses the queue's format name to identify which queue to open and how to access the opened queue. If you specify a path such as myComputer\myQueue, rather than the format name, the primary domain controller translates the Path into the associated FormatName before accessing the queue. Unlike most of the characteristics of a queue, the format name is not a Message Queuing application queue property that can be accessed through the Message Queuing management tool. It is simply a unique name for the queue that is generated by Message Queuing when the queue is created or generated later by the application.

When creating a queue, Message Queuing generates the format name from the queue's path name. After the queue is created, you can use the name generated by the Message Queuing application or specify a different one.

Example [Visual Basic]

The following example demonstrates using the queue's FormatName to set the Path property. Because FormatName is read-only, the procedure does not set the FormatName property; instead the procedure reads and appends the FormatName to the string "FormatName:Public=" in order to define the path. This procedure assumes that the Id value passed in represents a valid public queue. The ID of a queue can be retrieved using the Message Queuing application.

[Visual Basic]

Private Sub SendUsingQueueFormat(ByVal queueId As System.Guid)
    'The queue path, to be generated from the queue Id.
    Dim queuePath As String
    'Define a new MessageQueue.
    Dim messageQueue1 As MessageQueue

    'Generate the path using the FormatName.
    queuePath = "FormatName:PUBLIC=" + queueId.ToString
    'Instantiate a MessageQueue with the specified path.
    messageQueue1 = New MessageQueue(queuePath)
    'Send a message to the queue.
    messageQueue1.Send("Test Message")
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | Path | Label | MessageQueue


MessageQueue.Formatter

Gets or sets a formatter class used to format messages read or written to the message body.

[Visual Basic]
Public Property Formatter As IMessageFormatter
[C#]
public IMessageFormatter Formatter {get; set;}
[C++]
public: __property IMessageFormatter* get_Formatter();
public: __property void set_Formatter(IMessageFormatter*);
[JScript]
public function get Formatter() : IMessageFormatter;
public function set Formatter(IMessageFormatter);

Property Value

The IMessageFormatter that represents the way to format objects in the message. The default is SoapMessageFormatter.

Remarks

The formatter object defines how a message gets transformed into a specific format when it is sent or received by the queue. The Formatter property contains an instance of a formatter object used to read or write to the message body.

If you use the default SoapMessageFormatter, the message is human-readable throughout its life cycle and can be viewed using an XML reader. This allows for a greater level of error handling, as the message can be fixed if a part of it becomes corrupted.

If you use a binary message formatter or the dataset message formatter to write the message, the same formatter is required to read it. Unless you use the original formatter, you will not be able to fix corrupted messages, since the message is not human-readable in the binary or dataset format. However, the binary message formatters provide faster throughput.

When a formatter is used to write to the queue, the Formatter only defines the format for messages that use the default message properties, DefaultPropertiesToSend.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | SoapMessageFormatter | DataSetMessageFormatter | ActiveXMessageFormatter | BinaryMessageFormatter


MessageQueue.Id

Gets the Message Queuing unique identifier for the queue.

[Visual Basic]
Overridable Public ReadOnly Property Id As Guid
[C#]
public Guid Id {virtual get;}
[C++]
public: __property virtual Guid get_Id();
[JScript]
public function get Id() : Guid;

Property Value

An Id that represents the Message Queuing application-generated message identifier.

Exceptions

Exception Type | Condition
MessageQueueException | The attempt to get the id generated the exception specified by the given information.

Remarks

The Id property is set by the Message Queuing application when the application creates the queue.

Id and Category are both Guid values. However, their behavior is quite different. The Category is a read/write value, while Id is read-only. Also, the Category need not be unique on the network. You can, for example, define all Billing queues to have the same category, and all Order queues to have a different category. The Id values for each queue on the network are guaranteed to be unique when the Message Queuing application creates the queue.

Example [Visual Basic]

The following example uses the queue Id to set the Path property. Because Id is read-only, the procedure does not set the Id property, but it can be read and appended to the string "FormatName:Public=" in order to define the path. This procedure assumes that the Id passed in represents a valid public queue.

The function GetQueueId gets the Id from a known queue.

[Visual Basic]

Private Sub SendUsingQueueFormat(ByVal queueId As System.Guid)
    'The queue path, to be generated from the queue Id.
    Dim queuePath As String
    'Define a new MessageQueue.
    Dim messageQueue1 As MessageQueue

    'Generate the path using the FormatName.
    queuePath = "FormatName:PUBLIC=" + queueId.ToString
    'Instantiate a MessageQueue with the specified path.
    messageQueue1 = New MessageQueue(queuePath)
    'Send a message to the queue.
    messageQueue1.Send("Test Message")
End Sub

Private Function GetQueueId(ByVal queuePath As String) As System.Guid
    Dim idGuid As System.Guid
    'Create and instantiate a MessageQueue using the path passed in.
    Dim mq As MessageQueue
    mq = New MessageQueue(queuePath)
    'Return the Id of the queue to the calling procedure.
    GetQueueId = mq.Id
End Function

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | Category | TBD


MessageQueue.Label

Gets or sets the queue description.

[Visual Basic]
Overridable Public Property Label As String
[C#]
public string Label {virtual get; virtual set;}
[C++]
public: __property virtual String* get_Label();
public: __property virtual void set_Label(String*);
[JScript]
public function get Label() : String;
public function set Label(String);

Property Value

The label for the message queue. The default is an empty string ("").

Exceptions

Exception Type | Condition
ArgumentException | The label was set to an invalid value.
MessageQueueException | The attempt to get or set the label generated an internal error on the message queue component. The error is specified by the given status message.

Remarks

The maximum length of a message label is 250 Unicode characters (including the end-of-line character).

The Label property does not have to be unique across queues. However, the Label cannot be used to broadcast messages to multiple queues using the Send method. If you call Send and pass in a Label for the Path property, an exception will be thrown if the Label is not unique.

Example [Visual Basic]

The following example connects to a queue by specifying the Label property. Because the MachineName is not specified, the computer is the local computer. If no queue with the label exists, one is created.

It is assumed that the label parameter passed in was defined within the calling procedure.

[Visual Basic]

Private Sub CreateQueueByLabel(ByVal label As String)
    'Define a new MessageQueue
    Dim messageQueue1 As MessageQueue

    'If a queue with the given label doesn't exist, create it.
    If Not MessageQueue.Exists("Label:" + label) Then
        messageQueue1 = MessageQueue.Create("Label:" + label)
        'Set the label for the queue.
        messageQueue1.Label = label
    End If
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | Path | FormatName | MessageQueue | GetPublicQueuesByLabel | GetPublicQueues


MessageQueue.LastModifyTime

Indicates the last time the properties of a queue were modified.

[Visual Basic]
Overridable Public ReadOnly Property LastModifyTime As DateTime
[C#]
public DateTime LastModifyTime {virtual get;}
[C++]
public: __property virtual DateTime get_LastModifyTime();
[JScript]
public function get LastModifyTime() : DateTime;

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue.MachineName

Gets or sets the name of the computer where the queue referenced by this MessageQueue is located.

[Visual Basic]
Overridable Public Property MachineName As String
[C#]
public string MachineName {virtual get; virtual set;}
[C++]
public: __property virtual String* get_MachineName();
public: __property virtual void set_MachineName(String*);
[JScript]
public function get MachineName() : String;
public function set MachineName(String);

Property Value

The name of the computer on which the queue is located. The Message Queuing default is ".", the local computer.

Exceptions

Exception Type | Condition
ArgumentException | The MachineName is a null reference (in Visual Basic Nothing).
ArgumentException | The computer name was set to an invalid value. The syntax may be incorrect.
MessageQueueException | The attempt to get or set the machine name generated an internal error on the message queue component. The error is specified by the given status message.

Remarks

If you don't specify a value for the Path when the MachineName is set, the path is built from an existing queue. If you have not specified the format name either (from which a path could be built), the path defaults to the local journal queue.

Message Queuing can send and receive messages from any public queue on the network. You can search for public queues across the network with a variety of criteria, such as Category or LastModifyTime, but you must specify a computer when searching for private queues.

The MachineName is integral to defining queue paths by common names. When working online, the domain controller's Active Directory associates the common name for the Path with the path's unique FormatName. The syntax for the Path property depends on the type of queue it references. The following table shows the syntax you should use for a queue of a specified type.

Queue Type | Syntax
Public Queue | MachineName\QueueName
Private Queue | MachineName\Private$\QueueName
Journal Queue | MachineName\QueueName\Journal$
Machine Journal Queue | MachineName\Journal$
Machine DeadLetter Queue | MachineName\Deadletter$
Machine Transactional Deadletter Queue | MachineName\XactDeadletter$

Use "." for the local computer when specifying the MachineName.

Because the domain controller is required for path translation, defining the Path in terms of the MachineName throws an exception when working off-line. FormatName is required in the Path syntax when working off-line.

Example [Visual Basic]

The following example passes in a queue and creates a queue with the name "myNewQueue" on the same computer. The computer is determined by the queue passed in. This example assumes that a queue named "myNewQueue" does not already exist on the specified computer.

Import the System.Messaging namespace for this example.

[Visual Basic]

Private Sub CreateQueueOnComputer(ByVal currentQueuePath As String)
    Dim computer As String
    'Define a new MessageQueue.
    Dim messageQueue1 As MessageQueue

    'Instantiate a MessageQueue using the currentQueuePath.
    messageQueue1 = New MessageQueue(currentQueuePath)
    'Get the name of the computer from the queue.
    computer = messageQueue1.MachineName

    'Create a new queue on the same computer.
    MessageQueue.Create(computer + "\myNewQueue")
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | QueueName | Path | FormatName | GetPrivateQueuesByMachine | GetPublicQueuesByMachine | GetPublicQueues


MessageQueue.MaximumJournalSize

Gets or sets the maximum size of the journal queue.

[Visual Basic]
Overridable Public Property MaximumJournalSize As Long
[C#]
public long MaximumJournalSize {virtual get; virtual set;}
[C++]
public: __property virtual __int64 get_MaximumJournalSize();
public: __property virtual void set_MaximumJournalSize(__int64);
[JScript]
public function get MaximumJournalSize() : long;
public function set MaximumJournalSize(long);

Property Value

The maximum size in kilobytes of the journal queue. The Message Queuing default is no limit.

Exceptions

Exception Type | Condition
ArgumentException | The maximum journal queue size was set to an invalid value.
MessageQueueException | The attempt to get or set the maximum journal queue size generated an internal error on the message queue component. The error is specified by the given status message.

Remarks

MaximumJournalSize provides access to the Message Queuing journal storage limit. It is only relevant when UseJournalQueue is set to true.

When you store messages in a journal or dead-letter queue, clear these queues periodically to remove messages that are no longer needed. Messages stored in journal and dead-letter queues count against the quota for the computer where the queues reside (the computer quota is set by the administrator).

Example [Visual Basic]

The following example demonstrates creating a new Message Queuing backend queue object and setting the MaximumJournalSize and MaximumQueueSize for the queue. A message is then sent to the queue to test the connection. This example assumes you have a Message Queuing server called myComputer and a queue called myNewQueue does not exist yet on the computer.

[Visual Basic]

Private Sub CreateNewQueue()
    'Define a MessageQueue.
    Dim mq As MessageQueue
    'Set the MessageQueue to point to a new queue.
    mq = MessageQueue.Create("myComputer\myNewQueue")

    'Use the journal queue for all received messages.
    mq.UseJournalQueue = True
    'Set the size in kilobytes of the journal queue.
    mq.MaximumJournalSize = 5
    'Set the size in kilobytes of the queue.
    mq.MaximumQueueSize = 10
    'Send a message to the new queue.
    mq.Send("Test")
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | UseJournalQueue | MaximumQueueSize


MessageQueue.MaximumQueueSize

Gets or sets the maximum size of the queue.

[Visual Basic]
Overridable Public Property MaximumQueueSize As Long
[C#]
public long MaximumQueueSize {virtual get; virtual set;}
[C++]
public: __property virtual __int64 get_MaximumQueueSize();
public: __property virtual void set_MaximumQueueSize(__int64);
[JScript]
public function get MaximumQueueSize() : long;
public function set MaximumQueueSize(long);

Property Value

The maximum size in kilobytes of the queue. The Message Queuing default is no limit.

Exceptions

Exception Type | Condition
ArgumentException | The maximum queue size was set to a negative value.
MessageQueueException | The attempt to get or set the maximum queue size generated an internal error on the message queue component. The error is specified by the given status message.

Remarks

MaximumQueueSize provides access to the Message Queuing message storage limit. This is separate from the Administrator-defined computer quota.

If a queue exceeds the maximum size set for the queue or the Administrator-defined computer quota, messages may be lost. When the quota of a queue is reached, Message Queuing returns a negative acknowledgment message to the administration queue of the sending application to indicate that the queue is full. Message Queuing continues to send negative acknowledgments until the cumulative size of messages in the queue drops below the quota

Example [Visual Basic]

The following example demonstrates creating a new Message Queuing backend queue object and setting the MaximumJournalSize and MaximumQueueSize for the queue. A message is then sent to the queue to test the connection. This example assumes you have a Message Queuing server called myComputer and a queue called myNewQueue does not exist yet on the computer.

[Visual Basic]

Private Sub CreateNewQueue()
    'Define a MessageQueue.
    Dim mq As MessageQueue
    'Set the MessageQueue to point to a new queue.
    mq = MessageQueue.Create("myComputer\myNewQueue")

    'Use the journal queue for all received messages.
    mq.UseJournalQueue = True
    'Set the size in kilobytes of the journal queue.
    mq.MaximumJournalSize = 5
    'Set the size in kilobytes of the queue.
    mq.MaximumQueueSize = 10
    'Send a message to the new queue.
    mq.Send("Test")
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MaximumJournalSize


MessageQueue.MessageReadPropertyFilter

Gets or sets the property filter for receiving messages.

[Visual Basic]
Overridable Public Property MessageReadPropertyFilter As _
   MessagePropertyFilter
[C#]
public MessagePropertyFilter MessageReadPropertyFilter {virtual
   get; virtual set;}
[C++]
public: __property virtual MessagePropertyFilter* get_MessageReadPropertyFilter();
public: __property virtual void set_MessageReadPropertyFilter(MessagePropertyFilter*);
[JScript]
public function get MessageReadPropertyFilter() : MessagePropertyFilter;
public function set MessageReadPropertyFilter(MessagePropertyFilter);

Property Value

The filter used by the queue to limit the set of properties it receives for each message.

Exceptions

Exception Type | Condition
ArgumentException | The filter was set to a null reference (Visual Basic Nothing).
MessageQueueException | The attempt to get or set the message property filter generated an internal error on the message queue component. The error is specified by the given status message.

Remarks

This filter is a set of boolean values that you can set in order to restrict the message properties that the queue receives. Any message property for which the corresponding MessageReadPropertyFilter value is false will not be included when the message is retrieved.

Example [Visual Basic]

The following example uses the MessageReadPropertyFilter to restrict the properties retrieved from a queue. The filtered list of properties for the first message is retrieved.

This example assumes that the Message Queuing server computer's name is "myComputer" and there is a public queue on the computer called "myQueue".

[Visual Basic]

Private Sub ReceiveFilteredMessage()
    'Define a new filter, message, and message queue.
    Dim filter As MessagePropertyFilter
    Dim msg As Message
    Dim mq As MessageQueue

    'Set the filter to retrieve only selected message properties.
    filter = New MessagePropertyFilter
    filter.ArrivedTime = True
    filter.Body = True
    filter.Label = True
    filter.Priority = True
    filter.SentTime = True
    filter.SourceMachine = True

    'Instantialize a new MessageQueue.
    mq = New MessageQueue("myComputer\myQueue")

    mq.MessageReadPropertyFilter = filter
    'Read the message
    msg = mq.Receive
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | Peek | Receive | BeginPeek | BeginReceive


MessageQueue.Path

Gets or sets the queue's location.

[Visual Basic]
Overridable Public Property Path As String
[C#]
public string Path {virtual get; virtual set;}
[C++]
public: __property virtual String* get_Path();
public: __property virtual void set_Path(String*);
[JScript]
public function get Path() : String;
public function set Path(String);

Property Value

The location of the queue that is referenced by the MessageQueue.

Exceptions

Exception Type | Condition
ArgumentException | The path was set to an invalid value. The syntax may be invalid.
MessageQueueException | The attempt to get or set the path generated an internal error on the message queue component. The error is specified by the given status message. The path syntax may not be valid.

Remarks

The syntax for the Path property depends on the type of queue it references. The following table shows the syntax you should use for a queue of a specified type:

Queue Type | Syntax
Public Queue | machineName\queueName
Private Queue | machineName\Private$\queueName
Journal Queue | machineName\queueName\Journal$
Machine Journal Queue | machineName\Journal$
Machine Deadletter Queue | machineName\Deadletter$
Machine Transactional Deadletter Queue | machineName\XactDeadletter$

Use "." for the local computer.

You can also use the FormatName or Label of a Message Queuing application object to describe the queue path. The following table shows the proper syntax for each type of reference.

Reference | Syntax
Format Name | FormatName:[format name]
Label | Label:[label]

If you will be using the queue to work offline, you must use the format name to define the queue Path. If you are working offline and use the syntax in the Queue Type table above instead of the format name, the application will throw an exception. This is caused when the primary domain controller is unavailable to resolve the Path into the FormatName.

If you hard-code the path into your application, deleting and then creating a queue with the same name will not be seen as the same queue, because the queue Id, which generates part of the FormatName, will have changed.

You can specify the queue's label in the syntax of its path. Use the format Label:[label] in the Path. Setting a new path closes the message queue and releases all handles.

Example [Visual Basic]

The following example sets the Path to a public MessageQueue based on the type of information passed in. Then a message is sent to the queue.

If the queue is defined by its FormatName or Label, the correct text is prepended to generate the Path. Otherwise, the Path is defined as MachineName\ QueueName, which is the standard format for a public queue. Because the local computer is assumed, the MachineName is ".".

This procedure assumes you have a public queue on the local computer named "myQueue". It assumes there is a queue with the label "My Queue". Then it assumes there is a queue with the specified format name.

[Visual Basic]

Private Sub SendMessageToPublicQueue()
    'Set the paths based on Label, QueueName and FormatName.
    SetPublicPath("Label", "My Queue")
    SetPublicPath("QueueName", "myQueue")
    'The format name will be non-zero.
    SetPublicPath("FormatName", "{00000000-0000-0000-0000-000000000000}")
End Sub

Private Sub SetPublicPath(ByVal pathType As String, ByVal queueStr As String)
    'Used to hold the Path.
    Dim queuePath As String
    'Define and instantiate a MessageQueue.
    Dim messageQueue1 As MessageQueue
    messageQueue1 = New MessageQueue

    'Build the Path based on the information passed in.
    Select Case pathType
        Case "FormatName"
queuePath = "FormatName:Public=" + queueStr
        Case "Label"
queuePath = "Label:" + queueStr
        Case "QueueName"
queuePath = ".\" + queueString
    End Select

    'Set the path and send a message.
    messageQueue1.Path = queuePath
    messageQueue1.Send("Sending message to myQueue.")
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MachineName | QueueName | FormatName | Label | MessageQueue | Create | Delete | Close


MessageQueue.QueueName

Gets or sets the friendly name that identifies the queue.

[Visual Basic]
Overridable Public Property QueueName As String
[C#]
public string QueueName {virtual get; virtual set;}
[C++]
public: __property virtual String* get_QueueName();
public: __property virtual void set_QueueName(String*);
[JScript]
public function get QueueName() : String;
public function set QueueName(String);

Property Value

The name that identifies the reference to the MessageQueue. The value cannot be a null reference (Visual Basic Nothing).

Exceptions

Exception Type | Condition
ArgumentException | The queue name is a null reference (Visual Basic Nothing).
MessageQueueException | The attempt to get or set the queue name generated an internal error on the message queue component. The error is specified by the given status message.

Remarks

You can use the QueueName together with the MachineName to set a friendly Path property for the queue. It is necessary to work on-line when doing so, since the domain controller contains the Active Directory which associates the friendly path with the FormatName which uniquely identifies the queue.

The syntax for the friendly name variation of the Path property depends on the type of queue it references. The following table shows the QueueName syntax you should use for a queue of a specified type:

Queue Type | Syntax
Public Queue | machineName\queueName
Private Queue | machineName\Private$\queueName
Journal Queue | machineName\queueName\Journal$

Use "." for the local computer.

If the Path has not been set when you set the queue name, the QueueName property points to a location on the local computer.

Example [Visual Basic]

The following example builds a queue path by appending the QueueName to the MachineName for the local computer.

This procedure examines a queue on a remote computer, and creates a queue with the same name on the local computer.

[Visual Basic]

Private Sub CreateQueueByQueueName(ByVal remotePath As String)
    'Define new MessageQueue objects.
    Dim remoteMessageQueue As MessageQueue
    Dim localMessageQueue As MessageQueue

    'Associate the MessageQueue with the given path.
    remoteMessageQueue = New MessageQueue(remotePath)

    'If no queue with the given name exists on the local computer, create one.
    If Not MessageQueue.Exists(".\" + remoteMessageQueue.QueueName) Then
        localMessageQueue = MessageQueue.Create(".\" + remoteMessageQueue.QueueName)
    End If
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | Path | MachineName


MessageQueue.ReadHandle

The native handle used to receive messages from the message queue

[Visual Basic]
Overridable Public ReadOnly Property ReadHandle As Integer
[C#]
public int ReadHandle {virtual get;}
[C++]
public: __property virtual int get_ReadHandle();
[JScript]
public function get ReadHandle() : int;

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue.SynchronizingObject

Represents the object used to marshal the event handler calls issued as a result of a BeginReceive or BeginPeek request into a specific thread. Normally this property will be set when the component is placed inside a control or a from, since those components are bound to a specific thread.

[Visual Basic]
Public Property SynchronizingObject As ISynchronizeInvoke
[C#]
public ISynchronizeInvoke SynchronizingObject {get; set;}
[C++]
public: __property ISynchronizeInvoke* get_SynchronizingObject();
public: __property void set_SynchronizingObject(ISynchronizeInvoke*);
[JScript]
public function get SynchronizingObject() : ISynchronizeInvoke;
public function set SynchronizingObject(ISynchronizeInvoke);

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue.Transactional

Gets a value indicating whether the queue supports transactions.

[Visual Basic]
Overridable Public ReadOnly Property Transactional As Boolean
[C#]
public bool Transactional {virtual get;}
[C++]
public: __property virtual bool get_Transactional();
[JScript]
public function get Transactional() : Boolean;

Property Value

true if the queue can only accept messages that are sent as part of a transaction; otherwise, false.

Exceptions

Exception Type | Condition
MessageQueueException | The attempt to get the Transactional setting generated an internal error on the message queue component. The error is specified by the given status message.

Remarks

Transactional messaging implies the coupling of several related messages into a single transaction, ensuring that the messages are delivered in order, delivered only once, and are successfully retrieved from their destination queue.

If a queue is transactional, it can only accept messages that are sent as part of a transaction. However, messages can be retrieved from a local transaction queue without using a transaction. If a non-transactional message comes to a transactional queue, a transactional context is created for the message.

Example [Visual Basic]

The following is pseudocode.

The following example checks to see if a Message Queuing transactional backend resource exists. If is does, and supports transactions, it connects to the queue. Otherwise, it creates a new transactional backend resource with the path passed in, for example "myComputer\myQueue". It then creates a transaction, which sends messages to the billing and shipping queues.

If the process fails, the transaction is rolled back. Otherwise, it is committed. In the case of success, a message is sent to the new transactional queue and a message box provides notification of the event. This subroutine assumes that the queue path that you will create or use has been specified and passed in as the transQueuePath.

[Visual Basic]

Private Sub CreateNewTransactionalQueue(ByVal transQueuePath As String, ByVal order As Variant)
    'Create a new MessageQueue object
    Dim mq As System.Messaging.MessageQueue.MessageQueue
    Dim billingQueue As System.Messaging.MessageQueue.MessageQueue
    Dim shippingQueue As System.Messaging.MessageQueue.MessageQueue
    'Set the paths for the billing and shipping queues to existing queues
    'note that we are not creating new backend resources, just connections
    Set billingQueue = New System.messaging.MessageQueue.MessageQueue("myComputer\billing")
    Set shippingQueue = New System.messaging.MessageQueue.MessageQueue("myComputer\shipping")
    'If a queue at the specified path does not exist, create one
    If Not MessageQueue.Exists(transQueuePath) Then
        Set mq = MessageQueue.Create(transQueuePath, True)
    Else
        'Else, point to the existing queue
        Set mq = New MessageQueue(transQueuePath)
        'verify that the queue backend resource supports transactions
        If Not mq.Transactional Then
'The queue exists but is not transactional.
'Send notification and return.
MessageBox.Show "Queue " & transQueuePath & " already exists."
Return
        End If
    End If
    Try
        'begin a transaction
        mq.BeginTransaction
        'send order information to the billing and shipping queues
        billingQueue.Send order
        shippingQueue.Send order
        'commit the transaction (messages have been successfully sent
        'to shipping and billing)
        mq.CommitTransaction
        'Send a message to the transactional queue
        mq.Send "Test message sent to queue."
        'Send notification that a message has been sent to the queue.
        messagebox.Show "Message sent to " & mq.QueueName & "."
    Catch
        'there has been an error. Rollback the transaction
        mq.RollbackTransaction
        'Send notification that the transaction was rolled back
        messagebox.Show "Transaction rolled back."
    End Try
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | BeginTransaction | CommitTransaction | RollbackTransaction


MessageQueue.UseJournalQueue

Gets or sets a value indicating whether retrieved messages are copied to the journal queue.

[Visual Basic]
Overridable Public Property UseJournalQueue As Boolean
[C#]
public bool UseJournalQueue {virtual get; virtual set;}
[C++]
public: __property virtual bool get_UseJournalQueue();
public: __property virtual void set_UseJournalQueue(bool);
[JScript]
public function get UseJournalQueue() : Boolean;
public function set UseJournalQueue(Boolean);

Property Value

true if messages retrieved from the queue are copied to its journal queue; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentException | The UseJournalQueue property could not be set by the application.
MessageQueueException | The attempt to get or set the UseJournalQueue setting generated an internal error on the message queue component. The error is specified by the given status message.

Remarks

Journals are automatically created by the Message Queuing application whenever an application queue is created. Message Queuing creates the queue journal where the new queue is located. The queue journal is used to track the messages removed from a queue.

Note This does not include message removed from the queue when their time-to-be-received timer expires, or messages purged from the queue using the Message Queuing directory service (Information Store or Active Directory).

Applications cannot send messages to queue journals. Applications are limited to read-only access to these queues. In addition, Message Queuing never removes messages from a journal. It is up to the application using the queue to clear the messages of a journal queue by retrieving them or by purging the queue.

Example

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MaximumJournalSize


MessageQueue.WriteHandle

The native handle used to send messages to the message queue

[Visual Basic]
Overridable Public ReadOnly Property WriteHandle As Integer
[C#]
public int WriteHandle {virtual get;}
[C++]
public: __property virtual int get_WriteHandle();
[JScript]
public function get WriteHandle() : int;

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MessageQueue Methods

The methods of the MessageQueue class are listed below. For a complete list of MessageQueue class members, see the MessageQueue Members topic.

Public:

BeginPeek | Overloaded. Returns the first message in the queue without removing it from the queue.
BeginReceive | Overloaded. Receives the first message available in the queue.
BeginTransaction | Creates a new Message Queuing internal transaction context.
Close | Frees all resources allocated by the queue.
CommitTransaction | Commits a pending internal transaction.
Create | Overloaded. Creates a new backend queue resource with the specified path.
Delete | Deletes a queue backend resource identified by the given path.
Dispose (inherited from Component) | Disposes of the Component.
EndPeek | Terminates a peek asynchronous operation identified by the specified interface.
EndReceive | Terminates a receive asynchronous operation identified by the specified interface.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Exists | Determines whether a queue with the specified path exists.
GetAllMessages | Returns all the messages available in the queue.
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetMachineId | [To be supplied.]
GetMessageQueuesEnumerator | Overloaded. [To be supplied.]
GetMessagesEnumerator | Creates an enumerator object for the messages contained in the MessageQueue.
GetPrivateQueuesByMachine | Retrieves all the private queues on the specified computer.
GetPublicQueues | Overloaded. Retrieves public queues on the network.
GetPublicQueuesByCategory | Retrieves a set of public queues filtered by the specified category.
GetPublicQueuesByLabel | Retrieves a set of public queues filtered by the specified label.
GetPublicQueuesByMachine | Retrieves all public queues on the specified computer.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Peek | Overloaded. Returns the first message in the queue without removing it from the queue.
PeekByCorrelationId | Overloaded. [To be supplied.]
PeekById | Overloaded. [To be supplied.]
Purge | Deletes all the messages contained in the queue.
Receive | Overloaded. Receives the first message in the queue.
ReceiveByCorrelationId | Overloaded. [To be supplied.]
ReceiveById | Overloaded. [To be supplied.]
Refresh | Refreshes the properties presented by the MessageQueue to reflect the current state of the resource.
RollbackTransaction | Rolls back the pending internal transaction.
Send | Overloaded. [To be supplied.]
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.

Protected:

Finalize (inherited from Component) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Event Hookup:

AddOnPeekCompleted | Adds an event handler for the TBD event.
AddOnReceiveCompleted | Adds an event handler for the TBD event.
RemoveOnPeekCompleted | Removes an event handler from the PeekCompleted event.
RemoveOnReceiveCompleted | Removes an event handler from the ReceiveCompleted event.

See Also

MessageQueue Class | System.Messaging Namespace


MessageQueue.AddOnPeekCompleted

Adds an event handler for the TBD event.

[Visual Basic]
Overridable Public Sub AddOnPeekCompleted( _
   ByVal handler As PeekCompletedEventHandler _
)
[C#]
public virtual void AddOnPeekCompleted(
   PeekCompletedEventHandler handler
);
[C++]
public: virtual void AddOnPeekCompleted(
   PeekCompletedEventHandler* handler
);
[JScript]
public function AddOnPeekCompleted(
   handler : PeekCompletedEventHandler
);

Parameters

handler
A PeekCompletedEventHandler delegate that represents the method that will handle the TBD event.

Exceptions

Exception Type | Condition
ArgumentNullException | Theparameter is a null reference (Visual Basic Nothing). Themight not have been initialized.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | BeginPeek | EndPeek


MessageQueue.AddOnReceiveCompleted

Adds an event handler for the TBD event.

[Visual Basic]
Overridable Public Sub AddOnReceiveCompleted( _
   ByVal handler As ReceiveCompletedEventHandler _
)
[C#]
public virtual void AddOnReceiveCompleted(
   ReceiveCompletedEventHandler handler
);
[C++]
public: virtual void AddOnReceiveCompleted(
   ReceiveCompletedEventHandler* handler
);
[JScript]
public function AddOnReceiveCompleted(
   handler : ReceiveCompletedEventHandler
);

Parameters

handler
A ReceiveCompletedEventHandler delegate that represents the method that will handle the TBD event.

Exceptions

Exception Type | Condition
ArgumentNullException | Theparameter is a null reference (Visual Basic Nothing). Themight not have been initialized.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue.BeginPeek

Returns the first message in the queue without removing it from the queue.

Overload List

Returns without removing (peeks) the first message available in the queue referenced by the MessageQueue. Waits the specified interval for a new message to become available and uses the specified object to retrieve the result.

[Visual Basic] Overloads Public Function BeginPeek(TimeSpan, Object) As IAsyncResult
[C#] public IAsyncResult BeginPeek(TimeSpan, Object);
[C++] public: IAsyncResult* BeginPeek(TimeSpan, Object);
[JScript] public function BeginPeek(TimeSpan, Object) : IAsyncResult;

Returns without removing (peeks) the first message available in the queue referenced by the MessageQueue. Waits the specified interval for a new message to become available, uses the specified object to retrieve the result, and receives notification through a callback.

[Visual Basic] Overloads Public Function BeginPeek(TimeSpan, Object, AsyncCallback) As IAsyncResult
[C#] public IAsyncResult BeginPeek(TimeSpan, Object, AsyncCallback);
[C++] public: IAsyncResult* BeginPeek(TimeSpan, Object, AsyncCallback);
[JScript] public function BeginPeek(TimeSpan, Object, AsyncCallback) : IAsyncResult;

Returns without removing (peeks) the first message available in the queue referenced by the MessageQueue.

[Visual Basic] Overloads Public Function BeginPeek() As IAsyncResult
[C#] public IAsyncResult BeginPeek();
[C++] public: IAsyncResult* BeginPeek();
[JScript] public function BeginPeek() : IAsyncResult;

Returns without removing (peeks) the first message available in the queue referenced by the MessageQueue. Waits the specified interval for a message to become available.

[Visual Basic] Overloads Public Function BeginPeek(TimeSpan) As IAsyncResult
[C#] public IAsyncResult BeginPeek(TimeSpan);
[C++] public: IAsyncResult* BeginPeek(TimeSpan);
[JScript] public function BeginPeek(TimeSpan) : IAsyncResult;

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue.BeginPeek (TimeSpan, Object)

Returns without removing (peeks) the first message available in the queue referenced by the MessageQueue. Waits the specified interval for a new message to become available and uses the specified object to retrieve the result.

[Visual Basic]
Overloads Public Function BeginPeek( _
   ByVal timeout As TimeSpan, _
   ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginPeek(
   TimeSpan timeout,
   object stateObject
);
[C++]
public: IAsyncResult* BeginPeek(
   TimeSpan timeout,
   Object* stateObject
);
[JScript]
public function BeginPeek(
   timeout : TimeSpan,
   stateObject : Object
) : IAsyncResult;

Parameters

timeout
The interval of time, in milliseconds, to wait for a message to become available.
stateObject
A state object to be marshaled to the thread from which the asynchronous operation result is to be retrieved.

Return Value

The IAsyncResult that identifies the asynchronous request posted.

Exceptions

Exception Type | Condition
ArgumentException | The value specified for the timeout parameter is invalid. It may represent a negative number.

Remarks

The state object is used to handle passing information across threads. In an asynchronous scenario, if a thread is started but the callback is on a different thread, the state object is marshaled and passed back along with information from the event.

BeginPeek is used in asynchronous processing to notify the AsyncCallback delegate when a message is available or the specified timeout has expired.

Because BeginPeek is asynchronous, you can use this method to peek the queue without blocking the current thread of execution. To peek the queue synchronously, use the Peek method.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue.BeginPeek Overload List | EndPeek | BeginReceive | Peek | Receive


MessageQueue.BeginPeek (TimeSpan, Object, AsyncCallback)

Returns without removing (peeks) the first message available in the queue referenced by the MessageQueue. Waits the specified interval for a new message to become available, uses the specified object to retrieve the result, and receives notification through a callback.

[Visual Basic]
Overloads Public Function BeginPeek( _
   ByVal timeout As TimeSpan, _
   ByVal stateObject As Object, _
   ByVal callback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginPeek(
   TimeSpan timeout,
   object stateObject,
   AsyncCallback callback
);
[C++]
public: IAsyncResult* BeginPeek(
   TimeSpan timeout,
   Object* stateObject,
   AsyncCallback* callback
);
[JScript]
public function BeginPeek(
   timeout : TimeSpan,
   stateObject : Object,
   callback : AsyncCallback
) : IAsyncResult;

Parameters

timeout
The interval of time, in milliseconds, to wait for a message to become available.
stateObject
A state object to be marshaled to the thread from which the asynchronous operation result is to be retrieved.
callback
The AsyncCallback that will receive the asynchronous operation completion notification.

Return Value

The IAsyncResult that identifies the asynchronous request posted.

Exceptions

Exception Type | Condition
ArgumentException | The value specified for the timeout parameter is invalid. It may represent a negative number.

Remarks

The state object is used to handle passing information across threads. In an asynchronous scenario, if a thread is started but the callback is on a different thread, the state object is marshaled and passed back along with information from the event. When an asynchronous operation is complete, the delegate you define is called. For example, if you are sending a message to different delegates, you can use this overload of the BeginPeek method.

BeginPeek is used in asynchronous processing to notify the callback when a message is available or the specified timeout has expired.

Because BeginPeek is asynchronous, you can use this method to peek the queue without blocking the current thread of execution. To peek the queue synchronously, use the Peek method.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue.BeginPeek Overload List | EndPeek | BeginReceive | Peek | Receive


MessageQueue.BeginPeek ()

Returns without removing (peeks) the first message available in the queue referenced by the MessageQueue.

[Visual Basic]
Overloads Public Function BeginPeek() As IAsyncResult
[C#]
public IAsyncResult BeginPeek();
[C++]
public: IAsyncResult* BeginPeek();
[JScript]
public function BeginPeek() : IAsyncResult;

Return Value

The IAsyncResult that identifies the asynchronous request posted.

Remarks

BeginPeek is used in asynchronous processing to raise the System.Messaging.MessageQueue.MessageQueue.PeekCompleted event when a message is available. This overload does not specify a timeout, so System.Messaging.MessageQueue.PeekCompleted will only be raised when a message is received.

Because BeginPeek is asynchronous, you can use this method to peek the queue without blocking the current thread of execution. To peek the queue synchronously, use the Peek method.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue.BeginPeek Overload List | EndPeek | BeginReceive | Peek | Receive


MessageQueue.BeginPeek (TimeSpan)

Returns without removing (peeks) the first message available in the queue referenced by the MessageQueue. Waits the specified interval for a message to become available.

[Visual Basic]
Overloads Public Function BeginPeek( _
   ByVal timeout As TimeSpan _
) As IAsyncResult
[C#]
public IAsyncResult BeginPeek(
   TimeSpan timeout
);
[C++]
public: IAsyncResult* BeginPeek(
   TimeSpan timeout
);
[JScript]
public function BeginPeek(
   timeout : TimeSpan
) : IAsyncResult;

Parameters

timeout
The interval of time, in milliseconds, to wait for a message to become available.

Return Value

The IAsyncResult that identifies the asynchronous request posted.

Exceptions

Exception Type | Condition
ArgumentException | The value specified for the timeout parameter is invalid. It may represent a negative number.

Remarks

BeginPeek is used in asynchronous processing to raise the System.Messaging.MessageQueue.MessageQueue.PeekCompleted event when a message is available or the specified timeout has expired.

Because BeginPeek is asynchronous, you can use this method to peek the queue without blocking the current thread of execution. To peek the queue synchronously, use the Peek method.

Set the timeout to zero to determine whether there is a message in the queue without peeking the message.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue.BeginPeek Overload List | EndPeek | BeginReceive | Peek | Receive


MessageQueue.BeginReceive

Receives the first message available in the queue.

Overload List

Receives the first message available in the queue referenced by the MessageQueue. Waits the specified interval for a new message to be removed, uses the specified object to retrieve the result, and receives notification through a callback.

[Visual Basic] Overloads Public Function BeginReceive(TimeSpan, Object, AsyncCallback) As IAsyncResult
[C#] public IAsyncResult BeginReceive(TimeSpan, Object, AsyncCallback);
[C++] public: IAsyncResult* BeginReceive(TimeSpan, Object, AsyncCallback);
[JScript] public function BeginReceive(TimeSpan, Object, AsyncCallback) : IAsyncResult;

Receives the first message available in the queue referenced by the MessageQueue. Waits the specified interval for a new message to be removed and uses the specified object to retrieve the result.

[Visual Basic] Overloads Public Function BeginReceive(TimeSpan, Object) As IAsyncResult
[C#] public IAsyncResult BeginReceive(TimeSpan, Object);
[C++] public: IAsyncResult* BeginReceive(TimeSpan, Object);
[JScript] public function BeginReceive(TimeSpan, Object) : IAsyncResult;

Receives the first message available in the queue referenced by the MessageQueue. Waits the specified interval for the message to be removed.

[Visual Basic] Overloads Public Function BeginReceive(TimeSpan) As IAsyncResult
[C#] public IAsyncResult BeginReceive(TimeSpan);
[C++] public: IAsyncResult* BeginReceive(TimeSpan);
[JScript] public function BeginReceive(TimeSpan) : IAsyncResult;

Receives the first message available in the queue referenced by the MessageQueue.

[Visual Basic] Overloads Public Function BeginReceive() As IAsyncResult
[C#] public IAsyncResult BeginReceive();
[C++] public: IAsyncResult* BeginReceive();
[JScript] public function BeginReceive() : IAsyncResult;

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue.BeginReceive (TimeSpan, Object, AsyncCallback)

Receives the first message available in the queue referenced by the MessageQueue. Waits the specified interval for a new message to be removed, uses the specified object to retrieve the result, and receives notification through a callback.

[Visual Basic]
Overloads Public Function BeginReceive( _
   ByVal timeout As TimeSpan, _
   ByVal stateObject As Object, _
   ByVal callback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginReceive(
   TimeSpan timeout,
   object stateObject,
   AsyncCallback callback
);
[C++]
public: IAsyncResult* BeginReceive(
   TimeSpan timeout,
   Object* stateObject,
   AsyncCallback* callback
);
[JScript]
public function BeginReceive(
   timeout : TimeSpan,
   stateObject : Object,
   callback : AsyncCallback
) : IAsyncResult;

Parameters

timeout
The interval of time, in milliseconds, to wait for a message to be removed.
stateObject
A state object to be marshaled to the thread where the asynchronous operation result is to be retrieved.
callback
The AsyncCallback that will receive the asynchronous operation completion notification.

Return Value

The IAsyncResult that identifies the asynchronous request posted.

Exceptions

Exception Type | Condition
ArgumentException | The value specified for the timeout parameter is invalid. It may represent a negative number.

Remarks

The state object is used to handle passing information across threads. In an asynchronous scenario, if a thread is started but the callback is on a different thread, the state object is marshaled and passed back along with information from the event. When an asynchronous operation is complete, the delegate you define is called. For example, if you are sending a message to different delegates, you can use this override of the BeginReceive method.

BeginReceive notifies the AsyncCallback delegate when the message has been removed or the timeout has expired. The call to BeginReceive does not block the current thread of execution.

BeginReceive is used in asynchronous processing to notify the AsyncCallback delegate when a message is removed from the queue or the timeout has expired.

Because BeginReceive is asynchronous, you can use this method to peek the queue without blocking the current thread of execution. To peek the queue synchronously, use the Receive method.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue.BeginReceive Overload List | EndReceive | BeginPeek | Receive | Peek


MessageQueue.BeginReceive (TimeSpan, Object)

Receives the first message available in the queue referenced by the MessageQueue. Waits the specified interval for a new message to be removed and uses the specified object to retrieve the result.

[Visual Basic]
Overloads Public Function BeginReceive( _
   ByVal timeout As TimeSpan, _
   ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginReceive(
   TimeSpan timeout,
   object stateObject
);
[C++]
public: IAsyncResult* BeginReceive(
   TimeSpan timeout,
   Object* stateObject
);
[JScript]
public function BeginReceive(
   timeout : TimeSpan,
   stateObject : Object
) : IAsyncResult;

Parameters

timeout
The interval of time, in milliseconds, to wait for a message to be removed.
stateObject
A state object to be marshaled to the thread where the asynchronous operation result is to be retrieved.

Return Value

The IAsyncResult that identifies the asynchronous request posted.

Exceptions

Exception Type | Condition
ArgumentException | The value specfied for the timeout parameter is invalid. It may represent a negative number.

Remarks

The state object is used to handle passing information across threads. In an asynchronous scenario, if a thread is started but the callback is on a different thread, the state object is marshaled and passed back along with information from the event.

BeginReceive is used in asynchronous processing to raise the System.Messaging.MessageQueue.MessageQueue.ReceiveCompleted event when a message is removed from the queue or the timeout has expired.

Because BeginReceive is asynchronous, you can use this method to peek the queue without blocking the current thread of execution. To peek the queue synchronously, use the Receive method.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue.BeginReceive Overload List | EndReceive | BeginPeek | Receive | Peek


MessageQueue.BeginReceive (TimeSpan)

Receives the first message available in the queue referenced by the MessageQueue. Waits the specified interval for the message to be removed.

[Visual Basic]
Overloads Public Function BeginReceive( _
   ByVal timeout As TimeSpan _
) As IAsyncResult
[C#]
public IAsyncResult BeginReceive(
   TimeSpan timeout
);
[C++]
public: IAsyncResult* BeginReceive(
   TimeSpan timeout
);
[JScript]
public function BeginReceive(
   timeout : TimeSpan
) : IAsyncResult;

Parameters

timeout
The interval of time, in milliseconds, to wait for a message to be removed.

Return Value

The IAsyncResult that identifies the asynchronous request posted.

Exceptions

Exception Type | Condition
ArgumentException | The value specified for the timeout parameter is invalid. It may represent a negative number.

Remarks

BeginReceive is used in asynchronous processing to raise the System.Messaging.MessageQueue.MessageQueue.ReceiveCompleted event when a message is removed from the queue or the timeout has expired.

Because BeginReceive is asynchronous, you can use this method to peek the queue without blocking the current thread of execution. To peek the queue synchronously, use the Receive method.

Set the timeout to zero to determine whether there is a message in the queue without receiving the message.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue.BeginReceive Overload List | EndReceive | BeginPeek | Receive | Peek


MessageQueue.BeginReceive ()

Receives the first message available in the queue referenced by the MessageQueue.

[Visual Basic]
Overloads Public Function BeginReceive() As IAsyncResult
[C#]
public IAsyncResult BeginReceive();
[C++]
public: IAsyncResult* BeginReceive();
[JScript]
public function BeginReceive() : IAsyncResult;

Return Value

The IAsyncResult that identifies the asynchronous request posted.

Remarks

BeginReceive is used in asynchronous processing to raise the System.Messaging.MessageQueue.MessageQueue.ReceiveCompleted event when a message is removed from the queue. This overload does not specify a timeout, so System.Messaging.MessageQueue.ReceiveCompleted will only be raised when a message has been removed.

Because BeginReceive is asynchronous, you can use this method to peek the queue without blocking the current thread of execution. To peek the queue synchronously, use the Receive method.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue.BeginReceive Overload List | EndReceive | BeginPeek | Receive | Peek


MessageQueue.BeginTransaction

Creates a new Message Queuing internal transaction context.

[Visual Basic]
Public Sub BeginTransaction()
[C#]
public void BeginTransaction();
[C++]
public: void BeginTransaction();
[JScript]
public function BeginTransaction();

Exceptions

Exception Type | Condition
InvalidOperationException | The transaction has already been started.
MessageQueueException | The attempt to get information about the queue generated an exception specified by the given status.

Remarks

BeginTransaction marks the start of processing that will be committed or rolled back, depending on the success of the transaction. If an exception occurs during processing, the entire transaction will be rolled back. This includes messages sent after the call to BeginTransaction. Messages that are part of a transaction must be sent to transactional queues.

You should make a call to BeginTransaction within a Try...Catch block. The call to CommitTransaction should be within the Try clause. Insert the call to RollbackTransaction into the Catch clause.

Example

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | CommitTransaction | RollbackTransaction | Transactional


MessageQueue.Close

Frees all resources allocated by the queue.

[Visual Basic]
Overridable Public Sub Close()
[C#]
public virtual void Close();
[C++]
public: virtual void Close();
[JScript]
public function Close();

Remarks

Call Close on all queues before deleting the backend resource. Otherwise, messages sent to the queue could throw exceptions or appear in the Deadletter queue.

Example [Visual Basic]

The following example closes and deletes a Message Queuing backend resource. It assumes that a queue path has been passed in from the calling application, and that the path refers to a queue on the local computer.

As recommended, the queue is closed before there is an attempt to delete it. This ensures that further messages will not be sent to it before the backend resource is removed from Message Queuing.

This procedure assumes you can delete queues from the local machine.

[Visual Basic]

Private Sub TerminateQueue(ByVal queuePath As String)
    'Define and instantiate a new MessageQueue.
    Dim MessageQueue1 As MessageQueue
    MessageQueue1 = New MessageQueue(queuePath)

    'Close the message queue so it stops receiving messages.
    MessageQueue1.Close()
    'Delete the queue. This is a static method.
    MessageQueue.Delete(queuePath)
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | Delete


MessageQueue.CommitTransaction

Commits a pending internal transaction.

[Visual Basic]
Public Sub CommitTransaction()
[C#]
public void CommitTransaction();
[C++]
public: void CommitTransaction();
[JScript]
public function CommitTransaction();

Exceptions

Exception Type | Condition
MessageQueueException | The transaction you are trying to commit has not started.
MessageQueueException | The attempt to retrieve queue information to commit the transaction generated an exception specified by the given status message.

Remarks

CommitTransaction marks the successful completion of processing begun at a call to BeginTransaction. If an exception occurs between the call to BeginTransaction and the call to CommitTransaction, the entire transaction is rolled back. This includes messages sent after the call to BeginTransaction. Messages that are part of a transaction must be sent to transactional queues.

Make the call to BeginTransaction within a Try...Catch block, the call to CommitTransaction in the Try clause, and the call to RollbackTransaction in the Catch clause.

Example

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | BeginTransaction | RollbackTransaction | Transactional


MessageQueue.Create

Creates a new backend queue resource with the specified path.

Overload List

Creates a nontransactional Message Queuing backend queue resource with the specified path.

[Visual Basic] Overloads Public Shared Function Create(String) As MessageQueue
[C#] public static MessageQueue Create(String);
[C++] public: static MessageQueue* Create(String*);
[JScript] public static function Create(String) : MessageQueue;

Creates a transactional or nontransactional Message Queuing backend queue resource with the specified path.

[Visual Basic] Overloads Public Shared Function Create(String, Boolean) As MessageQueue
[C#] public static MessageQueue Create(String, bool);
[C++] public: static MessageQueue* Create(String*, bool);
[JScript] public static function Create(String, Boolean) : MessageQueue;

Example [Visual Basic]

The following example verifies whether a queue named "myNewQueue" exists on the local computer. If it doesn't, one is created and set to be transactional. If a queue named "myNewQueue" already exists, it is examined to see if it is transactional.

If the queue is transactional or was created by the procedure (and hence is transactional), a message is sent to the queue.

Note This example shows how to use one of the overloaded versions of Create. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub CreateTransactionalQueue(ByVal msg As Message)
    'Define a new MessageQueue.
    Dim messageQueue1 As MessageQueue

    If Not MessageQueue.Exists(".\myNewQueue") Then
        'Create a new transactional queue on the local computer.
        messageQueue1 = MessageQueue.Create(".\myNewQueue", True)
    Else
        'The queue exists already. Verify that it is transactional.
        messageQueue1 = New MessageQueue(".\myNewQueue")
        If Not messageQueue1.Transactional Then
Exit Sub
        End If
    End If

    'Send a message to the queue.
    messageQueue1.Send(msg)
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue.Create (String)

Creates a nontransactional Message Queuing backend queue resource with the specified path.

[Visual Basic]
Overloads Public Shared Function Create( _
   ByVal path As String _
) As MessageQueue
[C#]
public static MessageQueue Create(
   string path
);
[C++]
public: static MessageQueue* Create(
   String* path
);
[JScript]
public static function Create(
   path : String
) : MessageQueue;

Parameters

path
The path of the queue to be created, using "." for the local computer. For information on proper syntax for this parameter, see the Remarks section.

Return Value

A MessageQueue that represents the new queue.

Exceptions

Exception Type | Condition
ArgumentException | The path parameter is a null reference (in Visual Basic Nothing) or an empty string.
MessageQueueException | The path parameter is not unique.
MessageQueueException | The attempt to access the queue's Formatter property while creating a new queue generated an exception specified by the given status message.

Remarks

Use this overload to create nontransactional backend queue resource.

To instantiate a new MessageQueue within your application, use the constructor. Call Create to create a new resource in Message Queuing.

If you declare a MessageQueue, it is not necessary to instantiate it through a call to the constructor in addition to the call to Create. Create instantiates a MessageQueue automatically.

The syntax for the path parameter depends on the type of queue it references. The following table shows the syntax you should use for a queue of a specified type.

Queue Type | Syntax
Public Queue | MachineName\QueueName
Private Queue | MachineName\Private$\QueueName

Use "." for the local computer.

Example [Visual Basic]

The following example examines a queue passed in, and creates a queue named "myNewQueue" on the same computer. It then sends a message to the queue.

[Visual Basic]

Private Sub CreateQueueOnComputer(ByVal currentQueuePath As String)
    'Define a new MessageQueue.
    Dim messageQueue1 As MessageQueue
    Dim newQueue As MessageQueue

    'Instantiate a MessageQueue using the currentQueuePath.
    messageQueue1 = New MessageQueue(currentQueuePath)

    'Create a new queue on the same computer.
    newQueue = MessageQueue.Create(messageQueue1.MachineName + "\myNewQueue")
    newQueue.Send("Test Message")
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue.Create Overload List | Path | MessageQueue | Delete | Refresh


MessageQueue.Create (String, Boolean)

Creates a transactional or nontransactional Message Queuing backend queue resource with the specified path.

[Visual Basic]
Overloads Public Shared Function Create( _
   ByVal path As String, _
   ByVal transactional As Boolean _
) As MessageQueue
[C#]
public static MessageQueue Create(
   string path,
   bool transactional
);
[C++]
public: static MessageQueue* Create(
   String* path,
   bool transactional
);
[JScript]
public static function Create(
   path : String,
   transactional : Boolean
) : MessageQueue;

Parameters

path
The path of the queue to be created, using "." for the local computer. For information on proper syntax for this parameter, see the Remarks section .
transactional
true to create a transactional queue; false to create a nontransactional queue.

Return Value

A MessageQueue that represents the new queue.

Exceptions

Exception Type | Condition
ArgumentException | The path parameter is a null reference (in Visual Basic Nothing) or an empty string.
MessageQueueException | The path parameter is not unique.
MessageQueueException | The attempt to access the queue's Formatter property while creating a new queue generated an exception specified by the given status message.

Remarks

Use this overload to create a transactional backend queue resource. You can create a nontransactional resource by setting the transactional parameter to false.

To instantiate a new MessageQueue within your application, use the constructor. Call Create to create a new resource in Message Queuing.

If you declare a MessageQueue, it is not necessary to instantiate it through a call to the constructor in addition to the call to Create. Create instantiates a MessageQueue automatically.

The syntax for the path parameter depends on the type of queue it references. The following table shows the syntax you should use for a queue of a specified type.

Queue Type | Syntax
Public Queue | MachineName\QueueName
Private Queue | MachineName\Private$\QueueName

Example [Visual Basic]

The following example verifies whether a queue named "myNewQueue" exists on the local computer. If it doesn't, one is created and set to be transactional. If a queue named "myNewQueue" already exists, it is examined to see if it is transactional.

If the queue is transactional or was created by the procedure (and hence is transactional), a message is sent to the queue.

[Visual Basic]

Private Sub CreateTransactionalQueue(ByVal msg As Message)
    'Define a new MessageQueue.
    Dim messageQueue1 As MessageQueue

    If Not MessageQueue.Exists(".\myNewQueue") Then
        'Create a new transactional queue on the local computer.
        messageQueue1 = MessageQueue.Create(".\myNewQueue", True)
    Else
        'The queue exists already. Verify that it is transactional.
        messageQueue1 = New MessageQueue(".\myNewQueue")
        If Not messageQueue1.Transactional Then
Exit Sub
        End If
    End If

    'Send a message to the queue.
    messageQueue1.Send(msg)
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue.Create Overload List | Path | MessageQueue | Delete | Refresh | MessageQueue | Transactional


MessageQueue.Delete

Deletes a queue backend resource identified by the given path.

[Visual Basic]
Public Shared Sub Delete( _
   ByVal path As String _
)
[C#]
public static void Delete(
   string path
);
[C++]
public: static void Delete(
   String* path
);
[JScript]
public static function Delete(
   path : String
);

Parameters

path
The location of the queue to be deleted, using "." for the local computer. For information on proper syntax for this parameter, see the Remarks section.

Exceptions

Exception Type | Condition
ArgumentException | The path parameter is a null reference (in Visual Basic Nothing) or an empty string.
MessageQueueException | The syntax for the path parameter is invalid.
MessageQueueException | The attempt to access the queue's Formatter property while deleting the queue generated an exception specified by the given status message.

Remarks

You should close the queue before deleting it. If you send messages to a deleted queue, they will either throw exceptions or be sent to the Deadletter queue.

The syntax for the path parameter depends on the type of queue it references. The following table shows the syntax you should use for a queue of a specified type.

Queue Type | Syntax
Public Queue | MachineName\QueueName
Private Queue | MachineName\Private$\QueueName

You can also use the FormatName or Label of a Message Queuing object to describe the queue path. The following table shows the proper syntax for each type of reference.

Reference | Syntax
Format Name | FormatName:[format name]
Label | Label:[label]

Example [Visual Basic]

The following example closes and deletes a Message Queuing backend resource. It assumes that a queue path has been passed in from the calling application, and that the path refers to a queue on the local computer.

As recommended, the queue is closed before there is an attempt to delete it. This ensures that further messages will not be sent to it before the backend resource is removed from Message Queuing.

This procedure assumes you can delete queues from the local machine.

[Visual Basic]

Private Sub TerminateQueue(ByVal queuePath As String)
    'Define and instantiate a new MessageQueue.
    Dim MessageQueue1 As MessageQueue
    MessageQueue1 = New MessageQueue(queuePath)

    'Close the message queue so it stops receiving messages.
    MessageQueue1.Close()
    'Delete the queue. This is a static method.
    MessageQueue.Delete(queuePath)
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | Create | Close | Path


MessageQueue.EndPeek

Terminates a peek asynchronous operation identified by the specified interface.

[Visual Basic]
Public Function EndPeek( _
   ByVal asyncResult As IAsyncResult _
) As Message
[C#]
public Message EndPeek(
   IAsyncResult asyncResult
);
[C++]
public: Message* EndPeek(
   IAsyncResult* asyncResult
);
[JScript]
public function EndPeek(
   asyncResult : IAsyncResult
) : Message;

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous operation to finish, and from which to retrieve an end result.

Return Value

The Message that represents the result of the posted asynchronous operation.

Exceptions

Exception Type | Condition
ArgumentNullException | The asyncResult parameter is a null reference (in Visual Basic Nothing).
ArgumentException | The asyncResult parameter has invalid syntax.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | BeginPeek


MessageQueue.EndReceive

Terminates a receive asynchronous operation identified by the specified interface.

[Visual Basic]
Public Function EndReceive( _
   ByVal asyncResult As IAsyncResult _
) As Message
[C#]
public Message EndReceive(
   IAsyncResult asyncResult
);
[C++]
public: Message* EndReceive(
   IAsyncResult* asyncResult
);
[JScript]
public function EndReceive(
   asyncResult : IAsyncResult
) : Message;

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous operation to finish, and from which to retrieve an end result .

Return Value

The Message that represents the result of the posted asynchronous operation.

Exceptions

Exception Type | Condition
ArgumentNullException | The asyncResult parameter is a null reference (in Visual Basic Nothing).
ArgumentException | The asyncResult parameter has invalid syntax.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | BeginReceive


MessageQueue.Exists

Determines whether a queue with the specified path exists.

[Visual Basic]
Public Shared Function Exists( _
   ByVal path As String _
) As Boolean
[C#]
public static bool Exists(
   string path
);
[C++]
public: static bool Exists(
   String* path
);
[JScript]
public static function Exists(
   path : String
) : Boolean;

Parameters

path
The location of the queue to find, using "." for the local computer. For information on proper syntax for this parameter, see the Remarks section.

Return Value

true if a queue with the specified path exists; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentNullException | The path parameter is a null reference (in Visual Basic Nothing) or an empty string.
MessageQueueException | The syntax for the path parameter is invalid.
InvalidOperationException | The queue's format name generated an exception.

Remarks

This method can be used to determine whether a Message Queuing queue resource with the specified path exists. There is no way to determine whether a queue with a specified format name exists. If you do not verify the existence of a queue before sending a message, the application throws an exception if the queue is not found. Because the MachineName can be given as part of the Path, the Exists method can be used to search for paths on any computer on the network.

The syntax for the path parameter depends on the type of queue it references. The following table shows the syntax you should use for a queue of a specified type.

Queue Type | Syntax
Public Queue | MachineName\QueueName
Private Queue | MachineName\Private$\QueueName

You can also use the Label of a Message Queuing resource to describe the queue path. The following table shows the proper syntax for that type of reference.

Reference | Syntax
Label | Label:[label]

Example [Visual Basic]

The following example verifies whether a queue named "myQueue" exists on the local computer. If it does not, the queue is created. Then, a message is sent to the queue.

[Visual Basic]

Private Sub CreateNewQueue()
    'Define a new MessageQueue object
    Dim messageQueue1 As MessageQueue
    Dim queuePath As String
    queuePath = ".\myQueue"

    'If no queue exists at the specified path, create one.
    If Not MessageQueue.Exists(queuePath) Then
        messageQueue1 = MessageQueue.Create(queuePath)
    Else
        'Set the MessageQueue to the existing path.
        messageQueue1 = New MessageQueue(queuePath)
    End If
    'Send a message to the queue
    messageQueue1.Send("Test message.")
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue.GetAllMessages

Returns all the messages available in the queue.

[Visual Basic]
Public Function GetAllMessages() As Message ()
[C#]
public Message[] GetAllMessages();
[C++]
public: Message* GetAllMessages() [];
[JScript]
public function GetAllMessages() : Message[];

Return Value

An array of type Message which represents all the messages contained in the queue.

Example

Tech review: suggest pseudocode.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue.GetMachineId

[To be supplied.]

[Visual Basic]
Public Shared Function GetMachineId( _
   ByVal machineName As String _
) As Guid
[C#]
public static Guid GetMachineId(
   string machineName
);
[C++]
public: static Guid GetMachineId(
   String* machineName
);
[JScript]
public static function GetMachineId(
   machineName : String
) : Guid;

Parameters

machineName
[To be supplied.]

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue.GetMessageQueuesEnumerator

[To be supplied.]

Overload List

Creates an enumerator object for the message queues available on the network.

[Visual Basic] Overloads Public Shared Function GetMessageQueuesEnumerator(MessageQueueCriteria) As MessageQueuesEnumerator
[C#] public static MessageQueuesEnumerator GetMessageQueuesEnumerator(MessageQueueCriteria);
[C++] public: static MessageQueuesEnumerator* GetMessageQueuesEnumerator(MessageQueueCriteria*);
[JScript] public static function GetMessageQueuesEnumerator(MessageQueueCriteria) : MessageQueuesEnumerator;

Creates an enumerator object for the message queues available on the network.

[Visual Basic] Overloads Public Shared Function GetMessageQueuesEnumerator() As MessageQueuesEnumerator
[C#] public static MessageQueuesEnumerator GetMessageQueuesEnumerator();
[C++] public: static MessageQueuesEnumerator* GetMessageQueuesEnumerator();
[JScript] public static function GetMessageQueuesEnumerator() : MessageQueuesEnumerator;

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue.GetMessageQueuesEnumerator (MessageQueueCriteria)

Creates an enumerator object for the message queues available on the network.

[Visual Basic]
Overloads Public Shared Function GetMessageQueuesEnumerator( _
   ByVal criteria As MessageQueueCriteria _
) As MessageQueuesEnumerator
[C#]
public static MessageQueuesEnumerator GetMessageQueuesEnumerator(
   MessageQueueCriteria criteria
);
[C++]
public: static MessageQueuesEnumerator* GetMessageQueuesEnumerator(
   MessageQueueCriteria* criteria
);
[JScript]
public static function GetMessageQueuesEnumerator(
   criteria : MessageQueueCriteria
) : MessageQueuesEnumerator;

Parameters

criteria
The criteria that will be used to filter the available message queues.

Return Value

The IEnumerator interface for the message queues available on the network.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue.GetMessageQueuesEnumerator Overload List


MessageQueue.GetMessageQueuesEnumerator ()

Creates an enumerator object for the message queues available on the network.

[Visual Basic]
Overloads Public Shared Function GetMessageQueuesEnumerator() As _
   MessageQueuesEnumerator
[C#]
public static MessageQueuesEnumerator GetMessageQueuesEnumerator();
[C++]
public: static MessageQueuesEnumerator*
   GetMessageQueuesEnumerator();
[JScript]
public static function GetMessageQueuesEnumerator() :
   MessageQueuesEnumerator;

Return Value

The IEnumerator interface for the message queues available on the network.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue.GetMessageQueuesEnumerator Overload List


MessageQueue.GetMessagesEnumerator

Creates an enumerator object for the messages contained in the MessageQueue.

[Visual Basic]
Public Function GetMessagesEnumerator() As MessagesEnumerator
[C#]
public MessagesEnumerator GetMessagesEnumerator();
[C++]
public: MessagesEnumerator* GetMessagesEnumerator();
[JScript]
public function GetMessagesEnumerator() : MessagesEnumerator;

Return Value

The MessagesEnumerator holding the messages contained in the queue.

Remarks

MessageQueue.GetMessagesEnumerator creates a dynamic list of the queues contained in Message Queuing. Messages associated with the enumerator can be removed from the queue.

Example [Visual Basic]

The following example gets a dynamic list of messages in a queue. It assumes that you have a queue withthe path "myComputer\myQueue". It then writes the body of each message to the console.

[Visual Basic]

Private Sub GetDynamicMessages()
    'Define an enumerator to hold the messages.
    Dim msgEnum As MessagesEnumerator
    'Define a message.
    Dim msg As Message

    'Define and instantiate a MessageQueue.
    Dim messageQueue1 As MessageQueue
    messageQueue1 = New MessageQueue("myComputer\myQueue")

    'Get the messages in the queue.
    msgEnum = messageQueue1.GetMessagesEnumerator

    'Display the message bodies.
    For Each msg In msgEnum
        console.WriteLine(msg.BodyStream)
    Next
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue.GetPrivateQueuesByMachine

Retrieves all the private queues on the specified computer.

[Visual Basic]
Public Shared Function GetPrivateQueuesByMachine( _
   ByVal machineName As String _
) As MessageQueue ()
[C#]
public static MessageQueue[] GetPrivateQueuesByMachine(
   string machineName
);
[C++]
public: static MessageQueue* GetPrivateQueuesByMachine(
   String* machineName
) [];
[JScript]
public static function GetPrivateQueuesByMachine(
   machineName : String
) : MessageQueue[];

Parameters

machineName
The computer from which to retrieve the private queues.

Return Value

An array of type MessageQueue that references the private queues retrieved.

Exceptions

Exception Type | Condition
ArgumentException | The machineName parameter is a null reference (in Visual Basic Nothing) or an empty string ("").
MessageQueueException | The attempt to access the queue's machine name generated an exception specified by the given status message.

Remarks

GetPrivateQueuesByMachine retrieves a static snapshot of the queues on the specified computer. You cannot retrieve the private queues on a remote computer, because private queues are not published across the entire network.

Private queue paths include text identifying them as private queues. Use MachineName\Private$\ QueueName to specify the Path for a private queue. For example myComputer\Private$\myQueue.

GetPrivateQueuesByMachine is a static (in Visual Basic Shared) method, so it can be called on the MessageQueue class itself. It is not necessary to instantiate a MessageQueue to call the method.

Example [Visual Basic]

The following example retrieves a list of private queues on a computer. Then, it calls Peek on the first message in each queue.

[Visual Basic]

Private Sub GetPrivateQueueList()
    'Define an array to hold the private queues.
    Dim mqList() As MessageQueue
    'Define a message object.
    Dim msg As Message
    'This is used in the for loop.
    Dim i As Integer

    'Get the private queues on the computer.
    mqList = MessageQueue.GetPrivateQueuesByMachine("myComputer")

    For i = 0 To mqList.Length - 1
        'Peek the top message in each private queue.
        msg = mqList(i).Peek
    Next
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MachineName | GetPublicQueuesByMachine


MessageQueue.GetPublicQueues

Retrieves public queues on the network.

Overload List

Retrieves a set of public queues filtered by the specified criteria.

[Visual Basic] Overloads Public Shared Function GetPublicQueues(MessageQueueCriteria) As MessageQueue ()
[C#] public static MessageQueue[] GetPublicQueues(MessageQueueCriteria);
[C++] public: static MessageQueue* GetPublicQueues(MessageQueueCriteria*) [];
[JScript] public static function GetPublicQueues(MessageQueueCriteria) : MessageQueue[];

Retrieves all public queues on the network.

[Visual Basic] Overloads Public Shared Function GetPublicQueues() As MessageQueue ()
[C#] public static MessageQueue[] GetPublicQueues();
[C++] public: static MessageQueue* GetPublicQueues() [];
[JScript] public static function GetPublicQueues() : MessageQueue[];

Example [Visual Basic]

The following example gets a list of public queues which have been modified within the previous 24 hours. The example assumes that there is a computer on the network with the name "myComputer".

Note This example shows how to use one of the overloaded versions of GetPublicQueues. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub GetPublicQueuesByCriteria()
    'Define an array to hold the queues.
    Dim mqList() As MessageQueue
    'This is used in the for loop.
    Dim i As Integer
    'This holds the information about the last modified time.
    Dim mqModified As System.DateTime
    'The criteria to filter queues by.
    Dim criteria As MessageQueueCriteria

    'This will get the queues modified within the last 24 hours.
    mqModified = DateTime.Now.Subtract(New TimeSpan(1, 0, 0, 0))

    'Set criteria information.
    criteria = New MessageQueueCriteria
    criteria.MachineName = "myComputer"
    criteria.ModifiedAfter = mqModified

    'Get the public queues that meet the criteria.
    mqList = MessageQueue.GetPublicQueues(criteria)
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue.GetPublicQueues (MessageQueueCriteria)

Retrieves a set of public queues filtered by the specified criteria.

[Visual Basic]
Overloads Public Shared Function GetPublicQueues( _
   ByVal criteria As MessageQueueCriteria _
) As MessageQueue ()
[C#]
public static MessageQueue[] GetPublicQueues(
   MessageQueueCriteria criteria
);
[C++]
public: static MessageQueue* GetPublicQueues(
   MessageQueueCriteria* criteria
) [];
[JScript]
public static function GetPublicQueues(
   criteria : MessageQueueCriteria
) : MessageQueue[];

Parameters

criteria
The MessageQueueCriteria that is used to filter the queues.

Return Value

An array of MessageQueue objects that reference the public queues retrieved.

Remarks

Use this overload to filter public queues by multiple criteria, like both Label and MachineName. Use this overload also to filter by a property for which there is no specific method, such as a queue's last modification time. You must define and instantiate a MessageQueueCriteria object, setting the properties on the object as appropriate.

If you want to restrict the list by criteria like MachineName, Label, or Category, use GetPublicQueuesByMachine, GetPublicQueuesByLabel, or GetPublicQueuesByCategory, respectively.

GetPublicQueues retrieves a static snapshot of the queues. To interact with a dynamic queue list, use GetMessageQueuesEnumerator.

GetPublicQueues cannot be used to retrieve private or system queue information.

GetPublicQueues is a static (in Visual Basic Shared) member, so it can be called using the MessageQueue class itself. It is not necessary to create an instance of MessageQueue in order to call the method.

Example [Visual Basic]

The following example gets a list of public queues which have been modified within the previous 24 hours. The example assumes that there is a computer on the network with the name "myComputer".

[Visual Basic]

Private Sub GetPublicQueuesByCriteria()
    'Define an array to hold the queues.
    Dim mqList() As MessageQueue
    'This is used in the for loop.
    Dim i As Integer
    'This holds the information about the last modified time.
    Dim mqModified As System.DateTime
    'The criteria to filter queues by.
    Dim criteria As MessageQueueCriteria

    'This will get the queues modified within the last 24 hours.
    mqModified = DateTime.Now.Subtract(New TimeSpan(1, 0, 0, 0))

    'Set criteria information.
    criteria = New MessageQueueCriteria
    criteria.MachineName = "myComputer"
    criteria.ModifiedAfter = mqModified

    'Get the public queues that meet the criteria.
    mqList = MessageQueue.GetPublicQueues(criteria)
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue.GetPublicQueues Overload List | GetPublicQueuesByLabel | GetPublicQueuesByMachine | GetPublicQueuesByCategory


MessageQueue.GetPublicQueues ()

Retrieves all public queues on the network.

[Visual Basic]
Overloads Public Shared Function GetPublicQueues() As MessageQueue ()
[C#]
public static MessageQueue[] GetPublicQueues();
[C++]
public: static MessageQueue* GetPublicQueues() [];
[JScript]
public static function GetPublicQueues() : MessageQueue[];

Return Value

An array of MessageQueue objects that reference the public queues retrieved.

Remarks

Use this overload when you want a complete list of all queues on the network. If you want to restrict the list by any criteria like MachineName, modification times, or Category, use another overload of this method or use GetPublicQueuesByMachine, GetPublicQueuesByCategory, or GetPublicQueuesByLabel.

GetPublicQueues retrieves a static snapshot of the queues. To interact with a dynamic queue list, use GetMessageQueuesEnumerator.

GetPublicQueues cannot be used to retrieve private or system queue information.

GetPublicQueues is a static (in Visual Basic Shared) member, so it can be called using the MessageQueue class itself. It is not necessary to create an instance of MessageQueue in order to call the method.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue.GetPublicQueues Overload List | GetPublicQueuesByLabel | GetPublicQueuesByMachine | GetPublicQueuesByCategory


MessageQueue.GetPublicQueuesByCategory

Retrieves a set of public queues filtered by the specified category.

[Visual Basic]
Public Shared Function GetPublicQueuesByCategory( _
   ByVal category As Guid _
) As MessageQueue ()
[C#]
public static MessageQueue[] GetPublicQueuesByCategory(
   Guid category
);
[C++]
public: static MessageQueue* GetPublicQueuesByCategory(
   Guid category
) [];
[JScript]
public static function GetPublicQueuesByCategory(
   category : Guid
) : MessageQueue[];

Parameters

category
Specifies the category that will be used to filter the queues in the network.

Return Value

An array of MessageQueue objects that reference the public queues retrieved.

Remarks

Use this method to filter public queues by category. The Category property provides access to the Message Queuing queue-associated type ID read/write property. You can use NewGuid to create a category value that is guaranteed to be unique across all Guid values. However, it is only necessary for the category value to be distinct from other categories, not from all other Guid values. You may assign, for example, the Category for one set of queues to be {00000000-0000-0000-0000-000000000001} and the Category for another set of queues to be {00000000-0000-0000-0000-000000000002}.

GetPublicQueuesByCategory retrieves a static snapshot of the queues. To interact with a dynamic queue list, use GetMessageQueuesEnumerator. You can specify the category as part of the MessageQueueCriteria passed in.

GetPublicQueuesByCategory can not be used to retrieve private or system queue information.

GetPublicQueuesByCategory is a static (in Visual Basic Shared) member, so it can be called using the MessageQueue class itself. It is not necessary to create an instance of MessageQueue in order to call the method.

Example [Visual Basic]

The following example creates a list of queues associated with a specified category. The procedure retrieves the Category for a queue named "myComputer\myQueue" and sends a broadcast message to all other queues with the same Category.

This procedure assumes that the queue "myQueue" exists on the computer "myComputer". It is also assumed that the category associated with the queue is not a null reference (in Visual Basic Nothing).

[Visual Basic]

Private Sub SearchPublicQueuesByCategory()
    'Create an array to hold the set of message queues.
    Dim mqList() As MessageQueue
    'The following integer is used in the for loop.
    Dim i As Integer
    Dim category As System.Guid

    'Define a MessageQueue.
    Dim messageQueue1 As MessageQueue
    'Connect the MessageQueue to the specified queue.
    messageQueue1 = New MessageQueue("myComputer\myQueue")
    'Get the category of the queue.
    category = MessageQueue1.Category

    'Get an array containing messagequeue information.
    mqList = MessageQueue.GetPublicQueuesByCategory(category)

    'Iterate through the message queues; this may involve several computers.
    For i = 0 To mqList.Length - 1
        'Send a message to each queue in the category.
        mqList(i).Send("Broadcast message to queues with category " + category.ToString)
    Next
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | Category | GetPublicQueues | GetPublicQueuesByLabel | GetPublicQueuesByMachine


MessageQueue.GetPublicQueuesByLabel

Retrieves a set of public queues filtered by the specified label.

[Visual Basic]
Public Shared Function GetPublicQueuesByLabel( _
   ByVal label As String _
) As MessageQueue ()
[C#]
public static MessageQueue[] GetPublicQueuesByLabel(
   string label
);
[C++]
public: static MessageQueue* GetPublicQueuesByLabel(
   String* label
) [];
[JScript]
public static function GetPublicQueuesByLabel(
   label : String
) : MessageQueue[];

Parameters

label
The label that is used to filter the queues.

Return Value

An array of MessageQueue objects that reference the public queues retrieved.

Remarks

Use this method to filter public queues by label.

GetPublicQueuesByLabel retrieves a static snapshot of the queues. To interact with a dynamic queue list, use GetMessageQueuesEnumerator. You can specify the label as part of the MessageQueueCriteria passed in.

GetPublicQueuesByLabel can not be used to retrieve private or system queue information.

GetPublicQueuesByLabel is a static (in Visual Basic Shared) member, so it can be called using the MessageQueue class itself. It is not necessary to create an instance of MessageQueue in order to call the method.

Example [Visual Basic]

The following example finds all public queues with the Label "My Queue", places them in an array of MessageQueue objects, and sends a broadcast message to these queues. These queues can be on multiple computers.

[Visual Basic]

Private Sub SearchPublicQueuesByLabel()
    'Create an array to hold the set of message queue objects.
    Dim mqList() As MessageQueue
    'This is used in the For loop.
    Dim i As Integer

    'Get an array of queues with the given label.
    mqList = MessageQueue.GetPublicQueuesByLabel("My Queue")

    'Iterate through the queue list to send a message to each queue.
    For i = 0 To mqList.Length - 1
        'Send a message to each queue. This may involve multiple computers.
        mqList(i).Send("Broadcast message to queues with label My Queue")
    Next
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | Label | GetPublicQueues | GetPublicQueuesByMachine | GetPublicQueuesByCategory


MessageQueue.GetPublicQueuesByMachine

Retrieves all public queues on the specified computer.

[Visual Basic]
Public Shared Function GetPublicQueuesByMachine( _
   ByVal machineName As String _
) As MessageQueue ()
[C#]
public static MessageQueue[] GetPublicQueuesByMachine(
   string machineName
);
[C++]
public: static MessageQueue* GetPublicQueuesByMachine(
   String* machineName
) [];
[JScript]
public static function GetPublicQueuesByMachine(
   machineName : String
) : MessageQueue[];

Parameters

machineName
The name of the computer from which to get the public queues.

Return Value

An array of MessageQueue objects that reference the public queues on the computer.

Remarks

Use this method to filter public queues by computer.

GetPublicQueuesByMachine returns a static snapshot of the queues. To interact with a dynamic queue list, use GetMessageQueuesEnumerator. You can specify the computer name as part of the MessageQueueCriteria passed in.

GetPublicQueuesByMachine can not be used to retrieve private or system queue information.

GetPublicQueuesByMachine is a static (in Visual Basic Shared) member, so it can be called using the MessageQueue class itself. It is not necessary to create an instance of MessageQueue in order to call the method.

Example [Visual Basic]

The following example retrieves an array containing all the public queues available on a specified computer. A message is sent to each public queue on the computer.

[Visual Basic]

Private Sub SearchMachineForQueue(ByVal computerName As String, ByVal queueName As String)
    'Create an array to hold the set of message queue objects
    Dim mqList() As MessageQueue

    'The following integer is used in the for loop
    Dim i As Integer

    'Get an array of public queues on the computer
    mqList = MessageQueue.GetPublicQueuesByMachine("myComputer")
    'Send a message to each public queue.
    For i = 0 To mqList.Length - 1
        mqList(i).Send("Broadcast message sent to queue.")
    Next
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MachineName | GetPublicQueues | GetPublicQueuesByLabel | GetPublicQueuesByCategory


MessageQueue.Peek

Returns the first message in the queue without removing it from the queue.

Overload List

Returns without removing (peeks) the first message available in the queue referenced by the MessageQueue. This call is synchronous. It blocks the current thread of execution until a message is available.

[Visual Basic] Overloads Overridable Public Function Peek() As Message
[C#] public virtual Message Peek();
[C++] public: virtual Message* Peek();
[JScript] public function Peek() : Message;

Returns without removing (peeks) the first message available in the queue referenced by the MessageQueue. Waits the specified interval for a message to become available.

[Visual Basic] Overloads Overridable Public Function Peek(TimeSpan) As Message
[C#] public virtual Message Peek(TimeSpan);
[C++] public: virtual Message* Peek(TimeSpan);
[JScript] public function Peek(TimeSpan) : Message;

Example [Visual Basic]

The following example uses the Peek and Receive methods on a queue. A Message object is instantiated to refer to the first message in the queue. If the first message is an application-defined marker, the queue is purged. Otherwise, the first message is read and removed.

This procedure assumes that the queue "myQueue" exists on the computer "myComputer". It also assumes that the message body "Purge the queue" is used to indicate that the queue should be purged.

Note This example shows how to use one of the overloaded versions of Peek. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Private Sub PeekQueue()
    'Define a Message.
    Dim msg As System.Messaging.Message
    'Define a string to hold the contents of the message body
    Dim msgBody As String
    'Define a new MessageQueue.
    Dim messageQueue1 As MessageQueue
    'Associate the MessageQueue with the given queue.
    messageQueue1 = New MessageQueue("myComputer\myQueue")

    'Read without removing (peek) the first message in the queue.
    msg = messageQueue1.Peek

    'If the message body indicates a specific marker, purge the queue.
    If msg.BodyStream.ToString = "Purge the queue." Then
        messageQueue1.Purge()
    Else
        'Otherwise, remove the top message from the queue (receive it).
        msg = MessageQueue1.Receive
    End If
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue.Peek ()

Returns without removing (peeks) the first message available in the queue referenced by the MessageQueue. This call is synchronous. It blocks the current thread of execution until a message is available.

[Visual Basic]
Overloads Overridable Public Function Peek() As Message
[C#]
public virtual Message Peek();
[C++]
public: virtual Message* Peek();
[JScript]
public function Peek() : Message;

Return Value

The Message that represents the first message available in the queue.

Exceptions

Exception Type | Condition
MessageQueueException | The attempt to unlock the queue in order to peek generated an exception specified by the given status message.

Remarks

Use this overload to peek a queue, or wait until there are messages in the queue.

The Peek method allows for the synchronous reading of a message without removing it from the queue. Repeated calls to Peek return the same message unless a higher priority message arrives in the queue. To read a message and remove it from the queue, use the Receive method. Subsequent calls to Receive will return the following messages in the queue or a new, higher priority message.

Use a call to Peek when it is acceptable for the current thread to be blocked while it waits for a message to arrive in the queue. Because this overload of the Peek method specifies an System.Messaging.MessageQueue.Infinite timeout, the application may wait indefinitely. If the application processing should continue without waiting for a message, consider using the asynchronous method, BeginPeek.

Example [Visual Basic]

The following example uses the Peek and Receive methods on a queue. A Message object is instantiated to refer to the first message in the queue. If the first message is an application-defined marker, the queue is purged. Otherwise, the first message is read and removed.

This procedure assumes that the queue "myQueue" exists on the computer "myComputer". It also assumes that the message body "Purge the queue" is used to indicate that the queue should be purged.

[Visual Basic]

Private Sub PeekQueue()
    'Define a Message.
    Dim msg As System.Messaging.Message
    'Define a string to hold the contents of the message body
    Dim msgBody As String
    'Define a new MessageQueue.
    Dim messageQueue1 As MessageQueue
    'Associate the MessageQueue with the given queue.
    messageQueue1 = New MessageQueue("myComputer\myQueue")

    'Read without removing (peek) the first message in the queue.
    msg = messageQueue1.Peek

    'If the message body indicates a specific marker, purge the queue.
    If msg.BodyStream.ToString = "Purge the queue." Then
        messageQueue1.Purge()
    Else
        'Otherwise, remove the top message from the queue (receive it).
        msg = MessageQueue1.Receive
    End If
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue.Peek Overload List | Receive | BeginPeek | BeginReceive


MessageQueue.Peek (TimeSpan)

Returns without removing (peeks) the first message available in the queue referenced by the MessageQueue. Waits the specified interval for a message to become available.

[Visual Basic]
Overloads Overridable Public Function Peek( _
   ByVal timeout As TimeSpan _
) As Message
[C#]
public virtual Message Peek(
   TimeSpan timeout
);
[C++]
public: virtual Message* Peek(
   TimeSpan timeout
);
[JScript]
public function Peek(
   timeout : TimeSpan
) : Message;

Parameters

timeout
The interval of time, in milliseconds, to wait for a message to become available.

Return Value

The Message that represents first message available in the queue.

Exceptions

Exception Type | Condition
ArgumentException | The value specified for the timeout parameter is invalid. It may represent a negative number.
MessageQueueException | The attempt to unlock the queue in order to peek generated an exception specified by the given status message.

Remarks

Use this overload to peek a queue and return in a specified period of time if there are no messages in the queue.

The Peek method allows for the synchronous reading of a message without removing it from the queue. Repeated calls to Peek return the same message unless a higher priority message arrives in the queue. To read a message and remove it from the queue, use the Receive method. Subsequent calls to Receive will return the following messages in the queue or a new, higher priority message.

Use a call to Peek when it is acceptable for the current thread to be blocked while it waits for a message to arrive in the queue. The thread will be blocked for the given period of time, or indefinitely if you specified System.Messaging.MessageQueue.Infinite. If the application processing should continue without waiting for a message, consider using the asynchronous method, BeginPeek.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue.Peek Overload List | Receive | InfiniteTimeout | BeginPeek | BeginReceive


MessageQueue.PeekByCorrelationId

[To be supplied.]

Overload List

Peeks the message that matches the given correlation ID. If there is no message with a matching correlation ID, an exception is thrown.

[Visual Basic] Overloads Overridable Public Function PeekByCorrelationId(String) As Message
[C#] public virtual Message PeekByCorrelationId(String);
[C++] public: virtual Message* PeekByCorrelationId(String*);
[JScript] public function PeekByCorrelationId(String) : Message;

Peeks the message that matches the given correlation ID. This function will wait until a message with a matching correlation ID is available, or the given timeout expires when no more messages can be inspected.

[Visual Basic] Overloads Overridable Public Function PeekByCorrelationId(String, TimeSpan) As Message
[C#] public virtual Message PeekByCorrelationId(String, TimeSpan);
[C++] public: virtual Message* PeekByCorrelationId(String*, TimeSpan);
[JScript] public function PeekByCorrelationId(String, TimeSpan) : Message;

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue.PeekByCorrelationId (String)

Peeks the message that matches the given correlation ID. If there is no message with a matching correlation ID, an exception is thrown.

[Visual Basic]
Overloads Overridable Public Function PeekByCorrelationId( _
   ByVal correlationId As String _
) As Message
[C#]
public virtual Message PeekByCorrelationId(
   string correlationId
);
[C++]
public: virtual Message* PeekByCorrelationId(
   String* correlationId
);
[JScript]
public function PeekByCorrelationId(
   correlationId : String
) : Message;

Parameters

correlationId
The CorrelationId of the message to peek.

Return Value

The message with a matching correlation ID.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue.PeekByCorrelationId Overload List


MessageQueue.PeekByCorrelationId (String, TimeSpan)

Peeks the message that matches the given correlation ID. This function will wait until a message with a matching correlation ID is available, or the given timeout expires when no more messages can be inspected.

[Visual Basic]
Overloads Overridable Public Function PeekByCorrelationId( _
   ByVal correlationId As String, _
   ByVal timeout As TimeSpan _
) As Message
[C#]
public virtual Message PeekByCorrelationId(
   string correlationId,
   TimeSpan timeout
);
[C++]
public: virtual Message* PeekByCorrelationId(
   String* correlationId,
   TimeSpan timeout
);
[JScript]
public function PeekByCorrelationId(
   correlationId : String,
   timeout : TimeSpan
) : Message;

Parameters

correlationId
The System.Messaging.MessageQueue.CorrelationId of the message to peek.
timeout
The time to wait until a new message is available for inspection.

Return Value

The message with the matching correlation ID.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue.PeekByCorrelationId Overload List


MessageQueue.PeekById

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function PeekById(String, TimeSpan) As Message
[C#] public virtual Message PeekById(String, TimeSpan);
[C++] public: virtual Message* PeekById(String*, TimeSpan);
[JScript] public function PeekById(String, TimeSpan) : Message;

Peeks the message that matches the given ID. If there is no message with a matching ID, an exception will be raised.

[Visual Basic] Overloads Overridable Public Function PeekById(String) As Message
[C#] public virtual Message PeekById(String);
[C++] public: virtual Message* PeekById(String*);
[JScript] public function PeekById(String) : Message;

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue.PeekById (String, TimeSpan)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function PeekById( _
   ByVal id As String, _
   ByVal timeout As TimeSpan _
) As Message
[C#]
public virtual Message PeekById(
   string id,
   TimeSpan timeout
);
[C++]
public: virtual Message* PeekById(
   String* id,
   TimeSpan timeout
);
[JScript]
public function PeekById(
   id : String,
   timeout : TimeSpan
) : Message;

Parameters

id
[To be supplied.]
timeout
[To be supplied.]

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue.PeekById Overload List


MessageQueue.PeekById (String)

Peeks the message that matches the given ID. If there is no message with a matching ID, an exception will be raised.

[Visual Basic]
Overloads Overridable Public Function PeekById( _
   ByVal id As String _
) As Message
[C#]
public virtual Message PeekById(
   string id
);
[C++]
public: virtual Message* PeekById(
   String* id
);
[JScript]
public function PeekById(
   id : String
) : Message;

Parameters

id
The Id of the message to peek.

Return Value

The message with the matching ID.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue.PeekById Overload List


MessageQueue.Purge

Deletes all the messages contained in the queue.

[Visual Basic]
Overridable Public Sub Purge()
[C#]
public virtual void Purge();
[C++]
public: virtual void Purge();
[JScript]
public function Purge();

Example [Visual Basic]

The following example uses the Peek and Receive methods on a queue. A Message object is instantiated to refer to the first message in the queue. If the first message is an application-defined marker, the queue is purged. Otherwise, the first message is read and removed.

This procedure assumes that the queue "myQueue" exists on the computer "myComputer". It also assumes that the message body "Purge the queue" is used to indicate that the queue should be purged.

[Visual Basic]

Private Sub PeekQueue()
    'Define a Message.
    Dim msg As System.Messaging.Message
    'Define a string to hold the contents of the message body
    Dim msgBody As String
    'Define a new MessageQueue.
    Dim messageQueue1 As MessageQueue
    'Associate the MessageQueue with the given queue.
    messageQueue1 = New MessageQueue("myComputer\myQueue")

    'Read without removing (peek) the first message in the queue.
    msg = messageQueue1.Peek

    'If the message body indicates a specific marker, purge the queue.
    If msg.BodyStream.ToString = "Purge the queue." Then
        messageQueue1.Purge()
    Else
        'Otherwise, remove the top message from the queue (receive it).
        msg = MessageQueue1.Receive
    End If
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue.Receive

Receives the first message in the queue.

Overload List

Receives the first message available in the queue referenced by the MessageQueue. This call is synchronous. It blocks the current thread of execution until a message is available.

[Visual Basic] Overloads Overridable Public Function Receive() As Message
[C#] public virtual Message Receive();
[C++] public: virtual Message* Receive();
[JScript] public function Receive() : Message;

Receives the first message available in the queue referenced by the MessageQueue. Waits the specified interval for a message to become available.

[Visual Basic] Overloads Overridable Public Function Receive(TimeSpan) As Message
[C#] public virtual Message Receive(TimeSpan);
[C++] public: virtual Message* Receive(TimeSpan);
[JScript] public function Receive(TimeSpan) : Message;

Example

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue.Receive ()

Receives the first message available in the queue referenced by the MessageQueue. This call is synchronous. It blocks the current thread of execution until a message is available.

[Visual Basic]
Overloads Overridable Public Function Receive() As Message
[C#]
public virtual Message Receive();
[C++]
public: virtual Message* Receive();
[JScript]
public function Receive() : Message;

Return Value

A Message that references the first message available in the queue.

Exceptions

Exception Type | Condition
MessageQueueException | The attempt to unlock the queue to retrieve the message generated an exception specified by the given status message.

Remarks

Use this overload to receive a message from a queue, or wait until there are messages in the queue.

The Receive method allows for the synchronous reading of a message, removing it from the queue. Subsequent calls to Receive will return the messages that follow in the queue,k or a new, higher priority message.

To read the first message in a queue without removing it from the queue, use the Peek method. The Peek method always returns the first message in the queue, so subsequent calls to the method return the same message unless a higher priority message arrives in the queue.

Use a call to Receive when it is acceptable for the current thread to be blocked while it waits for a message to arrive in the queue. Because this overload of the Receive method specifies an System.Messaging.MessageQueue.Infinite timeout, the application may wait indefinitely. If the application processing should continue without waiting for a message, consider using the asynchronous method, BeginPeek.

Example [Visual Basic]

The following example uses the Peek and Receive methods on a queue. A Message object is instantiated to refer to the first message in the queue. If the first message is an application-defined marker, the queue is purged. Otherwise, the first message is read and removed.

This procedure assumes that the queue "myQueue" exists on the computer "myComputer". It also assumes that the message body "Purge the queue" is used to indicate that the queue should be purged.

[Visual Basic]

Private Sub PeekQueue()
    'Define a Message.
    Dim msg As System.Messaging.Message
    'Define a string to hold the contents of the message body
    Dim msgBody As String
    'Define a new MessageQueue.
    Dim messageQueue1 As MessageQueue
    'Associate the MessageQueue with the given queue.
    messageQueue1 = New MessageQueue("myComputer\myQueue")

    'Read without removing (peek) the first message in the queue.
    msg = messageQueue1.Peek

    'If the message body indicates a specific marker, purge the queue.
    If msg.BodyStream.ToString = "Purge the queue." Then
        messageQueue1.Purge()
    Else
        'Otherwise, remove the top message from the queue (receive it).
        msg = MessageQueue1.Receive
    End If
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue.Receive Overload List | Peek | BeginReceive | BeginPeek


MessageQueue.Receive (TimeSpan)

Receives the first message available in the queue referenced by the MessageQueue. Waits the specified interval for a message to become available.

[Visual Basic]
Overloads Overridable Public Function Receive( _
   ByVal timeout As TimeSpan _
) As Message
[C#]
public virtual Message Receive(
   TimeSpan timeout
);
[C++]
public: virtual Message* Receive(
   TimeSpan timeout
);
[JScript]
public function Receive(
   timeout : TimeSpan
) : Message;

Parameters

timeout
The interval of time, in milliseconds, to wait for a message to become available.

Return Value

A Message that references the first message available in the queue.

Exceptions

Exception Type | Condition
ArgumentException | The value specified for the timeout parameter is invalid. It may represent a negative number.
MessageQueueException | The attempt to unlock the queue in order to retrieve the contents generated an exception specified by the given status.

Remarks

Use this overload to receive a message from a queue and return in a specified period of time if there are no messages in the queue.

The Receive method allows for the synchronous reading of a message, removing it from the queue. Subsequent calls to Receive will return the messages that follow in the queue,k or a new, higher priority message.

To read the first message in a queue without removing it from the queue, use the Peek method. The Peek method always returns the first message in the queue, so subsequent calls to the method return the same message unless a higher priority message arrives in the queue.

Use a call to Receive when it is acceptable for the current thread to be blocked while it waits for a message to arrive in the queue. The thread will be blocked for the given period of time, or indefinitely if you specified System.Messaging.MessageQueue.Infinite. If the application processing should continue without waiting for a message, consider using the asynchronous method, BeginPeek.

Example

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue.Receive Overload List | Peek | InfiniteTimeout | BeginReceive | BeginPeek


MessageQueue.ReceiveByCorrelationId

[To be supplied.]

Overload List

Receivess the message that matches the given correlation ID. If there is no message with a matching correlation ID, an exception is thrown.

[Visual Basic] Overloads Overridable Public Function ReceiveByCorrelationId(String) As Message
[C#] public virtual Message ReceiveByCorrelationId(String);
[C++] public: virtual Message* ReceiveByCorrelationId(String*);
[JScript] public function ReceiveByCorrelationId(String) : Message;

Receives the message that matches the given correlation ID. This method waits until a message with a matching correlation ID is available or the given timeout expires when no more messages can be inspected.

[Visual Basic] Overloads Overridable Public Function ReceiveByCorrelationId(String, TimeSpan) As Message
[C#] public virtual Message ReceiveByCorrelationId(String, TimeSpan);
[C++] public: virtual Message* ReceiveByCorrelationId(String*, TimeSpan);
[JScript] public function ReceiveByCorrelationId(String, TimeSpan) : Message;

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue.ReceiveByCorrelationId (String)

Receivess the message that matches the given correlation ID. If there is no message with a matching correlation ID, an exception is thrown.

[Visual Basic]
Overloads Overridable Public Function ReceiveByCorrelationId( _
   ByVal correlationId As String _
) As Message
[C#]
public virtual Message ReceiveByCorrelationId(
   string correlationId
);
[C++]
public: virtual Message* ReceiveByCorrelationId(
   String* correlationId
);
[JScript]
public function ReceiveByCorrelationId(
   correlationId : String
) : Message;

Parameters

correlationId
The CorrelationId of the message to receive.

Return Value

The message with a matching correlation ID.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue.ReceiveByCorrelationId Overload List


MessageQueue.ReceiveByCorrelationId (String, TimeSpan)

Receives the message that matches the given correlation ID. This method waits until a message with a matching correlation ID is available or the given timeout expires when no more messages can be inspected.

[Visual Basic]
Overloads Overridable Public Function ReceiveByCorrelationId( _
   ByVal correlationId As String, _
   ByVal timeout As TimeSpan _
) As Message
[C#]
public virtual Message ReceiveByCorrelationId(
   string correlationId,
   TimeSpan timeout
);
[C++]
public: virtual Message* ReceiveByCorrelationId(
   String* correlationId,
   TimeSpan timeout
);
[JScript]
public function ReceiveByCorrelationId(
   correlationId : String,
   timeout : TimeSpan
) : Message;

Parameters

correlationId
The CorrelationId of the message to receive.
timeout
The time to wait until a new message is available for inspection.

Return Value

The message with the matching correlation ID.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue.ReceiveByCorrelationId Overload List


MessageQueue.ReceiveById

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function ReceiveById(String, TimeSpan) As Message
[C#] public virtual Message ReceiveById(String, TimeSpan);
[C++] public: virtual Message* ReceiveById(String*, TimeSpan);
[JScript] public function ReceiveById(String, TimeSpan) : Message;

Receives the message that matches the given ID. If there is no message with a matching ID, an exception is thrown.

[Visual Basic] Overloads Overridable Public Function ReceiveById(String) As Message
[C#] public virtual Message ReceiveById(String);
[C++] public: virtual Message* ReceiveById(String*);
[JScript] public function ReceiveById(String) : Message;

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue.ReceiveById (String, TimeSpan)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function ReceiveById( _
   ByVal id As String, _
   ByVal timeout As TimeSpan _
) As Message
[C#]
public virtual Message ReceiveById(
   string id,
   TimeSpan timeout
);
[C++]
public: virtual Message* ReceiveById(
   String* id,
   TimeSpan timeout
);
[JScript]
public function ReceiveById(
   id : String,
   timeout : TimeSpan
) : Message;

Parameters

id
[To be supplied.]
timeout
[To be supplied.]

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue.ReceiveById Overload List


MessageQueue.ReceiveById (String)

Receives the message that matches the given ID. If there is no message with a matching ID, an exception is thrown.

[Visual Basic]
Overloads Overridable Public Function ReceiveById( _
   ByVal id As String _
) As Message
[C#]
public virtual Message ReceiveById(
   string id
);
[C++]
public: virtual Message* ReceiveById(
   String* id
);
[JScript]
public function ReceiveById(
   id : String
) : Message;

Parameters

id
The Id of the message to receive.

Return Value

The message with the matching ID.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue.ReceiveById Overload List


MessageQueue.Refresh

Refreshes the properties presented by the MessageQueue to reflect the current state of the resource.

[Visual Basic]
Overridable Public Sub Refresh()
[C#]
public virtual void Refresh();
[C++]
public: virtual void Refresh();
[JScript]
public function Refresh();

Remarks

Refresh synchronizes the properties of a MessageQueue object with its associated Message Queuing backend resource. If any property, such as Label or Category, has changed on the backend since the time the MessageQueue instance was created, Refresh updates the MessageQueue with the new information.

The menu item, Refresh, associated with a message queue on the backend is not the same as the Refresh method. The menu item refreshes the view for the queue in the Message Queuing administrative tool. Refresh synchronizes the application-defined instance with the backend data, and is not merely associated with viewing the data.

Use Refresh when you are working with the static (in Visual Basic Shared) members that produce snapshot of the backend. For example, if you have called GetPublicQueues, GetPublicQueuesByCategory, GetPublicQueuesByLabel, GetPublicQueuesByMachine, or GetPrivateQueuesByMachine to retrieve a snapshot of queue data, it may be helpful to use Refresh to examine the property settings for a specific queue before manipulating the queue information.

Example [Visual Basic]

The following example illustrates how Refresh captures changes on a backend queue resource. You are prompted to change the label on a backend resource during execution. A message box indicates which resource was changed and what the new label is.

The example assumes that there is at least one public queue with the label "My Queue" on a computer on the network.

Import the System.Messaging and System.WinForms namespaces for this example.

[Visual Basic]

Private Sub RefreshLocalQueueInfo()
    'Define an array to hold the queues.
    Dim mqList() As MessageQueue
    'This is used in the for loop.
    Dim i As Integer
    'Get the public queues with the given label.
    mqList = MessageQueue.GetPublicQueuesByLabel("My Queue")
    '
    'Change a queue property using Message Queuing.
    MessageBox.Show("Use Message Queuing to change the label of any queue labeled My Queue")

    'Display the changed queues to the screen.
    For i = 0 To mqList.Length - 1
        'Sync with the current contents in Message Queuing.
        mqList(i).Refresh()
        'Display the changed label to the screen.
        If mqList(i).Label <> "My Queue" Then
MessageBox.Show(mqList(i).QueueName & ": label has changed to " & mqList(i).Label)
        End If
    Next
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | GetPublicQueues | GetPublicQueuesByCategory | GetPublicQueuesByLabel | GetPublicQueuesByMachine


MessageQueue.RemoveOnPeekCompleted

Removes an event handler from the PeekCompleted event.

[Visual Basic]
Overridable Public Sub RemoveOnPeekCompleted( _
   ByVal handler As PeekCompletedEventHandler _
)
[C#]
public virtual void RemoveOnPeekCompleted(
   PeekCompletedEventHandler handler
);
[C++]
public: virtual void RemoveOnPeekCompleted(
   PeekCompletedEventHandler* handler
);
[JScript]
public function RemoveOnPeekCompleted(
   handler : PeekCompletedEventHandler
);

Parameters

handler
[To be supplied.]

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue.RemoveOnReceiveCompleted

Removes an event handler from the ReceiveCompleted event.

[Visual Basic]
Overridable Public Sub RemoveOnReceiveCompleted( _
   ByVal handler As ReceiveCompletedEventHandler _
)
[C#]
public virtual void RemoveOnReceiveCompleted(
   ReceiveCompletedEventHandler handler
);
[C++]
public: virtual void RemoveOnReceiveCompleted(
   ReceiveCompletedEventHandler* handler
);
[JScript]
public function RemoveOnReceiveCompleted(
   handler : ReceiveCompletedEventHandler
);

Parameters

handler
[To be supplied.]

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue.RollbackTransaction

Rolls back the pending internal transaction.

[Visual Basic]
Public Sub RollbackTransaction()
[C#]
public void RollbackTransaction();
[C++]
public: void RollbackTransaction();
[JScript]
public function RollbackTransaction();

Exceptions

Exception Type | Condition
MessageQueueException | The internal transaction you are attempting to roll back has not started.
MessageQueueException | The attempt to retrieve queue information generated an exception specified by the given status message.

Remarks

RollbackTransaction marks the unsuccessful completion of a process begun at a call to BeginTransaction. If an exception occurs between the call to BeginTransaction and the call to CommitTransaction, the entire transaction is rolled back. This includes messages sent after the call to BeginTransaction. Messages that are part of a transaction must be sent to transactional queues.

Make the call to BeginTransaction within a Try...Catch block, the call to CommitTransaction in the Try clause, and the call to RollbackTransaction in the Catch clause.

Example

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | BeginTransaction | CommitTransaction | Transactional


MessageQueue.Send

[To be supplied.]

Overload List

Sends an object to the queue referenced by this MessageQueue. The object is serialized using the formatter provided.

[Visual Basic] Overloads Overridable Public Sub Send(Object)
[C#] public virtual void Send(Object);
[C++] public: virtual void Send(Object*);
[JScript] public function Send(Object);

Sends an object to the queue referenced by this MessageQueue. The object will be serialized using the formatter provided.

[Visual Basic] Overloads Overridable Public Sub Send(Object, String)
[C#] public virtual void Send(Object, String);
[C++] public: virtual void Send(Object*, String);
[JScript] public function Send(Object, String);

Example [Visual Basic]

The following example sends an object defined by a structure to a message queue. This example assumes there is a queue named "myQueue" on the computer "myComputer". It also assumes that there is a structure named MyNewObject with the members Item and Quantity.

Note This example shows how to use one of the overloaded versions of Send. For other examples that may be available, see the individual overload topics.

[Visual Basic]

Structure MyNewObject
    Public Item As String
    Public Quantity As Integer
End Structure

Private Sub SendObject()
    'Create a new Order object.
    Dim myNewObject1 As MyNewObject
    Dim messageQueue1 As MessageQueue
    messageQueue1 = New MessageQueue("myComputer\myQueue")
    'Populate the structure's members.
    myNewObject1.Item = "new item"
    myNewObject1.Quantity = 1
    'Send the structure to the message queue.
    messageQueue1.Send(myNewObject1)
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueue.Send (Object)

Sends an object to the queue referenced by this MessageQueue. The object is serialized using the formatter provided.

[Visual Basic]
Overloads Overridable Public Sub Send( _
   ByVal obj As Object _
)
[C#]
public virtual void Send(
   object obj
);
[C++]
public: virtual void Send(
   Object* obj
);
[JScript]
public function Send(
   obj : Object
);

Parameters

obj
The object to send to the queue.

Exceptions

Exception Type | Condition
MessageQueueException | The attempt to retrieve queue information generated an exception specified by the given status message.

Remarks

Use this overload to send a message to the queue referenced by the MessageQueue. The Path must already be specified before the message is sent, because this overload is not static (in Visual Basic Shared).

The object sent to the queue can be a Message, a structure, a data object, or any other NGWS object.

If you set DefaultPropertiesToSend before sending any object besides a Message object, these properties apply when you call Send. When sending a Message object, the property values are initially set by the Message object's constructor and must be overridden explicitly if you want to use the DefaultPropertiesToSend.

Example [Visual Basic]

The following example sends an object defined by a structure to a message queue. This example assumes there is a queue named "myQueue" on the computer "myComputer". It also assumes that there is a structure named MyNewObject with the members Item and Quantity.

[Visual Basic]

Structure MyNewObject
    Public Item As String
    Public Quantity As Integer
End Structure

Private Sub SendObject()
    'Create a new Order object.
    Dim myNewObject1 As MyNewObject
    Dim messageQueue1 As MessageQueue
    messageQueue1 = New MessageQueue("myComputer\myQueue")
    'Populate the structure's members.
    myNewObject1.Item = "new item"
    myNewObject1.Quantity = 1
    'Send the structure to the message queue.
    messageQueue1.Send(myNewObject1)
End Sub

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue.Send Overload List | DefaultPropertiesToSend | Message | Purge | Path


MessageQueue.Send (Object, String)

Sends an object to the queue referenced by this MessageQueue. The object will be serialized using the formatter provided.

[Visual Basic]
Overloads Overridable Public Sub Send( _
   ByVal obj As Object, _
   ByVal label As String _
)
[C#]
public virtual void Send(
   object obj,
   string label
);
[C++]
public: virtual void Send(
   Object* obj,
   String* label
);
[JScript]
public function Send(
   obj : Object,
   label : String
);

Parameters

obj
The object to send to the queue.
label
The label of the message to send.

Exceptions

Exception Type | Condition
MessageQueueException | The attempt to retrieve queue information generated an exception specified by the given status.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | MessageQueue.Send Overload List


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MessageQueue Events

The events of the MessageQueue class are listed below. For a complete list of MessageQueue class members, see the MessageQueue Members topic.

Public:

PeekCompleted | [To be supplied.]
ReceiveCompleted | [To be supplied.]

See Also

MessageQueue Class | System.Messaging Namespace


MessageQueue PeekCompleted Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the PeekCompleted event.

[Visual Basic]
Private Sub MessageQueueName_PeekCompleted( _
   ByVal sender As Object, _
   ByVal e As PeekCompletedEventArgs _
)
[C#]
private void MessageQueueName_PeekCompleted(
   object sender,
   PeekCompletedEventArgs e
);
[C++]
private: void MessageQueueName_PeekCompleted(
   Object* sender,
   PeekCompletedEventArgs* e
);
[JScript]
private MessageQueueName_PeekCompleted(
   sender : Object,
   e : PeekCompletedEventArgs
);

Parameters

sender
The source of the event.
e
A PeekCompletedEventArgs that contains the event data.

See Also

MessageQueue Class | MessageQueue MembersTopic | System.Messaging Namespace | BeginPeek | EndPeek


MessageQueue ReceiveCompleted Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the ReceiveCompleted event.

[Visual Basic]
Private Sub MessageQueueName_ReceiveCompleted( _
   ByVal sender As Object, _
   ByVal e As ReceiveCompletedEventArgs _
)
[C#]
private void MessageQueueName_ReceiveCompleted(
   object sender,
   ReceiveCompletedEventArgs e
);
[C++]
private: void MessageQueueName_ReceiveCompleted(
   Object* sender,
   ReceiveCompletedEventArgs* e
);
[JScript]
private MessageQueueName_ReceiveCompleted(
   sender : Object,
   e : ReceiveCompletedEventArgs
);

Parameters

sender
The source of the event.
e
A ReceiveCompletedEventArgs that contains the event data.

See Also

MessageQueue Class | MessageQueue MembersTopic | System.Messaging Namespace | BeginReceive | EndReceive


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MessageQueue Fields

The fields of the MessageQueue class are listed below. For a complete list of MessageQueue class members, see the MessageQueue Members topic.

Public:

InfiniteTimeout | Specifies that there is no timeout period for calls to peek or receive messages.
InifiniteQueueSize | [To be supplied.]

See Also

MessageQueue Class | System.Messaging Namespace


MessageQueue.InfiniteTimeout

Specifies that there is no timeout period for calls to peek or receive messages.

[Visual Basic]
Public Shared InfiniteTimeout As TimeSpan
[C#]
public static TimeSpan InfiniteTimeout;
[C++]
public: static TimeSpan InfiniteTimeout;
[JScript]
public static var InfiniteTimeout : TimeSpan;

Remarks

If the timeout value InfiniteTimeout is specified for synchronous calls to receive messages, the current thread of execution will be blocked until a new message is available. If InfiniteTimeout is specified for asynchronous calls to receive messages, the current thread of execution will not be blocked.

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace | Peek | Receive | BeginPeek | BeginReceive


MessageQueue.InifiniteQueueSize

[To be supplied.]

[Visual Basic]
Public Shared InifiniteQueueSize As Long
[C#]
public static long InifiniteQueueSize;
[C++]
public: static __int64 InifiniteQueueSize;
[JScript]
public static var InifiniteQueueSize : long;

See Also

MessageQueue Class | MessageQueue Members | System.Messaging Namespace


MessageQueueCriteria Class

This class is used to filter MessageQueues when performing a query in the network, through MessageQueue.GetPublicQueues method.

Object
MessageQueueCriteria

[Visual Basic]
Public Class MessageQueueCriteria
[C#]
public class MessageQueueCriteria
[C++]
public __gc class MessageQueueCriteria
[JScript]
public class MessageQueueCriteria

Remarks

[To be supplied.]

Requirements

Namespace: System.Messaging

Assembly: system.messaging.dll

See Also

MessageQueueCriteria Members | System.Messaging Namespace


MessageQueueCriteria Members

Public:

Constructor

MessageQueueCriteria Constructor [To be supplied.]

Properties

Category | Specifies the Category that will be used as the criteria to search queues in the network.
CreatedAfter | Specifies the lower bound of the interval that will be used as the queue creation time search criteria.
CreatedBefore | Specifies the upper bound of the interval that will be used as the queue creation time search criteria.
Label | Specifies the label that that will be used as the criteria to search queues in the network.
MachineName | Specifies the machine name that will be used as the criteria to search queues in the network.
ModifiedAfter | Specifies the lower bound of the interval that will be used as the queue modified time search criteria.
ModifiedBefore | Specifies the upper bound of the interval that will be used as the queue modified time search criteria.

Methods

ClearAll | Resets all the current instance settings.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MessageQueueCriteria Class | System.Messaging Namespace


MessageQueueCriteria Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public MessageQueueCriteria();
[C++]
public: MessageQueueCriteria();
[JScript]
public function MessageQueueCriteria();

See Also

MessageQueueCriteria Class | MessageQueueCriteria Members | System.Messaging Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MessageQueueCriteria Properties

The properties of the MessageQueueCriteria class are listed below. For a complete list of MessageQueueCriteria class members, see the MessageQueueCriteria Members topic.

Public:

Category | Specifies the Category that will be used as the criteria to search queues in the network.
CreatedAfter | Specifies the lower bound of the interval that will be used as the queue creation time search criteria.
CreatedBefore | Specifies the upper bound of the interval that will be used as the queue creation time search criteria.
Label | Specifies the label that that will be used as the criteria to search queues in the network.
MachineName | Specifies the machine name that will be used as the criteria to search queues in the network.
ModifiedAfter | Specifies the lower bound of the interval that will be used as the queue modified time search criteria.
ModifiedBefore | Specifies the upper bound of the interval that will be used as the queue modified time search criteria.

See Also

MessageQueueCriteria Class | System.Messaging Namespace


MessageQueueCriteria.Category

Specifies the Category that will be used as the criteria to search queues in the network.

[Visual Basic]
Overridable Public Property Category As Guid
[C#]
public Guid Category {virtual get; virtual set;}
[C++]
public: __property virtual Guid get_Category();
public: __property virtual void set_Category(Guid);
[JScript]
public function get Category() : Guid;
public function set Category(Guid);

See Also

MessageQueueCriteria Class | MessageQueueCriteria Members | System.Messaging Namespace


MessageQueueCriteria.CreatedAfter

Specifies the lower bound of the interval that will be used as the queue creation time search criteria.

[Visual Basic]
Overridable Public Property CreatedAfter As DateTime
[C#]
public DateTime CreatedAfter {virtual get; virtual set;}
[C++]
public: __property virtual DateTime get_CreatedAfter();
public: __property virtual void set_CreatedAfter(DateTime);
[JScript]
public function get CreatedAfter() : DateTime;
public function set CreatedAfter(DateTime);

See Also

MessageQueueCriteria Class | MessageQueueCriteria Members | System.Messaging Namespace


MessageQueueCriteria.CreatedBefore

Specifies the upper bound of the interval that will be used as the queue creation time search criteria.

[Visual Basic]
Overridable Public Property CreatedBefore As DateTime
[C#]
public DateTime CreatedBefore {virtual get; virtual set;}
[C++]
public: __property virtual DateTime get_CreatedBefore();
public: __property virtual void set_CreatedBefore(DateTime);
[JScript]
public function get CreatedBefore() : DateTime;
public function set CreatedBefore(DateTime);

See Also

MessageQueueCriteria Class | MessageQueueCriteria Members | System.Messaging Namespace


MessageQueueCriteria.Label

Specifies the label that that will be used as the criteria to search queues in the network.

[Visual Basic]
Overridable Public Property Label As String
[C#]
public string Label {virtual get; virtual set;}
[C++]
public: __property virtual String* get_Label();
public: __property virtual void set_Label(String*);
[JScript]
public function get Label() : String;
public function set Label(String);

See Also

MessageQueueCriteria Class | MessageQueueCriteria Members | System.Messaging Namespace


MessageQueueCriteria.MachineName

Specifies the machine name that will be used as the criteria to search queues in the network.

[Visual Basic]
Overridable Public Property MachineName As String
[C#]
public string MachineName {virtual get; virtual set;}
[C++]
public: __property virtual String* get_MachineName();
public: __property virtual void set_MachineName(String*);
[JScript]
public function get MachineName() : String;
public function set MachineName(String);

See Also

MessageQueueCriteria Class | MessageQueueCriteria Members | System.Messaging Namespace


MessageQueueCriteria.ModifiedAfter

Specifies the lower bound of the interval that will be used as the queue modified time search criteria.

[Visual Basic]
Overridable Public Property ModifiedAfter As DateTime
[C#]
public DateTime ModifiedAfter {virtual get; virtual set;}
[C++]
public: __property virtual DateTime get_ModifiedAfter();
public: __property virtual void set_ModifiedAfter(DateTime);
[JScript]
public function get ModifiedAfter() : DateTime;
public function set ModifiedAfter(DateTime);

See Also

MessageQueueCriteria Class | MessageQueueCriteria Members | System.Messaging Namespace


MessageQueueCriteria.ModifiedBefore

Specifies the upper bound of the interval that will be used as the queue modified time search criteria.

[Visual Basic]
Overridable Public Property ModifiedBefore As DateTime
[C#]
public DateTime ModifiedBefore {virtual get; virtual set;}
[C++]
public: __property virtual DateTime get_ModifiedBefore();
public: __property virtual void set_ModifiedBefore(DateTime);
[JScript]
public function get ModifiedBefore() : DateTime;
public function set ModifiedBefore(DateTime);

See Also

MessageQueueCriteria Class | MessageQueueCriteria Members | System.Messaging Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MessageQueueCriteria Methods

The methods of the MessageQueueCriteria class are listed below. For a complete list of MessageQueueCriteria class members, see the MessageQueueCriteria Members topic.

Public:

ClearAll | Resets all the current instance settings.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MessageQueueCriteria Class | System.Messaging Namespace


MessageQueueCriteria.ClearAll

Resets all the current instance settings.

[Visual Basic]
Overridable Public Sub ClearAll()
[C#]
public virtual void ClearAll();
[C++]
public: virtual void ClearAll();
[JScript]
public function ClearAll();

See Also

MessageQueueCriteria Class | MessageQueueCriteria Members | System.Messaging Namespace


MessageQueueException Class

Is thrown if a Microsoft Message Queue Server (MSMQ) internal error occurs.

Object
Exception
SystemException
ExternalException
MessageQueueException

[Visual Basic]
Public Class MessageQueueException
   Inherits ExternalException
[C#]
public class MessageQueueException : ExternalException
[C++]
public __gc class MessageQueueException : public ExternalException
[JScript]
public class MessageQueueException extends ExternalException

Remarks

Internal errors are generated by internal exceptions on MSMQ that must be dealt with through your code. You must trap and handle exceptions raised when getting queue and message properties.

Requirements

Namespace: System.Messaging

Assembly: system.messaging.dll

See Also

MessageQueueException Members | System.Messaging Namespace


MessageQueueException Members

Public:

Constructor

MessageQueueException Constructor Initializes a new instance of the MessageQueueException class.

Properties

ErrorCode (inherited from ExternalException) | [To be supplied.]
HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

MessageQueueException Class | System.Messaging Namespace


MessageQueueException Constructor

Initializes a new instance of the MessageQueueException class.

[Visual Basic]
Public Sub New( _
   ByVal error As Integer _
)
[C#]
public MessageQueueException(
   int error
);
[C++]
public: MessageQueueException(
   int error
);
[JScript]
public function MessageQueueException(
   error : int
);

Parameters

error
The system code value that represents the error message.

Remarks

The value thatrepresents corresponds to a constant defined in the QueueErrors class.

See Also

MessageQueueException Class | MessageQueueException Members | System.Messaging Namespace


MessageQueueInstaller Class

[To be supplied.]

Object
Component
Installer
ComponentInstaller
MessageQueueInstaller

[Visual Basic]
Public Class MessageQueueInstaller
   Inherits ComponentInstaller
[C#]
public class MessageQueueInstaller : ComponentInstaller
[C++]
public __gc class MessageQueueInstaller : public ComponentInstaller
[JScript]
public class MessageQueueInstaller extends ComponentInstaller

Remarks

[To be supplied.]

Requirements

Namespace: System.Messaging

Assembly: system.messaging.dll

See Also

MessageQueueInstaller Members | System.Messaging Namespace


MessageQueueInstaller Members

Public:

Constructor

MessageQueueInstaller Constructor Overloaded. [To be supplied.]

Properties

Authenticate | Specifies whether or not the queue only accepts authenticated messages.
BasePriority | A public queue's base priority is used for routing the queue's messages over the network. It can be used to give the messages sent to the queue a higher (or lower) priority than messages sent to other queues.
Category | The queue's type allows applications to categorize their queues according to how they are used.
Context (inherited from Installer) | Gets or sets information about the current installation.
EncryptionRequired | Specifies whether or not the queue only accepts private (encrypted) messages.
HelpText (inherited from Installer) | Gets the help text for all of the Installer objects contained in the Installers collection of this installer instance.
Installers (inherited from Installer) | Gets the collection of Installer objects contained in this Installer instance.
Label | Specifies a description of the queue.
MaximumJournalSize | Specifies the maximum size (in kilobytes) of the journal queue.
MaximumQueueSize | Specifies the maximum size (in kilobytes) of the queue.
Parent (inherited from Installer) | Gets or sets the Installer whose InstallerCollection contains this Installer instance.
Path | Specifies the location of the queue that will be referenced by this object. The syntax is: Public Queue: machineName\queueName Private Queue: machineName\Private$\queueName Journal Queue: machineName\queueName\Journal$ Machine Journal Queue: machineName\Journal$ Machine Deadletter Queue: machineName\Deadletter$ Machine Transactional Deadletter Queue: machineName\XactDeadletter$ Reference by format name FormatName:[format name] Referece by label Label:[label] Note: Use . for local machine.
Site (inherited from Component) | Gets or sets the site of the Component.
Transactional | If a queue is transactional, it can only accept messages that are sent as part of a transaction. However, messages can be retrieved from a local transaction queue with or without using a transaction.
UninstallAction | Determines what the installer does with the queue at uninstall time: remove it, restore it to how it was before Install, or leave it installed.
UseJournalQueue | Specifies if messages retrieved from the queue are also copied to its journal queue.

Methods

Commit | [To be supplied.]
CopyFromComponent | [To be supplied.]
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Install | [To be supplied.]
Rollback | [To be supplied.]
ShouldPersistCategory | [To be supplied.]
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
Uninstall | [To be supplied.]

Events

AfterCommit (inherited from Installer) | Occurs after the installations handled by the installers in the InstallerCollection of this instance are committed.
AfterInstall (inherited from Installer) | Occurs after the Install methods of all the installers in the InstallerCollection of this instance have run.
AfterRollback (inherited from Installer) | Occurs after the installations handled by the installers in the InstallerCollection of this instance are rolled back.
AfterUninstall (inherited from Installer) | Occurs after the installations handled by the installers in the InstallerCollection of this instance are uninstalled.
BeforeCommit (inherited from Installer) | Occurs before the installations handled by the installers in the InstallerCollection of this instance are committed.
BeforeInstall (inherited from Installer) | Occurs before the installers in the InstallerCollection of this instance are run.
BeforeRollback (inherited from Installer) | Occurs before the installations handled by the installers in the InstallerCollection of this instance are rolled back.
BeforeUninstall (inherited from Installer) | Occurs before the installations handled by the installers in the InstallerCollection of this instance are uninstalled.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCommit (inherited from Installer) | Raises the OnAfterCommit event.
OnAfterInstall (inherited from Installer) | Raises the OnAfterInstall event.
OnAfterRollback (inherited from Installer) | Raises the OnAfterRollback event.
OnAfterUninstall (inherited from Installer) | Raises the OnAfterUninstall event.
OnBeforeCommit (inherited from Installer) | Raises the OnBeforeCommit event.
OnBeforeInstall (inherited from Installer) | Raises the OnBeforeInstall event.
OnBeforeRollback (inherited from Installer) | Raises the OnBeforeRollback event.
OnBeforeUninstall (inherited from Installer) | Raises the OnBeforeUninstall event.

Event Hookup:

Methods

AddOnAfterCommit (inherited from Installer) | [To be supplied.]
AddOnAfterInstall (inherited from Installer) | [To be supplied.]
AddOnAfterRollback (inherited from Installer) | [To be supplied.]
AddOnAfterUninstall (inherited from Installer) | [To be supplied.]
AddOnBeforeCommit (inherited from Installer) | [To be supplied.]
AddOnBeforeInstall (inherited from Installer) | [To be supplied.]
AddOnBeforeRollback (inherited from Installer) | [To be supplied.]
AddOnBeforeUninstall (inherited from Installer) | [To be supplied.]
RemoveOnAfterCommit (inherited from Installer) | [To be supplied.]
RemoveOnAfterInstall (inherited from Installer) | [To be supplied.]
RemoveOnAfterRollback (inherited from Installer) | [To be supplied.]
RemoveOnAfterUninstall (inherited from Installer) | [To be supplied.]
RemoveOnBeforeCommit (inherited from Installer) | [To be supplied.]
RemoveOnBeforeInstall (inherited from Installer) | [To be supplied.]
RemoveOnBeforeRollback (inherited from Installer) | [To be supplied.]
RemoveOnBeforeUninstall (inherited from Installer) | [To be supplied.]

See Also

MessageQueueInstaller Class | System.Messaging Namespace


MessageQueueInstaller Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public MessageQueueInstaller();
[C++] public: MessageQueueInstaller();
[JScript] public function MessageQueueInstaller();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(MessageQueue)
[C#] public MessageQueueInstaller(MessageQueue);
[C++] public: MessageQueueInstaller(MessageQueue*);
[JScript] public function MessageQueueInstaller(MessageQueue);

See Also

MessageQueueInstaller Class | MessageQueueInstaller Members | System.Messaging Namespace


MessageQueueInstaller Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public MessageQueueInstaller();
[C++]
public: MessageQueueInstaller();
[JScript]
public function MessageQueueInstaller();

See Also

MessageQueueInstaller Class | MessageQueueInstaller Members | System.Messaging Namespace | MessageQueueInstaller Constructor Overload List


MessageQueueInstaller Constructor (MessageQueue)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal componentToCopy As MessageQueue _
)
[C#]
public MessageQueueInstaller(
   MessageQueue componentToCopy
);
[C++]
public: MessageQueueInstaller(
   MessageQueue* componentToCopy
);
[JScript]
public function MessageQueueInstaller(
   componentToCopy : MessageQueue
);

Parameters

componentToCopy
[To be supplied.]

See Also

MessageQueueInstaller Class | MessageQueueInstaller Members | System.Messaging Namespace | MessageQueueInstaller Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MessageQueueInstaller Properties

The properties of the MessageQueueInstaller class are listed below. For a complete list of MessageQueueInstaller class members, see the MessageQueueInstaller Members topic.

Public:

Authenticate | Specifies whether or not the queue only accepts authenticated messages.
BasePriority | A public queue's base priority is used for routing the queue's messages over the network. It can be used to give the messages sent to the queue a higher (or lower) priority than messages sent to other queues.
Category | The queue's type allows applications to categorize their queues according to how they are used.
Context (inherited from Installer) | Gets or sets information about the current installation.
EncryptionRequired | Specifies whether or not the queue only accepts private (encrypted) messages.
HelpText (inherited from Installer) | Gets the help text for all of the Installer objects contained in the Installers collection of this installer instance.
Installers (inherited from Installer) | Gets the collection of Installer objects contained in this Installer instance.
Label | Specifies a description of the queue.
MaximumJournalSize | Specifies the maximum size (in kilobytes) of the journal queue.
MaximumQueueSize | Specifies the maximum size (in kilobytes) of the queue.
Parent (inherited from Installer) | Gets or sets the Installer whose InstallerCollection contains this Installer instance.
Path | Specifies the location of the queue that will be referenced by this object. The syntax is: Public Queue: machineName\queueName Private Queue: machineName\Private$\queueName Journal Queue: machineName\queueName\Journal$ Machine Journal Queue: machineName\Journal$ Machine Deadletter Queue: machineName\Deadletter$ Machine Transactional Deadletter Queue: machineName\XactDeadletter$ Reference by format name FormatName:[format name] Referece by label Label:[label] Note: Use . for local machine.
Site (inherited from Component) | Gets or sets the site of the Component.
Transactional | If a queue is transactional, it can only accept messages that are sent as part of a transaction. However, messages can be retrieved from a local transaction queue with or without using a transaction.
UninstallAction | Determines what the installer does with the queue at uninstall time: remove it, restore it to how it was before Install, or leave it installed.
UseJournalQueue | Specifies if messages retrieved from the queue are also copied to its journal queue.

See Also

MessageQueueInstaller Class | System.Messaging Namespace


MessageQueueInstaller.Authenticate

Specifies whether or not the queue only accepts authenticated messages.

[Visual Basic]
Public Property Authenticate As Boolean
[C#]
public bool Authenticate {get; set;}
[C++]
public: __property bool get_Authenticate();
public: __property void set_Authenticate(bool);
[JScript]
public function get Authenticate() : Boolean;
public function set Authenticate(Boolean);

See Also

MessageQueueInstaller Class | MessageQueueInstaller Members | System.Messaging Namespace


MessageQueueInstaller.BasePriority

A public queue's base priority is used for routing the queue's messages over the network. It can be used to give the messages sent to the queue a higher (or lower) priority than messages sent to other queues.

[Visual Basic]
Public Property BasePriority As Short
[C#]
public short BasePriority {get; set;}
[C++]
public: __property short get_BasePriority();
public: __property void set_BasePriority(short);
[JScript]
public function get BasePriority() : Int16;
public function set BasePriority(Int16);

See Also

MessageQueueInstaller Class | MessageQueueInstaller Members | System.Messaging Namespace


MessageQueueInstaller.Category

The queue's type allows applications to categorize their queues according to how they are used.

[Visual Basic]
Public Property Category As Guid
[C#]
public Guid Category {get; set;}
[C++]
public: __property Guid get_Category();
public: __property void set_Category(Guid);
[JScript]
public function get Category() : Guid;
public function set Category(Guid);

See Also

MessageQueueInstaller Class | MessageQueueInstaller Members | System.Messaging Namespace


MessageQueueInstaller.EncryptionRequired

Specifies whether or not the queue only accepts private (encrypted) messages.

[Visual Basic]
Public Property EncryptionRequired As EncryptionRequired
[C#]
public EncryptionRequired EncryptionRequired {get; set;}
[C++]
public: __property EncryptionRequired get_EncryptionRequired();
public: __property void set_EncryptionRequired(EncryptionRequired);
[JScript]
public function get EncryptionRequired() : EncryptionRequired;
public function set EncryptionRequired(EncryptionRequired);

See Also

MessageQueueInstaller Class | MessageQueueInstaller Members | System.Messaging Namespace


MessageQueueInstaller.Label

Specifies a description of the queue.

[Visual Basic]
Public Property Label As String
[C#]
public string Label {get; set;}
[C++]
public: __property String* get_Label();
public: __property void set_Label(String*);
[JScript]
public function get Label() : String;
public function set Label(String);

See Also

MessageQueueInstaller Class | MessageQueueInstaller Members | System.Messaging Namespace


MessageQueueInstaller.MaximumJournalSize

Specifies the maximum size (in kilobytes) of the journal queue.

[Visual Basic]
Public Property MaximumJournalSize As Long
[C#]
public long MaximumJournalSize {get; set;}
[C++]
public: __property __int64 get_MaximumJournalSize();
public: __property void set_MaximumJournalSize(__int64);
[JScript]
public function get MaximumJournalSize() : long;
public function set MaximumJournalSize(long);

See Also

MessageQueueInstaller Class | MessageQueueInstaller Members | System.Messaging Namespace


MessageQueueInstaller.MaximumQueueSize

Specifies the maximum size (in kilobytes) of the queue.

[Visual Basic]
Public Property MaximumQueueSize As Long
[C#]
public long MaximumQueueSize {get; set;}
[C++]
public: __property __int64 get_MaximumQueueSize();
public: __property void set_MaximumQueueSize(__int64);
[JScript]
public function get MaximumQueueSize() : long;
public function set MaximumQueueSize(long);

See Also

MessageQueueInstaller Class | MessageQueueInstaller Members | System.Messaging Namespace


MessageQueueInstaller.Path

Specifies the location of the queue that will be referenced by this object. The syntax is: Public Queue: machineName\queueName Private Queue: machineName\Private$\queueName Journal Queue: machineName\queueName\Journal$ Machine Journal Queue: machineName\Journal$ Machine Deadletter Queue: machineName\Deadletter$ Machine Transactional Deadletter Queue: machineName\XactDeadletter$ Reference by format name FormatName:[format name] Referece by label Label:[label] Note: Use . for local machine.

[Visual Basic]
Public Property Path As String
[C#]
public string Path {get; set;}
[C++]
public: __property String* get_Path();
public: __property void set_Path(String*);
[JScript]
public function get Path() : String;
public function set Path(String);

See Also

MessageQueueInstaller Class | MessageQueueInstaller Members | System.Messaging Namespace


MessageQueueInstaller.Transactional

If a queue is transactional, it can only accept messages that are sent as part of a transaction. However, messages can be retrieved from a local transaction queue with or without using a transaction.

[Visual Basic]
Public Property Transactional As Boolean
[C#]
public bool Transactional {get; set;}
[C++]
public: __property bool get_Transactional();
public: __property void set_Transactional(bool);
[JScript]
public function get Transactional() : Boolean;
public function set Transactional(Boolean);

See Also

MessageQueueInstaller Class | MessageQueueInstaller Members | System.Messaging Namespace


MessageQueueInstaller.UninstallAction

Determines what the installer does with the queue at uninstall time: remove it, restore it to how it was before Install, or leave it installed.

[Visual Basic]
Public Property UninstallAction As UninstallAction
[C#]
public UninstallAction UninstallAction {get; set;}
[C++]
public: __property UninstallAction get_UninstallAction();
public: __property void set_UninstallAction(UninstallAction);
[JScript]
public function get UninstallAction() : UninstallAction;
public function set UninstallAction(UninstallAction);

See Also

MessageQueueInstaller Class | MessageQueueInstaller Members | System.Messaging Namespace


MessageQueueInstaller.UseJournalQueue

Specifies if messages retrieved from the queue are also copied to its journal queue.

[Visual Basic]
Public Property UseJournalQueue As Boolean
[C#]
public bool UseJournalQueue {get; set;}
[C++]
public: __property bool get_UseJournalQueue();
public: __property void set_UseJournalQueue(bool);
[JScript]
public function get UseJournalQueue() : Boolean;
public function set UseJournalQueue(Boolean);

See Also

MessageQueueInstaller Class | MessageQueueInstaller Members | System.Messaging Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MessageQueueInstaller Methods

The methods of the MessageQueueInstaller class are listed below. For a complete list of MessageQueueInstaller class members, see the MessageQueueInstaller Members topic.

Public:

Commit | [To be supplied.]
CopyFromComponent | [To be supplied.]
Dispose (inherited from Component) | Disposes of the Component.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetContainer (inherited from Component) | Returns the IContainer that contains the Component.
GetDesignMode (inherited from Component) | Gets a value indicating whether the Component is currently in design mode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetServiceObject (inherited from Component) | Returns an object representing a service provided by the Component.
GetType (inherited from Object) | Gets the Type of the Object.
Install | [To be supplied.]
Rollback | [To be supplied.]
ShouldPersistCategory | [To be supplied.]
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden. For internal use only.
Uninstall | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCommit (inherited from Installer) | Raises the OnAfterCommit event.
OnAfterInstall (inherited from Installer) | Raises the OnAfterInstall event.
OnAfterRollback (inherited from Installer) | Raises the OnAfterRollback event.
OnAfterUninstall (inherited from Installer) | Raises the OnAfterUninstall event.
OnBeforeCommit (inherited from Installer) | Raises the OnBeforeCommit event.
OnBeforeInstall (inherited from Installer) | Raises the OnBeforeInstall event.
OnBeforeRollback (inherited from Installer) | Raises the OnBeforeRollback event.
OnBeforeUninstall (inherited from Installer) | Raises the OnBeforeUninstall event.

Event Hookup:

AddOnAfterCommit (inherited from Installer) | [To be supplied.]
AddOnAfterInstall (inherited from Installer) | [To be supplied.]
AddOnAfterRollback (inherited from Installer) | [To be supplied.]
AddOnAfterUninstall (inherited from Installer) | [To be supplied.]
AddOnBeforeCommit (inherited from Installer) | [To be supplied.]
AddOnBeforeInstall (inherited from Installer) | [To be supplied.]
AddOnBeforeRollback (inherited from Installer) | [To be supplied.]
AddOnBeforeUninstall (inherited from Installer) | [To be supplied.]
RemoveOnAfterCommit (inherited from Installer) | [To be supplied.]
RemoveOnAfterInstall (inherited from Installer) | [To be supplied.]
RemoveOnAfterRollback (inherited from Installer) | [To be supplied.]
RemoveOnAfterUninstall (inherited from Installer) | [To be supplied.]
RemoveOnBeforeCommit (inherited from Installer) | [To be supplied.]
RemoveOnBeforeInstall (inherited from Installer) | [To be supplied.]
RemoveOnBeforeRollback (inherited from Installer) | [To be supplied.]
RemoveOnBeforeUninstall (inherited from Installer) | [To be supplied.]

See Also

MessageQueueInstaller Class | System.Messaging Namespace


MessageQueueInstaller.Commit

[To be supplied.]

[Visual Basic]
Overrides Public Sub Commit( _
   ByVal state As IDictionary _
)
[C#]
public override void Commit(
   IDictionary state
);
[C++]
public: override void Commit(
   IDictionary* state
);
[JScript]
public override function Commit(
   state : IDictionary
);

Parameters

state
[To be supplied.]

See Also

MessageQueueInstaller Class | MessageQueueInstaller Members | System.Messaging Namespace


MessageQueueInstaller.CopyFromComponent

[To be supplied.]

[Visual Basic]
Overrides Public Sub CopyFromComponent( _
   ByVal component As IComponent _
)
[C#]
public override void CopyFromComponent(
   IComponent component
);
[C++]
public: override void CopyFromComponent(
   IComponent* component
);
[JScript]
public override function CopyFromComponent(
   component : IComponent
);

Parameters

component
[To be supplied.]

See Also

MessageQueueInstaller Class | MessageQueueInstaller Members | System.Messaging Namespace


MessageQueueInstaller.Install

[To be supplied.]

[Visual Basic]
Overrides Public Sub Install( _
   ByVal state As IDictionary _
)
[C#]
public override void Install(
   IDictionary state
);
[C++]
public: override void Install(
   IDictionary* state
);
[JScript]
public override function Install(
   state : IDictionary
);

Parameters

state
[To be supplied.]

See Also

MessageQueueInstaller Class | MessageQueueInstaller Members | System.Messaging Namespace


MessageQueueInstaller.Rollback

[To be supplied.]

[Visual Basic]
Overrides Public Sub Rollback( _
   ByVal state As IDictionary _
)
[C#]
public override void Rollback(
   IDictionary state
);
[C++]
public: override void Rollback(
   IDictionary* state
);
[JScript]
public override function Rollback(
   state : IDictionary
);

Parameters

state
[To be supplied.]

See Also

MessageQueueInstaller Class | MessageQueueInstaller Members | System.Messaging Namespace


MessageQueueInstaller.ShouldPersistCategory

[To be supplied.]

[Visual Basic]
Public Function ShouldPersistCategory() As Boolean
[C#]
public bool ShouldPersistCategory();
[C++]
public: bool ShouldPersistCategory();
[JScript]
public function ShouldPersistCategory() : Boolean;

See Also

MessageQueueInstaller Class | MessageQueueInstaller Members | System.Messaging Namespace


MessageQueueInstaller.Uninstall

[To be supplied.]

[Visual Basic]
Overrides Public Sub Uninstall( _
   ByVal state As IDictionary _
)
[C#]
public override void Uninstall(
   IDictionary state
);
[C++]
public: override void Uninstall(
   IDictionary* state
);
[JScript]
public override function Uninstall(
   state : IDictionary
);

Parameters

state
[To be supplied.]

See Also

MessageQueueInstaller Class | MessageQueueInstaller Members | System.Messaging Namespace


MessageQueuesEnumerator Class

[To be supplied.]

Object
MessageQueuesEnumerator

[Visual Basic]
Public Class MessageQueuesEnumerator
   Implements IEnumerator
[C#]
public class MessageQueuesEnumerator : IEnumerator
[C++]
public __gc class MessageQueuesEnumerator : public IEnumerator
[JScript]
public class MessageQueuesEnumerator implements IEnumerator

Remarks

[To be supplied.]

Requirements

Namespace: System.Messaging

Assembly: system.messaging.dll

See Also

MessageQueuesEnumerator Members | System.Messaging Namespace


MessageQueuesEnumerator Members

Public:

Properties

Current | Returns the current MessageQueue of the enumeration. Before the first call to MoveNext and following a call to MoveNext that returned false an InvalidOperationException will be thrown. Multiple calls to Current with no intervening calls to MoveNext will return the same MessageQueue object.
LocatorHandle | The native MSMQ handle used to locate queues in a network.

Methods

Close | Frees the resources associated with the enumerator.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
MoveNext | Advances the enumerator to the next MessageQueue of the enumeration and returns a boolean indicating whether a MessageQueue is available. Upon creation, an enumerator is conceptually positioned before the first MessageQueue of the enumeration, and the first call to MoveNext brings the first MessageQueue of the enumeration into view.
Reset | Set the cursor to the begining of the enumeration.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MessageQueuesEnumerator Class | System.Messaging Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MessageQueuesEnumerator Properties

The properties of the MessageQueuesEnumerator class are listed below. For a complete list of MessageQueuesEnumerator class members, see the MessageQueuesEnumerator Members topic.

Public:

Current | Returns the current MessageQueue of the enumeration. Before the first call to MoveNext and following a call to MoveNext that returned false an InvalidOperationException will be thrown. Multiple calls to Current with no intervening calls to MoveNext will return the same MessageQueue object.
LocatorHandle | The native MSMQ handle used to locate queues in a network.

See Also

MessageQueuesEnumerator Class | System.Messaging Namespace


MessageQueuesEnumerator.Current

Returns the current MessageQueue of the enumeration. Before the first call to MoveNext and following a call to MoveNext that returned false an InvalidOperationException will be thrown. Multiple calls to Current with no intervening calls to MoveNext will return the same MessageQueue object.

[Visual Basic]
Overridable Public ReadOnly Property Current As Object
[C#]
public object Current {virtual get;}
[C++]
public: __property virtual Object* get_Current();
[JScript]
public function get Current() : Object;

See Also

MessageQueuesEnumerator Class | MessageQueuesEnumerator Members | System.Messaging Namespace


MessageQueuesEnumerator.LocatorHandle

The native MSMQ handle used to locate queues in a network.

[Visual Basic]
Overridable Public ReadOnly Property LocatorHandle As Integer
[C#]
public int LocatorHandle {virtual get;}
[C++]
public: __property virtual int get_LocatorHandle();
[JScript]
public function get LocatorHandle() : int;

See Also

MessageQueuesEnumerator Class | MessageQueuesEnumerator Members | System.Messaging Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MessageQueuesEnumerator Methods

The methods of the MessageQueuesEnumerator class are listed below. For a complete list of MessageQueuesEnumerator class members, see the MessageQueuesEnumerator Members topic.

Public:

Close | Frees the resources associated with the enumerator.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
MoveNext | Advances the enumerator to the next MessageQueue of the enumeration and returns a boolean indicating whether a MessageQueue is available. Upon creation, an enumerator is conceptually positioned before the first MessageQueue of the enumeration, and the first call to MoveNext brings the first MessageQueue of the enumeration into view.
Reset | Set the cursor to the begining of the enumeration.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MessageQueuesEnumerator Class | System.Messaging Namespace


MessageQueuesEnumerator.Close

Frees the resources associated with the enumerator.

[Visual Basic]
Public Sub Close()
[C#]
public void Close();
[C++]
public: void Close();
[JScript]
public function Close();

See Also

MessageQueuesEnumerator Class | MessageQueuesEnumerator Members | System.Messaging Namespace


MessageQueuesEnumerator.Finalize

[To be supplied.]

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

MessageQueuesEnumerator Class | MessageQueuesEnumerator Members | System.Messaging Namespace


MessageQueuesEnumerator.MoveNext

Advances the enumerator to the next MessageQueue of the enumeration and returns a boolean indicating whether a MessageQueue is available. Upon creation, an enumerator is conceptually positioned before the first MessageQueue of the enumeration, and the first call to MoveNext brings the first MessageQueue of the enumeration into view.

[Visual Basic]
Overridable Public Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;

Return Value

true if the enumerator was succesfully advanced to the next MessageQueue, false if the enumeration has been completed.

See Also

MessageQueuesEnumerator Class | MessageQueuesEnumerator Members | System.Messaging Namespace


MessageQueuesEnumerator.Reset

Set the cursor to the begining of the enumeration.

[Visual Basic]
Overridable Public Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();

See Also

MessageQueuesEnumerator Class | MessageQueuesEnumerator Members | System.Messaging Namespace


MessagesEnumerator Class

Provides forward only cursor semantics to enumerate the messages contained in a queue. Each instance of this object uses a separate cursor.

Object
MessagesEnumerator

[Visual Basic]
Public Class MessagesEnumerator
   Implements IEnumerator
[C#]
public class MessagesEnumerator : IEnumerator
[C++]
public __gc class MessagesEnumerator : public IEnumerator
[JScript]
public class MessagesEnumerator implements IEnumerator

Remarks

[To be supplied.]

Requirements

Namespace: System.Messaging

Assembly: system.messaging.dll

See Also

MessagesEnumerator Members | System.Messaging Namespace


MessagesEnumerator Members

Public:

Properties

Current | Returns the current Message of the enumeration. Before the first call to MoveNext and following a call to MoveNext that returned false an InvalidOperationException will be thrown.
CursorHandle | The native MSMQ cursor handle used to browse messages in the queue..

Methods

Close | Frees the resources associated with the enumerator.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
MoveNext | Overloaded. [To be supplied.]
Remove | Removes the current message from the underlying set of messages.
RemoveObject | Removes the current message from the underlying set of messages.
Reset | Resets the current enumerator, so it starts from the the head of the queue.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MessagesEnumerator Class | System.Messaging Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MessagesEnumerator Properties

The properties of the MessagesEnumerator class are listed below. For a complete list of MessagesEnumerator class members, see the MessagesEnumerator Members topic.

Public:

Current | Returns the current Message of the enumeration. Before the first call to MoveNext and following a call to MoveNext that returned false an InvalidOperationException will be thrown.
CursorHandle | The native MSMQ cursor handle used to browse messages in the queue..

See Also

MessagesEnumerator Class | System.Messaging Namespace


MessagesEnumerator.Current

Returns the current Message of the enumeration. Before the first call to MoveNext and following a call to MoveNext that returned false an InvalidOperationException will be thrown.

[Visual Basic]
Overridable Public ReadOnly Property Current As Object
[C#]
public object Current {virtual get;}
[C++]
public: __property virtual Object* get_Current();
[JScript]
public function get Current() : Object;

Property Value

the current message of the enumeration.

See Also

MessagesEnumerator Class | MessagesEnumerator Members | System.Messaging Namespace


MessagesEnumerator.CursorHandle

The native MSMQ cursor handle used to browse messages in the queue..

[Visual Basic]
Overridable Public ReadOnly Property CursorHandle As Integer
[C#]
public int CursorHandle {virtual get;}
[C++]
public: __property virtual int get_CursorHandle();
[JScript]
public function get CursorHandle() : int;

See Also

MessagesEnumerator Class | MessagesEnumerator Members | System.Messaging Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MessagesEnumerator Methods

The methods of the MessagesEnumerator class are listed below. For a complete list of MessagesEnumerator class members, see the MessagesEnumerator Members topic.

Public:

Close | Frees the resources associated with the enumerator.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
MoveNext | Overloaded. [To be supplied.]
Remove | Removes the current message from the underlying set of messages.
RemoveObject | Removes the current message from the underlying set of messages.
Reset | Resets the current enumerator, so it starts from the the head of the queue.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MessagesEnumerator Class | System.Messaging Namespace


MessagesEnumerator.Close

Frees the resources associated with the enumerator.

[Visual Basic]
Public Sub Close()
[C#]
public void Close();
[C++]
public: void Close();
[JScript]
public function Close();

See Also

MessagesEnumerator Class | MessagesEnumerator Members | System.Messaging Namespace


MessagesEnumerator.Finalize

[To be supplied.]

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

MessagesEnumerator Class | MessagesEnumerator Members | System.Messaging Namespace


MessagesEnumerator.MoveNext

[To be supplied.]

Overload List

Advances the enumerator to the next message of the enumeration and returns a boolean indicating whether a message is available, if the enumerator is positioned at the end of the queue, this operation will wait until a message is available or the given timeout expires. Upon creation, an enumerator is conceptually positioned before the first message of the enumeration, and the first call to MoveNext brings the first message of the enumeration into view.

[Visual Basic] Overloads Public Function MoveNext(TimeSpan) As Boolean
[C#] public bool MoveNext(TimeSpan);
[C++] public: bool MoveNext(TimeSpan);
[JScript] public function MoveNext(TimeSpan) : Boolean;

Advances the enumerator to the next message of the enumeration and returns a boolean indicating whether a message is available. Upon creation, an enumerator is conceptually positioned before the first message of the enumeration, and the first call to MoveNext brings the first message of the enumeration into view.

[Visual Basic] Overloads Overridable Public Function MoveNext() As Boolean
[C#] public virtual bool MoveNext();
[C++] public: virtual bool MoveNext();
[JScript] public function MoveNext() : Boolean;

See Also

MessagesEnumerator Class | MessagesEnumerator Members | System.Messaging Namespace


MessagesEnumerator.MoveNext (TimeSpan)

Advances the enumerator to the next message of the enumeration and returns a boolean indicating whether a message is available, if the enumerator is positioned at the end of the queue, this operation will wait until a message is available or the given timeout expires. Upon creation, an enumerator is conceptually positioned before the first message of the enumeration, and the first call to MoveNext brings the first message of the enumeration into view.

[Visual Basic]
Overloads Public Function MoveNext( _
   ByVal timeout As TimeSpan _
) As Boolean
[C#]
public bool MoveNext(
   TimeSpan timeout
);
[C++]
public: bool MoveNext(
   TimeSpan timeout
);
[JScript]
public function MoveNext(
   timeout : TimeSpan
) : Boolean;

Parameters

timeout
the time to wait for a message to be available if the enumerator is positioned at the end of the queue.

Return Value

true if the enumerator was succesfully advanced to the next message, false if the enumeration has been completed.

See Also

MessagesEnumerator Class | MessagesEnumerator Members | System.Messaging Namespace | MessagesEnumerator.MoveNext Overload List


MessagesEnumerator.MoveNext ()

Advances the enumerator to the next message of the enumeration and returns a boolean indicating whether a message is available. Upon creation, an enumerator is conceptually positioned before the first message of the enumeration, and the first call to MoveNext brings the first message of the enumeration into view.

[Visual Basic]
Overloads Overridable Public Function MoveNext() As Boolean
[C#]
public virtual bool MoveNext();
[C++]
public: virtual bool MoveNext();
[JScript]
public function MoveNext() : Boolean;

Return Value

true if the enumerator was succesfully advanced to the next message, false if the enumeration has been completed.

See Also

MessagesEnumerator Class | MessagesEnumerator Members | System.Messaging Namespace | MessagesEnumerator.MoveNext Overload List


MessagesEnumerator.Remove

Removes the current message from the underlying set of messages.

[Visual Basic]
Public Sub Remove()
[C#]
public void Remove();
[C++]
public: void Remove();
[JScript]
public function Remove();

Exceptions

Exception Type | Condition
ArgumentException | if the MoveNext method has not yet been called or if the last call to the MoveNext method returned false.
MessageQueueException | if problems when accessing MSMQ.

See Also

MessagesEnumerator Class | MessagesEnumerator Members | System.Messaging Namespace


MessagesEnumerator.RemoveObject

Removes the current message from the underlying set of messages.

[Visual Basic]
Public Function RemoveObject() As Object
[C#]
public object RemoveObject();
[C++]
public: Object* RemoveObject();
[JScript]
public function RemoveObject() : Object;

Return Value

the message that was just removed.

See Also

MessagesEnumerator Class | MessagesEnumerator Members | System.Messaging Namespace


MessagesEnumerator.Reset

Resets the current enumerator, so it starts from the the head of the queue.

[Visual Basic]
Overridable Public Sub Reset()
[C#]
public virtual void Reset();
[C++]
public: virtual void Reset();
[JScript]
public function Reset();

See Also

MessagesEnumerator Class | MessagesEnumerator Members | System.Messaging Namespace


MessageType Enumeration

A message can be a normal MSMQ message, a positive or negative (arrival and read) acknowledgment message, or a report message.

[Visual Basic]
Public Enum MessageType
[C#]
public enum MessageType
[C++]
public enum MessageType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Acknowledgement | [To be supplied.]
Normal | [To be supplied.]
Report | [To be supplied.]

Requirements

Namespace: System.Messaging

Assembly: system.messaging.dll

See Also

System.Messaging Namespace


PeekAsyncEventArgs Class

Contains the event information that is generated when an MessageQueue asynchronous Peek operation is completed.

Object
EventArgs
PeekAsyncEventArgs

[Visual Basic]
Public Class PeekAsyncEventArgs
   Inherits EventArgs
[C#]
public class PeekAsyncEventArgs : EventArgs
[C++]
public __gc class PeekAsyncEventArgs : public EventArgs
[JScript]
public class PeekAsyncEventArgs extends EventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.Messaging

Assembly: system.messaging.dll

See Also

PeekAsyncEventArgs Members | System.Messaging Namespace | MessageQueue


PeekAsyncEventArgs Members

Public:

Properties

AsyncResult | Contains the result of the asynchronous operation requested.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
Message | The end result of the posted asynchronous operation.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PeekAsyncEventArgs Class | System.Messaging Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PeekAsyncEventArgs Properties

The properties of the PeekAsyncEventArgs class are listed below. For a complete list of PeekAsyncEventArgs class members, see the PeekAsyncEventArgs Members topic.

Public:

AsyncResult | Contains the result of the asynchronous operation requested.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
Message | The end result of the posted asynchronous operation.

See Also

PeekAsyncEventArgs Class | System.Messaging Namespace


PeekAsyncEventArgs.AsyncResult

Contains the result of the asynchronous operation requested.

[Visual Basic]
Public Property AsyncResult As IAsyncResult
[C#]
public IAsyncResult AsyncResult {get; set;}
[C++]
public: __property IAsyncResult* get_AsyncResult();
public: __property void set_AsyncResult(IAsyncResult*);
[JScript]
public function get AsyncResult() : IAsyncResult;
public function set AsyncResult(IAsyncResult);

See Also

PeekAsyncEventArgs Class | PeekAsyncEventArgs Members | System.Messaging Namespace


PeekAsyncEventArgs.Message

The end result of the posted asynchronous operation.

[Visual Basic]
Public ReadOnly Property Message As Message
[C#]
public Message Message {get;}
[C++]
public: __property Message* get_Message();
[JScript]
public function get Message() : Message;

See Also

PeekAsyncEventArgs Class | PeekAsyncEventArgs Members | System.Messaging Namespace


PeekCompletedEventHandler Delegate

[To be supplied.]

[Visual Basic]
Public Delegate Sub PeekCompletedEventHandler( _
   ByVal sender As Object, _
   ByVal args As PeekAsyncEventArgs _
)
[C#]
public delegate void PeekCompletedEventHandler(
   object sender,
   PeekAsyncEventArgs args
);
[C++]
public __gc __delegate void PeekCompletedEventHandler(
   Object* sender,
   PeekAsyncEventArgs* args
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the PeekCompletedEventHandler delegate declaration.

Remarks

[To be supplied.]

Requirements

Namespace: System.Messaging

Assembly: system.messaging.dll

See Also

System.Messaging Namespace


ReceiveAsyncEventArgs Class

Contains the event information that is generated when an MessageQueue asynchronous Receive operation is completed.

Object
EventArgs
ReceiveAsyncEventArgs

[Visual Basic]
Public Class ReceiveAsyncEventArgs
   Inherits EventArgs
[C#]
public class ReceiveAsyncEventArgs : EventArgs
[C++]
public __gc class ReceiveAsyncEventArgs : public EventArgs
[JScript]
public class ReceiveAsyncEventArgs extends EventArgs

Remarks

[To be supplied.]

Requirements

Namespace: System.Messaging

Assembly: system.messaging.dll

See Also

ReceiveAsyncEventArgs Members | System.Messaging Namespace | MessageQueue


ReceiveAsyncEventArgs Members

Public:

Properties

AsyncResult | Contains the result of the asynchronous operation requested.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
Message | The end result of the posted asynchronous operation.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReceiveAsyncEventArgs Class | System.Messaging Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ReceiveAsyncEventArgs Properties

The properties of the ReceiveAsyncEventArgs class are listed below. For a complete list of ReceiveAsyncEventArgs class members, see the ReceiveAsyncEventArgs Members topic.

Public:

AsyncResult | Contains the result of the asynchronous operation requested.
ExtendedInfo (inherited from EventArgs) | Holds a reference to an object that manages the event's state.
Message | The end result of the posted asynchronous operation.

See Also

ReceiveAsyncEventArgs Class | System.Messaging Namespace


ReceiveAsyncEventArgs.AsyncResult

Contains the result of the asynchronous operation requested.

[Visual Basic]
Public Property AsyncResult As IAsyncResult
[C#]
public IAsyncResult AsyncResult {get; set;}
[C++]
public: __property IAsyncResult* get_AsyncResult();
public: __property void set_AsyncResult(IAsyncResult*);
[JScript]
public function get AsyncResult() : IAsyncResult;
public function set AsyncResult(IAsyncResult);

See Also

ReceiveAsyncEventArgs Class | ReceiveAsyncEventArgs Members | System.Messaging Namespace


ReceiveAsyncEventArgs.Message

The end result of the posted asynchronous operation.

[Visual Basic]
Public ReadOnly Property Message As Message
[C#]
public Message Message {get;}
[C++]
public: __property Message* get_Message();
[JScript]
public function get Message() : Message;

See Also

ReceiveAsyncEventArgs Class | ReceiveAsyncEventArgs Members | System.Messaging Namespace


ReceiveCompletedEventHandler Delegate

[To be supplied.]

[Visual Basic]
Public Delegate Sub ReceiveCompletedEventHandler( _
   ByVal sender As Object, _
   ByVal args As ReceiveAsyncEventArgs _
)
[C#]
public delegate void ReceiveCompletedEventHandler(
   object sender,
   ReceiveAsyncEventArgs args
);
[C++]
public __gc __delegate void ReceiveCompletedEventHandler(
   Object* sender,
   ReceiveAsyncEventArgs* args
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the ReceiveCompletedEventHandler delegate declaration.

Remarks

[To be supplied.]

Requirements

Namespace: System.Messaging

Assembly: system.messaging.dll

See Also

System.Messaging Namespace


SoapMessageFormatter Class

Formatter class that serializes and deserializes objects into and from MessageQueue messages using Xml.

Object
SoapMessageFormatter

[Visual Basic]
Public Class SoapMessageFormatter
   Implements IMessageFormatter
[C#]
public class SoapMessageFormatter : IMessageFormatter
[C++]
public __gc class SoapMessageFormatter : public IMessageFormatter
[JScript]
public class SoapMessageFormatter implements IMessageFormatter

Remarks

[To be supplied.]

Requirements

Namespace: System.Messaging

Assembly: system.messaging.dll

See Also

SoapMessageFormatter Members | System.Messaging Namespace


SoapMessageFormatter Members

Public:

Constructor

SoapMessageFormatter Constructor Overloaded. [To be supplied.]

Properties

TopObjectFormat | Determines how the top (root) object of a graph is laid out in the serialized stream.
TypeFormat | Determines how type descriptions are laid out in the serialized stream.

Methods

CanRead | When this method is called, the formatter will attempt to determine if the contents of the message are something the formatter can deal with.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Read | This method is used to read the contents from the given message and create an object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | This method is used to write the given object into the given message. If the formatter cannot understand the given object, an exception is thrown.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SoapMessageFormatter Class | System.Messaging Namespace


SoapMessageFormatter Constructor

[To be supplied.]

Overload List

Creates a new Soap message formatter object.

[Visual Basic] Overloads Public Sub New()
[C#] public SoapMessageFormatter();
[C++] public: SoapMessageFormatter();
[JScript] public function SoapMessageFormatter();

Creates a new Soap message formatter object with the given properties.

[Visual Basic] Overloads Public Sub New(FormatterTopObjectStyle, FormatterTypeStyle)
[C#] public SoapMessageFormatter(FormatterTopObjectStyle, FormatterTypeStyle);
[C++] public: SoapMessageFormatter(FormatterTopObjectStyle, FormatterTypeStyle);
[JScript] public function SoapMessageFormatter(FormatterTopObjectStyle, FormatterTypeStyle);

See Also

SoapMessageFormatter Class | SoapMessageFormatter Members | System.Messaging Namespace


SoapMessageFormatter Constructor ()

Creates a new Soap message formatter object.

[Visual Basic]
Overloads Public Sub New()
[C#]
public SoapMessageFormatter();
[C++]
public: SoapMessageFormatter();
[JScript]
public function SoapMessageFormatter();

See Also

SoapMessageFormatter Class | SoapMessageFormatter Members | System.Messaging Namespace | SoapMessageFormatter Constructor Overload List


SoapMessageFormatter Constructor (FormatterTopObjectStyle, FormatterTypeStyle)

Creates a new Soap message formatter object with the given properties.

[Visual Basic]
Overloads Public Sub New( _
   ByVal topObjectFormat As FormatterTopObjectStyle, _
   ByVal typeFormat As FormatterTypeStyle _
)
[C#]
public SoapMessageFormatter(
   FormatterTopObjectStyle topObjectFormat,
   FormatterTypeStyle typeFormat
);
[C++]
public: SoapMessageFormatter(
   FormatterTopObjectStyle topObjectFormat,
   FormatterTypeStyle typeFormat
);
[JScript]
public function SoapMessageFormatter(
   topObjectFormat : FormatterTopObjectStyle,
   typeFormat : FormatterTypeStyle
);

Parameters

topObjectFormat
Determines how the top (root) object of a graph is laid out in the serialized stream.
typeFormat
Determines how type descriptions are laid out in the serialized stream.

See Also

SoapMessageFormatter Class | SoapMessageFormatter Members | System.Messaging Namespace | SoapMessageFormatter Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SoapMessageFormatter Properties

The properties of the SoapMessageFormatter class are listed below. For a complete list of SoapMessageFormatter class members, see the SoapMessageFormatter Members topic.

Public:

TopObjectFormat | Determines how the top (root) object of a graph is laid out in the serialized stream.
TypeFormat | Determines how type descriptions are laid out in the serialized stream.

See Also

SoapMessageFormatter Class | System.Messaging Namespace


SoapMessageFormatter.TopObjectFormat

Determines how the top (root) object of a graph is laid out in the serialized stream.

[Visual Basic]
Public Property TopObjectFormat As FormatterTopObjectStyle
[C#]
public FormatterTopObjectStyle TopObjectFormat {get; set;}
[C++]
public: __property FormatterTopObjectStyle get_TopObjectFormat();
public: __property void set_TopObjectFormat(FormatterTopObjectStyle);
[JScript]
public function get TopObjectFormat() : FormatterTopObjectStyle;
public function set TopObjectFormat(FormatterTopObjectStyle);

See Also

SoapMessageFormatter Class | SoapMessageFormatter Members | System.Messaging Namespace


SoapMessageFormatter.TypeFormat

Determines how type descriptions are laid out in the serialized stream.

[Visual Basic]
Public Property TypeFormat As FormatterTypeStyle
[C#]
public FormatterTypeStyle TypeFormat {get; set;}
[C++]
public: __property FormatterTypeStyle get_TypeFormat();
public: __property void set_TypeFormat(FormatterTypeStyle);
[JScript]
public function get TypeFormat() : FormatterTypeStyle;
public function set TypeFormat(FormatterTypeStyle);

See Also

SoapMessageFormatter Class | SoapMessageFormatter Members | System.Messaging Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SoapMessageFormatter Methods

The methods of the SoapMessageFormatter class are listed below. For a complete list of SoapMessageFormatter class members, see the SoapMessageFormatter Members topic.

Public:

CanRead | When this method is called, the formatter will attempt to determine if the contents of the message are something the formatter can deal with.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Read | This method is used to read the contents from the given message and create an object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | This method is used to write the given object into the given message. If the formatter cannot understand the given object, an exception is thrown.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SoapMessageFormatter Class | System.Messaging Namespace


SoapMessageFormatter.CanRead

When this method is called, the formatter will attempt to determine if the contents of the message are something the formatter can deal with.

[Visual Basic]
Overridable Public Function CanRead( _
   ByVal message As Message _
) As Boolean
[C#]
public virtual bool CanRead(
   Message message
);
[C++]
public: virtual bool CanRead(
   Message* message
);
[JScript]
public function CanRead(
   message : Message
) : Boolean;

Parameters

message
the message to be inspected.

Return Value

indicates wehter or not the message passed can be read.

See Also

SoapMessageFormatter Class | SoapMessageFormatter Members | System.Messaging Namespace


SoapMessageFormatter.Read

This method is used to read the contents from the given message and create an object.

[Visual Basic]
Overridable Public Function Read( _
   ByVal message As Message _
) As Object
[C#]
public virtual object Read(
   Message message
);
[C++]
public: virtual Object* Read(
   Message* message
);
[JScript]
public function Read(
   message : Message
) : Object;

Parameters

message
the message to deserialize the object from.

Return Value

the object deserialized from the message.

See Also

SoapMessageFormatter Class | SoapMessageFormatter Members | System.Messaging Namespace


SoapMessageFormatter.Write

This method is used to write the given object into the given message. If the formatter cannot understand the given object, an exception is thrown.

[Visual Basic]
Overridable Public Sub Write( _
   ByVal message As Message, _
   ByVal obj As Object _
)
[C#]
public virtual void Write(
   Message message,
   object obj
);
[C++]
public: virtual void Write(
   Message* message,
   Object* obj
);
[JScript]
public function Write(
   message : Message,
   obj : Object
);

Parameters

message
the message to serialize the object into.
obj
the object to be serialized.

See Also

SoapMessageFormatter Class | SoapMessageFormatter Members | System.Messaging Namespace


System.Net

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Net Namespace

Classes

Class | Description
AuthenticationManager | Manages the authentication modules called during the client authentication process.
AuthenticationScheme | Provides a list of the default authentication types supported by the System.Net namespace.
Authorization | Used for handling and completing a custom authorization.
CredentialCache | Provides storage for multiple credentials.
DefaultControlObject | Stores basic proxy settings for the default proxy.
DNS | Provides simple domain name resolution functionality.
GlobalProxySelection | Contains a global ISelectProxy instance that is called on every request.
HttpAsyncResult | [To be supplied.]
HttpExtension | [To be supplied.]
HttpStatusCode | Contains the values of status codes defined for the HTTP protocol.
HttpWebRequest | HttpWebRequest is an HTTP-specific implementation of the WebRequest class.
HttpWebResponse | An HTTP-specific implementation of the WebResponse class.
IPAddress | Provides an internet protocol (IP) address.
IPEndPoint | Provides an IP address.
IPHostEntry | Provides a container class for IP addresses.
NetworkCredential | Provides credentials for password-based authentication schemes such as basic, digest, NTLM and Kerberos.
ProtocolVersion | Provides a generalized version number.
ProtocolViolationException | An exception class used when an attempt is made to use an invalid protocol.
ProxyData | Contains information about a proxy.
ServicePoint | Provides connection management for other classes.
ServicePointManager | Manages the collection of ServicePoint instances.
SingleCredential | Provides a simple username/ password pair for Web client authentication.
SocketPermission | Controls rights to make or accept connections on a transport address.
SocketsException | An exception class used when an invalid socket operation is performed.
SystemError | Maps system errors to their text definitions.
URLFormatException | An exception class used when an invalid Uniform Resource Identifier is detected.
WebException | Provides network communication exceptions to the application.
WebHeaders | Contains protocol headers associated with a request or response.
WebPermission | Controls rights to make or accept connections on a Web address.
WebRequest | A request to a Uniform Resource Identifier (URI). This is an abstract class.
WebRequestFactory | Creates WebRequest objects for specific network request schemes.
WebResponse | A response from a Uniform Resource Indentifier (URI). This is an abstract class.

Interfaces

Interface | Description
EndPoint | Identifies a network address.
IAuthenticationModule | Provides the base authentication interface for Web client authentication modules.
ICertificatePolicy | Validates a server certificate.
ICredentialLookup | Provides the base authentication interface for Web client authentication.
IProxyInfo | Obtains summary information about a proxy.
ISelectProxy | Finds the proxy that should be used for a specific WebRequest.
IWebRequestCreate | The IWebRequestCreate interface is used by the WebRequestFactory class to create WebRequest instances for a registered scheme.

Delegates

Delegate | Description
HttpContinueDelegate | Represents the method that will notify callers when a continue has been received by the client.

Enumerations

Enumeration | Description
ConnectionModes | Specifies the mode used to establish a connection with a server.
NetworkAccess | Defines network access permissions.
SChannelCred.Flags | [To be supplied.]
SChannelCred.Protocols | [To be supplied.]
TransportType | Defines the transport type allowed for the socket.
WebStatus | Specifies the status of a network request.


AuthenticationManager Class

Manages the authentication modules called during the client authentication process.

Object
AuthenticationManager

[Visual Basic]
Public Class AuthenticationManager
[C#]
public class AuthenticationManager
[C++]
public __gc class AuthenticationManager
[JScript]
public class AuthenticationManager

Remarks

[To be supplied.]

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

AuthenticationManager Members | System.Net Namespace


AuthenticationManager Members

Public:

Constructor

AuthenticationManager Constructor [To be supplied.]

Properties

RegisteredModules Returns a list of registered authentication modules.

Methods

BindModule | Binds an authentication response to a request for pre-authentication.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
PreAuthenticate | Pre-authenticates a request.
Register | Registers an authentication module with the authentication manager.
Respond | Call each registered authentication module to determine the first module that can respond to the authentication request.
ToString (inherited from Object) | Returns a String that represents the current Object.
Unregister | Unregisters authentication modules for an authentication scheme.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AuthenticationManager Class | System.Net Namespace


AuthenticationManager Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public AuthenticationManager();
[C++]
public: AuthenticationManager();
[JScript]
public function AuthenticationManager();

See Also

AuthenticationManager Class | AuthenticationManager Members | System.Net Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AuthenticationManager Properties

The properties of the AuthenticationManager class are listed below. For a complete list of AuthenticationManager class members, see the AuthenticationManager Members topic.

Public:

RegisteredModules Returns a list of registered authentication modules.

See Also

AuthenticationManager Class | System.Net Namespace


AuthenticationManager.RegisteredModules

Returns a list of registered authentication modules.

[Visual Basic]
Public Shared ReadOnly Property RegisteredModules As IEnumerator
[C#]
public static IEnumerator RegisteredModules {get;}
[C++]
public: __property static IEnumerator* get_RegisteredModules();
[JScript]
public static function get RegisteredModules() : IEnumerator;

See Also

AuthenticationManager Class | AuthenticationManager Members | System.Net Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AuthenticationManager Methods

The methods of the AuthenticationManager class are listed below. For a complete list of AuthenticationManager class members, see the AuthenticationManager Members topic.

Public:

BindModule | Binds an authentication response to a request for pre-authentication.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
PreAuthenticate | Pre-authenticates a request.
Register | Registers an authentication module with the authentication manager.
Respond | Call each registered authentication module to determine the first module that can respond to the authentication request.
ToString (inherited from Object) | Returns a String that represents the current Object.
Unregister | Unregisters authentication modules for an authentication scheme.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AuthenticationManager Class | System.Net Namespace


AuthenticationManager.BindModule

Binds an authentication response to a request for pre-authentication.

[Visual Basic]
Public Shared Sub BindModule( _
   ByVal request As WebRequest, _
   ByVal response As Authorization _
)
[C#]
public static void BindModule(
   WebRequest request,
   Authorization response
);
[C++]
public: static void BindModule(
   WebRequest* request,
   Authorization* response
);
[JScript]
public static function BindModule(
   request : WebRequest,
   response : Authorization
);

Parameters

request
A request to an Internet resource.
response
[To be supplied.]

See Also

AuthenticationManager Class | AuthenticationManager Members | System.Net Namespace


AuthenticationManager.PreAuthenticate

Pre-authenticates a request.

[Visual Basic]
Public Shared Function PreAuthenticate( _
   ByVal Request As WebRequest, _
   ByVal Credentials As ICredentialLookup _
) As Authorization
[C#]
public static Authorization PreAuthenticate(
   WebRequest Request,
   ICredentialLookup Credentials
);
[C++]
public: static Authorization* PreAuthenticate(
   WebRequest* Request,
   ICredentialLookup* Credentials
);
[JScript]
public static function PreAuthenticate(
   Request : WebRequest,
   Credentials : ICredentialLookup
) : Authorization;

Parameters

Request
A request to an Internet resource.
Credentials
[To be supplied.]

Return Value

An instance of the Authorization class if the request can be pre-authenticated; otherwise a null reference (in Visual Basic Nothing).

See Also

AuthenticationManager Class | AuthenticationManager Members | System.Net Namespace


AuthenticationManager.Register

Registers an authentication module with the authentication manager.

[Visual Basic]
Public Shared Sub Register( _
   ByVal M As IAuthenticationModule _
)
[C#]
public static void Register(
   IAuthenticationModule M
);
[C++]
public: static void Register(
   IAuthenticationModule* M
);
[JScript]
public static function Register(
   M : IAuthenticationModule
);

Parameters

M
The authentication module to register.

See Also

AuthenticationManager Class | AuthenticationManager Members | System.Net Namespace


AuthenticationManager.Respond

Call each registered authentication module to determine the first module that can respond to the authentication request.

[Visual Basic]
Public Shared Function Respond( _
   ByVal ResponseHeaders As NameValueCollection, _
   ByVal Request As WebRequest, _
   ByVal Credentials As ICredentialLookup _
) As Authorization
[C#]
public static Authorization Respond(
   NameValueCollection ResponseHeaders,
   WebRequest Request,
   ICredentialLookup Credentials
);
[C++]
public: static Authorization* Respond(
   NameValueCollection* ResponseHeaders,
   WebRequest* Request,
   ICredentialLookup* Credentials
);
[JScript]
public static function Respond(
   ResponseHeaders : NameValueCollection,
   Request : WebRequest,
   Credentials : ICredentialLookup
) : Authorization;

Parameters

ResponseHeaders
The header collection returned by the server in response to a request.
Request
[To be supplied.]
Credentials
[To be supplied.]

Return Value

An instance of the Authorization class containing the result of the authorization attempt.

See Also

AuthenticationManager Class | AuthenticationManager Members | System.Net Namespace


AuthenticationManager.Unregister

Unregisters authentication modules for an authentication scheme.

[Visual Basic]
Public Shared Sub Unregister( _
   ByVal moduleName As String _
)
[C#]
public static void Unregister(
   string moduleName
);
[C++]
public: static void Unregister(
   String* moduleName
);
[JScript]
public static function Unregister(
   moduleName : String
);

Parameters

moduleName
The authentication scheme to unregister.

Remarks

All modules with the given authentication scheme will be unregistered.Authentication schemes are listed in the AuthenticationScheme class.

See Also

AuthenticationManager Class | AuthenticationManager Members | System.Net Namespace


AuthenticationScheme Class

Provides a list of the default authentication types supported by the System.Net namespace.

Object
AuthenticationScheme

[Visual Basic]
Public Class AuthenticationScheme
[C#]
public class AuthenticationScheme
[C++]
public __gc class AuthenticationScheme
[JScript]
public class AuthenticationScheme

Remarks

[To be supplied.]

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

AuthenticationScheme Members | System.Net Namespace


AuthenticationScheme Members

Public:

Constructor

AuthenticationScheme Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Basic | [To be supplied.]
Digest | [To be supplied.]
Kerberos | [To be supplied.]
NTLM | [To be supplied.]
Passport | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AuthenticationScheme Class | System.Net Namespace


AuthenticationScheme Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public AuthenticationScheme();
[C++]
public: AuthenticationScheme();
[JScript]
public function AuthenticationScheme();

See Also

AuthenticationScheme Class | AuthenticationScheme Members | System.Net Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AuthenticationScheme Fields

The fields of the AuthenticationScheme class are listed below. For a complete list of AuthenticationScheme class members, see the AuthenticationScheme Members topic.

Public:

Basic | [To be supplied.]
Digest | [To be supplied.]
Kerberos | [To be supplied.]
NTLM | [To be supplied.]
Passport | [To be supplied.]

See Also

AuthenticationScheme Class | System.Net Namespace


AuthenticationScheme.Basic

[To be supplied.]

[Visual Basic]
Public Const Basic As String
[C#]
public const string Basic;
[C++]
public: const String* Basic;
[JScript]
public var Basic : String;

See Also

AuthenticationScheme Class | AuthenticationScheme Members | System.Net Namespace


AuthenticationScheme.Digest

[To be supplied.]

[Visual Basic]
Public Const Digest As String
[C#]
public const string Digest;
[C++]
public: const String* Digest;
[JScript]
public var Digest : String;

See Also

AuthenticationScheme Class | AuthenticationScheme Members | System.Net Namespace


AuthenticationScheme.Kerberos

[To be supplied.]

[Visual Basic]
Public Const Kerberos As String
[C#]
public const string Kerberos;
[C++]
public: const String* Kerberos;
[JScript]
public var Kerberos : String;

See Also

AuthenticationScheme Class | AuthenticationScheme Members | System.Net Namespace


AuthenticationScheme.NTLM

[To be supplied.]

[Visual Basic]
Public Const NTLM As String
[C#]
public const string NTLM;
[C++]
public: const String* NTLM;
[JScript]
public var NTLM : String;

See Also

AuthenticationScheme Class | AuthenticationScheme Members | System.Net Namespace


AuthenticationScheme.Passport

[To be supplied.]

[Visual Basic]
Public Const Passport As String
[C#]
public const string Passport;
[C++]
public: const String* Passport;
[JScript]
public var Passport : String;

See Also

AuthenticationScheme Class | AuthenticationScheme Members | System.Net Namespace


Authorization Class

Used for handling and completing a custom authorization.

Object
Authorization

[Visual Basic]
Public Class Authorization
[C#]
public class Authorization
[C++]
public __gc class Authorization
[JScript]
public class Authorization

Remarks

[To be supplied.]

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

Authorization Members | System.Net Namespace


Authorization Members

Public:

Constructor

Authorization Constructor Overloaded. Creates a new instance of the Authorization class.

Properties

Complete | Gets the completion status of the authorization.
Message | Gets the response returned to the server in response to an authentication challenge.
ProtectionRealm | Gets or sets the prefix for URIs that can be authenticated with the Message property.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Authorization Class | System.Net Namespace


Authorization Constructor

Creates a new instance of the Authorization class.

Overload List

Creates a new instance of the Authorization class with the specified authorization token.

[Visual Basic] Overloads Public Sub New(String)
[C#] public Authorization(String);
[C++] public: Authorization(String*);
[JScript] public function Authorization(String);

Creates a new instance of the Authorization class with the specified authorization token and completion status.

[Visual Basic] Overloads Public Sub New(String, Boolean)
[C#] public Authorization(String, bool);
[C++] public: Authorization(String*, bool);
[JScript] public function Authorization(String, Boolean);

See Also

Authorization Class | Authorization Members | System.Net Namespace


Authorization Constructor (String)

Creates a new instance of the Authorization class with the specified authorization token.

[Visual Basic]
Overloads Public Sub New( _
   ByVal Token As String _
)
[C#]
public Authorization(
   string Token
);
[C++]
public: Authorization(
   String* Token
);
[JScript]
public function Authorization(
   Token : String
);

Parameters

Token
An authorization token.

See Also

Authorization Class | Authorization Members | System.Net Namespace | Authorization Constructor Overload List


Authorization Constructor (String, Boolean)

Creates a new instance of the Authorization class with the specified authorization token and completion status.

[Visual Basic]
Overloads Public Sub New( _
   ByVal Token As String, _
   ByVal Finished As Boolean _
)
[C#]
public Authorization(
   string Token,
   bool Finished
);
[C++]
public: Authorization(
   String* Token,
   bool Finished
);
[JScript]
public function Authorization(
   Token : String,
   Finished : Boolean
);

Parameters

Token
An authorization token.
Finished
[To be supplied.]

See Also

Authorization Class | Authorization Members | System.Net Namespace | Authorization Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Authorization Properties

The properties of the Authorization class are listed below. For a complete list of Authorization class members, see the Authorization Members topic.

Public:

Complete | Gets the completion status of the authorization.
Message | Gets the response returned to the server in response to an authentication challenge.
ProtectionRealm | Gets or sets the prefix for URIs that can be authenticated with the Message property.

See Also

Authorization Class | System.Net Namespace


Authorization.Complete

Gets the completion status of the authorization.

[Visual Basic]
Public ReadOnly Property Complete As Boolean
[C#]
public bool Complete {get;}
[C++]
public: __property bool get_Complete();
[JScript]
public function get Complete() : Boolean;

See Also

Authorization Class | Authorization Members | System.Net Namespace


Authorization.Message

Gets the response returned to the server in response to an authentication challenge.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property String* get_Message();
[JScript]
public function get Message() : String;

See Also

Authorization Class | Authorization Members | System.Net Namespace


Authorization.ProtectionRealm

Gets or sets the prefix for URIs that can be authenticated with the Message property.

[Visual Basic]
Public Property ProtectionRealm As String ()
[C#]
public string[] ProtectionRealm {get; set;}
[C++]
public: __property String* get_ProtectionRealm();
public: __property void set_ProtectionRealm(String*[]);
[JScript]
public function get ProtectionRealm() : String[];
public function set ProtectionRealm(String[]);

See Also

Authorization Class | Authorization Members | System.Net Namespace


ConnectionModes Enumeration

Specifies the mode used to establish a connection with a server.

[Visual Basic]
Public Enum ConnectionModes
[C#]
public enum ConnectionModes
[C++]
public enum ConnectionModes

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
MUX | Persistent connection, many requests/responses out of order.
PERSISTENT | Persistent connection, on request/response at a time.
PIPELINE | Persistent connection, many requests/responses in order.
SINGLE | Non-persistent, on request per connection.

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

System.Net Namespace


CredentialCache Class

Provides storage for multiple credentials.

Object
CredentialCache

[Visual Basic]
Public Class CredentialCache
   Implements ICredentialLookup
[C#]
public class CredentialCache : ICredentialLookup
[C++]
public __gc class CredentialCache : public ICredentialLookup
[JScript]
public class CredentialCache implements ICredentialLookup

Remarks

[To be supplied.]

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

CredentialCache Members | System.Net Namespace


CredentialCache Members

Public:

Constructor

CredentialCache Constructor Initializes a new instance of the CredentialCache class.

Properties

DefaultCredentials Gets the default system credentials from the CredentialCache.

Methods

Add | Adds a NetworkCredential instance to the credential cache.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCredential | Returns the NetworkCredential instance associated with the supplied URI and authentication type.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Remove | Removes a NetworkCredential instance from the credential cache.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CredentialCache Class | System.Net Namespace


CredentialCache Constructor

Initializes a new instance of the CredentialCache class.

[Visual Basic]
Public Sub New()
[C#]
public CredentialCache();
[C++]
public: CredentialCache();
[JScript]
public function CredentialCache();

See Also

CredentialCache Class | CredentialCache Members | System.Net Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CredentialCache Properties

The properties of the CredentialCache class are listed below. For a complete list of CredentialCache class members, see the CredentialCache Members topic.

Public:

DefaultCredentials Gets the default system credentials from the CredentialCache.

See Also

CredentialCache Class | System.Net Namespace


CredentialCache.DefaultCredentials

Gets the default system credentials from the CredentialCache.

[Visual Basic]
Public Shared ReadOnly Property DefaultCredentials As _
   ICredentialLookup
[C#]
public static ICredentialLookup DefaultCredentials {get;}
[C++]
public: __property static ICredentialLookup*
   get_DefaultCredentials();
[JScript]
public static function get DefaultCredentials() : ICredentialLookup;

Remarks

System.Net.DefaultCredentials applies to NTLM and Kerberos-based authentication only.

System.Net.DefaultCredentials returns the system credentials for the current security context in which the application is running. For a client-side application, this is usually the Windows credentials (user name/password/domain) of the user running the application. When accessed from within an ASP+ page, the security context is determined by the ASP+ page. This context will be either the process token associated with IIS, or, if using ASP+ impersonation, it will be the process token being impersonated.

See Also

CredentialCache Class | CredentialCache Members | System.Net Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

CredentialCache Methods

The methods of the CredentialCache class are listed below. For a complete list of CredentialCache class members, see the CredentialCache Members topic.

Public:

Add | Adds a NetworkCredential instance to the credential cache.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCredential | Returns the NetworkCredential instance associated with the supplied URI and authentication type.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Remove | Removes a NetworkCredential instance from the credential cache.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CredentialCache Class | System.Net Namespace


CredentialCache.Add

Adds a NetworkCredential instance to the credential cache.

[Visual Basic]
Public Sub Add( _
   ByVal URIprefix As String, _
   ByVal AuthType As String, _
   ByVal cred As NetworkCredential _
)
[C#]
public void Add(
   string URIprefix,
   string AuthType,
   NetworkCredential cred
);
[C++]
public: void Add(
   String* URIprefix,
   String* AuthType,
   NetworkCredential* cred
);
[JScript]
public function Add(
   URIprefix : String,
   AuthType : String,
   cred : NetworkCredential
);

Parameters

URIprefix
The URI string that the credential applies to.
AuthType
The authentication scheme used by the host referred to in URI. Taken from the list of authentication types included in System.Net.AuthenticationTypes.
cred
The NetworkCredential instance to be added to the credential cache.

Return Value

true if the credential was successfully added to the cache; otherwise, false.

See Also

CredentialCache Class | CredentialCache Members | System.Net Namespace


CredentialCache.GetCredential

Returns the NetworkCredential instance associated with the supplied URI and authentication type.

[Visual Basic]
Overridable Public Function GetCredential( _
   ByVal URI As String, _
   ByVal AuthType As String _
) As NetworkCredential
[C#]
public virtual NetworkCredential GetCredential(
   string URI,
   string AuthType
);
[C++]
public: virtual NetworkCredential* GetCredential(
   String* URI,
   String* AuthType
);
[JScript]
public function GetCredential(
   URI : String,
   AuthType : String
) : NetworkCredential;

Parameters

URI
The URI string that the credential applies to.
AuthType
The authentication scheme used by the host referred to in URI. Taken from the list of authentication types included in System.Net.AuthenticationTypes.

Return Value

A NetworkCredential instance.

See Also

CredentialCache Class | CredentialCache Members | System.Net Namespace


CredentialCache.Remove

Removes a NetworkCredential instance from the credential cache.

[Visual Basic]
Public Sub Remove( _
   ByVal URIprefix As String, _
   ByVal AuthType As String _
)
[C#]
public void Remove(
   string URIprefix,
   string AuthType
);
[C++]
public: void Remove(
   String* URIprefix,
   String* AuthType
);
[JScript]
public function Remove(
   URIprefix : String,
   AuthType : String
);

Parameters

URIprefix
The URI string that the credential applies to.
AuthType
The authentication scheme used by the host referred to in URI. Taken from the list of authentication types included in System.Net.AuthenticationTypes.

Return Value

true if the credential was successfully removed from the cache; otherwise, false.

See Also

CredentialCache Class | CredentialCache Members | System.Net Namespace


DefaultControlObject Class

Stores basic proxy settings for the default proxy.

Object
DefaultControlObject

[Visual Basic]
Public Class DefaultControlObject
   Implements ISelectProxy
[C#]
public class DefaultControlObject : ISelectProxy
[C++]
public __gc class DefaultControlObject : public ISelectProxy
[JScript]
public class DefaultControlObject implements ISelectProxy

Remarks

[To be supplied.]

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

DefaultControlObject Members | System.Net Namespace


DefaultControlObject Members

Public:

Constructor

DefaultControlObject Constructor Overloaded. Initializes an instance of the DefaultControlObject class.

Properties

ProxyNoLocal Enables or disables a proxy for local use.

Methods

CreateProxyOverride | Creates a proxy object.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SelectProxy | Returns a proxy object for use in an Internet request.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefaultControlObject Class | System.Net Namespace


DefaultControlObject Constructor

Initializes an instance of the DefaultControlObject class.

Overload List

Initializes an instance of the DefaultControlObject class using default settings.

[Visual Basic] Overloads Public Sub New()
[C#] public DefaultControlObject();
[C++] public: DefaultControlObject();
[JScript] public function DefaultControlObject();

Initializes an instance of the DefaultControlObject class for a particular proxy host.

[Visual Basic] Overloads Public Sub New(String)
[C#] public DefaultControlObject(String);
[C++] public: DefaultControlObject(String*);
[JScript] public function DefaultControlObject(String);

Initializes an instance of the DefaultControlObject class for a particular proxy host, and a specific proxy port.

[Visual Basic] Overloads Public Sub New(String, Integer)
[C#] public DefaultControlObject(String, int);
[C++] public: DefaultControlObject(String*, int);
[JScript] public function DefaultControlObject(String, int);

See Also

DefaultControlObject Class | DefaultControlObject Members | System.Net Namespace


DefaultControlObject Constructor ()

Initializes an instance of the DefaultControlObject class using default settings.

[Visual Basic]
Overloads Public Sub New()
[C#]
public DefaultControlObject();
[C++]
public: DefaultControlObject();
[JScript]
public function DefaultControlObject();

Remarks

[To be supplied]

See Also

DefaultControlObject Class | DefaultControlObject Members | System.Net Namespace | DefaultControlObject Constructor Overload List


DefaultControlObject Constructor (String)

Initializes an instance of the DefaultControlObject class for a particular proxy host.

[Visual Basic]
Overloads Public Sub New( _
   ByVal proxyHost As String _
)
[C#]
public DefaultControlObject(
   string proxyHost
);
[C++]
public: DefaultControlObject(
   String* proxyHost
);
[JScript]
public function DefaultControlObject(
   proxyHost : String
);

Parameters

proxyHost
A string identifying a particular proxy host.

Remarks

[To be supplied]

See Also

DefaultControlObject Class | DefaultControlObject Members | System.Net Namespace | DefaultControlObject Constructor Overload List


DefaultControlObject Constructor (String, Int32)

Initializes an instance of the DefaultControlObject class for a particular proxy host, and a specific proxy port.

[Visual Basic]
Overloads Public Sub New( _
   ByVal proxyHost As String, _
   ByVal proxyPort As Integer _
)
[C#]
public DefaultControlObject(
   string proxyHost,
   int proxyPort
);
[C++]
public: DefaultControlObject(
   String* proxyHost,
   int proxyPort
);
[JScript]
public function DefaultControlObject(
   proxyHost : String,
   proxyPort : int
);

Parameters

proxyHost
A string identifying a particular proxy host.
proxyPort
A number identifying a particular proxy port.

Remarks

[To be supplied]

See Also

DefaultControlObject Class | DefaultControlObject Members | System.Net Namespace | DefaultControlObject Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DefaultControlObject Properties

The properties of the DefaultControlObject class are listed below. For a complete list of DefaultControlObject class members, see the DefaultControlObject Members topic.

Public:

ProxyNoLocal Enables or disables a proxy for local use.

See Also

DefaultControlObject Class | System.Net Namespace


DefaultControlObject.ProxyNoLocal

Enables or disables a proxy for local use.

[Visual Basic]
Public Property ProxyNoLocal As Boolean
[C#]
public bool ProxyNoLocal {get; set;}
[C++]
public: __property bool get_ProxyNoLocal();
public: __property void set_ProxyNoLocal(bool);
[JScript]
public function get ProxyNoLocal() : Boolean;
public function set ProxyNoLocal(Boolean);

Remarks

When ProxyNoLocal is true, System.Net.WebRequests to local hosts are not sent through the proxy; otherwise, all System.Net.WebRequests are sent through the proxy.

See Also

DefaultControlObject Class | DefaultControlObject Members | System.Net Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DefaultControlObject Methods

The methods of the DefaultControlObject class are listed below. For a complete list of DefaultControlObject class members, see the DefaultControlObject Members topic.

Public:

CreateProxyOverride | Creates a proxy object.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SelectProxy | Returns a proxy object for use in an Internet request.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefaultControlObject Class | System.Net Namespace


DefaultControlObject.CreateProxyOverride

Creates a proxy object.

[Visual Basic]
Overridable Public Function CreateProxyOverride() As IProxyInfo
[C#]
public virtual IProxyInfo CreateProxyOverride();
[C++]
public: virtual IProxyInfo* CreateProxyOverride();
[JScript]
public function CreateProxyOverride() : IProxyInfo;

See Also

DefaultControlObject Class | DefaultControlObject Members | System.Net Namespace


DefaultControlObject.SelectProxy

Returns a proxy object for use in an Internet request.

[Visual Basic]
Overridable Public Function SelectProxy( _
   ByVal Url As URI, _
   ByVal proxyInfo As IProxyInfo _
) As IProxyInfo
[C#]
public virtual IProxyInfo SelectProxy(
   URI Url,
   IProxyInfo proxyInfo
);
[C++]
public: virtual IProxyInfo* SelectProxy(
   URI* Url,
   IProxyInfo* proxyInfo
);
[JScript]
public function SelectProxy(
   Url : URI,
   proxyInfo : IProxyInfo
) : IProxyInfo;

Parameters

Url
[To be supplied.]
proxyInfo
[To be supplied.]

See Also

DefaultControlObject Class | DefaultControlObject Members | System.Net Namespace


DNS Class

Provides simple domain name resolution functionality.

Object
DNS

[Visual Basic]
Public Class DNS
[C#]
public class DNS
[C++]
public __gc class DNS
[JScript]
public class DNS

Remarks

[To be supplied.]

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

DNS Members | System.Net Namespace


DNS Members

Public:

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHostByAddr | Overloaded. Obtains host entry information for an address.
GetHostByName | Retrieves the IPHostEntry information corresponding to the DNS name provided in the host parameter.
GetHostName | Gets the host name of the local machine.
GetType (inherited from Object) | Gets the Type of the Object.
InetAddr | Converts an IP address string to an IPAddress instance.
InetNtoa | Creates a string containing the DNS name of the host specified in address.
IpToString | Converts an IP address to a string.
Resolve | Creates an IPAddress instance from a DNS hostname.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DNS Class | System.Net Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DNS Methods

The methods of the DNS class are listed below. For a complete list of DNS class members, see the DNS Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHostByAddr | Overloaded. Obtains host entry information for an address.
GetHostByName | Retrieves the IPHostEntry information corresponding to the DNS name provided in the host parameter.
GetHostName | Gets the host name of the local machine.
GetType (inherited from Object) | Gets the Type of the Object.
InetAddr | Converts an IP address string to an IPAddress instance.
InetNtoa | Creates a string containing the DNS name of the host specified in address.
IpToString | Converts an IP address to a string.
Resolve | Creates an IPAddress instance from a DNS hostname.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DNS Class | System.Net Namespace


DNS.GetHostByAddr

Obtains host entry information for an address.

Overload List

Creates an System.Net.IPHostAddress instance from an IP dotted address.

[Visual Basic] Overloads Public Shared Function GetHostByAddr(String) As IPHostEntry
[C#] public static IPHostEntry GetHostByAddr(String);
[C++] public: static IPHostEntry* GetHostByAddr(String*);
[JScript] public static function GetHostByAddr(String) : IPHostEntry;

Creates an System.Net.IPHostAddress instance from an IPAddress instance.

[Visual Basic] Overloads Public Shared Function GetHostByAddr(IPAddress) As IPHostEntry
[C#] public static IPHostEntry GetHostByAddr(IPAddress);
[C++] public: static IPHostEntry* GetHostByAddr(IPAddress*);
[JScript] public static function GetHostByAddr(IPAddress) : IPHostEntry;

See Also

DNS Class | DNS Members | System.Net Namespace


DNS.GetHostByAddr (String)

Creates an System.Net.IPHostAddress instance from an IP dotted address.

[Visual Basic]
Overloads Public Shared Function GetHostByAddr( _
   ByVal address As String _
) As IPHostEntry
[C#]
public static IPHostEntry GetHostByAddr(
   string address
);
[C++]
public: static IPHostEntry* GetHostByAddr(
   String* address
);
[JScript]
public static function GetHostByAddr(
   address : String
) : IPHostEntry;

Parameters

address
A string that represents a DNS-style host name (for example,

See Also

DNS Class | DNS Members | System.Net Namespace | DNS.GetHostByAddr Overload List


DNS.GetHostByAddr (IPAddress)

Creates an System.Net.IPHostAddress instance from an IPAddress instance.

[Visual Basic]
Overloads Public Shared Function GetHostByAddr( _
   ByVal address As IPAddress _
) As IPHostEntry
[C#]
public static IPHostEntry GetHostByAddr(
   IPAddress address
);
[C++]
public: static IPHostEntry* GetHostByAddr(
   IPAddress* address
);
[JScript]
public static function GetHostByAddr(
   address : IPAddress
) : IPHostEntry;

Parameters

address
An IPAddress instance.

Return Value

IPHostEntry instance.

Remarks

The name Inet_Ntoa() for this method was used instead of ToString() to maintain consistency with the traditional Winsock function Inet_Ntoa().

See Also

DNS Class | DNS Members | System.Net Namespace | DNS.GetHostByAddr Overload List


DNS.GetHostByName

Retrieves the IPHostEntry information corresponding to the DNS name provided in the host parameter.

[Visual Basic]
Public Shared Function GetHostByName( _
   ByVal host As String _
) As IPHostEntry
[C#]
public static IPHostEntry GetHostByName(
   string host
);
[C++]
public: static IPHostEntry* GetHostByName(
   String* host
);
[JScript]
public static function GetHostByName(
   host : String
) : IPHostEntry;

Parameters

host
A string representing the DNS name of the host.

Return Value

An IPHostEntry object containing host information pertaining to the address specified in host.

See Also

DNS Class | DNS Members | System.Net Namespace


DNS.GetHostName

Gets the host name of the local machine.

[Visual Basic]
Public Shared Function GetHostName() As String
[C#]
public static string GetHostName();
[C++]
public: static String* GetHostName();
[JScript]
public static function GetHostName() : String;

Return Value

A string containing the DNS host name of the local machine.

See Also

DNS Class | DNS Members | System.Net Namespace


DNS.InetAddr

Converts an IP address string to an IPAddress instance.

[Visual Basic]
Public Shared Function InetAddr( _
   ByVal ipString As String _
) As IPAddress
[C#]
public static IPAddress InetAddr(
   string ipString
);
[C++]
public: static IPAddress* InetAddr(
   String* ipString
);
[JScript]
public static function InetAddr(
   ipString : String
) : IPAddress;

Parameters

ipString
String containing an IP address in dotted-quad notation (i.e., 192.168.1.2).

Return Value

IPAddress instance.

See Also

DNS Class | DNS Members | System.Net Namespace


DNS.InetNtoa

Creates a string containing the DNS name of the host specified in address.

[Visual Basic]
Public Shared Function InetNtoa( _
   ByVal address As IPAddress _
) As String
[C#]
public static string InetNtoa(
   IPAddress address
);
[C++]
public: static String* InetNtoa(
   IPAddress* address
);
[JScript]
public static function InetNtoa(
   address : IPAddress
) : String;

Parameters

address
An IPAddress instance representing the IP (or dotted IP) address of the host.

Return Value

A string containing the DNS name of the host specified in the address.

See Also

DNS Class | DNS Members | System.Net Namespace


DNS.IpToString

Converts an IP address to a string.

[Visual Basic]
Public Shared Function IpToString( _
   ByVal address As Integer _
) As String
[C#]
public static string IpToString(
   int address
);
[C++]
public: static String* IpToString(
   int address
);
[JScript]
public static function IpToString(
   address : int
) : String;

Parameters

address
The IP address to convert.

Return Value

The string representation of the IP address.

See Also

DNS Class | DNS Members | System.Net Namespace


DNS.Resolve

Creates an IPAddress instance from a DNS hostname.

[Visual Basic]
Public Shared Function Resolve( _
   ByVal hostname As String _
) As IPAddress
[C#]
public static IPAddress Resolve(
   string hostname
);
[C++]
public: static IPAddress* Resolve(
   String* hostname
);
[JScript]
public static function Resolve(
   hostname : String
) : IPAddress;

Parameters

hostname
A DNS-style name. (i.e.

See Also

DNS Class | DNS Members | System.Net Namespace


EndPoint Interface

Identifies a network address.

EndPoint

[Visual Basic]
Public Interface EndPoint
[C#]
public interface EndPoint
[C++]
public __gc __interface EndPoint

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement EndPoint

Class | Description
IPEndPoint | Provides an IP address.

Remarks

[To be supplied.]

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

EndPoint Members | System.Net Namespace


EndPoint Members

Methods

Serialize Serializes endpoint information into a socket-address structure.

See Also

EndPoint Interface | System.Net Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EndPoint Methods

The methods of the EndPoint interface are listed below. For a complete list of EndPoint interface members, see the EndPoint Members topic.

Serialize Serializes endpoint information into a socket-address structure.

See Also

EndPoint Interface | System.Net Namespace


EndPoint.Serialize

Serializes endpoint information into a socket-address structure.

[Visual Basic]
Function Serialize() As Byte ()
[C#]
byte[] Serialize();
[C++]
unsigned char* Serialize() [] = 0;
[JScript]
function Serialize() : Byte[];

See Also

EndPoint Interface | EndPoint Members | System.Net Namespace


GlobalProxySelection Class

Contains a global ISelectProxy instance that is called on every request.

Object
GlobalProxySelection

[Visual Basic]
Public Class GlobalProxySelection
[C#]
public class GlobalProxySelection
[C++]
public __gc class GlobalProxySelection
[JScript]
public class GlobalProxySelection

Remarks

[To be supplied.]

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

GlobalProxySelection Members | System.Net Namespace


GlobalProxySelection Members

Public:

Constructor

GlobalProxySelection Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Select Contains the global proxy object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GlobalProxySelection Class | System.Net Namespace


GlobalProxySelection Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public GlobalProxySelection();
[C++]
public: GlobalProxySelection();
[JScript]
public function GlobalProxySelection();

See Also

GlobalProxySelection Class | GlobalProxySelection Members | System.Net Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

GlobalProxySelection Fields

The fields of the GlobalProxySelection class are listed below. For a complete list of GlobalProxySelection class members, see the GlobalProxySelection Members topic.

Public:

Select Contains the global proxy object.

See Also

GlobalProxySelection Class | System.Net Namespace


GlobalProxySelection.Select

Contains the global proxy object.

[Visual Basic]
Public Shared Select As ISelectProxy
[C#]
public static ISelectProxy Select;
[C++]
public: static ISelectProxy* Select;
[JScript]
public static var Select : ISelectProxy;

See Also

GlobalProxySelection Class | GlobalProxySelection Members | System.Net Namespace


HttpAsyncResult Class

[To be supplied.]

Object
HttpAsyncResult

[Visual Basic]
Public Class HttpAsyncResult
   Implements IAsyncResult
[C#]
public class HttpAsyncResult : IAsyncResult
[C++]
public __gc class HttpAsyncResult : public IAsyncResult
[JScript]
public class HttpAsyncResult implements IAsyncResult

Remarks

[To be supplied.]

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

HttpAsyncResult Members | System.Net Namespace


HttpAsyncResult Members

Public:

Properties

AsyncObject | [To be supplied.]
AsyncState | [To be supplied.]
AsyncWaitHandle | [To be supplied.]
CompletedSynchronously | [To be supplied.]
IsCompleted | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HttpAsyncResult Class | System.Net Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

HttpAsyncResult Properties

The properties of the HttpAsyncResult class are listed below. For a complete list of HttpAsyncResult class members, see the HttpAsyncResult Members topic.

Public:

AsyncObject | [To be supplied.]
AsyncState | [To be supplied.]
AsyncWaitHandle | [To be supplied.]
CompletedSynchronously | [To be supplied.]
IsCompleted | [To be supplied.]

See Also

HttpAsyncResult Class | System.Net Namespace


HttpAsyncResult.AsyncObject

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property AsyncObject As Object
[C#]
public object AsyncObject {virtual get;}
[C++]
public: __property virtual Object* get_AsyncObject();
[JScript]
public function get AsyncObject() : Object;

See Also

HttpAsyncResult Class | HttpAsyncResult Members | System.Net Namespace


HttpAsyncResult.AsyncState

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property AsyncState As Object
[C#]
public object AsyncState {virtual get;}
[C++]
public: __property virtual Object* get_AsyncState();
[JScript]
public function get AsyncState() : Object;

See Also

HttpAsyncResult Class | HttpAsyncResult Members | System.Net Namespace


HttpAsyncResult.AsyncWaitHandle

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property AsyncWaitHandle As WaitHandle
[C#]
public WaitHandle AsyncWaitHandle {virtual get;}
[C++]
public: __property virtual WaitHandle* get_AsyncWaitHandle();
[JScript]
public function get AsyncWaitHandle() : WaitHandle;

See Also

HttpAsyncResult Class | HttpAsyncResult Members | System.Net Namespace


HttpAsyncResult.CompletedSynchronously

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property CompletedSynchronously As _
   Boolean
[C#]
public bool CompletedSynchronously {virtual get;}
[C++]
public: __property virtual bool get_CompletedSynchronously();
[JScript]
public function get CompletedSynchronously() : Boolean;

See Also

HttpAsyncResult Class | HttpAsyncResult Members | System.Net Namespace


HttpAsyncResult.IsCompleted

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property IsCompleted As Boolean
[C#]
public bool IsCompleted {virtual get;}
[C++]
public: __property virtual bool get_IsCompleted();
[JScript]
public function get IsCompleted() : Boolean;

See Also

HttpAsyncResult Class | HttpAsyncResult Members | System.Net Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

HttpAsyncResult Methods

The methods of the HttpAsyncResult class are listed below. For a complete list of HttpAsyncResult class members, see the HttpAsyncResult Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HttpAsyncResult Class | System.Net Namespace


HttpAsyncResult.Finalize

[To be supplied.]

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

HttpAsyncResult Class | HttpAsyncResult Members | System.Net Namespace


HttpContinueDelegate Delegate

Represents the method that will notify callers when a continue has been received by the client.

[Visual Basic]
Public Delegate Sub HttpContinueDelegate( _
   ByVal StatusCode As Integer, _
   ByVal httpHeaders As WebHeaders _
)
[C#]
public delegate void HttpContinueDelegate(
   int StatusCode,
   WebHeaders httpHeaders
);
[C++]
public __gc __delegate void HttpContinueDelegate(
   int StatusCode,
   WebHeaders* httpHeaders
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the HttpContinueDelegate delegate declaration.

StatusCode
[To be supplied.]
httpHeaders
[To be supplied.]

Remarks

Use HttpContinueDelegate to specify the callback method to be called when a continue is received. When set, the delegate is called whenever protocol responses of type 100 are received.

This is useful when the client wants to display the stauts of data being received from the server.

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

System.Net Namespace


HttpExtension Class

[To be supplied.]

Object
HttpExtension

[Visual Basic]
Public Class HttpExtension
[C#]
public class HttpExtension
[C++]
public __gc class HttpExtension
[JScript]
public class HttpExtension

Remarks

[To be supplied.]

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

HttpExtension Members | System.Net Namespace


HttpExtension Members

Public:

Constructor

HttpExtension Constructor [To be supplied.]

Properties

HasAddedExtensionHeader | [To be supplied.]
Header | [To be supplied.]
ID | [To be supplied.]
Url | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HttpExtension Class | System.Net Namespace


HttpExtension Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal id As Integer, _
   ByVal url As String, _
   ByVal header As String _
)
[C#]
public HttpExtension(
   int id,
   string url,
   string header
);
[C++]
public: HttpExtension(
   int id,
   String* url,
   String* header
);
[JScript]
public function HttpExtension(
   id : int,
   url : String,
   header : String
);

Parameters

id
[To be supplied.]
url
[To be supplied.]
header
[To be supplied.]

See Also

HttpExtension Class | HttpExtension Members | System.Net Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

HttpExtension Properties

The properties of the HttpExtension class are listed below. For a complete list of HttpExtension class members, see the HttpExtension Members topic.

Public:

HasAddedExtensionHeader | [To be supplied.]
Header | [To be supplied.]
ID | [To be supplied.]
Url | [To be supplied.]

See Also

HttpExtension Class | System.Net Namespace


HttpExtension.HasAddedExtensionHeader

[To be supplied.]

[Visual Basic]
Public Property HasAddedExtensionHeader As Boolean
[C#]
public bool HasAddedExtensionHeader {get; set;}
[C++]
public: __property bool get_HasAddedExtensionHeader();
public: __property void set_HasAddedExtensionHeader(bool);
[JScript]
public function get HasAddedExtensionHeader() : Boolean;
public function set HasAddedExtensionHeader(Boolean);

See Also

HttpExtension Class | HttpExtension Members | System.Net Namespace


HttpExtension.Header

[To be supplied.]

[Visual Basic]
Public Property Header As String
[C#]
public string Header {get; set;}
[C++]
public: __property String* get_Header();
public: __property void set_Header(String*);
[JScript]
public function get Header() : String;
public function set Header(String);

See Also

HttpExtension Class | HttpExtension Members | System.Net Namespace


HttpExtension.ID

[To be supplied.]

[Visual Basic]
Public Property ID As Integer
[C#]
public int ID {get; set;}
[C++]
public: __property int get_ID();
public: __property void set_ID(int);
[JScript]
public function get ID() : int;
public function set ID(int);

See Also

HttpExtension Class | HttpExtension Members | System.Net Namespace


HttpExtension.Url

[To be supplied.]

[Visual Basic]
Public Property Url As String
[C#]
public string Url {get; set;}
[C++]
public: __property String* get_Url();
public: __property void set_Url(String*);
[JScript]
public function get Url() : String;
public function set Url(String);

See Also

HttpExtension Class | HttpExtension Members | System.Net Namespace


HttpStatusCode Class

Contains the values of status codes defined for the HTTP protocol.

Object
HttpStatusCode

[Visual Basic]
Public Class HttpStatusCode
[C#]
public class HttpStatusCode
[C++]
public __gc class HttpStatusCode
[JScript]
public class HttpStatusCode

Remarks

[To be supplied.]

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

HttpStatusCode Members | System.Net Namespace


HttpStatusCode Members

Public:

Constructor

HttpStatusCode Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Ambiguous | [To be supplied.]
Continue | [To be supplied.]
Moved | [To be supplied.]
OK | [To be supplied.]
Redirect | [To be supplied.]
RedirectKeepVerb | [To be supplied.]
RedirectMethod | [To be supplied.]
Unauthorized | [To be supplied.]
UseProxy | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HttpStatusCode Class | System.Net Namespace


HttpStatusCode Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public HttpStatusCode();
[C++]
public: HttpStatusCode();
[JScript]
public function HttpStatusCode();

See Also

HttpStatusCode Class | HttpStatusCode Members | System.Net Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

HttpStatusCode Fields

The fields of the HttpStatusCode class are listed below. For a complete list of HttpStatusCode class members, see the HttpStatusCode Members topic.

Public:

Ambiguous | [To be supplied.]
Continue | [To be supplied.]
Moved | [To be supplied.]
OK | [To be supplied.]
Redirect | [To be supplied.]
RedirectKeepVerb | [To be supplied.]
RedirectMethod | [To be supplied.]
Unauthorized | [To be supplied.]
UseProxy | [To be supplied.]

See Also

HttpStatusCode Class | System.Net Namespace


HttpStatusCode.Ambiguous

[To be supplied.]

[Visual Basic]
Public Const Ambiguous As Integer
[C#]
public const int Ambiguous;
[C++]
public: const int Ambiguous;
[JScript]
public var Ambiguous : int;

See Also

HttpStatusCode Class | HttpStatusCode Members | System.Net Namespace


HttpStatusCode.Continue

[To be supplied.]

[Visual Basic]
Public Const Continue As Integer
[C#]
public const int Continue;
[C++]
public: const int Continue;
[JScript]
public var Continue : int;

See Also

HttpStatusCode Class | HttpStatusCode Members | System.Net Namespace


HttpStatusCode.Moved

[To be supplied.]

[Visual Basic]
Public Const Moved As Integer
[C#]
public const int Moved;
[C++]
public: const int Moved;
[JScript]
public var Moved : int;

See Also

HttpStatusCode Class | HttpStatusCode Members | System.Net Namespace


HttpStatusCode.OK

[To be supplied.]

[Visual Basic]
Public Const OK As Integer
[C#]
public const int OK;
[C++]
public: const int OK;
[JScript]
public var OK : int;

See Also

HttpStatusCode Class | HttpStatusCode Members | System.Net Namespace


HttpStatusCode.Redirect

[To be supplied.]

[Visual Basic]
Public Const Redirect As Integer
[C#]
public const int Redirect;
[C++]
public: const int Redirect;
[JScript]
public var Redirect : int;

See Also

HttpStatusCode Class | HttpStatusCode Members | System.Net Namespace


HttpStatusCode.RedirectKeepVerb

[To be supplied.]

[Visual Basic]
Public Const RedirectKeepVerb As Integer
[C#]
public const int RedirectKeepVerb;
[C++]
public: const int RedirectKeepVerb;
[JScript]
public var RedirectKeepVerb : int;

See Also

HttpStatusCode Class | HttpStatusCode Members | System.Net Namespace


HttpStatusCode.RedirectMethod

[To be supplied.]

[Visual Basic]
Public Const RedirectMethod As Integer
[C#]
public const int RedirectMethod;
[C++]
public: const int RedirectMethod;
[JScript]
public var RedirectMethod : int;

See Also

HttpStatusCode Class | HttpStatusCode Members | System.Net Namespace


HttpStatusCode.Unauthorized

[To be supplied.]

[Visual Basic]
Public Const Unauthorized As Integer
[C#]
public const int Unauthorized;
[C++]
public: const int Unauthorized;
[JScript]
public var Unauthorized : int;

See Also

HttpStatusCode Class | HttpStatusCode Members | System.Net Namespace


HttpStatusCode.UseProxy

[To be supplied.]

[Visual Basic]
Public Const UseProxy As Integer
[C#]
public const int UseProxy;
[C++]
public: const int UseProxy;
[JScript]
public var UseProxy : int;

See Also

HttpStatusCode Class | HttpStatusCode Members | System.Net Namespace


HttpWebRequest Class

HttpWebRequest is an HTTP-specific implementation of the WebRequest class.

Object
WebRequest
HttpWebRequest

[Visual Basic]
Public Class HttpWebRequest
   Inherits WebRequest
[C#]
public class HttpWebRequest : WebRequest
[C++]
public __gc class HttpWebRequest : public WebRequest
[JScript]
public class HttpWebRequest extends WebRequest

Remarks

The HttpWebRequest class contains support for the properties and methods defined in WebRequest along with additional properties and methods that enable the user to interact directly with the HTTP protocol.

You should never directly create an instance of HttpWebRequest. Instead, you should call Create. If the scheme for the URI is "http://" or "

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

HttpWebRequest Members | System.Net Namespace


HttpWebRequest Members

Public:

Properties

Accept | Gets or sets the value of the Accept header.
Address | Gets the URI that actually responded to the request.
AllowAutoRedirect | Enables or disables automatically following redirection responses.
AllowWriteStreamBuffering | Enables or disables buffering the data stream sent to the server.
Connection | Gets and sets the value of the Connection header.
ConnectionGroupName | [To be supplied.]
ContentLength | Gets or sets the Content-Length header of the request.
ContentType | Gets and sets the value of the Content-Type header.
ContinueDelegate | [To be supplied.]
Credentials | Provides authentication information for the request.
Expect | Gets or sets the value of the Expect header.
HaveResponse | Returns true if a response has been received from the server.
Headers | A collection of HTTP headers stored as name value pairs.
IfModifiedSince | Gets or sets the value of the If-Modified-Since header.
KeepAlive | Gets or sets the value of the Keep-Alive header.
MaximumAutomaticRedirections | [To be supplied.]
Method | Gets or sets the request method.
Pipelined | Gets or sets the value of the
PreAuthenticate | Enables or disables pre-authentication.
Proxy | Gets or sets the proxy information for a request.
Referer | Gets or sets the value of the Referer header.
RequestURI | Gets the original URI of the request.
SendChunked | Enable and disable sending chunked data to the server.
SrvPoint | Gets the service point used for this request.
TransferEncoding | Gets or sets the value of the Transfer-Encoding header.
UserAgent | Gets or sets the value of the User-Agent header.
Version | Gets and sets the HTTP protocol version used in this request.

Methods

AddExtension | [To be supplied.]
AddRange | Overloaded. Adds a range header to the request.
BeginGetRequestStream | [To be supplied.]
BeginGetResponse | [To be supplied.]
CreateExtension | [To be supplied.]
EndGetRequestStream | [To be supplied.]
EndGetResponse | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRequestStream | Gets a Stream that the application can use to write request data.
GetResponse | Returns a response from a request to an Internet resource.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HttpWebRequest Class | System.Net Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

HttpWebRequest Properties

The properties of the HttpWebRequest class are listed below. For a complete list of HttpWebRequest class members, see the HttpWebRequest Members topic.

Public:

Accept | Gets or sets the value of the Accept header.
Address | Gets the URI that actually responded to the request.
AllowAutoRedirect | Enables or disables automatically following redirection responses.
AllowWriteStreamBuffering | Enables or disables buffering the data stream sent to the server.
Connection | Gets and sets the value of the Connection header.
ConnectionGroupName | [To be supplied.]
ContentLength | Gets or sets the Content-Length header of the request.
ContentType | Gets and sets the value of the Content-Type header.
ContinueDelegate | [To be supplied.]
Credentials | Provides authentication information for the request.
Expect | Gets or sets the value of the Expect header.
HaveResponse | Returns true if a response has been received from the server.
Headers | A collection of HTTP headers stored as name value pairs.
IfModifiedSince | Gets or sets the value of the If-Modified-Since header.
KeepAlive | Gets or sets the value of the Keep-Alive header.
MaximumAutomaticRedirections | [To be supplied.]
Method | Gets or sets the request method.
Pipelined | Gets or sets the value of the
PreAuthenticate | Enables or disables pre-authentication.
Proxy | Gets or sets the proxy information for a request.
Referer | Gets or sets the value of the Referer header.
RequestURI | Gets the original URI of the request.
SendChunked | Enable and disable sending chunked data to the server.
SrvPoint | Gets the service point used for this request.
TransferEncoding | Gets or sets the value of the Transfer-Encoding header.
UserAgent | Gets or sets the value of the User-Agent header.
Version | Gets and sets the HTTP protocol version used in this request.

See Also

HttpWebRequest Class | System.Net Namespace


HttpWebRequest.Accept

Gets or sets the value of the Accept header.

[Visual Basic]
Public Property Accept As String
[C#]
public string Accept {get; set;}
[C++]
public: __property String* get_Accept();
public: __property void set_Accept(String*);
[JScript]
public function get Accept() : String;
public function set Accept(String);

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.Address

Gets the URI that actually responded to the request.

[Visual Basic]
Public ReadOnly Property Address As URI
[C#]
public URI Address {get;}
[C++]
public: __property URI* get_Address();
[JScript]
public function get Address() : URI;

Remarks

Address is set to the URI that actually responds to a request, after all redirections that may happen during the request are complete.

The URI of the original request is kept in RequestURI.

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.AllowAutoRedirect

Enables or disables automatically following redirection responses.

[Visual Basic]
Public Property AllowAutoRedirect As Boolean
[C#]
public bool AllowAutoRedirect {get; set;}
[C++]
public: __property bool get_AllowAutoRedirect();
public: __property void set_AllowAutoRedirect(bool);
[JScript]
public function get AllowAutoRedirect() : Boolean;
public function set AllowAutoRedirect(Boolean);

Remarks

Set AllowAutoRedirect true to automatically follow HTTP redirection headers to the new location of the resource.

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.AllowWriteStreamBuffering

Enables or disables buffering the data stream sent to the server.

[Visual Basic]
Public Property AllowWriteStreamBuffering As Boolean
[C#]
public bool AllowWriteStreamBuffering {get; set;}
[C++]
public: __property bool get_AllowWriteStreamBuffering();
public: __property void set_AllowWriteStreamBuffering(bool);
[JScript]
public function get AllowWriteStreamBuffering() : Boolean;
public function set AllowWriteStreamBuffering(Boolean);

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.Connection

Gets and sets the value of the Connection header.

[Visual Basic]
Public Property Connection As String
[C#]
public string Connection {get; set;}
[C++]
public: __property String* get_Connection();
public: __property void set_Connection(String*);
[JScript]
public function get Connection() : String;
public function set Connection(String);

Exceptions

Exception Type | Condition
ArgumentException | The value of Connection is set to "keep-alive" or "close".

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.ConnectionGroupName

[To be supplied.]

[Visual Basic]
Overridable Public Property ConnectionGroupName As String
[C#]
public string ConnectionGroupName {override get; override set;}
[C++]
public: __property virtual String* get_ConnectionGroupName();
public: __property virtual void set_ConnectionGroupName(String*);
[JScript]
public function get ConnectionGroupName() : String;
public function set ConnectionGroupName(String);

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.ContentLength

Gets or sets the Content-Length header of the request.

[Visual Basic]
Overridable Public Property ContentLength As Long
[C#]
public long ContentLength {override get; override set;}
[C++]
public: __property virtual __int64 get_ContentLength();
public: __property virtual void set_ContentLength(__int64);
[JScript]
public function get ContentLength() : long;
public function set ContentLength(long);

Exceptions

Exception Type | Condition
InvalidOperationException | Data has already been written to the request stream.
ArgumentOutOfRangeException | The new ContentLength value is less than 0.

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.ContentType

Gets and sets the value of the Content-Type header.

[Visual Basic]
Overridable Public Property ContentType As String
[C#]
public string ContentType {override get; override set;}
[C++]
public: __property virtual String* get_ContentType();
public: __property virtual void set_ContentType(String*);
[JScript]
public function get ContentType() : String;
public function set ContentType(String);

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.ContinueDelegate

[To be supplied.]

[Visual Basic]
Public Property ContinueDelegate As HttpContinueDelegate
[C#]
public HttpContinueDelegate ContinueDelegate {get; set;}
[C++]
public: __property HttpContinueDelegate* get_ContinueDelegate();
public: __property void set_ContinueDelegate(HttpContinueDelegate*);
[JScript]
public function get ContinueDelegate() : HttpContinueDelegate;
public function set ContinueDelegate(HttpContinueDelegate);

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.Credentials

Provides authentication information for the request.

[Visual Basic]
Overridable Public Property Credentials As ICredentialLookup
[C#]
public ICredentialLookup Credentials {override get; override set;}
[C++]
public: __property virtual ICredentialLookup* get_Credentials();
public: __property virtual void set_Credentials(ICredentialLookup*);
[JScript]
public function get Credentials() : ICredentialLookup;
public function set Credentials(ICredentialLookup);

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.Expect

Gets or sets the value of the Expect header.

[Visual Basic]
Public Property Expect As String
[C#]
public string Expect {get; set;}
[C++]
public: __property String* get_Expect();
public: __property void set_Expect(String*);
[JScript]
public function get Expect() : String;
public function set Expect(String);

Exceptions

Exception Type | Condition
ArgumentException | Expect is set to "100-continue".

Remarks

By default, Expect contains "100-continue". You can add other values to the list Expect maintains, or you can delete all values except "100-continue" from the list by setting Expect to null.

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.HaveResponse

Returns true if a response has been received from the server.

[Visual Basic]
Public ReadOnly Property HaveResponse As Boolean
[C#]
public bool HaveResponse {get;}
[C++]
public: __property bool get_HaveResponse();
[JScript]
public function get HaveResponse() : Boolean;

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.Headers

A collection of HTTP headers stored as name value pairs.

[Visual Basic]
Overridable Public ReadOnly Property Headers As NameValueCollection
[C#]
public NameValueCollection Headers {override get;}
[C++]
public: __property virtual NameValueCollection* get_Headers();
[JScript]
public function get Headers() : NameValueCollection;

Remarks

The Headers collection contains protocol headers associated with a request. Some headers, listed below, are not stored in the Headers collection but are instead either set by the system or set using properties.

Headers set using properties are:

Header | Property
Transfer-Encoding | TransferEncoding
Content-Type | ContentType
Content-Length | ContentLength
Connection | Connection
Expect | Expect
Accept | Accept
Referer | Referer
User-Agent | UserAgent
Host | Set by system
Date | Set by system

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.IfModifiedSince

Gets or sets the value of the If-Modified-Since header.

[Visual Basic]
Public Property IfModifiedSince As DateTime
[C#]
public DateTime IfModifiedSince {get; set;}
[C++]
public: __property DateTime get_IfModifiedSince();
public: __property void set_IfModifiedSince(DateTime);
[JScript]
public function get IfModifiedSince() : DateTime;
public function set IfModifiedSince(DateTime);

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.KeepAlive

Gets or sets the value of the Keep-Alive header.

[Visual Basic]
Public Property KeepAlive As Boolean
[C#]
public bool KeepAlive {get; set;}
[C++]
public: __property bool get_KeepAlive();
public: __property void set_KeepAlive(bool);
[JScript]
public function get KeepAlive() : Boolean;
public function set KeepAlive(Boolean);

Remarks

The application uses KeepAlive to indicate its preference for persistant connections. When System.Net.KeepAlive is true, a persistant connection will be made to the servers that support persistant connections.

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.MaximumAutomaticRedirections

[To be supplied.]

[Visual Basic]
Public Property MaximumAutomaticRedirections As Integer
[C#]
public int MaximumAutomaticRedirections {get; set;}
[C++]
public: __property int get_MaximumAutomaticRedirections();
public: __property void set_MaximumAutomaticRedirections(int);
[JScript]
public function get MaximumAutomaticRedirections() : int;
public function set MaximumAutomaticRedirections(int);

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.Method

Gets or sets the request method.

[Visual Basic]
Overridable Public Property Method As String
[C#]
public string Method {override get; override set;}
[C++]
public: __property virtual String* get_Method();
public: __property virtual void set_Method(String*);
[JScript]
public function get Method() : String;
public function set Method(String);

Exceptions

Exception Type | Condition
ArgumentException | No method is supplied.

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.Pipelined

Gets or sets the value of the

[Visual Basic]
Public Property Pipelined As Boolean
[C#]
public bool Pipelined {get; set;}
[C++]
public: __property bool get_Pipelined();
public: __property void set_Pipelined(bool);
[JScript]
public function get Pipelined() : Boolean;
public function set Pipelined(Boolean);

Remarks

The application uses Pipelined to indicate its preference for pipelined connections. When System.Net.Pipelined is true, a pipelined connection may be made to the servers that support pipelined connections.

Pipelined connections are only made when KeepAlive is also true.

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.PreAuthenticate

Enables or disables pre-authentication.

[Visual Basic]
Overridable Public Property PreAuthenticate As Boolean
[C#]
public bool PreAuthenticate {override get; override set;}
[C++]
public: __property virtual bool get_PreAuthenticate();
public: __property virtual void set_PreAuthenticate(bool);
[JScript]
public function get PreAuthenticate() : Boolean;
public function set PreAuthenticate(Boolean);

Remarks

When PreAuthenticate is true, the WWW-Authenticate header is sent with the initial request if its value is known.

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.Proxy

Gets or sets the proxy information for a request.

[Visual Basic]
Public Property Proxy As IProxyInfo
[C#]
public IProxyInfo Proxy {get; set;}
[C++]
public: __property IProxyInfo* get_Proxy();
public: __property void set_Proxy(IProxyInfo*);
[JScript]
public function get Proxy() : IProxyInfo;
public function set Proxy(IProxyInfo);

Remarks

If System.Net.Proxy is a null reference (in Visual Basic Nothing), no proxy is used for the request.

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.Referer

Gets or sets the value of the Referer header.

[Visual Basic]
Public Property Referer As String
[C#]
public string Referer {get; set;}
[C++]
public: __property String* get_Referer();
public: __property void set_Referer(String*);
[JScript]
public function get Referer() : String;
public function set Referer(String);

Remarks

When System.Net.HttpWebRequest.AllowAutoRedirects is true, Referer will be set automatically if the request is redirected to another site.

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.RequestURI

Gets the original URI of the request.

[Visual Basic]
Overridable Public ReadOnly Property RequestURI As URI
[C#]
public URI RequestURI {override get;}
[C++]
public: __property virtual URI* get_RequestURI();
[JScript]
public function get RequestURI() : URI;

Remarks

The System.Net.Uri instance is passed to HttpWebRequest by the WebRequestFactory is always never null.

RequestURI is never changed by redirection. To get the actual URI that responded to the request, examine the Address property.

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.SendChunked

Enable and disable sending chunked data to the server.

[Visual Basic]
Public Property SendChunked As Boolean
[C#]
public bool SendChunked {get; set;}
[C++]
public: __property bool get_SendChunked();
public: __property void set_SendChunked(bool);
[JScript]
public function get SendChunked() : Boolean;
public function set SendChunked(Boolean);

Exceptions

Exception Type | Condition
InvalidOperationException | Data has already been written to the request stream.

Remarks

When SendChunked is true, data is sent to the server in segments. The server must support receiving chunked data, and ContentLength must be set to-1.

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.SrvPoint

Gets the service point used for this request.

[Visual Basic]
Public ReadOnly Property SrvPoint As ServicePoint
[C#]
public ServicePoint SrvPoint {get;}
[C++]
public: __property ServicePoint* get_SrvPoint();
[JScript]
public function get SrvPoint() : ServicePoint;

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.TransferEncoding

Gets or sets the value of the Transfer-Encoding header.

[Visual Basic]
Public Property TransferEncoding As String
[C#]
public string TransferEncoding {get; set;}
[C++]
public: __property String* get_TransferEncoding();
public: __property void set_TransferEncoding(String*);
[JScript]
public function get TransferEncoding() : String;
public function set TransferEncoding(String);

Exceptions

Exception Type | Condition
InvalidOperationException | TransferEncoding is set when SendChunked is false.
ArgumentException | System.Net.HttpWebRequest.TransferEndoding is set to the value "Chunked".

Remarks

You cannot set TransferEncoding without first setting SendChunked true. Clearing TransferEncoding by setting it to a null reference (in Visual Basic Nothing) has no effect the value of SendChunked.

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.UserAgent

Gets or sets the value of the User-Agent header.

[Visual Basic]
Public Property UserAgent As String
[C#]
public string UserAgent {get; set;}
[C++]
public: __property String* get_UserAgent();
public: __property void set_UserAgent(String*);
[JScript]
public function get UserAgent() : String;
public function set UserAgent(String);

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.Version

Gets and sets the HTTP protocol version used in this request.

[Visual Basic]
Public Property Version As ProtocolVersion
[C#]
public ProtocolVersion Version {get; set;}
[C++]
public: __property ProtocolVersion* get_Version();
public: __property void set_Version(ProtocolVersion*);
[JScript]
public function get Version() : ProtocolVersion;
public function set Version(ProtocolVersion);

Exceptions

Exception Type | Condition
ArgumentException | The HTTP protocol version is set to a value other than 1.0 or 1.1.

Remarks

HttpWebRequest supports only versions 1.0 and 1.1 of the HTTP protocol. Setting Version to a different version will throw an exception.

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

HttpWebRequest Methods

The methods of the HttpWebRequest class are listed below. For a complete list of HttpWebRequest class members, see the HttpWebRequest Members topic.

Public:

AddExtension | [To be supplied.]
AddRange | Overloaded. Adds a range header to the request.
BeginGetRequestStream | [To be supplied.]
BeginGetResponse | [To be supplied.]
CreateExtension | [To be supplied.]
EndGetRequestStream | [To be supplied.]
EndGetResponse | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRequestStream | Gets a Stream that the application can use to write request data.
GetResponse | Returns a response from a request to an Internet resource.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HttpWebRequest Class | System.Net Namespace


HttpWebRequest.AddExtension

[To be supplied.]

[Visual Basic]
Public Sub AddExtension( _
   ByVal extension As HttpExtension, _
   ByVal header As String, _
   ByVal value As String _
)
[C#]
public void AddExtension(
   HttpExtension extension,
   string header,
   string value
);
[C++]
public: void AddExtension(
   HttpExtension* extension,
   String* header,
   String* value
);
[JScript]
public function AddExtension(
   extension : HttpExtension,
   header : String,
   value : String
);

Parameters

extension
[To be supplied.]
header
[To be supplied.]
value
[To be supplied.]

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.AddRange

Adds a range header to the request.

Overload List

Adds a range header to a request for a specific range from the beginning or end of the requested data.

[Visual Basic] Overloads Public Sub AddRange(Integer)
[C#] public void AddRange(int);
[C++] public: void AddRange(int);
[JScript] public function AddRange(int);

Adds a range header to the request for a specified range.

[Visual Basic] Overloads Public Sub AddRange(Integer, Integer)
[C#] public void AddRange(int, int);
[C++] public: void AddRange(int, int);
[JScript] public function AddRange(int, int);

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.AddRange (Int32)

Adds a range header to a request for a specific range from the beginning or end of the requested data.

[Visual Basic]
Overloads Public Sub AddRange( _
   ByVal Range As Integer _
)
[C#]
public void AddRange(
   int Range
);
[C++]
public: void AddRange(
   int Range
);
[JScript]
public function AddRange(
   Range : int
);

Parameters

Range
The starting or ending point of the range.

Remarks

If Range is positive, the range requested will be from the start of the data to Range.

If Range is negative, the range requested will be from Range

to the end of the data.

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace | HttpWebRequest.AddRange Overload List


HttpWebRequest.AddRange (Int32, Int32)

Adds a range header to the request for a specified range.

[Visual Basic]
Overloads Public Sub AddRange( _
   ByVal From As Integer, _
   ByVal To As Integer _
)
[C#]
public void AddRange(
   int From,
   int To
);
[C++]
public: void AddRange(
   int From,
   int To
);
[JScript]
public function AddRange(
   From : int,
   To : int
);

Parameters

From
The position to start sending data.
To
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | from is greater than to -or- from or to is less than 0.

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace | HttpWebRequest.AddRange Overload List


HttpWebRequest.BeginGetRequestStream

[To be supplied.]

[Visual Basic]
Overrides Public Function BeginGetRequestStream( _
   ByVal Callback As AsyncCallback, _
   ByVal State As Object _
) As IAsyncResult
[C#]
public override IAsyncResult BeginGetRequestStream(
   AsyncCallback Callback,
   object State
);
[C++]
public: override IAsyncResult* BeginGetRequestStream(
   AsyncCallback* Callback,
   Object* State
);
[JScript]
public override function BeginGetRequestStream(
   Callback : AsyncCallback,
   State : Object
) : IAsyncResult;

Parameters

Callback
[To be supplied.]
State
[To be supplied.]

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.BeginGetResponse

[To be supplied.]

[Visual Basic]
Overrides Public Function BeginGetResponse( _
   ByVal Callback As AsyncCallback, _
   ByVal State As Object _
) As IAsyncResult
[C#]
public override IAsyncResult BeginGetResponse(
   AsyncCallback Callback,
   object State
);
[C++]
public: override IAsyncResult* BeginGetResponse(
   AsyncCallback* Callback,
   Object* State
);
[JScript]
public override function BeginGetResponse(
   Callback : AsyncCallback,
   State : Object
) : IAsyncResult;

Parameters

Callback
[To be supplied.]
State
[To be supplied.]

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.CreateExtension

[To be supplied.]

[Visual Basic]
Public Function CreateExtension( _
   ByVal url As String, _
   ByVal header As String _
) As HttpExtension
[C#]
public HttpExtension CreateExtension(
   string url,
   string header
);
[C++]
public: HttpExtension* CreateExtension(
   String* url,
   String* header
);
[JScript]
public function CreateExtension(
   url : String,
   header : String
) : HttpExtension;

Parameters

url
[To be supplied.]
header
[To be supplied.]

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.EndGetRequestStream

[To be supplied.]

[Visual Basic]
Overrides Public Function EndGetRequestStream( _
   ByVal AsyncResult As IAsyncResult _
) As Stream
[C#]
public override Stream EndGetRequestStream(
   IAsyncResult AsyncResult
);
[C++]
public: override Stream* EndGetRequestStream(
   IAsyncResult* AsyncResult
);
[JScript]
public override function EndGetRequestStream(
   AsyncResult : IAsyncResult
) : Stream;

Parameters

AsyncResult
[To be supplied.]

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.EndGetResponse

[To be supplied.]

[Visual Basic]
Overrides Public Function EndGetResponse( _
   ByVal AsyncResult As IAsyncResult _
) As WebResponse
[C#]
public override WebResponse EndGetResponse(
   IAsyncResult AsyncResult
);
[C++]
public: override WebResponse* EndGetResponse(
   IAsyncResult* AsyncResult
);
[JScript]
public override function EndGetResponse(
   AsyncResult : IAsyncResult
) : WebResponse;

Parameters

AsyncResult
[To be supplied.]

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.GetRequestStream

Gets a Stream that the application can use to write request data.

[Visual Basic]
Overrides Public Function GetRequestStream() As Stream
[C#]
public override Stream GetRequestStream();
[C++]
public: override Stream* GetRequestStream();
[JScript]
public override function GetRequestStream() : Stream;

Return Value

A Stream that can be used to write request data.

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebRequest.GetResponse

Returns a response from a request to an Internet resource.

[Visual Basic]
Overrides Public Function GetResponse() As WebResponse
[C#]
public override WebResponse GetResponse();
[C++]
public: override WebResponse* GetResponse();
[JScript]
public override function GetResponse() : WebResponse;

Return Value

A WebResponse instance containing the response from the Internet resource.

See Also

HttpWebRequest Class | HttpWebRequest Members | System.Net Namespace


HttpWebResponse Class

An HTTP-specific implementation of the WebResponse class.

Object
WebResponse
HttpWebResponse

[Visual Basic]
Public Class HttpWebResponse
   Inherits WebResponse
[C#]
public class HttpWebResponse : WebResponse
[C++]
public __gc class HttpWebResponse : public WebResponse
[JScript]
public class HttpWebResponse extends WebResponse

Remarks

The HttpWebResponse class contains support for the properties and methods included in WebResponse with additional elements that enable the user to interact directly with the HTTP protocol.You should never directly create an instance of HttpWebResponse. It is returned as result of a call to GetResponse.

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

HttpWebResponse Members | System.Net Namespace | WebResponse


HttpWebResponse Members

Public:

Properties

ContentEncoding | Gets the method used to encode the body of the response.
ContentLength | Gets the lenght of the content returned by the request.
ContentType | Gets the content type of the response.
Headers | Gets the headers associated with this response from the server.
LastModified | Gets the last date and time that the content of the response was modified.
Method | Gets the value of the method used to return the response.
ResponseURI | Gets the Uniform Resource Indentifier (URI) of the resource that returned the response.
ServerCertificate | Gets the server certificate returned with the response.
Status | Gets a number indicating the status of the response.
StatusDescription | Gets the status description returned with the response.
Version | Gets the version of the HTTP protocol used in the response.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetExtension | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetResponseHeader | Gets a specified header value returned with the response.
GetResponseStream | Gets the stream used for reading the body of the response from the server.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HttpWebResponse Class | System.Net Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

HttpWebResponse Properties

The properties of the HttpWebResponse class are listed below. For a complete list of HttpWebResponse class members, see the HttpWebResponse Members topic.

Public:

ContentEncoding | Gets the method used to encode the body of the response.
ContentLength | Gets the lenght of the content returned by the request.
ContentType | Gets the content type of the response.
Headers | Gets the headers associated with this response from the server.
LastModified | Gets the last date and time that the content of the response was modified.
Method | Gets the value of the method used to return the response.
ResponseURI | Gets the Uniform Resource Indentifier (URI) of the resource that returned the response.
ServerCertificate | Gets the server certificate returned with the response.
Status | Gets a number indicating the status of the response.
StatusDescription | Gets the status description returned with the response.
Version | Gets the version of the HTTP protocol used in the response.

See Also

HttpWebResponse Class | System.Net Namespace


HttpWebResponse.ContentEncoding

Gets the method used to encode the body of the response.

[Visual Basic]
Public ReadOnly Property ContentEncoding As String
[C#]
public string ContentEncoding {get;}
[C++]
public: __property String* get_ContentEncoding();
[JScript]
public function get ContentEncoding() : String;

Remarks

The ContentEncoding property contains the value of the Content-Encoding header returned with the response.

See Also

HttpWebResponse Class | HttpWebResponse Members | System.Net Namespace


HttpWebResponse.ContentLength

Gets the lenght of the content returned by the request.

[Visual Basic]
Overridable Public ReadOnly Property ContentLength As Long
[C#]
public long ContentLength {override get;}
[C++]
public: __property virtual __int64 get_ContentLength();
[JScript]
public function get ContentLength() : long;

Remarks

The ContentLength property contains the value of the Content-Length header returned with the response.

See Also

HttpWebResponse Class | HttpWebResponse Members | System.Net Namespace


HttpWebResponse.ContentType

Gets the content type of the response.

[Visual Basic]
Overridable Public ReadOnly Property ContentType As String
[C#]
public string ContentType {override get;}
[C++]
public: __property virtual String* get_ContentType();
[JScript]
public function get ContentType() : String;

Remarks

The ContentType property contains the value of the Content-Type header returned with the response.

See Also

HttpWebResponse Class | HttpWebResponse Members | System.Net Namespace


HttpWebResponse.Headers

Gets the headers associated with this response from the server.

[Visual Basic]
Overridable Public ReadOnly Property Headers As NameValueCollection
[C#]
public NameValueCollection Headers {override get;}
[C++]
public: __property virtual NameValueCollection* get_Headers();
[JScript]
public function get Headers() : NameValueCollection;

Remarks

The Headers property is a collection of name/value pairs containing the HTTP header values returned with the response.

See Also

HttpWebResponse Class | HttpWebResponse Members | System.Net Namespace


HttpWebResponse.LastModified

Gets the last date and time that the content of the response was modified.

[Visual Basic]
Public ReadOnly Property LastModified As DateTime
[C#]
public DateTime LastModified {get;}
[C++]
public: __property DateTime get_LastModified();
[JScript]
public function get LastModified() : DateTime;

Remarks

The LastModified property contains the value of the Last-Modified header received with the response.

See Also

HttpWebResponse Class | HttpWebResponse Members | System.Net Namespace


HttpWebResponse.Method

Gets the value of the method used to return the response.

[Visual Basic]
Public ReadOnly Property Method As String
[C#]
public string Method {get;}
[C++]
public: __property String* get_Method();
[JScript]
public function get Method() : String;

See Also

HttpWebResponse Class | HttpWebResponse Members | System.Net Namespace


HttpWebResponse.ResponseURI

Gets the Uniform Resource Indentifier (URI) of the resource that returned the response.

[Visual Basic]
Overridable Public ReadOnly Property ResponseURI As URI
[C#]
public URI ResponseURI {override get;}
[C++]
public: __property virtual URI* get_ResponseURI();
[JScript]
public function get ResponseURI() : URI;

See Also

HttpWebResponse Class | HttpWebResponse Members | System.Net Namespace


HttpWebResponse.ServerCertificate

Gets the server certificate returned with the response.

[Visual Basic]
Public ReadOnly Property ServerCertificate As X509Certificate
[C#]
public X509Certificate ServerCertificate {get;}
[C++]
public: __property X509Certificate* get_ServerCertificate();
[JScript]
public function get ServerCertificate() : X509Certificate;

See Also

HttpWebResponse Class | HttpWebResponse Members | System.Net Namespace


HttpWebResponse.Status

Gets a number indicating the status of the response.

[Visual Basic]
Overridable Public ReadOnly Property Status As Integer
[C#]
public int Status {override get;}
[C++]
public: __property virtual int get_Status();
[JScript]
public function get Status() : int;

Remarks

The Status parameter is a number indicating the status of the HTTP response. The expected values for status can be found in the HttpStatusCode class.

See Also

HttpWebResponse Class | HttpWebResponse Members | System.Net Namespace


HttpWebResponse.StatusDescription

Gets the status description returned with the response.

[Visual Basic]
Overridable Public ReadOnly Property StatusDescription As String
[C#]
public string StatusDescription {override get;}
[C++]
public: __property virtual String* get_StatusDescription();
[JScript]
public function get StatusDescription() : String;

See Also

HttpWebResponse Class | HttpWebResponse Members | System.Net Namespace


HttpWebResponse.Version

Gets the version of the HTTP protocol used in the response.

[Visual Basic]
Public ReadOnly Property Version As ProtocolVersion
[C#]
public ProtocolVersion Version {get;}
[C++]
public: __property ProtocolVersion* get_Version();
[JScript]
public function get Version() : ProtocolVersion;

See Also

HttpWebResponse Class | HttpWebResponse Members | System.Net Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

HttpWebResponse Methods

The methods of the HttpWebResponse class are listed below. For a complete list of HttpWebResponse class members, see the HttpWebResponse Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetExtension | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetResponseHeader | Gets a specified header value returned with the response.
GetResponseStream | Gets the stream used for reading the body of the response from the server.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HttpWebResponse Class | System.Net Namespace


HttpWebResponse.GetExtension

[To be supplied.]

[Visual Basic]
Public Function GetExtension( _
   ByVal extension As HttpExtension, _
   ByVal header As String _
) As String
[C#]
public string GetExtension(
   HttpExtension extension,
   string header
);
[C++]
public: String* GetExtension(
   HttpExtension* extension,
   String* header
);
[JScript]
public function GetExtension(
   extension : HttpExtension,
   header : String
) : String;

Parameters

extension
[To be supplied.]
header
[To be supplied.]

See Also

HttpWebResponse Class | HttpWebResponse Members | System.Net Namespace


HttpWebResponse.GetResponseHeader

Gets a specified header value returned with the response.

[Visual Basic]
Public Function GetResponseHeader( _
   ByVal headerName As String _
) As String
[C#]
public string GetResponseHeader(
   string headerName
);
[C++]
public: String* GetResponseHeader(
   String* headerName
);
[JScript]
public function GetResponseHeader(
   headerName : String
) : String;

Parameters

headerName
The header value to return.

Return Value

The value of the header specified.

See Also

HttpWebResponse Class | HttpWebResponse Members | System.Net Namespace


HttpWebResponse.GetResponseStream

Gets the stream used for reading the body of the response from the server.

[Visual Basic]
Overrides Public Function GetResponseStream() As Stream
[C#]
public override Stream GetResponseStream();
[C++]
public: override Stream* GetResponseStream();
[JScript]
public override function GetResponseStream() : Stream;

See Also

HttpWebResponse Class | HttpWebResponse Members | System.Net Namespace


IAuthenticationModule Interface

Provides the base authentication interface for Web client authentication modules.

IAuthenticationModule

[Visual Basic]
Public Interface IAuthenticationModule
[C#]
public interface IAuthenticationModule
[C++]
public __gc __interface IAuthenticationModule

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

Custom authentication modules should implement the IAuthenticationModule interface and then register with the Register method.

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

IAuthenticationModule Members | System.Net Namespace


IAuthenticationModule Members

Properties

AuthenticationType | The authentication scheme used by the host. Taken from the list of authentication types included in System.Net.AuthenticationTypes.
CanPreAuthenticate | Indicates whether the module implementing the interface supports pre-authentication.

Methods

CanRespond | Indicates that the authentication module can respond to the supplied challenge.
PreAuthenticate | [To be supplied.]
Respond | Returns an instance of the Authorization class in response to the authentication challenge from a server.

See Also

IAuthenticationModule Interface | System.Net Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IAuthenticationModule Properties

The properties of the IAuthenticationModule interface are listed below. For a complete list of IAuthenticationModule interface members, see the IAuthenticationModule Members topic.

AuthenticationType | The authentication scheme used by the host. Taken from the list of authentication types included in System.Net.AuthenticationTypes.
CanPreAuthenticate | Indicates whether the module implementing the interface supports pre-authentication.

See Also

IAuthenticationModule Interface | System.Net Namespace


IAuthenticationModule.AuthenticationType

The authentication scheme used by the host. Taken from the list of authentication types included in System.Net.AuthenticationTypes.

[Visual Basic]
ReadOnly Property AuthenticationType As String
[C#]
string AuthenticationType {get;}
[C++]
String* get_AuthenticationType() = 0;
[JScript]
abstract function get AuthenticationType() : String;

Remarks

The valid authentication types are listed in the System.Net.AuthenticationType class

See Also

IAuthenticationModule Interface | IAuthenticationModule Members | System.Net Namespace


IAuthenticationModule.CanPreAuthenticate

Indicates whether the module implementing the interface supports pre-authentication.

[Visual Basic]
ReadOnly Property CanPreAuthenticate As Boolean
[C#]
bool CanPreAuthenticate {get;}
[C++]
bool get_CanPreAuthenticate() = 0;
[JScript]
abstract function get CanPreAuthenticate() : Boolean;

See Also

IAuthenticationModule Interface | IAuthenticationModule Members | System.Net Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IAuthenticationModule Methods

The methods of the IAuthenticationModule interface are listed below. For a complete list of IAuthenticationModule interface members, see the IAuthenticationModule Members topic.

CanRespond | Indicates that the authentication module can respond to the supplied challenge.
PreAuthenticate | [To be supplied.]
Respond | Returns an instance of the Authorization class in response to the authentication challenge from a server.

See Also

IAuthenticationModule Interface | System.Net Namespace


IAuthenticationModule.CanRespond

Indicates that the authentication module can respond to the supplied challenge.

[Visual Basic]
Function CanRespond( _
   ByVal Challenge As String _
) As Boolean
[C#]
bool CanRespond(
   string Challenge
);
[C++]
bool CanRespond(
   String* Challenge
) = 0;
[JScript]
function CanRespond(
   Challenge : String
) : Boolean;

Parameters

Challenge
The authentication challenge sent by the server.

Return Value

true if the authentication module can respond to the supplied challenge; otherwise, false if the module cannot respond to the challenge.

Remarks

When an authentication challenge is received by the client, the AuthenticationManager calls the CanRespond method of each registered authentication module. The first module to respond true is then called to respond to the challenge.

See Also

IAuthenticationModule Interface | IAuthenticationModule Members | System.Net Namespace


IAuthenticationModule.PreAuthenticate

[To be supplied.]

[Visual Basic]
Function PreAuthenticate( _
   ByVal Request As WebRequest, _
   ByVal Credentials As ICredentialLookup _
) As Authorization
[C#]
Authorization PreAuthenticate(
   WebRequest Request,
   ICredentialLookup Credentials
);
[C++]
Authorization* PreAuthenticate(
   WebRequest* Request,
   ICredentialLookup* Credentials
) = 0;
[JScript]
function PreAuthenticate(
   Request : WebRequest,
   Credentials : ICredentialLookup
) : Authorization;

Parameters

Request
[To be supplied.]
Credentials
[To be supplied.]

See Also

IAuthenticationModule Interface | IAuthenticationModule Members | System.Net Namespace


IAuthenticationModule.Respond

Returns an instance of the Authorization class in response to the authentication challenge from a server.

[Visual Basic]
Function Respond( _
   ByVal Challenge As String, _
   ByVal Request As WebRequest, _
   ByVal Credentials As ICredentialLookup _
) As Authorization
[C#]
Authorization Respond(
   string Challenge,
   WebRequest Request,
   ICredentialLookup Credentials
);
[C++]
Authorization* Respond(
   String* Challenge,
   WebRequest* Request,
   ICredentialLookup* Credentials
) = 0;
[JScript]
function Respond(
   Challenge : String,
   Request : WebRequest,
   Credentials : ICredentialLookup
) : Authorization;

Parameters

Challenge
The authentication challenge sent by the server.
Request
The WebRequest instance associated with this challenge.
Credentials
The credentials associated with this challenge.

Return Value

Authorization instance.

See Also

IAuthenticationModule Interface | IAuthenticationModule Members | System.Net Namespace


ICertificatePolicy Interface

Validates a server certificate.

ICertificatePolicy

[Visual Basic]
Public Interface ICertificatePolicy
[C#]
public interface ICertificatePolicy
[C++]
public __gc __interface ICertificatePolicy

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

ICertificatePolicy Members | System.Net Namespace


ICertificatePolicy Members

Methods

CheckValidationResult Validates a server certificate.

See Also

ICertificatePolicy Interface | System.Net Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICertificatePolicy Methods

The methods of the ICertificatePolicy interface are listed below. For a complete list of ICertificatePolicy interface members, see the ICertificatePolicy Members topic.

CheckValidationResult Validates a server certificate.

See Also

ICertificatePolicy Interface | System.Net Namespace


ICertificatePolicy.CheckValidationResult

Validates a server certificate.

[Visual Basic]
Function CheckValidationResult( _
   ByVal SrvPoint As ServicePoint, _
   ByVal Certificate As X509Certificate, _
   ByVal Request As WebRequest, _
   ByVal CertificateProblem As Integer _
) As Boolean
[C#]
bool CheckValidationResult(
   ServicePoint SrvPoint,
   X509Certificate Certificate,
   WebRequest Request,
   int CertificateProblem
);
[C++]
bool CheckValidationResult(
   ServicePoint* SrvPoint,
   X509Certificate* Certificate,
   WebRequest* Request,
   int CertificateProblem
) = 0;
[JScript]
function CheckValidationResult(
   SrvPoint : ServicePoint,
   Certificate : X509Certificate,
   Request : WebRequest,
   CertificateProblem : int
) : Boolean;

Parameters

SrvPoint
The ServicePoint that will use the certificate.
Certificate
[To be supplied.]
Request
[To be supplied.]
CertificateProblem
[To be supplied.]

Return Value

true if the certificate was validated; otherwise, returns false.

See Also

ICertificatePolicy Interface | ICertificatePolicy Members | System.Net Namespace


ICredentialLookup Interface

Provides the base authentication interface for Web client authentication.

ICredentialLookup

[Visual Basic]
Public Interface ICredentialLookup
[C#]
public interface ICredentialLookup
[C++]
public __gc __interface ICredentialLookup

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement ICredentialLookup

Class | Description
CredentialCache | Provides storage for multiple credentials.
SingleCredential | Provides a simple username/ password pair for Web client authentication.

Remarks

[To be supplied]

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

ICredentialLookup Members | System.Net Namespace


ICredentialLookup Members

Methods

GetCredential Returns a NetworkCredential object that is associated with the supplied host, realm, and authentication type.

See Also

ICredentialLookup Interface | System.Net Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICredentialLookup Methods

The methods of the ICredentialLookup interface are listed below. For a complete list of ICredentialLookup interface members, see the ICredentialLookup Members topic.

GetCredential Returns a NetworkCredential object that is associated with the supplied host, realm, and authentication type.

See Also

ICredentialLookup Interface | System.Net Namespace


ICredentialLookup.GetCredential

Returns a NetworkCredential object that is associated with the supplied host, realm, and authentication type.

[Visual Basic]
Function GetCredential( _
   ByVal URI As String, _
   ByVal AuthType As String _
) As NetworkCredential
[C#]
NetworkCredential GetCredential(
   string URI,
   string AuthType
);
[C++]
NetworkCredential* GetCredential(
   String* URI,
   String* AuthType
) = 0;
[JScript]
function GetCredential(
   URI : String,
   AuthType : String
) : NetworkCredential;

Parameters

URI
The URI that the client is providing authentication for.
AuthType
The type of authentication as defined in the AuthenticationType class.

Return Value

NetworkCredential instance.

Remarks

[To be supplied]

See Also

ICredentialLookup Interface | ICredentialLookup Members | System.Net Namespace


IPAddress Class

Provides an internet protocol (IP) address.

Object
IPAddress

[Visual Basic]
Public Class IPAddress
[C#]
public class IPAddress
[C++]
public __gc class IPAddress
[JScript]
public class IPAddress

Remarks

[To be supplied.]

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

IPAddress Members | System.Net Namespace


IPAddress Members

Public:

Constructor

IPAddress Constructor Overloaded. Initializes a new instance of the IPAddress class.

Methods

Equals | Compares to IP addresses.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsLoopback | [To be supplied.]
ToString | Converts the Internet address to standard dotted quad format.

Fields

Address | [To be supplied.]
InaddrAny | [To be supplied.]
InaddrBroadcast | [To be supplied.]
InaddrLoopback | [To be supplied.]
InaddrNone | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IPAddress Class | System.Net Namespace


IPAddress Constructor

Initializes a new instance of the IPAddress class.

Overload List

Initializes a new instance of the IPAddress class with the specified address.

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public IPAddress(int);
[C++] public: IPAddress(int);
[JScript] public function IPAddress(int);

Initializes a new instance of the IPAddress class with the specified address.

[Visual Basic] Overloads Public Sub New(String)
[C#] public IPAddress(String);
[C++] public: IPAddress(String*);
[JScript] public function IPAddress(String);

See Also

IPAddress Class | IPAddress Members | System.Net Namespace


IPAddress Constructor (Int32)

Initializes a new instance of the IPAddress class with the specified address.

[Visual Basic]
Overloads Public Sub New( _
   ByVal newaddress As Integer _
)
[C#]
public IPAddress(
   int newaddress
);
[C++]
public: IPAddress(
   int newaddress
);
[JScript]
public function IPAddress(
   newaddress : int
);

Parameters

newaddress
[To be supplied.]

See Also

IPAddress Class | IPAddress Members | System.Net Namespace | IPAddress Constructor Overload List


IPAddress Constructor (String)

Initializes a new instance of the IPAddress class with the specified address.

[Visual Basic]
Overloads Public Sub New( _
   ByVal IPstring As String _
)
[C#]
public IPAddress(
   string IPstring
);
[C++]
public: IPAddress(
   String* IPstring
);
[JScript]
public function IPAddress(
   IPstring : String
);

Parameters

IPstring
An internet address in dotted-quad notation (i.e. 192.168.1.2).

See Also

IPAddress Class | IPAddress Members | System.Net Namespace | IPAddress Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IPAddress Methods

The methods of the IPAddress class are listed below. For a complete list of IPAddress class members, see the IPAddress Members topic.

Public:

Equals | Compares to IP addresses.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsLoopback | [To be supplied.]
ToString | Converts the Internet address to standard dotted quad format.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IPAddress Class | System.Net Namespace


IPAddress.Equals

Compares to IP addresses.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal rhs As Object _
) As Boolean
[C#]
public override bool Equals(
   object rhs
);
[C++]
public: override bool Equals(
   Object* rhs
);
[JScript]
public override function Equals(
   rhs : Object
) : Boolean;

Parameters

rhs
[To be supplied.]

Return Value

true if the two address are equal; otherwise, false.

See Also

IPAddress Class | IPAddress Members | System.Net Namespace


IPAddress.IsLoopback

[To be supplied.]

[Visual Basic]
Public Shared Function IsLoopback( _
   ByVal address As IPAddress _
) As Boolean
[C#]
public static bool IsLoopback(
   IPAddress address
);
[C++]
public: static bool IsLoopback(
   IPAddress* address
);
[JScript]
public static function IsLoopback(
   address : IPAddress
) : Boolean;

Parameters

address
[To be supplied.]

See Also

IPAddress Class | IPAddress Members | System.Net Namespace


IPAddress.ToString

Converts the Internet address to standard dotted quad format.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

The IP address in dotted-quad format (i.e. 192.168.1.2).

See Also

IPAddress Class | IPAddress Members | System.Net Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IPAddress Fields

The fields of the IPAddress class are listed below. For a complete list of IPAddress class members, see the IPAddress Members topic.

Public:

Address | [To be supplied.]
InaddrAny | [To be supplied.]
InaddrBroadcast | [To be supplied.]
InaddrLoopback | [To be supplied.]
InaddrNone | [To be supplied.]

See Also

IPAddress Class | System.Net Namespace


IPAddress.Address

[To be supplied.]

[Visual Basic]
Public Address As Integer
[C#]
public int Address;
[C++]
public: int Address;
[JScript]
public var Address : int;

See Also

IPAddress Class | IPAddress Members | System.Net Namespace


IPAddress.InaddrAny

[To be supplied.]

[Visual Basic]
Public Const InaddrAny As Integer
[C#]
public const int InaddrAny;
[C++]
public: const int InaddrAny;
[JScript]
public var InaddrAny : int;

See Also

IPAddress Class | IPAddress Members | System.Net Namespace


IPAddress.InaddrBroadcast

[To be supplied.]

[Visual Basic]
Public Const InaddrBroadcast As Integer
[C#]
public const int InaddrBroadcast;
[C++]
public: const int InaddrBroadcast;
[JScript]
public var InaddrBroadcast : int;

See Also

IPAddress Class | IPAddress Members | System.Net Namespace


IPAddress.InaddrLoopback

[To be supplied.]

[Visual Basic]
Public Const InaddrLoopback As Integer
[C#]
public const int InaddrLoopback;
[C++]
public: const int InaddrLoopback;
[JScript]
public var InaddrLoopback : int;

See Also

IPAddress Class | IPAddress Members | System.Net Namespace


IPAddress.InaddrNone

[To be supplied.]

[Visual Basic]
Public Const InaddrNone As Integer
[C#]
public const int InaddrNone;
[C++]
public: const int InaddrNone;
[JScript]
public var InaddrNone : int;

See Also

IPAddress Class | IPAddress Members | System.Net Namespace


IPEndPoint Class

Provides an IP address.

Object
IPEndPoint

[Visual Basic]
Public Class IPEndPoint
   Implements EndPoint
[C#]
public class IPEndPoint : EndPoint
[C++]
public __gc class IPEndPoint : public EndPoint
[JScript]
public class IPEndPoint implements EndPoint

Remarks

[To be supplied.]

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

IPEndPoint Members | System.Net Namespace


IPEndPoint Members

Public:

Constructor

IPEndPoint Constructor Overloaded. Creates a new instance of the IPEndPoint class.

Methods

Dump | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Serialize | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Address | Gets or sets the IP address.
MaxPort | Specifies the maximum acceptable value for the Port property.
MinPort | Specifies the minimum acceptable value for the Port property.
Port | Gets or sets the port.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IPEndPoint Class | System.Net Namespace


IPEndPoint Constructor

Creates a new instance of the IPEndPoint class.

Overload List

Creates a new instance of the IPEndPoint class with the specified address and port.

[Visual Basic] Overloads Public Sub New(Integer, Integer)
[C#] public IPEndPoint(int, int);
[C++] public: IPEndPoint(int, int);
[JScript] public function IPEndPoint(int, int);

Creates a new instance of the IPEndPoint class with the specified address and port.

[Visual Basic] Overloads Public Sub New(IPAddress, Integer)
[C#] public IPEndPoint(IPAddress, int);
[C++] public: IPEndPoint(IPAddress*, int);
[JScript] public function IPEndPoint(IPAddress, int);

See Also

IPEndPoint Class | IPEndPoint Members | System.Net Namespace


IPEndPoint Constructor (Int32, Int32)

Creates a new instance of the IPEndPoint class with the specified address and port.

[Visual Basic]
Overloads Public Sub New( _
   ByVal new_address As Integer, _
   ByVal new_port As Integer _
)
[C#]
public IPEndPoint(
   int new_address,
   int new_port
);
[C++]
public: IPEndPoint(
   int new_address,
   int new_port
);
[JScript]
public function IPEndPoint(
   new_address : int,
   new_port : int
);

Parameters

new_address
The IP address.
new_port
[To be supplied.]

See Also

IPEndPoint Class | IPEndPoint Members | System.Net Namespace | IPEndPoint Constructor Overload List


IPEndPoint Constructor (IPAddress, Int32)

Creates a new instance of the IPEndPoint class with the specified address and port.

[Visual Basic]
Overloads Public Sub New( _
   ByVal new_address As IPAddress, _
   ByVal new_port As Integer _
)
[C#]
public IPEndPoint(
   IPAddress new_address,
   int new_port
);
[C++]
public: IPEndPoint(
   IPAddress* new_address,
   int new_port
);
[JScript]
public function IPEndPoint(
   new_address : IPAddress,
   new_port : int
);

Parameters

new_address
The IP address.
new_port
The port number associated with the address.

See Also

IPEndPoint Class | IPEndPoint Members | System.Net Namespace | IPEndPoint Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IPEndPoint Methods

The methods of the IPEndPoint class are listed below. For a complete list of IPEndPoint class members, see the IPEndPoint Members topic.

Public:

Dump | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Serialize | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IPEndPoint Class | System.Net Namespace


IPEndPoint.Dump

[To be supplied.]

[Visual Basic]
Public Sub Dump()
[C#]
public void Dump();
[C++]
public: void Dump();
[JScript]
public function Dump();

See Also

IPEndPoint Class | IPEndPoint Members | System.Net Namespace


IPEndPoint.Serialize

[To be supplied.]

[Visual Basic]
Overridable Public Function Serialize() As Byte ()
[C#]
public virtual byte[] Serialize();
[C++]
public: virtual unsigned char* Serialize() [];
[JScript]
public function Serialize() : Byte[];

See Also

IPEndPoint Class | IPEndPoint Members | System.Net Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IPEndPoint Fields

The fields of the IPEndPoint class are listed below. For a complete list of IPEndPoint class members, see the IPEndPoint Members topic.

Public:

Address | Gets or sets the IP address.
MaxPort | Specifies the maximum acceptable value for the Port property.
MinPort | Specifies the minimum acceptable value for the Port property.
Port | Gets or sets the port.

See Also

IPEndPoint Class | System.Net Namespace


IPEndPoint.Address

Gets or sets the IP address.

[Visual Basic]
Public Address As IPAddress
[C#]
public IPAddress Address;
[C++]
public: IPAddress* Address;
[JScript]
public var Address : IPAddress;

See Also

IPEndPoint Class | IPEndPoint Members | System.Net Namespace


IPEndPoint.MaxPort

Specifies the maximum acceptable value for the Port property.

[Visual Basic]
Public Const MaxPort As Integer
[C#]
public const int MaxPort;
[C++]
public: const int MaxPort;
[JScript]
public var MaxPort : int;

See Also

IPEndPoint Class | IPEndPoint Members | System.Net Namespace


IPEndPoint.MinPort

Specifies the minimum acceptable value for the Port property.

[Visual Basic]
Public Const MinPort As Integer
[C#]
public const int MinPort;
[C++]
public: const int MinPort;
[JScript]
public var MinPort : int;

See Also

IPEndPoint Class | IPEndPoint Members | System.Net Namespace


IPEndPoint.Port

Gets or sets the port.

[Visual Basic]
Public Port As Short
[C#]
public short Port;
[C++]
public: short Port;
[JScript]
public var Port : Int16;

See Also

IPEndPoint Class | IPEndPoint Members | System.Net Namespace


IPHostEntry Class

Provides a container class for IP addresses.

Object
IPHostEntry

[Visual Basic]
Public Class IPHostEntry
[C#]
public class IPHostEntry
[C++]
public __gc class IPHostEntry
[JScript]
public class IPHostEntry

Remarks

The class enables you to provide a list of addresses with host names and aliases. It is used as a helper class with DNS and sockets classes.

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

IPHostEntry Members | System.Net Namespace


IPHostEntry Members

Public:

Constructor

IPHostEntry Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

AddressList | Provides an array of IPAddress objects.
Aliases | Provides an array of strings containing other DNS names that resolve to the IP addresses in AddressList.
Hostname | Contains the DNS name of the host.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IPHostEntry Class | System.Net Namespace


IPHostEntry Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public IPHostEntry();
[C++]
public: IPHostEntry();
[JScript]
public function IPHostEntry();

See Also

IPHostEntry Class | IPHostEntry Members | System.Net Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IPHostEntry Fields

The fields of the IPHostEntry class are listed below. For a complete list of IPHostEntry class members, see the IPHostEntry Members topic.

Public:

AddressList | Provides an array of IPAddress objects.
Aliases | Provides an array of strings containing other DNS names that resolve to the IP addresses in AddressList.
Hostname | Contains the DNS name of the host.

See Also

IPHostEntry Class | System.Net Namespace


IPHostEntry.AddressList

Provides an array of IPAddress objects.

[Visual Basic]
Public AddressList() As IPAddress
[C#]
public IPAddress[] AddressList;
[C++]
public: IPAddress* AddressList[];
[JScript]
public var AddressList : IPAddress[];

See Also

IPHostEntry Class | IPHostEntry Members | System.Net Namespace


IPHostEntry.Aliases

Provides an array of strings containing other DNS names that resolve to the IP addresses in AddressList.

[Visual Basic]
Public Aliases() As String
[C#]
public string[] Aliases;
[C++]
public: String* Aliases[];
[JScript]
public var Aliases : String[];

See Also

IPHostEntry Class | IPHostEntry Members | System.Net Namespace


IPHostEntry.Hostname

Contains the DNS name of the host.

[Visual Basic]
Public Hostname As String
[C#]
public string Hostname;
[C++]
public: String* Hostname;
[JScript]
public var Hostname : String;

See Also

IPHostEntry Class | IPHostEntry Members | System.Net Namespace


IProxyInfo Interface

Obtains summary information about a proxy.

IProxyInfo

[Visual Basic]
Public Interface IProxyInfo
[C#]
public interface IProxyInfo
[C++]
public __gc __interface IProxyInfo

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IProxyInfo

Class | Description
ProxyData | Contains information about a proxy.

Remarks

[To be supplied.]

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

IProxyInfo Members | System.Net Namespace


IProxyInfo Members

Properties

HostName | A string containing the host name of the proxy.
Port | The port number of the proxy.
ProxyType | An integer that represents the type of proxy.
UseProxy | Activates or deactivates the proxy.

See Also

IProxyInfo Interface | System.Net Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IProxyInfo Properties

The properties of the IProxyInfo interface are listed below. For a complete list of IProxyInfo interface members, see the IProxyInfo Members topic.

HostName | A string containing the host name of the proxy.
Port | The port number of the proxy.
ProxyType | An integer that represents the type of proxy.
UseProxy | Activates or deactivates the proxy.

See Also

IProxyInfo Interface | System.Net Namespace


IProxyInfo.HostName

A string containing the host name of the proxy.

[Visual Basic]
Property HostName As String
[C#]
string HostName {get; set;}
[C++]
String* get_HostName() = 0;void set_HostName(String*) = 0;
[JScript]
abstract function get HostName() : String;
public abstract function set HostName(String);

See Also

IProxyInfo Interface | IProxyInfo Members | System.Net Namespace


IProxyInfo.Port

The port number of the proxy.

[Visual Basic]
Property Port As Integer
[C#]
int Port {get; set;}
[C++]
int get_Port() = 0;void set_Port(int) = 0;
[JScript]
abstract function get Port() : int;
public abstract function set Port(int);

See Also

IProxyInfo Interface | IProxyInfo Members | System.Net Namespace


IProxyInfo.ProxyType

An integer that represents the type of proxy.

[Visual Basic]
Property ProxyType As Integer
[C#]
int ProxyType {get; set;}
[C++]
int get_ProxyType() = 0;void set_ProxyType(int) = 0;
[JScript]
abstract function get ProxyType() : int;
public abstract function set ProxyType(int);

See Also

IProxyInfo Interface | IProxyInfo Members | System.Net Namespace


IProxyInfo.UseProxy

Activates or deactivates the proxy.

[Visual Basic]
Property UseProxy As Boolean
[C#]
bool UseProxy {get; set;}
[C++]
bool get_UseProxy() = 0;void set_UseProxy(bool) = 0;
[JScript]
abstract function get UseProxy() : Boolean;
public abstract function set UseProxy(Boolean);

See Also

IProxyInfo Interface | IProxyInfo Members | System.Net Namespace


ISelectProxy Interface

Finds the proxy that should be used for a specific WebRequest.

ISelectProxy

[Visual Basic]
Public Interface ISelectProxy
[C#]
public interface ISelectProxy
[C++]
public __gc __interface ISelectProxy

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement ISelectProxy

Class | Description
DefaultControlObject | Stores basic proxy settings for the default proxy.

Remarks

[To be supplied.]

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

ISelectProxy Members | System.Net Namespace


ISelectProxy Members

Methods

CreateProxyOverride | Creates a proxy object.
SelectProxy | Returns a proxy object to use for an Internet request.

See Also

ISelectProxy Interface | System.Net Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ISelectProxy Methods

The methods of the ISelectProxy interface are listed below. For a complete list of ISelectProxy interface members, see the ISelectProxy Members topic.

CreateProxyOverride | Creates a proxy object.
SelectProxy | Returns a proxy object to use for an Internet request.

See Also

ISelectProxy Interface | System.Net Namespace


ISelectProxy.CreateProxyOverride

Creates a proxy object.

[Visual Basic]
Function CreateProxyOverride() As IProxyInfo
[C#]
IProxyInfo CreateProxyOverride();
[C++]
IProxyInfo* CreateProxyOverride() = 0;
[JScript]
function CreateProxyOverride() : IProxyInfo;

Return Value

A new instance of the class implementing the IProxyInfo interface.

See Also

ISelectProxy Interface | ISelectProxy Members | System.Net Namespace


ISelectProxy.SelectProxy

Returns a proxy object to use for an Internet request.

[Visual Basic]
Function SelectProxy( _
   ByVal Url As URI, _
   ByVal proxyInfo As IProxyInfo _
) As IProxyInfo
[C#]
IProxyInfo SelectProxy(
   URI Url,
   IProxyInfo proxyInfo
);
[C++]
IProxyInfo* SelectProxy(
   URI* Url,
   IProxyInfo* proxyInfo
) = 0;
[JScript]
function SelectProxy(
   Url : URI,
   proxyInfo : IProxyInfo
) : IProxyInfo;

Parameters

Url
The Uniform Resource Identifier for the desired Internet resource.
proxyInfo
[To be supplied.]

Return Value

A IProxyInfo instance describing the proxy object.

See Also

ISelectProxy Interface | ISelectProxy Members | System.Net Namespace


IWebRequestCreate Interface

The IWebRequestCreate interface is used by the WebRequestFactory class to create WebRequest instances for a registered scheme.

IWebRequestCreate

[Visual Basic]
Public Interface IWebRequestCreate
[C#]
public interface IWebRequestCreate
[C++]
public __gc __interface IWebRequestCreate

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

Classes that implement the IWebRequestCreate interface can be registered with the WebRequestFactory class and associated with a specific URI scheme so that the WebRequestFactory calls the class's Create method when a URI matching that scheme is requested.

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

IWebRequestCreate Members | System.Net Namespace


IWebRequestCreate Members

Methods

Create Creates a WebRequest instance.

See Also

IWebRequestCreate Interface | System.Net Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IWebRequestCreate Methods

The methods of the IWebRequestCreate interface are listed below. For a complete list of IWebRequestCreate interface members, see the IWebRequestCreate Members topic.

Create Creates a WebRequest instance.

See Also

IWebRequestCreate Interface | System.Net Namespace


IWebRequestCreate.Create

Creates a WebRequest instance.

[Visual Basic]
Function Create( _
   ByVal Url As URI _
) As WebRequest
[C#]
WebRequest Create(
   URI Url
);
[C++]
WebRequest* Create(
   URI* Url
) = 0;
[JScript]
function Create(
   Url : URI
) : WebRequest;

Parameters

Url
The URL of the Web resource.

Return Value

WebRequest object.

See Also

IWebRequestCreate Interface | IWebRequestCreate Members | System.Net Namespace


NetworkAccess Enumeration

Defines network access permissions.

[Visual Basic]
Public Enum NetworkAccess
[C#]
public enum NetworkAccess
[C++]
public enum NetworkAccess

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Accept | An application is allowed to accept connections from the Internet.
Connect | An application is allowed to connect to Internet resources.

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

System.Net Namespace


NetworkCredential Class

Provides credentials for password-based authentication schemes such as basic, digest, NTLM and Kerberos.

Object
NetworkCredential

[Visual Basic]
Public Class NetworkCredential
[C#]
public class NetworkCredential
[C++]
public __gc class NetworkCredential
[JScript]
public class NetworkCredential

Remarks

This class does not support public-key based authentication methods such as SSL client authentication.

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

NetworkCredential Members | System.Net Namespace


NetworkCredential Members

Public:

Constructor

NetworkCredential Constructor Overloaded. Initializes a new instance of the NetworkCredential class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Domain | The machine name that verifies the credentials. Usually this is the host machine.
Password | The password for the user name.
UserName | The user name associated with this credential.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NetworkCredential Class | System.Net Namespace


NetworkCredential Constructor

Initializes a new instance of the NetworkCredential class.

Overload List

Initializes a new instance of the NetworkCredential class with name and password set as specified.

[Visual Basic] Overloads Public Sub New(String, String)
[C#] public NetworkCredential(String, String);
[C++] public: NetworkCredential(String*, String*);
[JScript] public function NetworkCredential(String, String);

Initializes a new instance of the NetworkCredential class with name and password set as specified.

[Visual Basic] Overloads Public Sub New(String, String, String)
[C#] public NetworkCredential(String, String, String);
[C++] public: NetworkCredential(String*, String*, String*);
[JScript] public function NetworkCredential(String, String, String);

See Also

NetworkCredential Class | NetworkCredential Members | System.Net Namespace


NetworkCredential Constructor (String, String)

Initializes a new instance of the NetworkCredential class with name and password set as specified.

[Visual Basic]
Overloads Public Sub New( _
   ByVal Name As String, _
   ByVal Password As String _
)
[C#]
public NetworkCredential(
   string Name,
   string Password
);
[C++]
public: NetworkCredential(
   String* Name,
   String* Password
);
[JScript]
public function NetworkCredential(
   Name : String,
   Password : String
);

Parameters

Name
The user name associated with the credentials.
Password
The password for the user name.

See Also

NetworkCredential Class | NetworkCredential Members | System.Net Namespace | NetworkCredential Constructor Overload List


NetworkCredential Constructor (String, String, String)

Initializes a new instance of the NetworkCredential class with name and password set as specified.

[Visual Basic]
Overloads Public Sub New( _
   ByVal Name As String, _
   ByVal Password As String, _
   ByVal Domain As String _
)
[C#]
public NetworkCredential(
   string Name,
   string Password,
   string Domain
);
[C++]
public: NetworkCredential(
   String* Name,
   String* Password,
   String* Domain
);
[JScript]
public function NetworkCredential(
   Name : String,
   Password : String,
   Domain : String
);

Parameters

Name
The user name associated with the credentials.
Password
The password for the user name associated with the credentials.
Domain
The URI that these credentials are associated with.

See Also

NetworkCredential Class | NetworkCredential Members | System.Net Namespace | NetworkCredential Constructor Overload List


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

NetworkCredential Fields

The fields of the NetworkCredential class are listed below. For a complete list of NetworkCredential class members, see the NetworkCredential Members topic.

Public:

Domain | The machine name that verifies the credentials. Usually this is the host machine.
Password | The password for the user name.
UserName | The user name associated with this credential.

See Also

NetworkCredential Class | System.Net Namespace


NetworkCredential.Domain

The machine name that verifies the credentials. Usually this is the host machine.

[Visual Basic]
Public Domain As String
[C#]
public string Domain;
[C++]
public: String* Domain;
[JScript]
public var Domain : String;

See Also

NetworkCredential Class | NetworkCredential Members | System.Net Namespace


NetworkCredential.Password

The password for the user name.

[Visual Basic]
Public Password As String
[C#]
public string Password;
[C++]
public: String* Password;
[JScript]
public var Password : String;

See Also

NetworkCredential Class | NetworkCredential Members | System.Net Namespace


NetworkCredential.UserName

The user name associated with this credential.

[Visual Basic]
Public UserName As String
[C#]
public string UserName;
[C++]
public: String* UserName;
[JScript]
public var UserName : String;

See Also

NetworkCredential Class | NetworkCredential Members | System.Net Namespace


ProtocolVersion Class

Provides a generalized version number.

Object
ProtocolVersion

[Visual Basic]
Public Class ProtocolVersion
[C#]
public class ProtocolVersion
[C++]
public __gc class ProtocolVersion
[JScript]
public class ProtocolVersion

Remarks

The ProtocolVersion class encapsulates a version number expressed as a major version number/ minor version number pair.

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

ProtocolVersion Members | System.Net Namespace


ProtocolVersion Members

Public:

Constructor

ProtocolVersion Constructor Overloaded. Initializes a new instance of the ProtocolVersion class.

Properties

Major | Gets the major version number.
Minor | Gets the minor version number.

Methods

CompareTo | Compares two ProtocolVersion instances for equality.
Equals | Compares two ProtocolVersion instances for equality.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Converts a ProtocolVersion to a String.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProtocolVersion Class | System.Net Namespace


ProtocolVersion Constructor

Initializes a new instance of the ProtocolVersion class.

Overload List

Initializes a new instance of the ProtocolVersion with a version number extracted from the supplied parameter.

[Visual Basic] Overloads Public Sub New(String)
[C#] public ProtocolVersion(String);
[C++] public: ProtocolVersion(String*);
[JScript] public function ProtocolVersion(String);

Initializes a new ProtocolVersion instance with the specified major and minor version numbers.

[Visual Basic] Overloads Public Sub New(Integer, Integer)
[C#] public ProtocolVersion(int, int);
[C++] public: ProtocolVersion(int, int);
[JScript] public function ProtocolVersion(int, int);

See Also

ProtocolVersion Class | ProtocolVersion Members | System.Net Namespace


ProtocolVersion Constructor (String)

Initializes a new instance of the ProtocolVersion with a version number extracted from the supplied parameter.

[Visual Basic]
Overloads Public Sub New( _
   ByVal versionString As String _
)
[C#]
public ProtocolVersion(
   string versionString
);
[C++]
public: ProtocolVersion(
   String* versionString
);
[JScript]
public function ProtocolVersion(
   versionString : String
);

Parameters

versionString
The protocol version.

Exceptions

Exception Type | Condition
ArgumentException | versionString does not contain a version number -or- The Major or Minor version numbers are less than 0.
OverflowException | The Major or Minor version numbers in versionString will not are greater than the maximum allowed in a 32-bit signed integer.

Remarks

The constructor will search the contents of versionString seaching for the first occurance of a version number. If passed "HTTP/1.1" a ProtocolVersion instance is created with Major =1 and Minor =1.

See Also

ProtocolVersion Class | ProtocolVersion Members | System.Net Namespace | ProtocolVersion Constructor Overload List


ProtocolVersion Constructor (Int32, Int32)

Initializes a new ProtocolVersion instance with the specified major and minor version numbers.

[Visual Basic]
Overloads Public Sub New( _
   ByVal major As Integer, _
   ByVal minor As Integer _
)
[C#]
public ProtocolVersion(
   int major,
   int minor
);
[C++]
public: ProtocolVersion(
   int major,
   int minor
);
[JScript]
public function ProtocolVersion(
   major : int,
   minor : int
);

Parameters

major
The major version number.
minor
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentException | Either major or minor is less than 0.

See Also

ProtocolVersion Class | ProtocolVersion Members | System.Net Namespace | ProtocolVersion Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ProtocolVersion Properties

The properties of the ProtocolVersion class are listed below. For a complete list of ProtocolVersion class members, see the ProtocolVersion Members topic.

Public:

Major | Gets the major version number.
Minor | Gets the minor version number.

See Also

ProtocolVersion Class | System.Net Namespace


ProtocolVersion.Major

Gets the major version number.

[Visual Basic]
Public ReadOnly Property Major As Integer
[C#]
public int Major {get;}
[C++]
public: __property int get_Major();
[JScript]
public function get Major() : int;

See Also

ProtocolVersion Class | ProtocolVersion Members | System.Net Namespace


ProtocolVersion.Minor

Gets the minor version number.

[Visual Basic]
Public ReadOnly Property Minor As Integer
[C#]
public int Minor {get;}
[C++]
public: __property int get_Minor();
[JScript]
public function get Minor() : int;

See Also

ProtocolVersion Class | ProtocolVersion Members | System.Net Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ProtocolVersion Methods

The methods of the ProtocolVersion class are listed below. For a complete list of ProtocolVersion class members, see the ProtocolVersion Members topic.

Public:

CompareTo | Compares two ProtocolVersion instances for equality.
Equals | Compares two ProtocolVersion instances for equality.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Converts a ProtocolVersion to a String.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProtocolVersion Class | System.Net Namespace


ProtocolVersion.CompareTo

Compares two ProtocolVersion instances for equality.

[Visual Basic]
Public Function CompareTo( _
   ByVal comparand As Object _
) As Integer
[C#]
public int CompareTo(
   object comparand
);
[C++]
public: int CompareTo(
   Object* comparand
);
[JScript]
public function CompareTo(
   comparand : Object
) : int;

Parameters

comparand
The ProtocolVersion instance to compare with the current instance.

Return Value

The result of the comparison. Returns-1 if the current instance is less than comparand, 0 if the two instances are equal, and 1 if the current instance is more than comparand.

Exceptions

Exception Type | Condition
ArgumentException | comparand is not a ProtocolVersion instance.

See Also

ProtocolVersion Class | ProtocolVersion Members | System.Net Namespace | Equals


ProtocolVersion.Equals

Compares two ProtocolVersion instances for equality.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal comparand As Object _
) As Boolean
[C#]
public override bool Equals(
   object comparand
);
[C++]
public: override bool Equals(
   Object* comparand
);
[JScript]
public override function Equals(
   comparand : Object
) : Boolean;

Parameters

comparand
The ProtocolVersion instance to compare with the current instance.

Return Value

true, if the two instances are equal; otherwise, false.

Remarks

If you compare a ProtocolVersion instance to an instance of another class, Equals will return false.

See Also

ProtocolVersion Class | ProtocolVersion Members | System.Net Namespace | CompareTo


ProtocolVersion.ToString

Converts a ProtocolVersion to a String.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

The major and minor version numbers separated by a period (<major>.<minor>).

See Also

ProtocolVersion Class | ProtocolVersion Members | System.Net Namespace


ProtocolViolationException Class

An exception class used when an attempt is made to use an invalid protocol.

Object
Exception
ProtocolViolationException

[Visual Basic]
Public Class ProtocolViolationException
   Inherits Exception
[C#]
public class ProtocolViolationException : Exception
[C++]
public __gc class ProtocolViolationException : public Exception
[JScript]
public class ProtocolViolationException extends Exception

Remarks

The ProtocolViolationException is used most often in HTTP requests. An exception of this class is thrown, for example, when you attempt to send data with a HTTP GET request.

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

ProtocolViolationException Members | System.Net Namespace


ProtocolViolationException Members

Public:

Constructor

ProtocolViolationException Constructor Overloaded. Creates a new instance of the ProtocolViolationException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

ProtocolViolationException Class | System.Net Namespace


ProtocolViolationException Constructor

Creates a new instance of the ProtocolViolationException class.

Overload List

Creates a new instance of the ProtocolViolationException class.

[Visual Basic] Overloads Public Sub New()
[C#] public ProtocolViolationException();
[C++] public: ProtocolViolationException();
[JScript] public function ProtocolViolationException();

Creates a new instance of the ProtocolViolationException class with the specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public ProtocolViolationException(String);
[C++] public: ProtocolViolationException(String*);
[JScript] public function ProtocolViolationException(String);

See Also

ProtocolViolationException Class | ProtocolViolationException Members | System.Net Namespace


ProtocolViolationException Constructor ()

Creates a new instance of the ProtocolViolationException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ProtocolViolationException();
[C++]
public: ProtocolViolationException();
[JScript]
public function ProtocolViolationException();

See Also

ProtocolViolationException Class | ProtocolViolationException Members | System.Net Namespace | ProtocolViolationException Constructor Overload List


ProtocolViolationException Constructor (String)

Creates a new instance of the ProtocolViolationException class with the specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal S As String _
)
[C#]
public ProtocolViolationException(
   string S
);
[C++]
public: ProtocolViolationException(
   String* S
);
[JScript]
public function ProtocolViolationException(
   S : String
);

Parameters

S
The message string to provide to the calling method.

See Also

ProtocolViolationException Class | ProtocolViolationException Members | System.Net Namespace | ProtocolViolationException Constructor Overload List


ProxyData Class

Contains information about a proxy.

Object
ProxyData

[Visual Basic]
Public Class ProxyData
   Implements IProxyInfo
[C#]
public class ProxyData : IProxyInfo
[C++]
public __gc class ProxyData : public IProxyInfo
[JScript]
public class ProxyData implements IProxyInfo

Remarks

[To be supplied.]

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

ProxyData Members | System.Net Namespace


ProxyData Members

Public:

Constructor

ProxyData Constructor Initalizes a new instance of the ProxyData class.

Properties

HostName | Gets or sets the host name for the proxy.
OverrideSelectProxy | Activates or deactivates overriding the default proxy.
Port | Gets or sets the port number for the proxy.
ProxyType | Gets or sets the proxy type.
UseProxy | Enables or disables use of the proxy.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

PROXY_FTP_GW | Specifies that the proxy is an FTP gateway.
PROXY_SOCKS | Specifies that the proxy is a SOCKS server.
PROXY_STANDARD | Specifies that the proxy is a standard proxy.
PROXY_TUNNEL | Specifies that the proxy is a tunneling proxy.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProxyData Class | System.Net Namespace


ProxyData Constructor

Initalizes a new instance of the ProxyData class.

[Visual Basic]
Public Sub New()
[C#]
public ProxyData();
[C++]
public: ProxyData();
[JScript]
public function ProxyData();

See Also

ProxyData Class | ProxyData Members | System.Net Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ProxyData Properties

The properties of the ProxyData class are listed below. For a complete list of ProxyData class members, see the ProxyData Members topic.

Public:

HostName | Gets or sets the host name for the proxy.
OverrideSelectProxy | Activates or deactivates overriding the default proxy.
Port | Gets or sets the port number for the proxy.
ProxyType | Gets or sets the proxy type.
UseProxy | Enables or disables use of the proxy.

See Also

ProxyData Class | System.Net Namespace


ProxyData.HostName

Gets or sets the host name for the proxy.

[Visual Basic]
Overridable Public Property HostName As String
[C#]
public string HostName {virtual get; virtual set;}
[C++]
public: __property virtual String* get_HostName();
public: __property virtual void set_HostName(String*);
[JScript]
public function get HostName() : String;
public function set HostName(String);

See Also

ProxyData Class | ProxyData Members | System.Net Namespace


ProxyData.OverrideSelectProxy

Activates or deactivates overriding the default proxy.

[Visual Basic]
Public Property OverrideSelectProxy As Boolean
[C#]
public bool OverrideSelectProxy {get; set;}
[C++]
public: __property bool get_OverrideSelectProxy();
public: __property void set_OverrideSelectProxy(bool);
[JScript]
public function get OverrideSelectProxy() : Boolean;
public function set OverrideSelectProxy(Boolean);

See Also

ProxyData Class | ProxyData Members | System.Net Namespace


ProxyData.Port

Gets or sets the port number for the proxy.

[Visual Basic]
Overridable Public Property Port As Integer
[C#]
public int Port {virtual get; virtual set;}
[C++]
public: __property virtual int get_Port();
public: __property virtual void set_Port(int);
[JScript]
public function get Port() : int;
public function set Port(int);

See Also

ProxyData Class | ProxyData Members | System.Net Namespace


ProxyData.ProxyType

Gets or sets the proxy type.

[Visual Basic]
Overridable Public Property ProxyType As Integer
[C#]
public int ProxyType {virtual get; virtual set;}
[C++]
public: __property virtual int get_ProxyType();
public: __property virtual void set_ProxyType(int);
[JScript]
public function get ProxyType() : int;
public function set ProxyType(int);

See Also

ProxyData Class | ProxyData Members | System.Net Namespace


ProxyData.UseProxy

Enables or disables use of the proxy.

[Visual Basic]
Overridable Public Property UseProxy As Boolean
[C#]
public bool UseProxy {virtual get; virtual set;}
[C++]
public: __property virtual bool get_UseProxy();
public: __property virtual void set_UseProxy(bool);
[JScript]
public function get UseProxy() : Boolean;
public function set UseProxy(Boolean);

See Also

ProxyData Class | ProxyData Members | System.Net Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ProxyData Fields

The fields of the ProxyData class are listed below. For a complete list of ProxyData class members, see the ProxyData Members topic.

Public:

PROXY_FTP_GW | Specifies that the proxy is an FTP gateway.
PROXY_SOCKS | Specifies that the proxy is a SOCKS server.
PROXY_STANDARD | Specifies that the proxy is a standard proxy.
PROXY_TUNNEL | Specifies that the proxy is a tunneling proxy.

See Also

ProxyData Class | System.Net Namespace


ProxyData.PROXY_FTP_GW

Specifies that the proxy is an FTP gateway.

[Visual Basic]
Public Const PROXY_FTP_GW As Integer
[C#]
public const int PROXY_FTP_GW;
[C++]
public: const int PROXY_FTP_GW;
[JScript]
public var PROXY_FTP_GW : int;

See Also

ProxyData Class | ProxyData Members | System.Net Namespace


ProxyData.PROXY_SOCKS

Specifies that the proxy is a SOCKS server.

[Visual Basic]
Public Const PROXY_SOCKS As Integer
[C#]
public const int PROXY_SOCKS;
[C++]
public: const int PROXY_SOCKS;
[JScript]
public var PROXY_SOCKS : int;

See Also

ProxyData Class | ProxyData Members | System.Net Namespace


ProxyData.PROXY_STANDARD

Specifies that the proxy is a standard proxy.

[Visual Basic]
Public Const PROXY_STANDARD As Integer
[C#]
public const int PROXY_STANDARD;
[C++]
public: const int PROXY_STANDARD;
[JScript]
public var PROXY_STANDARD : int;

See Also

ProxyData Class | ProxyData Members | System.Net Namespace


ProxyData.PROXY_TUNNEL

Specifies that the proxy is a tunneling proxy.

[Visual Basic]
Public Const PROXY_TUNNEL As Integer
[C#]
public const int PROXY_TUNNEL;
[C++]
public: const int PROXY_TUNNEL;
[JScript]
public var PROXY_TUNNEL : int;

See Also

ProxyData Class | ProxyData Members | System.Net Namespace


SChannelCred.Flags Enumeration

[To be supplied.]

[Visual Basic]
Public Enum SChannelCred.Flags
[C#]
public enum SChannelCred.Flags
[C++]
public enum SChannelCred.Flags

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
NoDefaultCred | [To be supplied.]
NoNameCheck | [To be supplied.]
NoSystemMapper | [To be supplied.]
ValidateAuto | [To be supplied.]
ValidateManual | [To be supplied.]

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

System.Net Namespace


SChannelCred.Protocols Enumeration

[To be supplied.]

[Visual Basic]
Public Enum SChannelCred.Protocols
[C#]
public enum SChannelCred.Protocols
[C++]
public enum SChannelCred.Protocols

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
SP_PROT_SSL2_CLIENT | [To be supplied.]
SP_PROT_SSL3TLS1_CLIENTS | [To be supplied.]
SP_PROT_SSL3_CLIENT | [To be supplied.]
SP_PROT_TLS1_CLIENT | [To be supplied.]
SP_PROT_UNI_CLIENT | [To be supplied.]

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

System.Net Namespace


ServicePoint Class

Provides connection management for other classes.

Object
ServicePoint

[Visual Basic]
Public Class ServicePoint
[C#]
public class ServicePoint
[C++]
public __gc class ServicePoint
[JScript]
public class ServicePoint

Remarks

[To be supplied.]

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

ServicePoint Members | System.Net Namespace


ServicePoint Members

Public:

Properties

Address | Gets the Uniform Resource Identifier of the ServicePoint.
Certificate | Gets the certificate received for this ServicePoint.
ConnectionLimit | Gets or sets the maximum number of connections allowed on this ServicePoint.
ConnectionMode | Gets the connection mode in use by the ServicePoint. One of the ConnectionModes values.
ConnectionName | Gets the connection name established by the WebRequest that created the connection.
CurrentConnections | Gets the current number of Connection instances associated with this ServicePoint.
EndPoint | Gets the IP address or set of IP addresses associated with this ServicePoint.
IdleSince | Gets the date/time that the ServicePoint went idle.
MaxIdleTime | Gets or sets the maximum idle time allowed for this ServicePoint.
SupportsPipelining | Indicates that the ServicePoint supports pipelined connections.
Version | The version of the protocol being used on this ServicePoint.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

DefaultMaxIdleTime | The default maximum idle time for a ServicePoint. The default is 43,200 seconds, or 12 hours.
DefaultNonPersistentConnectionLimit | The number of non-persistant connections allowed on a ServicePoint.
DefaultPersistentConnectionLimit | The default number of persistent connections allowed on a ServicePoint.
LoopbackConnectionLimit | The default number of loopback (local) connections allowed on a ServicePoint.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ServicePoint Class | System.Net Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ServicePoint Properties

The properties of the ServicePoint class are listed below. For a complete list of ServicePoint class members, see the ServicePoint Members topic.

Public:

Address | Gets the Uniform Resource Identifier of the ServicePoint.
Certificate | Gets the certificate received for this ServicePoint.
ConnectionLimit | Gets or sets the maximum number of connections allowed on this ServicePoint.
ConnectionMode | Gets the connection mode in use by the ServicePoint. One of the ConnectionModes values.
ConnectionName | Gets the connection name established by the WebRequest that created the connection.
CurrentConnections | Gets the current number of Connection instances associated with this ServicePoint.
EndPoint | Gets the IP address or set of IP addresses associated with this ServicePoint.
IdleSince | Gets the date/time that the ServicePoint went idle.
MaxIdleTime | Gets or sets the maximum idle time allowed for this ServicePoint.
SupportsPipelining | Indicates that the ServicePoint supports pipelined connections.
Version | The version of the protocol being used on this ServicePoint.

See Also

ServicePoint Class | System.Net Namespace


ServicePoint.Address

Gets the Uniform Resource Identifier of the ServicePoint.

[Visual Basic]
Public ReadOnly Property Address As URI
[C#]
public URI Address {get;}
[C++]
public: __property URI* get_Address();
[JScript]
public function get Address() : URI;

See Also

ServicePoint Class | ServicePoint Members | System.Net Namespace


ServicePoint.Certificate

Gets the certificate received for this ServicePoint.

[Visual Basic]
Public ReadOnly Property Certificate As X509Certificate
[C#]
public X509Certificate Certificate {get;}
[C++]
public: __property X509Certificate* get_Certificate();
[JScript]
public function get Certificate() : X509Certificate;

Remarks

Only one certificate can be maintained for a service point even though multiple connections can be made.

See Also

ServicePoint Class | ServicePoint Members | System.Net Namespace


ServicePoint.ConnectionLimit

Gets or sets the maximum number of connections allowed on this ServicePoint.

[Visual Basic]
Public Property ConnectionLimit As Integer
[C#]
public int ConnectionLimit {get; set;}
[C++]
public: __property int get_ConnectionLimit();
public: __property void set_ConnectionLimit(int);
[JScript]
public function get ConnectionLimit() : int;
public function set ConnectionLimit(int);

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | The connection limit is 0 or less.

See Also

ServicePoint Class | ServicePoint Members | System.Net Namespace


ServicePoint.ConnectionMode

Gets the connection mode in use by the ServicePoint. One of the ConnectionModes values.

[Visual Basic]
Public ReadOnly Property ConnectionMode As ConnectionModes
[C#]
public ConnectionModes ConnectionMode {get;}
[C++]
public: __property ConnectionModes get_ConnectionMode();
[JScript]
public function get ConnectionMode() : ConnectionModes;

See Also

ServicePoint Class | ServicePoint Members | System.Net Namespace


ServicePoint.ConnectionName

Gets the connection name established by the WebRequest that created the connection.

[Visual Basic]
Public ReadOnly Property ConnectionName As String
[C#]
public string ConnectionName {get;}
[C++]
public: __property String* get_ConnectionName();
[JScript]
public function get ConnectionName() : String;

See Also

ServicePoint Class | ServicePoint Members | System.Net Namespace


ServicePoint.CurrentConnections

Gets the current number of Connection instances associated with this ServicePoint.

[Visual Basic]
Public ReadOnly Property CurrentConnections As Integer
[C#]
public int CurrentConnections {get;}
[C++]
public: __property int get_CurrentConnections();
[JScript]
public function get CurrentConnections() : int;

See Also

ServicePoint Class | ServicePoint Members | System.Net Namespace


ServicePoint.EndPoint

Gets the IP address or set of IP addresses associated with this ServicePoint.

[Visual Basic]
Public ReadOnly Property EndPoint As IPEndPoint
[C#]
public IPEndPoint EndPoint {get;}
[C++]
public: __property IPEndPoint* get_EndPoint();
[JScript]
public function get EndPoint() : IPEndPoint;

See Also

ServicePoint Class | ServicePoint Members | System.Net Namespace


ServicePoint.IdleSince

Gets the date/time that the ServicePoint went idle.

[Visual Basic]
Public ReadOnly Property IdleSince As DateTime
[C#]
public DateTime IdleSince {get;}
[C++]
public: __property DateTime get_IdleSince();
[JScript]
public function get IdleSince() : DateTime;

See Also

ServicePoint Class | ServicePoint Members | System.Net Namespace


ServicePoint.MaxIdleTime

Gets or sets the maximum idle time allowed for this ServicePoint.

[Visual Basic]
Public Property MaxIdleTime As Integer
[C#]
public int MaxIdleTime {get; set;}
[C++]
public: __property int get_MaxIdleTime();
public: __property void set_MaxIdleTime(int);
[JScript]
public function get MaxIdleTime() : int;
public function set MaxIdleTime(int);

See Also

ServicePoint Class | ServicePoint Members | System.Net Namespace


ServicePoint.SupportsPipelining

Indicates that the ServicePoint supports pipelined connections.

[Visual Basic]
Public ReadOnly Property SupportsPipelining As Boolean
[C#]
public bool SupportsPipelining {get;}
[C++]
public: __property bool get_SupportsPipelining();
[JScript]
public function get SupportsPipelining() : Boolean;

See Also

ServicePoint Class | ServicePoint Members | System.Net Namespace


ServicePoint.Version

The version of the protocol being used on this ServicePoint.

[Visual Basic]
Overridable Public ReadOnly Property Version As ProtocolVersion
[C#]
public ProtocolVersion Version {virtual get;}
[C++]
public: __property virtual ProtocolVersion* get_Version();
[JScript]
public function get Version() : ProtocolVersion;

See Also

ServicePoint Class | ServicePoint Members | System.Net Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ServicePoint Fields

The fields of the ServicePoint class are listed below. For a complete list of ServicePoint class members, see the ServicePoint Members topic.

Public:

DefaultMaxIdleTime | The default maximum idle time for a ServicePoint. The default is 43,200 seconds, or 12 hours.
DefaultNonPersistentConnectionLimit | The number of non-persistant connections allowed on a ServicePoint.
DefaultPersistentConnectionLimit | The default number of persistent connections allowed on a ServicePoint.
LoopbackConnectionLimit | The default number of loopback (local) connections allowed on a ServicePoint.

See Also

ServicePoint Class | System.Net Namespace


ServicePoint.DefaultMaxIdleTime

The default maximum idle time for a ServicePoint. The default is 43,200 seconds, or 12 hours.

[Visual Basic]
Public Const DefaultMaxIdleTime As Integer
[C#]
public const int DefaultMaxIdleTime;
[C++]
public: const int DefaultMaxIdleTime;
[JScript]
public var DefaultMaxIdleTime : int;

See Also

ServicePoint Class | ServicePoint Members | System.Net Namespace


ServicePoint.DefaultNonPersistentConnectionLimit

The number of non-persistant connections allowed on a ServicePoint.

[Visual Basic]
Public Const DefaultNonPersistentConnectionLimit As Integer
[C#]
public const int DefaultNonPersistentConnectionLimit;
[C++]
public: const int DefaultNonPersistentConnectionLimit;
[JScript]
public var DefaultNonPersistentConnectionLimit : int;

See Also

ServicePoint Class | ServicePoint Members | System.Net Namespace


ServicePoint.DefaultPersistentConnectionLimit

The default number of persistent connections allowed on a ServicePoint.

[Visual Basic]
Public Const DefaultPersistentConnectionLimit As Integer
[C#]
public const int DefaultPersistentConnectionLimit;
[C++]
public: const int DefaultPersistentConnectionLimit;
[JScript]
public var DefaultPersistentConnectionLimit : int;

See Also

ServicePoint Class | ServicePoint Members | System.Net Namespace


ServicePoint.LoopbackConnectionLimit

The default number of loopback (local) connections allowed on a ServicePoint.

[Visual Basic]
Public Const LoopbackConnectionLimit As Integer
[C#]
public const int LoopbackConnectionLimit;
[C++]
public: const int LoopbackConnectionLimit;
[JScript]
public var LoopbackConnectionLimit : int;

See Also

ServicePoint Class | ServicePoint Members | System.Net Namespace


ServicePointManager Class

Manages the collection of ServicePoint instances.

Object
ServicePointManager

[Visual Basic]
Public Class ServicePointManager
[C#]
public class ServicePointManager
[C++]
public __gc class ServicePointManager
[JScript]
public class ServicePointManager

Remarks

The ServicePointManager is a static class.

Application should always use the ServicePointManager to create, maintain, and delete System.Net.ServicePoints.

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

ServicePointManager Members | System.Net Namespace


ServicePointManager Members

Public:

Properties

CertificatePolicy | Defines the policy for how to deal with server certificates.
MaxServicePointIdleTime | Gets or sets the maximum idle time in seconds of a ServicePoint.
MaxServicePoints | Gets or sets the maximum number of System.Net.ServicePoints that should be maintained at any time.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FindServicePoint | Overloaded. Finds an existing ServicePoint or creates a new ServicePoint to manage communication for this request.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ServicePointManager Class | System.Net Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ServicePointManager Properties

The properties of the ServicePointManager class are listed below. For a complete list of ServicePointManager class members, see the ServicePointManager Members topic.

Public:

CertificatePolicy | Defines the policy for how to deal with server certificates.
MaxServicePointIdleTime | Gets or sets the maximum idle time in seconds of a ServicePoint.
MaxServicePoints | Gets or sets the maximum number of System.Net.ServicePoints that should be maintained at any time.

See Also

ServicePointManager Class | System.Net Namespace


ServicePointManager.CertificatePolicy

Defines the policy for how to deal with server certificates.

[Visual Basic]
Public Shared Property CertificatePolicy As ICertificatePolicy
[C#]
public static ICertificatePolicy CertificatePolicy {get; set;}
[C++]
public: __property static ICertificatePolicy* get_CertificatePolicy();
public: __property static void set_CertificatePolicy(ICertificatePolicy*);
[JScript]
public static function get CertificatePolicy() : ICertificatePolicy;
public static function set CertificatePolicy(ICertificatePolicy);

See Also

ServicePointManager Class | ServicePointManager Members | System.Net Namespace


ServicePointManager.MaxServicePointIdleTime

Gets or sets the maximum idle time in seconds of a ServicePoint.

[Visual Basic]
Public Shared Property MaxServicePointIdleTime As Integer
[C#]
public static int MaxServicePointIdleTime {get; set;}
[C++]
public: __property static int get_MaxServicePointIdleTime();
public: __property static void set_MaxServicePointIdleTime(int);
[JScript]
public static function get MaxServicePointIdleTime() : int;
public static function set MaxServicePointIdleTime(int);

Remarks

After a ServicePoint has been idle for the time specified in MaxServicePointIdleTime it is elligible for garbage collection. A ServicePoint is idle when the list of Connection instances associated with the ServicePoint is empty.

Defaul value is 43,200 seconds (12 hours).

See Also

ServicePointManager Class | ServicePointManager Members | System.Net Namespace


ServicePointManager.MaxServicePoints

Gets or sets the maximum number of System.Net.ServicePoints that should be maintained at any time.

[Visual Basic]
Public Shared Property MaxServicePoints As Integer
[C#]
public static int MaxServicePoints {get; set;}
[C++]
public: __property static int get_MaxServicePoints();
public: __property static void set_MaxServicePoints(int);
[JScript]
public static function get MaxServicePoints() : int;
public static function set MaxServicePoints(int);

Remarks

The default value for MaxServicePoints is 0, which means there is no limit to the number of ServicePoint instances that may be maintained.

See Also

ServicePointManager Class | ServicePointManager Members | System.Net Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ServicePointManager Methods

The methods of the ServicePointManager class are listed below. For a complete list of ServicePointManager class members, see the ServicePointManager Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FindServicePoint | Overloaded. Finds an existing ServicePoint or creates a new ServicePoint to manage communication for this request.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ServicePointManager Class | System.Net Namespace


ServicePointManager.FindServicePoint

Finds an existing ServicePoint or creates a new ServicePoint to manage communication for this request.

Overload List

Findes an existing ServicePoint or creates a new ServicePoint to manage communications to the specified System.Uri instance.

[Visual Basic] Overloads Public Shared Function FindServicePoint(URI, IProxyInfo, IProxyInfo) As ServicePoint
[C#] public static ServicePoint FindServicePoint(URI, IProxyInfo, IProxyInfo);
[C++] public: static ServicePoint* FindServicePoint(URI*, IProxyInfo, IProxyInfo);
[JScript] public static function FindServicePoint(URI, IProxyInfo, IProxyInfo) : ServicePoint;

Findes an existing ServicePoint or creates a new ServicePoint to manage communications to the specified Uniform Resource Identifier.

[Visual Basic] Overloads Public Shared Function FindServicePoint(String, IProxyInfo, IProxyInfo) As ServicePoint
[C#] public static ServicePoint FindServicePoint(String, IProxyInfo, IProxyInfo);
[C++] public: static ServicePoint* FindServicePoint(String*, IProxyInfo, IProxyInfo);
[JScript] public static function FindServicePoint(String, IProxyInfo, IProxyInfo) : ServicePoint;

See Also

ServicePointManager Class | ServicePointManager Members | System.Net Namespace


ServicePointManager.FindServicePoint (URI, IProxyInfo, IProxyInfo)

Findes an existing ServicePoint or creates a new ServicePoint to manage communications to the specified System.Uri instance.

[Visual Basic]
Overloads Public Shared Function FindServicePoint( _
   ByVal address As URI, _
   ByVal ProxyIn As IProxyInfo, _
   ByRef ProxyOut As IProxyInfo _
) As ServicePoint
[C#]
public static ServicePoint FindServicePoint(
   URI address,
   IProxyInfo ProxyIn,
   ref IProxyInfo ProxyOut
);
[C++]
public: static ServicePoint* FindServicePoint(
   URI* address,
   IProxyInfo* ProxyIn,
   IProxyInfo** ProxyOut
);
[JScript]
public static function FindServicePoint(
   address : URI,
   ProxyIn : IProxyInfo,
   ProxyOut : IProxyInfo
) : ServicePoint;

Parameters

address
A System.Uri instance containing the address of the Internet resource to be contacted.
ProxyIn
[To be supplied.]
ProxyOut
[To be supplied.]

Return Value

The ServicePoint that will manage communications for the request.

See Also

ServicePointManager Class | ServicePointManager Members | System.Net Namespace | ServicePointManager.FindServicePoint Overload List


ServicePointManager.FindServicePoint (String, IProxyInfo, IProxyInfo)

Findes an existing ServicePoint or creates a new ServicePoint to manage communications to the specified Uniform Resource Identifier.

[Visual Basic]
Overloads Public Shared Function FindServicePoint( _
   ByVal UrlString As String, _
   ByVal ProxyIn As IProxyInfo, _
   ByRef ProxyOut As IProxyInfo _
) As ServicePoint
[C#]
public static ServicePoint FindServicePoint(
   string UrlString,
   IProxyInfo ProxyIn,
   ref IProxyInfo ProxyOut
);
[C++]
public: static ServicePoint* FindServicePoint(
   String* UrlString,
   IProxyInfo* ProxyIn,
   IProxyInfo** ProxyOut
);
[JScript]
public static function FindServicePoint(
   UrlString : String,
   ProxyIn : IProxyInfo,
   ProxyOut : IProxyInfo
) : ServicePoint;

Parameters

UrlString
The URI of the Internet resource to be contacted.
ProxyIn
[To be supplied.]
ProxyOut
[To be supplied.]

Return Value

The ServicePoint that will manage communications for the request.

See Also

ServicePointManager Class | ServicePointManager Members | System.Net Namespace | ServicePointManager.FindServicePoint Overload List


SingleCredential Class

Provides a simple username/ password pair for Web client authentication.

Object
SingleCredential

[Visual Basic]
Public Class SingleCredential
   Implements ICredentialLookup
[C#]
public class SingleCredential : ICredentialLookup
[C++]
public __gc class SingleCredential : public ICredentialLookup
[JScript]
public class SingleCredential implements ICredentialLookup

Remarks

[To be supplied.]

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

SingleCredential Members | System.Net Namespace


SingleCredential Members

Public:

Constructor

SingleCredential Constructor Overloaded. Creates an instance of the SingleCredential class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCredential | Returns an instance of the NetworkCredential class for a URI and authentication type.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SingleCredential Class | System.Net Namespace


SingleCredential Constructor

Creates an instance of the SingleCredential class.

Overload List

Creates an instance of the SingleCredential class with the supplied user name and password.

[Visual Basic] Overloads Public Sub New(String, String)
[C#] public SingleCredential(String, String);
[C++] public: SingleCredential(String*, String*);
[JScript] public function SingleCredential(String, String);

Returns a SingleCredential object that is associated with the supplied host, realm, and authentication type.

[Visual Basic] Overloads Public Sub New(String, String, String)
[C#] public SingleCredential(String, String, String);
[C++] public: SingleCredential(String*, String*, String*);
[JScript] public function SingleCredential(String, String, String);

See Also

SingleCredential Class | SingleCredential Members | System.Net Namespace


SingleCredential Constructor (String, String)

Creates an instance of the SingleCredential class with the supplied user name and password.

[Visual Basic]
Overloads Public Sub New( _
   ByVal name As String, _
   ByVal passwd As String _
)
[C#]
public SingleCredential(
   string name,
   string passwd
);
[C++]
public: SingleCredential(
   String* name,
   String* passwd
);
[JScript]
public function SingleCredential(
   name : String,
   passwd : String
);

Parameters

name
The username associated with these credentials.
passwd
The password for the username associated with these credentials.

Remarks

[To be provided]

See Also

SingleCredential Class | SingleCredential Members | System.Net Namespace | SingleCredential Constructor Overload List


SingleCredential Constructor (String, String, String)

Returns a SingleCredential object that is associated with the supplied host, realm, and authentication type.

[Visual Basic]
Overloads Public Sub New( _
   ByVal name As String, _
   ByVal password As String, _
   ByVal domain As String _
)
[C#]
public SingleCredential(
   string name,
   string password,
   string domain
);
[C++]
public: SingleCredential(
   String* name,
   String* password,
   String* domain
);
[JScript]
public function SingleCredential(
   name : String,
   password : String,
   domain : String
);

Parameters

name
The username associated with these credentials.
password
The password for the username associated with these credentials.
domain
The machine that verified the credentials.

Return Value

A SingleCredential instance.

Remarks

[To be provided]

See Also

SingleCredential Class | SingleCredential Members | System.Net Namespace | SingleCredential Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SingleCredential Methods

The methods of the SingleCredential class are listed below. For a complete list of SingleCredential class members, see the SingleCredential Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCredential | Returns an instance of the NetworkCredential class for a URI and authentication type.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SingleCredential Class | System.Net Namespace


SingleCredential.GetCredential

Returns an instance of the NetworkCredential class for a URI and authentication type.

[Visual Basic]
Overridable Public Function GetCredential( _
   ByVal URI As String, _
   ByVal AuthType As String _
) As NetworkCredential
[C#]
public virtual NetworkCredential GetCredential(
   string URI,
   string AuthType
);
[C++]
public: virtual NetworkCredential* GetCredential(
   String* URI,
   String* AuthType
);
[JScript]
public function GetCredential(
   URI : String,
   AuthType : String
) : NetworkCredential;

Parameters

URI
The URI that the client is providing authentication for.
AuthType
The type of authentication as defined in the AuthenticationType class.

Return Value

NetworkCredential instance.

See Also

SingleCredential Class | SingleCredential Members | System.Net Namespace


SocketPermission Class

Controls rights to make or accept connections on a transport address.

Object
CodeAccessPermission
SocketPermission

[Visual Basic]
Public Class SocketPermission
   Inherits CodeAccessPermission
   Implements IUnrestrictedPermission
[C#]
public class SocketPermission : CodeAccessPermission,
   IUnrestrictedPermission
[C++]
public __gc class SocketPermission : public CodeAccessPermission,
   IUnrestrictedPermission
[JScript]
public class SocketPermission extends CodeAccessPermission,
   IUnrestrictedPermission

Remarks

[To be supplied.]

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

SocketPermission Members | System.Net Namespace


SocketPermission Members

Public:

Constructor

SocketPermission Constructor Overloaded. Creates a new instance of the SocketPermission class.

Methods

AddPermission | Adds a permission to the set of permissions for a transport address.
Assert (inherited from CodeAccessPermission) | Asserts that the calling code can access the resource identified by the current permission object, even if callers have not been granted permission to access the resource. Calling the Assert method stops the check on previous callers in the call chain. Therefore, even if previous callers do not have the requisite permissions, they can still access resources. Warning: Because calling the Assert method removes the requirement that all code in the call chain must be granted permission to access the specified resource, it can open up security holes if used incorrectly or inappropriately. Therefore, it should be used with great caution.
CheckDemand | Checks the System.Security.Permissions.SocketPermission against a permission demand.
Copy | Creates a copy of a System.Security.Permissions.SocketPermission instance.
Demand (inherited from CodeAccessPermission) | Determines at run-time whether all callers in the call chain have been granted the permission specified by the current permission object.
DemandImmediate (inherited from CodeAccessPermission) | Determines whether the immediate caller of the code that calls this method has been granted the permission specified by the current permission object.
Deny (inherited from CodeAccessPermission) | Deny callers in the call chain the ability to access the resource specified by the current permission object. This method prevents callers from accessing the protected resource even if they have been granted permission to access it.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FromXml | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Intersect | Returns the logical intersection between two System.Security.Permissions.SocketPermission instances.
IsSubsetOf | Compares two System.Security.Permissions.SocketPermission instances.
IsUnrestricted | Checks the overall permission state of the object.
PermitOnly (inherited from CodeAccessPermission) | Ensures that only the resources specified by this permission object can be accessed, even if the code has been granted permission to access other resources.
ToString (inherited from CodeAccessPermission) | Creates and returns a String representation for the current permission object.
ToXml | [To be supplied.]
Union | Returns the logical union between two System.Security.Permissions.SocketPermission instances.

Fields

AllPorts Defines a constant representing all ports.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SocketPermission Class | System.Net Namespace


SocketPermission Constructor

Creates a new instance of the SocketPermission class.

Overload List

Creates a new instance of the SocketPermission class that passes all demands or that fails all demands.

[Visual Basic] Overloads Public Sub New(PermissionState)
[C#] public SocketPermission(PermissionState);
[C++] public: SocketPermission(PermissionState);
[JScript] public function SocketPermission(PermissionState);

Creates a new instance of the SocketPermissions class for the given transport address with the specified permission.

[Visual Basic] Overloads Public Sub New(NetworkAccess, TransportType, String, Integer)
[C#] public SocketPermission(NetworkAccess, TransportType, String, int);
[C++] public: SocketPermission(NetworkAccess, TransportType, String, int);
[JScript] public function SocketPermission(NetworkAccess, TransportType, String, int);

See Also

SocketPermission Class | SocketPermission Members | System.Net Namespace


SocketPermission Constructor (PermissionState)

Creates a new instance of the SocketPermission class that passes all demands or that fails all demands.

[Visual Basic]
Overloads Public Sub New( _
   ByVal State As PermissionState _
)
[C#]
public SocketPermission(
   PermissionState State
);
[C++]
public: SocketPermission(
   PermissionState State
);
[JScript]
public function SocketPermission(
   State : PermissionState
);

Parameters

State
One of the PermissionState values.

Remarks

If State is Unrestricted than the SocketPermission instance will pass all demands. Any other value for State will result in a SocketPermission instance that will fail all demands.

See Also

SocketPermission Class | SocketPermission Members | System.Net Namespace | SocketPermission Constructor Overload List


SocketPermission Constructor (NetworkAccess, TransportType, String, Int32)

Creates a new instance of the SocketPermissions class for the given transport address with the specified permission.

[Visual Basic]
Overloads Public Sub New( _
   ByVal Access As NetworkAccess, _
   ByVal Transport As TransportType, _
   ByVal Hostname As String, _
   ByVal PortNumber As Integer _
)
[C#]
public SocketPermission(
   NetworkAccess Access,
   TransportType Transport,
   string Hostname,
   int PortNumber
);
[C++]
public: SocketPermission(
   NetworkAccess Access,
   TransportType Transport,
   String* Hostname,
   int PortNumber
);
[JScript]
public function SocketPermission(
   Access : NetworkAccess,
   Transport : TransportType,
   Hostname : String,
   PortNumber : int
);

Parameters

Access
The access rights to grant for the transport address.
Transport
[To be supplied.]
Hostname
[To be supplied.]
PortNumber
[To be supplied.]

See Also

SocketPermission Class | SocketPermission Members | System.Net Namespace | SocketPermission Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SocketPermission Methods

The methods of the SocketPermission class are listed below. For a complete list of SocketPermission class members, see the SocketPermission Members topic.

Public:

AddPermission | Adds a permission to the set of permissions for a transport address.
Assert (inherited from CodeAccessPermission) | Asserts that the calling code can access the resource identified by the current permission object, even if callers have not been granted permission to access the resource. Calling the Assert method stops the check on previous callers in the call chain. Therefore, even if previous callers do not have the requisite permissions, they can still access resources. Warning: Because calling the Assert method removes the requirement that all code in the call chain must be granted permission to access the specified resource, it can open up security holes if used incorrectly or inappropriately. Therefore, it should be used with great caution.
CheckDemand | Checks the System.Security.Permissions.SocketPermission against a permission demand.
Copy | Creates a copy of a System.Security.Permissions.SocketPermission instance.
Demand (inherited from CodeAccessPermission) | Determines at run-time whether all callers in the call chain have been granted the permission specified by the current permission object.
DemandImmediate (inherited from CodeAccessPermission) | Determines whether the immediate caller of the code that calls this method has been granted the permission specified by the current permission object.
Deny (inherited from CodeAccessPermission) | Deny callers in the call chain the ability to access the resource specified by the current permission object. This method prevents callers from accessing the protected resource even if they have been granted permission to access it.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FromXml | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Intersect | Returns the logical intersection between two System.Security.Permissions.SocketPermission instances.
IsSubsetOf | Compares two System.Security.Permissions.SocketPermission instances.
IsUnrestricted | Checks the overall permission state of the object.
PermitOnly (inherited from CodeAccessPermission) | Ensures that only the resources specified by this permission object can be accessed, even if the code has been granted permission to access other resources.
ToString (inherited from CodeAccessPermission) | Creates and returns a String representation for the current permission object.
ToXml | [To be supplied.]
Union | Returns the logical union between two System.Security.Permissions.SocketPermission instances.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SocketPermission Class | System.Net Namespace


SocketPermission.AddPermission

Adds a permission to the set of permissions for a transport address.

[Visual Basic]
Public Sub AddPermission( _
   ByVal Access As NetworkAccess, _
   ByVal Transport As TransportType, _
   ByVal Hostname As String, _
   ByVal PortNumber As Integer _
)
[C#]
public void AddPermission(
   NetworkAccess Access,
   TransportType Transport,
   string Hostname,
   int PortNumber
);
[C++]
public: void AddPermission(
   NetworkAccess Access,
   TransportType Transport,
   String* Hostname,
   int PortNumber
);
[JScript]
public function AddPermission(
   Access : NetworkAccess,
   Transport : TransportType,
   Hostname : String,
   PortNumber : int
);

Parameters

Access
The access rights to grant for the transport address.
Transport
A value from the TransportType class.
Hostname
The host name for the transport address.
PortNumber
[To be supplied.]

Remarks

Permissions are checked with a logical OR operation.

See Also

SocketPermission Class | SocketPermission Members | System.Net Namespace


SocketPermission.CheckDemand

Checks the System.Security.Permissions.SocketPermission against a permission demand.

[Visual Basic]
Overrides Public Sub CheckDemand( _
   ByVal P As CodeAccessPermission _
)
[C#]
public override void CheckDemand(
   CodeAccessPermission P
);
[C++]
public: override void CheckDemand(
   CodeAccessPermission* P
);
[JScript]
public override function CheckDemand(
   P : CodeAccessPermission
);

Parameters

P
The permission demanded by the application.

Remarks

CheckDemand should never be called directly by an application. The method is implemented by all permission classes as the underlying test of a code access permission.

See Also

SocketPermission Class | SocketPermission Members | System.Net Namespace


SocketPermission.Copy

Creates a copy of a System.Security.Permissions.SocketPermission instance.

[Visual Basic]
Overrides Public Function Copy() As IPermission
[C#]
public override IPermission Copy();
[C++]
public: override IPermission* Copy();
[JScript]
public override function Copy() : IPermission;

Return Value

A new instance of the System.Security.Permissions.SocketPermission class that is a copy of the current instance.

See Also

SocketPermission Class | SocketPermission Members | System.Net Namespace


SocketPermission.FromXml

[To be supplied.]

[Visual Basic]
Overrides Public Sub FromXml( _
   ByVal esd As SecurityElement _
)
[C#]
public override void FromXml(
   SecurityElement esd
);
[C++]
public: override void FromXml(
   SecurityElement* esd
);
[JScript]
public override function FromXml(
   esd : SecurityElement
);

Parameters

esd
[To be supplied.]

See Also

SocketPermission Class | SocketPermission Members | System.Net Namespace


SocketPermission.Intersect

Returns the logical intersection between two System.Security.Permissions.SocketPermission instances.

[Visual Basic]
Overrides Public Function Intersect( _
   ByVal target As IPermission _
) As IPermission
[C#]
public override IPermission Intersect(
   IPermission target
);
[C++]
public: override IPermission* Intersect(
   IPermission* target
);
[JScript]
public override function Intersect(
   target : IPermission
) : IPermission;

Parameters

target
The System.Security.Permissions.SocketPermission instance to combine with the current instance.

Return Value

System.Security.Permissions.SocketPermission instance that represents the intersection of two System.Security.Permissions.SocketPermission instances.

See Also

SocketPermission Class | SocketPermission Members | System.Net Namespace


SocketPermission.IsSubsetOf

Compares two System.Security.Permissions.SocketPermission instances.

[Visual Basic]
Overrides Public Function IsSubsetOf( _
   ByVal target As IPermission _
) As Boolean
[C#]
public override bool IsSubsetOf(
   IPermission target
);
[C++]
public: override bool IsSubsetOf(
   IPermission* target
);
[JScript]
public override function IsSubsetOf(
   target : IPermission
) : Boolean;

Parameters

target
The second System.Security.Permissions.SocketPermission instance to compare.

Return Value

true if the current instance is a subset of target; otherwise, false.

See Also

SocketPermission Class | SocketPermission Members | System.Net Namespace


SocketPermission.IsUnrestricted

Checks the overall permission state of the object.

[Visual Basic]
Overridable Public Function IsUnrestricted() As Boolean
[C#]
public virtual bool IsUnrestricted();
[C++]
public: virtual bool IsUnrestricted();
[JScript]
public function IsUnrestricted() : Boolean;

Return Value

true if the SocketPermission instance was created with Unrestricted; otherwise, false.

See Also

SocketPermission Class | SocketPermission Members | System.Net Namespace


SocketPermission.ToXml

[To be supplied.]

[Visual Basic]
Overrides Public Function ToXml() As SecurityElement
[C#]
public override SecurityElement ToXml();
[C++]
public: override SecurityElement* ToXml();
[JScript]
public override function ToXml() : SecurityElement;

See Also

SocketPermission Class | SocketPermission Members | System.Net Namespace


SocketPermission.Union

Returns the logical union between two System.Security.Permissions.SocketPermission instances.

[Visual Basic]
Overrides Public Function Union( _
   ByVal target As IPermission _
) As IPermission
[C#]
public override IPermission Union(
   IPermission target
);
[C++]
public: override IPermission* Union(
   IPermission* target
);
[JScript]
public override function Union(
   target : IPermission
) : IPermission;

Parameters

target
The System.Security.Permissions.SocketPermission instance to combine with the current instance.

Return Value

System.Security.Permissions.SocketPermission instance that represents the union of two System.Security.Permissions.SocketPermission instances.

See Also

SocketPermission Class | SocketPermission Members | System.Net Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SocketPermission Fields

The fields of the SocketPermission class are listed below. For a complete list of SocketPermission class members, see the SocketPermission Members topic.

Public:

AllPorts Defines a constant representing all ports.

See Also

SocketPermission Class | System.Net Namespace


SocketPermission.AllPorts

Defines a constant representing all ports.

[Visual Basic]
Public Const AllPorts As Integer
[C#]
public const int AllPorts;
[C++]
public: const int AllPorts;
[JScript]
public var AllPorts : int;

See Also

SocketPermission Class | SocketPermission Members | System.Net Namespace


SocketsException Class

An exception class used when an invalid socket operation is performed.

Object
Exception
SocketsException

[Visual Basic]
Public Class SocketsException
   Inherits Exception
[C#]
public class SocketsException : Exception
[C++]
public __gc class SocketsException : public Exception
[JScript]
public class SocketsException extends Exception

Remarks

[To be supplied.]

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

SocketsException Members | System.Net Namespace


SocketsException Members

Public:

Constructor

SocketsException Constructor Overloaded. Creates a new instance of the SocketsException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

SocketsException Class | System.Net Namespace


SocketsException Constructor

Creates a new instance of the SocketsException class.

Overload List

Creates a new instance of the SocketsException class.

[Visual Basic] Overloads Public Sub New()
[C#] public SocketsException();
[C++] public: SocketsException();
[JScript] public function SocketsException();

Creates a new instance of the SocketsException class with the specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public SocketsException(String);
[C++] public: SocketsException(String*);
[JScript] public function SocketsException(String);

See Also

SocketsException Class | SocketsException Members | System.Net Namespace


SocketsException Constructor ()

Creates a new instance of the SocketsException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public SocketsException();
[C++]
public: SocketsException();
[JScript]
public function SocketsException();

See Also

SocketsException Class | SocketsException Members | System.Net Namespace | SocketsException Constructor Overload List


SocketsException Constructor (String)

Creates a new instance of the SocketsException class with the specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal S As String _
)
[C#]
public SocketsException(
   string S
);
[C++]
public: SocketsException(
   String* S
);
[JScript]
public function SocketsException(
   S : String
);

Parameters

S
The message string to provide to the calling method.

See Also

SocketsException Class | SocketsException Members | System.Net Namespace | SocketsException Constructor Overload List


SystemError Class

Maps system errors to their text definitions.

Object
SystemError

[Visual Basic]
Public Class SystemError
[C#]
public class SystemError
[C++]
public __gc class SystemError
[JScript]
public class SystemError

Remarks

[To be supplied.]

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

SystemError Members | System.Net Namespace


SystemError Members

Public:

Constructor

SystemError Constructor Overloaded. Creates a new instance of the SystemError class.

Properties

Error | Gets or sets the error number.
ErrorText | Gets the error text for Error.
LastSystemError | Creates a new instance of the SystemError class for the latest system error.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SystemError Class | System.Net Namespace


SystemError Constructor

Creates a new instance of the SystemError class.

Overload List

Creates a new instance of the SystemError class.

[Visual Basic] Overloads Public Sub New()
[C#] public SystemError();
[C++] public: SystemError();
[JScript] public function SystemError();

Creates a new instance of the SystemError class for the specified class.

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public SystemError(int);
[C++] public: SystemError(int);
[JScript] public function SystemError(int);

See Also

SystemError Class | SystemError Members | System.Net Namespace


SystemError Constructor ()

Creates a new instance of the SystemError class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public SystemError();
[C++]
public: SystemError();
[JScript]
public function SystemError();

See Also

SystemError Class | SystemError Members | System.Net Namespace | SystemError Constructor Overload List


SystemError Constructor (Int32)

Creates a new instance of the SystemError class for the specified class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal err As Integer _
)
[C#]
public SystemError(
   int err
);
[C++]
public: SystemError(
   int err
);
[JScript]
public function SystemError(
   err : int
);

Parameters

err
[To be supplied.]

See Also

SystemError Class | SystemError Members | System.Net Namespace | SystemError Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SystemError Properties

The properties of the SystemError class are listed below. For a complete list of SystemError class members, see the SystemError Members topic.

Public:

Error | Gets or sets the error number.
ErrorText | Gets the error text for Error.
LastSystemError | Creates a new instance of the SystemError class for the latest system error.

See Also

SystemError Class | System.Net Namespace


SystemError.Error

Gets or sets the error number.

[Visual Basic]
Public Property Error As Integer
[C#]
public int Error {get; set;}
[C++]
public: __property int get_Error();
public: __property void set_Error(int);
[JScript]
public function get Error() : int;
public function set Error(int);

See Also

SystemError Class | SystemError Members | System.Net Namespace


SystemError.ErrorText

Gets the error text for Error.

[Visual Basic]
Public ReadOnly Property ErrorText As String
[C#]
public string ErrorText {get;}
[C++]
public: __property String* get_ErrorText();
[JScript]
public function get ErrorText() : String;

See Also

SystemError Class | SystemError Members | System.Net Namespace


SystemError.LastSystemError

Creates a new instance of the SystemError class for the latest system error.

[Visual Basic]
Public Shared ReadOnly Property LastSystemError As SystemError
[C#]
public static SystemError LastSystemError {get;}
[C++]
public: __property static SystemError* get_LastSystemError();
[JScript]
public static function get LastSystemError() : SystemError;

See Also

SystemError Class | SystemError Members | System.Net Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SystemError Methods

The methods of the SystemError class are listed below. For a complete list of SystemError class members, see the SystemError Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SystemError Class | System.Net Namespace


SystemError.Finalize

[To be supplied.]

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

SystemError Class | SystemError Members | System.Net Namespace


TransportType Enumeration

Defines the transport type allowed for the socket.

[Visual Basic]
Public Enum TransportType
[C#]
public enum TransportType
[C++]
public enum TransportType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
All | Any connection is allowed.
TCP | TCP connections are allowed.
UDP | UDP connections are allowed.

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

System.Net Namespace


URLFormatException Class

An exception class used when an invalid Uniform Resource Identifier is detected.

Object
Exception
URIFormatException
URLFormatException

[Visual Basic]
Public Class URLFormatException
   Inherits URIFormatException
[C#]
public class URLFormatException : URIFormatException
[C++]
public __gc class URLFormatException : public URIFormatException
[JScript]
public class URLFormatException extends URIFormatException

Remarks

The URLFormatException is thrown by any method that takes a URI or URI prefix as one of its parameters and the URI is malformed in someway, such as the following URI: "http://skj-\sdf\/\."

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

URLFormatException Members | System.Net Namespace


URLFormatException Members

Public:

Constructor

URLFormatException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

URLFormatException Class | System.Net Namespace


URLFormatException Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public URLFormatException();
[C++] public: URLFormatException();
[JScript] public function URLFormatException();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public URLFormatException(String);
[C++] public: URLFormatException(String*);
[JScript] public function URLFormatException(String);

See Also

URLFormatException Class | URLFormatException Members | System.Net Namespace


URLFormatException Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public URLFormatException();
[C++]
public: URLFormatException();
[JScript]
public function URLFormatException();

See Also

URLFormatException Class | URLFormatException Members | System.Net Namespace | URLFormatException Constructor Overload List


URLFormatException Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal S As String _
)
[C#]
public URLFormatException(
   string S
);
[C++]
public: URLFormatException(
   String* S
);
[JScript]
public function URLFormatException(
   S : String
);

Parameters

S
[To be supplied.]

See Also

URLFormatException Class | URLFormatException Members | System.Net Namespace | URLFormatException Constructor Overload List


WebException Class

Provides network communication exceptions to the application.

Object
Exception
WebException

[Visual Basic]
Public Class WebException
   Inherits Exception
[C#]
public class WebException : Exception
[C++]
public __gc class WebException : public Exception
[JScript]
public class WebException extends Exception

Remarks

The WebException class

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

WebException Members | System.Net Namespace


WebException Members

Public:

Constructor

WebException Constructor Overloaded. Creates a new instance of the WebException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Response | Gets the error message returned from the remote host.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
Status | Gets the status of the response.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

WebException Class | System.Net Namespace


WebException Constructor

Creates a new instance of the WebException class.

Overload List

Creates a new instance of the WebException class with the default status Error from the WebStatus values.

[Visual Basic] Overloads Public Sub New()
[C#] public WebException();
[C++] public: WebException();
[JScript] public function WebException();

Creates a new instance of the WebException class with the specified error message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public WebException(String);
[C++] public: WebException(String*);
[JScript] public function WebException(String);

Creates a new instance of the WebException class with the specified error message and nested exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public WebException(String, Exception);
[C++] public: WebException(String*, Exception);
[JScript] public function WebException(String, Exception);

Creates a new instance of the WebException class with the specified error message and status.

[Visual Basic] Overloads Public Sub New(String, WebStatus)
[C#] public WebException(String, WebStatus);
[C++] public: WebException(String*, WebStatus);
[JScript] public function WebException(String, WebStatus);

Creates a new instance of the WebException class with the specified error message, nested exception, status and response.

[Visual Basic] Overloads Public Sub New(String, Exception, WebStatus, WebResponse)
[C#] public WebException(String, Exception, WebStatus, WebResponse);
[C++] public: WebException(String*, Exception, WebStatus, WebResponse);
[JScript] public function WebException(String, Exception, WebStatus, WebResponse);

See Also

WebException Class | WebException Members | System.Net Namespace


WebException Constructor ()

Creates a new instance of the WebException class with the default status Error from the WebStatus values.

[Visual Basic]
Overloads Public Sub New()
[C#]
public WebException();
[C++]
public: WebException();
[JScript]
public function WebException();

See Also

WebException Class | WebException Members | System.Net Namespace | WebException Constructor Overload List


WebException Constructor (String)

Creates a new instance of the WebException class with the specified error message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal Message As String _
)
[C#]
public WebException(
   string Message
);
[C++]
public: WebException(
   String* Message
);
[JScript]
public function WebException(
   Message : String
);

Parameters

Message
The text of the error message.

See Also

WebException Class | WebException Members | System.Net Namespace | WebException Constructor Overload List


WebException Constructor (String, Exception)

Creates a new instance of the WebException class with the specified error message and nested exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal Message As String, _
   ByVal InnerException As Exception _
)
[C#]
public WebException(
   string Message,
   Exception InnerException
);
[C++]
public: WebException(
   String* Message,
   Exception* InnerException
);
[JScript]
public function WebException(
   Message : String,
   InnerException : Exception
);

Parameters

Message
The text of the error message.
InnerException
[To be supplied.]

See Also

WebException Class | WebException Members | System.Net Namespace | WebException Constructor Overload List


WebException Constructor (String, WebStatus)

Creates a new instance of the WebException class with the specified error message and status.

[Visual Basic]
Overloads Public Sub New( _
   ByVal Message As String, _
   ByVal Status As WebStatus _
)
[C#]
public WebException(
   string Message,
   WebStatus Status
);
[C++]
public: WebException(
   String* Message,
   WebStatus Status
);
[JScript]
public function WebException(
   Message : String,
   Status : WebStatus
);

Parameters

Message
The text of the error message.
Status
[To be supplied.]

See Also

WebException Class | WebException Members | System.Net Namespace | WebException Constructor Overload List


WebException Constructor (String, Exception, WebStatus, WebResponse)

Creates a new instance of the WebException class with the specified error message, nested exception, status and response.

[Visual Basic]
Overloads Public Sub New( _
   ByVal Message As String, _
   ByVal InnerException As Exception, _
   ByVal Status As WebStatus, _
   ByVal Response As WebResponse _
)
[C#]
public WebException(
   string Message,
   Exception InnerException,
   WebStatus Status,
   WebResponse Response
);
[C++]
public: WebException(
   String* Message,
   Exception* InnerException,
   WebStatus Status,
   WebResponse* Response
);
[JScript]
public function WebException(
   Message : String,
   InnerException : Exception,
   Status : WebStatus,
   Response : WebResponse
);

Parameters

Message
The text of the error message.
InnerException
[To be supplied.]
Status
[To be supplied.]
Response
[To be supplied.]

See Also

WebException Class | WebException Members | System.Net Namespace | WebException Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

WebException Properties

The properties of the WebException class are listed below. For a complete list of WebException class members, see the WebException Members topic.

Public:

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Response | Gets the error message returned from the remote host.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
Status | Gets the status of the response.
TargetSite (inherited from Exception) | [To be supplied.]

See Also

WebException Class | System.Net Namespace


WebException.Response

Gets the error message returned from the remote host.

[Visual Basic]
Public ReadOnly Property Response As WebResponse
[C#]
public WebResponse Response {get;}
[C++]
public: __property WebResponse* get_Response();
[JScript]
public function get Response() : WebResponse;

Remarks

When an error response is received from the remote host, the response is contained in a standard WebResponse instance.

See Also

WebException Class | WebException Members | System.Net Namespace


WebException.Status

Gets the status of the response.

[Visual Basic]
Public ReadOnly Property Status As WebStatus
[C#]
public WebStatus Status {get;}
[C++]
public: __property WebStatus get_Status();
[JScript]
public function get Status() : WebStatus;

Remarks

The value of Status will one of WebStatus values.

See Also

WebException Class | WebException Members | System.Net Namespace


WebHeaders Class

Contains protocol headers associated with a request or response.

Object
NameObjectCollectionBase
NameValueCollection
WebHeaders

[Visual Basic]
Public Class WebHeaders
   Inherits NameValueCollection
[C#]
public class WebHeaders : NameValueCollection
[C++]
public __gc class WebHeaders : public NameValueCollection
[JScript]
public class WebHeaders extends NameValueCollection

Remarks

The WebHeaders class is based on the NameValueCollection class.

The WebHeaders class is generally accessed through TBD or TBD. Some common headers are considered "privileged" and are either exposed directly by the API (such as Content-Type) or protected by the system and cannot be changed.

The privileged headers are:

Transfer-Encoding |
Content-Type | Exposed through the API.
Content-Length | Exposed through the API.
Connection |
Expect |
Accept |
Referrer |
User-Agent |
Host |
Date |

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

WebHeaders Members | System.Net Namespace


WebHeaders Members

Public:

Constructor

WebHeaders Constructor Initializes a new instance of the WebHeaders class.

Properties

All (inherited from NameValueCollection) | [To be supplied.]
AllKeys (inherited from NameValueCollection) | [To be supplied.]
Count (inherited from NameObjectCollectionBase) | [To be supplied.]
Item (inherited from NameValueCollection) | Overloaded. [To be supplied.] In C#, this member is the indexer for the WebHeaders class.

Methods

Add | Overloaded. Adds a new header.
Clear (inherited from NameValueCollection) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get (inherited from NameValueCollection) | Overloaded. [To be supplied.]
GetEnumerator (inherited from NameObjectCollectionBase) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetKey (inherited from NameValueCollection) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValues (inherited from NameValueCollection) | Overloaded. [To be supplied.]
HasKeys (inherited from NameValueCollection) | [To be supplied.]
Remove | Removes the specified header.
Set | Sets the specified header to the specified value.
ToString (inherited from NameValueCollection) | [To be supplied.]

Protected:

Properties

ReadOnly (inherited from NameObjectCollectionBase) [To be supplied.]

Methods

BaseAdd (inherited from NameObjectCollectionBase) | [To be supplied.]
BaseClear (inherited from NameObjectCollectionBase) | [To be supplied.]
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. [To be supplied.]
BaseGetAllKeys (inherited from NameObjectCollectionBase) | [To be supplied.]
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. [To be supplied.]
BaseGetKey (inherited from NameObjectCollectionBase) | [To be supplied.]
BaseHasKeys (inherited from NameObjectCollectionBase) | [To be supplied.]
BaseRemove (inherited from NameObjectCollectionBase) | Overloaded. [To be supplied.]
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
InvalidateCachedArrays (inherited from NameValueCollection) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WebHeaders Class | System.Net Namespace


WebHeaders Constructor

Initializes a new instance of the WebHeaders class.

[Visual Basic]
Public Sub New()
[C#]
public WebHeaders();
[C++]
public: WebHeaders();
[JScript]
public function WebHeaders();

See Also

WebHeaders Class | WebHeaders Members | System.Net Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

WebHeaders Methods

The methods of the WebHeaders class are listed below. For a complete list of WebHeaders class members, see the WebHeaders Members topic.

Public:

Add | Overloaded. Adds a new header.
Clear (inherited from NameValueCollection) | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Get (inherited from NameValueCollection) | Overloaded. [To be supplied.]
GetEnumerator (inherited from NameObjectCollectionBase) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetKey (inherited from NameValueCollection) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
GetValues (inherited from NameValueCollection) | Overloaded. [To be supplied.]
HasKeys (inherited from NameValueCollection) | [To be supplied.]
Remove | Removes the specified header.
Set | Sets the specified header to the specified value.
ToString (inherited from NameValueCollection) | [To be supplied.]

Protected:

BaseAdd (inherited from NameObjectCollectionBase) | [To be supplied.]
BaseClear (inherited from NameObjectCollectionBase) | [To be supplied.]
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. [To be supplied.]
BaseGetAllKeys (inherited from NameObjectCollectionBase) | [To be supplied.]
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. [To be supplied.]
BaseGetKey (inherited from NameObjectCollectionBase) | [To be supplied.]
BaseHasKeys (inherited from NameObjectCollectionBase) | [To be supplied.]
BaseRemove (inherited from NameObjectCollectionBase) | Overloaded. [To be supplied.]
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. [To be supplied.]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
InvalidateCachedArrays (inherited from NameValueCollection) | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WebHeaders Class | System.Net Namespace


WebHeaders.Add

Adds a new header.

Overload List

Adds a new header with the indicated name and value.

[Visual Basic] Overloads Overrides Public Sub Add(String, String)
[C#] public override void Add(String, String);
[C++] public: override void Add(String*, String*);
[JScript] public override function Add(String, String);

Adds the indicated header.

[Visual Basic] Overloads Public Sub Add(String)
[C#] public void Add(String);
[C++] public: void Add(String*);
[JScript] public function Add(String);

See Also

WebHeaders Class | WebHeaders Members | System.Net Namespace


WebHeaders.Add (String, String)

Adds a new header with the indicated name and value.

[Visual Basic]
Overloads Overrides Public Sub Add( _
   ByVal name As String, _
   ByVal value As String _
)
[C#]
public override void Add(
   string name,
   string value
);
[C++]
public: override void Add(
   String* name,
   String* value
);
[JScript]
public override function Add(
   name : String,
   value : String
);

Parameters

name
The header to add.
value
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentException | header is a restricted header that should be set with a property setting.

Remarks

If the header specified in header is already present, value is concatenated with the existing value.

See Also

WebHeaders Class | WebHeaders Members | System.Net Namespace | WebHeaders.Add Overload List


WebHeaders.Add (String)

Adds the indicated header.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal header As String _
)
[C#]
public void Add(
   string header
);
[C++]
public: void Add(
   String* header
);
[JScript]
public function Add(
   header : String
);

Parameters

header
The header to add, name and value separated by a colon.

Exceptions

Exception Type | Condition
ArgumentException | The header does not contain a colon (:) character -or- The header is a restricted header that should be set with a property.

Remarks

The header value should be specified in the format Header: value.

If the header specified in header is already present, value is concatenated with the existing value.

See Also

WebHeaders Class | WebHeaders Members | System.Net Namespace | WebHeaders.Add Overload List


WebHeaders.GetValues

Gets an array of header values stored in a header.

[Visual Basic]
Overrides Public Function GetValues( _
   ByVal header As String _
) As String ()
[C#]
public override string[] GetValues(
   string header
);
[C++]
public: override String* GetValues(
   String* header
) [];
[JScript]
public override function GetValues(
   header : String
) : String[];

Parameters

header
The header to return.

Return Value

An array of header strings.

See Also

WebHeaders Class | WebHeaders Members | System.Net Namespace


WebHeaders.Remove

Removes the specified header.

[Visual Basic]
Overrides Public Sub Remove( _
   ByVal name As String _
)
[C#]
public override void Remove(
   string name
);
[C++]
public: override void Remove(
   String* name
);
[JScript]
public override function Remove(
   name : String
);

Parameters

name
The name of the header to remove.

See Also

WebHeaders Class | WebHeaders Members | System.Net Namespace


WebHeaders.Set

Sets the specified header to the specified value.

[Visual Basic]
Overrides Public Sub Set( _
   ByVal name As String, _
   ByVal value As String _
)
[C#]
public override void Set(
   string name,
   string value
);
[C++]
public: override void Set(
   String* name,
   String* value
);
[JScript]
public override function Set(
   name : String,
   value : String
);

Parameters

name
The header to add.
value
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentException | header is a restricted header that should be set with a property setting.

See Also

WebHeaders Class | WebHeaders Members | System.Net Namespace


WebPermission Class

Controls rights to make or accept connections on a Web address.

Object
CodeAccessPermission
WebPermission

[Visual Basic]
Public Class WebPermission
   Inherits CodeAccessPermission
   Implements IUnrestrictedPermission
[C#]
public class WebPermission : CodeAccessPermission,
   IUnrestrictedPermission
[C++]
public __gc class WebPermission : public CodeAccessPermission,
   IUnrestrictedPermission
[JScript]
public class WebPermission extends CodeAccessPermission,
   IUnrestrictedPermission

Remarks

[To be supplied.]

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

WebPermission Members | System.Net Namespace


WebPermission Members

Public:

Constructor

WebPermission Constructor Overloaded. Creates a new instance of the WebPermissions class.

Methods

AddPermission | Overloaded. Adds a new Web access permission.
Assert (inherited from CodeAccessPermission) | Asserts that the calling code can access the resource identified by the current permission object, even if callers have not been granted permission to access the resource. Calling the Assert method stops the check on previous callers in the call chain. Therefore, even if previous callers do not have the requisite permissions, they can still access resources. Warning: Because calling the Assert method removes the requirement that all code in the call chain must be granted permission to access the specified resource, it can open up security holes if used incorrectly or inappropriately. Therefore, it should be used with great caution.
CheckDemand | Checks the WebPermission against a permission demand.
Copy | Creates a copy of a WebPermission instance.
Demand (inherited from CodeAccessPermission) | Determines at run-time whether all callers in the call chain have been granted the permission specified by the current permission object.
DemandImmediate (inherited from CodeAccessPermission) | Determines whether the immediate caller of the code that calls this method has been granted the permission specified by the current permission object.
Deny (inherited from CodeAccessPermission) | Deny callers in the call chain the ability to access the resource specified by the current permission object. This method prevents callers from accessing the protected resource even if they have been granted permission to access it.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FromXml | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Intersect | Returns the logical intersection between two WebPermission instances.
IsSubsetOf | Compares two WebPermission instances.
IsUnrestricted | Checks the overall permisison state of the object.
PermitOnly (inherited from CodeAccessPermission) | Ensures that only the resources specified by this permission object can be accessed, even if the code has been granted permission to access other resources.
ToString (inherited from CodeAccessPermission) | Creates and returns a String representation for the current permission object.
ToXml | [To be supplied.]
Union | Returns the logical union between two WebPermission instances.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WebPermission Class | System.Net Namespace


WebPermission Constructor

Creates a new instance of the WebPermissions class.

Overload List

Creates a new instance of the WebPermissions class that passes all demands or that fails all demands.

[Visual Basic] Overloads Public Sub New(PermissionState)
[C#] public WebPermission(PermissionState);
[C++] public: WebPermission(PermissionState);
[JScript] public function WebPermission(PermissionState);

Creates a new instance of the System.Net.WebPermissions class.

[Visual Basic] Overloads Public Sub New()
[C#] public WebPermission();
[C++] public: WebPermission();
[JScript] public function WebPermission();

Creates a new instance of the WebPermission class with the specified access rights for the specified Uniform Resource Identifier regular expression.

[Visual Basic] Overloads Public Sub New(NetworkAccess, Regex)
[C#] public WebPermission(NetworkAccess, Regex);
[C++] public: WebPermission(NetworkAccess, Regex);
[JScript] public function WebPermission(NetworkAccess, Regex);

See Also

WebPermission Class | WebPermission Members | System.Net Namespace


WebPermission Constructor (PermissionState)

Creates a new instance of the WebPermissions class that passes all demands or that fails all demands.

[Visual Basic]
Overloads Public Sub New( _
   ByVal State As PermissionState _
)
[C#]
public WebPermission(
   PermissionState State
);
[C++]
public: WebPermission(
   PermissionState State
);
[JScript]
public function WebPermission(
   State : PermissionState
);

Parameters

State
One of the System.Net.PermissionState values.

Remarks

If State is Unrestricted than the WebPermission instance will pass all demands. Any other value for State will result in a WebPermission instance that will fail all demands.

See Also

WebPermission Class | WebPermission Members | System.Net Namespace | WebPermission Constructor Overload List


WebPermission Constructor ()

Creates a new instance of the System.Net.WebPermissions class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public WebPermission();
[C++]
public: WebPermission();
[JScript]
public function WebPermission();

See Also

WebPermission Class | WebPermission Members | System.Net Namespace | WebPermission Constructor Overload List


WebPermission Constructor (NetworkAccess, Regex)

Creates a new instance of the WebPermission class with the specified access rights for the specified Uniform Resource Identifier regular expression.

[Visual Basic]
Overloads Public Sub New( _
   ByVal access As NetworkAccess, _
   ByVal uriRegex As Regex _
)
[C#]
public WebPermission(
   NetworkAccess access,
   Regex uriRegex
);
[C++]
public: WebPermission(
   NetworkAccess access,
   Regex* uriRegex
);
[JScript]
public function WebPermission(
   access : NetworkAccess,
   uriRegex : Regex
);

Parameters

access
The access right to grant.
uriRegex
[To be supplied.]

See Also

WebPermission Class | WebPermission Members | System.Net Namespace | WebPermission Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

WebPermission Methods

The methods of the WebPermission class are listed below. For a complete list of WebPermission class members, see the WebPermission Members topic.

Public:

AddPermission | Overloaded. Adds a new Web access permission.
Assert (inherited from CodeAccessPermission) | Asserts that the calling code can access the resource identified by the current permission object, even if callers have not been granted permission to access the resource. Calling the Assert method stops the check on previous callers in the call chain. Therefore, even if previous callers do not have the requisite permissions, they can still access resources. Warning: Because calling the Assert method removes the requirement that all code in the call chain must be granted permission to access the specified resource, it can open up security holes if used incorrectly or inappropriately. Therefore, it should be used with great caution.
CheckDemand | Checks the WebPermission against a permission demand.
Copy | Creates a copy of a WebPermission instance.
Demand (inherited from CodeAccessPermission) | Determines at run-time whether all callers in the call chain have been granted the permission specified by the current permission object.
DemandImmediate (inherited from CodeAccessPermission) | Determines whether the immediate caller of the code that calls this method has been granted the permission specified by the current permission object.
Deny (inherited from CodeAccessPermission) | Deny callers in the call chain the ability to access the resource specified by the current permission object. This method prevents callers from accessing the protected resource even if they have been granted permission to access it.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FromXml | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Intersect | Returns the logical intersection between two WebPermission instances.
IsSubsetOf | Compares two WebPermission instances.
IsUnrestricted | Checks the overall permisison state of the object.
PermitOnly (inherited from CodeAccessPermission) | Ensures that only the resources specified by this permission object can be accessed, even if the code has been granted permission to access other resources.
ToString (inherited from CodeAccessPermission) | Creates and returns a String representation for the current permission object.
ToXml | [To be supplied.]
Union | Returns the logical union between two WebPermission instances.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WebPermission Class | System.Net Namespace


WebPermission.AddPermission

Adds a new Web access permission.

Overload List

Adds a new instance of the WebPermission class with the specified access rights for the specified Uniform Resource Identifier regular expression.

[Visual Basic] Overloads Public Sub AddPermission(NetworkAccess, Regex)
[C#] public void AddPermission(NetworkAccess, Regex);
[C++] public: void AddPermission(NetworkAccess, Regex);
[JScript] public function AddPermission(NetworkAccess, Regex);

Adds a new instance of the WebPermission class with the specified access rights for the specified Uniform Resource Identifier.

[Visual Basic] Overloads Public Sub AddPermission(NetworkAccess, String)
[C#] public void AddPermission(NetworkAccess, String);
[C++] public: void AddPermission(NetworkAccess, String);
[JScript] public function AddPermission(NetworkAccess, String);

See Also

WebPermission Class | WebPermission Members | System.Net Namespace


WebPermission.AddPermission (NetworkAccess, Regex)

Adds a new instance of the WebPermission class with the specified access rights for the specified Uniform Resource Identifier regular expression.

[Visual Basic]
Overloads Public Sub AddPermission( _
   ByVal access As NetworkAccess, _
   ByVal uriRegex As Regex _
)
[C#]
public void AddPermission(
   NetworkAccess access,
   Regex uriRegex
);
[C++]
public: void AddPermission(
   NetworkAccess access,
   Regex* uriRegex
);
[JScript]
public function AddPermission(
   access : NetworkAccess,
   uriRegex : Regex
);

Parameters

access
The access right to grant.
uriRegex
A regular expression describing the URI to grant the access right to.

See Also

WebPermission Class | WebPermission Members | System.Net Namespace | WebPermission.AddPermission Overload List


WebPermission.AddPermission (NetworkAccess, String)

Adds a new instance of the WebPermission class with the specified access rights for the specified Uniform Resource Identifier.

[Visual Basic]
Overloads Public Sub AddPermission( _
   ByVal access As NetworkAccess, _
   ByVal uriRegexPattern As String _
)
[C#]
public void AddPermission(
   NetworkAccess access,
   string uriRegexPattern
);
[C++]
public: void AddPermission(
   NetworkAccess access,
   String* uriRegexPattern
);
[JScript]
public function AddPermission(
   access : NetworkAccess,
   uriRegexPattern : String
);

Parameters

access
The access right to grant.
uriRegexPattern
[To be supplied.]

See Also

WebPermission Class | WebPermission Members | System.Net Namespace | WebPermission.AddPermission Overload List


WebPermission.CheckDemand

Checks the WebPermission against a permission demand.

[Visual Basic]
Overrides Public Sub CheckDemand( _
   ByVal P As CodeAccessPermission _
)
[C#]
public override void CheckDemand(
   CodeAccessPermission P
);
[C++]
public: override void CheckDemand(
   CodeAccessPermission* P
);
[JScript]
public override function CheckDemand(
   P : CodeAccessPermission
);

Parameters

P
The permission demanded by the application.

See Also

WebPermission Class | WebPermission Members | System.Net Namespace


WebPermission.Copy

Creates a copy of a WebPermission instance.

[Visual Basic]
Overrides Public Function Copy() As IPermission
[C#]
public override IPermission Copy();
[C++]
public: override IPermission* Copy();
[JScript]
public override function Copy() : IPermission;

Return Value

A new instance of the WebPermission class that is a copy of the current instance.

See Also

WebPermission Class | WebPermission Members | System.Net Namespace


WebPermission.FromXml

[To be supplied.]

[Visual Basic]
Overrides Public Sub FromXml( _
   ByVal esd As SecurityElement _
)
[C#]
public override void FromXml(
   SecurityElement esd
);
[C++]
public: override void FromXml(
   SecurityElement* esd
);
[JScript]
public override function FromXml(
   esd : SecurityElement
);

Parameters

esd
[To be supplied.]

See Also

WebPermission Class | WebPermission Members | System.Net Namespace


WebPermission.Intersect

Returns the logical intersection between two WebPermission instances.

[Visual Basic]
Overrides Public Function Intersect( _
   ByVal target As IPermission _
) As IPermission
[C#]
public override IPermission Intersect(
   IPermission target
);
[C++]
public: override IPermission* Intersect(
   IPermission* target
);
[JScript]
public override function Intersect(
   target : IPermission
) : IPermission;

Parameters

target
The WebPermission instance to combine with the current instance.

Return Value

WebPermission instance that represents the intersection of two WebPermission instances.

See Also

WebPermission Class | WebPermission Members | System.Net Namespace


WebPermission.IsSubsetOf

Compares two WebPermission instances.

[Visual Basic]
Overrides Public Function IsSubsetOf( _
   ByVal target As IPermission _
) As Boolean
[C#]
public override bool IsSubsetOf(
   IPermission target
);
[C++]
public: override bool IsSubsetOf(
   IPermission* target
);
[JScript]
public override function IsSubsetOf(
   target : IPermission
) : Boolean;

Parameters

target
The second WebPermission instance to compare.

Return Value

true if the current instance is a subset of target; otherwise, false.

See Also

WebPermission Class | WebPermission Members | System.Net Namespace


WebPermission.IsUnrestricted

Checks the overall permisison state of the object.

[Visual Basic]
Overridable Public Function IsUnrestricted() As Boolean
[C#]
public virtual bool IsUnrestricted();
[C++]
public: virtual bool IsUnrestricted();
[JScript]
public function IsUnrestricted() : Boolean;

Return Value

true if the WebPermission instance was created with Unrestricted; otherwise, false.

See Also

WebPermission Class | WebPermission Members | System.Net Namespace


WebPermission.ToXml

[To be supplied.]

[Visual Basic]
Overrides Public Function ToXml() As SecurityElement
[C#]
public override SecurityElement ToXml();
[C++]
public: override SecurityElement* ToXml();
[JScript]
public override function ToXml() : SecurityElement;

See Also

WebPermission Class | WebPermission Members | System.Net Namespace


WebPermission.Union

Returns the logical union between two WebPermission instances.

[Visual Basic]
Overrides Public Function Union( _
   ByVal target As IPermission _
) As IPermission
[C#]
public override IPermission Union(
   IPermission target
);
[C++]
public: override IPermission* Union(
   IPermission* target
);
[JScript]
public override function Union(
   target : IPermission
) : IPermission;

Parameters

target
The WebPermission instance to combine with the current instance.

Return Value

WebPermission instance that represents the union of two WebPermission instances.

See Also

WebPermission Class | WebPermission Members | System.Net Namespace


WebRequest Class

A request to a Uniform Resource Identifier (URI). This is an abstract class.

Object
WebRequest

[Visual Basic]
MustInherit Public Class WebRequest
[C#]
public abstract class WebRequest
[C++]
public __gc __abstract class WebRequest
[JScript]
public abstract class WebRequest

Remarks

The WebRequest class is a base class that is the ancestor to protocol specific classes for requesting data from the Internet. The WebRequest class is used to send a request to a particlaur Uniform Resource Identifier (URI), such as a Web page from a server. Applications can use the WebRequest class to handle requests in a protocol-agnostic manner.

Applications should never create WebRequest objects directly; instead they should be created with the WebRequestFactory class.

Notes to Inheritors: When you inherit from WebRequest, you must override the following members: Method, RequestURI, Headers, ContentLength, ContentType, Credentials, PreAuthenticate, GetRequestStream, BeginGetRequestStream, EndGetRequestStream, GetResponse, BeginGetResponse, EndGetResponse. In addition, your class must implement the IWebRequestCreate interface.

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

WebRequest Members | System.Net Namespace | HttpWebRequest


WebRequest Members

Public:

Properties

ConnectionGroupName | [To be supplied.]
ContentLength | When overridden in a derived class, gets and sets the content length of request data being sent.
ContentType | When overridden in a derived class, gets and sets the content type of the request data being sent.
Credentials | When overridden in a derived class, gets and sets the network credentials used for authentication to this URI.
Headers | When overridden in a derived class, gets a collection of header name-value pairs associated with this request.
Method | When overridden in a derived class, gets and sets the protocol method used in this request. Default value should be "GET".
PreAuthenticate | When overridden in a derived class, enables or disables pre-authentication.
RequestURI | When overridden in a derived class, gets a URI instance representing the resource associated with the request.

Methods

BeginGetRequestStream | Asynchronous version of GetRequestStream method.
BeginGetResponse | Asynchronous version of GetResponse.
EndGetRequestStream | Returns a System.Net.Stream object that is used for writing data to the resource identified by RequestURI.
EndGetResponse | Returns a WebResponse object.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRequestStream | When overridden in a derived class, returns a Stream object that is used for writing data to the resource identified by RequestURI.
GetResponse | When overridden in a derived class, returns the response to an Internet request.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Constructor

WebRequest Constructor Initializes a new instance of the WebRequest class.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WebRequest Class | System.Net Namespace


WebRequest Constructor

Initializes a new instance of the WebRequest class.

[Visual Basic]
Protected Sub New()
[C#]
protected WebRequest();
[C++]
protected: WebRequest();
[JScript]
protected function WebRequest();

See Also

WebRequest Class | WebRequest Members | System.Net Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

WebRequest Properties

The properties of the WebRequest class are listed below. For a complete list of WebRequest class members, see the WebRequest Members topic.

Public:

ConnectionGroupName | [To be supplied.]
ContentLength | When overridden in a derived class, gets and sets the content length of request data being sent.
ContentType | When overridden in a derived class, gets and sets the content type of the request data being sent.
Credentials | When overridden in a derived class, gets and sets the network credentials used for authentication to this URI.
Headers | When overridden in a derived class, gets a collection of header name-value pairs associated with this request.
Method | When overridden in a derived class, gets and sets the protocol method used in this request. Default value should be "GET".
PreAuthenticate | When overridden in a derived class, enables or disables pre-authentication.
RequestURI | When overridden in a derived class, gets a URI instance representing the resource associated with the request.

See Also

WebRequest Class | System.Net Namespace


WebRequest.ConnectionGroupName

[To be supplied.]

[Visual Basic]
Overridable Public Property ConnectionGroupName As String
[C#]
public string ConnectionGroupName {virtual get; virtual set;}
[C++]
public: __property virtual String* get_ConnectionGroupName();
public: __property virtual void set_ConnectionGroupName(String*);
[JScript]
public function get ConnectionGroupName() : String;
public function set ConnectionGroupName(String);

See Also

WebRequest Class | WebRequest Members | System.Net Namespace


WebRequest.ContentLength

When overridden in a derived class, gets and sets the content length of request data being sent.

[Visual Basic]
Overridable Public Property ContentLength As Long
[C#]
public long ContentLength {virtual get; virtual set;}
[C++]
public: __property virtual __int64 get_ContentLength();
public: __property virtual void set_ContentLength(__int64);
[JScript]
public function get ContentLength() : long;
public function set ContentLength(long);

See Also

WebRequest Class | WebRequest Members | System.Net Namespace


WebRequest.ContentType

When overridden in a derived class, gets and sets the content type of the request data being sent.

[Visual Basic]
Overridable Public Property ContentType As String
[C#]
public string ContentType {virtual get; virtual set;}
[C++]
public: __property virtual String* get_ContentType();
public: __property virtual void set_ContentType(String*);
[JScript]
public function get ContentType() : String;
public function set ContentType(String);

See Also

WebRequest Class | WebRequest Members | System.Net Namespace


WebRequest.Credentials

When overridden in a derived class, gets and sets the network credentials used for authentication to this URI.

[Visual Basic]
Overridable Public Property Credentials As ICredentialLookup
[C#]
public ICredentialLookup Credentials {virtual get; virtual set;}
[C++]
public: __property virtual ICredentialLookup* get_Credentials();
public: __property virtual void set_Credentials(ICredentialLookup*);
[JScript]
public function get Credentials() : ICredentialLookup;
public function set Credentials(ICredentialLookup);

Remarks

The Credentials property is set to either an instance of SingleCredential or CredentialCache.

See Also

WebRequest Class | WebRequest Members | System.Net Namespace


WebRequest.Headers

When overridden in a derived class, gets a collection of header name-value pairs associated with this request.

[Visual Basic]
Overridable Public ReadOnly Property Headers As NameValueCollection
[C#]
public NameValueCollection Headers {virtual get;}
[C++]
public: __property virtual NameValueCollection* get_Headers();
[JScript]
public function get Headers() : NameValueCollection;

See Also

WebRequest Class | WebRequest Members | System.Net Namespace | NameValueCollection


WebRequest.Method

When overridden in a derived class, gets and sets the protocol method used in this request. Default value should be "GET".

[Visual Basic]
Overridable Public Property Method As String
[C#]
public string Method {virtual get; virtual set;}
[C++]
public: __property virtual String* get_Method();
public: __property virtual void set_Method(String*);
[JScript]
public function get Method() : String;
public function set Method(String);

See Also

WebRequest Class | WebRequest Members | System.Net Namespace


WebRequest.PreAuthenticate

When overridden in a derived class, enables or disables pre-authentication.

[Visual Basic]
Overridable Public Property PreAuthenticate As Boolean
[C#]
public bool PreAuthenticate {virtual get; virtual set;}
[C++]
public: __property virtual bool get_PreAuthenticate();
public: __property virtual void set_PreAuthenticate(bool);
[JScript]
public function get PreAuthenticate() : Boolean;
public function set PreAuthenticate(Boolean);

See Also

WebRequest Class | WebRequest Members | System.Net Namespace


WebRequest.RequestURI

When overridden in a derived class, gets a URI instance representing the resource associated with the request.

[Visual Basic]
Overridable Public ReadOnly Property RequestURI As URI
[C#]
public URI RequestURI {virtual get;}
[C++]
public: __property virtual URI* get_RequestURI();
[JScript]
public function get RequestURI() : URI;

See Also

WebRequest Class | WebRequest Members | System.Net Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

WebRequest Methods

The methods of the WebRequest class are listed below. For a complete list of WebRequest class members, see the WebRequest Members topic.

Public:

BeginGetRequestStream | Asynchronous version of GetRequestStream method.
BeginGetResponse | Asynchronous version of GetResponse.
EndGetRequestStream | Returns a System.Net.Stream object that is used for writing data to the resource identified by RequestURI.
EndGetResponse | Returns a WebResponse object.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRequestStream | When overridden in a derived class, returns a Stream object that is used for writing data to the resource identified by RequestURI.
GetResponse | When overridden in a derived class, returns the response to an Internet request.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WebRequest Class | System.Net Namespace


WebRequest.BeginGetRequestStream

Asynchronous version of GetRequestStream method.

[Visual Basic]
Overridable Public Function BeginGetRequestStream( _
   ByVal Callback As AsyncCallback, _
   ByVal State As Object _
) As IAsyncResult
[C#]
public virtual IAsyncResult BeginGetRequestStream(
   AsyncCallback Callback,
   object State
);
[C++]
public: virtual IAsyncResult* BeginGetRequestStream(
   AsyncCallback* Callback,
   Object* State
);
[JScript]
public function BeginGetRequestStream(
   Callback : AsyncCallback,
   State : Object
) : IAsyncResult;

Parameters

Callback
[To be supplied.]
State
[To be supplied.]

Return Value

IAsyncResult

See Also

WebRequest Class | WebRequest Members | System.Net Namespace


WebRequest.BeginGetResponse

Asynchronous version of GetResponse.

[Visual Basic]
Overridable Public Function BeginGetResponse( _
   ByVal Callback As AsyncCallback, _
   ByVal State As Object _
) As IAsyncResult
[C#]
public virtual IAsyncResult BeginGetResponse(
   AsyncCallback Callback,
   object State
);
[C++]
public: virtual IAsyncResult* BeginGetResponse(
   AsyncCallback* Callback,
   Object* State
);
[JScript]
public function BeginGetResponse(
   Callback : AsyncCallback,
   State : Object
) : IAsyncResult;

Parameters

Callback
[To be supplied.]
State
[To be supplied.]

Return Value

IAsyncResult

See Also

WebRequest Class | WebRequest Members | System.Net Namespace


WebRequest.EndGetRequestStream

Returns a System.Net.Stream object that is used for writing data to the resource identified by RequestURI.

[Visual Basic]
Overridable Public Function EndGetRequestStream( _
   ByVal AsyncResult As IAsyncResult _
) As Stream
[C#]
public virtual Stream EndGetRequestStream(
   IAsyncResult AsyncResult
);
[C++]
public: virtual Stream* EndGetRequestStream(
   IAsyncResult* AsyncResult
);
[JScript]
public function EndGetRequestStream(
   AsyncResult : IAsyncResult
) : Stream;

Parameters

AsyncResult
[To be supplied.]

Return Value

Stream

Remarks

Tip Close the response stream to avoid timing issues with garbage collection. To close the response stream, call the Close method on the stream returned by GetResponseStream after calling System.Net.WebResponse.EndGetResponse.

See Also

WebRequest Class | WebRequest Members | System.Net Namespace


WebRequest.EndGetResponse

Returns a WebResponse object.

[Visual Basic]
Overridable Public Function EndGetResponse( _
   ByVal AsyncResult As IAsyncResult _
) As WebResponse
[C#]
public virtual WebResponse EndGetResponse(
   IAsyncResult AsyncResult
);
[C++]
public: virtual WebResponse* EndGetResponse(
   IAsyncResult* AsyncResult
);
[JScript]
public function EndGetResponse(
   AsyncResult : IAsyncResult
) : WebResponse;

Parameters

AsyncResult
[To be supplied.]

Return Value

WebResponse

See Also

WebRequest Class | WebRequest Members | System.Net Namespace


WebRequest.GetRequestStream

When overridden in a derived class, returns a Stream object that is used for writing data to the resource identified by RequestURI.

[Visual Basic]
Overridable Public Function GetRequestStream() As Stream
[C#]
public virtual Stream GetRequestStream();
[C++]
public: virtual Stream* GetRequestStream();
[JScript]
public function GetRequestStream() : Stream;

Return Value

A Stream that can be used to write data to the Internet resource.

See Also

WebRequest Class | WebRequest Members | System.Net Namespace


WebRequest.GetResponse

When overridden in a derived class, returns the response to an Internet request.

[Visual Basic]
Overridable Public Function GetResponse() As WebResponse
[C#]
public virtual WebResponse GetResponse();
[C++]
public: virtual WebResponse* GetResponse();
[JScript]
public function GetResponse() : WebResponse;

Return Value

A WebResponse containing the response to the Internet request.

Remarks

If needed GetResponse should send a request to the URI identified by RequestURI.

See Also

WebRequest Class | WebRequest Members | System.Net Namespace


WebRequestFactory Class

Creates WebRequest objects for specific network request schemes.

Object
WebRequestFactory

[Visual Basic]
Public Class WebRequestFactory
[C#]
public class WebRequestFactory
[C++]
public __gc class WebRequestFactory
[JScript]
public class WebRequestFactory

Remarks

The WebRequestFactory class returns an instance of an object derived from WebRequest. The specific class of object returned is based on the URI scheme passed to the Create method.

Create is static so there is no need to create an instance before it can be used.

Requirements

Namespace: System.Net

Assembly: System.net.dll

Example [C#]

The following example creates a WebRequest instance for an HTTP request. The actual instance returned is an instance of HttpWebRequest.

[C#]

WebRequest wr = WebRequestFactory.Create("http://www.microsoft.com/");

See Also

WebRequestFactory Members | System.Net Namespace


WebRequestFactory Members

Public:

Constructor

WebRequestFactory Constructor [To be supplied.]

Methods

Create | Overloaded. Creates a new WebRequest instance, with the actual class of the WebRequest determined by the URI specified.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
RegisterPrefix | Registers a WebRequest descendent with the WebRequestFactory for a specific Uniform Resource Identifier.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WebRequestFactory Class | System.Net Namespace


WebRequestFactory Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public WebRequestFactory();
[C++]
public: WebRequestFactory();
[JScript]
public function WebRequestFactory();

See Also

WebRequestFactory Class | WebRequestFactory Members | System.Net Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

WebRequestFactory Methods

The methods of the WebRequestFactory class are listed below. For a complete list of WebRequestFactory class members, see the WebRequestFactory Members topic.

Public:

Create | Overloaded. Creates a new WebRequest instance, with the actual class of the WebRequest determined by the URI specified.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
RegisterPrefix | Registers a WebRequest descendent with the WebRequestFactory for a specific Uniform Resource Identifier.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WebRequestFactory Class | System.Net Namespace


WebRequestFactory.Create

Creates a new WebRequest instance, with the actual class of the WebRequest determined by the URI specified.

Overload List

Creates a new WebRequest instance for the specified URI scheme.

[Visual Basic] Overloads Public Shared Function Create(URI, Boolean) As WebRequest
[C#] public static WebRequest Create(URI, bool);
[C++] public: static WebRequest* Create(URI*, bool);
[JScript] public static function Create(URI, Boolean) : WebRequest;

Creates a new WebRequest instance for the specified URI scheme.

[Visual Basic] Overloads Public Shared Function Create(String) As WebRequest
[C#] public static WebRequest Create(String);
[C++] public: static WebRequest* Create(String*);
[JScript] public static function Create(String) : WebRequest;

Creates a new WebRequest instance for the specified URI scheme.

[Visual Basic] Overloads Public Shared Function Create(URI) As WebRequest
[C#] public static WebRequest Create(URI);
[C++] public: static WebRequest* Create(URI*);
[JScript] public static function Create(URI) : WebRequest;

See Also

WebRequestFactory Class | WebRequestFactory Members | System.Net Namespace


WebRequestFactory.Create (URI, Boolean)

Creates a new WebRequest instance for the specified URI scheme.

[Visual Basic]
Overloads Public Shared Function Create( _
   ByVal RequestURL As URI, _
   ByVal UseURLBase As Boolean _
) As WebRequest
[C#]
public static WebRequest Create(
   URI RequestURL,
   bool UseURLBase
);
[C++]
public: static WebRequest* Create(
   URI* RequestURL,
   bool UseURLBase
);
[JScript]
public static function Create(
   RequestURL : URI,
   UseURLBase : Boolean
) : WebRequest;

Parameters

RequestURL
A URI class instance containing the URI of the requested resource.
UseURLBase
[To be supplied.]

Return Value

A WebRequest descendent for the specific URI scheme.

Exceptions

Exception Type | Condition
NotSupportedException | The request scheme specified in RequestURL has not been registered.

Remarks

The registered IWebRequestCreate methods for WebRequest descendents are searched in order by length. The first method found that matches the RequestURL will be used to create a WebRequest instance to handle the request.

See Also

WebRequestFactory Class | WebRequestFactory Members | System.Net Namespace | WebRequestFactory.Create Overload List


WebRequestFactory.Create (String)

Creates a new WebRequest instance for the specified URI scheme.

[Visual Basic]
Overloads Public Shared Function Create( _
   ByVal RequestUrlString As String _
) As WebRequest
[C#]
public static WebRequest Create(
   string RequestUrlString
);
[C++]
public: static WebRequest* Create(
   String* RequestUrlString
);
[JScript]
public static function Create(
   RequestUrlString : String
) : WebRequest;

Parameters

RequestUrlString
A URI.

Return Value

A WebRequest descendent for the specific URI scheme.

Exceptions

Exception Type | Condition
NotSupportedException | The request scheme specified in RequestURLString has not been registered.

Remarks

RequestURLString is used to create a URI instance that is passed to the created WebRequest.

See Also

WebRequestFactory Class | WebRequestFactory Members | System.Net Namespace | WebRequestFactory.Create Overload List


WebRequestFactory.Create (URI)

Creates a new WebRequest instance for the specified URI scheme.

[Visual Basic]
Overloads Public Shared Function Create( _
   ByVal RequestURL As URI _
) As WebRequest
[C#]
public static WebRequest Create(
   URI RequestURL
);
[C++]
public: static WebRequest* Create(
   URI* RequestURL
);
[JScript]
public static function Create(
   RequestURL : URI
) : WebRequest;

Parameters

RequestURL
A URI class instance containing the URI of the requested resource.

Return Value

A WebRequest descendent for the specific URI scheme.

Exceptions

Exception Type | Condition
NotSupportedException | The request scheme specified in RequestURL has not been registered.

See Also

WebRequestFactory Class | WebRequestFactory Members | System.Net Namespace | WebRequestFactory.Create Overload List


WebRequestFactory.RegisterPrefix

Registers a WebRequest descendent with the WebRequestFactory for a specific Uniform Resource Identifier.

[Visual Basic]
Public Shared Function RegisterPrefix( _
   ByVal Prefix As String, _
   ByVal Creator As IWebRequestCreate _
) As Boolean
[C#]
public static bool RegisterPrefix(
   string Prefix,
   IWebRequestCreate Creator
);
[C++]
public: static bool RegisterPrefix(
   String* Prefix,
   IWebRequestCreate* Creator
);
[JScript]
public static function RegisterPrefix(
   Prefix : String,
   Creator : IWebRequestCreate
) : Boolean;

Parameters

Prefix
The URI prefix this WebRequest descendent will service.
Creator
The create method the WebRequestFactory should call to create the WebRequest descendent.

Return Value

true if registration was successful; otherwise, false.

Remarks

Duplicate prefixes are not allowed. RegisterPrefix will return false if an attempt is made to register a duplicate prefix.

Note The HttpWebRequest class is registered to service requests for the http and https schemes by default. Attempts to register a different WebRequest descendent for these schemes will fail.

See Also

WebRequestFactory Class | WebRequestFactory Members | System.Net Namespace


WebResponse Class

A response from a Uniform Resource Indentifier (URI). This is an abstract class.

Object
WebResponse

[Visual Basic]
MustInherit Public Class WebResponse
[C#]
public abstract class WebResponse
[C++]
public __gc __abstract class WebResponse
[JScript]
public abstract class WebResponse

Remarks

The WebResponse class is an abstract base class from which protocol-specific classes are derived. Applications can use the WebResponse class to handle responses in a protocol-agnostic manner. The WebResponse class can be used to access any resource on the network that is addressable with a Uniform Resource Identifier (URI), such as http://www.microsoft.com/ .

Client applications should never create WebResponse objects directly, they should be created by calling the GetResponse method on a WebRequest instance.

Notes to Inheritors: When you inherit from WebResponse, you must override the following members: Status, StatusDescription, ContentLength, ContentType, GetResponseStream, ResponseURI, and Headers.

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

WebResponse Members | System.Net Namespace


WebResponse Members

Public:

Properties

ContentLength | When overridden in a derived class, gets or sets the content length of data being received.
ContentType | When overridden in a derived class, gets or sets the content type of the data being received.
Headers | When overridden in a derived class, gets a collection of header name-value pairs associated with this request.
ResponseURI | When overridden in a derived class, gets the URI that actually responded to the request.
Status | When overridden in a derived class, gets or sets a number indicating the response status.
StatusDescription | When overridden in a derived class, gets or sets a description of the response status.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetResponseStream | When overridden in a derived class, returns the Stream object used for reading data from the resource referenced in the WebRequest object.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Constructor

WebResponse Constructor Initializes a new instance of the WebResponse class.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WebResponse Class | System.Net Namespace


WebResponse Constructor

Initializes a new instance of the WebResponse class.

[Visual Basic]
Protected Sub New()
[C#]
protected WebResponse();
[C++]
protected: WebResponse();
[JScript]
protected function WebResponse();

See Also

WebResponse Class | WebResponse Members | System.Net Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

WebResponse Properties

The properties of the WebResponse class are listed below. For a complete list of WebResponse class members, see the WebResponse Members topic.

Public:

ContentLength | When overridden in a derived class, gets or sets the content length of data being received.
ContentType | When overridden in a derived class, gets or sets the content type of the data being received.
Headers | When overridden in a derived class, gets a collection of header name-value pairs associated with this request.
ResponseURI | When overridden in a derived class, gets the URI that actually responded to the request.
Status | When overridden in a derived class, gets or sets a number indicating the response status.
StatusDescription | When overridden in a derived class, gets or sets a description of the response status.

See Also

WebResponse Class | System.Net Namespace


WebResponse.ContentLength

When overridden in a derived class, gets or sets the content length of data being received.

[Visual Basic]
Overridable Public Property ContentLength As Long
[C#]
public long ContentLength {virtual get; virtual set;}
[C++]
public: __property virtual __int64 get_ContentLength();
public: __property virtual void set_ContentLength(__int64);
[JScript]
public function get ContentLength() : long;
public function set ContentLength(long);

See Also

WebResponse Class | WebResponse Members | System.Net Namespace


WebResponse.ContentType

When overridden in a derived class, gets or sets the content type of the data being received.

[Visual Basic]
Overridable Public Property ContentType As String
[C#]
public string ContentType {virtual get; virtual set;}
[C++]
public: __property virtual String* get_ContentType();
public: __property virtual void set_ContentType(String*);
[JScript]
public function get ContentType() : String;
public function set ContentType(String);

See Also

WebResponse Class | WebResponse Members | System.Net Namespace


WebResponse.Headers

When overridden in a derived class, gets a collection of header name-value pairs associated with this request.

[Visual Basic]
Overridable Public ReadOnly Property Headers As NameValueCollection
[C#]
public NameValueCollection Headers {virtual get;}
[C++]
public: __property virtual NameValueCollection* get_Headers();
[JScript]
public function get Headers() : NameValueCollection;

See Also

WebResponse Class | WebResponse Members | System.Net Namespace


WebResponse.ResponseURI

When overridden in a derived class, gets the URI that actually responded to the request.

[Visual Basic]
Overridable Public ReadOnly Property ResponseURI As URI
[C#]
public URI ResponseURI {virtual get;}
[C++]
public: __property virtual URI* get_ResponseURI();
[JScript]
public function get ResponseURI() : URI;

See Also

WebResponse Class | WebResponse Members | System.Net Namespace


WebResponse.Status

When overridden in a derived class, gets or sets a number indicating the response status.

[Visual Basic]
Overridable Public Property Status As Integer
[C#]
public int Status {virtual get; virtual set;}
[C++]
public: __property virtual int get_Status();
public: __property virtual void set_Status(int);
[JScript]
public function get Status() : int;
public function set Status(int);

See Also

WebResponse Class | WebResponse Members | System.Net Namespace


WebResponse.StatusDescription

When overridden in a derived class, gets or sets a description of the response status.

[Visual Basic]
Overridable Public Property StatusDescription As String
[C#]
public string StatusDescription {virtual get; virtual set;}
[C++]
public: __property virtual String* get_StatusDescription();
public: __property virtual void set_StatusDescription(String*);
[JScript]
public function get StatusDescription() : String;
public function set StatusDescription(String);

See Also

WebResponse Class | WebResponse Members | System.Net Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

WebResponse Methods

The methods of the WebResponse class are listed below. For a complete list of WebResponse class members, see the WebResponse Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetResponseStream | When overridden in a derived class, returns the Stream object used for reading data from the resource referenced in the WebRequest object.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WebResponse Class | System.Net Namespace


WebResponse.GetResponseStream

When overridden in a derived class, returns the Stream object used for reading data from the resource referenced in the WebRequest object.

[Visual Basic]
Overridable Public Function GetResponseStream() As Stream
[C#]
public virtual Stream GetResponseStream();
[C++]
public: virtual Stream* GetResponseStream();
[JScript]
public function GetResponseStream() : Stream;

Return Value

A Stream instance that can be used to read data from the Internet resource.

See Also

WebResponse Class | WebResponse Members | System.Net Namespace


WebStatus Enumeration

Specifies the status of a network request.

[Visual Basic]
Public Enum WebStatus
[C#]
public enum WebStatus
[C++]
public enum WebStatus

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
ConnectFailure | The remote service point could not be contacted at the transport level.
ConnectionClosed | The connection was prematurely closed.
KeepAliveFailure | [To be supplied.]
NameResolutionFailure | The name resolver service could not resolve the host name.
ProtocolError | The response received from the server was complete but indicated a protocol-level error. For example, an HTTP protocol error such as 401 Access Denied would use this status.
ReceiveFailure | A complete response was not received from the remote server.
RequestCanceled | The request was cancelled.
SecureChannelFailure | An error occurred in a secure channel link.
SendFailure | A complete request could not be sent to the remote server.
ServerProtocolViolation | [To be supplied.]
Success | No error was encountered.
TrustFailure | A server certificate could not be validated.

Requirements

Namespace: System.Net

Assembly: System.net.dll

See Also

System.Net Namespace


System.Net.Sockets

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Net.Sockets Namespace

Classes

Class | Description
AddressFamily | Specifies the address families that an instance of the Socket class can use.
InvalidSocketConstants | Provides constants that indicate a socket is invalid.
LingerOption | Contains information for a sockets linger time, the amount of time it will remain after closing if data remains to be sent.
MulticastOption | Contains option values for IP multicast packets.
NetworkStream | Provides the underlying stream of data for network access.
ProtocolFamily | Specifies the type of protocol that an instance of the Socket class can use.
ProtocolType | Specifies the protocols that the Socket class supports.
Socket | The Socket class implements the Berkeley sockets interface.
SocketErrors | Defines socket error constants.
SocketMsgFlags | Provides constant values for socket messages.
SocketOption | Defines socket options for the Socket class.
SocketShutdown | Defines constants used by the Shutdown method.
SocketType | Specifies the type of socket an instance of the Socket class represents.
TCPClient | The TCPClient class provide TCP services at a higher level of abstraction than the Socket class. TCPClient is used to create a client connection to a remote host.
TCPListener | The TCPListener class provide TCP services at a higher level of abstraction than the Socket class. TCPListener is used to create a host process that listens for connections from TCP clients.
UDPClient | The UDPClient class provides access to UDP services at a higher abstraction level than the Socket class. UDPClient is used to connect to a remote host and to receive connections from a remote client.

Enumerations

Enumeration | Description
SelectMode | Specifies the mode for polling the status of a socket.


AddressFamily Class

Specifies the address families that an instance of the Socket class can use.

Object
AddressFamily

[Visual Basic]
Public Class AddressFamily
[C#]
public class AddressFamily
[C++]
public __gc class AddressFamily
[JScript]
public class AddressFamily

Remarks

[To be supplied.]

Requirements

Namespace: System.Net.Sockets

Assembly: System.net.dll

See Also

AddressFamily Members | System.Net.Sockets Namespace


AddressFamily Members

Public:

Constructor

AddressFamily Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

AfAppletalk | [To be supplied.]
AfBan | [To be supplied.]
AfCCITT | [To be supplied.]
AfChaos | [To be supplied.]
AfDatakit | [To be supplied.]
AfDECnet | [To be supplied.]
AfDli | [To be supplied.]
AfECMA | [To be supplied.]
AfFirefox | [To be supplied.]
AfHylink | [To be supplied.]
AfImplink | [To be supplied.]
AfINet | [To be supplied.]
AfIpx | [To be supplied.]
AfISO | [To be supplied.]
AfLAT | [To be supplied.]
AfNetbios | [To be supplied.]
AfNS | [To be supplied.]
AfOSI | [To be supplied.]
AfPup | [To be supplied.]
AfSNA | [To be supplied.]
AfUnix | [To be supplied.]
AfUnknown | [To be supplied.]
AfUnknown1 | [To be supplied.]
AfUnspec | [To be supplied.]
AfVoiceview | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AddressFamily Class | System.Net.Sockets Namespace


AddressFamily Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public AddressFamily();
[C++]
public: AddressFamily();
[JScript]
public function AddressFamily();

See Also

AddressFamily Class | AddressFamily Members | System.Net.Sockets Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AddressFamily Fields

The fields of the AddressFamily class are listed below. For a complete list of AddressFamily class members, see the AddressFamily Members topic.

Public:

AfAppletalk | [To be supplied.]
AfBan | [To be supplied.]
AfCCITT | [To be supplied.]
AfChaos | [To be supplied.]
AfDatakit | [To be supplied.]
AfDECnet | [To be supplied.]
AfDli | [To be supplied.]
AfECMA | [To be supplied.]
AfFirefox | [To be supplied.]
AfHylink | [To be supplied.]
AfImplink | [To be supplied.]
AfINet | [To be supplied.]
AfIpx | [To be supplied.]
AfISO | [To be supplied.]
AfLAT | [To be supplied.]
AfNetbios | [To be supplied.]
AfNS | [To be supplied.]
AfOSI | [To be supplied.]
AfPup | [To be supplied.]
AfSNA | [To be supplied.]
AfUnix | [To be supplied.]
AfUnknown | [To be supplied.]
AfUnknown1 | [To be supplied.]
AfUnspec | [To be supplied.]
AfVoiceview | [To be supplied.]

See Also

AddressFamily Class | System.Net.Sockets Namespace


AddressFamily.AfAppletalk

[To be supplied.]

[Visual Basic]
Public Const AfAppletalk As Integer
[C#]
public const int AfAppletalk;
[C++]
public: const int AfAppletalk;
[JScript]
public var AfAppletalk : int;

See Also

AddressFamily Class | AddressFamily Members | System.Net.Sockets Namespace


AddressFamily.AfBan

[To be supplied.]

[Visual Basic]
Public Const AfBan As Integer
[C#]
public const int AfBan;
[C++]
public: const int AfBan;
[JScript]
public var AfBan : int;

See Also

AddressFamily Class | AddressFamily Members | System.Net.Sockets Namespace


AddressFamily.AfCCITT

[To be supplied.]

[Visual Basic]
Public Const AfCCITT As Integer
[C#]
public const int AfCCITT;
[C++]
public: const int AfCCITT;
[JScript]
public var AfCCITT : int;

See Also

AddressFamily Class | AddressFamily Members | System.Net.Sockets Namespace


AddressFamily.AfChaos

[To be supplied.]

[Visual Basic]
Public Const AfChaos As Integer
[C#]
public const int AfChaos;
[C++]
public: const int AfChaos;
[JScript]
public var AfChaos : int;

See Also

AddressFamily Class | AddressFamily Members | System.Net.Sockets Namespace


AddressFamily.AfDatakit

[To be supplied.]

[Visual Basic]
Public Const AfDatakit As Integer
[C#]
public const int AfDatakit;
[C++]
public: const int AfDatakit;
[JScript]
public var AfDatakit : int;

See Also

AddressFamily Class | AddressFamily Members | System.Net.Sockets Namespace


AddressFamily.AfDECnet

[To be supplied.]

[Visual Basic]
Public Const AfDECnet As Integer
[C#]
public const int AfDECnet;
[C++]
public: const int AfDECnet;
[JScript]
public var AfDECnet : int;

See Also

AddressFamily Class | AddressFamily Members | System.Net.Sockets Namespace


AddressFamily.AfDli

[To be supplied.]

[Visual Basic]
Public Const AfDli As Integer
[C#]
public const int AfDli;
[C++]
public: const int AfDli;
[JScript]
public var AfDli : int;

See Also

AddressFamily Class | AddressFamily Members | System.Net.Sockets Namespace


AddressFamily.AfECMA

[To be supplied.]

[Visual Basic]
Public Const AfECMA As Integer
[C#]
public const int AfECMA;
[C++]
public: const int AfECMA;
[JScript]
public var AfECMA : int;

See Also

AddressFamily Class | AddressFamily Members | System.Net.Sockets Namespace


AddressFamily.AfFirefox

[To be supplied.]

[Visual Basic]
Public Const AfFirefox As Integer
[C#]
public const int AfFirefox;
[C++]
public: const int AfFirefox;
[JScript]
public var AfFirefox : int;

See Also

AddressFamily Class | AddressFamily Members | System.Net.Sockets Namespace


AddressFamily.AfHylink

[To be supplied.]

[Visual Basic]
Public Const AfHylink As Integer
[C#]
public const int AfHylink;
[C++]
public: const int AfHylink;
[JScript]
public var AfHylink : int;

See Also

AddressFamily Class | AddressFamily Members | System.Net.Sockets Namespace


AddressFamily.AfImplink

[To be supplied.]

[Visual Basic]
Public Const AfImplink As Integer
[C#]
public const int AfImplink;
[C++]
public: const int AfImplink;
[JScript]
public var AfImplink : int;

See Also

AddressFamily Class | AddressFamily Members | System.Net.Sockets Namespace


AddressFamily.AfINet

[To be supplied.]

[Visual Basic]
Public Const AfINet As Integer
[C#]
public const int AfINet;
[C++]
public: const int AfINet;
[JScript]
public var AfINet : int;

See Also

AddressFamily Class | AddressFamily Members | System.Net.Sockets Namespace


AddressFamily.AfIpx

[To be supplied.]

[Visual Basic]
Public Const AfIpx As Integer
[C#]
public const int AfIpx;
[C++]
public: const int AfIpx;
[JScript]
public var AfIpx : int;

See Also

AddressFamily Class | AddressFamily Members | System.Net.Sockets Namespace


AddressFamily.AfISO

[To be supplied.]

[Visual Basic]
Public Const AfISO As Integer
[C#]
public const int AfISO;
[C++]
public: const int AfISO;
[JScript]
public var AfISO : int;

See Also

AddressFamily Class | AddressFamily Members | System.Net.Sockets Namespace


AddressFamily.AfLAT

[To be supplied.]

[Visual Basic]
Public Const AfLAT As Integer
[C#]
public const int AfLAT;
[C++]
public: const int AfLAT;
[JScript]
public var AfLAT : int;

See Also

AddressFamily Class | AddressFamily Members | System.Net.Sockets Namespace


AddressFamily.AfNetbios

[To be supplied.]

[Visual Basic]
Public Const AfNetbios As Integer
[C#]
public const int AfNetbios;
[C++]
public: const int AfNetbios;
[JScript]
public var AfNetbios : int;

See Also

AddressFamily Class | AddressFamily Members | System.Net.Sockets Namespace


AddressFamily.AfNS

[To be supplied.]

[Visual Basic]
Public Const AfNS As Integer
[C#]
public const int AfNS;
[C++]
public: const int AfNS;
[JScript]
public var AfNS : int;

See Also

AddressFamily Class | AddressFamily Members | System.Net.Sockets Namespace


AddressFamily.AfOSI

[To be supplied.]

[Visual Basic]
Public Const AfOSI As Integer
[C#]
public const int AfOSI;
[C++]
public: const int AfOSI;
[JScript]
public var AfOSI : int;

See Also

AddressFamily Class | AddressFamily Members | System.Net.Sockets Namespace


AddressFamily.AfPup

[To be supplied.]

[Visual Basic]
Public Const AfPup As Integer
[C#]
public const int AfPup;
[C++]
public: const int AfPup;
[JScript]
public var AfPup : int;

See Also

AddressFamily Class | AddressFamily Members | System.Net.Sockets Namespace


AddressFamily.AfSNA

[To be supplied.]

[Visual Basic]
Public Const AfSNA As Integer
[C#]
public const int AfSNA;
[C++]
public: const int AfSNA;
[JScript]
public var AfSNA : int;

See Also

AddressFamily Class | AddressFamily Members | System.Net.Sockets Namespace


AddressFamily.AfUnix

[To be supplied.]

[Visual Basic]
Public Const AfUnix As Integer
[C#]
public const int AfUnix;
[C++]
public: const int AfUnix;
[JScript]
public var AfUnix : int;

See Also

AddressFamily Class | AddressFamily Members | System.Net.Sockets Namespace


AddressFamily.AfUnknown

[To be supplied.]

[Visual Basic]
Public Const AfUnknown As Integer
[C#]
public const int AfUnknown;
[C++]
public: const int AfUnknown;
[JScript]
public var AfUnknown : int;

See Also

AddressFamily Class | AddressFamily Members | System.Net.Sockets Namespace


AddressFamily.AfUnknown1

[To be supplied.]

[Visual Basic]
Public Const AfUnknown1 As Integer
[C#]
public const int AfUnknown1;
[C++]
public: const int AfUnknown1;
[JScript]
public var AfUnknown1 : int;

See Also

AddressFamily Class | AddressFamily Members | System.Net.Sockets Namespace


AddressFamily.AfUnspec

[To be supplied.]

[Visual Basic]
Public Const AfUnspec As Integer
[C#]
public const int AfUnspec;
[C++]
public: const int AfUnspec;
[JScript]
public var AfUnspec : int;

See Also

AddressFamily Class | AddressFamily Members | System.Net.Sockets Namespace


AddressFamily.AfVoiceview

[To be supplied.]

[Visual Basic]
Public Const AfVoiceview As Integer
[C#]
public const int AfVoiceview;
[C++]
public: const int AfVoiceview;
[JScript]
public var AfVoiceview : int;

See Also

AddressFamily Class | AddressFamily Members | System.Net.Sockets Namespace


InvalidSocketConstants Class

Provides constants that indicate a socket is invalid.

Object
InvalidSocketConstants

[Visual Basic]
Public Class InvalidSocketConstants
[C#]
public class InvalidSocketConstants
[C++]
public __gc class InvalidSocketConstants
[JScript]
public class InvalidSocketConstants

Remarks

[To be supplied.]

Requirements

Namespace: System.Net.Sockets

Assembly: System.net.dll

See Also

InvalidSocketConstants Members | System.Net.Sockets Namespace


InvalidSocketConstants Members

Public:

Constructor

InvalidSocketConstants Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

INVALID_SOCKET | The socket is invalid.
SOCKET_ERROR | The socket has an error.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InvalidSocketConstants Class | System.Net.Sockets Namespace


InvalidSocketConstants Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public InvalidSocketConstants();
[C++]
public: InvalidSocketConstants();
[JScript]
public function InvalidSocketConstants();

See Also

InvalidSocketConstants Class | InvalidSocketConstants Members | System.Net.Sockets Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

InvalidSocketConstants Fields

The fields of the InvalidSocketConstants class are listed below. For a complete list of InvalidSocketConstants class members, see the InvalidSocketConstants Members topic.

Public:

INVALID_SOCKET | The socket is invalid.
SOCKET_ERROR | The socket has an error.

See Also

InvalidSocketConstants Class | System.Net.Sockets Namespace


InvalidSocketConstants.INVALID_SOCKET

The socket is invalid.

[Visual Basic]
Public Const INVALID_SOCKET As Integer
[C#]
public const int INVALID_SOCKET;
[C++]
public: const int INVALID_SOCKET;
[JScript]
public var INVALID_SOCKET : int;

See Also

InvalidSocketConstants Class | InvalidSocketConstants Members | System.Net.Sockets Namespace


InvalidSocketConstants.SOCKET_ERROR

The socket has an error.

[Visual Basic]
Public Const SOCKET_ERROR As Integer
[C#]
public const int SOCKET_ERROR;
[C++]
public: const int SOCKET_ERROR;
[JScript]
public var SOCKET_ERROR : int;

See Also

InvalidSocketConstants Class | InvalidSocketConstants Members | System.Net.Sockets Namespace


LingerOption Class

Contains information for a sockets linger time, the amount of time it will remain after closing if data remains to be sent.

Object
LingerOption

[Visual Basic]
Public Class LingerOption
[C#]
public class LingerOption
[C++]
public __gc class LingerOption
[JScript]
public class LingerOption

Remarks

[To be supplied.]

Requirements

Namespace: System.Net.Sockets

Assembly: System.net.dll

See Also

LingerOption Members | System.Net.Sockets Namespace


LingerOption Members

Public:

Constructor

LingerOption Constructor Initializes a new instance of the LingerOption class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Enabled | Enables or disables lingering after close.
LingerTime | The amount of time, in seconds, to remain connected after a close.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LingerOption Class | System.Net.Sockets Namespace


LingerOption Constructor

Initializes a new instance of the LingerOption class.

[Visual Basic]
Public Sub New( _
   ByVal enable As Boolean, _
   ByVal seconds As Integer _
)
[C#]
public LingerOption(
   bool enable,
   int seconds
);
[C++]
public: LingerOption(
   bool enable,
   int seconds
);
[JScript]
public function LingerOption(
   enable : Boolean,
   seconds : int
);

Parameters

enable
true to enable remaining connected after a Close is sent; otherwise, false.
seconds
[To be supplied.]

See Also

LingerOption Class | LingerOption Members | System.Net.Sockets Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

LingerOption Fields

The fields of the LingerOption class are listed below. For a complete list of LingerOption class members, see the LingerOption Members topic.

Public:

Enabled | Enables or disables lingering after close.
LingerTime | The amount of time, in seconds, to remain connected after a close.

See Also

LingerOption Class | System.Net.Sockets Namespace


LingerOption.Enabled

Enables or disables lingering after close.

[Visual Basic]
Public Enabled As Boolean
[C#]
public bool Enabled;
[C++]
public: bool Enabled;
[JScript]
public var Enabled : Boolean;

See Also

LingerOption Class | LingerOption Members | System.Net.Sockets Namespace


LingerOption.LingerTime

The amount of time, in seconds, to remain connected after a close.

[Visual Basic]
Public LingerTime As Integer
[C#]
public int LingerTime;
[C++]
public: int LingerTime;
[JScript]
public var LingerTime : int;

See Also

LingerOption Class | LingerOption Members | System.Net.Sockets Namespace


MulticastOption Class

Contains option values for IP multicast packets.

Object
MulticastOption

[Visual Basic]
Public Class MulticastOption
[C#]
public class MulticastOption
[C++]
public __gc class MulticastOption
[JScript]
public class MulticastOption

Remarks

[To be supplied.]

Requirements

Namespace: System.Net.Sockets

Assembly: System.net.dll

See Also

MulticastOption Members | System.Net.Sockets Namespace


MulticastOption Members

Public:

Constructor

MulticastOption Constructor Overloaded. Creates a new instance of the MulticastOption class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Group | Sets the IP address of a multicast group.
LocalAddress | Sets the local address of a multicast group.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MulticastOption Class | System.Net.Sockets Namespace


MulticastOption Constructor

Creates a new instance of the MulticastOption class.

Overload List

Creates a new instance of the MulticaseOption class with the specified IP address group and local address.

[Visual Basic] Overloads Public Sub New(IPAddress, IPAddress)
[C#] public MulticastOption(IPAddress, IPAddress);
[C++] public: MulticastOption(IPAddress*, IPAddress*);
[JScript] public function MulticastOption(IPAddress, IPAddress);

Creates a new version of the MulticastOption class for the specified group.

[Visual Basic] Overloads Public Sub New(IPAddress)
[C#] public MulticastOption(IPAddress);
[C++] public: MulticastOption(IPAddress*);
[JScript] public function MulticastOption(IPAddress);

See Also

MulticastOption Class | MulticastOption Members | System.Net.Sockets Namespace


MulticastOption Constructor (IPAddress, IPAddress)

Creates a new instance of the MulticaseOption class with the specified IP address group and local address.

[Visual Basic]
Overloads Public Sub New( _
   ByVal group As IPAddress, _
   ByVal mcint As IPAddress _
)
[C#]
public MulticastOption(
   IPAddress group,
   IPAddress mcint
);
[C++]
public: MulticastOption(
   IPAddress* group,
   IPAddress* mcint
);
[JScript]
public function MulticastOption(
   group : IPAddress,
   mcint : IPAddress
);

Parameters

group
The group IP address.
mcint
[To be supplied.]

See Also

MulticastOption Class | MulticastOption Members | System.Net.Sockets Namespace | MulticastOption Constructor Overload List


MulticastOption Constructor (IPAddress)

Creates a new version of the MulticastOption class for the specified group.

[Visual Basic]
Overloads Public Sub New( _
   ByVal group As IPAddress _
)
[C#]
public MulticastOption(
   IPAddress group
);
[C++]
public: MulticastOption(
   IPAddress* group
);
[JScript]
public function MulticastOption(
   group : IPAddress
);

Parameters

group
The IP address of the multicast group.

See Also

MulticastOption Class | MulticastOption Members | System.Net.Sockets Namespace | MulticastOption Constructor Overload List


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MulticastOption Fields

The fields of the MulticastOption class are listed below. For a complete list of MulticastOption class members, see the MulticastOption Members topic.

Public:

Group | Sets the IP address of a multicast group.
LocalAddress | Sets the local address of a multicast group.

See Also

MulticastOption Class | System.Net.Sockets Namespace


MulticastOption.Group

Sets the IP address of a multicast group.

[Visual Basic]
Public Group As IPAddress
[C#]
public IPAddress Group;
[C++]
public: IPAddress* Group;
[JScript]
public var Group : IPAddress;

See Also

MulticastOption Class | MulticastOption Members | System.Net.Sockets Namespace


MulticastOption.LocalAddress

Sets the local address of a multicast group.

[Visual Basic]
Public LocalAddress As IPAddress
[C#]
public IPAddress LocalAddress;
[C++]
public: IPAddress* LocalAddress;
[JScript]
public var LocalAddress : IPAddress;

See Also

MulticastOption Class | MulticastOption Members | System.Net.Sockets Namespace


NetworkStream Class

Provides the underlying stream of data for network access.

Object
Stream
NetworkStream

[Visual Basic]
Public Class NetworkStream
   Inherits Stream
[C#]
public class NetworkStream : Stream
[C++]
public __gc class NetworkStream : public Stream
[JScript]
public class NetworkStream extends Stream

Remarks

[To be supplied.]

Requirements

Namespace: System.Net.Sockets

Assembly: System.net.dll

See Also

NetworkStream Members | System.Net.Sockets Namespace


NetworkStream Members

Public:

Constructor

NetworkStream Constructor Overloaded. Creates a new instance of the NetworkStream class.

Properties

CanRead | Indicates that data can be read from the stream.
CanSeek | Indicates that the stream can seek a specific location in the stream. This property always returns false.
CanWrite | Indicates that data can be written to the stream.
DataAvailable | Indicates data is available on the stream to be read.
Length | The length of data available on the stream. Always throws System..NotSupportedException.
Position | Gets or sets the position in the stream. Always throws System..NotSupportedException.

Methods

BeginRead | Begins an asychronous read from a stream.
BeginWrite | Begins an asynchronous write to a stream.
Close | Closes the stream, and then closes the underlying socket.
EndRead | Handle the end of an asynchronous read.
EndWrite | Handle the end of an asynchronous write.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Flush | Flushes data from the stream.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Read | Reads data from the stream.
ReadByte (inherited from Stream) | Reads a byte from the current position in the stream, or-1 if at the end of the stream.
Seek | Seeks a specific position in the stream. This method is not supported by the System.Net.Socket..NetworkStream class.
SetLength | Sets the length of the stream. Always throws System..NotSupportedException.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Writes data to the stream..
WriteByte (inherited from Stream) | Writes a byte to the current position in the stream. If the stream is closed or not writable, an exception will be thrown.

Protected:

Methods

CreateWaitHandle (inherited from Stream) | Allocates a WaitHandle object efficiently.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

m_Readable | Used by the class to indicate that the stream is readable.
m_StreamSocket | Used by the class to hold the underlying socket the stream uses.
m_Writeable | Used by the class to indicate that the stream is writable.

See Also

NetworkStream Class | System.Net.Sockets Namespace


NetworkStream Constructor

Creates a new instance of the NetworkStream class.

Overload List

Creates a new instance of the NetworkStream class for the specified Socket.

[Visual Basic] Overloads Public Sub New(Socket)
[C#] public NetworkStream(Socket);
[C++] public: NetworkStream(Socket*);
[JScript] public function NetworkStream(Socket);

Creates a new instance of the NetworkStream class for the specified Socket with the specified access rights.

[Visual Basic] Overloads Public Sub New(Socket, FileAccess)
[C#] public NetworkStream(Socket, FileAccess);
[C++] public: NetworkStream(Socket*, FileAccess);
[JScript] public function NetworkStream(Socket, FileAccess);

See Also

NetworkStream Class | NetworkStream Members | System.Net.Sockets Namespace


NetworkStream Constructor (Socket)

Creates a new instance of the NetworkStream class for the specified Socket.

[Visual Basic]
Overloads Public Sub New( _
   ByVal s As Socket _
)
[C#]
public NetworkStream(
   Socket s
);
[C++]
public: NetworkStream(
   Socket* s
);
[JScript]
public function NetworkStream(
   s : Socket
);

Parameters

s
The socket that provides the network data.

See Also

NetworkStream Class | NetworkStream Members | System.Net.Sockets Namespace | NetworkStream Constructor Overload List


NetworkStream Constructor (Socket, FileAccess)

Creates a new instance of the NetworkStream class for the specified Socket with the specified access rights.

[Visual Basic]
Overloads Public Sub New( _
   ByVal s As Socket, _
   ByVal access As FileAccess _
)
[C#]
public NetworkStream(
   Socket s,
   FileAccess access
);
[C++]
public: NetworkStream(
   Socket* s,
   FileAccess access
);
[JScript]
public function NetworkStream(
   s : Socket,
   access : FileAccess
);

Parameters

s
The socket that provides the network data.
access
[To be supplied.]

See Also

NetworkStream Class | NetworkStream Members | System.Net.Sockets Namespace | NetworkStream Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

NetworkStream Properties

The properties of the NetworkStream class are listed below. For a complete list of NetworkStream class members, see the NetworkStream Members topic.

Public:

CanRead | Indicates that data can be read from the stream.
CanSeek | Indicates that the stream can seek a specific location in the stream. This property always returns false.
CanWrite | Indicates that data can be written to the stream.
DataAvailable | Indicates data is available on the stream to be read.
Length | The length of data available on the stream. Always throws System..NotSupportedException.
Position | Gets or sets the position in the stream. Always throws System..NotSupportedException.

See Also

NetworkStream Class | System.Net.Sockets Namespace


NetworkStream.CanRead

Indicates that data can be read from the stream.

[Visual Basic]
Overridable Public ReadOnly Property CanRead As Boolean
[C#]
public bool CanRead {override get;}
[C++]
public: __property virtual bool get_CanRead();
[JScript]
public function get CanRead() : Boolean;

See Also

NetworkStream Class | NetworkStream Members | System.Net.Sockets Namespace


NetworkStream.CanSeek

Indicates that the stream can seek a specific location in the stream. This property always returns false.

[Visual Basic]
Overridable Public ReadOnly Property CanSeek As Boolean
[C#]
public bool CanSeek {override get;}
[C++]
public: __property virtual bool get_CanSeek();
[JScript]
public function get CanSeek() : Boolean;

See Also

NetworkStream Class | NetworkStream Members | System.Net.Sockets Namespace


NetworkStream.CanWrite

Indicates that data can be written to the stream.

[Visual Basic]
Overridable Public ReadOnly Property CanWrite As Boolean
[C#]
public bool CanWrite {override get;}
[C++]
public: __property virtual bool get_CanWrite();
[JScript]
public function get CanWrite() : Boolean;

See Also

NetworkStream Class | NetworkStream Members | System.Net.Sockets Namespace


NetworkStream.DataAvailable

Indicates data is available on the stream to be read.

[Visual Basic]
Overridable Public ReadOnly Property DataAvailable As Boolean
[C#]
public bool DataAvailable {override get;}
[C++]
public: __property virtual bool get_DataAvailable();
[JScript]
public function get DataAvailable() : Boolean;

See Also

NetworkStream Class | NetworkStream Members | System.Net.Sockets Namespace


NetworkStream.Length

The length of data available on the stream. Always throws System..NotSupportedException.

[Visual Basic]
Overridable Public ReadOnly Property Length As Long
[C#]
public long Length {override get;}
[C++]
public: __property virtual __int64 get_Length();
[JScript]
public function get Length() : long;

Exceptions

Exception Type | Condition
NotSupportedException | Any access.

See Also

NetworkStream Class | NetworkStream Members | System.Net.Sockets Namespace


NetworkStream.Position

Gets or sets the position in the stream. Always throws System..NotSupportedException.

[Visual Basic]
Overridable Public Property Position As Long
[C#]
public long Position {override get; override set;}
[C++]
public: __property virtual __int64 get_Position();
public: __property virtual void set_Position(__int64);
[JScript]
public function get Position() : long;
public function set Position(long);

Exceptions

Exception Type | Condition
NotSupportedException | Any access.

See Also

NetworkStream Class | NetworkStream Members | System.Net.Sockets Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

NetworkStream Methods

The methods of the NetworkStream class are listed below. For a complete list of NetworkStream class members, see the NetworkStream Members topic.

Public:

BeginRead | Begins an asychronous read from a stream.
BeginWrite | Begins an asynchronous write to a stream.
Close | Closes the stream, and then closes the underlying socket.
EndRead | Handle the end of an asynchronous read.
EndWrite | Handle the end of an asynchronous write.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Flush | Flushes data from the stream.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Read | Reads data from the stream.
ReadByte (inherited from Stream) | Reads a byte from the current position in the stream, or-1 if at the end of the stream.
Seek | Seeks a specific position in the stream. This method is not supported by the System.Net.Socket..NetworkStream class.
SetLength | Sets the length of the stream. Always throws System..NotSupportedException.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Writes data to the stream..
WriteByte (inherited from Stream) | Writes a byte to the current position in the stream. If the stream is closed or not writable, an exception will be thrown.

Protected:

CreateWaitHandle (inherited from Stream) | Allocates a WaitHandle object efficiently.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NetworkStream Class | System.Net.Sockets Namespace


NetworkStream.BeginRead

Begins an asychronous read from a stream.

[Visual Basic]
Overrides Public Function BeginRead( _
   ByVal readBuffer() As Byte, _
   ByVal index As Integer, _
   ByVal size As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
[C#]
public override IAsyncResult BeginRead(
   byte[] readBuffer,
   int index,
   int size,
   AsyncCallback callback,
   object state
);
[C++]
public: override IAsyncResult* BeginRead(
   unsigned char* readBuffer[],
   int index,
   int size,
   AsyncCallback* callback,
   Object* state
);
[JScript]
public override function BeginRead(
   readBuffer : Byte[],
   index : int,
   size : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;

Parameters

readBuffer
The location to store the data read from the stream.
index
[To be supplied.]
size
[To be supplied.]
callback
[To be supplied.]
state
[To be supplied.]

Return Value

A handle to the asynchronous call.

See Also

NetworkStream Class | NetworkStream Members | System.Net.Sockets Namespace


NetworkStream.BeginWrite

Begins an asynchronous write to a stream.

[Visual Basic]
Overrides Public Function BeginWrite( _
   ByVal sendBuffer() As Byte, _
   ByVal index As Integer, _
   ByVal size As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
[C#]
public override IAsyncResult BeginWrite(
   byte[] sendBuffer,
   int index,
   int size,
   AsyncCallback callback,
   object state
);
[C++]
public: override IAsyncResult* BeginWrite(
   unsigned char* sendBuffer[],
   int index,
   int size,
   AsyncCallback* callback,
   Object* state
);
[JScript]
public override function BeginWrite(
   sendBuffer : Byte[],
   index : int,
   size : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;

Parameters

sendBuffer
The data to send to the stream.
index
[To be supplied.]
size
[To be supplied.]
callback
[To be supplied.]
state
[To be supplied.]

Return Value

The handle to the asychronous call.

See Also

NetworkStream Class | NetworkStream Members | System.Net.Sockets Namespace


NetworkStream.Close

Closes the stream, and then closes the underlying socket.

[Visual Basic]
Overrides Public Sub Close()
[C#]
public override void Close();
[C++]
public: override void Close();
[JScript]
public override function Close();

See Also

NetworkStream Class | NetworkStream Members | System.Net.Sockets Namespace


NetworkStream.EndRead

Handle the end of an asynchronous read.

[Visual Basic]
Overrides Public Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
[C#]
public override int EndRead(
   IAsyncResult asyncResult
);
[C++]
public: override int EndRead(
   IAsyncResult* asyncResult
);
[JScript]
public override function EndRead(
   asyncResult : IAsyncResult
) : int;

Parameters

asyncResult
The handle to the asychronous call.

Return Value

The number of bytes read from the stream.

See Also

NetworkStream Class | NetworkStream Members | System.Net.Sockets Namespace


NetworkStream.EndWrite

Handle the end of an asynchronous write.

[Visual Basic]
Overrides Public Function EndWrite( _
   ByVal asyncResult As IAsyncResult _
) As Integer
[C#]
public override int EndWrite(
   IAsyncResult asyncResult
);
[C++]
public: override int EndWrite(
   IAsyncResult* asyncResult
);
[JScript]
public override function EndWrite(
   asyncResult : IAsyncResult
) : int;

Parameters

asyncResult
The handle to the asychronous call.

Return Value

The number of bytes written to the stream.

See Also

NetworkStream Class | NetworkStream Members | System.Net.Sockets Namespace


NetworkStream.Flush

Flushes data from the stream.

[Visual Basic]
Overrides Public Sub Flush()
[C#]
public override void Flush();
[C++]
public: override void Flush();
[JScript]
public override function Flush();

See Also

NetworkStream Class | NetworkStream Members | System.Net.Sockets Namespace


NetworkStream.Read

Reads data from the stream.

[Visual Basic]
Overrides Public Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
[C#]
public override int Read(
   byte[] buffer,
   int offset,
   int count
);
[C++]
public: override int Read(
   unsigned char* buffer[],
   int offset,
   int count
);
[JScript]
public override function Read(
   buffer : Byte[],
   offset : int,
   count : int
) : int;

Parameters

buffer
Location to store data read from the stream.
offset
[To be supplied.]
count
[To be supplied.]

Return Value

The number of bytes read from the stream, or 0 if the underlying socket is closed.

See Also

NetworkStream Class | NetworkStream Members | System.Net.Sockets Namespace


NetworkStream.Seek

Seeks a specific position in the stream. This method is not supported by the System.Net.Socket..NetworkStream class.

[Visual Basic]
Overrides Public Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
[C#]
public override long Seek(
   long offset,
   SeekOrigin origin
);
[C++]
public: override __int64 Seek(
   __int64 offset,
   SeekOrigin origin
);
[JScript]
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;

Parameters

offset
[To be supplied.]
origin
[To be supplied.]

Exceptions

Exception Type | Condition
NotSupportedException | Any access.

See Also

NetworkStream Class | NetworkStream Members | System.Net.Sockets Namespace


NetworkStream.SetLength

Sets the length of the stream. Always throws System..NotSupportedException.

[Visual Basic]
Overrides Public Sub SetLength( _
   ByVal value As Long _
)
[C#]
public override void SetLength(
   long value
);
[C++]
public: override void SetLength(
   __int64 value
);
[JScript]
public override function SetLength(
   value : long
);

Parameters

value
[To be supplied.]

Exceptions

Exception Type | Condition
NotSupportedException | Any access.

See Also

NetworkStream Class | NetworkStream Members | System.Net.Sockets Namespace


NetworkStream.Write

Writes data to the stream..

[Visual Basic]
Overrides Public Function Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
[C#]
public override int Write(
   byte[] buffer,
   int offset,
   int count
);
[C++]
public: override int Write(
   unsigned char* buffer[],
   int offset,
   int count
);
[JScript]
public override function Write(
   buffer : Byte[],
   offset : int,
   count : int
) : int;

Parameters

buffer
The data to write to the stream.
offset
The location in the buffer to start writing data.
count
The number of bytes to write to the stream.

Return Value

The number of bytes written to the stream.

Exceptions

Exception Type | Condition
System.IOException | The number of bytes written to the stream does not equal count.

See Also

NetworkStream Class | NetworkStream Members | System.Net.Sockets Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

NetworkStream Fields

The fields of the NetworkStream class are listed below. For a complete list of NetworkStream class members, see the NetworkStream Members topic.

Protected:

m_Readable | Used by the class to indicate that the stream is readable.
m_StreamSocket | Used by the class to hold the underlying socket the stream uses.
m_Writeable | Used by the class to indicate that the stream is writable.

See Also

NetworkStream Class | System.Net.Sockets Namespace


NetworkStream.m_Readable

Used by the class to indicate that the stream is readable.

[Visual Basic]
Protected m_Readable As Boolean
[C#]
protected bool m_Readable;
[C++]
protected: bool m_Readable;
[JScript]
protected var m_Readable : Boolean;

See Also

NetworkStream Class | NetworkStream Members | System.Net.Sockets Namespace


NetworkStream.m_StreamSocket

Used by the class to hold the underlying socket the stream uses.

[Visual Basic]
Protected m_StreamSocket As Socket
[C#]
protected Socket m_StreamSocket;
[C++]
protected: Socket* m_StreamSocket;
[JScript]
protected var m_StreamSocket : Socket;

See Also

NetworkStream Class | NetworkStream Members | System.Net.Sockets Namespace


NetworkStream.m_Writeable

Used by the class to indicate that the stream is writable.

[Visual Basic]
Protected m_Writeable As Boolean
[C#]
protected bool m_Writeable;
[C++]
protected: bool m_Writeable;
[JScript]
protected var m_Writeable : Boolean;

See Also

NetworkStream Class | NetworkStream Members | System.Net.Sockets Namespace


ProtocolFamily Class

Specifies the type of protocol that an instance of the Socket class can use.

Object
ProtocolFamily

[Visual Basic]
Public Class ProtocolFamily
[C#]
public class ProtocolFamily
[C++]
public __gc class ProtocolFamily
[JScript]
public class ProtocolFamily

Remarks

[To be supplied.]

Requirements

Namespace: System.Net.Sockets

Assembly: System.net.dll

See Also

ProtocolFamily Members | System.Net.Sockets Namespace


ProtocolFamily Members

Public:

Constructor

ProtocolFamily Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

PfAppletalk | [To be supplied.]
PfBan | [To be supplied.]
PfCCITT | [To be supplied.]
PfChaos | [To be supplied.]
PfDatakit | [To be supplied.]
PfDECnet | [To be supplied.]
PfDli | [To be supplied.]
PfECMA | [To be supplied.]
PfFirefox | [To be supplied.]
PfHylink | [To be supplied.]
PfImplink | [To be supplied.]
PfINet | [To be supplied.]
PfIpx | [To be supplied.]
PfISO | [To be supplied.]
PfLAT | [To be supplied.]
PfNetbios | [To be supplied.]
PfNS | [To be supplied.]
PfOSI | [To be supplied.]
PfPup | [To be supplied.]
PfSNA | [To be supplied.]
PfUnix | [To be supplied.]
PfUnspec | [To be supplied.]
PfUunknown1 | [To be supplied.]
PfVoiceview | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProtocolFamily Class | System.Net.Sockets Namespace


ProtocolFamily Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ProtocolFamily();
[C++]
public: ProtocolFamily();
[JScript]
public function ProtocolFamily();

See Also

ProtocolFamily Class | ProtocolFamily Members | System.Net.Sockets Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ProtocolFamily Fields

The fields of the ProtocolFamily class are listed below. For a complete list of ProtocolFamily class members, see the ProtocolFamily Members topic.

Public:

PfAppletalk | [To be supplied.]
PfBan | [To be supplied.]
PfCCITT | [To be supplied.]
PfChaos | [To be supplied.]
PfDatakit | [To be supplied.]
PfDECnet | [To be supplied.]
PfDli | [To be supplied.]
PfECMA | [To be supplied.]
PfFirefox | [To be supplied.]
PfHylink | [To be supplied.]
PfImplink | [To be supplied.]
PfINet | [To be supplied.]
PfIpx | [To be supplied.]
PfISO | [To be supplied.]
PfLAT | [To be supplied.]
PfNetbios | [To be supplied.]
PfNS | [To be supplied.]
PfOSI | [To be supplied.]
PfPup | [To be supplied.]
PfSNA | [To be supplied.]
PfUnix | [To be supplied.]
PfUnspec | [To be supplied.]
PfUunknown1 | [To be supplied.]
PfVoiceview | [To be supplied.]

See Also

ProtocolFamily Class | System.Net.Sockets Namespace


ProtocolFamily.PfAppletalk

[To be supplied.]

[Visual Basic]
Public Const PfAppletalk As Integer
[C#]
public const int PfAppletalk;
[C++]
public: const int PfAppletalk;
[JScript]
public var PfAppletalk : int;

See Also

ProtocolFamily Class | ProtocolFamily Members | System.Net.Sockets Namespace


ProtocolFamily.PfBan

[To be supplied.]

[Visual Basic]
Public Const PfBan As Integer
[C#]
public const int PfBan;
[C++]
public: const int PfBan;
[JScript]
public var PfBan : int;

See Also

ProtocolFamily Class | ProtocolFamily Members | System.Net.Sockets Namespace


ProtocolFamily.PfCCITT

[To be supplied.]

[Visual Basic]
Public Const PfCCITT As Integer
[C#]
public const int PfCCITT;
[C++]
public: const int PfCCITT;
[JScript]
public var PfCCITT : int;

See Also

ProtocolFamily Class | ProtocolFamily Members | System.Net.Sockets Namespace


ProtocolFamily.PfChaos

[To be supplied.]

[Visual Basic]
Public Const PfChaos As Integer
[C#]
public const int PfChaos;
[C++]
public: const int PfChaos;
[JScript]
public var PfChaos : int;

See Also

ProtocolFamily Class | ProtocolFamily Members | System.Net.Sockets Namespace


ProtocolFamily.PfDatakit

[To be supplied.]

[Visual Basic]
Public Const PfDatakit As Integer
[C#]
public const int PfDatakit;
[C++]
public: const int PfDatakit;
[JScript]
public var PfDatakit : int;

See Also

ProtocolFamily Class | ProtocolFamily Members | System.Net.Sockets Namespace


ProtocolFamily.PfDECnet

[To be supplied.]

[Visual Basic]
Public Const PfDECnet As Integer
[C#]
public const int PfDECnet;
[C++]
public: const int PfDECnet;
[JScript]
public var PfDECnet : int;

See Also

ProtocolFamily Class | ProtocolFamily Members | System.Net.Sockets Namespace


ProtocolFamily.PfDli

[To be supplied.]

[Visual Basic]
Public Const PfDli As Integer
[C#]
public const int PfDli;
[C++]
public: const int PfDli;
[JScript]
public var PfDli : int;

See Also

ProtocolFamily Class | ProtocolFamily Members | System.Net.Sockets Namespace


ProtocolFamily.PfECMA

[To be supplied.]

[Visual Basic]
Public Const PfECMA As Integer
[C#]
public const int PfECMA;
[C++]
public: const int PfECMA;
[JScript]
public var PfECMA : int;

See Also

ProtocolFamily Class | ProtocolFamily Members | System.Net.Sockets Namespace


ProtocolFamily.PfFirefox

[To be supplied.]

[Visual Basic]
Public Const PfFirefox As Integer
[C#]
public const int PfFirefox;
[C++]
public: const int PfFirefox;
[JScript]
public var PfFirefox : int;

See Also

ProtocolFamily Class | ProtocolFamily Members | System.Net.Sockets Namespace


ProtocolFamily.PfHylink

[To be supplied.]

[Visual Basic]
Public Const PfHylink As Integer
[C#]
public const int PfHylink;
[C++]
public: const int PfHylink;
[JScript]
public var PfHylink : int;

See Also

ProtocolFamily Class | ProtocolFamily Members | System.Net.Sockets Namespace


ProtocolFamily.PfImplink

[To be supplied.]

[Visual Basic]
Public Const PfImplink As Integer
[C#]
public const int PfImplink;
[C++]
public: const int PfImplink;
[JScript]
public var PfImplink : int;

See Also

ProtocolFamily Class | ProtocolFamily Members | System.Net.Sockets Namespace


ProtocolFamily.PfINet

[To be supplied.]

[Visual Basic]
Public Const PfINet As Integer
[C#]
public const int PfINet;
[C++]
public: const int PfINet;
[JScript]
public var PfINet : int;

See Also

ProtocolFamily Class | ProtocolFamily Members | System.Net.Sockets Namespace


ProtocolFamily.PfIpx

[To be supplied.]

[Visual Basic]
Public Const PfIpx As Integer
[C#]
public const int PfIpx;
[C++]
public: const int PfIpx;
[JScript]
public var PfIpx : int;

See Also

ProtocolFamily Class | ProtocolFamily Members | System.Net.Sockets Namespace


ProtocolFamily.PfISO

[To be supplied.]

[Visual Basic]
Public Const PfISO As Integer
[C#]
public const int PfISO;
[C++]
public: const int PfISO;
[JScript]
public var PfISO : int;

See Also

ProtocolFamily Class | ProtocolFamily Members | System.Net.Sockets Namespace


ProtocolFamily.PfLAT

[To be supplied.]

[Visual Basic]
Public Const PfLAT As Integer
[C#]
public const int PfLAT;
[C++]
public: const int PfLAT;
[JScript]
public var PfLAT : int;

See Also

ProtocolFamily Class | ProtocolFamily Members | System.Net.Sockets Namespace


ProtocolFamily.PfNetbios

[To be supplied.]

[Visual Basic]
Public Const PfNetbios As Integer
[C#]
public const int PfNetbios;
[C++]
public: const int PfNetbios;
[JScript]
public var PfNetbios : int;

See Also

ProtocolFamily Class | ProtocolFamily Members | System.Net.Sockets Namespace


ProtocolFamily.PfNS

[To be supplied.]

[Visual Basic]
Public Const PfNS As Integer
[C#]
public const int PfNS;
[C++]
public: const int PfNS;
[JScript]
public var PfNS : int;

See Also

ProtocolFamily Class | ProtocolFamily Members | System.Net.Sockets Namespace


ProtocolFamily.PfOSI

[To be supplied.]

[Visual Basic]
Public Const PfOSI As Integer
[C#]
public const int PfOSI;
[C++]
public: const int PfOSI;
[JScript]
public var PfOSI : int;

See Also

ProtocolFamily Class | ProtocolFamily Members | System.Net.Sockets Namespace


ProtocolFamily.PfPup

[To be supplied.]

[Visual Basic]
Public Const PfPup As Integer
[C#]
public const int PfPup;
[C++]
public: const int PfPup;
[JScript]
public var PfPup : int;

See Also

ProtocolFamily Class | ProtocolFamily Members | System.Net.Sockets Namespace


ProtocolFamily.PfSNA

[To be supplied.]

[Visual Basic]
Public Const PfSNA As Integer
[C#]
public const int PfSNA;
[C++]
public: const int PfSNA;
[JScript]
public var PfSNA : int;

See Also

ProtocolFamily Class | ProtocolFamily Members | System.Net.Sockets Namespace


ProtocolFamily.PfUnix

[To be supplied.]

[Visual Basic]
Public Const PfUnix As Integer
[C#]
public const int PfUnix;
[C++]
public: const int PfUnix;
[JScript]
public var PfUnix : int;

See Also

ProtocolFamily Class | ProtocolFamily Members | System.Net.Sockets Namespace


ProtocolFamily.PfUnspec

[To be supplied.]

[Visual Basic]
Public Const PfUnspec As Integer
[C#]
public const int PfUnspec;
[C++]
public: const int PfUnspec;
[JScript]
public var PfUnspec : int;

See Also

ProtocolFamily Class | ProtocolFamily Members | System.Net.Sockets Namespace


ProtocolFamily.PfUunknown1

[To be supplied.]

[Visual Basic]
Public Const PfUunknown1 As Integer
[C#]
public const int PfUunknown1;
[C++]
public: const int PfUunknown1;
[JScript]
public var PfUunknown1 : int;

See Also

ProtocolFamily Class | ProtocolFamily Members | System.Net.Sockets Namespace


ProtocolFamily.PfVoiceview

[To be supplied.]

[Visual Basic]
Public Const PfVoiceview As Integer
[C#]
public const int PfVoiceview;
[C++]
public: const int PfVoiceview;
[JScript]
public var PfVoiceview : int;

See Also

ProtocolFamily Class | ProtocolFamily Members | System.Net.Sockets Namespace


ProtocolType Class

Specifies the protocols that the Socket class supports.

Object
ProtocolType

[Visual Basic]
Public Class ProtocolType
[C#]
public class ProtocolType
[C++]
public __gc class ProtocolType
[JScript]
public class ProtocolType

Remarks

[To be supplied.]

Requirements

Namespace: System.Net.Sockets

Assembly: System.net.dll

See Also

ProtocolType Members | System.Net.Sockets Namespace


ProtocolType Members

Public:

Constructor

ProtocolType Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

ProtGGP | [To be supplied.]
ProtICMP | [To be supplied.]
ProtIDP | [To be supplied.]
ProtIGMP | [To be supplied.]
ProtIP | [To be supplied.]
ProtND | [To be supplied.]
ProtPUP | [To be supplied.]
ProtRaw | [To be supplied.]
ProtTCP | [To be supplied.]
ProtUDP | [To be supplied.]
ProtUnknown | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProtocolType Class | System.Net.Sockets Namespace


ProtocolType Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ProtocolType();
[C++]
public: ProtocolType();
[JScript]
public function ProtocolType();

See Also

ProtocolType Class | ProtocolType Members | System.Net.Sockets Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ProtocolType Fields

The fields of the ProtocolType class are listed below. For a complete list of ProtocolType class members, see the ProtocolType Members topic.

Public:

ProtGGP | [To be supplied.]
ProtICMP | [To be supplied.]
ProtIDP | [To be supplied.]
ProtIGMP | [To be supplied.]
ProtIP | [To be supplied.]
ProtND | [To be supplied.]
ProtPUP | [To be supplied.]
ProtRaw | [To be supplied.]
ProtTCP | [To be supplied.]
ProtUDP | [To be supplied.]
ProtUnknown | [To be supplied.]

See Also

ProtocolType Class | System.Net.Sockets Namespace


ProtocolType.ProtGGP

[To be supplied.]

[Visual Basic]
Public Const ProtGGP As Integer
[C#]
public const int ProtGGP;
[C++]
public: const int ProtGGP;
[JScript]
public var ProtGGP : int;

See Also

ProtocolType Class | ProtocolType Members | System.Net.Sockets Namespace


ProtocolType.ProtICMP

[To be supplied.]

[Visual Basic]
Public Const ProtICMP As Integer
[C#]
public const int ProtICMP;
[C++]
public: const int ProtICMP;
[JScript]
public var ProtICMP : int;

See Also

ProtocolType Class | ProtocolType Members | System.Net.Sockets Namespace


ProtocolType.ProtIDP

[To be supplied.]

[Visual Basic]
Public Const ProtIDP As Integer
[C#]
public const int ProtIDP;
[C++]
public: const int ProtIDP;
[JScript]
public var ProtIDP : int;

See Also

ProtocolType Class | ProtocolType Members | System.Net.Sockets Namespace


ProtocolType.ProtIGMP

[To be supplied.]

[Visual Basic]
Public Const ProtIGMP As Integer
[C#]
public const int ProtIGMP;
[C++]
public: const int ProtIGMP;
[JScript]
public var ProtIGMP : int;

See Also

ProtocolType Class | ProtocolType Members | System.Net.Sockets Namespace


ProtocolType.ProtIP

[To be supplied.]

[Visual Basic]
Public Const ProtIP As Integer
[C#]
public const int ProtIP;
[C++]
public: const int ProtIP;
[JScript]
public var ProtIP : int;

See Also

ProtocolType Class | ProtocolType Members | System.Net.Sockets Namespace


ProtocolType.ProtND

[To be supplied.]

[Visual Basic]
Public Const ProtND As Integer
[C#]
public const int ProtND;
[C++]
public: const int ProtND;
[JScript]
public var ProtND : int;

See Also

ProtocolType Class | ProtocolType Members | System.Net.Sockets Namespace


ProtocolType.ProtPUP

[To be supplied.]

[Visual Basic]
Public Const ProtPUP As Integer
[C#]
public const int ProtPUP;
[C++]
public: const int ProtPUP;
[JScript]
public var ProtPUP : int;

See Also

ProtocolType Class | ProtocolType Members | System.Net.Sockets Namespace


ProtocolType.ProtRaw

[To be supplied.]

[Visual Basic]
Public Const ProtRaw As Integer
[C#]
public const int ProtRaw;
[C++]
public: const int ProtRaw;
[JScript]
public var ProtRaw : int;

See Also

ProtocolType Class | ProtocolType Members | System.Net.Sockets Namespace


ProtocolType.ProtTCP

[To be supplied.]

[Visual Basic]
Public Const ProtTCP As Integer
[C#]
public const int ProtTCP;
[C++]
public: const int ProtTCP;
[JScript]
public var ProtTCP : int;

See Also

ProtocolType Class | ProtocolType Members | System.Net.Sockets Namespace


ProtocolType.ProtUDP

[To be supplied.]

[Visual Basic]
Public Const ProtUDP As Integer
[C#]
public const int ProtUDP;
[C++]
public: const int ProtUDP;
[JScript]
public var ProtUDP : int;

See Also

ProtocolType Class | ProtocolType Members | System.Net.Sockets Namespace


ProtocolType.ProtUnknown

[To be supplied.]

[Visual Basic]
Public Const ProtUnknown As Integer
[C#]
public const int ProtUnknown;
[C++]
public: const int ProtUnknown;
[JScript]
public var ProtUnknown : int;

See Also

ProtocolType Class | ProtocolType Members | System.Net.Sockets Namespace


SelectMode Enumeration

Specifies the mode for polling the status of a socket.

[Visual Basic]
Public Enum SelectMode
[C#]
public enum SelectMode
[C++]
public enum SelectMode

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
SelectError | Poll the error status of a socket.
SelectRead | Poll the read status of a socket.
SelectWrite | Poll the write status of a socket.

Requirements

Namespace: System.Net.Sockets

Assembly: System.net.dll

See Also

System.Net.Sockets Namespace


Socket Class

The Socket class implements the Berkeley sockets interface.

Object
Socket

[Visual Basic]
Public Class Socket
[C#]
public class Socket
[C++]
public __gc class Socket
[JScript]
public class Socket

Remarks

The Socket class creates a managed version of an Internet transport service. Once the socket is created, it is bound to a specific end point with the Bind method. The connection to the end point is established with the Connect method, and then data is sent to the socket using the Send or SendTo methods, and data is read from the socket using the Receive and ReceiveFrom methods. After use, the Shutdown method is used to disable the socket, and the Close method closes the socket.

Requirements

Namespace: System.Net.Sockets

Assembly: System.net.dll

See Also

Socket Members | System.Net.Sockets Namespace


Socket Members

Public:

Constructor

Socket Constructor Overloaded. [To be supplied.]

Properties

AddressFamily | Gets the socket's address family.
Available | Gets the amount of data pending in the network's input buffer that can be read from the socket.
Blocking | Gets and sets the blocking mode of a socket.
Connected | Gets the connection state of the socket.
Descriptor | Gets the operating system handle for the socket.
LocalEndpoint | Gets the local end point.
ProtocolType | Gets the socket's protocol type.
RemoteEndpoint | Gets the remote end point
SocketType | Gets the socket's type.

Methods

Accept | Creates a new Socket instance to handle an incoming connection.
BeginAccept | [To be supplied.]
BeginConnect | [To be supplied.]
BeginReceive | [To be supplied.]
BeginReceiveFrom | [To be supplied.]
BeginSend | [To be supplied.]
BeginSendTo | [To be supplied.]
Bind | Associates a socket with an end point.
Close | Forces a socket connection to close.
Connect | Establishes a connection to a remote system.
EndAccept | [To be supplied.]
EndConnect | [To be supplied.]
EndReceive | [To be supplied.]
EndReceiveFrom | [To be supplied.]
EndSend | [To be supplied.]
EndSendTo | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSockOpt | Gets the value of a socket option.
GetType (inherited from Object) | Gets the Type of the Object.
Listen | Places a socket in a listening state.
Poll | Determines the status of the socket.
Receive | Overloaded. Receives data from a connected socket.
ReceiveFrom | Overloaded. Receives a datagram and stores the source end point.
Select | Determines the status of a socket.
Send | Overloaded. Sends data to a connected socket.
SendTo | Overloaded. Sends data to a specific end point.
SetSockOpt | Overloaded. Sets a socket option.
Shutdown | Disables sends and receives on a socket.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Constructor

Socket Constructor Overloaded. [To be supplied.]

Methods

Audit | [To be supplied.]
Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Socket Class | System.Net.Sockets Namespace


Socket Constructor

[To be supplied.]

Overload List

Initializes a new instance of the Socket class.

[Visual Basic] Overloads Public Sub New(Integer, Integer, Integer)
[C#] public Socket(int, int, int);
[C++] public: Socket(int, int, int);
[JScript] public function Socket(int, int, int);

Called by the class to create a socket to accept an incoming request.

[Visual Basic] Overloads Protected Sub New(Integer)
[C#] protected Socket(int);
[C++] protected: Socket(int);
[JScript] protected function Socket(int);

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket Constructor (Int32, Int32, Int32)

Initializes a new instance of the Socket class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal af As Integer, _
   ByVal type As Integer, _
   ByVal pr As Integer _
)
[C#]
public Socket(
   int af,
   int type,
   int pr
);
[C++]
public: Socket(
   int af,
   int type,
   int pr
);
[JScript]
public function Socket(
   af : int,
   type : int,
   pr : int
);

Parameters

af
The address family the socket will use.
type
[To be supplied.]
pr
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentException | The combination of address family, socket type, and protocol results in an invalid socket.

Remarks

The address family, socket type, and protocol parameters are not independent. Some address families restrict the protocols that can be used with them, and often the socket type is implicit in the protocol used. If the combination of address family, socket type, and protocol results in and invalid socket, then an exception is thrown.

The valid address families are defined in the AddressFamily class. The valid socket types are defined in the SocketType class. The valid protocol types are defined in the ProtocolType class.

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace | Socket Constructor Overload List


Socket Constructor (Int32)

Called by the class to create a socket to accept an incoming request.

[Visual Basic]
Overloads Protected Sub New( _
   ByVal fd As Integer _
)
[C#]
protected Socket(
   int fd
);
[C++]
protected: Socket(
   int fd
);
[JScript]
protected function Socket(
   fd : int
);

Parameters

fd
Handle to a socket.

Remarks

This constructor is used by the class to create a copy of the socket to handle an incoming connection request when Accept is called. The socket returned is a copy of the socket referenced by fd.

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace | Socket Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Socket Properties

The properties of the Socket class are listed below. For a complete list of Socket class members, see the Socket Members topic.

Public:

AddressFamily | Gets the socket's address family.
Available | Gets the amount of data pending in the network's input buffer that can be read from the socket.
Blocking | Gets and sets the blocking mode of a socket.
Connected | Gets the connection state of the socket.
Descriptor | Gets the operating system handle for the socket.
LocalEndpoint | Gets the local end point.
ProtocolType | Gets the socket's protocol type.
RemoteEndpoint | Gets the remote end point
SocketType | Gets the socket's type.

See Also

Socket Class | System.Net.Sockets Namespace


Socket.AddressFamily

Gets the socket's address family.

[Visual Basic]
Public ReadOnly Property AddressFamily As Integer
[C#]
public int AddressFamily {get;}
[C++]
public: __property int get_AddressFamily();
[JScript]
public function get AddressFamily() : int;

Remarks

The valid address families are defined in the AddressFamily class.

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace | AddressFamily


Socket.Available

Gets the amount of data pending in the network's input buffer that can be read from the socket.

[Visual Basic]
Public ReadOnly Property Available As Integer
[C#]
public int Available {get;}
[C++]
public: __property int get_Available();
[JScript]
public function get Available() : int;

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.Blocking

Gets and sets the blocking mode of a socket.

[Visual Basic]
Public Property Blocking As Boolean
[C#]
public bool Blocking {get; set;}
[C++]
public: __property bool get_Blocking();
public: __property void set_Blocking(bool);
[JScript]
public function get Blocking() : Boolean;
public function set Blocking(Boolean);

Remarks

Sockets are created in blocking mode by default. To set the socket to non-blocking mode, set Blocking false.

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.Connected

Gets the connection state of the socket.

[Visual Basic]
Public ReadOnly Property Connected As Boolean
[C#]
public bool Connected {get;}
[C++]
public: __property bool get_Connected();
[JScript]
public function get Connected() : Boolean;

Remarks

Connected returns true if the socket has connected to a remote resource or if the socket has accepted a connection from a remote resource; otherwise Connected returns false.

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.Descriptor

Gets the operating system handle for the socket.

[Visual Basic]
Public ReadOnly Property Descriptor As Integer
[C#]
public int Descriptor {get;}
[C++]
public: __property int get_Descriptor();
[JScript]
public function get Descriptor() : int;

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.LocalEndpoint

Gets the local end point.

[Visual Basic]
Public ReadOnly Property LocalEndpoint As EndPoint
[C#]
public EndPoint LocalEndpoint {get;}
[C++]
public: __property EndPoint* get_LocalEndpoint();
[JScript]
public function get LocalEndpoint() : EndPoint;

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.ProtocolType

Gets the socket's protocol type.

[Visual Basic]
Public ReadOnly Property ProtocolType As Integer
[C#]
public int ProtocolType {get;}
[C++]
public: __property int get_ProtocolType();
[JScript]
public function get ProtocolType() : int;

Remarks

The valid protocol types are defined in the ProtocolType class.

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.RemoteEndpoint

Gets the remote end point

[Visual Basic]
Public ReadOnly Property RemoteEndpoint As EndPoint
[C#]
public EndPoint RemoteEndpoint {get;}
[C++]
public: __property EndPoint* get_RemoteEndpoint();
[JScript]
public function get RemoteEndpoint() : EndPoint;

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.SocketType

Gets the socket's type.

[Visual Basic]
Public ReadOnly Property SocketType As Integer
[C#]
public int SocketType {get;}
[C++]
public: __property int get_SocketType();
[JScript]
public function get SocketType() : int;

Remarks

The valid socket types are defined in the SocketType class.

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace | SocketType


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Socket Methods

The methods of the Socket class are listed below. For a complete list of Socket class members, see the Socket Members topic.

Public:

Accept | Creates a new Socket instance to handle an incoming connection.
BeginAccept | [To be supplied.]
BeginConnect | [To be supplied.]
BeginReceive | [To be supplied.]
BeginReceiveFrom | [To be supplied.]
BeginSend | [To be supplied.]
BeginSendTo | [To be supplied.]
Bind | Associates a socket with an end point.
Close | Forces a socket connection to close.
Connect | Establishes a connection to a remote system.
EndAccept | [To be supplied.]
EndConnect | [To be supplied.]
EndReceive | [To be supplied.]
EndReceiveFrom | [To be supplied.]
EndSend | [To be supplied.]
EndSendTo | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSockOpt | Gets the value of a socket option.
GetType (inherited from Object) | Gets the Type of the Object.
Listen | Places a socket in a listening state.
Poll | Determines the status of the socket.
Receive | Overloaded. Receives data from a connected socket.
ReceiveFrom | Overloaded. Receives a datagram and stores the source end point.
Select | Determines the status of a socket.
Send | Overloaded. Sends data to a connected socket.
SendTo | Overloaded. Sends data to a specific end point.
SetSockOpt | Overloaded. Sets a socket option.
Shutdown | Disables sends and receives on a socket.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Audit | [To be supplied.]
Finalize | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Socket Class | System.Net.Sockets Namespace


Socket.Accept

Creates a new Socket instance to handle an incoming connection.

[Visual Basic]
Public Function Accept() As Socket
[C#]
public Socket Accept();
[C++]
public: Socket* Accept();
[JScript]
public function Accept() : Socket;

Return Value

If there is a pending connection request, a Socket instance to handle the incoming connection. If there is no pending connection for an asynchronous socket, a null reference (in Visual Basic Nothing).

Exceptions

Exception Type | Condition
InvalidOperationException | The Accept call is made on a synchronous socket with no pending connection requests.

Remarks

The Accept method extracts the first connection request on the queue of pending requests and creates a new Socket instance to handle the request. The Socket returned by Accept is a duplicate of the current Socket.If Accept is called on an asynchronous socket with no pending connection requests, null will be returned.

Example [C#]

The following code will display any error message returned by Accept.

[C#]

result = aSocket.Accept
if (result <> 0)
{
   Console.WriteLine("Winsock error: " + Convert.ToString(Marshal.GetLastWin32Error()) );

}

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.Audit

[To be supplied.]

[Visual Basic]
Protected Sub Audit( _
   ByVal outgoing As Stream, _
   ByVal incoming As Stream _
)
[C#]
protected void Audit(
   Stream outgoing,
   Stream incoming
);
[C++]
protected: void Audit(
   Stream* outgoing,
   Stream* incoming
);
[JScript]
protected function Audit(
   outgoing : Stream,
   incoming : Stream
);

Parameters

outgoing
[To be supplied.]
incoming
[To be supplied.]

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.BeginAccept

[To be supplied.]

[Visual Basic]
Public Function BeginAccept( _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginAccept(
   AsyncCallback callback,
   object state
);
[C++]
public: IAsyncResult* BeginAccept(
   AsyncCallback* callback,
   Object* state
);
[JScript]
public function BeginAccept(
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;

Parameters

callback
[To be supplied.]
state
[To be supplied.]

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.BeginConnect

[To be supplied.]

[Visual Basic]
Public Function BeginConnect( _
   ByVal remoteEP As EndPoint, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginConnect(
   EndPoint remoteEP,
   AsyncCallback callback,
   object state
);
[C++]
public: IAsyncResult* BeginConnect(
   EndPoint* remoteEP,
   AsyncCallback* callback,
   Object* state
);
[JScript]
public function BeginConnect(
   remoteEP : EndPoint,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;

Parameters

remoteEP
[To be supplied.]
callback
[To be supplied.]
state
[To be supplied.]

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.BeginReceive

[To be supplied.]

[Visual Basic]
Public Function BeginReceive( _
   ByVal readBuffer As Array, _
   ByVal index As Integer, _
   ByVal size As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginReceive(
   Array readBuffer,
   int index,
   int size,
   AsyncCallback callback,
   object state
);
[C++]
public: IAsyncResult* BeginReceive(
   Array* readBuffer,
   int index,
   int size,
   AsyncCallback* callback,
   Object* state
);
[JScript]
public function BeginReceive(
   readBuffer : Array,
   index : int,
   size : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;

Parameters

readBuffer
[To be supplied.]
index
[To be supplied.]
size
[To be supplied.]
callback
[To be supplied.]
state
[To be supplied.]

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.BeginReceiveFrom

[To be supplied.]

[Visual Basic]
Public Function BeginReceiveFrom( _
   ByVal readBuffer As Array, _
   ByVal index As Integer, _
   ByVal request As Integer, _
   ByVal flags As Integer, _
   ByRef EP As EndPoint, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginReceiveFrom(
   Array readBuffer,
   int index,
   int request,
   int flags,
   ref EndPoint EP,
   AsyncCallback callback,
   object state
);
[C++]
public: IAsyncResult* BeginReceiveFrom(
   Array* readBuffer,
   int index,
   int request,
   int flags,
   EndPoint** EP,
   AsyncCallback* callback,
   Object* state
);
[JScript]
public function BeginReceiveFrom(
   readBuffer : Array,
   index : int,
   request : int,
   flags : int,
   EP : EndPoint,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;

Parameters

readBuffer
[To be supplied.]
index
[To be supplied.]
request
[To be supplied.]
flags
[To be supplied.]
EP
[To be supplied.]
callback
[To be supplied.]
state
[To be supplied.]

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.BeginSend

[To be supplied.]

[Visual Basic]
Public Function BeginSend( _
   ByVal writeBuffer As Array, _
   ByVal index As Integer, _
   ByVal size As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginSend(
   Array writeBuffer,
   int index,
   int size,
   AsyncCallback callback,
   object state
);
[C++]
public: IAsyncResult* BeginSend(
   Array* writeBuffer,
   int index,
   int size,
   AsyncCallback* callback,
   Object* state
);
[JScript]
public function BeginSend(
   writeBuffer : Array,
   index : int,
   size : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;

Parameters

writeBuffer
[To be supplied.]
index
[To be supplied.]
size
[To be supplied.]
callback
[To be supplied.]
state
[To be supplied.]

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.BeginSendTo

[To be supplied.]

[Visual Basic]
Public Function BeginSendTo( _
   ByVal writeBuffer As Array, _
   ByVal index As Integer, _
   ByVal size As Integer, _
   ByVal flags As Integer, _
   ByVal remoteEP As EndPoint, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginSendTo(
   Array writeBuffer,
   int index,
   int size,
   int flags,
   EndPoint remoteEP,
   AsyncCallback callback,
   object state
);
[C++]
public: IAsyncResult* BeginSendTo(
   Array* writeBuffer,
   int index,
   int size,
   int flags,
   EndPoint* remoteEP,
   AsyncCallback* callback,
   Object* state
);
[JScript]
public function BeginSendTo(
   writeBuffer : Array,
   index : int,
   size : int,
   flags : int,
   remoteEP : EndPoint,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;

Parameters

writeBuffer
[To be supplied.]
index
[To be supplied.]
size
[To be supplied.]
flags
[To be supplied.]
remoteEP
[To be supplied.]
callback
[To be supplied.]
state
[To be supplied.]

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.Bind

Associates a socket with an end point.

[Visual Basic]
Public Function Bind( _
   ByVal localEP As EndPoint _
) As Integer
[C#]
public int Bind(
   EndPoint localEP
);
[C++]
public: int Bind(
   EndPoint* localEP
);
[JScript]
public function Bind(
   localEP : EndPoint
) : int;

Parameters

localEP
The end point to associate with the socket.

Return Value

0 if the socket was successfully bound; otherwise, returns a non-zero error code.

Remarks

Bind must be called before Listen.

Requirements

NGWS Runtime Security:

NetworkAccess.Accept The end point referenced in localEP must have accept permission.

Example [C#]

If the socket cannot be bound to the end point, Bind will return a non-zero value indicating the error. The following code attempts to bind a socket to an end point. If the bind attempt is unsuccessful, the error code is written to the console.

[C#]

result = aSocket.Bind(anEndPoint);
if (result <> 0)
{
   Console.WriteLine("Winsock error: " + Convert.ToString(Marshal.GetLastWin32Error()) );

}

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.Close

Forces a socket connection to close.

[Visual Basic]
Public Function Close() As Integer
[C#]
public int Close();
[C++]
public: int Close();
[JScript]
public function Close() : int;

Return Value

0 if the socket was successfully closed; otherwise a non-zero error code.

Remarks

The Connected property is set to false when the socket is closed.

The application should call Shutdown before calling Close to assure that all data is sent or received on the socket before the socket is closed.

Example [C#]

If there is a problem closing the socket, Close will return a non-zero value indicating the error. The following code attempts to close a socket. If the attempt is unsuccessful, the error code is written to the console.

[C#]

result = aSocket.Close();
if (result <> 0)
{
   Console.WriteLine("Winsock error: " + Convert.ToString(Marshal.GetLastWin32Error()) );

}

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.Connect

Establishes a connection to a remote system.

[Visual Basic]
Public Function Connect( _
   ByVal remoteEP As EndPoint _
) As Integer
[C#]
public int Connect(
   EndPoint remoteEP
);
[C++]
public: int Connect(
   EndPoint* remoteEP
);
[JScript]
public function Connect(
   remoteEP : EndPoint
) : int;

Parameters

remoteEP
An EndPoint instance representing the remote system.

Return Value

0 if the connection was successful; otherwise, a non-zero error code.

Remarks

Bind must be called before Connect.

Requirements

NGWS Runtime Security:

NetworkAccess.Connect Must have connect permission to remoteEP.

Example [C#]

If the socket cannot be connected to the end point, Connect will return a non-zero value indicating the error. The following code attempts to connect a socket to an end point. If the connect attempt is unsuccessful, the error code is written to the console.

[C#]

result = aSocket.Connect(anEndPoint);
if (result <> 0)
{
   Console.WriteLine("Winsock error: " + Convert.ToString(Marshal.GetLastWin32Error()) );

}

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.EndAccept

[To be supplied.]

[Visual Basic]
Public Function EndAccept( _
   ByVal asyncResult As IAsyncResult _
) As Socket
[C#]
public Socket EndAccept(
   IAsyncResult asyncResult
);
[C++]
public: Socket* EndAccept(
   IAsyncResult* asyncResult
);
[JScript]
public function EndAccept(
   asyncResult : IAsyncResult
) : Socket;

Parameters

asyncResult
[To be supplied.]

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.EndConnect

[To be supplied.]

[Visual Basic]
Public Function EndConnect( _
   ByVal asyncResult As IAsyncResult _
) As Integer
[C#]
public int EndConnect(
   IAsyncResult asyncResult
);
[C++]
public: int EndConnect(
   IAsyncResult* asyncResult
);
[JScript]
public function EndConnect(
   asyncResult : IAsyncResult
) : int;

Parameters

asyncResult
[To be supplied.]

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.EndReceive

[To be supplied.]

[Visual Basic]
Public Function EndReceive( _
   ByVal asyncResult As IAsyncResult _
) As Integer
[C#]
public int EndReceive(
   IAsyncResult asyncResult
);
[C++]
public: int EndReceive(
   IAsyncResult* asyncResult
);
[JScript]
public function EndReceive(
   asyncResult : IAsyncResult
) : int;

Parameters

asyncResult
[To be supplied.]

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.EndReceiveFrom

[To be supplied.]

[Visual Basic]
Public Function EndReceiveFrom( _
   ByVal asyncResult As IAsyncResult _
) As Integer
[C#]
public int EndReceiveFrom(
   IAsyncResult asyncResult
);
[C++]
public: int EndReceiveFrom(
   IAsyncResult* asyncResult
);
[JScript]
public function EndReceiveFrom(
   asyncResult : IAsyncResult
) : int;

Parameters

asyncResult
[To be supplied.]

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.EndSend

[To be supplied.]

[Visual Basic]
Public Function EndSend( _
   ByVal asyncResult As IAsyncResult _
) As Integer
[C#]
public int EndSend(
   IAsyncResult asyncResult
);
[C++]
public: int EndSend(
   IAsyncResult* asyncResult
);
[JScript]
public function EndSend(
   asyncResult : IAsyncResult
) : int;

Parameters

asyncResult
[To be supplied.]

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.EndSendTo

[To be supplied.]

[Visual Basic]
Public Function EndSendTo( _
   ByVal asyncResult As IAsyncResult _
) As Integer
[C#]
public int EndSendTo(
   IAsyncResult asyncResult
);
[C++]
public: int EndSendTo(
   IAsyncResult* asyncResult
);
[JScript]
public function EndSendTo(
   asyncResult : IAsyncResult
) : int;

Parameters

asyncResult
[To be supplied.]

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.Finalize

[To be supplied.]

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.GetSockOpt

Gets the value of a socket option.

[Visual Basic]
Public Function GetSockOpt( _
   ByVal optionLevel As Integer, _
   ByVal optionName As Integer _
) As Object
[C#]
public object GetSockOpt(
   int optionLevel,
   int optionName
);
[C++]
public: Object* GetSockOpt(
   int optionLevel,
   int optionName
);
[JScript]
public function GetSockOpt(
   optionLevel : int,
   optionName : int
) : Object;

Parameters

optionLevel
The level at which the option is defined. Can be either OptionLevelIP or OptionLevelTCP
optionName
The name of the option to get. See the SocketOption class for the valid options.

Return Value

The value of the option. When optionName is set to SoLinger the return value is an instance of LingerOption. When optionName is set to IpAddMembership or IpDropMembership, the return value is an instance of MulticastOption.

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.Listen

Places a socket in a listening state.

[Visual Basic]
Public Function Listen( _
   ByVal backlog As Integer _
) As Integer
[C#]
public int Listen(
   int backlog
);
[C++]
public: int Listen(
   int backlog
);
[JScript]
public function Listen(
   backlog : int
) : int;

Parameters

backlog
Maximim length of the queue of pending connections.

Return Value

0 if no error occurs; otherwise, returns an non-zero error code.

Remarks

If Listen is successful, Connected is set to true.

Bind must be called before Listen.

Example [C#]

If Listen returns a non-zero result, the following code will write the error code to the console:

[C#]

result = aSocket.Shutdown
if (result <> 0)
{
   Console.WriteLine("Winsock error: " + Convert.ToString(Marshal.GetLastWin32Error()) );

}

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.Poll

Determines the status of the socket.

[Visual Basic]
Public Function Poll( _
   ByVal microSeconds As Integer, _
   ByVal mode As SelectMode _
) As Boolean
[C#]
public bool Poll(
   int microSeconds,
   SelectMode mode
);
[C++]
public: bool Poll(
   int microSeconds,
   SelectMode mode
);
[JScript]
public function Poll(
   microSeconds : int,
   mode : SelectMode
) : Boolean;

Parameters

microSeconds
The time to wait for a response, in microseconds.
mode
[To be supplied.]

Return Value

Mode | Return Value
SelectRead | true if Listen has been called and a connection is pending, Accept will succeed; -or- true if data is available for reading; -or- true, if connection has been closed, reset, or terminated; otherwise, returns false.
SelectWrite | true, if processing a non-blocking Connect, connection has succeeded; -or- true, if data can be sent; otherwise, returns false.
SelectError | true, if processing a non-blocking Connect, connection has failed; -or- true, if SoOOBInline is not set and out-of-band data is available; otherwise, returns false.

Exceptions

Exception Type | Condition
ArgumentException | mode is not one of SelectRead, SelectWrite, or SelectError.

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.Receive

Receives data from a connected socket.

Overload List

Receives data from a connected socket into a specific location of the receive buffer.

[Visual Basic] Overloads Public Function Receive(Array, Integer, Integer, Integer) As Integer
[C#] public int Receive(Array, int, int, int);
[C++] public: int Receive(Array*, int, int, int);
[JScript] public function Receive(Array, int, int, int) : int;

Receives data from a connected socket.

[Visual Basic] Overloads Public Function Receive(Array, Integer, Integer) As Integer
[C#] public int Receive(Array, int, int);
[C++] public: int Receive(Array*, int, int);
[JScript] public function Receive(Array, int, int) : int;

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.Receive (Array, Int32, Int32, Int32)

Receives data from a connected socket into a specific location of the receive buffer.

[Visual Basic]
Overloads Public Function Receive( _
   ByVal buffer As Array, _
   ByVal index As Integer, _
   ByVal request As Integer, _
   ByVal flags As Integer _
) As Integer
[C#]
public int Receive(
   Array buffer,
   int index,
   int request,
   int flags
);
[C++]
public: int Receive(
   Array* buffer,
   int index,
   int request,
   int flags
);
[JScript]
public function Receive(
   buffer : Array,
   index : int,
   request : int,
   flags : int
) : int;

Parameters

buffer
Storage location for received data.
index
The location in buffer to store the received data.
request
The size of buffer.
flags
[To be supplied.]

Return Value

If successful, the number of bytes received. If unsuccessful, then if the socket was closed with Close, returns 0; otherwise, returns an invalid socket error.

Exceptions

Exception Type | Condition
InvalidOperationException | [To be supplied.]

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace | Socket.Receive Overload List


Socket.Receive (Array, Int32, Int32)

Receives data from a connected socket.

[Visual Basic]
Overloads Public Function Receive( _
   ByVal buffer As Array, _
   ByVal request As Integer, _
   ByVal flags As Integer _
) As Integer
[C#]
public int Receive(
   Array buffer,
   int request,
   int flags
);
[C++]
public: int Receive(
   Array* buffer,
   int request,
   int flags
);
[JScript]
public function Receive(
   buffer : Array,
   request : int,
   flags : int
) : int;

Parameters

buffer
Storage location for received data.
request
[To be supplied.]
flags
[To be supplied.]

Return Value

If successful, the number of bytes received. If unsuccessful, then if the socket was closed with Close, returns 0; otherwise, returns an invalid socket error.

Exceptions

Exception Type | Condition
InvalidOperationException | [To be supplied.]

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace | Socket.Receive Overload List


Socket.ReceiveFrom

Receives a datagram and stores the source end point.

Overload List

Receives a datagram into a specific location in the data buffer and stores the end point.

[Visual Basic] Overloads Public Function ReceiveFrom(Array, Integer, Integer, Integer, EndPoint) As Integer
[C#] public int ReceiveFrom(Array, int, int, int, EndPoint);
[C++] public: int ReceiveFrom(Array*, int, int, int, EndPoint);
[JScript] public function ReceiveFrom(Array, int, int, int, EndPoint) : int;

Receives a datagram and stores the source end point.

[Visual Basic] Overloads Public Function ReceiveFrom(Array, Integer, Integer, EndPoint) As Integer
[C#] public int ReceiveFrom(Array, int, int, EndPoint);
[C++] public: int ReceiveFrom(Array*, int, int, EndPoint);
[JScript] public function ReceiveFrom(Array, int, int, EndPoint) : int;

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.ReceiveFrom (Array, Int32, Int32, Int32, EndPoint)

Receives a datagram into a specific location in the data buffer and stores the end point.

[Visual Basic]
Overloads Public Function ReceiveFrom( _
   ByVal buffer As Array, _
   ByVal index As Integer, _
   ByVal request As Integer, _
   ByVal flags As Integer, _
   ByRef EP As EndPoint _
) As Integer
[C#]
public int ReceiveFrom(
   Array buffer,
   int index,
   int request,
   int flags,
   ref EndPoint EP
);
[C++]
public: int ReceiveFrom(
   Array* buffer,
   int index,
   int request,
   int flags,
   EndPoint** EP
);
[JScript]
public function ReceiveFrom(
   buffer : Array,
   index : int,
   request : int,
   flags : int,
   EP : EndPoint
) : int;

Parameters

buffer
Storage location for received data.
index
[To be supplied.]
request
[To be supplied.]
flags
[To be supplied.]
EP
[To be supplied.]

Return Value

If successful, the number of bytes received. If unsuccessful, then if the socket was closed with Close, returns 0; otherwise, returns an invalid socket error.

Exceptions

Exception Type | Condition
InvalidOperationException | [To be supplied.]

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace | Socket.ReceiveFrom Overload List


Socket.ReceiveFrom (Array, Int32, Int32, EndPoint)

Receives a datagram and stores the source end point.

[Visual Basic]
Overloads Public Function ReceiveFrom( _
   ByVal buffer As Array, _
   ByVal request As Integer, _
   ByVal flags As Integer, _
   ByRef EP As EndPoint _
) As Integer
[C#]
public int ReceiveFrom(
   Array buffer,
   int request,
   int flags,
   ref EndPoint EP
);
[C++]
public: int ReceiveFrom(
   Array* buffer,
   int request,
   int flags,
   EndPoint** EP
);
[JScript]
public function ReceiveFrom(
   buffer : Array,
   request : int,
   flags : int,
   EP : EndPoint
) : int;

Parameters

buffer
Storage location for received data.
request
The size of buffer.
flags
Message receive flags.
EP
The source end point.

Return Value

If successful, the number of bytes received. If unsuccessful, then if the socket was closed with Close, returns 0; otherwise, returns an invalid socket error.

Exceptions

Exception Type | Condition
InvalidOperationException | [To be supplied.]

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace | Socket.ReceiveFrom Overload List


Socket.Select

Determines the status of a socket.

[Visual Basic]
Public Shared Sub Select( _
   ByVal checkRead As IList, _
   ByVal checkWrite As IList, _
   ByVal checkError As IList, _
   ByVal microSeconds As Integer _
)
[C#]
public static void Select(
   IList checkRead,
   IList checkWrite,
   IList checkError,
   int microSeconds
);
[C++]
public: static void Select(
   IList* checkRead,
   IList* checkWrite,
   IList* checkError,
   int microSeconds
);
[JScript]
public static function Select(
   checkRead : IList,
   checkWrite : IList,
   checkError : IList,
   microSeconds : int
);

Parameters

checkRead
[To be supplied.]
checkWrite
[To be supplied.]
checkError
[To be supplied.]
microSeconds
[To be supplied.]

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.Send

Sends data to a connected socket.

Overload List

Sends data to a connected socket, starting at the indicated location in the data.

[Visual Basic] Overloads Public Function Send(Array, Integer, Integer, Integer) As Integer
[C#] public int Send(Array, int, int, int);
[C++] public: int Send(Array*, int, int, int);
[JScript] public function Send(Array, int, int, int) : int;

Sends a data buffer to a connected socket.

[Visual Basic] Overloads Public Function Send(Array, Integer, Integer) As Integer
[C#] public int Send(Array, int, int);
[C++] public: int Send(Array*, int, int);
[JScript] public function Send(Array, int, int) : int;

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.Send (Array, Int32, Int32, Int32)

Sends data to a connected socket, starting at the indicated location in the data.

[Visual Basic]
Overloads Public Function Send( _
   ByVal buffer As Array, _
   ByVal index As Integer, _
   ByVal size As Integer, _
   ByVal flags As Integer _
) As Integer
[C#]
public int Send(
   Array buffer,
   int index,
   int size,
   int flags
);
[C++]
public: int Send(
   Array* buffer,
   int index,
   int size,
   int flags
);
[JScript]
public function Send(
   buffer : Array,
   index : int,
   size : int,
   flags : int
) : int;

Parameters

buffer
The data to be sent.
index
[To be supplied.]
size
[To be supplied.]
flags
Message send flags.

Return Value

If successful, the number of bytes sent to the socket; otherwise, an invalid socket error is returned.

Exceptions

Exception Type | Condition
InvalidOperationException | [To be supplied.]

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace | Socket.Send Overload List


Socket.Send (Array, Int32, Int32)

Sends a data buffer to a connected socket.

[Visual Basic]
Overloads Public Function Send( _
   ByVal buffer As Array, _
   ByVal size As Integer, _
   ByVal flags As Integer _
) As Integer
[C#]
public int Send(
   Array buffer,
   int size,
   int flags
);
[C++]
public: int Send(
   Array* buffer,
   int size,
   int flags
);
[JScript]
public function Send(
   buffer : Array,
   size : int,
   flags : int
) : int;

Parameters

buffer
The data to be sent.
size
[To be supplied.]
flags
[To be supplied.]

Return Value

If successful, the number of bytes sent to the socket; otherwise, an invalid socket error is returned.

Exceptions

Exception Type | Condition
InvalidOperationException | [To be supplied.]

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace | Socket.Send Overload List


Socket.SendTo

Sends data to a specific end point.

Overload List

Sends data to a specific end point, starting at the indicated location in the data.

[Visual Basic] Overloads Public Function SendTo(Array, Integer, Integer, EndPoint) As Integer
[C#] public int SendTo(Array, int, int, EndPoint);
[C++] public: int SendTo(Array*, int, int, EndPoint);
[JScript] public function SendTo(Array, int, int, EndPoint) : int;

Sends data to a specific end point, starting at the indicated location in the data.

[Visual Basic] Overloads Public Function SendTo(Array, Integer, Integer, Integer, EndPoint) As Integer
[C#] public int SendTo(Array, int, int, int, EndPoint);
[C++] public: int SendTo(Array*, int, int, int, EndPoint);
[JScript] public function SendTo(Array, int, int, int, EndPoint) : int;

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.SendTo (Array, Int32, Int32, EndPoint)

Sends data to a specific end point, starting at the indicated location in the data.

[Visual Basic]
Overloads Public Function SendTo( _
   ByVal buffer As Array, _
   ByVal size As Integer, _
   ByVal flags As Integer, _
   ByVal remoteEP As EndPoint _
) As Integer
[C#]
public int SendTo(
   Array buffer,
   int size,
   int flags,
   EndPoint remoteEP
);
[C++]
public: int SendTo(
   Array* buffer,
   int size,
   int flags,
   EndPoint* remoteEP
);
[JScript]
public function SendTo(
   buffer : Array,
   size : int,
   flags : int,
   remoteEP : EndPoint
) : int;

Parameters

buffer
The data to be sent.
size
The size of the data buffer.
flags
Message send flags.
remoteEP
The destination location for the data.

Return Value

If successful, the number of bytes sent; otherwise, an invalid socket error is returned.

Exceptions

Exception Type | Condition
InvalidOperationException | [To be supplied.]

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace | Socket.SendTo Overload List


Socket.SendTo (Array, Int32, Int32, Int32, EndPoint)

Sends data to a specific end point, starting at the indicated location in the data.

[Visual Basic]
Overloads Public Function SendTo( _
   ByVal buffer As Array, _
   ByVal index As Integer, _
   ByVal size As Integer, _
   ByVal flags As Integer, _
   ByVal remoteEP As EndPoint _
) As Integer
[C#]
public int SendTo(
   Array buffer,
   int index,
   int size,
   int flags,
   EndPoint remoteEP
);
[C++]
public: int SendTo(
   Array* buffer,
   int index,
   int size,
   int flags,
   EndPoint* remoteEP
);
[JScript]
public function SendTo(
   buffer : Array,
   index : int,
   size : int,
   flags : int,
   remoteEP : EndPoint
) : int;

Parameters

buffer
The data to be sent.
index
The position in the data buffer to begin sending data.
size
The size of the data buffer.
flags
Message send flags.
remoteEP
[To be supplied.]

Return Value

If successful, the number of bytes sent; otherwise, an invalid socket error is returned.

Exceptions

Exception Type | Condition
InvalidOperationException | [To be supplied.]

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace | Socket.SendTo Overload List


Socket.SetSockOpt

Sets a socket option.

Overload List

Sets the specified option to the specified value.

[Visual Basic] Overloads Public Function SetSockOpt(Integer, Integer, Object) As Boolean
[C#] public bool SetSockOpt(int, int, Object);
[C++] public: bool SetSockOpt(int, int, Object);
[JScript] public function SetSockOpt(int, int, Object) : Boolean;

Sets the specified option to the specified value.

[Visual Basic] Overloads Public Function SetSockOpt(Integer, Integer, Integer) As Boolean
[C#] public bool SetSockOpt(int, int, int);
[C++] public: bool SetSockOpt(int, int, int);
[JScript] public function SetSockOpt(int, int, int) : Boolean;

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


Socket.SetSockOpt (Int32, Int32, Object)

Sets the specified option to the specified value.

[Visual Basic]
Overloads Public Function SetSockOpt( _
   ByVal optionLevel As Integer, _
   ByVal optionName As Integer, _
   ByVal optionValue As Object _
) As Boolean
[C#]
public bool SetSockOpt(
   int optionLevel,
   int optionName,
   object optionValue
);
[C++]
public: bool SetSockOpt(
   int optionLevel,
   int optionName,
   Object* optionValue
);
[JScript]
public function SetSockOpt(
   optionLevel : int,
   optionName : int,
   optionValue : Object
) : Boolean;

Parameters

optionLevel
The level at which the option is defined. Can be either OptionLevelIP or OptionLevelTCP
optionName
The name of the option to set. See the SocketOption class for the valid options.
optionValue
An instance of LingerOption or MulticastOption containing the value of the option.

Return Value

true if the option was successfully set; otherwise, returns false.

Exceptions

Exception Type | Condition
ArgumentException | The object specified by optionValue is not an instance of LingerOption or MulticastOption.

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace | Socket.SetSockOpt Overload List


Socket.SetSockOpt (Int32, Int32, Int32)

Sets the specified option to the specified value.

[Visual Basic]
Overloads Public Function SetSockOpt( _
   ByVal optionLevel As Integer, _
   ByVal optionName As Integer, _
   ByVal optionValue As Integer _
) As Boolean
[C#]
public bool SetSockOpt(
   int optionLevel,
   int optionName,
   int optionValue
);
[C++]
public: bool SetSockOpt(
   int optionLevel,
   int optionName,
   int optionValue
);
[JScript]
public function SetSockOpt(
   optionLevel : int,
   optionName : int,
   optionValue : int
) : Boolean;

Parameters

optionLevel
The level at which the option is defined. Can be either OptionLevelIP or OptionLevelTCP
optionName
[To be supplied.]
optionValue
[To be supplied.]

Return Value

true if the option was successfully set; otherwise, returns false.

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace | Socket.SetSockOpt Overload List | SocketOption


Socket.Shutdown

Disables sends and receives on a socket.

[Visual Basic]
Public Function Shutdown( _
   ByVal how As Integer _
) As Integer
[C#]
public int Shutdown(
   int how
);
[C++]
public: int Shutdown(
   int how
);
[JScript]
public function Shutdown(
   how : int
) : int;

Parameters

how
The function that will no longer be allowed.

Return Value

0 if the socket was successfully disabled; otherwise, returns an non-zero error code.

Remarks

The SocketShutdown class contains the valid values for how. The valid values are:

Value | Description
sdSend | Disable sending on this socket.
sdReceive | Disable receiving on this socket.
sdBoth | Disable both sending and receiving on this socket.

If how is set to SdSend, subsequent calls to Send are not allowed. For TCP sockets a FIN will be sent after all data is sent and acknowledged by the receiver.

If how is set to SdReceive, susequent calls to Receive are not allowed. This has no effect on lower protocol layers. For TCP sockets the connection is reset if there is data waiting to be received or if more data arrives after the socket is disabled. For UDP sockets, datagrams are accepted and queued.

Setting how to SdBoth disables both sends and receives as described above.

A call to Close must be made after the call to Shutdown to finish closing the socket. You should not attempt to reuse the socket.

Example [C#]

If there is a problem disabling the socket, Shutdown will return a non-zero value indicating the error. The following code attempts to disable a socket. If the attempt is unsuccessful, the error code is written to the console.

[C#]

result = aSocket.Shutdown
if (result <> 0)
{
   Console.WriteLine("Winsock error: " + Convert.ToString(Marshal.GetLastWin32Error()) );

}

See Also

Socket Class | Socket Members | System.Net.Sockets Namespace


SocketErrors Class

Defines socket error constants.

Object
SocketErrors

[Visual Basic]
Public Class SocketErrors
[C#]
public class SocketErrors
[C++]
public __gc class SocketErrors
[JScript]
public class SocketErrors

Remarks

[To be supplied.]

Requirements

Namespace: System.Net.Sockets

Assembly: System.net.dll

See Also

SocketErrors Members | System.Net.Sockets Namespace


SocketErrors Members

Public:

Constructor

SocketErrors Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

HOST_NOT_FOUND | Host not found.
NO_ADDRESS | [To be supplied.]
NO_DATA | Valid name, no data record of requested type.
NO_RECOVERY | This is a nonrecoverable error.
TRY_AGAIN | Nonauthoritative host not found.
WSABASEERR | The base value of all socket error constants. All other socket errors are offset from this value.
WSAEACCES | Permission denied.
WSAEADDRINUSE | Address already in use.
WSAEADDRNOTAVAIL | Cannot assign requested address.
WSAEAFNOSUPPORT | Address family not supported by protocol family.
WSAEALREADY | Operation already in progress.
WSAEBADF | [To be supplied.]
WSAECONNABORTED | Software caused connection to abort.
WSAECONNREFUSED | Connection refused.
WSAECONNRESET | Connection reset by peer.
WSAEDESTADDRREQ | Destination address required.
WSAEDISCON | Graceful shutdown in progress.
WSAEDQUOT | [To be supplied.]
WSAEFAULT | Bad address.
WSAEHOSTDOWN | Host is down.
WSAEHOSTUNREACH | No route to host.
WSAEINPROGRESS | Operation now in progress.
WSAEINTR | A blocking socket call was canceled.
WSAEINVAL | Invalid argument.
WSAEISCONN | Socket is already connected.
WSAELOOP | [To be supplied.]
WSAEMFILE | Too many open files.
WSAEMSGSIZE | Message too long.
WSAENAMETOOLONG | [To be supplied.]
WSAENETDOWN | Network is down.
WSAENETRESET | Network dropped connection on reset.
WSAENETUNREACH | Network is unreachable.
WSAENOBUFS | No buffer space available.
WSAENOPROTOOPT | Bad protocol option.
WSAENOTCONN | Socket is not connected.
WSAENOTEMPTY | [To be supplied.]
WSAENOTSOCK | Socket operation on nonsocket.
WSAEOPNOTSUPP | Operation not supported.
WSAEPFNOSUPPORT | Protocol family not supported.
WSAEPROCLIM | Too many processes.
WSAEPROTONOSUPPORT | Protocol not supported.
WSAEPROTOTYPE | Protocol wrong type for socket.
WSAEREMOTE | [To be supplied.]
WSAESHUTDOWN | Cannot send after socket shutdown.
WSAESOCKTNOSUPPORT | Socket type not supported.
WSAESTALE | [To be supplied.]
WSAETIMEDOUT | Connection timed out.
WSAETOOMANYREFS | [To be supplied.]
WSAEUSERS | [To be supplied.]
WSAEWOULDBLOCK | Resource temporarily unavailable.
WSAHOST_NOT_FOUND | Host not found.
WSANOTINITIALISED | Successful startup not yet performed.
WSANO_ADDRESS | [To be supplied.]
WSANO_DATA | Valid name, no data record of requested type.
WSANO_RECOVERY | This is a nonrecoverable error.
WSASYSNOTREADY | Network subsystem is unavailable.
WSATRY_AGAIN | Nonauthoritative host not found.
WSAVERNOTSUPPORTED | Winsock.dll out of range.
WSA_IO_PENDING | Overlapped operations will complete later.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SocketErrors Class | System.Net.Sockets Namespace


SocketErrors Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public SocketErrors();
[C++]
public: SocketErrors();
[JScript]
public function SocketErrors();

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SocketErrors Fields

The fields of the SocketErrors class are listed below. For a complete list of SocketErrors class members, see the SocketErrors Members topic.

Public:

HOST_NOT_FOUND | Host not found.
NO_ADDRESS | [To be supplied.]
NO_DATA | Valid name, no data record of requested type.
NO_RECOVERY | This is a nonrecoverable error.
TRY_AGAIN | Nonauthoritative host not found.
WSABASEERR | The base value of all socket error constants. All other socket errors are offset from this value.
WSAEACCES | Permission denied.
WSAEADDRINUSE | Address already in use.
WSAEADDRNOTAVAIL | Cannot assign requested address.
WSAEAFNOSUPPORT | Address family not supported by protocol family.
WSAEALREADY | Operation already in progress.
WSAEBADF | [To be supplied.]
WSAECONNABORTED | Software caused connection to abort.
WSAECONNREFUSED | Connection refused.
WSAECONNRESET | Connection reset by peer.
WSAEDESTADDRREQ | Destination address required.
WSAEDISCON | Graceful shutdown in progress.
WSAEDQUOT | [To be supplied.]
WSAEFAULT | Bad address.
WSAEHOSTDOWN | Host is down.
WSAEHOSTUNREACH | No route to host.
WSAEINPROGRESS | Operation now in progress.
WSAEINTR | A blocking socket call was canceled.
WSAEINVAL | Invalid argument.
WSAEISCONN | Socket is already connected.
WSAELOOP | [To be supplied.]
WSAEMFILE | Too many open files.
WSAEMSGSIZE | Message too long.
WSAENAMETOOLONG | [To be supplied.]
WSAENETDOWN | Network is down.
WSAENETRESET | Network dropped connection on reset.
WSAENETUNREACH | Network is unreachable.
WSAENOBUFS | No buffer space available.
WSAENOPROTOOPT | Bad protocol option.
WSAENOTCONN | Socket is not connected.
WSAENOTEMPTY | [To be supplied.]
WSAENOTSOCK | Socket operation on nonsocket.
WSAEOPNOTSUPP | Operation not supported.
WSAEPFNOSUPPORT | Protocol family not supported.
WSAEPROCLIM | Too many processes.
WSAEPROTONOSUPPORT | Protocol not supported.
WSAEPROTOTYPE | Protocol wrong type for socket.
WSAEREMOTE | [To be supplied.]
WSAESHUTDOWN | Cannot send after socket shutdown.
WSAESOCKTNOSUPPORT | Socket type not supported.
WSAESTALE | [To be supplied.]
WSAETIMEDOUT | Connection timed out.
WSAETOOMANYREFS | [To be supplied.]
WSAEUSERS | [To be supplied.]
WSAEWOULDBLOCK | Resource temporarily unavailable.
WSAHOST_NOT_FOUND | Host not found.
WSANOTINITIALISED | Successful startup not yet performed.
WSANO_ADDRESS | [To be supplied.]
WSANO_DATA | Valid name, no data record of requested type.
WSANO_RECOVERY | This is a nonrecoverable error.
WSASYSNOTREADY | Network subsystem is unavailable.
WSATRY_AGAIN | Nonauthoritative host not found.
WSAVERNOTSUPPORTED | Winsock.dll out of range.
WSA_IO_PENDING | Overlapped operations will complete later.

See Also

SocketErrors Class | System.Net.Sockets Namespace


SocketErrors.HOST_NOT_FOUND

Host not found.

[Visual Basic]
Public Const HOST_NOT_FOUND As Integer
[C#]
public const int HOST_NOT_FOUND;
[C++]
public: const int HOST_NOT_FOUND;
[JScript]
public var HOST_NOT_FOUND : int;

Remarks

No such host is known. The name is not an official host name or alias, or it cannot be found in the database(s) being queried.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.NO_ADDRESS

[To be supplied.]

[Visual Basic]
Public Const NO_ADDRESS As Integer
[C#]
public const int NO_ADDRESS;
[C++]
public: const int NO_ADDRESS;
[JScript]
public var NO_ADDRESS : int;

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.NO_DATA

Valid name, no data record of requested type.

[Visual Basic]
Public Const NO_DATA As Integer
[C#]
public const int NO_DATA;
[C++]
public: const int NO_DATA;
[JScript]
public var NO_DATA : int;

Remarks

The requested name is valid and was found in the database, but it does not have the correct associated data being resolved for. The usual wxample for this is a hot name-to-address translation attempt which uses the Domain Name System (DNS). An MX record is returned by no A record-- indicating the host exists, but is not directly reachable.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.NO_RECOVERY

This is a nonrecoverable error.

[Visual Basic]
Public Const NO_RECOVERY As Integer
[C#]
public const int NO_RECOVERY;
[C++]
public: const int NO_RECOVERY;
[JScript]
public var NO_RECOVERY : int;

Remarks

This indicates that some sort of nonrecoverable error occurred during a database lookup. This may be because the database files (for example, BSD-compatible HOSTS, SERVICES, or PROTOCOLS files) could not be found, or a DNS request was returned with a severe error.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.TRY_AGAIN

Nonauthoritative host not found.

[Visual Basic]
Public Const TRY_AGAIN As Integer
[C#]
public const int TRY_AGAIN;
[C++]
public: const int TRY_AGAIN;
[JScript]
public var TRY_AGAIN : int;

Remarks

This is usually a temporary error during host name resolution and means that the local server did not receive a response from an authoritative server. A retry at some later time may be successful.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSABASEERR

The base value of all socket error constants. All other socket errors are offset from this value.

[Visual Basic]
Public Const WSABASEERR As Integer
[C#]
public const int WSABASEERR;
[C++]
public: const int WSABASEERR;
[JScript]
public var WSABASEERR : int;

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAEACCES

Permission denied.

[Visual Basic]
Public Const WSAEACCES As Integer
[C#]
public const int WSAEACCES;
[C++]
public: const int WSAEACCES;
[JScript]
public var WSAEACCES : int;

Remarks

An attempt was made to access a socket in a way that is forbidden by its access permissions, for example by using a socket for a broadcast without setting the System.Net.Sockets.SocketOptions.SoBroadcast option.

This error is also returned if an attempt is made to Bind to an address that has the System.Net.Sockets.SocketOptions.SoExclusiveAddrUse option set.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAEADDRINUSE

Address already in use.

[Visual Basic]
Public Const WSAEADDRINUSE As Integer
[C#]
public const int WSAEADDRINUSE;
[C++]
public: const int WSAEADDRINUSE;
[JScript]
public var WSAEADDRINUSE : int;

Remarks

A process on the machine is already bound to the fully-qualified address and the socket has not been marked for address reuse with SoReuseAddr.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAEADDRNOTAVAIL

Cannot assign requested address.

[Visual Basic]
Public Const WSAEADDRNOTAVAIL As Integer
[C#]
public const int WSAEADDRNOTAVAIL;
[C++]
public: const int WSAEADDRNOTAVAIL;
[JScript]
public var WSAEADDRNOTAVAIL : int;

Remarks

The requested address is not valid in its context. Either an attempt was made to bind to an invalid address on the local machine, or to connect to an invalid port on a remote machine.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAEAFNOSUPPORT

Address family not supported by protocol family.

[Visual Basic]
Public Const WSAEAFNOSUPPORT As Integer
[C#]
public const int WSAEAFNOSUPPORT;
[C++]
public: const int WSAEAFNOSUPPORT;
[JScript]
public var WSAEAFNOSUPPORT : int;

Remarks

An address incompatible with the requested protocol was used. All sockets are created with an associated address family and a generic protocol type. This error is returned if an incorrect protocol is requested when creating a socket, or in an address of the wrong family is uses when sending data.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAEALREADY

Operation already in progress.

[Visual Basic]
Public Const WSAEALREADY As Integer
[C#]
public const int WSAEALREADY;
[C++]
public: const int WSAEALREADY;
[JScript]
public var WSAEALREADY : int;

Remarks

An operation was attempted on a non-blocking socket with an operation already in process, such as calling Connect a second time on a non-blocking socket that is already connecting or canceling an asynchronous request that has already completed or been canceled.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAEBADF

[To be supplied.]

[Visual Basic]
Public Const WSAEBADF As Integer
[C#]
public const int WSAEBADF;
[C++]
public: const int WSAEBADF;
[JScript]
public var WSAEBADF : int;

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAECONNABORTED

Software caused connection to abort.

[Visual Basic]
Public Const WSAECONNABORTED As Integer
[C#]
public const int WSAECONNABORTED;
[C++]
public: const int WSAECONNABORTED;
[JScript]
public var WSAECONNABORTED : int;

Remarks

An established connection was aborted by the software in your host machine, possibly due to a data transmission timeout or protocol error.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAECONNREFUSED

Connection refused.

[Visual Basic]
Public Const WSAECONNREFUSED As Integer
[C#]
public const int WSAECONNREFUSED;
[C++]
public: const int WSAECONNREFUSED;
[JScript]
public var WSAECONNREFUSED : int;

Remarks

No connection could be made because the target machine refused it. This usually results from trying to connect to a service that is inactive on the target host-- that is one with no server application running.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAECONNRESET

Connection reset by peer.

[Visual Basic]
Public Const WSAECONNRESET As Integer
[C#]
public const int WSAECONNRESET;
[C++]
public: const int WSAECONNRESET;
[JScript]
public var WSAECONNRESET : int;

Remarks

An existing connection was closed by the remote host. This normally results when server application on the remote host is suddenly stopped, the host is rebooted, or the remote host uses a hard close.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAEDESTADDRREQ

Destination address required.

[Visual Basic]
Public Const WSAEDESTADDRREQ As Integer
[C#]
public const int WSAEDESTADDRREQ;
[C++]
public: const int WSAEDESTADDRREQ;
[JScript]
public var WSAEDESTADDRREQ : int;

Remarks

A required address was omitted from an operation on a socket.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAEDISCON

Graceful shutdown in progress.

[Visual Basic]
Public Const WSAEDISCON As Integer
[C#]
public const int WSAEDISCON;
[C++]
public: const int WSAEDISCON;
[JScript]
public var WSAEDISCON : int;

Remarks

Returned by Receive and ReceiveFrom to indicate that the remote host has initiated a graceful shutdown sequence.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAEDQUOT

[To be supplied.]

[Visual Basic]
Public Const WSAEDQUOT As Integer
[C#]
public const int WSAEDQUOT;
[C++]
public: const int WSAEDQUOT;
[JScript]
public var WSAEDQUOT : int;

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAEFAULT

Bad address.

[Visual Basic]
Public Const WSAEFAULT As Integer
[C#]
public const int WSAEFAULT;
[C++]
public: const int WSAEFAULT;
[JScript]
public var WSAEFAULT : int;

Remarks

The system detected a bad pointer address in attempting to use a pointer argument of a call. This error occurs if an application passes an invalid pointer value, or if the buffer is too small.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAEHOSTDOWN

Host is down.

[Visual Basic]
Public Const WSAEHOSTDOWN As Integer
[C#]
public const int WSAEHOSTDOWN;
[C++]
public: const int WSAEHOSTDOWN;
[JScript]
public var WSAEHOSTDOWN : int;

Remarks

A socket operation failed because the destination host is down, because the operation encountered a dead host, or because networking activity on the local host has not been initiated.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAEHOSTUNREACH

No route to host.

[Visual Basic]
Public Const WSAEHOSTUNREACH As Integer
[C#]
public const int WSAEHOSTUNREACH;
[C++]
public: const int WSAEHOSTUNREACH;
[JScript]
public var WSAEHOSTUNREACH : int;

Remarks

A socket operation was attempted to an unreachable host. This usually occurs when the local software knows no route to reach the remote host.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAEINPROGRESS

Operation now in progress.

[Visual Basic]
Public Const WSAEINPROGRESS As Integer
[C#]
public const int WSAEINPROGRESS;
[C++]
public: const int WSAEINPROGRESS;
[JScript]
public var WSAEINPROGRESS : int;

Remarks

A blocking call is being processed, or the service provider is still processing a callback function. Only one blocking call can be made at any time.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAEINTR

A blocking socket call was canceled.

[Visual Basic]
Public Const WSAEINTR As Integer
[C#]
public const int WSAEINTR;
[C++]
public: const int WSAEINTR;
[JScript]
public var WSAEINTR : int;

Remarks

A blocking operation was interrupted.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAEINVAL

Invalid argument.

[Visual Basic]
Public Const WSAEINVAL As Integer
[C#]
public const int WSAEINVAL;
[C++]
public: const int WSAEINVAL;
[JScript]
public var WSAEINVAL : int;

Remarks

Some invalid argument was supplied. In some instances, it also refers to the state of the socket, for instance, calling Accept on a socket that is not listening.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAEISCONN

Socket is already connected.

[Visual Basic]
Public Const WSAEISCONN As Integer
[C#]
public const int WSAEISCONN;
[C++]
public: const int WSAEISCONN;
[JScript]
public var WSAEISCONN : int;

Remarks

A Connect request was made to an already connected socket.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAELOOP

[To be supplied.]

[Visual Basic]
Public Const WSAELOOP As Integer
[C#]
public const int WSAELOOP;
[C++]
public: const int WSAELOOP;
[JScript]
public var WSAELOOP : int;

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAEMFILE

Too many open files.

[Visual Basic]
Public Const WSAEMFILE As Integer
[C#]
public const int WSAEMFILE;
[C++]
public: const int WSAEMFILE;
[JScript]
public var WSAEMFILE : int;

Remarks

Too many open sockets.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAEMSGSIZE

Message too long.

[Visual Basic]
Public Const WSAEMSGSIZE As Integer
[C#]
public const int WSAEMSGSIZE;
[C++]
public: const int WSAEMSGSIZE;
[JScript]
public var WSAEMSGSIZE : int;

Remarks

A message sent on a datagram socket was larger than the internal message buffer or some other network limit, or the buffer used to receive a datagram was smaller than the datagram itself.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAENAMETOOLONG

[To be supplied.]

[Visual Basic]
Public Const WSAENAMETOOLONG As Integer
[C#]
public const int WSAENAMETOOLONG;
[C++]
public: const int WSAENAMETOOLONG;
[JScript]
public var WSAENAMETOOLONG : int;

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAENETDOWN

Network is down.

[Visual Basic]
Public Const WSAENETDOWN As Integer
[C#]
public const int WSAENETDOWN;
[C++]
public: const int WSAENETDOWN;
[JScript]
public var WSAENETDOWN : int;

Remarks

A socket operation has encountered a dead network. This could indicate a serious failure of the network system, the network interface, or the local network itself.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAENETRESET

Network dropped connection on reset.

[Visual Basic]
Public Const WSAENETRESET As Integer
[C#]
public const int WSAENETRESET;
[C++]
public: const int WSAENETRESET;
[JScript]
public var WSAENETRESET : int;

Remarks

The connection has been broken due to keep-alive activity detecting a failure while the operation was in progress. It can also be returned if an attempt is made to set System.Net.Sockets.SocketOption.SoKeepAlive on a connection that has already failed.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAENETUNREACH

Network is unreachable.

[Visual Basic]
Public Const WSAENETUNREACH As Integer
[C#]
public const int WSAENETUNREACH;
[C++]
public: const int WSAENETUNREACH;
[JScript]
public var WSAENETUNREACH : int;

Remarks

A socket operation was attempted to an unreachable network. This usually occurs when the local software knows no route to reach the remote network.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAENOBUFS

No buffer space available.

[Visual Basic]
Public Const WSAENOBUFS As Integer
[C#]
public const int WSAENOBUFS;
[C++]
public: const int WSAENOBUFS;
[JScript]
public var WSAENOBUFS : int;

Remarks

An operation on a socket could not be perfomred because the system lacked sufficient buffer space or because a queue was full.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAENOPROTOOPT

Bad protocol option.

[Visual Basic]
Public Const WSAENOPROTOOPT As Integer
[C#]
public const int WSAENOPROTOOPT;
[C++]
public: const int WSAENOPROTOOPT;
[JScript]
public var WSAENOPROTOOPT : int;

Remarks

An unknown, invalid, or unsupported option or protocol level was specified in a GetSockOpt or SetSockOpt call.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAENOTCONN

Socket is not connected.

[Visual Basic]
Public Const WSAENOTCONN As Integer
[C#]
public const int WSAENOTCONN;
[C++]
public: const int WSAENOTCONN;
[JScript]
public var WSAENOTCONN : int;

Remarks

A request to send or receive data was disallowed because the socket is not connected and (when using SendTo) no address was supplied.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAENOTEMPTY

[To be supplied.]

[Visual Basic]
Public Const WSAENOTEMPTY As Integer
[C#]
public const int WSAENOTEMPTY;
[C++]
public: const int WSAENOTEMPTY;
[JScript]
public var WSAENOTEMPTY : int;

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAENOTSOCK

Socket operation on nonsocket.

[Visual Basic]
Public Const WSAENOTSOCK As Integer
[C#]
public const int WSAENOTSOCK;
[C++]
public: const int WSAENOTSOCK;
[JScript]
public var WSAENOTSOCK : int;

Remarks

An operation was attempted on something that is not a socket. Either the socket handle parameter did not reference a valid socket, or a member of an IList member was not valid in a Select call.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAEOPNOTSUPP

Operation not supported.

[Visual Basic]
Public Const WSAEOPNOTSUPP As Integer
[C#]
public const int WSAEOPNOTSUPP;
[C++]
public: const int WSAEOPNOTSUPP;
[JScript]
public var WSAEOPNOTSUPP : int;

Remarks

The attempted operation is not supported by the type of socket referenced. This usually happens when the socket does not support connection-oriented service.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAEPFNOSUPPORT

Protocol family not supported.

[Visual Basic]
Public Const WSAEPFNOSUPPORT As Integer
[C#]
public const int WSAEPFNOSUPPORT;
[C++]
public: const int WSAEPFNOSUPPORT;
[JScript]
public var WSAEPFNOSUPPORT : int;

Remarks

The protocol family has not been configured into the system or no implementation for it exists.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAEPROCLIM

Too many processes.

[Visual Basic]
Public Const WSAEPROCLIM As Integer
[C#]
public const int WSAEPROCLIM;
[C++]
public: const int WSAEPROCLIM;
[JScript]
public var WSAEPROCLIM : int;

Remarks

A socket implementation may have a limit o the number of applications that can use it simultaneously. This error is returned when that limit is reached.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAEPROTONOSUPPORT

Protocol not supported.

[Visual Basic]
Public Const WSAEPROTONOSUPPORT As Integer
[C#]
public const int WSAEPROTONOSUPPORT;
[C++]
public: const int WSAEPROTONOSUPPORT;
[JScript]
public var WSAEPROTONOSUPPORT : int;

Remarks

The requested protocol has not been configured into the system, or no implementation for it exists.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAEPROTOTYPE

Protocol wrong type for socket.

[Visual Basic]
Public Const WSAEPROTOTYPE As Integer
[C#]
public const int WSAEPROTOTYPE;
[C++]
public: const int WSAEPROTOTYPE;
[JScript]
public var WSAEPROTOTYPE : int;

Remarks

A protocol was specified in the Socket constructor that does not support the semantics of the socket type requested.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAEREMOTE

[To be supplied.]

[Visual Basic]
Public Const WSAEREMOTE As Integer
[C#]
public const int WSAEREMOTE;
[C++]
public: const int WSAEREMOTE;
[JScript]
public var WSAEREMOTE : int;

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAESHUTDOWN

Cannot send after socket shutdown.

[Visual Basic]
Public Const WSAESHUTDOWN As Integer
[C#]
public const int WSAESHUTDOWN;
[C++]
public: const int WSAESHUTDOWN;
[JScript]
public var WSAESHUTDOWN : int;

Remarks

A request to send or receive data was disallowed because the socket had already been shut down in that direction with a previous Shutdown call.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAESOCKTNOSUPPORT

Socket type not supported.

[Visual Basic]
Public Const WSAESOCKTNOSUPPORT As Integer
[C#]
public const int WSAESOCKTNOSUPPORT;
[C++]
public: const int WSAESOCKTNOSUPPORT;
[JScript]
public var WSAESOCKTNOSUPPORT : int;

Remarks

The support for the specified socket type does not exist in this address family.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAESTALE

[To be supplied.]

[Visual Basic]
Public Const WSAESTALE As Integer
[C#]
public const int WSAESTALE;
[C++]
public: const int WSAESTALE;
[JScript]
public var WSAESTALE : int;

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAETIMEDOUT

Connection timed out.

[Visual Basic]
Public Const WSAETIMEDOUT As Integer
[C#]
public const int WSAETIMEDOUT;
[C++]
public: const int WSAETIMEDOUT;
[JScript]
public var WSAETIMEDOUT : int;

Remarks

A connection attempt failed because the remote host did not properly respond after a period of time, or the establish connection failed because the connected host failed to respond.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAETOOMANYREFS

[To be supplied.]

[Visual Basic]
Public Const WSAETOOMANYREFS As Integer
[C#]
public const int WSAETOOMANYREFS;
[C++]
public: const int WSAETOOMANYREFS;
[JScript]
public var WSAETOOMANYREFS : int;

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAEUSERS

[To be supplied.]

[Visual Basic]
Public Const WSAEUSERS As Integer
[C#]
public const int WSAEUSERS;
[C++]
public: const int WSAEUSERS;
[JScript]
public var WSAEUSERS : int;

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAEWOULDBLOCK

Resource temporarily unavailable.

[Visual Basic]
Public Const WSAEWOULDBLOCK As Integer
[C#]
public const int WSAEWOULDBLOCK;
[C++]
public: const int WSAEWOULDBLOCK;
[JScript]
public var WSAEWOULDBLOCK : int;

Remarks

This error is returned from operatons on non-blocking sockets that cannot be completed immediately, for example Receive when no data is queued to be read from the socket. It is a non-fatal error, and the operation should be retried later.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAHOST_NOT_FOUND

Host not found.

[Visual Basic]
Public Const WSAHOST_NOT_FOUND As Integer
[C#]
public const int WSAHOST_NOT_FOUND;
[C++]
public: const int WSAHOST_NOT_FOUND;
[JScript]
public var WSAHOST_NOT_FOUND : int;

Remarks

No such host is known. The name is not an official host name or alias, or it cannot be found in the database(s) being queried.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSANOTINITIALISED

Successful startup not yet performed.

[Visual Basic]
Public Const WSANOTINITIALISED As Integer
[C#]
public const int WSANOTINITIALISED;
[C++]
public: const int WSANOTINITIALISED;
[JScript]
public var WSANOTINITIALISED : int;

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSANO_ADDRESS

[To be supplied.]

[Visual Basic]
Public Const WSANO_ADDRESS As Integer
[C#]
public const int WSANO_ADDRESS;
[C++]
public: const int WSANO_ADDRESS;
[JScript]
public var WSANO_ADDRESS : int;

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSANO_DATA

Valid name, no data record of requested type.

[Visual Basic]
Public Const WSANO_DATA As Integer
[C#]
public const int WSANO_DATA;
[C++]
public: const int WSANO_DATA;
[JScript]
public var WSANO_DATA : int;

Remarks

The requested name is valid and was found in the database, but it does not have the correct associated data being resolved for. The usual wxample for this is a hot name-to-address translation attempt which uses the Domain Name System (DNS). An MX record is returned by no A record-- indicating the host exists, but is not directly reachable.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSANO_RECOVERY

This is a nonrecoverable error.

[Visual Basic]
Public Const WSANO_RECOVERY As Integer
[C#]
public const int WSANO_RECOVERY;
[C++]
public: const int WSANO_RECOVERY;
[JScript]
public var WSANO_RECOVERY : int;

Remarks

This indicates that some sort of nonrecoverable error occurred during a database lookup. This may be because the database files (for example, BSD-compatible HOSTS, SERVICES, or PROTOCOLS files) could not be found, or a DNS request was returned with a severe error.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSASYSNOTREADY

Network subsystem is unavailable.

[Visual Basic]
Public Const WSASYSNOTREADY As Integer
[C#]
public const int WSASYSNOTREADY;
[C++]
public: const int WSASYSNOTREADY;
[JScript]
public var WSASYSNOTREADY : int;

Remarks

This error is returned in the Windows Socket implementation cannot function at this time because the underlying system it uses to provide network services is unavailable.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSATRY_AGAIN

Nonauthoritative host not found.

[Visual Basic]
Public Const WSATRY_AGAIN As Integer
[C#]
public const int WSATRY_AGAIN;
[C++]
public: const int WSATRY_AGAIN;
[JScript]
public var WSATRY_AGAIN : int;

Remarks

This is usually a temporary error during host name resolution and means that the local server did not receive a response from an authoritative server. A retry at some later time may be successful.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSAVERNOTSUPPORTED

Winsock.dll out of range.

[Visual Basic]
Public Const WSAVERNOTSUPPORTED As Integer
[C#]
public const int WSAVERNOTSUPPORTED;
[C++]
public: const int WSAVERNOTSUPPORTED;
[JScript]
public var WSAVERNOTSUPPORTED : int;

Remarks

The current Windows Sockets implementation does not support the Windows Sockets specification version requested by the application.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketErrors.WSA_IO_PENDING

Overlapped operations will complete later.

[Visual Basic]
Public Const WSA_IO_PENDING As Integer
[C#]
public const int WSA_IO_PENDING;
[C++]
public: const int WSA_IO_PENDING;
[JScript]
public var WSA_IO_PENDING : int;

Remarks

The application has initiated an overlapped operation that cannot be completed immediately. A completion indication will be given later when the operation has been completed.

See Also

SocketErrors Class | SocketErrors Members | System.Net.Sockets Namespace


SocketMsgFlags Class

Provides constant values for socket messages.

Object
SocketMsgFlags

[Visual Basic]
Public Class SocketMsgFlags
[C#]
public class SocketMsgFlags
[C++]
public __gc class SocketMsgFlags
[JScript]
public class SocketMsgFlags

Remarks

[To be supplied.]

Requirements

Namespace: System.Net.Sockets

Assembly: System.net.dll

See Also

SocketMsgFlags Members | System.Net.Sockets Namespace


SocketMsgFlags Members

Public:

Constructor

SocketMsgFlags Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

MsgDontRoute | Send without using routing tables.
MsgMaxOviLen | [To be supplied.]
MsgOOB | Process out-of-band data.
MsgPartial | [To be supplied.]
MsgPeek | Peek at incoming message.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SocketMsgFlags Class | System.Net.Sockets Namespace


SocketMsgFlags Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public SocketMsgFlags();
[C++]
public: SocketMsgFlags();
[JScript]
public function SocketMsgFlags();

See Also

SocketMsgFlags Class | SocketMsgFlags Members | System.Net.Sockets Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SocketMsgFlags Fields

The fields of the SocketMsgFlags class are listed below. For a complete list of SocketMsgFlags class members, see the SocketMsgFlags Members topic.

Public:

MsgDontRoute | Send without using routing tables.
MsgMaxOviLen | [To be supplied.]
MsgOOB | Process out-of-band data.
MsgPartial | [To be supplied.]
MsgPeek | Peek at incoming message.

See Also

SocketMsgFlags Class | System.Net.Sockets Namespace


SocketMsgFlags.MsgDontRoute

Send without using routing tables.

[Visual Basic]
Public Const MsgDontRoute As Integer
[C#]
public const int MsgDontRoute;
[C++]
public: const int MsgDontRoute;
[JScript]
public var MsgDontRoute : int;

See Also

SocketMsgFlags Class | SocketMsgFlags Members | System.Net.Sockets Namespace


SocketMsgFlags.MsgMaxOviLen

[To be supplied.]

[Visual Basic]
Public Const MsgMaxOviLen As Integer
[C#]
public const int MsgMaxOviLen;
[C++]
public: const int MsgMaxOviLen;
[JScript]
public var MsgMaxOviLen : int;

See Also

SocketMsgFlags Class | SocketMsgFlags Members | System.Net.Sockets Namespace


SocketMsgFlags.MsgOOB

Process out-of-band data.

[Visual Basic]
Public Const MsgOOB As Integer
[C#]
public const int MsgOOB;
[C++]
public: const int MsgOOB;
[JScript]
public var MsgOOB : int;

See Also

SocketMsgFlags Class | SocketMsgFlags Members | System.Net.Sockets Namespace


SocketMsgFlags.MsgPartial

[To be supplied.]

[Visual Basic]
Public Const MsgPartial As Integer
[C#]
public const int MsgPartial;
[C++]
public: const int MsgPartial;
[JScript]
public var MsgPartial : int;

See Also

SocketMsgFlags Class | SocketMsgFlags Members | System.Net.Sockets Namespace


SocketMsgFlags.MsgPeek

Peek at incoming message.

[Visual Basic]
Public Const MsgPeek As Integer
[C#]
public const int MsgPeek;
[C++]
public: const int MsgPeek;
[JScript]
public var MsgPeek : int;

See Also

SocketMsgFlags Class | SocketMsgFlags Members | System.Net.Sockets Namespace


SocketOption Class

Defines socket options for the Socket class.

Object
SocketOption

[Visual Basic]
Public Class SocketOption
[C#]
public class SocketOption
[C++]
public __gc class SocketOption
[JScript]
public class SocketOption

Remarks

[To be supplied.]

Requirements

Namespace: System.Net.Sockets

Assembly: System.net.dll

See Also

SocketOption Members | System.Net.Sockets Namespace


SocketOption Members

Public:

Constructor

SocketOption Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

IpAddMembership | Add an IP group membership.
IpDropMembership | Drop an IP group membership.
IpMulticastLoop | IP Multicast loopback.
IpMulticastTTL | IP multicast time to live.
OptionLevelIP | Indicates socket options apply to IP sockets.
OptionLevelTCP | Indicates socket options apply to TCP sockets.
SoAcceptConn | Socket is listening.
SoBroadcast | Permit sending broadcast messages on the socket.
SoDebug | Record debugging information.
SoDontLingee | Does not block waiting for unsent data to be sent.
SoDontRoute | Do not route, send directly to interface addresses.
SoError | Get error status and clear.
SoExclusiveAddrUse | Enables a socket to be bound for exclusive access.
SoKeepalive | Send keep-alives.
SoLinger | Linger on close if unsent data is present.
SolSocket | Indicates socket options apply to the socket itself.
SoMaxConn | Maximum queue length that can be specified by Listen.
SoOOBInline | Receives out-of-band data in the normal data stream.
SoRcvBuf | Specifies the total per-socket buffer space reserved for receives. This is unrelated to the maximum message size or the size of a TCP window.
SoRcvLowat | Receive low water mark.
SoRcvTimeo | Receive timeout.
SoReuseAddr | Allows the socket to be bound to an address that is already in use.
SoSndBuf | Specifies the total per-socket buffer space reserved for sends. This is unrelated to the maximum message size or the size of a TCP window.
SoSndLowat | Send low water mark.
SoSndTimeo | Send timeout.
SoType | Get socket type.
SoUseLoopback | Bypass hardware when possible.
TcpBSDUrgent | [To be supplied.]
TcpNodelay | Disables the Nagle algorithm for send coalescing.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SocketOption Class | System.Net.Sockets Namespace


SocketOption Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public SocketOption();
[C++]
public: SocketOption();
[JScript]
public function SocketOption();

See Also

SocketOption Class | SocketOption Members | System.Net.Sockets Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SocketOption Fields

The fields of the SocketOption class are listed below. For a complete list of SocketOption class members, see the SocketOption Members topic.

Public:

IpAddMembership | Add an IP group membership.
IpDropMembership | Drop an IP group membership.
IpMulticastLoop | IP Multicast loopback.
IpMulticastTTL | IP multicast time to live.
OptionLevelIP | Indicates socket options apply to IP sockets.
OptionLevelTCP | Indicates socket options apply to TCP sockets.
SoAcceptConn | Socket is listening.
SoBroadcast | Permit sending broadcast messages on the socket.
SoDebug | Record debugging information.
SoDontLingee | Does not block waiting for unsent data to be sent.
SoDontRoute | Do not route, send directly to interface addresses.
SoError | Get error status and clear.
SoExclusiveAddrUse | Enables a socket to be bound for exclusive access.
SoKeepalive | Send keep-alives.
SoLinger | Linger on close if unsent data is present.
SolSocket | Indicates socket options apply to the socket itself.
SoMaxConn | Maximum queue length that can be specified by Listen.
SoOOBInline | Receives out-of-band data in the normal data stream.
SoRcvBuf | Specifies the total per-socket buffer space reserved for receives. This is unrelated to the maximum message size or the size of a TCP window.
SoRcvLowat | Receive low water mark.
SoRcvTimeo | Receive timeout.
SoReuseAddr | Allows the socket to be bound to an address that is already in use.
SoSndBuf | Specifies the total per-socket buffer space reserved for sends. This is unrelated to the maximum message size or the size of a TCP window.
SoSndLowat | Send low water mark.
SoSndTimeo | Send timeout.
SoType | Get socket type.
SoUseLoopback | Bypass hardware when possible.
TcpBSDUrgent | [To be supplied.]
TcpNodelay | Disables the Nagle algorithm for send coalescing.

See Also

SocketOption Class | System.Net.Sockets Namespace


SocketOption.IpAddMembership

Add an IP group membership.

[Visual Basic]
Public Const IpAddMembership As Integer
[C#]
public const int IpAddMembership;
[C++]
public: const int IpAddMembership;
[JScript]
public var IpAddMembership : int;

See Also

SocketOption Class | SocketOption Members | System.Net.Sockets Namespace


SocketOption.IpDropMembership

Drop an IP group membership.

[Visual Basic]
Public Const IpDropMembership As Integer
[C#]
public const int IpDropMembership;
[C++]
public: const int IpDropMembership;
[JScript]
public var IpDropMembership : int;

See Also

SocketOption Class | SocketOption Members | System.Net.Sockets Namespace


SocketOption.IpMulticastLoop

IP Multicast loopback.

[Visual Basic]
Public Const IpMulticastLoop As Integer
[C#]
public const int IpMulticastLoop;
[C++]
public: const int IpMulticastLoop;
[JScript]
public var IpMulticastLoop : int;

See Also

SocketOption Class | SocketOption Members | System.Net.Sockets Namespace


SocketOption.IpMulticastTTL

IP multicast time to live.

[Visual Basic]
Public Const IpMulticastTTL As Integer
[C#]
public const int IpMulticastTTL;
[C++]
public: const int IpMulticastTTL;
[JScript]
public var IpMulticastTTL : int;

See Also

SocketOption Class | SocketOption Members | System.Net.Sockets Namespace


SocketOption.OptionLevelIP

Indicates socket options apply to IP sockets.

[Visual Basic]
Public Const OptionLevelIP As Integer
[C#]
public const int OptionLevelIP;
[C++]
public: const int OptionLevelIP;
[JScript]
public var OptionLevelIP : int;

See Also

SocketOption Class | SocketOption Members | System.Net.Sockets Namespace


SocketOption.OptionLevelTCP

Indicates socket options apply to TCP sockets.

[Visual Basic]
Public Const OptionLevelTCP As Integer
[C#]
public const int OptionLevelTCP;
[C++]
public: const int OptionLevelTCP;
[JScript]
public var OptionLevelTCP : int;

See Also

SocketOption Class | SocketOption Members | System.Net.Sockets Namespace


SocketOption.SoAcceptConn

Socket is listening.

[Visual Basic]
Public Const SoAcceptConn As Integer
[C#]
public const int SoAcceptConn;
[C++]
public: const int SoAcceptConn;
[JScript]
public var SoAcceptConn : int;

See Also

SocketOption Class | SocketOption Members | System.Net.Sockets Namespace


SocketOption.SoBroadcast

Permit sending broadcast messages on the socket.

[Visual Basic]
Public Const SoBroadcast As Integer
[C#]
public const int SoBroadcast;
[C++]
public: const int SoBroadcast;
[JScript]
public var SoBroadcast : int;

See Also

SocketOption Class | SocketOption Members | System.Net.Sockets Namespace


SocketOption.SoDebug

Record debugging information.

[Visual Basic]
Public Const SoDebug As Integer
[C#]
public const int SoDebug;
[C++]
public: const int SoDebug;
[JScript]
public var SoDebug : int;

See Also

SocketOption Class | SocketOption Members | System.Net.Sockets Namespace


SocketOption.SoDontLingee

Does not block waiting for unsent data to be sent.

[Visual Basic]
Public Const SoDontLingee As Integer
[C#]
public const int SoDontLingee;
[C++]
public: const int SoDontLingee;
[JScript]
public var SoDontLingee : int;

See Also

SocketOption Class | SocketOption Members | System.Net.Sockets Namespace


SocketOption.SoDontRoute

Do not route, send directly to interface addresses.

[Visual Basic]
Public Const SoDontRoute As Integer
[C#]
public const int SoDontRoute;
[C++]
public: const int SoDontRoute;
[JScript]
public var SoDontRoute : int;

See Also

SocketOption Class | SocketOption Members | System.Net.Sockets Namespace


SocketOption.SoError

Get error status and clear.

[Visual Basic]
Public Const SoError As Integer
[C#]
public const int SoError;
[C++]
public: const int SoError;
[JScript]
public var SoError : int;

See Also

SocketOption Class | SocketOption Members | System.Net.Sockets Namespace


SocketOption.SoExclusiveAddrUse

Enables a socket to be bound for exclusive access.

[Visual Basic]
Public Const SoExclusiveAddrUse As Integer
[C#]
public const int SoExclusiveAddrUse;
[C++]
public: const int SoExclusiveAddrUse;
[JScript]
public var SoExclusiveAddrUse : int;

See Also

SocketOption Class | SocketOption Members | System.Net.Sockets Namespace


SocketOption.SoKeepalive

Send keep-alives.

[Visual Basic]
Public Const SoKeepalive As Integer
[C#]
public const int SoKeepalive;
[C++]
public: const int SoKeepalive;
[JScript]
public var SoKeepalive : int;

See Also

SocketOption Class | SocketOption Members | System.Net.Sockets Namespace


SocketOption.SoLinger

Linger on close if unsent data is present.

[Visual Basic]
Public Const SoLinger As Integer
[C#]
public const int SoLinger;
[C++]
public: const int SoLinger;
[JScript]
public var SoLinger : int;

See Also

SocketOption Class | SocketOption Members | System.Net.Sockets Namespace


SocketOption.SolSocket

Indicates socket options apply to the socket itself.

[Visual Basic]
Public Const SolSocket As Integer
[C#]
public const int SolSocket;
[C++]
public: const int SolSocket;
[JScript]
public var SolSocket : int;

See Also

SocketOption Class | SocketOption Members | System.Net.Sockets Namespace


SocketOption.SoMaxConn

Maximum queue length that can be specified by Listen.

[Visual Basic]
Public Const SoMaxConn As Integer
[C#]
public const int SoMaxConn;
[C++]
public: const int SoMaxConn;
[JScript]
public var SoMaxConn : int;

See Also

SocketOption Class | SocketOption Members | System.Net.Sockets Namespace


SocketOption.SoOOBInline

Receives out-of-band data in the normal data stream.

[Visual Basic]
Public Const SoOOBInline As Integer
[C#]
public const int SoOOBInline;
[C++]
public: const int SoOOBInline;
[JScript]
public var SoOOBInline : int;

See Also

SocketOption Class | SocketOption Members | System.Net.Sockets Namespace


SocketOption.SoRcvBuf

Specifies the total per-socket buffer space reserved for receives. This is unrelated to the maximum message size or the size of a TCP window.

[Visual Basic]
Public Const SoRcvBuf As Integer
[C#]
public const int SoRcvBuf;
[C++]
public: const int SoRcvBuf;
[JScript]
public var SoRcvBuf : int;

See Also

SocketOption Class | SocketOption Members | System.Net.Sockets Namespace


SocketOption.SoRcvLowat

Receive low water mark.

[Visual Basic]
Public Const SoRcvLowat As Integer
[C#]
public const int SoRcvLowat;
[C++]
public: const int SoRcvLowat;
[JScript]
public var SoRcvLowat : int;

See Also

SocketOption Class | SocketOption Members | System.Net.Sockets Namespace


SocketOption.SoRcvTimeo

Receive timeout.

[Visual Basic]
Public Const SoRcvTimeo As Integer
[C#]
public const int SoRcvTimeo;
[C++]
public: const int SoRcvTimeo;
[JScript]
public var SoRcvTimeo : int;

See Also

SocketOption Class | SocketOption Members | System.Net.Sockets Namespace


SocketOption.SoReuseAddr

Allows the socket to be bound to an address that is already in use.

[Visual Basic]
Public Const SoReuseAddr As Integer
[C#]
public const int SoReuseAddr;
[C++]
public: const int SoReuseAddr;
[JScript]
public var SoReuseAddr : int;

See Also

SocketOption Class | SocketOption Members | System.Net.Sockets Namespace


SocketOption.SoSndBuf

Specifies the total per-socket buffer space reserved for sends. This is unrelated to the maximum message size or the size of a TCP window.

[Visual Basic]
Public Const SoSndBuf As Integer
[C#]
public const int SoSndBuf;
[C++]
public: const int SoSndBuf;
[JScript]
public var SoSndBuf : int;

See Also

SocketOption Class | SocketOption Members | System.Net.Sockets Namespace


SocketOption.SoSndLowat

Send low water mark.

[Visual Basic]
Public Const SoSndLowat As Integer
[C#]
public const int SoSndLowat;
[C++]
public: const int SoSndLowat;
[JScript]
public var SoSndLowat : int;

See Also

SocketOption Class | SocketOption Members | System.Net.Sockets Namespace


SocketOption.SoSndTimeo

Send timeout.

[Visual Basic]
Public Const SoSndTimeo As Integer
[C#]
public const int SoSndTimeo;
[C++]
public: const int SoSndTimeo;
[JScript]
public var SoSndTimeo : int;

See Also

SocketOption Class | SocketOption Members | System.Net.Sockets Namespace


SocketOption.SoType

Get socket type.

[Visual Basic]
Public Const SoType As Integer
[C#]
public const int SoType;
[C++]
public: const int SoType;
[JScript]
public var SoType : int;

See Also

SocketOption Class | SocketOption Members | System.Net.Sockets Namespace


SocketOption.SoUseLoopback

Bypass hardware when possible.

[Visual Basic]
Public Const SoUseLoopback As Integer
[C#]
public const int SoUseLoopback;
[C++]
public: const int SoUseLoopback;
[JScript]
public var SoUseLoopback : int;

See Also

SocketOption Class | SocketOption Members | System.Net.Sockets Namespace


SocketOption.TcpBSDUrgent

[To be supplied.]

[Visual Basic]
Public Const TcpBSDUrgent As Integer
[C#]
public const int TcpBSDUrgent;
[C++]
public: const int TcpBSDUrgent;
[JScript]
public var TcpBSDUrgent : int;

See Also

SocketOption Class | SocketOption Members | System.Net.Sockets Namespace


SocketOption.TcpNodelay

Disables the Nagle algorithm for send coalescing.

[Visual Basic]
Public Const TcpNodelay As Integer
[C#]
public const int TcpNodelay;
[C++]
public: const int TcpNodelay;
[JScript]
public var TcpNodelay : int;

See Also

SocketOption Class | SocketOption Members | System.Net.Sockets Namespace


SocketShutdown Class

Defines constants used by the Shutdown method.

Object
SocketShutdown

[Visual Basic]
Public Class SocketShutdown
[C#]
public class SocketShutdown
[C++]
public __gc class SocketShutdown
[JScript]
public class SocketShutdown

Remarks

[To be supplied.]

Requirements

Namespace: System.Net.Sockets

Assembly: System.net.dll

See Also

SocketShutdown Members | System.Net.Sockets Namespace


SocketShutdown Members

Public:

Constructor

SocketShutdown Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

SdBoth | Shutdown socket for both send and receive.
SdReceive | Shutdown sockets for receive.
SdSend | Shutdown socket for send.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SocketShutdown Class | System.Net.Sockets Namespace


SocketShutdown Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public SocketShutdown();
[C++]
public: SocketShutdown();
[JScript]
public function SocketShutdown();

See Also

SocketShutdown Class | SocketShutdown Members | System.Net.Sockets Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SocketShutdown Fields

The fields of the SocketShutdown class are listed below. For a complete list of SocketShutdown class members, see the SocketShutdown Members topic.

Public:

SdBoth | Shutdown socket for both send and receive.
SdReceive | Shutdown sockets for receive.
SdSend | Shutdown socket for send.

See Also

SocketShutdown Class | System.Net.Sockets Namespace


SocketShutdown.SdBoth

Shutdown socket for both send and receive.

[Visual Basic]
Public Const SdBoth As Integer
[C#]
public const int SdBoth;
[C++]
public: const int SdBoth;
[JScript]
public var SdBoth : int;

See Also

SocketShutdown Class | SocketShutdown Members | System.Net.Sockets Namespace


SocketShutdown.SdReceive

Shutdown sockets for receive.

[Visual Basic]
Public Const SdReceive As Integer
[C#]
public const int SdReceive;
[C++]
public: const int SdReceive;
[JScript]
public var SdReceive : int;

See Also

SocketShutdown Class | SocketShutdown Members | System.Net.Sockets Namespace


SocketShutdown.SdSend

Shutdown socket for send.

[Visual Basic]
Public Const SdSend As Integer
[C#]
public const int SdSend;
[C++]
public: const int SdSend;
[JScript]
public var SdSend : int;

See Also

SocketShutdown Class | SocketShutdown Members | System.Net.Sockets Namespace


SocketType Class

Specifies the type of socket an instance of the Socket class represents.

Object
SocketType

[Visual Basic]
Public Class SocketType
[C#]
public class SocketType
[C++]
public __gc class SocketType
[JScript]
public class SocketType

Remarks

[To be supplied.]

Requirements

Namespace: System.Net.Sockets

Assembly: System.net.dll

See Also

SocketType Members | System.Net.Sockets Namespace


SocketType Members

Public:

Constructor

SocketType Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

SockDgram | [To be supplied.]
SockRaw | [To be supplied.]
SockRDM | [To be supplied.]
SockSeqpacket | [To be supplied.]
SockStream | [To be supplied.]
SockUnknown | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SocketType Class | System.Net.Sockets Namespace


SocketType Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public SocketType();
[C++]
public: SocketType();
[JScript]
public function SocketType();

See Also

SocketType Class | SocketType Members | System.Net.Sockets Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SocketType Fields

The fields of the SocketType class are listed below. For a complete list of SocketType class members, see the SocketType Members topic.

Public:

SockDgram | [To be supplied.]
SockRaw | [To be supplied.]
SockRDM | [To be supplied.]
SockSeqpacket | [To be supplied.]
SockStream | [To be supplied.]
SockUnknown | [To be supplied.]

See Also

SocketType Class | System.Net.Sockets Namespace


SocketType.SockDgram

[To be supplied.]

[Visual Basic]
Public Const SockDgram As Integer
[C#]
public const int SockDgram;
[C++]
public: const int SockDgram;
[JScript]
public var SockDgram : int;

See Also

SocketType Class | SocketType Members | System.Net.Sockets Namespace


SocketType.SockRaw

[To be supplied.]

[Visual Basic]
Public Const SockRaw As Integer
[C#]
public const int SockRaw;
[C++]
public: const int SockRaw;
[JScript]
public var SockRaw : int;

See Also

SocketType Class | SocketType Members | System.Net.Sockets Namespace


SocketType.SockRDM

[To be supplied.]

[Visual Basic]
Public Const SockRDM As Integer
[C#]
public const int SockRDM;
[C++]
public: const int SockRDM;
[JScript]
public var SockRDM : int;

See Also

SocketType Class | SocketType Members | System.Net.Sockets Namespace


SocketType.SockSeqpacket

[To be supplied.]

[Visual Basic]
Public Const SockSeqpacket As Integer
[C#]
public const int SockSeqpacket;
[C++]
public: const int SockSeqpacket;
[JScript]
public var SockSeqpacket : int;

See Also

SocketType Class | SocketType Members | System.Net.Sockets Namespace


SocketType.SockStream

[To be supplied.]

[Visual Basic]
Public Const SockStream As Integer
[C#]
public const int SockStream;
[C++]
public: const int SockStream;
[JScript]
public var SockStream : int;

See Also

SocketType Class | SocketType Members | System.Net.Sockets Namespace


SocketType.SockUnknown

[To be supplied.]

[Visual Basic]
Public Const SockUnknown As Integer
[C#]
public const int SockUnknown;
[C++]
public: const int SockUnknown;
[JScript]
public var SockUnknown : int;

See Also

SocketType Class | SocketType Members | System.Net.Sockets Namespace


TCPClient Class

The TCPClient class provide TCP services at a higher level of abstraction than the Socket class. TCPClient is used to create a client connection to a remote host.

Object
TCPClient

[Visual Basic]
Public Class TCPClient
[C#]
public class TCPClient
[C++]
public __gc class TCPClient
[JScript]
public class TCPClient

Remarks

The TCPClient class builds upon the Socket class to provide TCP services at a higher level of abstraction. Application level protocols such as FTP and HTTP are built on the TCPClient class.

Requirements

Namespace: System.Net.Sockets

Assembly: System.net.dll

See Also

TCPClient Members | System.Net.Sockets Namespace


TCPClient Members

Public:

Constructor

TCPClient Constructor Overloaded. Initializes a new instance of the TCPClient class.

Properties

LingerState | Gets or sets the value of the connection's linger option.
NoDelay | Enables or disables delay when send or receive buffers are full.
ReceiveBufferSize | Gets or sets the size of the receive buffer in bytes.
ReceiveTimeout | Gets or sets the receive time out value of the connection in seconds.
SendBufferSize | Gets or sets the size of the send buffer in bytes.
SendTimeout | Gets or sets the send time out value of the connection in seconds.

Methods

Close | Closes the TCP connection
Connect | Overloaded. Connects the client to a TCP host.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetStream | Returns the stream used to read and write data to the remote host.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

Active | Used by the class to indicate that a connection has been made.
Client | Used by the class to provide the underlying network socket.
DataStream | Used by the class to provide the network data stream.

See Also

TCPClient Class | System.Net.Sockets Namespace


TCPClient Constructor

Initializes a new instance of the TCPClient class.

Overload List

Initializes a new instance of the TCPClient class with the specified end point.

[Visual Basic] Overloads Public Sub New(IPEndPoint)
[C#] public TCPClient(IPEndPoint);
[C++] public: TCPClient(IPEndPoint*);
[JScript] public function TCPClient(IPEndPoint);

Initializes a new instance of the TCPClient class.

[Visual Basic] Overloads Public Sub New()
[C#] public TCPClient();
[C++] public: TCPClient();
[JScript] public function TCPClient();

Initializes a new instance of the TCPClient class and connects to the specified port on the specified host.

[Visual Basic] Overloads Public Sub New(String, Integer)
[C#] public TCPClient(String, int);
[C++] public: TCPClient(String*, int);
[JScript] public function TCPClient(String, int);

See Also

TCPClient Class | TCPClient Members | System.Net.Sockets Namespace


TCPClient Constructor (IPEndPoint)

Initializes a new instance of the TCPClient class with the specified end point.

[Visual Basic]
Overloads Public Sub New( _
   ByVal localEP As IPEndPoint _
)
[C#]
public TCPClient(
   IPEndPoint localEP
);
[C++]
public: TCPClient(
   IPEndPoint* localEP
);
[JScript]
public function TCPClient(
   localEP : IPEndPoint
);

Parameters

localEP
The local end point to bind the TCP connection to.

See Also

TCPClient Class | TCPClient Members | System.Net.Sockets Namespace | TCPClient Constructor Overload List


TCPClient Constructor ()

Initializes a new instance of the TCPClient class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public TCPClient();
[C++]
public: TCPClient();
[JScript]
public function TCPClient();

Remarks

The default constructor sets the IP address to InaddrAny and the port number to 0.

See Also

TCPClient Class | TCPClient Members | System.Net.Sockets Namespace | TCPClient Constructor Overload List


TCPClient Constructor (String, Int32)

Initializes a new instance of the TCPClient class and connects to the specified port on the specified host.

[Visual Basic]
Overloads Public Sub New( _
   ByVal hostname As String, _
   ByVal port As Integer _
)
[C#]
public TCPClient(
   string hostname,
   int port
);
[C++]
public: TCPClient(
   String* hostname,
   int port
);
[JScript]
public function TCPClient(
   hostname : String,
   port : int
);

Parameters

hostname
The remote host to connect.
port
[To be supplied.]

Remarks

This constructor is the same as calling the default constructor and then calling Connect.

See Also

TCPClient Class | TCPClient Members | System.Net.Sockets Namespace | TCPClient Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TCPClient Properties

The properties of the TCPClient class are listed below. For a complete list of TCPClient class members, see the TCPClient Members topic.

Public:

LingerState | Gets or sets the value of the connection's linger option.
NoDelay | Enables or disables delay when send or receive buffers are full.
ReceiveBufferSize | Gets or sets the size of the receive buffer in bytes.
ReceiveTimeout | Gets or sets the receive time out value of the connection in seconds.
SendBufferSize | Gets or sets the size of the send buffer in bytes.
SendTimeout | Gets or sets the send time out value of the connection in seconds.

See Also

TCPClient Class | System.Net.Sockets Namespace


TCPClient.LingerState

Gets or sets the value of the connection's linger option.

[Visual Basic]
Public Property LingerState As LingerOption
[C#]
public LingerOption LingerState {get; set;}
[C++]
public: __property LingerOption* get_LingerState();
public: __property void set_LingerState(LingerOption*);
[JScript]
public function get LingerState() : LingerOption;
public function set LingerState(LingerOption);

See Also

TCPClient Class | TCPClient Members | System.Net.Sockets Namespace | LingerOption


TCPClient.NoDelay

Enables or disables delay when send or receive buffers are full.

[Visual Basic]
Public Property NoDelay As Boolean
[C#]
public bool NoDelay {get; set;}
[C++]
public: __property bool get_NoDelay();
public: __property void set_NoDelay(bool);
[JScript]
public function get NoDelay() : Boolean;
public function set NoDelay(Boolean);

See Also

TCPClient Class | TCPClient Members | System.Net.Sockets Namespace


TCPClient.ReceiveBufferSize

Gets or sets the size of the receive buffer in bytes.

[Visual Basic]
Public Property ReceiveBufferSize As Integer
[C#]
public int ReceiveBufferSize {get; set;}
[C++]
public: __property int get_ReceiveBufferSize();
public: __property void set_ReceiveBufferSize(int);
[JScript]
public function get ReceiveBufferSize() : int;
public function set ReceiveBufferSize(int);

Remarks

The size of the receive buffer can only be changed after a connection to a remote host has been made.

See Also

TCPClient Class | TCPClient Members | System.Net.Sockets Namespace


TCPClient.ReceiveTimeout

Gets or sets the receive time out value of the connection in seconds.

[Visual Basic]
Public Property ReceiveTimeout As Integer
[C#]
public int ReceiveTimeout {get; set;}
[C++]
public: __property int get_ReceiveTimeout();
public: __property void set_ReceiveTimeout(int);
[JScript]
public function get ReceiveTimeout() : int;
public function set ReceiveTimeout(int);

See Also

TCPClient Class | TCPClient Members | System.Net.Sockets Namespace


TCPClient.SendBufferSize

Gets or sets the size of the send buffer in bytes.

[Visual Basic]
Public Property SendBufferSize As Integer
[C#]
public int SendBufferSize {get; set;}
[C++]
public: __property int get_SendBufferSize();
public: __property void set_SendBufferSize(int);
[JScript]
public function get SendBufferSize() : int;
public function set SendBufferSize(int);

Remarks

The size of the receive buffer can only be changed after a connection to a remote host has been made.

See Also

TCPClient Class | TCPClient Members | System.Net.Sockets Namespace


TCPClient.SendTimeout

Gets or sets the send time out value of the connection in seconds.

[Visual Basic]
Public Property SendTimeout As Integer
[C#]
public int SendTimeout {get; set;}
[C++]
public: __property int get_SendTimeout();
public: __property void set_SendTimeout(int);
[JScript]
public function get SendTimeout() : int;
public function set SendTimeout(int);

See Also

TCPClient Class | TCPClient Members | System.Net.Sockets Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TCPClient Methods

The methods of the TCPClient class are listed below. For a complete list of TCPClient class members, see the TCPClient Members topic.

Public:

Close | Closes the TCP connection
Connect | Overloaded. Connects the client to a TCP host.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetStream | Returns the stream used to read and write data to the remote host.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TCPClient Class | System.Net.Sockets Namespace


TCPClient.Close

Closes the TCP connection

[Visual Basic]
Public Function Close() As Integer
[C#]
public int Close();
[C++]
public: int Close();
[JScript]
public function Close() : int;

Return Value

0 if the connection was successfully closed; otherwise a non-zero error code.

See Also

TCPClient Class | TCPClient Members | System.Net.Sockets Namespace | Close


TCPClient.Connect

Connects the client to a TCP host.

Overload List

Connects the client to the specified port on the specified host.

[Visual Basic] Overloads Public Function Connect(String, Integer) As Integer
[C#] public int Connect(String, int);
[C++] public: int Connect(String*, int);
[JScript] public function Connect(String, int) : int;

Connects the client to the specified port on the specified host.

[Visual Basic] Overloads Public Function Connect(IPAddress, Integer) As Integer
[C#] public int Connect(IPAddress, int);
[C++] public: int Connect(IPAddress*, int);
[JScript] public function Connect(IPAddress, int) : int;

Connect the client to the specified end point.

[Visual Basic] Overloads Public Function Connect(IPEndPoint) As Integer
[C#] public int Connect(IPEndPoint);
[C++] public: int Connect(IPEndPoint*);
[JScript] public function Connect(IPEndPoint) : int;

See Also

TCPClient Class | TCPClient Members | System.Net.Sockets Namespace


TCPClient.Connect (String, Int32)

Connects the client to the specified port on the specified host.

[Visual Basic]
Overloads Public Function Connect( _
   ByVal hostname As String, _
   ByVal port As Integer _
) As Integer
[C#]
public int Connect(
   string hostname,
   int port
);
[C++]
public: int Connect(
   String* hostname,
   int port
);
[JScript]
public function Connect(
   hostname : String,
   port : int
) : int;

Parameters

hostname
The remote host to connect.
port
The port on the remote host to connect.

Return Value

0 if the connection was successful; otherwise, a non-zero error code.

Remarks

Connect establishes a TCP connection to the port and hostname specified. The connection is made using the Connect method of the underlying Socket instance.

See Also

TCPClient Class | TCPClient Members | System.Net.Sockets Namespace | TCPClient.Connect Overload List | Connect


TCPClient.Connect (IPAddress, Int32)

Connects the client to the specified port on the specified host.

[Visual Basic]
Overloads Public Function Connect( _
   ByVal address As IPAddress, _
   ByVal port As Integer _
) As Integer
[C#]
public int Connect(
   IPAddress address,
   int port
);
[C++]
public: int Connect(
   IPAddress* address,
   int port
);
[JScript]
public function Connect(
   address : IPAddress,
   port : int
) : int;

Parameters

address
IP address of the desired host.
port
[To be supplied.]

Return Value

0 if the connection was successful; otherwise, a non-zero error code.

Remarks

Connect establishes a TCP connection to the port and IP address specified. The connection is made using the Connect method of the underlying Socket instance.

See Also

TCPClient Class | TCPClient Members | System.Net.Sockets Namespace | TCPClient.Connect Overload List


TCPClient.Connect (IPEndPoint)

Connect the client to the specified end point.

[Visual Basic]
Overloads Public Function Connect( _
   ByVal remoteEP As IPEndPoint _
) As Integer
[C#]
public int Connect(
   IPEndPoint remoteEP
);
[C++]
public: int Connect(
   IPEndPoint* remoteEP
);
[JScript]
public function Connect(
   remoteEP : IPEndPoint
) : int;

Parameters

remoteEP
The IP end point to connect.

Return Value

0 if the connection was successful; otherwise, a non-zero error code.

Remarks

Connect establishes a TCP connection to the IP end point specified. The connection is made using the Connect method of the underlying Socket instance.

See Also

TCPClient Class | TCPClient Members | System.Net.Sockets Namespace | TCPClient.Connect Overload List


TCPClient.GetStream

Returns the stream used to read and write data to the remote host.

[Visual Basic]
Public Function GetStream() As NetworkStream
[C#]
public NetworkStream GetStream();
[C++]
public: NetworkStream* GetStream();
[JScript]
public function GetStream() : NetworkStream;

Return Value

A network stream to read or write data.

Exceptions

Exception Type | Condition
System.InvalideOperationException | The TCPClient instance is not connected to a remote host.

See Also

TCPClient Class | TCPClient Members | System.Net.Sockets Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TCPClient Fields

The fields of the TCPClient class are listed below. For a complete list of TCPClient class members, see the TCPClient Members topic.

Protected:

Active | Used by the class to indicate that a connection has been made.
Client | Used by the class to provide the underlying network socket.
DataStream | Used by the class to provide the network data stream.

See Also

TCPClient Class | System.Net.Sockets Namespace


TCPClient.Active

Used by the class to indicate that a connection has been made.

[Visual Basic]
Protected Active As Boolean
[C#]
protected bool Active;
[C++]
protected: bool Active;
[JScript]
protected var Active : Boolean;

See Also

TCPClient Class | TCPClient Members | System.Net.Sockets Namespace


TCPClient.Client

Used by the class to provide the underlying network socket.

[Visual Basic]
Protected Client As Socket
[C#]
protected Socket Client;
[C++]
protected: Socket* Client;
[JScript]
protected var Client : Socket;

Remarks

TCPClient creates a Socket instance to handle the actual sending and recieving of data over the network. The socket is initialized with the following parameters passed to its constructor:

Item | Description
Address Family | AfInet
Socket Type | SockStream
Protocol Type | ProtTCP

See Also

TCPClient Class | TCPClient Members | System.Net.Sockets Namespace


TCPClient.DataStream

Used by the class to provide the network data stream.

[Visual Basic]
Protected DataStream As NetworkStream
[C#]
protected NetworkStream DataStream;
[C++]
protected: NetworkStream* DataStream;
[JScript]
protected var DataStream : NetworkStream;

See Also

TCPClient Class | TCPClient Members | System.Net.Sockets Namespace


TCPListener Class

The TCPListener class provide TCP services at a higher level of abstraction than the Socket class. TCPListener is used to create a host process that listens for connections from TCP clients.

Object
TCPListener

[Visual Basic]
Public Class TCPListener
[C#]
public class TCPListener
[C++]
public __gc class TCPListener
[JScript]
public class TCPListener

Remarks

The TCPListener class builds upon the Socket class to provide TCP services at a higher level of abstraction. Application level protocols such as FTP and HTTP are built on the TCPListener class.

Requirements

Namespace: System.Net.Sockets

Assembly: System.net.dll

See Also

TCPListener Members | System.Net.Sockets Namespace


TCPListener Members

Public:

Constructor

TCPListener Constructor Overloaded. Initializes a new instance of the TCPListener class.

Methods

Accept | Accepts a pending connection request.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Pending | Determine if there are pending connection requests.
Start | Starts listening to network requests.
Stop | Closes the netowrk connection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

Active | Used by the class to indicate that the listener's socket has been bound to a port and started listening.
Server | Used by the class to provide the underlying network socket.

See Also

TCPListener Class | System.Net.Sockets Namespace


TCPListener Constructor

Initializes a new instance of the TCPListener class.

Overload List

Initializes a new instance of the TCPListener class with the specified local end point.

[Visual Basic] Overloads Public Sub New(IPEndPoint)
[C#] public TCPListener(IPEndPoint);
[C++] public: TCPListener(IPEndPoint*);
[JScript] public function TCPListener(IPEndPoint);

Initializes a new instance of the TCPListener class that listens to the specified IP address and port.

[Visual Basic] Overloads Public Sub New(IPAddress, Integer)
[C#] public TCPListener(IPAddress, int);
[C++] public: TCPListener(IPAddress*, int);
[JScript] public function TCPListener(IPAddress, int);

Initiailizes a new instance of the TCPListener class that listens on the specified port.

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public TCPListener(int);
[C++] public: TCPListener(int);
[JScript] public function TCPListener(int);

See Also

TCPListener Class | TCPListener Members | System.Net.Sockets Namespace


TCPListener Constructor (IPEndPoint)

Initializes a new instance of the TCPListener class with the specified local end point.

[Visual Basic]
Overloads Public Sub New( _
   ByVal localEP As IPEndPoint _
)
[C#]
public TCPListener(
   IPEndPoint localEP
);
[C++]
public: TCPListener(
   IPEndPoint* localEP
);
[JScript]
public function TCPListener(
   localEP : IPEndPoint
);

Parameters

localEP
The local end point to bind the listener connection to.

See Also

TCPListener Class | TCPListener Members | System.Net.Sockets Namespace | TCPListener Constructor Overload List


TCPListener Constructor (IPAddress, Int32)

Initializes a new instance of the TCPListener class that listens to the specified IP address and port.

[Visual Basic]
Overloads Public Sub New( _
   ByVal localaddr As IPAddress, _
   ByVal port As Integer _
)
[C#]
public TCPListener(
   IPAddress localaddr,
   int port
);
[C++]
public: TCPListener(
   IPAddress* localaddr,
   int port
);
[JScript]
public function TCPListener(
   localaddr : IPAddress,
   port : int
);

Parameters

localaddr
The local IP address to listen to.
port
[To be supplied.]

See Also

TCPListener Class | TCPListener Members | System.Net.Sockets Namespace | TCPListener Constructor Overload List


TCPListener Constructor (Int32)

Initiailizes a new instance of the TCPListener class that listens on the specified port.

[Visual Basic]
Overloads Public Sub New( _
   ByVal port As Integer _
)
[C#]
public TCPListener(
   int port
);
[C++]
public: TCPListener(
   int port
);
[JScript]
public function TCPListener(
   port : int
);

Parameters

port
The port to listen on.

See Also

TCPListener Class | TCPListener Members | System.Net.Sockets Namespace | TCPListener Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TCPListener Methods

The methods of the TCPListener class are listed below. For a complete list of TCPListener class members, see the TCPListener Members topic.

Public:

Accept | Accepts a pending connection request.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Pending | Determine if there are pending connection requests.
Start | Starts listening to network requests.
Stop | Closes the netowrk connection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TCPListener Class | System.Net.Sockets Namespace


TCPListener.Accept

Accepts a pending connection request.

[Visual Basic]
Public Function Accept() As Socket
[C#]
public Socket Accept();
[C++]
public: Socket* Accept();
[JScript]
public function Accept() : Socket;

Return Value

A Socket instance to handle the incoming connection request.

See Also

TCPListener Class | TCPListener Members | System.Net.Sockets Namespace


TCPListener.Pending

Determine if there are pending connection requests.

[Visual Basic]
Public Function Pending() As Boolean
[C#]
public bool Pending();
[C++]
public: bool Pending();
[JScript]
public function Pending() : Boolean;

Return Value

True if connections are pending; otherwise, false.

Exceptions

Exception Type | Condition
InvalidOperationException | The listener has not been started with a call to Start.

See Also

TCPListener Class | TCPListener Members | System.Net.Sockets Namespace


TCPListener.Start

Starts listening to network requests.

[Visual Basic]
Public Function Start() As Integer
[C#]
public int Start();
[C++]
public: int Start();
[JScript]
public function Start() : int;

Return Value

0 of no error occurs; otherwise, a non-zero error code.

See Also

TCPListener Class | TCPListener Members | System.Net.Sockets Namespace | Listen


TCPListener.Stop

Closes the netowrk connection.

[Visual Basic]
Public Function Stop() As Integer
[C#]
public int Stop();
[C++]
public: int Stop();
[JScript]
public function Stop() : int;

Return Value

0 of no error occurs; otherwise, a non-zero error code.

See Also

TCPListener Class | TCPListener Members | System.Net.Sockets Namespace | Close


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TCPListener Fields

The fields of the TCPListener class are listed below. For a complete list of TCPListener class members, see the TCPListener Members topic.

Protected:

Active | Used by the class to indicate that the listener's socket has been bound to a port and started listening.
Server | Used by the class to provide the underlying network socket.

See Also

TCPListener Class | System.Net.Sockets Namespace


TCPListener.Active

Used by the class to indicate that the listener's socket has been bound to a port and started listening.

[Visual Basic]
Protected Active As Boolean
[C#]
protected bool Active;
[C++]
protected: bool Active;
[JScript]
protected var Active : Boolean;

See Also

TCPListener Class | TCPListener Members | System.Net.Sockets Namespace


TCPListener.Server

Used by the class to provide the underlying network socket.

[Visual Basic]
Protected Server As Socket
[C#]
protected Socket Server;
[C++]
protected: Socket* Server;
[JScript]
protected var Server : Socket;

See Also

TCPListener Class | TCPListener Members | System.Net.Sockets Namespace | Socket


UDPClient Class

The UDPClient class provides access to UDP services at a higher abstraction level than the Socket class. UDPClient is used to connect to a remote host and to receive connections from a remote client.

Object
UDPClient

[Visual Basic]
Public Class UDPClient
[C#]
public class UDPClient
[C++]
public __gc class UDPClient
[JScript]
public class UDPClient

Remarks

[To be supplied.]

Requirements

Namespace: System.Net.Sockets

Assembly: System.net.dll

See Also

UDPClient Members | System.Net.Sockets Namespace


UDPClient Members

Public:

Constructor

UDPClient Constructor Overloaded. Initializes a new instance of the UDPClient class.

Methods

Connect | Overloaded. Establishes a connection to a remote host.
DropMulticastGroup | Leaves a multicast address group.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
JoinMulticastGroup | Joins a multicast address group.
Receive | Returns a datagram sent by a server.
Send | Overloaded. Sends a UDP datagram to a remote host.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

Active | Used by the class to indicate that a connection to a remote host has been made.
Client | Used by the class to provide the underlying network socket.

See Also

UDPClient Class | System.Net.Sockets Namespace


UDPClient Constructor

Initializes a new instance of the UDPClient class.

Overload List

Initializes a new instance of the UDPClient class.

[Visual Basic] Overloads Public Sub New()
[C#] public UDPClient();
[C++] public: UDPClient();
[JScript] public function UDPClient();

Creates a new instance of the UDPClient class that communicates on the specified port number.

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public UDPClient(int);
[C++] public: UDPClient(int);
[JScript] public function UDPClient(int);

Creates a new instance of the UDPClient class that communicates on the specified end point.

[Visual Basic] Overloads Public Sub New(IPEndPoint)
[C#] public UDPClient(IPEndPoint);
[C++] public: UDPClient(IPEndPoint*);
[JScript] public function UDPClient(IPEndPoint);

Creates a new instance of the UDPClient class and connects to the specified remote host on the specified port.

[Visual Basic] Overloads Public Sub New(String, Integer)
[C#] public UDPClient(String, int);
[C++] public: UDPClient(String*, int);
[JScript] public function UDPClient(String, int);

See Also

UDPClient Class | UDPClient Members | System.Net.Sockets Namespace


UDPClient Constructor ()

Initializes a new instance of the UDPClient class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public UDPClient();
[C++]
public: UDPClient();
[JScript]
public function UDPClient();

See Also

UDPClient Class | UDPClient Members | System.Net.Sockets Namespace | UDPClient Constructor Overload List


UDPClient Constructor (Int32)

Creates a new instance of the UDPClient class that communicates on the specified port number.

[Visual Basic]
Overloads Public Sub New( _
   ByVal port As Integer _
)
[C#]
public UDPClient(
   int port
);
[C++]
public: UDPClient(
   int port
);
[JScript]
public function UDPClient(
   port : int
);

Parameters

port
The port to communicate on.

See Also

UDPClient Class | UDPClient Members | System.Net.Sockets Namespace | UDPClient Constructor Overload List


UDPClient Constructor (IPEndPoint)

Creates a new instance of the UDPClient class that communicates on the specified end point.

[Visual Basic]
Overloads Public Sub New( _
   ByVal localEP As IPEndPoint _
)
[C#]
public UDPClient(
   IPEndPoint localEP
);
[C++]
public: UDPClient(
   IPEndPoint* localEP
);
[JScript]
public function UDPClient(
   localEP : IPEndPoint
);

Parameters

localEP
The end point to communicate on.

See Also

UDPClient Class | UDPClient Members | System.Net.Sockets Namespace | UDPClient Constructor Overload List


UDPClient Constructor (String, Int32)

Creates a new instance of the UDPClient class and connects to the specified remote host on the specified port.

[Visual Basic]
Overloads Public Sub New( _
   ByVal hostname As String, _
   ByVal port As Integer _
)
[C#]
public UDPClient(
   string hostname,
   int port
);
[C++]
public: UDPClient(
   String* hostname,
   int port
);
[JScript]
public function UDPClient(
   hostname : String,
   port : int
);

Parameters

hostname
The remote host to connect to.
port
[To be supplied.]

See Also

UDPClient Class | UDPClient Members | System.Net.Sockets Namespace | UDPClient Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UDPClient Methods

The methods of the UDPClient class are listed below. For a complete list of UDPClient class members, see the UDPClient Members topic.

Public:

Connect | Overloaded. Establishes a connection to a remote host.
DropMulticastGroup | Leaves a multicast address group.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
JoinMulticastGroup | Joins a multicast address group.
Receive | Returns a datagram sent by a server.
Send | Overloaded. Sends a UDP datagram to a remote host.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UDPClient Class | System.Net.Sockets Namespace


UDPClient.Connect

Establishes a connection to a remote host.

Overload List

Establishes a connection to the specified port on the specified host.

[Visual Basic] Overloads Public Function Connect(String, Integer) As Integer
[C#] public int Connect(String, int);
[C++] public: int Connect(String*, int);
[JScript] public function Connect(String, int) : int;

Establishes a connection with the host at the specified address on the specified port.

[Visual Basic] Overloads Public Function Connect(IPAddress, Integer) As Integer
[C#] public int Connect(IPAddress, int);
[C++] public: int Connect(IPAddress*, int);
[JScript] public function Connect(IPAddress, int) : int;

Establishes a connection to a remote end point.

[Visual Basic] Overloads Public Function Connect(IPEndPoint) As Integer
[C#] public int Connect(IPEndPoint);
[C++] public: int Connect(IPEndPoint*);
[JScript] public function Connect(IPEndPoint) : int;

See Also

UDPClient Class | UDPClient Members | System.Net.Sockets Namespace


UDPClient.Connect (String, Int32)

Establishes a connection to the specified port on the specified host.

[Visual Basic]
Overloads Public Function Connect( _
   ByVal hostname As String, _
   ByVal port As Integer _
) As Integer
[C#]
public int Connect(
   string hostname,
   int port
);
[C++]
public: int Connect(
   String* hostname,
   int port
);
[JScript]
public function Connect(
   hostname : String,
   port : int
) : int;

Parameters

hostname
The remote host to connect to.
port
The remote port to communicate on.

Return Value

0 if the connection was successful; otherwise a non-zero error code.

Remarks

Connect establishes a UDP connection to the port and hostname specified. The connection is made using the Connect method of the underlying Socket instance.

See Also

UDPClient Class | UDPClient Members | System.Net.Sockets Namespace | UDPClient.Connect Overload List | Socket


UDPClient.Connect (IPAddress, Int32)

Establishes a connection with the host at the specified address on the specified port.

[Visual Basic]
Overloads Public Function Connect( _
   ByVal addr As IPAddress, _
   ByVal port As Integer _
) As Integer
[C#]
public int Connect(
   IPAddress addr,
   int port
);
[C++]
public: int Connect(
   IPAddress* addr,
   int port
);
[JScript]
public function Connect(
   addr : IPAddress,
   port : int
) : int;

Parameters

addr
The IP address of the remote host to connect to.
port
The remote port to communicate on.

Return Value

0 if the connection was successful; otherwise a non-zero error code.

Remarks

Connect establishes a UDP connection to the port and host at the IP address specified. The connection is made using the Connect method of the underlying Socket instance.

See Also

UDPClient Class | UDPClient Members | System.Net.Sockets Namespace | UDPClient.Connect Overload List


UDPClient.Connect (IPEndPoint)

Establishes a connection to a remote end point.

[Visual Basic]
Overloads Public Function Connect( _
   ByVal ep As IPEndPoint _
) As Integer
[C#]
public int Connect(
   IPEndPoint ep
);
[C++]
public: int Connect(
   IPEndPoint* ep
);
[JScript]
public function Connect(
   ep : IPEndPoint
) : int;

Parameters

ep
An System.Net.Sockets.IPEndPoint referencing the desired host and port.

Return Value

0 if the connection was successful; otherwise a non-zero error code.

Remarks

Connect establishes a UDP connection to the host referenced by the System.Net.Sockets.IPEndPoint. The connection is made using the Connect method of the underlying Socket instance.

See Also

UDPClient Class | UDPClient Members | System.Net.Sockets Namespace | UDPClient.Connect Overload List


UDPClient.DropMulticastGroup

Leaves a multicast address group.

[Visual Basic]
Public Function DropMulticastGroup( _
   ByVal multicastAddr As IPAddress _
) As Boolean
[C#]
public bool DropMulticastGroup(
   IPAddress multicastAddr
);
[C++]
public: bool DropMulticastGroup(
   IPAddress* multicastAddr
);
[JScript]
public function DropMulticastGroup(
   multicastAddr : IPAddress
) : Boolean;

Parameters

multicastAddr
The multicast address group to leave.

Return Value

true if the multicast address group was successfully left; otherwise, false.

See Also

UDPClient Class | UDPClient Members | System.Net.Sockets Namespace


UDPClient.JoinMulticastGroup

Joins a multicast address group.

[Visual Basic]
Public Function JoinMulticastGroup( _
   ByVal multicastAddr As IPAddress _
) As Boolean
[C#]
public bool JoinMulticastGroup(
   IPAddress multicastAddr
);
[C++]
public: bool JoinMulticastGroup(
   IPAddress* multicastAddr
);
[JScript]
public function JoinMulticastGroup(
   multicastAddr : IPAddress
) : Boolean;

Parameters

multicastAddr
The multicast address group to join.

Return Value

true if the multicast address group was successfully joined; otherwise, false.

See Also

UDPClient Class | UDPClient Members | System.Net.Sockets Namespace


UDPClient.Receive

Returns a datagram sent by a server.

[Visual Basic]
Public Function Receive( _
   ByRef EP As IPEndPoint _
) As Byte ()
[C#]
public byte[] Receive(
   ref IPEndPoint EP
);
[C++]
public: unsigned char* Receive(
   IPEndPoint** EP
) [];
[JScript]
public function Receive(
   EP : IPEndPoint
) : Byte[];

Parameters

EP
An System.Net.Sockets.IPEndPoint referencing the remote server sending the data.

Return Value

An array of 8-bit unsigned integers containing the datagram data.

See Also

UDPClient Class | UDPClient Members | System.Net.Sockets Namespace


UDPClient.Send

Sends a UDP datagram to a remote host.

Overload List

Sends a UDP datagram to the host at the remote end point.

[Visual Basic] Overloads Public Function Send(Byte(), Integer, IPEndPoint) As Integer
[C#] public int Send(byte[], int, IPEndPoint);
[C++] public: int Send(unsigned char*[], int, IPEndPoint);
[JScript] public function Send(Byte[], int, IPEndPoint) : int;

Sends a UDP datagram to the specified port on the specified remote host.

[Visual Basic] Overloads Public Function Send(Byte(), Integer, String, Integer) As Integer
[C#] public int Send(byte[], int, String, int);
[C++] public: int Send(unsigned char*[], int, String, int);
[JScript] public function Send(Byte[], int, String, int) : int;

Sends a UDP datagram to a remote host.

[Visual Basic] Overloads Public Function Send(Byte(), Integer) As Integer
[C#] public int Send(byte[], int);
[C++] public: int Send(unsigned char*[], int);
[JScript] public function Send(Byte[], int) : int;

See Also

UDPClient Class | UDPClient Members | System.Net.Sockets Namespace


UDPClient.Send (Byte[], Int32, IPEndPoint)

Sends a UDP datagram to the host at the remote end point.

[Visual Basic]
Overloads Public Function Send( _
   ByVal dgram() As Byte, _
   ByVal bytes As Integer, _
   ByVal ep As IPEndPoint _
) As Integer
[C#]
public int Send(
   byte[] dgram,
   int bytes,
   IPEndPoint ep
);
[C++]
public: int Send(
   unsigned char* dgram[],
   int bytes,
   IPEndPoint* ep
);
[JScript]
public function Send(
   dgram : Byte[],
   bytes : int,
   ep : IPEndPoint
) : int;

Parameters

dgram
The UDP datagram to send.
bytes
[To be supplied.]
ep
[To be supplied.]

Return Value

If successful, the number of bytes sent; otherwise an invalid socket error.

Exceptions

Exception Type | Condition
ArgumentException | The UDPClient is connected to a remote host.

Remarks

System.Net.Sockets.TCPClient.Send establishes a UDP connection to the host referenced by the System.Net.Sockets.IPEndPoint and sends the datagram. The data is sent the SendTo method of the underlying Socket instance.

See Also

UDPClient Class | UDPClient Members | System.Net.Sockets Namespace | UDPClient.Send Overload List


UDPClient.Send (Byte[], Int32, String, Int32)

Sends a UDP datagram to the specified port on the specified remote host.

[Visual Basic]
Overloads Public Function Send( _
   ByVal dgram() As Byte, _
   ByVal bytes As Integer, _
   ByVal hostname As String, _
   ByVal port As Integer _
) As Integer
[C#]
public int Send(
   byte[] dgram,
   int bytes,
   string hostname,
   int port
);
[C++]
public: int Send(
   unsigned char* dgram[],
   int bytes,
   String* hostname,
   int port
);
[JScript]
public function Send(
   dgram : Byte[],
   bytes : int,
   hostname : String,
   port : int
) : int;

Parameters

dgram
The UDP datagram to send.
bytes
The number of bytes in the datagram to send.
hostname
The remote host to connect to.
port
[To be supplied.]

Return Value

If successful, the number of bytes sent; otherwise an invalid socket error.

Exceptions

Exception Type | Condition
ArgumentException | The UDPClient is connected to a remote host.

Remarks

System.Net.Sockets.TCPClient.Send establishes a UDP connection to the host and port specified and sends the datagram. The data is sent the SendTo method of the underlying Socket instance.

See Also

UDPClient Class | UDPClient Members | System.Net.Sockets Namespace | UDPClient.Send Overload List


UDPClient.Send (Byte[], Int32)

Sends a UDP datagram to a remote host.

[Visual Basic]
Overloads Public Function Send( _
   ByVal dgram() As Byte, _
   ByVal bytes As Integer _
) As Integer
[C#]
public int Send(
   byte[] dgram,
   int bytes
);
[C++]
public: int Send(
   unsigned char* dgram[],
   int bytes
);
[JScript]
public function Send(
   dgram : Byte[],
   bytes : int
) : int;

Parameters

dgram
The UDP datagram to send.
bytes
The number of bytes in the datagram to send.

Return Value

If successful, the number of bytes sent; otherwise an invalid socket error.

Exceptions

Exception Type | Condition
ArgumentException | The UDPClient is not connected to a remote host.

Remarks

System.Net.Sockets.TCPClient.Send sends the datagram to a previously connected remote host. The data is sent the Send method of the underlying Socket instance.

See Also

UDPClient Class | UDPClient Members | System.Net.Sockets Namespace | UDPClient.Send Overload List


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UDPClient Fields

The fields of the UDPClient class are listed below. For a complete list of UDPClient class members, see the UDPClient Members topic.

Protected:

Active | Used by the class to indicate that a connection to a remote host has been made.
Client | Used by the class to provide the underlying network socket.

See Also

UDPClient Class | System.Net.Sockets Namespace


UDPClient.Active

Used by the class to indicate that a connection to a remote host has been made.

[Visual Basic]
Protected Active As Boolean
[C#]
protected bool Active;
[C++]
protected: bool Active;
[JScript]
protected var Active : Boolean;

See Also

UDPClient Class | UDPClient Members | System.Net.Sockets Namespace


UDPClient.Client

Used by the class to provide the underlying network socket.

[Visual Basic]
Protected Client As Socket
[C#]
protected Socket Client;
[C++]
protected: Socket* Client;
[JScript]
protected var Client : Socket;

See Also

UDPClient Class | UDPClient Members | System.Net.Sockets Namespace | Socket


System.NewXml

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.NewXml Namespace

Classes

Class | Description
DataDocumentNavigator | Reads and writes the data in an XmlDataDocument using a cursor model.
DocumentNavigator | Reads and writes the XML data in an XmlDocument using a cursor model.
XmlAttribute | Represents an attribute of the XMLElement object. Valid and default values for the attribute are defined in a DTD or schema.
XmlAttributeCollection | Represents a collection of attributes that can be accessed by name or index.
XmlCDataSection | Used to quote or escape blocks of text to keep that text from being interpreted as markup language.
XmlCharacterData | Provides text-manipulation methods that are used by several classes.
XmlComment | Represents the content of an XML comment.
XmlDataDocument | Represents an entire document. An XmlDataDocument can contain XML data or relational data (DataSet).
XmlDocument | Represents an entire document. An XmlDocument contains XML data.
XmlDocumentFragment | Represents a lightweight object that is useful for tree insert operations.
XmlDocumentType | Contains information associated with the document type declaration.
XmlElement | Represents an element.
XmlEntity | Represents a parsed or unparsed entity in the XML document.
XmlEntityReference | Represents an entity reference node.
XmlImplementation | Provides methods for performing operations that are independent of any particular instance of the document object model.
XmlNamedNodeMap | Represents a collection of nodes that can be accessed by name or index.
XmlNavigator | Reads and writes XML data using a cursor model. This class is abstract.
XmlNode | Represents a single node in the document.
XmlNodeList | Represents an ordered collection of nodes.
XmlNotation | Contains a notation declared in the DTD or schema.
XmlProcessingInstruction | Represents a processing instruction, which XML defines to keep processor-specific information in the text of the document.
XmlReader | Represents a reader that provides fast, non-cached forward only stream access to XML data.This class is abstract.
XmlResolver | Resolves external XML resources named by a URI. This class is abstract.
XmlText | Represents the text content of an element or attribute.
XmlTextReader | Represents a reader that provides fast, non-cached forward only stream access to XML data.
XmlTextWriter | Represents a writer that provides fast non-cached forward-only way of generating XML streams containing XML documents that conform to the W3C Extensible Markup Language (XML) 1.0 specification and the Namespaces in XML specification.
XmlUrlResolver | Resolves external XML resources named by a URI.
XmlWriter | Represents a writer that provides fast non-cached forward-only way of generating XML streams containing XML documents that conform to the W3C Extensible Markup Language (XML) 1.0 specification and the Namespaces in XML specification. This class is abstract.

Interfaces

Interface | Description
XmlNameTable | Provide efficient string interning for the XML parser so that the same string object is used for all repeated element and attribute names in an XML document. This class is abstract.

Delegates

Delegate | Description
ValidationDelegate | Represents the method that handles validation error events of the System.NewXml.XmlTextReaderClass.

Enumerations

Enumeration | Description
EntityHandling | Specifies how entities are handled.
Formatting | Specifies formatting options for the XmlWriter stream.
ReadState | Specifies the state of the stream.
TreePosition | Specifies a position relative to the current node.
Validation | Specifies the type of validation to perform.
WhitespaceHandling | Specifies how whitespace is handled.
WriteState | Specifies the state of the XmlWriter stream.
XmlNodeType | Specifies the type of node.
XmlSpace | Specifies the current xml:space scope.


DataDocumentNavigator Class

Reads and writes the data in an XmlDataDocument using a cursor model.

Object
XmlNavigator
DataDocumentNavigator

[Visual Basic]
Public Class DataDocumentNavigator
   Inherits XmlNavigator
[C#]
public class DataDocumentNavigator : XmlNavigator
[C++]
public __gc class DataDocumentNavigator : public XmlNavigator
[JScript]
public class DataDocumentNavigator extends XmlNavigator

Remarks

[To be supplied.]

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator Members

Public:

Constructor

DataDocumentNavigator Constructor Initializes a new instance of the DataDocumentNavigator class to navigate over the specified XmlDataDocument.

Properties

AttributeCount | Gets the number of attributes on the current node.
ChildCount | Gets the number of child nodes for the current node.
HasAttributes | Gets a value indicating whether the current node has any attributes.
HasChildren | Gets a value indicating whether the current node has child nodes.
HasSelection (inherited from XmlNavigator) | Determines if this XmlNavigator currently has a selection set.
HasValue | Gets a value indicating whether Value has a value to return.
IndexInParent | Gets the zero-based index of this node's position in its parent node.
InnerText | Gets or sets the concatenated values of the current node and all its children.
IsDefault | Gets a value indicating whether the current node is an attribute that was generated from the default value defined in the DTD or schema.
IsEmptyTag | Gets or sets a value indicating whether the current node is an empty element (for example, <MyElement/>).
IsReadOnly | Gets a value indicating whether the current node is read-only.
LocalName | Gets the name of the node without the namespace prefix.
Name | Gets the name of the current node, including the namespace prefix.
NamespaceURI | Gets the namespace URN (as defined in the W3C Namespace Specification) of the current namespace scope.
NameTable | Gets the XmlNameTable associated with this implementation.
NodeType | Gets the type of the current node.
Prefix | Gets or sets the namespace prefix associated with the current node.
Selection (inherited from XmlNavigator) | Gets the last XPath expression used in a successful call to the Select method.
Value | Gets or sets the text value of the current node.

Methods

Clone | Creates a new XmlNavigator positioned at the same node as this DataDocumentNavigator.
Compile (inherited from XmlNavigator) | Compiles the given XPath expression and returns an object representing that expression.
CopyChildren | Copies all the children from current position of the specified XmlNavigator and inserts them at the specified position in this XmlNavigator.
CopySelected | Copies all the selected nodes from the specified XmlNavigator (as returned by MoveToNextSelected) and inserts them at the specified position in this tree.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Evaluate (inherited from XmlNavigator) | Evaluates the given expression and returns the typed result (int, boolean or string).
GetAttribute | Overloaded. Gets the value of an attribute.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
HasAttribute | Overloaded. Determines whether the current node has the specified attribute.
Insert | Overloaded. Inserts node(s) at the specified position.
IsSamePosition | Determines whether this XmlNavigator is at the same position as the specified XmlNavigator.
IsSameRow | [To be supplied.]
LookupPrefix | Looks up the prefix for the given namespace URI as defined higher up in the tree.
Matches (inherited from XmlNavigator) | Determines whether the current node matches the specified XPath expression
Move | Moves the entire subtree point to in the specified XmlNavigator to the specified position in this XmlNavigator.
MoveChildren | Moves all the children from current position of the specified XmlNavigator and inserts them at the specified position in this XmlNavigator.
MoveSelected | Moves all the selected nodes from the specified XmlNavigator (as returned by MoveToNextSelected) and inserts them at the specified position in this XmlNavigator.
MoveTo | Moves to the same position as the specified XmlNavigator.
MoveToAttribute Overloaded. Move to the specified attribute.

The MoveToAttribute methods enable you to get both random access to attributes and strongly typed access to attribute values.

To get strongly typed access to an attribute value, you must do the following:

  1. Call MoveToAttribute to move to the attribute whose value you want to access.
  2. Call Read method for the data type you want (for example, ReadBoolean for boolean, ReadDate for DateTime, and so on).

After calling MoveToAttribute, the Name, Namespace, Prefix properties will reflect the properties of that attribute.
MoveToChild | Moves to the specified child node of the current node (index 0 is the first child).
MoveToDocument | Moves to the document node that owns this node.
MoveToDocumentElement | Moves to the child element node of the owning document.
MoveToElement | Moves to the element that contains the current attribute node.
MoveToFirst | Moves to the first sibling of the current node.
MoveToFirstAttribute | Moves to the first attribute.
MoveToFirstChild | Moves to the first child of the current node.
MoveToFirstSelected (inherited from XmlNavigator) | Moves the XmlNavigator to the first node in the selected set.
MoveToId | Moves to the node with an ID attribute whose value matches the specified string.
MoveToLast | Moves to the last sibling of the current node.
MoveToLastChild | Moves to the last child of the current node.
MoveToLastSelected (inherited from XmlNavigator) | Moves the XmlNavigator to the last node in the selected set.
MoveToNext | Moves to the next sibling of the current node.
MoveToNextAttribute | Moves to the next attribute.
MoveToNextSelected (inherited from XmlNavigator) | Moves the XmlNavigator to the next node in the selected set.
MoveToParent | Moves to the parent of the current node.
MoveToPrevious | Moves to the previous sibling of the current node.
MoveToPreviousSelected (inherited from XmlNavigator) | Moves the XmlNavigator to the previous node in the selected set.
MoveToRow | [To be supplied.]
PopPosition | Moves the XmlNavigator back to a previously pushed position and pops that saved position off the stack.
PushPosition | Saves the current position.
Remove | Overloaded. Removes the specified node(s).
RemoveSelected | Removes all the selected nodes.
Select (inherited from XmlNavigator) | Selects a new set of "records" using the specified XPath expression.
SelectSingle (inherited from XmlNavigator) | Selects the first node that matches the specified expression.
SetAttribute | Overloaded. Sets the value of the specified attribute.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

MemberwiseClone (inherited from Object) Creates a shallow copy of the current Object.

See Also

DataDocumentNavigator Class | System.NewXml Namespace


DataDocumentNavigator Constructor

Initializes a new instance of the DataDocumentNavigator class to navigate over the specified XmlDataDocument.

[Visual Basic]
Public Sub New( _
   ByVal doc As XmlDataDocument _
)
[C#]
public DataDocumentNavigator(
   XmlDataDocument doc
);
[C++]
public: DataDocumentNavigator(
   XmlDataDocument* doc
);
[JScript]
public function DataDocumentNavigator(
   doc : XmlDataDocument
);

Parameters

doc
The XmlDataDocument on which you want to use DataDocumentNavigator.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataDocumentNavigator Properties

The properties of the DataDocumentNavigator class are listed below. For a complete list of DataDocumentNavigator class members, see the DataDocumentNavigator Members topic.

Public:

AttributeCount | Gets the number of attributes on the current node.
ChildCount | Gets the number of child nodes for the current node.
HasAttributes | Gets a value indicating whether the current node has any attributes.
HasChildren | Gets a value indicating whether the current node has child nodes.
HasSelection (inherited from XmlNavigator) | Determines if this XmlNavigator currently has a selection set.
HasValue | Gets a value indicating whether Value has a value to return.
IndexInParent | Gets the zero-based index of this node's position in its parent node.
InnerText | Gets or sets the concatenated values of the current node and all its children.
IsDefault | Gets a value indicating whether the current node is an attribute that was generated from the default value defined in the DTD or schema.
IsEmptyTag | Gets or sets a value indicating whether the current node is an empty element (for example, <MyElement/>).
IsReadOnly | Gets a value indicating whether the current node is read-only.
LocalName | Gets the name of the node without the namespace prefix.
Name | Gets the name of the current node, including the namespace prefix.
NamespaceURI | Gets the namespace URN (as defined in the W3C Namespace Specification) of the current namespace scope.
NameTable | Gets the XmlNameTable associated with this implementation.
NodeType | Gets the type of the current node.
Prefix | Gets or sets the namespace prefix associated with the current node.
Selection (inherited from XmlNavigator) | Gets the last XPath expression used in a successful call to the Select method.
Value | Gets or sets the text value of the current node.

See Also

DataDocumentNavigator Class | System.NewXml Namespace


DataDocumentNavigator.AttributeCount

Gets the number of attributes on the current node.

[Visual Basic]
Overridable Public ReadOnly Property AttributeCount As Integer
[C#]
public int AttributeCount {override get;}
[C++]
public: __property virtual int get_AttributeCount();
[JScript]
public function get AttributeCount() : int;

Property Value

Count of attributes on the current node.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.ChildCount

Gets the number of child nodes for the current node.

[Visual Basic]
Overridable Public ReadOnly Property ChildCount As Integer
[C#]
public int ChildCount {override get;}
[C++]
public: __property virtual int get_ChildCount();
[JScript]
public function get ChildCount() : int;

Property Value

The number of child nodes for the current node.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.HasAttributes

Gets a value indicating whether the current node has any attributes.

[Visual Basic]
Overridable Public ReadOnly Property HasAttributes As Boolean
[C#]
public bool HasAttributes {override get;}
[C++]
public: __property virtual bool get_HasAttributes();
[JScript]
public function get HasAttributes() : Boolean;

Property Value

true if the current node has attributes; otherwise, false.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.HasChildren

Gets a value indicating whether the current node has child nodes.

[Visual Basic]
Overridable Public ReadOnly Property HasChildren As Boolean
[C#]
public bool HasChildren {override get;}
[C++]
public: __property virtual bool get_HasChildren();
[JScript]
public function get HasChildren() : Boolean;

Property Value

true if the current node has child nodes; otherwise, false.

Remarks

This is potentially more efficient than using the ChildCount property.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.HasValue

Gets a value indicating whether Value has a value to return.

[Visual Basic]
Overridable Public ReadOnly Property HasValue As Boolean
[C#]
public bool HasValue {override get;}
[C++]
public: __property virtual bool get_HasValue();
[JScript]
public function get HasValue() : Boolean;

Property Value

true if Value has a value to return or if any more content can be returned from the partial content read methods; otherwise, false.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.IndexInParent

Gets the zero-based index of this node's position in its parent node.

[Visual Basic]
Overridable Public ReadOnly Property IndexInParent As Integer
[C#]
public int IndexInParent {override get;}
[C++]
public: __property virtual int get_IndexInParent();
[JScript]
public function get IndexInParent() : int;

Property Value

The index position of this node within its parent node.

Returns-1 if there is no parent node. You can, therefore, use this to find out whether there is a parent node for the current node.

Remarks

For attributes, this property returns the index in the list of attributes. For child elements, it returns the index in the list of child nodes. The following is always true (assuming the tree is not changed in the middle of the execution of this code):

[C#]

DocumentNavigator other = this.Clone();
other.MoveToParent();
other.MoveToChild( this.IndexInParent );
Assert(other.IsSame(this) == true);

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.InnerText

Gets or sets the concatenated values of the current node and all its children.

[Visual Basic]
Overridable Public Property InnerText As String
[C#]
public string InnerText {override get; override set;}
[C++]
public: __property virtual String* get_InnerText();
public: __property virtual void set_InnerText(String*);
[JScript]
public function get InnerText() : String;
public function set InnerText(String);

Property Value

The concatenated values of the current node and all its children.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.IsDefault

Gets a value indicating whether the current node is an attribute that was generated from the default value defined in the DTD or schema.

[Visual Basic]
Overridable Public ReadOnly Property IsDefault As Boolean
[C#]
public bool IsDefault {override get;}
[C++]
public: __property virtual bool get_IsDefault();
[JScript]
public function get IsDefault() : Boolean;

Property Value

true if the the current node is an attribute whose value was generated from the default value defined in the DTD or schema.

false if the attribute's value was explicitly specified in the XML stream.

Remarks

This property applies only to an attribute node.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.IsEmptyTag

Gets or sets a value indicating whether the current node is an empty element (for example, <MyElement/>).

[Visual Basic]
Overridable Public Property IsEmptyTag As Boolean
[C#]
public bool IsEmptyTag {override get; override set;}
[C++]
public: __property virtual bool get_IsEmptyTag();
public: __property virtual void set_IsEmptyTag(bool);
[JScript]
public function get IsEmptyTag() : Boolean;
public function set IsEmptyTag(Boolean);

Property Value

true if the current node is an element (NodeType equals Element) that ends with "/>"; otherwise, false.

Remarks

This property enables you to determine the difference between the following:

<foo bar="123"/> (IsEmptyTag is true).

<foo bar="123"> (IsEmptyTag is false)

Note that a corresponding EndTag element is not generated for empty elements.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.IsReadOnly

Gets a value indicating whether the current node is read-only.

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {override get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;

Property Value

true if the the current node is read-only.

false if the node is read/write.

Remarks

A read-only node is one that you cannot change any of its properties, attributes, or children. But you can remove it from the tree and insert it somewhere else. For example, the node for an EntityReference is typically read-only because its children actually come from the DTD definition of that entity and typically the DTD is read-only.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.LocalName

Gets the name of the node without the namespace prefix.

[Visual Basic]
Overridable Public ReadOnly Property LocalName As String
[C#]
public string LocalName {override get;}
[C++]
public: __property virtual String* get_LocalName();
[JScript]
public function get LocalName() : String;

Property Value

The name of the node with the prefix removed. For example, LocalName is yyy for the element <xxx:yyy>.

The name returned is dependent on the NodeType of the node:

Type | Name
Attribute | name of attribute
CDATA | #cdata-section
Comment | #comment
Document | #document
DocumentFragment | #document-fragment
DocumentType | document type name
Element | tag name
Entity | entity name
EntityReference | name of entity referenced
Notation | notation name
ProcessingInstruction | target
Text | #text

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.Name

Gets the name of the current node, including the namespace prefix.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {override get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

Property Value

Name of the current node. The name returned depends on the NodeType of the current node.

XmlNodeType | Property Value
Attribute | Contains the name of the attribute.
CDATA | Contains the literal string "#cdata-section".
Comment | Contains the literal string "#comment".
Document | Contains the literal string "#document".
DocumentType | Contains the name of the document type; for example, xxx in <!DOCTYPE xxx ...>.
DocumentFragment | Contains the literal string "#document-fragment".
Element | Contains the name of the XML tag, with any namespace prefix included if present.
Entity | Contains the name of the entity.
EntityReference | Contains the name of the entity referenced. Note that the name does not include the leading ampersand or the trailing semicolon. The name includes the namespace if one is present.
Notation | Contains the name of the notation.
ProcessingInstruction | Contains the target; the first token following the <? characters.
Text | Contains the literal string "#text".

String.Empty is returned if current node/record has no value to return.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.NamespaceURI

Gets the namespace URN (as defined in the W3C Namespace Specification) of the current namespace scope.

[Visual Basic]
Overridable Public ReadOnly Property NamespaceURI As String
[C#]
public string NamespaceURI {override get;}
[C++]
public: __property virtual String* get_NamespaceURI();
[JScript]
public function get NamespaceURI() : String;

Property Value

The namespace URN of the current namespace scope.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.NameTable

Gets the XmlNameTable associated with this implementation.

[Visual Basic]
Overridable Public ReadOnly Property NameTable As XmlNameTable
[C#]
public XmlNameTable NameTable {override get;}
[C++]
public: __property virtual XmlNameTable* get_NameTable();
[JScript]
public function get NameTable() : XmlNameTable;

Property Value

XmlNameTable enabling you to get the atomized version of a string within the node.

Remarks

All node and attribute names returned from this class are atomized using this nametable. This means that when the same name is returned multiple times (like "Customer"), then the same String object will be returned for that name. This makes it possible for you to write efficient code that does object pointer comparisons on these strings instead of expensive string comparisons.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.NodeType

Gets the type of the current node.

[Visual Basic]
Overridable Public ReadOnly Property NodeType As XmlNodeType
[C#]
public XmlNodeType NodeType {override get;}
[C++]
public: __property virtual XmlNodeType get_NodeType();
[JScript]
public function get NodeType() : XmlNodeType;

Property Value

One of the XmlNodeType values.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.Prefix

Gets or sets the namespace prefix associated with the current node.

[Visual Basic]
Overridable Public Property Prefix As String
[C#]
public string Prefix {override get; override set;}
[C++]
public: __property virtual String* get_Prefix();
public: __property virtual void set_Prefix(String*);
[JScript]
public function get Prefix() : String;
public function set Prefix(String);

Property Value

The namespace prefix associated with the current node.

String.Empty if current node/record has no value to return (never returns null).

Remarks

Setting this prefix has the same semantics as the W3C DOM.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.Value

Gets or sets the text value of the current node.

[Visual Basic]
Overridable Public Property Value As String
[C#]
public string Value {override get; override set;}
[C++]
public: __property virtual String* get_Value();
public: __property virtual void set_Value(String*);
[JScript]
public function get Value() : String;
public function set Value(String);

Property Value

The text value of the current node.

Same semantics as W3C DOM NodeValue property. Returns null for Element and Document nodes.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DataDocumentNavigator Methods

The methods of the DataDocumentNavigator class are listed below. For a complete list of DataDocumentNavigator class members, see the DataDocumentNavigator Members topic.

Public:

Clone | Creates a new XmlNavigator positioned at the same node as this DataDocumentNavigator.
Compile (inherited from XmlNavigator) | Compiles the given XPath expression and returns an object representing that expression.
CopyChildren | Copies all the children from current position of the specified XmlNavigator and inserts them at the specified position in this XmlNavigator.
CopySelected | Copies all the selected nodes from the specified XmlNavigator (as returned by MoveToNextSelected) and inserts them at the specified position in this tree.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Evaluate (inherited from XmlNavigator) | Evaluates the given expression and returns the typed result (int, boolean or string).
GetAttribute | Overloaded. Gets the value of an attribute.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
HasAttribute | Overloaded. Determines whether the current node has the specified attribute.
Insert | Overloaded. Inserts node(s) at the specified position.
IsSamePosition | Determines whether this XmlNavigator is at the same position as the specified XmlNavigator.
IsSameRow | [To be supplied.]
LookupPrefix | Looks up the prefix for the given namespace URI as defined higher up in the tree.
Matches (inherited from XmlNavigator) | Determines whether the current node matches the specified XPath expression
Move | Moves the entire subtree point to in the specified XmlNavigator to the specified position in this XmlNavigator.
MoveChildren | Moves all the children from current position of the specified XmlNavigator and inserts them at the specified position in this XmlNavigator.
MoveSelected | Moves all the selected nodes from the specified XmlNavigator (as returned by MoveToNextSelected) and inserts them at the specified position in this XmlNavigator.
MoveTo | Moves to the same position as the specified XmlNavigator.
MoveToAttribute Overloaded. Move to the specified attribute.

The MoveToAttribute methods enable you to get both random access to attributes and strongly typed access to attribute values.

To get strongly typed access to an attribute value, you must do the following:

  1. Call MoveToAttribute to move to the attribute whose value you want to access.
  2. Call Read method for the data type you want (for example, ReadBoolean for boolean, ReadDate for DateTime, and so on).

After calling MoveToAttribute, the Name, Namespace, Prefix properties will reflect the properties of that attribute.
MoveToChild | Moves to the specified child node of the current node (index 0 is the first child).
MoveToDocument | Moves to the document node that owns this node.
MoveToDocumentElement | Moves to the child element node of the owning document.
MoveToElement | Moves to the element that contains the current attribute node.
MoveToFirst | Moves to the first sibling of the current node.
MoveToFirstAttribute | Moves to the first attribute.
MoveToFirstChild | Moves to the first child of the current node.
MoveToFirstSelected (inherited from XmlNavigator) | Moves the XmlNavigator to the first node in the selected set.
MoveToId | Moves to the node with an ID attribute whose value matches the specified string.
MoveToLast | Moves to the last sibling of the current node.
MoveToLastChild | Moves to the last child of the current node.
MoveToLastSelected (inherited from XmlNavigator) | Moves the XmlNavigator to the last node in the selected set.
MoveToNext | Moves to the next sibling of the current node.
MoveToNextAttribute | Moves to the next attribute.
MoveToNextSelected (inherited from XmlNavigator) | Moves the XmlNavigator to the next node in the selected set.
MoveToParent | Moves to the parent of the current node.
MoveToPrevious | Moves to the previous sibling of the current node.
MoveToPreviousSelected (inherited from XmlNavigator) | Moves the XmlNavigator to the previous node in the selected set.
MoveToRow | [To be supplied.]
PopPosition | Moves the XmlNavigator back to a previously pushed position and pops that saved position off the stack.
PushPosition | Saves the current position.
Remove | Overloaded. Removes the specified node(s).
RemoveSelected | Removes all the selected nodes.
Select (inherited from XmlNavigator) | Selects a new set of "records" using the specified XPath expression.
SelectSingle (inherited from XmlNavigator) | Selects the first node that matches the specified expression.
SetAttribute | Overloaded. Sets the value of the specified attribute.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

MemberwiseClone (inherited from Object) Creates a shallow copy of the current Object.

See Also

DataDocumentNavigator Class | System.NewXml Namespace


DataDocumentNavigator.Clone

Creates a new XmlNavigator positioned at the same node as this DataDocumentNavigator.

[Visual Basic]
Overrides Public Function Clone() As XmlNavigator
[C#]
public override XmlNavigator Clone();
[C++]
public: override XmlNavigator* Clone();
[JScript]
public override function Clone() : XmlNavigator;

Return Value

A new XmlNavigator object.

Remarks

The new XmlNavigator that is returned is not affected by subsequent changes to the current DataDocumentNavigator.

The Clone method does not clone all the selection and push/pop states. The cloned XmlNavigator has the same "liveness" behavior as this DocumentNavigator.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.CopyChildren

Copies all the children from current position of the specified XmlNavigator and inserts them at the specified position in this XmlNavigator.

[Visual Basic]
Overrides Public Sub CopyChildren( _
   ByVal p As TreePosition, _
   ByVal other As XmlNavigator _
)
[C#]
public override void CopyChildren(
   TreePosition p,
   XmlNavigator other
);
[C++]
public: override void CopyChildren(
   TreePosition p,
   XmlNavigator* other
);
[JScript]
public override function CopyChildren(
   p : TreePosition,
   other : XmlNavigator
);

Parameters

p
The specified position where the new nodes be copied. The position None does a Replace operation.
other
The source of the new nodes.

Exceptions

Exception Type | Condition
InvalidArgument | The child nodes in other specify nodes with an XmlNodeType that can not be inserted at position p.
InvalidArgument | The child nodes in other specify nodes with an XmlNodeType that can not be inserted at position p.
InvalidArgument | The child nodes in other specify nodes with an XmlNodeType that can not be inserted at position p.
InvalidArgument | The child nodes in other specify nodes with an XmlNodeType that can not be inserted at position p.
InvalidArgument | The child nodes in other specify nodes with an XmlNodeType that can not be inserted at position p.

Remarks

This XmlNavigator's position is unaffected by this operation.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.CopySelected

Copies all the selected nodes from the specified XmlNavigator (as returned by MoveToNextSelected) and inserts them at the specified position in this tree.

[Visual Basic]
Overrides Public Sub CopySelected( _
   ByVal p As TreePosition, _
   ByVal other As XmlNavigator _
)
[C#]
public override void CopySelected(
   TreePosition p,
   XmlNavigator other
);
[C++]
public: override void CopySelected(
   TreePosition p,
   XmlNavigator* other
);
[JScript]
public override function CopySelected(
   p : TreePosition,
   other : XmlNavigator
);

Parameters

p
The specified position where the new nodes will be copied. The position None does a Replace operation.
other
The source of the new nodes.

Exceptions

Exception Type | Condition
InvalidArgument | The child nodes in other specify nodes with an XmlNodeType that can not be inserted at position p.

Remarks

This XmlNavigator's position is unaffected by this operation.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.GetAttribute

Gets the value of an attribute.

Overload List

Gets the value of the attribute with the specified index.

[Visual Basic] Overloads Overrides Public Function GetAttribute(Integer) As String
[C#] public override string GetAttribute(int);
[C++] public: override String* GetAttribute(int);
[JScript] public override function GetAttribute(int) : String;

Gets the value of the attribute with the specified name and namespace.

[Visual Basic] Overloads Overrides Public Function GetAttribute(String, String) As String
[C#] public override string GetAttribute(String, String);
[C++] public: override String* GetAttribute(String*, String*);
[JScript] public override function GetAttribute(String, String) : String;

Gets the value of the attribute with the specified name.

[Visual Basic] Overloads Overrides Public Function GetAttribute(String) As String
[C#] public override string GetAttribute(String);
[C++] public: override String* GetAttribute(String*);
[JScript] public override function GetAttribute(String) : String;

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.GetAttribute (Int32)

Gets the value of the attribute with the specified index.

[Visual Basic]
Overloads Overrides Public Function GetAttribute( _
   ByVal i As Integer _
) As String
[C#]
public override string GetAttribute(
   int i
);
[C++]
public: override String* GetAttribute(
   int i
);
[JScript]
public override function GetAttribute(
   i : int
) : String;

Parameters

i
The index of the attribute. The index is zero-based (first attribute has index 0).

Return Value

The value of the specified attribute.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | The i parameter is less than 0 or greater than or equal to AttributeCount.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace | DataDocumentNavigator.GetAttribute Overload List


DataDocumentNavigator.GetAttribute (String, String)

Gets the value of the attribute with the specified name and namespace.

[Visual Basic]
Overloads Overrides Public Function GetAttribute( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As String
[C#]
public override string GetAttribute(
   string localName,
   string namespaceURI
);
[C++]
public: override String* GetAttribute(
   String* localName,
   String* namespaceURI
);
[JScript]
public override function GetAttribute(
   localName : String,
   namespaceURI : String
) : String;

Parameters

localName
The name of the attribute.
namespaceURI
The URN of the namespace of the attribute.

Return Value

The value of the specified attribute.

Exceptions

Exception Type | Condition
ArgumentException | The attribute specified by localName and namespaceURI properties cannot be found in the current node.

Remarks

The following XML contains an attribute in a specific namespace:

<test xmlns:dt="urn:datatypes" dt:type="int"/>

You can lookup the dt:type attribute using one argument (using Prefix+LocalName) or using two arguments (LocalName and NamespaceURI):

String dt = reader.GetAttribute("dt:type");

String dt2 = reader.GetAttribute("type","urn:datatypes");

Note that the xmlns attributes have no namespace URI; therefore, the only way to look them up is with the short version

String dt3 = reader.GetAttribute("xmlns:dt");

You can also get this information using the Prefix property.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace | DataDocumentNavigator.GetAttribute Overload List


DataDocumentNavigator.GetAttribute (String)

Gets the value of the attribute with the specified name.

[Visual Basic]
Overloads Overrides Public Function GetAttribute( _
   ByVal name As String _
) As String
[C#]
public override string GetAttribute(
   string name
);
[C++]
public: override String* GetAttribute(
   String* name
);
[JScript]
public override function GetAttribute(
   name : String
) : String;

Parameters

name
The name of the attribute. The name can include the prefix or leave it off.

Return Value

Empty string if currentnode/recordhas no value to return (never returns null).

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace | DataDocumentNavigator.GetAttribute Overload List


DataDocumentNavigator.HasAttribute

Determines whether the current node has the specified attribute.

Overload List

Determines whether the current node has the specified attribute from the specified namespace.

[Visual Basic] Overloads Overrides Public Function HasAttribute(String, String) As Boolean
[C#] public override bool HasAttribute(String, String);
[C++] public: override bool HasAttribute(String*, String*);
[JScript] public override function HasAttribute(String, String) : Boolean;

Determines whether the current node has the specified attribute.

[Visual Basic] Overloads Overrides Public Function HasAttribute(String) As Boolean
[C#] public override bool HasAttribute(String);
[C++] public: override bool HasAttribute(String*);
[JScript] public override function HasAttribute(String) : Boolean;

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.HasAttribute (String, String)

Determines whether the current node has the specified attribute from the specified namespace.

[Visual Basic]
Overloads Overrides Public Function HasAttribute( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Boolean
[C#]
public override bool HasAttribute(
   string localName,
   string namespaceURI
);
[C++]
public: override bool HasAttribute(
   String* localName,
   String* namespaceURI
);
[JScript]
public override function HasAttribute(
   localName : String,
   namespaceURI : String
) : Boolean;

Parameters

localName
[To be supplied.]
namespaceURI
The name of the namespace of the attribute to find.

Return Value

true if the current node has the specified attribute; otherwise, false.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace | DataDocumentNavigator.HasAttribute Overload List


DataDocumentNavigator.HasAttribute (String)

Determines whether the current node has the specified attribute.

[Visual Basic]
Overloads Overrides Public Function HasAttribute( _
   ByVal name As String _
) As Boolean
[C#]
public override bool HasAttribute(
   string name
);
[C++]
public: override bool HasAttribute(
   String* name
);
[JScript]
public override function HasAttribute(
   name : String
) : Boolean;

Parameters

name
The name of the attribute to find.

Return Value

true if the current node has the specified attribute; otherwise, false.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace | DataDocumentNavigator.HasAttribute Overload List


DataDocumentNavigator.Insert

Inserts node(s) at the specified position.

Overload List

Inserts a copy of the node or nodes represented by the specified object into the specified position and moves to the root of the newly inserted nodes.

[Visual Basic] Overloads Overrides Public Sub Insert(TreePosition, Object, Type)
[C#] public override void Insert(TreePosition, Object, Type);
[C++] public: override void Insert(TreePosition, Object, Type);
[JScript] public override function Insert(TreePosition, Object, Type);

Creates a new node and inserts it at the specified position in the tree relative to the current position and moves the navigator to point at this newly inserted node.

[Visual Basic] Overloads Overrides Public Sub Insert(TreePosition, XmlNodeType, String, String, String)
[C#] public override void Insert(TreePosition, XmlNodeType, String, String, String);
[C++] public: override void Insert(TreePosition, XmlNodeType, String, String, String);
[JScript] public override function Insert(TreePosition, XmlNodeType, String, String, String);

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.Insert (TreePosition, Object, Type)

Inserts a copy of the node or nodes represented by the specified object into the specified position and moves to the root of the newly inserted nodes.

[Visual Basic]
Overloads Overrides Public Sub Insert( _
   ByVal p As TreePosition, _
   ByVal obj As Object, _
   ByVal type As Type _
)
[C#]
public override void Insert(
   TreePosition p,
   object obj,
   Type type
);
[C++]
public: override void Insert(
   TreePosition p,
   Object* obj,
   Type* type
);
[JScript]
public override function Insert(
   p : TreePosition,
   obj : Object,
   type : Type
);

Parameters

p
The position of the new node relative to the current node. The position "None" means the new node is not inserted into the tree- but instead is left dangling with no parent. This is the only valid way to create DocumentFragment nodes.
obj
The object that contains the new nodes to be inserted.
type
The type of object. Optional. This parameter is only used to specify which interface to use if the object implements multiple interfaces. If type is null, the "instanceof" operator is used to determine the type.

A type of XmlNavigator copies the entire subtree pointed at by the other XmlNavigator object. The other XmlNavigator will not be moved.

Exceptions

Exception Type | Condition
ArgumentException | The object specifies a node with an XmlNodeType that can not be inserted at position p. For example, if the position specified is "Parent" then the NodeType of the new node cannot be Attribute, CDATA or Text or Comment. The specified XmlNodeType requires a name and no name was provided. The type argument is not one of the above.

Remarks

Inserting a subtree into the Parent position results in the current node becoming the first child of the new parent.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace | DataDocumentNavigator.Insert Overload List


DataDocumentNavigator.Insert (TreePosition, XmlNodeType, String, String, String)

Creates a new node and inserts it at the specified position in the tree relative to the current position and moves the navigator to point at this newly inserted node.

[Visual Basic]
Overloads Overrides Public Sub Insert( _
   ByVal p As TreePosition, _
   ByVal nt As XmlNodeType, _
   ByVal localName As String, _
   ByVal namespaceURI As String, _
   ByVal prefix As String _
)
[C#]
public override void Insert(
   TreePosition p,
   XmlNodeType nt,
   string localName,
   string namespaceURI,
   string prefix
);
[C++]
public: override void Insert(
   TreePosition p,
   XmlNodeType nt,
   String* localName,
   String* namespaceURI,
   String* prefix
);
[JScript]
public override function Insert(
   p : TreePosition,
   nt : XmlNodeType,
   localName : String,
   namespaceURI : String,
   prefix : String
);

Parameters

p
The relative position of the new node. The position "None" means the new node is not inserted into the tree- but instead is left dangling with no parent. This is the only valid way to create DocumentFragment nodes.
nt
[To be supplied.]
localName
The local name of the new node (if any). For nodes that have no name, this is null.
namespaceURI
The namespace URI for the new node (if any). For nodes that have no name, this is null or empty. Null and String.Empty mean the same thing.
prefix
The namespace prefix of the new node (if any). For nodes that have no name, this is null. You can use the LookupPrefix method to find out what the prefix is for a given namespace URI. The XmlNavigator does not do this automatically for performance reasons. Null and String.Empty mean the same thing.

Exceptions

Exception Type | Condition
ArgumentException | The nt parameter specifies an XmlNodeType that can not be inserted at position p. For example, if the position specified is "Parent" then the NodeType of the new node cannot be Attribute, CDATA or Text or Comment. The specified XmlNodeType requires a name and no name was provided. The XmlNodeType has no Name and a name, namespaceURI, or prefix was provided.

Remarks

TBD--Add NodeType table here.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace | DataDocumentNavigator.Insert Overload List


DataDocumentNavigator.IsSamePosition

Determines whether this XmlNavigator is at the same position as the specified XmlNavigator.

[Visual Basic]
Overrides Public Function IsSamePosition( _
   ByVal other As XmlNavigator _
) As Boolean
[C#]
public override bool IsSamePosition(
   XmlNavigator other
);
[C++]
public: override bool IsSamePosition(
   XmlNavigator* other
);
[JScript]
public override function IsSamePosition(
   other : XmlNavigator
) : Boolean;

Parameters

other
XmlNavigator with which you want to compare position.

Return Value

true if this XmlNavigator is at the same position as the specified XmlNavigator; otherwise, false.

Remarks

This also implies the other XmlNavigator is the same kind of XmlNavigator pointing at the same document instance.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.IsSameRow

[To be supplied.]

[Visual Basic]
Public Function IsSameRow( _
   ByVal row As DataRow _
) As Boolean
[C#]
public bool IsSameRow(
   DataRow row
);
[C++]
public: bool IsSameRow(
   DataRow* row
);
[JScript]
public function IsSameRow(
   row : DataRow
) : Boolean;

Parameters

row
[To be supplied.]

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.LookupPrefix

Looks up the prefix for the given namespace URI as defined higher up in the tree.

[Visual Basic]
Overrides Public Function LookupPrefix( _
   ByVal namespaceURI As String _
) As String
[C#]
public override string LookupPrefix(
   string namespaceURI
);
[C++]
public: override String* LookupPrefix(
   String* namespaceURI
);
[JScript]
public override function LookupPrefix(
   namespaceURI : String
) : String;

Parameters

namespaceURI
[To be supplied.]

Return Value

The prefix atomized string. Or a null reference (in Visual Basic Nothing) if not found.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.Move

Moves the entire subtree point to in the specified XmlNavigator to the specified position in this XmlNavigator.

[Visual Basic]
Overrides Public Sub Move( _
   ByVal p As TreePosition, _
   ByVal other As XmlNavigator _
)
[C#]
public override void Move(
   TreePosition p,
   XmlNavigator other
);
[C++]
public: override void Move(
   TreePosition p,
   XmlNavigator* other
);
[JScript]
public override function Move(
   p : TreePosition,
   other : XmlNavigator
);

Parameters

p
The specified position where the new nodes will be moved. The position None does a Replace operation.
other
XmlNavigator containing the source of the new nodes.

Exceptions

Exception Type | Condition
ArgumentException | The other XmlNavigator is pointing at read/only nodes (like the children of an entity reference). It can point to an entity reference and thereby move the entire entity reference- but it cannot point at the children of an entity reference.

Remarks

This XmlNavigator's position is unaffected by this operation.

The other XmlNavigator remains pointing at the same node. This means it is essentially moved over to this tree in the process.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.MoveChildren

Moves all the children from current position of the specified XmlNavigator and inserts them at the specified position in this XmlNavigator.

[Visual Basic]
Overrides Public Sub MoveChildren( _
   ByVal p As TreePosition, _
   ByVal other As XmlNavigator _
)
[C#]
public override void MoveChildren(
   TreePosition p,
   XmlNavigator other
);
[C++]
public: override void MoveChildren(
   TreePosition p,
   XmlNavigator* other
);
[JScript]
public override function MoveChildren(
   p : TreePosition,
   other : XmlNavigator
);

Parameters

p
The specified position where the new nodes will be copied. The position None does a Replace operation.
other
The source of the new nodes.

Exceptions

Exception Type | Condition
ArgumentException | The other XmlNavigator is pointing at read/only nodes (like the children of an entity reference). It can point to an entity reference and thereby move the entire entity reference- but it cannot point at the children of an entity reference.

Remarks

This XmlNavigator's position is unaffected by this operation.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.MoveSelected

Moves all the selected nodes from the specified XmlNavigator (as returned by MoveToNextSelected) and inserts them at the specified position in this XmlNavigator.

[Visual Basic]
Overrides Public Sub MoveSelected( _
   ByVal p As TreePosition, _
   ByVal other As XmlNavigator _
)
[C#]
public override void MoveSelected(
   TreePosition p,
   XmlNavigator other
);
[C++]
public: override void MoveSelected(
   TreePosition p,
   XmlNavigator* other
);
[JScript]
public override function MoveSelected(
   p : TreePosition,
   other : XmlNavigator
);

Parameters

p
The specified position where the new nodes will end up. The position None does a Replace operation.
other
The source of the new nodes.

Exceptions

Exception Type | Condition
ArgumentException | The other XmlNavigator is pointing at read/only nodes (like the children of an entity reference). It can point to an entity reference and thereby move the entire entity reference- but it cannot point at the children of an entity reference.

Remarks

This XmlNavigator's position is unaffected by this operation.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.MoveTo

Moves to the same position as the specified XmlNavigator.

[Visual Basic]
Overrides Public Function MoveTo( _
   ByVal other As XmlNavigator _
) As Boolean
[C#]
public override bool MoveTo(
   XmlNavigator other
);
[C++]
public: override bool MoveTo(
   XmlNavigator* other
);
[JScript]
public override function MoveTo(
   other : XmlNavigator
) : Boolean;

Parameters

other
XmlNavigator with the position you want to move this XmlNavigator to.

Return Value

TBD. Throws an exception if the two XmlNavigator objects are incompatible.

Remarks

The XmlNavigator is in the 'null' state when it temporarily points to no node. You can get out of this state by using MoveTo(XmlNavigator) or MoveToDocument. You can find out that you are in the Null state because NodeType returns 0.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.MoveToAttribute

Move to the specified attribute.

The MoveToAttribute methods enable you to get both random access to attributes and strongly typed access to attribute values.

To get strongly typed access to an attribute value, you must do the following:

  1. Call MoveToAttribute to move to the attribute whose value you want to access.
  2. Call Read method for the data type you want (for example, ReadBoolean for boolean, ReadDate for DateTime, and so on).

After calling MoveToAttribute, the Name, Namespace, Prefix properties will reflect the properties of that attribute.

Overload List

Moves to the attribute with the specified name.

[Visual Basic] Overloads Overrides Public Function MoveToAttribute(String) As Boolean
[C#] public override bool MoveToAttribute(String);
[C++] public: override bool MoveToAttribute(String*);
[JScript] public override function MoveToAttribute(String) : Boolean;

Moves to the attribute with the specified index.

[Visual Basic] Overloads Overrides Public Function MoveToAttribute(Integer) As Boolean
[C#] public override bool MoveToAttribute(int);
[C++] public: override bool MoveToAttribute(int);
[JScript] public override function MoveToAttribute(int) : Boolean;

Move to the attribute with matching name and namespace.

[Visual Basic] Overloads Overrides Public Function MoveToAttribute(String, String) As Boolean
[C#] public override bool MoveToAttribute(String, String);
[C++] public: override bool MoveToAttribute(String*, String*);
[JScript] public override function MoveToAttribute(String, String) : Boolean;

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.MoveToAttribute (String)

Moves to the attribute with the specified name.

[Visual Basic]
Overloads Overrides Public Function MoveToAttribute( _
   ByVal name As String _
) As Boolean
[C#]
public override bool MoveToAttribute(
   string name
);
[C++]
public: override bool MoveToAttribute(
   String* name
);
[JScript]
public override function MoveToAttribute(
   name : String
) : Boolean;

Parameters

name
The name of the attribute. The name can include the prefix or leave it off.

Return Value

true if the attribute is found; otherwise, false. If false, the DocumentNavigator's position does not change.

Exceptions

Exception Type | Condition
ArgumentException | The attribute specified by name cannot be found in the current node.

Remarks

If you are positioned on an attribute, this method will do an implicit MoveToElement before processing this method.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace | DataDocumentNavigator.MoveToAttribute Overload List


DataDocumentNavigator.MoveToAttribute (Int32)

Moves to the attribute with the specified index.

[Visual Basic]
Overloads Overrides Public Function MoveToAttribute( _
   ByVal i As Integer _
) As Boolean
[C#]
public override bool MoveToAttribute(
   int i
);
[C++]
public: override bool MoveToAttribute(
   int i
);
[JScript]
public override function MoveToAttribute(
   i : int
) : Boolean;

Parameters

i
The index of the attribute.

Return Value

true if the attribute is found; otherwise, false. If false, the reader's position does not change.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | The i parameter is less than 0 or greater than AttributeCount.

Remarks

If you are positioned on an attribute, this method will do an implicit MoveToElement before processing this method.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace | DataDocumentNavigator.MoveToAttribute Overload List


DataDocumentNavigator.MoveToAttribute (String, String)

Move to the attribute with matching name and namespace.

[Visual Basic]
Overloads Overrides Public Function MoveToAttribute( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Boolean
[C#]
public override bool MoveToAttribute(
   string localName,
   string namespaceURI
);
[C++]
public: override bool MoveToAttribute(
   String* localName,
   String* namespaceURI
);
[JScript]
public override function MoveToAttribute(
   localName : String,
   namespaceURI : String
) : Boolean;

Parameters

localName
The name of the attribute.
namespaceURI
The URN of the namespace of the attribute.

Return Value

true if the attribute is found; otherwise, false. If false, the DocumentNavigator's position does not change.

Remarks

If you are positioned on an attribute, this method will do an implicit MoveToElement before processing this method.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace | DataDocumentNavigator.MoveToAttribute Overload List


DataDocumentNavigator.MoveToChild

Moves to the specified child node of the current node (index 0 is the first child).

[Visual Basic]
Overrides Public Function MoveToChild( _
   ByVal i As Integer _
) As Boolean
[C#]
public override bool MoveToChild(
   int i
);
[C++]
public: override bool MoveToChild(
   int i
);
[JScript]
public override function MoveToChild(
   i : int
) : Boolean;

Parameters

i
The index of the child node.

Return Value

true if the specified child node exists; false if the specified child node does not exist.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.MoveToDocument

Moves to the document node that owns this node.

[Visual Basic]
Overrides Public Sub MoveToDocument()
[C#]
public override void MoveToDocument();
[C++]
public: override void MoveToDocument();
[JScript]
public override function MoveToDocument();

Remarks

All nodes belong to one and only one document; therefore, this method is guaranteed to succeed.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.MoveToDocumentElement

Moves to the child element node of the owning document.

[Visual Basic]
Overrides Public Function MoveToDocumentElement() As Boolean
[C#]
public override bool MoveToDocumentElement();
[C++]
public: override bool MoveToDocumentElement();
[JScript]
public override function MoveToDocumentElement() : Boolean;

Return Value

true if the document that owns this node currently has a child element node.

false if the document that owns this node currently has no child element node.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.MoveToElement

Moves to the element that contains the current attribute node.

[Visual Basic]
Overrides Public Function MoveToElement() As Boolean
[C#]
public override bool MoveToElement();
[C++]
public: override bool MoveToElement();
[JScript]
public override function MoveToElement() : Boolean;

Return Value

true if the attribute is owned by an element; false if the attribute you are positioned on has been removed from the owning element.

Exceptions

Exception Type | Condition
InvalidOperationException | The reader is not positioned on an attribute node.

Remarks

Use this method to return to an element after navigating through its attributes.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.MoveToFirst

Moves to the first sibling of the current node.

[Visual Basic]
Overrides Public Function MoveToFirst() As Boolean
[C#]
public override bool MoveToFirst();
[C++]
public: override bool MoveToFirst();
[JScript]
public override function MoveToFirst() : Boolean;

Return Value

true if there is a first sibling node; false if there is no first sibling.

Remarks

If you are positioned on an attribute, this method will do an implicit call to MoveToElement before processing this method. In other words, attribute navigation is orthogonal to tree navigation.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.MoveToFirstAttribute

Moves to the first attribute.

[Visual Basic]
Overrides Public Function MoveToFirstAttribute() As Boolean
[C#]
public override bool MoveToFirstAttribute();
[C++]
public: override bool MoveToFirstAttribute();
[JScript]
public override function MoveToFirstAttribute() : Boolean;

Return Value

true if the first attribute exists; otherwise, false.

Remarks

If you are positioned on an attribute, this method will do an implicit MoveToElement before processing this method.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.MoveToFirstChild

Moves to the first child of the current node.

[Visual Basic]
Overrides Public Function MoveToFirstChild() As Boolean
[C#]
public override bool MoveToFirstChild();
[C++]
public: override bool MoveToFirstChild();
[JScript]
public override function MoveToFirstChild() : Boolean;

Return Value

true if there is a first child node; false if there are no child nodes.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.MoveToId

Moves to the node with an ID attribute whose value matches the specified string.

[Visual Basic]
Overrides Public Function MoveToId( _
   ByVal id As String _
) As Boolean
[C#]
public override bool MoveToId(
   string id
);
[C++]
public: override bool MoveToId(
   String* id
);
[JScript]
public override function MoveToId(
   id : String
) : Boolean;

Parameters

id
The ID value of the node you want to move to.

Return Value

TBD. Throws IdNotFoundException if the id was not defined in the data.

Remarks

The argument does not need to be atomized. For example, suppose the DTD defined the following:

<!ATTLIST x a ID #REQUIRED >

and suppose the following XML data was loaded using this DTD:

<data> <x a="a1"/> </data>

then the following would be true:

[C#]

// "nav" pointing anywhere in the above data.
nav.MoveToId("a1");
// Now "nav" points to the element node named "x"

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.MoveToLast

Moves to the last sibling of the current node.

[Visual Basic]
Overrides Public Function MoveToLast() As Boolean
[C#]
public override bool MoveToLast();
[C++]
public: override bool MoveToLast();
[JScript]
public override function MoveToLast() : Boolean;

Return Value

true if there is a last sibling node; false if there is no last sibling.

Remarks

If you are positioned on an attribute, this method will do an implicit call to MoveToElement before processing this method. In other words, attribute navigation is orthogonal to tree navigation.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.MoveToLastChild

Moves to the last child of the current node.

[Visual Basic]
Overrides Public Function MoveToLastChild() As Boolean
[C#]
public override bool MoveToLastChild();
[C++]
public: override bool MoveToLastChild();
[JScript]
public override function MoveToLastChild() : Boolean;

Return Value

true if there is a last child node; false if there are no child nodes.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.MoveToNext

Moves to the next sibling of the current node.

[Visual Basic]
Overrides Public Function MoveToNext() As Boolean
[C#]
public override bool MoveToNext();
[C++]
public: override bool MoveToNext();
[JScript]
public override function MoveToNext() : Boolean;

Return Value

true if there is a next sibling node; false if there are no more siblings.

Remarks

If you are positioned on an attribute, this method will do an implicit call to MoveToElement before processing this method. In other words, attribute navigation is orthogonal to tree navigation.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.MoveToNextAttribute

Moves to the next attribute.

[Visual Basic]
Overrides Public Function MoveToNextAttribute() As Boolean
[C#]
public override bool MoveToNextAttribute();
[C++]
public: override bool MoveToNextAttribute();
[JScript]
public override function MoveToNextAttribute() : Boolean;

Return Value

true if there is a next attribute; false if there are no more attributes.

Remarks

If the current node is an element node, this method is equivalent to MoveToFirstAttribute.

If you are positioned on an attribute, this method will do an implicit MoveToElement before processing this method.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.MoveToParent

Moves to the parent of the current node.

[Visual Basic]
Overrides Public Function MoveToParent() As Boolean
[C#]
public override bool MoveToParent();
[C++]
public: override bool MoveToParent();
[JScript]
public override function MoveToParent() : Boolean;

Return Value

true if a parent node exists.

false if there is no parent node. This can happen if the tree is changed out from under the XmlNavigator.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.MoveToPrevious

Moves to the previous sibling of the current node.

[Visual Basic]
Overrides Public Function MoveToPrevious() As Boolean
[C#]
public override bool MoveToPrevious();
[C++]
public: override bool MoveToPrevious();
[JScript]
public override function MoveToPrevious() : Boolean;

Return Value

true if there is a previous sibling node; false if there is no previous sibling.

Remarks

If you are positioned on an attribute, this method will do an implicit call to MoveToElement before processing this method. In other words, attribute navigation is orthogonal to tree navigation.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.MoveToRow

[To be supplied.]

[Visual Basic]
Public Function MoveToRow( _
   ByVal row As DataRow _
) As Boolean
[C#]
public bool MoveToRow(
   DataRow row
);
[C++]
public: bool MoveToRow(
   DataRow* row
);
[JScript]
public function MoveToRow(
   row : DataRow
) : Boolean;

Parameters

row
[To be supplied.]

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.PopPosition

Moves the XmlNavigator back to a previously pushed position and pops that saved position off the stack.

[Visual Basic]
Overrides Public Function PopPosition() As Boolean
[C#]
public override bool PopPosition();
[C++]
public: override bool PopPosition();
[JScript]
public override function PopPosition() : Boolean;

Return Value

true if XmlNavigator moved to previous push position; false if there is no more to pop.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.PushPosition

Saves the current position.

[Visual Basic]
Overrides Public Sub PushPosition()
[C#]
public override void PushPosition();
[C++]
public: override void PushPosition();
[JScript]
public override function PushPosition();

Remarks

You can later return to this position by calling PopPosition(). Push has the same semantics as if you used Clone() and remembered the cloned XmlNavigators on your own stack.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.Remove

Removes the specified node(s).

Overload List

Removes the current node (and its entire subtree).

[Visual Basic] Overloads Overrides Public Sub Remove()
[C#] public override void Remove();
[C++] public: override void Remove();
[JScript] public override function Remove();

Removes the specified node (and its entire subtree) by relative position to the current node.

[Visual Basic] Overloads Overrides Public Sub Remove(TreePosition)
[C#] public override void Remove(TreePosition);
[C++] public: override void Remove(TreePosition);
[JScript] public override function Remove(TreePosition);

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.Remove ()

Removes the current node (and its entire subtree).

[Visual Basic]
Overloads Overrides Public Sub Remove()
[C#]
public override void Remove();
[C++]
public: override void Remove();
[JScript]
public override function Remove();

Remarks

After this method is called, the parent pointer is disconnected (so MoveToParent will return false) and the parent's ChildCount will be decremented by 1.

This XmlNavigator then stays pointing at this removed node.

If this node has already been removed and has no parent, this method has no effect.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace | DataDocumentNavigator.Remove Overload List


DataDocumentNavigator.Remove (TreePosition)

Removes the specified node (and its entire subtree) by relative position to the current node.

[Visual Basic]
Overloads Overrides Public Sub Remove( _
   ByVal p As TreePosition _
)
[C#]
public override void Remove(
   TreePosition p
);
[C++]
public: override void Remove(
   TreePosition p
);
[JScript]
public override function Remove(
   p : TreePosition
);

Parameters

p
Treeposition indicating the node to remove.

Remarks

After this method is called, the parent of the specified node is set to null. This XmlNavigator then stays pointing at this current node.

The position of "None" makes this method behave the same as Remove() with no arguments.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace | DataDocumentNavigator.Remove Overload List


DataDocumentNavigator.RemoveSelected

Removes all the selected nodes.

[Visual Basic]
Overrides Public Sub RemoveSelected()
[C#]
public override void RemoveSelected();
[C++]
public: override void RemoveSelected();
[JScript]
public override function RemoveSelected();

Remarks

If there are no selected nodes, this method has no effect.

The XmlNavigator's position is unaffected by this operation.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.SetAttribute

Sets the value of the specified attribute.

Overload List

Sets the value of the attribute with the specified index.

[Visual Basic] Overloads Overrides Public Sub SetAttribute(Integer, String)
[C#] public override void SetAttribute(int, String);
[C++] public: override void SetAttribute(int, String);
[JScript] public override function SetAttribute(int, String);

Sets the value of the attribute with the specified name and namespace.

[Visual Basic] Overloads Overrides Public Sub SetAttribute(String, String, String)
[C#] public override void SetAttribute(String, String, String);
[C++] public: override void SetAttribute(String*, String*, String*);
[JScript] public override function SetAttribute(String, String, String);

Sets the value of the attribute with the specified name.

[Visual Basic] Overloads Overrides Public Sub SetAttribute(String, String)
[C#] public override void SetAttribute(String, String);
[C++] public: override void SetAttribute(String*, String*);
[JScript] public override function SetAttribute(String, String);

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace


DataDocumentNavigator.SetAttribute (Int32, String)

Sets the value of the attribute with the specified index.

[Visual Basic]
Overloads Overrides Public Sub SetAttribute( _
   ByVal i As Integer, _
   ByVal value As String _
)
[C#]
public override void SetAttribute(
   int i,
   string value
);
[C++]
public: override void SetAttribute(
   int i,
   String* value
);
[JScript]
public override function SetAttribute(
   i : int,
   value : String
);

Parameters

i
The index of the attribute.
value
The value to set for the attribute.

Return Value

The value of the specified attribute.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | The i parameter is less than 0 or greater than AttributeCount.

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace | DataDocumentNavigator.SetAttribute Overload List


DataDocumentNavigator.SetAttribute (String, String, String)

Sets the value of the attribute with the specified name and namespace.

[Visual Basic]
Overloads Overrides Public Sub SetAttribute( _
   ByVal localName As String, _
   ByVal namespaceURI As String, _
   ByVal value As String _
)
[C#]
public override void SetAttribute(
   string localName,
   string namespaceURI,
   string value
);
[C++]
public: override void SetAttribute(
   String* localName,
   String* namespaceURI,
   String* value
);
[JScript]
public override function SetAttribute(
   localName : String,
   namespaceURI : String,
   value : String
);

Parameters

localName
The name of the attribute. The name can include the prefix or leave it off.
namespaceURI
The URN of the namespace of the attribute.
value
The value to set for the attribute.

Remarks

This name does may or may not include the prefix. For example:

[C#]

xti.SetAttribute("xmlns:x",null, nsuri);

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace | DataDocumentNavigator.SetAttribute Overload List


DataDocumentNavigator.SetAttribute (String, String)

Sets the value of the attribute with the specified name.

[Visual Basic]
Overloads Overrides Public Sub SetAttribute( _
   ByVal name As String, _
   ByVal value As String _
)
[C#]
public override void SetAttribute(
   string name,
   string value
);
[C++]
public: override void SetAttribute(
   String* name,
   String* value
);
[JScript]
public override function SetAttribute(
   name : String,
   value : String
);

Parameters

name
The name of the attribute. The name can include the prefix or leave it off.
value
[To be supplied.]

See Also

DataDocumentNavigator Class | DataDocumentNavigator Members | System.NewXml Namespace | DataDocumentNavigator.SetAttribute Overload List


DocumentNavigator Class

Reads and writes the XML data in an XmlDocument using a cursor model.

Object
XmlNavigator
DocumentNavigator

[Visual Basic]
Public Class DocumentNavigator
   Inherits XmlNavigator
[C#]
public class DocumentNavigator : XmlNavigator
[C++]
public __gc class DocumentNavigator : public XmlNavigator
[JScript]
public class DocumentNavigator extends XmlNavigator

Remarks

[To be supplied.]

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator Members

Public:

Constructor

DocumentNavigator Constructor Initializes a new instance of the DocumentNavigator class to navigate over the specified XmlDocument.

Properties

AttributeCount | Gets the number of attributes on the current node.
ChildCount | Gets the number of child nodes for the current node.
HasAttributes | Gets a value indicating whether the current node has any attributes.
HasChildren | Gets a value indicating whether the current node has child nodes.
HasSelection (inherited from XmlNavigator) | Determines if this XmlNavigator currently has a selection set.
HasValue | Gets a value indicating whether Value has a value to return.
IndexInParent | Gets the zero-based index of this node's position in its parent node.
InnerText | Gets or sets the concatenated values of the current node and all its children.
IsDefault | Gets a value indicating whether the current node is an attribute that was generated from the default value defined in the DTD or schema.
IsEmptyTag | Gets or sets a value indicating whether the current node is an empty element (for example, <MyElement/>).
IsReadOnly | Gets a value indicating whether the current node is read-only.
LocalName | Gets the name of the node without the namespace prefix.
Name | Gets the name of the current node, including the namespace prefix.
NamespaceURI | Gets the namespace URN (as defined in the W3C Namespace Specification) of the current namespace scope.
NameTable | Gets the XmlNameTable associated with this implementation.
NodeType | Gets the type of the current node.
Prefix | Gets or sets the namespace prefix associated with the current node.
Selection (inherited from XmlNavigator) | Gets the last XPath expression used in a successful call to the Select method.
Value | Gets or sets the text value of the current node.

Methods

Clone | Creates a new XmlNavigator positioned at the same node as this DocumentNavigator.
Compile (inherited from XmlNavigator) | Compiles the given XPath expression and returns an object representing that expression.
CopyChildren | Copies all the children from current position of the specified XmlNavigator and inserts them at the specified position in this XmlNavigator.
CopySelected | Copies all the selected nodes from the specified XmlNavigator (as returned by MoveToNextSelected) and inserts them at the specified position in this tree.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Evaluate (inherited from XmlNavigator) | Evaluates the given expression and returns the typed result (int, boolean or string).
GetAttribute | Overloaded. Gets the value of an attribute.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
HasAttribute | Overloaded. Determines whether the current node has the specified attribute.
Insert | Overloaded. Inserts node(s) at the specified position.
IsSamePosition | Determines whether this XmlNavigator is at the same position as the specified XmlNavigator.
LookupPrefix | Looks up the prefix for the given namespace URI as defined higher up in the tree.
Matches (inherited from XmlNavigator) | Determines whether the current node matches the specified XPath expression
Move | Moves the entire subtree point to in the specified XmlNavigator to the specified position in this XmlNavigator.
MoveChildren | Moves all the children from current position of the specified XmlNavigator and inserts them at the specified position in this XmlNavigator.
MoveSelected | Moves all the selected nodes from the specified XmlNavigator (as returned by MoveToNextSelected) and inserts them at the specified position in this XmlNavigator.
MoveTo | Moves to the same position as the specified XmlNavigator.
MoveToAttribute Overloaded. Move to the specified attribute.

The MoveToAttribute methods enable you to get both random access to attributes and strongly typed access to attribute values.

To get strongly typed access to an attribute value, you must do the following:

  1. Call MoveToAttribute to move to the attribute whose value you want to access.
  2. Call Read method for the data type you want (for example, ReadBoolean for boolean, ReadDate for DateTime, and so on).

After calling MoveToAttribute, the Name, Namespace, Prefix properties will reflect the properties of that attribute.
MoveToChild | Moves to the specified child node of the current node (index 0 is the first child).
MoveToDocument | Moves to the document node that owns this node.
MoveToDocumentElement | Moves to the child element node of the owning document.
MoveToElement | Moves to the element that contains the current attribute node.
MoveToFirst | Moves to the first sibling of the current node.
MoveToFirstAttribute | Moves to the first attribute.
MoveToFirstChild | Moves to the first child of the current node.
MoveToFirstSelected (inherited from XmlNavigator) | Moves the XmlNavigator to the first node in the selected set.
MoveToId | Moves to the node with an ID attribute whose value matches the specified string.
MoveToLast | Moves to the last sibling of the current node.
MoveToLastChild | Moves to the last child of the current node.
MoveToLastSelected (inherited from XmlNavigator) | Moves the XmlNavigator to the last node in the selected set.
MoveToNext | Moves to the next sibling of the current node.
MoveToNextAttribute | Moves to the next attribute.
MoveToNextSelected (inherited from XmlNavigator) | Moves the XmlNavigator to the next node in the selected set.
MoveToParent | Moves to the parent of the current node.
MoveToPrevious | Moves to the previous sibling of the current node.
MoveToPreviousSelected (inherited from XmlNavigator) | Moves the XmlNavigator to the previous node in the selected set.
PopPosition | Moves the XmlNavigator back to a previously pushed position and pops that saved position off the stack.
PushPosition | Saves the current position.
Remove | Overloaded. Removes the specified node(s).
RemoveSelected | Removes all the selected nodes.
Select (inherited from XmlNavigator) | Selects a new set of "records" using the specified XPath expression.
SelectSingle (inherited from XmlNavigator) | Selects the first node that matches the specified expression.
SetAttribute | Overloaded. Sets the value of the specified attribute.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DocumentNavigator Class | System.NewXml Namespace


DocumentNavigator Constructor

Initializes a new instance of the DocumentNavigator class to navigate over the specified XmlDocument.

[Visual Basic]
Public Sub New( _
   ByVal doc As XmlDocument _
)
[C#]
public DocumentNavigator(
   XmlDocument doc
);
[C++]
public: DocumentNavigator(
   XmlDocument* doc
);
[JScript]
public function DocumentNavigator(
   doc : XmlDocument
);

Parameters

doc
The XmlDocument on which you want to use DocumentNavigator.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DocumentNavigator Properties

The properties of the DocumentNavigator class are listed below. For a complete list of DocumentNavigator class members, see the DocumentNavigator Members topic.

Public:

AttributeCount | Gets the number of attributes on the current node.
ChildCount | Gets the number of child nodes for the current node.
HasAttributes | Gets a value indicating whether the current node has any attributes.
HasChildren | Gets a value indicating whether the current node has child nodes.
HasSelection (inherited from XmlNavigator) | Determines if this XmlNavigator currently has a selection set.
HasValue | Gets a value indicating whether Value has a value to return.
IndexInParent | Gets the zero-based index of this node's position in its parent node.
InnerText | Gets or sets the concatenated values of the current node and all its children.
IsDefault | Gets a value indicating whether the current node is an attribute that was generated from the default value defined in the DTD or schema.
IsEmptyTag | Gets or sets a value indicating whether the current node is an empty element (for example, <MyElement/>).
IsReadOnly | Gets a value indicating whether the current node is read-only.
LocalName | Gets the name of the node without the namespace prefix.
Name | Gets the name of the current node, including the namespace prefix.
NamespaceURI | Gets the namespace URN (as defined in the W3C Namespace Specification) of the current namespace scope.
NameTable | Gets the XmlNameTable associated with this implementation.
NodeType | Gets the type of the current node.
Prefix | Gets or sets the namespace prefix associated with the current node.
Selection (inherited from XmlNavigator) | Gets the last XPath expression used in a successful call to the Select method.
Value | Gets or sets the text value of the current node.

See Also

DocumentNavigator Class | System.NewXml Namespace


DocumentNavigator.AttributeCount

Gets the number of attributes on the current node.

[Visual Basic]
Overridable Public ReadOnly Property AttributeCount As Integer
[C#]
public int AttributeCount {override get;}
[C++]
public: __property virtual int get_AttributeCount();
[JScript]
public function get AttributeCount() : int;

Property Value

Count of attributes on the current node.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.ChildCount

Gets the number of child nodes for the current node.

[Visual Basic]
Overridable Public ReadOnly Property ChildCount As Integer
[C#]
public int ChildCount {override get;}
[C++]
public: __property virtual int get_ChildCount();
[JScript]
public function get ChildCount() : int;

Property Value

The number of child nodes for the current node.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.HasAttributes

Gets a value indicating whether the current node has any attributes.

[Visual Basic]
Overridable Public ReadOnly Property HasAttributes As Boolean
[C#]
public bool HasAttributes {override get;}
[C++]
public: __property virtual bool get_HasAttributes();
[JScript]
public function get HasAttributes() : Boolean;

Property Value

true if the current node has attributes; otherwise, false.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.HasChildren

Gets a value indicating whether the current node has child nodes.

[Visual Basic]
Overridable Public ReadOnly Property HasChildren As Boolean
[C#]
public bool HasChildren {override get;}
[C++]
public: __property virtual bool get_HasChildren();
[JScript]
public function get HasChildren() : Boolean;

Property Value

true if the current node has child nodes; otherwise, false.

Remarks

This is potentially more efficient than using the ChildCount property.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.HasValue

Gets a value indicating whether Value has a value to return.

[Visual Basic]
Overridable Public ReadOnly Property HasValue As Boolean
[C#]
public bool HasValue {override get;}
[C++]
public: __property virtual bool get_HasValue();
[JScript]
public function get HasValue() : Boolean;

Property Value

true if Value has a value to return or if any more content can be returned from the partial content read methods; otherwise, false.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.IndexInParent

Gets the zero-based index of this node's position in its parent node.

[Visual Basic]
Overridable Public ReadOnly Property IndexInParent As Integer
[C#]
public int IndexInParent {override get;}
[C++]
public: __property virtual int get_IndexInParent();
[JScript]
public function get IndexInParent() : int;

Property Value

The index position of this node within its parent node.

Returns-1 if there is no parent node. You can, therefore, use this to find out whether there is a parent node for the current node.

Remarks

For attributes, this property returns the index in the list of attributes. For child elements, it returns the index in the list of child nodes. The following is always true (assuming the tree is not changed in the middle of the execution of this code):

[C#]

DocumentNavigator other = this.Clone();
other.MoveToParent();
other.MoveToChild( this.IndexInParent );
Assert(other.IsSame(this) == true);

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.InnerText

Gets or sets the concatenated values of the current node and all its children.

[Visual Basic]
Overridable Public Property InnerText As String
[C#]
public string InnerText {override get; override set;}
[C++]
public: __property virtual String* get_InnerText();
public: __property virtual void set_InnerText(String*);
[JScript]
public function get InnerText() : String;
public function set InnerText(String);

Property Value

The concatenated values of the current node and all its children.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.IsDefault

Gets a value indicating whether the current node is an attribute that was generated from the default value defined in the DTD or schema.

[Visual Basic]
Overridable Public ReadOnly Property IsDefault As Boolean
[C#]
public bool IsDefault {override get;}
[C++]
public: __property virtual bool get_IsDefault();
[JScript]
public function get IsDefault() : Boolean;

Property Value

true if the the current node is an attribute whose value was generated from the default value defined in the DTD or schema.

false if the attribute's value was explicitly specified in the XML stream.

Remarks

This property applies only to an attribute node.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.IsEmptyTag

Gets or sets a value indicating whether the current node is an empty element (for example, <MyElement/>).

[Visual Basic]
Overridable Public Property IsEmptyTag As Boolean
[C#]
public bool IsEmptyTag {override get; override set;}
[C++]
public: __property virtual bool get_IsEmptyTag();
public: __property virtual void set_IsEmptyTag(bool);
[JScript]
public function get IsEmptyTag() : Boolean;
public function set IsEmptyTag(Boolean);

Property Value

true if the current node is an element (NodeType equals Element) that ends with "/>"; otherwise, false.

Remarks

This property enables you to determine the difference between the following:

<foo bar="123"/> (IsEmptyTag is true).

<foo bar="123"> (IsEmptyTag is false)

Note that a corresponding EndTag element is not generated for empty elements.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.IsReadOnly

Gets a value indicating whether the current node is read-only.

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {override get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;

Property Value

true if the the current node is read-only.

false if the node is read/write.

Remarks

A read-only node is one that you cannot change any of its properties, attributes, or children. But you can remove it from the tree and insert it somewhere else. For example, the node for an EntityReference is typically read-only because its children actually come from the DTD definition of that entity and typically the DTD is read-only.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.LocalName

Gets the name of the node without the namespace prefix.

[Visual Basic]
Overridable Public ReadOnly Property LocalName As String
[C#]
public string LocalName {override get;}
[C++]
public: __property virtual String* get_LocalName();
[JScript]
public function get LocalName() : String;

Property Value

The name of the node with the prefix removed. For example, LocalName is yyy for the element <xxx:yyy>.

The name returned is dependent on the NodeType of the node:

Type | Name
Attribute | name of attribute
CDATA | #cdata-section
Comment | #comment
Document | #document
DocumentFragment | #document-fragment
DocumentType | document type name
Element | tag name
Entity | entity name
EntityReference | name of entity referenced
Notation | notation name
ProcessingInstruction | target
Text | #text

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.Name

Gets the name of the current node, including the namespace prefix.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {override get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

Property Value

Name of the current node. The name returned depends on the NodeType of the current node.

XmlNodeType | Property Value
Attribute | Contains the name of the attribute.
CDATA | Contains the literal string "#cdata-section".
Comment | Contains the literal string "#comment".
Document | Contains the literal string "#document".
DocumentType | Contains the name of the document type; for example, xxx in <!DOCTYPE xxx ...>.
DocumentFragment | Contains the literal string "#document-fragment".
Element | Contains the name of the XML tag, with any namespace prefix included if present.
Entity | Contains the name of the entity.
EntityReference | Contains the name of the entity referenced. Note that the name does not include the leading ampersand or the trailing semicolon. The name includes the namespace if one is present.
Notation | Contains the name of the notation.
ProcessingInstruction | Contains the target; the first token following the <? characters.
Text | Contains the literal string "#text".

String.Empty is returned if current node/record has no value to return.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.NamespaceURI

Gets the namespace URN (as defined in the W3C Namespace Specification) of the current namespace scope.

[Visual Basic]
Overridable Public ReadOnly Property NamespaceURI As String
[C#]
public string NamespaceURI {override get;}
[C++]
public: __property virtual String* get_NamespaceURI();
[JScript]
public function get NamespaceURI() : String;

Property Value

The namespace URN of the current namespace scope.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.NameTable

Gets the XmlNameTable associated with this implementation.

[Visual Basic]
Overridable Public ReadOnly Property NameTable As XmlNameTable
[C#]
public XmlNameTable NameTable {override get;}
[C++]
public: __property virtual XmlNameTable* get_NameTable();
[JScript]
public function get NameTable() : XmlNameTable;

Property Value

XmlNameTable enabling you to get the atomized version of a string within the node.

Remarks

All node and attribute names returned from this class are atomized using this nametable. This means that when the same name is returned multiple times (like "Customer"), then the same String object will be returned for that name. This makes it possible for you to write efficient code that does object pointer comparisons on these strings instead of expensive string comparisons.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.NodeType

Gets the type of the current node.

[Visual Basic]
Overridable Public ReadOnly Property NodeType As XmlNodeType
[C#]
public XmlNodeType NodeType {override get;}
[C++]
public: __property virtual XmlNodeType get_NodeType();
[JScript]
public function get NodeType() : XmlNodeType;

Property Value

One of the XmlNodeType values.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.Prefix

Gets or sets the namespace prefix associated with the current node.

[Visual Basic]
Overridable Public Property Prefix As String
[C#]
public string Prefix {override get; override set;}
[C++]
public: __property virtual String* get_Prefix();
public: __property virtual void set_Prefix(String*);
[JScript]
public function get Prefix() : String;
public function set Prefix(String);

Property Value

The namespace prefix associated with the current node.

String.Empty if current node/record has no value to return (never returns null).

Remarks

Setting this prefix has the same semantics as the W3C DOM.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.Value

Gets or sets the text value of the current node.

[Visual Basic]
Overridable Public Property Value As String
[C#]
public string Value {override get; override set;}
[C++]
public: __property virtual String* get_Value();
public: __property virtual void set_Value(String*);
[JScript]
public function get Value() : String;
public function set Value(String);

Property Value

The text value of the current node.

Same semantics as W3C DOM NodeValue property. Returns null for Element and Document nodes.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DocumentNavigator Methods

The methods of the DocumentNavigator class are listed below. For a complete list of DocumentNavigator class members, see the DocumentNavigator Members topic.

Public:

Clone | Creates a new XmlNavigator positioned at the same node as this DocumentNavigator.
Compile (inherited from XmlNavigator) | Compiles the given XPath expression and returns an object representing that expression.
CopyChildren | Copies all the children from current position of the specified XmlNavigator and inserts them at the specified position in this XmlNavigator.
CopySelected | Copies all the selected nodes from the specified XmlNavigator (as returned by MoveToNextSelected) and inserts them at the specified position in this tree.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Evaluate (inherited from XmlNavigator) | Evaluates the given expression and returns the typed result (int, boolean or string).
GetAttribute | Overloaded. Gets the value of an attribute.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
HasAttribute | Overloaded. Determines whether the current node has the specified attribute.
Insert | Overloaded. Inserts node(s) at the specified position.
IsSamePosition | Determines whether this XmlNavigator is at the same position as the specified XmlNavigator.
LookupPrefix | Looks up the prefix for the given namespace URI as defined higher up in the tree.
Matches (inherited from XmlNavigator) | Determines whether the current node matches the specified XPath expression
Move | Moves the entire subtree point to in the specified XmlNavigator to the specified position in this XmlNavigator.
MoveChildren | Moves all the children from current position of the specified XmlNavigator and inserts them at the specified position in this XmlNavigator.
MoveSelected | Moves all the selected nodes from the specified XmlNavigator (as returned by MoveToNextSelected) and inserts them at the specified position in this XmlNavigator.
MoveTo | Moves to the same position as the specified XmlNavigator.
MoveToAttribute Overloaded. Move to the specified attribute.

The MoveToAttribute methods enable you to get both random access to attributes and strongly typed access to attribute values.

To get strongly typed access to an attribute value, you must do the following:

  1. Call MoveToAttribute to move to the attribute whose value you want to access.
  2. Call Read method for the data type you want (for example, ReadBoolean for boolean, ReadDate for DateTime, and so on).

After calling MoveToAttribute, the Name, Namespace, Prefix properties will reflect the properties of that attribute.
MoveToChild | Moves to the specified child node of the current node (index 0 is the first child).
MoveToDocument | Moves to the document node that owns this node.
MoveToDocumentElement | Moves to the child element node of the owning document.
MoveToElement | Moves to the element that contains the current attribute node.
MoveToFirst | Moves to the first sibling of the current node.
MoveToFirstAttribute | Moves to the first attribute.
MoveToFirstChild | Moves to the first child of the current node.
MoveToFirstSelected (inherited from XmlNavigator) | Moves the XmlNavigator to the first node in the selected set.
MoveToId | Moves to the node with an ID attribute whose value matches the specified string.
MoveToLast | Moves to the last sibling of the current node.
MoveToLastChild | Moves to the last child of the current node.
MoveToLastSelected (inherited from XmlNavigator) | Moves the XmlNavigator to the last node in the selected set.
MoveToNext | Moves to the next sibling of the current node.
MoveToNextAttribute | Moves to the next attribute.
MoveToNextSelected (inherited from XmlNavigator) | Moves the XmlNavigator to the next node in the selected set.
MoveToParent | Moves to the parent of the current node.
MoveToPrevious | Moves to the previous sibling of the current node.
MoveToPreviousSelected (inherited from XmlNavigator) | Moves the XmlNavigator to the previous node in the selected set.
PopPosition | Moves the XmlNavigator back to a previously pushed position and pops that saved position off the stack.
PushPosition | Saves the current position.
Remove | Overloaded. Removes the specified node(s).
RemoveSelected | Removes all the selected nodes.
Select (inherited from XmlNavigator) | Selects a new set of "records" using the specified XPath expression.
SelectSingle (inherited from XmlNavigator) | Selects the first node that matches the specified expression.
SetAttribute | Overloaded. Sets the value of the specified attribute.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DocumentNavigator Class | System.NewXml Namespace


DocumentNavigator.Clone

Creates a new XmlNavigator positioned at the same node as this DocumentNavigator.

[Visual Basic]
Overrides Public Function Clone() As XmlNavigator
[C#]
public override XmlNavigator Clone();
[C++]
public: override XmlNavigator* Clone();
[JScript]
public override function Clone() : XmlNavigator;

Return Value

A new XmlNavigator object.

Remarks

The new XmlNavigator that is returned is not affected by subsequent changes to the current DocumentNavigator.

The Clone method does not clone all the selection and push/pop states. The cloned XmlNavigator has the same "liveness" behavior as this DocumentNavigator.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.CopyChildren

Copies all the children from current position of the specified XmlNavigator and inserts them at the specified position in this XmlNavigator.

[Visual Basic]
Overrides Public Sub CopyChildren( _
   ByVal p As TreePosition, _
   ByVal other As XmlNavigator _
)
[C#]
public override void CopyChildren(
   TreePosition p,
   XmlNavigator other
);
[C++]
public: override void CopyChildren(
   TreePosition p,
   XmlNavigator* other
);
[JScript]
public override function CopyChildren(
   p : TreePosition,
   other : XmlNavigator
);

Parameters

p
The specified position where the new nodes be copied. The position None does a Replace operation.
other
The source of the new nodes.

Exceptions

Exception Type | Condition
InvalidArgument | The child nodes in other specify nodes with an XmlNodeType that can not be inserted at position p.

Remarks

This XmlNavigator's position is unaffected by this operation.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.CopySelected

Copies all the selected nodes from the specified XmlNavigator (as returned by MoveToNextSelected) and inserts them at the specified position in this tree.

[Visual Basic]
Overrides Public Sub CopySelected( _
   ByVal p As TreePosition, _
   ByVal other As XmlNavigator _
)
[C#]
public override void CopySelected(
   TreePosition p,
   XmlNavigator other
);
[C++]
public: override void CopySelected(
   TreePosition p,
   XmlNavigator* other
);
[JScript]
public override function CopySelected(
   p : TreePosition,
   other : XmlNavigator
);

Parameters

p
The specified position where the new nodes will be copied. The position None does a Replace operation.
other
The source of the new nodes.

Exceptions

Exception Type | Condition
InvalidArgument | The child nodes in other specify nodes with an XmlNodeType that can not be inserted at position p.

Remarks

This XmlNavigator's position is unaffected by this operation.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.GetAttribute

Gets the value of an attribute.

Overload List

Gets the value of the attribute with the specified name.

[Visual Basic] Overloads Overrides Public Function GetAttribute(String) As String
[C#] public override string GetAttribute(String);
[C++] public: override String* GetAttribute(String*);
[JScript] public override function GetAttribute(String) : String;

Gets the value of the attribute with the specified index.

[Visual Basic] Overloads Overrides Public Function GetAttribute(Integer) As String
[C#] public override string GetAttribute(int);
[C++] public: override String* GetAttribute(int);
[JScript] public override function GetAttribute(int) : String;

Gets the value of the attribute with the specified name and namespace.

[Visual Basic] Overloads Overrides Public Function GetAttribute(String, String) As String
[C#] public override string GetAttribute(String, String);
[C++] public: override String* GetAttribute(String*, String*);
[JScript] public override function GetAttribute(String, String) : String;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.GetAttribute (String)

Gets the value of the attribute with the specified name.

[Visual Basic]
Overloads Overrides Public Function GetAttribute( _
   ByVal name As String _
) As String
[C#]
public override string GetAttribute(
   string name
);
[C++]
public: override String* GetAttribute(
   String* name
);
[JScript]
public override function GetAttribute(
   name : String
) : String;

Parameters

name
The name of the attribute. The name can include the prefix or leave it off.

Return Value

Empty string if currentnode/recordhas no value to return (never returns null).

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace | DocumentNavigator.GetAttribute Overload List


DocumentNavigator.GetAttribute (Int32)

Gets the value of the attribute with the specified index.

[Visual Basic]
Overloads Overrides Public Function GetAttribute( _
   ByVal i As Integer _
) As String
[C#]
public override string GetAttribute(
   int i
);
[C++]
public: override String* GetAttribute(
   int i
);
[JScript]
public override function GetAttribute(
   i : int
) : String;

Parameters

i
The index of the attribute. The index is zero-based (first attribute has index 0).

Return Value

The value of the specified attribute.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | The i parameter is less than 0 or greater than or equal to AttributeCount.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace | DocumentNavigator.GetAttribute Overload List


DocumentNavigator.GetAttribute (String, String)

Gets the value of the attribute with the specified name and namespace.

[Visual Basic]
Overloads Overrides Public Function GetAttribute( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As String
[C#]
public override string GetAttribute(
   string localName,
   string namespaceURI
);
[C++]
public: override String* GetAttribute(
   String* localName,
   String* namespaceURI
);
[JScript]
public override function GetAttribute(
   localName : String,
   namespaceURI : String
) : String;

Parameters

localName
The name of the attribute.
namespaceURI
The URN of the namespace of the attribute.

Return Value

The value of the specified attribute.

Exceptions

Exception Type | Condition
ArgumentException | The attribute specified by localName and namespaceURI properties cannot be found in the current node.

Remarks

The following XML contains an attribute in a specific namespace:

<test xmlns:dt="urn:datatypes" dt:type="int"/>

You can lookup the dt:type attribute using one argument (using Prefix+LocalName) or using two arguments (LocalName and NamespaceURI):

String dt = reader.GetAttribute("dt:type");

String dt2 = reader.GetAttribute("type","urn:datatypes");

Note that the xmlns attributes have no namespace URI; therefore, the only way to look them up is with the short version

String dt3 = reader.GetAttribute("xmlns:dt");

You can also get this information using the Prefix property.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace | DocumentNavigator.GetAttribute Overload List


DocumentNavigator.HasAttribute

Determines whether the current node has the specified attribute.

Overload List

Determines whether the current node has the specified attribute from the specified namespace.

[Visual Basic] Overloads Overrides Public Function HasAttribute(String, String) As Boolean
[C#] public override bool HasAttribute(String, String);
[C++] public: override bool HasAttribute(String*, String*);
[JScript] public override function HasAttribute(String, String) : Boolean;

Determines whether the current node has the specified attribute.

[Visual Basic] Overloads Overrides Public Function HasAttribute(String) As Boolean
[C#] public override bool HasAttribute(String);
[C++] public: override bool HasAttribute(String*);
[JScript] public override function HasAttribute(String) : Boolean;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.HasAttribute (String, String)

Determines whether the current node has the specified attribute from the specified namespace.

[Visual Basic]
Overloads Overrides Public Function HasAttribute( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Boolean
[C#]
public override bool HasAttribute(
   string localName,
   string namespaceURI
);
[C++]
public: override bool HasAttribute(
   String* localName,
   String* namespaceURI
);
[JScript]
public override function HasAttribute(
   localName : String,
   namespaceURI : String
) : Boolean;

Parameters

localName
[To be supplied.]
namespaceURI
The name of the namespace of the attribute to find.

Return Value

true if the current node has the specified attribute; otherwise, false.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace | DocumentNavigator.HasAttribute Overload List


DocumentNavigator.HasAttribute (String)

Determines whether the current node has the specified attribute.

[Visual Basic]
Overloads Overrides Public Function HasAttribute( _
   ByVal name As String _
) As Boolean
[C#]
public override bool HasAttribute(
   string name
);
[C++]
public: override bool HasAttribute(
   String* name
);
[JScript]
public override function HasAttribute(
   name : String
) : Boolean;

Parameters

name
The name of the attribute to find.

Return Value

true if the current node has the specified attribute; otherwise, false.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace | DocumentNavigator.HasAttribute Overload List


DocumentNavigator.Insert

Inserts node(s) at the specified position.

Overload List

Creates a new node and inserts it at the specified position in the tree relative to the current position and moves the navigator to point at this newly inserted node.

[Visual Basic] Overloads Overrides Public Sub Insert(TreePosition, XmlNodeType, String, String, String)
[C#] public override void Insert(TreePosition, XmlNodeType, String, String, String);
[C++] public: override void Insert(TreePosition, XmlNodeType, String, String, String);
[JScript] public override function Insert(TreePosition, XmlNodeType, String, String, String);

Inserts a copy of the node or nodes represented by the specified object into the specified position and moves to the root of the newly inserted nodes.

[Visual Basic] Overloads Overrides Public Sub Insert(TreePosition, Object, Type)
[C#] public override void Insert(TreePosition, Object, Type);
[C++] public: override void Insert(TreePosition, Object, Type);
[JScript] public override function Insert(TreePosition, Object, Type);

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.Insert (TreePosition, XmlNodeType, String, String, String)

Creates a new node and inserts it at the specified position in the tree relative to the current position and moves the navigator to point at this newly inserted node.

[Visual Basic]
Overloads Overrides Public Sub Insert( _
   ByVal p As TreePosition, _
   ByVal nt As XmlNodeType, _
   ByVal localName As String, _
   ByVal namespaceURI As String, _
   ByVal prefix As String _
)
[C#]
public override void Insert(
   TreePosition p,
   XmlNodeType nt,
   string localName,
   string namespaceURI,
   string prefix
);
[C++]
public: override void Insert(
   TreePosition p,
   XmlNodeType nt,
   String* localName,
   String* namespaceURI,
   String* prefix
);
[JScript]
public override function Insert(
   p : TreePosition,
   nt : XmlNodeType,
   localName : String,
   namespaceURI : String,
   prefix : String
);

Parameters

p
The relative position of the new node. The position "None" means the new node is not inserted into the tree- but instead is left dangling with no parent. This is the only valid way to create DocumentFragment nodes.
nt
[To be supplied.]
localName
The local name of the new node (if any). For nodes that have no name, this is null.
namespaceURI
The namespace URI for the new node (if any). For nodes that have no name, this is null or empty. Null and String.Empty mean the same thing.
prefix
The namespace prefix of the new node (if any). For nodes that have no name, this is null. You can use the LookupPrefix method to find out what the prefix is for a given namespace URI. The XmlNavigator does not do this automatically for performance reasons. Null and String.Empty mean the same thing.

Exceptions

Exception Type | Condition
ArgumentException | The nt parameter specifies an XmlNodeType that can not be inserted at position p. For example, if the position specified is "Parent" then the NodeType of the new node cannot be Attribute, CDATA or Text or Comment. The specified XmlNodeType requires a name and no name was provided. The XmlNodeType has no Name and a name, namespaceURI, or prefix was provided.

Remarks

TBD--Add NodeType table here.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace | DocumentNavigator.Insert Overload List


DocumentNavigator.Insert (TreePosition, Object, Type)

Inserts a copy of the node or nodes represented by the specified object into the specified position and moves to the root of the newly inserted nodes.

[Visual Basic]
Overloads Overrides Public Sub Insert( _
   ByVal p As TreePosition, _
   ByVal obj As Object, _
   ByVal type As Type _
)
[C#]
public override void Insert(
   TreePosition p,
   object obj,
   Type type
);
[C++]
public: override void Insert(
   TreePosition p,
   Object* obj,
   Type* type
);
[JScript]
public override function Insert(
   p : TreePosition,
   obj : Object,
   type : Type
);

Parameters

p
The position of the new node relative to the current node. The position "None" means the new node is not inserted into the tree- but instead is left dangling with no parent. This is the only valid way to create DocumentFragment nodes.
obj
The object that contains the new nodes to be inserted.
type
The type of object. Optional. This parameter is only used to specify which interface to use if the object implements multiple interfaces. If type is null, the "instanceof" operator is used to determine the type.

A type of XmlNavigator copies the entire subtree pointed at by the other XmlNavigator object. The other XmlNavigator will not be moved.

Exceptions

Exception Type | Condition
ArgumentException | The object specifies a node with an XmlNodeType that can not be inserted at position p. For example, if the position specified is "Parent" then the NodeType of the new node cannot be Attribute, CDATA or Text or Comment. The specified XmlNodeType requires a name and no name was provided. The type argument is not one of the above.

Remarks

Inserting a subtree into the Parent position results in the current node becoming the first child of the new parent.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace | DocumentNavigator.Insert Overload List


DocumentNavigator.IsSamePosition

Determines whether this XmlNavigator is at the same position as the specified XmlNavigator.

[Visual Basic]
Overrides Public Function IsSamePosition( _
   ByVal other As XmlNavigator _
) As Boolean
[C#]
public override bool IsSamePosition(
   XmlNavigator other
);
[C++]
public: override bool IsSamePosition(
   XmlNavigator* other
);
[JScript]
public override function IsSamePosition(
   other : XmlNavigator
) : Boolean;

Parameters

other
XmlNavigator with which you want to compare position.

Return Value

true if this XmlNavigator is at the same position as the specified XmlNavigator; otherwise, false.

Remarks

This also implies the other XmlNavigator is the same kind of XmlNavigator pointing at the same document instance.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.LookupPrefix

Looks up the prefix for the given namespace URI as defined higher up in the tree.

[Visual Basic]
Overrides Public Function LookupPrefix( _
   ByVal namespaceURI As String _
) As String
[C#]
public override string LookupPrefix(
   string namespaceURI
);
[C++]
public: override String* LookupPrefix(
   String* namespaceURI
);
[JScript]
public override function LookupPrefix(
   namespaceURI : String
) : String;

Parameters

namespaceURI
[To be supplied.]

Return Value

The prefix atomized string. Or a null reference (in Visual Basic Nothing) if not found.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.Move

Moves the entire subtree point to in the specified XmlNavigator to the specified position in this XmlNavigator.

[Visual Basic]
Overrides Public Sub Move( _
   ByVal p As TreePosition, _
   ByVal other As XmlNavigator _
)
[C#]
public override void Move(
   TreePosition p,
   XmlNavigator other
);
[C++]
public: override void Move(
   TreePosition p,
   XmlNavigator* other
);
[JScript]
public override function Move(
   p : TreePosition,
   other : XmlNavigator
);

Parameters

p
The specified position where the new nodes will be moved. The position None does a Replace operation.
other
XmlNavigator containing the source of the new nodes.

Exceptions

Exception Type | Condition
ArgumentException | The other XmlNavigator is pointing at read/only nodes (like the children of an entity reference). It can point to an entity reference and thereby move the entire entity reference- but it cannot point at the children of an entity reference.

Remarks

This XmlNavigator's position is unaffected by this operation.

The other XmlNavigator remains pointing at the same node. This means it is essentially moved over to this tree in the process.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.MoveChildren

Moves all the children from current position of the specified XmlNavigator and inserts them at the specified position in this XmlNavigator.

[Visual Basic]
Overrides Public Sub MoveChildren( _
   ByVal p As TreePosition, _
   ByVal other As XmlNavigator _
)
[C#]
public override void MoveChildren(
   TreePosition p,
   XmlNavigator other
);
[C++]
public: override void MoveChildren(
   TreePosition p,
   XmlNavigator* other
);
[JScript]
public override function MoveChildren(
   p : TreePosition,
   other : XmlNavigator
);

Parameters

p
The specified position where the new nodes will be copied. The position None does a Replace operation.
other
The source of the new nodes.

Exceptions

Exception Type | Condition
ArgumentException | The other XmlNavigator is pointing at read/only nodes (like the children of an entity reference). It can point to an entity reference and thereby move the entire entity reference- but it cannot point at the children of an entity reference.

Remarks

This XmlNavigator's position is unaffected by this operation.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.MoveSelected

Moves all the selected nodes from the specified XmlNavigator (as returned by MoveToNextSelected) and inserts them at the specified position in this XmlNavigator.

[Visual Basic]
Overrides Public Sub MoveSelected( _
   ByVal p As TreePosition, _
   ByVal other As XmlNavigator _
)
[C#]
public override void MoveSelected(
   TreePosition p,
   XmlNavigator other
);
[C++]
public: override void MoveSelected(
   TreePosition p,
   XmlNavigator* other
);
[JScript]
public override function MoveSelected(
   p : TreePosition,
   other : XmlNavigator
);

Parameters

p
The specified position where the new nodes will end up. The position None does a Replace operation.
other
The source of the new nodes.

Exceptions

Exception Type | Condition
ArgumentException | The other XmlNavigator is pointing at read/only nodes (like the children of an entity reference). It can point to an entity reference and thereby move the entire entity reference- but it cannot point at the children of an entity reference.

Remarks

This XmlNavigator's position is unaffected by this operation.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.MoveTo

Moves to the same position as the specified XmlNavigator.

[Visual Basic]
Overrides Public Function MoveTo( _
   ByVal other As XmlNavigator _
) As Boolean
[C#]
public override bool MoveTo(
   XmlNavigator other
);
[C++]
public: override bool MoveTo(
   XmlNavigator* other
);
[JScript]
public override function MoveTo(
   other : XmlNavigator
) : Boolean;

Parameters

other
XmlNavigator with the position you want to move this XmlNavigator to.

Return Value

TBD. Throws an exception if the two XmlNavigator objects are incompatible.

Remarks

The XmlNavigator is in the 'null' state when it temporarily points to no node. You can get out of this state by using MoveTo(XmlNavigator) or MoveToDocument. You can find out that you are in the Null state because NodeType returns 0.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.MoveToAttribute

Move to the specified attribute.

The MoveToAttribute methods enable you to get both random access to attributes and strongly typed access to attribute values.

To get strongly typed access to an attribute value, you must do the following:

  1. Call MoveToAttribute to move to the attribute whose value you want to access.
  2. Call Read method for the data type you want (for example, ReadBoolean for boolean, ReadDate for DateTime, and so on).

After calling MoveToAttribute, the Name, Namespace, Prefix properties will reflect the properties of that attribute.

Overload List

Move to the attribute with matching name and namespace.

[Visual Basic] Overloads Overrides Public Function MoveToAttribute(String, String) As Boolean
[C#] public override bool MoveToAttribute(String, String);
[C++] public: override bool MoveToAttribute(String*, String*);
[JScript] public override function MoveToAttribute(String, String) : Boolean;

Moves to the attribute with the specified name.

[Visual Basic] Overloads Overrides Public Function MoveToAttribute(String) As Boolean
[C#] public override bool MoveToAttribute(String);
[C++] public: override bool MoveToAttribute(String*);
[JScript] public override function MoveToAttribute(String) : Boolean;

Moves to the attribute with the specified index.

[Visual Basic] Overloads Overrides Public Function MoveToAttribute(Integer) As Boolean
[C#] public override bool MoveToAttribute(int);
[C++] public: override bool MoveToAttribute(int);
[JScript] public override function MoveToAttribute(int) : Boolean;

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.MoveToAttribute (String, String)

Move to the attribute with matching name and namespace.

[Visual Basic]
Overloads Overrides Public Function MoveToAttribute( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Boolean
[C#]
public override bool MoveToAttribute(
   string localName,
   string namespaceURI
);
[C++]
public: override bool MoveToAttribute(
   String* localName,
   String* namespaceURI
);
[JScript]
public override function MoveToAttribute(
   localName : String,
   namespaceURI : String
) : Boolean;

Parameters

localName
The name of the attribute.
namespaceURI
The URN of the namespace of the attribute.

Return Value

true if the attribute is found; otherwise, false. If false, the DocumentNavigator's position does not change.

Remarks

If you are positioned on an attribute, this method will do an implicit MoveToElement before processing this method.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace | DocumentNavigator.MoveToAttribute Overload List


DocumentNavigator.MoveToAttribute (String)

Moves to the attribute with the specified name.

[Visual Basic]
Overloads Overrides Public Function MoveToAttribute( _
   ByVal name As String _
) As Boolean
[C#]
public override bool MoveToAttribute(
   string name
);
[C++]
public: override bool MoveToAttribute(
   String* name
);
[JScript]
public override function MoveToAttribute(
   name : String
) : Boolean;

Parameters

name
The name of the attribute. The name can include the prefix or leave it off.

Return Value

true if the attribute is found; otherwise, false. If false, the DocumentNavigator's position does not change.

Exceptions

Exception Type | Condition
ArgumentException | The attribute specified by name cannot be found in the current node.

Remarks

If you are positioned on an attribute, this method will do an implicit MoveToElement before processing this method.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace | DocumentNavigator.MoveToAttribute Overload List


DocumentNavigator.MoveToAttribute (Int32)

Moves to the attribute with the specified index.

[Visual Basic]
Overloads Overrides Public Function MoveToAttribute( _
   ByVal i As Integer _
) As Boolean
[C#]
public override bool MoveToAttribute(
   int i
);
[C++]
public: override bool MoveToAttribute(
   int i
);
[JScript]
public override function MoveToAttribute(
   i : int
) : Boolean;

Parameters

i
The index of the attribute.

Return Value

true if the attribute is found; otherwise, false. If false, the reader's position does not change.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | The i parameter is less than 0 or greater than AttributeCount.

Remarks

If you are positioned on an attribute, this method will do an implicit MoveToElement before processing this method.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace | DocumentNavigator.MoveToAttribute Overload List


DocumentNavigator.MoveToChild

Moves to the specified child node of the current node (index 0 is the first child).

[Visual Basic]
Overrides Public Function MoveToChild( _
   ByVal i As Integer _
) As Boolean
[C#]
public override bool MoveToChild(
   int i
);
[C++]
public: override bool MoveToChild(
   int i
);
[JScript]
public override function MoveToChild(
   i : int
) : Boolean;

Parameters

i
The index of the child node.

Return Value

true if the specified child node exists; false if the specified child node does not exist.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.MoveToDocument

Moves to the document node that owns this node.

[Visual Basic]
Overrides Public Sub MoveToDocument()
[C#]
public override void MoveToDocument();
[C++]
public: override void MoveToDocument();
[JScript]
public override function MoveToDocument();

Remarks

All nodes belong to one and only one document; therefore, this method is guaranteed to succeed.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.MoveToDocumentElement

Moves to the child element node of the owning document.

[Visual Basic]
Overrides Public Function MoveToDocumentElement() As Boolean
[C#]
public override bool MoveToDocumentElement();
[C++]
public: override bool MoveToDocumentElement();
[JScript]
public override function MoveToDocumentElement() : Boolean;

Return Value

true if the document that owns this node currently has a child element node.

false if the document that owns this node currently has no child element node.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.MoveToElement

Moves to the element that contains the current attribute node.

[Visual Basic]
Overrides Public Function MoveToElement() As Boolean
[C#]
public override bool MoveToElement();
[C++]
public: override bool MoveToElement();
[JScript]
public override function MoveToElement() : Boolean;

Return Value

true if the attribute is owned by an element; false if the attribute you are positioned on has been removed from the owning element.

Exceptions

Exception Type | Condition
InvalidOperationException | The reader is not positioned on an attribute node.

Remarks

Use this method to return to an element after navigating through its attributes.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.MoveToFirst

Moves to the first sibling of the current node.

[Visual Basic]
Overrides Public Function MoveToFirst() As Boolean
[C#]
public override bool MoveToFirst();
[C++]
public: override bool MoveToFirst();
[JScript]
public override function MoveToFirst() : Boolean;

Return Value

true if there is a first sibling node; false if there is no first sibling.

Remarks

If you are positioned on an attribute, this method will do an implicit call to MoveToElement before processing this method. In other words, attribute navigation is orthogonal to tree navigation.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.MoveToFirstAttribute

Moves to the first attribute.

[Visual Basic]
Overrides Public Function MoveToFirstAttribute() As Boolean
[C#]
public override bool MoveToFirstAttribute();
[C++]
public: override bool MoveToFirstAttribute();
[JScript]
public override function MoveToFirstAttribute() : Boolean;

Return Value

true if the first attribute exists; otherwise, false.

Remarks

If you are positioned on an attribute, this method will do an implicit MoveToElement before processing this method.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.MoveToFirstChild

Moves to the first child of the current node.

[Visual Basic]
Overrides Public Function MoveToFirstChild() As Boolean
[C#]
public override bool MoveToFirstChild();
[C++]
public: override bool MoveToFirstChild();
[JScript]
public override function MoveToFirstChild() : Boolean;

Return Value

true if there is a first child node; false if there are no child nodes.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.MoveToId

Moves to the node with an ID attribute whose value matches the specified string.

[Visual Basic]
Overrides Public Function MoveToId( _
   ByVal id As String _
) As Boolean
[C#]
public override bool MoveToId(
   string id
);
[C++]
public: override bool MoveToId(
   String* id
);
[JScript]
public override function MoveToId(
   id : String
) : Boolean;

Parameters

id
The ID value of the node you want to move to.

Return Value

TBD. Throws IdNotFoundException if the id was not defined in the data.

Remarks

The argument does not need to be atomized. For example, suppose the DTD defined the following:

<!ATTLIST x a ID #REQUIRED >

and suppose the following XML data was loaded using this DTD:

<data> <x a="a1"/> </data>

then the following would be true:

[C#]

// "nav" pointing anywhere in the above data.
nav.MoveToId("a1");
// Now "nav" points to the element node named "x"

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.MoveToLast

Moves to the last sibling of the current node.

[Visual Basic]
Overrides Public Function MoveToLast() As Boolean
[C#]
public override bool MoveToLast();
[C++]
public: override bool MoveToLast();
[JScript]
public override function MoveToLast() : Boolean;

Return Value

true if there is a last sibling node; false if there is no last sibling.

Remarks

If you are positioned on an attribute, this method will do an implicit call to MoveToElement before processing this method. In other words, attribute navigation is orthogonal to tree navigation.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.MoveToLastChild

Moves to the last child of the current node.

[Visual Basic]
Overrides Public Function MoveToLastChild() As Boolean
[C#]
public override bool MoveToLastChild();
[C++]
public: override bool MoveToLastChild();
[JScript]
public override function MoveToLastChild() : Boolean;

Return Value

true if there is a last child node; false if there are no child nodes.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.MoveToNext

Moves to the next sibling of the current node.

[Visual Basic]
Overrides Public Function MoveToNext() As Boolean
[C#]
public override bool MoveToNext();
[C++]
public: override bool MoveToNext();
[JScript]
public override function MoveToNext() : Boolean;

Return Value

true if there is a next sibling node; false if there are no more siblings.

Remarks

If you are positioned on an attribute, this method will do an implicit call to MoveToElement before processing this method. In other words, attribute navigation is orthogonal to tree navigation.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.MoveToNextAttribute

Moves to the next attribute.

[Visual Basic]
Overrides Public Function MoveToNextAttribute() As Boolean
[C#]
public override bool MoveToNextAttribute();
[C++]
public: override bool MoveToNextAttribute();
[JScript]
public override function MoveToNextAttribute() : Boolean;

Return Value

true if there is a next attribute; false if there are no more attributes.

Remarks

If the current node is an element node, this method is equivalent to MoveToFirstAttribute.

If you are positioned on an attribute, this method will do an implicit MoveToElement before processing this method.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.MoveToParent

Moves to the parent of the current node.

[Visual Basic]
Overrides Public Function MoveToParent() As Boolean
[C#]
public override bool MoveToParent();
[C++]
public: override bool MoveToParent();
[JScript]
public override function MoveToParent() : Boolean;

Return Value

true if a parent node exists.

false if there is no parent node. This can happen if the tree is changed out from under the XmlNavigator.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.MoveToPrevious

Moves to the previous sibling of the current node.

[Visual Basic]
Overrides Public Function MoveToPrevious() As Boolean
[C#]
public override bool MoveToPrevious();
[C++]
public: override bool MoveToPrevious();
[JScript]
public override function MoveToPrevious() : Boolean;

Return Value

true if there is a previous sibling node; false if there is no previous sibling.

Remarks

If you are positioned on an attribute, this method will do an implicit call to MoveToElement before processing this method. In other words, attribute navigation is orthogonal to tree navigation.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.PopPosition

Moves the XmlNavigator back to a previously pushed position and pops that saved position off the stack.

[Visual Basic]
Overrides Public Function PopPosition() As Boolean
[C#]
public override bool PopPosition();
[C++]
public: override bool PopPosition();
[JScript]
public override function PopPosition() : Boolean;

Return Value

true if XmlNavigator moved to previous push position; false if there is no more to pop.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.PushPosition

Saves the current position.

[Visual Basic]
Overrides Public Sub PushPosition()
[C#]
public override void PushPosition();
[C++]
public: override void PushPosition();
[JScript]
public override function PushPosition();

Remarks

You can later return to this position by calling PopPosition(). Push has the same semantics as if you used Clone() and remembered the cloned XmlNavigators on your own stack.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.Remove

Removes the specified node(s).

Overload List

Removes the specified node (and its entire subtree) by relative position to the current node.

[Visual Basic] Overloads Overrides Public Sub Remove(TreePosition)
[C#] public override void Remove(TreePosition);
[C++] public: override void Remove(TreePosition);
[JScript] public override function Remove(TreePosition);

Removes the current node (and its entire subtree).

[Visual Basic] Overloads Overrides Public Sub Remove()
[C#] public override void Remove();
[C++] public: override void Remove();
[JScript] public override function Remove();

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.Remove (TreePosition)

Removes the specified node (and its entire subtree) by relative position to the current node.

[Visual Basic]
Overloads Overrides Public Sub Remove( _
   ByVal p As TreePosition _
)
[C#]
public override void Remove(
   TreePosition p
);
[C++]
public: override void Remove(
   TreePosition p
);
[JScript]
public override function Remove(
   p : TreePosition
);

Parameters

p
Treeposition indicating the node to remove.

Remarks

After this method is called, the parent of the specified node is set to null. This XmlNavigator then stays pointing at this current node.

The position of "None" makes this method behave the same as Remove() with no arguments.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace | DocumentNavigator.Remove Overload List


DocumentNavigator.Remove ()

Removes the current node (and its entire subtree).

[Visual Basic]
Overloads Overrides Public Sub Remove()
[C#]
public override void Remove();
[C++]
public: override void Remove();
[JScript]
public override function Remove();

Remarks

After this method is called, the parent pointer is disconnected (so MoveToParent will return false) and the parent's ChildCount will be decremented by 1.

This XmlNavigator then stays pointing at this removed node.

If this node has already been removed and has no parent, this method has no effect.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace | DocumentNavigator.Remove Overload List


DocumentNavigator.RemoveSelected

Removes all the selected nodes.

[Visual Basic]
Overrides Public Sub RemoveSelected()
[C#]
public override void RemoveSelected();
[C++]
public: override void RemoveSelected();
[JScript]
public override function RemoveSelected();

Remarks

If there are no selected nodes, this method has no effect.

The XmlNavigator's position is unaffected by this operation.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.SetAttribute

Sets the value of the specified attribute.

Overload List

Sets the value of the attribute with the specified name and namespace.

[Visual Basic] Overloads Overrides Public Sub SetAttribute(String, String, String)
[C#] public override void SetAttribute(String, String, String);
[C++] public: override void SetAttribute(String*, String*, String*);
[JScript] public override function SetAttribute(String, String, String);

Sets the value of the attribute with the specified index.

[Visual Basic] Overloads Overrides Public Sub SetAttribute(Integer, String)
[C#] public override void SetAttribute(int, String);
[C++] public: override void SetAttribute(int, String);
[JScript] public override function SetAttribute(int, String);

Sets the value of the attribute with the specified name.

[Visual Basic] Overloads Overrides Public Sub SetAttribute(String, String)
[C#] public override void SetAttribute(String, String);
[C++] public: override void SetAttribute(String*, String*);
[JScript] public override function SetAttribute(String, String);

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace


DocumentNavigator.SetAttribute (String, String, String)

Sets the value of the attribute with the specified name and namespace.

[Visual Basic]
Overloads Overrides Public Sub SetAttribute( _
   ByVal localName As String, _
   ByVal namespaceURI As String, _
   ByVal value As String _
)
[C#]
public override void SetAttribute(
   string localName,
   string namespaceURI,
   string value
);
[C++]
public: override void SetAttribute(
   String* localName,
   String* namespaceURI,
   String* value
);
[JScript]
public override function SetAttribute(
   localName : String,
   namespaceURI : String,
   value : String
);

Parameters

localName
The name of the attribute. The name can include the prefix or leave it off.
namespaceURI
The URN of the namespace of the attribute.
value
The value to set for the attribute.

Remarks

This name does may or may not include the prefix. For example:

[C#]

xti.SetAttribute("xmlns:x",null, nsuri);

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace | DocumentNavigator.SetAttribute Overload List


DocumentNavigator.SetAttribute (Int32, String)

Sets the value of the attribute with the specified index.

[Visual Basic]
Overloads Overrides Public Sub SetAttribute( _
   ByVal i As Integer, _
   ByVal value As String _
)
[C#]
public override void SetAttribute(
   int i,
   string value
);
[C++]
public: override void SetAttribute(
   int i,
   String* value
);
[JScript]
public override function SetAttribute(
   i : int,
   value : String
);

Parameters

i
The index of the attribute.
value
The value to set for the attribute.

Return Value

The value of the specified attribute.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | The i parameter is less than 0 or greater than AttributeCount.

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace | DocumentNavigator.SetAttribute Overload List


DocumentNavigator.SetAttribute (String, String)

Sets the value of the attribute with the specified name.

[Visual Basic]
Overloads Overrides Public Sub SetAttribute( _
   ByVal name As String, _
   ByVal value As String _
)
[C#]
public override void SetAttribute(
   string name,
   string value
);
[C++]
public: override void SetAttribute(
   String* name,
   String* value
);
[JScript]
public override function SetAttribute(
   name : String,
   value : String
);

Parameters

name
The name of the attribute. The name can include the prefix or leave it off.
value
[To be supplied.]

See Also

DocumentNavigator Class | DocumentNavigator Members | System.NewXml Namespace | DocumentNavigator.SetAttribute Overload List


EntityHandling Enumeration

Specifies how entities are handled.

[Visual Basic]
Public Enum EntityHandling
[C#]
public enum EntityHandling
[C++]
public enum EntityHandling

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
AllEntityNodes | Return all built-in, character, and general entity references as nodes.
ExpandCharEntities | Expand character entities and return general entities as nodes (NodeType=XmlNodeType.EntityReference, Name=the name of the entity, HasValue= false). You must call ResolveEntity to see what the general entities expand to. This allows you to optimize entity handling by only expanding the entity the first time it is used.
ExpandEntities | Expand all entities. This is the default. Nodes of NodeType EntityReference are not returned. The entity text is expanded in place of the entity references.
IgnoreEntities | Ignore character and general entites. Nodes of NodeType EntityReference are not returned. Entities are returned embedded in the text, for example, "this &amp; that".

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

System.NewXml Namespace


Formatting Enumeration

Specifies formatting options for the XmlWriter stream.

[Visual Basic]
Public Enum Formatting
[C#]
public enum Formatting
[C++]
public enum Formatting

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Indented | This option causes child elements to be indented using the Indentation and IndentChar properties. It only indents Element Content (http://www.w3.org/TR/1998/REC-xml-19980210#sec-element-content) and not Mixed Content (http://www.w3.org/TR/1998/REC-xml-19980210#sec-mixed-content) according to the XML 1.0 definitions of these terms.
None | No special formatting is done (this is the default).

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

System.NewXml Namespace


ReadState Enumeration

Specifies the state of the stream.

[Visual Basic]
Public Enum ReadState
[C#]
public enum ReadState
[C++]
public enum ReadState

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Closed | The Close method has been called.
EndOfFile | The end of the stream has been reached successfully.
Error | An error occurred that prevents the read operation from continuing.
Initial | The Read method has not been called.
Interactive | Read operation is in progress.

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

System.NewXml Namespace


TreePosition Enumeration

Specifies a position relative to the current node.

[Visual Basic]
Public Enum TreePosition
[C#]
public enum TreePosition
[C++]
public enum TreePosition

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
After | The sibling immediately after the current node/record.
Before | The sibling immediately before the current node/record.
FirstAttribute | The first attribute of the current node/record.
FirstChild | The first child of the current node/record.
LastAttribute | [To be supplied.]
LastChild | The last child of the current node/record.
None | No position.
Parent | The parent of the current node/record.

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

System.NewXml Namespace


Validation Enumeration

Specifies the type of validation to perform.

[Visual Basic]
Public Enum Validation
[C#]
public enum Validation
[C++]
public enum Validation

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Auto The Auto member does the following:
  1. If there is no DTD or schema, it will parse the XML without validation.
  2. If there is a DTD defined in a <!DOCTYPE ...> declaration, it will load the DTD and process the DTD declarations such that default attributes and general entities will be made available. General entities are only loaded and parsed if they are used (expanded).
  3. If there is no <!DOCTYPE ...> declaration but there is an XSD "schemaLocation" attribute, it will load and process those XSD schemas and it will return any default attributes defined in those schemas.
  4. If there is no <!DOCTYPE ...> declaration and no XSD "schemaLocation" attribute but there are some namespaces using the MSXML "x-schema:" URN prefix, it will load and process those schemas and it will return any default attributes defined in those schemas.
DTD | Validate according to DTD.
None | No validation.
Schema | Validate according to XDR and XSD schemas, including inline schemas. An error is returned if both XDR and XSD schemas are referenced from the same document.

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

System.NewXml Namespace


ValidationDelegate Delegate

Represents the method that handles validation error events of the System.NewXml.XmlTextReaderClass.

[Visual Basic]
Public Delegate Sub ValidationDelegate( _
   ByVal hr As Integer, _
   ByVal reason As String _
)
[C#]
public delegate void ValidationDelegate(
   int hr,
   string reason
);
[C++]
public __gc __delegate void ValidationDelegate(
   int hr,
   String* reason
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the ValidationDelegate delegate declaration.

hr
Error code.
reason
Description of the error.

Remarks

[To be supplied.]

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

Example

The following is a simple example of a validation callback method:

[C++]
    private void ValidationCallback(int hr, String msg)
    {
        Console.WriteLine("");
        Console.WriteLine("hr: " + hr);
        Console.WriteLine(msg);
    }

See Also

System.NewXml Namespace


WhitespaceHandling Enumeration

Specifies how whitespace is handled.

[Visual Basic]
Public Enum WhitespaceHandling
[C#]
public enum WhitespaceHandling
[C++]
public enum WhitespaceHandling

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
All | Return Whitespace and SignificantWhitespace only. This is the default.
None | Return no Whitespace and no SignificantWhitespace.
Significant | Return just SignificantWhitespace.

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

System.NewXml Namespace


WriteState Enumeration

Specifies the state of the XmlWriter stream.

[Visual Basic]
Public Enum WriteState
[C#]
public enum WriteState
[C++]
public enum WriteState

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Attribute | Writing an attribute value.
Closed | Close has been called.
Content | Writing element content.
Element | Writing a the start tag for an element.
Prolog | Writing the prolog.
Start | Nothing has been written yet.

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

System.NewXml Namespace


XmlAttribute Class

Represents an attribute of the XMLElement object. Valid and default values for the attribute are defined in a DTD or schema.

Object
XmlNode
XmlAttribute

[Visual Basic]
Public Class XmlAttribute
   Inherits XmlNode
[C#]
public class XmlAttribute : XmlNode
[C++]
public __gc class XmlAttribute : public XmlNode
[JScript]
public class XmlAttribute extends XmlNode

Remarks

[To be supplied.]

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

XmlAttribute Members | System.NewXml Namespace


XmlAttribute Members

Public:

Properties

Attributes (inherited from XmlNode) | Gets an XmlAttributeCollection containing the attributes of this node.
ChildNodes (inherited from XmlNode) | Gets all children of this node.
FirstChild (inherited from XmlNode) | Gets the first child of this node.
HasChildNodes (inherited from XmlNode) | Gets a value indicating whether this node has any child nodes.
InnerText (inherited from XmlNode) | Gets or sets the concatenated values of the node and all its children.
InnerXml (inherited from XmlNode) | Gets or sets the markup representing just the children of this node.
IsReadOnly (inherited from XmlNode) | Gets a value indicating whether the node is read-only.
Item (inherited from XmlNode) | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlAttribute class.
LastChild (inherited from XmlNode) | Gets the last child of this node.
LocalName | Gets the name of the node without the namespace prefix.
Name | Gets the name of the node.
NamespaceURI | Gets the namespace URI of this node.
NextSibling (inherited from XmlNode) | Gets the node immediately following this node.
NodeType | Gets the type of the current node.
OuterXml (inherited from XmlNode) | Gets the markup representing this node and all its children.
OwnerDocument | Gets the XmlDocument that contains this node.
OwnerElement | Gets the XmlElement node that contains this attribute.
ParentNode | Gets the parent of this node (for nodes that can have parents).
Prefix | Gets or sets the namespace prefix of this node.
PreviousSibling (inherited from XmlNode) | Gets the node immediately preceding this node.
Specified | Gets a value indicating whether the value was explicitly set.
Value | Gets or sets the value of the node.

Methods

AppendChild (inherited from XmlNode) | Adds the specified node to the end of the list of children of this node.
Clone (inherited from XmlNode) | Creates a duplicate of this node.
CloneNode | Creates a duplicate of this node.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from XmlNode) | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamespaceOfPrefix (inherited from XmlNode) | Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.
GetPrefixOfNamespace (inherited from XmlNode) | Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.
GetType (inherited from Object) | Gets the Type of the Object.
InsertAfter (inherited from XmlNode) | Inserts the specified node immediately after the specified reference node.
InsertBefore (inherited from XmlNode) | Inserts the specified node immediately before the specified reference node.
Normalize (inherited from XmlNode) | Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.
PrependChild (inherited from XmlNode) | Adds the specified node to the beginning of the list of children of this node.
RemoveAll (inherited from XmlNode) | Removes all the children and/or attributes of the current node.
RemoveChild (inherited from XmlNode) | Removes specified child node.
ReplaceChild (inherited from XmlNode) | Replaces the child node oldChild with newChild node.
Supports (inherited from XmlNode) | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteContentTo | Saves all the children of the node to the specified XmlWriter.
WriteTo | Saves the node to the specified XmlWriter.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlAttribute Class | System.NewXml Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlAttribute Properties

The properties of the XmlAttribute class are listed below. For a complete list of XmlAttribute class members, see the XmlAttribute Members topic.

Public:

Attributes (inherited from XmlNode) | Gets an XmlAttributeCollection containing the attributes of this node.
ChildNodes (inherited from XmlNode) | Gets all children of this node.
FirstChild (inherited from XmlNode) | Gets the first child of this node.
HasChildNodes (inherited from XmlNode) | Gets a value indicating whether this node has any child nodes.
InnerText (inherited from XmlNode) | Gets or sets the concatenated values of the node and all its children.
InnerXml (inherited from XmlNode) | Gets or sets the markup representing just the children of this node.
IsReadOnly (inherited from XmlNode) | Gets a value indicating whether the node is read-only.
Item (inherited from XmlNode) | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlAttribute class.
LastChild (inherited from XmlNode) | Gets the last child of this node.
LocalName | Gets the name of the node without the namespace prefix.
Name | Gets the name of the node.
NamespaceURI | Gets the namespace URI of this node.
NextSibling (inherited from XmlNode) | Gets the node immediately following this node.
NodeType | Gets the type of the current node.
OuterXml (inherited from XmlNode) | Gets the markup representing this node and all its children.
OwnerDocument | Gets the XmlDocument that contains this node.
OwnerElement | Gets the XmlElement node that contains this attribute.
ParentNode | Gets the parent of this node (for nodes that can have parents).
Prefix | Gets or sets the namespace prefix of this node.
PreviousSibling (inherited from XmlNode) | Gets the node immediately preceding this node.
Specified | Gets a value indicating whether the value was explicitly set.
Value | Gets or sets the value of the node.

See Also

XmlAttribute Class | System.NewXml Namespace


XmlAttribute.LocalName

Gets the name of the node without the namespace prefix.

[Visual Basic]
Overridable Public ReadOnly Property LocalName As String
[C#]
public string LocalName {override get;}
[C++]
public: __property virtual String* get_LocalName();
[JScript]
public function get LocalName() : String;

Property Value

The name of the node with the prefix removed. For example, LocalName is yyy for the element <xxx:yyy>.

Remarks

For nodes created with a DOM Level 1 method, such as CreateElement, it is null.

See Also

XmlAttribute Class | XmlAttribute Members | System.NewXml Namespace


XmlAttribute.Name

Gets the name of the node.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {override get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

Property Value

The name of the node. The name returned is dependent on the NodeType of the node. For XmlAttribute, this property is the name of the attribute.

See Also

XmlAttribute Class | XmlAttribute Members | System.NewXml Namespace


XmlAttribute.NamespaceURI

Gets the namespace URI of this node.

[Visual Basic]
Overridable Public ReadOnly Property NamespaceURI As String
[C#]
public string NamespaceURI {override get;}
[C++]
public: __property virtual String* get_NamespaceURI();
[JScript]
public function get NamespaceURI() : String;

Property Value

The namespace URI of this node. If there is no namespace URI, this property is null.

Remarks

For example, "uuu" for the following "foo" element: <foo xmlns="uuu"> is not a computed value that is the result of a namespace lookup based on an examination of the namespace declarations in scope. It is merely the namespace URI given at creation time.

For nodes of any type other than ELEMENT_NODE and ATTRIBUTE_NODE and nodes created with a DOM Level 1 method, such as createElement from the XmlDocument, this is always null.In accordance with the Namespaces in XML Specification [Namespaces], an attribute does not inherit its namespace from the element it is attached to. If an attribute is not explicitly given a namespace, it simply has no namespace.

See Also

XmlAttribute Class | XmlAttribute Members | System.NewXml Namespace


XmlAttribute.NodeType

Gets the type of the current node.

[Visual Basic]
Overridable Public ReadOnly Property NodeType As XmlNodeType
[C#]
public XmlNodeType NodeType {override get;}
[C++]
public: __property virtual XmlNodeType get_NodeType();
[JScript]
public function get NodeType() : XmlNodeType;

Property Value

One of the XmlNodeType values.

See Also

XmlAttribute Class | XmlAttribute Members | System.NewXml Namespace


XmlAttribute.OwnerDocument

Gets the XmlDocument that contains this node.

[Visual Basic]
Overridable Public ReadOnly Property OwnerDocument As XmlDocument
[C#]
public XmlDocument OwnerDocument {override get;}
[C++]
public: __property virtual XmlDocument* get_OwnerDocument();
[JScript]
public function get OwnerDocument() : XmlDocument;

Property Value

An XmlDocument.

Remarks

When adding nodes to the current node, use the XmlDocument returned by the OwnerDocument property to create the node.

See Also

XmlAttribute Class | XmlAttribute Members | System.NewXml Namespace


XmlAttribute.OwnerElement

Gets the XmlElement node that contains this attribute.

[Visual Basic]
Overridable Public ReadOnly Property OwnerElement As XmlElement
[C#]
public XmlElement OwnerElement {virtual get;}
[C++]
public: __property virtual XmlElement* get_OwnerElement();
[JScript]
public function get OwnerElement() : XmlElement;

Property Value

The XmlElement node that contains this attribute or null if this attribute is not part of an XmlElement.

See Also

XmlAttribute Class | XmlAttribute Members | System.NewXml Namespace


XmlAttribute.ParentNode

Gets the parent of this node (for nodes that can have parents).

[Visual Basic]
Overridable Public ReadOnly Property ParentNode As XmlNode
[C#]
public XmlNode ParentNode {override get;}
[C++]
public: __property virtual XmlNode* get_ParentNode();
[JScript]
public function get ParentNode() : XmlNode;

Property Value

The XmlNode of this node's parent.

The value returned depends on the NodeType of the node. For XmlAttribute, this property is null.

See Also

XmlAttribute Class | XmlAttribute Members | System.NewXml Namespace


XmlAttribute.Prefix

Gets or sets the namespace prefix of this node.

[Visual Basic]
Overridable Public Property Prefix As String
[C#]
public string Prefix {override get; override set;}
[C++]
public: __property virtual String* get_Prefix();
public: __property virtual void set_Prefix(String*);
[JScript]
public function get Prefix() : String;
public function set Prefix(String);

Property Value

The namespace prefix of this node. If there is no prefix, this property is null.

Exceptions

Exception Type | Condition
INVALID_CHARACTER_ERR | Raised if the specified prefix contains an illegal character
NO_MODIFICATION_ALLOWED_ERR | Raised if this node is readonly
NAMESPACE_ERR | Raised if the specified prefix is malformed, if the namespaceURI of this node is null, if the specified prefix is "xml" and the namespaceURI of this node is different from "http://www.w3.org/XML/1998/namespace", if this node is an attribute and the specified prefix is "xmlns" and the namespaceURI of this node is different from "http://www.w3.org/2000/xmlns/", or if this node is an attribute and the qualifiedName of this node is "xmlns" [Namespaces].

Remarks

For example, the "xxx" for the element <myelement xxx:yyy="Some value"/> Note that setting this property, when permitted, changes the name property, which holds the qualified name, as well as the TagName on XmlElement and the Name properties on XmlAttribute. Note also that changing the prefix of an attribute that is known to have a default value, does not make a new attribute with the default value and the original prefix appear, since the namespaceURI and localName do not change.

See Also

XmlAttribute Class | XmlAttribute Members | System.NewXml Namespace


XmlAttribute.Specified

Gets a value indicating whether the value was explicitly set.

[Visual Basic]
Overridable Public ReadOnly Property Specified As Boolean
[C#]
public bool Specified {virtual get;}
[C++]
public: __property virtual bool get_Specified();
[JScript]
public function get Specified() : Boolean;

Property Value

true if this attribute was explicitly given a value in the original document; otherwise, false.

Remarks

Note that the implementation is in charge of this property, not the user. If the user changes the value of the attribute (even if it ends up having the same value as the default value) then the specified flag is automatically flipped to true. To re-specify the attribute as the default value from the DTD, the user must delete the attribute. The implementation will then make a new attribute available with specified set to false and the default value (if one exists).

In summary:

  1. If the attribute has an assigned value in the document then specified is true, and the value is the assigned value.
  2. If the attribute has no assigned value in the document and has a default value in the DTD, then specified is false, and the value is the default value in the DTD.
  3. If the attribute has no assigned value in the document and has a value of #IMPLIED in the DTD, then the attribute does not appear in the structure model of the document.

See Also

XmlAttribute Class | XmlAttribute Members | System.NewXml Namespace


XmlAttribute.Value

Gets or sets the value of the node.

[Visual Basic]
Overridable Public Property Value As String
[C#]
public string Value {override get; override set;}
[C++]
public: __property virtual String* get_Value();
public: __property virtual void set_Value(String*);
[JScript]
public function get Value() : String;
public function set Value(String);

Property Value

The value returned depends on the NodeType of the node. For XmlAttribute, this property is the value of attribute.

Exceptions

Exception Type | Condition
ReadOnlyException | Node is read-only.

See Also

XmlAttribute Class | XmlAttribute Members | System.NewXml Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlAttribute Methods

The methods of the XmlAttribute class are listed below. For a complete list of XmlAttribute class members, see the XmlAttribute Members topic.

Public:

AppendChild (inherited from XmlNode) | Adds the specified node to the end of the list of children of this node.
Clone (inherited from XmlNode) | Creates a duplicate of this node.
CloneNode | Creates a duplicate of this node.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from XmlNode) | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamespaceOfPrefix (inherited from XmlNode) | Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.
GetPrefixOfNamespace (inherited from XmlNode) | Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.
GetType (inherited from Object) | Gets the Type of the Object.
InsertAfter (inherited from XmlNode) | Inserts the specified node immediately after the specified reference node.
InsertBefore (inherited from XmlNode) | Inserts the specified node immediately before the specified reference node.
Normalize (inherited from XmlNode) | Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.
PrependChild (inherited from XmlNode) | Adds the specified node to the beginning of the list of children of this node.
RemoveAll (inherited from XmlNode) | Removes all the children and/or attributes of the current node.
RemoveChild (inherited from XmlNode) | Removes specified child node.
ReplaceChild (inherited from XmlNode) | Replaces the child node oldChild with newChild node.
Supports (inherited from XmlNode) | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteContentTo | Saves all the children of the node to the specified XmlWriter.
WriteTo | Saves the node to the specified XmlWriter.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlAttribute Class | System.NewXml Namespace


XmlAttribute.CloneNode

Creates a duplicate of this node.

[Visual Basic]
Overrides Public Function CloneNode( _
   ByVal deep As Boolean _
) As XmlNode
[C#]
public override XmlNode CloneNode(
   bool deep
);
[C++]
public: override XmlNode* CloneNode(
   bool deep
);
[JScript]
public override function CloneNode(
   deep : Boolean
) : XmlNode;

Parameters

deep
true to recursively clone the subtree under the specified node; false to clone only the node itself (and its attributes if the node is an XmlElement).

Return Value

The duplicate node.

Remarks

This method serves as a generic copy constructor for nodes. The duplicate node has no parent (ParentNode returns null).

See Also

XmlAttribute Class | XmlAttribute Members | System.NewXml Namespace


XmlAttribute.WriteContentTo

Saves all the children of the node to the specified XmlWriter.

[Visual Basic]
Overrides Public Sub WriteContentTo( _
   ByVal w As XmlWriter _
)
[C#]
public override void WriteContentTo(
   XmlWriter w
);
[C++]
public: override void WriteContentTo(
   XmlWriter* w
);
[JScript]
public override function WriteContentTo(
   w : XmlWriter
);

Parameters

w
The XmlWriter where you want to save the current node.

See Also

XmlAttribute Class | XmlAttribute Members | System.NewXml Namespace


XmlAttribute.WriteTo

Saves the node to the specified XmlWriter.

[Visual Basic]
Overrides Public Sub WriteTo( _
   ByVal w As XmlWriter _
)
[C#]
public override void WriteTo(
   XmlWriter w
);
[C++]
public: override void WriteTo(
   XmlWriter* w
);
[JScript]
public override function WriteTo(
   w : XmlWriter
);

Parameters

w
The XmlWriter where you want to save the node.

See Also

XmlAttribute Class | XmlAttribute Members | System.NewXml Namespace


XmlAttributeCollection Class

Represents a collection of attributes that can be accessed by name or index.

Object
XmlNamedNodeMap
XmlAttributeCollection

[Visual Basic]
Public Class XmlAttributeCollection
   Inherits XmlNamedNodeMap
[C#]
public class XmlAttributeCollection : XmlNamedNodeMap
[C++]
public __gc class XmlAttributeCollection : public XmlNamedNodeMap
[JScript]
public class XmlAttributeCollection extends XmlNamedNodeMap

Remarks

[To be supplied.]

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

XmlAttributeCollection Members | System.NewXml Namespace


XmlAttributeCollection Members

Public:

Properties

Count (inherited from XmlNamedNodeMap) | Gets the number of nodes in this XmlNamedNodeMap.
Item | Overloaded. Gets the specified attribute. In C#, this member is the indexer for the XmlAttributeCollection class.

Methods

Append | Inserts the specified node as the last node in the collection.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from XmlNamedNodeMap) | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedItem (inherited from XmlNamedNodeMap) | Overloaded. Retrieves the specified XmlNode from the collection of nodes in this XmlNamedNodeMap.
GetType (inherited from Object) | Gets the Type of the Object.
InsertAfter | Inserts the specified attribute immediately after the specified reference attribute.
InsertBefore | Inserts the specified attribute immediately before the specified reference attribute.
Item (inherited from XmlNamedNodeMap) | Retrieves the node at the specified index in this XmlNamedNodeMap.
Prepend | Inserts the specified node as the first node in the collection.
Remove | Removes the attribute node with the specified index from the map.
RemoveAll | Removes all attributes from the map.
RemoveAt | Removes the attribute node with the specified index from the map.
RemoveNamedItem (inherited from XmlNamedNodeMap) | Overloaded. Removes the specified node from this XmlNamedNodeMap.
SetNamedItem | Adds a XmlNode using its Name property
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlAttributeCollection Class | System.NewXml Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlAttributeCollection Properties

The properties of the XmlAttributeCollection class are listed below. For a complete list of XmlAttributeCollection class members, see the XmlAttributeCollection Members topic.

Public:

Count (inherited from XmlNamedNodeMap) | Gets the number of nodes in this XmlNamedNodeMap.
Item | Overloaded. Gets the specified attribute. In C#, this member is the indexer for the XmlAttributeCollection class.

See Also

XmlAttributeCollection Class | System.NewXml Namespace


XmlAttributeCollection.Item

Gets the specified attribute.

[C#] In C#, this member is the indexer for the XmlAttributeCollection class.

Overload List

Gets the attribute with the specified LocalName and NamespaceUri.

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(String, String) As XmlAttribute
[C#] public XmlAttribute this[String, String] {virtual get;}
[C++] public: __property virtual XmlAttribute* get_Item(String*, String*);
[JScript] XmlAttributeCollection.Item (String, String)

Gets the attribute with the specified index.

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(Integer) As XmlAttribute
[C#] public XmlAttribute this[int] {virtual get;}
[C++] public: __property virtual XmlAttribute* get_Item(int);
[JScript] XmlAttributeCollection.Item (int)

Gets the attribute with the specified name.

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(String) As XmlAttribute
[C#] public XmlAttribute this[String] {virtual get;}
[C++] public: __property virtual XmlAttribute* get_Item(String*);
[JScript] XmlAttributeCollection.Item (String)

See Also

XmlAttributeCollection Class | XmlAttributeCollection Members | System.NewXml Namespace


XmlAttributeCollection.Item (String, String)

Gets the attribute with the specified LocalName and NamespaceUri.

[C#] In C#, this member is the indexer for the XmlAttributeCollection class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As XmlAttribute
[C#]
public XmlAttribute this[
   string localName,
   string namespaceURI
] {virtual get;}
[C++]
public: __property virtual XmlAttribute* get_Item(
   String* localName,
   String* namespaceURI
);
[JScript]
returnValue = XmlAttributeCollectionObject.Item(localName, namespaceURI);
-or-
returnValue = XmlAttributeCollectionObject(localName, namespaceURI);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

localName
The name of the attribute.
namespaceURI
[To be supplied.]

Parameters [Visual Basic, C#, C++]

localName
The name of the attribute.
namespaceURI
[To be supplied.]

Property Value

The XmlAttribute for the specified attribute.

See Also

XmlAttributeCollection Class | XmlAttributeCollection Members | System.NewXml Namespace | XmlAttributeCollection.Item Overload List


XmlAttributeCollection.Item (Int32)

Gets the attribute with the specified index.

[C#] In C#, this member is the indexer for the XmlAttributeCollection class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal i As Integer _
) As XmlAttribute
[C#]
public XmlAttribute this[
   int i
] {virtual get;}
[C++]
public: __property virtual XmlAttribute* get_Item(
   int i
);
[JScript]
returnValue = XmlAttributeCollectionObject.Item(i);
-or-
returnValue = XmlAttributeCollectionObject(i);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

i
The index of the attribute.

Parameters [Visual Basic, C#, C++]

i
The index of the attribute.

Property Value

The XmlAttribute for the specified attribute.

See Also

XmlAttributeCollection Class | XmlAttributeCollection Members | System.NewXml Namespace | XmlAttributeCollection.Item Overload List


XmlAttributeCollection.Item (String)

Gets the attribute with the specified name.

[C#] In C#, this member is the indexer for the XmlAttributeCollection class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal name As String _
) As XmlAttribute
[C#]
public XmlAttribute this[
   string name
] {virtual get;}
[C++]
public: __property virtual XmlAttribute* get_Item(
   String* name
);
[JScript]
returnValue = XmlAttributeCollectionObject.Item(name);
-or-
returnValue = XmlAttributeCollectionObject(name);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
The name of the attribute. The name can include the prefix or leave it off.

Parameters [Visual Basic, C#, C++]

name
The name of the attribute. The name can include the prefix or leave it off.

Property Value

The XmlAttribute for the specified attribute.

See Also

XmlAttributeCollection Class | XmlAttributeCollection Members | System.NewXml Namespace | XmlAttributeCollection.Item Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlAttributeCollection Methods

The methods of the XmlAttributeCollection class are listed below. For a complete list of XmlAttributeCollection class members, see the XmlAttributeCollection Members topic.

Public:

Append | Inserts the specified node as the last node in the collection.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from XmlNamedNodeMap) | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedItem (inherited from XmlNamedNodeMap) | Overloaded. Retrieves the specified XmlNode from the collection of nodes in this XmlNamedNodeMap.
GetType (inherited from Object) | Gets the Type of the Object.
InsertAfter | Inserts the specified attribute immediately after the specified reference attribute.
InsertBefore | Inserts the specified attribute immediately before the specified reference attribute.
Item (inherited from XmlNamedNodeMap) | Retrieves the node at the specified index in this XmlNamedNodeMap.
Prepend | Inserts the specified node as the first node in the collection.
Remove | Removes the attribute node with the specified index from the map.
RemoveAll | Removes all attributes from the map.
RemoveAt | Removes the attribute node with the specified index from the map.
RemoveNamedItem (inherited from XmlNamedNodeMap) | Overloaded. Removes the specified node from this XmlNamedNodeMap.
SetNamedItem | Adds a XmlNode using its Name property
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlAttributeCollection Class | System.NewXml Namespace


XmlAttributeCollection.Append

Inserts the specified node as the last node in the collection.

[Visual Basic]
Overridable Public Function Append( _
   ByVal node As XmlAttribute _
) As XmlAttribute
[C#]
public virtual XmlAttribute Append(
   XmlAttribute node
);
[C++]
public: virtual XmlAttribute* Append(
   XmlAttribute* node
);
[JScript]
public function Append(
   node : XmlAttribute
) : XmlAttribute;

Parameters

node
XmlAttribute node to insert as the last node.

Remarks

If the node was already in the collection, it will be moved to the last position.

See Also

XmlAttributeCollection Class | XmlAttributeCollection Members | System.NewXml Namespace


XmlAttributeCollection.InsertAfter

Inserts the specified attribute immediately after the specified reference attribute.

[Visual Basic]
Overridable Public Function InsertAfter( _
   ByVal newNode As XmlAttribute, _
   ByVal refNode As XmlAttribute _
) As XmlAttribute
[C#]
public virtual XmlAttribute InsertAfter(
   XmlAttribute newNode,
   XmlAttribute refNode
);
[C++]
public: virtual XmlAttribute* InsertAfter(
   XmlAttribute* newNode,
   XmlAttribute* refNode
);
[JScript]
public function InsertAfter(
   newNode : XmlAttribute,
   refNode : XmlAttribute
) : XmlAttribute;

Parameters

newNode
XmlAttribute node to insert.
refNode
XmlAttribute node that is the reference attribute. The newNode is placed after the refNode.

See Also

XmlAttributeCollection Class | XmlAttributeCollection Members | System.NewXml Namespace


XmlAttributeCollection.InsertBefore

Inserts the specified attribute immediately before the specified reference attribute.

[Visual Basic]
Overridable Public Function InsertBefore( _
   ByVal newNode As XmlAttribute, _
   ByVal refNode As XmlAttribute _
) As XmlAttribute
[C#]
public virtual XmlAttribute InsertBefore(
   XmlAttribute newNode,
   XmlAttribute refNode
);
[C++]
public: virtual XmlAttribute* InsertBefore(
   XmlAttribute* newNode,
   XmlAttribute* refNode
);
[JScript]
public function InsertBefore(
   newNode : XmlAttribute,
   refNode : XmlAttribute
) : XmlAttribute;

Parameters

newNode
XmlAttribute node to insert.
refNode
XmlAttribute node that is the reference attribute. The newNode is placed before the refNode.

See Also

XmlAttributeCollection Class | XmlAttributeCollection Members | System.NewXml Namespace


XmlAttributeCollection.Prepend

Inserts the specified node as the first node in the collection.

[Visual Basic]
Overridable Public Function Prepend( _
   ByVal node As XmlAttribute _
) As XmlAttribute
[C#]
public virtual XmlAttribute Prepend(
   XmlAttribute node
);
[C++]
public: virtual XmlAttribute* Prepend(
   XmlAttribute* node
);
[JScript]
public function Prepend(
   node : XmlAttribute
) : XmlAttribute;

Parameters

node
XmlAttribute node to insert as the first node.

Remarks

If the node was already in the collection, it will be moved to the first position.

See Also

XmlAttributeCollection Class | XmlAttributeCollection Members | System.NewXml Namespace


XmlAttributeCollection.Remove

Removes the attribute node with the specified index from the map.

[Visual Basic]
Overridable Public Function Remove( _
   ByVal node As XmlAttribute _
) As XmlAttribute
[C#]
public virtual XmlAttribute Remove(
   XmlAttribute node
);
[C++]
public: virtual XmlAttribute* Remove(
   XmlAttribute* node
);
[JScript]
public function Remove(
   node : XmlAttribute
) : XmlAttribute;

Parameters

node
The node to remove

See Also

XmlAttributeCollection Class | XmlAttributeCollection Members | System.NewXml Namespace


XmlAttributeCollection.RemoveAll

Removes all attributes from the map.

[Visual Basic]
Overridable Public Sub RemoveAll()
[C#]
public virtual void RemoveAll();
[C++]
public: virtual void RemoveAll();
[JScript]
public function RemoveAll();

See Also

XmlAttributeCollection Class | XmlAttributeCollection Members | System.NewXml Namespace


XmlAttributeCollection.RemoveAt

Removes the attribute node with the specified index from the map.

[Visual Basic]
Overridable Public Function RemoveAt( _
   ByVal i As Integer _
) As XmlAttribute
[C#]
public virtual XmlAttribute RemoveAt(
   int i
);
[C++]
public: virtual XmlAttribute* RemoveAt(
   int i
);
[JScript]
public function RemoveAt(
   i : int
) : XmlAttribute;

Parameters

i
Index of the node to remove. The first node has index 0.

See Also

XmlAttributeCollection Class | XmlAttributeCollection Members | System.NewXml Namespace


XmlAttributeCollection.SetNamedItem

Adds a XmlNode using its Name property

[Visual Basic]
Overrides Public Function SetNamedItem( _
   ByVal node As XmlNode _
) As XmlNode
[C#]
public override XmlNode SetNamedItem(
   XmlNode node
);
[C++]
public: override XmlNode* SetNamedItem(
   XmlNode* node
);
[JScript]
public override function SetNamedItem(
   node : XmlNode
) : XmlNode;

Parameters

node
A XmlNode to store in this XmlAttributeCollection. The node will later be accessible using the value of the Name property of the node. If a node with that name is already present in the map, it is replaced by the new one.

Return Value

If the node replaces an existing node with the same name, the old node is returned; otherwise, null is returned.

Exceptions

Exception Type | Condition
WRONG_DOCUMENT_ERR | node was created from a different XmlDocument than the one that created this XmlNamedNodeMap.
NO_MODIFICATION_ALLOWED_ERR | This XmlNamedNodeMap is readonly.
INUSE_ATTRIBUTE_ERR | node is an XmlAttribute that is already an attribute of another XmlElement object. To re-use attributes in other elements, you must clone the XmlAttribute objects you want to re-use.

See Also

XmlAttributeCollection Class | XmlAttributeCollection Members | System.NewXml Namespace


XmlCDataSection Class

Used to quote or escape blocks of text to keep that text from being interpreted as markup language.

Object
XmlNode
XmlLinkedNode
XmlCharacterData
XmlCDataSection

[Visual Basic]
Public Class XmlCDataSection
   Inherits XmlCharacterData
[C#]
public class XmlCDataSection : XmlCharacterData
[C++]
public __gc class XmlCDataSection : public XmlCharacterData
[JScript]
public class XmlCDataSection extends XmlCharacterData

Remarks

[To be supplied.]

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

XmlCDataSection Members | System.NewXml Namespace


XmlCDataSection Members

Public:

Properties

Attributes (inherited from XmlNode) | Gets an XmlAttributeCollection containing the attributes of this node.
ChildNodes (inherited from XmlNode) | Gets all children of this node.
Data (inherited from XmlCharacterData) | Contains this node's data.
FirstChild (inherited from XmlNode) | Gets the first child of this node.
HasChildNodes (inherited from XmlNode) | Gets a value indicating whether this node has any child nodes.
InnerText (inherited from XmlCharacterData) | Gets or sets the concatenated values of the node and all its children.
InnerXml (inherited from XmlNode) | Gets or sets the markup representing just the children of this node.
IsReadOnly (inherited from XmlNode) | Gets a value indicating whether the node is read-only.
Item (inherited from XmlNode) | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlCDataSection class.
LastChild (inherited from XmlNode) | Gets the last child of this node.
Length (inherited from XmlCharacterData) | Gets the length of the data, in characters.
LocalName | Gets the name of the node without the namespace prefix.
Name | Gets the name of the node.
NamespaceURI (inherited from XmlNode) | Gets the namespace URI of this node.
NextSibling (inherited from XmlLinkedNode) | [To be supplied.]
NodeType | Gets the type of the current node.
OuterXml (inherited from XmlNode) | Gets the markup representing this node and all its children.
OwnerDocument (inherited from XmlNode) | Gets the XmlDocument that contains this node.
ParentNode (inherited from XmlNode) | Gets the parent of this node (for nodes that can have parents).
Prefix (inherited from XmlNode) | Gets or sets the namespace prefix of this node.
PreviousSibling (inherited from XmlLinkedNode) | [To be supplied.]
Value (inherited from XmlCharacterData) | Gets or sets the value of the node.

Methods

AppendChild (inherited from XmlNode) | Adds the specified node to the end of the list of children of this node.
AppendData (inherited from XmlCharacterData) | Appends the specified string to the end of the character data of the node.
Clone (inherited from XmlNode) | Creates a duplicate of this node.
CloneNode | Creates a duplicate of this node.
DeleteData (inherited from XmlCharacterData) | Remove a range of characters from the node.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from XmlNode) | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamespaceOfPrefix (inherited from XmlNode) | Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.
GetPrefixOfNamespace (inherited from XmlNode) | Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.
GetType (inherited from Object) | Gets the Type of the Object.
InsertAfter (inherited from XmlNode) | Inserts the specified node immediately after the specified reference node.
InsertBefore (inherited from XmlNode) | Inserts the specified node immediately before the specified reference node.
InsertData (inherited from XmlCharacterData) | Insert the specified string at the specified character offset.
Normalize (inherited from XmlNode) | Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.
PrependChild (inherited from XmlNode) | Adds the specified node to the beginning of the list of children of this node.
RemoveAll (inherited from XmlNode) | Removes all the children and/or attributes of the current node.
RemoveChild (inherited from XmlNode) | Removes specified child node.
ReplaceChild (inherited from XmlNode) | Replaces the child node oldChild with newChild node.
ReplaceData (inherited from XmlCharacterData) | Replace the specified number of characters starting at the specified offset with the specified string.
Substring (inherited from XmlCharacterData) | Retrieves a substring of the full string from the specified range.
Supports (inherited from XmlNode) | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteContentTo | Saves the node to the specified XmlWriter.
WriteTo | Saves the node to the specified XmlWriter.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlCDataSection Class | System.NewXml Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlCDataSection Properties

The properties of the XmlCDataSection class are listed below. For a complete list of XmlCDataSection class members, see the XmlCDataSection Members topic.

Public:

Attributes (inherited from XmlNode) | Gets an XmlAttributeCollection containing the attributes of this node.
ChildNodes (inherited from XmlNode) | Gets all children of this node.
Data (inherited from XmlCharacterData) | Contains this node's data.
FirstChild (inherited from XmlNode) | Gets the first child of this node.
HasChildNodes (inherited from XmlNode) | Gets a value indicating whether this node has any child nodes.
InnerText (inherited from XmlCharacterData) | Gets or sets the concatenated values of the node and all its children.
InnerXml (inherited from XmlNode) | Gets or sets the markup representing just the children of this node.
IsReadOnly (inherited from XmlNode) | Gets a value indicating whether the node is read-only.
Item (inherited from XmlNode) | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlCDataSection class.
LastChild (inherited from XmlNode) | Gets the last child of this node.
Length (inherited from XmlCharacterData) | Gets the length of the data, in characters.
LocalName | Gets the name of the node without the namespace prefix.
Name | Gets the name of the node.
NamespaceURI (inherited from XmlNode) | Gets the namespace URI of this node.
NextSibling (inherited from XmlLinkedNode) | [To be supplied.]
NodeType | Gets the type of the current node.
OuterXml (inherited from XmlNode) | Gets the markup representing this node and all its children.
OwnerDocument (inherited from XmlNode) | Gets the XmlDocument that contains this node.
ParentNode (inherited from XmlNode) | Gets the parent of this node (for nodes that can have parents).
Prefix (inherited from XmlNode) | Gets or sets the namespace prefix of this node.
PreviousSibling (inherited from XmlLinkedNode) | [To be supplied.]
Value (inherited from XmlCharacterData) | Gets or sets the value of the node.

See Also

XmlCDataSection Class | System.NewXml Namespace


XmlCDataSection.LocalName

Gets the name of the node without the namespace prefix.

[Visual Basic]
Overridable Public ReadOnly Property LocalName As String
[C#]
public string LocalName {override get;}
[C++]
public: __property virtual String* get_LocalName();
[JScript]
public function get LocalName() : String;

Property Value

The name of the node with the prefix removed. For example, LocalName is yyy for the element <xxx:yyy>.

For XmlComment, the name is "#cdata-section".

Remarks

For nodes created with a DOM Level 1 method, such as CreateElement, it is null.

See Also

XmlCDataSection Class | XmlCDataSection Members | System.NewXml Namespace


XmlCDataSection.Name

Gets the name of the node.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {override get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

Property Value

The name of the node. For XmlComment, the name is "#cdata-section".

See Also

XmlCDataSection Class | XmlCDataSection Members | System.NewXml Namespace


XmlCDataSection.NodeType

Gets the type of the current node.

[Visual Basic]
Overridable Public ReadOnly Property NodeType As XmlNodeType
[C#]
public XmlNodeType NodeType {override get;}
[C++]
public: __property virtual XmlNodeType get_NodeType();
[JScript]
public function get NodeType() : XmlNodeType;

Property Value

One of the XmlNodeType values.

See Also

XmlCDataSection Class | XmlCDataSection Members | System.NewXml Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlCDataSection Methods

The methods of the XmlCDataSection class are listed below. For a complete list of XmlCDataSection class members, see the XmlCDataSection Members topic.

Public:

AppendChild (inherited from XmlNode) | Adds the specified node to the end of the list of children of this node.
AppendData (inherited from XmlCharacterData) | Appends the specified string to the end of the character data of the node.
Clone (inherited from XmlNode) | Creates a duplicate of this node.
CloneNode | Creates a duplicate of this node.
DeleteData (inherited from XmlCharacterData) | Remove a range of characters from the node.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from XmlNode) | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamespaceOfPrefix (inherited from XmlNode) | Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.
GetPrefixOfNamespace (inherited from XmlNode) | Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.
GetType (inherited from Object) | Gets the Type of the Object.
InsertAfter (inherited from XmlNode) | Inserts the specified node immediately after the specified reference node.
InsertBefore (inherited from XmlNode) | Inserts the specified node immediately before the specified reference node.
InsertData (inherited from XmlCharacterData) | Insert the specified string at the specified character offset.
Normalize (inherited from XmlNode) | Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.
PrependChild (inherited from XmlNode) | Adds the specified node to the beginning of the list of children of this node.
RemoveAll (inherited from XmlNode) | Removes all the children and/or attributes of the current node.
RemoveChild (inherited from XmlNode) | Removes specified child node.
ReplaceChild (inherited from XmlNode) | Replaces the child node oldChild with newChild node.
ReplaceData (inherited from XmlCharacterData) | Replace the specified number of characters starting at the specified offset with the specified string.
Substring (inherited from XmlCharacterData) | Retrieves a substring of the full string from the specified range.
Supports (inherited from XmlNode) | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteContentTo | Saves the node to the specified XmlWriter.
WriteTo | Saves the node to the specified XmlWriter.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlCDataSection Class | System.NewXml Namespace


XmlCDataSection.CloneNode

Creates a duplicate of this node.

[Visual Basic]
Overrides Public Function CloneNode( _
   ByVal deep As Boolean _
) As XmlNode
[C#]
public override XmlNode CloneNode(
   bool deep
);
[C++]
public: override XmlNode* CloneNode(
   bool deep
);
[JScript]
public override function CloneNode(
   deep : Boolean
) : XmlNode;

Parameters

deep
true to recursively clone the subtree under the specified node; false to clone only the node itself (and its attributes if the node is an XmlElement).

Return Value

The duplicate node.

Remarks

This method serves as a generic copy constructor for nodes. The duplicate node has no parent (ParentNode returns null).

See Also

XmlCDataSection Class | XmlCDataSection Members | System.NewXml Namespace


XmlCDataSection.WriteContentTo

Saves the node to the specified XmlWriter.

[Visual Basic]
Overrides Public Sub WriteContentTo( _
   ByVal w As XmlWriter _
)
[C#]
public override void WriteContentTo(
   XmlWriter w
);
[C++]
public: override void WriteContentTo(
   XmlWriter* w
);
[JScript]
public override function WriteContentTo(
   w : XmlWriter
);

Parameters

w
The XmlWriter where you want to save the node.

See Also

XmlCDataSection Class | XmlCDataSection Members | System.NewXml Namespace


XmlCDataSection.WriteTo

Saves the node to the specified XmlWriter.

[Visual Basic]
Overrides Public Sub WriteTo( _
   ByVal w As XmlWriter _
)
[C#]
public override void WriteTo(
   XmlWriter w
);
[C++]
public: override void WriteTo(
   XmlWriter* w
);
[JScript]
public override function WriteTo(
   w : XmlWriter
);

Parameters

w
The XmlWriter where you want to save the node.

See Also

XmlCDataSection Class | XmlCDataSection Members | System.NewXml Namespace


XmlCharacterData Class

Provides text-manipulation methods that are used by several classes.

Object
XmlNode
XmlLinkedNode
XmlCharacterData

[Visual Basic]
MustInherit Public Class XmlCharacterData
   Inherits XmlLinkedNode
[C#]
public abstract class XmlCharacterData : XmlLinkedNode
[C++]
public __gc __abstract class XmlCharacterData : public
   XmlLinkedNode
[JScript]
public abstract class XmlCharacterData extends XmlLinkedNode

Remarks

[To be supplied.]

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

XmlCharacterData Members | System.NewXml Namespace


XmlCharacterData Members

Public:

Properties

Attributes (inherited from XmlNode) | Gets an XmlAttributeCollection containing the attributes of this node.
ChildNodes (inherited from XmlNode) | Gets all children of this node.
Data | Contains this node's data.
FirstChild (inherited from XmlNode) | Gets the first child of this node.
HasChildNodes (inherited from XmlNode) | Gets a value indicating whether this node has any child nodes.
InnerText | Gets or sets the concatenated values of the node and all its children.
InnerXml (inherited from XmlNode) | Gets or sets the markup representing just the children of this node.
IsReadOnly (inherited from XmlNode) | Gets a value indicating whether the node is read-only.
Item (inherited from XmlNode) | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlCharacterData class.
LastChild (inherited from XmlNode) | Gets the last child of this node.
Length | Gets the length of the data, in characters.
LocalName (inherited from XmlNode) | Gets the name of the node without the namespace prefix.
Name (inherited from XmlNode) | Gets the name of the node.
NamespaceURI (inherited from XmlNode) | Gets the namespace URI of this node.
NextSibling (inherited from XmlLinkedNode) | [To be supplied.]
NodeType (inherited from XmlNode) | Gets the type of the current node.
OuterXml (inherited from XmlNode) | Gets the markup representing this node and all its children.
OwnerDocument (inherited from XmlNode) | Gets the XmlDocument that contains this node.
ParentNode (inherited from XmlNode) | Gets the parent of this node (for nodes that can have parents).
Prefix (inherited from XmlNode) | Gets or sets the namespace prefix of this node.
PreviousSibling (inherited from XmlLinkedNode) | [To be supplied.]
Value | Gets or sets the value of the node.

Methods

AppendChild (inherited from XmlNode) | Adds the specified node to the end of the list of children of this node.
AppendData | Appends the specified string to the end of the character data of the node.
Clone (inherited from XmlNode) | Creates a duplicate of this node.
CloneNode (inherited from XmlNode) | Creates a duplicate of this node.
DeleteData | Remove a range of characters from the node.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from XmlNode) | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamespaceOfPrefix (inherited from XmlNode) | Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.
GetPrefixOfNamespace (inherited from XmlNode) | Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.
GetType (inherited from Object) | Gets the Type of the Object.
InsertAfter (inherited from XmlNode) | Inserts the specified node immediately after the specified reference node.
InsertBefore (inherited from XmlNode) | Inserts the specified node immediately before the specified reference node.
InsertData | Insert the specified string at the specified character offset.
Normalize (inherited from XmlNode) | Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.
PrependChild (inherited from XmlNode) | Adds the specified node to the beginning of the list of children of this node.
RemoveAll (inherited from XmlNode) | Removes all the children and/or attributes of the current node.
RemoveChild (inherited from XmlNode) | Removes specified child node.
ReplaceChild (inherited from XmlNode) | Replaces the child node oldChild with newChild node.
ReplaceData | Replace the specified number of characters starting at the specified offset with the specified string.
Substring | Retrieves a substring of the full string from the specified range.
Supports (inherited from XmlNode) | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteContentTo (inherited from XmlNode) | Saves all the children of the node to the specified XmlWriter.
WriteTo (inherited from XmlNode) | Saves the current node to the specified XmlWriter.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlCharacterData Class | System.NewXml Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlCharacterData Properties

The properties of the XmlCharacterData class are listed below. For a complete list of XmlCharacterData class members, see the XmlCharacterData Members topic.

Public:

Attributes (inherited from XmlNode) | Gets an XmlAttributeCollection containing the attributes of this node.
ChildNodes (inherited from XmlNode) | Gets all children of this node.
Data | Contains this node's data.
FirstChild (inherited from XmlNode) | Gets the first child of this node.
HasChildNodes (inherited from XmlNode) | Gets a value indicating whether this node has any child nodes.
InnerText | Gets or sets the concatenated values of the node and all its children.
InnerXml (inherited from XmlNode) | Gets or sets the markup representing just the children of this node.
IsReadOnly (inherited from XmlNode) | Gets a value indicating whether the node is read-only.
Item (inherited from XmlNode) | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlCharacterData class.
LastChild (inherited from XmlNode) | Gets the last child of this node.
Length | Gets the length of the data, in characters.
LocalName (inherited from XmlNode) | Gets the name of the node without the namespace prefix.
Name (inherited from XmlNode) | Gets the name of the node.
NamespaceURI (inherited from XmlNode) | Gets the namespace URI of this node.
NextSibling (inherited from XmlLinkedNode) | [To be supplied.]
NodeType (inherited from XmlNode) | Gets the type of the current node.
OuterXml (inherited from XmlNode) | Gets the markup representing this node and all its children.
OwnerDocument (inherited from XmlNode) | Gets the XmlDocument that contains this node.
ParentNode (inherited from XmlNode) | Gets the parent of this node (for nodes that can have parents).
Prefix (inherited from XmlNode) | Gets or sets the namespace prefix of this node.
PreviousSibling (inherited from XmlLinkedNode) | [To be supplied.]
Value | Gets or sets the value of the node.

See Also

XmlCharacterData Class | System.NewXml Namespace


XmlCharacterData.Data

Contains this node's data.

[Visual Basic]
Overridable Public Property Data As String
[C#]
public string Data {virtual get; virtual set;}
[C++]
public: __property virtual String* get_Data();
public: __property virtual void set_Data(String*);
[JScript]
public function get Data() : String;
public function set Data(String);

Property Value

The node's data. Same value as the Value property for this node.

See Also

XmlCharacterData Class | XmlCharacterData Members | System.NewXml Namespace


XmlCharacterData.InnerText

Gets or sets the concatenated values of the node and all its children.

[Visual Basic]
Overridable Public Property InnerText As String
[C#]
public string InnerText {override get; override set;}
[C++]
public: __property virtual String* get_InnerText();
public: __property virtual void set_InnerText(String*);
[JScript]
public function get InnerText() : String;
public function set InnerText(String);

Property Value

The concatenated values of the node and all its children.

See Also

XmlCharacterData Class | XmlCharacterData Members | System.NewXml Namespace


XmlCharacterData.Length

Gets the length of the data, in characters.

[Visual Basic]
Overridable Public ReadOnly Property Length As Integer
[C#]
public int Length {virtual get;}
[C++]
public: __property virtual int get_Length();
[JScript]
public function get Length() : int;

Property Value

Length, in characters, of the string in the Data property. This property may be zero, that is, CharacterData nodes can be empty.

See Also

XmlCharacterData Class | XmlCharacterData Members | System.NewXml Namespace


XmlCharacterData.Value

Gets or sets the value of the node.

[Visual Basic]
Overridable Public Property Value As String
[C#]
public string Value {override get; override set;}
[C++]
public: __property virtual String* get_Value();
public: __property virtual void set_Value(String*);
[JScript]
public function get Value() : String;
public function set Value(String);

Property Value

The value of the node.

Exceptions

Exception Type | Condition
ReadOnlyException | Node is read-only.

See Also

XmlCharacterData Class | XmlCharacterData Members | System.NewXml Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlCharacterData Methods

The methods of the XmlCharacterData class are listed below. For a complete list of XmlCharacterData class members, see the XmlCharacterData Members topic.

Public:

AppendChild (inherited from XmlNode) | Adds the specified node to the end of the list of children of this node.
AppendData | Appends the specified string to the end of the character data of the node.
Clone (inherited from XmlNode) | Creates a duplicate of this node.
CloneNode (inherited from XmlNode) | Creates a duplicate of this node.
DeleteData | Remove a range of characters from the node.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from XmlNode) | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamespaceOfPrefix (inherited from XmlNode) | Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.
GetPrefixOfNamespace (inherited from XmlNode) | Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.
GetType (inherited from Object) | Gets the Type of the Object.
InsertAfter (inherited from XmlNode) | Inserts the specified node immediately after the specified reference node.
InsertBefore (inherited from XmlNode) | Inserts the specified node immediately before the specified reference node.
InsertData | Insert the specified string at the specified character offset.
Normalize (inherited from XmlNode) | Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.
PrependChild (inherited from XmlNode) | Adds the specified node to the beginning of the list of children of this node.
RemoveAll (inherited from XmlNode) | Removes all the children and/or attributes of the current node.
RemoveChild (inherited from XmlNode) | Removes specified child node.
ReplaceChild (inherited from XmlNode) | Replaces the child node oldChild with newChild node.
ReplaceData | Replace the specified number of characters starting at the specified offset with the specified string.
Substring | Retrieves a substring of the full string from the specified range.
Supports (inherited from XmlNode) | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteContentTo (inherited from XmlNode) | Saves all the children of the node to the specified XmlWriter.
WriteTo (inherited from XmlNode) | Saves the current node to the specified XmlWriter.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlCharacterData Class | System.NewXml Namespace


XmlCharacterData.AppendData

Appends the specified string to the end of the character data of the node.

[Visual Basic]
Overridable Public Sub AppendData( _
   ByVal strData As String _
)
[C#]
public virtual void AppendData(
   string strData
);
[C++]
public: virtual void AppendData(
   String* strData
);
[JScript]
public function AppendData(
   strData : String
);

Parameters

strData
String data that is to be inserted into the existing string.

Remarks

On success, you have access to the concatenation of data and the specified string.

See Also

XmlCharacterData Class | XmlCharacterData Members | System.NewXml Namespace


XmlCharacterData.DeleteData

Remove a range of characters from the node.

[Visual Basic]
Overridable Public Sub DeleteData( _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
[C#]
public virtual void DeleteData(
   int offset,
   int count
);
[C++]
public: virtual void DeleteData(
   int offset,
   int count
);
[JScript]
public function DeleteData(
   offset : int,
   count : int
);

Parameters

offset
Offset, in characters, at which to start deleting string data.
count
[To be supplied.]

Remarks

On success, data and length reflect the change.

See Also

XmlCharacterData Class | XmlCharacterData Members | System.NewXml Namespace


XmlCharacterData.InsertData

Insert the specified string at the specified character offset.

[Visual Basic]
Overridable Public Sub InsertData( _
   ByVal offset As Integer, _
   ByVal strData As String _
)
[C#]
public virtual void InsertData(
   int offset,
   string strData
);
[C++]
public: virtual void InsertData(
   int offset,
   String* strData
);
[JScript]
public function InsertData(
   offset : int,
   strData : String
);

Parameters

offset
Offset, in characters, at which to insert the supplied string data.
strData
String data that is to be inserted into the existing string.

See Also

XmlCharacterData Class | XmlCharacterData Members | System.NewXml Namespace


XmlCharacterData.ReplaceData

Replace the specified number of characters starting at the specified offset with the specified string.

[Visual Basic]
Overridable Public Sub ReplaceData( _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal strData As String _
)
[C#]
public virtual void ReplaceData(
   int offset,
   int count,
   string strData
);
[C++]
public: virtual void ReplaceData(
   int offset,
   int count,
   String* strData
);
[JScript]
public function ReplaceData(
   offset : int,
   count : int,
   strData : String
);

Parameters

offset
Offset, in characters, at which to start replacing string data.
count
[To be supplied.]
strData
New data that replaces the old string data.

See Also

XmlCharacterData Class | XmlCharacterData Members | System.NewXml Namespace


XmlCharacterData.Substring

Retrieves a substring of the full string from the specified range.

[Visual Basic]
Overridable Public Function Substring( _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As String
[C#]
public virtual string Substring(
   int offset,
   int count
);
[C++]
public: virtual String* Substring(
   int offset,
   int count
);
[JScript]
public function Substring(
   offset : int,
   count : int
) : String;

Parameters

offset
Offset, in characters, from the beginning of the string. An offset of zero indicates copying from the start of the data.
count
[To be supplied.]

See Also

XmlCharacterData Class | XmlCharacterData Members | System.NewXml Namespace


XmlComment Class

Represents the content of an XML comment.

Object
XmlNode
XmlLinkedNode
XmlCharacterData
XmlComment

[Visual Basic]
Public Class XmlComment
   Inherits XmlCharacterData
[C#]
public class XmlComment : XmlCharacterData
[C++]
public __gc class XmlComment : public XmlCharacterData
[JScript]
public class XmlComment extends XmlCharacterData

Remarks

[To be supplied.]

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

XmlComment Members | System.NewXml Namespace


XmlComment Members

Public:

Properties

Attributes (inherited from XmlNode) | Gets an XmlAttributeCollection containing the attributes of this node.
ChildNodes (inherited from XmlNode) | Gets all children of this node.
Data (inherited from XmlCharacterData) | Contains this node's data.
FirstChild (inherited from XmlNode) | Gets the first child of this node.
HasChildNodes (inherited from XmlNode) | Gets a value indicating whether this node has any child nodes.
InnerText (inherited from XmlCharacterData) | Gets or sets the concatenated values of the node and all its children.
InnerXml (inherited from XmlNode) | Gets or sets the markup representing just the children of this node.
IsReadOnly (inherited from XmlNode) | Gets a value indicating whether the node is read-only.
Item (inherited from XmlNode) | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlComment class.
LastChild (inherited from XmlNode) | Gets the last child of this node.
Length (inherited from XmlCharacterData) | Gets the length of the data, in characters.
LocalName | Gets the name of the current node without the namespace prefix.
Name | Gets the name of the node.
NamespaceURI (inherited from XmlNode) | Gets the namespace URI of this node.
NextSibling (inherited from XmlLinkedNode) | [To be supplied.]
NodeType | Gets the type of the current node.
OuterXml (inherited from XmlNode) | Gets the markup representing this node and all its children.
OwnerDocument (inherited from XmlNode) | Gets the XmlDocument that contains this node.
ParentNode (inherited from XmlNode) | Gets the parent of this node (for nodes that can have parents).
Prefix (inherited from XmlNode) | Gets or sets the namespace prefix of this node.
PreviousSibling (inherited from XmlLinkedNode) | [To be supplied.]
Value (inherited from XmlCharacterData) | Gets or sets the value of the node.

Methods

AppendChild (inherited from XmlNode) | Adds the specified node to the end of the list of children of this node.
AppendData (inherited from XmlCharacterData) | Appends the specified string to the end of the character data of the node.
Clone (inherited from XmlNode) | Creates a duplicate of this node.
CloneNode | Creates a duplicate of this node.
DeleteData (inherited from XmlCharacterData) | Remove a range of characters from the node.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from XmlNode) | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamespaceOfPrefix (inherited from XmlNode) | Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.
GetPrefixOfNamespace (inherited from XmlNode) | Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.
GetType (inherited from Object) | Gets the Type of the Object.
InsertAfter (inherited from XmlNode) | Inserts the specified node immediately after the specified reference node.
InsertBefore (inherited from XmlNode) | Inserts the specified node immediately before the specified reference node.
InsertData (inherited from XmlCharacterData) | Insert the specified string at the specified character offset.
Normalize (inherited from XmlNode) | Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.
PrependChild (inherited from XmlNode) | Adds the specified node to the beginning of the list of children of this node.
RemoveAll (inherited from XmlNode) | Removes all the children and/or attributes of the current node.
RemoveChild (inherited from XmlNode) | Removes specified child node.
ReplaceChild (inherited from XmlNode) | Replaces the child node oldChild with newChild node.
ReplaceData (inherited from XmlCharacterData) | Replace the specified number of characters starting at the specified offset with the specified string.
Substring (inherited from XmlCharacterData) | Retrieves a substring of the full string from the specified range.
Supports (inherited from XmlNode) | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteContentTo | Saves all the children of the node to the specified XmlWriter.
WriteTo | Saves the node to the specified XmlWriter.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlComment Class | System.NewXml Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlComment Properties

The properties of the XmlComment class are listed below. For a complete list of XmlComment class members, see the XmlComment Members topic.

Public:

Attributes (inherited from XmlNode) | Gets an XmlAttributeCollection containing the attributes of this node.
ChildNodes (inherited from XmlNode) | Gets all children of this node.
Data (inherited from XmlCharacterData) | Contains this node's data.
FirstChild (inherited from XmlNode) | Gets the first child of this node.
HasChildNodes (inherited from XmlNode) | Gets a value indicating whether this node has any child nodes.
InnerText (inherited from XmlCharacterData) | Gets or sets the concatenated values of the node and all its children.
InnerXml (inherited from XmlNode) | Gets or sets the markup representing just the children of this node.
IsReadOnly (inherited from XmlNode) | Gets a value indicating whether the node is read-only.
Item (inherited from XmlNode) | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlComment class.
LastChild (inherited from XmlNode) | Gets the last child of this node.
Length (inherited from XmlCharacterData) | Gets the length of the data, in characters.
LocalName | Gets the name of the current node without the namespace prefix.
Name | Gets the name of the node.
NamespaceURI (inherited from XmlNode) | Gets the namespace URI of this node.
NextSibling (inherited from XmlLinkedNode) | [To be supplied.]
NodeType | Gets the type of the current node.
OuterXml (inherited from XmlNode) | Gets the markup representing this node and all its children.
OwnerDocument (inherited from XmlNode) | Gets the XmlDocument that contains this node.
ParentNode (inherited from XmlNode) | Gets the parent of this node (for nodes that can have parents).
Prefix (inherited from XmlNode) | Gets or sets the namespace prefix of this node.
PreviousSibling (inherited from XmlLinkedNode) | [To be supplied.]
Value (inherited from XmlCharacterData) | Gets or sets the value of the node.

See Also

XmlComment Class | System.NewXml Namespace


XmlComment.LocalName

Gets the name of the current node without the namespace prefix.

[Visual Basic]
Overridable Public ReadOnly Property LocalName As String
[C#]
public string LocalName {override get;}
[C++]
public: __property virtual String* get_LocalName();
[JScript]
public function get LocalName() : String;

Property Value

The name of the current node with the prefix removed. For example, LocalName is yyy for the element <xxx:yyy>.

For XmlComment, the name is "#comment".

See Also

XmlComment Class | XmlComment Members | System.NewXml Namespace


XmlComment.Name

Gets the name of the node.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {override get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

Property Value

The name of the node. For XmlComment, the name is "#comment".

See Also

XmlComment Class | XmlComment Members | System.NewXml Namespace


XmlComment.NodeType

Gets the type of the current node.

[Visual Basic]
Overridable Public ReadOnly Property NodeType As XmlNodeType
[C#]
public XmlNodeType NodeType {override get;}
[C++]
public: __property virtual XmlNodeType get_NodeType();
[JScript]
public function get NodeType() : XmlNodeType;

Property Value

One of the XmlNodeType values.

See Also

XmlComment Class | XmlComment Members | System.NewXml Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlComment Methods

The methods of the XmlComment class are listed below. For a complete list of XmlComment class members, see the XmlComment Members topic.

Public:

AppendChild (inherited from XmlNode) | Adds the specified node to the end of the list of children of this node.
AppendData (inherited from XmlCharacterData) | Appends the specified string to the end of the character data of the node.
Clone (inherited from XmlNode) | Creates a duplicate of this node.
CloneNode | Creates a duplicate of this node.
DeleteData (inherited from XmlCharacterData) | Remove a range of characters from the node.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from XmlNode) | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamespaceOfPrefix (inherited from XmlNode) | Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.
GetPrefixOfNamespace (inherited from XmlNode) | Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.
GetType (inherited from Object) | Gets the Type of the Object.
InsertAfter (inherited from XmlNode) | Inserts the specified node immediately after the specified reference node.
InsertBefore (inherited from XmlNode) | Inserts the specified node immediately before the specified reference node.
InsertData (inherited from XmlCharacterData) | Insert the specified string at the specified character offset.
Normalize (inherited from XmlNode) | Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.
PrependChild (inherited from XmlNode) | Adds the specified node to the beginning of the list of children of this node.
RemoveAll (inherited from XmlNode) | Removes all the children and/or attributes of the current node.
RemoveChild (inherited from XmlNode) | Removes specified child node.
ReplaceChild (inherited from XmlNode) | Replaces the child node oldChild with newChild node.
ReplaceData (inherited from XmlCharacterData) | Replace the specified number of characters starting at the specified offset with the specified string.
Substring (inherited from XmlCharacterData) | Retrieves a substring of the full string from the specified range.
Supports (inherited from XmlNode) | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteContentTo | Saves all the children of the node to the specified XmlWriter.
WriteTo | Saves the node to the specified XmlWriter.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlComment Class | System.NewXml Namespace


XmlComment.CloneNode

Creates a duplicate of this node.

[Visual Basic]
Overrides Public Function CloneNode( _
   ByVal deep As Boolean _
) As XmlNode
[C#]
public override XmlNode CloneNode(
   bool deep
);
[C++]
public: override XmlNode* CloneNode(
   bool deep
);
[JScript]
public override function CloneNode(
   deep : Boolean
) : XmlNode;

Parameters

deep
true to recursively clone the subtree under the specified node; false to clone only the node itself (and its attributes if the node is an XmlElement).

Return Value

The duplicate node.

Remarks

This method serves as a generic copy constructor for nodes. The duplicate node has no parent (ParentNode returns null).

See Also

XmlComment Class | XmlComment Members | System.NewXml Namespace


XmlComment.WriteContentTo

Saves all the children of the node to the specified XmlWriter.

[Visual Basic]
Overrides Public Sub WriteContentTo( _
   ByVal w As XmlWriter _
)
[C#]
public override void WriteContentTo(
   XmlWriter w
);
[C++]
public: override void WriteContentTo(
   XmlWriter* w
);
[JScript]
public override function WriteContentTo(
   w : XmlWriter
);

Parameters

w
The XmlWriter where you want to save the current node.

See Also

XmlComment Class | XmlComment Members | System.NewXml Namespace


XmlComment.WriteTo

Saves the node to the specified XmlWriter.

[Visual Basic]
Overrides Public Sub WriteTo( _
   ByVal w As XmlWriter _
)
[C#]
public override void WriteTo(
   XmlWriter w
);
[C++]
public: override void WriteTo(
   XmlWriter* w
);
[JScript]
public override function WriteTo(
   w : XmlWriter
);

Parameters

w
The XmlWriter where you want to save the node.

See Also

XmlComment Class | XmlComment Members | System.NewXml Namespace


XmlDataDocument Class

Represents an entire document. An XmlDataDocument can contain XML data or relational data (DataSet).

Object
XmlNode
XmlDocument
XmlDataDocument

[Visual Basic]
Public Class XmlDataDocument
   Inherits XmlDocument
[C#]
public class XmlDataDocument : XmlDocument
[C++]
public __gc class XmlDataDocument : public XmlDocument
[JScript]
public class XmlDataDocument extends XmlDocument

Remarks

XmlDataDocument enables you to load either relational data or XML data and manipulate that data using document object model (DOM). The DOM presents data as a hierarchy of node objects.

To load XML data into an XmlDataDocument, use the Load method.

To load relational data, specify the DataSet containing the relational data as the parameter in the XmlDataDocument constructor.

XmlDataDocument also enables you to handle the XML data it contains using a relational model (DataSet). The DataSet property returns a DataSet object, which provides a relational representation of the data in the XmlDataDocument.

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

XmlDataDocument Members | System.NewXml Namespace


XmlDataDocument Members

Public:

Constructor

XmlDataDocument Constructor Overloaded. Initializes a new instance of the XmlDataDocument class.

Properties

Attributes (inherited from XmlNode) | Gets an XmlAttributeCollection containing the attributes of this node.
ChildNodes (inherited from XmlNode) | Gets all children of this node.
DataSet | Gets a DataSet that provides a relational representation of the data in this XmlDataDocument.
DocumentElement (inherited from XmlDocument) | Gets the root XmlElement for the document.
DocumentType (inherited from XmlDocument) | Gets the node for the DOCTYPE declaration.
FirstChild (inherited from XmlNode) | Gets the first child of this node.
HasChildNodes (inherited from XmlNode) | Gets a value indicating whether this node has any child nodes.
Implementation (inherited from XmlDocument) | Gets the XmlImplementation object for this document.
InnerText (inherited from XmlNode) | Gets or sets the concatenated values of the node and all its children.
InnerXml (inherited from XmlNode) | Gets or sets the markup representing just the children of this node.
IsDocumentReadOnly (inherited from XmlDocument) | Gets or sets a value indicating whether the document is read-only.
IsReadOnly (inherited from XmlDocument) | Gets a value indicating whether the node is read-only.
Item (inherited from XmlNode) | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlDataDocument class.
LastChild (inherited from XmlNode) | Gets the last child of this node.
LocalName (inherited from XmlDocument) | Gets the name of the current node without the namespace prefix.
Name (inherited from XmlDocument) | Gets the name of the node.
NamespaceURI (inherited from XmlNode) | Gets the namespace URI of this node.
NameTable (inherited from XmlDocument) | Gets the XmlNameTable associated with this implementation.
NextSibling (inherited from XmlNode) | Gets the node immediately following this node.
NodeType (inherited from XmlDocument) | Gets the type of the current node.
OuterXml (inherited from XmlNode) | Gets the markup representing this node and all its children.
OwnerDocument (inherited from XmlDocument) | Gets the XmlDocument that contains this node.
ParentNode (inherited from XmlNode) | Gets the parent of this node (for nodes that can have parents).
Prefix (inherited from XmlNode) | Gets or sets the namespace prefix of this node.
PreserveWhiteSpace (inherited from XmlDocument) | Gets or sets a value indicating whether to preserve whitespace.
PreviousSibling (inherited from XmlNode) | Gets the node immediately preceding this node.
Value (inherited from XmlNode) | Gets or sets the value of the node.

Methods

AppendChild (inherited from XmlNode) | Adds the specified node to the end of the list of children of this node.
Clone (inherited from XmlNode) | Creates a duplicate of this node.
CloneNode (inherited from XmlDocument) | Creates a duplicate of this node.
CreateAttribute (inherited from XmlDocument) | Overloaded. Creates an XmlAttribute with the specified name.
CreateCDataSection (inherited from XmlDocument) | Creates a XmlCDataSection containing the specified data.
CreateComment (inherited from XmlDocument) | Creates an XmlComment containing the specified data.
CreateDocumentFragment (inherited from XmlDocument) | Creates an XmlDocumentFragment.
CreateElement (inherited from XmlDocument) | Overloaded. Creates an XmlElement.
CreateEntityReference (inherited from XmlDocument) | Creates an XmlEntityReference with the specified name.
CreateNode (inherited from XmlDocument) | Overloaded. Creates an XmlNode.
CreateProcessingInstruction (inherited from XmlDocument) | Creates a XmlProcessingInstruction with the specified name and data strings.
CreateTextNode (inherited from XmlDocument) | Creates an XmlText with the specified text.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetElementById (inherited from XmlDocument) | Returns the XmlElement with the specified ID.
GetElementFromRow |
GetElementsByTagName (inherited from XmlDocument) | Overloaded. Returns an XmlNodeList containing a list of all descendant elements that match the specified name.
GetEnumerator (inherited from XmlNode) | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamespaceOfPrefix (inherited from XmlNode) | Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.
GetPrefixOfNamespace (inherited from XmlNode) | Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.
GetRowFromElement |
GetType (inherited from Object) | Gets the Type of the Object.
ImportNode (inherited from XmlDocument) | Imports a node from another document to this document.
InsertAfter (inherited from XmlNode) | Inserts the specified node immediately after the specified reference node.
InsertBefore (inherited from XmlNode) | Inserts the specified node immediately before the specified reference node.
Load (inherited from XmlDocument) | Overloaded. Loads the specified XML data. By default, the Load method preserves SignificantWhitespace.
LoadDataSetMapping | Builds a relational view according to the specified schema.
LoadXml (inherited from XmlDocument) | Loads the XML document from the specified string.
Normalize (inherited from XmlNode) | Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.
PrependChild (inherited from XmlNode) | Adds the specified node to the beginning of the list of children of this node.
RemoveAll (inherited from XmlNode) | Removes all the children and/or attributes of the current node.
RemoveChild (inherited from XmlNode) | Removes specified child node.
ReplaceChild (inherited from XmlNode) | Replaces the child node oldChild with newChild node.
Save (inherited from XmlDocument) | Overloaded. Saves the XML document to the specified location.
SaveDataSetMapping |
Supports (inherited from XmlNode) | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteContentTo (inherited from XmlDocument) | Saves all the children of the node to the specified XmlWriter.
WriteTo | Saves the current node to the specified XmlWriter.

Events

NodeChanged (inherited from XmlDocument) | [To be supplied.]
NodeChanging (inherited from XmlDocument) | [To be supplied.]
NodeInserted (inherited from XmlDocument) | [To be supplied.]
NodeInserting (inherited from XmlDocument) | [To be supplied.]
NodeRemoved (inherited from XmlDocument) | [To be supplied.]
NodeRemoving (inherited from XmlDocument) | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Event Hookup:

Methods

AddOnNodeChanged (inherited from XmlDocument) | [To be supplied.]
AddOnNodeChanging (inherited from XmlDocument) | [To be supplied.]
AddOnNodeInserted (inherited from XmlDocument) | [To be supplied.]
AddOnNodeInserting (inherited from XmlDocument) | [To be supplied.]
AddOnNodeRemoved (inherited from XmlDocument) | [To be supplied.]
AddOnNodeRemoving (inherited from XmlDocument) | [To be supplied.]
RemoveOnNodeChanged (inherited from XmlDocument) | [To be supplied.]
RemoveOnNodeChanging (inherited from XmlDocument) | [To be supplied.]
RemoveOnNodeInserted (inherited from XmlDocument) | [To be supplied.]
RemoveOnNodeInserting (inherited from XmlDocument) | [To be supplied.]
RemoveOnNodeRemoved (inherited from XmlDocument) | [To be supplied.]
RemoveOnNodeRemoving (inherited from XmlDocument) | [To be supplied.]

See Also

XmlDataDocument Class | System.NewXml Namespace


XmlDataDocument Constructor

Initializes a new instance of the XmlDataDocument class.

Overload List

Initializes a new instance of the XmlDataDocument class.

[Visual Basic] Overloads Public Sub New()
[C#] public XmlDataDocument();
[C++] public: XmlDataDocument();
[JScript] public function XmlDataDocument();

Initializes a new instance of the XmlDataDocument class with the specified DataSet.

[Visual Basic] Overloads Public Sub New(DataSet)
[C#] public XmlDataDocument(DataSet);
[C++] public: XmlDataDocument(DataSet*);
[JScript] public function XmlDataDocument(DataSet);

See Also

XmlDataDocument Class | XmlDataDocument Members | System.NewXml Namespace


XmlDataDocument Constructor ()

Initializes a new instance of the XmlDataDocument class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public XmlDataDocument();
[C++]
public: XmlDataDocument();
[JScript]
public function XmlDataDocument();

See Also

XmlDataDocument Class | XmlDataDocument Members | System.NewXml Namespace | XmlDataDocument Constructor Overload List


XmlDataDocument Constructor (DataSet)

Initializes a new instance of the XmlDataDocument class with the specified DataSet.

[Visual Basic]
Overloads Public Sub New( _
   ByVal dataset As DataSet _
)
[C#]
public XmlDataDocument(
   DataSet dataset
);
[C++]
public: XmlDataDocument(
   DataSet* dataset
);
[JScript]
public function XmlDataDocument(
   dataset : DataSet
);

Parameters

dataset
The DataSet to load into the XmlDataDocument.

See Also

XmlDataDocument Class | XmlDataDocument Members | System.NewXml Namespace | XmlDataDocument Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlDataDocument Properties

The properties of the XmlDataDocument class are listed below. For a complete list of XmlDataDocument class members, see the XmlDataDocument Members topic.

Public:

Attributes (inherited from XmlNode) | Gets an XmlAttributeCollection containing the attributes of this node.
ChildNodes (inherited from XmlNode) | Gets all children of this node.
DataSet | Gets a DataSet that provides a relational representation of the data in this XmlDataDocument.
DocumentElement (inherited from XmlDocument) | Gets the root XmlElement for the document.
DocumentType (inherited from XmlDocument) | Gets the node for the DOCTYPE declaration.
FirstChild (inherited from XmlNode) | Gets the first child of this node.
HasChildNodes (inherited from XmlNode) | Gets a value indicating whether this node has any child nodes.
Implementation (inherited from XmlDocument) | Gets the XmlImplementation object for this document.
InnerText (inherited from XmlNode) | Gets or sets the concatenated values of the node and all its children.
InnerXml (inherited from XmlNode) | Gets or sets the markup representing just the children of this node.
IsDocumentReadOnly (inherited from XmlDocument) | Gets or sets a value indicating whether the document is read-only.
IsReadOnly (inherited from XmlDocument) | Gets a value indicating whether the node is read-only.
Item (inherited from XmlNode) | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlDataDocument class.
LastChild (inherited from XmlNode) | Gets the last child of this node.
LocalName (inherited from XmlDocument) | Gets the name of the current node without the namespace prefix.
Name (inherited from XmlDocument) | Gets the name of the node.
NamespaceURI (inherited from XmlNode) | Gets the namespace URI of this node.
NameTable (inherited from XmlDocument) | Gets the XmlNameTable associated with this implementation.
NextSibling (inherited from XmlNode) | Gets the node immediately following this node.
NodeType (inherited from XmlDocument) | Gets the type of the current node.
OuterXml (inherited from XmlNode) | Gets the markup representing this node and all its children.
OwnerDocument (inherited from XmlDocument) | Gets the XmlDocument that contains this node.
ParentNode (inherited from XmlNode) | Gets the parent of this node (for nodes that can have parents).
Prefix (inherited from XmlNode) | Gets or sets the namespace prefix of this node.
PreserveWhiteSpace (inherited from XmlDocument) | Gets or sets a value indicating whether to preserve whitespace.
PreviousSibling (inherited from XmlNode) | Gets the node immediately preceding this node.
Value (inherited from XmlNode) | Gets or sets the value of the node.

See Also

XmlDataDocument Class | System.NewXml Namespace


XmlDataDocument.DataSet

Gets a DataSet that provides a relational representation of the data in this XmlDataDocument.

[Visual Basic]
Public ReadOnly Property DataSet As DataSet
[C#]
public DataSet DataSet {get;}
[C++]
public: __property DataSet* get_DataSet();
[JScript]
public function get DataSet() : DataSet;

Property Value

A DataSet that can be used to access the data in this XmlDataDocument, using a relational model.

Remarks

The DataSet enables you to access the data in this XmlDataDocument using a relational model. This means that you can handle the data as tables and views, rows and columns, relations, and so on.

See Also

XmlDataDocument Class | XmlDataDocument Members | System.NewXml Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlDataDocument Methods

The methods of the XmlDataDocument class are listed below. For a complete list of XmlDataDocument class members, see the XmlDataDocument Members topic.

Public:

AppendChild (inherited from XmlNode) | Adds the specified node to the end of the list of children of this node.
Clone (inherited from XmlNode) | Creates a duplicate of this node.
CloneNode (inherited from XmlDocument) | Creates a duplicate of this node.
CreateAttribute (inherited from XmlDocument) | Overloaded. Creates an XmlAttribute with the specified name.
CreateCDataSection (inherited from XmlDocument) | Creates a XmlCDataSection containing the specified data.
CreateComment (inherited from XmlDocument) | Creates an XmlComment containing the specified data.
CreateDocumentFragment (inherited from XmlDocument) | Creates an XmlDocumentFragment.
CreateElement (inherited from XmlDocument) | Overloaded. Creates an XmlElement.
CreateEntityReference (inherited from XmlDocument) | Creates an XmlEntityReference with the specified name.
CreateNode (inherited from XmlDocument) | Overloaded. Creates an XmlNode.
CreateProcessingInstruction (inherited from XmlDocument) | Creates a XmlProcessingInstruction with the specified name and data strings.
CreateTextNode (inherited from XmlDocument) | Creates an XmlText with the specified text.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetElementById (inherited from XmlDocument) | Returns the XmlElement with the specified ID.
GetElementFromRow |
GetElementsByTagName (inherited from XmlDocument) | Overloaded. Returns an XmlNodeList containing a list of all descendant elements that match the specified name.
GetEnumerator (inherited from XmlNode) | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamespaceOfPrefix (inherited from XmlNode) | Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.
GetPrefixOfNamespace (inherited from XmlNode) | Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.
GetRowFromElement |
GetType (inherited from Object) | Gets the Type of the Object.
ImportNode (inherited from XmlDocument) | Imports a node from another document to this document.
InsertAfter (inherited from XmlNode) | Inserts the specified node immediately after the specified reference node.
InsertBefore (inherited from XmlNode) | Inserts the specified node immediately before the specified reference node.
Load (inherited from XmlDocument) | Overloaded. Loads the specified XML data. By default, the Load method preserves SignificantWhitespace.
LoadDataSetMapping | Builds a relational view according to the specified schema.
LoadXml (inherited from XmlDocument) | Loads the XML document from the specified string.
Normalize (inherited from XmlNode) | Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.
PrependChild (inherited from XmlNode) | Adds the specified node to the beginning of the list of children of this node.
RemoveAll (inherited from XmlNode) | Removes all the children and/or attributes of the current node.
RemoveChild (inherited from XmlNode) | Removes specified child node.
ReplaceChild (inherited from XmlNode) | Replaces the child node oldChild with newChild node.
Save (inherited from XmlDocument) | Overloaded. Saves the XML document to the specified location.
SaveDataSetMapping |
Supports (inherited from XmlNode) | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteContentTo (inherited from XmlDocument) | Saves all the children of the node to the specified XmlWriter.
WriteTo | Saves the current node to the specified XmlWriter.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Event Hookup:

AddOnNodeChanged (inherited from XmlDocument) | [To be supplied.]
AddOnNodeChanging (inherited from XmlDocument) | [To be supplied.]
AddOnNodeInserted (inherited from XmlDocument) | [To be supplied.]
AddOnNodeInserting (inherited from XmlDocument) | [To be supplied.]
AddOnNodeRemoved (inherited from XmlDocument) | [To be supplied.]
AddOnNodeRemoving (inherited from XmlDocument) | [To be supplied.]
RemoveOnNodeChanged (inherited from XmlDocument) | [To be supplied.]
RemoveOnNodeChanging (inherited from XmlDocument) | [To be supplied.]
RemoveOnNodeInserted (inherited from XmlDocument) | [To be supplied.]
RemoveOnNodeInserting (inherited from XmlDocument) | [To be supplied.]
RemoveOnNodeRemoved (inherited from XmlDocument) | [To be supplied.]
RemoveOnNodeRemoving (inherited from XmlDocument) | [To be supplied.]

See Also

XmlDataDocument Class | System.NewXml Namespace


XmlDataDocument.CreateElement

Creates an element with the specified Prefix, LocalName, and NamespaceURI.

[Visual Basic]
Overrides Public Function CreateElement( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As XmlElement
[C#]
public override XmlElement CreateElement(
   string prefix,
   string localName,
   string namespaceURI
);
[C++]
public: override XmlElement* CreateElement(
   String* prefix,
   String* localName,
   String* namespaceURI
);
[JScript]
public override function CreateElement(
   prefix : String,
   localName : String,
   namespaceURI : String
) : XmlElement;

Parameters

prefix
Prefix of the new element. If you specify null, there is no prefix.
localName
[To be supplied.]
namespaceURI
[To be supplied.]

Return Value

A new XmlElement object with the following attributes:

Attribute | Value
Name | Prefix concatenated with localName
namespaceURI | namespaceURI
Prefix | prefix or null if there is no prefix
LocalName | localName

See Also

XmlDataDocument Class | XmlDataDocument Members | System.NewXml Namespace


XmlDataDocument.GetElementFromRow

[Visual Basic]
Public Function GetElementFromRow( _
   ByVal r As DataRow _
) As XmlElement
[C#]
public XmlElement GetElementFromRow(
   DataRow r
);
[C++]
public: XmlElement* GetElementFromRow(
   DataRow* r
);
[JScript]
public function GetElementFromRow(
   r : DataRow
) : XmlElement;

Parameters

r
The DataRow whose associated XmlElement to retrieve.

Return Value

The XmlElement containing a representation of the specified DataRow.

See Also

XmlDataDocument Class | XmlDataDocument Members | System.NewXml Namespace


XmlDataDocument.GetRowFromElement

[Visual Basic]
Public Function GetRowFromElement( _
   ByVal e As XmlElement _
) As DataRow
[C#]
public DataRow GetRowFromElement(
   XmlElement e
);
[C++]
public: DataRow* GetRowFromElement(
   XmlElement* e
);
[JScript]
public function GetRowFromElement(
   e : XmlElement
) : DataRow;

Parameters

e
The XmlElement whose associated DataRow to retrieve.

Return Value

The DataRow containing a representation of the specified XmlElement.

See Also

XmlDataDocument Class | XmlDataDocument Members | System.NewXml Namespace


XmlDataDocument.Load

Loads the XML document from the specified XmlReader.

[Visual Basic]
Overrides Public Sub Load( _
   ByVal reader As XmlReader _
)
[C#]
public override void Load(
   XmlReader reader
);
[C++]
public: override void Load(
   XmlReader* reader
);
[JScript]
public override function Load(
   reader : XmlReader
);

Parameters

reader
XmlReader containing the XML document to load.

See Also

XmlDataDocument Class | XmlDataDocument Members | System.NewXml Namespace


XmlDataDocument.LoadDataSetMapping

Builds a relational view according to the specified schema.

[Visual Basic]
Public Sub LoadDataSetMapping( _
   ByVal schemaFile As String _
)
[C#]
public void LoadDataSetMapping(
   string schemaFile
);
[C++]
public: void LoadDataSetMapping(
   String* schemaFile
);
[JScript]
public function LoadDataSetMapping(
   schemaFile : String
);

Parameters

schemaFile
URL for the file containing the schema to use.

Remarks

If there is already a relational view defined for the XmlDataDocument, an exception is thrown.

See Also

XmlDataDocument Class | XmlDataDocument Members | System.NewXml Namespace


XmlDataDocument.SaveDataSetMapping

[Visual Basic]
Public Sub SaveDataSetMapping( _
   ByVal schemaFile As String _
)
[C#]
public void SaveDataSetMapping(
   string schemaFile
);
[C++]
public: void SaveDataSetMapping(
   String* schemaFile
);
[JScript]
public function SaveDataSetMapping(
   schemaFile : String
);

Parameters

schemaFile
Filename and location where you want to save the schema.

See Also

XmlDataDocument Class | XmlDataDocument Members | System.NewXml Namespace


XmlDataDocument.WriteTo

Saves the current node to the specified XmlWriter.

[Visual Basic]
Overrides Public Sub WriteTo( _
   ByVal writer As XmlWriter _
)
[C#]
public override void WriteTo(
   XmlWriter writer
);
[C++]
public: override void WriteTo(
   XmlWriter* writer
);
[JScript]
public override function WriteTo(
   writer : XmlWriter
);

Parameters

writer
The XmlWriter where you want to save the current node.

See Also

XmlDataDocument Class | XmlDataDocument Members | System.NewXml Namespace


XmlDocument Class

Represents an entire document. An XmlDocument contains XML data.

Object
XmlNode
XmlDocument

[Visual Basic]
Public Class XmlDocument
   Inherits XmlNode
[C#]
public class XmlDocument : XmlNode
[C++]
public __gc class XmlDocument : public XmlNode
[JScript]
public class XmlDocument extends XmlNode

Remarks

[To be supplied.]

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

XmlDocument Members | System.NewXml Namespace


XmlDocument Members

Public:

Constructor

XmlDocument Constructor Initializes a new instance of the XmlDocument class.

Properties

Attributes (inherited from XmlNode) | Gets an XmlAttributeCollection containing the attributes of this node.
ChildNodes (inherited from XmlNode) | Gets all children of this node.
DocumentElement | Gets the root XmlElement for the document.
DocumentType | Gets the node for the DOCTYPE declaration.
FirstChild (inherited from XmlNode) | Gets the first child of this node.
HasChildNodes (inherited from XmlNode) | Gets a value indicating whether this node has any child nodes.
Implementation | Gets the XmlImplementation object for this document.
InnerText (inherited from XmlNode) | Gets or sets the concatenated values of the node and all its children.
InnerXml (inherited from XmlNode) | Gets or sets the markup representing just the children of this node.
IsDocumentReadOnly | Gets or sets a value indicating whether the document is read-only.
IsReadOnly | Gets a value indicating whether the node is read-only.
Item (inherited from XmlNode) | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlDocument class.
LastChild (inherited from XmlNode) | Gets the last child of this node.
LocalName | Gets the name of the current node without the namespace prefix.
Name | Gets the name of the node.
NamespaceURI (inherited from XmlNode) | Gets the namespace URI of this node.
NameTable | Gets the XmlNameTable associated with this implementation.
NextSibling (inherited from XmlNode) | Gets the node immediately following this node.
NodeType | Gets the type of the current node.
OuterXml (inherited from XmlNode) | Gets the markup representing this node and all its children.
OwnerDocument | Gets the XmlDocument that contains this node.
ParentNode (inherited from XmlNode) | Gets the parent of this node (for nodes that can have parents).
Prefix (inherited from XmlNode) | Gets or sets the namespace prefix of this node.
PreserveWhiteSpace | Gets or sets a value indicating whether to preserve whitespace.
PreviousSibling (inherited from XmlNode) | Gets the node immediately preceding this node.
Value (inherited from XmlNode) | Gets or sets the value of the node.

Methods

AppendChild (inherited from XmlNode) | Adds the specified node to the end of the list of children of this node.
Clone (inherited from XmlNode) | Creates a duplicate of this node.
CloneNode | Creates a duplicate of this node.
CreateAttribute | Overloaded. Creates an XmlAttribute with the specified name.
CreateCDataSection | Creates a XmlCDataSection containing the specified data.
CreateComment | Creates an XmlComment containing the specified data.
CreateDocumentFragment | Creates an XmlDocumentFragment.
CreateElement | Overloaded. Creates an XmlElement.
CreateEntityReference | Creates an XmlEntityReference with the specified name.
CreateNode | Overloaded. Creates an XmlNode.
CreateProcessingInstruction | Creates a XmlProcessingInstruction with the specified name and data strings.
CreateTextNode | Creates an XmlText with the specified text.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetElementById | Returns the XmlElement with the specified ID.
GetElementsByTagName | Overloaded. Returns an XmlNodeList containing a list of all descendant elements that match the specified name.
GetEnumerator (inherited from XmlNode) | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamespaceOfPrefix (inherited from XmlNode) | Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.
GetPrefixOfNamespace (inherited from XmlNode) | Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.
GetType (inherited from Object) | Gets the Type of the Object.
ImportNode | Imports a node from another document to this document.
InsertAfter (inherited from XmlNode) | Inserts the specified node immediately after the specified reference node.
InsertBefore (inherited from XmlNode) | Inserts the specified node immediately before the specified reference node.
Load | Overloaded. Loads the specified XML data. By default, the Load method preserves SignificantWhitespace.
LoadXml | Loads the XML document from the specified string.
Normalize (inherited from XmlNode) | Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.
PrependChild (inherited from XmlNode) | Adds the specified node to the beginning of the list of children of this node.
RemoveAll (inherited from XmlNode) | Removes all the children and/or attributes of the current node.
RemoveChild (inherited from XmlNode) | Removes specified child node.
ReplaceChild (inherited from XmlNode) | Replaces the child node oldChild with newChild node.
Save | Overloaded. Saves the XML document to the specified location.
Supports (inherited from XmlNode) | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteContentTo | Saves all the children of the node to the specified XmlWriter.
WriteTo | Saves the node to the specified XmlWriter.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlDocument Class | System.NewXml Namespace


XmlDocument Constructor

Initializes a new instance of the XmlDocument class.

[Visual Basic]
Public Sub New()
[C#]
public XmlDocument();
[C++]
public: XmlDocument();
[JScript]
public function XmlDocument();

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlDocument Properties

The properties of the XmlDocument class are listed below. For a complete list of XmlDocument class members, see the XmlDocument Members topic.

Public:

Attributes (inherited from XmlNode) | Gets an XmlAttributeCollection containing the attributes of this node.
ChildNodes (inherited from XmlNode) | Gets all children of this node.
DocumentElement | Gets the root XmlElement for the document.
DocumentType | Gets the node for the DOCTYPE declaration.
FirstChild (inherited from XmlNode) | Gets the first child of this node.
HasChildNodes (inherited from XmlNode) | Gets a value indicating whether this node has any child nodes.
Implementation | Gets the XmlImplementation object for this document.
InnerText (inherited from XmlNode) | Gets or sets the concatenated values of the node and all its children.
InnerXml (inherited from XmlNode) | Gets or sets the markup representing just the children of this node.
IsDocumentReadOnly | Gets or sets a value indicating whether the document is read-only.
IsReadOnly | Gets a value indicating whether the node is read-only.
Item (inherited from XmlNode) | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlDocument class.
LastChild (inherited from XmlNode) | Gets the last child of this node.
LocalName | Gets the name of the current node without the namespace prefix.
Name | Gets the name of the node.
NamespaceURI (inherited from XmlNode) | Gets the namespace URI of this node.
NameTable | Gets the XmlNameTable associated with this implementation.
NextSibling (inherited from XmlNode) | Gets the node immediately following this node.
NodeType | Gets the type of the current node.
OuterXml (inherited from XmlNode) | Gets the markup representing this node and all its children.
OwnerDocument | Gets the XmlDocument that contains this node.
ParentNode (inherited from XmlNode) | Gets the parent of this node (for nodes that can have parents).
Prefix (inherited from XmlNode) | Gets or sets the namespace prefix of this node.
PreserveWhiteSpace | Gets or sets a value indicating whether to preserve whitespace.
PreviousSibling (inherited from XmlNode) | Gets the node immediately preceding this node.
Value (inherited from XmlNode) | Gets or sets the value of the node.

See Also

XmlDocument Class | System.NewXml Namespace


XmlDocument.DocumentElement

Gets the root XmlElement for the document.

[Visual Basic]
Public ReadOnly Property DocumentElement As XmlElement
[C#]
public XmlElement DocumentElement {get;}
[C++]
public: __property XmlElement* get_DocumentElement();
[JScript]
public function get DocumentElement() : XmlElement;

Property Value

The XmlElement object that represents the single element that represents the root of the XML document tree. It returns null if no root exists.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace


XmlDocument.DocumentType

Gets the node for the DOCTYPE declaration.

[Visual Basic]
Overridable Public ReadOnly Property DocumentType As _
   XmlDocumentType
[C#]
public XmlDocumentType DocumentType {virtual get;}
[C++]
public: __property virtual XmlDocumentType* get_DocumentType();
[JScript]
public function get DocumentType() : XmlDocumentType;

Property Value

The XmlNode containing the DocumentType (DOCTYPE declaration).

Remarks

An XmlDocument can have one and only one child with XmlNodeType equal to DocumentType.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace


XmlDocument.Implementation

Gets the XmlImplementation object for this document.

[Visual Basic]
Public ReadOnly Property Implementation As XmlImplementation
[C#]
public XmlImplementation Implementation {get;}
[C++]
public: __property XmlImplementation* get_Implementation();
[JScript]
public function get Implementation() : XmlImplementation;

Property Value

The XmlImplementation object for this document.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace


XmlDocument.IsDocumentReadOnly

Gets or sets a value indicating whether the document is read-only.

[Visual Basic]
Overridable Public Property IsDocumentReadOnly As Boolean
[C#]
public bool IsDocumentReadOnly {virtual get; virtual set;}
[C++]
public: __property virtual bool get_IsDocumentReadOnly();
public: __property virtual void set_IsDocumentReadOnly(bool);
[JScript]
public function get IsDocumentReadOnly() : Boolean;
public function set IsDocumentReadOnly(Boolean);

Property Value

true if the the current document is read-only.

false if the document is read/write.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace


XmlDocument.IsReadOnly

Gets a value indicating whether the node is read-only.

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {override get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;

Property Value

true if the the current node is read-only.

false if the node is read/write.

Remarks

A read-only node is one that you cannot change any of its properties, attributes, or children. But you can remove it from the tree and insert it somewhere else. For example, the node for an EntityReference is typically read-only because its children actually come from the DTD definition of that entity and typically the DTD is read-only.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace


XmlDocument.LocalName

Gets the name of the current node without the namespace prefix.

[Visual Basic]
Overridable Public ReadOnly Property LocalName As String
[C#]
public string LocalName {override get;}
[C++]
public: __property virtual String* get_LocalName();
[JScript]
public function get LocalName() : String;

Property Value

The name of the current node with the prefix removed. For example, LocalName is yyy for the element <xxx:yyy>.

For XmlDocument, the name is "#document".

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace


XmlDocument.Name

Gets the name of the node.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {override get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

Property Value

The name of the node. For XmlDocument, the name is "#document".

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace


XmlDocument.NameTable

Gets the XmlNameTable associated with this implementation.

[Visual Basic]
Public ReadOnly Property NameTable As XmlNameTable
[C#]
public XmlNameTable NameTable {get;}
[C++]
public: __property XmlNameTable* get_NameTable();
[JScript]
public function get NameTable() : XmlNameTable;

Property Value

XmlNameTable enabling you to get the atomized version of a string within the node.

Remarks

All node and attribute names returned from this class are atomized using this nametable. This means that when the same name is returned multiple times (like "Customer"), then the same String object will be returned for that name. This makes it possible for you to write efficient code that does object pointer comparisons on these strings instead of expensive string comparisons.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace


XmlDocument.NodeType

Gets the type of the current node.

[Visual Basic]
Overridable Public ReadOnly Property NodeType As XmlNodeType
[C#]
public XmlNodeType NodeType {override get;}
[C++]
public: __property virtual XmlNodeType get_NodeType();
[JScript]
public function get NodeType() : XmlNodeType;

Property Value

One of the XmlNodeType values.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace


XmlDocument.OwnerDocument

Gets the XmlDocument that contains this node.

[Visual Basic]
Overridable Public ReadOnly Property OwnerDocument As XmlDocument
[C#]
public XmlDocument OwnerDocument {override get;}
[C++]
public: __property virtual XmlDocument* get_OwnerDocument();
[JScript]
public function get OwnerDocument() : XmlDocument;

Property Value

An XmlDocument.

For XmlDocument (NodeType equals XmlNodeType.Document), this property is null.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace


XmlDocument.PreserveWhiteSpace

Gets or sets a value indicating whether to preserve whitespace.

[Visual Basic]
Public Property PreserveWhiteSpace As Boolean
[C#]
public bool PreserveWhiteSpace {get; set;}
[C++]
public: __property bool get_PreserveWhiteSpace();
public: __property void set_PreserveWhiteSpace(bool);
[JScript]
public function get PreserveWhiteSpace() : Boolean;
public function set PreserveWhiteSpace(Boolean);

Property Value

true to preserve whitespace; otherwise, false.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlDocument Methods

The methods of the XmlDocument class are listed below. For a complete list of XmlDocument class members, see the XmlDocument Members topic.

Public:

AppendChild (inherited from XmlNode) | Adds the specified node to the end of the list of children of this node.
Clone (inherited from XmlNode) | Creates a duplicate of this node.
CloneNode | Creates a duplicate of this node.
CreateAttribute | Overloaded. Creates an XmlAttribute with the specified name.
CreateCDataSection | Creates a XmlCDataSection containing the specified data.
CreateComment | Creates an XmlComment containing the specified data.
CreateDocumentFragment | Creates an XmlDocumentFragment.
CreateElement | Overloaded. Creates an XmlElement.
CreateEntityReference | Creates an XmlEntityReference with the specified name.
CreateNode | Overloaded. Creates an XmlNode.
CreateProcessingInstruction | Creates a XmlProcessingInstruction with the specified name and data strings.
CreateTextNode | Creates an XmlText with the specified text.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetElementById | Returns the XmlElement with the specified ID.
GetElementsByTagName | Overloaded. Returns an XmlNodeList containing a list of all descendant elements that match the specified name.
GetEnumerator (inherited from XmlNode) | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamespaceOfPrefix (inherited from XmlNode) | Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.
GetPrefixOfNamespace (inherited from XmlNode) | Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.
GetType (inherited from Object) | Gets the Type of the Object.
ImportNode | Imports a node from another document to this document.
InsertAfter (inherited from XmlNode) | Inserts the specified node immediately after the specified reference node.
InsertBefore (inherited from XmlNode) | Inserts the specified node immediately before the specified reference node.
Load | Overloaded. Loads the specified XML data. By default, the Load method preserves SignificantWhitespace.
LoadXml | Loads the XML document from the specified string.
Normalize (inherited from XmlNode) | Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.
PrependChild (inherited from XmlNode) | Adds the specified node to the beginning of the list of children of this node.
RemoveAll (inherited from XmlNode) | Removes all the children and/or attributes of the current node.
RemoveChild (inherited from XmlNode) | Removes specified child node.
ReplaceChild (inherited from XmlNode) | Replaces the child node oldChild with newChild node.
Save | Overloaded. Saves the XML document to the specified location.
Supports (inherited from XmlNode) | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteContentTo | Saves all the children of the node to the specified XmlWriter.
WriteTo | Saves the node to the specified XmlWriter.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlDocument Class | System.NewXml Namespace


XmlDocument.CloneNode

Creates a duplicate of this node.

[Visual Basic]
Overrides Public Function CloneNode( _
   ByVal deep As Boolean _
) As XmlNode
[C#]
public override XmlNode CloneNode(
   bool deep
);
[C++]
public: override XmlNode* CloneNode(
   bool deep
);
[JScript]
public override function CloneNode(
   deep : Boolean
) : XmlNode;

Parameters

deep
true to recursively clone the subtree under the specified node; false to clone only the node itself (and its attributes if the node is an XmlElement).

Return Value

The duplicate node.

Remarks

This method serves as a generic copy constructor for nodes. The duplicate node has no parent (ParentNode returns null).

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace


XmlDocument.CreateAttribute

Creates an XmlAttribute with the specified name.

Overload List

Creates an XmlAttribute with the specified LocalName and NamespaceURI.

[Visual Basic] Overloads Overridable Public Function CreateAttribute(String, String) As XmlAttribute
[C#] public virtual XmlAttribute CreateAttribute(String, String);
[C++] public: virtual XmlAttribute* CreateAttribute(String*, String*);
[JScript] public function CreateAttribute(String, String) : XmlAttribute;

Creates an XmlAttribute with the specified name.

[Visual Basic] Overloads Overridable Public Function CreateAttribute(String) As XmlAttribute
[C#] public virtual XmlAttribute CreateAttribute(String);
[C++] public: virtual XmlAttribute* CreateAttribute(String*);
[JScript] public function CreateAttribute(String) : XmlAttribute;

Creates an XmlAttribute with the specified Prefix, LocalName, and NamespaceURI.

[Visual Basic] Overloads Overridable Public Function CreateAttribute(String, String, String) As XmlAttribute
[C#] public virtual XmlAttribute CreateAttribute(String, String, String);
[C++] public: virtual XmlAttribute* CreateAttribute(String*, String*, String*);
[JScript] public function CreateAttribute(String, String, String) : XmlAttribute;

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace


XmlDocument.CreateAttribute (String, String)

Creates an XmlAttribute with the specified LocalName and NamespaceURI.

[Visual Basic]
Overloads Overridable Public Function CreateAttribute( _
   ByVal qualifiedName As String, _
   ByVal namespaceURI As String _
) As XmlAttribute
[C#]
public virtual XmlAttribute CreateAttribute(
   string qualifiedName,
   string namespaceURI
);
[C++]
public: virtual XmlAttribute* CreateAttribute(
   String* qualifiedName,
   String* namespaceURI
);
[JScript]
public function CreateAttribute(
   qualifiedName : String,
   namespaceURI : String
) : XmlAttribute;

Parameters

qualifiedName
Name of the attribute.
namespaceURI
NamespaceURI of the attribute.

Return Value

The new XmlAttribute.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace | XmlDocument.CreateAttribute Overload List


XmlDocument.CreateAttribute (String)

Creates an XmlAttribute with the specified name.

[Visual Basic]
Overloads Overridable Public Function CreateAttribute( _
   ByVal name As String _
) As XmlAttribute
[C#]
public virtual XmlAttribute CreateAttribute(
   string name
);
[C++]
public: virtual XmlAttribute* CreateAttribute(
   String* name
);
[JScript]
public function CreateAttribute(
   name : String
) : XmlAttribute;

Parameters

name
Name of the attribute.

Return Value

The new XmlAttribute.

Remarks

The XmlAttribute instance can then be set on an Element using the SetAttributeNode method. To create an attribute with a qualified name and namespace URI, use the other CreateAttribute method.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace | XmlDocument.CreateAttribute Overload List


XmlDocument.CreateAttribute (String, String, String)

Creates an XmlAttribute with the specified Prefix, LocalName, and NamespaceURI.

[Visual Basic]
Overloads Overridable Public Function CreateAttribute( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As XmlAttribute
[C#]
public virtual XmlAttribute CreateAttribute(
   string prefix,
   string localName,
   string namespaceURI
);
[C++]
public: virtual XmlAttribute* CreateAttribute(
   String* prefix,
   String* localName,
   String* namespaceURI
);
[JScript]
public function CreateAttribute(
   prefix : String,
   localName : String,
   namespaceURI : String
) : XmlAttribute;

Parameters

prefix
Prefix of the attribute. If you specify null, there is no prefix.
localName
LocalName of the attribute.
namespaceURI
NamespaceURI of the attribute.

Return Value

The new XmlAttribute.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace | XmlDocument.CreateAttribute Overload List


XmlDocument.CreateCDataSection

Creates a XmlCDataSection containing the specified data.

[Visual Basic]
Overridable Public Function CreateCDataSection( _
   ByVal data As String _
) As XmlCDataSection
[C#]
public virtual XmlCDataSection CreateCDataSection(
   string data
);
[C++]
public: virtual XmlCDataSection* CreateCDataSection(
   String* data
);
[JScript]
public function CreateCDataSection(
   data : String
) : XmlCDataSection;

Parameters

data
The data to add to the new XmlCDataSection.

Return Value

The new XmlCDataSection.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace


XmlDocument.CreateComment

Creates an XmlComment containing the specified data.

[Visual Basic]
Overridable Public Function CreateComment( _
   ByVal data As String _
) As XmlComment
[C#]
public virtual XmlComment CreateComment(
   string data
);
[C++]
public: virtual XmlComment* CreateComment(
   String* data
);
[JScript]
public function CreateComment(
   data : String
) : XmlComment;

Parameters

data
The data to add to the new XmlComment.

Return Value

The new XmlComment.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace


XmlDocument.CreateDocumentFragment

Creates an XmlDocumentFragment.

[Visual Basic]
Overridable Public Function CreateDocumentFragment() As _
   XmlDocumentFragment
[C#]
public virtual XmlDocumentFragment CreateDocumentFragment();
[C++]
public: virtual XmlDocumentFragment* CreateDocumentFragment();
[JScript]
public function CreateDocumentFragment() : XmlDocumentFragment;

Return Value

The new XmlDocumentFragment.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace


XmlDocument.CreateElement

Creates an XmlElement.

Overload List

Creates an element with the specified name.

[Visual Basic] Overloads Overridable Public Function CreateElement(String) As XmlElement
[C#] public virtual XmlElement CreateElement(String);
[C++] public: virtual XmlElement* CreateElement(String*);
[JScript] public function CreateElement(String) : XmlElement;

Creates an XmlElement with the specified LocalName and NamespaceURI.

[Visual Basic] Overloads Overridable Public Function CreateElement(String, String) As XmlElement
[C#] public virtual XmlElement CreateElement(String, String);
[C++] public: virtual XmlElement* CreateElement(String*, String*);
[JScript] public function CreateElement(String, String) : XmlElement;

Creates an element with the specified Prefix, LocalName, and NamespaceURI.

[Visual Basic] Overloads Overridable Public Function CreateElement(String, String, String) As XmlElement
[C#] public virtual XmlElement CreateElement(String, String, String);
[C++] public: virtual XmlElement* CreateElement(String*, String*, String*);
[JScript] public function CreateElement(String, String, String) : XmlElement;

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace


XmlDocument.CreateElement (String)

Creates an element with the specified name.

[Visual Basic]
Overloads Overridable Public Function CreateElement( _
   ByVal name As String _
) As XmlElement
[C#]
public virtual XmlElement CreateElement(
   string name
);
[C++]
public: virtual XmlElement* CreateElement(
   String* name
);
[JScript]
public function CreateElement(
   name : String
) : XmlElement;

Parameters

name
Name of the element.

Return Value

The new XmlElement.

Remarks

Note that the instance returned implements the XmlElement interface, so attributes can be specified directly on the returned object. In addition, if there are known attributes with default values, XmlAttribute nodes representing them are automatically created and attached to the element.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace | XmlDocument.CreateElement Overload List


XmlDocument.CreateElement (String, String)

Creates an XmlElement with the specified LocalName and NamespaceURI.

[Visual Basic]
Overloads Overridable Public Function CreateElement( _
   ByVal qualifiedName As String, _
   ByVal namespaceURI As String _
) As XmlElement
[C#]
public virtual XmlElement CreateElement(
   string qualifiedName,
   string namespaceURI
);
[C++]
public: virtual XmlElement* CreateElement(
   String* qualifiedName,
   String* namespaceURI
);
[JScript]
public function CreateElement(
   qualifiedName : String,
   namespaceURI : String
) : XmlElement;

Parameters

qualifiedName
Name of the element.
namespaceURI
NamespaceURI of the element.

Return Value

The new XmlElement.

Remarks

For example:

[C++]
CreateElement("foo:bar", "urn:abc");

This results in the same XmlElement that would have resulted from loading the following XML text:

<foo:bar xmlns:foo="urn:abc"/>

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace | XmlDocument.CreateElement Overload List


XmlDocument.CreateElement (String, String, String)

Creates an element with the specified Prefix, LocalName, and NamespaceURI.

[Visual Basic]
Overloads Overridable Public Function CreateElement( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As XmlElement
[C#]
public virtual XmlElement CreateElement(
   string prefix,
   string localName,
   string namespaceURI
);
[C++]
public: virtual XmlElement* CreateElement(
   String* prefix,
   String* localName,
   String* namespaceURI
);
[JScript]
public function CreateElement(
   prefix : String,
   localName : String,
   namespaceURI : String
) : XmlElement;

Parameters

prefix
Prefix of the new element. If you specify null, there is no prefix.
localName
[To be supplied.]
namespaceURI
[To be supplied.]

Return Value

A new XmlElement object with the following attributes:

Attribute | Value
Name | Prefix concatenated with localName
namespaceURI | namespaceURI
Prefix | prefix or null if there is no prefix
LocalName | localName

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace | XmlDocument.CreateElement Overload List


XmlDocument.CreateEntityReference

Creates an XmlEntityReference with the specified name.

[Visual Basic]
Overridable Public Function CreateEntityReference( _
   ByVal name As String _
) As XmlEntityReference
[C#]
public virtual XmlEntityReference CreateEntityReference(
   string name
);
[C++]
public: virtual XmlEntityReference* CreateEntityReference(
   String* name
);
[JScript]
public function CreateEntityReference(
   name : String
) : XmlEntityReference;

Parameters

name
Name of the entity reference.

Return Value

The new XmlEntityReference.

Remarks

If the referenced entity is known, the child list of the XmlEntityReference node is made the same as that of the corresponding XmlEntity node. Note: If any descendant of the XmlEntity node has an unbound namespace prefix, the corresponding descendant of the created XmlEntityReference node is also unbound; (its NamespaceURI is null). The DOM Level 2 does not support any mechanism to fix up unresolved namespace prefixes.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace


XmlDocument.CreateNode

Creates an XmlNode.

Overload List

Creates an XmlNode with the specified XmlNodeType, Name, and NamespaceURI.

[Visual Basic] Overloads Overridable Public Function CreateNode(XmlNodeType, String, String) As XmlNode
[C#] public virtual XmlNode CreateNode(XmlNodeType, String, String);
[C++] public: virtual XmlNode* CreateNode(XmlNodeType, String, String);
[JScript] public function CreateNode(XmlNodeType, String, String) : XmlNode;

Creates an XmlNode with the specified node type, Name, and NamespaceURI.

[Visual Basic] Overloads Overridable Public Function CreateNode(String, String, String) As XmlNode
[C#] public virtual XmlNode CreateNode(String, String, String);
[C++] public: virtual XmlNode* CreateNode(String*, String*, String*);
[JScript] public function CreateNode(String, String, String) : XmlNode;

Creates a XmlNode with the specified XmlNodeType, Prefix, Name, and NamespaceURI.

[Visual Basic] Overloads Overridable Public Function CreateNode(XmlNodeType, String, String, String) As XmlNode
[C#] public virtual XmlNode CreateNode(XmlNodeType, String, String, String);
[C++] public: virtual XmlNode* CreateNode(XmlNodeType, String, String, String);
[JScript] public function CreateNode(XmlNodeType, String, String, String) : XmlNode;

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace


XmlDocument.CreateNode (XmlNodeType, String, String)

Creates an XmlNode with the specified XmlNodeType, Name, and NamespaceURI.

[Visual Basic]
Overloads Overridable Public Function CreateNode( _
   ByVal type As XmlNodeType, _
   ByVal name As String, _
   ByVal namespaceURI As String _
) As XmlNode
[C#]
public virtual XmlNode CreateNode(
   XmlNodeType type,
   string name,
   string namespaceURI
);
[C++]
public: virtual XmlNode* CreateNode(
   XmlNodeType type,
   String* name,
   String* namespaceURI
);
[JScript]
public function CreateNode(
   type : XmlNodeType,
   name : String,
   namespaceURI : String
) : XmlNode;

Parameters

type
XmlNodeType of the new node.
name
[To be supplied.]
namespaceURI
[To be supplied.]

Return Value

The new XmlNode.

Exceptions

Exception Type | Condition
ArgumentException | The name was not provided and the XmlNodeType requires a name.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace | XmlDocument.CreateNode Overload List


XmlDocument.CreateNode (String, String, String)

Creates an XmlNode with the specified node type, Name, and NamespaceURI.

[Visual Basic]
Overloads Overridable Public Function CreateNode( _
   ByVal nodeTypeString As String, _
   ByVal name As String, _
   ByVal namespaceURI As String _
) As XmlNode
[C#]
public virtual XmlNode CreateNode(
   string nodeTypeString,
   string name,
   string namespaceURI
);
[C++]
public: virtual XmlNode* CreateNode(
   String* nodeTypeString,
   String* name,
   String* namespaceURI
);
[JScript]
public function CreateNode(
   nodeTypeString : String,
   name : String,
   namespaceURI : String
) : XmlNode;

Parameters

nodeTypeString
String version of the XmlNodeType of the new node.
name
[To be supplied.]
namespaceURI
[To be supplied.]

Return Value

The new XmlNode.

Exceptions

Exception Type | Condition
ArgumentException | The name was not provided and the XmlNodeType requires a name.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace | XmlDocument.CreateNode Overload List


XmlDocument.CreateNode (XmlNodeType, String, String, String)

Creates a XmlNode with the specified XmlNodeType, Prefix, Name, and NamespaceURI.

[Visual Basic]
Overloads Overridable Public Function CreateNode( _
   ByVal type As XmlNodeType, _
   ByVal prefix As String, _
   ByVal name As String, _
   ByVal namespaceURI As String _
) As XmlNode
[C#]
public virtual XmlNode CreateNode(
   XmlNodeType type,
   string prefix,
   string name,
   string namespaceURI
);
[C++]
public: virtual XmlNode* CreateNode(
   XmlNodeType type,
   String* prefix,
   String* name,
   String* namespaceURI
);
[JScript]
public function CreateNode(
   type : XmlNodeType,
   prefix : String,
   name : String,
   namespaceURI : String
) : XmlNode;

Parameters

type
XmlNodeType of the new node.
prefix
[To be supplied.]
name
[To be supplied.]
namespaceURI
[To be supplied.]

Return Value

The new XmlNode.

Exceptions

Exception Type | Condition
ArgumentException | The name was not provided and the XmlNodeType requires a name.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace | XmlDocument.CreateNode Overload List


XmlDocument.CreateProcessingInstruction

Creates a XmlProcessingInstruction with the specified name and data strings.

[Visual Basic]
Overridable Public Function CreateProcessingInstruction( _
   ByVal target As String, _
   ByVal data As String _
) As XmlProcessingInstruction
[C#]
public virtual XmlProcessingInstruction CreateProcessingInstruction(
   string target,
   string data
);
[C++]
public: virtual XmlProcessingInstruction* CreateProcessingInstruction(
   String* target,
   String* data
);
[JScript]
public function CreateProcessingInstruction(
   target : String,
   data : String
) : XmlProcessingInstruction;

Parameters

target
[To be supplied.]
data
The data for the processing instruction.

Return Value

The new XmlProcessingInstruction.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace


XmlDocument.CreateTextNode

Creates an XmlText with the specified text.

[Visual Basic]
Overridable Public Function CreateTextNode( _
   ByVal text As String _
) As XmlText
[C#]
public virtual XmlText CreateTextNode(
   string text
);
[C++]
public: virtual XmlText* CreateTextNode(
   String* text
);
[JScript]
public function CreateTextNode(
   text : String
) : XmlText;

Parameters

text
The text for the text node.

Return Value

The new XmlTextNode.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace


XmlDocument.GetElementById

Returns the XmlElement with the specified ID.

[Visual Basic]
Overridable Public Function GetElementById( _
   ByVal elementId As String _
) As XmlNode
[C#]
public virtual XmlNode GetElementById(
   string elementId
);
[C++]
public: virtual XmlNode* GetElementById(
   String* elementId
);
[JScript]
public function GetElementById(
   elementId : String
) : XmlNode;

Parameters

elementId
ID attribute to match

Return Value

The XmlNode for the matching element. If no such element exists, returns null.

Remarks

Behavior is not defined if more than one element has this ID. Note: The DOM implementation must have information that says which attributes are of type ID. Attributes with the name "ID" are not of type ID unless so defined. Implementations that do not know whether attributes are of type ID or not are expected to return null.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace


XmlDocument.GetElementsByTagName

Returns an XmlNodeList containing a list of all descendant elements that match the specified name.

Overload List

Returns an XmlNodeList containing a list of all descendant elements that match the specified name.

[Visual Basic] Overloads Overridable Public Function GetElementsByTagName(String) As XmlNodeList
[C#] public virtual XmlNodeList GetElementsByTagName(String);
[C++] public: virtual XmlNodeList* GetElementsByTagName(String*);
[JScript] public function GetElementsByTagName(String) : XmlNodeList;

Returns an XmlNodeList containing a list of all descendant elements that match the specified name.

[Visual Basic] Overloads Overridable Public Function GetElementsByTagName(String, String) As XmlNodeList
[C#] public virtual XmlNodeList GetElementsByTagName(String, String);
[C++] public: virtual XmlNodeList* GetElementsByTagName(String*, String*);
[JScript] public function GetElementsByTagName(String, String) : XmlNodeList;

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace


XmlDocument.GetElementsByTagName (String)

Returns an XmlNodeList containing a list of all descendant elements that match the specified name.

[Visual Basic]
Overloads Overridable Public Function GetElementsByTagName( _
   ByVal name As String _
) As XmlNodeList
[C#]
public virtual XmlNodeList GetElementsByTagName(
   string name
);
[C++]
public: virtual XmlNodeList* GetElementsByTagName(
   String* name
);
[JScript]
public function GetElementsByTagName(
   name : String
) : XmlNodeList;

Parameters

name
The name to match. The special value "*" matches all tags.

Return Value

An XmlNodeList containing a list of all matching nodes.

Remarks

The nodes are placed in the order in which they would be encountered in a preorder traversal of the XmlElement tree.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace | XmlDocument.GetElementsByTagName Overload List


XmlDocument.GetElementsByTagName (String, String)

Returns an XmlNodeList containing a list of all descendant elements that match the specified name.

[Visual Basic]
Overloads Overridable Public Function GetElementsByTagName( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As XmlNodeList
[C#]
public virtual XmlNodeList GetElementsByTagName(
   string localName,
   string namespaceURI
);
[C++]
public: virtual XmlNodeList* GetElementsByTagName(
   String* localName,
   String* namespaceURI
);
[JScript]
public function GetElementsByTagName(
   localName : String,
   namespaceURI : String
) : XmlNodeList;

Parameters

localName
The LocalName to match. The special value "*" matches all tags.
namespaceURI
NamespaceURI to match.

Return Value

An XmlNodeList containing a list of all matching nodes.

Remarks

The nodes are placed in the order in which they would be encountered in a preorder traversal of the XmlElement tree.

The same as the simple GetElementsByTagName, except it is matching on localName and namespaceURI instead of Name which is prefix and localName.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace | XmlDocument.GetElementsByTagName Overload List


XmlDocument.ImportNode

Imports a node from another document to this document.

[Visual Basic]
Overridable Public Function ImportNode( _
   ByVal node As XmlNode, _
   ByVal deep As Boolean _
) As XmlNode
[C#]
public virtual XmlNode ImportNode(
   XmlNode node,
   bool deep
);
[C++]
public: virtual XmlNode* ImportNode(
   XmlNode* node,
   bool deep
);
[JScript]
public function ImportNode(
   node : XmlNode,
   deep : Boolean
) : XmlNode;

Parameters

node
[To be supplied.]
deep
true to perform a deep clone; otherwise, false.

Return Value

The imported XmlNode.

Remarks

The returned node has no parent; The source node is not altered or removed from the original document; this method creates a new copy of the source node. For all nodes, importing a node creates a node object owned by the importing document, with attribute values identical to the source node's nodeName and nodeType, plus the attributes related to namespaces (prefix, localName, and namespaceURI). Additional information is copied as appropriate to the nodeType, attempting to mirror the behavior expected if a fragment of XML or HTML source was copied from one document to another, recognizing that the two documents may have different DTDs in the XML case.

The following list describes the specifics for every type of node.

XmlNodeType | Description
Attribute | The specified flag is set to true on the generated XmlAttribute. The descendants of the source XmlAttribute are recursively imported and the resulting nodes reassembled to form the corresponding subtree. Note that the deep parameter does not apply to XmlAttribute nodes; they always carry their children with them when imported.
DocumentFragment | If the deep option was set true, the descendants of the source element will be recursively imported and the resulting nodes reassembled to form the corresponding subtree. Otherwise, this simply generates an empty XmlDocumentFragment.
Document | Document nodes cannot be imported.
DocumentType | DocumentType nodes cannot be imported.
Element | Specified attribute nodes of the source element are imported, and the generated XmlAttribute nodes are attached to the generated XmlElement. Default attributes are not copied, though if the document being imported into defines default attributes for this element name, those are assigned. If the deep parameter was set to true, the descendants of the source element will be recursively imported and the resulting nodes reassembled to form the corresponding subtree.
Entity | Entity nodes can be imported, however in the current release of the DOM the DocumentType is readonly. Ability to add these imported nodes to a DocumentType will be considered for addition to a future release of the DOM. On import, the publicId, systemId, and notationName properties are copied. If a deep import is requested, the descendants of the the source Entity is recursively imported and the resulting nodes reassembled to form the corresponding subtree.
EntityReference | Only the XmlEntityReference itself is copied, even if a deep import is requested, since the source and destination documents might have defined the entity differently. If the document being imported into provides a definition for this entity name, its value is assigned.
Notation | Notation nodes can be imported, however in the current release of the DOM the DocumentType is readonly. Ability to add these imported nodes to a DocumentType will be considered for addition to a future release of the DOM. On import, the publicId and systemId attributes are copied. Note that the deep parameter does not apply to Notation nodes since they never have any children.
ProcessingInstruction | The imported node copies its target and data values from those of the source node.
Text, CData, Comment | These three types of nodes inheriting from CharacterData copy their data and length properties from those of the source node.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace


XmlDocument.Load

Loads the specified XML data.

By default, the Load method preserves SignificantWhitespace.

Overload List

Loads the XML document from the specified XmlReader.

[Visual Basic] Overloads Overridable Public Sub Load(XmlReader)
[C#] public virtual void Load(XmlReader);
[C++] public: virtual void Load(XmlReader*);
[JScript] public function Load(XmlReader);

Loads the XML document from the specified TextReader.

[Visual Basic] Overloads Overridable Public Sub Load(TextReader)
[C#] public virtual void Load(TextReader);
[C++] public: virtual void Load(TextReader*);
[JScript] public function Load(TextReader);

Loads the XML document from the specified URL.

[Visual Basic] Overloads Overridable Public Sub Load(String)
[C#] public virtual void Load(String);
[C++] public: virtual void Load(String*);
[JScript] public function Load(String);

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace


XmlDocument.Load (XmlReader)

Loads the XML document from the specified XmlReader.

[Visual Basic]
Overloads Overridable Public Sub Load( _
   ByVal reader As XmlReader _
)
[C#]
public virtual void Load(
   XmlReader reader
);
[C++]
public: virtual void Load(
   XmlReader* reader
);
[JScript]
public function Load(
   reader : XmlReader
);

Parameters

reader
XmlReader containing the XML document to load.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace | XmlDocument.Load Overload List


XmlDocument.Load (TextReader)

Loads the XML document from the specified TextReader.

[Visual Basic]
Overloads Overridable Public Sub Load( _
   ByVal reader As TextReader _
)
[C#]
public virtual void Load(
   TextReader reader
);
[C++]
public: virtual void Load(
   TextReader* reader
);
[JScript]
public function Load(
   reader : TextReader
);

Parameters

reader
TextReader containing the XML document to load.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace | XmlDocument.Load Overload List


XmlDocument.Load (String)

Loads the XML document from the specified URL.

[Visual Basic]
Overloads Overridable Public Sub Load( _
   ByVal filename As String _
)
[C#]
public virtual void Load(
   string filename
);
[C++]
public: virtual void Load(
   String* filename
);
[JScript]
public function Load(
   filename : String
);

Parameters

filename
URL for the file containing the XML document to load.

Exceptions

Exception Type | Condition
XmlException | A load or parse error in the XML. In this case, the document will remain empty.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace | XmlDocument.Load Overload List


XmlDocument.LoadXml

Loads the XML document from the specified string.

[Visual Basic]
Overridable Public Sub LoadXml( _
   ByVal xml As String _
)
[C#]
public virtual void LoadXml(
   string xml
);
[C++]
public: virtual void LoadXml(
   String* xml
);
[JScript]
public function LoadXml(
   xml : String
);

Parameters

xml
String containing the XML document to load.

Exceptions

Exception Type | Condition
XmlException | A load or parse error in the XML. In this case, the document will remain empty.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace


XmlDocument.Save

Saves the XML document to the specified location.

Overload List

Saves the XML document to the specified file.

[Visual Basic] Overloads Overridable Public Sub Save(String)
[C#] public virtual void Save(String);
[C++] public: virtual void Save(String*);
[JScript] public function Save(String);

Saves the XML document to the specified TextWriter.

[Visual Basic] Overloads Overridable Public Sub Save(TextWriter)
[C#] public virtual void Save(TextWriter);
[C++] public: virtual void Save(TextWriter*);
[JScript] public function Save(TextWriter);

Saves the XML document to the specified XmlWriter.

[Visual Basic] Overloads Overridable Public Sub Save(XmlWriter)
[C#] public virtual void Save(XmlWriter);
[C++] public: virtual void Save(XmlWriter*);
[JScript] public function Save(XmlWriter);

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace


XmlDocument.Save (String)

Saves the XML document to the specified file.

[Visual Basic]
Overloads Overridable Public Sub Save( _
   ByVal filename As String _
)
[C#]
public virtual void Save(
   string filename
);
[C++]
public: virtual void Save(
   String* filename
);
[JScript]
public function Save(
   filename : String
);

Parameters

filename
The location of the file where you want to save the document.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace | XmlDocument.Save Overload List


XmlDocument.Save (TextWriter)

Saves the XML document to the specified TextWriter.

[Visual Basic]
Overloads Overridable Public Sub Save( _
   ByVal writer As TextWriter _
)
[C#]
public virtual void Save(
   TextWriter writer
);
[C++]
public: virtual void Save(
   TextWriter* writer
);
[JScript]
public function Save(
   writer : TextWriter
);

Parameters

writer
The TextWriter where you want to save the document.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace | XmlDocument.Save Overload List


XmlDocument.Save (XmlWriter)

Saves the XML document to the specified XmlWriter.

[Visual Basic]
Overloads Overridable Public Sub Save( _
   ByVal writer As XmlWriter _
)
[C#]
public virtual void Save(
   XmlWriter writer
);
[C++]
public: virtual void Save(
   XmlWriter* writer
);
[JScript]
public function Save(
   writer : XmlWriter
);

Parameters

writer
The XmlWriter where you want to save the document.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace | XmlDocument.Save Overload List


XmlDocument.WriteContentTo

Saves all the children of the node to the specified XmlWriter.

[Visual Basic]
Overrides Public Sub WriteContentTo( _
   ByVal w As XmlWriter _
)
[C#]
public override void WriteContentTo(
   XmlWriter w
);
[C++]
public: override void WriteContentTo(
   XmlWriter* w
);
[JScript]
public override function WriteContentTo(
   w : XmlWriter
);

Parameters

w
The XmlWriter where you want to save the current node.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace


XmlDocument.WriteTo

Saves the node to the specified XmlWriter.

[Visual Basic]
Overrides Public Sub WriteTo( _
   ByVal w As XmlWriter _
)
[C#]
public override void WriteTo(
   XmlWriter w
);
[C++]
public: override void WriteTo(
   XmlWriter* w
);
[JScript]
public override function WriteTo(
   w : XmlWriter
);

Parameters

w
The XmlWriter where you want to save the node.

See Also

XmlDocument Class | XmlDocument Members | System.NewXml Namespace


XmlDocumentFragment Class

Represents a lightweight object that is useful for tree insert operations.

Object
XmlNode
XmlDocumentFragment

[Visual Basic]
Public Class XmlDocumentFragment
   Inherits XmlNode
[C#]
public class XmlDocumentFragment : XmlNode
[C++]
public __gc class XmlDocumentFragment : public XmlNode
[JScript]
public class XmlDocumentFragment extends XmlNode

Remarks

[To be supplied.]

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

XmlDocumentFragment Members | System.NewXml Namespace


XmlDocumentFragment Members

Public:

Properties

Attributes (inherited from XmlNode) | Gets an XmlAttributeCollection containing the attributes of this node.
ChildNodes (inherited from XmlNode) | Gets all children of this node.
FirstChild (inherited from XmlNode) | Gets the first child of this node.
HasChildNodes (inherited from XmlNode) | Gets a value indicating whether this node has any child nodes.
InnerText (inherited from XmlNode) | Gets or sets the concatenated values of the node and all its children.
InnerXml (inherited from XmlNode) | Gets or sets the markup representing just the children of this node.
IsReadOnly (inherited from XmlNode) | Gets a value indicating whether the node is read-only.
Item (inherited from XmlNode) | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlDocumentFragment class.
LastChild (inherited from XmlNode) | Gets the last child of this node.
LocalName | Gets the name of the current node without the namespace prefix.
Name | Gets the name of the node.
NamespaceURI (inherited from XmlNode) | Gets the namespace URI of this node.
NextSibling (inherited from XmlNode) | Gets the node immediately following this node.
NodeType | Gets the type of the current node.
OuterXml (inherited from XmlNode) | Gets the markup representing this node and all its children.
OwnerDocument | Gets the XmlDocument that contains this node.
ParentNode | Gets the parent of this node (for nodes that can have parents).
Prefix (inherited from XmlNode) | Gets or sets the namespace prefix of this node.
PreviousSibling (inherited from XmlNode) | Gets the node immediately preceding this node.
Value (inherited from XmlNode) | Gets or sets the value of the node.

Methods

AppendChild (inherited from XmlNode) | Adds the specified node to the end of the list of children of this node.
Clone (inherited from XmlNode) | Creates a duplicate of this node.
CloneNode | Creates a duplicate of this node.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from XmlNode) | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamespaceOfPrefix (inherited from XmlNode) | Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.
GetPrefixOfNamespace (inherited from XmlNode) | Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.
GetType (inherited from Object) | Gets the Type of the Object.
InsertAfter (inherited from XmlNode) | Inserts the specified node immediately after the specified reference node.
InsertBefore (inherited from XmlNode) | Inserts the specified node immediately before the specified reference node.
Normalize (inherited from XmlNode) | Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.
PrependChild (inherited from XmlNode) | Adds the specified node to the beginning of the list of children of this node.
RemoveAll (inherited from XmlNode) | Removes all the children and/or attributes of the current node.
RemoveChild (inherited from XmlNode) | Removes specified child node.
ReplaceChild (inherited from XmlNode) | Replaces the child node oldChild with newChild node.
Supports (inherited from XmlNode) | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteContentTo | Saves all the children of the node to the specified XmlWriter.
WriteTo | Saves the node to the specified XmlWriter.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlDocumentFragment Class | System.NewXml Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlDocumentFragment Properties

The properties of the XmlDocumentFragment class are listed below. For a complete list of XmlDocumentFragment class members, see the XmlDocumentFragment Members topic.

Public:

Attributes (inherited from XmlNode) | Gets an XmlAttributeCollection containing the attributes of this node.
ChildNodes (inherited from XmlNode) | Gets all children of this node.
FirstChild (inherited from XmlNode) | Gets the first child of this node.
HasChildNodes (inherited from XmlNode) | Gets a value indicating whether this node has any child nodes.
InnerText (inherited from XmlNode) | Gets or sets the concatenated values of the node and all its children.
InnerXml (inherited from XmlNode) | Gets or sets the markup representing just the children of this node.
IsReadOnly (inherited from XmlNode) | Gets a value indicating whether the node is read-only.
Item (inherited from XmlNode) | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlDocumentFragment class.
LastChild (inherited from XmlNode) | Gets the last child of this node.
LocalName | Gets the name of the current node without the namespace prefix.
Name | Gets the name of the node.
NamespaceURI (inherited from XmlNode) | Gets the namespace URI of this node.
NextSibling (inherited from XmlNode) | Gets the node immediately following this node.
NodeType | Gets the type of the current node.
OuterXml (inherited from XmlNode) | Gets the markup representing this node and all its children.
OwnerDocument | Gets the XmlDocument that contains this node.
ParentNode | Gets the parent of this node (for nodes that can have parents).
Prefix (inherited from XmlNode) | Gets or sets the namespace prefix of this node.
PreviousSibling (inherited from XmlNode) | Gets the node immediately preceding this node.
Value (inherited from XmlNode) | Gets or sets the value of the node.

See Also

XmlDocumentFragment Class | System.NewXml Namespace


XmlDocumentFragment.LocalName

Gets the name of the current node without the namespace prefix.

[Visual Basic]
Overridable Public ReadOnly Property LocalName As String
[C#]
public string LocalName {override get;}
[C++]
public: __property virtual String* get_LocalName();
[JScript]
public function get LocalName() : String;

Property Value

The name of the current node with the prefix removed. For example, LocalName is yyy for the element <xxx:yyy>.

For XmlDocumentFragment, the name is "#document-fragment".

See Also

XmlDocumentFragment Class | XmlDocumentFragment Members | System.NewXml Namespace


XmlDocumentFragment.Name

Gets the name of the node.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {override get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

Property Value

The name of the node. For XmlDocumentFragment, the name is "#document-fragment".

See Also

XmlDocumentFragment Class | XmlDocumentFragment Members | System.NewXml Namespace


XmlDocumentFragment.NodeType

Gets the type of the current node.

[Visual Basic]
Overridable Public ReadOnly Property NodeType As XmlNodeType
[C#]
public XmlNodeType NodeType {override get;}
[C++]
public: __property virtual XmlNodeType get_NodeType();
[JScript]
public function get NodeType() : XmlNodeType;

Property Value

One of the XmlNodeType values.

See Also

XmlDocumentFragment Class | XmlDocumentFragment Members | System.NewXml Namespace


XmlDocumentFragment.OwnerDocument

Gets the XmlDocument that contains this node.

[Visual Basic]
Overridable Public ReadOnly Property OwnerDocument As XmlDocument
[C#]
public XmlDocument OwnerDocument {override get;}
[C++]
public: __property virtual XmlDocument* get_OwnerDocument();
[JScript]
public function get OwnerDocument() : XmlDocument;

Property Value

An XmlDocument.

Remarks

When adding nodes to the current node, use the XmlDocument returned by the OwnerDocument property to create the node.

See Also

XmlDocumentFragment Class | XmlDocumentFragment Members | System.NewXml Namespace


XmlDocumentFragment.ParentNode

Gets the parent of this node (for nodes that can have parents).

[Visual Basic]
Overridable Public ReadOnly Property ParentNode As XmlNode
[C#]
public XmlNode ParentNode {override get;}
[C++]
public: __property virtual XmlNode* get_ParentNode();
[JScript]
public function get ParentNode() : XmlNode;

Property Value

The XmlNode of this node's parent.

The value returned depends on the NodeType of the node. For XmlDocumentFragment, this property is null.

See Also

XmlDocumentFragment Class | XmlDocumentFragment Members | System.NewXml Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlDocumentFragment Methods

The methods of the XmlDocumentFragment class are listed below. For a complete list of XmlDocumentFragment class members, see the XmlDocumentFragment Members topic.

Public:

AppendChild (inherited from XmlNode) | Adds the specified node to the end of the list of children of this node.
Clone (inherited from XmlNode) | Creates a duplicate of this node.
CloneNode | Creates a duplicate of this node.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from XmlNode) | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamespaceOfPrefix (inherited from XmlNode) | Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.
GetPrefixOfNamespace (inherited from XmlNode) | Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.
GetType (inherited from Object) | Gets the Type of the Object.
InsertAfter (inherited from XmlNode) | Inserts the specified node immediately after the specified reference node.
InsertBefore (inherited from XmlNode) | Inserts the specified node immediately before the specified reference node.
Normalize (inherited from XmlNode) | Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.
PrependChild (inherited from XmlNode) | Adds the specified node to the beginning of the list of children of this node.
RemoveAll (inherited from XmlNode) | Removes all the children and/or attributes of the current node.
RemoveChild (inherited from XmlNode) | Removes specified child node.
ReplaceChild (inherited from XmlNode) | Replaces the child node oldChild with newChild node.
Supports (inherited from XmlNode) | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteContentTo | Saves all the children of the node to the specified XmlWriter.
WriteTo | Saves the node to the specified XmlWriter.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlDocumentFragment Class | System.NewXml Namespace


XmlDocumentFragment.CloneNode

Creates a duplicate of this node.

[Visual Basic]
Overrides Public Function CloneNode( _
   ByVal deep As Boolean _
) As XmlNode
[C#]
public override XmlNode CloneNode(
   bool deep
);
[C++]
public: override XmlNode* CloneNode(
   bool deep
);
[JScript]
public override function CloneNode(
   deep : Boolean
) : XmlNode;

Parameters

deep
true to recursively clone the subtree under the specified node; false to clone only the node itself (and its attributes if the node is an XmlElement).

Return Value

The duplicate node.

Remarks

This method serves as a generic copy constructor for nodes. The duplicate node has no parent (ParentNode returns null).

See Also

XmlDocumentFragment Class | XmlDocumentFragment Members | System.NewXml Namespace


XmlDocumentFragment.WriteContentTo

Saves all the children of the node to the specified XmlWriter.

[Visual Basic]
Overrides Public Sub WriteContentTo( _
   ByVal w As XmlWriter _
)
[C#]
public override void WriteContentTo(
   XmlWriter w
);
[C++]
public: override void WriteContentTo(
   XmlWriter* w
);
[JScript]
public override function WriteContentTo(
   w : XmlWriter
);

Parameters

w
The XmlWriter where you want to save the current node.

See Also

XmlDocumentFragment Class | XmlDocumentFragment Members | System.NewXml Namespace


XmlDocumentFragment.WriteTo

Saves the node to the specified XmlWriter.

[Visual Basic]
Overrides Public Sub WriteTo( _
   ByVal w As XmlWriter _
)
[C#]
public override void WriteTo(
   XmlWriter w
);
[C++]
public: override void WriteTo(
   XmlWriter* w
);
[JScript]
public override function WriteTo(
   w : XmlWriter
);

Parameters

w
The XmlWriter where you want to save the node.

See Also

XmlDocumentFragment Class | XmlDocumentFragment Members | System.NewXml Namespace


XmlDocumentType Class

Contains information associated with the document type declaration.

Object
XmlNode
XmlLinkedNode
XmlDocumentType

[Visual Basic]
Public Class XmlDocumentType
   Inherits XmlLinkedNode
[C#]
public class XmlDocumentType : XmlLinkedNode
[C++]
public __gc class XmlDocumentType : public XmlLinkedNode
[JScript]
public class XmlDocumentType extends XmlLinkedNode

Remarks

[To be supplied.]

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

XmlDocumentType Members | System.NewXml Namespace


XmlDocumentType Members

Public:

Properties

Attributes (inherited from XmlNode) | Gets an XmlAttributeCollection containing the attributes of this node.
ChildNodes (inherited from XmlNode) | Gets all children of this node.
Entities | Gets the collection of XmlEntity nodes declared in the document type declaration.
FirstChild (inherited from XmlNode) | Gets the first child of this node.
HasChildNodes (inherited from XmlNode) | Gets a value indicating whether this node has any child nodes.
InnerText (inherited from XmlNode) | Gets or sets the concatenated values of the node and all its children.
InnerXml (inherited from XmlNode) | Gets or sets the markup representing just the children of this node.
InternalSubset | Gets the entire value of the DTD internal subset on the DOCTYPE declaration.
IsReadOnly | Gets a value indicating whether the node is read-only.
Item (inherited from XmlNode) | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlDocumentType class.
LastChild (inherited from XmlNode) | Gets the last child of this node.
LocalName | Gets the name of the current node without the namespace prefix.
Name | Gets the name of the node.
NamespaceURI (inherited from XmlNode) | Gets the namespace URI of this node.
NextSibling (inherited from XmlLinkedNode) | [To be supplied.]
NodeType | Gets the type of the current node.
Notations | Gets the collection of XmlNotation nodes present in the document type declaration.
OuterXml (inherited from XmlNode) | Gets the markup representing this node and all its children.
OwnerDocument (inherited from XmlNode) | Gets the XmlDocument that contains this node.
ParentNode (inherited from XmlNode) | Gets the parent of this node (for nodes that can have parents).
Prefix (inherited from XmlNode) | Gets or sets the namespace prefix of this node.
PreviousSibling (inherited from XmlLinkedNode) | [To be supplied.]
PublicId | Gets the value of the public identifier on the DOCTYPE declaration.
SystemId | Gets the value of the system identifier on the DOCTYPE declaration.
Value | Gets or sets the value of the node.

Methods

AppendChild (inherited from XmlNode) | Adds the specified node to the end of the list of children of this node.
Clone (inherited from XmlNode) | Creates a duplicate of this node.
CloneNode | Creates a duplicate of this node.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from XmlNode) | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamespaceOfPrefix (inherited from XmlNode) | Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.
GetPrefixOfNamespace (inherited from XmlNode) | Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.
GetType (inherited from Object) | Gets the Type of the Object.
InsertAfter (inherited from XmlNode) | Inserts the specified node immediately after the specified reference node.
InsertBefore (inherited from XmlNode) | Inserts the specified node immediately before the specified reference node.
Normalize (inherited from XmlNode) | Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.
PrependChild (inherited from XmlNode) | Adds the specified node to the beginning of the list of children of this node.
RemoveAll (inherited from XmlNode) | Removes all the children and/or attributes of the current node.
RemoveChild (inherited from XmlNode) | Removes specified child node.
ReplaceChild (inherited from XmlNode) | Replaces the child node oldChild with newChild node.
Supports (inherited from XmlNode) | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteContentTo | Saves all the children of the node to the specified XmlWriter.
WriteTo | Saves the node to the specified XmlWriter.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlDocumentType Class | System.NewXml Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlDocumentType Properties

The properties of the XmlDocumentType class are listed below. For a complete list of XmlDocumentType class members, see the XmlDocumentType Members topic.

Public:

Attributes (inherited from XmlNode) | Gets an XmlAttributeCollection containing the attributes of this node.
ChildNodes (inherited from XmlNode) | Gets all children of this node.
Entities | Gets the collection of XmlEntity nodes declared in the document type declaration.
FirstChild (inherited from XmlNode) | Gets the first child of this node.
HasChildNodes (inherited from XmlNode) | Gets a value indicating whether this node has any child nodes.
InnerText (inherited from XmlNode) | Gets or sets the concatenated values of the node and all its children.
InnerXml (inherited from XmlNode) | Gets or sets the markup representing just the children of this node.
InternalSubset | Gets the entire value of the DTD internal subset on the DOCTYPE declaration.
IsReadOnly | Gets a value indicating whether the node is read-only.
Item (inherited from XmlNode) | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlDocumentType class.
LastChild (inherited from XmlNode) | Gets the last child of this node.
LocalName | Gets the name of the current node without the namespace prefix.
Name | Gets the name of the node.
NamespaceURI (inherited from XmlNode) | Gets the namespace URI of this node.
NextSibling (inherited from XmlLinkedNode) | [To be supplied.]
NodeType | Gets the type of the current node.
Notations | Gets the collection of XmlNotation nodes present in the document type declaration.
OuterXml (inherited from XmlNode) | Gets the markup representing this node and all its children.
OwnerDocument (inherited from XmlNode) | Gets the XmlDocument that contains this node.
ParentNode (inherited from XmlNode) | Gets the parent of this node (for nodes that can have parents).
Prefix (inherited from XmlNode) | Gets or sets the namespace prefix of this node.
PreviousSibling (inherited from XmlLinkedNode) | [To be supplied.]
PublicId | Gets the value of the public identifier on the DOCTYPE declaration.
SystemId | Gets the value of the system identifier on the DOCTYPE declaration.
Value | Gets or sets the value of the node.

See Also

XmlDocumentType Class | System.NewXml Namespace


XmlDocumentType.Entities

Gets the collection of XmlEntity nodes declared in the document type declaration.

[Visual Basic]
Public ReadOnly Property Entities As XmlNamedNodeMap
[C#]
public XmlNamedNodeMap Entities {get;}
[C++]
public: __property XmlNamedNodeMap* get_Entities();
[JScript]
public function get Entities() : XmlNamedNodeMap;

Property Value

A XmlNamedNodeMap containing the XmlEntity nodes. The returned XmlNamedNodeMap is read only.

See Also

XmlDocumentType Class | XmlDocumentType Members | System.NewXml Namespace


XmlDocumentType.InternalSubset

Gets the entire value of the DTD internal subset on the DOCTYPE declaration.

[Visual Basic]
Public ReadOnly Property InternalSubset As String
[C#]
public string InternalSubset {get;}
[C++]
public: __property String* get_InternalSubset();
[JScript]
public function get InternalSubset() : String;

Property Value

The DTD internal subset on the DOCTYPE. If there is DTD internal subset, String.Empty is returned.

See Also

XmlDocumentType Class | XmlDocumentType Members | System.NewXml Namespace


XmlDocumentType.IsReadOnly

Gets a value indicating whether the node is read-only.

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {override get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;

Property Value

true if the node is read-only.

false if the node is read/write.

For XmlDocumentType, this property is true (the XmlDocumentType nodes are read-only).

Remarks

A read-only node is one that you cannot change any of its properties, attributes, or children. But you can remove it from the tree and insert it somewhere else. For example, the node for an EntityReference is typically read-only because its children actually come from the DTD definition of that entity and typically the DTD is read-only.

See Also

XmlDocumentType Class | XmlDocumentType Members | System.NewXml Namespace


XmlDocumentType.LocalName

Gets the name of the current node without the namespace prefix.

[Visual Basic]
Overridable Public ReadOnly Property LocalName As String
[C#]
public string LocalName {override get;}
[C++]
public: __property virtual String* get_LocalName();
[JScript]
public function get LocalName() : String;

Property Value

The name of the current node with the prefix removed. For example, LocalName is yyy for the element <xxx:yyy>.

See Also

XmlDocumentType Class | XmlDocumentType Members | System.NewXml Namespace


XmlDocumentType.Name

Gets the name of the node.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {override get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

Property Value

The name of the document type.

See Also

XmlDocumentType Class | XmlDocumentType Members | System.NewXml Namespace


XmlDocumentType.NodeType

Gets the type of the current node.

[Visual Basic]
Overridable Public ReadOnly Property NodeType As XmlNodeType
[C#]
public XmlNodeType NodeType {override get;}
[C++]
public: __property virtual XmlNodeType get_NodeType();
[JScript]
public function get NodeType() : XmlNodeType;

Property Value

One of the XmlNodeType values.

See Also

XmlDocumentType Class | XmlDocumentType Members | System.NewXml Namespace


XmlDocumentType.Notations

Gets the collection of XmlNotation nodes present in the document type declaration.

[Visual Basic]
Public ReadOnly Property Notations As XmlNamedNodeMap
[C#]
public XmlNamedNodeMap Notations {get;}
[C++]
public: __property XmlNamedNodeMap* get_Notations();
[JScript]
public function get Notations() : XmlNamedNodeMap;

Property Value

A XmlNamedNodeMap containing the XmlNotation nodes. The returned XmlNamedNodeMap is read only.

See Also

XmlDocumentType Class | XmlDocumentType Members | System.NewXml Namespace


XmlDocumentType.PublicId

Gets the value of the public identifier on the DOCTYPE declaration.

[Visual Basic]
Public ReadOnly Property PublicId As String
[C#]
public string PublicId {get;}
[C++]
public: __property String* get_PublicId();
[JScript]
public function get PublicId() : String;

Property Value

The public identifier on the DOCTYPE. If there is no public identifier, String.Empty is returned.

See Also

XmlDocumentType Class | XmlDocumentType Members | System.NewXml Namespace


XmlDocumentType.SystemId

Gets the value of the system identifier on the DOCTYPE declaration.

[Visual Basic]
Public ReadOnly Property SystemId As String
[C#]
public string SystemId {get;}
[C++]
public: __property String* get_SystemId();
[JScript]
public function get SystemId() : String;

Property Value

The system identifier on the DOCTYPE. If there is no system identifier, String.Empty is returned.

See Also

XmlDocumentType Class | XmlDocumentType Members | System.NewXml Namespace


XmlDocumentType.Value

Gets or sets the value of the node.

[Visual Basic]
Overridable Public Property Value As String
[C#]
public string Value {override get; override set;}
[C++]
public: __property virtual String* get_Value();
public: __property virtual void set_Value(String*);
[JScript]
public function get Value() : String;
public function set Value(String);

Property Value

The value returned depends on the NodeType of the node. ForXmlDocumentType, this property is null.

Exceptions

Exception Type | Condition
ReadOnlyException | Node is read-only.

See Also

XmlDocumentType Class | XmlDocumentType Members | System.NewXml Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlDocumentType Methods

The methods of the XmlDocumentType class are listed below. For a complete list of XmlDocumentType class members, see the XmlDocumentType Members topic.

Public:

AppendChild (inherited from XmlNode) | Adds the specified node to the end of the list of children of this node.
Clone (inherited from XmlNode) | Creates a duplicate of this node.
CloneNode | Creates a duplicate of this node.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from XmlNode) | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamespaceOfPrefix (inherited from XmlNode) | Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.
GetPrefixOfNamespace (inherited from XmlNode) | Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.
GetType (inherited from Object) | Gets the Type of the Object.
InsertAfter (inherited from XmlNode) | Inserts the specified node immediately after the specified reference node.
InsertBefore (inherited from XmlNode) | Inserts the specified node immediately before the specified reference node.
Normalize (inherited from XmlNode) | Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.
PrependChild (inherited from XmlNode) | Adds the specified node to the beginning of the list of children of this node.
RemoveAll (inherited from XmlNode) | Removes all the children and/or attributes of the current node.
RemoveChild (inherited from XmlNode) | Removes specified child node.
ReplaceChild (inherited from XmlNode) | Replaces the child node oldChild with newChild node.
Supports (inherited from XmlNode) | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteContentTo | Saves all the children of the node to the specified XmlWriter.
WriteTo | Saves the node to the specified XmlWriter.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlDocumentType Class | System.NewXml Namespace


XmlDocumentType.CloneNode

Creates a duplicate of this node.

[Visual Basic]
Overrides Public Function CloneNode( _
   ByVal deep As Boolean _
) As XmlNode
[C#]
public override XmlNode CloneNode(
   bool deep
);
[C++]
public: override XmlNode* CloneNode(
   bool deep
);
[JScript]
public override function CloneNode(
   deep : Boolean
) : XmlNode;

Parameters

deep
true to recursively clone the subtree under the specified node; false to clone only the node itself (and its attributes if the node is an XmlElement).

Return Value

The duplicate node.

Remarks

This method serves as a generic copy constructor for nodes. The duplicate node has no parent (ParentNode returns null).

See Also

XmlDocumentType Class | XmlDocumentType Members | System.NewXml Namespace


XmlDocumentType.WriteContentTo

Saves all the children of the node to the specified XmlWriter.

[Visual Basic]
Overrides Public Sub WriteContentTo( _
   ByVal w As XmlWriter _
)
[C#]
public override void WriteContentTo(
   XmlWriter w
);
[C++]
public: override void WriteContentTo(
   XmlWriter* w
);
[JScript]
public override function WriteContentTo(
   w : XmlWriter
);

Parameters

w
The XmlWriter where you want to save the current node.

See Also

XmlDocumentType Class | XmlDocumentType Members | System.NewXml Namespace


XmlDocumentType.WriteTo

Saves the node to the specified XmlWriter.

[Visual Basic]
Overrides Public Sub WriteTo( _
   ByVal w As XmlWriter _
)
[C#]
public override void WriteTo(
   XmlWriter w
);
[C++]
public: override void WriteTo(
   XmlWriter* w
);
[JScript]
public override function WriteTo(
   w : XmlWriter
);

Parameters

w
The XmlWriter where you want to save the node.

See Also

XmlDocumentType Class | XmlDocumentType Members | System.NewXml Namespace


XmlElement Class

Represents an element.

Object
XmlNode
XmlLinkedNode
XmlElement

[Visual Basic]
Public Class XmlElement
   Inherits XmlLinkedNode
[C#]
public class XmlElement : XmlLinkedNode
[C++]
public __gc class XmlElement : public XmlLinkedNode
[JScript]
public class XmlElement extends XmlLinkedNode

Remarks

[To be supplied.]

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

XmlElement Members | System.NewXml Namespace


XmlElement Members

Public:

Properties

Attributes | Gets a XmlAttributeCollection containing the list of attributes for this node.
ChildNodes (inherited from XmlNode) | Gets all children of this node.
FirstChild (inherited from XmlNode) | Gets the first child of this node.
HasAttributes | Gets a value indicating whether the current node has any attributes.
HasChildNodes (inherited from XmlNode) | Gets a value indicating whether this node has any child nodes.
InnerText (inherited from XmlNode) | Gets or sets the concatenated values of the node and all its children.
InnerXml (inherited from XmlNode) | Gets or sets the markup representing just the children of this node.
IsEmpty | Gets or sets whether the element does not have any children.
IsReadOnly (inherited from XmlNode) | Gets a value indicating whether the node is read-only.
Item (inherited from XmlNode) | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlElement class.
LastChild (inherited from XmlNode) | Gets the last child of this node.
LocalName | Gets the name of the current node without the namespace prefix.
Name | Gets the name of the node.
NamespaceURI | Gets the namespace URI of this node.
NextSibling (inherited from XmlLinkedNode) | [To be supplied.]
NodeType | Gets the type of the current node.
OuterXml (inherited from XmlNode) | Gets the markup representing this node and all its children.
OwnerDocument | Gets the XmlDocument that contains this node.
ParentNode (inherited from XmlNode) | Gets the parent of this node (for nodes that can have parents).
Prefix | Gets or sets the namespace prefix of this node.
PreviousSibling (inherited from XmlLinkedNode) | [To be supplied.]
Value (inherited from XmlNode) | Gets or sets the value of the node.

Methods

AppendChild (inherited from XmlNode) | Adds the specified node to the end of the list of children of this node.
Clone (inherited from XmlNode) | Creates a duplicate of this node.
CloneNode | Creates a duplicate of this node.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetAttribute | Overloaded. Returns the attribute value for the specified attribute.
GetAttributeNode | Overloaded. Return the specified XmlAttribute.
GetElementsByTagName | Overloaded. Returns an XmlNodeList containing a list of all descendant elements that match the specified name.
GetEnumerator (inherited from XmlNode) | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamespaceOfPrefix (inherited from XmlNode) | Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.
GetPrefixOfNamespace (inherited from XmlNode) | Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.
GetType (inherited from Object) | Gets the Type of the Object.
HasAttribute | Overloaded. Determines whether the current node has the specified attribute.
InsertAfter (inherited from XmlNode) | Inserts the specified node immediately after the specified reference node.
InsertBefore (inherited from XmlNode) | Inserts the specified node immediately before the specified reference node.
Normalize (inherited from XmlNode) | Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.
PrependChild (inherited from XmlNode) | Adds the specified node to the beginning of the list of children of this node.
RemoveAll (inherited from XmlNode) | Removes all the children and/or attributes of the current node.
RemoveAllAttributes | Removes all attributes from the element.
RemoveAttribute | Overloaded. Removes the specified attribute.
RemoveAttributeAt | Removes the attribute node with the specified index from the attribute collection.
RemoveAttributeNode | Overloaded. Removes an XmlAttribute.
RemoveChild (inherited from XmlNode) | Removes specified child node.
ReplaceChild (inherited from XmlNode) | Replaces the child node oldChild with newChild node.
SetAttribute | Overloaded. Sets the value of the specified attribute.
SetAttributeNode | Overloaded. Adds a new XmlAttribute.
Supports (inherited from XmlNode) | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteContentTo | Saves all the children of the node to the specified XmlWriter.
WriteTo | Saves the current node to the specified XmlWriter.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlElement Class | System.NewXml Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlElement Properties

The properties of the XmlElement class are listed below. For a complete list of XmlElement class members, see the XmlElement Members topic.

Public:

Attributes | Gets a XmlAttributeCollection containing the list of attributes for this node.
ChildNodes (inherited from XmlNode) | Gets all children of this node.
FirstChild (inherited from XmlNode) | Gets the first child of this node.
HasAttributes | Gets a value indicating whether the current node has any attributes.
HasChildNodes (inherited from XmlNode) | Gets a value indicating whether this node has any child nodes.
InnerText (inherited from XmlNode) | Gets or sets the concatenated values of the node and all its children.
InnerXml (inherited from XmlNode) | Gets or sets the markup representing just the children of this node.
IsEmpty | Gets or sets whether the element does not have any children.
IsReadOnly (inherited from XmlNode) | Gets a value indicating whether the node is read-only.
Item (inherited from XmlNode) | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlElement class.
LastChild (inherited from XmlNode) | Gets the last child of this node.
LocalName | Gets the name of the current node without the namespace prefix.
Name | Gets the name of the node.
NamespaceURI | Gets the namespace URI of this node.
NextSibling (inherited from XmlLinkedNode) | [To be supplied.]
NodeType | Gets the type of the current node.
OuterXml (inherited from XmlNode) | Gets the markup representing this node and all its children.
OwnerDocument | Gets the XmlDocument that contains this node.
ParentNode (inherited from XmlNode) | Gets the parent of this node (for nodes that can have parents).
Prefix | Gets or sets the namespace prefix of this node.
PreviousSibling (inherited from XmlLinkedNode) | [To be supplied.]
Value (inherited from XmlNode) | Gets or sets the value of the node.

See Also

XmlElement Class | System.NewXml Namespace


XmlElement.Attributes

Gets a XmlAttributeCollection containing the list of attributes for this node.

[Visual Basic]
Overridable Public ReadOnly Property Attributes As _
   XmlAttributeCollection
[C#]
public XmlAttributeCollection Attributes {override get;}
[C++]
public: __property virtual XmlAttributeCollection* get_Attributes();
[JScript]
public function get Attributes() : XmlAttributeCollection;

Property Value

XmlAttributeCollection containing the list of attributes for this node.

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace


XmlElement.HasAttributes

Gets a value indicating whether the current node has any attributes.

[Visual Basic]
Public ReadOnly Property HasAttributes As Boolean
[C#]
public bool HasAttributes {get;}
[C++]
public: __property bool get_HasAttributes();
[JScript]
public function get HasAttributes() : Boolean;

Property Value

true if the current node has attributes; otherwise, false.

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace


XmlElement.IsEmpty

Gets or sets whether the element does not have any children.

[Visual Basic]
Public Property IsEmpty As Boolean
[C#]
public bool IsEmpty {get; set;}
[C++]
public: __property bool get_IsEmpty();
public: __property void set_IsEmpty(bool);
[JScript]
public function get IsEmpty() : Boolean;
public function set IsEmpty(Boolean);

Property Value

true if the element doesn't have children; false if the element has children.

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace


XmlElement.LocalName

Gets the name of the current node without the namespace prefix.

[Visual Basic]
Overridable Public ReadOnly Property LocalName As String
[C#]
public string LocalName {override get;}
[C++]
public: __property virtual String* get_LocalName();
[JScript]
public function get LocalName() : String;

Property Value

The name of the current node with the prefix removed. For example, LocalName is yyy for the element <xxx:yyy>.

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace


XmlElement.Name

Gets the name of the node.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {override get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

Property Value

The name of the node. For XmlElement, the name is the tag name of the element.

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace


XmlElement.NamespaceURI

Gets the namespace URI of this node.

[Visual Basic]
Overridable Public ReadOnly Property NamespaceURI As String
[C#]
public string NamespaceURI {override get;}
[C++]
public: __property virtual String* get_NamespaceURI();
[JScript]
public function get NamespaceURI() : String;

Property Value

The namespace URI of this node. If there is no namespace URI, this property is null.

Remarks

For example, "uuu" for the following "foo" element: <foo xmlns="uuu"> is not a computed value that is the result of a namespace lookup based on an examination of the namespace declarations in scope. It is merely the namespace URI given at creation time.

For nodes of any type other than ELEMENT_NODE and ATTRIBUTE_NODE and nodes created with a DOM Level 1 method, such as createElement from the XmlDocument, this is always null.

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace


XmlElement.NodeType

Gets the type of the current node.

[Visual Basic]
Overridable Public ReadOnly Property NodeType As XmlNodeType
[C#]
public XmlNodeType NodeType {override get;}
[C++]
public: __property virtual XmlNodeType get_NodeType();
[JScript]
public function get NodeType() : XmlNodeType;

Property Value

One of the XmlNodeType values.

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace


XmlElement.OwnerDocument

Gets the XmlDocument that contains this node.

[Visual Basic]
Overridable Public ReadOnly Property OwnerDocument As XmlDocument
[C#]
public XmlDocument OwnerDocument {override get;}
[C++]
public: __property virtual XmlDocument* get_OwnerDocument();
[JScript]
public function get OwnerDocument() : XmlDocument;

Property Value

An XmlDocument.

Remarks

When adding nodes to the current node, use the XmlDocument returned by the OwnerDocument property to create the node.

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace


XmlElement.Prefix

Gets or sets the namespace prefix of this node.

[Visual Basic]
Overridable Public Property Prefix As String
[C#]
public string Prefix {override get; override set;}
[C++]
public: __property virtual String* get_Prefix();
public: __property virtual void set_Prefix(String*);
[JScript]
public function get Prefix() : String;
public function set Prefix(String);

Property Value

The namespace prefix of this node. If there is no prefix, this property is null.

Exceptions

Exception Type | Condition
INVALID_CHARACTER_ERR | The specified prefix contains an illegal character
NO_MODIFICATION_ALLOWED_ERR | This node is readonly
NAMESPACE_ERR | The specified prefix is malformed. The namespaceURI of this node is null. The specified prefix is "xml" and the namespaceURI of this node is different from

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlElement Methods

The methods of the XmlElement class are listed below. For a complete list of XmlElement class members, see the XmlElement Members topic.

Public:

AppendChild (inherited from XmlNode) | Adds the specified node to the end of the list of children of this node.
Clone (inherited from XmlNode) | Creates a duplicate of this node.
CloneNode | Creates a duplicate of this node.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetAttribute | Overloaded. Returns the attribute value for the specified attribute.
GetAttributeNode | Overloaded. Return the specified XmlAttribute.
GetElementsByTagName | Overloaded. Returns an XmlNodeList containing a list of all descendant elements that match the specified name.
GetEnumerator (inherited from XmlNode) | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamespaceOfPrefix (inherited from XmlNode) | Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.
GetPrefixOfNamespace (inherited from XmlNode) | Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.
GetType (inherited from Object) | Gets the Type of the Object.
HasAttribute | Overloaded. Determines whether the current node has the specified attribute.
InsertAfter (inherited from XmlNode) | Inserts the specified node immediately after the specified reference node.
InsertBefore (inherited from XmlNode) | Inserts the specified node immediately before the specified reference node.
Normalize (inherited from XmlNode) | Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.
PrependChild (inherited from XmlNode) | Adds the specified node to the beginning of the list of children of this node.
RemoveAll (inherited from XmlNode) | Removes all the children and/or attributes of the current node.
RemoveAllAttributes | Removes all attributes from the element.
RemoveAttribute | Overloaded. Removes the specified attribute.
RemoveAttributeAt | Removes the attribute node with the specified index from the attribute collection.
RemoveAttributeNode | Overloaded. Removes an XmlAttribute.
RemoveChild (inherited from XmlNode) | Removes specified child node.
ReplaceChild (inherited from XmlNode) | Replaces the child node oldChild with newChild node.
SetAttribute | Overloaded. Sets the value of the specified attribute.
SetAttributeNode | Overloaded. Adds a new XmlAttribute.
Supports (inherited from XmlNode) | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteContentTo | Saves all the children of the node to the specified XmlWriter.
WriteTo | Saves the current node to the specified XmlWriter.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlElement Class | System.NewXml Namespace


XmlElement.CloneNode

Creates a duplicate of this node.

[Visual Basic]
Overrides Public Function CloneNode( _
   ByVal deep As Boolean _
) As XmlNode
[C#]
public override XmlNode CloneNode(
   bool deep
);
[C++]
public: override XmlNode* CloneNode(
   bool deep
);
[JScript]
public override function CloneNode(
   deep : Boolean
) : XmlNode;

Parameters

deep
true to recursively clone the subtree under the specified node; false to clone only the node itself (and its attributes if the node is an XmlElement).

Return Value

The duplicate node.

Remarks

This method serves as a generic copy constructor for nodes. The duplicate node has no parent (ParentNode returns null).

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace


XmlElement.GetAttribute

Returns the attribute value for the specified attribute.

Overload List

Returns the value for the attribute with the specified name.

[Visual Basic] Overloads Overridable Public Function GetAttribute(String) As String
[C#] public virtual string GetAttribute(String);
[C++] public: virtual String* GetAttribute(String*);
[JScript] public function GetAttribute(String) : String;

Returns the value for the attribute with the specified LocalName and NamespaceURI.

[Visual Basic] Overloads Overridable Public Function GetAttribute(String, String) As String
[C#] public virtual string GetAttribute(String, String);
[C++] public: virtual String* GetAttribute(String*, String*);
[JScript] public function GetAttribute(String, String) : String;

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace


XmlElement.GetAttribute (String)

Returns the value for the attribute with the specified name.

[Visual Basic]
Overloads Overridable Public Function GetAttribute( _
   ByVal name As String _
) As String
[C#]
public virtual string GetAttribute(
   string name
);
[C++]
public: virtual String* GetAttribute(
   String* name
);
[JScript]
public function GetAttribute(
   name : String
) : String;

Parameters

name
The name of the attribute to retrieve.

Return Value

The value of the specified XmlAttribute as a string. Empty string is returned if that attribute does not have a specified or default value.

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace | XmlElement.GetAttribute Overload List


XmlElement.GetAttribute (String, String)

Returns the value for the attribute with the specified LocalName and NamespaceURI.

[Visual Basic]
Overloads Overridable Public Function GetAttribute( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As String
[C#]
public virtual string GetAttribute(
   string localName,
   string namespaceURI
);
[C++]
public: virtual String* GetAttribute(
   String* localName,
   String* namespaceURI
);
[JScript]
public function GetAttribute(
   localName : String,
   namespaceURI : String
) : String;

Parameters

localName
LocalName of the attribute to retrieve.
namespaceURI
NamespaceURI of the attribute to retrieve.

Return Value

The value of the specified XmlAttribute as a string. Empty string is returned if that attribute does not have a specified or default value.

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace | XmlElement.GetAttribute Overload List


XmlElement.GetAttributeNode

Return the specified XmlAttribute.

Overload List

Returns the XmlAttribute with the specified LocalName and NamespaceURI.

[Visual Basic] Overloads Overridable Public Function GetAttributeNode(String, String) As XmlAttribute
[C#] public virtual XmlAttribute GetAttributeNode(String, String);
[C++] public: virtual XmlAttribute* GetAttributeNode(String*, String*);
[JScript] public function GetAttributeNode(String, String) : XmlAttribute;

Returns the XmlAttribute with the specified name.

[Visual Basic] Overloads Overridable Public Function GetAttributeNode(String) As XmlAttribute
[C#] public virtual XmlAttribute GetAttributeNode(String);
[C++] public: virtual XmlAttribute* GetAttributeNode(String*);
[JScript] public function GetAttributeNode(String) : XmlAttribute;

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace


XmlElement.GetAttributeNode (String, String)

Returns the XmlAttribute with the specified LocalName and NamespaceURI.

[Visual Basic]
Overloads Overridable Public Function GetAttributeNode( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As XmlAttribute
[C#]
public virtual XmlAttribute GetAttributeNode(
   string localName,
   string namespaceURI
);
[C++]
public: virtual XmlAttribute* GetAttributeNode(
   String* localName,
   String* namespaceURI
);
[JScript]
public function GetAttributeNode(
   localName : String,
   namespaceURI : String
) : XmlAttribute;

Parameters

localName
LocalName of the attribute.
namespaceURI
NamespaceURI of the attribute.

Return Value

The specified XmlAttribute.

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace | XmlElement.GetAttributeNode Overload List


XmlElement.GetAttributeNode (String)

Returns the XmlAttribute with the specified name.

[Visual Basic]
Overloads Overridable Public Function GetAttributeNode( _
   ByVal name As String _
) As XmlAttribute
[C#]
public virtual XmlAttribute GetAttributeNode(
   string name
);
[C++]
public: virtual XmlAttribute* GetAttributeNode(
   String* name
);
[JScript]
public function GetAttributeNode(
   name : String
) : XmlAttribute;

Parameters

name
The name of the attribute. The name can include the prefix or leave it off.

Return Value

The specified XmlAttribute.

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace | XmlElement.GetAttributeNode Overload List


XmlElement.GetElementsByTagName

Returns an XmlNodeList containing a list of all descendant elements that match the specified name.

Overload List

Returns an XmlNodeList containing a list of all descendant elements that match the specified name.

[Visual Basic] Overloads Overridable Public Function GetElementsByTagName(String) As XmlNodeList
[C#] public virtual XmlNodeList GetElementsByTagName(String);
[C++] public: virtual XmlNodeList* GetElementsByTagName(String*);
[JScript] public function GetElementsByTagName(String) : XmlNodeList;

Returns an XmlNodeList containing a list of all descendant elements that match the specified name.

[Visual Basic] Overloads Overridable Public Function GetElementsByTagName(String, String) As XmlNodeList
[C#] public virtual XmlNodeList GetElementsByTagName(String, String);
[C++] public: virtual XmlNodeList* GetElementsByTagName(String*, String*);
[JScript] public function GetElementsByTagName(String, String) : XmlNodeList;

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace


XmlElement.GetElementsByTagName (String)

Returns an XmlNodeList containing a list of all descendant elements that match the specified name.

[Visual Basic]
Overloads Overridable Public Function GetElementsByTagName( _
   ByVal name As String _
) As XmlNodeList
[C#]
public virtual XmlNodeList GetElementsByTagName(
   string name
);
[C++]
public: virtual XmlNodeList* GetElementsByTagName(
   String* name
);
[JScript]
public function GetElementsByTagName(
   name : String
) : XmlNodeList;

Parameters

name
The Name to match. The special value "*" matches all tags.

Return Value

An XmlNodeList containing a list of all matching nodes.

Remarks

The nodes are placed in the order in which they would be encountered in a preorder traversal of the XmlElement tree.

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace | XmlElement.GetElementsByTagName Overload List


XmlElement.GetElementsByTagName (String, String)

Returns an XmlNodeList containing a list of all descendant elements that match the specified name.

[Visual Basic]
Overloads Overridable Public Function GetElementsByTagName( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As XmlNodeList
[C#]
public virtual XmlNodeList GetElementsByTagName(
   string localName,
   string namespaceURI
);
[C++]
public: virtual XmlNodeList* GetElementsByTagName(
   String* localName,
   String* namespaceURI
);
[JScript]
public function GetElementsByTagName(
   localName : String,
   namespaceURI : String
) : XmlNodeList;

Parameters

localName
The LocalName to match. The special value "*" matches all tags.
namespaceURI
NamespaceURI to match.

Return Value

An XmlNodeList containing a list of all matching nodes.

Remarks

The nodes are placed in the order in which they would be encountered in a preorder traversal of the XmlElement tree.

The same as the simple GetElementsByTagName, except it is matching on localName and namespaceURI instead of on "name" which is prefix and localName.

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace | XmlElement.GetElementsByTagName Overload List


XmlElement.HasAttribute

Determines whether the current node has the specified attribute.

Overload List

Determines whether the current node has the specified attribute.

[Visual Basic] Overloads Overridable Public Function HasAttribute(String) As Boolean
[C#] public virtual bool HasAttribute(String);
[C++] public: virtual bool HasAttribute(String*);
[JScript] public function HasAttribute(String) : Boolean;

Determines whether the current node has the specified attribute from the specified namespace.

[Visual Basic] Overloads Overridable Public Function HasAttribute(String, String) As Boolean
[C#] public virtual bool HasAttribute(String, String);
[C++] public: virtual bool HasAttribute(String*, String*);
[JScript] public function HasAttribute(String, String) : Boolean;

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace


XmlElement.HasAttribute (String)

Determines whether the current node has the specified attribute.

[Visual Basic]
Overloads Overridable Public Function HasAttribute( _
   ByVal name As String _
) As Boolean
[C#]
public virtual bool HasAttribute(
   string name
);
[C++]
public: virtual bool HasAttribute(
   String* name
);
[JScript]
public function HasAttribute(
   name : String
) : Boolean;

Parameters

name
The name of the attribute to find.

Return Value

true if the current node has the specified attribute; otherwise, false.

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace | XmlElement.HasAttribute Overload List


XmlElement.HasAttribute (String, String)

Determines whether the current node has the specified attribute from the specified namespace.

[Visual Basic]
Overloads Overridable Public Function HasAttribute( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Boolean
[C#]
public virtual bool HasAttribute(
   string localName,
   string namespaceURI
);
[C++]
public: virtual bool HasAttribute(
   String* localName,
   String* namespaceURI
);
[JScript]
public function HasAttribute(
   localName : String,
   namespaceURI : String
) : Boolean;

Parameters

localName
[To be supplied.]
namespaceURI
The name of the namespace of the attribute to find.

Return Value

true if the current node has the specified attribute; otherwise, false.

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace | XmlElement.HasAttribute Overload List


XmlElement.RemoveAllAttributes

Removes all attributes from the element.

[Visual Basic]
Overridable Public Sub RemoveAllAttributes()
[C#]
public virtual void RemoveAllAttributes();
[C++]
public: virtual void RemoveAllAttributes();
[JScript]
public function RemoveAllAttributes();

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace


XmlElement.RemoveAttribute

Removes the specified attribute.

Overload List

Removes an attribute specified by LocalName and NamespaceURI.

[Visual Basic] Overloads Overridable Public Sub RemoveAttribute(String, String)
[C#] public virtual void RemoveAttribute(String, String);
[C++] public: virtual void RemoveAttribute(String*, String*);
[JScript] public function RemoveAttribute(String, String);

Removes an attribute by name.

[Visual Basic] Overloads Overridable Public Sub RemoveAttribute(String)
[C#] public virtual void RemoveAttribute(String);
[C++] public: virtual void RemoveAttribute(String*);
[JScript] public function RemoveAttribute(String);

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace


XmlElement.RemoveAttribute (String, String)

Removes an attribute specified by LocalName and NamespaceURI.

[Visual Basic]
Overloads Overridable Public Sub RemoveAttribute( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
)
[C#]
public virtual void RemoveAttribute(
   string localName,
   string namespaceURI
);
[C++]
public: virtual void RemoveAttribute(
   String* localName,
   String* namespaceURI
);
[JScript]
public function RemoveAttribute(
   localName : String,
   namespaceURI : String
);

Parameters

localName
LocalName of the attribute to remove.
namespaceURI
NamespaceURI of the attribute to remove.

Exceptions

Exception Type | Condition
NO_MODIFICATION_ALLOWED_ERR | The node is read-only.

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace | XmlElement.RemoveAttribute Overload List


XmlElement.RemoveAttribute (String)

Removes an attribute by name.

[Visual Basic]
Overloads Overridable Public Sub RemoveAttribute( _
   ByVal name As String _
)
[C#]
public virtual void RemoveAttribute(
   string name
);
[C++]
public: virtual void RemoveAttribute(
   String* name
);
[JScript]
public function RemoveAttribute(
   name : String
);

Parameters

name
The name of the attribute to remove.

Exceptions

Exception Type | Condition
NO_MODIFICATION_ALLOWED_ERR | The node is read-only.

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace | XmlElement.RemoveAttribute Overload List


XmlElement.RemoveAttributeAt

Removes the attribute node with the specified index from the attribute collection.

[Visual Basic]
Overridable Public Function RemoveAttributeAt( _
   ByVal i As Integer _
) As XmlNode
[C#]
public virtual XmlNode RemoveAttributeAt(
   int i
);
[C++]
public: virtual XmlNode* RemoveAttributeAt(
   int i
);
[JScript]
public function RemoveAttributeAt(
   i : int
) : XmlNode;

Parameters

i
Index of the node to remove. The first node has index 0.

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace


XmlElement.RemoveAttributeNode

Removes an XmlAttribute.

Overload List

Removes the XmlAttribute specified by LocalName and NamespaceURI.

[Visual Basic] Overloads Overridable Public Function RemoveAttributeNode(String, String) As XmlAttribute
[C#] public virtual XmlAttribute RemoveAttributeNode(String, String);
[C++] public: virtual XmlAttribute* RemoveAttributeNode(String*, String*);
[JScript] public function RemoveAttributeNode(String, String) : XmlAttribute;

Removes the specified XmlAttribute.

[Visual Basic] Overloads Overridable Public Function RemoveAttributeNode(XmlAttribute) As XmlAttribute
[C#] public virtual XmlAttribute RemoveAttributeNode(XmlAttribute);
[C++] public: virtual XmlAttribute* RemoveAttributeNode(XmlAttribute*);
[JScript] public function RemoveAttributeNode(XmlAttribute) : XmlAttribute;

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace


XmlElement.RemoveAttributeNode (String, String)

Removes the XmlAttribute specified by LocalName and NamespaceURI.

[Visual Basic]
Overloads Overridable Public Function RemoveAttributeNode( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As XmlAttribute
[C#]
public virtual XmlAttribute RemoveAttributeNode(
   string localName,
   string namespaceURI
);
[C++]
public: virtual XmlAttribute* RemoveAttributeNode(
   String* localName,
   String* namespaceURI
);
[JScript]
public function RemoveAttributeNode(
   localName : String,
   namespaceURI : String
) : XmlAttribute;

Parameters

localName
LocalName of the attribute.
namespaceURI
NamespaceURI of the attribute.

Return Value

The removed XmlAttribute.

Exceptions

Exception Type | Condition
NO_MODIFICATION_ALLOWED_ERR | This node is read-only.
NOT_FOUND_ERR | The oldAttr is not an attribute of the element.

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace | XmlElement.RemoveAttributeNode Overload List


XmlElement.RemoveAttributeNode (XmlAttribute)

Removes the specified XmlAttribute.

[Visual Basic]
Overloads Overridable Public Function RemoveAttributeNode( _
   ByVal oldAttr As XmlAttribute _
) As XmlAttribute
[C#]
public virtual XmlAttribute RemoveAttributeNode(
   XmlAttribute oldAttr
);
[C++]
public: virtual XmlAttribute* RemoveAttributeNode(
   XmlAttribute* oldAttr
);
[JScript]
public function RemoveAttributeNode(
   oldAttr : XmlAttribute
) : XmlAttribute;

Parameters

oldAttr
The XmlAttribute node to remove from the attribute collection for this element. If the removed attribute has a default value, it is immediately replaced.

Return Value

The removed XmlAttribute.

Exceptions

Exception Type | Condition
NO_MODIFICATION_ALLOWED_ERR | This node is read-only.
NOT_FOUND_ERR | The oldAttr is not an attribute of the element.

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace | XmlElement.RemoveAttributeNode Overload List


XmlElement.SetAttribute

Sets the value of the specified attribute.

Overload List

Sets the value of the attribute with the specified name and namespace.

[Visual Basic] Overloads Overridable Public Function SetAttribute(String, String, String) As String
[C#] public virtual string SetAttribute(String, String, String);
[C++] public: virtual String* SetAttribute(String*, String*, String*);
[JScript] public function SetAttribute(String, String, String) : String;

Sets the value of the attribute with the specified name.

[Visual Basic] Overloads Overridable Public Sub SetAttribute(String, String)
[C#] public virtual void SetAttribute(String, String);
[C++] public: virtual void SetAttribute(String*, String*);
[JScript] public function SetAttribute(String, String);

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace


XmlElement.SetAttribute (String, String, String)

Sets the value of the attribute with the specified name and namespace.

[Visual Basic]
Overloads Overridable Public Function SetAttribute( _
   ByVal localName As String, _
   ByVal namespaceURI As String, _
   ByVal value As String _
) As String
[C#]
public virtual string SetAttribute(
   string localName,
   string namespaceURI,
   string value
);
[C++]
public: virtual String* SetAttribute(
   String* localName,
   String* namespaceURI,
   String* value
);
[JScript]
public function SetAttribute(
   localName : String,
   namespaceURI : String,
   value : String
) : String;

Parameters

localName
The name of the attribute. The name can include the prefix or leave it off.
namespaceURI
The URN of the namespace of the attribute.
value
The value to set for the attribute.

Remarks

This name does may or may not include the prefix. For example:

[C#]

xti.SetAttribute("xmlns:x",null, nsuri);

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace | XmlElement.SetAttribute Overload List


XmlElement.SetAttribute (String, String)

Sets the value of the attribute with the specified name.

[Visual Basic]
Overloads Overridable Public Sub SetAttribute( _
   ByVal name As String, _
   ByVal value As String _
)
[C#]
public virtual void SetAttribute(
   string name,
   string value
);
[C++]
public: virtual void SetAttribute(
   String* name,
   String* value
);
[JScript]
public function SetAttribute(
   name : String,
   value : String
);

Parameters

name
The name of the attribute. The name can include the prefix or leave it off.
value
[To be supplied.]

Exceptions

Exception Type | Condition
INVALID_CHARACTER_ERR | The specified name contains an invalid character.
NO_MODIFICATION_ALLOWED_ERR | The node is read-only.

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace | XmlElement.SetAttribute Overload List


XmlElement.SetAttributeNode

Adds a new XmlAttribute.

Overload List

Adds the specified XmlAttribute.

[Visual Basic] Overloads Overridable Public Function SetAttributeNode(String, String) As XmlAttribute
[C#] public virtual XmlAttribute SetAttributeNode(String, String);
[C++] public: virtual XmlAttribute* SetAttributeNode(String*, String*);
[JScript] public function SetAttributeNode(String, String) : XmlAttribute;

Adds the specified XmlAttribute.

[Visual Basic] Overloads Overridable Public Function SetAttributeNode(XmlAttribute) As XmlAttribute
[C#] public virtual XmlAttribute SetAttributeNode(XmlAttribute);
[C++] public: virtual XmlAttribute* SetAttributeNode(XmlAttribute*);
[JScript] public function SetAttributeNode(XmlAttribute) : XmlAttribute;

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace


XmlElement.SetAttributeNode (String, String)

Adds the specified XmlAttribute.

[Visual Basic]
Overloads Overridable Public Function SetAttributeNode( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As XmlAttribute
[C#]
public virtual XmlAttribute SetAttributeNode(
   string localName,
   string namespaceURI
);
[C++]
public: virtual XmlAttribute* SetAttributeNode(
   String* localName,
   String* namespaceURI
);
[JScript]
public function SetAttributeNode(
   localName : String,
   namespaceURI : String
) : XmlAttribute;

Parameters

localName
LocalName of the attribute.
namespaceURI
NamespaceURI of the attribute.

Return Value

The added XmlAttribute.

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace | XmlElement.SetAttributeNode Overload List


XmlElement.SetAttributeNode (XmlAttribute)

Adds the specified XmlAttribute.

[Visual Basic]
Overloads Overridable Public Function SetAttributeNode( _
   ByVal newAttr As XmlAttribute _
) As XmlAttribute
[C#]
public virtual XmlAttribute SetAttributeNode(
   XmlAttribute newAttr
);
[C++]
public: virtual XmlAttribute* SetAttributeNode(
   XmlAttribute* newAttr
);
[JScript]
public function SetAttributeNode(
   newAttr : XmlAttribute
) : XmlAttribute;

Parameters

newAttr
The XmlAttribute node to add to the attribute collection for this element.

Return Value

If the attribute replaces an existing attribute with the same name, the old XmlAttribute node is returned; otherwise, null is returned.

Exceptions

Exception Type | Condition
WRONG_DOCUMENT_ERR | The newAttr was created from a different document than the one that created this node.
NO_MODIFICATION_ALLOWED_ERR | This node is read-only.
INUSE_ATTRIBUTE_ERR | The newAttr is already an attribute of another XmlElement object. You must explicitly clone XmlAttribute nodes to re-use them in other XmlElements.

Remarks

If an attribute with that name is already present in the element, it is replaced by the new one.

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace | XmlElement.SetAttributeNode Overload List


XmlElement.WriteContentTo

Saves all the children of the node to the specified XmlWriter.

[Visual Basic]
Overrides Public Sub WriteContentTo( _
   ByVal w As XmlWriter _
)
[C#]
public override void WriteContentTo(
   XmlWriter w
);
[C++]
public: override void WriteContentTo(
   XmlWriter* w
);
[JScript]
public override function WriteContentTo(
   w : XmlWriter
);

Parameters

w
The XmlWriter where you want to save the current node.

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace


XmlElement.WriteTo

Saves the current node to the specified XmlWriter.

[Visual Basic]
Overrides Public Sub WriteTo( _
   ByVal w As XmlWriter _
)
[C#]
public override void WriteTo(
   XmlWriter w
);
[C++]
public: override void WriteTo(
   XmlWriter* w
);
[JScript]
public override function WriteTo(
   w : XmlWriter
);

Parameters

w
The XmlWriter where you want to save the current node.

See Also

XmlElement Class | XmlElement Members | System.NewXml Namespace


XmlEntity Class

Represents a parsed or unparsed entity in the XML document.

Object
XmlNode
XmlEntity

[Visual Basic]
Public Class XmlEntity
   Inherits XmlNode
[C#]
public class XmlEntity : XmlNode
[C++]
public __gc class XmlEntity : public XmlNode
[JScript]
public class XmlEntity extends XmlNode

Remarks

[To be supplied.]

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

XmlEntity Members | System.NewXml Namespace


XmlEntity Members

Public:

Properties

Attributes (inherited from XmlNode) | Gets an XmlAttributeCollection containing the attributes of this node.
ChildNodes (inherited from XmlNode) | Gets all children of this node.
FirstChild (inherited from XmlNode) | Gets the first child of this node.
HasChildNodes (inherited from XmlNode) | Gets a value indicating whether this node has any child nodes.
InnerText (inherited from XmlNode) | Gets or sets the concatenated values of the node and all its children.
InnerXml (inherited from XmlNode) | Gets or sets the markup representing just the children of this node.
IsReadOnly (inherited from XmlNode) | Gets a value indicating whether the node is read-only.
Item (inherited from XmlNode) | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlEntity class.
LastChild (inherited from XmlNode) | Gets the last child of this node.
LocalName | Gets the name of the node without the namespace prefix.
Name | Gets the name of the node.
NamespaceURI (inherited from XmlNode) | Gets the namespace URI of this node.
NextSibling (inherited from XmlNode) | Gets the node immediately following this node.
NodeType | Gets the type of the node.
NotationName | Gets the name of the optional NDATA attribute on the entity declaration.
OuterXml (inherited from XmlNode) | Gets the markup representing this node and all its children.
OwnerDocument (inherited from XmlNode) | Gets the XmlDocument that contains this node.
ParentNode (inherited from XmlNode) | Gets the parent of this node (for nodes that can have parents).
Prefix (inherited from XmlNode) | Gets or sets the namespace prefix of this node.
PreviousSibling (inherited from XmlNode) | Gets the node immediately preceding this node.
PublicId | Gets the value of the public identifier on the entity declaration.
SystemId | Gets the value of the system identifier on the entity declaration.
Value | Gets or sets the value of the node.

Methods

AppendChild (inherited from XmlNode) | Adds the specified node to the end of the list of children of this node.
Clone (inherited from XmlNode) | Creates a duplicate of this node.
CloneNode | Creates a duplicate of this node.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from XmlNode) | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamespaceOfPrefix (inherited from XmlNode) | Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.
GetPrefixOfNamespace (inherited from XmlNode) | Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.
GetType (inherited from Object) | Gets the Type of the Object.
InsertAfter (inherited from XmlNode) | Inserts the specified node immediately after the specified reference node.
InsertBefore (inherited from XmlNode) | Inserts the specified node immediately before the specified reference node.
Normalize (inherited from XmlNode) | Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.
PrependChild (inherited from XmlNode) | Adds the specified node to the beginning of the list of children of this node.
RemoveAll (inherited from XmlNode) | Removes all the children and/or attributes of the current node.
RemoveChild (inherited from XmlNode) | Removes specified child node.
ReplaceChild (inherited from XmlNode) | Replaces the child node oldChild with newChild node.
Supports (inherited from XmlNode) | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteContentTo | Saves all the children of the node to the specified XmlWriter.
WriteTo | Saves the node to the specified XmlWriter.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlEntity Class | System.NewXml Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlEntity Properties

The properties of the XmlEntity class are listed below. For a complete list of XmlEntity class members, see the XmlEntity Members topic.

Public:

Attributes (inherited from XmlNode) | Gets an XmlAttributeCollection containing the attributes of this node.
ChildNodes (inherited from XmlNode) | Gets all children of this node.
FirstChild (inherited from XmlNode) | Gets the first child of this node.
HasChildNodes (inherited from XmlNode) | Gets a value indicating whether this node has any child nodes.
InnerText (inherited from XmlNode) | Gets or sets the concatenated values of the node and all its children.
InnerXml (inherited from XmlNode) | Gets or sets the markup representing just the children of this node.
IsReadOnly (inherited from XmlNode) | Gets a value indicating whether the node is read-only.
Item (inherited from XmlNode) | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlEntity class.
LastChild (inherited from XmlNode) | Gets the last child of this node.
LocalName | Gets the name of the node without the namespace prefix.
Name | Gets the name of the node.
NamespaceURI (inherited from XmlNode) | Gets the namespace URI of this node.
NextSibling (inherited from XmlNode) | Gets the node immediately following this node.
NodeType | Gets the type of the node.
NotationName | Gets the name of the optional NDATA attribute on the entity declaration.
OuterXml (inherited from XmlNode) | Gets the markup representing this node and all its children.
OwnerDocument (inherited from XmlNode) | Gets the XmlDocument that contains this node.
ParentNode (inherited from XmlNode) | Gets the parent of this node (for nodes that can have parents).
Prefix (inherited from XmlNode) | Gets or sets the namespace prefix of this node.
PreviousSibling (inherited from XmlNode) | Gets the node immediately preceding this node.
PublicId | Gets the value of the public identifier on the entity declaration.
SystemId | Gets the value of the system identifier on the entity declaration.
Value | Gets or sets the value of the node.

See Also

XmlEntity Class | System.NewXml Namespace


XmlEntity.LocalName

Gets the name of the node without the namespace prefix.

[Visual Basic]
Overridable Public ReadOnly Property LocalName As String
[C#]
public string LocalName {override get;}
[C++]
public: __property virtual String* get_LocalName();
[JScript]
public function get LocalName() : String;

Property Value

The name of the node with the prefix removed. For example, LocalName is yyy for the element <xxx:yyy>.

Remarks

For nodes created with a DOM Level 1 method, such as CreateElement, it is null.

See Also

XmlEntity Class | XmlEntity Members | System.NewXml Namespace


XmlEntity.Name

Gets the name of the node.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {override get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

Property Value

The name of the entity.

See Also

XmlEntity Class | XmlEntity Members | System.NewXml Namespace


XmlEntity.NodeType

Gets the type of the node.

[Visual Basic]
Overridable Public ReadOnly Property NodeType As XmlNodeType
[C#]
public XmlNodeType NodeType {override get;}
[C++]
public: __property virtual XmlNodeType get_NodeType();
[JScript]
public function get NodeType() : XmlNodeType;

Property Value

One of the XmlNodeType values.

See Also

XmlEntity Class | XmlEntity Members | System.NewXml Namespace


XmlEntity.NotationName

Gets the name of the optional NDATA attribute on the entity declaration.

[Visual Basic]
Public ReadOnly Property NotationName As String
[C#]
public string NotationName {get;}
[C++]
public: __property String* get_NotationName();
[JScript]
public function get NotationName() : String;

Property Value

The name of the NDATA attribute. If there is no NDATA, String.Empty is returned.

See Also

XmlEntity Class | XmlEntity Members | System.NewXml Namespace


XmlEntity.PublicId

Gets the value of the public identifier on the entity declaration.

[Visual Basic]
Public ReadOnly Property PublicId As String
[C#]
public string PublicId {get;}
[C++]
public: __property String* get_PublicId();
[JScript]
public function get PublicId() : String;

Property Value

The public identifier on the entity. If there is no public identifier, String.Empty is returned.

See Also

XmlEntity Class | XmlEntity Members | System.NewXml Namespace


XmlEntity.SystemId

Gets the value of the system identifier on the entity declaration.

[Visual Basic]
Public ReadOnly Property SystemId As String
[C#]
public string SystemId {get;}
[C++]
public: __property String* get_SystemId();
[JScript]
public function get SystemId() : String;

Property Value

The system identifier on the entity. If there is no system identifier, String.Empty is returned.

See Also

XmlEntity Class | XmlEntity Members | System.NewXml Namespace


XmlEntity.Value

Gets or sets the value of the node.

[Visual Basic]
Overridable Public Property Value As String
[C#]
public string Value {override get; override set;}
[C++]
public: __property virtual String* get_Value();
public: __property virtual void set_Value(String*);
[JScript]
public function get Value() : String;
public function set Value(String);

Property Value

The value of the node.

Exceptions

Exception Type | Condition
ReadOnlyException | Node is read-only.
ArgumentOutOfRangeException | [To be supplied.]

See Also

XmlEntity Class | XmlEntity Members | System.NewXml Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlEntity Methods

The methods of the XmlEntity class are listed below. For a complete list of XmlEntity class members, see the XmlEntity Members topic.

Public:

AppendChild (inherited from XmlNode) | Adds the specified node to the end of the list of children of this node.
Clone (inherited from XmlNode) | Creates a duplicate of this node.
CloneNode | Creates a duplicate of this node.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from XmlNode) | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamespaceOfPrefix (inherited from XmlNode) | Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.
GetPrefixOfNamespace (inherited from XmlNode) | Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.
GetType (inherited from Object) | Gets the Type of the Object.
InsertAfter (inherited from XmlNode) | Inserts the specified node immediately after the specified reference node.
InsertBefore (inherited from XmlNode) | Inserts the specified node immediately before the specified reference node.
Normalize (inherited from XmlNode) | Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.
PrependChild (inherited from XmlNode) | Adds the specified node to the beginning of the list of children of this node.
RemoveAll (inherited from XmlNode) | Removes all the children and/or attributes of the current node.
RemoveChild (inherited from XmlNode) | Removes specified child node.
ReplaceChild (inherited from XmlNode) | Replaces the child node oldChild with newChild node.
Supports (inherited from XmlNode) | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteContentTo | Saves all the children of the node to the specified XmlWriter.
WriteTo | Saves the node to the specified XmlWriter.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlEntity Class | System.NewXml Namespace


XmlEntity.CloneNode

Creates a duplicate of this node.

[Visual Basic]
Overrides Public Function CloneNode( _
   ByVal deep As Boolean _
) As XmlNode
[C#]
public override XmlNode CloneNode(
   bool deep
);
[C++]
public: override XmlNode* CloneNode(
   bool deep
);
[JScript]
public override function CloneNode(
   deep : Boolean
) : XmlNode;

Parameters

deep
true to recursively clone the subtree under the specified node; false to clone only the node itself (and its attributes if the node is an XmlElement).

Return Value

The duplicate node.

Remarks

This method serves as a generic copy constructor for nodes. The duplicate node has no parent (ParentNode returns null).

See Also

XmlEntity Class | XmlEntity Members | System.NewXml Namespace


XmlEntity.WriteContentTo

Saves all the children of the node to the specified XmlWriter.

[Visual Basic]
Overrides Public Sub WriteContentTo( _
   ByVal w As XmlWriter _
)
[C#]
public override void WriteContentTo(
   XmlWriter w
);
[C++]
public: override void WriteContentTo(
   XmlWriter* w
);
[JScript]
public override function WriteContentTo(
   w : XmlWriter
);

Parameters

w
The XmlWriter where you want to save the current node.

See Also

XmlEntity Class | XmlEntity Members | System.NewXml Namespace


XmlEntity.WriteTo

Saves the node to the specified XmlWriter.

[Visual Basic]
Overrides Public Sub WriteTo( _
   ByVal w As XmlWriter _
)
[C#]
public override void WriteTo(
   XmlWriter w
);
[C++]
public: override void WriteTo(
   XmlWriter* w
);
[JScript]
public override function WriteTo(
   w : XmlWriter
);

Parameters

w
The XmlWriter where you want to save the node.

See Also

XmlEntity Class | XmlEntity Members | System.NewXml Namespace


XmlEntityReference Class

Represents an entity reference node.

Object
XmlNode
XmlLinkedNode
XmlEntityReference

[Visual Basic]
Public Class XmlEntityReference
   Inherits XmlLinkedNode
[C#]
public class XmlEntityReference : XmlLinkedNode
[C++]
public __gc class XmlEntityReference : public XmlLinkedNode
[JScript]
public class XmlEntityReference extends XmlLinkedNode

Remarks

[To be supplied.]

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

XmlEntityReference Members | System.NewXml Namespace


XmlEntityReference Members

Public:

Properties

Attributes (inherited from XmlNode) | Gets an XmlAttributeCollection containing the attributes of this node.
ChildNodes (inherited from XmlNode) | Gets all children of this node.
FirstChild (inherited from XmlNode) | Gets the first child of this node.
HasChildNodes (inherited from XmlNode) | Gets a value indicating whether this node has any child nodes.
InnerText (inherited from XmlNode) | Gets or sets the concatenated values of the node and all its children.
InnerXml (inherited from XmlNode) | Gets or sets the markup representing just the children of this node.
IsReadOnly (inherited from XmlNode) | Gets a value indicating whether the node is read-only.
Item (inherited from XmlNode) | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlEntityReference class.
LastChild (inherited from XmlNode) | Gets the last child of this node.
LocalName | Gets the name of the node without the namespace prefix.
Name | Gets the name of the node.
NamespaceURI (inherited from XmlNode) | Gets the namespace URI of this node.
NextSibling (inherited from XmlLinkedNode) | [To be supplied.]
NodeType | Gets the type of the node.
OuterXml (inherited from XmlNode) | Gets the markup representing this node and all its children.
OwnerDocument (inherited from XmlNode) | Gets the XmlDocument that contains this node.
ParentNode (inherited from XmlNode) | Gets the parent of this node (for nodes that can have parents).
Prefix (inherited from XmlNode) | Gets or sets the namespace prefix of this node.
PreviousSibling (inherited from XmlLinkedNode) | [To be supplied.]
Value | Gets or sets the value of the node.

Methods

AppendChild (inherited from XmlNode) | Adds the specified node to the end of the list of children of this node.
Clone (inherited from XmlNode) | Creates a duplicate of this node.
CloneNode | Creates a duplicate of this node.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from XmlNode) | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamespaceOfPrefix (inherited from XmlNode) | Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.
GetPrefixOfNamespace (inherited from XmlNode) | Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.
GetType (inherited from Object) | Gets the Type of the Object.
InsertAfter (inherited from XmlNode) | Inserts the specified node immediately after the specified reference node.
InsertBefore (inherited from XmlNode) | Inserts the specified node immediately before the specified reference node.
Normalize (inherited from XmlNode) | Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.
PrependChild (inherited from XmlNode) | Adds the specified node to the beginning of the list of children of this node.
RemoveAll (inherited from XmlNode) | Removes all the children and/or attributes of the current node.
RemoveChild (inherited from XmlNode) | Removes specified child node.
ReplaceChild (inherited from XmlNode) | Replaces the child node oldChild with newChild node.
Supports (inherited from XmlNode) | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteContentTo | Saves all the children of the node to the specified XmlWriter.
WriteTo | Saves the node to the specified XmlWriter.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlEntityReference Class | System.NewXml Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlEntityReference Properties

The properties of the XmlEntityReference class are listed below. For a complete list of XmlEntityReference class members, see the XmlEntityReference Members topic.

Public:

Attributes (inherited from XmlNode) | Gets an XmlAttributeCollection containing the attributes of this node.
ChildNodes (inherited from XmlNode) | Gets all children of this node.
FirstChild (inherited from XmlNode) | Gets the first child of this node.
HasChildNodes (inherited from XmlNode) | Gets a value indicating whether this node has any child nodes.
InnerText (inherited from XmlNode) | Gets or sets the concatenated values of the node and all its children.
InnerXml (inherited from XmlNode) | Gets or sets the markup representing just the children of this node.
IsReadOnly (inherited from XmlNode) | Gets a value indicating whether the node is read-only.
Item (inherited from XmlNode) | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlEntityReference class.
LastChild (inherited from XmlNode) | Gets the last child of this node.
LocalName | Gets the name of the node without the namespace prefix.
Name | Gets the name of the node.
NamespaceURI (inherited from XmlNode) | Gets the namespace URI of this node.
NextSibling (inherited from XmlLinkedNode) | [To be supplied.]
NodeType | Gets the type of the node.
OuterXml (inherited from XmlNode) | Gets the markup representing this node and all its children.
OwnerDocument (inherited from XmlNode) | Gets the XmlDocument that contains this node.
ParentNode (inherited from XmlNode) | Gets the parent of this node (for nodes that can have parents).
Prefix (inherited from XmlNode) | Gets or sets the namespace prefix of this node.
PreviousSibling (inherited from XmlLinkedNode) | [To be supplied.]
Value | Gets or sets the value of the node.

See Also

XmlEntityReference Class | System.NewXml Namespace


XmlEntityReference.LocalName

Gets the name of the node without the namespace prefix.

[Visual Basic]
Overridable Public ReadOnly Property LocalName As String
[C#]
public string LocalName {override get;}
[C++]
public: __property virtual String* get_LocalName();
[JScript]
public function get LocalName() : String;

Property Value

The name of the node with the prefix removed. For example, LocalName is yyy for the element <xxx:yyy>.

Remarks

For nodes created with a DOM Level 1 method, such as CreateElement, it is null.

See Also

XmlEntityReference Class | XmlEntityReference Members | System.NewXml Namespace


XmlEntityReference.Name

Gets the name of the node.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {override get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

Property Value

The name of the entity referenced.

See Also

XmlEntityReference Class | XmlEntityReference Members | System.NewXml Namespace


XmlEntityReference.NodeType

Gets the type of the node.

[Visual Basic]
Overridable Public ReadOnly Property NodeType As XmlNodeType
[C#]
public XmlNodeType NodeType {override get;}
[C++]
public: __property virtual XmlNodeType get_NodeType();
[JScript]
public function get NodeType() : XmlNodeType;

Property Value

One of the XmlNodeType values.

See Also

XmlEntityReference Class | XmlEntityReference Members | System.NewXml Namespace


XmlEntityReference.Value

Gets or sets the value of the node.

[Visual Basic]
Overridable Public Property Value As String
[C#]
public string Value {override get; override set;}
[C++]
public: __property virtual String* get_Value();
public: __property virtual void set_Value(String*);
[JScript]
public function get Value() : String;
public function set Value(String);

Property Value

The value of the node. For XmlEntityReference, the property is null.

Exceptions

Exception Type | Condition
ReadOnlyException | Node is read-only.
ArgumentOutOfRangeException | [To be supplied.]

See Also

XmlEntityReference Class | XmlEntityReference Members | System.NewXml Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlEntityReference Methods

The methods of the XmlEntityReference class are listed below. For a complete list of XmlEntityReference class members, see the XmlEntityReference Members topic.

Public:

AppendChild (inherited from XmlNode) | Adds the specified node to the end of the list of children of this node.
Clone (inherited from XmlNode) | Creates a duplicate of this node.
CloneNode | Creates a duplicate of this node.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from XmlNode) | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamespaceOfPrefix (inherited from XmlNode) | Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.
GetPrefixOfNamespace (inherited from XmlNode) | Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.
GetType (inherited from Object) | Gets the Type of the Object.
InsertAfter (inherited from XmlNode) | Inserts the specified node immediately after the specified reference node.
InsertBefore (inherited from XmlNode) | Inserts the specified node immediately before the specified reference node.
Normalize (inherited from XmlNode) | Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.
PrependChild (inherited from XmlNode) | Adds the specified node to the beginning of the list of children of this node.
RemoveAll (inherited from XmlNode) | Removes all the children and/or attributes of the current node.
RemoveChild (inherited from XmlNode) | Removes specified child node.
ReplaceChild (inherited from XmlNode) | Replaces the child node oldChild with newChild node.
Supports (inherited from XmlNode) | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteContentTo | Saves all the children of the node to the specified XmlWriter.
WriteTo | Saves the node to the specified XmlWriter.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlEntityReference Class | System.NewXml Namespace


XmlEntityReference.CloneNode

Creates a duplicate of this node.

[Visual Basic]
Overrides Public Function CloneNode( _
   ByVal deep As Boolean _
) As XmlNode
[C#]
public override XmlNode CloneNode(
   bool deep
);
[C++]
public: override XmlNode* CloneNode(
   bool deep
);
[JScript]
public override function CloneNode(
   deep : Boolean
) : XmlNode;

Parameters

deep
true to recursively clone the subtree under the specified node; false to clone only the node itself (and its attributes if the node is an XmlElement).

Return Value

The duplicate node.

Remarks

This method serves as a generic copy constructor for nodes. The duplicate node has no parent (ParentNode returns null).

See Also

XmlEntityReference Class | XmlEntityReference Members | System.NewXml Namespace


XmlEntityReference.WriteContentTo

Saves all the children of the node to the specified XmlWriter.

[Visual Basic]
Overrides Public Sub WriteContentTo( _
   ByVal w As XmlWriter _
)
[C#]
public override void WriteContentTo(
   XmlWriter w
);
[C++]
public: override void WriteContentTo(
   XmlWriter* w
);
[JScript]
public override function WriteContentTo(
   w : XmlWriter
);

Parameters

w
The XmlWriter where you want to save the current node.

See Also

XmlEntityReference Class | XmlEntityReference Members | System.NewXml Namespace


XmlEntityReference.WriteTo

Saves the node to the specified XmlWriter.

[Visual Basic]
Overrides Public Sub WriteTo( _
   ByVal w As XmlWriter _
)
[C#]
public override void WriteTo(
   XmlWriter w
);
[C++]
public: override void WriteTo(
   XmlWriter* w
);
[JScript]
public override function WriteTo(
   w : XmlWriter
);

Parameters

w
The XmlWriter where you want to save the node.

See Also

XmlEntityReference Class | XmlEntityReference Members | System.NewXml Namespace


XmlImplementation Class

Provides methods for performing operations that are independent of any particular instance of the document object model.

Object
XmlImplementation

[Visual Basic]
Public Class XmlImplementation
[C#]
public class XmlImplementation
[C++]
public __gc class XmlImplementation
[JScript]
public class XmlImplementation

Remarks

This class defines the context for a set of XmlDocument objects. Nodes from documents that come from the same implementation are interchangeable, in other words, you can move nodes around multiple document instances if and only if those documents come from the same implementation. For example, the following shows how a node created by doc1 can be inserted into doc2 without a WRONG_DOC_ERR exception. This is because both document objects share the same implementation context.

[C#]

XmlImplementation imp = new XmlImplementation();
XmlDocument doc1 = imp.CreateDocument();
XmlDocument doc2 = imp.CreateDocument();
doc2.AppendChild(doc1.CreateElement("foo"));

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

XmlImplementation Members | System.NewXml Namespace


XmlImplementation Members

Public:

Constructor

XmlImplementation Constructor Initializes a new instance of the XmlImplementation class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
HasFeature | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlImplementation Class | System.NewXml Namespace


XmlImplementation Constructor

Initializes a new instance of the XmlImplementation class.

[Visual Basic]
Public Sub New()
[C#]
public XmlImplementation();
[C++]
public: XmlImplementation();
[JScript]
public function XmlImplementation();

See Also

XmlImplementation Class | XmlImplementation Members | System.NewXml Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlImplementation Methods

The methods of the XmlImplementation class are listed below. For a complete list of XmlImplementation class members, see the XmlImplementation Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
HasFeature | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlImplementation Class | System.NewXml Namespace


XmlImplementation.HasFeature

Test if the DOM implementation implements a specific feature.

[Visual Basic]
Public Function HasFeature( _
   ByVal strFeature As String, _
   ByVal strVersion As String _
) As Boolean
[C#]
public bool HasFeature(
   string strFeature,
   string strVersion
);
[C++]
public: bool HasFeature(
   String* strFeature,
   String* strVersion
);
[JScript]
public function HasFeature(
   strFeature : String,
   strVersion : String
) : Boolean;

Parameters

strFeature
The package name of the feature to test. This name is case-insensitive.
strVersion
[To be supplied.]

Return Value

true if the feature is implemented in the specified version; otherwise, false.

This implementation returns true for the following combinations:

strFeature | strVersion
XML | 1.0
XML | 2.0

See Also

XmlImplementation Class | XmlImplementation Members | System.NewXml Namespace


XmlNamedNodeMap Class

Represents a collection of nodes that can be accessed by name or index.

Object
XmlNamedNodeMap

[Visual Basic]
Public Class XmlNamedNodeMap
   Implements IEnumerable
[C#]
public class XmlNamedNodeMap : IEnumerable
[C++]
public __gc class XmlNamedNodeMap : public IEnumerable
[JScript]
public class XmlNamedNodeMap implements IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

XmlNamedNodeMap Members | System.NewXml Namespace


XmlNamedNodeMap Members

Public:

Properties

Count Gets the number of nodes in this XmlNamedNodeMap.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedItem | Overloaded. Retrieves the specified XmlNode from the collection of nodes in this XmlNamedNodeMap.
GetType (inherited from Object) | Gets the Type of the Object.
Item | Retrieves the node at the specified index in this XmlNamedNodeMap.
RemoveNamedItem | Overloaded. Removes the specified node from this XmlNamedNodeMap.
SetNamedItem | Adds a XmlNode using its Name property
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlNamedNodeMap Class | System.NewXml Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlNamedNodeMap Properties

The properties of the XmlNamedNodeMap class are listed below. For a complete list of XmlNamedNodeMap class members, see the XmlNamedNodeMap Members topic.

Public:

Count Gets the number of nodes in this XmlNamedNodeMap.

See Also

XmlNamedNodeMap Class | System.NewXml Namespace


XmlNamedNodeMap.Count

Gets the number of nodes in this XmlNamedNodeMap.

[Visual Basic]
Overridable Public ReadOnly Property Count As Integer
[C#]
public int Count {virtual get;}
[C++]
public: __property virtual int get_Count();
[JScript]
public function get Count() : int;

Property Value

The number of nodes.

See Also

XmlNamedNodeMap Class | XmlNamedNodeMap Members | System.NewXml Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlNamedNodeMap Methods

The methods of the XmlNamedNodeMap class are listed below. For a complete list of XmlNamedNodeMap class members, see the XmlNamedNodeMap Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedItem | Overloaded. Retrieves the specified XmlNode from the collection of nodes in this XmlNamedNodeMap.
GetType (inherited from Object) | Gets the Type of the Object.
Item | Retrieves the node at the specified index in this XmlNamedNodeMap.
RemoveNamedItem | Overloaded. Removes the specified node from this XmlNamedNodeMap.
SetNamedItem | Adds a XmlNode using its Name property
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlNamedNodeMap Class | System.NewXml Namespace


XmlNamedNodeMap.GetEnumerator

Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.

[Visual Basic]
Overridable Public Function GetEnumerator() As IEnumerator
[C#]
public virtual IEnumerator GetEnumerator();
[C++]
public: virtual IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

Return Value

An IEnumerator.

See Also

XmlNamedNodeMap Class | XmlNamedNodeMap Members | System.NewXml Namespace


XmlNamedNodeMap.GetNamedItem

Retrieves the specified XmlNode from the collection of nodes in this XmlNamedNodeMap.

Overload List

Retrieves an XmlNode specified by name.

[Visual Basic] Overloads Overridable Public Function GetNamedItem(String) As XmlNode
[C#] public virtual XmlNode GetNamedItem(String);
[C++] public: virtual XmlNode* GetNamedItem(String*);
[JScript] public function GetNamedItem(String) : XmlNode;

Retrieves a node specified by LocalName and NamespaceURI.

[Visual Basic] Overloads Overridable Public Function GetNamedItem(String, String) As XmlNode
[C#] public virtual XmlNode GetNamedItem(String, String);
[C++] public: virtual XmlNode* GetNamedItem(String*, String*);
[JScript] public function GetNamedItem(String, String) : XmlNode;

See Also

XmlNamedNodeMap Class | XmlNamedNodeMap Members | System.NewXml Namespace


XmlNamedNodeMap.GetNamedItem (String)

Retrieves an XmlNode specified by name.

[Visual Basic]
Overloads Overridable Public Function GetNamedItem( _
   ByVal name As String _
) As XmlNode
[C#]
public virtual XmlNode GetNamedItem(
   string name
);
[C++]
public: virtual XmlNode* GetNamedItem(
   String* name
);
[JScript]
public function GetNamedItem(
   name : String
) : XmlNode;

Parameters

name
Name of the node to retrieve.

Return Value

An XmlNode with the specified name. If a node with the specified name is not found in this XmlNamedNodeMap, null is returned.

See Also

XmlNamedNodeMap Class | XmlNamedNodeMap Members | System.NewXml Namespace | XmlNamedNodeMap.GetNamedItem Overload List


XmlNamedNodeMap.GetNamedItem (String, String)

Retrieves a node specified by LocalName and NamespaceURI.

[Visual Basic]
Overloads Overridable Public Function GetNamedItem( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As XmlNode
[C#]
public virtual XmlNode GetNamedItem(
   string localName,
   string namespaceURI
);
[C++]
public: virtual XmlNode* GetNamedItem(
   String* localName,
   String* namespaceURI
);
[JScript]
public function GetNamedItem(
   localName : String,
   namespaceURI : String
) : XmlNode;

Parameters

localName
Local name of the node to retrieve.
namespaceURI
[To be supplied.]

Return Value

An XmlNode with the specified LocalName and NamespaceURI. If a node with both the specified LocalName and NamespaceURI is not found in this XmlNamedNodeMap, null is returned.

See Also

XmlNamedNodeMap Class | XmlNamedNodeMap Members | System.NewXml Namespace | XmlNamedNodeMap.GetNamedItem Overload List


XmlNamedNodeMap.Item

Retrieves the node at the specified index in this XmlNamedNodeMap.

[Visual Basic]
Overridable Public Function Item( _
   ByVal index As Integer _
) As XmlNode
[C#]
public virtual XmlNode Item(
   int index
);
[C++]
public: virtual XmlNode* Item(
   int index
);
[JScript]
public function Item(
   index : int
) : XmlNode;

Parameters

index
The index position of the node to retrieve from this XmlNamedNodeMap. The index is zero-based; therefore, the first node's index is 0 and the last node's index is Count-1.

Return Value

The XmlNode at the specified index. If index is greater than or equal to the Count property, a null reference (in Visual Basic Nothing) is returned.

See Also

XmlNamedNodeMap Class | XmlNamedNodeMap Members | System.NewXml Namespace


XmlNamedNodeMap.RemoveNamedItem

Removes the specified node from this XmlNamedNodeMap.

Overload List

Removes the node specified by name.

[Visual Basic] Overloads Overridable Public Function RemoveNamedItem(String) As XmlNode
[C#] public virtual XmlNode RemoveNamedItem(String);
[C++] public: virtual XmlNode* RemoveNamedItem(String*);
[JScript] public function RemoveNamedItem(String) : XmlNode;

Removes a node specified by local name and namespace URI.

[Visual Basic] Overloads Overridable Public Function RemoveNamedItem(String, String) As XmlNode
[C#] public virtual XmlNode RemoveNamedItem(String, String);
[C++] public: virtual XmlNode* RemoveNamedItem(String*, String*);
[JScript] public function RemoveNamedItem(String, String) : XmlNode;

See Also

XmlNamedNodeMap Class | XmlNamedNodeMap Members | System.NewXml Namespace


XmlNamedNodeMap.RemoveNamedItem (String)

Removes the node specified by name.

[Visual Basic]
Overloads Overridable Public Function RemoveNamedItem( _
   ByVal name As String _
) As XmlNode
[C#]
public virtual XmlNode RemoveNamedItem(
   string name
);
[C++]
public: virtual XmlNode* RemoveNamedItem(
   String* name
);
[JScript]
public function RemoveNamedItem(
   name : String
) : XmlNode;

Parameters

name
The name of the node to remove.

Return Value

The XmlNode removed from this XmlNamedNodeMap. If a node with the specified name does not exist, null is returned.

Remarks

If the removed node is an XmlAttribute that contains a default value, it is immediately replaced in this XmlNamedNodeMap.

See Also

XmlNamedNodeMap Class | XmlNamedNodeMap Members | System.NewXml Namespace | XmlNamedNodeMap.RemoveNamedItem Overload List


XmlNamedNodeMap.RemoveNamedItem (String, String)

Removes a node specified by local name and namespace URI.

[Visual Basic]
Overloads Overridable Public Function RemoveNamedItem( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As XmlNode
[C#]
public virtual XmlNode RemoveNamedItem(
   string localName,
   string namespaceURI
);
[C++]
public: virtual XmlNode* RemoveNamedItem(
   String* localName,
   String* namespaceURI
);
[JScript]
public function RemoveNamedItem(
   localName : String,
   namespaceURI : String
) : XmlNode;

Parameters

localName
Local name of the node to remove.
namespaceURI
[To be supplied.]

Return Value

The XmlNode removed from this XmlNamedNodeMap. If a node with the specified name does not exist, null is returned.

Exceptions

Exception Type | Condition
NOT_FOUND_ERR | No node with the specified LocalName and NamespaceUri exists in this XmlNamedNodeMap.

Remarks

If the removed node is an XmlAttribute that contains a default value, it is immediately replaced in this XmlNamedNodeMap.

See Also

XmlNamedNodeMap Class | XmlNamedNodeMap Members | System.NewXml Namespace | XmlNamedNodeMap.RemoveNamedItem Overload List


XmlNamedNodeMap.SetNamedItem

Adds a XmlNode using its Name property

[Visual Basic]
Overridable Public Function SetNamedItem( _
   ByVal node As XmlNode _
) As XmlNode
[C#]
public virtual XmlNode SetNamedItem(
   XmlNode node
);
[C++]
public: virtual XmlNode* SetNamedItem(
   XmlNode* node
);
[JScript]
public function SetNamedItem(
   node : XmlNode
) : XmlNode;

Parameters

node
A XmlNode to store in this XmlNamedNodeMap. The node will later be accessible using the value of the Name property of the node. If a node with that name is already present in the map, it is replaced by the new one.

Return Value

If the node replaces an existing node with the same name, the old node is returned; otherwise, null is returned.

See Also

XmlNamedNodeMap Class | XmlNamedNodeMap Members | System.NewXml Namespace


XmlNameTable Interface

Provide efficient string interning for the XML parser so that the same string object is used for all repeated element and attribute names in an XML document. This class is abstract.

XmlNameTable

[Visual Basic]
Public Interface XmlNameTable
[C#]
public interface XmlNameTable
[C++]
public __gc __interface XmlNameTable

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

XmlNameTable Members | System.NewXml Namespace


XmlNameTable Members

Methods

Add | Overloaded. Creates a new atom for the specified string.
Get | Overloaded. Gets the atomized String object containing the same characters as the specified String.

See Also

XmlNameTable Interface | System.NewXml Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlNameTable Methods

The methods of the XmlNameTable interface are listed below. For a complete list of XmlNameTable interface members, see the XmlNameTable Members topic.

Add | Overloaded. Creates a new atom for the specified string.
Get | Overloaded. Gets the atomized String object containing the same characters as the specified String.

See Also

XmlNameTable Interface | System.NewXml Namespace


XmlNameTable.Add

Creates a new atom for the specified string.

Overload List

Creates a new atom for the characters at the specified range of chararacters in the specified string.

[Visual Basic] Overloads Function Add(Char(), Integer, Integer) As String
[C#] string Add(char[], int, int);
[C++] String* Add(__wchar_t*[], int, int) = 0;
[JScript] function Add(Char[], int, int) : String;

Creates a new atom for the specified string.

[Visual Basic] Overloads Function Add(String) As String
[C#] string Add(String);
[C++] String* Add(String*) = 0;
[JScript] function Add(String) : String;

See Also

XmlNameTable Interface | XmlNameTable Members | System.NewXml Namespace


XmlNameTable.Add (Char[], Int32, Int32)

Creates a new atom for the characters at the specified range of chararacters in the specified string.

[Visual Basic]
Overloads Function Add( _
   ByVal array() As Char, _
   ByVal offset As Integer, _
   ByVal length As Integer _
) As String
[C#]
string Add(
   char[] array,
   int offset,
   int length
);
[C++]
String* Add(
   __wchar_t* array[],
   int offset,
   int length
) = 0;
[JScript]
function Add(
   array : Char[],
   offset : int,
   length : int
) : String;

Parameters

array
The character array containing the name to add.
offset
Zero based index into the array specifying the first character of the name.
length
The number of characters in the name.

Return Value

Returns atomized string. Returns String.Empty if length is zero. Returns the existing atom if one already exists.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | if 0 > offset > array.Length or 0 > length > array.Length- offset.

See Also

XmlNameTable Interface | XmlNameTable Members | System.NewXml Namespace | XmlNameTable.Add Overload List


XmlNameTable.Add (String)

Creates a new atom for the specified string.

[Visual Basic]
Overloads Function Add( _
   ByVal array As String _
) As String
[C#]
string Add(
   string array
);
[C++]
String* Add(
   String* array
) = 0;
[JScript]
function Add(
   array : String
) : String;

Parameters

array
The character array containing the name to add.

Return Value

Returns atomized string. Returns String.Empty if length is zero. Returns the existing atom if one already exists.

See Also

XmlNameTable Interface | XmlNameTable Members | System.NewXml Namespace | XmlNameTable.Add Overload List


XmlNameTable.Get

Gets the atomized String object containing the same characters as the specified String.

Overload List

Gets the atomized String object containing the same chars as the specified range of chars in the given char array.

[Visual Basic] Overloads Function Get(Char(), Integer, Integer) As String
[C#] string Get(char[], int, int);
[C++] String* Get(__wchar_t*[], int, int) = 0;
[JScript] function Get(Char[], int, int) : String;

Gets the atomized String object containing the same value as the specified string.

[Visual Basic] Overloads Function Get(String) As String
[C#] string Get(String);
[C++] String* Get(String*) = 0;
[JScript] function Get(String) : String;

See Also

XmlNameTable Interface | XmlNameTable Members | System.NewXml Namespace


XmlNameTable.Get (Char[], Int32, Int32)

Gets the atomized String object containing the same chars as the specified range of chars in the given char array.

[Visual Basic]
Overloads Function Get( _
   ByVal array() As Char, _
   ByVal offset As Integer, _
   ByVal length As Integer _
) As String
[C#]
string Get(
   char[] array,
   int offset,
   int length
);
[C++]
String* Get(
   __wchar_t* array[],
   int offset,
   int length
) = 0;
[JScript]
function Get(
   array : Char[],
   offset : int,
   length : int
) : String;

Parameters

array
The character array containing the name to look up.
offset
Zero based index into the array specifying the first character of the name.
length
The number of characters in the name. Returns null if this string has not already been atomized.

Return Value

The atomized string. Returns String.Empty if length is zero. Returns null if this string has not already been atomized.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | if 0 > offset > array.Length or 0 > length > array.Length- offset.

See Also

XmlNameTable Interface | XmlNameTable Members | System.NewXml Namespace | XmlNameTable.Get Overload List


XmlNameTable.Get (String)

Gets the atomized String object containing the same value as the specified string.

[Visual Basic]
Overloads Function Get( _
   ByVal array As String _
) As String
[C#]
string Get(
   string array
);
[C++]
String* Get(
   String* array
) = 0;
[JScript]
function Get(
   array : String
) : String;

Parameters

array
The character array containing the name to look up.

Return Value

The atomized string. Returns String.Empty if length is zero. Returns null if this string has not already been atomized.

See Also

XmlNameTable Interface | XmlNameTable Members | System.NewXml Namespace | XmlNameTable.Get Overload List


XmlNavigator Class

Reads and writes XML data using a cursor model.

This class is abstract.

Object
XmlNavigator

[Visual Basic]
MustInherit Public Class XmlNavigator
   Implements ICloneable
[C#]
public abstract class XmlNavigator : ICloneable
[C++]
public __gc __abstract class XmlNavigator : public ICloneable
[JScript]
public abstract class XmlNavigator implements ICloneable

Remarks

XmlNavigator provides all the node and attribute properties of the XmlReader. However, the XmlNavigator adds the following features:

  • Allows node and attribute properties to be set
  • Provides random access navigation (whereas XmlReader is a forward-only reader)
  • Enables you to handle a selected set of nodes within the document.

The XmlNavigator is always positioned on a node. If a method call fails, the XmlNavigator remains in the position it was in before the method call. The XmlNavigator provides a virtual window into a tree of nodes. This has the following implications:

  • When the virtual node that the XmlNavigator is pointing to is removed from the tree, or moved to a different tree the XmlNavigator continues to point at that moved node and MoveToParent may return something different than you expected.
  • MoveToNext and MoveToPrevious do not walk off the end of the list leaving the XmlNavigator in an indeterminate state. This model is easier for programmers to understand.
  • When the virtual node that the XmlNavigator is pointing to is moved to a different location in the tree, the XmlNavigator is moved along with it.

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

XmlNavigator Members | System.NewXml Namespace


XmlNavigator Members

Public:

Constructor

XmlNavigator Constructor [To be supplied.]

Properties

AttributeCount | Gets the number of attributes on the current node.
ChildCount | Gets the number of child nodes for the current node.
HasAttributes | Gets a value indicating whether the current node has any attributes.
HasChildren | Gets a value indicating whether the current node has child nodes.
HasSelection | Determines if this XmlNavigator currently has a selection set.
HasValue | Gets a value indicating whether Value has a value to return.
IndexInParent | Gets the zero-based index of this node's position in its parent node.
InnerText | Gets or sets the concatenated values of the current node and all its children.
IsDefault | Gets a value indicating whether the current node is an attribute that was generated from the default value defined in the DTD or schema.
IsEmptyTag | Gets a value indicating whether the current node is an empty element (for example, <MyElement/>).
IsReadOnly | Gets a value indicating whether the current node is read-only.
LocalName | Gets the name of the node without the namespace prefix.
Name | Gets the name of the current node, including the namespace prefix.
NamespaceURI | Gets the namespace URN (as defined in the W3C Namespace Specification) of the current namespace scope.
NameTable | Gets the XmlNameTable associated with this implementation.
NodeType | Gets the type of the current node.
Prefix | Gets or sets the namespace prefix associated with the current node.
Selection | Gets the last XPath expression used in a successful call to the Select method.
Value | Gets or sets the text value of the current node.

Methods

Clone | Creates a new XmlNavigator positioned at the same node as this XmlNavigator.
Compile | Compiles the given XPath expression and returns an object representing that expression.
CopyChildren | Copies all the children from current position of the specified XmlNavigator and inserts them at the specified position in this XmlNavigator.
CopySelected | Copies all the selected nodes from the specified XmlNavigator (as returned by MoveToNextSelected) and inserts them at the specified position in this tree.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Evaluate | Evaluates the given expression and returns the typed result (int, boolean or string).
GetAttribute | Overloaded. Gets the value of an attribute.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
HasAttribute | Overloaded. Determines whether the current node has the specified attribute.
Insert | Overloaded. Inserts node(s) at the specified position.
IsSamePosition | Determines whether this XmlNavigator is at the same position as the specified XmlNavigator.
LookupPrefix | Looks up the prefix for the given namespace URI as defined higher up in the tree.
Matches | Determines whether the current node matches the specified XPath expression
Move | Moves the entire subtree point to in the specified XmlNavigator to the specified position in this XmlNavigator.
MoveChildren | Moves all the children from current position of the specified XmlNavigator and inserts them at the specified position in this XmlNavigator.
MoveSelected | Moves all the selected nodes from the specified XmlNavigator (as returned by MoveToNextSelected) and inserts them at the specified position in this XmlNavigato. This navagitor's position is unaffected by this operation.
MoveTo | Moves to the same position as the specified XmlNavigator.
MoveToAttribute Overloaded. Move to the specified attribute.

The MoveToAttribute methods enable you to get both random access to attributes and strongly typed access to attribute values.

To get strongly typed access to an attribute value, you must do the following:

  1. Call MoveToAttribute to move to the attribute whose value you want to access.
  2. Call Read method for the data type you want (for example, ReadBoolean for boolean, ReadDate for DateTime, and so on).

After calling MoveToAttribute, the Name, Namespace, Prefix properties will reflect the properties of that attribute.
MoveToChild | Moves to the specified child node of the current node (index 0 is the first child).
MoveToDocument | Moves to the document node that owns this node.
MoveToDocumentElement | Moves to the child element node of the owning document.
MoveToElement | Moves to the element that contains the current attribute node.
MoveToFirst | Moves to the first sibling of the current node.
MoveToFirstAttribute | Moves to the first attribute.
MoveToFirstChild | Moves to the first child of the current node.
MoveToFirstSelected | Moves the XmlNavigator to the first node in the selected set.
MoveToId | Moves to the node with an ID attribute whose value matches the specified string.
MoveToLast | Moves to the last sibling of the current node.
MoveToLastChild | Moves to the last child of the current node.
MoveToLastSelected | Moves the XmlNavigator to the last node in the selected set.
MoveToNext | Moves to the next sibling of the current node.
MoveToNextAttribute | Moves to the next attribute.
MoveToNextSelected | Moves the XmlNavigator to the next node in the selected set.
MoveToParent | Moves to the parent of the current node.
MoveToPrevious | Moves to the previous sibling of the current node.
MoveToPreviousSelected | Moves the XmlNavigator to the previous node in the selected set.
PopPosition | Moves the XmlNavigator back to a previously pushed position and pops that saved position off the stack.
PushPosition | Saves the current position.
Remove | Overloaded. Removes the specified node(s).
RemoveSelected | Removes all the selected nodes.
Select | Selects a new set of "records" using the specified XPath expression.
SelectSingle | Selects the first node that matches the specified expression.
SetAttribute | Overloaded. Sets the value of the specified attribute.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlNavigator Class | System.NewXml Namespace


XmlNavigator Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public XmlNavigator();
[C++]
public: XmlNavigator();
[JScript]
public function XmlNavigator();

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlNavigator Properties

The properties of the XmlNavigator class are listed below. For a complete list of XmlNavigator class members, see the XmlNavigator Members topic.

Public:

AttributeCount | Gets the number of attributes on the current node.
ChildCount | Gets the number of child nodes for the current node.
HasAttributes | Gets a value indicating whether the current node has any attributes.
HasChildren | Gets a value indicating whether the current node has child nodes.
HasSelection | Determines if this XmlNavigator currently has a selection set.
HasValue | Gets a value indicating whether Value has a value to return.
IndexInParent | Gets the zero-based index of this node's position in its parent node.
InnerText | Gets or sets the concatenated values of the current node and all its children.
IsDefault | Gets a value indicating whether the current node is an attribute that was generated from the default value defined in the DTD or schema.
IsEmptyTag | Gets a value indicating whether the current node is an empty element (for example, <MyElement/>).
IsReadOnly | Gets a value indicating whether the current node is read-only.
LocalName | Gets the name of the node without the namespace prefix.
Name | Gets the name of the current node, including the namespace prefix.
NamespaceURI | Gets the namespace URN (as defined in the W3C Namespace Specification) of the current namespace scope.
NameTable | Gets the XmlNameTable associated with this implementation.
NodeType | Gets the type of the current node.
Prefix | Gets or sets the namespace prefix associated with the current node.
Selection | Gets the last XPath expression used in a successful call to the Select method.
Value | Gets or sets the text value of the current node.

See Also

XmlNavigator Class | System.NewXml Namespace


XmlNavigator.AttributeCount

Gets the number of attributes on the current node.

[Visual Basic]
MustOverride Public ReadOnly Property AttributeCount As Integer
[C#]
public int AttributeCount {abstract get;}
[C++]
public: __property virtual int get_AttributeCount() = 0;
[JScript]
public abstract function get AttributeCount() : int;

Property Value

Count of attributes on the current node.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.ChildCount

Gets the number of child nodes for the current node.

[Visual Basic]
MustOverride Public ReadOnly Property ChildCount As Integer
[C#]
public int ChildCount {abstract get;}
[C++]
public: __property virtual int get_ChildCount() = 0;
[JScript]
public abstract function get ChildCount() : int;

Property Value

The number of child nodes for the current node.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.HasAttributes

Gets a value indicating whether the current node has any attributes.

[Visual Basic]
MustOverride Public ReadOnly Property HasAttributes As Boolean
[C#]
public bool HasAttributes {abstract get;}
[C++]
public: __property virtual bool get_HasAttributes() = 0;
[JScript]
public abstract function get HasAttributes() : Boolean;

Property Value

true if the current node has attributes; otherwise, false.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.HasChildren

Gets a value indicating whether the current node has child nodes.

[Visual Basic]
MustOverride Public ReadOnly Property HasChildren As Boolean
[C#]
public bool HasChildren {abstract get;}
[C++]
public: __property virtual bool get_HasChildren() = 0;
[JScript]
public abstract function get HasChildren() : Boolean;

Property Value

true if the current node has child nodes; otherwise, false.

Remarks

This is potentially more efficient than using the ChildCount property.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.HasSelection

Determines if this XmlNavigator currently has a selection set.

[Visual Basic]
Overridable Public ReadOnly Property HasSelection As Boolean
[C#]
public bool HasSelection {virtual get;}
[C++]
public: __property virtual bool get_HasSelection();
[JScript]
public function get HasSelection() : Boolean;

Property Value

true if XmlNavigator has a selection set; false if there are no selected nodes.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.HasValue

Gets a value indicating whether Value has a value to return.

[Visual Basic]
MustOverride Public ReadOnly Property HasValue As Boolean
[C#]
public bool HasValue {abstract get;}
[C++]
public: __property virtual bool get_HasValue() = 0;
[JScript]
public abstract function get HasValue() : Boolean;

Property Value

true if Value has a value to return or if any more content can be returned from the partial content read methods; otherwise, false.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.IndexInParent

Gets the zero-based index of this node's position in its parent node.

[Visual Basic]
MustOverride Public ReadOnly Property IndexInParent As Integer
[C#]
public int IndexInParent {abstract get;}
[C++]
public: __property virtual int get_IndexInParent() = 0;
[JScript]
public abstract function get IndexInParent() : int;

Property Value

The index position of this node within its parent node.

Returns-1 if there is no parent node. You can, therefore, use this to find out whether there is a parent node for the current node.

Remarks

For attributes, this property returns the index in the list of attributes. For child elements, it returns the index in the list of child nodes. The following is always true (assuming the tree is not changed in the middle of the execution of this code):

[C#]

XmlNavigator other = this.Clone();
other.MoveToParent();
other.MoveToChild( this.IndexInParent );
Assert(other.IsSame(this) == true);

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.InnerText

Gets or sets the concatenated values of the current node and all its children.

[Visual Basic]
MustOverride Public Property InnerText As String
[C#]
public string InnerText {abstract get; abstract set;}
[C++]
public: __property virtual String* get_InnerText() = 0;public: __property virtual void set_InnerText(String*) = 0;
[JScript]
public abstract function get InnerText() : String;
public abstract function set InnerText(String);

Property Value

The concatenated values of the current node and all its children.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.IsDefault

Gets a value indicating whether the current node is an attribute that was generated from the default value defined in the DTD or schema.

[Visual Basic]
MustOverride Public ReadOnly Property IsDefault As Boolean
[C#]
public bool IsDefault {abstract get;}
[C++]
public: __property virtual bool get_IsDefault() = 0;
[JScript]
public abstract function get IsDefault() : Boolean;

Property Value

true if the the current node is an attribute whose value was generated from the default value defined in the DTD or schema.

false if the attribute's value was explicitly specified in the XML stream.

Remarks

This property applies only to an attribute node.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.IsEmptyTag

Gets a value indicating whether the current node is an empty element (for example, <MyElement/>).

[Visual Basic]
MustOverride Public Property IsEmptyTag As Boolean
[C#]
public bool IsEmptyTag {abstract get; abstract set;}
[C++]
public: __property virtual bool get_IsEmptyTag() = 0;public: __property virtual void set_IsEmptyTag(bool) = 0;
[JScript]
public abstract function get IsEmptyTag() : Boolean;
public abstract function set IsEmptyTag(Boolean);

Property Value

true if the current node is an element (NodeType equals Element) that ends with "/>"; otherwise, false.

Remarks

This property enables you to determine the difference between the following:

<foo bar="123"/> (IsEmptyTag is true).

<foo bar="123"> (IsEmptyTag is false)

Note that a corresponding EndTag element is not generated for empty elements.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.IsReadOnly

Gets a value indicating whether the current node is read-only.

[Visual Basic]
MustOverride Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {abstract get;}
[C++]
public: __property virtual bool get_IsReadOnly() = 0;
[JScript]
public abstract function get IsReadOnly() : Boolean;

Property Value

true if the the current node is read-only.

false if the node is read/write.

Remarks

A read-only node is one that you cannot change any of its properties, attributes, or children. But you can remove it from the tree and insert it somewhere else. For example, the node for an EntityReference is typically read-only because its children actually come from the DTD definition of that entity and typically the DTD is read-only.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.LocalName

Gets the name of the node without the namespace prefix.

[Visual Basic]
MustOverride Public ReadOnly Property LocalName As String
[C#]
public string LocalName {abstract get;}
[C++]
public: __property virtual String* get_LocalName() = 0;
[JScript]
public abstract function get LocalName() : String;

Property Value

The name of the node with the prefix removed. For example, LocalName is yyy for the element <xxx:yyy>.

The name returned is dependent on the NodeType of the node:

Type | Name
Attribute | name of attribute
CDATA | #cdata-section
Comment | #comment
Document | #document
DocumentFragment | #document-fragment
DocumentType | document type name
Element | tag name
Entity | entity name
EntityReference | name of entity referenced
Notation | notation name
ProcessingInstruction | target
Text | #text

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.Name

Gets the name of the current node, including the namespace prefix.

[Visual Basic]
MustOverride Public ReadOnly Property Name As String
[C#]
public string Name {abstract get;}
[C++]
public: __property virtual String* get_Name() = 0;
[JScript]
public abstract function get Name() : String;

Property Value

Name of the current node. The name returned depends on the NodeType of the current node.

XmlNodeType | Property Value
Attribute | Contains the name of the attribute.
CDATA | Contains the literal string "#cdata-section".
Comment | Contains the literal string "#comment".
Document | Contains the literal string "#document".
DocumentType | Contains the name of the document type; for example, xxx in <!DOCTYPE xxx ...>.
DocumentFragment | Contains the literal string "#document-fragment".
Element | Contains the name of the XML tag, with any namespace prefix included if present.
Entity | Contains the name of the entity.
EntityReference | Contains the name of the entity referenced. Note that the name does not include the leading ampersand or the trailing semicolon. The name includes the namespace if one is present.
Notation | Contains the name of the notation.
ProcessingInstruction | Contains the target; the first token following the <? characters.
Text | Contains the literal string "#text".

String.Empty is returned if current node/record has no value to return.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.NamespaceURI

Gets the namespace URN (as defined in the W3C Namespace Specification) of the current namespace scope.

[Visual Basic]
MustOverride Public ReadOnly Property NamespaceURI As String
[C#]
public string NamespaceURI {abstract get;}
[C++]
public: __property virtual String* get_NamespaceURI() = 0;
[JScript]
public abstract function get NamespaceURI() : String;

Property Value

The namespace URN of the current namespace scope.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.NameTable

Gets the XmlNameTable associated with this implementation.

[Visual Basic]
MustOverride Public ReadOnly Property NameTable As XmlNameTable
[C#]
public XmlNameTable NameTable {abstract get;}
[C++]
public: __property virtual XmlNameTable* get_NameTable() = 0;
[JScript]
public abstract function get NameTable() : XmlNameTable;

Property Value

XmlNameTable enabling you to get the atomized version of a string within the node.

Remarks

All node and attribute names returned from this class are atomized using this nametable. This means that when the same name is returned multiple times (like "Customer"), then the same String object will be returned for that name. This makes it possible for you to write efficient code that does object pointer comparisons on these strings instead of expensive string comparisons.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.NodeType

Gets the type of the current node.

[Visual Basic]
MustOverride Public ReadOnly Property NodeType As XmlNodeType
[C#]
public XmlNodeType NodeType {abstract get;}
[C++]
public: __property virtual XmlNodeType get_NodeType() = 0;
[JScript]
public abstract function get NodeType() : XmlNodeType;

Property Value

One of the XmlNodeType values.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.Prefix

Gets or sets the namespace prefix associated with the current node.

[Visual Basic]
MustOverride Public Property Prefix As String
[C#]
public string Prefix {abstract get; abstract set;}
[C++]
public: __property virtual String* get_Prefix() = 0;public: __property virtual void set_Prefix(String*) = 0;
[JScript]
public abstract function get Prefix() : String;
public abstract function set Prefix(String);

Property Value

The namespace prefix associated with the current node.

String.Empty if current node/record has no value to return (never returns null).

Remarks

Setting this prefix has the same semantics as the W3C DOM.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.Selection

Gets the last XPath expression used in a successful call to the Select method.

[Visual Basic]
Overridable Public ReadOnly Property Selection As String
[C#]
public string Selection {virtual get;}
[C++]
public: __property virtual String* get_Selection();
[JScript]
public function get Selection() : String;

Property Value

An XPath expression.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.Value

Gets or sets the text value of the current node.

[Visual Basic]
MustOverride Public Property Value As String
[C#]
public string Value {abstract get; abstract set;}
[C++]
public: __property virtual String* get_Value() = 0;public: __property virtual void set_Value(String*) = 0;
[JScript]
public abstract function get Value() : String;
public abstract function set Value(String);

Property Value

The text value of the current node.

Same semantics as W3C DOM NodeValue property. Returns null for Element and Document nodes.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlNavigator Methods

The methods of the XmlNavigator class are listed below. For a complete list of XmlNavigator class members, see the XmlNavigator Members topic.

Public:

Clone | Creates a new XmlNavigator positioned at the same node as this XmlNavigator.
Compile | Compiles the given XPath expression and returns an object representing that expression.
CopyChildren | Copies all the children from current position of the specified XmlNavigator and inserts them at the specified position in this XmlNavigator.
CopySelected | Copies all the selected nodes from the specified XmlNavigator (as returned by MoveToNextSelected) and inserts them at the specified position in this tree.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Evaluate | Evaluates the given expression and returns the typed result (int, boolean or string).
GetAttribute | Overloaded. Gets the value of an attribute.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
HasAttribute | Overloaded. Determines whether the current node has the specified attribute.
Insert | Overloaded. Inserts node(s) at the specified position.
IsSamePosition | Determines whether this XmlNavigator is at the same position as the specified XmlNavigator.
LookupPrefix | Looks up the prefix for the given namespace URI as defined higher up in the tree.
Matches | Determines whether the current node matches the specified XPath expression
Move | Moves the entire subtree point to in the specified XmlNavigator to the specified position in this XmlNavigator.
MoveChildren | Moves all the children from current position of the specified XmlNavigator and inserts them at the specified position in this XmlNavigator.
MoveSelected | Moves all the selected nodes from the specified XmlNavigator (as returned by MoveToNextSelected) and inserts them at the specified position in this XmlNavigato. This navagitor's position is unaffected by this operation.
MoveTo | Moves to the same position as the specified XmlNavigator.
MoveToAttribute Overloaded. Move to the specified attribute.

The MoveToAttribute methods enable you to get both random access to attributes and strongly typed access to attribute values.

To get strongly typed access to an attribute value, you must do the following:

  1. Call MoveToAttribute to move to the attribute whose value you want to access.
  2. Call Read method for the data type you want (for example, ReadBoolean for boolean, ReadDate for DateTime, and so on).

After calling MoveToAttribute, the Name, Namespace, Prefix properties will reflect the properties of that attribute.
MoveToChild | Moves to the specified child node of the current node (index 0 is the first child).
MoveToDocument | Moves to the document node that owns this node.
MoveToDocumentElement | Moves to the child element node of the owning document.
MoveToElement | Moves to the element that contains the current attribute node.
MoveToFirst | Moves to the first sibling of the current node.
MoveToFirstAttribute | Moves to the first attribute.
MoveToFirstChild | Moves to the first child of the current node.
MoveToFirstSelected | Moves the XmlNavigator to the first node in the selected set.
MoveToId | Moves to the node with an ID attribute whose value matches the specified string.
MoveToLast | Moves to the last sibling of the current node.
MoveToLastChild | Moves to the last child of the current node.
MoveToLastSelected | Moves the XmlNavigator to the last node in the selected set.
MoveToNext | Moves to the next sibling of the current node.
MoveToNextAttribute | Moves to the next attribute.
MoveToNextSelected | Moves the XmlNavigator to the next node in the selected set.
MoveToParent | Moves to the parent of the current node.
MoveToPrevious | Moves to the previous sibling of the current node.
MoveToPreviousSelected | Moves the XmlNavigator to the previous node in the selected set.
PopPosition | Moves the XmlNavigator back to a previously pushed position and pops that saved position off the stack.
PushPosition | Saves the current position.
Remove | Overloaded. Removes the specified node(s).
RemoveSelected | Removes all the selected nodes.
Select | Selects a new set of "records" using the specified XPath expression.
SelectSingle | Selects the first node that matches the specified expression.
SetAttribute | Overloaded. Sets the value of the specified attribute.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlNavigator Class | System.NewXml Namespace


XmlNavigator.Clone

Creates a new XmlNavigator positioned at the same node as this XmlNavigator.

[Visual Basic]
MustOverride Public Function Clone() As XmlNavigator
[C#]
public abstract XmlNavigator Clone();
[C++]
public: virtual XmlNavigator* Clone() = 0;
[JScript]
public abstract function Clone() : XmlNavigator;

Return Value

A new XmlNavigator object.

Remarks

The new XmlNavigator that is returned is not affected by subsequent changes to the current XmlNavigator.

The Clone method does not clone all the selection and push/pop states. The cloned XmlNavigator has the same "liveness" behavior as this XmlNavigator.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.Compile

Compiles the given XPath expression and returns an object representing that expression.

[Visual Basic]
Overridable Public Function Compile( _
   ByVal xpathexpr As String _
) As Object
[C#]
public virtual object Compile(
   string xpathexpr
);
[C++]
public: virtual Object* Compile(
   String* xpathexpr
);
[JScript]
public function Compile(
   xpathexpr : String
) : Object;

Parameters

xpathexpr
The expression to compile.

Return Value

The XPath expression as an object.

Exceptions

Exception Type | Condition
ArgumentException | The xpathexpr param contains an invalid XPath expression.

Remarks

An XPath expression is evaluated to yield one of the following return types:

  • node-set (an unordered collection of nodes without duplicates)
  • boolean (true or false)
  • number (a floating-point number)
  • string (a sequence of UCS characters)

The expressions that return a node-set can be used in the Select methods. The expressions that return a boolean, number, or string can be used in Evaluate. The rules on valid expressions for the Matches method are specific to that method.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.CopyChildren

Copies all the children from current position of the specified XmlNavigator and inserts them at the specified position in this XmlNavigator.

[Visual Basic]
MustOverride Public Sub CopyChildren( _
   ByVal p As TreePosition, _
   ByVal other As XmlNavigator _
)
[C#]
public abstract void CopyChildren(
   TreePosition p,
   XmlNavigator other
);
[C++]
public: virtual void CopyChildren(
   TreePosition p,
   XmlNavigator* other
) = 0;
[JScript]
public abstract function CopyChildren(
   p : TreePosition,
   other : XmlNavigator
);

Parameters

p
The specified position where the new nodes be copied. The position None does a Replace operation.
other
The source of the new nodes.

Exceptions

Exception Type | Condition
InvalidArgument | The child nodes in other specify nodes with an XmlNodeType that can not be inserted at position p.

Remarks

This XmlNavigator's position is unaffected by this operation.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.CopySelected

Copies all the selected nodes from the specified XmlNavigator (as returned by MoveToNextSelected) and inserts them at the specified position in this tree.

[Visual Basic]
MustOverride Public Sub CopySelected( _
   ByVal p As TreePosition, _
   ByVal other As XmlNavigator _
)
[C#]
public abstract void CopySelected(
   TreePosition p,
   XmlNavigator other
);
[C++]
public: virtual void CopySelected(
   TreePosition p,
   XmlNavigator* other
) = 0;
[JScript]
public abstract function CopySelected(
   p : TreePosition,
   other : XmlNavigator
);

Parameters

p
The specified position where the new nodes will be copied. The position None does a Replace operation.
other
The source of the new nodes.

Exceptions

Exception Type | Condition
InvalidArgument | The child nodes in other specify nodes with an XmlNodeType that can not be inserted at position p.

Remarks

This XmlNavigator's position is unaffected by this operation.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.Evaluate

Evaluates the given expression and returns the typed result (int, boolean or string).

[Visual Basic]
Overridable Public Function Evaluate( _
   ByVal xpathexpr As Object _
) As Object
[C#]
public virtual object Evaluate(
   object xpathexpr
);
[C++]
public: virtual Object* Evaluate(
   Object* xpathexpr
);
[JScript]
public function Evaluate(
   xpathexpr : Object
) : Object;

Parameters

xpathexpr
An expression describing how to navigate. This can be a string or an object returned from the Compile method.

Return Value

The result of the expression.

Exceptions

Exception Type | Condition
ArgumentException | The return type of the given expression is a node set.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.GetAttribute

Gets the value of an attribute.

Overload List

Gets the value of the attribute with the specified name and namespace.

[Visual Basic] Overloads MustOverride Public Function GetAttribute(String, String) As String
[C#] public abstract string GetAttribute(String, String);
[C++] public: virtual String* GetAttribute(String*, String*) = 0;
[JScript] public abstract function GetAttribute(String, String) : String;

Gets the value of the attribute with the specified index.

[Visual Basic] Overloads MustOverride Public Function GetAttribute(Integer) As String
[C#] public abstract string GetAttribute(int);
[C++] public: virtual String* GetAttribute(int) = 0;
[JScript] public abstract function GetAttribute(int) : String;

Gets the value of the attribute with the specified name.

[Visual Basic] Overloads MustOverride Public Function GetAttribute(String) As String
[C#] public abstract string GetAttribute(String);
[C++] public: virtual String* GetAttribute(String*) = 0;
[JScript] public abstract function GetAttribute(String) : String;

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.GetAttribute (String, String)

Gets the value of the attribute with the specified name and namespace.

[Visual Basic]
Overloads MustOverride Public Function GetAttribute( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As String
[C#]
public abstract string GetAttribute(
   string localName,
   string namespaceURI
);
[C++]
public: virtual String* GetAttribute(
   String* localName,
   String* namespaceURI
) = 0;
[JScript]
public abstract function GetAttribute(
   localName : String,
   namespaceURI : String
) : String;

Parameters

localName
The name of the attribute.
namespaceURI
The URN of the namespace of the attribute.

Return Value

The value of the specified attribute.

Exceptions

Exception Type | Condition
ArgumentException | The attribute specified by localName and namespaceURI properties cannot be found in the current node.

Remarks

The following XML contains an attribute in a specific namespace:

<test xmlns:dt="urn:datatypes" dt:type="int"/>

You can lookup the dt:type attribute using one argument (using Prefix+LocalName) or using two arguments (LocalName and NamespaceURI):

String dt = reader.GetAttribute("dt:type");

String dt2 = reader.GetAttribute("type","urn:datatypes");

Note that the xmlns attributes have no namespace URI; therefore, the only way to look them up is with the short version

String dt3 = reader.GetAttribute("xmlns:dt");

You can also get this information using the Prefix property.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace | XmlNavigator.GetAttribute Overload List


XmlNavigator.GetAttribute (Int32)

Gets the value of the attribute with the specified index.

[Visual Basic]
Overloads MustOverride Public Function GetAttribute( _
   ByVal i As Integer _
) As String
[C#]
public abstract string GetAttribute(
   int i
);
[C++]
public: virtual String* GetAttribute(
   int i
) = 0;
[JScript]
public abstract function GetAttribute(
   i : int
) : String;

Parameters

i
The index of the attribute. The index is zero-based (first attribute has index 0).

Return Value

The value of the specified attribute.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | The i parameter is less than 0 or greater than or equal to AttributeCount.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace | XmlNavigator.GetAttribute Overload List


XmlNavigator.GetAttribute (String)

Gets the value of the attribute with the specified name.

[Visual Basic]
Overloads MustOverride Public Function GetAttribute( _
   ByVal name As String _
) As String
[C#]
public abstract string GetAttribute(
   string name
);
[C++]
public: virtual String* GetAttribute(
   String* name
) = 0;
[JScript]
public abstract function GetAttribute(
   name : String
) : String;

Parameters

name
The name of the attribute. The name can include the prefix or leave it off.

Return Value

Empty string if currentnode/recordhas no value to return (never returns null).

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace | XmlNavigator.GetAttribute Overload List


XmlNavigator.HasAttribute

Determines whether the current node has the specified attribute.

Overload List

Determines whether the current node has the specified attribute from the specified namespace.

[Visual Basic] Overloads MustOverride Public Function HasAttribute(String, String) As Boolean
[C#] public abstract bool HasAttribute(String, String);
[C++] public: virtual bool HasAttribute(String*, String*) = 0;
[JScript] public abstract function HasAttribute(String, String) : Boolean;

Determines whether the current node has the specified attribute.

[Visual Basic] Overloads MustOverride Public Function HasAttribute(String) As Boolean
[C#] public abstract bool HasAttribute(String);
[C++] public: virtual bool HasAttribute(String*) = 0;
[JScript] public abstract function HasAttribute(String) : Boolean;

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.HasAttribute (String, String)

Determines whether the current node has the specified attribute from the specified namespace.

[Visual Basic]
Overloads MustOverride Public Function HasAttribute( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Boolean
[C#]
public abstract bool HasAttribute(
   string localName,
   string namespaceURI
);
[C++]
public: virtual bool HasAttribute(
   String* localName,
   String* namespaceURI
) = 0;
[JScript]
public abstract function HasAttribute(
   localName : String,
   namespaceURI : String
) : Boolean;

Parameters

localName
[To be supplied.]
namespaceURI
The name of the namespace of the attribute to find.

Return Value

true if the current node has the specified attribute; otherwise, false.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace | XmlNavigator.HasAttribute Overload List


XmlNavigator.HasAttribute (String)

Determines whether the current node has the specified attribute.

[Visual Basic]
Overloads MustOverride Public Function HasAttribute( _
   ByVal name As String _
) As Boolean
[C#]
public abstract bool HasAttribute(
   string name
);
[C++]
public: virtual bool HasAttribute(
   String* name
) = 0;
[JScript]
public abstract function HasAttribute(
   name : String
) : Boolean;

Parameters

name
The name of the attribute to find.

Return Value

true if the current node has the specified attribute; otherwise, false.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace | XmlNavigator.HasAttribute Overload List


XmlNavigator.Insert

Inserts node(s) at the specified position.

Overload List

Inserts a copy of the node or nodes represented by "obj" into the specified position in this tree relative to the current position and moves the navigator to point at the root of the newly inserted nodes.

[Visual Basic] Overloads MustOverride Public Sub Insert(TreePosition, Object, Type)
[C#] public abstract void Insert(TreePosition, Object, Type);
[C++] public: virtual void Insert(TreePosition, Object, Type) = 0;
[JScript] public abstract function Insert(TreePosition, Object, Type);

Creates a new node and inserts it at the specified position in the tree relative to the current position and moves the navigator to point at this newly inserted node.

[Visual Basic] Overloads MustOverride Public Sub Insert(TreePosition, XmlNodeType, String, String, String)
[C#] public abstract void Insert(TreePosition, XmlNodeType, String, String, String);
[C++] public: virtual void Insert(TreePosition, XmlNodeType, String, String, String) = 0;
[JScript] public abstract function Insert(TreePosition, XmlNodeType, String, String, String);

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.Insert (TreePosition, Object, Type)

Inserts a copy of the node or nodes represented by "obj" into the specified position in this tree relative to the current position and moves the navigator to point at the root of the newly inserted nodes.

[Visual Basic]
Overloads MustOverride Public Sub Insert( _
   ByVal p As TreePosition, _
   ByVal obj As Object, _
   ByVal type As Type _
)
[C#]
public abstract void Insert(
   TreePosition p,
   object obj,
   Type type
);
[C++]
public: virtual void Insert(
   TreePosition p,
   Object* obj,
   Type* type
) = 0;
[JScript]
public abstract function Insert(
   p : TreePosition,
   obj : Object,
   type : Type
);

Parameters

p
The relative position of the new node. The position "None" means the new node is not inserted into the tree- but instead is left dangling with no parent. This is the only valid way to create DocumentFragment nodes.
obj
[To be supplied.]
type
The type of object. Optional. This parameter is only used to specify which interface to use if the object implements multiple interfaces. If type is null, the "instanceof" operator is used to determine the type.

A type of XmlNavigator copies the entire subtree pointed at by the other XmlNavigator object. The other XmlNavigator will not be moved.

Exceptions

Exception Type | Condition
ArgumentException | The object specifies a node with an XmlNodeType that can not be inserted at position p. For example, if the position specified is "Parent" then the NodeType of the new node cannot be Attribute, CDATA or Text or Comment. The specified XmlNodeType requires a name and no name was provided. The type argument is not one of the above.

Remarks

Inserting a subtree into the Parent position results in the current node becoming the first child of the new parent.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace | XmlNavigator.Insert Overload List


XmlNavigator.Insert (TreePosition, XmlNodeType, String, String, String)

Creates a new node and inserts it at the specified position in the tree relative to the current position and moves the navigator to point at this newly inserted node.

[Visual Basic]
Overloads MustOverride Public Sub Insert( _
   ByVal p As TreePosition, _
   ByVal nt As XmlNodeType, _
   ByVal localName As String, _
   ByVal namespaceURI As String, _
   ByVal prefix As String _
)
[C#]
public abstract void Insert(
   TreePosition p,
   XmlNodeType nt,
   string localName,
   string namespaceURI,
   string prefix
);
[C++]
public: virtual void Insert(
   TreePosition p,
   XmlNodeType nt,
   String* localName,
   String* namespaceURI,
   String* prefix
) = 0;
[JScript]
public abstract function Insert(
   p : TreePosition,
   nt : XmlNodeType,
   localName : String,
   namespaceURI : String,
   prefix : String
);

Parameters

p
The relative position of the new node. The position "None" means the new node is not inserted into the tree- but instead is left dangling with no parent. This is the only valid way to create DocumentFragment nodes.
nt
[To be supplied.]
localName
The local name of the new node (if any). For nodes that have no name, this is null.
namespaceURI
The namespace URI for the new node (if any). For nodes that have no name, this is null or empty. Null and String.Empty mean the same thing.
prefix
The namespace prefix of the new node (if any). For nodes that have no name, this is null. You can use the LookupPrefix method to find out what the prefix is for a given namespace URI. The XmlNavigator does not do this automatically for performance reasons. Null and String.Empty mean the same thing.

Exceptions

Exception Type | Condition
ArgumentException | The nt parameter specifies an XmlNodeType that can not be inserted at position p. For example, if the position specified is "Parent" then the NodeType of the new node cannot be Attribute, CDATA or Text or Comment. The specified XmlNodeType requires a name and no name was provided. The XmlNodeType has no Name and a name, namespaceURI, or prefix was provided.

Remarks

TBD--Add NodeType table here.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace | XmlNavigator.Insert Overload List


XmlNavigator.IsSamePosition

Determines whether this XmlNavigator is at the same position as the specified XmlNavigator.

[Visual Basic]
MustOverride Public Function IsSamePosition( _
   ByVal other As XmlNavigator _
) As Boolean
[C#]
public abstract bool IsSamePosition(
   XmlNavigator other
);
[C++]
public: virtual bool IsSamePosition(
   XmlNavigator* other
) = 0;
[JScript]
public abstract function IsSamePosition(
   other : XmlNavigator
) : Boolean;

Parameters

other
XmlNavigator with which you want to compare position.

Return Value

true if this XmlNavigator is at the same position as the specified XmlNavigator; otherwise, false.

Remarks

This also implies the other XmlNavigator is the same kind of XmlNavigator pointing at the same document instance.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.LookupPrefix

Looks up the prefix for the given namespace URI as defined higher up in the tree.

[Visual Basic]
MustOverride Public Function LookupPrefix( _
   ByVal namespaceURI As String _
) As String
[C#]
public abstract string LookupPrefix(
   string namespaceURI
);
[C++]
public: virtual String* LookupPrefix(
   String* namespaceURI
) = 0;
[JScript]
public abstract function LookupPrefix(
   namespaceURI : String
) : String;

Parameters

namespaceURI
[To be supplied.]

Return Value

The prefix atomized string. Or a null reference (in Visual Basic Nothing) if not found.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.Matches

Determines whether the current node matches the specified XPath expression

[Visual Basic]
Overridable Public Function Matches( _
   ByVal xpathexpr As Object _
) As Boolean
[C#]
public virtual bool Matches(
   object xpathexpr
);
[C++]
public: virtual bool Matches(
   Object* xpathexpr
);
[JScript]
public function Matches(
   xpathexpr : Object
) : Boolean;

Parameters

xpathexpr
An XPath expression describing how to navigate. This can be a string or an object returned from the Compile method.

Return Value

true if the current node matches the specified XPath expression; otherwise, false.

The following example will return true if the parent of the current node has an attribute called "color" with the value "red".

[C#]

nav.Matches("..[attribute::color = 'red']")

Exceptions

Exception Type | Condition
ArgumentException | The specified expression cannot be evaluated this way.

Remarks

This has no effect on the state of the tree or the current selection.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.Move

Moves the entire subtree point to in the specified XmlNavigator to the specified position in this XmlNavigator.

[Visual Basic]
MustOverride Public Sub Move( _
   ByVal p As TreePosition, _
   ByVal other As XmlNavigator _
)
[C#]
public abstract void Move(
   TreePosition p,
   XmlNavigator other
);
[C++]
public: virtual void Move(
   TreePosition p,
   XmlNavigator* other
) = 0;
[JScript]
public abstract function Move(
   p : TreePosition,
   other : XmlNavigator
);

Parameters

p
The specified position where the new nodes will be moved. The position None does a Replace operation.
other
XmlNavigator containing the source of the new nodes.

Exceptions

Exception Type | Condition
ArgumentException | The other XmlNavigator is pointing at read/only nodes (like the children of an entity reference). It can point to an entity reference and thereby move the entire entity reference- but it cannot point at the children of an entity reference.

Remarks

This XmlNavigator's position is unaffected by this operation.

The other XmlNavigator remains pointing at the same node. This means it is essentially moved over to this tree in the process.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.MoveChildren

Moves all the children from current position of the specified XmlNavigator and inserts them at the specified position in this XmlNavigator.

[Visual Basic]
MustOverride Public Sub MoveChildren( _
   ByVal p As TreePosition, _
   ByVal other As XmlNavigator _
)
[C#]
public abstract void MoveChildren(
   TreePosition p,
   XmlNavigator other
);
[C++]
public: virtual void MoveChildren(
   TreePosition p,
   XmlNavigator* other
) = 0;
[JScript]
public abstract function MoveChildren(
   p : TreePosition,
   other : XmlNavigator
);

Parameters

p
The specified position where the new nodes will be copied. The position None does a Replace operation.
other
The source of the new nodes.

Exceptions

Exception Type | Condition
ArgumentException | The other XmlNavigator is pointing at read/only nodes (like the children of an entity reference). It can point to an entity reference and thereby move the entire entity reference- but it cannot point at the children of an entity reference.

Remarks

This XmlNavigator's position is unaffected by this operation.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.MoveSelected

Moves all the selected nodes from the specified XmlNavigator (as returned by MoveToNextSelected) and inserts them at the specified position in this XmlNavigato. This navagitor's position is unaffected by this operation.

[Visual Basic]
MustOverride Public Sub MoveSelected( _
   ByVal p As TreePosition, _
   ByVal other As XmlNavigator _
)
[C#]
public abstract void MoveSelected(
   TreePosition p,
   XmlNavigator other
);
[C++]
public: virtual void MoveSelected(
   TreePosition p,
   XmlNavigator* other
) = 0;
[JScript]
public abstract function MoveSelected(
   p : TreePosition,
   other : XmlNavigator
);

Parameters

p
The specified position where the new nodes will end up. The position None does a Replace operation.
other
The source of the new nodes.

Exceptions

Exception Type | Condition
ArgumentException | The other XmlNavigator is pointing at read/only nodes (like the children of an entity reference). It can point to an entity reference and thereby move the entire entity reference- but it cannot point at the children of an entity reference.

Remarks

This XmlNavigator's position is unaffected by this operation.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.MoveTo

Moves to the same position as the specified XmlNavigator.

[Visual Basic]
MustOverride Public Function MoveTo( _
   ByVal other As XmlNavigator _
) As Boolean
[C#]
public abstract bool MoveTo(
   XmlNavigator other
);
[C++]
public: virtual bool MoveTo(
   XmlNavigator* other
) = 0;
[JScript]
public abstract function MoveTo(
   other : XmlNavigator
) : Boolean;

Parameters

other
XmlNavigator with the position you want to move this XmlNavigator to.

Return Value

Throws an exception if the two XmlNavigator objects are incompatible.

Remarks

The XmlNavigator is in the 'null' state when it temporarily points to no node. You can get out of this state by using MoveTo(XmlNavigator) or MoveToDocument. You can find out that you are in the Null state because NodeType returns 0.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.MoveToAttribute

Move to the specified attribute.

The MoveToAttribute methods enable you to get both random access to attributes and strongly typed access to attribute values.

To get strongly typed access to an attribute value, you must do the following:

  1. Call MoveToAttribute to move to the attribute whose value you want to access.
  2. Call Read method for the data type you want (for example, ReadBoolean for boolean, ReadDate for DateTime, and so on).

After calling MoveToAttribute, the Name, Namespace, Prefix properties will reflect the properties of that attribute.

Overload List

Moves to the attribute with the specified name.

[Visual Basic] Overloads MustOverride Public Function MoveToAttribute(String) As Boolean
[C#] public abstract bool MoveToAttribute(String);
[C++] public: virtual bool MoveToAttribute(String*) = 0;
[JScript] public abstract function MoveToAttribute(String) : Boolean;

Moves to the attribute with the specified index.

[Visual Basic] Overloads MustOverride Public Function MoveToAttribute(Integer) As Boolean
[C#] public abstract bool MoveToAttribute(int);
[C++] public: virtual bool MoveToAttribute(int) = 0;
[JScript] public abstract function MoveToAttribute(int) : Boolean;

Move to the attribute with matching name and namespace.

[Visual Basic] Overloads MustOverride Public Function MoveToAttribute(String, String) As Boolean
[C#] public abstract bool MoveToAttribute(String, String);
[C++] public: virtual bool MoveToAttribute(String*, String*) = 0;
[JScript] public abstract function MoveToAttribute(String, String) : Boolean;

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.MoveToAttribute (String)

Moves to the attribute with the specified name.

[Visual Basic]
Overloads MustOverride Public Function MoveToAttribute( _
   ByVal name As String _
) As Boolean
[C#]
public abstract bool MoveToAttribute(
   string name
);
[C++]
public: virtual bool MoveToAttribute(
   String* name
) = 0;
[JScript]
public abstract function MoveToAttribute(
   name : String
) : Boolean;

Parameters

name
The name of the attribute. The name can include the prefix or leave it off.

Return Value

true if the attribute is found; otherwise, false. If false, the XmlNavigator's position does not change.

Exceptions

Exception Type | Condition
ArgumentException | The attribute specified by name cannot be found in the current node.

Remarks

If you are positioned on an attribute, this method will do an implicit MoveToElement before processing this method.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace | XmlNavigator.MoveToAttribute Overload List


XmlNavigator.MoveToAttribute (Int32)

Moves to the attribute with the specified index.

[Visual Basic]
Overloads MustOverride Public Function MoveToAttribute( _
   ByVal i As Integer _
) As Boolean
[C#]
public abstract bool MoveToAttribute(
   int i
);
[C++]
public: virtual bool MoveToAttribute(
   int i
) = 0;
[JScript]
public abstract function MoveToAttribute(
   i : int
) : Boolean;

Parameters

i
The index of the attribute.

Return Value

true if the attribute is found; otherwise, false. If false, the reader's position does not change.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | The i parameter is less than 0 or greater than AttributeCount.

Remarks

If you are positioned on an attribute, this method will do an implicit MoveToElement before processing this method.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace | XmlNavigator.MoveToAttribute Overload List


XmlNavigator.MoveToAttribute (String, String)

Move to the attribute with matching name and namespace.

[Visual Basic]
Overloads MustOverride Public Function MoveToAttribute( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Boolean
[C#]
public abstract bool MoveToAttribute(
   string localName,
   string namespaceURI
);
[C++]
public: virtual bool MoveToAttribute(
   String* localName,
   String* namespaceURI
) = 0;
[JScript]
public abstract function MoveToAttribute(
   localName : String,
   namespaceURI : String
) : Boolean;

Parameters

localName
[To be supplied.]
namespaceURI
[To be supplied.]

Return Value

true if the attribute is found; otherwise, false. If false, the XmlNavigator's position does not change.

Remarks

If you are positioned on an attribute, this method will do an implicit MoveToElement before processing this method.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace | XmlNavigator.MoveToAttribute Overload List


XmlNavigator.MoveToChild

Moves to the specified child node of the current node (index 0 is the first child).

[Visual Basic]
MustOverride Public Function MoveToChild( _
   ByVal i As Integer _
) As Boolean
[C#]
public abstract bool MoveToChild(
   int i
);
[C++]
public: virtual bool MoveToChild(
   int i
) = 0;
[JScript]
public abstract function MoveToChild(
   i : int
) : Boolean;

Parameters

i
The index of the child node.

Return Value

true if the specified child node exists; false if the specified child node does not exist.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.MoveToDocument

Moves to the document node that owns this node.

[Visual Basic]
MustOverride Public Sub MoveToDocument()
[C#]
public abstract void MoveToDocument();
[C++]
public: virtual void MoveToDocument() = 0;
[JScript]
public abstract function MoveToDocument();

Remarks

All nodes belong to one and only one document; therefore, this method is guaranteed to succeed.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.MoveToDocumentElement

Moves to the child element node of the owning document.

[Visual Basic]
MustOverride Public Function MoveToDocumentElement() As Boolean
[C#]
public abstract bool MoveToDocumentElement();
[C++]
public: virtual bool MoveToDocumentElement() = 0;
[JScript]
public abstract function MoveToDocumentElement() : Boolean;

Return Value

true if the document that owns this node currently has a child element node.

false if the document that owns this node currently has no child element node.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.MoveToElement

Moves to the element that contains the current attribute node.

[Visual Basic]
MustOverride Public Function MoveToElement() As Boolean
[C#]
public abstract bool MoveToElement();
[C++]
public: virtual bool MoveToElement() = 0;
[JScript]
public abstract function MoveToElement() : Boolean;

Return Value

true if the attribute is owned by an element; false if the attribute you are positioned on has been removed from the owning element.

Exceptions

Exception Type | Condition
InvalidOperationException | The reader is not positioned on an attribute node.

Remarks

Use this method to return to an element after navigating through its attributes.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.MoveToFirst

Moves to the first sibling of the current node.

[Visual Basic]
MustOverride Public Function MoveToFirst() As Boolean
[C#]
public abstract bool MoveToFirst();
[C++]
public: virtual bool MoveToFirst() = 0;
[JScript]
public abstract function MoveToFirst() : Boolean;

Return Value

true if there is a first sibling node; false if there is no first sibling.

Remarks

If you are positioned on an attribute, this method will do an implicit call to MoveToElement before processing this method. In other words, attribute navigation is orthogonal to tree navigation.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.MoveToFirstAttribute

Moves to the first attribute.

[Visual Basic]
MustOverride Public Function MoveToFirstAttribute() As Boolean
[C#]
public abstract bool MoveToFirstAttribute();
[C++]
public: virtual bool MoveToFirstAttribute() = 0;
[JScript]
public abstract function MoveToFirstAttribute() : Boolean;

Return Value

true if the first attribute exists; otherwise, false.

Remarks

If you are positioned on an attribute, this method will do an implicit MoveToElement before processing this method.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.MoveToFirstChild

Moves to the first child of the current node.

[Visual Basic]
MustOverride Public Function MoveToFirstChild() As Boolean
[C#]
public abstract bool MoveToFirstChild();
[C++]
public: virtual bool MoveToFirstChild() = 0;
[JScript]
public abstract function MoveToFirstChild() : Boolean;

Return Value

true if there is a first child node; false if there are no child nodes.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.MoveToFirstSelected

Moves the XmlNavigator to the first node in the selected set.

[Visual Basic]
Overridable Public Function MoveToFirstSelected() As Boolean
[C#]
public virtual bool MoveToFirstSelected();
[C++]
public: virtual bool MoveToFirstSelected();
[JScript]
public function MoveToFirstSelected() : Boolean;

Return Value

true if XmlNavigator moved to specified node; false if there are no selected nodes.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.MoveToId

Moves to the node with an ID attribute whose value matches the specified string.

[Visual Basic]
MustOverride Public Function MoveToId( _
   ByVal id As String _
) As Boolean
[C#]
public abstract bool MoveToId(
   string id
);
[C++]
public: virtual bool MoveToId(
   String* id
) = 0;
[JScript]
public abstract function MoveToId(
   id : String
) : Boolean;

Parameters

id
The ID value of the node you want to move to.

Return Value

Throws IdNotFoundException if the id was not defined in the data.

Remarks

The argument does not need to be atomized. For example, suppose the DTD defined the following:

<!ATTLIST x a ID #REQUIRED >

and suppose the following XML data was loaded using this DTD:

<data> <x a="a1"/> </data>

then the following would be true:

[C#]

// "nav" pointing anywhere in the above data.
nav.MoveToId("a1");
// Now "nav" points to the element node named "x"

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.MoveToLast

Moves to the last sibling of the current node.

[Visual Basic]
MustOverride Public Function MoveToLast() As Boolean
[C#]
public abstract bool MoveToLast();
[C++]
public: virtual bool MoveToLast() = 0;
[JScript]
public abstract function MoveToLast() : Boolean;

Return Value

true if there is a last sibling node; false if there is no last sibling.

Remarks

If you are positioned on an attribute, this method will do an implicit call to MoveToElement before processing this method. In other words, attribute navigation is orthogonal to tree navigation.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.MoveToLastChild

Moves to the last child of the current node.

[Visual Basic]
MustOverride Public Function MoveToLastChild() As Boolean
[C#]
public abstract bool MoveToLastChild();
[C++]
public: virtual bool MoveToLastChild() = 0;
[JScript]
public abstract function MoveToLastChild() : Boolean;

Return Value

true if there is a last child node; false if there are no child nodes.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.MoveToLastSelected

Moves the XmlNavigator to the last node in the selected set.

[Visual Basic]
Overridable Public Function MoveToLastSelected() As Boolean
[C#]
public virtual bool MoveToLastSelected();
[C++]
public: virtual bool MoveToLastSelected();
[JScript]
public function MoveToLastSelected() : Boolean;

Return Value

true if XmlNavigator moved to specified node; false if there are no selected nodes.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.MoveToNext

Moves to the next sibling of the current node.

[Visual Basic]
MustOverride Public Function MoveToNext() As Boolean
[C#]
public abstract bool MoveToNext();
[C++]
public: virtual bool MoveToNext() = 0;
[JScript]
public abstract function MoveToNext() : Boolean;

Return Value

true if there is a next sibling node; false if there are no more siblings.

Remarks

If you are positioned on an attribute, this method will do an implicit call to MoveToElement before processing this method. In other words, attribute navigation is orthogonal to tree navigation.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.MoveToNextAttribute

Moves to the next attribute.

[Visual Basic]
MustOverride Public Function MoveToNextAttribute() As Boolean
[C#]
public abstract bool MoveToNextAttribute();
[C++]
public: virtual bool MoveToNextAttribute() = 0;
[JScript]
public abstract function MoveToNextAttribute() : Boolean;

Return Value

true if there is a next attribute; false if there are no more attributes.

Remarks

If the current node is an element node, this method is equivalent to MoveToFirstAttribute.

If you are positioned on an attribute, this method will do an implicit MoveToElement before processing this method.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.MoveToNextSelected

Moves the XmlNavigator to the next node in the selected set.

[Visual Basic]
Overridable Public Function MoveToNextSelected() As Boolean
[C#]
public virtual bool MoveToNextSelected();
[C++]
public: virtual bool MoveToNextSelected();
[JScript]
public function MoveToNextSelected() : Boolean;

Return Value

true if XmlNavigator moved to specified node; false if there are no more selected nodes.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.MoveToParent

Moves to the parent of the current node.

[Visual Basic]
MustOverride Public Function MoveToParent() As Boolean
[C#]
public abstract bool MoveToParent();
[C++]
public: virtual bool MoveToParent() = 0;
[JScript]
public abstract function MoveToParent() : Boolean;

Return Value

true if a parent node exists.

false if there is no parent node. This can happen if the tree is changed out from under the XmlNavigator.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.MoveToPrevious

Moves to the previous sibling of the current node.

[Visual Basic]
MustOverride Public Function MoveToPrevious() As Boolean
[C#]
public abstract bool MoveToPrevious();
[C++]
public: virtual bool MoveToPrevious() = 0;
[JScript]
public abstract function MoveToPrevious() : Boolean;

Return Value

true if there is a previous sibling node; false if there is no previous sibling.

Remarks

If you are positioned on an attribute, this method will do an implicit call to MoveToElement before processing this method. In other words, attribute navigation is orthogonal to tree navigation.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.MoveToPreviousSelected

Moves the XmlNavigator to the previous node in the selected set.

[Visual Basic]
Overridable Public Function MoveToPreviousSelected() As Boolean
[C#]
public virtual bool MoveToPreviousSelected();
[C++]
public: virtual bool MoveToPreviousSelected();
[JScript]
public function MoveToPreviousSelected() : Boolean;

Return Value

true if XmlNavigator moved to specified node; false if there are no previous selected nodes.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.PopPosition

Moves the XmlNavigator back to a previously pushed position and pops that saved position off the stack.

[Visual Basic]
MustOverride Public Function PopPosition() As Boolean
[C#]
public abstract bool PopPosition();
[C++]
public: virtual bool PopPosition() = 0;
[JScript]
public abstract function PopPosition() : Boolean;

Return Value

true if XmlNavigator moved to previous push position; false if there is no more to pop.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.PushPosition

Saves the current position.

[Visual Basic]
MustOverride Public Sub PushPosition()
[C#]
public abstract void PushPosition();
[C++]
public: virtual void PushPosition() = 0;
[JScript]
public abstract function PushPosition();

Remarks

You can later return to this position by calling PopPosition(). Push has the same semantics as if you used Clone() and remembered the cloned XmlNavigators on your own stack.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.Remove

Removes the specified node(s).

Overload List

Removes the specified node (and its entire subtree) by relative position to the current node.

[Visual Basic] Overloads MustOverride Public Sub Remove(TreePosition)
[C#] public abstract void Remove(TreePosition);
[C++] public: virtual void Remove(TreePosition) = 0;
[JScript] public abstract function Remove(TreePosition);

Removes the current node (and its entire subtree).

[Visual Basic] Overloads MustOverride Public Sub Remove()
[C#] public abstract void Remove();
[C++] public: virtual void Remove() = 0;
[JScript] public abstract function Remove();

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.Remove (TreePosition)

Removes the specified node (and its entire subtree) by relative position to the current node.

[Visual Basic]
Overloads MustOverride Public Sub Remove( _
   ByVal p As TreePosition _
)
[C#]
public abstract void Remove(
   TreePosition p
);
[C++]
public: virtual void Remove(
   TreePosition p
) = 0;
[JScript]
public abstract function Remove(
   p : TreePosition
);

Parameters

p
Treeposition indicating the node to remove.

Remarks

After this method is called, the parent of the specified node is set to null. This XmlNavigator then stays pointing at this current node.

The position of "None" makes this method behave the same as Remove() with no arguments.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace | XmlNavigator.Remove Overload List


XmlNavigator.Remove ()

Removes the current node (and its entire subtree).

[Visual Basic]
Overloads MustOverride Public Sub Remove()
[C#]
public abstract void Remove();
[C++]
public: virtual void Remove() = 0;
[JScript]
public abstract function Remove();

Remarks

After this method is called, the parent pointer is disconnected (so MoveToParent will return false) and the parent's ChildCount will be decremented by 1.

This XmlNavigator then stays pointing at this removed node.

If this node has already been removed and has no parent, this method has no effect.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace | XmlNavigator.Remove Overload List


XmlNavigator.RemoveSelected

Removes all the selected nodes.

[Visual Basic]
MustOverride Public Sub RemoveSelected()
[C#]
public abstract void RemoveSelected();
[C++]
public: virtual void RemoveSelected() = 0;
[JScript]
public abstract function RemoveSelected();

Remarks

If there are no selected nodes, this method has no effect.

The XmlNavigator's position is unaffected by this operation.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.Select

Selects a new set of "records" using the specified XPath expression.

[Visual Basic]
Overridable Public Function Select( _
   ByVal xpathexpr As Object _
) As Boolean
[C#]
public virtual bool Select(
   object xpathexpr
);
[C++]
public: virtual bool Select(
   Object* xpathexpr
);
[JScript]
public function Select(
   xpathexpr : Object
) : Boolean;

Parameters

xpathexpr
An XPath expression describing how to navigate. This can be a string or an object returned from the Compile method.

Return Value

true if a node set matching the XPath expression was found; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentException | XPath expression contains an error. Or the return type of the XPath expression is not a node set.

Remarks

The context for the selection is the position of the navigator when you called this method. After calling this method, you must call MoveToNextSelected to find the first node that matches the specified XPath expression. This makes it easy to write a while loop on MoveToNextSelected- see example 1 below.

You can then use MoveToNextSelected and MoveToPreviousSelected to walk through the set of selected nodes. When you are positioned on a given node, you can also use the MoveToNext method to walk to the sibling of the selected node (which may be outside the selected set). If you do this, the next call to MoveToNextSelected jumps from whereever you were to the next selected node in the previously selected set. In other words, the basic navigation methods are independent of the selected set navigation methods.

Calling Select(xpath) completely resets the current selected set of nodes and forgets any previous selection.

Example | Description
child::* | Navigate to the children of the current node.
attribute::* | Navigate to the attributes of the current node.
descendant::* | Navigate to all the descendants of the current node in depth first traversal.
ancestor::* | Navigate back up the parents of the current node.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.SelectSingle

Selects the first node that matches the specified expression.

[Visual Basic]
Overridable Public Function SelectSingle( _
   ByVal xpathexpr As Object _
) As Boolean
[C#]
public virtual bool SelectSingle(
   object xpathexpr
);
[C++]
public: virtual bool SelectSingle(
   Object* xpathexpr
);
[JScript]
public function SelectSingle(
   xpathexpr : Object
) : Boolean;

Parameters

xpathexpr
An XPath expression describing how to navigate. This can be a string or an object returned from the Compile method.

Return Value

true if a node was found; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentException | The specified XPath expression is not a string or was not a result of a Compile method call. Or the XPath expression does not return a node.

Remarks

This is the same as Select except it selects a only the first matching node. So instead of writing the following code:

[C#]

nav.Select("Customer/Address/Street");
if (nav.MoveToFirstSelected())
    street = nav.InnerText;

You would use this code:

[C#]

if (nav.SelectSingle("Customer/Address/Street"))
    street = nav.InnerText;

This method has no effect on the current selection state.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.SetAttribute

Sets the value of the specified attribute.

Overload List

Sets the value of the attribute with the specified name and namespace.

[Visual Basic] Overloads MustOverride Public Sub SetAttribute(String, String, String)
[C#] public abstract void SetAttribute(String, String, String);
[C++] public: virtual void SetAttribute(String*, String*, String*) = 0;
[JScript] public abstract function SetAttribute(String, String, String);

Sets the value of the attribute with the specified index.

[Visual Basic] Overloads MustOverride Public Sub SetAttribute(Integer, String)
[C#] public abstract void SetAttribute(int, String);
[C++] public: virtual void SetAttribute(int, String) = 0;
[JScript] public abstract function SetAttribute(int, String);

Sets the value of the attribute with the specified name.

[Visual Basic] Overloads MustOverride Public Sub SetAttribute(String, String)
[C#] public abstract void SetAttribute(String, String);
[C++] public: virtual void SetAttribute(String*, String*) = 0;
[JScript] public abstract function SetAttribute(String, String);

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace


XmlNavigator.SetAttribute (String, String, String)

Sets the value of the attribute with the specified name and namespace.

[Visual Basic]
Overloads MustOverride Public Sub SetAttribute( _
   ByVal localName As String, _
   ByVal namespaceURI As String, _
   ByVal value As String _
)
[C#]
public abstract void SetAttribute(
   string localName,
   string namespaceURI,
   string value
);
[C++]
public: virtual void SetAttribute(
   String* localName,
   String* namespaceURI,
   String* value
) = 0;
[JScript]
public abstract function SetAttribute(
   localName : String,
   namespaceURI : String,
   value : String
);

Parameters

localName
The name of the attribute. The name can include the prefix or leave it off.
namespaceURI
The URN of the namespace of the attribute.
value
The value to set for the attribute.

Remarks

This name does may or may not include the prefix. For example:

[C#]

xti.SetAttribute("xmlns:x",null, nsuri);

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace | XmlNavigator.SetAttribute Overload List


XmlNavigator.SetAttribute (Int32, String)

Sets the value of the attribute with the specified index.

[Visual Basic]
Overloads MustOverride Public Sub SetAttribute( _
   ByVal i As Integer, _
   ByVal value As String _
)
[C#]
public abstract void SetAttribute(
   int i,
   string value
);
[C++]
public: virtual void SetAttribute(
   int i,
   String* value
) = 0;
[JScript]
public abstract function SetAttribute(
   i : int,
   value : String
);

Parameters

i
The index of the attribute.
value
[To be supplied.]

Return Value

The value of the specified attribute.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | The i parameter is less than 0 or greater than AttributeCount.

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace | XmlNavigator.SetAttribute Overload List


XmlNavigator.SetAttribute (String, String)

Sets the value of the attribute with the specified name.

[Visual Basic]
Overloads MustOverride Public Sub SetAttribute( _
   ByVal name As String, _
   ByVal value As String _
)
[C#]
public abstract void SetAttribute(
   string name,
   string value
);
[C++]
public: virtual void SetAttribute(
   String* name,
   String* value
) = 0;
[JScript]
public abstract function SetAttribute(
   name : String,
   value : String
);

Parameters

name
The name of the attribute. The name can include the prefix or leave it off.
value
[To be supplied.]

See Also

XmlNavigator Class | XmlNavigator Members | System.NewXml Namespace | XmlNavigator.SetAttribute Overload List


XmlNode Class

Represents a single node in the document.

Object
XmlNode

[Visual Basic]
MustInherit Public Class XmlNode
   Implements ICloneable, IEnumerable
[C#]
public abstract class XmlNode : ICloneable, IEnumerable
[C++]
public __gc __abstract class XmlNode : public ICloneable,
   IEnumerable
[JScript]
public abstract class XmlNode implements ICloneable, IEnumerable

Remarks

[To be supplied.]

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

XmlNode Members | System.NewXml Namespace


XmlNode Members

Public:

Properties

Attributes | Gets an XmlAttributeCollection containing the attributes of this node.
ChildNodes | Gets all children of this node.
FirstChild | Gets the first child of this node.
HasChildNodes | Gets a value indicating whether this node has any child nodes.
InnerText | Gets or sets the concatenated values of the node and all its children.
InnerXml | Gets or sets the markup representing just the children of this node.
IsReadOnly | Gets a value indicating whether the node is read-only.
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlNode class.
LastChild | Gets the last child of this node.
LocalName | Gets the name of the node without the namespace prefix.
Name | Gets the name of the node.
NamespaceURI | Gets the namespace URI of this node.
NextSibling | Gets the node immediately following this node.
NodeType | Gets the type of the current node.
OuterXml | Gets the markup representing this node and all its children.
OwnerDocument | Gets the XmlDocument that contains this node.
ParentNode | Gets the parent of this node (for nodes that can have parents).
Prefix | Gets or sets the namespace prefix of this node.
PreviousSibling | Gets the node immediately preceding this node.
Value | Gets or sets the value of the node.

Methods

AppendChild | Adds the specified node to the end of the list of children of this node.
Clone | Creates a duplicate of this node.
CloneNode | Creates a duplicate of this node.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamespaceOfPrefix | Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.
GetPrefixOfNamespace | Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.
GetType (inherited from Object) | Gets the Type of the Object.
InsertAfter | Inserts the specified node immediately after the specified reference node.
InsertBefore | Inserts the specified node immediately before the specified reference node.
Normalize | Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.
PrependChild | Adds the specified node to the beginning of the list of children of this node.
RemoveAll | Removes all the children and/or attributes of the current node.
RemoveChild | Removes specified child node.
ReplaceChild | Replaces the child node oldChild with newChild node.
Supports | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteContentTo | Saves all the children of the node to the specified XmlWriter.
WriteTo | Saves the current node to the specified XmlWriter.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlNode Class | System.NewXml Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlNode Properties

The properties of the XmlNode class are listed below. For a complete list of XmlNode class members, see the XmlNode Members topic.

Public:

Attributes | Gets an XmlAttributeCollection containing the attributes of this node.
ChildNodes | Gets all children of this node.
FirstChild | Gets the first child of this node.
HasChildNodes | Gets a value indicating whether this node has any child nodes.
InnerText | Gets or sets the concatenated values of the node and all its children.
InnerXml | Gets or sets the markup representing just the children of this node.
IsReadOnly | Gets a value indicating whether the node is read-only.
Item | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlNode class.
LastChild | Gets the last child of this node.
LocalName | Gets the name of the node without the namespace prefix.
Name | Gets the name of the node.
NamespaceURI | Gets the namespace URI of this node.
NextSibling | Gets the node immediately following this node.
NodeType | Gets the type of the current node.
OuterXml | Gets the markup representing this node and all its children.
OwnerDocument | Gets the XmlDocument that contains this node.
ParentNode | Gets the parent of this node (for nodes that can have parents).
Prefix | Gets or sets the namespace prefix of this node.
PreviousSibling | Gets the node immediately preceding this node.
Value | Gets or sets the value of the node.

See Also

XmlNode Class | System.NewXml Namespace


XmlNode.Attributes

Gets an XmlAttributeCollection containing the attributes of this node.

[Visual Basic]
Overridable Public ReadOnly Property Attributes As _
   XmlAttributeCollection
[C#]
public XmlAttributeCollection Attributes {virtual get;}
[C++]
public: __property virtual XmlAttributeCollection* get_Attributes();
[JScript]
public function get Attributes() : XmlAttributeCollection;

Property Value

An XmlAttributeCollection containing the attributes of the node.

If the node is of type XmlNodeType.Element, the attributes of the node are returned. Otherwise, this property is null.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.ChildNodes

Gets all children of this node.

[Visual Basic]
Overridable Public ReadOnly Property ChildNodes As XmlNodeList
[C#]
public XmlNodeList ChildNodes {virtual get;}
[C++]
public: __property virtual XmlNodeList* get_ChildNodes();
[JScript]
public function get ChildNodes() : XmlNodeList;

Property Value

A XmlNodeList that contains all children of this node.

If there are no children, this is an empty XmlNodeList.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.FirstChild

Gets the first child of this node.

[Visual Basic]
Overridable Public ReadOnly Property FirstChild As XmlNode
[C#]
public XmlNode FirstChild {virtual get;}
[C++]
public: __property virtual XmlNode* get_FirstChild();
[JScript]
public function get FirstChild() : XmlNode;

Property Value

The first child of this node. If there is no such node, null is returned.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.HasChildNodes

Gets a value indicating whether this node has any child nodes.

[Visual Basic]
Overridable Public ReadOnly Property HasChildNodes As Boolean
[C#]
public bool HasChildNodes {virtual get;}
[C++]
public: __property virtual bool get_HasChildNodes();
[JScript]
public function get HasChildNodes() : Boolean;

Property Value

true if the node has children, false if the node has no children.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.InnerText

Gets or sets the concatenated values of the node and all its children.

[Visual Basic]
Overridable Public Property InnerText As String
[C#]
public string InnerText {virtual get; virtual set;}
[C++]
public: __property virtual String* get_InnerText();
public: __property virtual void set_InnerText(String*);
[JScript]
public function get InnerText() : String;
public function set InnerText(String);

Property Value

The concatenated values of the node and all its children.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.InnerXml

Gets or sets the markup representing just the children of this node.

[Visual Basic]
Overridable Public Property InnerXml As String
[C#]
public string InnerXml {virtual get; virtual set;}
[C++]
public: __property virtual String* get_InnerXml();
public: __property virtual void set_InnerXml(String*);
[JScript]
public function get InnerXml() : String;
public function set InnerXml(String);

Property Value

The markup of the children of this node.

Remarks

This is also settable which replaces the children of the node with the parsed contents of the given string. The parsing is done in the current namespace context.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.IsReadOnly

Gets a value indicating whether the node is read-only.

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {virtual get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[JScript]
public function get IsReadOnly() : Boolean;

Property Value

true if the the current node is read-only.

false if the node is read/write.

Remarks

A read-only node is one that you cannot change any of its properties, attributes, or children. But you can remove it from the tree and insert it somewhere else. For example, the node for an EntityReference is typically read-only because its children actually come from the DTD definition of that entity and typically the DTD is read-only.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.Item

[To be supplied.]

[C#] In C#, this member is the indexer for the XmlNode class.

Overload List

Retrieves the first child element with the specified LocalName and NamespaceURI.

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(String, String) As XmlElement
[C#] public XmlElement this[String, String] {virtual get;}
[C++] public: __property virtual XmlElement* get_Item(String*, String*);
[JScript] XmlNode.Item (String, String)

Retrieves the first child element with the specified name.

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(String) As XmlElement
[C#] public XmlElement this[String] {virtual get;}
[C++] public: __property virtual XmlElement* get_Item(String*);
[JScript] XmlNode.Item (String)

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.Item (String, String)

Retrieves the first child element with the specified LocalName and NamespaceURI.

[C#] In C#, this member is the indexer for the XmlNode class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal localname As String, _
   ByVal ns As String _
) As XmlElement
[C#]
public XmlElement this[
   string localname,
   string ns
] {virtual get;}
[C++]
public: __property virtual XmlElement* get_Item(
   String* localname,
   String* ns
);
[JScript]
returnValue = XmlNodeObject.Item(localname, ns);
-or-
returnValue = XmlNodeObject(localname, ns);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

localname
LocalName to match
ns
[To be supplied.]

Parameters [Visual Basic, C#, C++]

localname
LocalName to match
ns
[To be supplied.]

Property Value

The first XmlElement that matches the specified LocalName and NamespaceURI.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace | XmlNode.Item Overload List


XmlNode.Item (String)

Retrieves the first child element with the specified name.

[C#] In C#, this member is the indexer for the XmlNode class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal name As String _
) As XmlElement
[C#]
public XmlElement this[
   string name
] {virtual get;}
[C++]
public: __property virtual XmlElement* get_Item(
   String* name
);
[JScript]
returnValue = XmlNodeObject.Item(name);
-or-
returnValue = XmlNodeObject(name);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
Name of the element to retrieve

Parameters [Visual Basic, C#, C++]

name
Name of the element to retrieve

Property Value

The first XmlElement that matches the specified LocalName and NamespaceURI.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace | XmlNode.Item Overload List


XmlNode.LastChild

Gets the last child of this node.

[Visual Basic]
Overridable Public ReadOnly Property LastChild As XmlNode
[C#]
public XmlNode LastChild {virtual get;}
[C++]
public: __property virtual XmlNode* get_LastChild();
[JScript]
public function get LastChild() : XmlNode;

Property Value

The last child of this node. If there is no such node, null is returned.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.LocalName

Gets the name of the node without the namespace prefix.

[Visual Basic]
MustOverride Public ReadOnly Property LocalName As String
[C#]
public string LocalName {abstract get;}
[C++]
public: __property virtual String* get_LocalName() = 0;
[JScript]
public abstract function get LocalName() : String;

Property Value

The name of the node with the prefix removed. For example, LocalName is yyy for the element <xxx:yyy>.

The name returned is dependent on the NodeType of the node:

Type | Name
Attribute | name of attribute
CDATA | #cdata-section
Comment | #comment
Document | #document
DocumentFragment | #document-fragment
DocumentType | document type name
Element | tag name
Entity | entity name
EntityReference | name of entity referenced
Notation | notation name
ProcessingInstruction | target
Text | #text

Remarks

For nodes created with a DOM Level 1 method, such as CreateElement, it is null.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.Name

Gets the name of the node.

[Visual Basic]
MustOverride Public ReadOnly Property Name As String
[C#]
public string Name {abstract get;}
[C++]
public: __property virtual String* get_Name() = 0;
[JScript]
public abstract function get Name() : String;

Property Value

The name of the node. The name returned is dependent on the NodeType of the node:

Type | Name
Attribute | name of attribute
CDATA | #cdata-section
Comment | #comment
Document | #document
DocumentFragment | #document-fragment
DocumentType | document type name
Element | tag name
Entity | entity name
EntityReference | name of entity referenced
Notation | notation name
ProcessingInstruction | target
Text | #text

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.NamespaceURI

Gets the namespace URI of this node.

[Visual Basic]
Overridable Public ReadOnly Property NamespaceURI As String
[C#]
public string NamespaceURI {virtual get;}
[C++]
public: __property virtual String* get_NamespaceURI();
[JScript]
public function get NamespaceURI() : String;

Property Value

The namespace URI of this node. If there is no namespace URI, this property is null.

Remarks

For example, "uuu" for the following "foo" element: <foo xmlns="uuu"> is not a computed value that is the result of a namespace lookup based on an examination of the namespace declarations in scope. It is merely the namespace URI given at creation time.

For nodes of any type other than ELEMENT_NODE and ATTRIBUTE_NODE and nodes created with a DOM Level 1 method, such as createElement from the XmlDocument, this is always null.In accordance with the Namespaces in XML Specification [Namespaces], an attribute does not inherit its namespace from the element it is attached to. If an attribute is not explicitly given a namespace, it simply has no namespace.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.NextSibling

Gets the node immediately following this node.

[Visual Basic]
Overridable Public ReadOnly Property NextSibling As XmlNode
[C#]
public XmlNode NextSibling {virtual get;}
[C++]
public: __property virtual XmlNode* get_NextSibling();
[JScript]
public function get NextSibling() : XmlNode;

Property Value

The next XmlNode. If there is no next node, a null reference (in Visual Basic Nothing) is returned.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.NodeType

Gets the type of the current node.

[Visual Basic]
MustOverride Public ReadOnly Property NodeType As XmlNodeType
[C#]
public XmlNodeType NodeType {abstract get;}
[C++]
public: __property virtual XmlNodeType get_NodeType() = 0;
[JScript]
public abstract function get NodeType() : XmlNodeType;

Property Value

One of the XmlNodeType values.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.OuterXml

Gets the markup representing this node and all its children.

[Visual Basic]
Overridable Public ReadOnly Property OuterXml As String
[C#]
public string OuterXml {virtual get;}
[C++]
public: __property virtual String* get_OuterXml();
[JScript]
public function get OuterXml() : String;

Property Value

The markup containing this node and all its children.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.OwnerDocument

Gets the XmlDocument that contains this node.

[Visual Basic]
Overridable Public ReadOnly Property OwnerDocument As XmlDocument
[C#]
public XmlDocument OwnerDocument {virtual get;}
[C++]
public: __property virtual XmlDocument* get_OwnerDocument();
[JScript]
public function get OwnerDocument() : XmlDocument;

Property Value

An XmlDocument.

If the node is an XmlDocument (NodeType equals XmlNodeType.Document), this property is null.

Remarks

When adding nodes to the current node, use the XmlDocument returned by the OwnerDocument property to create the node.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.ParentNode

Gets the parent of this node (for nodes that can have parents).

[Visual Basic]
Overridable Public ReadOnly Property ParentNode As XmlNode
[C#]
public XmlNode ParentNode {virtual get;}
[C++]
public: __property virtual XmlNode* get_ParentNode();
[JScript]
public function get ParentNode() : XmlNode;

Property Value

The XmlNode of this node's parent.

The value returned depends on the NodeType of the node:

NodeType | Parent NodeType
Attribute, Document, DocumentFragment | Returns a null reference (in Visual Basic Nothing); these nodes do not have parents.
CDATA | Returns the element or entity reference containing the CDATA section.
Comment | Returns the element, entity reference, document type, or document containing the comment.
DocumentType | Returns the document node.
Element | Returns the parent node of the element. If the element is the root node in the tree, the parent is the document node. If the node is the document node, parentNode is Null.
Entity | Returns the document type node.
EntityReference | Returns the element, attribute, or entity reference containing the entity reference.
Notation | Returns the document type node.
ProcessingInstruction | Returns the document, element, document type, or entity reference containing the processing instruction.
Text | Returns the parent element, attribute, or entity reference.

Remarks

All nodes except XmlDocument, XmlDocumentFragment, and XmlAttribute can have a parent. However, if a node has just been created and not yet added to the tree, or if it has been removed from the tree, the parent is a null reference (Nothing).

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.Prefix

Gets or sets the namespace prefix of this node.

[Visual Basic]
Overridable Public Property Prefix As String
[C#]
public string Prefix {virtual get; virtual set;}
[C++]
public: __property virtual String* get_Prefix();
public: __property virtual void set_Prefix(String*);
[JScript]
public function get Prefix() : String;
public function set Prefix(String);

Property Value

The namespace prefix of this node. If there is no prefix, this property is null.

Exceptions

Exception Type | Condition
INVALID_CHARACTER_ERR | The specified prefix contains an illegal character
NO_MODIFICATION_ALLOWED_ERR | This node is readonly
NAMESPACE_ERR | The specified prefix is malformed. The namespaceURI of this node is null. The specified prefix is "xml" and the namespaceURI of this node is different from

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.PreviousSibling

Gets the node immediately preceding this node.

[Visual Basic]
Overridable Public ReadOnly Property PreviousSibling As XmlNode
[C#]
public XmlNode PreviousSibling {virtual get;}
[C++]
public: __property virtual XmlNode* get_PreviousSibling();
[JScript]
public function get PreviousSibling() : XmlNode;

Property Value

The preceding XmlNode. If there is no preceding node, a null reference (in Visual Basic Nothing) is returned.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.Value

Gets or sets the value of the node.

[Visual Basic]
Overridable Public Property Value As String
[C#]
public string Value {virtual get; virtual set;}
[C++]
public: __property virtual String* get_Value();
public: __property virtual void set_Value(String*);
[JScript]
public function get Value() : String;
public function set Value(String);

Property Value

The value returned depends on the NodeType of the node:

Type | Value
Attr | value of attribute
CDATASection | content of the CDATA Section
Comment | content of the comment
Document | null
DocumentFragment | null
DocumentType | null
Element | null
Entity | null
EntityReference | null
Notation | null
ProcessingInstruction | entire content excluding the target
Text | content of the text node

Exceptions

Exception Type | Condition
ReadOnlyException | Node is read-only.
ArgumentOutOfRangeException | [To be supplied.]

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlNode Methods

The methods of the XmlNode class are listed below. For a complete list of XmlNode class members, see the XmlNode Members topic.

Public:

AppendChild | Adds the specified node to the end of the list of children of this node.
Clone | Creates a duplicate of this node.
CloneNode | Creates a duplicate of this node.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamespaceOfPrefix | Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.
GetPrefixOfNamespace | Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.
GetType (inherited from Object) | Gets the Type of the Object.
InsertAfter | Inserts the specified node immediately after the specified reference node.
InsertBefore | Inserts the specified node immediately before the specified reference node.
Normalize | Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.
PrependChild | Adds the specified node to the beginning of the list of children of this node.
RemoveAll | Removes all the children and/or attributes of the current node.
RemoveChild | Removes specified child node.
ReplaceChild | Replaces the child node oldChild with newChild node.
Supports | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteContentTo | Saves all the children of the node to the specified XmlWriter.
WriteTo | Saves the current node to the specified XmlWriter.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlNode Class | System.NewXml Namespace


XmlNode.AppendChild

Adds the specified node to the end of the list of children of this node.

[Visual Basic]
Overridable Public Function AppendChild( _
   ByVal newChild As XmlNode _
) As XmlNode
[C#]
public virtual XmlNode AppendChild(
   XmlNode newChild
);
[C++]
public: virtual XmlNode* AppendChild(
   XmlNode* newChild
);
[JScript]
public function AppendChild(
   newChild : XmlNode
) : XmlNode;

Parameters

newChild
The node to add. If it is a XmlDocumentFragment, the entire contents of the document fragment are moved into the child list of this node.

Return Value

The node added.

Exceptions

Exception Type | Condition
HIERARCHY_REQUEST_ERR | This node is of a type that does not allow children of the type of the newChild node. Or the node to be added is one of this node's ancestors.
WRONG_DOCUMENT_ERR | The newChild was created from a different document than the one that created this node.
NO_MODIFICATION_ALLOWED_ERR | This node is read-only.

Remarks

If the newChild is already in the tree, it is first removed.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.Clone

Creates a duplicate of this node.

[Visual Basic]
Overridable Public Function Clone() As XmlNode
[C#]
public virtual XmlNode Clone();
[C++]
public: virtual XmlNode* Clone();
[JScript]
public function Clone() : XmlNode;

Return Value

The duplicate node.

Remarks

Cloning an XmlElement copies all attributes and their values, including those generated by the XML processor to represent defaulted attributes. This method recursively clones the node and the subtree underneath it.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.CloneNode

Creates a duplicate of this node.

[Visual Basic]
MustOverride Public Function CloneNode( _
   ByVal deep As Boolean _
) As XmlNode
[C#]
public abstract XmlNode CloneNode(
   bool deep
);
[C++]
public: virtual XmlNode* CloneNode(
   bool deep
) = 0;
[JScript]
public abstract function CloneNode(
   deep : Boolean
) : XmlNode;

Parameters

deep
true to recursively clone the subtree under the specified node; false to clone only the node itself (and its attributes if the node is an XmlElement).

Return Value

The duplicate node.

Remarks

This method serves as a generic copy constructor for nodes. The duplicate node has no parent (ParentNode returns null).

Cloning an XmlElement copies all attributes and their values, including those generated by the XML processor to represent defaulted attributes. However, this method does not copy any text it contains unless it is a deep clone, since the text is contained in a child XmlText node. Cloning any other type of node simply returns a copy of this node.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.GetEnumerator

Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.

[Visual Basic]
Overridable Public Function GetEnumerator() As IEnumerator
[C#]
public virtual IEnumerator GetEnumerator();
[C++]
public: virtual IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

Return Value

An IEnumerator.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.GetNamespaceOfPrefix

Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.

[Visual Basic]
Overridable Public Function GetNamespaceOfPrefix( _
   ByVal prefix As String _
) As String
[C#]
public virtual string GetNamespaceOfPrefix(
   string prefix
);
[C++]
public: virtual String* GetNamespaceOfPrefix(
   String* prefix
);
[JScript]
public function GetNamespaceOfPrefix(
   prefix : String
) : String;

Parameters

prefix
Prefix whose namespace URI you want to find

Return Value

The namespace URI of the specified prefix.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.GetPrefixOfNamespace

Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.

[Visual Basic]
Overridable Public Function GetPrefixOfNamespace( _
   ByVal namespaceURI As String _
) As String
[C#]
public virtual string GetPrefixOfNamespace(
   string namespaceURI
);
[C++]
public: virtual String* GetPrefixOfNamespace(
   String* namespaceURI
);
[JScript]
public function GetPrefixOfNamespace(
   namespaceURI : String
) : String;

Parameters

namespaceURI
Namespace URI whose prefix you want to find

Return Value

The prefix for the specified namespace URI.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.InsertAfter

Inserts the specified node immediately after the specified reference node.

[Visual Basic]
Overridable Public Function InsertAfter( _
   ByVal newChild As XmlNode, _
   ByVal refChild As XmlNode _
) As XmlNode
[C#]
public virtual XmlNode InsertAfter(
   XmlNode newChild,
   XmlNode refChild
);
[C++]
public: virtual XmlNode* InsertAfter(
   XmlNode* newChild,
   XmlNode* refChild
);
[JScript]
public function InsertAfter(
   newChild : XmlNode,
   refChild : XmlNode
) : XmlNode;

Parameters

newChild
XmlNode to insert.
refChild
XmlNode that is the reference node. The newNode is placed after the refNode.

Remarks

If refChild is null, insert newChild at the beginning of the list of children. If newChild is a XmlDocumentFragment object, all of its children are inserted, in the same order, after refChild. If the newChild is already in the tree, it is first removed.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.InsertBefore

Inserts the specified node immediately before the specified reference node.

[Visual Basic]
Overridable Public Function InsertBefore( _
   ByVal newChild As XmlNode, _
   ByVal refChild As XmlNode _
) As XmlNode
[C#]
public virtual XmlNode InsertBefore(
   XmlNode newChild,
   XmlNode refChild
);
[C++]
public: virtual XmlNode* InsertBefore(
   XmlNode* newChild,
   XmlNode* refChild
);
[JScript]
public function InsertBefore(
   newChild : XmlNode,
   refChild : XmlNode
) : XmlNode;

Parameters

newChild
XmlNode to insert.
refChild
XmlNode that is the reference node. The newNode is placed before the refNode.

Exceptions

Exception Type | Condition
HIERARCHY_REQUEST_ERR | This node is of a type that does not allow children of the type of the newChild node. Or the node to insert is one of this node's ancestors.
WRONG_DOCUMENT_ERR | The newChild was created from a different document than the one that created this node.
NO_MODIFICATION_ALLOWED_ERR | This node is read-only.
NOT_FOUND_ERR | The refChild is not a child of this node.

Remarks

If refChild is null, insert newChild at the end of the list of children. If newChild is a XmlDocumentFragment object, all of its children are inserted, in the same order, before refChild. If the newChild is already in the tree, it is first removed.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.Normalize

Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.

[Visual Basic]
Overridable Public Sub Normalize()
[C#]
public virtual void Normalize();
[C++]
public: virtual void Normalize();
[JScript]
public function Normalize();

Remarks

This method can be used to ensure that the DOM view of a document is the same as if it were saved and re-loaded, and is useful when operations (such as XPointer lookups) that depend on a particular document tree structure are to be used.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.PrependChild

Adds the specified node to the beginning of the list of children of this node.

[Visual Basic]
Overridable Public Function PrependChild( _
   ByVal newChild As XmlNode _
) As XmlNode
[C#]
public virtual XmlNode PrependChild(
   XmlNode newChild
);
[C++]
public: virtual XmlNode* PrependChild(
   XmlNode* newChild
);
[JScript]
public function PrependChild(
   newChild : XmlNode
) : XmlNode;

Parameters

newChild
The node to add. If it is a XmlDocumentFragment, the entire contents of the document fragment are moved into the child list of this node.

Return Value

The node added.

Exceptions

Exception Type | Condition
HIERARCHY_REQUEST_ERR | This node is of a type that does not allow children of the type of the newChild node. Or the node to be added is one of this node's ancestors.
WRONG_DOCUMENT_ERR | The newChild was created from a different document than the one that created this node.
NO_MODIFICATION_ALLOWED_ERR | This node is read-only.

Remarks

If the newChild is already in the tree, it is first removed.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.RemoveAll

Removes all the children and/or attributes of the current node.

[Visual Basic]
Overridable Public Sub RemoveAll()
[C#]
public virtual void RemoveAll();
[C++]
public: virtual void RemoveAll();
[JScript]
public function RemoveAll();

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.RemoveChild

Removes specified child node.

[Visual Basic]
Overridable Public Function RemoveChild( _
   ByVal oldChild As XmlNode _
) As XmlNode
[C#]
public virtual XmlNode RemoveChild(
   XmlNode oldChild
);
[C++]
public: virtual XmlNode* RemoveChild(
   XmlNode* oldChild
);
[JScript]
public function RemoveChild(
   oldChild : XmlNode
) : XmlNode;

Parameters

oldChild
The node being removed.

Return Value

The node removed.

Exceptions

Exception Type | Condition
NO_MODIFICATION_ALLOWED_ERR | This node is read-only.
NOT_FOUND_ERR | The oldChild is not a child of this node.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.ReplaceChild

Replaces the child node oldChild with newChild node.

[Visual Basic]
Overridable Public Function ReplaceChild( _
   ByVal newChild As XmlNode, _
   ByVal oldChild As XmlNode _
) As XmlNode
[C#]
public virtual XmlNode ReplaceChild(
   XmlNode newChild,
   XmlNode oldChild
);
[C++]
public: virtual XmlNode* ReplaceChild(
   XmlNode* newChild,
   XmlNode* oldChild
);
[JScript]
public function ReplaceChild(
   newChild : XmlNode,
   oldChild : XmlNode
) : XmlNode;

Parameters

newChild
The new node to put in the child list.
oldChild
The node being replaced in the list.

Return Value

The node replaced.

Exceptions

Exception Type | Condition
HIERARCHY_REQUEST_ERR | This node is of a type that does not allow children of the type of the newChild node. Or the node to put in is one of this node's ancestors.
WRONG_DOCUMENT_ERR | The newChild was created from a different document than the one that created this node.
NO_MODIFICATION_ALLOWED_ERR | This node is read-only.
NOT_FOUND_ERR | The oldChild is not a child of this node.

Remarks

If the newChild is already in the tree, it is first removed.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.Supports

Test if the DOM implementation implements a specific feature.

[Visual Basic]
Overridable Public Function Supports( _
   ByVal feature As String, _
   ByVal version As String _
) As Boolean
[C#]
public virtual bool Supports(
   string feature,
   string version
);
[C++]
public: virtual bool Supports(
   String* feature,
   String* version
);
[JScript]
public function Supports(
   feature : String,
   version : String
) : Boolean;

Parameters

feature
The package name of the feature to test. This name is case-insensitive.
version
This is the version number of the package name to test. If the version is not specified (null), supporting any version of the feature will cause the method to return true.

Return Value

true if the feature is implemented in the specified version; otherwise, false.

This implementation returns true for the following combinations:

strFeature | strVersion
XML | 1.0

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.WriteContentTo

Saves all the children of the node to the specified XmlWriter.

[Visual Basic]
MustOverride Public Sub WriteContentTo( _
   ByVal w As XmlWriter _
)
[C#]
public abstract void WriteContentTo(
   XmlWriter w
);
[C++]
public: virtual void WriteContentTo(
   XmlWriter* w
) = 0;
[JScript]
public abstract function WriteContentTo(
   w : XmlWriter
);

Parameters

w
The XmlWriter where you want to save the current node.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNode.WriteTo

Saves the current node to the specified XmlWriter.

[Visual Basic]
MustOverride Public Sub WriteTo( _
   ByVal w As XmlWriter _
)
[C#]
public abstract void WriteTo(
   XmlWriter w
);
[C++]
public: virtual void WriteTo(
   XmlWriter* w
) = 0;
[JScript]
public abstract function WriteTo(
   w : XmlWriter
);

Parameters

w
The XmlWriter where you want to save the current node.

See Also

XmlNode Class | XmlNode Members | System.NewXml Namespace


XmlNodeList Class

Represents an ordered collection of nodes.

Object
XmlNodeList

[Visual Basic]
MustInherit Public Class XmlNodeList
   Implements IEnumerable
[C#]
public abstract class XmlNodeList : IEnumerable
[C++]
public __gc __abstract class XmlNodeList : public IEnumerable
[JScript]
public abstract class XmlNodeList implements IEnumerable

Remarks

The XmlNodeList is "live": changes to the children of the node object that it was created from are immediately reflected in the nodes returned by the XmlNodeList properties and methods. The XmlNodeList is not a static snapshot of the content of the node. This is true for every XmlNodeList, including the ones returned by the GetElementsByTagName method.

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

XmlNodeList Members | System.NewXml Namespace


XmlNodeList Members

Public:

Constructor

XmlNodeList Constructor [To be supplied.]

Properties

Count | Gets the number of nodes in this XmlNodeList.
Item | Retrieves a node at the given index. In C#, this member is the indexer for the XmlNodeList class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNodeList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Item | Retrieves a node at the given index.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlNodeList Class | System.NewXml Namespace


XmlNodeList Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public XmlNodeList();
[C++]
public: XmlNodeList();
[JScript]
public function XmlNodeList();

See Also

XmlNodeList Class | XmlNodeList Members | System.NewXml Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlNodeList Properties

The properties of the XmlNodeList class are listed below. For a complete list of XmlNodeList class members, see the XmlNodeList Members topic.

Public:

Count | Gets the number of nodes in this XmlNodeList.
Item | Retrieves a node at the given index. In C#, this member is the indexer for the XmlNodeList class.

See Also

XmlNodeList Class | System.NewXml Namespace


XmlNodeList.Count

Gets the number of nodes in this XmlNodeList.

[Visual Basic]
MustOverride Public ReadOnly Property Count As Integer
[C#]
public int Count {abstract get;}
[C++]
public: __property virtual int get_Count() = 0;
[JScript]
public abstract function get Count() : int;

Property Value

The number of nodes.

See Also

XmlNodeList Class | XmlNodeList Members | System.NewXml Namespace


XmlNodeList.Item

Retrieves a node at the given index.

[C#] In C#, this member is the indexer for the XmlNodeList class.

[Visual Basic]
Overridable Public Default ReadOnly Property Item( _
   ByVal i As Integer _
) As XmlNode
[C#]
public XmlNode this[
   int i
] {virtual get;}
[C++]
public: __property virtual XmlNode* get_Item(
   int i
);
[JScript]
returnValue = XmlNodeListObject.Item(i);
-or-
returnValue = XmlNodeListObject(i);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

i
Zero-based index into the list of nodes.

Parameters [Visual Basic, C#, C++]

i
Zero-based index into the list of nodes.

Property Value

The XmlNode in the collection. If index is greater than or equal to the number of nodes in the list, this returns null.

See Also

XmlNodeList Class | XmlNodeList Members | System.NewXml Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlNodeList Methods

The methods of the XmlNodeList class are listed below. For a complete list of XmlNodeList class members, see the XmlNodeList Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNodeList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Item | Retrieves a node at the given index.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlNodeList Class | System.NewXml Namespace


XmlNodeList.GetEnumerator

Provides a simple ForEach-style iteration over the collection of nodes in this XmlNodeList.

[Visual Basic]
Overridable Public Function GetEnumerator() As IEnumerator
[C#]
public virtual IEnumerator GetEnumerator();
[C++]
public: virtual IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IEnumerator;

Return Value

An IEnumerator.

See Also

XmlNodeList Class | XmlNodeList Members | System.NewXml Namespace


XmlNodeType Enumeration

Specifies the type of node.

[Visual Basic]
Public Enum XmlNodeType
[C#]
public enum XmlNodeType
[C++]
public enum XmlNodeType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
All | [To be supplied.]
Attribute | An Attribute. Example XML: id='123' An Attribute node can have the following child node types: Text and EntityReference. The Attribute node does not appear as the child node of any other node type; note that it is not considered a child node of an Element.
CDATA | A CDATA section. Example XML: <![CDATA[my escaped text]]> CDATA sections are used to escape blocks of text that would otherwise be recognized as markup. A CDATASection node cannot have any child nodes. The CDATASection node can appear as the child of the DocumentFragment, EntityReference, and Element nodes.
CharacterEntity | [To be supplied.]
Comment | A Comment. Example XML: <!-- my comment--> A Comment node cannot have any child nodes. The Comment node can appear as the child of the Document, DocumentFragment, Element, and EntityReference nodes.
Document | A document object, which, as the root of the document tree, provides access to the entire XML document. A Document node can have the following child node types: Element (maximum of one), ProcessingInstruction, Comment, and DocumentType. The Document node cannot appear as the child of any node types.
DocumentFragment | A document fragment. The DocumentFragment node associates a node or subtree with a document without actually being contained within the document. A DocumentFragment node can have the following child node types: Element, ProcessingInstruction, Comment, Text, CDATASection, and EntityReference. The DocumentFragment node cannot appear as the child of any node types.
DocumentType | The document type declaration, indicated by the <!DOCTYPE> tag. Example XML: <!DOCTYPE ...> A DocumentType node can have the following child node types: Notation and Entity. The DocumentType node can appear as the child of the Document node.
Element | An Element. Example XML: <Name>An Element node can have the following child node types: Element, Text, Comment, ProcessingInstruction, CDATA, and EntityReference. The Element node can be the child of the Document, DocumentFragment, EntityReference, and Element nodes.
EndEntity | Returned when XmlReader gets to the end of the entity replacement as a result of a call to ExpandEntity.
EndTag | End tag of an element. Example XML: </foo>
Entity | An expanded entity. Example XML: <!ENTITY ...> An Entity node can have child nodes that represent the expanded entity (for example, Text and EntityReference nodes). The Entity node can appear as the child of the DocumentType node.
EntityReference | A reference to an entity. Example XML: &foo; This applies to all entities, including character entity references. An EntityReference node can have the following child node types: Element, ProcessingInstruction, Comment, Text, CDATASection, and EntityReference. The EntityReference node can appear as the child of the Attribute, DocumentFragment, Element, and EntityReference nodes.
None | For XmlNavigator, cursor is not positioned on a node.
Notation | A notation in the document type declaration. Example XML: <!NOTATION ...> A Notation node cannot have any child nodes. The Notation node can appear as the child of the DocumentType node.
ProcessingInstruction | A processing instruction (PI). Example XML: <?pi test?> A PI node cannot have any child nodes. The PI node can appear as the child of the Document, DocumentFragment, Element, and EntityReference nodes.
SignificantWhitespace | Whitespace between markup in a mixed content model.
Text | The text content of an element. A Text node cannot have any child nodes. The Text node can appear as the child node of the Attribute, DocumentFragment, Element, and EntityReference nodes.
Whitespace | Whitespace between markup.

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

System.NewXml Namespace


XmlNotation Class

Contains a notation declared in the DTD or schema.

Object
XmlNode
XmlNotation

[Visual Basic]
Public Class XmlNotation
   Inherits XmlNode
[C#]
public class XmlNotation : XmlNode
[C++]
public __gc class XmlNotation : public XmlNode
[JScript]
public class XmlNotation extends XmlNode

Remarks

[To be supplied.]

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

XmlNotation Members | System.NewXml Namespace


XmlNotation Members

Public:

Properties

Attributes (inherited from XmlNode) | Gets an XmlAttributeCollection containing the attributes of this node.
ChildNodes (inherited from XmlNode) | Gets all children of this node.
FirstChild (inherited from XmlNode) | Gets the first child of this node.
HasChildNodes (inherited from XmlNode) | Gets a value indicating whether this node has any child nodes.
InnerText (inherited from XmlNode) | Gets or sets the concatenated values of the node and all its children.
InnerXml (inherited from XmlNode) | Gets or sets the markup representing just the children of this node.
IsReadOnly (inherited from XmlNode) | Gets a value indicating whether the node is read-only.
Item (inherited from XmlNode) | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlNotation class.
LastChild (inherited from XmlNode) | Gets the last child of this node.
LocalName | Gets the name of the current node without the namespace prefix.
Name | Gets the name of the node.
NamespaceURI (inherited from XmlNode) | Gets the namespace URI of this node.
NextSibling (inherited from XmlNode) | Gets the node immediately following this node.
NodeType | Gets the type of the current node.
OuterXml (inherited from XmlNode) | Gets the markup representing this node and all its children.
OwnerDocument (inherited from XmlNode) | Gets the XmlDocument that contains this node.
ParentNode (inherited from XmlNode) | Gets the parent of this node (for nodes that can have parents).
Prefix (inherited from XmlNode) | Gets or sets the namespace prefix of this node.
PreviousSibling (inherited from XmlNode) | Gets the node immediately preceding this node.
PublicId | Gets the value of the public identifier on the notation declaration.
SystemId | Gets the value of the system identifier on the notation declaration.
Value (inherited from XmlNode) | Gets or sets the value of the node.

Methods

AppendChild (inherited from XmlNode) | Adds the specified node to the end of the list of children of this node.
Clone (inherited from XmlNode) | Creates a duplicate of this node.
CloneNode | Creates a duplicate of this node.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from XmlNode) | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamespaceOfPrefix (inherited from XmlNode) | Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.
GetPrefixOfNamespace (inherited from XmlNode) | Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.
GetType (inherited from Object) | Gets the Type of the Object.
InsertAfter (inherited from XmlNode) | Inserts the specified node immediately after the specified reference node.
InsertBefore (inherited from XmlNode) | Inserts the specified node immediately before the specified reference node.
Normalize (inherited from XmlNode) | Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.
PrependChild (inherited from XmlNode) | Adds the specified node to the beginning of the list of children of this node.
RemoveAll (inherited from XmlNode) | Removes all the children and/or attributes of the current node.
RemoveChild (inherited from XmlNode) | Removes specified child node.
ReplaceChild (inherited from XmlNode) | Replaces the child node oldChild with newChild node.
Supports (inherited from XmlNode) | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteContentTo | Saves all the children of the node to the specified XmlWriter.
WriteTo | Saves the node to the specified XmlWriter.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlNotation Class | System.NewXml Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlNotation Properties

The properties of the XmlNotation class are listed below. For a complete list of XmlNotation class members, see the XmlNotation Members topic.

Public:

Attributes (inherited from XmlNode) | Gets an XmlAttributeCollection containing the attributes of this node.
ChildNodes (inherited from XmlNode) | Gets all children of this node.
FirstChild (inherited from XmlNode) | Gets the first child of this node.
HasChildNodes (inherited from XmlNode) | Gets a value indicating whether this node has any child nodes.
InnerText (inherited from XmlNode) | Gets or sets the concatenated values of the node and all its children.
InnerXml (inherited from XmlNode) | Gets or sets the markup representing just the children of this node.
IsReadOnly (inherited from XmlNode) | Gets a value indicating whether the node is read-only.
Item (inherited from XmlNode) | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlNotation class.
LastChild (inherited from XmlNode) | Gets the last child of this node.
LocalName | Gets the name of the current node without the namespace prefix.
Name | Gets the name of the node.
NamespaceURI (inherited from XmlNode) | Gets the namespace URI of this node.
NextSibling (inherited from XmlNode) | Gets the node immediately following this node.
NodeType | Gets the type of the current node.
OuterXml (inherited from XmlNode) | Gets the markup representing this node and all its children.
OwnerDocument (inherited from XmlNode) | Gets the XmlDocument that contains this node.
ParentNode (inherited from XmlNode) | Gets the parent of this node (for nodes that can have parents).
Prefix (inherited from XmlNode) | Gets or sets the namespace prefix of this node.
PreviousSibling (inherited from XmlNode) | Gets the node immediately preceding this node.
PublicId | Gets the value of the public identifier on the notation declaration.
SystemId | Gets the value of the system identifier on the notation declaration.
Value (inherited from XmlNode) | Gets or sets the value of the node.

See Also

XmlNotation Class | System.NewXml Namespace


XmlNotation.LocalName

Gets the name of the current node without the namespace prefix.

[Visual Basic]
Overridable Public ReadOnly Property LocalName As String
[C#]
public string LocalName {override get;}
[C++]
public: __property virtual String* get_LocalName();
[JScript]
public function get LocalName() : String;

Property Value

The name of the current node with the prefix removed. For example, LocalName is yyy for the element <xxx:yyy>.

See Also

XmlNotation Class | XmlNotation Members | System.NewXml Namespace


XmlNotation.Name

Gets the name of the node.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {override get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

Property Value

The name of the notation.

See Also

XmlNotation Class | XmlNotation Members | System.NewXml Namespace


XmlNotation.NodeType

Gets the type of the current node.

[Visual Basic]
Overridable Public ReadOnly Property NodeType As XmlNodeType
[C#]
public XmlNodeType NodeType {override get;}
[C++]
public: __property virtual XmlNodeType get_NodeType();
[JScript]
public function get NodeType() : XmlNodeType;

Property Value

One of the XmlNodeType values.

See Also

XmlNotation Class | XmlNotation Members | System.NewXml Namespace


XmlNotation.PublicId

Gets the value of the public identifier on the notation declaration.

[Visual Basic]
Public ReadOnly Property PublicId As String
[C#]
public string PublicId {get;}
[C++]
public: __property String* get_PublicId();
[JScript]
public function get PublicId() : String;

Property Value

The public identifier on the notation. If there is no public identifier, String.Empty is returned.

See Also

XmlNotation Class | XmlNotation Members | System.NewXml Namespace


XmlNotation.SystemId

Gets the value of the system identifier on the notation declaration.

[Visual Basic]
Public ReadOnly Property SystemId As String
[C#]
public string SystemId {get;}
[C++]
public: __property String* get_SystemId();
[JScript]
public function get SystemId() : String;

Property Value

The system identifier on the notation. If there is no system identifier, String.Empty is returned.

See Also

XmlNotation Class | XmlNotation Members | System.NewXml Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlNotation Methods

The methods of the XmlNotation class are listed below. For a complete list of XmlNotation class members, see the XmlNotation Members topic.

Public:

AppendChild (inherited from XmlNode) | Adds the specified node to the end of the list of children of this node.
Clone (inherited from XmlNode) | Creates a duplicate of this node.
CloneNode | Creates a duplicate of this node.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from XmlNode) | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamespaceOfPrefix (inherited from XmlNode) | Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.
GetPrefixOfNamespace (inherited from XmlNode) | Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.
GetType (inherited from Object) | Gets the Type of the Object.
InsertAfter (inherited from XmlNode) | Inserts the specified node immediately after the specified reference node.
InsertBefore (inherited from XmlNode) | Inserts the specified node immediately before the specified reference node.
Normalize (inherited from XmlNode) | Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.
PrependChild (inherited from XmlNode) | Adds the specified node to the beginning of the list of children of this node.
RemoveAll (inherited from XmlNode) | Removes all the children and/or attributes of the current node.
RemoveChild (inherited from XmlNode) | Removes specified child node.
ReplaceChild (inherited from XmlNode) | Replaces the child node oldChild with newChild node.
Supports (inherited from XmlNode) | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteContentTo | Saves all the children of the node to the specified XmlWriter.
WriteTo | Saves the node to the specified XmlWriter.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlNotation Class | System.NewXml Namespace


XmlNotation.CloneNode

Creates a duplicate of this node.

[Visual Basic]
Overrides Public Function CloneNode( _
   ByVal deep As Boolean _
) As XmlNode
[C#]
public override XmlNode CloneNode(
   bool deep
);
[C++]
public: override XmlNode* CloneNode(
   bool deep
);
[JScript]
public override function CloneNode(
   deep : Boolean
) : XmlNode;

Parameters

deep
true to recursively clone the subtree under the specified node; false to clone only the node itself (and its attributes if the node is an XmlElement).

Return Value

The duplicate node.

Remarks

This method serves as a generic copy constructor for nodes. The duplicate node has no parent (ParentNode returns null).

See Also

XmlNotation Class | XmlNotation Members | System.NewXml Namespace


XmlNotation.WriteContentTo

Saves all the children of the node to the specified XmlWriter.

[Visual Basic]
Overrides Public Sub WriteContentTo( _
   ByVal w As XmlWriter _
)
[C#]
public override void WriteContentTo(
   XmlWriter w
);
[C++]
public: override void WriteContentTo(
   XmlWriter* w
);
[JScript]
public override function WriteContentTo(
   w : XmlWriter
);

Parameters

w
The XmlWriter where you want to save the current node.

See Also

XmlNotation Class | XmlNotation Members | System.NewXml Namespace


XmlNotation.WriteTo

Saves the node to the specified XmlWriter.

[Visual Basic]
Overrides Public Sub WriteTo( _
   ByVal w As XmlWriter _
)
[C#]
public override void WriteTo(
   XmlWriter w
);
[C++]
public: override void WriteTo(
   XmlWriter* w
);
[JScript]
public override function WriteTo(
   w : XmlWriter
);

Parameters

w
The XmlWriter where you want to save the node.

See Also

XmlNotation Class | XmlNotation Members | System.NewXml Namespace


XmlProcessingInstruction Class

Represents a processing instruction, which XML defines to keep processor-specific information in the text of the document.

Object
XmlNode
XmlLinkedNode
XmlProcessingInstruction

[Visual Basic]
Public Class XmlProcessingInstruction
   Inherits XmlLinkedNode
[C#]
public class XmlProcessingInstruction : XmlLinkedNode
[C++]
public __gc class XmlProcessingInstruction : public XmlLinkedNode
[JScript]
public class XmlProcessingInstruction extends XmlLinkedNode

Remarks

[To be supplied.]

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

XmlProcessingInstruction Members | System.NewXml Namespace


XmlProcessingInstruction Members

Public:

Properties

Attributes (inherited from XmlNode) | Gets an XmlAttributeCollection containing the attributes of this node.
ChildNodes (inherited from XmlNode) | Gets all children of this node.
Data | Gets or sets the content of processing instruction, excluding the target.
FirstChild (inherited from XmlNode) | Gets the first child of this node.
HasChildNodes (inherited from XmlNode) | Gets a value indicating whether this node has any child nodes.
InnerText | Gets or sets the concatenated values of the node and all its children.
InnerXml (inherited from XmlNode) | Gets or sets the markup representing just the children of this node.
IsReadOnly (inherited from XmlNode) | Gets a value indicating whether the node is read-only.
Item (inherited from XmlNode) | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlProcessingInstruction class.
LastChild (inherited from XmlNode) | Gets the last child of this node.
LocalName | Gets the name of the current node without the namespace prefix.
Name | Gets the name of the node.
NamespaceURI (inherited from XmlNode) | Gets the namespace URI of this node.
NextSibling (inherited from XmlLinkedNode) | [To be supplied.]
NodeType | Gets the type of the current node.
OuterXml (inherited from XmlNode) | Gets the markup representing this node and all its children.
OwnerDocument (inherited from XmlNode) | Gets the XmlDocument that contains this node.
ParentNode (inherited from XmlNode) | Gets the parent of this node (for nodes that can have parents).
Prefix (inherited from XmlNode) | Gets or sets the namespace prefix of this node.
PreviousSibling (inherited from XmlLinkedNode) | [To be supplied.]
Target | Gets the target of the processing instruction.
Value | Gets or sets the value of the node.

Methods

AppendChild (inherited from XmlNode) | Adds the specified node to the end of the list of children of this node.
Clone (inherited from XmlNode) | Creates a duplicate of this node.
CloneNode | Creates a duplicate of this node.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from XmlNode) | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamespaceOfPrefix (inherited from XmlNode) | Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.
GetPrefixOfNamespace (inherited from XmlNode) | Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.
GetType (inherited from Object) | Gets the Type of the Object.
InsertAfter (inherited from XmlNode) | Inserts the specified node immediately after the specified reference node.
InsertBefore (inherited from XmlNode) | Inserts the specified node immediately before the specified reference node.
Normalize (inherited from XmlNode) | Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.
PrependChild (inherited from XmlNode) | Adds the specified node to the beginning of the list of children of this node.
RemoveAll (inherited from XmlNode) | Removes all the children and/or attributes of the current node.
RemoveChild (inherited from XmlNode) | Removes specified child node.
ReplaceChild (inherited from XmlNode) | Replaces the child node oldChild with newChild node.
Supports (inherited from XmlNode) | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteContentTo | Saves all the children of the node to the specified XmlWriter.
WriteTo | Saves the node to the specified XmlWriter.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlProcessingInstruction Class | System.NewXml Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlProcessingInstruction Properties

The properties of the XmlProcessingInstruction class are listed below. For a complete list of XmlProcessingInstruction class members, see the XmlProcessingInstruction Members topic.

Public:

Attributes (inherited from XmlNode) | Gets an XmlAttributeCollection containing the attributes of this node.
ChildNodes (inherited from XmlNode) | Gets all children of this node.
Data | Gets or sets the content of processing instruction, excluding the target.
FirstChild (inherited from XmlNode) | Gets the first child of this node.
HasChildNodes (inherited from XmlNode) | Gets a value indicating whether this node has any child nodes.
InnerText | Gets or sets the concatenated values of the node and all its children.
InnerXml (inherited from XmlNode) | Gets or sets the markup representing just the children of this node.
IsReadOnly (inherited from XmlNode) | Gets a value indicating whether the node is read-only.
Item (inherited from XmlNode) | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlProcessingInstruction class.
LastChild (inherited from XmlNode) | Gets the last child of this node.
LocalName | Gets the name of the current node without the namespace prefix.
Name | Gets the name of the node.
NamespaceURI (inherited from XmlNode) | Gets the namespace URI of this node.
NextSibling (inherited from XmlLinkedNode) | [To be supplied.]
NodeType | Gets the type of the current node.
OuterXml (inherited from XmlNode) | Gets the markup representing this node and all its children.
OwnerDocument (inherited from XmlNode) | Gets the XmlDocument that contains this node.
ParentNode (inherited from XmlNode) | Gets the parent of this node (for nodes that can have parents).
Prefix (inherited from XmlNode) | Gets or sets the namespace prefix of this node.
PreviousSibling (inherited from XmlLinkedNode) | [To be supplied.]
Target | Gets the target of the processing instruction.
Value | Gets or sets the value of the node.

See Also

XmlProcessingInstruction Class | System.NewXml Namespace


XmlProcessingInstruction.Data

Gets or sets the content of processing instruction, excluding the target.

[Visual Basic]
Public Property Data As String
[C#]
public string Data {get; set;}
[C++]
public: __property String* get_Data();
public: __property void set_Data(String*);
[JScript]
public function get Data() : String;
public function set Data(String);

Property Value

The content of processing instruction, excluding the target.

See Also

XmlProcessingInstruction Class | XmlProcessingInstruction Members | System.NewXml Namespace


XmlProcessingInstruction.InnerText

Gets or sets the concatenated values of the node and all its children.

[Visual Basic]
Overridable Public Property InnerText As String
[C#]
public string InnerText {override get; override set;}
[C++]
public: __property virtual String* get_InnerText();
public: __property virtual void set_InnerText(String*);
[JScript]
public function get InnerText() : String;
public function set InnerText(String);

Property Value

The concatenated values of the node and all its children.

See Also

XmlProcessingInstruction Class | XmlProcessingInstruction Members | System.NewXml Namespace


XmlProcessingInstruction.LocalName

Gets the name of the current node without the namespace prefix.

[Visual Basic]
Overridable Public ReadOnly Property LocalName As String
[C#]
public string LocalName {override get;}
[C++]
public: __property virtual String* get_LocalName();
[JScript]
public function get LocalName() : String;

Property Value

The name of the current node with the prefix removed. For example, LocalName is yyy for the element <xxx:yyy>.

For XmlProcessingInstruction, the name is the target of the processing instruction.

See Also

XmlProcessingInstruction Class | XmlProcessingInstruction Members | System.NewXml Namespace


XmlProcessingInstruction.Name

Gets the name of the node.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {override get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

Property Value

The name of the node. For XmlProcessingInstruction, the name is the target of the processing instruction.

See Also

XmlProcessingInstruction Class | XmlProcessingInstruction Members | System.NewXml Namespace


XmlProcessingInstruction.NodeType

Gets the type of the current node.

[Visual Basic]
Overridable Public ReadOnly Property NodeType As XmlNodeType
[C#]
public XmlNodeType NodeType {override get;}
[C++]
public: __property virtual XmlNodeType get_NodeType();
[JScript]
public function get NodeType() : XmlNodeType;

Property Value

One of the XmlNodeType values.

See Also

XmlProcessingInstruction Class | XmlProcessingInstruction Members | System.NewXml Namespace


XmlProcessingInstruction.Target

Gets the target of the processing instruction.

[Visual Basic]
Public ReadOnly Property Target As String
[C#]
public string Target {get;}
[C++]
public: __property String* get_Target();
[JScript]
public function get Target() : String;

Property Value

The target of the processing instruction.

See Also

XmlProcessingInstruction Class | XmlProcessingInstruction Members | System.NewXml Namespace


XmlProcessingInstruction.Value

Gets or sets the value of the node.

[Visual Basic]
Overridable Public Property Value As String
[C#]
public string Value {override get; override set;}
[C++]
public: __property virtual String* get_Value();
public: __property virtual void set_Value(String*);
[JScript]
public function get Value() : String;
public function set Value(String);

Property Value

The entire content of the processing instruction excluding the target.

Exceptions

Exception Type | Condition
ReadOnlyException | Node is read-only.

See Also

XmlProcessingInstruction Class | XmlProcessingInstruction Members | System.NewXml Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlProcessingInstruction Methods

The methods of the XmlProcessingInstruction class are listed below. For a complete list of XmlProcessingInstruction class members, see the XmlProcessingInstruction Members topic.

Public:

AppendChild (inherited from XmlNode) | Adds the specified node to the end of the list of children of this node.
Clone (inherited from XmlNode) | Creates a duplicate of this node.
CloneNode | Creates a duplicate of this node.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from XmlNode) | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamespaceOfPrefix (inherited from XmlNode) | Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.
GetPrefixOfNamespace (inherited from XmlNode) | Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.
GetType (inherited from Object) | Gets the Type of the Object.
InsertAfter (inherited from XmlNode) | Inserts the specified node immediately after the specified reference node.
InsertBefore (inherited from XmlNode) | Inserts the specified node immediately before the specified reference node.
Normalize (inherited from XmlNode) | Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.
PrependChild (inherited from XmlNode) | Adds the specified node to the beginning of the list of children of this node.
RemoveAll (inherited from XmlNode) | Removes all the children and/or attributes of the current node.
RemoveChild (inherited from XmlNode) | Removes specified child node.
ReplaceChild (inherited from XmlNode) | Replaces the child node oldChild with newChild node.
Supports (inherited from XmlNode) | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteContentTo | Saves all the children of the node to the specified XmlWriter.
WriteTo | Saves the node to the specified XmlWriter.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlProcessingInstruction Class | System.NewXml Namespace


XmlProcessingInstruction.CloneNode

Creates a duplicate of this node.

[Visual Basic]
Overrides Public Function CloneNode( _
   ByVal deep As Boolean _
) As XmlNode
[C#]
public override XmlNode CloneNode(
   bool deep
);
[C++]
public: override XmlNode* CloneNode(
   bool deep
);
[JScript]
public override function CloneNode(
   deep : Boolean
) : XmlNode;

Parameters

deep
true to recursively clone the subtree under the specified node; false to clone only the node itself (and its attributes if the node is an XmlElement).

Return Value

The duplicate node.

Remarks

This method serves as a generic copy constructor for nodes. The duplicate node has no parent (ParentNode returns null).

See Also

XmlProcessingInstruction Class | XmlProcessingInstruction Members | System.NewXml Namespace


XmlProcessingInstruction.WriteContentTo

Saves all the children of the node to the specified XmlWriter.

[Visual Basic]
Overrides Public Sub WriteContentTo( _
   ByVal w As XmlWriter _
)
[C#]
public override void WriteContentTo(
   XmlWriter w
);
[C++]
public: override void WriteContentTo(
   XmlWriter* w
);
[JScript]
public override function WriteContentTo(
   w : XmlWriter
);

Parameters

w
The XmlWriter where you want to save the current node.

See Also

XmlProcessingInstruction Class | XmlProcessingInstruction Members | System.NewXml Namespace


XmlProcessingInstruction.WriteTo

Saves the node to the specified XmlWriter.

[Visual Basic]
Overrides Public Sub WriteTo( _
   ByVal w As XmlWriter _
)
[C#]
public override void WriteTo(
   XmlWriter w
);
[C++]
public: override void WriteTo(
   XmlWriter* w
);
[JScript]
public override function WriteTo(
   w : XmlWriter
);

Parameters

w
The XmlWriter where you want to save the node.

See Also

XmlProcessingInstruction Class | XmlProcessingInstruction Members | System.NewXml Namespace


XmlReader Class

Represents a reader that provides fast, non-cached forward only stream access to XML data.This class is abstract.

Object
XmlReader

[Visual Basic]
MustInherit Public Class XmlReader
[C#]
public abstract class XmlReader
[C++]
public __gc __abstract class XmlReader
[JScript]
public abstract class XmlReader

Remarks

[To be supplied.]

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

XmlReader Members | System.NewXml Namespace


XmlReader Members

Public:

Constructor

XmlReader Constructor [To be supplied.]

Properties

AttributeCount | Gets the number of attributes on the current node.
BaseURI | Gets the base URI of the current node.
Depth | Gets the depth of the current node in the XML element stack.
EntityHandling | Gets or sets a value that specifies how the XmlReader handles entities.
EOF | Gets a value indicating whether XmlReader is positioned at the end of the stream.
HasAttributes | Gets a value indicating whether the current node has any attributes.
HasValue | Gets a value indicating whether Value has a value to return.
IsDefault | Gets a value indicating whether the current node is an attribute that was generated from the default value defined in the DTD or schema.
IsEmptyTag | Gets a value indicating whether the current node is an empty element (for example, <MyElement/>).
Item | Overloaded. Gets the value of an attribute. This is a shortcut for the GetAttribute method. In C#, this member is the indexer for the XmlReader class.
LocalName | Gets the name of the current node without the namespace prefix.
Name | Gets the name of the current node, including the namespace prefix.
NamespaceURI | Gets the namespace URN (as defined in the W3C Namespace Specification) of the current namespace scope.
NameTable | Gets the XmlNameTable associated with this implementation.
NodeType | Gets the type of the current node.
Prefix | Gets the namespace prefix associated with the current node.
QuoteChar | Gets the quotation mark character used to enclose the value of an attribute node.
ReadState | Returns the read state of the stream.
Value | Gets the text value of the current node.
XmlLang | Gets the current xml:lang scope.
XmlSpace | Gets the current xml:space scope.

Methods

Close | Closes the stream, changes the ReadState to Closed, and sets all the properties back to zero.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetAttribute | Overloaded. Gets the value of an attribute.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
LookupNamespace | Resolves a namespace prefix in the current element's scope.
MoveToAttribute Overloaded. Moves to the specified attribute.

The MoveToAttribute methods enable you to get both random access to attributes and strongly typed access to attribute values.

To get strongly typed access to an attribute value, you must do the following:

  1. Call MoveToAttribute to move to the attribute whose value you want to access.
  2. Call Read method for the data type you want (for example, ReadBoolean for boolean, ReadDate for DateTime, and so on).

After calling MoveToAttribute, the Name, Namespace, Prefix properties will reflect the properties of that attribute.
MoveToElement | Moves to the element that contains the current attribute node.
MoveToFirstAttribute | Moves to the first attribute.
MoveToNextAttribute | Moves to the next attribute.
Read | Reads the next node from the stream.
ReadAttributeValue | Parses the attribute value into one or more Text and/or EntityReference node types.
ReadBoolean | Reads the value and returns it as a bool.
ReadChar | Reads the element content one character at a time.
ReadChars | Reads the text contents of an element into a character buffer. This method is designed to read large streams of embedded text by calling it successively.
ReadCurrency | Reads the value and returns it as a Currency.
ReadDate | Reads the value and returns it as a DateTime.
ReadDecimal | Reads the value and returns it as a Decimal.
ReadDouble | Reads the value and returns it as a double.
ReadInnerXml | Reads all the content (including markup) as a string.
ReadInt16 | Reads the value and returns it as an Int16.
ReadInt32 | Reads the value and returns it as an Int32.
ReadInt64 | Reads the value and returns it as an Int64.
ReadSingle | Reads the value and returns it as a float.
ReadString | Reads the contents of an element as a string.
ReadTimeSpan | Reads the value and returns it as a TimeSpan.
ResolveEntity | Overloaded. Resolves an entity reference.
Skip | Skips to the end tag of the current element.
TagNameIs | Overloaded. Checks whether the current element has the specified name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlReader Class | System.NewXml Namespace


XmlReader Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public XmlReader();
[C++]
public: XmlReader();
[JScript]
public function XmlReader();

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlReader Properties

The properties of the XmlReader class are listed below. For a complete list of XmlReader class members, see the XmlReader Members topic.

Public:

AttributeCount | Gets the number of attributes on the current node.
BaseURI | Gets the base URI of the current node.
Depth | Gets the depth of the current node in the XML element stack.
EntityHandling | Gets or sets a value that specifies how the XmlReader handles entities.
EOF | Gets a value indicating whether XmlReader is positioned at the end of the stream.
HasAttributes | Gets a value indicating whether the current node has any attributes.
HasValue | Gets a value indicating whether Value has a value to return.
IsDefault | Gets a value indicating whether the current node is an attribute that was generated from the default value defined in the DTD or schema.
IsEmptyTag | Gets a value indicating whether the current node is an empty element (for example, <MyElement/>).
Item | Overloaded. Gets the value of an attribute. This is a shortcut for the GetAttribute method. In C#, this member is the indexer for the XmlReader class.
LocalName | Gets the name of the current node without the namespace prefix.
Name | Gets the name of the current node, including the namespace prefix.
NamespaceURI | Gets the namespace URN (as defined in the W3C Namespace Specification) of the current namespace scope.
NameTable | Gets the XmlNameTable associated with this implementation.
NodeType | Gets the type of the current node.
Prefix | Gets the namespace prefix associated with the current node.
QuoteChar | Gets the quotation mark character used to enclose the value of an attribute node.
ReadState | Returns the read state of the stream.
Value | Gets the text value of the current node.
XmlLang | Gets the current xml:lang scope.
XmlSpace | Gets the current xml:space scope.

See Also

XmlReader Class | System.NewXml Namespace


XmlReader.AttributeCount

Gets the number of attributes on the current node.

[Visual Basic]
MustOverride Public ReadOnly Property AttributeCount As Integer
[C#]
public int AttributeCount {abstract get;}
[C++]
public: __property virtual int get_AttributeCount() = 0;
[JScript]
public abstract function get AttributeCount() : int;

Property Value

Count of attributes on the current node.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.BaseURI

Gets the base URI of the current node.

[Visual Basic]
MustOverride Public ReadOnly Property BaseURI As String
[C#]
public string BaseURI {abstract get;}
[C++]
public: __property virtual String* get_BaseURI() = 0;
[JScript]
public abstract function get BaseURI() : String;

Property Value

The base URI of the current node. The string returned is also in NameTable.

Remarks

A "networked" XML document is comprised of chunks of data aggregated using various W3C standard inclusion mechanisms and therefore contains nodes that come from different places. DTD Entities are an example of this--but this is not limited to DTD's. The BaseURI tells you where these nodes came from. If there is no base URI for the nodes being returned (maybe they were parsed from an in-memory string), String.Empty is returned.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.Depth

Gets the depth of the current node in the XML element stack.

[Visual Basic]
MustOverride Public ReadOnly Property Depth As Integer
[C#]
public int Depth {abstract get;}
[C++]
public: __property virtual int get_Depth() = 0;
[JScript]
public abstract function get Depth() : int;

Property Value

The depth of the current node in the XML element stack.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.EntityHandling

Gets or sets a value that specifies how the XmlReader handles entities.

[Visual Basic]
MustOverride Public Property EntityHandling As EntityHandling
[C#]
public EntityHandling EntityHandling {abstract get; abstract set;}
[C++]
public: __property virtual EntityHandling get_EntityHandling() = 0;public: __property virtual void set_EntityHandling(EntityHandling) = 0;
[JScript]
public abstract function get EntityHandling() : EntityHandling;
public abstract function set EntityHandling(EntityHandling);

Property Value

One of the EntityHandling values.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | Invalid value was specified.

Remarks

This property can be changed on the fly and the new behavior begins after the next Read call.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.EOF

Gets a value indicating whether XmlReader is positioned at the end of the stream.

[Visual Basic]
MustOverride Public ReadOnly Property EOF As Boolean
[C#]
public bool EOF {abstract get;}
[C++]
public: __property virtual bool get_EOF() = 0;
[JScript]
public abstract function get EOF() : Boolean;

Property Value

true if XmlReader is positioned at the end of the stream; otherwise, false.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.HasAttributes

Gets a value indicating whether the current node has any attributes.

[Visual Basic]
Overridable Public ReadOnly Property HasAttributes As Boolean
[C#]
public bool HasAttributes {virtual get;}
[C++]
public: __property virtual bool get_HasAttributes();
[JScript]
public function get HasAttributes() : Boolean;

Property Value

true if the current node has attributes; otherwise, false.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.HasValue

Gets a value indicating whether Value has a value to return.

[Visual Basic]
MustOverride Public ReadOnly Property HasValue As Boolean
[C#]
public bool HasValue {abstract get;}
[C++]
public: __property virtual bool get_HasValue() = 0;
[JScript]
public abstract function get HasValue() : Boolean;

Property Value

true if Value has a value to return or if any more content can be returned from the partial content read methods; otherwise, false.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.IsDefault

Gets a value indicating whether the current node is an attribute that was generated from the default value defined in the DTD or schema.

[Visual Basic]
MustOverride Public ReadOnly Property IsDefault As Boolean
[C#]
public bool IsDefault {abstract get;}
[C++]
public: __property virtual bool get_IsDefault() = 0;
[JScript]
public abstract function get IsDefault() : Boolean;

Property Value

true if the the current node is an attribute whose value was generated from the default value defined in the DTD or schema.

false if the attribute's value was explicitly specified in the XML stream.

Remarks

This property applies only to an attribute node.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.IsEmptyTag

Gets a value indicating whether the current node is an empty element (for example, <MyElement/>).

[Visual Basic]
MustOverride Public ReadOnly Property IsEmptyTag As Boolean
[C#]
public bool IsEmptyTag {abstract get;}
[C++]
public: __property virtual bool get_IsEmptyTag() = 0;
[JScript]
public abstract function get IsEmptyTag() : Boolean;

Property Value

true if the current node is an element (NodeType equals Element) that ends with "/>"; otherwise, false.

Remarks

This property enables you to determine the difference between the following:

<foo bar="123"/> (IsEmptyTag is true).

<foo bar="123"> (IsEmptyTag is false)

Note that a corresponding EndTag element is not generated for empty elements.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.Item

Gets the value of an attribute. This is a shortcut for the GetAttribute method.

[C#] In C#, this member is the indexer for the XmlReader class.

Overload List

Gets the value of the attribute with the specified index.

[Visual Basic] Overloads MustOverride Public Default ReadOnly Property Item(Integer) As String
[C#] public string this[int] {abstract get;}
[C++] public: __property virtual String* get_Item(int) = 0;
[JScript] XmlReader.Item (int)

Gets the value of the attribute with the specified name.

[Visual Basic] Overloads MustOverride Public Default ReadOnly Property Item(String) As String
[C#] public string this[String] {abstract get;}
[C++] public: __property virtual String* get_Item(String*) = 0;
[JScript] XmlReader.Item (String)

Gets the value of the attribute with the specified name and namespace.

[Visual Basic] Overloads MustOverride Public Default ReadOnly Property Item(String, String) As String
[C#] public string this[String, String] {abstract get;}
[C++] public: __property virtual String* get_Item(String*, String*) = 0;
[JScript] XmlReader.Item (String, String)

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.Item (Int32)

Gets the value of the attribute with the specified index.

[C#] In C#, this member is the indexer for the XmlReader class.

[Visual Basic]
Overloads MustOverride Public Default ReadOnly Property Item( _
   ByVal i As Integer _
) As String
[C#]
public string this[
   int i
] {abstract get;}
[C++]
public: __property virtual String* get_Item(
   int i
) = 0;
[JScript]
abstract returnValue = XmlReaderObject.Item(i);
-or-
abstract returnValue = XmlReaderObject(i);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

i
The index of the attribute.

Parameters [Visual Basic, C#, C++]

i
The index of the attribute.

Property Value

The value of the specified attribute.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | The i parameter is less than 0 or greater than AttributeCount.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace | XmlReader.Item Overload List | GetAttribute


XmlReader.Item (String)

Gets the value of the attribute with the specified name.

[C#] In C#, this member is the indexer for the XmlReader class.

[Visual Basic]
Overloads MustOverride Public Default ReadOnly Property Item( _
   ByVal name As String _
) As String
[C#]
public string this[
   string name
] {abstract get;}
[C++]
public: __property virtual String* get_Item(
   String* name
) = 0;
[JScript]
abstract returnValue = XmlReaderObject.Item(name);
-or-
abstract returnValue = XmlReaderObject(name);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
The name of the attribute. The name can include the prefix or leave it off.

Parameters [Visual Basic, C#, C++]

name
The name of the attribute. The name can include the prefix or leave it off.

Property Value

The value of the specified attribute. If the attribute is not found, null is returned.

Exceptions

Exception Type | Condition
ArgumentException | The attribute specified by name cannot be found in the current node.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace | XmlReader.Item Overload List | GetAttribute


XmlReader.Item (String, String)

Gets the value of the attribute with the specified name and namespace.

[C#] In C#, this member is the indexer for the XmlReader class.

[Visual Basic]
Overloads MustOverride Public Default ReadOnly Property Item( _
   ByVal name As String, _
   ByVal namespaceURI As String _
) As String
[C#]
public string this[
   string name,
   string namespaceURI
] {abstract get;}
[C++]
public: __property virtual String* get_Item(
   String* name,
   String* namespaceURI
) = 0;
[JScript]
abstract returnValue = XmlReaderObject.Item(name, namespaceURI);
-or-
abstract returnValue = XmlReaderObject(name, namespaceURI);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
The name of the attribute.
namespaceURI
[To be supplied.]

Parameters [Visual Basic, C#, C++]

name
The name of the attribute.
namespaceURI
[To be supplied.]

Property Value

The value of the specified attribute. If the attribute is not found, null is returned.

Exceptions

Exception Type | Condition
ArgumentException | The attribute specified by name and namespaceURI properties cannot be found in the current node.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace | XmlReader.Item Overload List | GetAttribute


XmlReader.LocalName

Gets the name of the current node without the namespace prefix.

[Visual Basic]
MustOverride Public ReadOnly Property LocalName As String
[C#]
public string LocalName {abstract get;}
[C++]
public: __property virtual String* get_LocalName() = 0;
[JScript]
public abstract function get LocalName() : String;

Property Value

The name of the current node with the prefix removed. For example, LocalName is yyy for the element <xxx:yyy>.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.Name

Gets the name of the current node, including the namespace prefix.

[Visual Basic]
MustOverride Public ReadOnly Property Name As String
[C#]
public string Name {abstract get;}
[C++]
public: __property virtual String* get_Name() = 0;
[JScript]
public abstract function get Name() : String;

Property Value

The qualified name of the current node. This means Name includes the namespace prefix. For example, Name is xxx:yyy for the element <xxx:yyy>.

The name returned is dependent on the NodeType of the node:

Type | Name
Attribute | name of attribute
CDATA | String.Empty
Comment | String.Empty
Document | String.Empty
DocumentFragment | String.Empty
DocumentType | document type name
Element | tag name
Entity | entity name
EntityReference | name of entity referenced
Notation | notation name
ProcessingInstruction | target
Text | String.Empty

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.NamespaceURI

Gets the namespace URN (as defined in the W3C Namespace Specification) of the current namespace scope.

[Visual Basic]
MustOverride Public ReadOnly Property NamespaceURI As String
[C#]
public string NamespaceURI {abstract get;}
[C++]
public: __property virtual String* get_NamespaceURI() = 0;
[JScript]
public abstract function get NamespaceURI() : String;

Property Value

The namespace URN of the current namespace scope.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.NameTable

Gets the XmlNameTable associated with this implementation.

[Visual Basic]
MustOverride Public ReadOnly Property NameTable As XmlNameTable
[C#]
public XmlNameTable NameTable {abstract get;}
[C++]
public: __property virtual XmlNameTable* get_NameTable() = 0;
[JScript]
public abstract function get NameTable() : XmlNameTable;

Property Value

XmlNameTable enabling you to get the atomized version of a string within the node.

Remarks

All node and attribute names returned from this class are atomized using this nametable. This means that when the same name is returned multiple times (like "Customer"), then the same String object will be returned for that name. This makes it possible for you to write efficient code that does object pointer comparisons on these strings instead of expensive string comparisons.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.NodeType

Gets the type of the current node.

[Visual Basic]
MustOverride Public ReadOnly Property NodeType As XmlNodeType
[C#]
public XmlNodeType NodeType {abstract get;}
[C++]
public: __property virtual XmlNodeType get_NodeType() = 0;
[JScript]
public abstract function get NodeType() : XmlNodeType;

Property Value

One of the XmlNodeType values.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.Prefix

Gets the namespace prefix associated with the current node.

[Visual Basic]
MustOverride Public ReadOnly Property Prefix As String
[C#]
public string Prefix {abstract get;}
[C++]
public: __property virtual String* get_Prefix() = 0;
[JScript]
public abstract function get Prefix() : String;

Property Value

The namespace prefix associated with the current node.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.QuoteChar

Gets the quotation mark character used to enclose the value of an attribute node.

[Visual Basic]
MustOverride Public ReadOnly Property QuoteChar As Char
[C#]
public char QuoteChar {abstract get;}
[C++]
public: __property virtual __wchar_t get_QuoteChar() = 0;
[JScript]
public abstract function get QuoteChar() : Char;

Property Value

The quotation mark character (" or ') used to enclose the value of an attribute node.

Remarks

This property applies only to an attribute node.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.ReadState

Returns the read state of the stream.

[Visual Basic]
MustOverride Public ReadOnly Property ReadState As ReadState
[C#]
public ReadState ReadState {abstract get;}
[C++]
public: __property virtual ReadState get_ReadState() = 0;
[JScript]
public abstract function get ReadState() : ReadState;

Property Value

One of the ReadState values.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.Value

Gets the text value of the current node.

[Visual Basic]
MustOverride Public ReadOnly Property Value As String
[C#]
public string Value {abstract get;}
[C++]
public: __property virtual String* get_Value() = 0;
[JScript]
public abstract function get Value() : String;

Property Value

The text value of the current node.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.XmlLang

Gets the current xml:lang scope.

[Visual Basic]
MustOverride Public ReadOnly Property XmlLang As String
[C#]
public string XmlLang {abstract get;}
[C++]
public: __property virtual String* get_XmlLang() = 0;
[JScript]
public abstract function get XmlLang() : String;

Property Value

The current xml:lang scope.

Remarks

This property represents the xml:lang scope within which the current node resides. For example, here is an XML fragment with xml:lang set to US English in the root element:

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.XmlSpace

Gets the current xml:space scope.

[Visual Basic]
MustOverride Public ReadOnly Property XmlSpace As XmlSpace
[C#]
public XmlSpace XmlSpace {abstract get;}
[C++]
public: __property virtual XmlSpace get_XmlSpace() = 0;
[JScript]
public abstract function get XmlSpace() : XmlSpace;

Property Value

One of the XmlSpace values. If no xml:space scope exists, this property is None.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlReader Methods

The methods of the XmlReader class are listed below. For a complete list of XmlReader class members, see the XmlReader Members topic.

Public:

Close | Closes the stream, changes the ReadState to Closed, and sets all the properties back to zero.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetAttribute | Overloaded. Gets the value of an attribute.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
LookupNamespace | Resolves a namespace prefix in the current element's scope.
MoveToAttribute Overloaded. Moves to the specified attribute.

The MoveToAttribute methods enable you to get both random access to attributes and strongly typed access to attribute values.

To get strongly typed access to an attribute value, you must do the following:

  1. Call MoveToAttribute to move to the attribute whose value you want to access.
  2. Call Read method for the data type you want (for example, ReadBoolean for boolean, ReadDate for DateTime, and so on).

After calling MoveToAttribute, the Name, Namespace, Prefix properties will reflect the properties of that attribute.
MoveToElement | Moves to the element that contains the current attribute node.
MoveToFirstAttribute | Moves to the first attribute.
MoveToNextAttribute | Moves to the next attribute.
Read | Reads the next node from the stream.
ReadAttributeValue | Parses the attribute value into one or more Text and/or EntityReference node types.
ReadBoolean | Reads the value and returns it as a bool.
ReadChar | Reads the element content one character at a time.
ReadChars | Reads the text contents of an element into a character buffer. This method is designed to read large streams of embedded text by calling it successively.
ReadCurrency | Reads the value and returns it as a Currency.
ReadDate | Reads the value and returns it as a DateTime.
ReadDecimal | Reads the value and returns it as a Decimal.
ReadDouble | Reads the value and returns it as a double.
ReadInnerXml | Reads all the content (including markup) as a string.
ReadInt16 | Reads the value and returns it as an Int16.
ReadInt32 | Reads the value and returns it as an Int32.
ReadInt64 | Reads the value and returns it as an Int64.
ReadSingle | Reads the value and returns it as a float.
ReadString | Reads the contents of an element as a string.
ReadTimeSpan | Reads the value and returns it as a TimeSpan.
ResolveEntity | Overloaded. Resolves an entity reference.
Skip | Skips to the end tag of the current element.
TagNameIs | Overloaded. Checks whether the current element has the specified name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlReader Class | System.NewXml Namespace


XmlReader.Close

Closes the stream, changes the ReadState to Closed, and sets all the properties back to zero.

[Visual Basic]
MustOverride Public Sub Close()
[C#]
public abstract void Close();
[C++]
public: virtual void Close() = 0;
[JScript]
public abstract function Close();

Remarks

This method also releases any resources held while reading. This method also calls Close on the underlying streams provided in the XmlReader constructor.

If Close has already been called, no action is performed.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.GetAttribute

Gets the value of an attribute.

Overload List

Gets the value of the attribute with the specified name and namespace.

[Visual Basic] Overloads MustOverride Public Function GetAttribute(String, String) As String
[C#] public abstract string GetAttribute(String, String);
[C++] public: virtual String* GetAttribute(String*, String*) = 0;
[JScript] public abstract function GetAttribute(String, String) : String;

Gets the value of the attribute with the specified index.

[Visual Basic] Overloads MustOverride Public Function GetAttribute(Integer) As String
[C#] public abstract string GetAttribute(int);
[C++] public: virtual String* GetAttribute(int) = 0;
[JScript] public abstract function GetAttribute(int) : String;

Gets the value of the attribute with the specified name.

[Visual Basic] Overloads MustOverride Public Function GetAttribute(String) As String
[C#] public abstract string GetAttribute(String);
[C++] public: virtual String* GetAttribute(String*) = 0;
[JScript] public abstract function GetAttribute(String) : String;

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.GetAttribute (String, String)

Gets the value of the attribute with the specified name and namespace.

[Visual Basic]
Overloads MustOverride Public Function GetAttribute( _
   ByVal name As String, _
   ByVal namespaceURI As String _
) As String
[C#]
public abstract string GetAttribute(
   string name,
   string namespaceURI
);
[C++]
public: virtual String* GetAttribute(
   String* name,
   String* namespaceURI
) = 0;
[JScript]
public abstract function GetAttribute(
   name : String,
   namespaceURI : String
) : String;

Parameters

name
The name of the attribute.
namespaceURI
[To be supplied.]

Return Value

The value of the specified attribute. If the attribute is not found, null is returned.

Exceptions

Exception Type | Condition
ArgumentException | The attribute specified by name and namespaceURI properties cannot be found in the current node.

Remarks

The following XML contains an attribute in a specific namespace:

<test xmlns:dt="urn:datatypes" dt:type="int"/>

You can lookup the dt:type attribute using one argument (using Prefix+LocalName) or using two arguments (LocalName and NamespaceURI):

String dt = reader.GetAttribute("dt:type");

String dt2 = reader.GetAttribute("type","urn:datatypes");

Note that the xmlns attributes have no namespace URI; therefore, the only way to look them up is with the short version

String dt3 = reader.GetAttribute("xmlns:dt");

You can also get this information using the Prefix property.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace | XmlReader.GetAttribute Overload List


XmlReader.GetAttribute (Int32)

Gets the value of the attribute with the specified index.

[Visual Basic]
Overloads MustOverride Public Function GetAttribute( _
   ByVal i As Integer _
) As String
[C#]
public abstract string GetAttribute(
   int i
);
[C++]
public: virtual String* GetAttribute(
   int i
) = 0;
[JScript]
public abstract function GetAttribute(
   i : int
) : String;

Parameters

i
The index of the attribute. The index is zero-based (first attribute has index 0).

Return Value

The value of the specified attribute.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | The i parameter is less than 0 or greater than or equal to AttributeCount.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace | XmlReader.GetAttribute Overload List


XmlReader.GetAttribute (String)

Gets the value of the attribute with the specified name.

[Visual Basic]
Overloads MustOverride Public Function GetAttribute( _
   ByVal name As String _
) As String
[C#]
public abstract string GetAttribute(
   string name
);
[C++]
public: virtual String* GetAttribute(
   String* name
) = 0;
[JScript]
public abstract function GetAttribute(
   name : String
) : String;

Parameters

name
The name of the attribute. The name can include the prefix or leave it off.

Return Value

The value of the specified attribute. If the attribute is not found, null is returned.

Exceptions

Exception Type | Condition
ArgumentException | The attribute specified by name cannot be found in the current node.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace | XmlReader.GetAttribute Overload List


XmlReader.LookupNamespace

Resolves a namespace prefix in the current element's scope.

[Visual Basic]
MustOverride Public Function LookupNamespace( _
   ByVal prefix As String _
) As String
[C#]
public abstract string LookupNamespace(
   string prefix
);
[C++]
public: virtual String* LookupNamespace(
   String* prefix
) = 0;
[JScript]
public abstract function LookupNamespace(
   prefix : String
) : String;

Parameters

prefix
The prefix whose namespace URN you want to resolve. To match the default namespace, pass an empty string. This string does not have to be atomized.

Return Value

The namespace URN that the prefix maps to. a null reference (in Visual Basic Nothing) if no matching prefix is found.

Remarks

For example, suppose you have the following XML:

<root xmlns:a="urn:456">
    <item>
        <ref href="a:b"/>
    </item>
</root>

When you read the href attribute with the value "a:b", you can resolve the prefix "a" by calling LookupNamespace ("a"). The returned string will be "urn:456".

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.MoveToAttribute

Moves to the specified attribute.

The MoveToAttribute methods enable you to get both random access to attributes and strongly typed access to attribute values.

To get strongly typed access to an attribute value, you must do the following:

  1. Call MoveToAttribute to move to the attribute whose value you want to access.
  2. Call Read method for the data type you want (for example, ReadBoolean for boolean, ReadDate for DateTime, and so on).

After calling MoveToAttribute, the Name, Namespace, Prefix properties will reflect the properties of that attribute.

Overload List

Moves to the attribute with the specified index.

[Visual Basic] Overloads MustOverride Public Sub MoveToAttribute(Integer)
[C#] public abstract void MoveToAttribute(int);
[C++] public: virtual void MoveToAttribute(int) = 0;
[JScript] public abstract function MoveToAttribute(int);

Moves to the attribute with the specified name and namespace.

[Visual Basic] Overloads MustOverride Public Function MoveToAttribute(String, String) As Boolean
[C#] public abstract bool MoveToAttribute(String, String);
[C++] public: virtual bool MoveToAttribute(String*, String*) = 0;
[JScript] public abstract function MoveToAttribute(String, String) : Boolean;

Moves to the attribute with the specified name.

[Visual Basic] Overloads MustOverride Public Function MoveToAttribute(String) As Boolean
[C#] public abstract bool MoveToAttribute(String);
[C++] public: virtual bool MoveToAttribute(String*) = 0;
[JScript] public abstract function MoveToAttribute(String) : Boolean;

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.MoveToAttribute (Int32)

Moves to the attribute with the specified index.

[Visual Basic]
Overloads MustOverride Public Sub MoveToAttribute( _
   ByVal i As Integer _
)
[C#]
public abstract void MoveToAttribute(
   int i
);
[C++]
public: virtual void MoveToAttribute(
   int i
) = 0;
[JScript]
public abstract function MoveToAttribute(
   i : int
);

Parameters

i
The index of the attribute.

Return Value

true if the attribute is found; otherwise, false. If false, the reader's position does not change.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | The i parameter is less than 0 or greater than AttributeCount.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace | XmlReader.MoveToAttribute Overload List


XmlReader.MoveToAttribute (String, String)

Moves to the attribute with the specified name and namespace.

[Visual Basic]
Overloads MustOverride Public Function MoveToAttribute( _
   ByVal name As String, _
   ByVal ns As String _
) As Boolean
[C#]
public abstract bool MoveToAttribute(
   string name,
   string ns
);
[C++]
public: virtual bool MoveToAttribute(
   String* name,
   String* ns
) = 0;
[JScript]
public abstract function MoveToAttribute(
   name : String,
   ns : String
) : Boolean;

Parameters

name
The name of the attribute.
ns
[To be supplied.]

Return Value

true if the attribute is found; otherwise, false. If false, the reader's position does not change.

Exceptions

Exception Type | Condition
ArgumentException | The attribute specified by name and namespaceURI properties cannot be found in the current node.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace | XmlReader.MoveToAttribute Overload List


XmlReader.MoveToAttribute (String)

Moves to the attribute with the specified name.

[Visual Basic]
Overloads MustOverride Public Function MoveToAttribute( _
   ByVal name As String _
) As Boolean
[C#]
public abstract bool MoveToAttribute(
   string name
);
[C++]
public: virtual bool MoveToAttribute(
   String* name
) = 0;
[JScript]
public abstract function MoveToAttribute(
   name : String
) : Boolean;

Parameters

name
The name of the attribute. The name can include the prefix or leave it off.

Return Value

true if the attribute is found; otherwise, false. If false, the reader's position does not change.

Exceptions

Exception Type | Condition
ArgumentException | The attribute specified by name cannot be found in the current node.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace | XmlReader.MoveToAttribute Overload List


XmlReader.MoveToElement

Moves to the element that contains the current attribute node.

[Visual Basic]
MustOverride Public Function MoveToElement() As Boolean
[C#]
public abstract bool MoveToElement();
[C++]
public: virtual bool MoveToElement() = 0;
[JScript]
public abstract function MoveToElement() : Boolean;

Return Value

true if the attribute is owned by an element; false if the attribute you are positioned on has been removed from the owning element.

Remarks

Use this method to return to an element after navigating through its attributes.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.MoveToFirstAttribute

Moves to the first attribute.

[Visual Basic]
MustOverride Public Function MoveToFirstAttribute() As Boolean
[C#]
public abstract bool MoveToFirstAttribute();
[C++]
public: virtual bool MoveToFirstAttribute() = 0;
[JScript]
public abstract function MoveToFirstAttribute() : Boolean;

Return Value

true if the first attribute exists; otherwise, false.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.MoveToNextAttribute

Moves to the next attribute.

[Visual Basic]
MustOverride Public Function MoveToNextAttribute() As Boolean
[C#]
public abstract bool MoveToNextAttribute();
[C++]
public: virtual bool MoveToNextAttribute() = 0;
[JScript]
public abstract function MoveToNextAttribute() : Boolean;

Return Value

true if there is a next attribute; false if there are no more attributes.

Remarks

If the current node is an element node, this method is equivalent to MoveToFirstAttribute.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.Read

Reads the next node from the stream.

[Visual Basic]
MustOverride Public Function Read() As Boolean
[C#]
public abstract bool Read();
[C++]
public: virtual bool Read() = 0;
[JScript]
public abstract function Read() : Boolean;

Return Value

true if the next node was read successfully; false if there are no more nodes to read.

Remarks

When an XmlReader is first created and initialized, there is no information available. You must call Read to read the first node.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.ReadAttributeValue

Parses the attribute value into one or more Text and/or EntityReference node types.

[Visual Basic]
MustOverride Public Function ReadAttributeValue() As Boolean
[C#]
public abstract bool ReadAttributeValue();
[C++]
public: virtual bool ReadAttributeValue() = 0;
[JScript]
public abstract function ReadAttributeValue() : Boolean;

Return Value

true if there are nodes to return; false if there are no more nodes to return.

Note that an empty attribute (such as, foo="") returns true with a single node with a value of String.Empty.

Remarks

For example, suppose you have the following XML:

<test name="a &b; c"/>

where the entity "b" is defined in the DTD as follows:

<!ENTITY b "123">

If the EntityHandling is set to ExpandCharEntities, this attribute value will be returned as two text nodes and one entity reference node with the following code:

[C#]

reader.MoveToAttribute("name");
while (reader.ReadAttributeValue())
{
  if (reader.NodeType == XmlNodeType.Text)
  {
    // at this point reader.Text == "a " or " c"
  }
  else if (reader.NodeType == XmlReader.EntityReference)
  {
    // at this point reader.Name == "b"
    reader.ResolveEntity();
    while (reader.ReadAttributeValue() &&
   reader.NodeType != XmlNodeType.EndEntity)
    {
      // reader.Text == "123"
    }
  }
}

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.ReadBoolean

Reads the value and returns it as a bool.

[Visual Basic]
Overridable Public Function ReadBoolean() As Boolean
[C#]
public virtual bool ReadBoolean();
[C++]
public: virtual bool ReadBoolean();
[JScript]
public function ReadBoolean() : Boolean;

Return Value

The value as a bool.

Exceptions

Exception Type | Condition
FormatException | Value cannot be converted to bool.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.ReadChar

Reads the element content one character at a time.

[Visual Basic]
MustOverride Public Function ReadChar() As Char
[C#]
public abstract char ReadChar();
[C++]
public: virtual __wchar_t ReadChar() = 0;
[JScript]
public abstract function ReadChar() : Char;

Return Value

The next character in the element content. If current position is the end of the element content, zero is returned.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.ReadChars

Reads the text contents of an element into a character buffer. This method is designed to read large streams of embedded text by calling it successively.

[Visual Basic]
MustOverride Public Function ReadChars( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
[C#]
public abstract int ReadChars(
   char[] buffer,
   int index,
   int count
);
[C++]
public: virtual int ReadChars(
   __wchar_t* buffer[],
   int index,
   int count
) = 0;
[JScript]
public abstract function ReadChars(
   buffer : Char[],
   index : int,
   count : int
) : int;

Parameters

buffer
The array of characters that serves as the buffer to which the text contents are written.
index
[To be supplied.]
count
[To be supplied.]

Return Value

The number of characters read. This can be zero if there is no more text content to return in the current context.

Remarks

This is the most efficient way to process very large streams of text embedded in an XML document as opposed to allocating large String objects. This method returns text content a buffer at a time. For example, suppose you have the following element:

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.ReadCurrency

Reads the value and returns it as a Currency.

[Visual Basic]
Overridable Public Function ReadCurrency() As Currency
[C#]
public virtual Currency ReadCurrency();
[C++]
public: virtual Currency ReadCurrency();
[JScript]
public function ReadCurrency() : Currency;

Return Value

The value as a Currency.

Exceptions

Exception Type | Condition
FormatException | Value cannot be converted to Currency.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.ReadDate

Reads the value and returns it as a DateTime.

[Visual Basic]
Overridable Public Function ReadDate() As DateTime
[C#]
public virtual DateTime ReadDate();
[C++]
public: virtual DateTime ReadDate();
[JScript]
public function ReadDate() : DateTime;

Return Value

The value as DateTime.

Exceptions

Exception Type | Condition
FormatException | Value cannot be converted to DateTime.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.ReadDecimal

Reads the value and returns it as a Decimal.

[Visual Basic]
Overridable Public Function ReadDecimal() As Decimal
[C#]
public virtual Decimal ReadDecimal();
[C++]
public: virtual Decimal ReadDecimal();
[JScript]
public function ReadDecimal() : Decimal;

Return Value

The value as a Decimal.

Exceptions

Exception Type | Condition
FormatException | Value cannot be converted to Decimal.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.ReadDouble

Reads the value and returns it as a double.

[Visual Basic]
Overridable Public Function ReadDouble() As Double
[C#]
public virtual double ReadDouble();
[C++]
public: virtual double ReadDouble();
[JScript]
public function ReadDouble() : double;

Return Value

The value as a double.

Exceptions

Exception Type | Condition
FormatException | Value cannot be converted to double.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.ReadInnerXml

Reads all the content (including markup) as a string.

[Visual Basic]
MustOverride Public Function ReadInnerXml() As String
[C#]
public abstract string ReadInnerXml();
[C++]
public: virtual String* ReadInnerXml() = 0;
[JScript]
public abstract function ReadInnerXml() : String;

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.ReadInt16

Reads the value and returns it as an Int16.

[Visual Basic]
Overridable Public Function ReadInt16() As Short
[C#]
public virtual short ReadInt16();
[C++]
public: virtual short ReadInt16();
[JScript]
public function ReadInt16() : Int16;

Return Value

The value as an Int16.

Exceptions

Exception Type | Condition
FormatException | Value cannot be converted to Int16.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.ReadInt32

Reads the value and returns it as an Int32.

[Visual Basic]
Overridable Public Function ReadInt32() As Integer
[C#]
public virtual int ReadInt32();
[C++]
public: virtual int ReadInt32();
[JScript]
public function ReadInt32() : int;

Return Value

The value as an Int32.

Exceptions

Exception Type | Condition
FormatException | Value cannot be converted to Int32.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.ReadInt64

Reads the value and returns it as an Int64.

[Visual Basic]
Overridable Public Function ReadInt64() As Long
[C#]
public virtual long ReadInt64();
[C++]
public: virtual __int64 ReadInt64();
[JScript]
public function ReadInt64() : long;

Return Value

The value as an Int64.

Exceptions

Exception Type | Condition
FormatException | Value cannot be converted to Int64.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.ReadSingle

Reads the value and returns it as a float.

[Visual Basic]
Overridable Public Function ReadSingle() As Single
[C#]
public virtual float ReadSingle();
[C++]
public: virtual float ReadSingle();
[JScript]
public function ReadSingle() : float;

Return Value

The value as a float.

Exceptions

Exception Type | Condition
FormatException | Value cannot be converted to float.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.ReadString

Reads the contents of an element as a string.

[Visual Basic]
MustOverride Public Function ReadString() As String
[C#]
public abstract string ReadString();
[C++]
public: virtual String* ReadString() = 0;
[JScript]
public abstract function ReadString() : String;

Return Value

The contents of the element.

Exceptions

Exception Type | Condition
XmlException | Markup was found instead of an end tag.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.ReadTimeSpan

Reads the value and returns it as a TimeSpan.

[Visual Basic]
Overridable Public Function ReadTimeSpan() As TimeSpan
[C#]
public virtual TimeSpan ReadTimeSpan();
[C++]
public: virtual TimeSpan ReadTimeSpan();
[JScript]
public function ReadTimeSpan() : TimeSpan;

Return Value

The value as a TimeSpan.

Exceptions

Exception Type | Condition
FormatException | Value cannot be converted to TimeSpan.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.ResolveEntity

Resolves the entity reference for nodes of NodeType EntityReference.

[Visual Basic]
MustOverride Public Sub ResolveEntity()
[C#]
public abstract void ResolveEntity();
[C++]
public: virtual void ResolveEntity() = 0;
[JScript]
public abstract function ResolveEntity();

Exceptions

Exception Type | Condition
InvalidOperationException | XmlReader is not positioned on an EntityReference node.

Remarks

If the node has NodeType of EntityReference, the entity replacement text will be parsed next and returned as child nodes. When the entity replacement text is finished, a new NodeType called "EndEntity" is returned to close the EntityReference scope.

If this method is not called, the entity reference is treated like a leaf node and the parser moves on. In this case, the entity is not parsed in context but it is validated.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.Skip

Skips to the end tag of the current element.

[Visual Basic]
MustOverride Public Sub Skip()
[C#]
public abstract void Skip();
[C++]
public: virtual void Skip() = 0;
[JScript]
public abstract function Skip();

Remarks

For example, suppose you have the following XML input:

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.TagNameIs

Checks whether the current element has the specified name.

Overload List

Checks whether the current element has both the specified name and namespace.

[Visual Basic] Overloads Public Function TagNameIs(String, String) As Boolean
[C#] public bool TagNameIs(String, String);
[C++] public: bool TagNameIs(String*, String*);
[JScript] public function TagNameIs(String, String) : Boolean;

Checks whether the current element has the specified name.

[Visual Basic] Overloads Public Function TagNameIs(String) As Boolean
[C#] public bool TagNameIs(String);
[C++] public: bool TagNameIs(String*);
[JScript] public function TagNameIs(String) : Boolean;

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace


XmlReader.TagNameIs (String, String)

Checks whether the current element has both the specified name and namespace.

[Visual Basic]
Overloads Public Function TagNameIs( _
   ByVal localName As String, _
   ByVal ns As String _
) As Boolean
[C#]
public bool TagNameIs(
   string localName,
   string ns
);
[C++]
public: bool TagNameIs(
   String* localName,
   String* ns
);
[JScript]
public function TagNameIs(
   localName : String,
   ns : String
) : Boolean;

Parameters

localName
[To be supplied.]
ns
[To be supplied.]

Return Value

true if the current element has both the specified name and namespace; otherwise, false.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace | XmlReader.TagNameIs Overload List


XmlReader.TagNameIs (String)

Checks whether the current element has the specified name.

[Visual Basic]
Overloads Public Function TagNameIs( _
   ByVal name As String _
) As Boolean
[C#]
public bool TagNameIs(
   string name
);
[C++]
public: bool TagNameIs(
   String* name
);
[JScript]
public function TagNameIs(
   name : String
) : Boolean;

Parameters

name
The name to check against the current element's name. If the current element has a namespace prefix, the name parameter should include the namespace prefix.

Return Value

true if the current element has the specified name; otherwise, false.

See Also

XmlReader Class | XmlReader Members | System.NewXml Namespace | XmlReader.TagNameIs Overload List


XmlResolver Class

Resolves external XML resources named by a URI. This class is abstract.

Object
XmlResolver

[Visual Basic]
MustInherit Public Class XmlResolver
[C#]
public abstract class XmlResolver
[C++]
public __gc __abstract class XmlResolver
[JScript]
public abstract class XmlResolver

Remarks

XmlResolver is used by XmlTextReader to load external DTD's, entities, and schemas. It is also used by XslTransform to process <xsl:include> elements.

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

XmlResolver Members | System.NewXml Namespace


XmlResolver Members

Public:

Constructor

XmlResolver Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEntity | Maps a URI to an Object containing the actual resource.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlResolver Class | System.NewXml Namespace


XmlResolver Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public XmlResolver();
[C++]
public: XmlResolver();
[JScript]
public function XmlResolver();

See Also

XmlResolver Class | XmlResolver Members | System.NewXml Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlResolver Methods

The methods of the XmlResolver class are listed below. For a complete list of XmlResolver class members, see the XmlResolver Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEntity | Maps a URI to an Object containing the actual resource.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlResolver Class | System.NewXml Namespace


XmlResolver.GetEntity

Maps a URI to an Object containing the actual resource.

[Visual Basic]
MustOverride Public Function GetEntity( _
   ByVal baseUri As String, _
   ByVal relativeUri As String, _
   ByVal role As String, _
   ByVal type As Type, _
   ByRef resolvedUri As String _
) As Object
[C#]
public abstract object GetEntity(
   string baseUri,
   string relativeUri,
   string role,
   Type type,
   ref string resolvedUri
);
[C++]
public: virtual Object* GetEntity(
   String* baseUri,
   String* relativeUri,
   String* role,
   Type* type,
   String** resolvedUri
) = 0;
[JScript]
public abstract function GetEntity(
   baseUri : String,
   relativeUri : String,
   role : String,
   type : Type,
   resolvedUri : String
) : Object;

Parameters

baseUri
The URI of the resource containing thethat we are trying to resolve. This can be also used by an HTTP resolver as the REFERRER in the HTTP header.
relativeUri
The URI to resolve.
role
A user defined string that gives the XmlResolver some clue as to how the resource is going to be used. This would map to the xlink:role and could be used as an implementation specific argument in other scenarios. In the <!DOCTYPE and <ENTITY case this argument is the PUBLIC identifier.
type
The type of object that the caller wants returned. If this argument is null it returns a Stream object.
resolvedUri
This URI is returned to the caller and may be different from the initialparameter. It is a way for the resolver to communicate with the caller what the real fully resolved identity of the returned Object actually is. Thiscan then be used as thefor any subsequent requests for resources referenced by this object.

The caller can then use this information to check for circular dependencies. Another use of this might someone who is implementing cross-domain data security policy. The returnedtakes into account any HTTP redirections- which is required for such a security mechanism to be fully secure.

Return Value

Returns the object matching the requested Type or null if the Type is not supported or if the URI is not resolvable.

Exceptions

Exception Type | Condition
Exception | if there is any sort of runtime error like a connection to a server is down, etc.

Remarks

This method is used when the caller wants to map a given URI into the Object containing the actual resource that that URI represents. The type of object returned is negotiable but the implemention must at least always support System.IO.Stream.

Other implementations may provide even higher level objects representing for even greater efficiency. For example, pre-compiled Schemas for validation or pre-compiled XSL stylesheets for use during transformation.

See Also

XmlResolver Class | XmlResolver Members | System.NewXml Namespace


XmlSpace Enumeration

Specifies the current xml:space scope.

[Visual Basic]
Public Enum XmlSpace
[C#]
public enum XmlSpace
[C++]
public enum XmlSpace

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Default | The xml:space scope equals "default".
None | No xml:space scope.
Preserve | The xml:space scope equals "preserve".

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

System.NewXml Namespace


XmlText Class

Represents the text content of an element or attribute.

Object
XmlNode
XmlLinkedNode
XmlCharacterData
XmlText

[Visual Basic]
Public Class XmlText
   Inherits XmlCharacterData
[C#]
public class XmlText : XmlCharacterData
[C++]
public __gc class XmlText : public XmlCharacterData
[JScript]
public class XmlText extends XmlCharacterData

Remarks

[To be supplied.]

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

XmlText Members | System.NewXml Namespace


XmlText Members

Public:

Properties

Attributes (inherited from XmlNode) | Gets an XmlAttributeCollection containing the attributes of this node.
ChildNodes (inherited from XmlNode) | Gets all children of this node.
Data (inherited from XmlCharacterData) | Contains this node's data.
FirstChild (inherited from XmlNode) | Gets the first child of this node.
HasChildNodes (inherited from XmlNode) | Gets a value indicating whether this node has any child nodes.
InnerText (inherited from XmlCharacterData) | Gets or sets the concatenated values of the node and all its children.
InnerXml (inherited from XmlNode) | Gets or sets the markup representing just the children of this node.
IsReadOnly (inherited from XmlNode) | Gets a value indicating whether the node is read-only.
Item (inherited from XmlNode) | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlText class.
LastChild (inherited from XmlNode) | Gets the last child of this node.
Length (inherited from XmlCharacterData) | Gets the length of the data, in characters.
LocalName | Gets the name of the current node without the namespace prefix.
Name | Gets the name of the node.
NamespaceURI (inherited from XmlNode) | Gets the namespace URI of this node.
NextSibling (inherited from XmlLinkedNode) | [To be supplied.]
NodeType | Gets the type of the current node.
OuterXml (inherited from XmlNode) | Gets the markup representing this node and all its children.
OwnerDocument (inherited from XmlNode) | Gets the XmlDocument that contains this node.
ParentNode (inherited from XmlNode) | Gets the parent of this node (for nodes that can have parents).
Prefix (inherited from XmlNode) | Gets or sets the namespace prefix of this node.
PreviousSibling (inherited from XmlLinkedNode) | [To be supplied.]
Value (inherited from XmlCharacterData) | Gets or sets the value of the node.

Methods

AppendChild (inherited from XmlNode) | Adds the specified node to the end of the list of children of this node.
AppendData (inherited from XmlCharacterData) | Appends the specified string to the end of the character data of the node.
Clone (inherited from XmlNode) | Creates a duplicate of this node.
CloneNode | Creates a duplicate of this node.
DeleteData (inherited from XmlCharacterData) | Remove a range of characters from the node.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from XmlNode) | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamespaceOfPrefix (inherited from XmlNode) | Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.
GetPrefixOfNamespace (inherited from XmlNode) | Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.
GetType (inherited from Object) | Gets the Type of the Object.
InsertAfter (inherited from XmlNode) | Inserts the specified node immediately after the specified reference node.
InsertBefore (inherited from XmlNode) | Inserts the specified node immediately before the specified reference node.
InsertData (inherited from XmlCharacterData) | Insert the specified string at the specified character offset.
Normalize (inherited from XmlNode) | Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.
PrependChild (inherited from XmlNode) | Adds the specified node to the beginning of the list of children of this node.
RemoveAll (inherited from XmlNode) | Removes all the children and/or attributes of the current node.
RemoveChild (inherited from XmlNode) | Removes specified child node.
ReplaceChild (inherited from XmlNode) | Replaces the child node oldChild with newChild node.
ReplaceData (inherited from XmlCharacterData) | Replace the specified number of characters starting at the specified offset with the specified string.
SplitText | Splits the node into two nodes at the specified offset, keeping both in the tree as siblings.
Substring (inherited from XmlCharacterData) | Retrieves a substring of the full string from the specified range.
Supports (inherited from XmlNode) | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteContentTo | Saves all the children of the node to the specified XmlWriter.
WriteTo | Saves the node to the specified XmlWriter.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlText Class | System.NewXml Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlText Properties

The properties of the XmlText class are listed below. For a complete list of XmlText class members, see the XmlText Members topic.

Public:

Attributes (inherited from XmlNode) | Gets an XmlAttributeCollection containing the attributes of this node.
ChildNodes (inherited from XmlNode) | Gets all children of this node.
Data (inherited from XmlCharacterData) | Contains this node's data.
FirstChild (inherited from XmlNode) | Gets the first child of this node.
HasChildNodes (inherited from XmlNode) | Gets a value indicating whether this node has any child nodes.
InnerText (inherited from XmlCharacterData) | Gets or sets the concatenated values of the node and all its children.
InnerXml (inherited from XmlNode) | Gets or sets the markup representing just the children of this node.
IsReadOnly (inherited from XmlNode) | Gets a value indicating whether the node is read-only.
Item (inherited from XmlNode) | Overloaded. [To be supplied.] In C#, this member is the indexer for the XmlText class.
LastChild (inherited from XmlNode) | Gets the last child of this node.
Length (inherited from XmlCharacterData) | Gets the length of the data, in characters.
LocalName | Gets the name of the current node without the namespace prefix.
Name | Gets the name of the node.
NamespaceURI (inherited from XmlNode) | Gets the namespace URI of this node.
NextSibling (inherited from XmlLinkedNode) | [To be supplied.]
NodeType | Gets the type of the current node.
OuterXml (inherited from XmlNode) | Gets the markup representing this node and all its children.
OwnerDocument (inherited from XmlNode) | Gets the XmlDocument that contains this node.
ParentNode (inherited from XmlNode) | Gets the parent of this node (for nodes that can have parents).
Prefix (inherited from XmlNode) | Gets or sets the namespace prefix of this node.
PreviousSibling (inherited from XmlLinkedNode) | [To be supplied.]
Value (inherited from XmlCharacterData) | Gets or sets the value of the node.

See Also

XmlText Class | System.NewXml Namespace


XmlText.LocalName

Gets the name of the current node without the namespace prefix.

[Visual Basic]
Overridable Public ReadOnly Property LocalName As String
[C#]
public string LocalName {override get;}
[C++]
public: __property virtual String* get_LocalName();
[JScript]
public function get LocalName() : String;

Property Value

The name of the current node with the prefix removed. For example, LocalName is yyy for the element <xxx:yyy>.

For XmlText, the name is "#text".

See Also

XmlText Class | XmlText Members | System.NewXml Namespace


XmlText.Name

Gets the name of the node.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {override get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

Property Value

The name of the node. For XmlText, the name is "#text".

See Also

XmlText Class | XmlText Members | System.NewXml Namespace


XmlText.NodeType

Gets the type of the current node.

[Visual Basic]
Overridable Public ReadOnly Property NodeType As XmlNodeType
[C#]
public XmlNodeType NodeType {override get;}
[C++]
public: __property virtual XmlNodeType get_NodeType();
[JScript]
public function get NodeType() : XmlNodeType;

Property Value

One of the XmlNodeType values.

See Also

XmlText Class | XmlText Members | System.NewXml Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlText Methods

The methods of the XmlText class are listed below. For a complete list of XmlText class members, see the XmlText Members topic.

Public:

AppendChild (inherited from XmlNode) | Adds the specified node to the end of the list of children of this node.
AppendData (inherited from XmlCharacterData) | Appends the specified string to the end of the character data of the node.
Clone (inherited from XmlNode) | Creates a duplicate of this node.
CloneNode | Creates a duplicate of this node.
DeleteData (inherited from XmlCharacterData) | Remove a range of characters from the node.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator (inherited from XmlNode) | Provides a simple ForEach-style iteration over the collection of nodes in this XmlNamedNodeMap.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamespaceOfPrefix (inherited from XmlNode) | Looks up the closest xmlns declaration for the given prefix that is in scope for the current node and returns the namespace URI in the declaration.
GetPrefixOfNamespace (inherited from XmlNode) | Looks up the closest xmlns declaration for the given namespace URI that is in scope for the current node and returns the prefix defined in that declaration.
GetType (inherited from Object) | Gets the Type of the Object.
InsertAfter (inherited from XmlNode) | Inserts the specified node immediately after the specified reference node.
InsertBefore (inherited from XmlNode) | Inserts the specified node immediately before the specified reference node.
InsertData (inherited from XmlCharacterData) | Insert the specified string at the specified character offset.
Normalize (inherited from XmlNode) | Puts all XmlText nodes in the full depth of the sub-tree underneath this XmlNode into a "normal" form where only markup (e.g., tags, comments, processing instructions, CDATA sections, and entity references) separates XmlText nodes, that is, there are no adjacent XmlText nodes.
PrependChild (inherited from XmlNode) | Adds the specified node to the beginning of the list of children of this node.
RemoveAll (inherited from XmlNode) | Removes all the children and/or attributes of the current node.
RemoveChild (inherited from XmlNode) | Removes specified child node.
ReplaceChild (inherited from XmlNode) | Replaces the child node oldChild with newChild node.
ReplaceData (inherited from XmlCharacterData) | Replace the specified number of characters starting at the specified offset with the specified string.
SplitText | Splits the node into two nodes at the specified offset, keeping both in the tree as siblings.
Substring (inherited from XmlCharacterData) | Retrieves a substring of the full string from the specified range.
Supports (inherited from XmlNode) | Test if the DOM implementation implements a specific feature.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteContentTo | Saves all the children of the node to the specified XmlWriter.
WriteTo | Saves the node to the specified XmlWriter.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlText Class | System.NewXml Namespace


XmlText.CloneNode

Creates a duplicate of this node.

[Visual Basic]
Overrides Public Function CloneNode( _
   ByVal deep As Boolean _
) As XmlNode
[C#]
public override XmlNode CloneNode(
   bool deep
);
[C++]
public: override XmlNode* CloneNode(
   bool deep
);
[JScript]
public override function CloneNode(
   deep : Boolean
) : XmlNode;

Parameters

deep
true to recursively clone the subtree under the specified node; false to clone only the node itself (and its attributes if the node is an XmlElement).

Return Value

The duplicate node.

Remarks

This method serves as a generic copy constructor for nodes. The duplicate node has no parent (ParentNode returns null).

See Also

XmlText Class | XmlText Members | System.NewXml Namespace


XmlText.SplitText

Splits the node into two nodes at the specified offset, keeping both in the tree as siblings.

[Visual Basic]
Overridable Public Function SplitText( _
   ByVal offset As Integer _
) As XmlText
[C#]
public virtual XmlText SplitText(
   int offset
);
[C++]
public: virtual XmlText* SplitText(
   int offset
);
[JScript]
public function SplitText(
   offset : int
) : XmlText;

Parameters

offset
Offset at which to split this node.

Remarks

After this method is called, this node only contains all the content up to the offset point. A new node of the same type, which is inserted as the next sibling of this node, contains all the content at and after the offset point. When the offset is equal to the length of this node, the new node has no data.

See Also

XmlText Class | XmlText Members | System.NewXml Namespace


XmlText.WriteContentTo

Saves all the children of the node to the specified XmlWriter.

[Visual Basic]
Overrides Public Sub WriteContentTo( _
   ByVal w As XmlWriter _
)
[C#]
public override void WriteContentTo(
   XmlWriter w
);
[C++]
public: override void WriteContentTo(
   XmlWriter* w
);
[JScript]
public override function WriteContentTo(
   w : XmlWriter
);

Parameters

w
The XmlWriter where you want to save the current node.

See Also

XmlText Class | XmlText Members | System.NewXml Namespace


XmlText.WriteTo

Saves the node to the specified XmlWriter.

[Visual Basic]
Overrides Public Sub WriteTo( _
   ByVal w As XmlWriter _
)
[C#]
public override void WriteTo(
   XmlWriter w
);
[C++]
public: override void WriteTo(
   XmlWriter* w
);
[JScript]
public override function WriteTo(
   w : XmlWriter
);

Parameters

w
The XmlWriter where you want to save the node.

See Also

XmlText Class | XmlText Members | System.NewXml Namespace


XmlTextReader Class

Represents a reader that provides fast, non-cached forward only stream access to XML data.

Object
XmlReader
XmlTextReader

[Visual Basic]
Public Class XmlTextReader
   Inherits XmlReader
[C#]
public class XmlTextReader : XmlReader
[C++]
public __gc class XmlTextReader : public XmlReader
[JScript]
public class XmlTextReader extends XmlReader

Remarks

This class parses text input into a sequence of XML tokens.

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

XmlTextReader Members | System.NewXml Namespace


XmlTextReader Members

Public:

Constructor

XmlTextReader Constructor Overloaded. Initializes a new instance of the XmlTextReader class.

Properties

AttributeCount | Gets the number of attributes on the current node.
BaseURI | Gets the base URI of the current node.
Depth | Gets the depth of the current node in the XML element stack.
EntityHandling | Gets or sets a value that specifies how the XmlReader handles entities.
EOF | Gets a value indicating whether XmlReader is positioned at the end of the stream.
HasAttributes (inherited from XmlReader) | Gets a value indicating whether the current node has any attributes.
HasValue | Gets a value indicating whether Value has a value to return.
IsDefault | Gets a value indicating whether the current node is an attribute that was generated from the default value defined in the DTD or schema.
IsEmptyTag | Gets a value indicating whether the current node is an empty element (for example, <MyElement/>).
Item | Overloaded. Gets the value of an attribute. This is a shortcut for the GetAttribute method. In C#, this member is the indexer for the XmlTextReader class.
LineNumber | Gets the current line number.
LinePos | Gets the current line position.
LocalName | Gets the name of the current node without the namespace prefix.
Name | Gets the name of the current node, including the namespace prefix.
Namespaces | Gets or sets a value indicating whether to do namespace support.
NamespaceURI | Gets the namespace URN (as defined in the W3C Namespace Specification) of the current namespace scope.
NameTable | Gets the XmlNameTable associated with this implementation.
NodeType | Gets the type of the current node.
Normalization | Gets or sets a value indicating whether to do whitespace normalization as defined in the XML spec.
Prefix | Gets the namespace prefix associated with the current node.
QuoteChar | Gets the quotation mark character used to enclose the value of an attribute node.
ReadState | Gets the read state of the stream.
Validation | Gets or sets the type of validation to perform at parse time.
ValidationCallback | Gets or sets a callback delegate for receiving information about DTD validation errors.
Value | Gets the text value of the current node.
WhitespaceHandling | Gets or sets a value specifying how whitespace is handled.
XmlLang | Gets the current xml:lang scope.
XmlResolver | Gets or sets the XmlResolver used for resolving URLs and/or PUBLIC Id's used in external DTDs, parameter entities, or XML schemas referenced in namespaces.
XmlSpace | Gets the current xml:space scope.

Methods

Close | Closes the stream, changes the ReadState to Closed, and sets all the properties back to zero.
CopySettings | Copies all settings from the specified XmlTextReader, including the EntityHandling, Namespaces, Normalization, DecodeNames, WhitespaceHandling, Validation and Filter properties.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetAttribute | Overloaded. Gets the value of an attribute.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
LookupNamespace | Resolves a namespace prefix in the current element's scope.
MoveToAttribute Overloaded. Move to the specified attribute.

The MoveToAttribute methods enable you to get both random access to attributes and strongly typed access to attribute values.

To get strongly typed access to an attribute value, you must do the following:

  1. Call MoveToAttribute to move to the attribute whose value you want to access.
  2. Call Read method for the data type you want (for example, ReadBoolean for boolean, ReadDate for DateTime, and so on).

After calling MoveToAttribute, the Name, Namespace, Prefix properties will reflect the properties of that attribute.
MoveToElement | Moves to the element that contains the current attribute node.
MoveToFirstAttribute | Moves to the first attribute.
MoveToNextAttribute | Moves to the next attribute.
Read | Reads the next node from the stream.
ReadAttributeValue | Parses the attribute value into one or more Text and/or EntityReference node types.
ReadBoolean (inherited from XmlReader) | Reads the value and returns it as a bool.
ReadChar | Reads the element content one character at a time.
ReadChars | Reads the text contents of an element into a character buffer. This method is designed to read large streams of embedded text by calling it successively.
ReadCurrency (inherited from XmlReader) | Reads the value and returns it as a Currency.
ReadDate (inherited from XmlReader) | Reads the value and returns it as a DateTime.
ReadDecimal (inherited from XmlReader) | Reads the value and returns it as a Decimal.
ReadDouble (inherited from XmlReader) | Reads the value and returns it as a double.
ReadInnerXml | Reads all the content (including markup) as a string.
ReadInt16 (inherited from XmlReader) | Reads the value and returns it as an Int16.
ReadInt32 (inherited from XmlReader) | Reads the value and returns it as an Int32.
ReadInt64 (inherited from XmlReader) | Reads the value and returns it as an Int64.
ReadSingle (inherited from XmlReader) | Reads the value and returns it as a float.
ReadString | Reads the contents of an element as a string.
ReadTimeSpan (inherited from XmlReader) | Reads the value and returns it as a TimeSpan.
ResolveEntity | Overloaded. Resolves an entity reference.
Skip | Skips to the end tag of the current element.
TagNameIs (inherited from XmlReader) | Overloaded. Checks whether the current element has the specified name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Constructor

XmlTextReader Constructor Overloaded. Initializes a new instance of the XmlTextReader class.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlTextReader Class | System.NewXml Namespace


XmlTextReader Constructor

Initializes a new instance of the XmlTextReader class.

Overload List

Initializes a new instance of the XmlTextReader class with the specified XmlNameTable.

[Visual Basic] Overloads Protected Sub New(XmlNameTable)
[C#] protected XmlTextReader(XmlNameTable);
[C++] protected: XmlTextReader(XmlNameTable*);
[JScript] protected function XmlTextReader(XmlNameTable);

Initializes a new instance of the XmlTextReader class.

[Visual Basic] Overloads Public Sub New()
[C#] public XmlTextReader();
[C++] public: XmlTextReader();
[JScript] public function XmlTextReader();

Initializes a new instance of the XmlTextReader class with the specified stream and XmlNameTable.

[Visual Basic] Overloads Public Sub New(Stream, XmlNameTable)
[C#] public XmlTextReader(Stream, XmlNameTable);
[C++] public: XmlTextReader(Stream*, XmlNameTable);
[JScript] public function XmlTextReader(Stream, XmlNameTable);

Initializes a new instance of the XmlTextReader class with the specified TextReader and XmlNameTable.

[Visual Basic] Overloads Public Sub New(TextReader, XmlNameTable)
[C#] public XmlTextReader(TextReader, XmlNameTable);
[C++] public: XmlTextReader(TextReader*, XmlNameTable);
[JScript] public function XmlTextReader(TextReader, XmlNameTable);

Initializes a new instance of the XmlTextReader class with the specified file and XmlNameTable.

[Visual Basic] Overloads Public Sub New(String, XmlNameTable)
[C#] public XmlTextReader(String, XmlNameTable);
[C++] public: XmlTextReader(String*, XmlNameTable);
[JScript] public function XmlTextReader(String, XmlNameTable);

Initializes a new instance of the XmlTextReader class with the specified stream.

[Visual Basic] Overloads Public Sub New(Stream)
[C#] public XmlTextReader(Stream);
[C++] public: XmlTextReader(Stream*);
[JScript] public function XmlTextReader(Stream);

Initializes a new instance of the XmlTextReader class with the specified TextReader.

[Visual Basic] Overloads Public Sub New(TextReader)
[C#] public XmlTextReader(TextReader);
[C++] public: XmlTextReader(TextReader*);
[JScript] public function XmlTextReader(TextReader);

Initializes a new instance of the XmlTextReader class with the specified file.

[Visual Basic] Overloads Public Sub New(String)
[C#] public XmlTextReader(String);
[C++] public: XmlTextReader(String*);
[JScript] public function XmlTextReader(String);

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader Constructor (XmlNameTable)

Initializes a new instance of the XmlTextReader class with the specified XmlNameTable.

[Visual Basic]
Overloads Protected Sub New( _
   ByVal nt As XmlNameTable _
)
[C#]
protected XmlTextReader(
   XmlNameTable nt
);
[C++]
protected: XmlTextReader(
   XmlNameTable* nt
);
[JScript]
protected function XmlTextReader(
   nt : XmlNameTable
);

Parameters

nt
The XmlNameTable to use.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace | XmlTextReader Constructor Overload List


XmlTextReader Constructor ()

Initializes a new instance of the XmlTextReader class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public XmlTextReader();
[C++]
public: XmlTextReader();
[JScript]
public function XmlTextReader();

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace | XmlTextReader Constructor Overload List


XmlTextReader Constructor (Stream, XmlNameTable)

Initializes a new instance of the XmlTextReader class with the specified stream and XmlNameTable.

[Visual Basic]
Overloads Public Sub New( _
   ByVal input As Stream, _
   ByVal nt As XmlNameTable _
)
[C#]
public XmlTextReader(
   Stream input,
   XmlNameTable nt
);
[C++]
public: XmlTextReader(
   Stream* input,
   XmlNameTable* nt
);
[JScript]
public function XmlTextReader(
   input : Stream,
   nt : XmlNameTable
);

Parameters

input
The stream containing the XML data to read.
nt
The XmlNameTable to use.

Remarks

The XmlTextReader will properly decode this stream by wrapping this stream in a StreamReader and calling SwitchEncoding according to the rules for XML encoding.

The XmlResolver is used to resolve external resources needed to correctly parse the input such as DTDs, schemas, entities and <xml:include> elements.

If you specify a name table, this constructor will use the names defined already in that table.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace | XmlTextReader Constructor Overload List


XmlTextReader Constructor (TextReader, XmlNameTable)

Initializes a new instance of the XmlTextReader class with the specified TextReader and XmlNameTable.

[Visual Basic]
Overloads Public Sub New( _
   ByVal input As TextReader, _
   ByVal nt As XmlNameTable _
)
[C#]
public XmlTextReader(
   TextReader input,
   XmlNameTable nt
);
[C++]
public: XmlTextReader(
   TextReader* input,
   XmlNameTable* nt
);
[JScript]
public function XmlTextReader(
   input : TextReader,
   nt : XmlNameTable
);

Parameters

input
The TextReader containing the XML data to read.
nt
The XmlNameTable to use.

Remarks

It is assumed that the TextReader is already set to the correct encoding. This is used by clients who have already read some things from the stream in a multi-part MIME scenario.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace | XmlTextReader Constructor Overload List


XmlTextReader Constructor (String, XmlNameTable)

Initializes a new instance of the XmlTextReader class with the specified file and XmlNameTable.

[Visual Basic]
Overloads Public Sub New( _
   ByVal url As String, _
   ByVal nt As XmlNameTable _
)
[C#]
public XmlTextReader(
   string url,
   XmlNameTable nt
);
[C++]
public: XmlTextReader(
   String* url,
   XmlNameTable* nt
);
[JScript]
public function XmlTextReader(
   url : String,
   nt : XmlNameTable
);

Parameters

url
The URL for the file containing the XML data to read.
nt
The XmlNameTable to use.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace | XmlTextReader Constructor Overload List


XmlTextReader Constructor (Stream)

Initializes a new instance of the XmlTextReader class with the specified stream.

[Visual Basic]
Overloads Public Sub New( _
   ByVal input As Stream _
)
[C#]
public XmlTextReader(
   Stream input
);
[C++]
public: XmlTextReader(
   Stream* input
);
[JScript]
public function XmlTextReader(
   input : Stream
);

Parameters

input
The stream containing the XML data to read.

Remarks

The XmlTextReader will properly decode this stream by wrapping this stream in a StreamReader and calling SwitchEncoding according to the rules for XML encoding.

The XmlResolver is used to resolve external resources needed to correctly parse the input such as DTDs, schemas, entities and <xml:include> elements.

The default XmlNameTable is the rental model "NameTable" class.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace | XmlTextReader Constructor Overload List


XmlTextReader Constructor (TextReader)

Initializes a new instance of the XmlTextReader class with the specified TextReader.

[Visual Basic]
Overloads Public Sub New( _
   ByVal input As TextReader _
)
[C#]
public XmlTextReader(
   TextReader input
);
[C++]
public: XmlTextReader(
   TextReader* input
);
[JScript]
public function XmlTextReader(
   input : TextReader
);

Parameters

input
The TextReader containing the XML data to read.

Remarks

It is assumed that the TextReader is already set to the correct encoding. This is used by clients who have already read some things from the stream in a multi-part MIME scenario.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace | XmlTextReader Constructor Overload List


XmlTextReader Constructor (String)

Initializes a new instance of the XmlTextReader class with the specified file.

[Visual Basic]
Overloads Public Sub New( _
   ByVal url As String _
)
[C#]
public XmlTextReader(
   string url
);
[C++]
public: XmlTextReader(
   String* url
);
[JScript]
public function XmlTextReader(
   url : String
);

Parameters

url
The URL for the file containing the XML data to read.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace | XmlTextReader Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlTextReader Properties

The properties of the XmlTextReader class are listed below. For a complete list of XmlTextReader class members, see the XmlTextReader Members topic.

Public:

AttributeCount | Gets the number of attributes on the current node.
BaseURI | Gets the base URI of the current node.
Depth | Gets the depth of the current node in the XML element stack.
EntityHandling | Gets or sets a value that specifies how the XmlReader handles entities.
EOF | Gets a value indicating whether XmlReader is positioned at the end of the stream.
HasAttributes (inherited from XmlReader) | Gets a value indicating whether the current node has any attributes.
HasValue | Gets a value indicating whether Value has a value to return.
IsDefault | Gets a value indicating whether the current node is an attribute that was generated from the default value defined in the DTD or schema.
IsEmptyTag | Gets a value indicating whether the current node is an empty element (for example, <MyElement/>).
Item | Overloaded. Gets the value of an attribute. This is a shortcut for the GetAttribute method. In C#, this member is the indexer for the XmlTextReader class.
LineNumber | Gets the current line number.
LinePos | Gets the current line position.
LocalName | Gets the name of the current node without the namespace prefix.
Name | Gets the name of the current node, including the namespace prefix.
Namespaces | Gets or sets a value indicating whether to do namespace support.
NamespaceURI | Gets the namespace URN (as defined in the W3C Namespace Specification) of the current namespace scope.
NameTable | Gets the XmlNameTable associated with this implementation.
NodeType | Gets the type of the current node.
Normalization | Gets or sets a value indicating whether to do whitespace normalization as defined in the XML spec.
Prefix | Gets the namespace prefix associated with the current node.
QuoteChar | Gets the quotation mark character used to enclose the value of an attribute node.
ReadState | Gets the read state of the stream.
Validation | Gets or sets the type of validation to perform at parse time.
ValidationCallback | Gets or sets a callback delegate for receiving information about DTD validation errors.
Value | Gets the text value of the current node.
WhitespaceHandling | Gets or sets a value specifying how whitespace is handled.
XmlLang | Gets the current xml:lang scope.
XmlResolver | Gets or sets the XmlResolver used for resolving URLs and/or PUBLIC Id's used in external DTDs, parameter entities, or XML schemas referenced in namespaces.
XmlSpace | Gets the current xml:space scope.

See Also

XmlTextReader Class | System.NewXml Namespace


XmlTextReader.AttributeCount

Gets the number of attributes on the current node.

[Visual Basic]
Overridable Public ReadOnly Property AttributeCount As Integer
[C#]
public int AttributeCount {override get;}
[C++]
public: __property virtual int get_AttributeCount();
[JScript]
public function get AttributeCount() : int;

Property Value

Count of attributes on the current node.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.BaseURI

Gets the base URI of the current node.

[Visual Basic]
Overridable Public ReadOnly Property BaseURI As String
[C#]
public string BaseURI {override get;}
[C++]
public: __property virtual String* get_BaseURI();
[JScript]
public function get BaseURI() : String;

Property Value

The base URI of the current node. The string returned is also in NameTable.

Remarks

A "networked" XML document is comprised of chunks of data aggregated using various W3C standard inclusion mechanisms and therefore contains nodes that come from different places. DTD Entities are an example of this--but this is not limited to DTD's. The BaseURI tells you where these nodes came from. If there is no base URI for the nodes being returned (maybe they were parsed from an in-memory string), String.Empty is returned.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.Depth

Gets the depth of the current node in the XML element stack.

[Visual Basic]
Overridable Public ReadOnly Property Depth As Integer
[C#]
public int Depth {override get;}
[C++]
public: __property virtual int get_Depth();
[JScript]
public function get Depth() : int;

Property Value

The depth of the current node in the XML element stack.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.EntityHandling

Gets or sets a value that specifies how the XmlReader handles entities.

[Visual Basic]
Overridable Public Property EntityHandling As EntityHandling
[C#]
public EntityHandling EntityHandling {override get; override set;}
[C++]
public: __property virtual EntityHandling get_EntityHandling();
public: __property virtual void set_EntityHandling(EntityHandling);
[JScript]
public function get EntityHandling() : EntityHandling;
public function set EntityHandling(EntityHandling);

Property Value

One of the EntityHandling values.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | Invalid value was specified.

Remarks

This property can be changed on the fly and the new behavior begins after the next Read call.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.EOF

Gets a value indicating whether XmlReader is positioned at the end of the stream.

[Visual Basic]
Overridable Public ReadOnly Property EOF As Boolean
[C#]
public bool EOF {override get;}
[C++]
public: __property virtual bool get_EOF();
[JScript]
public function get EOF() : Boolean;

Property Value

true if XmlReader is positioned at the end of the stream; otherwise, false.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.HasValue

Gets a value indicating whether Value has a value to return.

[Visual Basic]
Overridable Public ReadOnly Property HasValue As Boolean
[C#]
public bool HasValue {override get;}
[C++]
public: __property virtual bool get_HasValue();
[JScript]
public function get HasValue() : Boolean;

Property Value

true if Value has a value to return or if any more content can be returned from the partial content read methods; otherwise, false.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.IsDefault

Gets a value indicating whether the current node is an attribute that was generated from the default value defined in the DTD or schema.

[Visual Basic]
Overridable Public ReadOnly Property IsDefault As Boolean
[C#]
public bool IsDefault {override get;}
[C++]
public: __property virtual bool get_IsDefault();
[JScript]
public function get IsDefault() : Boolean;

Property Value

true if the the current node is an attribute whose value was generated from the default value defined in the DTD or schema.

false if the attribute's value was explicitly specified in the XML stream.

Remarks

This property applies only to an attribute node.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.IsEmptyTag

Gets a value indicating whether the current node is an empty element (for example, <MyElement/>).

[Visual Basic]
Overridable Public ReadOnly Property IsEmptyTag As Boolean
[C#]
public bool IsEmptyTag {override get;}
[C++]
public: __property virtual bool get_IsEmptyTag();
[JScript]
public function get IsEmptyTag() : Boolean;

Property Value

true if the current node is an element (NodeType equals Element) that ends with "/>"; otherwise, false.

Remarks

This property enables you to determine the difference between the following:

<foo bar="123"/> (IsEmptyTag is true).

<foo bar="123"> (IsEmptyTag is false)

Note that a corresponding EndTag element is not generated for empty elements.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.Item

Gets the value of an attribute. This is a shortcut for the GetAttribute method.

[C#] In C#, this member is the indexer for the XmlTextReader class.

Overload List

Gets the value of the attribute with the specified index.

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(Integer) As String
[C#] public string this[int] {override get;}
[C++] public: __property virtual String* get_Item(int);
[JScript] XmlTextReader.Item (int)

Gets the value of the attribute with the specified name and namespace.

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(String, String) As String
[C#] public string this[String, String] {override get;}
[C++] public: __property virtual String* get_Item(String*, String*);
[JScript] XmlTextReader.Item (String, String)

Gets the value of the attribute with the specified name.

[Visual Basic] Overloads Overridable Public Default ReadOnly Property Item(String) As String
[C#] public string this[String] {override get;}
[C++] public: __property virtual String* get_Item(String*);
[JScript] XmlTextReader.Item (String)

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.Item (Int32)

Gets the value of the attribute with the specified index.

[C#] In C#, this member is the indexer for the XmlTextReader class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal i As Integer _
) As String
[C#]
public string this[
   int i
] {override get;}
[C++]
public: __property virtual String* get_Item(
   int i
);
[JScript]
returnValue = XmlTextReaderObject.Item(i);
-or-
returnValue = XmlTextReaderObject(i);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

i
The index of the attribute.

Parameters [Visual Basic, C#, C++]

i
The index of the attribute.

Property Value

The value of the specified attribute.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | The i parameter is less than 0 or greater than AttributeCount.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace | XmlTextReader.Item Overload List | GetAttribute


XmlTextReader.Item (String, String)

Gets the value of the attribute with the specified name and namespace.

[C#] In C#, this member is the indexer for the XmlTextReader class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal name As String, _
   ByVal namespaceURI As String _
) As String
[C#]
public string this[
   string name,
   string namespaceURI
] {override get;}
[C++]
public: __property virtual String* get_Item(
   String* name,
   String* namespaceURI
);
[JScript]
returnValue = XmlTextReaderObject.Item(name, namespaceURI);
-or-
returnValue = XmlTextReaderObject(name, namespaceURI);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
The name of the attribute.
namespaceURI
[To be supplied.]

Parameters [Visual Basic, C#, C++]

name
The name of the attribute.
namespaceURI
[To be supplied.]

Property Value

The value of the specified attribute. If the attribute is not found, null is returned.

Exceptions

Exception Type | Condition
ArgumentException | The attribute specified by name and namespaceURI properties cannot be found in the current node.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace | XmlTextReader.Item Overload List | GetAttribute


XmlTextReader.Item (String)

Gets the value of the attribute with the specified name.

[C#] In C#, this member is the indexer for the XmlTextReader class.

[Visual Basic]
Overloads Overridable Public Default ReadOnly Property Item( _
   ByVal name As String _
) As String
[C#]
public string this[
   string name
] {override get;}
[C++]
public: __property virtual String* get_Item(
   String* name
);
[JScript]
returnValue = XmlTextReaderObject.Item(name);
-or-
returnValue = XmlTextReaderObject(name);

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

name
The name of the attribute. The name can include the prefix or leave it off.

Parameters [Visual Basic, C#, C++]

name
The name of the attribute. The name can include the prefix or leave it off.

Property Value

The value of the specified attribute. If the attribute is not found, null is returned.

Exceptions

Exception Type | Condition
ArgumentException | The attribute specified by name cannot be found in the current node.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace | XmlTextReader.Item Overload List | GetAttribute


XmlTextReader.LineNumber

Gets the current line number.

[Visual Basic]
Public ReadOnly Property LineNumber As Integer
[C#]
public int LineNumber {get;}
[C++]
public: __property int get_LineNumber();
[JScript]
public function get LineNumber() : int;

Property Value

The current line number.

Remarks

This is mostly used for error reporting, but can be called any time.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.LinePos

Gets the current line position.

[Visual Basic]
Public ReadOnly Property LinePos As Integer
[C#]
public int LinePos {get;}
[C++]
public: __property int get_LinePos();
[JScript]
public function get LinePos() : int;

Property Value

The current line position.

Remarks

This is mostly used for error reporting, but can be called any time.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.LocalName

Gets the name of the current node without the namespace prefix.

[Visual Basic]
Overridable Public ReadOnly Property LocalName As String
[C#]
public string LocalName {override get;}
[C++]
public: __property virtual String* get_LocalName();
[JScript]
public function get LocalName() : String;

Property Value

The name of the current node with the prefix removed. For example, LocalName is yyy for the element <xxx:yyy>.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.Name

Gets the name of the current node, including the namespace prefix.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {override get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

Property Value

The qualified name of the current node. This means Name includes the namespace prefix. For example, Name is xxx:yyy for the element <xxx:yyy>.

The name returned is dependent on the NodeType of the node:

Type | Name
Attribute | name of attribute
CDATA | #cdata-section
Comment | #comment
Document | #document
DocumentFragment | #document-fragment
DocumentType | document type name
Element | tag name
Entity | entity name
EntityReference | name of entity referenced
Notation | notation name
ProcessingInstruction | target
Text | #text

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.Namespaces

Gets or sets a value indicating whether to do namespace support.

[Visual Basic]
Public Property Namespaces As Boolean
[C#]
public bool Namespaces {get; set;}
[C++]
public: __property bool get_Namespaces();
public: __property void set_Namespaces(bool);
[JScript]
public function get Namespaces() : Boolean;
public function set Namespaces(Boolean);

Property Value

true to do namespace support; otherwise, false. Default is true.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.NamespaceURI

Gets the namespace URN (as defined in the W3C Namespace Specification) of the current namespace scope.

[Visual Basic]
Overridable Public ReadOnly Property NamespaceURI As String
[C#]
public string NamespaceURI {override get;}
[C++]
public: __property virtual String* get_NamespaceURI();
[JScript]
public function get NamespaceURI() : String;

Property Value

The namespace URN of the current namespace scope.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.NameTable

Gets the XmlNameTable associated with this implementation.

[Visual Basic]
Overridable Public ReadOnly Property NameTable As XmlNameTable
[C#]
public XmlNameTable NameTable {override get;}
[C++]
public: __property virtual XmlNameTable* get_NameTable();
[JScript]
public function get NameTable() : XmlNameTable;

Property Value

XmlNameTable enabling you to get the atomized version of a string within the node.

Remarks

All node and attribute names returned from this class are atomized using this nametable. This means that when the same name is returned multiple times (like "Customer"), then the same String object will be returned for that name. This makes it possible for you to write efficient code that does object pointer comparisons on these strings instead of expensive string comparisons.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.NodeType

Gets the type of the current node.

[Visual Basic]
Overridable Public ReadOnly Property NodeType As XmlNodeType
[C#]
public XmlNodeType NodeType {override get;}
[C++]
public: __property virtual XmlNodeType get_NodeType();
[JScript]
public function get NodeType() : XmlNodeType;

Property Value

One of the XmlNodeType values.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.Normalization

Gets or sets a value indicating whether to do whitespace normalization as defined in the XML spec.

[Visual Basic]
Public Property Normalization As Boolean
[C#]
public bool Normalization {get; set;}
[C++]
public: __property bool get_Normalization();
public: __property void set_Normalization(bool);
[JScript]
public function get Normalization() : Boolean;
public function set Normalization(Boolean);

Property Value

true to do whitespace normalization; otherwise, false. Default is false.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.Prefix

Gets the namespace prefix associated with the current node.

[Visual Basic]
Overridable Public ReadOnly Property Prefix As String
[C#]
public string Prefix {override get;}
[C++]
public: __property virtual String* get_Prefix();
[JScript]
public function get Prefix() : String;

Property Value

The namespace prefix associated with the current node.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.QuoteChar

Gets the quotation mark character used to enclose the value of an attribute node.

[Visual Basic]
Overridable Public ReadOnly Property QuoteChar As Char
[C#]
public char QuoteChar {override get;}
[C++]
public: __property virtual __wchar_t get_QuoteChar();
[JScript]
public function get QuoteChar() : Char;

Property Value

The quotation mark character (" or ') used to enclose the value of an attribute node.

Remarks

This property applies only to an attribute node.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.ReadState

Gets the read state of the stream.

[Visual Basic]
Overridable Public ReadOnly Property ReadState As ReadState
[C#]
public ReadState ReadState {override get;}
[C++]
public: __property virtual ReadState get_ReadState();
[JScript]
public function get ReadState() : ReadState;

Property Value

One of the ReadState values.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.Validation

Gets or sets the type of validation to perform at parse time.

[Visual Basic]
Public Property Validation As Validation
[C#]
public Validation Validation {get; set;}
[C++]
public: __property Validation get_Validation();
public: __property void set_Validation(Validation);
[JScript]
public function get Validation() : Validation;
public function set Validation(Validation);

Property Value

One of the Validation values. The default is Auto.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | Invalid value was specified.

Remarks

When external DTDs or schemas are needed for validation, the XmlResolver is used. If no XmlResolver is available a validation error is raised.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.ValidationCallback

Gets or sets a callback delegate for receiving information about DTD validation errors.

[Visual Basic]
Public Property ValidationCallback As ValidationDelegate
[C#]
public ValidationDelegate ValidationCallback {get; set;}
[C++]
public: __property ValidationDelegate* get_ValidationCallback();
public: __property void set_ValidationCallback(ValidationDelegate*);
[JScript]
public function get ValidationCallback() : ValidationDelegate;
public function set ValidationCallback(ValidationDelegate);

Property Value

The ValidationDelegate to be called when a validation error occurs.

Remarks

The ValidationDelegate is only called if the DTDValidation or SchemaValidation flags are specified and only during Read(). If no delegate is provided,you will get the middle ground which is entity handling, default attributes, and data typing with no validation errors. The parser will not stop on any kind of validation error. It only stops when it hits a well-formedness error.

Note: A "validation Error" is any error listed in the W3C as "Validity Constraint:". If a given element reports a validity error via this callback because the content model does not match then the rest of the content model for that element is not validated (but it's children are validated). In other words, once the validator reaches the error state for a given element it does not keep reporting more and more errors for that element, it only reports the first error.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.Value

Gets the text value of the current node.

[Visual Basic]
Overridable Public ReadOnly Property Value As String
[C#]
public string Value {override get;}
[C++]
public: __property virtual String* get_Value();
[JScript]
public function get Value() : String;

Property Value

The text value of the current node.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.WhitespaceHandling

Gets or sets a value specifying how whitespace is handled.

[Visual Basic]
Public Property WhitespaceHandling As WhitespaceHandling
[C#]
public WhitespaceHandling WhitespaceHandling {get; set;}
[C++]
public: __property WhitespaceHandling get_WhitespaceHandling();
public: __property void set_WhitespaceHandling(WhitespaceHandling);
[JScript]
public function get WhitespaceHandling() : WhitespaceHandling;
public function set WhitespaceHandling(WhitespaceHandling);

Property Value

One of the WhitespaceHandling values. The default is All.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.XmlLang

Gets the current xml:lang scope.

[Visual Basic]
Overridable Public ReadOnly Property XmlLang As String
[C#]
public string XmlLang {override get;}
[C++]
public: __property virtual String* get_XmlLang();
[JScript]
public function get XmlLang() : String;

Property Value

The current xml:lang scope.

Remarks

This property represents the xml:lang scope within which the current node resides. For example, here is an XML fragment with xml:lang set to US English in the root element:

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.XmlResolver

Gets or sets the XmlResolver used for resolving URLs and/or PUBLIC Id's used in external DTDs, parameter entities, or XML schemas referenced in namespaces.

[Visual Basic]
Public Property XmlResolver As XmlResolver
[C#]
public XmlResolver XmlResolver {get; set;}
[C++]
public: __property XmlResolver* get_XmlResolver();
public: __property void set_XmlResolver(XmlResolver*);
[JScript]
public function get XmlResolver() : XmlResolver;
public function set XmlResolver(XmlResolver);

Property Value

The XmlResolver to use.

Remarks

This is only called if the DTDValidation or SchemaValidation flags are set. It is called the first time a reference to an external entity is found.

In the SchemaValidation case the UriResolver is also called before the first Read() to see if there is a schema for the null namespace.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.XmlSpace

Gets the current xml:space scope.

[Visual Basic]
Overridable Public ReadOnly Property XmlSpace As XmlSpace
[C#]
public XmlSpace XmlSpace {override get;}
[C++]
public: __property virtual XmlSpace get_XmlSpace();
[JScript]
public function get XmlSpace() : XmlSpace;

Property Value

One of the XmlSpace values. If no xml:space scope exists, this property is None.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlTextReader Methods

The methods of the XmlTextReader class are listed below. For a complete list of XmlTextReader class members, see the XmlTextReader Members topic.

Public:

Close | Closes the stream, changes the ReadState to Closed, and sets all the properties back to zero.
CopySettings | Copies all settings from the specified XmlTextReader, including the EntityHandling, Namespaces, Normalization, DecodeNames, WhitespaceHandling, Validation and Filter properties.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetAttribute | Overloaded. Gets the value of an attribute.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
LookupNamespace | Resolves a namespace prefix in the current element's scope.
MoveToAttribute Overloaded. Move to the specified attribute.

The MoveToAttribute methods enable you to get both random access to attributes and strongly typed access to attribute values.

To get strongly typed access to an attribute value, you must do the following:

  1. Call MoveToAttribute to move to the attribute whose value you want to access.
  2. Call Read method for the data type you want (for example, ReadBoolean for boolean, ReadDate for DateTime, and so on).

After calling MoveToAttribute, the Name, Namespace, Prefix properties will reflect the properties of that attribute.
MoveToElement | Moves to the element that contains the current attribute node.
MoveToFirstAttribute | Moves to the first attribute.
MoveToNextAttribute | Moves to the next attribute.
Read | Reads the next node from the stream.
ReadAttributeValue | Parses the attribute value into one or more Text and/or EntityReference node types.
ReadBoolean (inherited from XmlReader) | Reads the value and returns it as a bool.
ReadChar | Reads the element content one character at a time.
ReadChars | Reads the text contents of an element into a character buffer. This method is designed to read large streams of embedded text by calling it successively.
ReadCurrency (inherited from XmlReader) | Reads the value and returns it as a Currency.
ReadDate (inherited from XmlReader) | Reads the value and returns it as a DateTime.
ReadDecimal (inherited from XmlReader) | Reads the value and returns it as a Decimal.
ReadDouble (inherited from XmlReader) | Reads the value and returns it as a double.
ReadInnerXml | Reads all the content (including markup) as a string.
ReadInt16 (inherited from XmlReader) | Reads the value and returns it as an Int16.
ReadInt32 (inherited from XmlReader) | Reads the value and returns it as an Int32.
ReadInt64 (inherited from XmlReader) | Reads the value and returns it as an Int64.
ReadSingle (inherited from XmlReader) | Reads the value and returns it as a float.
ReadString | Reads the contents of an element as a string.
ReadTimeSpan (inherited from XmlReader) | Reads the value and returns it as a TimeSpan.
ResolveEntity | Overloaded. Resolves an entity reference.
Skip | Skips to the end tag of the current element.
TagNameIs (inherited from XmlReader) | Overloaded. Checks whether the current element has the specified name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlTextReader Class | System.NewXml Namespace


XmlTextReader.Close

Closes the stream, changes the ReadState to Closed, and sets all the properties back to zero.

[Visual Basic]
Overrides Public Sub Close()
[C#]
public override void Close();
[C++]
public: override void Close();
[JScript]
public override function Close();

Remarks

This method also releases any resources held while reading. This method also calls Close on the underlying streams provided in the XmlReader constructor.

If Close has already been called, no action is performed.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.CopySettings

Copies all settings from the specified XmlTextReader, including the EntityHandling, Namespaces, Normalization, DecodeNames, WhitespaceHandling, Validation and Filter properties.

[Visual Basic]
Public Sub CopySettings( _
   ByVal other As XmlTextReader _
)
[C#]
public void CopySettings(
   XmlTextReader other
);
[C++]
public: void CopySettings(
   XmlTextReader* other
);
[JScript]
public function CopySettings(
   other : XmlTextReader
);

Parameters

other
The XmlTextReader whose settings you want to copy to this XmlTextReader.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.GetAttribute

Gets the value of an attribute.

Overload List

Gets the value of the attribute with the specified index.

[Visual Basic] Overloads Overrides Public Function GetAttribute(Integer) As String
[C#] public override string GetAttribute(int);
[C++] public: override String* GetAttribute(int);
[JScript] public override function GetAttribute(int) : String;

Gets the value of the attribute with the specified name and namespace.

[Visual Basic] Overloads Overrides Public Function GetAttribute(String, String) As String
[C#] public override string GetAttribute(String, String);
[C++] public: override String* GetAttribute(String*, String*);
[JScript] public override function GetAttribute(String, String) : String;

Gets the value of the attribute with the specified name.

[Visual Basic] Overloads Overrides Public Function GetAttribute(String) As String
[C#] public override string GetAttribute(String);
[C++] public: override String* GetAttribute(String*);
[JScript] public override function GetAttribute(String) : String;

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.GetAttribute (Int32)

Gets the value of the attribute with the specified index.

[Visual Basic]
Overloads Overrides Public Function GetAttribute( _
   ByVal i As Integer _
) As String
[C#]
public override string GetAttribute(
   int i
);
[C++]
public: override String* GetAttribute(
   int i
);
[JScript]
public override function GetAttribute(
   i : int
) : String;

Parameters

i
The index of the attribute. The index is zero-based (first attribute has index 0).

Return Value

The value of the specified attribute.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | The i parameter is less than 0 or greater than or equal to AttributeCount.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace | XmlTextReader.GetAttribute Overload List


XmlTextReader.GetAttribute (String, String)

Gets the value of the attribute with the specified name and namespace.

[Visual Basic]
Overloads Overrides Public Function GetAttribute( _
   ByVal name As String, _
   ByVal namespaceURI As String _
) As String
[C#]
public override string GetAttribute(
   string name,
   string namespaceURI
);
[C++]
public: override String* GetAttribute(
   String* name,
   String* namespaceURI
);
[JScript]
public override function GetAttribute(
   name : String,
   namespaceURI : String
) : String;

Parameters

name
The name of the attribute.
namespaceURI
[To be supplied.]

Return Value

The value of the specified attribute. If the attribute is not found, null is returned.

Exceptions

Exception Type | Condition
ArgumentException | The attribute specified by name and namespaceURI properties cannot be found in the current node.

Remarks

The following XML contains an attribute in a specific namespace:

<test xmlns:dt="urn:datatypes" dt:type="int"/>

You can lookup the dt:type attribute using one argument (using Prefix+LocalName) or using two arguments (LocalName and NamespaceURI):

String dt = reader.GetAttribute("dt:type");

String dt2 = reader.GetAttribute("type","urn:datatypes");

Note that the xmlns attributes have no namespace URI; therefore, the only way to look them up is with the short version

String dt3 = reader.GetAttribute("xmlns:dt");

You can also get this information using the Prefix property.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace | XmlTextReader.GetAttribute Overload List


XmlTextReader.GetAttribute (String)

Gets the value of the attribute with the specified name.

[Visual Basic]
Overloads Overrides Public Function GetAttribute( _
   ByVal name As String _
) As String
[C#]
public override string GetAttribute(
   string name
);
[C++]
public: override String* GetAttribute(
   String* name
);
[JScript]
public override function GetAttribute(
   name : String
) : String;

Parameters

name
The name of the attribute. The name can include the prefix or leave it off.

Return Value

The value of the specified attribute. If the attribute is not found, null is returned.

Exceptions

Exception Type | Condition
ArgumentException | The attribute specified by name cannot be found in the current node.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace | XmlTextReader.GetAttribute Overload List


XmlTextReader.LookupNamespace

Resolves a namespace prefix in the current element's scope.

[Visual Basic]
Overrides Public Function LookupNamespace( _
   ByVal prefix As String _
) As String
[C#]
public override string LookupNamespace(
   string prefix
);
[C++]
public: override String* LookupNamespace(
   String* prefix
);
[JScript]
public override function LookupNamespace(
   prefix : String
) : String;

Parameters

prefix
The prefix whose namespace URN you want to resolve. To match the default namespace, pass an empty string. This string does not have to be atomized.

Return Value

The namespace URN that the prefix maps to. a null reference (in Visual Basic Nothing) if no matching prefix is found.

Remarks

For example, suppose you have the following XML:

<root xmlns:a="urn:456">
    <item>
        <ref href="a:b"/>
    </item>
</root>

When you read the href attribute with the value "a:b", you can resolve the prefix "a" by calling LookupNamespace ("a"). The returned string will be "urn:456".

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.MoveToAttribute

Move to the specified attribute.

The MoveToAttribute methods enable you to get both random access to attributes and strongly typed access to attribute values.

To get strongly typed access to an attribute value, you must do the following:

  1. Call MoveToAttribute to move to the attribute whose value you want to access.
  2. Call Read method for the data type you want (for example, ReadBoolean for boolean, ReadDate for DateTime, and so on).

After calling MoveToAttribute, the Name, Namespace, Prefix properties will reflect the properties of that attribute.

Overload List

Moves to the attribute with the specified name.

[Visual Basic] Overloads Overrides Public Function MoveToAttribute(String) As Boolean
[C#] public override bool MoveToAttribute(String);
[C++] public: override bool MoveToAttribute(String*);
[JScript] public override function MoveToAttribute(String) : Boolean;

Moves to the attribute with the specified name and namespace.

[Visual Basic] Overloads Overrides Public Function MoveToAttribute(String, String) As Boolean
[C#] public override bool MoveToAttribute(String, String);
[C++] public: override bool MoveToAttribute(String*, String*);
[JScript] public override function MoveToAttribute(String, String) : Boolean;

Moves to the attribute with the specified index.

[Visual Basic] Overloads Overrides Public Sub MoveToAttribute(Integer)
[C#] public override void MoveToAttribute(int);
[C++] public: override void MoveToAttribute(int);
[JScript] public override function MoveToAttribute(int);

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.MoveToAttribute (String)

Moves to the attribute with the specified name.

[Visual Basic]
Overloads Overrides Public Function MoveToAttribute( _
   ByVal name As String _
) As Boolean
[C#]
public override bool MoveToAttribute(
   string name
);
[C++]
public: override bool MoveToAttribute(
   String* name
);
[JScript]
public override function MoveToAttribute(
   name : String
) : Boolean;

Parameters

name
The name of the attribute. The name can include the prefix or leave it off.

Return Value

true if the attribute is found; otherwise, false. If false, the reader's position does not change.

Exceptions

Exception Type | Condition
ArgumentException | The attribute specified by name cannot be found in the current node.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace | XmlTextReader.MoveToAttribute Overload List


XmlTextReader.MoveToAttribute (String, String)

Moves to the attribute with the specified name and namespace.

[Visual Basic]
Overloads Overrides Public Function MoveToAttribute( _
   ByVal name As String, _
   ByVal namespaceURI As String _
) As Boolean
[C#]
public override bool MoveToAttribute(
   string name,
   string namespaceURI
);
[C++]
public: override bool MoveToAttribute(
   String* name,
   String* namespaceURI
);
[JScript]
public override function MoveToAttribute(
   name : String,
   namespaceURI : String
) : Boolean;

Parameters

name
The name of the attribute.
namespaceURI
[To be supplied.]

Return Value

true if the attribute is found; otherwise, false. If false, the reader's position does not change.

Exceptions

Exception Type | Condition
ArgumentException | The attribute specified by name and namespaceURI properties cannot be found in the current node.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace | XmlTextReader.MoveToAttribute Overload List


XmlTextReader.MoveToAttribute (Int32)

Moves to the attribute with the specified index.

[Visual Basic]
Overloads Overrides Public Sub MoveToAttribute( _
   ByVal i As Integer _
)
[C#]
public override void MoveToAttribute(
   int i
);
[C++]
public: override void MoveToAttribute(
   int i
);
[JScript]
public override function MoveToAttribute(
   i : int
);

Parameters

i
The index of the attribute.

Return Value

true if the attribute is found; otherwise, false. If false, the reader's position does not change.

Exceptions

Exception Type | Condition
IndexOutOfRangeException | The i parameter is less than 0 or greater than AttributeCount.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace | XmlTextReader.MoveToAttribute Overload List


XmlTextReader.MoveToElement

Moves to the element that contains the current attribute node.

[Visual Basic]
Overrides Public Function MoveToElement() As Boolean
[C#]
public override bool MoveToElement();
[C++]
public: override bool MoveToElement();
[JScript]
public override function MoveToElement() : Boolean;

Return Value

true if the attribute is owned by an element; false if the attribute you are positioned on has been removed from the owning element.

Remarks

Use this method to return to an element after navigating through its attributes.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.MoveToFirstAttribute

Moves to the first attribute.

[Visual Basic]
Overrides Public Function MoveToFirstAttribute() As Boolean
[C#]
public override bool MoveToFirstAttribute();
[C++]
public: override bool MoveToFirstAttribute();
[JScript]
public override function MoveToFirstAttribute() : Boolean;

Return Value

true if the first attribute exists; otherwise, false.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.MoveToNextAttribute

Moves to the next attribute.

[Visual Basic]
Overrides Public Function MoveToNextAttribute() As Boolean
[C#]
public override bool MoveToNextAttribute();
[C++]
public: override bool MoveToNextAttribute();
[JScript]
public override function MoveToNextAttribute() : Boolean;

Return Value

true if there is a next attribute; false if there are no more attributes.

Remarks

If the current node is an element node, this method is equivalent to MoveToFirstAttribute.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.Read

Reads the next node from the stream.

[Visual Basic]
Overrides Public Function Read() As Boolean
[C#]
public override bool Read();
[C++]
public: override bool Read();
[JScript]
public override function Read() : Boolean;

Return Value

true if the next node was read successfully; false if there are no more nodes to read.

Remarks

When an XmlReader is first created and initialized, there is no information available. You must call Read to read the first node.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.ReadAttributeValue

Parses the attribute value into one or more Text and/or EntityReference node types.

[Visual Basic]
Overrides Public Function ReadAttributeValue() As Boolean
[C#]
public override bool ReadAttributeValue();
[C++]
public: override bool ReadAttributeValue();
[JScript]
public override function ReadAttributeValue() : Boolean;

Return Value

true if there are nodes to return; false if there are no more nodes to return.

Note that an empty attribute (such as, foo="") returns true with a single node with a value of String.Empty.

Remarks

For example, suppose you have the following XML:

<test name="a &b; c"/>

where the entity "b" is defined in the DTD as follows:

<!ENTITY b "123">

If the EntityHandling is set to ExpandCharEntities, this attribute value will be returned as two text nodes and one entity reference node with the following code:

[C#]

reader.MoveToAttribute("name");
while (reader.ReadAttributeValue())
{
  if (reader.NodeType == XmlNodeType.Text)
  {
    // at this point reader.Text == "a " or " c"
  }
  else if (reader.NodeType == XmlReader.EntityReference)
  {
    // at this point reader.Name == "b"
    reader.ResolveEntity();
    while (reader.ReadAttributeValue() &&
   reader.NodeType != XmlNodeType.EndEntity)
    {
      // reader.Text == "123"
    }
  }
}

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.ReadChar

Reads the element content one character at a time.

[Visual Basic]
Overrides Public Function ReadChar() As Char
[C#]
public override char ReadChar();
[C++]
public: override __wchar_t ReadChar();
[JScript]
public override function ReadChar() : Char;

Return Value

The next character in the element content. If current position is the end of the element content, zero is returned.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.ReadChars

Reads the text contents of an element into a character buffer. This method is designed to read large streams of embedded text by calling it successively.

[Visual Basic]
Overrides Public Function ReadChars( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
[C#]
public override int ReadChars(
   char[] buffer,
   int index,
   int count
);
[C++]
public: override int ReadChars(
   __wchar_t* buffer[],
   int index,
   int count
);
[JScript]
public override function ReadChars(
   buffer : Char[],
   index : int,
   count : int
) : int;

Parameters

buffer
The array of characters that serves as the buffer to which the text contents are written.
index
[To be supplied.]
count
[To be supplied.]

Return Value

The number of characters read. This can be zero if there is no more text content to return in the current context.

Remarks

This is the most efficient way to process very large streams of text embedded in an XML document as opposed to allocating large String objects. This method returns text content a buffer at a time. For example, suppose you have the following element:

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.ReadInnerXml

Reads all the content (including markup) as a string.

[Visual Basic]
Overrides Public Function ReadInnerXml() As String
[C#]
public override string ReadInnerXml();
[C++]
public: override String* ReadInnerXml();
[JScript]
public override function ReadInnerXml() : String;

Return Value

All the XML content (including markup) in the current node.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.ReadString

Reads the contents of an element as a string.

[Visual Basic]
Overrides Public Function ReadString() As String
[C#]
public override string ReadString();
[C++]
public: override String* ReadString();
[JScript]
public override function ReadString() : String;

Return Value

The contents of the element.

Exceptions

Exception Type | Condition
XmlException | Markup was found instead of an end tag.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.ResolveEntity

Resolves the entity reference for nodes of NodeType EntityReference.

[Visual Basic]
Overrides Public Sub ResolveEntity()
[C#]
public override void ResolveEntity();
[C++]
public: override void ResolveEntity();
[JScript]
public override function ResolveEntity();

Exceptions

Exception Type | Condition
InvalidOperationException | XmlReader is not positioned on an EntityReference node.

Remarks

If the node has NodeType of EntityReference, the entity replacement text will be parsed next and returned as child nodes. When the entity replacement text is finished, a new NodeType called "EndEntity" is returned to close the EntityReference scope.

If this method is not called, the entity reference is treated like a leaf node and the parser moves on. In this case, the entity is not parsed in context but it is validated.

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextReader.Skip

Skips to the end tag of the current element.

[Visual Basic]
Overrides Public Sub Skip()
[C#]
public override void Skip();
[C++]
public: override void Skip();
[JScript]
public override function Skip();

Remarks

For example, suppose you have the following XML input:

See Also

XmlTextReader Class | XmlTextReader Members | System.NewXml Namespace


XmlTextWriter Class

Represents a writer that provides fast non-cached forward-only way of generating XML streams containing XML documents that conform to the W3C Extensible Markup Language (XML) 1.0 specification and the Namespaces in XML specification.

Object
XmlWriter
XmlTextWriter

[Visual Basic]
Public Class XmlTextWriter
   Inherits XmlWriter
[C#]
public class XmlTextWriter : XmlWriter
[C++]
public __gc class XmlTextWriter : public XmlWriter
[JScript]
public class XmlTextWriter extends XmlWriter

Remarks

[To be supplied.]

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter Members

Public:

Constructor

XmlTextWriter Constructor Overloaded. Creates an instance of the XmlTextWriter class.

Properties

DataTypeNamespace | Gets or sets the DataTypes namespace which determines how the strongly typed values are converted to XML text.
EncodeNames | Gets or sets a value indicating whether to encode element and attribute names according to the XML Names specification.
Formatting | Gets or sets options on how the output is formatted.
Indentation | Gets or sets how many IndentChars to write for each level in the hierarchy when doing "Indented" Formatting.
IndentChar | Gets or sets which character to use for indenting when doing "Indented" Formatting.
Namespaces | Gets or sets a value indicating whether to do namespace support.
QuoteChar | Gets or sets which character to use to quote attribute values.
WriteState | Gets the state of the stream.
XmlLang | Gets the current xml:lang scope.
XmlSpace | Gets an XmlSpace representing the current xml:space scope.

Methods

Close | Close this stream and the underlying stream.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Flush | Flush whatever is in the buffer to the underlying streams and flush the underlying stream.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
LookupPrefix | Returns the prefix defined in the current namespace scope for the specified namespace URI.
Reset | Enables you to write multiple XML documents to one stream.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteAttrBoolean (inherited from XmlWriter) | Overloaded. Writes out an attribute with a boolean value.
WriteAttrDate (inherited from XmlWriter) | Overloaded. Writes out an attribute with a Date value.
WriteAttrDateTime (inherited from XmlWriter) | Overloaded. Writes out an attribute with a DateTime value.
WriteAttrDecimal (inherited from XmlWriter) | Overloaded. Writes out an attribute with a Decimal value.
WriteAttrDouble (inherited from XmlWriter) | Overloaded. Writes out an attribute with a Double value.
WriteAttribute (inherited from XmlWriter) | Overloaded. Writes out specified attribute with the specified value.
WriteAttributes (inherited from XmlWriter) | Writes out all the attributes found at the current position in the specified XmlReader
WriteAttrInt16 (inherited from XmlWriter) | Overloaded. Writes out an attribute with a Int16 value.
WriteAttrInt32 (inherited from XmlWriter) | Overloaded. Writes out an attribute with a Int32 value.
WriteAttrInt64 (inherited from XmlWriter) | Overloaded. Writes out an attribute with a Int64 value.
WriteAttrSingle (inherited from XmlWriter) | Overloaded. Writes out an attribute with a Single value.
WriteAttrTime (inherited from XmlWriter) | Overloaded. Writes out an attribute with a Time value.
WriteAttrTimeSpan (inherited from XmlWriter) | Overloaded. Writes out an attribute with a TimeSpan value.
WriteBase64 | Encodes the specified binary bytes as base64 and writes out the resulting text.
WriteBinHex | Encodes the specified binary bytes as binhex and writes out the resulting text.
WriteBoolean | Writes out the specified boolean value.
WriteCData | Writes out a <![CDATA[...]]> block containing the specified text.
WriteChar | Writes out the specified single character value.
WriteCharEntity | Forces the generation of a character entity for the specified Unicode character value.
WriteChars | Writes text a buffer at a time.
WriteComment | Writes out a comment <!--...--> containing the specified text.
WriteDate | Writes out the specified Date value.
WriteDateTime | Writes out the specified DateTime value.
WriteDecimal | Writes out the specified Decimal value.
WriteDocType | Writes out the DOCTYPE declaration with the specified name and optional attributes.
WriteDouble | Writes out the specified Double value.
WriteElementBoolean (inherited from XmlWriter) | Overloaded. Writes out an element containing a boolean value.
WriteElementDate (inherited from XmlWriter) | Overloaded. Writes out an element containing a Date value.
WriteElementDateTime (inherited from XmlWriter) | Overloaded. Writes out an element containing a DateTime value.
WriteElementDecimal (inherited from XmlWriter) | Overloaded. Writes out an element containing a Decimal value.
WriteElementDouble (inherited from XmlWriter) | Overloaded. Writes out an element containing a Double value.
WriteElementInt16 (inherited from XmlWriter) | Overloaded. Writes out an element containing a Int16 value.
WriteElementInt32 (inherited from XmlWriter) | Overloaded. Writes out an element containing a Int32 value.
WriteElementInt64 (inherited from XmlWriter) | Overloaded. Writes out an element containing a Int64 value.
WriteElementSingle (inherited from XmlWriter) | Overloaded. Writes out an element containing a Single value.
WriteElementString (inherited from XmlWriter) | Overloaded. Writes out an element containing a string value.
WriteElementTime (inherited from XmlWriter) | Overloaded. Writes out an element containing a Time value.
WriteElementTimeSpan (inherited from XmlWriter) | Overloaded. Writes out an element containing a TimeSpan value.
WriteEmptyElement | This method will generate an empty tag that ends with "/>".
WriteEndAttribute | Closes the previous WriteStartAttribute call.
WriteEndElement | Closes one element and pops the corresponding namespace scope.
WriteEntityRef | Writes out an entity reference as follows: "&"+name+";".
WriteInt16 | Writes out the specified Int16 value.
WriteInt32 | Writes out the specified Int32 value.
WriteInt64 | Writes out the specified Int64 value.
WriteName | Writes out the specified name, ensuring it is a valid Name according to the XML specification (href="
WriteNmToken | Writes out the specified name, ensuring it is a valid NmToken according to the XML specification (
WriteNode (inherited from XmlWriter) | Copies everything from the given reader to the writer, moving the XmlReader to the end of the current element.
WriteProcessingInstruction | Writes out a processing instruction with a space between the name and text as follows: <?name text?>.
WriteQualifiedName | Writes out the specified namespace-qualified name by looking up the prefix that is in scope for the given namespace.
WriteRaw | Overloaded. Writes raw markup manually.
WriteSingle | Writes out the specified float value.
WriteStartAttribute | Writes the start of an attribute.
WriteStartElement (inherited from XmlWriter) | Overloaded. Writes out the specified start tag.
WriteString | Writes out the specified text content.
WriteTime | Writes out the specified Time value.
WriteTimeSpan | Writes out the specified TimeSpan value.
WriteXmlDecl | Overloaded. Writes out the XML declaration. A call to one of the WriteXmlDecl methods must be first write call.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlTextWriter Class | System.NewXml Namespace


XmlTextWriter Constructor

Creates an instance of the XmlTextWriter class.

Overload List

Creates an instance of the XmlTextWriter class using the specified stream.

[Visual Basic] Overloads Public Sub New(Stream, Encoding)
[C#] public XmlTextWriter(Stream, Encoding);
[C++] public: XmlTextWriter(Stream*, Encoding);
[JScript] public function XmlTextWriter(Stream, Encoding);

Creates an instance of the XmlTextWriter class using the specified file.

[Visual Basic] Overloads Public Sub New(String, Encoding)
[C#] public XmlTextWriter(String, Encoding);
[C++] public: XmlTextWriter(String*, Encoding);
[JScript] public function XmlTextWriter(String, Encoding);

Creates an instance of the XmlTextWriter class using the specified TextWriter.

[Visual Basic] Overloads Public Sub New(TextWriter)
[C#] public XmlTextWriter(TextWriter);
[C++] public: XmlTextWriter(TextWriter*);
[JScript] public function XmlTextWriter(TextWriter);

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter Constructor (Stream, Encoding)

Creates an instance of the XmlTextWriter class using the specified stream.

[Visual Basic]
Overloads Public Sub New( _
   ByVal w As Stream, _
   ByVal encoding As Encoding _
)
[C#]
public XmlTextWriter(
   Stream w,
   Encoding encoding
);
[C++]
public: XmlTextWriter(
   Stream* w,
   Encoding* encoding
);
[JScript]
public function XmlTextWriter(
   w : Stream,
   encoding : Encoding
);

Parameters

w
Stream that you want to write to
encoding
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentException | if encoding is not supported.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace | XmlTextWriter Constructor Overload List


XmlTextWriter Constructor (String, Encoding)

Creates an instance of the XmlTextWriter class using the specified file.

[Visual Basic]
Overloads Public Sub New( _
   ByVal filename As String, _
   ByVal encoding As Encoding _
)
[C#]
public XmlTextWriter(
   string filename,
   Encoding encoding
);
[C++]
public: XmlTextWriter(
   String* filename,
   Encoding* encoding
);
[JScript]
public function XmlTextWriter(
   filename : String,
   encoding : Encoding
);

Parameters

filename
Filename that you want to write to. If the file exists, it will truncate it and overwrite it with the new content.
encoding
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentException | if encoding is not supported.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace | XmlTextWriter Constructor Overload List


XmlTextWriter Constructor (TextWriter)

Creates an instance of the XmlTextWriter class using the specified TextWriter.

[Visual Basic]
Overloads Public Sub New( _
   ByVal w As TextWriter _
)
[C#]
public XmlTextWriter(
   TextWriter w
);
[C++]
public: XmlTextWriter(
   TextWriter* w
);
[JScript]
public function XmlTextWriter(
   w : TextWriter
);

Parameters

w
TextWriter to write to. It is assumed that the writer is already set to the correct encoding.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace | XmlTextWriter Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlTextWriter Properties

The properties of the XmlTextWriter class are listed below. For a complete list of XmlTextWriter class members, see the XmlTextWriter Members topic.

Public:

DataTypeNamespace | Gets or sets the DataTypes namespace which determines how the strongly typed values are converted to XML text.
EncodeNames | Gets or sets a value indicating whether to encode element and attribute names according to the XML Names specification.
Formatting | Gets or sets options on how the output is formatted.
Indentation | Gets or sets how many IndentChars to write for each level in the hierarchy when doing "Indented" Formatting.
IndentChar | Gets or sets which character to use for indenting when doing "Indented" Formatting.
Namespaces | Gets or sets a value indicating whether to do namespace support.
QuoteChar | Gets or sets which character to use to quote attribute values.
WriteState | Gets the state of the stream.
XmlLang | Gets the current xml:lang scope.
XmlSpace | Gets an XmlSpace representing the current xml:space scope.

See Also

XmlTextWriter Class | System.NewXml Namespace


XmlTextWriter.DataTypeNamespace

Gets or sets the DataTypes namespace which determines how the strongly typed values are converted to XML text.

[Visual Basic]
Public Property DataTypeNamespace As String
[C#]
public string DataTypeNamespace {get; set;}
[C++]
public: __property String* get_DataTypeNamespace();
public: __property void set_DataTypeNamespace(String*);
[JScript]
public function get DataTypeNamespace() : String;
public function set DataTypeNamespace(String);

Property Value

Supported namespaces are:

Namespace | Description
urn:schemas-microsoft-com:datatypes | Microsoft XML-Data Schema (XDR) datatypes namespace.
http://www.w3.org/1999/XMLSchema-datatypes | The W3C Schema (XSD) datatypes namespace (http://www.w3.org/TR/xmlschema-2/).

For example, if the namespace is urn:schemas-microsoft-com:datatypes then boolean values are written out as "0" or "1". This guarentees that other implementations of this datatype namespace (in MSXML and SQL Server, for example) can read the XML produced by this writer.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.EncodeNames

Gets or sets a value indicating whether to encode element and attribute names according to the XML Names specification.

[Visual Basic]
Public Property EncodeNames As Boolean
[C#]
public bool EncodeNames {get; set;}
[C++]
public: __property bool get_EncodeNames();
public: __property void set_EncodeNames(bool);
[JScript]
public function get EncodeNames() : Boolean;
public function set EncodeNames(Boolean);

Property Value

true to encode; otherwise, false.

Default is false.

Remarks

The complement of this is the DecodeNames flag on the XmlTextReader.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.Formatting

Gets or sets options on how the output is formatted.

[Visual Basic]
Public Property Formatting As Formatting
[C#]
public Formatting Formatting {get; set;}
[C++]
public: __property Formatting get_Formatting();
public: __property void set_Formatting(Formatting);
[JScript]
public function get Formatting() : Formatting;
public function set Formatting(Formatting);

Property Value

One of the Formatting values.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.Indentation

Gets or sets how many IndentChars to write for each level in the hierarchy when doing "Indented" Formatting.

[Visual Basic]
Public Property Indentation As Integer
[C#]
public int Indentation {get; set;}
[C++]
public: __property int get_Indentation();
public: __property void set_Indentation(int);
[JScript]
public function get Indentation() : int;
public function set Indentation(int);

Property Value

Number of IndentChars for each level. Default is 2.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.IndentChar

Gets or sets which character to use for indenting when doing "Indented" Formatting.

[Visual Basic]
Public Property IndentChar As Char
[C#]
public char IndentChar {get; set;}
[C++]
public: __property __wchar_t get_IndentChar();
public: __property void set_IndentChar(__wchar_t);
[JScript]
public function get IndentChar() : Char;
public function set IndentChar(Char);

Property Value

The character to use for indenting. Default is space. The character must be a valid whitespace character.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.Namespaces

Gets or sets a value indicating whether to do namespace support.

[Visual Basic]
Public Property Namespaces As Boolean
[C#]
public bool Namespaces {get; set;}
[C++]
public: __property bool get_Namespaces();
public: __property void set_Namespaces(bool);
[JScript]
public function get Namespaces() : Boolean;
public function set Namespaces(Boolean);

Property Value

true to support namespaces; otherwise, false.

Default is true.

Exceptions

Exception Type | Condition
InvalidOperationException | You can only change this property when in the WriteState.Start state.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.QuoteChar

Gets or sets which character to use to quote attribute values.

[Visual Basic]
Public Property QuoteChar As Char
[C#]
public char QuoteChar {get; set;}
[C++]
public: __property __wchar_t get_QuoteChar();
public: __property void set_QuoteChar(__wchar_t);
[JScript]
public function get QuoteChar() : Char;
public function set QuoteChar(Char);

Property Value

The character to use to quote attribute values. This must be a single quote (&#39;) or a double quote (&#34;).

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteState

Gets the state of the stream.

[Visual Basic]
Overridable Public ReadOnly Property WriteState As WriteState
[C#]
public WriteState WriteState {override get;}
[C++]
public: __property virtual WriteState get_WriteState();
[JScript]
public function get WriteState() : WriteState;

Property Value

One of the WriteState values.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.XmlLang

Gets the current xml:lang scope.

[Visual Basic]
Overridable Public ReadOnly Property XmlLang As String
[C#]
public string XmlLang {override get;}
[C++]
public: __property virtual String* get_XmlLang();
[JScript]
public function get XmlLang() : String;

Property Value

The current xml:lang scope.

Remarks

This allows one component to find out what state another component has left the writer in. Perhaps one component wants to tell the other which language help text to generate and it communicates the language information by writing an xml:lang attribute.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.XmlSpace

Gets an XmlSpace representing the current xml:space scope.

[Visual Basic]
Overridable Public ReadOnly Property XmlSpace As XmlSpace
[C#]
public XmlSpace XmlSpace {override get;}
[C++]
public: __property virtual XmlSpace get_XmlSpace();
[JScript]
public function get XmlSpace() : XmlSpace;

Property Value

The current xml:space scope.

Value | Meaning
None (0) | This is the default if no xml:space scope exists
Default (1) | In the scope of xml:space="default"
Preserve (2) | In the scope of xml:space="preserve".

This allows one component to find out what state another component has left the writer in.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlTextWriter Methods

The methods of the XmlTextWriter class are listed below. For a complete list of XmlTextWriter class members, see the XmlTextWriter Members topic.

Public:

Close | Close this stream and the underlying stream.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Flush | Flush whatever is in the buffer to the underlying streams and flush the underlying stream.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
LookupPrefix | Returns the prefix defined in the current namespace scope for the specified namespace URI.
Reset | Enables you to write multiple XML documents to one stream.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteAttrBoolean (inherited from XmlWriter) | Overloaded. Writes out an attribute with a boolean value.
WriteAttrDate (inherited from XmlWriter) | Overloaded. Writes out an attribute with a Date value.
WriteAttrDateTime (inherited from XmlWriter) | Overloaded. Writes out an attribute with a DateTime value.
WriteAttrDecimal (inherited from XmlWriter) | Overloaded. Writes out an attribute with a Decimal value.
WriteAttrDouble (inherited from XmlWriter) | Overloaded. Writes out an attribute with a Double value.
WriteAttribute (inherited from XmlWriter) | Overloaded. Writes out specified attribute with the specified value.
WriteAttributes (inherited from XmlWriter) | Writes out all the attributes found at the current position in the specified XmlReader
WriteAttrInt16 (inherited from XmlWriter) | Overloaded. Writes out an attribute with a Int16 value.
WriteAttrInt32 (inherited from XmlWriter) | Overloaded. Writes out an attribute with a Int32 value.
WriteAttrInt64 (inherited from XmlWriter) | Overloaded. Writes out an attribute with a Int64 value.
WriteAttrSingle (inherited from XmlWriter) | Overloaded. Writes out an attribute with a Single value.
WriteAttrTime (inherited from XmlWriter) | Overloaded. Writes out an attribute with a Time value.
WriteAttrTimeSpan (inherited from XmlWriter) | Overloaded. Writes out an attribute with a TimeSpan value.
WriteBase64 | Encodes the specified binary bytes as base64 and writes out the resulting text.
WriteBinHex | Encodes the specified binary bytes as binhex and writes out the resulting text.
WriteBoolean | Writes out the specified boolean value.
WriteCData | Writes out a <![CDATA[...]]> block containing the specified text.
WriteChar | Writes out the specified single character value.
WriteCharEntity | Forces the generation of a character entity for the specified Unicode character value.
WriteChars | Writes text a buffer at a time.
WriteComment | Writes out a comment <!--...--> containing the specified text.
WriteDate | Writes out the specified Date value.
WriteDateTime | Writes out the specified DateTime value.
WriteDecimal | Writes out the specified Decimal value.
WriteDocType | Writes out the DOCTYPE declaration with the specified name and optional attributes.
WriteDouble | Writes out the specified Double value.
WriteElementBoolean (inherited from XmlWriter) | Overloaded. Writes out an element containing a boolean value.
WriteElementDate (inherited from XmlWriter) | Overloaded. Writes out an element containing a Date value.
WriteElementDateTime (inherited from XmlWriter) | Overloaded. Writes out an element containing a DateTime value.
WriteElementDecimal (inherited from XmlWriter) | Overloaded. Writes out an element containing a Decimal value.
WriteElementDouble (inherited from XmlWriter) | Overloaded. Writes out an element containing a Double value.
WriteElementInt16 (inherited from XmlWriter) | Overloaded. Writes out an element containing a Int16 value.
WriteElementInt32 (inherited from XmlWriter) | Overloaded. Writes out an element containing a Int32 value.
WriteElementInt64 (inherited from XmlWriter) | Overloaded. Writes out an element containing a Int64 value.
WriteElementSingle (inherited from XmlWriter) | Overloaded. Writes out an element containing a Single value.
WriteElementString (inherited from XmlWriter) | Overloaded. Writes out an element containing a string value.
WriteElementTime (inherited from XmlWriter) | Overloaded. Writes out an element containing a Time value.
WriteElementTimeSpan (inherited from XmlWriter) | Overloaded. Writes out an element containing a TimeSpan value.
WriteEmptyElement | This method will generate an empty tag that ends with "/>".
WriteEndAttribute | Closes the previous WriteStartAttribute call.
WriteEndElement | Closes one element and pops the corresponding namespace scope.
WriteEntityRef | Writes out an entity reference as follows: "&"+name+";".
WriteInt16 | Writes out the specified Int16 value.
WriteInt32 | Writes out the specified Int32 value.
WriteInt64 | Writes out the specified Int64 value.
WriteName | Writes out the specified name, ensuring it is a valid Name according to the XML specification (href="
WriteNmToken | Writes out the specified name, ensuring it is a valid NmToken according to the XML specification (
WriteNode (inherited from XmlWriter) | Copies everything from the given reader to the writer, moving the XmlReader to the end of the current element.
WriteProcessingInstruction | Writes out a processing instruction with a space between the name and text as follows: <?name text?>.
WriteQualifiedName | Writes out the specified namespace-qualified name by looking up the prefix that is in scope for the given namespace.
WriteRaw | Overloaded. Writes raw markup manually.
WriteSingle | Writes out the specified float value.
WriteStartAttribute | Writes the start of an attribute.
WriteStartElement (inherited from XmlWriter) | Overloaded. Writes out the specified start tag.
WriteString | Writes out the specified text content.
WriteTime | Writes out the specified Time value.
WriteTimeSpan | Writes out the specified TimeSpan value.
WriteXmlDecl | Overloaded. Writes out the XML declaration. A call to one of the WriteXmlDecl methods must be first write call.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlTextWriter Class | System.NewXml Namespace


XmlTextWriter.Close

Close this stream and the underlying stream.

[Visual Basic]
Overrides Public Sub Close()
[C#]
public override void Close();
[C++]
public: override void Close();
[JScript]
public override function Close();

Remarks

Once this method is called, an InvalidOperationException is thrown if any call is made to write more output.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.Flush

Flush whatever is in the buffer to the underlying streams and flush the underlying stream.

[Visual Basic]
Overrides Public Sub Flush()
[C#]
public override void Flush();
[C++]
public: override void Flush();
[JScript]
public override function Flush();

Remarks

This is called instead of Close() when you want to write more to the underlying stream without losing what is still in the XmlWriter buffer.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.LookupPrefix

Returns the prefix defined in the current namespace scope for the specified namespace URI.

[Visual Basic]
Overrides Public Function LookupPrefix( _
   ByVal ns As String _
) As String
[C#]
public override string LookupPrefix(
   string ns
);
[C++]
public: override String* LookupPrefix(
   String* ns
);
[JScript]
public override function LookupPrefix(
   ns : String
) : String;

Parameters

ns
Namespace URI whose prefix you want to find.

Return Value

The matching prefix. Or null if no matching namespace URI is in scope.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.Reset

Enables you to write multiple XML documents to one stream.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();
[C++]
public: void Reset();
[JScript]
public function Reset();

Exceptions

Exception Type | Condition
InvalidOperationException | There are unclosed elements.

Remarks

This matches the Reset method on the XmlReader.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteBase64

Encodes the specified binary bytes as base64 and writes out the resulting text.

[Visual Basic]
Overrides Public Sub WriteBase64( _
   ByVal buffer() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
[C#]
public override void WriteBase64(
   byte[] buffer,
   int index,
   int count
);
[C++]
public: override void WriteBase64(
   unsigned char* buffer[],
   int index,
   int count
);
[JScript]
public override function WriteBase64(
   buffer : Byte[],
   index : int,
   count : int
);

Parameters

buffer
Byte array to encode.
index
The position within buffer indicating the start of the bytes to write.
count
The number of bytes to write.

Remarks

For example, the byte buffer may contain the binary contents of a GIF image. This clearly would not be valid XML. The Base64 encoding is designed to represent arbitrary byte sequences in a text form comprized of the 65 US-ASCII characters ([A-Za-z0-9+/=]) where each character encodes 6 bits of the binary data. See RFC 1521.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteBinHex

Encodes the specified binary bytes as binhex and writes out the resulting text.

[Visual Basic]
Overrides Public Sub WriteBinHex( _
   ByVal buffer() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
[C#]
public override void WriteBinHex(
   byte[] buffer,
   int index,
   int count
);
[C++]
public: override void WriteBinHex(
   unsigned char* buffer[],
   int index,
   int count
);
[JScript]
public override function WriteBinHex(
   buffer : Byte[],
   index : int,
   count : int
);

Parameters

buffer
Byte array to encode.
index
The position within buffer indicating the start of the bytes to write.
count
The number of bytes to write.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteBoolean

Writes out the specified boolean value.

[Visual Basic]
Overrides Public Sub WriteBoolean( _
   ByVal value As Boolean _
)
[C#]
public override void WriteBoolean(
   bool value
);
[C++]
public: override void WriteBoolean(
   bool value
);
[JScript]
public override function WriteBoolean(
   value : Boolean
);

Parameters

value
boolean to write.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteCData

Writes out a <![CDATA[...]]> block containing the specified text.

[Visual Basic]
Overrides Public Sub WriteCData( _
   ByVal text As String _
)
[C#]
public override void WriteCData(
   string text
);
[C++]
public: override void WriteCData(
   String* text
);
[JScript]
public override function WriteCData(
   text : String
);

Parameters

text
Text to place inside the CDATA block.

Exceptions

Exception Type | Condition
ArgumentException | The text would result in a non-well formed XML document.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteChar

Writes out the specified single character value.

[Visual Basic]
Overrides Public Sub WriteChar( _
   ByVal value As Char _
)
[C#]
public override void WriteChar(
   char value
);
[C++]
public: override void WriteChar(
   __wchar_t value
);
[JScript]
public override function WriteChar(
   value : Char
);

Parameters

value
Character to write.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteCharEntity

Forces the generation of a character entity for the specified Unicode character value.

[Visual Basic]
Overrides Public Sub WriteCharEntity( _
   ByVal ch As Char _
)
[C#]
public override void WriteCharEntity(
   char ch
);
[C++]
public: override void WriteCharEntity(
   __wchar_t ch
);
[JScript]
public override function WriteCharEntity(
   ch : Char
);

Parameters

ch
Unicode character for which to generate a character entity.

Remarks

This method writes the specified Unicode character in hexidecimal format.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteChars

Writes text a buffer at a time.

[Visual Basic]
Overrides Public Sub WriteChars( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
[C#]
public override void WriteChars(
   char[] buffer,
   int index,
   int count
);
[C++]
public: override void WriteChars(
   __wchar_t* buffer[],
   int index,
   int count
);
[JScript]
public override function WriteChars(
   buffer : Char[],
   index : int,
   count : int
);

Parameters

buffer
Character array containing the text to write.
index
The position within buffer indicating the start of the text to write.
count
The number of characters to write.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteComment

Writes out a comment <!--...--> containing the specified text.

[Visual Basic]
Overrides Public Sub WriteComment( _
   ByVal text As String _
)
[C#]
public override void WriteComment(
   string text
);
[C++]
public: override void WriteComment(
   String* text
);
[JScript]
public override function WriteComment(
   text : String
);

Parameters

text
Text to place inside the comment.

Exceptions

Exception Type | Condition
ArgumentException | If the text would result in a non-well formed XML document

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteDate

Writes out the specified Date value.

[Visual Basic]
Overrides Public Sub WriteDate( _
   ByVal value As DateTime _
)
[C#]
public override void WriteDate(
   DateTime value
);
[C++]
public: override void WriteDate(
   DateTime value
);
[JScript]
public override function WriteDate(
   value : DateTime
);

Parameters

value
DateTime to write.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteDateTime

Writes out the specified DateTime value.

[Visual Basic]
Overrides Public Sub WriteDateTime( _
   ByVal value As DateTime _
)
[C#]
public override void WriteDateTime(
   DateTime value
);
[C++]
public: override void WriteDateTime(
   DateTime value
);
[JScript]
public override function WriteDateTime(
   value : DateTime
);

Parameters

value
DateTime to write.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteDecimal

Writes out the specified Decimal value.

[Visual Basic]
Overrides Public Sub WriteDecimal( _
   ByVal value As Decimal _
)
[C#]
public override void WriteDecimal(
   Decimal value
);
[C++]
public: override void WriteDecimal(
   Decimal value
);
[JScript]
public override function WriteDecimal(
   value : Decimal
);

Parameters

value
Decimal to write.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteDocType

Writes out the DOCTYPE declaration with the specified name and optional attributes.

[Visual Basic]
Overrides Public Sub WriteDocType( _
   ByVal name As String, _
   ByVal pubid As String, _
   ByVal sysid As String, _
   ByVal subset As String _
)
[C#]
public override void WriteDocType(
   string name,
   string pubid,
   string sysid,
   string subset
);
[C++]
public: override void WriteDocType(
   String* name,
   String* pubid,
   String* sysid,
   String* subset
);
[JScript]
public override function WriteDocType(
   name : String,
   pubid : String,
   sysid : String,
   subset : String
);

Parameters

name
The name of the DOCTYPE- this must be non-empty.
pubid
If non-null it also writes PUBLIC "pubid" "sysid" where pubid and sysid are replaced with the value of the given arguments.
sysid
If pubid is null and sysid is non-null it writes SYSTEM "sysid" where sysid is replaced with the value of this argument.
subset
If non-null it writes [subset] where subset is replaced with the value of this argument.

Exceptions

Exception Type | Condition
InvalidOperationException | This method was called outside the prolog (after the root element).

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteDouble

Writes out the specified Double value.

[Visual Basic]
Overrides Public Sub WriteDouble( _
   ByVal value As Double _
)
[C#]
public override void WriteDouble(
   double value
);
[C++]
public: override void WriteDouble(
   double value
);
[JScript]
public override function WriteDouble(
   value : double
);

Parameters

value
Double to write.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteEmptyElement

This method will generate an empty tag that ends with "/>".

[Visual Basic]
Overrides Public Sub WriteEmptyElement( _
   ByVal name As String, _
   ByVal ns As String _
)
[C#]
public override void WriteEmptyElement(
   string name,
   string ns
);
[C++]
public: override void WriteEmptyElement(
   String* name,
   String* ns
);
[JScript]
public override function WriteEmptyElement(
   name : String,
   ns : String
);

Parameters

name
The name of the element. The name argument can contain a prefix.
ns
The namespace URI to associate with the element. If this namespace is already in scope and has an associated prefix then the writer will automatically write that prefix also.

Remarks

This tag is finished when you call WriteEndElement. The arguments have the same meaning as WriteStartElement. For example:

[C#]

writer.WriteEmptyElement("foo",null);
writer.WriteAttribute("bar","123");
writer.WriteEndElement();

Generates the following:

[xml]

<foo bar="123"/>

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteEndAttribute

Closes the previous WriteStartAttribute call.

[Visual Basic]
Overrides Public Sub WriteEndAttribute()
[C#]
public override void WriteEndAttribute();
[C++]
public: override void WriteEndAttribute();
[JScript]
public override function WriteEndAttribute();

Remarks

If you call WriteStartAttribute, you can close the attribute with this method.

You can also close the attribute by calling WriteStartAttribute again, calling WriteAttribute, or calling WriteEndElement.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteEndElement

Closes one element and pops the corresponding namespace scope.

[Visual Basic]
Overrides Public Sub WriteEndElement()
[C#]
public override void WriteEndElement();
[C++]
public: override void WriteEndElement();
[JScript]
public override function WriteEndElement();

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteEntityRef

Writes out an entity reference as follows: "&"+name+";".

[Visual Basic]
Overrides Public Sub WriteEntityRef( _
   ByVal name As String _
)
[C#]
public override void WriteEntityRef(
   string name
);
[C++]
public: override void WriteEntityRef(
   String* name
);
[JScript]
public override function WriteEntityRef(
   name : String
);

Parameters

name
Name of the entity reference.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteInt16

Writes out the specified Int16 value.

[Visual Basic]
Overrides Public Sub WriteInt16( _
   ByVal value As Short _
)
[C#]
public override void WriteInt16(
   short value
);
[C++]
public: override void WriteInt16(
   short value
);
[JScript]
public override function WriteInt16(
   value : Int16
);

Parameters

value
Int16 to write.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteInt32

Writes out the specified Int32 value.

[Visual Basic]
Overrides Public Sub WriteInt32( _
   ByVal value As Integer _
)
[C#]
public override void WriteInt32(
   int value
);
[C++]
public: override void WriteInt32(
   int value
);
[JScript]
public override function WriteInt32(
   value : int
);

Parameters

value
Int32 to write.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteInt64

Writes out the specified Int64 value.

[Visual Basic]
Overrides Public Sub WriteInt64( _
   ByVal value As Long _
)
[C#]
public override void WriteInt64(
   long value
);
[C++]
public: override void WriteInt64(
   __int64 value
);
[JScript]
public override function WriteInt64(
   value : long
);

Parameters

value
Int64 to write.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteName

Writes out the specified name, ensuring it is a valid Name according to the XML specification (href="

[Visual Basic]
Overrides Public Sub WriteName( _
   ByVal name As String _
)
[C#]
public override void WriteName(
   string name
);
[C++]
public: override void WriteName(
   String* name
);
[JScript]
public override function WriteName(
   name : String
);

Parameters

name
[To be supplied.]

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteNmToken

Writes out the specified name, ensuring it is a valid NmToken according to the XML specification (

[Visual Basic]
Overrides Public Sub WriteNmToken( _
   ByVal name As String _
)
[C#]
public override void WriteNmToken(
   string name
);
[C++]
public: override void WriteNmToken(
   String* name
);
[JScript]
public override function WriteNmToken(
   name : String
);

Parameters

name
[To be supplied.]

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteProcessingInstruction

Writes out a processing instruction with a space between the name and text as follows: <?name text?>.

[Visual Basic]
Overrides Public Sub WriteProcessingInstruction( _
   ByVal name As String, _
   ByVal text As String _
)
[C#]
public override void WriteProcessingInstruction(
   string name,
   string text
);
[C++]
public: override void WriteProcessingInstruction(
   String* name,
   String* text
);
[JScript]
public override function WriteProcessingInstruction(
   name : String,
   text : String
);

Parameters

name
Name of the processing instruction.
text
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentException | The text would result in a non-well formed XML document. The name is "xml". You must use WriteXmlDecl() to write the XML declaration.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteQualifiedName

Writes out the specified namespace-qualified name by looking up the prefix that is in scope for the given namespace.

[Visual Basic]
Overrides Public Sub WriteQualifiedName( _
   ByVal name As String, _
   ByVal ns As String _
)
[C#]
public override void WriteQualifiedName(
   string name,
   string ns
);
[C++]
public: override void WriteQualifiedName(
   String* name,
   String* ns
);
[JScript]
public override function WriteQualifiedName(
   name : String,
   ns : String
);

Parameters

name
Name to write.
ns
[To be supplied.]

Remarks

For example, the following code:

writer.WriteStartElement("root");
writer.WriteAttribute("xmlns:x","urn:abc");
    writer.WriteEmptyElement("item");
        writer.WriteStartAttribute("href",null);
        writer.WriteString("#");
        writer.WriteQualifiedName("foo","urn:abc");
        writer.WriteEndAttribute();
    writer.WriteEndElement();
writer.WriteEndElement();
writer.Close();

Will generate the following output:

<root xmlns:x="urn:abc">
         <item href="#x:foo"/>
         </root>

When writing attribute values it will generate a prefix if the specified namespace is not found.If the namespace maps to the current default namespace then it does not need a prefix. When writing element content it will throw an exception if the namespace is not found.

If the Namespace flag is turned on then it will also make sure the name is valid according to the Namespaces in XML specification (

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteRaw

Writes raw markup manually.

Overload List

Writes raw markup manually from a character buffer.

[Visual Basic] Overloads Overrides Public Sub WriteRaw(Char(), Integer, Integer)
[C#] public override void WriteRaw(char[], int, int);
[C++] public: override void WriteRaw(__wchar_t*[], int, int);
[JScript] public override function WriteRaw(Char[], int, int);

Writes raw markup manually from a string.

[Visual Basic] Overloads Overrides Public Sub WriteRaw(String)
[C#] public override void WriteRaw(String);
[C++] public: override void WriteRaw(String*);
[JScript] public override function WriteRaw(String);

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteRaw (Char[], Int32, Int32)

Writes raw markup manually from a character buffer.

[Visual Basic]
Overloads Overrides Public Sub WriteRaw( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
[C#]
public override void WriteRaw(
   char[] buffer,
   int index,
   int count
);
[C++]
public: override void WriteRaw(
   __wchar_t* buffer[],
   int index,
   int count
);
[JScript]
public override function WriteRaw(
   buffer : Char[],
   index : int,
   count : int
);

Parameters

buffer
Character array containing the text to write.
index
The position within buffer indicating the start of the text to write.
count
The number of characters to write.

Remarks

This bypasses the entitization of special characters.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace | XmlTextWriter.WriteRaw Overload List


XmlTextWriter.WriteRaw (String)

Writes raw markup manually from a string.

[Visual Basic]
Overloads Overrides Public Sub WriteRaw( _
   ByVal data As String _
)
[C#]
public override void WriteRaw(
   string data
);
[C++]
public: override void WriteRaw(
   String* data
);
[JScript]
public override function WriteRaw(
   data : String
);

Parameters

data
[To be supplied.]

Remarks

This bypasses the entitization of special characters.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace | XmlTextWriter.WriteRaw Overload List


XmlTextWriter.WriteSingle

Writes out the specified float value.

[Visual Basic]
Overrides Public Sub WriteSingle( _
   ByVal value As Single _
)
[C#]
public override void WriteSingle(
   float value
);
[C++]
public: override void WriteSingle(
   float value
);
[JScript]
public override function WriteSingle(
   value : float
);

Parameters

value
float to write.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteStartAttribute

Writes the start of an attribute.

[Visual Basic]
Overrides Public Sub WriteStartAttribute( _
   ByVal name As String, _
   ByVal ns As String _
)
[C#]
public override void WriteStartAttribute(
   string name,
   string ns
);
[C++]
public: override void WriteStartAttribute(
   String* name,
   String* ns
);
[JScript]
public override function WriteStartAttribute(
   name : String,
   ns : String
);

Parameters

name
Name of the attribute.
ns
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentException | The attribute is named "xmlns:xml" and Namespaces is true. This is invalid according to the namespace spec.

Remarks

This is a more advanced version of WriteAttribute that allows you to write an attribute value using multiple write methods, such as WriteString, WriteChar, WriteInt, and so on. For example:

writer.WriteStartElement("item");
writer.WriteStartAttribute("ids",null);
    writer.WriteInt(12);
    writer.WriteInt(25);
    writer.WriteInt(17);
writer.WriteEndAttribute();
writer.WriteInt(122);
writer.WriteEndElement();

which produces the following output:

<item id="12 25 17">122</item>

Notice that the WriteEndAttribute makes the last call to WriteInt(122) generate element content instead of attribute content.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteStartElement

Writes out the specified start tag and associates it with the given namespace.

[Visual Basic]
Overrides Public Sub WriteStartElement( _
   ByVal name As String, _
   ByVal ns As String _
)
[C#]
public override void WriteStartElement(
   string name,
   string ns
);
[C++]
public: override void WriteStartElement(
   String* name,
   String* ns
);
[JScript]
public override function WriteStartElement(
   name : String,
   ns : String
);

Parameters

name
The name argument can contain a prefix in which case uses this prefix and associates this prefix with the given namespace for the scope of this element.
ns
The namespace URI to associate with the element. If this namespace is already in scope and has an associated prefix then the writer will automatically write that prefix also.

Exceptions

Exception Type | Condition
InvalidOperationException | If writer is closed.

Remarks

After calling this method you can either write attributes, or you can go directly to content (WriteComment, WriteString, or WriteStartElement for child elements). You must close this element with WriteEndElement at which time a full end tag is written out. For example:

[C#]

writer.WriteStartElement("foo",null");
writer.WriteEndElement();

will generate the following output:

[C#]

<foo></foo>

If you want to write an empty element with the "/>" syntax, then use WriteEmptyElement .

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteString

Writes out the specified text content.

[Visual Basic]
Overrides Public Sub WriteString( _
   ByVal text As String _
)
[C#]
public override void WriteString(
   string text
);
[C++]
public: override void WriteString(
   String* text
);
[JScript]
public override function WriteString(
   text : String
);

Parameters

text
Text to write.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteTime

Writes out the specified Time value.

[Visual Basic]
Overrides Public Sub WriteTime( _
   ByVal value As DateTime _
)
[C#]
public override void WriteTime(
   DateTime value
);
[C++]
public: override void WriteTime(
   DateTime value
);
[JScript]
public override function WriteTime(
   value : DateTime
);

Parameters

value
DateTime to write.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteTimeSpan

Writes out the specified TimeSpan value.

[Visual Basic]
Overrides Public Sub WriteTimeSpan( _
   ByVal value As TimeSpan _
)
[C#]
public override void WriteTimeSpan(
   TimeSpan value
);
[C++]
public: override void WriteTimeSpan(
   TimeSpan value
);
[JScript]
public override function WriteTimeSpan(
   value : TimeSpan
);

Parameters

value
TimeSpan to write.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteXmlDecl

Writes out the XML declaration. A call to one of the WriteXmlDecl methods must be first write call.

Overload List

Writes out the XML declaration with the version "1.0" with specified standalone attribute.

[Visual Basic] Overloads Overrides Public Sub WriteXmlDecl(Boolean)
[C#] public override void WriteXmlDecl(bool);
[C++] public: override void WriteXmlDecl(bool);
[JScript] public override function WriteXmlDecl(Boolean);

Writes out the XML declaration with the version "1.0".

[Visual Basic] Overloads Overrides Public Sub WriteXmlDecl()
[C#] public override void WriteXmlDecl();
[C++] public: override void WriteXmlDecl();
[JScript] public override function WriteXmlDecl();

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace


XmlTextWriter.WriteXmlDecl (Boolean)

Writes out the XML declaration with the version "1.0" with specified standalone attribute.

[Visual Basic]
Overloads Overrides Public Sub WriteXmlDecl( _
   ByVal standalone As Boolean _
)
[C#]
public override void WriteXmlDecl(
   bool standalone
);
[C++]
public: override void WriteXmlDecl(
   bool standalone
);
[JScript]
public override function WriteXmlDecl(
   standalone : Boolean
);

Parameters

standalone
true writes standalone="yes"; false writes standalone="no".

Exceptions

Exception Type | Condition
InvalidOperationException | This was not the first write call.

Remarks

A call to one of the WriteXmlDecl methods must be first write call. The encoding attribute is determined by the implementation. For example, the XmlTextWriter constructor takes an Encoding object which determines the value of the encoding attribute.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace | XmlTextWriter.WriteXmlDecl Overload List


XmlTextWriter.WriteXmlDecl ()

Writes out the XML declaration with the version "1.0".

[Visual Basic]
Overloads Overrides Public Sub WriteXmlDecl()
[C#]
public override void WriteXmlDecl();
[C++]
public: override void WriteXmlDecl();
[JScript]
public override function WriteXmlDecl();

Exceptions

Exception Type | Condition
InvalidOperationException | This was not the first write call.

Remarks

A call to one of the WriteXmlDecl methods must be first write call. The encoding attribute is determined by the implementation. For example, the XmlTextWriter constructor takes an Encoding object which determines the value of the encoding attribute. No standalone attribute is written.

See Also

XmlTextWriter Class | XmlTextWriter Members | System.NewXml Namespace | XmlTextWriter.WriteXmlDecl Overload List


XmlUrlResolver Class

Resolves external XML resources named by a URI.

Object
XmlResolver
XmlUrlResolver

[Visual Basic]
Public Class XmlUrlResolver
   Inherits XmlResolver
[C#]
public class XmlUrlResolver : XmlResolver
[C++]
public __gc class XmlUrlResolver : public XmlResolver
[JScript]
public class XmlUrlResolver extends XmlResolver

Remarks

XmlUrlResolver is used by XmlTextReader to load external DTD's, entities, and schemas. It is also used by XslTransform to process <xsl:include> elements.

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

XmlUrlResolver Members | System.NewXml Namespace


XmlUrlResolver Members

Public:

Constructor

XmlUrlResolver Constructor Overloaded. Creates a new instance of the XmlUrlResolver class.

Properties

BaseUri Gets or sets the base URL used to resolve relative URLs when GetEntity is called.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEntity | Maps a URI to an Object containing the actual resource.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlUrlResolver Class | System.NewXml Namespace


XmlUrlResolver Constructor

Creates a new instance of the XmlUrlResolver class.

Overload List

Creates a new instance of the XmlUrlResolver class.

[Visual Basic] Overloads Public Sub New()
[C#] public XmlUrlResolver();
[C++] public: XmlUrlResolver();
[JScript] public function XmlUrlResolver();

Creates a new instance of the XmlUrlResolver class using the specified base URL.

[Visual Basic] Overloads Public Sub New(String)
[C#] public XmlUrlResolver(String);
[C++] public: XmlUrlResolver(String*);
[JScript] public function XmlUrlResolver(String);

See Also

XmlUrlResolver Class | XmlUrlResolver Members | System.NewXml Namespace


XmlUrlResolver Constructor ()

Creates a new instance of the XmlUrlResolver class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public XmlUrlResolver();
[C++]
public: XmlUrlResolver();
[JScript]
public function XmlUrlResolver();

See Also

XmlUrlResolver Class | XmlUrlResolver Members | System.NewXml Namespace | XmlUrlResolver Constructor Overload List


XmlUrlResolver Constructor (String)

Creates a new instance of the XmlUrlResolver class using the specified base URL.

[Visual Basic]
Overloads Public Sub New( _
   ByVal baseURI As String _
)
[C#]
public XmlUrlResolver(
   string baseURI
);
[C++]
public: XmlUrlResolver(
   String* baseURI
);
[JScript]
public function XmlUrlResolver(
   baseURI : String
);

Parameters

baseURI
URL used to resolve relative URLs when GetEntity is called. You can pass a null baseURL in which case the XmlUrlResolver will not be able to resolve relative URLs.

See Also

XmlUrlResolver Class | XmlUrlResolver Members | System.NewXml Namespace | XmlUrlResolver Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlUrlResolver Properties

The properties of the XmlUrlResolver class are listed below. For a complete list of XmlUrlResolver class members, see the XmlUrlResolver Members topic.

Public:

BaseUri Gets or sets the base URL used to resolve relative URLs when GetEntity is called.

See Also

XmlUrlResolver Class | System.NewXml Namespace


XmlUrlResolver.BaseUri

Gets or sets the base URL used to resolve relative URLs when GetEntity is called.

[Visual Basic]
Public Property BaseUri As String
[C#]
public string BaseUri {get; set;}
[C++]
public: __property String* get_BaseUri();
public: __property void set_BaseUri(String*);
[JScript]
public function get BaseUri() : String;
public function set BaseUri(String);

Property Value

The base URL used to resolve relative URLs when GetEntity is called.

See Also

XmlUrlResolver Class | XmlUrlResolver Members | System.NewXml Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlUrlResolver Methods

The methods of the XmlUrlResolver class are listed below. For a complete list of XmlUrlResolver class members, see the XmlUrlResolver Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEntity | Maps a URI to an Object containing the actual resource.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlUrlResolver Class | System.NewXml Namespace


XmlUrlResolver.GetEntity

Maps a URI to an Object containing the actual resource.

[Visual Basic]
Overrides Public Function GetEntity( _
   ByVal baseUri As String, _
   ByVal relativeUri As String, _
   ByVal role As String, _
   ByVal t As Type, _
   ByRef resolvedUri As String _
) As Object
[C#]
public override object GetEntity(
   string baseUri,
   string relativeUri,
   string role,
   Type t,
   ref string resolvedUri
);
[C++]
public: override Object* GetEntity(
   String* baseUri,
   String* relativeUri,
   String* role,
   Type* t,
   String** resolvedUri
);
[JScript]
public override function GetEntity(
   baseUri : String,
   relativeUri : String,
   role : String,
   t : Type,
   resolvedUri : String
) : Object;

Parameters

baseUri
The URI of the resource containing thethat we are trying to resolve. This can be also used by an HTTP resolver as the REFERRER in the HTTP header.
relativeUri
The URI to resolve.
role
A user defined string that gives the XmlResolver some clue as to how the resource is going to be used. This would map to the xlink:role and could be used as an implementation specific argument in other scenarios. In the <!DOCTYPE and <ENTITY case this argument is the PUBLIC identifier.
t
[To be supplied.]
resolvedUri
This URI is returned to the caller and may be different from the initialparameter. It is a way for the resolver to communicate with the caller what the real fully resolved identity of the returned Object actually is. Thiscan then be used as thefor any subsequent requests for resources referenced by this object.

The caller can then use this information to check for circular dependencies. Another use of this might someone who is implementing cross-domain data security policy. The returnedtakes into account any HTTP redirections- which is required for such a security mechanism to be fully secure.

Return Value

Returns the object matching the requested Type or null if the Type is not supported or if the URI is not resolvable.

Exceptions

Exception Type | Condition
Exception | if there is any sort of runtime error like a connection to a server is down, etc.

Remarks

This method is used when the caller wants to map a given URI into the Object containing the actual resource that that URI represents. The type of object returned is negotiable but the implemention must at least always support System.IO.Stream.

Other implementations may provide even higher level objects representing for even greater efficiency. For example, pre-compiled Schemas for validation or pre-compiled XSL stylesheets for use during transformation.

See Also

XmlUrlResolver Class | XmlUrlResolver Members | System.NewXml Namespace


XmlWriter Class

Represents a writer that provides fast non-cached forward-only way of generating XML streams containing XML documents that conform to the W3C Extensible Markup Language (XML) 1.0 specification and the Namespaces in XML specification.

This class is abstract.

Object
XmlWriter

[Visual Basic]
MustInherit Public Class XmlWriter
[C#]
public abstract class XmlWriter
[C++]
public __gc __abstract class XmlWriter
[JScript]
public abstract class XmlWriter

Remarks

[To be supplied.]

Requirements

Namespace: System.NewXml

Assembly: System.Xml.dll

See Also

XmlWriter Members | System.NewXml Namespace


XmlWriter Members

Public:

Constructor

XmlWriter Constructor [To be supplied.]

Properties

WriteState | Gets the state of the stream.
XmlLang | Gets the current xml:lang scope.
XmlSpace | Gets an XmlSpace representing the current xml:space scope.

Methods

Close | Close this stream and the underlying stream.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Flush | Flush whatever is in the buffer to the underlying streams and flush the underlying stream.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
LookupPrefix | Returns the prefix defined in the current namespace scope for the specified namespace URI.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteAttrBoolean | Overloaded. Writes out an attribute with a boolean value.
WriteAttrDate | Overloaded. Writes out an attribute with a Date value.
WriteAttrDateTime | Overloaded. Writes out an attribute with a DateTime value.
WriteAttrDecimal | Overloaded. Writes out an attribute with a Decimal value.
WriteAttrDouble | Overloaded. Writes out an attribute with a Double value.
WriteAttribute | Overloaded. Writes out specified attribute with the specified value.
WriteAttributes | Writes out all the attributes found at the current position in the specified XmlReader
WriteAttrInt16 | Overloaded. Writes out an attribute with a Int16 value.
WriteAttrInt32 | Overloaded. Writes out an attribute with a Int32 value.
WriteAttrInt64 | Overloaded. Writes out an attribute with a Int64 value.
WriteAttrSingle | Overloaded. Writes out an attribute with a Single value.
WriteAttrTime | Overloaded. Writes out an attribute with a Time value.
WriteAttrTimeSpan | Overloaded. Writes out an attribute with a TimeSpan value.
WriteBase64 | Encodes the specified binary bytes as base64 and writes out the resulting text.
WriteBinHex | Encodes the specified binary bytes as binhex and writes out the resulting text.
WriteBoolean | Writes out the specified boolean value.
WriteCData | Writes out a <![CDATA[...]]> block containing the specified text.
WriteChar | Writes out the specified single character value.
WriteCharEntity | Forces the generation of a character entity for the specified Unicode character value.
WriteChars | Writes text a buffer at a time.
WriteComment | Writes out a comment <!--...--> containing the specified text.
WriteDate | Writes out the specified Date value.
WriteDateTime | Writes out the specified DateTime value.
WriteDecimal | Writes out the specified Decimal value.
WriteDocType | Writes out the DOCTYPE declaration with the specified name and optional attributes.
WriteDouble | Writes out the specified Double value.
WriteElementBoolean | Overloaded. Writes out an element containing a boolean value.
WriteElementDate | Overloaded. Writes out an element containing a Date value.
WriteElementDateTime | Overloaded. Writes out an element containing a DateTime value.
WriteElementDecimal | Overloaded. Writes out an element containing a Decimal value.
WriteElementDouble | Overloaded. Writes out an element containing a Double value.
WriteElementInt16 | Overloaded. Writes out an element containing a Int16 value.
WriteElementInt32 | Overloaded. Writes out an element containing a Int32 value.
WriteElementInt64 | Overloaded. Writes out an element containing a Int64 value.
WriteElementSingle | Overloaded. Writes out an element containing a Single value.
WriteElementString | Overloaded. Writes out an element containing a string value.
WriteElementTime | Overloaded. Writes out an element containing a Time value.
WriteElementTimeSpan | Overloaded. Writes out an element containing a TimeSpan value.
WriteEmptyElement | Writes an empty tag that ends with "/>".
WriteEndAttribute | Closes the previous WriteStartAttribute call.
WriteEndElement | Closes one element and pops the corresponding namespace scope.
WriteEntityRef | Writes out an entity reference as follows: "&"+name+";".
WriteInt16 | Writes out the specified Int16 value.
WriteInt32 | Writes out the specified Int32 value.
WriteInt64 | Writes out the specified Int64 value.
WriteName | Writes out the specified name, ensuring it is a valid Name according to the XML specification (href="
WriteNmToken | Writes out the specified name, ensuring it is a valid NmToken according to the XML specification (
WriteNode | Copies everything from the given reader to the writer, moving the XmlReader to the end of the current element.
WriteProcessingInstruction | Writes out a processing instruction with a space between the name and text as follows: <?name text?>.
WriteQualifiedName | Writes out the specified namespace-qualified name by looking up the prefix that is in scope for the given namespace.
WriteRaw | Overloaded. Writes raw markup manually.
WriteSingle | Writes out the specified float value.
WriteStartAttribute | Writes the start of an attribute.
WriteStartElement | Overloaded. Writes out the specified start tag.
WriteString | Writes out the specified text content.
WriteTime | Writes out the specified Time value.
WriteTimeSpan | Writes out the specified TimeSpan value.
WriteXmlDecl | Overloaded. Writes out the XML declaration. A call to one of the WriteXmlDecl methods must be first write call.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlWriter Class | System.NewXml Namespace


XmlWriter Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public XmlWriter();
[C++]
public: XmlWriter();
[JScript]
public function XmlWriter();

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlWriter Properties

The properties of the XmlWriter class are listed below. For a complete list of XmlWriter class members, see the XmlWriter Members topic.

Public:

WriteState | Gets the state of the stream.
XmlLang | Gets the current xml:lang scope.
XmlSpace | Gets an XmlSpace representing the current xml:space scope.

See Also

XmlWriter Class | System.NewXml Namespace


XmlWriter.WriteState

Gets the state of the stream.

[Visual Basic]
MustOverride Public ReadOnly Property WriteState As WriteState
[C#]
public WriteState WriteState {abstract get;}
[C++]
public: __property virtual WriteState get_WriteState() = 0;
[JScript]
public abstract function get WriteState() : WriteState;

Property Value

One of the WriteState values.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.XmlLang

Gets the current xml:lang scope.

[Visual Basic]
MustOverride Public ReadOnly Property XmlLang As String
[C#]
public string XmlLang {abstract get;}
[C++]
public: __property virtual String* get_XmlLang() = 0;
[JScript]
public abstract function get XmlLang() : String;

Property Value

The current xml:lang scope.

Remarks

This allows one component to find out what state another component has left the writer in. Perhaps one component wants to tell the other which language help text to generate and it communicates the language information by writing an xml:lang attribute.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.XmlSpace

Gets an XmlSpace representing the current xml:space scope.

[Visual Basic]
MustOverride Public ReadOnly Property XmlSpace As XmlSpace
[C#]
public XmlSpace XmlSpace {abstract get;}
[C++]
public: __property virtual XmlSpace get_XmlSpace() = 0;
[JScript]
public abstract function get XmlSpace() : XmlSpace;

Property Value

The current xml:space scope.

Value | Meaning
None (0) | This is the default if no xml:space scope exists
Default (1) | In the scope of xml:space="default"
Preserve (2) | In the scope of xml:space="preserve".

This allows one component to find out what state another component has left the writer in.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XmlWriter Methods

The methods of the XmlWriter class are listed below. For a complete list of XmlWriter class members, see the XmlWriter Members topic.

Public:

Close | Close this stream and the underlying stream.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Flush | Flush whatever is in the buffer to the underlying streams and flush the underlying stream.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
LookupPrefix | Returns the prefix defined in the current namespace scope for the specified namespace URI.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteAttrBoolean | Overloaded. Writes out an attribute with a boolean value.
WriteAttrDate | Overloaded. Writes out an attribute with a Date value.
WriteAttrDateTime | Overloaded. Writes out an attribute with a DateTime value.
WriteAttrDecimal | Overloaded. Writes out an attribute with a Decimal value.
WriteAttrDouble | Overloaded. Writes out an attribute with a Double value.
WriteAttribute | Overloaded. Writes out specified attribute with the specified value.
WriteAttributes | Writes out all the attributes found at the current position in the specified XmlReader
WriteAttrInt16 | Overloaded. Writes out an attribute with a Int16 value.
WriteAttrInt32 | Overloaded. Writes out an attribute with a Int32 value.
WriteAttrInt64 | Overloaded. Writes out an attribute with a Int64 value.
WriteAttrSingle | Overloaded. Writes out an attribute with a Single value.
WriteAttrTime | Overloaded. Writes out an attribute with a Time value.
WriteAttrTimeSpan | Overloaded. Writes out an attribute with a TimeSpan value.
WriteBase64 | Encodes the specified binary bytes as base64 and writes out the resulting text.
WriteBinHex | Encodes the specified binary bytes as binhex and writes out the resulting text.
WriteBoolean | Writes out the specified boolean value.
WriteCData | Writes out a <![CDATA[...]]> block containing the specified text.
WriteChar | Writes out the specified single character value.
WriteCharEntity | Forces the generation of a character entity for the specified Unicode character value.
WriteChars | Writes text a buffer at a time.
WriteComment | Writes out a comment <!--...--> containing the specified text.
WriteDate | Writes out the specified Date value.
WriteDateTime | Writes out the specified DateTime value.
WriteDecimal | Writes out the specified Decimal value.
WriteDocType | Writes out the DOCTYPE declaration with the specified name and optional attributes.
WriteDouble | Writes out the specified Double value.
WriteElementBoolean | Overloaded. Writes out an element containing a boolean value.
WriteElementDate | Overloaded. Writes out an element containing a Date value.
WriteElementDateTime | Overloaded. Writes out an element containing a DateTime value.
WriteElementDecimal | Overloaded. Writes out an element containing a Decimal value.
WriteElementDouble | Overloaded. Writes out an element containing a Double value.
WriteElementInt16 | Overloaded. Writes out an element containing a Int16 value.
WriteElementInt32 | Overloaded. Writes out an element containing a Int32 value.
WriteElementInt64 | Overloaded. Writes out an element containing a Int64 value.
WriteElementSingle | Overloaded. Writes out an element containing a Single value.
WriteElementString | Overloaded. Writes out an element containing a string value.
WriteElementTime | Overloaded. Writes out an element containing a Time value.
WriteElementTimeSpan | Overloaded. Writes out an element containing a TimeSpan value.
WriteEmptyElement | Writes an empty tag that ends with "/>".
WriteEndAttribute | Closes the previous WriteStartAttribute call.
WriteEndElement | Closes one element and pops the corresponding namespace scope.
WriteEntityRef | Writes out an entity reference as follows: "&"+name+";".
WriteInt16 | Writes out the specified Int16 value.
WriteInt32 | Writes out the specified Int32 value.
WriteInt64 | Writes out the specified Int64 value.
WriteName | Writes out the specified name, ensuring it is a valid Name according to the XML specification (href="
WriteNmToken | Writes out the specified name, ensuring it is a valid NmToken according to the XML specification (
WriteNode | Copies everything from the given reader to the writer, moving the XmlReader to the end of the current element.
WriteProcessingInstruction | Writes out a processing instruction with a space between the name and text as follows: <?name text?>.
WriteQualifiedName | Writes out the specified namespace-qualified name by looking up the prefix that is in scope for the given namespace.
WriteRaw | Overloaded. Writes raw markup manually.
WriteSingle | Writes out the specified float value.
WriteStartAttribute | Writes the start of an attribute.
WriteStartElement | Overloaded. Writes out the specified start tag.
WriteString | Writes out the specified text content.
WriteTime | Writes out the specified Time value.
WriteTimeSpan | Writes out the specified TimeSpan value.
WriteXmlDecl | Overloaded. Writes out the XML declaration. A call to one of the WriteXmlDecl methods must be first write call.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlWriter Class | System.NewXml Namespace


XmlWriter.Close

Close this stream and the underlying stream.

[Visual Basic]
MustOverride Public Sub Close()
[C#]
public abstract void Close();
[C++]
public: virtual void Close() = 0;
[JScript]
public abstract function Close();

Remarks

Once this method is called, an InvalidOperationException is thrown if any call is made to write more output.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.Flush

Flush whatever is in the buffer to the underlying streams and flush the underlying stream.

[Visual Basic]
MustOverride Public Sub Flush()
[C#]
public abstract void Flush();
[C++]
public: virtual void Flush() = 0;
[JScript]
public abstract function Flush();

Remarks

This is called instead of Close() when you want to write more to the underlying stream without losing what is still in the XmlWriter buffer.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.LookupPrefix

Returns the prefix defined in the current namespace scope for the specified namespace URI.

[Visual Basic]
MustOverride Public Function LookupPrefix( _
   ByVal ns As String _
) As String
[C#]
public abstract string LookupPrefix(
   string ns
);
[C++]
public: virtual String* LookupPrefix(
   String* ns
) = 0;
[JScript]
public abstract function LookupPrefix(
   ns : String
) : String;

Parameters

ns
Namespace URI whose prefix you want to find.

Return Value

The matching prefix. Or null if no matching namespace URI is in scope.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteAttrBoolean

Writes out an attribute with a boolean value.

Overload List

Writes out an attribute with the specified name and boolean value.

[Visual Basic] Overloads Public Sub WriteAttrBoolean(String, Boolean)
[C#] public void WriteAttrBoolean(String, bool);
[C++] public: void WriteAttrBoolean(String*, bool);
[JScript] public function WriteAttrBoolean(String, Boolean);

Writes out an attribute with the specified name, namespace URI, and boolean value.

[Visual Basic] Overloads Public Sub WriteAttrBoolean(String, String, Boolean)
[C#] public void WriteAttrBoolean(String, String, bool);
[C++] public: void WriteAttrBoolean(String*, String*, bool);
[JScript] public function WriteAttrBoolean(String, String, Boolean);

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteAttrBoolean (String, Boolean)

Writes out an attribute with the specified name and boolean value.

[Visual Basic]
Overloads Public Sub WriteAttrBoolean( _
   ByVal name As String, _
   ByVal value As Boolean _
)
[C#]
public void WriteAttrBoolean(
   string name,
   bool value
);
[C++]
public: void WriteAttrBoolean(
   String* name,
   bool value
);
[JScript]
public function WriteAttrBoolean(
   name : String,
   value : Boolean
);

Parameters

name
Name of attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteAttrBoolean Overload List


XmlWriter.WriteAttrBoolean (String, String, Boolean)

Writes out an attribute with the specified name, namespace URI, and boolean value.

[Visual Basic]
Overloads Public Sub WriteAttrBoolean( _
   ByVal name As String, _
   ByVal ns As String, _
   ByVal value As Boolean _
)
[C#]
public void WriteAttrBoolean(
   string name,
   string ns,
   bool value
);
[C++]
public: void WriteAttrBoolean(
   String* name,
   String* ns,
   bool value
);
[JScript]
public function WriteAttrBoolean(
   name : String,
   ns : String,
   value : Boolean
);

Parameters

name
Name of attribute
ns
Namespace URI for the attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteAttrBoolean Overload List


XmlWriter.WriteAttrDate

Writes out an attribute with a Date value.

Overload List

Writes out an attribute with the specified name and Date value.

[Visual Basic] Overloads Public Sub WriteAttrDate(String, DateTime)
[C#] public void WriteAttrDate(String, DateTime);
[C++] public: void WriteAttrDate(String*, DateTime);
[JScript] public function WriteAttrDate(String, DateTime);

Writes out an attribute with the specified name, namespace URI, and Date value.

[Visual Basic] Overloads Public Sub WriteAttrDate(String, String, DateTime)
[C#] public void WriteAttrDate(String, String, DateTime);
[C++] public: void WriteAttrDate(String*, String*, DateTime);
[JScript] public function WriteAttrDate(String, String, DateTime);

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteAttrDate (String, DateTime)

Writes out an attribute with the specified name and Date value.

[Visual Basic]
Overloads Public Sub WriteAttrDate( _
   ByVal name As String, _
   ByVal value As DateTime _
)
[C#]
public void WriteAttrDate(
   string name,
   DateTime value
);
[C++]
public: void WriteAttrDate(
   String* name,
   DateTime value
);
[JScript]
public function WriteAttrDate(
   name : String,
   value : DateTime
);

Parameters

name
Name of attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteAttrDate Overload List


XmlWriter.WriteAttrDate (String, String, DateTime)

Writes out an attribute with the specified name, namespace URI, and Date value.

[Visual Basic]
Overloads Public Sub WriteAttrDate( _
   ByVal name As String, _
   ByVal ns As String, _
   ByVal value As DateTime _
)
[C#]
public void WriteAttrDate(
   string name,
   string ns,
   DateTime value
);
[C++]
public: void WriteAttrDate(
   String* name,
   String* ns,
   DateTime value
);
[JScript]
public function WriteAttrDate(
   name : String,
   ns : String,
   value : DateTime
);

Parameters

name
Name of attribute
ns
Namespace URI for the attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteAttrDate Overload List


XmlWriter.WriteAttrDateTime

Writes out an attribute with a DateTime value.

Overload List

Writes out an attribute with the specified name, namespace URI, and DateTime value.

[Visual Basic] Overloads Public Sub WriteAttrDateTime(String, String, DateTime)
[C#] public void WriteAttrDateTime(String, String, DateTime);
[C++] public: void WriteAttrDateTime(String*, String*, DateTime);
[JScript] public function WriteAttrDateTime(String, String, DateTime);

Writes out an attribute with the specified name and DateTime value.

[Visual Basic] Overloads Public Sub WriteAttrDateTime(String, DateTime)
[C#] public void WriteAttrDateTime(String, DateTime);
[C++] public: void WriteAttrDateTime(String*, DateTime);
[JScript] public function WriteAttrDateTime(String, DateTime);

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteAttrDateTime (String, String, DateTime)

Writes out an attribute with the specified name, namespace URI, and DateTime value.

[Visual Basic]
Overloads Public Sub WriteAttrDateTime( _
   ByVal name As String, _
   ByVal ns As String, _
   ByVal value As DateTime _
)
[C#]
public void WriteAttrDateTime(
   string name,
   string ns,
   DateTime value
);
[C++]
public: void WriteAttrDateTime(
   String* name,
   String* ns,
   DateTime value
);
[JScript]
public function WriteAttrDateTime(
   name : String,
   ns : String,
   value : DateTime
);

Parameters

name
Name of attribute
ns
Namespace URI for the attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteAttrDateTime Overload List


XmlWriter.WriteAttrDateTime (String, DateTime)

Writes out an attribute with the specified name and DateTime value.

[Visual Basic]
Overloads Public Sub WriteAttrDateTime( _
   ByVal name As String, _
   ByVal value As DateTime _
)
[C#]
public void WriteAttrDateTime(
   string name,
   DateTime value
);
[C++]
public: void WriteAttrDateTime(
   String* name,
   DateTime value
);
[JScript]
public function WriteAttrDateTime(
   name : String,
   value : DateTime
);

Parameters

name
Name of attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteAttrDateTime Overload List


XmlWriter.WriteAttrDecimal

Writes out an attribute with a Decimal value.

Overload List

Writes out an attribute with the specified name, namespace URI, and Decimal value.

[Visual Basic] Overloads Public Sub WriteAttrDecimal(String, String, Decimal)
[C#] public void WriteAttrDecimal(String, String, Decimal);
[C++] public: void WriteAttrDecimal(String*, String*, Decimal);
[JScript] public function WriteAttrDecimal(String, String, Decimal);

Writes out an attribute with the specified name and Decimal value.

[Visual Basic] Overloads Public Sub WriteAttrDecimal(String, Decimal)
[C#] public void WriteAttrDecimal(String, Decimal);
[C++] public: void WriteAttrDecimal(String*, Decimal);
[JScript] public function WriteAttrDecimal(String, Decimal);

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteAttrDecimal (String, String, Decimal)

Writes out an attribute with the specified name, namespace URI, and Decimal value.

[Visual Basic]
Overloads Public Sub WriteAttrDecimal( _
   ByVal name As String, _
   ByVal ns As String, _
   ByVal value As Decimal _
)
[C#]
public void WriteAttrDecimal(
   string name,
   string ns,
   Decimal value
);
[C++]
public: void WriteAttrDecimal(
   String* name,
   String* ns,
   Decimal value
);
[JScript]
public function WriteAttrDecimal(
   name : String,
   ns : String,
   value : Decimal
);

Parameters

name
Name of attribute
ns
Namespace URI for the attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteAttrDecimal Overload List


XmlWriter.WriteAttrDecimal (String, Decimal)

Writes out an attribute with the specified name and Decimal value.

[Visual Basic]
Overloads Public Sub WriteAttrDecimal( _
   ByVal name As String, _
   ByVal value As Decimal _
)
[C#]
public void WriteAttrDecimal(
   string name,
   Decimal value
);
[C++]
public: void WriteAttrDecimal(
   String* name,
   Decimal value
);
[JScript]
public function WriteAttrDecimal(
   name : String,
   value : Decimal
);

Parameters

name
Name of attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteAttrDecimal Overload List


XmlWriter.WriteAttrDouble

Writes out an attribute with a Double value.

Overload List

Writes out an attribute with the specified name, namespace URI, and double value.

[Visual Basic] Overloads Public Sub WriteAttrDouble(String, String, Double)
[C#] public void WriteAttrDouble(String, String, double);
[C++] public: void WriteAttrDouble(String*, String*, double);
[JScript] public function WriteAttrDouble(String, String, double);

Writes out an attribute with the specified name and Double value.

[Visual Basic] Overloads Public Sub WriteAttrDouble(String, Double)
[C#] public void WriteAttrDouble(String, double);
[C++] public: void WriteAttrDouble(String*, double);
[JScript] public function WriteAttrDouble(String, double);

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteAttrDouble (String, String, Double)

Writes out an attribute with the specified name, namespace URI, and double value.

[Visual Basic]
Overloads Public Sub WriteAttrDouble( _
   ByVal name As String, _
   ByVal ns As String, _
   ByVal value As Double _
)
[C#]
public void WriteAttrDouble(
   string name,
   string ns,
   double value
);
[C++]
public: void WriteAttrDouble(
   String* name,
   String* ns,
   double value
);
[JScript]
public function WriteAttrDouble(
   name : String,
   ns : String,
   value : double
);

Parameters

name
Name of attribute
ns
Namespace URI for the attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteAttrDouble Overload List


XmlWriter.WriteAttrDouble (String, Double)

Writes out an attribute with the specified name and Double value.

[Visual Basic]
Overloads Public Sub WriteAttrDouble( _
   ByVal name As String, _
   ByVal value As Double _
)
[C#]
public void WriteAttrDouble(
   string name,
   double value
);
[C++]
public: void WriteAttrDouble(
   String* name,
   double value
);
[JScript]
public function WriteAttrDouble(
   name : String,
   value : double
);

Parameters

name
Name of attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteAttrDouble Overload List


XmlWriter.WriteAttribute

Writes out specified attribute with the specified value.

Overload List

Writes out the attribute with the specified name, value, and namespace.

[Visual Basic] Overloads Public Sub WriteAttribute(String, String, String)
[C#] public void WriteAttribute(String, String, String);
[C++] public: void WriteAttribute(String*, String*, String*);
[JScript] public function WriteAttribute(String, String, String);

Writes out the attribute with the specified name and value.

[Visual Basic] Overloads Public Sub WriteAttribute(String, String)
[C#] public void WriteAttribute(String, String);
[C++] public: void WriteAttribute(String*, String*);
[JScript] public function WriteAttribute(String, String);

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteAttribute (String, String, String)

Writes out the attribute with the specified name, value, and namespace.

[Visual Basic]
Overloads Public Sub WriteAttribute( _
   ByVal name As String, _
   ByVal ns As String, _
   ByVal value As String _
)
[C#]
public void WriteAttribute(
   string name,
   string ns,
   string value
);
[C++]
public: void WriteAttribute(
   String* name,
   String* ns,
   String* value
);
[JScript]
public function WriteAttribute(
   name : String,
   ns : String,
   value : String
);

Parameters

name
Name of the attribute.
ns
[To be supplied.]
value
[To be supplied.]

Exceptions

Exception Type | Condition
InvalidOperationException | Writer is not WriteState.Element or writer is closed.

Remarks

If the name is "xmlns" or starts with "xmlns:", this method also treats this as a namespace declaration and assocates the declared prefix with the given namespace.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteAttribute Overload List


XmlWriter.WriteAttribute (String, String)

Writes out the attribute with the specified name and value.

[Visual Basic]
Overloads Public Sub WriteAttribute( _
   ByVal name As String, _
   ByVal value As String _
)
[C#]
public void WriteAttribute(
   string name,
   string value
);
[C++]
public: void WriteAttribute(
   String* name,
   String* value
);
[JScript]
public function WriteAttribute(
   name : String,
   value : String
);

Parameters

name
Name of the attribute.
value
[To be supplied.]

Exceptions

Exception Type | Condition
InvalidOperationException | Writer is not WriteState.Element or writer is closed.

Remarks

If the name is "xmlns" or starts with "xmlns:", this method also treats this as a namespace declaration and assocates the declared prefix with the given namespace.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteAttribute Overload List


XmlWriter.WriteAttributes

Writes out all the attributes found at the current position in the specified XmlReader

[Visual Basic]
Public Sub WriteAttributes( _
   ByVal reader As XmlReader, _
   ByVal defattr As Boolean _
)
[C#]
public void WriteAttributes(
   XmlReader reader,
   bool defattr
);
[C++]
public: void WriteAttributes(
   XmlReader* reader,
   bool defattr
);
[JScript]
public function WriteAttributes(
   reader : XmlReader,
   defattr : Boolean
);

Parameters

reader
XmlReader to copy the attributes from
defattr
Whether to also copy the default attributes from the XmlReader.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteAttrInt16

Writes out an attribute with a Int16 value.

Overload List

Writes out an attribute with the specified name and Int16 value.

[Visual Basic] Overloads Public Sub WriteAttrInt16(String, Integer)
[C#] public void WriteAttrInt16(String, short);
[C++] public: void WriteAttrInt16(String*, short);
[JScript] public function WriteAttrInt16(String, Int16);

Writes out an attribute with the specified name, namespace URI, and Int16 value.

[Visual Basic] Overloads Public Sub WriteAttrInt16(String, String, Integer)
[C#] public void WriteAttrInt16(String, String, short);
[C++] public: void WriteAttrInt16(String*, String*, short);
[JScript] public function WriteAttrInt16(String, String, Int16);

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteAttrInt16 (String, Int16)

Writes out an attribute with the specified name and Int16 value.

[Visual Basic]
Overloads Public Sub WriteAttrInt16( _
   ByVal name As String, _
   ByVal value As Short _
)
[C#]
public void WriteAttrInt16(
   string name,
   short value
);
[C++]
public: void WriteAttrInt16(
   String* name,
   short value
);
[JScript]
public function WriteAttrInt16(
   name : String,
   value : Int16
);

Parameters

name
Name of attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteAttrInt16 Overload List


XmlWriter.WriteAttrInt16 (String, String, Int16)

Writes out an attribute with the specified name, namespace URI, and Int16 value.

[Visual Basic]
Overloads Public Sub WriteAttrInt16( _
   ByVal name As String, _
   ByVal ns As String, _
   ByVal value As Short _
)
[C#]
public void WriteAttrInt16(
   string name,
   string ns,
   short value
);
[C++]
public: void WriteAttrInt16(
   String* name,
   String* ns,
   short value
);
[JScript]
public function WriteAttrInt16(
   name : String,
   ns : String,
   value : Int16
);

Parameters

name
Name of attribute
ns
Namespace URI for the attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteAttrInt16 Overload List


XmlWriter.WriteAttrInt32

Writes out an attribute with a Int32 value.

Overload List

Writes out an attribute with the specified name, namespace URI, and Int32 value.

[Visual Basic] Overloads Public Sub WriteAttrInt32(String, String, Integer)
[C#] public void WriteAttrInt32(String, String, int);
[C++] public: void WriteAttrInt32(String*, String*, int);
[JScript] public function WriteAttrInt32(String, String, int);

Writes out an attribute with the specified name and Int32 value.

[Visual Basic] Overloads Public Sub WriteAttrInt32(String, Integer)
[C#] public void WriteAttrInt32(String, int);
[C++] public: void WriteAttrInt32(String*, int);
[JScript] public function WriteAttrInt32(String, int);

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteAttrInt32 (String, String, Int32)

Writes out an attribute with the specified name, namespace URI, and Int32 value.

[Visual Basic]
Overloads Public Sub WriteAttrInt32( _
   ByVal name As String, _
   ByVal ns As String, _
   ByVal value As Integer _
)
[C#]
public void WriteAttrInt32(
   string name,
   string ns,
   int value
);
[C++]
public: void WriteAttrInt32(
   String* name,
   String* ns,
   int value
);
[JScript]
public function WriteAttrInt32(
   name : String,
   ns : String,
   value : int
);

Parameters

name
Name of attribute
ns
Namespace URI for the attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteAttrInt32 Overload List


XmlWriter.WriteAttrInt32 (String, Int32)

Writes out an attribute with the specified name and Int32 value.

[Visual Basic]
Overloads Public Sub WriteAttrInt32( _
   ByVal name As String, _
   ByVal value As Integer _
)
[C#]
public void WriteAttrInt32(
   string name,
   int value
);
[C++]
public: void WriteAttrInt32(
   String* name,
   int value
);
[JScript]
public function WriteAttrInt32(
   name : String,
   value : int
);

Parameters

name
Name of attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteAttrInt32 Overload List


XmlWriter.WriteAttrInt64

Writes out an attribute with a Int64 value.

Overload List

Writes out an attribute with the specified name, namespace URI, and Int64 value.

[Visual Basic] Overloads Public Sub WriteAttrInt64(String, String, Long)
[C#] public void WriteAttrInt64(String, String, long);
[C++] public: void WriteAttrInt64(String*, String*, __int64);
[JScript] public function WriteAttrInt64(String, String, long);

Writes out an attribute with the specified name and Int64 value.

[Visual Basic] Overloads Public Sub WriteAttrInt64(String, Long)
[C#] public void WriteAttrInt64(String, long);
[C++] public: void WriteAttrInt64(String*, __int64);
[JScript] public function WriteAttrInt64(String, long);

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteAttrInt64 (String, String, Int64)

Writes out an attribute with the specified name, namespace URI, and Int64 value.

[Visual Basic]
Overloads Public Sub WriteAttrInt64( _
   ByVal name As String, _
   ByVal ns As String, _
   ByVal value As Long _
)
[C#]
public void WriteAttrInt64(
   string name,
   string ns,
   long value
);
[C++]
public: void WriteAttrInt64(
   String* name,
   String* ns,
   __int64 value
);
[JScript]
public function WriteAttrInt64(
   name : String,
   ns : String,
   value : long
);

Parameters

name
Name of attribute
ns
Namespace URI for the attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteAttrInt64 Overload List


XmlWriter.WriteAttrInt64 (String, Int64)

Writes out an attribute with the specified name and Int64 value.

[Visual Basic]
Overloads Public Sub WriteAttrInt64( _
   ByVal name As String, _
   ByVal value As Long _
)
[C#]
public void WriteAttrInt64(
   string name,
   long value
);
[C++]
public: void WriteAttrInt64(
   String* name,
   __int64 value
);
[JScript]
public function WriteAttrInt64(
   name : String,
   value : long
);

Parameters

name
Name of attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteAttrInt64 Overload List


XmlWriter.WriteAttrSingle

Writes out an attribute with a Single value.

Overload List

Writes out an attribute with the specified name and Single value.

[Visual Basic] Overloads Public Sub WriteAttrSingle(String, Single)
[C#] public void WriteAttrSingle(String, float);
[C++] public: void WriteAttrSingle(String*, float);
[JScript] public function WriteAttrSingle(String, float);

Writes out an attribute with the specified name, namespace URI, and Single value.

[Visual Basic] Overloads Public Sub WriteAttrSingle(String, String, Single)
[C#] public void WriteAttrSingle(String, String, float);
[C++] public: void WriteAttrSingle(String*, String*, float);
[JScript] public function WriteAttrSingle(String, String, float);

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteAttrSingle (String, Single)

Writes out an attribute with the specified name and Single value.

[Visual Basic]
Overloads Public Sub WriteAttrSingle( _
   ByVal name As String, _
   ByVal value As Single _
)
[C#]
public void WriteAttrSingle(
   string name,
   float value
);
[C++]
public: void WriteAttrSingle(
   String* name,
   float value
);
[JScript]
public function WriteAttrSingle(
   name : String,
   value : float
);

Parameters

name
Name of attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteAttrSingle Overload List


XmlWriter.WriteAttrSingle (String, String, Single)

Writes out an attribute with the specified name, namespace URI, and Single value.

[Visual Basic]
Overloads Public Sub WriteAttrSingle( _
   ByVal name As String, _
   ByVal ns As String, _
   ByVal value As Single _
)
[C#]
public void WriteAttrSingle(
   string name,
   string ns,
   float value
);
[C++]
public: void WriteAttrSingle(
   String* name,
   String* ns,
   float value
);
[JScript]
public function WriteAttrSingle(
   name : String,
   ns : String,
   value : float
);

Parameters

name
Name of attribute
ns
Namespace URI for the attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteAttrSingle Overload List


XmlWriter.WriteAttrTime

Writes out an attribute with a Time value.

Overload List

Writes out an attribute with the specified name, namespace URI, and Time value.

[Visual Basic] Overloads Public Sub WriteAttrTime(String, String, DateTime)
[C#] public void WriteAttrTime(String, String, DateTime);
[C++] public: void WriteAttrTime(String*, String*, DateTime);
[JScript] public function WriteAttrTime(String, String, DateTime);

Writes out an attribute with the specified name and Time value.

[Visual Basic] Overloads Public Sub WriteAttrTime(String, DateTime)
[C#] public void WriteAttrTime(String, DateTime);
[C++] public: void WriteAttrTime(String*, DateTime);
[JScript] public function WriteAttrTime(String, DateTime);

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteAttrTime (String, String, DateTime)

Writes out an attribute with the specified name, namespace URI, and Time value.

[Visual Basic]
Overloads Public Sub WriteAttrTime( _
   ByVal name As String, _
   ByVal ns As String, _
   ByVal value As DateTime _
)
[C#]
public void WriteAttrTime(
   string name,
   string ns,
   DateTime value
);
[C++]
public: void WriteAttrTime(
   String* name,
   String* ns,
   DateTime value
);
[JScript]
public function WriteAttrTime(
   name : String,
   ns : String,
   value : DateTime
);

Parameters

name
Name of attribute
ns
Namespace URI for the attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteAttrTime Overload List


XmlWriter.WriteAttrTime (String, DateTime)

Writes out an attribute with the specified name and Time value.

[Visual Basic]
Overloads Public Sub WriteAttrTime( _
   ByVal name As String, _
   ByVal value As DateTime _
)
[C#]
public void WriteAttrTime(
   string name,
   DateTime value
);
[C++]
public: void WriteAttrTime(
   String* name,
   DateTime value
);
[JScript]
public function WriteAttrTime(
   name : String,
   value : DateTime
);

Parameters

name
Name of attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteAttrTime Overload List


XmlWriter.WriteAttrTimeSpan

Writes out an attribute with a TimeSpan value.

Overload List

Writes out an attribute with the specified name and TimeSpan value.

[Visual Basic] Overloads Public Sub WriteAttrTimeSpan(String, TimeSpan)
[C#] public void WriteAttrTimeSpan(String, TimeSpan);
[C++] public: void WriteAttrTimeSpan(String*, TimeSpan);
[JScript] public function WriteAttrTimeSpan(String, TimeSpan);

Writes out an attribute with the specified name, namespace URI, and TimeSpan value.

[Visual Basic] Overloads Public Sub WriteAttrTimeSpan(String, String, TimeSpan)
[C#] public void WriteAttrTimeSpan(String, String, TimeSpan);
[C++] public: void WriteAttrTimeSpan(String*, String*, TimeSpan);
[JScript] public function WriteAttrTimeSpan(String, String, TimeSpan);

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteAttrTimeSpan (String, TimeSpan)

Writes out an attribute with the specified name and TimeSpan value.

[Visual Basic]
Overloads Public Sub WriteAttrTimeSpan( _
   ByVal name As String, _
   ByVal value As TimeSpan _
)
[C#]
public void WriteAttrTimeSpan(
   string name,
   TimeSpan value
);
[C++]
public: void WriteAttrTimeSpan(
   String* name,
   TimeSpan value
);
[JScript]
public function WriteAttrTimeSpan(
   name : String,
   value : TimeSpan
);

Parameters

name
Name of attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteAttrTimeSpan Overload List


XmlWriter.WriteAttrTimeSpan (String, String, TimeSpan)

Writes out an attribute with the specified name, namespace URI, and TimeSpan value.

[Visual Basic]
Overloads Public Sub WriteAttrTimeSpan( _
   ByVal name As String, _
   ByVal ns As String, _
   ByVal value As TimeSpan _
)
[C#]
public void WriteAttrTimeSpan(
   string name,
   string ns,
   TimeSpan value
);
[C++]
public: void WriteAttrTimeSpan(
   String* name,
   String* ns,
   TimeSpan value
);
[JScript]
public function WriteAttrTimeSpan(
   name : String,
   ns : String,
   value : TimeSpan
);

Parameters

name
Name of attribute
ns
Namespace URI for the attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteAttrTimeSpan Overload List


XmlWriter.WriteBase64

Encodes the specified binary bytes as base64 and writes out the resulting text.

[Visual Basic]
MustOverride Public Sub WriteBase64( _
   ByVal buffer() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
[C#]
public abstract void WriteBase64(
   byte[] buffer,
   int index,
   int count
);
[C++]
public: virtual void WriteBase64(
   unsigned char* buffer[],
   int index,
   int count
) = 0;
[JScript]
public abstract function WriteBase64(
   buffer : Byte[],
   index : int,
   count : int
);

Parameters

buffer
Byte array to encode.
index
The position within buffer indicating the start of the bytes to write.
count
The number of bytes to write.

Remarks

For example, the byte buffer may contain the binary contents of a GIF image. This clearly would not be valid XML. The Base64 encoding is designed to represent arbitrary byte sequences in a text form comprized of the 65 US-ASCII characters ([A-Za-z0-9+/=]) where each character encodes 6 bits of the binary data. See RFC 1521.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteBinHex

Encodes the specified binary bytes as binhex and writes out the resulting text.

[Visual Basic]
MustOverride Public Sub WriteBinHex( _
   ByVal buffer() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
[C#]
public abstract void WriteBinHex(
   byte[] buffer,
   int index,
   int count
);
[C++]
public: virtual void WriteBinHex(
   unsigned char* buffer[],
   int index,
   int count
) = 0;
[JScript]
public abstract function WriteBinHex(
   buffer : Byte[],
   index : int,
   count : int
);

Parameters

buffer
Byte array to encode.
index
The position within buffer indicating the start of the bytes to write.
count
The number of bytes to write.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteBoolean

Writes out the specified boolean value.

[Visual Basic]
MustOverride Public Sub WriteBoolean( _
   ByVal value As Boolean _
)
[C#]
public abstract void WriteBoolean(
   bool value
);
[C++]
public: virtual void WriteBoolean(
   bool value
) = 0;
[JScript]
public abstract function WriteBoolean(
   value : Boolean
);

Parameters

value
boolean to write.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteCData

Writes out a <![CDATA[...]]> block containing the specified text.

[Visual Basic]
MustOverride Public Sub WriteCData( _
   ByVal text As String _
)
[C#]
public abstract void WriteCData(
   string text
);
[C++]
public: virtual void WriteCData(
   String* text
) = 0;
[JScript]
public abstract function WriteCData(
   text : String
);

Parameters

text
Text to place inside the CDATA block.

Exceptions

Exception Type | Condition
ArgumentException | The text would result in a non-well formed XML document.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteChar

Writes out the specified single character value.

[Visual Basic]
MustOverride Public Sub WriteChar( _
   ByVal value As Char _
)
[C#]
public abstract void WriteChar(
   char value
);
[C++]
public: virtual void WriteChar(
   __wchar_t value
) = 0;
[JScript]
public abstract function WriteChar(
   value : Char
);

Parameters

value
Character to write.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteCharEntity

Forces the generation of a character entity for the specified Unicode character value.

[Visual Basic]
MustOverride Public Sub WriteCharEntity( _
   ByVal ch As Char _
)
[C#]
public abstract void WriteCharEntity(
   char ch
);
[C++]
public: virtual void WriteCharEntity(
   __wchar_t ch
) = 0;
[JScript]
public abstract function WriteCharEntity(
   ch : Char
);

Parameters

ch
Unicode character for which to generate a character entity.

Remarks

This method writes the specified Unicode character in hexidecimal format.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteChars

Writes text a buffer at a time.

[Visual Basic]
MustOverride Public Sub WriteChars( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
[C#]
public abstract void WriteChars(
   char[] buffer,
   int index,
   int count
);
[C++]
public: virtual void WriteChars(
   __wchar_t* buffer[],
   int index,
   int count
) = 0;
[JScript]
public abstract function WriteChars(
   buffer : Char[],
   index : int,
   count : int
);

Parameters

buffer
Character array containing the text to write.
index
The position within buffer indicating the start of the text to write.
count
The number of characters to write.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteComment

Writes out a comment <!--...--> containing the specified text.

[Visual Basic]
MustOverride Public Sub WriteComment( _
   ByVal text As String _
)
[C#]
public abstract void WriteComment(
   string text
);
[C++]
public: virtual void WriteComment(
   String* text
) = 0;
[JScript]
public abstract function WriteComment(
   text : String
);

Parameters

text
Text to place inside the comment.

Exceptions

Exception Type | Condition
ArgumentException | If the text would result in a non-well formed XML document

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteDate

Writes out the specified Date value.

[Visual Basic]
MustOverride Public Sub WriteDate( _
   ByVal value As DateTime _
)
[C#]
public abstract void WriteDate(
   DateTime value
);
[C++]
public: virtual void WriteDate(
   DateTime value
) = 0;
[JScript]
public abstract function WriteDate(
   value : DateTime
);

Parameters

value
DateTime to write.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteDateTime

Writes out the specified DateTime value.

[Visual Basic]
MustOverride Public Sub WriteDateTime( _
   ByVal value As DateTime _
)
[C#]
public abstract void WriteDateTime(
   DateTime value
);
[C++]
public: virtual void WriteDateTime(
   DateTime value
) = 0;
[JScript]
public abstract function WriteDateTime(
   value : DateTime
);

Parameters

value
DateTime to write.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteDecimal

Writes out the specified Decimal value.

[Visual Basic]
MustOverride Public Sub WriteDecimal( _
   ByVal value As Decimal _
)
[C#]
public abstract void WriteDecimal(
   Decimal value
);
[C++]
public: virtual void WriteDecimal(
   Decimal value
) = 0;
[JScript]
public abstract function WriteDecimal(
   value : Decimal
);

Parameters

value
Decimal to write.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteDocType

Writes out the DOCTYPE declaration with the specified name and optional attributes.

[Visual Basic]
MustOverride Public Sub WriteDocType( _
   ByVal name As String, _
   ByVal pubid As String, _
   ByVal sysid As String, _
   ByVal subset As String _
)
[C#]
public abstract void WriteDocType(
   string name,
   string pubid,
   string sysid,
   string subset
);
[C++]
public: virtual void WriteDocType(
   String* name,
   String* pubid,
   String* sysid,
   String* subset
) = 0;
[JScript]
public abstract function WriteDocType(
   name : String,
   pubid : String,
   sysid : String,
   subset : String
);

Parameters

name
The name of the DOCTYPE- this must be non-empty.
pubid
If non-null it also writes PUBLIC "pubid" "sysid" where pubid and sysid are replaced with the value of the given arguments.
sysid
If pubid is null and sysid is non-null it writes SYSTEM "sysid" where sysid is replaced with the value of this argument.
subset
If non-null it writes [subset] where subset is replaced with the value of this argument.

Exceptions

Exception Type | Condition
InvalidOperationException | This method was called outside the prolog (after the root element).

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteDouble

Writes out the specified Double value.

[Visual Basic]
MustOverride Public Sub WriteDouble( _
   ByVal value As Double _
)
[C#]
public abstract void WriteDouble(
   double value
);
[C++]
public: virtual void WriteDouble(
   double value
) = 0;
[JScript]
public abstract function WriteDouble(
   value : double
);

Parameters

value
Double to write.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteElementBoolean

Writes out an element containing a boolean value.

Overload List

Writes out an element with the specified name containing an boolean value.

[Visual Basic] Overloads Public Sub WriteElementBoolean(String, Boolean)
[C#] public void WriteElementBoolean(String, bool);
[C++] public: void WriteElementBoolean(String*, bool);
[JScript] public function WriteElementBoolean(String, Boolean);

Writes out an attribute with the specified name, namespace URI, and boolean value.

[Visual Basic] Overloads Public Sub WriteElementBoolean(String, String, Boolean)
[C#] public void WriteElementBoolean(String, String, bool);
[C++] public: void WriteElementBoolean(String*, String*, bool);
[JScript] public function WriteElementBoolean(String, String, Boolean);

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteElementBoolean (String, Boolean)

Writes out an element with the specified name containing an boolean value.

[Visual Basic]
Overloads Public Sub WriteElementBoolean( _
   ByVal name As String, _
   ByVal value As Boolean _
)
[C#]
public void WriteElementBoolean(
   string name,
   bool value
);
[C++]
public: void WriteElementBoolean(
   String* name,
   bool value
);
[JScript]
public function WriteElementBoolean(
   name : String,
   value : Boolean
);

Parameters

name
Name of element
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteElementBoolean Overload List


XmlWriter.WriteElementBoolean (String, String, Boolean)

Writes out an attribute with the specified name, namespace URI, and boolean value.

[Visual Basic]
Overloads Public Sub WriteElementBoolean( _
   ByVal name As String, _
   ByVal ns As String, _
   ByVal value As Boolean _
)
[C#]
public void WriteElementBoolean(
   string name,
   string ns,
   bool value
);
[C++]
public: void WriteElementBoolean(
   String* name,
   String* ns,
   bool value
);
[JScript]
public function WriteElementBoolean(
   name : String,
   ns : String,
   value : Boolean
);

Parameters

name
Name of attribute
ns
Namespace URI for the attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteElementBoolean Overload List


XmlWriter.WriteElementDate

Writes out an element containing a Date value.

Overload List

Writes out an attribute with the specified name, namespace URI, and Int64 value.

[Visual Basic] Overloads Public Sub WriteElementDate(String, String, DateTime)
[C#] public void WriteElementDate(String, String, DateTime);
[C++] public: void WriteElementDate(String*, String*, DateTime);
[JScript] public function WriteElementDate(String, String, DateTime);

Writes out an element with the specified name containing an Date value.

[Visual Basic] Overloads Public Sub WriteElementDate(String, DateTime)
[C#] public void WriteElementDate(String, DateTime);
[C++] public: void WriteElementDate(String*, DateTime);
[JScript] public function WriteElementDate(String, DateTime);

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteElementDate (String, String, DateTime)

Writes out an attribute with the specified name, namespace URI, and Int64 value.

[Visual Basic]
Overloads Public Sub WriteElementDate( _
   ByVal name As String, _
   ByVal ns As String, _
   ByVal value As DateTime _
)
[C#]
public void WriteElementDate(
   string name,
   string ns,
   DateTime value
);
[C++]
public: void WriteElementDate(
   String* name,
   String* ns,
   DateTime value
);
[JScript]
public function WriteElementDate(
   name : String,
   ns : String,
   value : DateTime
);

Parameters

name
Name of attribute
ns
Namespace URI for the attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteElementDate Overload List


XmlWriter.WriteElementDate (String, DateTime)

Writes out an element with the specified name containing an Date value.

[Visual Basic]
Overloads Public Sub WriteElementDate( _
   ByVal name As String, _
   ByVal value As DateTime _
)
[C#]
public void WriteElementDate(
   string name,
   DateTime value
);
[C++]
public: void WriteElementDate(
   String* name,
   DateTime value
);
[JScript]
public function WriteElementDate(
   name : String,
   value : DateTime
);

Parameters

name
Name of element
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteElementDate Overload List


XmlWriter.WriteElementDateTime

Writes out an element containing a DateTime value.

Overload List

Writes out an attribute with the specified name, namespace URI, and DateTime value.

[Visual Basic] Overloads Public Sub WriteElementDateTime(String, String, DateTime)
[C#] public void WriteElementDateTime(String, String, DateTime);
[C++] public: void WriteElementDateTime(String*, String*, DateTime);
[JScript] public function WriteElementDateTime(String, String, DateTime);

Writes out an element with the specified name containing an DateTime value.

[Visual Basic] Overloads Public Sub WriteElementDateTime(String, DateTime)
[C#] public void WriteElementDateTime(String, DateTime);
[C++] public: void WriteElementDateTime(String*, DateTime);
[JScript] public function WriteElementDateTime(String, DateTime);

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteElementDateTime (String, String, DateTime)

Writes out an attribute with the specified name, namespace URI, and DateTime value.

[Visual Basic]
Overloads Public Sub WriteElementDateTime( _
   ByVal name As String, _
   ByVal ns As String, _
   ByVal value As DateTime _
)
[C#]
public void WriteElementDateTime(
   string name,
   string ns,
   DateTime value
);
[C++]
public: void WriteElementDateTime(
   String* name,
   String* ns,
   DateTime value
);
[JScript]
public function WriteElementDateTime(
   name : String,
   ns : String,
   value : DateTime
);

Parameters

name
Name of attribute
ns
Namespace URI for the attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteElementDateTime Overload List


XmlWriter.WriteElementDateTime (String, DateTime)

Writes out an element with the specified name containing an DateTime value.

[Visual Basic]
Overloads Public Sub WriteElementDateTime( _
   ByVal name As String, _
   ByVal value As DateTime _
)
[C#]
public void WriteElementDateTime(
   string name,
   DateTime value
);
[C++]
public: void WriteElementDateTime(
   String* name,
   DateTime value
);
[JScript]
public function WriteElementDateTime(
   name : String,
   value : DateTime
);

Parameters

name
Name of element
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteElementDateTime Overload List


XmlWriter.WriteElementDecimal

Writes out an element containing a Decimal value.

Overload List

Writes out an attribute with the specified name, namespace URI, and Decimal value.

[Visual Basic] Overloads Public Sub WriteElementDecimal(String, String, Decimal)
[C#] public void WriteElementDecimal(String, String, Decimal);
[C++] public: void WriteElementDecimal(String*, String*, Decimal);
[JScript] public function WriteElementDecimal(String, String, Decimal);

Writes out an element with the specified name containing an Decimal value.

[Visual Basic] Overloads Public Sub WriteElementDecimal(String, Decimal)
[C#] public void WriteElementDecimal(String, Decimal);
[C++] public: void WriteElementDecimal(String*, Decimal);
[JScript] public function WriteElementDecimal(String, Decimal);

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteElementDecimal (String, String, Decimal)

Writes out an attribute with the specified name, namespace URI, and Decimal value.

[Visual Basic]
Overloads Public Sub WriteElementDecimal( _
   ByVal name As String, _
   ByVal ns As String, _
   ByVal value As Decimal _
)
[C#]
public void WriteElementDecimal(
   string name,
   string ns,
   Decimal value
);
[C++]
public: void WriteElementDecimal(
   String* name,
   String* ns,
   Decimal value
);
[JScript]
public function WriteElementDecimal(
   name : String,
   ns : String,
   value : Decimal
);

Parameters

name
Name of attribute
ns
Namespace URI for the attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteElementDecimal Overload List


XmlWriter.WriteElementDecimal (String, Decimal)

Writes out an element with the specified name containing an Decimal value.

[Visual Basic]
Overloads Public Sub WriteElementDecimal( _
   ByVal name As String, _
   ByVal value As Decimal _
)
[C#]
public void WriteElementDecimal(
   string name,
   Decimal value
);
[C++]
public: void WriteElementDecimal(
   String* name,
   Decimal value
);
[JScript]
public function WriteElementDecimal(
   name : String,
   value : Decimal
);

Parameters

name
Name of element
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteElementDecimal Overload List


XmlWriter.WriteElementDouble

Writes out an element containing a Double value.

Overload List

Writes out an attribute with the specified name, namespace URI, and Double value.

[Visual Basic] Overloads Public Sub WriteElementDouble(String, String, Double)
[C#] public void WriteElementDouble(String, String, double);
[C++] public: void WriteElementDouble(String*, String*, double);
[JScript] public function WriteElementDouble(String, String, double);

Writes out an element with the specified name containing an Double value.

[Visual Basic] Overloads Public Sub WriteElementDouble(String, Double)
[C#] public void WriteElementDouble(String, double);
[C++] public: void WriteElementDouble(String*, double);
[JScript] public function WriteElementDouble(String, double);

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteElementDouble (String, String, Double)

Writes out an attribute with the specified name, namespace URI, and Double value.

[Visual Basic]
Overloads Public Sub WriteElementDouble( _
   ByVal name As String, _
   ByVal ns As String, _
   ByVal value As Double _
)
[C#]
public void WriteElementDouble(
   string name,
   string ns,
   double value
);
[C++]
public: void WriteElementDouble(
   String* name,
   String* ns,
   double value
);
[JScript]
public function WriteElementDouble(
   name : String,
   ns : String,
   value : double
);

Parameters

name
Name of attribute
ns
Namespace URI for the attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteElementDouble Overload List


XmlWriter.WriteElementDouble (String, Double)

Writes out an element with the specified name containing an Double value.

[Visual Basic]
Overloads Public Sub WriteElementDouble( _
   ByVal name As String, _
   ByVal value As Double _
)
[C#]
public void WriteElementDouble(
   string name,
   double value
);
[C++]
public: void WriteElementDouble(
   String* name,
   double value
);
[JScript]
public function WriteElementDouble(
   name : String,
   value : double
);

Parameters

name
Name of element
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteElementDouble Overload List


XmlWriter.WriteElementInt16

Writes out an element containing a Int16 value.

Overload List

Writes out an attribute with the specified name, namespace URI, and Int16 value.

[Visual Basic] Overloads Public Sub WriteElementInt16(String, String, Integer)
[C#] public void WriteElementInt16(String, String, short);
[C++] public: void WriteElementInt16(String*, String*, short);
[JScript] public function WriteElementInt16(String, String, Int16);

Writes out an element with the specified name containing an Int16 value.

[Visual Basic] Overloads Public Sub WriteElementInt16(String, Integer)
[C#] public void WriteElementInt16(String, short);
[C++] public: void WriteElementInt16(String*, short);
[JScript] public function WriteElementInt16(String, Int16);

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteElementInt16 (String, String, Int16)

Writes out an attribute with the specified name, namespace URI, and Int16 value.

[Visual Basic]
Overloads Public Sub WriteElementInt16( _
   ByVal name As String, _
   ByVal ns As String, _
   ByVal value As Short _
)
[C#]
public void WriteElementInt16(
   string name,
   string ns,
   short value
);
[C++]
public: void WriteElementInt16(
   String* name,
   String* ns,
   short value
);
[JScript]
public function WriteElementInt16(
   name : String,
   ns : String,
   value : Int16
);

Parameters

name
Name of attribute
ns
Namespace URI for the attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteElementInt16 Overload List


XmlWriter.WriteElementInt16 (String, Int16)

Writes out an element with the specified name containing an Int16 value.

[Visual Basic]
Overloads Public Sub WriteElementInt16( _
   ByVal name As String, _
   ByVal value As Short _
)
[C#]
public void WriteElementInt16(
   string name,
   short value
);
[C++]
public: void WriteElementInt16(
   String* name,
   short value
);
[JScript]
public function WriteElementInt16(
   name : String,
   value : Int16
);

Parameters

name
Name of element
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteElementInt16 Overload List


XmlWriter.WriteElementInt32

Writes out an element containing a Int32 value.

Overload List

Writes out an attribute with the specified name, namespace URI, and Int64 value.

[Visual Basic] Overloads Public Sub WriteElementInt32(String, String, Integer)
[C#] public void WriteElementInt32(String, String, int);
[C++] public: void WriteElementInt32(String*, String*, int);
[JScript] public function WriteElementInt32(String, String, int);

Writes out an element with the specified name containing an Int32 value.

[Visual Basic] Overloads Public Sub WriteElementInt32(String, Integer)
[C#] public void WriteElementInt32(String, int);
[C++] public: void WriteElementInt32(String*, int);
[JScript] public function WriteElementInt32(String, int);

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteElementInt32 (String, String, Int32)

Writes out an attribute with the specified name, namespace URI, and Int64 value.

[Visual Basic]
Overloads Public Sub WriteElementInt32( _
   ByVal name As String, _
   ByVal ns As String, _
   ByVal value As Integer _
)
[C#]
public void WriteElementInt32(
   string name,
   string ns,
   int value
);
[C++]
public: void WriteElementInt32(
   String* name,
   String* ns,
   int value
);
[JScript]
public function WriteElementInt32(
   name : String,
   ns : String,
   value : int
);

Parameters

name
Name of attribute
ns
Namespace URI for the attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteElementInt32 Overload List


XmlWriter.WriteElementInt32 (String, Int32)

Writes out an element with the specified name containing an Int32 value.

[Visual Basic]
Overloads Public Sub WriteElementInt32( _
   ByVal name As String, _
   ByVal value As Integer _
)
[C#]
public void WriteElementInt32(
   string name,
   int value
);
[C++]
public: void WriteElementInt32(
   String* name,
   int value
);
[JScript]
public function WriteElementInt32(
   name : String,
   value : int
);

Parameters

name
Name of element
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteElementInt32 Overload List


XmlWriter.WriteElementInt64

Writes out an element containing a Int64 value.

Overload List

Writes out an element with the specified name containing an Int64 value.

[Visual Basic] Overloads Public Sub WriteElementInt64(String, Long)
[C#] public void WriteElementInt64(String, long);
[C++] public: void WriteElementInt64(String*, __int64);
[JScript] public function WriteElementInt64(String, long);

Writes out an attribute with the specified name, namespace URI, and Int64 value.

[Visual Basic] Overloads Public Sub WriteElementInt64(String, String, Long)
[C#] public void WriteElementInt64(String, String, long);
[C++] public: void WriteElementInt64(String*, String*, __int64);
[JScript] public function WriteElementInt64(String, String, long);

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteElementInt64 (String, Int64)

Writes out an element with the specified name containing an Int64 value.

[Visual Basic]
Overloads Public Sub WriteElementInt64( _
   ByVal name As String, _
   ByVal value As Long _
)
[C#]
public void WriteElementInt64(
   string name,
   long value
);
[C++]
public: void WriteElementInt64(
   String* name,
   __int64 value
);
[JScript]
public function WriteElementInt64(
   name : String,
   value : long
);

Parameters

name
Name of element
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteElementInt64 Overload List


XmlWriter.WriteElementInt64 (String, String, Int64)

Writes out an attribute with the specified name, namespace URI, and Int64 value.

[Visual Basic]
Overloads Public Sub WriteElementInt64( _
   ByVal name As String, _
   ByVal ns As String, _
   ByVal value As Long _
)
[C#]
public void WriteElementInt64(
   string name,
   string ns,
   long value
);
[C++]
public: void WriteElementInt64(
   String* name,
   String* ns,
   __int64 value
);
[JScript]
public function WriteElementInt64(
   name : String,
   ns : String,
   value : long
);

Parameters

name
Name of attribute
ns
Namespace URI for the attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteElementInt64 Overload List


XmlWriter.WriteElementSingle

Writes out an element containing a Single value.

Overload List

Writes out an attribute with the specified name, namespace URI, and Single value.

[Visual Basic] Overloads Public Sub WriteElementSingle(String, String, Single)
[C#] public void WriteElementSingle(String, String, float);
[C++] public: void WriteElementSingle(String*, String*, float);
[JScript] public function WriteElementSingle(String, String, float);

Writes out an element with the specified name containing an Single value.

[Visual Basic] Overloads Public Sub WriteElementSingle(String, Single)
[C#] public void WriteElementSingle(String, float);
[C++] public: void WriteElementSingle(String*, float);
[JScript] public function WriteElementSingle(String, float);

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteElementSingle (String, String, Single)

Writes out an attribute with the specified name, namespace URI, and Single value.

[Visual Basic]
Overloads Public Sub WriteElementSingle( _
   ByVal name As String, _
   ByVal ns As String, _
   ByVal value As Single _
)
[C#]
public void WriteElementSingle(
   string name,
   string ns,
   float value
);
[C++]
public: void WriteElementSingle(
   String* name,
   String* ns,
   float value
);
[JScript]
public function WriteElementSingle(
   name : String,
   ns : String,
   value : float
);

Parameters

name
Name of attribute
ns
Namespace URI for the attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteElementSingle Overload List


XmlWriter.WriteElementSingle (String, Single)

Writes out an element with the specified name containing an Single value.

[Visual Basic]
Overloads Public Sub WriteElementSingle( _
   ByVal name As String, _
   ByVal value As Single _
)
[C#]
public void WriteElementSingle(
   string name,
   float value
);
[C++]
public: void WriteElementSingle(
   String* name,
   float value
);
[JScript]
public function WriteElementSingle(
   name : String,
   value : float
);

Parameters

name
Name of element
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteElementSingle Overload List


XmlWriter.WriteElementString

Writes out an element containing a string value.

Overload List

Writes out an attribute with the specified name, namespace URI, and string value.

[Visual Basic] Overloads Public Sub WriteElementString(String, String, String)
[C#] public void WriteElementString(String, String, String);
[C++] public: void WriteElementString(String*, String*, String*);
[JScript] public function WriteElementString(String, String, String);

Writes out an element with the specified name containing an string value.

[Visual Basic] Overloads Public Sub WriteElementString(String, String)
[C#] public void WriteElementString(String, String);
[C++] public: void WriteElementString(String*, String*);
[JScript] public function WriteElementString(String, String);

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteElementString (String, String, String)

Writes out an attribute with the specified name, namespace URI, and string value.

[Visual Basic]
Overloads Public Sub WriteElementString( _
   ByVal name As String, _
   ByVal ns As String, _
   ByVal value As String _
)
[C#]
public void WriteElementString(
   string name,
   string ns,
   string value
);
[C++]
public: void WriteElementString(
   String* name,
   String* ns,
   String* value
);
[JScript]
public function WriteElementString(
   name : String,
   ns : String,
   value : String
);

Parameters

name
Name of attribute
ns
Namespace URI for the attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteElementString Overload List


XmlWriter.WriteElementString (String, String)

Writes out an element with the specified name containing an string value.

[Visual Basic]
Overloads Public Sub WriteElementString( _
   ByVal name As String, _
   ByVal value As String _
)
[C#]
public void WriteElementString(
   string name,
   string value
);
[C++]
public: void WriteElementString(
   String* name,
   String* value
);
[JScript]
public function WriteElementString(
   name : String,
   value : String
);

Parameters

name
Name of element
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteElementString Overload List


XmlWriter.WriteElementTime

Writes out an element containing a Time value.

Overload List

Writes out an element with the specified name containing an Time value.

[Visual Basic] Overloads Public Sub WriteElementTime(String, DateTime)
[C#] public void WriteElementTime(String, DateTime);
[C++] public: void WriteElementTime(String*, DateTime);
[JScript] public function WriteElementTime(String, DateTime);

Writes out an attribute with the specified name, namespace URI, and Time value.

[Visual Basic] Overloads Public Sub WriteElementTime(String, String, DateTime)
[C#] public void WriteElementTime(String, String, DateTime);
[C++] public: void WriteElementTime(String*, String*, DateTime);
[JScript] public function WriteElementTime(String, String, DateTime);

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteElementTime (String, DateTime)

Writes out an element with the specified name containing an Time value.

[Visual Basic]
Overloads Public Sub WriteElementTime( _
   ByVal name As String, _
   ByVal value As DateTime _
)
[C#]
public void WriteElementTime(
   string name,
   DateTime value
);
[C++]
public: void WriteElementTime(
   String* name,
   DateTime value
);
[JScript]
public function WriteElementTime(
   name : String,
   value : DateTime
);

Parameters

name
Name of element
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteElementTime Overload List


XmlWriter.WriteElementTime (String, String, DateTime)

Writes out an attribute with the specified name, namespace URI, and Time value.

[Visual Basic]
Overloads Public Sub WriteElementTime( _
   ByVal name As String, _
   ByVal ns As String, _
   ByVal value As DateTime _
)
[C#]
public void WriteElementTime(
   string name,
   string ns,
   DateTime value
);
[C++]
public: void WriteElementTime(
   String* name,
   String* ns,
   DateTime value
);
[JScript]
public function WriteElementTime(
   name : String,
   ns : String,
   value : DateTime
);

Parameters

name
Name of attribute
ns
Namespace URI for the attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteElementTime Overload List


XmlWriter.WriteElementTimeSpan

Writes out an element containing a TimeSpan value.

Overload List

Writes out an attribute with the specified name, namespace URI, and TimeSpan value.

[Visual Basic] Overloads Public Sub WriteElementTimeSpan(String, String, TimeSpan)
[C#] public void WriteElementTimeSpan(String, String, TimeSpan);
[C++] public: void WriteElementTimeSpan(String*, String*, TimeSpan);
[JScript] public function WriteElementTimeSpan(String, String, TimeSpan);

Writes out an element with the specified name containing an TimeSpan value.

[Visual Basic] Overloads Public Sub WriteElementTimeSpan(String, TimeSpan)
[C#] public void WriteElementTimeSpan(String, TimeSpan);
[C++] public: void WriteElementTimeSpan(String*, TimeSpan);
[JScript] public function WriteElementTimeSpan(String, TimeSpan);

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteElementTimeSpan (String, String, TimeSpan)

Writes out an attribute with the specified name, namespace URI, and TimeSpan value.

[Visual Basic]
Overloads Public Sub WriteElementTimeSpan( _
   ByVal name As String, _
   ByVal ns As String, _
   ByVal value As TimeSpan _
)
[C#]
public void WriteElementTimeSpan(
   string name,
   string ns,
   TimeSpan value
);
[C++]
public: void WriteElementTimeSpan(
   String* name,
   String* ns,
   TimeSpan value
);
[JScript]
public function WriteElementTimeSpan(
   name : String,
   ns : String,
   value : TimeSpan
);

Parameters

name
Name of attribute
ns
Namespace URI for the attribute
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteElementTimeSpan Overload List


XmlWriter.WriteElementTimeSpan (String, TimeSpan)

Writes out an element with the specified name containing an TimeSpan value.

[Visual Basic]
Overloads Public Sub WriteElementTimeSpan( _
   ByVal name As String, _
   ByVal value As TimeSpan _
)
[C#]
public void WriteElementTimeSpan(
   string name,
   TimeSpan value
);
[C++]
public: void WriteElementTimeSpan(
   String* name,
   TimeSpan value
);
[JScript]
public function WriteElementTimeSpan(
   name : String,
   value : TimeSpan
);

Parameters

name
Name of element
value
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteElementTimeSpan Overload List


XmlWriter.WriteEmptyElement

Writes an empty tag that ends with "/>".

[Visual Basic]
MustOverride Public Sub WriteEmptyElement( _
   ByVal name As String, _
   ByVal ns As String _
)
[C#]
public abstract void WriteEmptyElement(
   string name,
   string ns
);
[C++]
public: virtual void WriteEmptyElement(
   String* name,
   String* ns
) = 0;
[JScript]
public abstract function WriteEmptyElement(
   name : String,
   ns : String
);

Parameters

name
The name of the element. The name argument can contain a prefix.
ns
The namespace URI to associate with the element. If this namespace is already in scope and has an associated prefix then the writer will automatically write that prefix also.

Remarks

This tag is finished when you call WriteEndElement. The arguments have the same meaning as WriteStartElement. For example:

[C#]

writer.WriteEmptyElement("foo",null);
writer.WriteAttribute("bar","123");
writer.WriteEndElement();

Generates the following:

<foo bar="123"/>

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteEndAttribute

Closes the previous WriteStartAttribute call.

[Visual Basic]
MustOverride Public Sub WriteEndAttribute()
[C#]
public abstract void WriteEndAttribute();
[C++]
public: virtual void WriteEndAttribute() = 0;
[JScript]
public abstract function WriteEndAttribute();

Remarks

If you call WriteStartAttribute, you can close the attribute with this method.

You can also close the attribute by calling WriteStartAttribute again, calling WriteAttribute, or calling WriteEndElement.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteEndElement

Closes one element and pops the corresponding namespace scope.

[Visual Basic]
MustOverride Public Sub WriteEndElement()
[C#]
public abstract void WriteEndElement();
[C++]
public: virtual void WriteEndElement() = 0;
[JScript]
public abstract function WriteEndElement();

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteEntityRef

Writes out an entity reference as follows: "&"+name+";".

[Visual Basic]
MustOverride Public Sub WriteEntityRef( _
   ByVal name As String _
)
[C#]
public abstract void WriteEntityRef(
   string name
);
[C++]
public: virtual void WriteEntityRef(
   String* name
) = 0;
[JScript]
public abstract function WriteEntityRef(
   name : String
);

Parameters

name
Name of the entity reference.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteInt16

Writes out the specified Int16 value.

[Visual Basic]
MustOverride Public Sub WriteInt16( _
   ByVal value As Short _
)
[C#]
public abstract void WriteInt16(
   short value
);
[C++]
public: virtual void WriteInt16(
   short value
) = 0;
[JScript]
public abstract function WriteInt16(
   value : Int16
);

Parameters

value
Int16 to write.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteInt32

Writes out the specified Int32 value.

[Visual Basic]
MustOverride Public Sub WriteInt32( _
   ByVal value As Integer _
)
[C#]
public abstract void WriteInt32(
   int value
);
[C++]
public: virtual void WriteInt32(
   int value
) = 0;
[JScript]
public abstract function WriteInt32(
   value : int
);

Parameters

value
Int32 to write.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteInt64

Writes out the specified Int64 value.

[Visual Basic]
MustOverride Public Sub WriteInt64( _
   ByVal value As Long _
)
[C#]
public abstract void WriteInt64(
   long value
);
[C++]
public: virtual void WriteInt64(
   __int64 value
) = 0;
[JScript]
public abstract function WriteInt64(
   value : long
);

Parameters

value
Int64 to write.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteName

Writes out the specified name, ensuring it is a valid Name according to the XML specification (href="

[Visual Basic]
MustOverride Public Sub WriteName( _
   ByVal name As String _
)
[C#]
public abstract void WriteName(
   string name
);
[C++]
public: virtual void WriteName(
   String* name
) = 0;
[JScript]
public abstract function WriteName(
   name : String
);

Parameters

name
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteNmToken

Writes out the specified name, ensuring it is a valid NmToken according to the XML specification (

[Visual Basic]
MustOverride Public Sub WriteNmToken( _
   ByVal name As String _
)
[C#]
public abstract void WriteNmToken(
   string name
);
[C++]
public: virtual void WriteNmToken(
   String* name
) = 0;
[JScript]
public abstract function WriteNmToken(
   name : String
);

Parameters

name
[To be supplied.]

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteNode

Copies everything from the given reader to the writer, moving the XmlReader to the end of the current element.

[Visual Basic]
Public Sub WriteNode( _
   ByVal reader As XmlReader, _
   ByVal defattr As Boolean _
)
[C#]
public void WriteNode(
   XmlReader reader,
   bool defattr
);
[C++]
public: void WriteNode(
   XmlReader* reader,
   bool defattr
);
[JScript]
public function WriteNode(
   reader : XmlReader,
   defattr : Boolean
);

Parameters

reader
The XmlReader to read from.
defattr
Whether to also copy the default attributes from the XmlReader.

Remarks

If the XmlReader is in the initial state, this method moves the reader to EOF.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteProcessingInstruction

Writes out a processing instruction with a space between the name and text as follows: <?name text?>.

[Visual Basic]
MustOverride Public Sub WriteProcessingInstruction( _
   ByVal name As String, _
   ByVal text As String _
)
[C#]
public abstract void WriteProcessingInstruction(
   string name,
   string text
);
[C++]
public: virtual void WriteProcessingInstruction(
   String* name,
   String* text
) = 0;
[JScript]
public abstract function WriteProcessingInstruction(
   name : String,
   text : String
);

Parameters

name
Name of the processing instruction.
text
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentException | The text would result in a non-well formed XML document. The name is "xml". You must use WriteXmlDecl() to write the XML declaration.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteQualifiedName

Writes out the specified namespace-qualified name by looking up the prefix that is in scope for the given namespace.

[Visual Basic]
MustOverride Public Sub WriteQualifiedName( _
   ByVal name As String, _
   ByVal ns As String _
)
[C#]
public abstract void WriteQualifiedName(
   string name,
   string ns
);
[C++]
public: virtual void WriteQualifiedName(
   String* name,
   String* ns
) = 0;
[JScript]
public abstract function WriteQualifiedName(
   name : String,
   ns : String
);

Parameters

name
Name to write.
ns
[To be supplied.]

Remarks

For example, the following code:

writer.WriteStartElement("root");
writer.WriteAttribute("xmlns:x","urn:abc");
    writer.WriteEmptyElement("item");
        writer.WriteStartAttribute("href",null);
        writer.WriteString("#");
        writer.WriteQualifiedName("foo","urn:abc");
        writer.WriteEndAttribute();
    writer.WriteEndElement();
writer.WriteEndElement();
writer.Close();

Will generate the following output:

<root xmlns:x="urn:abc">
         <item href="#x:foo"/>
         </root>

When writing attribute values it will generate a prefix if the specified namespace is not found.If the namespace maps to the current default namespace then it does not need a prefix. When writing element content it will throw an exception if the namespace is not found.

If the Namespace flag is turned on then it will also make sure the name is valid according to the Namespaces in XML specification (

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteRaw

Writes raw markup manually.

Overload List

Writes raw markup manually from a string.

[Visual Basic] Overloads MustOverride Public Sub WriteRaw(String)
[C#] public abstract void WriteRaw(String);
[C++] public: virtual void WriteRaw(String*) = 0;
[JScript] public abstract function WriteRaw(String);

Writes raw markup manually from a character buffer.

[Visual Basic] Overloads MustOverride Public Sub WriteRaw(Char(), Integer, Integer)
[C#] public abstract void WriteRaw(char[], int, int);
[C++] public: virtual void WriteRaw(__wchar_t*[], int, int) = 0;
[JScript] public abstract function WriteRaw(Char[], int, int);

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteRaw (String)

Writes raw markup manually from a string.

[Visual Basic]
Overloads MustOverride Public Sub WriteRaw( _
   ByVal data As String _
)
[C#]
public abstract void WriteRaw(
   string data
);
[C++]
public: virtual void WriteRaw(
   String* data
) = 0;
[JScript]
public abstract function WriteRaw(
   data : String
);

Parameters

data
[To be supplied.]

Remarks

This bypasses the entitization of special characters.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteRaw Overload List


XmlWriter.WriteRaw (Char[], Int32, Int32)

Writes raw markup manually from a character buffer.

[Visual Basic]
Overloads MustOverride Public Sub WriteRaw( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
[C#]
public abstract void WriteRaw(
   char[] buffer,
   int index,
   int count
);
[C++]
public: virtual void WriteRaw(
   __wchar_t* buffer[],
   int index,
   int count
) = 0;
[JScript]
public abstract function WriteRaw(
   buffer : Char[],
   index : int,
   count : int
);

Parameters

buffer
Character array containing the text to write.
index
The position within buffer indicating the start of the text to write.
count
The number of characters to write.

Remarks

This bypasses the entitization of special characters.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteRaw Overload List


XmlWriter.WriteSingle

Writes out the specified float value.

[Visual Basic]
MustOverride Public Sub WriteSingle( _
   ByVal value As Single _
)
[C#]
public abstract void WriteSingle(
   float value
);
[C++]
public: virtual void WriteSingle(
   float value
) = 0;
[JScript]
public abstract function WriteSingle(
   value : float
);

Parameters

value
float to write.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteStartAttribute

Writes the start of an attribute.

[Visual Basic]
MustOverride Public Sub WriteStartAttribute( _
   ByVal name As String, _
   ByVal ns As String _
)
[C#]
public abstract void WriteStartAttribute(
   string name,
   string ns
);
[C++]
public: virtual void WriteStartAttribute(
   String* name,
   String* ns
) = 0;
[JScript]
public abstract function WriteStartAttribute(
   name : String,
   ns : String
);

Parameters

name
Name of the attribute.
ns
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentException | The attribute is named "xmlns:xml" and Namespaces is true. This is invalid according to the namespace spec.

Remarks

This is a more advanced version of WriteAttribute that allows you to write an attribute value using multiple write methods, such as WriteString, WriteChar, WriteInt, and so on. For example:

writer.WriteStartElement("item");
writer.WriteStartAttribute("ids",null);
    writer.WriteInt(12);
    writer.WriteInt(25);
    writer.WriteInt(17);
writer.WriteEndAttribute();
writer.WriteInt(122);
writer.WriteEndElement();

which produces the following output:

<item id="12 25 17">122</item>

Notice that the WriteEndAttribute makes the last call to WriteInt(122) generate element content instead of attribute content.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteStartElement

Writes out the specified start tag.

Overload List

Writes out the specified start tag and associates it with the given namespace.

[Visual Basic] Overloads MustOverride Public Sub WriteStartElement(String, String)
[C#] public abstract void WriteStartElement(String, String);
[C++] public: virtual void WriteStartElement(String*, String*) = 0;
[JScript] public abstract function WriteStartElement(String, String);

Writes out a start tag with the specified name.

[Visual Basic] Overloads Public Sub WriteStartElement(String)
[C#] public void WriteStartElement(String);
[C++] public: void WriteStartElement(String*);
[JScript] public function WriteStartElement(String);

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteStartElement (String, String)

Writes out the specified start tag and associates it with the given namespace.

[Visual Basic]
Overloads MustOverride Public Sub WriteStartElement( _
   ByVal name As String, _
   ByVal ns As String _
)
[C#]
public abstract void WriteStartElement(
   string name,
   string ns
);
[C++]
public: virtual void WriteStartElement(
   String* name,
   String* ns
) = 0;
[JScript]
public abstract function WriteStartElement(
   name : String,
   ns : String
);

Parameters

name
The name argument can contain a prefix in which case uses this prefix and associates this prefix with the given namespace for the scope of this element.
ns
The namespace URI to associate with the element. If this namespace is already in scope and has an associated prefix then the writer will automatically write that prefix also.

Exceptions

Exception Type | Condition
InvalidOperationException | If writer is closed.

Remarks

After calling this method you can either write attributes, or you can go directly to content (WriteComment, WriteString, or WriteStartElement for child elements). You must close this element with WriteEndElement at which time a full end tag is written out. For example:

[C#]

writer.WriteStartElement("foo",null");
writer.WriteEndElement();

will generate the following output:

[C#]

<foo></foo>

If you want to write an empty element with the "/>" syntax, then use WriteEmptyElement .

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteStartElement Overload List


XmlWriter.WriteStartElement (String)

Writes out a start tag with the specified name.

[Visual Basic]
Overloads Public Sub WriteStartElement( _
   ByVal name As String _
)
[C#]
public void WriteStartElement(
   string name
);
[C++]
public: void WriteStartElement(
   String* name
);
[JScript]
public function WriteStartElement(
   name : String
);

Parameters

name
Name of the element tag.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteStartElement Overload List


XmlWriter.WriteString

Writes out the specified text content.

[Visual Basic]
MustOverride Public Sub WriteString( _
   ByVal text As String _
)
[C#]
public abstract void WriteString(
   string text
);
[C++]
public: virtual void WriteString(
   String* text
) = 0;
[JScript]
public abstract function WriteString(
   text : String
);

Parameters

text
Text to write.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteTime

Writes out the specified Time value.

[Visual Basic]
MustOverride Public Sub WriteTime( _
   ByVal value As DateTime _
)
[C#]
public abstract void WriteTime(
   DateTime value
);
[C++]
public: virtual void WriteTime(
   DateTime value
) = 0;
[JScript]
public abstract function WriteTime(
   value : DateTime
);

Parameters

value
DateTime to write.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteTimeSpan

Writes out the specified TimeSpan value.

[Visual Basic]
MustOverride Public Sub WriteTimeSpan( _
   ByVal value As TimeSpan _
)
[C#]
public abstract void WriteTimeSpan(
   TimeSpan value
);
[C++]
public: virtual void WriteTimeSpan(
   TimeSpan value
) = 0;
[JScript]
public abstract function WriteTimeSpan(
   value : TimeSpan
);

Parameters

value
TimeSpan to write.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteXmlDecl

Writes out the XML declaration. A call to one of the WriteXmlDecl methods must be first write call.

Overload List

Writes out the XML declaration with the version "1.0".

[Visual Basic] Overloads MustOverride Public Sub WriteXmlDecl()
[C#] public abstract void WriteXmlDecl();
[C++] public: virtual void WriteXmlDecl() = 0;
[JScript] public abstract function WriteXmlDecl();

Writes out the XML declaration with the version "1.0" with specified standalone attribute.

[Visual Basic] Overloads MustOverride Public Sub WriteXmlDecl(Boolean)
[C#] public abstract void WriteXmlDecl(bool);
[C++] public: virtual void WriteXmlDecl(bool) = 0;
[JScript] public abstract function WriteXmlDecl(Boolean);

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace


XmlWriter.WriteXmlDecl ()

Writes out the XML declaration with the version "1.0".

[Visual Basic]
Overloads MustOverride Public Sub WriteXmlDecl()
[C#]
public abstract void WriteXmlDecl();
[C++]
public: virtual void WriteXmlDecl() = 0;
[JScript]
public abstract function WriteXmlDecl();

Exceptions

Exception Type | Condition
InvalidOperationException | This was not the first write call.

Remarks

A call to one of the WriteXmlDecl methods must be first write call. The encoding attribute is determined by the implementation. For example, the XmlTextWriter constructor takes an Encoding object which determines the value of the encoding attribute. No standalone attribute is written.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteXmlDecl Overload List


XmlWriter.WriteXmlDecl (Boolean)

Writes out the XML declaration with the version "1.0" with specified standalone attribute.

[Visual Basic]
Overloads MustOverride Public Sub WriteXmlDecl( _
   ByVal standalone As Boolean _
)
[C#]
public abstract void WriteXmlDecl(
   bool standalone
);
[C++]
public: virtual void WriteXmlDecl(
   bool standalone
) = 0;
[JScript]
public abstract function WriteXmlDecl(
   standalone : Boolean
);

Parameters

standalone
true writes standalone="yes"; false writes standalone="no".

Exceptions

Exception Type | Condition
InvalidOperationException | This was not the first write call.

Remarks

A call to one of the WriteXmlDecl methods must be first write call. The encoding attribute is determined by the implementation. For example, the XmlTextWriter constructor takes an Encoding object which determines the value of the encoding attribute.

See Also

XmlWriter Class | XmlWriter Members | System.NewXml Namespace | XmlWriter.WriteXmlDecl Overload List


System.NewXml.XPath

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.NewXml.XPath Namespace

Enumerations

Enumeration | Description
Querytype | [To be supplied.]


Querytype Enumeration

[To be supplied.]

[Visual Basic]
Public Enum Querytype
[C#]
public enum Querytype
[C++]
public enum Querytype

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Ancestor | [To be supplied.]
Attribute | [To be supplied.]
Child | [To be supplied.]
Constant | [To be supplied.]
Descendant | [To be supplied.]
None | [To be supplied.]

Requirements

Namespace: System.NewXml.XPath

Assembly: System.Xml.dll

See Also

System.NewXml.XPath Namespace


System.NewXml.Xsl

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.NewXml.Xsl Namespace

Classes

Class | Description
XslTransform | Transforms XML data using an XSL stylesheet.


XslTransform Class

Transforms XML data using an XSL stylesheet.

Object
XslTransform

[Visual Basic]
Public Class XslTransform
[C#]
public class XslTransform
[C++]
public __gc class XslTransform
[JScript]
public class XslTransform

Remarks

To transform XML data:

  1. Create an XslTransform object.
  2. Load the stylesheet to use for the transformation into the XslTransform object using the Load method. There are three overloads for this method: each one for a different type of object supplying the XSL stylesheet: URL, XmlReader, and XmlNavigator.
  3. Create an XmlNavigator object and initialize it with an XmlDocument that contains the XML data you want to transform.
  4. Transform the XML data using the Transform method. Specify the XmlNavigator for XML data as the input parameter. There are four overloads for this method: each one is for a different type of output: XmlReader, XmlWriter, Stream, andTextWriter.

Requirements

Namespace: System.NewXml.Xsl

Assembly: System.Xml.dll

Example [C#]

The following example transforms the specified XML document using the specified stylesheet and outputs the result to the console using XmlWriter.

[C#]

//Create a new XslTransform
XslTransform xslt = new XslTransform();
//Load an XSL stylesheet
xslt.Load("http://somewhere/favorite.xsl");
//Create a new XmlDocument to load XML data from a file.
XmlDocument mydata = new XmlDocument()
//Load the XML data file
mydata.Load("http://somewhere/mydata.xml");
//Create an XmlTextWriter to transform output to the console.
XmlWriter writer = new XmlTextWriter(Console.Out);
//Transform the data and output the result.
xslt.Transform(new XmlDocumentNavigator(mydata),null,writer);

See Also

XslTransform Members | System.NewXml.Xsl Namespace


XslTransform Members

Public:

Constructor

XslTransform Constructor [To be supplied.]

Properties

XmlResolver Gets or sets the XmlResolver used by this XslTransform to resolve external resources.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Load | Overloaded. Loads the XSL stylesheet and any stylesheets referenced using xsl:include elements.
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform | Overloaded. Transforms the specified XML data using the loaded XSL stylesheet and outputs the results.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XslTransform Class | System.NewXml.Xsl Namespace


XslTransform Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public XslTransform();
[C++]
public: XslTransform();
[JScript]
public function XslTransform();

See Also

XslTransform Class | XslTransform Members | System.NewXml.Xsl Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XslTransform Properties

The properties of the XslTransform class are listed below. For a complete list of XslTransform class members, see the XslTransform Members topic.

Public:

XmlResolver Gets or sets the XmlResolver used by this XslTransform to resolve external resources.

See Also

XslTransform Class | System.NewXml.Xsl Namespace


XslTransform.XmlResolver

Gets or sets the XmlResolver used by this XslTransform to resolve external resources.

[Visual Basic]
Public Property XmlResolver As XmlResolver
[C#]
public XmlResolver XmlResolver {get; set;}
[C++]
public: __property XmlResolver* get_XmlResolver();
public: __property void set_XmlResolver(XmlResolver*);
[JScript]
public function get XmlResolver() : XmlResolver;
public function set XmlResolver(XmlResolver);

Property Value

The XmlResolver used by this XslTransform.

By default, this property uses the XmlUrlResolver, which resolves XML resources using the file:// and http:// protocols.

See Also

XslTransform Class | XslTransform Members | System.NewXml.Xsl Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

XslTransform Methods

The methods of the XslTransform class are listed below. For a complete list of XslTransform class members, see the XslTransform Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
Load | Overloaded. Loads the XSL stylesheet and any stylesheets referenced using xsl:include elements.
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform | Overloaded. Transforms the specified XML data using the loaded XSL stylesheet and outputs the results.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XslTransform Class | System.NewXml.Xsl Namespace


XslTransform.Load

Loads the XSL stylesheet and any stylesheets referenced using xsl:include elements.

Overload List

Loads the XSL stylesheet contained in the specified XmlNavigator.

[Visual Basic] Overloads Public Sub Load(XmlNavigator)
[C#] public void Load(XmlNavigator);
[C++] public: void Load(XmlNavigator*);
[JScript] public function Load(XmlNavigator);

Loads the XSL stylesheet specified by a URL.

[Visual Basic] Overloads Public Sub Load(String)
[C#] public void Load(String);
[C++] public: void Load(String*);
[JScript] public function Load(String);

Loads the XSL stylesheet contained in the specified XmlReader.

[Visual Basic] Overloads Public Sub Load(XmlReader)
[C#] public void Load(XmlReader);
[C++] public: void Load(XmlReader*);
[JScript] public function Load(XmlReader);

See Also

XslTransform Class | XslTransform Members | System.NewXml.Xsl Namespace


XslTransform.Load (XmlNavigator)

Loads the XSL stylesheet contained in the specified XmlNavigator.

[Visual Basic]
Overloads Public Sub Load( _
   ByVal stylesheet As XmlNavigator _
)
[C#]
public void Load(
   XmlNavigator stylesheet
);
[C++]
public: void Load(
   XmlNavigator* stylesheet
);
[JScript]
public function Load(
   stylesheet : XmlNavigator
);

Parameters

stylesheet
An XmlNavigator object that contains the XSL stylesheet.

Exceptions

Exception Type | Condition
Exception | The loaded resource is not valid. Or if there is an xsl:include but no XmlResolver has been provided.

See Also

XslTransform Class | XslTransform Members | System.NewXml.Xsl Namespace | XslTransform.Load Overload List


XslTransform.Load (String)

Loads the XSL stylesheet specified by a URL.

[Visual Basic]
Overloads Public Sub Load( _
   ByVal url As String _
)
[C#]
public void Load(
   string url
);
[C++]
public: void Load(
   String* url
);
[JScript]
public function Load(
   url : String
);

Parameters

url
The URL that specifies the XSL stylesheet to load.

Exceptions

Exception Type | Condition
Exception | The loaded resource is not valid. Or there is an xsl:include but no XmlResolver has been provided.

See Also

XslTransform Class | XslTransform Members | System.NewXml.Xsl Namespace | XslTransform.Load Overload List


XslTransform.Load (XmlReader)

Loads the XSL stylesheet contained in the specified XmlReader.

[Visual Basic]
Overloads Public Sub Load( _
   ByVal stylesheet As XmlReader _
)
[C#]
public void Load(
   XmlReader stylesheet
);
[C++]
public: void Load(
   XmlReader* stylesheet
);
[JScript]
public function Load(
   stylesheet : XmlReader
);

Parameters

stylesheet
An XmlReader object that contains the XSL stylesheet.

Exceptions

Exception Type | Condition
Exception | If the loaded resource is not valid or if there is an xsl:include but no XmlResolver has been provided.

See Also

XslTransform Class | XslTransform Members | System.NewXml.Xsl Namespace | XslTransform.Load Overload List


XslTransform.Transform

Transforms the specified XML data using the loaded XSL stylesheet and outputs the results.

Overload List

Transforms the XML data in the specified XmlNavigator and outputs the result to an XmlWriter.

[Visual Basic] Overloads Public Sub Transform(XmlNavigator, NSParamList, XmlWriter)
[C#] public void Transform(XmlNavigator, NSParamList, XmlWriter);
[C++] public: void Transform(XmlNavigator*, NSParamList, XmlWriter);
[JScript] public function Transform(XmlNavigator, NSParamList, XmlWriter);

Transforms the XML data in the specified XmlNavigator and outputs the result to an XmlReader.

[Visual Basic] Overloads Public Function Transform(XmlNavigator, NSParamList) As XmlReader
[C#] public XmlReader Transform(XmlNavigator, NSParamList);
[C++] public: XmlReader* Transform(XmlNavigator*, NSParamList);
[JScript] public function Transform(XmlNavigator, NSParamList) : XmlReader;

Transforms the XML data in the specified XmlNavigator and outputs the result to a TextWriter.

[Visual Basic] Overloads Public Sub Transform(XmlNavigator, NSParamList, TextWriter)
[C#] public void Transform(XmlNavigator, NSParamList, TextWriter);
[C++] public: void Transform(XmlNavigator*, NSParamList, TextWriter);
[JScript] public function Transform(XmlNavigator, NSParamList, TextWriter);

Transforms the XML data in the specified XmlNavigator and outputs the result to a Stream.

[Visual Basic] Overloads Public Sub Transform(XmlNavigator, NSParamList, Stream)
[C#] public void Transform(XmlNavigator, NSParamList, Stream);
[C++] public: void Transform(XmlNavigator*, NSParamList, Stream);
[JScript] public function Transform(XmlNavigator, NSParamList, Stream);

See Also

XslTransform Class | XslTransform Members | System.NewXml.Xsl Namespace


XslTransform.Transform (XmlNavigator, NSParamList, XmlWriter)

Transforms the XML data in the specified XmlNavigator and outputs the result to an XmlWriter.

[Visual Basic]
Overloads Public Sub Transform( _
   ByVal input As XmlNavigator, _
   ByVal args As NSParamList, _
   ByVal output As XmlWriter _
)
[C#]
public void Transform(
   XmlNavigator input,
   NSParamList args,
   XmlWriter output
);
[C++]
public: void Transform(
   XmlNavigator* input,
   NSParamList* args,
   XmlWriter* output
);
[JScript]
public function Transform(
   input : XmlNavigator,
   args : NSParamList,
   output : XmlWriter
);

Parameters

input
An XmlNavigator containing the data to be transformed.
args
For this release, specify null. The namespace-qualified arguments to be used as input to the transform itself.
output
The XmlWriter to push the output to.

Exceptions

Exception Type | Condition
XsltException.NoStylesheetLoaded | No stylesheet is loaded.

See Also

XslTransform Class | XslTransform Members | System.NewXml.Xsl Namespace | XslTransform.Transform Overload List


XslTransform.Transform (XmlNavigator, NSParamList)

Transforms the XML data in the specified XmlNavigator and outputs the result to an XmlReader.

[Visual Basic]
Overloads Public Function Transform( _
   ByVal input As XmlNavigator, _
   ByVal args As NSParamList _
) As XmlReader
[C#]
public XmlReader Transform(
   XmlNavigator input,
   NSParamList args
);
[C++]
public: XmlReader* Transform(
   XmlNavigator* input,
   NSParamList* args
);
[JScript]
public function Transform(
   input : XmlNavigator,
   args : NSParamList
) : XmlReader;

Parameters

input
An XmlNavigator containing the data to be transformed.
args
The namespace-qualified arguments to be used as input to the transform itself.

Return Value

An XmlReader containing the results of the transform.

See Also

XslTransform Class | XslTransform Members | System.NewXml.Xsl Namespace | XslTransform.Transform Overload List


XslTransform.Transform (XmlNavigator, NSParamList, TextWriter)

Transforms the XML data in the specified XmlNavigator and outputs the result to a TextWriter.

[Visual Basic]
Overloads Public Sub Transform( _
   ByVal input As XmlNavigator, _
   ByVal args As NSParamList, _
   ByVal output As TextWriter _
)
[C#]
public void Transform(
   XmlNavigator input,
   NSParamList args,
   TextWriter output
);
[C++]
public: void Transform(
   XmlNavigator* input,
   NSParamList* args,
   TextWriter* output
);
[JScript]
public function Transform(
   input : XmlNavigator,
   args : NSParamList,
   output : TextWriter
);

Parameters

input
An XmlNavigator containing the data to be transformed.
args
For this release, specify null. The namespace-qualified arguments to be used as input to the transform itself.
output
The TextWriter to push the output to.

Exceptions

Exception Type | Condition
XsltException.NoStylesheetLoaded | No stylesheet is loaded.

See Also

XslTransform Class | XslTransform Members | System.NewXml.Xsl Namespace | XslTransform.Transform Overload List


XslTransform.Transform (XmlNavigator, NSParamList, Stream)

Transforms the XML data in the specified XmlNavigator and outputs the result to a Stream.

[Visual Basic]
Overloads Public Sub Transform( _
   ByVal input As XmlNavigator, _
   ByVal args As NSParamList, _
   ByVal output As Stream _
)
[C#]
public void Transform(
   XmlNavigator input,
   NSParamList args,
   Stream output
);
[C++]
public: void Transform(
   XmlNavigator* input,
   NSParamList* args,
   Stream* output
);
[JScript]
public function Transform(
   input : XmlNavigator,
   args : NSParamList,
   output : Stream
);

Parameters

input
An XmlNavigator containing the data to be transformed.
args
For this release, specify null. The namespace-qualified arguments to be used as input to the transform itself.
output
The stream to push the output to.

Exceptions

Exception Type | Condition
XsltException.NoStylesheetLoaded | No stylesheet is loaded.

See Also

XslTransform Class | XslTransform Members | System.NewXml.Xsl Namespace | XslTransform.Transform Overload List


System.Reflection

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Reflection Namespace

Classes

Class | Description
AmbiguousMatchException | Represents an exception that is thrown when a method or constructor cannot be matched.
Assembly | An Assembly, that is a reusable, versionable, and self-describing building block of a NGWS application. Assemblies provide the infrastructure needed to allow NGWS runtime to fully understand the contents of an application and to enforce the versioning and dependency rules defined by the application. These concepts are crucial for solving the versioning problem and for simplifying the deployment of NGWS runtime applications.
AssemblyCompanyAttribute | [To be supplied.]
AssemblyConfigurationAttribute | [To be supplied.]
AssemblyCopyrightAttribute | [To be supplied.]
AssemblyDefaultAliasAttribute | [To be supplied.]
AssemblyDescriptionAttribute | [To be supplied.]
AssemblyInformationalVersionAttribute | [To be supplied.]
AssemblyName | This class fully describes an assembly's unique identity. An assembly's identity consists of several pieces of information including a simple textual name, a version number, a cryptographic key pair, and supported culture.
AssemblyProductAttribute | [To be supplied.]
AssemblyTitleAttribute | [To be supplied.]
AssemblyTrademarkAttribute | [To be supplied.]
Binder | Defines a set of methods that interact with reflection during the binding process. This control allows systems to apply language specific semantics to the binding and invocation process.
ConstructorInfo | Retrieves the name of the class constructor method as it is stored in metadata. This name is always ".ctor"
CustomAttributeFormatException | Represents an exception that is thrown when the binary format of a custom attribute is invalid.
DefaultMemberAttribute | Defines the member of a type that is the default member used by InvokeMember. The default member is a name given to a type.
EventInfo | Reflects an event. Implementation of this class is not complete for this release of NGWS. This documentation is for information only.
FieldInfo | Discovers the attributes of a field and provides access to field metadata. The field information is obtained from metadata. FieldInfo does not have a public constructor. Objects are created by invoking either the GetFields() or GetField() method of a Type object. Fields are variables defined in the class. Although related to fields, properties are marked explicitly in the metadata and usually have get and set routines associated with them. FieldInfo provides access to the metadata for a field within a class and provides dynamic set and get functionality for the field. The class is not loaded into memory until invoke or get is called on the object.
InvalidFilterCriteriaException | Represents an exception that is thrown in FindMembers when the filter criteria is not valid for the type of filter being used.
MemberInfo | Represents the class that is used to obtain information about the members of a class
MethodBase | The MethodBase class is the abstract base class for obtaining information about methods and constructors.
MethodInfo | Provides information about a method and a mechanism for calling the method. Instances of MethodInfo are created by invoking either the GetMethods or GetMethod method of a Type object.
Missing | This class represents a missing Object.
Module | The Module class reflects a module. A module is a portable executable file of type .dll or .exe consisting of one or more classes and interfaces. One or more modules that are deployed as a unit compose an assembly.
ParameterInfo | The ParameterInfo class reflects a parameter. Instances of this class are used to obtain information about the type of a parameter, the default value, etc.
Pointer | [To be supplied.]
PropertyInfo | The PropertyInfo class reflects a property. Properties are logically the same as fields. A property is a named aspect of an object's state whose value is typically accessible through get and set-accessors. Properties may be read-only, in which case a set routine is not supported. Initializes an instance of the PropertyInfo class.
ReflectionTypeLoadException | The ReflectionTypeLoadException class represents the exceptions thrown by the Module.GetTypes() method if any of the classes in a module are not able to be loaded
StrongNameKeyPair | Encapuslates access to a public/private key pair used to sign strong name assemblies.
TargetException | Represents the exception that is thrown when an attempt is made to invoke an invalid target.
TargetInvocationException | Represents the exception thrown when a method invoked through reflection throws an exception.
TargetParameterCountException | Represents an exception that is thrown when the number of the parameter and invocation doesn't match.
TypeDelegator | This class wraps a Type object and delegates all methods to that Type. It is useful to subclass this type and only overload those methods you need to provide customization in.
UnmanagedMarshal | Represents the class that describes the field marshal.

Interfaces

Interface | Description
ICustomAttributeProvider | The ICustomAttributeProvider interface contains methods common to the Type, ConstructorInfo, EventInfo, FieldInfo, MethodInfo, MethodBase, MemberInfo, ParameterInfo, and PropertyInfo classes.
IReflect | Supports basic runtime member Reflection namespace.

Structures

Structure | Description
InterfaceMapping | Retrieves the mapping of an interface into the actual methods on a class that implements that interface.
ParameterModifier | Attaches a modifier to parameters so that binding can work with parameter signatures in which the types have been modified.

Delegates

Delegate | Description
MemberFilter | Represents a delegate that is used to filter a list of members represented in an array of MemberInfo objects.
ResolveEventHandler | This delegate is used to handle the OnTypeResolveEvent and OnResourceResolveEvent events on Assembly. If the runtime class loader cannot resolve a reference to a type or a resource through normal means, these events are raised to give the caller a chance to tell the runtime which assembly the referenced class or resource is in. Cast EventArgs to a String to find the name of the requested Type or resource.
TypeFilter | Filters the classes represented in an array of Type objects.

Enumerations

Enumeration | Description
AssemblyNameFlags | These flags control how an AssemblyName is used during assembly binding.
BindingFlags | Comprises flags that control binding and the way in which the search for members and types is conducted using Reflection.
CallingConventions | Defines the valid calling conventions for an enumeration.
EventAttributes | Defines the attributes of an event. EventAttributes values may be bitwise or'ed together to get the appropriate combination. These are defined in corhdr.h and are a combination of bits and enumerators.
FieldAttributes | Comprises flags that specify the attributes of a field.
MemberTypes | Specifies a type of member.
MethodAttributes | Comprises flags that specify the attributes of a method. These flags are defined in corhdr.h.
MethodImplAttributes | Comprises flags that specify the attributes of a method implementation.
ParameterAttributes | Obtains the flags that define the attributes of a method parameter. The attributes can be used to determine if the parameter is an in parameter, an out parameter, etc.
PropertyAttributes | Defines the attributes that may be associated with a property. These attribute values are defined in corhdr.h.
ResourceAttributes | Defines the attributes for an embedded resource.
TypeAttributes | To be supplied.


AmbiguousMatchException Class

Represents an exception that is thrown when a method or constructor cannot be matched.

Object
Exception
SystemException
AmbiguousMatchException

[Visual Basic]
NotInheritable Public Class AmbiguousMatchException
   Inherits SystemException
[C#]
public sealed class AmbiguousMatchException : SystemException
[C++]
public __gc __sealed class AmbiguousMatchException : public
   SystemException
[JScript]
public class AmbiguousMatchException extends SystemException

Remarks

The AmbiguousMatchException is thrown when the binding to a method results in more than one method matching the binding criteria. In general, this exception is thrown when something is ambiguous.

An AmbiguousMatchException is thrown is the application calls upon a class and it cannot determine which class or overloaded class to utilize. The binding will attempt to locate the proper class to use, determined by the number of parameters and the type of parameters. If no acceptable class can be determined, the exception is thrown.

Overload resolution is a mechanism for selecting the best function member to invoke given an argument list and a set of candidate function members. Overload resolution selects the function member to invoke. If a selection cannot be determined, an AmbiguousMatchException is thrown.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

AmbiguousMatchException Members | System.Reflection Namespace | Exception | SystemException


AmbiguousMatchException Members

Public:

Constructor

AmbiguousMatchException Constructor Overloaded. Initializes an instance of the AmbiguousMatchException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

AmbiguousMatchException Class | System.Reflection Namespace


AmbiguousMatchException Constructor

Initializes an instance of the AmbiguousMatchException class.

Overload List

Initializes an instance of AmbiguousMatchException with an empty message string and the root cause exception set to null.

[Visual Basic] Overloads Public Sub New()
[C#] public AmbiguousMatchException();
[C++] public: AmbiguousMatchException();
[JScript] public function AmbiguousMatchException();

Initializes an instance of AmbiguousMatchException with its message string set to the given message and the root cause exception set to null.

[Visual Basic] Overloads Public Sub New(String)
[C#] public AmbiguousMatchException(String);
[C++] public: AmbiguousMatchException(String*);
[JScript] public function AmbiguousMatchException(String);

Initializes an instance of AmbiguousMatchException with its message string set to the given message and the given root cause exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public AmbiguousMatchException(String, Exception);
[C++] public: AmbiguousMatchException(String*, Exception);
[JScript] public function AmbiguousMatchException(String, Exception);

Example

In the example shown below, two classes are constucted, each named Mymethod. One class takes a integer and one a string. If an integer is passed to Mymethod, the first class is used. If a string is passed, the second class is used. If it cannot determine which Mymethod to use, the exception is thrown.

Note This example shows how to use one of the overloaded version of the AmbiguousMatchException constructor. For other examples that may be available, see the individual overload topics.
class Myambiguous{
   //The first overload is
typed to an Int32
   public static void
Mymethod (Int32 number){
      Console.Write("\n{0}", "I am from Int32
method");
   }
   //The second overload is
typed to a string
   public static void
Mymethod (string alpha){
      Console.Write("\n{0}", "I am from a string.");
   }
   public static void Main()
   {
      try{
      //The following does
not cause as exception
      Mymethod (2);  // goes to Mymethod (Int32)
      Mymethod ("3");   // goes to Mymethod (string)

      Type Mytype = Type.GetType ("Myambiguous");

      MethodInfo Mymethodinfo32 =
         Mytype.GetMethod("Mymethod", new Type[]{typeof(Int32)});
      MethodInfo Mymethodinfostr =
         Mytype.GetMethod("Mymethod", new Type[]{typeof(System.String)});

      //Invoke a method, utilizing a Int32 integer
      Mymethodinfo32.Invoke(null,new Variant[]{2});

      //Invoke the method utilizing a string
      Mymethodinfostr.Invoke(null,new Variant[]{"1"});

      //The following line causes an ambiguious exception
      MethodInfo Mymethodinfo = Mytype.GetMethod("Mymethod");
      }  // end of try block

      catch(System.Reflection.AmbiguousMatchException theException){
         Console.Write("\nAmbiguousMatchException message - {0}", theException.Message);
      }
      catch {
         Console.Write("\nError thrown");
      }
      return;
   }
}

Produces the following output
I am from Int32 method
I am from a string.
I am from Int32 method
I am from a string.
AmbiguousMatchException message - Ambiguous match found.

See Also

AmbiguousMatchException Class | AmbiguousMatchException Members | System.Reflection Namespace


AmbiguousMatchException Constructor ()

Initializes an instance of AmbiguousMatchException with an empty message string and the root cause exception set to null.

[Visual Basic]
Overloads Public Sub New()
[C#]
public AmbiguousMatchException();
[C++]
public: AmbiguousMatchException();
[JScript]
public function AmbiguousMatchException();

Remarks

The AmbiguousMatchException is the exception class that shows when a class or method was not located.

AmbiguousMatchException inherits from the Exception. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | null
Message | The empty string ("").

See Also

AmbiguousMatchException Class | AmbiguousMatchException Members | System.Reflection Namespace | AmbiguousMatchException Constructor Overload List | Exception | SystemException


AmbiguousMatchException Constructor (String)

Initializes an instance of AmbiguousMatchException with its message string set to the given message and the root cause exception set to null.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public AmbiguousMatchException(
   string message
);
[C++]
public: AmbiguousMatchException(
   String* message
);
[JScript]
public function AmbiguousMatchException(
   message : String
);

Parameters

message
The message that indicates the reason this exception was thrown.

Remarks

AmbiguousMatchException inherits from the Exception. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | null
Message | The message string.

See Also

AmbiguousMatchException Class | AmbiguousMatchException Members | System.Reflection Namespace | AmbiguousMatchException Constructor Overload List


AmbiguousMatchException Constructor (String, Exception)

Initializes an instance of AmbiguousMatchException with its message string set to the given message and the given root cause exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public AmbiguousMatchException(
   string message,
   Exception inner
);
[C++]
public: AmbiguousMatchException(
   String* message,
   Exception* inner
);
[JScript]
public function AmbiguousMatchException(
   message : String,
   inner : Exception
);

Parameters

message
The message that indicates the reason this exception was thrown.
inner
The exception, which is the root cause of this exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

AmbiguousMatchException inherits from the SystemException. This constructor sets the properties of the AmbiguousMatchException object as follows:

Property | Value
InnerException | The inner exception.
Message | The message string.

Example

In the example shown below, two classes are constucted, each named Mymethod. One class takes a integer and one a string. If an integer is passed to Mymethod, the first class is used. If a string is passed, the second class is used. If it cannot determine which Mymethod to use, the exception is thrown.

class Myambiguous{
   //The first overload is
typed to an Int32
   public static void
Mymethod (Int32 number){
      Console.Write("\n{0}", "I am from Int32
method");
   }
   //The second overload is
typed to a string
   public static void
Mymethod (string alpha){
      Console.Write("\n{0}", "I am from a string.");
   }
   public static void Main()
   {
      try{
      //The following does
not cause as exception
      Mymethod (2);  // goes to Mymethod (Int32)
      Mymethod ("3");   // goes to Mymethod (string)

      Type Mytype = Type.GetType ("Myambiguous");

      MethodInfo Mymethodinfo32 =
         Mytype.GetMethod("Mymethod", new Type[]{typeof(Int32)});
      MethodInfo Mymethodinfostr =
         Mytype.GetMethod("Mymethod", new Type[]{typeof(System.String)});

      //Invoke a method, utilizing a Int32 integer
      Mymethodinfo32.Invoke(null,new Variant[]{2});

      //Invoke the method utilizing a string
      Mymethodinfostr.Invoke(null,new Variant[]{"1"});

      //The following line causes an ambiguious exception
      MethodInfo Mymethodinfo = Mytype.GetMethod("Mymethod");
      }  // end of try block

      catch(System.Reflection.AmbiguousMatchException theException){
         Console.Write("\nAmbiguousMatchException message - {0}", theException.Message);
      }
      catch {
         Console.Write("\nError thrown");
      }
      return;
   }
}

Produces the following output
I am from Int32 method
I am from a string.
I am from Int32 method
I am from a string.
AmbiguousMatchException message - Ambiguous match found.

See Also

AmbiguousMatchException Class | AmbiguousMatchException Members | System.Reflection Namespace | AmbiguousMatchException Constructor Overload List | Exception


Assembly Class

An Assembly, that is a reusable, versionable, and self-describing building block of a NGWS application. Assemblies provide the infrastructure needed to allow NGWS runtime to fully understand the contents of an application and to enforce the versioning and dependency rules defined by the application. These concepts are crucial for solving the versioning problem and for simplifying the deployment of NGWS runtime applications.

Object
Assembly

[Visual Basic]
Public Class Assembly
   Implements IEvidenceFactory, ICustomAttributeProvider, _
   ISerializable
[C#]
public class Assembly : IEvidenceFactory, ICustomAttributeProvider,
   ISerializable
[C++]
public __gc class Assembly : public IEvidenceFactory,
   ICustomAttributeProvider, ISerializable
[JScript]
public class Assembly implements IEvidenceFactory,
   ICustomAttributeProvider, ISerializable

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

Assembly Members | System.Reflection Namespace


Assembly Members

Public:

Properties

CodeBase | This read-only property returns the location of the assembly as specified originally, for example, in an AssemblyName object.
CopiedCodeBase | This read-only property returns the location from which the assembly was loaded. This will be different from the value of CodeBase if the assembly is a shadow copy.
EntryPoint | Read-only. Gets the entry point of this assembly.
Evidence | This read-only property returns the evidence for this assembly.
FullName | This read-only property returns the display name of the assembly.
IsShared | This read-only property checks if this assembly has code that is shared across multiple application domains.
ShareCount | This read-only property returns the number of application domains that are currently sharing the code for this assembly.

Methods

CreateInstance | Overloaded. [To be supplied.]
CreateQualifiedName | Creates the name of a type qualified by the display name of its assembly.
DefineDynamicModule | Overloaded. Overloaded. Defines a dynamic module in this assembly.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetAssembly | Gets the assembly in which the specified class is defined.
GetCustomAttributes | Overloaded. Overloaded. Gets the custom attributes for this assembly.
GetExecutingAssembly | Gets the Assembly that the current code is running from.
GetExportedTypes | Gets the public types defined in this assembly.
GetFile | Gets a FileStream for the specified file in the file table of the manifest of this assembly.
GetFiles | Gets a FileStream for each file in the file table of the manifest of this assembly.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLoadedModules | Gets all the loaded modules that are part of this assembly.
GetManifestResourceNames | Returns the names of all the resources in this assembly.
GetManifestResourceStream | Overloaded. Overloaded. Loads the specified resource from this assembly.
GetModule | Gets the specified module in this assembly.
GetModules | Gets all the modules that are part of this assembly.
GetName | Overloaded. Overloaded. Gets the AssemblyName of this assembly.
GetObjectData | Gets serialization information with all of the data needed to reinstantiate this assembly.
GetReferencedAssemblies | Gets the AssemblyName objects for all the assemblies referenced by this assembly.
GetSatelliteAssembly | Gets the satellite assembly for the specified culture.
GetType | Overloaded. Overloaded. Gets the Type object that represents the specified type.
GetTypes | Gets the types defined in this assembly.
IsDefined | Checks if a custom attribute identified by the specified Type is defined.
Load | Overloaded. [To be supplied.]
LoadFrom | Overloaded. [To be supplied.]
nCreateQualifiedName | Creates a name that qualifies the supplied type name with the supplied display name of an assembly.
SetObjectData | Reflate this assembly using all of the information in the specified SerializationInfo object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Events

ResourceResolve | [To be supplied.]
TypeResolve | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Event Hookup:

Methods

AddOnResourceResolve | Subscribes to the "resource resolve" event. The "resource resolve" event is raised when a resource is loaded.
AddOnTypeResolve | Subscribes to the "type resolve" event. The "type resolve" event is raised when a type is loaded.
RemoveOnResourceResolve | Unsubscribes to the "resource resolve" event. The "resource resolve" event is raised when a resource is loaded.
RemoveOnTypeResolve | Unsubscribes to the "type resolve" event. The "type resolve" event is raised when a type is loaded.

See Also

Assembly Class | System.Reflection Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Assembly Properties

The properties of the Assembly class are listed below. For a complete list of Assembly class members, see the Assembly Members topic.

Public:

CodeBase | This read-only property returns the location of the assembly as specified originally, for example, in an AssemblyName object.
CopiedCodeBase | This read-only property returns the location from which the assembly was loaded. This will be different from the value of CodeBase if the assembly is a shadow copy.
EntryPoint | Read-only. Gets the entry point of this assembly.
Evidence | This read-only property returns the evidence for this assembly.
FullName | This read-only property returns the display name of the assembly.
IsShared | This read-only property checks if this assembly has code that is shared across multiple application domains.
ShareCount | This read-only property returns the number of application domains that are currently sharing the code for this assembly.

See Also

Assembly Class | System.Reflection Namespace


Assembly.CodeBase

This read-only property returns the location of the assembly as specified originally, for example, in an AssemblyName object.

[Visual Basic]
Overridable Public ReadOnly Property CodeBase As String
[C#]
public string CodeBase {virtual get;}
[C++]
public: __property virtual String* get_CodeBase();
[JScript]
public function get CodeBase() : String;

Property Value

Read-only. Returns the location of the assembly as specified originally.

Example

[To
be supplied.]

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.CopiedCodeBase

This read-only property returns the location from which the assembly was loaded. This will be different from the value of CodeBase if the assembly is a shadow copy.

[Visual Basic]
Overridable Public ReadOnly Property CopiedCodeBase As String
[C#]
public string CopiedCodeBase {virtual get;}
[C++]
public: __property virtual String* get_CopiedCodeBase();
[JScript]
public function get CopiedCodeBase() : String;

Property Value

Read-only. Returns the location from which the assembly was loaded.

Example

[To
be supplied.]

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.EntryPoint

Read-only. Gets the entry point of this assembly.

[Visual Basic]
Public ReadOnly Property EntryPoint As MethodInfo
[C#]
public MethodInfo EntryPoint {get;}
[C++]
public: __property MethodInfo* get_EntryPoint();
[JScript]
public function get EntryPoint() : MethodInfo;

Property Value

The entry point of this assembly.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.Evidence

This read-only property returns the evidence for this assembly.

[Visual Basic]
Overridable Public ReadOnly Property Evidence As Evidence
[C#]
public Evidence Evidence {virtual get;}
[C++]
public: __property virtual Evidence* get_Evidence();
[JScript]
public function get Evidence() : Evidence;

Property Value

Read-only. Returns the evidence for this assembly.

Example

[To
be supplied.]

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.FullName

This read-only property returns the display name of the assembly.

[Visual Basic]
Overridable Public ReadOnly Property FullName As String
[C#]
public string FullName {virtual get;}
[C++]
public: __property virtual String* get_FullName();
[JScript]
public function get FullName() : String;

Property Value

Read-only. Returns the display name of the assembly.

Remarks

See AssemblyName for a description of the format of the display name of an assembly.

Example

[To
be supplied.]

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.IsShared

This read-only property checks if this assembly has code that is shared across multiple application domains.

[Visual Basic]
Public ReadOnly Property IsShared As Boolean
[C#]
public bool IsShared {get;}
[C++]
public: __property bool get_IsShared();
[JScript]
public function get IsShared() : Boolean;

Property Value

Read-only. Returns true if this assembly has code that is shared across multiple application domains. Otherwise, returns false.

Example

[To
be supplied.]

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.ShareCount

This read-only property returns the number of application domains that are currently sharing the code for this assembly.

[Visual Basic]
Public ReadOnly Property ShareCount As Integer
[C#]
public int ShareCount {get;}
[C++]
public: __property int get_ShareCount();
[JScript]
public function get ShareCount() : int;

Property Value

Read-only. Returns the number of application domains that are currently sharing the code for this assembly.

Example

[To
be supplied.]

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Assembly Methods

The methods of the Assembly class are listed below. For a complete list of Assembly class members, see the Assembly Members topic.

Public:

CreateInstance | Overloaded. [To be supplied.]
CreateQualifiedName | Creates the name of a type qualified by the display name of its assembly.
DefineDynamicModule | Overloaded. Overloaded. Defines a dynamic module in this assembly.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetAssembly | Gets the assembly in which the specified class is defined.
GetCustomAttributes | Overloaded. Overloaded. Gets the custom attributes for this assembly.
GetExecutingAssembly | Gets the Assembly that the current code is running from.
GetExportedTypes | Gets the public types defined in this assembly.
GetFile | Gets a FileStream for the specified file in the file table of the manifest of this assembly.
GetFiles | Gets a FileStream for each file in the file table of the manifest of this assembly.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLoadedModules | Gets all the loaded modules that are part of this assembly.
GetManifestResourceNames | Returns the names of all the resources in this assembly.
GetManifestResourceStream | Overloaded. Overloaded. Loads the specified resource from this assembly.
GetModule | Gets the specified module in this assembly.
GetModules | Gets all the modules that are part of this assembly.
GetName | Overloaded. Overloaded. Gets the AssemblyName of this assembly.
GetObjectData | Gets serialization information with all of the data needed to reinstantiate this assembly.
GetReferencedAssemblies | Gets the AssemblyName objects for all the assemblies referenced by this assembly.
GetSatelliteAssembly | Gets the satellite assembly for the specified culture.
GetType | Overloaded. Overloaded. Gets the Type object that represents the specified type.
GetTypes | Gets the types defined in this assembly.
IsDefined | Checks if a custom attribute identified by the specified Type is defined.
Load | Overloaded. [To be supplied.]
LoadFrom | Overloaded. [To be supplied.]
nCreateQualifiedName | Creates a name that qualifies the supplied type name with the supplied display name of an assembly.
SetObjectData | Reflate this assembly using all of the information in the specified SerializationInfo object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Event Hookup:

AddOnResourceResolve | Subscribes to the "resource resolve" event. The "resource resolve" event is raised when a resource is loaded.
AddOnTypeResolve | Subscribes to the "type resolve" event. The "type resolve" event is raised when a type is loaded.
RemoveOnResourceResolve | Unsubscribes to the "resource resolve" event. The "resource resolve" event is raised when a resource is loaded.
RemoveOnTypeResolve | Unsubscribes to the "type resolve" event. The "type resolve" event is raised when a type is loaded.

See Also

Assembly Class | System.Reflection Namespace


Assembly.AddOnResourceResolve

Subscribes to the "resource resolve" event. The "resource resolve" event is raised when a resource is loaded.

[Visual Basic]
Overridable Public Sub AddOnResourceResolve( _
   ByVal handler As ResolveEventHandler _
)
[C#]
public virtual void AddOnResourceResolve(
   ResolveEventHandler handler
);
[C++]
public: virtual void AddOnResourceResolve(
   ResolveEventHandler* handler
);
[JScript]
public function AddOnResourceResolve(
   handler : ResolveEventHandler
);

Parameters

handler
The event handler for the "resource resolve" event.

Remarks

The argument passed to the ResolveEventHandler is the name of the resource that was loaded.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.AddOnTypeResolve

Subscribes to the "type resolve" event. The "type resolve" event is raised when a type is loaded.

[Visual Basic]
Overridable Public Sub AddOnTypeResolve( _
   ByVal handler As ResolveEventHandler _
)
[C#]
public virtual void AddOnTypeResolve(
   ResolveEventHandler handler
);
[C++]
public: virtual void AddOnTypeResolve(
   ResolveEventHandler* handler
);
[JScript]
public function AddOnTypeResolve(
   handler : ResolveEventHandler
);

Parameters

handler
The event handler for the "type resolve" event.

Remarks

The argument passed to the ResolveEventHandler is the full type name qualified by the display name of the assembly in which the type was found. The format is:

<FullTypeName>, <AssemblyDisplayName>

See AssemblyName for a description of the format of the display name of an assembly.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.CreateInstance

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function CreateInstance(String) As Object
[C#] public object CreateInstance(String);
[C++] public: Object* CreateInstance(String*);
[JScript] public function CreateInstance(String) : Object;

[To be supplied.]

[Visual Basic] Overloads Public Function CreateInstance(String, Boolean, BindingFlags, Binder, Object(), CultureInfo, Object()) As Object
[C#] public object CreateInstance(String, bool, BindingFlags, Binder, Object[], CultureInfo, Object[]);
[C++] public: Object* CreateInstance(String*, bool, BindingFlags, Binder, Object[], CultureInfo, Object[]);
[JScript] public function CreateInstance(String, Boolean, BindingFlags, Binder, Object[], CultureInfo, Object[]) : Object;

[To be supplied.]

[Visual Basic] Overloads Public Function CreateInstance(String, Boolean) As Object
[C#] public object CreateInstance(String, bool);
[C++] public: Object* CreateInstance(String*, bool);
[JScript] public function CreateInstance(String, Boolean) : Object;

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.CreateInstance (String)

[To be supplied.]

[Visual Basic]
Overloads Public Function CreateInstance( _
   ByVal typeName As String _
) As Object
[C#]
public object CreateInstance(
   string typeName
);
[C++]
public: Object* CreateInstance(
   String* typeName
);
[JScript]
public function CreateInstance(
   typeName : String
) : Object;

Parameters

typeName
[To be supplied.]

See Also

Assembly Class | Assembly Members | System.Reflection Namespace | Assembly.CreateInstance Overload List


Assembly.CreateInstance (String, Boolean, BindingFlags, Binder, Object[], CultureInfo, Object[])

[To be supplied.]

[Visual Basic]
Overloads Public Function CreateInstance( _
   ByVal typeName As String, _
   ByVal ignoreCase As Boolean, _
   ByVal bindingAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal args() As Object, _
   ByVal culture As CultureInfo, _
   ByVal activationAttributes() As Object _
) As Object
[C#]
public object CreateInstance(
   string typeName,
   bool ignoreCase,
   BindingFlags bindingAttr,
   Binder binder,
   object[] args,
   CultureInfo culture,
   object[] activationAttributes
);
[C++]
public: Object* CreateInstance(
   String* typeName,
   bool ignoreCase,
   BindingFlags bindingAttr,
   Binder* binder,
   Object* args[],
   CultureInfo* culture,
   Object* activationAttributes[]
);
[JScript]
public function CreateInstance(
   typeName : String,
   ignoreCase : Boolean,
   bindingAttr : BindingFlags,
   binder : Binder,
   args : Object[],
   culture : CultureInfo,
   activationAttributes : Object[]
) : Object;

Parameters

typeName
[To be supplied.]
ignoreCase
[To be supplied.]
bindingAttr
[To be supplied.]
binder
[To be supplied.]
args
[To be supplied.]
culture
[To be supplied.]
activationAttributes
[To be supplied.]

See Also

Assembly Class | Assembly Members | System.Reflection Namespace | Assembly.CreateInstance Overload List


Assembly.CreateInstance (String, Boolean)

[To be supplied.]

[Visual Basic]
Overloads Public Function CreateInstance( _
   ByVal typeName As String, _
   ByVal ignoreCase As Boolean _
) As Object
[C#]
public object CreateInstance(
   string typeName,
   bool ignoreCase
);
[C++]
public: Object* CreateInstance(
   String* typeName,
   bool ignoreCase
);
[JScript]
public function CreateInstance(
   typeName : String,
   ignoreCase : Boolean
) : Object;

Parameters

typeName
[To be supplied.]
ignoreCase
[To be supplied.]

See Also

Assembly Class | Assembly Members | System.Reflection Namespace | Assembly.CreateInstance Overload List


Assembly.CreateQualifiedName

Creates the name of a type qualified by the display name of its assembly.

[Visual Basic]
Public Shared Function CreateQualifiedName( _
   ByVal assemblyName As String, _
   ByVal typeName As String _
) As String
[C#]
public static string CreateQualifiedName(
   string assemblyName,
   string typeName
);
[C++]
public: static String* CreateQualifiedName(
   String* assemblyName,
   String* typeName
);
[JScript]
public static function CreateQualifiedName(
   assemblyName : String,
   typeName : String
) : String;

Parameters

assemblyName
The display name of an assembly.
typeName
The full name of a type.

Return Value

The full name of the type qualified by the display name of the assembly.

Remarks

The format of the returned string is:

<FullTypeName>, <AssemblyDisplayName>

See AssemblyName for a description of the format of the display name of an assembly.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.DefineDynamicModule

Overloaded. Defines a dynamic module in this assembly.

Overload List

Defines a named dynamic module in this assembly. The defined dynamic module is transient.

[Visual Basic] Overloads Overridable Public Function DefineDynamicModule(String) As ModuleBuilder
[C#] public virtual ModuleBuilder DefineDynamicModule(String);
[C++] public: virtual ModuleBuilder* DefineDynamicModule(String*);
[JScript] public function DefineDynamicModule(String) : ModuleBuilder;

Defines a named dynamic module in this assembly and specifies whether or not symbol information should be emitted. The defined dynamic module is transient.

[Visual Basic] Overloads Overridable Public Function DefineDynamicModule(String, Boolean) As ModuleBuilder
[C#] public virtual ModuleBuilder DefineDynamicModule(String, bool);
[C++] public: virtual ModuleBuilder* DefineDynamicModule(String*, bool);
[JScript] public function DefineDynamicModule(String, Boolean) : ModuleBuilder;

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.DefineDynamicModule (String)

Defines a named dynamic module in this assembly. The defined dynamic module is transient.

[Visual Basic]
Overloads Overridable Public Function DefineDynamicModule( _
   ByVal name As String _
) As ModuleBuilder
[C#]
public virtual ModuleBuilder DefineDynamicModule(
   string name
);
[C++]
public: virtual ModuleBuilder* DefineDynamicModule(
   String* name
);
[JScript]
public function DefineDynamicModule(
   name : String
) : ModuleBuilder;

Parameters

name
The name of the dynamic module.

Return Value

A ModuleBuilder representing the defined dynamic module.

Remarks

It is an error to define multiple dynamic modules with the same name in an assembly.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace | Assembly.DefineDynamicModule Overload List


Assembly.DefineDynamicModule (String, Boolean)

Defines a named dynamic module in this assembly and specifies whether or not symbol information should be emitted. The defined dynamic module is transient.

[Visual Basic]
Overloads Overridable Public Function DefineDynamicModule( _
   ByVal name As String, _
   ByVal emitSymbolInfo As Boolean _
) As ModuleBuilder
[C#]
public virtual ModuleBuilder DefineDynamicModule(
   string name,
   bool emitSymbolInfo
);
[C++]
public: virtual ModuleBuilder* DefineDynamicModule(
   String* name,
   bool emitSymbolInfo
);
[JScript]
public function DefineDynamicModule(
   name : String,
   emitSymbolInfo : Boolean
) : ModuleBuilder;

Parameters

name
The name of the dynamic module.
emitSymbolInfo
true if symbol information is to be emitted. Otherwise, false.

Return Value

A ModuleBuilder representing the defined dynamic module.

Exceptions

Exception Type | Condition
ExecutionEngineException | if the default symbol writer cannot be loaded.

Remarks

It is an error to define multiple dynamic modules with the same name in an assembly.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace | Assembly.DefineDynamicModule Overload List


Assembly.GetAssembly

Gets the assembly in which the specified class is defined.

[Visual Basic]
Public Shared Function GetAssembly( _
   ByVal type As Type _
) As Assembly
[C#]
public static Assembly GetAssembly(
   Type type
);
[C++]
public: static Assembly* GetAssembly(
   Type* type
);
[JScript]
public static function GetAssembly(
   type : Type
) : Assembly;

Parameters

type
A Type object representing a class in the assembly that will be returned.

Return Value

The assembly in which the specified class is defined.

Exceptions

Exception Type | Condition
ArgumentNullException | if type is a null reference (in Visual Basic Nothing).

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.GetCustomAttributes

Overloaded. Gets the custom attributes for this assembly.

Overload List

Gets all the custom attributes for this assembly.

[Visual Basic] Overloads Overridable Public Function GetCustomAttributes() As Object ()
[C#] public virtual object[] GetCustomAttributes();
[C++] public: virtual Object* GetCustomAttributes() [];
[JScript] public function GetCustomAttributes() : Object[];

Gets the custom attribute for this assembly identified by the specified type.

[Visual Basic] Overloads Overridable Public Function GetCustomAttributes(Type) As Object ()
[C#] public virtual object[] GetCustomAttributes(Type);
[C++] public: virtual Object* GetCustomAttributes(Type*) [];
[JScript] public function GetCustomAttributes(Type) : Object[];

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.GetCustomAttributes ()

Gets all the custom attributes for this assembly.

[Visual Basic]
Overloads Overridable Public Function GetCustomAttributes() As Object ()
[C#]
public virtual object[] GetCustomAttributes();
[C++]
public: virtual Object* GetCustomAttributes() [];
[JScript]
public function GetCustomAttributes() : Object[];

Return Value

An array of objects representing the custom attributes for this assembly.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace | Assembly.GetCustomAttributes Overload List


Assembly.GetCustomAttributes (Type)

Gets the custom attribute for this assembly identified by the specified type.

[Visual Basic]
Overloads Overridable Public Function GetCustomAttributes( _
   ByVal attributeType As Type _
) As Object ()
[C#]
public virtual object[] GetCustomAttributes(
   Type attributeType
);
[C++]
public: virtual Object* GetCustomAttributes(
   Type* attributeType
) [];
[JScript]
public function GetCustomAttributes(
   attributeType : Type
) : Object[];

Parameters

attributeType
The Type for which the custom attributes are to be returned.

Return Value

The custom attribute for this assembly identified by the specified type.

Exceptions

Exception Type | Condition
ArgumentNullException | attributeType is a null reference (in Visual Basic Nothing).
ArgumentException | attributeType is not a runtime type.

Remarks

A array of objects representing the specified custom attributes.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace | Assembly.GetCustomAttributes Overload List


Assembly.GetExecutingAssembly

Gets the Assembly that the current code is running from.

[Visual Basic]
Public Shared Function GetExecutingAssembly() As Assembly
[C#]
public static Assembly GetExecutingAssembly();
[C++]
public: static Assembly* GetExecutingAssembly();
[JScript]
public static function GetExecutingAssembly() : Assembly;

Return Value

The assembly that the current code is running from.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.GetExportedTypes

Gets the public types defined in this assembly.

[Visual Basic]
Overridable Public Function GetExportedTypes() As Type ()
[C#]
public virtual Type[] GetExportedTypes();
[C++]
public: virtual Type* GetExportedTypes() [];
[JScript]
public function GetExportedTypes() : Type[];

Return Value

The public types defined in this assembly.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.GetFile

Gets a FileStream for the specified file in the file table of the manifest of this assembly.

[Visual Basic]
Overridable Public Function GetFile( _
   ByVal name As String _
) As FileStream
[C#]
public virtual FileStream GetFile(
   string name
);
[C++]
public: virtual FileStream* GetFile(
   String* name
);
[JScript]
public function GetFile(
   name : String
) : FileStream;

Parameters

name
The name of the specified file.

Return Value

A FileStream for the specified file. a null reference (in Visual Basic Nothing) is returned if the file is not found.

Remarks

name should not include the path to the file.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.GetFiles

Gets a FileStream for each file in the file table of the manifest of this assembly.

[Visual Basic]
Overridable Public Function GetFiles() As FileStream ()
[C#]
public virtual FileStream[] GetFiles();
[C++]
public: virtual FileStream* GetFiles() [];
[JScript]
public function GetFiles() : FileStream[];

Return Value

An array of FileStream objects.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.GetLoadedModules

Gets all the loaded modules that are part of this assembly.

[Visual Basic]
Public Function GetLoadedModules() As Module ()
[C#]
public Module[] GetLoadedModules();
[C++]
public: Module* GetLoadedModules() [];
[JScript]
public function GetLoadedModules() : Module[];

Return Value

An array of modules.

Remarks

A type can be retrieved from a specific module using Module.GetType. Calling Module.GetType on the module containing the manifest will not initiate a search of the entire assembly. To retrieve a type from an assembly, regardless of which module it is in, you must call Assembly.GetType.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.GetManifestResourceNames

Returns the names of all the resources in this assembly.

[Visual Basic]
Public Function GetManifestResourceNames() As String ()
[C#]
public string[] GetManifestResourceNames();
[C++]
public: String* GetManifestResourceNames() [];
[JScript]
public function GetManifestResourceNames() : String[];

Return Value

The names of all the resources.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.GetManifestResourceStream

Overloaded. Loads the specified resource from this assembly.

Overload List

Loads the specified resource from this assembly.

[Visual Basic] Overloads Overridable Public Function GetManifestResourceStream(String) As Stream
[C#] public virtual Stream GetManifestResourceStream(String);
[C++] public: virtual Stream* GetManifestResourceStream(String*);
[JScript] public function GetManifestResourceStream(String) : Stream;

Loads the specified resource, scoped by the namespace of the specified type, from this assembly.

[Visual Basic] Overloads Overridable Public Function GetManifestResourceStream(Type, String) As Stream
[C#] public virtual Stream GetManifestResourceStream(Type, String);
[C++] public: virtual Stream* GetManifestResourceStream(Type*, String);
[JScript] public function GetManifestResourceStream(Type, String) : Stream;

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.GetManifestResourceStream (String)

Loads the specified resource from this assembly.

[Visual Basic]
Overloads Overridable Public Function GetManifestResourceStream( _
   ByVal name As String _
) As Stream
[C#]
public virtual Stream GetManifestResourceStream(
   string name
);
[C++]
public: virtual Stream* GetManifestResourceStream(
   String* name
);
[JScript]
public function GetManifestResourceStream(
   name : String
) : Stream;

Parameters

name
The name of the resource being requested.

Return Value

A Stream representing this resource.

Remarks

The returned Stream has its file pointer set to the beginning of the resource.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace | Assembly.GetManifestResourceStream Overload List


Assembly.GetManifestResourceStream (Type, String)

Loads the specified resource, scoped by the namespace of the specified type, from this assembly.

[Visual Basic]
Overloads Overridable Public Function GetManifestResourceStream( _
   ByVal type As Type, _
   ByVal name As String _
) As Stream
[C#]
public virtual Stream GetManifestResourceStream(
   Type type,
   string name
);
[C++]
public: virtual Stream* GetManifestResourceStream(
   Type* type,
   String* name
);
[JScript]
public function GetManifestResourceStream(
   type : Type,
   name : String
) : Stream;

Parameters

type
The type whose namespace is used to scope the resource name.
name
The name of the resource being requested.

Return Value

A Stream representing this resource.

Remarks

The returned Stream has its file pointer set to the beginning of the resource.

For example, if the full name of type is "MyNameSpace.Foo" and name is "Bar", System.Reflection.Assembly.GetManifestResourceName will search for a resource named "MyNameSpace.Bar".

See Also

Assembly Class | Assembly Members | System.Reflection Namespace | Assembly.GetManifestResourceStream Overload List


Assembly.GetModule

Gets the specified module in this assembly.

[Visual Basic]
Public Function GetModule( _
   ByVal name As String _
) As Module
[C#]
public Module GetModule(
   string name
);
[C++]
public: Module* GetModule(
   String* name
);
[JScript]
public function GetModule(
   name : String
) : Module;

Parameters

name
The name of the module being requested.

Return Value

The Module being requested

Remarks

A type can be retrieved from a specific module using Module.GetType. Calling Module.GetType on the module containing the manifest will not initiate a search of the entire assembly. To retrieve a type from an assembly, regardless of which module it is in, you must call Assembly.GetType.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.GetModules

Gets all the modules that are part of this assembly.

[Visual Basic]
Public Function GetModules() As Module ()
[C#]
public Module[] GetModules();
[C++]
public: Module* GetModules() [];
[JScript]
public function GetModules() : Module[];

Return Value

An array of modules.

Remarks

A type can be retrieved from a specific module using Module.GetType. Calling Module.GetType on the module containing the manifest will not initiate a search of the entire assembly. To retrieve a type from an assembly, regardless of which module it is in, you must call Assembly.GetType.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.GetName

Overloaded. Gets the AssemblyName of this assembly.

Overload List

Gets the AssemblyName of this assembly. The codebase in the AssemblyName will be set to the original codebase or the codebase of the shadow copy depending on the value of the Boolean parameter passed to the method.

[Visual Basic] Overloads Overridable Public Function GetName(Boolean) As AssemblyName
[C#] public virtual AssemblyName GetName(bool);
[C++] public: virtual AssemblyName* GetName(bool);
[JScript] public function GetName(Boolean) : AssemblyName;

Gets the AssemblyName of this assembly.

[Visual Basic] Overloads Overridable Public Function GetName() As AssemblyName
[C#] public virtual AssemblyName GetName();
[C++] public: virtual AssemblyName* GetName();
[JScript] public function GetName() : AssemblyName;

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.GetName (Boolean)

Gets the AssemblyName of this assembly. The codebase in the AssemblyName will be set to the original codebase or the codebase of the shadow copy depending on the value of the Boolean parameter passed to the method.

[Visual Basic]
Overloads Overridable Public Function GetName( _
   ByVal copiedName As Boolean _
) As AssemblyName
[C#]
public virtual AssemblyName GetName(
   bool copiedName
);
[C++]
public: virtual AssemblyName* GetName(
   bool copiedName
);
[JScript]
public function GetName(
   copiedName : Boolean
) : AssemblyName;

Parameters

copiedName
true to set the CodeBase to the location of the assembly after it was shadow copied; false to set CodeBase to the original location.

Return Value

The AssemblyName for this assembly.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace | Assembly.GetName Overload List


Assembly.GetName ()

Gets the AssemblyName of this assembly.

[Visual Basic]
Overloads Overridable Public Function GetName() As AssemblyName
[C#]
public virtual AssemblyName GetName();
[C++]
public: virtual AssemblyName* GetName();
[JScript]
public function GetName() : AssemblyName;

Return Value

The AssemblyName of this assembly.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace | Assembly.GetName Overload List


Assembly.GetObjectData

Gets serialization information with all of the data needed to reinstantiate this assembly.

[Visual Basic]
Overridable Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
public: virtual void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
);
[JScript]
public function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);

Parameters

info
The object to be populated with serialization information.
context
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentNullException | if info is a null reference (in Visual Basic Nothing)

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.GetReferencedAssemblies

Gets the AssemblyName objects for all the assemblies referenced by this assembly.

[Visual Basic]
Public Function GetReferencedAssemblies() As AssemblyName ()
[C#]
public AssemblyName[] GetReferencedAssemblies();
[C++]
public: AssemblyName* GetReferencedAssemblies() [];
[JScript]
public function GetReferencedAssemblies() : AssemblyName[];

Return Value

The AssemblyName objects for all the assemblies referenced by this assembly.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.GetSatelliteAssembly

Gets the satellite assembly for the specified culture.

[Visual Basic]
Public Function GetSatelliteAssembly( _
   ByVal culture As CultureInfo _
) As Assembly
[C#]
public Assembly GetSatelliteAssembly(
   CultureInfo culture
);
[C++]
public: Assembly* GetSatelliteAssembly(
   CultureInfo* culture
);
[JScript]
public function GetSatelliteAssembly(
   culture : CultureInfo
) : Assembly;

Parameters

culture
[To be supplied].

Return Value

The specified satellite assembly.

Exceptions

Exception Type | Condition
ArgumentNullException | if culture is null.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.GetType

Overloaded. Gets the Type object that represents the specified type.

Overload List

Gets the Type object with the specified name, ignoring case, and optionally throws an exception on error.

[Visual Basic] Overloads Public Function GetType(String, Boolean, Boolean) As Type
[C#] public Type GetType(String, bool, bool);
[C++] public: Type* GetType(String*, bool, bool);
[JScript] public function GetType(String, Boolean, Boolean) : Type;

Gets the Type object with the specified name and optionally throws an exception on exception.

[Visual Basic] Overloads Overridable Public Function GetType(String, Boolean) As Type
[C#] public virtual Type GetType(String, bool);
[C++] public: virtual Type* GetType(String*, bool);
[JScript] public function GetType(String, Boolean) : Type;

Gets the Type object with the specified name.

[Visual Basic] Overloads Overridable Public Function GetType(String) As Type
[C#] public virtual Type GetType(String);
[C++] public: virtual Type* GetType(String*);
[JScript] public function GetType(String) : Type;

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.GetType (String, Boolean, Boolean)

Gets the Type object with the specified name, ignoring case, and optionally throws an exception on error.

[Visual Basic]
Overloads Public Function GetType( _
   ByVal name As String, _
   ByVal throwOnError As Boolean, _
   ByVal ignoreCase As Boolean _
) As Type
[C#]
public Type GetType(
   string name,
   bool throwOnError,
   bool ignoreCase
);
[C++]
public: Type* GetType(
   String* name,
   bool throwOnError,
   bool ignoreCase
);
[JScript]
public function GetType(
   name : String,
   throwOnError : Boolean,
   ignoreCase : Boolean
) : Type;

Parameters

name
The full name of the type.
throwOnError
true to throw an exception if the type is not found. Otherwise, return null.
ignoreCase
true to ignore the case of the type name. false to observe the case of the type name.

Return Value

A Type object that represents the specified class.

Exceptions

Exception Type | Condition
ArgumentNullException | if name is null.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace | Assembly.GetType Overload List


Assembly.GetType (String, Boolean)

Gets the Type object with the specified name and optionally throws an exception on exception.

[Visual Basic]
Overloads Overridable Public Function GetType( _
   ByVal name As String, _
   ByVal throwOnError As Boolean _
) As Type
[C#]
public virtual Type GetType(
   string name,
   bool throwOnError
);
[C++]
public: virtual Type* GetType(
   String* name,
   bool throwOnError
);
[JScript]
public function GetType(
   name : String,
   throwOnError : Boolean
) : Type;

Parameters

name
The full name of the type.
throwOnError
true to throw an exception if the type is not found. Otherwise, return null.

Return Value

A Type object that represents the specified class.

Exceptions

Exception Type | Condition
ArgumentNullException | if name is null.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace | Assembly.GetType Overload List


Assembly.GetType (String)

Gets the Type object with the specified name.

[Visual Basic]
Overloads Overridable Public Function GetType( _
   ByVal name As String _
) As Type
[C#]
public virtual Type GetType(
   string name
);
[C++]
public: virtual Type* GetType(
   String* name
);
[JScript]
public function GetType(
   name : String
) : Type;

Parameters

name
The full name of the type.

Return Value

A Type object that represents the specified class.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace | Assembly.GetType Overload List


Assembly.GetTypes

Gets the types defined in this assembly.

[Visual Basic]
Overridable Public Function GetTypes() As Type ()
[C#]
public virtual Type[] GetTypes();
[C++]
public: virtual Type* GetTypes() [];
[JScript]
public function GetTypes() : Type[];

Return Value

The Type objects for all the types defined in this assembly.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.IsDefined

Checks if a custom attribute identified by the specified Type is defined.

[Visual Basic]
Overridable Public Function IsDefined( _
   ByVal attributeType As Type _
) As Boolean
[C#]
public virtual bool IsDefined(
   Type attributeType
);
[C++]
public: virtual bool IsDefined(
   Type* attributeType
);
[JScript]
public function IsDefined(
   attributeType : Type
) : Boolean;

Parameters

attributeType
The Type for which the custom attributes is to be checked.

Return Value

Returns true if a custom attribute identified by the specified Type is defined. Otherwise, returns false.

Exceptions

Exception Type | Condition
ArgumentNullException | if attributeType is a null reference (in Visual Basic Nothing).

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.Load

[To be supplied.]

Overload List

Loads the assembly with a COFF based image containing an emitted assembly. The assembly is loaded into the domain of the caller using the supplied evidence. The raw bytes representing the symbols for the assembly are also loaded.

[Visual Basic] Overloads Public Shared Function Load(Byte(), Byte(), Evidence) As Assembly
[C#] public static Assembly Load(byte[], byte[], Evidence);
[C++] public: static Assembly* Load(unsigned char*[], unsigned char*[], Evidence);
[JScript] public static function Load(Byte[], Byte[], Evidence) : Assembly;

Loads the assembly with a COFF based image containing an emitted assembly. The assembly is loaded into the domain of the caller. The raw bytes representing the symbols for the assembly are also loaded.

[Visual Basic] Overloads Public Shared Function Load(Byte(), Byte()) As Assembly
[C#] public static Assembly Load(byte[], byte[]);
[C++] public: static Assembly* Load(unsigned char*[], unsigned char*[]);
[JScript] public static function Load(Byte[], Byte[]) : Assembly;

Loads an assembly given its display name.

[Visual Basic] Overloads Public Shared Function Load(String) As Assembly
[C#] public static Assembly Load(String);
[C++] public: static Assembly* Load(String*);
[JScript] public static function Load(String) : Assembly;

Loads an assembly given its AssemblyName. The assembly may be shared.

[Visual Basic] Overloads Public Shared Function Load(AssemblyName, Boolean) As Assembly
[C#] public static Assembly Load(AssemblyName, bool);
[C++] public: static Assembly* Load(AssemblyName*, bool);
[JScript] public static function Load(AssemblyName, Boolean) : Assembly;

Loads an assembly given its AssemblyName.

[Visual Basic] Overloads Public Shared Function Load(AssemblyName) As Assembly
[C#] public static Assembly Load(AssemblyName);
[C++] public: static Assembly* Load(AssemblyName*);
[JScript] public static function Load(AssemblyName) : Assembly;

Loads an assembly given its display name. The assembly may optionally be shared.

[Visual Basic] Overloads Public Shared Function Load(String, Boolean) As Assembly
[C#] public static Assembly Load(String, bool);
[C++] public: static Assembly* Load(String*, bool);
[JScript] public static function Load(String, Boolean) : Assembly;

Loads an assembly given its display name. The assembly is loaded into the domain of the caller using the supplied evidence. The assembly may optionally be shared.

[Visual Basic] Overloads Public Shared Function Load(String, Evidence, Boolean) As Assembly
[C#] public static Assembly Load(String, Evidence, bool);
[C++] public: static Assembly* Load(String*, Evidence, bool);
[JScript] public static function Load(String, Evidence, Boolean) : Assembly;

Loads the assembly with a COFF based image containing an emitted assembly. The assembly is loaded into the domain of the caller.

[Visual Basic] Overloads Public Shared Function Load(Byte()) As Assembly
[C#] public static Assembly Load(byte[]);
[C++] public: static Assembly* Load(unsigned char*[]);
[JScript] public static function Load(Byte[]) : Assembly;

Loads the assembly with a COFF based image containing an emitted assembly. The assembly is loaded into the domain of the caller using the supplied evidence. The assembly may optionally be shared.

[Visual Basic] Overloads Public Shared Function Load(AssemblyName, Evidence, Boolean) As Assembly
[C#] public static Assembly Load(AssemblyName, Evidence, bool);
[C++] public: static Assembly* Load(AssemblyName*, Evidence, bool);
[JScript] public static function Load(AssemblyName, Evidence, Boolean) : Assembly;

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.Load (Byte[], Byte[], Evidence)

Loads the assembly with a COFF based image containing an emitted assembly. The assembly is loaded into the domain of the caller using the supplied evidence. The raw bytes representing the symbols for the assembly are also loaded.

[Visual Basic]
Overloads Public Shared Function Load( _
   ByVal rawAssembly() As Byte, _
   ByVal rawSymbolStore() As Byte, _
   ByVal securityEvidence As Evidence _
) As Assembly
[C#]
public static Assembly Load(
   byte[] rawAssembly,
   byte[] rawSymbolStore,
   Evidence securityEvidence
);
[C++]
public: static Assembly* Load(
   unsigned char* rawAssembly[],
   unsigned char* rawSymbolStore[],
   Evidence* securityEvidence
);
[JScript]
public static function Load(
   rawAssembly : Byte[],
   rawSymbolStore : Byte[],
   securityEvidence : Evidence
) : Assembly;

Parameters

rawAssembly
COFF based image containing an emitted assembly.
rawSymbolStore
The raw bytes representing the symbols for the assembly.
securityEvidence
Evidence for loading the assembly.

Return Value

The loaded assembly.

Exceptions

Exception Type | Condition
ArgumentNullException | if rawAssembly is a null reference (in Visual Basic Nothing).

Remarks

The assembly is loaded into the domain of the caller.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace | Assembly.Load Overload List


Assembly.Load (Byte[], Byte[])

Loads the assembly with a COFF based image containing an emitted assembly. The assembly is loaded into the domain of the caller. The raw bytes representing the symbols for the assembly are also loaded.

[Visual Basic]
Overloads Public Shared Function Load( _
   ByVal rawAssembly() As Byte, _
   ByVal rawSymbolStore() As Byte _
) As Assembly
[C#]
public static Assembly Load(
   byte[] rawAssembly,
   byte[] rawSymbolStore
);
[C++]
public: static Assembly* Load(
   unsigned char* rawAssembly[],
   unsigned char* rawSymbolStore[]
);
[JScript]
public static function Load(
   rawAssembly : Byte[],
   rawSymbolStore : Byte[]
) : Assembly;

Parameters

rawAssembly
COFF based image containing an emitted assembly.
rawSymbolStore
The raw bytes representing the symbols for the assembly.

Return Value

The loaded assembly.

Exceptions

Exception Type | Condition
ArgumentNullException | if rawAssembly is a null reference (in Visual Basic Nothing).

Remarks

The assembly is loaded into the domain of the caller.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace | Assembly.Load Overload List


Assembly.Load (String)

Loads an assembly given its display name.

[Visual Basic]
Overloads Public Shared Function Load( _
   ByVal assemblyString As String _
) As Assembly
[C#]
public static Assembly Load(
   string assemblyString
);
[C++]
public: static Assembly* Load(
   String* assemblyString
);
[JScript]
public static function Load(
   assemblyString : String
) : Assembly;

Parameters

assemblyString
The display name of the assembly.

Return Value

The loaded assembly.

Exceptions

Exception Type | Condition
ArgumentNullException | if assemblyString is a null reference (in Visual Basic Nothing)
FileNotFoundException | if assembly is not found

Remarks

See AssemblyName for a description of the format of the display name.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace | Assembly.Load Overload List


Assembly.Load (AssemblyName, Boolean)

Loads an assembly given its AssemblyName. The assembly may be shared.

[Visual Basic]
Overloads Public Shared Function Load( _
   ByVal assemblyRef As AssemblyName, _
   ByVal shared As Boolean _
) As Assembly
[C#]
public static Assembly Load(
   AssemblyName assemblyRef,
   bool shared
);
[C++]
public: static Assembly* Load(
   AssemblyName* assemblyRef,
   bool shared
);
[JScript]
public static function Load(
   assemblyRef : AssemblyName,
   shared : Boolean
) : Assembly;

Parameters

assemblyRef
The AssemblyName object that describes the assembly to be loaded.
shared
true to load the assembly in a form where the JIT-compiled code can be reused by multiple application domains (at a slight cost in code quality).

Return Value

The loaded assembly.

Exceptions

Exception Type | Condition
ArgumentNullException | if assemblyRef is a null reference (in Visual Basic Nothing)
FileNotFoundException | if assembly is not found

Remarks

The assembly is loaded into the domain of the caller.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace | Assembly.Load Overload List


Assembly.Load (AssemblyName)

Loads an assembly given its AssemblyName.

[Visual Basic]
Overloads Public Shared Function Load( _
   ByVal assemblyRef As AssemblyName _
) As Assembly
[C#]
public static Assembly Load(
   AssemblyName assemblyRef
);
[C++]
public: static Assembly* Load(
   AssemblyName* assemblyRef
);
[JScript]
public static function Load(
   assemblyRef : AssemblyName
) : Assembly;

Parameters

assemblyRef
The AssemblyName object that describes the assembly to be loaded.

Return Value

The loaded assembly.

Exceptions

Exception Type | Condition
ArgumentNullException | if assemblyRef is a null reference (in Visual Basic Nothing)
FileNotFoundException | if assembly is not found

Remarks

The assembly is loaded into the domain of the caller.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace | Assembly.Load Overload List


Assembly.Load (String, Boolean)

Loads an assembly given its display name. The assembly may optionally be shared.

[Visual Basic]
Overloads Public Shared Function Load( _
   ByVal assemblyString As String, _
   ByVal shared As Boolean _
) As Assembly
[C#]
public static Assembly Load(
   string assemblyString,
   bool shared
);
[C++]
public: static Assembly* Load(
   String* assemblyString,
   bool shared
);
[JScript]
public static function Load(
   assemblyString : String,
   shared : Boolean
) : Assembly;

Parameters

assemblyString
The display name of the assembly.
shared
true to load the assembly in a form where the JIT-compiled code can be reused by multiple application domains (at a slight cost in code quality).

Return Value

The loaded assembly.

Exceptions

Exception Type | Condition
ArgumentNullException | if assemblyString is a null reference (in Visual Basic Nothing)
FileNotFoundException | if assembly is not found

Remarks

The assembly is loaded into the domain of the caller.

See AssemblyName for a description of the format of the display name.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace | Assembly.Load Overload List


Assembly.Load (String, Evidence, Boolean)

Loads an assembly given its display name. The assembly is loaded into the domain of the caller using the supplied evidence. The assembly may optionally be shared.

[Visual Basic]
Overloads Public Shared Function Load( _
   ByVal assemblyString As String, _
   ByVal assemblySecurity As Evidence, _
   ByVal shared As Boolean _
) As Assembly
[C#]
public static Assembly Load(
   string assemblyString,
   Evidence assemblySecurity,
   bool shared
);
[C++]
public: static Assembly* Load(
   String* assemblyString,
   Evidence* assemblySecurity,
   bool shared
);
[JScript]
public static function Load(
   assemblyString : String,
   assemblySecurity : Evidence,
   shared : Boolean
) : Assembly;

Parameters

assemblyString
The display name of the assembly.
assemblySecurity
Evidence for loading the assembly.
shared
true to load the assembly in a form where the JIT-compiled code can be reused by multiple application domains (at a slight cost in code quality).

Return Value

The loaded assembly.

Exceptions

Exception Type | Condition
ArgumentNullException | if assemblyString is a null reference (in Visual Basic Nothing)
FileNotFoundException | if assembly is not found

Remarks

The assembly is loaded into the domain of the caller.

See AssemblyName for a description of the format of the display name.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace | Assembly.Load Overload List


Assembly.Load (Byte[])

Loads the assembly with a COFF based image containing an emitted assembly. The assembly is loaded into the domain of the caller.

[Visual Basic]
Overloads Public Shared Function Load( _
   ByVal rawAssembly() As Byte _
) As Assembly
[C#]
public static Assembly Load(
   byte[] rawAssembly
);
[C++]
public: static Assembly* Load(
   unsigned char* rawAssembly[]
);
[JScript]
public static function Load(
   rawAssembly : Byte[]
) : Assembly;

Parameters

rawAssembly
COFF based image containing an emitted assembly.

Return Value

The loaded assembly.

Remarks

The assembly is loaded into the domain of the caller.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace | Assembly.Load Overload List


Assembly.Load (AssemblyName, Evidence, Boolean)

Loads the assembly with a COFF based image containing an emitted assembly. The assembly is loaded into the domain of the caller using the supplied evidence. The assembly may optionally be shared.

[Visual Basic]
Overloads Public Shared Function Load( _
   ByVal assemblyRef As AssemblyName, _
   ByVal assemblySecurity As Evidence, _
   ByVal shared As Boolean _
) As Assembly
[C#]
public static Assembly Load(
   AssemblyName assemblyRef,
   Evidence assemblySecurity,
   bool shared
);
[C++]
public: static Assembly* Load(
   AssemblyName* assemblyRef,
   Evidence* assemblySecurity,
   bool shared
);
[JScript]
public static function Load(
   assemblyRef : AssemblyName,
   assemblySecurity : Evidence,
   shared : Boolean
) : Assembly;

Parameters

assemblyRef
The AssemblyName object that describes the assembly to be loaded.
assemblySecurity
Evidence for loading the assembly.
shared
true to load the assembly in a form where the JIT-compiled code can be reused by multiple application domains (at a slight cost in code quality).

Return Value

The loaded assembly.

Exceptions

Exception Type | Condition
ArgumentNullException | if assemblyRef is a null reference (in Visual Basic Nothing)
FileNotFoundException | if assembly is not found

Remarks

The assembly is loaded into the domain of the caller.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace | Assembly.Load Overload List


Assembly.LoadFrom

[To be supplied.]

Overload List

Loads an assembly given its file name.

[Visual Basic] Overloads Public Shared Function LoadFrom(String) As Assembly
[C#] public static Assembly LoadFrom(String);
[C++] public: static Assembly* LoadFrom(String*);
[JScript] public static function LoadFrom(String) : Assembly;

Loads an assembly given its file name. The assembly may be shared. Evidence is supplied.

[Visual Basic] Overloads Public Shared Function LoadFrom(String, Evidence, Boolean) As Assembly
[C#] public static Assembly LoadFrom(String, Evidence, bool);
[C++] public: static Assembly* LoadFrom(String*, Evidence, bool);
[JScript] public static function LoadFrom(String, Evidence, Boolean) : Assembly;

Loads an assembly given its file name. The assembly may optionally be shared.

[Visual Basic] Overloads Public Shared Function LoadFrom(String, Boolean) As Assembly
[C#] public static Assembly LoadFrom(String, bool);
[C++] public: static Assembly* LoadFrom(String*, bool);
[JScript] public static function LoadFrom(String, Boolean) : Assembly;

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.LoadFrom (String)

Loads an assembly given its file name.

[Visual Basic]
Overloads Public Shared Function LoadFrom( _
   ByVal assemblyFile As String _
) As Assembly
[C#]
public static Assembly LoadFrom(
   string assemblyFile
);
[C++]
public: static Assembly* LoadFrom(
   String* assemblyFile
);
[JScript]
public static function LoadFrom(
   assemblyFile : String
) : Assembly;

Parameters

assemblyFile
The name of the file that contains the manifest of the assembly.

Return Value

The loaded assembly.

Exceptions

Exception Type | Condition
ArgumentNullException | if assemblyFile is a null reference (in Visual Basic Nothing)
FileNotFoundException | if assemblyFile is not found

Remarks

The assembly is loaded into the domain of the caller.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace | Assembly.LoadFrom Overload List


Assembly.LoadFrom (String, Evidence, Boolean)

Loads an assembly given its file name. The assembly may be shared. Evidence is supplied.

[Visual Basic]
Overloads Public Shared Function LoadFrom( _
   ByVal assemblyFile As String, _
   ByVal securityEvidence As Evidence, _
   ByVal shared As Boolean _
) As Assembly
[C#]
public static Assembly LoadFrom(
   string assemblyFile,
   Evidence securityEvidence,
   bool shared
);
[C++]
public: static Assembly* LoadFrom(
   String* assemblyFile,
   Evidence* securityEvidence,
   bool shared
);
[JScript]
public static function LoadFrom(
   assemblyFile : String,
   securityEvidence : Evidence,
   shared : Boolean
) : Assembly;

Parameters

assemblyFile
The name of the file that contains the manifest of the assembly.
securityEvidence
Evidence for loading the assembly.
shared
true to load the assembly in a form where the JIT-compiled code can be reused by multiple application domains (at a slight cost in code quality).

Return Value

The loaded assembly.

Exceptions

Exception Type | Condition
ArgumentNullException | if assemblyFile is a null reference (in Visual Basic Nothing)
FileNotFoundException | if assemblyFile is not found

Remarks

The assembly is loaded into the domain of the caller.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace | Assembly.LoadFrom Overload List


Assembly.LoadFrom (String, Boolean)

Loads an assembly given its file name. The assembly may optionally be shared.

[Visual Basic]
Overloads Public Shared Function LoadFrom( _
   ByVal assemblyFile As String, _
   ByVal shared As Boolean _
) As Assembly
[C#]
public static Assembly LoadFrom(
   string assemblyFile,
   bool shared
);
[C++]
public: static Assembly* LoadFrom(
   String* assemblyFile,
   bool shared
);
[JScript]
public static function LoadFrom(
   assemblyFile : String,
   shared : Boolean
) : Assembly;

Parameters

assemblyFile
The name of the file that contains the manifest of the assembly.
shared
true to load the assembly in a form where the JIT-compiled code can be reused by multiple application domains (at a slight cost in code quality).

Return Value

The loaded assembly.

Exceptions

Exception Type | Condition
ArgumentNullException | if assemblyFile is a null reference (in Visual Basic Nothing)
FileNotFoundException | if assemblyFile is not found

Remarks

The assembly is loaded into the domain of the caller.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace | Assembly.LoadFrom Overload List


Assembly.nCreateQualifiedName

Creates a name that qualifies the supplied type name with the supplied display name of an assembly.

[Visual Basic]
Public Shared Function nCreateQualifiedName( _
   ByVal assemblyName As String, _
   ByVal typeName As String _
) As String
[C#]
public static string nCreateQualifiedName(
   string assemblyName,
   string typeName
);
[C++]
public: static String* nCreateQualifiedName(
   String* assemblyName,
   String* typeName
);
[JScript]
public static function nCreateQualifiedName(
   assemblyName : String,
   typeName : String
) : String;

Parameters

assemblyName
The display name of an assembly.
typeName
The full name of a type.

Return Value

The type name qualified with the display name of the assembly.

Remarks

This method will be removed in a future release.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.RemoveOnResourceResolve

Unsubscribes to the "resource resolve" event. The "resource resolve" event is raised when a resource is loaded.

[Visual Basic]
Overridable Public Sub RemoveOnResourceResolve( _
   ByVal handler As ResolveEventHandler _
)
[C#]
public virtual void RemoveOnResourceResolve(
   ResolveEventHandler handler
);
[C++]
public: virtual void RemoveOnResourceResolve(
   ResolveEventHandler* handler
);
[JScript]
public function RemoveOnResourceResolve(
   handler : ResolveEventHandler
);

Parameters

handler
The event handler for the "resource resolve" event.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.RemoveOnTypeResolve

Unsubscribes to the "type resolve" event. The "type resolve" event is raised when a type is loaded.

[Visual Basic]
Overridable Public Sub RemoveOnTypeResolve( _
   ByVal handler As ResolveEventHandler _
)
[C#]
public virtual void RemoveOnTypeResolve(
   ResolveEventHandler handler
);
[C++]
public: virtual void RemoveOnTypeResolve(
   ResolveEventHandler* handler
);
[JScript]
public function RemoveOnTypeResolve(
   handler : ResolveEventHandler
);

Parameters

handler
The event handler for the "type resolve" event.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Assembly.SetObjectData

Reflate this assembly using all of the information in the specified SerializationInfo object.

[Visual Basic]
Public Sub SetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
public void SetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
public: void SetObjectData(
   SerializationInfo* info,
   StreamingContext context
);
[JScript]
public function SetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);

Parameters

info
The serialization information needed to reflate the assembly.
context
[To be supplied.]

Exceptions

Exception Type | Condition
NotSupportedException | This method is not supported.

See Also

Assembly Class | Assembly Members | System.Reflection Namespace


Events

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Assembly Events

The events of the Assembly class are listed below. For a complete list of Assembly class members, see the Assembly Members topic.

Public:

ResourceResolve | [To be supplied.]
TypeResolve | [To be supplied.]

See Also

Assembly Class | System.Reflection Namespace


Assembly ResourceResolve Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the ResourceResolve event.

[Visual Basic]
Private Sub AssemblyName_ResourceResolve( _
   ByVal sender As Object, _
   ByVal e As ResolveEventArgs _
)
[C#]
private void AssemblyName_ResourceResolve(
   object sender,
   ResolveEventArgs e
);
[C++]
private: void AssemblyName_ResourceResolve(
   Object* sender,
   ResolveEventArgs* e
);
[JScript]
private AssemblyName_ResourceResolve(
   sender : Object,
   e : ResolveEventArgs
);

Parameters

sender
The source of the event.
e
A ResolveEventArgs that contains the event data.

See Also

Assembly Class | Assembly MembersTopic | System.Reflection Namespace


Assembly TypeResolve Event

[To be supplied.]

The following declaration shows the syntax for a method that handles the TypeResolve event.

[Visual Basic]
Private Sub AssemblyName_TypeResolve( _
   ByVal sender As Object, _
   ByVal e As ResolveEventArgs _
)
[C#]
private void AssemblyName_TypeResolve(
   object sender,
   ResolveEventArgs e
);
[C++]
private: void AssemblyName_TypeResolve(
   Object* sender,
   ResolveEventArgs* e
);
[JScript]
private AssemblyName_TypeResolve(
   sender : Object,
   e : ResolveEventArgs
);

Parameters

sender
The source of the event.
e
A ResolveEventArgs that contains the event data.

See Also

Assembly Class | Assembly MembersTopic | System.Reflection Namespace


AssemblyCompanyAttribute Class

[To be supplied.]

Object
Attribute
AssemblyCompanyAttribute

[Visual Basic]
Public Class AssemblyCompanyAttribute
   Inherits Attribute
[C#]
public class AssemblyCompanyAttribute : Attribute
[C++]
public __gc class AssemblyCompanyAttribute : public Attribute
[JScript]
public class AssemblyCompanyAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

AssemblyCompanyAttribute Members | System.Reflection Namespace


AssemblyCompanyAttribute Members

Public:

Constructor

AssemblyCompanyAttribute Constructor [To be supplied.]

Properties

Company [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyCompanyAttribute Class | System.Reflection Namespace


AssemblyCompanyAttribute Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal company As String _
)
[C#]
public AssemblyCompanyAttribute(
   string company
);
[C++]
public: AssemblyCompanyAttribute(
   String* company
);
[JScript]
public function AssemblyCompanyAttribute(
   company : String
);

Parameters

company
[To be supplied.]

See Also

AssemblyCompanyAttribute Class | AssemblyCompanyAttribute Members | System.Reflection Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AssemblyCompanyAttribute Properties

The properties of the AssemblyCompanyAttribute class are listed below. For a complete list of AssemblyCompanyAttribute class members, see the AssemblyCompanyAttribute Members topic.

Public:

Company [To be supplied.]

See Also

AssemblyCompanyAttribute Class | System.Reflection Namespace


AssemblyCompanyAttribute.Company

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Company As String
[C#]
public string Company {get;}
[C++]
public: __property String* get_Company();
[JScript]
public function get Company() : String;

See Also

AssemblyCompanyAttribute Class | AssemblyCompanyAttribute Members | System.Reflection Namespace


AssemblyConfigurationAttribute Class

[To be supplied.]

Object
Attribute
AssemblyConfigurationAttribute

[Visual Basic]
Public Class AssemblyConfigurationAttribute
   Inherits Attribute
[C#]
public class AssemblyConfigurationAttribute : Attribute
[C++]
public __gc class AssemblyConfigurationAttribute : public Attribute
[JScript]
public class AssemblyConfigurationAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

AssemblyConfigurationAttribute Members | System.Reflection Namespace


AssemblyConfigurationAttribute Members

Public:

Constructor

AssemblyConfigurationAttribute Constructor [To be supplied.]

Properties

Configuration [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyConfigurationAttribute Class | System.Reflection Namespace


AssemblyConfigurationAttribute Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal configuration As String _
)
[C#]
public AssemblyConfigurationAttribute(
   string configuration
);
[C++]
public: AssemblyConfigurationAttribute(
   String* configuration
);
[JScript]
public function AssemblyConfigurationAttribute(
   configuration : String
);

Parameters

configuration
[To be supplied.]

See Also

AssemblyConfigurationAttribute Class | AssemblyConfigurationAttribute Members | System.Reflection Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AssemblyConfigurationAttribute Properties

The properties of the AssemblyConfigurationAttribute class are listed below. For a complete list of AssemblyConfigurationAttribute class members, see the AssemblyConfigurationAttribute Members topic.

Public:

Configuration [To be supplied.]

See Also

AssemblyConfigurationAttribute Class | System.Reflection Namespace


AssemblyConfigurationAttribute.Configuration

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Configuration As String
[C#]
public string Configuration {get;}
[C++]
public: __property String* get_Configuration();
[JScript]
public function get Configuration() : String;

See Also

AssemblyConfigurationAttribute Class | AssemblyConfigurationAttribute Members | System.Reflection Namespace


AssemblyCopyrightAttribute Class

[To be supplied.]

Object
Attribute
AssemblyCopyrightAttribute

[Visual Basic]
Public Class AssemblyCopyrightAttribute
   Inherits Attribute
[C#]
public class AssemblyCopyrightAttribute : Attribute
[C++]
public __gc class AssemblyCopyrightAttribute : public Attribute
[JScript]
public class AssemblyCopyrightAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

AssemblyCopyrightAttribute Members | System.Reflection Namespace


AssemblyCopyrightAttribute Members

Public:

Constructor

AssemblyCopyrightAttribute Constructor [To be supplied.]

Properties

Copyright [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyCopyrightAttribute Class | System.Reflection Namespace


AssemblyCopyrightAttribute Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal copyright As String _
)
[C#]
public AssemblyCopyrightAttribute(
   string copyright
);
[C++]
public: AssemblyCopyrightAttribute(
   String* copyright
);
[JScript]
public function AssemblyCopyrightAttribute(
   copyright : String
);

Parameters

copyright
[To be supplied.]

See Also

AssemblyCopyrightAttribute Class | AssemblyCopyrightAttribute Members | System.Reflection Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AssemblyCopyrightAttribute Properties

The properties of the AssemblyCopyrightAttribute class are listed below. For a complete list of AssemblyCopyrightAttribute class members, see the AssemblyCopyrightAttribute Members topic.

Public:

Copyright [To be supplied.]

See Also

AssemblyCopyrightAttribute Class | System.Reflection Namespace


AssemblyCopyrightAttribute.Copyright

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Copyright As String
[C#]
public string Copyright {get;}
[C++]
public: __property String* get_Copyright();
[JScript]
public function get Copyright() : String;

See Also

AssemblyCopyrightAttribute Class | AssemblyCopyrightAttribute Members | System.Reflection Namespace


AssemblyDefaultAliasAttribute Class

[To be supplied.]

Object
Attribute
AssemblyDefaultAliasAttribute

[Visual Basic]
Public Class AssemblyDefaultAliasAttribute
   Inherits Attribute
[C#]
public class AssemblyDefaultAliasAttribute : Attribute
[C++]
public __gc class AssemblyDefaultAliasAttribute : public Attribute
[JScript]
public class AssemblyDefaultAliasAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

AssemblyDefaultAliasAttribute Members | System.Reflection Namespace


AssemblyDefaultAliasAttribute Members

Public:

Constructor

AssemblyDefaultAliasAttribute Constructor [To be supplied.]

Properties

DefaultAlias [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyDefaultAliasAttribute Class | System.Reflection Namespace


AssemblyDefaultAliasAttribute Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal defaultAlias As String _
)
[C#]
public AssemblyDefaultAliasAttribute(
   string defaultAlias
);
[C++]
public: AssemblyDefaultAliasAttribute(
   String* defaultAlias
);
[JScript]
public function AssemblyDefaultAliasAttribute(
   defaultAlias : String
);

Parameters

defaultAlias
[To be supplied.]

See Also

AssemblyDefaultAliasAttribute Class | AssemblyDefaultAliasAttribute Members | System.Reflection Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AssemblyDefaultAliasAttribute Properties

The properties of the AssemblyDefaultAliasAttribute class are listed below. For a complete list of AssemblyDefaultAliasAttribute class members, see the AssemblyDefaultAliasAttribute Members topic.

Public:

DefaultAlias [To be supplied.]

See Also

AssemblyDefaultAliasAttribute Class | System.Reflection Namespace


AssemblyDefaultAliasAttribute.DefaultAlias

[To be supplied.]

[Visual Basic]
Public ReadOnly Property DefaultAlias As String
[C#]
public string DefaultAlias {get;}
[C++]
public: __property String* get_DefaultAlias();
[JScript]
public function get DefaultAlias() : String;

See Also

AssemblyDefaultAliasAttribute Class | AssemblyDefaultAliasAttribute Members | System.Reflection Namespace


AssemblyDescriptionAttribute Class

[To be supplied.]

Object
Attribute
AssemblyDescriptionAttribute

[Visual Basic]
Public Class AssemblyDescriptionAttribute
   Inherits Attribute
[C#]
public class AssemblyDescriptionAttribute : Attribute
[C++]
public __gc class AssemblyDescriptionAttribute : public Attribute
[JScript]
public class AssemblyDescriptionAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

AssemblyDescriptionAttribute Members | System.Reflection Namespace


AssemblyDescriptionAttribute Members

Public:

Constructor

AssemblyDescriptionAttribute Constructor [To be supplied.]

Properties

Description [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyDescriptionAttribute Class | System.Reflection Namespace


AssemblyDescriptionAttribute Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal description As String _
)
[C#]
public AssemblyDescriptionAttribute(
   string description
);
[C++]
public: AssemblyDescriptionAttribute(
   String* description
);
[JScript]
public function AssemblyDescriptionAttribute(
   description : String
);

Parameters

description
[To be supplied.]

See Also

AssemblyDescriptionAttribute Class | AssemblyDescriptionAttribute Members | System.Reflection Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AssemblyDescriptionAttribute Properties

The properties of the AssemblyDescriptionAttribute class are listed below. For a complete list of AssemblyDescriptionAttribute class members, see the AssemblyDescriptionAttribute Members topic.

Public:

Description [To be supplied.]

See Also

AssemblyDescriptionAttribute Class | System.Reflection Namespace


AssemblyDescriptionAttribute.Description

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Description As String
[C#]
public string Description {get;}
[C++]
public: __property String* get_Description();
[JScript]
public function get Description() : String;

See Also

AssemblyDescriptionAttribute Class | AssemblyDescriptionAttribute Members | System.Reflection Namespace


AssemblyInformationalVersionAttribute Class

[To be supplied.]

Object
Attribute
AssemblyInformationalVersionAttribute

[Visual Basic]
Public Class AssemblyInformationalVersionAttribute
   Inherits Attribute
[C#]
public class AssemblyInformationalVersionAttribute : Attribute
[C++]
public __gc class AssemblyInformationalVersionAttribute : public
   Attribute
[JScript]
public class AssemblyInformationalVersionAttribute extends
   Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

AssemblyInformationalVersionAttribute Members | System.Reflection Namespace


AssemblyInformationalVersionAttribute Members

Public:

Constructor

AssemblyInformationalVersionAttribute Constructor [To be supplied.]

Properties

InformationalVersion [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyInformationalVersionAttribute Class | System.Reflection Namespace


AssemblyInformationalVersionAttribute Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal informationalVersion As String _
)
[C#]
public AssemblyInformationalVersionAttribute(
   string informationalVersion
);
[C++]
public: AssemblyInformationalVersionAttribute(
   String* informationalVersion
);
[JScript]
public function AssemblyInformationalVersionAttribute(
   informationalVersion : String
);

Parameters

informationalVersion
[To be supplied.]

See Also

AssemblyInformationalVersionAttribute Class | AssemblyInformationalVersionAttribute Members | System.Reflection Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AssemblyInformationalVersionAttribute Properties

The properties of the AssemblyInformationalVersionAttribute class are listed below. For a complete list of AssemblyInformationalVersionAttribute class members, see the AssemblyInformationalVersionAttribute Members topic.

Public:

InformationalVersion [To be supplied.]

See Also

AssemblyInformationalVersionAttribute Class | System.Reflection Namespace


AssemblyInformationalVersionAttribute.InformationalVersion

[To be supplied.]

[Visual Basic]
Public ReadOnly Property InformationalVersion As String
[C#]
public string InformationalVersion {get;}
[C++]
public: __property String* get_InformationalVersion();
[JScript]
public function get InformationalVersion() : String;

See Also

AssemblyInformationalVersionAttribute Class | AssemblyInformationalVersionAttribute Members | System.Reflection Namespace


AssemblyName Class

This class fully describes an assembly's unique identity. An assembly's identity consists of several pieces of information including a simple textual name, a version number, a cryptographic key pair, and supported culture.

Object
AssemblyName

[Visual Basic]
Public Class AssemblyName
   Implements ICloneable
[C#]
public class AssemblyName : ICloneable
[C++]
public __gc class AssemblyName : public ICloneable
[JScript]
public class AssemblyName implements ICloneable

Remarks

The AssemblyName class is used for binding and retrieving information about an assembly. The AssemblyName class is used to interface with the assembly cache manager.

The friendly textual name of an assembly is called simple name. A name secured with a public and private cryptographic key pair is called strong name.

A fully specified AssemblyName must have the following parameters: name, culture, originator, major version, minor version, revision number, and build number. The last four are packaged in the Version type.

An AssemblyName may specify a partial query in that an insufficient number of parameters is supplied to explicitly determine a unique assembly. The AssemblyName is used by the assembly cache manager to bind to an assembly, given other information such as application assembly deployment and assembly cache state. The assembly cache manager will return the first assembly that matches the specified AssemblyName. The order in which the parameters may be specified in partial assembly name references is restricted to the order specified above. For example, it is permissible to specify and match on name, culture, originator with the version parameters omitted, but it is not permissible to match on name and originator, omitting both culture and the version. When used for binding the name is the minimal requirement

To create a simple name, create an AssemblyName object using the default constructor and set the Name. The other properties are optional.

To create a full strong name, create an AssemblyName object using the default constructor and set the Name and KeyPair. The other properties are optional. The Originator will be set for you. The strong name signing always uses the SHA1 hash algorithm.

For a partial specified strong name, create an AssemblyName object using the default constructor and set the Name and Originator. The other properties are optional. An assembly created using such an AssemblyName can be signed later using the LM tool.

It is possible to specify an Originator and a KeyPair with inconsistent values. This is useful in developer scenarios. In this case the Originator specifies the correct public key while the KeyPair specifies the public and private keys used during development. When the runtime detects a mismatch between the KeyPair and the Originator, it looks up in the registry the correct key that matches the Originator.

The format of the display name of an AssemblyName is a comma delimited Unicode string that begins with the name.

Name <,Loc = CultureInfo> <,Ver = Major.Minor.Revision.Build> <,SN = StrongName> <,PK = PublicKey> '\0'

Name is the textual name of the assembly. CultureInfo is the RFC1766 format defined culture. StrongName is the hexadecimal-encoded low-order 64 bits of the hash value of the Originator generated using the SHA-1 hashing algorithm and the public key specified by the Originator. Major, Minor, Revision, and Build are the major version, minor version, revision number, and build number of the assembly. PublicKey is the hexadecimal-encoded public key specified by the Originator.

Quoted values are optional. Hexadecimal encoding is defined as the conversion of each byte of a binary object to two hexadecimal characters, progressing from least to most significant byte. Additional display values will be added as deemed necessary.

If the full public key is known then PK (public key) may be substituted for SN.

Also note that except for name which must come first, the lexical order of parameters as specified in the string is unimportant.

However, any parameter (Ver, Loc, SN or PK) not specifically set is considered to be omitted and the AssemblyName is considered partial. When specifying partial information, name parameters must be specified in the order described previously.

When supplying a display name, the convention SN=null or PK=null, indicates that binding and matching against a simply named assembly is required. Additionally, the convention Loc= "" (double quote representing empty string) indicates matching against the default culture.

1. Example of fully specified AssemblyName for simply named assembly with default locale:

com.microsoft.crypto, Loc="", SN=null, Ver=1.0.0.0,

2. Example of fully specified ref for strongly named assembly with locale "en":

com.microsoft.crypto, Loc=en, SN=a5d015c7d5a0b012, Ver=1.0.0.0

3. Examples of partially specified AssemblyName, may be satisfied by either strong or simply named assembly:

com.microsoft.crypto

com.microsoft.crypto, Loc=""

com.microsoft.crypto, Loc=en

4. Examples of partially specified AssemblyName, must be satisfied by simply named assembly:

com.microsoft.crypto, Loc="", SN=null

com.microsoft.crypto, Loc=en, SN=null, Ver=1.0

5. Examples of partially specified AssemblyName, must be satisfied by strongly named assembly:

com.microsoft.crypto, Loc="", SN=a5d015c7d5a0b012

com.microsoft.crypto, Loc=en, SN=a5d015c7d5a0b012, Ver=1.0

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

AssemblyName Members | System.Reflection Namespace


AssemblyName Members

Public:

Constructor

AssemblyName Constructor Initializes a new AssemblyName.

Properties

CodeBase | This read/write property returns and sets the location of the assembly. The location is a URL.
Configuration | This read/write property returns and sets the configuration of the assembly. The value "Retail" is predefined, and would be the configuration provided by the assembly cache manager's binding services if no specific configuration is requested. Otherwise, the configuration may be set to any string value.
CultureInfo | This read/write property returns and sets the culture of the assembly.
DefaultAlias | This read/write property returns and sets the default alias to be used by referencing assemblies. This allows a friendly default alias to be provided in cases where the name itself is not friendly. For example, in COM interoperability, the generated assembly name will be the GUID of the type library, whilst the default alias will be the friendly type library name. If null, then the name would be used as the default alias.
Description | This read/write property returns and sets a short description summarizing the nature and purpose of the assembly.
Flags | This read/write property returns and sets the attributes of the assembly.
FullName | This read-only property returns the full name of the assembly.
HashAlgorithm | This read/write property returns and sets the hash algorithm to use for hashing the files within the assembly.
KeyPair | This read/write property returns and sets the public and private cryptographic key pair generated by the originator of the assembly.
Name | This read/write property returns and sets the simple human-readable name of the assembly.
Processor | This read-write property gets or sets the processors supported by the assembly.
Title | This read/write property returns and sets the "friendly name" of the assembly. It is expected that Name is a short name, that is a valid language identifier, and Title then provides a friendly name, that could include spaces, etc. For example, Name = "comdlg", Title = "Microsoft Common Dialog Control". It is not expected that the title would include the version.
Version | This read/write property returns and sets the major, minor, revision and build of the assembly.
VersionCompatibility | This read/write property returns and sets the information related to the assembly's compatibility with other assemblies, indicating, for example, if it cannot execute side-by-side with other versions (e.g. due to conflicts over a device driver).

Methods

Clone | Make a copy of this AssemblyName object.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetAssemblyHash | Get the hash value of the file containing the assembly manifest.
GetAssemblyName | Get the AssemblyName for a given file.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetOperatingSystems | Get the operating systems supported by the assembly.
GetOriginator | Get the public key identifying the originator of the assembly.
GetProcessors | Get the processors supported by the assembly.
GetType (inherited from Object) | Gets the Type of the Object.
SetAssemblyHash | Sets the hash value of the file containing the assembly manifest.
SetOperatingSystems | Sets the operating systems supported by the assembly.
SetOriginator | Set the public key identifying the originator of the assembly.
SetProcessors | Sets the processors supported by the assembly.
ToString | Get the full name of the assembly.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyName Class | System.Reflection Namespace


AssemblyName Constructor

Initializes a new AssemblyName.

[Visual Basic]
Public Sub New()
[C#]
public AssemblyName();
[C++]
public: AssemblyName();
[JScript]
public function AssemblyName();

See Also

AssemblyName Class | AssemblyName Members | System.Reflection Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AssemblyName Properties

The properties of the AssemblyName class are listed below. For a complete list of AssemblyName class members, see the AssemblyName Members topic.

Public:

CodeBase | This read/write property returns and sets the location of the assembly. The location is a URL.
Configuration | This read/write property returns and sets the configuration of the assembly. The value "Retail" is predefined, and would be the configuration provided by the assembly cache manager's binding services if no specific configuration is requested. Otherwise, the configuration may be set to any string value.
CultureInfo | This read/write property returns and sets the culture of the assembly.
DefaultAlias | This read/write property returns and sets the default alias to be used by referencing assemblies. This allows a friendly default alias to be provided in cases where the name itself is not friendly. For example, in COM interoperability, the generated assembly name will be the GUID of the type library, whilst the default alias will be the friendly type library name. If null, then the name would be used as the default alias.
Description | This read/write property returns and sets a short description summarizing the nature and purpose of the assembly.
Flags | This read/write property returns and sets the attributes of the assembly.
FullName | This read-only property returns the full name of the assembly.
HashAlgorithm | This read/write property returns and sets the hash algorithm to use for hashing the files within the assembly.
KeyPair | This read/write property returns and sets the public and private cryptographic key pair generated by the originator of the assembly.
Name | This read/write property returns and sets the simple human-readable name of the assembly.
Processor | This read-write property gets or sets the processors supported by the assembly.
Title | This read/write property returns and sets the "friendly name" of the assembly. It is expected that Name is a short name, that is a valid language identifier, and Title then provides a friendly name, that could include spaces, etc. For example, Name = "comdlg", Title = "Microsoft Common Dialog Control". It is not expected that the title would include the version.
Version | This read/write property returns and sets the major, minor, revision and build of the assembly.
VersionCompatibility | This read/write property returns and sets the information related to the assembly's compatibility with other assemblies, indicating, for example, if it cannot execute side-by-side with other versions (e.g. due to conflicts over a device driver).

See Also

AssemblyName Class | System.Reflection Namespace


AssemblyName.CodeBase

This read/write property returns and sets the location of the assembly. The location is a URL.

[Visual Basic]
Overridable Public Property CodeBase As String
[C#]
public string CodeBase {virtual get; virtual set;}
[C++]
public: __property virtual String* get_CodeBase();
public: __property virtual void set_CodeBase(String*);
[JScript]
public function get CodeBase() : String;
public function set CodeBase(String);

Property Value

Read/write. Returns and sets the location of the assembly.

See Also

AssemblyName Class | AssemblyName Members | System.Reflection Namespace


AssemblyName.Configuration

This read/write property returns and sets the configuration of the assembly. The value "Retail" is predefined, and would be the configuration provided by the assembly cache manager's binding services if no specific configuration is requested. Otherwise, the configuration may be set to any string value.

[Visual Basic]
Overridable Public Property Configuration As String
[C#]
public string Configuration {virtual get; virtual set;}
[C++]
public: __property virtual String* get_Configuration();
public: __property virtual void set_Configuration(String*);
[JScript]
public function get Configuration() : String;
public function set Configuration(String);

Property Value

Read/write. Returns and sets the configuration of the assembly.

See Also

AssemblyName Class | AssemblyName Members | System.Reflection Namespace


AssemblyName.CultureInfo

This read/write property returns and sets the culture of the assembly.

[Visual Basic]
Overridable Public Property CultureInfo As CultureInfo
[C#]
public CultureInfo CultureInfo {virtual get; virtual set;}
[C++]
public: __property virtual CultureInfo* get_CultureInfo();
public: __property virtual void set_CultureInfo(CultureInfo*);
[JScript]
public function get CultureInfo() : CultureInfo;
public function set CultureInfo(CultureInfo);

Property Value

Read/write. Returns and sets the culture of the assembly.

See Also

AssemblyName Class | AssemblyName Members | System.Reflection Namespace


AssemblyName.DefaultAlias

This read/write property returns and sets the default alias to be used by referencing assemblies. This allows a friendly default alias to be provided in cases where the name itself is not friendly. For example, in COM interoperability, the generated assembly name will be the GUID of the type library, whilst the default alias will be the friendly type library name. If null, then the name would be used as the default alias.

[Visual Basic]
Overridable Public Property DefaultAlias As String
[C#]
public string DefaultAlias {virtual get; virtual set;}
[C++]
public: __property virtual String* get_DefaultAlias();
public: __property virtual void set_DefaultAlias(String*);
[JScript]
public function get DefaultAlias() : String;
public function set DefaultAlias(String);

Property Value

Read/write. Returns and sets the default alias to be used by referencing assemblies.

See Also

AssemblyName Class | AssemblyName Members | System.Reflection Namespace


AssemblyName.Description

This read/write property returns and sets a short description summarizing the nature and purpose of the assembly.

[Visual Basic]
Overridable Public Property Description As String
[C#]
public string Description {virtual get; virtual set;}
[C++]
public: __property virtual String* get_Description();
public: __property virtual void set_Description(String*);
[JScript]
public function get Description() : String;
public function set Description(String);

Property Value

Read/write. Returns and sets a short description summarizing the nature and purpose of the assembly.

See Also

AssemblyName Class | AssemblyName Members | System.Reflection Namespace


AssemblyName.Flags

This read/write property returns and sets the attributes of the assembly.

[Visual Basic]
Overridable Public Property Flags As AssemblyNameFlags
[C#]
public AssemblyNameFlags Flags {virtual get; virtual set;}
[C++]
public: __property virtual AssemblyNameFlags get_Flags();
public: __property virtual void set_Flags(AssemblyNameFlags);
[JScript]
public function get Flags() : AssemblyNameFlags;
public function set Flags(AssemblyNameFlags);

Property Value

Read/write. Returns and sets the attributes of the assembly.

See Also

AssemblyName Class | AssemblyName Members | System.Reflection Namespace


AssemblyName.FullName

This read-only property returns the full name of the assembly.

[Visual Basic]
Overridable Public ReadOnly Property FullName As String
[C#]
public string FullName {virtual get;}
[C++]
public: __property virtual String* get_FullName();
[JScript]
public function get FullName() : String;

Property Value

Read-only. Returns the full name of the assembly.

See Also

AssemblyName Class | AssemblyName Members | System.Reflection Namespace


AssemblyName.HashAlgorithm

This read/write property returns and sets the hash algorithm to use for hashing the files within the assembly.

[Visual Basic]
Overridable Public Property HashAlgorithm As AssemblyHashAlgorithm
[C#]
public AssemblyHashAlgorithm HashAlgorithm {virtual get; virtual
   set;}
[C++]
public: __property virtual AssemblyHashAlgorithm get_HashAlgorithm();
public: __property virtual void set_HashAlgorithm(AssemblyHashAlgorithm);
[JScript]
public function get HashAlgorithm() : AssemblyHashAlgorithm;
public function set HashAlgorithm(AssemblyHashAlgorithm);

Property Value

Read/write. Returns and sets the hash algorithm to use for hashing the files within the assembly.

See Also

AssemblyName Class | AssemblyName Members | System.Reflection Namespace


AssemblyName.KeyPair

This read/write property returns and sets the public and private cryptographic key pair generated by the originator of the assembly.

[Visual Basic]
Overridable Public Property KeyPair As StrongNameKeyPair
[C#]
public StrongNameKeyPair KeyPair {virtual get; virtual set;}
[C++]
public: __property virtual StrongNameKeyPair* get_KeyPair();
public: __property virtual void set_KeyPair(StrongNameKeyPair*);
[JScript]
public function get KeyPair() : StrongNameKeyPair;
public function set KeyPair(StrongNameKeyPair);

Property Value

Read/write. Returns and sets the public and private cryptographic key pair generated by the originator of the assembly.

See Also

AssemblyName Class | AssemblyName Members | System.Reflection Namespace


AssemblyName.Name

This read/write property returns and sets the simple human-readable name of the assembly.

[Visual Basic]
Overridable Public Property Name As String
[C#]
public string Name {virtual get; virtual set;}
[C++]
public: __property virtual String* get_Name();
public: __property virtual void set_Name(String*);
[JScript]
public function get Name() : String;
public function set Name(String);

Property Value

Read/write. Returns and sets the simple human-readable name of the assembly.

See Also

AssemblyName Class | AssemblyName Members | System.Reflection Namespace


AssemblyName.Processor

This read-write property gets or sets the processors supported by the assembly.

[Visual Basic]
Property Processor As ProcessorID
[C#]
ProcessorID Processor {virtual set;}
[C++]
public: __property virtual void set_Processor(ProcessorID);
[JScript]
public function set Processor(ProcessorID);

Property Value

Gets or sets the processors supported by the assembly

Remarks

This property will be removed in a future release. Use GetProcessors or SetProcessors.

See Also

AssemblyName Class | AssemblyName Members | System.Reflection Namespace


AssemblyName.Title

This read/write property returns and sets the "friendly name" of the assembly. It is expected that Name is a short name, that is a valid language identifier, and Title then provides a friendly name, that could include spaces, etc. For example, Name = "comdlg", Title = "Microsoft Common Dialog Control". It is not expected that the title would include the version.

[Visual Basic]
Overridable Public Property Title As String
[C#]
public string Title {virtual get; virtual set;}
[C++]
public: __property virtual String* get_Title();
public: __property virtual void set_Title(String*);
[JScript]
public function get Title() : String;
public function set Title(String);

Property Value

This read/write property returns and sets the "friendly name" of the assembly.

See Also

AssemblyName Class | AssemblyName Members | System.Reflection Namespace


AssemblyName.Version

This read/write property returns and sets the major, minor, revision and build of the assembly.

[Visual Basic]
Overridable Public Property Version As Version
[C#]
public Version Version {virtual get; virtual set;}
[C++]
public: __property virtual Version* get_Version();
public: __property virtual void set_Version(Version*);
[JScript]
public function get Version() : Version;
public function set Version(Version);

Property Value

Read/write. Returns and sets the major, minor, revision and build of the assembly.

See Also

AssemblyName Class | AssemblyName Members | System.Reflection Namespace


AssemblyName.VersionCompatibility

This read/write property returns and sets the information related to the assembly's compatibility with other assemblies, indicating, for example, if it cannot execute side-by-side with other versions (e.g. due to conflicts over a device driver).

[Visual Basic]
Overridable Public Property VersionCompatibility As _
   AssemblyVersionCompatibility
[C#]
public AssemblyVersionCompatibility VersionCompatibility {virtual
   get; virtual set;}
[C++]
public: __property virtual AssemblyVersionCompatibility get_VersionCompatibility();
public: __property virtual void set_VersionCompatibility(AssemblyVersionCompatibility);
[JScript]
public function get VersionCompatibility() : AssemblyVersionCompatibility;
public function set VersionCompatibility(AssemblyVersionCompatibility);

Property Value

Read/write. Returns and sets the information related to the assembly's compatibility with other assemblies.

See Also

AssemblyName Class | AssemblyName Members | System.Reflection Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AssemblyName Methods

The methods of the AssemblyName class are listed below. For a complete list of AssemblyName class members, see the AssemblyName Members topic.

Public:

Clone | Make a copy of this AssemblyName object.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetAssemblyHash | Get the hash value of the file containing the assembly manifest.
GetAssemblyName | Get the AssemblyName for a given file.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetOperatingSystems | Get the operating systems supported by the assembly.
GetOriginator | Get the public key identifying the originator of the assembly.
GetProcessors | Get the processors supported by the assembly.
GetType (inherited from Object) | Gets the Type of the Object.
SetAssemblyHash | Sets the hash value of the file containing the assembly manifest.
SetOperatingSystems | Sets the operating systems supported by the assembly.
SetOriginator | Set the public key identifying the originator of the assembly.
SetProcessors | Sets the processors supported by the assembly.
ToString | Get the full name of the assembly.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyName Class | System.Reflection Namespace


AssemblyName.Clone

Make a copy of this AssemblyName object.

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();
[C++]
public: virtual Object* Clone();
[JScript]
public function Clone() : Object;

Return Value

Returns a copy of this AssemblyName object.

Remarks

A new object is created, identical to the original.

See Also

AssemblyName Class | AssemblyName Members | System.Reflection Namespace


AssemblyName.GetAssemblyHash

Get the hash value of the file containing the assembly manifest.

[Visual Basic]
Public Function GetAssemblyHash() As Byte ()
[C#]
public byte[] GetAssemblyHash();
[C++]
public: unsigned char* GetAssemblyHash() [];
[JScript]
public function GetAssemblyHash() : Byte[];

Return Value

Returns the hash value of the file containing the assembly manifest.

See Also

AssemblyName Class | AssemblyName Members | System.Reflection Namespace


AssemblyName.GetAssemblyName

Get the AssemblyName for a given file.

[Visual Basic]
Public Shared Function GetAssemblyName( _
   ByVal filename As String _
) As AssemblyName
[C#]
public static AssemblyName GetAssemblyName(
   string filename
);
[C++]
public: static AssemblyName* GetAssemblyName(
   String* filename
);
[JScript]
public static function GetAssemblyName(
   filename : String
) : AssemblyName;

Parameters

filename
The file for which to get the AssemblyName.

Return Value

Returns the AssemblyName for the given file.

Remarks

This will only work if the file contains an assembly manifest. This method causes the file to be opened and closed.

See Also

AssemblyName Class | AssemblyName Members | System.Reflection Namespace


AssemblyName.GetOperatingSystems

Get the operating systems supported by the assembly.

[Visual Basic]
Public Function GetOperatingSystems() As OperatingSystem ()
[C#]
public OperatingSystem[] GetOperatingSystems();
[C++]
public: OperatingSystem* GetOperatingSystems() [];
[JScript]
public function GetOperatingSystems() : OperatingSystem[];

Return Value

Returns the operating systems supported by the assembly.

See Also

AssemblyName Class | AssemblyName Members | System.Reflection Namespace


AssemblyName.GetOriginator

Get the public key identifying the originator of the assembly.

[Visual Basic]
Public Function GetOriginator() As Byte ()
[C#]
public byte[] GetOriginator();
[C++]
public: unsigned char* GetOriginator() [];
[JScript]
public function GetOriginator() : Byte[];

Return Value

Returns the public key identifying the originator of the assembly.

See Also

AssemblyName Class | AssemblyName Members | System.Reflection Namespace


AssemblyName.GetProcessors

Get the processors supported by the assembly.

[Visual Basic]
Public Function GetProcessors() As ProcessorID ()
[C#]
public ProcessorID[] GetProcessors();
[C++]
public: ProcessorID* GetProcessors() [];
[JScript]
public function GetProcessors() : ProcessorID[];

Return Value

Returns the processors supported by the assembly.

See Also

AssemblyName Class | AssemblyName Members | System.Reflection Namespace


AssemblyName.SetAssemblyHash

Sets the hash value of the file containing the assembly manifest.

[Visual Basic]
Public Sub SetAssemblyHash( _
   ByVal assemblyHash() As Byte _
)
[C#]
public void SetAssemblyHash(
   byte[] assemblyHash
);
[C++]
public: void SetAssemblyHash(
   unsigned char* assemblyHash[]
);
[JScript]
public function SetAssemblyHash(
   assemblyHash : Byte[]
);

Parameters

assemblyHash
The hash value of the file that contains the manifest.

See Also

AssemblyName Class | AssemblyName Members | System.Reflection Namespace


AssemblyName.SetOperatingSystems

Sets the operating systems supported by the assembly.

[Visual Basic]
Public Sub SetOperatingSystems( _
   ByVal operatingSystems() As OperatingSystem _
)
[C#]
public void SetOperatingSystems(
   OperatingSystem[] operatingSystems
);
[C++]
public: void SetOperatingSystems(
   OperatingSystem* operatingSystems[]
);
[JScript]
public function SetOperatingSystems(
   operatingSystems : OperatingSystem[]
);

Parameters

operatingSystems
The operating systems supported by the assembly.

See Also

AssemblyName Class | AssemblyName Members | System.Reflection Namespace


AssemblyName.SetOriginator

Set the public key identifying the originator of the assembly.

[Visual Basic]
Public Sub SetOriginator( _
   ByVal originator() As Byte _
)
[C#]
public void SetOriginator(
   byte[] originator
);
[C++]
public: void SetOriginator(
   unsigned char* originator[]
);
[JScript]
public function SetOriginator(
   originator : Byte[]
);

Parameters

originator
The public key identifying the originator of the assembly.

See Also

AssemblyName Class | AssemblyName Members | System.Reflection Namespace


AssemblyName.SetProcessors

Sets the processors supported by the assembly.

[Visual Basic]
Public Sub SetProcessors( _
   ByVal processorIDs() As ProcessorID _
)
[C#]
public void SetProcessors(
   ProcessorID[] processorIDs
);
[C++]
public: void SetProcessors(
   ProcessorID* processorIDs[]
);
[JScript]
public function SetProcessors(
   processorIDs : ProcessorID[]
);

Parameters

processorIDs
The processors supported by the assembly.

See Also

AssemblyName Class | AssemblyName Members | System.Reflection Namespace


AssemblyName.ToString

Get the full name of the assembly.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

Returns the full name of the assembly.

Remarks

See the description of AssemblyName for the format of the returned string.

If the full name of the assembly cannot be determined, returns the name of this class.

See Also

AssemblyName Class | AssemblyName Members | System.Reflection Namespace


AssemblyNameFlags Enumeration

These flags control how an AssemblyName is used during assembly binding.

[Visual Basic]
Public Enum AssemblyNameFlags
[C#]
public enum AssemblyNameFlags
[C++]
public enum AssemblyNameFlags

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
FullOriginator | Flag used to specify that an originator is formed from the full public key and not the compress one.
None | No flags specified.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

System.Reflection Namespace


AssemblyProductAttribute Class

[To be supplied.]

Object
Attribute
AssemblyProductAttribute

[Visual Basic]
Public Class AssemblyProductAttribute
   Inherits Attribute
[C#]
public class AssemblyProductAttribute : Attribute
[C++]
public __gc class AssemblyProductAttribute : public Attribute
[JScript]
public class AssemblyProductAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

AssemblyProductAttribute Members | System.Reflection Namespace


AssemblyProductAttribute Members

Public:

Constructor

AssemblyProductAttribute Constructor [To be supplied.]

Properties

Product [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyProductAttribute Class | System.Reflection Namespace


AssemblyProductAttribute Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal product As String _
)
[C#]
public AssemblyProductAttribute(
   string product
);
[C++]
public: AssemblyProductAttribute(
   String* product
);
[JScript]
public function AssemblyProductAttribute(
   product : String
);

Parameters

product
[To be supplied.]

See Also

AssemblyProductAttribute Class | AssemblyProductAttribute Members | System.Reflection Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AssemblyProductAttribute Properties

The properties of the AssemblyProductAttribute class are listed below. For a complete list of AssemblyProductAttribute class members, see the AssemblyProductAttribute Members topic.

Public:

Product [To be supplied.]

See Also

AssemblyProductAttribute Class | System.Reflection Namespace


AssemblyProductAttribute.Product

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Product As String
[C#]
public string Product {get;}
[C++]
public: __property String* get_Product();
[JScript]
public function get Product() : String;

See Also

AssemblyProductAttribute Class | AssemblyProductAttribute Members | System.Reflection Namespace


AssemblyTitleAttribute Class

[To be supplied.]

Object
Attribute
AssemblyTitleAttribute

[Visual Basic]
Public Class AssemblyTitleAttribute
   Inherits Attribute
[C#]
public class AssemblyTitleAttribute : Attribute
[C++]
public __gc class AssemblyTitleAttribute : public Attribute
[JScript]
public class AssemblyTitleAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

AssemblyTitleAttribute Members | System.Reflection Namespace


AssemblyTitleAttribute Members

Public:

Constructor

AssemblyTitleAttribute Constructor [To be supplied.]

Properties

Title [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyTitleAttribute Class | System.Reflection Namespace


AssemblyTitleAttribute Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal title As String _
)
[C#]
public AssemblyTitleAttribute(
   string title
);
[C++]
public: AssemblyTitleAttribute(
   String* title
);
[JScript]
public function AssemblyTitleAttribute(
   title : String
);

Parameters

title
[To be supplied.]

See Also

AssemblyTitleAttribute Class | AssemblyTitleAttribute Members | System.Reflection Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AssemblyTitleAttribute Properties

The properties of the AssemblyTitleAttribute class are listed below. For a complete list of AssemblyTitleAttribute class members, see the AssemblyTitleAttribute Members topic.

Public:

Title [To be supplied.]

See Also

AssemblyTitleAttribute Class | System.Reflection Namespace


AssemblyTitleAttribute.Title

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Title As String
[C#]
public string Title {get;}
[C++]
public: __property String* get_Title();
[JScript]
public function get Title() : String;

See Also

AssemblyTitleAttribute Class | AssemblyTitleAttribute Members | System.Reflection Namespace


AssemblyTrademarkAttribute Class

[To be supplied.]

Object
Attribute
AssemblyTrademarkAttribute

[Visual Basic]
Public Class AssemblyTrademarkAttribute
   Inherits Attribute
[C#]
public class AssemblyTrademarkAttribute : Attribute
[C++]
public __gc class AssemblyTrademarkAttribute : public Attribute
[JScript]
public class AssemblyTrademarkAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

AssemblyTrademarkAttribute Members | System.Reflection Namespace


AssemblyTrademarkAttribute Members

Public:

Constructor

AssemblyTrademarkAttribute Constructor [To be supplied.]

Properties

Trademark [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyTrademarkAttribute Class | System.Reflection Namespace


AssemblyTrademarkAttribute Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal trademark As String _
)
[C#]
public AssemblyTrademarkAttribute(
   string trademark
);
[C++]
public: AssemblyTrademarkAttribute(
   String* trademark
);
[JScript]
public function AssemblyTrademarkAttribute(
   trademark : String
);

Parameters

trademark
[To be supplied.]

See Also

AssemblyTrademarkAttribute Class | AssemblyTrademarkAttribute Members | System.Reflection Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AssemblyTrademarkAttribute Properties

The properties of the AssemblyTrademarkAttribute class are listed below. For a complete list of AssemblyTrademarkAttribute class members, see the AssemblyTrademarkAttribute Members topic.

Public:

Trademark [To be supplied.]

See Also

AssemblyTrademarkAttribute Class | System.Reflection Namespace


AssemblyTrademarkAttribute.Trademark

[To be supplied.]

[Visual Basic]
Public ReadOnly Property Trademark As String
[C#]
public string Trademark {get;}
[C++]
public: __property String* get_Trademark();
[JScript]
public function get Trademark() : String;

See Also

AssemblyTrademarkAttribute Class | AssemblyTrademarkAttribute Members | System.Reflection Namespace


Binder Class

Defines a set of methods that interact with reflection during the binding process. This control allows systems to apply language specific semantics to the binding and invocation process.

Object
Binder

[Visual Basic]
MustInherit Public Class Binder
[C#]
public abstract class Binder
[C++]
public __gc __abstract class Binder
[JScript]
public abstract class Binder

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

Binder Members | System.Reflection Namespace


Binder Members

Public:

Constructor

Binder Constructor [To be supplied.]

Methods

BindToField | When implemented by a subclass, this method selects a field from the given set of fields, based on the specified criteria.
BindToMethod | When implemented by a subclass, this method selects a method to invoke from the given set of methods, based on the specified criteria.
ChangeType | When implemented by a subclass, this method changes the type of the given Variant to the given Type.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SelectMethod | When implemented by a subclass, this method selects a method from the given set of methods, based on the specified criteria.
SelectProperty | When implemented by a subclass, this method selects a property from the given set of properties, based on the specified criteria.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Binder Class | System.Reflection Namespace


Binder Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public Binder();
[C++]
public: Binder();
[JScript]
public function Binder();

See Also

Binder Class | Binder Members | System.Reflection Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Binder Methods

The methods of the Binder class are listed below. For a complete list of Binder class members, see the Binder Members topic.

Public:

BindToField | When implemented by a subclass, this method selects a field from the given set of fields, based on the specified criteria.
BindToMethod | When implemented by a subclass, this method selects a method to invoke from the given set of methods, based on the specified criteria.
ChangeType | When implemented by a subclass, this method changes the type of the given Variant to the given Type.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SelectMethod | When implemented by a subclass, this method selects a method from the given set of methods, based on the specified criteria.
SelectProperty | When implemented by a subclass, this method selects a property from the given set of properties, based on the specified criteria.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Binder Class | System.Reflection Namespace


Binder.BindToField

When implemented by a subclass, this method selects a field from the given set of fields, based on the specified criteria.

[Visual Basic]
MustOverride Public Function BindToField( _
   ByVal bindingAttr As BindingFlags, _
   ByVal match() As FieldInfo, _
   ByVal value As Object, _
   ByVal culture As CultureInfo _
) As FieldInfo
[C#]
public abstract FieldInfo BindToField(
   BindingFlags bindingAttr,
   FieldInfo[] match,
   object value,
   CultureInfo culture
);
[C++]
public: virtual FieldInfo* BindToField(
   BindingFlags bindingAttr,
   FieldInfo* match[],
   Object* value,
   CultureInfo* culture
) = 0;
[JScript]
public abstract function BindToField(
   bindingAttr : BindingFlags,
   match : FieldInfo[],
   value : Object,
   culture : CultureInfo
) : FieldInfo;

Parameters

bindingAttr
[To be supplied.]
match
The set of fields to locate a matching field.
value
The field value used to locate a matching field.
culture
An instance of CultureInfo used to control the coercion of data types.'> If this is null, the CultureInfo for the current thread is used. (Note that this is necessary to, for example, convert a String that represents 1000 to a Double value, since 1000 is represented differently by different cultures.) Not Yet Implemented

Return Value

Returns a FieldInfo object containing the matching field.

Remarks

This method controls the binding provided by Type.InvokeMember().

See Also

Binder Class | Binder Members | System.Reflection Namespace | FieldInfo


Binder.BindToMethod

When implemented by a subclass, this method selects a method to invoke from the given set of methods, based on the specified criteria.

[Visual Basic]
MustOverride Public Function BindToMethod( _
   ByVal bindingAttr As BindingFlags, _
   ByVal match() As MethodBase, _
   ByRef args() As Object, _
   ByVal modifiers() As ParameterModifier, _
   ByVal culture As CultureInfo, _
   ByVal names() As String _
) As MethodBase
[C#]
public abstract MethodBase BindToMethod(
   BindingFlags bindingAttr,
   MethodBase[] match,
   ref object[] args,
   ParameterModifier[] modifiers,
   CultureInfo culture,
   string[] names
);
[C++]
public: virtual MethodBase* BindToMethod(
   BindingFlags bindingAttr,
   MethodBase* match[],
   Object** args[],
   ParameterModifier* modifiers[],
   CultureInfo* culture,
   String* names[]
) = 0;
[JScript]
public abstract function BindToMethod(
   bindingAttr : BindingFlags,
   match : MethodBase[],
   args : Object[],
   modifiers : ParameterModifier[],
   culture : CultureInfo,
   names : String[]
) : MethodBase;

Parameters

bindingAttr
[To be supplied.]
match
[To be supplied.]
args
[To be supplied.]
modifiers
[To be supplied.]
culture
An instance of CultureInfo used to control the coercion of data types.'> If this is null, the CultureInfo for the current thread is used. (Note that this is necessary to, for example, convert a String that represents 1000 to a Double value, since 1000 is represented differently by different cultures.) Not Yet Implemented
names
[To be supplied.]

Return Value

Returns a MethodBase object containing the matching method.

Remarks

[To be supplied.]

See Also

Binder Class | Binder Members | System.Reflection Namespace | MethodBase


Binder.ChangeType

When implemented by a subclass, this method changes the type of the given Variant to the given Type.

[Visual Basic]
MustOverride Public Function ChangeType( _
   ByVal value As Object, _
   ByVal type As Type, _
   ByVal culture As CultureInfo _
) As Object
[C#]
public abstract object ChangeType(
   object value,
   Type type,
   CultureInfo culture
);
[C++]
public: virtual Object* ChangeType(
   Object* value,
   Type* type,
   CultureInfo* culture
) = 0;
[JScript]
public abstract function ChangeType(
   value : Object,
   type : Type,
   culture : CultureInfo
) : Object;

Parameters

value
The value to change into a new Type.
type
The new Type that value will become.
culture
An instance of CultureInfo used to control the coercion of data types.'> If this is null, the CultureInfo for the current thread is used. (Note that this is necessary to, for example, convert a String that represents 1000 to a Double value, since 1000 is represented differently by different cultures.) Not Yet Implemented

Return Value

Returns a Variant object containing the given value as the new type.

Remarks

[To be supplied.]

See Also

Binder Class | Binder Members | System.Reflection Namespace


Binder.SelectMethod

When implemented by a subclass, this method selects a method from the given set of methods, based on the specified criteria.

[Visual Basic]
MustOverride Public Function SelectMethod( _
   ByVal bindingAttr As BindingFlags, _
   ByVal match() As MethodBase, _
   ByVal types() As Type, _
   ByVal modifiers() As ParameterModifier _
) As MethodBase
[C#]
public abstract MethodBase SelectMethod(
   BindingFlags bindingAttr,
   MethodBase[] match,
   Type[] types,
   ParameterModifier[] modifiers
);
[C++]
public: virtual MethodBase* SelectMethod(
   BindingFlags bindingAttr,
   MethodBase* match[],
   Type* types[],
   ParameterModifier* modifiers[]
) = 0;
[JScript]
public abstract function SelectMethod(
   bindingAttr : BindingFlags,
   match : MethodBase[],
   types : Type[],
   modifiers : ParameterModifier[]
) : MethodBase;

Parameters

bindingAttr
[To be supplied.]
match
The set of fields to locate a matching field.
types
The field value used to locate a matching field.
modifiers
[To be supplied.]

Return Value

Value | Condition
A MethodBase object containing the matching method. | A method matches the given criteria.
Null | Otherwise.

Remarks

This method should return null if no method matches the criteria. This method controls the selection provided by the GetConstructor and GetMethod methods on Type.

See Also

Binder Class | Binder Members | System.Reflection Namespace


Binder.SelectProperty

When implemented by a subclass, this method selects a property from the given set of properties, based on the specified criteria.

[Visual Basic]
MustOverride Public Function SelectProperty( _
   ByVal bindingAttr As BindingFlags, _
   ByVal match() As PropertyInfo, _
   ByVal returnType As Type, _
   ByVal indexes() As Type, _
   ByVal modifiers() As ParameterModifier _
) As PropertyInfo
[C#]
public abstract PropertyInfo SelectProperty(
   BindingFlags bindingAttr,
   PropertyInfo[] match,
   Type returnType,
   Type[] indexes,
   ParameterModifier[] modifiers
);
[C++]
public: virtual PropertyInfo* SelectProperty(
   BindingFlags bindingAttr,
   PropertyInfo* match[],
   Type* returnType,
   Type* indexes[],
   ParameterModifier* modifiers[]
) = 0;
[JScript]
public abstract function SelectProperty(
   bindingAttr : BindingFlags,
   match : PropertyInfo[],
   returnType : Type,
   indexes : Type[],
   modifiers : ParameterModifier[]
) : PropertyInfo;

Parameters

bindingAttr
[To be supplied.]
match
The set of properties to locate a matching property.
returnType
The return value the matching property must have.
indexes
[To be supplied.]
modifiers
[To be supplied.]

Return Value

Returns a PropertyInfo object containing the matching property.

Remarks

This method controls the selection provided by the GetProperty method on Type.

See Also

Binder Class | Binder Members | System.Reflection Namespace | PropertyInfo


BindingFlags Enumeration

Comprises flags that control binding and the way in which the search for members and types is conducted using Reflection.

[Visual Basic]
Public Enum BindingFlags
[C#]
public enum BindingFlags
[C++]
public enum BindingFlags

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

BindingFlags provides enumerators for a great many classes in the System, System.Reflection, and System.Runtime namespaces that invoke, create, get, set, and find members and types.

BindingFlags are used in the following Type methods and other places such as Invoke:

  • InvokeMember
  • CreateInstance
  • GetConstructor
  • GetConstructors
  • GetMethod
  • GetMethods
  • GetField
  • GetFields
  • GetEvent
  • GetProperty
  • GetProperties
  • GetMember
  • FindMembers

InvokeMember, GetMethod, and Invoke are especially important.

InvokeMember and GetMethod find methods by using the DefaultBinding, ExactBinding, BinderBinding, and DefaultValueBinding flags.

Invoke methods change types to match the target signature. These use the DefaultChangeType, ExactChangeType, BinderChangeType, and DefaultValueChangeType enumerators. The Default enumerator aggregates the DefaultBinding, DefaultChangeType, and DefaultLookup flags. For more control, specify the proper combination. This means if you provide a binder you must specify both BinderChangeType and BinderBinding.

Filter and modifier flags are used for searching. Filter flags (Instance, Static, Public, and NonPublic) as used by the Lookup enumerators are bit flags indicating that members of that type should be included in the search.

Modifier flags are either on or off, and change how the search works. The modifier flags are IgnoreCase and DeclaredOnly.

Three aggregate enumerators indicate normal use of the binding flags: DefaultLookup, LookupAll, and Default. Use Default or DefaultLookup in searches. The Default flag aggregates the DefaultBinding, DefaultChangeType, and DefaultLookup flags. Default is the normal flag used by InvokeMember. Use LookupAll in places where BindingFlags.NonPublic was used.

Arguments to InvokeMember and CreateInstance don't require specifying the lookup bits. Type.InvokeMember uses DefaultLookup and CreateInstance uses Public or Instance.

Members

Member Name | Description
BinderBinding | Specifies that change type will be handled by the binder. A binder must be provided. BinderBinding may not be combined with ExactBinding or DefaultBinding.
BinderChangeType | Specifies that change type will be handled by the binder. A binder must be provided. BinderChangeType may not be combined with ExactChangeType or DefaultChangeType.
BinderFull | Combines BinderBinding and BinderChangeType.
CallNonVirt | Specifies that the Invoke is not to be virtualized.
ConstructorDefault | [To be supplied.]
ConstructorLookupAll | [To be supplied.]
CreateInstance | Specifies that an instance of the type is to be created. Calls the constructor that matches the given arguments. Not valid with any other InvokeMember enumerator. The member name is ignored.
DeclaredOnly | Specifies that only members declared at this level of the type hierarchy, and not inherited method, should be considered.
Default | Specifies that the default binding rules are used. DefaultBinding may not be combined with ExactBinding or BinderBinding. DefaultChangeType may not be combined with ExactChangeType or BinderChangeType. The default binder does not follow any particular language's binding rules, rather relying on each language to provide its own binding.
DefaultBinding | Specifies that the system default binding rules should be used. DefaultBinding may not be combined with ExactBinding or BinderBinding.
DefaultChangeType | Specifies that the default change type rules are to be used. DefaultChangeType may not be combined with ExactChangeType or BinderChangeType.
DefaultLookup | Aggregates three bit flags to indicate that members of that type should be included in the search. Arguments to InvokeMember and CreateInstance don't require specifying the lookup bits. System.Type.InvokeMember uses DefaultLookup and System.Activator.CreateInstance uses the Public or Instance flag.
DefaultValueBinding | Returns the set of methods that have a specified number of parameters. This is used for default values, varargs, and so on. DefaultValueBinding may be combined with other binding options.
DefaultValueChangeType | Returns the set of methods of the specified type. This is used for default values, varargs, and so on. DefaultValueChangeType may be combined with other binding options.
DefaultValueFull | Combines DefaultValueBinding and DefaultValueChangeType.
ExactBinding | Specifies that exact data type matching is to be done. ExactBinding may not be combined with BinderBinding or DefaultBinding.
ExactChangeType | Specifies that no change of type is to be done; the types of the actual arguments must match exactly with the types of the formal arguments. ExactChangeType may not be combined with BinderChangeType or DefaultChangeType.
ExactFull | Combines ExactBinding and ExactChangeType.
FlattenHierarchy | Specifies that static members are to be rolled up into the class.
GetField | Specifies that the value of the specified field should be returned.
GetProperty | Specifies that the value of the specified property should be returned.
IgnoreCase | Specifies that the case of the member name is not to be considered.
IgnoreReturn | Used in COM Interop.
Instance | Specifies that instance members are to be included in the search.
InvokeMethod | Specifies that a method is to be invoked. This may be not be the constructor or type initializer.
LookupAll | Aggregate enumerator indicating normal use of the binding flags. Use LookupAll in places where NonPublic was used.
NonPublic | Specifies that non-public members are to be included in the search.
Public | Specifies that public members are to be included in the search.
PutDispProperty | [To be supplied.]
PutRefDispProperty | [To be supplied.]
SetField | Specifies that the value of the specified field should be set.
SetProperty | Specifies that the value of the specified property should be set.
Static | Specifies that static members are to be included in the search.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

System.Reflection Namespace


CallingConventions Enumeration

Defines the valid calling conventions for an enumeration.

[Visual Basic]
Public Enum CallingConventions
[C#]
public enum CallingConventions
[C++]
public enum CallingConventions

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

The "native calling convention" is the set of rules governing the order and layout of arguments passed to compiled methods. It also governs how the return value is passed, what registers are used for arguments and who cleans up the stack.

Members

Member Name | Description
Any | [To be supplied.]
ExplicitThis | [To be supplied.]
HasThis | [To be supplied.]
Standard | [To be supplied.]
VarArgs | [To be supplied.]

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

System.Reflection Namespace


ConstructorInfo Class

Retrieves the name of the class constructor method as it is stored in metadata. This name is always ".ctor"

Object
MemberInfo
MethodBase
ConstructorInfo

[Visual Basic]
MustInherit Public Class ConstructorInfo
   Inherits MethodBase
[C#]
public abstract class ConstructorInfo : MethodBase
[C++]
public __gc __abstract class ConstructorInfo : public MethodBase
[JScript]
public abstract class ConstructorInfo extends MethodBase

Remarks

ConstructorInfo is used to discover the attributes of a constructor as well as to invoke a constructor. ConstructorInfo is an abstract class and does not have a public constructor. Objects are created by invoking either the GetConstructors() or GetConstructor() method of a Type object.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

ConstructorInfo Members | System.Reflection Namespace


ConstructorInfo Members

Public:

Properties

Attributes (inherited from MethodBase) | Retrieves the attributes for this method.
CallingConvention (inherited from MethodBase) | Retrieves the calling conventions for this method.
DeclaringType (inherited from MemberInfo) | Retrieves the class that declares this member.
IsAbstract (inherited from MethodBase) | Retrieves whether this is an abstract method.
IsAssembly (inherited from MethodBase) | Retrieves whether this is an abstract method.
IsConstructor (inherited from MethodBase) | If set, the method is a constructor.
IsFamily (inherited from MethodBase) | If set, this method can be called by all subclasses, wherever they are, but not by unrelated classes.
IsFamilyAndAssembly (inherited from MethodBase) | If set, this method can be called by subclasses if they are in the same assembly.
IsFamilyOrAssembly (inherited from MethodBase) | If set, this method can be called by subclasses, wherever they are, and by all classes in the same assembly.
IsFinal (inherited from MethodBase) | If set, this method cannot be overridden by a subclass.
IsHideBySig (inherited from MethodBase) | [To be supplied.]
IsPrivate (inherited from MethodBase) | If set, this method can be called only by other members of the class itself.
IsPublic (inherited from MethodBase) | Retrieves whether this is a public method.
IsSpecialName (inherited from MethodBase) | If set, this method has a special name.
IsStatic (inherited from MethodBase) | If set, the method is static.
IsVirtual (inherited from MethodBase) | Retrieves a value indicating whether the method is virtual.
MemberType | Specifies the type of this member this instance reflects.
MethodHandle (inherited from MethodBase) | [To be supplied].
Name (inherited from MemberInfo) | Retrieves the name of this member.
ReflectedType (inherited from MemberInfo) | Retrieves the class object that was used to obtain this instance of MemberInfo.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCustomAttributes (inherited from MemberInfo) | Overloaded. Returns all attributes defined on this member.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetMethodImplementationFlags (inherited from MethodBase) | [To be supplied.]
GetParameters (inherited from MethodBase) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
Invoke | Overloaded. Invokes the constructor reflected by this instance.
IsDefined (inherited from MemberInfo) | Returns a Boolean if one or more instance of attributeType is defined on this member.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

ConstructorName | Retrieves the name of the class constructor method as it is stored in metadata. This name is always ".ctor"
TypeConstructorName | Retrieves the name of the type constructor method as it is stored in metadata. This name is always ".cctor"

Protected:

Constructor

ConstructorInfo Constructor Initializes a new instance of the ConstructorInfo class.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConstructorInfo Class | System.Reflection Namespace


ConstructorInfo Constructor

Initializes a new instance of the ConstructorInfo class.

[Visual Basic]
Protected Sub New()
[C#]
protected ConstructorInfo();
[C++]
protected: ConstructorInfo();
[JScript]
protected function ConstructorInfo();

See Also

ConstructorInfo Class | ConstructorInfo Members | System.Reflection Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ConstructorInfo Properties

The properties of the ConstructorInfo class are listed below. For a complete list of ConstructorInfo class members, see the ConstructorInfo Members topic.

Public:

Attributes (inherited from MethodBase) | Retrieves the attributes for this method.
CallingConvention (inherited from MethodBase) | Retrieves the calling conventions for this method.
DeclaringType (inherited from MemberInfo) | Retrieves the class that declares this member.
IsAbstract (inherited from MethodBase) | Retrieves whether this is an abstract method.
IsAssembly (inherited from MethodBase) | Retrieves whether this is an abstract method.
IsConstructor (inherited from MethodBase) | If set, the method is a constructor.
IsFamily (inherited from MethodBase) | If set, this method can be called by all subclasses, wherever they are, but not by unrelated classes.
IsFamilyAndAssembly (inherited from MethodBase) | If set, this method can be called by subclasses if they are in the same assembly.
IsFamilyOrAssembly (inherited from MethodBase) | If set, this method can be called by subclasses, wherever they are, and by all classes in the same assembly.
IsFinal (inherited from MethodBase) | If set, this method cannot be overridden by a subclass.
IsHideBySig (inherited from MethodBase) | [To be supplied.]
IsPrivate (inherited from MethodBase) | If set, this method can be called only by other members of the class itself.
IsPublic (inherited from MethodBase) | Retrieves whether this is a public method.
IsSpecialName (inherited from MethodBase) | If set, this method has a special name.
IsStatic (inherited from MethodBase) | If set, the method is static.
IsVirtual (inherited from MethodBase) | Retrieves a value indicating whether the method is virtual.
MemberType | Specifies the type of this member this instance reflects.
MethodHandle (inherited from MethodBase) | [To be supplied].
Name (inherited from MemberInfo) | Retrieves the name of this member.
ReflectedType (inherited from MemberInfo) | Retrieves the class object that was used to obtain this instance of MemberInfo.

See Also

ConstructorInfo Class | System.Reflection Namespace


ConstructorInfo.MemberType

Specifies the type of this member this instance reflects.

[Visual Basic]
Overridable Public ReadOnly Property MemberType As MemberTypes
[C#]
public MemberTypes MemberType {override get;}
[C++]
public: __property virtual MemberTypes get_MemberType();
[JScript]
public function get MemberType() : MemberTypes;

Property Value

Read-only. This property takes its value from the MemberTypes class.

See Also

ConstructorInfo Class | ConstructorInfo Members | System.Reflection Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ConstructorInfo Methods

The methods of the ConstructorInfo class are listed below. For a complete list of ConstructorInfo class members, see the ConstructorInfo Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCustomAttributes (inherited from MemberInfo) | Overloaded. Returns all attributes defined on this member.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetMethodImplementationFlags (inherited from MethodBase) | [To be supplied.]
GetParameters (inherited from MethodBase) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
Invoke | Overloaded. Invokes the constructor reflected by this instance.
IsDefined (inherited from MemberInfo) | Returns a Boolean if one or more instance of attributeType is defined on this member.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConstructorInfo Class | System.Reflection Namespace


ConstructorInfo.Invoke

Invokes the constructor reflected by this instance.

Overload List

When implemented by a subclass, this method invokes the constructor reflected by this ConstructorInfo with the specified arguments, under the constraints of the specified Binder.

[Visual Basic] Overloads MustOverride Public Function Invoke(BindingFlags, Binder, Object(), CultureInfo) As Object
[C#] public abstract object Invoke(BindingFlags, Binder, Object[], CultureInfo);
[C++] public: virtual Object* Invoke(BindingFlags, Binder, Object[], CultureInfo) = 0;
[JScript] public abstract function Invoke(BindingFlags, Binder, Object[], CultureInfo) : Object;

[To be supplied.]

[Visual Basic] Overloads Public Function Invoke(Object()) As Object
[C#] public object Invoke(Object[]);
[C++] public: Object* Invoke(Object*[]);
[JScript] public function Invoke(Object[]) : Object;

See Also

ConstructorInfo Class | ConstructorInfo Members | System.Reflection Namespace


ConstructorInfo.Invoke (BindingFlags, Binder, Object[], CultureInfo)

When implemented by a subclass, this method invokes the constructor reflected by this ConstructorInfo with the specified arguments, under the constraints of the specified Binder.

[Visual Basic]
Overloads MustOverride Public Function Invoke( _
   ByVal invokeAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal parameters() As Object, _
   ByVal culture As CultureInfo _
) As Object
[C#]
public abstract object Invoke(
   BindingFlags invokeAttr,
   Binder binder,
   object[] parameters,
   CultureInfo culture
);
[C++]
public: virtual Object* Invoke(
   BindingFlags invokeAttr,
   Binder* binder,
   Object* parameters[],
   CultureInfo* culture
) = 0;
[JScript]
public abstract function Invoke(
   invokeAttr : BindingFlags,
   binder : Binder,
   parameters : Object[],
   culture : CultureInfo
) : Object;

Parameters

invokeAttr
This value is a field of BindingFlags that specifies the type of binding that is desired (e.g., BindingFlags.CreateInstance, BindingFlags.ExactBinding).
binder
[To be supplied.]
parameters
[To be supplied.]
culture
[To be supplied.]

Exceptions

Exception Type | Condition
AccessException | The attempt to access the constructor fails (e.g., the class may be abstract) or the method is a class initializer.The InnerException property of the TargetInvocationException will hold the exception thrown by the constructor.
ArgumentException | The parameters array does not contain values that match the number, order and type of the parameters accepted by this constructor, under the constraints of the binder.
TargetInvocationException | The invoked constructor throws an exception. The InnerException property of the TargetInvocationException will hold the exception thrown by the constructor.

Remarks

The number, type, and order of elements in the parameters array should be identical to the number, type, and order of parameters for the constructor reflected by this instance.

Before calling the constructor, Invoke will check to see if the caller has access permission and verify that the parameters are of the correct number, order and type.

Access restrictions are ignored for fully trusted code. That is, private constructors, methods, fields, and properties can be accessed and invoked via Reflection whenever the code is fully trusted

See Also

ConstructorInfo Class | ConstructorInfo Members | System.Reflection Namespace | ConstructorInfo.Invoke Overload List | Binder | BindingFlags


ConstructorInfo.Invoke (Object[])

[To be supplied.]

[Visual Basic]
Overloads Public Function Invoke( _
   ByVal parameters() As Object _
) As Object
[C#]
public object Invoke(
   object[] parameters
);
[C++]
public: Object* Invoke(
   Object* parameters[]
);
[JScript]
public function Invoke(
   parameters : Object[]
) : Object;

Parameters

parameters
An array of values that matches the number, order and type (under the constraints of the default binder) of the parameters for this constructor. If this constructor takes no parameters then either an array with 0 elements or a null reference should be used (e.g., Variant[] parameters = new Variant[0];). If the parameters contain an uninitialized variant, it is treated a Variant.Empty, which, with the default binder, can be widened to 0, 0.0 or String.

Return Value

Returns an instance of the class associated with the constructor.

Exceptions

Exception Type | Condition
AccessException | The attempt to access the constructor fails (e.g., the class may be abstract) or the method is a class initializer.
ArgumentException | The parameters array does not contain values that match the number, type, and order of the parameters accepted by this constructor.
TargetInvocationException | The constructor being invoked throws an exception. The InnerException property of the TargetInvocationException will hold the exception thrown by the constructor.

Remarks

The number, type, and order of elements in the parameters array should be identical to the number, type, and order of parameters for the constructor reflected by this instance. Before calling the constructor, Invoke will check to see if the caller has access permission and verify that the parameters are legal.

Access restrictions are ignored for fully trusted code. That is, private constructors, methods, fields, and properties can be accessed and invoked via Reflection whenever the code is fully trusted.

This method is a convenience method for the following overloaded version, using default values. This method cannot be overridden.

See Also

ConstructorInfo Class | ConstructorInfo Members | System.Reflection Namespace | ConstructorInfo.Invoke Overload List


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ConstructorInfo Fields

The fields of the ConstructorInfo class are listed below. For a complete list of ConstructorInfo class members, see the ConstructorInfo Members topic.

Public:

ConstructorName | Retrieves the name of the class constructor method as it is stored in metadata. This name is always ".ctor"
TypeConstructorName | Retrieves the name of the type constructor method as it is stored in metadata. This name is always ".cctor"

See Also

ConstructorInfo Class | System.Reflection Namespace


ConstructorInfo.ConstructorName

Retrieves the name of the class constructor method as it is stored in metadata. This name is always ".ctor"

[Visual Basic]
Public Shared ReadOnly ConstructorName As String
[C#]
public static readonly string ConstructorName;
[C++]
public: static readonly String* ConstructorName;
[JScript]
public static var ConstructorName : String;

See Also

ConstructorInfo Class | ConstructorInfo Members | System.Reflection Namespace


ConstructorInfo.TypeConstructorName

Retrieves the name of the type constructor method as it is stored in metadata. This name is always ".cctor"

[Visual Basic]
Public Shared ReadOnly TypeConstructorName As String
[C#]
public static readonly string TypeConstructorName;
[C++]
public: static readonly String* TypeConstructorName;
[JScript]
public static var TypeConstructorName : String;

See Also

ConstructorInfo Class | ConstructorInfo Members | System.Reflection Namespace


CustomAttributeFormatException Class

Represents an exception that is thrown when the binary format of a custom attribute is invalid.

Object
Exception
SystemException
FormatException
CustomAttributeFormatException

[Visual Basic]
Public Class CustomAttributeFormatException
   Inherits FormatException
[C#]
public class CustomAttributeFormatException : FormatException
[C++]
public __gc class CustomAttributeFormatException : public
   FormatException
[JScript]
public class CustomAttributeFormatException extends FormatException

Remarks

CustomAttributeFormatException is thrown because a custom attribute on a data type was formatted incorrectly, possibly because of a bug in the tool used to create the data type.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

CustomAttributeFormatException Members | System.Reflection Namespace | Exception | FormatException


CustomAttributeFormatException Members

Public:

Constructor

CustomAttributeFormatException Constructor Overloaded. Initializes an instance of the CustomAttributeFormatException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

CustomAttributeFormatException Class | System.Reflection Namespace


CustomAttributeFormatException Constructor

Initializes an instance of the CustomAttributeFormatException class.

Overload List

Initializes an instance of the CustomAttributeFormatException class with the default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public CustomAttributeFormatException();
[C++] public: CustomAttributeFormatException();
[JScript] public function CustomAttributeFormatException();

Initializes an instance of the CustomAttributeFormatException class with the specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public CustomAttributeFormatException(String);
[C++] public: CustomAttributeFormatException(String*);
[JScript] public function CustomAttributeFormatException(String);

Initializes an instance of the CustomAttributeFormatException class with the given message and inner exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public CustomAttributeFormatException(String, Exception);
[C++] public: CustomAttributeFormatException(String*, Exception);
[JScript] public function CustomAttributeFormatException(String, Exception);

See Also

CustomAttributeFormatException Class | CustomAttributeFormatException Members | System.Reflection Namespace


CustomAttributeFormatException Constructor ()

Initializes an instance of the CustomAttributeFormatException class with the default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CustomAttributeFormatException();
[C++]
public: CustomAttributeFormatException();
[JScript]
public function CustomAttributeFormatException();

Remarks

CustomAttributeFormatExcdption initializes an instance of the CustomAttributeFormatException with an empty message string and the root cause exception set to null.

CustomAttributeFormatException inherits from Exception. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | null
Message | The empty string ("").

See Also

CustomAttributeFormatException Class | CustomAttributeFormatException Members | System.Reflection Namespace | CustomAttributeFormatException Constructor Overload List


CustomAttributeFormatException Constructor (String)

Initializes an instance of the CustomAttributeFormatException class with the specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public CustomAttributeFormatException(
   string message
);
[C++]
public: CustomAttributeFormatException(
   String* message
);
[JScript]
public function CustomAttributeFormatException(
   message : String
);

Parameters

message
The message that indicates the reason this exception was thrown.

Remarks

CustomAttributeFormatException inherits from Exception. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | The inner exception.
Message | The message string

See Also

CustomAttributeFormatException Class | CustomAttributeFormatException Members | System.Reflection Namespace | CustomAttributeFormatException Constructor Overload List | Exception | FormatException


CustomAttributeFormatException Constructor (String, Exception)

Initializes an instance of the CustomAttributeFormatException class with the given message and inner exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public CustomAttributeFormatException(
   string message,
   Exception inner
);
[C++]
public: CustomAttributeFormatException(
   String* message,
   Exception* inner
);
[JScript]
public function CustomAttributeFormatException(
   message : String,
   inner : Exception
);

Parameters

message
The message that indicates the reason this exception was thrown.
inner
The exception, which is the root cause of this exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.) CutomAttributeFormatException inherits from Exception. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | The inner exception.
Message | The message string.

See Also

CustomAttributeFormatException Class | CustomAttributeFormatException Members | System.Reflection Namespace | CustomAttributeFormatException Constructor Overload List


DefaultMemberAttribute Class

Defines the member of a type that is the default member used by InvokeMember. The default member is a name given to a type.

Object
Attribute
DefaultMemberAttribute

[Visual Basic]
Public Class DefaultMemberAttribute
   Inherits Attribute
[C#]
public class DefaultMemberAttribute : Attribute
[C++]
public __gc class DefaultMemberAttribute : public Attribute
[JScript]
public class DefaultMemberAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

DefaultMemberAttribute Members | System.Reflection Namespace


DefaultMemberAttribute Members

Public:

Constructor

DefaultMemberAttribute Constructor Initializes a new DefaultMemberAttribute.

Properties

MemberName Gets the name from the attribute.

There is no set accessor because the name must be provided to the constructor. The name is not optional.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefaultMemberAttribute Class | System.Reflection Namespace


DefaultMemberAttribute Constructor

Initializes a new DefaultMemberAttribute.

[Visual Basic]
Public Sub New( _
   ByVal memberName As String _
)
[C#]
public DefaultMemberAttribute(
   string memberName
);
[C++]
public: DefaultMemberAttribute(
   String* memberName
);
[JScript]
public function DefaultMemberAttribute(
   memberName : String
);

Parameters

memberName
The name of the member to invoke. This may be a constructor, method, property, or field. A suitable invocation attribute must be specified. Note that it is possible to invoke the default member of a class by passing an empty string as the name of the member.

The default member of a type is marked with the DefaultMemberAttribute custom attribute or marked in COM in the usual way.

See Also

DefaultMemberAttribute Class | DefaultMemberAttribute Members | System.Reflection Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DefaultMemberAttribute Properties

The properties of the DefaultMemberAttribute class are listed below. For a complete list of DefaultMemberAttribute class members, see the DefaultMemberAttribute Members topic.

Public:

MemberName Gets the name from the attribute.

There is no set accessor because the name must be provided to the constructor. The name is not optional.

See Also

DefaultMemberAttribute Class | System.Reflection Namespace


DefaultMemberAttribute.MemberName

Gets the name from the attribute.

There is no set accessor because the name must be provided to the constructor. The name is not optional.

[Visual Basic]
Overridable Public ReadOnly Property MemberName As String
[C#]
public string MemberName {virtual get;}
[C++]
public: __property virtual String* get_MemberName();
[JScript]
public function get MemberName() : String;

Property Value

A string representing the member name.

See Also

DefaultMemberAttribute Class | DefaultMemberAttribute Members | System.Reflection Namespace


EventAttributes Enumeration

Defines the attributes of an event. EventAttributes values may be bitwise or'ed together to get the appropriate combination.

These are defined in corhdr.h and are a combination of bits and enumerators.

[Visual Basic]
Public Enum EventAttributes
[C#]
public enum EventAttributes
[C++]
public enum EventAttributes

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
None | [To be supplied.]
ReservedMask | [To be supplied.]
RTSpecialName | [To be supplied.]
SpecialName | [To be supplied.]

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

System.Reflection Namespace


EventInfo Class

Reflects an event.

Implementation of this class is not complete for this release of the NGWS SDK. This documentation is for information only.

Object
MemberInfo
EventInfo

[Visual Basic]
MustInherit Public Class EventInfo
   Inherits MemberInfo
[C#]
public abstract class EventInfo : MemberInfo
[C++]
public __gc __abstract class EventInfo : public MemberInfo
[JScript]
public abstract class EventInfo extends MemberInfo

Remarks

Events are used in conjunction with delegates. An event listener instantiates an event-handler delegate that is invoked whenever the event is raised by an event source. In order to connect to the event source, the event listener "adds" this delegate to the invocation list on the source. When the event is raised, the invoke method of the event-handler delegate is called. Both multicast and single-cast event notifications are supported. The "add" and "remove" methods, as well as the event-handler delegate class associated with an event must be marked in the metadata.

Delegates are object oriented function pointers. In C/C++, a function pointer is a reference to a method. In contrast to the C/C++ function pointer, a delegate contains two references: a reference to a method and a reference to an object that supports the method. An interesting property of delegates is that they can be used to invoke a method without knowing the class type that declares or inherits the method. Delegates need only know the return type and parameters list of the method.

The event model works equally well for single-cast and multicast delegates. When the delegate's invoke method is called, only a single object will have a method called on it. A multicast modifier can be applied to a delegate declaration which allows multiple methods to be called when the invoke method of the delegate is called.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

EventInfo Members | System.Reflection Namespace


EventInfo Members

Public:

Properties

Attributes | Retrieves the attributes for this event. Implementation of this member is not complete for this release of the NGWS SDK. This documentation is for information only.
DeclaringType (inherited from MemberInfo) | Retrieves the class that declares this member.
EventHandlerType | Retrieves the Type object of the underlying handler delegate. Implementation of this member is not complete for this release of the NGWS SDK. This documentation is for information only.
IsMulticast | Indicates whether the event is multicast. Implementation of this member is not complete for this release of the NGWS SDK. This documentation is for information only.
IsSpecialName | Indicates whether the EventInfo is the Special Name. Implementation of this member is not complete for this release of the NGWS SDK. This documentation is for information only.
MemberType | Retrieves the member type of this event. Implementation of this member is not complete for this release of the NGWS SDK. This documentation is for information only.
Name (inherited from MemberInfo) | Retrieves the name of this member.
ReflectedType (inherited from MemberInfo) | Retrieves the class object that was used to obtain this instance of MemberInfo.

Methods

AddEventHandler | Adds an event handler to an event source. Implementation of this member is not complete for this release of the NGWS SDK. This documentation is for information only.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetAddMethod | Overloaded. Retrieves the MethodInfo object for "add" methods of the event represented by this instance. Implementation of this member is not complete for this release of the NGWS SDK. This documentation is for information only.
GetCustomAttributes (inherited from MemberInfo) | Overloaded. Returns all attributes defined on this member.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRaiseMethod | Overloaded. Retrieves the MethodInfo object for "raising" a method of the event represented by this instance. Implementation of this member is not complete for this release of the NGWS SDK. This documentation is for information only.
GetRemoveMethod | Overloaded. Retrieves the MethodInfo object for "removing" a method of the event represented by this instance. Implementation of this member is not complete for this release of the NGWS SDK. This documentation is for information only.
GetType (inherited from Object) | Gets the Type of the Object.
IsDefined (inherited from MemberInfo) | Returns a Boolean if one or more instance of attributeType is defined on this member.
RemoveEventHandler | Removes an event handler from an event source. Implementation of this member is not complete for this release of the NGWS SDK. This documentation is for information only.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Constructor

EventInfo Constructor Initializes an instance of the EventInfo class with a given parameter count.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EventInfo Class | System.Reflection Namespace


EventInfo Constructor

Initializes an instance of the EventInfo class with a given parameter count.

[Visual Basic]
Protected Sub New()
[C#]
protected EventInfo();
[C++]
protected: EventInfo();
[JScript]
protected function EventInfo();

Remarks

This EventInfo constructor assigns an inital value to this instance of the EventInfo class with a given parameter count.

See Also

EventInfo Class | EventInfo Members | System.Reflection Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EventInfo Properties

The properties of the EventInfo class are listed below. For a complete list of EventInfo class members, see the EventInfo Members topic.

Public:

Attributes | Retrieves the attributes for this event. Implementation of this member is not complete for this release of the NGWS SDK. This documentation is for information only.
DeclaringType (inherited from MemberInfo) | Retrieves the class that declares this member.
EventHandlerType | Retrieves the Type object of the underlying handler delegate. Implementation of this member is not complete for this release of the NGWS SDK. This documentation is for information only.
IsMulticast | Indicates whether the event is multicast. Implementation of this member is not complete for this release of the NGWS SDK. This documentation is for information only.
IsSpecialName | Indicates whether the EventInfo is the Special Name. Implementation of this member is not complete for this release of the NGWS SDK. This documentation is for information only.
MemberType | Retrieves the member type of this event. Implementation of this member is not complete for this release of the NGWS SDK. This documentation is for information only.
Name (inherited from MemberInfo) | Retrieves the name of this member.
ReflectedType (inherited from MemberInfo) | Retrieves the class object that was used to obtain this instance of MemberInfo.

See Also

EventInfo Class | System.Reflection Namespace


EventInfo.Attributes

Retrieves the attributes for this event.

Implementation of this member is not complete for this release of the NGWS SDK. This documentation is for information only.

[Visual Basic]
MustOverride Public ReadOnly Property Attributes As EventAttributes
[C#]
public EventAttributes Attributes {abstract get;}
[C++]
public: __property virtual EventAttributes get_Attributes() = 0;
[JScript]
public abstract function get Attributes() : EventAttributes;

Property Value

The read-only attributes for this event.

Remarks

The attributes are returned in a 4-byte integer representing a bit map of the attributes set for the event reflected by this instance.

The EventAttributes property retrieves a number representing the bit map of the attributes set for the event reflected by this instance.

See Also

EventInfo Class | EventInfo Members | System.Reflection Namespace


EventInfo.EventHandlerType

Retrieves the Type object of the underlying handler delegate.

Implementation of this member is not complete for this release of the NGWS SDK. This documentation is for information only.

[Visual Basic]
Public ReadOnly Property EventHandlerType As Type
[C#]
public Type EventHandlerType {get;}
[C++]
public: __property Type* get_EventHandlerType();
[JScript]
public function get EventHandlerType() : Type;

Property Value

A read-only Type object.

Remarks

The EventHandlerType property retrieves the Type object that represents the event-handler delegate associated with this event. It returns the class representing the delegate event handler.

See Also

EventInfo Class | EventInfo Members | System.Reflection Namespace | Type | Delegate | EventHandler


EventInfo.IsMulticast

Indicates whether the event is multicast.

Implementation of this member is not complete for this release of the NGWS SDK. This documentation is for information only.

[Visual Basic]
Public ReadOnly Property IsMulticast As Boolean
[C#]
public bool IsMulticast {get;}
[C++]
public: __property bool get_IsMulticast();
[JScript]
public function get IsMulticast() : Boolean;

Property Value

true if the delegate returned by GetEventHandlerDelegate() is an instance of a multicast delegate; otherwise, false. Read-only.

See Also

EventInfo Class | EventInfo Members | System.Reflection Namespace | MulticastDelegate | Type | EventHandler


EventInfo.IsSpecialName

Indicates whether the EventInfo is the Special Name.

Implementation of this member is not complete for this release of the NGWS SDK. This documentation is for information only.

[Visual Basic]
Public ReadOnly Property IsSpecialName As Boolean
[C#]
public bool IsSpecialName {get;}
[C++]
public: __property bool get_IsSpecialName();
[JScript]
public function get IsSpecialName() : Boolean;

Property Value

true if this event is the Special name; otherwise, false. Read-only.

Remarks

The IsSpecialName property determines whether the event's Special Name has a special meaning.

See Also

EventInfo Class | EventInfo Members | System.Reflection Namespace | EventAttributes


EventInfo.MemberType

Retrieves the member type of this event.

Implementation of this member is not complete for this release of the NGWS SDK. This documentation is for information only.

[Visual Basic]
Overridable Public ReadOnly Property MemberType As MemberTypes
[C#]
public MemberTypes MemberType {override get;}
[C++]
public: __property virtual MemberTypes get_MemberType();
[JScript]
public function get MemberType() : MemberTypes;

Property Value

Retrieves Event.

Read-only.

Remarks

Overrides MemberType.

See Also

EventInfo Class | EventInfo Members | System.Reflection Namespace | Type


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EventInfo Methods

The methods of the EventInfo class are listed below. For a complete list of EventInfo class members, see the EventInfo Members topic.

Public:

AddEventHandler | Adds an event handler to an event source. Implementation of this member is not complete for this release of the NGWS SDK. This documentation is for information only.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetAddMethod | Overloaded. Retrieves the MethodInfo object for "add" methods of the event represented by this instance. Implementation of this member is not complete for this release of the NGWS SDK. This documentation is for information only.
GetCustomAttributes (inherited from MemberInfo) | Overloaded. Returns all attributes defined on this member.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRaiseMethod | Overloaded. Retrieves the MethodInfo object for "raising" a method of the event represented by this instance. Implementation of this member is not complete for this release of the NGWS SDK. This documentation is for information only.
GetRemoveMethod | Overloaded. Retrieves the MethodInfo object for "removing" a method of the event represented by this instance. Implementation of this member is not complete for this release of the NGWS SDK. This documentation is for information only.
GetType (inherited from Object) | Gets the Type of the Object.
IsDefined (inherited from MemberInfo) | Returns a Boolean if one or more instance of attributeType is defined on this member.
RemoveEventHandler | Removes an event handler from an event source. Implementation of this member is not complete for this release of the NGWS SDK. This documentation is for information only.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EventInfo Class | System.Reflection Namespace


EventInfo.AddEventHandler

Adds an event handler to an event source.

Implementation of this member is not complete for this release of the NGWS SDK. This documentation is for information only.

[Visual Basic]
Public Sub AddEventHandler( _
   ByVal target As Object, _
   ByVal handler As Delegate _
)
[C#]
public void AddEventHandler(
   object target,
   Delegate handler
);
[C++]
public: void AddEventHandler(
   Object* target,
   Delegate* handler
);
[JScript]
public function AddEventHandler(
   target : Object,
   handler : Delegate
);

Parameters

target
The event source.
handler
Encapsulates a method, or multiple methods, to be invoked when the event is raised by the target.

Exceptions

Exception Type | Condition
ArgumentException | target or handler is a null reference (in Visual Basic Nothing).
AccessException | The caller does not have permission to invoke the "add" method on the event source (e.g. It may be private.)
TargetInvocationException | The "add" method throws an exception.
ArgumentException | handler is not the same type as the event handler delegate used in conjunction with the event reflected by this instance.

Remarks

The AddEventHandler method will atttempt to add a delegate to sync the event on the the target object.Each time the event is raised by the target parameter, the method or methods encapsulated by the handler will be invoked.

See Also

EventInfo Class | EventInfo Members | System.Reflection Namespace | Object | Delegate | EventHandler


EventInfo.GetAddMethod

Retrieves the MethodInfo object for "add" methods of the event represented by this instance.

Implementation of this member is not complete for this release of the NGWS SDK. This documentation is for information only.

Overload List

Retrieves the MethodInfo object for "add" method of the event represented by this instance with the given parameter count and modifier bit map.

[Visual Basic] Overloads MustOverride Public Function GetAddMethod(Boolean) As MethodInfo
[C#] public abstract MethodInfo GetAddMethod(bool);
[C++] public: virtual MethodInfo* GetAddMethod(bool) = 0;
[JScript] public abstract function GetAddMethod(Boolean) : MethodInfo;

Retrieves the MethodInfo object for "add" method of the event represented by this instance with default properties.

[Visual Basic] Overloads Public Function GetAddMethod() As MethodInfo
[C#] public MethodInfo GetAddMethod();
[C++] public: MethodInfo* GetAddMethod();
[JScript] public function GetAddMethod() : MethodInfo;

Example

Typically, the method has hte following signature:

public void AddOn<EventName>(<EventHandlerType>hander)

See Also

EventInfo Class | EventInfo Members | System.Reflection Namespace


EventInfo.GetAddMethod (Boolean)

Retrieves the MethodInfo object for "add" method of the event represented by this instance with the given parameter count and modifier bit map.

[Visual Basic]
Overloads MustOverride Public Function GetAddMethod( _
   ByVal nonPublic As Boolean _
) As MethodInfo
[C#]
public abstract MethodInfo GetAddMethod(
   bool nonPublic
);
[C++]
public: virtual MethodInfo* GetAddMethod(
   bool nonPublic
) = 0;
[JScript]
public abstract function GetAddMethod(
   nonPublic : Boolean
) : MethodInfo;

Parameters

nonPublic
A Boolean value.

Return Value

Returns the event subscribe method as a Boolean.

Remarks

Read-only.

The GetAddMethod initializes and adds the event subscribe method as a Boolean. The "add" method is used to add an even-handler delegate to the invocation list of an event source.

Example

Typically, the method has hte following signature:

public void AddOn<EventName>(<EventHandlerType>hander)

See Also

EventInfo Class | EventInfo Members | System.Reflection Namespace | EventInfo.GetAddMethod Overload List | MethodInfo


EventInfo.GetAddMethod ()

Retrieves the MethodInfo object for "add" method of the event represented by this instance with default properties.

[Visual Basic]
Overloads Public Function GetAddMethod() As MethodInfo
[C#]
public MethodInfo GetAddMethod();
[C++]
public: MethodInfo* GetAddMethod();
[JScript]
public function GetAddMethod() : MethodInfo;

Return Value

Returns the event subscribe method.

Remarks

The GetAddMethod Initializes and adds the event subscribe method. The "add" method is used to add an even-handler delegate to the invocation list of an event source.

Example

Typically, the method has hte following signature:

public void AddOn<EventName>(<EventHandlerType>hander)

See Also

EventInfo Class | EventInfo Members | System.Reflection Namespace | EventInfo.GetAddMethod Overload List | MethodInfo


EventInfo.GetRaiseMethod

Retrieves the MethodInfo object for "raising" a method of the event represented by this instance.

Implementation of this member is not complete for this release of the NGWS SDK. This documentation is for information only.

Overload List

Retrieves the MethodInfo object for "raising" a method of the event represented by this instance with the given parameter count and modifier bit map.

[Visual Basic] Overloads MustOverride Public Function GetRaiseMethod(Boolean) As MethodInfo
[C#] public abstract MethodInfo GetRaiseMethod(bool);
[C++] public: virtual MethodInfo* GetRaiseMethod(bool) = 0;
[JScript] public abstract function GetRaiseMethod(Boolean) : MethodInfo;

Retrieves the MethodInfo object for "removing" a method of the event represented by this instance.

[Visual Basic] Overloads Public Function GetRaiseMethod() As MethodInfo
[C#] public MethodInfo GetRaiseMethod();
[C++] public: MethodInfo* GetRaiseMethod();
[JScript] public function GetRaiseMethod() : MethodInfo;

Example

Typically, the method has the following signature:public void AddOn<EventName>(<EventHandlerType>hander)

See Also

EventInfo Class | EventInfo Members | System.Reflection Namespace


EventInfo.GetRaiseMethod (Boolean)

Retrieves the MethodInfo object for "raising" a method of the event represented by this instance with the given parameter count and modifier bit map.

[Visual Basic]
Overloads MustOverride Public Function GetRaiseMethod( _
   ByVal nonPublic As Boolean _
) As MethodInfo
[C#]
public abstract MethodInfo GetRaiseMethod(
   bool nonPublic
);
[C++]
public: virtual MethodInfo* GetRaiseMethod(
   bool nonPublic
) = 0;
[JScript]
public abstract function GetRaiseMethod(
   nonPublic : Boolean
) : MethodInfo;

Parameters

nonPublic
A Boolean value.

Return Value

Retrieves a MethodInfo object that you call to unsubscribe to an event.

Remarks

Read-only.The GetRemoveMethod method will return the unsubscribed method as a Boolean.

Example

Typically, the method has the following signature:public void AddOn<EventName>(<EventHandlerType>hander)

See Also

EventInfo Class | EventInfo Members | System.Reflection Namespace | EventInfo.GetRaiseMethod Overload List | MethodInfo


EventInfo.GetRaiseMethod ()

Retrieves the MethodInfo object for "removing" a method of the event represented by this instance.

[Visual Basic]
Overloads Public Function GetRaiseMethod() As MethodInfo
[C#]
public MethodInfo GetRaiseMethod();
[C++]
public: MethodInfo* GetRaiseMethod();
[JScript]
public function GetRaiseMethod() : MethodInfo;

Return Value

Retrieves a MethodInfo object that you call to return the unsubscribe an event.

See Also

EventInfo Class | EventInfo Members | System.Reflection Namespace | EventInfo.GetRaiseMethod Overload List


EventInfo.GetRemoveMethod

Retrieves the MethodInfo object for "removing" a method of the event represented by this instance.

Implementation of this member is not complete for this release of the NGWS SDK. This documentation is for information only.

Overload List

Retrieves the MethodInfo object for "removing" a method of the event represented by this instance with the given parameter count and modifier bit map.

[Visual Basic] Overloads MustOverride Public Function GetRemoveMethod(Boolean) As MethodInfo
[C#] public abstract MethodInfo GetRemoveMethod(bool);
[C++] public: virtual MethodInfo* GetRemoveMethod(bool) = 0;
[JScript] public abstract function GetRemoveMethod(Boolean) : MethodInfo;

Retrieves the MethodInfo object for "removing" a method of the event represented by this instance with default properties.

[Visual Basic] Overloads Public Function GetRemoveMethod() As MethodInfo
[C#] public MethodInfo GetRemoveMethod();
[C++] public: MethodInfo* GetRemoveMethod();
[JScript] public function GetRemoveMethod() : MethodInfo;

Example

Typically, the method has the following signature:

public void AddOn<EventName>(<EventHandlerType>hander)

See Also

EventInfo Class | EventInfo Members | System.Reflection Namespace


EventInfo.GetRemoveMethod (Boolean)

Retrieves the MethodInfo object for "removing" a method of the event represented by this instance with the given parameter count and modifier bit map.

[Visual Basic]
Overloads MustOverride Public Function GetRemoveMethod( _
   ByVal nonPublic As Boolean _
) As MethodInfo
[C#]
public abstract MethodInfo GetRemoveMethod(
   bool nonPublic
);
[C++]
public: virtual MethodInfo* GetRemoveMethod(
   bool nonPublic
) = 0;
[JScript]
public abstract function GetRemoveMethod(
   nonPublic : Boolean
) : MethodInfo;

Parameters

nonPublic
A Boolean value.

Return Value

Retrieves a MethodInfo object that you call to unsubscribe to an event.

Remarks

Read-only.

The GetRemoveMethod method will return the unsubscribed method as a Boolean.

Example

Typically, the method has hte following signature:

public void AddOn<EventName>(<EventHandlerType>hander)

See Also

EventInfo Class | EventInfo Members | System.Reflection Namespace | EventInfo.GetRemoveMethod Overload List | MethodInfo


EventInfo.GetRemoveMethod ()

Retrieves the MethodInfo object for "removing" a method of the event represented by this instance with default properties.

[Visual Basic]
Overloads Public Function GetRemoveMethod() As MethodInfo
[C#]
public MethodInfo GetRemoveMethod();
[C++]
public: MethodInfo* GetRemoveMethod();
[JScript]
public function GetRemoveMethod() : MethodInfo;

Return Value

Retrieves a MethodInfo object that you call to unsubscribe to an event.

Remarks

The GetRemoveMethod method will return the unsubscribed method. The "remove" method is used to add an even-handler delegate to the invocation list of an event source.

Example

Typically, the method has the following signature:

public void AddOn<EventName>(<EventHandlerType>hander)

See Also

EventInfo Class | EventInfo Members | System.Reflection Namespace | EventInfo.GetRemoveMethod Overload List | MethodInfo


EventInfo.RemoveEventHandler

Removes an event handler from an event source.

Implementation of this member is not complete for this release of the NGWS SDK. This documentation is for information only.

[Visual Basic]
Public Sub RemoveEventHandler( _
   ByVal target As Object, _
   ByVal handler As Delegate _
)
[C#]
public void RemoveEventHandler(
   object target,
   Delegate handler
);
[C++]
public: void RemoveEventHandler(
   Object* target,
   Delegate* handler
);
[JScript]
public function RemoveEventHandler(
   target : Object,
   handler : Delegate
);

Parameters

target
The event source.
handler
Encapsulates one or more methods to be invoked when the event is raised by the target.

Exceptions

Exception Type | Condition
ArgumentException | target or handler is a null reference (in Visual Basic Nothing).
AccessException | The caller does not have permission to invoke the "remove" method on the event source. For example, the method might be private.
TargetInvocationException | The "remove" method throws an exception.
ArgumentException | handler is not the same type as the event handler delegate used in conjunction with the event reflected by this instance.

Remarks

The RemoveEventHandler method will attempt to remove thate delegate that may sync this event on the the target object.

When an event is raised by target, the method(s) encapsulated by handler will no longer be invoked.

See Also

EventInfo Class | EventInfo Members | System.Reflection Namespace | Object | Delegate | EventHandler


FieldAttributes Enumeration

Comprises flags that specify the attributes of a field.

[Visual Basic]
Public Enum FieldAttributes
[C#]
public enum FieldAttributes
[C++]
public enum FieldAttributes

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

FieldAttributes uses this value from the FieldAccessMask property to mask off only the parts of the attribute value that is the accessibility. For example, the following code snippet determines if Attributes has the public bit set:

(Attributes & FieldAttributes.FieldAccessMask) == FieldAttributes.Public

In the example shown below, three fields are build and the FieldAttributes value is displayed, when it is exactly defined. A FieldAttributes may contain more than one attributes, such as Public and Literal, as shown in the third field below.

To get the FieldAttributes, first get the class Type. From the Type, get the FieldInfo. From the FieldInfo, get the Attributes.

The enumerated value is a number representing the bitwise Or of the attributes implemented on the field. Us the following mask values to retrieve accessible information

FieldAccessMask = 0x0007,

PrivateScope = 0x0000

Private = 0x0001

FamANDAssem = 0x0002

Assembly = 0x0003

Family = 0x0004

FamORAssem = 0x0005

Public = 0x0006

field contract attributes.

Static = 0x0010

InitOnly = 0x0020

Literal = 0x0040

NotSerialized = 0x0080

SpecialName = 0x0200

interop and runtime attributes

PinvokeImpl = 0x2000

RTSpecialName = 0x0400

Reserved flags for runtime use only

ReservedMask = 0xd500

RTSpecialName = 0x0400

HasFieldMarshal = 0x1000

HasSecurity = 0x4000

HasDefault = 0x8000

HasFieldRVA = 0x0100

Members

Member Name | Description
Assembly | Indicates that the field is accessible throughout the assembly.
FamANDAssem | Indicates that the field is accessible only by sub-types in this assembly.
Family | Indicates that the field is accessible only by type and sub-types.
FamORAssem | Indicates that the field is accessible by sub-types anywhere, as well as throughout this assembly.
FieldAccessMask | Specifies the access level of a given field.
HasDefault | Indicates that the field has a default value.
HasFieldMarshal | Indicates that the field has marshalling information.
HasFieldRVA | Indicates that the field has a Relative Virtual Address (RVA). RVA is the location of the method body in the current image, as an address relative to the start of the image file in which it is located.
HasSecurity | Indicates that the field has a security associate.
InitOnly | Indicates that the field is initialized only, and cannot be written after initialization.
Literal | Indicates that the field's value is a compile-time (static or early bound) constant. No set accessor.
NotSerialized | Indicates that the field does not have to be serialized when the type is remoted.
PinvokeImpl | Indicates that the field's implementation is forwarded through PInvoke.
Private | Indicates that the field is accessible only by the parent type.
PrivateScope | Indicates that the field cannot be referenced.
Public | Indicates that the field is accessible by any member for whom this scope is visible.
ReservedMask | [To be supplied.]
RTSpecialName | Indicates that the NGWS runtime (metadata internal APIs) should check the name encoding.
SpecialName | Indicates a special method, with the name describing how the method is special.
Static | Indicates that the field represents the defined type, or else it is per-instance.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

Example [C#]

[C#]

//Make three fields
//The first field is private
public class Myfielda
{
    private string field = "A private field";
    public string Field{
        get{return field;}
        set{if(field!=value) {field=value + "---";}}
    }
}
//The second field is public
public class Myfieldb
{
    public string field = "B public field";
    public string Field{
        get{return field;}
        set{if(field!=value) {field=value;}}
    }
}
//The third field is public and literal, which is not exactly defined.
public class Myfieldc
{
    public const string field = "C constant field";
    public string Field{
        get{return field;}
    }
}
public class Myfieldattributes
{
    public static int Main()
    {
        Console.WriteLine ("\nReflection.FieldAttributes");
        Myfielda Myfielda = new Myfielda();
        Myfieldb Myfieldb = new Myfieldb();
        Myfieldc Myfieldc = new Myfieldc();

        //Get the Type and FieldInfo for each of the three fields
        Type MyTypea = Type.GetType("Myfielda");
        FieldInfo Myfieldinfoa = MyTypea.GetField("field",
BindingFlags.NonPublic);
        Type MyTypeb = Type.GetType("Myfieldb");
        FieldInfo Myfieldinfob = MyTypeb.GetField("field",
BindingFlags.NonPublic);
        Type MyTypec = Type.GetType("Myfieldc");
        FieldInfo Myfieldinfoc = MyTypec.GetField("field",
BindingFlags.NonPublic);

        //For the first field;
        //Get and Display the Name, field, and attributes
        Console.Write ("\n{0} - ", MyTypea.FullName);
        Console.Write ("{0}; ", Myfieldinfoa.GetValue(Myfielda));
        FieldAttributes Myattributesa = Myfieldinfoa.Attributes;

        //If the FieldAttributes is exactly defined,
        // print it out, otherwise say it is not defined
        if (EnumInfo.IsDefined(typeof(FieldAttributes),
Myattributesa))
Console.Write ("It has a {0} field attribute.",
    EnumInfo.ToString(typeof(FieldAttributes),
    Myattributesa));
        else
Console.Write ("It is not exactly defined.");

        //For the second field;
        //Get and Display the Name, field, and attributes
        Console.Write ("\n{0} - ", MyTypeb.FullName);
        Console.Write ("{0}; ", Myfieldinfob.GetValue(Myfieldb));
        FieldAttributes Myattributesb = Myfieldinfob.Attributes;

        //If the FieldAttributes is exactly defined,
        // print it out, otherwise say it is not defined
        if (EnumInfo.IsDefined(typeof(FieldAttributes),
Myattributesb))
Console.Write ("It has a {0} field attribute.",
    EnumInfo.ToString(typeof(FieldAttributes),
        Myattributesb));
        else
Console.Write ("It is not exactly defined.");

        //For the third field;
        //Get and Display the Name, field, and attributes
        Console.Write ("\n{0} - ", MyTypec.FullName);
        Console.Write ("{0}; ", Myfieldinfoc.GetValue(Myfieldc));
        FieldAttributes Myattributesc = Myfieldinfoc.Attributes;

        //If the FieldAttributes is exactly defined,
        // print it out, otherwise say it is not defined
        if (EnumInfo.IsDefined(typeof(FieldAttributes),
Myattributesc))
Console.Write ("It has a {0} field attribute.",
    EnumInfo.ToString(typeof(FieldAttributes),
        Myattributesc));
        else
Console.Write ("It is not exactly defined.");

        return 0;
    }
}

This code produces the following output:

Reflection.FieldAttributes

Myfielda- A private field; It has a Private field attribute.

Myfieldb- B public field; It has a Public field attribute.

Myfieldc- C constant field; It is not exactly defined.

See Also

System.Reflection Namespace


FieldInfo Class

Discovers the attributes of a field and provides access to field metadata. The field information is obtained from metadata. FieldInfo does not have a public constructor. Objects are created by invoking either the GetFields() or GetField() method of a Type object.

Fields are variables defined in the class. Although related to fields, properties are marked explicitly in the metadata and usually have get and set routines associated with them. FieldInfo provides access to the metadata for a field within a class and provides dynamic set and get functionality for the field. The class is not loaded into memory until invoke or get is called on the object.

Object
MemberInfo
FieldInfo

[Visual Basic]
MustInherit Public Class FieldInfo
   Inherits MemberInfo
[C#]
public abstract class FieldInfo : MemberInfo
[C++]
public __gc __abstract class FieldInfo : public MemberInfo
[JScript]
public abstract class FieldInfo extends MemberInfo

Remarks

When Type.GetField is called, the returned FieldInfo will appear to have a ToString method; it does not. This is due to an internal private class used by Type. This matter will be made more clear in a future release.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

FieldInfo Members | System.Reflection Namespace


FieldInfo Members

Public:

Properties

Attributes | Retrieves the attributes associated with this field.
DeclaringType (inherited from MemberInfo) | Retrieves the class that declares this member.
FieldHandle | Retrieves a RuntimeFieldHandle, which is a handle to the internal metadata representation of a field.
FieldType | Retrieves the Type of this field.
IsAssembly | Indicates whether this field has Assembly level visibility.
IsFamily | Indicates whether this field has Family level visibility.
IsFamilyAndAssembly | Indicates whether this field has FamilyANDAssembly level visibility.
IsFamilyOrAssembly | Indicates whether this field has FamilyORAssembly level visibility.
IsInitOnly | Indicates whether the field can only be set in the body of the constructor.
IsLiteral | Indicates whether the value is written at compile time and cannot be changed.
IsNotSerialized | Indicates whether this field has the NotSerialized attribute.
IsPinvokeImpl | Indicates whether the corresponding PinvokeImpl attribute is set in FieldAttributes.
IsPrivate | Retrieves a value indicating whether the field is private.
IsPublic | Indicates whether the field is public.
IsSpecialName | Indicates whether the corresponding SpecialName attribute is set in the FieldAttributes enumerator.
IsStatic | Indicates whether the field is static.
MemberType | Retrieves the Type of property reflected by this FieldInfo object. The retrieved value indicates that this member is a field.
Name (inherited from MemberInfo) | Retrieves the name of this member.
ReflectedType (inherited from MemberInfo) | Retrieves the class object that was used to obtain this instance of MemberInfo.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCustomAttributes (inherited from MemberInfo) | Overloaded. Returns all attributes defined on this member.
GetFieldFromHandle | Retrieves a FieldInfo containing the value of the field reflected by this instance..
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | Returns the value of a field supported by a given object.
GetValueDirect | [To be supplied.]
IsDefined (inherited from MemberInfo) | Returns a Boolean if one or more instance of attributeType is defined on this member.
SetValue | Overloaded. Sets the value of the field for the given object to the given value.
SetValueDirect | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Constructor

FieldInfo Constructor Initializes a new instance of the FieldInfo class.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldInfo Class | System.Reflection Namespace


FieldInfo Constructor

Initializes a new instance of the FieldInfo class.

[Visual Basic]
Protected Sub New()
[C#]
protected FieldInfo();
[C++]
protected: FieldInfo();
[JScript]
protected function FieldInfo();

See Also

FieldInfo Class | FieldInfo Members | System.Reflection Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

FieldInfo Properties

The properties of the FieldInfo class are listed below. For a complete list of FieldInfo class members, see the FieldInfo Members topic.

Public:

Attributes | Retrieves the attributes associated with this field.
DeclaringType (inherited from MemberInfo) | Retrieves the class that declares this member.
FieldHandle | Retrieves a RuntimeFieldHandle, which is a handle to the internal metadata representation of a field.
FieldType | Retrieves the Type of this field.
IsAssembly | Indicates whether this field has Assembly level visibility.
IsFamily | Indicates whether this field has Family level visibility.
IsFamilyAndAssembly | Indicates whether this field has FamilyANDAssembly level visibility.
IsFamilyOrAssembly | Indicates whether this field has FamilyORAssembly level visibility.
IsInitOnly | Indicates whether the field can only be set in the body of the constructor.
IsLiteral | Indicates whether the value is written at compile time and cannot be changed.
IsNotSerialized | Indicates whether this field has the NotSerialized attribute.
IsPinvokeImpl | Indicates whether the corresponding PinvokeImpl attribute is set in FieldAttributes.
IsPrivate | Retrieves a value indicating whether the field is private.
IsPublic | Indicates whether the field is public.
IsSpecialName | Indicates whether the corresponding SpecialName attribute is set in the FieldAttributes enumerator.
IsStatic | Indicates whether the field is static.
MemberType | Retrieves the Type of property reflected by this FieldInfo object. The retrieved value indicates that this member is a field.
Name (inherited from MemberInfo) | Retrieves the name of this member.
ReflectedType (inherited from MemberInfo) | Retrieves the class object that was used to obtain this instance of MemberInfo.

See Also

FieldInfo Class | System.Reflection Namespace


FieldInfo.Attributes

Retrieves the attributes associated with this field.

[Visual Basic]
MustOverride Public ReadOnly Property Attributes As FieldAttributes
[C#]
public FieldAttributes Attributes {abstract get;}
[C++]
public: __property virtual FieldAttributes get_Attributes() = 0;
[JScript]
public abstract function get Attributes() : FieldAttributes;

Property Value

Read-only. Retrieves the FieldAttributes for this field.

Remarks

Property representing the Attributes associated with a Member. All members have a set of attributes, which are defined in relation to the specific type of member. The FieldAttributes let the user know if this field is the private field, a static field, etc.

To get the Attributes property, first get the class Type. From the Type, get the FieldInfo. From the FieldInfo, get the Attributes.

Example [C#]

[C#]

public class Myproperty
{
   private string caption = "Default caption";
   public string Caption{
      get{return caption;}
      set{if(caption!=value) {caption = value;}}
   }
}
class Myfieldinfo
{
   public static int Main()
      {
      Console.WriteLine ("\nReflection.FieldInfo");
      Myproperty Myproperty = new Myproperty();

      //Get the Type and FieldInfo
      Type MyType = Type.GetType("Myproperty");
      FieldInfo Myfieldinfo = MyType.GetField("caption", BindingFlags.NonPublic);

      //Get and Display the FieldInfo.Attributes
      Console.Write ("\nFor {0}.", MyType.FullName);
      Console.Write ("{0}; ", Myfieldinfo.Name);
      FieldAttributes Myfieldattributes = Myfieldinfo.Attributes;
      Console.WriteLine("FieldInfo.Attributes = {0}",
        EnumInfo.ToString(typeof(FieldAttributes),Myfieldattributes));

      return 0;
   }
}

This code produces the following output:

Reflection.FieldInfo

For Myproperty.caption;

FieldInfo.Attributes = Private

See Also

FieldInfo Class | FieldInfo Members | System.Reflection Namespace | FieldAttributes


FieldInfo.FieldHandle

Retrieves a RuntimeFieldHandle, which is a handle to the internal metadata representation of a field.

[Visual Basic]
MustOverride Public ReadOnly Property FieldHandle As _
   RuntimeFieldHandle
[C#]
public RuntimeFieldHandle FieldHandle {abstract get;}
[C++]
public: __property virtual RuntimeFieldHandle get_FieldHandle() = 0;
[JScript]
public abstract function get FieldHandle() : RuntimeFieldHandle;

Property Value

A handle to the internal metadata representation of a field.

Remarks

[To be supplied.]

See Also

FieldInfo Class | FieldInfo Members | System.Reflection Namespace


FieldInfo.FieldType

Retrieves the Type of this field.

[Visual Basic]
MustOverride Public ReadOnly Property FieldType As Type
[C#]
public Type FieldType {abstract get;}
[C++]
public: __property virtual Type* get_FieldType() = 0;
[JScript]
public abstract function get FieldType() : Type;

Property Value

Read-only. Retrieves the class of this field object.

Remarks

The Type is string, Boolean, Integer, and so on.

To get the FieldType property, first get the class Type. From the Type, get the FieldInfo. From the FieldInfo, get the FieldType value.

Example [C#]

[C#]

//Make a field
public class Myfield
{
   private string field = "private field";
   public string Field{
      get{return field;}
   }
}
public class Myfieldinfo
{
   public static int Main()
   {
      Console.WriteLine ("\nReflection.FieldInfo");
      Myfield Myfield = new Myfield();

      //Get the Type and FieldInfo
      Type MyType = Type.GetType("Myfield");
      FieldInfo Myfieldinfo = MyType.GetField("field", BindingFlags.NonPublic);

      //Get and Display the FieldType
      Console.Write ("\n{0}.", MyType.FullName);
      Console.Write ("{0} - ", Myfieldinfo.Name);
      Console.Write ("{0};", Myfield.Field);
      Console.Write ("\nFieldType = {0}", Myfieldinfo.FieldType);

      return 0;
   }
}

This code produces the following output:

Myfield.field- private field;

FieldType = System.String

See Also

FieldInfo Class | FieldInfo Members | System.Reflection Namespace | FieldAttributes


FieldInfo.IsAssembly

Indicates whether this field has Assembly level visibility.

[Visual Basic]
Public ReadOnly Property IsAssembly As Boolean
[C#]
public bool IsAssembly {get;}
[C++]
public: __property bool get_IsAssembly();
[JScript]
public function get IsAssembly() : Boolean;

Property Value

Read-only. true if the field has the Assembly attribute set; otherwise, false.

Remarks

If a field has Assembly level visibility, it can be called from any member within that assembly, but none outside of it.

The IsAssembly property is set when the FieldAttributes.Assembly attribute is set. Declaring the field internal, sets these properties. Declaring the field internal limits the access of this field to this project.

Example [C#]

[C#]

//Make two fields
public
class Myfielda
{
   private string field = "A private field";
   public string Field{
      get{return field;}
      set{if(field!=value){field=value;}}
   }
}
public
class Myfieldb
{
   internal string field = "B public field";
   public string Field{
      get{return field;}
      set{if(field!=value){field=value;}}
   }
}
public
class Myfieldinfo
{
   public static int Main()
   {
      Console.WriteLine("\nReflection.FieldInfo");
      Myfielda Myfielda = new Myfielda();
      Myfieldb Myfieldb = new Myfieldb();

      //Get the Type and FieldInfo
      Type MyTypea = Type.GetType("Myfielda");
      FieldInfo Myfieldinfoa = MyTypea.GetField("field", BindingFlags.NonPublic);
      Type MyTypeb = Type.GetType("Myfieldb");
      FieldInfo Myfieldinfob = MyTypeb.GetField("field", BindingFlags.NonPublic);

      //For the first field;
      //Get and Display the Name, field, and IsAssembly
      Console.Write("\n{0} - ", MyTypea.FullName);
      Console.Write("{0};", Myfieldinfoa.GetValue(Myfielda));
      Console.Write(" IsAssembly = {0}; ", Myfieldinfoa.IsAssembly );
      if (Myfieldinfoa.IsAssembly )
         Console.Write("Field has limited accessability");

      //For the second field;
      //Get and Display the Name, field, and IsAssembly

      Console.Write("\n{0} - ", MyTypeb.FullName);
      Console.Write("{0}; ", Myfieldinfob.GetValue(Myfieldb));
      Console.Write(" IsAssembly = {0}; ", Myfieldinfob.IsAssembly );
      if (Myfieldinfob.IsAssembly )
         Console.Write("Field has limited accessability");

      return 0;
   }
}

This code produces the following output:

Reflection.FieldInfo

Myfielda- A private field; IsAssembly = False;

Myfieldb- B public field; IsAssembly = True; Field has limited accessibility

See Also

FieldInfo Class | FieldInfo Members | System.Reflection Namespace | FieldAttributes


FieldInfo.IsFamily

Indicates whether this field has Family level visibility.

[Visual Basic]
Public ReadOnly Property IsFamily As Boolean
[C#]
public bool IsFamily {get;}
[C++]
public: __property bool get_IsFamily();
[JScript]
public function get IsFamily() : Boolean;

Property Value

Read-only. true if the field has the Family attribute set; otherwise, false.

Remarks

Boolean property indicating if the field has the Family level visibility set. It can be called from any member in a derived class, but not from any other type.

To get the IsFamily property, first get the class Type. From the Type, get the FieldInfo. From the FieldInfo, get the IsFamily value.

The IsFamily property is set when the FieldAttributes.Family attribute is set.

Example [C#]

In the following example, two properties are created. The first property has a private string field and the second property has a protected string field, resulting in the IsFamily being set to true.

[C#]

//Make
two fields
public
class Myfielda
{
   private string field = "A private field";
   public string Field{
      get{return field;}
      set{if(field!=value){field=value;}}
   }
}
public
class Myfieldb
{
   protected string field = "B public field";
   public string Field{
      get{return field;}
      set{if(field!=value){field=value;}}
   }
}

public
class Myfieldinfo
{
   public static int Main()
   {
      Console.WriteLine("\nReflection.FieldInfo");
      Myfielda Myfielda = new Myfielda();
      Myfieldb Myfieldb = new Myfieldb();

      //Get the Type and FieldInfo
      Type MyTypea = Type.GetType("Myfielda");
      FieldInfo Myfieldinfoa = MyTypea.GetField("field",
         BindingFlags.NonPublic);
      Type MyTypeb = Type.GetType("Myfieldb");
      FieldInfo Myfieldinfob = MyTypeb.GetField("field",
         BindingFlags.NonPublic);

      //For the first field;
      //Get and Display the Name, field, and IsFamily
      Console.Write("\n{0} - ", MyTypea.FullName);
      Console.Write("{0} - ", Myfieldinfoa.GetValue(Myfielda));
      Console.Write("\n  IsFamily - {0}", Myfieldinfoa.IsFamily);
      Console.Write("\n  FieldAttributes - {0}",EnumInfo.ToString(
         typeof(FieldAttributes),Myfieldinfoa.Attributes));

      //For the second field;
      //Get and Display the Name, field, and IsFamily
      Console.Write("\n{0} - ", MyTypeb.FullName);
      Console.Write("{0} - ", Myfieldinfob.GetValue(Myfieldb));
      Console.Write("\n  IsFamily - {0}", Myfieldinfob.IsFamily);
      FieldAttributes Myfieldattributesb = Myfieldinfob.Attributes;
      Console.Write("\n  FieldAttributes - {0}", EnumInfo.ToString(
         typeof(FieldAttributes),Myfieldinfob.Attributes));

      return 0;
   }
}

This code produces the following output:

Reflection.FieldInfo

Myfielda- A private field-

IsFamily- False

FieldAttributes- Private

Myfieldb- B public field-

IsFamily- True

FieldAttributes- Family

See Also

FieldInfo Class | FieldInfo Members | System.Reflection Namespace | FieldAttributes


FieldInfo.IsFamilyAndAssembly

Indicates whether this field has FamilyANDAssembly level visibility.

[Visual Basic]
Public ReadOnly Property IsFamilyAndAssembly As Boolean
[C#]
public bool IsFamilyAndAssembly {get;}
[C++]
public: __property bool get_IsFamilyAndAssembly();
[JScript]
public function get IsFamilyAndAssembly() : Boolean;

Property Value

Read-only. true if the field has the FamANDAssem attribute set; otherwise, false.

Remarks

If a field has FamilyAndAssembly level visibility, it can be called from any member in a derived class that is also in the same assembly, but not from any other type.

The IsFamilyAndAssembly property is set when the FieldAttributes.FamANDAssem attribute is set.

See Also

FieldInfo Class | FieldInfo Members | System.Reflection Namespace | FieldAttributes


FieldInfo.IsFamilyOrAssembly

Indicates whether this field has FamilyORAssembly level visibility.

[Visual Basic]
Public ReadOnly Property IsFamilyOrAssembly As Boolean
[C#]
public bool IsFamilyOrAssembly {get;}
[C++]
public: __property bool get_IsFamilyOrAssembly();
[JScript]
public function get IsFamilyOrAssembly() : Boolean;

Property Value

Read-only. true if the field has the FamORAssem attribute set; otherwise, false.

Remarks

If a field has FamilyORAssembly level visibility, it can be called from any member in a derived class or any member in the same assembly, but not from any other type. A derived class can access a protected member of a base class with this flag set.The IsFamilyOrAssembly property is set when the FieldAttributes.FamORAssem attribute is set.

Example [C#]

In the following example, two fields are created. The second field, Myfieldb is derived from the first, Myfielda. The Myfielda.field is protected internal, which allows Myfieldb.field to be derived. If Myfielda.field was a private field, Myfieldb.field could not be derived.

[C#]

//Make two fields
public class Myfielda
   //Note that if the private line below is uncommented
   // and the protected internal line below is commented out
   // this will not compile as Myfielda.field is inaccessible
{
   //private string field = "A private field";
   protected internal string field = "A private field";
   public string Field{
      get{return field;}
      set{if(field!=value) {field=value;}}
   }
}
//Myfieldb is derived from Myfielda.
//The protected internal string field allows
//the IsFamilyOrAssembly flag to be set and allows
//the field to be visible from a derived class.
public class Myfieldb:Myfielda
{
   new public string Field{
      get{return field;}
      set{if(field!=value){field=value;}}
   }
}
public
class Myfieldinfo
{
   public static int Main()
   {
      Console.WriteLine("\nReflection.FieldInfo");
      Myfielda Myfielda = new Myfielda();
      Myfieldb Myfieldb = new Myfieldb();

      //Get the Type and FieldInfo
      Type MyTypea = Type.GetType("Myfielda");
      FieldInfo Myfieldinfoa = MyTypea.GetField("field",
         BindingFlags.NonPublic);
      Type MyTypeb = Type.GetType("Myfieldb");
      FieldInfo Myfieldinfob = MyTypeb.GetField("field",
         BindingFlags.NonPublic);

      //For the first field;
      //Get and Display the Name, field, and IsFamilyOrAssembly
      Console.Write("\n{0} - ", MyTypea.FullName);
      Console.Write("{0};", Myfieldinfoa.GetValue(Myfielda));
      Console.Write("\n   IsFamilyOrAssembly = {0};",
         Myfieldinfoa.IsFamilyOrAssembly
);
      if (Myfieldinfoa.IsFamilyOrAssembly )
         Console.Write("Field has limited accessability");

      //For the second field;
      //Get and Display the Name, field
      Console.Write("\n{0} - ", MyTypeb.FullName);
      Console.Write("{0}; ", Myfieldinfob.GetValue(Myfieldb));

      return 0;
   }
}

This code produces the following output:

Reflection.FieldInfo

Myfielda- A private field; IsFamilyOrAssembly = True; Field has limited accessibility

Myfieldb- A private field;

See Also

FieldInfo Class | FieldInfo Members | System.Reflection Namespace | FieldAttributes


FieldInfo.IsInitOnly

Indicates whether the field can only be set in the body of the constructor.

[Visual Basic]
Public ReadOnly Property Is As Boolean
[C#]
public bool IsInitOnly {get;}
[C++]
public: __property bool get_IsInitOnly();
[JScript]
public function get IsInitOnly() : Boolean;

Property Value

Read-only. true if the field has the InitOnly attribute set; otherwise, false.

Remarks

If the returned value is True, the Field may only be initialized, not written to after initilization.

To get the IsInitOnly property, first get the class Type. From the Type, get the FieldInfo. From the FieldInfo, get the IsInitOnly. To access a non public property, in the GetField method, set the BindingFlags to NonPublic.

The IsInitOnly property is set when the FieldAttributes.InitOnly attribute is set.

Example [C#]

In the following example, two fields are created. The second field is readonly, has no set accessor, and the IsInit is set to true.

[C#]

//Make two fields, one public and one readonly
public class Myfielda
{
   public string field = "A public field";
   public string Field{
      get{return field;}
      set{if(field!=value){field=value;}}
   }
}
public class Myfieldb
{
   readonly string field = "B readonly field";
   public string Field{
      get{return field;}
   }
}
public class Myfieldinfo
{
   public static int Main()
   {
      Console.WriteLine("\nReflection.FieldInfo");
      Myfielda Myfielda = new Myfielda();
      Myfieldb Myfieldb = new Myfieldb();

      //Get the Type and FieldInfo
      Type MyTypea = Type.GetType("Myfielda");
      FieldInfo Myfieldinfoa = MyTypea.GetField("field",
         BindingFlags.NonPublic);
      Type MyTypeb = Type.GetType("Myfieldb");
      FieldInfo Myfieldinfob = MyTypeb.GetField("field",
         BindingFlags.NonPublic);

      //Modify the fields
      //Note the Myfieldb is not modified, as it is
      // read only (IsInitOnly is True).
      Myfielda.field = "A- modified";
      //Myfieldb.field = "B- modified";

      //For the first field;
      //Get and Display the Name, field, and IsInitOnly
      Console.Write("\n{0} - {1}, IsInitOnly = {2} ",
         MyTypea.FullName,
         Myfieldinfoa.GetValue(Myfielda),
         Myfieldinfoa.IsInitOnly);

      //For the second field;
      //Get and Display the Name, field, and IsInitOnly
      Console.Write("\n{0} - {1}, IsInitOnly = {2} ",
         MyTypeb.FullName,
         Myfieldinfob.GetValue(Myfieldb),
         Myfieldinfob.IsInitOnly);

      return 0;
   }
}

This code produces the following output:

Reflection.FieldInfo Myfielda- A- modified, IsInitOnly = False

Myfieldb- B readonly field, IsInitOnly = True

See Also

FieldInfo Class | FieldInfo Members | System.Reflection Namespace | FieldAttributes


FieldInfo.IsLiteral

Indicates whether the value is written at compile time and cannot be changed.

[Visual Basic]
Public ReadOnly Property IsLiteral As Boolean
[C#]
public bool IsLiteral {get;}
[C++]
public: __property bool get_IsLiteral();
[JScript]
public function get IsLiteral() : Boolean;

Property Value

Read-only. true if the field has the Literal attribute set; otherwise, false.

Remarks

The IsLiteral property is set when the FieldAttributes.Literal attribute is set. If this attribute is set, the field cannot be changed and is constant. Note in the sample below, the second field has IsLiteral set to true, the field is a constant, and the field has no set accessor.

Example [C#]

[C#]

//Make two fields
public class Myfielda
{
   private string field = "A private field";
   public string Field{
      get{return field;}
      set{if(field!=value){field=value;}}
   }
}
public class Myfieldb
{
   public const string field = "B public field";
   public string Field{
      get{return field;}
   }
}

public class Myfieldinfo
{
   public static int Main()
   {
      Console.WriteLine("\nReflection.FieldInfo");
      Myfielda Myfielda = new Myfielda();
      Myfieldb Myfieldb = new Myfieldb();

      //Get the Type and FieldInfo
      Type MyTypea = Type.GetType("Myfielda");
      FieldInfo Myfieldinfoa =
         MyTypea.GetField("field", BindingFlags.NonPublic);
      Type MyTypeb = Type.GetType("Myfieldb");
      FieldInfo Myfieldinfob =
         MyTypeb.GetField("field", BindingFlags.NonPublic);

      //For the first field;
      //Get and Display the Name, field, and IsLiteral
      Console.Write("\n{0} - ", MyTypea.FullName);
      Console.Write("{0};", Myfieldinfoa.GetValue(Myfielda));
      Console.Write("    IsLiteral = {0}; ", Myfieldinfoa.IsLiteral);
      if (Myfieldinfoa.IsLiteral)
         Console.Write("Field cannot be changed");

      //For the second field;
      //Get and Display the Name, field, and IsLiteral
      Console.Write("\n{0} - ", MyTypeb.FullName);
      Console.Write("{0}; ", Myfieldinfob.GetValue(Myfieldb));
      Console.Write("    IsLiteral = {0}; ", Myfieldinfob.IsLiteral);
      if (Myfieldinfob.IsLiteral)
         Console.Write("Field cannot be changed");

      return 0;
   }
}

This code produces the following output:

Reflection.FieldInfo

Myfielda- A private field; IsLiteral = False;

Myfieldb- B public field; IsLiteral = True; Field cannot be changed

See Also

FieldInfo Class | FieldInfo Members | System.Reflection Namespace | FieldAttributes


FieldInfo.IsNotSerialized

Indicates whether this field has the NotSerialized attribute.

[Visual Basic]
Public ReadOnly Property IsNotSerialized As Boolean
[C#]
public bool IsNotSerialized {get;}
[C++]
public: __property bool get_IsNotSerialized();
[JScript]
public function get IsNotSerialized() : Boolean;

Property Value

Read-only. true if the field has the NotSerialized attribute set; otherwise, false.

Remarks

The IsNotSerialized property is set when the FieldAttributes.NotSerialized attribute is set. The presence of the NonSerialized attribute on a field or property indicates that that field or property should not be serialized.

See Also

FieldInfo Class | FieldInfo Members | System.Reflection Namespace | FieldAttributes


FieldInfo.IsPinvokeImpl

Indicates whether the corresponding PinvokeImpl attribute is set in FieldAttributes.

[Visual Basic]
Public ReadOnly Property IsPinvokeImpl As Boolean
[C#]
public bool IsPinvokeImpl {get;}
[C++]
public: __property bool get_IsPinvokeImpl();
[JScript]
public function get IsPinvokeImpl() : Boolean;

Property Value

true if the PinvokeImpl attribute is set in FieldAttributes; otherwise, false.

See Also

FieldInfo Class | FieldInfo Members | System.Reflection Namespace | FieldAttributes


FieldInfo.IsPrivate

Retrieves a value indicating whether the field is private.

[Visual Basic]
Public ReadOnly Property IsPrivate As Boolean
[C#]
public bool IsPrivate {get;}
[C++]
public: __property bool get_IsPrivate();
[JScript]
public function get IsPrivate() : Boolean;

Property Value

Read-only. true if the field is private; otherwise; false.

Remarks

Private fields are accessible only from member functions and subclasses.

The IsPrivate property is set when the FieldAttributes.Private attribute is set.

To get the IsPrivate property, first get the class Type. From the Type, get the FieldInfo. From the FieldInfo, get the IsPrivate. If the property is other than public, it is protected and cannot be readily accessed. To access a non public property, in the GetField method, set the BindingFlags to NonPublic.

Example

See Also

FieldInfo Class | FieldInfo Members | System.Reflection Namespace


FieldInfo.IsPublic

Indicates whether the field is public.

[Visual Basic]
Public ReadOnly Property IsPublic As Boolean
[C#]
public bool IsPublic {get;}
[C++]
public: __property bool get_IsPublic();
[JScript]
public function get IsPublic() : Boolean;

Property Value

Read-only. true if this field is public; otherwise, false.

Remarks

Public fields are accessible everywhere their corresponding classes are visible.

The IsPublic property is set when the FieldAttributes.Public attribute is set.

To get the IsPublic property, first get the class Type. From the Type, get the FieldInfo. From the FieldInfo, get the IsPublic property. If the property is other than public, it is protected and cannot be readily accessed. To access a non public property, in the GetField method, set the BindingFlags to NonPublic.

Example [C#]

[C#]

//Make
two fields
public
class Myfielda // private
{
   private string field = "private field";
   public string Field{
      get{return field;}
   }
}
public
class Myfieldb // public
{
   public string field = "public field";
   public string Field{
      get{return field;}
   }
}
public
class Myfieldinfo
{
   public static int Main()
   {
      Console.WriteLine("\nReflection.FieldInfo");
      Myfielda Myfielda = new Myfielda();
      Myfieldb Myfieldb = new Myfieldb();

      //Get the Type and FieldInfo
      Type MyTypea = Type.GetType("Myfielda");
      FieldInfo Myfieldinfoa = MyTypea.GetField("field", BindingFlags.NonPublic);
      Type MyTypeb = Type.GetType("Myfieldb");
      FieldInfo Myfieldinfob = MyTypeb.GetField("field");

      //Get and Display the IsPublic and IsPrivate
      Console.Write("\n{0}.", MyTypea.FullName);
      Console.Write("{0} - ", Myfieldinfoa.Name);
      Console.Write("{0};", Myfielda.Field);
      Console.Write("\n   IsPublic = {0}; ",Myfieldinfoa.IsPublic);
      Console.Write("\n   IsPrivate = {0}; ",Myfieldinfoa.IsPrivate);

      Console.Write("\n{0}.", MyTypeb.FullName);
      Console.Write("{0} - ", Myfieldinfob.Name);
      Console.Write("{0};", Myfieldb.Field);
      Console.Write("\n   IsPublic = {0}; ", Myfieldinfob.IsPublic);
      Console.Write("\n   IsPrivate = {0}; ",Myfieldinfob.IsPrivate);

      return 0;
   }
}

This code produces the following output:

Reflection.FieldInfo

Myfielda.field- private field; IsPublic = False; IsPrivate = True;

Myfieldb.field- public field; IsPublic = True; IsPrivate = False;

See Also

FieldInfo Class | FieldInfo Members | System.Reflection Namespace | FieldAttributes


FieldInfo.IsSpecialName

Indicates whether the corresponding SpecialName attribute is set in the FieldAttributes enumerator.

[Visual Basic]
Public ReadOnly Property IsSpecialName As Boolean
[C#]
public bool IsSpecialName {get;}
[C++]
public: __property bool get_IsSpecialName();
[JScript]
public function get IsSpecialName() : Boolean;

Property Value

true if the SpecialName attribute is set in FieldAttributes; otherwise, false.

See Also

FieldInfo Class | FieldInfo Members | System.Reflection Namespace | FieldAttributes


FieldInfo.IsStatic

Indicates whether the field is static.

[Visual Basic]
Public ReadOnly Property IsStatic As Boolean
[C#]
public bool IsStatic {get;}
[C++]
public: __property bool get_IsStatic();
[JScript]
public function get IsStatic() : Boolean;

Property Value

Read-only. true if this field is static; otherwise, false.

Remarks

When a field is static, one copy of the field is shared by all instances of the class. A static field is also called a class variable.

The IsStatic property is set when the FieldAttributes.Static attribute is set.

To get the IsStatic property, first get the class Type. From the Type, get the FieldInfo. From the FieldInfo, get the IsStatic property. To access a non public property, in the GetField method, set the BindingFlags to NonPublic.

Example [C#]

[C#]

//Make
two fields
public class Myfielda
{
   private string field = "A private field";
   public string Field{
      get{return field;}
      set{if(field!=value){field=value;}}
   }
}
public class Myfieldb
{
   static string field = "B static field";
   public string Field {
      get{return field;}
      set{if(field!=value){field=value;}}
   }
}

public class Myfieldinfo
{
   public static int Main()
   {
      Console.WriteLine("\nReflection.FieldInfo");
      Myfielda Myfielda = new Myfielda();
      Myfieldb Myfieldb = new Myfieldb();

      //Get the Type and FieldInfo
      Type MyTypea = Type.GetType("Myfielda");
      FieldInfo Myfieldinfoa = MyTypea.GetField("field", BindingFlags.NonPublic);
      Type MyTypeb = Type.GetType("Myfieldb");
      FieldInfo Myfieldinfob = MyTypeb.GetField("field", BindingFlags.NonPublic);

      //For the first field;
      //Get and Display the Name, field, and IsStatic
      Console.Write("\n{0} - ", MyTypea.FullName);
      Console.Write("{0}; ", Myfieldinfoa.GetValue(Myfielda));
      Console.Write("IsStatic - {0}", Myfieldinfoa.IsStatic);

      //For the second field;
      //Get and Display the Name, field, and IsStatic
      Console.Write("\n{0} - ", MyTypeb.FullName);
      Console.Write("{0}; ", Myfieldinfob.GetValue(Myfieldb));
      Console.Write("IsStatic - {0}", Myfieldinfob.IsStatic);

      return 0;
   }
}

This code produces the following output:

Reflection.FieldInfo

Myfielda- A private field; IsStatic- False

Myfieldb- B static field; IsStatic- True

See Also

FieldInfo Class | FieldInfo Members | System.Reflection Namespace | FieldAttributes


FieldInfo.MemberType

Retrieves the Type of property reflected by this FieldInfo object. The retrieved value indicates that this member is a field.

[Visual Basic]
Overridable Public ReadOnly Property MemberType As MemberTypes
[C#]
public MemberTypes MemberType {override get;}
[C++]
public: __property virtual MemberTypes get_MemberType();
[JScript]
public function get MemberType() : MemberTypes;

Property Value

Read-only. Returns MemberTypes.Field.

Remarks

This is used when this field is being tested as generic member.

Example [C#]

[C#]

//Make a field
public class Myfield
{
   private string field = "a private field";
   public string Field{
      get{return field;}
   }
}

public class Myfieldinfo
{
   public static int Main()
   {
      Console.WriteLine ("\nReflection.FieldInfo");
      Myfield Myfield = new Myfield();

      //Get the Type and FieldInfo
      Type MyType = Type.GetType("Myfield");
      FieldInfo Myfieldinfo = MyType.GetField("field", BindingFlags.NonPublic);

      //Get and Display the MemberType
      Console.Write ("\n{0}.", MyType.FullName);
      Console.Write ("{0} - ", Myfieldinfo.Name);
      Console.Write ("{0};", Myfield.Field);

      MemberTypes Mymembertypes = Myfieldinfo.MemberType;
      Console.Write(" MemberType is a {0}",
         EnumInfo.ToString(typeof(MemberTypes), Mymembertypes));

      return 0;
   }
}

This code produces the following output:

Reflection.FieldInfo

Myfield.field- a private field; MemberType is a Field

See Also

FieldInfo Class | FieldInfo Members | System.Reflection Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

FieldInfo Methods

The methods of the FieldInfo class are listed below. For a complete list of FieldInfo class members, see the FieldInfo Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCustomAttributes (inherited from MemberInfo) | Overloaded. Returns all attributes defined on this member.
GetFieldFromHandle | Retrieves a FieldInfo containing the value of the field reflected by this instance..
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | Returns the value of a field supported by a given object.
GetValueDirect | [To be supplied.]
IsDefined (inherited from MemberInfo) | Returns a Boolean if one or more instance of attributeType is defined on this member.
SetValue | Overloaded. Sets the value of the field for the given object to the given value.
SetValueDirect | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldInfo Class | System.Reflection Namespace


FieldInfo.GetFieldFromHandle

Retrieves a FieldInfo containing the value of the field reflected by this instance..

[Visual Basic]
Public Shared Function GetFieldFromHandle( _
   ByVal handle As RuntimeFieldHandle _
) As FieldInfo
[C#]
public static FieldInfo GetFieldFromHandle(
   RuntimeFieldHandle handle
);
[C++]
public: static FieldInfo* GetFieldFromHandle(
   RuntimeFieldHandle handle
);
[JScript]
public static function GetFieldFromHandle(
   handle : RuntimeFieldHandle
) : FieldInfo;

Parameters

handle
A handle to the internal metadata representation of a field.

Return Value

A FieldInfo containing the value of the field reflected by this instance.

Remarks

[To be supplied].

See Also

FieldInfo Class | FieldInfo Members | System.Reflection Namespace


FieldInfo.GetValue

Returns the value of a field supported by a given object.

[Visual Basic]
MustOverride Public Function GetValue( _
   ByVal obj As Object _
) As Object
[C#]
public abstract object GetValue(
   object obj
);
[C++]
public: virtual Object* GetValue(
   Object* obj
) = 0;
[JScript]
public abstract function GetValue(
   obj : Object
) : Object;

Parameters

obj
The object whose field value will be returned.

Return Value

A Variant containing the value of the field reflected by this instance.

Exceptions

Exception Type | Condition
AccessException | The caller does not have permission to access this field. For example, this field may be private.
TargetException | The method is non-static and obj is a null reference. The method is neither declared nor inherited by the class of obj.

Remarks

If the field is static, obj is ignored. For non-static fields, obj should be an instance of a class that inherits or declares the field. Note that the return type of GetValue is Variant. For example, if the field holds a Boolean primitive value, an instance of Variant with the appropriate Boolean value is returned. Before returning the value, GetValue checks to see if the user has access permission.

Note Access restrictions are ignored for fully trusted code. That is, private constructors, methods, fields, and properties can be accessed and invoked through reflection whenever the code is fully trusted.

See Also

FieldInfo Class | FieldInfo Members | System.Reflection Namespace | Variant


FieldInfo.GetValueDirect

[To be supplied.]

[Visual Basic]
Overridable Public Function GetValueDirect( _
   ByVal obj As TypedReference _
) As Object
[C#]
public virtual object GetValueDirect(
   TypedReference obj
);
[C++]
public: virtual Object* GetValueDirect(
   TypedReference obj
);
[JScript]
public function GetValueDirect(
   obj : TypedReference
) : Object;

Parameters

obj
[To be supplied.]

See Also

FieldInfo Class | FieldInfo Members | System.Reflection Namespace


FieldInfo.SetValue

Sets the value of the field for the given object to the given value.

Overload List

When implemented by a subclass, this method sets the value of the field supported by the given object.

[Visual Basic] Overloads MustOverride Public Sub SetValue(Object, Object, BindingFlags, Binder, CultureInfo)
[C#] public abstract void SetValue(Object, Object, BindingFlags, Binder, CultureInfo);
[C++] public: virtual void SetValue(Object*, Object*, BindingFlags, Binder, CultureInfo) = 0;
[JScript] public abstract function SetValue(Object, Object, BindingFlags, Binder, CultureInfo);

Sets the value of the field supported by the given object.

[Visual Basic] Overloads Public Sub SetValue(Object, Object)
[C#] public void SetValue(Object, Object);
[C++] public: void SetValue(Object*, Object*);
[JScript] public function SetValue(Object, Object);

See Also

FieldInfo Class | FieldInfo Members | System.Reflection Namespace


FieldInfo.SetValue (Object, Object, BindingFlags, Binder, CultureInfo)

When implemented by a subclass, this method sets the value of the field supported by the given object.

[Visual Basic]
Overloads MustOverride Public Sub SetValue( _
   ByVal obj As Object, _
   ByVal value As Object, _
   ByVal invokeAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal culture As CultureInfo _
)
[C#]
public abstract void SetValue(
   object obj,
   object value,
   BindingFlags invokeAttr,
   Binder binder,
   CultureInfo culture
);
[C++]
public: virtual void SetValue(
   Object* obj,
   Object* value,
   BindingFlags invokeAttr,
   Binder* binder,
   CultureInfo* culture
) = 0;
[JScript]
public abstract function SetValue(
   obj : Object,
   value : Object,
   invokeAttr : BindingFlags,
   binder : Binder,
   culture : CultureInfo
);

Parameters

obj
The object whose field value will be set.
value
The value to assign to the field.
invokeAttr
[To be supplied.]
binder
[To be supplied.]
culture
[To be supplied.]

Remarks

This method will assign value to the field reflected by this instance on object obj. If the field is static, obj will be ignored. For non-static fields, obj should be an instance of a class that inherits or declares the field. The new value is passed as a Variant. For example, if the field's type is Boolean, an instance of Variant with the appropriate Boolean value is passed. Before setting the value, SetValue checks to see if the user has access permission.

Note Access restrictions are ignored for fully trusted code. That is, private constructors, methods, fields, and properties can be accessed and invoked via Reflection whenever the code is fully trusted.

See Also

FieldInfo Class | FieldInfo Members | System.Reflection Namespace | FieldInfo.SetValue Overload List


FieldInfo.SetValue (Object, Object)

Sets the value of the field supported by the given object.

[Visual Basic]
Overloads Public Sub SetValue( _
   ByVal obj As Object, _
   ByVal value As Object _
)
[C#]
public void SetValue(
   object obj,
   object value
);
[C++]
public: void SetValue(
   Object* obj,
   Object* value
);
[JScript]
public function SetValue(
   obj : Object,
   value : Object
);

Parameters

obj
The object whose field value will be set.
value
[To be supplied.]

Remarks

This method will assign value to the field reflected by this instance on object obj. If the field is static, obj will be ignored. For non-static fields, obj should be an instance of a class that inherits or declares the field. The new value is passed as a Variant. For example, if the field's type is Boolean, an instance of Variant with the appropriate Boolean value is passed. Before setting the value, SetValue checks to see if the user has access permission. This final method is a convenience method for calling the following SetValue method.

Note Access restrictions are ignored for fully trusted code. That is, private constructors, methods, fields, and properties can be accessed and invoked via Reflection whenever the code is fully trusted.

See Also

FieldInfo Class | FieldInfo Members | System.Reflection Namespace | FieldInfo.SetValue Overload List


FieldInfo.SetValueDirect

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetValueDirect( _
   ByVal obj As TypedReference, _
   ByVal value As Object _
)
[C#]
public virtual void SetValueDirect(
   TypedReference obj,
   object value
);
[C++]
public: virtual void SetValueDirect(
   TypedReference obj,
   Object* value
);
[JScript]
public function SetValueDirect(
   obj : TypedReference,
   value : Object
);

Parameters

obj
[To be supplied.]
value
[To be supplied.]

See Also

FieldInfo Class | FieldInfo Members | System.Reflection Namespace


ICustomAttributeProvider Interface

The ICustomAttributeProvider interface contains methods common to the Type, ConstructorInfo, EventInfo, FieldInfo, MethodInfo, MethodBase, MemberInfo, ParameterInfo, and PropertyInfo classes.

ICustomAttributeProvider

[Visual Basic]
Public Interface ICustomAttributeProvider
[C#]
public interface ICustomAttributeProvider
[C++]
public __gc __interface ICustomAttributeProvider

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement ICustomAttributeProvider

Class | Description
Assembly | An Assembly, that is a reusable, versionable, and self-describing building block of a NGWS application. Assemblies provide the infrastructure needed to allow NGWS runtime to fully understand the contents of an application and to enforce the versioning and dependency rules defined by the application. These concepts are crucial for solving the versioning problem and for simplifying the deployment of NGWS runtime applications.
MemberInfo | Represents the class that is used to obtain information about the members of a class
Module | The Module class reflects a module. A module is a portable executable file of type .dll or .exe consisting of one or more classes and interfaces. One or more modules that are deployed as a unit compose an assembly.
ParameterInfo | The ParameterInfo class reflects a parameter. Instances of this class are used to obtain information about the type of a parameter, the default value, etc.

Remarks

Nearly all the Reflection classes can have attributes associated with them. Attributes can be standard (public, private, HelpString) or custom.

ICustomAttributeProvider is an interface that is implemented by reflection objects that support custom attributes.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

ICustomAttributeProvider Members | System.Reflection Namespace


ICustomAttributeProvider Members

Methods

GetCustomAttributes | Overloaded. Returns all the attributes defined on this member.
IsDefined | Returns true if one or more instance of attributeType is defined on this member.

See Also

ICustomAttributeProvider Interface | System.Reflection Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICustomAttributeProvider Methods

The methods of the ICustomAttributeProvider interface are listed below. For a complete list of ICustomAttributeProvider interface members, see the ICustomAttributeProvider Members topic.

GetCustomAttributes | Overloaded. Returns all the attributes defined on this member.
IsDefined | Returns true if one or more instance of attributeType is defined on this member.

See Also

ICustomAttributeProvider Interface | System.Reflection Namespace


ICustomAttributeProvider.GetCustomAttributes

Returns all the attributes defined on this member.

Overload List

Return an array of custom attributes identified by Type.

[Visual Basic] Overloads Function GetCustomAttributes(Type) As Object ()
[C#] object[] GetCustomAttributes(Type);
[C++] Object* GetCustomAttributes(Type*) [] = 0;
[JScript] function GetCustomAttributes(Type) : Object[];

Return an array of all of the custom attributes, excluding named attributes.

[Visual Basic] Overloads Function GetCustomAttributes() As Object ()
[C#] object[] GetCustomAttributes();
[C++] Object* GetCustomAttributes() [] = 0;
[JScript] function GetCustomAttributes() : Object[];

See Also

ICustomAttributeProvider Interface | ICustomAttributeProvider Members | System.Reflection Namespace


ICustomAttributeProvider.GetCustomAttributes (Type)

Return an array of custom attributes identified by Type.

[Visual Basic]
Overloads Function GetCustomAttributes( _
   ByVal attributeType As Type _
) As Object ()
[C#]
object[] GetCustomAttributes(
   Type attributeType
);
[C++]
Object* GetCustomAttributes(
   Type* attributeType
) [] = 0;
[JScript]
function GetCustomAttributes(
   attributeType : Type
) : Object[];

Parameters

attributeType
The Type object to which the custom attributes are applied.

Return Value

An array of custom attributes identified by Type.

Exceptions

Exception Type | Condition
TypeLoadException | The custom attribute type can not be loaded.
TypeLoadException | if the custom attribute type can not be loaded.

Remarks

If no attributes are defined for this member, an empty array is returned.

See Also

ICustomAttributeProvider Interface | ICustomAttributeProvider Members | System.Reflection Namespace | ICustomAttributeProvider.GetCustomAttributes Overload List


ICustomAttributeProvider.GetCustomAttributes ()

Return an array of all of the custom attributes, excluding named attributes.

[Visual Basic]
Overloads Function GetCustomAttributes() As Object ()
[C#]
object[] GetCustomAttributes();
[C++]
Object* GetCustomAttributes() [] = 0;
[JScript]
function GetCustomAttributes() : Object[];

Return Value

Returns an array of Objects representing the attributes defined on this member.

Exceptions

Exception Type | Condition
TypeLoadException | The custom attribute type can not be loaded.
TypeLoadException | if the custom attribute type can not be loaded.

Remarks

If no attributes are defined for this member, an empty array is returned.

See Also

ICustomAttributeProvider Interface | ICustomAttributeProvider Members | System.Reflection Namespace | ICustomAttributeProvider.GetCustomAttributes Overload List


ICustomAttributeProvider.IsDefined

Returns true if one or more instance of attributeType is defined on this member.

[Visual Basic]
Function IsDefined( _
   ByVal attributeType As Type _
) As Boolean
[C#]
bool IsDefined(
   Type attributeType
);
[C++]
bool IsDefined(
   Type* attributeType
) = 0;
[JScript]
function IsDefined(
   attributeType : Type
) : Boolean;

Parameters

attributeType
The Type object to which the custom attributes are applied

Return Value

true if the attributeType is found on this member; false otherwise.

Remarks

To be supplied

See Also

ICustomAttributeProvider Interface | ICustomAttributeProvider Members | System.Reflection Namespace


InterfaceMapping Structure

Retrieves the mapping of an interface into the actual methods on a class that implements that interface.

Object
ValueType
InterfaceMapping

[Visual Basic]
Public Structure InterfaceMapping
[C#]
public struct InterfaceMapping
[C++]
public __value struct InterfaceMapping

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

InterfaceMapping Members | System.Reflection Namespace


InterfaceMapping Members

Public:

Methods

Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Fields

interfaceMethods | Shows the methods that are defined on the interface.
interfaceType | Shows the type that represents the interface.
targetMethods | Shows the methods that implement the interface.
targetType | Represents the Type that implements the interface.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InterfaceMapping Structure | System.Reflection Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

InterfaceMapping Fields

The fields of the InterfaceMapping structure are listed below. For a complete list of InterfaceMapping structure members, see the InterfaceMapping Members topic.

Public:

interfaceMethods | Shows the methods that are defined on the interface.
interfaceType | Shows the type that represents the interface.
targetMethods | Shows the methods that implement the interface.
targetType | Represents the Type that implements the interface.

See Also

InterfaceMapping Structure | System.Reflection Namespace


InterfaceMapping.interfaceMethods

Shows the methods that are defined on the interface.

[Visual Basic]
Public interfaceMethods() As MethodInfo
[C#]
public MethodInfo[] interfaceMethods;
[C++]
public: MethodInfo* interfaceMethods[];
[JScript]
public var interfaceMethods : MethodInfo[];

See Also

InterfaceMapping Structure | InterfaceMapping Members | System.Reflection Namespace | MethodInfo


InterfaceMapping.interfaceType

Shows the type that represents the interface.

[Visual Basic]
Public interfaceType As Type
[C#]
public Type interfaceType;
[C++]
public: Type* interfaceType;
[JScript]
public var interfaceType : Type;

See Also

InterfaceMapping Structure | InterfaceMapping Members | System.Reflection Namespace | Type


InterfaceMapping.targetMethods

Shows the methods that implement the interface.

[Visual Basic]
Public targetMethods() As MethodInfo
[C#]
public MethodInfo[] targetMethods;
[C++]
public: MethodInfo* targetMethods[];
[JScript]
public var targetMethods : MethodInfo[];

See Also

InterfaceMapping Structure | InterfaceMapping Members | System.Reflection Namespace | MethodInfo


InterfaceMapping.targetType

Represents the Type that implements the interface.

[Visual Basic]
Public targetType As Type
[C#]
public Type targetType;
[C++]
public: Type* targetType;
[JScript]
public var targetType : Type;

See Also

InterfaceMapping Structure | InterfaceMapping Members | System.Reflection Namespace | Type


InvalidFilterCriteriaException Class

Represents an exception that is thrown in FindMembers when the filter criteria is not valid for the type of filter being used.

Object
Exception
ApplicationException
InvalidFilterCriteriaException

[Visual Basic]
Public Class InvalidFilterCriteriaException
   Inherits ApplicationException
[C#]
public class InvalidFilterCriteriaException : ApplicationException
[C++]
public __gc class InvalidFilterCriteriaException : public
   ApplicationException
[JScript]
public class InvalidFilterCriteriaException extends
   ApplicationException

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

InvalidFilterCriteriaException Members | System.Reflection Namespace | Type | ApplicationException


InvalidFilterCriteriaException Members

Public:

Constructor

InvalidFilterCriteriaException Constructor Overloaded. Initializes an instance of the InvalidFilterCriteriaException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

InvalidFilterCriteriaException Class | System.Reflection Namespace


InvalidFilterCriteriaException Constructor

Initializes an instance of the InvalidFilterCriteriaException class.

Overload List

Initializes an instance of InvalidFilterCriteriaException with the default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public InvalidFilterCriteriaException();
[C++] public: InvalidFilterCriteriaException();
[JScript] public function InvalidFilterCriteriaException();

Initializes an instance of InvalidFilterCriteriaException with the given HRESULT and message string.

[Visual Basic] Overloads Public Sub New(String)
[C#] public InvalidFilterCriteriaException(String);
[C++] public: InvalidFilterCriteriaException(String*);
[JScript] public function InvalidFilterCriteriaException(String);

Initializes an instance of InvalidFilterCriteriaException with the given message string and the given root cause exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public InvalidFilterCriteriaException(String, Exception);
[C++] public: InvalidFilterCriteriaException(String*, Exception);
[JScript] public function InvalidFilterCriteriaException(String, Exception);

See Also

InvalidFilterCriteriaException Class | InvalidFilterCriteriaException Members | System.Reflection Namespace


InvalidFilterCriteriaException Constructor ()

Initializes an instance of InvalidFilterCriteriaException with the default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public InvalidFilterCriteriaException();
[C++]
public: InvalidFilterCriteriaException();
[JScript]
public function InvalidFilterCriteriaException();

Remarks

InvalidFilterCriteriaException inherits from the Exception.

See Also

InvalidFilterCriteriaException Class | InvalidFilterCriteriaException Members | System.Reflection Namespace | InvalidFilterCriteriaException Constructor Overload List


InvalidFilterCriteriaException Constructor (String)

Initializes an instance of InvalidFilterCriteriaException with the given HRESULT and message string.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public InvalidFilterCriteriaException(
   string message
);
[C++]
public: InvalidFilterCriteriaException(
   String* message
);
[JScript]
public function InvalidFilterCriteriaException(
   message : String
);

Parameters

message
The message text for the exception.

Remarks

InvalidFilterCriteriaException inherits from the Exception. This constructor sets the properties of the Exception object as follows:

Property | Value
Message | The empty string.

See Also

InvalidFilterCriteriaException Class | InvalidFilterCriteriaException Members | System.Reflection Namespace | InvalidFilterCriteriaException Constructor Overload List


InvalidFilterCriteriaException Constructor (String, Exception)

Initializes an instance of InvalidFilterCriteriaException with the given message string and the given root cause exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public InvalidFilterCriteriaException(
   string message,
   Exception inner
);
[C++]
public: InvalidFilterCriteriaException(
   String* message,
   Exception* inner
);
[JScript]
public function InvalidFilterCriteriaException(
   message : String,
   inner : Exception
);

Parameters

message
The message text for the exception.
inner
A reference to an exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

InvalidFilterCriteriaException inherits from the Exception. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | null
Message | The empty string.

See Also

InvalidFilterCriteriaException Class | InvalidFilterCriteriaException Members | System.Reflection Namespace | InvalidFilterCriteriaException Constructor Overload List


IReflect Interface

Supports basic runtime member Reflection namespace.

IReflect

[Visual Basic]
Public Interface IReflect
[C#]
public interface IReflect
[C++]
public __gc __interface IReflect

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IReflect

Class | Description
Type | Represents type declarations: class types, interface types, array types, value types, and enumeration types.

Remarks

IReflect is an interface that defines a subset of the Type reflection methods. This interface is used to access and invoke members of a Type. It can be either type based (like Type) or instance based (like Expando). This interface is used in combination with IExpando to model the Microsoft.Win32.Interop.IDispatchEx expando capabilities.

The Reflection namespace is based upon abstract base classes, which represent members of instances. IReflect is an interface that allows objects to return MemberInfo objects which represent an object. This interface contains methods common to System.Runtime.InteropServices.Expando objects.

The Expando class implements the methods in this interface.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

IReflect Members | System.Reflection Namespace


IReflect Members

Properties

UnderlyingSystemType Retrieves the underlying Type that represents the IReflect object.

Methods

GetField | Retrieves the FieldInfo object corresponding to a specified field.
GetFields | Retrieves an array of FieldInfo objects corresponding to all fields of the current class.
GetMember | Retrieves an array of MemberInfo objects corresponding to all public members or to all members that match a specified name.
GetMembers | Retrieves an array of MemberInfo objects corresponding either to all public members or to all members of the current class.
GetMethod | Overloaded. Retrieves a MethodInfo object corresponding to a specified method.
GetMethods | Retrieves an array of MethodInfo objects with all public methods or all methods of the current class.
GetProperties | Retrieves an array of PropertyInfo objects corresponding to all public properties or to all properties of the current class.
GetProperty | Overloaded. Retrieves a PropertyInfo object corresponding to a specified property.
InvokeMember | Supports a specified member.

See Also

IReflect Interface | System.Reflection Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IReflect Properties

The properties of the IReflect interface are listed below. For a complete list of IReflect interface members, see the IReflect Members topic.

UnderlyingSystemType Retrieves the underlying Type that represents the IReflect object.

See Also

IReflect Interface | System.Reflection Namespace


IReflect.UnderlyingSystemType

Retrieves the underlying Type that represents the IReflect object.

[Visual Basic]
ReadOnly Property UnderlyingSystemType As Type
[C#]
Type UnderlyingSystemType {get;}
[C++]
Type* get_UnderlyingSystemType() = 0;
[JScript]
abstract function get UnderlyingSystemType() : Type;

Property Value

Read-only.

The underlying Type that represents the IReflect object.

Remarks

For expando object, the returned type is the (Object) IReflectInstance.GetType().

See Also

IReflect Interface | IReflect Members | System.Reflection Namespace | Object


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IReflect Methods

The methods of the IReflect interface are listed below. For a complete list of IReflect interface members, see the IReflect Members topic.

GetField | Retrieves the FieldInfo object corresponding to a specified field.
GetFields | Retrieves an array of FieldInfo objects corresponding to all fields of the current class.
GetMember | Retrieves an array of MemberInfo objects corresponding to all public members or to all members that match a specified name.
GetMembers | Retrieves an array of MemberInfo objects corresponding either to all public members or to all members of the current class.
GetMethod | Overloaded. Retrieves a MethodInfo object corresponding to a specified method.
GetMethods | Retrieves an array of MethodInfo objects with all public methods or all methods of the current class.
GetProperties | Retrieves an array of PropertyInfo objects corresponding to all public properties or to all properties of the current class.
GetProperty | Overloaded. Retrieves a PropertyInfo object corresponding to a specified property.
InvokeMember | Supports a specified member.

See Also

IReflect Interface | System.Reflection Namespace


IReflect.GetField

Retrieves the FieldInfo object corresponding to a specified field.

[Visual Basic]
Function GetField( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags _
) As FieldInfo
[C#]
FieldInfo GetField(
   string name,
   BindingFlags bindingAttr
);
[C++]
FieldInfo* GetField(
   String* name,
   BindingFlags bindingAttr
) = 0;
[JScript]
function GetField(
   name : String,
   bindingAttr : BindingFlags
) : FieldInfo;

Parameters

name
The name of the field to find.
bindingAttr
The binding attributes used to control the search.

Return Value

A FieldInfo object containing the field information for the named object.

Exceptions

Exception Type | Condition
AmbiguousMatchException | if the object implements multiple fields with the same name.

Remarks

The GetField method retrieves the FieldInfo object using the name and binding attributes parameters. The match is based upon the name of the field.

An example of a binding attribute value is IgnoreCase.

See Also

IReflect Interface | IReflect Members | System.Reflection Namespace | String | BindingFlags


IReflect.GetFields

Retrieves an array of FieldInfo objects corresponding to all fields of the current class.

[Visual Basic]
Function GetFields( _
   ByVal bindingAttr As BindingFlags _
) As FieldInfo ()
[C#]
FieldInfo[] GetFields(
   BindingFlags bindingAttr
);
[C++]
FieldInfo* GetFields(
   BindingFlags bindingAttr
) [] = 0;
[JScript]
function GetFields(
   bindingAttr : BindingFlags
) : FieldInfo[];

Parameters

bindingAttr
The binding attributes used to control the search.

Return Value

Returns an array of FieldInfo objects containing all the field information for this reflection object.

Remarks

The GetFields method retrieves an array of FieldInfo objects by using the binding attribute that correspond to all fields of the current class.

The match is based upon a name. Each field must have a unique name. The NonPublic flag indicates when non-public methods are considered; Public indicates when public methods are considered.

An example of a binding attribute value is IgnoreCase.

See Also

IReflect Interface | IReflect Members | System.Reflection Namespace | BindingFlags | BindingFlags


IReflect.GetMember

Retrieves an array of MemberInfo objects corresponding to all public members or to all members that match a specified name.

[Visual Basic]
Function GetMember( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags _
) As MemberInfo ()
[C#]
MemberInfo[] GetMember(
   string name,
   BindingFlags bindingAttr
);
[C++]
MemberInfo* GetMember(
   String* name,
   BindingFlags bindingAttr
) [] = 0;
[JScript]
function GetMember(
   name : String,
   bindingAttr : BindingFlags
) : MemberInfo[];

Parameters

name
The name of the member to find.
bindingAttr
The binding attributes used to control the search.

Return Value

An array of MemberInfo which match the passed in name.

Remarks

The GetMember method retrieves an array of MemberInfo objects by using the name and binding attributue that correspond to all public members or to all members that match a specified name. The case of the specified name is observed or ignored, as specified. An example of a binding attribute value is IgnoreCase.

See Also

IReflect Interface | IReflect Members | System.Reflection Namespace | String | BindingFlags


IReflect.GetMembers

Retrieves an array of MemberInfo objects corresponding either to all public members or to all members of the current class.

[Visual Basic]
Function GetMembers( _
   ByVal bindingAttr As BindingFlags _
) As MemberInfo ()
[C#]
MemberInfo[] GetMembers(
   BindingFlags bindingAttr
);
[C++]
MemberInfo* GetMembers(
   BindingFlags bindingAttr
) [] = 0;
[JScript]
function GetMembers(
   bindingAttr : BindingFlags
) : MemberInfo[];

Parameters

bindingAttr
The binding attributes used to control the search.

Return Value

An array of MemberInfo objects containing all the member information for this reflection object.

Remarks

The GetMembers method retrieves an array of MemberInfo objects by using the binding attribute that corresponds either to all public members or to all members of the current class. It returns an array of all of the members defined for this object.An example of a binding attribute is IgnoreCase.

See Also

IReflect Interface | IReflect Members | System.Reflection Namespace | BindingFlags


IReflect.GetMethod

Retrieves a MethodInfo object corresponding to a specified method.

Overload List

Retrieves a MethodInfo object corresponding to a specified method, and a type array is used to choose among overloaded methods with the same name.

[Visual Basic] Overloads Function GetMethod(String, BindingFlags, Binder, Type(), ParameterModifier()) As MethodInfo
[C#] MethodInfo GetMethod(String, BindingFlags, Binder, Type[], ParameterModifier[]);
[C++] MethodInfo* GetMethod(String*, BindingFlags, Binder, Type[], ParameterModifier[]) = 0;
[JScript] function GetMethod(String, BindingFlags, Binder, Type[], ParameterModifier[]) : MethodInfo;

Retrieves a MethodInfo object corresponding to a specified method under specified search constraints.

[Visual Basic] Overloads Function GetMethod(String, BindingFlags) As MethodInfo
[C#] MethodInfo GetMethod(String, BindingFlags);
[C++] MethodInfo* GetMethod(String*, BindingFlags) = 0;
[JScript] function GetMethod(String, BindingFlags) : MethodInfo;

See Also

IReflect Interface | IReflect Members | System.Reflection Namespace


IReflect.GetMethod (String, BindingFlags, Binder, Type[], ParameterModifier[])

Retrieves a MethodInfo object corresponding to a specified method, and a type array is used to choose among overloaded methods with the same name.

[Visual Basic]
Overloads Function GetMethod( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal types() As Type, _
   ByVal modifiers() As ParameterModifier _
) As MethodInfo
[C#]
MethodInfo GetMethod(
   string name,
   BindingFlags bindingAttr,
   Binder binder,
   Type[] types,
   ParameterModifier[] modifiers
);
[C++]
MethodInfo* GetMethod(
   String* name,
   BindingFlags bindingAttr,
   Binder* binder,
   Type* types[],
   ParameterModifier* modifiers[]
) = 0;
[JScript]
function GetMethod(
   name : String,
   bindingAttr : BindingFlags,
   binder : Binder,
   types : Type[],
   modifiers : ParameterModifier[]
) : MethodInfo;

Parameters

name
The name of the member to find.
bindingAttr
The binding attributes help control the search.
binder
An object which implements Binder, containing properties related to this method.
types
This array is used to choose among overloaded methods with the same name.
modifiers
[To be supplied.]

Return Value

The requested method.

Exceptions

Exception Type | Condition
AmbiguousMatchException | If the object implements multiple methods with the same name.

Remarks

The GetMethod method retrieves a MethodInfo object corresponding to a specified method, and a type array is used to choose among overloaded methods with the same name.An example of a binding attribute value is IgnoreCase. The return value is a match is based upon the name and System.Reflection.DescriptorInfo which describes the signature of the method.

See Also

IReflect Interface | IReflect Members | System.Reflection Namespace | IReflect.GetMethod Overload List | String | BindingFlags | Binder | Type | ParameterModifier


IReflect.GetMethod (String, BindingFlags)

Retrieves a MethodInfo object corresponding to a specified method under specified search constraints.

[Visual Basic]
Overloads Function GetMethod( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags _
) As MethodInfo
[C#]
MethodInfo GetMethod(
   string name,
   BindingFlags bindingAttr
);
[C++]
MethodInfo* GetMethod(
   String* name,
   BindingFlags bindingAttr
) = 0;
[JScript]
function GetMethod(
   name : String,
   bindingAttr : BindingFlags
) : MethodInfo;

Parameters

name
The name of the member to find.
bindingAttr
The binding attributes used to control the search.

Return Value

A MethodInfo object containing the method information, and the match is based upon the name of the method.

Exceptions

Exception Type | Condition
AmbiguousMatchException | If the object implements multiple methods with the same name.

Remarks

The GetMethod method retrieves a MethodInfo object that corresponds to a specified method that uses name and bind attributes parameters.

An example of a binding attribute value is IgnoreCase.

See Also

IReflect Interface | IReflect Members | System.Reflection Namespace | IReflect.GetMethod Overload List | String | BindingFlags


IReflect.GetMethods

Retrieves an array of MethodInfo objects with all public methods or all methods of the current class.

[Visual Basic]
Function GetMethods( _
   ByVal bindingAttr As BindingFlags _
) As MethodInfo ()
[C#]
MethodInfo[] GetMethods(
   BindingFlags bindingAttr
);
[C++]
MethodInfo* GetMethods(
   BindingFlags bindingAttr
) [] = 0;
[JScript]
function GetMethods(
   bindingAttr : BindingFlags
) : MethodInfo[];

Parameters

bindingAttr
The binding attributes help control the search.

Return Value

An array of MethodInfo objects containing all the methods defined for this reflection object.

Remarks

The GetMethods method retrieves an array of MethodInfo objects corresponding to all public methods or to all methods of the current class

The nonpublic attribute of bindingAttr is indicated only if public methods are returned.

An example of a binding attribute value is IgnoreCase.

See Also

IReflect Interface | IReflect Members | System.Reflection Namespace | BindingFlags | BindingFlags


IReflect.GetProperties

Retrieves an array of PropertyInfo objects corresponding to all public properties or to all properties of the current class.

[Visual Basic]
Function GetProperties( _
   ByVal bindingAttr As BindingFlags _
) As PropertyInfo ()
[C#]
PropertyInfo[] GetProperties(
   BindingFlags bindingAttr
);
[C++]
PropertyInfo* GetProperties(
   BindingFlags bindingAttr
) [] = 0;
[JScript]
function GetProperties(
   bindingAttr : BindingFlags
) : PropertyInfo[];

Parameters

bindingAttr
The binding attributes help control the search.

Return Value

An array of PropertyInfo objects for all the properties defined on the reflection object.

Remarks

The GetProperties method retrieves an array of PropertyInfo objects by using the binding attribute parameter that correspond to all public properties or to all properties of the current class.

The match is based upon a name.An example of a bind attribute value is IgnoreCase.

See Also

IReflect Interface | IReflect Members | System.Reflection Namespace | BindingFlags


IReflect.GetProperty

Retrieves a PropertyInfo object corresponding to a specified property.

Overload List

Retrieves a PropertyInfo object corresponding to a specified property with specified search constraints.

[Visual Basic] Overloads Function GetProperty(String, BindingFlags, Binder, Type(), ParameterModifier()) As PropertyInfo
[C#] PropertyInfo GetProperty(String, BindingFlags, Binder, Type[], ParameterModifier[]);
[C++] PropertyInfo* GetProperty(String*, BindingFlags, Binder, Type[], ParameterModifier[]) = 0;
[JScript] function GetProperty(String, BindingFlags, Binder, Type[], ParameterModifier[]) : PropertyInfo;

Retrieves a PropertyInfo object corresponding to a specified property under specified search constraints.

[Visual Basic] Overloads Function GetProperty(String, BindingFlags) As PropertyInfo
[C#] PropertyInfo GetProperty(String, BindingFlags);
[C++] PropertyInfo* GetProperty(String*, BindingFlags) = 0;
[JScript] function GetProperty(String, BindingFlags) : PropertyInfo;

See Also

IReflect Interface | IReflect Members | System.Reflection Namespace


IReflect.GetProperty (String, BindingFlags, Binder, Type[], ParameterModifier[])

Retrieves a PropertyInfo object corresponding to a specified property with specified search constraints.

[Visual Basic]
Overloads Function GetProperty( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal types() As Type, _
   ByVal modifiers() As ParameterModifier _
) As PropertyInfo
[C#]
PropertyInfo GetProperty(
   string name,
   BindingFlags bindingAttr,
   Binder binder,
   Type[] types,
   ParameterModifier[] modifiers
);
[C++]
PropertyInfo* GetProperty(
   String* name,
   BindingFlags bindingAttr,
   Binder* binder,
   Type* types[],
   ParameterModifier* modifiers[]
) = 0;
[JScript]
function GetProperty(
   name : String,
   bindingAttr : BindingFlags,
   binder : Binder,
   types : Type[],
   modifiers : ParameterModifier[]
) : PropertyInfo;

Parameters

name
The name of the member to find.
bindingAttr
The binding attributes help control the search.
binder
An object which implements Binder, containing properties related to this method.
types
This array is used to choose among overloaded methods with the same name.
modifiers
This array is used choose the modifiers.

Return Value

Value | Condition
A PropertyInfo object for the located property. | A property with the given name was located in this reflection object.
null | The property was not located.

Remarks

The GetProperty method retrieves a PropertyInfo object corresponding to a specified property under specified search constraints. A type array is used to choose among overloaded methods with the same name.

An example of a binding attribute value is IgnoreCase.

See Also

IReflect Interface | IReflect Members | System.Reflection Namespace | IReflect.GetProperty Overload List | ParameterModifier | Type | Binder | String | BindingFlags


IReflect.GetProperty (String, BindingFlags)

Retrieves a PropertyInfo object corresponding to a specified property under specified search constraints.

[Visual Basic]
Overloads Function GetProperty( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags _
) As PropertyInfo
[C#]
PropertyInfo GetProperty(
   string name,
   BindingFlags bindingAttr
);
[C++]
PropertyInfo* GetProperty(
   String* name,
   BindingFlags bindingAttr
) = 0;
[JScript]
function GetProperty(
   name : String,
   bindingAttr : BindingFlags
) : PropertyInfo;

Parameters

name
The name of the property to find.
bindingAttr
The binding attributes used to control the search.

Return Value

Value | Condition
A PropertyInfo object for the located property. | A property with the given name was located in this reflection object.
null | The property was not located.

Exceptions

Exception Type | Condition
AmbiguousMatchException | If the object implements multiple fields with the same name.

Remarks

The GetProperty method retrieves a PropertyInfo object that corresponds to a specified property using a specified name and binding attribute.An example of a binding attribute value is IgnoreCase.

See Also

IReflect Interface | IReflect Members | System.Reflection Namespace | IReflect.GetProperty Overload List | String | BindingFlags


IReflect.InvokeMember

Supports a specified member.

[Visual Basic]
Function InvokeMember( _
   ByVal name As String, _
   ByVal invokeAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal target As Object, _
   ByVal args() As Object, _
   ByVal modifiers() As ParameterModifier, _
   ByVal culture As CultureInfo, _
   ByVal namedParameters() As String _
) As Object
[C#]
object InvokeMember(
   string name,
   BindingFlags invokeAttr,
   Binder binder,
   object target,
   object[] args,
   ParameterModifier[] modifiers,
   CultureInfo culture,
   string[] namedParameters
);
[C++]
Object* InvokeMember(
   String* name,
   BindingFlags invokeAttr,
   Binder* binder,
   Object* target,
   Object* args[],
   ParameterModifier* modifiers[],
   CultureInfo* culture,
   String* namedParameters[]
) = 0;
[JScript]
function InvokeMember(
   name : String,
   invokeAttr : BindingFlags,
   binder : Binder,
   target : Object,
   args : Object[],
   modifiers : ParameterModifier[],
   culture : CultureInfo,
   namedParameters : String[]
) : Object;

Parameters

name
This aray is used to choose among overloaded methods with the same name.
invokeAttr
[To be supplied.]
binder
[To be supplied.]
target
The object on which to invoke the specified member.
args
[To be supplied.]
modifiers
[To be supplied.]
culture
[To be supplied.]
namedParameters
TBD

Exceptions

Exception Type | Condition
ArgumentException | If invokeAttr is CreateInstance and any one of the the other bit flags ae set. That is, if CreateInstance is set then none of the other flags should also be set.
ArgumentException | If invokeAttr is not CreateInstance and name is null.
ArgumentException | If invokeAttr isnot an invocation attribute from BindingFlags.
ArgumentException | If invokeAttr specifies both get and set for a property or field.
ArgumentException | If invokeAttr specifieds both field set and invoke method. args are provided for a field get.
ArgumentException | If more than one argument is specified for a field set.
MissingFieldException | The field or property cannot be found.
MissingMethodException | The method cannot be found.
SecurityException | There is an attempt to invoke a private member and the caller doesn not have the necessary ReflectionPermission NYI.

Remarks

The InvokeMember method invokes a specified member. The method that is to be invoked must be accessible and provide the most specific match with the specified argument list, under the constraints of the specified binder and invocation attributes.

A method will be invoked if the number of parameters in the method declaration equals the number of arguments in the specified argument list, and the type of each argument can be converted by the binder to the type of the parameter.

Note The array of parameter modifiers passed in to InvokeMember must contain a single parameter modifier. Only the first parameter modifier will be considered when determining which argument needs to be passed byref when exposed to COM.

The binder will find all of the matching methods. These methods are found based upon the type of binding requested (InvokeMethod, GetProperties, etc.). The set of methods is filtered by the name, number of arguments, and a set of search modifiers defined in the binder. After the method is selected, it will be invoked. Accessibility is checked at that point. The search may control which set of methods are searched based upon the accessibility attribute associated with the method. The BindToMethod method is responsible for selecting the method to be invoked. The default binder selects the most specific match.

See the spec for possible remarks. It describes the 'Binding Process' and may indeed relate to InvokeMember.

The invokeAttr parameter maybe a constructor, method, property, or field. A suitable invocation attribute must be specified. Note that is possible to invoke the default member of a class by passing the empty string as the name of the member.

The binder parameter must be a bit flag from BindingFlags (InvokeMethod, CreateInstance, GetField, SetField, GetProperty, or SetProperty).

The target parameter is ignored if the member is static.

The args parameter is an array of objects that contains the number, order, and type of the parameters of the member to be invoked. If there are no parameters, this should be null.

The modifiers parameter has attributes associated with it in the metadata. Currently, a parameter can have the following attributes: pdIn, pdOut, pdRetval, pdOptional, and pdHasDefault. Respecitively, these represent [in], [out], [retval], [optional], and a parameter that has a default value. They are used by various interoperability services. See the metadata specs fo details such as this.

The culture parameter is an instance of CultureInfo used to govern the coercion of types. If this is null, the CultureInfo fo hte current thread is used. (Note: for example, this is necessary to convert a String that represents 1000 to a Double value, since 1000 is represented differently by different cultures.)

Access restrictions are ignored for fully trusted code. That is, private constructors, methods, fields, and properties can be accessed and invoked via Reflection whenever the code is fully trusted.

Example

This managed C++ sample demonstrates how InvokeMember an be used to obtain the value of the Now property.

#import

using namespace Reflection;

#define NULL 0

void main()

{

Type *tDate = Type::GetType(L"System.DateTime");

Object result = tDate-> InvokeMember(L"Now", BindingFlags::GetProperty, NULL, NULL, new __managed Object[0];

Console::WriteLine(result.ToString());

}

/*

OUTPUT:

D:\CCOM>CORSDK\COMPILER\VC|cl.exe/EEi/c invokemember.cpp

Microsoft(R) 32-bit C/C++ Optiizing Compiler Vers. 13.00.8576 for 80x86 COM+

Copyright (C) Microsoft Corp 1992-1999. All rights reserved.

D:\CCOM>invokemember.exe

8/19/99 8:18:14 AM

*/

See Also

IReflect Interface | IReflect Members | System.Reflection Namespace | Object


MemberFilter Delegate

Represents a delegate that is used to filter a list of members represented in an array of MemberInfo objects.

[Visual Basic]
Public Delegate Sub MemberFilter( _
   ByVal m As MemberInfo, _
   ByVal filterCriteria As Object _
) As Boolean
[C#]
public delegate bool MemberFilter(
   MemberInfo m,
   object filterCriteria
);
[C++]
public __gc __delegate bool MemberFilter(
   MemberInfo* m,
   Object* filterCriteria
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the MemberFilter delegate declaration.

m
The MemberInfo object to which the filter is applied.
filterCriteria
An arbitrary object used to filter the list.

Remarks

Every subclass of a Delegate and MulticastDelegate has a constructor and an Invoke method. (See the code example in Delegate.)

The FindMembers method uses this delegate to filter the list of members that it returns.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

System.Reflection Namespace | Type


MemberInfo Class

Represents the class that is used to obtain information about the members of a class

Object
MemberInfo

[Visual Basic]
MustInherit Public Class MemberInfo
   Implements ICustomAttributeProvider
[C#]
public abstract class MemberInfo : ICustomAttributeProvider
[C++]
public __gc __abstract class MemberInfo : public
   ICustomAttributeProvider
[JScript]
public abstract class MemberInfo implements
   ICustomAttributeProvider

Remarks

The MemberInfo class is the abstract base class of the classes used to obtain information concerning the members (constructors, events, fields, methods, and properties) of a class.

This class introduces the basic functionality that all members provide.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

MemberInfo Members | System.Reflection Namespace


MemberInfo Members

Public:

Properties

DeclaringType | Retrieves the class that declares this member.
MemberType | Retrieves a the type of this member.
Name | Retrieves the name of this member.
ReflectedType | Retrieves the class object that was used to obtain this instance of MemberInfo.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCustomAttributes | Overloaded. Returns all attributes defined on this member.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsDefined | Returns a Boolean if one or more instance of attributeType is defined on this member.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Constructor

MemberInfo Constructor Initializes an instance of the MemberInfo class.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MemberInfo Class | System.Reflection Namespace


MemberInfo Constructor

Initializes an instance of the MemberInfo class.

[Visual Basic]
Protected Sub New()
[C#]
protected MemberInfo();
[C++]
protected: MemberInfo();
[JScript]
protected function MemberInfo();

Remarks

This is used primarily by the System.Runtime.InteropServices.Expando classes.

Only a subclass can create this MemberInfo class.

See Also

MemberInfo Class | MemberInfo Members | System.Reflection Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MemberInfo Properties

The properties of the MemberInfo class are listed below. For a complete list of MemberInfo class members, see the MemberInfo Members topic.

Public:

DeclaringType | Retrieves the class that declares this member.
MemberType | Retrieves a the type of this member.
Name | Retrieves the name of this member.
ReflectedType | Retrieves the class object that was used to obtain this instance of MemberInfo.

See Also

MemberInfo Class | System.Reflection Namespace


MemberInfo.DeclaringType

Retrieves the class that declares this member.

[Visual Basic]
MustOverride Public ReadOnly Property DeclaringType As Type
[C#]
public Type DeclaringType {abstract get;}
[C++]
public: __property virtual Type* get_DeclaringType() = 0;
[JScript]
public abstract function get DeclaringType() : Type;

Property Value

Read-only.

The Type object for the class that declares this member.

Remarks

The DeclaringType property retrieves a reference to the Type object for the type that declares this member. A member of a class (or interface) is either declared or inherited from a base class (or interface). The returned class may not be the same as the Type object used to obtain this MemberInfo object.

  • If the Type object from which this MemberInfo object was obtained did not declare this member, the DeclaringType will represent one of its base types.
  • If the Type object from which this MemberInfo object was obtained is a global member, the DeclaringType is null.

Note the example shown has a returned type of Empty and Object from a MemberInfo object from a System.Empty class.

Example

class Mymemberinfo{ public static int Main() { Console.WriteLine ("\nReflection.MemberInfo");

See Also

MemberInfo Class | MemberInfo Members | System.Reflection Namespace


MemberInfo.MemberType

Retrieves a the type of this member.

[Visual Basic]
MustOverride Public ReadOnly Property MemberType As MemberTypes
[C#]
public MemberTypes MemberType {abstract get;}
[C++]
public: __property virtual MemberTypes get_MemberType() = 0;
[JScript]
public abstract function get MemberType() : MemberTypes;

Property Value

Read-only.

An enumerated value from the MemberTypes class describing this member as a constructor, event, field, method, property, type information, all, or custom.

Remarks

The MemberTypes property retrieves a MemberTypes object that describes this member as constructor, event, field, method, property, type information, all, or custom.

The returned value is from the MemberTypes enumeration, an enumerated value from the MemberTypes class describing this member as a constructor, event, field, method, property, type information, all, or custom.

To get the MemberType property:

  • First get the class Type.
  • From the Type, get the MethodInfo array.
  • From the MethodInfo array, get the MemberTypes.

Example [C#]

[C#]

class Mymemberinfo
{
   public static int Main()
   {
      Console.WriteLine ("\nReflection.MemberInfo");

      //Get the Type and
MemberInfo
      Type MyType =
Type.GetType("System.Reflection.PropertyInfo");
      MemberInfo[] Mymemberinfoarray = MyType.GetMembers();

      //Get MemberType
method- display the 38th- 41th elements only
      Console.Write("\nThere are {0} members in "
         Mymemberinfoarray.Count);
      Console.Write("{0}.", MyType.FullName);

      for ( int counter =
37; counter <40; counter++)
      {
         Console.Write("\n" + counter +
". "
+ Mymemberinfoarray[counter].Name
+ " Member type - " +
EnumInfo.ToString(typeof(MemberTypes),
Mymemberinfoarray[counter].MemberType));
      }
      return 0;
   }
}
Produces the following output
Reflection.MemberInfo

There are 52 members in System.Reflection.PropertyInfo.
37. GetCanRead Member type - Method
38. GetCanWrite Member type - Method
39. MemberType Member type - Property
40. PropertyType Member type - Property

[To be supplied]

See Also

MemberInfo Class | MemberInfo Members | System.Reflection Namespace


MemberInfo.Name

Retrieves the name of this member.

[Visual Basic]
MustOverride Public ReadOnly Property Name As String
[C#]
public string Name {abstract get;}
[C++]
public: __property virtual String* get_Name() = 0;
[JScript]
public abstract function get Name() : String;

Property Value

Read-only.

A String containing the name of this member.

Remarks

A String containing the name of this member is returned. Only the simple name is returned, not the fully qualified name. For example, for a member System.Reflection.MemberTypes.Field, the Name property would be Field.

To get the Name property:

  • First get the class Type.
  • From the Type, get the MemberInfo array.
  • From a MemberInfo element of the array, obtain the Name property.

Example [C#]

The example listed below lists the Name and Declaring Type property of each member of the System.Empty class.

[C#]

class Mymemberinfo
{
   public static int Main()
   {
      Console.WriteLine ("\nReflection.MemberInfo");

      //Get the Type and
MemberInfo
      Type MyType =
Type.GetType("System.Empty");
      MemberInfo[] Mymemberinfoarray = MyType.GetMembers();

      //Get and display the
DeclaringType method
      Console.Write("\nThere are {0} members in ",
         Mymemberinfoarray.Count);
      Console.Write("{0}.", MyType.FullName);

      foreach (MemberInfo Mymemberinfo in Mymemberinfoarray)
      {
         Console.Write("\n" + Mymemberinfo.Name
+ " declaring type - " +
Mymemberinfo.DeclaringType);
      }

      return 0;
   }
}
Produces the following output
Reflection.MemberInfo

There are 14 members in System.Empty.
Value declaring type - System.Empty
GetType declaring type - System.Object
.
.
.
SetObjectData declaring type - System.Empty
.cctor declaring type - System.Empty

[To be supplied]

See Also

MemberInfo Class | MemberInfo Members | System.Reflection Namespace


MemberInfo.ReflectedType

Retrieves the class object that was used to obtain this instance of MemberInfo.

[Visual Basic]
MustOverride Public ReadOnly Property ReflectedType As Type
[C#]
public Type ReflectedType {abstract get;}
[C++]
public: __property virtual Type* get_ReflectedType() = 0;
[JScript]
public abstract function get ReflectedType() : Type;

Property Value

Read-only.

The Type object through which this MemberInfo object was obtained.

Remarks

The ReflectedType property retrieves the Type object that was used to obtain this instance of MemberInfo. A MemberInfo object represents a method on a particular class or interface.

In order to obtain a MethodInfo object:

  • The Type object that represents the class or interface that supports the method is queried. This property holds a reference to that Type object.
  • If the reflected type is the same class as the declaring class, the member is defined on the declaring class, not on a superclass.
  • If the Type object from which this MemberInfo object was obtained is a global member, the DeclaringType is null.

Example [C#]

[C#]

class Mymemberinfo
{
   public static int Main()
   {
      Console.WriteLine ("\nReflection.MemberInfo");

      //Get the Type and
MemberInfo
      Type MyType =
Type.GetType("System.Reflection.PropertyInfo");
      MemberInfo[] Mymemberinfoarray = MyType.GetMembers();

      //Display the ReflectedType
      Console.Write("\nMymemberinfoarray ReflectedType is
{0}",
         Mymemberinfoarray[0].ReflectedType);
      return 0;
   }
}
Produces the following output
Reflection.MemberInfo

Mymemberinfoarray ReflectedType is System.Reflection.PropertyInfo
[To be supplied]

See Also

MemberInfo Class | MemberInfo Members | System.Reflection Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MemberInfo Methods

The methods of the MemberInfo class are listed below. For a complete list of MemberInfo class members, see the MemberInfo Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCustomAttributes | Overloaded. Returns all attributes defined on this member.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsDefined | Returns a Boolean if one or more instance of attributeType is defined on this member.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MemberInfo Class | System.Reflection Namespace


MemberInfo.GetCustomAttributes

Returns all attributes defined on this member.

Overload List

Returns an array of all of the custom attributes.

[Visual Basic] Overloads MustOverride Public Function GetCustomAttributes() As Object ()
[C#] public abstract object[] GetCustomAttributes();
[C++] public: virtual Object* GetCustomAttributes() [] = 0;
[JScript] public abstract function GetCustomAttributes() : Object[];

Returns an array of custom attributes identified by Type.

[Visual Basic] Overloads MustOverride Public Function GetCustomAttributes(Type) As Object ()
[C#] public abstract object[] GetCustomAttributes(Type);
[C++] public: virtual Object* GetCustomAttributes(Type*) [] = 0;
[JScript] public abstract function GetCustomAttributes(Type) : Object[];

See Also

MemberInfo Class | MemberInfo Members | System.Reflection Namespace


MemberInfo.GetCustomAttributes ()

Returns an array of all of the custom attributes.

[Visual Basic]
Overloads MustOverride Public Function GetCustomAttributes() As Object ()
[C#]
public abstract object[] GetCustomAttributes();
[C++]
public: virtual Object* GetCustomAttributes() [] = 0;
[JScript]
public abstract function GetCustomAttributes() : Object[];

Return Value

An array of the all the custom attributes.

Remarks

The GetCustomAttributes method is an abstract method that will retrieve all the custom attributes and return an array. When implemented by a subclass, this method returns all of the custom attributes defined on this member.

See Also

MemberInfo Class | MemberInfo Members | System.Reflection Namespace | MemberInfo.GetCustomAttributes Overload List | Object | CustomAttributeBuilder


MemberInfo.GetCustomAttributes (Type)

Returns an array of custom attributes identified by Type.

[Visual Basic]
Overloads MustOverride Public Function GetCustomAttributes( _
   ByVal attributeType As Type _
) As Object ()
[C#]
public abstract object[] GetCustomAttributes(
   Type attributeType
);
[C++]
public: virtual Object* GetCustomAttributes(
   Type* attributeType
) [] = 0;
[JScript]
public abstract function GetCustomAttributes(
   attributeType : Type
) : Object[];

Parameters

attributeType
An array of custom attributes identified by Type

Return Value

Value | Condition
An array of custom attributes | Attributes are defined on this reflected member.
An empty array | No attributes are defined on this member.

Exceptions

Exception Type | Condition
TypeLoadException | If the custom attribute type can not be loaded.

Remarks

The GetCustomAttributes method is an abstract method that will retrieve one or more attribute types that are defined by this member.

See Also

MemberInfo Class | MemberInfo Members | System.Reflection Namespace | MemberInfo.GetCustomAttributes Overload List


MemberInfo.IsDefined

Returns a Boolean if one or more instance of attributeType is defined on this member.

[Visual Basic]
MustOverride Public Function IsDefined( _
   ByVal attributeType As Type _
) As Boolean
[C#]
public abstract bool IsDefined(
   Type attributeType
);
[C++]
public: virtual bool IsDefined(
   Type* attributeType
) = 0;
[JScript]
public abstract function IsDefined(
   attributeType : Type
) : Boolean;

Parameters

attributeType
The Type object to which the custom attributes are applied.

Return Value

Returns true if one or more instance of attributeType is defined on this member, otherwise false.

Remarks

The IsDefined method is an abstract method that retrieves a Boolean value when a custom attribute has been defined on the Type object . Otherwise a false is returned.

See Also

MemberInfo Class | MemberInfo Members | System.Reflection Namespace


MemberTypes Enumeration

Specifies a type of member.

[Visual Basic]
Public Enum MemberTypes
[C#]
public enum MemberTypes
[C++]
public enum MemberTypes

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

The MemberTypes enumeration is a subclass of MemberInfo and is a bit mask marking each type of Member that is defined as a subclass of MemberInfo. This enumeration matchs the CorTypeAttr defined in CorHdr.h.

These are returned by MemberType and are useful in switch statements. MemberTypes is returned by MemberInfo.MemberType and is useful in switch statements.

To obtain this MemberTypes value for a method:

  • First get a Type.
  • From the Type, get the MemberInfo array.
  • From the MemberInfo array, get the MemberType.

Members

Member Name | Description
All | All member types. (Constructor | Event | Field | Method | Property | TypeInfo).
Constructor | Constructor. It represents a ConstructorInfo member. Hex value of 0x01.
Custom | Custom member type. Hex value of 0x40.
Event | Event. It represents an EventInfo member. Hex value of 0x02.
Field | Field. It represents a FieldInfo member. Hex value of 0x04.
Method | Method. It represents a MethodInfo member. Hex value of 0x08.
NestedType | Extends MemberInfo.
Property | Property. It represents a PropertyInfo member. Hex value of 0x10.
TypeInfo | Type. It represents a TypeInfo member. Hex value of 0x20.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

Example

class membertypesenum

{

public static int Main(string[] args)

{

Console.WriteLine ("\nReflection.MemberTypes");

MemberTypes Mymembertypes;

//Get the type

Type Mytype = Type.GetType

("System.Reflection.ReflectionTypeLoadException");

//Get the MemberInfo array

MemberInfo[] Mymembersinfoarray = Mytype.GetMembers();

//Get and display the name and the MemberType for each member

foreach (MemberInfo Mymemberinfo in Mymembersinfoarray)

{

Console.Write ("\n" + Mymemberinfo.Name);

Mymembertypes = Mymemberinfo.MemberType;

Console.Write (" is a "

+ EnumInfo.ToString(Type.GetType(

"System.Reflection.MemberTypes"),Mymembertypes));

}

return 0;

}

}

Produces the following output

Reflection.MemberTypes

GetType is a Method

ToString is a Method

.

.

.

.ctor is a Constructor

Types is a Property

LoaderExceptions is a Property.

See Also

System.Reflection Namespace


MethodAttributes Enumeration

Comprises flags that specify the attributes of a method. These flags are defined in corhdr.h.

[Visual Basic]
Public Enum MethodAttributes
[C#]
public enum MethodAttributes
[C++]
public enum MethodAttributes

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

The MethodAttributes enumeration defines the attributes that can be associated with a method. This set of attributes is a combination of Enumeration and bit flags.

The enumerated value is a number representing the bitwise OR of the attributes implemented on the method. The attributes are logically bitwise OR'd in the following groups:

Member access masks. Use these masks to retrieve accessibility information:

  • MemberAccessMask = 0x0007
  • PrivateScope = 0x0000
  • Private = 0x0001
  • FamANDAssem = 0x0002
  • Assembly = 0x0003
  • Family = 0x0004
  • FamORAssem = 0x0005
  • Public = 0x0006

Method contract attributes:

  • Static = 0x0010
  • Final = 0x0020
  • Virtual = 0x0040
  • HideBySig = 0x0080

Vtable layout masks. Use these masks to retrieve vtable attributes.

  • VtableLayoutMask = 0x0100
  • ReuseSlot = 0x0000
  • NewSlot = 0x0100

Method implementation attributes:

  • Abstract = 0x0400
  • SpecialName = 0x0800

Interop attributes:

  • PinvokeImpl = 0x2000
  • UnmanagedExport = 0x0008
  • RTSpecialName = 0x1000

Reserved flags for runtime use only:

  • ReservedMask = 0xc000
  • HasSecurity = 0x4000
  • RequireSecObject = 0x8000

Members

Member Name | Description
Abstract | Indicates that the class does not provide an implementation of this method.
Assembly | Indicates that the method is accessible to any class of this assembly.
FamANDAssem | Indicates that the method is accessible only to members of this class and its subclasses.
Family | Indicates that the method is accessible only to members of this class and its subclasses.
FamORAssem | Indicates that the method is accesssible to subclasses anywhere, as well as to any class in the assembly.
Final | Indicates that the method cannot be overriden.
HasSecurity | Indicates that the method has security associated with it. Reserved flag for runtime use only.
HideBySig | Indicates that the method hides by name and signature; otherwise, by name only.
MemberAccessMask | Retrieves accessibility information.
NewSlot | Indicates that the method always gets a new slot in the vtable.
PinvokeImpl | Indicates that the method implementation is forwarded through PInvoke (Platform Invocation Services).
Private | Indicates that the method is accessible only to the current class and the parent class.
PrivateScope | Indicates that the member cannot be referenced.
Public | Indicates that the method is accessible to any object for which this object is in scope.
RequireSecObject | Indicates that the method calls another method containing security code. Reserved flag for runtime use only.
ReservedMask | Indicates a reserved flag for runtime use only.
ReuseSlot | Indicates that the method will reuse an existing slot in the vtable. This is the default behavior.
RTSpecialName | Indicates that the NGWS runtime checks the name encoding.
SpecialName | Indicates that the method is special. The name describes how this method is special.
Static | Indicates that the method is defined on the type; otherwise, it is defined per instance.
UnmanagedExport | Indicates that the managed method is exported by thunk to unmanaged code.
Virtual | Indicates that the method is virtual.
VtableLayoutMask | Retrieves vtable attributes.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

Example [C#]

[C#]

class methodattributesenum
{
   public void Mymethod (
      [in] int int1m, out
string str2m, ref string str3m)
   {
      str2m = "in
Mymethod";
   }

   public static int
Main(string[] args)
   {
      Console.WriteLine ("\nReflection.Parameterinfo");

      //Get the
MethodAttributes Enumeration of a method.

      //Get the type
      Type MyType =
Type.GetType("methodattributesenum");

      //Get and display
the method
      MethodBase
Mymethodbase = MyType.GetMethod("Mymethod");

Console.Write("\nMymethodbase = " + Mymethodbase);

      //Get the
MethodAttribute enumerated value
      MethodAttributes
Myattributes = Mymethodbase.Attributes;

      //Display the
attributes for the method
      Console.Write
("\nMyattributes = " + (int) Myattributes);
      //allow the next
write only if the attribute
      // is exactly a
defined attribute.
      if
(EnumInfo.IsDefined(Type.GetType(

"System.Reflection.MethodAttributes"),

(int)Myattributes))
         {
Console.Write
("\nToString = " + EnumInfo.ToString(

Type.GetType("System.Reflection.MethodAttributes"),

(int)Myattributes));
         }
      return 0;
   }
}
Produces the following output
Reflection.Parameterinfo

Mymethodbase = Void Mymethod (Int32, System.String ByRef,
System.String ByRef)
Myattributes = 6
ToString = Public

See Also

System.Reflection Namespace


MethodBase Class

The MethodBase class is the abstract base class for obtaining information about methods and constructors.

Object
MemberInfo
MethodBase

[Visual Basic]
MustInherit Public Class MethodBase
   Inherits MemberInfo
[C#]
public abstract class MethodBase : MemberInfo
[C++]
public __gc __abstract class MethodBase : public MemberInfo
[JScript]
public abstract class MethodBase extends MemberInfo

Remarks

MethodBase is the superclass of MethodInfo and ConstructorInfo.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

MethodBase Members | System.Reflection Namespace


MethodBase Members

Public:

Properties

Attributes | Retrieves the attributes for this method.
CallingConvention | Retrieves the calling conventions for this method.
DeclaringType (inherited from MemberInfo) | Retrieves the class that declares this member.
IsAbstract | Retrieves whether this is an abstract method.
IsAssembly | Retrieves whether this is an abstract method.
IsConstructor | If set, the method is a constructor.
IsFamily | If set, this method can be called by all subclasses, wherever they are, but not by unrelated classes.
IsFamilyAndAssembly | If set, this method can be called by subclasses if they are in the same assembly.
IsFamilyOrAssembly | If set, this method can be called by subclasses, wherever they are, and by all classes in the same assembly.
IsFinal | If set, this method cannot be overridden by a subclass.
IsHideBySig | [To be supplied.]
IsPrivate | If set, this method can be called only by other members of the class itself.
IsPublic | Retrieves whether this is a public method.
IsSpecialName | If set, this method has a special name.
IsStatic | If set, the method is static.
IsVirtual | Retrieves a value indicating whether the method is virtual.
MemberType (inherited from MemberInfo) | Retrieves a the type of this member.
MethodHandle | [To be supplied].
Name (inherited from MemberInfo) | Retrieves the name of this member.
ReflectedType (inherited from MemberInfo) | Retrieves the class object that was used to obtain this instance of MemberInfo.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCurrentMethod | Returns a MethodBase object representing the currently executing method.
GetCustomAttributes (inherited from MemberInfo) | Overloaded. Returns all attributes defined on this member.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetMethodFromHandle | [To be supplied].
GetMethodImplementationFlags | [To be supplied.]
GetParameters | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsDefined (inherited from MemberInfo) | Returns a Boolean if one or more instance of attributeType is defined on this member.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Constructor

MethodBase Constructor Initializes an instance of the MethodBase class.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MethodBase Class | System.Reflection Namespace


MethodBase Constructor

Initializes an instance of the MethodBase class.

[Visual Basic]
Protected Sub New()
[C#]
protected MethodBase();
[C++]
protected: MethodBase();
[JScript]
protected function MethodBase();

See Also

MethodBase Class | MethodBase Members | System.Reflection Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MethodBase Properties

The properties of the MethodBase class are listed below. For a complete list of MethodBase class members, see the MethodBase Members topic.

Public:

Attributes | Retrieves the attributes for this method.
CallingConvention | Retrieves the calling conventions for this method.
DeclaringType (inherited from MemberInfo) | Retrieves the class that declares this member.
IsAbstract | Retrieves whether this is an abstract method.
IsAssembly | Retrieves whether this is an abstract method.
IsConstructor | If set, the method is a constructor.
IsFamily | If set, this method can be called by all subclasses, wherever they are, but not by unrelated classes.
IsFamilyAndAssembly | If set, this method can be called by subclasses if they are in the same assembly.
IsFamilyOrAssembly | If set, this method can be called by subclasses, wherever they are, and by all classes in the same assembly.
IsFinal | If set, this method cannot be overridden by a subclass.
IsHideBySig | [To be supplied.]
IsPrivate | If set, this method can be called only by other members of the class itself.
IsPublic | Retrieves whether this is a public method.
IsSpecialName | If set, this method has a special name.
IsStatic | If set, the method is static.
IsVirtual | Retrieves a value indicating whether the method is virtual.
MemberType (inherited from MemberInfo) | Retrieves a the type of this member.
MethodHandle | [To be supplied].
Name (inherited from MemberInfo) | Retrieves the name of this member.
ReflectedType (inherited from MemberInfo) | Retrieves the class object that was used to obtain this instance of MemberInfo.

See Also

MethodBase Class | System.Reflection Namespace


MethodBase.Attributes

Retrieves the attributes for this method.

[Visual Basic]
MustOverride Public ReadOnly Property Attributes As _
   MethodAttributes
[C#]
public MethodAttributes Attributes {abstract get;}
[C++]
public: __property virtual MethodAttributes get_Attributes() = 0;
[JScript]
public abstract function get Attributes() : MethodAttributes;

Property Value

Read-only.

Remarks

All members have a set of attributes, which are defined in relation to the specific type of member.

To get the MethodAttributes, first get the type. From the type, get the method. From the method, get the MethodAttributes.

The Attributes is a MethodAttributes enumeration defining the attributes that may be associated with this method. This enumerated value can be used to determine the Public/ Private attributes of the method.

Example [C#]

[C#]

class methodbase
{
   public void Mymethod ( [in] int int1m, out string str2m, ref string str3m)
   {
      str2m = "in Mymethod";
   }

   public static int Main(string[] args)
   {
      Console.WriteLine ("\nReflection.MethodBase");

      //Get the MethodBase of a method.
      Type MyType = Type.GetType("methodbase");

      //Get and display the method
      MethodBase Mymethodbase = MyType.GetMethod("Mymethod");

      Console.Write("\nMymethodbase = " + Mymethodbase);

      //Get the MethodAttribute enumerated value
      MethodAttributes Myattributes = Mymethodbase.Attributes;

      //Display the attributes for the method
      Console.Write ("\nMyattributes = " + (int) Myattributes);
      //Allow the next write only if the attribute
      // is exactly a defined attribute.
      if (EnumInfo.IsDefined(Type.GetType("System.Reflection.MethodAttributes"),
         (int)Myattributes))
         {
Console.Write ("\nToString = " +
EnumInfo.ToString(Type.GetType("System.Reflection.MethodAttributes"),
   (int)Myattributes));
         }
      return 0;
   }
}

Produces the following output
Reflection.MethodBase

Mymethodbase = Void Mymethod (Int32, System.String ByRef, System.String ByRef)
Myattributes = 6
ToString = Public

See Also

MethodBase Class | MethodBase Members | System.Reflection Namespace


MethodBase.CallingConvention

Retrieves the calling conventions for this method.

[Visual Basic]
Overridable Public ReadOnly Property CallingConvention As _
   CallingConventions
[C#]
public CallingConventions CallingConvention {virtual get;}
[C++]
public: __property virtual CallingConventions
   get_CallingConvention();
[JScript]
public function get CallingConvention() : CallingConventions;

Property Value

Read-only. The CallingConventions for this method.

Remarks

[To be supplied.]

See Also

MethodBase Class | MethodBase Members | System.Reflection Namespace | CallingConventions


MethodBase.IsAbstract

Retrieves whether this is an abstract method.

[Visual Basic]
Public ReadOnly Property IsAbstract As Boolean
[C#]
public bool IsAbstract {get;}
[C++]
public: __property bool get_IsAbstract();
[JScript]
public function get IsAbstract() : Boolean;

Property Value

Read-only. true if the method is abstract; otherwise false.

Remarks

An abstract member is used on a base class and has no implementation supplied.

To get the MethodBase, first get the type. From the type, get the method. From the method, get the Methodbase. If the method base is other than a public method, it is protected and cannot be readily accessed. To access a non public method, in the GetMethod method, set the BindingFlags to NonPublic.

Example [C#]

[C#]

class methodbase
{
   public static int Main(string[] args)
   {
      Console.WriteLine ("\nReflection.MethodBase");

      //Get the MethodBase of two methods.

      //Get the types
      Type MyType1 = Type.GetType("System.Runtime.Serialization.Formatter");
      Type MyType2 = Type.GetType("System.Reflection.MethodBase");

      //Get and display the methods
      MethodBase Mymethodbase1 =
         MyType1.GetMethod("WriteInt32",BindingFlags.NonPublic);
      MethodBase Mymethodbase2 =
         MyType2.GetMethod("GetCurrentMethod", BindingFlags.NonPublic);

      Console.Write("\nMymethodbase = " + Mymethodbase1);
      if (Mymethodbase1.IsAbstract)
         Console.Write ("\nMymethodbase is an abstract method");
      else
         Console.Write ("\nMymethodbase is not an abstract method");

      Console.Write("\n\nMymethodbase = " + Mymethodbase2);
      if (Mymethodbase2.IsAbstract)
         Console.Write ("\nMymethodbase is an abstract method");
      else
         Console.Write ("\nMymethodbase is not an abstract method");

      return 0;
   }
}
Produces the following output
Reflection.MethodBase

Mymethodbase = Void WriteInt32 (Int32, System.String)
Mymethodbase is an abstract method

Mymethodbase = System.Reflection.MethodBase GetCurrentMethod ()
Mymethodbase is not an abstract method

See Also

MethodBase Class | MethodBase Members | System.Reflection Namespace | Boolean | BindingFlags


MethodBase.IsAssembly

Retrieves whether this is an abstract method.

[Visual Basic]
Public ReadOnly Property IsAssembly As Boolean
[C#]
public bool IsAssembly {get;}
[C++]
public: __property bool get_IsAssembly();
[JScript]
public function get IsAssembly() : Boolean;

Property Value

Read-only.

true if access to this method is restricted to the class itself and to other classes in the same assembly; otherwise, false.

Remarks

If set, this method can be called by other classes in the same assembly.

To get the MethodBase, first get the type. From the type, get the method. From the method, get the Methodbase. If the method base is other than a public method, it is protected and cannot be readily accessed. To access a non public method, in the GetMethod method, set the BindingFlags to NonPublic.

Example [C#]

[C#]

class methodbase
{
   public static int Main(string[] args)

      Console.WriteLine ("\nReflection.MethodBase");

      //Get the MethodBase of two methods.

      //Get the types
      Type MyType1 = Type.GetType("System.Runtime.Serialization.Formatter");
      Type MyType2 = Type.GetType("System.Variant");

      //Get and display the methods and the IsAssembly
      MethodBase Mymethodbase1 =
         MyType1.GetMethod("WriteInt32",BindingFlags.NonPublic);
      MethodBase Mymethodbase2 =
         MyType2.GetMethod("SetFieldsObject", BindingFlags.NonPublic);

      Console.Write("\nMymethodbase = " + Mymethodbase1);
      if (Mymethodbase1.IsAssembly)
         Console.Write ("\nMymethodbase is an assembly method");
      else
         Console.Write ("\nMymethodbase is not an assembly method");

      Console.Write("\n\nMymethodbase = " + Mymethodbase2);
      if (Mymethodbase2.IsAssembly)
         Console.Write ("\nMymethodbase is an assembly method");
      else
         Console.Write ("\nMymethodbase is not an assembly method");

      return 0;
   }
}
Produces the following output
Reflection.MethodBase

Mymethodbase = Void WriteInt32 (Int32, System.String)
Mymethodbase is not an assembly method

Mymethodbase = Void SetFieldsObject (System.Object)
Mymethodbase is an assembly method

See Also

MethodBase Class | MethodBase Members | System.Reflection Namespace | FieldAttributes | Boolean | BindingFlags


MethodBase.IsConstructor

If set, the method is a constructor.

[Visual Basic]
Public ReadOnly Property IsConstructor As Boolean
[C#]
public bool IsConstructor {get;}
[C++]
public: __property bool get_IsConstructor();
[JScript]
public function get IsConstructor() : Boolean;

Property Value

Read-only. true if this is method is a constructor; otherwise, false.

See Also

MethodBase Class | MethodBase Members | System.Reflection Namespace | Boolean


MethodBase.IsFamily

If set, this method can be called by all subclasses, wherever they are, but not by unrelated classes.

[Visual Basic]
Public ReadOnly Property IsFamily As Boolean
[C#]
public bool IsFamily {get;}
[C++]
public: __property bool get_IsFamily();
[JScript]
public function get IsFamily() : Boolean;

Property Value

Read-only.

true if access to the class is restricted to members of the class itself and to members of its subclasses; otherwise, false.

Remarks

If a type member has Family level visibility it can be called from any member in a derived class, but not from any other type.

See Also

MethodBase Class | MethodBase Members | System.Reflection Namespace | Boolean


MethodBase.IsFamilyAndAssembly

If set, this method can be called by subclasses if they are in the same assembly.

[Visual Basic]
Public ReadOnly Property IsFamilyAndAssembly As Boolean
[C#]
public bool IsFamilyAndAssembly {get;}
[C++]
public: __property bool get_IsFamilyAndAssembly();
[JScript]
public function get IsFamilyAndAssembly() : Boolean;

Property Value

Read-only.

true if access to this method is restricted to members of the class itself and to members of subclasses that are in the same assembly; otherwise, false.

See Also

MethodBase Class | MethodBase Members | System.Reflection Namespace | Boolean


MethodBase.IsFamilyOrAssembly

If set, this method can be called by subclasses, wherever they are, and by all classes in the same assembly.

[Visual Basic]
Public ReadOnly Property IsFamilyOrAssembly As Boolean
[C#]
public bool IsFamilyOrAssembly {get;}
[C++]
public: __property bool get_IsFamilyOrAssembly();
[JScript]
public function get IsFamilyOrAssembly() : Boolean;

Property Value

Read-only. true if access to this method is restricted to members of the class itself, members of subclasses wherever they are, and members of other classes in the same assembly; otherwise, false.

Remarks

If a type member has FamilyOrAssembly level visibility it can be called from any member in a derived class or any member in the same assembly, but not from any other type.

See Also

MethodBase Class | MethodBase Members | System.Reflection Namespace | Boolean


MethodBase.IsFinal

If set, this method cannot be overridden by a subclass.

[Visual Basic]
Public ReadOnly Property IsFinal As Boolean
[C#]
public bool IsFinal {get;}
[C++]
public: __property bool get_IsFinal();
[JScript]
public function get IsFinal() : Boolean;

Property Value

Read-only.

true if this method cannot be overridden by a subclass; otherwise, false.

See Also

MethodBase Class | MethodBase Members | System.Reflection Namespace | Boolean


MethodBase.IsHideBySig

[To be supplied.]

[Visual Basic]
Public ReadOnly Property IsHideBySig As Boolean
[C#]
public bool IsHideBySig {get;}
[C++]
public: __property bool get_IsHideBySig();
[JScript]
public function get IsHideBySig() : Boolean;

Property Value

Read-only.

See Also

MethodBase Class | MethodBase Members | System.Reflection Namespace


MethodBase.IsPrivate

If set, this method can be called only by other members of the class itself.

[Visual Basic]
Public ReadOnly Property IsPrivate As Boolean
[C#]
public bool IsPrivate {get;}
[C++]
public: __property bool get_IsPrivate();
[JScript]
public function get IsPrivate() : Boolean;

Property Value

Read-only.

true if access to this method is restricted to other members of the class itself; otherwise, false.

Remarks

If a type member has Private level visibility it can called from any member in the same class and no others.

See Also

MethodBase Class | MethodBase Members | System.Reflection Namespace | Boolean


MethodBase.IsPublic

Retrieves whether this is a public method.

[Visual Basic]
Public ReadOnly Property IsPublic As Boolean
[C#]
public bool IsPublic {get;}
[C++]
public: __property bool get_IsPublic();
[JScript]
public function get IsPublic() : Boolean;

Property Value

Read-only.

true if this method is public; otherwise, false.

Remarks

To get the MethodBase, first get the type. From the type, get the method. From the method, get the Methodbase. If the method base is other than a public method, it is protected and cannot be readily accessed. To access a non public method, in the GetMethod method, set the BindingFlags to NonPublic.

Example [C#]

[C#]

class
methodbase
{
   public static int Main(string[] args)
   {

      Console.WriteLine("\nReflection.MethodBase");

      //Get the MethodBase of a method.

      //Get the type
      Type MyType = Type.GetType("System.MulticastDelegate");

      //Get and display the method
      MethodBase Mymethodbase = MyType.GetMethod("RemoveImpl",BindingFlags.NonPublic);

      Console.Write("\nMymethodbase = " + Mymethodbase);

      bool Myispublic = Mymethodbase.IsPublic;
      if (Myispublic)
         Console.Write ("\nMymethodbase is a public method");
      else
         Console.Write ("\nMymethodbase is not a public method");

      return 0;
   }
}
Produces the following output

Reflection.MethodBase
Mymethodbase = System.Delegate RemoveImpl (System.Delegate)
Mymethodbase is not a public method

See Also

MethodBase Class | MethodBase Members | System.Reflection Namespace | Boolean | BindingFlags


MethodBase.IsSpecialName

If set, this method has a special name.

[Visual Basic]
Public ReadOnly Property IsSpecialName As Boolean
[C#]
public bool IsSpecialName {get;}
[C++]
public: __property bool get_IsSpecialName();
[JScript]
public function get IsSpecialName() : Boolean;

Property Value

Read-only.

true if this method has a special name; otherwise, false.

Remarks

The SpecialName bit is set to flag members that are treated in a special way by some compilers (such as Property accessors and operator overloading methods).

See Also

MethodBase Class | MethodBase Members | System.Reflection Namespace | Boolean | MethodAttributes


MethodBase.IsStatic

If set, the method is static.

[Visual Basic]
Public ReadOnly Property IsStatic As Boolean
[C#]
public bool IsStatic {get;}
[C++]
public: __property bool get_IsStatic();
[JScript]
public function get IsStatic() : Boolean;

Property Value

Read-only.

true if this method is static; otherwise, false.

Remarks

A static member cannot implicitly reference instance data in a class (see Static).

See Also

MethodBase Class | MethodBase Members | System.Reflection Namespace | Boolean | MethodAttributes


MethodBase.IsVirtual

Retrieves a value indicating whether the method is virtual.

[Visual Basic]
Public ReadOnly Property IsVirtual As Boolean
[C#]
public bool IsVirtual {get;}
[C++]
public: __property bool get_IsVirtual();
[JScript]
public function get IsVirtual() : Boolean;

Property Value

Read-only.

true if this method is virtual; otherwise, false.

Remarks

A virtual member may reference instance data in a class and must be referenced through an instance of the class.

See Also

MethodBase Class | MethodBase Members | System.Reflection Namespace


MethodBase.MethodHandle

[To be supplied].

[Visual Basic]
MustOverride Public ReadOnly Property MethodHandle As _
   RuntimeMethodHandle
[C#]
public RuntimeMethodHandle MethodHandle {abstract get;}
[C++]
public: __property virtual RuntimeMethodHandle get_MethodHandle() =
   0;
[JScript]
public abstract function get MethodHandle() : RuntimeMethodHandle;

Property Value

[To be supplied].

Remarks

[To be supplied.]

See Also

MethodBase Class | MethodBase Members | System.Reflection Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MethodBase Methods

The methods of the MethodBase class are listed below. For a complete list of MethodBase class members, see the MethodBase Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCurrentMethod | Returns a MethodBase object representing the currently executing method.
GetCustomAttributes (inherited from MemberInfo) | Overloaded. Returns all attributes defined on this member.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetMethodFromHandle | [To be supplied].
GetMethodImplementationFlags | [To be supplied.]
GetParameters | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsDefined (inherited from MemberInfo) | Returns a Boolean if one or more instance of attributeType is defined on this member.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MethodBase Class | System.Reflection Namespace


MethodBase.GetCurrentMethod

Returns a MethodBase object representing the currently executing method.

[Visual Basic]
Public Shared Function GetCurrentMethod() As MethodBase
[C#]
public static MethodBase GetCurrentMethod();
[C++]
public: static MethodBase* GetCurrentMethod();
[JScript]
public static function GetCurrentMethod() : MethodBase;

Return Value

Returns a MethodBase object representing the currently executing method.

Remarks

The MethodBase objects are equal if they have the same name and refer to the same System.Runtime.InteropServices.Expando object.

See Also

MethodBase Class | MethodBase Members | System.Reflection Namespace


MethodBase.GetMethodFromHandle

[To be supplied].

[Visual Basic]
Public Shared Function GetMethodFromHandle( _
   ByVal handle As RuntimeMethodHandle _
) As MethodBase
[C#]
public static MethodBase GetMethodFromHandle(
   RuntimeMethodHandle handle
);
[C++]
public: static MethodBase* GetMethodFromHandle(
   RuntimeMethodHandle handle
);
[JScript]
public static function GetMethodFromHandle(
   handle : RuntimeMethodHandle
) : MethodBase;

Parameters

handle
[To be supplied].

Return Value

[To be supplied]

Remarks

[To be supplied].

See Also

MethodBase Class | MethodBase Members | System.Reflection Namespace


MethodBase.GetMethodImplementationFlags

[To be supplied.]

[Visual Basic]
MustOverride Public Function GetMethodImplementationFlags() As _
   MethodImplAttributes
[C#]
public abstract MethodImplAttributes GetMethodImplementationFlags();
[C++]
public: virtual MethodImplAttributes GetMethodImplementationFlags()
   = 0;
[JScript]
public abstract function GetMethodImplementationFlags() :
   MethodImplAttributes;

See Also

MethodBase Class | MethodBase Members | System.Reflection Namespace


MethodBase.GetParameters

[To be supplied.]

[Visual Basic]
MustOverride Public Function GetParameters() As ParameterInfo ()
[C#]
public abstract ParameterInfo[] GetParameters();
[C++]
public: virtual ParameterInfo* GetParameters() [] = 0;
[JScript]
public abstract function GetParameters() : ParameterInfo[];

See Also

MethodBase Class | MethodBase Members | System.Reflection Namespace


MethodImplAttributes Enumeration

Comprises flags that specify the attributes of a method implementation.

[Visual Basic]
Public Enum MethodImplAttributes
[C#]
public enum MethodImplAttributes
[C++]
public enum MethodImplAttributes

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

MethodImplAttributes is an Enum defining the flags that are the methodimpl flags of a method.

The attributes are logically bitwise Or'd in the following groups.

code impl mask

CodeTypeMask = 0x0003

IL =0x0000

Native = 0x0001

OPTIL = 0x0002

Runtime = 0x0003

managed mask

ManagedMask = 0x0004

Unmanaged = 0x0004

Managed = 0x0000

implementation info and interop

ForwardRef = 0x0010

OLE = 0x0080

InternalCall=0x1000

Synchronized = 0x0020

NoInlining = 0x0008

OneWay = 0x0040

MaxMethodImplVal = 0xFFFF

Members

Member Name | Description
CodeTypeMask | Flags about code type.
ForwardRef | [To be supplied.]
IL | Represents that the method implementation is IL.
InternalCall | [To be supplied.]
Managed | [To be supplied.]
ManagedMask | [To be supplied.]
MaxMethodImplVal | [To be supplied.]
Native | Represents that the method implementation is native.
NoInlining | [To be supplied.]
OLE | [To be supplied.]
OneWay | [To be supplied.]
OPTIL | Represents that the method implementation is OPTIL.
Runtime | Represents that the method implementation is provided by the runtime.
Synchronized | [To be supplied.]
Unmanaged | Represents that the method implementation is unmanaged, otherwise managed.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

System.Reflection Namespace | System.Reflection


MethodInfo Class

Provides information about a method and a mechanism for calling the method. Instances of MethodInfo are created by invoking either the GetMethods or GetMethod method of a Type object.

Object
MemberInfo
MethodBase
MethodInfo

[Visual Basic]
MustInherit Public Class MethodInfo
   Inherits MethodBase
[C#]
public abstract class MethodInfo : MethodBase
[C++]
public __gc __abstract class MethodInfo : public MethodBase
[JScript]
public abstract class MethodInfo extends MethodBase

Remarks

When Type.GetMethod is called, the returned MethodInfo will appear to have a ToString method; it does not. This is due to an internal private class used by Type. This matter will be made clearer in a future release.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

MethodInfo Members | System.Reflection Namespace


MethodInfo Members

Public:

Properties

Attributes (inherited from MethodBase) | Retrieves the attributes for this method.
CallingConvention (inherited from MethodBase) | Retrieves the calling conventions for this method.
DeclaringType (inherited from MemberInfo) | Retrieves the class that declares this member.
IsAbstract (inherited from MethodBase) | Retrieves whether this is an abstract method.
IsAssembly (inherited from MethodBase) | Retrieves whether this is an abstract method.
IsConstructor (inherited from MethodBase) | If set, the method is a constructor.
IsFamily (inherited from MethodBase) | If set, this method can be called by all subclasses, wherever they are, but not by unrelated classes.
IsFamilyAndAssembly (inherited from MethodBase) | If set, this method can be called by subclasses if they are in the same assembly.
IsFamilyOrAssembly (inherited from MethodBase) | If set, this method can be called by subclasses, wherever they are, and by all classes in the same assembly.
IsFinal (inherited from MethodBase) | If set, this method cannot be overridden by a subclass.
IsHideBySig (inherited from MethodBase) | [To be supplied.]
IsPrivate (inherited from MethodBase) | If set, this method can be called only by other members of the class itself.
IsPublic (inherited from MethodBase) | Retrieves whether this is a public method.
IsSpecialName (inherited from MethodBase) | If set, this method has a special name.
IsStatic (inherited from MethodBase) | If set, the method is static.
IsVirtual (inherited from MethodBase) | Retrieves a value indicating whether the method is virtual.
MemberType | Retrieves a value indicating that this member is a method.
MethodHandle (inherited from MethodBase) | [To be supplied].
Name (inherited from MemberInfo) | Retrieves the name of this member.
ReflectedType (inherited from MemberInfo) | Retrieves the class object that was used to obtain this instance of MemberInfo.
ReturnType | When implemented by a subclass, this property retrieves the Type of this method's return value.
ReturnTypeCustomAttributes | Returns an object that represents the custom attributes for the return type.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseDefinition | When implemented by a subclass, this method returns the MethodInfo object for the method on the direct or indirect super class in which the method represented by this instance was first declared. This implementation merely throws an exception unless a subclass must override this implementation.
GetCustomAttributes (inherited from MemberInfo) | Overloaded. Returns all attributes defined on this member.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetMethodImplementationFlags (inherited from MethodBase) | [To be supplied.]
GetParameters (inherited from MethodBase) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
Invoke | Overloaded. Invokes the method reflected by this MethodInfo instance. Invokes the underlying method represented by this Method object, on the specified object with the specified parameters.
IsDefined (inherited from MemberInfo) | Returns a Boolean if one or more instance of attributeType is defined on this member.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Constructor

MethodInfo Constructor Initializes an instance of the MethodInfo class.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MethodInfo Class | System.Reflection Namespace


MethodInfo Constructor

Initializes an instance of the MethodInfo class.

[Visual Basic]
Protected Sub New()
[C#]
protected MethodInfo();
[C++]
protected: MethodInfo();
[JScript]
protected function MethodInfo();

See Also

MethodInfo Class | MethodInfo Members | System.Reflection Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MethodInfo Properties

The properties of the MethodInfo class are listed below. For a complete list of MethodInfo class members, see the MethodInfo Members topic.

Public:

Attributes (inherited from MethodBase) | Retrieves the attributes for this method.
CallingConvention (inherited from MethodBase) | Retrieves the calling conventions for this method.
DeclaringType (inherited from MemberInfo) | Retrieves the class that declares this member.
IsAbstract (inherited from MethodBase) | Retrieves whether this is an abstract method.
IsAssembly (inherited from MethodBase) | Retrieves whether this is an abstract method.
IsConstructor (inherited from MethodBase) | If set, the method is a constructor.
IsFamily (inherited from MethodBase) | If set, this method can be called by all subclasses, wherever they are, but not by unrelated classes.
IsFamilyAndAssembly (inherited from MethodBase) | If set, this method can be called by subclasses if they are in the same assembly.
IsFamilyOrAssembly (inherited from MethodBase) | If set, this method can be called by subclasses, wherever they are, and by all classes in the same assembly.
IsFinal (inherited from MethodBase) | If set, this method cannot be overridden by a subclass.
IsHideBySig (inherited from MethodBase) | [To be supplied.]
IsPrivate (inherited from MethodBase) | If set, this method can be called only by other members of the class itself.
IsPublic (inherited from MethodBase) | Retrieves whether this is a public method.
IsSpecialName (inherited from MethodBase) | If set, this method has a special name.
IsStatic (inherited from MethodBase) | If set, the method is static.
IsVirtual (inherited from MethodBase) | Retrieves a value indicating whether the method is virtual.
MemberType | Retrieves a value indicating that this member is a method.
MethodHandle (inherited from MethodBase) | [To be supplied].
Name (inherited from MemberInfo) | Retrieves the name of this member.
ReflectedType (inherited from MemberInfo) | Retrieves the class object that was used to obtain this instance of MemberInfo.
ReturnType | When implemented by a subclass, this property retrieves the Type of this method's return value.
ReturnTypeCustomAttributes | Returns an object that represents the custom attributes for the return type.

See Also

MethodInfo Class | System.Reflection Namespace


MethodInfo.MemberType

Retrieves a value indicating that this member is a method.

[Visual Basic]
Overridable Public ReadOnly Property MemberType As MemberTypes
[C#]
public MemberTypes MemberType {override get;}
[C++]
public: __property virtual MemberTypes get_MemberType();
[JScript]
public function get MemberType() : MemberTypes;

Property Value

Read-only. Returns a MemberTypes object indicating that this member is a method.

Remarks

This is used when this method is being tested as generic member.

To get the MemberType property, first get the class Type. From the Type, get the MethodInfo. From the MethodInfo, get the MemberType.

Example [C#]

[C#]

class MyMethodInfo
{
  public static int Main()
  {
      Console.WriteLine("\nReflection.MethodInfo");

      //Get the Type and
      MethodInfo Type MyType = Type.GetType("System.Reflection.FieldInfo");
      MethodInfo Mymethodinfo = MyType.GetMethod("GetValue");
      Console.Write("\n" + MyType.FullName + "." + Mymethodinfo.Name);

      //Get and display the MemberType property
      MemberTypes Mymembertypes = Mymethodinfo.MemberType;

      Console.Write("\nMemberType - {0} ",

      EnumInfo.ToString(typeof(MemberTypes), Mymembertypes));
      return 0;
   }
}

Produces the following output

Reflection.MethodInfo
System.Reflection.FieldInfo.GetValue
MemberType - Method

See Also

MethodInfo Class | MethodInfo Members | System.Reflection Namespace


MethodInfo.ReturnType

When implemented by a subclass, this property retrieves the Type of this method's return value.

[Visual Basic]
MustOverride Public ReadOnly Property ReturnType As Type
[C#]
public Type ReturnType {abstract get;}
[C++]
public: __property virtual Type* get_ReturnType() = 0;
[JScript]
public abstract function get ReturnType() : Type;

Property Value

Read-only. The Type of object this method returns.

Remarks

The return type of the method.

To get the return type property, first get the class Type. From the Type, get the MethodInfo. From the MethodInfo, get the ReturnType.

Example [C#]

[C#]

class Mymethodinfo
{
   public static int Main()
      {
      Console.WriteLine ("\nReflection.MethodInfo");

      //Get the Type and MethodInfo
      Type MyType = Type.GetType("System.Reflection.FieldInfo");
      MethodInfo Mymethodinfo = MyType.GetMethod("GetValue");
      Console.Write ("\n" + MyType.FullName + "." + Mymethodinfo.Name);

      //Get and display the ReturnType
      Console.Write ("\nReturnType - {0}", Mymethodinfo.ReturnType);
      return 0;
   }
}
Produces the following output

Reflection.MethodInfo
System.Reflection.FieldInfo.GetValue
ReturnType - System.Variant

See Also

MethodInfo Class | MethodInfo Members | System.Reflection Namespace


MethodInfo.ReturnTypeCustomAttributes

Returns an object that represents the custom attributes for the return type.

[Visual Basic]
MustOverride Public ReadOnly Property ReturnTypeCustomAttributes As _
   ICustomAttributeProvider
[C#]
public ICustomAttributeProvider ReturnTypeCustomAttributes
   {abstract get;}
[C++]
public: __property virtual ICustomAttributeProvider*
   get_ReturnTypeCustomAttributes() = 0;
[JScript]
public abstract function get ReturnTypeCustomAttributes() :
   ICustomAttributeProvider;

Example

See Also

MethodInfo Class | MethodInfo Members | System.Reflection Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MethodInfo Methods

The methods of the MethodInfo class are listed below. For a complete list of MethodInfo class members, see the MethodInfo Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseDefinition | When implemented by a subclass, this method returns the MethodInfo object for the method on the direct or indirect super class in which the method represented by this instance was first declared. This implementation merely throws an exception unless a subclass must override this implementation.
GetCustomAttributes (inherited from MemberInfo) | Overloaded. Returns all attributes defined on this member.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetMethodImplementationFlags (inherited from MethodBase) | [To be supplied.]
GetParameters (inherited from MethodBase) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
Invoke | Overloaded. Invokes the method reflected by this MethodInfo instance. Invokes the underlying method represented by this Method object, on the specified object with the specified parameters.
IsDefined (inherited from MemberInfo) | Returns a Boolean if one or more instance of attributeType is defined on this member.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MethodInfo Class | System.Reflection Namespace


MethodInfo.GetBaseDefinition

When implemented by a subclass, this method returns the MethodInfo object for the method on the direct or indirect super class in which the method represented by this instance was first declared.

This implementation merely throws an exception unless a subclass must override this implementation.

[Visual Basic]
MustOverride Public Function GetBaseDefinition() As MethodInfo
[C#]
public abstract MethodInfo GetBaseDefinition();
[C++]
public: virtual MethodInfo* GetBaseDefinition() = 0;
[JScript]
public abstract function GetBaseDefinition() : MethodInfo;

Remarks

For example, the FileStream class has a method named Close. This method is first declared in the Stream class. FileStream inherits from BufferedStream which inherits from Stream. If GetBaseDefinition is invoked on the MethodInfo that represents the Close method of FileStream, the MethodInfo for the Close method on Stream will be returned.

Return the parents definition for a method in an inheritance chain. Normally returns the base implementation for a method.

To get the GetBaseDefinition method, first get the class Type. From the Type, get the MethodInfo. From the MethodInfo, get the GetBaseDefinition.

Example [C#]

The following Managed C++ code sample demonstrates the functionality of GetBaseDefinition.

[C++]
#import <mscorlib.dll>
using namespace Reflection;

void main ()
{
    Type *type = Type::GetType(L"System.IO.FileStream");
    MethodInfo *method = type->GetMethod(L"Close");
    MethodInfo *baseMethod = method->GetBaseDefinition();
    Console::Write(L"The base definition of FileStream::Close is ");
    Console::WriteLine(L"{0}::{1}.", baseMethod->ReflectedType->Name,
      baseMethod->Name);
    /**
     * Output:
     * The base definition of FileStream::Close is Stream::Close.
     */
}

[C#]

class Mymethodinfo
{
   public static int Main()
      {
      Console.WriteLine ("\nReflection.MethodInfo");

      //Get the Type and MethodInfo
      Type MyType = Type.GetType("System.IO.FileStream");
      MethodInfo Mymethodinfo = MyType.GetMethod("Close");
      MethodInfo Mybasemethod = Mymethodinfo.GetBaseDefinition();

      //Get and display the Mymethodinfo GetBaseDefinition
      Console.Write ("\nThe base definition of "
         + MyType.FullName + "."
         + Mymethodinfo.Name +" is a "
         + Mymethodinfo.GetBaseDefinition());

      //Get and display the GetBaseDefinition
      Console.Write ("\nThe base definition of "
         + MyType.FullName + "."
         + Mymethodinfo.Name +" is "
         + Mybasemethod.ReflectedType + ":"
         + Mybasemethod.Name);

      return 0;
   }
}
Produces the following output

Reflection.MethodInfo
The base definition of System.IO.FileStream.Close is a Void Close ()
The base definition of System.IO.FileStream.Close is System.IO.Stream:Close

See Also

MethodInfo Class | MethodInfo Members | System.Reflection Namespace


MethodInfo.Invoke

Invokes the method reflected by this MethodInfo instance. Invokes the underlying method represented by this Method object, on the specified object with the specified parameters.

Overload List

When implemented by a subclass, this method invokes the reflected method with the given parameters.

[Visual Basic] Overloads MustOverride Public Function Invoke(Object, BindingFlags, Binder, Object(), CultureInfo) As Object
[C#] public abstract object Invoke(Object, BindingFlags, Binder, Object[], CultureInfo);
[C++] public: virtual Object* Invoke(Object*, BindingFlags, Binder, Object*[], CultureInfo) = 0;
[JScript] public abstract function Invoke(Object, BindingFlags, Binder, Object[], CultureInfo) : Object;

Invokes the method reflected by this instance using the given parameters

[Visual Basic] Overloads Public Function Invoke(Object, Object()) As Object
[C#] public object Invoke(Object, Object[]);
[C++] public: Object* Invoke(Object*, Object*[]);
[JScript] public function Invoke(Object, Object[]) : Object;

Example [C#]

The following Managed C++ sample demonstrates dynamic method lookup via reflection. Note that all of the invocations return 1, because the method in classes A and B is virtual.

Note This example shows how to use one of the overloaded versions of Invoke. For other examples that may be available, see the individual overload topics.
[C++]
#import <mscorlib.dll>
using namespace Reflection;

#define NULL 0

__managed class A
{
    public:
    virtual int method() { return 0;}
};

__managed class B : public A
{
    public:
    virtual int method() { return 1;}
};

void main ()
{
    A *objA = new A();
    B *objB = new B();

    Type *typeA = objA->GetType();
    Type *typeB = objB->GetType();

    MethodInfo *methodA = typeA->GetMethod(L"method");
    MethodInfo *methodB = typeB->GetMethod(L"method");

    Console::WriteLine(L"\tUsing reflection to invoke A::method on objB returns {0}.",
 dynamic_cast<Object *>(methodA->Invoke(objB, NULL)));
    Console::WriteLine(L"\tUsing Invoke on objB after converting to type A returns {0}.",
 dynamic_cast<Object *>(methodA->Invoke(dynamic_cast<A *>(objB), NULL)));

    Console::WriteLine(L"\r\nThe same behavior is seen when the method ");
    Console::WriteLine(L"is invoked without reflection:\r\n");

    Console::WriteLine(L"\tDirectly invoking B::method on objB returns {0}.",
 Int32::Box(objB->method()) );
    Console::WriteLine(L"\tDirectly invoking B::method on objB after converting to type A returns {0}.",
 Int32::Box(dynamic_cast<A *>(objB)->method()));
};

[C#]

public class A
{
   public virtual int method () {return 0;}
}

public class B
{
   public virtual int method () {return 1;}
}

class Mymethodinfo
{
   public static int Main()
   {
      Console.WriteLine ("\nReflection.MethodInfo");
      A MyA = new A();
      B MyB = new B();

      //Get the Type and MethodInfo
      Type MyTypea = Type.GetType("A");
      MethodInfo Mymethodinfoa = MyTypea.GetMethod("method");

      Type MyTypeb = Type.GetType("B");
      MethodInfo Mymethodinfob = MyTypeb.GetMethod("method");

      //Get and display the Invoke method
      Console.Write("\nFirst method - " + MyTypea.FullName + " returns " + Mymethodinfoa.Invoke(MyA, null));
      Console.Write("\nSecond method - " + MyTypeb.FullName + " returns " + Mymethodinfob.Invoke(MyB, null));

      return 0;
   }
}

Produces the following output

See Also

MethodInfo Class | MethodInfo Members | System.Reflection Namespace


MethodInfo.Invoke (Object, BindingFlags, Binder, Object[], CultureInfo)

When implemented by a subclass, this method invokes the reflected method with the given parameters.

[Visual Basic]
Overloads MustOverride Public Function Invoke( _
   ByVal obj As Object, _
   ByVal invokeAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal parameters() As Object, _
   ByVal culture As CultureInfo _
) As Object
[C#]
public abstract object Invoke(
   object obj,
   BindingFlags invokeAttr,
   Binder binder,
   object[] parameters,
   CultureInfo culture
);
[C++]
public: virtual Object* Invoke(
   Object* obj,
   BindingFlags invokeAttr,
   Binder* binder,
   Object* parameters[],
   CultureInfo* culture
) = 0;
[JScript]
public abstract function Invoke(
   obj : Object,
   invokeAttr : BindingFlags,
   binder : Binder,
   parameters : Object[],
   culture : CultureInfo
) : Object;

Parameters

obj
The object on which to invoke the method. If the method is static, this argument is ignored.
invokeAttr
[To be supplied.]
binder
[To be supplied.]
parameters
[To be supplied.]
culture
[To be supplied.]

Return Value

Returns a Variant containing the return value of the invoked method, or a null reference (in Visual Basic Nothing) if the method's return type is void. For example, if the method returns a Boolean, an instance of Variant with the appropriate Boolean value is returned. If the method has a void return type, a null reference (Nothing) is returned. Before calling the method, Invoke will check to see if the user has access permission and verify that the parameters are legal.

Exceptions

Exception Type | Condition
TargetException | obj is null. The method is non-static if the method is not declared or inherited by the class of obj.
ArgumentException | The number, type and order of parameters do not match the signature of the method reflected by this instance.
AccessException | The caller does not have permission to invoke the method. The method invoked is a class initializer.
TargetInvocationException | The invoked method throws an exception. TargetInvocationException.GetException() returns the exception.

Remarks

Dynamically invokes the method reflected by this instance on obj, and passes along the specified parameters. If the method is static, the obj parameter is ignored. For non-static methods, obj should be an instance of a class that inherits or declares the method and must be the same type as this class. If the method has no parameters, the value of the parameters parameter should be null. Otherwise the number, type, and order of elements in the parameters array should be identical to the number, type, and order of parameters for the method reflected by this instance.

You may not omit optional parameters in calls to Invoke. To invoke a method omitting optional parameters, you should call Type.InvokeMember instead.

For pass-by-value primitive parameters, normal widening are preformed (Int16-> Int32 for example). For pass-by-value reference parameters, normal reference widening are allowed (Derived class to base class and base class to interface type). However for pass-by-reference primitive parameters the types must match exactly. For pass-by-reference reference parameters the normal widening still apply.

For example, if the method reflected by this instance is declared as public boolean Compare(String a, String b), then parameters should be an array of Variants with length 2 such that parameters[0] = new Variant("SomeString1") and parameters[1] = new Variant("SomeString2").

Note that reflection uses dynamic method lookup when invoking virtual methods. For example, suppose that class B inherits from class A and both implement a virtual method named M. Now suppose that you have a MethodInfo object that represents M on class A. If you use the Invoke method to invoke M on an object of type B, then reflection will use the implementation given by class B. Even if the object of type B is cast to A, the implementation given by class B is used (see code sample below).

On the other hand, if the method is non-virtual then reflection will use the implementation given by the type from which the MethodInfo was obtained, regardless of the type of the object passed as the target.

Access restrictions are ignored for fully trusted code. That is, private constructors, methods, fields, and properties can be accessed and invoked via reflection whenever the code is fully trusted.

If the invoked method throws an exception, TargetInvocationException.GetException() returns the exception. This implementation throws NotSupportedException.

Example [C#]

The following Managed C++ sample demonstrates dynamic method lookup via reflection. Note that all of the invocations return 1, because the method in classes A and B is virtual.

[C++]
#import <mscorlib.dll>
using namespace Reflection;

#define NULL 0

__managed class A
{
    public:
    virtual int method() { return 0;}
};

__managed class B : public A
{
    public:
    virtual int method() { return 1;}
};

void main ()
{
    A *objA = new A();
    B *objB = new B();

    Type *typeA = objA->GetType();
    Type *typeB = objB->GetType();

    MethodInfo *methodA = typeA->GetMethod(L"method");
    MethodInfo *methodB = typeB->GetMethod(L"method");

    Console::WriteLine(L"\tUsing reflection to invoke A::method on objB returns {0}.",
 dynamic_cast<Object *>(methodA->Invoke(objB, NULL)));
    Console::WriteLine(L"\tUsing Invoke on objB after converting to type A returns {0}.",
 dynamic_cast<Object *>(methodA->Invoke(dynamic_cast<A *>(objB), NULL)));

    Console::WriteLine(L"\r\nThe same behavior is seen when the method ");
    Console::WriteLine(L"is invoked without reflection:\r\n");

    Console::WriteLine(L"\tDirectly invoking B::method on objB returns {0}.",
 Int32::Box(objB->method()) );
    Console::WriteLine(L"\tDirectly invoking B::method on objB after converting to type A returns {0}.",
 Int32::Box(dynamic_cast<A *>(objB)->method()));
};

[C#]

public class A
{
   public virtual int method () {return 0;}
}

public class B
{
   public virtual int method () {return 1;}
}

class Mymethodinfo
{
   public static int Main()
   {
      Console.WriteLine ("\nReflection.MethodInfo");
      A MyA = new A();
      B MyB = new B();

      //Get the Type and MethodInfo
      Type MyTypea = Type.GetType("A");
      MethodInfo Mymethodinfoa = MyTypea.GetMethod("method");

      Type MyTypeb = Type.GetType("B");
      MethodInfo Mymethodinfob = MyTypeb.GetMethod("method");

      //Get and display the Invoke method
      Console.Write("\nFirst method - " + MyTypea.FullName + " returns " + Mymethodinfoa.Invoke(MyA, null));
      Console.Write("\nSecond method - " + MyTypeb.FullName + " returns " + Mymethodinfob.Invoke(MyB, null));

      return 0;
   }
}

Produces the following output

See Also

MethodInfo Class | MethodInfo Members | System.Reflection Namespace | MethodInfo.Invoke Overload List


MethodInfo.Invoke (Object, Object[])

Invokes the method reflected by this instance using the given parameters

[Visual Basic]
Overloads Public Function Invoke( _
   ByVal obj As Object, _
   ByVal parameters() As Object _
) As Object
[C#]
public object Invoke(
   object obj,
   object[] parameters
);
[C++]
public: Object* Invoke(
   Object* obj,
   Object* parameters[]
);
[JScript]
public function Invoke(
   obj : Object,
   parameters : Object[]
) : Object;

Parameters

obj
This object must be the object instance that created this method.
parameters
[To be supplied.]

Return Value

Returns a Variant containing the return value of the invoked method.

Exceptions

Exception Type | Condition
TargetException | obj is null. The method is non-static and it is not declared or inherited by the class of obj.
ArgumentException | The number, type and order of parameters do not match the signature of the method reflected by this instance.
AccessException | The caller does not have permission to invoke the method. The method invoked is a class initializer.

Remarks

This method is a convenience method that calls the following Invoke method, passing null in the other parameters.

If the invoked method throws an exception, TargetInvocationException.GetException() returns the exception.

You may not omit optional parameters with the Invoke method. If you must do so, use Type.InvokeMember instead.

See Also

MethodInfo Class | MethodInfo Members | System.Reflection Namespace | MethodInfo.Invoke Overload List


Missing Class

This class represents a missing Object.

Object
Missing

[Visual Basic]
NotInheritable Public Class Missing
[C#]
public sealed class Missing
[C++]
public __gc __sealed class Missing
[JScript]
public class Missing

Remarks

Like DBNull and Empty, only one instance of Missing ever exists.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

Missing Members | System.Reflection Namespace | DBNull | Empty


Missing Members

Public:

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Value Represents the sole instance of the Missing class.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Missing Class | System.Reflection Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Missing Fields

The fields of the Missing class are listed below. For a complete list of Missing class members, see the Missing Members topic.

Public:

Value Represents the sole instance of the Missing class.

See Also

Missing Class | System.Reflection Namespace


Missing.Value

Represents the sole instance of the Missing class.

[Visual Basic]
Public Shared ReadOnly Value As Missing
[C#]
public static readonly Missing Value;
[C++]
public: static readonly Missing* Value;
[JScript]
public static var Value : Missing;

See Also

Missing Class | Missing Members | System.Reflection Namespace


Module Class

The Module class reflects a module. A module is a portable executable file of type .dll or .exe consisting of one or more classes and interfaces. One or more modules that are deployed as a unit compose an assembly.

Object
Module

[Visual Basic]
Public Class Module
   Implements ISerializable, ICustomAttributeProvider
[C#]
public class Module : ISerializable, ICustomAttributeProvider
[C++]
public __gc class Module : public ISerializable,
   ICustomAttributeProvider
[JScript]
public class Module implements ISerializable,
   ICustomAttributeProvider

Remarks

There may be multiple namespaces contained in a single module and a namespace may be span multiple modules.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

Module Members | System.Reflection Namespace


Module Members

Public:

Properties

Assembly | Returns the appropriate Assembly for this instance of Module.
FullyQualifiedName | Returns the fully qualified name and path to this Module.
Name | Returns the name of the module with the path removed.
ScopeName | Returns a String representing the Name of the Module.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FindTypes | Returns an array of classes accepted by the given filter and filter criteria.
GetCaller | Returns a Module representing the module to which the caller belongs.
GetCustomAttributes | Overloaded. [To be supplied.]
GetField | Overloaded. [To be supplied.]
GetFields | To be supplied
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetMethod | Overloaded. [To be supplied.]
GetMethods | Returns an array of all of the global methods defined on the Module.
GetObjectData | [To be supplied.]
GetSignerCertificate | [To be supplied.]
GetType | Overloaded. [To be supplied.]
GetTypes | Returns all the classes defined within this module.
IsDefined | Determines if the attributeType is defined on this module.
ToString | Returns the name of the module.

Fields

FilterTypeName | Represents a TypeFilter object that filters the list of Types defined in this Module based upon the name (case sensitive).
FilterTypeNameIgnoreCase | Represents a TypeFilter object that filters the list of types defined in this Module based upon the name (case insensitive).

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetMethodImpl | To be supplied.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Module Class | System.Reflection Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Module Properties

The properties of the Module class are listed below. For a complete list of Module class members, see the Module Members topic.

Public:

Assembly | Returns the appropriate Assembly for this instance of Module.
FullyQualifiedName | Returns the fully qualified name and path to this Module.
Name | Returns the name of the module with the path removed.
ScopeName | Returns a String representing the Name of the Module.

See Also

Module Class | System.Reflection Namespace


Module.Assembly

Returns the appropriate Assembly for this instance of Module.

[Visual Basic]
Public ReadOnly Property Assembly As Assembly
[C#]
public Assembly Assembly {get;}
[C++]
public: __property Assembly* get_Assembly();
[JScript]
public function get Assembly() : Assembly;

Property Value

Read-only.

Remarks

[To be supplied]

See Also

Module Class | Module Members | System.Reflection Namespace


Module.FullyQualifiedName

Returns the fully qualified name and path to this Module.

[Visual Basic]
Public ReadOnly Property FullyQualifiedName As String
[C#]
public string FullyQualifiedName {get;}
[C++]
public: __property String* get_FullyQualifiedName();
[JScript]
public function get FullyQualifiedName() : String;

Property Value

Read-only.

Remarks

To get the name, without the path, use Name.

See Also

Module Class | Module Members | System.Reflection Namespace


Module.Name

Returns the name of the module with the path removed.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}
[C++]
public: __property String* get_Name();
[JScript]
public function get Name() : String;

Property Value

Read-only.

Remarks

To get the name and the path, use FullyQualifiedName.

See Also

Module Class | Module Members | System.Reflection Namespace


Module.ScopeName

Returns a String representing the Name of the Module.

[Visual Basic]
Public ReadOnly Property ScopeName As String
[C#]
public string ScopeName {get;}
[C++]
public: __property String* get_ScopeName();
[JScript]
public function get ScopeName() : String;

Property Value

Read-only.

Remarks

[To be supplied]

See Also

Module Class | Module Members | System.Reflection Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Module Methods

The methods of the Module class are listed below. For a complete list of Module class members, see the Module Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FindTypes | Returns an array of classes accepted by the given filter and filter criteria.
GetCaller | Returns a Module representing the module to which the caller belongs.
GetCustomAttributes | Overloaded. [To be supplied.]
GetField | Overloaded. [To be supplied.]
GetFields | To be supplied
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetMethod | Overloaded. [To be supplied.]
GetMethods | Returns an array of all of the global methods defined on the Module.
GetObjectData | [To be supplied.]
GetSignerCertificate | [To be supplied.]
GetType | Overloaded. [To be supplied.]
GetTypes | Returns all the classes defined within this module.
IsDefined | Determines if the attributeType is defined on this module.
ToString | Returns the name of the module.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetMethodImpl | To be supplied.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Module Class | System.Reflection Namespace


Module.FindTypes

Returns an array of classes accepted by the given filter and filter criteria.

[Visual Basic]
Overridable Public Function FindTypes( _
   ByVal filter As TypeFilter, _
   ByVal filterCriteria As Object _
) As Type ()
[C#]
public virtual Type[] FindTypes(
   TypeFilter filter,
   object filterCriteria
);
[C++]
public: virtual Type* FindTypes(
   TypeFilter* filter,
   Object* filterCriteria
) [];
[JScript]
public function FindTypes(
   filter : TypeFilter,
   filterCriteria : Object
) : Type[];

Parameters

filter
The delegate used to filter the classes.
filterCriteria
An Object used to filter the classes.

Return Value

Returns an array of classes that were accepted by the filter.

Exceptions

Exception Type | Condition
ReflectionTypeLoadException | if any of the classes in a module are not able to be loaded. This is a special class load exception. It contains the array of classes (Types property) that were defined in the module and were loaded. This array may contain some null values. There is also another array of exceptions (LoaderExceptions property). This array represents the exceptions that were thrown by the class loader. The holes in the class array line up with the exceptions.

Remarks

The delegate given by filter is called for each class in the module, passing along the Type object representing the class as well as the given filterCriteria. If filter returns true the class will be included in the returned array. If filter is null then all classes are returned and the filterCriteria will be ignored.

See Also

Module Class | Module Members | System.Reflection Namespace


Module.GetCaller

Returns a Module representing the module to which the caller belongs.

[Visual Basic]
Public Shared Function GetCaller() As Module
[C#]
public static Module GetCaller();
[C++]
public: static Module* GetCaller();
[JScript]
public static function GetCaller() : Module;

Return Value

Returns a Module representing the immediate caller.

Remarks

The caller is the thread that called the static method in this module.

See Also

Module Class | Module Members | System.Reflection Namespace


Module.GetCustomAttributes

[To be supplied.]

Overload List

To be supplied

[Visual Basic] Overloads Overridable Public Function GetCustomAttributes(Type) As Object ()
[C#] public virtual object[] GetCustomAttributes(Type);
[C++] public: virtual Object* GetCustomAttributes(Type*) [];
[JScript] public function GetCustomAttributes(Type) : Object[];

To be supplied

[Visual Basic] Overloads Overridable Public Function GetCustomAttributes() As Object ()
[C#] public virtual object[] GetCustomAttributes();
[C++] public: virtual Object* GetCustomAttributes() [];
[JScript] public function GetCustomAttributes() : Object[];

See Also

Module Class | Module Members | System.Reflection Namespace


Module.GetCustomAttributes (Type)

To be supplied

[Visual Basic]
Overloads Overridable Public Function GetCustomAttributes( _
   ByVal attributeType As Type _
) As Object ()
[C#]
public virtual object[] GetCustomAttributes(
   Type attributeType
);
[C++]
public: virtual Object* GetCustomAttributes(
   Type* attributeType
) [];
[JScript]
public function GetCustomAttributes(
   attributeType : Type
) : Object[];

Parameters

attributeType
[To be supplied]

Return Value

Returns a Module representing the immediate caller.

Remarks

The caller is the thread that called the static method in this module.

See Also

Module Class | Module Members | System.Reflection Namespace | Module.GetCustomAttributes Overload List


Module.GetCustomAttributes ()

To be supplied

[Visual Basic]
Overloads Overridable Public Function GetCustomAttributes() As Object ()
[C#]
public virtual object[] GetCustomAttributes();
[C++]
public: virtual Object* GetCustomAttributes() [];
[JScript]
public function GetCustomAttributes() : Object[];

See Also

Module Class | Module Members | System.Reflection Namespace | Module.GetCustomAttributes Overload List


Module.GetField

[To be supplied.]

Overload List

Returns the specified Module. If the module is not currently loaded, it will be loaded.

[Visual Basic] Overloads Public Function GetField(String, BindingFlags) As FieldInfo
[C#] public FieldInfo GetField(String, BindingFlags);
[C++] public: FieldInfo* GetField(String*, BindingFlags);
[JScript] public function GetField(String, BindingFlags) : FieldInfo;

Returns the specified Module. If the module is not currently loaded, it will be loaded.

[Visual Basic] Overloads Public Function GetField(String) As FieldInfo
[C#] public FieldInfo GetField(String);
[C++] public: FieldInfo* GetField(String*);
[JScript] public function GetField(String) : FieldInfo;

See Also

Module Class | Module Members | System.Reflection Namespace


Module.GetField (String, BindingFlags)

Returns the specified Module. If the module is not currently loaded, it will be loaded.

[Visual Basic]
Overloads Public Function GetField( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags _
) As FieldInfo
[C#]
public FieldInfo GetField(
   string name,
   BindingFlags bindingAttr
);
[C++]
public: FieldInfo* GetField(
   String* name,
   BindingFlags bindingAttr
);
[JScript]
public function GetField(
   name : String,
   bindingAttr : BindingFlags
) : FieldInfo;

Parameters

name
To be supplied
bindingAttr
[To be supplied.]

Return Value

Value | Condition
To be supplied. | To be supplied
To be supplied | To be supplied

Remarks

[To be supplied.]

See Also

Module Class | Module Members | System.Reflection Namespace | Module.GetField Overload List


Module.GetField (String)

Returns the specified Module. If the module is not currently loaded, it will be loaded.

[Visual Basic]
Overloads Public Function GetField( _
   ByVal name As String _
) As FieldInfo
[C#]
public FieldInfo GetField(
   string name
);
[C++]
public: FieldInfo* GetField(
   String* name
);
[JScript]
public function GetField(
   name : String
) : FieldInfo;

Parameters

name
To be supplied

Return Value

Value | Condition
To be supplied. | To be supplied
To be supplied | To be supplied

Remarks

[To be supplied.]

See Also

Module Class | Module Members | System.Reflection Namespace | Module.GetField Overload List


Module.GetFields

To be supplied

[Visual Basic]
Public Function GetFields() As FieldInfo ()
[C#]
public FieldInfo[] GetFields();
[C++]
public: FieldInfo* GetFields() [];
[JScript]
public function GetFields() : FieldInfo[];

Return Value

Value | Condition
To be supplied. | To be supplied
To be supplied | To be supplied

Remarks

[To be supplied.]

See Also

Module Class | Module Members | System.Reflection Namespace


Module.GetMethod

[To be supplied.]

Overload List

To be supplied

[Visual Basic] Overloads Public Function GetMethod(String) As MethodInfo
[C#] public MethodInfo GetMethod(String);
[C++] public: MethodInfo* GetMethod(String*);
[JScript] public function GetMethod(String) : MethodInfo;

To be supplied

[Visual Basic] Overloads Public Function GetMethod(String, Type()) As MethodInfo
[C#] public MethodInfo GetMethod(String, Type[]);
[C++] public: MethodInfo* GetMethod(String*, Type[]);
[JScript] public function GetMethod(String, Type[]) : MethodInfo;

To be supplied

[Visual Basic] Overloads Public Function GetMethod(String, BindingFlags, Binder, CallingConventions, Type(), ParameterModifier()) As MethodInfo
[C#] public MethodInfo GetMethod(String, BindingFlags, Binder, CallingConventions, Type[], ParameterModifier[]);
[C++] public: MethodInfo* GetMethod(String*, BindingFlags, Binder, CallingConventions, Type[], ParameterModifier[]);
[JScript] public function GetMethod(String, BindingFlags, Binder, CallingConventions, Type[], ParameterModifier[]) : MethodInfo;

See Also

Module Class | Module Members | System.Reflection Namespace


Module.GetMethod (String)

To be supplied

[Visual Basic]
Overloads Public Function GetMethod( _
   ByVal name As String _
) As MethodInfo
[C#]
public MethodInfo GetMethod(
   string name
);
[C++]
public: MethodInfo* GetMethod(
   String* name
);
[JScript]
public function GetMethod(
   name : String
) : MethodInfo;

Parameters

name
[To be supplied]

Return Value

[To be supplied]

Exceptions

Exception Type | Condition
ArgumentNullException | is thrown if name is null.

See Also

Module Class | Module Members | System.Reflection Namespace | Module.GetMethod Overload List


Module.GetMethod (String, Type[])

To be supplied

[Visual Basic]
Overloads Public Function GetMethod( _
   ByVal name As String, _
   ByVal types() As Type _
) As MethodInfo
[C#]
public MethodInfo GetMethod(
   string name,
   Type[] types
);
[C++]
public: MethodInfo* GetMethod(
   String* name,
   Type* types[]
);
[JScript]
public function GetMethod(
   name : String,
   types : Type[]
) : MethodInfo;

Parameters

name
To be supplied.
types
To be supplied.

Return Value

To be supplied

Exceptions

Exception Type | Condition
ArgumentNullException | is thrown if name is null, types is null, or types (i) is null.

See Also

Module Class | Module Members | System.Reflection Namespace | Module.GetMethod Overload List


Module.GetMethod (String, BindingFlags, Binder, CallingConventions, Type[], ParameterModifier[])

To be supplied

[Visual Basic]
Overloads Public Function GetMethod( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal callConvention As CallingConventions, _
   ByVal types() As Type, _
   ByVal modifiers() As ParameterModifier _
) As MethodInfo
[C#]
public MethodInfo GetMethod(
   string name,
   BindingFlags bindingAttr,
   Binder binder,
   CallingConventions callConvention,
   Type[] types,
   ParameterModifier[] modifiers
);
[C++]
public: MethodInfo* GetMethod(
   String* name,
   BindingFlags bindingAttr,
   Binder* binder,
   CallingConventions callConvention,
   Type* types[],
   ParameterModifier* modifiers[]
);
[JScript]
public function GetMethod(
   name : String,
   bindingAttr : BindingFlags,
   binder : Binder,
   callConvention : CallingConventions,
   types : Type[],
   modifiers : ParameterModifier[]
) : MethodInfo;

Parameters

name
To be supplied.
bindingAttr
To be supplied.
binder
To be supplied.
callConvention
To be supplied.
types
To be supplied.
modifiers
To be supplied.

Return Value

To be supplied

Exceptions

Exception Type | Condition
ArgumentNullException | is thrown if name is null, types is null, or types (i) is null.

Remarks

[To be supplied.]

See Also

Module Class | Module Members | System.Reflection Namespace | Module.GetMethod Overload List


Module.GetMethodImpl

To be supplied.

[Visual Basic]
Overridable Protected Function GetMethodImpl( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal callConvention As CallingConventions, _
   ByVal types() As Type, _
   ByVal modifiers() As ParameterModifier _
) As MethodInfo
[C#]
protected virtual MethodInfo GetMethodImpl(
   string name,
   BindingFlags bindingAttr,
   Binder binder,
   CallingConventions callConvention,
   Type[] types,
   ParameterModifier[] modifiers
);
[C++]
protected: virtual MethodInfo* GetMethodImpl(
   String* name,
   BindingFlags bindingAttr,
   Binder* binder,
   CallingConventions callConvention,
   Type* types[],
   ParameterModifier* modifiers[]
);
[JScript]
protected function GetMethodImpl(
   name : String,
   bindingAttr : BindingFlags,
   binder : Binder,
   callConvention : CallingConventions,
   types : Type[],
   modifiers : ParameterModifier[]
) : MethodInfo;

Parameters

name
To be supplied.
bindingAttr
To be supplied.
binder
To be supplied.
callConvention
To be supplied.
types
To be supplied.
modifiers
To be supplied.

Return Value

To be supplied

Exceptions

Exception Type | Condition
AmbiguousMatchException | is thrown if types is null.

Remarks

[To be supplied.]

See Also

Module Class | Module Members | System.Reflection Namespace


Module.GetMethods

Returns an array of all of the global methods defined on the Module.

[Visual Basic]
Public Function GetMethods() As MethodInfo ()
[C#]
public MethodInfo[] GetMethods();
[C++]
public: MethodInfo* GetMethods() [];
[JScript]
public function GetMethods() : MethodInfo[];

Return Value

[To be supplied]

Remarks

[To be supplied.]

See Also

Module Class | Module Members | System.Reflection Namespace


Module.GetObjectData

[To be supplied.]

[Visual Basic]
Overridable Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
public: virtual void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
);
[JScript]
public function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);

Parameters

info
[To be supplied.]
context
[To be supplied.]

See Also

Module Class | Module Members | System.Reflection Namespace


Module.GetSignerCertificate

[To be supplied.]

[Visual Basic]
Public Function GetSignerCertificate() As X509Certificate
[C#]
public X509Certificate GetSignerCertificate();
[C++]
public: X509Certificate* GetSignerCertificate();
[JScript]
public function GetSignerCertificate() : X509Certificate;

See Also

Module Class | Module Members | System.Reflection Namespace


Module.GetType

[To be supplied.]

Overload List

Returns the class by the given name, performing a case-sensitive search.

[Visual Basic] Overloads Overridable Public Function GetType(String) As Type
[C#] public virtual Type GetType(String);
[C++] public: virtual Type* GetType(String*);
[JScript] public function GetType(String) : Type;

Returns the class by the given name, searching the module with the specified case sensitivity.

[Visual Basic] Overloads Public Function GetType(String, Boolean) As Type
[C#] public Type GetType(String, bool);
[C++] public: Type* GetType(String*, bool);
[JScript] public function GetType(String, Boolean) : Type;

See Also

Module Class | Module Members | System.Reflection Namespace


Module.GetType (String)

Returns the class by the given name, performing a case-sensitive search.

[Visual Basic]
Overloads Overridable Public Function GetType( _
   ByVal className As String _
) As Type
[C#]
public virtual Type GetType(
   string className
);
[C++]
public: virtual Type* GetType(
   String* className
);
[JScript]
public function GetType(
   className : String
) : Type;

Parameters

className
The name of the class to locate. The name must be fully qualified with the namespace.

Return Value

Value | Condition
A Type object representing the given classname. | The classname is located in this Module.
null | Otherwise.

Exceptions

Exception Type | Condition
ArgumentException | if className is null.
TargetInvocationException | if the class initializers are invoked and an exception is thrown.

See Also

Module Class | Module Members | System.Reflection Namespace | Module.GetType Overload List


Module.GetType (String, Boolean)

Returns the class by the given name, searching the module with the specified case sensitivity.

[Visual Basic]
Overloads Public Function GetType( _
   ByVal className As String, _
   ByVal ignoreCase As Boolean _
) As Type
[C#]
public Type GetType(
   string className,
   bool ignoreCase
);
[C++]
public: Type* GetType(
   String* className,
   bool ignoreCase
);
[JScript]
public function GetType(
   className : String,
   ignoreCase : Boolean
) : Type;

Parameters

className
The name of the class to locate. The name must be fully qualified with the namespace.
ignoreCase
If ignoreCase is true then the search for className is case-insensitive; otherwise the search is case-sensitive.

Return Value

Value | Condition
A Type object representing the given classname. | The classname is located in this Module.
null | Otherwise.

Exceptions

Exception Type | Condition
ArgumentException | className is a null reference (in Visual Basic Nothing).
TargetInvocationException | The class initializers are invoked and an exception is thrown.

See Also

Module Class | Module Members | System.Reflection Namespace | Module.GetType Overload List


Module.GetTypes

Returns all the classes defined within this module.

[Visual Basic]
Public Function GetTypes() As Type ()
[C#]
public Type[] GetTypes();
[C++]
public: Type* GetTypes() [];
[JScript]
public function GetTypes() : Type[];

Return Value

Returns an array of classes defined within the module that is reflected by this instance.

Exceptions

Exception Type | Condition
ReflectionTypeLoadException | Any class in a module is unable to be loaded. This is a special class load exception. It contains the array of classes (Types property) that were defined in the module and were loaded. This array may contain some null values. There is also another array of exceptions (LoaderExceptions property). This array represents the exceptions that were thrown by the class loader. The holes in the class array line up with the exceptions.For example, if the class initializers of one of the classes throws an exception while it is being loaded, a TargetInvocationException is stored in the corresponding element of the LoaderExceptions array.
SecurityException | The caller does not have the required permission.

Remarks

[To be supplied.]

Requirements

NGWS Runtime Security:

ReflectionPermission Reflection permission for the current module.

See Also

Module Class | Module Members | System.Reflection Namespace


Module.IsDefined

Determines if the attributeType is defined on this module.

[Visual Basic]
Overridable Public Function IsDefined( _
   ByVal attributeType As Type _
) As Boolean
[C#]
public virtual bool IsDefined(
   Type attributeType
);
[C++]
public: virtual bool IsDefined(
   Type* attributeType
);
[JScript]
public function IsDefined(
   attributeType : Type
) : Boolean;

Parameters

attributeType
The Type object to which the custom attributes is applied.

Return Value

Returns true if one or more instance of attributeType is defined on this module.

Exceptions

Exception Type | Condition
ArgumentNullException | if the attributeType is null.

Remarks

[To be supplied.]

See Also

Module Class | Module Members | System.Reflection Namespace


Module.ToString

Returns the name of the module.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

Returns a String representing the name of this module.

See Also

Module Class | Module Members | System.Reflection Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Module Fields

The fields of the Module class are listed below. For a complete list of Module class members, see the Module Members topic.

Public:

FilterTypeName | Represents a TypeFilter object that filters the list of Types defined in this Module based upon the name (case sensitive).
FilterTypeNameIgnoreCase | Represents a TypeFilter object that filters the list of types defined in this Module based upon the name (case insensitive).

See Also

Module Class | System.Reflection Namespace


Module.FilterTypeName

Represents a TypeFilter object that filters the list of Types defined in this Module based upon the name (case sensitive).

[Visual Basic]
Public Shared ReadOnly FilterTypeName As TypeFilter
[C#]
public static readonly TypeFilter FilterTypeName;
[C++]
public: static readonly TypeFilter* FilterTypeName;
[JScript]
public static var FilterTypeName : TypeFilter;

Remarks

Filters the list of Types defined in this Module based upon the Name. The filter is case sensitive and supports a trailing "*" wildcard.

See Also

Module Class | Module Members | System.Reflection Namespace


Module.FilterTypeNameIgnoreCase

Represents a TypeFilter object that filters the list of types defined in this Module based upon the name (case insensitive).

[Visual Basic]
Public Shared ReadOnly FilterTypeNameIgnoreCase As TypeFilter
[C#]
public static readonly TypeFilter FilterTypeNameIgnoreCase;
[C++]
public: static readonly TypeFilter* FilterTypeNameIgnoreCase;
[JScript]
public static var FilterTypeNameIgnoreCase : TypeFilter;

Remarks

Filters the list of Types defined in this Module based upon the Name The filter is case insensitive and supports a trailing "*" wildcard.

See Also

Module Class | Module Members | System.Reflection Namespace


ParameterAttributes Enumeration

Obtains the flags that define the attributes of a method parameter. The attributes can be used to determine if the parameter is an in parameter, an out parameter, etc.

[Visual Basic]
Public Enum ParameterAttributes
[C#]
public enum ParameterAttributes
[C++]
public enum ParameterAttributes

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

ParameterAttributes is an enum defining the attributes that may be associated with a Parameter. This enumerated value can be used to determine the In/ Out attributes of the parameter.

To get the ParameterAttributes value, first get the Type. From the Type, get the ParameterInfo array. The ParameterAttributes is within the array.

These enumerator values are dependent on optional metadata. Not all attributes are available from all compilers. See the appropriate compiler instructions to determine which enumerated values are available.

The attributes are logically bitwise Or'd in the following groups.

Flags

None = 0x0000

In = 0x0001

Out = 0x0002

Lcid = 0x0004

Retval = 0x0008

Optional = 0x0010

Reserved flags for Runtime use only.

ReservedMask = 0xf000,

HasDefault = 0x1000

HasFieldMarshal = 0x2000

Reserved3 = 0x4000

Reserved4 = 0x8000

Members

Member Name | Description
HasDefault | [To be supplied.]
HasFieldMarshal | [To be supplied.]
In | [To be supplied.]
Lcid | [To be supplied.]
None | [To be supplied.]
Optional | [To be supplied.]
Out | [To be supplied.]
Reserved3 | [To be supplied.]
Reserved4 | [To be supplied.]
ReservedMask | [To be supplied.]
Retval | [To be supplied.]

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

Example [C#]

[C#]

class paramatt
{
   public static void mymethod ([in] string str1, [out] string str2,
      ref string str3)
   {
   }
   public static int Main(string[] args)
   {
      Console.WriteLine("\nReflection.ParameterAttributes");

      //Get the Type and the method.

      Type Mytype = Type.GetType("paramatt");
      MethodBase Mymethodbase = Mytype.GetMethod("mymethod");

      //Display the method
     Console.Write("\nMymethodbase = " + Mymethodbase);

      //Get the ParameterInfo array
      ParameterInfo[] Myarray = Mymethodbase.GetParameters();

      //Get and display the attributes for the second parameter
      ParameterAttributes Myparamattributes = Myarray[1].Attributes;

      Console.Write("\nFor the second parameter:\nMyparamattributes = "
         + (int) Myparamattributes
         + ", which is a "
         + EnumInfo.ToString(Type.GetType( "System.Reflection.ParameterAttributes"),
         Myparamattributes));

      return 0;
   }
}
Produces the following output

Reflection.ParameterAttributes

Mymethodbase = Void mymethod (System.String, System.String,
System.String ByRef)

For the second parameter:
Myparamattributes = 2, which is a Out

See Also

System.Reflection Namespace


ParameterInfo Class

The ParameterInfo class reflects a parameter. Instances of this class are used to obtain information about the type of a parameter, the default value, etc.

Object
ParameterInfo

[Visual Basic]
Public Class ParameterInfo
   Implements ICustomAttributeProvider
[C#]
public class ParameterInfo : ICustomAttributeProvider
[C++]
public __gc class ParameterInfo : public ICustomAttributeProvider
[JScript]
public class ParameterInfo implements ICustomAttributeProvider

Remarks

MethodBase.GetParameters() returns an array of ParameterInfo objects representing the parameters of a method, in order.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

ParameterInfo Members | System.Reflection Namespace


ParameterInfo Members

Public:

Constructor

ParameterInfo Constructor Overloaded. Initializes an instance of the ParameterInfo class.

Properties

Attributes | Retrieves the attributes for this parameter.
DefaultValue | Retrieves the default value of the parameter.
IsIn | Retrieves whether this is an input parameter.
IsLcid | Retrieves whether this is an Lcid parameter. Retrieves whether the culture identifier is set for the current ParameterInfo.
IsOptional | Retrieves whether this parameter is optional.
IsOut | Retrieves whether this is an output parameter.
IsRetval | Retrieves whether this is a Retval parameter.
Member | [To be supplied].
Name | Retrieves the name of the parameter.
ParameterType | Retrieves the Type of this parameter.
Position | Retrieves the signature position for the parameter.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCustomAttributes | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsDefined | Determines if the attributeType is defined on this member.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Constructor

ParameterInfo Constructor Overloaded. Initializes an instance of the ParameterInfo class.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

AttrsImpl | The attributes of the parameter.
ClassImpl | The Type of the parameter.
DefaultValueImpl | The default value of the parameter.
MemberImpl | [To be supplied]
NameImpl | The name of the parameter.
PositionImpl | The position of the parameter.

See Also

ParameterInfo Class | System.Reflection Namespace


ParameterInfo Constructor

Initializes an instance of the ParameterInfo class.

Overload List

Initializes an instance of the ParameterInfo class.

[Visual Basic] Overloads Protected Sub New()
[C#] protected ParameterInfo();
[C++] protected: ParameterInfo();
[JScript] protected function ParameterInfo();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Type, String, Integer, ParameterAttributes)
[C#] public ParameterInfo(Type, String, int, ParameterAttributes);
[C++] public: ParameterInfo(Type*, String, int, ParameterAttributes);
[JScript] public function ParameterInfo(Type, String, int, ParameterAttributes);

See Also

ParameterInfo Class | ParameterInfo Members | System.Reflection Namespace


ParameterInfo Constructor ()

Initializes an instance of the ParameterInfo class.

[Visual Basic]
Overloads Protected Sub New()
[C#]
protected ParameterInfo();
[C++]
protected: ParameterInfo();
[JScript]
protected function ParameterInfo();

See Also

ParameterInfo Class | ParameterInfo Members | System.Reflection Namespace | ParameterInfo Constructor Overload List


ParameterInfo Constructor (Type, String, Int32, ParameterAttributes)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal cls As Type, _
   ByVal name As String, _
   ByVal pos As Integer, _
   ByVal attrs As ParameterAttributes _
)
[C#]
public ParameterInfo(
   Type cls,
   string name,
   int pos,
   ParameterAttributes attrs
);
[C++]
public: ParameterInfo(
   Type* cls,
   String* name,
   int pos,
   ParameterAttributes attrs
);
[JScript]
public function ParameterInfo(
   cls : Type,
   name : String,
   pos : int,
   attrs : ParameterAttributes
);

Parameters

cls
A Type of class. The class that represents the type of the parameter.
name
[To be supplied.]
pos
[To be supplied.]
attrs
[To be supplied.]

See Also

ParameterInfo Class | ParameterInfo Members | System.Reflection Namespace | ParameterInfo Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ParameterInfo Properties

The properties of the ParameterInfo class are listed below. For a complete list of ParameterInfo class members, see the ParameterInfo Members topic.

Public:

Attributes | Retrieves the attributes for this parameter.
DefaultValue | Retrieves the default value of the parameter.
IsIn | Retrieves whether this is an input parameter.
IsLcid | Retrieves whether this is an Lcid parameter. Retrieves whether the culture identifier is set for the current ParameterInfo.
IsOptional | Retrieves whether this parameter is optional.
IsOut | Retrieves whether this is an output parameter.
IsRetval | Retrieves whether this is a Retval parameter.
Member | [To be supplied].
Name | Retrieves the name of the parameter.
ParameterType | Retrieves the Type of this parameter.
Position | Retrieves the signature position for the parameter.

See Also

ParameterInfo Class | System.Reflection Namespace


ParameterInfo.Attributes

Retrieves the attributes for this parameter.

[Visual Basic]
Overridable Public ReadOnly Property Attributes As _
   ParameterAttributes
[C#]
public ParameterAttributes Attributes {virtual get;}
[C++]
public: __property virtual ParameterAttributes get_Attributes();
[JScript]
public function get Attributes() : ParameterAttributes;

Property Value

Read-only. Retrieves the attributes for this parameter.

Remarks

This method utilizes the AttrsImpl method.

To get the ParameterInfo array, first get the method. From the method, get the Type. From the Type, get the ParameterInfo array.

The Attributes is a ParameterAttributes enumeration defining the attributes that may be associated with a Parameter. This enumerated value can be used to determine the In/ Out attributes of the parameter.

See Also

ParameterInfo Class | ParameterInfo Members | System.Reflection Namespace | ParameterAttributes


ParameterInfo.DefaultValue

Retrieves the default value of the parameter.

[Visual Basic]
Overridable Public ReadOnly Property DefaultValue As Object
[C#]
public object DefaultValue {virtual get;}
[C++]
public: __property virtual Object* get_DefaultValue();
[JScript]
public function get DefaultValue() : Object;

Property Value

Read-only. The default value of the parameter.

Remarks

Retrieves the default value of the parameter.

This method utilizes the DefaultValueImpl method.

To get the ParameterInfo array, first get the Type. From the Type, get the ParameterInfo array.

See Also

ParameterInfo Class | ParameterInfo Members | System.Reflection Namespace


ParameterInfo.IsIn

Retrieves whether this is an input parameter.

[Visual Basic]
Public ReadOnly Property IsIn As Boolean
[C#]
public bool IsIn {get;}
[C++]
public: __property bool get_IsIn();
[JScript]
public function get IsIn() : Boolean;

Property Value

Read-only.

Retrieves whether In is set for this parameter.

true if the parameter is an Input; otherwise, false.

Remarks

This method depends on an optional metadata flag. This flag may be inserted by compilers, but the compilers are not obligated to do so.

This method utilizes the ParameterAttributes.In method.

To get the ParameterInfo array, first get the method. From the method, get the Type. From the Type, get the ParameterInfo array.

If the parameter is an input parameter, the IsIn is True. Otherwise it is False.

Example [C#]

[C#]

class
parminfo
{
   public static void mymethod (
      [in] int int1m, out string str2m, ref string str3m)
   {
      str2m = "in mymethod";
   }

   public static int Main(string[] args)
   {
      Console.WriteLine("\nReflection.Parameterinfo");

      //Get the ParameterInfo parameter of a function.

      //Get the type
      Type Mytype = Type.GetType("parminfo");

      //Get and display the method
      MethodBase Mymethodbase = Mytype.GetMethod("mymethod");
      Console.Write("\nMymethodbase = " + Mymethodbase);

      //Get the ParameterInfo array
      ParameterInfo[] Myarray = Mymethodbase.GetParameters();

      //Get and display the IsIn of each parameter
      foreach (ParameterInfo Myparam in Myarray)
      {
         Console.Write ("\nFor parameter # "   + Myparam.Position
+ ", the IsIn is - " +  Myparam.IsIn );
      }
      return 0;
   }
}
Produces
the following output
Reflection.Parameterinfo

Mymethodbase = Void mymethod (Int32, System.String ByRef, System.String ByRef)
For parameter # 0, the IsIn is - True
For parameter # 1, the IsIn is - False
For parameter # 2, the IsIn is - False

See Also

ParameterInfo Class | ParameterInfo Members | System.Reflection Namespace


ParameterInfo.IsLcid

Retrieves whether this is an Lcid parameter.

Retrieves whether the culture identifier is set for the current ParameterInfo.

[Visual Basic]
Public ReadOnly Property IsLcid As Boolean
[C#]
public bool IsLcid {get;}
[C++]
public: __property bool get_IsLcid();
[JScript]
public function get IsLcid() : Boolean;

Property Value

Read-only.

Retrieves whether Lcid is set for this parameter.

true if the parameter is Lcid; otherwise, false.

Remarks

This method depends on an optional metadata flag. This flag may be inserted by compilers, but the compilers are not obligated to do so.

This method utilizes the ParameterAttributes.Lcid method.

To get the ParameterInfo array, first get the method. From the method, get the Type. From the Type, get the ParameterInfo array.

If the parameter is a culture identifier parameter, the IsLcid is True. Otherwise it is False.

See Also

ParameterInfo Class | ParameterInfo Members | System.Reflection Namespace


ParameterInfo.IsOptional

Retrieves whether this parameter is optional.

[Visual Basic]
Public ReadOnly Property IsOptional As Boolean
[C#]
public bool IsOptional {get;}
[C++]
public: __property bool get_IsOptional();
[JScript]
public function get IsOptional() : Boolean;

Property Value

Read-only.

Retrieves whether Optional is set for this parameter.

true if the parameter is optional; otherwise, false.

Remarks

This method depends on an optional metadata flag. This flag may be inserted by compilers, but the compilers are not obligated to do so.

This method utilizes the ParameterAttributes.Optional method.

To get the ParameterInfo array, first get the method. From the method, get the Type. From the Type, get the ParameterInfo array.

If the parameter is an optional parameter, the IsIOptional is True. Otherwise it is False.

See Also

ParameterInfo Class | ParameterInfo Members | System.Reflection Namespace


ParameterInfo.IsOut

Retrieves whether this is an output parameter.

[Visual Basic]
Public ReadOnly Property IsOut As Boolean
[C#]
public bool IsOut {get;}
[C++]
public: __property bool get_IsOut();
[JScript]
public function get IsOut() : Boolean;

Property Value

Read-only.

Retrieves whether Out is set for this parameter.

true if the parameter is an Output; otherwise, TBD.

Remarks

This method depends on an optional metadata flag. This flag may be inserted by compilers, but the compilers are not obligated to do so.

This method utilizes the ParameterAttributes.Out method.

To get the ParameterInfo array, first get the method. From the method, get the Type. From the Type, get the ParameterInfo array.

If the parameter is an output parameter, the IsOut is True. Otherwise it is False.

Example [C#]

[C#]

class parminfo
{
   public static void mymethod (
      [in] int int1m, out string str2m, ref string str3m)
   {
      str2m = "in mymethod";
   }

   public static int Main(string[] args)
   {
      Console.WriteLine("\nReflection.Parameterinfo");

      //Get the ParameterInfo parameter of a function.

      //Get the type
      Type Mytype = Type.GetType("parminfo");

      //Get and display the method
      MethodBase Mymethodbase = Mytype.GetMethod("mymethod");
      Console.Write("\nMymethodbase = " + Mymethodbase);

      //Get the ParameterInfo array
      ParameterInfo[] Myarray = Mymethodbase.GetParameters();

      //Get and display the IsOut of each parameter
      foreach (ParameterInfo Myparam in Myarray)
      {
         Console.Write ("\nFor parameter # "   + Myparam.Position
+ ", the IsOut is - " +  Myparam.IsOut );
      }
      return 0;
   }
}
Produces
the following output
Reflection.Parameterinfo

Mymethodbase = Void mymethod (Int32, System.String ByRef, System.String ByRef)
For parameter # 0, the IsOut is - False
For parameter # 1, the IsOut is - True
For parameter # 2, the IsOut is - False

See Also

ParameterInfo Class | ParameterInfo Members | System.Reflection Namespace


ParameterInfo.IsRetval

Retrieves whether this is a Retval parameter.

[Visual Basic]
Public ReadOnly Property IsRetval As Boolean
[C#]
public bool IsRetval {get;}
[C++]
public: __property bool get_IsRetval();
[JScript]
public function get IsRetval() : Boolean;

Property Value

Read-only.

Retrieves whether Retval is set for this parameter.

true if the parameter is a Retval; otherwise, false.

Remarks

This method depends on an optional metadata flag. This flag may be inserted by compilers, but the compilers are not obligated to do so.

This method utilizes the ParameterAttributes.Retval method.

To get the ParameterInfo array, first get the method. From the method, get the Type. From the Type, get the ParameterInfo array.

If the parameter is a Retval parameter, the IsRetval is True. Otherwise it is False.

See Also

ParameterInfo Class | ParameterInfo Members | System.Reflection Namespace


ParameterInfo.Member

[To be supplied].

[Visual Basic]
Overridable Public ReadOnly Property Member As MemberInfo
[C#]
public MemberInfo Member {virtual get;}
[C++]
public: __property virtual MemberInfo* get_Member();
[JScript]
public function get Member() : MemberInfo;

Property Value

[To be supplied].

Remarks

[To be supplied].

See Also

ParameterInfo Class | ParameterInfo Members | System.Reflection Namespace


ParameterInfo.Name

Retrieves the name of the parameter.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {virtual get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

Property Value

Read-only. Retrieves a String containing the simple name of this parameter.

Remarks

The string value for the parameter name is obtained by this method.

This method utilizes the protected NameImpl method.

This method depends on an optional metadata and may not be available in all compilers.

To get the ParameterInfo array, first get the method. From the method, get the Type. From the Type, get the ParameterInfo array.

Example [C#]

[C#]

class
parminfo
{
   public static void mymethod (
      [in] int int1m, out string str2m, ref string str3m)
   {
      str2m = "in mymethod";
   }

   public static int Main(string[] args)
   {
      Console.WriteLine("\nReflection.Parameterinfo");

      //Get the ParameterInfo parameter of a function.

      //Get the type
      Type Mytype = Type.GetType("parminfo");

      //Get and display the method
      MethodBase Mymethodbase = Mytype.GetMethod("mymethod");
      Console.Write("\nMymethodbase = " + Mymethodbase);

      //Get the ParameterInfo array
      ParameterInfo[] Myarray = Mymethodbase.GetParameters();

      //Get and display the name of each parameter
      foreach (ParameterInfo Myparam in Myarray)
      {
         Console.Write ("\nFor parameter # "   + Myparam.Position
+ ", the Name is - " +  Myparam.Name);
      }
      return 0;
   }
}
Produces
the following output
Reflection.Parameterinfo

Mymethodbase
= Void mymethod (Int32, System.String ByRef, System.String ByRef)
For parameter # 0, the Name is - int1m
For parameter # 1, the Name is - str2m
For parameter # 2, the Name is - str3m

See Also

ParameterInfo Class | ParameterInfo Members | System.Reflection Namespace


ParameterInfo.ParameterType

Retrieves the Type of this parameter.

[Visual Basic]
Overridable Public ReadOnly Property ParameterType As Type
[C#]
public Type ParameterType {virtual get;}
[C++]
public: __property virtual Type* get_ParameterType();
[JScript]
public function get ParameterType() : Type;

Property Value

Read-only. Retrieves the Type object that represents the Type of this parameter.

Remarks

Retrieves the class that represents the type of the parameter.

This method utilizes the ClassImpl method.

This method depends on an optional metadata and may not be available in all compilers.

To get the ParameterInfo array, first get the method. From the method, get the Type. From the Type, get the ParameterInfo array.

Example

[C++]
class parminfo
{
   public static void mymethod (
      [in] int int1m, out string str2m, ref string str3m)
   {
      str2m = "in mymethod";
   }

   public static int Main(string[] args)
   {
      Console.WriteLine("\nReflection.Parameterinfo");

      //Get the ParameterInfo parameter of a function.

      //Get the type
      Type Mytype = Type.GetType("parminfo");

      //Get and display the method
      MethodBase Mymethodbase = Mytype.GetMethod("mymethod");
      Console.Write("\nMymethodbase = " + Mymethodbase);

      //Get the ParameterInfo array
      ParameterInfo[]Myarray = Mymethodbase.GetParameters();

      //Get and display the ParameterInfo of each parameter
      foreach (ParameterInfo Myparam in Myarray)
      {
         Console.Write ("\nFor parameter # " + Myparam.Position
+ ", the ParameterType is - " + Myparam.ParameterType);
      }
      return 0;
   }
}

Produces the following output

Reflection.Parameterinfo
Mymethodbase = Void mymethod (Int32, System.String ByRef,
System.String ByRef)
For parameter # 0, the ParameterType is - Int32
For parameter # 1, the ParameterType is - System.String
For parameter # 2, the ParameterType is - System.String

See Also

ParameterInfo Class | ParameterInfo Members | System.Reflection Namespace


ParameterInfo.Position

Retrieves the signature position for the parameter.

[Visual Basic]
Overridable Public ReadOnly Property Position As Integer
[C#]
public int Position {virtual get;}
[C++]
public: __property virtual int get_Position();
[JScript]
public function get Position() : int;

Property Value

Read-only. Retrieves the position this parameter occupies in the parameter list.

Remarks

This method utilizes the PositionImpl method.

To get the ParameterInfo array, first get the method. From the method, get the Type. From the Type, get the ParameterInfo array.

See Also

ParameterInfo Class | ParameterInfo Members | System.Reflection Namespace | Name


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ParameterInfo Methods

The methods of the ParameterInfo class are listed below. For a complete list of ParameterInfo class members, see the ParameterInfo Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCustomAttributes | Overloaded. [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
IsDefined | Determines if the attributeType is defined on this member.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ParameterInfo Class | System.Reflection Namespace


ParameterInfo.GetCustomAttributes

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function GetCustomAttributes() As Object ()
[C#] public virtual object[] GetCustomAttributes();
[C++] public: virtual Object* GetCustomAttributes() [];
[JScript] public function GetCustomAttributes() : Object[];

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function GetCustomAttributes(Type) As Object ()
[C#] public virtual object[] GetCustomAttributes(Type);
[C++] public: virtual Object* GetCustomAttributes(Type*) [];
[JScript] public function GetCustomAttributes(Type) : Object[];

See Also

ParameterInfo Class | ParameterInfo Members | System.Reflection Namespace


ParameterInfo.GetCustomAttributes ()

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function GetCustomAttributes() As Object ()
[C#]
public virtual object[] GetCustomAttributes();
[C++]
public: virtual Object* GetCustomAttributes() [];
[JScript]
public function GetCustomAttributes() : Object[];

See Also

ParameterInfo Class | ParameterInfo Members | System.Reflection Namespace | ParameterInfo.GetCustomAttributes Overload List


ParameterInfo.GetCustomAttributes (Type)

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function GetCustomAttributes( _
   ByVal attributeType As Type _
) As Object ()
[C#]
public virtual object[] GetCustomAttributes(
   Type attributeType
);
[C++]
public: virtual Object* GetCustomAttributes(
   Type* attributeType
) [];
[JScript]
public function GetCustomAttributes(
   attributeType : Type
) : Object[];

Parameters

attributeType
[To be supplied.]

See Also

ParameterInfo Class | ParameterInfo Members | System.Reflection Namespace | ParameterInfo.GetCustomAttributes Overload List


ParameterInfo.IsDefined

Determines if the attributeType is defined on this member.

[Visual Basic]
Overridable Public Function IsDefined( _
   ByVal attributeType As Type _
) As Boolean
[C#]
public virtual bool IsDefined(
   Type attributeType
);
[C++]
public: virtual bool IsDefined(
   Type* attributeType
);
[JScript]
public function IsDefined(
   attributeType : Type
) : Boolean;

Parameters

attributeType
The Type object to which the parameter is searched.

Return Value

Returns true if one or more instance of attributeType is defined on this member.

Exceptions

Exception Type | Condition
ArgumentNullException | if the attributeType is null.

See Also

ParameterInfo Class | ParameterInfo Members | System.Reflection Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ParameterInfo Fields

The fields of the ParameterInfo class are listed below. For a complete list of ParameterInfo class members, see the ParameterInfo Members topic.

Protected:

AttrsImpl | The attributes of the parameter.
ClassImpl | The Type of the parameter.
DefaultValueImpl | The default value of the parameter.
MemberImpl | [To be supplied]
NameImpl | The name of the parameter.
PositionImpl | The position of the parameter.

See Also

ParameterInfo Class | System.Reflection Namespace


ParameterInfo.AttrsImpl

The attributes of the parameter.

[Visual Basic]
Protected AttrsImpl As ParameterAttributes
[C#]
protected ParameterAttributes AttrsImpl;
[C++]
protected: ParameterAttributes AttrsImpl;
[JScript]
protected var AttrsImpl : ParameterAttributes;

Remarks

A protected parameter and is intended for users subclassing ParameterInfo. This method is inaccessible due to its protection level. The attributes of the parameter can be accessed through Attributes.

See Also

ParameterInfo Class | ParameterInfo Members | System.Reflection Namespace


ParameterInfo.ClassImpl

The Type of the parameter.

[Visual Basic]
Protected ClassImpl As Type
[C#]
protected Type ClassImpl;
[C++]
protected: Type* ClassImpl;
[JScript]
protected var ClassImpl : Type;

Remarks

A protected parameter and is intended for users subclassing ParameterInfo. This method is inaccessible due to its protection level. The Type of the parameter can be accessed through ParameterType.

See Also

ParameterInfo Class | ParameterInfo Members | System.Reflection Namespace


ParameterInfo.DefaultValueImpl

The default value of the parameter.

[Visual Basic]
Protected DefaultValueImpl As Object
[C#]
protected object DefaultValueImpl;
[C++]
protected: Object* DefaultValueImpl;
[JScript]
protected var DefaultValueImpl : Object;

Remarks

A protected parameter and is intended for users subclassing ParameterInfo. This method is inaccessible due to its protection level. The default value of the parameter can be accessed through DefaultValue.

See Also

ParameterInfo Class | ParameterInfo Members | System.Reflection Namespace


ParameterInfo.MemberImpl

[To be supplied]

[Visual Basic]
Protected MemberImpl As MemberInfo
[C#]
protected MemberInfo MemberImpl;
[C++]
protected: MemberInfo* MemberImpl;
[JScript]
protected var MemberImpl : MemberInfo;

Remarks

Modifiers.

See Also

ParameterInfo Class | ParameterInfo Members | System.Reflection Namespace


ParameterInfo.NameImpl

The name of the parameter.

[Visual Basic]
Protected NameImpl As String
[C#]
protected string NameImpl;
[C++]
protected: String* NameImpl;
[JScript]
protected var NameImpl : String;

Remarks

A protected parameter and is intended for users subclassing ParameterInfo. This method is inaccessible due to its protection level. The name of the parameter can be accessed through the Name property or through a subclass of ParameterInfo.

See Also

ParameterInfo Class | ParameterInfo Members | System.Reflection Namespace


ParameterInfo.PositionImpl

The position of the parameter.

[Visual Basic]
Protected PositionImpl As Integer
[C#]
protected int PositionImpl;
[C++]
protected: int PositionImpl;
[JScript]
protected var PositionImpl : int;

Remarks

A protected parameter and is intended for users subclassing ParameterInfo. Zero based position this parameter occupies in the parameter list. This method is inaccessible due to its protection level. The name of the parameter can be accessed through Position.

See Also

ParameterInfo Class | ParameterInfo Members | System.Reflection Namespace


ParameterModifier Structure

Attaches a modifier to parameters so that binding can work with parameter signatures in which the types have been modified.

Object
ValueType
ParameterModifier

[Visual Basic]
Public Structure ParameterModifier
[C#]
public struct ParameterModifier
[C++]
public __value struct ParameterModifier

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

This class is used in Type.InvokeMember.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

ParameterModifier Members | System.Reflection Namespace


ParameterModifier Members

Public:

Constructor

ParameterModifier Constructor Initializes a new instance of ParameterModifier.

Properties

Item Gets or sets the index of the parameter array.

In C#, this member is the indexer for the ParameterModifier class.

Methods

Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ParameterModifier Structure | System.Reflection Namespace


ParameterModifier Constructor

Initializes a new instance of ParameterModifier.

[Visual Basic]
Public Sub New( _
   ByVal paramaterCount As Integer _
)
[C#]
public ParameterModifier(
   int paramaterCount
);
[C++]
public: ParameterModifier(
   int paramaterCount
);
[JScript]
public function ParameterModifier(
   paramaterCount : int
);

Parameters

paramaterCount
The number of parameters to modify.

Exceptions

Exception Type | Condition
ArgumentException | paramaterCount is negative

See Also

ParameterModifier Structure | ParameterModifier Members | System.Reflection Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ParameterModifier Properties

The properties of the ParameterModifier structure are listed below. For a complete list of ParameterModifier structure members, see the ParameterModifier Members topic.

Public:

Item Gets or sets the index of the parameter array.

In C#, this member is the indexer for the ParameterModifier class.

See Also

ParameterModifier Structure | System.Reflection Namespace


ParameterModifier.Item

Gets or sets the index of the parameter array.

[C#] In C#, this member is the indexer for the ParameterModifier class.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As Boolean
[C#]
public bool this[
   int index
] {get; set;}
[C++]
public: __property bool get_Item(
   int index
);
public: __property void set_Item(
   int index,
   bool
);
[JScript]
returnValue = ParameterModifierObject.Item(index);
ParameterModifierObject.Item(index) = returnValue;
-or-
returnValue = ParameterModifierObject(index);
ParameterModifierObject(index) = returnValue;

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed Item property whose type is Object and whose index type is String.

Arguments [JScript]

index
[To be supplied.]

Parameters [Visual Basic, C#, C++]

index
[To be supplied.]

See Also

ParameterModifier Structure | ParameterModifier Members | System.Reflection Namespace


Pointer Class

[To be supplied.]

Object
Pointer

[Visual Basic]
NotInheritable Public Class Pointer
[C#]
public sealed class Pointer
[C++]
public __gc __sealed class Pointer
[JScript]
public class Pointer

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

Pointer Members | System.Reflection Namespace


Pointer Members

Public:

Methods

Box | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Unbox | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Pointer Class | System.Reflection Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Pointer Methods

The methods of the Pointer class are listed below. For a complete list of Pointer class members, see the Pointer Members topic.

Public:

Box | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Unbox | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Pointer Class | System.Reflection Namespace


Pointer.Box

[To be supplied.]

[Visual Basic]
Public Shared Function Box( _
   ByVal ptr As Void*, _
   ByVal type As Type _
) As Object
[C#]
public static object Box(
   Void* ptr,
   Type type
);
[C++]
public: static Object* Box(
   Void** ptr,
   Type* type
);
[JScript]
public static function Box(
   ptr : Void*,
   type : Type
) : Object;

Parameters

ptr
[To be supplied.]
type
[To be supplied.]

See Also

Pointer Class | Pointer Members | System.Reflection Namespace


Pointer.Unbox

[To be supplied.]

[Visual Basic]
Public Shared Function Unbox( _
   ByVal ptr As Object _
) As Void*
[C#]
public static Void* Unbox(
   object ptr
);
[C++]
public: static Void** Unbox(
   Object* ptr
);
[JScript]
public static function Unbox(
   ptr : Object
) : Void*;

Parameters

ptr
[To be supplied.]

See Also

Pointer Class | Pointer Members | System.Reflection Namespace


PropertyAttributes Enumeration

Defines the attributes that may be associated with a property. These attribute values are defined in corhdr.h.

[Visual Basic]
Public Enum PropertyAttributes
[C#]
public enum PropertyAttributes
[C++]
public enum PropertyAttributes

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

In the example shown below, three properties are built and the PropertyAttributes enumerated value is displayed. Note that the for the read only property has no setter and thus cannot be changed by .Caption = statement.

To get the PropertyAttributes, first get the class Type. From the Type, get the PropertyInfo. From the PropertyInfo, get the Attributes.

The enumerated value is a number representing the bitwise OR of the attributes implemented on the method. Us the following mask values to retrieve accessible information

The attributes are logically bitwise OR'd in the following groups.

Flags

None = 0x0000

DefaultProperty = 0x0001

SpecialName = 0x0200

Reserved flags for Runtime use only.

ReservedMask= 0xf400

RTSpecialName = 0x0400

HasDefault= 0x1000

Reserved2= 0x2000

Reserved3= 0x4000

Reserved4= 0x8000

Members

Member Name | Description
HasDefault | Indicates that the property has a default value.
None | Indicates that no attributes are associated with a property.
Reserved2 | [To be supplied.]
Reserved3 | [To be supplied.]
Reserved4 | [To be supplied.]
ReservedMask | Indicates a flag reserved for runtime use only.
RTSpecialName | Indicates that the metadata internal APIs check the name encoding.
SpecialName | Indicates that the property is special, with the name describing how the property is special.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

Example [C#]

[C#]

//Make three properties, one read-write, one default
// and one read only.
public class Aproperty
// A read-write property
{
   private string caption = "A Default caption";
   public string Caption{
      get{return caption;}
      set{
         if (caption != value){caption = value;}
      }
   }
}
public class Bproperty
// A default property
{
   private string caption  = "B Default caption";
   public string this [int index]{
      get {return "1";}
   }
   public string Caption{

      get{return caption;}
      set{
         if (caption != value){caption = value;}
      }
   }
}
public class Cproperty
// A read only property
{
   private string caption = "C Default caption";
   public string Caption{
      get{return caption;}
      //No set- this is read only
   }
}

class propertyattributesenum
{
   public static int Main(string[] args)
   {
      Console.WriteLine("\nReflection.PropertyAttributes");

      //Prove that a property exist and change its value
      Aproperty Mypropertya = new Aproperty();
      Bproperty Mypropertyb = new Bproperty();
      Cproperty Mypropertyc = new Cproperty();

Console.Write("\n1. Mypropertya.Caption = " + Mypropertya.Caption );

Console.Write("\n1. Mypropertyb.Caption = " + Mypropertyb.Caption );

Console.Write("\n1. Mypropertyc.Caption = " + Mypropertyc.Caption );

      //Can change only Mypropertya as Mypropertyb is read only
      Mypropertya.Caption = "A- This is changed.";
      Mypropertyb.Caption = "B- This is changed.";
      //Note that Mypropertyc is not changed- it is read only

      Console.Write("\n\n2. Mypropertya.Caption = " + Mypropertya.Caption );

      Console.Write("\n2.Mypropertyb.Caption = " + Mypropertyb.Caption );

      Console.Write("\n2. Mypropertyc.Caption = " + Mypropertyc.Caption );

      //Get the PropertyAttributes Enumeration of the property.
      //Get the type
      Type MyTypea = Type.GetType("Aproperty");
      Type MyTypeb = Type.GetType("Bproperty");
      Type MyTypec = Type.GetType("Cproperty");

      //Get the property attributes
      PropertyInfo Mypropertyinfoa = MyTypea.GetProperty("Caption");
      PropertyAttributes Myattributesa = Mypropertyinfoa.Attributes;
      PropertyInfo Mypropertyinfob = MyTypeb.GetProperty("Item");
      PropertyAttributes Myattributesb = Mypropertyinfob.Attributes;
      PropertyInfo Mypropertyinfoc = MyTypec.GetProperty("Caption");
      PropertyAttributes Myattributesc = Mypropertyinfoc.Attributes;

      //Display the property attributes value

      Console.Write("\n\na- " + EnumInfo.ToString(Type.GetType("System.Reflection.PropertyAttributes"), Myattributesa ));

      Console.Write("\nb-" + EnumInfo.ToString(Type.GetType("System.Reflection.PropertyAttributes"), Myattributesb ));

      Console.Write("\nc- " + EnumInfo.ToString(Type.GetType("System.Reflection.PropertyAttributes"), Myattributesc ));
      return 0;
   }
}

Produces the following output

Reflection.PropertyAttributes

1. Mypropertya.Caption = A Default caption
1. Mypropertyb.Caption = B Default caption
1. Mypropertyc.Caption = C Default caption

2. Mypropertya.Caption = A- This is changed.
2. Mypropertyb.Caption = B- This is changed.
2. Mypropertyc.Caption = C Default caption

a- None
b- DefaultProperty
c- None

See Also

System.Reflection Namespace


PropertyInfo Class

The PropertyInfo class reflects a property.

Properties are logically the same as fields. A property is a named aspect of an object's state whose value is typically accessible through get and set-accessors. Properties may be read-only, in which case a set routine is not supported. Initializes an instance of the PropertyInfo class.

Object
MemberInfo
PropertyInfo

[Visual Basic]
MustInherit Public Class PropertyInfo
   Inherits MemberInfo
[C#]
public abstract class PropertyInfo : MemberInfo
[C++]
public __gc __abstract class PropertyInfo : public MemberInfo
[JScript]
public abstract class PropertyInfo extends MemberInfo

Remarks

Several methods in this class assume that the getter and setter methods of a property have certain formats. If the following format is not followed, the behavior of the GetValue and SetValue methods is undefined.

The signatures of the get and set methods must match the following convention:

  • The return type of the getter and the last argument of the setter must be identical. This is the type of the property.
  • The getter and setter must have the same number, type and order of indices.

PropertyGet

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

PropertyInfo Members | System.Reflection Namespace


PropertyInfo Members

Public:

Properties

Attributes | Retrieves the attributes for this property.
CanRead | Retrieves whether the property can be read.
CanWrite | Retrieves whether the property can be written to.
DeclaringType (inherited from MemberInfo) | Retrieves the class that declares this member.
IsSpecialName | Retrieves whether the property is the Special Name.
MemberType | Retrieves the Type of property reflected by this PropertyInfo object.
Name (inherited from MemberInfo) | Retrieves the name of this member.
PropertyType | Retrieves the type of the field of this property.
ReflectedType (inherited from MemberInfo) | Retrieves the class object that was used to obtain this instance of MemberInfo.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetAccessors | Overloaded. [To be supplied.]
GetCustomAttributes (inherited from MemberInfo) | Overloaded. Returns all attributes defined on this member.
GetGetMethod | Overloaded. Returns a MethodInfo representing the get accessor for this property.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetIndexParameters | Returns an array of all the parameters for the property.
GetSetMethod | Overloaded. Returns a MethodInfo representing the set accessor for this property.
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | Overloaded. Returns the value of the property.
IsDefined (inherited from MemberInfo) | Returns a Boolean if one or more instance of attributeType is defined on this member.
SetValue | Overloaded. Sets the property value for the given object to the given value.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Constructor

PropertyInfo Constructor Initializes an instance of the PropertyInfo class.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyInfo Class | System.Reflection Namespace


PropertyInfo Constructor

Initializes an instance of the PropertyInfo class.

[Visual Basic]
Protected Sub New()
[C#]
protected PropertyInfo();
[C++]
protected: PropertyInfo();
[JScript]
protected function PropertyInfo();

Remarks

The Member type Property. Properties are logical collections of methods that act as accessors.

See Also

PropertyInfo Class | PropertyInfo Members | System.Reflection Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PropertyInfo Properties

The properties of the PropertyInfo class are listed below. For a complete list of PropertyInfo class members, see the PropertyInfo Members topic.

Public:

Attributes | Retrieves the attributes for this property.
CanRead | Retrieves whether the property can be read.
CanWrite | Retrieves whether the property can be written to.
DeclaringType (inherited from MemberInfo) | Retrieves the class that declares this member.
IsSpecialName | Retrieves whether the property is the Special Name.
MemberType | Retrieves the Type of property reflected by this PropertyInfo object.
Name (inherited from MemberInfo) | Retrieves the name of this member.
PropertyType | Retrieves the type of the field of this property.
ReflectedType (inherited from MemberInfo) | Retrieves the class object that was used to obtain this instance of MemberInfo.

See Also

PropertyInfo Class | System.Reflection Namespace


PropertyInfo.Attributes

Retrieves the attributes for this property.

[Visual Basic]
MustOverride Public ReadOnly Property Attributes As _
   PropertyAttributes
[C#]
public PropertyAttributes Attributes {abstract get;}
[C++]
public: __property virtual PropertyAttributes get_Attributes() = 0;
[JScript]
public abstract function get Attributes() : PropertyAttributes;

Property Value

Read-only. Attributes of this property.

Remarks

Property representing the Attributes associated with a Member. All members have a set of attributes which are defined in relation to the specific type of member. The property attributes let the user know if this property is the Default property, is a SpecialName property, etc.

To get the Attributes property, first get the class Type. From the Type, get the PropertyInfo. From the PropertyInfo, get the Attributes.

Example [C#]

[C#]

//Make a property, then display the PropertyInfo
public class Myproperty
{
   private string caption = "Default caption";
   public string Caption{
      get{return caption;}
      set {if(caption!=value) {caption = value;}
      }
   }
}

class Mypropertyinfo
{
   public static int Main(string[] args)
   {
      Console.WriteLine("\nReflection.PropertyInfo");

      //Build a property
      Myproperty Myproperty = new Myproperty();
      Console.Write("\nMyproperty.Caption = " + Myproperty.Caption);

      //Get the type and PropertyInfo
      Type MyType = Type.GetType("Myproperty");
      PropertyInfo Mypropertyinfo = MyType.GetProperty("Caption");

      //Get and display the attributes property
      PropertyAttributes Myattributes = Mypropertyinfo.Attributes;

      Console.Write("\nPropertyAttributes - " + EnumInfo.ToString(Type.GetType("System.Reflection.PropertyAttributes"), Myattributes ));

      return 0;
   }
}

Produces the following output

Reflection.PropertyInfo
Myproperty.Caption = Default caption
PropertyAttributes - None

See Also

PropertyInfo Class | PropertyInfo Members | System.Reflection Namespace


PropertyInfo.CanRead

Retrieves whether the property can be read.

[Visual Basic]
MustOverride Public ReadOnly Property CanRead As Boolean
[C#]
public bool CanRead {abstract get;}
[C++]
public: __property virtual bool get_CanRead() = 0;
[JScript]
public abstract function get CanRead() : Boolean;

Property Value

Read-only.

true if this property can be read; otherwise, false.

Remarks

Boolean property indicating if the property can be read. If the property does not have a get accessor, it cannot be read.

To get the CanRead property, first get the class Type. From the Type, get the PropertyInfo. From the PropertyInfo, get the CanRead value.

In the following example, two properties are created. The first property is readable and the CanRead property is True. The second property is not readable (there is no get accessor) and the CanRead property is False.

Example [C#]

[C#]

//Make two properties, one readable and on not readable
public class Mypropertya
{
   private string caption = "A Default caption";
   public string Caption{
      get{return caption;}
      set {if(caption!=value) {caption = value;}
      }
   }
}
public class Mypropertyb
{
   private string caption = "B Default caption";
   public string Caption{
      set{if(caption!=value) {caption = value;}
      }
   }
}

class Mypropertyinfo
{
   public static int Main()
   {
      Console.WriteLine("\nReflection.PropertyInfo");

      //Build two properties
      Mypropertya Mypropertya = new Mypropertya();
      Mypropertyb Mypropertyb = new Mypropertyb();

      Console.Write("\nMypropertya.Caption = " + Mypropertya.Caption);
      //Note: Mypropertyb.Caption cannot be read as
      // there is no get accessor

      //Get the type and PropertyInfo
      Type MyTypea = Type.GetType("Mypropertya");
      PropertyInfo Mypropertyinfoa = MyTypea.GetProperty("Caption");
      Type MyTypeb = Type.GetType("Mypropertyb");
      PropertyInfo Mypropertyinfob = MyTypeb.GetProperty("Caption");

      //Get and display the CanRead property

      Console.Write("\nCanRead a - " + Mypropertyinfoa.CanRead);

      Console.Write("\nCanRead b - " + Mypropertyinfob.CanRead);

      return 0;
   }
}

Produces the following output

Reflection.PropertyInfo
Mypropertya.Caption = A Default caption
CanRead a - True
CanRead b - False

See Also

PropertyInfo Class | PropertyInfo Members | System.Reflection Namespace


PropertyInfo.CanWrite

Retrieves whether the property can be written to.

[Visual Basic]
MustOverride Public ReadOnly Property CanWrite As Boolean
[C#]
public bool CanWrite {abstract get;}
[C++]
public: __property virtual bool get_CanWrite() = 0;
[JScript]
public abstract function get CanWrite() : Boolean;

Property Value

Read-only.

true if this property can be written; otherwise, false.

Remarks

Boolean property indicating if the property can be written. If the property does not have a set accessor, it cannot be written to.

To get the CanWrite property, first get the class Type. From the Type, get the PropertyInfo. From the PropertyInfo, get the CanWrite value.

In the following example, two properties are created. The first property is writeable and the CanWrite property is True. The second property is not writeable (there is no set accessor) and the CanWrite is False.

Example [C#]

[C#]

//Make two properties, one writable and on not writeable public class Mypropertya
{
   private string caption = "A Default caption";
   public string Caption{
      get{return caption;}
      set {if(caption!=value) {caption = value;}
      }
   }
}
public class Mypropertyb
{
   private string caption = "B Default caption";
   public string Caption{
      get{return caption;}
   }
}

class Mypropertyinfo
{
   public static int Main()
   {
      Console.WriteLine("\nReflection.PropertyInfo");

      //Build two properties
      Mypropertya Mypropertya = new Mypropertya();
      Mypropertyb Mypropertyb = new Mypropertyb();

      //Read and display the property
      Console.Write("\nMypropertya.Caption = " + Mypropertya.Caption);
      Console.Write("\nMypropertyb.Caption = " + Mypropertyb.Caption);

      //Write to the property
      Mypropertya.Caption = "A- I have been changed";
      //Note: Mypropertyb.Caption cannot be written as
      // there is no set accessor

      //Read and display the property
      Console.Write("\nMypropertya.Caption = " + Mypropertya.Caption);
      Console.Write ("\nMypropertyb.Caption = " + Mypropertyb.Caption);

      //Get the type and PropertyInfo
      Type MyTypea = Type.GetType("Mypropertya");
      PropertyInfo Mypropertyinfoa = MyTypea.GetProperty("Caption");
      Type MyTypeb = Type.GetType("Mypropertyb");
      PropertyInfo Mypropertyinfob = MyTypeb.GetProperty("Caption");

      //Get and display the CanWrite property

      Console.Write("\nCanRead a - " + Mypropertyinfoa.CanWrite);

      Console.Write("\nCanRead b - " + Mypropertyinfob.CanWrite);

      return 0;
   }
}

Produces the following output

Reflection.PropertyInfo
Mypropertya.Caption = A Default caption
Mypropertyb.Caption = B Default caption
Mypropertya.Caption = A- I have been changed
Mypropertyb.Caption = B Default caption
CanRead a - True
CanRead b - False

See Also

PropertyInfo Class | PropertyInfo Members | System.Reflection Namespace


PropertyInfo.IsSpecialName

Retrieves whether the property is the Special Name.

[Visual Basic]
Public ReadOnly Property IsSpecialName As Boolean
[C#]
public bool IsSpecialName {get;}
[C++]
public: __property bool get_IsSpecialName();
[JScript]
public function get IsSpecialName() : Boolean;

Property Value

Read-only.

true if this property is the Special name; otherwise, false.

Remarks

The SpecialName bit is set to flag members that are treated in a special way by some compilers (such as Property accessors and operator overloading methods).

To get the IsSpecialName property, first get the class Type. From the Type, get the PropertyInfo. From the PropertyInfo, get the IsSpecialName value.

See Also

PropertyInfo Class | PropertyInfo Members | System.Reflection Namespace


PropertyInfo.MemberType

Retrieves the Type of property reflected by this PropertyInfo object.

[Visual Basic]
Overridable Public ReadOnly Property MemberType As MemberTypes
[C#]
public MemberTypes MemberType {override get;}
[C++]
public: __property virtual MemberTypes get_MemberType();
[JScript]
public function get MemberType() : MemberTypes;

Property Value

Read-only.

Remarks

MemberType is a subclass of MemberInfo and specifies the type of member this is. Member types are constructors, properties, fields, methods, etc. Since this is a PropertyInfo property, the returned type is a Property.

To get the MemberType property, first get the class Type. From the Type, get the PropertyInfo. From the PropertyInfo, get the MemberType value.

Example [C#]

[C#]

class Mypropertyinfo
{
   public static int Main()
   {
      Console.WriteLine("\nReflection.PropertyInfo");

      //Get the type and PropertyInfo
      Type MyType = Type.GetType("System.Reflection.MemberInfo");
      PropertyInfo Mypropertyinfo = MyType.GetProperty("Name");

      //Read and display the MemberType property
      Console.Write("\nMemberType = " + EnumInfo.ToString(Type.GetType("System.Reflection.MemberTypes"), Mypropertyinfo.MemberType));

      return 0;
   }
}
Produces the following output

Reflection.PropertyInfo
MemberType = Property

See Also

PropertyInfo Class | PropertyInfo Members | System.Reflection Namespace


PropertyInfo.PropertyType

Retrieves the type of the field of this property.

[Visual Basic]
MustOverride Public ReadOnly Property PropertyType As Type
[C#]
public Type PropertyType {abstract get;}
[C++]
public: __property virtual Type* get_PropertyType() = 0;
[JScript]
public abstract function get PropertyType() : Type;

Property Value

Read-only. The Type of this property.

Remarks

The Type is string, Boolean, Integer, etc.

To get the PropertyType property, first get the class Type. From the Type, get the PropertyInfo. From the PropertyInfo, get the PropertyType value.

Example [C#]

[C#]

class Mypropertyinfo
{
   public static int Main()
   {
      Console.WriteLine("\nReflection.PropertyInfo");

      //Get the type and PropertyInfo
      Type MyTypea = Type.GetType("System.Reflection.MemberInfo");
      PropertyInfo Mypropertyinfoa = MyTypea.GetProperty("Name");
      Type MyTypeb = Type.GetType("System.Reflection.MethodBase");
      PropertyInfo Mypropertyinfob = MyTypeb.GetProperty("IsFinal");

      //Read and display the PropertyType property
      Console.Write ("\n" + MyTypea.FullName + "." + Mypropertyinfoa.Name + " has a PropertyType of " + Mypropertyinfoa.PropertyType);
      Console.Write("\n" + MyTypeb.FullName + "." + Mypropertyinfob.Name + " has a PropertyType of " + Mypropertyinfob.PropertyType);

      return 0;
   }
}
Produces the following output

Reflection.PropertyInfo
System.Reflection.MemberInfo.Name has a PropertyType of System.String
System.Reflection.MethodBase.IsFinal has a PropertyType of Boolean

See Also

PropertyInfo Class | PropertyInfo Members | System.Reflection Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PropertyInfo Methods

The methods of the PropertyInfo class are listed below. For a complete list of PropertyInfo class members, see the PropertyInfo Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetAccessors | Overloaded. [To be supplied.]
GetCustomAttributes (inherited from MemberInfo) | Overloaded. Returns all attributes defined on this member.
GetGetMethod | Overloaded. Returns a MethodInfo representing the get accessor for this property.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetIndexParameters | Returns an array of all the parameters for the property.
GetSetMethod | Overloaded. Returns a MethodInfo representing the set accessor for this property.
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | Overloaded. Returns the value of the property.
IsDefined (inherited from MemberInfo) | Returns a Boolean if one or more instance of attributeType is defined on this member.
SetValue | Overloaded. Sets the property value for the given object to the given value.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyInfo Class | System.Reflection Namespace


PropertyInfo.GetAccessors

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Function GetAccessors() As MethodInfo ()
[C#] public MethodInfo[] GetAccessors();
[C++] public: MethodInfo* GetAccessors() [];
[JScript] public function GetAccessors() : MethodInfo[];

Returns an array of the public, and/or non-public Get and Set accessors on this property.

[Visual Basic] Overloads MustOverride Public Function GetAccessors(Boolean) As MethodInfo ()
[C#] public abstract MethodInfo[] GetAccessors(bool);
[C++] public: virtual MethodInfo* GetAccessors(bool) [] = 0;
[JScript] public abstract function GetAccessors(Boolean) : MethodInfo[];

Example [C#]

Note This example shows how to use one of the overloaded versions of GetAccessors. For other examples that may be available, see the individual overload topics.

[C#]

//Make a property
public class Myproperty
{
   private string caption = "A Default caption";
   public string Caption{
      get{return caption;}
      set {if(caption!=value) {caption = value;}
      }
   }
}

class Mypropertyinfo
{
   public static int Main()
      {
      Console.WriteLine ("\nReflection.PropertyInfo");

      //Get the type and PropertyInfo
      Type MyType = Type.GetType("Myproperty");
      PropertyInfo Mypropertyinfo = MyType.GetProperty("Caption");

      //Get the public GetAccessors Method
      MethodInfo[] Mymethodinfoarray = Mypropertyinfo.GetAccessors(true);
      Console.Write ("\nThere are "
         + Mymethodinfoarray.Count + "accessors (public)");

      return 0;
   }
}
Produces the following output

Reflection.PropertyInfo
There are 2 accessors (public)

See Also

PropertyInfo Class | PropertyInfo Members | System.Reflection Namespace


PropertyInfo.GetAccessors ()

[To be supplied.]

[Visual Basic]
Overloads Public Function GetAccessors() As MethodInfo ()
[C#]
public MethodInfo[] GetAccessors();
[C++]
public: MethodInfo* GetAccessors() [];
[JScript]
public function GetAccessors() : MethodInfo[];

See Also

PropertyInfo Class | PropertyInfo Members | System.Reflection Namespace | PropertyInfo.GetAccessors Overload List


PropertyInfo.GetAccessors (Boolean)

Returns an array of the public, and/or non-public Get and Set accessors on this property.

[Visual Basic]
Overloads MustOverride Public Function GetAccessors( _
   ByVal nonPublic As Boolean _
) As MethodInfo ()
[C#]
public abstract MethodInfo[] GetAccessors(
   bool nonPublic
);
[C++]
public: virtual MethodInfo* GetAccessors(
   bool nonPublic
) [] = 0;
[JScript]
public abstract function GetAccessors(
   nonPublic : Boolean
) : MethodInfo[];

Parameters

nonPublic
Indicates whether non-public methods should be returned in the MethodInfo array. True to include non-public methods. False to indicate only public methods.

Return Value

Value | Condition
An array of MethodInfo objects representing the public or non-public accessors. | Matching, public or non-public, accessors exist on this property.
An empty MethodInfo array. | Matching accessors do not exist on this property.

Remarks

The array will be empty if no accessors are found.

To use the GetAccessors method, first get the class Type. From the Type, get the PropertyInfo. From the PropertyInfo, use the GetAccessors method.

Example [C#]

[C#]

//Make a property
public class Myproperty
{
   private string caption = "A Default caption";
   public string Caption{
      get{return caption;}
      set {if(caption!=value) {caption = value;}
      }
   }
}

class Mypropertyinfo
{
   public static int Main()
      {
      Console.WriteLine ("\nReflection.PropertyInfo");

      //Get the type and PropertyInfo
      Type MyType = Type.GetType("Myproperty");
      PropertyInfo Mypropertyinfo = MyType.GetProperty("Caption");

      //Get the public GetAccessors Method
      MethodInfo[] Mymethodinfoarray = Mypropertyinfo.GetAccessors(true);
      Console.Write ("\nThere are "
         + Mymethodinfoarray.Count + "accessors (public)");

      return 0;
   }
}
Produces the following output

Reflection.PropertyInfo
There are 2 accessors (public)

See Also

PropertyInfo Class | PropertyInfo Members | System.Reflection Namespace | PropertyInfo.GetAccessors Overload List


PropertyInfo.GetGetMethod

Returns a MethodInfo representing the get accessor for this property.

Overload List

Returns the Get-accessor for this property.

[Visual Basic] Overloads MustOverride Public Function GetGetMethod(Boolean) As MethodInfo
[C#] public abstract MethodInfo GetGetMethod(bool);
[C++] public: virtual MethodInfo* GetGetMethod(bool) = 0;
[JScript] public abstract function GetGetMethod(Boolean) : MethodInfo;

Returns the public get-accessor for this property.

[Visual Basic] Overloads Public Function GetGetMethod() As MethodInfo
[C#] public MethodInfo GetGetMethod();
[C++] public: MethodInfo* GetGetMethod();
[JScript] public function GetGetMethod() : MethodInfo;

Example [C#]

Note This example shows how to use one of the overloaded versions of GetGetMethod. For other examples that may be available, see the individual overload topics.

[C#]

//Make a property
public class Myproperty
{
   private string caption = "A Default caption";
   public string Caption{
      get{return caption;}
      set {if(caption!=value) {caption = value;}
      }
   }
}

class Mypropertyinfo
{
   public static int Main()
      {
      Console.WriteLine ("\nReflection.PropertyInfo");

      //Get the type and PropertyInfo for two separate properties
      Type MyTypea = Type.GetType("Myproperty");
      PropertyInfo Mypropertyinfoa = MyTypea.GetProperty("Caption");
      Type MyTypeb = Type.GetType("System.Reflection.MethodInfo");
      PropertyInfo Mypropertyinfob = MyTypeb.GetProperty("MemberType");

      //Get and display the GetGetMethod Method for each property
      MethodInfo Mygetmethodinfoa = Mypropertyinfoa.GetGetMethod();
      Console.Write ("\nGetAccessor for " + Mypropertyinfoa.Name
         + " returns a " + Mygetmethodinfoa.ReturnType);
      MethodInfo Mygetmethodinfob = Mypropertyinfob.GetGetMethod();
      Console.Write ("\nGetAccessor for " + Mypropertyinfob.Name
         + " returns a " + Mygetmethodinfob.ReturnType);

      //Display the GetGetMethod without using the MethodInfo
      Console.Write ("\n\n" + MyTypea.FullName + "." + Mypropertyinfoa.Name
          + " GetGetMethod - " + Mypropertyinfoa.GetGetMethod());
      Console.Write ("\n" + MyTypeb.FullName + "." + Mypropertyinfob.Name
          + " GetGetMethod - " + Mypropertyinfob.GetGetMethod());
      return 0;
   }
}

Produces the following output

Reflection.PropertyInfo
GetAccessor for Caption returns a System.String
GetAccessor for MemberType returns a System.Reflection.MemberTypes
Myproperty.Caption GetGetMethod - System.String GetCaption ()
System.Reflection.MethodInfo.MemberType GetGetMethod - System.Reflection.MemberTypes GetMemberType ()

See Also

PropertyInfo Class | PropertyInfo Members | System.Reflection Namespace


PropertyInfo.GetGetMethod (Boolean)

Returns the Get-accessor for this property.

[Visual Basic]
Overloads MustOverride Public Function GetGetMethod( _
   ByVal nonPublic As Boolean _
) As MethodInfo
[C#]
public abstract MethodInfo GetGetMethod(
   bool nonPublic
);
[C++]
public: virtual MethodInfo* GetGetMethod(
   bool nonPublic
) = 0;
[JScript]
public abstract function GetGetMethod(
   nonPublic : Boolean
) : MethodInfo;

Parameters

nonPublic
Indicates whether the accessor should be returned if it is non-public. True to include non-public methods. False to indicate only public methods.

Return Value

Value | Condition
A MethodInfo object representing the Get accessor for this property. | The set accessor is public. nonPublic is true and non-public methods can be returned.
null | nonPublic is false and the Get accessor is non-public. nonPublic is true, but no Get accessors exist.

Remarks

This property is the MethodInfo representing the Get Accessor.

To use the GetGetMethod method, first get the class Type. From the Type, get the PropertyInfo. From the PropertyInfo, use the GetGetMethod method.

Example [C#]

[C#]

//Make a property
public class Myproperty
{
   private string caption = "A Default caption";
   public string Caption{
      get{return caption;}
      set {if(caption!=value) {caption = value;}
      }
   }
}

class Mypropertyinfo
{
   public static int Main()
      {
      Console.WriteLine ("\nReflection.PropertyInfo");

      //Get the type and PropertyInfo for two separate properties
      Type MyTypea = Type.GetType("Myproperty");
      PropertyInfo Mypropertyinfoa = MyTypea.GetProperty("Caption");
      Type MyTypeb = Type.GetType("System.Reflection.MethodInfo");
      PropertyInfo Mypropertyinfob = MyTypeb.GetProperty("MemberType");

      //Get and display the GetGetMethod Method for each property
      MethodInfo Mygetmethodinfoa = Mypropertyinfoa.GetGetMethod();
      Console.Write ("\nGetAccessor for " + Mypropertyinfoa.Name
         + " returns a " + Mygetmethodinfoa.ReturnType);
      MethodInfo Mygetmethodinfob = Mypropertyinfob.GetGetMethod();
      Console.Write ("\nGetAccessor for " + Mypropertyinfob.Name
         + " returns a " + Mygetmethodinfob.ReturnType);

      //Display the GetGetMethod without using the MethodInfo
      Console.Write ("\n\n" + MyTypea.FullName + "." + Mypropertyinfoa.Name
          + " GetGetMethod - " + Mypropertyinfoa.GetGetMethod());
      Console.Write ("\n" + MyTypeb.FullName + "." + Mypropertyinfob.Name
          + " GetGetMethod - " + Mypropertyinfob.GetGetMethod());
      return 0;
   }
}

Produces the following output

Reflection.PropertyInfo
GetAccessor for Caption returns a System.String
GetAccessor for MemberType returns a System.Reflection.MemberTypes
Myproperty.Caption GetGetMethod - System.String GetCaption ()
System.Reflection.MethodInfo.MemberType GetGetMethod - System.Reflection.MemberTypes GetMemberType ()

See Also

PropertyInfo Class | PropertyInfo Members | System.Reflection Namespace | PropertyInfo.GetGetMethod Overload List


PropertyInfo.GetGetMethod ()

Returns the public get-accessor for this property.

[Visual Basic]
Overloads Public Function GetGetMethod() As MethodInfo
[C#]
public MethodInfo GetGetMethod();
[C++]
public: MethodInfo* GetGetMethod();
[JScript]
public function GetGetMethod() : MethodInfo;

Return Value

Value | Condition
A MethodInfo object representing the Get accessor for this property. | The Get accessor is public.
null | The Get accessor is non-public or does not exist.

Remarks

This method is a convenience method that calls the following GetGetMethod method with a parameter of false. Note that the following method is abstract and must be implemented before this method is functional.

To use the GetGetMethod method, first get the class Type. From the Type, get the PropertyInfo. From the PropertyInfo, use the GetGetMethod method.

See Also

PropertyInfo Class | PropertyInfo Members | System.Reflection Namespace | PropertyInfo.GetGetMethod Overload List


PropertyInfo.GetIndexParameters

Returns an array of all the parameters for the property.

[Visual Basic]
MustOverride Public Function GetIndexParameters() As ParameterInfo ()
[C#]
public abstract ParameterInfo[] GetIndexParameters();
[C++]
public: virtual ParameterInfo* GetIndexParameters() [] = 0;
[JScript]
public abstract function GetIndexParameters() : ParameterInfo[];

Return Value

Returns a ParameterInfo array containing the parameters for the indexes.

Remarks

Extract any required parameter information from the returned array.

To use the GetIndexParameters method, first get the class Type. From the Type, get the PropertyInfo. From the PropertyInfo, use the GetIndexParameters method.

Example [C#]

[C#]

//Make a property
public class Myproperty
{
   private string caption = "A Default caption";
   public string Caption{
      get{return caption;}
      set {if(caption!=value) {caption = value;}
      }
   }
}

class Mypropertyinfo
{
   public static int Main()
      {
      Console.WriteLine ("\nReflection.PropertyInfo");

      //Get the type and PropertyInfo
      Type MyType = Type.GetType("Myproperty");
      PropertyInfo Mypropertyinfo = MyType.GetProperty("Caption");

      //Get the public GetIndexParameters Method
      ParameterInfo[] Myparameterinfoarray =
         Mypropertyinfo.GetIndexParameters();
      Console.Write ("\n" + MyType.FullName + "." + Mypropertyinfo.Name
         + " has " + Myparameterinfoarray.Count + " parameters");

      return 0;
   }
}

Produces the following output

Reflection.PropertyInfo
Myproperty.Caption has 0 parameters

See Also

PropertyInfo Class | PropertyInfo Members | System.Reflection Namespace


PropertyInfo.GetSetMethod

Returns a MethodInfo representing the set accessor for this property.

Overload List

Returns the public set accessor for this property.

[Visual Basic] Overloads Public Function GetSetMethod() As MethodInfo
[C#] public MethodInfo GetSetMethod();
[C++] public: MethodInfo* GetSetMethod();
[JScript] public function GetSetMethod() : MethodInfo;

Returns the set accessor for this property.

[Visual Basic] Overloads MustOverride Public Function GetSetMethod(Boolean) As MethodInfo
[C#] public abstract MethodInfo GetSetMethod(bool);
[C++] public: virtual MethodInfo* GetSetMethod(bool) = 0;
[JScript] public abstract function GetSetMethod(Boolean) : MethodInfo;

Example [C#]

Note This example shows how to use one of the overloaded versions of GetSetMethod. For other examples that may be available, see the individual overload topics.

[C#]

//Make a property
public class Myproperty
{
   private string caption = "A Default caption";
   public string Caption{
      get{return caption;}
      set {if(caption!=value) {caption = value;}
      }
   }
}

class Mypropertyinfo
{
   public static int Main()
      {
      Console.WriteLine ("\nReflection.PropertyInfo");

      //Get the type and PropertyInfo for two separate properties
      Type MyTypea = Type.GetType("Myproperty");
      PropertyInfo Mypropertyinfoa = MyTypea.GetProperty("Caption");
      Type MyTypeb = Type.GetType("System.StringBuilder");
      PropertyInfo Mypropertyinfob = MyTypeb.GetProperty("Length");
      //Get and display the GetSetMethod Method for each property
      MethodInfo Mygetmethodinfoa = Mypropertyinfoa.GetSetMethod();
      Console.Write ("\nSetAccessor for " + Mypropertyinfoa.Name
         + " returns a " + Mygetmethodinfoa.ReturnType);
      MethodInfo Mygetmethodinfob = Mypropertyinfob.GetSetMethod();
      Console.Write ("\nSetAccessor for " + Mypropertyinfob.Name
         + " returns a " + Mygetmethodinfob.ReturnType);

      //Display the GetSetMethod without using the MethodInfo
      Console.Write ("\n\n" + MyTypea.FullName + "."
         + Mypropertyinfoa.Name + " GetSetMethod - "
         + Mypropertyinfoa.GetSetMethod());
      Console.Write ("\n" + MyTypeb.FullName + "."
         + Mypropertyinfob.Name + " GetSetMethod - "
         + Mypropertyinfob.GetSetMethod());
      return 0;
   }
}

Produces the following output

Reflection.PropertyInfo
SetAccessor for Caption returns a System.Void
SetAccessor for Length returns a System.Void
Myproperty.Caption GetSetMethod - Void SetCaption (System.String)
System.StringBuilder.Length GetSetMethod - Void SetLength (Int32)

See Also

PropertyInfo Class | PropertyInfo Members | System.Reflection Namespace


PropertyInfo.GetSetMethod ()

Returns the public set accessor for this property.

[Visual Basic]
Overloads Public Function GetSetMethod() As MethodInfo
[C#]
public MethodInfo GetSetMethod();
[C++]
public: MethodInfo* GetSetMethod();
[JScript]
public function GetSetMethod() : MethodInfo;

Return Value

Value | Condition
The MethodInfo object representing the Set method for this property. | The set accessor is public.
null | The set accessor is non-public. The property is read-only.

Remarks

This method is a convenience method that calls the following GetSetMethod method with a parameter of false. Note that the following method is abstract and must be implemented before this method is functional.

To use the GetSetMethod method, first get the class Type. From the Type, get the PropertyInfo. From the PropertyInfo, use the GetSetMethod method.

See Also

PropertyInfo Class | PropertyInfo Members | System.Reflection Namespace | PropertyInfo.GetSetMethod Overload List


PropertyInfo.GetSetMethod (Boolean)

Returns the set accessor for this property.

[Visual Basic]
Overloads MustOverride Public Function GetSetMethod( _
   ByVal nonPublic As Boolean _
) As MethodInfo
[C#]
public abstract MethodInfo GetSetMethod(
   bool nonPublic
);
[C++]
public: virtual MethodInfo* GetSetMethod(
   bool nonPublic
) = 0;
[JScript]
public abstract function GetSetMethod(
   nonPublic : Boolean
) : MethodInfo;

Parameters

nonPublic
Indicates whether the accessor should be returned if it is non-public. True to include non-public methods. False to indicate only public methods.

Return Value

Value | Condition
A MethodInfo object representing the Set method for this property. | The set accessor is public. nonPublic is true and non-public methods can be returned.
null | nonPublic is true, but the property is read-only. nonPublic is false and the set accessor is non-public.

Remarks

This property is the MethodInfo representing the Set Accessor.

To use the GetSetMethod method, first get the class Type. From the Type, get the PropertyInfo. From the PropertyInfo, use the GetSetMethod method.

Example [C#]

[C#]

//Make a property
public class Myproperty
{
   private string caption = "A Default caption";
   public string Caption{
      get{return caption;}
      set {if(caption!=value) {caption = value;}
      }
   }
}

class Mypropertyinfo
{
   public static int Main()
      {
      Console.WriteLine ("\nReflection.PropertyInfo");

      //Get the type and PropertyInfo for two separate properties
      Type MyTypea = Type.GetType("Myproperty");
      PropertyInfo Mypropertyinfoa = MyTypea.GetProperty("Caption");
      Type MyTypeb = Type.GetType("System.StringBuilder");
      PropertyInfo Mypropertyinfob = MyTypeb.GetProperty("Length");
      //Get and display the GetSetMethod Method for each property
      MethodInfo Mygetmethodinfoa = Mypropertyinfoa.GetSetMethod();
      Console.Write ("\nSetAccessor for " + Mypropertyinfoa.Name
         + " returns a " + Mygetmethodinfoa.ReturnType);
      MethodInfo Mygetmethodinfob = Mypropertyinfob.GetSetMethod();
      Console.Write ("\nSetAccessor for " + Mypropertyinfob.Name
         + " returns a " + Mygetmethodinfob.ReturnType);

      //Display the GetSetMethod without using the MethodInfo
      Console.Write ("\n\n" + MyTypea.FullName + "."
         + Mypropertyinfoa.Name + " GetSetMethod - "
         + Mypropertyinfoa.GetSetMethod());
      Console.Write ("\n" + MyTypeb.FullName + "."
         + Mypropertyinfob.Name + " GetSetMethod - "
         + Mypropertyinfob.GetSetMethod());
      return 0;
   }
}

Produces the following output

Reflection.PropertyInfo
SetAccessor for Caption returns a System.Void
SetAccessor for Length returns a System.Void
Myproperty.Caption GetSetMethod - Void SetCaption (System.String)
System.StringBuilder.Length GetSetMethod - Void SetLength (Int32)

See Also

PropertyInfo Class | PropertyInfo Members | System.Reflection Namespace | PropertyInfo.GetSetMethod Overload List


PropertyInfo.GetValue

Returns the value of the property.

Overload List

Returns the value of the property with optional index values for index properties.

[Visual Basic] Overloads MustOverride Public Function GetValue(Object, BindingFlags, Binder, Object(), CultureInfo) As Object
[C#] public abstract object GetValue(Object, BindingFlags, Binder, Object[], CultureInfo);
[C++] public: virtual Object* GetValue(Object*, BindingFlags, Binder, Object*[], CultureInfo) = 0;
[JScript] public abstract function GetValue(Object, BindingFlags, Binder, Object[], CultureInfo) : Object;

[To be supplied.]

[Visual Basic] Overloads Overridable Public Function GetValue(Object, Object()) As Object
[C#] public virtual object GetValue(Object, Object[]);
[C++] public: virtual Object* GetValue(Object*, Object*[]);
[JScript] public function GetValue(Object, Object[]) : Object;

See Also

PropertyInfo Class | PropertyInfo Members | System.Reflection Namespace


PropertyInfo.GetValue (Object, BindingFlags, Binder, Object[], CultureInfo)

Returns the value of the property with optional index values for index properties.

[Visual Basic]
Overloads MustOverride Public Function GetValue( _
   ByVal obj As Object, _
   ByVal invokeAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal index() As Object, _
   ByVal culture As CultureInfo _
) As Object
[C#]
public abstract object GetValue(
   object obj,
   BindingFlags invokeAttr,
   Binder binder,
   object[] index,
   CultureInfo culture
);
[C++]
public: virtual Object* GetValue(
   Object* obj,
   BindingFlags invokeAttr,
   Binder* binder,
   Object* index[],
   CultureInfo* culture
) = 0;
[JScript]
public abstract function GetValue(
   obj : Object,
   invokeAttr : BindingFlags,
   binder : Binder,
   index : Object[],
   culture : CultureInfo
) : Object;

Parameters

obj
The object whose property value will be returned.
invokeAttr
[To be supplied.]
binder
[To be supplied.]
index
[To be supplied.]
culture
[To be supplied.]

Return Value

Returns the property value for obj.

To use the GetValue method, first get the class Type. From the Type, get the PropertyInfo. From the PropertyInfo, use the GetValue method.

Exceptions

Exception Type | Condition
ArgumentException | the index array doesn't contain the exact number and type of arguments needed.

Remarks

This implementation throws NotSupportedException.

See Also

PropertyInfo Class | PropertyInfo Members | System.Reflection Namespace | PropertyInfo.GetValue Overload List


PropertyInfo.GetValue (Object, Object[])

[To be supplied.]

[Visual Basic]
Overloads Overridable Public Function GetValue( _
   ByVal obj As Object, _
   ByVal index() As Object _
) As Object
[C#]
public virtual object GetValue(
   object obj,
   object[] index
);
[C++]
public: virtual Object* GetValue(
   Object* obj,
   Object* index[]
);
[JScript]
public function GetValue(
   obj : Object,
   index : Object[]
) : Object;

Parameters

obj
The object whose property value will be returned.
index
[To be supplied.]

Return Value

Returns the property value for obj.

To use the GetValue method, first get the class Type. From the Type, get the PropertyInfo. From the PropertyInfo, use the GetValue method.

Exceptions

Exception Type | Condition
ArgumentException | the index array doesn't contain the exact number and type of arguments needed.

Remarks

This method is a convenience method that calls the following GetValue method with a BinderFlags parameter of DefaultChangeType, the Binder set to null, and the CultureInfo set to null. Note that the following method is abstract and must be implemented before this method is functional.

See Also

PropertyInfo Class | PropertyInfo Members | System.Reflection Namespace | PropertyInfo.GetValue Overload List


PropertyInfo.SetValue

Sets the property value for the given object to the given value.

Overload List

Sets the value of the property with optional index values for index properties.

[Visual Basic] Overloads Overridable Public Sub SetValue(Object, Object, Object())
[C#] public virtual void SetValue(Object, Object, Object[]);
[C++] public: virtual void SetValue(Object*, Object*, Object*[]);
[JScript] public function SetValue(Object, Object, Object[]);

Returns an array of the public get and set accessors on this property.

[Visual Basic] Overloads MustOverride Public Sub SetValue(Object, Object, BindingFlags, Binder, Object(), CultureInfo)
[C#] public abstract void SetValue(Object, Object, BindingFlags, Binder, Object[], CultureInfo);
[C++] public: virtual void SetValue(Object*, Object*, BindingFlags, Binder, Object*[], CultureInfo) = 0;
[JScript] public abstract function SetValue(Object, Object, BindingFlags, Binder, Object[], CultureInfo);

Example [C#]

Note This example shows how to use one of the overloaded versions of SetValue. For other examples that may be available, see the individual overload topics.

[C#]

Make a property
public class Myproperty
{
   private string caption = "A Default caption";
   public string Caption{
      get{return caption;}
      set {if(caption!=value) {caption = value;}
      }
   }
}

class Mypropertyinfo
{
   public static int Main()
      {
      Console.WriteLine ("\nReflection.PropertyInfo");
      Myproperty Myproperty = new Myproperty();

      //Get the type and PropertyInfo
      Type MyType = Type.GetType("Myproperty");
      PropertyInfo Mypropertyinfo = MyType.GetProperty("Caption");

      //Get and display the GetValue Method
      Console.Write ("\nGetValue - "
         + Mypropertyinfo.GetValue (Myproperty, null));

      //Use the SetValue Method to change the caption
      Mypropertyinfo.SetValue(
         Myproperty, "This caption has been changed", null);

      //Get the caption again and display it
      Console.Write ("\nGetValue - "
         + Mypropertyinfo.GetValue (Myproperty, null));
      return 0;
   }
}

Produces the following output

Reflection.PropertyInfo
GetValue - A Default caption
GetValue - This caption has been changed

See Also

PropertyInfo Class | PropertyInfo Members | System.Reflection Namespace


PropertyInfo.SetValue (Object, Object, Object[])

Sets the value of the property with optional index values for index properties.

[Visual Basic]
Overloads Overridable Public Sub SetValue( _
   ByVal obj As Object, _
   ByVal value As Object, _
   ByVal index() As Object _
)
[C#]
public virtual void SetValue(
   object obj,
   object value,
   object[] index
);
[C++]
public: virtual void SetValue(
   Object* obj,
   Object* value,
   Object* index[]
);
[JScript]
public function SetValue(
   obj : Object,
   value : Object,
   index : Object[]
);

Parameters

obj
The object whose property value will be set.
value
[To be supplied.]
index
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentException | the index array doesn't contain the exact number and type of arguments needed.

Remarks

This method is a convenience method that calls the following SetValue method with a BinderFlags parameter of DefaultChangeType, the Binder set to null, and the CultureInfo set to null. Note that the following method is abstract and must be implemented before this method is functional.

To use the SetValue method, first get the class Type. From the Type, get the PropertyInfo. From the PropertyInfo, use the SetValue method.

See Also

PropertyInfo Class | PropertyInfo Members | System.Reflection Namespace | PropertyInfo.SetValue Overload List


PropertyInfo.SetValue (Object, Object, BindingFlags, Binder, Object[], CultureInfo)

Returns an array of the public get and set accessors on this property.

[Visual Basic]
Overloads MustOverride Public Sub SetValue( _
   ByVal obj As Object, _
   ByVal value As Object, _
   ByVal invokeAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal index() As Object, _
   ByVal culture As CultureInfo _
)
[C#]
public abstract void SetValue(
   object obj,
   object value,
   BindingFlags invokeAttr,
   Binder binder,
   object[] index,
   CultureInfo culture
);
[C++]
public: virtual void SetValue(
   Object* obj,
   Object* value,
   BindingFlags invokeAttr,
   Binder* binder,
   Object* index[],
   CultureInfo* culture
) = 0;
[JScript]
public abstract function SetValue(
   obj : Object,
   value : Object,
   invokeAttr : BindingFlags,
   binder : Binder,
   index : Object[],
   culture : CultureInfo
);

Parameters

obj
The object whose property value will be set.
value
[To be supplied.]
invokeAttr
[To be supplied.]
binder
[To be supplied.]
index
[To be supplied.]
culture
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentException | the index array doesn't contain the exact number and type of arguments needed.

Remarks

Access restrictions are ignored for fully trusted code. That is, private constructors, methods, fields, and properties can be accessed and invoked via Reflection whenever the code is fully trusted.

To use the SetValue method, first get the class Type. From the Type, get the PropertyInfo. From the PropertyInfo, use the SetValue method.

These implementations both throw NotSupportedException.

Example [C#]

[C#]

Make a property
public class Myproperty
{
   private string caption = "A Default caption";
   public string Caption{
      get{return caption;}
      set {if(caption!=value) {caption = value;}
      }
   }
}

class Mypropertyinfo
{
   public static int Main()
      {
      Console.WriteLine ("\nReflection.PropertyInfo");
      Myproperty Myproperty = new Myproperty();

      //Get the type and PropertyInfo
      Type MyType = Type.GetType("Myproperty");
      PropertyInfo Mypropertyinfo = MyType.GetProperty("Caption");

      //Get and display the GetValue Method
      Console.Write ("\nGetValue - "
         + Mypropertyinfo.GetValue (Myproperty, null));

      //Use the SetValue Method to change the caption
      Mypropertyinfo.SetValue(
         Myproperty, "This caption has been changed", null);

      //Get the caption again and display it
      Console.Write ("\nGetValue - "
         + Mypropertyinfo.GetValue (Myproperty, null));
      return 0;
   }
}

Produces the following output

Reflection.PropertyInfo
GetValue - A Default caption
GetValue - This caption has been changed

See Also

PropertyInfo Class | PropertyInfo Members | System.Reflection Namespace | PropertyInfo.SetValue Overload List


ReflectionTypeLoadException Class

The ReflectionTypeLoadException class represents the exceptions thrown by the Module.GetTypes() method if any of the classes in a module are not able to be loaded

Object
Exception
SystemException
ReflectionTypeLoadException

[Visual Basic]
NotInheritable Public Class ReflectionTypeLoadException
   Inherits SystemException
[C#]
public sealed class ReflectionTypeLoadException : SystemException
[C++]
public __gc __sealed class ReflectionTypeLoadException : public
   SystemException
[JScript]
public class ReflectionTypeLoadException extends SystemException

Remarks

An instance contains the array of classes (Types property) that were defined in the module and were loaded. This classes array may contain some null values. There is also another array of exceptions (LoaderExceptions property). This exception array represents the exceptions that were thrown by the class loader. The holes in the class array line up with the exceptions.

This exception exposes both the array of classes and the array of TypeLoadExceptions.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

ReflectionTypeLoadException Members | System.Reflection Namespace


ReflectionTypeLoadException Members

Public:

Constructor

ReflectionTypeLoadException Constructor Initializes an instance of the ReflectionTypeLoadException class with the given classes and their associated exceptions.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
LoaderExceptions | Retrieves the array of exceptions thrown by the class loader.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]
Types | Retrieves the array of classes that were defined in the module, and loaded.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

ReflectionTypeLoadException Class | System.Reflection Namespace


ReflectionTypeLoadException Constructor

Initializes an instance of the ReflectionTypeLoadException class with the given classes and their associated exceptions.

[Visual Basic]
Public Sub New( _
   ByVal classes() As Type, _
   ByVal exceptions() As Exception _
)
[C#]
public ReflectionTypeLoadException(
   Type[] classes,
   Exception[] exceptions
);
[C++]
public: ReflectionTypeLoadException(
   Type* classes[],
   Exception* exceptions[]
);
[JScript]
public function ReflectionTypeLoadException(
   classes : Type[],
   exceptions : Exception[]
);

Parameters

classes
An array containing the classes that were defined in the module and loaded. This array may contain some null values.
exceptions
An array containing the exceptions that were thrown by the class loader. The null values in the classes array line up with the exceptions in this exceptions array.

See Also

ReflectionTypeLoadException Class | ReflectionTypeLoadException Members | System.Reflection Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ReflectionTypeLoadException Properties

The properties of the ReflectionTypeLoadException class are listed below. For a complete list of ReflectionTypeLoadException class members, see the ReflectionTypeLoadException Members topic.

Public:

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
LoaderExceptions | Retrieves the array of exceptions thrown by the class loader.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]
Types | Retrieves the array of classes that were defined in the module, and loaded.

See Also

ReflectionTypeLoadException Class | System.Reflection Namespace


ReflectionTypeLoadException.LoaderExceptions

Retrieves the array of exceptions thrown by the class loader.

[Visual Basic]
Public ReadOnly Property LoaderExceptions As Exception ()
[C#]
public Exception[] LoaderExceptions {get;}
[C++]
public: __property Exception* get_LoaderExceptions();
[JScript]
public function get LoaderExceptions() : Exception[];

Property Value

Read-only. An Exception array containing the exceptions thrown by the class loader. The null values in the classes array of this instance line up with the exceptions in this array.

Remarks

The LoaderExceptions property retrieves an array of Exceptions that is parallel to this Types array. This array will contain null values wherever reflection cannot load a class.

See Also

ReflectionTypeLoadException Class | ReflectionTypeLoadException Members | System.Reflection Namespace


ReflectionTypeLoadException.Types

Retrieves the array of classes that were defined in the module, and loaded.

[Visual Basic]
Public ReadOnly Property Types As Type ()
[C#]
public Type[] Types {get;}
[C++]
public: __property Type* get_Types();
[JScript]
public function get Types() : Type[];

Property Value

Read-only. A Type array containing the classes that were defined in the module and loaded. This array may contain some null values.

Remarks

The LoaderExceptions property retrieves an array of Exceptions that is parallel to this Types array. This array will contain null values wherever reflection cannot load a class.

See Also

ReflectionTypeLoadException Class | ReflectionTypeLoadException Members | System.Reflection Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ReflectionTypeLoadException Methods

The methods of the ReflectionTypeLoadException class are listed below. For a complete list of ReflectionTypeLoadException class members, see the ReflectionTypeLoadException Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReflectionTypeLoadException Class | System.Reflection Namespace


ReflectionTypeLoadException.GetObjectData

[To be supplied.]

[Visual Basic]
Overrides Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
public: override void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
);
[JScript]
public override function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);

Parameters

info
[To be supplied.]
context
[To be supplied.]

See Also

ReflectionTypeLoadException Class | ReflectionTypeLoadException Members | System.Reflection Namespace


ResolveEventHandler Delegate

This delegate is used to handle the OnTypeResolveEvent and OnResourceResolveEvent events on Assembly. If the runtime class loader cannot resolve a reference to a type or a resource through normal means, these events are raised to give the caller a chance to tell the runtime which assembly the referenced class or resource is in. Cast EventArgs to a String to find the name of the requested Type or resource.

[Visual Basic]
Public Delegate Sub ResolveEventHandler( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) As Assembly
[C#]
public delegate Assembly ResolveEventHandler(
   object sender,
   EventArgs e
);
[C++]
public __gc __delegate Assembly* ResolveEventHandler(
   Object* sender,
   EventArgs* e
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the ResolveEventHandler delegate declaration.

sender
The object that was the source of the event.
e
The arguments supplied by the object describing the event.

Remarks

Every subclass of Delegate and MulticastDelegate has a constructor and an Invoke method. See the Managed C++ code example given in the description for the Delegate.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

System.Reflection Namespace


ResourceAttributes Enumeration

Defines the attributes for an embedded resource.

[Visual Basic]
Public Enum ResourceAttributes
[C#]
public enum ResourceAttributes
[C++]
public enum ResourceAttributes

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Private | The embedded resource is private.
Public | The embedded resource is public.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

System.Reflection Namespace


StrongNameKeyPair Class

Encapuslates access to a public/private key pair used to sign strong name assemblies.

Object
StrongNameKeyPair

[Visual Basic]
Public Class StrongNameKeyPair
[C#]
public class StrongNameKeyPair
[C++]
public __gc class StrongNameKeyPair
[JScript]
public class StrongNameKeyPair

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

StrongNameKeyPair Members | System.Reflection Namespace | SecurityPermissionAttribute | SecurityPermissionFlag


StrongNameKeyPair Members

Public:

Constructor

StrongNameKeyPair Constructor Overloaded. Initializes an instance of the PropertyInfo class.

Properties

Originator Get the originator of the key pair.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StrongNameKeyPair Class | System.Reflection Namespace


StrongNameKeyPair Constructor

Initializes an instance of the PropertyInfo class.

Overload List

Initializes an instance of the StrongNameKeyPair class. Build key pair from file.

[Visual Basic] Overloads Public Sub New(FileStream)
[C#] public StrongNameKeyPair(FileStream);
[C++] public: StrongNameKeyPair(FileStream*);
[JScript] public function StrongNameKeyPair(FileStream);

Initializes an instance of the StrongNameKeyPair class. Build key pair from byte array in memory.

[Visual Basic] Overloads Public Sub New(Byte())
[C#] public StrongNameKeyPair(byte[]);
[C++] public: StrongNameKeyPair(unsigned char*[]);
[JScript] public function StrongNameKeyPair(Byte[]);

Initializes an instance of the StrongNameKeyPair class. Reference key pair in named key container.

[Visual Basic] Overloads Public Sub New(String)
[C#] public StrongNameKeyPair(String);
[C++] public: StrongNameKeyPair(String*);
[JScript] public function StrongNameKeyPair(String);

See Also

StrongNameKeyPair Class | StrongNameKeyPair Members | System.Reflection Namespace


StrongNameKeyPair Constructor (FileStream)

Initializes an instance of the StrongNameKeyPair class. Build key pair from file.

[Visual Basic]
Overloads Public Sub New( _
   ByVal keyPairFile As FileStream _
)
[C#]
public StrongNameKeyPair(
   FileStream keyPairFile
);
[C++]
public: StrongNameKeyPair(
   FileStream* keyPairFile
);
[JScript]
public function StrongNameKeyPair(
   keyPairFile : FileStream
);

Parameters

keyPairFile
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentNullException | If the keyPairFile is null.

Remarks

The key pair is built from a file.

See Also

StrongNameKeyPair Class | StrongNameKeyPair Members | System.Reflection Namespace | StrongNameKeyPair Constructor Overload List | Array


StrongNameKeyPair Constructor (Byte[])

Initializes an instance of the StrongNameKeyPair class. Build key pair from byte array in memory.

[Visual Basic]
Overloads Public Sub New( _
   ByVal keyPairArray() As Byte _
)
[C#]
public StrongNameKeyPair(
   byte[] keyPairArray
);
[C++]
public: StrongNameKeyPair(
   unsigned char* keyPairArray[]
);
[JScript]
public function StrongNameKeyPair(
   keyPairArray : Byte[]
);

Parameters

keyPairArray
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentNullException | If the keyPairArray is null

Remarks

The key pair is built from a byte array in memory.

See Also

StrongNameKeyPair Class | StrongNameKeyPair Members | System.Reflection Namespace | StrongNameKeyPair Constructor Overload List | Array


StrongNameKeyPair Constructor (String)

Initializes an instance of the StrongNameKeyPair class. Reference key pair in named key container.

[Visual Basic]
Overloads Public Sub New( _
   ByVal keyPairContainer As String _
)
[C#]
public StrongNameKeyPair(
   string keyPairContainer
);
[C++]
public: StrongNameKeyPair(
   String* keyPairContainer
);
[JScript]
public function StrongNameKeyPair(
   keyPairContainer : String
);

Parameters

keyPairContainer
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentNullException | If the keyPairContainer is null.

Remarks

The key pair is in a named key container.

See Also

StrongNameKeyPair Class | StrongNameKeyPair Members | System.Reflection Namespace | StrongNameKeyPair Constructor Overload List | Array


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StrongNameKeyPair Properties

The properties of the StrongNameKeyPair class are listed below. For a complete list of StrongNameKeyPair class members, see the StrongNameKeyPair Members topic.

Public:

Originator Get the originator of the key pair.

See Also

StrongNameKeyPair Class | System.Reflection Namespace


StrongNameKeyPair.Originator

Get the originator of the key pair.

[Visual Basic]
Public ReadOnly Property Originator As Byte ()
[C#]
public byte[] Originator {get;}
[C++]
public: __property unsigned char* get_Originator();
[JScript]
public function get Originator() : Byte[];

Property Value

Read only.

Remarks

The Originator property returns the originator of the public portion of the key pair. Get the originator (public portion) of the key pair.

See Also

StrongNameKeyPair Class | StrongNameKeyPair Members | System.Reflection Namespace | Array | String


TargetException Class

Represents the exception that is thrown when an attempt is made to invoke an invalid target.

Object
Exception
ApplicationException
TargetException

[Visual Basic]
Public Class TargetException
   Inherits ApplicationException
[C#]
public class TargetException : ApplicationException
[C++]
public __gc class TargetException : public ApplicationException
[JScript]
public class TargetException extends ApplicationException

Remarks

The TargetException class is thrown when an attempt is made to invoke a non-static method on a null object. This may occur because the caller doesn't have access to the member or the target doesn't define the member, etc.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

TargetException Members | System.Reflection Namespace


TargetException Members

Public:

Constructor

TargetException Constructor Overloaded. Initializes an instance of the TargetException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

TargetException Class | System.Reflection Namespace


TargetException Constructor

Initializes an instance of the TargetException class.

Overload List

Initializes an instance of the TargetException class with an empty message and the root cause of the exception.

[Visual Basic] Overloads Public Sub New()
[C#] public TargetException();
[C++] public: TargetException();
[JScript] public function TargetException();

Initializes an instance of the TargetException class with the given message and the root cause exception.

[Visual Basic] Overloads Public Sub New(String)
[C#] public TargetException(String);
[C++] public: TargetException(String*);
[JScript] public function TargetException(String);

Initializes an instance of the TargetException class with the given message and given root cause exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public TargetException(String, Exception);
[C++] public: TargetException(String*, Exception);
[JScript] public function TargetException(String, Exception);

See Also

TargetException Class | TargetException Members | System.Reflection Namespace


TargetException Constructor ()

Initializes an instance of the TargetException class with an empty message and the root cause of the exception.

[Visual Basic]
Overloads Public Sub New()
[C#]
public TargetException();
[C++]
public: TargetException();
[JScript]
public function TargetException();

Remarks

The InnerException property set to null and the HRESULT error code is set to COR_E_TARGET.

The TargetException is the exception classs that shows when a class or method was not located.

TargetException inherits from the Exception. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | null
Message | The empty string.

See Also

TargetException Class | TargetException Members | System.Reflection Namespace | TargetException Constructor Overload List


TargetException Constructor (String)

Initializes an instance of the TargetException class with the given message and the root cause exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public TargetException(
   string message
);
[C++]
public: TargetException(
   String* message
);
[JScript]
public function TargetException(
   message : String
);

Parameters

message
A message that provides reasoning for why the exception occured.

Remarks

TargetException inherits from the Exception. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | null
Message | The message string.

See Also

TargetException Class | TargetException Members | System.Reflection Namespace | TargetException Constructor Overload List


TargetException Constructor (String, Exception)

Initializes an instance of the TargetException class with the given message and given root cause exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public TargetException(
   string message,
   Exception inner
);
[C++]
public: TargetException(
   String* message,
   Exception* inner
);
[JScript]
public function TargetException(
   message : String,
   inner : Exception
);

Parameters

message
A message that provides reasoning for why the exception occured.
inner
The exception, which is the root cause of this exception.

Remarks

A reference to an exception. When handling exceptions, it is sometimes desirable to throw another exception, one which is more indicative of the error that has occurred. In order that the original exception and the information that it carries is not lost, exceptions have a field that can hold a reference to another exception.

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

TargetException inherits from the Exception. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | The inner exception.
Message | The message string.

See Also

TargetException Class | TargetException Members | System.Reflection Namespace | TargetException Constructor Overload List


TargetInvocationException Class

Represents the exception thrown when a method invoked through reflection throws an exception.

Object
Exception
ApplicationException
TargetInvocationException

[Visual Basic]
NotInheritable Public Class TargetInvocationException
   Inherits ApplicationException
[C#]
public sealed class TargetInvocationException :
   ApplicationException
[C++]
public __gc __sealed class TargetInvocationException : public
   ApplicationException
[JScript]
public class TargetInvocationException extends ApplicationException

Remarks

When created, the TargetInvocationException is passed a reference to the exception thrown by the method invoked through reflection. The InnerException property holds the underlying exception.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

TargetInvocationException Members | System.Reflection Namespace


TargetInvocationException Members

Public:

Constructor

TargetInvocationException Constructor Overloaded. Initializes a new instance of the TargetInvocationException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

TargetInvocationException Class | System.Reflection Namespace


TargetInvocationException Constructor

Initializes a new instance of the TargetInvocationException class.

Overload List

Initializes a new TargetInvocationException with an empty message string and the root cause of the exception.

[Visual Basic] Overloads Public Sub New(Exception)
[C#] public TargetInvocationException(Exception);
[C++] public: TargetInvocationException(Exception*);
[JScript] public function TargetInvocationException(Exception);

Initializes an instance of the TargetInvocationException class with the given message and given root cause exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public TargetInvocationException(String, Exception);
[C++] public: TargetInvocationException(String*, Exception);
[JScript] public function TargetInvocationException(String, Exception);

See Also

TargetInvocationException Class | TargetInvocationException Members | System.Reflection Namespace


TargetInvocationException Constructor (Exception)

Initializes a new TargetInvocationException with an empty message string and the root cause of the exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal inner As Exception _
)
[C#]
public TargetInvocationException(
   Exception inner
);
[C++]
public: TargetInvocationException(
   Exception* inner
);
[JScript]
public function TargetInvocationException(
   inner : Exception
);

Parameters

inner
[To be supplied.]

Remarks

The TargetInvocationException is the exception classs that shows when a class or method was not located.

TargetInvocationException inherits from the Exception. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | null
Message | The empty string.

See Also

TargetInvocationException Class | TargetInvocationException Members | System.Reflection Namespace | TargetInvocationException Constructor Overload List


TargetInvocationException Constructor (String, Exception)

Initializes an instance of the TargetInvocationException class with the given message and given root cause exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public TargetInvocationException(
   string message,
   Exception inner
);
[C++]
public: TargetInvocationException(
   String* message,
   Exception* inner
);
[JScript]
public function TargetInvocationException(
   message : String,
   inner : Exception
);

Parameters

message
A message that provides reasoning for why the exception occured.
inner
The exception, which is the root cause of this exception.

Remarks

The ErrorCode property is set to COR_E_TARGETINVOCATION.A reference to an exception. When handling exceptions, it is sometimes desirable to throw another exception, one which is more indicative of the error that has occurred. In order that the original exception and the information that it carries is not lost, exceptions have a field that can hold a reference to another exception. When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

TargetInvocationException inherits from the Exception. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | The inner exception.
Message | The message

See Also

TargetInvocationException Class | TargetInvocationException Members | System.Reflection Namespace | TargetInvocationException Constructor Overload List


TargetParameterCountException Class

Represents an exception that is thrown when the number of the parameter and invocation doesn't match.

Object
Exception
ApplicationException
TargetParameterCountException

[Visual Basic]
NotInheritable Public Class TargetParameterCountException
   Inherits ApplicationException
[C#]
public sealed class TargetParameterCountException :
   ApplicationException
[C++]
public __gc __sealed class TargetParameterCountException : public
   ApplicationException
[JScript]
public class TargetParameterCountException extends
   ApplicationException

Remarks

The TargetParameterCountException is thrown is thrown when the number of the parameter to an invocation doesn't match the number expected.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

TargetParameterCountException Members | System.Reflection Namespace


TargetParameterCountException Members

Public:

Constructor

TargetParameterCountException Constructor Overloaded. Initializes a new instance of the TargetParameterCountException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

TargetParameterCountException Class | System.Reflection Namespace


TargetParameterCountException Constructor

Initializes a new instance of the TargetParameterCountException class.

Overload List

Initializes a new TargetParameterCountException with an empty message string and the root cause of the exception.

[Visual Basic] Overloads Public Sub New()
[C#] public TargetParameterCountException();
[C++] public: TargetParameterCountException();
[JScript] public function TargetParameterCountException();

Initializes an instance of TargetParameterCountException with its message string set to the given message and the root cause exception.

[Visual Basic] Overloads Public Sub New(String)
[C#] public TargetParameterCountException(String);
[C++] public: TargetParameterCountException(String*);
[JScript] public function TargetParameterCountException(String);

Initializes a new TargetParameterCountException with a string that indicates the cause of the exception and an exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public TargetParameterCountException(String, Exception);
[C++] public: TargetParameterCountException(String*, Exception);
[JScript] public function TargetParameterCountException(String, Exception);

See Also

TargetParameterCountException Class | TargetParameterCountException Members | System.Reflection Namespace


TargetParameterCountException Constructor ()

Initializes a new TargetParameterCountException with an empty message string and the root cause of the exception.

[Visual Basic]
Overloads Public Sub New()
[C#]
public TargetParameterCountException();
[C++]
public: TargetParameterCountException();
[JScript]
public function TargetParameterCountException();

Remarks

The TargetParameterCountException is the exception classs that shows when a class or method was not located.

TargetParameterCountException inherits from the Exception. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | null
Message | The empty string.

See Also

TargetParameterCountException Class | TargetParameterCountException Members | System.Reflection Namespace | TargetParameterCountException Constructor Overload List


TargetParameterCountException Constructor (String)

Initializes an instance of TargetParameterCountException with its message string set to the given message and the root cause exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public TargetParameterCountException(
   string message
);
[C++]
public: TargetParameterCountException(
   String* message
);
[JScript]
public function TargetParameterCountException(
   message : String
);

Parameters

message
The message that indicates the reason this exception was thrown.

Remarks

TargetParmeterCountException inherits from the Exception. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | null
Message | The message string.

See Also

TargetParameterCountException Class | TargetParameterCountException Members | System.Reflection Namespace | TargetParameterCountException Constructor Overload List


TargetParameterCountException Constructor (String, Exception)

Initializes a new TargetParameterCountException with a string that indicates the cause of the exception and an exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public TargetParameterCountException(
   string message,
   Exception inner
);
[C++]
public: TargetParameterCountException(
   String* message,
   Exception* inner
);
[JScript]
public function TargetParameterCountException(
   message : String,
   inner : Exception
);

Parameters

message
The message that indicates the reason this exception was thrown.
inner
The exception, which is the root cause of this exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

TargetParameterCountException inherits from the Exception. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | The inner exception.
Message | The message string.

See Also

TargetParameterCountException Class | TargetParameterCountException Members | System.Reflection Namespace | TargetParameterCountException Constructor Overload List


TypeAttributes Enumeration

To be supplied.

[Visual Basic]
Public Enum TypeAttributes
[C#]
public enum TypeAttributes
[C++]
public enum TypeAttributes

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Abstract | Type is abstract.
AnsiClass | [To be supplied.]
AutoClass | [To be supplied.]
AutoLayout | Fields are automatically laid out by the runtime.
Class | Current type is a class.
ClassSemanticsMask | Current class is contextful (else agile).
Enum | Type is an enumeration.
ExplicitLayout | Fields of this type are laid out at the specified offsets.
HasSecurity | [To be supplied.]
Import | Class or interface is imported from another module.
Interface | Type is an interface.
LateInit | [To be supplied.]
LayoutMask | To be supplied.
LayoutSequential | Fields of this type are laid out sequentially, in the order that the fields were emitted to the metadata.
NestedAssembly | Class is nested, and that it is accessible only by methods within its assembly.
NestedFamANDAssem | Class is nested, and that it is accessible only by methods lying in the intersection of its family and assembly.
NestedFamily | Class is nested, and that it is accessible only by methods within its own type and any sub-types.
NestedFamORAssem | Class is nested, and that it is accessible only by methods lying in the union of its family and assembly.
NestedPrivate | Class is nested, and that it is accessible only by methods in its own, or its enclosing type.
NestedPublic | Class is nested, and that it is accessible only by methods outside of its assembly.
NotPublic | Class is nested, and that it is not accessible by methods outside of its assembly.
Public | Class is nested, and that it is accessible only by methods outside of its assembly.
ReservedMask | [To be supplied.]
RTSpecialName | [To be supplied.]
Sealed | Subclass cannot be derived from the type; it is concrete.
Serializable | Class can be serialized.
SpecialName | Class is special in a way denoted by the name.
StringFormatMask | [To be supplied.]
UnicodeClass | [To be supplied.]
UnmanagedValueType | Type is never allocated from the garbage collection heap. This is used for Interop.
ValueType | Type has value-based semantics.
VisibilityMask | To be supplied.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

System.Reflection Namespace


TypeDelegator Class

This class wraps a Type object and delegates all methods to that Type. It is useful to subclass this type and only overload those methods you need to provide customization in.

Object
MemberInfo
Type
TypeDelegator

[Visual Basic]
Public Class TypeDelegator
   Inherits Type
[C#]
public class TypeDelegator : Type
[C++]
public __gc class TypeDelegator : public Type
[JScript]
public class TypeDelegator extends Type

Remarks

Delegates are used for the managed code objects to encapsulate method calls. They are used primarily in Event notifications and callbacks.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

TypeDelegator Members | System.Reflection Namespace


TypeDelegator Members

Public:

Constructor

TypeDelegator Constructor Overloaded. Initializes a new instance of the TypeDelegator class.

Properties

AssemblyQualifiedName | [To be supplied.]
Attributes (inherited from Type) | Gets a bitmask indicating the attributes associated with the Type.
BaseType | Retrieves the base type for the current type.
DeclaringType (inherited from Type) | Gets the current Type.
FullName | Retrieves the fully qualified name of the implemented type.
GUID | Retrieves the GUID (Global Unique Identifier) of the implemented type.
HasElementType (inherited from Type) | Gets a value indicating whether the Type ...
IsAbstract (inherited from Type) | Gets a value indicating whether the Type is abstract and must be overridden.
IsAnsiClass (inherited from Type) | Gets a value indicating whether the string format attribute AnsiClass is selected for the Type.
IsArray (inherited from Type) | Gets a value indicating whether the Type is an array.
IsAutoClass (inherited from Type) | Gets a value indicating whether the string format attribute AutoClass is selected for the Type.
IsAutoLayout (inherited from Type) | Gets a value indicating whether the class layout attribute AutoLayout is selected for the Type.
IsByRef (inherited from Type) | Gets a value indicating whether the Type is passed by reference.
IsClass (inherited from Type) | Gets a value indicating whether the Type is a class; that is, not a value type or interface.
IsCOMObject (inherited from Type) | Gets a value indicating whether the Type is a COM object.
IsContextful (inherited from Type) | Gets a value indicating whether the Type can be hosted in a context.
IsEnum (inherited from Type) | Gets a value indicating whether the Type is an enumeration.
IsExplicitLayout (inherited from Type) | Gets a value indicating whether the class layout attribute ExplicitLayout is selected for the Type.
IsImport (inherited from Type) | Gets a value indicating whether the Type was imported from another class.
IsInterface (inherited from Type) | Gets a value indicating whether the Type is an interface; that is, not a class or a value type.
IsLayoutSequential (inherited from Type) | Gets a value indicating whether the class layout attribute LayoutSequential is selected for the Type.
IsMarshalByRef (inherited from Type) | Gets a value indicating whether the Type is marshalled by reference.
IsNestedAssembly (inherited from Type) | Gets a value indicating whether the Type is nested and visible only within its own assembly.
IsNestedFamANDAssem (inherited from Type) | Gets a value indicating whether the Type is nested and visible only to classes that belong to both its own family and its own assembly.
IsNestedFamily (inherited from Type) | Gets a value indicating whether the Type is nested and visible only within its own family.
IsNestedFamORAssem (inherited from Type) | Gets a value indicating whether the Type is nested and visible only to classes that belong to its own family or to its own assembly.
IsNestedPrivate (inherited from Type) | Gets a value indicating whether the Type is nested and declared private.
IsNestedPublic (inherited from Type) | Gets a value indicating whether the Type is nested and declared public.
IsNotPublic (inherited from Type) | Gets a value indicating whether the Type is not declared public.
IsPointer (inherited from Type) | Gets a value indicating whether the Type is a pointer.
IsPrimitive (inherited from Type) | Gets a value indicating whether the Type is one of the primitive types.
IsPublic (inherited from Type) | Gets a value indicating whether the Type is declared public.
IsSealed (inherited from Type) | Gets a value indicating whether the Type is declared sealed.
IsSerializable (inherited from Type) | Gets a value indicating whether the Type is serializable.
IsSpecialName (inherited from Type) | Gets a value indicating whether the Type has a name that requires special handling.
IsUnicodeClass (inherited from Type) | Gets a value indicating whether the string format attribute UnicodeClass is selected for the Type.
IsUnmanagedValueType (inherited from Type) | Gets a value indicating whether the Type is one of the unmanaged value types.
IsValueType (inherited from Type) | Gets a value indicating whether the Type is a value type; that is, not a class or an interface.
MemberType (inherited from Type) | Gets a bit mask indicating the member type.
Module | Retrieves the module of the implemented type.
Name | Retrieves the name of the implemented type, with the path removed.
Namespace | Retrieves the namespace of the implemented type.
ReflectedType (inherited from Type) | Gets the current Type.
TypeHandle | Retrieves the handle to the type for the implemented type.
TypeInitializer (inherited from Type) | Gets the name of the class constructor for the Type.
UnderlyingSystemType | Retrieves the underlying Type that represents the implemented type.

Methods

Equals (inherited from Type) | Overloaded. Determines if the underlying system type of the current Type is the same as the underlying system type of the specified Object or Type.
FindInterfaces (inherited from Type) | Returns an array of Type objects representing a filtered list of interfaces implemented or inherited by the current Type.
FindMembers (inherited from Type) | Returns a filtered array of MemberInfo objects of the specified member type.
GetArrayRank (inherited from Type) | When implemented by a derived class, gets the number of dimensions in an Array.
GetConstructor (inherited from Type) | Overloaded. Gets a specific constructor of the current Type.
GetConstructors | Overloaded. [To be supplied.]
GetCustomAttributes | Overloaded. Returns an instance of each custom attribute defined on the given TypeDelegator.
GetDefaultMembers (inherited from Type) | Searches for the members defined for the current Type whose DefaultMemberAttribute is set.
GetElementType | To be supplied
GetEvent (inherited from Type) | Overloaded. Gets a specific event declared or inherited by the current Type.
GetEvents | Overloaded. [To be supplied.]
GetField (inherited from Type) | Overloaded. Gets a specific field of the current Type.
GetFields (inherited from Type) | Overloaded. Gets the fields of the current Type.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInterface | Overloaded. [To be supplied.]
GetInterfaceMap | [To be supplied.]
GetInterfaces | Returns an array of Type objects representing all the interfaces implemented on the current class and its superclasses.
GetMember (inherited from Type) | Overloaded. Gets the specified members of the current Type.
GetMembers | Overloaded. [To be supplied.]
GetMethod (inherited from Type) | Overloaded. Gets a specific method of the current Type.
GetMethods (inherited from Type) | Overloaded. Gets the methods of the current Type.
GetNestedType (inherited from Type) | Overloaded. Gets a specific type nested within the current Type.
GetNestedTypes | Overloaded. [To be supplied.]
GetProperties (inherited from Type) | Overloaded. Gets the properties of the current Type.
GetProperty (inherited from Type) | Overloaded. Gets a specific property of the current Type.
GetType (inherited from Object) | Gets the Type of the Object.
InvokeMember (inherited from Type) | Overloaded. Invokes a specific member of the current Type; essentially calls a constructor member or a method member, gets or sets a property member, gets or sets a data field member, or gets or sets an element of an array member.
IsAssignableFrom (inherited from Type) | Determines whether an instance of the specified type can be assigned to the current Type instance.
IsDefined | Checks to see if the TypeDelegator is defined on the given element (including inherited members).
IsInstanceOfType (inherited from Type) | Determines whether the specified object is an instance of the Type.
IsSubclassOf (inherited from Type) | Determines whether the current Type is a subclass of the specified class.
ToString (inherited from Type) | Returns a String representing the name of the current Type.

Protected:

Constructor

TypeDelegator Constructor Overloaded. Initializes a new instance of the TypeDelegator class.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetAttributeFlagsImpl | Gets the attributes assigned to the TypeDelegator.
GetConstructorImpl | Gets the constructor that implemented the TypeDelegator.
GetMethodImpl | To be supplied
GetPropertyImpl | To be supplied
HasElementTypeImpl | To be supplied
IsArrayImpl | To be supplied
IsByRefImpl | Checks if this TypeDelegator is by reference.
IsCOMObjectImpl | Checks if this TypeDelegator imports a COM type.
IsContextfulImpl (inherited from Type) | Implements the IsContextful property and determines whether the Type can be hosted in a context.
IsMarshalByRefImpl (inherited from Type) | Implements the IsMarshalByRef property and determines whether the Type is marshalled by reference.
IsPointerImpl | To be supplied
IsPrimitiveImpl | To be supplied
IsValueTypeImpl | To be supplied
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

typeImpl To be supplied

See Also

TypeDelegator Class | System.Reflection Namespace


TypeDelegator Constructor

Initializes a new instance of the TypeDelegator class.

Overload List

Initializes a new instance of the TypeDelegator class with default properties.

[Visual Basic] Overloads Protected Sub New()
[C#] protected TypeDelegator();
[C++] protected: TypeDelegator();
[JScript] protected function TypeDelegator();

Initializes a new instance of the class TypeDelegator with the delegating Type parameter.

[Visual Basic] Overloads Public Sub New(Type)
[C#] public TypeDelegator(Type);
[C++] public: TypeDelegator(Type*);
[JScript] public function TypeDelegator(Type);

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator Constructor ()

Initializes a new instance of the TypeDelegator class with default properties.

[Visual Basic]
Overloads Protected Sub New()
[C#]
protected TypeDelegator();
[C++]
protected: TypeDelegator();
[JScript]
protected function TypeDelegator();

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace | TypeDelegator Constructor Overload List


TypeDelegator Constructor (Type)

Initializes a new instance of the class TypeDelegator with the delegating Type parameter.

[Visual Basic]
Overloads Public Sub New( _
   ByVal delegatingType As Type _
)
[C#]
public TypeDelegator(
   Type delegatingType
);
[C++]
public: TypeDelegator(
   Type* delegatingType
);
[JScript]
public function TypeDelegator(
   delegatingType : Type
);

Parameters

delegatingType
The instance of the class Type that encapsulates the call to the method of a object.

Exceptions

Exception Type | Condition
ArgumentNullException | The delegatingType parameter is null.

Remarks

This constructor is called from a class to generate a delegate based upon the Type object for the class defining the method.

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace | TypeDelegator Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypeDelegator Properties

The properties of the TypeDelegator class are listed below. For a complete list of TypeDelegator class members, see the TypeDelegator Members topic.

Public:

AssemblyQualifiedName | [To be supplied.]
Attributes (inherited from Type) | Gets a bitmask indicating the attributes associated with the Type.
BaseType | Retrieves the base type for the current type.
DeclaringType (inherited from Type) | Gets the current Type.
FullName | Retrieves the fully qualified name of the implemented type.
GUID | Retrieves the GUID (Global Unique Identifier) of the implemented type.
HasElementType (inherited from Type) | Gets a value indicating whether the Type ...
IsAbstract (inherited from Type) | Gets a value indicating whether the Type is abstract and must be overridden.
IsAnsiClass (inherited from Type) | Gets a value indicating whether the string format attribute AnsiClass is selected for the Type.
IsArray (inherited from Type) | Gets a value indicating whether the Type is an array.
IsAutoClass (inherited from Type) | Gets a value indicating whether the string format attribute AutoClass is selected for the Type.
IsAutoLayout (inherited from Type) | Gets a value indicating whether the class layout attribute AutoLayout is selected for the Type.
IsByRef (inherited from Type) | Gets a value indicating whether the Type is passed by reference.
IsClass (inherited from Type) | Gets a value indicating whether the Type is a class; that is, not a value type or interface.
IsCOMObject (inherited from Type) | Gets a value indicating whether the Type is a COM object.
IsContextful (inherited from Type) | Gets a value indicating whether the Type can be hosted in a context.
IsEnum (inherited from Type) | Gets a value indicating whether the Type is an enumeration.
IsExplicitLayout (inherited from Type) | Gets a value indicating whether the class layout attribute ExplicitLayout is selected for the Type.
IsImport (inherited from Type) | Gets a value indicating whether the Type was imported from another class.
IsInterface (inherited from Type) | Gets a value indicating whether the Type is an interface; that is, not a class or a value type.
IsLayoutSequential (inherited from Type) | Gets a value indicating whether the class layout attribute LayoutSequential is selected for the Type.
IsMarshalByRef (inherited from Type) | Gets a value indicating whether the Type is marshalled by reference.
IsNestedAssembly (inherited from Type) | Gets a value indicating whether the Type is nested and visible only within its own assembly.
IsNestedFamANDAssem (inherited from Type) | Gets a value indicating whether the Type is nested and visible only to classes that belong to both its own family and its own assembly.
IsNestedFamily (inherited from Type) | Gets a value indicating whether the Type is nested and visible only within its own family.
IsNestedFamORAssem (inherited from Type) | Gets a value indicating whether the Type is nested and visible only to classes that belong to its own family or to its own assembly.
IsNestedPrivate (inherited from Type) | Gets a value indicating whether the Type is nested and declared private.
IsNestedPublic (inherited from Type) | Gets a value indicating whether the Type is nested and declared public.
IsNotPublic (inherited from Type) | Gets a value indicating whether the Type is not declared public.
IsPointer (inherited from Type) | Gets a value indicating whether the Type is a pointer.
IsPrimitive (inherited from Type) | Gets a value indicating whether the Type is one of the primitive types.
IsPublic (inherited from Type) | Gets a value indicating whether the Type is declared public.
IsSealed (inherited from Type) | Gets a value indicating whether the Type is declared sealed.
IsSerializable (inherited from Type) | Gets a value indicating whether the Type is serializable.
IsSpecialName (inherited from Type) | Gets a value indicating whether the Type has a name that requires special handling.
IsUnicodeClass (inherited from Type) | Gets a value indicating whether the string format attribute UnicodeClass is selected for the Type.
IsUnmanagedValueType (inherited from Type) | Gets a value indicating whether the Type is one of the unmanaged value types.
IsValueType (inherited from Type) | Gets a value indicating whether the Type is a value type; that is, not a class or an interface.
MemberType (inherited from Type) | Gets a bit mask indicating the member type.
Module | Retrieves the module of the implemented type.
Name | Retrieves the name of the implemented type, with the path removed.
Namespace | Retrieves the namespace of the implemented type.
ReflectedType (inherited from Type) | Gets the current Type.
TypeHandle | Retrieves the handle to the type for the implemented type.
TypeInitializer (inherited from Type) | Gets the name of the class constructor for the Type.
UnderlyingSystemType | Retrieves the underlying Type that represents the implemented type.

See Also

TypeDelegator Class | System.Reflection Namespace


TypeDelegator.AssemblyQualifiedName

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property AssemblyQualifiedName As _
   String
[C#]
public string AssemblyQualifiedName {override get;}
[C++]
public: __property virtual String* get_AssemblyQualifiedName();
[JScript]
public function get AssemblyQualifiedName() : String;

Property Value

The base type for a type.

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.BaseType

Retrieves the base type for the current type.

[Visual Basic]
Overridable Public ReadOnly Property BaseType As Type
[C#]
public Type BaseType {override get;}
[C++]
public: __property virtual Type* get_BaseType();
[JScript]
public function get BaseType() : Type;

Property Value

The base type for a type.

Remarks

The base type is the type from which this type directly inherits. Since the Object class type is the ultimate base class of all the other types, it is the only type that does not have a base type. In this case a null reference is returned as the base type of the Object type.

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.FullName

Retrieves the fully qualified name of the implemented type.

[Visual Basic]
Overridable Public ReadOnly Property FullName As String
[C#]
public string FullName {override get;}
[C++]
public: __property virtual String* get_FullName();
[JScript]
public function get FullName() : String;

Property Value

Read only.

Remarks

A string containing the fully qualified name of the current TypeDelegator.

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.GUID

Retrieves the GUID (Global Unique Identifier) of the implemented type.

[Visual Basic]
Overridable Public ReadOnly Property GUID As Guid
[C#]
public Guid GUID {override get;}
[C++]
public: __property virtual Guid get_GUID();
[JScript]
public function get GUID() : Guid;

Property Value

Read only.

Remarks

The GUID (Global Unique Identifier) is a 128-bit, unique identification string used to identify a class or an interface. It is primarily useful for interoperability between the NGWS runtime and COM.

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace | Guid


TypeDelegator.Module

Retrieves the module of the implemented type.

[Visual Basic]
Overridable Public ReadOnly Property Module As Module
[C#]
public Module Module {override get;}
[C++]
public: __property virtual Module* get_Module();
[JScript]
public function get Module() : Module;

Property Value

Read only.

Remarks

A module is a portable executable file of type .dll or .exe consisting of one or more classes and interfaces.The module statement defines a group of functions, typically a set of DLL entry points.

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.Name

Retrieves the name of the implemented type, with the path removed.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {override get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

Property Value

Read only.

Remarks

A string containing the name of the current TypeDelegator. Only the simple name, not the fully qualified name, is returned. To get the name and the path, use FullName

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.Namespace

Retrieves the namespace of the implemented type.

[Visual Basic]
Overridable Public ReadOnly Property Namespace As String
[C#]
public string Namespace {override get;}
[C++]
public: __property virtual String* get_Namespace();
[JScript]
public function get Namespace() : String;

Property Value

Read only.

Remarks

A string containing the namespace of the current TypeDelegator. For example, if the TypeDelegator is TypeFilter the returned namespace is System.Reflection.

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.TypeHandle

Retrieves the handle to the type for the implemented type.

[Visual Basic]
Overridable Public ReadOnly Property TypeHandle As _
   RuntimeTypeHandle
[C#]
public RuntimeTypeHandle TypeHandle {override get;}
[C++]
public: __property virtual RuntimeTypeHandle get_TypeHandle();
[JScript]
public function get TypeHandle() : RuntimeTypeHandle;

Property Value

Read only.

Remarks

A type handle is a unique integer value associated with each type. The handle is unique during the runtime.

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.UnderlyingSystemType

Retrieves the underlying Type that represents the implemented type.

[Visual Basic]
Overridable Public ReadOnly Property UnderlyingSystemType As Type
[C#]
public Type UnderlyingSystemType {override get;}
[C++]
public: __property virtual Type* get_UnderlyingSystemType();
[JScript]
public function get UnderlyingSystemType() : Type;

Property Value

Read only. A type representing the current TypeDelegator.

Remarks

[To be supplied]

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypeDelegator Methods

The methods of the TypeDelegator class are listed below. For a complete list of TypeDelegator class members, see the TypeDelegator Members topic.

Public:

Equals (inherited from Type) | Overloaded. Determines if the underlying system type of the current Type is the same as the underlying system type of the specified Object or Type.
FindInterfaces (inherited from Type) | Returns an array of Type objects representing a filtered list of interfaces implemented or inherited by the current Type.
FindMembers (inherited from Type) | Returns a filtered array of MemberInfo objects of the specified member type.
GetArrayRank (inherited from Type) | When implemented by a derived class, gets the number of dimensions in an Array.
GetConstructor (inherited from Type) | Overloaded. Gets a specific constructor of the current Type.
GetConstructors | Overloaded. [To be supplied.]
GetCustomAttributes | Overloaded. Returns an instance of each custom attribute defined on the given TypeDelegator.
GetDefaultMembers (inherited from Type) | Searches for the members defined for the current Type whose DefaultMemberAttribute is set.
GetElementType | To be supplied
GetEvent (inherited from Type) | Overloaded. Gets a specific event declared or inherited by the current Type.
GetEvents | Overloaded. [To be supplied.]
GetField (inherited from Type) | Overloaded. Gets a specific field of the current Type.
GetFields (inherited from Type) | Overloaded. Gets the fields of the current Type.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInterface | Overloaded. [To be supplied.]
GetInterfaceMap | [To be supplied.]
GetInterfaces | Returns an array of Type objects representing all the interfaces implemented on the current class and its superclasses.
GetMember (inherited from Type) | Overloaded. Gets the specified members of the current Type.
GetMembers | Overloaded. [To be supplied.]
GetMethod (inherited from Type) | Overloaded. Gets a specific method of the current Type.
GetMethods (inherited from Type) | Overloaded. Gets the methods of the current Type.
GetNestedType (inherited from Type) | Overloaded. Gets a specific type nested within the current Type.
GetNestedTypes | Overloaded. [To be supplied.]
GetProperties (inherited from Type) | Overloaded. Gets the properties of the current Type.
GetProperty (inherited from Type) | Overloaded. Gets a specific property of the current Type.
GetType (inherited from Object) | Gets the Type of the Object.
InvokeMember (inherited from Type) | Overloaded. Invokes a specific member of the current Type; essentially calls a constructor member or a method member, gets or sets a property member, gets or sets a data field member, or gets or sets an element of an array member.
IsAssignableFrom (inherited from Type) | Determines whether an instance of the specified type can be assigned to the current Type instance.
IsDefined | Checks to see if the TypeDelegator is defined on the given element (including inherited members).
IsInstanceOfType (inherited from Type) | Determines whether the specified object is an instance of the Type.
IsSubclassOf (inherited from Type) | Determines whether the current Type is a subclass of the specified class.
ToString (inherited from Type) | Returns a String representing the name of the current Type.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetAttributeFlagsImpl | Gets the attributes assigned to the TypeDelegator.
GetConstructorImpl | Gets the constructor that implemented the TypeDelegator.
GetMethodImpl | To be supplied
GetPropertyImpl | To be supplied
HasElementTypeImpl | To be supplied
IsArrayImpl | To be supplied
IsByRefImpl | Checks if this TypeDelegator is by reference.
IsCOMObjectImpl | Checks if this TypeDelegator imports a COM type.
IsContextfulImpl (inherited from Type) | Implements the IsContextful property and determines whether the Type can be hosted in a context.
IsMarshalByRefImpl (inherited from Type) | Implements the IsMarshalByRef property and determines whether the Type is marshalled by reference.
IsPointerImpl | To be supplied
IsPrimitiveImpl | To be supplied
IsValueTypeImpl | To be supplied
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeDelegator Class | System.Reflection Namespace


TypeDelegator.GetAttributeFlagsImpl

Gets the attributes assigned to the TypeDelegator.

[Visual Basic]
Overrides Protected Function GetAttributeFlagsImpl() As _
   TypeAttributes
[C#]
protected override TypeAttributes GetAttributeFlagsImpl();
[C++]
protected: override TypeAttributes GetAttributeFlagsImpl();
[JScript]
protected override function GetAttributeFlagsImpl() :
   TypeAttributes;

Return Value

Returns the implementation attribute flags.

Remarks

This method can be used to determine if the TypeDelegator is an Abstract, Public, etc. class.

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace | TypeAttributes


TypeDelegator.GetConstructorImpl

Gets the constructor that implemented the TypeDelegator.

[Visual Basic]
Overrides Protected Function GetConstructorImpl( _
   ByVal bindingAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal callConvention As CallingConventions, _
   ByVal types() As Type, _
   ByVal modifiers() As ParameterModifier _
) As ConstructorInfo
[C#]
protected override ConstructorInfo GetConstructorImpl(
   BindingFlags bindingAttr,
   Binder binder,
   CallingConventions callConvention,
   Type[] types,
   ParameterModifier[] modifiers
);
[C++]
protected: override ConstructorInfo* GetConstructorImpl(
   BindingFlags bindingAttr,
   Binder* binder,
   CallingConventions callConvention,
   Type* types[],
   ParameterModifier* modifiers[]
);
[JScript]
protected override function GetConstructorImpl(
   bindingAttr : BindingFlags,
   binder : Binder,
   callConvention : CallingConventions,
   types : Type[],
   modifiers : ParameterModifier[]
) : ConstructorInfo;

Parameters

bindingAttr
This bit mask affects the way in which the search is conducted. The value is a combination of zero or more bit flags from BindingFlags, such as NonPublic and Default.
binder
An object that enables the binding, coercion of argument types, invocation of members, and retrieval of MemberInfo objects via reflection. If binder is null, the default binder is used. See Binder.
callConvention
The calling conventions.
types
A list of parameter types. The list represents the number, order, and types of the parameters. Types cannot be null; use an appropriate GetMethod method or an empty array to search for a method without parameters.
modifiers
An array of the same length as types with elements that represent the attributes associated with the parameters of the method to get.

Return Value

A ConstructorInfo object for the method that matches the specified criteria, or null if a match cannot be found.

Remarks

The CallingConventions parameter indicates the calling convention for the entry point. If no CallingConventions is specified, a default CallingConventions value of Standard is used.

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace | CallingConventions


TypeDelegator.GetConstructors

Returns an array of ConstructorInfo objects representing constructors defined for the current class.

[Visual Basic]
Overrides Public Function GetConstructors( _
   ByVal bindingAttr As BindingFlags _
) As ConstructorInfo ()
[C#]
public override ConstructorInfo[] GetConstructors(
   BindingFlags bindingAttr
);
[C++]
public: override ConstructorInfo* GetConstructors(
   BindingFlags bindingAttr
) [];
[JScript]
public override function GetConstructors(
   bindingAttr : BindingFlags
) : ConstructorInfo[];

Parameters

bindingAttr
This bit mask affects the way in which the search is conducted. The value is a BindingFlags, such as NonPublic or Public.

Return Value

Returns an array of ConstructorInfo objects representing the specified constructors defined for this class. If no constructors are defined, an empty array is returned.

Depending on the value of a specified parameter, only public constructors or both public and non-public constructors will be returned.

Remarks

Class initializers are available only through GetMember, GetMembers, FindMembers, and GetConstructors.

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.GetCustomAttributes

Returns an instance of each custom attribute defined on the given TypeDelegator.

Overload List

Returns an instance of each custom attribute defined on the given TypeDelegator.

[Visual Basic] Overloads Overrides Public Function GetCustomAttributes() As Object ()
[C#] public override object[] GetCustomAttributes();
[C++] public: override Object* GetCustomAttributes() [];
[JScript] public override function GetCustomAttributes() : Object[];

Returns an instance of each custom attribute defined on the given TypeDelegator that meet the Type criteria.

[Visual Basic] Overloads Overrides Public Function GetCustomAttributes(Type) As Object ()
[C#] public override object[] GetCustomAttributes(Type);
[C++] public: override Object* GetCustomAttributes(Type*) [];
[JScript] public override function GetCustomAttributes(Type) : Object[];

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.GetCustomAttributes ()

Returns an instance of each custom attribute defined on the given TypeDelegator.

[Visual Basic]
Overloads Overrides Public Function GetCustomAttributes() As Object ()
[C#]
public override object[] GetCustomAttributes();
[C++]
public: override Object* GetCustomAttributes() [];
[JScript]
public override function GetCustomAttributes() : Object[];

Return Value

Returns an array of all the custom attributes defined on this TypeDelegator.

Exceptions

Exception Type | Condition
TypeLoadException | if the custom attribute type can not be loaded.

Remarks

Returns an empty array if non-custom attributes exists on this the given element. Ignores any attributes that don't inherit from Attribute. If a type is specified, the array returned must be an array of that type.

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace | TypeDelegator.GetCustomAttributes Overload List | Attribute


TypeDelegator.GetCustomAttributes (Type)

Returns an instance of each custom attribute defined on the given TypeDelegator that meet the Type criteria.

[Visual Basic]
Overloads Overrides Public Function GetCustomAttributes( _
   ByVal attributeType As Type _
) As Object ()
[C#]
public override object[] GetCustomAttributes(
   Type attributeType
);
[C++]
public: override Object* GetCustomAttributes(
   Type* attributeType
) [];
[JScript]
public override function GetCustomAttributes(
   attributeType : Type
) : Object[];

Parameters

attributeType
The type of the attribute to be returned.

Return Value

Returns an array of all the custom attributes of type attributeType defined on this TypeDelegator.

Exceptions

Exception Type | Condition
TypeLoadException | if the custom attribute type can not be loaded.

Remarks

Returns an empty array if non-custom attributes exists on this the given element. Ignores any attributes that don't inherit from Attribute. If a type is specified, the array returned must be an array of that type.

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace | TypeDelegator.GetCustomAttributes Overload List | Attribute


TypeDelegator.GetElementType

To be supplied

[Visual Basic]
Overrides Public Function GetElementType() As Type
[C#]
public override Type GetElementType();
[C++]
public: override Type* GetElementType();
[JScript]
public override function GetElementType() : Type;

Return Value

The Type object representing the type of the elements of the current array.

Exceptions

Exception Type | Condition
TypeLoadException | if the custom attribute type can not be loaded.

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.GetEvent

Returns the EventInfo object representing specified event.

[Visual Basic]
Overrides Public Function GetEvent( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags _
) As EventInfo
[C#]
public override EventInfo GetEvent(
   string name,
   BindingFlags bindingAttr
);
[C++]
public: override EventInfo* GetEvent(
   String* name,
   BindingFlags bindingAttr
);
[JScript]
public override function GetEvent(
   name : String,
   bindingAttr : BindingFlags
) : EventInfo;

Parameters

name
The name of the event to get.
bindingAttr
This bit mask affects the way in which the search is conducted. The value is a BindingFlags.IgnoreCase, to ignore the case.

Return Value

Returns an EventInfo object representing the event declared or inherited by this type with the specified name. Returns null if no such event is found.

Remarks

If bindingAttr is BindingFlags.IgnoreCase, the case on name is ignored.

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.GetEvents

[To be supplied.]

Overload List

Returns an array of EventInfo objects representing all the public events declared or inherited by the current TypeDelegator.

[Visual Basic] Overloads Overrides Public Function GetEvents() As EventInfo ()
[C#] public override EventInfo[] GetEvents();
[C++] public: override EventInfo* GetEvents() [];
[JScript] public override function GetEvents() : EventInfo[];

Returns an array of EventInfo objects representing all the public events declared or inherited by the current TypeDelegator.

[Visual Basic] Overloads Overrides Public Function GetEvents(BindingFlags) As EventInfo ()
[C#] public override EventInfo[] GetEvents(BindingFlags);
[C++] public: override EventInfo* GetEvents(BindingFlags) [];
[JScript] public override function GetEvents(BindingFlags) : EventInfo[];

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.GetEvents ()

Returns an array of EventInfo objects representing all the public events declared or inherited by the current TypeDelegator.

[Visual Basic]
Overloads Overrides Public Function GetEvents() As EventInfo ()
[C#]
public override EventInfo[] GetEvents();
[C++]
public: override EventInfo* GetEvents() [];
[JScript]
public override function GetEvents() : EventInfo[];

Return Value

Returns an array of EventInfo objects representing all the events declared or inherited by the current type. If there are no public events, an empty array is returned.

Remarks

To be supplied

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace | TypeDelegator.GetEvents Overload List


TypeDelegator.GetEvents (BindingFlags)

Returns an array of EventInfo objects representing all the public events declared or inherited by the current TypeDelegator.

[Visual Basic]
Overloads Overrides Public Function GetEvents( _
   ByVal bindingAttr As BindingFlags _
) As EventInfo ()
[C#]
public override EventInfo[] GetEvents(
   BindingFlags bindingAttr
);
[C++]
public: override EventInfo* GetEvents(
   BindingFlags bindingAttr
) [];
[JScript]
public override function GetEvents(
   bindingAttr : BindingFlags
) : EventInfo[];

Parameters

bindingAttr
[To be supplied.]

Return Value

Returns an array of EventInfo objects representing all the events declared or inherited by the current type. If there are no public events, an empty array is returned.

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace | TypeDelegator.GetEvents Overload List


TypeDelegator.GetField

Returns the FieldInfo object representing the field with the specified name.

[Visual Basic]
Overrides Public Function GetField( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags _
) As FieldInfo
[C#]
public override FieldInfo GetField(
   string name,
   BindingFlags bindingAttr
);
[C++]
public: override FieldInfo* GetField(
   String* name,
   BindingFlags bindingAttr
);
[JScript]
public override function GetField(
   name : String,
   bindingAttr : BindingFlags
) : FieldInfo;

Parameters

name
The name of the field to find.
bindingAttr
This bit mask affects the way in which the search is conducted. The binding attributes used to control the search. An example is Binder.NonPublic

Return Value

Returns an FieldInfo object representing the field declared or inherited by this TypeDelegator with the specified name. Returns null if no such field is found.

Remarks

Use a bindingAttr of BindingFlags.NonPublic to return all public and nonpublic fields. Use BindingFlags.IgnoreCase to ignore the case of the fields as the search is case sensitive.

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.GetFields

Returns an array of FieldInfo objects representing the fields, or data members, defined for the current class.

[Visual Basic]
Overrides Public Function GetFields( _
   ByVal bindingAttr As BindingFlags _
) As FieldInfo ()
[C#]
public override FieldInfo[] GetFields(
   BindingFlags bindingAttr
);
[C++]
public: override FieldInfo* GetFields(
   BindingFlags bindingAttr
) [];
[JScript]
public override function GetFields(
   bindingAttr : BindingFlags
) : FieldInfo[];

Parameters

bindingAttr
This bit mask affects the way in which the search is conducted. The binding attributes used to control the search. An example is Binder.NonPublic

Return Value

An array of FieldInfo objects representing the fields declared or inherited by the current TypeDelegator . An empty array is returned if there are no matched fields.

Remarks

Use a bindingAttr of BindingFlags.NonPublic to return all public and nonpublic fields.

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.GetInterface

Returns a Type object representing a specified interface implemented by the current class.

[Visual Basic]
Overrides Public Function GetInterface( _
   ByVal name As String, _
   ByVal ignoreCase As Boolean _
) As Type
[C#]
public override Type GetInterface(
   string name,
   bool ignoreCase
);
[C++]
public: override Type* GetInterface(
   String* name,
   bool ignoreCase
);
[JScript]
public override function GetInterface(
   name : String,
   ignoreCase : Boolean
) : Type;

Parameters

name
The fully qualified name of the interface implemented by the current class.
ignoreCase
A flag indicating whether case is to be ignored (true) or considered (false)

Return Value

A Type object representing the interface implemented (directly or indirectly) by the current class with the fully qualified name matching the specified name. If no interface that matches name is found, null is returned.

Remarks

To be supplied

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.GetInterfaceMap

[To be supplied.]

[Visual Basic]
Overrides Public Function GetInterfaceMap( _
   ByVal interfaceType As Type _
) As InterfaceMapping
[C#]
public override InterfaceMapping GetInterfaceMap(
   Type interfaceType
);
[C++]
public: override InterfaceMapping GetInterfaceMap(
   Type* interfaceType
);
[JScript]
public override function GetInterfaceMap(
   interfaceType : Type
) : InterfaceMapping;

Parameters

interfaceType
[To be supplied.]

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.GetInterfaces

Returns an array of Type objects representing all the interfaces implemented on the current class and its superclasses.

[Visual Basic]
Overrides Public Function GetInterfaces() As Type ()
[C#]
public override Type[] GetInterfaces();
[C++]
public: override Type* GetInterfaces() [];
[JScript]
public override function GetInterfaces() : Type[];

Return Value

An array of Type objects representing all the interfaces implemented on the current class and its superclasses. If none are defined, an empty array is returned.

Remarks

To be supplied

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.GetMember

Returns an array of specified MemberInfo objects, representing members (properties, methods, fields, events, etc) specified by the given name and bindingAttr.

[Visual Basic]
Overrides Public Function GetMember( _
   ByVal name As String, _
   ByVal type As MemberTypes, _
   ByVal bindingAttr As BindingFlags _
) As MemberInfo ()
[C#]
public override MemberInfo[] GetMember(
   string name,
   MemberTypes type,
   BindingFlags bindingAttr
);
[C++]
public: override MemberInfo* GetMember(
   String* name,
   MemberTypes type,
   BindingFlags bindingAttr
) [];
[JScript]
public override function GetMember(
   name : String,
   type : MemberTypes,
   bindingAttr : BindingFlags
) : MemberInfo[];

Parameters

name
The name of the member to get.
type
[To be supplied.]
bindingAttr
This bit mask affects the way in which the search is conducted. The binding attributes used to control the search. An example is BindingFlags.NonPublic

Return Value

Returns an array of MemberInfo objects representing all the members of the current class which have the specified name meets the bindingAttr filter. Returns the members from the current class and its base classes.

Remarks

If bindingAttr is BindingFlags.NonPublic, all the members will be considered. If there are no matches, an empty array is returned.

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.GetMembers

Returns an array of specified MemberInfo objects, representing members (properties, methods, fields, events, etc) specified by bindingAttr.

[Visual Basic]
Overrides Public Function GetMembers( _
   ByVal bindingAttr As BindingFlags _
) As MemberInfo ()
[C#]
public override MemberInfo[] GetMembers(
   BindingFlags bindingAttr
);
[C++]
public: override MemberInfo* GetMembers(
   BindingFlags bindingAttr
) [];
[JScript]
public override function GetMembers(
   bindingAttr : BindingFlags
) : MemberInfo[];

Parameters

bindingAttr
This bit mask affects the way in which the search is conducted. The binding attributes used to control the search. An example is BindingFlags.NonPublic

Return Value

Returns an array of MemberInfo objects representing all the members of the current class which meets the bindingAttr filter. Returns the members from the current class and its base classes.

Remarks

If bindingAttr is BindingFlags.NonPublic, all the members will be considered. If there are no matches, an empty array is returned.

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.GetMethodImpl

To be supplied

[Visual Basic]
Overrides Protected Function GetMethodImpl( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal callConvention As CallingConventions, _
   ByVal types() As Type, _
   ByVal modifiers() As ParameterModifier _
) As MethodInfo
[C#]
protected override MethodInfo GetMethodImpl(
   string name,
   BindingFlags bindingAttr,
   Binder binder,
   CallingConventions callConvention,
   Type[] types,
   ParameterModifier[] modifiers
);
[C++]
protected: override MethodInfo* GetMethodImpl(
   String* name,
   BindingFlags bindingAttr,
   Binder* binder,
   CallingConventions callConvention,
   Type* types[],
   ParameterModifier* modifiers[]
);
[JScript]
protected override function GetMethodImpl(
   name : String,
   bindingAttr : BindingFlags,
   binder : Binder,
   callConvention : CallingConventions,
   types : Type[],
   modifiers : ParameterModifier[]
) : MethodInfo;

Parameters

name
To be supplied
bindingAttr
This bit mask affects the way in which the search is conducted. The binding attributes used to control the search. An example is BindingFlags.NonPublic
binder
An object that enables the binding, coercion of argument types, invocation of members, and retrieval of MemberInfo objects via reflection. If binder is null, the default binder is used. See Binder.
callConvention
The calling conventions.
types
A list of parameter types. The list represents the number, order, and types of the parameters. Types cannot be null; use an appropriate GetMethod method or an empty array to search for a method without parameters.
modifiers
An array of the same length as types with elements that represent the attributes associated with the parameters of the method to get.

Return Value

A MethodInfoInfo object for the implementation method that matches the specified criteria, or null if a match cannot be found.

Remarks

To be supplied

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.GetMethods

Returns an array of MethodInfo objects representing specified methods of the current TypeDelegator.

[Visual Basic]
Overrides Public Function GetMethods( _
   ByVal bindingAttr As BindingFlags _
) As MethodInfo ()
[C#]
public override MethodInfo[] GetMethods(
   BindingFlags bindingAttr
);
[C++]
public: override MethodInfo* GetMethods(
   BindingFlags bindingAttr
) [];
[JScript]
public override function GetMethods(
   bindingAttr : BindingFlags
) : MethodInfo[];

Parameters

bindingAttr
This bit mask affects the way in which the search is conducted. The binding attributes used to control the search. An example is BindingFlags.NonPublic

Return Value

An array of MethodInfo objects representing the methods defined on this TypeDelegator

Remarks

Returns the methods declared or inherited

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.GetNestedType

To be supplied

[Visual Basic]
Overrides Public Function GetNestedType( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags _
) As Type
[C#]
public override Type GetNestedType(
   string name,
   BindingFlags bindingAttr
);
[C++]
public: override Type* GetNestedType(
   String* name,
   BindingFlags bindingAttr
);
[JScript]
public override function GetNestedType(
   name : String,
   bindingAttr : BindingFlags
) : Type;

Parameters

name
To be supplied
bindingAttr
This bit mask affects the way in which the search is conducted. The binding attributes used to control the search. An example is BindingFlags.NonPublic

Return Value

To be supplied

Remarks

To be supplied

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.GetNestedTypes

To be supplied

[Visual Basic]
Overrides Public Function GetNestedTypes( _
   ByVal bindingAttr As BindingFlags _
) As Type ()
[C#]
public override Type[] GetNestedTypes(
   BindingFlags bindingAttr
);
[C++]
public: override Type* GetNestedTypes(
   BindingFlags bindingAttr
) [];
[JScript]
public override function GetNestedTypes(
   bindingAttr : BindingFlags
) : Type[];

Parameters

bindingAttr
This bit mask affects the way in which the search is conducted. The binding attributes used to control the search. An example is BindingFlags.NonPublic

Return Value

To be supplied

Remarks

To be supplied

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.GetProperties

Returns an array of PropertyInfo objects representing properties defined on this TypeDelegator.

[Visual Basic]
Overrides Public Function GetProperties( _
   ByVal bindingAttr As BindingFlags _
) As PropertyInfo ()
[C#]
public override PropertyInfo[] GetProperties(
   BindingFlags bindingAttr
);
[C++]
public: override PropertyInfo* GetProperties(
   BindingFlags bindingAttr
) [];
[JScript]
public override function GetProperties(
   bindingAttr : BindingFlags
) : PropertyInfo[];

Parameters

bindingAttr
This bit mask affects the way in which the search is conducted. The binding attributes used to control the search. An example is BindingFlags.NonPublic

Return Value

An array of PropertyInfo objects representing properties defined on this TypeDelegator.

Remarks

To be supplied

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.GetPropertyImpl

To be supplied

[Visual Basic]
Overrides Protected Function GetPropertyImpl( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal types() As Type, _
   ByVal modifiers() As ParameterModifier _
) As PropertyInfo
[C#]
protected override PropertyInfo GetPropertyImpl(
   string name,
   BindingFlags bindingAttr,
   Binder binder,
   Type[] types,
   ParameterModifier[] modifiers
);
[C++]
protected: override PropertyInfo* GetPropertyImpl(
   String* name,
   BindingFlags bindingAttr,
   Binder* binder,
   Type* types[],
   ParameterModifier* modifiers[]
);
[JScript]
protected override function GetPropertyImpl(
   name : String,
   bindingAttr : BindingFlags,
   binder : Binder,
   types : Type[],
   modifiers : ParameterModifier[]
) : PropertyInfo;

Parameters

name
To be supplied
bindingAttr
This bit mask affects the way in which the search is conducted. The value is a combination of zero or more bit flags from BindingFlags, such as NonPublic and Default.
binder
An object that enables the binding, coercion of argument types, invocation of members, and retrieval of MemberInfo objects via reflection. If binder is null, the default binder is used. See Binder.
types
A list of parameter types. The list represents the number, order, and types of the parameters. Types cannot be null; use an appropriate GetMethod method or an empty array to search for a method without parameters.
modifiers
An array of the same length as types with elements that represent the attributes associated with the parameters of the method to get.

Return Value

A PropertyInfo object for the property that matches the specified criteria, or null if a match cannot be found.

Remarks

To be supplied

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.HasElementTypeImpl

To be supplied

[Visual Basic]
Overrides Protected Function HasElementTypeImpl() As Boolean
[C#]
protected override bool HasElementTypeImpl();
[C++]
protected: override bool HasElementTypeImpl();
[JScript]
protected override function HasElementTypeImpl() : Boolean;

Return Value

To be supplied

Remarks

To be supplied

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.InvokeMember

[To be supplied.]

[Visual Basic]
Overrides Public Function InvokeMember( _
   ByVal name As String, _
   ByVal invokeAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal target As Object, _
   ByVal args() As Object, _
   ByVal modifiers() As ParameterModifier, _
   ByVal culture As CultureInfo, _
   ByVal namedParameters() As String _
) As Object
[C#]
public override object InvokeMember(
   string name,
   BindingFlags invokeAttr,
   Binder binder,
   object target,
   object[] args,
   ParameterModifier[] modifiers,
   CultureInfo culture,
   string[] namedParameters
);
[C++]
public: override Object* InvokeMember(
   String* name,
   BindingFlags invokeAttr,
   Binder* binder,
   Object* target,
   Object* args[],
   ParameterModifier* modifiers[],
   CultureInfo* culture,
   String* namedParameters[]
);
[JScript]
public override function InvokeMember(
   name : String,
   invokeAttr : BindingFlags,
   binder : Binder,
   target : Object,
   args : Object[],
   modifiers : ParameterModifier[],
   culture : CultureInfo,
   namedParameters : String[]
) : Object;

Parameters

name
The name of the member to invoke. This may be a constructor, method, property, or field. If an empty string ("") is passed, the default member is invoked.
invokeAttr
The invocation attribute. This must be a bit flag from BindingFlags: InvokeMethod, CreateInstance, Static, GetField, SetField, GetProperty, or SetProperty. A suitable invocation attribute must be specified. If a static member is to be invoked, the Static flag must be set.
binder
An object that enables the binding, coercion of argument types, invocation of members, and retrieval of MemberInfo objects via reflection. If binder is null, the default binder is used. See Binder.
target
The object on which to invoke the specified member.
args
An argument list. This is an array of variants that contains the number, order, and type of the parameters of the member to be invoked. If the args contain an uninitialized variant, it is treated a Variant.Empty, which, with the default binder, can be widened to 0, 0.0 or String.
modifiers
An array of the same length as args with elements that represent the attributes associated with the arguments of the member to be invoked. A parameter has attributes associated with it in the member's signature. For ByRef, use ParameterModifer.ByRef and for none use ParameterModifer.None. The default binder does exact matching on these. Attributes such as In, InOut, etc. are not used in binding, they can be viewed using ParameterInfo.
culture
An instance of CultureInfo used to govern the coercion of types. If this is null, the CultureInfo for the current thread's CultureInfo is used. (Note that this is necessary to, for example, convert a String that represents 1000 to a Double value, since 1000 is represented differently by different cultures.)
namedParameters
This array of parameter names match up starting at element zero with the args array. That args[0] is matched with the parameter named namedParamaters[0] etc. There must be no "wholes" in the array. If args.Length > namedParameters.Length, the remaining parameters are filled in order.

Return Value

Returns the value of the invoked member.

Remarks

A method will be invoked if

the number of parameters in the method declaration equals the number of arguments in the specified argument list (unless default arguments are defined on the member), and

the type of each arguments can be converted by the binder to the type of the parameter.

The binder will find all of the matching methods. These methods are found based upon the type of binding requested (BindingFlags.MethodInvoke, BindingFlags.GetProperties, etc.). The set of methods is filtered by the name, number of arguments, and a set of search modifiers defined in the binder.

After the method is selected, it will be invoked. Accessibility is checked at that point. The search may control which set of methods are searched based upon the accessibility attribute associated with the method. The Binder.BindToMethod method is responsible for selecting the method to be invoked. The default binder selects the most specific match.

Note: Access restrictions are ignored for fully trusted code. That is, private constructors, methods, fields, and properties can be accessed and invoked via Reflection whenever the code is fully trusted.

Currently, InvokeMember performs the NGWS runtime reflection semantics for every type of object.

If the member specified by name is an array and the BindingFlags.GetField flag is set on invokeAttr, the args array specifies the elements whose values are to be returned. For example, the following call through Type object t returns the value of the first element of the string array MyArray, which is a member of the calling object:

String ret = (String) t.InvokeMember ("MyArray", BindingFlags.GetField, null, this, new Variant[]{0});

You can use InvokeMember to set one or more elements of a member array. All elements are set to the same value. The args array must be formatted as follows:

{index1, index2, ..., value}

For example, to set the first member of MyArray from the previous example, the syntax is as follows:

t.InvokeMember ("MyArray", BindingFlags.SetField, null, this, new Variant[]{0,"Updated"});

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace | CultureInfo


TypeDelegator.IsArrayImpl

To be supplied

[Visual Basic]
Overrides Protected Function IsArrayImpl() As Boolean
[C#]
protected override bool IsArrayImpl();
[C++]
protected: override bool IsArrayImpl();
[JScript]
protected override function IsArrayImpl() : Boolean;

Return Value

To be supplied

Remarks

To be supplied

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.IsByRefImpl

Checks if this TypeDelegator is by reference.

[Visual Basic]
Overrides Protected Function IsByRefImpl() As Boolean
[C#]
protected override bool IsByRefImpl();
[C++]
protected: override bool IsByRefImpl();
[JScript]
protected override function IsByRefImpl() : Boolean;

Return Value

Returns true if this TypeDelegator is ByRef, false otherwise.

Remarks

To be supplied

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.IsCOMObjectImpl

Checks if this TypeDelegator imports a COM type.

[Visual Basic]
Overrides Protected Function IsCOMObjectImpl() As Boolean
[C#]
protected override bool IsCOMObjectImpl();
[C++]
protected: override bool IsCOMObjectImpl();
[JScript]
protected override function IsCOMObjectImpl() : Boolean;

Return Value

Returns true if this type imports a COM type, false otherwise.

Remarks

To be supplied

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.IsDefined

Checks to see if the TypeDelegator is defined on the given element (including inherited members).

[Visual Basic]
Overrides Public Function IsDefined( _
   ByVal attributeType As Type _
) As Boolean
[C#]
public override bool IsDefined(
   Type attributeType
);
[C++]
public: override bool IsDefined(
   Type* attributeType
);
[JScript]
public override function IsDefined(
   attributeType : Type
) : Boolean;

Parameters

attributeType
The type of the attribute to be returned

Return Value

Returns true if this attribute is defined on the given element (including inherited members)

Remarks

To be supplied

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.IsPointerImpl

To be supplied

[Visual Basic]
Overrides Protected Function IsPointerImpl() As Boolean
[C#]
protected override bool IsPointerImpl();
[C++]
protected: override bool IsPointerImpl();
[JScript]
protected override function IsPointerImpl() : Boolean;

Return Value

To be supplied

Remarks

To be supplied

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.IsPrimitiveImpl

To be supplied

[Visual Basic]
Overrides Protected Function IsPrimitiveImpl() As Boolean
[C#]
protected override bool IsPrimitiveImpl();
[C++]
protected: override bool IsPrimitiveImpl();
[JScript]
protected override function IsPrimitiveImpl() : Boolean;

Return Value

To be supplied

Remarks

To be supplied

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeDelegator.IsValueTypeImpl

To be supplied

[Visual Basic]
Overrides Protected Function IsValueTypeImpl() As Boolean
[C#]
protected override bool IsValueTypeImpl();
[C++]
protected: override bool IsValueTypeImpl();
[JScript]
protected override function IsValueTypeImpl() : Boolean;

Return Value

To be supplied

Remarks

To be supplied

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypeDelegator Fields

The fields of the TypeDelegator class are listed below. For a complete list of TypeDelegator class members, see the TypeDelegator Members topic.

Protected:

typeImpl To be supplied

See Also

TypeDelegator Class | System.Reflection Namespace


TypeDelegator.typeImpl

To be supplied

[Visual Basic]
Protected typeImpl As Type
[C#]
protected Type typeImpl;
[C++]
protected: Type* typeImpl;
[JScript]
protected var typeImpl : Type;

See Also

TypeDelegator Class | TypeDelegator Members | System.Reflection Namespace


TypeFilter Delegate

Filters the classes represented in an array of Type objects.

[Visual Basic]
Public Delegate Sub TypeFilter( _
   ByVal m As Type, _
   ByVal filterCriteria As Object _
) As Boolean
[C#]
public delegate bool TypeFilter(
   Type m,
   object filterCriteria
);
[C++]
public __gc __delegate bool TypeFilter(
   Type* m,
   Object* filterCriteria
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the TypeFilter delegate declaration.

m
The Type object to which the filter is applied.
filterCriteria
An arbitrary object used to filter the list.

Remarks

The TypeFilter delegate is used to filter a list of classes. Specifically, you use it to filter the classes represented in an array of Type objects. The Type.FindInterfaces() method uses this delegate to filter the list of interfaces that it returns. Every subclass of Delegate and MulticastDelegate has a constructor and a DynamicInvoke method. See the Managed C++ code example given in the description for Delegate.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

System.Reflection Namespace | FindInterfaces | Object | Delegate | MulticastDelegate


UnmanagedMarshal Class

Represents the class that describes the field marshal.

Object
UnmanagedMarshal

[Visual Basic]
NotInheritable Public Class UnmanagedMarshal
[C#]
public sealed class UnmanagedMarshal
[C++]
public __gc __sealed class UnmanagedMarshal
[JScript]
public class UnmanagedMarshal

Remarks

Marshaling is the process of packaging and unpackaging parameters so a remote procedure call can take place.

Requirements

Namespace: System.Reflection

Assembly: mscorlib.dll

See Also

UnmanagedMarshal Members | System.Reflection Namespace | Type | UnmanagedType | Guid


UnmanagedMarshal Members

Public:

Properties

BaseType | Returns a base type.
ElementCount | Returns a number element.
GetUnmanagedType | Returns a unmanaged type.
IIDGuid | Returns a GUID.

Methods

DefineByValArray | [To be supplied.]
DefineByValTStr | [To be supplied.]
DefineLPArray | [To be supplied.]
DefineSafeArray | [To be supplied.]
DefineUnmanagedMarshal | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UnmanagedMarshal Class | System.Reflection Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UnmanagedMarshal Properties

The properties of the UnmanagedMarshal class are listed below. For a complete list of UnmanagedMarshal class members, see the UnmanagedMarshal Members topic.

Public:

BaseType | Returns a base type.
ElementCount | Returns a number element.
GetUnmanagedType | Returns a unmanaged type.
IIDGuid | Returns a GUID.

See Also

UnmanagedMarshal Class | System.Reflection Namespace


UnmanagedMarshal.BaseType

Returns a base type.

[Visual Basic]
Public ReadOnly Property BaseType As UnmanagedType
[C#]
public UnmanagedType BaseType {get;}
[C++]
public: __property UnmanagedType get_BaseType();
[JScript]
public function get BaseType() : UnmanagedType;

Exceptions

Exception Type | Condition
ArgumentException | If the argument is not a nested marshal.

Remarks

There is a NestedUnmanagedType only if there is a LPArray or a SafeArray.

See Also

UnmanagedMarshal Class | UnmanagedMarshal Members | System.Reflection Namespace | Type


UnmanagedMarshal.ElementCount

Returns a number element.

[Visual Basic]
Public ReadOnly Property ElementCount As Integer
[C#]
public int ElementCount {get;}
[C++]
public: __property int get_ElementCount();
[JScript]
public function get ElementCount() : int;

Exceptions

Exception Type | Condition
ArgumentException | If the argument is not a unmanaged element count.

Remarks

There is a NumElement only if there is a NativeTypeFixedArray.

See Also

UnmanagedMarshal Class | UnmanagedMarshal Members | System.Reflection Namespace


UnmanagedMarshal.GetUnmanagedType

Returns a unmanaged type.

[Visual Basic]
Public ReadOnly Property GetUnmanagedType As UnmanagedType
[C#]
public UnmanagedType GetUnmanagedType {get;}
[C++]
public: __property UnmanagedType get_GetUnmanagedType();
[JScript]
public function get GetUnmanagedType() : UnmanagedType;

Remarks

The GetUnmanagedType property is an assessor function fo the native type.

See Also

UnmanagedMarshal Class | UnmanagedMarshal Members | System.Reflection Namespace


UnmanagedMarshal.IIDGuid

Returns a GUID.

[Visual Basic]
Public ReadOnly Property IIDGuid As Guid
[C#]
public Guid IIDGuid {get;}
[C++]
public: __property Guid get_IIDGuid();
[JScript]
public function get IIDGuid() : Guid;

Exceptions

Exception Type | Condition
ArgumentException | If the argument is not a customer marshaler.

See Also

UnmanagedMarshal Class | UnmanagedMarshal Members | System.Reflection Namespace | Int32 | Guid


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UnmanagedMarshal Methods

The methods of the UnmanagedMarshal class are listed below. For a complete list of UnmanagedMarshal class members, see the UnmanagedMarshal Members topic.

Public:

DefineByValArray | [To be supplied.]
DefineByValTStr | [To be supplied.]
DefineLPArray | [To be supplied.]
DefineSafeArray | [To be supplied.]
DefineUnmanagedMarshal | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UnmanagedMarshal Class | System.Reflection Namespace


UnmanagedMarshal.DefineByValArray

[To be supplied.]

[Visual Basic]
Public Shared Function DefineByValArray( _
   ByVal elemCount As Integer _
) As UnmanagedMarshal
[C#]
public static UnmanagedMarshal DefineByValArray(
   int elemCount
);
[C++]
public: static UnmanagedMarshal* DefineByValArray(
   int elemCount
);
[JScript]
public static function DefineByValArray(
   elemCount : int
) : UnmanagedMarshal;

Parameters

elemCount
To be supplied.

Exceptions

Exception Type | Condition
ArgumentException | If the argument is not a simple native type.

Remarks

The DefineByValArray method is not a simple native marshal.

Only unmanaged marshal constructs can be made using these static constructors.

Marshaling an array is a more complex process than marshaling an integer parameter . Array members are copied in a specific order so that the other side can reconstruct the array exactly.

See Also

UnmanagedMarshal Class | UnmanagedMarshal Members | System.Reflection Namespace


UnmanagedMarshal.DefineByValTStr

[To be supplied.]

[Visual Basic]
Public Shared Function DefineByValTStr( _
   ByVal elemCount As Integer _
) As UnmanagedMarshal
[C#]
public static UnmanagedMarshal DefineByValTStr(
   int elemCount
);
[C++]
public: static UnmanagedMarshal* DefineByValTStr(
   int elemCount
);
[JScript]
public static function DefineByValTStr(
   elemCount : int
) : UnmanagedMarshal;

Parameters

elemCount
To be supplied.

Return Value

Returns a new unmanaged marshal.

Exceptions

Exception Type | Condition
ArgumentException | If the argument is not a simple native type.

Remarks

The DefineByValStr method is not a simple native marshal.

Only unmanaged marshal constructs can be made using these static constructors.

Marshaling an array is a more complex process than marshaling an integer parameter . Array members are copied in a specific order so that the other side can reconstruct the array exactly.

See Also

UnmanagedMarshal Class | UnmanagedMarshal Members | System.Reflection Namespace | Int32 | Array | String


UnmanagedMarshal.DefineLPArray

[To be supplied.]

[Visual Basic]
Public Shared Function DefineLPArray( _
   ByVal elemType As UnmanagedType _
) As UnmanagedMarshal
[C#]
public static UnmanagedMarshal DefineLPArray(
   UnmanagedType elemType
);
[C++]
public: static UnmanagedMarshal* DefineLPArray(
   UnmanagedType elemType
);
[JScript]
public static function DefineLPArray(
   elemType : UnmanagedType
) : UnmanagedMarshal;

Parameters

elemType
To be supplied.

Exceptions

Exception Type | Condition
ArgumentException | If the argument is not a simple native type.

Remarks

The DefineLPArray method is not a simple native marshal.

Only unmanaged marshal constructs can be made using these static constructors.

Marshaling an array is a more complex process than marshaling an integer parameter . Array members are copied in a specific order so that the other side can reconstruct the array exactly.

See Also

UnmanagedMarshal Class | UnmanagedMarshal Members | System.Reflection Namespace


UnmanagedMarshal.DefineSafeArray

[To be supplied.]

[Visual Basic]
Public Shared Function DefineSafeArray( _
   ByVal elemType As UnmanagedType _
) As UnmanagedMarshal
[C#]
public static UnmanagedMarshal DefineSafeArray(
   UnmanagedType elemType
);
[C++]
public: static UnmanagedMarshal* DefineSafeArray(
   UnmanagedType elemType
);
[JScript]
public static function DefineSafeArray(
   elemType : UnmanagedType
) : UnmanagedMarshal;

Parameters

elemType
The base type or the UnmanagedType of each element of the array.

Exceptions

Exception Type | Condition
ArgumentException | If the argument is not a simple native type.

Remarks

The DefineSafeArray method is not a simple native marshal.

Only unmanaged marshal constructs can be made using these static constructors.

Marshaling an array is a more complex process than marshaling an integer parameter . Array members are copied in a specific order so that the other side can reconstruct the array exactly.

See Also

UnmanagedMarshal Class | UnmanagedMarshal Members | System.Reflection Namespace


UnmanagedMarshal.DefineUnmanagedMarshal

[To be supplied.]

[Visual Basic]
Public Shared Function DefineUnmanagedMarshal( _
   ByVal unmanagedType As UnmanagedType _
) As UnmanagedMarshal
[C#]
public static UnmanagedMarshal DefineUnmanagedMarshal(
   UnmanagedType unmanagedType
);
[C++]
public: static UnmanagedMarshal* DefineUnmanagedMarshal(
   UnmanagedType unmanagedType
);
[JScript]
public static function DefineUnmanagedMarshal(
   unmanagedType : UnmanagedType
) : UnmanagedMarshal;

Parameters

unmanagedType
To be supplied.

Return Value

Returns a new unmanaged marshal.

Exceptions

Exception Type | Condition
ArgumentException | If the argument is not a simple native type.

Remarks

The DefineUnmanagedMarshal method is not a simple native marshal.Only unmanaged marshal constructs can be made using these static constructors.

See Also

UnmanagedMarshal Class | UnmanagedMarshal Members | System.Reflection Namespace


System.Reflection.Emit

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Reflection.Emit Namespace

Classes

Class | Description
AssemblyBuilder | The AssemblyBuilder class is used to define and represent a dynamic assembly. The dynamic modules in the assembly are saved when the dynamic assembly is saved using the Save method. To generate an executable, the ModuleBuilder.SetEntryPoint method must be called to identify the method that is the entry point to the module. If no entry point is specified, a DLL will be generated.
ConstructorBuilder | The ConstructorBuilder class is used to define and represent a constructor on a dynamic class. ConstructorBuilder is used to fully describe a constructor in IL, including the name, attributes, signature, and constructor body. It is used in conjunction with the TypeBuilder class to create classes at run time.
CustomAttributeBuilder | CustomAttributeBuilder is a helper class to help build custom attributes.
EnumBuilder | The EnumBuilder class is used to describe and represent an enumeration type.
EventBuilder | This class is used to define events for a class. An EventBuilder is always associated with a TypeBuilder. The TypeBuilder.DefineEvent method will return a new EventBuilder to a client.
FieldBuilder | The FieldBuilder class is used to define and represent a field.
ILGenerator | The ILGenerator class generates IL instructions.
LocalBuilder | The LocalBuilder class represents a local variable within a method or constructor. A LocalBuilder object can be defined using the DeclareLocal method.
MethodBuilder | The MethodBuilder class is used to define and represent a method (or constructor) on a dynamic class. MethodBuilder is used to fully describe a method in IL, including the name, attributes, signature, and method body. It is used in conjunction with the TypeBuilder class to create classes at run time.
MethodRental | The MethodRental class provides a fast way to swap method body implementation given a method of a class.
ModuleBuilder | The ModuleBuilder class is used to define and represent a module.
OpCodes | The IL instruction opcodes supported by the runtime. The IL Instruction Specification describes each Opcode.
ParameterBuilder | The ParameterBuilder class is used to create or associate parameter information.
PropertyBuilder | The PropertyBuilder class defines the properties for a type.
SignatureHelper | The SignatureHelper class provides methods for building signatures.
TypeBuilder | The TypeBuilder class is used to define and instantiate classes at run time. TypeBuilder is the root class used to control the creation of dynamic classes in the runtime. TypeBuilder provides a set of routines that are used to define classes, add methods and fields, and then create the class inside the runtime. A new TypeBuilder can be created from a dynamic Module.

Structures

Structure | Description
EventToken | The EventToken class is an opaque representation of the Token returned by the MetaData to represent an event.
FieldToken | The FieldToken class is an object representation of a token that represents a field.
Label | The Label class is used with the ILGenerator class to represent a label in the instruction stream.
LocalToken | This class is obsolete and is no longer being used. It will be removed in a future release.
MethodToken | The MethodToken class is an object representation of a token that represents a method.
OpCode | Describes an IL instruction.
ParameterToken | The ParameterToken class is an opaque representation of the Token returned by the MetaData to represent a parameter.
PropertyToken | The PropertyToken class is an opaque representation of the Token returned by the MetaData to represent a property.
SignatureToken | The SignatureToken class is an opaque representation of the Token returned by the MetaData to represent a signature.
StringToken | The StringToken class is an object representation of a token that represents a string.
TypeToken | The TypeToken class is an opaque representation of the Token returned by the MetaData to represent a type.

Enumerations

Enumeration | Description
AssemblyBuilderAccess | The AssemblyBuilderAccess class is an enumeration that defines the access modes for a dynamic assembly.
FlowControl | FlowControl describes how an instruction alters the flow of control.
OpCodeType | Describes the types of the IL instructions.
OperandType | Describes the operand type of IL instruction.
PackingSize | An enumeration for specifying the packing size of a type.
PEFileKinds | Specifies the type of the PE file.
StackBehaviour | Describes how values are pushed onto a stack or popped off a stack.


AssemblyBuilder Class

The AssemblyBuilder class is used to define and represent a dynamic assembly.

The dynamic modules in the assembly are saved when the dynamic assembly is saved using the Save method. To generate an executable, the ModuleBuilder.SetEntryPoint method must be called to identify the method that is the entry point to the module. If no entry point is specified, a DLL will be generated.

Object
Assembly
AssemblyBuilder

[Visual Basic]
NotInheritable Public Class AssemblyBuilder
   Inherits Assembly
[C#]
public sealed class AssemblyBuilder : Assembly
[C++]
public __gc __sealed class AssemblyBuilder : public Assembly
[JScript]
public class AssemblyBuilder extends Assembly

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

AssemblyBuilder Members | System.Reflection.Emit Namespace


AssemblyBuilder Members

Public:

Properties

CodeBase (inherited from Assembly) | This read-only property returns the location of the assembly as specified originally, for example, in an AssemblyName object.
CopiedCodeBase (inherited from Assembly) | This read-only property returns the location from which the assembly was loaded. This will be different from the value of CodeBase if the assembly is a shadow copy.
EntryPoint (inherited from Assembly) | Read-only. Gets the entry point of this assembly.
Evidence (inherited from Assembly) | This read-only property returns the evidence for this assembly.
FullName (inherited from Assembly) | This read-only property returns the display name of the assembly.
IsShared (inherited from Assembly) | This read-only property checks if this assembly has code that is shared across multiple application domains.
ShareCount (inherited from Assembly) | This read-only property returns the number of application domains that are currently sharing the code for this assembly.

Methods

CreateInstance (inherited from Assembly) | Overloaded. [To be supplied.]
DefineDynamicModule (inherited from Assembly) | Overloaded. Overloaded. Defines a dynamic module in this assembly.
DefineResource | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCustomAttributes (inherited from Assembly) | Overloaded. Overloaded. Gets the custom attributes for this assembly.
GetDynamicModule | Returns the dynamic module with the specified name.
GetExportedTypes (inherited from Assembly) | Gets the public types defined in this assembly.
GetFile (inherited from Assembly) | Gets a FileStream for the specified file in the file table of the manifest of this assembly.
GetFiles (inherited from Assembly) | Gets a FileStream for each file in the file table of the manifest of this assembly.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLoadedModules (inherited from Assembly) | Gets all the loaded modules that are part of this assembly.
GetManifestResourceNames (inherited from Assembly) | Returns the names of all the resources in this assembly.
GetManifestResourceStream (inherited from Assembly) | Overloaded. Overloaded. Loads the specified resource from this assembly.
GetModule (inherited from Assembly) | Gets the specified module in this assembly.
GetModules (inherited from Assembly) | Gets all the modules that are part of this assembly.
GetName (inherited from Assembly) | Overloaded. Overloaded. Gets the AssemblyName of this assembly.
GetObjectData (inherited from Assembly) | Gets serialization information with all of the data needed to reinstantiate this assembly.
GetReferencedAssemblies (inherited from Assembly) | Gets the AssemblyName objects for all the assemblies referenced by this assembly.
GetSatelliteAssembly (inherited from Assembly) | Gets the satellite assembly for the specified culture.
GetType (inherited from Assembly) | Overloaded. Overloaded. Gets the Type object that represents the specified type.
GetTypes (inherited from Assembly) | Gets the types defined in this assembly.
IsDefined (inherited from Assembly) | Checks if a custom attribute identified by the specified Type is defined.
Save | Saves this dynamic assembly to disk. Save also saves all dynamic modules defined in this dynamic assembly. The assembly file name can be the same as one of the module's name. If so, the assembly information is stored within that module. The assembly file name can be different from the names of all of the modules contained within the assembly. If so, the assembly is stored standalone.
SetCustomAttribute | Overloaded. [To be supplied.]
SetEntryPoint | Sets the entry point for this dynamic assembly if the AssemblyBuilder is building an executable.
SetObjectData (inherited from Assembly) | Reflate this assembly using all of the information in the specified SerializationInfo object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Events

ResourceResolve (inherited from Assembly) | [To be supplied.]
TypeResolve (inherited from Assembly) | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Event Hookup:

Methods

AddOnResourceResolve (inherited from Assembly) | Subscribes to the "resource resolve" event. The "resource resolve" event is raised when a resource is loaded.
AddOnTypeResolve (inherited from Assembly) | Subscribes to the "type resolve" event. The "type resolve" event is raised when a type is loaded.
RemoveOnResourceResolve (inherited from Assembly) | Unsubscribes to the "resource resolve" event. The "resource resolve" event is raised when a resource is loaded.
RemoveOnTypeResolve (inherited from Assembly) | Unsubscribes to the "type resolve" event. The "type resolve" event is raised when a type is loaded.

See Also

AssemblyBuilder Class | System.Reflection.Emit Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

AssemblyBuilder Methods

The methods of the AssemblyBuilder class are listed below. For a complete list of AssemblyBuilder class members, see the AssemblyBuilder Members topic.

Public:

CreateInstance (inherited from Assembly) | Overloaded. [To be supplied.]
DefineDynamicModule (inherited from Assembly) | Overloaded. Overloaded. Defines a dynamic module in this assembly.
DefineResource | Overloaded. [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCustomAttributes (inherited from Assembly) | Overloaded. Overloaded. Gets the custom attributes for this assembly.
GetDynamicModule | Returns the dynamic module with the specified name.
GetExportedTypes (inherited from Assembly) | Gets the public types defined in this assembly.
GetFile (inherited from Assembly) | Gets a FileStream for the specified file in the file table of the manifest of this assembly.
GetFiles (inherited from Assembly) | Gets a FileStream for each file in the file table of the manifest of this assembly.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLoadedModules (inherited from Assembly) | Gets all the loaded modules that are part of this assembly.
GetManifestResourceNames (inherited from Assembly) | Returns the names of all the resources in this assembly.
GetManifestResourceStream (inherited from Assembly) | Overloaded. Overloaded. Loads the specified resource from this assembly.
GetModule (inherited from Assembly) | Gets the specified module in this assembly.
GetModules (inherited from Assembly) | Gets all the modules that are part of this assembly.
GetName (inherited from Assembly) | Overloaded. Overloaded. Gets the AssemblyName of this assembly.
GetObjectData (inherited from Assembly) | Gets serialization information with all of the data needed to reinstantiate this assembly.
GetReferencedAssemblies (inherited from Assembly) | Gets the AssemblyName objects for all the assemblies referenced by this assembly.
GetSatelliteAssembly (inherited from Assembly) | Gets the satellite assembly for the specified culture.
GetType (inherited from Assembly) | Overloaded. Overloaded. Gets the Type object that represents the specified type.
GetTypes (inherited from Assembly) | Gets the types defined in this assembly.
IsDefined (inherited from Assembly) | Checks if a custom attribute identified by the specified Type is defined.
Save | Saves this dynamic assembly to disk. Save also saves all dynamic modules defined in this dynamic assembly. The assembly file name can be the same as one of the module's name. If so, the assembly information is stored within that module. The assembly file name can be different from the names of all of the modules contained within the assembly. If so, the assembly is stored standalone.
SetCustomAttribute | Overloaded. [To be supplied.]
SetEntryPoint | Sets the entry point for this dynamic assembly if the AssemblyBuilder is building an executable.
SetObjectData (inherited from Assembly) | Reflate this assembly using all of the information in the specified SerializationInfo object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Event Hookup:

AddOnResourceResolve (inherited from Assembly) | Subscribes to the "resource resolve" event. The "resource resolve" event is raised when a resource is loaded.
AddOnTypeResolve (inherited from Assembly) | Subscribes to the "type resolve" event. The "type resolve" event is raised when a type is loaded.
RemoveOnResourceResolve (inherited from Assembly) | Unsubscribes to the "resource resolve" event. The "resource resolve" event is raised when a resource is loaded.
RemoveOnTypeResolve (inherited from Assembly) | Unsubscribes to the "type resolve" event. The "type resolve" event is raised when a type is loaded.

See Also

AssemblyBuilder Class | System.Reflection.Emit Namespace


AssemblyBuilder.DefineDynamicModule

Defines a persistable dynamic module in this dynamic assembly. To define a persistable dynamic module, this assembly should have been created with the AssemblyBuilderAccess.Save or the AssemblyBuilderAccess.RunAndSave attribute.

Overload List

Defines a dynamic module with the given name that will be saved to the specified file. No symbol information is emitted.

[Visual Basic] Overloads Public Function DefineDynamicModule(String, String) As ModuleBuilder
[C#] public ModuleBuilder DefineDynamicModule(String, String);
[C++] public: ModuleBuilder* DefineDynamicModule(String*, String*);
[JScript] public function DefineDynamicModule(String, String) : ModuleBuilder;

Defines a persistable dynamic module in this dynamic assembly that optionally includes symbolic information using the default symbol writer. To define a persistable dynamic module, this assembly should have been created with the AssemblyBuilderAccess.Save or the AssemblyBuilderAccess.RunAndSave attribute.

[Visual Basic] Overloads Public Function DefineDynamicModule(String, String, Boolean) As ModuleBuilder
[C#] public ModuleBuilder DefineDynamicModule(String, String, bool);
[C++] public: ModuleBuilder* DefineDynamicModule(String*, String*, bool);
[JScript] public function DefineDynamicModule(String, String, Boolean) : ModuleBuilder;

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit=true

See Also

AssemblyBuilder Class | AssemblyBuilder Members | System.Reflection.Emit Namespace


AssemblyBuilder.DefineDynamicModule (String, String)

Defines a dynamic module with the given name that will be saved to the specified file. No symbol information is emitted.

[Visual Basic]
Overloads Public Function DefineDynamicModule( _
   ByVal name As String, _
   ByVal fileName As String _
) As ModuleBuilder
[C#]
public ModuleBuilder DefineDynamicModule(
   string name,
   string fileName
);
[C++]
public: ModuleBuilder* DefineDynamicModule(
   String* name,
   String* fileName
);
[JScript]
public function DefineDynamicModule(
   name : String,
   fileName : String
) : ModuleBuilder;

Parameters

name
The name of the dynamic module.
fileName
The name of the file to which the dynamic module should be saved.

Return Value

A ModuleBuilder object representing the defined dynamic module.

Exceptions

Exception Type | Condition
ArgumentNullException | if name is null
InvalidOperationException | if this assembly has been previously saved
NotSupportedException | if called on a dynamic assembly with AssemblyBuilderAccess.Run attribute

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit=true

See Also

AssemblyBuilder Class | AssemblyBuilder Members | System.Reflection.Emit Namespace | AssemblyBuilder.DefineDynamicModule Overload List


AssemblyBuilder.DefineDynamicModule (String, String, Boolean)

Defines a persistable dynamic module in this dynamic assembly that optionally includes symbolic information using the default symbol writer. To define a persistable dynamic module, this assembly should have been created with the AssemblyBuilderAccess.Save or the AssemblyBuilderAccess.RunAndSave attribute.

[Visual Basic]
Overloads Public Function DefineDynamicModule( _
   ByVal name As String, _
   ByVal fileName As String, _
   ByVal emitSymbolInfo As Boolean _
) As ModuleBuilder
[C#]
public ModuleBuilder DefineDynamicModule(
   string name,
   string fileName,
   bool emitSymbolInfo
);
[C++]
public: ModuleBuilder* DefineDynamicModule(
   String* name,
   String* fileName,
   bool emitSymbolInfo
);
[JScript]
public function DefineDynamicModule(
   name : String,
   fileName : String,
   emitSymbolInfo : Boolean
) : ModuleBuilder;

Parameters

name
The name of the dynamic module.
fileName
[To be supplied.]
emitSymbolInfo
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentNullException | if name is null
InvalidOperationException | if this assembly has been previously saved
NotSupportedException | if called on a dynamic assembly with AssemblyBuilderAccess.Run attribute
ExecutionEngineException | if the assembly for default symbol writer cannot be loaded or if the type that implements the default symbol writer interface cannot be found

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit=true

See Also

AssemblyBuilder Class | AssemblyBuilder Members | System.Reflection.Emit Namespace | AssemblyBuilder.DefineDynamicModule Overload List


AssemblyBuilder.DefineResource

[To be supplied.]

Overload List

Defines a standalone managed resource for this assembly. Attributes can be specified for the managed resource.

[Visual Basic] Overloads Public Function DefineResource(String, String, String, ResourceAttributes) As ResourceWriter
[C#] public ResourceWriter DefineResource(String, String, String, ResourceAttributes);
[C++] public: ResourceWriter* DefineResource(String*, String*, String*, ResourceAttributes);
[JScript] public function DefineResource(String, String, String, ResourceAttributes) : ResourceWriter;

Defines a standalone managed resource for this assembly.

[Visual Basic] Overloads Public Function DefineResource(String, String, String) As ResourceWriter
[C#] public ResourceWriter DefineResource(String, String, String);
[C++] public: ResourceWriter* DefineResource(String*, String*, String*);
[JScript] public function DefineResource(String, String, String) : ResourceWriter;

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit=true

See Also

AssemblyBuilder Class | AssemblyBuilder Members | System.Reflection.Emit Namespace


AssemblyBuilder.DefineResource (String, String, String, ResourceAttributes)

Defines a standalone managed resource for this assembly. Attributes can be specified for the managed resource.

[Visual Basic]
Overloads Public Function DefineResource( _
   ByVal name As String, _
   ByVal description As String, _
   ByVal fileName As String, _
   ByVal attribute As ResourceAttributes _
) As ResourceWriter
[C#]
public ResourceWriter DefineResource(
   string name,
   string description,
   string fileName,
   ResourceAttributes attribute
);
[C++]
public: ResourceWriter* DefineResource(
   String* name,
   String* description,
   String* fileName,
   ResourceAttributes attribute
);
[JScript]
public function DefineResource(
   name : String,
   description : String,
   fileName : String,
   attribute : ResourceAttributes
) : ResourceWriter;

Parameters

name
The logical name of the resource.
description
A textual description of the resource.
fileName
The physical file name (.resources file) to which the logical name is mapped.
attribute
The resource attributes.

Return Value

A ResourceWriter object for the specified resource.

Exceptions

Exception Type | Condition
ArgumentException | If name has been previously defined

Remarks

Fine-grain resources can be added with the returned ResourceWriter by calling AddResource.

Filename should not be the same as that of any other persistable module, standalone managed resource, or the standalone manifest file.

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit=true

See Also

AssemblyBuilder Class | AssemblyBuilder Members | System.Reflection.Emit Namespace | AssemblyBuilder.DefineResource Overload List


AssemblyBuilder.DefineResource (String, String, String)

Defines a standalone managed resource for this assembly.

[Visual Basic]
Overloads Public Function DefineResource( _
   ByVal name As String, _
   ByVal description As String, _
   ByVal fileName As String _
) As ResourceWriter
[C#]
public ResourceWriter DefineResource(
   string name,
   string description,
   string fileName
);
[C++]
public: ResourceWriter* DefineResource(
   String* name,
   String* description,
   String* fileName
);
[JScript]
public function DefineResource(
   name : String,
   description : String,
   fileName : String
) : ResourceWriter;

Parameters

name
The logical name of the resource.
description
A textual description of the resource.
fileName
The physical file name (.resources file) to which the logical name is mapped.

Return Value

A ResourceWriter object for the specified resource.

Exceptions

Exception Type | Condition
ArgumentException | If name has been previously defined

Remarks

Fine-grain resources can be added with the returned ResourceWriter by calling AddResource.

Filename should not be the same as that of any other persistable module, standalone managed resource, or the standalone manifest file.

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit=true

See Also

AssemblyBuilder Class | AssemblyBuilder Members | System.Reflection.Emit Namespace | AssemblyBuilder.DefineResource Overload List


AssemblyBuilder.GetDynamicModule

Returns the dynamic module with the specified name.

[Visual Basic]
Public Function GetDynamicModule( _
   ByVal name As String _
) As ModuleBuilder
[C#]
public ModuleBuilder GetDynamicModule(
   string name
);
[C++]
public: ModuleBuilder* GetDynamicModule(
   String* name
);
[JScript]
public function GetDynamicModule(
   name : String
) : ModuleBuilder;

Parameters

name
The name of the requested dynamic module.

Return Value

A ModuleBuilder object representing the requested dynamic module.

Exceptions

Exception Type | Condition
ArgumentNullException | if name is null

Remarks

None

See Also

AssemblyBuilder Class | AssemblyBuilder Members | System.Reflection.Emit Namespace


AssemblyBuilder.Save

Saves this dynamic assembly to disk. Save also saves all dynamic modules defined in this dynamic assembly. The assembly file name can be the same as one of the module's name. If so, the assembly information is stored within that module. The assembly file name can be different from the names of all of the modules contained within the assembly. If so, the assembly is stored standalone.

[Visual Basic]
Public Sub Save( _
   ByVal assemblyFileName As String _
)
[C#]
public void Save(
   string assemblyFileName
);
[C++]
public: void Save(
   String* assemblyFileName
);
[JScript]
public function Save(
   assemblyFileName : String
);

Parameters

assemblyFileName
The file name of the assembly.

Return Value

None

Exceptions

Exception Type | Condition
InvalidOperationException | if this assembly has been saved before or if this assembly has access AssemblyBuilderAccess.Run

Remarks

This method also saves all dynamic modules defined in this dynamic assembly. The assembly file name can be the same as one of the module's name. If so, the assemby information is stored within that module. assemblyFileName can be different from the names of all of the modules contained within the assembly. If so, the assembly is stored standalone.

See Also

AssemblyBuilder Class | AssemblyBuilder Members | System.Reflection.Emit Namespace


AssemblyBuilder.SetCustomAttribute

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub SetCustomAttribute(CustomAttributeBuilder)
[C#] public void SetCustomAttribute(CustomAttributeBuilder);
[C++] public: void SetCustomAttribute(CustomAttributeBuilder*);
[JScript] public function SetCustomAttribute(CustomAttributeBuilder);

[To be supplied.]

[Visual Basic] Overloads Public Sub SetCustomAttribute(ConstructorInfo, Byte())
[C#] public void SetCustomAttribute(ConstructorInfo, byte[]);
[C++] public: void SetCustomAttribute(ConstructorInfo*, unsigned char[]);
[JScript] public function SetCustomAttribute(ConstructorInfo, Byte[]);

See Also

AssemblyBuilder Class | AssemblyBuilder Members | System.Reflection.Emit Namespace


AssemblyBuilder.SetCustomAttribute (CustomAttributeBuilder)

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetCustomAttribute( _
   ByVal customBuilder As CustomAttributeBuilder _
)
[C#]
public void SetCustomAttribute(
   CustomAttributeBuilder customBuilder
);
[C++]
public: void SetCustomAttribute(
   CustomAttributeBuilder* customBuilder
);
[JScript]
public function SetCustomAttribute(
   customBuilder : CustomAttributeBuilder
);

Parameters

customBuilder
[To be supplied.]

See Also

AssemblyBuilder Class | AssemblyBuilder Members | System.Reflection.Emit Namespace | AssemblyBuilder.SetCustomAttribute Overload List


AssemblyBuilder.SetCustomAttribute (ConstructorInfo, Byte[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub SetCustomAttribute( _
   ByVal con As ConstructorInfo, _
   ByVal binaryAttribute() As Byte _
)
[C#]
public void SetCustomAttribute(
   ConstructorInfo con,
   byte[] binaryAttribute
);
[C++]
public: void SetCustomAttribute(
   ConstructorInfo* con,
   unsigned char* binaryAttribute[]
);
[JScript]
public function SetCustomAttribute(
   con : ConstructorInfo,
   binaryAttribute : Byte[]
);

Parameters

con
[To be supplied.]
binaryAttribute
[To be supplied.]

See Also

AssemblyBuilder Class | AssemblyBuilder Members | System.Reflection.Emit Namespace | AssemblyBuilder.SetCustomAttribute Overload List


AssemblyBuilder.SetEntryPoint

Sets the entry point for this dynamic assembly if the AssemblyBuilder is building an executable.

[Visual Basic]
Public Sub SetEntryPoint( _
   ByVal entryMethod As MethodInfo _
)
[C#]
public void SetEntryPoint(
   MethodInfo entryMethod
);
[C++]
public: void SetEntryPoint(
   MethodInfo* entryMethod
);
[JScript]
public function SetEntryPoint(
   entryMethod : MethodInfo
);

Parameters

entryMethod
A reference to the method that represents the entry point for this dynamic assembly.

Return Value

None

Exceptions

Exception Type | Condition
ArgumentNullException | if entryMethod is null
InvalidOperationException | if entryMethod is not contained within this assembly

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit=true

See Also

AssemblyBuilder Class | AssemblyBuilder Members | System.Reflection.Emit Namespace


AssemblyBuilderAccess Enumeration

The AssemblyBuilderAccess class is an enumeration that defines the access modes for a dynamic assembly.

[Visual Basic]
Public Enum AssemblyBuilderAccess
[C#]
public enum AssemblyBuilderAccess
[C++]
public enum AssemblyBuilderAccess

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Run | Represents that the dynamic assembly can be executed but not saved.
RunAndSave | Represents that the dynamic assembly can be executed and saved.
Save | Represents that the dynamic assembly can be saved but not executed.

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

System.Reflection.Emit Namespace


ConstructorBuilder Class

The ConstructorBuilder class is used to define and represent a constructor on a dynamic class. ConstructorBuilder is used to fully describe a constructor in IL, including the name, attributes, signature, and constructor body. It is used in conjunction with the TypeBuilder class to create classes at run time.

Object
MemberInfo
MethodBase
ConstructorInfo
ConstructorBuilder

[Visual Basic]
NotInheritable Public Class ConstructorBuilder
   Inherits ConstructorInfo
[C#]
public sealed class ConstructorBuilder : ConstructorInfo
[C++]
public __gc __sealed class ConstructorBuilder : public
   ConstructorInfo
[JScript]
public class ConstructorBuilder extends ConstructorInfo

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

ConstructorBuilder Members | System.Reflection.Emit Namespace


ConstructorBuilder Members

Public:

Properties

Attributes | Retrieves the attributes for this constructor.
CallingConvention (inherited from MethodBase) | Retrieves the calling conventions for this method.
DeclaringType | Retrieves a reference to the Type object for the type that declares this member. A member of a class (or interface) is either declared or inherited from a base class (or interface).
IsAbstract (inherited from MethodBase) | Retrieves whether this is an abstract method.
IsAssembly (inherited from MethodBase) | Retrieves whether this is an abstract method.
IsConstructor (inherited from MethodBase) | If set, the method is a constructor.
IsFamily (inherited from MethodBase) | If set, this method can be called by all subclasses, wherever they are, but not by unrelated classes.
IsFamilyAndAssembly (inherited from MethodBase) | If set, this method can be called by subclasses if they are in the same assembly.
IsFamilyOrAssembly (inherited from MethodBase) | If set, this method can be called by subclasses, wherever they are, and by all classes in the same assembly.
IsFinal (inherited from MethodBase) | If set, this method cannot be overridden by a subclass.
IsHideBySig (inherited from MethodBase) | [To be supplied.]
IsPrivate (inherited from MethodBase) | If set, this method can be called only by other members of the class itself.
IsPublic (inherited from MethodBase) | Retrieves whether this is a public method.
IsSpecialName (inherited from MethodBase) | If set, this method has a special name.
IsStatic (inherited from MethodBase) | If set, the method is static.
IsVirtual (inherited from MethodBase) | Retrieves a value indicating whether the method is virtual.
MemberType (inherited from ConstructorInfo) | Specifies the type of this member this instance reflects.
MethodHandle | Retrieves the internal handle for the method. Use this handle to access the underlying metadata handle.
Name | Retrieves the name of this constructor.
ReflectedType | This read-only property holds a reference to the Type object from which this object was obtained. A ConstructorBuilder object represents a constructor on a particular class. In order to obtain a ConstructorInfo object, the Type object that represents the class that supports the constructor is queried. This property holds a reference to that Type object.
ReturnType | Retrieves the Type of this constructor's return value.
Signature | Retrieves the signature of the field.

Methods

AddDeclarativeSecurity | Adds declarative security to this constructor. AddDeclarativeSecurity may be called several times with each call specifying a security action (e.g., Demand, Assert, Deny) and a set of permissions that the action applies to.
DefineParameter | Defines a parameter of this constructor.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCustomAttributes | Overloaded. Overloaded. Returns the custom attributes defined for this constructor.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetILGenerator | Gets an ILGenerator for this constructor.
GetMethodImplementationFlags | Returns the method implementation flags for this constructor.
GetModule | Returns a reference to the module that contains this constructor.
GetParameters | Returns the parameters of this constructor.
GetToken | Returns the MethodToken that represents the token for this constructor.
GetType (inherited from Object) | Gets the Type of the Object.
Invoke | Overloaded. [To be supplied.]
IsDefined | Checks if the specified custom attribute type is defined.
SetCustomAttribute | Overloaded. Sets a custom attribute.
SetImplementationFlags | Sets the method implementation flags for this constructor.
SetSymCustomAttribute | Sets this constructor's custom attribute associated with symbolic information.
ToString | Returns this ConstructorBuilder instance as a String.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConstructorBuilder Class | System.Reflection.Emit Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ConstructorBuilder Properties

The properties of the ConstructorBuilder class are listed below. For a complete list of ConstructorBuilder class members, see the ConstructorBuilder Members topic.

Public:

Attributes | Retrieves the attributes for this constructor.
CallingConvention (inherited from MethodBase) | Retrieves the calling conventions for this method.
DeclaringType | Retrieves a reference to the Type object for the type that declares this member. A member of a class (or interface) is either declared or inherited from a base class (or interface).
IsAbstract (inherited from MethodBase) | Retrieves whether this is an abstract method.
IsAssembly (inherited from MethodBase) | Retrieves whether this is an abstract method.
IsConstructor (inherited from MethodBase) | If set, the method is a constructor.
IsFamily (inherited from MethodBase) | If set, this method can be called by all subclasses, wherever they are, but not by unrelated classes.
IsFamilyAndAssembly (inherited from MethodBase) | If set, this method can be called by subclasses if they are in the same assembly.
IsFamilyOrAssembly (inherited from MethodBase) | If set, this method can be called by subclasses, wherever they are, and by all classes in the same assembly.
IsFinal (inherited from MethodBase) | If set, this method cannot be overridden by a subclass.
IsHideBySig (inherited from MethodBase) | [To be supplied.]
IsPrivate (inherited from MethodBase) | If set, this method can be called only by other members of the class itself.
IsPublic (inherited from MethodBase) | Retrieves whether this is a public method.
IsSpecialName (inherited from MethodBase) | If set, this method has a special name.
IsStatic (inherited from MethodBase) | If set, the method is static.
IsVirtual (inherited from MethodBase) | Retrieves a value indicating whether the method is virtual.
MemberType (inherited from ConstructorInfo) | Specifies the type of this member this instance reflects.
MethodHandle | Retrieves the internal handle for the method. Use this handle to access the underlying metadata handle.
Name | Retrieves the name of this constructor.
ReflectedType | This read-only property holds a reference to the Type object from which this object was obtained. A ConstructorBuilder object represents a constructor on a particular class. In order to obtain a ConstructorInfo object, the Type object that represents the class that supports the constructor is queried. This property holds a reference to that Type object.
ReturnType | Retrieves the Type of this constructor's return value.
Signature | Retrieves the signature of the field.

See Also

ConstructorBuilder Class | System.Reflection.Emit Namespace


ConstructorBuilder.Attributes

Retrieves the attributes for this constructor.

[Visual Basic]
Overridable Public ReadOnly Property Attributes As MethodAttributes
[C#]
public MethodAttributes Attributes {override get;}
[C++]
public: __property virtual MethodAttributes get_Attributes();
[JScript]
public function get Attributes() : MethodAttributes;

Property Value

Returns the attributes for this constructor.

See Also

ConstructorBuilder Class | ConstructorBuilder Members | System.Reflection.Emit Namespace


ConstructorBuilder.DeclaringType

Retrieves a reference to the Type object for the type that declares this member. A member of a class (or interface) is either declared or inherited from a base class (or interface).

[Visual Basic]
Overridable Public ReadOnly Property DeclaringType As Type
[C#]
public Type DeclaringType {override get;}
[C++]
public: __property virtual Type* get_DeclaringType();
[JScript]
public function get DeclaringType() : Type;

Property Value

Returns the Type object for the type that declares this member.

See Also

ConstructorBuilder Class | ConstructorBuilder Members | System.Reflection.Emit Namespace


ConstructorBuilder.MethodHandle

Retrieves the internal handle for the method. Use this handle to access the underlying metadata handle.

[Visual Basic]
Overridable Public ReadOnly Property MethodHandle As _
   RuntimeMethodHandle
[C#]
public RuntimeMethodHandle MethodHandle {override get;}
[C++]
public: __property virtual RuntimeMethodHandle get_MethodHandle();
[JScript]
public function get MethodHandle() : RuntimeMethodHandle;

Property Value

Returns the internal handle for the method. Use this handle to access the underlying metadata handle.

Exceptions

Exception Type | Condition
NotSupportedException | This property is not supported on this class.

See Also

ConstructorBuilder Class | ConstructorBuilder Members | System.Reflection.Emit Namespace


ConstructorBuilder.Name

Retrieves the name of this constructor.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {override get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

Property Value

Returns the name of this constructor.

See Also

ConstructorBuilder Class | ConstructorBuilder Members | System.Reflection.Emit Namespace


ConstructorBuilder.ReflectedType

This read-only property holds a reference to the Type object from which this object was obtained.

A ConstructorBuilder object represents a constructor on a particular class. In order to obtain a ConstructorInfo object, the Type object that represents the class that supports the constructor is queried. This property holds a reference to that Type object.

[Visual Basic]
Overridable Public ReadOnly Property ReflectedType As Type
[C#]
public Type ReflectedType {override get;}
[C++]
public: __property virtual Type* get_ReflectedType();
[JScript]
public function get ReflectedType() : Type;

Property Value

Returns the Type object from which this object was obtained.

See Also

ConstructorBuilder Class | ConstructorBuilder Members | System.Reflection.Emit Namespace


ConstructorBuilder.ReturnType

Retrieves the Type of this constructor's return value.

[Visual Basic]
Public ReadOnly Property ReturnType As Type
[C#]
public Type ReturnType {get;}
[C++]
public: __property Type* get_ReturnType();
[JScript]
public function get ReturnType() : Type;

Property Value

Returns the Type of this constructor's return value.

See Also

ConstructorBuilder Class | ConstructorBuilder Members | System.Reflection.Emit Namespace


ConstructorBuilder.Signature

Retrieves the signature of the field.

[Visual Basic]
Public ReadOnly Property Signature As String
[C#]
public string Signature {get;}
[C++]
public: __property String* get_Signature();
[JScript]
public function get Signature() : String;

Property Value

Returns the signature of the field.

See Also

ConstructorBuilder Class | ConstructorBuilder Members | System.Reflection.Emit Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ConstructorBuilder Methods

The methods of the ConstructorBuilder class are listed below. For a complete list of ConstructorBuilder class members, see the ConstructorBuilder Members topic.

Public:

AddDeclarativeSecurity | Adds declarative security to this constructor. AddDeclarativeSecurity may be called several times with each call specifying a security action (e.g., Demand, Assert, Deny) and a set of permissions that the action applies to.
DefineParameter | Defines a parameter of this constructor.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCustomAttributes | Overloaded. Overloaded. Returns the custom attributes defined for this constructor.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetILGenerator | Gets an ILGenerator for this constructor.
GetMethodImplementationFlags | Returns the method implementation flags for this constructor.
GetModule | Returns a reference to the module that contains this constructor.
GetParameters | Returns the parameters of this constructor.
GetToken | Returns the MethodToken that represents the token for this constructor.
GetType (inherited from Object) | Gets the Type of the Object.
Invoke | Overloaded. [To be supplied.]
IsDefined | Checks if the specified custom attribute type is defined.
SetCustomAttribute | Overloaded. Sets a custom attribute.
SetImplementationFlags | Sets the method implementation flags for this constructor.
SetSymCustomAttribute | Sets this constructor's custom attribute associated with symbolic information.
ToString | Returns this ConstructorBuilder instance as a String.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConstructorBuilder Class | System.Reflection.Emit Namespace


ConstructorBuilder.AddDeclarativeSecurity

Adds declarative security to this constructor. AddDeclarativeSecurity may be called several times with each call specifying a security action (e.g., Demand, Assert, Deny) and a set of permissions that the action applies to.

[Visual Basic]
Public Sub AddDeclarativeSecurity( _
   ByVal action As SecurityAction, _
   ByVal pset As PermissionSet _
)
[C#]
public void AddDeclarativeSecurity(
   SecurityAction action,
   PermissionSet pset
);
[C++]
public: void AddDeclarativeSecurity(
   SecurityAction action,
   PermissionSet* pset
);
[JScript]
public function AddDeclarativeSecurity(
   action : SecurityAction,
   pset : PermissionSet
);

Parameters

action
The security action to be taken such as Demand, Assert, etc.
pset
The set of permissions the action applies to.

Exceptions

Exception Type | Condition
InvalidOperationException | If the containing type has been created using CreateType.

See Also

ConstructorBuilder Class | ConstructorBuilder Members | System.Reflection.Emit Namespace


ConstructorBuilder.DefineParameter

Defines a parameter of this constructor.

[Visual Basic]
Public Function DefineParameter( _
   ByVal iSequence As Integer, _
   ByVal attributes As ParameterAttributes, _
   ByVal strParamName As String _
) As ParameterBuilder
[C#]
public ParameterBuilder DefineParameter(
   int iSequence,
   ParameterAttributes attributes,
   string strParamName
);
[C++]
public: ParameterBuilder* DefineParameter(
   int iSequence,
   ParameterAttributes attributes,
   String* strParamName
);
[JScript]
public function DefineParameter(
   iSequence : int,
   attributes : ParameterAttributes,
   strParamName : String
) : ParameterBuilder;

Parameters

iSequence
The zero-indexed position of the parameter in the parameter list.
attributes
The attributes of the parameter.
strParamName
The name of the parameter. The name can be the null string.

Return Value

Returns a ParameterBuilder object that represents the new parameter of this constructor.

Exceptions

Exception Type | Condition
InvalidOperationException | If the containing type has been created using CreateType.

See Also

ConstructorBuilder Class | ConstructorBuilder Members | System.Reflection.Emit Namespace


ConstructorBuilder.GetCustomAttributes

Overloaded. Returns the custom attributes defined for this constructor.

Overload List

Returns the custom attributes identified by the given type.

[Visual Basic] Overloads Overrides Public Function GetCustomAttributes(Type) As Object ()
[C#] public override object[] GetCustomAttributes(Type);
[C++] public: override Object* GetCustomAttributes(Type*) [];
[JScript] public override function GetCustomAttributes(Type) : Object[];

Returns all the custom attributes defined for this constructor.

[Visual Basic] Overloads Overrides Public Function GetCustomAttributes() As Object ()
[C#] public override object[] GetCustomAttributes();
[C++] public: override Object* GetCustomAttributes() [];
[JScript] public override function GetCustomAttributes() : Object[];

See Also

ConstructorBuilder Class | ConstructorBuilder Members | System.Reflection.Emit Namespace


ConstructorBuilder.GetCustomAttributes (Type)

Returns the custom attributes identified by the given type.

[Visual Basic]
Overloads Overrides Public Function GetCustomAttributes( _
   ByVal attributeType As Type _
) As Object ()
[C#]
public override object[] GetCustomAttributes(
   Type attributeType
);
[C++]
public: override Object* GetCustomAttributes(
   Type* attributeType
) [];
[JScript]
public override function GetCustomAttributes(
   attributeType : Type
) : Object[];

Parameters

attributeType
The custom attribute type.

Return Value

Returns an array of objects representing the attributes of this constructor that are of Type attributeType.

See Also

ConstructorBuilder Class | ConstructorBuilder Members | System.Reflection.Emit Namespace | ConstructorBuilder.GetCustomAttributes Overload List


ConstructorBuilder.GetCustomAttributes ()

Returns all the custom attributes defined for this constructor.

[Visual Basic]
Overloads Overrides Public Function GetCustomAttributes() As Object ()
[C#]
public override object[] GetCustomAttributes();
[C++]
public: override Object* GetCustomAttributes() [];
[JScript]
public override function GetCustomAttributes() : Object[];

Return Value

Returns an array of objects representing all the custom attributes of the constructor represented by this ConstructorBuilder instance.

See Also

ConstructorBuilder Class | ConstructorBuilder Members | System.Reflection.Emit Namespace | ConstructorBuilder.GetCustomAttributes Overload List


ConstructorBuilder.GetILGenerator

Gets an ILGenerator for this constructor.

[Visual Basic]
Public Function GetILGenerator() As ILGenerator
[C#]
public ILGenerator GetILGenerator();
[C++]
public: ILGenerator* GetILGenerator();
[JScript]
public function GetILGenerator() : ILGenerator;

Return Value

Returns an ILGenerator object for this constructor.

See Also

ConstructorBuilder Class | ConstructorBuilder Members | System.Reflection.Emit Namespace


ConstructorBuilder.GetMethodImplementationFlags

Returns the method implementation flags for this constructor.

[Visual Basic]
Overrides Public Function GetMethodImplementationFlags() As _
   MethodImplAttributes
[C#]
public override MethodImplAttributes GetMethodImplementationFlags();
[C++]
public: override MethodImplAttributes
   GetMethodImplementationFlags();
[JScript]
public override function GetMethodImplementationFlags() :
   MethodImplAttributes;

Return Value

The method implementation flags for this constructor.

See Also

ConstructorBuilder Class | ConstructorBuilder Members | System.Reflection.Emit Namespace


ConstructorBuilder.GetModule

Returns a reference to the module that contains this constructor.

[Visual Basic]
Public Function GetModule() As Module
[C#]
public Module GetModule();
[C++]
public: Module* GetModule();
[JScript]
public function GetModule() : Module;

See Also

ConstructorBuilder Class | ConstructorBuilder Members | System.Reflection.Emit Namespace


ConstructorBuilder.GetParameters

Returns the parameters of this constructor.

[Visual Basic]
Overrides Public Function GetParameters() As ParameterInfo ()
[C#]
public override ParameterInfo[] GetParameters();
[C++]
public: override ParameterInfo* GetParameters() [];
[JScript]
public override function GetParameters() : ParameterInfo[];

Return Value

Returns an array of ParameterInfo objects that represent the parameters of this constructor.

See Also

ConstructorBuilder Class | ConstructorBuilder Members | System.Reflection.Emit Namespace


ConstructorBuilder.GetToken

Returns the MethodToken that represents the token for this constructor.

[Visual Basic]
Public Function GetToken() As MethodToken
[C#]
public MethodToken GetToken();
[C++]
public: MethodToken GetToken();
[JScript]
public function GetToken() : MethodToken;

Return Value

Returns the MethodToken of this constructor.

See Also

ConstructorBuilder Class | ConstructorBuilder Members | System.Reflection.Emit Namespace


ConstructorBuilder.Invoke

Dynamically invokes the constructor reflected by this instance on the given object, passing along the specified parameters, and under the constraints of the given binder.

[Visual Basic]
Overrides Public Function Invoke( _
   ByVal invokeAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal parameters() As Object, _
   ByVal culture As CultureInfo _
) As Object
[C#]
public override object Invoke(
   BindingFlags invokeAttr,
   Binder binder,
   object[] parameters,
   CultureInfo culture
);
[C++]
public: override Object* Invoke(
   BindingFlags invokeAttr,
   Binder* binder,
   Object* parameters[],
   CultureInfo* culture
);
[JScript]
public override function Invoke(
   invokeAttr : BindingFlags,
   binder : Binder,
   parameters : Object[],
   culture : CultureInfo
) : Object;

Parameters

invokeAttr
This must be a bit flag from BindingFlags: InvokeMethod, NonPublic, etc.
binder
An object that enables the binding, coercion of argument types, invocation of members, and retrieval of MemberInfo objects via reflection. If binder is a null reference (in Visual Basic Nothing), the default binder is used. See Binder.
parameters
An argument list. This is an array of arguments with the same number, order, and type as the parameters of the constructor to be invoked. If there are no parameters this should be a null reference (Nothing).
culture
An instance of CultureInfo used to govern the coercion of types. If this is null, the CultureInfo for the current thread is used. (Note that this is necessary to, for example, convert a String that represents 1000 to a Double value, since 1000 is represented differently by different cultures.)

Return Value

Returns an Object that is the return value of the invoked constructor.

Exceptions

Exception Type | Condition
NotSupportedException | This method is not currently supported. The workaround is to retrieve the constructor using GetConstructor and call Invoke on the returned ConstructorInfo.

Remarks

If the constructor has no parameters, the value of the parameters parameter should be a null reference (Nothing). Otherwise the number, type, and order of elements in the parameters array should be identical to the number, type, and order of parameters for the constructor reflected by this instance.

For example, if the constructor reflected by this instance is declared as public Foo(String a, String b), then parameters should be an array of Objects with length 2.

Note: Access restrictions are ignored for fully trusted code. That is, private constructors, methods, fields, and properties can be accessed and invoked via Reflection whenever the code is fully trusted.

See Also

ConstructorBuilder Class | ConstructorBuilder Members | System.Reflection.Emit Namespace


ConstructorBuilder.IsDefined

Checks if the specified custom attribute type is defined.

[Visual Basic]
Overrides Public Function IsDefined( _
   ByVal attributeType As Type _
) As Boolean
[C#]
public override bool IsDefined(
   Type attributeType
);
[C++]
public: override bool IsDefined(
   Type* attributeType
);
[JScript]
public override function IsDefined(
   attributeType : Type
) : Boolean;

Parameters

attributeType
A custom attribute type.

Return Value

true if the specified custom attribute type is defined. Otherwise, false.

See Also

ConstructorBuilder Class | ConstructorBuilder Members | System.Reflection.Emit Namespace


ConstructorBuilder.SetCustomAttribute

Sets a custom attribute.

Overload List

Set a custom attribute using a custom attribute builder.

[Visual Basic] Overloads Public Sub SetCustomAttribute(CustomAttributeBuilder)
[C#] public void SetCustomAttribute(CustomAttributeBuilder);
[C++] public: void SetCustomAttribute(CustomAttributeBuilder*);
[JScript] public function SetCustomAttribute(CustomAttributeBuilder);

Set a custom attribute using a specified custom attribute blob.

[Visual Basic] Overloads Public Sub SetCustomAttribute(ConstructorInfo, Byte())
[C#] public void SetCustomAttribute(ConstructorInfo, byte[]);
[C++] public: void SetCustomAttribute(ConstructorInfo*, unsigned char[]);
[JScript] public function SetCustomAttribute(ConstructorInfo, Byte[]);

See Also

ConstructorBuilder Class | ConstructorBuilder Members | System.Reflection.Emit Namespace


ConstructorBuilder.SetCustomAttribute (CustomAttributeBuilder)

Set a custom attribute using a custom attribute builder.

[Visual Basic]
Overloads Public Sub SetCustomAttribute( _
   ByVal customBuilder As CustomAttributeBuilder _
)
[C#]
public void SetCustomAttribute(
   CustomAttributeBuilder customBuilder
);
[C++]
public: void SetCustomAttribute(
   CustomAttributeBuilder* customBuilder
);
[JScript]
public function SetCustomAttribute(
   customBuilder : CustomAttributeBuilder
);

Parameters

customBuilder
An instance of a helper class to define the custom attribute.

Exceptions

Exception Type | Condition
ArgumentNullException | if con is a null reference (in Visual Basic Nothing)

See Also

ConstructorBuilder Class | ConstructorBuilder Members | System.Reflection.Emit Namespace | ConstructorBuilder.SetCustomAttribute Overload List


ConstructorBuilder.SetCustomAttribute (ConstructorInfo, Byte[])

Set a custom attribute using a specified custom attribute blob.

[Visual Basic]
Overloads Public Sub SetCustomAttribute( _
   ByVal con As ConstructorInfo, _
   ByVal binaryAttribute() As Byte _
)
[C#]
public void SetCustomAttribute(
   ConstructorInfo con,
   byte[] binaryAttribute
);
[C++]
public: void SetCustomAttribute(
   ConstructorInfo* con,
   unsigned char* binaryAttribute[]
);
[JScript]
public function SetCustomAttribute(
   con : ConstructorInfo,
   binaryAttribute : Byte[]
);

Parameters

con
The constructor for the custom attribute.
binaryAttribute
A byte blob representing the attributes.

Exceptions

Exception Type | Condition
ArgumentNullException | if con or binaryAttribute is a null reference (in Visual Basic Nothing)

Remarks

See the for details on how to format binaryAttribute.

See Also

ConstructorBuilder Class | ConstructorBuilder Members | System.Reflection.Emit Namespace | ConstructorBuilder.SetCustomAttribute Overload List


ConstructorBuilder.SetImplementationFlags

Sets the method implementation flags for this constructor.

[Visual Basic]
Public Sub SetImplementationFlags( _
   ByVal attributes As MethodImplAttributes _
)
[C#]
public void SetImplementationFlags(
   MethodImplAttributes attributes
);
[C++]
public: void SetImplementationFlags(
   MethodImplAttributes attributes
);
[JScript]
public function SetImplementationFlags(
   attributes : MethodImplAttributes
);

Parameters

attributes
The method implementation flags.

See Also

ConstructorBuilder Class | ConstructorBuilder Members | System.Reflection.Emit Namespace


ConstructorBuilder.SetSymCustomAttribute

Sets this constructor's custom attribute associated with symbolic information.

[Visual Basic]
Public Sub SetSymCustomAttribute( _
   ByVal name As String, _
   ByVal data() As Byte _
)
[C#]
public void SetSymCustomAttribute(
   string name,
   byte[] data
);
[C++]
public: void SetSymCustomAttribute(
   String* name,
   unsigned char* data[]
);
[JScript]
public function SetSymCustomAttribute(
   name : String,
   data : Byte[]
);

Parameters

name
The name of the custom attribute.
data
[To be supplied.]

Exceptions

Exception Type | Condition
InvalidOperationException | If the containing type has been created using CreateType.

See Also

ConstructorBuilder Class | ConstructorBuilder Members | System.Reflection.Emit Namespace


ConstructorBuilder.ToString

Returns this ConstructorBuilder instance as a String.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

Returns a String containing the name, attributes, and exceptions of this constructor followed by the current IL Stream.

See Also

ConstructorBuilder Class | ConstructorBuilder Members | System.Reflection.Emit Namespace


CustomAttributeBuilder Class

CustomAttributeBuilder is a helper class to help build custom attributes.

Object
CustomAttributeBuilder

[Visual Basic]
Public Class CustomAttributeBuilder
[C#]
public class CustomAttributeBuilder
[C++]
public __gc class CustomAttributeBuilder
[JScript]
public class CustomAttributeBuilder

Remarks

Use the CustomAttributeBuilder object returned by the constructor to set the custom attribute using the SetCustomAttribute method.

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

CustomAttributeBuilder Members | System.Reflection.Emit Namespace


CustomAttributeBuilder Members

Public:

Constructor

CustomAttributeBuilder Constructor Initializes an instance of the CustomAttributeBuilder class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CustomAttributeBuilder Class | System.Reflection.Emit Namespace


CustomAttributeBuilder Constructor

Initializes an instance of the CustomAttributeBuilder class.

[Visual Basic]
Public Sub New( _
   ByVal con As ConstructorInfo, _
   ByVal constructorArgs() As Object _
)
[C#]
public CustomAttributeBuilder(
   ConstructorInfo con,
   object[] constructorArgs
);
[C++]
public: CustomAttributeBuilder(
   ConstructorInfo* con,
   Object* constructorArgs[]
);
[JScript]
public function CustomAttributeBuilder(
   con : ConstructorInfo,
   constructorArgs : Object[]
);

Parameters

con
The constructor for the custom attribute.
constructorArgs
The arguments to the constructor of the custom attribute.

See Also

CustomAttributeBuilder Class | CustomAttributeBuilder Members | System.Reflection.Emit Namespace


EnumBuilder Class

The EnumBuilder class is used to describe and represent an enumeration type.

Object
MemberInfo
Type
EnumBuilder

[Visual Basic]
NotInheritable Public Class EnumBuilder
   Inherits Type
[C#]
public sealed class EnumBuilder : Type
[C++]
public __gc __sealed class EnumBuilder : public Type
[JScript]
public class EnumBuilder extends Type

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder Members

Public:

Properties

AssemblyQualifiedName | Returns the full path name of this enum qualified by the display name of the parent assembly.
Attributes (inherited from Type) | Gets a bitmask indicating the attributes associated with the Type.
BaseType | Returns the parent Type of this type.
DeclaringType | Returns the type that declared this field.
FullName | Returns the full path name of this enum.
GUID | Returns the GUID of this enum.
HasElementType (inherited from Type) | Gets a value indicating whether the Type ...
IsAbstract (inherited from Type) | Gets a value indicating whether the Type is abstract and must be overridden.
IsAnsiClass (inherited from Type) | Gets a value indicating whether the string format attribute AnsiClass is selected for the Type.
IsArray (inherited from Type) | Gets a value indicating whether the Type is an array.
IsAutoClass (inherited from Type) | Gets a value indicating whether the string format attribute AutoClass is selected for the Type.
IsAutoLayout (inherited from Type) | Gets a value indicating whether the class layout attribute AutoLayout is selected for the Type.
IsByRef (inherited from Type) | Gets a value indicating whether the Type is passed by reference.
IsClass (inherited from Type) | Gets a value indicating whether the Type is a class; that is, not a value type or interface.
IsCOMObject (inherited from Type) | Gets a value indicating whether the Type is a COM object.
IsContextful (inherited from Type) | Gets a value indicating whether the Type can be hosted in a context.
IsEnum (inherited from Type) | Gets a value indicating whether the Type is an enumeration.
IsExplicitLayout (inherited from Type) | Gets a value indicating whether the class layout attribute ExplicitLayout is selected for the Type.
IsImport (inherited from Type) | Gets a value indicating whether the Type was imported from another class.
IsInterface (inherited from Type) | Gets a value indicating whether the Type is an interface; that is, not a class or a value type.
IsLayoutSequential (inherited from Type) | Gets a value indicating whether the class layout attribute LayoutSequential is selected for the Type.
IsMarshalByRef (inherited from Type) | Gets a value indicating whether the Type is marshalled by reference.
IsNestedAssembly (inherited from Type) | Gets a value indicating whether the Type is nested and visible only within its own assembly.
IsNestedFamANDAssem (inherited from Type) | Gets a value indicating whether the Type is nested and visible only to classes that belong to both its own family and its own assembly.
IsNestedFamily (inherited from Type) | Gets a value indicating whether the Type is nested and visible only within its own family.
IsNestedFamORAssem (inherited from Type) | Gets a value indicating whether the Type is nested and visible only to classes that belong to its own family or to its own assembly.
IsNestedPrivate (inherited from Type) | Gets a value indicating whether the Type is nested and declared private.
IsNestedPublic (inherited from Type) | Gets a value indicating whether the Type is nested and declared public.
IsNotPublic (inherited from Type) | Gets a value indicating whether the Type is not declared public.
IsPointer (inherited from Type) | Gets a value indicating whether the Type is a pointer.
IsPrimitive (inherited from Type) | Gets a value indicating whether the Type is one of the primitive types.
IsPublic (inherited from Type) | Gets a value indicating whether the Type is declared public.
IsSealed (inherited from Type) | Gets a value indicating whether the Type is declared sealed.
IsSerializable (inherited from Type) | Gets a value indicating whether the Type is serializable.
IsSpecialName (inherited from Type) | Gets a value indicating whether the Type has a name that requires special handling.
IsUnicodeClass (inherited from Type) | Gets a value indicating whether the string format attribute UnicodeClass is selected for the Type.
IsUnmanagedValueType (inherited from Type) | Gets a value indicating whether the Type is one of the unmanaged value types.
IsValueType (inherited from Type) | Gets a value indicating whether the Type is a value type; that is, not a class or an interface.
MemberType (inherited from Type) | Gets a bit mask indicating the member type.
Module | Retrieves the dynamic module that contains this type definition.
Name | Returns the name of this enum.
Namespace | Returns the namespace of this enum.
ReflectedType | Return the type that was used to obtain this field.
TypeHandle | Retrieves the internal handle for this enum. Use this handle to access the underlying metadata handle.
TypeInitializer (inherited from Type) | Gets the name of the class constructor for the Type.
TypeToken | Returns the internal metadata type token of this enum.
UnderlyingField | Returns the underlying field for this enum.
UnderlyingSystemType | Returns the underlying system type for this enum.

Methods

CreateType | Creates a Type object for this enum.
DefineLiteral | Defines the named static field in an enumeration type with the specified constant value.
Equals (inherited from Type) | Overloaded. Determines if the underlying system type of the current Type is the same as the underlying system type of the specified Object or Type.
FindInterfaces (inherited from Type) | Returns an array of Type objects representing a filtered list of interfaces implemented or inherited by the current Type.
FindMembers (inherited from Type) | Returns a filtered array of MemberInfo objects of the specified member type.
GetArrayRank (inherited from Type) | When implemented by a derived class, gets the number of dimensions in an Array.
GetConstructor (inherited from Type) | Overloaded. Gets a specific constructor of the current Type.
GetConstructors (inherited from Type) | Overloaded. Gets the constructors of the current Type.
GetCustomAttributes | Overloaded. Overloaded. Returns the custom attributes defined for this constructor.
GetDefaultMembers (inherited from Type) | Searches for the members defined for the current Type whose DefaultMemberAttribute is set.
GetElementType | This member is not supported.
GetEvent (inherited from Type) | Overloaded. Gets a specific event declared or inherited by the current Type.
GetEvents | Overloaded. [To be supplied.]
GetField | Overloaded. [To be supplied.]
GetFields (inherited from Type) | Overloaded. Gets the fields of the current Type.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInterface (inherited from Type) | Overloaded. Gets a specific interface implemented or inherited by the current Type.
GetInterfaceMap | This method will return an interface mapping for the interface requested.
GetInterfaces | Returns an array of all the interfaces implemented on this a class and its super classes.
GetMember (inherited from Type) | Overloaded. Gets the specified members of the current Type.
GetMembers | Overloaded. [To be supplied.]
GetMethod (inherited from Type) | Overloaded. Gets a specific method of the current Type.
GetMethods (inherited from Type) | Overloaded. Gets the methods of the current Type.
GetNestedType | Overloaded. [To be supplied.]
GetNestedTypes (inherited from Type) | Overloaded. Gets the types nested within the current Type.
GetProperties (inherited from Type) | Overloaded. Gets the properties of the current Type.
GetProperty (inherited from Type) | Overloaded. Gets a specific property of the current Type.
GetType (inherited from Object) | Gets the Type of the Object.
InvokeMember (inherited from Type) | Overloaded. Invokes a specific member of the current Type; essentially calls a constructor member or a method member, gets or sets a property member, gets or sets a data field member, or gets or sets an element of an array member.
IsAssignableFrom (inherited from Type) | Determines whether an instance of the specified type can be assigned to the current Type instance.
IsDefined | This method is not implemented.
IsInstanceOfType (inherited from Type) | Determines whether the specified object is an instance of the Type.
IsSubclassOf (inherited from Type) | Determines whether the current Type is a subclass of the specified class.
SetCustomAttribute | Overloaded. Overloaded. Sets custom attributes for this constructor.
ToString (inherited from Type) | Returns a String representing the name of the current Type.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetAttributeFlagsImpl | Get the implementation attribute flags.
GetConstructorImpl | This member is not yet implemented.
GetMethodImpl | This member is not yet implemented.
GetPropertyImpl | This member is not yet implemented.
HasElementTypeImpl | This member is not supported.
IsArrayImpl | Returns false.
IsByRefImpl | Returns true.
IsCOMObjectImpl | Returns false.
IsContextfulImpl (inherited from Type) | Implements the IsContextful property and determines whether the Type can be hosted in a context.
IsMarshalByRefImpl (inherited from Type) | Implements the IsMarshalByRef property and determines whether the Type is marshalled by reference.
IsPointerImpl | Returns true.
IsPrimitiveImpl | Returns false.
IsValueTypeImpl | Returns true.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EnumBuilder Class | System.Reflection.Emit Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EnumBuilder Properties

The properties of the EnumBuilder class are listed below. For a complete list of EnumBuilder class members, see the EnumBuilder Members topic.

Public:

AssemblyQualifiedName | Returns the full path name of this enum qualified by the display name of the parent assembly.
Attributes (inherited from Type) | Gets a bitmask indicating the attributes associated with the Type.
BaseType | Returns the parent Type of this type.
DeclaringType | Returns the type that declared this field.
FullName | Returns the full path name of this enum.
GUID | Returns the GUID of this enum.
HasElementType (inherited from Type) | Gets a value indicating whether the Type ...
IsAbstract (inherited from Type) | Gets a value indicating whether the Type is abstract and must be overridden.
IsAnsiClass (inherited from Type) | Gets a value indicating whether the string format attribute AnsiClass is selected for the Type.
IsArray (inherited from Type) | Gets a value indicating whether the Type is an array.
IsAutoClass (inherited from Type) | Gets a value indicating whether the string format attribute AutoClass is selected for the Type.
IsAutoLayout (inherited from Type) | Gets a value indicating whether the class layout attribute AutoLayout is selected for the Type.
IsByRef (inherited from Type) | Gets a value indicating whether the Type is passed by reference.
IsClass (inherited from Type) | Gets a value indicating whether the Type is a class; that is, not a value type or interface.
IsCOMObject (inherited from Type) | Gets a value indicating whether the Type is a COM object.
IsContextful (inherited from Type) | Gets a value indicating whether the Type can be hosted in a context.
IsEnum (inherited from Type) | Gets a value indicating whether the Type is an enumeration.
IsExplicitLayout (inherited from Type) | Gets a value indicating whether the class layout attribute ExplicitLayout is selected for the Type.
IsImport (inherited from Type) | Gets a value indicating whether the Type was imported from another class.
IsInterface (inherited from Type) | Gets a value indicating whether the Type is an interface; that is, not a class or a value type.
IsLayoutSequential (inherited from Type) | Gets a value indicating whether the class layout attribute LayoutSequential is selected for the Type.
IsMarshalByRef (inherited from Type) | Gets a value indicating whether the Type is marshalled by reference.
IsNestedAssembly (inherited from Type) | Gets a value indicating whether the Type is nested and visible only within its own assembly.
IsNestedFamANDAssem (inherited from Type) | Gets a value indicating whether the Type is nested and visible only to classes that belong to both its own family and its own assembly.
IsNestedFamily (inherited from Type) | Gets a value indicating whether the Type is nested and visible only within its own family.
IsNestedFamORAssem (inherited from Type) | Gets a value indicating whether the Type is nested and visible only to classes that belong to its own family or to its own assembly.
IsNestedPrivate (inherited from Type) | Gets a value indicating whether the Type is nested and declared private.
IsNestedPublic (inherited from Type) | Gets a value indicating whether the Type is nested and declared public.
IsNotPublic (inherited from Type) | Gets a value indicating whether the Type is not declared public.
IsPointer (inherited from Type) | Gets a value indicating whether the Type is a pointer.
IsPrimitive (inherited from Type) | Gets a value indicating whether the Type is one of the primitive types.
IsPublic (inherited from Type) | Gets a value indicating whether the Type is declared public.
IsSealed (inherited from Type) | Gets a value indicating whether the Type is declared sealed.
IsSerializable (inherited from Type) | Gets a value indicating whether the Type is serializable.
IsSpecialName (inherited from Type) | Gets a value indicating whether the Type has a name that requires special handling.
IsUnicodeClass (inherited from Type) | Gets a value indicating whether the string format attribute UnicodeClass is selected for the Type.
IsUnmanagedValueType (inherited from Type) | Gets a value indicating whether the Type is one of the unmanaged value types.
IsValueType (inherited from Type) | Gets a value indicating whether the Type is a value type; that is, not a class or an interface.
MemberType (inherited from Type) | Gets a bit mask indicating the member type.
Module | Retrieves the dynamic module that contains this type definition.
Name | Returns the name of this enum.
Namespace | Returns the namespace of this enum.
ReflectedType | Return the type that was used to obtain this field.
TypeHandle | Retrieves the internal handle for this enum. Use this handle to access the underlying metadata handle.
TypeInitializer (inherited from Type) | Gets the name of the class constructor for the Type.
TypeToken | Returns the internal metadata type token of this enum.
UnderlyingField | Returns the underlying field for this enum.
UnderlyingSystemType | Returns the underlying system type for this enum.

See Also

EnumBuilder Class | System.Reflection.Emit Namespace


EnumBuilder.AssemblyQualifiedName

Returns the full path name of this enum qualified by the display name of the parent assembly.

[Visual Basic]
Overridable Public ReadOnly Property AssemblyQualifiedName As _
   String
[C#]
public string AssemblyQualifiedName {override get;}
[C++]
public: __property virtual String* get_AssemblyQualifiedName();
[JScript]
public function get AssemblyQualifiedName() : String;

Property Value

Read-only. The full path name of this enum qualified by the display name of the parent assembly.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.BaseType

Returns the parent Type of this type.

[Visual Basic]
Overridable Public ReadOnly Property BaseType As Type
[C#]
public Type BaseType {override get;}
[C++]
public: __property virtual Type* get_BaseType();
[JScript]
public function get BaseType() : Type;

Property Value

Read-only. Theparent Type of this type.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.DeclaringType

Returns the type that declared this field.

[Visual Basic]
Overridable Public ReadOnly Property DeclaringType As Type
[C#]
public Type DeclaringType {override get;}
[C++]
public: __property virtual Type* get_DeclaringType();
[JScript]
public function get DeclaringType() : Type;

Property Value

Read-only. The type that declared this field.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.FullName

Returns the full path name of this enum.

[Visual Basic]
Overridable Public ReadOnly Property FullName As String
[C#]
public string FullName {override get;}
[C++]
public: __property virtual String* get_FullName();
[JScript]
public function get FullName() : String;

Property Value

Read-only. The full path name of this enum.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.GUID

Returns the GUID of this enum.

[Visual Basic]
Overridable Public ReadOnly Property GUID As Guid
[C#]
public Guid GUID {override get;}
[C++]
public: __property virtual Guid get_GUID();
[JScript]
public function get GUID() : Guid;

Property Value

Read-only. The GUID of this enum.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.Module

Retrieves the dynamic module that contains this type definition.

[Visual Basic]
Overridable Public ReadOnly Property Module As Module
[C#]
public Module Module {override get;}
[C++]
public: __property virtual Module* get_Module();
[JScript]
public function get Module() : Module;

Property Value

Read-only. The dynamic module that contains this type definition

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.Name

Returns the name of this enum.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {override get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

Property Value

Read-only. The name of this enum.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.Namespace

Returns the namespace of this enum.

[Visual Basic]
Overridable Public ReadOnly Property Namespace As String
[C#]
public string Namespace {override get;}
[C++]
public: __property virtual String* get_Namespace();
[JScript]
public function get Namespace() : String;

Property Value

Read-only. The namespace of this enum.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.ReflectedType

Return the type that was used to obtain this field.

[Visual Basic]
Overridable Public ReadOnly Property ReflectedType As Type
[C#]
public Type ReflectedType {override get;}
[C++]
public: __property virtual Type* get_ReflectedType();
[JScript]
public function get ReflectedType() : Type;

Property Value

Read-only. The type that was used to obtain this field.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.TypeHandle

Retrieves the internal handle for this enum. Use this handle to access the underlying metadata handle.

[Visual Basic]
Overridable Public ReadOnly Property TypeHandle As _
   RuntimeTypeHandle
[C#]
public RuntimeTypeHandle TypeHandle {override get;}
[C++]
public: __property virtual RuntimeTypeHandle get_TypeHandle();
[JScript]
public function get TypeHandle() : RuntimeTypeHandle;

Property Value

Read-only. The internal handle for this enum.

Exceptions

Exception Type | Condition
NotSupportedException | This property is not currently supported.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.TypeToken

Returns the internal metadata type token of this enum.

[Visual Basic]
Public ReadOnly Property TypeToken As TypeToken
[C#]
public TypeToken TypeToken {get;}
[C++]
public: __property TypeToken get_TypeToken();
[JScript]
public function get TypeToken() : TypeToken;

Property Value

Read-only. The type token of this enum.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.UnderlyingField

Returns the underlying field for this enum.

[Visual Basic]
Public ReadOnly Property UnderlyingField As FieldBuilder
[C#]
public FieldBuilder UnderlyingField {get;}
[C++]
public: __property FieldBuilder* get_UnderlyingField();
[JScript]
public function get UnderlyingField() : FieldBuilder;

Property Value

Read-only. The underlying field for this enum.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.UnderlyingSystemType

Returns the underlying system type for this enum.

[Visual Basic]
Overridable Public ReadOnly Property UnderlyingSystemType As Type
[C#]
public Type UnderlyingSystemType {override get;}
[C++]
public: __property virtual Type* get_UnderlyingSystemType();
[JScript]
public function get UnderlyingSystemType() : Type;

Exceptions

Exception Type | Condition
NotSupportedException | This member is not supported in dynamic modules.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EnumBuilder Methods

The methods of the EnumBuilder class are listed below. For a complete list of EnumBuilder class members, see the EnumBuilder Members topic.

Public:

CreateType | Creates a Type object for this enum.
DefineLiteral | Defines the named static field in an enumeration type with the specified constant value.
Equals (inherited from Type) | Overloaded. Determines if the underlying system type of the current Type is the same as the underlying system type of the specified Object or Type.
FindInterfaces (inherited from Type) | Returns an array of Type objects representing a filtered list of interfaces implemented or inherited by the current Type.
FindMembers (inherited from Type) | Returns a filtered array of MemberInfo objects of the specified member type.
GetArrayRank (inherited from Type) | When implemented by a derived class, gets the number of dimensions in an Array.
GetConstructor (inherited from Type) | Overloaded. Gets a specific constructor of the current Type.
GetConstructors (inherited from Type) | Overloaded. Gets the constructors of the current Type.
GetCustomAttributes | Overloaded. Overloaded. Returns the custom attributes defined for this constructor.
GetDefaultMembers (inherited from Type) | Searches for the members defined for the current Type whose DefaultMemberAttribute is set.
GetElementType | This member is not supported.
GetEvent (inherited from Type) | Overloaded. Gets a specific event declared or inherited by the current Type.
GetEvents | Overloaded. [To be supplied.]
GetField | Overloaded. [To be supplied.]
GetFields (inherited from Type) | Overloaded. Gets the fields of the current Type.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInterface (inherited from Type) | Overloaded. Gets a specific interface implemented or inherited by the current Type.
GetInterfaceMap | This method will return an interface mapping for the interface requested.
GetInterfaces | Returns an array of all the interfaces implemented on this a class and its super classes.
GetMember (inherited from Type) | Overloaded. Gets the specified members of the current Type.
GetMembers | Overloaded. [To be supplied.]
GetMethod (inherited from Type) | Overloaded. Gets a specific method of the current Type.
GetMethods (inherited from Type) | Overloaded. Gets the methods of the current Type.
GetNestedType | Overloaded. [To be supplied.]
GetNestedTypes (inherited from Type) | Overloaded. Gets the types nested within the current Type.
GetProperties (inherited from Type) | Overloaded. Gets the properties of the current Type.
GetProperty (inherited from Type) | Overloaded. Gets a specific property of the current Type.
GetType (inherited from Object) | Gets the Type of the Object.
InvokeMember (inherited from Type) | Overloaded. Invokes a specific member of the current Type; essentially calls a constructor member or a method member, gets or sets a property member, gets or sets a data field member, or gets or sets an element of an array member.
IsAssignableFrom (inherited from Type) | Determines whether an instance of the specified type can be assigned to the current Type instance.
IsDefined | This method is not implemented.
IsInstanceOfType (inherited from Type) | Determines whether the specified object is an instance of the Type.
IsSubclassOf (inherited from Type) | Determines whether the current Type is a subclass of the specified class.
SetCustomAttribute | Overloaded. Overloaded. Sets custom attributes for this constructor.
ToString (inherited from Type) | Returns a String representing the name of the current Type.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetAttributeFlagsImpl | Get the implementation attribute flags.
GetConstructorImpl | This member is not yet implemented.
GetMethodImpl | This member is not yet implemented.
GetPropertyImpl | This member is not yet implemented.
HasElementTypeImpl | This member is not supported.
IsArrayImpl | Returns false.
IsByRefImpl | Returns true.
IsCOMObjectImpl | Returns false.
IsContextfulImpl (inherited from Type) | Implements the IsContextful property and determines whether the Type can be hosted in a context.
IsMarshalByRefImpl (inherited from Type) | Implements the IsMarshalByRef property and determines whether the Type is marshalled by reference.
IsPointerImpl | Returns true.
IsPrimitiveImpl | Returns false.
IsValueTypeImpl | Returns true.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EnumBuilder Class | System.Reflection.Emit Namespace


EnumBuilder.CreateType

Creates a Type object for this enum.

[Visual Basic]
Public Function CreateType() As Type
[C#]
public Type CreateType();
[C++]
public: Type* CreateType();
[JScript]
public function CreateType() : Type;

Return Value

A Type object for this enum.

Exceptions

Exception Type | Condition
InvalidOperationException | if the containing Type has been created using CreateType.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.DefineLiteral

Defines the named static field in an enumeration type with the specified constant value.

[Visual Basic]
Public Function DefineLiteral( _
   ByVal literalName As String, _
   ByVal literalValue As Object _
) As FieldBuilder
[C#]
public FieldBuilder DefineLiteral(
   string literalName,
   object literalValue
);
[C++]
public: FieldBuilder* DefineLiteral(
   String* literalName,
   Object* literalValue
);
[JScript]
public function DefineLiteral(
   literalName : String,
   literalValue : Object
) : FieldBuilder;

Parameters

literalName
The name of the static field.
literalValue
[To be supplied.]

Return Value

The defined field.

Remarks

The defined field will have the field attributes Public, Static, and Literal set.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.GetAttributeFlagsImpl

Get the implementation attribute flags.

[Visual Basic]
Overrides Protected Function GetAttributeFlagsImpl() As _
   TypeAttributes
[C#]
protected override TypeAttributes GetAttributeFlagsImpl();
[C++]
protected: override TypeAttributes GetAttributeFlagsImpl();
[JScript]
protected override function GetAttributeFlagsImpl() :
   TypeAttributes;

Return Value

The implementation attribute flags.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.GetConstructorImpl

This member is not yet implemented.

[Visual Basic]
Overrides Protected Function GetConstructorImpl( _
   ByVal bindingAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal callConvention As CallingConventions, _
   ByVal types() As Type, _
   ByVal modifiers() As ParameterModifier _
) As ConstructorInfo
[C#]
protected override ConstructorInfo GetConstructorImpl(
   BindingFlags bindingAttr,
   Binder binder,
   CallingConventions callConvention,
   Type[] types,
   ParameterModifier[] modifiers
);
[C++]
protected: override ConstructorInfo* GetConstructorImpl(
   BindingFlags bindingAttr,
   Binder* binder,
   CallingConventions callConvention,
   Type* types[],
   ParameterModifier* modifiers[]
);
[JScript]
protected override function GetConstructorImpl(
   bindingAttr : BindingFlags,
   binder : Binder,
   callConvention : CallingConventions,
   types : Type[],
   modifiers : ParameterModifier[]
) : ConstructorInfo;

Parameters

bindingAttr
[To be supplied.]
binder
[To be supplied.]
callConvention
[To be supplied.]
types
[To be supplied.]
modifiers
[To be supplied.]

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.GetConstructors

This member is not yet implemented.

[Visual Basic]
Overrides Public Function GetConstructors( _
   ByVal bindingAttr As BindingFlags _
) As ConstructorInfo ()
[C#]
public override ConstructorInfo[] GetConstructors(
   BindingFlags bindingAttr
);
[C++]
public: override ConstructorInfo* GetConstructors(
   BindingFlags bindingAttr
) [];
[JScript]
public override function GetConstructors(
   bindingAttr : BindingFlags
) : ConstructorInfo[];

Parameters

bindingAttr
[To be supplied.]

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.GetCustomAttributes

Overloaded. Returns the custom attributes defined for this constructor.

Overload List

Returns the custom attributes identified by the given type.

[Visual Basic] Overloads Overrides Public Function GetCustomAttributes(Type) As Object ()
[C#] public override object[] GetCustomAttributes(Type);
[C++] public: override Object* GetCustomAttributes(Type*) [];
[JScript] public override function GetCustomAttributes(Type) : Object[];

Returns all the custom attributes defined for this constructor.

[Visual Basic] Overloads Overrides Public Function GetCustomAttributes() As Object ()
[C#] public override object[] GetCustomAttributes();
[C++] public: override Object* GetCustomAttributes() [];
[JScript] public override function GetCustomAttributes() : Object[];

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.GetCustomAttributes (Type)

Returns the custom attributes identified by the given type.

[Visual Basic]
Overloads Overrides Public Function GetCustomAttributes( _
   ByVal attributeType As Type _
) As Object ()
[C#]
public override object[] GetCustomAttributes(
   Type attributeType
);
[C++]
public: override Object* GetCustomAttributes(
   Type* attributeType
) [];
[JScript]
public override function GetCustomAttributes(
   attributeType : Type
) : Object[];

Parameters

attributeType
The custom attribute type.

Return Value

Returns an array of objects representing the attributes of this constructor that are of Type attributeType.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace | EnumBuilder.GetCustomAttributes Overload List


EnumBuilder.GetCustomAttributes ()

Returns all the custom attributes defined for this constructor.

[Visual Basic]
Overloads Overrides Public Function GetCustomAttributes() As Object ()
[C#]
public override object[] GetCustomAttributes();
[C++]
public: override Object* GetCustomAttributes() [];
[JScript]
public override function GetCustomAttributes() : Object[];

Return Value

Returns an array of objects representing all the custom attributes of the constructor represented by this ConstructorBuilder instance.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace | EnumBuilder.GetCustomAttributes Overload List


EnumBuilder.GetElementType

This member is not supported.

[Visual Basic]
Overrides Public Function GetElementType() As Type
[C#]
public override Type GetElementType();
[C++]
public: override Type* GetElementType();
[JScript]
public override function GetElementType() : Type;

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.GetEvent

This member is not yet implemented.

[Visual Basic]
Overrides Public Function GetEvent( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags _
) As EventInfo
[C#]
public override EventInfo GetEvent(
   string name,
   BindingFlags bindingAttr
);
[C++]
public: override EventInfo* GetEvent(
   String* name,
   BindingFlags bindingAttr
);
[JScript]
public override function GetEvent(
   name : String,
   bindingAttr : BindingFlags
) : EventInfo;

Parameters

name
[To be supplied.]
bindingAttr
[To be supplied.]

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.GetEvents

[To be supplied.]

Overload List

This member is not yet implemented.

[Visual Basic] Overloads Overrides Public Function GetEvents(BindingFlags) As EventInfo ()
[C#] public override EventInfo[] GetEvents(BindingFlags);
[C++] public: override EventInfo* GetEvents(BindingFlags) [];
[JScript] public override function GetEvents(BindingFlags) : EventInfo[];

This member is not yet implemented.

[Visual Basic] Overloads Overrides Public Function GetEvents() As EventInfo ()
[C#] public override EventInfo[] GetEvents();
[C++] public: override EventInfo* GetEvents() [];
[JScript] public override function GetEvents() : EventInfo[];

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.GetEvents (BindingFlags)

This member is not yet implemented.

[Visual Basic]
Overloads Overrides Public Function GetEvents( _
   ByVal bindingAttr As BindingFlags _
) As EventInfo ()
[C#]
public override EventInfo[] GetEvents(
   BindingFlags bindingAttr
);
[C++]
public: override EventInfo* GetEvents(
   BindingFlags bindingAttr
) [];
[JScript]
public override function GetEvents(
   bindingAttr : BindingFlags
) : EventInfo[];

Parameters

bindingAttr
[To be supplied.]

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace | EnumBuilder.GetEvents Overload List


EnumBuilder.GetEvents ()

This member is not yet implemented.

[Visual Basic]
Overloads Overrides Public Function GetEvents() As EventInfo ()
[C#]
public override EventInfo[] GetEvents();
[C++]
public: override EventInfo* GetEvents() [];
[JScript]
public override function GetEvents() : EventInfo[];

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace | EnumBuilder.GetEvents Overload List


EnumBuilder.GetField

This member is not yet implemented.

[Visual Basic]
Overrides Public Function GetField( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags _
) As FieldInfo
[C#]
public override FieldInfo GetField(
   string name,
   BindingFlags bindingAttr
);
[C++]
public: override FieldInfo* GetField(
   String* name,
   BindingFlags bindingAttr
);
[JScript]
public override function GetField(
   name : String,
   bindingAttr : BindingFlags
) : FieldInfo;

Parameters

name
[To be supplied.]
bindingAttr
[To be supplied.]

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.GetFields

This member is not yet implemented.

[Visual Basic]
Overrides Public Function GetFields( _
   ByVal bindingAttr As BindingFlags _
) As FieldInfo ()
[C#]
public override FieldInfo[] GetFields(
   BindingFlags bindingAttr
);
[C++]
public: override FieldInfo* GetFields(
   BindingFlags bindingAttr
) [];
[JScript]
public override function GetFields(
   bindingAttr : BindingFlags
) : FieldInfo[];

Parameters

bindingAttr
[To be supplied.]

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.GetInterface

Returns the interface implemented (directly or indirectly) by this class with the fully-qualified name matching the given interface name.

[Visual Basic]
Overrides Public Function GetInterface( _
   ByVal name As String, _
   ByVal ignoreCase As Boolean _
) As Type
[C#]
public override Type GetInterface(
   string name,
   bool ignoreCase
);
[C++]
public: override Type* GetInterface(
   String* name,
   bool ignoreCase
);
[JScript]
public override function GetInterface(
   name : String,
   ignoreCase : Boolean
) : Type;

Parameters

name
The name of the interface.
ignoreCase
If true, the search is case-insensitive. If false, the search is case-sensitive.

Return Value

Returns a Type object representing the implemented interface. Returns null if no interface matching name is found.

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.GetInterfaceMap

This method will return an interface mapping for the interface requested.

[Visual Basic]
Overrides Public Function GetInterfaceMap( _
   ByVal interfaceType As Type _
) As InterfaceMapping
[C#]
public override InterfaceMapping GetInterfaceMap(
   Type interfaceType
);
[C++]
public: override InterfaceMapping GetInterfaceMap(
   Type* interfaceType
);
[JScript]
public override function GetInterfaceMap(
   interfaceType : Type
) : InterfaceMapping;

Parameters

interfaceType
The Type of the interface for which the interface mapping is to be retrieved.

Return Value

The requested interface mapping.

Exceptions

Exception Type | Condition
ArgumentException | if the Type does not implement the interface.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.GetInterfaces

Returns an array of all the interfaces implemented on this a class and its super classes.

[Visual Basic]
Overrides Public Function GetInterfaces() As Type ()
[C#]
public override Type[] GetInterfaces();
[C++]
public: override Type* GetInterfaces() [];
[JScript]
public override function GetInterfaces() : Type[];

Return Value

Returns an array of Type objects representing the implemented interfaces. If none are defined, an empty array is returned.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.GetMember

This member is not yet implemented.

[Visual Basic]
Overrides Public Function GetMember( _
   ByVal name As String, _
   ByVal type As MemberTypes, _
   ByVal bindingAttr As BindingFlags _
) As MemberInfo ()
[C#]
public override MemberInfo[] GetMember(
   string name,
   MemberTypes type,
   BindingFlags bindingAttr
);
[C++]
public: override MemberInfo* GetMember(
   String* name,
   MemberTypes type,
   BindingFlags bindingAttr
) [];
[JScript]
public override function GetMember(
   name : String,
   type : MemberTypes,
   bindingAttr : BindingFlags
) : MemberInfo[];

Parameters

name
[To be supplied.]
type
[To be supplied.]
bindingAttr
[To be supplied.]

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.GetMembers

This member is not yet implemented.

[Visual Basic]
Overrides Public Function GetMembers( _
   ByVal bindingAttr As BindingFlags _
) As MemberInfo ()
[C#]
public override MemberInfo[] GetMembers(
   BindingFlags bindingAttr
);
[C++]
public: override MemberInfo* GetMembers(
   BindingFlags bindingAttr
) [];
[JScript]
public override function GetMembers(
   bindingAttr : BindingFlags
) : MemberInfo[];

Parameters

bindingAttr
[To be supplied.]

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.GetMethodImpl

This member is not yet implemented.

[Visual Basic]
Overrides Protected Function GetMethodImpl( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal callConvention As CallingConventions, _
   ByVal types() As Type, _
   ByVal modifiers() As ParameterModifier _
) As MethodInfo
[C#]
protected override MethodInfo GetMethodImpl(
   string name,
   BindingFlags bindingAttr,
   Binder binder,
   CallingConventions callConvention,
   Type[] types,
   ParameterModifier[] modifiers
);
[C++]
protected: override MethodInfo* GetMethodImpl(
   String* name,
   BindingFlags bindingAttr,
   Binder* binder,
   CallingConventions callConvention,
   Type* types[],
   ParameterModifier* modifiers[]
);
[JScript]
protected override function GetMethodImpl(
   name : String,
   bindingAttr : BindingFlags,
   binder : Binder,
   callConvention : CallingConventions,
   types : Type[],
   modifiers : ParameterModifier[]
) : MethodInfo;

Parameters

name
[To be supplied.]
bindingAttr
[To be supplied.]
binder
[To be supplied.]
callConvention
[To be supplied.]
types
[To be supplied.]
modifiers
[To be supplied.]

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.GetMethods

This member is not yet implemented.

[Visual Basic]
Overrides Public Function GetMethods( _
   ByVal bindingAttr As BindingFlags _
) As MethodInfo ()
[C#]
public override MethodInfo[] GetMethods(
   BindingFlags bindingAttr
);
[C++]
public: override MethodInfo* GetMethods(
   BindingFlags bindingAttr
) [];
[JScript]
public override function GetMethods(
   bindingAttr : BindingFlags
) : MethodInfo[];

Parameters

bindingAttr
[To be supplied.]

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.GetNestedType

This member is not yet implemented.

[Visual Basic]
Overrides Public Function GetNestedType( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags _
) As Type
[C#]
public override Type GetNestedType(
   string name,
   BindingFlags bindingAttr
);
[C++]
public: override Type* GetNestedType(
   String* name,
   BindingFlags bindingAttr
);
[JScript]
public override function GetNestedType(
   name : String,
   bindingAttr : BindingFlags
) : Type;

Parameters

name
[To be supplied.]
bindingAttr
[To be supplied.]

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.GetNestedTypes

This member is not yet implemented.

[Visual Basic]
Overrides Public Function GetNestedTypes( _
   ByVal bindingAttr As BindingFlags _
) As Type ()
[C#]
public override Type[] GetNestedTypes(
   BindingFlags bindingAttr
);
[C++]
public: override Type* GetNestedTypes(
   BindingFlags bindingAttr
) [];
[JScript]
public override function GetNestedTypes(
   bindingAttr : BindingFlags
) : Type[];

Parameters

bindingAttr
[To be supplied.]

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.GetProperties

This member is not yet implemented.

[Visual Basic]
Overrides Public Function GetProperties( _
   ByVal bindingAttr As BindingFlags _
) As PropertyInfo ()
[C#]
public override PropertyInfo[] GetProperties(
   BindingFlags bindingAttr
);
[C++]
public: override PropertyInfo* GetProperties(
   BindingFlags bindingAttr
) [];
[JScript]
public override function GetProperties(
   bindingAttr : BindingFlags
) : PropertyInfo[];

Parameters

bindingAttr
[To be supplied.]

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.GetPropertyImpl

This member is not yet implemented.

[Visual Basic]
Overrides Protected Function GetPropertyImpl( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal types() As Type, _
   ByVal modifiers() As ParameterModifier _
) As PropertyInfo
[C#]
protected override PropertyInfo GetPropertyImpl(
   string name,
   BindingFlags bindingAttr,
   Binder binder,
   Type[] types,
   ParameterModifier[] modifiers
);
[C++]
protected: override PropertyInfo* GetPropertyImpl(
   String* name,
   BindingFlags bindingAttr,
   Binder* binder,
   Type* types[],
   ParameterModifier* modifiers[]
);
[JScript]
protected override function GetPropertyImpl(
   name : String,
   bindingAttr : BindingFlags,
   binder : Binder,
   types : Type[],
   modifiers : ParameterModifier[]
) : PropertyInfo;

Parameters

name
[To be supplied.]
bindingAttr
[To be supplied.]
binder
[To be supplied.]
types
[To be supplied.]
modifiers
[To be supplied.]

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.HasElementTypeImpl

This member is not supported.

[Visual Basic]
Overrides Protected Function HasElementTypeImpl() As Boolean
[C#]
protected override bool HasElementTypeImpl();
[C++]
protected: override bool HasElementTypeImpl();
[JScript]
protected override function HasElementTypeImpl() : Boolean;

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.InvokeMember

This member is not yet implemented.

[Visual Basic]
Overrides Public Function InvokeMember( _
   ByVal name As String, _
   ByVal invokeAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal target As Object, _
   ByVal args() As Object, _
   ByVal modifiers() As ParameterModifier, _
   ByVal culture As CultureInfo, _
   ByVal namedParameters() As String _
) As Object
[C#]
public override object InvokeMember(
   string name,
   BindingFlags invokeAttr,
   Binder binder,
   object target,
   object[] args,
   ParameterModifier[] modifiers,
   CultureInfo culture,
   string[] namedParameters
);
[C++]
public: override Object* InvokeMember(
   String* name,
   BindingFlags invokeAttr,
   Binder* binder,
   Object* target,
   Object* args[],
   ParameterModifier* modifiers[],
   CultureInfo* culture,
   String* namedParameters[]
);
[JScript]
public override function InvokeMember(
   name : String,
   invokeAttr : BindingFlags,
   binder : Binder,
   target : Object,
   args : Object[],
   modifiers : ParameterModifier[],
   culture : CultureInfo,
   namedParameters : String[]
) : Object;

Parameters

name
[To be supplied.]
invokeAttr
[To be supplied.]
binder
[To be supplied.]
target
[To be supplied.]
args
[To be supplied.]
modifiers
[To be supplied.]
culture
[To be supplied.]
namedParameters
[To be supplied.]

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.IsArrayImpl

Returns false.

[Visual Basic]
Overrides Protected Function IsArrayImpl() As Boolean
[C#]
protected override bool IsArrayImpl();
[C++]
protected: override bool IsArrayImpl();
[JScript]
protected override function IsArrayImpl() : Boolean;

Return Value

false

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.IsByRefImpl

Returns true.

[Visual Basic]
Overrides Protected Function IsByRefImpl() As Boolean
[C#]
protected override bool IsByRefImpl();
[C++]
protected: override bool IsByRefImpl();
[JScript]
protected override function IsByRefImpl() : Boolean;

Return Value

true

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.IsCOMObjectImpl

Returns false.

[Visual Basic]
Overrides Protected Function IsCOMObjectImpl() As Boolean
[C#]
protected override bool IsCOMObjectImpl();
[C++]
protected: override bool IsCOMObjectImpl();
[JScript]
protected override function IsCOMObjectImpl() : Boolean;

Return Value

false

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.IsDefined

This method is not implemented.

[Visual Basic]
Overrides Public Function IsDefined( _
   ByVal attributeType As Type _
) As Boolean
[C#]
public override bool IsDefined(
   Type attributeType
);
[C++]
public: override bool IsDefined(
   Type* attributeType
);
[JScript]
public override function IsDefined(
   attributeType : Type
) : Boolean;

Parameters

attributeType
[To be supplied.]

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.IsPointerImpl

Returns true.

[Visual Basic]
Overrides Protected Function IsPointerImpl() As Boolean
[C#]
protected override bool IsPointerImpl();
[C++]
protected: override bool IsPointerImpl();
[JScript]
protected override function IsPointerImpl() : Boolean;

Return Value

true

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.IsPrimitiveImpl

Returns false.

[Visual Basic]
Overrides Protected Function IsPrimitiveImpl() As Boolean
[C#]
protected override bool IsPrimitiveImpl();
[C++]
protected: override bool IsPrimitiveImpl();
[JScript]
protected override function IsPrimitiveImpl() : Boolean;

Return Value

false

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.IsValueTypeImpl

Returns true.

[Visual Basic]
Overrides Protected Function IsValueTypeImpl() As Boolean
[C#]
protected override bool IsValueTypeImpl();
[C++]
protected: override bool IsValueTypeImpl();
[JScript]
protected override function IsValueTypeImpl() : Boolean;

Return Value

true

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.SetCustomAttribute

Overloaded. Sets custom attributes for this constructor.

Overload List

Set a custom attribute using a custom attribute builder.

[Visual Basic] Overloads Public Sub SetCustomAttribute(CustomAttributeBuilder)
[C#] public void SetCustomAttribute(CustomAttributeBuilder);
[C++] public: void SetCustomAttribute(CustomAttributeBuilder*);
[JScript] public function SetCustomAttribute(CustomAttributeBuilder);

Set a custom attribute using a specified custom attribute blob.

[Visual Basic] Overloads Public Sub SetCustomAttribute(ConstructorInfo, Byte())
[C#] public void SetCustomAttribute(ConstructorInfo, byte[]);
[C++] public: void SetCustomAttribute(ConstructorInfo*, unsigned char[]);
[JScript] public function SetCustomAttribute(ConstructorInfo, Byte[]);

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace


EnumBuilder.SetCustomAttribute (CustomAttributeBuilder)

Set a custom attribute using a custom attribute builder.

[Visual Basic]
Overloads Public Sub SetCustomAttribute( _
   ByVal customBuilder As CustomAttributeBuilder _
)
[C#]
public void SetCustomAttribute(
   CustomAttributeBuilder customBuilder
);
[C++]
public: void SetCustomAttribute(
   CustomAttributeBuilder* customBuilder
);
[JScript]
public function SetCustomAttribute(
   customBuilder : CustomAttributeBuilder
);

Parameters

customBuilder
An instance of a helper class to define the custom attribute.

Exceptions

Exception Type | Condition
ArgumentNullException | if con is a null reference (in Visual Basic Nothing)

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace | EnumBuilder.SetCustomAttribute Overload List


EnumBuilder.SetCustomAttribute (ConstructorInfo, Byte[])

Set a custom attribute using a specified custom attribute blob.

[Visual Basic]
Overloads Public Sub SetCustomAttribute( _
   ByVal con As ConstructorInfo, _
   ByVal binaryAttribute() As Byte _
)
[C#]
public void SetCustomAttribute(
   ConstructorInfo con,
   byte[] binaryAttribute
);
[C++]
public: void SetCustomAttribute(
   ConstructorInfo* con,
   unsigned char* binaryAttribute[]
);
[JScript]
public function SetCustomAttribute(
   con : ConstructorInfo,
   binaryAttribute : Byte[]
);

Parameters

con
The constructor for the custom attribute.
binaryAttribute
A byte blob representing the attributes.

Exceptions

Exception Type | Condition
ArgumentNullException | if con or binaryAttribute is a null reference (in Visual Basic Nothing)

Remarks

See the for details on how to format binaryAttribute.

See Also

EnumBuilder Class | EnumBuilder Members | System.Reflection.Emit Namespace | EnumBuilder.SetCustomAttribute Overload List


EventBuilder Class

This class is used to define events for a class. An EventBuilder is always associated with a TypeBuilder. The TypeBuilder.DefineEvent method will return a new EventBuilder to a client.

Object
EventBuilder

[Visual Basic]
NotInheritable Public Class EventBuilder
[C#]
public sealed class EventBuilder
[C++]
public __gc __sealed class EventBuilder
[JScript]
public class EventBuilder

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

EventBuilder Members | System.Reflection.Emit Namespace


EventBuilder Members

Public:

Methods

AddOtherMethod | Adds one of the other methods associated with this event.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEventToken | Returns the token for this event.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SetAddOnMethod | Sets the method used to subscribe to this event.
SetCustomAttribute | Overloaded. Overloaded. Sets custom attributes for this constructor.
SetRaiseMethod | Sets the method used to raise this event.
SetRemoveOnMethod | Sets the method used to unsubscribe to this event.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EventBuilder Class | System.Reflection.Emit Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EventBuilder Methods

The methods of the EventBuilder class are listed below. For a complete list of EventBuilder class members, see the EventBuilder Members topic.

Public:

AddOtherMethod | Adds one of the other methods associated with this event.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEventToken | Returns the token for this event.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SetAddOnMethod | Sets the method used to subscribe to this event.
SetCustomAttribute | Overloaded. Overloaded. Sets custom attributes for this constructor.
SetRaiseMethod | Sets the method used to raise this event.
SetRemoveOnMethod | Sets the method used to unsubscribe to this event.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EventBuilder Class | System.Reflection.Emit Namespace


EventBuilder.AddOtherMethod

Adds one of the other methods associated with this event.

[Visual Basic]
Public Sub AddOtherMethod( _
   ByVal mdBuilder As MethodBuilder _
)
[C#]
public void AddOtherMethod(
   MethodBuilder mdBuilder
);
[C++]
public: void AddOtherMethod(
   MethodBuilder* mdBuilder
);
[JScript]
public function AddOtherMethod(
   mdBuilder : MethodBuilder
);

Parameters

mdBuilder
A MethodBuilder object that represents the other method.

See Also

EventBuilder Class | EventBuilder Members | System.Reflection.Emit Namespace


EventBuilder.GetEventToken

Returns the token for this event.

[Visual Basic]
Public Function GetEventToken() As EventToken
[C#]
public EventToken GetEventToken();
[C++]
public: EventToken GetEventToken();
[JScript]
public function GetEventToken() : EventToken;

Return Value

Returns the EventToken for this event.

See Also

EventBuilder Class | EventBuilder Members | System.Reflection.Emit Namespace


EventBuilder.SetAddOnMethod

Sets the method used to subscribe to this event.

[Visual Basic]
Public Sub SetAddOnMethod( _
   ByVal mdBuilder As MethodBuilder _
)
[C#]
public void SetAddOnMethod(
   MethodBuilder mdBuilder
);
[C++]
public: void SetAddOnMethod(
   MethodBuilder* mdBuilder
);
[JScript]
public function SetAddOnMethod(
   mdBuilder : MethodBuilder
);

Parameters

mdBuilder
A MethodBuilder object that represents the method used to subscribe to this event.

See Also

EventBuilder Class | EventBuilder Members | System.Reflection.Emit Namespace


EventBuilder.SetCustomAttribute

Overloaded. Sets custom attributes for this constructor.

Overload List

Set a custom attribute using a custom attribute builder.

[Visual Basic] Overloads Public Sub SetCustomAttribute(CustomAttributeBuilder)
[C#] public void SetCustomAttribute(CustomAttributeBuilder);
[C++] public: void SetCustomAttribute(CustomAttributeBuilder*);
[JScript] public function SetCustomAttribute(CustomAttributeBuilder);

Set a custom attribute using a specified custom attribute blob.

[Visual Basic] Overloads Public Sub SetCustomAttribute(ConstructorInfo, Byte())
[C#] public void SetCustomAttribute(ConstructorInfo, byte[]);
[C++] public: void SetCustomAttribute(ConstructorInfo*, unsigned char[]);
[JScript] public function SetCustomAttribute(ConstructorInfo, Byte[]);

See Also

EventBuilder Class | EventBuilder Members | System.Reflection.Emit Namespace


EventBuilder.SetCustomAttribute (CustomAttributeBuilder)

Set a custom attribute using a custom attribute builder.

[Visual Basic]
Overloads Public Sub SetCustomAttribute( _
   ByVal customBuilder As CustomAttributeBuilder _
)
[C#]
public void SetCustomAttribute(
   CustomAttributeBuilder customBuilder
);
[C++]
public: void SetCustomAttribute(
   CustomAttributeBuilder* customBuilder
);
[JScript]
public function SetCustomAttribute(
   customBuilder : CustomAttributeBuilder
);

Parameters

customBuilder
An instance of a helper class to define the custom attribute.

Exceptions

Exception Type | Condition
ArgumentNullException | if con is a null reference (in Visual Basic Nothing)

See Also

EventBuilder Class | EventBuilder Members | System.Reflection.Emit Namespace | EventBuilder.SetCustomAttribute Overload List


EventBuilder.SetCustomAttribute (ConstructorInfo, Byte[])

Set a custom attribute using a specified custom attribute blob.

[Visual Basic]
Overloads Public Sub SetCustomAttribute( _
   ByVal con As ConstructorInfo, _
   ByVal binaryAttribute() As Byte _
)
[C#]
public void SetCustomAttribute(
   ConstructorInfo con,
   byte[] binaryAttribute
);
[C++]
public: void SetCustomAttribute(
   ConstructorInfo* con,
   unsigned char* binaryAttribute[]
);
[JScript]
public function SetCustomAttribute(
   con : ConstructorInfo,
   binaryAttribute : Byte[]
);

Parameters

con
The constructor for the custom attribute.
binaryAttribute
A byte blob representing the attributes.

Exceptions

Exception Type | Condition
ArgumentNullException | if con or binaryAttribute is a null reference (in Visual Basic Nothing)

Remarks

See the for details on how to format binaryAttribute.

See Also

EventBuilder Class | EventBuilder Members | System.Reflection.Emit Namespace | EventBuilder.SetCustomAttribute Overload List


EventBuilder.SetRaiseMethod

Sets the method used to raise this event.

[Visual Basic]
Public Sub SetRaiseMethod( _
   ByVal mdBuilder As MethodBuilder _
)
[C#]
public void SetRaiseMethod(
   MethodBuilder mdBuilder
);
[C++]
public: void SetRaiseMethod(
   MethodBuilder* mdBuilder
);
[JScript]
public function SetRaiseMethod(
   mdBuilder : MethodBuilder
);

Parameters

mdBuilder
A MethodBuilder object that represents the method used to raise this event.

See Also

EventBuilder Class | EventBuilder Members | System.Reflection.Emit Namespace


EventBuilder.SetRemoveOnMethod

Sets the method used to unsubscribe to this event.

[Visual Basic]
Public Sub SetRemoveOnMethod( _
   ByVal mdBuilder As MethodBuilder _
)
[C#]
public void SetRemoveOnMethod(
   MethodBuilder mdBuilder
);
[C++]
public: void SetRemoveOnMethod(
   MethodBuilder* mdBuilder
);
[JScript]
public function SetRemoveOnMethod(
   mdBuilder : MethodBuilder
);

Parameters

mdBuilder
A MethodBuilder object that represents the method used to unsubscribe to this event.

See Also

EventBuilder Class | EventBuilder Members | System.Reflection.Emit Namespace


EventToken Structure

The EventToken class is an opaque representation of the Token returned by the MetaData to represent an event.

Object
ValueType
EventToken

[Visual Basic]
Public Structure EventToken
[C#]
public struct EventToken
[C++]
public __value struct EventToken

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

EventToken Members | System.Reflection.Emit Namespace


EventToken Members

Public:

Properties

Token Retrieves the metadata token for this event.

Methods

Equals | Checks if the given object is an instance of EventToken and is equal to this instance.
GetHashCode | Generates the hash code for this event.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Fields

Empty The default EventToken with Token value 0.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EventToken Structure | System.Reflection.Emit Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EventToken Properties

The properties of the EventToken structure are listed below. For a complete list of EventToken structure members, see the EventToken Members topic.

Public:

Token Retrieves the metadata token for this event.

See Also

EventToken Structure | System.Reflection.Emit Namespace


EventToken.Token

Retrieves the metadata token for this event.

[Visual Basic]
Public ReadOnly Property Token As Integer
[C#]
public int Token {get;}
[C++]
public: __property int get_Token();
[JScript]
public function get Token() : int;

Property Value

Read-only. Retrieves the metadata token for this event.

See Also

EventToken Structure | EventToken Members | System.Reflection.Emit Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EventToken Methods

The methods of the EventToken structure are listed below. For a complete list of EventToken structure members, see the EventToken Members topic.

Public:

Equals | Checks if the given object is an instance of EventToken and is equal to this instance.
GetHashCode | Generates the hash code for this event.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EventToken Structure | System.Reflection.Emit Namespace


EventToken.Equals

Checks if the given object is an instance of EventToken and is equal to this instance.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The object to be compared with this instance.

Return Value

Returns true if obj is an instance of EventToken and equals the current instance, false otherwise.

See Also

EventToken Structure | EventToken Members | System.Reflection.Emit Namespace


EventToken.GetHashCode

Generates the hash code for this event.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

Returns the hash code for this instance.

See Also

EventToken Structure | EventToken Members | System.Reflection.Emit Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

EventToken Fields

The fields of the EventToken structure are listed below. For a complete list of EventToken structure members, see the EventToken Members topic.

Public:

Empty The default EventToken with Token value 0.

See Also

EventToken Structure | System.Reflection.Emit Namespace


EventToken.Empty

The default EventToken with Token value 0.

[Visual Basic]
Public Shared ReadOnly Empty As EventToken
[C#]
public static readonly EventToken Empty;
[C++]
public: static readonly EventToken Empty;
[JScript]
public static var Empty : EventToken;

See Also

EventToken Structure | EventToken Members | System.Reflection.Emit Namespace


FieldBuilder Class

The FieldBuilder class is used to define and represent a field.

Object
MemberInfo
FieldInfo
FieldBuilder

[Visual Basic]
NotInheritable Public Class FieldBuilder
   Inherits FieldInfo
[C#]
public sealed class FieldBuilder : FieldInfo
[C++]
public __gc __sealed class FieldBuilder : public FieldInfo
[JScript]
public class FieldBuilder extends FieldInfo

Remarks

This class can not be extended. The constructor is private so an instance can only be created internally.

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

FieldBuilder Members | System.Reflection.Emit Namespace


FieldBuilder Members

Public:

Properties

Attributes | Retrieves the attributes of this field.
DeclaringType | Retrieves a reference to the Type object for the type that declares this field.
FieldHandle | Retrieves the internal metadata handle for this field.
FieldType | Retrieves the Type object that represents the type of this field.
IsAssembly (inherited from FieldInfo) | Indicates whether this field has Assembly level visibility.
IsFamily (inherited from FieldInfo) | Indicates whether this field has Family level visibility.
IsFamilyAndAssembly (inherited from FieldInfo) | Indicates whether this field has FamilyANDAssembly level visibility.
IsFamilyOrAssembly (inherited from FieldInfo) | Indicates whether this field has FamilyORAssembly level visibility.
IsInitOnly (inherited from FieldInfo) | Indicates whether the field can only be set in the body of the constructor.
IsLiteral (inherited from FieldInfo) | Indicates whether the value is written at compile time and cannot be changed.
IsNotSerialized (inherited from FieldInfo) | Indicates whether this field has the NotSerialized attribute.
IsPinvokeImpl (inherited from FieldInfo) | Indicates whether the corresponding PinvokeImpl attribute is set in FieldAttributes.
IsPrivate (inherited from FieldInfo) | Retrieves a value indicating whether the field is private.
IsPublic (inherited from FieldInfo) | Indicates whether the field is public.
IsSpecialName (inherited from FieldInfo) | Indicates whether the corresponding SpecialName attribute is set in the FieldAttributes enumerator.
IsStatic (inherited from FieldInfo) | Indicates whether the field is static.
MemberType (inherited from FieldInfo) | Retrieves the Type of property reflected by this FieldInfo object. The retrieved value indicates that this member is a field.
Name | Retrieves the name of this field.
ReflectedType | Retrieves the reference to the Type object from which this object was obtained.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCustomAttributes | Overloaded. Overloaded. Returns the custom attributes defined for this constructor.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetToken | Returns the token representing this field.
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | Retrieves the value of the field supported by the given object.
GetValueDirect (inherited from FieldInfo) | [To be supplied.]
IsDefined | [To be supplied.]
SetConstant | Sets the default value of this field.
SetCustomAttribute | Overloaded. Sets a custom attribute.
SetMarshal | Describes the native marshaling of the field.
SetOffset | Specifies the field layout.
SetValue | Overloaded. [To be supplied.]
SetValueDirect (inherited from FieldInfo) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldBuilder Class | System.Reflection.Emit Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

FieldBuilder Properties

The properties of the FieldBuilder class are listed below. For a complete list of FieldBuilder class members, see the FieldBuilder Members topic.

Public:

Attributes | Retrieves the attributes of this field.
DeclaringType | Retrieves a reference to the Type object for the type that declares this field.
FieldHandle | Retrieves the internal metadata handle for this field.
FieldType | Retrieves the Type object that represents the type of this field.
IsAssembly (inherited from FieldInfo) | Indicates whether this field has Assembly level visibility.
IsFamily (inherited from FieldInfo) | Indicates whether this field has Family level visibility.
IsFamilyAndAssembly (inherited from FieldInfo) | Indicates whether this field has FamilyANDAssembly level visibility.
IsFamilyOrAssembly (inherited from FieldInfo) | Indicates whether this field has FamilyORAssembly level visibility.
IsInitOnly (inherited from FieldInfo) | Indicates whether the field can only be set in the body of the constructor.
IsLiteral (inherited from FieldInfo) | Indicates whether the value is written at compile time and cannot be changed.
IsNotSerialized (inherited from FieldInfo) | Indicates whether this field has the NotSerialized attribute.
IsPinvokeImpl (inherited from FieldInfo) | Indicates whether the corresponding PinvokeImpl attribute is set in FieldAttributes.
IsPrivate (inherited from FieldInfo) | Retrieves a value indicating whether the field is private.
IsPublic (inherited from FieldInfo) | Indicates whether the field is public.
IsSpecialName (inherited from FieldInfo) | Indicates whether the corresponding SpecialName attribute is set in the FieldAttributes enumerator.
IsStatic (inherited from FieldInfo) | Indicates whether the field is static.
MemberType (inherited from FieldInfo) | Retrieves the Type of property reflected by this FieldInfo object. The retrieved value indicates that this member is a field.
Name | Retrieves the name of this field.
ReflectedType | Retrieves the reference to the Type object from which this object was obtained.

See Also

FieldBuilder Class | System.Reflection.Emit Namespace


FieldBuilder.Attributes

Retrieves the attributes of this field.

[Visual Basic]
Overridable Public ReadOnly Property Attributes As FieldAttributes
[C#]
public FieldAttributes Attributes {override get;}
[C++]
public: __property virtual FieldAttributes get_Attributes();
[JScript]
public function get Attributes() : FieldAttributes;

Property Value

Read-only. Retrieves the attributes of this field.

See Also

FieldBuilder Class | FieldBuilder Members | System.Reflection.Emit Namespace


FieldBuilder.DeclaringType

Retrieves a reference to the Type object for the type that declares this field.

[Visual Basic]
Overridable Public ReadOnly Property DeclaringType As Type
[C#]
public Type DeclaringType {override get;}
[C++]
public: __property virtual Type* get_DeclaringType();
[JScript]
public function get DeclaringType() : Type;

Property Value

Read-only. Retrieves a reference to the Type object for the type that declares this field.

See Also

FieldBuilder Class | FieldBuilder Members | System.Reflection.Emit Namespace


FieldBuilder.FieldHandle

Retrieves the internal metadata handle for this field.

[Visual Basic]
Overridable Public ReadOnly Property FieldHandle As _
   RuntimeFieldHandle
[C#]
public RuntimeFieldHandle FieldHandle {override get;}
[C++]
public: __property virtual RuntimeFieldHandle get_FieldHandle();
[JScript]
public function get FieldHandle() : RuntimeFieldHandle;

Property Value

Read-only. The internal metadata handle for this field.

See Also

FieldBuilder Class | FieldBuilder Members | System.Reflection.Emit Namespace


FieldBuilder.FieldType

Retrieves the Type object that represents the type of this field.

[Visual Basic]
Overridable Public ReadOnly Property FieldType As Type
[C#]
public Type FieldType {override get;}
[C++]
public: __property virtual Type* get_FieldType();
[JScript]
public function get FieldType() : Type;

Property Value

Read-only. Retrieves the Type object that represents the type of this field.

See Also

FieldBuilder Class | FieldBuilder Members | System.Reflection.Emit Namespace


FieldBuilder.Name

Retrieves the name of this field.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {override get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

Property Value

Read-only. Retrieves the name of this field.

See Also

FieldBuilder Class | FieldBuilder Members | System.Reflection.Emit Namespace


FieldBuilder.ReflectedType

Retrieves the reference to the Type object from which this object was obtained.

[Visual Basic]
Overridable Public ReadOnly Property ReflectedType As Type
[C#]
public Type ReflectedType {override get;}
[C++]
public: __property virtual Type* get_ReflectedType();
[JScript]
public function get ReflectedType() : Type;

Property Value

Read-only. Retrieves the reference to the Type object from which this instance was obtained.

Remarks

A FieldBuilder object represents a field of a particular class. In order to obtain a FieldBuilder object, the Type object that represents the class that supports the field is queried. This property holds a reference to that Type object.

See Also

FieldBuilder Class | FieldBuilder Members | System.Reflection.Emit Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

FieldBuilder Methods

The methods of the FieldBuilder class are listed below. For a complete list of FieldBuilder class members, see the FieldBuilder Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetCustomAttributes | Overloaded. Overloaded. Returns the custom attributes defined for this constructor.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetToken | Returns the token representing this field.
GetType (inherited from Object) | Gets the Type of the Object.
GetValue | Retrieves the value of the field supported by the given object.
GetValueDirect (inherited from FieldInfo) | [To be supplied.]
IsDefined | [To be supplied.]
SetConstant | Sets the default value of this field.
SetCustomAttribute | Overloaded. Sets a custom attribute.
SetMarshal | Describes the native marshaling of the field.
SetOffset | Specifies the field layout.
SetValue | Overloaded. [To be supplied.]
SetValueDirect (inherited from FieldInfo) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldBuilder Class | System.Reflection.Emit Namespace


FieldBuilder.GetCustomAttributes

Overloaded. Returns the custom attributes defined for this constructor.

Overload List

Returns all the custom attributes defined for this constructor.

[Visual Basic] Overloads Overrides Public Function GetCustomAttributes() As Object ()
[C#] public override object[] GetCustomAttributes();
[C++] public: override Object* GetCustomAttributes() [];
[JScript] public override function GetCustomAttributes() : Object[];

Returns the custom attributes identified by the given type.

[Visual Basic] Overloads Overrides Public Function GetCustomAttributes(Type) As Object ()
[C#] public override object[] GetCustomAttributes(Type);
[C++] public: override Object* GetCustomAttributes(Type*) [];
[JScript] public override function GetCustomAttributes(Type) : Object[];

See Also

FieldBuilder Class | FieldBuilder Members | System.Reflection.Emit Namespace


FieldBuilder.GetCustomAttributes ()

Returns all the custom attributes defined for this constructor.

[Visual Basic]
Overloads Overrides Public Function GetCustomAttributes() As Object ()
[C#]
public override object[] GetCustomAttributes();
[C++]
public: override Object* GetCustomAttributes() [];
[JScript]
public override function GetCustomAttributes() : Object[];

Return Value

Returns an array of objects representing all the custom attributes of the constructor represented by this ConstructorBuilder instance.

See Also

FieldBuilder Class | FieldBuilder Members | System.Reflection.Emit Namespace | FieldBuilder.GetCustomAttributes Overload List


FieldBuilder.GetCustomAttributes (Type)

Returns the custom attributes identified by the given type.

[Visual Basic]
Overloads Overrides Public Function GetCustomAttributes( _
   ByVal attributeType As Type _
) As Object ()
[C#]
public override object[] GetCustomAttributes(
   Type attributeType
);
[C++]
public: override Object* GetCustomAttributes(
   Type* attributeType
) [];
[JScript]
public override function GetCustomAttributes(
   attributeType : Type
) : Object[];

Parameters

attributeType
The custom attribute type.

Return Value

Returns an array of objects representing the attributes of this constructor that are of Type attributeType.

See Also

FieldBuilder Class | FieldBuilder Members | System.Reflection.Emit Namespace | FieldBuilder.GetCustomAttributes Overload List


FieldBuilder.GetToken

Returns the token representing this field.

[Visual Basic]
Public Function GetToken() As FieldToken
[C#]
public FieldToken GetToken();
[C++]
public: FieldToken GetToken();
[JScript]
public function GetToken() : FieldToken;

Return Value

Returns the FieldToken object that represents the token for this field.

See Also

FieldBuilder Class | FieldBuilder Members | System.Reflection.Emit Namespace


FieldBuilder.GetValue

Retrieves the value of the field supported by the given object.

[Visual Basic]
Overrides Public Function GetValue( _
   ByVal obj As Object _
) As Object
[C#]
public override object GetValue(
   object obj
);
[C++]
public: override Object* GetValue(
   Object* obj
);
[JScript]
public override function GetValue(
   obj : Object
) : Object;

Parameters

obj
The object on which to access the field.

Return Value

Returns a Variant containing the value of the field reflected by this instance.

Exceptions

Exception Type | Condition
NotSupportedException | . This method is not supported in this preliminary release of the NGWS SDK.

Remarks

If the field is static, the obj parameter is ignored. For non-static fields, obj should be an instance of a class that inherits or declares the field.

The return type of GetValue is Variant. For example, if the field holds a Boolean primitive value, an instance of Variant with the appropriate Boolean value is returned. Before returning the value, GetValue checks to see if the user has access permission.

Access restrictions are ignored for fully trusted code. Private constructors, methods, fields, and properties can be accessed and invoked via Reflection whenever the code is fully trusted.

See Also

FieldBuilder Class | FieldBuilder Members | System.Reflection.Emit Namespace


FieldBuilder.IsDefined

[To be supplied.]

[Visual Basic]
Overrides Public Function IsDefined( _
   ByVal attributeType As Type _
) As Boolean
[C#]
public override bool IsDefined(
   Type attributeType
);
[C++]
public: override bool IsDefined(
   Type* attributeType
);
[JScript]
public override function IsDefined(
   attributeType : Type
) : Boolean;

Parameters

attributeType
[To be supplied.]

See Also

FieldBuilder Class | FieldBuilder Members | System.Reflection.Emit Namespace


FieldBuilder.SetConstant

Sets the default value of this field.

[Visual Basic]
Public Sub SetConstant( _
   ByVal defaultValue As Object _
)
[C#]
public void SetConstant(
   object defaultValue
);
[C++]
public: void SetConstant(
   Object* defaultValue
);
[JScript]
public function SetConstant(
   defaultValue : Object
);

Parameters

defaultValue
The new default value for this field.

Exceptions

Exception Type | Condition
InvalidOperationException | if the containing type has been created using TypeBuilder.CreateType().

See Also

FieldBuilder Class | FieldBuilder Members | System.Reflection.Emit Namespace


FieldBuilder.SetCustomAttribute

Sets a custom attribute.

Overload List

Set a custom attribute using a specified custom attribute blob.

[Visual Basic] Overloads Public Sub SetCustomAttribute(ConstructorInfo, Byte())
[C#] public void SetCustomAttribute(ConstructorInfo, byte[]);
[C++] public: void SetCustomAttribute(ConstructorInfo*, unsigned char[]);
[JScript] public function SetCustomAttribute(ConstructorInfo, Byte[]);

Set a custom attribute using a custom attribute builder.

[Visual Basic] Overloads Public Sub SetCustomAttribute(CustomAttributeBuilder)
[C#] public void SetCustomAttribute(CustomAttributeBuilder);
[C++] public: void SetCustomAttribute(CustomAttributeBuilder*);
[JScript] public function SetCustomAttribute(CustomAttributeBuilder);

See Also

FieldBuilder Class | FieldBuilder Members | System.Reflection.Emit Namespace


FieldBuilder.SetCustomAttribute (ConstructorInfo, Byte[])

Set a custom attribute using a specified custom attribute blob.

[Visual Basic]
Overloads Public Sub SetCustomAttribute( _
   ByVal con As ConstructorInfo, _
   ByVal binaryAttribute() As Byte _
)
[C#]
public void SetCustomAttribute(
   ConstructorInfo con,
   byte[] binaryAttribute
);
[C++]
public: void SetCustomAttribute(
   ConstructorInfo* con,
   unsigned char* binaryAttribute[]
);
[JScript]
public function SetCustomAttribute(
   con : ConstructorInfo,
   binaryAttribute : Byte[]
);

Parameters

con
The constructor for the custom attribute.
binaryAttribute
A byte blob representing the attributes.

Exceptions

Exception Type | Condition
ArgumentNullException | if con or binaryAttribute is a null reference (in Visual Basic Nothing)

Remarks

See the for details on how to format binaryAttribute.

See Also

FieldBuilder Class | FieldBuilder Members | System.Reflection.Emit Namespace | FieldBuilder.SetCustomAttribute Overload List


FieldBuilder.SetCustomAttribute (CustomAttributeBuilder)

Set a custom attribute using a custom attribute builder.

[Visual Basic]
Overloads Public Sub SetCustomAttribute( _
   ByVal customBuilder As CustomAttributeBuilder _
)
[C#]
public void SetCustomAttribute(
   CustomAttributeBuilder customBuilder
);
[C++]
public: void SetCustomAttribute(
   CustomAttributeBuilder* customBuilder
);
[JScript]
public function SetCustomAttribute(
   customBuilder : CustomAttributeBuilder
);

Parameters

customBuilder
An instance of a helper class to define the custom attribute.

Exceptions

Exception Type | Condition
ArgumentNullException | if con is a null reference (in Visual Basic Nothing)

See Also

FieldBuilder Class | FieldBuilder Members | System.Reflection.Emit Namespace | FieldBuilder.SetCustomAttribute Overload List


FieldBuilder.SetMarshal

Describes the native marshaling of the field.

[Visual Basic]
Public Sub SetMarshal( _
   ByVal unmanagedMarshal As UnmanagedMarshal _
)
[C#]
public void SetMarshal(
   UnmanagedMarshal unmanagedMarshal
);
[C++]
public: void SetMarshal(
   UnmanagedMarshal* unmanagedMarshal
);
[JScript]
public function SetMarshal(
   unmanagedMarshal : UnmanagedMarshal
);

Parameters

unmanagedMarshal
A descriptor specifying the native marshalling of this field.

Exceptions

Exception Type | Condition
InvalidOperationException | if the containing type has been created using TypeBuilder.CreateType().

See Also

FieldBuilder Class | FieldBuilder Members | System.Reflection.Emit Namespace


FieldBuilder.SetOffset

Specifies the field layout.

[Visual Basic]
Public Sub SetOffset( _
   ByVal iOffset As Integer _
)
[C#]
public void SetOffset(
   int iOffset
);
[C++]
public: void SetOffset(
   int iOffset
);
[JScript]
public function SetOffset(
   iOffset : int
);

Parameters

iOffset
The offset of the field within the type containing this field.

Exceptions

Exception Type | Condition
InvalidOperationException | if the containing type has been created using TypeBuilder.CreateType().

See Also

FieldBuilder Class | FieldBuilder Members | System.Reflection.Emit Namespace


FieldBuilder.SetValue

Sets the value of the field supported by the given object.

[Visual Basic]
Overrides Public Sub SetValue( _
   ByVal obj As Object, _
   ByVal val As Object, _
   ByVal invokeAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal culture As CultureInfo _
)
[C#]
public override void SetValue(
   object obj,
   object val,
   BindingFlags invokeAttr,
   Binder binder,
   CultureInfo culture
);
[C++]
public: override void SetValue(
   Object* obj,
   Object* val,
   BindingFlags invokeAttr,
   Binder* binder,
   CultureInfo* culture
);
[JScript]
public override function SetValue(
   obj : Object,
   val : Object,
   invokeAttr : BindingFlags,
   binder : Binder,
   culture : CultureInfo
);

Parameters

obj
The object on which to access the field.
val
The value to assign to the field.
invokeAttr
A member of IBinder that specifies the type of binding that is desired (for example, IBinder.CreateInstance, IBinder.ExactBinding).
binder
A set of properties and enabling for binding, coercion of argument types, and invocation of members via reflection. If binder is null, then IBinder.DefaultBinding is used.
culture
The software preferences of a particular culture

Exceptions

Exception Type | Condition
NotSupportedException | . This method is not supported in this preliminary release of the NGWS SDK.

Remarks

This method will assign the val parameter to the field reflected by this instance on object obj. If the field is static, obj will be ignored. For non-static fields, obj should be an instance of a class that inherits or declares the field.

The new value is passed as a Variant. For example, if the field's type is Boolean, an instance of Variant with the appropriate Boolean value is passed. Before setting the value, SetValue checks to see if the user has access permission.

Access restrictions are ignored for fully trusted code. Private constructors, methods, fields, and properties can be accessed and invoked via Reflection whenever the code is fully trusted.

See Also

FieldBuilder Class | FieldBuilder Members | System.Reflection.Emit Namespace


FieldToken Structure

The FieldToken class is an object representation of a token that represents a field.

Object
ValueType
FieldToken

[Visual Basic]
Public Structure FieldToken
[C#]
public struct FieldToken
[C++]
public __value struct FieldToken

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

FieldToken Members | System.Reflection.Emit Namespace


FieldToken Members

Public:

Properties

Token Retrieves the metadata token for this field.

Methods

Equals | Determines if an object is an instance of FieldToken and is equal to this instance.
GetHashCode | Generates the hash code for this field.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Fields

Empty The default FieldToken with Token value 0.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldToken Structure | System.Reflection.Emit Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

FieldToken Properties

The properties of the FieldToken structure are listed below. For a complete list of FieldToken structure members, see the FieldToken Members topic.

Public:

Token Retrieves the metadata token for this field.

See Also

FieldToken Structure | System.Reflection.Emit Namespace


FieldToken.Token

Retrieves the metadata token for this field.

[Visual Basic]
Public ReadOnly Property Token As Integer
[C#]
public int Token {get;}
[C++]
public: __property int get_Token();
[JScript]
public function get Token() : int;

Property Value

Read-only. Retrieves the metadata token of this field.

See Also

FieldToken Structure | FieldToken Members | System.Reflection.Emit Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

FieldToken Methods

The methods of the FieldToken structure are listed below. For a complete list of FieldToken structure members, see the FieldToken Members topic.

Public:

Equals | Determines if an object is an instance of FieldToken and is equal to this instance.
GetHashCode | Generates the hash code for this field.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldToken Structure | System.Reflection.Emit Namespace


FieldToken.Equals

Determines if an object is an instance of FieldToken and is equal to this instance.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The object to compare to this FieldToken.

Return Value

Returns true if obj is an instance of FieldToken and is equal to this object. Otherwise, returns false.

See Also

FieldToken Structure | FieldToken Members | System.Reflection.Emit Namespace


FieldToken.GetHashCode

Generates the hash code for this field.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

Returns the hash code for this instance.

See Also

FieldToken Structure | FieldToken Members | System.Reflection.Emit Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

FieldToken Fields

The fields of the FieldToken structure are listed below. For a complete list of FieldToken structure members, see the FieldToken Members topic.

Public:

Empty The default FieldToken with Token value 0.

See Also

FieldToken Structure | System.Reflection.Emit Namespace


FieldToken.Empty

The default FieldToken with Token value 0.

[Visual Basic]
Public Shared ReadOnly Empty As FieldToken
[C#]
public static readonly FieldToken Empty;
[C++]
public: static readonly FieldToken Empty;
[JScript]
public static var Empty : FieldToken;

See Also

FieldToken Structure | FieldToken Members | System.Reflection.Emit Namespace


FlowControl Enumeration

FlowControl describes how an instruction alters the flow of control.

[Visual Basic]
Public Enum FlowControl
[C#]
public enum FlowControl
[C++]
public enum FlowControl

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Branch | Branch instruction.
Break | Break instruction.
Call | Call instruction.
Cond_Branch | Conditional branch instruction.
Meta | Provides information about a subsequent instruction. For example, the System.Reflection.Emit.Opcodes value Unaligned instruction has FlowControl.Meta and specifies that the subsequent pointer instruction may be unaligned.
Next | Normal flow of control.
Phi | Annotation for ann.phi instruction.
Return | Return instruction.
Throw | Exception throw instruction.

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

System.Reflection.Emit Namespace


ILGenerator Class

The ILGenerator class generates IL instructions.

Object
ILGenerator

[Visual Basic]
Public Class ILGenerator
[C#]
public class ILGenerator
[C++]
public __gc class ILGenerator
[JScript]
public class ILGenerator

Remarks

Intermediate Language, IL, is input to a JIT compiler.

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

ILGenerator Members | System.Reflection.Emit Namespace


ILGenerator Members

Public:

Methods

BeginCatchBlock | Begins a catch block. Emits a branch instruction to the end of the current exception block.
BeginExceptFilterBlock | Begins an exception block for a filtered exception.
BeginExceptionBlock | Begins an exception block for a non-filtered exception.
BeginFaultBlock | Begins an exception fault block on the instruction stream.
BeginFinallyBlock | Begins a finally block on the instruction stream.
BeginScope | Begins a lexical scope.
DeclareLocal | Declares a local variable.
DefineLabel | Declares a new Label. This is just a token and does not yet represent any particular location within the stream.
Emit | Overloaded. Puts an instruction onto the instruction stream for the JIT compiler. If the opcode requires an argument, the caller must ensure that the argument length matches the length of the declared parameter. Otherwise, results will be unpredictable. For example, if the Emit instruction requires a 2-byte operand and the caller supplies a 4-byte operand, the runtime will emit two additional bytes to the instruction stream. These extra bytes will be Opcodes.Nop instructions.
EmitCall | Puts a call or callvirt instruction onto the IL stream.
EmitCalli | Puts a calli instruction onto the IL stream.
EmitWriteLine | Overloaded. [To be supplied.]
EndExceptionBlock | Ends an exception block.
EndScope | Ends a lexical scope.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
MarkLabel | Defines a label by setting the position where that label is found within the stream.
MarkSequencePoint | Marks a sequence point in the instruction stream.
ThrowException | Emits an instruction to throw an exception.
ToString (inherited from Object) | Returns a String that represents the current Object.
UsingNamespace | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ILGenerator Class | System.Reflection.Emit Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ILGenerator Methods

The methods of the ILGenerator class are listed below. For a complete list of ILGenerator class members, see the ILGenerator Members topic.

Public:

BeginCatchBlock | Begins a catch block. Emits a branch instruction to the end of the current exception block.
BeginExceptFilterBlock | Begins an exception block for a filtered exception.
BeginExceptionBlock | Begins an exception block for a non-filtered exception.
BeginFaultBlock | Begins an exception fault block on the instruction stream.
BeginFinallyBlock | Begins a finally block on the instruction stream.
BeginScope | Begins a lexical scope.
DeclareLocal | Declares a local variable.
DefineLabel | Declares a new Label. This is just a token and does not yet represent any particular location within the stream.
Emit | Overloaded. Puts an instruction onto the instruction stream for the JIT compiler. If the opcode requires an argument, the caller must ensure that the argument length matches the length of the declared parameter. Otherwise, results will be unpredictable. For example, if the Emit instruction requires a 2-byte operand and the caller supplies a 4-byte operand, the runtime will emit two additional bytes to the instruction stream. These extra bytes will be Opcodes.Nop instructions.
EmitCall | Puts a call or callvirt instruction onto the IL stream.
EmitCalli | Puts a calli instruction onto the IL stream.
EmitWriteLine | Overloaded. [To be supplied.]
EndExceptionBlock | Ends an exception block.
EndScope | Ends a lexical scope.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
MarkLabel | Defines a label by setting the position where that label is found within the stream.
MarkSequencePoint | Marks a sequence point in the instruction stream.
ThrowException | Emits an instruction to throw an exception.
ToString (inherited from Object) | Returns a String that represents the current Object.
UsingNamespace | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ILGenerator Class | System.Reflection.Emit Namespace


ILGenerator.BeginCatchBlock

Begins a catch block. Emits a branch instruction to the end of the current exception block.

[Visual Basic]
Overridable Public Sub BeginCatchBlock( _
   ByVal exceptionType As Type _
)
[C#]
public virtual void BeginCatchBlock(
   Type exceptionType
);
[C++]
public: virtual void BeginCatchBlock(
   Type* exceptionType
);
[JScript]
public function BeginCatchBlock(
   exceptionType : Type
);

Parameters

exceptionType
The Type object that represents the exception.

Exceptions

Exception Type | Condition
ArgumentException | if exceptionType is not a subclass of the Exception class or if the catch block is within a filtered exception
ArgumentNullException | if exceptionType is a null reference (in Visual Basic Nothing)
NotSupportedException | the IL being generated is not currently in an exception block.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace


ILGenerator.BeginExceptFilterBlock

Begins an exception block for a filtered exception.

[Visual Basic]
Overridable Public Sub BeginExceptFilterBlock()
[C#]
public virtual void BeginExceptFilterBlock();
[C++]
public: virtual void BeginExceptFilterBlock();
[JScript]
public function BeginExceptFilterBlock();

Exceptions

Exception Type | Condition
NotSupportedException | if the IL being generated is not currently in an exception block.

Remarks

Emits a branch instruction to the end of the current exception block.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace


ILGenerator.BeginExceptionBlock

Begins an exception block for a non-filtered exception.

[Visual Basic]
Overridable Public Function BeginExceptionBlock() As Label
[C#]
public virtual Label BeginExceptionBlock();
[C++]
public: virtual Label BeginExceptionBlock();
[JScript]
public function BeginExceptionBlock() : Label;

Return Value

The label for the end of the block. This will leave you in the correct place to execute finally blocks or to finish the try.

Remarks

Creating an exception block records some information, but does not actually emit any IL onto the stream.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace


ILGenerator.BeginFaultBlock

Begins an exception fault block on the instruction stream.

[Visual Basic]
Overridable Public Sub BeginFaultBlock()
[C#]
public virtual void BeginFaultBlock();
[C++]
public: virtual void BeginFaultBlock();
[JScript]
public function BeginFaultBlock();

Exceptions

Exception Type | Condition
NotSupportedException | the IL being generated is not currently in an exception block.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace


ILGenerator.BeginFinallyBlock

Begins a finally block on the instruction stream.

[Visual Basic]
Overridable Public Sub BeginFinallyBlock()
[C#]
public virtual void BeginFinallyBlock();
[C++]
public: virtual void BeginFinallyBlock();
[JScript]
public function BeginFinallyBlock();

Exceptions

Exception Type | Condition
NotSupportedException | if the IL being generated is not currently in an exception block.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace


ILGenerator.BeginScope

Begins a lexical scope.

[Visual Basic]
Overridable Public Sub BeginScope()
[C#]
public virtual void BeginScope();
[C++]
public: virtual void BeginScope();
[JScript]
public function BeginScope();

Remarks

This method is used to emit symbolic information.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace


ILGenerator.DeclareLocal

Declares a local variable.

[Visual Basic]
Public Function DeclareLocal( _
   ByVal localType As Type _
) As LocalBuilder
[C#]
public LocalBuilder DeclareLocal(
   Type localType
);
[C++]
public: LocalBuilder* DeclareLocal(
   Type* localType
);
[JScript]
public function DeclareLocal(
   localType : Type
) : LocalBuilder;

Parameters

localType
The Type of the local variable.

Return Value

The declared local variable.

Exceptions

Exception Type | Condition
ArgumentNullException | if localType is a null reference (in Visual Basic Nothing)
InvalidOperationException | if the containing type has been created with CreateType.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace


ILGenerator.DefineLabel

Declares a new Label. This is just a token and does not yet represent any particular location within the stream.

[Visual Basic]
Overridable Public Function DefineLabel() As Label
[C#]
public virtual Label DefineLabel();
[C++]
public: virtual Label DefineLabel();
[JScript]
public function DefineLabel() : Label;

Return Value

Returns a new label that can be used as a token for branching.

Remarks

In order to set the position of the label within the stream, you must call MarkLabel.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace


ILGenerator.Emit

Puts an instruction onto the instruction stream for the JIT compiler. If the opcode requires an argument, the caller must ensure that the argument length matches the length of the declared parameter. Otherwise, results will be unpredictable. For example, if the Emit instruction requires a 2-byte operand and the caller supplies a 4-byte operand, the runtime will emit two additional bytes to the instruction stream. These extra bytes will be Opcodes.Nop instructions.

Overload List

Puts the specified instruction onto the stream and leaves space to include a Label when fixes are done.

Emits a switch table.

[Visual Basic] Overloads Overridable Public Sub Emit(OpCode, Label())
[C#] public virtual void Emit(OpCode, Label[]);
[C++] public: virtual void Emit(OpCode, Label[]);
[JScript] public function Emit(OpCode, Label[]);

Puts the specified instruction and metadata token for the specified field onto the stream of instructions.

[Visual Basic] Overloads Overridable Public Sub Emit(OpCode, FieldInfo)
[C#] public virtual void Emit(OpCode, FieldInfo);
[C++] public: virtual void Emit(OpCode, FieldInfo);
[JScript] public function Emit(OpCode, FieldInfo);

Puts the specified instruction onto the IL stream followed by the metadata token for the given string.

[Visual Basic] Overloads Overridable Public Sub Emit(OpCode, String)
[C#] public virtual void Emit(OpCode, String);
[C++] public: virtual void Emit(OpCode, String);
[JScript] public function Emit(OpCode, String);

Puts the specified instruction onto the stream and leaves space to include a Label when fixes are done.

[Visual Basic] Overloads Overridable Public Sub Emit(OpCode, Label)
[C#] public virtual void Emit(OpCode, Label);
[C++] public: virtual void Emit(OpCode, Label);
[JScript] public function Emit(OpCode, Label);

Puts the specified instruction and numerical argument onto the stream of instructions.

[Visual Basic] Overloads Overridable Public Sub Emit(OpCode, Integer)
[C#] public virtual void Emit(OpCode, short);
[C++] public: virtual void Emit(OpCode, short);
[JScript] public function Emit(OpCode, Int16);

Puts the specified instruction and numerical argument onto the stream of instructions.

[Visual Basic] Overloads Overridable Public Sub Emit(OpCode, Integer)
[C#] public virtual void Emit(OpCode, int);
[C++] public: virtual void Emit(OpCode, int);
[JScript] public function Emit(OpCode, int);

Puts the specified instruction onto the IL stream followed by the metadata token for the given method.

[Visual Basic] Overloads Overridable Public Sub Emit(OpCode, MethodInfo)
[C#] public virtual void Emit(OpCode, MethodInfo);
[C++] public: virtual void Emit(OpCode, MethodInfo);
[JScript] public function Emit(OpCode, MethodInfo);

Puts the specified instruction and character argument onto the stream of instructions.

[Visual Basic] Overloads Public Sub Emit(OpCode, SByte)
[C#] public void Emit(OpCode, sbyte);
[C++] public: void Emit(OpCode, char);
[JScript] public function Emit(OpCode, SByte);

Puts the specified instruction onto the stream of instructions.

[Visual Basic] Overloads Overridable Public Sub Emit(OpCode)
[C#] public virtual void Emit(OpCode);
[C++] public: virtual void Emit(OpCode);
[JScript] public function Emit(OpCode);

Puts the specified instruction and character argument onto the stream of instructions.

[Visual Basic] Overloads Overridable Public Sub Emit(OpCode, Byte)
[C#] public virtual void Emit(OpCode, byte);
[C++] public: virtual void Emit(OpCode, unsigned char);
[JScript] public function Emit(OpCode, Byte);

Puts the specified instruction and numerical argument onto the stream of instructions.

[Visual Basic] Overloads Overridable Public Sub Emit(OpCode, Long)
[C#] public virtual void Emit(OpCode, long);
[C++] public: virtual void Emit(OpCode, __int64);
[JScript] public function Emit(OpCode, long);

Puts the specified instruction and numerical argument onto the stream of instructions.

[Visual Basic] Overloads Overridable Public Sub Emit(OpCode, Single)
[C#] public virtual void Emit(OpCode, float);
[C++] public: virtual void Emit(OpCode, float);
[JScript] public function Emit(OpCode, float);

Puts the specified instruction and numerical argument onto the stream of instructions.

[Visual Basic] Overloads Overridable Public Sub Emit(OpCode, Double)
[C#] public virtual void Emit(OpCode, double);
[C++] public: virtual void Emit(OpCode, double);
[JScript] public function Emit(OpCode, double);

Puts the specified instruction and a signature token onto the stream of instructions.

[Visual Basic] Overloads Overridable Public Sub Emit(OpCode, SignatureHelper)
[C#] public virtual void Emit(OpCode, SignatureHelper);
[C++] public: virtual void Emit(OpCode, SignatureHelper);
[JScript] public function Emit(OpCode, SignatureHelper);

Puts the specified instruction and metadata token for the specified constructor onto the stream of instructions.

[Visual Basic] Overloads Overridable Public Sub Emit(OpCode, ConstructorInfo)
[C#] public virtual void Emit(OpCode, ConstructorInfo);
[C++] public: virtual void Emit(OpCode, ConstructorInfo);
[JScript] public function Emit(OpCode, ConstructorInfo);

Puts the specified instruction onto the IL stream followed by the metadata token for the given type.

[Visual Basic] Overloads Overridable Public Sub Emit(OpCode, Type)
[C#] public virtual void Emit(OpCode, Type);
[C++] public: virtual void Emit(OpCode, Type);
[JScript] public function Emit(OpCode, Type);

Puts the specified instruction onto the IL stream followed by the metadata token for the given local variable.

[Visual Basic] Overloads Overridable Public Sub Emit(OpCode, LocalBuilder)
[C#] public virtual void Emit(OpCode, LocalBuilder);
[C++] public: virtual void Emit(OpCode, LocalBuilder);
[JScript] public function Emit(OpCode, LocalBuilder);

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace


ILGenerator.Emit (OpCode, Label[])

Puts the specified instruction onto the stream and leaves space to include a Label when fixes are done.

Emits a switch table.

[Visual Basic]
Overloads Overridable Public Sub Emit( _
   ByVal opcode As OpCode, _
   ByVal labels() As Label _
)
[C#]
public virtual void Emit(
   OpCode opcode,
   Label[] labels
);
[C++]
public: virtual void Emit(
   OpCode opcode,
   Label* labels[]
);
[JScript]
public function Emit(
   opcode : OpCode,
   labels : Label[]
);

Parameters

opcode
The IL instruction to be emitted onto the stream.
labels
The array of Label objects to which to branch from this location. All of the labels will be used.

Remarks

The instruction values are defined in the OpCodes enumeration.

Labels are created using ILGenerator.CreateLabel and their location within the stream is fixed by using ILGenerator.MarkLabel. If a single-byte instruction is used, the label can represent a jump of at most 127 bytes along the stream. instruction must represent a branch instruction. Since branches are relative instructions, label will be replaced with the correct offset to branch during the fixup process.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace | ILGenerator.Emit Overload List


ILGenerator.Emit (OpCode, FieldInfo)

Puts the specified instruction and metadata token for the specified field onto the stream of instructions.

[Visual Basic]
Overloads Overridable Public Sub Emit( _
   ByVal opcode As OpCode, _
   ByVal field As FieldInfo _
)
[C#]
public virtual void Emit(
   OpCode opcode,
   FieldInfo field
);
[C++]
public: virtual void Emit(
   OpCode opcode,
   FieldInfo* field
);
[JScript]
public function Emit(
   opcode : OpCode,
   field : FieldInfo
);

Parameters

opcode
The IL instruction to be emitted onto the stream.
field
A FieldInfo representing a field.

Remarks

The instruction values are defined in the OpCodes enumeration. The location of field is recorded so that the instruction stream can be patched if necessary when persisting the module to a PE.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace | ILGenerator.Emit Overload List


ILGenerator.Emit (OpCode, String)

Puts the specified instruction onto the IL stream followed by the metadata token for the given string.

[Visual Basic]
Overloads Overridable Public Sub Emit( _
   ByVal opcode As OpCode, _
   ByVal str As String _
)
[C#]
public virtual void Emit(
   OpCode opcode,
   string str
);
[C++]
public: virtual void Emit(
   OpCode opcode,
   String* str
);
[JScript]
public function Emit(
   opcode : OpCode,
   str : String
);

Parameters

opcode
The IL instruction to be emitted onto the stream.
str
The String to be emitted.

Remarks

The instruction values are defined in the OpCodes enumeration. The location of str is recorded for future fixups if the module is persisted to a PE.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace | ILGenerator.Emit Overload List


ILGenerator.Emit (OpCode, Label)

Puts the specified instruction onto the stream and leaves space to include a Label when fixes are done.

[Visual Basic]
Overloads Overridable Public Sub Emit( _
   ByVal opcode As OpCode, _
   ByVal label As Label _
)
[C#]
public virtual void Emit(
   OpCode opcode,
   Label label
);
[C++]
public: virtual void Emit(
   OpCode opcode,
   Label label
);
[JScript]
public function Emit(
   opcode : OpCode,
   label : Label
);

Parameters

opcode
The IL instruction to be emitted onto the stream.
label
The Label to which to branch from this location.

Remarks

The instruction values are defined in the OpCodes enumeration.

Labels are created using DefineLabel and their location within the stream is fixed by using MarkLabel. If a single-byte instruction is used, the label can represent a jump of at most 127 bytes along the stream. instruction must represent a branch instruction. Since branches are relative instructions, label will be replaced with the correct offset to branch during the fixup process.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace | ILGenerator.Emit Overload List


ILGenerator.Emit (OpCode, Int16)

Puts the specified instruction and numerical argument onto the stream of instructions.

[Visual Basic]
Overloads Overridable Public Sub Emit( _
   ByVal opcode As OpCode, _
   ByVal arg As Short _
)
[C#]
public virtual void Emit(
   OpCode opcode,
   short arg
);
[C++]
public: virtual void Emit(
   OpCode opcode,
   short arg
);
[JScript]
public function Emit(
   opcode : OpCode,
   arg : Int16
);

Parameters

opcode
The IL instruction to be emitted onto the stream.
arg
The Int argument pushed onto the stream immediately after the instruction.

Remarks

The instruction values are defined in the OpCodes enumeration.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace | ILGenerator.Emit Overload List


ILGenerator.Emit (OpCode, Int32)

Puts the specified instruction and numerical argument onto the stream of instructions.

[Visual Basic]
Overloads Overridable Public Sub Emit( _
   ByVal opcode As OpCode, _
   ByVal arg As Integer _
)
[C#]
public virtual void Emit(
   OpCode opcode,
   int arg
);
[C++]
public: virtual void Emit(
   OpCode opcode,
   int arg
);
[JScript]
public function Emit(
   opcode : OpCode,
   arg : int
);

Parameters

opcode
The IL instruction to be put onto the stream.
arg
The numerical argument pushed onto the stream immediately after the instruction.

Remarks

The instruction values are defined in the OpCodes enumeration.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace | ILGenerator.Emit Overload List


ILGenerator.Emit (OpCode, MethodInfo)

Puts the specified instruction onto the IL stream followed by the metadata token for the given method.

[Visual Basic]
Overloads Overridable Public Sub Emit( _
   ByVal opcode As OpCode, _
   ByVal meth As MethodInfo _
)
[C#]
public virtual void Emit(
   OpCode opcode,
   MethodInfo meth
);
[C++]
public: virtual void Emit(
   OpCode opcode,
   MethodInfo* meth
);
[JScript]
public function Emit(
   opcode : OpCode,
   meth : MethodInfo
);

Parameters

opcode
The IL instruction to be emitted onto the stream.
meth
A MethodInfo representing a method.

Exceptions

Exception Type | Condition
ArgumentNullException | if meth is a null reference (in Visual Basic Nothing)

Remarks

The instruction values are defined in the OpCodes enumeration.

The location of meth is recorded so that the instruction stream can be patched if necessary when persisting the module to a PE.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace | ILGenerator.Emit Overload List


ILGenerator.Emit (OpCode, SByte)

Puts the specified instruction and character argument onto the stream of instructions.

[Visual Basic]
Overloads Public Sub Emit( _
   ByVal opcode As OpCode, _
   ByVal arg As SByte _
)
[C#]
public void Emit(
   OpCode opcode,
   sbyte arg
);
[C++]
public: void Emit(
   OpCode opcode,
   char arg
);
[JScript]
public function Emit(
   opcode : OpCode,
   arg : SByte
);

Parameters

opcode
The IL instruction to be put onto the stream.
arg
The character argument pushed onto the stream immediately after the instruction.

Remarks

The instruction values are defined in the OpCodes enumeration.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace | ILGenerator.Emit Overload List


ILGenerator.Emit (OpCode)

Puts the specified instruction onto the stream of instructions.

[Visual Basic]
Overloads Overridable Public Sub Emit( _
   ByVal opcode As OpCode _
)
[C#]
public virtual void Emit(
   OpCode opcode
);
[C++]
public: virtual void Emit(
   OpCode opcode
);
[JScript]
public function Emit(
   opcode : OpCode
);

Parameters

opcode
The IL instruction to be put onto the stream. Defined in the OpCodes enumeration.

Remarks

The instruction values are defined in the OpCodes enumeration.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace | ILGenerator.Emit Overload List


ILGenerator.Emit (OpCode, Byte)

Puts the specified instruction and character argument onto the stream of instructions.

[Visual Basic]
Overloads Overridable Public Sub Emit( _
   ByVal opcode As OpCode, _
   ByVal arg As Byte _
)
[C#]
public virtual void Emit(
   OpCode opcode,
   byte arg
);
[C++]
public: virtual void Emit(
   OpCode opcode,
   unsigned char arg
);
[JScript]
public function Emit(
   opcode : OpCode,
   arg : Byte
);

Parameters

opcode
The IL instruction to be put onto the stream.
arg
The character argument pushed onto the stream immediately after the instruction.

Remarks

The instruction values are defined in the OpCodes enumeration.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace | ILGenerator.Emit Overload List


ILGenerator.Emit (OpCode, Int64)

Puts the specified instruction and numerical argument onto the stream of instructions.

[Visual Basic]
Overloads Overridable Public Sub Emit( _
   ByVal opcode As OpCode, _
   ByVal arg As Long _
)
[C#]
public virtual void Emit(
   OpCode opcode,
   long arg
);
[C++]
public: virtual void Emit(
   OpCode opcode,
   __int64 arg
);
[JScript]
public function Emit(
   opcode : OpCode,
   arg : long
);

Parameters

opcode
The IL instruction to be put onto the stream.
arg
The numerical argument pushed onto the stream immediately after the instruction.

Remarks

The instruction values are defined in the OpCodes enumeration.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace | ILGenerator.Emit Overload List


ILGenerator.Emit (OpCode, Single)

Puts the specified instruction and numerical argument onto the stream of instructions.

[Visual Basic]
Overloads Overridable Public Sub Emit( _
   ByVal opcode As OpCode, _
   ByVal arg As Single _
)
[C#]
public virtual void Emit(
   OpCode opcode,
   float arg
);
[C++]
public: virtual void Emit(
   OpCode opcode,
   float arg
);
[JScript]
public function Emit(
   opcode : OpCode,
   arg : float
);

Parameters

opcode
The IL instruction to be put onto the stream.
arg
The Single argument pushed onto the stream immediately after the instruction.

Remarks

The instruction values are defined in the OpCodes enumeration.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace | ILGenerator.Emit Overload List


ILGenerator.Emit (OpCode, Double)

Puts the specified instruction and numerical argument onto the stream of instructions.

[Visual Basic]
Overloads Overridable Public Sub Emit( _
   ByVal opcode As OpCode, _
   ByVal arg As Double _
)
[C#]
public virtual void Emit(
   OpCode opcode,
   double arg
);
[C++]
public: virtual void Emit(
   OpCode opcode,
   double arg
);
[JScript]
public function Emit(
   opcode : OpCode,
   arg : double
);

Parameters

opcode
The IL instruction to be put onto the stream. Defined in the OpCodes enumeration.
arg
The numerical argument pushed onto the stream immediately after the instruction.

Remarks

The instruction values are defined in the OpCodes enumeration.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace | ILGenerator.Emit Overload List


ILGenerator.Emit (OpCode, SignatureHelper)

Puts the specified instruction and a signature token onto the stream of instructions.

[Visual Basic]
Overloads Overridable Public Sub Emit( _
   ByVal opcode As OpCode, _
   ByVal signature As SignatureHelper _
)
[C#]
public virtual void Emit(
   OpCode opcode,
   SignatureHelper signature
);
[C++]
public: virtual void Emit(
   OpCode opcode,
   SignatureHelper* signature
);
[JScript]
public function Emit(
   opcode : OpCode,
   signature : SignatureHelper
);

Parameters

opcode
The IL instruction to be emitted onto the stream.
signature
A helper for constructing a signature token.

Exceptions

Exception Type | Condition
ArgumentNullException | if signature is a null reference (in Visual Basic Nothing)

Remarks

The instruction values are defined in the OpCodes enumeration.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace | ILGenerator.Emit Overload List


ILGenerator.Emit (OpCode, ConstructorInfo)

Puts the specified instruction and metadata token for the specified constructor onto the stream of instructions.

[Visual Basic]
Overloads Overridable Public Sub Emit( _
   ByVal opcode As OpCode, _
   ByVal con As ConstructorInfo _
)
[C#]
public virtual void Emit(
   OpCode opcode,
   ConstructorInfo con
);
[C++]
public: virtual void Emit(
   OpCode opcode,
   ConstructorInfo* con
);
[JScript]
public function Emit(
   opcode : OpCode,
   con : ConstructorInfo
);

Parameters

opcode
The IL instruction to be emitted onto the stream.
con
A ConstructorInfo representing a constructor.

Remarks

The instruction values are defined in the OpCodes enumeration.

The location of con is recorded so that the instruction stream can be patched if necessary when persisting the module to a PE.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace | ILGenerator.Emit Overload List


ILGenerator.Emit (OpCode, Type)

Puts the specified instruction onto the IL stream followed by the metadata token for the given type.

[Visual Basic]
Overloads Overridable Public Sub Emit( _
   ByVal opcode As OpCode, _
   ByVal cls As Type _
)
[C#]
public virtual void Emit(
   OpCode opcode,
   Type cls
);
[C++]
public: virtual void Emit(
   OpCode opcode,
   Type* cls
);
[JScript]
public function Emit(
   opcode : OpCode,
   cls : Type
);

Parameters

opcode
The IL instruction to be put onto the stream.
cls
A Type.

Remarks

The instruction values are defined in the OpCodes enumeration. The location of cls is recorded so that the token can be patched if necessary when persisting the module to a PE.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace | ILGenerator.Emit Overload List


ILGenerator.Emit (OpCode, LocalBuilder)

Puts the specified instruction onto the IL stream followed by the metadata token for the given local variable.

[Visual Basic]
Overloads Overridable Public Sub Emit( _
   ByVal opcode As OpCode, _
   ByVal local As LocalBuilder _
)
[C#]
public virtual void Emit(
   OpCode opcode,
   LocalBuilder local
);
[C++]
public: virtual void Emit(
   OpCode opcode,
   LocalBuilder* local
);
[JScript]
public function Emit(
   opcode : OpCode,
   local : LocalBuilder
);

Parameters

opcode
The IL instruction to be emitted onto the stream.
local
A local variable.

Exceptions

Exception Type | Condition
InvalidOperationException | if instruction is a single-byte instruction and local represents a local with an index of greater than Byte.MaxValue.

Remarks

The instruction values are defined in the OpCodes enumeration.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace | ILGenerator.Emit Overload List


ILGenerator.EmitCall

Puts a call or callvirt instruction onto the IL stream.

[Visual Basic]
Public Sub EmitCall( _
   ByVal opcode As OpCode, _
   ByVal methodInfo As MethodInfo, _
   ByVal optionalParameterTypes() As Type _
)
[C#]
public void EmitCall(
   OpCode opcode,
   MethodInfo methodInfo,
   Type[] optionalParameterTypes
);
[C++]
public: void EmitCall(
   OpCode opcode,
   MethodInfo* methodInfo,
   Type* optionalParameterTypes[]
);
[JScript]
public function EmitCall(
   opcode : OpCode,
   methodInfo : MethodInfo,
   optionalParameterTypes : Type[]
);

Parameters

opcode
The IL instruction to be emitted onto the stream.
methodInfo
The method to be called.
optionalParameterTypes
The types of the optional arguments if the method is a varargs method.

Exceptions

Exception Type | Condition
ArgumentNullException | if meth is a null reference (in Visual Basic Nothing)

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace


ILGenerator.EmitCalli

Puts a calli instruction onto the IL stream.

[Visual Basic]
Public Sub EmitCalli( _
   ByVal opcode As OpCode, _
   ByVal callingConvention As CallingConventions, _
   ByVal returnType As Type, _
   ByVal parameterTypes() As Type, _
   ByVal optionalParameterTypes() As Type _
)
[C#]
public void EmitCalli(
   OpCode opcode,
   CallingConventions callingConvention,
   Type returnType,
   Type[] parameterTypes,
   Type[] optionalParameterTypes
);
[C++]
public: void EmitCalli(
   OpCode opcode,
   CallingConventions callingConvention,
   Type* returnType,
   Type* parameterTypes[],
   Type* optionalParameterTypes[]
);
[JScript]
public function EmitCalli(
   opcode : OpCode,
   callingConvention : CallingConventions,
   returnType : Type,
   parameterTypes : Type[],
   optionalParameterTypes : Type[]
);

Parameters

opcode
The IL instruction to be emitted onto the stream.
callingConvention
The calling convention to be used.
returnType
The Type of the result.
parameterTypes
The types of the required arguments to the instruction.
optionalParameterTypes
The types of the optional arguments for vararg calls.

Exceptions

Exception Type | Condition
InvalidOperationException | if optionalParameterTypes is not a null reference (in Visual Basic Nothing) and callingConvention is VarArgs.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace


ILGenerator.EmitWriteLine

[To be supplied.]

Overload List

Emits the IL necessary to call WriteLine with the given local variable.

[Visual Basic] Overloads Overridable Public Sub EmitWriteLine(LocalBuilder)
[C#] public virtual void EmitWriteLine(LocalBuilder);
[C++] public: virtual void EmitWriteLine(LocalBuilder*);
[JScript] public function EmitWriteLine(LocalBuilder);

Emits the IL necessary to call WriteLine with the given field.

[Visual Basic] Overloads Overridable Public Sub EmitWriteLine(FieldInfo)
[C#] public virtual void EmitWriteLine(FieldInfo);
[C++] public: virtual void EmitWriteLine(FieldInfo*);
[JScript] public function EmitWriteLine(FieldInfo);

Emits the IL to call WriteLine with a string.

[Visual Basic] Overloads Overridable Public Sub EmitWriteLine(String)
[C#] public virtual void EmitWriteLine(String);
[C++] public: virtual void EmitWriteLine(String*);
[JScript] public function EmitWriteLine(String);

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace


ILGenerator.EmitWriteLine (LocalBuilder)

Emits the IL necessary to call WriteLine with the given local variable.

[Visual Basic]
Overloads Overridable Public Sub EmitWriteLine( _
   ByVal localBuilder As LocalBuilder _
)
[C#]
public virtual void EmitWriteLine(
   LocalBuilder localBuilder
);
[C++]
public: virtual void EmitWriteLine(
   LocalBuilder* localBuilder
);
[JScript]
public function EmitWriteLine(
   localBuilder : LocalBuilder
);

Parameters

localBuilder
The local variable to be written.

Exceptions

Exception Type | Condition
ArgumentException | if the type of localBuilder is not supported, e.g., TypeBuilder.

Remarks

It is an error to call EmitWriteLine with a LocalBuilder which is not of one of the types for which Console.WriteLine implements overloads. (e.g. you do not call ToString on the locals.)

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace | ILGenerator.EmitWriteLine Overload List


ILGenerator.EmitWriteLine (FieldInfo)

Emits the IL necessary to call WriteLine with the given field.

[Visual Basic]
Overloads Overridable Public Sub EmitWriteLine( _
   ByVal fld As FieldInfo _
)
[C#]
public virtual void EmitWriteLine(
   FieldInfo fld
);
[C++]
public: virtual void EmitWriteLine(
   FieldInfo* fld
);
[JScript]
public function EmitWriteLine(
   fld : FieldInfo
);

Parameters

fld
The field to be written.

Exceptions

Exception Type | Condition
ArgumentNullException | if fld is a null reference (in Visual Basic Nothing)

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace | ILGenerator.EmitWriteLine Overload List


ILGenerator.EmitWriteLine (String)

Emits the IL to call WriteLine with a string.

[Visual Basic]
Overloads Overridable Public Sub EmitWriteLine( _
   ByVal value As String _
)
[C#]
public virtual void EmitWriteLine(
   string value
);
[C++]
public: virtual void EmitWriteLine(
   String* value
);
[JScript]
public function EmitWriteLine(
   value : String
);

Parameters

value
The String to be printed.

Remarks

The String must have already been defined.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace | ILGenerator.EmitWriteLine Overload List


ILGenerator.EndExceptionBlock

Ends an exception block.

[Visual Basic]
Overridable Public Sub EndExceptionBlock()
[C#]
public virtual void EndExceptionBlock();
[C++]
public: virtual void EndExceptionBlock();
[JScript]
public function EndExceptionBlock();

Exceptions

Exception Type | Condition
NotSupportedException | if the IL being generated is not currently in an exception block.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace


ILGenerator.EndScope

Ends a lexical scope.

[Visual Basic]
Overridable Public Sub EndScope()
[C#]
public virtual void EndScope();
[C++]
public: virtual void EndScope();
[JScript]
public function EndScope();

Remarks

This method is used to emit symbolic information.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace


ILGenerator.MarkLabel

Defines a label by setting the position where that label is found within the stream.

[Visual Basic]
Overridable Public Sub MarkLabel( _
   ByVal loc As Label _
)
[C#]
public virtual void MarkLabel(
   Label loc
);
[C++]
public: virtual void MarkLabel(
   Label loc
);
[JScript]
public function MarkLabel(
   loc : Label
);

Parameters

loc
The label for which to set an index.

Exceptions

Exception Type | Condition
ArgumentException | loc represents an invalid index into the label array or if an index for loc has already been defined.

Remarks

A label can not be defined more than once.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace


ILGenerator.MarkSequencePoint

Marks a sequence point in the instruction stream.

[Visual Basic]
Overridable Public Sub MarkSequencePoint( _
   ByVal document As ISymbolDocumentWriter, _
   ByVal startLine As Integer, _
   ByVal startColumn As Integer, _
   ByVal endLine As Integer, _
   ByVal endColumn As Integer _
)
[C#]
public virtual void MarkSequencePoint(
   ISymbolDocumentWriter document,
   int startLine,
   int startColumn,
   int endLine,
   int endColumn
);
[C++]
public: virtual void MarkSequencePoint(
   ISymbolDocumentWriter* document,
   int startLine,
   int startColumn,
   int endLine,
   int endColumn
);
[JScript]
public function MarkSequencePoint(
   document : ISymbolDocumentWriter,
   startLine : int,
   startColumn : int,
   endLine : int,
   endColumn : int
);

Parameters

document
The document for which the sequence point is being defined.
startLine
[To be supplied.]
startColumn
[To be supplied.]
endLine
[To be supplied.]
endColumn
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentException | if startLine or endLine is <= 0

Remarks

Line numbers are indexed from 1. Columns are indexed from 0.

The symbolic information normally includes at least one IL offset for each source line. When the JIT compiler is about to compile a method, it asks the Profiling Services for a list of IL offsets that should be preserved. These IL offsets are called sequence points.

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace


ILGenerator.ThrowException

Emits an instruction to throw an exception.

[Visual Basic]
Overridable Public Sub ThrowException( _
   ByVal excType As Type _
)
[C#]
public virtual void ThrowException(
   Type excType
);
[C++]
public: virtual void ThrowException(
   Type* excType
);
[JScript]
public function ThrowException(
   excType : Type
);

Parameters

excType
The class of the type of exception to throw.

Exceptions

Exception Type | Condition
ArgumentException | if excType is not the Exception class or a subclass of Exception or if the type does not have a default constructor
ArgumentNullException | if excType is a null reference (in Visual Basic Nothing)

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace


ILGenerator.UsingNamespace

[To be supplied.]

[Visual Basic]
Public Sub UsingNamespace( _
   ByVal usingNamespace As String _
)
[C#]
public void UsingNamespace(
   string usingNamespace
);
[C++]
public: void UsingNamespace(
   String* usingNamespace
);
[JScript]
public function UsingNamespace(
   usingNamespace : String
);

Parameters

usingNamespace
[To be supplied.]

See Also

ILGenerator Class | ILGenerator Members | System.Reflection.Emit Namespace


Label Structure

The Label class is used with the ILGenerator class to represent a label in the instruction stream.

Object
ValueType
Label

[Visual Basic]
Public Structure Label
[C#]
public struct Label
[C++]
public __value struct Label

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

Label Members | System.Reflection.Emit Namespace


Label Members

Public:

Methods

Equals | Checks if the given object is an instance of Label and is equal to this instance.
GetHashCode | Generates a hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Label Structure | System.Reflection.Emit Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Label Methods

The methods of the Label structure are listed below. For a complete list of Label structure members, see the Label Members topic.

Public:

Equals | Checks if the given object is an instance of Label and is equal to this instance.
GetHashCode | Generates a hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Label Structure | System.Reflection.Emit Namespace


Label.Equals

Checks if the given object is an instance of Label and is equal to this instance.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The object to compare with this Label instance.

Return Value

Returns true if obj is an instance of Label and is equal to this object. Otherwise, returns false.

See Also

Label Structure | Label Members | System.Reflection.Emit Namespace


Label.GetHashCode

Generates a hash code for this instance.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

Returns a hash code for this instance.

See Also

Label Structure | Label Members | System.Reflection.Emit Namespace


LocalBuilder Class

The LocalBuilder class represents a local variable within a method or constructor. A LocalBuilder object can be defined using the DeclareLocal method.

Object
LocalBuilder

[Visual Basic]
NotInheritable Public Class LocalBuilder
[C#]
public sealed class LocalBuilder
[C++]
public __gc __sealed class LocalBuilder
[JScript]
public class LocalBuilder

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

LocalBuilder Members | System.Reflection.Emit Namespace


LocalBuilder Members

Public:

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SetLocalSymInfo | Overloaded. Sets the local variable's symbolic information.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LocalBuilder Class | System.Reflection.Emit Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

LocalBuilder Methods

The methods of the LocalBuilder class are listed below. For a complete list of LocalBuilder class members, see the LocalBuilder Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SetLocalSymInfo | Overloaded. Sets the local variable's symbolic information.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LocalBuilder Class | System.Reflection.Emit Namespace


LocalBuilder.SetLocalSymInfo

Sets the local variable's symbolic information.

Overload List

Sets the name of this local variable.

[Visual Basic] Overloads Public Sub SetLocalSymInfo(String)
[C#] public void SetLocalSymInfo(String);
[C++] public: void SetLocalSymInfo(String*);
[JScript] public function SetLocalSymInfo(String);

Sets the name and lexical scope of this local variable.

[Visual Basic] Overloads Public Sub SetLocalSymInfo(String, Integer, Integer)
[C#] public void SetLocalSymInfo(String, int, int);
[C++] public: void SetLocalSymInfo(String*, int, int);
[JScript] public function SetLocalSymInfo(String, int, int);

See Also

LocalBuilder Class | LocalBuilder Members | System.Reflection.Emit Namespace


LocalBuilder.SetLocalSymInfo (String)

Sets the name of this local variable.

[Visual Basic]
Overloads Public Sub SetLocalSymInfo( _
   ByVal name As String _
)
[C#]
public void SetLocalSymInfo(
   string name
);
[C++]
public: void SetLocalSymInfo(
   String* name
);
[JScript]
public function SetLocalSymInfo(
   name : String
);

Parameters

name
The name of the local variable.

See Also

LocalBuilder Class | LocalBuilder Members | System.Reflection.Emit Namespace | LocalBuilder.SetLocalSymInfo Overload List


LocalBuilder.SetLocalSymInfo (String, Int32, Int32)

Sets the name and lexical scope of this local variable.

[Visual Basic]
Overloads Public Sub SetLocalSymInfo( _
   ByVal name As String, _
   ByVal startOffset As Integer, _
   ByVal endOffset As Integer _
)
[C#]
public void SetLocalSymInfo(
   string name,
   int startOffset,
   int endOffset
);
[C++]
public: void SetLocalSymInfo(
   String* name,
   int startOffset,
   int endOffset
);
[JScript]
public function SetLocalSymInfo(
   name : String,
   startOffset : int,
   endOffset : int
);

Parameters

name
The name of the local variable.
startOffset
The beginning offset of the lexical scope of the local variable.
endOffset
The ending offset of the lexical scope of the local variable.

Exceptions

Exception Type | Condition
InvalidOperationException | if the containing type has been created with CreateType or if there is no symbolic writer defined for the containing module

See Also

LocalBuilder Class | LocalBuilder Members | System.Reflection.Emit Namespace | LocalBuilder.SetLocalSymInfo Overload List


LocalToken Structure

This class is obsolete and is no longer being used. It will be removed in a future release.

Object
ValueType
LocalToken

[Visual Basic]
Public Structure LocalToken
[C#]
public struct LocalToken
[C++]
public __value struct LocalToken

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

LocalToken Members | System.Reflection.Emit Namespace


LocalToken Members

Public:

Methods

Equals | Checks if the given object is an instance of LocalToken and is equal to this instance.
GetHashCode | Generates a hash code for this LocalToken instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Fields

Empty [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LocalToken Structure | System.Reflection.Emit Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

LocalToken Methods

The methods of the LocalToken structure are listed below. For a complete list of LocalToken structure members, see the LocalToken Members topic.

Public:

Equals | Checks if the given object is an instance of LocalToken and is equal to this instance.
GetHashCode | Generates a hash code for this LocalToken instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LocalToken Structure | System.Reflection.Emit Namespace


LocalToken.Equals

Checks if the given object is an instance of LocalToken and is equal to this instance.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The object to compare to this object..

Return Value

Value | Condition
true | obj is a LocalToken instance and equals the current instance.
false | Otherwise .

Remarks

Two LocalToken objects are equal if they have the same index and represent local variables that have the same type. The index of the LocalToken is assigned by the MethodBuilder that declared it

See Also

LocalToken Structure | LocalToken Members | System.Reflection.Emit Namespace


LocalToken.GetHashCode

Generates a hash code for this LocalToken instance.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

Returns the hash code for this instance.

Remarks

The hash code is generated by multiplying the index of this LocalToken by the sync block index of the Type object that represents the type of this local variable. The index of the LocalToken is assigned by the MethodBuilder that declared it. The sync block index is obtained via Object.Equals. The hash code is therefore not necessarily unique, even for the local variables of a single MethodBuilder.

See Also

LocalToken Structure | LocalToken Members | System.Reflection.Emit Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

LocalToken Fields

The fields of the LocalToken structure are listed below. For a complete list of LocalToken structure members, see the LocalToken Members topic.

Public:

Empty [To be supplied.]

See Also

LocalToken Structure | System.Reflection.Emit Namespace


LocalToken.Empty

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Empty As LocalToken
[C#]
public static readonly LocalToken Empty;
[C++]
public: static readonly LocalToken Empty;
[JScript]
public static var Empty : LocalToken;

See Also

LocalToken Structure | LocalToken Members | System.Reflection.Emit Namespace


MethodBuilder Class

The MethodBuilder class is used to define and represent a method (or constructor) on a dynamic class. MethodBuilder is used to fully describe a method in IL, including the name, attributes, signature, and method body. It is used in conjunction with the TypeBuilder class to create classes at run time.

Object
MemberInfo
MethodBase
MethodInfo
MethodBuilder

[Visual Basic]
NotInheritable Public Class MethodBuilder
   Inherits MethodInfo
[C#]
public sealed class MethodBuilder : MethodInfo
[C++]
public __gc __sealed class MethodBuilder : public MethodInfo
[JScript]
public class MethodBuilder extends MethodInfo

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

MethodBuilder Members | System.Reflection.Emit Namespace


MethodBuilder Members

Public:

Properties

Attributes | Retrieves the attributes for this method.
CallingConvention | Returns the calling convention of the method.
DeclaringType | Returns the type that declares this method.
InitLocals | Gets or sets whether the local variables in this method should be zero initialized.
IsAbstract (inherited from MethodBase) | Retrieves whether this is an abstract method.
IsAssembly (inherited from MethodBase) | Retrieves whether this is an abstract method.
IsConstructor (inherited from MethodBase) | If set, the method is a constructor.
IsFamily (inherited from MethodBase) | If set, this method can be called by all subclasses, wherever they are, but not by unrelated classes.
IsFamilyAndAssembly (inherited from MethodBase) | If set, this method can be called by subclasses if they are in the same assembly.
IsFamilyOrAssembly (inherited from MethodBase) | If set, this method can be called by subclasses, wherever they are, and by all classes in the same assembly.
IsFinal (inherited from MethodBase) | If set, this method cannot be overridden by a subclass.
IsHideBySig (inherited from MethodBase) | [To be supplied.]
IsPrivate (inherited from MethodBase) | If set, this method can be called only by other members of the class itself.
IsPublic (inherited from MethodBase) | Retrieves whether this is a public method.
IsSpecialName (inherited from MethodBase) | If set, this method has a special name.
IsStatic (inherited from MethodBase) | If set, the method is static.
IsVirtual (inherited from MethodBase) | Retrieves a value indicating whether the method is virtual.
MemberType (inherited from MethodInfo) | Retrieves a value indicating that this member is a method.
MethodHandle | Retrieves the internal handle for the method. Use this handle to access the underlying metadata handle.
Name | Retrieves the name of this method.
ReflectedType | Retrieves the class that was used in reflection to obtain this object.
ReturnType | Retrieves the Type of this method's return value.
ReturnTypeCustomAttributes | Returns the custom attributes of the method's return type.
Signature | Retrieves the signature of the field.

Methods

AddDeclarativeSecurity | Adds declarative security to this method.
CreateMethodBody | Creates the body of the method using the given array of IL instructions.
DefineParameter | Defines a parameter of this method.
Equals | Determines whether the given object is equal to this instance.
GetBaseDefinition | Return the base implementation for a method.
GetCustomAttributes | Overloaded. Overloaded. Returns the custom attributes defined for this method.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetILGenerator | Returns an ILGenerator for this method.
GetImplementationFlags | Gets the implementation flags for the method.
GetMethodImplementationFlags | Returns the implementation flags for the method.
GetModule | Returns a reference to the module that contains this method.
GetParameters | Returns the parameters of this method.
GetToken | Returns the MethodToken that represents the token for this method.
GetType (inherited from Object) | Gets the Type of the Object.
Invoke | Overloaded. [To be supplied.]
IsDefined | Checks if the specified custom attribute type is defined.
SetCustomAttribute | Overloaded. Sets a custom attribute.
SetImplementationFlags | Sets the implementation flags for this method.
SetMarshal | Sets marshalling information for the return type of this method.
SetSymCustomAttribute | Set a custom attribute using a specified custom attribute blob.
ToString | Returns this MethodBuilder instance as a String.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MethodBuilder Class | System.Reflection.Emit Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MethodBuilder Properties

The properties of the MethodBuilder class are listed below. For a complete list of MethodBuilder class members, see the MethodBuilder Members topic.

Public:

Attributes | Retrieves the attributes for this method.
CallingConvention | Returns the calling convention of the method.
DeclaringType | Returns the type that declares this method.
InitLocals | Gets or sets whether the local variables in this method should be zero initialized.
IsAbstract (inherited from MethodBase) | Retrieves whether this is an abstract method.
IsAssembly (inherited from MethodBase) | Retrieves whether this is an abstract method.
IsConstructor (inherited from MethodBase) | If set, the method is a constructor.
IsFamily (inherited from MethodBase) | If set, this method can be called by all subclasses, wherever they are, but not by unrelated classes.
IsFamilyAndAssembly (inherited from MethodBase) | If set, this method can be called by subclasses if they are in the same assembly.
IsFamilyOrAssembly (inherited from MethodBase) | If set, this method can be called by subclasses, wherever they are, and by all classes in the same assembly.
IsFinal (inherited from MethodBase) | If set, this method cannot be overridden by a subclass.
IsHideBySig (inherited from MethodBase) | [To be supplied.]
IsPrivate (inherited from MethodBase) | If set, this method can be called only by other members of the class itself.
IsPublic (inherited from MethodBase) | Retrieves whether this is a public method.
IsSpecialName (inherited from MethodBase) | If set, this method has a special name.
IsStatic (inherited from MethodBase) | If set, the method is static.
IsVirtual (inherited from MethodBase) | Retrieves a value indicating whether the method is virtual.
MemberType (inherited from MethodInfo) | Retrieves a value indicating that this member is a method.
MethodHandle | Retrieves the internal handle for the method. Use this handle to access the underlying metadata handle.
Name | Retrieves the name of this method.
ReflectedType | Retrieves the class that was used in reflection to obtain this object.
ReturnType | Retrieves the Type of this method's return value.
ReturnTypeCustomAttributes | Returns the custom attributes of the method's return type.
Signature | Retrieves the signature of the field.

See Also

MethodBuilder Class | System.Reflection.Emit Namespace


MethodBuilder.Attributes

Retrieves the attributes for this method.

[Visual Basic]
Overridable Public ReadOnly Property Attributes As MethodAttributes
[C#]
public MethodAttributes Attributes {override get;}
[C++]
public: __property virtual MethodAttributes get_Attributes();
[JScript]
public function get Attributes() : MethodAttributes;

Property Value

Read-only. Retrieves the MethodAttributes for this method.

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace


MethodBuilder.CallingConvention

Returns the calling convention of the method.

[Visual Basic]
Overridable Public ReadOnly Property CallingConvention As _
   CallingConventions
[C#]
public CallingConventions CallingConvention {override get;}
[C++]
public: __property virtual CallingConventions
   get_CallingConvention();
[JScript]
public function get CallingConvention() : CallingConventions;

Property Value

Read-only. The calling convention of the method.

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace


MethodBuilder.DeclaringType

Returns the type that declares this method.

[Visual Basic]
Overridable Public ReadOnly Property DeclaringType As Type
[C#]
public Type DeclaringType {override get;}
[C++]
public: __property virtual Type* get_DeclaringType();
[JScript]
public function get DeclaringType() : Type;

Property Value

Read-only. The type that declares this method.

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace


MethodBuilder.InitLocals

Gets or sets whether the local variables in this method should be zero initialized.

[Visual Basic]
Public Property InitLocals As Boolean
[C#]
public bool InitLocals {get; set;}
[C++]
public: __property bool get_InitLocals();
public: __property void set_InitLocals(bool);
[JScript]
public function get InitLocals() : Boolean;
public function set InitLocals(Boolean);

Property Value

Read/write. Gets or sets whether the local variables in this method should be zero initialized.

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace


MethodBuilder.MethodHandle

Retrieves the internal handle for the method. Use this handle to access the underlying metadata handle.

[Visual Basic]
Overridable Public ReadOnly Property MethodHandle As _
   RuntimeMethodHandle
[C#]
public RuntimeMethodHandle MethodHandle {override get;}
[C++]
public: __property virtual RuntimeMethodHandle get_MethodHandle();
[JScript]
public function get MethodHandle() : RuntimeMethodHandle;

Property Value

Read-only. The internal handle for the method. Use this handle to access the underlying metadata handle.

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace


MethodBuilder.Name

Retrieves the name of this method.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {override get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

Property Value

Read-only. Retrieves a String containing the simple name of this method.

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace


MethodBuilder.ReflectedType

Retrieves the class that was used in reflection to obtain this object.

[Visual Basic]
Overridable Public ReadOnly Property ReflectedType As Type
[C#]
public Type ReflectedType {override get;}
[C++]
public: __property virtual Type* get_ReflectedType();
[JScript]
public function get ReflectedType() : Type;

Property Value

Read-only. The Type used to obtain this method.

Remarks

A MethodBuilder object represents a method on a particular class or interface. In order to obtain a MethodInfo object, the Type object that represents the class or interface that supports the method is queried. This property holds a reference to that Type object.

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace


MethodBuilder.ReturnType

Retrieves the Type of this method's return value.

[Visual Basic]
Overridable Public ReadOnly Property ReturnType As Type
[C#]
public Type ReturnType {override get;}
[C++]
public: __property virtual Type* get_ReturnType();
[JScript]
public function get ReturnType() : Type;

Property Value

Read-only. The Type of object this method returns.

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace


MethodBuilder.ReturnTypeCustomAttributes

Returns the custom attributes of the method's return type.

[Visual Basic]
Overridable Public ReadOnly Property ReturnTypeCustomAttributes As _
   ICustomAttributeProvider
[C#]
public ICustomAttributeProvider ReturnTypeCustomAttributes
   {override get;}
[C++]
public: __property virtual ICustomAttributeProvider*
   get_ReturnTypeCustomAttributes();
[JScript]
public function get ReturnTypeCustomAttributes() :
   ICustomAttributeProvider;

Property Value

Read-only. The custom attributes of the method's return type.

Remarks

This method always returns a null reference (in Visual Basic Nothing) at this time. As a workaround, get the MethodInfo after the containing Type has been created and invoked ReturnTypeCustomAttributes on the MethodInfo.

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace


MethodBuilder.Signature

Retrieves the signature of the field.

[Visual Basic]
Public ReadOnly Property Signature As String
[C#]
public string Signature {get;}
[C++]
public: __property String* get_Signature();
[JScript]
public function get Signature() : String;

Property Value

Read-only. A String containing the signature of the method reflected by this MethodBase instance.

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MethodBuilder Methods

The methods of the MethodBuilder class are listed below. For a complete list of MethodBuilder class members, see the MethodBuilder Members topic.

Public:

AddDeclarativeSecurity | Adds declarative security to this method.
CreateMethodBody | Creates the body of the method using the given array of IL instructions.
DefineParameter | Defines a parameter of this method.
Equals | Determines whether the given object is equal to this instance.
GetBaseDefinition | Return the base implementation for a method.
GetCustomAttributes | Overloaded. Overloaded. Returns the custom attributes defined for this method.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetILGenerator | Returns an ILGenerator for this method.
GetImplementationFlags | Gets the implementation flags for the method.
GetMethodImplementationFlags | Returns the implementation flags for the method.
GetModule | Returns a reference to the module that contains this method.
GetParameters | Returns the parameters of this method.
GetToken | Returns the MethodToken that represents the token for this method.
GetType (inherited from Object) | Gets the Type of the Object.
Invoke | Overloaded. [To be supplied.]
IsDefined | Checks if the specified custom attribute type is defined.
SetCustomAttribute | Overloaded. Sets a custom attribute.
SetImplementationFlags | Sets the implementation flags for this method.
SetMarshal | Sets marshalling information for the return type of this method.
SetSymCustomAttribute | Set a custom attribute using a specified custom attribute blob.
ToString | Returns this MethodBuilder instance as a String.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MethodBuilder Class | System.Reflection.Emit Namespace


MethodBuilder.AddDeclarativeSecurity

Adds declarative security to this method.

[Visual Basic]
Public Sub AddDeclarativeSecurity( _
   ByVal action As SecurityAction, _
   ByVal pset As PermissionSet _
)
[C#]
public void AddDeclarativeSecurity(
   SecurityAction action,
   PermissionSet pset
);
[C++]
public: void AddDeclarativeSecurity(
   SecurityAction action,
   PermissionSet* pset
);
[JScript]
public function AddDeclarativeSecurity(
   action : SecurityAction,
   pset : PermissionSet
);

Parameters

action
The security action to be taken (Demand, Assert, etc.)
pset
The set of permissions the action applies to.

Exceptions

Exception Type | Condition
ArgumentNullException | if pset is a null reference (in Visual Basic Nothing)
ArgumentOutOfRangeException | if the action is invalid
InvalidOperationException | if the containing type was previously created using CreateType

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace


MethodBuilder.CreateMethodBody

Creates the body of the method using the given array of IL instructions.

[Visual Basic]
Public Sub CreateMethodBody( _
   ByVal il() As Byte, _
   ByVal count As Integer _
)
[C#]
public void CreateMethodBody(
   byte[] il,
   int count
);
[C++]
public: void CreateMethodBody(
   unsigned char* il[],
   int count
);
[JScript]
public function CreateMethodBody(
   il : Byte[],
   count : int
);

Parameters

il
An array containing valid IL instructions. If this parameter is null, the method's body is cleared.
count
The number of valid bytes in the il array. This value is ignored if il is null.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | if the count is not withing the range of indices of the supplied IL instruction array
InvalidOperationException | if the containing type was previously created using CreateType

Remarks

This method creates the method's body from il, an array containing IL instructions. The number of bytes of valid IL is given by count. Note: This is currently not fully supported.

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace


MethodBuilder.DefineParameter

Defines a parameter of this method.

[Visual Basic]
Public Function DefineParameter( _
   ByVal position As Integer, _
   ByVal attributes As ParameterAttributes, _
   ByVal strParamName As String _
) As ParameterBuilder
[C#]
public ParameterBuilder DefineParameter(
   int position,
   ParameterAttributes attributes,
   string strParamName
);
[C++]
public: ParameterBuilder* DefineParameter(
   int position,
   ParameterAttributes attributes,
   String* strParamName
);
[JScript]
public function DefineParameter(
   position : int,
   attributes : ParameterAttributes,
   strParamName : String
) : ParameterBuilder;

Parameters

position
The zero-indexed position of the parameter in the parameter list.
attributes
The attributes of the parameter.
strParamName
The name of the parameter. The name can be the null string.

Return Value

Returns a ParameterBuilder object that represents the new parrameter of this method.

Exceptions

Exception Type | Condition
InvalidOperationException | if the containing type was previously created using CreateType

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace


MethodBuilder.Equals

Determines whether the given object is equal to this instance.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The object to compare with this MethodBuilder instance.

Return Value

Returns true if obj is an instance of MethodBuilder and is equal to this object. Otherwise, returns false.

Remarks

Equality is determined by having the same name, attributes and signature.

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace


MethodBuilder.GetBaseDefinition

Return the base implementation for a method.

[Visual Basic]
Overrides Public Function GetBaseDefinition() As MethodInfo
[C#]
public override MethodInfo GetBaseDefinition();
[C++]
public: override MethodInfo* GetBaseDefinition();
[JScript]
public override function GetBaseDefinition() : MethodInfo;

Return Value

The base implementation of this method.

Remarks

This is always this MethodBuilder object.

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace


MethodBuilder.GetCustomAttributes

Overloaded. Returns the custom attributes defined for this method.

Overload List

Returns all the custom attributes defined for this method.

[Visual Basic] Overloads Overrides Public Function GetCustomAttributes() As Object ()
[C#] public override object[] GetCustomAttributes();
[C++] public: override Object* GetCustomAttributes() [];
[JScript] public override function GetCustomAttributes() : Object[];

Returns the custom attributes identified by the given type.

[Visual Basic] Overloads Overrides Public Function GetCustomAttributes(Type) As Object ()
[C#] public override object[] GetCustomAttributes(Type);
[C++] public: override Object* GetCustomAttributes(Type*) [];
[JScript] public override function GetCustomAttributes(Type) : Object[];

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace


MethodBuilder.GetCustomAttributes ()

Returns all the custom attributes defined for this method.

[Visual Basic]
Overloads Overrides Public Function GetCustomAttributes() As Object ()
[C#]
public override object[] GetCustomAttributes();
[C++]
public: override Object* GetCustomAttributes() [];
[JScript]
public override function GetCustomAttributes() : Object[];

Return Value

Returns an array of objects representing all the custom attributes of this method.

Exceptions

Exception Type | Condition
TypeLoadException | if the custom attribute type can not be loaded.

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace | MethodBuilder.GetCustomAttributes Overload List


MethodBuilder.GetCustomAttributes (Type)

Returns the custom attributes identified by the given type.

[Visual Basic]
Overloads Overrides Public Function GetCustomAttributes( _
   ByVal attributeType As Type _
) As Object ()
[C#]
public override object[] GetCustomAttributes(
   Type attributeType
);
[C++]
public: override Object* GetCustomAttributes(
   Type* attributeType
) [];
[JScript]
public override function GetCustomAttributes(
   attributeType : Type
) : Object[];

Parameters

attributeType
The custom attribute type.

Return Value

Returns an array of objects representing the attributes of this methodthat are of Type attributeType.

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace | MethodBuilder.GetCustomAttributes Overload List


MethodBuilder.GetILGenerator

Returns an ILGenerator for this method.

[Visual Basic]
Public Function GetILGenerator() As ILGenerator
[C#]
public ILGenerator GetILGenerator();
[C++]
public: ILGenerator* GetILGenerator();
[JScript]
public function GetILGenerator() : ILGenerator;

Return Value

Returns an ILGenerator object for this method.

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace


MethodBuilder.GetImplementationFlags

Gets the implementation flags for the method.

[Visual Basic]
Public Function GetImplementationFlags() As MethodImplAttributes
[C#]
public MethodImplAttributes GetImplementationFlags();
[C++]
public: MethodImplAttributes GetImplementationFlags();
[JScript]
public function GetImplementationFlags() : MethodImplAttributes;

Return Value

Returns the implementation flags for the method.

Remarks

GetImplementationFlags is a synonym for GetMethodImplementationFlags.

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace


MethodBuilder.GetMethodImplementationFlags

Returns the implementation flags for the method.

[Visual Basic]
Overrides Public Function GetMethodImplementationFlags() As _
   MethodImplAttributes
[C#]
public override MethodImplAttributes GetMethodImplementationFlags();
[C++]
public: override MethodImplAttributes
   GetMethodImplementationFlags();
[JScript]
public override function GetMethodImplementationFlags() :
   MethodImplAttributes;

Return Value

Returns the implementation flags for the method.

Remarks

GetMethodImplementationFlags is a synonym for GetImplementationFlags.

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace


MethodBuilder.GetModule

Returns a reference to the module that contains this method.

[Visual Basic]
Public Function GetModule() As Module
[C#]
public Module GetModule();
[C++]
public: Module* GetModule();
[JScript]
public function GetModule() : Module;

Return Value

Returns a reference to the module that contains this method.

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace


MethodBuilder.GetParameters

Returns the parameters of this method.

[Visual Basic]
Overrides Public Function GetParameters() As ParameterInfo ()
[C#]
public override ParameterInfo[] GetParameters();
[C++]
public: override ParameterInfo* GetParameters() [];
[JScript]
public override function GetParameters() : ParameterInfo[];

Return Value

An array of ParameterInfo objects that represent the parameters of the method.

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace


MethodBuilder.GetToken

Returns the MethodToken that represents the token for this method.

[Visual Basic]
Public Function GetToken() As MethodToken
[C#]
public MethodToken GetToken();
[C++]
public: MethodToken GetToken();
[JScript]
public function GetToken() : MethodToken;

Return Value

Returns the MethodToken of this method.

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace


MethodBuilder.Invoke

Dynamically invokes the method reflected by this instance on the given object, passing along the specified parameters, and under the constraints of the given binder.

[Visual Basic]
Overrides Public Function Invoke( _
   ByVal obj As Object, _
   ByVal invokeAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal parameters() As Object, _
   ByVal culture As CultureInfo _
) As Object
[C#]
public override object Invoke(
   object obj,
   BindingFlags invokeAttr,
   Binder binder,
   object[] parameters,
   CultureInfo culture
);
[C++]
public: override Object* Invoke(
   Object* obj,
   BindingFlags invokeAttr,
   Binder* binder,
   Object* parameters[],
   CultureInfo* culture
);
[JScript]
public override function Invoke(
   obj : Object,
   invokeAttr : BindingFlags,
   binder : Binder,
   parameters : Object[],
   culture : CultureInfo
) : Object;

Parameters

obj
The object on which to invoke the specified method. If the method is static, this parameter is ignored.
invokeAttr
This must be a bit flag from BindingFlags: InvokeMethod, NonPublic, etc.
binder
An object that enables the binding, coercion of argument types, invocation of members, and retrieval of MemberInfo objects via reflection. If binder is a null reference (in Visual Basic Nothing), the default binder is used. See Binder.
parameters
An argument list. This is an array of arguments with the same number, order, and type as the parameters of the method to be invoked. If there are no parameters this should be a null reference (Nothing).
culture
An instance of CultureInfo used to govern the coercion of types. If this is null, the CultureInfo for the current thread is used. (Note that this is necessary to, for example, convert a String that represents 1000 to a Double value, since 1000 is represented differently by different cultures.)

Return Value

Returns a Variant containing the return value of the invoked method.

Exceptions

Exception Type | Condition
NotSupportedException | This method is not currently supported. The workaround is to retrieve the constructor using GetMethod and call Invoke on the returned MethodInfo.

Remarks

If the method is static, the obj parameter is ignored. For non-static methods, obj should be an instance of a class that inherits or declares the method and must be the same type as this class. If the method has no parameters, the value of parameters should be a null reference (Nothing). Otherwise the number, type, and order of elements in the parameters array should be identical to the number, type, and order of parameters for the method reflected by this instance.

Note: Access restrictions are ignored for fully trusted code. That is, private constructors, methods, fields, and properties can be accessed and invoked via Reflection whenever the code is fully trusted.

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace


MethodBuilder.IsDefined

Checks if the specified custom attribute type is defined.

[Visual Basic]
Overrides Public Function IsDefined( _
   ByVal attributeType As Type _
) As Boolean
[C#]
public override bool IsDefined(
   Type attributeType
);
[C++]
public: override bool IsDefined(
   Type* attributeType
);
[JScript]
public override function IsDefined(
   attributeType : Type
) : Boolean;

Parameters

attributeType
A custom attribute type.

Return Value

true if the specified custom attribute type is defined. Otherwise, false.

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace


MethodBuilder.SetCustomAttribute

Sets a custom attribute.

Overload List

Set a custom attribute using a specified custom attribute blob.

[Visual Basic] Overloads Public Sub SetCustomAttribute(ConstructorInfo, Byte())
[C#] public void SetCustomAttribute(ConstructorInfo, byte[]);
[C++] public: void SetCustomAttribute(ConstructorInfo*, unsigned char[]);
[JScript] public function SetCustomAttribute(ConstructorInfo, Byte[]);

Set a custom attribute using a custom attribute builder.

[Visual Basic] Overloads Public Sub SetCustomAttribute(CustomAttributeBuilder)
[C#] public void SetCustomAttribute(CustomAttributeBuilder);
[C++] public: void SetCustomAttribute(CustomAttributeBuilder*);
[JScript] public function SetCustomAttribute(CustomAttributeBuilder);

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace


MethodBuilder.SetCustomAttribute (ConstructorInfo, Byte[])

Set a custom attribute using a specified custom attribute blob.

[Visual Basic]
Overloads Public Sub SetCustomAttribute( _
   ByVal con As ConstructorInfo, _
   ByVal binaryAttribute() As Byte _
)
[C#]
public void SetCustomAttribute(
   ConstructorInfo con,
   byte[] binaryAttribute
);
[C++]
public: void SetCustomAttribute(
   ConstructorInfo* con,
   unsigned char* binaryAttribute[]
);
[JScript]
public function SetCustomAttribute(
   con : ConstructorInfo,
   binaryAttribute : Byte[]
);

Parameters

con
The constructor for the custom attribute.
binaryAttribute
A byte blob representing the attributes.

Exceptions

Exception Type | Condition
ArgumentNullException | if con or binaryAttribute is a null reference (in Visual Basic Nothing)

Remarks

See the for details on how to format binaryAttribute.

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace | MethodBuilder.SetCustomAttribute Overload List


MethodBuilder.SetCustomAttribute (CustomAttributeBuilder)

Set a custom attribute using a custom attribute builder.

[Visual Basic]
Overloads Public Sub SetCustomAttribute( _
   ByVal customBuilder As CustomAttributeBuilder _
)
[C#]
public void SetCustomAttribute(
   CustomAttributeBuilder customBuilder
);
[C++]
public: void SetCustomAttribute(
   CustomAttributeBuilder* customBuilder
);
[JScript]
public function SetCustomAttribute(
   customBuilder : CustomAttributeBuilder
);

Parameters

customBuilder
An instance of a helper class to define the custom attribute.

Exceptions

Exception Type | Condition
ArgumentNullException | if con is a null reference (in Visual Basic Nothing)

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace | MethodBuilder.SetCustomAttribute Overload List


MethodBuilder.SetImplementationFlags

Sets the implementation flags for this method.

[Visual Basic]
Public Sub SetImplementationFlags( _
   ByVal attributes As MethodImplAttributes _
)
[C#]
public void SetImplementationFlags(
   MethodImplAttributes attributes
);
[C++]
public: void SetImplementationFlags(
   MethodImplAttributes attributes
);
[JScript]
public function SetImplementationFlags(
   attributes : MethodImplAttributes
);

Parameters

attributes
The implementation flags to set.

Exceptions

Exception Type | Condition
InvalidOperationException | if the containing type was previously created using CreateType

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace


MethodBuilder.SetMarshal

Sets marshalling information for the return type of this method.

[Visual Basic]
Public Sub SetMarshal( _
   ByVal unmanagedMarshal As UnmanagedMarshal _
)
[C#]
public void SetMarshal(
   UnmanagedMarshal unmanagedMarshal
);
[C++]
public: void SetMarshal(
   UnmanagedMarshal* unmanagedMarshal
);
[JScript]
public function SetMarshal(
   unmanagedMarshal : UnmanagedMarshal
);

Parameters

unmanagedMarshal
Marshalling information for the return type of this method.

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace


MethodBuilder.SetSymCustomAttribute

Set a custom attribute using a specified custom attribute blob.

[Visual Basic]
Public Sub SetSymCustomAttribute( _
   ByVal name As String, _
   ByVal data() As Byte _
)
[C#]
public void SetSymCustomAttribute(
   string name,
   byte[] data
);
[C++]
public: void SetSymCustomAttribute(
   String* name,
   unsigned char* data[]
);
[JScript]
public function SetSymCustomAttribute(
   name : String,
   data : Byte[]
);

Parameters

name
The constructor for the custom attribute.
data
A byte blob representing the attributes.

Exceptions

Exception Type | Condition
ArgumentNullException | if con or binaryAttribute is a null reference (in Visual Basic Nothing)

Remarks

See the for details on how to format binaryAttribute.

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace


MethodBuilder.ToString

Returns this MethodBuilder instance as a String.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

Returns a String containing the name, attributes, method signature, exceptions, and local signature of this method followed by the current IL Stream.

See Also

MethodBuilder Class | MethodBuilder Members | System.Reflection.Emit Namespace


MethodRental Class

The MethodRental class provides a fast way to swap method body implementation given a method of a class.

Object
MethodRental

[Visual Basic]
NotInheritable Public Class MethodRental
[C#]
public sealed class MethodRental
[C++]
public __gc __sealed class MethodRental
[JScript]
public class MethodRental

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

MethodRental Members | System.Reflection.Emit Namespace


MethodRental Members

Public:

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SwapMethodBody | Swaps the body of a method.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

JitImmediate | Specifies that the method should be JIT-compiled immediately.
JitOnDemand | Specifies that the method should be JIT-compiled when needed.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MethodRental Class | System.Reflection.Emit Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MethodRental Methods

The methods of the MethodRental class are listed below. For a complete list of MethodRental class members, see the MethodRental Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SwapMethodBody | Swaps the body of a method.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MethodRental Class | System.Reflection.Emit Namespace


MethodRental.SwapMethodBody

Swaps the body of a method.

[Visual Basic]
Public Shared Sub SwapMethodBody( _
   ByVal cls As Type, _
   ByVal methodtoken As Integer, _
   ByVal rgIL As Integer, _
   ByVal methodSize As Integer, _
   ByVal flags As Integer _
)
[C#]
public static void SwapMethodBody(
   Type cls,
   int methodtoken,
   int rgIL,
   int methodSize,
   int flags
);
[C++]
public: static void SwapMethodBody(
   Type* cls,
   int methodtoken,
   int rgIL,
   int methodSize,
   int flags
);
[JScript]
public static function SwapMethodBody(
   cls : Type,
   methodtoken : int,
   rgIL : int,
   methodSize : int,
   flags : int
);

Parameters

cls
The class containing the method.
methodtoken
The token for the method.
rgIL
A pointer to the method.
methodSize
The size of the new method body in bytes.
flags
Flags that control the swapping.

See Also

MethodRental Class | MethodRental Members | System.Reflection.Emit Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MethodRental Fields

The fields of the MethodRental class are listed below. For a complete list of MethodRental class members, see the MethodRental Members topic.

Public:

JitImmediate | Specifies that the method should be JIT-compiled immediately.
JitOnDemand | Specifies that the method should be JIT-compiled when needed.

See Also

MethodRental Class | System.Reflection.Emit Namespace


MethodRental.JitImmediate

Specifies that the method should be JIT-compiled immediately.

[Visual Basic]
Public Const JitImmediate As Integer
[C#]
public const int JitImmediate;
[C++]
public: const int JitImmediate;
[JScript]
public var JitImmediate : int;

See Also

MethodRental Class | MethodRental Members | System.Reflection.Emit Namespace


MethodRental.JitOnDemand

Specifies that the method should be JIT-compiled when needed.

[Visual Basic]
Public Const JitOnDemand As Integer
[C#]
public const int JitOnDemand;
[C++]
public: const int JitOnDemand;
[JScript]
public var JitOnDemand : int;

See Also

MethodRental Class | MethodRental Members | System.Reflection.Emit Namespace


MethodToken Structure

The MethodToken class is an object representation of a token that represents a method.

Object
ValueType
MethodToken

[Visual Basic]
Public Structure MethodToken
[C#]
public struct MethodToken
[C++]
public __value struct MethodToken

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

MethodToken Members | System.Reflection.Emit Namespace


MethodToken Members

Public:

Properties

Token Returns the metadata token for this method.

Methods

Equals | Tests whether the given object is equal to this MethodToken object.
GetHashCode | Returns the generated hash code for this method.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Fields

Empty The default MethodToken with Token value 0.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MethodToken Structure | System.Reflection.Emit Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MethodToken Properties

The properties of the MethodToken structure are listed below. For a complete list of MethodToken structure members, see the MethodToken Members topic.

Public:

Token Returns the metadata token for this method.

See Also

MethodToken Structure | System.Reflection.Emit Namespace


MethodToken.Token

Returns the metadata token for this method.

[Visual Basic]
Public ReadOnly Property Token As Integer
[C#]
public int Token {get;}
[C++]
public: __property int get_Token();
[JScript]
public function get Token() : int;

Property Value

Read-only. Returns the metadata token for this method.

See Also

MethodToken Structure | MethodToken Members | System.Reflection.Emit Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MethodToken Methods

The methods of the MethodToken structure are listed below. For a complete list of MethodToken structure members, see the MethodToken Members topic.

Public:

Equals | Tests whether the given object is equal to this MethodToken object.
GetHashCode | Returns the generated hash code for this method.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MethodToken Structure | System.Reflection.Emit Namespace


MethodToken.Equals

Tests whether the given object is equal to this MethodToken object.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The object to compare to this object..

Return Value

Returns true if obj is an instance of MethodToken and is equal to this object. Otherwise, returns false.

See Also

MethodToken Structure | MethodToken Members | System.Reflection.Emit Namespace


MethodToken.GetHashCode

Returns the generated hash code for this method.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

Returns the hash code for this instance.

See Also

MethodToken Structure | MethodToken Members | System.Reflection.Emit Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MethodToken Fields

The fields of the MethodToken structure are listed below. For a complete list of MethodToken structure members, see the MethodToken Members topic.

Public:

Empty The default MethodToken with Token value 0.

See Also

MethodToken Structure | System.Reflection.Emit Namespace


MethodToken.Empty

The default MethodToken with Token value 0.

[Visual Basic]
Public Shared ReadOnly Empty As MethodToken
[C#]
public static readonly MethodToken Empty;
[C++]
public: static readonly MethodToken Empty;
[JScript]
public static var Empty : MethodToken;

See Also

MethodToken Structure | MethodToken Members | System.Reflection.Emit Namespace


ModuleBuilder Class

The ModuleBuilder class is used to define and represent a module.

Object
Module
ModuleBuilder

[Visual Basic]
Public Class ModuleBuilder
   Inherits Module
[C#]
public class ModuleBuilder : Module
[C++]
public __gc class ModuleBuilder : public Module
[JScript]
public class ModuleBuilder extends Module

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

ModuleBuilder Members | System.Reflection.Emit Namespace


ModuleBuilder Members

Public:

Properties

Assembly (inherited from Module) | Returns the appropriate Assembly for this instance of Module.
FullyQualifiedName (inherited from Module) | Returns the fully qualified name and path to this Module.
Name (inherited from Module) | Returns the name of the module with the path removed.
ScopeName (inherited from Module) | Returns a String representing the Name of the Module.

Methods

CreateGlobalFunctions | Fixes up a dynamic module containing global functions.
DefineDocument | Define a document for source.
DefineEnum | Defines an enumeration type with that is a value type with a single non-static field called value__ of the specified type.
DefineGlobalMethod | Overloaded. Defines a global method.
DefineInitializedData | Defines initialized data field in the .sdata section of the PE file.
DefinePInvokeMethod | Overloaded. Defines a PInvoke method.
DefineResource | Overloaded. Defines a managed embedded resource to be stored in this module.
DefineType | Overloaded. Constructs a TypeBuilder.
DefineUninitializedData | Defines uninitialized data field in the .sdata section of the PE file.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FindTypes (inherited from Module) | Returns an array of classes accepted by the given filter and filter criteria.
GetArrayMethod | Returns the named method on an array class.
GetArrayMethodToken | Returns the token for the named method on an array class.
GetConstructorDefToken | Deprecated. Return the token defined in the original module for the ConstructorInfo.
GetConstructorToken | Returns the token used to identify the specified constructor within this module.
GetCustomAttributes (inherited from Module) | Overloaded. [To be supplied.]
GetField (inherited from Module) | Overloaded. [To be supplied.]
GetFields (inherited from Module) | To be supplied
GetFieldToken | Returns the token used to identify the specified field within this module.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetMethod (inherited from Module) | Overloaded. [To be supplied.]
GetMethodDefToken | Deprecated. Returns the token in the original module for the MethodInfo.
GetMethods (inherited from Module) | Returns an array of all of the global methods defined on the Module.
GetMethodToken | Returns the token used to identify the specified method within this module.
GetObjectData (inherited from Module) | [To be supplied.]
GetSignatureToken | Overloaded. Defines a signature token.
GetSignerCertificate (inherited from Module) | [To be supplied.]
GetStringConstant | Returns the token of the given string in the module's constant pool.
GetSymWriter | Returns the symbol writer associated with this dynamic module.
GetType (inherited from Module) | Overloaded. [To be supplied.]
GetTypes (inherited from Module) | Returns all the classes defined within this module.
GetTypeToken | Overloaded. Returns a type token. Tokens are used in IL instructions to identify objects. Tokens are relative to the module in which they are contained. For example, the token value for a String is likely to be different in different modules. When GetTypeToken is called, a reference is added to the module. The reference becomes a permanent part of the module. Multiple calls to GetTypeToken with the same argument have no additional effect.
IsDefined (inherited from Module) | Determines if the attributeType is defined on this module.
IsTransient | Checks if this dynamic module is transient.
SetCustomAttribute | Overloaded. Sets a custom attribute.
SetEntryPoint | Overloaded. Sets the entry point of the module to the given method.
SetSymCustomAttribute | Sets the custom attribute that is stored with the symbolic information.
SetUserEntryPoint | Sets the user entry point.
ToString (inherited from Module) | Returns the name of the module.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetMethodImpl (inherited from Module) | To be supplied.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ModuleBuilder Class | System.Reflection.Emit Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ModuleBuilder Methods

The methods of the ModuleBuilder class are listed below. For a complete list of ModuleBuilder class members, see the ModuleBuilder Members topic.

Public:

CreateGlobalFunctions | Fixes up a dynamic module containing global functions.
DefineDocument | Define a document for source.
DefineEnum | Defines an enumeration type with that is a value type with a single non-static field called value__ of the specified type.
DefineGlobalMethod | Overloaded. Defines a global method.
DefineInitializedData | Defines initialized data field in the .sdata section of the PE file.
DefinePInvokeMethod | Overloaded. Defines a PInvoke method.
DefineResource | Overloaded. Defines a managed embedded resource to be stored in this module.
DefineType | Overloaded. Constructs a TypeBuilder.
DefineUninitializedData | Defines uninitialized data field in the .sdata section of the PE file.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FindTypes (inherited from Module) | Returns an array of classes accepted by the given filter and filter criteria.
GetArrayMethod | Returns the named method on an array class.
GetArrayMethodToken | Returns the token for the named method on an array class.
GetConstructorDefToken | Deprecated. Return the token defined in the original module for the ConstructorInfo.
GetConstructorToken | Returns the token used to identify the specified constructor within this module.
GetCustomAttributes (inherited from Module) | Overloaded. [To be supplied.]
GetField (inherited from Module) | Overloaded. [To be supplied.]
GetFields (inherited from Module) | To be supplied
GetFieldToken | Returns the token used to identify the specified field within this module.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetMethod (inherited from Module) | Overloaded. [To be supplied.]
GetMethodDefToken | Deprecated. Returns the token in the original module for the MethodInfo.
GetMethods (inherited from Module) | Returns an array of all of the global methods defined on the Module.
GetMethodToken | Returns the token used to identify the specified method within this module.
GetObjectData (inherited from Module) | [To be supplied.]
GetSignatureToken | Overloaded. Defines a signature token.
GetSignerCertificate (inherited from Module) | [To be supplied.]
GetStringConstant | Returns the token of the given string in the module's constant pool.
GetSymWriter | Returns the symbol writer associated with this dynamic module.
GetType (inherited from Module) | Overloaded. [To be supplied.]
GetTypes (inherited from Module) | Returns all the classes defined within this module.
GetTypeToken | Overloaded. Returns a type token. Tokens are used in IL instructions to identify objects. Tokens are relative to the module in which they are contained. For example, the token value for a String is likely to be different in different modules. When GetTypeToken is called, a reference is added to the module. The reference becomes a permanent part of the module. Multiple calls to GetTypeToken with the same argument have no additional effect.
IsDefined (inherited from Module) | Determines if the attributeType is defined on this module.
IsTransient | Checks if this dynamic module is transient.
SetCustomAttribute | Overloaded. Sets a custom attribute.
SetEntryPoint | Overloaded. Sets the entry point of the module to the given method.
SetSymCustomAttribute | Sets the custom attribute that is stored with the symbolic information.
SetUserEntryPoint | Sets the user entry point.
ToString (inherited from Module) | Returns the name of the module.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetMethodImpl (inherited from Module) | To be supplied.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ModuleBuilder Class | System.Reflection.Emit Namespace


ModuleBuilder.CreateGlobalFunctions

Fixes up a dynamic module containing global functions.

[Visual Basic]
Public Sub CreateGlobalFunctions()
[C#]
public void CreateGlobalFunctions();
[C++]
public: void CreateGlobalFunctions();
[JScript]
public function CreateGlobalFunctions();

Exceptions

Exception Type | Condition
InvalidOperationException | if this method was called previously

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace


ModuleBuilder.DefineDocument

Define a document for source.

[Visual Basic]
Public Function DefineDocument( _
   ByVal url As String, _
   ByVal language As Guid, _
   ByVal languageVendor As Guid, _
   ByVal documentType As Guid _
) As ISymbolDocumentWriter
[C#]
public ISymbolDocumentWriter DefineDocument(
   string url,
   Guid language,
   Guid languageVendor,
   Guid documentType
);
[C++]
public: ISymbolDocumentWriter* DefineDocument(
   String* url,
   Guid language,
   Guid languageVendor,
   Guid documentType
);
[JScript]
public function DefineDocument(
   url : String,
   language : Guid,
   languageVendor : Guid,
   documentType : Guid
) : ISymbolDocumentWriter;

Parameters

url
The URL for the document.
language
The GUID identifying the document language. This can be null.
languageVendor
The GUID identifying the document language vendor. This can be null.
documentType
The GUID identifying the document type. This can be null.

Return Value

An ISymbolDocumentWriter object representing the defined document.

Exceptions

Exception Type | Condition
ArgumentNullException | if url is a null reference (in Visual Basic Nothing)
InvalidOperationException | if this method is called on a dynamic module that is not a debug module.

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace


ModuleBuilder.DefineEnum

Defines an enumeration type with that is a value type with a single non-static field called value__ of the specified type.

[Visual Basic]
Public Function DefineEnum( _
   ByVal name As String, _
   ByVal visibility As TypeAttributes, _
   ByVal underlyingType As Type _
) As EnumBuilder
[C#]
public EnumBuilder DefineEnum(
   string name,
   TypeAttributes visibility,
   Type underlyingType
);
[C++]
public: EnumBuilder* DefineEnum(
   String* name,
   TypeAttributes visibility,
   Type* underlyingType
);
[JScript]
public function DefineEnum(
   name : String,
   visibility : TypeAttributes,
   underlyingType : Type
) : EnumBuilder;

Parameters

name
The full path name of the enumeration type.
visibility
[To be supplied.]
underlyingType
[To be supplied.]

Return Value

Returns the defined enumeration.

Exceptions

Exception Type | Condition
ArgumentException | if attributes other than visibility attributes are provided
ArgumentNullException | if name is a null reference (in Visual Basic Nothing)

Remarks

The ValueType attribute is set by default on the created type. The defined enum is a subclass of Enum. The defined field has Private and SpecialName set.

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace


ModuleBuilder.DefineGlobalMethod

Defines a global method.

Overload List

Defines a global method given its name, attributes, calling convention, return type, and parameter types.

[Visual Basic] Overloads Public Function DefineGlobalMethod(String, MethodAttributes, CallingConventions, Type, Type()) As MethodBuilder
[C#] public MethodBuilder DefineGlobalMethod(String, MethodAttributes, CallingConventions, Type, Type[]);
[C++] public: MethodBuilder* DefineGlobalMethod(String*, MethodAttributes, CallingConventions, Type, Type[]);
[JScript] public function DefineGlobalMethod(String, MethodAttributes, CallingConventions, Type, Type[]) : MethodBuilder;

Defines a global method given its name, attributes, return type, and parameter types.

[Visual Basic] Overloads Public Function DefineGlobalMethod(String, MethodAttributes, Type, Type()) As MethodBuilder
[C#] public MethodBuilder DefineGlobalMethod(String, MethodAttributes, Type, Type[]);
[C++] public: MethodBuilder* DefineGlobalMethod(String*, MethodAttributes, Type, Type[]);
[JScript] public function DefineGlobalMethod(String, MethodAttributes, Type, Type[]) : MethodBuilder;

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace


ModuleBuilder.DefineGlobalMethod (String, MethodAttributes, CallingConventions, Type, Type[])

Defines a global method given its name, attributes, calling convention, return type, and parameter types.

[Visual Basic]
Overloads Public Function DefineGlobalMethod( _
   ByVal name As String, _
   ByVal attributes As MethodAttributes, _
   ByVal callingConvention As CallingConventions, _
   ByVal returnType As Type, _
   ByVal parameterTypes() As Type _
) As MethodBuilder
[C#]
public MethodBuilder DefineGlobalMethod(
   string name,
   MethodAttributes attributes,
   CallingConventions callingConvention,
   Type returnType,
   Type[] parameterTypes
);
[C++]
public: MethodBuilder* DefineGlobalMethod(
   String* name,
   MethodAttributes attributes,
   CallingConventions callingConvention,
   Type* returnType,
   Type* parameterTypes[]
);
[JScript]
public function DefineGlobalMethod(
   name : String,
   attributes : MethodAttributes,
   callingConvention : CallingConventions,
   returnType : Type,
   parameterTypes : Type[]
) : MethodBuilder;

Parameters

name
The name of the method.
attributes
[To be supplied.]
callingConvention
[To be supplied.]
returnType
[To be supplied.]
parameterTypes
[To be supplied.]

Return Value

Returns the defined global method.

Exceptions

Exception Type | Condition
ArgumentException | if the method is not static
ArgumentNullException | if name is a null reference (in Visual Basic Nothing)
InvalidOperationException | if CreateGlobalFunctions has been previously called

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace | ModuleBuilder.DefineGlobalMethod Overload List


ModuleBuilder.DefineGlobalMethod (String, MethodAttributes, Type, Type[])

Defines a global method given its name, attributes, return type, and parameter types.

[Visual Basic]
Overloads Public Function DefineGlobalMethod( _
   ByVal name As String, _
   ByVal attributes As MethodAttributes, _
   ByVal returnType As Type, _
   ByVal parameterTypes() As Type _
) As MethodBuilder
[C#]
public MethodBuilder DefineGlobalMethod(
   string name,
   MethodAttributes attributes,
   Type returnType,
   Type[] parameterTypes
);
[C++]
public: MethodBuilder* DefineGlobalMethod(
   String* name,
   MethodAttributes attributes,
   Type* returnType,
   Type* parameterTypes[]
);
[JScript]
public function DefineGlobalMethod(
   name : String,
   attributes : MethodAttributes,
   returnType : Type,
   parameterTypes : Type[]
) : MethodBuilder;

Parameters

name
The name of the method.
attributes
[To be supplied.]
returnType
[To be supplied.]
parameterTypes
[To be supplied.]

Return Value

Returns the defined global method.

Exceptions

Exception Type | Condition
ArgumentException | if the method is not static
ArgumentNullException | if name is a null reference (in Visual Basic Nothing)
InvalidOperationException | if CreateGlobalFunctions has been previously called

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace | ModuleBuilder.DefineGlobalMethod Overload List


ModuleBuilder.DefineInitializedData

Defines initialized data field in the .sdata section of the PE file.

[Visual Basic]
Public Function DefineInitializedData( _
   ByVal name As String, _
   ByVal data() As Byte, _
   ByVal attributes As FieldAttributes _
) As FieldBuilder
[C#]
public FieldBuilder DefineInitializedData(
   string name,
   byte[] data,
   FieldAttributes attributes
);
[C++]
public: FieldBuilder* DefineInitializedData(
   String* name,
   unsigned char* data[],
   FieldAttributes attributes
);
[JScript]
public function DefineInitializedData(
   name : String,
   data : Byte[],
   attributes : FieldAttributes
) : FieldBuilder;

Parameters

name
The name used to refer to the data.
data
[To be supplied.]
attributes
[To be supplied.]

Return Value

A field to reference the data.

Exceptions

Exception Type | Condition
ArgumentNullException | if name is a null reference (in Visual Basic Nothing)
InvalidOperationException | if CreateGlobalFunctions has been previously called

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace


ModuleBuilder.DefinePInvokeMethod

Defines a PInvoke method.

Overload List

Defines a PInvoke method given its name, the name of the DLL in which the method is defined, the attributes of the method, the calling convention of the method, the return type of the method, the types of the parameters of the method, and the PInvoke flags.

[Visual Basic] Overloads Public Function DefinePInvokeMethod(String, String, MethodAttributes, CallingConventions, Type, Type(), PInvokeMap) As MethodBuilder
[C#] public MethodBuilder DefinePInvokeMethod(String, String, MethodAttributes, CallingConventions, Type, Type[], PInvokeMap);
[C++] public: MethodBuilder* DefinePInvokeMethod(String*, String*, MethodAttributes, CallingConventions, Type, Type[], PInvokeMap);
[JScript] public function DefinePInvokeMethod(String, String, MethodAttributes, CallingConventions, Type, Type[], PInvokeMap) : MethodBuilder;

Defines a PInvoke method given its name, the name of the DLL in which the method is defined, the attributes of the method, the calling convention of the method, the return type of the method, the types of the parameters of the method, and the PInvoke flags.

[Visual Basic] Overloads Public Function DefinePInvokeMethod(String, String, String, MethodAttributes, CallingConventions, Type, Type(), PInvokeMap) As MethodBuilder
[C#] public MethodBuilder DefinePInvokeMethod(String, String, String, MethodAttributes, CallingConventions, Type, Type[], PInvokeMap);
[C++] public: MethodBuilder* DefinePInvokeMethod(String*, String*, String*, MethodAttributes, CallingConventions, Type, Type[], PInvokeMap);
[JScript] public function DefinePInvokeMethod(String, String, String, MethodAttributes, CallingConventions, Type, Type[], PInvokeMap) : MethodBuilder;

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace


ModuleBuilder.DefinePInvokeMethod (String, String, MethodAttributes, CallingConventions, Type, Type[], PInvokeMap)

Defines a PInvoke method given its name, the name of the DLL in which the method is defined, the attributes of the method, the calling convention of the method, the return type of the method, the types of the parameters of the method, and the PInvoke flags.

[Visual Basic]
Overloads Public Function DefinePInvokeMethod( _
   ByVal name As String, _
   ByVal dllName As String, _
   ByVal attributes As MethodAttributes, _
   ByVal callingConvention As CallingConventions, _
   ByVal returnType As Type, _
   ByVal parameterTypes() As Type, _
   ByVal linkFlags As PInvokeMap _
) As MethodBuilder
[C#]
public MethodBuilder DefinePInvokeMethod(
   string name,
   string dllName,
   MethodAttributes attributes,
   CallingConventions callingConvention,
   Type returnType,
   Type[] parameterTypes,
   PInvokeMap linkFlags
);
[C++]
public: MethodBuilder* DefinePInvokeMethod(
   String* name,
   String* dllName,
   MethodAttributes attributes,
   CallingConventions callingConvention,
   Type* returnType,
   Type* parameterTypes[],
   PInvokeMap linkFlags
);
[JScript]
public function DefinePInvokeMethod(
   name : String,
   dllName : String,
   attributes : MethodAttributes,
   callingConvention : CallingConventions,
   returnType : Type,
   parameterTypes : Type[],
   linkFlags : PInvokeMap
) : MethodBuilder;

Parameters

name
The name of the PInvoke method.
dllName
[To be supplied.]
attributes
[To be supplied.]
callingConvention
[To be supplied.]
returnType
[To be supplied.]
parameterTypes
[To be supplied.]
linkFlags
[To be supplied.]

Return Value

The defined PInvoke method.

Exceptions

Exception Type | Condition
ArgumentException | if the method is not static or if the containing type is an interface or if the method is abstract of if the method was previously defined
ArgumentNullException | if name or dllName is a null reference (in Visual Basic Nothing)
InvalidOperationException | if the containing type has been previously created using CreateType

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace | ModuleBuilder.DefinePInvokeMethod Overload List


ModuleBuilder.DefinePInvokeMethod (String, String, String, MethodAttributes, CallingConventions, Type, Type[], PInvokeMap)

Defines a PInvoke method given its name, the name of the DLL in which the method is defined, the attributes of the method, the calling convention of the method, the return type of the method, the types of the parameters of the method, and the PInvoke flags.

[Visual Basic]
Overloads Public Function DefinePInvokeMethod( _
   ByVal name As String, _
   ByVal dllName As String, _
   ByVal entyrName As String, _
   ByVal attributes As MethodAttributes, _
   ByVal callingConvention As CallingConventions, _
   ByVal returnType As Type, _
   ByVal parameterTypes() As Type, _
   ByVal linkFlags As PInvokeMap _
) As MethodBuilder
[C#]
public MethodBuilder DefinePInvokeMethod(
   string name,
   string dllName,
   string entyrName,
   MethodAttributes attributes,
   CallingConventions callingConvention,
   Type returnType,
   Type[] parameterTypes,
   PInvokeMap linkFlags
);
[C++]
public: MethodBuilder* DefinePInvokeMethod(
   String* name,
   String* dllName,
   String* entyrName,
   MethodAttributes attributes,
   CallingConventions callingConvention,
   Type* returnType,
   Type* parameterTypes[],
   PInvokeMap linkFlags
);
[JScript]
public function DefinePInvokeMethod(
   name : String,
   dllName : String,
   entyrName : String,
   attributes : MethodAttributes,
   callingConvention : CallingConventions,
   returnType : Type,
   parameterTypes : Type[],
   linkFlags : PInvokeMap
) : MethodBuilder;

Parameters

name
The name of the PInvoke method.
dllName
The name of the DLL in which the PInvoke method is defined.
entyrName
The name of the entry point in the DLL.
attributes
The attributes of the method.
callingConvention
The method's calling convention.
returnType
The method's return type.
parameterTypes
The types of the method's parameters.
linkFlags
The PInvoke flags.

Return Value

The defined PInvoke method.

Exceptions

Exception Type | Condition
ArgumentException | if the method is not static or if the containing type is an interface or if the method is abstract of if the method was previously defined
ArgumentNullException | if name or dllName is a null reference (in Visual Basic Nothing)
InvalidOperationException | if the containing type has been previously created using CreateType

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace | ModuleBuilder.DefinePInvokeMethod Overload List


ModuleBuilder.DefineResource

Defines a managed embedded resource to be stored in this module.

Overload List

Defines the named managed embedded resource to be stored in this module.

[Visual Basic] Overloads Public Function DefineResource(String, String) As ResourceWriter
[C#] public ResourceWriter DefineResource(String, String);
[C++] public: ResourceWriter* DefineResource(String*, String*);
[JScript] public function DefineResource(String, String) : ResourceWriter;

Defines the named managed embedded resource with the given attributes that is to be stored in this module.

[Visual Basic] Overloads Public Function DefineResource(String, String, ResourceAttributes) As ResourceWriter
[C#] public ResourceWriter DefineResource(String, String, ResourceAttributes);
[C++] public: ResourceWriter* DefineResource(String*, String*, ResourceAttributes);
[JScript] public function DefineResource(String, String, ResourceAttributes) : ResourceWriter;

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace


ModuleBuilder.DefineResource (String, String)

Defines the named managed embedded resource to be stored in this module.

[Visual Basic]
Overloads Public Function DefineResource( _
   ByVal name As String, _
   ByVal description As String _
) As ResourceWriter
[C#]
public ResourceWriter DefineResource(
   string name,
   string description
);
[C++]
public: ResourceWriter* DefineResource(
   String* name,
   String* description
);
[JScript]
public function DefineResource(
   name : String,
   description : String
) : ResourceWriter;

Parameters

name
The name of the resource.
description
[To be supplied.]

Return Value

Returns a resource writer for the defined resource.

Exceptions

Exception Type | Condition
ArgumentNullException | if name is null
InvalidOperationException | if this module is transient or if the containing assembly is not persistable

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace | ModuleBuilder.DefineResource Overload List


ModuleBuilder.DefineResource (String, String, ResourceAttributes)

Defines the named managed embedded resource with the given attributes that is to be stored in this module.

[Visual Basic]
Overloads Public Function DefineResource( _
   ByVal name As String, _
   ByVal description As String, _
   ByVal attribute As ResourceAttributes _
) As ResourceWriter
[C#]
public ResourceWriter DefineResource(
   string name,
   string description,
   ResourceAttributes attribute
);
[C++]
public: ResourceWriter* DefineResource(
   String* name,
   String* description,
   ResourceAttributes attribute
);
[JScript]
public function DefineResource(
   name : String,
   description : String,
   attribute : ResourceAttributes
) : ResourceWriter;

Parameters

name
The name of the resource.
description
The description of the resource.
attribute
[To be supplied.]

Return Value

Returns a resource writer for the defined resource.

Exceptions

Exception Type | Condition
ArgumentNullException | if name is null
InvalidOperationException | if this module is transient or if the containing assembly is not persistable

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace | ModuleBuilder.DefineResource Overload List


ModuleBuilder.DefineType

Constructs a TypeBuilder.

Overload List

Constructs a TypeBuilder given type name, its attributes, and the type that the defined type extends.

[Visual Basic] Overloads Public Function DefineType(String, TypeAttributes, Type) As TypeBuilder
[C#] public TypeBuilder DefineType(String, TypeAttributes, Type);
[C++] public: TypeBuilder* DefineType(String*, TypeAttributes, Type);
[JScript] public function DefineType(String, TypeAttributes, Type) : TypeBuilder;

Constructs a TypeBuilder given the type name, attributes, the type that the defined type extends, and the interfaces that the defined type implements.

[Visual Basic] Overloads Public Function DefineType(String, TypeAttributes, Type, Type()) As TypeBuilder
[C#] public TypeBuilder DefineType(String, TypeAttributes, Type, Type[]);
[C++] public: TypeBuilder* DefineType(String*, TypeAttributes, Type, Type[]);
[JScript] public function DefineType(String, TypeAttributes, Type, Type[]) : TypeBuilder;

Constructs a TypeBuilder for a type with the specified name.

[Visual Basic] Overloads Public Function DefineType(String) As TypeBuilder
[C#] public TypeBuilder DefineType(String);
[C++] public: TypeBuilder* DefineType(String*);
[JScript] public function DefineType(String) : TypeBuilder;

Constructs a TypeBuilder given the type name and the type attributes.

[Visual Basic] Overloads Public Function DefineType(String, TypeAttributes) As TypeBuilder
[C#] public TypeBuilder DefineType(String, TypeAttributes);
[C++] public: TypeBuilder* DefineType(String*, TypeAttributes);
[JScript] public function DefineType(String, TypeAttributes) : TypeBuilder;

Constructs a TypeBuilder given the type name, the attributes, the type that the defined type extends, and the packing size of the type.

[Visual Basic] Overloads Public Function DefineType(String, TypeAttributes, Type, PackingSize) As TypeBuilder
[C#] public TypeBuilder DefineType(String, TypeAttributes, Type, PackingSize);
[C++] public: TypeBuilder* DefineType(String*, TypeAttributes, Type, PackingSize);
[JScript] public function DefineType(String, TypeAttributes, Type, PackingSize) : TypeBuilder;

Constructs a TypeBuilder given the type name, the attributes, the type that the defined type extends, and the total size of the type.

[Visual Basic] Overloads Public Function DefineType(String, TypeAttributes, Type, Integer) As TypeBuilder
[C#] public TypeBuilder DefineType(String, TypeAttributes, Type, int);
[C++] public: TypeBuilder* DefineType(String*, TypeAttributes, Type, int);
[JScript] public function DefineType(String, TypeAttributes, Type, int) : TypeBuilder;

Constructs a TypeBuilder given the type name, attributes, the type that the defined type extends, the packing size of the defined type, and the total size of the defined type.

[Visual Basic] Overloads Public Function DefineType(String, TypeAttributes, Type, PackingSize, Integer) As TypeBuilder
[C#] public TypeBuilder DefineType(String, TypeAttributes, Type, PackingSize, int);
[C++] public: TypeBuilder* DefineType(String*, TypeAttributes, Type, PackingSize, int);
[JScript] public function DefineType(String, TypeAttributes, Type, PackingSize, int) : TypeBuilder;

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace


ModuleBuilder.DefineType (String, TypeAttributes, Type)

Constructs a TypeBuilder given type name, its attributes, and the type that the defined type extends.

[Visual Basic]
Overloads Public Function DefineType( _
   ByVal name As String, _
   ByVal attr As TypeAttributes, _
   ByVal parent As Type _
) As TypeBuilder
[C#]
public TypeBuilder DefineType(
   string name,
   TypeAttributes attr,
   Type parent
);
[C++]
public: TypeBuilder* DefineType(
   String* name,
   TypeAttributes attr,
   Type* parent
);
[JScript]
public function DefineType(
   name : String,
   attr : TypeAttributes,
   parent : Type
) : TypeBuilder;

Parameters

name
The full path name of the type.
attr
The attribute to be associated with the type.
parent
[To be supplied.]

Return Value

Returns a TypeBuilder created with all of the requested attributes.

Exceptions

Exception Type | Condition
ArgumentException | if name is null.

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace | ModuleBuilder.DefineType Overload List


ModuleBuilder.DefineType (String, TypeAttributes, Type, Type[])

Constructs a TypeBuilder given the type name, attributes, the type that the defined type extends, and the interfaces that the defined type implements.

[Visual Basic]
Overloads Public Function DefineType( _
   ByVal name As String, _
   ByVal attr As TypeAttributes, _
   ByVal parent As Type, _
   ByVal interfaces() As Type _
) As TypeBuilder
[C#]
public TypeBuilder DefineType(
   string name,
   TypeAttributes attr,
   Type parent,
   Type[] interfaces
);
[C++]
public: TypeBuilder* DefineType(
   String* name,
   TypeAttributes attr,
   Type* parent,
   Type* interfaces[]
);
[JScript]
public function DefineType(
   name : String,
   attr : TypeAttributes,
   parent : Type,
   interfaces : Type[]
) : TypeBuilder;

Parameters

name
The full path name of the type.
attr
The attributes to be associated with the type.
parent
The Type that the defined type extends.
interfaces
The list of interfaces that the type implements.

Return Value

Returns a TypeBuilder created with all of the requested attributes.

Exceptions

Exception Type | Condition
ArgumentException | if name is null.

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace | ModuleBuilder.DefineType Overload List


ModuleBuilder.DefineType (String)

Constructs a TypeBuilder for a type with the specified name.

[Visual Basic]
Overloads Public Function DefineType( _
   ByVal name As String _
) As TypeBuilder
[C#]
public TypeBuilder DefineType(
   string name
);
[C++]
public: TypeBuilder* DefineType(
   String* name
);
[JScript]
public function DefineType(
   name : String
) : TypeBuilder;

Parameters

name
The full path name of the type.

Return Value

Returns the created TypeBuilder.

Exceptions

Exception Type | Condition
ArgumentException | if name is null.

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace | ModuleBuilder.DefineType Overload List


ModuleBuilder.DefineType (String, TypeAttributes)

Constructs a TypeBuilder given the type name and the type attributes.

[Visual Basic]
Overloads Public Function DefineType( _
   ByVal name As String, _
   ByVal attr As TypeAttributes _
) As TypeBuilder
[C#]
public TypeBuilder DefineType(
   string name,
   TypeAttributes attr
);
[C++]
public: TypeBuilder* DefineType(
   String* name,
   TypeAttributes attr
);
[JScript]
public function DefineType(
   name : String,
   attr : TypeAttributes
) : TypeBuilder;

Parameters

name
The full path name of the type.
attr
The attributes of the defined type.

Return Value

Returns a TypeBuilder created with all of the requested attributes.

Exceptions

Exception Type | Condition
ArgumentException | if name is null.

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace | ModuleBuilder.DefineType Overload List


ModuleBuilder.DefineType (String, TypeAttributes, Type, PackingSize)

Constructs a TypeBuilder given the type name, the attributes, the type that the defined type extends, and the packing size of the type.

[Visual Basic]
Overloads Public Function DefineType( _
   ByVal name As String, _
   ByVal attr As TypeAttributes, _
   ByVal parent As Type, _
   ByVal packsize As PackingSize _
) As TypeBuilder
[C#]
public TypeBuilder DefineType(
   string name,
   TypeAttributes attr,
   Type parent,
   PackingSize packsize
);
[C++]
public: TypeBuilder* DefineType(
   String* name,
   TypeAttributes attr,
   Type* parent,
   PackingSize packsize
);
[JScript]
public function DefineType(
   name : String,
   attr : TypeAttributes,
   parent : Type,
   packsize : PackingSize
) : TypeBuilder;

Parameters

name
The full path name of the type.
attr
The attributes of the defined type.
parent
The Type that the defined type extends.
packsize
The packing size of the type.

Return Value

Returns a TypeBuilder object.

Exceptions

Exception Type | Condition
ArgumentException | if name is null.

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace | ModuleBuilder.DefineType Overload List


ModuleBuilder.DefineType (String, TypeAttributes, Type, Int32)

Constructs a TypeBuilder given the type name, the attributes, the type that the defined type extends, and the total size of the type.

[Visual Basic]
Overloads Public Function DefineType( _
   ByVal name As String, _
   ByVal attr As TypeAttributes, _
   ByVal parent As Type, _
   ByVal typesize As Integer _
) As TypeBuilder
[C#]
public TypeBuilder DefineType(
   string name,
   TypeAttributes attr,
   Type parent,
   int typesize
);
[C++]
public: TypeBuilder* DefineType(
   String* name,
   TypeAttributes attr,
   Type* parent,
   int typesize
);
[JScript]
public function DefineType(
   name : String,
   attr : TypeAttributes,
   parent : Type,
   typesize : int
) : TypeBuilder;

Parameters

name
The full path name of the type.
attr
The attributes of the defined type.
parent
The Type that the defined type extends.
typesize
The total size of the type.

Return Value

Returns a TypeBuilder object.

Exceptions

Exception Type | Condition
ArgumentException | if name is null.

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace | ModuleBuilder.DefineType Overload List


ModuleBuilder.DefineType (String, TypeAttributes, Type, PackingSize, Int32)

Constructs a TypeBuilder given the type name, attributes, the type that the defined type extends, the packing size of the defined type, and the total size of the defined type.

[Visual Basic]
Overloads Public Function DefineType( _
   ByVal name As String, _
   ByVal attr As TypeAttributes, _
   ByVal parent As Type, _
   ByVal packingSize As PackingSize, _
   ByVal typesize As Integer _
) As TypeBuilder
[C#]
public TypeBuilder DefineType(
   string name,
   TypeAttributes attr,
   Type parent,
   PackingSize packingSize,
   int typesize
);
[C++]
public: TypeBuilder* DefineType(
   String* name,
   TypeAttributes attr,
   Type* parent,
   PackingSize packingSize,
   int typesize
);
[JScript]
public function DefineType(
   name : String,
   attr : TypeAttributes,
   parent : Type,
   packingSize : PackingSize,
   typesize : int
) : TypeBuilder;

Parameters

name
The full path name of the type.
attr
The attributes of the defined type.
parent
[To be supplied.]
packingSize
The packing size of the type.
typesize
The total size of the type.

Return Value

Returns a TypeBuilder created with all of the requested attributes.

Exceptions

Exception Type | Condition
ArgumentException | if name is null.

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace | ModuleBuilder.DefineType Overload List


ModuleBuilder.DefineUninitializedData

Defines uninitialized data field in the .sdata section of the PE file.

[Visual Basic]
Public Function DefineUninitializedData( _
   ByVal name As String, _
   ByVal size As Integer, _
   ByVal attributes As FieldAttributes _
) As FieldBuilder
[C#]
public FieldBuilder DefineUninitializedData(
   string name,
   int size,
   FieldAttributes attributes
);
[C++]
public: FieldBuilder* DefineUninitializedData(
   String* name,
   int size,
   FieldAttributes attributes
);
[JScript]
public function DefineUninitializedData(
   name : String,
   size : int,
   attributes : FieldAttributes
) : FieldBuilder;

Parameters

name
The name used to refer to the data.
size
The blob of data.
attributes
The attributes for the field.

Return Value

A field to reference the data.

Exceptions

Exception Type | Condition
ArgumentNullException | if name is a null reference (in Visual Basic Nothing)
InvalidOperationException | if CreateGlobalFunctions has been previously called

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace


ModuleBuilder.GetArrayMethod

Returns the named method on an array class.

[Visual Basic]
Public Function GetArrayMethod( _
   ByVal arrayClass As Type, _
   ByVal methodName As String, _
   ByVal callingConvention As CallingConventions, _
   ByVal returnType As Type, _
   ByVal parameterTypes() As Type _
) As MethodInfo
[C#]
public MethodInfo GetArrayMethod(
   Type arrayClass,
   string methodName,
   CallingConventions callingConvention,
   Type returnType,
   Type[] parameterTypes
);
[C++]
public: MethodInfo* GetArrayMethod(
   Type* arrayClass,
   String* methodName,
   CallingConventions callingConvention,
   Type* returnType,
   Type* parameterTypes[]
);
[JScript]
public function GetArrayMethod(
   arrayClass : Type,
   methodName : String,
   callingConvention : CallingConventions,
   returnType : Type,
   parameterTypes : Type[]
) : MethodInfo;

Parameters

arrayClass
An array class.
methodName
[To be supplied.]
callingConvention
[To be supplied.]
returnType
[To be supplied.]
parameterTypes
[To be supplied.]

Return Value

The named method on an array class.

Exceptions

Exception Type | Condition
ArgumentException | if arrayClass is not an array
ArgumentNullException | if arrayClass or methodName is a null reference (in Visual Basic Nothing)

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace


ModuleBuilder.GetArrayMethodToken

Returns the token for the named method on an array class.

[Visual Basic]
Public Function GetArrayMethodToken( _
   ByVal arrayClass As Type, _
   ByVal methodName As String, _
   ByVal callingConvention As CallingConventions, _
   ByVal returnType As Type, _
   ByVal parameterTypes() As Type _
) As MethodToken
[C#]
public MethodToken GetArrayMethodToken(
   Type arrayClass,
   string methodName,
   CallingConventions callingConvention,
   Type returnType,
   Type[] parameterTypes
);
[C++]
public: MethodToken GetArrayMethodToken(
   Type* arrayClass,
   String* methodName,
   CallingConventions callingConvention,
   Type* returnType,
   Type* parameterTypes[]
);
[JScript]
public function GetArrayMethodToken(
   arrayClass : Type,
   methodName : String,
   callingConvention : CallingConventions,
   returnType : Type,
   parameterTypes : Type[]
) : MethodToken;

Parameters

arrayClass
The Type object for the array.
methodName
A String containing the name of the method.
callingConvention
The calling convention for the method.
returnType
The return type of the method.
parameterTypes
The types of the parameters of the method.

Return Value

The token for the named method on an array class.

Exceptions

Exception Type | Condition
ArgumentException | if arrayClass is not an array
ArgumentNullException | if arrayClass or methodName is a null reference (in Visual Basic Nothing)

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace


ModuleBuilder.GetConstructorDefToken

Deprecated. Return the token defined in the original module for the ConstructorInfo.

[Visual Basic]
Public Function GetConstructorDefToken( _
   ByVal con As ConstructorInfo _
) As MethodToken
[C#]
public MethodToken GetConstructorDefToken(
   ConstructorInfo con
);
[C++]
public: MethodToken GetConstructorDefToken(
   ConstructorInfo* con
);
[JScript]
public function GetConstructorDefToken(
   con : ConstructorInfo
) : MethodToken;

Parameters

con
The constructor to get a token for.

Return Value

Returns the token of the constructor.

Exceptions

Exception Type | Condition
ArgumentNullException | if con is a null reference (in Visual Basic Nothing)

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace


ModuleBuilder.GetConstructorToken

Returns the token used to identify the specified constructor within this module.

[Visual Basic]
Public Function GetConstructorToken( _
   ByVal con As ConstructorInfo _
) As MethodToken
[C#]
public MethodToken GetConstructorToken(
   ConstructorInfo con
);
[C++]
public: MethodToken GetConstructorToken(
   ConstructorInfo* con
);
[JScript]
public function GetConstructorToken(
   con : ConstructorInfo
) : MethodToken;

Parameters

con
A ConstructorInfo object representing the constructor to get a token for.

Return Value

Returns the token used to identify the constructor represented by con within this module.

Exceptions

Exception Type | Condition
ArgumentNullException | if con is a null reference (in Visual Basic Nothing)

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace


ModuleBuilder.GetFieldToken

Returns the token used to identify the specified field within this module.

[Visual Basic]
Public Function GetFieldToken( _
   ByVal field As FieldInfo _
) As FieldToken
[C#]
public FieldToken GetFieldToken(
   FieldInfo field
);
[C++]
public: FieldToken GetFieldToken(
   FieldInfo* field
);
[JScript]
public function GetFieldToken(
   field : FieldInfo
) : FieldToken;

Parameters

field
A FieldInfo object representing the field to get a token for.

Return Value

Returns the token used to identify the field represented by con within this module.

Exceptions

Exception Type | Condition
ArgumentNullException | if con is a null reference (in Visual Basic Nothing)

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace


ModuleBuilder.GetMethodDefToken

Deprecated. Returns the token in the original module for the MethodInfo.

[Visual Basic]
Overridable Public Function GetMethodDefToken( _
   ByVal method As MethodInfo _
) As MethodToken
[C#]
public virtual MethodToken GetMethodDefToken(
   MethodInfo method
);
[C++]
public: virtual MethodToken GetMethodDefToken(
   MethodInfo* method
);
[JScript]
public function GetMethodDefToken(
   method : MethodInfo
) : MethodToken;

Parameters

method
The method for which the token is requested.

Return Value

The requested method token.

Exceptions

Exception Type | Condition
ArgumentNullException | if method is a null reference (in Visual Basic Nothing)
InvalidOperationException | if method is not defined in this module

Remarks

This method is obsolete and will be removed in a future release.

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace


ModuleBuilder.GetMethodToken

Returns the token used to identify the specified method within this module.

[Visual Basic]
Public Function GetMethodToken( _
   ByVal method As MethodInfo _
) As MethodToken
[C#]
public MethodToken GetMethodToken(
   MethodInfo method
);
[C++]
public: MethodToken GetMethodToken(
   MethodInfo* method
);
[JScript]
public function GetMethodToken(
   method : MethodInfo
) : MethodToken;

Parameters

method
A MethodToken object representing the method to get a token for.

Return Value

Returns the token used to identify the method represented by method within this module.

Exceptions

Exception Type | Condition
ArgumentNullException | if method is a null reference (in Visual Basic Nothing)

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace


ModuleBuilder.GetSignatureToken

Defines a signature token.

Overload List

Defines a signature token specified by the character array and signature length.

[Visual Basic] Overloads Public Function GetSignatureToken(Byte(), Integer) As SignatureToken
[C#] public SignatureToken GetSignatureToken(byte[], int);
[C++] public: SignatureToken GetSignatureToken(unsigned char*[], int);
[JScript] public function GetSignatureToken(Byte[], int) : SignatureToken;

Defines a signature token using the given SignatureHelper object

[Visual Basic] Overloads Public Function GetSignatureToken(SignatureHelper) As SignatureToken
[C#] public SignatureToken GetSignatureToken(SignatureHelper);
[C++] public: SignatureToken GetSignatureToken(SignatureHelper*);
[JScript] public function GetSignatureToken(SignatureHelper) : SignatureToken;

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace


ModuleBuilder.GetSignatureToken (Byte[], Int32)

Defines a signature token specified by the character array and signature length.

[Visual Basic]
Overloads Public Function GetSignatureToken( _
   ByVal sigBytes() As Byte, _
   ByVal sigLength As Integer _
) As SignatureToken
[C#]
public SignatureToken GetSignatureToken(
   byte[] sigBytes,
   int sigLength
);
[C++]
public: SignatureToken GetSignatureToken(
   unsigned char* sigBytes[],
   int sigLength
);
[JScript]
public function GetSignatureToken(
   sigBytes : Byte[],
   sigLength : int
) : SignatureToken;

Parameters

sigBytes
The signature blob.
sigLength
The length of the signature blob.

Return Value

A SignatureToken for the defined signature.

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace | ModuleBuilder.GetSignatureToken Overload List


ModuleBuilder.GetSignatureToken (SignatureHelper)

Defines a signature token using the given SignatureHelper object

[Visual Basic]
Overloads Public Function GetSignatureToken( _
   ByVal sigHelper As SignatureHelper _
) As SignatureToken
[C#]
public SignatureToken GetSignatureToken(
   SignatureHelper sigHelper
);
[C++]
public: SignatureToken GetSignatureToken(
   SignatureHelper* sigHelper
);
[JScript]
public function GetSignatureToken(
   sigHelper : SignatureHelper
) : SignatureToken;

Parameters

sigHelper
A reference to a SignatureHelper.

Return Value

A SignatureToken for the defined signature.

Exceptions

Exception Type | Condition
ArgumentNullException | if sigHelper is a null reference (in Visual Basic Nothing)

Remarks

This will define a metadata token for the signature described by SignatureHelper.

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace | ModuleBuilder.GetSignatureToken Overload List


ModuleBuilder.GetStringConstant

Returns the token of the given string in the module's constant pool.

[Visual Basic]
Public Function GetStringConstant( _
   ByVal str As String _
) As StringToken
[C#]
public StringToken GetStringConstant(
   string str
);
[C++]
public: StringToken GetStringConstant(
   String* str
);
[JScript]
public function GetStringConstant(
   str : String
) : StringToken;

Parameters

str
The String to add to the module's constant pool.

Return Value

Returns the StringToken of the string added to the constant pool.

Exceptions

Exception Type | Condition
ArgumentNullException | if str is a null reference (in Visual Basic Nothing)

Remarks

If str has already been defined, the existing token will be returned.

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace


ModuleBuilder.GetSymWriter

Returns the symbol writer associated with this dynamic module.

[Visual Basic]
Public Function GetSymWriter() As ISymbolWriter
[C#]
public ISymbolWriter GetSymWriter();
[C++]
public: ISymbolWriter* GetSymWriter();
[JScript]
public function GetSymWriter() : ISymbolWriter;

Return Value

Returns the symbol writer associated with this dynamic module.

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace


ModuleBuilder.GetType

Gets a type defined in the module.

Overload List

Gets the named type defined in the module given the base type of the type.

[Visual Basic] Overloads Public Function GetType(String, Type) As Type
[C#] public Type GetType(String, Type);
[C++] public: Type* GetType(String*, Type);
[JScript] public function GetType(String, Type) : Type;

Gets the named type defined in the module.

[Visual Basic] Overloads Overrides Public Function GetType(String) As Type
[C#] public override Type GetType(String);
[C++] public: override Type* GetType(String*);
[JScript] public override function GetType(String) : Type;

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace


ModuleBuilder.GetType (String, Type)

Gets the named type defined in the module given the base type of the type.

[Visual Basic]
Overloads Public Function GetType( _
   ByVal strFormat As String, _
   ByVal baseType As Type _
) As Type
[C#]
public Type GetType(
   string strFormat,
   Type baseType
);
[C++]
public: Type* GetType(
   String* strFormat,
   Type* baseType
);
[JScript]
public function GetType(
   strFormat : String,
   baseType : Type
) : Type;

Parameters

strFormat
The named type.
baseType
[To be supplied.]

Return Value

The requested type. Returns a null reference (in Visual Basic Nothing) if the type is not found.

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace | ModuleBuilder.GetType Overload List


ModuleBuilder.GetType (String)

Gets the named type defined in the module.

[Visual Basic]
Overloads Overrides Public Function GetType( _
   ByVal className As String _
) As Type
[C#]
public override Type GetType(
   string className
);
[C++]
public: override Type* GetType(
   String* className
);
[JScript]
public override function GetType(
   className : String
) : Type;

Parameters

className
Name of the type.

Return Value

The requested type. Returns a null reference (in Visual Basic Nothing) if the type is not found.

Exceptions

Exception Type | Condition
ArgumentNullException | if className is a null reference (Nothing)

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace | ModuleBuilder.GetType Overload List


ModuleBuilder.GetTypeToken

Returns a type token. Tokens are used in IL instructions to identify objects. Tokens are relative to the module in which they are contained. For example, the token value for a String is likely to be different in different modules. When GetTypeToken is called, a reference is added to the module. The reference becomes a permanent part of the module. Multiple calls to GetTypeToken with the same argument have no additional effect.

Overload List

Returns the token used to identify the specified type within this module.

[Visual Basic] Overloads Public Function GetTypeToken(Type) As TypeToken
[C#] public TypeToken GetTypeToken(Type);
[C++] public: TypeToken GetTypeToken(Type*);
[JScript] public function GetTypeToken(Type) : TypeToken;

Returns the token used to identify the type given its name.

[Visual Basic] Overloads Public Function GetTypeToken(String) As TypeToken
[C#] public TypeToken GetTypeToken(String);
[C++] public: TypeToken GetTypeToken(String*);
[JScript] public function GetTypeToken(String) : TypeToken;

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace


ModuleBuilder.GetTypeToken (Type)

Returns the token used to identify the specified type within this module.

[Visual Basic]
Overloads Public Function GetTypeToken( _
   ByVal type As Type _
) As TypeToken
[C#]
public TypeToken GetTypeToken(
   Type type
);
[C++]
public: TypeToken GetTypeToken(
   Type* type
);
[JScript]
public function GetTypeToken(
   type : Type
) : TypeToken;

Parameters

type
The Type object that represents the class type.

Return Value

Returns the TypeToken used to identify the given type within this module.

Exceptions

Exception Type | Condition
ArgumentNullException | if type is a null reference (in Visual Basic Nothing)
ArgumentException | if type is a ByRef

Remarks

Tokens are used in IL instructions to identify objects. Tokens are relative to the module in which they are contained. For example, the token value for String is likely to be different from module to module. When GetTypeToken is invoked, a reference is added to the module. The reference becomes a permanent part of the module; multiple calls with the same argument have no additional affect.

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace | ModuleBuilder.GetTypeToken Overload List


ModuleBuilder.GetTypeToken (String)

Returns the token used to identify the type given its name.

[Visual Basic]
Overloads Public Function GetTypeToken( _
   ByVal name As String _
) As TypeToken
[C#]
public TypeToken GetTypeToken(
   string name
);
[C++]
public: TypeToken GetTypeToken(
   String* name
);
[JScript]
public function GetTypeToken(
   name : String
) : TypeToken;

Parameters

name
A String representing the name of the class.

Return Value

Returns the TypeToken used to identify the type given by name within this module.

Exceptions

Exception Type | Condition
ArgumentNullException | if name is a null reference (in Visual Basic Nothing)
ArgumentException | if the type is a ByRef

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace | ModuleBuilder.GetTypeToken Overload List


ModuleBuilder.IsTransient

Checks if this dynamic module is transient.

[Visual Basic]
Public Function IsTransient() As Boolean
[C#]
public bool IsTransient();
[C++]
public: bool IsTransient();
[JScript]
public function IsTransient() : Boolean;

Return Value

Returns true if this dynamic module is transient, otherwise returns false.

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace


ModuleBuilder.SetCustomAttribute

Sets a custom attribute.

Overload List

Set a custom attribute using a custom attribute builder.

[Visual Basic] Overloads Public Sub SetCustomAttribute(CustomAttributeBuilder)
[C#] public void SetCustomAttribute(CustomAttributeBuilder);
[C++] public: void SetCustomAttribute(CustomAttributeBuilder*);
[JScript] public function SetCustomAttribute(CustomAttributeBuilder);

Set a custom attribute using a specified custom attribute blob.

[Visual Basic] Overloads Public Sub SetCustomAttribute(ConstructorInfo, Byte())
[C#] public void SetCustomAttribute(ConstructorInfo, byte[]);
[C++] public: void SetCustomAttribute(ConstructorInfo*, unsigned char[]);
[JScript] public function SetCustomAttribute(ConstructorInfo, Byte[]);

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace


ModuleBuilder.SetCustomAttribute (CustomAttributeBuilder)

Set a custom attribute using a custom attribute builder.

[Visual Basic]
Overloads Public Sub SetCustomAttribute( _
   ByVal customBuilder As CustomAttributeBuilder _
)
[C#]
public void SetCustomAttribute(
   CustomAttributeBuilder customBuilder
);
[C++]
public: void SetCustomAttribute(
   CustomAttributeBuilder* customBuilder
);
[JScript]
public function SetCustomAttribute(
   customBuilder : CustomAttributeBuilder
);

Parameters

customBuilder
An instance of a helper class to define the custom attribute.

Exceptions

Exception Type | Condition
ArgumentNullException | if con is a null reference (in Visual Basic Nothing)

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace | ModuleBuilder.SetCustomAttribute Overload List


ModuleBuilder.SetCustomAttribute (ConstructorInfo, Byte[])

Set a custom attribute using a specified custom attribute blob.

[Visual Basic]
Overloads Public Sub SetCustomAttribute( _
   ByVal con As ConstructorInfo, _
   ByVal binaryAttribute() As Byte _
)
[C#]
public void SetCustomAttribute(
   ConstructorInfo con,
   byte[] binaryAttribute
);
[C++]
public: void SetCustomAttribute(
   ConstructorInfo* con,
   unsigned char* binaryAttribute[]
);
[JScript]
public function SetCustomAttribute(
   con : ConstructorInfo,
   binaryAttribute : Byte[]
);

Parameters

con
The constructor for the custom attribute.
binaryAttribute
A byte blob representing the attributes.

Exceptions

Exception Type | Condition
ArgumentNullException | if con or binaryAttribute is a null reference (in Visual Basic Nothing)

Remarks

See the for details on how to format binaryAttribute.

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace | ModuleBuilder.SetCustomAttribute Overload List


ModuleBuilder.SetEntryPoint

Sets the entry point of the module to the given method.

Overload List

Sets the entry point of the module to the given method given the type of the PE file.

[Visual Basic] Overloads Public Sub SetEntryPoint(MethodInfo, PEFileKinds)
[C#] public void SetEntryPoint(MethodInfo, PEFileKinds);
[C++] public: void SetEntryPoint(MethodInfo*, PEFileKinds);
[JScript] public function SetEntryPoint(MethodInfo, PEFileKinds);

Sets the entry point of the module to the given method.

[Visual Basic] Overloads Public Sub SetEntryPoint(MethodInfo)
[C#] public void SetEntryPoint(MethodInfo);
[C++] public: void SetEntryPoint(MethodInfo*);
[JScript] public function SetEntryPoint(MethodInfo);

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace


ModuleBuilder.SetEntryPoint (MethodInfo, PEFileKinds)

Sets the entry point of the module to the given method given the type of the PE file.

[Visual Basic]
Overloads Public Sub SetEntryPoint( _
   ByVal entryPoint As MethodInfo, _
   ByVal fileKind As PEFileKinds _
)
[C#]
public void SetEntryPoint(
   MethodInfo entryPoint,
   PEFileKinds fileKind
);
[C++]
public: void SetEntryPoint(
   MethodInfo* entryPoint,
   PEFileKinds fileKind
);
[JScript]
public function SetEntryPoint(
   entryPoint : MethodInfo,
   fileKind : PEFileKinds
);

Parameters

entryPoint
The method that is the entry point to the module.
fileKind
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentNullException | if entryPoint is a null reference (in Visual Basic Nothing)

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace | ModuleBuilder.SetEntryPoint Overload List


ModuleBuilder.SetEntryPoint (MethodInfo)

Sets the entry point of the module to the given method.

[Visual Basic]
Overloads Public Sub SetEntryPoint( _
   ByVal entryPoint As MethodInfo _
)
[C#]
public void SetEntryPoint(
   MethodInfo entryPoint
);
[C++]
public: void SetEntryPoint(
   MethodInfo* entryPoint
);
[JScript]
public function SetEntryPoint(
   entryPoint : MethodInfo
);

Parameters

entryPoint
The method that is the entry point to the module.

Exceptions

Exception Type | Condition
ArgumentNullException | if entryPoint is a null reference (in Visual Basic Nothing)

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace | ModuleBuilder.SetEntryPoint Overload List


ModuleBuilder.SetSymCustomAttribute

Sets the custom attribute that is stored with the symbolic information.

[Visual Basic]
Public Sub SetSymCustomAttribute( _
   ByVal name As String, _
   ByVal data() As Byte _
)
[C#]
public void SetSymCustomAttribute(
   string name,
   byte[] data
);
[C++]
public: void SetSymCustomAttribute(
   String* name,
   unsigned char* data[]
);
[JScript]
public function SetSymCustomAttribute(
   name : String,
   data : Byte[]
);

Parameters

name
The name of the custom attribute
data
[To be supplied.]

Exceptions

Exception Type | Condition
ArgumentNullException | if url is a null reference (in Visual Basic Nothing)
InvalidOperationException | if this method is called on a dynamic module that is not a debug module.

Remarks

The custom attribute that is set by this method is associated only with the symbolic information written by the symbol writer and is different from the custom attribute set using the SetCustomAttribute method.

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace


ModuleBuilder.SetUserEntryPoint

Sets the user entry point.

[Visual Basic]
Public Sub SetUserEntryPoint( _
   ByVal entryPoint As MethodInfo _
)
[C#]
public void SetUserEntryPoint(
   MethodInfo entryPoint
);
[C++]
public: void SetUserEntryPoint(
   MethodInfo* entryPoint
);
[JScript]
public function SetUserEntryPoint(
   entryPoint : MethodInfo
);

Parameters

entryPoint
The user entry point.

Exceptions

Exception Type | Condition
ArgumentNullException | if entryPoint is a null reference (in Visual Basic Nothing)
InvalidOperationException | if this method is called on a dynamic module that is not a debug module or if entryPoint is not contained in this dynamic module

Remarks

The compiler may generate a startup stub before calling user main. The startup stub will be the entry point. While the user "main" will be the user entry point so that debugger will not step into the compiler entry point.

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

ModuleBuilder Class | ModuleBuilder Members | System.Reflection.Emit Namespace


OpCode Structure

Describes an IL instruction.

Object
ValueType
OpCode

[Visual Basic]
Public Structure OpCode
[C#]
public struct OpCode
[C++]
public __value struct OpCode

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

OpCode Members | System.Reflection.Emit Namespace


OpCode Members

Public:

Properties

FlowControl | Describes the type of flow control.
Name | The name of the IL instruction.
OpCodeType | The type of IL instruction.
OperandType | The operand type of an IL instruction.
Size | The size of the IL instruction.
StackBehaviourPop | How the IL instruction pops the stack.
StackBehaviourPush | How the IL instruction pushes operand onto the stack.
Value | The value of the immediate operand of the IL instruction.

Methods

Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OpCode Structure | System.Reflection.Emit Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

OpCode Properties

The properties of the OpCode structure are listed below. For a complete list of OpCode structure members, see the OpCode Members topic.

Public:

FlowControl | Describes the type of flow control.
Name | The name of the IL instruction.
OpCodeType | The type of IL instruction.
OperandType | The operand type of an IL instruction.
Size | The size of the IL instruction.
StackBehaviourPop | How the IL instruction pops the stack.
StackBehaviourPush | How the IL instruction pushes operand onto the stack.
Value | The value of the immediate operand of the IL instruction.

See Also

OpCode Structure | System.Reflection.Emit Namespace


OpCode.FlowControl

Describes the type of flow control.

[Visual Basic]
Public ReadOnly Property FlowControl As FlowControl
[C#]
public FlowControl FlowControl {get;}
[C++]
public: __property FlowControl get_FlowControl();
[JScript]
public function get FlowControl() : FlowControl;

Property Value

Read-only. The type of flow control.

See Also

OpCode Structure | OpCode Members | System.Reflection.Emit Namespace


OpCode.Name

The name of the IL instruction.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}
[C++]
public: __property String* get_Name();
[JScript]
public function get Name() : String;

Property Value

Read-only. The name of the IL instruction.

See Also

OpCode Structure | OpCode Members | System.Reflection.Emit Namespace


OpCode.OpCodeType

The type of IL instruction.

[Visual Basic]
Public ReadOnly Property OpCodeType As OpCodeType
[C#]
public OpCodeType OpCodeType {get;}
[C++]
public: __property OpCodeType get_OpCodeType();
[JScript]
public function get OpCodeType() : OpCodeType;

Property Value

Read-only. The type of IL instruction.

See Also

OpCode Structure | OpCode Members | System.Reflection.Emit Namespace


OpCode.OperandType

The operand type of an IL instruction.

[Visual Basic]
Public ReadOnly Property OperandType As OperandType
[C#]
public OperandType OperandType {get;}
[C++]
public: __property OperandType get_OperandType();
[JScript]
public function get OperandType() : OperandType;

Property Value

Read-only. The operand type of an IL instruction.

See Also

OpCode Structure | OpCode Members | System.Reflection.Emit Namespace


OpCode.Size

The size of the IL instruction.

[Visual Basic]
Public ReadOnly Property Size As Integer
[C#]
public int Size {get;}
[C++]
public: __property int get_Size();
[JScript]
public function get Size() : int;

Property Value

Read-only. The size of the IL instruction.

See Also

OpCode Structure | OpCode Members | System.Reflection.Emit Namespace


OpCode.StackBehaviourPop

How the IL instruction pops the stack.

[Visual Basic]
Public ReadOnly Property StackBehaviourPop As StackBehaviour
[C#]
public StackBehaviour StackBehaviourPop {get;}
[C++]
public: __property StackBehaviour get_StackBehaviourPop();
[JScript]
public function get StackBehaviourPop() : StackBehaviour;

Property Value

Read-only. How the IL instruction pops the stack.

See Also

OpCode Structure | OpCode Members | System.Reflection.Emit Namespace


OpCode.StackBehaviourPush

How the IL instruction pushes operand onto the stack.

[Visual Basic]
Public ReadOnly Property StackBehaviourPush As StackBehaviour
[C#]
public StackBehaviour StackBehaviourPush {get;}
[C++]
public: __property StackBehaviour get_StackBehaviourPush();
[JScript]
public function get StackBehaviourPush() : StackBehaviour;

Property Value

Read-only. How the IL instruction pushes operand onto the stack.

See Also

OpCode Structure | OpCode Members | System.Reflection.Emit Namespace


OpCode.Value

The value of the immediate operand of the IL instruction.

[Visual Basic]
Public ReadOnly Property Value As Short
[C#]
public short Value {get;}
[C++]
public: __property short get_Value();
[JScript]
public function get Value() : Int16;

Property Value

Read-only. The value of the immediate operand of the IL instruction.

See Also

OpCode Structure | OpCode Members | System.Reflection.Emit Namespace


OpCodes Class

The IL instruction opcodes supported by the runtime. The IL Instruction Specification describes each Opcode.

Object
OpCodes

[Visual Basic]
Public Class OpCodes
[C#]
public class OpCodes
[C++]
public __gc class OpCodes
[JScript]
public class OpCodes

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

OpCodes Members | System.Reflection.Emit Namespace | TBD


OpCodes Members

Public:

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
TakesSingleByteArgument | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

Add | [To be supplied.]
Add_Ovf | [To be supplied.]
Add_Ovf_Un | [To be supplied.]
And | [To be supplied.]
Ann_Call | [To be supplied.]
Ann_Catch | [To be supplied.]
Ann_Data | [To be supplied.]
Ann_Data_S | [To be supplied.]
Ann_Dead | [To be supplied.]
Ann_Def | [To be supplied.]
Ann_Hoisted | [To be supplied.]
Ann_Hoisted_Call | [To be supplied.]
Ann_Lab | [To be supplied.]
Ann_Live | [To be supplied.]
Ann_Phi | [To be supplied.]
Ann_Ref | [To be supplied.]
Ann_Ref_S | [To be supplied.]
Arglist | [To be supplied.]
Beq | [To be supplied.]
Beq_S | [To be supplied.]
Bge | [To be supplied.]
Bge_S | [To be supplied.]
Bge_Un | [To be supplied.]
Bge_Un_S | [To be supplied.]
Bgt | [To be supplied.]
Bgt_S | [To be supplied.]
Bgt_Un | [To be supplied.]
Bgt_Un_S | [To be supplied.]
Ble | [To be supplied.]
Ble_S | [To be supplied.]
Ble_Un | [To be supplied.]
Ble_Un_S | [To be supplied.]
Blt | [To be supplied.]
Blt_S | [To be supplied.]
Blt_Un | [To be supplied.]
Blt_Un_S | [To be supplied.]
Bne_Un | [To be supplied.]
Bne_Un_S | [To be supplied.]
Box | [To be supplied.]
Br | [To be supplied.]
Break | [To be supplied.]
Brfalse | [To be supplied.]
Brfalse_S | [To be supplied.]
Brtrue | [To be supplied.]
Brtrue_S | [To be supplied.]
Br_S | [To be supplied.]
Call | [To be supplied.]
Calli | [To be supplied.]
Callvirt | [To be supplied.]
Castclass | [To be supplied.]
Ceq | [To be supplied.]
Cgt | [To be supplied.]
Cgt_Un | [To be supplied.]
Ckfinite | [To be supplied.]
Clt | [To be supplied.]
Clt_Un | [To be supplied.]
Conv_I | [To be supplied.]
Conv_I1 | [To be supplied.]
Conv_I2 | [To be supplied.]
Conv_I4 | [To be supplied.]
Conv_I8 | [To be supplied.]
Conv_Ovf_I | [To be supplied.]
Conv_Ovf_I1 | [To be supplied.]
Conv_Ovf_I1_Un | [To be supplied.]
Conv_Ovf_I2 | [To be supplied.]
Conv_Ovf_I2_Un | [To be supplied.]
Conv_Ovf_I4 | [To be supplied.]
Conv_Ovf_I4_Un | [To be supplied.]
Conv_Ovf_I8 | [To be supplied.]
Conv_Ovf_I8_Un | [To be supplied.]
Conv_Ovf_I_Un | [To be supplied.]
Conv_Ovf_U | [To be supplied.]
Conv_Ovf_U1 | [To be supplied.]
Conv_Ovf_U1_Un | [To be supplied.]
Conv_Ovf_U2 | [To be supplied.]
Conv_Ovf_U2_Un | [To be supplied.]
Conv_Ovf_U4 | [To be supplied.]
Conv_Ovf_U4_Un | [To be supplied.]
Conv_Ovf_U8 | [To be supplied.]
Conv_Ovf_U8_Un | [To be supplied.]
Conv_Ovf_U_Un | [To be supplied.]
Conv_R4 | [To be supplied.]
Conv_R8 | [To be supplied.]
Conv_R_Un | [To be supplied.]
Conv_U | [To be supplied.]
Conv_U1 | [To be supplied.]
Conv_U2 | [To be supplied.]
Conv_U4 | [To be supplied.]
Conv_U8 | [To be supplied.]
Cpblk | [To be supplied.]
Cpobj | [To be supplied.]
Deprecated_Ann_Arg | [To be supplied.]
Deprecated_Endcatch | [To be supplied.]
Div | [To be supplied.]
Div_Un | [To be supplied.]
Dup | [To be supplied.]
Endfilter | [To be supplied.]
Endfinally | [To be supplied.]
Fromproxy | [To be supplied.]
Initblk | [To be supplied.]
Initobj | [To be supplied.]
Isinst | [To be supplied.]
Jmp | [To be supplied.]
Jmpi | [To be supplied.]
Ldarg | [To be supplied.]
Ldarga | [To be supplied.]
Ldarga_S | [To be supplied.]
Ldarg_0 | [To be supplied.]
Ldarg_1 | [To be supplied.]
Ldarg_2 | [To be supplied.]
Ldarg_3 | [To be supplied.]
Ldarg_S | [To be supplied.]
Ldc_I4 | [To be supplied.]
Ldc_I4_0 | [To be supplied.]
Ldc_I4_1 | [To be supplied.]
Ldc_I4_2 | [To be supplied.]
Ldc_I4_3 | [To be supplied.]
Ldc_I4_4 | [To be supplied.]
Ldc_I4_5 | [To be supplied.]
Ldc_I4_6 | [To be supplied.]
Ldc_I4_7 | [To be supplied.]
Ldc_I4_8 | [To be supplied.]
Ldc_I4_M1 | [To be supplied.]
Ldc_I4_S | [To be supplied.]
Ldc_I8 | [To be supplied.]
Ldc_R4 | [To be supplied.]
Ldc_R8 | [To be supplied.]
Ldelema | [To be supplied.]
Ldelem_I | [To be supplied.]
Ldelem_I1 | [To be supplied.]
Ldelem_I2 | [To be supplied.]
Ldelem_I4 | [To be supplied.]
Ldelem_I8 | [To be supplied.]
Ldelem_R4 | [To be supplied.]
Ldelem_R8 | [To be supplied.]
Ldelem_Ref | [To be supplied.]
Ldelem_U1 | [To be supplied.]
Ldelem_U2 | [To be supplied.]
Ldelem_U4 | [To be supplied.]
Ldfld | [To be supplied.]
Ldflda | [To be supplied.]
Ldftn | [To be supplied.]
Ldind_I | [To be supplied.]
Ldind_I1 | [To be supplied.]
Ldind_I2 | [To be supplied.]
Ldind_I4 | [To be supplied.]
Ldind_I8 | [To be supplied.]
Ldind_R4 | [To be supplied.]
Ldind_R8 | [To be supplied.]
Ldind_Ref | [To be supplied.]
Ldind_U1 | [To be supplied.]
Ldind_U2 | [To be supplied.]
Ldind_U4 | [To be supplied.]
Ldlen | [To be supplied.]
Ldloc | [To be supplied.]
Ldloca | [To be supplied.]
Ldloca_S | [To be supplied.]
Ldloc_0 | [To be supplied.]
Ldloc_1 | [To be supplied.]
Ldloc_2 | [To be supplied.]
Ldloc_3 | [To be supplied.]
Ldloc_S | [To be supplied.]
Ldnull | [To be supplied.]
Ldobj | [To be supplied.]
Ldptr | [To be supplied.]
Ldsfld | [To be supplied.]
Ldsflda | [To be supplied.]
Ldstr | [To be supplied.]
Ldtoken | [To be supplied.]
Ldvirtftn | [To be supplied.]
Leave | [To be supplied.]
Leave_S | [To be supplied.]
Localloc | [To be supplied.]
Mkrefany | [To be supplied.]
Mul | [To be supplied.]
Mul_Ovf | [To be supplied.]
Mul_Ovf_Un | [To be supplied.]
Neg | [To be supplied.]
Newarr | [To be supplied.]
Newobj | [To be supplied.]
Nop | [To be supplied.]
Not | [To be supplied.]
Or | [To be supplied.]
Pop | [To be supplied.]
Prefix1 | [To be supplied.]
Prefix2 | [To be supplied.]
Prefix3 | [To be supplied.]
Prefix4 | [To be supplied.]
Prefix5 | [To be supplied.]
Prefix6 | [To be supplied.]
Prefix7 | [To be supplied.]
Prefixref | [To be supplied.]
Refanytype | [To be supplied.]
Refanyval | [To be supplied.]
Rem | [To be supplied.]
Rem_Un | [To be supplied.]
Ret | [To be supplied.]
Rethrow | [To be supplied.]
Shl | [To be supplied.]
Shr | [To be supplied.]
Shr_Un | [To be supplied.]
Sizeof | [To be supplied.]
Starg | [To be supplied.]
Starg_S | [To be supplied.]
Stelem_I | [To be supplied.]
Stelem_I1 | [To be supplied.]
Stelem_I2 | [To be supplied.]
Stelem_I4 | [To be supplied.]
Stelem_I8 | [To be supplied.]
Stelem_R4 | [To be supplied.]
Stelem_R8 | [To be supplied.]
Stelem_Ref | [To be supplied.]
Stfld | [To be supplied.]
Stind_I | [To be supplied.]
Stind_I1 | [To be supplied.]
Stind_I2 | [To be supplied.]
Stind_I4 | [To be supplied.]
Stind_I8 | [To be supplied.]
Stind_R4 | [To be supplied.]
Stind_R8 | [To be supplied.]
Stind_Ref | [To be supplied.]
Stloc | [To be supplied.]
Stloc_0 | [To be supplied.]
Stloc_1 | [To be supplied.]
Stloc_2 | [To be supplied.]
Stloc_3 | [To be supplied.]
Stloc_S | [To be supplied.]
Stobj | [To be supplied.]
Stsfld | [To be supplied.]
Sub | [To be supplied.]
Sub_Ovf | [To be supplied.]
Sub_Ovf_Un | [To be supplied.]
Switch | [To be supplied.]
Tailcall | [To be supplied.]
Throw | [To be supplied.]
Toproxy | [To be supplied.]
Unaligned | [To be supplied.]
Unbox | [To be supplied.]
Volatile | [To be supplied.]
Xor | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OpCodes Class | System.Reflection.Emit Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

OpCodes Methods

The methods of the OpCodes class are listed below. For a complete list of OpCodes class members, see the OpCodes Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
TakesSingleByteArgument | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OpCodes Class | System.Reflection.Emit Namespace


OpCodes.TakesSingleByteArgument

[To be supplied.]

[Visual Basic]
Public Shared Function TakesSingleByteArgument( _
   ByVal inst As OpCode _
) As Boolean
[C#]
public static bool TakesSingleByteArgument(
   OpCode inst
);
[C++]
public: static bool TakesSingleByteArgument(
   OpCode inst
);
[JScript]
public static function TakesSingleByteArgument(
   inst : OpCode
) : Boolean;

Parameters

inst
[To be supplied.]

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

OpCodes Fields

The fields of the OpCodes class are listed below. For a complete list of OpCodes class members, see the OpCodes Members topic.

Public:

Add | [To be supplied.]
Add_Ovf | [To be supplied.]
Add_Ovf_Un | [To be supplied.]
And | [To be supplied.]
Ann_Call | [To be supplied.]
Ann_Catch | [To be supplied.]
Ann_Data | [To be supplied.]
Ann_Data_S | [To be supplied.]
Ann_Dead | [To be supplied.]
Ann_Def | [To be supplied.]
Ann_Hoisted | [To be supplied.]
Ann_Hoisted_Call | [To be supplied.]
Ann_Lab | [To be supplied.]
Ann_Live | [To be supplied.]
Ann_Phi | [To be supplied.]
Ann_Ref | [To be supplied.]
Ann_Ref_S | [To be supplied.]
Arglist | [To be supplied.]
Beq | [To be supplied.]
Beq_S | [To be supplied.]
Bge | [To be supplied.]
Bge_S | [To be supplied.]
Bge_Un | [To be supplied.]
Bge_Un_S | [To be supplied.]
Bgt | [To be supplied.]
Bgt_S | [To be supplied.]
Bgt_Un | [To be supplied.]
Bgt_Un_S | [To be supplied.]
Ble | [To be supplied.]
Ble_S | [To be supplied.]
Ble_Un | [To be supplied.]
Ble_Un_S | [To be supplied.]
Blt | [To be supplied.]
Blt_S | [To be supplied.]
Blt_Un | [To be supplied.]
Blt_Un_S | [To be supplied.]
Bne_Un | [To be supplied.]
Bne_Un_S | [To be supplied.]
Box | [To be supplied.]
Br | [To be supplied.]
Break | [To be supplied.]
Brfalse | [To be supplied.]
Brfalse_S | [To be supplied.]
Brtrue | [To be supplied.]
Brtrue_S | [To be supplied.]
Br_S | [To be supplied.]
Call | [To be supplied.]
Calli | [To be supplied.]
Callvirt | [To be supplied.]
Castclass | [To be supplied.]
Ceq | [To be supplied.]
Cgt | [To be supplied.]
Cgt_Un | [To be supplied.]
Ckfinite | [To be supplied.]
Clt | [To be supplied.]
Clt_Un | [To be supplied.]
Conv_I | [To be supplied.]
Conv_I1 | [To be supplied.]
Conv_I2 | [To be supplied.]
Conv_I4 | [To be supplied.]
Conv_I8 | [To be supplied.]
Conv_Ovf_I | [To be supplied.]
Conv_Ovf_I1 | [To be supplied.]
Conv_Ovf_I1_Un | [To be supplied.]
Conv_Ovf_I2 | [To be supplied.]
Conv_Ovf_I2_Un | [To be supplied.]
Conv_Ovf_I4 | [To be supplied.]
Conv_Ovf_I4_Un | [To be supplied.]
Conv_Ovf_I8 | [To be supplied.]
Conv_Ovf_I8_Un | [To be supplied.]
Conv_Ovf_I_Un | [To be supplied.]
Conv_Ovf_U | [To be supplied.]
Conv_Ovf_U1 | [To be supplied.]
Conv_Ovf_U1_Un | [To be supplied.]
Conv_Ovf_U2 | [To be supplied.]
Conv_Ovf_U2_Un | [To be supplied.]
Conv_Ovf_U4 | [To be supplied.]
Conv_Ovf_U4_Un | [To be supplied.]
Conv_Ovf_U8 | [To be supplied.]
Conv_Ovf_U8_Un | [To be supplied.]
Conv_Ovf_U_Un | [To be supplied.]
Conv_R4 | [To be supplied.]
Conv_R8 | [To be supplied.]
Conv_R_Un | [To be supplied.]
Conv_U | [To be supplied.]
Conv_U1 | [To be supplied.]
Conv_U2 | [To be supplied.]
Conv_U4 | [To be supplied.]
Conv_U8 | [To be supplied.]
Cpblk | [To be supplied.]
Cpobj | [To be supplied.]
Deprecated_Ann_Arg | [To be supplied.]
Deprecated_Endcatch | [To be supplied.]
Div | [To be supplied.]
Div_Un | [To be supplied.]
Dup | [To be supplied.]
Endfilter | [To be supplied.]
Endfinally | [To be supplied.]
Fromproxy | [To be supplied.]
Initblk | [To be supplied.]
Initobj | [To be supplied.]
Isinst | [To be supplied.]
Jmp | [To be supplied.]
Jmpi | [To be supplied.]
Ldarg | [To be supplied.]
Ldarga | [To be supplied.]
Ldarga_S | [To be supplied.]
Ldarg_0 | [To be supplied.]
Ldarg_1 | [To be supplied.]
Ldarg_2 | [To be supplied.]
Ldarg_3 | [To be supplied.]
Ldarg_S | [To be supplied.]
Ldc_I4 | [To be supplied.]
Ldc_I4_0 | [To be supplied.]
Ldc_I4_1 | [To be supplied.]
Ldc_I4_2 | [To be supplied.]
Ldc_I4_3 | [To be supplied.]
Ldc_I4_4 | [To be supplied.]
Ldc_I4_5 | [To be supplied.]
Ldc_I4_6 | [To be supplied.]
Ldc_I4_7 | [To be supplied.]
Ldc_I4_8 | [To be supplied.]
Ldc_I4_M1 | [To be supplied.]
Ldc_I4_S | [To be supplied.]
Ldc_I8 | [To be supplied.]
Ldc_R4 | [To be supplied.]
Ldc_R8 | [To be supplied.]
Ldelema | [To be supplied.]
Ldelem_I | [To be supplied.]
Ldelem_I1 | [To be supplied.]
Ldelem_I2 | [To be supplied.]
Ldelem_I4 | [To be supplied.]
Ldelem_I8 | [To be supplied.]
Ldelem_R4 | [To be supplied.]
Ldelem_R8 | [To be supplied.]
Ldelem_Ref | [To be supplied.]
Ldelem_U1 | [To be supplied.]
Ldelem_U2 | [To be supplied.]
Ldelem_U4 | [To be supplied.]
Ldfld | [To be supplied.]
Ldflda | [To be supplied.]
Ldftn | [To be supplied.]
Ldind_I | [To be supplied.]
Ldind_I1 | [To be supplied.]
Ldind_I2 | [To be supplied.]
Ldind_I4 | [To be supplied.]
Ldind_I8 | [To be supplied.]
Ldind_R4 | [To be supplied.]
Ldind_R8 | [To be supplied.]
Ldind_Ref | [To be supplied.]
Ldind_U1 | [To be supplied.]
Ldind_U2 | [To be supplied.]
Ldind_U4 | [To be supplied.]
Ldlen | [To be supplied.]
Ldloc | [To be supplied.]
Ldloca | [To be supplied.]
Ldloca_S | [To be supplied.]
Ldloc_0 | [To be supplied.]
Ldloc_1 | [To be supplied.]
Ldloc_2 | [To be supplied.]
Ldloc_3 | [To be supplied.]
Ldloc_S | [To be supplied.]
Ldnull | [To be supplied.]
Ldobj | [To be supplied.]
Ldptr | [To be supplied.]
Ldsfld | [To be supplied.]
Ldsflda | [To be supplied.]
Ldstr | [To be supplied.]
Ldtoken | [To be supplied.]
Ldvirtftn | [To be supplied.]
Leave | [To be supplied.]
Leave_S | [To be supplied.]
Localloc | [To be supplied.]
Mkrefany | [To be supplied.]
Mul | [To be supplied.]
Mul_Ovf | [To be supplied.]
Mul_Ovf_Un | [To be supplied.]
Neg | [To be supplied.]
Newarr | [To be supplied.]
Newobj | [To be supplied.]
Nop | [To be supplied.]
Not | [To be supplied.]
Or | [To be supplied.]
Pop | [To be supplied.]
Prefix1 | [To be supplied.]
Prefix2 | [To be supplied.]
Prefix3 | [To be supplied.]
Prefix4 | [To be supplied.]
Prefix5 | [To be supplied.]
Prefix6 | [To be supplied.]
Prefix7 | [To be supplied.]
Prefixref | [To be supplied.]
Refanytype | [To be supplied.]
Refanyval | [To be supplied.]
Rem | [To be supplied.]
Rem_Un | [To be supplied.]
Ret | [To be supplied.]
Rethrow | [To be supplied.]
Shl | [To be supplied.]
Shr | [To be supplied.]
Shr_Un | [To be supplied.]
Sizeof | [To be supplied.]
Starg | [To be supplied.]
Starg_S | [To be supplied.]
Stelem_I | [To be supplied.]
Stelem_I1 | [To be supplied.]
Stelem_I2 | [To be supplied.]
Stelem_I4 | [To be supplied.]
Stelem_I8 | [To be supplied.]
Stelem_R4 | [To be supplied.]
Stelem_R8 | [To be supplied.]
Stelem_Ref | [To be supplied.]
Stfld | [To be supplied.]
Stind_I | [To be supplied.]
Stind_I1 | [To be supplied.]
Stind_I2 | [To be supplied.]
Stind_I4 | [To be supplied.]
Stind_I8 | [To be supplied.]
Stind_R4 | [To be supplied.]
Stind_R8 | [To be supplied.]
Stind_Ref | [To be supplied.]
Stloc | [To be supplied.]
Stloc_0 | [To be supplied.]
Stloc_1 | [To be supplied.]
Stloc_2 | [To be supplied.]
Stloc_3 | [To be supplied.]
Stloc_S | [To be supplied.]
Stobj | [To be supplied.]
Stsfld | [To be supplied.]
Sub | [To be supplied.]
Sub_Ovf | [To be supplied.]
Sub_Ovf_Un | [To be supplied.]
Switch | [To be supplied.]
Tailcall | [To be supplied.]
Throw | [To be supplied.]
Toproxy | [To be supplied.]
Unaligned | [To be supplied.]
Unbox | [To be supplied.]
Volatile | [To be supplied.]
Xor | [To be supplied.]

See Also

OpCodes Class | System.Reflection.Emit Namespace


OpCodes.Add

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Add As OpCode
[C#]
public static readonly OpCode Add;
[C++]
public: static readonly OpCode Add;
[JScript]
public static var Add : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Add_Ovf

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Add_Ovf As OpCode
[C#]
public static readonly OpCode Add_Ovf;
[C++]
public: static readonly OpCode Add_Ovf;
[JScript]
public static var Add_Ovf : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Add_Ovf_Un

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Add_Ovf_Un As OpCode
[C#]
public static readonly OpCode Add_Ovf_Un;
[C++]
public: static readonly OpCode Add_Ovf_Un;
[JScript]
public static var Add_Ovf_Un : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.And

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly And As OpCode
[C#]
public static readonly OpCode And;
[C++]
public: static readonly OpCode And;
[JScript]
public static var And : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ann_Call

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ann_Call As OpCode
[C#]
public static readonly OpCode Ann_Call;
[C++]
public: static readonly OpCode Ann_Call;
[JScript]
public static var Ann_Call : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ann_Catch

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ann_Catch As OpCode
[C#]
public static readonly OpCode Ann_Catch;
[C++]
public: static readonly OpCode Ann_Catch;
[JScript]
public static var Ann_Catch : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ann_Data

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ann_Data As OpCode
[C#]
public static readonly OpCode Ann_Data;
[C++]
public: static readonly OpCode Ann_Data;
[JScript]
public static var Ann_Data : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ann_Data_S

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ann_Data_S As OpCode
[C#]
public static readonly OpCode Ann_Data_S;
[C++]
public: static readonly OpCode Ann_Data_S;
[JScript]
public static var Ann_Data_S : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ann_Dead

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ann_Dead As OpCode
[C#]
public static readonly OpCode Ann_Dead;
[C++]
public: static readonly OpCode Ann_Dead;
[JScript]
public static var Ann_Dead : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ann_Def

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ann_Def As OpCode
[C#]
public static readonly OpCode Ann_Def;
[C++]
public: static readonly OpCode Ann_Def;
[JScript]
public static var Ann_Def : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ann_Hoisted

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ann_Hoisted As OpCode
[C#]
public static readonly OpCode Ann_Hoisted;
[C++]
public: static readonly OpCode Ann_Hoisted;
[JScript]
public static var Ann_Hoisted : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ann_Hoisted_Call

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ann_Hoisted_Call As OpCode
[C#]
public static readonly OpCode Ann_Hoisted_Call;
[C++]
public: static readonly OpCode Ann_Hoisted_Call;
[JScript]
public static var Ann_Hoisted_Call : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ann_Lab

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ann_Lab As OpCode
[C#]
public static readonly OpCode Ann_Lab;
[C++]
public: static readonly OpCode Ann_Lab;
[JScript]
public static var Ann_Lab : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ann_Live

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ann_Live As OpCode
[C#]
public static readonly OpCode Ann_Live;
[C++]
public: static readonly OpCode Ann_Live;
[JScript]
public static var Ann_Live : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ann_Phi

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ann_Phi As OpCode
[C#]
public static readonly OpCode Ann_Phi;
[C++]
public: static readonly OpCode Ann_Phi;
[JScript]
public static var Ann_Phi : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ann_Ref

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ann_Ref As OpCode
[C#]
public static readonly OpCode Ann_Ref;
[C++]
public: static readonly OpCode Ann_Ref;
[JScript]
public static var Ann_Ref : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ann_Ref_S

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ann_Ref_S As OpCode
[C#]
public static readonly OpCode Ann_Ref_S;
[C++]
public: static readonly OpCode Ann_Ref_S;
[JScript]
public static var Ann_Ref_S : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Arglist

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Arglist As OpCode
[C#]
public static readonly OpCode Arglist;
[C++]
public: static readonly OpCode Arglist;
[JScript]
public static var Arglist : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Beq

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Beq As OpCode
[C#]
public static readonly OpCode Beq;
[C++]
public: static readonly OpCode Beq;
[JScript]
public static var Beq : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Beq_S

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Beq_S As OpCode
[C#]
public static readonly OpCode Beq_S;
[C++]
public: static readonly OpCode Beq_S;
[JScript]
public static var Beq_S : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Bge

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Bge As OpCode
[C#]
public static readonly OpCode Bge;
[C++]
public: static readonly OpCode Bge;
[JScript]
public static var Bge : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Bge_S

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Bge_S As OpCode
[C#]
public static readonly OpCode Bge_S;
[C++]
public: static readonly OpCode Bge_S;
[JScript]
public static var Bge_S : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Bge_Un

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Bge_Un As OpCode
[C#]
public static readonly OpCode Bge_Un;
[C++]
public: static readonly OpCode Bge_Un;
[JScript]
public static var Bge_Un : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Bge_Un_S

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Bge_Un_S As OpCode
[C#]
public static readonly OpCode Bge_Un_S;
[C++]
public: static readonly OpCode Bge_Un_S;
[JScript]
public static var Bge_Un_S : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Bgt

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Bgt As OpCode
[C#]
public static readonly OpCode Bgt;
[C++]
public: static readonly OpCode Bgt;
[JScript]
public static var Bgt : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Bgt_S

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Bgt_S As OpCode
[C#]
public static readonly OpCode Bgt_S;
[C++]
public: static readonly OpCode Bgt_S;
[JScript]
public static var Bgt_S : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Bgt_Un

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Bgt_Un As OpCode
[C#]
public static readonly OpCode Bgt_Un;
[C++]
public: static readonly OpCode Bgt_Un;
[JScript]
public static var Bgt_Un : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Bgt_Un_S

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Bgt_Un_S As OpCode
[C#]
public static readonly OpCode Bgt_Un_S;
[C++]
public: static readonly OpCode Bgt_Un_S;
[JScript]
public static var Bgt_Un_S : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ble

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ble As OpCode
[C#]
public static readonly OpCode Ble;
[C++]
public: static readonly OpCode Ble;
[JScript]
public static var Ble : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ble_S

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ble_S As OpCode
[C#]
public static readonly OpCode Ble_S;
[C++]
public: static readonly OpCode Ble_S;
[JScript]
public static var Ble_S : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ble_Un

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ble_Un As OpCode
[C#]
public static readonly OpCode Ble_Un;
[C++]
public: static readonly OpCode Ble_Un;
[JScript]
public static var Ble_Un : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ble_Un_S

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ble_Un_S As OpCode
[C#]
public static readonly OpCode Ble_Un_S;
[C++]
public: static readonly OpCode Ble_Un_S;
[JScript]
public static var Ble_Un_S : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Blt

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Blt As OpCode
[C#]
public static readonly OpCode Blt;
[C++]
public: static readonly OpCode Blt;
[JScript]
public static var Blt : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Blt_S

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Blt_S As OpCode
[C#]
public static readonly OpCode Blt_S;
[C++]
public: static readonly OpCode Blt_S;
[JScript]
public static var Blt_S : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Blt_Un

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Blt_Un As OpCode
[C#]
public static readonly OpCode Blt_Un;
[C++]
public: static readonly OpCode Blt_Un;
[JScript]
public static var Blt_Un : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Blt_Un_S

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Blt_Un_S As OpCode
[C#]
public static readonly OpCode Blt_Un_S;
[C++]
public: static readonly OpCode Blt_Un_S;
[JScript]
public static var Blt_Un_S : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Bne_Un

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Bne_Un As OpCode
[C#]
public static readonly OpCode Bne_Un;
[C++]
public: static readonly OpCode Bne_Un;
[JScript]
public static var Bne_Un : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Bne_Un_S

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Bne_Un_S As OpCode
[C#]
public static readonly OpCode Bne_Un_S;
[C++]
public: static readonly OpCode Bne_Un_S;
[JScript]
public static var Bne_Un_S : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Box

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Box As OpCode
[C#]
public static readonly OpCode Box;
[C++]
public: static readonly OpCode Box;
[JScript]
public static var Box : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Br

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Br As OpCode
[C#]
public static readonly OpCode Br;
[C++]
public: static readonly OpCode Br;
[JScript]
public static var Br : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Break

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Break As OpCode
[C#]
public static readonly OpCode Break;
[C++]
public: static readonly OpCode Break;
[JScript]
public static var Break : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Brfalse

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Brfalse As OpCode
[C#]
public static readonly OpCode Brfalse;
[C++]
public: static readonly OpCode Brfalse;
[JScript]
public static var Brfalse : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Brfalse_S

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Brfalse_S As OpCode
[C#]
public static readonly OpCode Brfalse_S;
[C++]
public: static readonly OpCode Brfalse_S;
[JScript]
public static var Brfalse_S : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Brtrue

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Brtrue As OpCode
[C#]
public static readonly OpCode Brtrue;
[C++]
public: static readonly OpCode Brtrue;
[JScript]
public static var Brtrue : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Brtrue_S

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Brtrue_S As OpCode
[C#]
public static readonly OpCode Brtrue_S;
[C++]
public: static readonly OpCode Brtrue_S;
[JScript]
public static var Brtrue_S : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Br_S

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Br_S As OpCode
[C#]
public static readonly OpCode Br_S;
[C++]
public: static readonly OpCode Br_S;
[JScript]
public static var Br_S : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Call

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Call As OpCode
[C#]
public static readonly OpCode Call;
[C++]
public: static readonly OpCode Call;
[JScript]
public static var Call : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Calli

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Calli As OpCode
[C#]
public static readonly OpCode Calli;
[C++]
public: static readonly OpCode Calli;
[JScript]
public static var Calli : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Callvirt

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Callvirt As OpCode
[C#]
public static readonly OpCode Callvirt;
[C++]
public: static readonly OpCode Callvirt;
[JScript]
public static var Callvirt : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Castclass

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Castclass As OpCode
[C#]
public static readonly OpCode Castclass;
[C++]
public: static readonly OpCode Castclass;
[JScript]
public static var Castclass : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ceq

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ceq As OpCode
[C#]
public static readonly OpCode Ceq;
[C++]
public: static readonly OpCode Ceq;
[JScript]
public static var Ceq : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Cgt

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Cgt As OpCode
[C#]
public static readonly OpCode Cgt;
[C++]
public: static readonly OpCode Cgt;
[JScript]
public static var Cgt : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Cgt_Un

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Cgt_Un As OpCode
[C#]
public static readonly OpCode Cgt_Un;
[C++]
public: static readonly OpCode Cgt_Un;
[JScript]
public static var Cgt_Un : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ckfinite

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ckfinite As OpCode
[C#]
public static readonly OpCode Ckfinite;
[C++]
public: static readonly OpCode Ckfinite;
[JScript]
public static var Ckfinite : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Clt

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Clt As OpCode
[C#]
public static readonly OpCode Clt;
[C++]
public: static readonly OpCode Clt;
[JScript]
public static var Clt : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Clt_Un

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Clt_Un As OpCode
[C#]
public static readonly OpCode Clt_Un;
[C++]
public: static readonly OpCode Clt_Un;
[JScript]
public static var Clt_Un : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_I

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_I As OpCode
[C#]
public static readonly OpCode Conv_I;
[C++]
public: static readonly OpCode Conv_I;
[JScript]
public static var Conv_I : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_I1

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_I1 As OpCode
[C#]
public static readonly OpCode Conv_I1;
[C++]
public: static readonly OpCode Conv_I1;
[JScript]
public static var Conv_I1 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_I2

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_I2 As OpCode
[C#]
public static readonly OpCode Conv_I2;
[C++]
public: static readonly OpCode Conv_I2;
[JScript]
public static var Conv_I2 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_I4

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_I4 As OpCode
[C#]
public static readonly OpCode Conv_I4;
[C++]
public: static readonly OpCode Conv_I4;
[JScript]
public static var Conv_I4 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_I8

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_I8 As OpCode
[C#]
public static readonly OpCode Conv_I8;
[C++]
public: static readonly OpCode Conv_I8;
[JScript]
public static var Conv_I8 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_Ovf_I

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_Ovf_I As OpCode
[C#]
public static readonly OpCode Conv_Ovf_I;
[C++]
public: static readonly OpCode Conv_Ovf_I;
[JScript]
public static var Conv_Ovf_I : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_Ovf_I1

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_Ovf_I1 As OpCode
[C#]
public static readonly OpCode Conv_Ovf_I1;
[C++]
public: static readonly OpCode Conv_Ovf_I1;
[JScript]
public static var Conv_Ovf_I1 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_Ovf_I1_Un

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_Ovf_I1_Un As OpCode
[C#]
public static readonly OpCode Conv_Ovf_I1_Un;
[C++]
public: static readonly OpCode Conv_Ovf_I1_Un;
[JScript]
public static var Conv_Ovf_I1_Un : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_Ovf_I2

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_Ovf_I2 As OpCode
[C#]
public static readonly OpCode Conv_Ovf_I2;
[C++]
public: static readonly OpCode Conv_Ovf_I2;
[JScript]
public static var Conv_Ovf_I2 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_Ovf_I2_Un

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_Ovf_I2_Un As OpCode
[C#]
public static readonly OpCode Conv_Ovf_I2_Un;
[C++]
public: static readonly OpCode Conv_Ovf_I2_Un;
[JScript]
public static var Conv_Ovf_I2_Un : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_Ovf_I4

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_Ovf_I4 As OpCode
[C#]
public static readonly OpCode Conv_Ovf_I4;
[C++]
public: static readonly OpCode Conv_Ovf_I4;
[JScript]
public static var Conv_Ovf_I4 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_Ovf_I4_Un

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_Ovf_I4_Un As OpCode
[C#]
public static readonly OpCode Conv_Ovf_I4_Un;
[C++]
public: static readonly OpCode Conv_Ovf_I4_Un;
[JScript]
public static var Conv_Ovf_I4_Un : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_Ovf_I8

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_Ovf_I8 As OpCode
[C#]
public static readonly OpCode Conv_Ovf_I8;
[C++]
public: static readonly OpCode Conv_Ovf_I8;
[JScript]
public static var Conv_Ovf_I8 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_Ovf_I8_Un

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_Ovf_I8_Un As OpCode
[C#]
public static readonly OpCode Conv_Ovf_I8_Un;
[C++]
public: static readonly OpCode Conv_Ovf_I8_Un;
[JScript]
public static var Conv_Ovf_I8_Un : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_Ovf_I_Un

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_Ovf_I_Un As OpCode
[C#]
public static readonly OpCode Conv_Ovf_I_Un;
[C++]
public: static readonly OpCode Conv_Ovf_I_Un;
[JScript]
public static var Conv_Ovf_I_Un : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_Ovf_U

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_Ovf_U As OpCode
[C#]
public static readonly OpCode Conv_Ovf_U;
[C++]
public: static readonly OpCode Conv_Ovf_U;
[JScript]
public static var Conv_Ovf_U : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_Ovf_U1

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_Ovf_U1 As OpCode
[C#]
public static readonly OpCode Conv_Ovf_U1;
[C++]
public: static readonly OpCode Conv_Ovf_U1;
[JScript]
public static var Conv_Ovf_U1 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_Ovf_U1_Un

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_Ovf_U1_Un As OpCode
[C#]
public static readonly OpCode Conv_Ovf_U1_Un;
[C++]
public: static readonly OpCode Conv_Ovf_U1_Un;
[JScript]
public static var Conv_Ovf_U1_Un : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_Ovf_U2

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_Ovf_U2 As OpCode
[C#]
public static readonly OpCode Conv_Ovf_U2;
[C++]
public: static readonly OpCode Conv_Ovf_U2;
[JScript]
public static var Conv_Ovf_U2 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_Ovf_U2_Un

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_Ovf_U2_Un As OpCode
[C#]
public static readonly OpCode Conv_Ovf_U2_Un;
[C++]
public: static readonly OpCode Conv_Ovf_U2_Un;
[JScript]
public static var Conv_Ovf_U2_Un : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_Ovf_U4

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_Ovf_U4 As OpCode
[C#]
public static readonly OpCode Conv_Ovf_U4;
[C++]
public: static readonly OpCode Conv_Ovf_U4;
[JScript]
public static var Conv_Ovf_U4 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_Ovf_U4_Un

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_Ovf_U4_Un As OpCode
[C#]
public static readonly OpCode Conv_Ovf_U4_Un;
[C++]
public: static readonly OpCode Conv_Ovf_U4_Un;
[JScript]
public static var Conv_Ovf_U4_Un : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_Ovf_U8

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_Ovf_U8 As OpCode
[C#]
public static readonly OpCode Conv_Ovf_U8;
[C++]
public: static readonly OpCode Conv_Ovf_U8;
[JScript]
public static var Conv_Ovf_U8 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_Ovf_U8_Un

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_Ovf_U8_Un As OpCode
[C#]
public static readonly OpCode Conv_Ovf_U8_Un;
[C++]
public: static readonly OpCode Conv_Ovf_U8_Un;
[JScript]
public static var Conv_Ovf_U8_Un : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_Ovf_U_Un

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_Ovf_U_Un As OpCode
[C#]
public static readonly OpCode Conv_Ovf_U_Un;
[C++]
public: static readonly OpCode Conv_Ovf_U_Un;
[JScript]
public static var Conv_Ovf_U_Un : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_R4

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_R4 As OpCode
[C#]
public static readonly OpCode Conv_R4;
[C++]
public: static readonly OpCode Conv_R4;
[JScript]
public static var Conv_R4 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_R8

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_R8 As OpCode
[C#]
public static readonly OpCode Conv_R8;
[C++]
public: static readonly OpCode Conv_R8;
[JScript]
public static var Conv_R8 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_R_Un

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_R_Un As OpCode
[C#]
public static readonly OpCode Conv_R_Un;
[C++]
public: static readonly OpCode Conv_R_Un;
[JScript]
public static var Conv_R_Un : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_U

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_U As OpCode
[C#]
public static readonly OpCode Conv_U;
[C++]
public: static readonly OpCode Conv_U;
[JScript]
public static var Conv_U : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_U1

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_U1 As OpCode
[C#]
public static readonly OpCode Conv_U1;
[C++]
public: static readonly OpCode Conv_U1;
[JScript]
public static var Conv_U1 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_U2

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_U2 As OpCode
[C#]
public static readonly OpCode Conv_U2;
[C++]
public: static readonly OpCode Conv_U2;
[JScript]
public static var Conv_U2 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_U4

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_U4 As OpCode
[C#]
public static readonly OpCode Conv_U4;
[C++]
public: static readonly OpCode Conv_U4;
[JScript]
public static var Conv_U4 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Conv_U8

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Conv_U8 As OpCode
[C#]
public static readonly OpCode Conv_U8;
[C++]
public: static readonly OpCode Conv_U8;
[JScript]
public static var Conv_U8 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Cpblk

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Cpblk As OpCode
[C#]
public static readonly OpCode Cpblk;
[C++]
public: static readonly OpCode Cpblk;
[JScript]
public static var Cpblk : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Cpobj

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Cpobj As OpCode
[C#]
public static readonly OpCode Cpobj;
[C++]
public: static readonly OpCode Cpobj;
[JScript]
public static var Cpobj : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Deprecated_Ann_Arg

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Deprecated_Ann_Arg As OpCode
[C#]
public static readonly OpCode Deprecated_Ann_Arg;
[C++]
public: static readonly OpCode Deprecated_Ann_Arg;
[JScript]
public static var Deprecated_Ann_Arg : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Deprecated_Endcatch

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Deprecated_Endcatch As OpCode
[C#]
public static readonly OpCode Deprecated_Endcatch;
[C++]
public: static readonly OpCode Deprecated_Endcatch;
[JScript]
public static var Deprecated_Endcatch : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Div

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Div As OpCode
[C#]
public static readonly OpCode Div;
[C++]
public: static readonly OpCode Div;
[JScript]
public static var Div : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Div_Un

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Div_Un As OpCode
[C#]
public static readonly OpCode Div_Un;
[C++]
public: static readonly OpCode Div_Un;
[JScript]
public static var Div_Un : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Dup

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Dup As OpCode
[C#]
public static readonly OpCode Dup;
[C++]
public: static readonly OpCode Dup;
[JScript]
public static var Dup : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Endfilter

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Endfilter As OpCode
[C#]
public static readonly OpCode Endfilter;
[C++]
public: static readonly OpCode Endfilter;
[JScript]
public static var Endfilter : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Endfinally

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Endfinally As OpCode
[C#]
public static readonly OpCode Endfinally;
[C++]
public: static readonly OpCode Endfinally;
[JScript]
public static var Endfinally : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Fromproxy

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Fromproxy As OpCode
[C#]
public static readonly OpCode Fromproxy;
[C++]
public: static readonly OpCode Fromproxy;
[JScript]
public static var Fromproxy : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Initblk

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Initblk As OpCode
[C#]
public static readonly OpCode Initblk;
[C++]
public: static readonly OpCode Initblk;
[JScript]
public static var Initblk : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Initobj

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Initobj As OpCode
[C#]
public static readonly OpCode Initobj;
[C++]
public: static readonly OpCode Initobj;
[JScript]
public static var Initobj : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Isinst

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Isinst As OpCode
[C#]
public static readonly OpCode Isinst;
[C++]
public: static readonly OpCode Isinst;
[JScript]
public static var Isinst : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Jmp

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Jmp As OpCode
[C#]
public static readonly OpCode Jmp;
[C++]
public: static readonly OpCode Jmp;
[JScript]
public static var Jmp : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Jmpi

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Jmpi As OpCode
[C#]
public static readonly OpCode Jmpi;
[C++]
public: static readonly OpCode Jmpi;
[JScript]
public static var Jmpi : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldarg

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldarg As OpCode
[C#]
public static readonly OpCode Ldarg;
[C++]
public: static readonly OpCode Ldarg;
[JScript]
public static var Ldarg : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldarga

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldarga As OpCode
[C#]
public static readonly OpCode Ldarga;
[C++]
public: static readonly OpCode Ldarga;
[JScript]
public static var Ldarga : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldarga_S

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldarga_S As OpCode
[C#]
public static readonly OpCode Ldarga_S;
[C++]
public: static readonly OpCode Ldarga_S;
[JScript]
public static var Ldarga_S : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldarg_0

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldarg_0 As OpCode
[C#]
public static readonly OpCode Ldarg_0;
[C++]
public: static readonly OpCode Ldarg_0;
[JScript]
public static var Ldarg_0 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldarg_1

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldarg_1 As OpCode
[C#]
public static readonly OpCode Ldarg_1;
[C++]
public: static readonly OpCode Ldarg_1;
[JScript]
public static var Ldarg_1 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldarg_2

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldarg_2 As OpCode
[C#]
public static readonly OpCode Ldarg_2;
[C++]
public: static readonly OpCode Ldarg_2;
[JScript]
public static var Ldarg_2 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldarg_3

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldarg_3 As OpCode
[C#]
public static readonly OpCode Ldarg_3;
[C++]
public: static readonly OpCode Ldarg_3;
[JScript]
public static var Ldarg_3 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldarg_S

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldarg_S As OpCode
[C#]
public static readonly OpCode Ldarg_S;
[C++]
public: static readonly OpCode Ldarg_S;
[JScript]
public static var Ldarg_S : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldc_I4

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldc_I4 As OpCode
[C#]
public static readonly OpCode Ldc_I4;
[C++]
public: static readonly OpCode Ldc_I4;
[JScript]
public static var Ldc_I4 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldc_I4_0

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldc_I4_0 As OpCode
[C#]
public static readonly OpCode Ldc_I4_0;
[C++]
public: static readonly OpCode Ldc_I4_0;
[JScript]
public static var Ldc_I4_0 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldc_I4_1

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldc_I4_1 As OpCode
[C#]
public static readonly OpCode Ldc_I4_1;
[C++]
public: static readonly OpCode Ldc_I4_1;
[JScript]
public static var Ldc_I4_1 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldc_I4_2

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldc_I4_2 As OpCode
[C#]
public static readonly OpCode Ldc_I4_2;
[C++]
public: static readonly OpCode Ldc_I4_2;
[JScript]
public static var Ldc_I4_2 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldc_I4_3

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldc_I4_3 As OpCode
[C#]
public static readonly OpCode Ldc_I4_3;
[C++]
public: static readonly OpCode Ldc_I4_3;
[JScript]
public static var Ldc_I4_3 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldc_I4_4

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldc_I4_4 As OpCode
[C#]
public static readonly OpCode Ldc_I4_4;
[C++]
public: static readonly OpCode Ldc_I4_4;
[JScript]
public static var Ldc_I4_4 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldc_I4_5

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldc_I4_5 As OpCode
[C#]
public static readonly OpCode Ldc_I4_5;
[C++]
public: static readonly OpCode Ldc_I4_5;
[JScript]
public static var Ldc_I4_5 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldc_I4_6

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldc_I4_6 As OpCode
[C#]
public static readonly OpCode Ldc_I4_6;
[C++]
public: static readonly OpCode Ldc_I4_6;
[JScript]
public static var Ldc_I4_6 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldc_I4_7

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldc_I4_7 As OpCode
[C#]
public static readonly OpCode Ldc_I4_7;
[C++]
public: static readonly OpCode Ldc_I4_7;
[JScript]
public static var Ldc_I4_7 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldc_I4_8

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldc_I4_8 As OpCode
[C#]
public static readonly OpCode Ldc_I4_8;
[C++]
public: static readonly OpCode Ldc_I4_8;
[JScript]
public static var Ldc_I4_8 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldc_I4_M1

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldc_I4_M1 As OpCode
[C#]
public static readonly OpCode Ldc_I4_M1;
[C++]
public: static readonly OpCode Ldc_I4_M1;
[JScript]
public static var Ldc_I4_M1 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldc_I4_S

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldc_I4_S As OpCode
[C#]
public static readonly OpCode Ldc_I4_S;
[C++]
public: static readonly OpCode Ldc_I4_S;
[JScript]
public static var Ldc_I4_S : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldc_I8

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldc_I8 As OpCode
[C#]
public static readonly OpCode Ldc_I8;
[C++]
public: static readonly OpCode Ldc_I8;
[JScript]
public static var Ldc_I8 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldc_R4

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldc_R4 As OpCode
[C#]
public static readonly OpCode Ldc_R4;
[C++]
public: static readonly OpCode Ldc_R4;
[JScript]
public static var Ldc_R4 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldc_R8

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldc_R8 As OpCode
[C#]
public static readonly OpCode Ldc_R8;
[C++]
public: static readonly OpCode Ldc_R8;
[JScript]
public static var Ldc_R8 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldelema

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldelema As OpCode
[C#]
public static readonly OpCode Ldelema;
[C++]
public: static readonly OpCode Ldelema;
[JScript]
public static var Ldelema : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldelem_I

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldelem_I As OpCode
[C#]
public static readonly OpCode Ldelem_I;
[C++]
public: static readonly OpCode Ldelem_I;
[JScript]
public static var Ldelem_I : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldelem_I1

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldelem_I1 As OpCode
[C#]
public static readonly OpCode Ldelem_I1;
[C++]
public: static readonly OpCode Ldelem_I1;
[JScript]
public static var Ldelem_I1 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldelem_I2

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldelem_I2 As OpCode
[C#]
public static readonly OpCode Ldelem_I2;
[C++]
public: static readonly OpCode Ldelem_I2;
[JScript]
public static var Ldelem_I2 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldelem_I4

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldelem_I4 As OpCode
[C#]
public static readonly OpCode Ldelem_I4;
[C++]
public: static readonly OpCode Ldelem_I4;
[JScript]
public static var Ldelem_I4 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldelem_I8

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldelem_I8 As OpCode
[C#]
public static readonly OpCode Ldelem_I8;
[C++]
public: static readonly OpCode Ldelem_I8;
[JScript]
public static var Ldelem_I8 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldelem_R4

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldelem_R4 As OpCode
[C#]
public static readonly OpCode Ldelem_R4;
[C++]
public: static readonly OpCode Ldelem_R4;
[JScript]
public static var Ldelem_R4 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldelem_R8

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldelem_R8 As OpCode
[C#]
public static readonly OpCode Ldelem_R8;
[C++]
public: static readonly OpCode Ldelem_R8;
[JScript]
public static var Ldelem_R8 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldelem_Ref

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldelem_Ref As OpCode
[C#]
public static readonly OpCode Ldelem_Ref;
[C++]
public: static readonly OpCode Ldelem_Ref;
[JScript]
public static var Ldelem_Ref : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldelem_U1

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldelem_U1 As OpCode
[C#]
public static readonly OpCode Ldelem_U1;
[C++]
public: static readonly OpCode Ldelem_U1;
[JScript]
public static var Ldelem_U1 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldelem_U2

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldelem_U2 As OpCode
[C#]
public static readonly OpCode Ldelem_U2;
[C++]
public: static readonly OpCode Ldelem_U2;
[JScript]
public static var Ldelem_U2 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldelem_U4

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldelem_U4 As OpCode
[C#]
public static readonly OpCode Ldelem_U4;
[C++]
public: static readonly OpCode Ldelem_U4;
[JScript]
public static var Ldelem_U4 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldfld

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldfld As OpCode
[C#]
public static readonly OpCode Ldfld;
[C++]
public: static readonly OpCode Ldfld;
[JScript]
public static var Ldfld : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldflda

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldflda As OpCode
[C#]
public static readonly OpCode Ldflda;
[C++]
public: static readonly OpCode Ldflda;
[JScript]
public static var Ldflda : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldftn

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldftn As OpCode
[C#]
public static readonly OpCode Ldftn;
[C++]
public: static readonly OpCode Ldftn;
[JScript]
public static var Ldftn : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldind_I

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldind_I As OpCode
[C#]
public static readonly OpCode Ldind_I;
[C++]
public: static readonly OpCode Ldind_I;
[JScript]
public static var Ldind_I : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldind_I1

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldind_I1 As OpCode
[C#]
public static readonly OpCode Ldind_I1;
[C++]
public: static readonly OpCode Ldind_I1;
[JScript]
public static var Ldind_I1 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldind_I2

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldind_I2 As OpCode
[C#]
public static readonly OpCode Ldind_I2;
[C++]
public: static readonly OpCode Ldind_I2;
[JScript]
public static var Ldind_I2 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldind_I4

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldind_I4 As OpCode
[C#]
public static readonly OpCode Ldind_I4;
[C++]
public: static readonly OpCode Ldind_I4;
[JScript]
public static var Ldind_I4 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldind_I8

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldind_I8 As OpCode
[C#]
public static readonly OpCode Ldind_I8;
[C++]
public: static readonly OpCode Ldind_I8;
[JScript]
public static var Ldind_I8 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldind_R4

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldind_R4 As OpCode
[C#]
public static readonly OpCode Ldind_R4;
[C++]
public: static readonly OpCode Ldind_R4;
[JScript]
public static var Ldind_R4 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldind_R8

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldind_R8 As OpCode
[C#]
public static readonly OpCode Ldind_R8;
[C++]
public: static readonly OpCode Ldind_R8;
[JScript]
public static var Ldind_R8 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldind_Ref

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldind_Ref As OpCode
[C#]
public static readonly OpCode Ldind_Ref;
[C++]
public: static readonly OpCode Ldind_Ref;
[JScript]
public static var Ldind_Ref : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldind_U1

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldind_U1 As OpCode
[C#]
public static readonly OpCode Ldind_U1;
[C++]
public: static readonly OpCode Ldind_U1;
[JScript]
public static var Ldind_U1 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldind_U2

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldind_U2 As OpCode
[C#]
public static readonly OpCode Ldind_U2;
[C++]
public: static readonly OpCode Ldind_U2;
[JScript]
public static var Ldind_U2 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldind_U4

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldind_U4 As OpCode
[C#]
public static readonly OpCode Ldind_U4;
[C++]
public: static readonly OpCode Ldind_U4;
[JScript]
public static var Ldind_U4 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldlen

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldlen As OpCode
[C#]
public static readonly OpCode Ldlen;
[C++]
public: static readonly OpCode Ldlen;
[JScript]
public static var Ldlen : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldloc

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldloc As OpCode
[C#]
public static readonly OpCode Ldloc;
[C++]
public: static readonly OpCode Ldloc;
[JScript]
public static var Ldloc : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldloca

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldloca As OpCode
[C#]
public static readonly OpCode Ldloca;
[C++]
public: static readonly OpCode Ldloca;
[JScript]
public static var Ldloca : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldloca_S

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldloca_S As OpCode
[C#]
public static readonly OpCode Ldloca_S;
[C++]
public: static readonly OpCode Ldloca_S;
[JScript]
public static var Ldloca_S : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldloc_0

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldloc_0 As OpCode
[C#]
public static readonly OpCode Ldloc_0;
[C++]
public: static readonly OpCode Ldloc_0;
[JScript]
public static var Ldloc_0 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldloc_1

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldloc_1 As OpCode
[C#]
public static readonly OpCode Ldloc_1;
[C++]
public: static readonly OpCode Ldloc_1;
[JScript]
public static var Ldloc_1 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldloc_2

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldloc_2 As OpCode
[C#]
public static readonly OpCode Ldloc_2;
[C++]
public: static readonly OpCode Ldloc_2;
[JScript]
public static var Ldloc_2 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldloc_3

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldloc_3 As OpCode
[C#]
public static readonly OpCode Ldloc_3;
[C++]
public: static readonly OpCode Ldloc_3;
[JScript]
public static var Ldloc_3 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldloc_S

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldloc_S As OpCode
[C#]
public static readonly OpCode Ldloc_S;
[C++]
public: static readonly OpCode Ldloc_S;
[JScript]
public static var Ldloc_S : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldnull

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldnull As OpCode
[C#]
public static readonly OpCode Ldnull;
[C++]
public: static readonly OpCode Ldnull;
[JScript]
public static var Ldnull : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldobj

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldobj As OpCode
[C#]
public static readonly OpCode Ldobj;
[C++]
public: static readonly OpCode Ldobj;
[JScript]
public static var Ldobj : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldptr

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldptr As OpCode
[C#]
public static readonly OpCode Ldptr;
[C++]
public: static readonly OpCode Ldptr;
[JScript]
public static var Ldptr : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldsfld

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldsfld As OpCode
[C#]
public static readonly OpCode Ldsfld;
[C++]
public: static readonly OpCode Ldsfld;
[JScript]
public static var Ldsfld : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldsflda

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldsflda As OpCode
[C#]
public static readonly OpCode Ldsflda;
[C++]
public: static readonly OpCode Ldsflda;
[JScript]
public static var Ldsflda : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldstr

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldstr As OpCode
[C#]
public static readonly OpCode Ldstr;
[C++]
public: static readonly OpCode Ldstr;
[JScript]
public static var Ldstr : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldtoken

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldtoken As OpCode
[C#]
public static readonly OpCode Ldtoken;
[C++]
public: static readonly OpCode Ldtoken;
[JScript]
public static var Ldtoken : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ldvirtftn

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ldvirtftn As OpCode
[C#]
public static readonly OpCode Ldvirtftn;
[C++]
public: static readonly OpCode Ldvirtftn;
[JScript]
public static var Ldvirtftn : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Leave

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Leave As OpCode
[C#]
public static readonly OpCode Leave;
[C++]
public: static readonly OpCode Leave;
[JScript]
public static var Leave : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Leave_S

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Leave_S As OpCode
[C#]
public static readonly OpCode Leave_S;
[C++]
public: static readonly OpCode Leave_S;
[JScript]
public static var Leave_S : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Localloc

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Localloc As OpCode
[C#]
public static readonly OpCode Localloc;
[C++]
public: static readonly OpCode Localloc;
[JScript]
public static var Localloc : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Mkrefany

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Mkrefany As OpCode
[C#]
public static readonly OpCode Mkrefany;
[C++]
public: static readonly OpCode Mkrefany;
[JScript]
public static var Mkrefany : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Mul

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Mul As OpCode
[C#]
public static readonly OpCode Mul;
[C++]
public: static readonly OpCode Mul;
[JScript]
public static var Mul : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Mul_Ovf

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Mul_Ovf As OpCode
[C#]
public static readonly OpCode Mul_Ovf;
[C++]
public: static readonly OpCode Mul_Ovf;
[JScript]
public static var Mul_Ovf : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Mul_Ovf_Un

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Mul_Ovf_Un As OpCode
[C#]
public static readonly OpCode Mul_Ovf_Un;
[C++]
public: static readonly OpCode Mul_Ovf_Un;
[JScript]
public static var Mul_Ovf_Un : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Neg

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Neg As OpCode
[C#]
public static readonly OpCode Neg;
[C++]
public: static readonly OpCode Neg;
[JScript]
public static var Neg : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Newarr

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Newarr As OpCode
[C#]
public static readonly OpCode Newarr;
[C++]
public: static readonly OpCode Newarr;
[JScript]
public static var Newarr : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Newobj

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Newobj As OpCode
[C#]
public static readonly OpCode Newobj;
[C++]
public: static readonly OpCode Newobj;
[JScript]
public static var Newobj : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Nop

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Nop As OpCode
[C#]
public static readonly OpCode Nop;
[C++]
public: static readonly OpCode Nop;
[JScript]
public static var Nop : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Not

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Not As OpCode
[C#]
public static readonly OpCode Not;
[C++]
public: static readonly OpCode Not;
[JScript]
public static var Not : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Or

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Or As OpCode
[C#]
public static readonly OpCode Or;
[C++]
public: static readonly OpCode Or;
[JScript]
public static var Or : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Pop

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Pop As OpCode
[C#]
public static readonly OpCode Pop;
[C++]
public: static readonly OpCode Pop;
[JScript]
public static var Pop : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Prefix1

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Prefix1 As OpCode
[C#]
public static readonly OpCode Prefix1;
[C++]
public: static readonly OpCode Prefix1;
[JScript]
public static var Prefix1 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Prefix2

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Prefix2 As OpCode
[C#]
public static readonly OpCode Prefix2;
[C++]
public: static readonly OpCode Prefix2;
[JScript]
public static var Prefix2 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Prefix3

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Prefix3 As OpCode
[C#]
public static readonly OpCode Prefix3;
[C++]
public: static readonly OpCode Prefix3;
[JScript]
public static var Prefix3 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Prefix4

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Prefix4 As OpCode
[C#]
public static readonly OpCode Prefix4;
[C++]
public: static readonly OpCode Prefix4;
[JScript]
public static var Prefix4 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Prefix5

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Prefix5 As OpCode
[C#]
public static readonly OpCode Prefix5;
[C++]
public: static readonly OpCode Prefix5;
[JScript]
public static var Prefix5 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Prefix6

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Prefix6 As OpCode
[C#]
public static readonly OpCode Prefix6;
[C++]
public: static readonly OpCode Prefix6;
[JScript]
public static var Prefix6 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Prefix7

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Prefix7 As OpCode
[C#]
public static readonly OpCode Prefix7;
[C++]
public: static readonly OpCode Prefix7;
[JScript]
public static var Prefix7 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Prefixref

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Prefixref As OpCode
[C#]
public static readonly OpCode Prefixref;
[C++]
public: static readonly OpCode Prefixref;
[JScript]
public static var Prefixref : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Refanytype

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Refanytype As OpCode
[C#]
public static readonly OpCode Refanytype;
[C++]
public: static readonly OpCode Refanytype;
[JScript]
public static var Refanytype : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Refanyval

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Refanyval As OpCode
[C#]
public static readonly OpCode Refanyval;
[C++]
public: static readonly OpCode Refanyval;
[JScript]
public static var Refanyval : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Rem

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Rem As OpCode
[C#]
public static readonly OpCode Rem;
[C++]
public: static readonly OpCode Rem;
[JScript]
public static var Rem : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Rem_Un

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Rem_Un As OpCode
[C#]
public static readonly OpCode Rem_Un;
[C++]
public: static readonly OpCode Rem_Un;
[JScript]
public static var Rem_Un : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Ret

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Ret As OpCode
[C#]
public static readonly OpCode Ret;
[C++]
public: static readonly OpCode Ret;
[JScript]
public static var Ret : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Rethrow

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Rethrow As OpCode
[C#]
public static readonly OpCode Rethrow;
[C++]
public: static readonly OpCode Rethrow;
[JScript]
public static var Rethrow : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Shl

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Shl As OpCode
[C#]
public static readonly OpCode Shl;
[C++]
public: static readonly OpCode Shl;
[JScript]
public static var Shl : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Shr

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Shr As OpCode
[C#]
public static readonly OpCode Shr;
[C++]
public: static readonly OpCode Shr;
[JScript]
public static var Shr : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Shr_Un

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Shr_Un As OpCode
[C#]
public static readonly OpCode Shr_Un;
[C++]
public: static readonly OpCode Shr_Un;
[JScript]
public static var Shr_Un : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Sizeof

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Sizeof As OpCode
[C#]
public static readonly OpCode Sizeof;
[C++]
public: static readonly OpCode Sizeof;
[JScript]
public static var Sizeof : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Starg

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Starg As OpCode
[C#]
public static readonly OpCode Starg;
[C++]
public: static readonly OpCode Starg;
[JScript]
public static var Starg : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Starg_S

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Starg_S As OpCode
[C#]
public static readonly OpCode Starg_S;
[C++]
public: static readonly OpCode Starg_S;
[JScript]
public static var Starg_S : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Stelem_I

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Stelem_I As OpCode
[C#]
public static readonly OpCode Stelem_I;
[C++]
public: static readonly OpCode Stelem_I;
[JScript]
public static var Stelem_I : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Stelem_I1

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Stelem_I1 As OpCode
[C#]
public static readonly OpCode Stelem_I1;
[C++]
public: static readonly OpCode Stelem_I1;
[JScript]
public static var Stelem_I1 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Stelem_I2

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Stelem_I2 As OpCode
[C#]
public static readonly OpCode Stelem_I2;
[C++]
public: static readonly OpCode Stelem_I2;
[JScript]
public static var Stelem_I2 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Stelem_I4

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Stelem_I4 As OpCode
[C#]
public static readonly OpCode Stelem_I4;
[C++]
public: static readonly OpCode Stelem_I4;
[JScript]
public static var Stelem_I4 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Stelem_I8

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Stelem_I8 As OpCode
[C#]
public static readonly OpCode Stelem_I8;
[C++]
public: static readonly OpCode Stelem_I8;
[JScript]
public static var Stelem_I8 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Stelem_R4

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Stelem_R4 As OpCode
[C#]
public static readonly OpCode Stelem_R4;
[C++]
public: static readonly OpCode Stelem_R4;
[JScript]
public static var Stelem_R4 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Stelem_R8

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Stelem_R8 As OpCode
[C#]
public static readonly OpCode Stelem_R8;
[C++]
public: static readonly OpCode Stelem_R8;
[JScript]
public static var Stelem_R8 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Stelem_Ref

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Stelem_Ref As OpCode
[C#]
public static readonly OpCode Stelem_Ref;
[C++]
public: static readonly OpCode Stelem_Ref;
[JScript]
public static var Stelem_Ref : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Stfld

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Stfld As OpCode
[C#]
public static readonly OpCode Stfld;
[C++]
public: static readonly OpCode Stfld;
[JScript]
public static var Stfld : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Stind_I

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Stind_I As OpCode
[C#]
public static readonly OpCode Stind_I;
[C++]
public: static readonly OpCode Stind_I;
[JScript]
public static var Stind_I : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Stind_I1

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Stind_I1 As OpCode
[C#]
public static readonly OpCode Stind_I1;
[C++]
public: static readonly OpCode Stind_I1;
[JScript]
public static var Stind_I1 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Stind_I2

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Stind_I2 As OpCode
[C#]
public static readonly OpCode Stind_I2;
[C++]
public: static readonly OpCode Stind_I2;
[JScript]
public static var Stind_I2 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Stind_I4

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Stind_I4 As OpCode
[C#]
public static readonly OpCode Stind_I4;
[C++]
public: static readonly OpCode Stind_I4;
[JScript]
public static var Stind_I4 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Stind_I8

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Stind_I8 As OpCode
[C#]
public static readonly OpCode Stind_I8;
[C++]
public: static readonly OpCode Stind_I8;
[JScript]
public static var Stind_I8 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Stind_R4

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Stind_R4 As OpCode
[C#]
public static readonly OpCode Stind_R4;
[C++]
public: static readonly OpCode Stind_R4;
[JScript]
public static var Stind_R4 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Stind_R8

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Stind_R8 As OpCode
[C#]
public static readonly OpCode Stind_R8;
[C++]
public: static readonly OpCode Stind_R8;
[JScript]
public static var Stind_R8 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Stind_Ref

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Stind_Ref As OpCode
[C#]
public static readonly OpCode Stind_Ref;
[C++]
public: static readonly OpCode Stind_Ref;
[JScript]
public static var Stind_Ref : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Stloc

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Stloc As OpCode
[C#]
public static readonly OpCode Stloc;
[C++]
public: static readonly OpCode Stloc;
[JScript]
public static var Stloc : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Stloc_0

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Stloc_0 As OpCode
[C#]
public static readonly OpCode Stloc_0;
[C++]
public: static readonly OpCode Stloc_0;
[JScript]
public static var Stloc_0 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Stloc_1

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Stloc_1 As OpCode
[C#]
public static readonly OpCode Stloc_1;
[C++]
public: static readonly OpCode Stloc_1;
[JScript]
public static var Stloc_1 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Stloc_2

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Stloc_2 As OpCode
[C#]
public static readonly OpCode Stloc_2;
[C++]
public: static readonly OpCode Stloc_2;
[JScript]
public static var Stloc_2 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Stloc_3

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Stloc_3 As OpCode
[C#]
public static readonly OpCode Stloc_3;
[C++]
public: static readonly OpCode Stloc_3;
[JScript]
public static var Stloc_3 : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Stloc_S

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Stloc_S As OpCode
[C#]
public static readonly OpCode Stloc_S;
[C++]
public: static readonly OpCode Stloc_S;
[JScript]
public static var Stloc_S : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Stobj

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Stobj As OpCode
[C#]
public static readonly OpCode Stobj;
[C++]
public: static readonly OpCode Stobj;
[JScript]
public static var Stobj : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Stsfld

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Stsfld As OpCode
[C#]
public static readonly OpCode Stsfld;
[C++]
public: static readonly OpCode Stsfld;
[JScript]
public static var Stsfld : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Sub

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Sub As OpCode
[C#]
public static readonly OpCode Sub;
[C++]
public: static readonly OpCode Sub;
[JScript]
public static var Sub : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Sub_Ovf

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Sub_Ovf As OpCode
[C#]
public static readonly OpCode Sub_Ovf;
[C++]
public: static readonly OpCode Sub_Ovf;
[JScript]
public static var Sub_Ovf : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Sub_Ovf_Un

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Sub_Ovf_Un As OpCode
[C#]
public static readonly OpCode Sub_Ovf_Un;
[C++]
public: static readonly OpCode Sub_Ovf_Un;
[JScript]
public static var Sub_Ovf_Un : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Switch

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Switch As OpCode
[C#]
public static readonly OpCode Switch;
[C++]
public: static readonly OpCode Switch;
[JScript]
public static var Switch : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Tailcall

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Tailcall As OpCode
[C#]
public static readonly OpCode Tailcall;
[C++]
public: static readonly OpCode Tailcall;
[JScript]
public static var Tailcall : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Throw

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Throw As OpCode
[C#]
public static readonly OpCode Throw;
[C++]
public: static readonly OpCode Throw;
[JScript]
public static var Throw : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Toproxy

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Toproxy As OpCode
[C#]
public static readonly OpCode Toproxy;
[C++]
public: static readonly OpCode Toproxy;
[JScript]
public static var Toproxy : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Unaligned

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Unaligned As OpCode
[C#]
public static readonly OpCode Unaligned;
[C++]
public: static readonly OpCode Unaligned;
[JScript]
public static var Unaligned : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Unbox

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Unbox As OpCode
[C#]
public static readonly OpCode Unbox;
[C++]
public: static readonly OpCode Unbox;
[JScript]
public static var Unbox : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Volatile

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Volatile As OpCode
[C#]
public static readonly OpCode Volatile;
[C++]
public: static readonly OpCode Volatile;
[JScript]
public static var Volatile : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodes.Xor

[To be supplied.]

[Visual Basic]
Public Shared ReadOnly Xor As OpCode
[C#]
public static readonly OpCode Xor;
[C++]
public: static readonly OpCode Xor;
[JScript]
public static var Xor : OpCode;

See Also

OpCodes Class | OpCodes Members | System.Reflection.Emit Namespace


OpCodeType Enumeration

Describes the types of the IL instructions.

[Visual Basic]
Public Enum OpCodeType
[C#]
public enum OpCodeType
[C++]
public enum OpCodeType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Annotation | Describes an IL instruction that can be ignored by most processors. These instructions are used to convey additional information for the use of particular IL processors.
Macro | These are IL instructions that are used as a synonym for other IL instructions. For example, ldarg.0 represents the ldarg 0 instruction.
Nternal | Describes a reserved IL instruction.
Objmodel | Describes an IL instruction that applies to objects.
Prefix | Describes a prefix instruction that specifies what action needs to be taken before the next instruction is executed.
Primitive | Describes a built-in instruction.

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

System.Reflection.Emit Namespace


OperandType Enumeration

Describes the operand type of IL instruction.

[Visual Basic]
Public Enum OperandType
[C#]
public enum OperandType
[C++]
public enum OperandType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
InlineBrTarget | The operand is a long branch target.
InlineField | The operand is a 32-bit metadata token.
InlineI | The operand is a 32-bit integer.
InlineI8 | The operand is a 64-bit integer.
InlineMethod | The operand is a MethodRef token.
InlineNone | No operand.
InlinePhi | The operand is a single static assignment node. This operand type is used by the ann.phi instruction.
InlineR | The operand is a 64-bit IEEE floating point number.
InlineRVA | Deprecated.The operand is a RVA.
InlineSig | The operand is a signature token.
InlineString | The operand is a string token.
InlineSwitch | The operand is the argument to a switch instruction.
InlineTok | The operand is a FieldRef, MethodRef, or TypeRef token.
InlineType | The operand is a TypeRef token.
InlineVar | The operand is a variable.
ShortInlineBrTarget | The operand is a short branch target.
ShortInlineI | The operand is a 16-bit integer.
ShortInlineR | The operand is a 32-bit IEEE floating point number.
ShortInlineVar | The operand is a short variable.

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

System.Reflection.Emit Namespace


PackingSize Enumeration

An enumeration for specifying the packing size of a type.

[Visual Basic]
Public Enum PackingSize
[C#]
public enum PackingSize
[C++]
public enum PackingSize

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Size1 | The packing size is 1 byte.
Size16 | The packing size is 16 bytes.
Size2 | The packing size is 2 bytes.
Size4 | The packing size is 4 bytes.
Size8 | The packing size is 8 bytes.
Unspecified | The packing size is not specified.

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

System.Reflection.Emit Namespace


ParameterBuilder Class

The ParameterBuilder class is used to create or associate parameter information.

Object
ParameterBuilder

[Visual Basic]
Public Class ParameterBuilder
[C#]
public class ParameterBuilder
[C++]
public __gc class ParameterBuilder
[JScript]
public class ParameterBuilder

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

ParameterBuilder Members | System.Reflection.Emit Namespace


ParameterBuilder Members

Public:

Properties

Attributes | Retrieves the attributes for this parameter.
IsIn | Retrieves whether this is an input parameter.
IsOptional | Retrieves whether this parameter is optional.
IsOut | Retrieves whether this parameter is an output parameter.
Name | Retrieves the name of this parameter.
Position | Retrieves the signature position for this parameter.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetToken | Retrieves the token for this parameter.
GetType (inherited from Object) | Gets the Type of the Object.
SetConstant | Sets the default value of the parameter.
SetCustomAttribute | Overloaded. Sets a custom attribute.
SetMarshal | Specifies the marshalling for this parameter.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ParameterBuilder Class | System.Reflection.Emit Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ParameterBuilder Properties

The properties of the ParameterBuilder class are listed below. For a complete list of ParameterBuilder class members, see the ParameterBuilder Members topic.

Public:

Attributes | Retrieves the attributes for this parameter.
IsIn | Retrieves whether this is an input parameter.
IsOptional | Retrieves whether this parameter is optional.
IsOut | Retrieves whether this parameter is an output parameter.
Name | Retrieves the name of this parameter.
Position | Retrieves the signature position for this parameter.

See Also

ParameterBuilder Class | System.Reflection.Emit Namespace


ParameterBuilder.Attributes

Retrieves the attributes for this parameter.

[Visual Basic]
Overridable Public ReadOnly Property Attributes As Integer
[C#]
public int Attributes {virtual get;}
[C++]
public: __property virtual int get_Attributes();
[JScript]
public function get Attributes() : int;

Property Value

Read-only. Retrieves the attributes for this parameter.

See Also

ParameterBuilder Class | ParameterBuilder Members | System.Reflection.Emit Namespace


ParameterBuilder.IsIn

Retrieves whether this is an input parameter.

[Visual Basic]
Public ReadOnly Property IsIn As Boolean
[C#]
public bool IsIn {get;}
[C++]
public: __property bool get_IsIn();
[JScript]
public function get IsIn() : Boolean;

Property Value

Read-only. Retrieves whether this is an input parameter.

Remarks

This method depends on an optional metadata flag. This flag may be inserted by compilers, but the compilers are not obligated to do so.

See Also

ParameterBuilder Class | ParameterBuilder Members | System.Reflection.Emit Namespace


ParameterBuilder.IsOptional

Retrieves whether this parameter is optional.

[Visual Basic]
Public ReadOnly Property IsOptional As Boolean
[C#]
public bool IsOptional {get;}
[C++]
public: __property bool get_IsOptional();
[JScript]
public function get IsOptional() : Boolean;

Property Value

Read-only. Retrieves whether this parameter is optional.

See Also

ParameterBuilder Class | ParameterBuilder Members | System.Reflection.Emit Namespace


ParameterBuilder.IsOut

Retrieves whether this parameter is an output parameter.

[Visual Basic]
Public ReadOnly Property IsOut As Boolean
[C#]
public bool IsOut {get;}
[C++]
public: __property bool get_IsOut();
[JScript]
public function get IsOut() : Boolean;

Property Value

Read-only. Retrieves whether this parameter is an output parameter.

See Also

ParameterBuilder Class | ParameterBuilder Members | System.Reflection.Emit Namespace


ParameterBuilder.Name

Retrieves the name of this parameter.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {virtual get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

Property Value

Read-only. Retrieves the name of this parameter.

See Also

ParameterBuilder Class | ParameterBuilder Members | System.Reflection.Emit Namespace


ParameterBuilder.Position

Retrieves the signature position for this parameter.

[Visual Basic]
Overridable Public ReadOnly Property Position As Integer
[C#]
public int Position {virtual get;}
[C++]
public: __property virtual int get_Position();
[JScript]
public function get Position() : int;

Property Value

Read-only. Retrieves the signature position for this parameter.

See Also

ParameterBuilder Class | ParameterBuilder Members | System.Reflection.Emit Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ParameterBuilder Methods

The methods of the ParameterBuilder class are listed below. For a complete list of ParameterBuilder class members, see the ParameterBuilder Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetToken | Retrieves the token for this parameter.
GetType (inherited from Object) | Gets the Type of the Object.
SetConstant | Sets the default value of the parameter.
SetCustomAttribute | Overloaded. Sets a custom attribute.
SetMarshal | Specifies the marshalling for this parameter.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ParameterBuilder Class | System.Reflection.Emit Namespace


ParameterBuilder.GetToken

Retrieves the token for this parameter.

[Visual Basic]
Overridable Public Function GetToken() As ParameterToken
[C#]
public virtual ParameterToken GetToken();
[C++]
public: virtual ParameterToken GetToken();
[JScript]
public function GetToken() : ParameterToken;

Return Value

Returns the token for this parameter.

See Also

ParameterBuilder Class | ParameterBuilder Members | System.Reflection.Emit Namespace


ParameterBuilder.SetConstant

Sets the default value of the parameter.

[Visual Basic]
Overridable Public Sub SetConstant( _
   ByVal defaultValue As Object _
)
[C#]
public virtual void SetConstant(
   object defaultValue
);
[C++]
public: virtual void SetConstant(
   Object* defaultValue
);
[JScript]
public function SetConstant(
   defaultValue : Object
);

Parameters

defaultValue
The default value of this parameter.

Remarks

Should throw the following exception but currently does not:

InvalidOperationException if the containing type has been created using TypeBuilder.CreateType().

See Also

ParameterBuilder Class | ParameterBuilder Members | System.Reflection.Emit Namespace


ParameterBuilder.SetCustomAttribute

Sets a custom attribute.

Overload List

Set a custom attribute using a custom attribute builder.

[Visual Basic] Overloads Public Sub SetCustomAttribute(CustomAttributeBuilder)
[C#] public void SetCustomAttribute(CustomAttributeBuilder);
[C++] public: void SetCustomAttribute(CustomAttributeBuilder*);
[JScript] public function SetCustomAttribute(CustomAttributeBuilder);

Set a custom attribute using a specified custom attribute blob.

[Visual Basic] Overloads Public Sub SetCustomAttribute(ConstructorInfo, Byte())
[C#] public void SetCustomAttribute(ConstructorInfo, byte[]);
[C++] public: void SetCustomAttribute(ConstructorInfo*, unsigned char[]);
[JScript] public function SetCustomAttribute(ConstructorInfo, Byte[]);

See Also

ParameterBuilder Class | ParameterBuilder Members | System.Reflection.Emit Namespace


ParameterBuilder.SetCustomAttribute (CustomAttributeBuilder)

Set a custom attribute using a custom attribute builder.

[Visual Basic]
Overloads Public Sub SetCustomAttribute( _
   ByVal customBuilder As CustomAttributeBuilder _
)
[C#]
public void SetCustomAttribute(
   CustomAttributeBuilder customBuilder
);
[C++]
public: void SetCustomAttribute(
   CustomAttributeBuilder* customBuilder
);
[JScript]
public function SetCustomAttribute(
   customBuilder : CustomAttributeBuilder
);

Parameters

customBuilder
An instance of a helper class to define the custom attribute.

Exceptions

Exception Type | Condition
ArgumentNullException | if con is a null reference (in Visual Basic Nothing)

See Also

ParameterBuilder Class | ParameterBuilder Members | System.Reflection.Emit Namespace | ParameterBuilder.SetCustomAttribute Overload List


ParameterBuilder.SetCustomAttribute (ConstructorInfo, Byte[])

Set a custom attribute using a specified custom attribute blob.

[Visual Basic]
Overloads Public Sub SetCustomAttribute( _
   ByVal con As ConstructorInfo, _
   ByVal binaryAttribute() As Byte _
)
[C#]
public void SetCustomAttribute(
   ConstructorInfo con,
   byte[] binaryAttribute
);
[C++]
public: void SetCustomAttribute(
   ConstructorInfo* con,
   unsigned char* binaryAttribute[]
);
[JScript]
public function SetCustomAttribute(
   con : ConstructorInfo,
   binaryAttribute : Byte[]
);

Parameters

con
The constructor for the custom attribute.
binaryAttribute
A byte blob representing the attributes.

Exceptions

Exception Type | Condition
ArgumentNullException | if con or binaryAttribute is a null reference (in Visual Basic Nothing)

Remarks

See the for details on how to format binaryAttribute.

See Also

ParameterBuilder Class | ParameterBuilder Members | System.Reflection.Emit Namespace | ParameterBuilder.SetCustomAttribute Overload List


ParameterBuilder.SetMarshal

Specifies the marshalling for this parameter.

[Visual Basic]
Overridable Public Sub SetMarshal( _
   ByVal unmanagedMarshal As UnmanagedMarshal _
)
[C#]
public virtual void SetMarshal(
   UnmanagedMarshal unmanagedMarshal
);
[C++]
public: virtual void SetMarshal(
   UnmanagedMarshal* unmanagedMarshal
);
[JScript]
public function SetMarshal(
   unmanagedMarshal : UnmanagedMarshal
);

Parameters

unmanagedMarshal
The marshalling information for this parameter.

Exceptions

Exception Type | Condition
ArgumentNullException | if unmanagedMarshal is a null reference (in Visual Basic Nothing)

Remarks

Should throw the following exception but currently does not:

InvalidOperationException if the containing type has been created using TypeBuilder.CreateType().

See Also

ParameterBuilder Class | ParameterBuilder Members | System.Reflection.Emit Namespace


ParameterToken Structure

The ParameterToken class is an opaque representation of the Token returned by the MetaData to represent a parameter.

Object
ValueType
ParameterToken

[Visual Basic]
Public Structure ParameterToken
[C#]
public struct ParameterToken
[C++]
public __value struct ParameterToken

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

ParameterToken Members | System.Reflection.Emit Namespace


ParameterToken Members

Public:

Properties

Token Retrieves the metadata token for this parameter.

Methods

Equals | Checks if the given object is an instance of ParameterToken and is equal to this instance.
GetHashCode | Generates the hash code for this parameter.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Fields

Empty The default ParameterToken with Token value 0.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ParameterToken Structure | System.Reflection.Emit Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ParameterToken Properties

The properties of the ParameterToken structure are listed below. For a complete list of ParameterToken structure members, see the ParameterToken Members topic.

Public:

Token Retrieves the metadata token for this parameter.

See Also

ParameterToken Structure | System.Reflection.Emit Namespace


ParameterToken.Token

Retrieves the metadata token for this parameter.

[Visual Basic]
Public ReadOnly Property Token As Integer
[C#]
public int Token {get;}
[C++]
public: __property int get_Token();
[JScript]
public function get Token() : int;

Property Value

Read-only. Retrieves the metadata token for this parameter.

See Also

ParameterToken Structure | ParameterToken Members | System.Reflection.Emit Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ParameterToken Methods

The methods of the ParameterToken structure are listed below. For a complete list of ParameterToken structure members, see the ParameterToken Members topic.

Public:

Equals | Checks if the given object is an instance of ParameterToken and is equal to this instance.
GetHashCode | Generates the hash code for this parameter.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ParameterToken Structure | System.Reflection.Emit Namespace


ParameterToken.Equals

Checks if the given object is an instance of ParameterToken and is equal to this instance.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The object to compare to this object.

Return Value

Returns true if obj is an instance of ParameterToken and equals the current instance, false otherwise.

See Also

ParameterToken Structure | ParameterToken Members | System.Reflection.Emit Namespace


ParameterToken.GetHashCode

Generates the hash code for this parameter.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

Returns the hash code for this parameter.

See Also

ParameterToken Structure | ParameterToken Members | System.Reflection.Emit Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ParameterToken Fields

The fields of the ParameterToken structure are listed below. For a complete list of ParameterToken structure members, see the ParameterToken Members topic.

Public:

Empty The default ParameterToken with Token value 0.

See Also

ParameterToken Structure | System.Reflection.Emit Namespace


ParameterToken.Empty

The default ParameterToken with Token value 0.

[Visual Basic]
Public Shared ReadOnly Empty As ParameterToken
[C#]
public static readonly ParameterToken Empty;
[C++]
public: static readonly ParameterToken Empty;
[JScript]
public static var Empty : ParameterToken;

See Also

ParameterToken Structure | ParameterToken Members | System.Reflection.Emit Namespace


PEFileKinds Enumeration

Specifies the type of the PE file.

[Visual Basic]
Public Enum PEFileKinds
[C#]
public enum PEFileKinds
[C++]
public enum PEFileKinds

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Dll | The PE file is a DLL.
Exe | The PE file is an executable.

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

System.Reflection.Emit Namespace


PropertyBuilder Class

The PropertyBuilder class defines the properties for a type.

Object
PropertyBuilder

[Visual Basic]
NotInheritable Public Class PropertyBuilder
[C#]
public sealed class PropertyBuilder
[C++]
public __gc __sealed class PropertyBuilder
[JScript]
public class PropertyBuilder

Remarks

A PropertyBuilder is always associated with a TypeBuilder. The TypeBuilder.DefineProperty method will return a new PropertyBuilder to a client.

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

PropertyBuilder Members | System.Reflection.Emit Namespace


PropertyBuilder Members

Public:

Properties

PropertyToken Retrieves the token for this property.

Methods

AddOtherMethod | Add one of the other methods associated with this property.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SetConstant | Sets the default value of this property.
SetCustomAttribute | Overloaded. Sets a custom attribute.
SetGetMethod | Sets the method that gets the property value.
SetSetMethod | Sets the method that sets the property value.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyBuilder Class | System.Reflection.Emit Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PropertyBuilder Properties

The properties of the PropertyBuilder class are listed below. For a complete list of PropertyBuilder class members, see the PropertyBuilder Members topic.

Public:

PropertyToken Retrieves the token for this property.

See Also

PropertyBuilder Class | System.Reflection.Emit Namespace


PropertyBuilder.PropertyToken

Retrieves the token for this property.

[Visual Basic]
Public ReadOnly Property PropertyToken As PropertyToken
[C#]
public PropertyToken PropertyToken {get;}
[C++]
public: __property PropertyToken get_PropertyToken();
[JScript]
public function get PropertyToken() : PropertyToken;

Property Value

Read-only. Retrieves the token for this property.

See Also

PropertyBuilder Class | PropertyBuilder Members | System.Reflection.Emit Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PropertyBuilder Methods

The methods of the PropertyBuilder class are listed below. For a complete list of PropertyBuilder class members, see the PropertyBuilder Members topic.

Public:

AddOtherMethod | Add one of the other methods associated with this property.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
SetConstant | Sets the default value of this property.
SetCustomAttribute | Overloaded. Sets a custom attribute.
SetGetMethod | Sets the method that gets the property value.
SetSetMethod | Sets the method that sets the property value.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyBuilder Class | System.Reflection.Emit Namespace


PropertyBuilder.AddOtherMethod

Add one of the other methods associated with this property.

[Visual Basic]
Public Sub AddOtherMethod( _
   ByVal mdBuilder As MethodBuilder _
)
[C#]
public void AddOtherMethod(
   MethodBuilder mdBuilder
);
[C++]
public: void AddOtherMethod(
   MethodBuilder* mdBuilder
);
[JScript]
public function AddOtherMethod(
   mdBuilder : MethodBuilder
);

Parameters

mdBuilder
A MethodBuilder object that represents the other method.

Exceptions

Exception Type | Condition
ArgumentNullException | if mdBuilder is a null reference (in Visual Basic Nothing)

Remarks

Should throw the following exceptions but does not currently do so:

if mdBuilder is null.

if the containing type has been created using TypeBuilder.CreateType.

See Also

PropertyBuilder Class | PropertyBuilder Members | System.Reflection.Emit Namespace


PropertyBuilder.SetConstant

Sets the default value of this property.

[Visual Basic]
Public Sub SetConstant( _
   ByVal defaultValue As Object _
)
[C#]
public void SetConstant(
   object defaultValue
);
[C++]
public: void SetConstant(
   Object* defaultValue
);
[JScript]
public function SetConstant(
   defaultValue : Object
);

Parameters

defaultValue
The default value of this property.

See Also

PropertyBuilder Class | PropertyBuilder Members | System.Reflection.Emit Namespace


PropertyBuilder.SetCustomAttribute

Sets a custom attribute.

Overload List

Set a custom attribute using a specified custom attribute blob.

[Visual Basic] Overloads Public Sub SetCustomAttribute(ConstructorInfo, Byte())
[C#] public void SetCustomAttribute(ConstructorInfo, byte[]);
[C++] public: void SetCustomAttribute(ConstructorInfo*, unsigned char[]);
[JScript] public function SetCustomAttribute(ConstructorInfo, Byte[]);

Set a custom attribute using a custom attribute builder.

[Visual Basic] Overloads Public Sub SetCustomAttribute(CustomAttributeBuilder)
[C#] public void SetCustomAttribute(CustomAttributeBuilder);
[C++] public: void SetCustomAttribute(CustomAttributeBuilder*);
[JScript] public function SetCustomAttribute(CustomAttributeBuilder);

See Also

PropertyBuilder Class | PropertyBuilder Members | System.Reflection.Emit Namespace


PropertyBuilder.SetCustomAttribute (ConstructorInfo, Byte[])

Set a custom attribute using a specified custom attribute blob.

[Visual Basic]
Overloads Public Sub SetCustomAttribute( _
   ByVal con As ConstructorInfo, _
   ByVal binaryAttribute() As Byte _
)
[C#]
public void SetCustomAttribute(
   ConstructorInfo con,
   byte[] binaryAttribute
);
[C++]
public: void SetCustomAttribute(
   ConstructorInfo* con,
   unsigned char* binaryAttribute[]
);
[JScript]
public function SetCustomAttribute(
   con : ConstructorInfo,
   binaryAttribute : Byte[]
);

Parameters

con
The constructor for the custom attribute.
binaryAttribute
A byte blob representing the attributes.

Exceptions

Exception Type | Condition
ArgumentNullException | if con or binaryAttribute is a null reference (in Visual Basic Nothing)

Remarks

See the for details on how to format binaryAttribute.

See Also

PropertyBuilder Class | PropertyBuilder Members | System.Reflection.Emit Namespace | PropertyBuilder.SetCustomAttribute Overload List


PropertyBuilder.SetCustomAttribute (CustomAttributeBuilder)

Set a custom attribute using a custom attribute builder.

[Visual Basic]
Overloads Public Sub SetCustomAttribute( _
   ByVal customBuilder As CustomAttributeBuilder _
)
[C#]
public void SetCustomAttribute(
   CustomAttributeBuilder customBuilder
);
[C++]
public: void SetCustomAttribute(
   CustomAttributeBuilder* customBuilder
);
[JScript]
public function SetCustomAttribute(
   customBuilder : CustomAttributeBuilder
);

Parameters

customBuilder
An instance of a helper class to define the custom attribute.

Exceptions

Exception Type | Condition
ArgumentNullException | if con is a null reference (in Visual Basic Nothing)

See Also

PropertyBuilder Class | PropertyBuilder Members | System.Reflection.Emit Namespace | PropertyBuilder.SetCustomAttribute Overload List


PropertyBuilder.SetGetMethod

Sets the method that gets the property value.

[Visual Basic]
Public Sub SetGetMethod( _
   ByVal mdBuilder As MethodBuilder _
)
[C#]
public void SetGetMethod(
   MethodBuilder mdBuilder
);
[C++]
public: void SetGetMethod(
   MethodBuilder* mdBuilder
);
[JScript]
public function SetGetMethod(
   mdBuilder : MethodBuilder
);

Parameters

mdBuilder
A MethodBuilder object that represents the method that gets the property value.

Exceptions

Exception Type | Condition
ArgumentNullException | if mdBuilder is a null reference (in Visual Basic Nothing)

Remarks

Should throw the following exceptions but does not currently do so:

if mdBuilder is null.

if the containing type has been created using TypeBuilder.CreateType.

See Also

PropertyBuilder Class | PropertyBuilder Members | System.Reflection.Emit Namespace


PropertyBuilder.SetSetMethod

Sets the method that sets the property value.

[Visual Basic]
Public Sub SetSetMethod( _
   ByVal mdBuilder As MethodBuilder _
)
[C#]
public void SetSetMethod(
   MethodBuilder mdBuilder
);
[C++]
public: void SetSetMethod(
   MethodBuilder* mdBuilder
);
[JScript]
public function SetSetMethod(
   mdBuilder : MethodBuilder
);

Parameters

mdBuilder
A MethodBuilder object that represents the method that sets the property value.

Exceptions

Exception Type | Condition
ArgumentNullException | if mdBuilder is a null reference (in Visual Basic Nothing)

Remarks

Should throw the following exceptions but does not currently do so:

if mdBuilder is null.

if the containing type has been created using TypeBuilder.CreateType.

See Also

PropertyBuilder Class | PropertyBuilder Members | System.Reflection.Emit Namespace


PropertyToken Structure

The PropertyToken class is an opaque representation of the Token returned by the MetaData to represent a property.

Object
ValueType
PropertyToken

[Visual Basic]
Public Structure PropertyToken
[C#]
public struct PropertyToken
[C++]
public __value struct PropertyToken

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

PropertyToken Members | System.Reflection.Emit Namespace


PropertyToken Members

Public:

Properties

Token Retrieves the metadata token for this property.

Methods

Equals | Checks if the given object is an instance of PropertyToken and is equal to this instance.
GetHashCode | Generates the hash code for this property.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Fields

Empty The default PropertyToken with Token value 0.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyToken Structure | System.Reflection.Emit Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PropertyToken Properties

The properties of the PropertyToken structure are listed below. For a complete list of PropertyToken structure members, see the PropertyToken Members topic.

Public:

Token Retrieves the metadata token for this property.

See Also

PropertyToken Structure | System.Reflection.Emit Namespace


PropertyToken.Token

Retrieves the metadata token for this property.

[Visual Basic]
Public ReadOnly Property Token As Integer
[C#]
public int Token {get;}
[C++]
public: __property int get_Token();
[JScript]
public function get Token() : int;

Property Value

Read-only. Retrieves the metadata token for this instance.

See Also

PropertyToken Structure | PropertyToken Members | System.Reflection.Emit Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PropertyToken Methods

The methods of the PropertyToken structure are listed below. For a complete list of PropertyToken structure members, see the PropertyToken Members topic.

Public:

Equals | Checks if the given object is an instance of PropertyToken and is equal to this instance.
GetHashCode | Generates the hash code for this property.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyToken Structure | System.Reflection.Emit Namespace


PropertyToken.Equals

Checks if the given object is an instance of PropertyToken and is equal to this instance.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The object to this object.

Return Value

Returns true if obj is an instance of PropertyToken and equals the current instance, false otherwise.

See Also

PropertyToken Structure | PropertyToken Members | System.Reflection.Emit Namespace


PropertyToken.GetHashCode

Generates the hash code for this property.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

Returns the hash code for this property.

See Also

PropertyToken Structure | PropertyToken Members | System.Reflection.Emit Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PropertyToken Fields

The fields of the PropertyToken structure are listed below. For a complete list of PropertyToken structure members, see the PropertyToken Members topic.

Public:

Empty The default PropertyToken with Token value 0.

See Also

PropertyToken Structure | System.Reflection.Emit Namespace


PropertyToken.Empty

The default PropertyToken with Token value 0.

[Visual Basic]
Public Shared ReadOnly Empty As PropertyToken
[C#]
public static readonly PropertyToken Empty;
[C++]
public: static readonly PropertyToken Empty;
[JScript]
public static var Empty : PropertyToken;

See Also

PropertyToken Structure | PropertyToken Members | System.Reflection.Emit Namespace


SignatureHelper Class

The SignatureHelper class provides methods for building signatures.

Object
SignatureHelper

[Visual Basic]
NotInheritable Public Class SignatureHelper
[C#]
public sealed class SignatureHelper
[C++]
public __gc __sealed class SignatureHelper
[JScript]
public class SignatureHelper

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

SignatureHelper Members | System.Reflection.Emit Namespace


SignatureHelper Members

Public:

Methods

AddArgument | Adds an argument to the signature. Takes a Type and determines whether it is one of the primitive types or a more general class. In the former case, the method adds the appropriate short cut encoding, otherwise the method calculates the proper description for the type.
AddSentinel | Mark the vararg fix part. This is only used if the caller is creating a vararg signature call site.
Equals | Checks if this instance is equal to the given object.
GetFieldSigHelper | Returns a signature helper for a field.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLocalVarSigHelper | Returns a signature helper for a local variable.
GetMethodSigHelper | Overloaded. Returns a signature helper for a method.
GetPropertySigHelper | Returns a signature helper for a property given the property'smodule, return type, and parameter types.
GetSignature | Chops the internal signature to the appropriate length. Adds the end token to the signature and marks the signature as finished so that no further tokens can be added.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Returns a string representing the signature parameters.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SignatureHelper Class | System.Reflection.Emit Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SignatureHelper Methods

The methods of the SignatureHelper class are listed below. For a complete list of SignatureHelper class members, see the SignatureHelper Members topic.

Public:

AddArgument | Adds an argument to the signature. Takes a Type and determines whether it is one of the primitive types or a more general class. In the former case, the method adds the appropriate short cut encoding, otherwise the method calculates the proper description for the type.
AddSentinel | Mark the vararg fix part. This is only used if the caller is creating a vararg signature call site.
Equals | Checks if this instance is equal to the given object.
GetFieldSigHelper | Returns a signature helper for a field.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLocalVarSigHelper | Returns a signature helper for a local variable.
GetMethodSigHelper | Overloaded. Returns a signature helper for a method.
GetPropertySigHelper | Returns a signature helper for a property given the property'smodule, return type, and parameter types.
GetSignature | Chops the internal signature to the appropriate length. Adds the end token to the signature and marks the signature as finished so that no further tokens can be added.
GetType (inherited from Object) | Gets the Type of the Object.
ToString | Returns a string representing the signature parameters.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SignatureHelper Class | System.Reflection.Emit Namespace


SignatureHelper.AddArgument

Adds an argument to the signature. Takes a Type and determines whether it is one of the primitive types or a more general class. In the former case, the method adds the appropriate short cut encoding, otherwise the method calculates the proper description for the type.

[Visual Basic]
Public Sub AddArgument( _
   ByVal clsArgument As Type _
)
[C#]
public void AddArgument(
   Type clsArgument
);
[C++]
public: void AddArgument(
   Type* clsArgument
);
[JScript]
public function AddArgument(
   clsArgument : Type
);

Parameters

clsArgument
The type of the argument.

Exceptions

Exception Type | Condition
ArgumentException | if the signature has already been finalized

See Also

SignatureHelper Class | SignatureHelper Members | System.Reflection.Emit Namespace


SignatureHelper.AddSentinel

Mark the vararg fix part. This is only used if the caller is creating a vararg signature call site.

[Visual Basic]
Public Sub AddSentinel()
[C#]
public void AddSentinel();
[C++]
public: void AddSentinel();
[JScript]
public function AddSentinel();

See Also

SignatureHelper Class | SignatureHelper Members | System.Reflection.Emit Namespace


SignatureHelper.Equals

Checks if this instance is equal to the given object.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The object with which this instance should be compared.

Return Value

Returns true if the given object is a SignatureHelper and represents the same signature. Otherwise, returns false.

See Also

SignatureHelper Class | SignatureHelper Members | System.Reflection.Emit Namespace


SignatureHelper.GetFieldSigHelper

Returns a signature helper for a field.

[Visual Basic]
Public Shared Function GetFieldSigHelper( _
   ByVal mod As Module _
) As SignatureHelper
[C#]
public static SignatureHelper GetFieldSigHelper(
   Module mod
);
[C++]
public: static SignatureHelper* GetFieldSigHelper(
   Module* mod
);
[JScript]
public static function GetFieldSigHelper(
   mod : Module
) : SignatureHelper;

Parameters

mod
The Module that contains the field for which the SignatureHelper is requested.

Return Value

The SignatureHelper object for a field.

See Also

SignatureHelper Class | SignatureHelper Members | System.Reflection.Emit Namespace


SignatureHelper.GetLocalVarSigHelper

Returns a signature helper for a local variable.

[Visual Basic]
Public Shared Function GetLocalVarSigHelper( _
   ByVal mod As Module _
) As SignatureHelper
[C#]
public static SignatureHelper GetLocalVarSigHelper(
   Module mod
);
[C++]
public: static SignatureHelper* GetLocalVarSigHelper(
   Module* mod
);
[JScript]
public static function GetLocalVarSigHelper(
   mod : Module
) : SignatureHelper;

Parameters

mod
The Module that contains the local variable for which the SignatureHelper is requested.

Return Value

The SignatureHelper object for a local variable.

See Also

SignatureHelper Class | SignatureHelper Members | System.Reflection.Emit Namespace


SignatureHelper.GetMethodSigHelper

Returns a signature helper for a method.

Overload List

Returns a signature helper for a method given the method's module, calling convention, and return type.

[Visual Basic] Overloads Public Shared Function GetMethodSigHelper(Module, CallingConventions, Type) As SignatureHelper
[C#] public static SignatureHelper GetMethodSigHelper(Module, CallingConventions, Type);
[C++] public: static SignatureHelper* GetMethodSigHelper(Module*, CallingConventions, Type);
[JScript] public static function GetMethodSigHelper(Module, CallingConventions, Type) : SignatureHelper;

Returns a signature helper for a method given the method's module, calling convention, return type, and parameter types.

[Visual Basic] Overloads Public Shared Function GetMethodSigHelper(Module, Type, Type()) As SignatureHelper
[C#] public static SignatureHelper GetMethodSigHelper(Module, Type, Type[]);
[C++] public: static SignatureHelper* GetMethodSigHelper(Module*, Type, Type[]);
[JScript] public static function GetMethodSigHelper(Module, Type, Type[]) : SignatureHelper;

See Also

SignatureHelper Class | SignatureHelper Members | System.Reflection.Emit Namespace


SignatureHelper.GetMethodSigHelper (Module, CallingConventions, Type)

Returns a signature helper for a method given the method's module, calling convention, and return type.

[Visual Basic]
Overloads Public Shared Function GetMethodSigHelper( _
   ByVal mod As Module, _
   ByVal callingConvention As CallingConventions, _
   ByVal returnType As Type _
) As SignatureHelper
[C#]
public static SignatureHelper GetMethodSigHelper(
   Module mod,
   CallingConventions callingConvention,
   Type returnType
);
[C++]
public: static SignatureHelper* GetMethodSigHelper(
   Module* mod,
   CallingConventions callingConvention,
   Type* returnType
);
[JScript]
public static function GetMethodSigHelper(
   mod : Module,
   callingConvention : CallingConventions,
   returnType : Type
) : SignatureHelper;

Parameters

mod
The Module that contains the method for which the SignatureHelper is requested.
callingConvention
[To be supplied.]
returnType
[To be supplied.]

Return Value

The SignatureHelper object for a method.

See Also

SignatureHelper Class | SignatureHelper Members | System.Reflection.Emit Namespace | SignatureHelper.GetMethodSigHelper Overload List


SignatureHelper.GetMethodSigHelper (Module, Type, Type[])

Returns a signature helper for a method given the method's module, calling convention, return type, and parameter types.

[Visual Basic]
Overloads Public Shared Function GetMethodSigHelper( _
   ByVal mod As Module, _
   ByVal returnType As Type, _
   ByVal parameterTypes() As Type _
) As SignatureHelper
[C#]
public static SignatureHelper GetMethodSigHelper(
   Module mod,
   Type returnType,
   Type[] parameterTypes
);
[C++]
public: static SignatureHelper* GetMethodSigHelper(
   Module* mod,
   Type* returnType,
   Type* parameterTypes[]
);
[JScript]
public static function GetMethodSigHelper(
   mod : Module,
   returnType : Type,
   parameterTypes : Type[]
) : SignatureHelper;

Parameters

mod
The Module that contains the method for which the SignatureHelper is requested.
returnType
The return type of the method.
parameterTypes
The types of the parameters of the method.

Return Value

The SignatureHelper object for a method.

See Also

SignatureHelper Class | SignatureHelper Members | System.Reflection.Emit Namespace | SignatureHelper.GetMethodSigHelper Overload List


SignatureHelper.GetPropertySigHelper

Returns a signature helper for a property given the property'smodule, return type, and parameter types.

[Visual Basic]
Public Shared Function GetPropertySigHelper( _
   ByVal mod As Module, _
   ByVal returnType As Type, _
   ByVal parameterTypes() As Type _
) As SignatureHelper
[C#]
public static SignatureHelper GetPropertySigHelper(
   Module mod,
   Type returnType,
   Type[] parameterTypes
);
[C++]
public: static SignatureHelper* GetPropertySigHelper(
   Module* mod,
   Type* returnType,
   Type* parameterTypes[]
);
[JScript]
public static function GetPropertySigHelper(
   mod : Module,
   returnType : Type,
   parameterTypes : Type[]
) : SignatureHelper;

Parameters

mod
The Module that contains the property for which the SignatureHelper is requested.
returnType
[To be supplied.]
parameterTypes
[To be supplied.]

Return Value

The SignatureHelper object for a property.

See Also

SignatureHelper Class | SignatureHelper Members | System.Reflection.Emit Namespace


SignatureHelper.GetSignature

Chops the internal signature to the appropriate length. Adds the end token to the signature and marks the signature as finished so that no further tokens can be added.

[Visual Basic]
Public Function GetSignature() As Byte ()
[C#]
public byte[] GetSignature();
[C++]
public: unsigned char* GetSignature() [];
[JScript]
public function GetSignature() : Byte[];

Return Value

Returns the full signature in a trimmed array.

See Also

SignatureHelper Class | SignatureHelper Members | System.Reflection.Emit Namespace


SignatureHelper.ToString

Returns a string representing the signature parameters.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

Returns a String representing the parameters of this signature.

See Also

SignatureHelper Class | SignatureHelper Members | System.Reflection.Emit Namespace


SignatureToken Structure

The SignatureToken class is an opaque representation of the Token returned by the MetaData to represent a signature.

Object
ValueType
SignatureToken

[Visual Basic]
Public Structure SignatureToken
[C#]
public struct SignatureToken
[C++]
public __value struct SignatureToken

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

SignatureToken Members | System.Reflection.Emit Namespace


SignatureToken Members

Public:

Properties

Token Retrieves the metadata token for the Local Variable Signature for this method.

Methods

Equals | Checks if the given object is an instance of SignatureToken and is equal to this instance.
GetHashCode | Generates the hash code for this signature.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Fields

Empty The default SignatureToken with Token value 0.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SignatureToken Structure | System.Reflection.Emit Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SignatureToken Properties

The properties of the SignatureToken structure are listed below. For a complete list of SignatureToken structure members, see the SignatureToken Members topic.

Public:

Token Retrieves the metadata token for the Local Variable Signature for this method.

See Also

SignatureToken Structure | System.Reflection.Emit Namespace


SignatureToken.Token

Retrieves the metadata token for the Local Variable Signature for this method.

[Visual Basic]
Public ReadOnly Property Token As Integer
[C#]
public int Token {get;}
[C++]
public: __property int get_Token();
[JScript]
public function get Token() : int;

Property Value

Read-only. Retrieves the metadata token of this signature.

Remarks

This returns a numeric representation of the metadata token.

See Also

SignatureToken Structure | SignatureToken Members | System.Reflection.Emit Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SignatureToken Methods

The methods of the SignatureToken structure are listed below. For a complete list of SignatureToken structure members, see the SignatureToken Members topic.

Public:

Equals | Checks if the given object is an instance of SignatureToken and is equal to this instance.
GetHashCode | Generates the hash code for this signature.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SignatureToken Structure | System.Reflection.Emit Namespace


SignatureToken.Equals

Checks if the given object is an instance of SignatureToken and is equal to this instance.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The object to compare with this SignatureToken.

Return Value

Returns true if obj is an instance of SignatureToken and is equal to this object. Otherwise, returns false.

See Also

SignatureToken Structure | SignatureToken Members | System.Reflection.Emit Namespace


SignatureToken.GetHashCode

Generates the hash code for this signature.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

Returns the hash code for this signature.

Remarks

[To be supplied.]

See Also

SignatureToken Structure | SignatureToken Members | System.Reflection.Emit Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SignatureToken Fields

The fields of the SignatureToken structure are listed below. For a complete list of SignatureToken structure members, see the SignatureToken Members topic.

Public:

Empty The default SignatureToken with Token value 0.

See Also

SignatureToken Structure | System.Reflection.Emit Namespace


SignatureToken.Empty

The default SignatureToken with Token value 0.

[Visual Basic]
Public Shared ReadOnly Empty As SignatureToken
[C#]
public static readonly SignatureToken Empty;
[C++]
public: static readonly SignatureToken Empty;
[JScript]
public static var Empty : SignatureToken;

See Also

SignatureToken Structure | SignatureToken Members | System.Reflection.Emit Namespace


StackBehaviour Enumeration

Describes how values are pushed onto a stack or popped off a stack.

[Visual Basic]
Public Enum StackBehaviour
[C#]
public enum StackBehaviour
[C++]
public enum StackBehaviour

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Pop0 | No values are popped off the stack.
Pop1 | Pop one value of the stack.
Pop1_pop1 | Pop 1 value of the stack for the first operand, and 1 value of the stack for the second operand.
Popi | Pop a 32-bit integer off the stack.
Popi_pop1 | Pop a 32-bit integer of the stack for the first operand, and a value of the stack for the second operand.
Popi_popi | Pop a 32-bit integer of the stack for the first operand, and a 32-bit integer of the stack for the second operand.
Popi_popi8 | Pop a 32-bit integer of the stack for the first operand, and a 64-bit integer of the stack for the second operand.
Popi_popi_popi | Pop a 32-bit integer of the stack for the first operand, a 32-bit integer of the stack for the second operand, and a 32-bit integer of the stack for the third operand.
Popi_popr4 | Pop a 32-bit integer of the stack for the first operand, and a 32-bit floating point number of the stack for the second operand.
Popi_popr8 | Pop a 32-bit integer of the stack for the first operand, and a 64-bit floating point number of the stack for the second operand.
Popref | Pop a reference of the stack.
Popref_pop1 | Pop a reference of the stack for the first operand, and a value of the stack for the second operand.
Popref_popi | Pop a reference of the stack for the first operand, and a 32-bit integer of the stack for the second operand.
Popref_popi_popi | Pop a reference of the stack for the first operand, a value of the stack for the second operand, and a value of the stack for the third operand.
Popref_popi_popi8 | Pop a reference of the stack for the first operand, a value of the stack for the second operand, and a 64-bit integer of the stack for the third operand.
Popref_popi_popr4 | Pop a reference of the stack for the first operand, a value of the stack for the second operand, and a 32-bit integer of the stack for the third operand.
Popref_popi_popr8 | Pop a reference of the stack for the first operand, a value of the stack for the second operand, and a 64-bit floating point number of the stack for the third operand.
Popref_popi_popref | Pop a reference of the stack for the first operand, a value of the stack for the second operand, and a reference of the stack for the third operand.
Push0 | No values are pushed onto the stack.
Push1 | Pop one value onto the stack.
Push1_push1 | Push 1 value onto the stack for the first operand, and 1 value onto the stack for the second operand.
Pushi | Push a 32-bit integer onto the stack.
Pushi8 | Push a 64-bit integer onto the stack.
Pushr4 | Push a 32-bit floating point number onto the stack.
Pushr8 | Push a 64-bit floating point number onto the stack.
Pushref | Push a reference onto the stack.
Varpop | Pop a variable off the stack.
Varpush | Push a variable onto the stack.

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

System.Reflection.Emit Namespace


StringToken Structure

The StringToken class is an object representation of a token that represents a string.

Object
ValueType
StringToken

[Visual Basic]
Public Structure StringToken
[C#]
public struct StringToken
[C++]
public __value struct StringToken

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

StringToken Members | System.Reflection.Emit Namespace


StringToken Members

Public:

Properties

Token Retrieves the metadata token for this string.

Methods

Equals | Checks if the given object is an instance of StringToken and is equal to this instance.
GetHashCode | Returns the hash code for this string.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StringToken Structure | System.Reflection.Emit Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StringToken Properties

The properties of the StringToken structure are listed below. For a complete list of StringToken structure members, see the StringToken Members topic.

Public:

Token Retrieves the metadata token for this string.

See Also

StringToken Structure | System.Reflection.Emit Namespace


StringToken.Token

Retrieves the metadata token for this string.

[Visual Basic]
Public ReadOnly Property Token As Integer
[C#]
public int Token {get;}
[C++]
public: __property int get_Token();
[JScript]
public function get Token() : int;

Property Value

Read-only. Retrieves the metadata token of this string.

See Also

StringToken Structure | StringToken Members | System.Reflection.Emit Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StringToken Methods

The methods of the StringToken structure are listed below. For a complete list of StringToken structure members, see the StringToken Members topic.

Public:

Equals | Checks if the given object is an instance of StringToken and is equal to this instance.
GetHashCode | Returns the hash code for this string.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StringToken Structure | System.Reflection.Emit Namespace


StringToken.Equals

Checks if the given object is an instance of StringToken and is equal to this instance.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The object to compare with this StringToken.

Return Value

Returns true if obj is an instance of StringToken and is equal to this object. Otherwise, returns false.

See Also

StringToken Structure | StringToken Members | System.Reflection.Emit Namespace


StringToken.GetHashCode

Returns the hash code for this string.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

Returns the underlying string token.

See Also

StringToken Structure | StringToken Members | System.Reflection.Emit Namespace


TypeBuilder Class

The TypeBuilder class is used to define and instantiate classes at run time. TypeBuilder is the root class used to control the creation of dynamic classes in the runtime. TypeBuilder provides a set of routines that are used to define classes, add methods and fields, and then create the class inside the runtime. A new TypeBuilder can be created from a dynamic Module.

Object
MemberInfo
Type
TypeBuilder

[Visual Basic]
NotInheritable Public Class TypeBuilder
   Inherits Type
[C#]
public sealed class TypeBuilder : Type
[C++]
public __gc __sealed class TypeBuilder : public Type
[JScript]
public class TypeBuilder extends Type

Remarks

[To be supplied.]

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder Members

Public:

Properties

AssemblyQualifiedName | Returns the full name of this type qualified by the display name of the assembly.
Attributes (inherited from Type) | Gets a bitmask indicating the attributes associated with the Type.
BaseType | Retrieves the base type of this type.
DeclaringType | Returns the type that declared this type.
FullName | Retrieves the full path name of this type.
GUID | Retrieves the GUID of this type.
HasElementType (inherited from Type) | Gets a value indicating whether the Type ...
IsAbstract (inherited from Type) | Gets a value indicating whether the Type is abstract and must be overridden.
IsAnsiClass (inherited from Type) | Gets a value indicating whether the string format attribute AnsiClass is selected for the Type.
IsArray (inherited from Type) | Gets a value indicating whether the Type is an array.
IsAutoClass (inherited from Type) | Gets a value indicating whether the string format attribute AutoClass is selected for the Type.
IsAutoLayout (inherited from Type) | Gets a value indicating whether the class layout attribute AutoLayout is selected for the Type.
IsByRef (inherited from Type) | Gets a value indicating whether the Type is passed by reference.
IsClass (inherited from Type) | Gets a value indicating whether the Type is a class; that is, not a value type or interface.
IsCOMObject (inherited from Type) | Gets a value indicating whether the Type is a COM object.
IsContextful (inherited from Type) | Gets a value indicating whether the Type can be hosted in a context.
IsEnum (inherited from Type) | Gets a value indicating whether the Type is an enumeration.
IsExplicitLayout (inherited from Type) | Gets a value indicating whether the class layout attribute ExplicitLayout is selected for the Type.
IsImport (inherited from Type) | Gets a value indicating whether the Type was imported from another class.
IsInterface (inherited from Type) | Gets a value indicating whether the Type is an interface; that is, not a class or a value type.
IsLayoutSequential (inherited from Type) | Gets a value indicating whether the class layout attribute LayoutSequential is selected for the Type.
IsMarshalByRef (inherited from Type) | Gets a value indicating whether the Type is marshalled by reference.
IsNestedAssembly (inherited from Type) | Gets a value indicating whether the Type is nested and visible only within its own assembly.
IsNestedFamANDAssem (inherited from Type) | Gets a value indicating whether the Type is nested and visible only to classes that belong to both its own family and its own assembly.
IsNestedFamily (inherited from Type) | Gets a value indicating whether the Type is nested and visible only within its own family.
IsNestedFamORAssem (inherited from Type) | Gets a value indicating whether the Type is nested and visible only to classes that belong to its own family or to its own assembly.
IsNestedPrivate (inherited from Type) | Gets a value indicating whether the Type is nested and declared private.
IsNestedPublic (inherited from Type) | Gets a value indicating whether the Type is nested and declared public.
IsNotPublic (inherited from Type) | Gets a value indicating whether the Type is not declared public.
IsPointer (inherited from Type) | Gets a value indicating whether the Type is a pointer.
IsPrimitive (inherited from Type) | Gets a value indicating whether the Type is one of the primitive types.
IsPublic (inherited from Type) | Gets a value indicating whether the Type is declared public.
IsSealed (inherited from Type) | Gets a value indicating whether the Type is declared sealed.
IsSerializable (inherited from Type) | Gets a value indicating whether the Type is serializable.
IsSpecialName (inherited from Type) | Gets a value indicating whether the Type has a name that requires special handling.
IsUnicodeClass (inherited from Type) | Gets a value indicating whether the string format attribute UnicodeClass is selected for the Type.
IsUnmanagedValueType (inherited from Type) | Gets a value indicating whether the Type is one of the unmanaged value types.
IsValueType (inherited from Type) | Gets a value indicating whether the Type is a value type; that is, not a class or an interface.
MemberType (inherited from Type) | Gets a bit mask indicating the member type.
Module | Retrieves the dynamic module that contains this type definition.
Name | Retrieves the name of this type.
Namespace | Retrieves the namespace where this TypeBuilder is defined.
PackingSize | Retrieves the packing size of this type.
ReflectedType | Returns the type that was used to obtain this type.
Size | Retrieves the total size of a type.
TypeHandle | Not supported in dynamic modules.
TypeInitializer (inherited from Type) | Gets the name of the class constructor for the Type.
TypeToken | Returns the type token of this type.
UnderlyingSystemType | Not implemented.

Methods

AddDeclarativeSecurity | Adds declarative security to this type.
AddInterfaceImplementation | Adds an interface that this type implements.
CreateType | Creates a Type object for the class. After defining fields and methods on the class, CreateType is called in order to load its Type object.
DefineConstructor | Adds a new constructor to the class, with the given attributes and signature.
DefineDefaultConstructor | Defines the default constructor. The constructor defined here will simply call the default constructor of the parent.
DefineEvent | Adds a new event to the class, with the given name, attributes and event type.
DefineField | Adds a new fieldto the class, with the given name, attributes and field type.
DefineInitializedData | Defines initialized data field in the .sdata section of the PE file.
DefineMethod | Overloaded. Defines a method.
DefineMethodOverride | Specifies a given method body that implements a given method declaration.
DefineNestedType | Overloaded. Defines a nested type.
DefinePInvokeMethod | Overloaded. Defines a PInvoke method.
DefineProperty | Adds a new property to the class, with the given name and property signature.
DefineTypeInitializer | Defines the initializer for this type.
DefineUninitializedData | Defines uninitialized data field in the .sdata section of the PE file.
Equals (inherited from Type) | Overloaded. Determines if the underlying system type of the current Type is the same as the underlying system type of the specified Object or Type.
FindInterfaces (inherited from Type) | Returns an array of Type objects representing a filtered list of interfaces implemented or inherited by the current Type.
FindMembers (inherited from Type) | Returns a filtered array of MemberInfo objects of the specified member type.
GetArrayRank (inherited from Type) | When implemented by a derived class, gets the number of dimensions in an Array.
GetConstructor (inherited from Type) | Overloaded. Gets a specific constructor of the current Type.
GetConstructors (inherited from Type) | Overloaded. Gets the constructors of the current Type.
GetCustomAttributes | Overloaded. Overloaded. Returns the custom attributes defined for this type.
GetDefaultMembers (inherited from Type) | Searches for the members defined for the current Type whose DefaultMemberAttribute is set.
GetElementType | Not implemented.
GetEvent (inherited from Type) | Overloaded. Gets a specific event declared or inherited by the current Type.
GetEvents | Overloaded. [To be supplied.]
GetField (inherited from Type) | Overloaded. Gets a specific field of the current Type.
GetFields (inherited from Type) | Overloaded. Gets the fields of the current Type.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInterface | Overloaded. [To be supplied.]
GetInterfaceMap | Returns an interface mapping for the requested interface.
GetInterfaces | Returns an array of all the interfaces implemented on this a class and its super classes.
GetMember (inherited from Type) | Overloaded. Gets the specified members of the current Type.
GetMembers (inherited from Type) | Overloaded. Gets the members (properties, methods, fields, events, and so on) of the current Type.
GetMethod (inherited from Type) | Overloaded. Gets a specific method of the current Type.
GetMethods (inherited from Type) | Overloaded. Gets the methods of the current Type.
GetNestedType | Overloaded. [To be supplied.]
GetNestedTypes (inherited from Type) | Overloaded. Gets the types nested within the current Type.
GetProperties | Overloaded. [To be supplied.]
GetProperty (inherited from Type) | Overloaded. Gets a specific property of the current Type.
GetType (inherited from Object) | Gets the Type of the Object.
InvokeMember (inherited from Type) | Overloaded. Invokes a specific member of the current Type; essentially calls a constructor member or a method member, gets or sets a property member, gets or sets a data field member, or gets or sets an element of an array member.
IsAssignableFrom (inherited from Type) | Determines whether an instance of the specified type can be assigned to the current Type instance.
IsDefined | Checks if the specified custom attribute type is defined.
IsInstanceOfType (inherited from Type) | Determines whether the specified object is an instance of the Type.
IsSubclassOf (inherited from Type) | Determines whether the current Type is a subclass of the specified class.
SetCustomAttribute | Overloaded. Sets a custom attribute.
SetParent | Sets the parent of this Type.
ToString | Returns the name of the type excluding the namespace.

Fields

UnspecifiedTypeSize Represents that total size for the type is not specified.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetAttributeFlagsImpl | Returns the implementation attribute flags.
GetConstructorImpl | Not implemented.
GetMethodImpl | Not implemented.
GetPropertyImpl | Not implemented.
HasElementTypeImpl | Not implemented.
IsArrayImpl | Returns false always.
IsByRefImpl | Returns false always.
IsCOMObjectImpl | Checks if this type imports a COM type.
IsContextfulImpl (inherited from Type) | Implements the IsContextful property and determines whether the Type can be hosted in a context.
IsMarshalByRefImpl (inherited from Type) | Implements the IsMarshalByRef property and determines whether the Type is marshalled by reference.
IsPointerImpl | Returns false always.
IsPrimitiveImpl | Returns false always.
IsValueTypeImpl | Returns false always.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeBuilder Class | System.Reflection.Emit Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypeBuilder Properties

The properties of the TypeBuilder class are listed below. For a complete list of TypeBuilder class members, see the TypeBuilder Members topic.

Public:

AssemblyQualifiedName | Returns the full name of this type qualified by the display name of the assembly.
Attributes (inherited from Type) | Gets a bitmask indicating the attributes associated with the Type.
BaseType | Retrieves the base type of this type.
DeclaringType | Returns the type that declared this type.
FullName | Retrieves the full path name of this type.
GUID | Retrieves the GUID of this type.
HasElementType (inherited from Type) | Gets a value indicating whether the Type ...
IsAbstract (inherited from Type) | Gets a value indicating whether the Type is abstract and must be overridden.
IsAnsiClass (inherited from Type) | Gets a value indicating whether the string format attribute AnsiClass is selected for the Type.
IsArray (inherited from Type) | Gets a value indicating whether the Type is an array.
IsAutoClass (inherited from Type) | Gets a value indicating whether the string format attribute AutoClass is selected for the Type.
IsAutoLayout (inherited from Type) | Gets a value indicating whether the class layout attribute AutoLayout is selected for the Type.
IsByRef (inherited from Type) | Gets a value indicating whether the Type is passed by reference.
IsClass (inherited from Type) | Gets a value indicating whether the Type is a class; that is, not a value type or interface.
IsCOMObject (inherited from Type) | Gets a value indicating whether the Type is a COM object.
IsContextful (inherited from Type) | Gets a value indicating whether the Type can be hosted in a context.
IsEnum (inherited from Type) | Gets a value indicating whether the Type is an enumeration.
IsExplicitLayout (inherited from Type) | Gets a value indicating whether the class layout attribute ExplicitLayout is selected for the Type.
IsImport (inherited from Type) | Gets a value indicating whether the Type was imported from another class.
IsInterface (inherited from Type) | Gets a value indicating whether the Type is an interface; that is, not a class or a value type.
IsLayoutSequential (inherited from Type) | Gets a value indicating whether the class layout attribute LayoutSequential is selected for the Type.
IsMarshalByRef (inherited from Type) | Gets a value indicating whether the Type is marshalled by reference.
IsNestedAssembly (inherited from Type) | Gets a value indicating whether the Type is nested and visible only within its own assembly.
IsNestedFamANDAssem (inherited from Type) | Gets a value indicating whether the Type is nested and visible only to classes that belong to both its own family and its own assembly.
IsNestedFamily (inherited from Type) | Gets a value indicating whether the Type is nested and visible only within its own family.
IsNestedFamORAssem (inherited from Type) | Gets a value indicating whether the Type is nested and visible only to classes that belong to its own family or to its own assembly.
IsNestedPrivate (inherited from Type) | Gets a value indicating whether the Type is nested and declared private.
IsNestedPublic (inherited from Type) | Gets a value indicating whether the Type is nested and declared public.
IsNotPublic (inherited from Type) | Gets a value indicating whether the Type is not declared public.
IsPointer (inherited from Type) | Gets a value indicating whether the Type is a pointer.
IsPrimitive (inherited from Type) | Gets a value indicating whether the Type is one of the primitive types.
IsPublic (inherited from Type) | Gets a value indicating whether the Type is declared public.
IsSealed (inherited from Type) | Gets a value indicating whether the Type is declared sealed.
IsSerializable (inherited from Type) | Gets a value indicating whether the Type is serializable.
IsSpecialName (inherited from Type) | Gets a value indicating whether the Type has a name that requires special handling.
IsUnicodeClass (inherited from Type) | Gets a value indicating whether the string format attribute UnicodeClass is selected for the Type.
IsUnmanagedValueType (inherited from Type) | Gets a value indicating whether the Type is one of the unmanaged value types.
IsValueType (inherited from Type) | Gets a value indicating whether the Type is a value type; that is, not a class or an interface.
MemberType (inherited from Type) | Gets a bit mask indicating the member type.
Module | Retrieves the dynamic module that contains this type definition.
Name | Retrieves the name of this type.
Namespace | Retrieves the namespace where this TypeBuilder is defined.
PackingSize | Retrieves the packing size of this type.
ReflectedType | Returns the type that was used to obtain this type.
Size | Retrieves the total size of a type.
TypeHandle | Not supported in dynamic modules.
TypeInitializer (inherited from Type) | Gets the name of the class constructor for the Type.
TypeToken | Returns the type token of this type.
UnderlyingSystemType | Not implemented.

See Also

TypeBuilder Class | System.Reflection.Emit Namespace


TypeBuilder.AssemblyQualifiedName

Returns the full name of this type qualified by the display name of the assembly.

[Visual Basic]
Overridable Public ReadOnly Property AssemblyQualifiedName As _
   String
[C#]
public string AssemblyQualifiedName {override get;}
[C++]
public: __property virtual String* get_AssemblyQualifiedName();
[JScript]
public function get AssemblyQualifiedName() : String;

Property Value

Read-only. The full name of this type qualified by the display name of the assembly.

Remarks

The format of the returned string is:

<FullTypeName>, <AssemblyDisplayName>

See AssemblyName for a description of the format of the display name of an assembly.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.BaseType

Retrieves the base type of this type.

[Visual Basic]
Overridable Public ReadOnly Property BaseType As Type
[C#]
public Type BaseType {override get;}
[C++]
public: __property virtual Type* get_BaseType();
[JScript]
public function get BaseType() : Type;

Property Value

Read-only. Retrieves the base type of this type.

Remarks

[To be supplied.]

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.DeclaringType

Returns the type that declared this type.

[Visual Basic]
Overridable Public ReadOnly Property DeclaringType As Type
[C#]
public Type DeclaringType {override get;}
[C++]
public: __property virtual Type* get_DeclaringType();
[JScript]
public function get DeclaringType() : Type;

Property Value

Read-only. The type that declared this type.

Remarks

[To be supplied.]

Example

[To
be supplied.]

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.FullName

Retrieves the full path name of this type.

[Visual Basic]
Overridable Public ReadOnly Property FullName As String
[C#]
public string FullName {override get;}
[C++]
public: __property virtual String* get_FullName();
[JScript]
public function get FullName() : String;

Property Value

Read-only. Retrieves the full path name of this type.

Remarks

[To be supplied.]

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.GUID

Retrieves the GUID of this type.

[Visual Basic]
Overridable Public ReadOnly Property GUID As Guid
[C#]
public Guid GUID {override get;}
[C++]
public: __property virtual Guid get_GUID();
[JScript]
public function get GUID() : Guid;

Property Value

Read-only. Retrieves the GUID of this type

Exceptions

Exception Type | Condition
NotSupportedException | This method is not currently supported.

Remarks

As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.Module

Retrieves the dynamic module that contains this type definition.

[Visual Basic]
Overridable Public ReadOnly Property Module As Module
[C#]
public Module Module {override get;}
[C++]
public: __property virtual Module* get_Module();
[JScript]
public function get Module() : Module;

Property Value

Read-only. Retrieves the dynamic module that contains this type definition.

Remarks

[To be supplied.]

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.Name

Retrieves the name of this type.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {override get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

Property Value

Read-only. Retrieves the String name of this type.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.Namespace

Retrieves the namespace where this TypeBuilder is defined.

[Visual Basic]
Overridable Public ReadOnly Property Namespace As String
[C#]
public string Namespace {override get;}
[C++]
public: __property virtual String* get_Namespace();
[JScript]
public function get Namespace() : String;

Property Value

Read-only. Retrieves the namespace where this TypeBuilder is defined.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.PackingSize

Retrieves the packing size of this type.

[Visual Basic]
Public ReadOnly Property PackingSize As PackingSize
[C#]
public PackingSize PackingSize {get;}
[C++]
public: __property PackingSize get_PackingSize();
[JScript]
public function get PackingSize() : PackingSize;

Property Value

Read-only. Retrieves the packing size of this type.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.ReflectedType

Returns the type that was used to obtain this type.

[Visual Basic]
Overridable Public ReadOnly Property ReflectedType As Type
[C#]
public Type ReflectedType {override get;}
[C++]
public: __property virtual Type* get_ReflectedType();
[JScript]
public function get ReflectedType() : Type;

Property Value

Read-only. The type that was used to obtain this type.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.Size

Retrieves the total size of a type.

[Visual Basic]
Public ReadOnly Property Size As Integer
[C#]
public int Size {get;}
[C++]
public: __property int get_Size();
[JScript]
public function get Size() : int;

Property Value

Read-only. Retrieves this type's total size.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.TypeHandle

Not supported in dynamic modules.

[Visual Basic]
Overridable Public ReadOnly Property TypeHandle As _
   RuntimeTypeHandle
[C#]
public RuntimeTypeHandle TypeHandle {override get;}
[C++]
public: __property virtual RuntimeTypeHandle get_TypeHandle();
[JScript]
public function get TypeHandle() : RuntimeTypeHandle;

Property Value

Read-only. None.

Exceptions

Exception Type | Condition
NotSupportedException | Not supported in dynamic modules.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.TypeToken

Returns the type token of this type.

[Visual Basic]
Public ReadOnly Property TypeToken As TypeToken
[C#]
public TypeToken TypeToken {get;}
[C++]
public: __property TypeToken get_TypeToken();
[JScript]
public function get TypeToken() : TypeToken;

Property Value

Read-only. Returns the TypeToken of this type.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.UnderlyingSystemType

Not implemented.

[Visual Basic]
Overridable Public ReadOnly Property UnderlyingSystemType As Type
[C#]
public Type UnderlyingSystemType {override get;}
[C++]
public: __property virtual Type* get_UnderlyingSystemType();
[JScript]
public function get UnderlyingSystemType() : Type;

Exceptions

Exception Type | Condition
NotSupportedException | This method is not supported.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypeBuilder Methods

The methods of the TypeBuilder class are listed below. For a complete list of TypeBuilder class members, see the TypeBuilder Members topic.

Public:

AddDeclarativeSecurity | Adds declarative security to this type.
AddInterfaceImplementation | Adds an interface that this type implements.
CreateType | Creates a Type object for the class. After defining fields and methods on the class, CreateType is called in order to load its Type object.
DefineConstructor | Adds a new constructor to the class, with the given attributes and signature.
DefineDefaultConstructor | Defines the default constructor. The constructor defined here will simply call the default constructor of the parent.
DefineEvent | Adds a new event to the class, with the given name, attributes and event type.
DefineField | Adds a new fieldto the class, with the given name, attributes and field type.
DefineInitializedData | Defines initialized data field in the .sdata section of the PE file.
DefineMethod | Overloaded. Defines a method.
DefineMethodOverride | Specifies a given method body that implements a given method declaration.
DefineNestedType | Overloaded. Defines a nested type.
DefinePInvokeMethod | Overloaded. Defines a PInvoke method.
DefineProperty | Adds a new property to the class, with the given name and property signature.
DefineTypeInitializer | Defines the initializer for this type.
DefineUninitializedData | Defines uninitialized data field in the .sdata section of the PE file.
Equals (inherited from Type) | Overloaded. Determines if the underlying system type of the current Type is the same as the underlying system type of the specified Object or Type.
FindInterfaces (inherited from Type) | Returns an array of Type objects representing a filtered list of interfaces implemented or inherited by the current Type.
FindMembers (inherited from Type) | Returns a filtered array of MemberInfo objects of the specified member type.
GetArrayRank (inherited from Type) | When implemented by a derived class, gets the number of dimensions in an Array.
GetConstructor (inherited from Type) | Overloaded. Gets a specific constructor of the current Type.
GetConstructors (inherited from Type) | Overloaded. Gets the constructors of the current Type.
GetCustomAttributes | Overloaded. Overloaded. Returns the custom attributes defined for this type.
GetDefaultMembers (inherited from Type) | Searches for the members defined for the current Type whose DefaultMemberAttribute is set.
GetElementType | Not implemented.
GetEvent (inherited from Type) | Overloaded. Gets a specific event declared or inherited by the current Type.
GetEvents | Overloaded. [To be supplied.]
GetField (inherited from Type) | Overloaded. Gets a specific field of the current Type.
GetFields (inherited from Type) | Overloaded. Gets the fields of the current Type.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInterface | Overloaded. [To be supplied.]
GetInterfaceMap | Returns an interface mapping for the requested interface.
GetInterfaces | Returns an array of all the interfaces implemented on this a class and its super classes.
GetMember (inherited from Type) | Overloaded. Gets the specified members of the current Type.
GetMembers (inherited from Type) | Overloaded. Gets the members (properties, methods, fields, events, and so on) of the current Type.
GetMethod (inherited from Type) | Overloaded. Gets a specific method of the current Type.
GetMethods (inherited from Type) | Overloaded. Gets the methods of the current Type.
GetNestedType | Overloaded. [To be supplied.]
GetNestedTypes (inherited from Type) | Overloaded. Gets the types nested within the current Type.
GetProperties | Overloaded. [To be supplied.]
GetProperty (inherited from Type) | Overloaded. Gets a specific property of the current Type.
GetType (inherited from Object) | Gets the Type of the Object.
InvokeMember (inherited from Type) | Overloaded. Invokes a specific member of the current Type; essentially calls a constructor member or a method member, gets or sets a property member, gets or sets a data field member, or gets or sets an element of an array member.
IsAssignableFrom (inherited from Type) | Determines whether an instance of the specified type can be assigned to the current Type instance.
IsDefined | Checks if the specified custom attribute type is defined.
IsInstanceOfType (inherited from Type) | Determines whether the specified object is an instance of the Type.
IsSubclassOf (inherited from Type) | Determines whether the current Type is a subclass of the specified class.
SetCustomAttribute | Overloaded. Sets a custom attribute.
SetParent | Sets the parent of this Type.
ToString | Returns the name of the type excluding the namespace.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetAttributeFlagsImpl | Returns the implementation attribute flags.
GetConstructorImpl | Not implemented.
GetMethodImpl | Not implemented.
GetPropertyImpl | Not implemented.
HasElementTypeImpl | Not implemented.
IsArrayImpl | Returns false always.
IsByRefImpl | Returns false always.
IsCOMObjectImpl | Checks if this type imports a COM type.
IsContextfulImpl (inherited from Type) | Implements the IsContextful property and determines whether the Type can be hosted in a context.
IsMarshalByRefImpl (inherited from Type) | Implements the IsMarshalByRef property and determines whether the Type is marshalled by reference.
IsPointerImpl | Returns false always.
IsPrimitiveImpl | Returns false always.
IsValueTypeImpl | Returns false always.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeBuilder Class | System.Reflection.Emit Namespace


TypeBuilder.AddDeclarativeSecurity

Adds declarative security to this type.

[Visual Basic]
Public Sub AddDeclarativeSecurity( _
   ByVal action As SecurityAction, _
   ByVal pset As PermissionSet _
)
[C#]
public void AddDeclarativeSecurity(
   SecurityAction action,
   PermissionSet pset
);
[C++]
public: void AddDeclarativeSecurity(
   SecurityAction action,
   PermissionSet* pset
);
[JScript]
public function AddDeclarativeSecurity(
   action : SecurityAction,
   pset : PermissionSet
);

Parameters

action
The security action to be taken such as Demand, Assert, etc.
pset
The set of permissions the action applies to.

Remarks

AddDeclarativeSecurity may be called several times with each call specifying a security action (e.g., Demand, Assert, Deny) and a set of permissions that apply to the action.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.AddInterfaceImplementation

Adds an interface that this type implements.

[Visual Basic]
Public Sub AddInterfaceImplementation( _
   ByVal interfaceType As Type _
)
[C#]
public void AddInterfaceImplementation(
   Type interfaceType
);
[C++]
public: void AddInterfaceImplementation(
   Type* interfaceType
);
[JScript]
public function AddInterfaceImplementation(
   interfaceType : Type
);

Parameters

interfaceType
The interface that this type implements

Exceptions

Exception Type | Condition
ArgumentNullException | if interfaceType is a null reference (in Visual Basic Nothing)
InvalidOperationException | if the type was previously created using CreateType

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.CreateType

Creates a Type object for the class. After defining fields and methods on the class, CreateType is called in order to load its Type object.

[Visual Basic]
Public Function CreateType() As Type
[C#]
public Type CreateType();
[C++]
public: Type* CreateType();
[JScript]
public function CreateType() : Type;

Return Value

Returns the new Type object for this class.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.DefineConstructor

Adds a new constructor to the class, with the given attributes and signature.

[Visual Basic]
Public Function DefineConstructor( _
   ByVal attributes As MethodAttributes, _
   ByVal callingConvention As CallingConventions, _
   ByVal parameterTypes() As Type _
) As ConstructorBuilder
[C#]
public ConstructorBuilder DefineConstructor(
   MethodAttributes attributes,
   CallingConventions callingConvention,
   Type[] parameterTypes
);
[C++]
public: ConstructorBuilder* DefineConstructor(
   MethodAttributes attributes,
   CallingConventions callingConvention,
   Type* parameterTypes[]
);
[JScript]
public function DefineConstructor(
   attributes : MethodAttributes,
   callingConvention : CallingConventions,
   parameterTypes : Type[]
) : ConstructorBuilder;

Parameters

attributes
The attributes of the constructor.
callingConvention
The calling convention of the constructor.
parameterTypes
The types of the parameters of the constructor.

Return Value

The defined constructor.

Exceptions

Exception Type | Condition
InvalidOperationException | if the type was previously created using CreateType

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.DefineDefaultConstructor

Defines the default constructor. The constructor defined here will simply call the default constructor of the parent.

[Visual Basic]
Public Function DefineDefaultConstructor( _
   ByVal attributes As MethodAttributes _
) As ConstructorBuilder
[C#]
public ConstructorBuilder DefineDefaultConstructor(
   MethodAttributes attributes
);
[C++]
public: ConstructorBuilder* DefineDefaultConstructor(
   MethodAttributes attributes
);
[JScript]
public function DefineDefaultConstructor(
   attributes : MethodAttributes
) : ConstructorBuilder;

Parameters

attributes
A MethodAttributes object representing the attributes to be applied to the constructor.

Return Value

Returns the constructor.

Exceptions

Exception Type | Condition
NotSupportedException | if the parent class does not have a default constructor

Remarks

Since the default constructor is automatically defined, it is only necessary to call this method if the attributes on the default constructor should be set to something other than MethodBase.Constructor. This method is provided here to make it easier to set the attributes.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.DefineEvent

Adds a new event to the class, with the given name, attributes and event type.

[Visual Basic]
Public Function DefineEvent( _
   ByVal name As String, _
   ByVal attributes As EventAttributes, _
   ByVal eventtype As Type _
) As EventBuilder
[C#]
public EventBuilder DefineEvent(
   string name,
   EventAttributes attributes,
   Type eventtype
);
[C++]
public: EventBuilder* DefineEvent(
   String* name,
   EventAttributes attributes,
   Type* eventtype
);
[JScript]
public function DefineEvent(
   name : String,
   attributes : EventAttributes,
   eventtype : Type
) : EventBuilder;

Parameters

name
The name of the event.
attributes
The attributes of the event.
eventtype
The type of the event.

Return Value

The defined event.

Exceptions

Exception Type | Condition
ArgumentNullException | if name is a null reference (in Visual Basic Nothing)
InvalidOperationException | if the type was previously created using CreateType

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.DefineField

Adds a new fieldto the class, with the given name, attributes and field type.

[Visual Basic]
Public Function DefineField( _
   ByVal fieldName As String, _
   ByVal type As Type, _
   ByVal attributes As FieldAttributes _
) As FieldBuilder
[C#]
public FieldBuilder DefineField(
   string fieldName,
   Type type,
   FieldAttributes attributes
);
[C++]
public: FieldBuilder* DefineField(
   String* fieldName,
   Type* type,
   FieldAttributes attributes
);
[JScript]
public function DefineField(
   fieldName : String,
   type : Type,
   attributes : FieldAttributes
) : FieldBuilder;

Parameters

fieldName
The name of the field.
type
The type of the field
attributes
The attributes of the field.

Return Value

The defined field.

Exceptions

Exception Type | Condition
ArgumentNullException | if fieldName is a null reference (in Visual Basic Nothing)
InvalidOperationException | if the type was previously created using CreateType

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.DefineInitializedData

Defines initialized data field in the .sdata section of the PE file.

[Visual Basic]
Public Function DefineInitializedData( _
   ByVal name As String, _
   ByVal data() As Byte, _
   ByVal attributes As FieldAttributes _
) As FieldBuilder
[C#]
public FieldBuilder DefineInitializedData(
   string name,
   byte[] data,
   FieldAttributes attributes
);
[C++]
public: FieldBuilder* DefineInitializedData(
   String* name,
   unsigned char* data[],
   FieldAttributes attributes
);
[JScript]
public function DefineInitializedData(
   name : String,
   data : Byte[],
   attributes : FieldAttributes
) : FieldBuilder;

Parameters

name
The name used to refer to the data.
data
[To be supplied.]
attributes
[To be supplied.]

Return Value

A field to reference the data.

Exceptions

Exception Type | Condition
ArgumentNullException | if name is a null reference (in Visual Basic Nothing)
InvalidOperationException | if CreateGlobalFunctions has been previously called

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.DefineMethod

Defines a method.

Overload List

Adds a new method to the class, with the given name and method signature.

[Visual Basic] Overloads Public Function DefineMethod(String, MethodAttributes, Type, Type()) As MethodBuilder
[C#] public MethodBuilder DefineMethod(String, MethodAttributes, Type, Type[]);
[C++] public: MethodBuilder* DefineMethod(String*, MethodAttributes, Type, Type[]);
[JScript] public function DefineMethod(String, MethodAttributes, Type, Type[]) : MethodBuilder;

Adds a new method to the class, with the given name and method signature.

[Visual Basic] Overloads Public Function DefineMethod(String, MethodAttributes, CallingConventions, Type, Type()) As MethodBuilder
[C#] public MethodBuilder DefineMethod(String, MethodAttributes, CallingConventions, Type, Type[]);
[C++] public: MethodBuilder* DefineMethod(String*, MethodAttributes, CallingConventions, Type, Type[]);
[JScript] public function DefineMethod(String, MethodAttributes, CallingConventions, Type, Type[]) : MethodBuilder;

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.DefineMethod (String, MethodAttributes, Type, Type[])

Adds a new method to the class, with the given name and method signature.

[Visual Basic]
Overloads Public Function DefineMethod( _
   ByVal name As String, _
   ByVal attributes As MethodAttributes, _
   ByVal returnType As Type, _
   ByVal parameterTypes() As Type _
) As MethodBuilder
[C#]
public MethodBuilder DefineMethod(
   string name,
   MethodAttributes attributes,
   Type returnType,
   Type[] parameterTypes
);
[C++]
public: MethodBuilder* DefineMethod(
   String* name,
   MethodAttributes attributes,
   Type* returnType,
   Type* parameterTypes[]
);
[JScript]
public function DefineMethod(
   name : String,
   attributes : MethodAttributes,
   returnType : Type,
   parameterTypes : Type[]
) : MethodBuilder;

Parameters

name
The name of the method.
attributes
The attributes of the method.
returnType
The return type of the method.
parameterTypes
The types of the parameters of the method.

Return Value

The defined method.

Exceptions

Exception Type | Condition
ArgumentNullException | if name is a null reference (in Visual Basic Nothing)
InvalidOperationException | if the type was previously created using CreateType

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace | TypeBuilder.DefineMethod Overload List


TypeBuilder.DefineMethod (String, MethodAttributes, CallingConventions, Type, Type[])

Adds a new method to the class, with the given name and method signature.

[Visual Basic]
Overloads Public Function DefineMethod( _
   ByVal name As String, _
   ByVal attributes As MethodAttributes, _
   ByVal callingConvention As CallingConventions, _
   ByVal returnType As Type, _
   ByVal parameterTypes() As Type _
) As MethodBuilder
[C#]
public MethodBuilder DefineMethod(
   string name,
   MethodAttributes attributes,
   CallingConventions callingConvention,
   Type returnType,
   Type[] parameterTypes
);
[C++]
public: MethodBuilder* DefineMethod(
   String* name,
   MethodAttributes attributes,
   CallingConventions callingConvention,
   Type* returnType,
   Type* parameterTypes[]
);
[JScript]
public function DefineMethod(
   name : String,
   attributes : MethodAttributes,
   callingConvention : CallingConventions,
   returnType : Type,
   parameterTypes : Type[]
) : MethodBuilder;

Parameters

name
The name of the method.
attributes
The attributes of the method.
callingConvention
[To be supplied.]
returnType
The return type of the method.
parameterTypes
The types of the parameters of the method.

Return Value

The defined method.

Exceptions

Exception Type | Condition
ArgumentNullException | if name is a null reference (in Visual Basic Nothing)
InvalidOperationException | if the type was previously created using CreateType

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace | TypeBuilder.DefineMethod Overload List


TypeBuilder.DefineMethodOverride

Specifies a given method body that implements a given method declaration.

[Visual Basic]
Public Sub DefineMethodOverride( _
   ByVal methodInfoBody As MethodInfo, _
   ByVal methodInfoDeclaration As MethodInfo _
)
[C#]
public void DefineMethodOverride(
   MethodInfo methodInfoBody,
   MethodInfo methodInfoDeclaration
);
[C++]
public: void DefineMethodOverride(
   MethodInfo* methodInfoBody,
   MethodInfo* methodInfoDeclaration
);
[JScript]
public function DefineMethodOverride(
   methodInfoBody : MethodInfo,
   methodInfoDeclaration : MethodInfo
);

Parameters

methodInfoBody
The method body to be used.
methodInfoDeclaration
The method whose declaration is to be used.

Remarks

DefineMethodOverride defines a method impl. A method impl is a token point to an implementation and a token pointing to a declaration that the body will implement. The body must be defined on the type the method impl is defined and the body must be virtual. The declaration can be to a method defined on an interface implemented by the type, a method on a subclass or a method defined in the type. If the declaration is on an interface only the slot defined for the interface is altered. If the declaration is to a method on a base type then the slot for the method is overridden and any duplicates for the overridden method are also replaced. The method overridden may not be the actual method declared. If the method is on the same type then the slot is replaced and any duplicates for the replaced methods are overridden

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.DefineNestedType

Defines a nested type.

Overload List

Defines a nested type given its name and attributes.

[Visual Basic] Overloads Public Function DefineNestedType(String, TypeAttributes) As TypeBuilder
[C#] public TypeBuilder DefineNestedType(String, TypeAttributes);
[C++] public: TypeBuilder* DefineNestedType(String*, TypeAttributes);
[JScript] public function DefineNestedType(String, TypeAttributes) : TypeBuilder;

Defines a nested type given its name, attributes, the total size of the type, and the type that it extends.

[Visual Basic] Overloads Public Function DefineNestedType(String, TypeAttributes, Type, Integer) As TypeBuilder
[C#] public TypeBuilder DefineNestedType(String, TypeAttributes, Type, int);
[C++] public: TypeBuilder* DefineNestedType(String*, TypeAttributes, Type, int);
[JScript] public function DefineNestedType(String, TypeAttributes, Type, int) : TypeBuilder;

Defines a nested type given its name, attributes, and the type that it extends.

[Visual Basic] Overloads Public Function DefineNestedType(String, TypeAttributes, Type) As TypeBuilder
[C#] public TypeBuilder DefineNestedType(String, TypeAttributes, Type);
[C++] public: TypeBuilder* DefineNestedType(String*, TypeAttributes, Type);
[JScript] public function DefineNestedType(String, TypeAttributes, Type) : TypeBuilder;

Defines a nested type given its name, attributes, the type that it extends, and the interfaces that it implements.

[Visual Basic] Overloads Public Function DefineNestedType(String, TypeAttributes, Type, Type()) As TypeBuilder
[C#] public TypeBuilder DefineNestedType(String, TypeAttributes, Type, Type[]);
[C++] public: TypeBuilder* DefineNestedType(String*, TypeAttributes, Type, Type[]);
[JScript] public function DefineNestedType(String, TypeAttributes, Type, Type[]) : TypeBuilder;

Defines a nested type given its name.

[Visual Basic] Overloads Public Function DefineNestedType(String) As TypeBuilder
[C#] public TypeBuilder DefineNestedType(String);
[C++] public: TypeBuilder* DefineNestedType(String*);
[JScript] public function DefineNestedType(String) : TypeBuilder;

Defines a nested type given its name, attributes, the total size of the type, and the type that it extends.

[Visual Basic] Overloads Public Function DefineNestedType(String, TypeAttributes, Type, PackingSize) As TypeBuilder
[C#] public TypeBuilder DefineNestedType(String, TypeAttributes, Type, PackingSize);
[C++] public: TypeBuilder* DefineNestedType(String*, TypeAttributes, Type, PackingSize);
[JScript] public function DefineNestedType(String, TypeAttributes, Type, PackingSize) : TypeBuilder;

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.DefineNestedType (String, TypeAttributes)

Defines a nested type given its name and attributes.

[Visual Basic]
Overloads Public Function DefineNestedType( _
   ByVal name As String, _
   ByVal attr As TypeAttributes _
) As TypeBuilder
[C#]
public TypeBuilder DefineNestedType(
   string name,
   TypeAttributes attr
);
[C++]
public: TypeBuilder* DefineNestedType(
   String* name,
   TypeAttributes attr
);
[JScript]
public function DefineNestedType(
   name : String,
   attr : TypeAttributes
) : TypeBuilder;

Parameters

name
The full path name of the type.
attr
The attributes of the type.

Return Value

The defined nested type.

Exceptions

Exception Type | Condition
ArgumentException | if the nested attribute is not specified, or if this type is sealed, or if this type is an array, or if this type is an interface but the nested type is not an interface
ArgumentNullException | if name is a null reference (in Visual Basic Nothing) or a null interface is specified in the interfaces array
InvalidOperationException | if the type was previously created using CreateType

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace | TypeBuilder.DefineNestedType Overload List


TypeBuilder.DefineNestedType (String, TypeAttributes, Type, Int32)

Defines a nested type given its name, attributes, the total size of the type, and the type that it extends.

[Visual Basic]
Overloads Public Function DefineNestedType( _
   ByVal name As String, _
   ByVal attr As TypeAttributes, _
   ByVal parent As Type, _
   ByVal typeSize As Integer _
) As TypeBuilder
[C#]
public TypeBuilder DefineNestedType(
   string name,
   TypeAttributes attr,
   Type parent,
   int typeSize
);
[C++]
public: TypeBuilder* DefineNestedType(
   String* name,
   TypeAttributes attr,
   Type* parent,
   int typeSize
);
[JScript]
public function DefineNestedType(
   name : String,
   attr : TypeAttributes,
   parent : Type,
   typeSize : int
) : TypeBuilder;

Parameters

name
The full path name of the type.
attr
The attributes of the type.
parent
The type that the nested type extends.
typeSize
[To be supplied.]

Return Value

The defined nested type.

Exceptions

Exception Type | Condition
ArgumentException | if the nested attribute is not specified, or if this type is sealed, or if this type is an array, or if this type is an interface but the nested type is not an interface
ArgumentNullException | if name is a null reference (in Visual Basic Nothing) or a null interface is specified in the interfaces array
InvalidOperationException | if the type was previously created using CreateType

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace | TypeBuilder.DefineNestedType Overload List


TypeBuilder.DefineNestedType (String, TypeAttributes, Type)

Defines a nested type given its name, attributes, and the type that it extends.

[Visual Basic]
Overloads Public Function DefineNestedType( _
   ByVal name As String, _
   ByVal attr As TypeAttributes, _
   ByVal parent As Type _
) As TypeBuilder
[C#]
public TypeBuilder DefineNestedType(
   string name,
   TypeAttributes attr,
   Type parent
);
[C++]
public: TypeBuilder* DefineNestedType(
   String* name,
   TypeAttributes attr,
   Type* parent
);
[JScript]
public function DefineNestedType(
   name : String,
   attr : TypeAttributes,
   parent : Type
) : TypeBuilder;

Parameters

name
The full path name of the type.
attr
The attributes of the type.
parent
The type that the nested type extends.

Return Value

The defined nested type.

Exceptions

Exception Type | Condition
ArgumentException | if the nested attribute is not specified, or if this type is sealed, or if this type is an array, or if this type is an interface but the nested type is not an interface
ArgumentNullException | if name is a null reference (in Visual Basic Nothing) or a null interface is specified in the interfaces array
InvalidOperationException | if the type was previously created using CreateType

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace | TypeBuilder.DefineNestedType Overload List


TypeBuilder.DefineNestedType (String, TypeAttributes, Type, Type[])

Defines a nested type given its name, attributes, the type that it extends, and the interfaces that it implements.

[Visual Basic]
Overloads Public Function DefineNestedType( _
   ByVal name As String, _
   ByVal attr As TypeAttributes, _
   ByVal parent As Type, _
   ByVal interfaces() As Type _
) As TypeBuilder
[C#]
public TypeBuilder DefineNestedType(
   string name,
   TypeAttributes attr,
   Type parent,
   Type[] interfaces
);
[C++]
public: TypeBuilder* DefineNestedType(
   String* name,
   TypeAttributes attr,
   Type* parent,
   Type* interfaces[]
);
[JScript]
public function DefineNestedType(
   name : String,
   attr : TypeAttributes,
   parent : Type,
   interfaces : Type[]
) : TypeBuilder;

Parameters

name
The full path name of the type.
attr
The attributes of the type.
parent
The type that the nested type extends.
interfaces
The interfaces that the nested type implements.

Return Value

The defined nested type.

Exceptions

Exception Type | Condition
ArgumentException | if the nested attribute is not specified, or if this type is sealed, or if this type is an array, or if this type is an interface but the nested type is not an interface
ArgumentNullException | if name is a null reference (in Visual Basic Nothing) or a null interface is specified in the interfaces array
InvalidOperationException | if the type was previously created using CreateType

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace | TypeBuilder.DefineNestedType Overload List


TypeBuilder.DefineNestedType (String)

Defines a nested type given its name.

[Visual Basic]
Overloads Public Function DefineNestedType( _
   ByVal name As String _
) As TypeBuilder
[C#]
public TypeBuilder DefineNestedType(
   string name
);
[C++]
public: TypeBuilder* DefineNestedType(
   String* name
);
[JScript]
public function DefineNestedType(
   name : String
) : TypeBuilder;

Parameters

name
The full path name of the type.

Return Value

The defined nested type.

Exceptions

Exception Type | Condition
ArgumentNullException | if name is a null reference (in Visual Basic Nothing) or a null interface is specified in the interfaces array
InvalidOperationException | if the type was previously created using CreateType

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace | TypeBuilder.DefineNestedType Overload List


TypeBuilder.DefineNestedType (String, TypeAttributes, Type, PackingSize)

Defines a nested type given its name, attributes, the total size of the type, and the type that it extends.

[Visual Basic]
Overloads Public Function DefineNestedType( _
   ByVal name As String, _
   ByVal attr As TypeAttributes, _
   ByVal parent As Type, _
   ByVal packSize As PackingSize _
) As TypeBuilder
[C#]
public TypeBuilder DefineNestedType(
   string name,
   TypeAttributes attr,
   Type parent,
   PackingSize packSize
);
[C++]
public: TypeBuilder* DefineNestedType(
   String* name,
   TypeAttributes attr,
   Type* parent,
   PackingSize packSize
);
[JScript]
public function DefineNestedType(
   name : String,
   attr : TypeAttributes,
   parent : Type,
   packSize : PackingSize
) : TypeBuilder;

Parameters

name
The full path name of the type.
attr
The attributes of the type.
parent
The type that the nested type extends.
packSize
The packing size of the type.

Return Value

The defined nested type.

Exceptions

Exception Type | Condition
ArgumentException | if the nested attribute is not specified, or if this type is sealed, or if this type is an array, or if this type is an interface but the nested type is not an interface
ArgumentNullException | if name is a null reference (in Visual Basic Nothing) or a null interface is specified in the interfaces array
InvalidOperationException | if the type was previously created using CreateType

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace | TypeBuilder.DefineNestedType Overload List


TypeBuilder.DefinePInvokeMethod

Defines a PInvoke method.

Overload List

Defines a PInvoke method given its name, the name of the DLL in which the method is defined, the attributes of the method, the calling convention of the method, the return type of the method, the types of the parameters of the method, and the PInvoke flags.

[Visual Basic] Overloads Public Function DefinePInvokeMethod(String, String, String, MethodAttributes, CallingConventions, Type, Type(), PInvokeMap) As MethodBuilder
[C#] public MethodBuilder DefinePInvokeMethod(String, String, String, MethodAttributes, CallingConventions, Type, Type[], PInvokeMap);
[C++] public: MethodBuilder* DefinePInvokeMethod(String*, String*, String*, MethodAttributes, CallingConventions, Type, Type[], PInvokeMap);
[JScript] public function DefinePInvokeMethod(String, String, String, MethodAttributes, CallingConventions, Type, Type[], PInvokeMap) : MethodBuilder;

Defines a PInvoke method given its name, the name of the DLL in which the method is defined, the attributes of the method, the calling convention of the method, the return type of the method, the types of the parameters of the method, and the PInvoke flags.

[Visual Basic] Overloads Public Function DefinePInvokeMethod(String, String, MethodAttributes, CallingConventions, Type, Type(), PInvokeMap) As MethodBuilder
[C#] public MethodBuilder DefinePInvokeMethod(String, String, MethodAttributes, CallingConventions, Type, Type[], PInvokeMap);
[C++] public: MethodBuilder* DefinePInvokeMethod(String*, String*, MethodAttributes, CallingConventions, Type, Type[], PInvokeMap);
[JScript] public function DefinePInvokeMethod(String, String, MethodAttributes, CallingConventions, Type, Type[], PInvokeMap) : MethodBuilder;

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.DefinePInvokeMethod (String, String, String, MethodAttributes, CallingConventions, Type, Type[], PInvokeMap)

Defines a PInvoke method given its name, the name of the DLL in which the method is defined, the attributes of the method, the calling convention of the method, the return type of the method, the types of the parameters of the method, and the PInvoke flags.

[Visual Basic]
Overloads Public Function DefinePInvokeMethod( _
   ByVal name As String, _
   ByVal dllName As String, _
   ByVal entryName As String, _
   ByVal attributes As MethodAttributes, _
   ByVal callingConvention As CallingConventions, _
   ByVal returnType As Type, _
   ByVal parameterTypes() As Type, _
   ByVal linkFlags As PInvokeMap _
) As MethodBuilder
[C#]
public MethodBuilder DefinePInvokeMethod(
   string name,
   string dllName,
   string entryName,
   MethodAttributes attributes,
   CallingConventions callingConvention,
   Type returnType,
   Type[] parameterTypes,
   PInvokeMap linkFlags
);
[C++]
public: MethodBuilder* DefinePInvokeMethod(
   String* name,
   String* dllName,
   String* entryName,
   MethodAttributes attributes,
   CallingConventions callingConvention,
   Type* returnType,
   Type* parameterTypes[],
   PInvokeMap linkFlags
);
[JScript]
public function DefinePInvokeMethod(
   name : String,
   dllName : String,
   entryName : String,
   attributes : MethodAttributes,
   callingConvention : CallingConventions,
   returnType : Type,
   parameterTypes : Type[],
   linkFlags : PInvokeMap
) : MethodBuilder;

Parameters

name
The name of the PInvoke method.
dllName
[To be supplied.]
entryName
[To be supplied.]
attributes
[To be supplied.]
callingConvention
[To be supplied.]
returnType
[To be supplied.]
parameterTypes
[To be supplied.]
linkFlags
[To be supplied.]

Return Value

The defined PInvoke method.

Exceptions

Exception Type | Condition
ArgumentException | if the method is not static or if the containing type is an interface or if the method is abstract of if the method was previously defined
ArgumentNullException | if name or dllName is a null reference (in Visual Basic Nothing)
InvalidOperationException | if the containing type has been previously created using CreateType

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace | TypeBuilder.DefinePInvokeMethod Overload List


TypeBuilder.DefinePInvokeMethod (String, String, MethodAttributes, CallingConventions, Type, Type[], PInvokeMap)

Defines a PInvoke method given its name, the name of the DLL in which the method is defined, the attributes of the method, the calling convention of the method, the return type of the method, the types of the parameters of the method, and the PInvoke flags.

[Visual Basic]
Overloads Public Function DefinePInvokeMethod( _
   ByVal name As String, _
   ByVal dllName As String, _
   ByVal attributes As MethodAttributes, _
   ByVal callingConvention As CallingConventions, _
   ByVal returnType As Type, _
   ByVal parameterTypes() As Type, _
   ByVal linkFlags As PInvokeMap _
) As MethodBuilder
[C#]
public MethodBuilder DefinePInvokeMethod(
   string name,
   string dllName,
   MethodAttributes attributes,
   CallingConventions callingConvention,
   Type returnType,
   Type[] parameterTypes,
   PInvokeMap linkFlags
);
[C++]
public: MethodBuilder* DefinePInvokeMethod(
   String* name,
   String* dllName,
   MethodAttributes attributes,
   CallingConventions callingConvention,
   Type* returnType,
   Type* parameterTypes[],
   PInvokeMap linkFlags
);
[JScript]
public function DefinePInvokeMethod(
   name : String,
   dllName : String,
   attributes : MethodAttributes,
   callingConvention : CallingConventions,
   returnType : Type,
   parameterTypes : Type[],
   linkFlags : PInvokeMap
) : MethodBuilder;

Parameters

name
The name of the PInvoke method.
dllName
[To be supplied.]
attributes
[To be supplied.]
callingConvention
[To be supplied.]
returnType
[To be supplied.]
parameterTypes
[To be supplied.]
linkFlags
[To be supplied.]

Return Value

The defined PInvoke method.

Exceptions

Exception Type | Condition
ArgumentException | if the method is not static or if the containing type is an interface or if the method is abstract of if the method was previously defined
ArgumentNullException | if name or dllName is a null reference (in Visual Basic Nothing)
InvalidOperationException | if the containing type has been previously created using CreateType

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace | TypeBuilder.DefinePInvokeMethod Overload List


TypeBuilder.DefineProperty

Adds a new property to the class, with the given name and property signature.

[Visual Basic]
Public Function DefineProperty( _
   ByVal name As String, _
   ByVal attributes As PropertyAttributes, _
   ByVal returnType As Type, _
   ByVal parameterTypes() As Type, _
   ByVal backingField As FieldBuilder _
) As PropertyBuilder
[C#]
public PropertyBuilder DefineProperty(
   string name,
   PropertyAttributes attributes,
   Type returnType,
   Type[] parameterTypes,
   FieldBuilder backingField
);
[C++]
public: PropertyBuilder* DefineProperty(
   String* name,
   PropertyAttributes attributes,
   Type* returnType,
   Type* parameterTypes[],
   FieldBuilder* backingField
);
[JScript]
public function DefineProperty(
   name : String,
   attributes : PropertyAttributes,
   returnType : Type,
   parameterTypes : Type[],
   backingField : FieldBuilder
) : PropertyBuilder;

Parameters

name
The name of the property.
attributes
The attributes of the property.
returnType
The return type of the property.
parameterTypes
The types of the parameters of the property.
backingField
[To be supplied.]

Return Value

The defined property.

Exceptions

Exception Type | Condition
ArgumentNullException | if name is a null reference (in Visual Basic Nothing)
InvalidOperationException | if the type was previously created using CreateType

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.DefineTypeInitializer

Defines the initializer for this type.

[Visual Basic]
Public Function DefineTypeInitializer() As ConstructorBuilder
[C#]
public ConstructorBuilder DefineTypeInitializer();
[C++]
public: ConstructorBuilder* DefineTypeInitializer();
[JScript]
public function DefineTypeInitializer() : ConstructorBuilder;

Return Value

Returns a type initializer.

Exceptions

Exception Type | Condition
InvalidOperationException | if the containing type has been previously created using CreateType

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.DefineUninitializedData

Defines uninitialized data field in the .sdata section of the PE file.

[Visual Basic]
Public Function DefineUninitializedData( _
   ByVal name As String, _
   ByVal size As Integer, _
   ByVal attributes As FieldAttributes _
) As FieldBuilder
[C#]
public FieldBuilder DefineUninitializedData(
   string name,
   int size,
   FieldAttributes attributes
);
[C++]
public: FieldBuilder* DefineUninitializedData(
   String* name,
   int size,
   FieldAttributes attributes
);
[JScript]
public function DefineUninitializedData(
   name : String,
   size : int,
   attributes : FieldAttributes
) : FieldBuilder;

Parameters

name
The name used to refer to the data.
size
The blob of data.
attributes
The attributes for the field.

Return Value

A field to reference the data.

Exceptions

Exception Type | Condition
ArgumentNullException | if name is a null reference (in Visual Basic Nothing)
InvalidOperationException | if CreateGlobalFunctions has been previously called

Requirements

NGWS Runtime Security:

ReflectionPermission SecurityAction.Demand, ReflectionEmit

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.GetAttributeFlagsImpl

Returns the implementation attribute flags.

[Visual Basic]
Overrides Protected Function GetAttributeFlagsImpl() As _
   TypeAttributes
[C#]
protected override TypeAttributes GetAttributeFlagsImpl();
[C++]
protected: override TypeAttributes GetAttributeFlagsImpl();
[JScript]
protected override function GetAttributeFlagsImpl() :
   TypeAttributes;

Return Value

Returns the implementation attribute flags.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.GetConstructorImpl

Not implemented.

[Visual Basic]
Overrides Protected Function GetConstructorImpl( _
   ByVal bindingAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal callConvention As CallingConventions, _
   ByVal types() As Type, _
   ByVal modifiers() As ParameterModifier _
) As ConstructorInfo
[C#]
protected override ConstructorInfo GetConstructorImpl(
   BindingFlags bindingAttr,
   Binder binder,
   CallingConventions callConvention,
   Type[] types,
   ParameterModifier[] modifiers
);
[C++]
protected: override ConstructorInfo* GetConstructorImpl(
   BindingFlags bindingAttr,
   Binder* binder,
   CallingConventions callConvention,
   Type* types[],
   ParameterModifier* modifiers[]
);
[JScript]
protected override function GetConstructorImpl(
   bindingAttr : BindingFlags,
   binder : Binder,
   callConvention : CallingConventions,
   types : Type[],
   modifiers : ParameterModifier[]
) : ConstructorInfo;

Parameters

bindingAttr
TBD
binder
TBD
callConvention
TBD
types
TBD
modifiers
TBD

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.GetConstructors

Returns an array of ConstructorInfo objects representing the public and non-public constructors defined for this class, as specified.

[Visual Basic]
Overrides Public Function GetConstructors( _
   ByVal bindingAttr As BindingFlags _
) As ConstructorInfo ()
[C#]
public override ConstructorInfo[] GetConstructors(
   BindingFlags bindingAttr
);
[C++]
public: override ConstructorInfo* GetConstructors(
   BindingFlags bindingAttr
) [];
[JScript]
public override function GetConstructors(
   bindingAttr : BindingFlags
) : ConstructorInfo[];

Parameters

bindingAttr
This must be a bit flag from BindingFlags: InvokeMethod, NonPublic, etc.

Return Value

Returns an array of ConstructorInfo objects representing the specified constructors defined for this class. If no constructors are defined, an empty array is returned.

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

Requirements

NGWS Runtime Security:

ReflectionPermission TypeInformation required for non-public members.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.GetCustomAttributes

Overloaded. Returns the custom attributes defined for this type.

Overload List

Returns the custom attributes identified by the given type.

[Visual Basic] Overloads Overrides Public Function GetCustomAttributes(Type) As Object ()
[C#] public override object[] GetCustomAttributes(Type);
[C++] public: override Object* GetCustomAttributes(Type*) [];
[JScript] public override function GetCustomAttributes(Type) : Object[];

Returns all the custom attributes defined for this type.

[Visual Basic] Overloads Overrides Public Function GetCustomAttributes() As Object ()
[C#] public override object[] GetCustomAttributes();
[C++] public: override Object* GetCustomAttributes() [];
[JScript] public override function GetCustomAttributes() : Object[];

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.GetCustomAttributes (Type)

Returns the custom attributes identified by the given type.

[Visual Basic]
Overloads Overrides Public Function GetCustomAttributes( _
   ByVal attributeType As Type _
) As Object ()
[C#]
public override object[] GetCustomAttributes(
   Type attributeType
);
[C++]
public: override Object* GetCustomAttributes(
   Type* attributeType
) [];
[JScript]
public override function GetCustomAttributes(
   attributeType : Type
) : Object[];

Parameters

attributeType
The custom attribute type.

Return Value

Returns an array of objects representing the attributes of this type that are of Type attributeType.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace | TypeBuilder.GetCustomAttributes Overload List


TypeBuilder.GetCustomAttributes ()

Returns all the custom attributes defined for this type.

[Visual Basic]
Overloads Overrides Public Function GetCustomAttributes() As Object ()
[C#]
public override object[] GetCustomAttributes();
[C++]
public: override Object* GetCustomAttributes() [];
[JScript]
public override function GetCustomAttributes() : Object[];

Return Value

Returns an array of objects representing all the custom attributes of this type.

Exceptions

Exception Type | Condition
TypeLoadException | if the custom attribute type can not be loaded.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace | TypeBuilder.GetCustomAttributes Overload List


TypeBuilder.GetElementType

Not implemented.

[Visual Basic]
Overrides Public Function GetElementType() As Type
[C#]
public override Type GetElementType();
[C++]
public: override Type* GetElementType();
[JScript]
public override function GetElementType() : Type;

Exceptions

Exception Type | Condition
NotSupportedException | This method is not supported.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.GetEvent

Returns the event with the specified name.

[Visual Basic]
Overrides Public Function GetEvent( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags _
) As EventInfo
[C#]
public override EventInfo GetEvent(
   string name,
   BindingFlags bindingAttr
);
[C++]
public: override EventInfo* GetEvent(
   String* name,
   BindingFlags bindingAttr
);
[JScript]
public override function GetEvent(
   name : String,
   bindingAttr : BindingFlags
) : EventInfo;

Parameters

name
The name of the event to get.
bindingAttr
This invocation attribute. This must be a bit flag from BindingFlags: InvokeMethod, NonPublic, etc.

Return Value

Returns an EventInfo object representing the event declared or inherited by this type with the specified name. If there are no matches, then an empty array is returned.

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.GetEvents

[To be supplied.]

Overload List

Returns the public and non-public events that are declared by this type.

[Visual Basic] Overloads Overrides Public Function GetEvents(BindingFlags) As EventInfo ()
[C#] public override EventInfo[] GetEvents(BindingFlags);
[C++] public: override EventInfo* GetEvents(BindingFlags) [];
[JScript] public override function GetEvents(BindingFlags) : EventInfo[];

Returns the events for the public events declared or inherited by this type.

[Visual Basic] Overloads Overrides Public Function GetEvents() As EventInfo ()
[C#] public override EventInfo[] GetEvents();
[C++] public: override EventInfo* GetEvents() [];
[JScript] public override function GetEvents() : EventInfo[];

Requirements

NGWS Runtime Security:

ReflectionPermission TypeInformation required for non-public members

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.GetEvents (BindingFlags)

Returns the public and non-public events that are declared by this type.

[Visual Basic]
Overloads Overrides Public Function GetEvents( _
   ByVal bindingAttr As BindingFlags _
) As EventInfo ()
[C#]
public override EventInfo[] GetEvents(
   BindingFlags bindingAttr
);
[C++]
public: override EventInfo* GetEvents(
   BindingFlags bindingAttr
) [];
[JScript]
public override function GetEvents(
   bindingAttr : BindingFlags
) : EventInfo[];

Parameters

bindingAttr
This must be a bit flag from BindingFlags: InvokeMethod, NonPublic, etc.

Return Value

Returns an array of EventInfo objects representing the public and non-public events declared or inherited by this type. An empty array is returned if there are no events, as specified.

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

Requirements

NGWS Runtime Security:

ReflectionPermission TypeInformation required for non-public members

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace | TypeBuilder.GetEvents Overload List


TypeBuilder.GetEvents ()

Returns the events for the public events declared or inherited by this type.

[Visual Basic]
Overloads Overrides Public Function GetEvents() As EventInfo ()
[C#]
public override EventInfo[] GetEvents();
[C++]
public: override EventInfo* GetEvents() [];
[JScript]
public override function GetEvents() : EventInfo[];

Return Value

Returns an array of EventInfo objects representing the public events declared or inherited by this type. An empty array is returned if there are no public events.

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace | TypeBuilder.GetEvents Overload List


TypeBuilder.GetField

Returns the field specified by the given name.

[Visual Basic]
Overrides Public Function GetField( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags _
) As FieldInfo
[C#]
public override FieldInfo GetField(
   string name,
   BindingFlags bindingAttr
);
[C++]
public: override FieldInfo* GetField(
   String* name,
   BindingFlags bindingAttr
);
[JScript]
public override function GetField(
   name : String,
   bindingAttr : BindingFlags
) : FieldInfo;

Parameters

name
The name of the field to get.
bindingAttr
This must be a bit flag from BindingFlags: InvokeMethod, NonPublic, etc.

Return Value

Returns the FieldInfo object representing the field declared or inherited by this type with the specified name and public or non-public modifier. If there are no matches then null is returned.

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

Requirements

NGWS Runtime Security:

ReflectionPermission TypeInformation required for non-public members

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.GetFields

Returns the public and non-public fields that are declared by this type.

[Visual Basic]
Overrides Public Function GetFields( _
   ByVal bindingAttr As BindingFlags _
) As FieldInfo ()
[C#]
public override FieldInfo[] GetFields(
   BindingFlags bindingAttr
);
[C++]
public: override FieldInfo* GetFields(
   BindingFlags bindingAttr
) [];
[JScript]
public override function GetFields(
   bindingAttr : BindingFlags
) : FieldInfo[];

Parameters

bindingAttr
This must be a bit flag from BindingFlags: InvokeMethod, NonPublic, etc.

Return Value

Returns an array of FieldInfo objects representing the public and non-public fields declared or inherited by this type. An empty array is returned if there are no fields, as specified.

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

Requirements

NGWS Runtime Security:

ReflectionPermission TypeInformation required for non-public members

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.GetInterface

Returns the interface implemented (directly or indirectly) by this class with the fully-qualified name matching the given interface name.

[Visual Basic]
Overrides Public Function GetInterface( _
   ByVal name As String, _
   ByVal ignoreCase As Boolean _
) As Type
[C#]
public override Type GetInterface(
   string name,
   bool ignoreCase
);
[C++]
public: override Type* GetInterface(
   String* name,
   bool ignoreCase
);
[JScript]
public override function GetInterface(
   name : String,
   ignoreCase : Boolean
) : Type;

Parameters

name
The name of the interface.
ignoreCase
If true, the search is case-insensitive. If false, the search is case-sensitive.

Return Value

Returns a Type object representing the implemented interface. Returns null if no interface matching name is found.

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.GetInterfaceMap

Returns an interface mapping for the requested interface.

[Visual Basic]
Overrides Public Function GetInterfaceMap( _
   ByVal interfaceType As Type _
) As InterfaceMapping
[C#]
public override InterfaceMapping GetInterfaceMap(
   Type interfaceType
);
[C++]
public: override InterfaceMapping GetInterfaceMap(
   Type* interfaceType
);
[JScript]
public override function GetInterfaceMap(
   interfaceType : Type
) : InterfaceMapping;

Parameters

interfaceType
The Type of the interface for which the mapping is to be retrieved.

Return Value

Returns the requested interface mapping.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.GetInterfaces

Returns an array of all the interfaces implemented on this a class and its super classes.

[Visual Basic]
Overrides Public Function GetInterfaces() As Type ()
[C#]
public override Type[] GetInterfaces();
[C++]
public: override Type* GetInterfaces() [];
[JScript]
public override function GetInterfaces() : Type[];

Return Value

Returns an array of Type objects representing the implemented interfaces. If none are defined, an empty array is returned.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.GetMember

Returns all the public and non-public members declared or inherited by this type, as specified.

[Visual Basic]
Overrides Public Function GetMember( _
   ByVal name As String, _
   ByVal type As MemberTypes, _
   ByVal bindingAttr As BindingFlags _
) As MemberInfo ()
[C#]
public override MemberInfo[] GetMember(
   string name,
   MemberTypes type,
   BindingFlags bindingAttr
);
[C++]
public: override MemberInfo* GetMember(
   String* name,
   MemberTypes type,
   BindingFlags bindingAttr
) [];
[JScript]
public override function GetMember(
   name : String,
   type : MemberTypes,
   bindingAttr : BindingFlags
) : MemberInfo[];

Parameters

name
[To be supplied.]
type
[To be supplied.]
bindingAttr
This must be a bit flag from BindingFlags: InvokeMethod, NonPublic, etc.

Return Value

Returns an array of MemberInfo objects representing the public and non-public members defined on this type if nonPublic is used; otherwise only the public members are returned.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.GetMembers

Returns the members for the public and non-public members declared or inherited by this type.

[Visual Basic]
Overrides Public Function GetMembers( _
   ByVal bindingAttr As BindingFlags _
) As MemberInfo ()
[C#]
public override MemberInfo[] GetMembers(
   BindingFlags bindingAttr
);
[C++]
public: override MemberInfo* GetMembers(
   BindingFlags bindingAttr
) [];
[JScript]
public override function GetMembers(
   bindingAttr : BindingFlags
) : MemberInfo[];

Parameters

bindingAttr
This must be a bit flag from BindingFlags: InvokeMethod, NonPublic, etc.

Return Value

Returns an array of MemberInfo objects representing the public and non-public members declared or inherited by this type. An empty array is returned if there are no matching members.

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

Requirements

NGWS Runtime Security:

ReflectionPermission TypeInformation required for non-public members

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.GetMethodImpl

Not implemented.

[Visual Basic]
Overrides Protected Function GetMethodImpl( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal callConvention As CallingConventions, _
   ByVal types() As Type, _
   ByVal modifiers() As ParameterModifier _
) As MethodInfo
[C#]
protected override MethodInfo GetMethodImpl(
   string name,
   BindingFlags bindingAttr,
   Binder binder,
   CallingConventions callConvention,
   Type[] types,
   ParameterModifier[] modifiers
);
[C++]
protected: override MethodInfo* GetMethodImpl(
   String* name,
   BindingFlags bindingAttr,
   Binder* binder,
   CallingConventions callConvention,
   Type* types[],
   ParameterModifier* modifiers[]
);
[JScript]
protected override function GetMethodImpl(
   name : String,
   bindingAttr : BindingFlags,
   binder : Binder,
   callConvention : CallingConventions,
   types : Type[],
   modifiers : ParameterModifier[]
) : MethodInfo;

Parameters

name
TBD
bindingAttr
TBD
binder
TBD
callConvention
[To be supplied.]
types
TBD
modifiers
TBD

Return Value

TBD

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.GetMethods

Returns all the public and non-public methods declared or inherited by this type, as specified.

[Visual Basic]
Overrides Public Function GetMethods( _
   ByVal bindingAttr As BindingFlags _
) As MethodInfo ()
[C#]
public override MethodInfo[] GetMethods(
   BindingFlags bindingAttr
);
[C++]
public: override MethodInfo* GetMethods(
   BindingFlags bindingAttr
) [];
[JScript]
public override function GetMethods(
   bindingAttr : BindingFlags
) : MethodInfo[];

Parameters

bindingAttr
This must be a bit flag from BindingFlags: InvokeMethod, NonPublic, etc.

Return Value

Returns an array of MethodInfo objects representing the public and non-public methods defined on this type if nonPublic is used; otherwise only the public methods are returned.

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

Requirements

NGWS Runtime Security:

ReflectionPermission TypeInformation required for non-public members

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.GetNestedType

Returns the public and non-public nested types that are declared by this type.

[Visual Basic]
Overrides Public Function GetNestedType( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags _
) As Type
[C#]
public override Type GetNestedType(
   string name,
   BindingFlags bindingAttr
);
[C++]
public: override Type* GetNestedType(
   String* name,
   BindingFlags bindingAttr
);
[JScript]
public override function GetNestedType(
   name : String,
   bindingAttr : BindingFlags
) : Type;

Parameters

name
[To be supplied.]
bindingAttr
This must be a bit flag from BindingFlags: InvokeMethod, NonPublic, etc.

Return Value

Returns an array of Type objects representing the public and non-public types declared by this type. An empty array is returned if there are no types, as specified.

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

Requirements

NGWS Runtime Security:

ReflectionPermission TypeInformation required for non-public members

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.GetNestedTypes

Returns the public and non-public nested types that are declared or inherited by this type.

[Visual Basic]
Overrides Public Function GetNestedTypes( _
   ByVal bindingAttr As BindingFlags _
) As Type ()
[C#]
public override Type[] GetNestedTypes(
   BindingFlags bindingAttr
);
[C++]
public: override Type* GetNestedTypes(
   BindingFlags bindingAttr
) [];
[JScript]
public override function GetNestedTypes(
   bindingAttr : BindingFlags
) : Type[];

Parameters

bindingAttr
This must be a bit flag from BindingFlags: InvokeMethod, NonPublic, etc.

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

Requirements

NGWS Runtime Security:

ReflectionPermission TypeInformation required for non-public members

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.GetProperties

Returns all the public and non-public properties declared or inherited by this type, as specified.

[Visual Basic]
Overrides Public Function GetProperties( _
   ByVal bindingAttr As BindingFlags _
) As PropertyInfo ()
[C#]
public override PropertyInfo[] GetProperties(
   BindingFlags bindingAttr
);
[C++]
public: override PropertyInfo* GetProperties(
   BindingFlags bindingAttr
) [];
[JScript]
public override function GetProperties(
   bindingAttr : BindingFlags
) : PropertyInfo[];

Parameters

bindingAttr
This invocation attribute. This must be a bit flag from BindingFlags: InvokeMethod, NonPublic, etc.

Return Value

Returns an array of PropertyInfo objects representing the public and non-public properties defined on this type if nonPublic is used; otherwise only the public properties are returned.

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.GetPropertyImpl

Not implemented.

[Visual Basic]
Overrides Protected Function GetPropertyImpl( _
   ByVal name As String, _
   ByVal bindingAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal types() As Type, _
   ByVal modifiers() As ParameterModifier _
) As PropertyInfo
[C#]
protected override PropertyInfo GetPropertyImpl(
   string name,
   BindingFlags bindingAttr,
   Binder binder,
   Type[] types,
   ParameterModifier[] modifiers
);
[C++]
protected: override PropertyInfo* GetPropertyImpl(
   String* name,
   BindingFlags bindingAttr,
   Binder* binder,
   Type* types[],
   ParameterModifier* modifiers[]
);
[JScript]
protected override function GetPropertyImpl(
   name : String,
   bindingAttr : BindingFlags,
   binder : Binder,
   types : Type[],
   modifiers : ParameterModifier[]
) : PropertyInfo;

Parameters

name
TBD
bindingAttr
TBD
binder
TBD
types
TBD
modifiers
TBD

Return Value

TBD

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

Remarks

This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.HasElementTypeImpl

Not implemented.

[Visual Basic]
Overrides Protected Function HasElementTypeImpl() As Boolean
[C#]
protected override bool HasElementTypeImpl();
[C++]
protected: override bool HasElementTypeImpl();
[JScript]
protected override function HasElementTypeImpl() : Boolean;

Exceptions

Exception Type | Condition
NotSupportedException | This method is not supported.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.InvokeMember

Invokes the specified member. The method that is to be invoked must be accessible and provide the most specific match with the specified argument list, under the contraints of the specified binder and invocation attributes.

[Visual Basic]
Overrides Public Function InvokeMember( _
   ByVal name As String, _
   ByVal invokeAttr As BindingFlags, _
   ByVal binder As Binder, _
   ByVal target As Object, _
   ByVal args() As Object, _
   ByVal modifiers() As ParameterModifier, _
   ByVal culture As CultureInfo, _
   ByVal namedParameters() As String _
) As Object
[C#]
public override object InvokeMember(
   string name,
   BindingFlags invokeAttr,
   Binder binder,
   object target,
   object[] args,
   ParameterModifier[] modifiers,
   CultureInfo culture,
   string[] namedParameters
);
[C++]
public: override Object* InvokeMember(
   String* name,
   BindingFlags invokeAttr,
   Binder* binder,
   Object* target,
   Object* args[],
   ParameterModifier* modifiers[],
   CultureInfo* culture,
   String* namedParameters[]
);
[JScript]
public override function InvokeMember(
   name : String,
   invokeAttr : BindingFlags,
   binder : Binder,
   target : Object,
   args : Object[],
   modifiers : ParameterModifier[],
   culture : CultureInfo,
   namedParameters : String[]
) : Object;

Parameters

name
The name of the member to invoke. This may be a constructor, method, property, or field. A suitable invocation attribute must be specified. Note that it is possible to invoke the default member of a class by passing an empty string as the name of the member.
invokeAttr
The invocation attribute. This must be a bit flag from BindingFlags.
binder
An object that enables the binding, coercion of argument types, invocation of members, and retrieval of MemberInfo objects via reflection. If binder is a null reference (in Visual Basic Nothing), the default binder is used. See Binder.
target
The object on which to invoke the specified member. If the member is static, this parameter is ignored.
args
An argument list. This is an array of Objects that contains the number, order, and type of the parameters of the member to be invoked. If there are no parameters this should be null.
modifiers
An array of the same length as args with elements that represent the attributes associated with the arguments of the member to be invoked. A parameter has attributes associated with it in the metadata. They are used by various interoperability services. See the metadata specs for details such as this.
culture
An instance of CultureInfo used to govern the coercion of types. If this is null, the CultureInfo for the current thread is used. (Note that this is necessary to, for example, convert a String that represents 1000 to a Double value, since 1000 is represented differently by different cultures.)
namedParameters
This array of parameter names match up starting at element zero with the args array. That args[0] is matched with the parameter named namedParamaters[0] etc. There must be no "wholes" in the array. If args.Length > namedParameters.Length, the remain parameters are filled in order.

Return Value

Returns the return value of the invoked member.

Exceptions

Exception Type | Condition
NotSupportedException | This method is not currently supported.

Remarks

A method will be invoked if the number of parameters in the method declaration equals the number of arguments in the specified argument list, and the type of each argument can be converted by the binder to the type of the parameter.

The binder will find all of the matching methods. These methods are found based upon the type of binding requested (BindingFlags.InvokeMethod, BindingFlags.GetProperties, etc.). The set of methods is filtered by the name, number of arguments, and a set of search modifiers defined in the binder. After the method is selected, it will be invoked. Accessability is checked at that point. The search may control which set of methods are searched based upon the accessibility attribute associated with the method. The IBinder.BindToMethod method is responsible for selecting the method to be invoked. The default binder selects the most specific match.

Note: Access restrictions are ignored for fully trusted code. That is, private constructors, methods, fields, and properties can be accessed and invoked via Reflection whenever the code is fully trusted.This method is not currently supported. As a workaround, retrieve the type using Type.GetType or Assembly.GetType and use reflection on the retrieved type.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.IsArrayImpl

Returns false always.

[Visual Basic]
Overrides Protected Function IsArrayImpl() As Boolean
[C#]
protected override bool IsArrayImpl();
[C++]
protected: override bool IsArrayImpl();
[JScript]
protected override function IsArrayImpl() : Boolean;

Return Value

Returns false.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.IsByRefImpl

Returns false always.

[Visual Basic]
Overrides Protected Function IsByRefImpl() As Boolean
[C#]
protected override bool IsByRefImpl();
[C++]
protected: override bool IsByRefImpl();
[JScript]
protected override function IsByRefImpl() : Boolean;

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.IsCOMObjectImpl

Checks if this type imports a COM type.

[Visual Basic]
Overrides Protected Function IsCOMObjectImpl() As Boolean
[C#]
protected override bool IsCOMObjectImpl();
[C++]
protected: override bool IsCOMObjectImpl();
[JScript]
protected override function IsCOMObjectImpl() : Boolean;

Return Value

Returns true if this type imports a COM type, false otherwise.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.IsDefined

Checks if the specified custom attribute type is defined.

[Visual Basic]
Overrides Public Function IsDefined( _
   ByVal attributeType As Type _
) As Boolean
[C#]
public override bool IsDefined(
   Type attributeType
);
[C++]
public: override bool IsDefined(
   Type* attributeType
);
[JScript]
public override function IsDefined(
   attributeType : Type
) : Boolean;

Parameters

attributeType
A custom attribute type.

Return Value

true if the specified custom attribute type is defined. Otherwise, false.

Exceptions

Exception Type | Condition
NotSupportedException | This method is not implemented.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.IsPointerImpl

Returns false always.

[Visual Basic]
Overrides Protected Function IsPointerImpl() As Boolean
[C#]
protected override bool IsPointerImpl();
[C++]
protected: override bool IsPointerImpl();
[JScript]
protected override function IsPointerImpl() : Boolean;

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.IsPrimitiveImpl

Returns false always.

[Visual Basic]
Overrides Protected Function IsPrimitiveImpl() As Boolean
[C#]
protected override bool IsPrimitiveImpl();
[C++]
protected: override bool IsPrimitiveImpl();
[JScript]
protected override function IsPrimitiveImpl() : Boolean;

Return Value

Returns false.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.IsValueTypeImpl

Returns false always.

[Visual Basic]
Overrides Protected Function IsValueTypeImpl() As Boolean
[C#]
protected override bool IsValueTypeImpl();
[C++]
protected: override bool IsValueTypeImpl();
[JScript]
protected override function IsValueTypeImpl() : Boolean;

Return Value

Returns false.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.SetCustomAttribute

Sets a custom attribute.

Overload List

Set a custom attribute using a specified custom attribute blob.

[Visual Basic] Overloads Public Sub SetCustomAttribute(ConstructorInfo, Byte())
[C#] public void SetCustomAttribute(ConstructorInfo, byte[]);
[C++] public: void SetCustomAttribute(ConstructorInfo*, unsigned char[]);
[JScript] public function SetCustomAttribute(ConstructorInfo, Byte[]);

Set a custom attribute using a custom attribute builder.

[Visual Basic] Overloads Public Sub SetCustomAttribute(CustomAttributeBuilder)
[C#] public void SetCustomAttribute(CustomAttributeBuilder);
[C++] public: void SetCustomAttribute(CustomAttributeBuilder*);
[JScript] public function SetCustomAttribute(CustomAttributeBuilder);

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.SetCustomAttribute (ConstructorInfo, Byte[])

Set a custom attribute using a specified custom attribute blob.

[Visual Basic]
Overloads Public Sub SetCustomAttribute( _
   ByVal con As ConstructorInfo, _
   ByVal binaryAttribute() As Byte _
)
[C#]
public void SetCustomAttribute(
   ConstructorInfo con,
   byte[] binaryAttribute
);
[C++]
public: void SetCustomAttribute(
   ConstructorInfo* con,
   unsigned char* binaryAttribute[]
);
[JScript]
public function SetCustomAttribute(
   con : ConstructorInfo,
   binaryAttribute : Byte[]
);

Parameters

con
The constructor for the custom attribute.
binaryAttribute
A byte blob representing the attributes.

Exceptions

Exception Type | Condition
ArgumentNullException | if con or binaryAttribute is a null reference (in Visual Basic Nothing)

Remarks

See the for details on how to format binaryAttribute.

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace | TypeBuilder.SetCustomAttribute Overload List


TypeBuilder.SetCustomAttribute (CustomAttributeBuilder)

Set a custom attribute using a custom attribute builder.

[Visual Basic]
Overloads Public Sub SetCustomAttribute( _
   ByVal customBuilder As CustomAttributeBuilder _
)
[C#]
public void SetCustomAttribute(
   CustomAttributeBuilder customBuilder
);
[C++]
public: void SetCustomAttribute(
   CustomAttributeBuilder* customBuilder
);
[JScript]
public function SetCustomAttribute(
   customBuilder : CustomAttributeBuilder
);

Parameters

customBuilder
An instance of a helper class to define the custom attribute.

Exceptions

Exception Type | Condition
ArgumentNullException | if con is a null reference (in Visual Basic Nothing)

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace | TypeBuilder.SetCustomAttribute Overload List


TypeBuilder.SetParent

Sets the parent of this Type.

[Visual Basic]
Public Sub SetParent( _
   ByVal parent As Type _
)
[C#]
public void SetParent(
   Type parent
);
[C++]
public: void SetParent(
   Type* parent
);
[JScript]
public function SetParent(
   parent : Type
);

Parameters

parent
The parent Type.

Exceptions

Exception Type | Condition
ArgumentNullException | if parent is a null reference (in Visual Basic Nothing)
InvalidOperationException | if the type was previously created using CreateType

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeBuilder.ToString

Returns the name of the type excluding the namespace.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

Read-only. The name of the type excluding the namespace

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypeBuilder Fields

The fields of the TypeBuilder class are listed below. For a complete list of TypeBuilder class members, see the TypeBuilder Members topic.

Public:

UnspecifiedTypeSize Represents that total size for the type is not specified.

See Also

TypeBuilder Class | System.Reflection.Emit Namespace


TypeBuilder.UnspecifiedTypeSize

Represents that total size for the type is not specified.

[Visual Basic]
Public Const UnspecifiedTypeSize As Integer
[C#]
public const int UnspecifiedTypeSize;
[C++]
public: const int UnspecifiedTypeSize;
[JScript]
public var UnspecifiedTypeSize : int;

See Also

TypeBuilder Class | TypeBuilder Members | System.Reflection.Emit Namespace


TypeToken Structure

The TypeToken class is an opaque representation of the Token returned by the MetaData to represent a type.

Object
ValueType
TypeToken

[Visual Basic]
Public Structure TypeToken
[C#]
public struct TypeToken
[C++]
public __value struct TypeToken

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

The 'type' of an object is also known as the 'class' of an object.

Requirements

Namespace: System.Reflection.Emit

Assembly: mscorlib.dll

See Also

TypeToken Members | System.Reflection.Emit Namespace


TypeToken Members

Public:

Properties

Token Retrieves the metadata token for this class.

Methods

Equals | Checks if the given object is an instance of TypeToken and is equal to this instance.
GetHashCode | Generates the hash code for this type.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Fields

Empty The default TypeToken with Token value 0.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeToken Structure | System.Reflection.Emit Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypeToken Properties

The properties of the TypeToken structure are listed below. For a complete list of TypeToken structure members, see the TypeToken Members topic.

Public:

Token Retrieves the metadata token for this class.

See Also

TypeToken Structure | System.Reflection.Emit Namespace


TypeToken.Token

Retrieves the metadata token for this class.

[Visual Basic]
Public ReadOnly Property Token As Integer
[C#]
public int Token {get;}
[C++]
public: __property int get_Token();
[JScript]
public function get Token() : int;

Property Value

Read-only. Retrieves the metadata token of this type.

See Also

TypeToken Structure | TypeToken Members | System.Reflection.Emit Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypeToken Methods

The methods of the TypeToken structure are listed below. For a complete list of TypeToken structure members, see the TypeToken Members topic.

Public:

Equals | Checks if the given object is an instance of TypeToken and is equal to this instance.
GetHashCode | Generates the hash code for this type.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeToken Structure | System.Reflection.Emit Namespace


TypeToken.Equals

Checks if the given object is an instance of TypeToken and is equal to this instance.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
The object to compare with this TypeToken.

Return Value

Returns true if obj is an instance of TypeToken and is equal to this object. Otherwise, returns false.

See Also

TypeToken Structure | TypeToken Members | System.Reflection.Emit Namespace


TypeToken.GetHashCode

Generates the hash code for this type.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

Returns the hash code for this type.

See Also

TypeToken Structure | TypeToken Members | System.Reflection.Emit Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypeToken Fields

The fields of the TypeToken structure are listed below. For a complete list of TypeToken structure members, see the TypeToken Members topic.

Public:

Empty The default TypeToken with Token value 0.

See Also

TypeToken Structure | System.Reflection.Emit Namespace


TypeToken.Empty

The default TypeToken with Token value 0.

[Visual Basic]
Public Shared ReadOnly Empty As TypeToken
[C#]
public static readonly TypeToken Empty;
[C++]
public: static readonly TypeToken Empty;
[JScript]
public static var Empty : TypeToken;

See Also

TypeToken Structure | TypeToken Members | System.Reflection.Emit Namespace


System.Resources

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Resources Namespace

Classes

Class | Description
MissingManifestResourceException | The MissingManifestResourceException is thrown if the main assembly does not contain the resources for the neutral culture.
ResourceManager | Represents a set of resources with a given root name.
ResourceReader | Provides a default implementation of the IResourceReader interface and implements a resource reader. Resource readers are used to read resource name and resource value pairs from ".resources" files. These methods are used to advance to the next resource and read the name and value of each resource in the ".resources" file. This class can be used to enumerate the resources only one time.
ResourceSet | Stores all the resources defined in one particular CultureInfo.
ResourceWriter | Generates a binary ".resources" file in the system-default format from name and value pairs. Create one with a unique file name, call AddResource at least once, then call Write to write the ".resources" file to disk.

Interfaces

Interface | Description
IResourceReader | This interface is implemented by resource readers to read data from resource files. Resource readers are used to read a stream of ".resources" files in the system default binary file format. See the TBD for details on the default resource file format.
IResourceWriter | This interface is implemented by resource writers, which write resources to an output file or output stream. Resource writers are used to write resources in the system default file format. See the TBD for details on the default resource file format.


IResourceReader Interface

This interface is implemented by resource readers to read data from resource files. Resource readers are used to read a stream of ".resources" files in the system default binary file format. See the TBD for details on the default resource file format.

IResourceReader

[Visual Basic]
Public Interface IResourceReader
   Implements IEnumerable
[C#]
public interface IResourceReader : IEnumerable
[C++]
public __gc __interface IResourceReader : public IEnumerable

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IResourceReader

Class | Description
ResourceReader | Provides a default implementation of the IResourceReader interface and implements a resource reader. Resource readers are used to read resource name and resource value pairs from ".resources" files. These methods are used to advance to the next resource and read the name and value of each resource in the ".resources" file. This class can be used to enumerate the resources only one time.

Remarks

[To be supplied.]

Requirements

Namespace: System.Resources

Assembly: mscorlib.dll

See Also

IResourceReader Members | System.Resources Namespace


IResourceReader Members

Methods

Close | Closes the resource reader after releasing any resources associated with it. For example, this might close a network connection, a file, or do nothing at all.
GetEnumerator | Returns an enumerator for the resources for this reader.

See Also

IResourceReader Interface | System.Resources Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IResourceReader Methods

The methods of the IResourceReader interface are listed below. For a complete list of IResourceReader interface members, see the IResourceReader Members topic.

Close | Closes the resource reader after releasing any resources associated with it. For example, this might close a network connection, a file, or do nothing at all.
GetEnumerator | Returns an enumerator for the resources for this reader.

See Also

IResourceReader Interface | System.Resources Namespace


IResourceReader.Close

Closes the resource reader after releasing any resources associated with it. For example, this might close a network connection, a file, or do nothing at all.

[Visual Basic]
Sub Close()
[C#]
void Close();
[C++]
void Close() = 0;
[JScript]
function Close();

See Also

IResourceReader Interface | IResourceReader Members | System.Resources Namespace


IResourceReader.GetEnumerator

Returns an enumerator for the resources for this reader.

[Visual Basic]
Function GetEnumerator() As IDictionaryEnumerator
[C#]
IDictionaryEnumerator GetEnumerator();
[C++]
IDictionaryEnumerator* GetEnumerator() = 0;
[JScript]
function GetEnumerator() : IDictionaryEnumerator;

Return Value

Returns an enumerator for the resources for this reader.

See Also

IResourceReader Interface | IResourceReader Members | System.Resources Namespace


IResourceWriter Interface

This interface is implemented by resource writers, which write resources to an output file or output stream. Resource writers are used to write resources in the system default file format. See the TBD for details on the default resource file format.

IResourceWriter

[Visual Basic]
Public Interface IResourceWriter
[C#]
public interface IResourceWriter
[C++]
public __gc __interface IResourceWriter

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IResourceWriter

Class | Description
ResourceWriter | Generates a binary ".resources" file in the system-default format from name and value pairs. Create one with a unique file name, call AddResource at least once, then call Write to write the ".resources" file to disk.

Remarks

[To be supplied.]

Requirements

Namespace: System.Resources

Assembly: mscorlib.dll

See Also

IResourceWriter Members | System.Resources Namespace


IResourceWriter Members

Methods

AddResource | Overloaded. Overloaded. Adds a resource to the list of resources to be written to an output file or output stream. The resource is not written until Write is called.
Close | Closes the underlying file or stream.
Write | Writes all resources that were added to the output file or output stream. Write does not close the output file or output stream.

See Also

IResourceWriter Interface | System.Resources Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IResourceWriter Methods

The methods of the IResourceWriter interface are listed below. For a complete list of IResourceWriter interface members, see the IResourceWriter Members topic.

AddResource | Overloaded. Overloaded. Adds a resource to the list of resources to be written to an output file or output stream. The resource is not written until Write is called.
Close | Closes the underlying file or stream.
Write | Writes all resources that were added to the output file or output stream. Write does not close the output file or output stream.

See Also

IResourceWriter Interface | System.Resources Namespace


IResourceWriter.AddResource

Overloaded. Adds a resource to the list of resources to be written to an output file or output stream. The resource is not written until Write is called.

Overload List

Adds a named resource of type Object to the list of resources to be written. The resource is not written until Write is called.

[Visual Basic] Overloads Sub AddResource(String, Object)
[C#] void AddResource(String, Object);
[C++] void AddResource(String*, Object) = 0;
[JScript] function AddResource(String, Object);

Adds a resource with the specified name and value to the list of resources that will be written.

[Visual Basic] Overloads Sub AddResource(String, String)
[C#] void AddResource(String, String);
[C++] void AddResource(String*, String*) = 0;
[JScript] function AddResource(String, String);

Adds a byte array as a named resource to the list of resources to be written. The resources are not written until Write is called.

[Visual Basic] Overloads Sub AddResource(String, Byte())
[C#] void AddResource(String, byte[]);
[C++] void AddResource(String*, unsigned char[]) = 0;
[JScript] function AddResource(String, Byte[]);

See Also

IResourceWriter Interface | IResourceWriter Members | System.Resources Namespace


IResourceWriter.AddResource (String, Object)

Adds a named resource of type Object to the list of resources to be written. The resource is not written until Write is called.

[Visual Basic]
Overloads Sub AddResource( _
   ByVal name As String, _
   ByVal value As Object _
)
[C#]
void AddResource(
   string name,
   object value
);
[C++]
void AddResource(
   String* name,
   Object* value
) = 0;
[JScript]
function AddResource(
   name : String,
   value : Object
);

Parameters

name
The name of the resource.
value
The value of the resource.

Exceptions

Exception Type | Condition
ArgumentNullException | if either of the parameters is a null reference (in Visual Basic Nothing)

See Also

IResourceWriter Interface | IResourceWriter Members | System.Resources Namespace | IResourceWriter.AddResource Overload List


IResourceWriter.AddResource (String, String)

Adds a resource with the specified name and value to the list of resources that will be written.

[Visual Basic]
Overloads Sub AddResource( _
   ByVal name As String, _
   ByVal value As String _
)
[C#]
void AddResource(
   string name,
   string value
);
[C++]
void AddResource(
   String* name,
   String* value
) = 0;
[JScript]
function AddResource(
   name : String,
   value : String
);

Parameters

name
The name of a resource be added.
value
The value of the resource.

Exceptions

Exception Type | Condition
ArgumentException | if either parameter is a null reference (in Visual Basic Nothing)

See Also

IResourceWriter Interface | IResourceWriter Members | System.Resources Namespace | IResourceWriter.AddResource Overload List


IResourceWriter.AddResource (String, Byte[])

Adds a byte array as a named resource to the list of resources to be written. The resources are not written until Write is called.

[Visual Basic]
Overloads Sub AddResource( _
   ByVal name As String, _
   ByVal value() As Byte _
)
[C#]
void AddResource(
   string name,
   byte[] value
);
[C++]
void AddResource(
   String* name,
   unsigned char* value[]
) = 0;
[JScript]
function AddResource(
   name : String,
   value : Byte[]
);

Parameters

name
Name of a resource
value
Value of a resource as an unsigned byte array

Exceptions

Exception Type | Condition
ArgumentNullException | if either parameter is a null reference (in Visual Basic Nothing)

See Also

IResourceWriter Interface | IResourceWriter Members | System.Resources Namespace | IResourceWriter.AddResource Overload List


IResourceWriter.Close

Closes the underlying file or stream.

[Visual Basic]
Sub Close()
[C#]
void Close();
[C++]
void Close() = 0;
[JScript]
function Close();

See Also

IResourceWriter Interface | IResourceWriter Members | System.Resources Namespace


IResourceWriter.Write

Writes all resources that were added to the output file or output stream. Write does not close the output file or output stream.

[Visual Basic]
Sub Write()
[C#]
void Write();
[C++]
void Write() = 0;
[JScript]
function Write();

See Also

IResourceWriter Interface | IResourceWriter Members | System.Resources Namespace


MissingManifestResourceException Class

The MissingManifestResourceException is thrown if the main assembly does not contain the resources for the neutral culture.

Object
Exception
MissingManifestResourceException

[Visual Basic]
Public Class MissingManifestResourceException
   Inherits Exception
[C#]
public class MissingManifestResourceException : Exception
[C++]
public __gc class MissingManifestResourceException : public
   Exception
[JScript]
public class MissingManifestResourceException extends Exception

Remarks

[To be supplied.]

Requirements

Namespace: System.Resources

Assembly: mscorlib.dll

See Also

MissingManifestResourceException Members | System.Resources Namespace


MissingManifestResourceException Members

Public:

Constructor

MissingManifestResourceException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

MissingManifestResourceException Class | System.Resources Namespace


MissingManifestResourceException Constructor

[To be supplied.]

Overload List

Constructs a MissingManifestResourceException.

[Visual Basic] Overloads Public Sub New()
[C#] public MissingManifestResourceException();
[C++] public: MissingManifestResourceException();
[JScript] public function MissingManifestResourceException();

Constructs a MissingManifestResourceException with the specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public MissingManifestResourceException(String);
[C++] public: MissingManifestResourceException(String*);
[JScript] public function MissingManifestResourceException(String);

Constructs a MissingManifestResourceException with the specified message and specified inner exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public MissingManifestResourceException(String, Exception);
[C++] public: MissingManifestResourceException(String*, Exception);
[JScript] public function MissingManifestResourceException(String, Exception);

See Also

MissingManifestResourceException Class | MissingManifestResourceException Members | System.Resources Namespace


MissingManifestResourceException Constructor ()

Constructs a MissingManifestResourceException.

[Visual Basic]
Overloads Public Sub New()
[C#]
public MissingManifestResourceException();
[C++]
public: MissingManifestResourceException();
[JScript]
public function MissingManifestResourceException();

See Also

MissingManifestResourceException Class | MissingManifestResourceException Members | System.Resources Namespace | MissingManifestResourceException Constructor Overload List


MissingManifestResourceException Constructor (String)

Constructs a MissingManifestResourceException with the specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public MissingManifestResourceException(
   string message
);
[C++]
public: MissingManifestResourceException(
   String* message
);
[JScript]
public function MissingManifestResourceException(
   message : String
);

Parameters

message
Exception message

See Also

MissingManifestResourceException Class | MissingManifestResourceException Members | System.Resources Namespace | MissingManifestResourceException Constructor Overload List


MissingManifestResourceException Constructor (String, Exception)

Constructs a MissingManifestResourceException with the specified message and specified inner exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public MissingManifestResourceException(
   string message,
   Exception inner
);
[C++]
public: MissingManifestResourceException(
   String* message,
   Exception* inner
);
[JScript]
public function MissingManifestResourceException(
   message : String,
   inner : Exception
);

Parameters

message
Exception message
inner
Inner exception

See Also

MissingManifestResourceException Class | MissingManifestResourceException Members | System.Resources Namespace | MissingManifestResourceException Constructor Overload List


ResourceManager Class

Represents a set of resources with a given root name.

Object
ResourceManager

[Visual Basic]
Public Class ResourceManager
[C#]
public class ResourceManager
[C++]
public __gc class ResourceManager
[JScript]
public class ResourceManager

Remarks

Using the methods of ResourceManager, a caller can obtain a ResourceSet, which represents the resources for a particular culture. The ResourceSet can then be used to access the resources, localized for that culture, by name. A caller can also access the resources for a particular culture directly through the ResourceManager via GetObject and GetString. By default, these methods return the resource for the culture determined by the current cultural settings of the thread that made the call.

Ideally, resources should be created for every culture, or at the minimum a meaningful subset of the cultures. The resource file names follow the naming convention basename.cultureName.resources. basename can be the name of the application, or depending on the granularity desired, the name of a class. cultureName is determined from Name. A resource for the neutral culture (returned by InvariantCulture) should be named basename.resource. If a subculture is specified, the naming convention for cultureName is mainCultureName-subCultureName .

For example, suppose that an assembly has several resources with the root name "MyResources". These resources will have names such as "MyResources.ja-jp.resources", "MyResources.de.resources", "MyResources.zh.resources", "MyResources.fr-be.resources", which contain resources respectively for Japan, Germany, China, and French (Belgium). Now suppose that a ResourceManager has been created to represent the resources with this root name. Using the ResourceManager, one could obtain a ResourceSet which encapsulates "MyResources.ja-jp.resources" by calling GetResourceSet(new CultureInfo ("ja-jp"),

TRUE, FALSE). Or, if it is known that "MyResources" contains a resource by the name "TOOLBAR_ICON", one could obtain the value of that resource localized for Japan by calling GetObject("TOOLBAR_ICON", new CultureInfo("ja-jp")).

ResourceManager is case-sensitive, i.e., resource names, resource keys, etc. are all case-sensitive.

Requirements

Namespace: System.Resources

Assembly: mscorlib.dll

See Also

ResourceManager Members | System.Resources Namespace


ResourceManager Members

Public:

Constructor

ResourceManager Constructor Overloaded. Initializes a new instance of the ResourceManager class.

Properties

BaseName | This read-only property returns the base name for the ResourceManager.
ResourceSetType | This read-only property returns the Type of the ResourceSet the ResourceManager uses to construct a ResourceSet object.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObject | Overloaded. Gets the value of the specified resource.
GetResourceSet | Gets the specified ResourceSet.
GetString | Overloaded. Gets the value of the specified resource.
GetType (inherited from Object) | Gets the Type of the Object.
ReleaseAllResources | Tells the ResourceManager to call Close on all ResourceSet objects and release all resources. This will shrink the working set in a running application. Any future resource lookups on this ResourceManager will be as expensive as the first lookup, since it will need to search and load resources again. This may be useful in some complex threading scenarios, where creating a new ResourceManager is not quite the correct behavior.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

MagicNumber Holds the number used to identify resource files. The value is set to 0xBEEFCACE. The first four bytes of the system default file format contain a 32-bit signed integer in little-endian format (see the TBD).

Protected:

Constructor

ResourceManager Constructor Overloaded. Initializes a new instance of the ResourceManager class.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetResourceFileName | [To be supplied.]
InternalGetResourceSet | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

BaseNameField | The root name of the resource.
MainAssembly | The main Assembly that contains the resources.
ResourceSets | Returns a mapping from cultures to ResourceSet objects.
UseManifest | Determines if resources should be searched for in the Assembly manifest.
UseSatelliteAssem | Determines if resources should be searched for in satellite assemblies.

See Also

ResourceManager Class | System.Resources Namespace


ResourceManager Constructor

Initializes a new instance of the ResourceManager class.

Overload List

Initializes a new instance of the ResourceManager class.

[Visual Basic] Overloads Protected Sub New()
[C#] protected ResourceManager();
[C++] protected: ResourceManager();
[JScript] protected function ResourceManager();

Creates a ResourceManager for the resources whose names begin with the specified root name in the specified directory.

[Visual Basic] Overloads Public Sub New(String, String, Type)
[C#] public ResourceManager(String, String, Type);
[C++] public: ResourceManager(String*, String*, Type);
[JScript] public function ResourceManager(String, String, Type);

Creates a ResourceManager for resources whose names begin with the specified root name in the directory of the specified type's module.

[Visual Basic] Overloads Public Sub New(String, Type, Type)
[C#] public ResourceManager(String, Type, Type);
[C++] public: ResourceManager(String*, Type, Type);
[JScript] public function ResourceManager(String, Type, Type);

Creates a ResourceManager for looking up resources beginning with the specified root name using the Assembly manifest.

[Visual Basic] Overloads Public Sub New(String, Assembly, Type, Boolean)
[C#] public ResourceManager(String, Assembly, Type, bool);
[C++] public: ResourceManager(String*, Assembly, Type, bool);
[JScript] public function ResourceManager(String, Assembly, Type, Boolean);

Creates a ResourceManager for looking up resources beginning with the specified root name using the manifest of a specified type's Assembly.

[Visual Basic] Overloads Public Sub New(String, Type, Type, Boolean)
[C#] public ResourceManager(String, Type, Type, bool);
[C++] public: ResourceManager(String*, Type, Type, bool);
[JScript] public function ResourceManager(String, Type, Type, Boolean);

See Also

ResourceManager Class | ResourceManager Members | System.Resources Namespace


ResourceManager Constructor ()

Initializes a new instance of the ResourceManager class.

[Visual Basic]
Overloads Protected Sub New()
[C#]
protected ResourceManager();
[C++]
protected: ResourceManager();
[JScript]
protected function ResourceManager();

See Also

ResourceManager Class | ResourceManager Members | System.Resources Namespace | ResourceManager Constructor Overload List


ResourceManager Constructor (String, String, Type)

Creates a ResourceManager for the resources whose names begin with the specified root name in the specified directory.

[Visual Basic]
Overloads Public Sub New( _
   ByVal baseName As String, _
   ByVal resourceDir As String, _
   ByVal usingResourceSet As Type _
)
[C#]
public ResourceManager(
   string baseName,
   string resourceDir,
   Type usingResourceSet
);
[C++]
public: ResourceManager(
   String* baseName,
   String* resourceDir,
   Type* usingResourceSet
);
[JScript]
public function ResourceManager(
   baseName : String,
   resourceDir : String,
   usingResourceSet : Type
);

Parameters

baseName
The root name of the resources. For example, the root name for the resource "MyResource.en-us.resources" is "MyResource".
resourceDir
The name of the directory to search for the resources.
usingResourceSet
The Type of the custom ResourceSet to be used. If a null reference (in Visual Basic Nothing), the default runtime ResourceSet will be used.

Exceptions

Exception Type | Condition
ArgumentException | if baseName ends in ".resources"
ArgumentNullException | if baseName is a null reference (Nothing)

Remarks

This Assembly ignorant constructor is mostly useful for testing a ResourceSet implementation.

You can specify a ResourceSet implementation to be used. If you do not need a specific ResourceSet implementation but would like to use a custom resource file format, you should subclass ResourceSet, override GetDefaultReader and GetDefaultWriter, and pass that type to this constructor.

See Also

ResourceManager Class | ResourceManager Members | System.Resources Namespace | ResourceManager Constructor Overload List


ResourceManager Constructor (String, Type, Type)

Creates a ResourceManager for resources whose names begin with the specified root name in the directory of the specified type's module.

[Visual Basic]
Overloads Public Sub New( _
   ByVal baseName As String, _
   ByVal locationInfo As Type, _
   ByVal usingResourceSet As Type _
)
[C#]
public ResourceManager(
   string baseName,
   Type locationInfo,
   Type usingResourceSet
);
[C++]
public: ResourceManager(
   String* baseName,
   Type* locationInfo,
   Type* usingResourceSet
);
[JScript]
public function ResourceManager(
   baseName : String,
   locationInfo : Type,
   usingResourceSet : Type
);

Parameters

baseName
The root name of the resources. For example, the root name for the resource "MyResource.en-us.resources" is "MyResource".
locationInfo
The resources will be searched for in the directory of the Module of the Type locationInfo. Additionally, the namespace of locationInfo will be used to qualify resource names. For example, if the name of the Type locationInfo is "MyNamespace.MyType" and baseName is "MyResource", the ResourceManager will look for a neutral resource named "MyNamespace.MyResource.resources" and for a German resource named "MyNamespace.MyResource.de.resources".
usingResourceSet
The Type of the custom ResourceSet to be used. If a null reference (in Visual Basic Nothing), the default runtime ResourceSet will be used.

Exceptions

Exception Type | Condition
ArgumentException | if usingResourceSet is not a subclass of ResourceSet.
ArgumentNullException | if baseName is a null reference (Nothing) or locationInfo is a null reference (Nothing).

Remarks

You can specify a ResourceSet implementation to be used. If you do not need a specific ResourceSet implementation but would like to use a custom resource file format, you should subclass ResourceSet, override GetDefaultReader and GetDefaultWriter, and pass that type to this constructor.

See Also

ResourceManager Class | ResourceManager Members | System.Resources Namespace | ResourceManager Constructor Overload List


ResourceManager Constructor (String, Assembly, Type, Boolean)

Creates a ResourceManager for looking up resources beginning with the specified root name using the Assembly manifest.

[Visual Basic]
Overloads Public Sub New( _
   ByVal baseName As String, _
   ByVal assembly As Assembly, _
   ByVal usingResourceSet As Type, _
   ByVal usingSatelliteAssemblies As Boolean _
)
[C#]
public ResourceManager(
   string baseName,
   Assembly assembly,
   Type usingResourceSet,
   bool usingSatelliteAssemblies
);
[C++]
public: ResourceManager(
   String* baseName,
   Assembly* assembly,
   Type* usingResourceSet,
   bool usingSatelliteAssemblies
);
[JScript]
public function ResourceManager(
   baseName : String,
   assembly : Assembly,
   usingResourceSet : Type,
   usingSatelliteAssemblies : Boolean
);

Parameters

baseName
The root name of the resources. For example, the root name for the resource "MyResource.en-us.resources" is "MyResource".
assembly
The main Assembly for the resources.
usingResourceSet
The Type of the custom ResourceSet to be used. If a null reference (in Visual Basic Nothing), the default runtime ResourceSet will be used.
usingSatelliteAssemblies
true if the ResourceManager should search for resources in satellite assemblies.

Exceptions

Exception Type | Condition
ArgumentException | if usingResourceset is not a subclass of ResourceSet
ArgumentNullException | if baseName is a null reference (Nothing) or assembly is a null reference (Nothing)
MissingManifestResourceException | if the assembly does not contain the resources for the neutral culture

Remarks

The resources are searched for in a flat namespace. On large projects, this may lead to collisions in resource names.

The individual resources can either all be contained in the specified main assembly, or they can be contained in satellite assemblies. A satellite assembly is assumed to contain resources for a single culture specified in that assembly's metadata. The satellite assemblies are loaded if necessary.

You can specify a ResourceSet implementation to be used. If you do not need a specific ResourceSet implementation but would like to use a custom resource file format, you should subclass ResourceSet, override GetDefaultReader and GetDefaultWriter, and pass that type to this constructor.

See Also

ResourceManager Class | ResourceManager Members | System.Resources Namespace | ResourceManager Constructor Overload List


ResourceManager Constructor (String, Type, Type, Boolean)

Creates a ResourceManager for looking up resources beginning with the specified root name using the manifest of a specified type's Assembly.

[Visual Basic]
Overloads Public Sub New( _
   ByVal baseName As String, _
   ByVal locationInfo As Type, _
   ByVal usingResourceSet As Type, _
   ByVal usingSatelliteAssemblies As Boolean _
)
[C#]
public ResourceManager(
   string baseName,
   Type locationInfo,
   Type usingResourceSet,
   bool usingSatelliteAssemblies
);
[C++]
public: ResourceManager(
   String* baseName,
   Type* locationInfo,
   Type* usingResourceSet,
   bool usingSatelliteAssemblies
);
[JScript]
public function ResourceManager(
   baseName : String,
   locationInfo : Type,
   usingResourceSet : Type,
   usingSatelliteAssemblies : Boolean
);

Parameters

baseName
The root name of the resources. For example, the root name for the resource "MyResource.en-us.resources" is "MyResource".
locationInfo
The resources will be searched for in the Assembly of the Type locationInfo. Additionally, the namespace of locationInfo will be used to qualify resource names. For example, if the name of the Type locationInfo is "MyNamespace.MyType" and baseName is "MyResource", the ResourceManager will look for neutral resources named "MyNamespace.MyResource.resources" and for a German resource named "MyNamespace.MyResource.de.resources".
usingResourceSet
The Type of the custom ResourceSet to be used. If a null reference (in Visual Basic Nothing), the default runtime ResourceSet will be used.
usingSatelliteAssemblies
true if the ResourceManager should search for resources in satellite assemblies.

Exceptions

Exception Type | Condition
ArgumentException | if usingResourceSet is not a subclass of ResourceSet.
ArgumentNullException | if baseName is a null reference (Nothing) or locationInfo is a null reference (Nothing).
MissingManifestResourceException | if the assembly does not contain the resources for the neutral culture.

Remarks

The resources are searched for in a namespace qualified by a specified Type. On large projects, this will reduce collisions in resource names.

The individual resources can either all be contained in the specified main assembly, or they can be contained in satellite assemblies. A satellite assembly is assumed to contain resources for a single culture specified in that assembly's metadata. The satellite assemblies are loaded if necessary.

You can specify a ResourceSet implementation to be used. If you do not need a specific ResourceSet implementation but would like to use a custom resource file format, you should subclass ResourceSet, override GetDefaultReader and GetDefaultWriter, and pass that type to this constructor.

See Also

ResourceManager Class | ResourceManager Members | System.Resources Namespace | ResourceManager Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ResourceManager Properties

The properties of the ResourceManager class are listed below. For a complete list of ResourceManager class members, see the ResourceManager Members topic.

Public:

BaseName | This read-only property returns the base name for the ResourceManager.
ResourceSetType | This read-only property returns the Type of the ResourceSet the ResourceManager uses to construct a ResourceSet object.

See Also

ResourceManager Class | System.Resources Namespace


ResourceManager.BaseName

This read-only property returns the base name for the ResourceManager.

[Visual Basic]
Overridable Public ReadOnly Property BaseName As String
[C#]
public string BaseName {virtual get;}
[C++]
public: __property virtual String* get_BaseName();
[JScript]
public function get BaseName() : String;

Property Value

Read only. Returns the name for the ResourceManager.

Remarks

None

See Also

ResourceManager Class | ResourceManager Members | System.Resources Namespace


ResourceManager.ResourceSetType

This read-only property returns the Type of the ResourceSet the ResourceManager uses to construct a ResourceSet object.

[Visual Basic]
Overridable Public ReadOnly Property ResourceSetType As Type
[C#]
public Type ResourceSetType {virtual get;}
[C++]
public: __property virtual Type* get_ResourceSetType();
[JScript]
public function get ResourceSetType() : Type;

Property Value

Read only.

See Also

ResourceManager Class | ResourceManager Members | System.Resources Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ResourceManager Methods

The methods of the ResourceManager class are listed below. For a complete list of ResourceManager class members, see the ResourceManager Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObject | Overloaded. Gets the value of the specified resource.
GetResourceSet | Gets the specified ResourceSet.
GetString | Overloaded. Gets the value of the specified resource.
GetType (inherited from Object) | Gets the Type of the Object.
ReleaseAllResources | Tells the ResourceManager to call Close on all ResourceSet objects and release all resources. This will shrink the working set in a running application. Any future resource lookups on this ResourceManager will be as expensive as the first lookup, since it will need to search and load resources again. This may be useful in some complex threading scenarios, where creating a new ResourceManager is not quite the correct behavior.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
GetResourceFileName | [To be supplied.]
InternalGetResourceSet | [To be supplied.]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResourceManager Class | System.Resources Namespace


ResourceManager.GetObject

Gets the value of the specified resource.

Overload List

Returns the value of the specified resource. The resource that is returned is localized for the culture determined by the current cultural settings of the current Thread (this is accomplished via the culture's CurrentUICulture property). If the resource has not been localized for that culture, the resource that is returned is localized for a "best match" (this is accomplished via the Parent property). Otherwise, a a null reference (in Visual Basic Nothing) reference is returned.

[Visual Basic] Overloads Overridable Public Function GetObject(String) As Object
[C#] public virtual object GetObject(String);
[C++] public: virtual Object* GetObject(String*);
[JScript] public function GetObject(String) : Object;

Gets the value of the specified resource. The resource that is returned is localized for the specified culture. If the resource has not been localized for that culture, the resource that is returned is localized for a "best match" (this is accomplished via the culture's CurrentUICulture property). Otherwise, a a null reference (Nothing) reference is returned.

[Visual Basic] Overloads Overridable Public Function GetObject(String, CultureInfo) As Object
[C#] public virtual object GetObject(String, CultureInfo);
[C++] public: virtual Object* GetObject(String*, CultureInfo);
[JScript] public function GetObject(String, CultureInfo) : Object;

See Also

ResourceManager Class | ResourceManager Members | System.Resources Namespace


ResourceManager.GetObject (String)

Returns the value of the specified resource. The resource that is returned is localized for the culture determined by the current cultural settings of the current Thread (this is accomplished via the culture's CurrentUICulture property). If the resource has not been localized for that culture, the resource that is returned is localized for a "best match" (this is accomplished via the Parent property). Otherwise, a a null reference (in Visual Basic Nothing) reference is returned.

[Visual Basic]
Overloads Overridable Public Function GetObject( _
   ByVal name As String _
) As Object
[C#]
public virtual object GetObject(
   string name
);
[C++]
public: virtual Object* GetObject(
   String* name
);
[JScript]
public function GetObject(
   name : String
) : Object;

Parameters

name
The name of the resource to get.

Return Value

The value of the resource localized for the caller's current culture settings. If a match is not possible, a null reference (Nothing) is returned.

Exceptions

Exception Type | Condition
ArgumentNullException | if name is a null reference (Nothing)

See Also

ResourceManager Class | ResourceManager Members | System.Resources Namespace | ResourceManager.GetObject Overload List


ResourceManager.GetObject (String, CultureInfo)

Gets the value of the specified resource. The resource that is returned is localized for the specified culture. If the resource has not been localized for that culture, the resource that is returned is localized for a "best match" (this is accomplished via the culture's CurrentUICulture property). Otherwise, a a null reference (in Visual Basic Nothing) reference is returned.

[Visual Basic]
Overloads Overridable Public Function GetObject( _
   ByVal name As String, _
   ByVal culture As CultureInfo _
) As Object
[C#]
public virtual object GetObject(
   string name,
   CultureInfo culture
);
[C++]
public: virtual Object* GetObject(
   String* name,
   CultureInfo* culture
);
[JScript]
public function GetObject(
   name : String,
   culture : CultureInfo
) : Object;

Parameters

name
The name of the resource to get.
culture
The CultureInfo object that represents the culture for which the resource is to be localized. Note that if the resource is not localized for this culture, the culture's Parent property will be called successively in search of a match. If this value is a null reference (Nothing), the CultureInfo is obtained via the culture's CurrentUICulture property.

Return Value

The value of the resource, localized for the specified culture. If a "best match" is not possible, a null reference (Nothing) is returned.

Exceptions

Exception Type | Condition
ArgumentNullException | if name is a null reference (Nothing)

See Also

ResourceManager Class | ResourceManager Members | System.Resources Namespace | ResourceManager.GetObject Overload List


ResourceManager.GetResourceFileName

[To be supplied.]

[Visual Basic]
Overridable Protected Function GetResourceFileName( _
   ByVal culture As CultureInfo _
) As String
[C#]
protected virtual string GetResourceFileName(
   CultureInfo culture
);
[C++]
protected: virtual String* GetResourceFileName(
   CultureInfo* culture
);
[JScript]
protected function GetResourceFileName(
   culture : CultureInfo
) : String;

Parameters

culture
[To be supplied.]

See Also

ResourceManager Class | ResourceManager Members | System.Resources Namespace


ResourceManager.GetResourceSet

Gets the specified ResourceSet.

[Visual Basic]
Overridable Public Function GetResourceSet( _
   ByVal culture As CultureInfo, _
   ByVal createIfNotExists As Boolean, _
   ByVal tryParents As Boolean _
) As ResourceSet
[C#]
public virtual ResourceSet GetResourceSet(
   CultureInfo culture,
   bool createIfNotExists,
   bool tryParents
);
[C++]
public: virtual ResourceSet* GetResourceSet(
   CultureInfo* culture,
   bool createIfNotExists,
   bool tryParents
);
[JScript]
public function GetResourceSet(
   culture : CultureInfo,
   createIfNotExists : Boolean,
   tryParents : Boolean
) : ResourceSet;

Parameters

culture
The CultureInfo to look for.
createIfNotExists
If true and if the ResourceSet has not been loaded yet, load it.
tryParents
If the ResourceSet cannot be loaded, try parent CultureInfo objects to see if they exist.

Return Value

The specified ResourceSet.

Exceptions

Exception Type | Condition
ArgumentNullException | if culture is a null reference (in Visual Basic Nothing).

Remarks

The ResourceSet that is returned represents the resources localized for the specified culture. If the resources have not been localized for that culture and tryParents is true, the ResourceSet that is returned is localized for a "best match" (this is accomplished via Parent). Otherwise, a a null reference (Nothing) reference is returned.

The parameters let you control whether the ResourceSet is created if it hasn't been loaded yet, and whether parent CultureInfo objects should be loaded as well for resource inheritance.

See Also

ResourceManager Class | ResourceManager Members | System.Resources Namespace


ResourceManager.GetString

Gets the value of the specified resource.

Overload List

Gets the value of the specified resource. The resource that is returned is localized for the specified culture. If the resource has not been localized for that culture, the resource that is returned is localized for a "best match" (this is accomplished via the culture's Parent property). Otherwise, a a null reference (in Visual Basic Nothing) reference is returned.

[Visual Basic] Overloads Overridable Public Function GetString(String, CultureInfo) As String
[C#] public virtual string GetString(String, CultureInfo);
[C++] public: virtual String* GetString(String*, CultureInfo);
[JScript] public function GetString(String, CultureInfo) : String;

Returns the value of the specified resource. The resource that is returned is localized for the culture determined by the current cultural settings of the current Thread (this is accomplished via the culture's CurrentUICulture property). If the resource has not been localized for that culture, the resource that is returned is localized for a "best match" (this is accomplished via the Parent property). Otherwise, a a null reference (Nothing) reference is returned.

[Visual Basic] Overloads Overridable Public Function GetString(String) As String
[C#] public virtual string GetString(String);
[C++] public: virtual String* GetString(String*);
[JScript] public function GetString(String) : String;

See Also

ResourceManager Class | ResourceManager Members | System.Resources Namespace


ResourceManager.GetString (String, CultureInfo)

Gets the value of the specified resource. The resource that is returned is localized for the specified culture. If the resource has not been localized for that culture, the resource that is returned is localized for a "best match" (this is accomplished via the culture's Parent property). Otherwise, a a null reference (in Visual Basic Nothing) reference is returned.

[Visual Basic]
Overloads Overridable Public Function GetString( _
   ByVal name As String, _
   ByVal culture As CultureInfo _
) As String
[C#]
public virtual string GetString(
   string name,
   CultureInfo culture
);
[C++]
public: virtual String* GetString(
   String* name,
   CultureInfo* culture
);
[JScript]
public function GetString(
   name : String,
   culture : CultureInfo
) : String;

Parameters

name
The name of the resource to get.
culture
The CultureInfo object that represents the culture for which the resource is to be localized. Note that if the resource is not localized for this culture, the culture's Parent property will be called successively in search of a match. If this value is a null reference (Nothing), the CultureInfo is obtained via the culture's CurrentUICulture property.

Return Value

The value of the resource localized for the specified culture. If a "best match" is not possible, a null reference (Nothing) is returned.

Exceptions

Exception Type | Condition
ArgumentNullException | If name is a null reference (Nothing)
InvalidOperationException | If the value of the specified resource is not a String

See Also

ResourceManager Class | ResourceManager Members | System.Resources Namespace | ResourceManager.GetString Overload List


ResourceManager.GetString (String)

Returns the value of the specified resource. The resource that is returned is localized for the culture determined by the current cultural settings of the current Thread (this is accomplished via the culture's CurrentUICulture property). If the resource has not been localized for that culture, the resource that is returned is localized for a "best match" (this is accomplished via the Parent property). Otherwise, a a null reference (in Visual Basic Nothing) reference is returned.

[Visual Basic]
Overloads Overridable Public Function GetString( _
   ByVal name As String _
) As String
[C#]
public virtual string GetString(
   string name
);
[C++]
public: virtual String* GetString(
   String* name
);
[JScript]
public function GetString(
   name : String
) : String;

Parameters

name
The name of the resource to get.

Return Value

The value of the resource localized for the caller's current culture settings. If a match is not possible, a null reference (Nothing) is returned.

Exceptions

Exception Type | Condition
ArgumentNullException | The name parameter is a null reference (Nothing).
InvalidOperationException | The value of the specified resource is not a string.

See Also

ResourceManager Class | ResourceManager Members | System.Resources Namespace | ResourceManager.GetString Overload List


ResourceManager.InternalGetResourceSet

[To be supplied.]

[Visual Basic]
Overridable Protected Function InternalGetResourceSet( _
   ByVal culture As CultureInfo, _
   ByVal createIfNotExists As Boolean, _
   ByVal tryParents As Boolean _
) As ResourceSet
[C#]
protected virtual ResourceSet InternalGetResourceSet(
   CultureInfo culture,
   bool createIfNotExists,
   bool tryParents
);
[C++]
protected: virtual ResourceSet* InternalGetResourceSet(
   CultureInfo* culture,
   bool createIfNotExists,
   bool tryParents
);
[JScript]
protected function InternalGetResourceSet(
   culture : CultureInfo,
   createIfNotExists : Boolean,
   tryParents : Boolean
) : ResourceSet;

Parameters

culture
[To be supplied.]
createIfNotExists
[To be supplied.]
tryParents
[To be supplied.]

See Also

ResourceManager Class | ResourceManager Members | System.Resources Namespace


ResourceManager.ReleaseAllResources

Tells the ResourceManager to call Close on all ResourceSet objects and release all resources. This will shrink the working set in a running application. Any future resource lookups on this ResourceManager will be as expensive as the first lookup, since it will need to search and load resources again.

This may be useful in some complex threading scenarios, where creating a new ResourceManager is not quite the correct behavior.

[Visual Basic]
Overridable Public Sub ReleaseAllResources()
[C#]
public virtual void ReleaseAllResources();
[C++]
public: virtual void ReleaseAllResources();
[JScript]
public function ReleaseAllResources();

See Also

ResourceManager Class | ResourceManager Members | System.Resources Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ResourceManager Fields

The fields of the ResourceManager class are listed below. For a complete list of ResourceManager class members, see the ResourceManager Members topic.

Public:

MagicNumber Holds the number used to identify resource files. The value is set to 0xBEEFCACE. The first four bytes of the system default file format contain a 32-bit signed integer in little-endian format (see the TBD).

Protected:

BaseNameField | The root name of the resource.
MainAssembly | The main Assembly that contains the resources.
ResourceSets | Returns a mapping from cultures to ResourceSet objects.
UseManifest | Determines if resources should be searched for in the Assembly manifest.
UseSatelliteAssem | Determines if resources should be searched for in satellite assemblies.

See Also

ResourceManager Class | System.Resources Namespace


ResourceManager.BaseNameField

The root name of the resource.

[Visual Basic]
Protected BaseNameField As String
[C#]
protected string BaseNameField;
[C++]
protected: String* BaseNameField;
[JScript]
protected var BaseNameField : String;

See Also

ResourceManager Class | ResourceManager Members | System.Resources Namespace


ResourceManager.MagicNumber

Holds the number used to identify resource files. The value is set to 0xBEEFCACE. The first four bytes of the system default file format contain a 32-bit signed integer in little-endian format (see the TBD).

[Visual Basic]
Public Const MagicNumber As Integer
[C#]
public const int MagicNumber;
[C++]
public: const int MagicNumber;
[JScript]
public var MagicNumber : int;

See Also

ResourceManager Class | ResourceManager Members | System.Resources Namespace


ResourceManager.MainAssembly

The main Assembly that contains the resources.

[Visual Basic]
Protected MainAssembly As Assembly
[C#]
protected Assembly MainAssembly;
[C++]
protected: Assembly* MainAssembly;
[JScript]
protected var MainAssembly : Assembly;

See Also

ResourceManager Class | ResourceManager Members | System.Resources Namespace


ResourceManager.ResourceSets

Returns a mapping from cultures to ResourceSet objects.

[Visual Basic]
Protected ResourceSets As Hashtable
[C#]
protected Hashtable ResourceSets;
[C++]
protected: Hashtable* ResourceSets;
[JScript]
protected var ResourceSets : Hashtable;

See Also

ResourceManager Class | ResourceManager Members | System.Resources Namespace


ResourceManager.UseManifest

Determines if resources should be searched for in the Assembly manifest.

[Visual Basic]
Protected UseManifest As Boolean
[C#]
protected bool UseManifest;
[C++]
protected: bool UseManifest;
[JScript]
protected var UseManifest : Boolean;

See Also

ResourceManager Class | ResourceManager Members | System.Resources Namespace


ResourceManager.UseSatelliteAssem

Determines if resources should be searched for in satellite assemblies.

[Visual Basic]
Protected UseSatelliteAssem As Boolean
[C#]
protected bool UseSatelliteAssem;
[C++]
protected: bool UseSatelliteAssem;
[JScript]
protected var UseSatelliteAssem : Boolean;

See Also

ResourceManager Class | ResourceManager Members | System.Resources Namespace


ResourceReader Class

Provides a default implementation of the IResourceReader interface and implements a resource reader. Resource readers are used to read resource name and resource value pairs from ".resources" files. These methods are used to advance to the next resource and read the name and value of each resource in the ".resources" file. This class can be used to enumerate the resources only one time.

Object
ResourceReader

[Visual Basic]
Public Class ResourceReader
   Implements IResourceReader, IEnumerable
[C#]
public class ResourceReader : IResourceReader, IEnumerable
[C++]
public __gc class ResourceReader : public IResourceReader,
   IEnumerable
[JScript]
public class ResourceReader implements IResourceReader, IEnumerable

Remarks

The TBD provides details on the default resource file form

Example: Reading the "mscorlib.resources" resource.

The "mscorlib.resources" resource will be used by the base class library in order to localize the message strings carried by exceptions. The following code sample displays the contents of the "mscorlib.resources resource" on the console:

[C#]

using System;
using System.Resources;

public class ReadResources
{
  public static void Main(string[] args)
  {
    ResourceReader reader = new ResourceReader("mscorlib.resources");
    while (reader.MoveNext() != null) {
      Console.WriteLine();
      Console.WriteLine("Name: {0}", reader.GetKey());
      Console.WriteLine("Value: {0}", reader.GetValue());
    }
    reader.Close();
  }
}

Requirements

Namespace: System.Resources

Assembly: mscorlib.dll

See Also

ResourceReader Members | System.Resources Namespace


ResourceReader Members

Public:

Constructor

ResourceReader Constructor Overloaded. Initializes a new instance of the ResourceReader class.

Methods

Close | Releases all operating system resources associated with this ResourceReader.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Returns an enumerator for this ResourceReader.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResourceReader Class | System.Resources Namespace


ResourceReader Constructor

Initializes a new instance of the ResourceReader class.

Overload List

Initializes a new instance of the ResourceReader class for the specified resource file.

[Visual Basic] Overloads Public Sub New(String)
[C#] public ResourceReader(String);
[C++] public: ResourceReader(String*);
[JScript] public function ResourceReader(String);

Initializes a new instance of the ResourceReader class for the specified stream.

[Visual Basic] Overloads Public Sub New(Stream)
[C#] public ResourceReader(Stream);
[C++] public: ResourceReader(Stream*);
[JScript] public function ResourceReader(Stream);

See Also

ResourceReader Class | ResourceReader Members | System.Resources Namespace


ResourceReader Constructor (String)

Initializes a new instance of the ResourceReader class for the specified resource file.

[Visual Basic]
Overloads Public Sub New( _
   ByVal fileName As String _
)
[C#]
public ResourceReader(
   string fileName
);
[C++]
public: ResourceReader(
   String* fileName
);
[JScript]
public function ResourceReader(
   fileName : String
);

Parameters

fileName
The path of the resource file to be read.

Exceptions

Exception Type | Condition
ArgumentNullException | if fileName is null
FileNotFoundException | if the file cannot be found
IOException | if an I/O error occurs

See Also

ResourceReader Class | ResourceReader Members | System.Resources Namespace | ResourceReader Constructor Overload List


ResourceReader Constructor (Stream)

Initializes a new instance of the ResourceReader class for the specified stream.

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream _
)
[C#]
public ResourceReader(
   Stream stream
);
[C++]
public: ResourceReader(
   Stream* stream
);
[JScript]
public function ResourceReader(
   stream : Stream
);

Parameters

stream
The input stream for reading resources.

Exceptions

Exception Type | Condition
ArgumentException | if stream is not readable.
ArgumentNullException | if stream is null.
IOException | if an I/O error occurs while accessing stream.

See Also

ResourceReader Class | ResourceReader Members | System.Resources Namespace | ResourceReader Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ResourceReader Methods

The methods of the ResourceReader class are listed below. For a complete list of ResourceReader class members, see the ResourceReader Members topic.

Public:

Close | Releases all operating system resources associated with this ResourceReader.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetEnumerator | Returns an enumerator for this ResourceReader.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResourceReader Class | System.Resources Namespace


ResourceReader.Close

Releases all operating system resources associated with this ResourceReader.

[Visual Basic]
Overridable Public Sub Close()
[C#]
public virtual void Close();
[C++]
public: virtual void Close();
[JScript]
public function Close();

See Also

ResourceReader Class | ResourceReader Members | System.Resources Namespace


ResourceReader.GetEnumerator

Returns an enumerator for this ResourceReader.

[Visual Basic]
Overridable Public Function GetEnumerator() As IDictionaryEnumerator
[C#]
public virtual IDictionaryEnumerator GetEnumerator();
[C++]
public: virtual IDictionaryEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator() : IDictionaryEnumerator;

See Also

ResourceReader Class | ResourceReader Members | System.Resources Namespace


ResourceSet Class

Stores all the resources defined in one particular CultureInfo.

Object
ResourceSet

[Visual Basic]
Public Class ResourceSet
[C#]
public class ResourceSet
[C++]
public __gc class ResourceSet
[JScript]
public class ResourceSet

Remarks

The ResourceSet class enumerates over an IResourceReader, loading every name and value, then stores them in a Hashtable. A custom IResourceReader can be used.

See the TBD for details on the default resource file format.

Requirements

Namespace: System.Resources

Assembly: mscorlib.dll

See Also

ResourceSet Members | System.Resources Namespace


ResourceSet Members

Public:

Constructor

ResourceSet Constructor Overloaded. Initializes a new instance of the ResourceSet class.

Methods

Close | Closes and releases any resources used by this ResourceSet, if any. All calls to methods on the ResourceSet after a call to this method may fail.
CreateWriter | Creates a resource writer for the specified file. The type of the resource writer to be created is determined by GetDefaultWriter. If the file already exists, it will be overwritten.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDefaultReader | Returns the preferred resource reader class for this kind of ResourceSet. Subclasses of ResourceSet using their own ResourceReader should override GetDefaultReader and GetDefaultWriter.
GetDefaultWriter | Returns the preferred resource writer class for this kind of ResourceSet. Subclasses of ResourceSet using their own ResourceWriter should override GetDefaultReader and GetDefaultWriter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObject | Looks up an object value for a resource given its name.
GetString | Looks up a String value for a resource given its name.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Constructor

ResourceSet Constructor Overloaded. Initializes a new instance of the ResourceSet class.

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ReadResources | Reads all the resources and stores them in Table.

Fields

Reader | The resource reader used to read the resources.
Table | The Hashtable in which the resources are stored.

See Also

ResourceSet Class | System.Resources Namespace


ResourceSet Constructor

Initializes a new instance of the ResourceSet class.

Overload List

Initializes a new instance of the ResourceSet class.

[Visual Basic] Overloads Protected Sub New()
[C#] protected ResourceSet();
[C++] protected: ResourceSet();
[JScript] protected function ResourceSet();

Initializes a new instance of the ResourceSet class using the system default implementation that opens and reads resources from a given file.

[Visual Basic] Overloads Public Sub New(String)
[C#] public ResourceSet(String);
[C++] public: ResourceSet(String*);
[JScript] public function ResourceSet(String);

Initializes a new instance of the ResourceSet class using the system default implementation that reads resources from an open stream of data.

[Visual Basic] Overloads Public Sub New(Stream)
[C#] public ResourceSet(Stream);
[C++] public: ResourceSet(Stream*);
[JScript] public function ResourceSet(Stream);

Initializes a new instance of the ResourceSet class using the specified resource reader interface.

[Visual Basic] Overloads Public Sub New(IResourceReader)
[C#] public ResourceSet(IResourceReader);
[C++] public: ResourceSet(IResourceReader*);
[JScript] public function ResourceSet(IResourceReader);

See Also

ResourceSet Class | ResourceSet Members | System.Resources Namespace


ResourceSet Constructor ()

Initializes a new instance of the ResourceSet class.

[Visual Basic]
Overloads Protected Sub New()
[C#]
protected ResourceSet();
[C++]
protected: ResourceSet();
[JScript]
protected function ResourceSet();

See Also

ResourceSet Class | ResourceSet Members | System.Resources Namespace | ResourceSet Constructor Overload List


ResourceSet Constructor (String)

Initializes a new instance of the ResourceSet class using the system default implementation that opens and reads resources from a given file.

[Visual Basic]
Overloads Public Sub New( _
   ByVal fileName As String _
)
[C#]
public ResourceSet(
   string fileName
);
[C++]
public: ResourceSet(
   String* fileName
);
[JScript]
public function ResourceSet(
   fileName : String
);

Parameters

fileName
Resource file to read.

See Also

ResourceSet Class | ResourceSet Members | System.Resources Namespace | ResourceSet Constructor Overload List


ResourceSet Constructor (Stream)

Initializes a new instance of the ResourceSet class using the system default implementation that reads resources from an open stream of data.

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream _
)
[C#]
public ResourceSet(
   Stream stream
);
[C++]
public: ResourceSet(
   Stream* stream
);
[JScript]
public function ResourceSet(
   stream : Stream
);

Parameters

stream
The Stream of resources to be read.

Exceptions

Exception Type | Condition
ArgumentNullException | if stream is a null reference (in Visual Basic Nothing).

See Also

ResourceSet Class | ResourceSet Members | System.Resources Namespace | ResourceSet Constructor Overload List


ResourceSet Constructor (IResourceReader)

Initializes a new instance of the ResourceSet class using the specified resource reader interface.

[Visual Basic]
Overloads Public Sub New( _
   ByVal reader As IResourceReader _
)
[C#]
public ResourceSet(
   IResourceReader reader
);
[C++]
public: ResourceSet(
   IResourceReader* reader
);
[JScript]
public function ResourceSet(
   reader : IResourceReader
);

Parameters

reader
The reader to use.

Exceptions

Exception Type | Condition
ArgumentNullException | if reader is a null reference (in Visual Basic Nothing).

See Also

ResourceSet Class | ResourceSet Members | System.Resources Namespace | ResourceSet Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ResourceSet Methods

The methods of the ResourceSet class are listed below. For a complete list of ResourceSet class members, see the ResourceSet Members topic.

Public:

Close | Closes and releases any resources used by this ResourceSet, if any. All calls to methods on the ResourceSet after a call to this method may fail.
CreateWriter | Creates a resource writer for the specified file. The type of the resource writer to be created is determined by GetDefaultWriter. If the file already exists, it will be overwritten.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetDefaultReader | Returns the preferred resource reader class for this kind of ResourceSet. Subclasses of ResourceSet using their own ResourceReader should override GetDefaultReader and GetDefaultWriter.
GetDefaultWriter | Returns the preferred resource writer class for this kind of ResourceSet. Subclasses of ResourceSet using their own ResourceWriter should override GetDefaultReader and GetDefaultWriter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObject | Looks up an object value for a resource given its name.
GetString | Looks up a String value for a resource given its name.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ReadResources | Reads all the resources and stores them in Table.

See Also

ResourceSet Class | System.Resources Namespace


ResourceSet.Close

Closes and releases any resources used by this ResourceSet, if any. All calls to methods on the ResourceSet after a call to this method may fail.

[Visual Basic]
Overridable Public Sub Close()
[C#]
public virtual void Close();
[C++]
public: virtual void Close();
[JScript]
public function Close();

See Also

ResourceSet Class | ResourceSet Members | System.Resources Namespace


ResourceSet.CreateWriter

Creates a resource writer for the specified file. The type of the resource writer to be created is determined by GetDefaultWriter. If the file already exists, it will be overwritten.

[Visual Basic]
Overridable Public Function CreateWriter( _
   ByVal fileName As String _
) As IResourceWriter
[C#]
public virtual IResourceWriter CreateWriter(
   string fileName
);
[C++]
public: virtual IResourceWriter* CreateWriter(
   String* fileName
);
[JScript]
public function CreateWriter(
   fileName : String
) : IResourceWriter;

Parameters

fileName
A relative or absolute path for the resource file for which a writer is to be created.

Return Value

Returns a resource writer for the specified file.

Exceptions

Exception Type | Condition
ArgumentException | If fileName is either a null reference (in Visual Basic Nothing) or an empty string.
SecurityException | If the caller does not have the appropriate FileIOPermission.

See Also

ResourceSet Class | ResourceSet Members | System.Resources Namespace


ResourceSet.GetDefaultReader

Returns the preferred resource reader class for this kind of ResourceSet. Subclasses of ResourceSet using their own ResourceReader should override GetDefaultReader and GetDefaultWriter.

[Visual Basic]
Overridable Public Function GetDefaultReader() As Type
[C#]
public virtual Type GetDefaultReader();
[C++]
public: virtual Type* GetDefaultReader();
[JScript]
public function GetDefaultReader() : Type;

Return Value

Returns the preferred class for this kind of ResourceSet.

See Also

ResourceSet Class | ResourceSet Members | System.Resources Namespace


ResourceSet.GetDefaultWriter

Returns the preferred resource writer class for this kind of ResourceSet. Subclasses of ResourceSet using their own ResourceWriter should override GetDefaultReader and GetDefaultWriter.

[Visual Basic]
Overridable Public Function GetDefaultWriter() As Type
[C#]
public virtual Type GetDefaultWriter();
[C++]
public: virtual Type* GetDefaultWriter();
[JScript]
public function GetDefaultWriter() : Type;

Return Value

Returns the preferred class for this kind of ResourceSet.

See Also

ResourceSet Class | ResourceSet Members | System.Resources Namespace


ResourceSet.GetObject

Looks up an object value for a resource given its name.

[Visual Basic]
Overridable Public Function GetObject( _
   ByVal name As String _
) As Object
[C#]
public virtual object GetObject(
   string name
);
[C++]
public: virtual Object* GetObject(
   String* name
);
[JScript]
public function GetObject(
   name : String
) : Object;

Parameters

name
Name of the resource to look up.

Return Value

Returns the object value of a resource.

Exceptions

Exception Type | Condition
ArgumentNullException | If name is a null reference (in Visual Basic Nothing).
InvalidOperationException | If this ResourceSet et has been closed.

See Also

ResourceSet Class | ResourceSet Members | System.Resources Namespace


ResourceSet.GetString

Looks up a String value for a resource given its name.

[Visual Basic]
Overridable Public Function GetString( _
   ByVal name As String _
) As String
[C#]
public virtual string GetString(
   string name
);
[C++]
public: virtual String* GetString(
   String* name
);
[JScript]
public function GetString(
   name : String
) : String;

Parameters

name
Name of the resource to look up.

Return Value

The String value of a resource.

Exceptions

Exception Type | Condition
ArgumentNullException | If name is a null reference (in Visual Basic Nothing).
InvalidOperationException | If the value of the resource is not a String or if this ResourceSet has been closed.

See Also

ResourceSet Class | ResourceSet Members | System.Resources Namespace


ResourceSet.ReadResources

Reads all the resources and stores them in Table.

[Visual Basic]
Overridable Protected Sub ReadResources()
[C#]
protected virtual void ReadResources();
[C++]
protected: virtual void ReadResources();
[JScript]
protected function ReadResources();

See Also

ResourceSet Class | ResourceSet Members | System.Resources Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ResourceSet Fields

The fields of the ResourceSet class are listed below. For a complete list of ResourceSet class members, see the ResourceSet Members topic.

Protected:

Reader | The resource reader used to read the resources.
Table | The Hashtable in which the resources are stored.

See Also

ResourceSet Class | System.Resources Namespace


ResourceSet.Reader

The resource reader used to read the resources.

[Visual Basic]
Protected Reader As IResourceReader
[C#]
protected IResourceReader Reader;
[C++]
protected: IResourceReader* Reader;
[JScript]
protected var Reader : IResourceReader;

See Also

ResourceSet Class | ResourceSet Members | System.Resources Namespace


ResourceSet.Table

The Hashtable in which the resources are stored.

[Visual Basic]
Protected Table As Hashtable
[C#]
protected Hashtable Table;
[C++]
protected: Hashtable* Table;
[JScript]
protected var Table : Hashtable;

See Also

ResourceSet Class | ResourceSet Members | System.Resources Namespace


ResourceWriter Class

Generates a binary ".resources" file in the system-default format from name and value pairs. Create one with a unique file name, call AddResource at least once, then call Write to write the ".resources" file to disk.

Object
ResourceWriter

[Visual Basic]
Public Class ResourceWriter
   Implements IResourceWriter
[C#]
public class ResourceWriter : IResourceWriter
[C++]
public __gc class ResourceWriter : public IResourceWriter
[JScript]
public class ResourceWriter implements IResourceWriter

Remarks

The ResourceWriter class is used to write resources in a binary system default format to an output file or an output stream. Resources are specified as name and value pairs using the AddResource method. Resources are written using the Write method.

The resources are not guaranteed to be written in the same order they were added.

Requirements

Namespace: System.Resources

Assembly: mscorlib.dll

See Also

ResourceWriter Members | System.Resources Namespace


ResourceWriter Members

Public:

Constructor

ResourceWriter Constructor Overloaded. Initializes a new instance of the ResourceWriter class.

Methods

AddResource | Overloaded. Adds a resource to the list of resources to be added to an output file or output stream. The resource is not written until Write is called. The resource added must be serializable.
Close | Closes the output stream.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Writes all resources to the output stream in the system default format. If an exception occurs while writing the resources, the output stream is closed since the information written is most likely invalid.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
WriteValue | Writes the value of an object to the specified stream. In general, serializes the object using the specified object formatter. However, for certain types, writes a more compact form of the object. For instance, writes a compact form of Int32 value. The method recognizes most of the primitive types and certain value classes.

Fields

Output | This field holds a reference to the output stream to which the resources are to be written.
ResourceList | This field holds a reference to the Hashtable hash table to which the resources are added using the AddResource method. The value of each resource is stored in the hash table keyed by the name of the resource.

See Also

ResourceWriter Class | System.Resources Namespace


ResourceWriter Constructor

Initializes a new instance of the ResourceWriter class.

Overload List

Initializes a new instance of the ResourceWriter class that writes the resources to the file named "default.resources".

[Visual Basic] Overloads Public Sub New()
[C#] public ResourceWriter();
[C++] public: ResourceWriter();
[JScript] public function ResourceWriter();

Initializes a new instance of the ResourceWriter class that writes the resources to the file named fileName.

[Visual Basic] Overloads Public Sub New(String)
[C#] public ResourceWriter(String);
[C++] public: ResourceWriter(String*);
[JScript] public function ResourceWriter(String);

Initializes a new instance of the ResourceWriter class that writes the resources to the stream named stream.

[Visual Basic] Overloads Public Sub New(Stream)
[C#] public ResourceWriter(Stream);
[C++] public: ResourceWriter(Stream*);
[JScript] public function ResourceWriter(Stream);

See Also

ResourceWriter Class | ResourceWriter Members | System.Resources Namespace


ResourceWriter Constructor ()

Initializes a new instance of the ResourceWriter class that writes the resources to the file named "default.resources".

[Visual Basic]
Overloads Public Sub New()
[C#]
public ResourceWriter();
[C++]
public: ResourceWriter();
[JScript]
public function ResourceWriter();

See Also

ResourceWriter Class | ResourceWriter Members | System.Resources Namespace | ResourceWriter Constructor Overload List


ResourceWriter Constructor (String)

Initializes a new instance of the ResourceWriter class that writes the resources to the file named fileName.

[Visual Basic]
Overloads Public Sub New( _
   ByVal fileName As String _
)
[C#]
public ResourceWriter(
   string fileName
);
[C++]
public: ResourceWriter(
   String* fileName
);
[JScript]
public function ResourceWriter(
   fileName : String
);

Parameters

fileName
The output file name of the ResourceWriter.

Exceptions

Exception Type | Condition
FileNotFoundException | if the file cannot be found
IOException | if an I/O error occurs

See Also

ResourceWriter Class | ResourceWriter Members | System.Resources Namespace | ResourceWriter Constructor Overload List


ResourceWriter Constructor (Stream)

Initializes a new instance of the ResourceWriter class that writes the resources to the stream named stream.

[Visual Basic]
Overloads Public Sub New( _
   ByVal stream As Stream _
)
[C#]
public ResourceWriter(
   Stream stream
);
[C++]
public: ResourceWriter(
   Stream* stream
);
[JScript]
public function ResourceWriter(
   stream : Stream
);

Parameters

stream
The output stream of the ResourceWriter.

Exceptions

Exception Type | Condition
ArgumentException | if stream is not writeable
ArgumentNullException | if stream is a null reference (in Visual Basic Nothing)

See Also

ResourceWriter Class | ResourceWriter Members | System.Resources Namespace | ResourceWriter Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ResourceWriter Methods

The methods of the ResourceWriter class are listed below. For a complete list of ResourceWriter class members, see the ResourceWriter Members topic.

Public:

AddResource | Overloaded. Adds a resource to the list of resources to be added to an output file or output stream. The resource is not written until Write is called. The resource added must be serializable.
Close | Closes the output stream.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Writes all resources to the output stream in the system default format. If an exception occurs while writing the resources, the output stream is closed since the information written is most likely invalid.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
WriteValue | Writes the value of an object to the specified stream. In general, serializes the object using the specified object formatter. However, for certain types, writes a more compact form of the object. For instance, writes a compact form of Int32 value. The method recognizes most of the primitive types and certain value classes.

See Also

ResourceWriter Class | System.Resources Namespace


ResourceWriter.AddResource

Adds a resource to the list of resources to be added to an output file or output stream. The resource is not written until Write is called. The resource added must be serializable.

Overload List

Adds a named resource specified as an object to the list of resources to be written. The resource is not written until Write is called.

[Visual Basic] Overloads Overridable Public Sub AddResource(String, Object)
[C#] public virtual void AddResource(String, Object);
[C++] public: virtual void AddResource(String*, Object);
[JScript] public function AddResource(String, Object);

Adds a named resource specified as a String to the list of resources to be written to a file. The resource is not written until Write is called.

[Visual Basic] Overloads Overridable Public Sub AddResource(String, String)
[C#] public virtual void AddResource(String, String);
[C++] public: virtual void AddResource(String*, String*);
[JScript] public function AddResource(String, String);

Adds a named resource specified as a byte array to the list of resources to be written. The resource is not written until Write is called.

[Visual Basic] Overloads Overridable Public Sub AddResource(String, Byte())
[C#] public virtual void AddResource(String, byte[]);
[C++] public: virtual void AddResource(String*, unsigned char[]);
[JScript] public function AddResource(String, Byte[]);

See Also

ResourceWriter Class | ResourceWriter Members | System.Resources Namespace


ResourceWriter.AddResource (String, Object)

Adds a named resource specified as an object to the list of resources to be written. The resource is not written until Write is called.

[Visual Basic]
Overloads Overridable Public Sub AddResource( _
   ByVal name As String, _
   ByVal value As Object _
)
[C#]
public virtual void AddResource(
   string name,
   object value
);
[C++]
public: virtual void AddResource(
   String* name,
   Object* value
);
[JScript]
public function AddResource(
   name : String,
   value : Object
);

Parameters

name
The name of the resource.
value
The value of the resource.

Exceptions

Exception Type | Condition
ArgumentNullException | if name or value is a null reference (in Visual Basic Nothing)

See Also

ResourceWriter Class | ResourceWriter Members | System.Resources Namespace | ResourceWriter.AddResource Overload List


ResourceWriter.AddResource (String, String)

Adds a named resource specified as a String to the list of resources to be written to a file. The resource is not written until Write is called.

[Visual Basic]
Overloads Overridable Public Sub AddResource( _
   ByVal name As String, _
   ByVal value As String _
)
[C#]
public virtual void AddResource(
   string name,
   string value
);
[C++]
public: virtual void AddResource(
   String* name,
   String* value
);
[JScript]
public function AddResource(
   name : String,
   value : String
);

Parameters

name
The name of a resource.
value
The value of the resource.

Exceptions

Exception Type | Condition
ArgumentException | if name or value is a null reference (in Visual Basic Nothing)

See Also

ResourceWriter Class | ResourceWriter Members | System.Resources Namespace | ResourceWriter.AddResource Overload List


ResourceWriter.AddResource (String, Byte[])

Adds a named resource specified as a byte array to the list of resources to be written. The resource is not written until Write is called.

[Visual Basic]
Overloads Overridable Public Sub AddResource( _
   ByVal name As String, _
   ByVal value() As Byte _
)
[C#]
public virtual void AddResource(
   string name,
   byte[] value
);
[C++]
public: virtual void AddResource(
   String* name,
   unsigned char* value[]
);
[JScript]
public function AddResource(
   name : String,
   value : Byte[]
);

Parameters

name
The name of a resource.
value
The value of the resource.

Exceptions

Exception Type | Condition
ArgumentException | if name or value is a null reference (in Visual Basic Nothing)

See Also

ResourceWriter Class | ResourceWriter Members | System.Resources Namespace | ResourceWriter.AddResource Overload List


ResourceWriter.Close

Closes the output stream.

[Visual Basic]
Overridable Public Sub Close()
[C#]
public virtual void Close();
[C++]
public: virtual void Close();
[JScript]
public function Close();

Exceptions

Exception Type | Condition
IOException | if an I/O error occurred
SerializationException | if an error occurred during object serialization

See Also

ResourceWriter Class | ResourceWriter Members | System.Resources Namespace


ResourceWriter.Write

Writes all resources to the output stream in the system default format. If an exception occurs while writing the resources, the output stream is closed since the information written is most likely invalid.

[Visual Basic]
Overridable Public Sub Write()
[C#]
public virtual void Write();
[C++]
public: virtual void Write();
[JScript]
public function Write();

Exceptions

Exception Type | Condition
IOException | if an I/O error occurred
SerializationException | if an error occurred during object serialization

See Also

ResourceWriter Class | ResourceWriter Members | System.Resources Namespace


ResourceWriter.WriteValue

Writes the value of an object to the specified stream. In general, serializes the object using the specified object formatter. However, for certain types, writes a more compact form of the object. For instance, writes a compact form of Int32 value. The method recognizes most of the primitive types and certain value classes.

[Visual Basic]
Overridable Protected Sub WriteValue( _
   ByVal type As Type, _
   ByVal value As Object, _
   ByVal writer As BinaryWriter, _
   ByVal objFormatter As IFormatter _
)
[C#]
protected virtual void WriteValue(
   Type type,
   object value,
   BinaryWriter writer,
   IFormatter objFormatter
);
[C++]
protected: virtual void WriteValue(
   Type* type,
   Object* value,
   BinaryWriter* writer,
   IFormatter* objFormatter
);
[JScript]
protected function WriteValue(
   type : Type,
   value : Object,
   writer : BinaryWriter,
   objFormatter : IFormatter
);

Parameters

type
The Type of the Object to be written to the specified stream.
value
The Object to be written.
writer
TBD.
objFormatter
A IFormatter object.

See Also

ResourceWriter Class | ResourceWriter Members | System.Resources Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ResourceWriter Fields

The fields of the ResourceWriter class are listed below. For a complete list of ResourceWriter class members, see the ResourceWriter Members topic.

Protected:

Output | This field holds a reference to the output stream to which the resources are to be written.
ResourceList | This field holds a reference to the Hashtable hash table to which the resources are added using the AddResource method. The value of each resource is stored in the hash table keyed by the name of the resource.

See Also

ResourceWriter Class | System.Resources Namespace


ResourceWriter.Output

This field holds a reference to the output stream to which the resources are to be written.

[Visual Basic]
Protected Output As Stream
[C#]
protected Stream Output;
[C++]
protected: Stream* Output;
[JScript]
protected var Output : Stream;

See Also

ResourceWriter Class | ResourceWriter Members | System.Resources Namespace


ResourceWriter.ResourceList

This field holds a reference to the Hashtable hash table to which the resources are added using the AddResource method. The value of each resource is stored in the hash table keyed by the name of the resource.

[Visual Basic]
Protected ResourceList As Hashtable
[C#]
protected Hashtable ResourceList;
[C++]
protected: Hashtable* ResourceList;
[JScript]
protected var ResourceList : Hashtable;

See Also

ResourceWriter Class | ResourceWriter Members | System.Resources Namespace


System.Runtime.InteropServices

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Runtime.InteropServices Namespace

Classes

Class | Description
CallConvCdecl | [To be supplied.]
CallConvFastcall | [To be supplied.]
CallConvStdcall | [To be supplied.]
CallConvThiscall | [To be supplied.]
ComAliasNameAttribute | Applied to a parameter or field to indicate the COM alias for the parameter or field type.
ComConversionLossAttribute | [To be supplied.]
ComEmulateAttribute Use this attribute on a class to indicate that the class is an emulator class for another NGWS class. The emulator class acts as a proxy for managed types that supportnstances of the emulator class are activated via COM's CoCreateInstance API. This include instances created from managed clients which always interact with the emulator class through COM Interop.

Refer to
COMEmulateException | [To be supplied.]
COMException | Represents the exception that is thrown when there is a COM Interop error.
ComImportAttribute | A Pseudo attribute used to indicate that a class or interface definition was imported from a COM type library. The runtime uses this flag to know how to activate and marshal the type.
ComRegisterFunctionAttribute Use this attribute on a method to indicate that the method should be called when the assembly is registered for use from COM. This allows user written code to be executed during the registraton process. Methods with this attrubte must be static and must take a single string parameter for the name of the registry key being updated. If and when the assembly containing the method is registered with the RegAsm tool, this method is called by the runtime. If the assembly containing the method is not registered. the method is not called. If the types within the assembly were not intented to be used from com, the assembly will typically not be registered. The registry key being updated such as "HKEY_CLASSES_ROOT\CLSID\<clsid>" is passed to the method. Each assembly can have only one registration function, at most.

If a registration method is provided, users shoudl be sure to "undo" when the registration did in the unregistration function.
ComSourceInterfacesAttribute | Identifies the list of interfaces that are sources of events for the class. The string value consists of a a null reference (in Visual Basic Nothing) delimited list of interface names. See the com interop spec for additional details
ComUnregisterFunctionAttribute Use this attribute on a method to indicate that the method should be called when the assembly is unregistered for use from COM. This allows user written code to be executed during the unregistraton process. Methods with this attrubte must be static and must take a single string parameter for the name of the registry key being updated. If and when the assembly containing the method is unregistered with the RegAsm tool, this method is called by the runtime. If the assembly containing the method is not unregistered. the method is not called. If the types within the assembly were not intented to be used from com, the assembly will typically not be registered. The registry key being updated such as "HKEY_CLASSES_ROOT\CLSID\<clsid>" is passed to the method. Each assembly can have only one unregistration function, at most.

If a unregistration method is provided, it should be sure to "undo" when the registration function did.
ComVisibleAttribute | This attribute can be applied to an individual type or to an entire assembly to control COM visibility. To make types visible to COM set the attribute to true. To hide types from COM, set the attribute to false. By default, all managed types that are public are visible (the attribute is not needed to make them visible). Setting the attribute to false on the assembly hides all public types within the assembly. Setting the attribute to false on a specific type hides that specific type. Settings applied to an individual type override any assembly settings. Therefore, setting the attribute to false on the assembly and true on an individual type will cause only that type to be visible from the assembly. Only types that are public can be made visible. The attribute cannot be used to make a private or protected type visible to COM.
DispIdAttribute Custom attribute to specify the COM DISPID of a Method or Field.

This attribute contains the dispid for the method, field or property it describes. Unique Dispids are typically assigned by the runtime but this attribute can be used to force a specific method to have a specific dispid.

When methods with this attribute are exposed through IDispatch, they are exposed with the dispid specified in the attribute. When importing a typelib, this attribute is applied to all methods with assigned dispids. This ensures that the any managed implementation of the same method would retain the same dispid if exposed to com.
DllImportAttribute | Used to indicate that a method in P/Invoke method implemented in unmanaged code. The attribute provides the name of the file (DllName) and the name of the method within that file (EntryPoint) where the implementation can be found.
ExposeHResultAttribute | Deprecated. USe PreserveSigAttribute instead.
ExtensibleClassFactory | Provides methods used to customize the creation of managed objects that extend from unmanaged objects.
ExternalException | Represents COM Interop errors and SEH exceptions.
FieldOffsetAttribute | Used along with the System.Runtime.InteropServices.StructLayoutAttribute.LayoutKind set to Explicit to indicate he physical position of each field within a class.
GlobalObjectAttribute | Deprecated. Do not use
GuidAttribute | Used to supply the GUID of a class, interface or an entire type library. The string passed to the attribute must be a format that is an acceptable constructor argument for the type Guid. To avoid conflicts with the type Guid the long name "GuidAttribute" should be used explicitly.
HasDefaultInterfaceAttribute Custom attribute to specify that a class has a COM default interface.

This custom attribute indicates that the class has an explicit default interface. If the custom attribute is present, the first Interface implementation supplied when the type was defined is assumed to be the default interface for the class. If a custom value is missing, the default interface is assumed to be the class interface for the class. See the Interop Spec for important details.
IDispatchImplAttribute
ImportedFromTypeLibAttribute Custom attribute to specify that a module is imported from a COM type library.

This attribute indicates that the module was originally imported from a COM type library. The primary use of the attribute is to ensure that the module is not subsequently re-exported to COM thereby causing duplicate type definitions. This should not be confused with the ComImportAttribute, which is used on a type to indicate that the individual type is implemented in COM.
InAttribute | Used on a parameter or field to indicate that data should be marshaled in to the caller.
InterfaceTypeAttribute Controls how a managed interface is exposed to COM clients (IDispatch derived or IUnknown derived).

This attribute indicates whether a managed interface is Dual, IDispatch or IUnknown based when exposed to COM. If the attrigute is missing the interface is exposed to COM as a Dual interface.
InvalidComObjectException | Represents the exception that is thrown when an invalid COM object is used.
InvalidOleVariantTypeException | [To be supplied.]
Marshal | PInvoke (Platform Invocation Services) lets you execute existing, unmanaged code, that lives in a regular DLL, from managed code.
MarshalAsAttribute | This attribute is used on fields or parameters to indicate how the data should be marshaled between managed and unmanaged code. The attribute is always optional as each data type has default marshaling behavior. The attribute is only necessary when a given type can be marshaled to a number of other possible types. For example, a String could be marshaled to unmanaged code as either a LPSTR, LPWSTR, LPTSTR or as a BSTR. By default the string would be marshaled as a BSTR. The MarshalAsAttribute can be applied to an individual field or parameter to cause that particular string to be marshaled as a LPSTR instead of a BSTR. For complete details on using this attribute see the data type marshaling spec.
MethodImplAttribute | [To be supplied.]
NoComRegistrationAttribute | Use this attribute to indicate that an otherwise public, COM-creatable type shuld not be registered for use form com applications.
NoIDispatchAttribute | This attribute is used to control how the class responds to queries for an IDispatch Interface. If the attribute is present, all calls to QueryInterface that request IID_IDispatch will return E_NOINTERFACE. If the attribute is missing, the class will respond to queries for IID_IDispatch by returning either the class interface or the interface that is explicitly marked as the class's default interface. For details on selecting the default interface see the HasDefaultInterfaceAttribute.
OutAttribute | Used on a parameter or field to indicate that data should be marshaled out from callee back to caller.
PredeclaredAttribute | Deprecated. Do not use
PreserveSigAttribute | Used to indicate that HResult/retval signature transformation that normally takes place during Interop calls should be suppressed. The attribute affects marshaling as well as type library importing and exporting.
ProgIdAttribute | Custom attribute that allows the user to specify the prog ID of a NGWS class.
RegistrationServices | [To be supplied.]
Root | This class allows you to create an opaque, 32-bit root handle to any managed object. A root handle prevents that 'rooted' managed object from being reclaimed by garbage collection, so that a reference to the managed object can be safely stored in native data structures.
SafeArrayTypeMismatchException | [To be supplied.]
SEHException | Represents Structured Exception Handler (SEH) errors.
StructLayoutAttribute | Typically the runtime controls the physical layout of the data members of class. The StructLayoutAttribute allows the user to control the physical layout of the data members of a class. Explicit control of a classes layout is important if the class is to be passed to unmanaged code that expects a specific layout. The LayoutKind value Sequential is used to force the members to be laid out sequentially in the order they appear. Explicit is used to control the precise position of each data member. With Explicit each member must use the FieldOffsetAttribute to indicate the position of that field within the type.
TypeAttr | [To be supplied.]
TypeLibAttr | [To be supplied.]
TypeLibConverter | [To be supplied.]
TypeLibFuncAttribute | Contains the FUNCFLAGS that were originally imported for this function from the COM type library.
TypeLibTypeAttribute | Contains the TYPEFLAGS that were originally imported for this type from the COM type library.
TypeLibVarAttribute | Contains the VARFLAGS that were originally imported for this variable from the COM type library.
VTableCallsNotSupportedException | [To be supplied.]

Interfaces

Interface | Description
ICustomMarshaler | [To be supplied.]
ITypeLibConverter | [To be supplied.]
ITypeLibExporterNotifySink | [To be supplied.]
ITypeLibImporterNotifySink | [To be supplied.]
UCOMIConnectionPoint | Used by the custom connection point marshaler that the NGWS runtime provides.
UCOMIConnectionPointContainer | UCOMIConnectionPointContainer interface definition.
UCOMIEnumVARIANT | [To be supplied.]
UCOMITypeInfo | [To be supplied.]
UCOMITypeLib | [To be supplied.]

Structures

Structure | Description
ArrayWithOffset | Encapsulates a combination of an array and an offset within that array. When used as an argument to a native method, reached via Platform Invoke, the PInvoke marshaler will fetch the base address of the array, add the offset, and pass the resulting pointer to the underlying native function.
GCHandle | This class allows you to create an opaque, GC handle to any NGWS object. A GC handle is used when an object reference must be reachable from unmanaged memory. See GCHandleType for more information about the different types of GCHandles used by the Runtime Execution Engine.
IDLDesc | [To be supplied.]
TypeDesc | [To be supplied.]

Delegates

Delegate | Description
ObjectCreationDelegate | Creates a COM object.

Enumerations

Enumeration | Description
CallingConvention | [To be supplied.]
CharSet | [To be supplied.]
ComInterfaceType | This enumeration is used with the InterfaceTypeAttribute to identify how an interface should be exposed to COM.
ExporterEventKind | [To be supplied.]
GCHandleType | This enum represents the the 4 different types of GCHandlesthat can be allocated by the GCHandle class. The type of handles are Normal, Weak, WeakTrackResurrection and Pinned
IDispatchImplType | [To be supplied.]
ImporterEventKind | [To be supplied.]
LayoutKind | [To be supplied.]
LIBFLAGS | [To be supplied.]
MethodImplOptions | [To be supplied.]
PInvokeMap | Defines the PInvoke attributes. These values are defined in CorHdr.h.
SYSKIND | [To be supplied.]
TYPEFLAGS | [To be supplied.]
TYPEKIND | [To be supplied.]
TypeLibFuncFlags | Describes the original settings of the FUNCFLAGS in the COM type library from where this method was imported.
TypeLibTypeFlags | Describes the original settings of the TYPEFLAGS in the COM type library from which the type was imported.
TypeLibVarFlags | Describes the original settings of the VARFLAGS in the COM type library from which the variable was imported.
UnmanagedType | Identifies how parameters or fields should be marshaled to unmanaged code.
VarEnum | [To be supplied.]


ArrayWithOffset Structure

Encapsulates a combination of an array and an offset within that array. When used as an argument to a native method, reached via Platform Invoke, the PInvoke marshaler will fetch the base address of the array, add the offset, and pass the resulting pointer to the underlying native function.

Object
ValueType
ArrayWithOffset

[Visual Basic]
Public Structure ArrayWithOffset
[C#]
public struct ArrayWithOffset
[C++]
public __value struct ArrayWithOffset

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

Only supports arrays that contain no references, i.e. arrays of primitive types and arrays of value types that only contain fields of primitive types.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

ArrayWithOffset Members | System.Runtime.InteropServices Namespace


ArrayWithOffset Members

Public:

Constructor

ArrayWithOffset Constructor Initializes a new instance of the ArrayWithOffset structure.

Methods

Equals | Returns true if the specified object matches the current ArrayWithOffset.
GetArray | Returns the managed array that is referenced by this ArrayWithOffset
GetHashCode | Returns a hash code for this value type.
GetOffset | Returns the offset originally provided when this ArrayWithOffset was constructed.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArrayWithOffset Structure | System.Runtime.InteropServices Namespace


ArrayWithOffset Constructor

Initializes a new instance of the ArrayWithOffset structure.

[Visual Basic]
Public Sub New( _
   ByVal array As Object, _
   ByVal offset As Integer _
)
[C#]
public ArrayWithOffset(
   object array,
   int offset
);
[C++]
public: ArrayWithOffset(
   Object* array,
   int offset
);
[JScript]
public function ArrayWithOffset(
   array : Object,
   offset : int
);

Parameters

array
A managed array.
offset
The offset, in bytes, of the element to be passed through PInvoke.

See Also

ArrayWithOffset Structure | ArrayWithOffset Members | System.Runtime.InteropServices Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ArrayWithOffset Methods

The methods of the ArrayWithOffset structure are listed below. For a complete list of ArrayWithOffset structure members, see the ArrayWithOffset Members topic.

Public:

Equals | Returns true if the specified object matches the current ArrayWithOffset.
GetArray | Returns the managed array that is referenced by this ArrayWithOffset
GetHashCode | Returns a hash code for this value type.
GetOffset | Returns the offset originally provided when this ArrayWithOffset was constructed.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArrayWithOffset Structure | System.Runtime.InteropServices Namespace


ArrayWithOffset.Equals

Returns true if the specified object matches the current ArrayWithOffset.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: override bool Equals(
   Object* obj
);
[JScript]
public override function Equals(
   obj : Object
) : Boolean;

Parameters

obj
Object to be compared with this instance.

Return Value

True if the object matches this ArrayWithOffset; otherwise, false.

See Also

ArrayWithOffset Structure | ArrayWithOffset Members | System.Runtime.InteropServices Namespace


ArrayWithOffset.GetArray

Returns the managed array that is referenced by this ArrayWithOffset

[Visual Basic]
Public Function GetArray() As Object
[C#]
public object GetArray();
[C++]
public: Object* GetArray();
[JScript]
public function GetArray() : Object;

Return Value

The managed array referenced by this instance.

See Also

ArrayWithOffset Structure | ArrayWithOffset Members | System.Runtime.InteropServices Namespace


ArrayWithOffset.GetHashCode

Returns a hash code for this value type.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: override int GetHashCode();
[JScript]
public override function GetHashCode() : int;

Return Value

The hash code for this instance.

See Also

ArrayWithOffset Structure | ArrayWithOffset Members | System.Runtime.InteropServices Namespace


ArrayWithOffset.GetOffset

Returns the offset originally provided when this ArrayWithOffset was constructed.

[Visual Basic]
Public Function GetOffset() As Integer
[C#]
public int GetOffset();
[C++]
public: int GetOffset();
[JScript]
public function GetOffset() : int;

Return Value

The offset for this instance.

See Also

ArrayWithOffset Structure | ArrayWithOffset Members | System.Runtime.InteropServices Namespace


CallConvCdecl Class

[To be supplied.]

Object
CallConvCdecl

[Visual Basic]
Public Class CallConvCdecl
[C#]
public class CallConvCdecl
[C++]
public __gc class CallConvCdecl
[JScript]
public class CallConvCdecl

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

CallConvCdecl Members | System.Runtime.InteropServices Namespace


CallConvCdecl Members

Public:

Constructor

CallConvCdecl Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CallConvCdecl Class | System.Runtime.InteropServices Namespace


CallConvCdecl Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CallConvCdecl();
[C++]
public: CallConvCdecl();
[JScript]
public function CallConvCdecl();

See Also

CallConvCdecl Class | CallConvCdecl Members | System.Runtime.InteropServices Namespace


CallConvFastcall Class

[To be supplied.]

Object
CallConvFastcall

[Visual Basic]
Public Class CallConvFastcall
[C#]
public class CallConvFastcall
[C++]
public __gc class CallConvFastcall
[JScript]
public class CallConvFastcall

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

CallConvFastcall Members | System.Runtime.InteropServices Namespace


CallConvFastcall Members

Public:

Constructor

CallConvFastcall Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CallConvFastcall Class | System.Runtime.InteropServices Namespace


CallConvFastcall Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CallConvFastcall();
[C++]
public: CallConvFastcall();
[JScript]
public function CallConvFastcall();

See Also

CallConvFastcall Class | CallConvFastcall Members | System.Runtime.InteropServices Namespace


CallConvStdcall Class

[To be supplied.]

Object
CallConvStdcall

[Visual Basic]
Public Class CallConvStdcall
[C#]
public class CallConvStdcall
[C++]
public __gc class CallConvStdcall
[JScript]
public class CallConvStdcall

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

CallConvStdcall Members | System.Runtime.InteropServices Namespace


CallConvStdcall Members

Public:

Constructor

CallConvStdcall Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CallConvStdcall Class | System.Runtime.InteropServices Namespace


CallConvStdcall Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CallConvStdcall();
[C++]
public: CallConvStdcall();
[JScript]
public function CallConvStdcall();

See Also

CallConvStdcall Class | CallConvStdcall Members | System.Runtime.InteropServices Namespace


CallConvThiscall Class

[To be supplied.]

Object
CallConvThiscall

[Visual Basic]
Public Class CallConvThiscall
[C#]
public class CallConvThiscall
[C++]
public __gc class CallConvThiscall
[JScript]
public class CallConvThiscall

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

CallConvThiscall Members | System.Runtime.InteropServices Namespace


CallConvThiscall Members

Public:

Constructor

CallConvThiscall Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CallConvThiscall Class | System.Runtime.InteropServices Namespace


CallConvThiscall Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public CallConvThiscall();
[C++]
public: CallConvThiscall();
[JScript]
public function CallConvThiscall();

See Also

CallConvThiscall Class | CallConvThiscall Members | System.Runtime.InteropServices Namespace


CallingConvention Enumeration

[To be supplied.]

[Visual Basic]
Public Enum CallingConvention
[C#]
public enum CallingConvention
[C++]
public enum CallingConvention

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Cdecl | [To be supplied.]
FastCall | [To be supplied.]
StdCall | [To be supplied.]
ThisCall | [To be supplied.]
Winapi | [To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

System.Runtime.InteropServices Namespace


CharSet Enumeration

[To be supplied.]

[Visual Basic]
Public Enum CharSet
[C#]
public enum CharSet
[C++]
public enum CharSet

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Ansi | Strings should be marshaled as ANSI 1-byte chars.
Auto | Marshal string in the right way for the target system.
None | User didn't specify how to marshal strings.
Unicode | Strings should be marshaled as Unicode 2-byte chars.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

System.Runtime.InteropServices Namespace


ComAliasNameAttribute Class

Applied to a parameter or field to indicate the COM alias for the parameter or field type.

Object
Attribute
ComAliasNameAttribute

[Visual Basic]
Public Class ComAliasNameAttribute
   Inherits Attribute
[C#]
public class ComAliasNameAttribute : Attribute
[C++]
public __gc class ComAliasNameAttribute : public Attribute
[JScript]
public class ComAliasNameAttribute extends Attribute

Remarks

Can be used to attribute parameters, fields or return values.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

Example [C#]

In the following type library OLE_COLOR is an alias for int. During import the arguments of the Color accessor are marked with the ComAliasNameAttribute to indicate that type library refers to them as OLE_COLOR.

[C#]

typedef int OLE_COLOR;

interface Bar {
    HResult SetColor([in] OLE_COLOR cl);
    HResult GetColor([out, retval] OLE_COLOR *cl);
}

imported as:

[C#]

interface Bar {
    void SetColor([ComAliasName("stdole.OLE_COLOR")]] int cl);
    [ComAliasName("stdole.OLE_COLOR")] in GetColor();
}

See Also

ComAliasNameAttribute Members | System.Runtime.InteropServices Namespace


ComAliasNameAttribute Members

Public:

Constructor

ComAliasNameAttribute Constructor Initializes a new instance of the ComAliasNameAttribute class.

Properties

Value [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ComAliasNameAttribute Class | System.Runtime.InteropServices Namespace


ComAliasNameAttribute Constructor

Initializes a new instance of the ComAliasNameAttribute class.

[Visual Basic]
Public Sub New( _
   ByVal val As String _
)
[C#]
public ComAliasNameAttribute(
   string val
);
[C++]
public: ComAliasNameAttribute(
   String* val
);
[JScript]
public function ComAliasNameAttribute(
   val : String
);

Parameters

val
[To be supplied.]

See Also

ComAliasNameAttribute Class | ComAliasNameAttribute Members | System.Runtime.InteropServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ComAliasNameAttribute Properties

The properties of the ComAliasNameAttribute class are listed below. For a complete list of ComAliasNameAttribute class members, see the ComAliasNameAttribute Members topic.

Public:

Value [To be supplied.]

See Also

ComAliasNameAttribute Class | System.Runtime.InteropServices Namespace


ComAliasNameAttribute.Value

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Value As String
[C#]
public string Value {virtual get;}
[C++]
public: __property virtual String* get_Value();
[JScript]
public function get Value() : String;

See Also

ComAliasNameAttribute Class | ComAliasNameAttribute Members | System.Runtime.InteropServices Namespace


ComConversionLossAttribute Class

[To be supplied.]

Object
Attribute
ComConversionLossAttribute

[Visual Basic]
Public Class ComConversionLossAttribute
   Inherits Attribute
[C#]
public class ComConversionLossAttribute : Attribute
[C++]
public __gc class ComConversionLossAttribute : public Attribute
[JScript]
public class ComConversionLossAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

ComConversionLossAttribute Members | System.Runtime.InteropServices Namespace


ComConversionLossAttribute Members

Public:

Constructor

ComConversionLossAttribute Constructor Initializes a new instance of the ComConversionLossAttribute class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ComConversionLossAttribute Class | System.Runtime.InteropServices Namespace


ComConversionLossAttribute Constructor

Initializes a new instance of the ComConversionLossAttribute class.

[Visual Basic]
Public Sub New()
[C#]
public ComConversionLossAttribute();
[C++]
public: ComConversionLossAttribute();
[JScript]
public function ComConversionLossAttribute();

See Also

ComConversionLossAttribute Class | ComConversionLossAttribute Members | System.Runtime.InteropServices Namespace


ComEmulateAttribute Class

Use this attribute on a class to indicate that the class is an emulator class for another NGWS class. The emulator class acts as a proxy for managed types that supportnstances of the emulator class are activated via COM's CoCreateInstance API. This include instances created from managed clients which always interact with the emulator class through COM Interop.

Refer to

Object
Attribute
ComEmulateAttribute

[Visual Basic]
Public Class ComEmulateAttribute
   Inherits Attribute
[C#]
public class ComEmulateAttribute : Attribute
[C++]
public __gc class ComEmulateAttribute : public Attribute
[JScript]
public class ComEmulateAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

Example [C#]

[C#]

[guid("557B96C4-F7E6-4d48-BBC3-10981E0CA664")]
[ComEmulate("Component.Account")]
[Transaction(Required)]
public class EmulAccount { }

[guid("871D8D5C-ECC6-40a5-BD82-D5E3B1740095")]
internal class Account : IAccount
{
    public void Debit(int amount)
    {
      //... do some Db work
      if (ok)
          ContextUtil.SetComplete();
      else
          ContextUtil.SetAbort();
     }
}

See Also

ComEmulateAttribute Members | System.Runtime.InteropServices Namespace


ComEmulateAttribute Members

Public:

Constructor

ComEmulateAttribute Constructor Initializes a new instance of the ComEmulateAttribute class.

Properties

Value The fully qualified name of the class that the emulator is emulating.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ComEmulateAttribute Class | System.Runtime.InteropServices Namespace


ComEmulateAttribute Constructor

Initializes a new instance of the ComEmulateAttribute class.

[Visual Basic]
Public Sub New( _
   ByVal val As String _
)
[C#]
public ComEmulateAttribute(
   string val
);
[C++]
public: ComEmulateAttribute(
   String* val
);
[JScript]
public function ComEmulateAttribute(
   val : String
);

Parameters

val
The fully qualified name of the class that the emulator is emulating. The name must include the assembly if the class is in a different assembly.

See Also

ComEmulateAttribute Class | ComEmulateAttribute Members | System.Runtime.InteropServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ComEmulateAttribute Properties

The properties of the ComEmulateAttribute class are listed below. For a complete list of ComEmulateAttribute class members, see the ComEmulateAttribute Members topic.

Public:

Value The fully qualified name of the class that the emulator is emulating.

See Also

ComEmulateAttribute Class | System.Runtime.InteropServices Namespace


ComEmulateAttribute.Value

The fully qualified name of the class that the emulator is emulating.

[Visual Basic]
Overridable Public ReadOnly Property Value As String
[C#]
public string Value {virtual get;}
[C++]
public: __property virtual String* get_Value();
[JScript]
public function get Value() : String;

See Also

ComEmulateAttribute Class | ComEmulateAttribute Members | System.Runtime.InteropServices Namespace


COMEmulateException Class

[To be supplied.]

Object
Exception
SystemException
COMEmulateException

[Visual Basic]
Public Class COMEmulateException
   Inherits SystemException
[C#]
public class COMEmulateException : SystemException
[C++]
public __gc class COMEmulateException : public SystemException
[JScript]
public class COMEmulateException extends SystemException

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

COMEmulateException Members | System.Runtime.InteropServices Namespace


COMEmulateException Members

Public:

Constructor

COMEmulateException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

COMEmulateException Class | System.Runtime.InteropServices Namespace


COMEmulateException Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public COMEmulateException();
[C++] public: COMEmulateException();
[JScript] public function COMEmulateException();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public COMEmulateException(String);
[C++] public: COMEmulateException(String*);
[JScript] public function COMEmulateException(String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public COMEmulateException(String, Exception);
[C++] public: COMEmulateException(String*, Exception);
[JScript] public function COMEmulateException(String, Exception);

See Also

COMEmulateException Class | COMEmulateException Members | System.Runtime.InteropServices Namespace


COMEmulateException Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public COMEmulateException();
[C++]
public: COMEmulateException();
[JScript]
public function COMEmulateException();

See Also

COMEmulateException Class | COMEmulateException Members | System.Runtime.InteropServices Namespace | COMEmulateException Constructor Overload List


COMEmulateException Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public COMEmulateException(
   string message
);
[C++]
public: COMEmulateException(
   String* message
);
[JScript]
public function COMEmulateException(
   message : String
);

Parameters

message
[To be supplied.]

See Also

COMEmulateException Class | COMEmulateException Members | System.Runtime.InteropServices Namespace | COMEmulateException Constructor Overload List


COMEmulateException Constructor (String, Exception)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public COMEmulateException(
   string message,
   Exception inner
);
[C++]
public: COMEmulateException(
   String* message,
   Exception* inner
);
[JScript]
public function COMEmulateException(
   message : String,
   inner : Exception
);

Parameters

message
[To be supplied.]
inner
[To be supplied.]

See Also

COMEmulateException Class | COMEmulateException Members | System.Runtime.InteropServices Namespace | COMEmulateException Constructor Overload List


COMException Class

Represents the exception that is thrown when there is a COM Interop error.

Object
Exception
SystemException
ExternalException
COMException

[Visual Basic]
Public Class COMException
   Inherits ExternalException
[C#]
public class COMException : ExternalException
[C++]
public __gc class COMException : public ExternalException
[JScript]
public class COMException extends ExternalException

Remarks

A COMException is the exception class that is thrown for all errors from COM Interop in which the HResult is not recognized.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

COMException Members | System.Runtime.InteropServices Namespace


COMException Members

Public:

Constructor

COMException Constructor Overloaded. Initializes a new instance of the COMException class.

Properties

ErrorCode (inherited from ExternalException) | [To be supplied.]
HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

COMException Class | System.Runtime.InteropServices Namespace


COMException Constructor

Initializes a new instance of the COMException class.

Overload List

Initializes a new instance of the COMException class with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public COMException();
[C++] public: COMException();
[JScript] public function COMException();

Initializes a new instance of COMException with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public COMException(String);
[C++] public: COMException(String*);
[JScript] public function COMException(String);

Initializes a new instance of COMException with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public COMException(String, Exception);
[C++] public: COMException(String*, Exception);
[JScript] public function COMException(String, Exception);

Initializes a new instance of COMException with a specified message and error code.

[Visual Basic] Overloads Public Sub New(String, Integer)
[C#] public COMException(String, int);
[C++] public: COMException(String*, int);
[JScript] public function COMException(String, int);

See Also

COMException Class | COMException Members | System.Runtime.InteropServices Namespace


COMException Constructor ()

Initializes a new instance of the COMException class with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public COMException();
[C++]
public: COMException();
[JScript]
public function COMException();

Remarks

COMException inherits from Exception. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | null
Message | The empty string.

See Also

COMException Class | COMException Members | System.Runtime.InteropServices Namespace | COMException Constructor Overload List


COMException Constructor (String)

Initializes a new instance of COMException with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public COMException(
   string message
);
[C++]
public: COMException(
   String* message
);
[JScript]
public function COMException(
   message : String
);

Parameters

message
The message indicates the reason the exception occurred.

Remarks

COMException inherits from Exception. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | null
Message | message.

See Also

COMException Class | COMException Members | System.Runtime.InteropServices Namespace | COMException Constructor Overload List


COMException Constructor (String, Exception)

Initializes a new instance of COMException with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public COMException(
   string message,
   Exception inner
);
[C++]
public: COMException(
   String* message,
   Exception* inner
);
[JScript]
public function COMException(
   message : String,
   inner : Exception
);

Parameters

message
The message indicates the reason the exception occurred.
inner
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

COMException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | inner.
Message | message.

See Also

COMException Class | COMException Members | System.Runtime.InteropServices Namespace | COMException Constructor Overload List


COMException Constructor (String, Int32)

Initializes a new instance of COMException with a specified message and error code.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal errorCode As Integer _
)
[C#]
public COMException(
   string message,
   int errorCode
);
[C++]
public: COMException(
   String* message,
   int errorCode
);
[JScript]
public function COMException(
   message : String,
   errorCode : int
);

Parameters

message
The message that indicates the reason the exception occurred.
errorCode
The error code value associate with this exception.

Remarks

This COMException constructor sets the base message witht the error code.

The errorCode parameter that is set the by this constructor. (For more information, see Int32).

COMException inherits from Exception. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | a null reference (in Visual Basic Nothing)
Message | message

See Also

COMException Class | COMException Members | System.Runtime.InteropServices Namespace | COMException Constructor Overload List


ComImportAttribute Class

A Pseudo attribute used to indicate that a class or interface definition was imported from a COM type library. The runtime uses this flag to know how to activate and marshal the type.

Object
Attribute
ComImportAttribute

[Visual Basic]
Public Class ComImportAttribute
   Inherits Attribute
[C#]
public class ComImportAttribute : Attribute
[C++]
public __gc class ComImportAttribute : public Attribute
[JScript]
public class ComImportAttribute extends Attribute

Remarks

Can be used to attribute classes or interfaces.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

ComImportAttribute Members | System.Runtime.InteropServices Namespace


ComImportAttribute Members

Public:

Constructor

ComImportAttribute Constructor Initializes a new instance of the ComImportAttribute class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ComImportAttribute Class | System.Runtime.InteropServices Namespace


ComImportAttribute Constructor

Initializes a new instance of the ComImportAttribute class.

[Visual Basic]
Public Sub New()
[C#]
public ComImportAttribute();
[C++]
public: ComImportAttribute();
[JScript]
public function ComImportAttribute();

See Also

ComImportAttribute Class | ComImportAttribute Members | System.Runtime.InteropServices Namespace


ComInterfaceType Enumeration

This enumeration is used with the InterfaceTypeAttribute to identify how an interface should be exposed to COM.

[Visual Basic]
Public Enum ComInterfaceType
[C#]
public enum ComInterfaceType
[C++]
public enum ComInterfaceType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
InterfaceIsDual | Indicates that the interface should be expsoed to com as a Dual interface
InterfaceIsIDispatch | Indicates that an interface should be expsoed to com as a dispinterface.
InterfaceIsIUnknown | Indicates that an interface should be expsoed to com as an IUnknown derived interface as opposed to a dispinterface or a dual interface.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

System.Runtime.InteropServices Namespace | InterfaceTypeAttribute


ComRegisterFunctionAttribute Class

Use this attribute on a method to indicate that the method should be called when the assembly is registered for use from COM. This allows user written code to be executed during the registraton process. Methods with this attrubte must be static and must take a single string parameter for the name of the registry key being updated. If and when the assembly containing the method is registered with the RegAsm tool, this method is called by the runtime. If the assembly containing the method is not registered. the method is not called. If the types within the assembly were not intented to be used from com, the assembly will typically not be registered. The registry key being updated such as "HKEY_CLASSES_ROOT\CLSID\<clsid>" is passed to the method. Each assembly can have only one registration function, at most.

If a registration method is provided, users shoudl be sure to "undo" when the registration did in the unregistration function.

Object
Attribute
ComRegisterFunctionAttribute

[Visual Basic]
Public Class ComRegisterFunctionAttribute
   Inherits Attribute
[C#]
public class ComRegisterFunctionAttribute : Attribute
[C++]
public __gc class ComRegisterFunctionAttribute : public Attribute
[JScript]
public class ComRegisterFunctionAttribute extends Attribute

Remarks

Can be used to attribute assemblies .

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

ComRegisterFunctionAttribute Members | System.Runtime.InteropServices Namespace


ComRegisterFunctionAttribute Members

Public:

Constructor

ComRegisterFunctionAttribute Constructor Initializes a new instance of the ComRegisterFunctionAttribute class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ComRegisterFunctionAttribute Class | System.Runtime.InteropServices Namespace


ComRegisterFunctionAttribute Constructor

Initializes a new instance of the ComRegisterFunctionAttribute class.

[Visual Basic]
Public Sub New()
[C#]
public ComRegisterFunctionAttribute();
[C++]
public: ComRegisterFunctionAttribute();
[JScript]
public function ComRegisterFunctionAttribute();

See Also

ComRegisterFunctionAttribute Class | ComRegisterFunctionAttribute Members | System.Runtime.InteropServices Namespace


ComSourceInterfacesAttribute Class

Identifies the list of interfaces that are sources of events for the class. The string value consists of a a null reference (in Visual Basic Nothing) delimited list of interface names. See the com interop spec for additional details

Object
Attribute
ComSourceInterfacesAttribute

[Visual Basic]
Public Class ComSourceInterfacesAttribute
   Inherits Attribute
[C#]
public class ComSourceInterfacesAttribute : Attribute
[C++]
public __gc class ComSourceInterfacesAttribute : public Attribute
[JScript]
public class ComSourceInterfacesAttribute extends Attribute

Remarks

Can be used to attribute classes.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

ComSourceInterfacesAttribute Members | System.Runtime.InteropServices Namespace


ComSourceInterfacesAttribute Members

Public:

Constructor

ComSourceInterfacesAttribute Constructor Initializes a new instance of the ComSourceInterfacesAttribute class.

Properties

Value [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ComSourceInterfacesAttribute Class | System.Runtime.InteropServices Namespace


ComSourceInterfacesAttribute Constructor

Initializes a new instance of the ComSourceInterfacesAttribute class.

[Visual Basic]
Public Sub New( _
   ByVal val As String _
)
[C#]
public ComSourceInterfacesAttribute(
   string val
);
[C++]
public: ComSourceInterfacesAttribute(
   String* val
);
[JScript]
public function ComSourceInterfacesAttribute(
   val : String
);

Parameters

val
[To be supplied.]

See Also

ComSourceInterfacesAttribute Class | ComSourceInterfacesAttribute Members | System.Runtime.InteropServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ComSourceInterfacesAttribute Properties

The properties of the ComSourceInterfacesAttribute class are listed below. For a complete list of ComSourceInterfacesAttribute class members, see the ComSourceInterfacesAttribute Members topic.

Public:

Value [To be supplied.]

See Also

ComSourceInterfacesAttribute Class | System.Runtime.InteropServices Namespace


ComSourceInterfacesAttribute.Value

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Value As String
[C#]
public string Value {virtual get;}
[C++]
public: __property virtual String* get_Value();
[JScript]
public function get Value() : String;

See Also

ComSourceInterfacesAttribute Class | ComSourceInterfacesAttribute Members | System.Runtime.InteropServices Namespace


ComUnregisterFunctionAttribute Class

Use this attribute on a method to indicate that the method should be called when the assembly is unregistered for use from COM. This allows user written code to be executed during the unregistraton process. Methods with this attrubte must be static and must take a single string parameter for the name of the registry key being updated. If and when the assembly containing the method is unregistered with the RegAsm tool, this method is called by the runtime. If the assembly containing the method is not unregistered. the method is not called. If the types within the assembly were not intented to be used from com, the assembly will typically not be registered. The registry key being updated such as "HKEY_CLASSES_ROOT\CLSID\<clsid>" is passed to the method. Each assembly can have only one unregistration function, at most.

If a unregistration method is provided, it should be sure to "undo" when the registration function did.

Object
Attribute
ComUnregisterFunctionAttribute

[Visual Basic]
Public Class ComUnregisterFunctionAttribute
   Inherits Attribute
[C#]
public class ComUnregisterFunctionAttribute : Attribute
[C++]
public __gc class ComUnregisterFunctionAttribute : public Attribute
[JScript]
public class ComUnregisterFunctionAttribute extends Attribute

Remarks

Can be used to attribute assemblies.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

ComUnregisterFunctionAttribute Members | System.Runtime.InteropServices Namespace


ComUnregisterFunctionAttribute Members

Public:

Constructor

ComUnregisterFunctionAttribute Constructor Initializes a new instance of the ComUnregisterFunctionAttribute class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ComUnregisterFunctionAttribute Class | System.Runtime.InteropServices Namespace


ComUnregisterFunctionAttribute Constructor

Initializes a new instance of the ComUnregisterFunctionAttribute class.

[Visual Basic]
Public Sub New()
[C#]
public ComUnregisterFunctionAttribute();
[C++]
public: ComUnregisterFunctionAttribute();
[JScript]
public function ComUnregisterFunctionAttribute();

See Also

ComUnregisterFunctionAttribute Class | ComUnregisterFunctionAttribute Members | System.Runtime.InteropServices Namespace


ComVisibleAttribute Class

This attribute can be applied to an individual type or to an entire assembly to control COM visibility. To make types visible to COM set the attribute to true. To hide types from COM, set the attribute to false. By default, all managed types that are public are visible (the attribute is not needed to make them visible). Setting the attribute to false on the assembly hides all public types within the assembly. Setting the attribute to false on a specific type hides that specific type. Settings applied to an individual type override any assembly settings. Therefore, setting the attribute to false on the assembly and true on an individual type will cause only that type to be visible from the assembly. Only types that are public can be made visible. The attribute cannot be used to make a private or protected type visible to COM.

Object
Attribute
ComVisibleAttribute

[Visual Basic]
Public Class ComVisibleAttribute
   Inherits Attribute
[C#]
public class ComVisibleAttribute : Attribute
[C++]
public __gc class ComVisibleAttribute : public Attribute
[JScript]
public class ComVisibleAttribute extends Attribute

Remarks

Can be used to attribute assemblies, classes or interfaces.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

ComVisibleAttribute Members | System.Runtime.InteropServices Namespace


ComVisibleAttribute Members

Public:

Constructor

ComVisibleAttribute Constructor Initializes a new instance of the ComVisibleAttribute class.

Properties

Value [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ComVisibleAttribute Class | System.Runtime.InteropServices Namespace


ComVisibleAttribute Constructor

Initializes a new instance of the ComVisibleAttribute class.

[Visual Basic]
Public Sub New( _
   ByVal val As Boolean _
)
[C#]
public ComVisibleAttribute(
   bool val
);
[C++]
public: ComVisibleAttribute(
   bool val
);
[JScript]
public function ComVisibleAttribute(
   val : Boolean
);

Parameters

val
[To be supplied.]

See Also

ComVisibleAttribute Class | ComVisibleAttribute Members | System.Runtime.InteropServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ComVisibleAttribute Properties

The properties of the ComVisibleAttribute class are listed below. For a complete list of ComVisibleAttribute class members, see the ComVisibleAttribute Members topic.

Public:

Value [To be supplied.]

See Also

ComVisibleAttribute Class | System.Runtime.InteropServices Namespace


ComVisibleAttribute.Value

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Value As Boolean
[C#]
public bool Value {virtual get;}
[C++]
public: __property virtual bool get_Value();
[JScript]
public function get Value() : Boolean;

See Also

ComVisibleAttribute Class | ComVisibleAttribute Members | System.Runtime.InteropServices Namespace


DispIdAttribute Class

Custom attribute to specify the COM DISPID of a Method or Field.

This attribute contains the dispid for the method, field or property it describes. Unique Dispids are typically assigned by the runtime but this attribute can be used to force a specific method to have a specific dispid.

When methods with this attribute are exposed through IDispatch, they are exposed with the dispid specified in the attribute. When importing a typelib, this attribute is applied to all methods with assigned dispids. This ensures that the any managed implementation of the same method would retain the same dispid if exposed to com.

Object
Attribute
DispIdAttribute

[Visual Basic]
Public Class DispIdAttribute
   Inherits Attribute
[C#]
public class DispIdAttribute : Attribute
[C++]
public __gc class DispIdAttribute : public Attribute
[JScript]
public class DispIdAttribute extends Attribute

Remarks

Can be used to attribute methods, fields or properties.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

DispIdAttribute Members | System.Runtime.InteropServices Namespace


DispIdAttribute Members

Public:

Constructor

DispIdAttribute Constructor Initializes a new instance of the DispIdAttribute class.

Properties

Value [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DispIdAttribute Class | System.Runtime.InteropServices Namespace


DispIdAttribute Constructor

Initializes a new instance of the DispIdAttribute class.

[Visual Basic]
Public Sub New( _
   ByVal val As Integer _
)
[C#]
public DispIdAttribute(
   int val
);
[C++]
public: DispIdAttribute(
   int val
);
[JScript]
public function DispIdAttribute(
   val : int
);

Parameters

val
[To be supplied.]

See Also

DispIdAttribute Class | DispIdAttribute Members | System.Runtime.InteropServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DispIdAttribute Properties

The properties of the DispIdAttribute class are listed below. For a complete list of DispIdAttribute class members, see the DispIdAttribute Members topic.

Public:

Value [To be supplied.]

See Also

DispIdAttribute Class | System.Runtime.InteropServices Namespace


DispIdAttribute.Value

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Value As Integer
[C#]
public int Value {virtual get;}
[C++]
public: __property virtual int get_Value();
[JScript]
public function get Value() : int;

See Also

DispIdAttribute Class | DispIdAttribute Members | System.Runtime.InteropServices Namespace


DllImportAttribute Class

Used to indicate that a method in P/Invoke method implemented in unmanaged code. The attribute provides the name of the file (DllName) and the name of the method within that file (EntryPoint) where the implementation can be found.

Object
Attribute
DllImportAttribute

[Visual Basic]
Public Class DllImportAttribute
   Inherits Attribute
[C#]
public class DllImportAttribute : Attribute
[C++]
public __gc class DllImportAttribute : public Attribute
[JScript]
public class DllImportAttribute extends Attribute

Remarks

Can be used to attribute methods.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

Example [C#]

[C#]

[DllImport(KERNEL32, EntryPoint="MoveFile",  SetLastError=true, CharSet=CharSet.Auto, ExactSpelling=true, CallingConvention=StdCall)]
public static extern bool MoveFile(String src, String dst);

See Also

DllImportAttribute Members | System.Runtime.InteropServices Namespace


DllImportAttribute Members

Public:

Constructor

DllImportAttribute Constructor [To be supplied.]

Properties

Value [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

CallingConvention | Set to indicate the calling convention used in passing method arguments. See calling conventions in MSDN for details on each. The default is the CallingConvention value StdCall.
CharSet | Indicates how string arguments to the method should be marshaled. This field is set to one of the CharSet values. If the CharSet field is set to Unicode, all string arguments are converted to Unicode characters before being passed to the unmanaged implementation. If the field is set to Ansi, the strings are converted to ANSI strings first. If the CharSet is set to Auto, the conversion is platform dependent (Unicode on WinNT and ANSI on Win 9x). Auto is only supported through PInvoke.
EntryPoint | Indicates the name or ordinal of the dll entry point to be called.
ExactSpelling | Set to true to indicate that the name of the entry point in the unmanaged dll should not be modified to correspond to the CharSet value specified in the CharSet field. If the field is not set, the letter A is appended to the method name when Ansi is used and the letter W is appended to the method name when Unicode is used. The default is false.
SetLastError | Set to true to indicate that the caller may call GetLastError to determine if an error occurred while executing the method. The default is false.
TransformSig | Set to true to indicate that the managed method signature should be transformed into a unmanaged signature that returns an HResult and has an additional out retval argument for the return value. See the COM Interop spec for details. The default is false.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DllImportAttribute Class | System.Runtime.InteropServices Namespace


DllImportAttribute Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal val As String _
)
[C#]
public DllImportAttribute(
   string val
);
[C++]
public: DllImportAttribute(
   String* val
);
[JScript]
public function DllImportAttribute(
   val : String
);

Parameters

val
[To be supplied.]

See Also

DllImportAttribute Class | DllImportAttribute Members | System.Runtime.InteropServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DllImportAttribute Properties

The properties of the DllImportAttribute class are listed below. For a complete list of DllImportAttribute class members, see the DllImportAttribute Members topic.

Public:

Value [To be supplied.]

See Also

DllImportAttribute Class | System.Runtime.InteropServices Namespace


DllImportAttribute.Value

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Value As String
[C#]
public string Value {virtual get;}
[C++]
public: __property virtual String* get_Value();
[JScript]
public function get Value() : String;

See Also

DllImportAttribute Class | DllImportAttribute Members | System.Runtime.InteropServices Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

DllImportAttribute Fields

The fields of the DllImportAttribute class are listed below. For a complete list of DllImportAttribute class members, see the DllImportAttribute Members topic.

Public:

CallingConvention | Set to indicate the calling convention used in passing method arguments. See calling conventions in MSDN for details on each. The default is the CallingConvention value StdCall.
CharSet | Indicates how string arguments to the method should be marshaled. This field is set to one of the CharSet values. If the CharSet field is set to Unicode, all string arguments are converted to Unicode characters before being passed to the unmanaged implementation. If the field is set to Ansi, the strings are converted to ANSI strings first. If the CharSet is set to Auto, the conversion is platform dependent (Unicode on WinNT and ANSI on Win 9x). Auto is only supported through PInvoke.
EntryPoint | Indicates the name or ordinal of the dll entry point to be called.
ExactSpelling | Set to true to indicate that the name of the entry point in the unmanaged dll should not be modified to correspond to the CharSet value specified in the CharSet field. If the field is not set, the letter A is appended to the method name when Ansi is used and the letter W is appended to the method name when Unicode is used. The default is false.
SetLastError | Set to true to indicate that the caller may call GetLastError to determine if an error occurred while executing the method. The default is false.
TransformSig | Set to true to indicate that the managed method signature should be transformed into a unmanaged signature that returns an HResult and has an additional out retval argument for the return value. See the COM Interop spec for details. The default is false.

See Also

DllImportAttribute Class | System.Runtime.InteropServices Namespace


DllImportAttribute.CallingConvention

Set to indicate the calling convention used in passing method arguments. See calling conventions in MSDN for details on each. The default is the CallingConvention value StdCall.

[Visual Basic]
Public CallingConvention As CallingConvention
[C#]
public CallingConvention CallingConvention;
[C++]
public: CallingConvention CallingConvention;
[JScript]
public var CallingConvention : CallingConvention;

See Also

DllImportAttribute Class | DllImportAttribute Members | System.Runtime.InteropServices Namespace | CallingConvention


DllImportAttribute.CharSet

Indicates how string arguments to the method should be marshaled. This field is set to one of the CharSet values. If the CharSet field is set to Unicode, all string arguments are converted to Unicode characters before being passed to the unmanaged implementation. If the field is set to Ansi, the strings are converted to ANSI strings first. If the CharSet is set to Auto, the conversion is platform dependent (Unicode on WinNT and ANSI on Win 9x). Auto is only supported through PInvoke.

[Visual Basic]
Public CharSet As CharSet
[C#]
public CharSet CharSet;
[C++]
public: CharSet CharSet;
[JScript]
public var CharSet : CharSet;

See Also

DllImportAttribute Class | DllImportAttribute Members | System.Runtime.InteropServices Namespace | CharSet


DllImportAttribute.EntryPoint

Indicates the name or ordinal of the dll entry point to be called.

[Visual Basic]
Public EntryPoint As String
[C#]
public string EntryPoint;
[C++]
public: String* EntryPoint;
[JScript]
public var EntryPoint : String;

See Also

DllImportAttribute Class | DllImportAttribute Members | System.Runtime.InteropServices Namespace


DllImportAttribute.ExactSpelling

Set to true to indicate that the name of the entry point in the unmanaged dll should not be modified to correspond to the CharSet value specified in the CharSet field. If the field is not set, the letter A is appended to the method name when Ansi is used and the letter W is appended to the method name when Unicode is used. The default is false.

[Visual Basic]
Public ExactSpelling As Boolean
[C#]
public bool ExactSpelling;
[C++]
public: bool ExactSpelling;
[JScript]
public var ExactSpelling : Boolean;

See Also

DllImportAttribute Class | DllImportAttribute Members | System.Runtime.InteropServices Namespace


DllImportAttribute.SetLastError

Set to true to indicate that the caller may call GetLastError to determine if an error occurred while executing the method. The default is false.

[Visual Basic]
Public SetLastError As Boolean
[C#]
public bool SetLastError;
[C++]
public: bool SetLastError;
[JScript]
public var SetLastError : Boolean;

See Also

DllImportAttribute Class | DllImportAttribute Members | System.Runtime.InteropServices Namespace


DllImportAttribute.TransformSig

Set to true to indicate that the managed method signature should be transformed into a unmanaged signature that returns an HResult and has an additional out retval argument for the return value. See the COM Interop spec for details. The default is false.

[Visual Basic]
Public TransformSig As Boolean
[C#]
public bool TransformSig;
[C++]
public: bool TransformSig;
[JScript]
public var TransformSig : Boolean;

See Also

DllImportAttribute Class | DllImportAttribute Members | System.Runtime.InteropServices Namespace


ExporterEventKind Enumeration

[To be supplied.]

[Visual Basic]
Public Enum ExporterEventKind
[C#]
public enum ExporterEventKind
[C++]
public enum ExporterEventKind

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
ERROR_REFTOINVALIDASSEMBLY | [To be supplied.]
NOTIF_CONVERTWARNING | [To be supplied.]
NOTIF_TYPECONVERTED | [To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

System.Runtime.InteropServices Namespace


ExposeHResultAttribute Class

Deprecated. USe PreserveSigAttribute instead.

Object
Attribute
ExposeHResultAttribute

[Visual Basic]
Public Class ExposeHResultAttribute
   Inherits Attribute
[C#]
public class ExposeHResultAttribute : Attribute
[C++]
public __gc class ExposeHResultAttribute : public Attribute
[JScript]
public class ExposeHResultAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

ExposeHResultAttribute Members | System.Runtime.InteropServices Namespace


ExposeHResultAttribute Members

Public:

Constructor

ExposeHResultAttribute Constructor Initializes a new instance of the ExposeHResultAttribute class.

Properties

Value [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExposeHResultAttribute Class | System.Runtime.InteropServices Namespace


ExposeHResultAttribute Constructor

Initializes a new instance of the ExposeHResultAttribute class.

[Visual Basic]
Public Sub New( _
   ByVal val As Boolean _
)
[C#]
public ExposeHResultAttribute(
   bool val
);
[C++]
public: ExposeHResultAttribute(
   bool val
);
[JScript]
public function ExposeHResultAttribute(
   val : Boolean
);

Parameters

val
[To be supplied.]

See Also

ExposeHResultAttribute Class | ExposeHResultAttribute Members | System.Runtime.InteropServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ExposeHResultAttribute Properties

The properties of the ExposeHResultAttribute class are listed below. For a complete list of ExposeHResultAttribute class members, see the ExposeHResultAttribute Members topic.

Public:

Value [To be supplied.]

See Also

ExposeHResultAttribute Class | System.Runtime.InteropServices Namespace


ExposeHResultAttribute.Value

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Value As Boolean
[C#]
public bool Value {virtual get;}
[C++]
public: __property virtual bool get_Value();
[JScript]
public function get Value() : Boolean;

See Also

ExposeHResultAttribute Class | ExposeHResultAttribute Members | System.Runtime.InteropServices Namespace


ExtensibleClassFactory Class

Provides methods used to customize the creation of managed objects that extend from unmanaged objects.

Object
ExtensibleClassFactory

[Visual Basic]
NotInheritable Public Class ExtensibleClassFactory
[C#]
public sealed class ExtensibleClassFactory
[C++]
public __gc __sealed class ExtensibleClassFactory
[JScript]
public class ExtensibleClassFactory

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

ExtensibleClassFactory Members | System.Runtime.InteropServices Namespace


ExtensibleClassFactory Members

Public:

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
RegisterObjectCreationCallback | Registers a delegate that will be called whenever an instance of a managed type that extends from an unmanaged type needs to allocate the aggregated unmanaged object. This delegate is expected to allocate and aggregate the unmanaged object and is called in place of a CoCreateInstance. This routine must be called in the context of the static initializer for the class for which the callbacks will be made. It is not legal to register this callback from a class that has any parents that have already registered a callback.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExtensibleClassFactory Class | System.Runtime.InteropServices Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ExtensibleClassFactory Methods

The methods of the ExtensibleClassFactory class are listed below. For a complete list of ExtensibleClassFactory class members, see the ExtensibleClassFactory Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
RegisterObjectCreationCallback | Registers a delegate that will be called whenever an instance of a managed type that extends from an unmanaged type needs to allocate the aggregated unmanaged object. This delegate is expected to allocate and aggregate the unmanaged object and is called in place of a CoCreateInstance. This routine must be called in the context of the static initializer for the class for which the callbacks will be made. It is not legal to register this callback from a class that has any parents that have already registered a callback.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExtensibleClassFactory Class | System.Runtime.InteropServices Namespace


ExtensibleClassFactory.RegisterObjectCreationCallback

Registers a delegate that will be called whenever an instance of a managed type that extends from an unmanaged type needs to allocate the aggregated unmanaged object. This delegate is expected to allocate and aggregate the unmanaged object and is called in place of a CoCreateInstance. This routine must be called in the context of the static initializer for the class for which the callbacks will be made.

It is not legal to register this callback from a class that has any parents that have already registered a callback.

[Visual Basic]
Public Shared Sub RegisterObjectCreationCallback( _
   ByVal callback As ObjectCreationDelegate _
)
[C#]
public static void RegisterObjectCreationCallback(
   ObjectCreationDelegate callback
);
[C++]
public: static void RegisterObjectCreationCallback(
   ObjectCreationDelegate* callback
);
[JScript]
public static function RegisterObjectCreationCallback(
   callback : ObjectCreationDelegate
);

Parameters

callback
To be supplied.

See Also

ExtensibleClassFactory Class | ExtensibleClassFactory Members | System.Runtime.InteropServices Namespace


ExternalException Class

Represents COM Interop errors and SEH exceptions.

Object
Exception
SystemException
ExternalException

[Visual Basic]
Public Class ExternalException
   Inherits SystemException
[C#]
public class ExternalException : SystemException
[C++]
public __gc class ExternalException : public SystemException
[JScript]
public class ExternalException extends SystemException

Remarks

ExternalException is the base class for all COM Interop errors and Structured Exception Handler (SHE) exceptions.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

ExternalException Members | System.Runtime.InteropServices Namespace


ExternalException Members

Public:

Constructor

ExternalException Constructor Overloaded. Initializes a new instance of the ExternalException class.

Properties

ErrorCode | [To be supplied.]
HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

ExternalException Class | System.Runtime.InteropServices Namespace


ExternalException Constructor

Initializes a new instance of the ExternalException class.

Overload List

Initializes a new instance of the ExternalException class.

[Visual Basic] Overloads Public Sub New()
[C#] public ExternalException();
[C++] public: ExternalException();
[JScript] public function ExternalException();

Initializes a new instance of ExternalException with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public ExternalException(String);
[C++] public: ExternalException(String*);
[JScript] public function ExternalException(String);

Initializes a new instance of ExternalException with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public ExternalException(String, Exception);
[C++] public: ExternalException(String*, Exception);
[JScript] public function ExternalException(String, Exception);

Initializes a new instance of the ExternalException class with a specified message and error code.

[Visual Basic] Overloads Public Sub New(String, Integer)
[C#] public ExternalException(String, int);
[C++] public: ExternalException(String*, int);
[JScript] public function ExternalException(String, int);

See Also

ExternalException Class | ExternalException Members | System.Runtime.InteropServices Namespace


ExternalException Constructor ()

Initializes a new instance of the ExternalException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ExternalException();
[C++]
public: ExternalException();
[JScript]
public function ExternalException();

Remarks

ExternalException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | a null reference (in Visual Basic Nothing).
Message | The empty string.

See Also

ExternalException Class | ExternalException Members | System.Runtime.InteropServices Namespace | ExternalException Constructor Overload List


ExternalException Constructor (String)

Initializes a new instance of ExternalException with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public ExternalException(
   string message
);
[C++]
public: ExternalException(
   String* message
);
[JScript]
public function ExternalException(
   message : String
);

Parameters

message
The message that indicates the reason the exception occurred.

Remarks

ExternalException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | a null reference (in Visual Basic Nothing).
Message | The message string.

See Also

ExternalException Class | ExternalException Members | System.Runtime.InteropServices Namespace | ExternalException Constructor Overload List


ExternalException Constructor (String, Exception)

Initializes a new instance of ExternalException with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public ExternalException(
   string message,
   Exception inner
);
[C++]
public: ExternalException(
   String* message,
   Exception* inner
);
[JScript]
public function ExternalException(
   message : String,
   inner : Exception
);

Parameters

message
The message that indicates the reason the exception occurred.
inner
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

ExternalException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | The inner exception.
Message | The message string.

See Also

ExternalException Class | ExternalException Members | System.Runtime.InteropServices Namespace | ExternalException Constructor Overload List


ExternalException Constructor (String, Int32)

Initializes a new instance of the ExternalException class with a specified message and error code.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal errorCode As Integer _
)
[C#]
public ExternalException(
   string message,
   int errorCode
);
[C++]
public: ExternalException(
   String* message,
   int errorCode
);
[JScript]
public function ExternalException(
   message : String,
   errorCode : int
);

Parameters

message
The message that indicates the reason the exception occurred.
errorCode
[To be supplied.]

Remarks

ExternalException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property | Value
InnerException | a null reference (in Visual Basic Nothing).
Message | The message string.

See Also

ExternalException Class | ExternalException Members | System.Runtime.InteropServices Namespace | ExternalException Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ExternalException Properties

The properties of the ExternalException class are listed below. For a complete list of ExternalException class members, see the ExternalException Members topic.

Public:

ErrorCode | [To be supplied.]
HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

See Also

ExternalException Class | System.Runtime.InteropServices Namespace


ExternalException.ErrorCode

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property ErrorCode As Integer
[C#]
public int ErrorCode {virtual get;}
[C++]
public: __property virtual int get_ErrorCode();
[JScript]
public function get ErrorCode() : int;

See Also

ExternalException Class | ExternalException Members | System.Runtime.InteropServices Namespace


FieldOffsetAttribute Class

Used along with the System.Runtime.InteropServices.StructLayoutAttribute.LayoutKind set to Explicit to indicate he physical position of each field within a class.

Object
Attribute
FieldOffsetAttribute

[Visual Basic]
Public Class FieldOffsetAttribute
   Inherits Attribute
[C#]
public class FieldOffsetAttribute : Attribute
[C++]
public __gc class FieldOffsetAttribute : public Attribute
[JScript]
public class FieldOffsetAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

Example [C#]

[C#]

[StructLayout(LayoutKind.Sequential, CharSet=CharSet.Unicode), Pack=4]
public struct TypeDesc {
    public int lpValue;
    public WORD vt;
}

[StructLayout(Layout.Explicit)]
public class SYSTEM_INFO
{
[FieldOffset(0)] ulong OemId;
[FieldOffset(4)] ulong PageSize;
[FieldOffset(16)] ulong ActiveProcessorMask;
[FieldOffset(20)] ulong NumberOfProcessors;
[FieldOffset(24)] ulong ProcessorType;
}

See Also

FieldOffsetAttribute Members | System.Runtime.InteropServices Namespace


FieldOffsetAttribute Members

Public:

Constructor

FieldOffsetAttribute Constructor Initializes a new instance of the FieldOffsetAttribute class.

Properties

Value [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldOffsetAttribute Class | System.Runtime.InteropServices Namespace


FieldOffsetAttribute Constructor

Initializes a new instance of the FieldOffsetAttribute class.

[Visual Basic]
Public Sub New( _
   ByVal val As Integer _
)
[C#]
public FieldOffsetAttribute(
   int val
);
[C++]
public: FieldOffsetAttribute(
   int val
);
[JScript]
public function FieldOffsetAttribute(
   val : int
);

Parameters

val
[To be supplied.]

See Also

FieldOffsetAttribute Class | FieldOffsetAttribute Members | System.Runtime.InteropServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

FieldOffsetAttribute Properties

The properties of the FieldOffsetAttribute class are listed below. For a complete list of FieldOffsetAttribute class members, see the FieldOffsetAttribute Members topic.

Public:

Value [To be supplied.]

See Also

FieldOffsetAttribute Class | System.Runtime.InteropServices Namespace


FieldOffsetAttribute.Value

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Value As Integer
[C#]
public int Value {virtual get;}
[C++]
public: __property virtual int get_Value();
[JScript]
public function get Value() : int;

See Also

FieldOffsetAttribute Class | FieldOffsetAttribute Members | System.Runtime.InteropServices Namespace


GCHandle Structure

This class allows you to create an opaque, GC handle to any NGWS object. A GC handle is used when an object reference must be reachable from unmanaged memory. See GCHandleType for more information about the different types of GCHandles used by the Runtime Execution Engine.

Object
ValueType
GCHandle

[Visual Basic]
Public Structure GCHandle
[C#]
public struct GCHandle
[C++]
public __value struct GCHandle

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

GCHandle Members | System.Runtime.InteropServices Namespace


GCHandle Members

Public:

Properties

IsAllocated | This method can be used to determine if the handle is still allocated. This method is particularly useful when using weak handles GCHandleType- Weak) since it provides a way of determining if the GC handle is still available. When the GC attempts to collect the object, the latter could still be resurrected in the finalizer. In this case, the handle will not be allocated (this is lost when the GC attempts to collect the object) although the Target object is valid.
Target | Allows getting/ setting the Object this handle represents.

Methods

AddrOfPinnedObject | Retrieve the address of an object in a Pinned handle.
Alloc | Overloaded. Allocates a Normal handle for the object specified. A normal handle ensures the object will not be collected by the garbage collector and is more space and performance efficient than the two weak handles described in GCHandleType.
Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
Free | Frees a GC handle. The caller must provide synchronization to prevent multiple threads from executing this call simultaneously for a given handle.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Type Conversions

Int32 to GCHandle Conversion | [To be supplied.]
GCHandle to Int32 Conversion | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GCHandle Structure | System.Runtime.InteropServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

GCHandle Properties

The properties of the GCHandle structure are listed below. For a complete list of GCHandle structure members, see the GCHandle Members topic.

Public:

IsAllocated | This method can be used to determine if the handle is still allocated. This method is particularly useful when using weak handles GCHandleType- Weak) since it provides a way of determining if the GC handle is still available. When the GC attempts to collect the object, the latter could still be resurrected in the finalizer. In this case, the handle will not be allocated (this is lost when the GC attempts to collect the object) although the Target object is valid.
Target | Allows getting/ setting the Object this handle represents.

See Also

GCHandle Structure | System.Runtime.InteropServices Namespace


GCHandle.IsAllocated

This method can be used to determine if the handle is still allocated. This method is particularly useful when using weak handles GCHandleType- Weak) since it provides a way of determining if the GC handle is still available. When the GC attempts to collect the object, the latter could still be resurrected in the finalizer. In this case, the handle will not be allocated (this is lost when the GC attempts to collect the object) although the Target object is valid.

[Visual Basic]
Public ReadOnly Property IsAllocated As Boolean
[C#]
public bool IsAllocated {get;}
[C++]
public: __property bool get_IsAllocated();
[JScript]
public function get IsAllocated() : Boolean;

Property Value

Returns true if the handle is allocated, else false.

See Also

GCHandle Structure | GCHandle Members | System.Runtime.InteropServices Namespace


GCHandle.Target

Allows getting/ setting the Object this handle represents.

[Visual Basic]
Public Property Target As Object
[C#]
public object Target {get; set;}
[C++]
public: __property Object* get_Target();
public: __property void set_Target(Object*);
[JScript]
public function get Target() : Object;
public function set Target(Object);

Exceptions

Exception Type | Condition
InvalidOperationException | will be thrown if the handle was never initialized or if it was freed

See Also

GCHandle Structure | GCHandle Members | System.Runtime.InteropServices Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

GCHandle Methods

The methods of the GCHandle structure are listed below. For a complete list of GCHandle structure members, see the GCHandle Members topic.

Public:

AddrOfPinnedObject | Retrieve the address of an object in a Pinned handle.
Alloc | Overloaded. Allocates a Normal handle for the object specified. A normal handle ensures the object will not be collected by the garbage collector and is more space and performance efficient than the two weak handles described in GCHandleType.
Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
Free | Frees a GC handle. The caller must provide synchronization to prevent multiple threads from executing this call simultaneously for a given handle.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GCHandle Structure | System.Runtime.InteropServices Namespace


GCHandle.AddrOfPinnedObject

Retrieve the address of an object in a Pinned handle.

[Visual Basic]
Public Function AddrOfPinnedObject() As Integer
[C#]
public int AddrOfPinnedObject();
[C++]
public: int AddrOfPinnedObject();
[JScript]
public function AddrOfPinnedObject() : int;

Return Value

Returns the address of the of the pinned object as an integer.

Exceptions

Exception Type | Condition
InvalidOperationException | will be thrown if the handle is any type other than Pinned.

See Also

GCHandle Structure | GCHandle Members | System.Runtime.InteropServices Namespace


GCHandle.Alloc

Allocates a Normal handle for the object specified. A normal handle ensures the object will not be collected by the garbage collector and is more space and performance efficient than the two weak handles described in GCHandleType.

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Shared Function Alloc(Object) As GCHandle
[C#] public static GCHandle Alloc(Object);
[C++] public: static GCHandle Alloc(Object*);
[JScript] public static function Alloc(Object) : GCHandle;

Allocates a handle of the required type for the object specified.

[Visual Basic] Overloads Public Shared Function Alloc(Object, GCHandleType) As GCHandle
[C#] public static GCHandle Alloc(Object, GCHandleType);
[C++] public: static GCHandle Alloc(Object*, GCHandleType);
[JScript] public static function Alloc(Object, GCHandleType) : GCHandle;

See Also

GCHandle Structure | GCHandle Members | System.Runtime.InteropServices Namespace


GCHandle.Alloc (Object)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function Alloc( _
   ByVal value As Object _
) As GCHandle
[C#]
public static GCHandle Alloc(
   object value
);
[C++]
public: static GCHandle Alloc(
   Object* value
);
[JScript]
public static function Alloc(
   value : Object
) : GCHandle;

Parameters

value
The object that the GC handle is created for

Return Value

Returns a new GC handle that protects the object

See Also

GCHandle Structure | GCHandle Members | System.Runtime.InteropServices Namespace | GCHandle.Alloc Overload List


GCHandle.Alloc (Object, GCHandleType)

Allocates a handle of the required type for the object specified.

[Visual Basic]
Overloads Public Shared Function Alloc( _
   ByVal value As Object, _
   ByVal type As GCHandleType _
) As GCHandle
[C#]
public static GCHandle Alloc(
   object value,
   GCHandleType type
);
[C++]
public: static GCHandle Alloc(
   Object* value,
   GCHandleType type
);
[JScript]
public static function Alloc(
   value : Object,
   type : GCHandleType
) : GCHandle;

Parameters

value
The object that the GC handle is created for
type
[To be supplied.]

Return Value

Returns a new GC handle that protects the object.

See Also

GCHandle Structure | GCHandle Members | System.Runtime.InteropServices Namespace | GCHandle.Alloc Overload List


GCHandle.Free

Frees a GC handle. The caller must provide synchronization to prevent multiple threads from executing this call simultaneously for a given handle.

[Visual Basic]
Public Sub Free()
[C#]
public void Free();
[C++]
public: void Free();
[JScript]
public function Free();

Exceptions

Exception Type | Condition
InvalidOperationException | will be thrown if the handle was never initialized or if it was freed.

See Also

GCHandle Structure | GCHandle Members | System.Runtime.InteropServices Namespace


Type Conversions

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

GCHandle Type Conversions

The type conversions of the GCHandle structure are listed below. For a complete list of GCHandle structure members, see the GCHandle Members topic.

Public:

Int32 to GCHandle Conversion | [To be supplied.]
GCHandle to Int32 Conversion | [To be supplied.]

See Also

GCHandle Structure | System.Runtime.InteropServices Namespace


Int32 to GCHandle Conversion

[To be supplied.]

[C#]
public static explicit operator GCHandle(
   int value
);
[C++]
public: static GCHandle op_Explicit(
   int value
);
[JScript]
returnValue = GCHandle(value);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#, C++]

value
[To be supplied.]

See Also

GCHandle Structure | GCHandle Members | System.Runtime.InteropServices Namespace


GCHandle to Int32 Conversion

[To be supplied.]

[C#]
public static explicit operator int(
   GCHandle value
);
[C++]
public: operator int();
[JScript]
returnValue = Int32(value);

[Visual Basic] In Visual Basic, you cannot use the conversion operators defined by a type, nor override them or define your own.

[JScript] In JScript, you can use the conversion operators defined by a type, but you cannot override them or define your own.

Arguments [JScript]

value
[To be supplied.]

Parameters [C#]

value
[To be supplied.]

See Also

GCHandle Structure | GCHandle Members | System.Runtime.InteropServices Namespace


GCHandleType Enumeration

This enum represents the the 4 different types of GCHandlesthat can be allocated by the GCHandle class. The type of handles are Normal, Weak, WeakTrackResurrection and Pinned

[Visual Basic]
Public Enum GCHandleType
[C#]
public enum GCHandleType
[C++]
public enum GCHandleType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Normal | This handle type prevents the object from being collected.
Pinned | This handle type is the same as normal, but allows the address of the actual object to be taken.
Weak | This handle type allows object to be collected. When this happens, the handle contents in the GCHandle instance will be zeroed. Weak references are zeroed before the finalizer runs, so if the object is resurrected in the finalizer, the weak reference is still zeroed.
WeakTrackResurrection | This handle type is basically the same as Weak, but the handle is not zeroed if the object is resurrected.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

System.Runtime.InteropServices Namespace


GlobalObjectAttribute Class

Deprecated. Do not use

Object
Attribute
GlobalObjectAttribute

[Visual Basic]
Public Class GlobalObjectAttribute
   Inherits Attribute
[C#]
public class GlobalObjectAttribute : Attribute
[C++]
public __gc class GlobalObjectAttribute : public Attribute
[JScript]
public class GlobalObjectAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

GlobalObjectAttribute Members | System.Runtime.InteropServices Namespace


GlobalObjectAttribute Members

Public:

Constructor

GlobalObjectAttribute Constructor Initializes a new instance of the GlobalObjectAttribute class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GlobalObjectAttribute Class | System.Runtime.InteropServices Namespace


GlobalObjectAttribute Constructor

Initializes a new instance of the GlobalObjectAttribute class.

[Visual Basic]
Public Sub New()
[C#]
public GlobalObjectAttribute();
[C++]
public: GlobalObjectAttribute();
[JScript]
public function GlobalObjectAttribute();

See Also

GlobalObjectAttribute Class | GlobalObjectAttribute Members | System.Runtime.InteropServices Namespace


GuidAttribute Class

Used to supply the GUID of a class, interface or an entire type library. The string passed to the attribute must be a format that is an acceptable constructor argument for the type Guid. To avoid conflicts with the type Guid the long name "GuidAttribute" should be used explicitly.

Object
Attribute
GuidAttribute

[Visual Basic]
Public Class GuidAttribute
   Inherits Attribute
[C#]
public class GuidAttribute : Attribute
[C++]
public __gc class GuidAttribute : public Attribute
[JScript]
public class GuidAttribute extends Attribute

Remarks

Can be used to attribute assemblies, classes, interfaces, structures, enumerations, or delegates.

For example:

[C#]

[GuidAttribute("9ED54F84-A89D-4fcd-A854-44251E925F09")]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

GuidAttribute Members | System.Runtime.InteropServices Namespace


GuidAttribute Members

Public:

Constructor

GuidAttribute Constructor Initializes a new instance of the GuidAttribute class.

Properties

Value [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GuidAttribute Class | System.Runtime.InteropServices Namespace


GuidAttribute Constructor

Initializes a new instance of the GuidAttribute class.

[Visual Basic]
Public Sub New( _
   ByVal val As String _
)
[C#]
public GuidAttribute(
   string val
);
[C++]
public: GuidAttribute(
   String* val
);
[JScript]
public function GuidAttribute(
   val : String
);

Parameters

val
[To be supplied.]

See Also

GuidAttribute Class | GuidAttribute Members | System.Runtime.InteropServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

GuidAttribute Properties

The properties of the GuidAttribute class are listed below. For a complete list of GuidAttribute class members, see the GuidAttribute Members topic.

Public:

Value [To be supplied.]

See Also

GuidAttribute Class | System.Runtime.InteropServices Namespace


GuidAttribute.Value

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Value As String
[C#]
public string Value {virtual get;}
[C++]
public: __property virtual String* get_Value();
[JScript]
public function get Value() : String;

See Also

GuidAttribute Class | GuidAttribute Members | System.Runtime.InteropServices Namespace


HasDefaultInterfaceAttribute Class

Custom attribute to specify that a class has a COM default interface.

This custom attribute indicates that the class has an explicit default interface. If the custom attribute is present, the first Interface implementation supplied when the type was defined is assumed to be the default interface for the class. If a custom value is missing, the default interface is assumed to be the class interface for the class. See the Interop Spec for important details.

Object
Attribute
HasDefaultInterfaceAttribute

[Visual Basic]
Public Class HasDefaultInterfaceAttribute
   Inherits Attribute
[C#]
public class HasDefaultInterfaceAttribute : Attribute
[C++]
public __gc class HasDefaultInterfaceAttribute : public Attribute
[JScript]
public class HasDefaultInterfaceAttribute extends Attribute

Remarks

Can be used to attribute classes.

COM to NGWS runtime interpretation: The absence of this attribute control causes TlbExp to generate the definition of the class interface in the exported type library. The class interface is also identified as the default interface for the coclass. If the attribute is present, the first interface in the list of interfaceImpls (usually the first interface listed in the inheritance list) is assumed to be the default interface and is identified as such when the type library is exported.

NGWS runtime to COM interpretation: This attribute is set on all classes that are imported from a COM typelib that have an explicitly identified default interface. The default interface is always the first interface in the list of interfaceImpls.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

HasDefaultInterfaceAttribute Members | System.Runtime.InteropServices Namespace


HasDefaultInterfaceAttribute Members

Public:

Constructor

HasDefaultInterfaceAttribute Constructor Initializes a new instance of the HasDefaultInterface class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HasDefaultInterfaceAttribute Class | System.Runtime.InteropServices Namespace


HasDefaultInterfaceAttribute Constructor

Initializes a new instance of the HasDefaultInterface class.

[Visual Basic]
Public Sub New()
[C#]
public HasDefaultInterfaceAttribute();
[C++]
public: HasDefaultInterfaceAttribute();
[JScript]
public function HasDefaultInterfaceAttribute();

See Also

HasDefaultInterfaceAttribute Class | HasDefaultInterfaceAttribute Members | System.Runtime.InteropServices Namespace


ICustomMarshaler Interface

[To be supplied.]

ICustomMarshaler

[Visual Basic]
Public Interface ICustomMarshaler
[C#]
public interface ICustomMarshaler
[C++]
public __gc __interface ICustomMarshaler

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

ICustomMarshaler Members | System.Runtime.InteropServices Namespace


ICustomMarshaler Members

Methods

CleanUpManagedData | [To be supplied.]
CleanUpNativeData | [To be supplied.]
GetNativeDataSize | [To be supplied.]
MarshalManagedToNative | [To be supplied.]
MarshalNativeToManaged | [To be supplied.]

See Also

ICustomMarshaler Interface | System.Runtime.InteropServices Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ICustomMarshaler Methods

The methods of the ICustomMarshaler interface are listed below. For a complete list of ICustomMarshaler interface members, see the ICustomMarshaler Members topic.

CleanUpManagedData | [To be supplied.]
CleanUpNativeData | [To be supplied.]
GetNativeDataSize | [To be supplied.]
MarshalManagedToNative | [To be supplied.]
MarshalNativeToManaged | [To be supplied.]

See Also

ICustomMarshaler Interface | System.Runtime.InteropServices Namespace


ICustomMarshaler.CleanUpManagedData

[To be supplied.]

[Visual Basic]
Sub CleanUpManagedData( _
   ByVal ManagedObj As Object _
)
[C#]
void CleanUpManagedData(
   object ManagedObj
);
[C++]
void CleanUpManagedData(
   Object* ManagedObj
) = 0;
[JScript]
function CleanUpManagedData(
   ManagedObj : Object
);

Parameters

ManagedObj
[To be supplied.]

See Also

ICustomMarshaler Interface | ICustomMarshaler Members | System.Runtime.InteropServices Namespace


ICustomMarshaler.CleanUpNativeData

[To be supplied.]

[Visual Basic]
Sub CleanUpNativeData( _
   ByVal pNativeData As Integer _
)
[C#]
void CleanUpNativeData(
   int pNativeData
);
[C++]
void CleanUpNativeData(
   int pNativeData
) = 0;
[JScript]
function CleanUpNativeData(
   pNativeData : int
);

Parameters

pNativeData
[To be supplied.]

See Also

ICustomMarshaler Interface | ICustomMarshaler Members | System.Runtime.InteropServices Namespace


ICustomMarshaler.GetNativeDataSize

[To be supplied.]

[Visual Basic]
Function GetNativeDataSize() As Integer
[C#]
int GetNativeDataSize();
[C++]
int GetNativeDataSize() = 0;
[JScript]
function GetNativeDataSize() : int;

See Also

ICustomMarshaler Interface | ICustomMarshaler Members | System.Runtime.InteropServices Namespace


ICustomMarshaler.MarshalManagedToNative

[To be supplied.]

[Visual Basic]
Function MarshalManagedToNative( _
   ByVal ManagedObj As Object _
) As Integer
[C#]
int MarshalManagedToNative(
   object ManagedObj
);
[C++]
int MarshalManagedToNative(
   Object* ManagedObj
) = 0;
[JScript]
function MarshalManagedToNative(
   ManagedObj : Object
) : int;

Parameters

ManagedObj
[To be supplied.]

See Also

ICustomMarshaler Interface | ICustomMarshaler Members | System.Runtime.InteropServices Namespace


ICustomMarshaler.MarshalNativeToManaged

[To be supplied.]

[Visual Basic]
Function MarshalNativeToManaged( _
   ByVal pNativeData As Integer _
) As Object
[C#]
object MarshalNativeToManaged(
   int pNativeData
);
[C++]
Object* MarshalNativeToManaged(
   int pNativeData
) = 0;
[JScript]
function MarshalNativeToManaged(
   pNativeData : int
) : Object;

Parameters

pNativeData
[To be supplied.]

See Also

ICustomMarshaler Interface | ICustomMarshaler Members | System.Runtime.InteropServices Namespace


IDispatchImplAttribute Class

Object
Attribute
IDispatchImplAttribute

[Visual Basic]
Public Class IDispatchImplAttribute
   Inherits Attribute
[C#]
public class IDispatchImplAttribute : Attribute
[C++]
public __gc class IDispatchImplAttribute : public Attribute
[JScript]
public class IDispatchImplAttribute extends Attribute

Remarks

Can be used to attribute classes or assemblies.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

IDispatchImplAttribute Members | System.Runtime.InteropServices Namespace | IDispatchImplType


IDispatchImplAttribute Members

Public:

Constructor

IDispatchImplAttribute Constructor Initializes a new instance of the IDispatchImplAttribute class.

Properties

Value [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IDispatchImplAttribute Class | System.Runtime.InteropServices Namespace


IDispatchImplAttribute Constructor

Initializes a new instance of the IDispatchImplAttribute class.

[Visual Basic]
Public Sub New( _
   ByVal val As IDispatchImplType _
)
[C#]
public IDispatchImplAttribute(
   IDispatchImplType val
);
[C++]
public: IDispatchImplAttribute(
   IDispatchImplType val
);
[JScript]
public function IDispatchImplAttribute(
   val : IDispatchImplType
);

Parameters

val
[To be supplied.]

See Also

IDispatchImplAttribute Class | IDispatchImplAttribute Members | System.Runtime.InteropServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDispatchImplAttribute Properties

The properties of the IDispatchImplAttribute class are listed below. For a complete list of IDispatchImplAttribute class members, see the IDispatchImplAttribute Members topic.

Public:

Value [To be supplied.]

See Also

IDispatchImplAttribute Class | System.Runtime.InteropServices Namespace


IDispatchImplAttribute.Value

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Value As IDispatchImplType
[C#]
public IDispatchImplType Value {virtual get;}
[C++]
public: __property virtual IDispatchImplType get_Value();
[JScript]
public function get Value() : IDispatchImplType;

See Also

IDispatchImplAttribute Class | IDispatchImplAttribute Members | System.Runtime.InteropServices Namespace


IDispatchImplType Enumeration

[To be supplied.]

[Visual Basic]
Public Enum IDispatchImplType
[C#]
public enum IDispatchImplType
[C++]
public enum IDispatchImplType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Members

Member Name | Description
CompatibleImpl | [To be supplied.]
InternalImpl | [To be supplied.]
SystemDefinedImpl | [To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

System.Runtime.InteropServices Namespace


IDLDesc Structure

[To be supplied.]

Object
ValueType
IDLDesc

[Visual Basic]
Public Structure IDLDesc
[C#]
public struct IDLDesc
[C++]
public __value struct IDLDesc

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

IDLDesc Members | System.Runtime.InteropServices Namespace


IDLDesc Members

Public:

Methods

Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Fields

dwReserved | [To be supplied.]
wIDLFlags | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IDLDesc Structure | System.Runtime.InteropServices Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDLDesc Fields

The fields of the IDLDesc structure are listed below. For a complete list of IDLDesc structure members, see the IDLDesc Members topic.

Public:

dwReserved | [To be supplied.]
wIDLFlags | [To be supplied.]

See Also

IDLDesc Structure | System.Runtime.InteropServices Namespace


IDLDesc.dwReserved

[To be supplied.]

[Visual Basic]
Public dwReserved As UInt32
[C#]
public uint dwReserved;
[C++]
public: unsigned int dwReserved;
[JScript]
public var dwReserved : UInt32;

See Also

IDLDesc Structure | IDLDesc Members | System.Runtime.InteropServices Namespace


IDLDesc.wIDLFlags

[To be supplied.]

[Visual Basic]
Public wIDLFlags As UInt16
[C#]
public ushort wIDLFlags;
[C++]
public: unsigned short wIDLFlags;
[JScript]
public var wIDLFlags : UInt16;

See Also

IDLDesc Structure | IDLDesc Members | System.Runtime.InteropServices Namespace


ImportedFromTypeLibAttribute Class

Custom attribute to specify that a module is imported from a COM type library.

This attribute indicates that the module was originally imported from a COM type library. The primary use of the attribute is to ensure that the module is not subsequently re-exported to COM thereby causing duplicate type definitions. This should not be confused with the ComImportAttribute, which is used on a type to indicate that the individual type is implemented in COM.

Object
Attribute
ImportedFromTypeLibAttribute

[Visual Basic]
Public Class ImportedFromTypeLibAttribute
   Inherits Attribute
[C#]
public class ImportedFromTypeLibAttribute : Attribute
[C++]
public __gc class ImportedFromTypeLibAttribute : public Attribute
[JScript]
public class ImportedFromTypeLibAttribute extends Attribute

Remarks

Can be used to attribute assemblies.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

ImportedFromTypeLibAttribute Members | System.Runtime.InteropServices Namespace


ImportedFromTypeLibAttribute Members

Public:

Constructor

ImportedFromTypeLibAttribute Constructor Initializes a new instance of the ImportedFromTypeLibAttribute class.

Properties

Value [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ImportedFromTypeLibAttribute Class | System.Runtime.InteropServices Namespace


ImportedFromTypeLibAttribute Constructor

Initializes a new instance of the ImportedFromTypeLibAttribute class.

[Visual Basic]
Public Sub New( _
   ByVal val As String _
)
[C#]
public ImportedFromTypeLibAttribute(
   string val
);
[C++]
public: ImportedFromTypeLibAttribute(
   String* val
);
[JScript]
public function ImportedFromTypeLibAttribute(
   val : String
);

Parameters

val
[To be supplied.]

See Also

ImportedFromTypeLibAttribute Class | ImportedFromTypeLibAttribute Members | System.Runtime.InteropServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ImportedFromTypeLibAttribute Properties

The properties of the ImportedFromTypeLibAttribute class are listed below. For a complete list of ImportedFromTypeLibAttribute class members, see the ImportedFromTypeLibAttribute Members topic.

Public:

Value [To be supplied.]

See Also

ImportedFromTypeLibAttribute Class | System.Runtime.InteropServices Namespace


ImportedFromTypeLibAttribute.Value

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Value As String
[C#]
public string Value {virtual get;}
[C++]
public: __property virtual String* get_Value();
[JScript]
public function get Value() : String;

See Also

ImportedFromTypeLibAttribute Class | ImportedFromTypeLibAttribute Members | System.Runtime.InteropServices Namespace


ImporterEventKind Enumeration

[To be supplied.]

[Visual Basic]
Public Enum ImporterEventKind
[C#]
public enum ImporterEventKind
[C++]
public enum ImporterEventKind

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
ERROR_REFTOINVALIDTYPELIB | [To be supplied.]
NOTIF_CONVERTWARNING | [To be supplied.]
NOTIF_TYPECONVERTED | [To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

System.Runtime.InteropServices Namespace


InAttribute Class

Used on a parameter or field to indicate that data should be marshaled in to the caller.

Object
Attribute
InAttribute

[Visual Basic]
Public Class InAttribute
   Inherits Attribute
[C#]
public class InAttribute : Attribute
[C++]
public __gc class InAttribute : public Attribute
[JScript]
public class InAttribute extends Attribute

Remarks

Can be used to attribute parameters.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

InAttribute Members | System.Runtime.InteropServices Namespace


InAttribute Members

Public:

Constructor

InAttribute Constructor Initializes a new instance of the InAttribute class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InAttribute Class | System.Runtime.InteropServices Namespace


InAttribute Constructor

Initializes a new instance of the InAttribute class.

[Visual Basic]
Public Sub New()
[C#]
public InAttribute();
[C++]
public: InAttribute();
[JScript]
public function InAttribute();

See Also

InAttribute Class | InAttribute Members | System.Runtime.InteropServices Namespace


InterfaceTypeAttribute Class

Controls how a managed interface is exposed to COM clients (IDispatch derived or IUnknown derived).

This attribute indicates whether a managed interface is Dual, IDispatch or IUnknown based when exposed to COM. If the attrigute is missing the interface is exposed to COM as a Dual interface.

Object
Attribute
InterfaceTypeAttribute

[Visual Basic]
Public Class InterfaceTypeAttribute
   Inherits Attribute
[C#]
public class InterfaceTypeAttribute : Attribute
[C++]
public __gc class InterfaceTypeAttribute : public Attribute
[JScript]
public class InterfaceTypeAttribute extends Attribute

Remarks

This attribute has no effect on the managed view of the interface. See Interop metadata spec for more details on this attribute class.

Can be used to attribute interfaces.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

InterfaceTypeAttribute Members | System.Runtime.InteropServices Namespace | ComInterfaceType


InterfaceTypeAttribute Members

Public:

Constructor

InterfaceTypeAttribute Constructor Initializes a new instance of the InterfaceTypeAttribute class.

Properties

Value [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InterfaceTypeAttribute Class | System.Runtime.InteropServices Namespace


InterfaceTypeAttribute Constructor

Initializes a new instance of the InterfaceTypeAttribute class.

[Visual Basic]
Public Sub New( _
   ByVal val As ComInterfaceType _
)
[C#]
public InterfaceTypeAttribute(
   ComInterfaceType val
);
[C++]
public: InterfaceTypeAttribute(
   ComInterfaceType val
);
[JScript]
public function InterfaceTypeAttribute(
   val : ComInterfaceType
);

Parameters

val
Describes how the interface should be exposed to COM clients.

See Also

InterfaceTypeAttribute Class | InterfaceTypeAttribute Members | System.Runtime.InteropServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

InterfaceTypeAttribute Properties

The properties of the InterfaceTypeAttribute class are listed below. For a complete list of InterfaceTypeAttribute class members, see the InterfaceTypeAttribute Members topic.

Public:

Value [To be supplied.]

See Also

InterfaceTypeAttribute Class | System.Runtime.InteropServices Namespace


InterfaceTypeAttribute.Value

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Value As ComInterfaceType
[C#]
public ComInterfaceType Value {virtual get;}
[C++]
public: __property virtual ComInterfaceType get_Value();
[JScript]
public function get Value() : ComInterfaceType;

See Also

InterfaceTypeAttribute Class | InterfaceTypeAttribute Members | System.Runtime.InteropServices Namespace


InvalidComObjectException Class

Represents the exception that is thrown when an invalid COM object is used.

Object
Exception
SystemException
InvalidComObjectException

[Visual Basic]
Public Class InvalidComObjectException
   Inherits SystemException
[C#]
public class InvalidComObjectException : SystemException
[C++]
public __gc class InvalidComObjectException : public
   SystemException
[JScript]
public class InvalidComObjectException extends SystemException

Remarks

An InvalidComObjectException is the exception that is thrown when an invalid COM object is used. This happens when the __ComObject type is used directly without having a backing class factory. (For more infomation, see IsCOMObject.)

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

InvalidComObjectException Members | System.Runtime.InteropServices Namespace


InvalidComObjectException Members

Public:

Constructor

InvalidComObjectException Constructor Overloaded. Initializes an instance of the InvalidComObjectException class.

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

InvalidComObjectException Class | System.Runtime.InteropServices Namespace


InvalidComObjectException Constructor

Initializes an instance of the InvalidComObjectException class.

Overload List

Initializes an instance of the InvalidComObjectException with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public InvalidComObjectException();
[C++] public: InvalidComObjectException();
[JScript] public function InvalidComObjectException();

Initializes an instance of the InvalidComObjectException with a message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public InvalidComObjectException(String);
[C++] public: InvalidComObjectException(String*);
[JScript] public function InvalidComObjectException(String);

Initializes an instance of the InvalidComObjectException with a message and the reason for the exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public InvalidComObjectException(String, Exception);
[C++] public: InvalidComObjectException(String*, Exception);
[JScript] public function InvalidComObjectException(String, Exception);

See Also

InvalidComObjectException Class | InvalidComObjectException Members | System.Runtime.InteropServices Namespace


InvalidComObjectException Constructor ()

Initializes an instance of the InvalidComObjectException with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public InvalidComObjectException();
[C++]
public: InvalidComObjectException();
[JScript]
public function InvalidComObjectException();

Remarks

InvalidComObjectException inherits from the Exception class. This constructor sets the properties of the exception object as follows:

Property Type | Description
InnerException | a null reference (in Visual Basic Nothing)
Message | The empty string.

See Also

InvalidComObjectException Class | InvalidComObjectException Members | System.Runtime.InteropServices Namespace | InvalidComObjectException Constructor Overload List


InvalidComObjectException Constructor (String)

Initializes an instance of the InvalidComObjectException with a message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public InvalidComObjectException(
   string message
);
[C++]
public: InvalidComObjectException(
   String* message
);
[JScript]
public function InvalidComObjectException(
   message : String
);

Parameters

message
The message identifies the reason the exception occurred.

Remarks

InvalidComObjectException inherits from the Exception class. This constructor sets the properties of the exception object as follows:

Property Type | Description
InnerException | a null reference (in Visual Basic Nothing)
Message | The message string.

See Also

InvalidComObjectException Class | InvalidComObjectException Members | System.Runtime.InteropServices Namespace | InvalidComObjectException Constructor Overload List


InvalidComObjectException Constructor (String, Exception)

Initializes an instance of the InvalidComObjectException with a message and the reason for the exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public InvalidComObjectException(
   string message,
   Exception inner
);
[C++]
public: InvalidComObjectException(
   String* message,
   Exception* inner
);
[JScript]
public function InvalidComObjectException(
   message : String,
   inner : Exception
);

Parameters

message
The message indicates the reason the exception occurred.
inner
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

InvalidComObjectException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | The inner exception.
Message | The message string.

See Also

InvalidComObjectException Class | InvalidComObjectException Members | System.Runtime.InteropServices Namespace | InvalidComObjectException Constructor Overload List


InvalidOleVariantTypeException Class

[To be supplied.]

Object
Exception
SystemException
InvalidOleVariantTypeException

[Visual Basic]
Public Class InvalidOleVariantTypeException
   Inherits SystemException
[C#]
public class InvalidOleVariantTypeException : SystemException
[C++]
public __gc class InvalidOleVariantTypeException : public
   SystemException
[JScript]
public class InvalidOleVariantTypeException extends SystemException

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

InvalidOleVariantTypeException Members | System.Runtime.InteropServices Namespace


InvalidOleVariantTypeException Members

Public:

Constructor

InvalidOleVariantTypeException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

InvalidOleVariantTypeException Class | System.Runtime.InteropServices Namespace


InvalidOleVariantTypeException Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public InvalidOleVariantTypeException();
[C++] public: InvalidOleVariantTypeException();
[JScript] public function InvalidOleVariantTypeException();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public InvalidOleVariantTypeException(String);
[C++] public: InvalidOleVariantTypeException(String*);
[JScript] public function InvalidOleVariantTypeException(String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public InvalidOleVariantTypeException(String, Exception);
[C++] public: InvalidOleVariantTypeException(String*, Exception);
[JScript] public function InvalidOleVariantTypeException(String, Exception);

See Also

InvalidOleVariantTypeException Class | InvalidOleVariantTypeException Members | System.Runtime.InteropServices Namespace


InvalidOleVariantTypeException Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public InvalidOleVariantTypeException();
[C++]
public: InvalidOleVariantTypeException();
[JScript]
public function InvalidOleVariantTypeException();

See Also

InvalidOleVariantTypeException Class | InvalidOleVariantTypeException Members | System.Runtime.InteropServices Namespace | InvalidOleVariantTypeException Constructor Overload List


InvalidOleVariantTypeException Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public InvalidOleVariantTypeException(
   string message
);
[C++]
public: InvalidOleVariantTypeException(
   String* message
);
[JScript]
public function InvalidOleVariantTypeException(
   message : String
);

Parameters

message
[To be supplied.]

See Also

InvalidOleVariantTypeException Class | InvalidOleVariantTypeException Members | System.Runtime.InteropServices Namespace | InvalidOleVariantTypeException Constructor Overload List


InvalidOleVariantTypeException Constructor (String, Exception)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public InvalidOleVariantTypeException(
   string message,
   Exception inner
);
[C++]
public: InvalidOleVariantTypeException(
   String* message,
   Exception* inner
);
[JScript]
public function InvalidOleVariantTypeException(
   message : String,
   inner : Exception
);

Parameters

message
[To be supplied.]
inner
[To be supplied.]

See Also

InvalidOleVariantTypeException Class | InvalidOleVariantTypeException Members | System.Runtime.InteropServices Namespace | InvalidOleVariantTypeException Constructor Overload List


ITypeLibConverter Interface

[To be supplied.]

ITypeLibConverter

[Visual Basic]
Public Interface ITypeLibConverter
[C#]
public interface ITypeLibConverter
[C++]
public __gc __interface ITypeLibConverter

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement ITypeLibConverter

Class | Description
TypeLibConverter | [To be supplied.]

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

ITypeLibConverter Members | System.Runtime.InteropServices Namespace


ITypeLibConverter Members

Methods

ConvertAssemblyToTypeLib | [To be supplied.]
ConvertTypeLibToAssembly | [To be supplied.]

See Also

ITypeLibConverter Interface | System.Runtime.InteropServices Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ITypeLibConverter Methods

The methods of the ITypeLibConverter interface are listed below. For a complete list of ITypeLibConverter interface members, see the ITypeLibConverter Members topic.

ConvertAssemblyToTypeLib | [To be supplied.]
ConvertTypeLibToAssembly | [To be supplied.]

See Also

ITypeLibConverter Interface | System.Runtime.InteropServices Namespace


ITypeLibConverter.ConvertAssemblyToTypeLib

[To be supplied.]

[Visual Basic]
Function ConvertAssemblyToTypeLib( _
   ByVal assembly As Assembly, _
   ByVal typeLibName As String, _
   ByVal flags As Integer, _
   ByVal notifySink As ITypeLibExporterNotifySink _
) As Object
[C#]
object ConvertAssemblyToTypeLib(
   Assembly assembly,
   string typeLibName,
   int flags,
   ITypeLibExporterNotifySink notifySink
);
[C++]
Object* ConvertAssemblyToTypeLib(
   Assembly* assembly,
   String* typeLibName,
   int flags,
   ITypeLibExporterNotifySink* notifySink
) = 0;
[JScript]
function ConvertAssemblyToTypeLib(
   assembly : Assembly,
   typeLibName : String,
   flags : int,
   notifySink : ITypeLibExporterNotifySink
) : Object;

Parameters

assembly
[To be supplied.]
typeLibName
[To be supplied.]
flags
[To be supplied.]
notifySink
[To be supplied.]

See Also

ITypeLibConverter Interface | ITypeLibConverter Members | System.Runtime.InteropServices Namespace


ITypeLibConverter.ConvertTypeLibToAssembly

[To be supplied.]

[Visual Basic]
Function ConvertTypeLibToAssembly( _
   ByVal typelib As Object, _
   ByVal asmFileName As String, _
   ByVal flags As Integer, _
   ByVal notifySink As ITypeLibImporterNotifySink, _
   ByVal originator() As Byte, _
   ByVal keyPair As StrongNameKeyPair, _
   ByVal unsafeInterfaces As Boolean _
) As AssemblyBuilder
[C#]
AssemblyBuilder ConvertTypeLibToAssembly(
   object typelib,
   string asmFileName,
   int flags,
   ITypeLibImporterNotifySink notifySink,
   byte[] originator,
   StrongNameKeyPair keyPair,
   bool unsafeInterfaces
);
[C++]
AssemblyBuilder* ConvertTypeLibToAssembly(
   Object* typelib,
   String* asmFileName,
   int flags,
   ITypeLibImporterNotifySink* notifySink,
   unsigned char* originator[],
   StrongNameKeyPair* keyPair,
   bool unsafeInterfaces
) = 0;
[JScript]
function ConvertTypeLibToAssembly(
   typelib : Object,
   asmFileName : String,
   flags : int,
   notifySink : ITypeLibImporterNotifySink,
   originator : Byte[],
   keyPair : StrongNameKeyPair,
   unsafeInterfaces : Boolean
) : AssemblyBuilder;

Parameters

typelib
[To be supplied.]
asmFileName
[To be supplied.]
flags
[To be supplied.]
notifySink
[To be supplied.]
originator
[To be supplied.]
keyPair
[To be supplied.]
unsafeInterfaces
[To be supplied.]

See Also

ITypeLibConverter Interface | ITypeLibConverter Members | System.Runtime.InteropServices Namespace


ITypeLibExporterNotifySink Interface

[To be supplied.]

ITypeLibExporterNotifySink

[Visual Basic]
Public Interface ITypeLibExporterNotifySink
[C#]
public interface ITypeLibExporterNotifySink
[C++]
public __gc __interface ITypeLibExporterNotifySink

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

ITypeLibExporterNotifySink Members | System.Runtime.InteropServices Namespace


ITypeLibExporterNotifySink Members

Methods

ReportEvent | [To be supplied.]
ResolveRef | [To be supplied.]

See Also

ITypeLibExporterNotifySink Interface | System.Runtime.InteropServices Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ITypeLibExporterNotifySink Methods

The methods of the ITypeLibExporterNotifySink interface are listed below. For a complete list of ITypeLibExporterNotifySink interface members, see the ITypeLibExporterNotifySink Members topic.

ReportEvent | [To be supplied.]
ResolveRef | [To be supplied.]

See Also

ITypeLibExporterNotifySink Interface | System.Runtime.InteropServices Namespace


ITypeLibExporterNotifySink.ReportEvent

[To be supplied.]

[Visual Basic]
Sub ReportEvent( _
   ByVal eventKind As ExporterEventKind, _
   ByVal eventCode As Integer, _
   ByVal eventMsg As String _
)
[C#]
void ReportEvent(
   ExporterEventKind eventKind,
   int eventCode,
   string eventMsg
);
[C++]
void ReportEvent(
   ExporterEventKind eventKind,
   int eventCode,
   String* eventMsg
) = 0;
[JScript]
function ReportEvent(
   eventKind : ExporterEventKind,
   eventCode : int,
   eventMsg : String
);

Parameters

eventKind
[To be supplied.]
eventCode
[To be supplied.]
eventMsg
[To be supplied.]

See Also

ITypeLibExporterNotifySink Interface | ITypeLibExporterNotifySink Members | System.Runtime.InteropServices Namespace


ITypeLibExporterNotifySink.ResolveRef

[To be supplied.]

[Visual Basic]
Function ResolveRef( _
   ByVal assembly As Assembly _
) As Object
[C#]
object ResolveRef(
   Assembly assembly
);
[C++]
Object* ResolveRef(
   Assembly* assembly
) = 0;
[JScript]
function ResolveRef(
   assembly : Assembly
) : Object;

Parameters

assembly
[To be supplied.]

See Also

ITypeLibExporterNotifySink Interface | ITypeLibExporterNotifySink Members | System.Runtime.InteropServices Namespace


ITypeLibImporterNotifySink Interface

[To be supplied.]

ITypeLibImporterNotifySink

[Visual Basic]
Public Interface ITypeLibImporterNotifySink
[C#]
public interface ITypeLibImporterNotifySink
[C++]
public __gc __interface ITypeLibImporterNotifySink

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

ITypeLibImporterNotifySink Members | System.Runtime.InteropServices Namespace


ITypeLibImporterNotifySink Members

Methods

ReportEvent | [To be supplied.]
ResolveRef | [To be supplied.]

See Also

ITypeLibImporterNotifySink Interface | System.Runtime.InteropServices Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ITypeLibImporterNotifySink Methods

The methods of the ITypeLibImporterNotifySink interface are listed below. For a complete list of ITypeLibImporterNotifySink interface members, see the ITypeLibImporterNotifySink Members topic.

ReportEvent | [To be supplied.]
ResolveRef | [To be supplied.]

See Also

ITypeLibImporterNotifySink Interface | System.Runtime.InteropServices Namespace


ITypeLibImporterNotifySink.ReportEvent

[To be supplied.]

[Visual Basic]
Sub ReportEvent( _
   ByVal eventKind As ImporterEventKind, _
   ByVal eventCode As Integer, _
   ByVal eventMsg As String _
)
[C#]
void ReportEvent(
   ImporterEventKind eventKind,
   int eventCode,
   string eventMsg
);
[C++]
void ReportEvent(
   ImporterEventKind eventKind,
   int eventCode,
   String* eventMsg
) = 0;
[JScript]
function ReportEvent(
   eventKind : ImporterEventKind,
   eventCode : int,
   eventMsg : String
);

Parameters

eventKind
[To be supplied.]
eventCode
[To be supplied.]
eventMsg
[To be supplied.]

See Also

ITypeLibImporterNotifySink Interface | ITypeLibImporterNotifySink Members | System.Runtime.InteropServices Namespace


ITypeLibImporterNotifySink.ResolveRef

[To be supplied.]

[Visual Basic]
Function ResolveRef( _
   ByVal typeLib As Object _
) As Assembly
[C#]
Assembly ResolveRef(
   object typeLib
);
[C++]
Assembly* ResolveRef(
   Object* typeLib
) = 0;
[JScript]
function ResolveRef(
   typeLib : Object
) : Assembly;

Parameters

typeLib
[To be supplied.]

See Also

ITypeLibImporterNotifySink Interface | ITypeLibImporterNotifySink Members | System.Runtime.InteropServices Namespace


LayoutKind Enumeration

[To be supplied.]

[Visual Basic]
Public Enum LayoutKind
[C#]
public enum LayoutKind
[C++]
public enum LayoutKind

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
Explicit | [To be supplied.]
Sequential | [To be supplied.]
Union | [To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

System.Runtime.InteropServices Namespace


LIBFLAGS Enumeration

[To be supplied.]

[Visual Basic]
Public Enum LIBFLAGS
[C#]
public enum LIBFLAGS
[C++]
public enum LIBFLAGS

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
LIBFLAG_FCONTROL | [To be supplied.]
LIBFLAG_FHASDISKIMAGE | [To be supplied.]
LIBFLAG_FHIDDEN | [To be supplied.]
LIBFLAG_FRESTRICTED | [To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

System.Runtime.InteropServices Namespace


Marshal Class

PInvoke (Platform Invocation Services) lets you execute existing, unmanaged code, that lives in a regular DLL, from managed code.

Object
Marshal

[Visual Basic]
NotInheritable Public Class Marshal
[C#]
public sealed class Marshal
[C++]
public __gc __sealed class Marshal
[JScript]
public class Marshal

Remarks

The Marshal Class described here provides a collection of useful functions when working in this mixed, managed/unmanaged mode. Note that all of the methods in the Marshal Class are declared as static. So, you don't ever create an instance of a Marshal object. You just use the functions you need, straight off. For example, the StringToHGlobalAnsi method copies the Ansi characters from a specified String (in managed heap) to a buffer in unmanaged heap. It also allocates the target heap for you, of just the right size. Like this:

< p > String s = "Hello";

int p = Marshal.StringToHGlobalAnsi(s);

In general, Marshal methods return integers where you would normally expect a pointer. Simply cast the integer to the appropriate pointer type, and carry on.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

Marshal Members | System.Runtime.InteropServices Namespace


Marshal Members

Public:

Methods

AddRef | [To be supplied.]
AddrOfArrayElement | Returns the address of an element of an array in the native heap.
AddrOfDelegate | Returns the address of a previously pinned delegate object.
AddrOfPinnedObject | Returns the address, in managed heap, of an object that was previously pinned against garbage reclamation or movement (by a call to GetPinnedHandle).
AllocCoTaskMem | Allocates a block of memory of specified size from the COM task memory allocator.
AllocHGlobal | Allocates memory from the process' unmanaged, native, heap.
Copy | Overloaded. [To be supplied.]
CreateWrapperOfType | [To be supplied.]
DestroyStructure | Frees all substructures pointed to by the native memory block.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FreeCoTaskMem | Frees a block of memory allocated by the unmanaged COM task memory allocator.
FreeHGlobal | Frees memory, previously allocated from from the process' unmanaged, native heap.
FreePinnedHandle | Unpins the object previously pinned against garbage reclamation and movement.
GenerateGuidForType | [To be supplied.]
GetComInterfaceForObject | [To be supplied.]
GetExceptionCode | [To be supplied.]
GetExceptionPointers | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHINSTANCE | [To be supplied.]
GetIDispatchForObject | Returns an IDispatch interface from a managed object.
GetITypeInfoForType | [To be supplied.]
GetIUnknownForObject | [To be supplied.]
GetLastWin32Error | Returns the last error incurred by Win32 code executed via Marshal. Note that the target function must have had the setLastError metadata flag set-- how this is done varies depending upon the source language used.
GetManagedThunkForUnmanagedMethodPtr | [To be supplied.]
GetNativeVariantForObject | [To be supplied.]
GetObjectForIUnknown | Returns an instance of System.Object that represents an unmanaged COM object that is specified by a pointer to its IUnknown interface.
GetObjectForNativeVariant | [To be supplied.]
GetPinnedHandle | Pins the specified object to prevent it from being garbage collected or moved. (This called must be matched with a subsequent FreePinnedHandle)
GetPinnedObject | Returns the object, previously pinned against garbage collection and movement by a call to GetPinnedHandle.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypedObjectForIUnknown | Returns a managed object of a specified type that represents an unmanaged COM object. NOTE: Type T should be either a COM-imported Type or a sub-type of a COM-imported Type.
GetTypeForITypeInfo | Creates a TypeInfo/Type marshaler and passes the provided ITypeInfo to the marshaler. The marshaler then delegates the calls on the Type object to the underlying ITypeInfo interface.
GetTypeInfoName | [To be supplied.]
GetTypeLibName | [To be supplied.]
GetUnmanagedThunkForManagedMethodPtr | [To be supplied.]
IsComObject | Indicates whether a specified object represents an unmanaged COM object.
IsTypeVisibleFromCom | [To be supplied.]
NumParamBytes | Calculate the number of bytes required to hold the parameters for the specified method.
OffsetOf | Returns the byte offset for a field within a class used by Marshal.
Prelink | Checks that the native method m is type-compatible with the corresponding managed declaration. (This action is performed automatically when the target method is invoked anyway.)
PrelinkAll | Performs a Prelink check for all methods on a class.
PtrToStringAnsi | Overloaded. Copies all or part of an ANSI string, stored in native heap, to a managed String object.
PtrToStringAuto | Overloaded. Copies all or part of a string, stored in native heap, to a managed String object.
PtrToStringUni | Overloaded. Copies part or all of a UNICODE string, stored in native heap, to a managed String object.
PtrToStructure | Overloaded. Marshals data from an unmanaged block of memory to a managed object.
QueryInterface | Requests a pointer to a specified interface on an unmanaged COM object.
ReadByte | Overloaded. Reads a single byte from native heap
ReadInt16 | Overloaded. Reads a 16-bit integer from native heap
ReadInt32 | Overloaded. Reads a 32-bit integer from native heap.
ReadInt64 | Overloaded. Reads a 64-bit integer from native heap.
ReAllocCoTaskMem | [To be supplied.]
ReAllocHGlobal | [To be supplied.]
Release | Decrements the reference count on a specified unmanaged COM interface.
ReleaseComObject | Releases the COM component and, if the reference hits 0, zombies this object. Further usage of this object might throw an exception.
ReleaseThreadCache | Forces the aggressive release of the current thread's cache. There may be a thread-based cache of COM components.
SizeOf | Overloaded. Returns the size, in bytes, of a class used via Marshal.
StringToCoTaskMemAnsi | Copies the contents of a string to block of memory allocated from the unmanaged COM task allocator. The characters of the string are copied as ANSI characters.
StringToCoTaskMemAuto | Copies the contents of a string to a block of memory allocated from the unmanaged COM task allocator. The characters of the string are copied as either ANSI or Unicode characters, depending on the operating system where the code is executing. On Windows 95 or Windows 98, the characters are copied as ANSI characters. On Windows NT 4.0 or Windows 2000, the characters are copied as Unicode characters.
StringToCoTaskMemUni | Copies the contents of a string to block of memory allocated from the unmanaged COM task allocator. The characters of the string are copied as Unicode characters.
StringToHGlobalAnsi | Copies the contents of a managed String object into native heap, converting into ASCII format on-the-fly. The method allocates the required, native heap memory.
StringToHGlobalAuto | Copies the contents of a managed String object into native heap, converting into ASCII format on-the-fly if required. The method allocates the required, native heap memory.
StringToHGlobalUni | Copies the contents of a managed String object into native heap. (source and destination are both UNICODE). The method allocates the required, native heap memory.
StructureToPtr | Marshals data from a managed object to an unmanaged block of memory. This method copies the contents of structure to the block of memory pointed to by ptr. If fDeleteOld is true, the buffer originally pointed to by ptr will be deleted. This is accomplished by calling the appropriate 'delete' API on the embedded pointer. StructureToPtr does this tidy-up for every reference field specified in the 'mirror' managed class.
ToString (inherited from Object) | Returns a String that represents the current Object.
UnsafeAddrOfPinnedArrayElement | [To be supplied.]
WriteByte | Overloaded. Writes a single byte value into native heap.
WriteInt16 | Overloaded. Writes a 16-bit integer value into native heap.
WriteInt32 | Overloaded. Writes a 32-bit integer value into native heap.
WriteInt64 | Overloaded. Writes a 64-bit integer value into native heap.

Fields

SystemDefaultCharSize Defined as 1 on an ANSI platform, and 2 on a UNICODE platform

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Marshal Class | System.Runtime.InteropServices Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Marshal Methods

The methods of the Marshal class are listed below. For a complete list of Marshal class members, see the Marshal Members topic.

Public:

AddRef | [To be supplied.]
AddrOfArrayElement | Returns the address of an element of an array in the native heap.
AddrOfDelegate | Returns the address of a previously pinned delegate object.
AddrOfPinnedObject | Returns the address, in managed heap, of an object that was previously pinned against garbage reclamation or movement (by a call to GetPinnedHandle).
AllocCoTaskMem | Allocates a block of memory of specified size from the COM task memory allocator.
AllocHGlobal | Allocates memory from the process' unmanaged, native, heap.
Copy | Overloaded. [To be supplied.]
CreateWrapperOfType | [To be supplied.]
DestroyStructure | Frees all substructures pointed to by the native memory block.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FreeCoTaskMem | Frees a block of memory allocated by the unmanaged COM task memory allocator.
FreeHGlobal | Frees memory, previously allocated from from the process' unmanaged, native heap.
FreePinnedHandle | Unpins the object previously pinned against garbage reclamation and movement.
GenerateGuidForType | [To be supplied.]
GetComInterfaceForObject | [To be supplied.]
GetExceptionCode | [To be supplied.]
GetExceptionPointers | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHINSTANCE | [To be supplied.]
GetIDispatchForObject | Returns an IDispatch interface from a managed object.
GetITypeInfoForType | [To be supplied.]
GetIUnknownForObject | [To be supplied.]
GetLastWin32Error | Returns the last error incurred by Win32 code executed via Marshal. Note that the target function must have had the setLastError metadata flag set-- how this is done varies depending upon the source language used.
GetManagedThunkForUnmanagedMethodPtr | [To be supplied.]
GetNativeVariantForObject | [To be supplied.]
GetObjectForIUnknown | Returns an instance of System.Object that represents an unmanaged COM object that is specified by a pointer to its IUnknown interface.
GetObjectForNativeVariant | [To be supplied.]
GetPinnedHandle | Pins the specified object to prevent it from being garbage collected or moved. (This called must be matched with a subsequent FreePinnedHandle)
GetPinnedObject | Returns the object, previously pinned against garbage collection and movement by a call to GetPinnedHandle.
GetType (inherited from Object) | Gets the Type of the Object.
GetTypedObjectForIUnknown | Returns a managed object of a specified type that represents an unmanaged COM object. NOTE: Type T should be either a COM-imported Type or a sub-type of a COM-imported Type.
GetTypeForITypeInfo | Creates a TypeInfo/Type marshaler and passes the provided ITypeInfo to the marshaler. The marshaler then delegates the calls on the Type object to the underlying ITypeInfo interface.
GetTypeInfoName | [To be supplied.]
GetTypeLibName | [To be supplied.]
GetUnmanagedThunkForManagedMethodPtr | [To be supplied.]
IsComObject | Indicates whether a specified object represents an unmanaged COM object.
IsTypeVisibleFromCom | [To be supplied.]
NumParamBytes | Calculate the number of bytes required to hold the parameters for the specified method.
OffsetOf | Returns the byte offset for a field within a class used by Marshal.
Prelink | Checks that the native method m is type-compatible with the corresponding managed declaration. (This action is performed automatically when the target method is invoked anyway.)
PrelinkAll | Performs a Prelink check for all methods on a class.
PtrToStringAnsi | Overloaded. Copies all or part of an ANSI string, stored in native heap, to a managed String object.
PtrToStringAuto | Overloaded. Copies all or part of a string, stored in native heap, to a managed String object.
PtrToStringUni | Overloaded. Copies part or all of a UNICODE string, stored in native heap, to a managed String object.
PtrToStructure | Overloaded. Marshals data from an unmanaged block of memory to a managed object.
QueryInterface | Requests a pointer to a specified interface on an unmanaged COM object.
ReadByte | Overloaded. Reads a single byte from native heap
ReadInt16 | Overloaded. Reads a 16-bit integer from native heap
ReadInt32 | Overloaded. Reads a 32-bit integer from native heap.
ReadInt64 | Overloaded. Reads a 64-bit integer from native heap.
ReAllocCoTaskMem | [To be supplied.]
ReAllocHGlobal | [To be supplied.]
Release | Decrements the reference count on a specified unmanaged COM interface.
ReleaseComObject | Releases the COM component and, if the reference hits 0, zombies this object. Further usage of this object might throw an exception.
ReleaseThreadCache | Forces the aggressive release of the current thread's cache. There may be a thread-based cache of COM components.
SizeOf | Overloaded. Returns the size, in bytes, of a class used via Marshal.
StringToCoTaskMemAnsi | Copies the contents of a string to block of memory allocated from the unmanaged COM task allocator. The characters of the string are copied as ANSI characters.
StringToCoTaskMemAuto | Copies the contents of a string to a block of memory allocated from the unmanaged COM task allocator. The characters of the string are copied as either ANSI or Unicode characters, depending on the operating system where the code is executing. On Windows 95 or Windows 98, the characters are copied as ANSI characters. On Windows NT 4.0 or Windows 2000, the characters are copied as Unicode characters.
StringToCoTaskMemUni | Copies the contents of a string to block of memory allocated from the unmanaged COM task allocator. The characters of the string are copied as Unicode characters.
StringToHGlobalAnsi | Copies the contents of a managed String object into native heap, converting into ASCII format on-the-fly. The method allocates the required, native heap memory.
StringToHGlobalAuto | Copies the contents of a managed String object into native heap, converting into ASCII format on-the-fly if required. The method allocates the required, native heap memory.
StringToHGlobalUni | Copies the contents of a managed String object into native heap. (source and destination are both UNICODE). The method allocates the required, native heap memory.
StructureToPtr | Marshals data from a managed object to an unmanaged block of memory. This method copies the contents of structure to the block of memory pointed to by ptr. If fDeleteOld is true, the buffer originally pointed to by ptr will be deleted. This is accomplished by calling the appropriate 'delete' API on the embedded pointer. StructureToPtr does this tidy-up for every reference field specified in the 'mirror' managed class.
ToString (inherited from Object) | Returns a String that represents the current Object.
UnsafeAddrOfPinnedArrayElement | [To be supplied.]
WriteByte | Overloaded. Writes a single byte value into native heap.
WriteInt16 | Overloaded. Writes a 16-bit integer value into native heap.
WriteInt32 | Overloaded. Writes a 32-bit integer value into native heap.
WriteInt64 | Overloaded. Writes a 64-bit integer value into native heap.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Marshal Class | System.Runtime.InteropServices Namespace


Marshal.AddRef

[To be supplied.]

[Visual Basic]
Public Shared Function AddRef( _
   ByVal pUnk As Integer _
) As Integer
[C#]
public static int AddRef(
   int pUnk
);
[C++]
public: static int AddRef(
   int pUnk
);
[JScript]
public static function AddRef(
   pUnk : int
) : int;

Parameters

pUnk
[To be supplied.]

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.AddrOfArrayElement

Returns the address of an element of an array in the native heap.

[Visual Basic]
Public Shared Function AddrOfArrayElement( _
   ByVal arr As Array, _
   ByVal index As Integer _
) As Integer
[C#]
public static int AddrOfArrayElement(
   Array arr,
   int index
);
[C++]
public: static int AddrOfArrayElement(
   Array* arr,
   int index
);
[JScript]
public static function AddrOfArrayElement(
   arr : Array,
   index : int
) : int;

Parameters

arr
Array of interest.
index
Element index of interest within the array.

Return Value

Address of target array element.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.AddrOfDelegate

Returns the address of a previously pinned delegate object.

[Visual Basic]
Public Shared Function AddrOfDelegate( _
   ByVal root As Integer _
) As Integer
[C#]
public static int AddrOfDelegate(
   int root
);
[C++]
public: static int AddrOfDelegate(
   int root
);
[JScript]
public static function AddrOfDelegate(
   root : int
) : int;

Parameters

root
Root handle for the delegate of interest.

Return Value

Target address.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.AddrOfPinnedObject

Returns the address, in managed heap, of an object that was previously pinned against garbage reclamation or movement (by a call to GetPinnedHandle).

[Visual Basic]
Public Shared Function AddrOfPinnedObject( _
   ByVal handleIndex As Integer _
) As Integer
[C#]
public static int AddrOfPinnedObject(
   int handleIndex
);
[C++]
public: static int AddrOfPinnedObject(
   int handleIndex
);
[JScript]
public static function AddrOfPinnedObject(
   handleIndex : int
) : int;

Parameters

handleIndex
Handle for the pinned object, as returned by GetPinnedHandle.

Return Value

Address of target pinned object.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.AllocCoTaskMem

Allocates a block of memory of specified size from the COM task memory allocator.

[Visual Basic]
Public Shared Function AllocCoTaskMem( _
   ByVal cb As Integer _
) As Integer
[C#]
public static int AllocCoTaskMem(
   int cb
);
[C++]
public: static int AllocCoTaskMem(
   int cb
);
[JScript]
public static function AllocCoTaskMem(
   cb : int
) : int;

Parameters

cb
Size of the block of memory to be allocated.

Return Value

An integer representing the address of the block of memory allocated.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.AllocHGlobal

Allocates memory from the process' unmanaged, native, heap.

[Visual Basic]
Public Shared Function AllocHGlobal( _
   ByVal cb As Integer _
) As Integer
[C#]
public static int AllocHGlobal(
   int cb
);
[C++]
public: static int AllocHGlobal(
   int cb
);
[JScript]
public static function AllocHGlobal(
   cb : int
) : int;

Parameters

cb
Number of bytes of memory required.

Return Value

A pointer to the newly allocated memory. Treat this as a void* and cast as appropriate.

Exceptions

Exception Type | Condition
System.Runtime.InteropServices.OutOfMemoryException | if there is insufficient memory to satisfy the request.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.Copy

[To be supplied.]

Overload List

Copies an array of Int64s from the managed heap to the native heap.

[Visual Basic] Overloads Public Shared Sub Copy(Long(), Integer, Integer, Integer)
[C#] public static void Copy(long[], int, int, int);
[C++] public: static void Copy(__int64*[], int, int, int);
[JScript] public static function Copy(long[], int, int, int);

Copies an array of doubles from managed heap to native heap.

[Visual Basic] Overloads Public Shared Sub Copy(Double(), Integer, Integer, Integer)
[C#] public static void Copy(double[], int, int, int);
[C++] public: static void Copy(double*[], int, int, int);
[JScript] public static function Copy(double[], int, int, int);

Copies an array of floats from managed heap to native heap.

[Visual Basic] Overloads Public Shared Sub Copy(Single(), Integer, Integer, Integer)
[C#] public static void Copy(float[], int, int, int);
[C++] public: static void Copy(float*[], int, int, int);
[JScript] public static function Copy(float[], int, int, int);

Copies an array of int32s from managed heap to native heap.

[Visual Basic] Overloads Public Shared Sub Copy(Integer(), Integer, Integer, Integer)
[C#] public static void Copy(int[], int, int, int);
[C++] public: static void Copy(int*[], int*, int*, int*);
[JScript] public static function Copy(int[], int, int, int);

Copies an array of wide characters from managed heap to native heap.

[Visual Basic] Overloads Public Shared Sub Copy(Char(), Integer, Integer, Integer)
[C#] public static void Copy(char[], int, int, int);
[C++] public: static void Copy(__wchar_t*[], int, int, int);
[JScript] public static function Copy(Char[], int, int, int);

Copies an array of int16s from managed heap to native heap.

[Visual Basic] Overloads Public Shared Sub Copy(Integer(), Integer, Integer, Integer)
[C#] public static void Copy(short[], int, int, int);
[C++] public: static void Copy(short*[], int, int, int);
[JScript] public static function Copy(Int16[], int, int, int);

[To be supplied.]

[Visual Basic] Overloads Public Shared Sub Copy(Byte(), Integer, Integer, Integer)
[C#] public static void Copy(byte[], int, int, int);
[C++] public: static void Copy(unsigned char*[], int, int, int);
[JScript] public static function Copy(Byte[], int, int, int);

[To be supplied.]

[Visual Basic] Overloads Public Shared Sub Copy(Integer, Single(), Integer, Integer)
[C#] public static void Copy(int, float[], int, int);
[C++] public: static void Copy(int, float[], int, int);
[JScript] public static function Copy(int, float[], int, int);

Copies an array of int64s from native heap to managed heap.

[Visual Basic] Overloads Public Shared Sub Copy(Integer, Long(), Integer, Integer)
[C#] public static void Copy(int, long[], int, int);
[C++] public: static void Copy(int, __int64[], int, int);
[JScript] public static function Copy(int, long[], int, int);

Copies an array of unsigned chars from native heap to managed heap.

[Visual Basic] Overloads Public Shared Sub Copy(Integer, Byte(), Integer, Integer)
[C#] public static void Copy(int, byte[], int, int);
[C++] public: static void Copy(int, unsigned char[], int, int);
[JScript] public static function Copy(int, Byte[], int, int);

Copies an array of doubles from native heap to managed heap.

[Visual Basic] Overloads Public Shared Sub Copy(Integer, Double(), Integer, Integer)
[C#] public static void Copy(int, double[], int, int);
[C++] public: static void Copy(int, double[], int, int);
[JScript] public static function Copy(int, double[], int, int);

Copies an array of int32s from native heap to managed heap.

[Visual Basic] Overloads Public Shared Sub Copy(Integer, Integer(), Integer, Integer)
[C#] public static void Copy(int, int[], int, int);
[C++] public: static void Copy(int, int[], int, int);
[JScript] public static function Copy(int, int[], int, int);

Copies an array of wide characters from native heap to managed heap.

[Visual Basic] Overloads Public Shared Sub Copy(Integer, Char(), Integer, Integer)
[C#] public static void Copy(int, char[], int, int);
[C++] public: static void Copy(int, __wchar_t[], int, int);
[JScript] public static function Copy(int, Char[], int, int);

Copies an array of Int16s from native heap to managed heap.

[Visual Basic] Overloads Public Shared Sub Copy(Integer, Integer(), Integer, Integer)
[C#] public static void Copy(int, short[], int, int);
[C++] public: static void Copy(int, short[], int, int);
[JScript] public static function Copy(int, Int16[], int, int);

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.Copy (Int64[], Int32, Int32, Int32)

Copies an array of Int64s from the managed heap to the native heap.

[Visual Basic]
Overloads Public Shared Sub Copy( _
   ByVal source() As Long, _
   ByVal startIndex As Integer, _
   ByVal destination As Integer, _
   ByVal length As Integer _
)
[C#]
public static void Copy(
   long[] source,
   int startIndex,
   int destination,
   int length
);
[C++]
public: static void Copy(
   __int64* source[],
   int startIndex,
   int destination,
   int length
);
[JScript]
public static function Copy(
   source : long[],
   startIndex : int,
   destination : int,
   length : int
);

Parameters

source
Managed array of int64s.
startIndex
Index within source at which copy is to start.
destination
Pointer to native heap.
length
Number of int64s to copy.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.Copy Overload List


Marshal.Copy (Double[], Int32, Int32, Int32)

Copies an array of doubles from managed heap to native heap.

[Visual Basic]
Overloads Public Shared Sub Copy( _
   ByVal source() As Double, _
   ByVal startIndex As Integer, _
   ByVal destination As Integer, _
   ByVal length As Integer _
)
[C#]
public static void Copy(
   double[] source,
   int startIndex,
   int destination,
   int length
);
[C++]
public: static void Copy(
   double* source[],
   int startIndex,
   int destination,
   int length
);
[JScript]
public static function Copy(
   source : double[],
   startIndex : int,
   destination : int,
   length : int
);

Parameters

source
Managed array of doubles.
startIndex
Index within source at which copy is to start.
destination
Pointer to native heap.
length
Number of doubles to copy.

Remarks

NGWS Runtime Security: In addition to any permissions required by the class, your code must have the following permissions: [To be supplied.]

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.Copy Overload List


Marshal.Copy (Single[], Int32, Int32, Int32)

Copies an array of floats from managed heap to native heap.

[Visual Basic]
Overloads Public Shared Sub Copy( _
   ByVal source() As Single, _
   ByVal startIndex As Integer, _
   ByVal destination As Integer, _
   ByVal length As Integer _
)
[C#]
public static void Copy(
   float[] source,
   int startIndex,
   int destination,
   int length
);
[C++]
public: static void Copy(
   float* source[],
   int startIndex,
   int destination,
   int length
);
[JScript]
public static function Copy(
   source : float[],
   startIndex : int,
   destination : int,
   length : int
);

Parameters

source
Managed array of floats.
startIndex
Index within source at which copy is to start.
destination
Pointer to native heap.
length
Number of floats to copy.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.Copy Overload List


Marshal.Copy (Int32[], Int32, Int32, Int32)

Copies an array of int32s from managed heap to native heap.

[Visual Basic]
Overloads Public Shared Sub Copy( _
   ByVal source() As Integer, _
   ByVal startIndex As Integer, _
   ByVal destination As Integer, _
   ByVal length As Integer _
)
[C#]
public static void Copy(
   int[] source,
   int startIndex,
   int destination,
   int length
);
[C++]
public: static void Copy(
   int* source[],
   int startIndex,
   int destination,
   int length
);
[JScript]
public static function Copy(
   source : int[],
   startIndex : int,
   destination : int,
   length : int
);

Parameters

source
Managed array of int32s.
startIndex
Index within source at which copy is to start.
destination
Pointer to native heap.
length
Number of int32s to copy.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.Copy Overload List


Marshal.Copy (Char[], Int32, Int32, Int32)

Copies an array of wide characters from managed heap to native heap.

[Visual Basic]
Overloads Public Shared Sub Copy( _
   ByVal source() As Char, _
   ByVal startIndex As Integer, _
   ByVal destination As Integer, _
   ByVal length As Integer _
)
[C#]
public static void Copy(
   char[] source,
   int startIndex,
   int destination,
   int length
);
[C++]
public: static void Copy(
   __wchar_t* source[],
   int startIndex,
   int destination,
   int length
);
[JScript]
public static function Copy(
   source : Char[],
   startIndex : int,
   destination : int,
   length : int
);

Parameters

source
Managed array of wide characters.
startIndex
Index within source at which copy is to start.
destination
Pointer to native heap.
length
Number of wide characters to copy.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.Copy Overload List


Marshal.Copy (Int16[], Int32, Int32, Int32)

Copies an array of int16s from managed heap to native heap.

[Visual Basic]
Overloads Public Shared Sub Copy( _
   ByVal source() As Short, _
   ByVal startIndex As Integer, _
   ByVal destination As Integer, _
   ByVal length As Integer _
)
[C#]
public static void Copy(
   short[] source,
   int startIndex,
   int destination,
   int length
);
[C++]
public: static void Copy(
   short* source[],
   int startIndex,
   int destination,
   int length
);
[JScript]
public static function Copy(
   source : Int16[],
   startIndex : int,
   destination : int,
   length : int
);

Parameters

source
Managed array of Int16s.
startIndex
Index within source at which copy is to start.
destination
Pointer to native heap.
length
Number of Int16s to copy.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.Copy Overload List


Marshal.Copy (Byte[], Int32, Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Sub Copy( _
   ByVal source() As Byte, _
   ByVal startIndex As Integer, _
   ByVal destination As Integer, _
   ByVal length As Integer _
)
[C#]
public static void Copy(
   byte[] source,
   int startIndex,
   int destination,
   int length
);
[C++]
public: static void Copy(
   unsigned char* source[],
   int startIndex,
   int destination,
   int length
);
[JScript]
public static function Copy(
   source : Byte[],
   startIndex : int,
   destination : int,
   length : int
);

Parameters

source
[To be supplied.]
startIndex
[To be supplied.]
destination
[To be supplied.]
length
[To be supplied.]

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.Copy Overload List


Marshal.Copy (Int32, Single[], Int32, Int32)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Sub Copy( _
   ByVal source As Integer, _
   ByVal destination() As Single, _
   ByVal startIndex As Integer, _
   ByVal length As Integer _
)
[C#]
public static void Copy(
   int source,
   float[] destination,
   int startIndex,
   int length
);
[C++]
public: static void Copy(
   int source,
   float* destination[],
   int startIndex,
   int length
);
[JScript]
public static function Copy(
   source : int,
   destination : float[],
   startIndex : int,
   length : int
);

Parameters

source
[To be supplied.]
destination
[To be supplied.]
startIndex
[To be supplied.]
length
[To be supplied.]

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.Copy Overload List


Marshal.Copy (Int32, Int64[], Int32, Int32)

Copies an array of int64s from native heap to managed heap.

[Visual Basic]
Overloads Public Shared Sub Copy( _
   ByVal source As Integer, _
   ByVal destination() As Long, _
   ByVal startIndex As Integer, _
   ByVal length As Integer _
)
[C#]
public static void Copy(
   int source,
   long[] destination,
   int startIndex,
   int length
);
[C++]
public: static void Copy(
   int source,
   __int64* destination[],
   int startIndex,
   int length
);
[JScript]
public static function Copy(
   source : int,
   destination : long[],
   startIndex : int,
   length : int
);

Parameters

source
Native array of int64s.
destination
Pointer to managed heap.
startIndex
Index within source at which copy is to start.
length
Number of int64s to copy.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.Copy Overload List


Marshal.Copy (Int32, Byte[], Int32, Int32)

Copies an array of unsigned chars from native heap to managed heap.

[Visual Basic]
Overloads Public Shared Sub Copy( _
   ByVal source As Integer, _
   ByVal destination() As Byte, _
   ByVal startIndex As Integer, _
   ByVal length As Integer _
)
[C#]
public static void Copy(
   int source,
   byte[] destination,
   int startIndex,
   int length
);
[C++]
public: static void Copy(
   int source,
   unsigned char* destination[],
   int startIndex,
   int length
);
[JScript]
public static function Copy(
   source : int,
   destination : Byte[],
   startIndex : int,
   length : int
);

Parameters

source
Native array of unsigned chars.
destination
Pointer to managed heap.
startIndex
Index within source at which copy is to start.
length
Number of unsigned chars to copy.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.Copy Overload List


Marshal.Copy (Int32, Double[], Int32, Int32)

Copies an array of doubles from native heap to managed heap.

[Visual Basic]
Overloads Public Shared Sub Copy( _
   ByVal source As Integer, _
   ByVal destination() As Double, _
   ByVal startIndex As Integer, _
   ByVal length As Integer _
)
[C#]
public static void Copy(
   int source,
   double[] destination,
   int startIndex,
   int length
);
[C++]
public: static void Copy(
   int source,
   double* destination[],
   int startIndex,
   int length
);
[JScript]
public static function Copy(
   source : int,
   destination : double[],
   startIndex : int,
   length : int
);

Parameters

source
Native array of doubles.
destination
Pointer to managed heap.
startIndex
Index within source at which copy is to start.
length
Number of doubles to copy.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.Copy Overload List


Marshal.Copy (Int32, Int32[], Int32, Int32)

Copies an array of int32s from native heap to managed heap.

[Visual Basic]
Overloads Public Shared Sub Copy( _
   ByVal source As Integer, _
   ByVal destination() As Integer, _
   ByVal startIndex As Integer, _
   ByVal length As Integer _
)
[C#]
public static void Copy(
   int source,
   int[] destination,
   int startIndex,
   int length
);
[C++]
public: static void Copy(
   int source,
   int* destination[],
   int startIndex,
   int length
);
[JScript]
public static function Copy(
   source : int,
   destination : int[],
   startIndex : int,
   length : int
);

Parameters

source
Native array of int32s.
destination
Pointer to managed heap.
startIndex
Index within source at which copy is to start.
length
Number of int32s to copy.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.Copy Overload List


Marshal.Copy (Int32, Char[], Int32, Int32)

Copies an array of wide characters from native heap to managed heap.

[Visual Basic]
Overloads Public Shared Sub Copy( _
   ByVal source As Integer, _
   ByVal destination() As Char, _
   ByVal startIndex As Integer, _
   ByVal length As Integer _
)
[C#]
public static void Copy(
   int source,
   char[] destination,
   int startIndex,
   int length
);
[C++]
public: static void Copy(
   int source,
   __wchar_t* destination[],
   int startIndex,
   int length
);
[JScript]
public static function Copy(
   source : int,
   destination : Char[],
   startIndex : int,
   length : int
);

Parameters

source
Native array of wide characters.
destination
Pointer to managed heap.
startIndex
Index within source at which copy is to start.
length
Number of wide characters to copy.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.Copy Overload List


Marshal.Copy (Int32, Int16[], Int32, Int32)

Copies an array of Int16s from native heap to managed heap.

[Visual Basic]
Overloads Public Shared Sub Copy( _
   ByVal source As Integer, _
   ByVal destination() As Short, _
   ByVal startIndex As Integer, _
   ByVal length As Integer _
)
[C#]
public static void Copy(
   int source,
   short[] destination,
   int startIndex,
   int length
);
[C++]
public: static void Copy(
   int source,
   short* destination[],
   int startIndex,
   int length
);
[JScript]
public static function Copy(
   source : int,
   destination : Int16[],
   startIndex : int,
   length : int
);

Parameters

source
Native array of Int16s.
destination
Pointer to managed heap.
startIndex
Index within source at which copy is to start.
length
Number of Int16s to copy.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.Copy Overload List


Marshal.CreateWrapperOfType

[To be supplied.]

[Visual Basic]
Public Shared Function CreateWrapperOfType( _
   ByVal o As Object, _
   ByVal t As Type _
) As Object
[C#]
public static object CreateWrapperOfType(
   object o,
   Type t
);
[C++]
public: static Object* CreateWrapperOfType(
   Object* o,
   Type* t
);
[JScript]
public static function CreateWrapperOfType(
   o : Object,
   t : Type
) : Object;

Parameters

o
[To be supplied.]
t
[To be supplied.]

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.DestroyStructure

Frees all substructures pointed to by the native memory block.

[Visual Basic]
Public Shared Sub DestroyStructure( _
   ByVal ptr As Integer, _
   ByVal structuretype As Type _
)
[C#]
public static void DestroyStructure(
   int ptr,
   Type structuretype
);
[C++]
public: static void DestroyStructure(
   int ptr,
   Type* structuretype
);
[JScript]
public static function DestroyStructure(
   ptr : int,
   structuretype : Type
);

Parameters

ptr
A pointer to an unmanaged block of memory.
structuretype
A Type object that represents a formatted class. This provides the layout information necessary to delete the buffer(s).

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.FreeCoTaskMem

Frees a block of memory allocated by the unmanaged COM task memory allocator.

[Visual Basic]
Public Shared Sub FreeCoTaskMem( _
   ByVal ptr As Integer _
)
[C#]
public static void FreeCoTaskMem(
   int ptr
);
[C++]
public: static void FreeCoTaskMem(
   int ptr
);
[JScript]
public static function FreeCoTaskMem(
   ptr : int
);

Parameters

ptr
Integer representation of the address of the memory to be freed.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.FreeHGlobal

Frees memory, previously allocated from from the process' unmanaged, native heap.

[Visual Basic]
Public Shared Sub FreeHGlobal( _
   ByVal hglobal As Integer _
)
[C#]
public static void FreeHGlobal(
   int hglobal
);
[C++]
public: static void FreeHGlobal(
   int hglobal
);
[JScript]
public static function FreeHGlobal(
   hglobal : int
);

Parameters

hglobal
The handle returned by the original, matching, call to AllocHGlobal.

Exceptions

Exception Type | Condition
System.Runtime.InteropServices.ArgumentException | if there is any failure.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.FreePinnedHandle

Unpins the object previously pinned against garbage reclamation and movement.

[Visual Basic]
Public Shared Sub FreePinnedHandle( _
   ByVal handleIndex As Integer _
)
[C#]
public static void FreePinnedHandle(
   int handleIndex
);
[C++]
public: static void FreePinnedHandle(
   int handleIndex
);
[JScript]
public static function FreePinnedHandle(
   handleIndex : int
);

Parameters

handleIndex
Handle obtained from previous call to GetPinnedHandle.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.GenerateGuidForType

[To be supplied.]

[Visual Basic]
Public Shared Function GenerateGuidForType( _
   ByVal type As Type _
) As Guid
[C#]
public static Guid GenerateGuidForType(
   Type type
);
[C++]
public: static Guid GenerateGuidForType(
   Type* type
);
[JScript]
public static function GenerateGuidForType(
   type : Type
) : Guid;

Parameters

type
[To be supplied.]

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.GetComInterfaceForObject

[To be supplied.]

[Visual Basic]
Public Shared Function GetComInterfaceForObject( _
   ByVal o As Object, _
   ByVal T As Type _
) As Integer
[C#]
public static int GetComInterfaceForObject(
   object o,
   Type T
);
[C++]
public: static int GetComInterfaceForObject(
   Object* o,
   Type* T
);
[JScript]
public static function GetComInterfaceForObject(
   o : Object,
   T : Type
) : int;

Parameters

o
[To be supplied.]
T
[To be supplied.]

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.GetExceptionCode

[To be supplied.]

[Visual Basic]
Public Shared Function GetExceptionCode( _
   ByVal e As Exception _
) As Integer
[C#]
public static int GetExceptionCode(
   Exception e
);
[C++]
public: static int GetExceptionCode(
   Exception* e
);
[JScript]
public static function GetExceptionCode(
   e : Exception
) : int;

Parameters

e
[To be supplied.]

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.GetExceptionPointers

[To be supplied.]

[Visual Basic]
Public Shared Function GetExceptionPointers( _
   ByVal e As Exception _
) As Integer
[C#]
public static int GetExceptionPointers(
   Exception e
);
[C++]
public: static int GetExceptionPointers(
   Exception* e
);
[JScript]
public static function GetExceptionPointers(
   e : Exception
) : int;

Parameters

e
[To be supplied.]

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.GetHINSTANCE

[To be supplied.]

[Visual Basic]
Public Shared Function GetHINSTANCE( _
   ByVal m As Module _
) As Integer
[C#]
public static int GetHINSTANCE(
   Module m
);
[C++]
public: static int GetHINSTANCE(
   Module* m
);
[JScript]
public static function GetHINSTANCE(
   m : Module
) : int;

Parameters

m
[To be supplied.]

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.GetIDispatchForObject

Returns an IDispatch interface from a managed object.

[Visual Basic]
Public Shared Function GetIDispatchForObject( _
   ByVal o As Object _
) As Integer
[C#]
public static int GetIDispatchForObject(
   object o
);
[C++]
public: static int GetIDispatchForObject(
   Object* o
);
[JScript]
public static function GetIDispatchForObject(
   o : Object
) : int;

Parameters

o
The object whose IDispatch interface is requested.

Return Value

The IDispatch* for an Object.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.GetITypeInfoForType

[To be supplied.]

[Visual Basic]
Public Shared Function GetITypeInfoForType( _
   ByVal t As Type _
) As Integer
[C#]
public static int GetITypeInfoForType(
   Type t
);
[C++]
public: static int GetITypeInfoForType(
   Type* t
);
[JScript]
public static function GetITypeInfoForType(
   t : Type
) : int;

Parameters

t
[To be supplied.]

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.GetIUnknownForObject

[To be supplied.]

[Visual Basic]
Public Shared Function GetIUnknownForObject( _
   ByVal o As Object _
) As Integer
[C#]
public static int GetIUnknownForObject(
   object o
);
[C++]
public: static int GetIUnknownForObject(
   Object* o
);
[JScript]
public static function GetIUnknownForObject(
   o : Object
) : int;

Parameters

o
[To be supplied.]

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.GetLastWin32Error

Returns the last error incurred by Win32 code executed via Marshal. Note that the target function must have had the setLastError metadata flag set-- how this is done varies depending upon the source language used.

[Visual Basic]
Public Shared Function GetLastWin32Error() As Integer
[C#]
public static int GetLastWin32Error();
[C++]
public: static int GetLastWin32Error();
[JScript]
public static function GetLastWin32Error() : int;

Return Value

Last Win32 error code.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.GetManagedThunkForUnmanagedMethodPtr

[To be supplied.]

[Visual Basic]
Public Shared Function GetManagedThunkForUnmanagedMethodPtr( _
   ByVal pfnMethodToWrap As Integer, _
   ByVal pbSignature As Integer, _
   ByVal cbSignature As Integer _
) As Integer
[C#]
public static int GetManagedThunkForUnmanagedMethodPtr(
   int pfnMethodToWrap,
   int pbSignature,
   int cbSignature
);
[C++]
public: static int GetManagedThunkForUnmanagedMethodPtr(
   int pfnMethodToWrap,
   int pbSignature,
   int cbSignature
);
[JScript]
public static function GetManagedThunkForUnmanagedMethodPtr(
   pfnMethodToWrap : int,
   pbSignature : int,
   cbSignature : int
) : int;

Parameters

pfnMethodToWrap
[To be supplied.]
pbSignature
[To be supplied.]
cbSignature
[To be supplied.]

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.GetNativeVariantForObject

[To be supplied.]

[Visual Basic]
Public Shared Sub GetNativeVariantForObject( _
   ByVal obj As Object, _
   ByVal pDstNativeVariant As Integer _
)
[C#]
public static void GetNativeVariantForObject(
   object obj,
   int pDstNativeVariant
);
[C++]
public: static void GetNativeVariantForObject(
   Object* obj,
   int pDstNativeVariant
);
[JScript]
public static function GetNativeVariantForObject(
   obj : Object,
   pDstNativeVariant : int
);

Parameters

obj
[To be supplied.]
pDstNativeVariant
[To be supplied.]

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.GetObjectForIUnknown

Returns an instance of System.Object that represents an unmanaged COM object that is specified by a pointer to its IUnknown interface.

[Visual Basic]
Public Shared Function GetObjectForIUnknown( _
   ByVal pUnk As Integer _
) As Object
[C#]
public static object GetObjectForIUnknown(
   int pUnk
);
[C++]
public: static Object* GetObjectForIUnknown(
   int pUnk
);
[JScript]
public static function GetObjectForIUnknown(
   pUnk : int
) : Object;

Parameters

pUnk
Integer representing a pointer to the IUnknown interface of the managed object to be returned.

Return Value

An instance of System.Object representing the specified unmanaged COM object.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.GetObjectForNativeVariant

[To be supplied.]

[Visual Basic]
Public Shared Function GetObjectForNativeVariant( _
   ByVal pSrcNativeVariant As Integer _
) As Object
[C#]
public static object GetObjectForNativeVariant(
   int pSrcNativeVariant
);
[C++]
public: static Object* GetObjectForNativeVariant(
   int pSrcNativeVariant
);
[JScript]
public static function GetObjectForNativeVariant(
   pSrcNativeVariant : int
) : Object;

Parameters

pSrcNativeVariant
[To be supplied.]

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.GetPinnedHandle

Pins the specified object to prevent it from being garbage collected or moved. (This called must be matched with a subsequent FreePinnedHandle)

[Visual Basic]
Public Shared Function GetPinnedHandle( _
   ByVal obj As Object _
) As Integer
[C#]
public static int GetPinnedHandle(
   object obj
);
[C++]
public: static int GetPinnedHandle(
   Object* obj
);
[JScript]
public static function GetPinnedHandle(
   obj : Object
) : int;

Parameters

obj
Managed object to be pinned.

Return Value

A handle on the pinned object.

Exceptions

Exception Type | Condition
System.Runtime.InteropServices.ArgumentException | if obj is not an array of primitive types.
System.Runtime.InteropServices.NullReferenceException | if obj is null.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.GetPinnedObject

Returns the object, previously pinned against garbage collection and movement by a call to GetPinnedHandle.

[Visual Basic]
Public Shared Function GetPinnedObject( _
   ByVal handleIndex As Integer _
) As Object
[C#]
public static object GetPinnedObject(
   int handleIndex
);
[C++]
public: static Object* GetPinnedObject(
   int handleIndex
);
[JScript]
public static function GetPinnedObject(
   handleIndex : int
) : Object;

Parameters

handleIndex
Handle returned by previous call to GetPinnedHandle for this object.

Return Value

Previously-pinned object.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.GetTypedObjectForIUnknown

Returns a managed object of a specified type that represents an unmanaged COM object. NOTE: Type T should be either a COM-imported Type or a sub-type of a COM-imported Type.

[Visual Basic]
Public Shared Function GetTypedObjectForIUnknown( _
   ByVal pUnk As Integer, _
   ByVal T As Type _
) As Object
[C#]
public static object GetTypedObjectForIUnknown(
   int pUnk,
   Type T
);
[C++]
public: static Object* GetTypedObjectForIUnknown(
   int pUnk,
   Type* T
);
[JScript]
public static function GetTypedObjectForIUnknown(
   pUnk : int,
   T : Type
) : Object;

Parameters

pUnk
Integer representing a pointer to the IUnknown interface of the unmanaged COM object.
T
Type object corresponding to the type of the managed class requested.

Return Value

An instance of the class corresponding to the Type object that represents the requested unmanaged COM object.

Remarks

The type represented by T must be a type whose metadata was imported by TLBIMP.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.GetTypeForITypeInfo

Creates a TypeInfo/Type marshaler and passes the provided ITypeInfo to the marshaler. The marshaler then delegates the calls on the Type object to the underlying ITypeInfo interface.

[Visual Basic]
Public Shared Function GetTypeForITypeInfo( _
   ByVal piTypeInfo As Integer _
) As Type
[C#]
public static Type GetTypeForITypeInfo(
   int piTypeInfo
);
[C++]
public: static Type* GetTypeForITypeInfo(
   int piTypeInfo
);
[JScript]
public static function GetTypeForITypeInfo(
   piTypeInfo : int
) : Type;

Parameters

piTypeInfo
The ITypeInfo interface to be marshaled.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.GetTypeInfoName

[To be supplied.]

[Visual Basic]
Public Shared Function GetTypeInfoName( _
   ByVal pTI As UCOMITypeInfo _
) As String
[C#]
public static string GetTypeInfoName(
   UCOMITypeInfo pTI
);
[C++]
public: static String* GetTypeInfoName(
   UCOMITypeInfo* pTI
);
[JScript]
public static function GetTypeInfoName(
   pTI : UCOMITypeInfo
) : String;

Parameters

pTI
[To be supplied.]

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.GetTypeLibName

[To be supplied.]

[Visual Basic]
Public Shared Function GetTypeLibName( _
   ByVal pTLB As UCOMITypeLib _
) As String
[C#]
public static string GetTypeLibName(
   UCOMITypeLib pTLB
);
[C++]
public: static String* GetTypeLibName(
   UCOMITypeLib* pTLB
);
[JScript]
public static function GetTypeLibName(
   pTLB : UCOMITypeLib
) : String;

Parameters

pTLB
[To be supplied.]

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.GetUnmanagedThunkForManagedMethodPtr

[To be supplied.]

[Visual Basic]
Public Shared Function GetUnmanagedThunkForManagedMethodPtr( _
   ByVal pfnMethodToWrap As Integer, _
   ByVal pbSignature As Integer, _
   ByVal cbSignature As Integer _
) As Integer
[C#]
public static int GetUnmanagedThunkForManagedMethodPtr(
   int pfnMethodToWrap,
   int pbSignature,
   int cbSignature
);
[C++]
public: static int GetUnmanagedThunkForManagedMethodPtr(
   int pfnMethodToWrap,
   int pbSignature,
   int cbSignature
);
[JScript]
public static function GetUnmanagedThunkForManagedMethodPtr(
   pfnMethodToWrap : int,
   pbSignature : int,
   cbSignature : int
) : int;

Parameters

pfnMethodToWrap
[To be supplied.]
pbSignature
[To be supplied.]
cbSignature
[To be supplied.]

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.IsComObject

Indicates whether a specified object represents an unmanaged COM object.

[Visual Basic]
Public Shared Function IsComObject( _
   ByVal o As Object _
) As Boolean
[C#]
public static bool IsComObject(
   object o
);
[C++]
public: static bool IsComObject(
   Object* o
);
[JScript]
public static function IsComObject(
   o : Object
) : Boolean;

Parameters

o
The object to be checked.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.IsTypeVisibleFromCom

[To be supplied.]

[Visual Basic]
Public Shared Function IsTypeVisibleFromCom( _
   ByVal t As Type _
) As Boolean
[C#]
public static bool IsTypeVisibleFromCom(
   Type t
);
[C++]
public: static bool IsTypeVisibleFromCom(
   Type* t
);
[JScript]
public static function IsTypeVisibleFromCom(
   t : Type
) : Boolean;

Parameters

t
[To be supplied.]

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.NumParamBytes

Calculate the number of bytes required to hold the parameters for the specified method.

[Visual Basic]
Public Shared Function NumParamBytes( _
   ByVal m As MethodInfo _
) As Integer
[C#]
public static int NumParamBytes(
   MethodInfo m
);
[C++]
public: static int NumParamBytes(
   MethodInfo* m
);
[JScript]
public static function NumParamBytes(
   m : MethodInfo
) : int;

Parameters

m
Method to be checked.

Return Value

Number of bytes required.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.OffsetOf

Returns the byte offset for a field within a class used by Marshal.

[Visual Basic]
Public Shared Function OffsetOf( _
   ByVal t As Type, _
   ByVal fieldName As String _
) As Integer
[C#]
public static int OffsetOf(
   Type t,
   string fieldName
);
[C++]
public: static int OffsetOf(
   Type* t,
   String* fieldName
);
[JScript]
public static function OffsetOf(
   t : Type,
   fieldName : String
) : int;

Parameters

t
[To be supplied.]
fieldName
Field within class.

Return Value

Offset in bytes, for fieldname within the PInvoke-declared class c.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.Prelink

Checks that the native method m is type-compatible with the corresponding managed declaration. (This action is performed automatically when the target method is invoked anyway.)

[Visual Basic]
Public Shared Sub Prelink( _
   ByVal m As MethodInfo _
)
[C#]
public static void Prelink(
   MethodInfo m
);
[C++]
public: static void Prelink(
   MethodInfo* m
);
[JScript]
public static function Prelink(
   m : MethodInfo
);

Parameters

m
Method to be checked.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.PrelinkAll

Performs a Prelink check for all methods on a class.

[Visual Basic]
Public Shared Sub PrelinkAll( _
   ByVal c As Type _
)
[C#]
public static void PrelinkAll(
   Type c
);
[C++]
public: static void PrelinkAll(
   Type* c
);
[JScript]
public static function PrelinkAll(
   c : Type
);

Parameters

c
Class whose methods are to be checked.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.PtrToStringAnsi

Copies all or part of an ANSI string, stored in native heap, to a managed String object.

Overload List

Copies a specified number of characters from an ANSI string, stored in native heap, to a managed String object. Widens each ASCII character to UNICODE.

[Visual Basic] Overloads Public Shared Function PtrToStringAnsi(Integer, Integer) As String
[C#] public static string PtrToStringAnsi(int, int);
[C++] public: static String* PtrToStringAnsi(int, int);
[JScript] public static function PtrToStringAnsi(int, int) : String;

Copies an ANSI string, stored in native heap, to a managed String object. Widens each ASCII character to UNICODE.

[Visual Basic] Overloads Public Shared Function PtrToStringAnsi(Integer) As String
[C#] public static string PtrToStringAnsi(int);
[C++] public: static String* PtrToStringAnsi(int);
[JScript] public static function PtrToStringAnsi(int) : String;

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.PtrToStringAnsi (Int32, Int32)

Copies a specified number of characters from an ANSI string, stored in native heap, to a managed String object. Widens each ASCII character to UNICODE.

[Visual Basic]
Overloads Public Shared Function PtrToStringAnsi( _
   ByVal ptr As Integer, _
   ByVal len As Integer _
) As String
[C#]
public static string PtrToStringAnsi(
   int ptr,
   int len
);
[C++]
public: static String* PtrToStringAnsi(
   int ptr,
   int len
);
[JScript]
public static function PtrToStringAnsi(
   ptr : int,
   len : int
) : String;

Parameters

ptr
Address in native heap of source string.
len
Number of ASCII characters to copy.

Return Value

Managed String object, holding a copy of the native, ANSI string.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.PtrToStringAnsi Overload List


Marshal.PtrToStringAnsi (Int32)

Copies an ANSI string, stored in native heap, to a managed String object. Widens each ASCII character to UNICODE.

[Visual Basic]
Overloads Public Shared Function PtrToStringAnsi( _
   ByVal ptr As Integer _
) As String
[C#]
public static string PtrToStringAnsi(
   int ptr
);
[C++]
public: static String* PtrToStringAnsi(
   int ptr
);
[JScript]
public static function PtrToStringAnsi(
   ptr : int
) : String;

Parameters

ptr
Address in native heap of source string.

Return Value

Managed String object, holding a copy of the native, ANSI string.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.PtrToStringAnsi Overload List


Marshal.PtrToStringAuto

Copies all or part of a string, stored in native heap, to a managed String object.

Overload List

Copies a specified number of characters from a string, stored in native heap, to a managed String object. Widens each ASCII character to UNICODE, if required. (If current platform is UNICODE, calls to PtrToStringUni else calls PtrToStringAnsi)

[Visual Basic] Overloads Public Shared Function PtrToStringAuto(Integer, Integer) As String
[C#] public static string PtrToStringAuto(int, int);
[C++] public: static String* PtrToStringAuto(int, int);
[JScript] public static function PtrToStringAuto(int, int) : String;

Copies a string, stored in native heap, to a managed String object. Automatically widens each ASCII character to UNICODE, if required. (If current platform is UNICODE, calls to PtrToStringUni else calls PtrToStringAnsi)

[Visual Basic] Overloads Public Shared Function PtrToStringAuto(Integer) As String
[C#] public static string PtrToStringAuto(int);
[C++] public: static String* PtrToStringAuto(int);
[JScript] public static function PtrToStringAuto(int) : String;

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.PtrToStringAuto (Int32, Int32)

Copies a specified number of characters from a string, stored in native heap, to a managed String object. Widens each ASCII character to UNICODE, if required. (If current platform is UNICODE, calls to PtrToStringUni else calls PtrToStringAnsi)

[Visual Basic]
Overloads Public Shared Function PtrToStringAuto( _
   ByVal ptr As Integer, _
   ByVal len As Integer _
) As String
[C#]
public static string PtrToStringAuto(
   int ptr,
   int len
);
[C++]
public: static String* PtrToStringAuto(
   int ptr,
   int len
);
[JScript]
public static function PtrToStringAuto(
   ptr : int,
   len : int
) : String;

Parameters

ptr
Address in native heap of source string
len
Number of characters to copy

Return Value

Managed String object, holding a copy of the native string.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.PtrToStringAuto Overload List


Marshal.PtrToStringAuto (Int32)

Copies a string, stored in native heap, to a managed String object. Automatically widens each ASCII character to UNICODE, if required. (If current platform is UNICODE, calls to PtrToStringUni else calls PtrToStringAnsi)

[Visual Basic]
Overloads Public Shared Function PtrToStringAuto( _
   ByVal ptr As Integer _
) As String
[C#]
public static string PtrToStringAuto(
   int ptr
);
[C++]
public: static String* PtrToStringAuto(
   int ptr
);
[JScript]
public static function PtrToStringAuto(
   ptr : int
) : String;

Parameters

ptr
Address in native heap of source string.

Return Value

Managed String object, holding a copy of the native string.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.PtrToStringAuto Overload List


Marshal.PtrToStringUni

Copies part or all of a UNICODE string, stored in native heap, to a managed String object.

Overload List

Copies a specified number of characters from a UNICODE string, stored in native heap, to a managed String object.

[Visual Basic] Overloads Public Shared Function PtrToStringUni(Integer, Integer) As String
[C#] public static string PtrToStringUni(int, int);
[C++] public: static String* PtrToStringUni(int, int);
[JScript] public static function PtrToStringUni(int, int) : String;

Copies a UNICODE string, stored in native heap, to a managed String object.

[Visual Basic] Overloads Public Shared Function PtrToStringUni(Integer) As String
[C#] public static string PtrToStringUni(int);
[C++] public: static String* PtrToStringUni(int);
[JScript] public static function PtrToStringUni(int) : String;

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.PtrToStringUni (Int32, Int32)

Copies a specified number of characters from a UNICODE string, stored in native heap, to a managed String object.

[Visual Basic]
Overloads Public Shared Function PtrToStringUni( _
   ByVal ptr As Integer, _
   ByVal len As Integer _
) As String
[C#]
public static string PtrToStringUni(
   int ptr,
   int len
);
[C++]
public: static String* PtrToStringUni(
   int ptr,
   int len
);
[JScript]
public static function PtrToStringUni(
   ptr : int,
   len : int
) : String;

Parameters

ptr
Address in native heap of source string
len
Number of UNICODE characters to copy

Return Value

Managed String object, holding a copy of the native string.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.PtrToStringUni Overload List


Marshal.PtrToStringUni (Int32)

Copies a UNICODE string, stored in native heap, to a managed String object.

[Visual Basic]
Overloads Public Shared Function PtrToStringUni( _
   ByVal ptr As Integer _
) As String
[C#]
public static string PtrToStringUni(
   int ptr
);
[C++]
public: static String* PtrToStringUni(
   int ptr
);
[JScript]
public static function PtrToStringUni(
   ptr : int
) : String;

Parameters

ptr
Address in native heap of source string

Return Value

Managed String object, holding a copy of the native string.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.PtrToStringUni Overload List


Marshal.PtrToStructure

Marshals data from an unmanaged block of memory to a managed object.

Overload List

Marshals data from an unmanaged block of memory to a newly allocated object of the specified type.

[Visual Basic] Overloads Public Shared Function PtrToStructure(Integer, Type) As Object
[C#] public static object PtrToStructure(int, Type);
[C++] public: static Object* PtrToStructure(int, Type);
[JScript] public static function PtrToStructure(int, Type) : Object;

Marshals data from an unmanaged block of memory pointed to a managed object. The object must be an instance of a formatted class (structure class).

[Visual Basic] Overloads Public Shared Sub PtrToStructure(Integer, Object)
[C#] public static void PtrToStructure(int, Object);
[C++] public: static void PtrToStructure(int, Object);
[JScript] public static function PtrToStructure(int, Object);

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.PtrToStructure (Int32, Type)

Marshals data from an unmanaged block of memory to a newly allocated object of the specified type.

[Visual Basic]
Overloads Public Shared Function PtrToStructure( _
   ByVal ptr As Integer, _
   ByVal structuretype As Type _
) As Object
[C#]
public static object PtrToStructure(
   int ptr,
   Type structuretype
);
[C++]
public: static Object* PtrToStructure(
   int ptr,
   Type* structuretype
);
[JScript]
public static function PtrToStructure(
   ptr : int,
   structuretype : Type
) : Object;

Parameters

ptr
A pointer to an unmanaged block of memory.
structuretype
A Type object representing the type of object to be created. This Type object must represent a formatted class.

Return Value

A managed object containing the data pointed to by ptr.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.PtrToStructure Overload List


Marshal.PtrToStructure (Int32, Object)

Marshals data from an unmanaged block of memory pointed to a managed object. The object must be an instance of a formatted class (structure class).

[Visual Basic]
Overloads Public Shared Sub PtrToStructure( _
   ByVal ptr As Integer, _
   ByVal structure As Object _
)
[C#]
public static void PtrToStructure(
   int ptr,
   object structure
);
[C++]
public: static void PtrToStructure(
   int ptr,
   Object* structure
);
[JScript]
public static function PtrToStructure(
   ptr : int,
   structure : Object
);

Parameters

ptr
A pointer to an unmanaged block of memory.
structure
[To be supplied.]

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.PtrToStructure Overload List


Marshal.QueryInterface

Requests a pointer to a specified interface on an unmanaged COM object.

[Visual Basic]
Public Shared Function QueryInterface( _
   ByVal pUnk As Integer, _
   ByRef iid As Guid, _
   ByRef ppv As Integer _
) As Integer
[C#]
public static int QueryInterface(
   int pUnk,
   ref Guid iid,
   ref int ppv
);
[C++]
public: static int QueryInterface(
   int pUnk,
   Guid** iid,
   int** ppv
);
[JScript]
public static function QueryInterface(
   pUnk : int,
   iid : Guid,
   ppv : int
) : int;

Parameters

pUnk
[To be supplied.]
iid
[To be supplied.]
ppv
[To be supplied.]

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.ReadByte

Reads a single byte from native heap

Overload List

Reads a single byte from native heap

[Visual Basic] Overloads Public Shared Function ReadByte(Integer) As Byte
[C#] public static byte ReadByte(int);
[C++] public: static unsigned char ReadByte(int);
[JScript] public static function ReadByte(int) : Byte;

Reads a single byte from native heap

[Visual Basic] Overloads extern Public Shared Function ReadByte(Integer, Integer) As Byte
[C#] public static extern byte ReadByte(int, int);
[C++] public: static extern unsigned char ReadByte(int, int);
[JScript] public static extern function ReadByte(int, int) : Byte;

Reads a single byte from native heap

[Visual Basic] Overloads extern Public Shared Function ReadByte(Object, Integer) As Byte
[C#] public static extern byte ReadByte(Object, int);
[C++] public: static extern unsigned char ReadByte(Object, int);
[JScript] public static extern function ReadByte(Object, int) : Byte;

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.ReadByte (Int32)

Reads a single byte from native heap

[Visual Basic]
Overloads Public Shared Function ReadByte( _
   ByVal ptr As Integer _
) As Byte
[C#]
public static byte ReadByte(
   int ptr
);
[C++]
public: static unsigned char ReadByte(
   int ptr
);
[JScript]
public static function ReadByte(
   ptr : int
) : Byte;

Parameters

ptr
Address in native heap from which to read.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.ReadByte Overload List


Marshal.ReadByte (Int32, Int32)

Reads a single byte from native heap

[Visual Basic]
Overloads extern Public Shared Function ReadByte( _
   ByVal ptr As Integer, _
   ByVal ofs As Integer _
) As Byte
[C#]
public static extern byte ReadByte(
   int ptr,
   int ofs
);
[C++]
public: static extern unsigned char ReadByte(
   int ptr,
   int ofs
);
[JScript]
public static extern function ReadByte(
   ptr : int,
   ofs : int
) : Byte;

Parameters

ptr
Base address in native heap from which to read.
ofs
Additional byte offset, added to ptr before reading.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.ReadByte Overload List


Marshal.ReadByte (Object, Int32)

Reads a single byte from native heap

[Visual Basic]
Overloads extern Public Shared Function ReadByte( _
   ByVal ptr As Object, _
   ByVal ofs As Integer _
) As Byte
[C#]
public static extern byte ReadByte(
   in object ptr,
   int ofs
);
[C++]
public: static extern unsigned char ReadByte(
   __in Object* ptr,
   int ofs
);
[JScript]
public static extern function ReadByte(
   in ptr : Object,
   ofs : int
) : Byte;

Parameters

ptr
Base address in native heap of source object.
ofs
Additional byte offset, added to ptr before reading.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.ReadByte Overload List


Marshal.ReadInt16

Reads a 16-bit integer from native heap

Overload List

Reads a 16-bit integer from native heap

[Visual Basic] Overloads Public Shared Function ReadInt16(Integer) As Short
[C#] public static short ReadInt16(int);
[C++] public: static short ReadInt16(int);
[JScript] public static function ReadInt16(int) : Int16;

Reads a 16-bit integer from native heap.

[Visual Basic] Overloads extern Public Shared Function ReadInt16(Integer, Integer) As Short
[C#] public static extern short ReadInt16(int, int);
[C++] public: static extern short ReadInt16(int, int);
[JScript] public static extern function ReadInt16(int, int) : Int16;

Reads a 16-bit integer from native heap.

[Visual Basic] Overloads extern Public Shared Function ReadInt16(Object, Integer) As Short
[C#] public static extern short ReadInt16(Object, int);
[C++] public: static extern short ReadInt16(Object, int);
[JScript] public static extern function ReadInt16(Object, int) : Int16;

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.ReadInt16 (Int32)

Reads a 16-bit integer from native heap

[Visual Basic]
Overloads Public Shared Function ReadInt16( _
   ByVal ptr As Integer _
) As Short
[C#]
public static short ReadInt16(
   int ptr
);
[C++]
public: static short ReadInt16(
   int ptr
);
[JScript]
public static function ReadInt16(
   ptr : int
) : Int16;

Parameters

ptr
Address in native heap from which to read.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.ReadInt16 Overload List


Marshal.ReadInt16 (Int32, Int32)

Reads a 16-bit integer from native heap.

[Visual Basic]
Overloads extern Public Shared Function ReadInt16( _
   ByVal ptr As Integer, _
   ByVal ofs As Integer _
) As Short
[C#]
public static extern short ReadInt16(
   int ptr,
   int ofs
);
[C++]
public: static extern short ReadInt16(
   int ptr,
   int ofs
);
[JScript]
public static extern function ReadInt16(
   ptr : int,
   ofs : int
) : Int16;

Parameters

ptr
Base address in native heap from which to read.
ofs
Additional byte offset, added to ptr before reading.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.ReadInt16 Overload List


Marshal.ReadInt16 (Object, Int32)

Reads a 16-bit integer from native heap.

[Visual Basic]
Overloads extern Public Shared Function ReadInt16( _
   ByVal ptr As Object, _
   ByVal ofs As Integer _
) As Short
[C#]
public static extern short ReadInt16(
   in object ptr,
   int ofs
);
[C++]
public: static extern short ReadInt16(
   __in Object* ptr,
   int ofs
);
[JScript]
public static extern function ReadInt16(
   in ptr : Object,
   ofs : int
) : Int16;

Parameters

ptr
Base address in native heap of source object
ofs
Additional byte offset, added to ptr before reading

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.ReadInt16 Overload List


Marshal.ReadInt32

Reads a 32-bit integer from native heap.

Overload List

Reads a 32-bit integer from native heap.

[Visual Basic] Overloads extern Public Shared Function ReadInt32(Object, Integer) As Integer
[C#] public static extern int ReadInt32(Object, int);
[C++] public: static extern int ReadInt32(Object, int);
[JScript] public static extern function ReadInt32(Object, int) : int;

Reads a 32-bit integer from native heap.

[Visual Basic] Overloads extern Public Shared Function ReadInt32(Integer, Integer) As Integer
[C#] public static extern int ReadInt32(int, int);
[C++] public: static extern int ReadInt32(int, int);
[JScript] public static extern function ReadInt32(int, int) : int;

Reads a 32-bit integer from native heap.

[Visual Basic] Overloads Public Shared Function ReadInt32(Integer) As Integer
[C#] public static int ReadInt32(int);
[C++] public: static int ReadInt32(int);
[JScript] public static function ReadInt32(int) : int;

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.ReadInt32 (Object, Int32)

Reads a 32-bit integer from native heap.

[Visual Basic]
Overloads extern Public Shared Function ReadInt32( _
   ByVal ptr As Object, _
   ByVal ofs As Integer _
) As Integer
[C#]
public static extern int ReadInt32(
   in object ptr,
   int ofs
);
[C++]
public: static extern int ReadInt32(
   __in Object* ptr,
   int ofs
);
[JScript]
public static extern function ReadInt32(
   in ptr : Object,
   ofs : int
) : int;

Parameters

ptr
Base address in native heap of source object.
ofs
Additional byte offset, added to ptr before reading.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.ReadInt32 Overload List


Marshal.ReadInt32 (Int32, Int32)

Reads a 32-bit integer from native heap.

[Visual Basic]
Overloads extern Public Shared Function ReadInt32( _
   ByVal ptr As Integer, _
   ByVal ofs As Integer _
) As Integer
[C#]
public static extern int ReadInt32(
   int ptr,
   int ofs
);
[C++]
public: static extern int ReadInt32(
   int ptr,
   int ofs
);
[JScript]
public static extern function ReadInt32(
   ptr : int,
   ofs : int
) : int;

Parameters

ptr
Base address in native heap from which to read.
ofs
Additional byte offset, added to ptr before reading.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.ReadInt32 Overload List


Marshal.ReadInt32 (Int32)

Reads a 32-bit integer from native heap.

[Visual Basic]
Overloads Public Shared Function ReadInt32( _
   ByVal ptr As Integer _
) As Integer
[C#]
public static int ReadInt32(
   int ptr
);
[C++]
public: static int ReadInt32(
   int ptr
);
[JScript]
public static function ReadInt32(
   ptr : int
) : int;

Parameters

ptr
Address in native heap from which to read.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.ReadInt32 Overload List


Marshal.ReadInt64

Reads a 64-bit integer from native heap.

Overload List

Reads a 64-bit integer from native heap.

[Visual Basic] Overloads extern Public Shared Function ReadInt64(Object, Integer) As Long
[C#] public static extern long ReadInt64(Object, int);
[C++] public: static extern __int64 ReadInt64(Object, int);
[JScript] public static extern function ReadInt64(Object, int) : long;

Reads a 64-bit integer from native heap.

[Visual Basic] Overloads Public Shared Function ReadInt64(Integer) As Long
[C#] public static long ReadInt64(int);
[C++] public: static __int64 ReadInt64(int);
[JScript] public static function ReadInt64(int) : long;

Reads a 64-bit integer from native heap.

[Visual Basic] Overloads extern Public Shared Function ReadInt64(Integer, Integer) As Long
[C#] public static extern long ReadInt64(int, int);
[C++] public: static extern __int64 ReadInt64(int, int);
[JScript] public static extern function ReadInt64(int, int) : long;

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.ReadInt64 (Object, Int32)

Reads a 64-bit integer from native heap.

[Visual Basic]
Overloads extern Public Shared Function ReadInt64( _
   ByVal ptr As Object, _
   ByVal ofs As Integer _
) As Long
[C#]
public static extern long ReadInt64(
   in object ptr,
   int ofs
);
[C++]
public: static extern __int64 ReadInt64(
   __in Object* ptr,
   int ofs
);
[JScript]
public static extern function ReadInt64(
   in ptr : Object,
   ofs : int
) : long;

Parameters

ptr
Base address in native heap of source object.
ofs
Additional byte offset, added to ptr before reading.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.ReadInt64 Overload List


Marshal.ReadInt64 (Int32)

Reads a 64-bit integer from native heap.

[Visual Basic]
Overloads Public Shared Function ReadInt64( _
   ByVal ptr As Integer _
) As Long
[C#]
public static long ReadInt64(
   int ptr
);
[C++]
public: static __int64 ReadInt64(
   int ptr
);
[JScript]
public static function ReadInt64(
   ptr : int
) : long;

Parameters

ptr
Address in native heap from which to read.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.ReadInt64 Overload List


Marshal.ReadInt64 (Int32, Int32)

Reads a 64-bit integer from native heap.

[Visual Basic]
Overloads extern Public Shared Function ReadInt64( _
   ByVal ptr As Integer, _
   ByVal ofs As Integer _
) As Long
[C#]
public static extern long ReadInt64(
   int ptr,
   int ofs
);
[C++]
public: static extern __int64 ReadInt64(
   int ptr,
   int ofs
);
[JScript]
public static extern function ReadInt64(
   ptr : int,
   ofs : int
) : long;

Parameters

ptr
Base address in native heap from which to read.
ofs
Additional byte offset, added to ptr before reading.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.ReadInt64 Overload List


Marshal.ReAllocCoTaskMem

[To be supplied.]

[Visual Basic]
Public Shared Function ReAllocCoTaskMem( _
   ByVal pv As Integer, _
   ByVal cb As Integer _
) As Integer
[C#]
public static int ReAllocCoTaskMem(
   int pv,
   int cb
);
[C++]
public: static int ReAllocCoTaskMem(
   int pv,
   int cb
);
[JScript]
public static function ReAllocCoTaskMem(
   pv : int,
   cb : int
) : int;

Parameters

pv
[To be supplied.]
cb
[To be supplied.]

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.ReAllocHGlobal

[To be supplied.]

[Visual Basic]
Public Shared Function ReAllocHGlobal( _
   ByVal pv As Integer, _
   ByVal cb As Integer _
) As Integer
[C#]
public static int ReAllocHGlobal(
   int pv,
   int cb
);
[C++]
public: static int ReAllocHGlobal(
   int pv,
   int cb
);
[JScript]
public static function ReAllocHGlobal(
   pv : int,
   cb : int
) : int;

Parameters

pv
[To be supplied.]
cb
[To be supplied.]

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.Release

Decrements the reference count on a specified unmanaged COM interface.

[Visual Basic]
Public Shared Function Release( _
   ByVal pUnk As Integer _
) As Integer
[C#]
public static int Release(
   int pUnk
);
[C++]
public: static int Release(
   int pUnk
);
[JScript]
public static function Release(
   pUnk : int
) : int;

Parameters

pUnk
[To be supplied.]

Return Value

[To be supplied.]

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.ReleaseComObject

Releases the COM component and, if the reference hits 0, zombies this object. Further usage of this object might throw an exception.

[Visual Basic]
Public Shared Function ReleaseComObject( _
   ByVal o As Object _
) As Integer
[C#]
public static int ReleaseComObject(
   object o
);
[C++]
public: static int ReleaseComObject(
   Object* o
);
[JScript]
public static function ReleaseComObject(
   o : Object
) : int;

Parameters

o
[To be supplied.]

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.ReleaseThreadCache

Forces the aggressive release of the current thread's cache. There may be a thread-based cache of COM components.

[Visual Basic]
Public Shared Sub ReleaseThreadCache()
[C#]
public static void ReleaseThreadCache();
[C++]
public: static void ReleaseThreadCache();
[JScript]
public static function ReleaseThreadCache();

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.SizeOf

Returns the size, in bytes, of a class used via Marshal.

Overload List

Returns the size, in bytes, of a class used via PInvoke as an argument to a native function

[Visual Basic] Overloads Public Shared Function SizeOf(Object) As Integer
[C#] public static int SizeOf(Object);
[C++] public: static int SizeOf(Object*);
[JScript] public static function SizeOf(Object) : int;

[To be supplied.]

[Visual Basic] Overloads Public Shared Function SizeOf(Type) As Integer
[C#] public static int SizeOf(Type);
[C++] public: static int SizeOf(Type*);
[JScript] public static function SizeOf(Type) : int;

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.SizeOf (Object)

Returns the size, in bytes, of a class used via PInvoke as an argument to a native function

[Visual Basic]
Overloads Public Shared Function SizeOf( _
   ByVal structure As Object _
) As Integer
[C#]
public static int SizeOf(
   object structure
);
[C++]
public: static int SizeOf(
   Object* structure
);
[JScript]
public static function SizeOf(
   structure : Object
) : int;

Parameters

structure
[To be supplied.]

Return Value

Size of specified object.

Exceptions

Exception Type | Condition
System.Runtime.InteropServices.ArgumentException | if cls is not a Marshal Class.
System.Runtime.InteropServices.NullReferenceException | if cls is null.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.SizeOf Overload List


Marshal.SizeOf (Type)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Function SizeOf( _
   ByVal t As Type _
) As Integer
[C#]
public static int SizeOf(
   Type t
);
[C++]
public: static int SizeOf(
   Type* t
);
[JScript]
public static function SizeOf(
   t : Type
) : int;

Parameters

t
[To be supplied.]

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.SizeOf Overload List


Marshal.StringToCoTaskMemAnsi

Copies the contents of a string to block of memory allocated from the unmanaged COM task allocator. The characters of the string are copied as ANSI characters.

[Visual Basic]
Public Shared Function StringToCoTaskMemAnsi( _
   ByVal s As String _
) As Integer
[C#]
public static int StringToCoTaskMemAnsi(
   string s
);
[C++]
public: static int StringToCoTaskMemAnsi(
   String* s
);
[JScript]
public static function StringToCoTaskMemAnsi(
   s : String
) : int;

Parameters

s
[To be supplied.]

Return Value

An integer representing a pointer to the block of memory allocated for the string.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.StringToCoTaskMemAuto

Copies the contents of a string to a block of memory allocated from the unmanaged COM task allocator. The characters of the string are copied as either ANSI or Unicode characters, depending on the operating system where the code is executing. On Windows 95 or Windows 98, the characters are copied as ANSI characters. On Windows NT 4.0 or Windows 2000, the characters are copied as Unicode characters.

[Visual Basic]
Public Shared Function StringToCoTaskMemAuto( _
   ByVal s As String _
) As Integer
[C#]
public static int StringToCoTaskMemAuto(
   string s
);
[C++]
public: static int StringToCoTaskMemAuto(
   String* s
);
[JScript]
public static function StringToCoTaskMemAuto(
   s : String
) : int;

Parameters

s
[To be supplied.]

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.StringToCoTaskMemUni

Copies the contents of a string to block of memory allocated from the unmanaged COM task allocator. The characters of the string are copied as Unicode characters.

[Visual Basic]
Public Shared Function StringToCoTaskMemUni( _
   ByVal s As String _
) As Integer
[C#]
public static int StringToCoTaskMemUni(
   string s
);
[C++]
public: static int StringToCoTaskMemUni(
   String* s
);
[JScript]
public static function StringToCoTaskMemUni(
   s : String
) : int;

Parameters

s
[To be supplied.]

Return Value

An integer representing a pointer to the block of memory allocated for the string.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.StringToHGlobalAnsi

Copies the contents of a managed String object into native heap, converting into ASCII format on-the-fly. The method allocates the required, native heap memory.

[Visual Basic]
Public Shared Function StringToHGlobalAnsi( _
   ByVal s As String _
) As Integer
[C#]
public static int StringToHGlobalAnsi(
   string s
);
[C++]
public: static int StringToHGlobalAnsi(
   String* s
);
[JScript]
public static function StringToHGlobalAnsi(
   s : String
) : int;

Parameters

s
Managed String object to be copied.

Return Value

Address, in native heap, to where the string was copied.

Exceptions

Exception Type | Condition
System.Runtime.InteropServices.OutOfMemoryException | if the method could not allocate enough native heap memory

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.StringToHGlobalAuto

Copies the contents of a managed String object into native heap, converting into ASCII format on-the-fly if required. The method allocates the required, native heap memory.

[Visual Basic]
Public Shared Function StringToHGlobalAuto( _
   ByVal s As String _
) As Integer
[C#]
public static int StringToHGlobalAuto(
   string s
);
[C++]
public: static int StringToHGlobalAuto(
   String* s
);
[JScript]
public static function StringToHGlobalAuto(
   s : String
) : int;

Parameters

s
Managed String object to be copied.

Return Value

Address, in native heap, to where the string was copied.

Exceptions

Exception Type | Condition
System.Runtime.InteropServices.OutOfMemoryException | if the method could not allocate enough native heap memory.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.StringToHGlobalUni

Copies the contents of a managed String object into native heap. (source and destination are both UNICODE). The method allocates the required, native heap memory.

[Visual Basic]
Public Shared Function StringToHGlobalUni( _
   ByVal s As String _
) As Integer
[C#]
public static int StringToHGlobalUni(
   string s
);
[C++]
public: static int StringToHGlobalUni(
   String* s
);
[JScript]
public static function StringToHGlobalUni(
   s : String
) : int;

Parameters

s
Managed String object to be copied.

Return Value

Address, in native heap, to where the string was copied

Exceptions

Exception Type | Condition
System.Runtime.InteropServices.OutOfMemoryException | if the method could not allocate enough native heap memory

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.StructureToPtr

Marshals data from a managed object to an unmanaged block of memory. This method copies the contents of structure to the block of memory pointed to by ptr. If fDeleteOld is true, the buffer originally pointed to by ptr will be deleted. This is accomplished by calling the appropriate 'delete' API on the embedded pointer. StructureToPtr does this tidy-up for every reference field specified in the 'mirror' managed class.

[Visual Basic]
Public Shared Sub StructureToPtr( _
   ByVal structure As Object, _
   ByVal ptr As Integer, _
   ByVal fDeleteOld As Boolean _
)
[C#]
public static void StructureToPtr(
   object structure,
   int ptr,
   bool fDeleteOld
);
[C++]
public: static void StructureToPtr(
   Object* structure,
   int ptr,
   bool fDeleteOld
);
[JScript]
public static function StructureToPtr(
   structure : Object,
   ptr : int,
   fDeleteOld : Boolean
);

Parameters

structure
A managed object holding the data to be marshaled. This object must be an instance of a formatted class.
ptr
A pointer to an unmanaged block of memory, which must be allocated before this method is called.
fDeleteOld
If true, the buffer originally pointed to by ptr is deleted. Note that passing false may lead to a memory leak.

Remarks

Suppose your unmanaged block of memory is pointed to by Ptr. [its layout is described by a corresponding managed class, called Structure]. StructureToPtr will marshall field values from Structure to Ptr.

Suppose your Ptr block includes a reference field, pointing to a string buffer, and currently holding "abc". Suppose the corresponding field on the managed side is a string holding "vwxyz". If you don't tell it otherwise, StructureToPtr will allocate a new unmanaged buffer to hold "vwxyz", and hook it up to the Ptr block. But it will cast the old buffer "abc" adrift, without freeing it back to the unmanaged heap; so you end up with an orphan buffer that represents a memory leak in your code. However, if you set the fDeleteOld bit true, then StructureToPtr frees the buffer holding "abc" before going on to allocate a new buffer for "vwxyz". So, no heap leak!

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.UnsafeAddrOfPinnedArrayElement

[To be supplied.]

[Visual Basic]
Public Shared Function UnsafeAddrOfPinnedArrayElement( _
   ByVal arr As Array, _
   ByVal index As Integer _
) As Integer
[C#]
public static int UnsafeAddrOfPinnedArrayElement(
   Array arr,
   int index
);
[C++]
public: static int UnsafeAddrOfPinnedArrayElement(
   Array* arr,
   int index
);
[JScript]
public static function UnsafeAddrOfPinnedArrayElement(
   arr : Array,
   index : int
) : int;

Parameters

arr
[To be supplied.]
index
[To be supplied.]

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.WriteByte

Writes a single byte value into native heap.

Overload List

Writes a single byte value into native heap.

[Visual Basic] Overloads extern Public Shared Sub WriteByte(Integer, Integer, Byte)
[C#] public static extern void WriteByte(int, int, byte);
[C++] public: static extern void WriteByte(int, int, unsigned char);
[JScript] public static extern function WriteByte(int, int, Byte);

Writes a single byte value into native heap.

[Visual Basic] Overloads extern Public Shared Sub WriteByte(Object, Integer, Byte)
[C#] public static extern void WriteByte(Object, int, byte);
[C++] public: static extern void WriteByte(Object, int, unsigned char);
[JScript] public static extern function WriteByte(Object, int, Byte);

Writes a single byte value into native heap.

[Visual Basic] Overloads Public Shared Sub WriteByte(Integer, Byte)
[C#] public static void WriteByte(int, byte);
[C++] public: static void WriteByte(int, unsigned char);
[JScript] public static function WriteByte(int, Byte);

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.WriteByte (Int32, Int32, Byte)

Writes a single byte value into native heap.

[Visual Basic]
Overloads extern Public Shared Sub WriteByte( _
   ByVal ptr As Integer, _
   ByVal ofs As Integer, _
   ByVal val As Byte _
)
[C#]
public static extern void WriteByte(
   int ptr,
   int ofs,
   byte val
);
[C++]
public: static extern void WriteByte(
   int ptr,
   int ofs,
   unsigned char val
);
[JScript]
public static extern function WriteByte(
   ptr : int,
   ofs : int,
   val : Byte
);

Parameters

ptr
C
ofs
Additional byte offset, added to ptr before writing.
val
Value to be written.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.WriteByte Overload List


Marshal.WriteByte (Object, Int32, Byte)

Writes a single byte value into native heap.

[Visual Basic]
Overloads extern Public Shared Sub WriteByte( _
   ByVal ptr As Object, _
   ByVal ofs As Integer, _
   ByVal val As Byte _
)
[C#]
public static extern void WriteByte(
   in out object ptr,
   int ofs,
   byte val
);
[C++]
public: static extern void WriteByte(
   __in Object** ptr,
   int ofs,
   unsigned char val
);
[JScript]
public static extern function WriteByte(
   in ptr : Object,
   ofs : int,
   val : Byte
);

Parameters

ptr
Base address in native heap of target object.
ofs
Additional byte offset, added to ptr before writing.
val
Value to be written.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.WriteByte Overload List


Marshal.WriteByte (Int32, Byte)

Writes a single byte value into native heap.

[Visual Basic]
Overloads Public Shared Sub WriteByte( _
   ByVal ptr As Integer, _
   ByVal val As Byte _
)
[C#]
public static void WriteByte(
   int ptr,
   byte val
);
[C++]
public: static void WriteByte(
   int ptr,
   unsigned char val
);
[JScript]
public static function WriteByte(
   ptr : int,
   val : Byte
);

Parameters

ptr
Address in native heap at which to write.
val
Value to be written.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.WriteByte Overload List


Marshal.WriteInt16

Writes a 16-bit integer value into native heap.

Overload List

Writes a 16-bit integer value into native heap.

[Visual Basic] Overloads extern Public Shared Sub WriteInt16(Integer, Integer, Integer)
[C#] public static extern void WriteInt16(int, int, short);
[C++] public: static extern void WriteInt16(int, int, short);
[JScript] public static extern function WriteInt16(int, int, Int16);

Writes a 16-bit integer value into native heap.

[Visual Basic] Overloads extern Public Shared Sub WriteInt16(Object, Integer, Char)
[C#] public static extern void WriteInt16(Object, int, char);
[C++] public: static extern void WriteInt16(Object, int, __wchar_t);
[JScript] public static extern function WriteInt16(Object, int, Char);

Writes a 16-bit integer value into native heap.

[Visual Basic] Overloads Public Shared Sub WriteInt16(Integer, Char)
[C#] public static void WriteInt16(int, char);
[C++] public: static void WriteInt16(int, __wchar_t);
[JScript] public static function WriteInt16(int, Char);

Writes a 16-bit integer value into native heap.

[Visual Basic] Overloads extern Public Shared Sub WriteInt16(Object, Integer, Integer)
[C#] public static extern void WriteInt16(Object, int, short);
[C++] public: static extern void WriteInt16(Object, int, short);
[JScript] public static extern function WriteInt16(Object, int, Int16);

[To be supplied.]

[Visual Basic] Overloads Public Shared Sub WriteInt16(Integer, Integer)
[C#] public static void WriteInt16(int, short);
[C++] public: static void WriteInt16(int, short);
[JScript] public static function WriteInt16(int, Int16);

Writes a 16-bit integer value into native heap.

[Visual Basic] Overloads extern Public Shared Sub WriteInt16(Integer, Integer, Char)
[C#] public static extern void WriteInt16(int, int, char);
[C++] public: static extern void WriteInt16(int, int, __wchar_t);
[JScript] public static extern function WriteInt16(int, int, Char);

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.WriteInt16 (Int32, Int32, Int16)

Writes a 16-bit integer value into native heap.

[Visual Basic]
Overloads extern Public Shared Sub WriteInt16( _
   ByVal ptr As Integer, _
   ByVal ofs As Integer, _
   ByVal val As Short _
)
[C#]
public static extern void WriteInt16(
   int ptr,
   int ofs,
   short val
);
[C++]
public: static extern void WriteInt16(
   int ptr,
   int ofs,
   short val
);
[JScript]
public static extern function WriteInt16(
   ptr : int,
   ofs : int,
   val : Int16
);

Parameters

ptr
Base address in native heap at which to write.
ofs
Additional byte offset, added to ptr before writing.
val
Value to be written

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.WriteInt16 Overload List


Marshal.WriteInt16 (Object, Int32, Char)

Writes a 16-bit integer value into native heap.

[Visual Basic]
Overloads extern Public Shared Sub WriteInt16( _
   ByVal ptr As Object, _
   ByVal ofs As Integer, _
   ByVal val As Char _
)
[C#]
public static extern void WriteInt16(
   in out object ptr,
   int ofs,
   char val
);
[C++]
public: static extern void WriteInt16(
   __in Object** ptr,
   int ofs,
   __wchar_t val
);
[JScript]
public static extern function WriteInt16(
   in ptr : Object,
   ofs : int,
   val : Char
);

Parameters

ptr
Base address in native heap of target object.
ofs
Additional byte offset, added to ptr before writing.
val
Value to be written

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.WriteInt16 Overload List


Marshal.WriteInt16 (Int32, Char)

Writes a 16-bit integer value into native heap.

[Visual Basic]
Overloads Public Shared Sub WriteInt16( _
   ByVal ptr As Integer, _
   ByVal val As Char _
)
[C#]
public static void WriteInt16(
   int ptr,
   char val
);
[C++]
public: static void WriteInt16(
   int ptr,
   __wchar_t val
);
[JScript]
public static function WriteInt16(
   ptr : int,
   val : Char
);

Parameters

ptr
Address in native heap at which to write.
val
Value to be written.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.WriteInt16 Overload List


Marshal.WriteInt16 (Object, Int32, Int16)

Writes a 16-bit integer value into native heap.

[Visual Basic]
Overloads extern Public Shared Sub WriteInt16( _
   ByVal ptr As Object, _
   ByVal ofs As Integer, _
   ByVal val As Short _
)
[C#]
public static extern void WriteInt16(
   in out object ptr,
   int ofs,
   short val
);
[C++]
public: static extern void WriteInt16(
   __in Object** ptr,
   int ofs,
   short val
);
[JScript]
public static extern function WriteInt16(
   in ptr : Object,
   ofs : int,
   val : Int16
);

Parameters

ptr
Base address in native heap of target object.
ofs
Additional byte offset, added to ptr before writing.
val
Value to be written

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.WriteInt16 Overload List


Marshal.WriteInt16 (Int32, Int16)

[To be supplied.]

[Visual Basic]
Overloads Public Shared Sub WriteInt16( _
   ByVal ptr As Integer, _
   ByVal val As Short _
)
[C#]
public static void WriteInt16(
   int ptr,
   short val
);
[C++]
public: static void WriteInt16(
   int ptr,
   short val
);
[JScript]
public static function WriteInt16(
   ptr : int,
   val : Int16
);

Parameters

ptr
[To be supplied.]
val
[To be supplied.]

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.WriteInt16 Overload List


Marshal.WriteInt16 (Int32, Int32, Char)

Writes a 16-bit integer value into native heap.

[Visual Basic]
Overloads extern Public Shared Sub WriteInt16( _
   ByVal ptr As Integer, _
   ByVal ofs As Integer, _
   ByVal val As Char _
)
[C#]
public static extern void WriteInt16(
   int ptr,
   int ofs,
   char val
);
[C++]
public: static extern void WriteInt16(
   int ptr,
   int ofs,
   __wchar_t val
);
[JScript]
public static extern function WriteInt16(
   ptr : int,
   ofs : int,
   val : Char
);

Parameters

ptr
Base address in native heap at which to write.
ofs
Additional byte offset, added to ptr before writing.
val
Value to be written.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.WriteInt16 Overload List


Marshal.WriteInt32

Writes a 32-bit integer value into native heap.

Overload List

Writes a 32-bit integer value into native heap.

[Visual Basic] Overloads Public Shared Sub WriteInt32(Integer, Integer)
[C#] public static void WriteInt32(int, int);
[C++] public: static void WriteInt32(int, int);
[JScript] public static function WriteInt32(int, int);

Writes a 32-bit integer value into native heap.

[Visual Basic] Overloads extern Public Shared Sub WriteInt32(Object, Integer, Integer)
[C#] public static extern void WriteInt32(Object, int, int);
[C++] public: static extern void WriteInt32(Object, int, int);
[JScript] public static extern function WriteInt32(Object, int, int);

Writes a 32-bit integer value into native heap.

[Visual Basic] Overloads extern Public Shared Sub WriteInt32(Integer, Integer, Integer)
[C#] public static extern void WriteInt32(int, int, int);
[C++] public: static extern void WriteInt32(int, int, int);
[JScript] public static extern function WriteInt32(int, int, int);

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.WriteInt32 (Int32, Int32)

Writes a 32-bit integer value into native heap.

[Visual Basic]
Overloads Public Shared Sub WriteInt32( _
   ByVal ptr As Integer, _
   ByVal val As Integer _
)
[C#]
public static void WriteInt32(
   int ptr,
   int val
);
[C++]
public: static void WriteInt32(
   int ptr,
   int val
);
[JScript]
public static function WriteInt32(
   ptr : int,
   val : int
);

Parameters

ptr
Address in native heap at which to write.
val
Value to be written.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.WriteInt32 Overload List


Marshal.WriteInt32 (Object, Int32, Int32)

Writes a 32-bit integer value into native heap.

[Visual Basic]
Overloads extern Public Shared Sub WriteInt32( _
   ByVal ptr As Object, _
   ByVal ofs As Integer, _
   ByVal val As Integer _
)
[C#]
public static extern void WriteInt32(
   in out object ptr,
   int ofs,
   int val
);
[C++]
public: static extern void WriteInt32(
   __in Object** ptr,
   int ofs,
   int val
);
[JScript]
public static extern function WriteInt32(
   in ptr : Object,
   ofs : int,
   val : int
);

Parameters

ptr
Base address in native heap of target object.
ofs
Additional byte offset, added to ptr before writing.
val
Value to be written.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.WriteInt32 Overload List


Marshal.WriteInt32 (Int32, Int32, Int32)

Writes a 32-bit integer value into native heap.

[Visual Basic]
Overloads extern Public Shared Sub WriteInt32( _
   ByVal ptr As Integer, _
   ByVal ofs As Integer, _
   ByVal val As Integer _
)
[C#]
public static extern void WriteInt32(
   int ptr,
   int ofs,
   int val
);
[C++]
public: static extern void WriteInt32(
   int ptr,
   int ofs,
   int val
);
[JScript]
public static extern function WriteInt32(
   ptr : int,
   ofs : int,
   val : int
);

Parameters

ptr
Base address in native heap at which to write.
ofs
Additional byte offset, added to ptr before writing.
val
Value to be written

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.WriteInt32 Overload List


Marshal.WriteInt64

Writes a 64-bit integer value into native heap.

Overload List

Writes a 64-bit integer value into native heap.

[Visual Basic] Overloads Public Shared Sub WriteInt64(Integer, Long)
[C#] public static void WriteInt64(int, long);
[C++] public: static void WriteInt64(int, __int64);
[JScript] public static function WriteInt64(int, long);

Writes a 64-bit integer value into native heap.

[Visual Basic] Overloads extern Public Shared Sub WriteInt64(Integer, Integer, Long)
[C#] public static extern void WriteInt64(int, int, long);
[C++] public: static extern void WriteInt64(int, int, __int64);
[JScript] public static extern function WriteInt64(int, int, long);

Writes a 64-bit integer value into native heap.

[Visual Basic] Overloads extern Public Shared Sub WriteInt64(Object, Integer, Long)
[C#] public static extern void WriteInt64(Object, int, long);
[C++] public: static extern void WriteInt64(Object, int, __int64);
[JScript] public static extern function WriteInt64(Object, int, long);

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


Marshal.WriteInt64 (Int32, Int64)

Writes a 64-bit integer value into native heap.

[Visual Basic]
Overloads Public Shared Sub WriteInt64( _
   ByVal ptr As Integer, _
   ByVal val As Long _
)
[C#]
public static void WriteInt64(
   int ptr,
   long val
);
[C++]
public: static void WriteInt64(
   int ptr,
   __int64 val
);
[JScript]
public static function WriteInt64(
   ptr : int,
   val : long
);

Parameters

ptr
Address in native heap at which to write.
val
Value to be written.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.WriteInt64 Overload List


Marshal.WriteInt64 (Int32, Int32, Int64)

Writes a 64-bit integer value into native heap.

[Visual Basic]
Overloads extern Public Shared Sub WriteInt64( _
   ByVal ptr As Integer, _
   ByVal ofs As Integer, _
   ByVal val As Long _
)
[C#]
public static extern void WriteInt64(
   int ptr,
   int ofs,
   long val
);
[C++]
public: static extern void WriteInt64(
   int ptr,
   int ofs,
   __int64 val
);
[JScript]
public static extern function WriteInt64(
   ptr : int,
   ofs : int,
   val : long
);

Parameters

ptr
Base address in native heap at which to write.
ofs
Additional byte offset, added to ptr before writing.
val
Value to be written.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.WriteInt64 Overload List


Marshal.WriteInt64 (Object, Int32, Int64)

Writes a 64-bit integer value into native heap.

[Visual Basic]
Overloads extern Public Shared Sub WriteInt64( _
   ByVal ptr As Object, _
   ByVal ofs As Integer, _
   ByVal val As Long _
)
[C#]
public static extern void WriteInt64(
   in out object ptr,
   int ofs,
   long val
);
[C++]
public: static extern void WriteInt64(
   __in Object** ptr,
   int ofs,
   __int64 val
);
[JScript]
public static extern function WriteInt64(
   in ptr : Object,
   ofs : int,
   val : long
);

Parameters

ptr
Base address in native heap of target object.
ofs
Additional byte offset, added to ptr before writing.
val
Value to be written.

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace | Marshal.WriteInt64 Overload List


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Marshal Fields

The fields of the Marshal class are listed below. For a complete list of Marshal class members, see the Marshal Members topic.

Public:

SystemDefaultCharSize Defined as 1 on an ANSI platform, and 2 on a UNICODE platform

See Also

Marshal Class | System.Runtime.InteropServices Namespace


Marshal.SystemDefaultCharSize

Defined as 1 on an ANSI platform, and 2 on a UNICODE platform

[Visual Basic]
Public Shared ReadOnly SystemDefaultCharSize As Integer
[C#]
public static readonly int SystemDefaultCharSize;
[C++]
public: static readonly int SystemDefaultCharSize;
[JScript]
public static var SystemDefaultCharSize : int;

See Also

Marshal Class | Marshal Members | System.Runtime.InteropServices Namespace


MarshalAsAttribute Class

This attribute is used on fields or parameters to indicate how the data should be marshaled between managed and unmanaged code. The attribute is always optional as each data type has default marshaling behavior. The attribute is only necessary when a given type can be marshaled to a number of other possible types. For example, a String could be marshaled to unmanaged code as either a LPSTR, LPWSTR, LPTSTR or as a BSTR. By default the string would be marshaled as a BSTR. The MarshalAsAttribute can be applied to an individual field or parameter to cause that particular string to be marshaled as a LPSTR instead of a BSTR. For complete details on using this attribute see the data type marshaling spec.

Object
Attribute
MarshalAsAttribute

[Visual Basic]
Public Class MarshalAsAttribute
   Inherits Attribute
[C#]
public class MarshalAsAttribute : Attribute
[C++]
public __gc class MarshalAsAttribute : public Attribute
[JScript]
public class MarshalAsAttribute extends Attribute

Remarks

Can be used to attribute parameters or fields.

In most cases, the attribute simply identifies the format of the unmanaged data using the UnmanagedType enumeration. For example:

[C#]

Void foo([MarshalAs(LPSTR) String s);

Some UnmanagedTypes require additional information. For example, additional information is needed when the UnmanagedType is LPARRAY. For a complete description of how to use this attribute, see the DataTypeMarshaling Spec.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

MarshalAsAttribute Members | System.Runtime.InteropServices Namespace


MarshalAsAttribute Members

Public:

Constructor

MarshalAsAttribute Constructor Initializes a new instance of the MarshalAsAttribute class.

Properties

Value [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

ArraySubType | [To be supplied.]
MarshalCookie | [To be supplied.]
MarshalType | [To be supplied.]
MarshalTypeLibGuid | [To be supplied.]
MarshalUnmanagedType | [To be supplied.]
SafeArraySubType | [To be supplied.]
SizeConst | [To be supplied.]
SizeParamIndex | [To be supplied.]
SizeParamMultiplier | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MarshalAsAttribute Class | System.Runtime.InteropServices Namespace


MarshalAsAttribute Constructor

Initializes a new instance of the MarshalAsAttribute class.

[Visual Basic]
Public Sub New( _
   ByVal unmanagedType As UnmanagedType _
)
[C#]
public MarshalAsAttribute(
   UnmanagedType unmanagedType
);
[C++]
public: MarshalAsAttribute(
   UnmanagedType unmanagedType
);
[JScript]
public function MarshalAsAttribute(
   unmanagedType : UnmanagedType
);

Parameters

unmanagedType
[To be supplied.]

See Also

MarshalAsAttribute Class | MarshalAsAttribute Members | System.Runtime.InteropServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MarshalAsAttribute Properties

The properties of the MarshalAsAttribute class are listed below. For a complete list of MarshalAsAttribute class members, see the MarshalAsAttribute Members topic.

Public:

Value [To be supplied.]

See Also

MarshalAsAttribute Class | System.Runtime.InteropServices Namespace


MarshalAsAttribute.Value

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Value As UnmanagedType
[C#]
public UnmanagedType Value {virtual get;}
[C++]
public: __property virtual UnmanagedType get_Value();
[JScript]
public function get Value() : UnmanagedType;

See Also

MarshalAsAttribute Class | MarshalAsAttribute Members | System.Runtime.InteropServices Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MarshalAsAttribute Fields

The fields of the MarshalAsAttribute class are listed below. For a complete list of MarshalAsAttribute class members, see the MarshalAsAttribute Members topic.

Public:

ArraySubType | [To be supplied.]
MarshalCookie | [To be supplied.]
MarshalType | [To be supplied.]
MarshalTypeLibGuid | [To be supplied.]
MarshalUnmanagedType | [To be supplied.]
SafeArraySubType | [To be supplied.]
SizeConst | [To be supplied.]
SizeParamIndex | [To be supplied.]
SizeParamMultiplier | [To be supplied.]

See Also

MarshalAsAttribute Class | System.Runtime.InteropServices Namespace


MarshalAsAttribute.ArraySubType

[To be supplied.]

[Visual Basic]
Public ArraySubType As UnmanagedType
[C#]
public UnmanagedType ArraySubType;
[C++]
public: UnmanagedType ArraySubType;
[JScript]
public var ArraySubType : UnmanagedType;

See Also

MarshalAsAttribute Class | MarshalAsAttribute Members | System.Runtime.InteropServices Namespace


MarshalAsAttribute.MarshalCookie

[To be supplied.]

[Visual Basic]
Public MarshalCookie As String
[C#]
public string MarshalCookie;
[C++]
public: String* MarshalCookie;
[JScript]
public var MarshalCookie : String;

See Also

MarshalAsAttribute Class | MarshalAsAttribute Members | System.Runtime.InteropServices Namespace


MarshalAsAttribute.MarshalType

[To be supplied.]

[Visual Basic]
Public MarshalType As String
[C#]
public string MarshalType;
[C++]
public: String* MarshalType;
[JScript]
public var MarshalType : String;

See Also

MarshalAsAttribute Class | MarshalAsAttribute Members | System.Runtime.InteropServices Namespace


MarshalAsAttribute.MarshalTypeLibGuid

[To be supplied.]

[Visual Basic]
Public MarshalTypeLibGuid As String
[C#]
public string MarshalTypeLibGuid;
[C++]
public: String* MarshalTypeLibGuid;
[JScript]
public var MarshalTypeLibGuid : String;

See Also

MarshalAsAttribute Class | MarshalAsAttribute Members | System.Runtime.InteropServices Namespace


MarshalAsAttribute.MarshalUnmanagedType

[To be supplied.]

[Visual Basic]
Public MarshalUnmanagedType As String
[C#]
public string MarshalUnmanagedType;
[C++]
public: String* MarshalUnmanagedType;
[JScript]
public var MarshalUnmanagedType : String;

See Also

MarshalAsAttribute Class | MarshalAsAttribute Members | System.Runtime.InteropServices Namespace


MarshalAsAttribute.SafeArraySubType

[To be supplied.]

[Visual Basic]
Public SafeArraySubType As VarEnum
[C#]
public VarEnum SafeArraySubType;
[C++]
public: VarEnum SafeArraySubType;
[JScript]
public var SafeArraySubType : VarEnum;

See Also

MarshalAsAttribute Class | MarshalAsAttribute Members | System.Runtime.InteropServices Namespace


MarshalAsAttribute.SizeConst

[To be supplied.]

[Visual Basic]
Public SizeConst As Integer
[C#]
public int SizeConst;
[C++]
public: int SizeConst;
[JScript]
public var SizeConst : int;

See Also

MarshalAsAttribute Class | MarshalAsAttribute Members | System.Runtime.InteropServices Namespace


MarshalAsAttribute.SizeParamIndex

[To be supplied.]

[Visual Basic]
Public SizeParamIndex As Short
[C#]
public short SizeParamIndex;
[C++]
public: short SizeParamIndex;
[JScript]
public var SizeParamIndex : Int16;

See Also

MarshalAsAttribute Class | MarshalAsAttribute Members | System.Runtime.InteropServices Namespace


MarshalAsAttribute.SizeParamMultiplier

[To be supplied.]

[Visual Basic]
Public SizeParamMultiplier As Integer
[C#]
public int SizeParamMultiplier;
[C++]
public: int SizeParamMultiplier;
[JScript]
public var SizeParamMultiplier : int;

See Also

MarshalAsAttribute Class | MarshalAsAttribute Members | System.Runtime.InteropServices Namespace


MethodImplAttribute Class

[To be supplied.]

Object
Attribute
MethodImplAttribute

[Visual Basic]
Public Class MethodImplAttribute
   Inherits Attribute
[C#]
public class MethodImplAttribute : Attribute
[C++]
public __gc class MethodImplAttribute : public Attribute
[JScript]
public class MethodImplAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

MethodImplAttribute Members | System.Runtime.InteropServices Namespace


MethodImplAttribute Members

Public:

Constructor

MethodImplAttribute Constructor Initializes a new instance of the MethodImplAttribute class.

Properties

Value [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MethodImplAttribute Class | System.Runtime.InteropServices Namespace


MethodImplAttribute Constructor

Initializes a new instance of the MethodImplAttribute class.

[Visual Basic]
Public Sub New( _
   ByVal methodImplOptions As MethodImplOptions _
)
[C#]
public MethodImplAttribute(
   MethodImplOptions methodImplOptions
);
[C++]
public: MethodImplAttribute(
   MethodImplOptions methodImplOptions
);
[JScript]
public function MethodImplAttribute(
   methodImplOptions : MethodImplOptions
);

Parameters

methodImplOptions
[To be supplied.]

See Also

MethodImplAttribute Class | MethodImplAttribute Members | System.Runtime.InteropServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

MethodImplAttribute Properties

The properties of the MethodImplAttribute class are listed below. For a complete list of MethodImplAttribute class members, see the MethodImplAttribute Members topic.

Public:

Value [To be supplied.]

See Also

MethodImplAttribute Class | System.Runtime.InteropServices Namespace


MethodImplAttribute.Value

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Value As MethodImplOptions
[C#]
public MethodImplOptions Value {virtual get;}
[C++]
public: __property virtual MethodImplOptions get_Value();
[JScript]
public function get Value() : MethodImplOptions;

See Also

MethodImplAttribute Class | MethodImplAttribute Members | System.Runtime.InteropServices Namespace


MethodImplOptions Enumeration

[To be supplied.]

[Visual Basic]
Public Enum MethodImplOptions
[C#]
public enum MethodImplOptions
[C++]
public enum MethodImplOptions

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
NoInlining | [To be supplied.]
OLE | [To be supplied.]
OneWay | [To be supplied.]
Synchronized | [To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

System.Runtime.InteropServices Namespace


NoComRegistrationAttribute Class

Use this attribute to indicate that an otherwise public, COM-creatable type shuld not be registered for use form com applications.

Object
Attribute
NoComRegistrationAttribute

[Visual Basic]
Public Class NoComRegistrationAttribute
   Inherits Attribute
[C#]
public class NoComRegistrationAttribute : Attribute
[C++]
public __gc class NoComRegistrationAttribute : public Attribute
[JScript]
public class NoComRegistrationAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

NoComRegistrationAttribute Members | System.Runtime.InteropServices Namespace


NoComRegistrationAttribute Members

Public:

Constructor

NoComRegistrationAttribute Constructor Initializes a new instance of the NoComRegistrationAttribute class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NoComRegistrationAttribute Class | System.Runtime.InteropServices Namespace


NoComRegistrationAttribute Constructor

Initializes a new instance of the NoComRegistrationAttribute class.

[Visual Basic]
Public Sub New()
[C#]
public NoComRegistrationAttribute();
[C++]
public: NoComRegistrationAttribute();
[JScript]
public function NoComRegistrationAttribute();

See Also

NoComRegistrationAttribute Class | NoComRegistrationAttribute Members | System.Runtime.InteropServices Namespace


NoIDispatchAttribute Class

This attribute is used to control how the class responds to queries for an IDispatch Interface. If the attribute is present, all calls to QueryInterface that request IID_IDispatch will return E_NOINTERFACE. If the attribute is missing, the class will respond to queries for IID_IDispatch by returning either the class interface or the interface that is explicitly marked as the class's default interface. For details on selecting the default interface see the HasDefaultInterfaceAttribute.

Object
Attribute
NoIDispatchAttribute

[Visual Basic]
Public Class NoIDispatchAttribute
   Inherits Attribute
[C#]
public class NoIDispatchAttribute : Attribute
[C++]
public __gc class NoIDispatchAttribute : public Attribute
[JScript]
public class NoIDispatchAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

NoIDispatchAttribute Members | System.Runtime.InteropServices Namespace


NoIDispatchAttribute Members

Public:

Constructor

NoIDispatchAttribute Constructor Initializes a new instance of the NoIDispatchAttribute class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NoIDispatchAttribute Class | System.Runtime.InteropServices Namespace


NoIDispatchAttribute Constructor

Initializes a new instance of the NoIDispatchAttribute class.

[Visual Basic]
Public Sub New()
[C#]
public NoIDispatchAttribute();
[C++]
public: NoIDispatchAttribute();
[JScript]
public function NoIDispatchAttribute();

See Also

NoIDispatchAttribute Class | NoIDispatchAttribute Members | System.Runtime.InteropServices Namespace


ObjectCreationDelegate Delegate

Creates a COM object.

[Visual Basic]
Public Delegate Sub ObjectCreationDelegate( _
   ByVal aggregator As Integer _
) As Integer
[C#]
public delegate int ObjectCreationDelegate(
   int aggregator
);
[C++]
public __gc __delegate int ObjectCreationDelegate(
   int aggregator
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the ObjectCreationDelegate delegate declaration.

Remarks

This delegate is called to create a COM object as an alternative to CoCreateInstance when a managed object wishes to instantiate its unmanaged portion. The IUnknown of the managed object (the aggregator) is passed as a parameter and the delegate should return the IUnknown of the unmanaged object (the aggregatee). Both are passed as ints to avoid any marshaling.

Every subclass of Delegate and MulticastDelegate has a constructor and an Invoke method.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

System.Runtime.InteropServices Namespace


OutAttribute Class

Used on a parameter or field to indicate that data should be marshaled out from callee back to caller.

Object
Attribute
OutAttribute

[Visual Basic]
Public Class OutAttribute
   Inherits Attribute
[C#]
public class OutAttribute : Attribute
[C++]
public __gc class OutAttribute : public Attribute
[JScript]
public class OutAttribute extends Attribute

Remarks

Can be used to attribute parameters.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

OutAttribute Members | System.Runtime.InteropServices Namespace


OutAttribute Members

Public:

Constructor

OutAttribute Constructor Initializes a new instance of the OutAttribute class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OutAttribute Class | System.Runtime.InteropServices Namespace


OutAttribute Constructor

Initializes a new instance of the OutAttribute class.

[Visual Basic]
Public Sub New()
[C#]
public OutAttribute();
[C++]
public: OutAttribute();
[JScript]
public function OutAttribute();

See Also

OutAttribute Class | OutAttribute Members | System.Runtime.InteropServices Namespace


PInvokeMap Enumeration

Defines the PInvoke attributes. These values are defined in CorHdr.h.

[Visual Basic]
Public Enum PInvokeMap
[C#]
public enum PInvokeMap
[C++]
public enum PInvokeMap

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

PInvoke is Platform Invocation Services. PInvoke allows managed code to call unmanaged functions that are implemented in a DLL.

Members

Member Name | Description
CallConvCdecl | [To be supplied.]
CallConvFastcall | [To be supplied.]
CallConvStdcall | [To be supplied.]
CallConvThiscall | [To be supplied.]
CallConvWinapi | [To be supplied.]
CharSetAnsi | [To be supplied.]
CharSetAuto | [To be supplied.]
CharSetMask | Heuristic used in data type name mapping.
CharSetNotSpec | [To be supplied.]
CharSetUnicode | [To be supplied.]
NoMangle | Indicates the PInvoke is to use the member name as specified.
PinvokeOLE | [To be supplied.]
SupportsLastError | [To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

System.Runtime.InteropServices Namespace


PredeclaredAttribute Class

Deprecated. Do not use

Object
Attribute
PredeclaredAttribute

[Visual Basic]
Public Class PredeclaredAttribute
   Inherits Attribute
[C#]
public class PredeclaredAttribute : Attribute
[C++]
public __gc class PredeclaredAttribute : public Attribute
[JScript]
public class PredeclaredAttribute extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

PredeclaredAttribute Members | System.Runtime.InteropServices Namespace


PredeclaredAttribute Members

Public:

Constructor

PredeclaredAttribute Constructor Initializes a new instance of the PredeclaredAttribute class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PredeclaredAttribute Class | System.Runtime.InteropServices Namespace


PredeclaredAttribute Constructor

Initializes a new instance of the PredeclaredAttribute class.

[Visual Basic]
Public Sub New()
[C#]
public PredeclaredAttribute();
[C++]
public: PredeclaredAttribute();
[JScript]
public function PredeclaredAttribute();

See Also

PredeclaredAttribute Class | PredeclaredAttribute Members | System.Runtime.InteropServices Namespace


PreserveSigAttribute Class

Used to indicate that HResult/retval signature transformation that normally takes place during Interop calls should be suppressed. The attribute affects marshaling as well as type library importing and exporting.

Object
Attribute
PreserveSigAttribute

[Visual Basic]
Public Class PreserveSigAttribute
   Inherits Attribute
[C#]
public class PreserveSigAttribute : Attribute
[C++]
public __gc class PreserveSigAttribute : public Attribute
[JScript]
public class PreserveSigAttribute extends Attribute

Remarks

Can be used to attribute methods.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

Example [C#]

The following managed method:

[C#]

int DoSomething (long l);

Is normally converted to:

[C#]

HRESULT DoSomething ([in] long l, [out retval] int * I);

When exported to a type library. When the PreserveSignatureAttribute is applied to the method:

[C#]

[PreserveSig] Int DoSomething (long l);

The method is exported to the type library as is:

[C#]

int DoSomething ([in] long l);

See Also

PreserveSigAttribute Members | System.Runtime.InteropServices Namespace


PreserveSigAttribute Members

Public:

Constructor

PreserveSigAttribute Constructor Initializes a new instance of the PreserveSigAttribute class.

Properties

Value [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PreserveSigAttribute Class | System.Runtime.InteropServices Namespace


PreserveSigAttribute Constructor

Initializes a new instance of the PreserveSigAttribute class.

[Visual Basic]
Public Sub New( _
   ByVal val As Boolean _
)
[C#]
public PreserveSigAttribute(
   bool val
);
[C++]
public: PreserveSigAttribute(
   bool val
);
[JScript]
public function PreserveSigAttribute(
   val : Boolean
);

Parameters

val
[To be supplied.]

See Also

PreserveSigAttribute Class | PreserveSigAttribute Members | System.Runtime.InteropServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

PreserveSigAttribute Properties

The properties of the PreserveSigAttribute class are listed below. For a complete list of PreserveSigAttribute class members, see the PreserveSigAttribute Members topic.

Public:

Value [To be supplied.]

See Also

PreserveSigAttribute Class | System.Runtime.InteropServices Namespace


PreserveSigAttribute.Value

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Value As Boolean
[C#]
public bool Value {virtual get;}
[C++]
public: __property virtual bool get_Value();
[JScript]
public function get Value() : Boolean;

See Also

PreserveSigAttribute Class | PreserveSigAttribute Members | System.Runtime.InteropServices Namespace


ProgIdAttribute Class

Custom attribute that allows the user to specify the prog ID of a NGWS class.

Object
Attribute
ProgIdAttribute

[Visual Basic]
Public Class ProgIdAttribute
   Inherits Attribute
[C#]
public class ProgIdAttribute : Attribute
[C++]
public __gc class ProgIdAttribute : public Attribute
[JScript]
public class ProgIdAttribute extends Attribute

Remarks

Can be used to attribute classes.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

ProgIdAttribute Members | System.Runtime.InteropServices Namespace


ProgIdAttribute Members

Public:

Constructor

ProgIdAttribute Constructor Initializes a new instance of the ProgIdAttribute class.

Properties

Value [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProgIdAttribute Class | System.Runtime.InteropServices Namespace


ProgIdAttribute Constructor

Initializes a new instance of the ProgIdAttribute class.

[Visual Basic]
Public Sub New( _
   ByVal val As String _
)
[C#]
public ProgIdAttribute(
   string val
);
[C++]
public: ProgIdAttribute(
   String* val
);
[JScript]
public function ProgIdAttribute(
   val : String
);

Parameters

val
[To be supplied.]

See Also

ProgIdAttribute Class | ProgIdAttribute Members | System.Runtime.InteropServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ProgIdAttribute Properties

The properties of the ProgIdAttribute class are listed below. For a complete list of ProgIdAttribute class members, see the ProgIdAttribute Members topic.

Public:

Value [To be supplied.]

See Also

ProgIdAttribute Class | System.Runtime.InteropServices Namespace


ProgIdAttribute.Value

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Value As String
[C#]
public string Value {virtual get;}
[C++]
public: __property virtual String* get_Value();
[JScript]
public function get Value() : String;

See Also

ProgIdAttribute Class | ProgIdAttribute Members | System.Runtime.InteropServices Namespace


RegistrationServices Class

[To be supplied.]

Object
RegistrationServices

[Visual Basic]
Public Class RegistrationServices
[C#]
public class RegistrationServices
[C++]
public __gc class RegistrationServices
[JScript]
public class RegistrationServices

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

RegistrationServices Members | System.Runtime.InteropServices Namespace


RegistrationServices Members

Public:

Constructor

RegistrationServices Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetMsCorEEFileName | [To be supplied.]
GetProgIdForType | [To be supplied.]
GetRegistrableTypesInAssembly | [To be supplied.]
GetRegistryFileEntryForAsm | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
RegisterAssembly | [To be supplied.]
RegisterTypeForComClients | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.
UnregisterAssembly | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RegistrationServices Class | System.Runtime.InteropServices Namespace


RegistrationServices Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public RegistrationServices();
[C++]
public: RegistrationServices();
[JScript]
public function RegistrationServices();

See Also

RegistrationServices Class | RegistrationServices Members | System.Runtime.InteropServices Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

RegistrationServices Methods

The methods of the RegistrationServices class are listed below. For a complete list of RegistrationServices class members, see the RegistrationServices Members topic.

Public:

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetMsCorEEFileName | [To be supplied.]
GetProgIdForType | [To be supplied.]
GetRegistrableTypesInAssembly | [To be supplied.]
GetRegistryFileEntryForAsm | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
RegisterAssembly | [To be supplied.]
RegisterTypeForComClients | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.
UnregisterAssembly | [To be supplied.]

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RegistrationServices Class | System.Runtime.InteropServices Namespace


RegistrationServices.GetMsCorEEFileName

[To be supplied.]

[Visual Basic]
Public Shared Function GetMsCorEEFileName() As String
[C#]
public static string GetMsCorEEFileName();
[C++]
public: static String* GetMsCorEEFileName();
[JScript]
public static function GetMsCorEEFileName() : String;

See Also

RegistrationServices Class | RegistrationServices Members | System.Runtime.InteropServices Namespace


RegistrationServices.GetProgIdForType

[To be supplied.]

[Visual Basic]
Public Shared Function GetProgIdForType( _
   ByVal type As Type _
) As String
[C#]
public static string GetProgIdForType(
   Type type
);
[C++]
public: static String* GetProgIdForType(
   Type* type
);
[JScript]
public static function GetProgIdForType(
   type : Type
) : String;

Parameters

type
[To be supplied.]

See Also

RegistrationServices Class | RegistrationServices Members | System.Runtime.InteropServices Namespace


RegistrationServices.GetRegistrableTypesInAssembly

[To be supplied.]

[Visual Basic]
Public Shared Function GetRegistrableTypesInAssembly( _
   ByVal asm As Assembly _
) As Type ()
[C#]
public static Type[] GetRegistrableTypesInAssembly(
   Assembly asm
);
[C++]
public: static Type* GetRegistrableTypesInAssembly(
   Assembly* asm
) [];
[JScript]
public static function GetRegistrableTypesInAssembly(
   asm : Assembly
) : Type[];

Parameters

asm
[To be supplied.]

See Also

RegistrationServices Class | RegistrationServices Members | System.Runtime.InteropServices Namespace


RegistrationServices.GetRegistryFileEntryForAsm

[To be supplied.]

[Visual Basic]
Public Shared Function GetRegistryFileEntryForAsm( _
   ByVal asm As Assembly _
) As String
[C#]
public static string GetRegistryFileEntryForAsm(
   Assembly asm
);
[C++]
public: static String* GetRegistryFileEntryForAsm(
   Assembly* asm
);
[JScript]
public static function GetRegistryFileEntryForAsm(
   asm : Assembly
) : String;

Parameters

asm
[To be supplied.]

See Also

RegistrationServices Class | RegistrationServices Members | System.Runtime.InteropServices Namespace


RegistrationServices.RegisterAssembly

[To be supplied.]

[Visual Basic]
Public Shared Function RegisterAssembly( _
   ByVal asm As Assembly _
) As Boolean
[C#]
public static bool RegisterAssembly(
   Assembly asm
);
[C++]
public: static bool RegisterAssembly(
   Assembly* asm
);
[JScript]
public static function RegisterAssembly(
   asm : Assembly
) : Boolean;

Parameters

asm
[To be supplied.]

See Also

RegistrationServices Class | RegistrationServices Members | System.Runtime.InteropServices Namespace


RegistrationServices.RegisterTypeForComClients

[To be supplied.]

[Visual Basic]
Public Shared Sub RegisterTypeForComClients( _
   ByVal type As Type, _
   ByRef g As Guid _
)
[C#]
public static void RegisterTypeForComClients(
   Type type,
   ref Guid g
);
[C++]
public: static void RegisterTypeForComClients(
   Type* type,
   Guid** g
);
[JScript]
public static function RegisterTypeForComClients(
   type : Type,
   g : Guid
);

Parameters

type
[To be supplied.]
g
[To be supplied.]

See Also

RegistrationServices Class | RegistrationServices Members | System.Runtime.InteropServices Namespace


RegistrationServices.UnregisterAssembly

[To be supplied.]

[Visual Basic]
Public Shared Function UnregisterAssembly( _
   ByVal asm As Assembly _
) As Boolean
[C#]
public static bool UnregisterAssembly(
   Assembly asm
);
[C++]
public: static bool UnregisterAssembly(
   Assembly* asm
);
[JScript]
public static function UnregisterAssembly(
   asm : Assembly
) : Boolean;

Parameters

asm
[To be supplied.]

See Also

RegistrationServices Class | RegistrationServices Members | System.Runtime.InteropServices Namespace


Root Class

This class allows you to create an opaque, 32-bit root handle to any managed object. A root handle prevents that 'rooted' managed object from being reclaimed by garbage collection, so that a reference to the managed object can be safely stored in native data structures.

Object
Root

[Visual Basic]
NotInheritable Public Class Root
[C#]
public sealed class Root
[C++]
public __gc __sealed class Root
[JScript]
public class Root

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

Root Members | System.Runtime.InteropServices Namespace


Root Members

Public:

Methods

Alloc | Allocates a handle to the specified, managed object, to prevent it being reclaimed by garbage collection.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Free | Releases the managed object, previously 'rooted' against garbage reclamation, by a call to Alloc.
Get | Returns the managed object corresponding to the specified 'root' handle.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Root Class | System.Runtime.InteropServices Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Root Methods

The methods of the Root class are listed below. For a complete list of Root class members, see the Root Members topic.

Public:

Alloc | Allocates a handle to the specified, managed object, to prevent it being reclaimed by garbage collection.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
Free | Releases the managed object, previously 'rooted' against garbage reclamation, by a call to Alloc.
Get | Returns the managed object corresponding to the specified 'root' handle.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Root Class | System.Runtime.InteropServices Namespace


Root.Alloc

Allocates a handle to the specified, managed object, to prevent it being reclaimed by garbage collection.

[Visual Basic]
Public Shared Function Alloc( _
   ByVal value As Object _
) As Integer
[C#]
public static int Alloc(
   object value
);
[C++]
public: static int Alloc(
   Object* value
);
[JScript]
public static function Alloc(
   value : Object
) : int;

Parameters

value
The managed object to be 'rooted' against garbage collection

Return Value

A handle to the 'rooted' managed object. Only of use to the caller when it comes time to 'unroot' that managed object with a call to Free or to enquire the root handle with a call to Get.

Remarks

Root handles require explicit deallocation using the Free method. The object will not be reclaimed by the garbage collector until the Free method is called.

See Also

Root Class | Root Members | System.Runtime.InteropServices Namespace


Root.Free

Releases the managed object, previously 'rooted' against garbage reclamation, by a call to Alloc.

[Visual Basic]
Public Shared Sub Free( _
   ByVal root As Integer _
)
[C#]
public static void Free(
   int root
);
[C++]
public: static void Free(
   int root
);
[JScript]
public static function Free(
   root : int
);

Parameters

root
The handle, obtained from a previous call to Alloc for the managed object of interest.

See Also

Root Class | Root Members | System.Runtime.InteropServices Namespace


Root.Get

Returns the managed object corresponding to the specified 'root' handle.

[Visual Basic]
Public Shared Function Get( _
   ByVal root As Integer _
) As Object
[C#]
public static object Get(
   int root
);
[C++]
public: static Object* Get(
   int root
);
[JScript]
public static function Get(
   root : int
) : Object;

Parameters

root
The root handle for the managed object of interest, obtained from a previous call to Alloc.

Return Value

The managed object corresponding to the root handle.

See Also

Root Class | Root Members | System.Runtime.InteropServices Namespace


SafeArrayTypeMismatchException Class

[To be supplied.]

Object
Exception
SystemException
SafeArrayTypeMismatchException

[Visual Basic]
Public Class SafeArrayTypeMismatchException
   Inherits SystemException
[C#]
public class SafeArrayTypeMismatchException : SystemException
[C++]
public __gc class SafeArrayTypeMismatchException : public
   SystemException
[JScript]
public class SafeArrayTypeMismatchException extends SystemException

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

SafeArrayTypeMismatchException Members | System.Runtime.InteropServices Namespace


SafeArrayTypeMismatchException Members

Public:

Constructor

SafeArrayTypeMismatchException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

SafeArrayTypeMismatchException Class | System.Runtime.InteropServices Namespace


SafeArrayTypeMismatchException Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public SafeArrayTypeMismatchException();
[C++] public: SafeArrayTypeMismatchException();
[JScript] public function SafeArrayTypeMismatchException();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public SafeArrayTypeMismatchException(String);
[C++] public: SafeArrayTypeMismatchException(String*);
[JScript] public function SafeArrayTypeMismatchException(String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public SafeArrayTypeMismatchException(String, Exception);
[C++] public: SafeArrayTypeMismatchException(String*, Exception);
[JScript] public function SafeArrayTypeMismatchException(String, Exception);

See Also

SafeArrayTypeMismatchException Class | SafeArrayTypeMismatchException Members | System.Runtime.InteropServices Namespace


SafeArrayTypeMismatchException Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public SafeArrayTypeMismatchException();
[C++]
public: SafeArrayTypeMismatchException();
[JScript]
public function SafeArrayTypeMismatchException();

See Also

SafeArrayTypeMismatchException Class | SafeArrayTypeMismatchException Members | System.Runtime.InteropServices Namespace | SafeArrayTypeMismatchException Constructor Overload List


SafeArrayTypeMismatchException Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public SafeArrayTypeMismatchException(
   string message
);
[C++]
public: SafeArrayTypeMismatchException(
   String* message
);
[JScript]
public function SafeArrayTypeMismatchException(
   message : String
);

Parameters

message
[To be supplied.]

See Also

SafeArrayTypeMismatchException Class | SafeArrayTypeMismatchException Members | System.Runtime.InteropServices Namespace | SafeArrayTypeMismatchException Constructor Overload List


SafeArrayTypeMismatchException Constructor (String, Exception)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public SafeArrayTypeMismatchException(
   string message,
   Exception inner
);
[C++]
public: SafeArrayTypeMismatchException(
   String* message,
   Exception* inner
);
[JScript]
public function SafeArrayTypeMismatchException(
   message : String,
   inner : Exception
);

Parameters

message
[To be supplied.]
inner
[To be supplied.]

See Also

SafeArrayTypeMismatchException Class | SafeArrayTypeMismatchException Members | System.Runtime.InteropServices Namespace | SafeArrayTypeMismatchException Constructor Overload List


SEHException Class

Represents Structured Exception Handler (SEH) errors.

Object
Exception
SystemException
ExternalException
SEHException

[Visual Basic]
Public Class SEHException
   Inherits ExternalException
[C#]
public class SEHException : ExternalException
[C++]
public __gc class SEHException : public ExternalException
[JScript]
public class SEHException extends ExternalException

Remarks

The SEHException class handles errors from the Structured Exception Handler code.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

SEHException Members | System.Runtime.InteropServices Namespace


SEHException Members

Public:

Constructor

SEHException Constructor Overloaded. Initializes an instance of the SEHException class.

Properties

ErrorCode (inherited from ExternalException) | [To be supplied.]
HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

CanResume | Not yet implemented. Can be resumable.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

SEHException Class | System.Runtime.InteropServices Namespace


SEHException Constructor

Initializes an instance of the SEHException class.

Overload List

Initializes an instance of the SEHException with default properties.

[Visual Basic] Overloads Public Sub New()
[C#] public SEHException();
[C++] public: SEHException();
[JScript] public function SEHException();

Initializes a new instance of the SEHException class with a specified message.

[Visual Basic] Overloads Public Sub New(String)
[C#] public SEHException(String);
[C++] public: SEHException(String*);
[JScript] public function SEHException(String);

Initializes a new instance of the SEHException class with a specified message and the exception that is the root cause of this exception.

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public SEHException(String, Exception);
[C++] public: SEHException(String*, Exception);
[JScript] public function SEHException(String, Exception);

See Also

SEHException Class | SEHException Members | System.Runtime.InteropServices Namespace


SEHException Constructor ()

Initializes an instance of the SEHException with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public SEHException();
[C++]
public: SEHException();
[JScript]
public function SEHException();

Remarks

SEHException inherits from Exception. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The empty string.

See Also

SEHException Class | SEHException Members | System.Runtime.InteropServices Namespace | SEHException Constructor Overload List


SEHException Constructor (String)

Initializes a new instance of the SEHException class with a specified message.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public SEHException(
   string message
);
[C++]
public: SEHException(
   String* message
);
[JScript]
public function SEHException(
   message : String
);

Parameters

message
The message that indicates the reason the exception occurred.

Remarks

SEHException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | null
Message | The message string.

See Also

SEHException Class | SEHException Members | System.Runtime.InteropServices Namespace | SEHException Constructor Overload List


SEHException Constructor (String, Exception)

Initializes a new instance of the SEHException class with a specified message and the exception that is the root cause of this exception.

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public SEHException(
   string message,
   Exception inner
);
[C++]
public: SEHException(
   String* message,
   Exception* inner
);
[JScript]
public function SEHException(
   message : String,
   inner : Exception
);

Parameters

message
The message that indicates the reason the exception occurred.
inner
A reference to an exception that is indicative of the problem exception.

Remarks

When handling an exception, it is sometimes helpful to have a reference to the exception(s) that caused the error to occur. You can use this constructor to create a chain of new and more meaningful exceptions with the InnerException property set to the inner exception reference. This more meaningful exception can then be thrown to the caller. Note that with this functionality it is possible to create a series of linked exceptions that terminates with the exception that was first thrown. (See Exception for more information.)

SEHException inherits from the Exception class. This constructor sets the properties of the Exception object as follows:

Property Type | Condition
InnerException | The inner exception.
Message | The message string.

See Also

SEHException Class | SEHException Members | System.Runtime.InteropServices Namespace | SEHException Constructor Overload List


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

SEHException Methods

The methods of the SEHException class are listed below. For a complete list of SEHException class members, see the SEHException Members topic.

Public:

CanResume | Not yet implemented. Can be resumable.
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SEHException Class | System.Runtime.InteropServices Namespace


SEHException.CanResume

Not yet implemented. Can be resumable.

[Visual Basic]
Overridable Public Function CanResume() As Boolean
[C#]
public virtual bool CanResume();
[C++]
public: virtual bool CanResume();
[JScript]
public function CanResume() : Boolean;

Return Value

Resumable exceptions are not yet implemented, so this method always returns false.

Remarks

CanResume can be resumable, which means a filtered exception handler can correct the problem that caused the exception, and the code will continue from the point that threw the exception.

This method is currently not implemented but exists and will always return false.

See Also

SEHException Class | SEHException Members | System.Runtime.InteropServices Namespace


StructLayoutAttribute Class

Typically the runtime controls the physical layout of the data members of class. The StructLayoutAttribute allows the user to control the physical layout of the data members of a class. Explicit control of a classes layout is important if the class is to be passed to unmanaged code that expects a specific layout. The LayoutKind value Sequential is used to force the members to be laid out sequentially in the order they appear. Explicit is used to control the precise position of each data member. With Explicit each member must use the FieldOffsetAttribute to indicate the position of that field within the type.

Object
Attribute
StructLayoutAttribute

[Visual Basic]
Public Class StructLayoutAttribute
   Inherits Attribute
[C#]
public class StructLayoutAttribute : Attribute
[C++]
public __gc class StructLayoutAttribute : public Attribute
[JScript]
public class StructLayoutAttribute extends Attribute

Remarks

Can be used to attribute classes or structures.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

StructLayoutAttribute Members | System.Runtime.InteropServices Namespace


StructLayoutAttribute Members

Public:

Constructor

StructLayoutAttribute Constructor Initalizes a new instance of the StructLayoutAttribute class.

Properties

Value [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

CharSet | Indicates how string data members within the class should be marshaled. If the CharSet field is set to the CharSet value Unicode, all string arguments are converted to Unicode characters before being passed to the unmanaged implementation. If the field is set to Ansi, the strings are converted to ANSI strings. If the CharSet is set to Auto, the conversion is platform dependent (Unicode on WinNT and ANSI on Win 9x).
CheckFastMarshal | [To be supplied.]
Pack | Indicates the packing size that should be used when the System.Runtime.InteropServices.Value Sequential value is specified. The default packing size is 4.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StructLayoutAttribute Class | System.Runtime.InteropServices Namespace


StructLayoutAttribute Constructor

Initalizes a new instance of the StructLayoutAttribute class.

[Visual Basic]
Public Sub New( _
   ByVal val As LayoutKind _
)
[C#]
public StructLayoutAttribute(
   LayoutKind val
);
[C++]
public: StructLayoutAttribute(
   LayoutKind val
);
[JScript]
public function StructLayoutAttribute(
   val : LayoutKind
);

Parameters

val
[To be supplied.]

See Also

StructLayoutAttribute Class | StructLayoutAttribute Members | System.Runtime.InteropServices Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StructLayoutAttribute Properties

The properties of the StructLayoutAttribute class are listed below. For a complete list of StructLayoutAttribute class members, see the StructLayoutAttribute Members topic.

Public:

Value [To be supplied.]

See Also

StructLayoutAttribute Class | System.Runtime.InteropServices Namespace


StructLayoutAttribute.Value

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Value As LayoutKind
[C#]
public LayoutKind Value {virtual get;}
[C++]
public: __property virtual LayoutKind get_Value();
[JScript]
public function get Value() : LayoutKind;

See Also

StructLayoutAttribute Class | StructLayoutAttribute Members | System.Runtime.InteropServices Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

StructLayoutAttribute Fields

The fields of the StructLayoutAttribute class are listed below. For a complete list of StructLayoutAttribute class members, see the StructLayoutAttribute Members topic.

Public:

CharSet | Indicates how string data members within the class should be marshaled. If the CharSet field is set to the CharSet value Unicode, all string arguments are converted to Unicode characters before being passed to the unmanaged implementation. If the field is set to Ansi, the strings are converted to ANSI strings. If the CharSet is set to Auto, the conversion is platform dependent (Unicode on WinNT and ANSI on Win 9x).
CheckFastMarshal | [To be supplied.]
Pack | Indicates the packing size that should be used when the System.Runtime.InteropServices.Value Sequential value is specified. The default packing size is 4.

See Also

StructLayoutAttribute Class | System.Runtime.InteropServices Namespace


StructLayoutAttribute.CharSet

Indicates how string data members within the class should be marshaled. If the CharSet field is set to the CharSet value Unicode, all string arguments are converted to Unicode characters before being passed to the unmanaged implementation. If the field is set to Ansi, the strings are converted to ANSI strings. If the CharSet is set to Auto, the conversion is platform dependent (Unicode on WinNT and ANSI on Win 9x).

[Visual Basic]
Public CharSet As CharSet
[C#]
public CharSet CharSet;
[C++]
public: CharSet CharSet;
[JScript]
public var CharSet : CharSet;

See Also

StructLayoutAttribute Class | StructLayoutAttribute Members | System.Runtime.InteropServices Namespace


StructLayoutAttribute.CheckFastMarshal

[To be supplied.]

[Visual Basic]
Public CheckFastMarshal As Boolean
[C#]
public bool CheckFastMarshal;
[C++]
public: bool CheckFastMarshal;
[JScript]
public var CheckFastMarshal : Boolean;

See Also

StructLayoutAttribute Class | StructLayoutAttribute Members | System.Runtime.InteropServices Namespace


StructLayoutAttribute.Pack

Indicates the packing size that should be used when the System.Runtime.InteropServices.Value Sequential value is specified. The default packing size is 4.

[Visual Basic]
Public Pack As Integer
[C#]
public int Pack;
[C++]
public: int Pack;
[JScript]
public var Pack : int;

See Also

StructLayoutAttribute Class | StructLayoutAttribute Members | System.Runtime.InteropServices Namespace


SYSKIND Enumeration

[To be supplied.]

[Visual Basic]
Public Enum SYSKIND
[C#]
public enum SYSKIND
[C++]
public enum SYSKIND

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
SYS_MAC | [To be supplied.]
SYS_WIN16 | [To be supplied.]
SYS_WIN32 | [To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

System.Runtime.InteropServices Namespace


TypeAttr Class

[To be supplied.]

Object
TypeAttr

[Visual Basic]
Public Class TypeAttr
[C#]
public class TypeAttr
[C++]
public __gc class TypeAttr
[JScript]
public class TypeAttr

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

TypeAttr Members | System.Runtime.InteropServices Namespace


TypeAttr Members

Public:

Constructor

TypeAttr Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

cbAlignment | [To be supplied.]
cbSizeInstance | [To be supplied.]
cbSizeVft | [To be supplied.]
cFuncs | [To be supplied.]
cImplTypes | [To be supplied.]
cVars | [To be supplied.]
dwReserved | [To be supplied.]
guid | [To be supplied.]
idldescType | [To be supplied.]
lcid | [To be supplied.]
lpstrSchema | [To be supplied.]
MEMBER_ID_NILL | [To be supplied.]
memidConstructor | [To be supplied.]
memidDestructor | [To be supplied.]
tdescAlias | [To be supplied.]
typekind | [To be supplied.]
wMajorVerNum | [To be supplied.]
wMinorVerNum | [To be supplied.]
wTypeFlags | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeAttr Class | System.Runtime.InteropServices Namespace


TypeAttr Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public TypeAttr();
[C++]
public: TypeAttr();
[JScript]
public function TypeAttr();

See Also

TypeAttr Class | TypeAttr Members | System.Runtime.InteropServices Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypeAttr Fields

The fields of the TypeAttr class are listed below. For a complete list of TypeAttr class members, see the TypeAttr Members topic.

Public:

cbAlignment | [To be supplied.]
cbSizeInstance | [To be supplied.]
cbSizeVft | [To be supplied.]
cFuncs | [To be supplied.]
cImplTypes | [To be supplied.]
cVars | [To be supplied.]
dwReserved | [To be supplied.]
guid | [To be supplied.]
idldescType | [To be supplied.]
lcid | [To be supplied.]
lpstrSchema | [To be supplied.]
MEMBER_ID_NILL | [To be supplied.]
memidConstructor | [To be supplied.]
memidDestructor | [To be supplied.]
tdescAlias | [To be supplied.]
typekind | [To be supplied.]
wMajorVerNum | [To be supplied.]
wMinorVerNum | [To be supplied.]
wTypeFlags | [To be supplied.]

See Also

TypeAttr Class | System.Runtime.InteropServices Namespace


TypeAttr.cbAlignment

[To be supplied.]

[Visual Basic]
Public cbAlignment As UInt16
[C#]
public ushort cbAlignment;
[C++]
public: unsigned short cbAlignment;
[JScript]
public var cbAlignment : UInt16;

See Also

TypeAttr Class | TypeAttr Members | System.Runtime.InteropServices Namespace


TypeAttr.cbSizeInstance

[To be supplied.]

[Visual Basic]
Public cbSizeInstance As UInt32
[C#]
public uint cbSizeInstance;
[C++]
public: unsigned int cbSizeInstance;
[JScript]
public var cbSizeInstance : UInt32;

See Also

TypeAttr Class | TypeAttr Members | System.Runtime.InteropServices Namespace


TypeAttr.cbSizeVft

[To be supplied.]

[Visual Basic]
Public cbSizeVft As UInt16
[C#]
public ushort cbSizeVft;
[C++]
public: unsigned short cbSizeVft;
[JScript]
public var cbSizeVft : UInt16;

See Also

TypeAttr Class | TypeAttr Members | System.Runtime.InteropServices Namespace


TypeAttr.cFuncs

[To be supplied.]

[Visual Basic]
Public cFuncs As UInt16
[C#]
public ushort cFuncs;
[C++]
public: unsigned short cFuncs;
[JScript]
public var cFuncs : UInt16;

See Also

TypeAttr Class | TypeAttr Members | System.Runtime.InteropServices Namespace


TypeAttr.cImplTypes

[To be supplied.]

[Visual Basic]
Public cImplTypes As UInt16
[C#]
public ushort cImplTypes;
[C++]
public: unsigned short cImplTypes;
[JScript]
public var cImplTypes : UInt16;

See Also

TypeAttr Class | TypeAttr Members | System.Runtime.InteropServices Namespace


TypeAttr.cVars

[To be supplied.]

[Visual Basic]
Public cVars As UInt16
[C#]
public ushort cVars;
[C++]
public: unsigned short cVars;
[JScript]
public var cVars : UInt16;

See Also

TypeAttr Class | TypeAttr Members | System.Runtime.InteropServices Namespace


TypeAttr.dwReserved

[To be supplied.]

[Visual Basic]
Public dwReserved As UInt32
[C#]
public uint dwReserved;
[C++]
public: unsigned int dwReserved;
[JScript]
public var dwReserved : UInt32;

See Also

TypeAttr Class | TypeAttr Members | System.Runtime.InteropServices Namespace


TypeAttr.guid

[To be supplied.]

[Visual Basic]
Public guid As Guid
[C#]
public Guid guid;
[C++]
public: Guid guid;
[JScript]
public var guid : Guid;

See Also

TypeAttr Class | TypeAttr Members | System.Runtime.InteropServices Namespace


TypeAttr.idldescType

[To be supplied.]

[Visual Basic]
Public idldescType As IDLDesc
[C#]
public IDLDesc idldescType;
[C++]
public: IDLDesc idldescType;
[JScript]
public var idldescType : IDLDesc;

See Also

TypeAttr Class | TypeAttr Members | System.Runtime.InteropServices Namespace


TypeAttr.lcid

[To be supplied.]

[Visual Basic]
Public lcid As UInt32
[C#]
public uint lcid;
[C++]
public: unsigned int lcid;
[JScript]
public var lcid : UInt32;

See Also

TypeAttr Class | TypeAttr Members | System.Runtime.InteropServices Namespace


TypeAttr.lpstrSchema

[To be supplied.]

[Visual Basic]
Public lpstrSchema As Integer
[C#]
public int lpstrSchema;
[C++]
public: int lpstrSchema;
[JScript]
public var lpstrSchema : int;

See Also

TypeAttr Class | TypeAttr Members | System.Runtime.InteropServices Namespace


TypeAttr.MEMBER_ID_NILL

[To be supplied.]

[Visual Basic]
Public Const MEMBER_ID_NILL As UInt32
[C#]
public const uint MEMBER_ID_NILL;
[C++]
public: const unsigned int MEMBER_ID_NILL;
[JScript]
public var MEMBER_ID_NILL : UInt32;

See Also

TypeAttr Class | TypeAttr Members | System.Runtime.InteropServices Namespace


TypeAttr.memidConstructor

[To be supplied.]

[Visual Basic]
Public memidConstructor As UInt32
[C#]
public uint memidConstructor;
[C++]
public: unsigned int memidConstructor;
[JScript]
public var memidConstructor : UInt32;

See Also

TypeAttr Class | TypeAttr Members | System.Runtime.InteropServices Namespace


TypeAttr.memidDestructor

[To be supplied.]

[Visual Basic]
Public memidDestructor As UInt32
[C#]
public uint memidDestructor;
[C++]
public: unsigned int memidDestructor;
[JScript]
public var memidDestructor : UInt32;

See Also

TypeAttr Class | TypeAttr Members | System.Runtime.InteropServices Namespace


TypeAttr.tdescAlias

[To be supplied.]

[Visual Basic]
Public tdescAlias As TypeDesc
[C#]
public TypeDesc tdescAlias;
[C++]
public: TypeDesc tdescAlias;
[JScript]
public var tdescAlias : TypeDesc;

See Also

TypeAttr Class | TypeAttr Members | System.Runtime.InteropServices Namespace


TypeAttr.typekind

[To be supplied.]

[Visual Basic]
Public typekind As TYPEKIND
[C#]
public TYPEKIND typekind;
[C++]
public: TYPEKIND typekind;
[JScript]
public var typekind : TYPEKIND;

See Also

TypeAttr Class | TypeAttr Members | System.Runtime.InteropServices Namespace


TypeAttr.wMajorVerNum

[To be supplied.]

[Visual Basic]
Public wMajorVerNum As UInt16
[C#]
public ushort wMajorVerNum;
[C++]
public: unsigned short wMajorVerNum;
[JScript]
public var wMajorVerNum : UInt16;

See Also

TypeAttr Class | TypeAttr Members | System.Runtime.InteropServices Namespace


TypeAttr.wMinorVerNum

[To be supplied.]

[Visual Basic]
Public wMinorVerNum As UInt16
[C#]
public ushort wMinorVerNum;
[C++]
public: unsigned short wMinorVerNum;
[JScript]
public var wMinorVerNum : UInt16;

See Also

TypeAttr Class | TypeAttr Members | System.Runtime.InteropServices Namespace


TypeAttr.wTypeFlags

[To be supplied.]

[Visual Basic]
Public wTypeFlags As TYPEFLAGS
[C#]
public TYPEFLAGS wTypeFlags;
[C++]
public: TYPEFLAGS wTypeFlags;
[JScript]
public var wTypeFlags : TYPEFLAGS;

See Also

TypeAttr Class | TypeAttr Members | System.Runtime.InteropServices Namespace


TypeDesc Structure

[To be supplied.]

Object
ValueType
TypeDesc

[Visual Basic]
Public Structure TypeDesc
[C#]
public struct TypeDesc
[C++]
public __value struct TypeDesc

[JScript] In JScript, you can use the structures in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

TypeDesc Members | System.Runtime.InteropServices Namespace


TypeDesc Members

Public:

Methods

Equals (inherited from ValueType) | Indicates whether this instance and another object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from ValueType) | Returns the name of the type.

Fields

lpValue | [To be supplied.]
vt | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeDesc Structure | System.Runtime.InteropServices Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypeDesc Fields

The fields of the TypeDesc structure are listed below. For a complete list of TypeDesc structure members, see the TypeDesc Members topic.

Public:

lpValue | [To be supplied.]
vt | [To be supplied.]

See Also

TypeDesc Structure | System.Runtime.InteropServices Namespace


TypeDesc.lpValue

[To be supplied.]

[Visual Basic]
Public lpValue As Integer
[C#]
public int lpValue;
[C++]
public: int lpValue;
[JScript]
public var lpValue : int;

See Also

TypeDesc Structure | TypeDesc Members | System.Runtime.InteropServices Namespace


TypeDesc.vt

[To be supplied.]

[Visual Basic]
Public vt As UInt16
[C#]
public ushort vt;
[C++]
public: unsigned short vt;
[JScript]
public var vt : UInt16;

See Also

TypeDesc Structure | TypeDesc Members | System.Runtime.InteropServices Namespace


TYPEFLAGS Enumeration

[To be supplied.]

[Visual Basic]
Public Enum TYPEFLAGS
[C#]
public enum TYPEFLAGS
[C++]
public enum TYPEFLAGS

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
TYPEFLAG_FAGGREGATABLE | [To be supplied.]
TYPEFLAG_FAPPOBJECT | [To be supplied.]
TYPEFLAG_FCANCREATE | [To be supplied.]
TYPEFLAG_FCONTROL | [To be supplied.]
TYPEFLAG_FDISPATCHABLE | [To be supplied.]
TYPEFLAG_FDUAL | [To be supplied.]
TYPEFLAG_FHIDDEN | [To be supplied.]
TYPEFLAG_FLICENSED | [To be supplied.]
TYPEFLAG_FNONEXTENSIBLE | [To be supplied.]
TYPEFLAG_FOLEAUTOMATION | [To be supplied.]
TYPEFLAG_FPREDECLID | [To be supplied.]
TYPEFLAG_FREPLACEABLE | [To be supplied.]
TYPEFLAG_FRESTRICTED | [To be supplied.]
TYPEFLAG_FREVERSEBIND | [To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

System.Runtime.InteropServices Namespace


TYPEKIND Enumeration

[To be supplied.]

[Visual Basic]
Public Enum TYPEKIND
[C#]
public enum TYPEKIND
[C++]
public enum TYPEKIND

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
TKIND_ALIAS | [To be supplied.]
TKIND_COCLASS | [To be supplied.]
TKIND_DISPATCH | [To be supplied.]
TKIND_ENUM | [To be supplied.]
TKIND_INTERFACE | [To be supplied.]
TKIND_MAX | [To be supplied.]
TKIND_MODULE | [To be supplied.]
TKIND_RECORD | [To be supplied.]
TKIND_UNION | [To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

System.Runtime.InteropServices Namespace


TypeLibAttr Class

[To be supplied.]

Object
TypeLibAttr

[Visual Basic]
Public Class TypeLibAttr
[C#]
public class TypeLibAttr
[C++]
public __gc class TypeLibAttr
[JScript]
public class TypeLibAttr

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

TypeLibAttr Members | System.Runtime.InteropServices Namespace


TypeLibAttr Members

Public:

Constructor

TypeLibAttr Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

guid | [To be supplied.]
lcid | [To be supplied.]
syskind | [To be supplied.]
wLibFlags | [To be supplied.]
wMajorVerNum | [To be supplied.]
wMinorVerNum | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeLibAttr Class | System.Runtime.InteropServices Namespace


TypeLibAttr Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public TypeLibAttr();
[C++]
public: TypeLibAttr();
[JScript]
public function TypeLibAttr();

See Also

TypeLibAttr Class | TypeLibAttr Members | System.Runtime.InteropServices Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypeLibAttr Fields

The fields of the TypeLibAttr class are listed below. For a complete list of TypeLibAttr class members, see the TypeLibAttr Members topic.

Public:

guid | [To be supplied.]
lcid | [To be supplied.]
syskind | [To be supplied.]
wLibFlags | [To be supplied.]
wMajorVerNum | [To be supplied.]
wMinorVerNum | [To be supplied.]

See Also

TypeLibAttr Class | System.Runtime.InteropServices Namespace


TypeLibAttr.guid

[To be supplied.]

[Visual Basic]
Public guid As Guid
[C#]
public Guid guid;
[C++]
public: Guid guid;
[JScript]
public var guid : Guid;

See Also

TypeLibAttr Class | TypeLibAttr Members | System.Runtime.InteropServices Namespace


TypeLibAttr.lcid

[To be supplied.]

[Visual Basic]
Public lcid As UInt32
[C#]
public uint lcid;
[C++]
public: unsigned int lcid;
[JScript]
public var lcid : UInt32;

See Also

TypeLibAttr Class | TypeLibAttr Members | System.Runtime.InteropServices Namespace


TypeLibAttr.syskind

[To be supplied.]

[Visual Basic]
Public syskind As SYSKIND
[C#]
public SYSKIND syskind;
[C++]
public: SYSKIND syskind;
[JScript]
public var syskind : SYSKIND;

See Also

TypeLibAttr Class | TypeLibAttr Members | System.Runtime.InteropServices Namespace


TypeLibAttr.wLibFlags

[To be supplied.]

[Visual Basic]
Public wLibFlags As LIBFLAGS
[C#]
public LIBFLAGS wLibFlags;
[C++]
public: LIBFLAGS wLibFlags;
[JScript]
public var wLibFlags : LIBFLAGS;

See Also

TypeLibAttr Class | TypeLibAttr Members | System.Runtime.InteropServices Namespace


TypeLibAttr.wMajorVerNum

[To be supplied.]

[Visual Basic]
Public wMajorVerNum As UInt16
[C#]
public ushort wMajorVerNum;
[C++]
public: unsigned short wMajorVerNum;
[JScript]
public var wMajorVerNum : UInt16;

See Also

TypeLibAttr Class | TypeLibAttr Members | System.Runtime.InteropServices Namespace


TypeLibAttr.wMinorVerNum

[To be supplied.]

[Visual Basic]
Public wMinorVerNum As UInt16
[C#]
public ushort wMinorVerNum;
[C++]
public: unsigned short wMinorVerNum;
[JScript]
public var wMinorVerNum : UInt16;

See Also

TypeLibAttr Class | TypeLibAttr Members | System.Runtime.InteropServices Namespace


TypeLibConverter Class

[To be supplied.]

Object
TypeLibConverter

[Visual Basic]
NotInheritable Public Class TypeLibConverter
   Implements ITypeLibConverter
[C#]
public sealed class TypeLibConverter : ITypeLibConverter
[C++]
public __gc __sealed class TypeLibConverter : public
   ITypeLibConverter
[JScript]
public class TypeLibConverter implements ITypeLibConverter

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

TypeLibConverter Members | System.Runtime.InteropServices Namespace


TypeLibConverter Members

Public:

Constructor

TypeLibConverter Constructor [To be supplied.]

Methods

ConvertAssemblyToTypeLib | [To be supplied.]
ConvertTypeLibToAssembly | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeLibConverter Class | System.Runtime.InteropServices Namespace


TypeLibConverter Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public TypeLibConverter();
[C++]
public: TypeLibConverter();
[JScript]
public function TypeLibConverter();

See Also

TypeLibConverter Class | TypeLibConverter Members | System.Runtime.InteropServices Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypeLibConverter Methods

The methods of the TypeLibConverter class are listed below. For a complete list of TypeLibConverter class members, see the TypeLibConverter Members topic.

Public:

ConvertAssemblyToTypeLib | [To be supplied.]
ConvertTypeLibToAssembly | [To be supplied.]
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeLibConverter Class | System.Runtime.InteropServices Namespace


TypeLibConverter.ConvertAssemblyToTypeLib

[To be supplied.]

[Visual Basic]
Overridable Public Function ConvertAssemblyToTypeLib( _
   ByVal assembly As Assembly, _
   ByVal strTypeLibName As String, _
   ByVal flags As Integer, _
   ByVal notifySink As ITypeLibExporterNotifySink _
) As Object
[C#]
public virtual object ConvertAssemblyToTypeLib(
   Assembly assembly,
   string strTypeLibName,
   int flags,
   ITypeLibExporterNotifySink notifySink
);
[C++]
public: virtual Object* ConvertAssemblyToTypeLib(
   Assembly* assembly,
   String* strTypeLibName,
   int flags,
   ITypeLibExporterNotifySink* notifySink
);
[JScript]
public function ConvertAssemblyToTypeLib(
   assembly : Assembly,
   strTypeLibName : String,
   flags : int,
   notifySink : ITypeLibExporterNotifySink
) : Object;

Parameters

assembly
[To be supplied.]
strTypeLibName
[To be supplied.]
flags
[To be supplied.]
notifySink
[To be supplied.]

See Also

TypeLibConverter Class | TypeLibConverter Members | System.Runtime.InteropServices Namespace


TypeLibConverter.ConvertTypeLibToAssembly

[To be supplied.]

[Visual Basic]
Overridable Public Function ConvertTypeLibToAssembly( _
   ByVal typeLib As Object, _
   ByVal asmFileName As String, _
   ByVal flags As Integer, _
   ByVal notifySink As ITypeLibImporterNotifySink, _
   ByVal originator() As Byte, _
   ByVal keyPair As StrongNameKeyPair, _
   ByVal unsafeInterfaces As Boolean _
) As AssemblyBuilder
[C#]
public virtual AssemblyBuilder ConvertTypeLibToAssembly(
   object typeLib,
   string asmFileName,
   int flags,
   ITypeLibImporterNotifySink notifySink,
   byte[] originator,
   StrongNameKeyPair keyPair,
   bool unsafeInterfaces
);
[C++]
public: virtual AssemblyBuilder* ConvertTypeLibToAssembly(
   Object* typeLib,
   String* asmFileName,
   int flags,
   ITypeLibImporterNotifySink* notifySink,
   unsigned char* originator[],
   StrongNameKeyPair* keyPair,
   bool unsafeInterfaces
);
[JScript]
public function ConvertTypeLibToAssembly(
   typeLib : Object,
   asmFileName : String,
   flags : int,
   notifySink : ITypeLibImporterNotifySink,
   originator : Byte[],
   keyPair : StrongNameKeyPair,
   unsafeInterfaces : Boolean
) : AssemblyBuilder;

Parameters

typeLib
[To be supplied.]
asmFileName
[To be supplied.]
flags
[To be supplied.]
notifySink
[To be supplied.]
originator
[To be supplied.]
keyPair
[To be supplied.]
unsafeInterfaces
[To be supplied.]

See Also

TypeLibConverter Class | TypeLibConverter Members | System.Runtime.InteropServices Namespace


TypeLibFuncAttribute Class

Contains the FUNCFLAGS that were originally imported for this function from the COM type library.

Object
Attribute
TypeLibFuncAttribute

[Visual Basic]
Public Class TypeLibFuncAttribute
   Inherits Attribute
[C#]
public class TypeLibFuncAttribute : Attribute
[C++]
public __gc class TypeLibFuncAttribute : public Attribute
[JScript]
public class TypeLibFuncAttribute extends Attribute

Remarks

Can be used to attribute methods.

This attribute is set by the type library importer and should never be changed. The attribute is designed to be used by tools that need to know how the original FUNCFLAGS were set. The NGWS runtime does not use this attribute.

See the Interop spec for complete details on this attribute.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

TypeLibFuncAttribute Members | System.Runtime.InteropServices Namespace


TypeLibFuncAttribute Members

Public:

Constructor

TypeLibFuncAttribute Constructor Overloaded. [To be supplied.]

Properties

Value [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeLibFuncAttribute Class | System.Runtime.InteropServices Namespace


TypeLibFuncAttribute Constructor

[To be supplied.]

Overload List

Initializes a new instance of the TypeLibFuncAttribute class.

[Visual Basic] Overloads Public Sub New(TypeLibFuncFlags)
[C#] public TypeLibFuncAttribute(TypeLibFuncFlags);
[C++] public: TypeLibFuncAttribute(TypeLibFuncFlags);
[JScript] public function TypeLibFuncAttribute(TypeLibFuncFlags);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public TypeLibFuncAttribute(short);
[C++] public: TypeLibFuncAttribute(short);
[JScript] public function TypeLibFuncAttribute(Int16);

See Also

TypeLibFuncAttribute Class | TypeLibFuncAttribute Members | System.Runtime.InteropServices Namespace


TypeLibFuncAttribute Constructor (TypeLibFuncFlags)

Initializes a new instance of the TypeLibFuncAttribute class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal val As TypeLibFuncFlags _
)
[C#]
public TypeLibFuncAttribute(
   TypeLibFuncFlags val
);
[C++]
public: TypeLibFuncAttribute(
   TypeLibFuncFlags val
);
[JScript]
public function TypeLibFuncAttribute(
   val : TypeLibFuncFlags
);

Parameters

val
[To be supplied.]

See Also

TypeLibFuncAttribute Class | TypeLibFuncAttribute Members | System.Runtime.InteropServices Namespace | TypeLibFuncAttribute Constructor Overload List


TypeLibFuncAttribute Constructor (Int16)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal val As Short _
)
[C#]
public TypeLibFuncAttribute(
   short val
);
[C++]
public: TypeLibFuncAttribute(
   short val
);
[JScript]
public function TypeLibFuncAttribute(
   val : Int16
);

Parameters

val
[To be supplied.]

See Also

TypeLibFuncAttribute Class | TypeLibFuncAttribute Members | System.Runtime.InteropServices Namespace | TypeLibFuncAttribute Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypeLibFuncAttribute Properties

The properties of the TypeLibFuncAttribute class are listed below. For a complete list of TypeLibFuncAttribute class members, see the TypeLibFuncAttribute Members topic.

Public:

Value [To be supplied.]

See Also

TypeLibFuncAttribute Class | System.Runtime.InteropServices Namespace


TypeLibFuncAttribute.Value

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Value As TypeLibFuncFlags
[C#]
public TypeLibFuncFlags Value {virtual get;}
[C++]
public: __property virtual TypeLibFuncFlags get_Value();
[JScript]
public function get Value() : TypeLibFuncFlags;

See Also

TypeLibFuncAttribute Class | TypeLibFuncAttribute Members | System.Runtime.InteropServices Namespace


TypeLibFuncFlags Enumeration

Describes the original settings of the FUNCFLAGS in the COM type library from where this method was imported.

[Visual Basic]
Public Enum TypeLibFuncFlags
[C#]
public enum TypeLibFuncFlags
[C++]
public enum TypeLibFuncFlags

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

TypeLibFuncFlags is used with the TypeLibFuncAttribute. The flags are retained for reference only. They are not used by the NGWS runtime.

See the Interop Metadata spec for complete details.

Members

Member Name | Description
FBindable | [To be supplied.]
FDefaultBind | [To be supplied.]
FDefaultCollelem | [To be supplied.]
FDisplayBind | [To be supplied.]
FHidden | [To be supplied.]
FImmediateBind | [To be supplied.]
FNonBrowsable | [To be supplied.]
FReplaceable | [To be supplied.]
FRequestEdit | [To be supplied.]
FRestricted | [To be supplied.]
FSource | [To be supplied.]
FUiDefault | [To be supplied.]
FUsesGetLastError | [To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

System.Runtime.InteropServices Namespace


TypeLibTypeAttribute Class

Contains the TYPEFLAGS that were originally imported for this type from the COM type library.

Object
Attribute
TypeLibTypeAttribute

[Visual Basic]
Public Class TypeLibTypeAttribute
   Inherits Attribute
[C#]
public class TypeLibTypeAttribute : Attribute
[C++]
public __gc class TypeLibTypeAttribute : public Attribute
[JScript]
public class TypeLibTypeAttribute extends Attribute

Remarks

Can be used to attribute classes or interfaces.

This attribute is set by the type library importer and should never be changed. The attribute is designed to be used by tools that need to know how the original TYPEFLAGS were set. The NGWS runtime does not use this attribute.

See the Interop spec for complete details on this attribute.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

TypeLibTypeAttribute Members | System.Runtime.InteropServices Namespace


TypeLibTypeAttribute Members

Public:

Constructor

TypeLibTypeAttribute Constructor Overloaded. [To be supplied.]

Properties

Value [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeLibTypeAttribute Class | System.Runtime.InteropServices Namespace


TypeLibTypeAttribute Constructor

[To be supplied.]

Overload List

Initializes a new instance of the TypeLibTypeAttribute class.

[Visual Basic] Overloads Public Sub New(TypeLibTypeFlags)
[C#] public TypeLibTypeAttribute(TypeLibTypeFlags);
[C++] public: TypeLibTypeAttribute(TypeLibTypeFlags);
[JScript] public function TypeLibTypeAttribute(TypeLibTypeFlags);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public TypeLibTypeAttribute(short);
[C++] public: TypeLibTypeAttribute(short);
[JScript] public function TypeLibTypeAttribute(Int16);

See Also

TypeLibTypeAttribute Class | TypeLibTypeAttribute Members | System.Runtime.InteropServices Namespace


TypeLibTypeAttribute Constructor (TypeLibTypeFlags)

Initializes a new instance of the TypeLibTypeAttribute class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal val As TypeLibTypeFlags _
)
[C#]
public TypeLibTypeAttribute(
   TypeLibTypeFlags val
);
[C++]
public: TypeLibTypeAttribute(
   TypeLibTypeFlags val
);
[JScript]
public function TypeLibTypeAttribute(
   val : TypeLibTypeFlags
);

Parameters

val
[To be supplied.]

See Also

TypeLibTypeAttribute Class | TypeLibTypeAttribute Members | System.Runtime.InteropServices Namespace | TypeLibTypeAttribute Constructor Overload List


TypeLibTypeAttribute Constructor (Int16)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal val As Short _
)
[C#]
public TypeLibTypeAttribute(
   short val
);
[C++]
public: TypeLibTypeAttribute(
   short val
);
[JScript]
public function TypeLibTypeAttribute(
   val : Int16
);

Parameters

val
[To be supplied.]

See Also

TypeLibTypeAttribute Class | TypeLibTypeAttribute Members | System.Runtime.InteropServices Namespace | TypeLibTypeAttribute Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypeLibTypeAttribute Properties

The properties of the TypeLibTypeAttribute class are listed below. For a complete list of TypeLibTypeAttribute class members, see the TypeLibTypeAttribute Members topic.

Public:

Value [To be supplied.]

See Also

TypeLibTypeAttribute Class | System.Runtime.InteropServices Namespace


TypeLibTypeAttribute.Value

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Value As TypeLibTypeFlags
[C#]
public TypeLibTypeFlags Value {virtual get;}
[C++]
public: __property virtual TypeLibTypeFlags get_Value();
[JScript]
public function get Value() : TypeLibTypeFlags;

See Also

TypeLibTypeAttribute Class | TypeLibTypeAttribute Members | System.Runtime.InteropServices Namespace


TypeLibTypeFlags Enumeration

Describes the original settings of the TYPEFLAGS in the COM type library from which the type was imported.

[Visual Basic]
Public Enum TypeLibTypeFlags
[C#]
public enum TypeLibTypeFlags
[C++]
public enum TypeLibTypeFlags

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

TypeLibTypeFlags is used along with the TypeLibTypeAttribute. The flags are retained for reference only. They are not used by the runtime.

See the Interop Metadata spec for complete details.

Members

Member Name | Description
FAggregatable | [To be supplied.]
FAppObject | [To be supplied.]
FCanCreate | [To be supplied.]
FControl | [To be supplied.]
FDispatchable | [To be supplied.]
FDual | [To be supplied.]
FHidden | [To be supplied.]
FLicensed | [To be supplied.]
FNonExtensible | [To be supplied.]
FOleAutomation | [To be supplied.]
FPreDeclId | [To be supplied.]
FReplaceable | [To be supplied.]
FRestricted | [To be supplied.]
FReverseBind | [To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

System.Runtime.InteropServices Namespace


TypeLibVarAttribute Class

Contains the VARFLAGS that were originally imported for this variable from the COM type library.

Object
Attribute
TypeLibVarAttribute

[Visual Basic]
Public Class TypeLibVarAttribute
   Inherits Attribute
[C#]
public class TypeLibVarAttribute : Attribute
[C++]
public __gc class TypeLibVarAttribute : public Attribute
[JScript]
public class TypeLibVarAttribute extends Attribute

Remarks

Can be used to attribute fields.

This attribute is set by the type library importer and should never be changed. The attribute is designed to be used by tools that need to know how the original VARFLAGS were set. The runtime does not use this attribute.

See the Interop Metadata spec for complete details on this attribute.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

TypeLibVarAttribute Members | System.Runtime.InteropServices Namespace


TypeLibVarAttribute Members

Public:

Constructor

TypeLibVarAttribute Constructor Overloaded. [To be supplied.]

Properties

Value [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeLibVarAttribute Class | System.Runtime.InteropServices Namespace


TypeLibVarAttribute Constructor

[To be supplied.]

Overload List

Initializes a new instance of the TypeLibVarAttribute class.

[Visual Basic] Overloads Public Sub New(TypeLibVarFlags)
[C#] public TypeLibVarAttribute(TypeLibVarFlags);
[C++] public: TypeLibVarAttribute(TypeLibVarFlags);
[JScript] public function TypeLibVarAttribute(TypeLibVarFlags);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Integer)
[C#] public TypeLibVarAttribute(short);
[C++] public: TypeLibVarAttribute(short);
[JScript] public function TypeLibVarAttribute(Int16);

See Also

TypeLibVarAttribute Class | TypeLibVarAttribute Members | System.Runtime.InteropServices Namespace


TypeLibVarAttribute Constructor (TypeLibVarFlags)

Initializes a new instance of the TypeLibVarAttribute class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal val As TypeLibVarFlags _
)
[C#]
public TypeLibVarAttribute(
   TypeLibVarFlags val
);
[C++]
public: TypeLibVarAttribute(
   TypeLibVarFlags val
);
[JScript]
public function TypeLibVarAttribute(
   val : TypeLibVarFlags
);

Parameters

val
[To be supplied.]

See Also

TypeLibVarAttribute Class | TypeLibVarAttribute Members | System.Runtime.InteropServices Namespace | TypeLibVarAttribute Constructor Overload List


TypeLibVarAttribute Constructor (Int16)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal val As Short _
)
[C#]
public TypeLibVarAttribute(
   short val
);
[C++]
public: TypeLibVarAttribute(
   short val
);
[JScript]
public function TypeLibVarAttribute(
   val : Int16
);

Parameters

val
[To be supplied.]

See Also

TypeLibVarAttribute Class | TypeLibVarAttribute Members | System.Runtime.InteropServices Namespace | TypeLibVarAttribute Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

TypeLibVarAttribute Properties

The properties of the TypeLibVarAttribute class are listed below. For a complete list of TypeLibVarAttribute class members, see the TypeLibVarAttribute Members topic.

Public:

Value [To be supplied.]

See Also

TypeLibVarAttribute Class | System.Runtime.InteropServices Namespace


TypeLibVarAttribute.Value

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Value As TypeLibVarFlags
[C#]
public TypeLibVarFlags Value {virtual get;}
[C++]
public: __property virtual TypeLibVarFlags get_Value();
[JScript]
public function get Value() : TypeLibVarFlags;

See Also

TypeLibVarAttribute Class | TypeLibVarAttribute Members | System.Runtime.InteropServices Namespace


TypeLibVarFlags Enumeration

Describes the original settings of the VARFLAGS in the COM type library from which the variable was imported.

[Visual Basic]
Public Enum TypeLibVarFlags
[C#]
public enum TypeLibVarFlags
[C++]
public enum TypeLibVarFlags

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Remarks

TypeLibVarFlags is used along with the TypeLibVarAttribute. The flags are retained for reference only. They are not used by the NGWS runtime.

See the Interop Metadata spec for complete details.

Members

Member Name | Description
FBindable | [To be supplied.]
FDefaultBind | [To be supplied.]
FDefaultCollelem | [To be supplied.]
FDisplayBind | [To be supplied.]
FHidden | [To be supplied.]
FImmediateBind | [To be supplied.]
FNonBrowsable | [To be supplied.]
FReadOnly | [To be supplied.]
FReplaceable | [To be supplied.]
FRequestEdit | [To be supplied.]
FRestricted | [To be supplied.]
FSource | [To be supplied.]
FUiDefault | [To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

System.Runtime.InteropServices Namespace


UCOMIConnectionPoint Interface

Used by the custom connection point marshaler that the NGWS runtime provides.

UCOMIConnectionPoint

[Visual Basic]
Public Interface UCOMIConnectionPoint
[C#]
public interface UCOMIConnectionPoint
[C++]
public __gc __interface UCOMIConnectionPoint

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

See the Interop spec for complete details on the use of this interface.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

UCOMIConnectionPoint Members | System.Runtime.InteropServices Namespace


UCOMIConnectionPoint Members

Methods

Advise | [To be supplied.]
EnumConnections | [To be supplied.]
GetConnectionInterface | [To be supplied.]
GetConnectionPointContainer | [To be supplied.]
Unadvise | [To be supplied.]

See Also

UCOMIConnectionPoint Interface | System.Runtime.InteropServices Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UCOMIConnectionPoint Methods

The methods of the UCOMIConnectionPoint interface are listed below. For a complete list of UCOMIConnectionPoint interface members, see the UCOMIConnectionPoint Members topic.

Advise | [To be supplied.]
EnumConnections | [To be supplied.]
GetConnectionInterface | [To be supplied.]
GetConnectionPointContainer | [To be supplied.]
Unadvise | [To be supplied.]

See Also

UCOMIConnectionPoint Interface | System.Runtime.InteropServices Namespace


UCOMIConnectionPoint.Advise

[To be supplied.]

[Visual Basic]
Sub Advise( _
   ByVal pUnkSink As Object, _
   ByRef pdwCookie As Integer _
)
[C#]
void Advise(
   object pUnkSink,
   ref int pdwCookie
);
[C++]
void Advise(
   Object* pUnkSink,
   int** pdwCookie
) = 0;
[JScript]
function Advise(
   pUnkSink : Object,
   pdwCookie : int
);

Parameters

pUnkSink
[To be supplied.]
pdwCookie
[To be supplied.]

See Also

UCOMIConnectionPoint Interface | UCOMIConnectionPoint Members | System.Runtime.InteropServices Namespace


UCOMIConnectionPoint.EnumConnections

[To be supplied.]

[Visual Basic]
Sub EnumConnections()
[C#]
void EnumConnections();
[C++]
void EnumConnections() = 0;
[JScript]
function EnumConnections();

See Also

UCOMIConnectionPoint Interface | UCOMIConnectionPoint Members | System.Runtime.InteropServices Namespace


UCOMIConnectionPoint.GetConnectionInterface

[To be supplied.]

[Visual Basic]
Sub GetConnectionInterface()
[C#]
void GetConnectionInterface();
[C++]
void GetConnectionInterface() = 0;
[JScript]
function GetConnectionInterface();

See Also

UCOMIConnectionPoint Interface | UCOMIConnectionPoint Members | System.Runtime.InteropServices Namespace


UCOMIConnectionPoint.GetConnectionPointContainer

[To be supplied.]

[Visual Basic]
Sub GetConnectionPointContainer()
[C#]
void GetConnectionPointContainer();
[C++]
void GetConnectionPointContainer() = 0;
[JScript]
function GetConnectionPointContainer();

See Also

UCOMIConnectionPoint Interface | UCOMIConnectionPoint Members | System.Runtime.InteropServices Namespace


UCOMIConnectionPoint.Unadvise

[To be supplied.]

[Visual Basic]
Sub Unadvise( _
   ByVal dwCookie As Integer _
)
[C#]
void Unadvise(
   int dwCookie
);
[C++]
void Unadvise(
   int dwCookie
) = 0;
[JScript]
function Unadvise(
   dwCookie : int
);

Parameters

dwCookie
[To be supplied.]

See Also

UCOMIConnectionPoint Interface | UCOMIConnectionPoint Members | System.Runtime.InteropServices Namespace


UCOMIConnectionPointContainer Interface

UCOMIConnectionPointContainer interface definition.

UCOMIConnectionPointContainer

[Visual Basic]
Public Interface UCOMIConnectionPointContainer
[C#]
public interface UCOMIConnectionPointContainer
[C++]
public __gc __interface UCOMIConnectionPointContainer

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

UCOMIConnectionPointContainer Members | System.Runtime.InteropServices Namespace


UCOMIConnectionPointContainer Members

Methods

EnumConnectionPoints | [To be supplied.]
FindConnectionPoint | [To be supplied.]

See Also

UCOMIConnectionPointContainer Interface | System.Runtime.InteropServices Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UCOMIConnectionPointContainer Methods

The methods of the UCOMIConnectionPointContainer interface are listed below. For a complete list of UCOMIConnectionPointContainer interface members, see the UCOMIConnectionPointContainer Members topic.

EnumConnectionPoints | [To be supplied.]
FindConnectionPoint | [To be supplied.]

See Also

UCOMIConnectionPointContainer Interface | System.Runtime.InteropServices Namespace


UCOMIConnectionPointContainer.EnumConnectionPoints

[To be supplied.]

[Visual Basic]
Sub EnumConnectionPoints()
[C#]
void EnumConnectionPoints();
[C++]
void EnumConnectionPoints() = 0;
[JScript]
function EnumConnectionPoints();

See Also

UCOMIConnectionPointContainer Interface | UCOMIConnectionPointContainer Members | System.Runtime.InteropServices Namespace


UCOMIConnectionPointContainer.FindConnectionPoint

[To be supplied.]

[Visual Basic]
Sub FindConnectionPoint( _
   ByRef riid As Guid, _
   ByRef ppCP As UCOMIConnectionPoint _
)
[C#]
void FindConnectionPoint(
   ref Guid riid,
   ref UCOMIConnectionPoint ppCP
);
[C++]
void FindConnectionPoint(
   Guid** riid,
   UCOMIConnectionPoint** ppCP
) = 0;
[JScript]
function FindConnectionPoint(
   riid : Guid,
   ppCP : UCOMIConnectionPoint
);

Parameters

riid
[To be supplied.]
ppCP
[To be supplied.]

See Also

UCOMIConnectionPointContainer Interface | UCOMIConnectionPointContainer Members | System.Runtime.InteropServices Namespace


UCOMIEnumVARIANT Interface

[To be supplied.]

UCOMIEnumVARIANT

[Visual Basic]
Public Interface UCOMIEnumVARIANT
[C#]
public interface UCOMIEnumVARIANT
[C++]
public __gc __interface UCOMIEnumVARIANT

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

UCOMIEnumVARIANT Members | System.Runtime.InteropServices Namespace


UCOMIEnumVARIANT Members

Methods

Clone | [To be supplied.]
Next | [To be supplied.]
Reset | [To be supplied.]
Skip | [To be supplied.]

See Also

UCOMIEnumVARIANT Interface | System.Runtime.InteropServices Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UCOMIEnumVARIANT Methods

The methods of the UCOMIEnumVARIANT interface are listed below. For a complete list of UCOMIEnumVARIANT interface members, see the UCOMIEnumVARIANT Members topic.

Clone | [To be supplied.]
Next | [To be supplied.]
Reset | [To be supplied.]
Skip | [To be supplied.]

See Also

UCOMIEnumVARIANT Interface | System.Runtime.InteropServices Namespace


UCOMIEnumVARIANT.Clone

[To be supplied.]

[Visual Basic]
Function Clone( _
   ByVal ppenum As Integer _
) As Integer
[C#]
int Clone(
   int ppenum
);
[C++]
int Clone(
   int ppenum
) = 0;
[JScript]
function Clone(
   ppenum : int
) : int;

Parameters

ppenum
[To be supplied.]

See Also

UCOMIEnumVARIANT Interface | UCOMIEnumVARIANT Members | System.Runtime.InteropServices Namespace


UCOMIEnumVARIANT.Next

[To be supplied.]

[Visual Basic]
Function Next( _
   ByVal celt As Integer, _
   ByVal rgvar As Integer, _
   ByVal pceltFetched As Integer _
) As Integer
[C#]
int Next(
   int celt,
   int rgvar,
   int pceltFetched
);
[C++]
int Next(
   int celt,
   int rgvar,
   int pceltFetched
) = 0;
[JScript]
function Next(
   celt : int,
   rgvar : int,
   pceltFetched : int
) : int;

Parameters

celt
[To be supplied.]
rgvar
[To be supplied.]
pceltFetched
[To be supplied.]

See Also

UCOMIEnumVARIANT Interface | UCOMIEnumVARIANT Members | System.Runtime.InteropServices Namespace


UCOMIEnumVARIANT.Reset

[To be supplied.]

[Visual Basic]
Function Reset() As Integer
[C#]
int Reset();
[C++]
int Reset() = 0;
[JScript]
function Reset() : int;

See Also

UCOMIEnumVARIANT Interface | UCOMIEnumVARIANT Members | System.Runtime.InteropServices Namespace


UCOMIEnumVARIANT.Skip

[To be supplied.]

[Visual Basic]
Function Skip( _
   ByVal celt As Integer _
) As Integer
[C#]
int Skip(
   int celt
);
[C++]
int Skip(
   int celt
) = 0;
[JScript]
function Skip(
   celt : int
) : int;

Parameters

celt
[To be supplied.]

See Also

UCOMIEnumVARIANT Interface | UCOMIEnumVARIANT Members | System.Runtime.InteropServices Namespace


UCOMITypeInfo Interface

[To be supplied.]

UCOMITypeInfo

[Visual Basic]
Public Interface UCOMITypeInfo
[C#]
public interface UCOMITypeInfo
[C++]
public __gc __interface UCOMITypeInfo

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

UCOMITypeInfo Members | System.Runtime.InteropServices Namespace


UCOMITypeInfo Members

Methods

AddressOfMember | [To be supplied.]
CreateInstance | [To be supplied.]
GetContainingTypeLib | [To be supplied.]
GetDllEntry | [To be supplied.]
GetDocumentation | [To be supplied.]
GetFuncDesc | [To be supplied.]
GetIDsOfNames | [To be supplied.]
GetImplTypeFlags | [To be supplied.]
GetMops | [To be supplied.]
GetNames | [To be supplied.]
GetRefTypeInfo | [To be supplied.]
GetRefTypeOfImplType | [To be supplied.]
GetTypeAttr | [To be supplied.]
GetTypeComp | [To be supplied.]
GetVarDesc | [To be supplied.]
Invoke | [To be supplied.]
ReleaseFuncDesc | [To be supplied.]
ReleaseTypeAttr | [To be supplied.]
ReleaseVarDesc | [To be supplied.]

See Also

UCOMITypeInfo Interface | System.Runtime.InteropServices Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UCOMITypeInfo Methods

The methods of the UCOMITypeInfo interface are listed below. For a complete list of UCOMITypeInfo interface members, see the UCOMITypeInfo Members topic.

AddressOfMember | [To be supplied.]
CreateInstance | [To be supplied.]
GetContainingTypeLib | [To be supplied.]
GetDllEntry | [To be supplied.]
GetDocumentation | [To be supplied.]
GetFuncDesc | [To be supplied.]
GetIDsOfNames | [To be supplied.]
GetImplTypeFlags | [To be supplied.]
GetMops | [To be supplied.]
GetNames | [To be supplied.]
GetRefTypeInfo | [To be supplied.]
GetRefTypeOfImplType | [To be supplied.]
GetTypeAttr | [To be supplied.]
GetTypeComp | [To be supplied.]
GetVarDesc | [To be supplied.]
Invoke | [To be supplied.]
ReleaseFuncDesc | [To be supplied.]
ReleaseTypeAttr | [To be supplied.]
ReleaseVarDesc | [To be supplied.]

See Also

UCOMITypeInfo Interface | System.Runtime.InteropServices Namespace


UCOMITypeInfo.AddressOfMember

[To be supplied.]

[Visual Basic]
Sub AddressOfMember()
[C#]
void AddressOfMember();
[C++]
void AddressOfMember() = 0;
[JScript]
function AddressOfMember();

See Also

UCOMITypeInfo Interface | UCOMITypeInfo Members | System.Runtime.InteropServices Namespace


UCOMITypeInfo.CreateInstance

[To be supplied.]

[Visual Basic]
Sub CreateInstance()
[C#]
void CreateInstance();
[C++]
void CreateInstance() = 0;
[JScript]
function CreateInstance();

See Also

UCOMITypeInfo Interface | UCOMITypeInfo Members | System.Runtime.InteropServices Namespace


UCOMITypeInfo.GetContainingTypeLib

[To be supplied.]

[Visual Basic]
Sub GetContainingTypeLib( _
   ByRef ppTLB As UCOMITypeLib, _
   ByRef pIndex As Integer _
)
[C#]
void GetContainingTypeLib(
   ref UCOMITypeLib ppTLB,
   ref int pIndex
);
[C++]
void GetContainingTypeLib(
   UCOMITypeLib** ppTLB,
   int** pIndex
) = 0;
[JScript]
function GetContainingTypeLib(
   ppTLB : UCOMITypeLib,
   pIndex : int
);

Parameters

ppTLB
[To be supplied.]
pIndex
[To be supplied.]

See Also

UCOMITypeInfo Interface | UCOMITypeInfo Members | System.Runtime.InteropServices Namespace


UCOMITypeInfo.GetDllEntry

[To be supplied.]

[Visual Basic]
Sub GetDllEntry()
[C#]
void GetDllEntry();
[C++]
void GetDllEntry() = 0;
[JScript]
function GetDllEntry();

See Also

UCOMITypeInfo Interface | UCOMITypeInfo Members | System.Runtime.InteropServices Namespace


UCOMITypeInfo.GetDocumentation

[To be supplied.]

[Visual Basic]
Sub GetDocumentation( _
   ByVal index As Integer, _
   ByRef strName As String, _
   ByRef strDocString As String, _
   ByRef dwHelpContext As Integer, _
   ByRef strHelpFile As String _
)
[C#]
void GetDocumentation(
   int index,
   ref string strName,
   ref string strDocString,
   ref int dwHelpContext,
   ref string strHelpFile
);
[C++]
void GetDocumentation(
   int index,
   String** strName,
   String** strDocString,
   int** dwHelpContext,
   String** strHelpFile
) = 0;
[JScript]
function GetDocumentation(
   index : int,
   strName : String,
   strDocString : String,
   dwHelpContext : int,
   strHelpFile : String
);

Parameters

index
[To be supplied.]
strName
[To be supplied.]
strDocString
[To be supplied.]
dwHelpContext
[To be supplied.]
strHelpFile
[To be supplied.]

See Also

UCOMITypeInfo Interface | UCOMITypeInfo Members | System.Runtime.InteropServices Namespace


UCOMITypeInfo.GetFuncDesc

[To be supplied.]

[Visual Basic]
Sub GetFuncDesc()
[C#]
void GetFuncDesc();
[C++]
void GetFuncDesc() = 0;
[JScript]
function GetFuncDesc();

See Also

UCOMITypeInfo Interface | UCOMITypeInfo Members | System.Runtime.InteropServices Namespace


UCOMITypeInfo.GetIDsOfNames

[To be supplied.]

[Visual Basic]
Sub GetIDsOfNames()
[C#]
void GetIDsOfNames();
[C++]
void GetIDsOfNames() = 0;
[JScript]
function GetIDsOfNames();

See Also

UCOMITypeInfo Interface | UCOMITypeInfo Members | System.Runtime.InteropServices Namespace


UCOMITypeInfo.GetImplTypeFlags

[To be supplied.]

[Visual Basic]
Sub GetImplTypeFlags()
[C#]
void GetImplTypeFlags();
[C++]
void GetImplTypeFlags() = 0;
[JScript]
function GetImplTypeFlags();

See Also

UCOMITypeInfo Interface | UCOMITypeInfo Members | System.Runtime.InteropServices Namespace


UCOMITypeInfo.GetMops

[To be supplied.]

[Visual Basic]
Sub GetMops()
[C#]
void GetMops();
[C++]
void GetMops() = 0;
[JScript]
function GetMops();

See Also

UCOMITypeInfo Interface | UCOMITypeInfo Members | System.Runtime.InteropServices Namespace


UCOMITypeInfo.GetNames

[To be supplied.]

[Visual Basic]
Sub GetNames()
[C#]
void GetNames();
[C++]
void GetNames() = 0;
[JScript]
function GetNames();

See Also

UCOMITypeInfo Interface | UCOMITypeInfo Members | System.Runtime.InteropServices Namespace


UCOMITypeInfo.GetRefTypeInfo

[To be supplied.]

[Visual Basic]
Sub GetRefTypeInfo( _
   ByVal hRef As Integer, _
   ByRef ppTI As UCOMITypeInfo _
)
[C#]
void GetRefTypeInfo(
   int hRef,
   ref UCOMITypeInfo ppTI
);
[C++]
void GetRefTypeInfo(
   int hRef,
   UCOMITypeInfo** ppTI
) = 0;
[JScript]
function GetRefTypeInfo(
   hRef : int,
   ppTI : UCOMITypeInfo
);

Parameters

hRef
[To be supplied.]
ppTI
[To be supplied.]

See Also

UCOMITypeInfo Interface | UCOMITypeInfo Members | System.Runtime.InteropServices Namespace


UCOMITypeInfo.GetRefTypeOfImplType

[To be supplied.]

[Visual Basic]
Sub GetRefTypeOfImplType( _
   ByVal index As Integer, _
   ByRef href As Integer _
)
[C#]
void GetRefTypeOfImplType(
   int index,
   ref int href
);
[C++]
void GetRefTypeOfImplType(
   int index,
   int** href
) = 0;
[JScript]
function GetRefTypeOfImplType(
   index : int,
   href : int
);

Parameters

index
[To be supplied.]
href
[To be supplied.]

See Also

UCOMITypeInfo Interface | UCOMITypeInfo Members | System.Runtime.InteropServices Namespace


UCOMITypeInfo.GetTypeAttr

[To be supplied.]

[Visual Basic]
Sub GetTypeAttr( _
   ByRef ppTypeAttr As Integer _
)
[C#]
void GetTypeAttr(
   ref int ppTypeAttr
);
[C++]
void GetTypeAttr(
   int** ppTypeAttr
) = 0;
[JScript]
function GetTypeAttr(
   ppTypeAttr : int
);

Parameters

ppTypeAttr
[To be supplied.]

See Also

UCOMITypeInfo Interface | UCOMITypeInfo Members | System.Runtime.InteropServices Namespace


UCOMITypeInfo.GetTypeComp

[To be supplied.]

[Visual Basic]
Sub GetTypeComp()
[C#]
void GetTypeComp();
[C++]
void GetTypeComp() = 0;
[JScript]
function GetTypeComp();

See Also

UCOMITypeInfo Interface | UCOMITypeInfo Members | System.Runtime.InteropServices Namespace


UCOMITypeInfo.GetVarDesc

[To be supplied.]

[Visual Basic]
Sub GetVarDesc()
[C#]
void GetVarDesc();
[C++]
void GetVarDesc() = 0;
[JScript]
function GetVarDesc();

See Also

UCOMITypeInfo Interface | UCOMITypeInfo Members | System.Runtime.InteropServices Namespace


UCOMITypeInfo.Invoke

[To be supplied.]

[Visual Basic]
Sub Invoke()
[C#]
void Invoke();
[C++]
void Invoke() = 0;
[JScript]
function Invoke();

See Also

UCOMITypeInfo Interface | UCOMITypeInfo Members | System.Runtime.InteropServices Namespace


UCOMITypeInfo.ReleaseFuncDesc

[To be supplied.]

[Visual Basic]
Sub ReleaseFuncDesc()
[C#]
void ReleaseFuncDesc();
[C++]
void ReleaseFuncDesc() = 0;
[JScript]
function ReleaseFuncDesc();

See Also

UCOMITypeInfo Interface | UCOMITypeInfo Members | System.Runtime.InteropServices Namespace


UCOMITypeInfo.ReleaseTypeAttr

[To be supplied.]

[Visual Basic]
Sub ReleaseTypeAttr( _
   ByVal pTypeAttr As Integer _
)
[C#]
void ReleaseTypeAttr(
   int pTypeAttr
);
[C++]
void ReleaseTypeAttr(
   int pTypeAttr
) = 0;
[JScript]
function ReleaseTypeAttr(
   pTypeAttr : int
);

Parameters

pTypeAttr
[To be supplied.]

See Also

UCOMITypeInfo Interface | UCOMITypeInfo Members | System.Runtime.InteropServices Namespace


UCOMITypeInfo.ReleaseVarDesc

[To be supplied.]

[Visual Basic]
Sub ReleaseVarDesc()
[C#]
void ReleaseVarDesc();
[C++]
void ReleaseVarDesc() = 0;
[JScript]
function ReleaseVarDesc();

See Also

UCOMITypeInfo Interface | UCOMITypeInfo Members | System.Runtime.InteropServices Namespace


UCOMITypeLib Interface

[To be supplied.]

UCOMITypeLib

[Visual Basic]
Public Interface UCOMITypeLib
[C#]
public interface UCOMITypeLib
[C++]
public __gc __interface UCOMITypeLib

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

UCOMITypeLib Members | System.Runtime.InteropServices Namespace


UCOMITypeLib Members

Methods

FindName | [To be supplied.]
GetDocumentation | [To be supplied.]
GetLibAttr | [To be supplied.]
GetTypeComp | [To be supplied.]
GetTypeInfo | [To be supplied.]
GetTypeInfoCount | [To be supplied.]
GetTypeInfoOfGuid | [To be supplied.]
GetTypeInfoType | [To be supplied.]
IsName | [To be supplied.]
ReleaseTLibAttr | [To be supplied.]

See Also

UCOMITypeLib Interface | System.Runtime.InteropServices Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

UCOMITypeLib Methods

The methods of the UCOMITypeLib interface are listed below. For a complete list of UCOMITypeLib interface members, see the UCOMITypeLib Members topic.

FindName | [To be supplied.]
GetDocumentation | [To be supplied.]
GetLibAttr | [To be supplied.]
GetTypeComp | [To be supplied.]
GetTypeInfo | [To be supplied.]
GetTypeInfoCount | [To be supplied.]
GetTypeInfoOfGuid | [To be supplied.]
GetTypeInfoType | [To be supplied.]
IsName | [To be supplied.]
ReleaseTLibAttr | [To be supplied.]

See Also

UCOMITypeLib Interface | System.Runtime.InteropServices Namespace


UCOMITypeLib.FindName

[To be supplied.]

[Visual Basic]
Sub FindName()
[C#]
void FindName();
[C++]
void FindName() = 0;
[JScript]
function FindName();

See Also

UCOMITypeLib Interface | UCOMITypeLib Members | System.Runtime.InteropServices Namespace


UCOMITypeLib.GetDocumentation

[To be supplied.]

[Visual Basic]
Sub GetDocumentation( _
   ByVal index As Integer, _
   ByRef strName As String, _
   ByRef strDocString As String, _
   ByRef dwHelpContext As Integer, _
   ByRef strHelpFile As String _
)
[C#]
void GetDocumentation(
   int index,
   ref string strName,
   ref string strDocString,
   ref int dwHelpContext,
   ref string strHelpFile
);
[C++]
void GetDocumentation(
   int index,
   String** strName,
   String** strDocString,
   int** dwHelpContext,
   String** strHelpFile
) = 0;
[JScript]
function GetDocumentation(
   index : int,
   strName : String,
   strDocString : String,
   dwHelpContext : int,
   strHelpFile : String
);

Parameters

index
[To be supplied.]
strName
[To be supplied.]
strDocString
[To be supplied.]
dwHelpContext
[To be supplied.]
strHelpFile
[To be supplied.]

See Also

UCOMITypeLib Interface | UCOMITypeLib Members | System.Runtime.InteropServices Namespace


UCOMITypeLib.GetLibAttr

[To be supplied.]

[Visual Basic]
Sub GetLibAttr( _
   ByRef ppTLibAttr As Integer _
)
[C#]
void GetLibAttr(
   ref int ppTLibAttr
);
[C++]
void GetLibAttr(
   int** ppTLibAttr
) = 0;
[JScript]
function GetLibAttr(
   ppTLibAttr : int
);

Parameters

ppTLibAttr
[To be supplied.]

See Also

UCOMITypeLib Interface | UCOMITypeLib Members | System.Runtime.InteropServices Namespace


UCOMITypeLib.GetTypeComp

[To be supplied.]

[Visual Basic]
Sub GetTypeComp()
[C#]
void GetTypeComp();
[C++]
void GetTypeComp() = 0;
[JScript]
function GetTypeComp();

See Also

UCOMITypeLib Interface | UCOMITypeLib Members | System.Runtime.InteropServices Namespace


UCOMITypeLib.GetTypeInfo

[To be supplied.]

[Visual Basic]
Sub GetTypeInfo( _
   ByVal index As Integer, _
   ByRef ppTI As UCOMITypeInfo _
)
[C#]
void GetTypeInfo(
   int index,
   ref UCOMITypeInfo ppTI
);
[C++]
void GetTypeInfo(
   int index,
   UCOMITypeInfo** ppTI
) = 0;
[JScript]
function GetTypeInfo(
   index : int,
   ppTI : UCOMITypeInfo
);

Parameters

index
[To be supplied.]
ppTI
[To be supplied.]

See Also

UCOMITypeLib Interface | UCOMITypeLib Members | System.Runtime.InteropServices Namespace


UCOMITypeLib.GetTypeInfoCount

[To be supplied.]

[Visual Basic]
Function GetTypeInfoCount() As Integer
[C#]
int GetTypeInfoCount();
[C++]
int GetTypeInfoCount() = 0;
[JScript]
function GetTypeInfoCount() : int;

See Also

UCOMITypeLib Interface | UCOMITypeLib Members | System.Runtime.InteropServices Namespace


UCOMITypeLib.GetTypeInfoOfGuid

[To be supplied.]

[Visual Basic]
Sub GetTypeInfoOfGuid()
[C#]
void GetTypeInfoOfGuid();
[C++]
void GetTypeInfoOfGuid() = 0;
[JScript]
function GetTypeInfoOfGuid();

See Also

UCOMITypeLib Interface | UCOMITypeLib Members | System.Runtime.InteropServices Namespace


UCOMITypeLib.GetTypeInfoType

[To be supplied.]

[Visual Basic]
Sub GetTypeInfoType()
[C#]
void GetTypeInfoType();
[C++]
void GetTypeInfoType() = 0;
[JScript]
function GetTypeInfoType();

See Also

UCOMITypeLib Interface | UCOMITypeLib Members | System.Runtime.InteropServices Namespace


UCOMITypeLib.IsName

[To be supplied.]

[Visual Basic]
Sub IsName()
[C#]
void IsName();
[C++]
void IsName() = 0;
[JScript]
function IsName();

See Also

UCOMITypeLib Interface | UCOMITypeLib Members | System.Runtime.InteropServices Namespace


UCOMITypeLib.ReleaseTLibAttr

[To be supplied.]

[Visual Basic]
Sub ReleaseTLibAttr( _
   ByVal pTLibAttr As Integer _
)
[C#]
void ReleaseTLibAttr(
   int pTLibAttr
);
[C++]
void ReleaseTLibAttr(
   int pTLibAttr
) = 0;
[JScript]
function ReleaseTLibAttr(
   pTLibAttr : int
);

Parameters

pTLibAttr
[To be supplied.]

See Also

UCOMITypeLib Interface | UCOMITypeLib Members | System.Runtime.InteropServices Namespace


UnmanagedType Enumeration

Identifies how parameters or fields should be marshaled to unmanaged code.

[Visual Basic]
Public Enum UnmanagedType
[C#]
public enum UnmanagedType
[C++]
public enum UnmanagedType

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
AnsiBStr | ANSI character string that is a length prefixed, single byte.
AsAny | Dynamic type that determines the type of an Object at runtime and marshals the Object as that type.
Bool | 4-byte Boolean value (true != 0, false = 0).
BStr | Unicode character string that is a length prefixed double byte.
ByValArray | A fixed length array. The UnmanagedFormatAttribute must contain the count of elements in the array. The UnmanagedFormatAttribute may optionally contain the unmanaged type of the elements when it is necessary to differentiate among string types.
ByValTStr | A string in a fixed length buffer. The type UnmanagedFormatAttribute must also contain the size of the buffer in bytes. The type of the characters is determined they the Charset used by the class.
CustomMarshaler | Custom marshaler native type. This must be followed by a string of the following format: "Native type name\0Custom marshaler type name\0Optional cookie\0" Or "{Native type GUID}\0Custom marshaler type name\0Optional cookie\0"
Error | This native type associated with an I4 or a U4 will cause the parameter to be exported as an HRESULT in the exported typelib.
FunctionPtr | A function pointer.
I1 | 1-byte signed integer.
I2 | 2-byte signed integer.
I4 | 4-byte signed integer.
I8 | 8-byte signed integer.
IDispatch | A COM IUnknown pointer. This unmanaged type only applies to object.
Interface | A COM interface pointer. The GUID of the interface is obtained from the class metadata.
IUnknown | A COM IUnknown pointer. This unmanaged type only applies to object.
LPArray | An array whose length is determined at runtime by the size of the actual marshaled array. Optionally followed by the unmanaged type of the elements within the array when it is necessary to differentiate among string types. When marshaling from managed to unmanaged, the size of the array is determined dynamically. When marshaling from unmanaged to managed, the size is always assumed to be 1.
LPStr | A single byte ANSI character string.
LPStruct | A pointer to a C-style structure. Used to marshal managed formatted classes and value types.
LPTStr | A platform independent character string, ANSI on Win9x, Unicode on WinNT.
LPVoid | An un-typed 4-byte pointer.
LPWStr | A double byte Unicode character string.
NativeTypeMax | First invalid element type
R4 | 4-byte floating point number.
R8 | 8-byte floating point number.
RPrecise | Size agnostic floating point number.
SafeArray | An OLE Automation SafeArray. The UnmanagedFormatAttribute may optionally supply the unmanaged type of the elements within the array when it is necessary to differentiate among string types.
Struct | A C-style structure, used to marshal managed formatted classes and value types.
SysInt | A platform independent signed integer. 4-bytes on 32 bit Windows, 8-bytes on 64 bit Windows.
SysUInt | Hardware natural sized unsigned integer
TBStr | A length prefixed platform independent char string. ANSI on Windows 9x, Unicode on Windows NT.
U1 | 1-byte unsigned integer.
U2 | 2-byte unsigned integer.
U4 | 4-byte unsigned integer.
U8 | 8-byte unsigned integer.
VariantBool | 8-byte unsigned integer.
VBByRefStr | VB specific.

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

System.Runtime.InteropServices Namespace


VarEnum Enumeration

[To be supplied.]

[Visual Basic]
Public Enum VarEnum
[C#]
public enum VarEnum
[C++]
public enum VarEnum

[JScript] In JScript, you can use the enumerations in the NGWS frameworks, but you cannot define your own.

Members

Member Name | Description
VT_BLOB | [To be supplied.]
VT_BLOB_OBJECT | [To be supplied.]
VT_BOOL | [To be supplied.]
VT_BSTR | [To be supplied.]
VT_CARRAY | [To be supplied.]
VT_CF | [To be supplied.]
VT_CLSID | [To be supplied.]
VT_CY | [To be supplied.]
VT_DATE | [To be supplied.]
VT_DECIMAL | [To be supplied.]
VT_DISPATCH | [To be supplied.]
VT_EMPTY | [To be supplied.]
VT_ERROR | [To be supplied.]
VT_FILETIME | [To be supplied.]
VT_HRESULT | [To be supplied.]
VT_I1 | [To be supplied.]
VT_I2 | [To be supplied.]
VT_I4 | [To be supplied.]
VT_I8 | [To be supplied.]
VT_INT | [To be supplied.]
VT_LPSTR | [To be supplied.]
VT_LPWSTR | [To be supplied.]
VT_NULL | [To be supplied.]
VT_PTR | [To be supplied.]
VT_R4 | [To be supplied.]
VT_R8 | [To be supplied.]
VT_RECORD | [To be supplied.]
VT_SAFEARRAY | [To be supplied.]
VT_STORAGE | [To be supplied.]
VT_STORED_OBJECT | [To be supplied.]
VT_STREAM | [To be supplied.]
VT_STREAMED_OBJECT | [To be supplied.]
VT_UI1 | [To be supplied.]
VT_UI2 | [To be supplied.]
VT_UI4 | [To be supplied.]
VT_UI8 | [To be supplied.]
VT_UINT | [To be supplied.]
VT_UNKNOWN | [To be supplied.]
VT_USERDEFINED | [To be supplied.]
VT_VARIANT | [To be supplied.]
VT_VOID | [To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

System.Runtime.InteropServices Namespace


VTableCallsNotSupportedException Class

[To be supplied.]

Object
Exception
SystemException
VTableCallsNotSupportedException

[Visual Basic]
Public Class VTableCallsNotSupportedException
   Inherits SystemException
[C#]
public class VTableCallsNotSupportedException : SystemException
[C++]
public __gc class VTableCallsNotSupportedException : public
   SystemException
[JScript]
public class VTableCallsNotSupportedException extends
   SystemException

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices

Assembly: mscorlib.dll

See Also

VTableCallsNotSupportedException Members | System.Runtime.InteropServices Namespace


VTableCallsNotSupportedException Members

Public:

Constructor

VTableCallsNotSupportedException Constructor Overloaded. [To be supplied.]

Properties

HelpLink (inherited from Exception) | Retrieves a link to the help file associated with this exception.
InnerException (inherited from Exception) | Retrieves a reference to an inner (that may be nested) exception.
Message (inherited from Exception) | Retrieves the message text.
Source (inherited from Exception) | Retrieves or assigns a string containing the name of the application or the object that has generated the error.
StackTrace (inherited from Exception) | Retrieves the stack trace, which is valuable for determining where the error occurred.
TargetSite (inherited from Exception) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetBaseException (inherited from Exception) | Returns the original exception that caused that exception and other exceptions linked to it.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | Accesses the method that contains the context of the data from the source or destination.
GetType (inherited from Object) | Gets the Type of the Object.
SetHelpLink (inherited from Exception) | Sets the HelpLink property of this exception.
SetObjectData (inherited from Exception) | Sets the object that contains the context of the data from the source or destination.
ToString (inherited from Exception) | Returns the fully qualified name of this exception and the message held by the Message property.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

HResult (inherited from Exception) Protected. Returns a HResult.

See Also

VTableCallsNotSupportedException Class | System.Runtime.InteropServices Namespace


VTableCallsNotSupportedException Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New()
[C#] public VTableCallsNotSupportedException();
[C++] public: VTableCallsNotSupportedException();
[JScript] public function VTableCallsNotSupportedException();

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String)
[C#] public VTableCallsNotSupportedException(String);
[C++] public: VTableCallsNotSupportedException(String*);
[JScript] public function VTableCallsNotSupportedException(String);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(String, Exception)
[C#] public VTableCallsNotSupportedException(String, Exception);
[C++] public: VTableCallsNotSupportedException(String*, Exception);
[JScript] public function VTableCallsNotSupportedException(String, Exception);

See Also

VTableCallsNotSupportedException Class | VTableCallsNotSupportedException Members | System.Runtime.InteropServices Namespace


VTableCallsNotSupportedException Constructor ()

[To be supplied.]

[Visual Basic]
Overloads Public Sub New()
[C#]
public VTableCallsNotSupportedException();
[C++]
public: VTableCallsNotSupportedException();
[JScript]
public function VTableCallsNotSupportedException();

See Also

VTableCallsNotSupportedException Class | VTableCallsNotSupportedException Members | System.Runtime.InteropServices Namespace | VTableCallsNotSupportedException Constructor Overload List


VTableCallsNotSupportedException Constructor (String)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String _
)
[C#]
public VTableCallsNotSupportedException(
   string message
);
[C++]
public: VTableCallsNotSupportedException(
   String* message
);
[JScript]
public function VTableCallsNotSupportedException(
   message : String
);

Parameters

message
[To be supplied.]

See Also

VTableCallsNotSupportedException Class | VTableCallsNotSupportedException Members | System.Runtime.InteropServices Namespace | VTableCallsNotSupportedException Constructor Overload List


VTableCallsNotSupportedException Constructor (String, Exception)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public VTableCallsNotSupportedException(
   string message,
   Exception inner
);
[C++]
public: VTableCallsNotSupportedException(
   String* message,
   Exception* inner
);
[JScript]
public function VTableCallsNotSupportedException(
   message : String,
   inner : Exception
);

Parameters

message
[To be supplied.]
inner
[To be supplied.]

See Also

VTableCallsNotSupportedException Class | VTableCallsNotSupportedException Members | System.Runtime.InteropServices Namespace | VTableCallsNotSupportedException Constructor Overload List


System.Runtime.InteropServices.Expando

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Runtime.InteropServices.Expando Namespace

Interfaces

Interface | Description
IExpando | Allows modification of objects by adding and removing members, represented by MemberInfo objects.


IExpando Interface

Allows modification of objects by adding and removing members, represented by MemberInfo objects.

IExpando

[Visual Basic]
Public Interface IExpando
   Implements IReflect
[C#]
public interface IExpando : IReflect
[C++]
public __gc __interface IExpando : public IReflect

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.InteropServices.Expando

Assembly: mscorlib.dll

See Also

IExpando Members | System.Runtime.InteropServices.Expando Namespace


IExpando Members

Methods

AddField | Adds the named field to the Reflection object.
AddMethod | Add the named method to the reflection object.
AddProperty | Adds the named property to the Reflection object.
RemoveMember | Removes the specified member.

See Also

IExpando Interface | System.Runtime.InteropServices.Expando Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IExpando Methods

The methods of the IExpando interface are listed below. For a complete list of IExpando interface members, see the IExpando Members topic.

AddField | Adds the named field to the Reflection object.
AddMethod | Add the named method to the reflection object.
AddProperty | Adds the named property to the Reflection object.
RemoveMember | Removes the specified member.

See Also

IExpando Interface | System.Runtime.InteropServices.Expando Namespace


IExpando.AddField

Adds the named field to the Reflection object.

[Visual Basic]
Function AddField( _
   ByVal name As String _
) As FieldInfo
[C#]
FieldInfo AddField(
   string name
);
[C++]
FieldInfo* AddField(
   String* name
) = 0;
[JScript]
function AddField(
   name : String
) : FieldInfo;

Parameters

name
The name of the field.

Return Value

A FieldInfo object representing the added field.

See Also

IExpando Interface | IExpando Members | System.Runtime.InteropServices.Expando Namespace


IExpando.AddMethod

Add the named method to the reflection object.

[Visual Basic]
Function AddMethod( _
   ByVal name As String, _
   ByVal method As Delegate _
) As MethodInfo
[C#]
MethodInfo AddMethod(
   string name,
   Delegate method
);
[C++]
MethodInfo* AddMethod(
   String* name,
   Delegate* method
) = 0;
[JScript]
function AddMethod(
   name : String,
   method : Delegate
) : MethodInfo;

Parameters

name
The name of the method.
method
[To be supplied.]

Return Value

A MethodInfo object representing the added method.

See Also

IExpando Interface | IExpando Members | System.Runtime.InteropServices.Expando Namespace


IExpando.AddProperty

Adds the named property to the Reflection object.

[Visual Basic]
Function AddProperty( _
   ByVal name As String _
) As PropertyInfo
[C#]
PropertyInfo AddProperty(
   string name
);
[C++]
PropertyInfo* AddProperty(
   String* name
) = 0;
[JScript]
function AddProperty(
   name : String
) : PropertyInfo;

Parameters

name
The name of the property.

Return Value

A PropertyInfo object representing the added property.

See Also

IExpando Interface | IExpando Members | System.Runtime.InteropServices.Expando Namespace


IExpando.RemoveMember

Removes the specified member.

[Visual Basic]
Sub RemoveMember( _
   ByVal m As MemberInfo _
)
[C#]
void RemoveMember(
   MemberInfo m
);
[C++]
void RemoveMember(
   MemberInfo* m
) = 0;
[JScript]
function RemoveMember(
   m : MemberInfo
);

Parameters

m
Member to be removed.

See Also

IExpando Interface | IExpando Members | System.Runtime.InteropServices.Expando Namespace


System.Runtime.Remoting

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

System.Runtime.Remoting Namespace

Classes

Class | Description
ChannelServices
ConstructionCall | [To be supplied.]
ConstructionResponse | [To be supplied.]
Context Key Points:

A boundary containing a collection of objects with the same usage rules

Context rules include: synchronization, thread affinity, transactions, etc.

Classes are marked with ContextAttribute, which provide the usage rules

Execution system:

On the newobj IL instruction, the EE finds a compatible or creates a new Context for the object

Ensures the rules are enforced when entering and leaving a context

Provides synchronization rules for managed objects

Flexible synchronization model

A context is an ordered sequence of properties that define an environment for the objects resident inside it. Contexts get created during the activation process for objects that are configured to require certain automatic services such synchronization, transactions, just-in-time activation, security etc. Multiple objects can live inside a context.

Below is a brief summary of some of the Context characteristics:

Contexts are a general mechanism that bound a set of objects.

A context is composed from a set of Context properties.

Classes that can be bound to a context are called context-bound classes.

Context-bound objects are referenced directly within their own context and via a proxy when referenced from another context.

Any call from an object in one context to an object in another context will go through a context proxy and be affected by the policy that the combined context properties enforce.

Contexts are created during object activation i.e. a new object is either placed in an existing context or a new one is created for it, but once there, the object stays in its context for life.

A new object's context is generally chosen based on meta-data attributes on the class. This mechanism is extensible via custom attributes. These are known as static context properties, which are compiled into the class meta-data. Dynamic (also known as configuration) context properties can be applied and configured by administrators.

As a general rule, contexts are freed when there are no longer any external references to objects in the context and there are no threads executing in the context.

When context-bound objects access "agile" locations (location accessible from anywhere- like class static variables) that contain context-bound objects, proxy wrapping and unwrapping must be done.

There is one special kind of context property called an AppDomain property. An AppDomain property defines the boundary that contains the set of statics for a program (set of classes). If the same class is loaded into two contexts with different AppDomain properties then two copies of all of its static member variables are created.

Because all context-bound objects can be proxied across contexts, this imposes certain restrictions on how code can manipulate context-bound objects. For example, code cannot access a field on a context-bound object directly. Another example is that non-virtual calls must be made through an indirection and no inlining is allowed (to allow proxies when appropriate). This makes context-bound objects a good bit more expensive than one would like.

Classes, which are not context-bound, are sometimes referred to as agile classes. This should not be confused with agile locations (described below in the location section), although the ideas are parallel. Agile objects are not bound to contexts and they are not proxied across contexts within the same AppDomain. Agile objects are only agile within an AppDomain. Agile objects "live" in the DefaultContext (of which there is one per app-domain). The default context has no non-trivial properties. Any object passes across an AppDomain boundary is considered to be remoted.

Context-bound objects are very appropriate for transaction isolation/ propagation and other features where the cost is acceptable.
ContextAttribute | ContextAttribute is the root for all context attributes. ContextAttribute provides the default implementations of IContextAttribute and IContextProperty. Simple Context properties can derived from ContextAttribute with the context attribute and the context property being in the class. For more specialized or more sophisticated needs the context attribute still derives from ContextAttribute and context property can be split into a separated class.
ContextProperty
Embedded | [To be supplied.]
Header | Defines the out-of-band data for a call.
Lease
LeaseManager | The LeaseManager is responsible for managing and maintaining a list of registered leases and notifying the relevant sponsors of any changes in the state of the lease.
LeaseSink ????????????????????????????????????????
LifetimeServices
MethodCall | [To be supplied.]
MethodResponse | [To be supplied.]
ObjectHandle | [To be supplied.]
ObjRef Defines the marshaled object reference class.

An ObjRef is a serializable representation of an object used to transfer an object reference across an AppDomain boundary. The act of creating an ObjRef for an object is called marshaling. The ObjRef can be transferred via a channel into another AppDomain (possibly on another process or machine). Once in the other AppDomain, the ObjRef must be parsed to create a Proxy for the Object, generally connected to the real Object. This operation is called unmarshaling. ObjRefs have enough information that describes the Type/ class of the object being marshaled (like the class hierarchy), something that will uniquely identify the specific object instance (the URI) and how to reach the remoting-subdivision where the object lives (communication related information).

An important notion to be aware of about marshaling are the semantics of Marshal-by-Value versus Marshal-by-Reference. When a reference to an Object is converted to an ObjRef such that the Proxy created after unmarshaling talks to the original object for most method calls via a proxy, this is called Marshal-by-Reference. However, there are objects whose state does not change in any interesting way once initialized. For such objects, it makes sense to send over the entire state of the Object in the ObjRef and then create a local object that is a clone of the remote one within the remoting-boundary of the client. This is called Marshal-by-Value.
OneWayAttribute | [To be supplied.]
RealProxy
RemotingException | This class is the exception class for remoting. An Exception is thrown when something has gone wrong during remoting.
RemotingServices
RemotingSurrogateSelector | [To be supplied.]
ReturnMessage | This class implements IMethodReturnMessage which is used to return a message in response to a method call on an object at the end of the message sink.
SchemaType | [To be supplied.]
Synchronization | [To be supplied.]
ThreadAffinity Key Points:

Refinement of Synchronized Context

Mark type with Thread Affinity Context Attribute

Only a single thread allowed to execute within the Synchronization Domain, hence only that thread can access instance fields and methods

Useful:

User Interface objects

Objects that hold onto OS resource that should only be accessed on the thread that created them

The Thread Affinity Context Property provides a similar capability as the Synchronization Context property with the further constraint that only a single thread is allow to execute within the context or synchronization domain at any time. This is useful for objects that could hold onto OS resources that should only be accessed from a particular thread and only that thread. Thread Affinity is useful when users want to always access the object on the same thread. Certain UI resources should only be accessed on the same thread, on which they were created.

An instance of this property in a context enforces a thread affinity domain for the context (and all contexts that share the same instance). This means that for all contexts sharing an instance of this property, all methods on objects resident in those contexts will execute on the same thread for the lifetime of the objects.

This is done by contributing message sinks that intercept and serialize in-coming calls.

If the property is marked for reentrancy, then call-outs are intercepted too. The call-out interception allows other waiting calls to enter the thread affinity domain.

[ThreadAffinity()]

public class Foo: ContextBoundObject

{

. . .// implementation for Foo

}

// Make an instance of Foo

void SomeOtherMethod(void)

{

. . . Foo foo = new Foo();

}
TrackingServices
URLAttribute | [To be supplied.]
XmlNamespaceEncoder | [To be supplied.]

Interfaces

Interface | Description
IActivator
IChannel Channels provide conducts for messages that cross remoting boundaries (for example, Context, AppDomain, Processes, and Machines). These crossings include both inbound and outbound. A channel can listen on an endpoint for inbound messages or send to an endpoint for outbound messages or both. This provides an extensibility point in the runtime to plug in a wide range protocols, even though the runtime may not be at the other end of the channel.

Runtime objects can be used to expose and represent a wide and rich set of semantics and entities. The channel provides the extensibility point to convert the messages to and from the specific protocols. If there are runtimes are both ends of the channel, a "virtual channel" is created between the two ends, in order to connect the client and sever sink chains on either side of the boundary together.

The client part of the channel is located at the end of Client context sink chain. The server part of the channel is located at the start of the Server context sink chain. Messages are delivered to the client channel via the IMessageSink interface, travel through the channel, and are received by the server channel. The server channel delivers the message to the first server context sink. Channels must expose the IChannel interface, which provides informational properties such as the ChannelName, ChannelPriority and MimeType. Channels are registered via RegisterChannel.
IChannelInfo | Provides custom channel information that is carried along with the ObjRef.
IChannelReceiver
IChannelSender | The sending side of channels must expose the IChannelSender interface.
IConstructionCallMessage | [To be supplied.]
IConstructionReturnMessage | [To be supplied.]
IContextAttribute | Determines whether a particular context is OK for the context attribute and returns a context property for a new context.
IContextProperty | Gathers naming information from the context property and determines whether the new context is ok for the context property.
IContextPropertyActivator
IContributeClientContextSink | Contributes an interception sink at the context boundary on the client end of a remoting call.
IContributeDynamicSink | The IContributeDynamicSink interface is implemented by properties that are registered at runtime through the RemotingServicesRegisterDynamicProperty API. These properties can contribute sinks that are notified when remoting calls start and finish.
IContributeEnvoySink The IContributeEnvoySink interface is implemented by context properties in the Server Context that wish to contribute an envoy message sink on the client end. The Server Envoy Chain is composed from those context properties that implement IContributeEnvoySink interface. The Envoy Chain lives on the client end and acts as representative of the corresponding message sinks from the server context properties.

See also Context.
IContributeObjectSink The IContributeObjectSink interface is implemented by context properties in a Context that wish to contribute an object specific interception sink on the server end of a remoting call.

The Server Object Chain is composed from those context properties in the server object's context that implement IContributeObjectSink interface. (Just-In-Time activation is an example of such a property, i.e. the message sink would activate the object after the call arrives and then pass the message on to the object.)
IContributeServerContextSink The IContributeServerContextSink interface is implemented by context properties in a Context that wish to contribute an interception sink at the context boundary on the server end of a remoting call.

The Server Context Chain is composed from those properties in the server context that implement IContributeServerContextSink interface and which contribute a sink via the GetServerContextSink method call. This chain is cached for future use. Thread Affinity could be an example of such a context property i.e. in this case the MessageSink would involve switching to a specific thread before processing a call further.
IDynamicMessageSink | IDynamicMessageSink is implemented by message sinks provided by dynamically registered properties. These sinks are provided notifications of call-start and call-finish with flags indicating whether the call is currently on the client-side or server-side (this is useful for the context level sinks).
IDynamicProperty ??????????????????????????????????????
IEnvoyInfo | Provides envoy information. Users can use this interface to provide custom envoy information that is carried along with the ObjRef.
ILease | Distributed Garbage Collection (DGC) controls when server applications can be deleted. Traditionally DGC uses reference counts and pinging for control. This works well when there are a few clients per service, but doesn't scale well when there are thousands of clients per service. A Leasing Distributed Garbage Collector (LDGC) associates a lease time with each service. The service is deleted when the lease's time expires. The LDGC can subsume the function of a traditional DGC, in addition it scales well when the numbers of clients increase per server.
IMessage Messages can be thought of as a container for communicating data between co-operating, message sinks. These message sinks could be anywhere along the message sink chain: in the client sink chains or in the server sink chains. A message object is passed from message sink to message sink, through the chain and carries set of named properties such as, but not limited to, action identifiers, envoy information, and parameters.

An object that implements the interface IMessage meets the minimum qualification to be considered a message object. Also, there is no restriction that the exact object received by a message sink must be passed on to the next sink, though this will often be the case.

Although it is not a requirement that the objects in the property bag be serializable, it is certainly something that the message sink implementer would want to consider since an properties that need to flow out of the application domain will need to be serializable. Objects should also be agile if they are to be used in cross-context, same app-domain calls.
IMessageCtrl | Provides a way to control asynchronous messages once they have dispatched via IMessageSink::AsyncProcessMessage.
IMessageSink When a method call is made on the proxy, the remoting infrastructure provides the necessary support for:

Passing the arguments to the actual object across the remoting boundaries.

Calling the actual object method with the arguments.

Returning the results back to the client of the proxy object.

A remote method call is defined in terms of a Message that goes from the client end to the server end and possibly back again. As it crosses interesting boundaries on the way, it passes through a chain of MessageSink objects. Each sink in the chain receives the Message object, performs a specific operation and delegates to the next sink in the chain. The Proxy object contains a reference to the first MessageSink it needs to use, to start off the chain.

For asynchronous calls, at the time of delegation, each sink provides a ReplySink (another MessageSink object) that will be called by the next sink when the reply is on its way back.

The nature of the operation performed by a MessageSink when it receives a Message object to process may be radically different for different types of sinks. For example, one sink could cause a lock to be taken, another could enforce call security, another could be performing flow call control/ reliability services and yet another could be responsible for transporting the call to a different AppDomain/ process/ machine. Two or more message sinks in the chain may communicate and interact with each other in regard to each specific action.
IMethodCallMessage | [To be supplied.]
IMethodMessage | [To be supplied.]
IMethodReturnMessage | [To be supplied.]
IObjectHandle | [To be supplied.]
IRemotingFormatter | Provides the interface for all formatters.
IRemotingTypeInfo | Interface for providing type information. Users can use this interface to provide custom type information that is carried along with the ObjRef.
ISchemaType | [To be supplied.]
ISponsor
ITrackingHandler | The ITrackingHandler interface is called by Remoting when an event happens on an object or proxy.

Delegates

Delegate | Description
CrossContextDelegate | Every subclass of Delegate and MulticastDelegate has a constructor and an Invoke method. See the managed C++ code example given in the description for Delegate. Delegate defined for context callbacks. It is expected to be a function on an agile object.
HeaderHandler | The HeaderHandler delegate is used to process headers on the stream during serialization. Every subclass of Delegate and MulticastDelegate has a constructor and an Invoke method. See the managed C++ code example given in the description for Delegate.
MessageSurrogateFilter | [To be supplied.]

Enumerations

Enumeration | Description
LeaseState | The different lease states are Null:= The lease is not initialized. Initial:= Active:= Renewing:= Expired:=
WellKnownObjectMode |


ChannelServices Class

Object
ChannelServices

[Visual Basic]
NotInheritable Public Class ChannelServices
[C#]
public sealed class ChannelServices
[C++]
public __gc __sealed class ChannelServices
[JScript]
public class ChannelServices

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.Remoting

Assembly: mscorlib.dll

See Also

ChannelServices Members | System.Runtime.Remoting Namespace


ChannelServices Members

Public:

Constructor

ChannelServices Constructor [To be supplied.]

Properties

RegisteredChannels Returns an array of currently registered channels.

Methods

AsyncDispatchMessage |
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetChannel | Perform a lookup using the channel name on the registered channels.
GetChannelSinkProperties |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
GetURLsforObject |
RegisterChannel | Registers a with the channel services. Takes in the IChannel interface from a Channel object.
ResolveChannelMessageSink |
StartListening | Instructs a particular channel to start listening for requests when called by application code.
StopListening | Instructs a particular channel to stop listening for requests called by application code.
SyncDispatchMessage | This method is used by the channel to dispatch the incoming messages to the server-side chain(s) based on the URI embedded in the message. The URI uniquely identifies the receiving object.
ToString (inherited from Object) | Returns a String that represents the current Object.
UnregisterChannel |

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ChannelServices Class | System.Runtime.Remoting Namespace


ChannelServices Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public ChannelServices();
[C++]
public: ChannelServices();
[JScript]
public function ChannelServices();

See Also

ChannelServices Class | ChannelServices Members | System.Runtime.Remoting Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ChannelServices Properties

The properties of the ChannelServices class are listed below. For a complete list of ChannelServices class members, see the ChannelServices Members topic.

Public:

RegisteredChannels Returns an array of currently registered channels.

See Also

ChannelServices Class | System.Runtime.Remoting Namespace


ChannelServices.RegisteredChannels

Returns an array of currently registered channels.

[Visual Basic]
Public Shared ReadOnly Property RegisteredChannels As IChannel ()
[C#]
public static IChannel[] RegisteredChannels {get;}
[C++]
public: __property static IChannel* get_RegisteredChannels();
[JScript]
public static function get RegisteredChannels() : IChannel[];

Property Value

An array of the the currently registered channels.

See Also

ChannelServices Class | ChannelServices Members | System.Runtime.Remoting Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ChannelServices Methods

The methods of the ChannelServices class are listed below. For a complete list of ChannelServices class members, see the ChannelServices Members topic.

Public:

AsyncDispatchMessage |
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetChannel | Perform a lookup using the channel name on the registered channels.
GetChannelSinkProperties |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
GetURLsforObject |
RegisterChannel | Registers a with the channel services. Takes in the IChannel interface from a Channel object.
ResolveChannelMessageSink |
StartListening | Instructs a particular channel to start listening for requests when called by application code.
StopListening | Instructs a particular channel to stop listening for requests called by application code.
SyncDispatchMessage | This method is used by the channel to dispatch the incoming messages to the server-side chain(s) based on the URI embedded in the message. The URI uniquely identifies the receiving object.
ToString (inherited from Object) | Returns a String that represents the current Object.
UnregisterChannel |

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ChannelServices Class | System.Runtime.Remoting Namespace


ChannelServices.AsyncDispatchMessage

[Visual Basic]
Public Shared Function AsyncDispatchMessage( _
   ByVal msg As IMessage, _
   ByVal replySink As IMessageSink _
) As IMessageCtrl
[C#]
public static IMessageCtrl AsyncDispatchMessage(
   IMessage msg,
   IMessageSink replySink
);
[C++]
public: static IMessageCtrl* AsyncDispatchMessage(
   IMessage* msg,
   IMessageSink* replySink
);
[JScript]
public static function AsyncDispatchMessage(
   msg : IMessage,
   replySink : IMessageSink
) : IMessageCtrl;

Parameters

msg
[To be supplied.]
replySink
Process the return message if non-null

Return Value

ReplyMessage returned by a ProcessMessage call to the sever side chain.

See Also

ChannelServices Class | ChannelServices Members | System.Runtime.Remoting Namespace


ChannelServices.GetChannel

Perform a lookup using the channel name on the registered channels.

[Visual Basic]
Public Shared Function GetChannel( _
   ByVal name As String _
) As IChannel
[C#]
public static IChannel GetChannel(
   string name
);
[C++]
public: static IChannel* GetChannel(
   String* name
);
[JScript]
public static function GetChannel(
   name : String
) : IChannel;

Parameters

name
The channel name.

Return Value

Returns an interface to a registered channel, or null if the channel is not registered

See Also

ChannelServices Class | ChannelServices Members | System.Runtime.Remoting Namespace


ChannelServices.GetChannelSinkProperties

[Visual Basic]
Public Shared Function GetChannelSinkProperties( _
   ByVal obj As Object _
) As IDictionary
[C#]
public static IDictionary GetChannelSinkProperties(
   object obj
);
[C++]
public: static IDictionary* GetChannelSinkProperties(
   Object* obj
);
[JScript]
public static function GetChannelSinkProperties(
   obj : Object
) : IDictionary;

Parameters

obj
The proxy to retrieve properties for

Return Value

An interface to the dictionary of properties or null if no properties were found.

See Also

ChannelServices Class | ChannelServices Members | System.Runtime.Remoting Namespace


ChannelServices.GetURLsforObject

[Visual Basic]
Public Shared Function GetURLsforObject( _
   ByVal obj As MarshalByRefObject _
) As String ()
[C#]
public static string[] GetURLsforObject(
   MarshalByRefObject obj
);
[C++]
public: static String* GetURLsforObject(
   MarshalByRefObject* obj
) [];
[JScript]
public static function GetURLsforObject(
   obj : MarshalByRefObject
) : String[];

Parameters

obj
The object to retrieve the URL array for

Return Value

Returns an array of strings containing the URL's or null if none were found

See Also

ChannelServices Class | ChannelServices Members | System.Runtime.Remoting Namespace


ChannelServices.RegisterChannel

Registers a with the channel services. Takes in the IChannel interface from a Channel object.

[Visual Basic]
Public Shared Sub RegisterChannel( _
   ByVal chnl As IChannel _
)
[C#]
public static void RegisterChannel(
   IChannel chnl
);
[C++]
public: static void RegisterChannel(
   IChannel* chnl
);
[JScript]
public static function RegisterChannel(
   chnl : IChannel
);

Parameters

chnl
The channel to register

Exceptions

Exception Type | Condition
ArgumentNullException | is thrown if the channel is null
RemotingException | is thrown if the channel has already been registerd

See Also

ChannelServices Class | ChannelServices Members | System.Runtime.Remoting Namespace


ChannelServices.ResolveChannelMessageSink

[Visual Basic]
Public Shared Function ResolveChannelMessageSink( _
   ByVal obj As Object _
) As IMessageSink
[C#]
public static IMessageSink ResolveChannelMessageSink(
   object obj
);
[C++]
public: static IMessageSink* ResolveChannelMessageSink(
   Object* obj
);
[JScript]
public static function ResolveChannelMessageSink(
   obj : Object
) : IMessageSink;

Parameters

obj
The object the message sink is required for

Return Value

Returns and interface for the message sink

See Also

ChannelServices Class | ChannelServices Members | System.Runtime.Remoting Namespace


ChannelServices.StartListening

Instructs a particular channel to start listening for requests when called by application code.

[Visual Basic]
Public Shared Sub StartListening( _
   ByVal name As String, _
   ByVal data As Object _
)
[C#]
public static void StartListening(
   string name,
   object data
);
[C++]
public: static void StartListening(
   String* name,
   Object* data
);
[JScript]
public static function StartListening(
   name : String,
   data : Object
);

Parameters

name
The channel name.
data
Data object.

Remarks

The data object can be used to pass specific initialization state to the channel.

See Also

ChannelServices Class | ChannelServices Members | System.Runtime.Remoting Namespace


ChannelServices.StopListening

Instructs a particular channel to stop listening for requests called by application code.

[Visual Basic]
Public Shared Sub StopListening( _
   ByVal name As String, _
   ByVal data As Object _
)
[C#]
public static void StopListening(
   string name,
   object data
);
[C++]
public: static void StopListening(
   String* name,
   Object* data
);
[JScript]
public static function StopListening(
   name : String,
   data : Object
);

Parameters

name
Channel name.
data
Data object.

Remarks

The data object can be used to pass specific initialization state to the channel.

See Also

ChannelServices Class | ChannelServices Members | System.Runtime.Remoting Namespace


ChannelServices.SyncDispatchMessage

This method is used by the channel to dispatch the incoming messages to the server-side chain(s) based on the URI embedded in the message. The URI uniquely identifies the receiving object.

[Visual Basic]
Public Shared Function SyncDispatchMessage( _
   ByVal msg As IMessage _
) As IMessage
[C#]
public static IMessage SyncDispatchMessage(
   IMessage msg
);
[C++]
public: static IMessage* SyncDispatchMessage(
   IMessage* msg
);
[JScript]
public static function SyncDispatchMessage(
   msg : IMessage
) : IMessage;

Parameters

msg
The message to dispatch

Return Value

A reply message is returned by the call to the sever side chain

See Also

ChannelServices Class | ChannelServices Members | System.Runtime.Remoting Namespace


ChannelServices.UnregisterChannel

[Visual Basic]
Public Shared Sub UnregisterChannel( _
   ByVal chnl As IChannel _
)
[C#]
public static void UnregisterChannel(
   IChannel chnl
);
[C++]
public: static void UnregisterChannel(
   IChannel* chnl
);
[JScript]
public static function UnregisterChannel(
   chnl : IChannel
);

Parameters

chnl
The channel to unregister

Exceptions

Exception Type | Condition
ArgumentNullException | is thrown if the channel parameter is null
RemotingException | is thrown if the channel is not registered

See Also

ChannelServices Class | ChannelServices Members | System.Runtime.Remoting Namespace


ConstructionCall Class

[To be supplied.]

Object
MethodCall
ConstructionCall

[Visual Basic]
Public Class ConstructionCall
   Inherits MethodCall
   Implements IConstructionCallMessage
[C#]
public class ConstructionCall : MethodCall,
   IConstructionCallMessage
[C++]
public __gc class ConstructionCall : public MethodCall,
   IConstructionCallMessage
[JScript]
public class ConstructionCall extends MethodCall,
   IConstructionCallMessage

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.Remoting

Assembly: mscorlib.dll

See Also

ConstructionCall Members | System.Runtime.Remoting Namespace


ConstructionCall Members

Public:

Constructor

ConstructionCall Constructor Overloaded. [To be supplied.]

Properties

ArgCount (inherited from MethodCall) | [To be supplied.]
Args (inherited from MethodCall) | [To be supplied.]
CallSiteActivationAttributes | [To be supplied.]
ContextProperties | [To be supplied.]
HasVarArgs (inherited from MethodCall) | [To be supplied.]
InArgCount (inherited from MethodCall) | The number of arguments.
InArgs (inherited from MethodCall) | [To be supplied.]
MethodName (inherited from MethodCall) | [To be supplied.]
MethodSignature (inherited from MethodCall) | [To be supplied.]
Properties | [To be supplied.]
ServerType | [To be supplied.]
TypeName (inherited from MethodCall) | [To be supplied.]
URI (inherited from MethodCall) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetArg (inherited from MethodCall) | [To be supplied.]
GetArgName (inherited from MethodCall) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInArg (inherited from MethodCall) | [To be supplied.]
GetInArgName (inherited from MethodCall) | Return the name of a specific argument.
GetObjectData (inherited from MethodCall) | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
HeaderHandler (inherited from MethodCall) | [To be supplied.]
Init (inherited from MethodCall) | [To be supplied.]
ResolveMethod (inherited from MethodCall) | [To be supplied.]
RootSetObjectData (inherited from MethodCall) | [To be supplied.]
SetObjectData (inherited from MethodCall) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

_Args (inherited from MethodCall) | [To be supplied.]
_CallContext (inherited from MethodCall) | [To be supplied.]
_ExternalProperties (inherited from MethodCall) | [To be supplied.]
_InternalProperties (inherited from MethodCall) | [To be supplied.]
_MethodName (inherited from MethodCall) | [To be supplied.]
_MethodSignature (inherited from MethodCall) | [To be supplied.]
_MI (inherited from MethodCall) | [To be supplied.]
_TypeName (inherited from MethodCall) | [To be supplied.]
_URI (inherited from MethodCall) | [To be supplied.]

See Also

ConstructionCall Class | System.Runtime.Remoting Namespace


ConstructionCall Constructor

[To be supplied.]

Overload List

[To be supplied.]

[Visual Basic] Overloads Public Sub New(Header())
[C#] public ConstructionCall(Header[]);
[C++] public: ConstructionCall(Header*[]);
[JScript] public function ConstructionCall(Header[]);

[To be supplied.]

[Visual Basic] Overloads Public Sub New(IMessage)
[C#] public ConstructionCall(IMessage);
[C++] public: ConstructionCall(IMessage*);
[JScript] public function ConstructionCall(IMessage);

See Also

ConstructionCall Class | ConstructionCall Members | System.Runtime.Remoting Namespace


ConstructionCall Constructor (Header[])

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal headers() As Header _
)
[C#]
public ConstructionCall(
   Header[] headers
);
[C++]
public: ConstructionCall(
   Header* headers[]
);
[JScript]
public function ConstructionCall(
   headers : Header[]
);

Parameters

headers
[To be supplied.]

See Also

ConstructionCall Class | ConstructionCall Members | System.Runtime.Remoting Namespace | ConstructionCall Constructor Overload List


ConstructionCall Constructor (IMessage)

[To be supplied.]

[Visual Basic]
Overloads Public Sub New( _
   ByVal m As IMessage _
)
[C#]
public ConstructionCall(
   IMessage m
);
[C++]
public: ConstructionCall(
   IMessage* m
);
[JScript]
public function ConstructionCall(
   m : IMessage
);

Parameters

m
[To be supplied.]

See Also

ConstructionCall Class | ConstructionCall Members | System.Runtime.Remoting Namespace | ConstructionCall Constructor Overload List


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ConstructionCall Properties

The properties of the ConstructionCall class are listed below. For a complete list of ConstructionCall class members, see the ConstructionCall Members topic.

Public:

ArgCount (inherited from MethodCall) | [To be supplied.]
Args (inherited from MethodCall) | [To be supplied.]
CallSiteActivationAttributes | [To be supplied.]
ContextProperties | [To be supplied.]
HasVarArgs (inherited from MethodCall) | [To be supplied.]
InArgCount (inherited from MethodCall) | The number of arguments.
InArgs (inherited from MethodCall) | [To be supplied.]
MethodName (inherited from MethodCall) | [To be supplied.]
MethodSignature (inherited from MethodCall) | [To be supplied.]
Properties | [To be supplied.]
ServerType | [To be supplied.]
TypeName (inherited from MethodCall) | [To be supplied.]
URI (inherited from MethodCall) | [To be supplied.]

See Also

ConstructionCall Class | System.Runtime.Remoting Namespace


ConstructionCall.CallSiteActivationAttributes

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property CallSiteActivationAttributes _
   As Object ()
[C#]
public object[] CallSiteActivationAttributes {virtual get;}
[C++]
public: __property virtual Object*
   get_CallSiteActivationAttributes();
[JScript]
public function get CallSiteActivationAttributes() : Object[];

See Also

ConstructionCall Class | ConstructionCall Members | System.Runtime.Remoting Namespace


ConstructionCall.ContextProperties

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property ContextProperties As IList
[C#]
public IList ContextProperties {virtual get;}
[C++]
public: __property virtual IList* get_ContextProperties();
[JScript]
public function get ContextProperties() : IList;

See Also

ConstructionCall Class | ConstructionCall Members | System.Runtime.Remoting Namespace


ConstructionCall.Properties

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Properties As IDictionary
[C#]
public IDictionary Properties {override get;}
[C++]
public: __property virtual IDictionary* get_Properties();
[JScript]
public function get Properties() : IDictionary;

See Also

ConstructionCall Class | ConstructionCall Members | System.Runtime.Remoting Namespace


ConstructionCall.ServerType

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property ServerType As Type
[C#]
public Type ServerType {virtual get;}
[C++]
public: __property virtual Type* get_ServerType();
[JScript]
public function get ServerType() : Type;

See Also

ConstructionCall Class | ConstructionCall Members | System.Runtime.Remoting Namespace


ConstructionResponse Class

[To be supplied.]

Object
MethodResponse
ConstructionResponse

[Visual Basic]
Public Class ConstructionResponse
   Inherits MethodResponse
   Implements IConstructionReturnMessage
[C#]
public class ConstructionResponse : MethodResponse,
   IConstructionReturnMessage
[C++]
public __gc class ConstructionResponse : public MethodResponse,
   IConstructionReturnMessage
[JScript]
public class ConstructionResponse extends MethodResponse,
   IConstructionReturnMessage

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.Remoting

Assembly: mscorlib.dll

See Also

ConstructionResponse Members | System.Runtime.Remoting Namespace


ConstructionResponse Members

Public:

Constructor

ConstructionResponse Constructor [To be supplied.]

Properties

ArgCount (inherited from MethodResponse) | [To be supplied.]
Args (inherited from MethodResponse) | [To be supplied.]
Exception (inherited from MethodResponse) | [To be supplied.]
HasVarArgs (inherited from MethodResponse) | [To be supplied.]
MethodName (inherited from MethodResponse) | [To be supplied.]
MethodSignature (inherited from MethodResponse) | [To be supplied.]
OutArgCount (inherited from MethodResponse) | The number of out arguments.
OutArgs (inherited from MethodResponse) | [To be supplied.]
Properties | [To be supplied.]
ReturnValue (inherited from MethodResponse) | [To be supplied.]
TypeName (inherited from MethodResponse) | [To be supplied.]
URI (inherited from MethodResponse) | [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetArg (inherited from MethodResponse) | [To be supplied.]
GetArgName (inherited from MethodResponse) | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from MethodResponse) | [To be supplied.]
GetOutArg (inherited from MethodResponse) | [To be supplied.]
GetOutArgName (inherited from MethodResponse) | Return the name of a specific out argument.
GetType (inherited from Object) | Gets the Type of the Object.
HeaderHandler (inherited from MethodResponse) | [To be supplied.]
RootSetObjectData (inherited from MethodResponse) | [To be supplied.]
SetObjectData (inherited from MethodResponse) | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

_CallContext (inherited from MethodResponse) | [To be supplied.]
_ExternalProperties (inherited from MethodResponse) | [To be supplied.]
_Fault (inherited from MethodResponse) | [To be supplied.]
_InternalProperties (inherited from MethodResponse) | [To be supplied.]
_MethodName (inherited from MethodResponse) | [To be supplied.]
_MethodSignature (inherited from MethodResponse) | [To be supplied.]
_MI (inherited from MethodResponse) | [To be supplied.]
_OutArgs (inherited from MethodResponse) | [To be supplied.]
_Return (inherited from MethodResponse) | [To be supplied.]
_TypeName (inherited from MethodResponse) | [To be supplied.]
_URI (inherited from MethodResponse) | [To be supplied.]

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConstructionResponse Class | System.Runtime.Remoting Namespace


ConstructionResponse Constructor

[To be supplied.]

[Visual Basic]
Public Sub New( _
   ByVal h() As Header, _
   ByVal mcm As IMethodCallMessage _
)
[C#]
public ConstructionResponse(
   Header[] h,
   IMethodCallMessage mcm
);
[C++]
public: ConstructionResponse(
   Header* h[],
   IMethodCallMessage* mcm
);
[JScript]
public function ConstructionResponse(
   h : Header[],
   mcm : IMethodCallMessage
);

Parameters

h
[To be supplied.]
mcm
[To be supplied.]

See Also

ConstructionResponse Class | ConstructionResponse Members | System.Runtime.Remoting Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ConstructionResponse Properties

The properties of the ConstructionResponse class are listed below. For a complete list of ConstructionResponse class members, see the ConstructionResponse Members topic.

Public:

ArgCount (inherited from MethodResponse) | [To be supplied.]
Args (inherited from MethodResponse) | [To be supplied.]
Exception (inherited from MethodResponse) | [To be supplied.]
HasVarArgs (inherited from MethodResponse) | [To be supplied.]
MethodName (inherited from MethodResponse) | [To be supplied.]
MethodSignature (inherited from MethodResponse) | [To be supplied.]
OutArgCount (inherited from MethodResponse) | The number of out arguments.
OutArgs (inherited from MethodResponse) | [To be supplied.]
Properties | [To be supplied.]
ReturnValue (inherited from MethodResponse) | [To be supplied.]
TypeName (inherited from MethodResponse) | [To be supplied.]
URI (inherited from MethodResponse) | [To be supplied.]

See Also

ConstructionResponse Class | System.Runtime.Remoting Namespace


ConstructionResponse.Properties

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Properties As IDictionary
[C#]
public IDictionary Properties {override get;}
[C++]
public: __property virtual IDictionary* get_Properties();
[JScript]
public function get Properties() : IDictionary;

See Also

ConstructionResponse Class | ConstructionResponse Members | System.Runtime.Remoting Namespace


Context Class

Key Points:

A boundary containing a collection of objects with the same usage rules

Context rules include: synchronization, thread affinity, transactions, etc.

Classes are marked with ContextAttribute, which provide the usage rules

Execution system:

On the newobj IL instruction, the EE finds a compatible or creates a new Context for the object

Ensures the rules are enforced when entering and leaving a context

Provides synchronization rules for managed objects

Flexible synchronization model

A context is an ordered sequence of properties that define an environment for the objects resident inside it. Contexts get created during the activation process for objects that are configured to require certain automatic services such synchronization, transactions, just-in-time activation, security etc. Multiple objects can live inside a context.

Below is a brief summary of some of the Context characteristics:

Contexts are a general mechanism that bound a set of objects.

A context is composed from a set of Context properties.

Classes that can be bound to a context are called context-bound classes.

Context-bound objects are referenced directly within their own context and via a proxy when referenced from another context.

Any call from an object in one context to an object in another context will go through a context proxy and be affected by the policy that the combined context properties enforce.

Contexts are created during object activation i.e. a new object is either placed in an existing context or a new one is created for it, but once there, the object stays in its context for life.

A new object's context is generally chosen based on meta-data attributes on the class. This mechanism is extensible via custom attributes. These are known as static context properties, which are compiled into the class meta-data. Dynamic (also known as configuration) context properties can be applied and configured by administrators.

As a general rule, contexts are freed when there are no longer any external references to objects in the context and there are no threads executing in the context.

When context-bound objects access "agile" locations (location accessible from anywhere- like class static variables) that contain context-bound objects, proxy wrapping and unwrapping must be done.

There is one special kind of context property called an AppDomain property. An AppDomain property defines the boundary that contains the set of statics for a program (set of classes). If the same class is loaded into two contexts with different AppDomain properties then two copies of all of its static member variables are created.

Because all context-bound objects can be proxied across contexts, this imposes certain restrictions on how code can manipulate context-bound objects. For example, code cannot access a field on a context-bound object directly. Another example is that non-virtual calls must be made through an indirection and no inlining is allowed (to allow proxies when appropriate). This makes context-bound objects a good bit more expensive than one would like.

Classes, which are not context-bound, are sometimes referred to as agile classes. This should not be confused with agile locations (described below in the location section), although the ideas are parallel. Agile objects are not bound to contexts and they are not proxied across contexts within the same AppDomain. Agile objects are only agile within an AppDomain. Agile objects "live" in the DefaultContext (of which there is one per app-domain). The default context has no non-trivial properties. Any object passes across an AppDomain boundary is considered to be remoted.

Context-bound objects are very appropriate for transaction isolation/ propagation and other features where the cost is acceptable.

Object
Context

[Visual Basic]
Public Class Context
   Implements ISerializable
[C#]
public class Context : ISerializable
[C++]
public __gc class Context : public ISerializable
[JScript]
public class Context implements ISerializable

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.Remoting

Assembly: mscorlib.dll

See Also

Context Members | System.Runtime.Remoting Namespace


Context Members

Public:

Constructor

Context Constructor This constructor creates a new context and uses the specified ContextID.

Properties

ContextID | Reserved. This read-only property returns the ContextID for the Context.
ContextProperties | This read-only property returns an array of the context properties.
DefaultContext | This read-only property returns the default context for the AppDomain. Every thread in an app domain for which a context is not explicitly set is considered to be running in the DefaultContext.

Methods

AllocateDataSlot |
AllocateNamedDataSlot |
DoCallBack |
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FreeNamedDataSlot |
Freeze | Freeze the context. Context properties cannot be added after the context has been frozen.
GetData |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedDataSlot |
GetObjectData | [To be supplied.]
GetProperty |
GetType (inherited from Object) | Gets the Type of the Object.
RegisterDynamicProperty | This allows users to register a property implementing IContributeDynamicSink with the remoting service. Based on the obj and ctx parameters, the property is asked to contribute a sink that is placed at some location in the path ofremoting calls. If multiple properties are registered, their sinks may be called in an arbitrary order that may change between calls.
SetData |
SetObjectData | [To be supplied.]
SetProperty | Sets a specific context property by name.
ToString |
UnregisterDynamicProperty | Unregister dynamic property. See RegisterDynamicProperty.

Protected:

Methods

Finalize | This method only cleans up the backing objects for the non-default contexts. Default contexts these are cleaned up during AppDomain shutdown.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Context Class | System.Runtime.Remoting Namespace


Context Constructor

This constructor creates a new context and uses the specified ContextID.

[Visual Basic]
Public Sub New()
[C#]
public Context();
[C++]
public: Context();
[JScript]
public function Context();

See Also

Context Class | Context Members | System.Runtime.Remoting Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Context Properties

The properties of the Context class are listed below. For a complete list of Context class members, see the Context Members topic.

Public:

ContextID | Reserved. This read-only property returns the ContextID for the Context.
ContextProperties | This read-only property returns an array of the context properties.
DefaultContext | This read-only property returns the default context for the AppDomain. Every thread in an app domain for which a context is not explicitly set is considered to be running in the DefaultContext.

See Also

Context Class | System.Runtime.Remoting Namespace


Context.ContextID

Reserved. This read-only property returns the ContextID for the Context.

[Visual Basic]
Overridable Public ReadOnly Property ContextID As Integer
[C#]
public int ContextID {virtual get;}
[C++]
public: __property virtual int get_ContextID();
[JScript]
public function get ContextID() : int;

Property Value

Read only. Reserved. This property returns the ContextID for the context.

See Also

Context Class | Context Members | System.Runtime.Remoting Namespace


Context.ContextProperties

This read-only property returns an array of the context properties.

[Visual Basic]
Overridable Public ReadOnly Property ContextProperties As _
   IContextProperty ()
[C#]
public IContextProperty[] ContextProperties {virtual get;}
[C++]
public: __property virtual IContextProperty*
   get_ContextProperties();
[JScript]
public function get ContextProperties() : IContextProperty[];

Property Value

Read only. This property returns an array of the context properties, of null if the property does not have any.

See Also

Context Class | Context Members | System.Runtime.Remoting Namespace


Context.DefaultContext

This read-only property returns the default context for the AppDomain. Every thread in an app domain for which a context is not explicitly set is considered to be running in the DefaultContext.

[Visual Basic]
Public Shared ReadOnly Property DefaultContext As Context
[C#]
public static Context DefaultContext {get;}
[C++]
public: __property static Context* get_DefaultContext();
[JScript]
public static function get DefaultContext() : Context;

Property Value

Read only. This property returns the default context for the AppDomain.

See Also

Context Class | Context Members | System.Runtime.Remoting Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Context Methods

The methods of the Context class are listed below. For a complete list of Context class members, see the Context Members topic.

Public:

AllocateDataSlot |
AllocateNamedDataSlot |
DoCallBack |
Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
FreeNamedDataSlot |
Freeze | Freeze the context. Context properties cannot be added after the context has been frozen.
GetData |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedDataSlot |
GetObjectData | [To be supplied.]
GetProperty |
GetType (inherited from Object) | Gets the Type of the Object.
RegisterDynamicProperty | This allows users to register a property implementing IContributeDynamicSink with the remoting service. Based on the obj and ctx parameters, the property is asked to contribute a sink that is placed at some location in the path ofremoting calls. If multiple properties are registered, their sinks may be called in an arbitrary order that may change between calls.
SetData |
SetObjectData | [To be supplied.]
SetProperty | Sets a specific context property by name.
ToString |
UnregisterDynamicProperty | Unregister dynamic property. See RegisterDynamicProperty.

Protected:

Finalize | This method only cleans up the backing objects for the non-default contexts. Default contexts these are cleaned up during AppDomain shutdown.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Context Class | System.Runtime.Remoting Namespace


Context.AllocateDataSlot

[Visual Basic]
Public Shared Function AllocateDataSlot() As LocalDataStoreSlot
[C#]
public static LocalDataStoreSlot AllocateDataSlot();
[C++]
public: static LocalDataStoreSlot* AllocateDataSlot();
[JScript]
public static function AllocateDataSlot() : LocalDataStoreSlot;

Return Value

A LocalDataSlot is returned

See Also

Context Class | Context Members | System.Runtime.Remoting Namespace


Context.AllocateNamedDataSlot

[Visual Basic]
Public Shared Function AllocateNamedDataSlot( _
   ByVal name As String _
) As LocalDataStoreSlot
[C#]
public static LocalDataStoreSlot AllocateNamedDataSlot(
   string name
);
[C++]
public: static LocalDataStoreSlot* AllocateNamedDataSlot(
   String* name
);
[JScript]
public static function AllocateNamedDataSlot(
   name : String
) : LocalDataStoreSlot;

Parameters

name
The required for the data slot

Return Value

A LocalDataSlot object is returned

See Also

Context Class | Context Members | System.Runtime.Remoting Namespace


Context.DoCallBack

[Visual Basic]
Public Sub DoCallBack( _
   ByVal deleg As CrossContextDelegate _
)
[C#]
public void DoCallBack(
   CrossContextDelegate deleg
);
[C++]
public: void DoCallBack(
   CrossContextDelegate* deleg
);
[JScript]
public function DoCallBack(
   deleg : CrossContextDelegate
);

Parameters

deleg
The delegate used to request the callback

See Also

Context Class | Context Members | System.Runtime.Remoting Namespace


Context.Finalize

This method only cleans up the backing objects for the non-default contexts. Default contexts these are cleaned up during AppDomain shutdown.

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();
[C++]
protected: override void Finalize();
[JScript]
protected override function Finalize();

See Also

Context Class | Context Members | System.Runtime.Remoting Namespace


Context.FreeNamedDataSlot

[Visual Basic]
Public Shared Sub FreeNamedDataSlot( _
   ByVal name As String _
)
[C#]
public static void FreeNamedDataSlot(
   string name
);
[C++]
public: static void FreeNamedDataSlot(
   String* name
);
[JScript]
public static function FreeNamedDataSlot(
   name : String
);

Parameters

name
The name of the data slot to free

See Also

Context Class | Context Members | System.Runtime.Remoting Namespace


Context.Freeze

Freeze the context. Context properties cannot be added after the context has been frozen.

[Visual Basic]
Overridable Public Sub Freeze()
[C#]
public virtual void Freeze();
[C++]
public: virtual void Freeze();
[JScript]
public function Freeze();

Exceptions

Exception Type | Condition
InvalidOperationException | is thrown if the context is already frozen

See Also

Context Class | Context Members | System.Runtime.Remoting Namespace


Context.GetData

[Visual Basic]
Public Shared Function GetData( _
   ByVal slot As LocalDataStoreSlot _
) As Object
[C#]
public static object GetData(
   LocalDataStoreSlot slot
);
[C++]
public: static Object* GetData(
   LocalDataStoreSlot* slot
);
[JScript]
public static function GetData(
   slot : LocalDataStoreSlot
) : Object;

Parameters

slot
The data slot that contains the data

Return Value

Returns the data associated with the DataSlot provided

See Also

Context Class | Context Members | System.Runtime.Remoting Namespace


Context.GetNamedDataSlot

[Visual Basic]
Public Shared Function GetNamedDataSlot( _
   ByVal name As String _
) As LocalDataStoreSlot
[C#]
public static LocalDataStoreSlot GetNamedDataSlot(
   string name
);
[C++]
public: static LocalDataStoreSlot* GetNamedDataSlot(
   String* name
);
[JScript]
public static function GetNamedDataSlot(
   name : String
) : LocalDataStoreSlot;

Parameters

name
The data slot name

Return Value

Retruns a LocalDataSlot

See Also

Context Class | Context Members | System.Runtime.Remoting Namespace


Context.GetObjectData

[To be supplied.]

[Visual Basic]
Overridable Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
public: virtual void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
);
[JScript]
public function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);

Parameters

info
[To be supplied.]
context
[To be supplied.]

See Also

Context Class | Context Members | System.Runtime.Remoting Namespace


Context.GetProperty

[Visual Basic]
Overridable Public Function GetProperty( _
   ByVal name As String _
) As IContextProperty
[C#]
public virtual IContextProperty GetProperty(
   string name
);
[C++]
public: virtual IContextProperty* GetProperty(
   String* name
);
[JScript]
public function GetProperty(
   name : String
) : IContextProperty;

Parameters

name
The name of the property

See Also

Context Class | Context Members | System.Runtime.Remoting Namespace


Context.RegisterDynamicProperty

This allows users to register a property implementing IContributeDynamicSink with the remoting service. Based on the obj and ctx parameters, the property is asked to contribute a sink that is placed at some location in the path ofremoting calls. If multiple properties are registered, their sinks may be called in an arbitrary order that may change between calls.

[Visual Basic]
Public Shared Function RegisterDynamicProperty( _
   ByVal prop As IDynamicProperty, _
   ByVal obj As MarshalByRefObject, _
   ByVal ctx As Context _
) As Boolean
[C#]
public static bool RegisterDynamicProperty(
   IDynamicProperty prop,
   MarshalByRefObject obj,
   Context ctx
);
[C++]
public: static bool RegisterDynamicProperty(
   IDynamicProperty* prop,
   MarshalByRefObject* obj,
   Context* ctx
);
[JScript]
public static function RegisterDynamicProperty(
   prop : IDynamicProperty,
   obj : MarshalByRefObject,
   ctx : Context
) : Boolean;

Parameters

prop
[To be supplied.]
obj
[To be supplied.]
ctx

Return Value

Returns true if the property was successfully registered, else false

Exceptions

Exception Type | Condition
ArgumentNullException | is thrown if the property or property name is null
ArgumentException | is thrown if both an object as well as a context is specified

Remarks

See Also

Context Class | Context Members | System.Runtime.Remoting Namespace


Context.SetData

[Visual Basic]
Public Shared Sub SetData( _
   ByVal slot As LocalDataStoreSlot, _
   ByVal data As Object _
)
[C#]
public static void SetData(
   LocalDataStoreSlot slot,
   object data
);
[C++]
public: static void SetData(
   LocalDataStoreSlot* slot,
   Object* data
);
[JScript]
public static function SetData(
   slot : LocalDataStoreSlot,
   data : Object
);

Parameters

slot
[To be supplied.]
data
The data

See Also

Context Class | Context Members | System.Runtime.Remoting Namespace


Context.SetObjectData

[To be supplied.]

[Visual Basic]
Overridable Public Sub SetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
public virtual void SetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
public: virtual void SetObjectData(
   SerializationInfo* info,
   StreamingContext context
);
[JScript]
public function SetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);

Parameters

info
[To be supplied.]
context
[To be supplied.]

See Also

Context Class | Context Members | System.Runtime.Remoting Namespace


Context.SetProperty

Sets a specific context property by name.

[Visual Basic]
Overridable Public Sub SetProperty( _
   ByVal prop As IContextProperty _
)
[C#]
public virtual void SetProperty(
   IContextProperty prop
);
[C++]
public: virtual void SetProperty(
   IContextProperty* prop
);
[JScript]
public function SetProperty(
   prop : IContextProperty
);

Parameters

prop
Actual context property.

Exceptions

Exception Type | Condition
InvalidOperationException | is thrown when there is an attempt to add properties to the default context
InvalidOperationException | is thrown if the context is frozen
ArgumentNullException | is thrown when property or the property name is NULL

See Also

Context Class | Context Members | System.Runtime.Remoting Namespace


Context.ToString

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: override String* ToString();
[JScript]
public override function ToString() : String;

Return Value

Returns the context as a String

See Also

Context Class | Context Members | System.Runtime.Remoting Namespace


Context.UnregisterDynamicProperty

Unregister dynamic property. See RegisterDynamicProperty.

[Visual Basic]
Public Shared Function UnregisterDynamicProperty( _
   ByVal name As String, _
   ByVal obj As MarshalByRefObject, _
   ByVal ctx As Context _
) As Boolean
[C#]
public static bool UnregisterDynamicProperty(
   string name,
   MarshalByRefObject obj,
   Context ctx
);
[C++]
public: static bool UnregisterDynamicProperty(
   String* name,
   MarshalByRefObject* obj,
   Context* ctx
);
[JScript]
public static function UnregisterDynamicProperty(
   name : String,
   obj : MarshalByRefObject,
   ctx : Context
) : Boolean;

Parameters

name
[To be supplied.]
obj
[To be supplied.]
ctx

Return Value

Returns true if the object was successfully unregistered

Exceptions

Exception Type | Condition
ArgumentNullException | is thrown if the name is null
ArgumentException | is thrown if both an object as well as a context is specified

See Also

Context Class | Context Members | System.Runtime.Remoting Namespace


ContextAttribute Class

ContextAttribute is the root for all context attributes. ContextAttribute provides the default implementations of IContextAttribute and IContextProperty. Simple Context properties can derived from ContextAttribute with the context attribute and the context property being in the class. For more specialized or more sophisticated needs the context attribute still derives from ContextAttribute and context property can be split into a separated class.

Object
Attribute
ContextAttribute

[Visual Basic]
Public Class ContextAttribute
   Inherits Attribute
   Implements IContextAttribute, IContextProperty
[C#]
public class ContextAttribute : Attribute, IContextAttribute,
   IContextProperty
[C++]
public __gc class ContextAttribute : public Attribute,
   IContextAttribute, IContextProperty
[JScript]
public class ContextAttribute extends Attribute, IContextAttribute,
   IContextProperty

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.Remoting

Assembly: mscorlib.dll

See Also

ContextAttribute Members | System.Runtime.Remoting Namespace


ContextAttribute Members

Public:

Constructor

ContextAttribute Constructor Create a context attribute with the specified name using this constructor

Properties

Name [To be supplied.]

Methods

Equals | [To be supplied.]
Freeze | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPropertiesForNewContext | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsContextOK | [To be supplied.]
IsNewContextOK | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Fields

AttributeName The name of the context attribute

See Also

ContextAttribute Class | System.Runtime.Remoting Namespace


ContextAttribute Constructor

Create a context attribute with the specified name using this constructor

[Visual Basic]
Public Sub New( _
   ByVal name As String _
)
[C#]
public ContextAttribute(
   string name
);
[C++]
public: ContextAttribute(
   String* name
);
[JScript]
public function ContextAttribute(
   name : String
);

Parameters

name
The name of the context attribute

See Also

ContextAttribute Class | ContextAttribute Members | System.Runtime.Remoting Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ContextAttribute Properties

The properties of the ContextAttribute class are listed below. For a complete list of ContextAttribute class members, see the ContextAttribute Members topic.

Public:

Name [To be supplied.]

See Also

ContextAttribute Class | System.Runtime.Remoting Namespace


ContextAttribute.Name

[To be supplied.]

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {virtual get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

See Also

ContextAttribute Class | ContextAttribute Members | System.Runtime.Remoting Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ContextAttribute Methods

The methods of the ContextAttribute class are listed below. For a complete list of ContextAttribute class members, see the ContextAttribute Members topic.

Public:

Equals | [To be supplied.]
Freeze | [To be supplied.]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPropertiesForNewContext | [To be supplied.]
GetType (inherited from Object) | Gets the Type of the Object.
IsContextOK | [To be supplied.]
IsNewContextOK | [To be supplied.]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ContextAttribute Class | System.Runtime.Remoting Namespace


ContextAttribute.Equals

[To be supplied.]

[Visual Basic]
Overrides Public Function Equals( _
   ByVal o As Object _
) As Boolean
[C#]
public override bool Equals(
   object o
);
[C++]
public: override bool Equals(
   Object* o
);
[JScript]
public override function Equals(
   o : Object
) : Boolean;

Parameters

o
[To be supplied.]

See Also

ContextAttribute Class | ContextAttribute Members | System.Runtime.Remoting Namespace


ContextAttribute.Freeze

[To be supplied.]

[Visual Basic]
Overridable Public Sub Freeze( _
   ByVal newContext As Context _
)
[C#]
public virtual void Freeze(
   Context newContext
);
[C++]
public: virtual void Freeze(
   Context* newContext
);
[JScript]
public function Freeze(
   newContext : Context
);

Parameters

newContext
[To be supplied.]

See Also

ContextAttribute Class | ContextAttribute Members | System.Runtime.Remoting Namespace


ContextAttribute.GetPropertiesForNewContext

[To be supplied.]

[Visual Basic]
Overridable Public Sub GetPropertiesForNewContext( _
   ByVal ctorMsg As IConstructionCallMessage _
)
[C#]
public virtual void GetPropertiesForNewContext(
   IConstructionCallMessage ctorMsg
);
[C++]
public: virtual void GetPropertiesForNewContext(
   IConstructionCallMessage* ctorMsg
);
[JScript]
public function GetPropertiesForNewContext(
   ctorMsg : IConstructionCallMessage
);

Parameters

ctorMsg
[To be supplied.]

See Also

ContextAttribute Class | ContextAttribute Members | System.Runtime.Remoting Namespace


ContextAttribute.IsContextOK

[To be supplied.]

[Visual Basic]
Overridable Public Function IsContextOK( _
   ByVal ctx As Context, _
   ByVal ctorMsg As IConstructionCallMessage _
) As Boolean
[C#]
public virtual bool IsContextOK(
   Context ctx,
   IConstructionCallMessage ctorMsg
);
[C++]
public: virtual bool IsContextOK(
   Context* ctx,
   IConstructionCallMessage* ctorMsg
);
[JScript]
public function IsContextOK(
   ctx : Context,
   ctorMsg : IConstructionCallMessage
) : Boolean;

Parameters

ctx
[To be supplied.]
ctorMsg
[To be supplied.]

See Also

ContextAttribute Class | ContextAttribute Members | System.Runtime.Remoting Namespace


ContextAttribute.IsNewContextOK

[To be supplied.]

[Visual Basic]
Overridable Public Function IsNewContextOK( _
   ByVal newCtx As Context _
) As Boolean
[C#]
public virtual bool IsNewContextOK(
   Context newCtx
);
[C++]
public: virtual bool IsNewContextOK(
   Context* newCtx
);
[JScript]
public function IsNewContextOK(
   newCtx : Context
) : Boolean;

Parameters

newCtx
[To be supplied.]

See Also

ContextAttribute Class | ContextAttribute Members | System.Runtime.Remoting Namespace


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ContextAttribute Fields

The fields of the ContextAttribute class are listed below. For a complete list of ContextAttribute class members, see the ContextAttribute Members topic.

Protected:

AttributeName The name of the context attribute

See Also

ContextAttribute Class | System.Runtime.Remoting Namespace


ContextAttribute.AttributeName

The name of the context attribute

[Visual Basic]
Protected AttributeName As String
[C#]
protected string AttributeName;
[C++]
protected: String* AttributeName;
[JScript]
protected var AttributeName : String;

See Also

ContextAttribute Class | ContextAttribute Members | System.Runtime.Remoting Namespace


ContextProperty Class

Object
ContextProperty

[Visual Basic]
Public Class ContextProperty
[C#]
public class ContextProperty
[C++]
public __gc class ContextProperty
[JScript]
public class ContextProperty

Remarks

The properties that make up the context are provided by various automatic services and are set up by Activation Services at the time the Context is created. Each property is itself a managed object. Depending upon whether properties contribute MessageSinks or not, we look upon them as being Active or Passive. A ContextProperty is a name-value pair. An array of these is returned by Context::ContextProperties().

Requirements

Namespace: System.Runtime.Remoting

Assembly: mscorlib.dll

See Also

ContextProperty Members | System.Runtime.Remoting Namespace


ContextProperty Members

Public:

Properties

Name | Returns the name of the ContextProperty.
Property | Returns the actual context property object.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ContextProperty Class | System.Runtime.Remoting Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ContextProperty Properties

The properties of the ContextProperty class are listed below. For a complete list of ContextProperty class members, see the ContextProperty Members topic.

Public:

Name | Returns the name of the ContextProperty.
Property | Returns the actual context property object.

See Also

ContextProperty Class | System.Runtime.Remoting Namespace


ContextProperty.Name

Returns the name of the ContextProperty.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public string Name {virtual get;}
[C++]
public: __property virtual String* get_Name();
[JScript]
public function get Name() : String;

Property Value

See Also

ContextProperty Class | ContextProperty Members | System.Runtime.Remoting Namespace


ContextProperty.Property

Returns the actual context property object.

[Visual Basic]
Overridable Public ReadOnly Property Property As Object
[C#]
public object Property {virtual get;}
[C++]
public: __property virtual Object* get_Property();
[JScript]
public function get Property() : Object;

See Also

ContextProperty Class | ContextProperty Members | System.Runtime.Remoting Namespace


CrossContextDelegate Delegate

Every subclass of Delegate and MulticastDelegate has a constructor and an Invoke method. See the managed C++ code example given in the description for Delegate.

Delegate defined for context callbacks. It is expected to be a function on an agile object.

[Visual Basic]
Public Delegate Sub CrossContextDelegate()
[C#]
public delegate void CrossContextDelegate();
[C++]
public __gc __delegate void CrossContextDelegate();

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the CrossContextDelegate delegate declaration.

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.Remoting

Assembly: mscorlib.dll

See Also

System.Runtime.Remoting Namespace


Embedded Class

[To be supplied.]

Object
Attribute
Embedded

[Visual Basic]
Public Class Embedded
   Inherits Attribute
[C#]
public class Embedded : Attribute
[C++]
public __gc class Embedded : public Attribute
[JScript]
public class Embedded extends Attribute

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.Remoting

Assembly: mscorlib.dll

See Also

Embedded Members | System.Runtime.Remoting Namespace


Embedded Members

Public:

Constructor

Embedded Constructor [To be supplied.]

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Embedded Class | System.Runtime.Remoting Namespace


Embedded Constructor

[To be supplied.]

[Visual Basic]
Public Sub New()
[C#]
public Embedded();
[C++]
public: Embedded();
[JScript]
public function Embedded();

See Also

Embedded Class | Embedded Members | System.Runtime.Remoting Namespace


Header Class

Defines the out-of-band data for a call.

Object
Header

[Visual Basic]
Public Class Header
[C#]
public class Header
[C++]
public __gc class Header
[JScript]
public class Header

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.Remoting

Assembly: mscorlib.dll

See Also

Header Members | System.Runtime.Remoting Namespace


Header Members

Public:

Constructor

Header Constructor Overloaded. Initializes a new instance of the Header class.

Methods

Equals (inherited from Object) | Determines whether the specified Object is the same instance as the current Object. Subclasses are expected to override this method to support value equality (not reference equality).
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the Object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Fields

MustUnderstand | Must be understood.
Name | Name of the Header.
Value | Object that contains the Value for the Header.

Protected:

Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by the Garbage Collector (GC). This method may be ignored by the runtime; therefore, necessary cleanup operations should be done elsewhere.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Header Class | System.Runtime.Remoting Namespace


Header Constructor

Initializes a new instance of the Header class.

Overload List

Initializes a new instance of the Header class.

[Visual Basic] Overloads Public Sub New(String, Object)
[C#] public Header(String, Object);
[C++] public: Header(String*, Object);
[JScript] public function Header(String, Object);

Initializes a new instance of the Header class.

[Visual Basic] Overloads Public Sub New(String, Object, Boolean)
[C#] public Header(String, Object, bool);
[C++] public: Header(String*, Object, bool);
[JScript] public function Header(String, Object, Boolean);

See Also

Header Class | Header Members | System.Runtime.Remoting Namespace


Header Constructor (String, Object)

Initializes a new instance of the Header class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal _Name As String, _
   ByVal _Value As Object _
)
[C#]
public Header(
   string _Name,
   object _Value
);
[C++]
public: Header(
   String* _Name,
   Object* _Value
);
[JScript]
public function Header(
   _Name : String,
   _Value : Object
);

Parameters

_Name
The name of the Header.
_Value
The object that contains the value for the Header.

See Also

Header Class | Header Members | System.Runtime.Remoting Namespace | Header Constructor Overload List


Header Constructor (String, Object, Boolean)

Initializes a new instance of the Header class.

[Visual Basic]
Overloads Public Sub New( _
   ByVal _Name As String, _
   ByVal _Value As Object, _
   ByVal _MustUnderstand As Boolean _
)
[C#]
public Header(
   string _Name,
   object _Value,
   bool _MustUnderstand
);
[C++]
public: Header(
   String* _Name,
   Object* _Value,
   bool _MustUnderstand
);
[JScript]
public function Header(
   _Name : String,
   _Value : Object,
   _MustUnderstand : Boolean
);

Parameters

_Name
The name of the Header.
_Value
The object that contains the value for the Header.
_MustUnderstand
The receiving end must understand the out-of-band data.

See Also

Header Class | Header Members | System.Runtime.Remoting Namespace | Header Constructor Overload List


Fields

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

Header Fields

The fields of the Header class are listed below. For a complete list of Header class members, see the Header Members topic.

Public:

MustUnderstand | Must be understood.
Name | Name of the Header.
Value | Object that contains the Value for the Header.

See Also

Header Class | System.Runtime.Remoting Namespace


Header.MustUnderstand

Must be understood.

[Visual Basic]
Public MustUnderstand As Boolean
[C#]
public bool MustUnderstand;
[C++]
public: bool MustUnderstand;
[JScript]
public var MustUnderstand : Boolean;

See Also

Header Class | Header Members | System.Runtime.Remoting Namespace


Header.Name

Name of the Header.

[Visual Basic]
Public Name As String
[C#]
public string Name;
[C++]
public: String* Name;
[JScript]
public var Name : String;

See Also

Header Class | Header Members | System.Runtime.Remoting Namespace


Header.Value

Object that contains the Value for the Header.

[Visual Basic]
Public Value As Object
[C#]
public object Value;
[C++]
public: Object* Value;
[JScript]
public var Value : Object;

See Also

Header Class | Header Members | System.Runtime.Remoting Namespace


HeaderHandler Delegate

The HeaderHandler delegate is used to process headers on the stream during serialization. Every subclass of Delegate and MulticastDelegate has a constructor and an Invoke method. See the managed C++ code example given in the description for Delegate.

[Visual Basic]
Public Delegate Sub HeaderHandler( _
   ByVal headers() As Header _
) As Object
[C#]
public delegate object HeaderHandler(
   Header[] headers
);
[C++]
public __gc __delegate Object* HeaderHandler(
   Header* headers[]
);

[JScript] In JScript, you can use the delegates in the NGWS frameworks, but you cannot define your own.

Parameters [Visual Basic, C#, C++]

The declaration of your event-handling method must have the same parameters as the HeaderHandler delegate declaration.

headers
The headers of the event.

Remarks

The declaration of your event-handling method must have the same parameters as the DeserializationEventHandler delegate.

When you create a HeaderHandler, you identify the method that will handle the event. For an overview, see the Delegates/EventModule topic.

Requirements

Namespace: System.Runtime.Remoting

Assembly: mscorlib.dll

See Also

System.Runtime.Remoting Namespace


IActivator Interface

IActivator

[Visual Basic]
Public Interface IActivator
[C#]
public interface IActivator
[C++]
public __gc __interface IActivator

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

Requirements

Namespace: System.Runtime.Remoting

Assembly: mscorlib.dll

See Also

IActivator Members | System.Runtime.Remoting Namespace


IActivator Members

Methods

Activate Creates an instance of the object. The parameters are encapsulated in a message.

See Also

IActivator Interface | System.Runtime.Remoting Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IActivator Methods

The methods of the IActivator interface are listed below. For a complete list of IActivator interface members, see the IActivator Members topic.

Activate Creates an instance of the object. The parameters are encapsulated in a message.

See Also

IActivator Interface | System.Runtime.Remoting Namespace


IActivator.Activate

Creates an instance of the object. The parameters are encapsulated in a message.

[Visual Basic]
Function Activate( _
   ByVal msg As IConstructionCallMessage _
) As IConstructionReturnMessage
[C#]
IConstructionReturnMessage Activate(
   IConstructionCallMessage msg
);
[C++]
IConstructionReturnMessage* Activate(
   IConstructionCallMessage* msg
) = 0;
[JScript]
function Activate(
   msg : IConstructionCallMessage
) : IConstructionReturnMessage;

Parameters

msg

See Also

IActivator Interface | IActivator Members | System.Runtime.Remoting Namespace


IChannel Interface

Channels provide conducts for messages that cross remoting boundaries (for example, Context, AppDomain, Processes, and Machines). These crossings include both inbound and outbound. A channel can listen on an endpoint for inbound messages or send to an endpoint for outbound messages or both. This provides an extensibility point in the runtime to plug in a wide range protocols, even though the runtime may not be at the other end of the channel.

Runtime objects can be used to expose and represent a wide and rich set of semantics and entities. The channel provides the extensibility point to convert the messages to and from the specific protocols. If there are runtimes are both ends of the channel, a "virtual channel" is created between the two ends, in order to connect the client and sever sink chains on either side of the boundary together.

The client part of the channel is located at the end of Client context sink chain. The server part of the channel is located at the start of the Server context sink chain. Messages are delivered to the client channel via the IMessageSink interface, travel through the channel, and are received by the server channel. The server channel delivers the message to the first server context sink. Channels must expose the IChannel interface, which provides informational properties such as the ChannelName, ChannelPriority and MimeType. Channels are registered via RegisterChannel.

IChannel

[Visual Basic]
Public Interface IChannel
[C#]
public interface IChannel
[C++]
public __gc __interface IChannel

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.Remoting

Assembly: mscorlib.dll

See Also

IChannel Members | System.Runtime.Remoting Namespace


IChannel Members

Properties

ChannelName | Returns the name of the channel.
ChannelPriority | Returns the priority of the channel.
MimeType | Sets or returns the mime type of the channel.

See Also

IChannel Interface | System.Runtime.Remoting Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IChannel Properties

The properties of the IChannel interface are listed below. For a complete list of IChannel interface members, see the IChannel Members topic.

ChannelName | Returns the name of the channel.
ChannelPriority | Returns the priority of the channel.
MimeType | Sets or returns the mime type of the channel.

See Also

IChannel Interface | System.Runtime.Remoting Namespace


IChannel.ChannelName

Returns the name of the channel.

[Visual Basic]
ReadOnly Property ChannelName As String
[C#]
string ChannelName {get;}
[C++]
String* get_ChannelName() = 0;
[JScript]
abstract function get ChannelName() : String;

Property Value

Read-only

The name of the channel.

See Also

IChannel Interface | IChannel Members | System.Runtime.Remoting Namespace


IChannel.ChannelPriority

Returns the priority of the channel.

[Visual Basic]
ReadOnly Property ChannelPriority As Integer
[C#]
int ChannelPriority {get;}
[C++]
int get_ChannelPriority() = 0;
[JScript]
abstract function get ChannelPriority() : int;

Property Value

Read-only

The priority of the channel.

See Also

IChannel Interface | IChannel Members | System.Runtime.Remoting Namespace


IChannel.MimeType

Sets or returns the mime type of the channel.

[Visual Basic]
Property MimeType As String
[C#]
string MimeType {get; set;}
[C++]
String* get_MimeType() = 0;void set_MimeType(String*) = 0;
[JScript]
abstract function get MimeType() : String;
public abstract function set MimeType(String);

Property Value

Read-write.

Returns the mime type of the channel.

See Also

IChannel Interface | IChannel Members | System.Runtime.Remoting Namespace


IChannelInfo Interface

Provides custom channel information that is carried along with the ObjRef.

IChannelInfo

[Visual Basic]
Public Interface IChannelInfo
[C#]
public interface IChannelInfo
[C++]
public __gc __interface IChannelInfo

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.Remoting

Assembly: mscorlib.dll

See Also

IChannelInfo Members | System.Runtime.Remoting Namespace


IChannelInfo Members

Properties

ChannelData | Gets and sets the channel data for each channel.
ChannelNames | Gets and sets the names of the channels.

See Also

IChannelInfo Interface | System.Runtime.Remoting Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IChannelInfo Properties

The properties of the IChannelInfo interface are listed below. For a complete list of IChannelInfo interface members, see the IChannelInfo Members topic.

ChannelData | Gets and sets the channel data for each channel.
ChannelNames | Gets and sets the names of the channels.

See Also

IChannelInfo Interface | System.Runtime.Remoting Namespace


IChannelInfo.ChannelData

Gets and sets the channel data for each channel.

[Visual Basic]
Property ChannelData As Object ()
[C#]
object[] ChannelData {get; set;}
[C++]
Object* get_ChannelData() = 0;void set_ChannelData(Object*[]) = 0;
[JScript]
abstract function get ChannelData() : Object[];
public abstract function set ChannelData(Object[]);

See Also

IChannelInfo Interface | IChannelInfo Members | System.Runtime.Remoting Namespace


IChannelInfo.ChannelNames

Gets and sets the names of the channels.

[Visual Basic]
Property ChannelNames As String ()
[C#]
string[] ChannelNames {get; set;}
[C++]
String* get_ChannelNames() = 0;void set_ChannelNames(String*[]) = 0;
[JScript]
abstract function get ChannelNames() : String[];
public abstract function set ChannelNames(String[]);

See Also

IChannelInfo Interface | IChannelInfo Members | System.Runtime.Remoting Namespace


IChannelReceiver Interface

IChannelReceiver

[Visual Basic]
Public Interface IChannelReceiver
   Implements IChannel
[C#]
public interface IChannelReceiver : IChannel
[C++]
public __gc __interface IChannelReceiver : public IChannel

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.Remoting

Assembly: mscorlib.dll

See Also

IChannelReceiver Members | System.Runtime.Remoting Namespace


IChannelReceiver Members

Properties

ChannelData

Methods

GetURLsforURI
StartListening
StopListening

See Also

IChannelReceiver Interface | System.Runtime.Remoting Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IChannelReceiver Properties

The properties of the IChannelReceiver interface are listed below. For a complete list of IChannelReceiver interface members, see the IChannelReceiver Members topic.

ChannelData

See Also

IChannelReceiver Interface | System.Runtime.Remoting Namespace


IChannelReceiver.ChannelData

[Visual Basic]
ReadOnly Property ChannelData As Object
[C#]
object ChannelData {get;}
[C++]
Object* get_ChannelData() = 0;
[JScript]
abstract function get ChannelData() : Object;

See Also

IChannelReceiver Interface | IChannelReceiver Members | System.Runtime.Remoting Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IChannelReceiver Methods

The methods of the IChannelReceiver interface are listed below. For a complete list of IChannelReceiver interface members, see the IChannelReceiver Members topic.

GetURLsforURI
StartListening
StopListening

See Also

IChannelReceiver Interface | System.Runtime.Remoting Namespace


IChannelReceiver.GetURLsforURI

[Visual Basic]
Function GetURLsforURI( _
   ByVal objectURI As String _
) As String ()
[C#]
string[] GetURLsforURI(
   string objectURI
);
[C++]
String* GetURLsforURI(
   String* objectURI
) [] = 0;
[JScript]
function GetURLsforURI(
   objectURI : String
) : String[];

Parameters

objectURI
The URI for which URL's are required

See Also

IChannelReceiver Interface | IChannelReceiver Members | System.Runtime.Remoting Namespace


IChannelReceiver.StartListening

[Visual Basic]
Sub StartListening( _
   ByVal data As Object _
)
[C#]
void StartListening(
   object data
);
[C++]
void StartListening(
   Object* data
) = 0;
[JScript]
function StartListening(
   data : Object
);

Parameters

data
Optional ininitialization information

See Also

IChannelReceiver Interface | IChannelReceiver Members | System.Runtime.Remoting Namespace


IChannelReceiver.StopListening

[Visual Basic]
Sub StopListening( _
   ByVal data As Object _
)
[C#]
void StopListening(
   object data
);
[C++]
void StopListening(
   Object* data
) = 0;
[JScript]
function StopListening(
   data : Object
);

Parameters

data
Optional state information for the channel

See Also

IChannelReceiver Interface | IChannelReceiver Members | System.Runtime.Remoting Namespace


IChannelSender Interface

The sending side of channels must expose the IChannelSender interface.

IChannelSender

[Visual Basic]
Public Interface IChannelSender
   Implements IChannel
[C#]
public interface IChannelSender : IChannel
[C++]
public __gc __interface IChannelSender : public IChannel

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.Remoting

Assembly: mscorlib.dll

See Also

IChannelSender Members | System.Runtime.Remoting Namespace


IChannelSender Members

Methods

CreateMessageSink Returns a message sink.

See Also

IChannelSender Interface | System.Runtime.Remoting Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IChannelSender Methods

The methods of the IChannelSender interface are listed below. For a complete list of IChannelSender interface members, see the IChannelSender Members topic.

CreateMessageSink Returns a message sink.

See Also

IChannelSender Interface | System.Runtime.Remoting Namespace


IChannelSender.CreateMessageSink

Returns a message sink.

[Visual Basic]
Function CreateMessageSink( _
   ByVal url As String, _
   ByVal data As Object, _
   ByRef objectURI As String _
) As IMessageSink
[C#]
IMessageSink CreateMessageSink(
   string url,
   object data,
   ref string objectURI
);
[C++]
IMessageSink* CreateMessageSink(
   String* url,
   Object* data,
   String** objectURI
) = 0;
[JScript]
function CreateMessageSink(
   url : String,
   data : Object,
   objectURI : String
) : IMessageSink;

Parameters

url
[To be supplied.]
data
The channel data object.
objectURI
[To be supplied.]

Return Value

TBD.

See Also

IChannelSender Interface | IChannelSender Members | System.Runtime.Remoting Namespace


IConstructionCallMessage Interface

[To be supplied.]

[Visual Basic]
Public Interface IConstructionCallMessage
   Implements IMethodCallMessage, IMethodMessage, IMessage
[C#]
public interface IConstructionCallMessage : IMethodCallMessage,
   IMethodMessage, IMessage
[C++]
public __gc __interface IConstructionCallMessage : public
   IMethodCallMessage, IMethodMessage, IMessage

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IConstructionCallMessage

Class | Description
ConstructionCall | [To be supplied.]

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.Remoting

Assembly: mscorlib.dll

See Also

IConstructionCallMessage Members | System.Runtime.Remoting Namespace


IConstructionCallMessage Members

Properties

CallSiteActivationAttributes | [To be supplied.]
ContextProperties | [To be supplied.]
ServerType | [To be supplied.]

See Also

IConstructionCallMessage Interface | System.Runtime.Remoting Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IConstructionCallMessage Properties

The properties of the IConstructionCallMessage interface are listed below. For a complete list of IConstructionCallMessage interface members, see the IConstructionCallMessage Members topic.

CallSiteActivationAttributes | [To be supplied.]
ContextProperties | [To be supplied.]
ServerType | [To be supplied.]

See Also

IConstructionCallMessage Interface | System.Runtime.Remoting Namespace


IConstructionCallMessage.CallSiteActivationAttributes

[To be supplied.]

[Visual Basic]
ReadOnly Property CallSiteActivationAttributes As Object ()
[C#]
object[] CallSiteActivationAttributes {get;}
[C++]
Object* get_CallSiteActivationAttributes() = 0;
[JScript]
abstract function get CallSiteActivationAttributes() : Object[];

See Also

IConstructionCallMessage Interface | IConstructionCallMessage Members | System.Runtime.Remoting Namespace


IConstructionCallMessage.ContextProperties

[To be supplied.]

[Visual Basic]
ReadOnly Property ContextProperties As IList
[C#]
IList ContextProperties {get;}
[C++]
IList* get_ContextProperties() = 0;
[JScript]
abstract function get ContextProperties() : IList;

See Also

IConstructionCallMessage Interface | IConstructionCallMessage Members | System.Runtime.Remoting Namespace


IConstructionCallMessage.ServerType

[To be supplied.]

[Visual Basic]
ReadOnly Property ServerType As Type
[C#]
Type ServerType {get;}
[C++]
Type* get_ServerType() = 0;
[JScript]
abstract function get ServerType() : Type;

See Also

IConstructionCallMessage Interface | IConstructionCallMessage Members | System.Runtime.Remoting Namespace


IConstructionReturnMessage Interface

[To be supplied.]

[Visual Basic]
Public Interface IConstructionReturnMessage
   Implements IMethodReturnMessage, IMethodMessage, IMessage
[C#]
public interface IConstructionReturnMessage : IMethodReturnMessage,
   IMethodMessage, IMessage
[C++]
public __gc __interface IConstructionReturnMessage : public
   IMethodReturnMessage, IMethodMessage, IMessage

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IConstructionReturnMessage

Class | Description
ConstructionResponse | [To be supplied.]

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.Remoting

Assembly: mscorlib.dll

See Also

IConstructionReturnMessage Members | System.Runtime.Remoting Namespace


IConstructionReturnMessage Members

See Also

IConstructionReturnMessage Interface | System.Runtime.Remoting Namespace


IContextAttribute Interface

Determines whether a particular context is OK for the context attribute and returns a context property for a new context.

IContextAttribute

[Visual Basic]
Public Interface IContextAttribute
[C#]
public interface IContextAttribute
[C++]
public __gc __interface IContextAttribute

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IContextAttribute

Class | Description
ContextAttribute | ContextAttribute is the root for all context attributes. ContextAttribute provides the default implementations of IContextAttribute and IContextProperty. Simple Context properties can derived from ContextAttribute with the context attribute and the context property being in the class. For more specialized or more sophisticated needs the context attribute still derives from ContextAttribute and context property can be split into a separated class.

Remarks

An IContextAttribute is exposed from all context attributes.

Requirements

Namespace: System.Runtime.Remoting

Assembly: mscorlib.dll

See Also

IContextAttribute Members | System.Runtime.Remoting Namespace


IContextAttribute Members

Methods

GetPropertiesForNewContext | Return context properties to the caller
IsContextOK | Returns a Boolean indicating whether the context parameter meets the context attribute's requirements.

See Also

IContextAttribute Interface | System.Runtime.Remoting Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IContextAttribute Methods

The methods of the IContextAttribute interface are listed below. For a complete list of IContextAttribute interface members, see the IContextAttribute Members topic.

GetPropertiesForNewContext | Return context properties to the caller
IsContextOK | Returns a Boolean indicating whether the context parameter meets the context attribute's requirements.

See Also

IContextAttribute Interface | System.Runtime.Remoting Namespace


IContextAttribute.GetPropertiesForNewContext

Return context properties to the caller

[Visual Basic]
Sub GetPropertiesForNewContext( _
   ByVal msg As IConstructionCallMessage _
)
[C#]
void GetPropertiesForNewContext(
   IConstructionCallMessage msg
);
[C++]
void GetPropertiesForNewContext(
   IConstructionCallMessage* msg
) = 0;
[JScript]
function GetPropertiesForNewContext(
   msg : IConstructionCallMessage
);

Parameters

msg
?

See Also

IContextAttribute Interface | IContextAttribute Members | System.Runtime.Remoting Namespace


IContextAttribute.IsContextOK

Returns a Boolean indicating whether the context parameter meets the context attribute's requirements.

[Visual Basic]
Function IsContextOK( _
   ByVal ctx As Context, _
   ByVal msg As IConstructionCallMessage _
) As Boolean
[C#]
bool IsContextOK(
   Context ctx,
   IConstructionCallMessage msg
);
[C++]
bool IsContextOK(
   Context* ctx,
   IConstructionCallMessage* msg
) = 0;
[JScript]
function IsContextOK(
   ctx : Context,
   msg : IConstructionCallMessage
) : Boolean;

Parameters

ctx
The context in which to check.
msg
[To be supplied.]

Return Value

true if the passed in context is OK; otherwise, false.

Remarks

The OUT cookie object can be used to return some specific information which is later passed to the GetPropertiesForNewContext method. It can be null.

See Also

IContextAttribute Interface | IContextAttribute Members | System.Runtime.Remoting Namespace


IContextProperty Interface

Gathers naming information from the context property and determines whether the new context is ok for the context property.

IContextProperty

[Visual Basic]
Public Interface IContextProperty
[C#]
public interface IContextProperty
[C++]
public __gc __interface IContextProperty

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IContextProperty

Class | Description
ContextAttribute | ContextAttribute is the root for all context attributes. ContextAttribute provides the default implementations of IContextAttribute and IContextProperty. Simple Context properties can derived from ContextAttribute with the context attribute and the context property being in the class. For more specialized or more sophisticated needs the context attribute still derives from ContextAttribute and context property can be split into a separated class.

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.Remoting

Assembly: mscorlib.dll

See Also

IContextProperty Members | System.Runtime.Remoting Namespace


IContextProperty Members

Properties

Name The name of the property

Methods

Freeze | Called when the context is frozen.
IsNewContextOK | Returns a Boolean indicating whether the context property is ok with the new context.

See Also

IContextProperty Interface | System.Runtime.Remoting Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IContextProperty Properties

The properties of the IContextProperty interface are listed below. For a complete list of IContextProperty interface members, see the IContextProperty Members topic.

Name The name of the property

See Also

IContextProperty Interface | System.Runtime.Remoting Namespace


IContextProperty.Name

The name of the property

[Visual Basic]
ReadOnly Property Name As String
[C#]
string Name {get;}
[C++]
String* get_Name() = 0;
[JScript]
abstract function get Name() : String;

See Also

IContextProperty Interface | IContextProperty Members | System.Runtime.Remoting Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IContextProperty Methods

The methods of the IContextProperty interface are listed below. For a complete list of IContextProperty interface members, see the IContextProperty Members topic.

Freeze | Called when the context is frozen.
IsNewContextOK | Returns a Boolean indicating whether the context property is ok with the new context.

See Also

IContextProperty Interface | System.Runtime.Remoting Namespace


IContextProperty.Freeze

Called when the context is frozen.

[Visual Basic]
Sub Freeze( _
   ByVal newContext As Context _
)
[C#]
void Freeze(
   Context newContext
);
[C++]
void Freeze(
   Context* newContext
) = 0;
[JScript]
function Freeze(
   newContext : Context
);

Parameters

newContext
Th context to freeze

See Also

IContextProperty Interface | IContextProperty Members | System.Runtime.Remoting Namespace


IContextProperty.IsNewContextOK

Returns a Boolean indicating whether the context property is ok with the new context.

[Visual Basic]
Function IsNewContextOK( _
   ByVal newCtx As Context _
) As Boolean
[C#]
bool IsNewContextOK(
   Context newCtx
);
[C++]
bool IsNewContextOK(
   Context* newCtx
) = 0;
[JScript]
function IsNewContextOK(
   newCtx : Context
) : Boolean;

Parameters

newCtx
The new Context in which the ContextProperty has been created.

Return Value

true if the context property is ok with the new context; otherwise, false.

Remarks

Once all the context properties have been added to the new context, they are all asked whether they are OK in the new context. The context property could look at the other context properties from the parameter new context and determine whether it is ok coexisting with these other context properties. Returns false if not ok in the context.

See Also

IContextProperty Interface | IContextProperty Members | System.Runtime.Remoting Namespace


IContextPropertyActivator Interface

IContextPropertyActivator

[Visual Basic]
Public Interface IContextPropertyActivator
[C#]
public interface IContextPropertyActivator
[C++]
public __gc __interface IContextPropertyActivator

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.Remoting

Assembly: mscorlib.dll

See Also

IContextPropertyActivator Members | System.Runtime.Remoting Namespace


IContextPropertyActivator Members

Methods

CollectFromClientContext |
CollectFromServerContext | Called on each server context property that has this interface, before the construction response leaves the server for the client. The context property can examine and manipulate the contents of the IConstructionReturnMessage.
DeliverClientContextToServerContext | Called on each server context property that has this interface, when the construction request arrives at the server from the client. The context property can examine the contents of the IConstructionCallMessage.
DeliverServerContextToClientContext | Called on each client context property that has this interface, when the construction request returns to the client from the server. The context property can examine the contents of the IConstructionReturnMessage.

See Also

IContextPropertyActivator Interface | System.Runtime.Remoting Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IContextPropertyActivator Methods

The methods of the IContextPropertyActivator interface are listed below. For a complete list of IContextPropertyActivator interface members, see the IContextPropertyActivator Members topic.

CollectFromClientContext |
CollectFromServerContext | Called on each server context property that has this interface, before the construction response leaves the server for the client. The context property can examine and manipulate the contents of the IConstructionReturnMessage.
DeliverClientContextToServerContext | Called on each server context property that has this interface, when the construction request arrives at the server from the client. The context property can examine the contents of the IConstructionCallMessage.
DeliverServerContextToClientContext | Called on each client context property that has this interface, when the construction request returns to the client from the server. The context property can examine the contents of the IConstructionReturnMessage.

See Also

IContextPropertyActivator Interface | System.Runtime.Remoting Namespace


IContextPropertyActivator.CollectFromClientContext

[Visual Basic]
Sub CollectFromClientContext( _
   ByVal msg As IConstructionCallMessage _
)
[C#]
void CollectFromClientContext(
   IConstructionCallMessage msg
);
[C++]
void CollectFromClientContext(
   IConstructionCallMessage* msg
) = 0;
[JScript]
function CollectFromClientContext(
   msg : IConstructionCallMessage
);

Parameters

msg
[To be supplied.]

See Also

IContextPropertyActivator Interface | IContextPropertyActivator Members | System.Runtime.Remoting Namespace


IContextPropertyActivator.CollectFromServerContext

Called on each server context property that has this interface, before the construction response leaves the server for the client. The context property can examine and manipulate the contents of the IConstructionReturnMessage.

[Visual Basic]
Sub CollectFromServerContext( _
   ByVal msg As IConstructionReturnMessage _
)
[C#]
void CollectFromServerContext(
   IConstructionReturnMessage msg
);
[C++]
void CollectFromServerContext(
   IConstructionReturnMessage* msg
) = 0;
[JScript]
function CollectFromServerContext(
   msg : IConstructionReturnMessage
);

Parameters

msg
[To be supplied.]

See Also

IContextPropertyActivator Interface | IContextPropertyActivator Members | System.Runtime.Remoting Namespace


IContextPropertyActivator.DeliverClientContextToServerContext

Called on each server context property that has this interface, when the construction request arrives at the server from the client. The context property can examine the contents of the IConstructionCallMessage.

[Visual Basic]
Function DeliverClientContextToServerContext( _
   ByVal msg As IConstructionCallMessage _
) As Boolean
[C#]
bool DeliverClientContextToServerContext(
   IConstructionCallMessage msg
);
[C++]
bool DeliverClientContextToServerContext(
   IConstructionCallMessage* msg
) = 0;
[JScript]
function DeliverClientContextToServerContext(
   msg : IConstructionCallMessage
) : Boolean;

Parameters

msg
[To be supplied.]

See Also

IContextPropertyActivator Interface | IContextPropertyActivator Members | System.Runtime.Remoting Namespace


IContextPropertyActivator.DeliverServerContextToClientContext

Called on each client context property that has this interface, when the construction request returns to the client from the server. The context property can examine the contents of the IConstructionReturnMessage.

[Visual Basic]
Function DeliverServerContextToClientContext( _
   ByVal msg As IConstructionReturnMessage _
) As Boolean
[C#]
bool DeliverServerContextToClientContext(
   IConstructionReturnMessage msg
);
[C++]
bool DeliverServerContextToClientContext(
   IConstructionReturnMessage* msg
) = 0;
[JScript]
function DeliverServerContextToClientContext(
   msg : IConstructionReturnMessage
) : Boolean;

Parameters

msg
[To be supplied.]

See Also

IContextPropertyActivator Interface | IContextPropertyActivator Members | System.Runtime.Remoting Namespace


IContributeClientContextSink Interface

Contributes an interception sink at the context boundary on the client end of a remoting call.

IContributeClientContextSink

[Visual Basic]
Public Interface IContributeClientContextSink
[C#]
public interface IContributeClientContextSink
[C++]
public __gc __interface IContributeClientContextSink

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IContributeClientContextSink

Class | Description
Synchronization | [To be supplied.]
ThreadAffinity Key Points:

Refinement of Synchronized Context

Mark type with Thread Affinity Context Attribute

Only a single thread allowed to execute within the Synchronization Domain, hence only that thread can access instance fields and methods

Useful:

User Interface objects

Objects that hold onto OS resource that should only be accessed on the thread that created them

The Thread Affinity Context Property provides a similar capability as the Synchronization Context property with the further constraint that only a single thread is allow to execute within the context or synchronization domain at any time. This is useful for objects that could hold onto OS resources that should only be accessed from a particular thread and only that thread. Thread Affinity is useful when users want to always access the object on the same thread. Certain UI resources should only be accessed on the same thread, on which they were created.

An instance of this property in a context enforces a thread affinity domain for the context (and all contexts that share the same instance). This means that for all contexts sharing an instance of this property, all methods on objects resident in those contexts will execute on the same thread for the lifetime of the objects.

This is done by contributing message sinks that intercept and serialize in-coming calls.

If the property is marked for reentrancy, then call-outs are intercepted too. The call-out interception allows other waiting calls to enter the thread affinity domain.

[ThreadAffinity()]

public class Foo: ContextBoundObject

{

. . .// implementation for Foo

}

// Make an instance of Foo

void SomeOtherMethod(void)

{

. . . Foo foo = new Foo();

}

Remarks

The IContributeClientContextSink interface is implemented by context properties in a Context.

The client context chain is composed from those properties in the client context that implement IContributeClientContextSink interface, which contributes to a sink via the GetClientContextSink method call. This chain is cached for future use.

Requirements

Namespace: System.Runtime.Remoting

Assembly: mscorlib.dll

See Also

IContributeClientContextSink Members | System.Runtime.Remoting Namespace


IContributeClientContextSink Members

Methods

GetClientContextSink Takes the first sink in the chain of sinks composed so far, chains its message sink in front of the chain formed.

See Also

IContributeClientContextSink Interface | System.Runtime.Remoting Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IContributeClientContextSink Methods

The methods of the IContributeClientContextSink interface are listed below. For a complete list of IContributeClientContextSink interface members, see the IContributeClientContextSink Members topic.

GetClientContextSink Takes the first sink in the chain of sinks composed so far, chains its message sink in front of the chain formed.

See Also

IContributeClientContextSink Interface | System.Runtime.Remoting Namespace


IContributeClientContextSink.GetClientContextSink

Takes the first sink in the chain of sinks composed so far, chains its message sink in front of the chain formed.

[Visual Basic]
Function GetClientContextSink( _
   ByVal nextSink As IMessageSink _
) As IMessageSink
[C#]
IMessageSink GetClientContextSink(
   IMessageSink nextSink
);
[C++]
IMessageSink* GetClientContextSink(
   IMessageSink* nextSink
) = 0;
[JScript]
function GetClientContextSink(
   nextSink : IMessageSink
) : IMessageSink;

Parameters

nextSink
The chain of sinks composed so far.

Return Value

The composite sink chain.

See Also

IContributeClientContextSink Interface | IContributeClientContextSink Members | System.Runtime.Remoting Namespace


IContributeDynamicSink Interface

The IContributeDynamicSink interface is implemented by properties that are registered at runtime through the RemotingServicesRegisterDynamicProperty API. These properties can contribute sinks that are notified when remoting calls start and finish.

IContributeDynamicSink

[Visual Basic]
Public Interface IContributeDynamicSink
[C#]
public interface IContributeDynamicSink
[C++]
public __gc __interface IContributeDynamicSink

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.Remoting

Assembly: mscorlib.dll

See Also

IContributeDynamicSink Members | System.Runtime.Remoting Namespace


IContributeDynamicSink Members

Methods

GetDynamicSink Returns the message sink that will be notified of call start and finish events through the IDynamicMessageSink interface.

See Also

IContributeDynamicSink Interface | System.Runtime.Remoting Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IContributeDynamicSink Methods

The methods of the IContributeDynamicSink interface are listed below. For a complete list of IContributeDynamicSink interface members, see the IContributeDynamicSink Members topic.

GetDynamicSink Returns the message sink that will be notified of call start and finish events through the IDynamicMessageSink interface.

See Also

IContributeDynamicSink Interface | System.Runtime.Remoting Namespace


IContributeDynamicSink.GetDynamicSink

Returns the message sink that will be notified of call start and finish events through the IDynamicMessageSink interface.

[Visual Basic]
Function GetDynamicSink() As IDynamicMessageSink
[C#]
IDynamicMessageSink GetDynamicSink();
[C++]
IDynamicMessageSink* GetDynamicSink() = 0;
[JScript]
function GetDynamicSink() : IDynamicMessageSink;

Return Value

The dynamic sink that exposes IDynamicMessageSink

See Also

IContributeDynamicSink Interface | IContributeDynamicSink Members | System.Runtime.Remoting Namespace


IContributeEnvoySink Interface

The IContributeEnvoySink interface is implemented by context properties in the Server Context that wish to contribute an envoy message sink on the client end. The Server Envoy Chain is composed from those context properties that implement IContributeEnvoySink interface. The Envoy Chain lives on the client end and acts as representative of the corresponding message sinks from the server context properties.

See also Context.

IContributeEnvoySink

[Visual Basic]
Public Interface IContributeEnvoySink
[C#]
public interface IContributeEnvoySink
[C++]
public __gc __interface IContributeEnvoySink

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.Remoting

Assembly: mscorlib.dll

See Also

IContributeEnvoySink Members | System.Runtime.Remoting Namespace


IContributeEnvoySink Members

Methods

GetEnvoySink Takes the first sink in the chain of sinks composed so far, chain its message sink in front of the chain formed.

See Also

IContributeEnvoySink Interface | System.Runtime.Remoting Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IContributeEnvoySink Methods

The methods of the IContributeEnvoySink interface are listed below. For a complete list of IContributeEnvoySink interface members, see the IContributeEnvoySink Members topic.

GetEnvoySink Takes the first sink in the chain of sinks composed so far, chain its message sink in front of the chain formed.

See Also

IContributeEnvoySink Interface | System.Runtime.Remoting Namespace


IContributeEnvoySink.GetEnvoySink

Takes the first sink in the chain of sinks composed so far, chain its message sink in front of the chain formed.

[Visual Basic]
Function GetEnvoySink( _
   ByVal obj As MarshalByRefObject, _
   ByVal nextSink As IMessageSink _
) As IMessageSink
[C#]
IMessageSink GetEnvoySink(
   MarshalByRefObject obj,
   IMessageSink nextSink
);
[C++]
IMessageSink* GetEnvoySink(
   MarshalByRefObject* obj,
   IMessageSink* nextSink
) = 0;
[JScript]
function GetEnvoySink(
   obj : MarshalByRefObject,
   nextSink : IMessageSink
) : IMessageSink;

Parameters

obj
The server object for which the chain is being created.
nextSink
The chain of sinks composed so far.

Return Value

The composite sink chain.

Remarks

Used as an optimization to create envoy sink when the destination is a different context in the same application domain and is used by the Wrap operation.

See Also

IContributeEnvoySink Interface | IContributeEnvoySink Members | System.Runtime.Remoting Namespace


IContributeObjectSink Interface

The IContributeObjectSink interface is implemented by context properties in a Context that wish to contribute an object specific interception sink on the server end of a remoting call.

The Server Object Chain is composed from those context properties in the server object's context that implement IContributeObjectSink interface. (Just-In-Time activation is an example of such a property, i.e. the message sink would activate the object after the call arrives and then pass the message on to the object.)

IContributeObjectSink

[Visual Basic]
Public Interface IContributeObjectSink
[C#]
public interface IContributeObjectSink
[C++]
public __gc __interface IContributeObjectSink

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.Remoting

Assembly: mscorlib.dll

See Also

IContributeObjectSink Members | System.Runtime.Remoting Namespace


IContributeObjectSink Members

Methods

GetObjectSink Takes the object and the first sink in the chain of sinks composed so far, chains its message sink in front of the chain formed.

See Also

IContributeObjectSink Interface | System.Runtime.Remoting Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IContributeObjectSink Methods

The methods of the IContributeObjectSink interface are listed below. For a complete list of IContributeObjectSink interface members, see the IContributeObjectSink Members topic.

GetObjectSink Takes the object and the first sink in the chain of sinks composed so far, chains its message sink in front of the chain formed.

See Also

IContributeObjectSink Interface | System.Runtime.Remoting Namespace


IContributeObjectSink.GetObjectSink

Takes the object and the first sink in the chain of sinks composed so far, chains its message sink in front of the chain formed.

[Visual Basic]
Function GetObjectSink( _
   ByVal obj As MarshalByRefObject, _
   ByVal nextSink As IMessageSink _
) As IMessageSink
[C#]
IMessageSink GetObjectSink(
   MarshalByRefObject obj,
   IMessageSink nextSink
);
[C++]
IMessageSink* GetObjectSink(
   MarshalByRefObject* obj,
   IMessageSink* nextSink
) = 0;
[JScript]
function GetObjectSink(
   obj : MarshalByRefObject,
   nextSink : IMessageSink
) : IMessageSink;

Parameters

obj
Object.
nextSink
The chain of sinks composed so far.

Return Value

Returns the composite sink chain.

See Also

IContributeObjectSink Interface | IContributeObjectSink Members | System.Runtime.Remoting Namespace


IContributeServerContextSink Interface

The IContributeServerContextSink interface is implemented by context properties in a Context that wish to contribute an interception sink at the context boundary on the server end of a remoting call.

The Server Context Chain is composed from those properties in the server context that implement IContributeServerContextSink interface and which contribute a sink via the GetServerContextSink method call. This chain is cached for future use. Thread Affinity could be an example of such a context property i.e. in this case the MessageSink would involve switching to a specific thread before processing a call further.

IContributeServerContextSink

[Visual Basic]
Public Interface IContributeServerContextSink
[C#]
public interface IContributeServerContextSink
[C++]
public __gc __interface IContributeServerContextSink

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement IContributeServerContextSink

Class | Description
Synchronization | [To be supplied.]
ThreadAffinity Key Points:

Refinement of Synchronized Context

Mark type with Thread Affinity Context Attribute

Only a single thread allowed to execute within the Synchronization Domain, hence only that thread can access instance fields and methods

Useful:

User Interface objects

Objects that hold onto OS resource that should only be accessed on the thread that created them

The Thread Affinity Context Property provides a similar capability as the Synchronization Context property with the further constraint that only a single thread is allow to execute within the context or synchronization domain at any time. This is useful for objects that could hold onto OS resources that should only be accessed from a particular thread and only that thread. Thread Affinity is useful when users want to always access the object on the same thread. Certain UI resources should only be accessed on the same thread, on which they were created.

An instance of this property in a context enforces a thread affinity domain for the context (and all contexts that share the same instance). This means that for all contexts sharing an instance of this property, all methods on objects resident in those contexts will execute on the same thread for the lifetime of the objects.

This is done by contributing message sinks that intercept and serialize in-coming calls.

If the property is marked for reentrancy, then call-outs are intercepted too. The call-out interception allows other waiting calls to enter the thread affinity domain.

[ThreadAffinity()]

public class Foo: ContextBoundObject

{

. . .// implementation for Foo

}

// Make an instance of Foo

void SomeOtherMethod(void)

{

. . . Foo foo = new Foo();

}

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.Remoting

Assembly: mscorlib.dll

See Also

IContributeServerContextSink Members | System.Runtime.Remoting Namespace


IContributeServerContextSink Members

Methods

GetServerContextSink Takes the first sink in the chain of sinks composed so far, chains its message sink in front of the chain formed.

See Also

IContributeServerContextSink Interface | System.Runtime.Remoting Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IContributeServerContextSink Methods

The methods of the IContributeServerContextSink interface are listed below. For a complete list of IContributeServerContextSink interface members, see the IContributeServerContextSink Members topic.

GetServerContextSink Takes the first sink in the chain of sinks composed so far, chains its message sink in front of the chain formed.

See Also

IContributeServerContextSink Interface | System.Runtime.Remoting Namespace


IContributeServerContextSink.GetServerContextSink

Takes the first sink in the chain of sinks composed so far, chains its message sink in front of the chain formed.

[Visual Basic]
Function GetServerContextSink( _
   ByVal nextSink As IMessageSink _
) As IMessageSink
[C#]
IMessageSink GetServerContextSink(
   IMessageSink nextSink
);
[C++]
IMessageSink* GetServerContextSink(
   IMessageSink* nextSink
) = 0;
[JScript]
function GetServerContextSink(
   nextSink : IMessageSink
) : IMessageSink;

Parameters

nextSink
The chain of sinks composed so far.

Return Value

Returns the composite sink chain.

Remarks

[To be supplied.

See Also

IContributeServerContextSink Interface | IContributeServerContextSink Members | System.Runtime.Remoting Namespace


IDynamicMessageSink Interface

IDynamicMessageSink is implemented by message sinks provided by dynamically registered properties. These sinks are provided notifications of call-start and call-finish with flags indicating whether the call is currently on the client-side or server-side (this is useful for the context level sinks).

IDynamicMessageSink

[Visual Basic]
Public Interface IDynamicMessageSink
[C#]
public interface IDynamicMessageSink
[C++]
public __gc __interface IDynamicMessageSink

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.Remoting

Assembly: mscorlib.dll

See Also

IDynamicMessageSink Members | System.Runtime.Remoting Namespace


IDynamicMessageSink Members

Methods

ProcessMessageFinish | Indicates that a call is returning. The Booleans tell whether we are on the client side or the server side and whether the call is using AsyncProcessMessage.
ProcessMessageStart | Indicates that a call is starting. The Booleans tell whether we are on the client side or the server side and whether the call is using AsyncProcessMessage.

See Also

IDynamicMessageSink Interface | System.Runtime.Remoting Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDynamicMessageSink Methods

The methods of the IDynamicMessageSink interface are listed below. For a complete list of IDynamicMessageSink interface members, see the IDynamicMessageSink Members topic.

ProcessMessageFinish | Indicates that a call is returning. The Booleans tell whether we are on the client side or the server side and whether the call is using AsyncProcessMessage.
ProcessMessageStart | Indicates that a call is starting. The Booleans tell whether we are on the client side or the server side and whether the call is using AsyncProcessMessage.

See Also

IDynamicMessageSink Interface | System.Runtime.Remoting Namespace


IDynamicMessageSink.ProcessMessageFinish

Indicates that a call is returning. The Booleans tell whether we are on the client side or the server side and whether the call is using AsyncProcessMessage.

[Visual Basic]
Sub ProcessMessageFinish( _
   ByVal replyMsg As IMessage, _
   ByVal bCliSide As Boolean, _
   ByVal bAsync As Boolean _
)
[C#]
void ProcessMessageFinish(
   IMessage replyMsg,
   bool bCliSide,
   bool bAsync
);
[C++]
void ProcessMessageFinish(
   IMessage* replyMsg,
   bool bCliSide,
   bool bAsync
) = 0;
[JScript]
function ProcessMessageFinish(
   replyMsg : IMessage,
   bCliSide : Boolean,
   bAsync : Boolean
);

Parameters

replyMsg
Reply Message.
bCliSide
True if client side.
bAsync
True if async call.

See Also

IDynamicMessageSink Interface | IDynamicMessageSink Members | System.Runtime.Remoting Namespace


IDynamicMessageSink.ProcessMessageStart

Indicates that a call is starting. The Booleans tell whether we are on the client side or the server side and whether the call is using AsyncProcessMessage.

[Visual Basic]
Sub ProcessMessageStart( _
   ByVal reqMsg As IMessage, _
   ByVal bCliSide As Boolean, _
   ByVal bAsync As Boolean _
)
[C#]
void ProcessMessageStart(
   IMessage reqMsg,
   bool bCliSide,
   bool bAsync
);
[C++]
void ProcessMessageStart(
   IMessage* reqMsg,
   bool bCliSide,
   bool bAsync
) = 0;
[JScript]
function ProcessMessageStart(
   reqMsg : IMessage,
   bCliSide : Boolean,
   bAsync : Boolean
);

Parameters

reqMsg
Request Message.
bCliSide
True if client side.
bAsync
True if async call.

See Also

IDynamicMessageSink Interface | IDynamicMessageSink Members | System.Runtime.Remoting Namespace


IDynamicProperty Interface

??????????????????????????????????????

IDynamicProperty

[Visual Basic]
Public Interface IDynamicProperty
[C#]
public interface IDynamicProperty
[C++]
public __gc __interface IDynamicProperty

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.Remoting

Assembly: mscorlib.dll

See Also

IDynamicProperty Members | System.Runtime.Remoting Namespace


IDynamicProperty Members

Properties

Name ?????????????????????????????????

See Also

IDynamicProperty Interface | System.Runtime.Remoting Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IDynamicProperty Properties

The properties of the IDynamicProperty interface are listed below. For a complete list of IDynamicProperty interface members, see the IDynamicProperty Members topic.

Name ?????????????????????????????????

See Also

IDynamicProperty Interface | System.Runtime.Remoting Namespace


IDynamicProperty.Name

?????????????????????????????????

[Visual Basic]
ReadOnly Property Name As String
[C#]
string Name {get;}
[C++]
String* get_Name() = 0;
[JScript]
abstract function get Name() : String;

See Also

IDynamicProperty Interface | IDynamicProperty Members | System.Runtime.Remoting Namespace


IEnvoyInfo Interface

Provides envoy information. Users can use this interface to provide custom envoy information that is carried along with the ObjRef.

IEnvoyInfo

[Visual Basic]
Public Interface IEnvoyInfo
[C#]
public interface IEnvoyInfo
[C++]
public __gc __interface IEnvoyInfo

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.Remoting

Assembly: mscorlib.dll

See Also

IEnvoyInfo Members | System.Runtime.Remoting Namespace


IEnvoyInfo Members

Properties

EnvoySinks This read-write property gets and sets the envoy sinks. The list of envoys that were contributed by the ServerContext and ServerObject chains when the System.Runtime.Remoting.Object was marshaled.

See Also

IEnvoyInfo Interface | System.Runtime.Remoting Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

IEnvoyInfo Properties

The properties of the IEnvoyInfo interface are listed below. For a complete list of IEnvoyInfo interface members, see the IEnvoyInfo Members topic.

EnvoySinks This read-write property gets and sets the envoy sinks. The list of envoys that were contributed by the ServerContext and ServerObject chains when the System.Runtime.Remoting.Object was marshaled.

See Also

IEnvoyInfo Interface | System.Runtime.Remoting Namespace


IEnvoyInfo.EnvoySinks

This read-write property gets and sets the envoy sinks. The list of envoys that were contributed by the ServerContext and ServerObject chains when the System.Runtime.Remoting.Object was marshaled.

[Visual Basic]
Property EnvoySinks As IMessageSink
[C#]
IMessageSink EnvoySinks {get; set;}
[C++]
IMessageSink* get_EnvoySinks() = 0;void set_EnvoySinks(IMessageSink*) = 0;
[JScript]
abstract function get EnvoySinks() : IMessageSink;
public abstract function set EnvoySinks(IMessageSink);

Property Value

Read-write.

[To be supplied.]

See Also

IEnvoyInfo Interface | IEnvoyInfo Members | System.Runtime.Remoting Namespace


ILease Interface

Distributed Garbage Collection (DGC) controls when server applications can be deleted. Traditionally DGC uses reference counts and pinging for control. This works well when there are a few clients per service, but doesn't scale well when there are thousands of clients per service. A Leasing Distributed Garbage Collector (LDGC) associates a lease time with each service. The service is deleted when the lease's time expires. The LDGC can subsume the function of a traditional DGC, in addition it scales well when the numbers of clients increase per server.

ILease

[Visual Basic]
Public Interface ILease
[C#]
public interface ILease
[C++]
public __gc __interface ILease

[JScript] In JScript, you can use the interfaces in the NGWS frameworks, but you cannot define your own.

Classes that Implement ILease

Class | Description
Lease |

Remarks

[To be supplied.]

Requirements

Namespace: System.Runtime.Remoting

Assembly: mscorlib.dll

See Also

ILease Members | System.Runtime.Remoting Namespace


ILease Members

Properties

CurrentLeaseTime | The amount of time remaining on the lease.
CurrentState | The current state of the lease.
InitialLeaseTime |
RenewOnCallTime |
SponsorshipTimeout |

Methods

Register | Overloaded. [To be supplied.]
Renew |
UnRegister | Remove the sponsor from the sponsor list. The lease state changes to expired and the obejct will be collected by the GC

See Also

ILease Interface | System.Runtime.Remoting Namespace


Properties

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ILease Properties

The properties of the ILease interface are listed below. For a complete list of ILease interface members, see the ILease Members topic.

CurrentLeaseTime | The amount of time remaining on the lease.
CurrentState | The current state of the lease.
InitialLeaseTime |
RenewOnCallTime |
SponsorshipTimeout |

See Also

ILease Interface | System.Runtime.Remoting Namespace


ILease.CurrentLeaseTime

The amount of time remaining on the lease.

[Visual Basic]
ReadOnly Property CurrentLeaseTime As TimeSpan
[C#]
TimeSpan CurrentLeaseTime {get;}
[C++]
TimeSpan get_CurrentLeaseTime() = 0;
[JScript]
abstract function get CurrentLeaseTime() : TimeSpan;

See Also

ILease Interface | ILease Members | System.Runtime.Remoting Namespace


ILease.CurrentState

The current state of the lease.

[Visual Basic]
ReadOnly Property CurrentState As LeaseState
[C#]
LeaseState CurrentState {get;}
[C++]
LeaseState get_CurrentState() = 0;
[JScript]
abstract function get CurrentState() : LeaseState;

Remarks

The different lease states are

Null:= The lease is not initialized.

Initial:=

Active:=

Renewing:=

Expired:=

See Also

ILease Interface | ILease Members | System.Runtime.Remoting Namespace


ILease.InitialLeaseTime

[Visual Basic]
Property InitialLeaseTime As TimeSpan
[C#]
TimeSpan InitialLeaseTime {get; set;}
[C++]
TimeSpan get_InitialLeaseTime() = 0;void set_InitialLeaseTime(TimeSpan) = 0;
[JScript]
abstract function get InitialLeaseTime() : TimeSpan;
public abstract function set InitialLeaseTime(TimeSpan);

See Also

ILease Interface | ILease Members | System.Runtime.Remoting Namespace


ILease.RenewOnCallTime

[Visual Basic]
Property RenewOnCallTime As TimeSpan
[C#]
TimeSpan RenewOnCallTime {get; set;}
[C++]
TimeSpan get_RenewOnCallTime() = 0;void set_RenewOnCallTime(TimeSpan) = 0;
[JScript]
abstract function get RenewOnCallTime() : TimeSpan;
public abstract function set RenewOnCallTime(TimeSpan);

See Also

ILease Interface | ILease Members | System.Runtime.Remoting Namespace


ILease.SponsorshipTimeout

[Visual Basic]
Property SponsorshipTimeout As TimeSpan
[C#]
TimeSpan SponsorshipTimeout {get; set;}
[C++]
TimeSpan get_SponsorshipTimeout() = 0;void set_SponsorshipTimeout(TimeSpan) = 0;
[JScript]
abstract function get SponsorshipTimeout() : TimeSpan;
public abstract function set SponsorshipTimeout(TimeSpan);

See Also

ILease Interface | ILease Members | System.Runtime.Remoting Namespace


Methods

NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

ILease Methods

The methods of the ILease interface are listed below. For a complete list of ILease interface members, see the ILease Members topic.

Register | Overloaded. [To be supplied.]
Renew |
UnRegister | Remove the sponsor from the sponsor list. The lease state changes to expired and the obejct will be collected by the GC

See Also

ILease Interface | System.Runtime.Remoting Namespace


ILease.Register

[To be supplied.]

Overload List

[Visual Basic] Overloads Sub Register(ISponsor)
[C#] void Register(ISponsor);
[C++] void Register(ISponsor*) = 0;
[JScript] function Register(ISponsor);
[Visual Basic] Overloads Sub Register(ISponsor, TimeSpan)
[C#] void Register(ISponsor, TimeSpan);
[C++] void Register(ISponsor*, TimeSpan) = 0;
[JScript] function Register(ISponsor, TimeSpan);

See Also

ILease Interface | ILease Members | System.Runtime.Remoting Namespace


ILease.Register (ISponsor)

[Visual Basic]
Overloads Sub Register( _
   ByVal obj As ISponsor _
)
[C#]
void Register(
   ISponsor obj
);
[C++]
void Register(
   ISponsor* obj
) = 0;
[JScript]
function Register(
   obj : ISponsor
);

Parameters

obj
The callback object of the sponsor

See Also

ILease Interface | ILease Members | System.Runtime.Remoting Namespace | ILease.Register Overload List


ILease.Register (ISponsor, TimeSpan)

[Visual Basic]
Overloads Sub Register( _
   ByVal obj As ISponsor, _
   ByVal renewalTime As TimeSpan _
)
[C#]
void Register(
   ISponsor obj,
   TimeSpan renewalTime
);
[C++]
void Register(
   ISponsor* obj,
   TimeSpan renewalTime
) = 0;
[JScript]
function Register(
   obj : ISponsor,
   renewalTime : TimeSpan
);

Parameters

obj
[To be supplied.]
renewalTime
Renew the lease by this amount whenever a method is called on the remote object

See Also

ILease Interface | ILease Members | System.Runtime.Remoting Namespace | ILease.Register Overload List


ILease.Renew

[Visual Basic]
Function Renew( _
   ByVal renewalTime As TimeSpan _
) As TimeSpan
[C#]
TimeSpan Renew(
   TimeSpan renewalTime
);
[C++]
TimeSpan Renew(
   TimeSpan renewalTime
) = 0;
[JScript]
function Renew(
   renewalTime : TimeSpan
) : TimeSpan;

Parameters

renewalTime
Length of time to renew the lease by

Return Value

The leases expiration time is returned to the caller

See Also

ILease Interface | ILease Members | System.Runtime.Remoting Namespace